GSF Namespace

Grid Solutions Framework Documentation
Grid Solutions Framework GSF Namespace
Contains fundamental classes that define commonly-used value and reference data types, interfaces, and basic type extension functions.
Classes
 | Class | Description
Public class | ArrayExtensions | Defines extension functions related to Array manipulation.
Public class | BigBinaryValue | Represents a big-endian ordered binary data sample stored as a byte array, but implicitly castable to most common native types.
Public class | BigEndian | Defines a set of big-endian byte order interoperability functions.
Public class | BigEndianOrder | Represents a big-endian byte order interoperability class.
Public class | BinaryCodedDecimal | Defines functions related to binary-coded decimals.
Public class | BinaryValueBaseTEndianOrder | Represents the base class for a binary data sample stored as a byte array, but implicitly castable to most common native types.
Public class | BitExtensions | Defines extension methods related to bit operations.
Public class | BitwiseCast | Defines specialized bitwise integer data type conversion functions
Public class | BufferPool | Obsolete. Represents a common buffer pool that can be used by an application.
Public class | ByteEncoding | Defines a set of methods used to convert byte buffers to and from user presentable data formats.
Public class | ByteEncodingASCIIEncoding | Handles conversion of byte buffers to and from a ASCII data format.
Public class | ByteEncodingBase64Encoding | Handles conversion of byte buffers to and from a base64 data format.
Public class | ByteEncodingBinaryEncoding | Handles conversion of byte buffers to and from a binary (i.e., 0 and 1's) data format.
Public class | ByteEncodingDecimalEncoding | Handles conversion of byte buffers to and from a decimal data format.
Public class | ByteEncodingHexadecimalEncoding | Handles conversion of byte buffers to and from a hexadecimal data format.
Public class | CharExtensions | Defines extension functions related to character manipulation.
Public class | Common | Defines common global functions.
Public class | CompoundValueT | Represents a collection of individual values that together represent a compound value once all the values have been assigned.
Public class | DateTimeExtensions | Defines extension functions related to Date/Time manipulation.
Public class | EndianOrder | Represents an endian byte order interoperability class.
Public class | EnumExtensions | Defines extension methods related to enumerations.
Public class | EventArgsT | Represents a generic event arguments class with one data argument.
Public class | EventArgsT1, T2 | Represents a generic event arguments class with two data arguments.
Public class | EventArgsT1, T2, T3 | Represents a generic event arguments class with three data arguments.
Public class | EventArgsT1, T2, T3, T4 | Represents a generic event arguments class with three data arguments.
Public class | FastObjectFactory | Quickly creates new objects based on specified type.
Public class | FastObjectFactoryT | Quickly creates new objects based on specified type.
Public class | GuidExtensions | Extension methods for Guid.
Public class | IdentifiableItemTId, TItem | Represents an identifiable item.
Public class | InitializationException | The exception that is thrown when an object fails to initialize properly.
Public class | LittleBinaryValue | Represents a little-endian ordered binary data sample stored as a byte array, but implicitly castable to most common native types.
Public class | LittleEndian | Defines a set of little-endian byte order interoperability functions.
Public class | LittleEndianOrder | Represents a little-endian byte order interoperability class.
Public class | NativeBinaryValue | Represents a binary data sample stored as a byte array ordered in the endianness of the OS, but implicitly castable to most common native types.
Public class | NativeEndianOrder | Represents a native-endian byte order interoperability class.
Public class | NtpTimeTag | Represents a standard Network Time Protocol (NTP) timetag.
Public class | NumericExtensions | Defines extension functions related to numbers.
Public class | ObjectStateTState | A serializable class that can be used to track the current and previous state of an object.
Public class | PrecisionTimer | Represents a high-resolution timer and timestamp class.
Public class | ProcessProgressTUnit | Represents current process progress for an operation.
Public class | ProcessProgressHandlerTUnit | Defines a delegate handler for a ProcessProgressTUnit instance.
Public class | RangeT | Represents a range of values with a start and end value.
Public class | ReusableObjectPool | Obsolete. Represents a reusable object pool that can be used by an application.
Public class | ReusableObjectPoolT | Obsolete. Represents a reusable object pool that can be used by an application.
Public class | Serialization | Common serialization related functions.
Public class | StringExtensions | Defines extension functions related to string manipulation.
Public class | TimerStartException | Represents an exception that is thrown when a PrecisionTimer fails to start.
Public class | TimeSpanExtensions | Extends the TimeSpan Class
Public class | TimeTagBase | Represents the base class for alternate timetag implementations.
Public class | TransformEqualityComparerT | Equality comparer that compares objects by the results of a transformation.
Public class | TypeExtensions | Extensions to all Type objects.
Public class | UnixTimeTag | Represents a standard Unix timetag.
Public class | USTimeZones | Defines a few common United States time zones.
Public class | Word | Represents functions and extensions related to 16-bit words, 32-bit double-words and 64-bit quad-words.
Structures
 | Structure | Description
Public structure | ComplexNumber | Represents a complex number.
Public structure | Int24 | Represents a 3-byte, 24-bit signed integer.
Public structure | Ticks | Represents an instant in time, or time period, as a 64-bit signed integer with a value that is expressed as the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
Public structure | TimerCapabilities | Represents information about the system's multimedia timer capabilities.
Public structure | UInt24 | Represents a 3-byte, 24-bit unsigned integer.
Interfaces
 | Interface | Description
Public interface | IProvideStatus | Defines an interface for any object to allow it to provide a name and status that can be displayed for informational purposes.
Public interface | ISupportLifecycle | Specifies that this object provides support for performing tasks during the key stages of object lifecycle.
Enumerations
 | Enumeration | Description
Public enumeration | ApplicationType | Specifies the type of the application.
Public enumeration | BaselineTimeInterval | Time intervals enumeration used by BaselinedTimestamp(BaselineTimeInterval) method.
Public enumeration | Bits | Represents bits in a signed or unsigned integer value.
Public enumeration | Endianness | Endian Byte Order Enumeration.
Public enumeration | SerializationFormat | Indicates the format of Object serialization or deserialization.
Public enumeration | UpdateType | Indicates the type of update.
See Grid Solutions Framework Project for latest code.

Copyright © 2015, Grid Protection Alliance. All Rights Reserved.

Send comments on this topic to GPA Development


ApplicationType Enumeration

Grid Solutions Framework ApplicationType Enumeration
Specifies the type of the application.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ApplicationType
Public Enumeration ApplicationType
type ApplicationType
GSF.ApplicationType = function();
GSF.ApplicationType.createEnum('GSF.ApplicationType', false);
public enum class ApplicationType
Members
Member name | Value | Description
Unknown | 0 | Application is of unknown type.
Native | 1 | Application doesn't require a subsystem.
WindowsGui | 2 | Application runs in the Windows GUI subsystem.
WindowsCui | 3 | Application runs in the Windows character subsystem.
OS2Cui | 5 | Application runs in the OS/2 character subsystem.
PosixCui | 7 | Application runs in the POSIX character subsystem.
NativeWindows | 8 | Application is a native Win9x driver.
WindowsCEGui | 9 | Application runs in the Windows CE subsystem.
Web | 100 | The application is a web site or web application.
See Also

Reference

GSF Namespace


ArrayExtensions Class

Grid Solutions Framework ArrayExtensions Class
Defines extension functions related to Array manipulation.
Inheritance Hierarchy
SystemObject
GSFArrayExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ArrayExtensions
<ExtensionAttribute>
Public NotInheritable Class ArrayExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ArrayExtensions =  class end
GSF.ArrayExtensions = function();

Type.createClass(
    'GSF.ArrayExtensions');
[ExtensionAttribute]
public ref class ArrayExtensions abstract sealed

The ArrayExtensions type exposes the following members.

Methods
Name | Description
BlockCopyT | Returns a copy of the specified portion of the array array.
Combine(Byte) | Combines an array of buffers together as a single image.
Combine(Byte, Byte, Byte) | Combines buffers together as a single image.
Combine(Byte, Byte, Byte, Byte) | Combines buffers together as a single image.
Combine(Byte, Byte, Byte, Byte, Byte) | Combines buffers together as a single image.
CombineT(T) | Combines array of arrays together into a single array.
CombineT(T, T) | Combines arrays together into a single array.
CombineT(T, T, T) | Combines arrays together into a single array.
CombineT(T, T, T, T) | Combines arrays together into a single array.
CombineT(T, T, T, T, T) | Combines arrays together into a single array.
CombineT(T, Int32, Int32, T, Int32, Int32) | Combines specified portions of arrays together into a single array.
CompareToT(T, T) | Returns comparison results of two binary arrays.
CompareToT(T, Int32, T, Int32, Int32) | Returns comparison results of two binary arrays.
IndexOfSequenceT(T, T) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the array.
IndexOfSequenceT(T, T, Int32) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index.
IndexOfSequenceT(T, T, Int32, Int32) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index and contains the specified number of elements.
ReadStructureT(Byte) | Reads a structure from a byte array.
ReadStructureT(BinaryReader) | Reads a structure from a BinaryReader.
ValidateParametersT | Validates that the specified startIndex and length are valid within the given array.
Top
See Also

Reference

GSF Namespace


ArrayExtensions Methods

Grid Solutions Framework ArrayExtensions Methods

The ArrayExtensions type exposes the following members.

Methods
Name | Description
BlockCopyT | Returns a copy of the specified portion of the array array.
Combine(Byte) | Combines an array of buffers together as a single image.
Combine(Byte, Byte, Byte) | Combines buffers together as a single image.
Combine(Byte, Byte, Byte, Byte) | Combines buffers together as a single image.
Combine(Byte, Byte, Byte, Byte, Byte) | Combines buffers together as a single image.
CombineT(T) | Combines array of arrays together into a single array.
CombineT(T, T) | Combines arrays together into a single array.
CombineT(T, T, T) | Combines arrays together into a single array.
CombineT(T, T, T, T) | Combines arrays together into a single array.
CombineT(T, T, T, T, T) | Combines arrays together into a single array.
CombineT(T, Int32, Int32, T, Int32, Int32) | Combines specified portions of arrays together into a single array.
CompareToT(T, T) | Returns comparison results of two binary arrays.
CompareToT(T, Int32, T, Int32, Int32) | Returns comparison results of two binary arrays.
IndexOfSequenceT(T, T) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the array.
IndexOfSequenceT(T, T, Int32) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index.
IndexOfSequenceT(T, T, Int32, Int32) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index and contains the specified number of elements.
ReadStructureT(Byte) | Reads a structure from a byte array.
ReadStructureT(BinaryReader) | Reads a structure from a BinaryReader.
ValidateParametersT | Validates that the specified startIndex and length are valid within the given array.
Top
See Also

Reference

ArrayExtensions Class
GSF Namespace


ArrayExtensions.BlockCopy(T) Method

Grid Solutions Framework ArrayExtensionsBlockCopyT Method
Returns a copy of the specified portion of the array array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] BlockCopy<T>(
    this T[] array,
    int startIndex,
    int length
)

<ExtensionAttribute>
Public Shared Function BlockCopy(Of T) (
    array As T(),
    startIndex As Integer,
    length As Integer
) As T()
static member BlockCopy :
        array : 'T[] *
        startIndex : int *
        length : int -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ BlockCopy(
    array<T>^ array,
    int startIndex,
    int length
)

Parameters

array
Type: T
Source array.
startIndex
Type: SystemInt32
Offset into array array.
length
Type: SystemInt32
Length of array array to copy at startIndex offset.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.BlockCopy``1(``0[],System.Int32,System.Int32)"]

Return Value

Type: T
A array of data copied from the specified portion of the source array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the source array -or- length is less than 0.
Remarks

Returned array will be extended as needed to make it the specified length, but it will never be less than the source array length - startIndex.

This is a convenience function. If an existing array is already available, using the BlockCopy(Array, Int32, Array, Int32, Int32) directly instead of this extension method will be optimal since this method always allocates a new return array.

See Also

Reference

ArrayExtensions Class
GSF Namespace


ArrayExtensions.Combine Method

Grid Solutions Framework ArrayExtensionsCombine Method
Overload List
Name | Description
Combine(Byte) | Combines an array of buffers together as a single image.
CombineT(T) | Combines array of arrays together into a single array.
CombineT(T, T) | Combines arrays together into a single array.
Combine(Byte, Byte, Byte) | Combines buffers together as a single image.
CombineT(T, T, T) | Combines arrays together into a single array.
Combine(Byte, Byte, Byte, Byte) | Combines buffers together as a single image.
CombineT(T, T, T, T) | Combines arrays together into a single array.
Combine(Byte, Byte, Byte, Byte, Byte) | Combines buffers together as a single image.
CombineT(T, T, T, T, T) | Combines arrays together into a single array.
CombineT(T, Int32, Int32, T, Int32, Int32) | Combines specified portions of arrays together into a single array.
Top
See Also

Reference

ArrayExtensions Class
GSF Namespace


ArrayExtensions.Combine Method (Byte[][])

Grid Solutions Framework ArrayExtensionsCombine Method (Byte)
Combines an array of buffers together as a single image.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Combine(
    this byte[][] buffers
)
<ExtensionAttribute>
Public Shared Function Combine (
    buffers As Byte()()
) As Byte()
static member Combine :
        buffers : byte[][] -> byte[]

GSF.ArrayExtensions.Combine = function(buffers);
public:
[ExtensionAttribute]
static array<unsigned char>^ Combine(
    array<array<unsigned char>^>^ buffers
)

Parameters

buffers
Type: SystemByte
Array of byte buffers.

Return Value

Type: Byte
Combined buffers.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | Cannot create a byte array with more than 2,147,483,591 elements.
Remarks
Only use this function if you need a copy of the combined buffers, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined buffers.
See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine(T) Method (T[][])

Grid Solutions Framework ArrayExtensionsCombineT Method (T)
Combines array of arrays together into a single array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] Combine<T>(
    this T[][] arrays
)

<ExtensionAttribute>
Public Shared Function Combine(Of T) (
    arrays As T()()
) As T()
static member Combine :
        arrays : 'T[][] -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ Combine(
    array<array<T>^>^ arrays
)

Parameters

arrays
Type: T
Array of arrays to combine.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.Combine``1(``0[][])"]

Return Value

Type: T
Combined arrays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Only use this function if you need a copy of the combined arrays, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined arrays.

This function can easily throw an out of memory exception if there is not enough contiguous memory to create an array sized with the combined lengths.

See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine(T) Method (T[], T[])

Grid Solutions Framework ArrayExtensionsCombineT Method (T, T)
Combines arrays together into a single array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] Combine<T>(
    this T[] source,
    T[] other
)

<ExtensionAttribute>
Public Shared Function Combine(Of T) (
    source As T(),
    other As T()
) As T()
static member Combine :
        source : 'T[] *
        other : 'T[] -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ Combine(
    array<T>^ source,
    array<T>^ other
)

Parameters

source
Type: T
Source array.
other
Type: T
Other array to combine to source array.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.Combine``1(``0[],``0[])"]

Return Value

Type: T
Combined arrays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Only use this function if you need a copy of the combined arrays, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined arrays.

This function can easily throw an out of memory exception if there is not enough contiguous memory to create an array sized with the combined lengths.

See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine Method (Byte[], Byte[], Byte[])

Grid Solutions Framework ArrayExtensionsCombine Method (Byte, Byte, Byte)
Combines buffers together as a single image.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Combine(
    this byte[] source,
    byte[] other1,
    byte[] other2
)
<ExtensionAttribute>
Public Shared Function Combine (
    source As Byte(),
    other1 As Byte(),
    other2 As Byte()
) As Byte()
static member Combine :
        source : byte[] *
        other1 : byte[] *
        other2 : byte[] -> byte[]

GSF.ArrayExtensions.Combine = function(source, other1, other2);
public:
[ExtensionAttribute]
static array<unsigned char>^ Combine(
    array<unsigned char>^ source,
    array<unsigned char>^ other1,
    array<unsigned char>^ other2
)

Parameters

source
Type: SystemByte
Source buffer.
other1
Type: SystemByte
First buffer to combine to source buffer.
other2
Type: SystemByte
Second buffer to combine to source buffer.

Return Value

Type: Byte
Combined buffers.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | Cannot create a byte array with more than 2,147,483,591 elements.
Remarks
Only use this function if you need a copy of the combined buffers, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined buffers.
See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine(T) Method (T[], T[], T[])

Grid Solutions Framework ArrayExtensionsCombineT Method (T, T, T)
Combines arrays together into a single array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] Combine<T>(
    this T[] source,
    T[] other1,
    T[] other2
)

<ExtensionAttribute>
Public Shared Function Combine(Of T) (
    source As T(),
    other1 As T(),
    other2 As T()
) As T()
static member Combine :
        source : 'T[] *
        other1 : 'T[] *
        other2 : 'T[] -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ Combine(
    array<T>^ source,
    array<T>^ other1,
    array<T>^ other2
)

Parameters

source
Type: T
Source array.
other1
Type: T
First array to combine to source array.
other2
Type: T
Second array to combine to source array.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.Combine``1(``0[],``0[],``0[])"]

Return Value

Type: T
Combined arrays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Only use this function if you need a copy of the combined arrays, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined arrays.

This function can easily throw an out of memory exception if there is not enough contiguous memory to create an array sized with the combined lengths.

See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine Method (Byte[], Byte[], Byte[], Byte[])

Grid Solutions Framework ArrayExtensionsCombine Method (Byte, Byte, Byte, Byte)
Combines buffers together as a single image.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Combine(
    this byte[] source,
    byte[] other1,
    byte[] other2,
    byte[] other3
)
<ExtensionAttribute>
Public Shared Function Combine (
    source As Byte(),
    other1 As Byte(),
    other2 As Byte(),
    other3 As Byte()
) As Byte()
static member Combine :
        source : byte[] *
        other1 : byte[] *
        other2 : byte[] *
        other3 : byte[] -> byte[]

GSF.ArrayExtensions.Combine = function(source, other1, other2, other3);
public:
[ExtensionAttribute]
static array<unsigned char>^ Combine(
    array<unsigned char>^ source,
    array<unsigned char>^ other1,
    array<unsigned char>^ other2,
    array<unsigned char>^ other3
)

Parameters

source
Type: SystemByte
Source buffer.
other1
Type: SystemByte
First buffer to combine to source buffer.
other2
Type: SystemByte
Second buffer to combine to source buffer.
other3
Type: SystemByte
Third buffer to combine to source buffer.

Return Value

Type: Byte
Combined buffers.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | Cannot create a byte array with more than 2,147,483,591 elements.
Remarks
Only use this function if you need a copy of the combined buffers, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined buffers.
See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine(T) Method (T[], T[], T[], T[])

Grid Solutions Framework ArrayExtensionsCombineT Method (T, T, T, T)
Combines arrays together into a single array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] Combine<T>(
    this T[] source,
    T[] other1,
    T[] other2,
    T[] other3
)

<ExtensionAttribute>
Public Shared Function Combine(Of T) (
    source As T(),
    other1 As T(),
    other2 As T(),
    other3 As T()
) As T()
static member Combine :
        source : 'T[] *
        other1 : 'T[] *
        other2 : 'T[] *
        other3 : 'T[] -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ Combine(
    array<T>^ source,
    array<T>^ other1,
    array<T>^ other2,
    array<T>^ other3
)

Parameters

source
Type: T
Source array.
other1
Type: T
First array to combine to source array.
other2
Type: T
Second array to combine to source array.
other3
Type: T
Third array to combine to source array.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.Combine``1(``0[],``0[],``0[],``0[])"]

Return Value

Type: T
Combined arrays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Only use this function if you need a copy of the combined arrays, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined arrays.

This function can easily throw an out of memory exception if there is not enough contiguous memory to create an array sized with the combined lengths.

See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine Method (Byte[], Byte[], Byte[], Byte[], Byte[])

Grid Solutions Framework ArrayExtensionsCombine Method (Byte, Byte, Byte, Byte, Byte)
Combines buffers together as a single image.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Combine(
    this byte[] source,
    byte[] other1,
    byte[] other2,
    byte[] other3,
    byte[] other4
)
<ExtensionAttribute>
Public Shared Function Combine (
    source As Byte(),
    other1 As Byte(),
    other2 As Byte(),
    other3 As Byte(),
    other4 As Byte()
) As Byte()
static member Combine :
        source : byte[] *
        other1 : byte[] *
        other2 : byte[] *
        other3 : byte[] *
        other4 : byte[] -> byte[]

GSF.ArrayExtensions.Combine = function(source, other1, other2, other3, other4);
public:
[ExtensionAttribute]
static array<unsigned char>^ Combine(
    array<unsigned char>^ source,
    array<unsigned char>^ other1,
    array<unsigned char>^ other2,
    array<unsigned char>^ other3,
    array<unsigned char>^ other4
)

Parameters

source
Type: SystemByte
Source buffer.
other1
Type: SystemByte
First buffer to combine to source buffer.
other2
Type: SystemByte
Second buffer to combine to source buffer.
other3
Type: SystemByte
Third buffer to combine to source buffer.
other4
Type: SystemByte
Fourth buffer to combine to source buffer.

Return Value

Type: Byte
Combined buffers.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
InvalidOperationException | Cannot create a byte array with more than 2,147,483,591 elements.
Remarks
Only use this function if you need a copy of the combined buffers, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined buffers.
See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine(T) Method (T[], T[], T[], T[], T[])

Grid Solutions Framework ArrayExtensionsCombineT Method (T, T, T, T, T)
Combines arrays together into a single array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] Combine<T>(
    this T[] source,
    T[] other1,
    T[] other2,
    T[] other3,
    T[] other4
)

<ExtensionAttribute>
Public Shared Function Combine(Of T) (
    source As T(),
    other1 As T(),
    other2 As T(),
    other3 As T(),
    other4 As T()
) As T()
static member Combine :
        source : 'T[] *
        other1 : 'T[] *
        other2 : 'T[] *
        other3 : 'T[] *
        other4 : 'T[] -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ Combine(
    array<T>^ source,
    array<T>^ other1,
    array<T>^ other2,
    array<T>^ other3,
    array<T>^ other4
)

Parameters

source
Type: T
Source array.
other1
Type: T
First array to combine to source array.
other2
Type: T
Second array to combine to source array.
other3
Type: T
Third array to combine to source array.
other4
Type: T
Fourth array to combine to source array.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.Combine``1(``0[],``0[],``0[],``0[],``0[])"]

Return Value

Type: T
Combined arrays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Only use this function if you need a copy of the combined arrays, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined arrays.

This function can easily throw an out of memory exception if there is not enough contiguous memory to create an array sized with the combined lengths.

See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.Combine(T) Method (T[], Int32, Int32, T[], Int32, Int32)

Grid Solutions Framework ArrayExtensionsCombineT Method (T, Int32, Int32, T, Int32, Int32)
Combines specified portions of arrays together into a single array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] Combine<T>(
    this T[] source,
    int sourceOffset,
    int sourceCount,
    T[] other,
    int otherOffset,
    int otherCount
)

<ExtensionAttribute>
Public Shared Function Combine(Of T) (
    source As T(),
    sourceOffset As Integer,
    sourceCount As Integer,
    other As T(),
    otherOffset As Integer,
    otherCount As Integer
) As T()
static member Combine :
        source : 'T[] *
        sourceOffset : int *
        sourceCount : int *
        other : 'T[] *
        otherOffset : int *
        otherCount : int -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ Combine(
    array<T>^ source,
    int sourceOffset,
    int sourceCount,
    array<T>^ other,
    int otherOffset,
    int otherCount
)

Parameters

source
Type: T
Source array.
sourceOffset
Type: SystemInt32
Offset into source array to begin copy.
sourceCount
Type: SystemInt32
Number of bytes to copy from source array.
other
Type: T
Other array to combine to source array.
otherOffset
Type: SystemInt32
Offset into other array to begin copy.
otherCount
Type: SystemInt32
Number of bytes to copy from other array.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.Combine``1(``0[],System.Int32,System.Int32,``0[],System.Int32,System.Int32)"]

Return Value

Type: T
Combined specified portions of both arrays.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | sourceOffset or otherOffset is outside the range of valid indexes for the associated array -or- sourceCount or otherCount is less than 0 -or- sourceOffset or otherOffset, and sourceCount or otherCount do not specify a valid section in the associated array.
Remarks

Only use this function if you need a copy of the combined arrays, it will be optimal to use the Linq function ConcatTSource(IEnumerableTSource, IEnumerableTSource) if you simply need to iterate over the combined arrays.

This function can easily throw an out of memory exception if there is not enough contiguous memory to create an array sized with the combined lengths.

See Also

Reference

ArrayExtensions Class
Combine Overload
GSF Namespace


ArrayExtensions.CompareTo Method

Grid Solutions Framework ArrayExtensionsCompareTo Method
Overload List
Name | Description
CompareToT(T, T) | Returns comparison results of two binary arrays.
CompareToT(T, Int32, T, Int32, Int32) | Returns comparison results of two binary arrays.
Top
See Also

Reference

ArrayExtensions Class
GSF Namespace


ArrayExtensions.CompareTo(T) Method (T[], T[])

Grid Solutions Framework ArrayExtensionsCompareToT Method (T, T)
Returns comparison results of two binary arrays.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CompareTo<T>(
    this T[] source,
    T[] other
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function CompareTo(Of T As {Object, IComparable(Of T)}) (
    source As T(),
    other As T()
) As Integer
static member CompareTo :
        source : 'T[] *
        other : 'T[] -> int  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static int CompareTo(
    array<T>^ source,
    array<T>^ other
)

Parameters

source
Type: T
Source array.
other
Type: T
Other array to compare to source array.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.CompareTo``1(``0[],``0[])"]

Return Value

Type: Int32

A signed integer that indicates the relative comparison of source array and other array.

Return Value | Description
Less than zero | Source array is less than other array.
Zero | Source array is equal to other array.
Greater than zero | Source array is greater than other array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Note that if both arrays are null the arrays will be considered equal. If one array is null and the other array is not null, the non-null array will be considered larger. If the array lengths are not equal, the array with the larger length will be considered larger. If the array lengths are equal, the arrays will be compared based on content.
See Also

Reference

ArrayExtensions Class
CompareTo Overload
GSF Namespace


ArrayExtensions.CompareTo(T) Method (T[], Int32, T[], Int32, Int32)

Grid Solutions Framework ArrayExtensionsCompareToT Method (T, Int32, T, Int32, Int32)
Returns comparison results of two binary arrays.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CompareTo<T>(
    this T[] source,
    int sourceOffset,
    T[] other,
    int otherOffset,
    int count
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function CompareTo(Of T As {Object, IComparable(Of T)}) (
    source As T(),
    sourceOffset As Integer,
    other As T(),
    otherOffset As Integer,
    count As Integer
) As Integer
static member CompareTo :
        source : 'T[] *
        sourceOffset : int *
        other : 'T[] *
        otherOffset : int *
        count : int -> int  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static int CompareTo(
    array<T>^ source,
    int sourceOffset,
    array<T>^ other,
    int otherOffset,
    int count
)

Parameters

source
Type: T
Source array.
sourceOffset
Type: SystemInt32
Offset into source array to begin compare.
other
Type: T
Other array to compare to source array.
otherOffset
Type: SystemInt32
Offset into other array to begin compare.
count
Type: SystemInt32
Number of bytes to compare in both arrays.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.CompareTo``1(``0[],System.Int32,``0[],System.Int32,System.Int32)"]

Return Value

Type: Int32

A signed integer that indicates the relative comparison of source array and other array.

Return Value | Description
Less than zero | Source array is less than other array.
Zero | Source array is equal to other array.
Greater than zero | Source array is greater than other array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | sourceOffset or otherOffset is outside the range of valid indexes for the associated array -or- count is less than 0 -or- sourceOffset or otherOffset and count do not specify a valid section in the associated array.
Remarks
Note that if both arrays are null the arrays will be considered equal. If one array is null and the other array is not null, the non-null array will be considered larger.
See Also

Reference

ArrayExtensions Class
CompareTo Overload
GSF Namespace


ArrayExtensions.IndexOfSequence Method

Grid Solutions Framework ArrayExtensionsIndexOfSequence Method
Overload List
Name | Description
IndexOfSequenceT(T, T) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the array.
IndexOfSequenceT(T, T, Int32) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index.
IndexOfSequenceT(T, T, Int32, Int32) | Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index and contains the specified number of elements.
Top
See Also

Reference

ArrayExtensions Class
GSF Namespace


ArrayExtensions.IndexOfSequence(T) Method (T[], T[])

Grid Solutions Framework ArrayExtensionsIndexOfSequenceT Method (T, T)
Searches for the specified sequenceToFind and returns the index of the first occurrence within the array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOfSequence<T>(
    this T[] array,
    T[] sequenceToFind
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function IndexOfSequence(Of T As {Object, IComparable(Of T)}) (
    array As T(),
    sequenceToFind As T()
) As Integer
static member IndexOfSequence :
        array : 'T[] *
        sequenceToFind : 'T[] -> int  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static int IndexOfSequence(
    array<T>^ array,
    array<T>^ sequenceToFind
)

Parameters

array
Type: T
Array to search.
sequenceToFind
Type: T
Sequence of items to search for.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.IndexOfSequence``1(``0[],``0[])"]

Return Value

Type: Int32
The zero-based index of the first occurrence of the sequenceToFind in the array, if found; otherwise, -1.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ArrayExtensions Class
IndexOfSequence Overload
GSF Namespace


ArrayExtensions.IndexOfSequence(T) Method (T[], T[], Int32)

Grid Solutions Framework ArrayExtensionsIndexOfSequenceT Method (T, T, Int32)
Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOfSequence<T>(
    this T[] array,
    T[] sequenceToFind,
    int startIndex
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function IndexOfSequence(Of T As {Object, IComparable(Of T)}) (
    array As T(),
    sequenceToFind As T(),
    startIndex As Integer
) As Integer
static member IndexOfSequence :
        array : 'T[] *
        sequenceToFind : 'T[] *
        startIndex : int -> int  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static int IndexOfSequence(
    array<T>^ array,
    array<T>^ sequenceToFind,
    int startIndex
)

Parameters

array
Type: T
Array to search.
sequenceToFind
Type: T
Sequence of items to search for.
startIndex
Type: SystemInt32
Start index in the array to start searching.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.IndexOfSequence``1(``0[],``0[],System.Int32)"]

Return Value

Type: Int32
The zero-based index of the first occurrence of the sequenceToFind in the array, if found; otherwise, -1.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ArrayExtensions Class
IndexOfSequence Overload
GSF Namespace


ArrayExtensions.IndexOfSequence(T) Method (T[], T[], Int32, Int32)

Grid Solutions Framework ArrayExtensionsIndexOfSequenceT Method (T, T, Int32, Int32)
Searches for the specified sequenceToFind and returns the index of the first occurrence within the range of elements in the array that starts at the specified index and contains the specified number of elements.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOfSequence<T>(
    this T[] array,
    T[] sequenceToFind,
    int startIndex,
    int length
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function IndexOfSequence(Of T As {Object, IComparable(Of T)}) (
    array As T(),
    sequenceToFind As T(),
    startIndex As Integer,
    length As Integer
) As Integer
static member IndexOfSequence :
        array : 'T[] *
        sequenceToFind : 'T[] *
        startIndex : int *
        length : int -> int  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static int IndexOfSequence(
    array<T>^ array,
    array<T>^ sequenceToFind,
    int startIndex,
    int length
)

Parameters

array
Type: T
Array to search.
sequenceToFind
Type: T
Sequence of items to search for.
startIndex
Type: SystemInt32
Start index in the array to start searching.
length
Type: SystemInt32
Number of bytes in the array to search through.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.IndexOfSequence``1(``0[],``0[],System.Int32,System.Int32)"]

Return Value

Type: Int32
The zero-based index of the first occurrence of the sequenceToFind in the array, if found; otherwise, -1.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | sequenceToFind is null or has zero length.
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the source array -or- length is less than 0.
See Also

Reference

ArrayExtensions Class
IndexOfSequence Overload
GSF Namespace


ArrayExtensions.ReadStructure Method

Grid Solutions Framework ArrayExtensionsReadStructure Method
Overload List
Name | Description
ReadStructureT(Byte) | Reads a structure from a byte array.
ReadStructureT(BinaryReader) | Reads a structure from a BinaryReader.
Top
See Also

Reference

ArrayExtensions Class
GSF Namespace


ArrayExtensions.ReadStructure(T) Method (Byte[])

Grid Solutions Framework ArrayExtensionsReadStructureT Method (Byte)
Reads a structure from a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T ReadStructure<T>(
    this byte[] bytes
)
where T : struct, new()

<ExtensionAttribute>
Public Shared Function ReadStructure(Of T As {Structure, New}) (
    bytes As Byte()
) As T
static member ReadStructure :
        bytes : byte[] -> 'T  when 'T : struct, new()

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : value class, gcnew()
static T ReadStructure(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: SystemByte
Bytes containing structure.

Type Parameters

T
Type of structure to read.

Return Value

Type: T
A structure from bytes.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ArrayExtensions Class
ReadStructure Overload
GSF Namespace


ArrayExtensions.ReadStructure(T) Method (BinaryReader)

Grid Solutions Framework ArrayExtensionsReadStructureT Method (BinaryReader)
Reads a structure from a BinaryReader.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T ReadStructure<T>(
    this BinaryReader reader
)
where T : struct, new()

<ExtensionAttribute>
Public Shared Function ReadStructure(Of T As {Structure, New}) (
    reader As BinaryReader
) As T
static member ReadStructure :
        reader : BinaryReader -> 'T  when 'T : struct, new()

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : value class, gcnew()
static T ReadStructure(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader
BinaryReader positioned at desired structure.

Type Parameters

T
Type of structure to read.

Return Value

Type: T
A structure read from BinaryReader.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BinaryReader. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ArrayExtensions Class
ReadStructure Overload
GSF Namespace


ArrayExtensions.ValidateParameters(T) Method

Grid Solutions Framework ArrayExtensionsValidateParametersT Method
Validates that the specified startIndex and length are valid within the given array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ValidateParameters<T>(
    this T[] array,
    int startIndex,
    int length
)

<ExtensionAttribute>
Public Shared Sub ValidateParameters(Of T) (
    array As T(),
    startIndex As Integer,
    length As Integer
)
static member ValidateParameters :
        array : 'T[] *
        startIndex : int *
        length : int -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static void ValidateParameters(
    array<T>^ array,
    int startIndex,
    int length
)

Parameters

array
Type: T
Array to validate.
startIndex
Type: SystemInt32
0-based start index into the array.
length
Type: SystemInt32
Valid number of items within array from startIndex.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ArrayExtensions.ValidateParameters``1(``0[],System.Int32,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed array length.
See Also

Reference

ArrayExtensions Class
GSF Namespace


BaselineTimeInterval Enumeration

Grid Solutions Framework BaselineTimeInterval Enumeration
Time intervals enumeration used by BaselinedTimestamp(BaselineTimeInterval) method.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum BaselineTimeInterval
Public Enumeration BaselineTimeInterval
type BaselineTimeInterval
GSF.BaselineTimeInterval = function();
GSF.BaselineTimeInterval.createEnum('GSF.BaselineTimeInterval', false);
public enum class BaselineTimeInterval
Members
Member name | Value | Description
Second | 0 | Baseline timestamp to the second (i.e., starting at zero milliseconds).
Minute | 1 | Baseline timestamp to the minute (i.e., starting at zero seconds and milliseconds).
Hour | 2 | Baseline timestamp to the hour (i.e., starting at zero minutes, seconds and milliseconds).
Day | 3 | Baseline timestamp to the day (i.e., starting at zero hours, minutes, seconds and milliseconds).
Month | 4 | Baseline timestamp to the month (i.e., starting at day one, zero hours, minutes, seconds and milliseconds).
Year | 5 | Baseline timestamp to the year (i.e., starting at month one, day one, zero hours, minutes, seconds and milliseconds).
See Also

Reference

GSF Namespace


BigBinaryValue Class

Grid Solutions Framework BigBinaryValue Class
Represents a big-endian ordered binary data sample stored as a byte array, but implicitly castable to most common native types.
Inheritance Hierarchy
SystemObject
GSFBinaryValueBase BigEndianOrder
GSFBigBinaryValue

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BigBinaryValue : BinaryValueBase<BigEndianOrder>
Public Class BigBinaryValue
    Inherits BinaryValueBase(Of BigEndianOrder)
type BigBinaryValue =
    class
        inherit BinaryValueBase<BigEndianOrder>
    end
GSF.BigBinaryValue = function();

Type.createClass(
    'GSF.BigBinaryValue',
    GSF.BinaryValueBase`1);
public ref class BigBinaryValue : public BinaryValueBase<BigEndianOrder^>

The BigBinaryValue type exposes the following members.

Constructors
 | Name | Description
Public method | BigBinaryValue(Byte) | Creates a new big-endian ordered binary value from the given byte array.
Public method | BigBinaryValue(TypeCode, Byte) | Creates a new big-endian ordered binary value from the given byte array.
Public method | BigBinaryValue(Byte, Int32, Int32) | Creates a new big-endian ordered binary value from the given byte array.
Public method | BigBinaryValue(TypeCode, Byte, Int32, Int32) | Creates a new big-endian ordered binary value from the given byte array.
Top
Methods
 | Name | Description
Public method | ConvertToType | Returns a BigBinaryValue representation of source value converted to specified TypeCode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToString | Returns a String that represents the current BigBinaryValue. (Overrides ObjectToString.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Top
Operators
Name | Description
(Byte to BigBinaryValue) | Implicitly converts Byte to BigBinaryValue.
(Double to BigBinaryValue) | Implicitly converts Double to BigBinaryValue.
(Int16 to BigBinaryValue) | Implicitly converts Int16 to BigBinaryValue.
(Int32 to BigBinaryValue) | Implicitly converts Int32 to BigBinaryValue.
(Int64 to BigBinaryValue) | Implicitly converts Int64 to BigBinaryValue.
(Single to BigBinaryValue) | Implicitly converts Single to BigBinaryValue.
(UInt16 to BigBinaryValue) | Implicitly converts UInt16 to BigBinaryValue.
(UInt32 to BigBinaryValue) | Implicitly converts UInt32 to BigBinaryValue.
(UInt64 to BigBinaryValue) | Implicitly converts UInt64 to BigBinaryValue.
(BigBinaryValue to Byte) | Implicitly converts BigBinaryValue to Byte.
(BigBinaryValue to Int16) | Implicitly converts BigBinaryValue to Int16.
(BigBinaryValue to UInt16) | Implicitly converts BigBinaryValue to UInt16.
(BigBinaryValue to Int24) | Implicitly converts BigBinaryValue to Int24.
(BigBinaryValue to UInt24) | Implicitly converts BigBinaryValue to UInt24.
(BigBinaryValue to Int32) | Implicitly converts BigBinaryValue to Int32.
(BigBinaryValue to UInt32) | Implicitly converts BigBinaryValue to UInt32.
(BigBinaryValue to Int64) | Implicitly converts BigBinaryValue to Int64.
(BigBinaryValue to UInt64) | Implicitly converts BigBinaryValue to UInt64.
(BigBinaryValue to Single) | Implicitly converts BigBinaryValue to Single.
(BigBinaryValue to Double) | Implicitly converts BigBinaryValue to Double.
(Int24 to BigBinaryValue) | Implicitly converts Int24 to BigBinaryValue.
(UInt24 to BigBinaryValue) | Implicitly converts UInt24 to BigBinaryValue.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample. (Inherited from BinaryValueBaseTEndianOrder.)
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents. (Inherited from BinaryValueBaseTEndianOrder.)
Top
See Also

Reference

GSF Namespace


BigBinaryValue Constructor

Grid Solutions Framework BigBinaryValue Constructor
Overload List
 | Name | Description
Public method | BigBinaryValue(Byte) | Creates a new big-endian ordered binary value from the given byte array.
Public method | BigBinaryValue(TypeCode, Byte) | Creates a new big-endian ordered binary value from the given byte array.
Public method | BigBinaryValue(Byte, Int32, Int32) | Creates a new big-endian ordered binary value from the given byte array.
Public method | BigBinaryValue(TypeCode, Byte, Int32, Int32) | Creates a new big-endian ordered binary value from the given byte array.
Top
See Also

Reference

BigBinaryValue Class
GSF Namespace


BigBinaryValue Constructor (Byte[])

Grid Solutions Framework BigBinaryValue Constructor (Byte)
Creates a new big-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BigBinaryValue(
    byte[] buffer
)
Public Sub New (
    buffer As Byte()
)
new :
        buffer : byte[] -> BigBinaryValue
GSF.BigBinaryValue = function(buffer);
public:
BigBinaryValue(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
Remarks
This constructor assumes a type code of Empty to represent "undefined".
See Also

Reference

BigBinaryValue Class
BigBinaryValue Overload
GSF Namespace


BigBinaryValue Constructor (TypeCode, Byte[])

Grid Solutions Framework BigBinaryValue Constructor (TypeCode, Byte)
Creates a new big-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BigBinaryValue(
    TypeCode typeCode,
    byte[] buffer
)
Public Sub New (
    typeCode As TypeCode,
    buffer As Byte()
)
new :
        typeCode : TypeCode *
        buffer : byte[] -> BigBinaryValue
GSF.BigBinaryValue = function(typeCode, buffer);
public:
BigBinaryValue(
    TypeCode typeCode,
    array<unsigned char>^ buffer
)

Parameters

typeCode
Type: SystemTypeCode
The type code of the native value that the binary value represents.
buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
See Also

Reference

BigBinaryValue Class
BigBinaryValue Overload
GSF Namespace


BigBinaryValue Constructor (Byte[], Int32, Int32)

Grid Solutions Framework BigBinaryValue Constructor (Byte, Int32, Int32)
Creates a new big-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BigBinaryValue(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> BigBinaryValue
GSF.BigBinaryValue = function(buffer, startIndex, length);
public:
BigBinaryValue(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
startIndex
Type: SystemInt32
The offset in the buffer where the data starts.
length
Type: SystemInt32
The number of data bytes that make up the binary value.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null
ArgumentOutOfRangeException | startIndex is outside the range of the buffer -or- length is less than 0 -or- startIndex and length do not specify a valid region in the buffer
Remarks
This constructor assumes a type code of Empty to represent "undefined".
See Also

Reference

BigBinaryValue Class
BigBinaryValue Overload
GSF Namespace


BigBinaryValue Constructor (TypeCode, Byte[], Int32, Int32)

Grid Solutions Framework BigBinaryValue Constructor (TypeCode, Byte, Int32, Int32)
Creates a new big-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BigBinaryValue(
    TypeCode typeCode,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    typeCode As TypeCode,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        typeCode : TypeCode *
        buffer : byte[] *
        startIndex : int *
        length : int -> BigBinaryValue
GSF.BigBinaryValue = function(typeCode, buffer, startIndex, length);
public:
BigBinaryValue(
    TypeCode typeCode,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

typeCode
Type: SystemTypeCode
The type code of the native value that the binary value represents.
buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
startIndex
Type: SystemInt32
The offset in the buffer where the data starts.
length
Type: SystemInt32
The number of data bytes that make up the binary value.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null
ArgumentOutOfRangeException | startIndex is outside the range of the buffer -or- length is less than 0 -or- startIndex and length do not specify a valid region in the buffer
See Also

Reference

BigBinaryValue Class
BigBinaryValue Overload
GSF Namespace


BigBinaryValue Methods

Grid Solutions Framework BigBinaryValue Methods

The BigBinaryValue type exposes the following members.

Methods
 | Name | Description
Public method | ConvertToType | Returns a BigBinaryValue representation of source value converted to specified TypeCode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToString | Returns a String that represents the current BigBinaryValue. (Overrides ObjectToString.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BigBinaryValue Class
GSF Namespace


BigBinaryValue.ConvertToType Method

Grid Solutions Framework BigBinaryValueConvertToType Method
Returns a BigBinaryValue representation of source value converted to specified TypeCode.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BigBinaryValue ConvertToType(
    TypeCode typeCode
)
Public Function ConvertToType (
    typeCode As TypeCode
) As BigBinaryValue
member ConvertToType :
        typeCode : TypeCode -> BigBinaryValue

function ConvertToType(typeCode);
public:
BigBinaryValue^ ConvertToType(
    TypeCode typeCode
)

Parameters

typeCode
Type: SystemTypeCode
Desired TypeCode for destination value.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of source value converted to specified TypeCode.
Exceptions
Exception | Condition
InvalidOperationException | Unable to convert binary value to specified type.
See Also

Reference

BigBinaryValue Class
GSF Namespace


BigBinaryValue.ToString Method

Grid Solutions Framework BigBinaryValueToString Method
Returns a String that represents the current BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current BigBinaryValue.
See Also

Reference

BigBinaryValue Class
GSF Namespace


BigBinaryValue Type Conversions

Grid Solutions Framework BigBinaryValue Type Conversions
Operators
Name | Description
(Byte to BigBinaryValue) | Implicitly converts Byte to BigBinaryValue.
(Double to BigBinaryValue) | Implicitly converts Double to BigBinaryValue.
(Int16 to BigBinaryValue) | Implicitly converts Int16 to BigBinaryValue.
(Int32 to BigBinaryValue) | Implicitly converts Int32 to BigBinaryValue.
(Int64 to BigBinaryValue) | Implicitly converts Int64 to BigBinaryValue.
(Single to BigBinaryValue) | Implicitly converts Single to BigBinaryValue.
(UInt16 to BigBinaryValue) | Implicitly converts UInt16 to BigBinaryValue.
(UInt32 to BigBinaryValue) | Implicitly converts UInt32 to BigBinaryValue.
(UInt64 to BigBinaryValue) | Implicitly converts UInt64 to BigBinaryValue.
(BigBinaryValue to Byte) | Implicitly converts BigBinaryValue to Byte.
(BigBinaryValue to Int16) | Implicitly converts BigBinaryValue to Int16.
(BigBinaryValue to UInt16) | Implicitly converts BigBinaryValue to UInt16.
(BigBinaryValue to Int24) | Implicitly converts BigBinaryValue to Int24.
(BigBinaryValue to UInt24) | Implicitly converts BigBinaryValue to UInt24.
(BigBinaryValue to Int32) | Implicitly converts BigBinaryValue to Int32.
(BigBinaryValue to UInt32) | Implicitly converts BigBinaryValue to UInt32.
(BigBinaryValue to Int64) | Implicitly converts BigBinaryValue to Int64.
(BigBinaryValue to UInt64) | Implicitly converts BigBinaryValue to UInt64.
(BigBinaryValue to Single) | Implicitly converts BigBinaryValue to Single.
(BigBinaryValue to Double) | Implicitly converts BigBinaryValue to Double.
(Int24 to BigBinaryValue) | Implicitly converts Int24 to BigBinaryValue.
(UInt24 to BigBinaryValue) | Implicitly converts UInt24 to BigBinaryValue.
Top
See Also

Reference

BigBinaryValue Class
GSF Namespace


BigBinaryValue Implicit Conversion Operators

Grid Solutions Framework BigBinaryValue Conversion Operators
Overload List
Name | Description
(Byte to BigBinaryValue) | Implicitly converts Byte to BigBinaryValue.
(Double to BigBinaryValue) | Implicitly converts Double to BigBinaryValue.
(Int16 to BigBinaryValue) | Implicitly converts Int16 to BigBinaryValue.
(Int32 to BigBinaryValue) | Implicitly converts Int32 to BigBinaryValue.
(Int64 to BigBinaryValue) | Implicitly converts Int64 to BigBinaryValue.
(Single to BigBinaryValue) | Implicitly converts Single to BigBinaryValue.
(UInt16 to BigBinaryValue) | Implicitly converts UInt16 to BigBinaryValue.
(UInt32 to BigBinaryValue) | Implicitly converts UInt32 to BigBinaryValue.
(UInt64 to BigBinaryValue) | Implicitly converts UInt64 to BigBinaryValue.
(BigBinaryValue to Byte) | Implicitly converts BigBinaryValue to Byte.
(BigBinaryValue to Int16) | Implicitly converts BigBinaryValue to Int16.
(BigBinaryValue to UInt16) | Implicitly converts BigBinaryValue to UInt16.
(BigBinaryValue to Int24) | Implicitly converts BigBinaryValue to Int24.
(BigBinaryValue to UInt24) | Implicitly converts BigBinaryValue to UInt24.
(BigBinaryValue to Int32) | Implicitly converts BigBinaryValue to Int32.
(BigBinaryValue to UInt32) | Implicitly converts BigBinaryValue to UInt32.
(BigBinaryValue to Int64) | Implicitly converts BigBinaryValue to Int64.
(BigBinaryValue to UInt64) | Implicitly converts BigBinaryValue to UInt64.
(BigBinaryValue to Single) | Implicitly converts BigBinaryValue to Single.
(BigBinaryValue to Double) | Implicitly converts BigBinaryValue to Double.
(Int24 to BigBinaryValue) | Implicitly converts Int24 to BigBinaryValue.
(UInt24 to BigBinaryValue) | Implicitly converts UInt24 to BigBinaryValue.
Top
See Also

Reference

BigBinaryValue Class
GSF Namespace


BigBinaryValue Implicit Conversion (Byte to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (Byte to BigBinaryValue)
Implicitly converts Byte to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    byte value
)
Public Shared Widening Operator CType (
    value As Byte
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    unsigned char value
)

Parameters

value
Type: SystemByte
Byte to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of Byte.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (Double to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (Double to BigBinaryValue)
Implicitly converts Double to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    double value
)

Parameters

value
Type: SystemDouble
Double to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of Double.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (Int16 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (Int16 to BigBinaryValue)
Implicitly converts Int16 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    short value
)
Public Shared Widening Operator CType (
    value As Short
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    short value
)

Parameters

value
Type: SystemInt16
Int16 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of Int16.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (Int32 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (Int32 to BigBinaryValue)
Implicitly converts Int32 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    int value
)
Public Shared Widening Operator CType (
    value As Integer
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    int value
)

Parameters

value
Type: SystemInt32
Int32 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of Int32.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (Int64 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (Int64 to BigBinaryValue)
Implicitly converts Int64 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    long value
)
Public Shared Widening Operator CType (
    value As Long
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    long long value
)

Parameters

value
Type: SystemInt64
Int64 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of Int64.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (Single to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (Single to BigBinaryValue)
Implicitly converts Single to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    float value
)
Public Shared Widening Operator CType (
    value As Single
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    float value
)

Parameters

value
Type: SystemSingle
Single to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of Single.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (UInt16 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (UInt16 to BigBinaryValue)
Implicitly converts UInt16 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    ushort value
)
Public Shared Widening Operator CType (
    value As UShort
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    unsigned short value
)

Parameters

value
Type: SystemUInt16
UInt16 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of UInt16.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (UInt32 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (UInt32 to BigBinaryValue)
Implicitly converts UInt32 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    uint value
)
Public Shared Widening Operator CType (
    value As UInteger
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    unsigned int value
)

Parameters

value
Type: SystemUInt32
UInt32 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of UInt32.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (UInt64 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (UInt64 to BigBinaryValue)
Implicitly converts UInt64 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    ulong value
)
Public Shared Widening Operator CType (
    value As ULong
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
UInt64 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of UInt64.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to Byte)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to Byte)
Implicitly converts BigBinaryValue to Byte.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator byte (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As Byte
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned char (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to Byte.

Return Value

Type: Byte
A Byte representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to Int16)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to Int16)
Implicitly converts BigBinaryValue to Int16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator short (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As Short
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator short (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to Int16.

Return Value

Type: Int16
A Int16 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to UInt16)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to UInt16)
Implicitly converts BigBinaryValue to UInt16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ushort (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As UShort
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned short (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to UInt16.

Return Value

Type: UInt16
A UInt16 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to Int24)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to Int24)
Implicitly converts BigBinaryValue to Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Int24 (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Int24 (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to Int24.

Return Value

Type: Int24
A Int24 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to UInt24)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to UInt24)
Implicitly converts BigBinaryValue to UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator UInt24 (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator UInt24 (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to UInt24.

Return Value

Type: UInt24
A UInt24 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to Int32)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to Int32)
Implicitly converts BigBinaryValue to Int32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator int (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As Integer
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator int (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to Int32.

Return Value

Type: Int32
A Int32 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to UInt32)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to UInt32)
Implicitly converts BigBinaryValue to UInt32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator uint (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As UInteger
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned int (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to UInt32.

Return Value

Type: UInt32
A UInt32 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to Int64)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to Int64)
Implicitly converts BigBinaryValue to Int64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator long (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As Long
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator long long (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to Int64.

Return Value

Type: Int64
A Int64 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to UInt64)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to UInt64)
Implicitly converts BigBinaryValue to UInt64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ulong (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As ULong
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned long long (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to UInt64.

Return Value

Type: UInt64
A UInt64 representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to Single)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to Single)
Implicitly converts BigBinaryValue to Single.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator float (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As Single
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator float (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to Single.

Return Value

Type: Single
A Single representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (BigBinaryValue to Double)

Grid Solutions Framework BigBinaryValue Conversion (BigBinaryValue to Double)
Implicitly converts BigBinaryValue to Double.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    BigBinaryValue value
)
Public Shared Widening Operator CType (
    value As BigBinaryValue
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    BigBinaryValue^ value
)

Parameters

value
Type: GSFBigBinaryValue
BigBinaryValue to convert to Double.

Return Value

Type: Double
A Double representation of BigBinaryValue.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (Int24 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (Int24 to BigBinaryValue)
Implicitly converts Int24 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of Int24.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Implicit Conversion (UInt24 to BigBinaryValue)

Grid Solutions Framework BigBinaryValue Conversion (UInt24 to BigBinaryValue)
Implicitly converts UInt24 to BigBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator BigBinaryValue (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As BigBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator BigBinaryValue^ (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 to convert to BigBinaryValue.

Return Value

Type: BigBinaryValue
A BigBinaryValue representation of UInt24.
See Also

Reference

BigBinaryValue Class
Overload
GSF Namespace


BigBinaryValue Properties

Grid Solutions Framework BigBinaryValue Properties

The BigBinaryValue type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample. (Inherited from BinaryValueBaseTEndianOrder.)
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents. (Inherited from BinaryValueBaseTEndianOrder.)
Top
See Also

Reference

BigBinaryValue Class
GSF Namespace


BigEndian Class

Grid Solutions Framework BigEndian Class
Defines a set of big-endian byte order interoperability functions.
Inheritance Hierarchy
SystemObject
GSFBigEndian

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class BigEndian
Public NotInheritable Class BigEndian
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BigEndian =  class end
GSF.BigEndian = function();

Type.createClass(
    'GSF.BigEndian');
public ref class BigEndian abstract sealed
Methods
Name | Description
CopyBytes(Boolean, Byte*) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte*) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte*) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte*) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte*) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte*) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte*) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte*) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte*) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte*) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte*) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte*) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte*) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte, Int32) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte*) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
GetBytes(Decimal) | Returns the specified 128-bit decimal value as an array of bytes.
GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
ToBoolean(Byte*) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToBoolean(Byte, Int32) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToChar(Byte*) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToChar(Byte, Int32) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte*) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte, Int32) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte*) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte, Int32) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte*) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte, Int32) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte*) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte, Int32) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte*) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte, Int32) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte*) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte, Int32) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte*) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte, Int32) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte*) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte, Int32) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte*) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte, Int32) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte*) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte, Int32) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte*) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte, Int32) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
Remarks
This class is setup to support aggressive in-lining of big endian conversions. Bounds will not be checked as part of this function call, if bounds are violated, the exception will be thrown at the Array level.
See Also

Reference

GSF Namespace


BigEndian Methods

Grid Solutions Framework BigEndian Methods
Methods
Name | Description
CopyBytes(Boolean, Byte*) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte*) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte*) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte*) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte*) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte*) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte*) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte*) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte*) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte*) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte*) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte*) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte*) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte, Int32) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte*) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
GetBytes(Decimal) | Returns the specified 128-bit decimal value as an array of bytes.
GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
ToBoolean(Byte*) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToBoolean(Byte, Int32) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToChar(Byte*) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToChar(Byte, Int32) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte*) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte, Int32) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte*) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte, Int32) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte*) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte, Int32) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte*) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte, Int32) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte*) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte, Int32) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte*) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte, Int32) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte*) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte, Int32) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte*) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte, Int32) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte*) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte, Int32) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte*) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte, Int32) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte*) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte, Int32) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.CopyBytes Method

Grid Solutions Framework BigEndianCopyBytes Method
Overload List
Name | Description
CopyBytes(Boolean, Byte*) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte*) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte*) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte*) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte*) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte*) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte*) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte*) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte*) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte*) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte*) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte*) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte*) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte*) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte, Int32) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.CopyBytes Method (Boolean, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Boolean, Byte)
Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    bool value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    bool value,
    unsigned char* destination
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Char, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Char, Byte)
Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    char value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    wchar_t value,
    unsigned char* destination
)

Parameters

value
Type: SystemChar
The Unicode character value to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Decimal, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Decimal, Byte)
Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    decimal value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    Decimal value,
    unsigned char* destination
)

Parameters

value
Type: SystemDecimal
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Double, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Double, Byte)
Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    double value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    double value,
    unsigned char* destination
)

Parameters

value
Type: SystemDouble
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int16, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Int16, Byte)
Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    short value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    short value,
    unsigned char* destination
)

Parameters

value
Type: SystemInt16
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int32, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Int32, Byte)
Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    int value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    int value,
    unsigned char* destination
)

Parameters

value
Type: SystemInt32
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int64, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Int64, Byte)
Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    long value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    long long value,
    unsigned char* destination
)

Parameters

value
Type: SystemInt64
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Single, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Single, Byte)
Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    float value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    float value,
    unsigned char* destination
)

Parameters

value
Type: SystemSingle
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt16, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (UInt16, Byte)
Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ushort value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    unsigned short value,
    unsigned char* destination
)

Parameters

value
Type: SystemUInt16
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt32, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (UInt32, Byte)
Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    uint value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    unsigned int value,
    unsigned char* destination
)

Parameters

value
Type: SystemUInt32
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt64, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (UInt64, Byte)
Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ulong value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    unsigned long long value,
    unsigned char* destination
)

Parameters

value
Type: SystemUInt64
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes(T) Method (T, Byte*)

Grid Solutions Framework BigEndianCopyBytesT Method (T, Byte)
Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes<T>(
    T value,
    byte* destination
)
where T : struct, new(), IConvertible

Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
static int CopyBytes(
    T value,
    unsigned char* destination
)

Parameters

value
Type: T
The Boolean value to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Int32
Length of bytes copied into array based on size of T.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int24, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (Int24, Byte)
Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    Int24 value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    Int24 value,
    unsigned char* destination
)

Parameters

value
Type: GSFInt24
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt24, Byte*)

Grid Solutions Framework BigEndianCopyBytes Method (UInt24, Byte)
Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    UInt24 value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    UInt24 value,
    unsigned char* destination
)

Parameters

value
Type: GSFUInt24
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Boolean, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Boolean, Byte, Int32)
Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    bool value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Boolean,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : bool *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    bool value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Char, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Char, Byte, Int32)
Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    char value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Char,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : char *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    wchar_t value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemChar
The Unicode character value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Decimal, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Decimal, Byte, Int32)
Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    decimal value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Decimal,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : decimal *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    Decimal value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemDecimal
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Double, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Double, Byte, Int32)
Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    double value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Double,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : float *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    double value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemDouble
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int16, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Int16, Byte, Int32)
Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    short value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Short,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : int16 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    short value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt16
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int32, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Int32, Byte, Int32)
Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    int value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Integer,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : int *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    int value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt32
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int64, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Int64, Byte, Int32)
Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    long value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Long,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : int64 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    long long value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt64
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Single, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Single, Byte, Int32)
Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    float value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Single,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : float32 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    float value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemSingle
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt16, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (UInt16, Byte, Int32)
Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ushort value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As UShort,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : uint16 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    unsigned short value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt16
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt32, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (UInt32, Byte, Int32)
Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    uint value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As UInteger,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : uint32 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    unsigned int value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt32
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt64, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (UInt64, Byte, Int32)
Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ulong value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As ULong,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : uint64 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    unsigned long long value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt64
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes(T) Method (T, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytesT Method (T, Byte, Int32)
Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes<T>(
    T value,
    byte[] destinationArray,
    int destinationIndex
)
where T : struct, new(), IConvertible

Public Shared Function CopyBytes(Of T As {Structure, New, IConvertible}) (
    value As T,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : 'T *
        destinationArray : byte[] *
        destinationIndex : int -> int  when 'T : struct, new() and IConvertible

JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
static int CopyBytes(
    T value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: T
The Boolean value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Int32
Length of bytes copied into array based on size of T.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (Int24, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (Int24, Byte, Int32)
Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    Int24 value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Int24,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : Int24 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    Int24 value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: GSFInt24
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.CopyBytes Method (UInt24, Byte[], Int32)

Grid Solutions Framework BigEndianCopyBytes Method (UInt24, Byte, Int32)
Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    UInt24 value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As UInt24,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : UInt24 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.BigEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    UInt24 value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: GSFUInt24
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

BigEndian Class
CopyBytes Overload
GSF Namespace


BigEndian.GetBytes Method

Grid Solutions Framework BigEndianGetBytes Method
Overload List
Name | Description
GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
GetBytes(Decimal) | Returns the specified 128-bit decimal value as an array of bytes.
GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.GetBytes Method (Boolean)

Grid Solutions Framework BigEndianGetBytes Method (Boolean)
Returns the specified Boolean value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    bool value
)
Public Shared Function GetBytes (
    value As Boolean
) As Byte()
static member GetBytes :
        value : bool -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    bool value
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert.

Return Value

Type: Byte
An array of bytes with length 1.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Char)

Grid Solutions Framework BigEndianGetBytes Method (Char)
Returns the specified Unicode character value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    char value
)
Public Shared Function GetBytes (
    value As Char
) As Byte()
static member GetBytes :
        value : char -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    wchar_t value
)

Parameters

value
Type: SystemChar
The Unicode character value to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Decimal)

Grid Solutions Framework BigEndianGetBytes Method (Decimal)
Returns the specified 128-bit decimal value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    decimal value
)
Public Shared Function GetBytes (
    value As Decimal
) As Byte()
static member GetBytes :
        value : decimal -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    Decimal value
)

Parameters

value
Type: SystemDecimal
The number to convert.

Return Value

Type: Byte
An array of bytes with length 16.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Double)

Grid Solutions Framework BigEndianGetBytes Method (Double)
Returns the specified double-precision floating point value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    double value
)
Public Shared Function GetBytes (
    value As Double
) As Byte()
static member GetBytes :
        value : float -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    double value
)

Parameters

value
Type: SystemDouble
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Int16)

Grid Solutions Framework BigEndianGetBytes Method (Int16)
Returns the specified 16-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    short value
)
Public Shared Function GetBytes (
    value As Short
) As Byte()
static member GetBytes :
        value : int16 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    short value
)

Parameters

value
Type: SystemInt16
The number to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Int32)

Grid Solutions Framework BigEndianGetBytes Method (Int32)
Returns the specified 32-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    int value
)
Public Shared Function GetBytes (
    value As Integer
) As Byte()
static member GetBytes :
        value : int -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    int value
)

Parameters

value
Type: SystemInt32
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Int64)

Grid Solutions Framework BigEndianGetBytes Method (Int64)
Returns the specified 64-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    long value
)
Public Shared Function GetBytes (
    value As Long
) As Byte()
static member GetBytes :
        value : int64 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    long long value
)

Parameters

value
Type: SystemInt64
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Single)

Grid Solutions Framework BigEndianGetBytes Method (Single)
Returns the specified single-precision floating point value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    float value
)
Public Shared Function GetBytes (
    value As Single
) As Byte()
static member GetBytes :
        value : float32 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    float value
)

Parameters

value
Type: SystemSingle
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (UInt16)

Grid Solutions Framework BigEndianGetBytes Method (UInt16)
Returns the specified 16-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    ushort value
)
Public Shared Function GetBytes (
    value As UShort
) As Byte()
static member GetBytes :
        value : uint16 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    unsigned short value
)

Parameters

value
Type: SystemUInt16
The number to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (UInt32)

Grid Solutions Framework BigEndianGetBytes Method (UInt32)
Returns the specified 32-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    uint value
)
Public Shared Function GetBytes (
    value As UInteger
) As Byte()
static member GetBytes :
        value : uint32 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (UInt64)

Grid Solutions Framework BigEndianGetBytes Method (UInt64)
Returns the specified 64-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    ulong value
)
Public Shared Function GetBytes (
    value As ULong
) As Byte()
static member GetBytes :
        value : uint64 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes(T) Method (T)

Grid Solutions Framework BigEndianGetBytesT Method (T)
Returns the specified value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes<T>(
    T value
)
where T : struct, new(), IConvertible

Public Shared Function GetBytes(Of T As {Structure, New, IConvertible}) (
    value As T
) As Byte()
static member GetBytes :
        value : 'T -> byte[]  when 'T : struct, new() and IConvertible

JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
static array<unsigned char>^ GetBytes(
    T value
)

Parameters

value
Type: T
The value to convert.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Byte
An array of bytes with length 1.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (Int24)

Grid Solutions Framework BigEndianGetBytes Method (Int24)
Returns the specified 24-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    Int24 value
)
Public Shared Function GetBytes (
    value As Int24
) As Byte()
static member GetBytes :
        value : Int24 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    Int24 value
)

Parameters

value
Type: GSFInt24
The number to convert.

Return Value

Type: Byte
An array of bytes with length 3.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.GetBytes Method (UInt24)

Grid Solutions Framework BigEndianGetBytes Method (UInt24)
Returns the specified 24-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    UInt24 value
)
Public Shared Function GetBytes (
    value As UInt24
) As Byte()
static member GetBytes :
        value : UInt24 -> byte[]

GSF.BigEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
The number to convert.

Return Value

Type: Byte
An array of bytes with length 3.
See Also

Reference

BigEndian Class
GetBytes Overload
GSF Namespace


BigEndian.ToBoolean Method

Grid Solutions Framework BigEndianToBoolean Method
Overload List
Name | Description
ToBoolean(Byte*) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToBoolean(Byte, Int32) | Returns a Boolean value converted from one byte at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToBoolean Method (Byte*)

Grid Solutions Framework BigEndianToBoolean Method (Byte)
Returns a Boolean value converted from one byte at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ToBoolean(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static bool ToBoolean(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes.

Return Value

Type: Boolean
true if the byte at startIndex in value is nonzero; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToBoolean Overload
GSF Namespace


BigEndian.ToBoolean Method (Byte[], Int32)

Grid Solutions Framework BigEndianToBoolean Method (Byte, Int32)
Returns a Boolean value converted from one byte at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ToBoolean(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToBoolean (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
static member ToBoolean :
        buffer : byte[] *
        startIndex : int -> bool

GSF.BigEndian.ToBoolean = function(buffer, startIndex);
public:
static bool ToBoolean(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes.
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Boolean
true if the byte at startIndex in value is nonzero; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToBoolean Overload
GSF Namespace


BigEndian.ToChar Method

Grid Solutions Framework BigEndianToChar Method
Overload List
Name | Description
ToChar(Byte*) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToChar(Byte, Int32) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToChar Method (Byte*)

Grid Solutions Framework BigEndianToChar Method (Byte)
Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static char ToChar(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static wchar_t ToChar(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Char
A character formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToChar Overload
GSF Namespace


BigEndian.ToChar Method (Byte[], Int32)

Grid Solutions Framework BigEndianToChar Method (Byte, Int32)
Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static char ToChar(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToChar (
    buffer As Byte(),
    startIndex As Integer
) As Char
static member ToChar :
        buffer : byte[] *
        startIndex : int -> char

GSF.BigEndian.ToChar = function(buffer, startIndex);
public:
static wchar_t ToChar(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Char
A character formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToChar Overload
GSF Namespace


BigEndian.ToDecimal Method

Grid Solutions Framework BigEndianToDecimal Method
Overload List
Name | Description
ToDecimal(Byte*) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte, Int32) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToDecimal Method (Byte*)

Grid Solutions Framework BigEndianToDecimal Method (Byte)
Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static decimal ToDecimal(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static Decimal ToDecimal(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Decimal
A 128-bit decimal formed by 16 bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToDecimal Overload
GSF Namespace


BigEndian.ToDecimal Method (Byte[], Int32)

Grid Solutions Framework BigEndianToDecimal Method (Byte, Int32)
Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static decimal ToDecimal(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToDecimal (
    buffer As Byte(),
    startIndex As Integer
) As Decimal
static member ToDecimal :
        buffer : byte[] *
        startIndex : int -> decimal

GSF.BigEndian.ToDecimal = function(buffer, startIndex);
public:
static Decimal ToDecimal(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Decimal
A 128-bit decimal formed by 16 bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToDecimal Overload
GSF Namespace


BigEndian.ToDouble Method

Grid Solutions Framework BigEndianToDouble Method
Overload List
Name | Description
ToDouble(Byte*) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte, Int32) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToDouble Method (Byte*)

Grid Solutions Framework BigEndianToDouble Method (Byte)
Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ToDouble(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static double ToDouble(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Double
A double-precision floating point number formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToDouble Overload
GSF Namespace


BigEndian.ToDouble Method (Byte[], Int32)

Grid Solutions Framework BigEndianToDouble Method (Byte, Int32)
Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ToDouble(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToDouble (
    buffer As Byte(),
    startIndex As Integer
) As Double
static member ToDouble :
        buffer : byte[] *
        startIndex : int -> float

GSF.BigEndian.ToDouble = function(buffer, startIndex);
public:
static double ToDouble(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Double
A double-precision floating point number formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToDouble Overload
GSF Namespace


BigEndian.ToInt16 Method

Grid Solutions Framework BigEndianToInt16 Method
Overload List
Name | Description
ToInt16(Byte*) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte, Int32) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToInt16 Method (Byte*)

Grid Solutions Framework BigEndianToInt16 Method (Byte)
Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ToInt16(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static short ToInt16(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int16
A 16-bit signed integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt16 Overload
GSF Namespace


BigEndian.ToInt16 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToInt16 Method (Byte, Int32)
Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ToInt16(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt16 (
    buffer As Byte(),
    startIndex As Integer
) As Short
static member ToInt16 :
        buffer : byte[] *
        startIndex : int -> int16

GSF.BigEndian.ToInt16 = function(buffer, startIndex);
public:
static short ToInt16(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int16
A 16-bit signed integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt16 Overload
GSF Namespace


BigEndian.ToInt24 Method

Grid Solutions Framework BigEndianToInt24 Method
Overload List
Name | Description
ToInt24(Byte*) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte, Int32) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToInt24 Method (Byte*)

Grid Solutions Framework BigEndianToInt24 Method (Byte)
Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ToInt24(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static Int24 ToInt24(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int24
A 24-bit signed integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt24 Overload
GSF Namespace


BigEndian.ToInt24 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToInt24 Method (Byte, Int32)
Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ToInt24(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt24 (
    buffer As Byte(),
    startIndex As Integer
) As Int24
static member ToInt24 :
        buffer : byte[] *
        startIndex : int -> Int24

GSF.BigEndian.ToInt24 = function(buffer, startIndex);
public:
static Int24 ToInt24(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int24
A 24-bit signed integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt24 Overload
GSF Namespace


BigEndian.ToInt32 Method

Grid Solutions Framework BigEndianToInt32 Method
Overload List
Name | Description
ToInt32(Byte*) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte, Int32) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToInt32 Method (Byte*)

Grid Solutions Framework BigEndianToInt32 Method (Byte)
Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToInt32(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int ToInt32(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int32
A 32-bit signed integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt32 Overload
GSF Namespace


BigEndian.ToInt32 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToInt32 Method (Byte, Int32)
Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToInt32(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt32 (
    buffer As Byte(),
    startIndex As Integer
) As Integer
static member ToInt32 :
        buffer : byte[] *
        startIndex : int -> int

GSF.BigEndian.ToInt32 = function(buffer, startIndex);
public:
static int ToInt32(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int32
A 32-bit signed integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt32 Overload
GSF Namespace


BigEndian.ToInt64 Method

Grid Solutions Framework BigEndianToInt64 Method
Overload List
Name | Description
ToInt64(Byte*) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte, Int32) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToInt64 Method (Byte*)

Grid Solutions Framework BigEndianToInt64 Method (Byte)
Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ToInt64(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static long long ToInt64(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int64
A 64-bit signed integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt64 Overload
GSF Namespace


BigEndian.ToInt64 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToInt64 Method (Byte, Int32)
Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ToInt64(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt64 (
    buffer As Byte(),
    startIndex As Integer
) As Long
static member ToInt64 :
        buffer : byte[] *
        startIndex : int -> int64

GSF.BigEndian.ToInt64 = function(buffer, startIndex);
public:
static long long ToInt64(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int64
A 64-bit signed integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToInt64 Overload
GSF Namespace


BigEndian.ToSingle Method

Grid Solutions Framework BigEndianToSingle Method
Overload List
Name | Description
ToSingle(Byte*) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte, Int32) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToSingle Method (Byte*)

Grid Solutions Framework BigEndianToSingle Method (Byte)
Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static float ToSingle(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static float ToSingle(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Single
A single-precision floating point number formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToSingle Overload
GSF Namespace


BigEndian.ToSingle Method (Byte[], Int32)

Grid Solutions Framework BigEndianToSingle Method (Byte, Int32)
Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static float ToSingle(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToSingle (
    buffer As Byte(),
    startIndex As Integer
) As Single
static member ToSingle :
        buffer : byte[] *
        startIndex : int -> float32

GSF.BigEndian.ToSingle = function(buffer, startIndex);
public:
static float ToSingle(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Single
A single-precision floating point number formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToSingle Overload
GSF Namespace


BigEndian.ToUInt16 Method

Grid Solutions Framework BigEndianToUInt16 Method
Overload List
Name | Description
ToUInt16(Byte*) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte, Int32) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToUInt16 Method (Byte*)

Grid Solutions Framework BigEndianToUInt16 Method (Byte)
Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ToUInt16(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static unsigned short ToUInt16(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt16
A 16-bit unsigned integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt16 Overload
GSF Namespace


BigEndian.ToUInt16 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToUInt16 Method (Byte, Int32)
Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ToUInt16(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToUInt16 (
    buffer As Byte(),
    startIndex As Integer
) As UShort
static member ToUInt16 :
        buffer : byte[] *
        startIndex : int -> uint16

GSF.BigEndian.ToUInt16 = function(buffer, startIndex);
public:
static unsigned short ToUInt16(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt16
A 16-bit unsigned integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt16 Overload
GSF Namespace


BigEndian.ToUInt24 Method

Grid Solutions Framework BigEndianToUInt24 Method
Overload List
Name | Description
ToUInt24(Byte*) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte, Int32) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToUInt24 Method (Byte*)

Grid Solutions Framework BigEndianToUInt24 Method (Byte)
Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ToUInt24(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static UInt24 ToUInt24(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt24
A 24-bit unsigned integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt24 Overload
GSF Namespace


BigEndian.ToUInt24 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToUInt24 Method (Byte, Int32)
Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ToUInt24(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToUInt24 (
    buffer As Byte(),
    startIndex As Integer
) As UInt24
static member ToUInt24 :
        buffer : byte[] *
        startIndex : int -> UInt24

GSF.BigEndian.ToUInt24 = function(buffer, startIndex);
public:
static UInt24 ToUInt24(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt24
A 24-bit unsigned integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt24 Overload
GSF Namespace


BigEndian.ToUInt32 Method

Grid Solutions Framework BigEndianToUInt32 Method
Overload List
Name | Description
ToUInt32(Byte*) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte, Int32) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToUInt32 Method (Byte*)

Grid Solutions Framework BigEndianToUInt32 Method (Byte)
Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ToUInt32(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static unsigned int ToUInt32(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt32
A 32-bit unsigned integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt32 Overload
GSF Namespace


BigEndian.ToUInt32 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToUInt32 Method (Byte, Int32)
Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ToUInt32(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToUInt32 (
    buffer As Byte(),
    startIndex As Integer
) As UInteger
static member ToUInt32 :
        buffer : byte[] *
        startIndex : int -> uint32

GSF.BigEndian.ToUInt32 = function(buffer, startIndex);
public:
static unsigned int ToUInt32(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt32
A 32-bit unsigned integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt32 Overload
GSF Namespace


BigEndian.ToUInt64 Method

Grid Solutions Framework BigEndianToUInt64 Method
Overload List
Name | Description
ToUInt64(Byte*) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte, Int32) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

BigEndian Class
GSF Namespace


BigEndian.ToUInt64 Method (Byte*)

Grid Solutions Framework BigEndianToUInt64 Method (Byte)
Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ToUInt64(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static unsigned long long ToUInt64(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt64
A 64-bit unsigned integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt64 Overload
GSF Namespace


BigEndian.ToUInt64 Method (Byte[], Int32)

Grid Solutions Framework BigEndianToUInt64 Method (Byte, Int32)
Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ToUInt64(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToUInt64 (
    buffer As Byte(),
    startIndex As Integer
) As ULong
static member ToUInt64 :
        buffer : byte[] *
        startIndex : int -> uint64

GSF.BigEndian.ToUInt64 = function(buffer, startIndex);
public:
static unsigned long long ToUInt64(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt64
A 64-bit unsigned integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

BigEndian Class
ToUInt64 Overload
GSF Namespace


BigEndianOrder Class

Grid Solutions Framework BigEndianOrder Class
Represents a big-endian byte order interoperability class.
Inheritance Hierarchy
SystemObject
GSFEndianOrder
GSFBigEndianOrder

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BigEndianOrder : EndianOrder
Public Class BigEndianOrder
    Inherits EndianOrder
type BigEndianOrder =
    class
        inherit EndianOrder
    end
GSF.BigEndianOrder = function();

Type.createClass(
    'GSF.BigEndianOrder',
    GSF.EndianOrder);
public ref class BigEndianOrder : public EndianOrder

The BigEndianOrder type exposes the following members.

Constructors
 | Name | Description
Public method | BigEndianOrder | Constructs a new instance of the BigEndianOrder class.
Top
Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
 | Default | Returns the default instance of the BigEndianOrder class.
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Top
See Also

Reference

GSF Namespace


BigEndianOrder Constructor

Grid Solutions Framework BigEndianOrder Constructor
Constructs a new instance of the BigEndianOrder class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BigEndianOrder()
Public Sub New
new : unit -> BigEndianOrder
GSF.BigEndianOrder = function();
public:
BigEndianOrder()
See Also

Reference

BigEndianOrder Class
GSF Namespace


BigEndianOrder Methods

Grid Solutions Framework BigEndianOrder Methods

The BigEndianOrder type exposes the following members.

Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BigEndianOrder Class
GSF Namespace


BigEndianOrder Properties

Grid Solutions Framework BigEndianOrder Properties

The BigEndianOrder type exposes the following members.

Properties
 | Name | Description
 | Default | Returns the default instance of the BigEndianOrder class.
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Top
See Also

Reference

BigEndianOrder Class
GSF Namespace


BigEndianOrder.Default Property

Grid Solutions Framework BigEndianOrderDefault Property
Returns the default instance of the BigEndianOrder class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static BigEndianOrder Default { get; }
Public Shared ReadOnly Property Default As BigEndianOrder
    Get
static member Default : BigEndianOrder with get

GSF.BigEndianOrder.get_Default = function();

public:
static property BigEndianOrder^ Default {
    BigEndianOrder^ get ();
}

Property Value

Type: BigEndianOrder
See Also

Reference

BigEndianOrder Class
GSF Namespace


BinaryCodedDecimal Class

Grid Solutions Framework BinaryCodedDecimal Class
Defines functions related to binary-coded decimals.
Inheritance Hierarchy
SystemObject
GSFBinaryCodedDecimal

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class BinaryCodedDecimal
Public NotInheritable Class BinaryCodedDecimal
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BinaryCodedDecimal =  class end
GSF.BinaryCodedDecimal = function();

Type.createClass(
    'GSF.BinaryCodedDecimal');
public ref class BinaryCodedDecimal abstract sealed
Methods
Name | Description
Decode(Byte) | Gets binary value from binary-coded decimal.
Decode(UInt16) | Gets binary value from two-byte binary-coded decimal.
Decode(UInt32) | Gets binary value from four-byte binary-coded decimal.
Decode(UInt64) | Gets binary value from eight-byte binary-coded decimal.
Encode(Byte) | Gets binary-coded decimal from binary value.
Encode(UInt16) | Gets binary-coded decimal from binary value.
Encode(UInt32) | Gets binary-coded decimal from binary value.
Encode(UInt64) | Gets binary-coded decimal from binary value.
Top
Remarks
See Binary-coded decimal for details.
See Also

Reference

GSF Namespace


BinaryCodedDecimal Methods

Grid Solutions Framework BinaryCodedDecimal Methods
Methods
Name | Description
Decode(Byte) | Gets binary value from binary-coded decimal.
Decode(UInt16) | Gets binary value from two-byte binary-coded decimal.
Decode(UInt32) | Gets binary value from four-byte binary-coded decimal.
Decode(UInt64) | Gets binary value from eight-byte binary-coded decimal.
Encode(Byte) | Gets binary-coded decimal from binary value.
Encode(UInt16) | Gets binary-coded decimal from binary value.
Encode(UInt32) | Gets binary-coded decimal from binary value.
Encode(UInt64) | Gets binary-coded decimal from binary value.
Top
See Also

Reference

BinaryCodedDecimal Class
GSF Namespace


BinaryCodedDecimal.Decode Method

Grid Solutions Framework BinaryCodedDecimalDecode Method
Overload List
Name | Description
Decode(Byte) | Gets binary value from binary-coded decimal.
Decode(UInt16) | Gets binary value from two-byte binary-coded decimal.
Decode(UInt32) | Gets binary value from four-byte binary-coded decimal.
Decode(UInt64) | Gets binary value from eight-byte binary-coded decimal.
Top
See Also

Reference

BinaryCodedDecimal Class
GSF Namespace


BinaryCodedDecimal.Decode Method (Byte)

Grid Solutions Framework BinaryCodedDecimalDecode Method (Byte)
Gets binary value from binary-coded decimal.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte Decode(
    byte bcd
)
Public Shared Function Decode (
    bcd As Byte
) As Byte
static member Decode :
        bcd : byte -> byte

GSF.BinaryCodedDecimal.Decode = function(bcd);
public:
static unsigned char Decode(
    unsigned char bcd
)

Parameters

bcd
Type: SystemByte
Binary-coded decimal value.

Return Value

Type: Byte
Standard binary representation of binary-coded decimal value.
See Also

Reference

BinaryCodedDecimal Class
Decode Overload
GSF Namespace


BinaryCodedDecimal.Decode Method (UInt16)

Grid Solutions Framework BinaryCodedDecimalDecode Method (UInt16)
Gets binary value from two-byte binary-coded decimal.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort Decode(
    ushort bcd
)
Public Shared Function Decode (
    bcd As UShort
) As UShort
static member Decode :
        bcd : uint16 -> uint16

GSF.BinaryCodedDecimal.Decode = function(bcd);
public:
static unsigned short Decode(
    unsigned short bcd
)

Parameters

bcd
Type: SystemUInt16
Two-byte binary-coded decimal value.

Return Value

Type: UInt16
Standard binary representation of binary-coded decimal value.
See Also

Reference

BinaryCodedDecimal Class
Decode Overload
GSF Namespace


BinaryCodedDecimal.Decode Method (UInt32)

Grid Solutions Framework BinaryCodedDecimalDecode Method (UInt32)
Gets binary value from four-byte binary-coded decimal.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint Decode(
    uint bcd
)
Public Shared Function Decode (
    bcd As UInteger
) As UInteger
static member Decode :
        bcd : uint32 -> uint32

GSF.BinaryCodedDecimal.Decode = function(bcd);
public:
static unsigned int Decode(
    unsigned int bcd
)

Parameters

bcd
Type: SystemUInt32
Four-byte binary-coded decimal value.

Return Value

Type: UInt32
Standard binary representation of binary-coded decimal value.
See Also

Reference

BinaryCodedDecimal Class
Decode Overload
GSF Namespace


BinaryCodedDecimal.Decode Method (UInt64)

Grid Solutions Framework BinaryCodedDecimalDecode Method (UInt64)
Gets binary value from eight-byte binary-coded decimal.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong Decode(
    ulong bcd
)
Public Shared Function Decode (
    bcd As ULong
) As ULong
static member Decode :
        bcd : uint64 -> uint64

GSF.BinaryCodedDecimal.Decode = function(bcd);
public:
static unsigned long long Decode(
    unsigned long long bcd
)

Parameters

bcd
Type: SystemUInt64
Eight-byte binary-coded decimal value.

Return Value

Type: UInt64
Standard binary representation of binary-coded decimal value.
See Also

Reference

BinaryCodedDecimal Class
Decode Overload
GSF Namespace


BinaryCodedDecimal.Encode Method

Grid Solutions Framework BinaryCodedDecimalEncode Method
Overload List
Name | Description
Encode(Byte) | Gets binary-coded decimal from binary value.
Encode(UInt16) | Gets binary-coded decimal from binary value.
Encode(UInt32) | Gets binary-coded decimal from binary value.
Encode(UInt64) | Gets binary-coded decimal from binary value.
Top
See Also

Reference

BinaryCodedDecimal Class
GSF Namespace


BinaryCodedDecimal.Encode Method (Byte)

Grid Solutions Framework BinaryCodedDecimalEncode Method (Byte)
Gets binary-coded decimal from binary value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte Encode(
    byte value
)
Public Shared Function Encode (
    value As Byte
) As Byte
static member Encode :
        value : byte -> byte

GSF.BinaryCodedDecimal.Encode = function(value);
public:
static unsigned char Encode(
    unsigned char value
)

Parameters

value
Type: SystemByte
Binary value.

Return Value

Type: Byte
Binary-coded decimal representation of standard binary value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A binary-coded decimal has a maximum value of 99 for a single byte.
See Also

Reference

BinaryCodedDecimal Class
Encode Overload
GSF Namespace


BinaryCodedDecimal.Encode Method (UInt16)

Grid Solutions Framework BinaryCodedDecimalEncode Method (UInt16)
Gets binary-coded decimal from binary value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort Encode(
    ushort value
)
Public Shared Function Encode (
    value As UShort
) As UShort
static member Encode :
        value : uint16 -> uint16

GSF.BinaryCodedDecimal.Encode = function(value);
public:
static unsigned short Encode(
    unsigned short value
)

Parameters

value
Type: SystemUInt16
Binary value.

Return Value

Type: UInt16
Binary-coded decimal representation of standard binary value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A binary-coded decimal has a maximum value of 9,999 for two bytes.
See Also

Reference

BinaryCodedDecimal Class
Encode Overload
GSF Namespace


BinaryCodedDecimal.Encode Method (UInt32)

Grid Solutions Framework BinaryCodedDecimalEncode Method (UInt32)
Gets binary-coded decimal from binary value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint Encode(
    uint value
)
Public Shared Function Encode (
    value As UInteger
) As UInteger
static member Encode :
        value : uint32 -> uint32

GSF.BinaryCodedDecimal.Encode = function(value);
public:
static unsigned int Encode(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
Binary value.

Return Value

Type: UInt32
Binary-coded decimal representation of standard binary value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A binary-coded decimal has a maximum value of 99,999,999 for four bytes.
See Also

Reference

BinaryCodedDecimal Class
Encode Overload
GSF Namespace


BinaryCodedDecimal.Encode Method (UInt64)

Grid Solutions Framework BinaryCodedDecimalEncode Method (UInt64)
Gets binary-coded decimal from binary value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong Encode(
    ulong value
)
Public Shared Function Encode (
    value As ULong
) As ULong
static member Encode :
        value : uint64 -> uint64

GSF.BinaryCodedDecimal.Encode = function(value);
public:
static unsigned long long Encode(
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
Binary value.

Return Value

Type: UInt64
Binary-coded decimal representation of standard binary value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | A binary-coded decimal has a maximum value of 9,999,999,999,999,999 for eight bytes.
See Also

Reference

BinaryCodedDecimal Class
Encode Overload
GSF Namespace


BinaryValueBase(TEndianOrder) Class

Grid Solutions Framework BinaryValueBaseTEndianOrder Class
Represents the base class for a binary data sample stored as a byte array, but implicitly castable to most common native types.
Inheritance Hierarchy
SystemObject
GSFBinaryValueBaseTEndianOrder
GSFBigBinaryValue
GSFLittleBinaryValue
GSFNativeBinaryValue

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class BinaryValueBase<TEndianOrder>
where TEndianOrder : EndianOrder

Public MustInherit Class BinaryValueBase(Of TEndianOrder As EndianOrder)
[<AbstractClassAttribute>]
type BinaryValueBase<'TEndianOrder when 'TEndianOrder : EndianOrder> =  class end
JavaScript does not support generic types or methods.
generic<typename TEndianOrder>
where TEndianOrder : EndianOrder
public ref class BinaryValueBase abstract

Type Parameters

TEndianOrder
Type of EndianOrder class used to transpose byte order of derived implementation of BinaryValueBaseTEndianOrder.

The BinaryValueBaseTEndianOrder type exposes the following members.

Constructors
 | Name | Description
Protected method | BinaryValueBaseTEndianOrder | Creates a new binary value from the given byte array.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer.
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
s_endianOrder | EndianOrder instance used to transpose byte order of derived implementation of BinaryValueBaseTEndianOrder.
Top
Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample.
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents.
Top
See Also

Reference

GSF Namespace


BinaryValueBase(TEndianOrder) Constructor

Grid Solutions Framework BinaryValueBaseTEndianOrder Constructor
Creates a new binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected BinaryValueBase(
    TypeCode typeCode,
    byte[] buffer,
    int startIndex,
    int length
)
Protected Sub New (
    typeCode As TypeCode,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        typeCode : TypeCode *
        buffer : byte[] *
        startIndex : int *
        length : int -> BinaryValueBase
GSF.BinaryValueBase = function(typeCode, buffer, startIndex, length);
protected:
BinaryValueBase(
    TypeCode typeCode,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

typeCode
Type: SystemTypeCode
The type code of the native value that the binary value represents.
buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
startIndex
Type: SystemInt32
The offset in the buffer where the data starts.
length
Type: SystemInt32
The number of data bytes that make up the binary value.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null
ArgumentOutOfRangeException | startIndex is outside the range of the buffer -or- length is less than 0 -or- startIndex and length do not specify a valid region in the buffer
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder) Fields

Grid Solutions Framework BinaryValueBaseTEndianOrder Fields

The BinaryValueBaseTEndianOrder generic type exposes the following members.

Fields
Name | Description
s_endianOrder | EndianOrder instance used to transpose byte order of derived implementation of BinaryValueBaseTEndianOrder.
Top
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).s_endianOrder Field

Grid Solutions Framework BinaryValueBaseTEndianOrders_endianOrder Field
EndianOrder instance used to transpose byte order of derived implementation of BinaryValueBaseTEndianOrder.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected static TEndianOrder s_endianOrder
Protected Shared s_endianOrder As TEndianOrder
static val mutable s_endianOrder: 'TEndianOrder
var GSF.BinaryValueBase.s_endianOrder
protected:
static TEndianOrder s_endianOrder

Field Value

Type: TEndianOrder
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder) Methods

Grid Solutions Framework BinaryValueBaseTEndianOrder Methods

The BinaryValueBaseTEndianOrder generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer.
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToByte Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToByte Method
Returns a byte from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte ToByte()
Public Function ToByte As Byte
member ToByte : unit -> byte

function ToByte();
public:
unsigned char ToByte()

Return Value

Type: Byte
A byte from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToDouble Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToDouble Method
Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToDouble()
Public Function ToDouble As Double
member ToDouble : unit -> float

function ToDouble();
public:
double ToDouble()

Return Value

Type: Double
A double-precision floating point number, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToInt16 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToInt16 Method
Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short ToInt16()
Public Function ToInt16 As Short
member ToInt16 : unit -> int16

function ToInt16();
public:
short ToInt16()

Return Value

Type: Int16
A 16-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToInt24 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToInt24 Method
Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Int24 ToInt24()
Public Function ToInt24 As Int24
member ToInt24 : unit -> Int24

function ToInt24();
public:
Int24 ToInt24()

Return Value

Type: Int24
A 24-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToInt32 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToInt32 Method
Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ToInt32()
Public Function ToInt32 As Integer
member ToInt32 : unit -> int

function ToInt32();
public:
int ToInt32()

Return Value

Type: Int32
A 32-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToInt64 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToInt64 Method
Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ToInt64()
Public Function ToInt64 As Long
member ToInt64 : unit -> int64

function ToInt64();
public:
long long ToInt64()

Return Value

Type: Int64
A 64-bit signed integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToSingle Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToSingle Method
Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ToSingle()
Public Function ToSingle As Single
member ToSingle : unit -> float32

function ToSingle();
public:
float ToSingle()

Return Value

Type: Single
A single-precision floating point number, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToUInt16 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToUInt16 Method
Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ToUInt16()
Public Function ToUInt16 As UShort
member ToUInt16 : unit -> uint16

function ToUInt16();
public:
unsigned short ToUInt16()

Return Value

Type: UInt16
A 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToUInt24 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToUInt24 Method
Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UInt24 ToUInt24()
Public Function ToUInt24 As UInt24
member ToUInt24 : unit -> UInt24

function ToUInt24();
public:
UInt24 ToUInt24()

Return Value

Type: UInt24
A 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToUInt32 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToUInt32 Method
Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ToUInt32()
Public Function ToUInt32 As UInteger
member ToUInt32 : unit -> uint32

function ToUInt32();
public:
unsigned int ToUInt32()

Return Value

Type: UInt32
A 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).ToUInt64 Method

Grid Solutions Framework BinaryValueBaseTEndianOrderToUInt64 Method
Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong ToUInt64()
Public Function ToUInt64 As ULong
member ToUInt64 : unit -> uint64

function ToUInt64();
public:
unsigned long long ToUInt64()

Return Value

Type: UInt64
A 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer.
Exceptions
Exception | Condition
InvalidOperationException | Binary value buffer is too small to represent requested type.
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder) Properties

Grid Solutions Framework BinaryValueBaseTEndianOrder Properties

The BinaryValueBaseTEndianOrder generic type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample.
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents.
Top
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).Buffer Property

Grid Solutions Framework BinaryValueBaseTEndianOrderBuffer Property
Gets or sets the binary representation of this data sample.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Buffer { get; set; }
Public Property Buffer As Byte()
    Get
    Set
member Buffer : byte[] with get, set

function get_Buffer();
function set_Buffer(value);
public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BinaryValueBase(TEndianOrder).TypeCode Property

Grid Solutions Framework BinaryValueBaseTEndianOrderTypeCode Property
Gets or sets TypeCode that this binary data sample represents.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode TypeCode { get; set; }
Public Property TypeCode As TypeCode
    Get
    Set
member TypeCode : TypeCode with get, set

function get_TypeCode();
function set_TypeCode(value);
public:
property TypeCode TypeCode {
    TypeCode get ();
    void set (TypeCode value);
}

Property Value

Type: TypeCode
See Also

Reference

BinaryValueBaseTEndianOrder Class
GSF Namespace


BitExtensions Class

Grid Solutions Framework BitExtensions Class
Defines extension methods related to bit operations.
Inheritance Hierarchy
SystemObject
GSFBitExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class BitExtensions
<ExtensionAttribute>
Public NotInheritable Class BitExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BitExtensions =  class end
GSF.BitExtensions = function();

Type.createClass(
    'GSF.BitExtensions');
[ExtensionAttribute]
public ref class BitExtensions abstract sealed

The BitExtensions type exposes the following members.

Methods
Name | Description
BitRotL(Byte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(SByte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Byte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(SByte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitVal | Gets the bit value for the specified bit index (0 - 63).
CheckBits(Byte, Bits) | Determines if specified bits are set.
CheckBits(Byte, Byte) | Determines if specified bits are set.
CheckBits(Int16, Bits) | Determines if specified bits are set.
CheckBits(Int16, Int16) | Determines if specified bits are set.
CheckBits(Int32, Bits) | Determines if specified bits are set.
CheckBits(Int32, Int32) | Determines if specified bits are set.
CheckBits(Int64, Bits) | Determines if specified bits are set.
CheckBits(Int64, Int64) | Determines if specified bits are set.
CheckBits(SByte, Bits) | Determines if specified bits are set.
CheckBits(SByte, SByte) | Determines if specified bits are set.
CheckBits(UInt16, Bits) | Determines if specified bits are set.
CheckBits(UInt16, UInt16) | Determines if specified bits are set.
CheckBits(UInt32, Bits) | Determines if specified bits are set.
CheckBits(UInt32, UInt32) | Determines if specified bits are set.
CheckBits(UInt64, Bits) | Determines if specified bits are set.
CheckBits(UInt64, UInt64) | Determines if specified bits are set.
CheckBits(Int24, Bits) | Determines if specified bits are set.
CheckBits(Int24, Int24) | Determines if specified bits are set.
CheckBits(UInt24, Bits) | Determines if specified bits are set.
CheckBits(UInt24, UInt24) | Determines if specified bits are set.
CheckBits(Byte, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Byte, Byte, Boolean) | Determines if specified bits are set.
CheckBits(Int16, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int16, Int16, Boolean) | Determines if specified bits are set.
CheckBits(Int32, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int32, Int32, Boolean) | Determines if specified bits are set.
CheckBits(Int64, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int64, Int64, Boolean) | Determines if specified bits are set.
CheckBits(SByte, Bits, Boolean) | Determines if specified bits are set.
CheckBits(SByte, SByte, Boolean) | Determines if specified bits are set.
CheckBits(UInt16, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt16, UInt16, Boolean) | Determines if specified bits are set.
CheckBits(UInt32, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt32, UInt32, Boolean) | Determines if specified bits are set.
CheckBits(UInt64, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt64, UInt64, Boolean) | Determines if specified bits are set.
CheckBits(Int24, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int24, Int24, Boolean) | Determines if specified bits are set.
CheckBits(UInt24, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt24, UInt24, Boolean) | Determines if specified bits are set.
ClearBits(Byte, Bits) | Returns value with specified bits cleared.
ClearBits(Byte, Byte) | Returns value with specified bits cleared.
ClearBits(Int16, Bits) | Returns value with specified bits cleared.
ClearBits(Int16, Int16) | Returns value with specified bits cleared.
ClearBits(Int32, Bits) | Returns value with specified bits cleared.
ClearBits(Int32, Int32) | Returns value with specified bits cleared.
ClearBits(Int64, Bits) | Returns value with specified bits cleared.
ClearBits(Int64, Int64) | Returns value with specified bits cleared.
ClearBits(SByte, Bits) | Returns value with specified bits cleared.
ClearBits(SByte, SByte) | Returns value with specified bits cleared.
ClearBits(UInt16, Bits) | Returns value with specified bits cleared.
ClearBits(UInt16, UInt16) | Returns value with specified bits cleared.
ClearBits(UInt32, Bits) | Returns value with specified bits cleared.
ClearBits(UInt32, UInt32) | Returns value with specified bits cleared.
ClearBits(UInt64, Bits) | Returns value with specified bits cleared.
ClearBits(UInt64, UInt64) | Returns value with specified bits cleared.
ClearBits(Int24, Bits) | Returns value with specified bits cleared.
ClearBits(Int24, Int24) | Returns value with specified bits cleared.
ClearBits(UInt24, Bits) | Returns value with specified bits cleared.
ClearBits(UInt24, UInt24) | Returns value with specified bits cleared.
GetMaskedValue(Byte, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Byte, Byte) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int16, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int16, Int16) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int32, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int32, Int32) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int64, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int64, Int64) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(SByte, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(SByte, SByte) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt16, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt16, UInt16) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt32, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt32, UInt32) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt64, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt64, UInt64) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int24, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int24, Int24) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt24, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt24, UInt24) | Returns value stored in the bits represented by the specified bitmask.
SetBits(Byte, Bits) | Returns value with specified bits set.
SetBits(Byte, Byte) | Returns value with specified bits set.
SetBits(Int16, Bits) | Returns value with specified bits set.
SetBits(Int16, Int16) | Returns value with specified bits set.
SetBits(Int32, Bits) | Returns value with specified bits set.
SetBits(Int32, Int32) | Returns value with specified bits set.
SetBits(Int64, Bits) | Returns value with specified bits set.
SetBits(Int64, Int64) | Returns value with specified bits set.
SetBits(SByte, Bits) | Returns value with specified bits set.
SetBits(SByte, SByte) | Returns value with specified bits set.
SetBits(UInt16, Bits) | Returns value with specified bits set.
SetBits(UInt16, UInt16) | Returns value with specified bits set.
SetBits(UInt32, Bits) | Returns value with specified bits set.
SetBits(UInt32, UInt32) | Returns value with specified bits set.
SetBits(UInt64, Bits) | Returns value with specified bits set.
SetBits(UInt64, UInt64) | Returns value with specified bits set.
SetBits(Int24, Bits) | Returns value with specified bits set.
SetBits(Int24, Int24) | Returns value with specified bits set.
SetBits(UInt24, Bits) | Returns value with specified bits set.
SetBits(UInt24, UInt24) | Returns value with specified bits set.
SetMaskedValue(Byte, Bits, Byte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Byte, Byte, Byte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int16, Bits, Int16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int16, Int16, Int16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int32, Bits, Int32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int32, Int32, Int32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int64, Bits, Int64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int64, Int64, Int64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(SByte, Bits, SByte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(SByte, SByte, SByte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt16, Bits, UInt16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt16, UInt16, UInt16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt32, Bits, UInt32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt32, UInt32, UInt32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt64, Bits, UInt64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt64, UInt64, UInt64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int24, Bits, Int24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int24, Int24, Int24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt24, Bits, UInt24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt24, UInt24, UInt24) | Returns value after setting a new value for the bits specified by the bitmask.
ToggleBits(Byte, Bits) | Returns value with specified bits toggled.
ToggleBits(Byte, Byte) | Returns value with specified bits toggled.
ToggleBits(Int16, Bits) | Returns value with specified bits toggled.
ToggleBits(Int16, Int16) | Returns value with specified bits toggled.
ToggleBits(Int32, Bits) | Returns value with specified bits toggled.
ToggleBits(Int32, Int32) | Returns value with specified bits toggled.
ToggleBits(Int64, Bits) | Returns value with specified bits toggled.
ToggleBits(Int64, Int64) | Returns value with specified bits toggled.
ToggleBits(SByte, Bits) | Returns value with specified bits toggled.
ToggleBits(SByte, SByte) | Returns value with specified bits toggled.
ToggleBits(UInt16, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt16, UInt16) | Returns value with specified bits toggled.
ToggleBits(UInt32, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt32, UInt32) | Returns value with specified bits toggled.
ToggleBits(UInt64, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt64, UInt64) | Returns value with specified bits toggled.
ToggleBits(Int24, Bits) | Returns value with specified bits toggled.
ToggleBits(Int24, Int24) | Returns value with specified bits toggled.
ToggleBits(UInt24, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt24, UInt24) | Returns value with specified bits toggled.
Top
See Also

Reference

GSF Namespace


BitExtensions Methods

Grid Solutions Framework BitExtensions Methods

The BitExtensions type exposes the following members.

Methods
Name | Description
BitRotL(Byte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(SByte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Byte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(SByte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitVal | Gets the bit value for the specified bit index (0 - 63).
CheckBits(Byte, Bits) | Determines if specified bits are set.
CheckBits(Byte, Byte) | Determines if specified bits are set.
CheckBits(Int16, Bits) | Determines if specified bits are set.
CheckBits(Int16, Int16) | Determines if specified bits are set.
CheckBits(Int32, Bits) | Determines if specified bits are set.
CheckBits(Int32, Int32) | Determines if specified bits are set.
CheckBits(Int64, Bits) | Determines if specified bits are set.
CheckBits(Int64, Int64) | Determines if specified bits are set.
CheckBits(SByte, Bits) | Determines if specified bits are set.
CheckBits(SByte, SByte) | Determines if specified bits are set.
CheckBits(UInt16, Bits) | Determines if specified bits are set.
CheckBits(UInt16, UInt16) | Determines if specified bits are set.
CheckBits(UInt32, Bits) | Determines if specified bits are set.
CheckBits(UInt32, UInt32) | Determines if specified bits are set.
CheckBits(UInt64, Bits) | Determines if specified bits are set.
CheckBits(UInt64, UInt64) | Determines if specified bits are set.
CheckBits(Int24, Bits) | Determines if specified bits are set.
CheckBits(Int24, Int24) | Determines if specified bits are set.
CheckBits(UInt24, Bits) | Determines if specified bits are set.
CheckBits(UInt24, UInt24) | Determines if specified bits are set.
CheckBits(Byte, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Byte, Byte, Boolean) | Determines if specified bits are set.
CheckBits(Int16, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int16, Int16, Boolean) | Determines if specified bits are set.
CheckBits(Int32, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int32, Int32, Boolean) | Determines if specified bits are set.
CheckBits(Int64, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int64, Int64, Boolean) | Determines if specified bits are set.
CheckBits(SByte, Bits, Boolean) | Determines if specified bits are set.
CheckBits(SByte, SByte, Boolean) | Determines if specified bits are set.
CheckBits(UInt16, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt16, UInt16, Boolean) | Determines if specified bits are set.
CheckBits(UInt32, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt32, UInt32, Boolean) | Determines if specified bits are set.
CheckBits(UInt64, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt64, UInt64, Boolean) | Determines if specified bits are set.
CheckBits(Int24, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int24, Int24, Boolean) | Determines if specified bits are set.
CheckBits(UInt24, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt24, UInt24, Boolean) | Determines if specified bits are set.
ClearBits(Byte, Bits) | Returns value with specified bits cleared.
ClearBits(Byte, Byte) | Returns value with specified bits cleared.
ClearBits(Int16, Bits) | Returns value with specified bits cleared.
ClearBits(Int16, Int16) | Returns value with specified bits cleared.
ClearBits(Int32, Bits) | Returns value with specified bits cleared.
ClearBits(Int32, Int32) | Returns value with specified bits cleared.
ClearBits(Int64, Bits) | Returns value with specified bits cleared.
ClearBits(Int64, Int64) | Returns value with specified bits cleared.
ClearBits(SByte, Bits) | Returns value with specified bits cleared.
ClearBits(SByte, SByte) | Returns value with specified bits cleared.
ClearBits(UInt16, Bits) | Returns value with specified bits cleared.
ClearBits(UInt16, UInt16) | Returns value with specified bits cleared.
ClearBits(UInt32, Bits) | Returns value with specified bits cleared.
ClearBits(UInt32, UInt32) | Returns value with specified bits cleared.
ClearBits(UInt64, Bits) | Returns value with specified bits cleared.
ClearBits(UInt64, UInt64) | Returns value with specified bits cleared.
ClearBits(Int24, Bits) | Returns value with specified bits cleared.
ClearBits(Int24, Int24) | Returns value with specified bits cleared.
ClearBits(UInt24, Bits) | Returns value with specified bits cleared.
ClearBits(UInt24, UInt24) | Returns value with specified bits cleared.
GetMaskedValue(Byte, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Byte, Byte) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int16, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int16, Int16) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int32, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int32, Int32) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int64, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int64, Int64) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(SByte, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(SByte, SByte) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt16, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt16, UInt16) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt32, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt32, UInt32) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt64, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt64, UInt64) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int24, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int24, Int24) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt24, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt24, UInt24) | Returns value stored in the bits represented by the specified bitmask.
SetBits(Byte, Bits) | Returns value with specified bits set.
SetBits(Byte, Byte) | Returns value with specified bits set.
SetBits(Int16, Bits) | Returns value with specified bits set.
SetBits(Int16, Int16) | Returns value with specified bits set.
SetBits(Int32, Bits) | Returns value with specified bits set.
SetBits(Int32, Int32) | Returns value with specified bits set.
SetBits(Int64, Bits) | Returns value with specified bits set.
SetBits(Int64, Int64) | Returns value with specified bits set.
SetBits(SByte, Bits) | Returns value with specified bits set.
SetBits(SByte, SByte) | Returns value with specified bits set.
SetBits(UInt16, Bits) | Returns value with specified bits set.
SetBits(UInt16, UInt16) | Returns value with specified bits set.
SetBits(UInt32, Bits) | Returns value with specified bits set.
SetBits(UInt32, UInt32) | Returns value with specified bits set.
SetBits(UInt64, Bits) | Returns value with specified bits set.
SetBits(UInt64, UInt64) | Returns value with specified bits set.
SetBits(Int24, Bits) | Returns value with specified bits set.
SetBits(Int24, Int24) | Returns value with specified bits set.
SetBits(UInt24, Bits) | Returns value with specified bits set.
SetBits(UInt24, UInt24) | Returns value with specified bits set.
SetMaskedValue(Byte, Bits, Byte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Byte, Byte, Byte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int16, Bits, Int16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int16, Int16, Int16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int32, Bits, Int32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int32, Int32, Int32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int64, Bits, Int64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int64, Int64, Int64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(SByte, Bits, SByte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(SByte, SByte, SByte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt16, Bits, UInt16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt16, UInt16, UInt16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt32, Bits, UInt32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt32, UInt32, UInt32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt64, Bits, UInt64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt64, UInt64, UInt64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int24, Bits, Int24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int24, Int24, Int24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt24, Bits, UInt24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt24, UInt24, UInt24) | Returns value after setting a new value for the bits specified by the bitmask.
ToggleBits(Byte, Bits) | Returns value with specified bits toggled.
ToggleBits(Byte, Byte) | Returns value with specified bits toggled.
ToggleBits(Int16, Bits) | Returns value with specified bits toggled.
ToggleBits(Int16, Int16) | Returns value with specified bits toggled.
ToggleBits(Int32, Bits) | Returns value with specified bits toggled.
ToggleBits(Int32, Int32) | Returns value with specified bits toggled.
ToggleBits(Int64, Bits) | Returns value with specified bits toggled.
ToggleBits(Int64, Int64) | Returns value with specified bits toggled.
ToggleBits(SByte, Bits) | Returns value with specified bits toggled.
ToggleBits(SByte, SByte) | Returns value with specified bits toggled.
ToggleBits(UInt16, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt16, UInt16) | Returns value with specified bits toggled.
ToggleBits(UInt32, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt32, UInt32) | Returns value with specified bits toggled.
ToggleBits(UInt64, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt64, UInt64) | Returns value with specified bits toggled.
ToggleBits(Int24, Bits) | Returns value with specified bits toggled.
ToggleBits(Int24, Int24) | Returns value with specified bits toggled.
ToggleBits(UInt24, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt24, UInt24) | Returns value with specified bits toggled.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.BitRotL Method

Grid Solutions Framework BitExtensionsBitRotL Method
Overload List
Name | Description
BitRotL(Byte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(SByte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(Int24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotL(UInt24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.BitRotL Method (Byte, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (Byte, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte BitRotL(
    this byte value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As Byte,
    rotations As Integer
) As Byte
static member BitRotL :
        value : byte *
        rotations : int -> byte

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned char BitRotL(
    unsigned char value,
    int rotations
)

Parameters

value
Type: SystemByte
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Byte
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (Int16, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (Int16, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short BitRotL(
    this short value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As Short,
    rotations As Integer
) As Short
static member BitRotL :
        value : int16 *
        rotations : int -> int16

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static short BitRotL(
    short value,
    int rotations
)

Parameters

value
Type: SystemInt16
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int16
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (Int32, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (Int32, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int BitRotL(
    this int value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As Integer,
    rotations As Integer
) As Integer
static member BitRotL :
        value : int *
        rotations : int -> int

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static int BitRotL(
    int value,
    int rotations
)

Parameters

value
Type: SystemInt32
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int32
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (Int64, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (Int64, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long BitRotL(
    this long value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As Long,
    rotations As Integer
) As Long
static member BitRotL :
        value : int64 *
        rotations : int -> int64

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static long long BitRotL(
    long long value,
    int rotations
)

Parameters

value
Type: SystemInt64
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int64
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (SByte, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (SByte, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte BitRotL(
    this sbyte value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As SByte,
    rotations As Integer
) As SByte
static member BitRotL :
        value : sbyte *
        rotations : int -> sbyte

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static signed char BitRotL(
    signed char value,
    int rotations
)

Parameters

value
Type: SystemSByte
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: SByte
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (UInt16, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (UInt16, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort BitRotL(
    this ushort value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As UShort,
    rotations As Integer
) As UShort
static member BitRotL :
        value : uint16 *
        rotations : int -> uint16

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned short BitRotL(
    unsigned short value,
    int rotations
)

Parameters

value
Type: SystemUInt16
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt16
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (UInt32, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (UInt32, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint BitRotL(
    this uint value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As UInteger,
    rotations As Integer
) As UInteger
static member BitRotL :
        value : uint32 *
        rotations : int -> uint32

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned int BitRotL(
    unsigned int value,
    int rotations
)

Parameters

value
Type: SystemUInt32
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt32
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (UInt64, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (UInt64, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong BitRotL(
    this ulong value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As ULong,
    rotations As Integer
) As ULong
static member BitRotL :
        value : uint64 *
        rotations : int -> uint64

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned long long BitRotL(
    unsigned long long value,
    int rotations
)

Parameters

value
Type: SystemUInt64
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt64
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (Int24, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (Int24, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 BitRotL(
    this Int24 value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As Int24,
    rotations As Integer
) As Int24
static member BitRotL :
        value : Int24 *
        rotations : int -> Int24

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static Int24 BitRotL(
    Int24 value,
    int rotations
)

Parameters

value
Type: GSFInt24
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int24
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotL Method (UInt24, Int32)

Grid Solutions Framework BitExtensionsBitRotL Method (UInt24, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 BitRotL(
    this UInt24 value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotL (
    value As UInt24,
    rotations As Integer
) As UInt24
static member BitRotL :
        value : UInt24 *
        rotations : int -> UInt24

GSF.BitExtensions.BitRotL = function(value, rotations);
public:
[ExtensionAttribute]
static UInt24 BitRotL(
    UInt24 value,
    int rotations
)

Parameters

value
Type: GSFUInt24
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt24
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate right on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotL Overload
GSF Namespace


BitExtensions.BitRotR Method

Grid Solutions Framework BitExtensionsBitRotR Method
Overload List
Name | Description
BitRotR(Byte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(SByte, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt16, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt32, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt64, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(Int24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
BitRotR(UInt24, Int32) | Performs rightwise bit-rotation for the specified number of rotations.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.BitRotR Method (Byte, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (Byte, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte BitRotR(
    this byte value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As Byte,
    rotations As Integer
) As Byte
static member BitRotR :
        value : byte *
        rotations : int -> byte

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned char BitRotR(
    unsigned char value,
    int rotations
)

Parameters

value
Type: SystemByte
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Byte
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (Int16, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (Int16, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short BitRotR(
    this short value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As Short,
    rotations As Integer
) As Short
static member BitRotR :
        value : int16 *
        rotations : int -> int16

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static short BitRotR(
    short value,
    int rotations
)

Parameters

value
Type: SystemInt16
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int16
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (Int32, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (Int32, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int BitRotR(
    this int value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As Integer,
    rotations As Integer
) As Integer
static member BitRotR :
        value : int *
        rotations : int -> int

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static int BitRotR(
    int value,
    int rotations
)

Parameters

value
Type: SystemInt32
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int32
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (Int64, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (Int64, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long BitRotR(
    this long value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As Long,
    rotations As Integer
) As Long
static member BitRotR :
        value : int64 *
        rotations : int -> int64

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static long long BitRotR(
    long long value,
    int rotations
)

Parameters

value
Type: SystemInt64
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int64
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (SByte, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (SByte, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte BitRotR(
    this sbyte value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As SByte,
    rotations As Integer
) As SByte
static member BitRotR :
        value : sbyte *
        rotations : int -> sbyte

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static signed char BitRotR(
    signed char value,
    int rotations
)

Parameters

value
Type: SystemSByte
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: SByte
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (UInt16, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (UInt16, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort BitRotR(
    this ushort value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As UShort,
    rotations As Integer
) As UShort
static member BitRotR :
        value : uint16 *
        rotations : int -> uint16

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned short BitRotR(
    unsigned short value,
    int rotations
)

Parameters

value
Type: SystemUInt16
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt16
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (UInt32, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (UInt32, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint BitRotR(
    this uint value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As UInteger,
    rotations As Integer
) As UInteger
static member BitRotR :
        value : uint32 *
        rotations : int -> uint32

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned int BitRotR(
    unsigned int value,
    int rotations
)

Parameters

value
Type: SystemUInt32
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt32
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (UInt64, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (UInt64, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong BitRotR(
    this ulong value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As ULong,
    rotations As Integer
) As ULong
static member BitRotR :
        value : uint64 *
        rotations : int -> uint64

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static unsigned long long BitRotR(
    unsigned long long value,
    int rotations
)

Parameters

value
Type: SystemUInt64
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt64
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (Int24, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (Int24, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 BitRotR(
    this Int24 value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As Int24,
    rotations As Integer
) As Int24
static member BitRotR :
        value : Int24 *
        rotations : int -> Int24

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static Int24 BitRotR(
    Int24 value,
    int rotations
)

Parameters

value
Type: GSFInt24
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: Int24
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitRotR Method (UInt24, Int32)

Grid Solutions Framework BitExtensionsBitRotR Method (UInt24, Int32)
Performs rightwise bit-rotation for the specified number of rotations.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 BitRotR(
    this UInt24 value,
    int rotations
)
<ExtensionAttribute>
Public Shared Function BitRotR (
    value As UInt24,
    rotations As Integer
) As UInt24
static member BitRotR :
        value : UInt24 *
        rotations : int -> UInt24

GSF.BitExtensions.BitRotR = function(value, rotations);
public:
[ExtensionAttribute]
static UInt24 BitRotR(
    UInt24 value,
    int rotations
)

Parameters

value
Type: GSFUInt24
Value used for bit-rotation.
rotations
Type: SystemInt32
Number of rotations to perform.

Return Value

Type: UInt24
Value that has its bits rotated to the right the specified number of times.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Actual rotation direction is from a big-endian perspective - this is an artifact of the native .NET bit shift operators. As a result bits may actually appear to rotate left on little-endian architectures.
See Also

Reference

BitExtensions Class
BitRotR Overload
GSF Namespace


BitExtensions.BitVal Method

Grid Solutions Framework BitExtensionsBitVal Method
Gets the bit value for the specified bit index (0 - 63).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bits BitVal(
    int bit
)
Public Shared Function BitVal (
    bit As Integer
) As Bits
static member BitVal :
        bit : int -> Bits

GSF.BitExtensions.BitVal = function(bit);
public:
static Bits BitVal(
    int bit
)

Parameters

bit
Type: SystemInt32
Bit index (0 - 63)

Return Value

Type: Bits
Value of the specified bit.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Parameter must be between 0 and 63.
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.CheckBits Method

Grid Solutions Framework BitExtensionsCheckBits Method
Overload List
Name | Description
CheckBits(Byte, Bits) | Determines if specified bits are set.
CheckBits(Byte, Byte) | Determines if specified bits are set.
CheckBits(Int16, Bits) | Determines if specified bits are set.
CheckBits(Int16, Int16) | Determines if specified bits are set.
CheckBits(Int32, Bits) | Determines if specified bits are set.
CheckBits(Int32, Int32) | Determines if specified bits are set.
CheckBits(Int64, Bits) | Determines if specified bits are set.
CheckBits(Int64, Int64) | Determines if specified bits are set.
CheckBits(SByte, Bits) | Determines if specified bits are set.
CheckBits(SByte, SByte) | Determines if specified bits are set.
CheckBits(UInt16, Bits) | Determines if specified bits are set.
CheckBits(UInt16, UInt16) | Determines if specified bits are set.
CheckBits(UInt32, Bits) | Determines if specified bits are set.
CheckBits(UInt32, UInt32) | Determines if specified bits are set.
CheckBits(UInt64, Bits) | Determines if specified bits are set.
CheckBits(UInt64, UInt64) | Determines if specified bits are set.
CheckBits(Int24, Bits) | Determines if specified bits are set.
CheckBits(Int24, Int24) | Determines if specified bits are set.
CheckBits(UInt24, Bits) | Determines if specified bits are set.
CheckBits(UInt24, UInt24) | Determines if specified bits are set.
CheckBits(Byte, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Byte, Byte, Boolean) | Determines if specified bits are set.
CheckBits(Int16, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int16, Int16, Boolean) | Determines if specified bits are set.
CheckBits(Int32, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int32, Int32, Boolean) | Determines if specified bits are set.
CheckBits(Int64, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int64, Int64, Boolean) | Determines if specified bits are set.
CheckBits(SByte, Bits, Boolean) | Determines if specified bits are set.
CheckBits(SByte, SByte, Boolean) | Determines if specified bits are set.
CheckBits(UInt16, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt16, UInt16, Boolean) | Determines if specified bits are set.
CheckBits(UInt32, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt32, UInt32, Boolean) | Determines if specified bits are set.
CheckBits(UInt64, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt64, UInt64, Boolean) | Determines if specified bits are set.
CheckBits(Int24, Bits, Boolean) | Determines if specified bits are set.
CheckBits(Int24, Int24, Boolean) | Determines if specified bits are set.
CheckBits(UInt24, Bits, Boolean) | Determines if specified bits are set.
CheckBits(UInt24, UInt24, Boolean) | Determines if specified bits are set.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.CheckBits Method (Byte, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (Byte, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this byte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Byte,
    bits As Bits
) As Boolean
static member CheckBits :
        source : byte *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned char source,
    Bits bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Byte, Byte)

Grid Solutions Framework BitExtensionsCheckBits Method (Byte, Byte)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this byte source,
    byte bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Byte,
    bits As Byte
) As Boolean
static member CheckBits :
        source : byte *
        bits : byte -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned char source,
    unsigned char bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: SystemByte
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int16, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (Int16, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this short source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Short,
    bits As Bits
) As Boolean
static member CheckBits :
        source : int16 *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    short source,
    Bits bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int16, Int16)

Grid Solutions Framework BitExtensionsCheckBits Method (Int16, Int16)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this short source,
    short bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Short,
    bits As Short
) As Boolean
static member CheckBits :
        source : int16 *
        bits : int16 -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    short source,
    short bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: SystemInt16
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int32, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (Int32, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this int source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Integer,
    bits As Bits
) As Boolean
static member CheckBits :
        source : int *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    int source,
    Bits bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int32, Int32)

Grid Solutions Framework BitExtensionsCheckBits Method (Int32, Int32)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this int source,
    int bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Integer,
    bits As Integer
) As Boolean
static member CheckBits :
        source : int *
        bits : int -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    int source,
    int bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: SystemInt32
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int64, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (Int64, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this long source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Long,
    bits As Bits
) As Boolean
static member CheckBits :
        source : int64 *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    long long source,
    Bits bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int64, Int64)

Grid Solutions Framework BitExtensionsCheckBits Method (Int64, Int64)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this long source,
    long bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Long,
    bits As Long
) As Boolean
static member CheckBits :
        source : int64 *
        bits : int64 -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    long long source,
    long long bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: SystemInt64
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (SByte, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (SByte, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this sbyte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As SByte,
    bits As Bits
) As Boolean
static member CheckBits :
        source : sbyte *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    signed char source,
    Bits bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (SByte, SByte)

Grid Solutions Framework BitExtensionsCheckBits Method (SByte, SByte)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this sbyte source,
    sbyte bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As SByte,
    bits As SByte
) As Boolean
static member CheckBits :
        source : sbyte *
        bits : sbyte -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    signed char source,
    signed char bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: SystemSByte
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt16, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt16, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ushort source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UShort,
    bits As Bits
) As Boolean
static member CheckBits :
        source : uint16 *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned short source,
    Bits bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt16, UInt16)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt16, UInt16)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ushort source,
    ushort bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UShort,
    bits As UShort
) As Boolean
static member CheckBits :
        source : uint16 *
        bits : uint16 -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned short source,
    unsigned short bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: SystemUInt16
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt32, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt32, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this uint source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInteger,
    bits As Bits
) As Boolean
static member CheckBits :
        source : uint32 *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned int source,
    Bits bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt32, UInt32)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt32, UInt32)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this uint source,
    uint bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInteger,
    bits As UInteger
) As Boolean
static member CheckBits :
        source : uint32 *
        bits : uint32 -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned int source,
    unsigned int bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: SystemUInt32
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt64, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt64, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ulong source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As ULong,
    bits As Bits
) As Boolean
static member CheckBits :
        source : uint64 *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned long long source,
    Bits bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt64, UInt64)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt64, UInt64)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ulong source,
    ulong bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As ULong,
    bits As ULong
) As Boolean
static member CheckBits :
        source : uint64 *
        bits : uint64 -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned long long source,
    unsigned long long bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: SystemUInt64
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int24, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (Int24, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this Int24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Int24,
    bits As Bits
) As Boolean
static member CheckBits :
        source : Int24 *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    Int24 source,
    Bits bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int24, Int24)

Grid Solutions Framework BitExtensionsCheckBits Method (Int24, Int24)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this Int24 source,
    Int24 bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Int24,
    bits As Int24
) As Boolean
static member CheckBits :
        source : Int24 *
        bits : Int24 -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    Int24 source,
    Int24 bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFInt24
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt24, Bits)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt24, Bits)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this UInt24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInt24,
    bits As Bits
) As Boolean
static member CheckBits :
        source : UInt24 *
        bits : Bits -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    UInt24 source,
    Bits bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFBits
Bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt24, UInt24)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt24, UInt24)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this UInt24 source,
    UInt24 bits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInt24,
    bits As UInt24
) As Boolean
static member CheckBits :
        source : UInt24 *
        bits : UInt24 -> bool

GSF.BitExtensions.CheckBits = function(source, bits);
public:
[ExtensionAttribute]
static bool CheckBits(
    UInt24 source,
    UInt24 bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFUInt24
Bit-mask of the bits to check.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Byte, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Byte, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this byte source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Byte,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : byte *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned char source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Byte, Byte, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Byte, Byte, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this byte source,
    byte bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Byte,
    bits As Byte,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : byte *
        bits : byte *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned char source,
    unsigned char bits,
    bool allBits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: SystemByte
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int16, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int16, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this short source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Short,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : int16 *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    short source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int16, Int16, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int16, Int16, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this short source,
    short bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Short,
    bits As Short,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : int16 *
        bits : int16 *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    short source,
    short bits,
    bool allBits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: SystemInt16
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int32, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int32, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this int source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Integer,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : int *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    int source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int32, Int32, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int32, Int32, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this int source,
    int bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Integer,
    bits As Integer,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : int *
        bits : int *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    int source,
    int bits,
    bool allBits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: SystemInt32
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int64, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int64, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this long source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Long,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : int64 *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    long long source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int64, Int64, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int64, Int64, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this long source,
    long bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Long,
    bits As Long,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : int64 *
        bits : int64 *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    long long source,
    long long bits,
    bool allBits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: SystemInt64
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (SByte, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (SByte, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this sbyte source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As SByte,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : sbyte *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    signed char source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (SByte, SByte, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (SByte, SByte, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this sbyte source,
    sbyte bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As SByte,
    bits As SByte,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : sbyte *
        bits : sbyte *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    signed char source,
    signed char bits,
    bool allBits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: SystemSByte
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt16, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt16, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ushort source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UShort,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : uint16 *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned short source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt16, UInt16, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt16, UInt16, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ushort source,
    ushort bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UShort,
    bits As UShort,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : uint16 *
        bits : uint16 *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned short source,
    unsigned short bits,
    bool allBits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: SystemUInt16
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt32, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt32, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this uint source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInteger,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : uint32 *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned int source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt32, UInt32, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt32, UInt32, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this uint source,
    uint bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInteger,
    bits As UInteger,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : uint32 *
        bits : uint32 *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned int source,
    unsigned int bits,
    bool allBits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: SystemUInt32
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt64, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt64, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ulong source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As ULong,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : uint64 *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned long long source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt64, UInt64, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt64, UInt64, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this ulong source,
    ulong bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As ULong,
    bits As ULong,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : uint64 *
        bits : uint64 *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    unsigned long long source,
    unsigned long long bits,
    bool allBits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: SystemUInt64
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int24, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int24, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this Int24 source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Int24,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : Int24 *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    Int24 source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (Int24, Int24, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (Int24, Int24, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this Int24 source,
    Int24 bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As Int24,
    bits As Int24,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : Int24 *
        bits : Int24 *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    Int24 source,
    Int24 bits,
    bool allBits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFInt24
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt24, Bits, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt24, Bits, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this UInt24 source,
    Bits bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInt24,
    bits As Bits,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : UInt24 *
        bits : Bits *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    UInt24 source,
    Bits bits,
    bool allBits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFBits
Bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.CheckBits Method (UInt24, UInt24, Boolean)

Grid Solutions Framework BitExtensionsCheckBits Method (UInt24, UInt24, Boolean)
Determines if specified bits are set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CheckBits(
    this UInt24 source,
    UInt24 bits,
    bool allBits
)
<ExtensionAttribute>
Public Shared Function CheckBits (
    source As UInt24,
    bits As UInt24,
    allBits As Boolean
) As Boolean
static member CheckBits :
        source : UInt24 *
        bits : UInt24 *
        allBits : bool -> bool

GSF.BitExtensions.CheckBits = function(source, bits, allBits);
public:
[ExtensionAttribute]
static bool CheckBits(
    UInt24 source,
    UInt24 bits,
    bool allBits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFUInt24
Bit-mask of the bits to check.
allBits
Type: SystemBoolean
true to check if all bits are set; otherwise false.

Return Value

Type: Boolean
true if specified bits are set in source value; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
CheckBits Overload
GSF Namespace


BitExtensions.ClearBits Method

Grid Solutions Framework BitExtensionsClearBits Method
Overload List
Name | Description
ClearBits(Byte, Bits) | Returns value with specified bits cleared.
ClearBits(Byte, Byte) | Returns value with specified bits cleared.
ClearBits(Int16, Bits) | Returns value with specified bits cleared.
ClearBits(Int16, Int16) | Returns value with specified bits cleared.
ClearBits(Int32, Bits) | Returns value with specified bits cleared.
ClearBits(Int32, Int32) | Returns value with specified bits cleared.
ClearBits(Int64, Bits) | Returns value with specified bits cleared.
ClearBits(Int64, Int64) | Returns value with specified bits cleared.
ClearBits(SByte, Bits) | Returns value with specified bits cleared.
ClearBits(SByte, SByte) | Returns value with specified bits cleared.
ClearBits(UInt16, Bits) | Returns value with specified bits cleared.
ClearBits(UInt16, UInt16) | Returns value with specified bits cleared.
ClearBits(UInt32, Bits) | Returns value with specified bits cleared.
ClearBits(UInt32, UInt32) | Returns value with specified bits cleared.
ClearBits(UInt64, Bits) | Returns value with specified bits cleared.
ClearBits(UInt64, UInt64) | Returns value with specified bits cleared.
ClearBits(Int24, Bits) | Returns value with specified bits cleared.
ClearBits(Int24, Int24) | Returns value with specified bits cleared.
ClearBits(UInt24, Bits) | Returns value with specified bits cleared.
ClearBits(UInt24, UInt24) | Returns value with specified bits cleared.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.ClearBits Method (Byte, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (Byte, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte ClearBits(
    this byte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Byte,
    bits As Bits
) As Byte
static member ClearBits :
        source : byte *
        bits : Bits -> byte

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned char ClearBits(
    unsigned char source,
    Bits bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: Byte
Byte value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Byte, Byte)

Grid Solutions Framework BitExtensionsClearBits Method (Byte, Byte)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte ClearBits(
    this byte source,
    byte bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Byte,
    bits As Byte
) As Byte
static member ClearBits :
        source : byte *
        bits : byte -> byte

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned char ClearBits(
    unsigned char source,
    unsigned char bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: SystemByte
Bit-mask of the bits to clear.

Return Value

Type: Byte
Byte value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int16, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (Int16, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ClearBits(
    this short source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Short,
    bits As Bits
) As Short
static member ClearBits :
        source : int16 *
        bits : Bits -> int16

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static short ClearBits(
    short source,
    Bits bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: Int16
Int16 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int16, Int16)

Grid Solutions Framework BitExtensionsClearBits Method (Int16, Int16)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ClearBits(
    this short source,
    short bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Short,
    bits As Short
) As Short
static member ClearBits :
        source : int16 *
        bits : int16 -> int16

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static short ClearBits(
    short source,
    short bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: SystemInt16
Bit-mask of the bits to clear.

Return Value

Type: Int16
Int16 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int32, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (Int32, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ClearBits(
    this int source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Integer,
    bits As Bits
) As Integer
static member ClearBits :
        source : int *
        bits : Bits -> int

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static int ClearBits(
    int source,
    Bits bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: Int32
Int32 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int32, Int32)

Grid Solutions Framework BitExtensionsClearBits Method (Int32, Int32)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ClearBits(
    this int source,
    int bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Integer,
    bits As Integer
) As Integer
static member ClearBits :
        source : int *
        bits : int -> int

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static int ClearBits(
    int source,
    int bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: SystemInt32
Bit-mask of the bits to clear.

Return Value

Type: Int32
Int32 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int64, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (Int64, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ClearBits(
    this long source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Long,
    bits As Bits
) As Long
static member ClearBits :
        source : int64 *
        bits : Bits -> int64

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static long long ClearBits(
    long long source,
    Bits bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: Int64
Int64 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int64, Int64)

Grid Solutions Framework BitExtensionsClearBits Method (Int64, Int64)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ClearBits(
    this long source,
    long bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Long,
    bits As Long
) As Long
static member ClearBits :
        source : int64 *
        bits : int64 -> int64

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static long long ClearBits(
    long long source,
    long long bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: SystemInt64
Bit-mask of the bits to clear.

Return Value

Type: Int64
Int64 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (SByte, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (SByte, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte ClearBits(
    this sbyte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As SByte,
    bits As Bits
) As SByte
static member ClearBits :
        source : sbyte *
        bits : Bits -> sbyte

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static signed char ClearBits(
    signed char source,
    Bits bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: SByte
SByte value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (SByte, SByte)

Grid Solutions Framework BitExtensionsClearBits Method (SByte, SByte)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte ClearBits(
    this sbyte source,
    sbyte bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As SByte,
    bits As SByte
) As SByte
static member ClearBits :
        source : sbyte *
        bits : sbyte -> sbyte

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static signed char ClearBits(
    signed char source,
    signed char bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: SystemSByte
Bit-mask of the bits to clear.

Return Value

Type: SByte
SByte value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt16, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (UInt16, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ClearBits(
    this ushort source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As UShort,
    bits As Bits
) As UShort
static member ClearBits :
        source : uint16 *
        bits : Bits -> uint16

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned short ClearBits(
    unsigned short source,
    Bits bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: UInt16
UInt16 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt16, UInt16)

Grid Solutions Framework BitExtensionsClearBits Method (UInt16, UInt16)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ClearBits(
    this ushort source,
    ushort bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As UShort,
    bits As UShort
) As UShort
static member ClearBits :
        source : uint16 *
        bits : uint16 -> uint16

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned short ClearBits(
    unsigned short source,
    unsigned short bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: SystemUInt16
Bit-mask of the bits to clear.

Return Value

Type: UInt16
UInt16 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt32, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (UInt32, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ClearBits(
    this uint source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As UInteger,
    bits As Bits
) As UInteger
static member ClearBits :
        source : uint32 *
        bits : Bits -> uint32

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned int ClearBits(
    unsigned int source,
    Bits bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: UInt32
UInt32 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt32, UInt32)

Grid Solutions Framework BitExtensionsClearBits Method (UInt32, UInt32)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ClearBits(
    this uint source,
    uint bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As UInteger,
    bits As UInteger
) As UInteger
static member ClearBits :
        source : uint32 *
        bits : uint32 -> uint32

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned int ClearBits(
    unsigned int source,
    unsigned int bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: SystemUInt32
Bit-mask of the bits to clear.

Return Value

Type: UInt32
UInt32 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt64, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (UInt64, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ClearBits(
    this ulong source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As ULong,
    bits As Bits
) As ULong
static member ClearBits :
        source : uint64 *
        bits : Bits -> uint64

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned long long ClearBits(
    unsigned long long source,
    Bits bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: UInt64
UInt64 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt64, UInt64)

Grid Solutions Framework BitExtensionsClearBits Method (UInt64, UInt64)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ClearBits(
    this ulong source,
    ulong bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As ULong,
    bits As ULong
) As ULong
static member ClearBits :
        source : uint64 *
        bits : uint64 -> uint64

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned long long ClearBits(
    unsigned long long source,
    unsigned long long bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: SystemUInt64
Bit-mask of the bits to clear.

Return Value

Type: UInt64
UInt64 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int24, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (Int24, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ClearBits(
    this Int24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Int24,
    bits As Bits
) As Int24
static member ClearBits :
        source : Int24 *
        bits : Bits -> Int24

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static Int24 ClearBits(
    Int24 source,
    Bits bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: Int24
Int24 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (Int24, Int24)

Grid Solutions Framework BitExtensionsClearBits Method (Int24, Int24)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ClearBits(
    this Int24 source,
    Int24 bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As Int24,
    bits As Int24
) As Int24
static member ClearBits :
        source : Int24 *
        bits : Int24 -> Int24

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static Int24 ClearBits(
    Int24 source,
    Int24 bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFInt24
Bit-mask of the bits to clear.

Return Value

Type: Int24
Int24 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt24, Bits)

Grid Solutions Framework BitExtensionsClearBits Method (UInt24, Bits)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ClearBits(
    this UInt24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As UInt24,
    bits As Bits
) As UInt24
static member ClearBits :
        source : UInt24 *
        bits : Bits -> UInt24

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static UInt24 ClearBits(
    UInt24 source,
    Bits bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFBits
Bits to clear.

Return Value

Type: UInt24
UInt24 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.ClearBits Method (UInt24, UInt24)

Grid Solutions Framework BitExtensionsClearBits Method (UInt24, UInt24)
Returns value with specified bits cleared.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ClearBits(
    this UInt24 source,
    UInt24 bits
)
<ExtensionAttribute>
Public Shared Function ClearBits (
    source As UInt24,
    bits As UInt24
) As UInt24
static member ClearBits :
        source : UInt24 *
        bits : UInt24 -> UInt24

GSF.BitExtensions.ClearBits = function(source, bits);
public:
[ExtensionAttribute]
static UInt24 ClearBits(
    UInt24 source,
    UInt24 bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFUInt24
Bit-mask of the bits to clear.

Return Value

Type: UInt24
UInt24 value with specified bits cleared.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ClearBits Overload
GSF Namespace


BitExtensions.GetMaskedValue Method

Grid Solutions Framework BitExtensionsGetMaskedValue Method
Overload List
Name | Description
GetMaskedValue(Byte, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Byte, Byte) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int16, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int16, Int16) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int32, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int32, Int32) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int64, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int64, Int64) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(SByte, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(SByte, SByte) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt16, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt16, UInt16) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt32, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt32, UInt32) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt64, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt64, UInt64) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int24, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(Int24, Int24) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt24, Bits) | Returns value stored in the bits represented by the specified bitmask.
GetMaskedValue(UInt24, UInt24) | Returns value stored in the bits represented by the specified bitmask.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.GetMaskedValue Method (Byte, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Byte, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte GetMaskedValue(
    this byte source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Byte,
    bitmask As Bits
) As Byte
static member GetMaskedValue :
        source : byte *
        bitmask : Bits -> byte

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned char GetMaskedValue(
    unsigned char source,
    Bits bitmask
)

Parameters

source
Type: SystemByte
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: Byte
Byte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Byte, Byte)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Byte, Byte)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte GetMaskedValue(
    this byte source,
    byte bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Byte,
    bitmask As Byte
) As Byte
static member GetMaskedValue :
        source : byte *
        bitmask : byte -> byte

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned char GetMaskedValue(
    unsigned char source,
    unsigned char bitmask
)

Parameters

source
Type: SystemByte
Value source.
bitmask
Type: SystemByte
Bit-mask of the bits involved.

Return Value

Type: Byte
Byte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int16, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int16, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short GetMaskedValue(
    this short source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Short,
    bitmask As Bits
) As Short
static member GetMaskedValue :
        source : int16 *
        bitmask : Bits -> int16

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static short GetMaskedValue(
    short source,
    Bits bitmask
)

Parameters

source
Type: SystemInt16
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: Int16
Int16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int16, Int16)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int16, Int16)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short GetMaskedValue(
    this short source,
    short bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Short,
    bitmask As Short
) As Short
static member GetMaskedValue :
        source : int16 *
        bitmask : int16 -> int16

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static short GetMaskedValue(
    short source,
    short bitmask
)

Parameters

source
Type: SystemInt16
Value source.
bitmask
Type: SystemInt16
Bit-mask of the bits involved.

Return Value

Type: Int16
Int16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int32, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int32, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int GetMaskedValue(
    this int source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Integer,
    bitmask As Bits
) As Integer
static member GetMaskedValue :
        source : int *
        bitmask : Bits -> int

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static int GetMaskedValue(
    int source,
    Bits bitmask
)

Parameters

source
Type: SystemInt32
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: Int32
Int32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int32, Int32)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int32, Int32)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int GetMaskedValue(
    this int source,
    int bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Integer,
    bitmask As Integer
) As Integer
static member GetMaskedValue :
        source : int *
        bitmask : int -> int

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static int GetMaskedValue(
    int source,
    int bitmask
)

Parameters

source
Type: SystemInt32
Value source.
bitmask
Type: SystemInt32
Bit-mask of the bits involved.

Return Value

Type: Int32
Int32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int64, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int64, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GetMaskedValue(
    this long source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Long,
    bitmask As Bits
) As Long
static member GetMaskedValue :
        source : int64 *
        bitmask : Bits -> int64

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static long long GetMaskedValue(
    long long source,
    Bits bitmask
)

Parameters

source
Type: SystemInt64
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: Int64
Int64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int64, Int64)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int64, Int64)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GetMaskedValue(
    this long source,
    long bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Long,
    bitmask As Long
) As Long
static member GetMaskedValue :
        source : int64 *
        bitmask : int64 -> int64

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static long long GetMaskedValue(
    long long source,
    long long bitmask
)

Parameters

source
Type: SystemInt64
Value source.
bitmask
Type: SystemInt64
Bit-mask of the bits involved.

Return Value

Type: Int64
Int64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (SByte, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (SByte, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte GetMaskedValue(
    this sbyte source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As SByte,
    bitmask As Bits
) As SByte
static member GetMaskedValue :
        source : sbyte *
        bitmask : Bits -> sbyte

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static signed char GetMaskedValue(
    signed char source,
    Bits bitmask
)

Parameters

source
Type: SystemSByte
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: SByte
SByte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (SByte, SByte)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (SByte, SByte)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte GetMaskedValue(
    this sbyte source,
    sbyte bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As SByte,
    bitmask As SByte
) As SByte
static member GetMaskedValue :
        source : sbyte *
        bitmask : sbyte -> sbyte

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static signed char GetMaskedValue(
    signed char source,
    signed char bitmask
)

Parameters

source
Type: SystemSByte
Value source.
bitmask
Type: SystemSByte
Bit-mask of the bits involved.

Return Value

Type: SByte
SByte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt16, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt16, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort GetMaskedValue(
    this ushort source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As UShort,
    bitmask As Bits
) As UShort
static member GetMaskedValue :
        source : uint16 *
        bitmask : Bits -> uint16

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned short GetMaskedValue(
    unsigned short source,
    Bits bitmask
)

Parameters

source
Type: SystemUInt16
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: UInt16
UInt16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt16, UInt16)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt16, UInt16)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort GetMaskedValue(
    this ushort source,
    ushort bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As UShort,
    bitmask As UShort
) As UShort
static member GetMaskedValue :
        source : uint16 *
        bitmask : uint16 -> uint16

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned short GetMaskedValue(
    unsigned short source,
    unsigned short bitmask
)

Parameters

source
Type: SystemUInt16
Value source.
bitmask
Type: SystemUInt16
Bit-mask of the bits involved.

Return Value

Type: UInt16
UInt16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt32, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt32, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint GetMaskedValue(
    this uint source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As UInteger,
    bitmask As Bits
) As UInteger
static member GetMaskedValue :
        source : uint32 *
        bitmask : Bits -> uint32

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned int GetMaskedValue(
    unsigned int source,
    Bits bitmask
)

Parameters

source
Type: SystemUInt32
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: UInt32
UInt32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt32, UInt32)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt32, UInt32)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint GetMaskedValue(
    this uint source,
    uint bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As UInteger,
    bitmask As UInteger
) As UInteger
static member GetMaskedValue :
        source : uint32 *
        bitmask : uint32 -> uint32

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned int GetMaskedValue(
    unsigned int source,
    unsigned int bitmask
)

Parameters

source
Type: SystemUInt32
Value source.
bitmask
Type: SystemUInt32
Bit-mask of the bits involved.

Return Value

Type: UInt32
UInt32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt64, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt64, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong GetMaskedValue(
    this ulong source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As ULong,
    bitmask As Bits
) As ULong
static member GetMaskedValue :
        source : uint64 *
        bitmask : Bits -> uint64

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned long long GetMaskedValue(
    unsigned long long source,
    Bits bitmask
)

Parameters

source
Type: SystemUInt64
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: UInt64
UInt64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt64, UInt64)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt64, UInt64)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong GetMaskedValue(
    this ulong source,
    ulong bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As ULong,
    bitmask As ULong
) As ULong
static member GetMaskedValue :
        source : uint64 *
        bitmask : uint64 -> uint64

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static unsigned long long GetMaskedValue(
    unsigned long long source,
    unsigned long long bitmask
)

Parameters

source
Type: SystemUInt64
Value source.
bitmask
Type: SystemUInt64
Bit-mask of the bits involved.

Return Value

Type: UInt64
UInt64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int24, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int24, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 GetMaskedValue(
    this Int24 source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Int24,
    bitmask As Bits
) As Int24
static member GetMaskedValue :
        source : Int24 *
        bitmask : Bits -> Int24

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static Int24 GetMaskedValue(
    Int24 source,
    Bits bitmask
)

Parameters

source
Type: GSFInt24
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: Int24
Int24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (Int24, Int24)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (Int24, Int24)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 GetMaskedValue(
    this Int24 source,
    Int24 bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As Int24,
    bitmask As Int24
) As Int24
static member GetMaskedValue :
        source : Int24 *
        bitmask : Int24 -> Int24

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static Int24 GetMaskedValue(
    Int24 source,
    Int24 bitmask
)

Parameters

source
Type: GSFInt24
Value source.
bitmask
Type: GSFInt24
Bit-mask of the bits involved.

Return Value

Type: Int24
Int24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt24, Bits)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt24, Bits)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 GetMaskedValue(
    this UInt24 source,
    Bits bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As UInt24,
    bitmask As Bits
) As UInt24
static member GetMaskedValue :
        source : UInt24 *
        bitmask : Bits -> UInt24

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static UInt24 GetMaskedValue(
    UInt24 source,
    Bits bitmask
)

Parameters

source
Type: GSFUInt24
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.

Return Value

Type: UInt24
UInt24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.GetMaskedValue Method (UInt24, UInt24)

Grid Solutions Framework BitExtensionsGetMaskedValue Method (UInt24, UInt24)
Returns value stored in the bits represented by the specified bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 GetMaskedValue(
    this UInt24 source,
    UInt24 bitmask
)
<ExtensionAttribute>
Public Shared Function GetMaskedValue (
    source As UInt24,
    bitmask As UInt24
) As UInt24
static member GetMaskedValue :
        source : UInt24 *
        bitmask : UInt24 -> UInt24

GSF.BitExtensions.GetMaskedValue = function(source, bitmask);
public:
[ExtensionAttribute]
static UInt24 GetMaskedValue(
    UInt24 source,
    UInt24 bitmask
)

Parameters

source
Type: GSFUInt24
Value source.
bitmask
Type: GSFUInt24
Bit-mask of the bits involved.

Return Value

Type: UInt24
UInt24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
GetMaskedValue Overload
GSF Namespace


BitExtensions.SetBits Method

Grid Solutions Framework BitExtensionsSetBits Method
Overload List
Name | Description
SetBits(Byte, Bits) | Returns value with specified bits set.
SetBits(Byte, Byte) | Returns value with specified bits set.
SetBits(Int16, Bits) | Returns value with specified bits set.
SetBits(Int16, Int16) | Returns value with specified bits set.
SetBits(Int32, Bits) | Returns value with specified bits set.
SetBits(Int32, Int32) | Returns value with specified bits set.
SetBits(Int64, Bits) | Returns value with specified bits set.
SetBits(Int64, Int64) | Returns value with specified bits set.
SetBits(SByte, Bits) | Returns value with specified bits set.
SetBits(SByte, SByte) | Returns value with specified bits set.
SetBits(UInt16, Bits) | Returns value with specified bits set.
SetBits(UInt16, UInt16) | Returns value with specified bits set.
SetBits(UInt32, Bits) | Returns value with specified bits set.
SetBits(UInt32, UInt32) | Returns value with specified bits set.
SetBits(UInt64, Bits) | Returns value with specified bits set.
SetBits(UInt64, UInt64) | Returns value with specified bits set.
SetBits(Int24, Bits) | Returns value with specified bits set.
SetBits(Int24, Int24) | Returns value with specified bits set.
SetBits(UInt24, Bits) | Returns value with specified bits set.
SetBits(UInt24, UInt24) | Returns value with specified bits set.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.SetBits Method (Byte, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (Byte, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte SetBits(
    this byte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Byte,
    bits As Bits
) As Byte
static member SetBits :
        source : byte *
        bits : Bits -> byte

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned char SetBits(
    unsigned char source,
    Bits bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: Byte
Byte value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Byte, Byte)

Grid Solutions Framework BitExtensionsSetBits Method (Byte, Byte)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte SetBits(
    this byte source,
    byte bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Byte,
    bits As Byte
) As Byte
static member SetBits :
        source : byte *
        bits : byte -> byte

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned char SetBits(
    unsigned char source,
    unsigned char bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: SystemByte
Bit-mask of the bits to set.

Return Value

Type: Byte
Byte value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int16, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (Int16, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short SetBits(
    this short source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Short,
    bits As Bits
) As Short
static member SetBits :
        source : int16 *
        bits : Bits -> int16

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static short SetBits(
    short source,
    Bits bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: Int16
Int16 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int16, Int16)

Grid Solutions Framework BitExtensionsSetBits Method (Int16, Int16)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short SetBits(
    this short source,
    short bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Short,
    bits As Short
) As Short
static member SetBits :
        source : int16 *
        bits : int16 -> int16

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static short SetBits(
    short source,
    short bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: SystemInt16
Bit-mask of the bits to set.

Return Value

Type: Int16
Int16 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int32, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (Int32, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int SetBits(
    this int source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Integer,
    bits As Bits
) As Integer
static member SetBits :
        source : int *
        bits : Bits -> int

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static int SetBits(
    int source,
    Bits bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: Int32
Int32 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int32, Int32)

Grid Solutions Framework BitExtensionsSetBits Method (Int32, Int32)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int SetBits(
    this int source,
    int bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Integer,
    bits As Integer
) As Integer
static member SetBits :
        source : int *
        bits : int -> int

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static int SetBits(
    int source,
    int bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: SystemInt32
Bit-mask of the bits to set.

Return Value

Type: Int32
Int32 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int64, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (Int64, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long SetBits(
    this long source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Long,
    bits As Bits
) As Long
static member SetBits :
        source : int64 *
        bits : Bits -> int64

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static long long SetBits(
    long long source,
    Bits bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: Int64
Int64 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int64, Int64)

Grid Solutions Framework BitExtensionsSetBits Method (Int64, Int64)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long SetBits(
    this long source,
    long bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Long,
    bits As Long
) As Long
static member SetBits :
        source : int64 *
        bits : int64 -> int64

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static long long SetBits(
    long long source,
    long long bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: SystemInt64
Bit-mask of the bits to set.

Return Value

Type: Int64
Int64 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (SByte, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (SByte, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte SetBits(
    this sbyte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As SByte,
    bits As Bits
) As SByte
static member SetBits :
        source : sbyte *
        bits : Bits -> sbyte

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static signed char SetBits(
    signed char source,
    Bits bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: SByte
SByte value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (SByte, SByte)

Grid Solutions Framework BitExtensionsSetBits Method (SByte, SByte)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte SetBits(
    this sbyte source,
    sbyte bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As SByte,
    bits As SByte
) As SByte
static member SetBits :
        source : sbyte *
        bits : sbyte -> sbyte

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static signed char SetBits(
    signed char source,
    signed char bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: SystemSByte
Bit-mask of the bits to set.

Return Value

Type: SByte
SByte value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt16, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (UInt16, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort SetBits(
    this ushort source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As UShort,
    bits As Bits
) As UShort
static member SetBits :
        source : uint16 *
        bits : Bits -> uint16

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned short SetBits(
    unsigned short source,
    Bits bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: UInt16
UInt16 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt16, UInt16)

Grid Solutions Framework BitExtensionsSetBits Method (UInt16, UInt16)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort SetBits(
    this ushort source,
    ushort bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As UShort,
    bits As UShort
) As UShort
static member SetBits :
        source : uint16 *
        bits : uint16 -> uint16

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned short SetBits(
    unsigned short source,
    unsigned short bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: SystemUInt16
Bit-mask of the bits to set.

Return Value

Type: UInt16
UInt16 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt32, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (UInt32, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint SetBits(
    this uint source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As UInteger,
    bits As Bits
) As UInteger
static member SetBits :
        source : uint32 *
        bits : Bits -> uint32

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned int SetBits(
    unsigned int source,
    Bits bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: UInt32
UInt32 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt32, UInt32)

Grid Solutions Framework BitExtensionsSetBits Method (UInt32, UInt32)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint SetBits(
    this uint source,
    uint bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As UInteger,
    bits As UInteger
) As UInteger
static member SetBits :
        source : uint32 *
        bits : uint32 -> uint32

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned int SetBits(
    unsigned int source,
    unsigned int bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: SystemUInt32
Bit-mask of the bits to set.

Return Value

Type: UInt32
UInt32 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt64, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (UInt64, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong SetBits(
    this ulong source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As ULong,
    bits As Bits
) As ULong
static member SetBits :
        source : uint64 *
        bits : Bits -> uint64

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned long long SetBits(
    unsigned long long source,
    Bits bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: UInt64
UInt64 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt64, UInt64)

Grid Solutions Framework BitExtensionsSetBits Method (UInt64, UInt64)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong SetBits(
    this ulong source,
    ulong bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As ULong,
    bits As ULong
) As ULong
static member SetBits :
        source : uint64 *
        bits : uint64 -> uint64

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned long long SetBits(
    unsigned long long source,
    unsigned long long bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: SystemUInt64
Bit-mask of the bits to set.

Return Value

Type: UInt64
UInt64 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int24, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (Int24, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 SetBits(
    this Int24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Int24,
    bits As Bits
) As Int24
static member SetBits :
        source : Int24 *
        bits : Bits -> Int24

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static Int24 SetBits(
    Int24 source,
    Bits bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: Int24
Int24 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (Int24, Int24)

Grid Solutions Framework BitExtensionsSetBits Method (Int24, Int24)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 SetBits(
    this Int24 source,
    Int24 bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As Int24,
    bits As Int24
) As Int24
static member SetBits :
        source : Int24 *
        bits : Int24 -> Int24

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static Int24 SetBits(
    Int24 source,
    Int24 bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFInt24
Bit-mask of the bits to set.

Return Value

Type: Int24
Int24 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt24, Bits)

Grid Solutions Framework BitExtensionsSetBits Method (UInt24, Bits)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 SetBits(
    this UInt24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As UInt24,
    bits As Bits
) As UInt24
static member SetBits :
        source : UInt24 *
        bits : Bits -> UInt24

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static UInt24 SetBits(
    UInt24 source,
    Bits bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFBits
Bits to set.

Return Value

Type: UInt24
UInt24 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetBits Method (UInt24, UInt24)

Grid Solutions Framework BitExtensionsSetBits Method (UInt24, UInt24)
Returns value with specified bits set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 SetBits(
    this UInt24 source,
    UInt24 bits
)
<ExtensionAttribute>
Public Shared Function SetBits (
    source As UInt24,
    bits As UInt24
) As UInt24
static member SetBits :
        source : UInt24 *
        bits : UInt24 -> UInt24

GSF.BitExtensions.SetBits = function(source, bits);
public:
[ExtensionAttribute]
static UInt24 SetBits(
    UInt24 source,
    UInt24 bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFUInt24
Bit-mask of the bits to set.

Return Value

Type: UInt24
UInt24 value with specified bits set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetBits Overload
GSF Namespace


BitExtensions.SetMaskedValue Method

Grid Solutions Framework BitExtensionsSetMaskedValue Method
Overload List
Name | Description
SetMaskedValue(Byte, Bits, Byte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Byte, Byte, Byte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int16, Bits, Int16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int16, Int16, Int16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int32, Bits, Int32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int32, Int32, Int32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int64, Bits, Int64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int64, Int64, Int64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(SByte, Bits, SByte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(SByte, SByte, SByte) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt16, Bits, UInt16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt16, UInt16, UInt16) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt32, Bits, UInt32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt32, UInt32, UInt32) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt64, Bits, UInt64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt64, UInt64, UInt64) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int24, Bits, Int24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(Int24, Int24, Int24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt24, Bits, UInt24) | Returns value after setting a new value for the bits specified by the bitmask.
SetMaskedValue(UInt24, UInt24, UInt24) | Returns value after setting a new value for the bits specified by the bitmask.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.SetMaskedValue Method (Byte, Bits, Byte)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Byte, Bits, Byte)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte SetMaskedValue(
    this byte source,
    Bits bitmask,
    byte value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Byte,
    bitmask As Bits,
    value As Byte
) As Byte
static member SetMaskedValue :
        source : byte *
        bitmask : Bits *
        value : byte -> byte

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned char SetMaskedValue(
    unsigned char source,
    Bits bitmask,
    unsigned char value
)

Parameters

source
Type: SystemByte
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemByte
New value.

Return Value

Type: Byte
Byte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Byte, Byte, Byte)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Byte, Byte, Byte)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte SetMaskedValue(
    this byte source,
    byte bitmask,
    byte value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Byte,
    bitmask As Byte,
    value As Byte
) As Byte
static member SetMaskedValue :
        source : byte *
        bitmask : byte *
        value : byte -> byte

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned char SetMaskedValue(
    unsigned char source,
    unsigned char bitmask,
    unsigned char value
)

Parameters

source
Type: SystemByte
Value source.
bitmask
Type: SystemByte
Bit-mask of the bits involved.
value
Type: SystemByte
New value.

Return Value

Type: Byte
Byte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int16, Bits, Int16)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int16, Bits, Int16)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short SetMaskedValue(
    this short source,
    Bits bitmask,
    short value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Short,
    bitmask As Bits,
    value As Short
) As Short
static member SetMaskedValue :
        source : int16 *
        bitmask : Bits *
        value : int16 -> int16

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static short SetMaskedValue(
    short source,
    Bits bitmask,
    short value
)

Parameters

source
Type: SystemInt16
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemInt16
New value.

Return Value

Type: Int16
Int16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int16, Int16, Int16)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int16, Int16, Int16)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short SetMaskedValue(
    this short source,
    short bitmask,
    short value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Short,
    bitmask As Short,
    value As Short
) As Short
static member SetMaskedValue :
        source : int16 *
        bitmask : int16 *
        value : int16 -> int16

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static short SetMaskedValue(
    short source,
    short bitmask,
    short value
)

Parameters

source
Type: SystemInt16
Value source.
bitmask
Type: SystemInt16
Bit-mask of the bits involved.
value
Type: SystemInt16
New value.

Return Value

Type: Int16
Int16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int32, Bits, Int32)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int32, Bits, Int32)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int SetMaskedValue(
    this int source,
    Bits bitmask,
    int value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Integer,
    bitmask As Bits,
    value As Integer
) As Integer
static member SetMaskedValue :
        source : int *
        bitmask : Bits *
        value : int -> int

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static int SetMaskedValue(
    int source,
    Bits bitmask,
    int value
)

Parameters

source
Type: SystemInt32
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemInt32
New value.

Return Value

Type: Int32
Int32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int32, Int32, Int32)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int32, Int32, Int32)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int SetMaskedValue(
    this int source,
    int bitmask,
    int value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Integer,
    bitmask As Integer,
    value As Integer
) As Integer
static member SetMaskedValue :
        source : int *
        bitmask : int *
        value : int -> int

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static int SetMaskedValue(
    int source,
    int bitmask,
    int value
)

Parameters

source
Type: SystemInt32
Value source.
bitmask
Type: SystemInt32
Bit-mask of the bits involved.
value
Type: SystemInt32
New value.

Return Value

Type: Int32
Int32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int64, Bits, Int64)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int64, Bits, Int64)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long SetMaskedValue(
    this long source,
    Bits bitmask,
    long value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Long,
    bitmask As Bits,
    value As Long
) As Long
static member SetMaskedValue :
        source : int64 *
        bitmask : Bits *
        value : int64 -> int64

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static long long SetMaskedValue(
    long long source,
    Bits bitmask,
    long long value
)

Parameters

source
Type: SystemInt64
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemInt64
New value.

Return Value

Type: Int64
Int64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int64, Int64, Int64)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int64, Int64, Int64)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long SetMaskedValue(
    this long source,
    long bitmask,
    long value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Long,
    bitmask As Long,
    value As Long
) As Long
static member SetMaskedValue :
        source : int64 *
        bitmask : int64 *
        value : int64 -> int64

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static long long SetMaskedValue(
    long long source,
    long long bitmask,
    long long value
)

Parameters

source
Type: SystemInt64
Value source.
bitmask
Type: SystemInt64
Bit-mask of the bits involved.
value
Type: SystemInt64
New value.

Return Value

Type: Int64
Int64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (SByte, Bits, SByte)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (SByte, Bits, SByte)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte SetMaskedValue(
    this sbyte source,
    Bits bitmask,
    sbyte value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As SByte,
    bitmask As Bits,
    value As SByte
) As SByte
static member SetMaskedValue :
        source : sbyte *
        bitmask : Bits *
        value : sbyte -> sbyte

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static signed char SetMaskedValue(
    signed char source,
    Bits bitmask,
    signed char value
)

Parameters

source
Type: SystemSByte
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemSByte
New value.

Return Value

Type: SByte
SByte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (SByte, SByte, SByte)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (SByte, SByte, SByte)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte SetMaskedValue(
    this sbyte source,
    sbyte bitmask,
    sbyte value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As SByte,
    bitmask As SByte,
    value As SByte
) As SByte
static member SetMaskedValue :
        source : sbyte *
        bitmask : sbyte *
        value : sbyte -> sbyte

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static signed char SetMaskedValue(
    signed char source,
    signed char bitmask,
    signed char value
)

Parameters

source
Type: SystemSByte
Value source.
bitmask
Type: SystemSByte
Bit-mask of the bits involved.
value
Type: SystemSByte
New value.

Return Value

Type: SByte
SByte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt16, Bits, UInt16)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt16, Bits, UInt16)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort SetMaskedValue(
    this ushort source,
    Bits bitmask,
    ushort value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As UShort,
    bitmask As Bits,
    value As UShort
) As UShort
static member SetMaskedValue :
        source : uint16 *
        bitmask : Bits *
        value : uint16 -> uint16

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned short SetMaskedValue(
    unsigned short source,
    Bits bitmask,
    unsigned short value
)

Parameters

source
Type: SystemUInt16
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemUInt16
New value.

Return Value

Type: UInt16
UInt16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt16, UInt16, UInt16)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt16, UInt16, UInt16)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort SetMaskedValue(
    this ushort source,
    ushort bitmask,
    ushort value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As UShort,
    bitmask As UShort,
    value As UShort
) As UShort
static member SetMaskedValue :
        source : uint16 *
        bitmask : uint16 *
        value : uint16 -> uint16

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned short SetMaskedValue(
    unsigned short source,
    unsigned short bitmask,
    unsigned short value
)

Parameters

source
Type: SystemUInt16
Value source.
bitmask
Type: SystemUInt16
Bit-mask of the bits involved.
value
Type: SystemUInt16
New value.

Return Value

Type: UInt16
UInt16 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt32, Bits, UInt32)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt32, Bits, UInt32)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint SetMaskedValue(
    this uint source,
    Bits bitmask,
    uint value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As UInteger,
    bitmask As Bits,
    value As UInteger
) As UInteger
static member SetMaskedValue :
        source : uint32 *
        bitmask : Bits *
        value : uint32 -> uint32

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned int SetMaskedValue(
    unsigned int source,
    Bits bitmask,
    unsigned int value
)

Parameters

source
Type: SystemUInt32
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemUInt32
New value.

Return Value

Type: UInt32
UInt32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt32, UInt32, UInt32)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt32, UInt32, UInt32)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint SetMaskedValue(
    this uint source,
    uint bitmask,
    uint value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As UInteger,
    bitmask As UInteger,
    value As UInteger
) As UInteger
static member SetMaskedValue :
        source : uint32 *
        bitmask : uint32 *
        value : uint32 -> uint32

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned int SetMaskedValue(
    unsigned int source,
    unsigned int bitmask,
    unsigned int value
)

Parameters

source
Type: SystemUInt32
Value source.
bitmask
Type: SystemUInt32
Bit-mask of the bits involved.
value
Type: SystemUInt32
New value.

Return Value

Type: UInt32
UInt32 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt64, Bits, UInt64)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt64, Bits, UInt64)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong SetMaskedValue(
    this ulong source,
    Bits bitmask,
    ulong value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As ULong,
    bitmask As Bits,
    value As ULong
) As ULong
static member SetMaskedValue :
        source : uint64 *
        bitmask : Bits *
        value : uint64 -> uint64

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned long long SetMaskedValue(
    unsigned long long source,
    Bits bitmask,
    unsigned long long value
)

Parameters

source
Type: SystemUInt64
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: SystemUInt64
New value.

Return Value

Type: UInt64
UInt64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt64, UInt64, UInt64)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt64, UInt64, UInt64)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong SetMaskedValue(
    this ulong source,
    ulong bitmask,
    ulong value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As ULong,
    bitmask As ULong,
    value As ULong
) As ULong
static member SetMaskedValue :
        source : uint64 *
        bitmask : uint64 *
        value : uint64 -> uint64

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static unsigned long long SetMaskedValue(
    unsigned long long source,
    unsigned long long bitmask,
    unsigned long long value
)

Parameters

source
Type: SystemUInt64
Value source.
bitmask
Type: SystemUInt64
Bit-mask of the bits involved.
value
Type: SystemUInt64
New value.

Return Value

Type: UInt64
UInt64 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int24, Bits, Int24)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int24, Bits, Int24)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 SetMaskedValue(
    this Int24 source,
    Bits bitmask,
    Int24 value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Int24,
    bitmask As Bits,
    value As Int24
) As Int24
static member SetMaskedValue :
        source : Int24 *
        bitmask : Bits *
        value : Int24 -> Int24

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static Int24 SetMaskedValue(
    Int24 source,
    Bits bitmask,
    Int24 value
)

Parameters

source
Type: GSFInt24
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: GSFInt24
New value.

Return Value

Type: Int24
Int24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (Int24, Int24, Int24)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (Int24, Int24, Int24)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 SetMaskedValue(
    this Int24 source,
    Int24 bitmask,
    Int24 value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As Int24,
    bitmask As Int24,
    value As Int24
) As Int24
static member SetMaskedValue :
        source : Int24 *
        bitmask : Int24 *
        value : Int24 -> Int24

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static Int24 SetMaskedValue(
    Int24 source,
    Int24 bitmask,
    Int24 value
)

Parameters

source
Type: GSFInt24
Value source.
bitmask
Type: GSFInt24
Bit-mask of the bits involved.
value
Type: GSFInt24
New value.

Return Value

Type: Int24
Int24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt24, Bits, UInt24)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt24, Bits, UInt24)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 SetMaskedValue(
    this UInt24 source,
    Bits bitmask,
    UInt24 value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As UInt24,
    bitmask As Bits,
    value As UInt24
) As UInt24
static member SetMaskedValue :
        source : UInt24 *
        bitmask : Bits *
        value : UInt24 -> UInt24

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static UInt24 SetMaskedValue(
    UInt24 source,
    Bits bitmask,
    UInt24 value
)

Parameters

source
Type: GSFUInt24
Value source.
bitmask
Type: GSFBits
Bits that make-up the bit-mask.
value
Type: GSFUInt24
New value.

Return Value

Type: UInt24
UInt24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.SetMaskedValue Method (UInt24, UInt24, UInt24)

Grid Solutions Framework BitExtensionsSetMaskedValue Method (UInt24, UInt24, UInt24)
Returns value after setting a new value for the bits specified by the bitmask.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 SetMaskedValue(
    this UInt24 source,
    UInt24 bitmask,
    UInt24 value
)
<ExtensionAttribute>
Public Shared Function SetMaskedValue (
    source As UInt24,
    bitmask As UInt24,
    value As UInt24
) As UInt24
static member SetMaskedValue :
        source : UInt24 *
        bitmask : UInt24 *
        value : UInt24 -> UInt24

GSF.BitExtensions.SetMaskedValue = function(source, bitmask, value);
public:
[ExtensionAttribute]
static UInt24 SetMaskedValue(
    UInt24 source,
    UInt24 bitmask,
    UInt24 value
)

Parameters

source
Type: GSFUInt24
Value source.
bitmask
Type: GSFUInt24
Bit-mask of the bits involved.
value
Type: GSFUInt24
New value.

Return Value

Type: UInt24
UInt24 value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
SetMaskedValue Overload
GSF Namespace


BitExtensions.ToggleBits Method

Grid Solutions Framework BitExtensionsToggleBits Method
Overload List
Name | Description
ToggleBits(Byte, Bits) | Returns value with specified bits toggled.
ToggleBits(Byte, Byte) | Returns value with specified bits toggled.
ToggleBits(Int16, Bits) | Returns value with specified bits toggled.
ToggleBits(Int16, Int16) | Returns value with specified bits toggled.
ToggleBits(Int32, Bits) | Returns value with specified bits toggled.
ToggleBits(Int32, Int32) | Returns value with specified bits toggled.
ToggleBits(Int64, Bits) | Returns value with specified bits toggled.
ToggleBits(Int64, Int64) | Returns value with specified bits toggled.
ToggleBits(SByte, Bits) | Returns value with specified bits toggled.
ToggleBits(SByte, SByte) | Returns value with specified bits toggled.
ToggleBits(UInt16, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt16, UInt16) | Returns value with specified bits toggled.
ToggleBits(UInt32, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt32, UInt32) | Returns value with specified bits toggled.
ToggleBits(UInt64, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt64, UInt64) | Returns value with specified bits toggled.
ToggleBits(Int24, Bits) | Returns value with specified bits toggled.
ToggleBits(Int24, Int24) | Returns value with specified bits toggled.
ToggleBits(UInt24, Bits) | Returns value with specified bits toggled.
ToggleBits(UInt24, UInt24) | Returns value with specified bits toggled.
Top
See Also

Reference

BitExtensions Class
GSF Namespace


BitExtensions.ToggleBits Method (Byte, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (Byte, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte ToggleBits(
    this byte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Byte,
    bits As Bits
) As Byte
static member ToggleBits :
        source : byte *
        bits : Bits -> byte

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned char ToggleBits(
    unsigned char source,
    Bits bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: Byte
Byte value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Byte, Byte)

Grid Solutions Framework BitExtensionsToggleBits Method (Byte, Byte)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte ToggleBits(
    this byte source,
    byte bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Byte,
    bits As Byte
) As Byte
static member ToggleBits :
        source : byte *
        bits : byte -> byte

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned char ToggleBits(
    unsigned char source,
    unsigned char bits
)

Parameters

source
Type: SystemByte
Value source.
bits
Type: SystemByte
Bit-mask of the bits to toggle.

Return Value

Type: Byte
Byte value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int16, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (Int16, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ToggleBits(
    this short source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Short,
    bits As Bits
) As Short
static member ToggleBits :
        source : int16 *
        bits : Bits -> int16

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static short ToggleBits(
    short source,
    Bits bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: Int16
Int16 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int16, Int16)

Grid Solutions Framework BitExtensionsToggleBits Method (Int16, Int16)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ToggleBits(
    this short source,
    short bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Short,
    bits As Short
) As Short
static member ToggleBits :
        source : int16 *
        bits : int16 -> int16

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static short ToggleBits(
    short source,
    short bits
)

Parameters

source
Type: SystemInt16
Value source.
bits
Type: SystemInt16
Bit-mask of the bits to toggle.

Return Value

Type: Int16
Int16 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int32, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (Int32, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToggleBits(
    this int source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Integer,
    bits As Bits
) As Integer
static member ToggleBits :
        source : int *
        bits : Bits -> int

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static int ToggleBits(
    int source,
    Bits bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: Int32
Int32 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int32, Int32)

Grid Solutions Framework BitExtensionsToggleBits Method (Int32, Int32)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToggleBits(
    this int source,
    int bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Integer,
    bits As Integer
) As Integer
static member ToggleBits :
        source : int *
        bits : int -> int

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static int ToggleBits(
    int source,
    int bits
)

Parameters

source
Type: SystemInt32
Value source.
bits
Type: SystemInt32
Bit-mask of the bits to toggle.

Return Value

Type: Int32
Int32 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int64, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (Int64, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ToggleBits(
    this long source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Long,
    bits As Bits
) As Long
static member ToggleBits :
        source : int64 *
        bits : Bits -> int64

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static long long ToggleBits(
    long long source,
    Bits bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: Int64
Int64 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int64, Int64)

Grid Solutions Framework BitExtensionsToggleBits Method (Int64, Int64)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ToggleBits(
    this long source,
    long bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Long,
    bits As Long
) As Long
static member ToggleBits :
        source : int64 *
        bits : int64 -> int64

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static long long ToggleBits(
    long long source,
    long long bits
)

Parameters

source
Type: SystemInt64
Value source.
bits
Type: SystemInt64
Bit-mask of the bits to toggle.

Return Value

Type: Int64
Int64 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (SByte, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (SByte, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte ToggleBits(
    this sbyte source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As SByte,
    bits As Bits
) As SByte
static member ToggleBits :
        source : sbyte *
        bits : Bits -> sbyte

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static signed char ToggleBits(
    signed char source,
    Bits bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: SByte
SByte value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (SByte, SByte)

Grid Solutions Framework BitExtensionsToggleBits Method (SByte, SByte)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static sbyte ToggleBits(
    this sbyte source,
    sbyte bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As SByte,
    bits As SByte
) As SByte
static member ToggleBits :
        source : sbyte *
        bits : sbyte -> sbyte

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static signed char ToggleBits(
    signed char source,
    signed char bits
)

Parameters

source
Type: SystemSByte
Value source.
bits
Type: SystemSByte
Bit-mask of the bits to toggle.

Return Value

Type: SByte
SByte value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SByte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt16, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt16, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ToggleBits(
    this ushort source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As UShort,
    bits As Bits
) As UShort
static member ToggleBits :
        source : uint16 *
        bits : Bits -> uint16

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned short ToggleBits(
    unsigned short source,
    Bits bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: UInt16
UInt16 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt16, UInt16)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt16, UInt16)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ToggleBits(
    this ushort source,
    ushort bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As UShort,
    bits As UShort
) As UShort
static member ToggleBits :
        source : uint16 *
        bits : uint16 -> uint16

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned short ToggleBits(
    unsigned short source,
    unsigned short bits
)

Parameters

source
Type: SystemUInt16
Value source.
bits
Type: SystemUInt16
Bit-mask of the bits to toggle.

Return Value

Type: UInt16
UInt16 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt32, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt32, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ToggleBits(
    this uint source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As UInteger,
    bits As Bits
) As UInteger
static member ToggleBits :
        source : uint32 *
        bits : Bits -> uint32

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned int ToggleBits(
    unsigned int source,
    Bits bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: UInt32
UInt32 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt32, UInt32)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt32, UInt32)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ToggleBits(
    this uint source,
    uint bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As UInteger,
    bits As UInteger
) As UInteger
static member ToggleBits :
        source : uint32 *
        bits : uint32 -> uint32

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned int ToggleBits(
    unsigned int source,
    unsigned int bits
)

Parameters

source
Type: SystemUInt32
Value source.
bits
Type: SystemUInt32
Bit-mask of the bits to toggle.

Return Value

Type: UInt32
UInt32 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt64, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt64, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ToggleBits(
    this ulong source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As ULong,
    bits As Bits
) As ULong
static member ToggleBits :
        source : uint64 *
        bits : Bits -> uint64

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned long long ToggleBits(
    unsigned long long source,
    Bits bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: UInt64
UInt64 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt64, UInt64)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt64, UInt64)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ToggleBits(
    this ulong source,
    ulong bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As ULong,
    bits As ULong
) As ULong
static member ToggleBits :
        source : uint64 *
        bits : uint64 -> uint64

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static unsigned long long ToggleBits(
    unsigned long long source,
    unsigned long long bits
)

Parameters

source
Type: SystemUInt64
Value source.
bits
Type: SystemUInt64
Bit-mask of the bits to toggle.

Return Value

Type: UInt64
UInt64 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int24, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (Int24, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ToggleBits(
    this Int24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Int24,
    bits As Bits
) As Int24
static member ToggleBits :
        source : Int24 *
        bits : Bits -> Int24

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static Int24 ToggleBits(
    Int24 source,
    Bits bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: Int24
Int24 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (Int24, Int24)

Grid Solutions Framework BitExtensionsToggleBits Method (Int24, Int24)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ToggleBits(
    this Int24 source,
    Int24 bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As Int24,
    bits As Int24
) As Int24
static member ToggleBits :
        source : Int24 *
        bits : Int24 -> Int24

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static Int24 ToggleBits(
    Int24 source,
    Int24 bits
)

Parameters

source
Type: GSFInt24
Value source.
bits
Type: GSFInt24
Bit-mask of the bits to toggle.

Return Value

Type: Int24
Int24 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt24, Bits)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt24, Bits)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ToggleBits(
    this UInt24 source,
    Bits bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As UInt24,
    bits As Bits
) As UInt24
static member ToggleBits :
        source : UInt24 *
        bits : Bits -> UInt24

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static UInt24 ToggleBits(
    UInt24 source,
    Bits bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFBits
Bits to toggle.

Return Value

Type: UInt24
UInt24 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


BitExtensions.ToggleBits Method (UInt24, UInt24)

Grid Solutions Framework BitExtensionsToggleBits Method (UInt24, UInt24)
Returns value with specified bits toggled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ToggleBits(
    this UInt24 source,
    UInt24 bits
)
<ExtensionAttribute>
Public Shared Function ToggleBits (
    source As UInt24,
    bits As UInt24
) As UInt24
static member ToggleBits :
        source : UInt24 *
        bits : UInt24 -> UInt24

GSF.BitExtensions.ToggleBits = function(source, bits);
public:
[ExtensionAttribute]
static UInt24 ToggleBits(
    UInt24 source,
    UInt24 bits
)

Parameters

source
Type: GSFUInt24
Value source.
bits
Type: GSFUInt24
Bit-mask of the bits to toggle.

Return Value

Type: UInt24
UInt24 value with specified bits toggled.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt24. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

BitExtensions Class
ToggleBits Overload
GSF Namespace


Bits Enumeration

Grid Solutions Framework Bits Enumeration
Represents bits in a signed or unsigned integer value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum Bits
<FlagsAttribute>
Public Enumeration Bits
[<FlagsAttribute>]
type Bits
GSF.Bits = function();
GSF.Bits.createEnum('GSF.Bits', true);
[FlagsAttribute]
public enum class Bits
Members
Member name | Value | Description
Nil | 0 | No bits set (0x0000000000000000)
Bit00 | 1 | Bit 00 (0x0000000000000001)
Bit01 | 2 | Bit 01 (0x0000000000000002)
Bit02 | 4 | Bit 02 (0x0000000000000004)
Bit03 | 8 | Bit 03 (0x0000000000000008)
Bit04 | 16 | Bit 04 (0x0000000000000010)
Bit05 | 32 | Bit 05 (0x0000000000000020)
Bit06 | 64 | Bit 06 (0x0000000000000040)
Bit07 | 128 | Bit 07 (0x0000000000000080)
Bit08 | 256 | Bit 08 (0x0000000000000100)
Bit09 | 512 | Bit 09 (0x0000000000000200)
Bit10 | 1024 | Bit 10 (0x0000000000000400)
Bit11 | 2048 | Bit 11 (0x0000000000000800)
Bit12 | 4096 | Bit 12 (0x0000000000001000)
Bit13 | 8192 | Bit 13 (0x0000000000002000)
Bit14 | 16384 | Bit 14 (0x0000000000004000)
Bit15 | 32768 | Bit 15 (0x0000000000008000)
Bit16 | 65536 | Bit 16 (0x0000000000010000)
Bit17 | 131072 | Bit 17 (0x0000000000020000)
Bit18 | 262144 | Bit 18 (0x0000000000040000)
Bit19 | 524288 | Bit 19 (0x0000000000080000)
Bit20 | 1048576 | Bit 20 (0x0000000000100000)
Bit21 | 2097152 | Bit 21 (0x0000000000200000)
Bit22 | 4194304 | Bit 22 (0x0000000000400000)
Bit23 | 8388608 | Bit 23 (0x0000000000800000)
Bit24 | 16777216 | Bit 24 (0x0000000001000000)
Bit25 | 33554432 | Bit 25 (0x0000000002000000)
Bit26 | 67108864 | Bit 26 (0x0000000004000000)
Bit27 | 134217728 | Bit 27 (0x0000000008000000)
Bit28 | 268435456 | Bit 28 (0x0000000010000000)
Bit29 | 536870912 | Bit 29 (0x0000000020000000)
Bit30 | 1073741824 | Bit 30 (0x0000000040000000)
Bit31 | 2147483648 | Bit 31 (0x0000000080000000)
Bit32 | 4294967296 | Bit 32 (0x0000000100000000)
Bit33 | 8589934592 | Bit 33 (0x0000000200000000)
Bit34 | 17179869184 | Bit 34 (0x0000000400000000)
Bit35 | 34359738368 | Bit 35 (0x0000000800000000)
Bit36 | 68719476736 | Bit 36 (0x0000001000000000)
Bit37 | 137438953472 | Bit 37 (0x0000002000000000)
Bit38 | 274877906944 | Bit 38 (0x0000004000000000)
Bit39 | 549755813888 | Bit 39 (0x0000008000000000)
Bit40 | 1099511627776 | Bit 40 (0x0000010000000000)
Bit41 | 2199023255552 | Bit 41 (0x0000020000000000)
Bit42 | 4398046511104 | Bit 42 (0x0000040000000000)
Bit43 | 8796093022208 | Bit 43 (0x0000080000000000)
Bit44 | 17592186044416 | Bit 44 (0x0000100000000000)
Bit45 | 35184372088832 | Bit 45 (0x0000200000000000)
Bit46 | 70368744177664 | Bit 46 (0x0000400000000000)
Bit47 | 140737488355328 | Bit 47 (0x0000800000000000)
Bit48 | 281474976710656 | Bit 48 (0x0001000000000000)
Bit49 | 562949953421312 | Bit 49 (0x0002000000000000)
Bit50 | 1125899906842624 | Bit 50 (0x0004000000000000)
Bit51 | 2251799813685248 | Bit 51 (0x0008000000000000)
Bit52 | 4503599627370496 | Bit 52 (0x0010000000000000)
Bit53 | 9007199254740992 | Bit 53 (0x0020000000000000)
Bit54 | 18014398509481984 | Bit 54 (0x0040000000000000)
Bit55 | 36028797018963968 | Bit 55 (0x0080000000000000)
Bit56 | 72057594037927936 | Bit 56 (0x0100000000000000)
Bit57 | 144115188075855872 | Bit 57 (0x0200000000000000)
Bit58 | 288230376151711744 | Bit 58 (0x0400000000000000)
Bit59 | 576460752303423488 | Bit 59 (0x0800000000000000)
Bit60 | 1152921504606846976 | Bit 60 (0x1000000000000000)
Bit61 | 2305843009213693952 | Bit 61 (0x2000000000000000)
Bit62 | 4611686018427387904 | Bit 62 (0x4000000000000000)
Bit63 | 9223372036854775808 | Bit 63 (0x8000000000000000)
See Also

Reference

GSF Namespace


BitwiseCast Class

Grid Solutions Framework BitwiseCast Class
Defines specialized bitwise integer data type conversion functions
Inheritance Hierarchy
SystemObject
GSFBitwiseCast

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class BitwiseCast
Public NotInheritable Class BitwiseCast
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BitwiseCast =  class end
GSF.BitwiseCast = function();

Type.createClass(
    'GSF.BitwiseCast');
public ref class BitwiseCast abstract sealed

The BitwiseCast type exposes the following members.

Methods
Name | Description
ToInt16 | Performs proper bitwise conversion between unsigned and signed value
ToInt24 | Performs proper bitwise conversion between unsigned and signed value
ToInt32 | Performs proper bitwise conversion between unsigned and signed value
ToInt64 | Performs proper bitwise conversion between unsigned and signed value
ToUInt16 | Performs proper bitwise conversion between signed and unsigned value
ToUInt24 | Performs proper bitwise conversion between signed and unsigned value
ToUInt32 | Performs proper bitwise conversion between signed and unsigned value
ToUInt64 | Performs proper bitwise conversion between signed and unsigned value
Top
Remarks
This class allows for proper bitwise casting between signed and unsigned integers. It may be most useful in languages that do not allow override of numerical overflow checks. For example, C# provides an "unchecked" keyword to allow for bitwise casting, but VB.NET does not.
See Also

Reference

GSF Namespace


BitwiseCast Methods

Grid Solutions Framework BitwiseCast Methods

The BitwiseCast type exposes the following members.

Methods
Name | Description
ToInt16 | Performs proper bitwise conversion between unsigned and signed value
ToInt24 | Performs proper bitwise conversion between unsigned and signed value
ToInt32 | Performs proper bitwise conversion between unsigned and signed value
ToInt64 | Performs proper bitwise conversion between unsigned and signed value
ToUInt16 | Performs proper bitwise conversion between signed and unsigned value
ToUInt24 | Performs proper bitwise conversion between signed and unsigned value
ToUInt32 | Performs proper bitwise conversion between signed and unsigned value
ToUInt64 | Performs proper bitwise conversion between signed and unsigned value
Top
See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToInt16 Method

Grid Solutions Framework BitwiseCastToInt16 Method
Performs proper bitwise conversion between unsigned and signed value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ToInt16(
    ushort unsignedInt
)
Public Shared Function ToInt16 (
    unsignedInt As UShort
) As Short
static member ToInt16 :
        unsignedInt : uint16 -> int16

GSF.BitwiseCast.ToInt16 = function(unsignedInt);
public:
static short ToInt16(
    unsigned short unsignedInt
)

Parameters

unsignedInt
Type: SystemUInt16
Unsigned short that is passed in to be converted to a signed short.

Return Value

Type: Int16
The converted short value.
Remarks

This function is useful because Convert.ToInt16 will throw an OverflowException for values greater than Int16.MaxValue.

For example, this function correctly converts unsigned 16-bit integer 65535 (i.e., UInt16.MaxValue) to signed 16-bit integer -1.

See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToInt24 Method

Grid Solutions Framework BitwiseCastToInt24 Method
Performs proper bitwise conversion between unsigned and signed value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ToInt24(
    UInt24 unsignedInt
)
Public Shared Function ToInt24 (
    unsignedInt As UInt24
) As Int24
static member ToInt24 :
        unsignedInt : UInt24 -> Int24

GSF.BitwiseCast.ToInt24 = function(unsignedInt);
public:
static Int24 ToInt24(
    UInt24 unsignedInt
)

Parameters

unsignedInt
Type: GSFUInt24
Unsigned UInt24 that is passed in to be converted to a signed Int24.

Return Value

Type: Int24
The Int24 value.
Remarks

This function is useful because CType(n, Int24) will throw an OverflowException for values greater than Int24.MaxValue.

For example, this function correctly converts unsigned 24-bit integer 16777215 (i.e., UInt24.MaxValue) to signed 24-bit integer -1.

See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToInt32 Method

Grid Solutions Framework BitwiseCastToInt32 Method
Performs proper bitwise conversion between unsigned and signed value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToInt32(
    uint unsignedInt
)
Public Shared Function ToInt32 (
    unsignedInt As UInteger
) As Integer
static member ToInt32 :
        unsignedInt : uint32 -> int

GSF.BitwiseCast.ToInt32 = function(unsignedInt);
public:
static int ToInt32(
    unsigned int unsignedInt
)

Parameters

unsignedInt
Type: SystemUInt32
Unsigned integer that is passed in to be converted to a signed Int32.

Return Value

Type: Int32
The int value.
Remarks

This function is useful because Convert.ToInt32 will throw an OverflowException for values greater than Int32.MaxValue.

For example, this function correctly converts unsigned 32-bit integer 4294967295 (i.e., UInt32.MaxValue) to signed 32-bit integer -1.

See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToInt64 Method

Grid Solutions Framework BitwiseCastToInt64 Method
Performs proper bitwise conversion between unsigned and signed value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ToInt64(
    ulong unsignedInt
)
Public Shared Function ToInt64 (
    unsignedInt As ULong
) As Long
static member ToInt64 :
        unsignedInt : uint64 -> int64

GSF.BitwiseCast.ToInt64 = function(unsignedInt);
public:
static long long ToInt64(
    unsigned long long unsignedInt
)

Parameters

unsignedInt
Type: SystemUInt64
Unsigned integer that is passed in to be converted to a long.

Return Value

Type: Int64
The long value.
Remarks

This function is useful because Convert.ToInt64 will throw an OverflowException for values greater than Int64.MaxValue.

For example, this function correctly converts unsigned 64-bit integer 18446744073709551615 (i.e., UInt64.MaxValue) to signed 64-bit integer -1.

See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToUInt16 Method

Grid Solutions Framework BitwiseCastToUInt16 Method
Performs proper bitwise conversion between signed and unsigned value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ToUInt16(
    short signedInt
)
Public Shared Function ToUInt16 (
    signedInt As Short
) As UShort
static member ToUInt16 :
        signedInt : int16 -> uint16

GSF.BitwiseCast.ToUInt16 = function(signedInt);
public:
static unsigned short ToUInt16(
    short signedInt
)

Parameters

signedInt
Type: SystemInt16
Signed integer that is passed in to be converted to an unsigned short.

Return Value

Type: UInt16
The unsigned short value.
Remarks

This function is useful because Convert.ToUInt16 will throw an OverflowException for values less than zero.

For example, this function correctly converts signed 16-bit integer -32768 (i.e., Int16.MinValue) to unsigned 16-bit integer 32768.

See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToUInt24 Method

Grid Solutions Framework BitwiseCastToUInt24 Method
Performs proper bitwise conversion between signed and unsigned value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ToUInt24(
    Int24 signedInt
)
Public Shared Function ToUInt24 (
    signedInt As Int24
) As UInt24
static member ToUInt24 :
        signedInt : Int24 -> UInt24

GSF.BitwiseCast.ToUInt24 = function(signedInt);
public:
static UInt24 ToUInt24(
    Int24 signedInt
)

Parameters

signedInt
Type: GSFInt24
Signed integer that is passed in to be converted to an unsigned integer.

Return Value

Type: UInt24
The unsigned integer value.
Remarks

This function is useful because CType(n, UInt24) will throw an OverflowException for values less than zero.

For example, this function correctly converts signed 24-bit integer -8388608 (i.e., Int24.MinValue) to unsigned 24-bit integer 8388608.

See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToUInt32 Method

Grid Solutions Framework BitwiseCastToUInt32 Method
Performs proper bitwise conversion between signed and unsigned value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ToUInt32(
    int signedInt
)
Public Shared Function ToUInt32 (
    signedInt As Integer
) As UInteger
static member ToUInt32 :
        signedInt : int -> uint32

GSF.BitwiseCast.ToUInt32 = function(signedInt);
public:
static unsigned int ToUInt32(
    int signedInt
)

Parameters

signedInt
Type: SystemInt32
Signed integer that is passed in to be converted to an unsigned integer.

Return Value

Type: UInt32
The unsigned integer value.
Remarks

This function is useful because Convert.ToUInt32 will throw an OverflowException for values less than zero.

For example, this function correctly converts signed 32-bit integer -2147483648 (i.e., Int32.MinValue) to unsigned 32-bit integer 2147483648.

See Also

Reference

BitwiseCast Class
GSF Namespace


BitwiseCast.ToUInt64 Method

Grid Solutions Framework BitwiseCastToUInt64 Method
Performs proper bitwise conversion between signed and unsigned value

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ToUInt64(
    long signedInt
)
Public Shared Function ToUInt64 (
    signedInt As Long
) As ULong
static member ToUInt64 :
        signedInt : int64 -> uint64

GSF.BitwiseCast.ToUInt64 = function(signedInt);
public:
static unsigned long long ToUInt64(
    long long signedInt
)

Parameters

signedInt
Type: SystemInt64
Signed integer that is passed in to be converted to an unsigned long.

Return Value

Type: UInt64
The unsigned long value.
Remarks

This function is useful because Convert.ToUInt64 will throw an OverflowException for values less than zero.

For example, this function correctly converts signed 64-bit integer -9223372036854775808 (i.e., Int64.MinValue) to unsigned 64-bit integer 9223372036854775808.

See Also

Reference

BitwiseCast Class
GSF Namespace


BufferPool Class

Grid Solutions Framework BufferPool Class

Note: This API is now obsolete.

Represents a common buffer pool that can be used by an application.
Inheritance Hierarchy
SystemObject
GSFBufferPool

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")]
public static class BufferPool
<ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")>
Public NotInheritable Class BufferPool
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")>]
type BufferPool =  class end
GSF.BufferPool = function();

Type.createClass(
    'GSF.BufferPool');
[ObsoleteAttribute(L"It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")]
public ref class BufferPool abstract sealed

The BufferPool type exposes the following members.

Methods
Name | Description
Clear | Releases all the buffers currently cached in the pool.
ReturnBuffer | Returns a buffer to the pool.
TakeBuffer | Gets a buffer of at least the specified size from the pool.
Top
Remarks

The buffer pool is statically created at application startup and is available for all components and classes within an application domain. Every time you need to use a buffer, you take one from the pool, use it, and return it to the pool when done.

It is very important to return the buffer to the pool when you are finished using it. If you are using a buffer scoped within a method, make sure to use a try/finally so that you can take the buffer within the try and return the buffer within the finally. If you are using a buffer as a member scoped class field, make sure you use the standard dispose pattern and return the buffer in the Dispose method.

Internally this class simply wraps a static instance of the WCF BufferManager.

See Also

Reference

GSF Namespace


BufferPool Methods

Grid Solutions Framework BufferPool Methods

The BufferPool type exposes the following members.

Methods
Name | Description
Clear | Releases all the buffers currently cached in the pool.
ReturnBuffer | Returns a buffer to the pool.
TakeBuffer | Gets a buffer of at least the specified size from the pool.
Top
See Also

Reference

BufferPool Class
GSF Namespace


BufferPool.Clear Method

Grid Solutions Framework BufferPoolClear Method
Releases all the buffers currently cached in the pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Clear()
Public Shared Sub Clear
static member Clear : unit -> unit

GSF.BufferPool.Clear = function();
public:
static void Clear()
See Also

Reference

BufferPool Class
GSF Namespace


BufferPool.ReturnBuffer Method

Grid Solutions Framework BufferPoolReturnBuffer Method
Returns a buffer to the pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ReturnBuffer(
    byte[] buffer
)
Public Shared Sub ReturnBuffer (
    buffer As Byte()
)
static member ReturnBuffer :
        buffer : byte[] -> unit

GSF.BufferPool.ReturnBuffer = function(buffer);
public:
static void ReturnBuffer(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
A reference to the buffer being returned.
Exceptions
Exception | Condition
ArgumentNullException | buffer reference cannot be null.
ArgumentException | Length of buffer does not match the pool's buffer length property.
See Also

Reference

BufferPool Class
GSF Namespace


BufferPool.TakeBuffer Method

Grid Solutions Framework BufferPoolTakeBuffer Method
Gets a buffer of at least the specified size from the pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] TakeBuffer(
    int bufferSize
)
Public Shared Function TakeBuffer (
    bufferSize As Integer
) As Byte()
static member TakeBuffer :
        bufferSize : int -> byte[]

GSF.BufferPool.TakeBuffer = function(bufferSize);
public:
static array<unsigned char>^ TakeBuffer(
    int bufferSize
)

Parameters

bufferSize
Type: SystemInt32
The size, in bytes, of the requested buffer.

Return Value

Type: Byte
A byte array that is the requested size of the buffer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | bufferSize cannot be less than zero.
See Also

Reference

BufferPool Class
GSF Namespace


ByteEncoding Class

Grid Solutions Framework ByteEncoding Class
Defines a set of methods used to convert byte buffers to and from user presentable data formats.
Inheritance Hierarchy
SystemObject
GSFByteEncoding
GSFByteEncodingASCIIEncoding
GSFByteEncodingBase64Encoding
GSFByteEncodingBinaryEncoding
GSFByteEncodingDecimalEncoding
GSFByteEncodingHexadecimalEncoding

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ByteEncoding
Public MustInherit Class ByteEncoding
[<AbstractClassAttribute>]
type ByteEncoding =  class end
GSF.ByteEncoding = function();

Type.createClass(
    'GSF.ByteEncoding');
public ref class ByteEncoding abstract

The ByteEncoding type exposes the following members.

Constructors
 | Name | Description
Protected method | ByteEncoding | Initializes a new instance of the ByteEncoding class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer.
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
NoSpacing | Constant used to specify that "no spacing" should be used for data conversion.
Top
Properties
Name | Description
ASCII | Handles encoding and decoding of a byte buffer into an ASCII character presentation format.
Base64 | Handles encoding and decoding of a byte buffer into a base64 presentation format.
BigEndianBinary | Handles encoding and decoding of a byte buffer into a big-endian binary (i.e., 0 and 1's) based presentation format.
Decimal | Handles encoding and decoding of a byte buffer into an integer-based presentation format.
Hexadecimal | Handles encoding and decoding of a byte buffer into a hexadecimal-based presentation format.
LittleEndianBinary | Handles encoding and decoding of a byte buffer into a little-endian binary (i.e., 0 and 1's) based presentation format.
Top
See Also

Reference

GSF Namespace


ByteEncoding Constructor

Grid Solutions Framework ByteEncoding Constructor
Initializes a new instance of the ByteEncoding class

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ByteEncoding()
Protected Sub New
new : unit -> ByteEncoding
GSF.ByteEncoding = function();
protected:
ByteEncoding()
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding Fields

Grid Solutions Framework ByteEncoding Fields

The ByteEncoding type exposes the following members.

Fields
Name | Description
NoSpacing | Constant used to specify that "no spacing" should be used for data conversion.
Top
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.NoSpacing Field

Grid Solutions Framework ByteEncodingNoSpacing Field
Constant used to specify that "no spacing" should be used for data conversion.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const char NoSpacing
Public Const NoSpacing As Char
static val mutable NoSpacing: char
var GSF.ByteEncoding.NoSpacing
public:
literal wchar_t NoSpacing

Field Value

Type: Char
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding Methods

Grid Solutions Framework ByteEncoding Methods

The ByteEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer.
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.GetBytes Method

Grid Solutions Framework ByteEncodingGetBytes Method
Overload List
 | Name | Description
Public method | GetBytes(String) | Decodes given string back into a byte buffer.
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer.
Top
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.GetBytes Method (String)

Grid Solutions Framework ByteEncodingGetBytes Method (String)
Decodes given string back into a byte buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte[] GetBytes(
    string value
)
Public Overridable Function GetBytes (
    value As String
) As Byte()
abstract GetBytes :
        value : string -> byte[]
override GetBytes :
        value : string -> byte[]
function GetBytes(value);
public:
virtual array<unsigned char>^ GetBytes(
    String^ value
)

Parameters

value
Type: SystemString
Encoded string to decode.

Return Value

Type: Byte
Decoded bytes.
See Also

Reference

ByteEncoding Class
GetBytes Overload
GSF Namespace


ByteEncoding.GetBytes Method (String, Char)

Grid Solutions Framework ByteEncodingGetBytes Method (String, Char)
Decodes given string back into a byte buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract byte[] GetBytes(
    string value,
    char spacingCharacter
)
Public MustOverride Function GetBytes (
    value As String,
    spacingCharacter As Char
) As Byte()
abstract GetBytes :
        value : string *
        spacingCharacter : char -> byte[]

function GetBytes(value, spacingCharacter);
public:
virtual array<unsigned char>^ GetBytes(
    String^ value,
    wchar_t spacingCharacter
) abstract

Parameters

value
Type: SystemString
Encoded string to decode.
spacingCharacter
Type: SystemChar
Original spacing character that was inserted between encoded bytes.

Return Value

Type: Byte
Decoded bytes
See Also

Reference

ByteEncoding Class
GetBytes Overload
GSF Namespace


ByteEncoding.GetString Method

Grid Solutions Framework ByteEncodingGetString Method
Overload List
 | Name | Description
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation.
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation.
Top
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.GetString Method (Byte[])

Grid Solutions Framework ByteEncodingGetString Method (Byte)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string GetString(
    byte[] bytes
)
Public Overridable Function GetString (
    bytes As Byte()
) As String
abstract GetString :
        bytes : byte[] -> string
override GetString :
        bytes : byte[] -> string
function GetString(bytes);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes
)

Parameters

bytes
Type: SystemByte
Bytes to encode.

Return Value

Type: String
String representation of byte array.
See Also

Reference

ByteEncoding Class
GetString Overload
GSF Namespace


ByteEncoding.GetString Method (Byte[], Char)

Grid Solutions Framework ByteEncodingGetString Method (Byte, Char)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string GetString(
    byte[] bytes,
    char spacingCharacter
)
Public Overridable Function GetString (
    bytes As Byte(),
    spacingCharacter As Char
) As String
abstract GetString :
        bytes : byte[] *
        spacingCharacter : char -> string
override GetString :
        bytes : byte[] *
        spacingCharacter : char -> string
function GetString(bytes, spacingCharacter);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    wchar_t spacingCharacter
)

Parameters

bytes
Type: SystemByte
Bytes to encode.
spacingCharacter
Type: SystemChar
Spacing character to place between encoded bytes.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncoding Class
GetString Overload
GSF Namespace


ByteEncoding.GetString Method (Byte[], Int32, Int32)

Grid Solutions Framework ByteEncodingGetString Method (Byte, Int32, Int32)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string GetString(
    byte[] bytes,
    int offset,
    int length
)
Public Overridable Function GetString (
    bytes As Byte(),
    offset As Integer,
    length As Integer
) As String
abstract GetString :
        bytes : byte[] *
        offset : int *
        length : int -> string
override GetString :
        bytes : byte[] *
        offset : int *
        length : int -> string
function GetString(bytes, offset, length);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    int offset,
    int length
)

Parameters

bytes
Type: SystemByte
Bytes to encode.
offset
Type: SystemInt32
Offset into buffer to begin encoding.
length
Type: SystemInt32
Length of buffer to encode.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncoding Class
GetString Overload
GSF Namespace


ByteEncoding.GetString Method (Byte[], Int32, Int32, Char)

Grid Solutions Framework ByteEncodingGetString Method (Byte, Int32, Int32, Char)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract string GetString(
    byte[] bytes,
    int offset,
    int length,
    char spacingCharacter
)
Public MustOverride Function GetString (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    spacingCharacter As Char
) As String
abstract GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string

function GetString(bytes, offset, length, spacingCharacter);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    wchar_t spacingCharacter
) abstract

Parameters

bytes
Type: SystemByte
Bytes to encode.
offset
Type: SystemInt32
Offset into buffer to begin encoding.
length
Type: SystemInt32
Length of buffer to encode.
spacingCharacter
Type: SystemChar
Spacing character to place between encoded bytes.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncoding Class
GetString Overload
GSF Namespace


ByteEncoding Properties

Grid Solutions Framework ByteEncoding Properties

The ByteEncoding type exposes the following members.

Properties
Name | Description
ASCII | Handles encoding and decoding of a byte buffer into an ASCII character presentation format.
Base64 | Handles encoding and decoding of a byte buffer into a base64 presentation format.
BigEndianBinary | Handles encoding and decoding of a byte buffer into a big-endian binary (i.e., 0 and 1's) based presentation format.
Decimal | Handles encoding and decoding of a byte buffer into an integer-based presentation format.
Hexadecimal | Handles encoding and decoding of a byte buffer into a hexadecimal-based presentation format.
LittleEndianBinary | Handles encoding and decoding of a byte buffer into a little-endian binary (i.e., 0 and 1's) based presentation format.
Top
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.ASCII Property

Grid Solutions Framework ByteEncodingASCII Property
Handles encoding and decoding of a byte buffer into an ASCII character presentation format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ByteEncoding ASCII { get; }
Public Shared ReadOnly Property ASCII As ByteEncoding
    Get
static member ASCII : ByteEncoding with get

GSF.ByteEncoding.get_ASCII = function();

public:
static property ByteEncoding^ ASCII {
    ByteEncoding^ get ();
}

Property Value

Type: ByteEncoding
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.Base64 Property

Grid Solutions Framework ByteEncodingBase64 Property
Handles encoding and decoding of a byte buffer into a base64 presentation format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ByteEncoding Base64 { get; }
Public Shared ReadOnly Property Base64 As ByteEncoding
    Get
static member Base64 : ByteEncoding with get

GSF.ByteEncoding.get_Base64 = function();

public:
static property ByteEncoding^ Base64 {
    ByteEncoding^ get ();
}

Property Value

Type: ByteEncoding
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.BigEndianBinary Property

Grid Solutions Framework ByteEncodingBigEndianBinary Property
Handles encoding and decoding of a byte buffer into a big-endian binary (i.e., 0 and 1's) based presentation format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ByteEncoding BigEndianBinary { get; }
Public Shared ReadOnly Property BigEndianBinary As ByteEncoding
    Get
static member BigEndianBinary : ByteEncoding with get

GSF.ByteEncoding.get_BigEndianBinary = function();

public:
static property ByteEncoding^ BigEndianBinary {
    ByteEncoding^ get ();
}

Property Value

Type: ByteEncoding
Remarks
Although endianness is typically used in the context of byte order (see EndianOrder to handle byte order swapping), this property allows you visualize "bits" in big-endian order, right-to-left. Note that bits are normally stored in the same order as their bytes.).
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.Decimal Property

Grid Solutions Framework ByteEncodingDecimal Property
Handles encoding and decoding of a byte buffer into an integer-based presentation format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ByteEncoding Decimal { get; }
Public Shared ReadOnly Property Decimal As ByteEncoding
    Get
static member Decimal : ByteEncoding with get

GSF.ByteEncoding.get_Decimal = function();

public:
static property ByteEncoding^ Decimal {
    ByteEncoding^ get ();
}

Property Value

Type: ByteEncoding
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.Hexadecimal Property

Grid Solutions Framework ByteEncodingHexadecimal Property
Handles encoding and decoding of a byte buffer into a hexadecimal-based presentation format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ByteEncoding Hexadecimal { get; }
Public Shared ReadOnly Property Hexadecimal As ByteEncoding
    Get
static member Hexadecimal : ByteEncoding with get

GSF.ByteEncoding.get_Hexadecimal = function();

public:
static property ByteEncoding^ Hexadecimal {
    ByteEncoding^ get ();
}

Property Value

Type: ByteEncoding
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.LittleEndianBinary Property

Grid Solutions Framework ByteEncodingLittleEndianBinary Property
Handles encoding and decoding of a byte buffer into a little-endian binary (i.e., 0 and 1's) based presentation format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ByteEncoding LittleEndianBinary { get; }
Public Shared ReadOnly Property LittleEndianBinary As ByteEncoding
    Get
static member LittleEndianBinary : ByteEncoding with get

GSF.ByteEncoding.get_LittleEndianBinary = function();

public:
static property ByteEncoding^ LittleEndianBinary {
    ByteEncoding^ get ();
}

Property Value

Type: ByteEncoding
Remarks
Although endianness is typically used in the context of byte order (see EndianOrder to handle byte order swapping), this property allows you visualize "bits" in little-endian order, left-to-right. Note that bits are normally stored in the same order as their bytes.
See Also

Reference

ByteEncoding Class
GSF Namespace


ByteEncoding.ASCIIEncoding Class

Grid Solutions Framework ByteEncodingASCIIEncoding Class
Handles conversion of byte buffers to and from a ASCII data format.
Inheritance Hierarchy
SystemObject
GSFByteEncoding
GSFByteEncodingASCIIEncoding

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class ASCIIEncoding : ByteEncoding
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class ASCIIEncoding
    Inherits ByteEncoding
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type ASCIIEncoding =
    class
        inherit ByteEncoding
    end
GSF.ASCIIEncoding = function();

Type.createClass(
    'GSF.ASCIIEncoding',
    GSF.ByteEncoding);
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public ref class ASCIIEncoding : public ByteEncoding

The ByteEncodingASCIIEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF Namespace


ASCIIEncoding Methods

Grid Solutions Framework ASCIIEncoding Methods

The ByteEncodingASCIIEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ByteEncodingASCIIEncoding Class
GSF Namespace


ASCIIEncoding.GetBytes Method

Grid Solutions Framework ASCIIEncodingGetBytes Method
Overload List
 | Name | Description
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Top
See Also

Reference

ByteEncodingASCIIEncoding Class
GSF Namespace


ByteEncoding.ASCIIEncoding.GetBytes Method (String, Char)

Grid Solutions Framework ByteEncodingASCIIEncodingGetBytes Method (String, Char)
Decodes given string back into a byte buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] GetBytes(
    string binaryData,
    char spacingCharacter
)
Public Overrides Function GetBytes (
    binaryData As String,
    spacingCharacter As Char
) As Byte()
abstract GetBytes :
        binaryData : string *
        spacingCharacter : char -> byte[]
override GetBytes :
        binaryData : string *
        spacingCharacter : char -> byte[]
function GetBytes(binaryData, spacingCharacter);
public:
virtual array<unsigned char>^ GetBytes(
    String^ binaryData,
    wchar_t spacingCharacter
) override

Parameters

binaryData
Type: SystemString
Encoded binary data string to decode.
spacingCharacter
Type: SystemChar
Original spacing character that was inserted between encoded bytes.

Return Value

Type: Byte
Decoded bytes.
See Also

Reference

ByteEncodingASCIIEncoding Class
GetBytes Overload
GSF Namespace


ASCIIEncoding.GetString Method

Grid Solutions Framework ASCIIEncodingGetString Method
Overload List
 | Name | Description
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Top
See Also

Reference

ByteEncodingASCIIEncoding Class
GSF Namespace


ByteEncoding.ASCIIEncoding.GetString Method (Byte[], Int32, Int32, Char)

Grid Solutions Framework ByteEncodingASCIIEncodingGetString Method (Byte, Int32, Int32, Char)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetString(
    byte[] bytes,
    int offset,
    int length,
    char spacingCharacter
)
Public Overrides Function GetString (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    spacingCharacter As Char
) As String
abstract GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
override GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
function GetString(bytes, offset, length, spacingCharacter);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    wchar_t spacingCharacter
) override

Parameters

bytes
Type: SystemByte
Bytes to encode.
offset
Type: SystemInt32
Offset into buffer to begin encoding.
length
Type: SystemInt32
Length of buffer to encode.
spacingCharacter
Type: SystemChar
Spacing character to place between encoded bytes.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncodingASCIIEncoding Class
GetString Overload
GSF Namespace


ByteEncoding.Base64Encoding Class

Grid Solutions Framework ByteEncodingBase64Encoding Class
Handles conversion of byte buffers to and from a base64 data format.
Inheritance Hierarchy
SystemObject
GSFByteEncoding
GSFByteEncodingBase64Encoding

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class Base64Encoding : ByteEncoding
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class Base64Encoding
    Inherits ByteEncoding
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type Base64Encoding =
    class
        inherit ByteEncoding
    end
GSF.Base64Encoding = function();

Type.createClass(
    'GSF.Base64Encoding',
    GSF.ByteEncoding);
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public ref class Base64Encoding : public ByteEncoding

The ByteEncodingBase64Encoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF Namespace


Base64Encoding Methods

Grid Solutions Framework Base64Encoding Methods

The ByteEncodingBase64Encoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ByteEncodingBase64Encoding Class
GSF Namespace


Base64Encoding.GetBytes Method

Grid Solutions Framework Base64EncodingGetBytes Method
Overload List
 | Name | Description
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Top
See Also

Reference

ByteEncodingBase64Encoding Class
GSF Namespace


ByteEncoding.Base64Encoding.GetBytes Method (String, Char)

Grid Solutions Framework ByteEncodingBase64EncodingGetBytes Method (String, Char)
Decodes given string back into a byte buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] GetBytes(
    string binaryData,
    char spacingCharacter
)
Public Overrides Function GetBytes (
    binaryData As String,
    spacingCharacter As Char
) As Byte()
abstract GetBytes :
        binaryData : string *
        spacingCharacter : char -> byte[]
override GetBytes :
        binaryData : string *
        spacingCharacter : char -> byte[]
function GetBytes(binaryData, spacingCharacter);
public:
virtual array<unsigned char>^ GetBytes(
    String^ binaryData,
    wchar_t spacingCharacter
) override

Parameters

binaryData
Type: SystemString
Encoded binary data string to decode.
spacingCharacter
Type: SystemChar
Original spacing character that was inserted between encoded bytes.

Return Value

Type: Byte
Decoded bytes.
See Also

Reference

ByteEncodingBase64Encoding Class
GetBytes Overload
GSF Namespace


Base64Encoding.GetString Method

Grid Solutions Framework Base64EncodingGetString Method
Overload List
 | Name | Description
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Top
See Also

Reference

ByteEncodingBase64Encoding Class
GSF Namespace


ByteEncoding.Base64Encoding.GetString Method (Byte[], Int32, Int32, Char)

Grid Solutions Framework ByteEncodingBase64EncodingGetString Method (Byte, Int32, Int32, Char)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetString(
    byte[] bytes,
    int offset,
    int length,
    char spacingCharacter
)
Public Overrides Function GetString (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    spacingCharacter As Char
) As String
abstract GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
override GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
function GetString(bytes, offset, length, spacingCharacter);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    wchar_t spacingCharacter
) override

Parameters

bytes
Type: SystemByte
Bytes to encode.
offset
Type: SystemInt32
Offset into buffer to begin encoding.
length
Type: SystemInt32
Length of buffer to encode.
spacingCharacter
Type: SystemChar
Spacing character to place between encoded bytes.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncodingBase64Encoding Class
GetString Overload
GSF Namespace


ByteEncoding.BinaryEncoding Class

Grid Solutions Framework ByteEncodingBinaryEncoding Class
Handles conversion of byte buffers to and from a binary (i.e., 0 and 1's) data format.
Inheritance Hierarchy
SystemObject
GSFByteEncoding
GSFByteEncodingBinaryEncoding

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class BinaryEncoding : ByteEncoding
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class BinaryEncoding
    Inherits ByteEncoding
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type BinaryEncoding =
    class
        inherit ByteEncoding
    end
GSF.BinaryEncoding = function();

Type.createClass(
    'GSF.BinaryEncoding',
    GSF.ByteEncoding);
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public ref class BinaryEncoding : public ByteEncoding

The ByteEncodingBinaryEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF Namespace


BinaryEncoding Methods

Grid Solutions Framework BinaryEncoding Methods

The ByteEncodingBinaryEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ByteEncodingBinaryEncoding Class
GSF Namespace


BinaryEncoding.GetBytes Method

Grid Solutions Framework BinaryEncodingGetBytes Method
Overload List
 | Name | Description
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Top
See Also

Reference

ByteEncodingBinaryEncoding Class
GSF Namespace


ByteEncoding.BinaryEncoding.GetBytes Method (String, Char)

Grid Solutions Framework ByteEncodingBinaryEncodingGetBytes Method (String, Char)
Decodes given string back into a byte buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] GetBytes(
    string binaryData,
    char spacingCharacter
)
Public Overrides Function GetBytes (
    binaryData As String,
    spacingCharacter As Char
) As Byte()
abstract GetBytes :
        binaryData : string *
        spacingCharacter : char -> byte[]
override GetBytes :
        binaryData : string *
        spacingCharacter : char -> byte[]
function GetBytes(binaryData, spacingCharacter);
public:
virtual array<unsigned char>^ GetBytes(
    String^ binaryData,
    wchar_t spacingCharacter
) override

Parameters

binaryData
Type: SystemString
Encoded binary data string to decode.
spacingCharacter
Type: SystemChar
Original spacing character that was inserted between encoded bytes.

Return Value

Type: Byte
Decoded bytes.
See Also

Reference

ByteEncodingBinaryEncoding Class
GetBytes Overload
GSF Namespace


BinaryEncoding.GetString Method

Grid Solutions Framework BinaryEncodingGetString Method
Overload List
 | Name | Description
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Top
See Also

Reference

ByteEncodingBinaryEncoding Class
GSF Namespace


ByteEncoding.BinaryEncoding.GetString Method (Byte[], Int32, Int32, Char)

Grid Solutions Framework ByteEncodingBinaryEncodingGetString Method (Byte, Int32, Int32, Char)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetString(
    byte[] bytes,
    int offset,
    int length,
    char spacingCharacter
)
Public Overrides Function GetString (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    spacingCharacter As Char
) As String
abstract GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
override GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
function GetString(bytes, offset, length, spacingCharacter);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    wchar_t spacingCharacter
) override

Parameters

bytes
Type: SystemByte
Bytes to encode.
offset
Type: SystemInt32
Offset into buffer to begin encoding.
length
Type: SystemInt32
Length of buffer to encode.
spacingCharacter
Type: SystemChar
Spacing character to place between encoded bytes.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncodingBinaryEncoding Class
GetString Overload
GSF Namespace


ByteEncoding.DecimalEncoding Class

Grid Solutions Framework ByteEncodingDecimalEncoding Class
Handles conversion of byte buffers to and from a decimal data format.
Inheritance Hierarchy
SystemObject
GSFByteEncoding
GSFByteEncodingDecimalEncoding

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class DecimalEncoding : ByteEncoding
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class DecimalEncoding
    Inherits ByteEncoding
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type DecimalEncoding =
    class
        inherit ByteEncoding
    end
GSF.DecimalEncoding = function();

Type.createClass(
    'GSF.DecimalEncoding',
    GSF.ByteEncoding);
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public ref class DecimalEncoding : public ByteEncoding

The ByteEncodingDecimalEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF Namespace


DecimalEncoding Methods

Grid Solutions Framework DecimalEncoding Methods

The ByteEncodingDecimalEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ByteEncodingDecimalEncoding Class
GSF Namespace


DecimalEncoding.GetBytes Method

Grid Solutions Framework DecimalEncodingGetBytes Method
Overload List
 | Name | Description
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Top
See Also

Reference

ByteEncodingDecimalEncoding Class
GSF Namespace


ByteEncoding.DecimalEncoding.GetBytes Method (String, Char)

Grid Solutions Framework ByteEncodingDecimalEncodingGetBytes Method (String, Char)
Decodes given string back into a byte buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] GetBytes(
    string decData,
    char spacingCharacter
)
Public Overrides Function GetBytes (
    decData As String,
    spacingCharacter As Char
) As Byte()
abstract GetBytes :
        decData : string *
        spacingCharacter : char -> byte[]
override GetBytes :
        decData : string *
        spacingCharacter : char -> byte[]
function GetBytes(decData, spacingCharacter);
public:
virtual array<unsigned char>^ GetBytes(
    String^ decData,
    wchar_t spacingCharacter
) override

Parameters

decData
Type: SystemString
Encoded decimal data string to decode.
spacingCharacter
Type: SystemChar
Original spacing character that was inserted between encoded bytes.

Return Value

Type: Byte
Decoded bytes.
See Also

Reference

ByteEncodingDecimalEncoding Class
GetBytes Overload
GSF Namespace


DecimalEncoding.GetString Method

Grid Solutions Framework DecimalEncodingGetString Method
Overload List
 | Name | Description
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Top
See Also

Reference

ByteEncodingDecimalEncoding Class
GSF Namespace


ByteEncoding.DecimalEncoding.GetString Method (Byte[], Int32, Int32, Char)

Grid Solutions Framework ByteEncodingDecimalEncodingGetString Method (Byte, Int32, Int32, Char)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetString(
    byte[] bytes,
    int offset,
    int length,
    char spacingCharacter
)
Public Overrides Function GetString (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    spacingCharacter As Char
) As String
abstract GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
override GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
function GetString(bytes, offset, length, spacingCharacter);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    wchar_t spacingCharacter
) override

Parameters

bytes
Type: SystemByte
Bytes to encode.
offset
Type: SystemInt32
Offset into buffer to begin encoding.
length
Type: SystemInt32
Length of buffer to encode.
spacingCharacter
Type: SystemChar
Spacing character to place between encoded bytes.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncodingDecimalEncoding Class
GetString Overload
GSF Namespace


ByteEncoding.HexadecimalEncoding Class

Grid Solutions Framework ByteEncodingHexadecimalEncoding Class
Handles conversion of byte buffers to and from a hexadecimal data format.
Inheritance Hierarchy
SystemObject
GSFByteEncoding
GSFByteEncodingHexadecimalEncoding

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class HexadecimalEncoding : ByteEncoding
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class HexadecimalEncoding
    Inherits ByteEncoding
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type HexadecimalEncoding =
    class
        inherit ByteEncoding
    end
GSF.HexadecimalEncoding = function();

Type.createClass(
    'GSF.HexadecimalEncoding',
    GSF.ByteEncoding);
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public ref class HexadecimalEncoding : public ByteEncoding

The ByteEncodingHexadecimalEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF Namespace


HexadecimalEncoding Methods

Grid Solutions Framework HexadecimalEncoding Methods

The ByteEncodingHexadecimalEncoding type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ByteEncodingHexadecimalEncoding Class
GSF Namespace


HexadecimalEncoding.GetBytes Method

Grid Solutions Framework HexadecimalEncodingGetBytes Method
Overload List
 | Name | Description
Public method | GetBytes(String) | Decodes given string back into a byte buffer. (Inherited from ByteEncoding.)
Public method | GetBytes(String, Char) | Decodes given string back into a byte buffer. (Overrides ByteEncodingGetBytes(String, Char).)
Top
See Also

Reference

ByteEncodingHexadecimalEncoding Class
GSF Namespace


ByteEncoding.HexadecimalEncoding.GetBytes Method (String, Char)

Grid Solutions Framework ByteEncodingHexadecimalEncodingGetBytes Method (String, Char)
Decodes given string back into a byte buffer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] GetBytes(
    string hexData,
    char spacingCharacter
)
Public Overrides Function GetBytes (
    hexData As String,
    spacingCharacter As Char
) As Byte()
abstract GetBytes :
        hexData : string *
        spacingCharacter : char -> byte[]
override GetBytes :
        hexData : string *
        spacingCharacter : char -> byte[]
function GetBytes(hexData, spacingCharacter);
public:
virtual array<unsigned char>^ GetBytes(
    String^ hexData,
    wchar_t spacingCharacter
) override

Parameters

hexData
Type: SystemString
Encoded hexadecimal data string to decode.
spacingCharacter
Type: SystemChar
Original spacing character that was inserted between encoded bytes.

Return Value

Type: Byte
Decoded bytes.
See Also

Reference

ByteEncodingHexadecimalEncoding Class
GetBytes Overload
GSF Namespace


HexadecimalEncoding.GetString Method

Grid Solutions Framework HexadecimalEncodingGetString Method
Overload List
 | Name | Description
Public method | GetString(Byte) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Char) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32) | Encodes given buffer into a user presentable representation. (Inherited from ByteEncoding.)
Public method | GetString(Byte, Int32, Int32, Char) | Encodes given buffer into a user presentable representation. (Overrides ByteEncodingGetString(Byte, Int32, Int32, Char).)
Top
See Also

Reference

ByteEncodingHexadecimalEncoding Class
GSF Namespace


ByteEncoding.HexadecimalEncoding.GetString Method (Byte[], Int32, Int32, Char)

Grid Solutions Framework ByteEncodingHexadecimalEncodingGetString Method (Byte, Int32, Int32, Char)
Encodes given buffer into a user presentable representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetString(
    byte[] bytes,
    int offset,
    int length,
    char spacingCharacter
)
Public Overrides Function GetString (
    bytes As Byte(),
    offset As Integer,
    length As Integer,
    spacingCharacter As Char
) As String
abstract GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
override GetString :
        bytes : byte[] *
        offset : int *
        length : int *
        spacingCharacter : char -> string
function GetString(bytes, offset, length, spacingCharacter);
public:
virtual String^ GetString(
    array<unsigned char>^ bytes,
    int offset,
    int length,
    wchar_t spacingCharacter
) override

Parameters

bytes
Type: SystemByte
Bytes to encode.
offset
Type: SystemInt32
Offset into buffer to begin encoding.
length
Type: SystemInt32
Length of buffer to encode.
spacingCharacter
Type: SystemChar
Spacing character to place between encoded bytes.

Return Value

Type: String
String of encoded bytes.
See Also

Reference

ByteEncodingHexadecimalEncoding Class
GetString Overload
GSF Namespace


CharExtensions Class

Grid Solutions Framework CharExtensions Class
Defines extension functions related to character manipulation.
Inheritance Hierarchy
SystemObject
GSFCharExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class CharExtensions
<ExtensionAttribute>
Public NotInheritable Class CharExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CharExtensions =  class end
GSF.CharExtensions = function();

Type.createClass(
    'GSF.CharExtensions');
[ExtensionAttribute]
public ref class CharExtensions abstract sealed

The CharExtensions type exposes the following members.

Methods
Name | Description
IsAnyOf | Determines if a character matches any character in a sent array.
IsInRange | Tests a character to determine if it is between a specified character range
IsNumeric | Tests a character to determine if is a common part of a numeric string (digits or one of "+ - , .")
IsWordTerminator | Tests a character to determine if it marks the end of a typical English word.
RegexEncode | Encodes the specified Unicode character in proper Regular Expression format.
Top
See Also

Reference

GSF Namespace


CharExtensions Methods

Grid Solutions Framework CharExtensions Methods

The CharExtensions type exposes the following members.

Methods
Name | Description
IsAnyOf | Determines if a character matches any character in a sent array.
IsInRange | Tests a character to determine if it is between a specified character range
IsNumeric | Tests a character to determine if is a common part of a numeric string (digits or one of "+ - , .")
IsWordTerminator | Tests a character to determine if it marks the end of a typical English word.
RegexEncode | Encodes the specified Unicode character in proper Regular Expression format.
Top
See Also

Reference

CharExtensions Class
GSF Namespace


CharExtensions.IsAnyOf Method

Grid Solutions Framework CharExtensionsIsAnyOf Method
Determines if a character matches any character in a sent array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAnyOf(
    this char value,
    IEnumerable<char> testChars
)
<ExtensionAttribute>
Public Shared Function IsAnyOf (
    value As Char,
    testChars As IEnumerable(Of Char)
) As Boolean
static member IsAnyOf :
        value : char *
        testChars : IEnumerable<char> -> bool

GSF.CharExtensions.IsAnyOf = function(value, testChars);
public:
[ExtensionAttribute]
static bool IsAnyOf(
    wchar_t value,
    IEnumerable<wchar_t>^ testChars
)

Parameters

value
Type: SystemChar
The character to check.
testChars
Type: System.Collections.GenericIEnumerable Char
The array of characters to test.

Return Value

Type: Boolean
Boolean value indicating a that the character is in the array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Char. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CharExtensions Class
GSF Namespace


CharExtensions.IsInRange Method

Grid Solutions Framework CharExtensionsIsInRange Method
Tests a character to determine if it is between a specified character range

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsInRange(
    this char value,
    char startOfRange,
    char endOfRange
)
<ExtensionAttribute>
Public Shared Function IsInRange (
    value As Char,
    startOfRange As Char,
    endOfRange As Char
) As Boolean
static member IsInRange :
        value : char *
        startOfRange : char *
        endOfRange : char -> bool

GSF.CharExtensions.IsInRange = function(value, startOfRange, endOfRange);
public:
[ExtensionAttribute]
static bool IsInRange(
    wchar_t value,
    wchar_t startOfRange,
    wchar_t endOfRange
)

Parameters

value
Type: SystemChar
Input character to process.
startOfRange
Type: SystemChar
Beginning of range character.
endOfRange
Type: SystemChar
End of range character.

Return Value

Type: Boolean
true is the character is within the range.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Char. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CharExtensions Class
GSF Namespace


CharExtensions.IsNumeric Method

Grid Solutions Framework CharExtensionsIsNumeric Method
Tests a character to determine if is a common part of a numeric string (digits or one of "+ - , .")

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsNumeric(
    this char value
)
<ExtensionAttribute>
Public Shared Function IsNumeric (
    value As Char
) As Boolean
static member IsNumeric :
        value : char -> bool

GSF.CharExtensions.IsNumeric = function(value);
public:
[ExtensionAttribute]
static bool IsNumeric(
    wchar_t value
)

Parameters

value
Type: SystemChar
The character to check.

Return Value

Type: Boolean
true if numeric character.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Char. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CharExtensions Class
GSF Namespace


CharExtensions.IsWordTerminator Method

Grid Solutions Framework CharExtensionsIsWordTerminator Method
Tests a character to determine if it marks the end of a typical English word.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsWordTerminator(
    this char value
)
<ExtensionAttribute>
Public Shared Function IsWordTerminator (
    value As Char
) As Boolean
static member IsWordTerminator :
        value : char -> bool

GSF.CharExtensions.IsWordTerminator = function(value);
public:
[ExtensionAttribute]
static bool IsWordTerminator(
    wchar_t value
)

Parameters

value
Type: SystemChar
Input character to check.

Return Value

Type: Boolean
true if character is a work separator.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Char. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Performs no testing for ASCII codes > 127.
Does not separate words based on punctuation of ' % - _
However does include the angle bracket symbols < > as separators

For reference the standard char tests are:
  • "IsSperator (1) == simple space (32 or 160) only.
  • IsPunctuation (23) == . , ! ? : ; " ' [ ] { } ( ) \ / @ % # * & - _ (plus other char's > 127)
  • IsSymbol (8) == $ + < > = ^ ` ~
  • IsWhiteSpace (6) == control char's 9 thru 13, plus 32 -- TAB, LF, VT, FF, CR, SP
See Also

Reference

CharExtensions Class
GSF Namespace


CharExtensions.RegexEncode Method

Grid Solutions Framework CharExtensionsRegexEncode Method
Encodes the specified Unicode character in proper Regular Expression format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RegexEncode(
    this char item
)
<ExtensionAttribute>
Public Shared Function RegexEncode (
    item As Char
) As String
static member RegexEncode :
        item : char -> string

GSF.CharExtensions.RegexEncode = function(item);
public:
[ExtensionAttribute]
static String^ RegexEncode(
    wchar_t item
)

Parameters

item
Type: SystemChar
Unicode character to encode in Regular Expression format.

Return Value

Type: String
Specified Unicode character in proper Regular Expression format.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Char. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CharExtensions Class
GSF Namespace


Common Class

Grid Solutions Framework Common Class
Defines common global functions.
Inheritance Hierarchy
SystemObject
GSFCommon

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
<ExtensionAttribute>
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.Common = function();

Type.createClass(
    'GSF.Common');
[ExtensionAttribute]
public ref class Common abstract sealed

The Common type exposes the following members.

Methods
Name | Description
CreateArrayT(Int32) | Creates a strongly-typed Array.
CreateArrayT(Int32, T) | Creates a strongly-typed Array with an initial value parameter.
GetApplicationType | Gets the type of the currently executing application.
GetOSPlatformID | Gets the operating system PlatformID
GetOSProductName | Gets the operating system product name.
GetProcessMemory | Gets the memory usage by the current process.
IIfT | Returns one of two strongly-typed objects.
IsDefaultValue | Determines if given item is equal to its default value (e.g., null or 0.0).
IsNonStringReference | Determines if given item is a reference type but not a string.
IsNumeric | Determines if given item is numeric.
IsReference | Determines if given item is a reference type.
MaxT | Returns the largest item from a list of parameters.
MidT | Returns the value that is neither the largest nor the smallest.
MinT | Returns the smallest item from a list of parameters.
ToNonNullNorEmptyStringT | Converts value to string; null objects, DBNull objects or empty strings will return specified nonNullNorEmptyValue.
ToNonNullNorWhiteSpaceT | Converts value to string; null objects, DBNull objects, empty strings or all white space strings will return specified nonNullNorWhiteSpaceValue.
ToNonNullString(String) | Makes sure returned string value is not null; if this string is null, empty string ("") will be returned.
ToNonNullStringT(T) | Converts value to string; null objects (or DBNull objects) will return an empty string ("").
ToNonNullStringT(T, String) | Converts value to string; null objects (or DBNull objects) will return specified nonNullValue.
TypeConvertToString(Object) | Converts value to a String using an appropriate TypeConverter.
TypeConvertToString(Object, CultureInfo) | Converts value to a String using an appropriate TypeConverter.
Top
Fields
Name | Description
IsMono | Determines if the code base is currently running under Mono.
IsPosixEnvironment | Determines if the current system is a POSIX style environment.
Top
Properties
Name | Description
SystemTimer | Gets a high-resolution number of seconds, including fractional seconds, that have elapsed since 12:00:00 midnight, January 1, 0001.
Top
See Also

Reference

GSF Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
IsMono | Determines if the code base is currently running under Mono.
IsPosixEnvironment | Determines if the current system is a POSIX style environment.
Top
See Also

Reference

Common Class
GSF Namespace


Common.IsMono Field

Grid Solutions Framework CommonIsMono Field
Determines if the code base is currently running under Mono.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsMono
Public Shared IsMono As Boolean
static val mutable IsMono: bool
var GSF.Common.IsMono
public:
static bool IsMono

Field Value

Type: Boolean
Remarks
This property can be used to make a run-time determination if Windows or Mono based .NET is being used. However, it is highly recommended to use the MONO compiler directive wherever possible instead of determining this at run-time.
See Also

Reference

Common Class
GSF Namespace


Common.IsPosixEnvironment Field

Grid Solutions Framework CommonIsPosixEnvironment Field
Determines if the current system is a POSIX style environment.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly bool IsPosixEnvironment
Public Shared ReadOnly IsPosixEnvironment As Boolean
static val IsPosixEnvironment: bool
var GSF.Common.IsPosixEnvironment
public:
static initonly bool IsPosixEnvironment

Field Value

Type: Boolean
Remarks

Since a .NET application compiled under Mono can run under both Windows and Unix style platforms, you can use this property to easily determine the current operating environment.

This property will return true for both MacOSX and Unix environments. Use the Platform property of the OSVersion to determine more specific platform type, e.g., MacOSX or Unix. Note that all flavors of Linux will show up as Unix.

See Also

Reference

Common Class
GSF Namespace


Common Methods

Grid Solutions Framework Common Methods

The Common type exposes the following members.

Methods
Name | Description
CreateArrayT(Int32) | Creates a strongly-typed Array.
CreateArrayT(Int32, T) | Creates a strongly-typed Array with an initial value parameter.
GetApplicationType | Gets the type of the currently executing application.
GetOSPlatformID | Gets the operating system PlatformID
GetOSProductName | Gets the operating system product name.
GetProcessMemory | Gets the memory usage by the current process.
IIfT | Returns one of two strongly-typed objects.
IsDefaultValue | Determines if given item is equal to its default value (e.g., null or 0.0).
IsNonStringReference | Determines if given item is a reference type but not a string.
IsNumeric | Determines if given item is numeric.
IsReference | Determines if given item is a reference type.
MaxT | Returns the largest item from a list of parameters.
MidT | Returns the value that is neither the largest nor the smallest.
MinT | Returns the smallest item from a list of parameters.
ToNonNullNorEmptyStringT | Converts value to string; null objects, DBNull objects or empty strings will return specified nonNullNorEmptyValue.
ToNonNullNorWhiteSpaceT | Converts value to string; null objects, DBNull objects, empty strings or all white space strings will return specified nonNullNorWhiteSpaceValue.
ToNonNullString(String) | Makes sure returned string value is not null; if this string is null, empty string ("") will be returned.
ToNonNullStringT(T) | Converts value to string; null objects (or DBNull objects) will return an empty string ("").
ToNonNullStringT(T, String) | Converts value to string; null objects (or DBNull objects) will return specified nonNullValue.
TypeConvertToString(Object) | Converts value to a String using an appropriate TypeConverter.
TypeConvertToString(Object, CultureInfo) | Converts value to a String using an appropriate TypeConverter.
Top
See Also

Reference

Common Class
GSF Namespace


Common.CreateArray Method

Grid Solutions Framework CommonCreateArray Method
Overload List
Name | Description
CreateArrayT(Int32) | Creates a strongly-typed Array.
CreateArrayT(Int32, T) | Creates a strongly-typed Array with an initial value parameter.
Top
See Also

Reference

Common Class
GSF Namespace


Common.CreateArray(T) Method (Int32)

Grid Solutions Framework CommonCreateArrayT Method (Int32)
Creates a strongly-typed Array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] CreateArray<T>(
    int length
)

Public Shared Function CreateArray(Of T) (
    length As Integer
) As T()
static member CreateArray :
        length : int -> 'T[]

JavaScript does not support generic types or methods.
public:
generic<typename T>
static array<T>^ CreateArray(
    int length
)

Parameters

length
Type: SystemInt32
Desired length of new array.

Type Parameters

T
Return type for new array.

Return Value

Type: T
New array of specified type.
Remarks

It is expected that this function will only be used in Visual Basic.NET.

The Array.CreateInstance provides better performance and more direct CLR access for array creation (not to mention less confusion on the matter of array lengths) in VB.NET, however the returned System.Array is not typed properly. This function properly casts the return array based on the type specification helping when Option Strict is enabled.

Examples
VB
Copy
Dim buffer As Byte() = CreateArray(Of Byte)(12)
Dim matrix As Integer()() = CreateArray(Of Integer())(10)
See Also

Reference

Common Class
CreateArray Overload
GSF Namespace


Common.CreateArray(T) Method (Int32, T)

Grid Solutions Framework CommonCreateArrayT Method (Int32, T)
Creates a strongly-typed Array with an initial value parameter.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] CreateArray<T>(
    int length,
    T initialValue
)

Public Shared Function CreateArray(Of T) (
    length As Integer,
    initialValue As T
) As T()
static member CreateArray :
        length : int *
        initialValue : 'T -> 'T[]

JavaScript does not support generic types or methods.
public:
generic<typename T>
static array<T>^ CreateArray(
    int length,
    T initialValue
)

Parameters

length
Type: SystemInt32
Desired length of new array.
initialValue
Type: T
Value used to initialize all array elements.

Type Parameters

T
Return type for new array.

Return Value

Type: T
New array of specified type.
Remarks
It is expected that this function will only be used in Visual Basic.NET.
Examples
VB
Copy
Dim elements As Integer() = CreateArray(12, -1)
Dim names As String() = CreateArray(100, "undefined")
See Also

Reference

Common Class
CreateArray Overload
GSF Namespace


Common.GetApplicationType Method

Grid Solutions Framework CommonGetApplicationType Method
Gets the type of the currently executing application.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ApplicationType GetApplicationType()
Public Shared Function GetApplicationType As ApplicationType
static member GetApplicationType : unit -> ApplicationType

GSF.Common.GetApplicationType = function();
public:
static ApplicationType GetApplicationType()

Return Value

Type: ApplicationType
One of the ApplicationType values.
See Also

Reference

Common Class
GSF Namespace


Common.GetOSPlatformID Method

Grid Solutions Framework CommonGetOSPlatformID Method
Gets the operating system PlatformID

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static PlatformID GetOSPlatformID()
Public Shared Function GetOSPlatformID As PlatformID
static member GetOSPlatformID : unit -> PlatformID

GSF.Common.GetOSPlatformID = function();
public:
static PlatformID GetOSPlatformID()

Return Value

Type: PlatformID
The operating system PlatformID.
Remarks
This function will properly detect the platform ID, even if running on Mac.
See Also

Reference

Common Class
GSF Namespace


Common.GetOSProductName Method

Grid Solutions Framework CommonGetOSProductName Method
Gets the operating system product name.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetOSProductName()
Public Shared Function GetOSProductName As String
static member GetOSProductName : unit -> string

GSF.Common.GetOSProductName = function();
public:
static String^ GetOSProductName()

Return Value

Type: String
Operating system product name.
See Also

Reference

Common Class
GSF Namespace


Common.GetProcessMemory Method

Grid Solutions Framework CommonGetProcessMemory Method
Gets the memory usage by the current process.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GetProcessMemory()
Public Shared Function GetProcessMemory As Long
static member GetProcessMemory : unit -> int64

GSF.Common.GetProcessMemory = function();
public:
static long long GetProcessMemory()

Return Value

Type: Int64
Memory usage by the current process.
See Also

Reference

Common Class
GSF Namespace


Common.IIf(T) Method

Grid Solutions Framework CommonIIfT Method
Returns one of two strongly-typed objects.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T IIf<T>(
    bool expression,
    T truePart,
    T falsePart
)

Public Shared Function IIf(Of T) (
    expression As Boolean,
    truePart As T,
    falsePart As T
) As T
static member IIf :
        expression : bool *
        truePart : 'T *
        falsePart : 'T -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
static T IIf(
    bool expression,
    T truePart,
    T falsePart
)

Parameters

expression
Type: SystemBoolean
The expression you want to evaluate.
truePart
Type: T
Returned if expression evaluates to True.
falsePart
Type: T
Returned if expression evaluates to False.

Type Parameters

T
Return type used for immediate expression

Return Value

Type: T
One of two objects, depending on the evaluation of given expression.
Remarks

This function acts as a strongly-typed immediate if (a.k.a. inline if).

It is expected that this function will only be used in languages that do not support ?: conditional operations, e.g., Visual Basic.NET. In Visual Basic this function can be used as a strongly-typed IIf replacement by specifying "Imports GSF.Common".

See Also

Reference

Common Class
GSF Namespace


Common.IsDefaultValue Method

Grid Solutions Framework CommonIsDefaultValue Method
Determines if given item is equal to its default value (e.g., null or 0.0).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsDefaultValue(
    Object item
)
Public Shared Function IsDefaultValue (
    item As Object
) As Boolean
static member IsDefaultValue :
        item : Object -> bool

GSF.Common.IsDefaultValue = function(item);
public:
static bool IsDefaultValue(
    Object^ item
)

Parameters

item
Type: SystemObject
Object to evaluate.

Return Value

Type: Boolean
Result of evaluation as a Boolean.
Remarks
Native types default to zero, not null, therefore this can be used to evaluate if an item is its default (i.e., uninitialized) value.
See Also

Reference

Common Class
GSF Namespace


Common.IsNonStringReference Method

Grid Solutions Framework CommonIsNonStringReference Method
Determines if given item is a reference type but not a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsNonStringReference(
    Object item
)
Public Shared Function IsNonStringReference (
    item As Object
) As Boolean
static member IsNonStringReference :
        item : Object -> bool

GSF.Common.IsNonStringReference = function(item);
public:
static bool IsNonStringReference(
    Object^ item
)

Parameters

item
Type: SystemObject
Object to evaluate.

Return Value

Type: Boolean
Result of evaluation as a Boolean.
See Also

Reference

Common Class
GSF Namespace


Common.IsNumeric Method

Grid Solutions Framework CommonIsNumeric Method
Determines if given item is numeric.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsNumeric(
    Object item
)
Public Shared Function IsNumeric (
    item As Object
) As Boolean
static member IsNumeric :
        item : Object -> bool

GSF.Common.IsNumeric = function(item);
public:
static bool IsNumeric(
    Object^ item
)

Parameters

item
Type: SystemObject
Object to evaluate.

Return Value

Type: Boolean
Result of evaluation as a Boolean.
See Also

Reference

Common Class
GSF Namespace


Common.IsReference Method

Grid Solutions Framework CommonIsReference Method
Determines if given item is a reference type.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsReference(
    Object item
)
Public Shared Function IsReference (
    item As Object
) As Boolean
static member IsReference :
        item : Object -> bool

GSF.Common.IsReference = function(item);
public:
static bool IsReference(
    Object^ item
)

Parameters

item
Type: SystemObject
Object to evaluate.

Return Value

Type: Boolean
Result of evaluation as a Boolean.
See Also

Reference

Common Class
GSF Namespace


Common.Max(T) Method

Grid Solutions Framework CommonMaxT Method
Returns the largest item from a list of parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Max<T>(
    params T[] itemList
)

Public Shared Function Max(Of T) (
    ParamArray itemList As T()
) As T
static member Max :
        itemList : 'T[] -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
static T Max(
    ... array<T>^ itemList
)

Parameters

itemList
Type: T
A variable number of parameters of the specified type .

Type Parameters

T
Return type Type that is the maximum value in the itemList.

Return Value

Type: T
Result is the maximum value of type Type in the itemList.
See Also

Reference

Common Class
GSF Namespace


Common.Mid(T) Method

Grid Solutions Framework CommonMidT Method
Returns the value that is neither the largest nor the smallest.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Mid<T>(
    T value1,
    T value2,
    T value3
)
where T : Object, IComparable<T>

Public Shared Function Mid(Of T As {Object, IComparable(Of T)}) (
    value1 As T,
    value2 As T,
    value3 As T
) As T
static member Mid :
        value1 : 'T *
        value2 : 'T *
        value3 : 'T -> 'T  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : Object, IComparable<T>
static T Mid(
    T value1,
    T value2,
    T value3
)

Parameters

value1
Type: T
Value 1.
value2
Type: T
Value 2.
value3
Type: T
Value 3.

Type Parameters

T
Type of the objects passed to and returned from this method.

Return Value

Type: T
Result is the value that is neither the largest nor the smallest.
See Also

Reference

Common Class
GSF Namespace


Common.Min(T) Method

Grid Solutions Framework CommonMinT Method
Returns the smallest item from a list of parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Min<T>(
    params T[] itemList
)

Public Shared Function Min(Of T) (
    ParamArray itemList As T()
) As T
static member Min :
        itemList : 'T[] -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
static T Min(
    ... array<T>^ itemList
)

Parameters

itemList
Type: T
A variable number of parameters of the specified type.

Type Parameters

T
Return type Type that is the minimum value in the itemList.

Return Value

Type: T
Result is the minimum value of type Type in the itemList.
See Also

Reference

Common Class
GSF Namespace


Common.ToNonNullNorEmptyString(T) Method

Grid Solutions Framework CommonToNonNullNorEmptyStringT Method
Converts value to string; null objects, DBNull objects or empty strings will return specified nonNullNorEmptyValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToNonNullNorEmptyString<T>(
    this T value,
    string nonNullNorEmptyValue = ""
)
where T : class

<ExtensionAttribute>
Public Shared Function ToNonNullNorEmptyString(Of T As Class) (
    value As T,
    Optional nonNullNorEmptyValue As String = ""
) As String
static member ToNonNullNorEmptyString :
        value : 'T *
        ?nonNullNorEmptyValue : string
(* Defaults:
        let _nonNullNorEmptyValue = defaultArg nonNullNorEmptyValue ""
*)
-> string  when 'T : not struct

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static String^ ToNonNullNorEmptyString(
    T value,
    String^ nonNullNorEmptyValue = L""
)

Parameters

value
Type: T
Value to convert to string.
nonNullNorEmptyValue (Optional)
Type: SystemString
String to return if value is null.

Type Parameters

T
Type of Object to convert to string.

Return Value

Type: String
value as a string; if value is null, DBNull or an empty string nonNullNorEmptyValue will be returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | nonNullNorEmptyValue must not be null or an empty string.
See Also

Reference

Common Class
GSF Namespace


Common.ToNonNullNorWhiteSpace(T) Method

Grid Solutions Framework CommonToNonNullNorWhiteSpaceT Method
Converts value to string; null objects, DBNull objects, empty strings or all white space strings will return specified nonNullNorWhiteSpaceValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToNonNullNorWhiteSpace<T>(
    this T value,
    string nonNullNorWhiteSpaceValue = "_"
)
where T : class

<ExtensionAttribute>
Public Shared Function ToNonNullNorWhiteSpace(Of T As Class) (
    value As T,
    Optional nonNullNorWhiteSpaceValue As String = "_"
) As String
static member ToNonNullNorWhiteSpace :
        value : 'T *
        ?nonNullNorWhiteSpaceValue : string
(* Defaults:
        let _nonNullNorWhiteSpaceValue = defaultArg nonNullNorWhiteSpaceValue "_"
*)
-> string  when 'T : not struct

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static String^ ToNonNullNorWhiteSpace(
    T value,
    String^ nonNullNorWhiteSpaceValue = L"_"
)

Parameters

value
Type: T
Value to convert to string.
nonNullNorWhiteSpaceValue (Optional)
Type: SystemString
String to return if value is null.

Type Parameters

T
Type of Object to convert to string.

Return Value

Type: String
value as a string; if value is null, DBNull, empty or all white space, nonNullNorWhiteSpaceValue will be returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | nonNullNorWhiteSpaceValue must not be null, an empty string or white space.
See Also

Reference

Common Class
GSF Namespace


Common.ToNonNullString Method

Grid Solutions Framework CommonToNonNullString Method
Overload List
Name | Description
ToNonNullString(String) | Makes sure returned string value is not null; if this string is null, empty string ("") will be returned.
ToNonNullStringT(T) | Converts value to string; null objects (or DBNull objects) will return an empty string ("").
ToNonNullStringT(T, String) | Converts value to string; null objects (or DBNull objects) will return specified nonNullValue.
Top
See Also

Reference

Common Class
GSF Namespace


Common.ToNonNullString Method (String)

Grid Solutions Framework CommonToNonNullString Method (String)
Makes sure returned string value is not null; if this string is null, empty string ("") will be returned.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToNonNullString(
    this string value
)
<ExtensionAttribute>
Public Shared Function ToNonNullString (
    value As String
) As String
static member ToNonNullString :
        value : string -> string

GSF.Common.ToNonNullString = function(value);
public:
[ExtensionAttribute]
static String^ ToNonNullString(
    String^ value
)

Parameters

value
Type: SystemString
String to verify is not null.

Return Value

Type: String
String value; if value is null, empty string ("") will be returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
ToNonNullString Overload
GSF Namespace


Common.ToNonNullString(T) Method (T)

Grid Solutions Framework CommonToNonNullStringT Method (T)
Converts value to string; null objects (or DBNull objects) will return an empty string ("").

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToNonNullString<T>(
    this T value
)
where T : class

<ExtensionAttribute>
Public Shared Function ToNonNullString(Of T As Class) (
    value As T
) As String
static member ToNonNullString :
        value : 'T -> string  when 'T : not struct

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static String^ ToNonNullString(
    T value
)

Parameters

value
Type: T
Value to convert to string.

Type Parameters

T
Type of Object to convert to string.

Return Value

Type: String
value as a string; if value is null, empty string ("") will be returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
ToNonNullString Overload
GSF Namespace


Common.ToNonNullString(T) Method (T, String)

Grid Solutions Framework CommonToNonNullStringT Method (T, String)
Converts value to string; null objects (or DBNull objects) will return specified nonNullValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToNonNullString<T>(
    this T value,
    string nonNullValue
)
where T : class

<ExtensionAttribute>
Public Shared Function ToNonNullString(Of T As Class) (
    value As T,
    nonNullValue As String
) As String
static member ToNonNullString :
        value : 'T *
        nonNullValue : string -> string  when 'T : not struct

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : ref class
static String^ ToNonNullString(
    T value,
    String^ nonNullValue
)

Parameters

value
Type: T
Value to convert to string.
nonNullValue
Type: SystemString
String to return if value is null.

Type Parameters

T
Type of Object to convert to string.

Return Value

Type: String
value as a string; if value is null, nonNullValue will be returned.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | nonNullValue cannot be null.
See Also

Reference

Common Class
ToNonNullString Overload
GSF Namespace


Common.TypeConvertToString Method

Grid Solutions Framework CommonTypeConvertToString Method
Overload List
Name | Description
TypeConvertToString(Object) | Converts value to a String using an appropriate TypeConverter.
TypeConvertToString(Object, CultureInfo) | Converts value to a String using an appropriate TypeConverter.
Top
See Also

Reference

Common Class
GSF Namespace


Common.TypeConvertToString Method (Object)

Grid Solutions Framework CommonTypeConvertToString Method (Object)
Converts value to a String using an appropriate TypeConverter.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TypeConvertToString(
    Object value
)
Public Shared Function TypeConvertToString (
    value As Object
) As String
static member TypeConvertToString :
        value : Object -> string

GSF.Common.TypeConvertToString = function(value);
public:
static String^ TypeConvertToString(
    Object^ value
)

Parameters

value
Type: SystemObject
Value to convert to a String.

Return Value

Type: String
value converted to a String.
Remarks

If TypeConverter fails, the value's ToString() value will be returned. Returned value will never be null, if no value exists an empty string ("") will be returned.

You can use the ConvertToTypeT(String) string extension method to convert the string back to its original Type.

See Also

Reference

Common Class
TypeConvertToString Overload
GSF Namespace


Common.TypeConvertToString Method (Object, CultureInfo)

Grid Solutions Framework CommonTypeConvertToString Method (Object, CultureInfo)
Converts value to a String using an appropriate TypeConverter.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TypeConvertToString(
    Object value,
    CultureInfo culture
)
Public Shared Function TypeConvertToString (
    value As Object,
    culture As CultureInfo
) As String
static member TypeConvertToString :
        value : Object *
        culture : CultureInfo -> string

GSF.Common.TypeConvertToString = function(value, culture);
public:
static String^ TypeConvertToString(
    Object^ value,
    CultureInfo^ culture
)

Parameters

value
Type: SystemObject
Value to convert to a String.
culture
Type: System.GlobalizationCultureInfo
CultureInfo to use for the conversion.

Return Value

Type: String
value converted to a String.
Remarks

If TypeConverter fails, the value's ToString() value will be returned. Returned value will never be null, if no value exists an empty string ("") will be returned.

You can use the ConvertToTypeT(String) string extension method to convert the string back to its original Type.

See Also

Reference

Common Class
TypeConvertToString Overload
GSF Namespace


Common Properties

Grid Solutions Framework Common Properties

The Common type exposes the following members.

Properties
Name | Description
SystemTimer | Gets a high-resolution number of seconds, including fractional seconds, that have elapsed since 12:00:00 midnight, January 1, 0001.
Top
See Also

Reference

Common Class
GSF Namespace


Common.SystemTimer Property

Grid Solutions Framework CommonSystemTimer Property
Gets a high-resolution number of seconds, including fractional seconds, that have elapsed since 12:00:00 midnight, January 1, 0001.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double SystemTimer { get; }
Public Shared ReadOnly Property SystemTimer As Double
    Get
static member SystemTimer : float with get

GSF.Common.get_SystemTimer = function();

public:
static property double SystemTimer {
    double get ();
}

Property Value

Type: Double
See Also

Reference

Common Class
GSF Namespace


ComplexNumber Structure

Grid Solutions Framework ComplexNumber Structure
Represents a complex number.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct ComplexNumber : IEquatable<ComplexNumber>
Public Structure ComplexNumber
    Implements IEquatable(Of ComplexNumber)
[<SealedAttribute>]
type ComplexNumber =
    struct
        interface IEquatable<ComplexNumber>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class ComplexNumber : IEquatable<ComplexNumber>

The ComplexNumber type exposes the following members.

Constructors
 | Name | Description
Public method | ComplexNumber(ComplexNumber) | Creates a ComplexNumber from the given ComplexNumber.
Public method | ComplexNumber(Double, Double) | Creates a ComplexNumber from the given rectangular values.
Public method | ComplexNumber(Angle, Double) | Creates a ComplexNumber from the given polar values.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(ComplexNumber) | Returns a value indicating whether this instance is equal to a specified ComplexNumber value.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Pow | Returns specified ComplexNumber raised to the specified power.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
(Double to ComplexNumber) | Implicitly converts a Double to a ComplexNumber.
Inequality | Compares the two values for inequality.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
UnaryNegation | Returns the negated value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllAssigned | Gets a boolean value indicating if each composite value of the ComplexNumber (i.e., real and imaginary) has been assigned a value.
Public property | Angle | Gets or sets the Angle (a.k.a. the argument) in radians of this ComplexNumber.
Public property | Conjugate | Gets the complex conjugate of this ComplexNumber.
Public property | Imaginary | Gets or sets the imaginary component of this ComplexNumber.
Public property | Magnitude | Gets or sets the magnitude (a.k.a. the modulus or absolute value) of this ComplexNumber.
Public property | NoneAssigned | Gets a boolean value indicating if each composite value of the ComplexNumber (i.e., real and imaginary) has not been assigned a value.
Public property | Real | Gets or sets the real component of this ComplexNumber.
Top
See Also

Reference

GSF Namespace


ComplexNumber Constructor

Grid Solutions Framework ComplexNumber Constructor
Overload List
 | Name | Description
Public method | ComplexNumber(ComplexNumber) | Creates a ComplexNumber from the given ComplexNumber.
Public method | ComplexNumber(Double, Double) | Creates a ComplexNumber from the given rectangular values.
Public method | ComplexNumber(Angle, Double) | Creates a ComplexNumber from the given polar values.
Top
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber Constructor (ComplexNumber)

Grid Solutions Framework ComplexNumber Constructor (ComplexNumber)
Creates a ComplexNumber from the given ComplexNumber.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ComplexNumber(
    ComplexNumber z
)
Public Sub New (
    z As ComplexNumber
)
new :
        z : ComplexNumber -> ComplexNumber
GSF.ComplexNumber = function(z);
public:
ComplexNumber(
    ComplexNumber z
)

Parameters

z
Type: GSFComplexNumber
ComplexNumber to be copied.
See Also

Reference

ComplexNumber Structure
ComplexNumber Overload
GSF Namespace


ComplexNumber Constructor (Double, Double)

Grid Solutions Framework ComplexNumber Constructor (Double, Double)
Creates a ComplexNumber from the given rectangular values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ComplexNumber(
    double real,
    double imaginary
)
Public Sub New (
    real As Double,
    imaginary As Double
)
new :
        real : float *
        imaginary : float -> ComplexNumber
GSF.ComplexNumber = function(real, imaginary);
public:
ComplexNumber(
    double real,
    double imaginary
)

Parameters

real
Type: SystemDouble
The real component of the ComplexNumber.
imaginary
Type: SystemDouble
The imaginary component of the ComplexNumber.
See Also

Reference

ComplexNumber Structure
ComplexNumber Overload
GSF Namespace


ComplexNumber Constructor (Angle, Double)

Grid Solutions Framework ComplexNumber Constructor (Angle, Double)
Creates a ComplexNumber from the given polar values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ComplexNumber(
    Angle angle,
    double magnitude
)
Public Sub New (
    angle As Angle,
    magnitude As Double
)
new :
        angle : Angle *
        magnitude : float -> ComplexNumber
GSF.ComplexNumber = function(angle, magnitude);
public:
ComplexNumber(
    Angle angle,
    double magnitude
)

Parameters

angle
Type: GSF.UnitsAngle
The Angle component, in radians, of the ComplexNumber.
magnitude
Type: SystemDouble
The magnitude (or absolute value) component of the ComplexNumber.
See Also

Reference

ComplexNumber Structure
ComplexNumber Overload
GSF Namespace


ComplexNumber Methods

Grid Solutions Framework ComplexNumber Methods

The ComplexNumber type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(ComplexNumber) | Returns a value indicating whether this instance is equal to a specified ComplexNumber value.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Pow | Returns specified ComplexNumber raised to the specified power.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Equals Method

Grid Solutions Framework ComplexNumberEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(ComplexNumber) | Returns a value indicating whether this instance is equal to a specified ComplexNumber value.
Top
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Equals Method (Object)

Grid Solutions Framework ComplexNumberEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of ComplexNumber and equals the value of this instance; otherwise, False.
See Also

Reference

ComplexNumber Structure
Equals Overload
GSF Namespace


ComplexNumber.Equals Method (ComplexNumber)

Grid Solutions Framework ComplexNumberEquals Method (ComplexNumber)
Returns a value indicating whether this instance is equal to a specified ComplexNumber value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    ComplexNumber obj
)
Public Function Equals (
    obj As ComplexNumber
) As Boolean
abstract Equals :
        obj : ComplexNumber -> bool
override Equals :
        obj : ComplexNumber -> bool
function Equals(obj);
public:
virtual bool Equals(
    ComplexNumber obj
) sealed

Parameters

obj
Type: GSFComplexNumber
A ComplexNumber to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

ComplexNumber Structure
Equals Overload
GSF Namespace


ComplexNumber.GetHashCode Method

Grid Solutions Framework ComplexNumberGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Pow Method

Grid Solutions Framework ComplexNumberPow Method
Returns specified ComplexNumber raised to the specified power.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ComplexNumber Pow(
    ComplexNumber z,
    double y
)
Public Shared Function Pow (
    z As ComplexNumber,
    y As Double
) As ComplexNumber
static member Pow :
        z : ComplexNumber *
        y : float -> ComplexNumber

GSF.ComplexNumber.Pow = function(z, y);
public:
static ComplexNumber Pow(
    ComplexNumber z,
    double y
)

Parameters

z
Type: GSFComplexNumber
Complex number to be raised to power y.
y
Type: SystemDouble
Power to raise ComplexNumber z.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.ToString Method

Grid Solutions Framework ComplexNumberToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this ComplexNumber instance.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber Operators and Type Conversions

Grid Solutions Framework ComplexNumber Operators and Type Conversions

The ComplexNumber type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
(Double to ComplexNumber) | Implicitly converts a Double to a ComplexNumber.
Inequality | Compares the two values for inequality.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
UnaryNegation | Returns the negated value.
Top
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Addition Operator

Grid Solutions Framework ComplexNumberAddition Operator
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ComplexNumber operator +(
    ComplexNumber value1,
    ComplexNumber value2
)
Public Shared Operator + (
    value1 As ComplexNumber,
    value2 As ComplexNumber
) As ComplexNumber
static let inline (+)
        value1 : ComplexNumber *
        value2 : ComplexNumber  : ComplexNumber
JavaScript does not support overloaded operators.
public:
static ComplexNumber operator +(
    ComplexNumber value1,
    ComplexNumber value2
)

Parameters

value1
Type: GSFComplexNumber
Left hand operand.
value2
Type: GSFComplexNumber
Right hand operand.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the addition operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Division Operator

Grid Solutions Framework ComplexNumberDivision Operator
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ComplexNumber operator /(
    ComplexNumber value1,
    ComplexNumber value2
)
Public Shared Operator / (
    value1 As ComplexNumber,
    value2 As ComplexNumber
) As ComplexNumber
static let inline (/)
        value1 : ComplexNumber *
        value2 : ComplexNumber  : ComplexNumber
JavaScript does not support overloaded operators.
public:
static ComplexNumber operator /(
    ComplexNumber value1,
    ComplexNumber value2
)

Parameters

value1
Type: GSFComplexNumber
Left hand operand.
value2
Type: GSFComplexNumber
Right hand operand.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the division operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Equality Operator

Grid Solutions Framework ComplexNumberEquality Operator
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    ComplexNumber value1,
    ComplexNumber value2
)
Public Shared Operator = (
    value1 As ComplexNumber,
    value2 As ComplexNumber
) As Boolean
static let inline (=)
        value1 : ComplexNumber *
        value2 : ComplexNumber  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    ComplexNumber value1,
    ComplexNumber value2
)

Parameters

value1
Type: GSFComplexNumber
Left hand operand.
value2
Type: GSFComplexNumber
Right hand operand.

Return Value

Type: Boolean
Boolean representing the result of the addition operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Exponent Operator

Grid Solutions Framework ComplexNumberExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    z As ComplexNumber,
    y As Double
) As ComplexNumber
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

z
Type: GSFComplexNumber
Complex number to be raised to power y.
y
Type: SystemDouble
Power to raise ComplexNumber z.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber Implicit Conversion (Double to ComplexNumber)

Grid Solutions Framework ComplexNumber Conversion (Double to ComplexNumber)
Implicitly converts a Double to a ComplexNumber.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ComplexNumber (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As ComplexNumber
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator ComplexNumber (
    double value
)

Parameters

value
Type: SystemDouble
Operand.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Inequality Operator

Grid Solutions Framework ComplexNumberInequality Operator
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    ComplexNumber value1,
    ComplexNumber value2
)
Public Shared Operator <> (
    value1 As ComplexNumber,
    value2 As ComplexNumber
) As Boolean
static let inline (<>)
        value1 : ComplexNumber *
        value2 : ComplexNumber  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    ComplexNumber value1,
    ComplexNumber value2
)

Parameters

value1
Type: GSFComplexNumber
Left hand operand.
value2
Type: GSFComplexNumber
Right hand operand.

Return Value

Type: Boolean
Boolean representing the result of the inequality operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Multiply Operator

Grid Solutions Framework ComplexNumberMultiply Operator
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ComplexNumber operator *(
    ComplexNumber value1,
    ComplexNumber value2
)
Public Shared Operator * (
    value1 As ComplexNumber,
    value2 As ComplexNumber
) As ComplexNumber
static let inline (*)
        value1 : ComplexNumber *
        value2 : ComplexNumber  : ComplexNumber
JavaScript does not support overloaded operators.
public:
static ComplexNumber operator *(
    ComplexNumber value1,
    ComplexNumber value2
)

Parameters

value1
Type: GSFComplexNumber
Left hand operand.
value2
Type: GSFComplexNumber
Right hand operand.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the multiplication operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Subtraction Operator

Grid Solutions Framework ComplexNumberSubtraction Operator
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ComplexNumber operator -(
    ComplexNumber value1,
    ComplexNumber value2
)
Public Shared Operator - (
    value1 As ComplexNumber,
    value2 As ComplexNumber
) As ComplexNumber
static let inline (-)
        value1 : ComplexNumber *
        value2 : ComplexNumber  : ComplexNumber
JavaScript does not support overloaded operators.
public:
static ComplexNumber operator -(
    ComplexNumber value1,
    ComplexNumber value2
)

Parameters

value1
Type: GSFComplexNumber
Left hand operand.
value2
Type: GSFComplexNumber
Right hand operand.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the subtraction operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.UnaryNegation Operator

Grid Solutions Framework ComplexNumberUnaryNegation Operator
Returns the negated value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ComplexNumber operator -(
    ComplexNumber z
)
Public Shared Operator - (
    z As ComplexNumber
) As ComplexNumber
static let inline (-)
        z : ComplexNumber  : ComplexNumber
JavaScript does not support overloaded operators.
public:
static ComplexNumber operator -(
    ComplexNumber z
)

Parameters

z
Type: GSFComplexNumber
Left hand operand.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the unary negation operation.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber Properties

Grid Solutions Framework ComplexNumber Properties

The ComplexNumber type exposes the following members.

Properties
 | Name | Description
Public property | AllAssigned | Gets a boolean value indicating if each composite value of the ComplexNumber (i.e., real and imaginary) has been assigned a value.
Public property | Angle | Gets or sets the Angle (a.k.a. the argument) in radians of this ComplexNumber.
Public property | Conjugate | Gets the complex conjugate of this ComplexNumber.
Public property | Imaginary | Gets or sets the imaginary component of this ComplexNumber.
Public property | Magnitude | Gets or sets the magnitude (a.k.a. the modulus or absolute value) of this ComplexNumber.
Public property | NoneAssigned | Gets a boolean value indicating if each composite value of the ComplexNumber (i.e., real and imaginary) has not been assigned a value.
Public property | Real | Gets or sets the real component of this ComplexNumber.
Top
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.AllAssigned Property

Grid Solutions Framework ComplexNumberAllAssigned Property
Gets a boolean value indicating if each composite value of the ComplexNumber (i.e., real and imaginary) has been assigned a value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllAssigned { get; }
Public ReadOnly Property AllAssigned As Boolean
    Get
member AllAssigned : bool with get

function get_AllAssigned();

public:
property bool AllAssigned {
    bool get ();
}

Return Value

Type: Boolean
True, if all composite values have been assigned a value; otherwise, false.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Angle Property

Grid Solutions Framework ComplexNumberAngle Property
Gets or sets the Angle (a.k.a. the argument) in radians of this ComplexNumber.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Angle Angle { get; set; }
Public Property Angle As Angle
    Get
    Set
member Angle : Angle with get, set

function get_Angle();
function set_Angle(value);
public:
property Angle Angle {
    Angle get ();
    void set (Angle value);
}

Property Value

Type: Angle
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Conjugate Property

Grid Solutions Framework ComplexNumberConjugate Property
Gets the complex conjugate of this ComplexNumber.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ComplexNumber Conjugate { get; }
Public ReadOnly Property Conjugate As ComplexNumber
    Get
member Conjugate : ComplexNumber with get

function get_Conjugate();

public:
property ComplexNumber Conjugate {
    ComplexNumber get ();
}

Property Value

Type: ComplexNumber
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Imaginary Property

Grid Solutions Framework ComplexNumberImaginary Property
Gets or sets the imaginary component of this ComplexNumber.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Imaginary { get; set; }
Public Property Imaginary As Double
    Get
    Set
member Imaginary : float with get, set

function get_Imaginary();
function set_Imaginary(value);
public:
property double Imaginary {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Magnitude Property

Grid Solutions Framework ComplexNumberMagnitude Property
Gets or sets the magnitude (a.k.a. the modulus or absolute value) of this ComplexNumber.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Magnitude { get; set; }
Public Property Magnitude As Double
    Get
    Set
member Magnitude : float with get, set

function get_Magnitude();
function set_Magnitude(value);
public:
property double Magnitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.NoneAssigned Property

Grid Solutions Framework ComplexNumberNoneAssigned Property
Gets a boolean value indicating if each composite value of the ComplexNumber (i.e., real and imaginary) has not been assigned a value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool NoneAssigned { get; }
Public ReadOnly Property NoneAssigned As Boolean
    Get
member NoneAssigned : bool with get

function get_NoneAssigned();

public:
property bool NoneAssigned {
    bool get ();
}

Return Value

Type: Boolean
True, if none of the composite values have been assigned a value; otherwise, false.
See Also

Reference

ComplexNumber Structure
GSF Namespace


ComplexNumber.Real Property

Grid Solutions Framework ComplexNumberReal Property
Gets or sets the real component of this ComplexNumber.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Real { get; set; }
Public Property Real As Double
    Get
    Set
member Real : float with get, set

function get_Real();
function set_Real(value);
public:
property double Real {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ComplexNumber Structure
GSF Namespace


CompoundValue(T) Class

Grid Solutions Framework CompoundValueT Class
Represents a collection of individual values that together represent a compound value once all the values have been assigned.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection Nullable T
GSFCompoundValueT

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CompoundValue<T> : Collection<Nullable<T>>
where T : struct, new()

Public Class CompoundValue(Of T As {Structure, New})
    Inherits Collection(Of Nullable(Of T))
type CompoundValue<'T when 'T : struct, new()> =
    class
        inherit Collection<Nullable<'T>>
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : value class, gcnew()
public ref class CompoundValue : public Collection<Nullable<T>>

Type Parameters

T
Type of composite values.

The CompoundValueT type exposes the following members.

Constructors
 | Name | Description
Public method | CompoundValueT | Creates a new CompoundValueT.
Public method | CompoundValueT(IEnumerableNullableT) | Creates a new CompoundValueT from the specified list.
Public method | CompoundValueT(IEnumerableT) | Creates a new CompoundValueT from the specified list.
Public method | CompoundValueT(Int32) | Creates a new CompoundValueT specifing the total number of composite values to track.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Nullable T.)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Nullable T.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from Collection Nullable T.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection Nullable T.)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Nullable T.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Nullable T.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Nullable T.)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Nullable T.)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Nullable T.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Nullable T.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Nullable T.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from Collection Nullable T.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection Nullable T.)
Public method | ToArray | Gets an array of all the GetValueOrDefault elements of the CompoundValueT.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value.
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Nullable T.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection Nullable T.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Nullable T.)
Public property | NoneAssigned | Gets a boolean value indicating if none of the composite values have been assigned a value.
Top
Remarks
Composite values are stored as NullableT and can be cumulated until all values have been assigned so that a compound value can be created.
See Also

Reference

GSF Namespace


CompoundValue(T) Constructor

Grid Solutions Framework CompoundValueT Constructor
Overload List
 | Name | Description
Public method | CompoundValueT | Creates a new CompoundValueT.
Public method | CompoundValueT(IEnumerableNullableT) | Creates a new CompoundValueT from the specified list.
Public method | CompoundValueT(IEnumerableT) | Creates a new CompoundValueT from the specified list.
Public method | CompoundValueT(Int32) | Creates a new CompoundValueT specifing the total number of composite values to track.
Top
See Also

Reference

CompoundValueT Class
GSF Namespace


CompoundValue(T) Constructor

Grid Solutions Framework CompoundValueT Constructor
Creates a new CompoundValueT.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompoundValue()
Public Sub New
new : unit -> CompoundValue
GSF.CompoundValue = function();
public:
CompoundValue()
See Also

Reference

CompoundValueT Class
CompoundValueT Overload
GSF Namespace


CompoundValue(T) Constructor (IEnumerable(Nullable(T)))

Grid Solutions Framework CompoundValueT Constructor (IEnumerableNullableT)
Creates a new CompoundValueT from the specified list.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompoundValue(
    IEnumerable<Nullable<T>> values
)
Public Sub New (
    values As IEnumerable(Of Nullable(Of T))
)
new :
        values : IEnumerable<Nullable<'T>> -> CompoundValue
GSF.CompoundValue = function(values);
public:
CompoundValue(
    IEnumerable<Nullable<T>>^ values
)

Parameters

values
Type: System.Collections.GenericIEnumerable Nullable T
List of values used to initialize CompoundValueT.
See Also

Reference

CompoundValueT Class
CompoundValueT Overload
GSF Namespace


CompoundValue(T) Constructor (IEnumerable(T))

Grid Solutions Framework CompoundValueT Constructor (IEnumerableT)
Creates a new CompoundValueT from the specified list.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompoundValue(
    IEnumerable<T> values
)
Public Sub New (
    values As IEnumerable(Of T)
)
new :
        values : IEnumerable<'T> -> CompoundValue
GSF.CompoundValue = function(values);
public:
CompoundValue(
    IEnumerable<T>^ values
)

Parameters

values
Type: System.Collections.GenericIEnumerable T
List of values used to initialize CompoundValueT.
See Also

Reference

CompoundValueT Class
CompoundValueT Overload
GSF Namespace


CompoundValue(T) Constructor (Int32)

Grid Solutions Framework CompoundValueT Constructor (Int32)
Creates a new CompoundValueT specifing the total number of composite values to track.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompoundValue(
    int count
)
Public Sub New (
    count As Integer
)
new :
        count : int -> CompoundValue
GSF.CompoundValue = function(count);
public:
CompoundValue(
    int count
)

Parameters

count
Type: SystemInt32
Total number of composite values to track.
Remarks
The specified count of items are added to the CompoundValueT, each item will be marked as unassigned (i.e., null).
See Also

Reference

CompoundValueT Class
CompoundValueT Overload
GSF Namespace


CompoundValue(T) Methods

Grid Solutions Framework CompoundValueT Methods

The CompoundValueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection Nullable T .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Nullable T .)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from Collection Nullable T .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection Nullable T .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Nullable T .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Nullable T .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Nullable T .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Nullable T .)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Nullable T .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Nullable T .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Nullable T .)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from Collection Nullable T .)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from Collection Nullable T .)
Public method | ToArray | Gets an array of all the GetValueOrDefault elements of the CompoundValueT.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CompoundValueT Class
GSF Namespace


CompoundValue(T).ToArray Method

Grid Solutions Framework CompoundValueTToArray Method
Gets an array of all the GetValueOrDefault elements of the CompoundValueT.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T[] ToArray()
Public Function ToArray As T()
member ToArray : unit -> 'T[]

function ToArray();
public:
array<T>^ ToArray()

Return Value

Type: T
A new array containing copies of the GetValueOrDefault elements of the CompoundValueT.
See Also

Reference

CompoundValueT Class
GSF Namespace


CompoundValue(T) Properties

Grid Solutions Framework CompoundValueT Properties

The CompoundValueT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value.
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Nullable T .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection Nullable T .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Nullable T .)
Public property | NoneAssigned | Gets a boolean value indicating if none of the composite values have been assigned a value.
Top
See Also

Reference

CompoundValueT Class
GSF Namespace


CompoundValue(T).AllAssigned Property

Grid Solutions Framework CompoundValueTAllAssigned Property
Gets a boolean value indicating if all of the composite values have been assigned a value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllAssigned { get; }
Public ReadOnly Property AllAssigned As Boolean
    Get
member AllAssigned : bool with get

function get_AllAssigned();

public:
property bool AllAssigned {
    bool get ();
}

Return Value

Type: Boolean
True, if all composite values have been assigned a value; otherwise, false.
See Also

Reference

CompoundValueT Class
GSF Namespace


CompoundValue(T).NoneAssigned Property

Grid Solutions Framework CompoundValueTNoneAssigned Property
Gets a boolean value indicating if none of the composite values have been assigned a value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool NoneAssigned { get; }
Public ReadOnly Property NoneAssigned As Boolean
    Get
member NoneAssigned : bool with get

function get_NoneAssigned();

public:
property bool NoneAssigned {
    bool get ();
}

Return Value

Type: Boolean
True, if no composite values have been assigned a value; otherwise, false.
See Also

Reference

CompoundValueT Class
GSF Namespace


DateTimeExtensions Class

Grid Solutions Framework DateTimeExtensions Class
Defines extension functions related to Date/Time manipulation.
Inheritance Hierarchy
SystemObject
GSFDateTimeExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class DateTimeExtensions
<ExtensionAttribute>
Public NotInheritable Class DateTimeExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DateTimeExtensions =  class end
GSF.DateTimeExtensions = function();

Type.createClass(
    'GSF.DateTimeExtensions');
[ExtensionAttribute]
public ref class DateTimeExtensions abstract sealed

The DateTimeExtensions type exposes the following members.

Methods
Name | Description
AbbreviatedMonthName | Gets the abbreviated month name for month of the timestamp.
AbbreviatedWeekdayName | Gets the abbreviated weekday name for weekday of the timestamp.
BaselinedTimestamp | Creates a baselined timestamp which begins at the specified time interval.
DistanceBeyondSecond | Gets the distance, in Ticks, beyond the top of the timestamp second.
LocalTimeIsValid | Determines if the specified local time is valid, by comparing it to the system clock.
LocalTimeTo(DateTime, String) | Converts given local time to time in specified time zone.
LocalTimeTo(DateTime, TimeZoneInfo) | Converts given local time to time in specified time zone.
LocalTimeToCentralTime | Converts given local time to Central time.
LocalTimeToEasternTime | Converts given local time to Eastern time.
LocalTimeToMountainTime | Converts given local time to Mountain time.
LocalTimeToPacificTime | Converts given local time to Pacific time.
LocalTimeToUniversalTime | Converts given local time to Universally Coordinated Time (a.k.a., Greenwich Meridian Time).
MonthName | Gets the full month name for month of the timestamp.
ShortWeekdayName | Gets the shortest weekday name for weekday of the timestamp.
TimeIsValid | Determines if time is valid, by comparing it to the specified current time.
TimeZoneToTimeZone(DateTime, String, String) | Converts given timestamp from one time zone to another using standard names for time zones.
TimeZoneToTimeZone(DateTime, TimeZoneInfo, TimeZoneInfo) | Converts given timestamp from one time zone to another.
UniversalTimeTo(DateTime, String) | Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.
UniversalTimeTo(DateTime, TimeZoneInfo) | Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.
UniversalTimeToCentralTime | Converts the specified Universally Coordinated Time timestamp to Central time timestamp.
UniversalTimeToEasternTime | Converts the specified Universally Coordinated Time timestamp to Eastern time timestamp.
UniversalTimeToMountainTime | Converts the specified Universally Coordinated Time timestamp to Mountain time timestamp.
UniversalTimeToPacificTime | Converts the specified Universally Coordinated Time timestamp to Pacific time timestamp.
UtcTimeIsValid | Determines if the specified UTC time is valid, by comparing it to the system clock.
WeekdayName | Gets the full weekday name for weekday of the timestamp.
Top
See Also

Reference

GSF Namespace


DateTimeExtensions Methods

Grid Solutions Framework DateTimeExtensions Methods

The DateTimeExtensions type exposes the following members.

Methods
Name | Description
AbbreviatedMonthName | Gets the abbreviated month name for month of the timestamp.
AbbreviatedWeekdayName | Gets the abbreviated weekday name for weekday of the timestamp.
BaselinedTimestamp | Creates a baselined timestamp which begins at the specified time interval.
DistanceBeyondSecond | Gets the distance, in Ticks, beyond the top of the timestamp second.
LocalTimeIsValid | Determines if the specified local time is valid, by comparing it to the system clock.
LocalTimeTo(DateTime, String) | Converts given local time to time in specified time zone.
LocalTimeTo(DateTime, TimeZoneInfo) | Converts given local time to time in specified time zone.
LocalTimeToCentralTime | Converts given local time to Central time.
LocalTimeToEasternTime | Converts given local time to Eastern time.
LocalTimeToMountainTime | Converts given local time to Mountain time.
LocalTimeToPacificTime | Converts given local time to Pacific time.
LocalTimeToUniversalTime | Converts given local time to Universally Coordinated Time (a.k.a., Greenwich Meridian Time).
MonthName | Gets the full month name for month of the timestamp.
ShortWeekdayName | Gets the shortest weekday name for weekday of the timestamp.
TimeIsValid | Determines if time is valid, by comparing it to the specified current time.
TimeZoneToTimeZone(DateTime, String, String) | Converts given timestamp from one time zone to another using standard names for time zones.
TimeZoneToTimeZone(DateTime, TimeZoneInfo, TimeZoneInfo) | Converts given timestamp from one time zone to another.
UniversalTimeTo(DateTime, String) | Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.
UniversalTimeTo(DateTime, TimeZoneInfo) | Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.
UniversalTimeToCentralTime | Converts the specified Universally Coordinated Time timestamp to Central time timestamp.
UniversalTimeToEasternTime | Converts the specified Universally Coordinated Time timestamp to Eastern time timestamp.
UniversalTimeToMountainTime | Converts the specified Universally Coordinated Time timestamp to Mountain time timestamp.
UniversalTimeToPacificTime | Converts the specified Universally Coordinated Time timestamp to Pacific time timestamp.
UtcTimeIsValid | Determines if the specified UTC time is valid, by comparing it to the system clock.
WeekdayName | Gets the full weekday name for weekday of the timestamp.
Top
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.AbbreviatedMonthName Method

Grid Solutions Framework DateTimeExtensionsAbbreviatedMonthName Method
Gets the abbreviated month name for month of the timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string AbbreviatedMonthName(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function AbbreviatedMonthName (
    timestamp As DateTime
) As String
static member AbbreviatedMonthName :
        timestamp : DateTime -> string

GSF.DateTimeExtensions.AbbreviatedMonthName = function(timestamp);
public:
[ExtensionAttribute]
static String^ AbbreviatedMonthName(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp from which month name is extracted.

Return Value

Type: String
String representation of the month name based on timestamp

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.AbbreviatedWeekdayName Method

Grid Solutions Framework DateTimeExtensionsAbbreviatedWeekdayName Method
Gets the abbreviated weekday name for weekday of the timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string AbbreviatedWeekdayName(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function AbbreviatedWeekdayName (
    timestamp As DateTime
) As String
static member AbbreviatedWeekdayName :
        timestamp : DateTime -> string

GSF.DateTimeExtensions.AbbreviatedWeekdayName = function(timestamp);
public:
[ExtensionAttribute]
static String^ AbbreviatedWeekdayName(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp from which weekday name is extracted.

Return Value

Type: String
String representation of the weekday name based on timestamp

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.BaselinedTimestamp Method

Grid Solutions Framework DateTimeExtensionsBaselinedTimestamp Method
Creates a baselined timestamp which begins at the specified time interval.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime BaselinedTimestamp(
    this DateTime timestamp,
    BaselineTimeInterval interval
)
<ExtensionAttribute>
Public Shared Function BaselinedTimestamp (
    timestamp As DateTime,
    interval As BaselineTimeInterval
) As DateTime
static member BaselinedTimestamp :
        timestamp : DateTime *
        interval : BaselineTimeInterval -> DateTime

GSF.DateTimeExtensions.BaselinedTimestamp = function(timestamp, interval);
public:
[ExtensionAttribute]
static DateTime BaselinedTimestamp(
    DateTime timestamp,
    BaselineTimeInterval interval
)

Parameters

timestamp
Type: SystemDateTime
Timestamp to baseline.
interval
Type: GSFBaselineTimeInterval
BaselineTimeInterval to which timestamp should be baselined.

Return Value

Type: DateTime
A new DateTime value that represents a baselined timestamp that begins at the specified BaselineTimeInterval.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Baselining to the Second would return the DateTime value starting at zero milliseconds.
Baselining to the Minute would return the DateTime value starting at zero seconds and milliseconds.
Baselining to the Hour would return the DateTime value starting at zero minutes, seconds and milliseconds.
Baselining to the Day would return the DateTime value starting at zero hours, minutes, seconds and milliseconds.
Baselining to the Month would return the DateTime value starting at day one, zero hours, minutes, seconds and milliseconds.
Baselining to the Year would return the DateTime value starting at month one, day one, zero hours, minutes, seconds and milliseconds.
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.DistanceBeyondSecond Method

Grid Solutions Framework DateTimeExtensionsDistanceBeyondSecond Method
Gets the distance, in Ticks, beyond the top of the timestamp second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks DistanceBeyondSecond(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function DistanceBeyondSecond (
    timestamp As DateTime
) As Ticks
static member DistanceBeyondSecond :
        timestamp : DateTime -> Ticks

GSF.DateTimeExtensions.DistanceBeyondSecond = function(timestamp);
public:
[ExtensionAttribute]
static Ticks DistanceBeyondSecond(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp to evaluate.

Return Value

Type: Ticks
Timestamp's tick distance from the top of the second.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.LocalTimeIsValid Method

Grid Solutions Framework DateTimeExtensionsLocalTimeIsValid Method
Determines if the specified local time is valid, by comparing it to the system clock.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool LocalTimeIsValid(
    this DateTime localTime,
    double lagTime,
    double leadTime
)
<ExtensionAttribute>
Public Shared Function LocalTimeIsValid (
    localTime As DateTime,
    lagTime As Double,
    leadTime As Double
) As Boolean
static member LocalTimeIsValid :
        localTime : DateTime *
        lagTime : float *
        leadTime : float -> bool

GSF.DateTimeExtensions.LocalTimeIsValid = function(localTime, lagTime, leadTime);
public:
[ExtensionAttribute]
static bool LocalTimeIsValid(
    DateTime localTime,
    double lagTime,
    double leadTime
)

Parameters

localTime
Type: SystemDateTime
Time to test for validity.
lagTime
Type: SystemDouble
The allowed lag time, in seconds, before assuming time is too old to be valid.
leadTime
Type: SystemDouble
The allowed lead time, in seconds, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if time is within the specified range.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime and LeadTime must be greater than zero, but can be less than one.
Remarks

Time is considered valid if it exists within the specified lag time/lead time range of current time.

Note that lag time and lead time must be greater than zero, but can be set to sub-second intervals.

See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.LocalTimeTo Method

Grid Solutions Framework DateTimeExtensionsLocalTimeTo Method
Overload List
Name | Description
LocalTimeTo(DateTime, String) | Converts given local time to time in specified time zone.
LocalTimeTo(DateTime, TimeZoneInfo) | Converts given local time to time in specified time zone.
Top
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.LocalTimeTo Method (DateTime, String)

Grid Solutions Framework DateTimeExtensionsLocalTimeTo Method (DateTime, String)
Converts given local time to time in specified time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime LocalTimeTo(
    this DateTime timestamp,
    string destinationTimeZoneStandardName
)
<ExtensionAttribute>
Public Shared Function LocalTimeTo (
    timestamp As DateTime,
    destinationTimeZoneStandardName As String
) As DateTime
static member LocalTimeTo :
        timestamp : DateTime *
        destinationTimeZoneStandardName : string -> DateTime

GSF.DateTimeExtensions.LocalTimeTo = function(timestamp, destinationTimeZoneStandardName);
public:
[ExtensionAttribute]
static DateTime LocalTimeTo(
    DateTime timestamp,
    String^ destinationTimeZoneStandardName
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in local time to be converted to time in specified time zone.
destinationTimeZoneStandardName
Type: SystemString
Standard name of desired end time zone for given timestamp.

Return Value

Type: DateTime

Timestamp in specified time zone.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
LocalTimeTo Overload
GSF Namespace


DateTimeExtensions.LocalTimeTo Method (DateTime, TimeZoneInfo)

Grid Solutions Framework DateTimeExtensionsLocalTimeTo Method (DateTime, TimeZoneInfo)
Converts given local time to time in specified time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime LocalTimeTo(
    this DateTime timestamp,
    TimeZoneInfo destinationTimeZone
)
<ExtensionAttribute>
Public Shared Function LocalTimeTo (
    timestamp As DateTime,
    destinationTimeZone As TimeZoneInfo
) As DateTime
static member LocalTimeTo :
        timestamp : DateTime *
        destinationTimeZone : TimeZoneInfo -> DateTime

GSF.DateTimeExtensions.LocalTimeTo = function(timestamp, destinationTimeZone);
public:
[ExtensionAttribute]
static DateTime LocalTimeTo(
    DateTime timestamp,
    TimeZoneInfo^ destinationTimeZone
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in local time to be converted to time in specified time zone.
destinationTimeZone
Type: SystemTimeZoneInfo
Desired end time zone for given timestamp.

Return Value

Type: DateTime

Timestamp in specified time zone.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
LocalTimeTo Overload
GSF Namespace


DateTimeExtensions.LocalTimeToCentralTime Method

Grid Solutions Framework DateTimeExtensionsLocalTimeToCentralTime Method
Converts given local time to Central time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime LocalTimeToCentralTime(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function LocalTimeToCentralTime (
    timestamp As DateTime
) As DateTime
static member LocalTimeToCentralTime :
        timestamp : DateTime -> DateTime

GSF.DateTimeExtensions.LocalTimeToCentralTime = function(timestamp);
public:
[ExtensionAttribute]
static DateTime LocalTimeToCentralTime(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in local time to be converted to Central time.

Return Value

Type: DateTime

Timestamp in Central time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.LocalTimeToEasternTime Method

Grid Solutions Framework DateTimeExtensionsLocalTimeToEasternTime Method
Converts given local time to Eastern time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime LocalTimeToEasternTime(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function LocalTimeToEasternTime (
    timestamp As DateTime
) As DateTime
static member LocalTimeToEasternTime :
        timestamp : DateTime -> DateTime

GSF.DateTimeExtensions.LocalTimeToEasternTime = function(timestamp);
public:
[ExtensionAttribute]
static DateTime LocalTimeToEasternTime(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in local time to be converted to Eastern time.

Return Value

Type: DateTime

Timestamp in Eastern time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.LocalTimeToMountainTime Method

Grid Solutions Framework DateTimeExtensionsLocalTimeToMountainTime Method
Converts given local time to Mountain time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime LocalTimeToMountainTime(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function LocalTimeToMountainTime (
    timestamp As DateTime
) As DateTime
static member LocalTimeToMountainTime :
        timestamp : DateTime -> DateTime

GSF.DateTimeExtensions.LocalTimeToMountainTime = function(timestamp);
public:
[ExtensionAttribute]
static DateTime LocalTimeToMountainTime(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in local time to be converted to Mountain time.

Return Value

Type: DateTime

Timestamp in Mountain time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.LocalTimeToPacificTime Method

Grid Solutions Framework DateTimeExtensionsLocalTimeToPacificTime Method
Converts given local time to Pacific time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime LocalTimeToPacificTime(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function LocalTimeToPacificTime (
    timestamp As DateTime
) As DateTime
static member LocalTimeToPacificTime :
        timestamp : DateTime -> DateTime

GSF.DateTimeExtensions.LocalTimeToPacificTime = function(timestamp);
public:
[ExtensionAttribute]
static DateTime LocalTimeToPacificTime(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in local time to be converted to Pacific time.

Return Value

Type: DateTime

Timestamp in Pacific time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.LocalTimeToUniversalTime Method

Grid Solutions Framework DateTimeExtensionsLocalTimeToUniversalTime Method
Converts given local time to Universally Coordinated Time (a.k.a., Greenwich Meridian Time).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime LocalTimeToUniversalTime(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function LocalTimeToUniversalTime (
    timestamp As DateTime
) As DateTime
static member LocalTimeToUniversalTime :
        timestamp : DateTime -> DateTime

GSF.DateTimeExtensions.LocalTimeToUniversalTime = function(timestamp);
public:
[ExtensionAttribute]
static DateTime LocalTimeToUniversalTime(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in local time to be converted to Universal time.

Return Value

Type: DateTime

Timestamp in UniversalTime (a.k.a., GMT).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function is only provided for the sake of completeness. All it does is call the "ToUniversalTime" property on the given timestamp.
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.MonthName Method

Grid Solutions Framework DateTimeExtensionsMonthName Method
Gets the full month name for month of the timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string MonthName(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function MonthName (
    timestamp As DateTime
) As String
static member MonthName :
        timestamp : DateTime -> string

GSF.DateTimeExtensions.MonthName = function(timestamp);
public:
[ExtensionAttribute]
static String^ MonthName(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp from which month name is extracted.

Return Value

Type: String
String representation of the month name based on timestamp

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.ShortWeekdayName Method

Grid Solutions Framework DateTimeExtensionsShortWeekdayName Method
Gets the shortest weekday name for weekday of the timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ShortWeekdayName(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function ShortWeekdayName (
    timestamp As DateTime
) As String
static member ShortWeekdayName :
        timestamp : DateTime -> string

GSF.DateTimeExtensions.ShortWeekdayName = function(timestamp);
public:
[ExtensionAttribute]
static String^ ShortWeekdayName(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp from which weekday name is extracted.

Return Value

Type: String
String representation of the short weekday name based on timestamp

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.TimeIsValid Method

Grid Solutions Framework DateTimeExtensionsTimeIsValid Method
Determines if time is valid, by comparing it to the specified current time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TimeIsValid(
    this DateTime testTime,
    DateTime currentTime,
    double lagTime,
    double leadTime
)
<ExtensionAttribute>
Public Shared Function TimeIsValid (
    testTime As DateTime,
    currentTime As DateTime,
    lagTime As Double,
    leadTime As Double
) As Boolean
static member TimeIsValid :
        testTime : DateTime *
        currentTime : DateTime *
        lagTime : float *
        leadTime : float -> bool

GSF.DateTimeExtensions.TimeIsValid = function(testTime, currentTime, lagTime, leadTime);
public:
[ExtensionAttribute]
static bool TimeIsValid(
    DateTime testTime,
    DateTime currentTime,
    double lagTime,
    double leadTime
)

Parameters

testTime
Type: SystemDateTime
Time to test for validity.
currentTime
Type: SystemDateTime
Specified current time (e.g., could be Date.Now or Date.UtcNow).
lagTime
Type: SystemDouble
The allowed lag time, in seconds, before assuming time is too old to be valid.
leadTime
Type: SystemDouble
The allowed lead time, in seconds, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if time is within the specified range.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime and LeadTime must be greater than zero, but can be less than one.
Remarks

Time is considered valid if it exists within the specified lag time/lead time range of current time.

Note that lag time and lead time must be greater than zero, but can be set to sub-second intervals.

See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.TimeZoneToTimeZone Method

Grid Solutions Framework DateTimeExtensionsTimeZoneToTimeZone Method
Overload List
Name | Description
TimeZoneToTimeZone(DateTime, String, String) | Converts given timestamp from one time zone to another using standard names for time zones.
TimeZoneToTimeZone(DateTime, TimeZoneInfo, TimeZoneInfo) | Converts given timestamp from one time zone to another.
Top
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.TimeZoneToTimeZone Method (DateTime, String, String)

Grid Solutions Framework DateTimeExtensionsTimeZoneToTimeZone Method (DateTime, String, String)
Converts given timestamp from one time zone to another using standard names for time zones.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime TimeZoneToTimeZone(
    this DateTime timestamp,
    string sourceTimeZoneStandardName,
    string destinationTimeZoneStandardName
)
<ExtensionAttribute>
Public Shared Function TimeZoneToTimeZone (
    timestamp As DateTime,
    sourceTimeZoneStandardName As String,
    destinationTimeZoneStandardName As String
) As DateTime
static member TimeZoneToTimeZone :
        timestamp : DateTime *
        sourceTimeZoneStandardName : string *
        destinationTimeZoneStandardName : string -> DateTime

GSF.DateTimeExtensions.TimeZoneToTimeZone = function(timestamp, sourceTimeZoneStandardName, destinationTimeZoneStandardName);
public:
[ExtensionAttribute]
static DateTime TimeZoneToTimeZone(
    DateTime timestamp,
    String^ sourceTimeZoneStandardName,
    String^ destinationTimeZoneStandardName
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in source time zone to be converted to time in destination time zone.
sourceTimeZoneStandardName
Type: SystemString
Standard name of time zone for given source timestamp.
destinationTimeZoneStandardName
Type: SystemString
Standard name of desired end time zone for given source timestamp.

Return Value

Type: DateTime

Timestamp in destination time zone.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
TimeZoneToTimeZone Overload
GSF Namespace


DateTimeExtensions.TimeZoneToTimeZone Method (DateTime, TimeZoneInfo, TimeZoneInfo)

Grid Solutions Framework DateTimeExtensionsTimeZoneToTimeZone Method (DateTime, TimeZoneInfo, TimeZoneInfo)
Converts given timestamp from one time zone to another.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime TimeZoneToTimeZone(
    this DateTime timestamp,
    TimeZoneInfo sourceTimeZone,
    TimeZoneInfo destinationTimeZone
)
<ExtensionAttribute>
Public Shared Function TimeZoneToTimeZone (
    timestamp As DateTime,
    sourceTimeZone As TimeZoneInfo,
    destinationTimeZone As TimeZoneInfo
) As DateTime
static member TimeZoneToTimeZone :
        timestamp : DateTime *
        sourceTimeZone : TimeZoneInfo *
        destinationTimeZone : TimeZoneInfo -> DateTime

GSF.DateTimeExtensions.TimeZoneToTimeZone = function(timestamp, sourceTimeZone, destinationTimeZone);
public:
[ExtensionAttribute]
static DateTime TimeZoneToTimeZone(
    DateTime timestamp,
    TimeZoneInfo^ sourceTimeZone,
    TimeZoneInfo^ destinationTimeZone
)

Parameters

timestamp
Type: SystemDateTime
Timestamp in source time zone to be converted to time in destination time zone.
sourceTimeZone
Type: SystemTimeZoneInfo
Time zone for given source timestamp.
destinationTimeZone
Type: SystemTimeZoneInfo
Desired end time zone for given source timestamp.

Return Value

Type: DateTime

Timestamp in destination time zone.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
TimeZoneToTimeZone Overload
GSF Namespace


DateTimeExtensions.UniversalTimeTo Method

Grid Solutions Framework DateTimeExtensionsUniversalTimeTo Method
Overload List
Name | Description
UniversalTimeTo(DateTime, String) | Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.
UniversalTimeTo(DateTime, TimeZoneInfo) | Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.
Top
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.UniversalTimeTo Method (DateTime, String)

Grid Solutions Framework DateTimeExtensionsUniversalTimeTo Method (DateTime, String)
Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime UniversalTimeTo(
    this DateTime universalTimestamp,
    string destinationTimeZoneStandardName
)
<ExtensionAttribute>
Public Shared Function UniversalTimeTo (
    universalTimestamp As DateTime,
    destinationTimeZoneStandardName As String
) As DateTime
static member UniversalTimeTo :
        universalTimestamp : DateTime *
        destinationTimeZoneStandardName : string -> DateTime

GSF.DateTimeExtensions.UniversalTimeTo = function(universalTimestamp, destinationTimeZoneStandardName);
public:
[ExtensionAttribute]
static DateTime UniversalTimeTo(
    DateTime universalTimestamp,
    String^ destinationTimeZoneStandardName
)

Parameters

universalTimestamp
Type: SystemDateTime
The Universally Coordinated Time timestamp that is to be converted.
destinationTimeZoneStandardName
Type: SystemString
The time zone standard name to which the Universally Coordinated Time timestamp is to be converted to.

Return Value

Type: DateTime
The timestamp in the specified time zone.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
UniversalTimeTo Overload
GSF Namespace


DateTimeExtensions.UniversalTimeTo Method (DateTime, TimeZoneInfo)

Grid Solutions Framework DateTimeExtensionsUniversalTimeTo Method (DateTime, TimeZoneInfo)
Converts the specified Universally Coordinated Time timestamp to timestamp in specified time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime UniversalTimeTo(
    this DateTime universalTimestamp,
    TimeZoneInfo destinationTimeZone
)
<ExtensionAttribute>
Public Shared Function UniversalTimeTo (
    universalTimestamp As DateTime,
    destinationTimeZone As TimeZoneInfo
) As DateTime
static member UniversalTimeTo :
        universalTimestamp : DateTime *
        destinationTimeZone : TimeZoneInfo -> DateTime

GSF.DateTimeExtensions.UniversalTimeTo = function(universalTimestamp, destinationTimeZone);
public:
[ExtensionAttribute]
static DateTime UniversalTimeTo(
    DateTime universalTimestamp,
    TimeZoneInfo^ destinationTimeZone
)

Parameters

universalTimestamp
Type: SystemDateTime
The Universally Coordinated Time timestamp that is to be converted.
destinationTimeZone
Type: SystemTimeZoneInfo
The time zone to which the Universally Coordinated Time timestamp is to be converted to.

Return Value

Type: DateTime
The timestamp in the specified time zone.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
UniversalTimeTo Overload
GSF Namespace


DateTimeExtensions.UniversalTimeToCentralTime Method

Grid Solutions Framework DateTimeExtensionsUniversalTimeToCentralTime Method
Converts the specified Universally Coordinated Time timestamp to Central time timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime UniversalTimeToCentralTime(
    this DateTime universalTimestamp
)
<ExtensionAttribute>
Public Shared Function UniversalTimeToCentralTime (
    universalTimestamp As DateTime
) As DateTime
static member UniversalTimeToCentralTime :
        universalTimestamp : DateTime -> DateTime

GSF.DateTimeExtensions.UniversalTimeToCentralTime = function(universalTimestamp);
public:
[ExtensionAttribute]
static DateTime UniversalTimeToCentralTime(
    DateTime universalTimestamp
)

Parameters

universalTimestamp
Type: SystemDateTime
The Universally Coordinated Time timestamp that is to be converted.

Return Value

Type: DateTime
The timestamp in Central time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.UniversalTimeToEasternTime Method

Grid Solutions Framework DateTimeExtensionsUniversalTimeToEasternTime Method
Converts the specified Universally Coordinated Time timestamp to Eastern time timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime UniversalTimeToEasternTime(
    this DateTime universalTimestamp
)
<ExtensionAttribute>
Public Shared Function UniversalTimeToEasternTime (
    universalTimestamp As DateTime
) As DateTime
static member UniversalTimeToEasternTime :
        universalTimestamp : DateTime -> DateTime

GSF.DateTimeExtensions.UniversalTimeToEasternTime = function(universalTimestamp);
public:
[ExtensionAttribute]
static DateTime UniversalTimeToEasternTime(
    DateTime universalTimestamp
)

Parameters

universalTimestamp
Type: SystemDateTime
The Universally Coordinated Time timestamp that is to be converted.

Return Value

Type: DateTime
The timestamp in Eastern time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.UniversalTimeToMountainTime Method

Grid Solutions Framework DateTimeExtensionsUniversalTimeToMountainTime Method
Converts the specified Universally Coordinated Time timestamp to Mountain time timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime UniversalTimeToMountainTime(
    this DateTime universalTimestamp
)
<ExtensionAttribute>
Public Shared Function UniversalTimeToMountainTime (
    universalTimestamp As DateTime
) As DateTime
static member UniversalTimeToMountainTime :
        universalTimestamp : DateTime -> DateTime

GSF.DateTimeExtensions.UniversalTimeToMountainTime = function(universalTimestamp);
public:
[ExtensionAttribute]
static DateTime UniversalTimeToMountainTime(
    DateTime universalTimestamp
)

Parameters

universalTimestamp
Type: SystemDateTime
The Universally Coordinated Time timestamp that is to be converted.

Return Value

Type: DateTime
The timestamp in Mountain time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.UniversalTimeToPacificTime Method

Grid Solutions Framework DateTimeExtensionsUniversalTimeToPacificTime Method
Converts the specified Universally Coordinated Time timestamp to Pacific time timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime UniversalTimeToPacificTime(
    this DateTime universalTimestamp
)
<ExtensionAttribute>
Public Shared Function UniversalTimeToPacificTime (
    universalTimestamp As DateTime
) As DateTime
static member UniversalTimeToPacificTime :
        universalTimestamp : DateTime -> DateTime

GSF.DateTimeExtensions.UniversalTimeToPacificTime = function(universalTimestamp);
public:
[ExtensionAttribute]
static DateTime UniversalTimeToPacificTime(
    DateTime universalTimestamp
)

Parameters

universalTimestamp
Type: SystemDateTime
The Universally Coordinated Time timestamp that is to be converted.

Return Value

Type: DateTime
The timestamp in Pacific time.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.UtcTimeIsValid Method

Grid Solutions Framework DateTimeExtensionsUtcTimeIsValid Method
Determines if the specified UTC time is valid, by comparing it to the system clock.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool UtcTimeIsValid(
    this DateTime utcTime,
    double lagTime,
    double leadTime
)
<ExtensionAttribute>
Public Shared Function UtcTimeIsValid (
    utcTime As DateTime,
    lagTime As Double,
    leadTime As Double
) As Boolean
static member UtcTimeIsValid :
        utcTime : DateTime *
        lagTime : float *
        leadTime : float -> bool

GSF.DateTimeExtensions.UtcTimeIsValid = function(utcTime, lagTime, leadTime);
public:
[ExtensionAttribute]
static bool UtcTimeIsValid(
    DateTime utcTime,
    double lagTime,
    double leadTime
)

Parameters

utcTime
Type: SystemDateTime
UTC time to test for validity.
lagTime
Type: SystemDouble
The allowed lag time, in seconds, before assuming time is too old to be valid.
leadTime
Type: SystemDouble
The allowed lead time, in seconds, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if time is within the specified range.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime and LeadTime must be greater than zero, but can be less than one.
Remarks

Time is considered valid if it exists within the specified lag time/lead time range of current time.

Note that lag time and lead time must be greater than zero, but can be set to sub-second intervals.

See Also

Reference

DateTimeExtensions Class
GSF Namespace


DateTimeExtensions.WeekdayName Method

Grid Solutions Framework DateTimeExtensionsWeekdayName Method
Gets the full weekday name for weekday of the timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string WeekdayName(
    this DateTime timestamp
)
<ExtensionAttribute>
Public Shared Function WeekdayName (
    timestamp As DateTime
) As String
static member WeekdayName :
        timestamp : DateTime -> string

GSF.DateTimeExtensions.WeekdayName = function(timestamp);
public:
[ExtensionAttribute]
static String^ WeekdayName(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
Timestamp from which weekday name is extracted.

Return Value

Type: String
String representation of the weekday name based on timestamp

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DateTime. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DateTimeExtensions Class
GSF Namespace


Endianness Enumeration

Grid Solutions Framework Endianness Enumeration
Endian Byte Order Enumeration.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum Endianness
Public Enumeration Endianness
type Endianness
GSF.Endianness = function();
GSF.Endianness.createEnum('GSF.Endianness', false);
public enum class Endianness
Members
Member name | Value | Description
BigEndian | 0 | Big-endian byte order.
LittleEndian | 1 | Little-endian byte order.
See Also

Reference

GSF Namespace


EndianOrder Class

Grid Solutions Framework EndianOrder Class
Represents an endian byte order interoperability class.
Inheritance Hierarchy
SystemObject
GSFEndianOrder
GSFBigEndianOrder
GSFLittleEndianOrder
GSFNativeEndianOrder

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EndianOrder
Public Class EndianOrder
type EndianOrder =  class end
GSF.EndianOrder = function();

Type.createClass(
    'GSF.EndianOrder');
public ref class EndianOrder

The EndianOrder type exposes the following members.

Constructors
 | Name | Description
Protected method | EndianOrder | Constructs a new instance of the EndianOrder class.
Top
Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation.
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation.
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes.
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array.
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
BigEndian | Default instance of the Big-Endian byte order conversion class.
LittleEndian | Default instance of the Little-Endian byte order conversion class.
Top
Properties
 | Name | Description
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation.
Top
Remarks
Intel systems use little-endian byte order, other systems, such as Unix, use big-endian byte ordering. Little-endian ordering means bits are ordered such that the bit whose in-memory representation is right-most is the most-significant-bit in a byte. Big-endian ordering means bits are ordered such that the bit whose in-memory representation is left-most is the most-significant-bit in a byte.
See Also

Reference

GSF Namespace


EndianOrder Constructor

Grid Solutions Framework EndianOrder Constructor
Constructs a new instance of the EndianOrder class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected EndianOrder(
    Endianness targetEndianness
)
Protected Sub New (
    targetEndianness As Endianness
)
new :
        targetEndianness : Endianness -> EndianOrder
GSF.EndianOrder = function(targetEndianness);
protected:
EndianOrder(
    Endianness targetEndianness
)

Parameters

targetEndianness
Type: GSFEndianness
Endianness parameter.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder Fields

Grid Solutions Framework EndianOrder Fields

The EndianOrder type exposes the following members.

Fields
Name | Description
BigEndian | Default instance of the Big-Endian byte order conversion class.
LittleEndian | Default instance of the Little-Endian byte order conversion class.
Top
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.BigEndian Field

Grid Solutions Framework EndianOrderBigEndian Field
Default instance of the Big-Endian byte order conversion class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static EndianOrder BigEndian
Public Shared BigEndian As EndianOrder
static val mutable BigEndian: EndianOrder
var GSF.EndianOrder.BigEndian
public:
static EndianOrder^ BigEndian

Field Value

Type: EndianOrder
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.LittleEndian Field

Grid Solutions Framework EndianOrderLittleEndian Field
Default instance of the Little-Endian byte order conversion class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static EndianOrder LittleEndian
Public Shared LittleEndian As EndianOrder
static val mutable LittleEndian: EndianOrder
var GSF.EndianOrder.LittleEndian
public:
static EndianOrder^ LittleEndian

Field Value

Type: EndianOrder
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder Methods

Grid Solutions Framework EndianOrder Methods

The EndianOrder type exposes the following members.

Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation.
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation.
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes.
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array.
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.CoerceByteOrder Method

Grid Solutions Framework EndianOrderCoerceByteOrder Method

Note: This API is now obsolete.

Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method may be removed from future builds",
    false)]
public byte[] CoerceByteOrder(
    byte[] buffer
)
<ObsoleteAttribute("This method may be removed from future builds",
    false)>
Public Function CoerceByteOrder (
    buffer As Byte()
) As Byte()
[<ObsoleteAttribute("This method may be removed from future builds",
    false)>]
member CoerceByteOrder :
        buffer : byte[] -> byte[]

function CoerceByteOrder(buffer);
public:
[ObsoleteAttribute(L"This method may be removed from future builds",
    false)]
array<unsigned char>^ CoerceByteOrder(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
Byte buffer to be coerced.

Return Value

Type: Byte
Coerced byte array.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.CopyBuffer Method

Grid Solutions Framework EndianOrderCopyBuffer Method

Note: This API is now obsolete.

Copies a buffer in the target endian-order of this EndianOrder representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method may be removed from future builds",
    false)]
public void CopyBuffer(
    byte[] sourceBuffer,
    int sourceIndex,
    byte[] destinationBuffer,
    int destinationIndex,
    int length
)
<ObsoleteAttribute("This method may be removed from future builds",
    false)>
Public Sub CopyBuffer (
    sourceBuffer As Byte(),
    sourceIndex As Integer,
    destinationBuffer As Byte(),
    destinationIndex As Integer,
    length As Integer
)
[<ObsoleteAttribute("This method may be removed from future builds",
    false)>]
member CopyBuffer :
        sourceBuffer : byte[] *
        sourceIndex : int *
        destinationBuffer : byte[] *
        destinationIndex : int *
        length : int -> unit

function CopyBuffer(sourceBuffer, sourceIndex, destinationBuffer, destinationIndex, length);
public:
[ObsoleteAttribute(L"This method may be removed from future builds",
    false)]
void CopyBuffer(
    array<unsigned char>^ sourceBuffer,
    int sourceIndex,
    array<unsigned char>^ destinationBuffer,
    int destinationIndex,
    int length
)

Parameters

sourceBuffer
Type: SystemByte
The source buffer.
sourceIndex
Type: SystemInt32
The byte offset into sourceBuffer.
destinationBuffer
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationBuffer.
length
Type: SystemInt32
The number of bytes to copy.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.CopyBytes Method

Grid Solutions Framework EndianOrderCopyBytes Method
Overload List
 | Name | Description
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
Top
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.CopyBytes Method (Boolean, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Boolean, Byte, Int32)
Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    bool value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Boolean,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : bool *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    bool value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Char, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Char, Byte, Int32)
Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    char value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Char,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : char *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    wchar_t value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemChar
The Unicode character value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Double, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Double, Byte, Int32)
Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    double value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Double,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : float *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    double value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemDouble
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Guid, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Guid, Byte, Int32)

Note: This API is now obsolete.

Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method may be removed from future builds",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public int CopyBytes(
    Guid value,
    byte[] destinationArray,
    int destinationIndex
)
<ObsoleteAttribute("This method may be removed from future builds",
    false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Function CopyBytes (
    value As Guid,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
[<ObsoleteAttribute("This method may be removed from future builds",
    false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
member CopyBytes :
        value : Guid *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
[ObsoleteAttribute(L"This method may be removed from future builds",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
int CopyBytes(
    Guid value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemGuid
The Guid to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Int16, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Int16, Byte, Int32)
Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    short value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Short,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : int16 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    short value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt16
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Int32, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Int32, Byte, Int32)
Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    int value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Integer,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : int *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    int value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt32
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Int64, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Int64, Byte, Int32)
Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    long value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Long,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : int64 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    long long value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt64
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Single, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Single, Byte, Int32)
Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    float value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Single,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : float32 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    float value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemSingle
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (UInt16, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (UInt16, Byte, Int32)
Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    ushort value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As UShort,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : uint16 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    unsigned short value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt16
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (UInt32, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (UInt32, Byte, Int32)
Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    uint value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As UInteger,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : uint32 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    unsigned int value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt32
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (UInt64, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (UInt64, Byte, Int32)
Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    ulong value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As ULong,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : uint64 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    unsigned long long value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt64
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes(T) Method (T, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytesT Method (T, Byte, Int32)
Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes<T>(
    T value,
    byte[] destinationArray,
    int destinationIndex
)
where T : struct, new(), IConvertible

Public Function CopyBytes(Of T As {Structure, New, IConvertible}) (
    value As T,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : 'T *
        destinationArray : byte[] *
        destinationIndex : int -> int  when 'T : struct, new() and IConvertible

JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
int CopyBytes(
    T value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: T
The Boolean value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Int32
Length of bytes copied into array based on size of T.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (Int24, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (Int24, Byte, Int32)
Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    Int24 value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As Int24,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : Int24 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    Int24 value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: GSFInt24
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.CopyBytes Method (UInt24, Byte[], Int32)

Grid Solutions Framework EndianOrderCopyBytes Method (UInt24, Byte, Int32)
Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CopyBytes(
    UInt24 value,
    byte[] destinationArray,
    int destinationIndex
)
Public Function CopyBytes (
    value As UInt24,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
member CopyBytes :
        value : UInt24 *
        destinationArray : byte[] *
        destinationIndex : int -> int

function CopyBytes(value, destinationArray, destinationIndex);
public:
int CopyBytes(
    UInt24 value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: GSFUInt24
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

EndianOrder Class
CopyBytes Overload
GSF Namespace


EndianOrder.GetBytes Method

Grid Solutions Framework EndianOrderGetBytes Method
Overload List
 | Name | Description
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes.
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
Top
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.GetBytes Method (Boolean)

Grid Solutions Framework EndianOrderGetBytes Method (Boolean)
Returns the specified Boolean value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    bool value
)
Public Function GetBytes (
    value As Boolean
) As Byte()
member GetBytes :
        value : bool -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    bool value
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert.

Return Value

Type: Byte
An array of bytes with length 1.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Char)

Grid Solutions Framework EndianOrderGetBytes Method (Char)
Returns the specified Unicode character value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    char value
)
Public Function GetBytes (
    value As Char
) As Byte()
member GetBytes :
        value : char -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    wchar_t value
)

Parameters

value
Type: SystemChar
The Unicode character value to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Double)

Grid Solutions Framework EndianOrderGetBytes Method (Double)
Returns the specified double-precision floating point value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    double value
)
Public Function GetBytes (
    value As Double
) As Byte()
member GetBytes :
        value : float -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    double value
)

Parameters

value
Type: SystemDouble
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Guid)

Grid Solutions Framework EndianOrderGetBytes Method (Guid)

Note: This API is now obsolete.

Returns the specified Guid value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method may be removed from future builds",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public byte[] GetBytes(
    Guid value
)
<ObsoleteAttribute("This method may be removed from future builds",
    false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Function GetBytes (
    value As Guid
) As Byte()
[<ObsoleteAttribute("This method may be removed from future builds",
    false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
member GetBytes :
        value : Guid -> byte[]

function GetBytes(value);
public:
[ObsoleteAttribute(L"This method may be removed from future builds",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
array<unsigned char>^ GetBytes(
    Guid value
)

Parameters

value
Type: SystemGuid
The number to convert.

Return Value

Type: Byte
An array of bytes with length 16.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Int16)

Grid Solutions Framework EndianOrderGetBytes Method (Int16)
Returns the specified 16-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    short value
)
Public Function GetBytes (
    value As Short
) As Byte()
member GetBytes :
        value : int16 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    short value
)

Parameters

value
Type: SystemInt16
The number to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Int32)

Grid Solutions Framework EndianOrderGetBytes Method (Int32)
Returns the specified 32-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    int value
)
Public Function GetBytes (
    value As Integer
) As Byte()
member GetBytes :
        value : int -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    int value
)

Parameters

value
Type: SystemInt32
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Int64)

Grid Solutions Framework EndianOrderGetBytes Method (Int64)
Returns the specified 64-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    long value
)
Public Function GetBytes (
    value As Long
) As Byte()
member GetBytes :
        value : int64 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    long long value
)

Parameters

value
Type: SystemInt64
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Single)

Grid Solutions Framework EndianOrderGetBytes Method (Single)
Returns the specified single-precision floating point value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    float value
)
Public Function GetBytes (
    value As Single
) As Byte()
member GetBytes :
        value : float32 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    float value
)

Parameters

value
Type: SystemSingle
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (UInt16)

Grid Solutions Framework EndianOrderGetBytes Method (UInt16)
Returns the specified 16-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    ushort value
)
Public Function GetBytes (
    value As UShort
) As Byte()
member GetBytes :
        value : uint16 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    unsigned short value
)

Parameters

value
Type: SystemUInt16
The number to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (UInt32)

Grid Solutions Framework EndianOrderGetBytes Method (UInt32)
Returns the specified 32-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    uint value
)
Public Function GetBytes (
    value As UInteger
) As Byte()
member GetBytes :
        value : uint32 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (UInt64)

Grid Solutions Framework EndianOrderGetBytes Method (UInt64)
Returns the specified 64-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    ulong value
)
Public Function GetBytes (
    value As ULong
) As Byte()
member GetBytes :
        value : uint64 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes(T) Method (T)

Grid Solutions Framework EndianOrderGetBytesT Method (T)
Returns the specified value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes<T>(
    T value
)
where T : struct, new(), IConvertible

Public Function GetBytes(Of T As {Structure, New, IConvertible}) (
    value As T
) As Byte()
member GetBytes :
        value : 'T -> byte[]  when 'T : struct, new() and IConvertible

JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
array<unsigned char>^ GetBytes(
    T value
)

Parameters

value
Type: T
The value to convert.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Byte
An array of bytes with length 1.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (Int24)

Grid Solutions Framework EndianOrderGetBytes Method (Int24)
Returns the specified 24-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    Int24 value
)
Public Function GetBytes (
    value As Int24
) As Byte()
member GetBytes :
        value : Int24 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    Int24 value
)

Parameters

value
Type: GSFInt24
The number to convert.

Return Value

Type: Byte
An array of bytes with length 3.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.GetBytes Method (UInt24)

Grid Solutions Framework EndianOrderGetBytes Method (UInt24)
Returns the specified 24-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes(
    UInt24 value
)
Public Function GetBytes (
    value As UInt24
) As Byte()
member GetBytes :
        value : UInt24 -> byte[]

function GetBytes(value);
public:
array<unsigned char>^ GetBytes(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
The number to convert.

Return Value

Type: Byte
An array of bytes with length 3.
See Also

Reference

EndianOrder Class
GetBytes Overload
GSF Namespace


EndianOrder.ToBoolean Method

Grid Solutions Framework EndianOrderToBoolean Method
Returns a Boolean value converted from one byte at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ToBoolean(
    byte[] value,
    int startIndex
)
Public Function ToBoolean (
    value As Byte(),
    startIndex As Integer
) As Boolean
member ToBoolean :
        value : byte[] *
        startIndex : int -> bool

function ToBoolean(value, startIndex);
public:
bool ToBoolean(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes.
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Boolean
true if the byte at startIndex in value is nonzero; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToChar Method

Grid Solutions Framework EndianOrderToChar Method
Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char ToChar(
    byte[] value,
    int startIndex
)
Public Function ToChar (
    value As Byte(),
    startIndex As Integer
) As Char
member ToChar :
        value : byte[] *
        startIndex : int -> char

function ToChar(value, startIndex);
public:
wchar_t ToChar(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Char
A character formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToDouble Method

Grid Solutions Framework EndianOrderToDouble Method
Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToDouble(
    byte[] value,
    int startIndex
)
Public Function ToDouble (
    value As Byte(),
    startIndex As Integer
) As Double
member ToDouble :
        value : byte[] *
        startIndex : int -> float

function ToDouble(value, startIndex);
public:
double ToDouble(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Double
A double-precision floating point number formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToGuid Method

Grid Solutions Framework EndianOrderToGuid Method

Note: This API is now obsolete.

Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method may be removed from future builds",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public Guid ToGuid(
    byte[] value,
    int startIndex
)
<ObsoleteAttribute("This method may be removed from future builds",
    false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Function ToGuid (
    value As Byte(),
    startIndex As Integer
) As Guid
[<ObsoleteAttribute("This method may be removed from future builds",
    false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
member ToGuid :
        value : byte[] *
        startIndex : int -> Guid

function ToGuid(value, startIndex);
public:
[ObsoleteAttribute(L"This method may be removed from future builds",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
Guid ToGuid(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Guid
A Guid formed by sixteen bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToInt16 Method

Grid Solutions Framework EndianOrderToInt16 Method
Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short ToInt16(
    byte[] value,
    int startIndex
)
Public Function ToInt16 (
    value As Byte(),
    startIndex As Integer
) As Short
member ToInt16 :
        value : byte[] *
        startIndex : int -> int16

function ToInt16(value, startIndex);
public:
short ToInt16(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int16
A 16-bit signed integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToInt24 Method

Grid Solutions Framework EndianOrderToInt24 Method
Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Int24 ToInt24(
    byte[] value,
    int startIndex
)
Public Function ToInt24 (
    value As Byte(),
    startIndex As Integer
) As Int24
member ToInt24 :
        value : byte[] *
        startIndex : int -> Int24

function ToInt24(value, startIndex);
public:
Int24 ToInt24(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int24
A 24-bit signed integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToInt32 Method

Grid Solutions Framework EndianOrderToInt32 Method
Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ToInt32(
    byte[] value,
    int startIndex
)
Public Function ToInt32 (
    value As Byte(),
    startIndex As Integer
) As Integer
member ToInt32 :
        value : byte[] *
        startIndex : int -> int

function ToInt32(value, startIndex);
public:
int ToInt32(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int32
A 32-bit signed integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToInt64 Method

Grid Solutions Framework EndianOrderToInt64 Method
Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ToInt64(
    byte[] value,
    int startIndex
)
Public Function ToInt64 (
    value As Byte(),
    startIndex As Integer
) As Long
member ToInt64 :
        value : byte[] *
        startIndex : int -> int64

function ToInt64(value, startIndex);
public:
long long ToInt64(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int64
A 64-bit signed integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToSingle Method

Grid Solutions Framework EndianOrderToSingle Method
Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ToSingle(
    byte[] value,
    int startIndex
)
Public Function ToSingle (
    value As Byte(),
    startIndex As Integer
) As Single
member ToSingle :
        value : byte[] *
        startIndex : int -> float32

function ToSingle(value, startIndex);
public:
float ToSingle(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Single
A single-precision floating point number formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToUInt16 Method

Grid Solutions Framework EndianOrderToUInt16 Method
Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ToUInt16(
    byte[] value,
    int startIndex
)
Public Function ToUInt16 (
    value As Byte(),
    startIndex As Integer
) As UShort
member ToUInt16 :
        value : byte[] *
        startIndex : int -> uint16

function ToUInt16(value, startIndex);
public:
unsigned short ToUInt16(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt16
A 16-bit unsigned integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToUInt24 Method

Grid Solutions Framework EndianOrderToUInt24 Method
Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UInt24 ToUInt24(
    byte[] value,
    int startIndex
)
Public Function ToUInt24 (
    value As Byte(),
    startIndex As Integer
) As UInt24
member ToUInt24 :
        value : byte[] *
        startIndex : int -> UInt24

function ToUInt24(value, startIndex);
public:
UInt24 ToUInt24(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt24
A 24-bit unsigned integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToUInt32 Method

Grid Solutions Framework EndianOrderToUInt32 Method
Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ToUInt32(
    byte[] value,
    int startIndex
)
Public Function ToUInt32 (
    value As Byte(),
    startIndex As Integer
) As UInteger
member ToUInt32 :
        value : byte[] *
        startIndex : int -> uint32

function ToUInt32(value, startIndex);
public:
unsigned int ToUInt32(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt32
A 32-bit unsigned integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.ToUInt64 Method

Grid Solutions Framework EndianOrderToUInt64 Method
Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong ToUInt64(
    byte[] value,
    int startIndex
)
Public Function ToUInt64 (
    value As Byte(),
    startIndex As Integer
) As ULong
member ToUInt64 :
        value : byte[] *
        startIndex : int -> uint64

function ToUInt64(value, startIndex);
public:
unsigned long long ToUInt64(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt64
A 64-bit unsigned integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder Properties

Grid Solutions Framework EndianOrder Properties

The EndianOrder type exposes the following members.

Properties
 | Name | Description
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation.
Top
See Also

Reference

EndianOrder Class
GSF Namespace


EndianOrder.TargetEndianness Property

Grid Solutions Framework EndianOrderTargetEndianness Property
Returns the target endian-order of this EndianOrder representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Endianness TargetEndianness { get; }
Public ReadOnly Property TargetEndianness As Endianness
    Get
member TargetEndianness : Endianness with get

function get_TargetEndianness();

public:
property Endianness TargetEndianness {
    Endianness get ();
}

Property Value

Type: Endianness
See Also

Reference

EndianOrder Class
GSF Namespace


EnumExtensions Class

Grid Solutions Framework EnumExtensions Class
Defines extension methods related to enumerations.
Inheritance Hierarchy
SystemObject
GSFEnumExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class EnumExtensions
<ExtensionAttribute>
Public NotInheritable Class EnumExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type EnumExtensions =  class end
GSF.EnumExtensions = function();

Type.createClass(
    'GSF.EnumExtensions');
[ExtensionAttribute]
public ref class EnumExtensions abstract sealed

The EnumExtensions type exposes the following members.

Methods
Name | Description
GetDescription | Retrieves the description of the value that this Enum represents extracted from the DescriptionAttribute, or the enumeration name if no description is available.
GetEnumValueByDescription | Gets the enumeration of the specified type whose description matches this description.
GetEnumValueByName | Gets the enumeration value with the specified name.
GetEnumValueOrDefault(Object, Type, Object) | Gets the enumeration constant for value, if defined in the enumeration, or a default value.
GetEnumValueOrDefaultT(Object, Object) | Gets the enumeration constant for this value, if defined in the enumeration, or a default value.
GetFormattedName | Retrieves a formatted name of the value that this Enum represents for visual display.
Top
See Also

Reference

GSF Namespace


EnumExtensions Methods

Grid Solutions Framework EnumExtensions Methods

The EnumExtensions type exposes the following members.

Methods
Name | Description
GetDescription | Retrieves the description of the value that this Enum represents extracted from the DescriptionAttribute, or the enumeration name if no description is available.
GetEnumValueByDescription | Gets the enumeration of the specified type whose description matches this description.
GetEnumValueByName | Gets the enumeration value with the specified name.
GetEnumValueOrDefault(Object, Type, Object) | Gets the enumeration constant for value, if defined in the enumeration, or a default value.
GetEnumValueOrDefaultT(Object, Object) | Gets the enumeration constant for this value, if defined in the enumeration, or a default value.
GetFormattedName | Retrieves a formatted name of the value that this Enum represents for visual display.
Top
See Also

Reference

EnumExtensions Class
GSF Namespace


EnumExtensions.GetDescription Method

Grid Solutions Framework EnumExtensionsGetDescription Method
Retrieves the description of the value that this Enum represents extracted from the DescriptionAttribute, or the enumeration name if no description is available.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetDescription(
    this Enum enumeration
)
<ExtensionAttribute>
Public Shared Function GetDescription (
    enumeration As Enum
) As String
static member GetDescription :
        enumeration : Enum -> string

GSF.EnumExtensions.GetDescription = function(enumeration);
public:
[ExtensionAttribute]
static String^ GetDescription(
    Enum^ enumeration
)

Parameters

enumeration
Type: SystemEnum
Enum to operate on.

Return Value

Type: String
Description of the Enum if specified, otherwise the String representation of this enumeration.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Enum. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumExtensions Class
GSF Namespace


EnumExtensions.GetEnumValueByDescription Method

Grid Solutions Framework EnumExtensionsGetEnumValueByDescription Method
Gets the enumeration of the specified type whose description matches this description.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object GetEnumValueByDescription(
    this string description,
    Type type,
    bool ignoreCase = false
)
<ExtensionAttribute>
Public Shared Function GetEnumValueByDescription (
    description As String,
    type As Type,
    Optional ignoreCase As Boolean = false
) As Object
static member GetEnumValueByDescription :
        description : string *
        type : Type *
        ?ignoreCase : bool
(* Defaults:
        let _ignoreCase = defaultArg ignoreCase false
*)
-> Object

GSF.EnumExtensions.GetEnumValueByDescription = function(description, type, ignoreCase);
public:
[ExtensionAttribute]
static Object^ GetEnumValueByDescription(
    String^ description,
    Type^ type,
    bool ignoreCase = false
)

Parameters

description
Type: SystemString
Description to be used for lookup of the enumeration.
type
Type: SystemType
Type of the enumeration.
ignoreCase (Optional)
Type: SystemBoolean
true to ignore case during the comparison; otherwise, false.

Return Value

Type: Object
An enumeration of the specified type if a match is found, otherwise null.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | The type is not an enumeration.
See Also

Reference

EnumExtensions Class
GSF Namespace


EnumExtensions.GetEnumValueByName Method

Grid Solutions Framework EnumExtensionsGetEnumValueByName Method
Gets the enumeration value with the specified name.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object GetEnumValueByName(
    this string name,
    Type type,
    bool ignoreCase = false
)
<ExtensionAttribute>
Public Shared Function GetEnumValueByName (
    name As String,
    type As Type,
    Optional ignoreCase As Boolean = false
) As Object
static member GetEnumValueByName :
        name : string *
        type : Type *
        ?ignoreCase : bool
(* Defaults:
        let _ignoreCase = defaultArg ignoreCase false
*)
-> Object

GSF.EnumExtensions.GetEnumValueByName = function(name, type, ignoreCase);
public:
[ExtensionAttribute]
static Object^ GetEnumValueByName(
    String^ name,
    Type^ type,
    bool ignoreCase = false
)

Parameters

name
Type: SystemString
Name to search for.
type
Type: SystemType
Type of the enumeration.
ignoreCase (Optional)
Type: SystemBoolean
true to ignore case during the comparison; otherwise, false.

Return Value

Type: Object
Specific value of the enumerated constant in terms of its underlying type associated with the specified name, or null if no matching enumerated value was found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumExtensions Class
GSF Namespace


EnumExtensions.GetEnumValueOrDefault Method

Grid Solutions Framework EnumExtensionsGetEnumValueOrDefault Method
Overload List
Name | Description
GetEnumValueOrDefaultT(Object, Object) | Gets the enumeration constant for this value, if defined in the enumeration, or a default value.
GetEnumValueOrDefault(Object, Type, Object) | Gets the enumeration constant for value, if defined in the enumeration, or a default value.
Top
See Also

Reference

EnumExtensions Class
GSF Namespace


EnumExtensions.GetEnumValueOrDefault(T) Method (Object, Object)

Grid Solutions Framework EnumExtensionsGetEnumValueOrDefaultT Method (Object, Object)
Gets the enumeration constant for this value, if defined in the enumeration, or a default value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T GetEnumValueOrDefault<T>(
    this Object value,
    Object defaultValue = null
)

<ExtensionAttribute>
Public Shared Function GetEnumValueOrDefault(Of T) (
    value As Object,
    Optional defaultValue As Object = Nothing
) As T
static member GetEnumValueOrDefault :
        value : Object *
        ?defaultValue : Object
(* Defaults:
        let _defaultValue = defaultArg defaultValue null
*)
-> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T GetEnumValueOrDefault(
    Object^ value,
    Object^ defaultValue = nullptr
)

Parameters

value
Type: SystemObject
Value to attempt to return from enumeration.
defaultValue (Optional)
Type: SystemObject
Value to return if enumeration value is not found.

Type Parameters

T
Type of enumeration.

Return Value

Type: T
Enumeration value specified, if found, or a default value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentException | T is not an enum. -or- The type of value is not of type T. -or- The type of value is not an underlying type of T.
InvalidOperationException | value is not type SByte, Int16, Int32, Int64, Byte, UInt16, UInt32, or UInt64, or String.
Remarks
If a default value is not defined, first enumeration value will be used.
See Also

Reference

EnumExtensions Class
GetEnumValueOrDefault Overload
GSF Namespace


EnumExtensions.GetEnumValueOrDefault Method (Object, Type, Object)

Grid Solutions Framework EnumExtensionsGetEnumValueOrDefault Method (Object, Type, Object)
Gets the enumeration constant for value, if defined in the enumeration, or a default value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object GetEnumValueOrDefault(
    this Object value,
    Type type,
    Object defaultValue = null
)
<ExtensionAttribute>
Public Shared Function GetEnumValueOrDefault (
    value As Object,
    type As Type,
    Optional defaultValue As Object = Nothing
) As Object
static member GetEnumValueOrDefault :
        value : Object *
        type : Type *
        ?defaultValue : Object
(* Defaults:
        let _defaultValue = defaultArg defaultValue null
*)
-> Object

GSF.EnumExtensions.GetEnumValueOrDefault = function(value, type, defaultValue);
public:
[ExtensionAttribute]
static Object^ GetEnumValueOrDefault(
    Object^ value,
    Type^ type,
    Object^ defaultValue = nullptr
)

Parameters

value
Type: SystemObject
Value to attempt to return from enumeration.
type
Type: SystemType
Type of the enumeration.
defaultValue (Optional)
Type: SystemObject
Value to return if enumeration value is not found.

Return Value

Type: Object
Enumeration value specified, if found, or a default value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Object. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | type or value is null.
ArgumentException | type is not an enum. -or- The type of value is not of type type. -or- The type of value is not an underlying type of type.
InvalidOperationException | value is not type SByte, Int16, Int32, Int64, Byte, UInt16, UInt32, or UInt64, or String.
Remarks
If a default value is not defined, first enumeration value will be used.
See Also

Reference

EnumExtensions Class
GetEnumValueOrDefault Overload
GSF Namespace


EnumExtensions.GetFormattedName Method

Grid Solutions Framework EnumExtensionsGetFormattedName Method
Retrieves a formatted name of the value that this Enum represents for visual display.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetFormattedName(
    this Enum enumeration
)
<ExtensionAttribute>
Public Shared Function GetFormattedName (
    enumeration As Enum
) As String
static member GetFormattedName :
        enumeration : Enum -> string

GSF.EnumExtensions.GetFormattedName = function(enumeration);
public:
[ExtensionAttribute]
static String^ GetFormattedName(
    Enum^ enumeration
)

Parameters

enumeration
Type: SystemEnum
Enum to operate on.

Return Value

Type: String
Formatted enumeration name of the specified value for visual display.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Enum. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

EnumExtensions Class
GSF Namespace


EventArgs(T) Class

Grid Solutions Framework EventArgsT Class
Represents a generic event arguments class with one data argument.
Inheritance Hierarchy
SystemObject
SystemEventArgs
GSFEventArgsT

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class EventArgs<T> : EventArgs

<SerializableAttribute>
Public Class EventArgs(Of T)
    Inherits EventArgs
[<SerializableAttribute>]
type EventArgs<'T> =
    class
        inherit EventArgs
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
public ref class EventArgs : public EventArgs

Type Parameters

T
Type of data argument for this event arguments instance.

The EventArgsT type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT | Initializes a new instance of the EventArgsT class.
Public method | EventArgsT(T) | Initializes a new instance of the EventArgsT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Argument | Gets or sets the data argument for the event using EventArgsT for its EventArgs.
Top
See Also

Reference

GSF Namespace


EventArgs(T) Constructor

Grid Solutions Framework EventArgsT Constructor
Overload List
 | Name | Description
Public method | EventArgsT | Initializes a new instance of the EventArgsT class.
Public method | EventArgsT(T) | Initializes a new instance of the EventArgsT class.
Top
See Also

Reference

EventArgsT Class
GSF Namespace


EventArgs(T) Constructor

Grid Solutions Framework EventArgsT Constructor
Initializes a new instance of the EventArgsT class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs()
Public Sub New
new : unit -> EventArgs
GSF.EventArgs = function();
public:
EventArgs()
See Also

Reference

EventArgsT Class
EventArgsT Overload
GSF Namespace


EventArgs(T) Constructor (T)

Grid Solutions Framework EventArgsT Constructor (T)
Initializes a new instance of the EventArgsT class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs(
    T argument
)
Public Sub New (
    argument As T
)
new :
        argument : 'T -> EventArgs
GSF.EventArgs = function(argument);
public:
EventArgs(
    T argument
)

Parameters

argument
Type: T
The argument data for the event.
See Also

Reference

EventArgsT Class
EventArgsT Overload
GSF Namespace


EventArgs(T) Fields

Grid Solutions Framework EventArgsT Fields

The EventArgsT generic type exposes the following members.

Fields
 | Name | Description
Public field | Argument | Gets or sets the data argument for the event using EventArgsT for its EventArgs.
Top
See Also

Reference

EventArgsT Class
GSF Namespace


EventArgs(T).Argument Field

Grid Solutions Framework EventArgsTArgument Field
Gets or sets the data argument for the event using EventArgsT for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Argument
Public Argument As T
val mutable Argument: 'T
var Argument
public:
T Argument

Field Value

Type: T
See Also

Reference

EventArgsT Class
GSF Namespace


EventArgs(T) Methods

Grid Solutions Framework EventArgsT Methods

The EventArgsT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventArgsT Class
GSF Namespace


EventArgs(T1, T2) Class

Grid Solutions Framework EventArgsT1, T2 Class
Represents a generic event arguments class with two data arguments.
Inheritance Hierarchy
SystemObject
SystemEventArgs
GSFEventArgsT1, T2

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class EventArgs<T1, T2> : EventArgs

<SerializableAttribute>
Public Class EventArgs(Of T1, T2)
    Inherits EventArgs
[<SerializableAttribute>]
type EventArgs<'T1, 'T2> =
    class
        inherit EventArgs
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T1, typename T2>
public ref class EventArgs : public EventArgs

Type Parameters

T1
The type of the first data argument for this event arguments instance.
T2
The type of the second data argument for this event arguments instance.

The EventArgsT1, T2 type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT1, T2 | Initializes a new instance of the EventArgsT1, T2 class.
Public method | EventArgsT1, T2(T1, T2) | Initializes a new instance of the EventArgsT1, T2 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Argument1 | Gets or sets the first data argument for the event using EventArgsT1, T2 for its EventArgs.
Public field | Argument2 | Gets or sets the second data argument for the event using EventArgsT1, T2 for its EventArgs.
Top
See Also

Reference

GSF Namespace


EventArgs(T1, T2) Constructor

Grid Solutions Framework EventArgsT1, T2 Constructor
Overload List
 | Name | Description
Public method | EventArgsT1, T2 | Initializes a new instance of the EventArgsT1, T2 class.
Public method | EventArgsT1, T2(T1, T2) | Initializes a new instance of the EventArgsT1, T2 class.
Top
See Also

Reference

EventArgsT1, T2 Class
GSF Namespace


EventArgs(T1, T2) Constructor

Grid Solutions Framework EventArgsT1, T2 Constructor
Initializes a new instance of the EventArgsT1, T2 class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs()
Public Sub New
new : unit -> EventArgs
GSF.EventArgs = function();
public:
EventArgs()
See Also

Reference

EventArgsT1, T2 Class
EventArgsT1, T2 Overload
GSF Namespace


EventArgs(T1, T2) Constructor (T1, T2)

Grid Solutions Framework EventArgsT1, T2 Constructor (T1, T2)
Initializes a new instance of the EventArgsT1, T2 class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs(
    T1 argument1,
    T2 argument2
)
Public Sub New (
    argument1 As T1,
    argument2 As T2
)
new :
        argument1 : 'T1 *
        argument2 : 'T2 -> EventArgs
GSF.EventArgs = function(argument1, argument2);
public:
EventArgs(
    T1 argument1,
    T2 argument2
)

Parameters

argument1
Type: T1
The first data argument for the event.
argument2
Type: T2
The second data argument for the event.
See Also

Reference

EventArgsT1, T2 Class
EventArgsT1, T2 Overload
GSF Namespace


EventArgs(T1, T2) Fields

Grid Solutions Framework EventArgsT1, T2 Fields

The EventArgsT1, T2 generic type exposes the following members.

Fields
 | Name | Description
Public field | Argument1 | Gets or sets the first data argument for the event using EventArgsT1, T2 for its EventArgs.
Public field | Argument2 | Gets or sets the second data argument for the event using EventArgsT1, T2 for its EventArgs.
Top
See Also

Reference

EventArgsT1, T2 Class
GSF Namespace


EventArgs(T1, T2).Argument1 Field

Grid Solutions Framework EventArgsT1, T2Argument1 Field
Gets or sets the first data argument for the event using EventArgsT1, T2 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T1 Argument1
Public Argument1 As T1
val mutable Argument1: 'T1
var Argument1
public:
T1 Argument1

Field Value

Type: T1
See Also

Reference

EventArgsT1, T2 Class
GSF Namespace


EventArgs(T1, T2).Argument2 Field

Grid Solutions Framework EventArgsT1, T2Argument2 Field
Gets or sets the second data argument for the event using EventArgsT1, T2 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T2 Argument2
Public Argument2 As T2
val mutable Argument2: 'T2
var Argument2
public:
T2 Argument2

Field Value

Type: T2
See Also

Reference

EventArgsT1, T2 Class
GSF Namespace


EventArgs(T1, T2) Methods

Grid Solutions Framework EventArgsT1, T2 Methods

The EventArgsT1, T2 generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventArgsT1, T2 Class
GSF Namespace


EventArgs(T1, T2, T3) Class

Grid Solutions Framework EventArgsT1, T2, T3 Class
Represents a generic event arguments class with three data arguments.
Inheritance Hierarchy
SystemObject
SystemEventArgs
GSFEventArgsT1, T2, T3

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class EventArgs<T1, T2, T3> : EventArgs

<SerializableAttribute>
Public Class EventArgs(Of T1, T2, T3)
    Inherits EventArgs
[<SerializableAttribute>]
type EventArgs<'T1, 'T2, 'T3> =
    class
        inherit EventArgs
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T1, typename T2, typename T3>
public ref class EventArgs : public EventArgs

Type Parameters

T1
The type of the first data argument for this event arguments instance.
T2
The type of the second data argument for this event arguments instance.
T3
The type of the third data argument for this event arguments instance.

The EventArgsT1, T2, T3 type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT1, T2, T3 | Initializes a new instance of the EventArgsT1, T2, T3 class.
Public method | EventArgsT1, T2, T3(T1, T2, T3) | Initializes a new instance of the EventArgsT1, T2, T3 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Argument1 | Gets or sets the first data argument for the event using EventArgsT1, T2, T3 for its EventArgs.
Public field | Argument2 | Gets or sets the second data argument for the event using EventArgsT1, T2, T3 for its EventArgs.
Public field | Argument3 | Gets or sets the third data argument for the event using EventArgsT1, T2, T3 for its EventArgs.
Top
See Also

Reference

GSF Namespace


EventArgs(T1, T2, T3) Constructor

Grid Solutions Framework EventArgsT1, T2, T3 Constructor
Overload List
 | Name | Description
Public method | EventArgsT1, T2, T3 | Initializes a new instance of the EventArgsT1, T2, T3 class.
Public method | EventArgsT1, T2, T3(T1, T2, T3) | Initializes a new instance of the EventArgsT1, T2, T3 class.
Top
See Also

Reference

EventArgsT1, T2, T3 Class
GSF Namespace


EventArgs(T1, T2, T3) Constructor

Grid Solutions Framework EventArgsT1, T2, T3 Constructor
Initializes a new instance of the EventArgsT1, T2, T3 class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs()
Public Sub New
new : unit -> EventArgs
GSF.EventArgs = function();
public:
EventArgs()
See Also

Reference

EventArgsT1, T2, T3 Class
EventArgsT1, T2, T3 Overload
GSF Namespace


EventArgs(T1, T2, T3) Constructor (T1, T2, T3)

Grid Solutions Framework EventArgsT1, T2, T3 Constructor (T1, T2, T3)
Initializes a new instance of the EventArgsT1, T2, T3 class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs(
    T1 argument1,
    T2 argument2,
    T3 argument3
)
Public Sub New (
    argument1 As T1,
    argument2 As T2,
    argument3 As T3
)
new :
        argument1 : 'T1 *
        argument2 : 'T2 *
        argument3 : 'T3 -> EventArgs
GSF.EventArgs = function(argument1, argument2, argument3);
public:
EventArgs(
    T1 argument1,
    T2 argument2,
    T3 argument3
)

Parameters

argument1
Type: T1
The first data argument for the event.
argument2
Type: T2
The second data argument for the event.
argument3
Type: T3
The third data argument for the event.
See Also

Reference

EventArgsT1, T2, T3 Class
EventArgsT1, T2, T3 Overload
GSF Namespace


EventArgs(T1, T2, T3) Fields

Grid Solutions Framework EventArgsT1, T2, T3 Fields

The EventArgsT1, T2, T3 generic type exposes the following members.

Fields
 | Name | Description
Public field | Argument1 | Gets or sets the first data argument for the event using EventArgsT1, T2, T3 for its EventArgs.
Public field | Argument2 | Gets or sets the second data argument for the event using EventArgsT1, T2, T3 for its EventArgs.
Public field | Argument3 | Gets or sets the third data argument for the event using EventArgsT1, T2, T3 for its EventArgs.
Top
See Also

Reference

EventArgsT1, T2, T3 Class
GSF Namespace


EventArgs(T1, T2, T3).Argument1 Field

Grid Solutions Framework EventArgsT1, T2, T3Argument1 Field
Gets or sets the first data argument for the event using EventArgsT1, T2, T3 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T1 Argument1
Public Argument1 As T1
val mutable Argument1: 'T1
var Argument1
public:
T1 Argument1

Field Value

Type: T1
See Also

Reference

EventArgsT1, T2, T3 Class
GSF Namespace


EventArgs(T1, T2, T3).Argument2 Field

Grid Solutions Framework EventArgsT1, T2, T3Argument2 Field
Gets or sets the second data argument for the event using EventArgsT1, T2, T3 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T2 Argument2
Public Argument2 As T2
val mutable Argument2: 'T2
var Argument2
public:
T2 Argument2

Field Value

Type: T2
See Also

Reference

EventArgsT1, T2, T3 Class
GSF Namespace


EventArgs(T1, T2, T3).Argument3 Field

Grid Solutions Framework EventArgsT1, T2, T3Argument3 Field
Gets or sets the third data argument for the event using EventArgsT1, T2, T3 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T3 Argument3
Public Argument3 As T3
val mutable Argument3: 'T3
var Argument3
public:
T3 Argument3

Field Value

Type: T3
See Also

Reference

EventArgsT1, T2, T3 Class
GSF Namespace


EventArgs(T1, T2, T3) Methods

Grid Solutions Framework EventArgsT1, T2, T3 Methods

The EventArgsT1, T2, T3 generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventArgsT1, T2, T3 Class
GSF Namespace


EventArgs(T1, T2, T3, T4) Class

Grid Solutions Framework EventArgsT1, T2, T3, T4 Class
Represents a generic event arguments class with three data arguments.
Inheritance Hierarchy
SystemObject
SystemEventArgs
GSFEventArgsT1, T2, T3, T4

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class EventArgs<T1, T2, T3, T4> : EventArgs

<SerializableAttribute>
Public Class EventArgs(Of T1, T2, T3, T4)
    Inherits EventArgs
[<SerializableAttribute>]
type EventArgs<'T1, 'T2, 'T3, 'T4> =
    class
        inherit EventArgs
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T1, typename T2, typename T3, typename T4>
public ref class EventArgs : public EventArgs

Type Parameters

T1
The type of the first data argument for this event arguments instance.
T2
The type of the second data argument for this event arguments instance.
T3
The type of the third data argument for this event arguments instance.
T4
The type of the fourth data argument for this event arguments instance.

The EventArgsT1, T2, T3, T4 type exposes the following members.

Constructors
 | Name | Description
Public method | EventArgsT1, T2, T3, T4 | Initializes a new instance of the EventArgsT1, T2, T3, T4 class.
Public method | EventArgsT1, T2, T3, T4(T1, T2, T3, T4) | Initializes a new instance of the EventArgsT1, T2, T3 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Argument1 | Gets or sets the first data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Public field | Argument2 | Gets or sets the second data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Public field | Argument3 | Gets or sets the third data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Public field | Argument4 | Gets or sets the fourth data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Top
See Also

Reference

GSF Namespace


EventArgs(T1, T2, T3, T4) Constructor

Grid Solutions Framework EventArgsT1, T2, T3, T4 Constructor
Overload List
 | Name | Description
Public method | EventArgsT1, T2, T3, T4 | Initializes a new instance of the EventArgsT1, T2, T3, T4 class.
Public method | EventArgsT1, T2, T3, T4(T1, T2, T3, T4) | Initializes a new instance of the EventArgsT1, T2, T3 class.
Top
See Also

Reference

EventArgsT1, T2, T3, T4 Class
GSF Namespace


EventArgs(T1, T2, T3, T4) Constructor

Grid Solutions Framework EventArgsT1, T2, T3, T4 Constructor
Initializes a new instance of the EventArgsT1, T2, T3, T4 class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs()
Public Sub New
new : unit -> EventArgs
GSF.EventArgs = function();
public:
EventArgs()
See Also

Reference

EventArgsT1, T2, T3, T4 Class
EventArgsT1, T2, T3, T4 Overload
GSF Namespace


EventArgs(T1, T2, T3, T4) Constructor (T1, T2, T3, T4)

Grid Solutions Framework EventArgsT1, T2, T3, T4 Constructor (T1, T2, T3, T4)
Initializes a new instance of the EventArgsT1, T2, T3 class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs(
    T1 argument1,
    T2 argument2,
    T3 argument3,
    T4 argument4
)
Public Sub New (
    argument1 As T1,
    argument2 As T2,
    argument3 As T3,
    argument4 As T4
)
new :
        argument1 : 'T1 *
        argument2 : 'T2 *
        argument3 : 'T3 *
        argument4 : 'T4 -> EventArgs
GSF.EventArgs = function(argument1, argument2, argument3, argument4);
public:
EventArgs(
    T1 argument1,
    T2 argument2,
    T3 argument3,
    T4 argument4
)

Parameters

argument1
Type: T1
The first data argument for the event.
argument2
Type: T2
The second data argument for the event.
argument3
Type: T3
The third data argument for the event.
argument4
Type: T4
The fourth data argument for the event.
See Also

Reference

EventArgsT1, T2, T3, T4 Class
EventArgsT1, T2, T3, T4 Overload
GSF Namespace


EventArgs(T1, T2, T3, T4) Fields

Grid Solutions Framework EventArgsT1, T2, T3, T4 Fields

The EventArgsT1, T2, T3, T4 generic type exposes the following members.

Fields
 | Name | Description
Public field | Argument1 | Gets or sets the first data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Public field | Argument2 | Gets or sets the second data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Public field | Argument3 | Gets or sets the third data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Public field | Argument4 | Gets or sets the fourth data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.
Top
See Also

Reference

EventArgsT1, T2, T3, T4 Class
GSF Namespace


EventArgs(T1, T2, T3, T4).Argument1 Field

Grid Solutions Framework EventArgsT1, T2, T3, T4Argument1 Field
Gets or sets the first data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T1 Argument1
Public Argument1 As T1
val mutable Argument1: 'T1
var Argument1
public:
T1 Argument1

Field Value

Type: T1
See Also

Reference

EventArgsT1, T2, T3, T4 Class
GSF Namespace


EventArgs(T1, T2, T3, T4).Argument2 Field

Grid Solutions Framework EventArgsT1, T2, T3, T4Argument2 Field
Gets or sets the second data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T2 Argument2
Public Argument2 As T2
val mutable Argument2: 'T2
var Argument2
public:
T2 Argument2

Field Value

Type: T2
See Also

Reference

EventArgsT1, T2, T3, T4 Class
GSF Namespace


EventArgs(T1, T2, T3, T4).Argument3 Field

Grid Solutions Framework EventArgsT1, T2, T3, T4Argument3 Field
Gets or sets the third data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T3 Argument3
Public Argument3 As T3
val mutable Argument3: 'T3
var Argument3
public:
T3 Argument3

Field Value

Type: T3
See Also

Reference

EventArgsT1, T2, T3, T4 Class
GSF Namespace


EventArgs(T1, T2, T3, T4).Argument4 Field

Grid Solutions Framework EventArgsT1, T2, T3, T4Argument4 Field
Gets or sets the fourth data argument for the event using EventArgsT1, T2, T3, T4 for its EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T4 Argument4
Public Argument4 As T4
val mutable Argument4: 'T4
var Argument4
public:
T4 Argument4

Field Value

Type: T4
See Also

Reference

EventArgsT1, T2, T3, T4 Class
GSF Namespace


EventArgs(T1, T2, T3, T4) Methods

Grid Solutions Framework EventArgsT1, T2, T3, T4 Methods

The EventArgsT1, T2, T3, T4 generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventArgsT1, T2, T3, T4 Class
GSF Namespace


FastObjectFactory Class

Grid Solutions Framework FastObjectFactory Class
Quickly creates new objects based on specified type.
Inheritance Hierarchy
SystemObject
GSFFastObjectFactory

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class FastObjectFactory
Public NotInheritable Class FastObjectFactory
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FastObjectFactory =  class end
GSF.FastObjectFactory = function();

Type.createClass(
    'GSF.FastObjectFactory');
public ref class FastObjectFactory abstract sealed
Methods
Name | Description
GetCreateObjectFunction(Type) | Gets delegate that creates new instance of the type.
GetCreateObjectFunctionT(Type) | Gets delegate of specified return type that creates new instance of the type.
Top
Remarks
FastObjectFactory should be used when you only have the Type of an object available (such as when you are using reflection), otherwise you should use the generic FastObjectFactoryT.
See Also

Reference

GSF Namespace


FastObjectFactory Methods

Grid Solutions Framework FastObjectFactory Methods
Methods
Name | Description
GetCreateObjectFunction(Type) | Gets delegate that creates new instance of the type.
GetCreateObjectFunctionT(Type) | Gets delegate of specified return type that creates new instance of the type.
Top
See Also

Reference

FastObjectFactory Class
GSF Namespace


FastObjectFactory.GetCreateObjectFunction Method

Grid Solutions Framework FastObjectFactoryGetCreateObjectFunction Method
Overload List
Name | Description
GetCreateObjectFunction(Type) | Gets delegate that creates new instance of the type.
GetCreateObjectFunctionT(Type) | Gets delegate of specified return type that creates new instance of the type.
Top
See Also

Reference

FastObjectFactory Class
GSF Namespace


FastObjectFactory.GetCreateObjectFunction Method (Type)

Grid Solutions Framework FastObjectFactoryGetCreateObjectFunction Method (Type)
Gets delegate that creates new instance of the type.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Func<Object> GetCreateObjectFunction(
    Type type
)
Public Shared Function GetCreateObjectFunction (
    type As Type
) As Func(Of Object)
static member GetCreateObjectFunction :
        type : Type -> Func<Object>

GSF.FastObjectFactory.GetCreateObjectFunction = function(type);
public:
static Func<Object^>^ GetCreateObjectFunction(
    Type^ type
)

Parameters

type
Type: SystemType
Type of object to create quickly.

Return Value

Type: Func Object
Delegate to use to quickly create new objects.
Exceptions
Exception | Condition
InvalidOperationException | type does not support parameterless public constructor.
See Also

Reference

FastObjectFactory Class
GetCreateObjectFunction Overload
GSF Namespace


FastObjectFactory.GetCreateObjectFunction(T) Method (Type)

Grid Solutions Framework FastObjectFactoryGetCreateObjectFunctionT Method (Type)
Gets delegate of specified return type that creates new instance of the type.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Func<T> GetCreateObjectFunction<T>(
    Type type
)

Public Shared Function GetCreateObjectFunction(Of T) (
    type As Type
) As Func(Of T)
static member GetCreateObjectFunction :
        type : Type -> Func<'T>

JavaScript does not support generic types or methods.
public:
generic<typename T>
static Func<T>^ GetCreateObjectFunction(
    Type^ type
)

Parameters

type
Type: SystemType
Type of object to create quickly.

Type Parameters

T
Type of returned object function used to create objects quickly.

Return Value

Type: Func T
Delegate to use to quickly create new objects.
Exceptions
Exception | Condition
InvalidOperationException | type does not support parameterless public constructor -or- type is not a subclass or interface implementation of function type definition.
Remarks
This function will validate that T is related to type.
See Also

Reference

FastObjectFactory Class
GetCreateObjectFunction Overload
GSF Namespace


FastObjectFactory(T) Class

Grid Solutions Framework FastObjectFactoryT Class
Quickly creates new objects based on specified type.
Inheritance Hierarchy
SystemObject
GSFFastObjectFactoryT

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class FastObjectFactory<T>
where T : class, new()

Public NotInheritable Class FastObjectFactory(Of T As {Class, New})
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FastObjectFactory<'T when 'T : not struct, new()> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
where T : ref class, gcnew()
public ref class FastObjectFactory abstract sealed

Type Parameters

T
Type of object to create quickly.

The FastObjectFactoryT type exposes the following members.

Properties
Name | Description
CreateObjectFunction | Gets delegate that quickly creates new instance of the specified type.
Top
Remarks
You can use the alternate FastObjectFactory implementation if you only have the Type of an object available (such as when you are using reflection).
See Also

Reference

GSF Namespace


FastObjectFactory(T) Properties

Grid Solutions Framework FastObjectFactoryT Properties

The FastObjectFactoryT generic type exposes the following members.

Properties
Name | Description
CreateObjectFunction | Gets delegate that quickly creates new instance of the specified type.
Top
See Also

Reference

FastObjectFactoryT Class
GSF Namespace


FastObjectFactory(T).CreateObjectFunction Property

Grid Solutions Framework FastObjectFactoryTCreateObjectFunction Property
Gets delegate that quickly creates new instance of the specified type.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Func<T> CreateObjectFunction { get; }
Public Shared ReadOnly Property CreateObjectFunction As Func(Of T)
    Get
static member CreateObjectFunction : Func<'T> with get

GSF.FastObjectFactory.get_CreateObjectFunction = function();

public:
static property Func<T>^ CreateObjectFunction {
    Func<T>^ get ();
}

Property Value

Type: Func T
See Also

Reference

FastObjectFactoryT Class
GSF Namespace


GuidExtensions Class

Grid Solutions Framework GuidExtensions Class
Extension methods for Guid.
Inheritance Hierarchy
SystemObject
GSFGuidExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class GuidExtensions
<ExtensionAttribute>
Public NotInheritable Class GuidExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GuidExtensions =  class end
GSF.GuidExtensions = function();

Type.createClass(
    'GSF.GuidExtensions');
[ExtensionAttribute]
public ref class GuidExtensions abstract sealed

The GuidExtensions type exposes the following members.

Methods
Name | Description
__ToBigEndianOrderBytes(Guid) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderBytes(Guid, Byte, Int32) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderGuid(Byte) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderGuid(Byte, Int32) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
CopyLittleEndianBytes(Guid, Byte*) | Writes a Guid in Little Endian byte order.
CopyLittleEndianBytes(Guid, Byte, Int32) | Writes a Guid in Little Endian byte order.
ToLittleEndianBytes | Gets the little endian encoded bytes.
ToLittleEndianGuid(Byte*) | Reads a Guid in Little Endian byte order.
ToLittleEndianGuid(Byte) | Reads a Guid in Little Endian byte order.
ToLittleEndianGuid(Byte, Int32) | Mimicks the encoding that was present in LittleEndianOrder on a Little Endian CPU.
ToRfcBytes(Guid) | Encodes a Guid following RFC 4122.
ToRfcBytes(Guid, Byte*) | Encodes a Guid following RFC 4122.
ToRfcBytes(Guid, Byte, Int32) | Encodes a Guid following RFC 4122.
ToRfcGuid(Byte*) | Decodes a Guid following RFC 4122
ToRfcGuid(Byte) | Decodes a Guid following RFC 4122
ToRfcGuid(Byte, Int32) | Decodes a Guid following RFC 4122
Top
See Also

Reference

GSF Namespace


GuidExtensions Methods

Grid Solutions Framework GuidExtensions Methods

The GuidExtensions type exposes the following members.

Methods
Name | Description
__ToBigEndianOrderBytes(Guid) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderBytes(Guid, Byte, Int32) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderGuid(Byte) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderGuid(Byte, Int32) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
CopyLittleEndianBytes(Guid, Byte*) | Writes a Guid in Little Endian byte order.
CopyLittleEndianBytes(Guid, Byte, Int32) | Writes a Guid in Little Endian byte order.
ToLittleEndianBytes | Gets the little endian encoded bytes.
ToLittleEndianGuid(Byte*) | Reads a Guid in Little Endian byte order.
ToLittleEndianGuid(Byte) | Reads a Guid in Little Endian byte order.
ToLittleEndianGuid(Byte, Int32) | Mimicks the encoding that was present in LittleEndianOrder on a Little Endian CPU.
ToRfcBytes(Guid) | Encodes a Guid following RFC 4122.
ToRfcBytes(Guid, Byte*) | Encodes a Guid following RFC 4122.
ToRfcBytes(Guid, Byte, Int32) | Encodes a Guid following RFC 4122.
ToRfcGuid(Byte*) | Decodes a Guid following RFC 4122
ToRfcGuid(Byte) | Decodes a Guid following RFC 4122
ToRfcGuid(Byte, Int32) | Decodes a Guid following RFC 4122
Top
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.__ToBigEndianOrderBytes Method

Grid Solutions Framework GuidExtensions__ToBigEndianOrderBytes Method
Overload List
Name | Description
__ToBigEndianOrderBytes(Guid) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderBytes(Guid, Byte, Int32) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
Top
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.__ToBigEndianOrderBytes Method (Guid)

Grid Solutions Framework GuidExtensions__ToBigEndianOrderBytes Method (Guid)

Note: This API is now obsolete.

Mimicks the encoding that was present in BigEndianOrder.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)]
public static byte[] __ToBigEndianOrderBytes(
    Guid guid
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)>
Public Shared Function __ToBigEndianOrderBytes (
    guid As Guid
) As Byte()
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)>]
static member __ToBigEndianOrderBytes :
        guid : Guid -> byte[]

GSF.GuidExtensions.__ToBigEndianOrderBytes = function(guid);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[ObsoleteAttribute(L"This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)]
static array<unsigned char>^ __ToBigEndianOrderBytes(
    Guid guid
)

Parameters

guid
Type: SystemGuid
the Guid to serialize

Return Value

Type: Byte
A Byte[] that represents a big endian encoded Guid.
See Also

Reference

GuidExtensions Class
__ToBigEndianOrderBytes Overload
GSF Namespace


GuidExtensions.__ToBigEndianOrderBytes Method (Guid, Byte[], Int32)

Grid Solutions Framework GuidExtensions__ToBigEndianOrderBytes Method (Guid, Byte, Int32)

Note: This API is now obsolete.

Mimicks the encoding that was present in BigEndianOrder.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)]
public static int __ToBigEndianOrderBytes(
    Guid guid,
    byte[] buffer,
    int startingIndex
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)>
Public Shared Function __ToBigEndianOrderBytes (
    guid As Guid,
    buffer As Byte(),
    startingIndex As Integer
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)>]
static member __ToBigEndianOrderBytes :
        guid : Guid *
        buffer : byte[] *
        startingIndex : int -> int

GSF.GuidExtensions.__ToBigEndianOrderBytes = function(guid, buffer, startingIndex);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[ObsoleteAttribute(L"This method is for backwards compatibility only. Use ToRfcBytes from now on.",
    false)]
static int __ToBigEndianOrderBytes(
    Guid guid,
    array<unsigned char>^ buffer,
    int startingIndex
)

Parameters

guid
Type: SystemGuid
the Guid to serialize
buffer
Type: SystemByte
where to store the guid
startingIndex
Type: SystemInt32
the starting index in buffer

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.GuidExtensions.__ToBigEndianOrderBytes(System.Guid,System.Byte[],System.Int32)"]

See Also

Reference

GuidExtensions Class
__ToBigEndianOrderBytes Overload
GSF Namespace


GuidExtensions.__ToBigEndianOrderGuid Method

Grid Solutions Framework GuidExtensions__ToBigEndianOrderGuid Method
Overload List
Name | Description
__ToBigEndianOrderGuid(Byte) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
__ToBigEndianOrderGuid(Byte, Int32) | Obsolete. Mimicks the encoding that was present in BigEndianOrder.
Top
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.__ToBigEndianOrderGuid Method (Byte[])

Grid Solutions Framework GuidExtensions__ToBigEndianOrderGuid Method (Byte)

Note: This API is now obsolete.

Mimicks the encoding that was present in BigEndianOrder.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public static Guid __ToBigEndianOrderGuid(
    byte[] buffer
)
<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Shared Function __ToBigEndianOrderGuid (
    buffer As Byte()
) As Guid
[<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
static member __ToBigEndianOrderGuid :
        buffer : byte[] -> Guid

GSF.GuidExtensions.__ToBigEndianOrderGuid = function(buffer);
public:
[ObsoleteAttribute(L"This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
static Guid __ToBigEndianOrderGuid(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
where to read the Guid.

Return Value

Type: Guid

[Missing <returns> documentation for "M:GSF.GuidExtensions.__ToBigEndianOrderGuid(System.Byte[])"]

See Also

Reference

GuidExtensions Class
__ToBigEndianOrderGuid Overload
GSF Namespace


GuidExtensions.__ToBigEndianOrderGuid Method (Byte[], Int32)

Grid Solutions Framework GuidExtensions__ToBigEndianOrderGuid Method (Byte, Int32)

Note: This API is now obsolete.

Mimicks the encoding that was present in BigEndianOrder.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)]
public static Guid __ToBigEndianOrderGuid(
    byte[] buffer,
    int startingIndex
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)>
Public Shared Function __ToBigEndianOrderGuid (
    buffer As Byte(),
    startingIndex As Integer
) As Guid
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<ObsoleteAttribute("This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)>]
static member __ToBigEndianOrderGuid :
        buffer : byte[] *
        startingIndex : int -> Guid

GSF.GuidExtensions.__ToBigEndianOrderGuid = function(buffer, startingIndex);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[ObsoleteAttribute(L"This method is for backwards compatibility only. Use ToRfcGuid from now on.",
    false)]
static Guid __ToBigEndianOrderGuid(
    array<unsigned char>^ buffer,
    int startingIndex
)

Parameters

buffer
Type: SystemByte
where to read the Guid.
startingIndex
Type: SystemInt32
the starting index in buffer

Return Value

Type: Guid

[Missing <returns> documentation for "M:GSF.GuidExtensions.__ToBigEndianOrderGuid(System.Byte[],System.Int32)"]

See Also

Reference

GuidExtensions Class
__ToBigEndianOrderGuid Overload
GSF Namespace


GuidExtensions.CopyLittleEndianBytes Method

Grid Solutions Framework GuidExtensionsCopyLittleEndianBytes Method
Overload List
Name | Description
CopyLittleEndianBytes(Guid, Byte*) | Writes a Guid in Little Endian byte order.
CopyLittleEndianBytes(Guid, Byte, Int32) | Writes a Guid in Little Endian byte order.
Top
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.CopyLittleEndianBytes Method (Guid, Byte*)

Grid Solutions Framework GuidExtensionsCopyLittleEndianBytes Method (Guid, Byte)
Writes a Guid in Little Endian byte order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyLittleEndianBytes(
    Guid guid,
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyLittleEndianBytes(
    Guid guid,
    unsigned char* buffer
)

Parameters

guid
Type: SystemGuid
the Guid to serialize
buffer
Type: SystemByte*
where to store the guid

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.GuidExtensions.CopyLittleEndianBytes(System.Guid,System.Byte*)"]

See Also

Reference

GuidExtensions Class
CopyLittleEndianBytes Overload
GSF Namespace


GuidExtensions.CopyLittleEndianBytes Method (Guid, Byte[], Int32)

Grid Solutions Framework GuidExtensionsCopyLittleEndianBytes Method (Guid, Byte, Int32)
Writes a Guid in Little Endian byte order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyLittleEndianBytes(
    Guid guid,
    byte[] buffer,
    int startingIndex
)
Public Shared Function CopyLittleEndianBytes (
    guid As Guid,
    buffer As Byte(),
    startingIndex As Integer
) As Integer
static member CopyLittleEndianBytes :
        guid : Guid *
        buffer : byte[] *
        startingIndex : int -> int

GSF.GuidExtensions.CopyLittleEndianBytes = function(guid, buffer, startingIndex);
public:
static int CopyLittleEndianBytes(
    Guid guid,
    array<unsigned char>^ buffer,
    int startingIndex
)

Parameters

guid
Type: SystemGuid
the Guid to serialize
buffer
Type: SystemByte
where to store the guid
startingIndex
Type: SystemInt32
the starting index in buffer

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.GuidExtensions.CopyLittleEndianBytes(System.Guid,System.Byte[],System.Int32)"]

See Also

Reference

GuidExtensions Class
CopyLittleEndianBytes Overload
GSF Namespace


GuidExtensions.ToLittleEndianBytes Method

Grid Solutions Framework GuidExtensionsToLittleEndianBytes Method
Gets the little endian encoded bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] ToLittleEndianBytes(
    Guid guid
)
Public Shared Function ToLittleEndianBytes (
    guid As Guid
) As Byte()
static member ToLittleEndianBytes :
        guid : Guid -> byte[]

GSF.GuidExtensions.ToLittleEndianBytes = function(guid);
public:
static array<unsigned char>^ ToLittleEndianBytes(
    Guid guid
)

Parameters

guid
Type: SystemGuid
the Guid to serialize

Return Value

Type: Byte
A Byte[] that represents a big endian encoded Guid.
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.ToLittleEndianGuid Method

Grid Solutions Framework GuidExtensionsToLittleEndianGuid Method
Overload List
Name | Description
ToLittleEndianGuid(Byte*) | Reads a Guid in Little Endian byte order.
ToLittleEndianGuid(Byte) | Reads a Guid in Little Endian byte order.
ToLittleEndianGuid(Byte, Int32) | Mimicks the encoding that was present in LittleEndianOrder on a Little Endian CPU.
Top
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.ToLittleEndianGuid Method (Byte*)

Grid Solutions Framework GuidExtensionsToLittleEndianGuid Method (Byte)
Reads a Guid in Little Endian byte order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ToLittleEndianGuid(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static Guid ToLittleEndianGuid(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
where to read the Guid.

Return Value

Type: Guid

[Missing <returns> documentation for "M:GSF.GuidExtensions.ToLittleEndianGuid(System.Byte*)"]

See Also

Reference

GuidExtensions Class
ToLittleEndianGuid Overload
GSF Namespace


GuidExtensions.ToLittleEndianGuid Method (Byte[])

Grid Solutions Framework GuidExtensionsToLittleEndianGuid Method (Byte)
Reads a Guid in Little Endian byte order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ToLittleEndianGuid(
    byte[] buffer
)
Public Shared Function ToLittleEndianGuid (
    buffer As Byte()
) As Guid
static member ToLittleEndianGuid :
        buffer : byte[] -> Guid

GSF.GuidExtensions.ToLittleEndianGuid = function(buffer);
public:
static Guid ToLittleEndianGuid(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
where to read the Guid.

Return Value

Type: Guid

[Missing <returns> documentation for "M:GSF.GuidExtensions.ToLittleEndianGuid(System.Byte[])"]

See Also

Reference

GuidExtensions Class
ToLittleEndianGuid Overload
GSF Namespace


GuidExtensions.ToLittleEndianGuid Method (Byte[], Int32)

Grid Solutions Framework GuidExtensionsToLittleEndianGuid Method (Byte, Int32)
Mimicks the encoding that was present in LittleEndianOrder on a Little Endian CPU.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ToLittleEndianGuid(
    byte[] buffer,
    int startingIndex
)
Public Shared Function ToLittleEndianGuid (
    buffer As Byte(),
    startingIndex As Integer
) As Guid
static member ToLittleEndianGuid :
        buffer : byte[] *
        startingIndex : int -> Guid

GSF.GuidExtensions.ToLittleEndianGuid = function(buffer, startingIndex);
public:
static Guid ToLittleEndianGuid(
    array<unsigned char>^ buffer,
    int startingIndex
)

Parameters

buffer
Type: SystemByte
where to read the Guid.
startingIndex
Type: SystemInt32
the starting index in buffer

Return Value

Type: Guid

[Missing <returns> documentation for "M:GSF.GuidExtensions.ToLittleEndianGuid(System.Byte[],System.Int32)"]

See Also

Reference

GuidExtensions Class
ToLittleEndianGuid Overload
GSF Namespace


GuidExtensions.ToRfcBytes Method

Grid Solutions Framework GuidExtensionsToRfcBytes Method
Overload List
Name | Description
ToRfcBytes(Guid) | Encodes a Guid following RFC 4122.
ToRfcBytes(Guid, Byte*) | Encodes a Guid following RFC 4122.
ToRfcBytes(Guid, Byte, Int32) | Encodes a Guid following RFC 4122.
Top
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.ToRfcBytes Method (Guid)

Grid Solutions Framework GuidExtensionsToRfcBytes Method (Guid)
Encodes a Guid following RFC 4122.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] ToRfcBytes(
    this Guid guid
)
<ExtensionAttribute>
Public Shared Function ToRfcBytes (
    guid As Guid
) As Byte()
static member ToRfcBytes :
        guid : Guid -> byte[]

GSF.GuidExtensions.ToRfcBytes = function(guid);
public:
[ExtensionAttribute]
static array<unsigned char>^ ToRfcBytes(
    Guid guid
)

Parameters

guid
Type: SystemGuid
Guid to serialize.

Return Value

Type: Byte
A Byte array that represents a big-endian encoded Guid.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Guid. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GuidExtensions Class
ToRfcBytes Overload
GSF Namespace


GuidExtensions.ToRfcBytes Method (Guid, Byte*)

Grid Solutions Framework GuidExtensionsToRfcBytes Method (Guid, Byte)
Encodes a Guid following RFC 4122.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToRfcBytes(
    this Guid guid,
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
[ExtensionAttribute]
static int ToRfcBytes(
    Guid guid,
    unsigned char* buffer
)

Parameters

guid
Type: SystemGuid
The Guid to serialize.
buffer
Type: SystemByte*
Destination buffer to hold serialized guid.

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.GuidExtensions.ToRfcBytes(System.Guid,System.Byte*)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Guid. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GuidExtensions Class
ToRfcBytes Overload
GSF Namespace


GuidExtensions.ToRfcBytes Method (Guid, Byte[], Int32)

Grid Solutions Framework GuidExtensionsToRfcBytes Method (Guid, Byte, Int32)
Encodes a Guid following RFC 4122.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToRfcBytes(
    this Guid guid,
    byte[] buffer,
    int startingIndex
)
<ExtensionAttribute>
Public Shared Function ToRfcBytes (
    guid As Guid,
    buffer As Byte(),
    startingIndex As Integer
) As Integer
static member ToRfcBytes :
        guid : Guid *
        buffer : byte[] *
        startingIndex : int -> int

GSF.GuidExtensions.ToRfcBytes = function(guid, buffer, startingIndex);
public:
[ExtensionAttribute]
static int ToRfcBytes(
    Guid guid,
    array<unsigned char>^ buffer,
    int startingIndex
)

Parameters

guid
Type: SystemGuid
The Guid to serialize.
buffer
Type: SystemByte
Destination buffer to hold serialized guid.
startingIndex
Type: SystemInt32
Starting index in buffer.

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.GuidExtensions.ToRfcBytes(System.Guid,System.Byte[],System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Guid. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GuidExtensions Class
ToRfcBytes Overload
GSF Namespace


GuidExtensions.ToRfcGuid Method

Grid Solutions Framework GuidExtensionsToRfcGuid Method
Overload List
Name | Description
ToRfcGuid(Byte*) | Decodes a Guid following RFC 4122
ToRfcGuid(Byte) | Decodes a Guid following RFC 4122
ToRfcGuid(Byte, Int32) | Decodes a Guid following RFC 4122
Top
See Also

Reference

GuidExtensions Class
GSF Namespace


GuidExtensions.ToRfcGuid Method (Byte*)

Grid Solutions Framework GuidExtensionsToRfcGuid Method (Byte)
Decodes a Guid following RFC 4122

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ToRfcGuid(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static Guid ToRfcGuid(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
Buffer containing a serialized big-endian encoded Guid.

Return Value

Type: Guid
Guid deserialized from buffer.
See Also

Reference

GuidExtensions Class
ToRfcGuid Overload
GSF Namespace


GuidExtensions.ToRfcGuid Method (Byte[])

Grid Solutions Framework GuidExtensionsToRfcGuid Method (Byte)
Decodes a Guid following RFC 4122

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ToRfcGuid(
    this byte[] buffer
)
<ExtensionAttribute>
Public Shared Function ToRfcGuid (
    buffer As Byte()
) As Guid
static member ToRfcGuid :
        buffer : byte[] -> Guid

GSF.GuidExtensions.ToRfcGuid = function(buffer);
public:
[ExtensionAttribute]
static Guid ToRfcGuid(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
Buffer containing a serialized big-endian encoded Guid.

Return Value

Type: Guid
Guid deserialized from buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GuidExtensions Class
ToRfcGuid Overload
GSF Namespace


GuidExtensions.ToRfcGuid Method (Byte[], Int32)

Grid Solutions Framework GuidExtensionsToRfcGuid Method (Byte, Int32)
Decodes a Guid following RFC 4122

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ToRfcGuid(
    this byte[] buffer,
    int startingIndex
)
<ExtensionAttribute>
Public Shared Function ToRfcGuid (
    buffer As Byte(),
    startingIndex As Integer
) As Guid
static member ToRfcGuid :
        buffer : byte[] *
        startingIndex : int -> Guid

GSF.GuidExtensions.ToRfcGuid = function(buffer, startingIndex);
public:
[ExtensionAttribute]
static Guid ToRfcGuid(
    array<unsigned char>^ buffer,
    int startingIndex
)

Parameters

buffer
Type: SystemByte
Buffer containing a serialized big-endian encoded Guid.
startingIndex
Type: SystemInt32
Starting index in buffer.

Return Value

Type: Guid
Guid deserialized from buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

GuidExtensions Class
ToRfcGuid Overload
GSF Namespace


IdentifiableItem(TId, TItem) Class

Grid Solutions Framework IdentifiableItemTId, TItem Class
Represents an identifiable item.
Inheritance Hierarchy
SystemObject
GSFIdentifiableItemTId, TItem

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IdentifiableItem<TId, TItem>

Public Class IdentifiableItem(Of TId, TItem)
type IdentifiableItem<'TId, 'TItem> =  class end
JavaScript does not support generic types or methods.
generic<typename TId, typename TItem>
public ref class IdentifiableItem

Type Parameters

TId
Type of the identifier to be used for identification.
TItem
Type of the item that is to be made identifiable.

The IdentifiableItemTId, TItem type exposes the following members.

Constructors
 | Name | Description
Public method | IdentifiableItemTId, TItem | Initializes a new instance of the IdentifiableItemTId, TItem class.
Public method | IdentifiableItemTId, TItem(TId, TItem) | Initializes a new instance of the IdentifiableItemTId, TItem class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | ID | Defines the identifier of the Item.
Public field | Item | Defines the buffer being made identifiable by its associated ID.
Top
See Also

Reference

GSF Namespace


IdentifiableItem(TId, TItem) Constructor

Grid Solutions Framework IdentifiableItemTId, TItem Constructor
Overload List
 | Name | Description
Public method | IdentifiableItemTId, TItem | Initializes a new instance of the IdentifiableItemTId, TItem class.
Public method | IdentifiableItemTId, TItem(TId, TItem) | Initializes a new instance of the IdentifiableItemTId, TItem class.
Top
See Also

Reference

IdentifiableItemTId, TItem Class
GSF Namespace


IdentifiableItem(TId, TItem) Constructor

Grid Solutions Framework IdentifiableItemTId, TItem Constructor
Initializes a new instance of the IdentifiableItemTId, TItem class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IdentifiableItem()
Public Sub New
new : unit -> IdentifiableItem
GSF.IdentifiableItem = function();
public:
IdentifiableItem()
See Also

Reference

IdentifiableItemTId, TItem Class
IdentifiableItemTId, TItem Overload
GSF Namespace


IdentifiableItem(TId, TItem) Constructor (TId, TItem)

Grid Solutions Framework IdentifiableItemTId, TItem Constructor (TId, TItem)
Initializes a new instance of the IdentifiableItemTId, TItem class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IdentifiableItem(
    TId id,
    TItem item
)
Public Sub New (
    id As TId,
    item As TItem
)
new :
        id : 'TId *
        item : 'TItem -> IdentifiableItem
GSF.IdentifiableItem = function(id, item);
public:
IdentifiableItem(
    TId id,
    TItem item
)

Parameters

id
Type: TId
The identifier of the item.
item
Type: TItem
The item being associated with the id to make it identifiable.
See Also

Reference

IdentifiableItemTId, TItem Class
IdentifiableItemTId, TItem Overload
GSF Namespace


IdentifiableItem(TId, TItem) Fields

Grid Solutions Framework IdentifiableItemTId, TItem Fields

The IdentifiableItemTId, TItem generic type exposes the following members.

Fields
 | Name | Description
Public field | ID | Defines the identifier of the Item.
Public field | Item | Defines the buffer being made identifiable by its associated ID.
Top
See Also

Reference

IdentifiableItemTId, TItem Class
GSF Namespace


IdentifiableItem(TId, TItem).ID Field

Grid Solutions Framework IdentifiableItemTId, TItemID Field
Defines the identifier of the Item.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TId ID
Public ID As TId
val mutable ID: 'TId
var ID
public:
TId ID

Field Value

Type: TId
See Also

Reference

IdentifiableItemTId, TItem Class
GSF Namespace


IdentifiableItem(TId, TItem).Item Field

Grid Solutions Framework IdentifiableItemTId, TItemItem Field
Defines the buffer being made identifiable by its associated ID.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TItem Item
Public Item As TItem
val mutable Item: 'TItem
var Item
public:
TItem Item

Field Value

Type: TItem
See Also

Reference

IdentifiableItemTId, TItem Class
GSF Namespace


IdentifiableItem(TId, TItem) Methods

Grid Solutions Framework IdentifiableItemTId, TItem Methods

The IdentifiableItemTId, TItem generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IdentifiableItemTId, TItem Class
GSF Namespace


InitializationException Class

Grid Solutions Framework InitializationException Class
The exception that is thrown when an object fails to initialize properly.
Inheritance Hierarchy
SystemObject
SystemException
GSFInitializationException

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class InitializationException : Exception
<SerializableAttribute>
Public Class InitializationException
    Inherits Exception
[<SerializableAttribute>]
type InitializationException =
    class
        inherit Exception
    end
GSF.InitializationException = function();

Type.createClass(
    'GSF.InitializationException',
    Exception);
[SerializableAttribute]
public ref class InitializationException : public Exception

The InitializationException type exposes the following members.

Constructors
 | Name | Description
Public method | InitializationException | Initializes a new instance of the InitializationException class.
Public method | InitializationException(String) | Initializes a new instance of the InitializationException class.
Public method | InitializationException(String, Exception) | Initializes a new instance of the InitializationException class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF Namespace


InitializationException Constructor

Grid Solutions Framework InitializationException Constructor
Overload List
 | Name | Description
Public method | InitializationException | Initializes a new instance of the InitializationException class.
Public method | InitializationException(String) | Initializes a new instance of the InitializationException class.
Public method | InitializationException(String, Exception) | Initializes a new instance of the InitializationException class.
Top
See Also

Reference

InitializationException Class
GSF Namespace


InitializationException Constructor

Grid Solutions Framework InitializationException Constructor
Initializes a new instance of the InitializationException class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InitializationException()
Public Sub New
new : unit -> InitializationException
GSF.InitializationException = function();
public:
InitializationException()
See Also

Reference

InitializationException Class
InitializationException Overload
GSF Namespace


InitializationException Constructor (String)

Grid Solutions Framework InitializationException Constructor (String)
Initializes a new instance of the InitializationException class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InitializationException(
    string message
)
Public Sub New (
    message As String
)
new :
        message : string -> InitializationException
GSF.InitializationException = function(message);
public:
InitializationException(
    String^ message
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

InitializationException Class
InitializationException Overload
GSF Namespace


InitializationException Constructor (String, Exception)

Grid Solutions Framework InitializationException Constructor (String, Exception)
Initializes a new instance of the InitializationException class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InitializationException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
new :
        message : string *
        innerException : Exception -> InitializationException
GSF.InitializationException = function(message, innerException);
public:
InitializationException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: SystemString
The message that describes the error.
innerException
Type: SystemException
The exception that is the cause of the current exception.
See Also

Reference

InitializationException Class
InitializationException Overload
GSF Namespace


InitializationException Methods

Grid Solutions Framework InitializationException Methods

The InitializationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

InitializationException Class
GSF Namespace


InitializationException Properties

Grid Solutions Framework InitializationException Properties

The InitializationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

InitializationException Class
GSF Namespace


InitializationException Events

Grid Solutions Framework InitializationException Events

The InitializationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

InitializationException Class
GSF Namespace


Int24 Structure

Grid Solutions Framework Int24 Structure
Represents a 3-byte, 24-bit signed integer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Int24 : IComparable, IFormattable,
    IConvertible, IComparable<Int24>, IComparable<int>, IEquatable<Int24>,
    IEquatable<int>
<SerializableAttribute>
Public Structure Int24
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Int24),
    IComparable(Of Integer), IEquatable(Of Int24), IEquatable(Of Integer)
[<SealedAttribute>]
[<SerializableAttribute>]
type Int24 =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Int24>
        interface IComparable<int>
        interface IEquatable<Int24>
        interface IEquatable<int>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Int24 : IComparable,
    IFormattable, IConvertible, IComparable<Int24>, IComparable<int>,
    IEquatable<Int24>, IEquatable<int>

The Int24 type exposes the following members.

Constructors
 | Name | Description
Public method | Int24(Int32) | Creates 24-bit signed integer from a 32-bit signed integer.
Public method | Int24(Int24) | Creates 24-bit signed integer from an existing 24-bit signed integer.
Public method | Int24(Byte, Int32) | Creates 24-bit signed integer from three bytes at a specified position in a byte array.
Top
Methods
 | Name | Description
Public method | CompareTo(Int32) | Compares this instance to a specified 32-bit signed integer and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Int24) | Compares this instance to a specified 24-bit signed integer and returns an indication of their relative values.
Public method | Equals(Int32) | Returns a value indicating whether this instance is equal to a specified Int32 value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Int24) | Returns a value indicating whether this instance is equal to a specified Int24 value.
Public method | GetBytes | Returns the Int24 value as an array of three bytes.
 | GetBytes(Int24) | Returns the specified Int24 value as an array of three bytes.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the System.TypeCode for value type System.Int32 (there is no defined type code for an Int24).
 | GetValue | Returns a 24-bit signed integer from three bytes at a specified position in a byte array.
 | Parse(String) | Converts the string representation of a number to its 24-bit signed integer equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its 24-bit signed integer equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its 24-bit signed integer equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Int24) | Converts the string representation of a number to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Int24) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition(Int32, Int24) | Returns computed sum of values.
Addition(Int24, Int24) | Returns computed sum of values.
Addition(Int24, Int32) | Returns computed sum of values.
BitwiseAnd(Int32, Int24) | Returns logical bitwise AND of values.
BitwiseAnd(Int24, Int24) | Returns logical bitwise AND of values.
BitwiseAnd(Int24, Int32) | Returns logical bitwise AND of values.
BitwiseOr(Int32, Int24) | Returns logical bitwise OR of values.
BitwiseOr(Int24, Int24) | Returns logical bitwise OR of values.
BitwiseOr(Int24, Int32) | Returns logical bitwise OR of values.
Decrement | Returns decremented value.
Division(Int32, Int24) | Returns computed division of values.
Division(Int24, Int24) | Returns computed division of values.
Division(Int24, Int32) | Returns computed division of values.
Equality(Int32, Int24) | Compares the two values for equality.
Equality(Int24, Int24) | Compares the two values for equality.
Equality(Int24, Int32) | Compares the two values for equality.
ExclusiveOr(Int32, Int24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(Int24, Int24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(Int24, Int32) | Returns logical bitwise exclusive-OR of values.
(Decimal to Int24) | Explicitly converts value to an Int24.
(Double to Int24) | Explicitly converts value to an Int24.
(Enum to Int24) | Explicitly converts value to an Int24.
(Int32 to Int24) | Explicitly converts value to an Int24.
(Int64 to Int24) | Explicitly converts value to an Int24.
(Single to Int24) | Explicitly converts value to an Int24.
(String to Int24) | Explicitly converts value to an Int24.
(Int24 to Int16) | Explicitly converts Int24 to Int16.
(Int24 to UInt16) | Explicitly converts Int24 to UInt16.
(Int24 to Byte) | Explicitly converts Int24 to Byte.
Exponent(Int32, Int24) | Returns result of first value raised to power of second value.
Exponent(Int24, Int24) | Returns result of first value raised to power of second value.
Exponent(Int24, Int32) | Returns result of first value raised to power of second value.
False | Returns true if value is equal to zero.
GreaterThan(Int32, Int24) | Returns true if left value is greater than right value.
GreaterThan(Int24, Int24) | Returns true if left value is greater than right value.
GreaterThan(Int24, Int32) | Returns true if left value is greater than right value.
GreaterThanOrEqual(Int32, Int24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(Int24, Int24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(Int24, Int32) | Returns true if left value is greater than or equal to right value.
(Byte to Int24) | Implicitly converts value to an Int24.
(Char to Int24) | Implicitly converts value to an Int24.
(Int16 to Int24) | Implicitly converts value to an Int24.
(Int24 to Int32) | Implicitly converts Int24 to Int32.
(Int24 to UInt32) | Implicitly converts Int24 to UInt32.
(Int24 to Int64) | Implicitly converts Int24 to Int64.
(Int24 to UInt64) | Implicitly converts Int24 to UInt64.
(Int24 to Double) | Implicitly converts Int24 to Double.
(Int24 to Single) | Implicitly converts Int24 to Single.
(Int24 to Decimal) | Implicitly converts Int24 to Decimal.
(Int24 to String) | Implicitly converts Int24 to String.
Increment | Returns incremented value.
Inequality(Int32, Int24) | Compares the two values for inequality.
Inequality(Int24, Int24) | Compares the two values for inequality.
Inequality(Int24, Int32) | Compares the two values for inequality.
LeftShift | Returns value after left shifts of first value by the number of bits specified by second value.
LessThan(Int32, Int24) | Returns true if left value is less than right value.
LessThan(Int24, Int24) | Returns true if left value is less than right value.
LessThan(Int24, Int32) | Returns true if left value is less than right value.
LessThanOrEqual(Int32, Int24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(Int24, Int24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(Int24, Int32) | Returns true if left value is less or equal to than right value.
Modulus(Int32, Int24) | Returns computed remainder after dividing first value by the second.
Modulus(Int24, Int24) | Returns computed remainder after dividing first value by the second.
Modulus(Int24, Int32) | Returns computed remainder after dividing first value by the second.
Multiply(Int32, Int24) | Returns computed product of values.
Multiply(Int24, Int24) | Returns computed product of values.
Multiply(Int24, Int32) | Returns computed product of values.
OnesComplement | Returns bitwise complement of value.
RightShift | Returns value after right shifts of first value by the number of bits specified by second value.
Subtraction(Int32, Int24) | Returns computed difference of values.
Subtraction(Int24, Int24) | Returns computed difference of values.
Subtraction(Int24, Int32) | Returns computed difference of values.
True | Returns true if value is not zero.
Top
Extension Methods
 | Name | Description
Public Extension Method | BitRotL | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | BitRotR | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Int24) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Int24, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | ClearBits(Bits) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | ClearBits(Int24) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetMaskedValue(Bits) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | GetMaskedValue(Int24) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | SetBits(Bits) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetBits(Int24) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(Bits, Int24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(Int24, Int24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(Bits) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(Int24) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Top
Fields
Name | Description
BitMask | High byte bit-mask used when a 24-bit integer is stored within a 32-bit integer. This field is constant.
MaxValue | Represents the largest possible value of an Int24. This field is constant.
MinValue | Represents the smallest possible value of an Int24. This field is constant.
Top
Remarks

This class behaves like most other intrinsic signed integers but allows a 3-byte, 24-bit integer implementation that is often found in many digital-signal processing arenas and different kinds of protocol parsing. A signed 24-bit integer is typically used to save storage space on disk where its value range of -8388608 to 8388607 is sufficient, but the signed Int16 value range of -32768 to 32767 is too small.

This structure uses an Int32 internally for storage and most other common expected integer functionality, so using a 24-bit integer will not save memory. However, if the 24-bit signed integer range (-8388608 to 8388607) suits your data needs you can save disk space by only storing the three bytes that this integer actually consumes. You can do this by calling the Int24.GetBytes function to return a three byte binary array that can be serialized to the desired destination and then calling the Int24.GetValue function to restore the Int24 value from those three bytes.

All the standard operators for the Int24 have been fully defined for use with both Int24 and Int32 signed integers; you should find that without the exception Int24 can be compared and numerically calculated with an Int24 or Int32. Necessary casting should be minimal and typical use should be very simple - just as if you are using any other native signed integer.

See Also

Reference

GSF Namespace


Int24 Constructor

Grid Solutions Framework Int24 Constructor
Overload List
 | Name | Description
Public method | Int24(Int32) | Creates 24-bit signed integer from a 32-bit signed integer.
Public method | Int24(Int24) | Creates 24-bit signed integer from an existing 24-bit signed integer.
Public method | Int24(Byte, Int32) | Creates 24-bit signed integer from three bytes at a specified position in a byte array.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24 Constructor (Int32)

Grid Solutions Framework Int24 Constructor (Int32)
Creates 24-bit signed integer from a 32-bit signed integer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Int24(
    int value
)
Public Sub New (
    value As Integer
)
new :
        value : int -> Int24
GSF.Int24 = function(value);
public:
Int24(
    int value
)

Parameters

value
Type: SystemInt32
32-bit signed integer to use as new 24-bit signed integer value.
Exceptions
Exception | Condition
OverflowException | Source values outside 24-bit min/max range will cause an overflow exception.
See Also

Reference

Int24 Structure
Int24 Overload
GSF Namespace


Int24 Constructor (Int24)

Grid Solutions Framework Int24 Constructor (Int24)
Creates 24-bit signed integer from an existing 24-bit signed integer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Int24(
    Int24 value
)
Public Sub New (
    value As Int24
)
new :
        value : Int24 -> Int24
GSF.Int24 = function(value);
public:
Int24(
    Int24 value
)

Parameters

value
Type: GSFInt24
24-but signed integer to create new Int24 from.
See Also

Reference

Int24 Structure
Int24 Overload
GSF Namespace


Int24 Constructor (Byte[], Int32)

Grid Solutions Framework Int24 Constructor (Byte, Int32)
Creates 24-bit signed integer from three bytes at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Int24(
    byte[] value,
    int startIndex
)
Public Sub New (
    value As Byte(),
    startIndex As Integer
)
new :
        value : byte[] *
        startIndex : int -> Int24
GSF.Int24 = function(value, startIndex);
public:
Int24(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes.
startIndex
Type: SystemInt32
The starting position within value.
Exceptions
Exception | Condition
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | startIndex is greater than value length.
ArgumentException | value length from startIndex is too small to represent a UInt24.
Remarks

You can use this constructor in-lieu of a System.BitConverter.ToInt24 function.

Bytes endian order assumed to match that of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

Int24 Structure
Int24 Overload
GSF Namespace


Int24 Fields

Grid Solutions Framework Int24 Fields

The Int24 type exposes the following members.

Fields
Name | Description
BitMask | High byte bit-mask used when a 24-bit integer is stored within a 32-bit integer. This field is constant.
MaxValue | Represents the largest possible value of an Int24. This field is constant.
MinValue | Represents the smallest possible value of an Int24. This field is constant.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.BitMask Field

Grid Solutions Framework Int24BitMask Field
High byte bit-mask used when a 24-bit integer is stored within a 32-bit integer. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int BitMask
Public Const BitMask As Integer
static val mutable BitMask: int
var GSF.Int24.BitMask
public:
literal int BitMask

Field Value

Type: Int32
See Also

Reference

Int24 Structure
GSF Namespace


Int24.MaxValue Field

Grid Solutions Framework Int24MaxValue Field
Represents the largest possible value of an Int24. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Int24 MaxValue
Public Shared ReadOnly MaxValue As Int24
static val MaxValue: Int24
var GSF.Int24.MaxValue
public:
static initonly Int24 MaxValue

Field Value

Type: Int24
See Also

Reference

Int24 Structure
GSF Namespace


Int24.MinValue Field

Grid Solutions Framework Int24MinValue Field
Represents the smallest possible value of an Int24. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Int24 MinValue
Public Shared ReadOnly MinValue As Int24
static val MinValue: Int24
var GSF.Int24.MinValue
public:
static initonly Int24 MinValue

Field Value

Type: Int24
See Also

Reference

Int24 Structure
GSF Namespace


Int24 Methods

Grid Solutions Framework Int24 Methods

The Int24 type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Int32) | Compares this instance to a specified 32-bit signed integer and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Int24) | Compares this instance to a specified 24-bit signed integer and returns an indication of their relative values.
Public method | Equals(Int32) | Returns a value indicating whether this instance is equal to a specified Int32 value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Int24) | Returns a value indicating whether this instance is equal to a specified Int24 value.
Public method | GetBytes | Returns the Int24 value as an array of three bytes.
 | GetBytes(Int24) | Returns the specified Int24 value as an array of three bytes.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the System.TypeCode for value type System.Int32 (there is no defined type code for an Int24).
 | GetValue | Returns a 24-bit signed integer from three bytes at a specified position in a byte array.
 | Parse(String) | Converts the string representation of a number to its 24-bit signed integer equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its 24-bit signed integer equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its 24-bit signed integer equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Int24) | Converts the string representation of a number to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Int24) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | BitRotL | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | BitRotR | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Int24) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Int24, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | ClearBits(Bits) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | ClearBits(Int24) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetMaskedValue(Bits) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | GetMaskedValue(Int24) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | SetBits(Bits) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetBits(Int24) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(Bits, Int24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(Int24, Int24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(Bits) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(Int24) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.CompareTo Method

Grid Solutions Framework Int24CompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Int32) | Compares this instance to a specified 32-bit signed integer and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Int24) | Compares this instance to a specified 24-bit signed integer and returns an indication of their relative values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.CompareTo Method (Int32)

Grid Solutions Framework Int24CompareTo Method (Int32)
Compares this instance to a specified 32-bit signed integer and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    int value
)
Public Function CompareTo (
    value As Integer
) As Integer
abstract CompareTo :
        value : int -> int
override CompareTo :
        value : int -> int
function CompareTo(value);
public:
virtual int CompareTo(
    int value
) sealed

Parameters

value
Type: SystemInt32
An integer to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Int24 Structure
CompareTo Overload
GSF Namespace


Int24.CompareTo Method (Object)

Grid Solutions Framework Int24CompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not an Int32 or Int24.
See Also

Reference

Int24 Structure
CompareTo Overload
GSF Namespace


Int24.CompareTo Method (Int24)

Grid Solutions Framework Int24CompareTo Method (Int24)
Compares this instance to a specified 24-bit signed integer and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Int24 value
)
Public Function CompareTo (
    value As Int24
) As Integer
abstract CompareTo :
        value : Int24 -> int
override CompareTo :
        value : Int24 -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Int24 value
) sealed

Parameters

value
Type: GSFInt24
An integer to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Int24 Structure
CompareTo Overload
GSF Namespace


Int24.Equals Method

Grid Solutions Framework Int24Equals Method
Overload List
 | Name | Description
Public method | Equals(Int32) | Returns a value indicating whether this instance is equal to a specified Int32 value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Int24) | Returns a value indicating whether this instance is equal to a specified Int24 value.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Equals Method (Int32)

Grid Solutions Framework Int24Equals Method (Int32)
Returns a value indicating whether this instance is equal to a specified Int32 value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    int obj
)
Public Function Equals (
    obj As Integer
) As Boolean
abstract Equals :
        obj : int -> bool
override Equals :
        obj : int -> bool
function Equals(obj);
public:
virtual bool Equals(
    int obj
) sealed

Parameters

obj
Type: SystemInt32
An Int32 value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Int24 Structure
Equals Overload
GSF Namespace


Int24.Equals Method (Object)

Grid Solutions Framework Int24Equals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Int32 or Int24 and equals the value of this instance; otherwise, False.
See Also

Reference

Int24 Structure
Equals Overload
GSF Namespace


Int24.Equals Method (Int24)

Grid Solutions Framework Int24Equals Method (Int24)
Returns a value indicating whether this instance is equal to a specified Int24 value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Int24 obj
)
Public Function Equals (
    obj As Int24
) As Boolean
abstract Equals :
        obj : Int24 -> bool
override Equals :
        obj : Int24 -> bool
function Equals(obj);
public:
virtual bool Equals(
    Int24 obj
) sealed

Parameters

obj
Type: GSFInt24
An Int24 value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Int24 Structure
Equals Overload
GSF Namespace


Int24.GetBytes Method

Grid Solutions Framework Int24GetBytes Method
Overload List
 | Name | Description
Public method | GetBytes | Returns the Int24 value as an array of three bytes.
 | GetBytes(Int24) | Returns the specified Int24 value as an array of three bytes.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.GetBytes Method

Grid Solutions Framework Int24GetBytes Method
Returns the Int24 value as an array of three bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes()
Public Function GetBytes As Byte()
member GetBytes : unit -> byte[]

function GetBytes();
public:
array<unsigned char>^ GetBytes()

Return Value

Type: Byte
An array of bytes with length 3.
Remarks

You can use this function in-lieu of a System.BitConverter.GetBytes function.

Bytes will be returned in endian order of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

Int24 Structure
GetBytes Overload
GSF Namespace


Int24.GetBytes Method (Int24)

Grid Solutions Framework Int24GetBytes Method (Int24)
Returns the specified Int24 value as an array of three bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    Int24 value
)
Public Shared Function GetBytes (
    value As Int24
) As Byte()
static member GetBytes :
        value : Int24 -> byte[]

GSF.Int24.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value to convert to bytes.

Return Value

Type: Byte
An array of bytes with length 3.
Remarks

You can use this function in-lieu of a System.BitConverter.GetBytes(Int24) function.

Bytes will be returned in endian order of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

Int24 Structure
GetBytes Overload
GSF Namespace


Int24.GetHashCode Method

Grid Solutions Framework Int24GetHashCode Method
Returns the hash code for this instance.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.GetTypeCode Method

Grid Solutions Framework Int24GetTypeCode Method
Returns the System.TypeCode for value type System.Int32 (there is no defined type code for an Int24).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, System.TypeCode.Int32.

Implements

IConvertibleGetTypeCode
Remarks
There is no defined Int24 type code and since an Int24 will easily fit inside an Int32, the Int32 type code is returned.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.GetValue Method

Grid Solutions Framework Int24GetValue Method
Returns a 24-bit signed integer from three bytes at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 GetValue(
    byte[] value,
    int startIndex
)
Public Shared Function GetValue (
    value As Byte(),
    startIndex As Integer
) As Int24
static member GetValue :
        value : byte[] *
        startIndex : int -> Int24

GSF.Int24.GetValue = function(value, startIndex);
public:
static Int24 GetValue(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes.
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int24
A 24-bit signed integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | startIndex is greater than value length.
ArgumentException | value length from startIndex is too small to represent an Int24.
Remarks

You can use this function in-lieu of a System.BitConverter.ToInt24 function.

Bytes endian order assumed to match that of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

Int24 Structure
GSF Namespace


Int24.Parse Method

Grid Solutions Framework Int24Parse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its 24-bit signed integer equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its 24-bit signed integer equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its 24-bit signed integer equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Parse Method (String)

Grid Solutions Framework Int24Parse Method (String)
Converts the string representation of a number to its 24-bit signed integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Int24
static member Parse :
        s : string -> Int24

GSF.Int24.Parse = function(s);
public:
static Int24 Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Int24
A 24-bit signed integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than Int24.MinValue or greater than Int24.MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Int24 Structure
Parse Overload
GSF Namespace


Int24.Parse Method (String, NumberStyles)

Grid Solutions Framework Int24Parse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its 24-bit signed integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Int24
static member Parse :
        s : string *
        style : NumberStyles -> Int24

GSF.Int24.Parse = function(s, style);
public:
static Int24 Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s. A typical value to specify is System.Globalization.NumberStyles.Integer.

Return Value

Type: Int24
A 24-bit signed integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than Int24.MinValue or greater than Int24.MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Int24 Structure
Parse Overload
GSF Namespace


Int24.Parse Method (String, IFormatProvider)

Grid Solutions Framework Int24Parse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its 24-bit signed integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Int24
static member Parse :
        s : string *
        provider : IFormatProvider -> Int24

GSF.Int24.Parse = function(s, provider);
public:
static Int24 Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Int24
A 24-bit signed integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than Int24.MinValue or greater than Int24.MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Int24 Structure
Parse Overload
GSF Namespace


Int24.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework Int24Parse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Int24
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Int24

GSF.Int24.Parse = function(s, style, provider);
public:
static Int24 Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s. A typical value to specify is System.Globalization.NumberStyles.Integer.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Int24
A 24-bit signed integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than Int24.MinValue or greater than Int24.MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Int24 Structure
Parse Overload
GSF Namespace


Int24.ToString Method

Grid Solutions Framework Int24ToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.ToString Method

Grid Solutions Framework Int24ToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Int24 Structure
ToString Overload
GSF Namespace


Int24.ToString Method (IFormatProvider)

Grid Solutions Framework Int24ToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Int24 Structure
ToString Overload
GSF Namespace


Int24.ToString Method (String)

Grid Solutions Framework Int24ToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Int24 Structure
ToString Overload
GSF Namespace


Int24.ToString Method (String, IFormatProvider)

Grid Solutions Framework Int24ToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Int24 Structure
ToString Overload
GSF Namespace


Int24.TryParse Method

Grid Solutions Framework Int24TryParse Method
Overload List
Name | Description
TryParse(String, Int24) | Converts the string representation of a number to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Int24) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.TryParse Method (String, Int24)

Grid Solutions Framework Int24TryParse Method (String, Int24)
Converts the string representation of a number to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Int24 result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Int24
) As Boolean
static member TryParse :
        s : string *
        result : Int24 byref -> bool

GSF.Int24.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Int24% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSFInt24
When this method returns, contains the 24-bit signed integer value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not of the correct format, or represents a number less than Int24.MinValue or greater than Int24.MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Int24 Structure
TryParse Overload
GSF Namespace


Int24.TryParse Method (String, NumberStyles, IFormatProvider, Int24)

Grid Solutions Framework Int24TryParse Method (String, NumberStyles, IFormatProvider, Int24)
Converts the string representation of a number in a specified style and culture-specific format to its 24-bit signed integer equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Int24 result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Int24
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Int24 byref -> bool

GSF.Int24.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Int24% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s. A typical value to specify is System.Globalization.NumberStyles.Integer.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSFInt24
When this method returns, contains the 24-bit signed integer value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not in a format compliant with style, or represents a number less than Int24.MinValue or greater than Int24.MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Int24 Structure
TryParse Overload
GSF Namespace


Int24 Operators and Type Conversions

Grid Solutions Framework Int24 Operators and Type Conversions

The Int24 type exposes the following members.

Operators
Name | Description
Addition(Int32, Int24) | Returns computed sum of values.
Addition(Int24, Int24) | Returns computed sum of values.
Addition(Int24, Int32) | Returns computed sum of values.
BitwiseAnd(Int32, Int24) | Returns logical bitwise AND of values.
BitwiseAnd(Int24, Int24) | Returns logical bitwise AND of values.
BitwiseAnd(Int24, Int32) | Returns logical bitwise AND of values.
BitwiseOr(Int32, Int24) | Returns logical bitwise OR of values.
BitwiseOr(Int24, Int24) | Returns logical bitwise OR of values.
BitwiseOr(Int24, Int32) | Returns logical bitwise OR of values.
Decrement | Returns decremented value.
Division(Int32, Int24) | Returns computed division of values.
Division(Int24, Int24) | Returns computed division of values.
Division(Int24, Int32) | Returns computed division of values.
Equality(Int32, Int24) | Compares the two values for equality.
Equality(Int24, Int24) | Compares the two values for equality.
Equality(Int24, Int32) | Compares the two values for equality.
ExclusiveOr(Int32, Int24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(Int24, Int24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(Int24, Int32) | Returns logical bitwise exclusive-OR of values.
(Decimal to Int24) | Explicitly converts value to an Int24.
(Double to Int24) | Explicitly converts value to an Int24.
(Enum to Int24) | Explicitly converts value to an Int24.
(Int32 to Int24) | Explicitly converts value to an Int24.
(Int64 to Int24) | Explicitly converts value to an Int24.
(Single to Int24) | Explicitly converts value to an Int24.
(String to Int24) | Explicitly converts value to an Int24.
(Int24 to Int16) | Explicitly converts Int24 to Int16.
(Int24 to UInt16) | Explicitly converts Int24 to UInt16.
(Int24 to Byte) | Explicitly converts Int24 to Byte.
Exponent(Int32, Int24) | Returns result of first value raised to power of second value.
Exponent(Int24, Int24) | Returns result of first value raised to power of second value.
Exponent(Int24, Int32) | Returns result of first value raised to power of second value.
False | Returns true if value is equal to zero.
GreaterThan(Int32, Int24) | Returns true if left value is greater than right value.
GreaterThan(Int24, Int24) | Returns true if left value is greater than right value.
GreaterThan(Int24, Int32) | Returns true if left value is greater than right value.
GreaterThanOrEqual(Int32, Int24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(Int24, Int24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(Int24, Int32) | Returns true if left value is greater than or equal to right value.
(Byte to Int24) | Implicitly converts value to an Int24.
(Char to Int24) | Implicitly converts value to an Int24.
(Int16 to Int24) | Implicitly converts value to an Int24.
(Int24 to Int32) | Implicitly converts Int24 to Int32.
(Int24 to UInt32) | Implicitly converts Int24 to UInt32.
(Int24 to Int64) | Implicitly converts Int24 to Int64.
(Int24 to UInt64) | Implicitly converts Int24 to UInt64.
(Int24 to Double) | Implicitly converts Int24 to Double.
(Int24 to Single) | Implicitly converts Int24 to Single.
(Int24 to Decimal) | Implicitly converts Int24 to Decimal.
(Int24 to String) | Implicitly converts Int24 to String.
Increment | Returns incremented value.
Inequality(Int32, Int24) | Compares the two values for inequality.
Inequality(Int24, Int24) | Compares the two values for inequality.
Inequality(Int24, Int32) | Compares the two values for inequality.
LeftShift | Returns value after left shifts of first value by the number of bits specified by second value.
LessThan(Int32, Int24) | Returns true if left value is less than right value.
LessThan(Int24, Int24) | Returns true if left value is less than right value.
LessThan(Int24, Int32) | Returns true if left value is less than right value.
LessThanOrEqual(Int32, Int24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(Int24, Int24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(Int24, Int32) | Returns true if left value is less or equal to than right value.
Modulus(Int32, Int24) | Returns computed remainder after dividing first value by the second.
Modulus(Int24, Int24) | Returns computed remainder after dividing first value by the second.
Modulus(Int24, Int32) | Returns computed remainder after dividing first value by the second.
Multiply(Int32, Int24) | Returns computed product of values.
Multiply(Int24, Int24) | Returns computed product of values.
Multiply(Int24, Int32) | Returns computed product of values.
OnesComplement | Returns bitwise complement of value.
RightShift | Returns value after right shifts of first value by the number of bits specified by second value.
Subtraction(Int32, Int24) | Returns computed difference of values.
Subtraction(Int24, Int24) | Returns computed difference of values.
Subtraction(Int24, Int32) | Returns computed difference of values.
True | Returns true if value is not zero.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Addition Operator

Grid Solutions Framework Int24Addition Operator
Overload List
Name | Description
Addition(Int32, Int24) | Returns computed sum of values.
Addition(Int24, Int24) | Returns computed sum of values.
Addition(Int24, Int32) | Returns computed sum of values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Addition Operator (Int32, Int24)

Grid Solutions Framework Int24Addition Operator (Int32, Int24)
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator +(
    int value1,
    Int24 value2
)
Public Shared Operator + (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (+)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator +(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int32
Integer result of addition.
See Also

Reference

Int24 Structure
Addition Overload
GSF Namespace


Int24.Addition Operator (Int24, Int24)

Grid Solutions Framework Int24Addition Operator (Int24, Int24)
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator +(
    Int24 value1,
    Int24 value2
)
Public Shared Operator + (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (+)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator +(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int24
Int24 result of addition.
See Also

Reference

Int24 Structure
Addition Overload
GSF Namespace


Int24.Addition Operator (Int24, Int32)

Grid Solutions Framework Int24Addition Operator (Int24, Int32)
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator +(
    Int24 value1,
    int value2
)
Public Shared Operator + (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (+)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator +(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Int32
Integer result of addition.
See Also

Reference

Int24 Structure
Addition Overload
GSF Namespace


Int24.BitwiseAnd Operator

Grid Solutions Framework Int24BitwiseAnd Operator
Overload List
Name | Description
BitwiseAnd(Int32, Int24) | Returns logical bitwise AND of values.
BitwiseAnd(Int24, Int24) | Returns logical bitwise AND of values.
BitwiseAnd(Int24, Int32) | Returns logical bitwise AND of values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.BitwiseAnd Operator (Int32, Int24)

Grid Solutions Framework Int24BitwiseAnd Operator (Int32, Int24)
Returns logical bitwise AND of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator &(
    int value1,
    Int24 value2
)
Public Shared Operator And (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (&&&)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator &(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int32
Integer as result of operation.
See Also

Reference

Int24 Structure
BitwiseAnd Overload
GSF Namespace


Int24.BitwiseAnd Operator (Int24, Int24)

Grid Solutions Framework Int24BitwiseAnd Operator (Int24, Int24)
Returns logical bitwise AND of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator &(
    Int24 value1,
    Int24 value2
)
Public Shared Operator And (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (&&&)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator &(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int24
Int24 as result of operation.
See Also

Reference

Int24 Structure
BitwiseAnd Overload
GSF Namespace


Int24.BitwiseAnd Operator (Int24, Int32)

Grid Solutions Framework Int24BitwiseAnd Operator (Int24, Int32)
Returns logical bitwise AND of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator &(
    Int24 value1,
    int value2
)
Public Shared Operator And (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (&&&)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator &(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Int32
Integer as result of operation.
See Also

Reference

Int24 Structure
BitwiseAnd Overload
GSF Namespace


Int24.BitwiseOr Operator

Grid Solutions Framework Int24BitwiseOr Operator
Overload List
Name | Description
BitwiseOr(Int32, Int24) | Returns logical bitwise OR of values.
BitwiseOr(Int24, Int24) | Returns logical bitwise OR of values.
BitwiseOr(Int24, Int32) | Returns logical bitwise OR of values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.BitwiseOr Operator (Int32, Int24)

Grid Solutions Framework Int24BitwiseOr Operator (Int32, Int24)
Returns logical bitwise OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator |(
    int value1,
    Int24 value2
)
Public Shared Operator Or (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (|||)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator |(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int32
Integer as result of operation.
See Also

Reference

Int24 Structure
BitwiseOr Overload
GSF Namespace


Int24.BitwiseOr Operator (Int24, Int24)

Grid Solutions Framework Int24BitwiseOr Operator (Int24, Int24)
Returns logical bitwise OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator |(
    Int24 value1,
    Int24 value2
)
Public Shared Operator Or (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (|||)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator |(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int24
Int24 as result of operation.
See Also

Reference

Int24 Structure
BitwiseOr Overload
GSF Namespace


Int24.BitwiseOr Operator (Int24, Int32)

Grid Solutions Framework Int24BitwiseOr Operator (Int24, Int32)
Returns logical bitwise OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator |(
    Int24 value1,
    int value2
)
Public Shared Operator Or (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (|||)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator |(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Int32
Integer as result of operation.
See Also

Reference

Int24 Structure
BitwiseOr Overload
GSF Namespace


Int24.Decrement Operator

Grid Solutions Framework Int24Decrement Operator
Returns decremented value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator --(
    Int24 value
)
Public Shared Operator -- (
    value As Int24
) As Int24
static let inline (--)
        value : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator --(
    Int24 value
)

Parameters

value
Type: GSFInt24
The operand.

Return Value

Type: Int24
Int24 result of decrement.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Division Operator

Grid Solutions Framework Int24Division Operator
Overload List
Name | Description
Division(Int32, Int24) | Returns computed division of values.
Division(Int24, Int24) | Returns computed division of values.
Division(Int24, Int32) | Returns computed division of values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Division Operator (Int32, Int24)

Grid Solutions Framework Int24Division Operator (Int32, Int24)
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator /(
    int value1,
    Int24 value2
)
Public Shared Operator / (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (/)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator /(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int32
Integer result of operation.
See Also

Reference

Int24 Structure
Division Overload
GSF Namespace


Int24.Division Operator (Int24, Int24)

Grid Solutions Framework Int24Division Operator (Int24, Int24)
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator /(
    Int24 value1,
    Int24 value2
)
Public Shared Operator / (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (/)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator /(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int24
Int24 result of operation.
See Also

Reference

Int24 Structure
Division Overload
GSF Namespace


Int24.Division Operator (Int24, Int32)

Grid Solutions Framework Int24Division Operator (Int24, Int32)
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator /(
    Int24 value1,
    int value2
)
Public Shared Operator / (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (/)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator /(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Int32
Integer result of operation.
See Also

Reference

Int24 Structure
Division Overload
GSF Namespace


Int24.Equality Operator

Grid Solutions Framework Int24Equality Operator
Overload List
Name | Description
Equality(Int32, Int24) | Compares the two values for equality.
Equality(Int24, Int24) | Compares the two values for equality.
Equality(Int24, Int32) | Compares the two values for equality.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Equality Operator (Int32, Int24)

Grid Solutions Framework Int24Equality Operator (Int32, Int24)
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    int value1,
    Int24 value2
)
Public Shared Operator = (
    value1 As Integer,
    value2 As Int24
) As Boolean
static let inline (=)
        value1 : int *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean value indicating equality.
See Also

Reference

Int24 Structure
Equality Overload
GSF Namespace


Int24.Equality Operator (Int24, Int24)

Grid Solutions Framework Int24Equality Operator (Int24, Int24)
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Int24 value1,
    Int24 value2
)
Public Shared Operator = (
    value1 As Int24,
    value2 As Int24
) As Boolean
static let inline (=)
        value1 : Int24 *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean value indicating equality.
See Also

Reference

Int24 Structure
Equality Overload
GSF Namespace


Int24.Equality Operator (Int24, Int32)

Grid Solutions Framework Int24Equality Operator (Int24, Int32)
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Int24 value1,
    int value2
)
Public Shared Operator = (
    value1 As Int24,
    value2 As Integer
) As Boolean
static let inline (=)
        value1 : Int24 *
        value2 : int  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Boolean
Boolean value indicating equality.
See Also

Reference

Int24 Structure
Equality Overload
GSF Namespace


Int24.ExclusiveOr Operator

Grid Solutions Framework Int24ExclusiveOr Operator
Overload List
Name | Description
ExclusiveOr(Int32, Int24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(Int24, Int24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(Int24, Int32) | Returns logical bitwise exclusive-OR of values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.ExclusiveOr Operator (Int32, Int24)

Grid Solutions Framework Int24ExclusiveOr Operator (Int32, Int24)
Returns logical bitwise exclusive-OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator ^(
    int value1,
    Int24 value2
)
Public Shared Operator Xor (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (^^^)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator ^(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int32
Integer value of the resulting exclusive-OR operation.
See Also

Reference

Int24 Structure
ExclusiveOr Overload
GSF Namespace


Int24.ExclusiveOr Operator (Int24, Int24)

Grid Solutions Framework Int24ExclusiveOr Operator (Int24, Int24)
Returns logical bitwise exclusive-OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator ^(
    Int24 value1,
    Int24 value2
)
Public Shared Operator Xor (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (^^^)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator ^(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int24
Integer value of the resulting exclusive-OR operation.
See Also

Reference

Int24 Structure
ExclusiveOr Overload
GSF Namespace


Int24.ExclusiveOr Operator (Int24, Int32)

Grid Solutions Framework Int24ExclusiveOr Operator (Int24, Int32)
Returns logical bitwise exclusive-OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator ^(
    Int24 value1,
    int value2
)
Public Shared Operator Xor (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (^^^)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator ^(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Int32
Integer value of the resulting exclusive-OR operation.
See Also

Reference

Int24 Structure
ExclusiveOr Overload
GSF Namespace


Int24 Explicit Conversion Operators

Grid Solutions Framework Int24 Conversion Operators
Overload List
Name | Description
(Decimal to Int24) | Explicitly converts value to an Int24.
(Double to Int24) | Explicitly converts value to an Int24.
(Enum to Int24) | Explicitly converts value to an Int24.
(Int32 to Int24) | Explicitly converts value to an Int24.
(Int64 to Int24) | Explicitly converts value to an Int24.
(Single to Int24) | Explicitly converts value to an Int24.
(String to Int24) | Explicitly converts value to an Int24.
(Int24 to Int16) | Explicitly converts Int24 to Int16.
(Int24 to UInt16) | Explicitly converts Int24 to UInt16.
(Int24 to Byte) | Explicitly converts Int24 to Byte.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24 Explicit Conversion (Decimal to Int24)

Grid Solutions Framework Int24 Conversion (Decimal to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    decimal value
)
Public Shared Narrowing Operator CType (
    value As Decimal
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    Decimal value
)

Parameters

value
Type: SystemDecimal
Decimal value that is converted.

Return Value

Type: Int24
Int24
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Double to Int24)

Grid Solutions Framework Int24 Conversion (Double to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    double value
)
Public Shared Narrowing Operator CType (
    value As Double
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    double value
)

Parameters

value
Type: SystemDouble
Double value that is converted.

Return Value

Type: Int24
Int24
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Enum to Int24)

Grid Solutions Framework Int24 Conversion (Enum to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    Enum value
)
Public Shared Narrowing Operator CType (
    value As Enum
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    Enum^ value
)

Parameters

value
Type: SystemEnum
Enum value that is converted.

Return Value

Type: Int24
Int24
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Int32 to Int24)

Grid Solutions Framework Int24 Conversion (Int32 to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    int value
)
Public Shared Narrowing Operator CType (
    value As Integer
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    int value
)

Parameters

value
Type: SystemInt32
Integer value that is converted.

Return Value

Type: Int24
Int24
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Int64 to Int24)

Grid Solutions Framework Int24 Conversion (Int64 to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    long value
)
Public Shared Narrowing Operator CType (
    value As Long
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    long long value
)

Parameters

value
Type: SystemInt64
Long value that is converted.

Return Value

Type: Int24
Int24
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Single to Int24)

Grid Solutions Framework Int24 Conversion (Single to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    float value
)
Public Shared Narrowing Operator CType (
    value As Single
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    float value
)

Parameters

value
Type: SystemSingle
Float value that is converted.

Return Value

Type: Int24
Int24
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (String to Int24)

Grid Solutions Framework Int24 Conversion (String to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    string value
)
Public Shared Narrowing Operator CType (
    value As String
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    String^ value
)

Parameters

value
Type: SystemString
String value that is converted.

Return Value

Type: Int24
Int24
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Int24 to Int16)

Grid Solutions Framework Int24 Conversion (Int24 to Int16)
Explicitly converts Int24 to Int16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator short (
    Int24 value
)
Public Shared Narrowing Operator CType (
    value As Int24
) As Short
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator short (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted.

Return Value

Type: Int16
Short
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Int24 to UInt16)

Grid Solutions Framework Int24 Conversion (Int24 to UInt16)
Explicitly converts Int24 to UInt16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator ushort (
    Int24 value
)
Public Shared Narrowing Operator CType (
    value As Int24
) As UShort
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator unsigned short (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted.

Return Value

Type: UInt16
Unsigned Short
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Explicit Conversion (Int24 to Byte)

Grid Solutions Framework Int24 Conversion (Int24 to Byte)
Explicitly converts Int24 to Byte.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator byte (
    Int24 value
)
Public Shared Narrowing Operator CType (
    value As Int24
) As Byte
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator unsigned char (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted.

Return Value

Type: Byte
Byte
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24.Exponent Operator

Grid Solutions Framework Int24Exponent Operator
Overload List
Name | Description
Exponent(Int32, Int24) | Returns result of first value raised to power of second value.
Exponent(Int24, Int24) | Returns result of first value raised to power of second value.
Exponent(Int24, Int32) | Returns result of first value raised to power of second value.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Exponent Operator (Int32, Int24)

Grid Solutions Framework Int24Exponent Operator (Int32, Int24)
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Integer,
    value2 As Int24
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Double
Double that is the result of the operation.
See Also

Reference

Int24 Structure
Exponent Overload
GSF Namespace


Int24.Exponent Operator (Int24, Int24)

Grid Solutions Framework Int24Exponent Operator (Int24, Int24)
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Int24,
    value2 As Int24
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Double
Double that is the result of the operation.
See Also

Reference

Int24 Structure
Exponent Overload
GSF Namespace


Int24.Exponent Operator (Int24, Int32)

Grid Solutions Framework Int24Exponent Operator (Int24, Int32)
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Int24,
    value2 As Integer
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Double
Double that is the result of the operation.
See Also

Reference

Int24 Structure
Exponent Overload
GSF Namespace


Int24.False Operator

Grid Solutions Framework Int24False Operator
Returns true if value is equal to zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator false(
    Int24 value
)
Public Shared Operator IsFalse (
    value As Int24
) As Boolean
static let inline (false)
        value : Int24  : bool
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value
Type: GSFInt24
Int24 value to test.

Return Value

Type: Boolean
Boolean to indicate whether the value was equal to zero.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.GreaterThan Operator

Grid Solutions Framework Int24GreaterThan Operator
Overload List
Name | Description
GreaterThan(Int32, Int24) | Returns true if left value is greater than right value.
GreaterThan(Int24, Int24) | Returns true if left value is greater than right value.
GreaterThan(Int24, Int32) | Returns true if left value is greater than right value.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.GreaterThan Operator (Int32, Int24)

Grid Solutions Framework Int24GreaterThan Operator (Int32, Int24)
Returns true if left value is greater than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    int value1,
    Int24 value2
)
Public Shared Operator > (
    value1 As Integer,
    value2 As Int24
) As Boolean
static let inline (>)
        value1 : int *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was greater than the right value.
See Also

Reference

Int24 Structure
GreaterThan Overload
GSF Namespace


Int24.GreaterThan Operator (Int24, Int24)

Grid Solutions Framework Int24GreaterThan Operator (Int24, Int24)
Returns true if left value is greater than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Int24 value1,
    Int24 value2
)
Public Shared Operator > (
    value1 As Int24,
    value2 As Int24
) As Boolean
static let inline (>)
        value1 : Int24 *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was greater than the right value.
See Also

Reference

Int24 Structure
GreaterThan Overload
GSF Namespace


Int24.GreaterThan Operator (Int24, Int32)

Grid Solutions Framework Int24GreaterThan Operator (Int24, Int32)
Returns true if left value is greater than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Int24 value1,
    int value2
)
Public Shared Operator > (
    value1 As Int24,
    value2 As Integer
) As Boolean
static let inline (>)
        value1 : Int24 *
        value2 : int  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was greater than the right value.
See Also

Reference

Int24 Structure
GreaterThan Overload
GSF Namespace


Int24.GreaterThanOrEqual Operator

Grid Solutions Framework Int24GreaterThanOrEqual Operator
Overload List
Name | Description
GreaterThanOrEqual(Int32, Int24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(Int24, Int24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(Int24, Int32) | Returns true if left value is greater than or equal to right value.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.GreaterThanOrEqual Operator (Int32, Int24)

Grid Solutions Framework Int24GreaterThanOrEqual Operator (Int32, Int24)
Returns true if left value is greater than or equal to right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    int value1,
    Int24 value2
)
Public Shared Operator >= (
    value1 As Integer,
    value2 As Int24
) As Boolean
static let inline (>=)
        value1 : int *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was greater than or equal to the right value.
See Also

Reference

Int24 Structure
GreaterThanOrEqual Overload
GSF Namespace


Int24.GreaterThanOrEqual Operator (Int24, Int24)

Grid Solutions Framework Int24GreaterThanOrEqual Operator (Int24, Int24)
Returns true if left value is greater than or equal to right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Int24 value1,
    Int24 value2
)
Public Shared Operator >= (
    value1 As Int24,
    value2 As Int24
) As Boolean
static let inline (>=)
        value1 : Int24 *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was greater than or equal to the right value.
See Also

Reference

Int24 Structure
GreaterThanOrEqual Overload
GSF Namespace


Int24.GreaterThanOrEqual Operator (Int24, Int32)

Grid Solutions Framework Int24GreaterThanOrEqual Operator (Int24, Int32)
Returns true if left value is greater than or equal to right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Int24 value1,
    int value2
)
Public Shared Operator >= (
    value1 As Int24,
    value2 As Integer
) As Boolean
static let inline (>=)
        value1 : Int24 *
        value2 : int  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was greater than or equal to the right value.
See Also

Reference

Int24 Structure
GreaterThanOrEqual Overload
GSF Namespace


Int24 Implicit Conversion Operators

Grid Solutions Framework Int24 Conversion Operators
Overload List
Name | Description
(Byte to Int24) | Implicitly converts value to an Int24.
(Char to Int24) | Implicitly converts value to an Int24.
(Int16 to Int24) | Implicitly converts value to an Int24.
(Int24 to Int32) | Implicitly converts Int24 to Int32.
(Int24 to UInt32) | Implicitly converts Int24 to UInt32.
(Int24 to Int64) | Implicitly converts Int24 to Int64.
(Int24 to UInt64) | Implicitly converts Int24 to UInt64.
(Int24 to Double) | Implicitly converts Int24 to Double.
(Int24 to Single) | Implicitly converts Int24 to Single.
(Int24 to Decimal) | Implicitly converts Int24 to Decimal.
(Int24 to String) | Implicitly converts Int24 to String.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24 Implicit Conversion (Byte to Int24)

Grid Solutions Framework Int24 Conversion (Byte to Int24)
Implicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Int24 (
    byte value
)
Public Shared Widening Operator CType (
    value As Byte
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Int24 (
    unsigned char value
)

Parameters

value
Type: SystemByte
Byte value that is converted to an Int24.

Return Value

Type: Int24
An Int24 value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Char to Int24)

Grid Solutions Framework Int24 Conversion (Char to Int24)
Implicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Int24 (
    char value
)
Public Shared Widening Operator CType (
    value As Char
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Int24 (
    wchar_t value
)

Parameters

value
Type: SystemChar
Char value that is converted to an Int24.

Return Value

Type: Int24
An Int24 value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int16 to Int24)

Grid Solutions Framework Int24 Conversion (Int16 to Int24)
Implicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Int24 (
    short value
)
Public Shared Widening Operator CType (
    value As Short
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Int24 (
    short value
)

Parameters

value
Type: SystemInt16
Short value that is converted to an Int24.

Return Value

Type: Int24
An Int24 value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to Int32)

Grid Solutions Framework Int24 Conversion (Int24 to Int32)
Implicitly converts Int24 to Int32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator int (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As Integer
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator int (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an Int32.

Return Value

Type: Int32
An Int32 value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to UInt32)

Grid Solutions Framework Int24 Conversion (Int24 to UInt32)
Implicitly converts Int24 to UInt32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator uint (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As UInteger
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned int (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an unsigned integer.

Return Value

Type: UInt32
Unsigned integer
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to Int64)

Grid Solutions Framework Int24 Conversion (Int24 to Int64)
Implicitly converts Int24 to Int64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator long (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As Long
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator long long (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an Int64.

Return Value

Type: Int64
An Int64 value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to UInt64)

Grid Solutions Framework Int24 Conversion (Int24 to UInt64)
Implicitly converts Int24 to UInt64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ulong (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As ULong
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned long long (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an UInt64.

Return Value

Type: UInt64
An UInt64 value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to Double)

Grid Solutions Framework Int24 Conversion (Int24 to Double)
Implicitly converts Int24 to Double.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an Double.

Return Value

Type: Double
A Double value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to Single)

Grid Solutions Framework Int24 Conversion (Int24 to Single)
Implicitly converts Int24 to Single.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator float (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As Single
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator float (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an Single.

Return Value

Type: Single
A Single value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to Decimal)

Grid Solutions Framework Int24 Conversion (Int24 to Decimal)
Implicitly converts Int24 to Decimal.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator decimal (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As Decimal
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Decimal (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an Decimal.

Return Value

Type: Decimal
A Decimal value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24 Implicit Conversion (Int24 to String)

Grid Solutions Framework Int24 Conversion (Int24 to String)
Implicitly converts Int24 to String.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator string (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As String
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator String^ (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value that is converted to an String.

Return Value

Type: String
A String value.
See Also

Reference

Int24 Structure
Overload
GSF Namespace


Int24.Increment Operator

Grid Solutions Framework Int24Increment Operator
Returns incremented value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator ++(
    Int24 value
)
Public Shared Operator ++ (
    value As Int24
) As Int24
static let inline (++)
        value : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator ++(
    Int24 value
)

Parameters

value
Type: GSFInt24
The operand.

Return Value

Type: Int24
Int24 result of increment.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Inequality Operator

Grid Solutions Framework Int24Inequality Operator
Overload List
Name | Description
Inequality(Int32, Int24) | Compares the two values for inequality.
Inequality(Int24, Int24) | Compares the two values for inequality.
Inequality(Int24, Int32) | Compares the two values for inequality.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Inequality Operator (Int32, Int24)

Grid Solutions Framework Int24Inequality Operator (Int32, Int24)
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    int value1,
    Int24 value2
)
Public Shared Operator <> (
    value1 As Integer,
    value2 As Int24
) As Boolean
static let inline (<>)
        value1 : int *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating the result of the inequality.
See Also

Reference

Int24 Structure
Inequality Overload
GSF Namespace


Int24.Inequality Operator (Int24, Int24)

Grid Solutions Framework Int24Inequality Operator (Int24, Int24)
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Int24 value1,
    Int24 value2
)
Public Shared Operator <> (
    value1 As Int24,
    value2 As Int24
) As Boolean
static let inline (<>)
        value1 : Int24 *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating the result of the inequality.
See Also

Reference

Int24 Structure
Inequality Overload
GSF Namespace


Int24.Inequality Operator (Int24, Int32)

Grid Solutions Framework Int24Inequality Operator (Int24, Int32)
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Int24 value1,
    int value2
)
Public Shared Operator <> (
    value1 As Int24,
    value2 As Integer
) As Boolean
static let inline (<>)
        value1 : Int24 *
        value2 : int  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Boolean
Boolean indicating the result of the inequality.
See Also

Reference

Int24 Structure
Inequality Overload
GSF Namespace


Int24.LeftShift Operator

Grid Solutions Framework Int24LeftShift Operator
Returns value after left shifts of first value by the number of bits specified by second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator <<(
    Int24 value,
    int shifts
)
Public Shared Operator << (
    value As Int24,
    shifts As Integer
) As Int24
static let inline (<<<)
        value : Int24 *
        shifts : int  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator <<(
    Int24 value,
    int shifts
)

Parameters

value
Type: GSFInt24
Int24 value to shift.
shifts
Type: SystemInt32
Int32 shifts indicates how many places to shift.

Return Value

Type: Int24
An Int24 value.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.LessThan Operator

Grid Solutions Framework Int24LessThan Operator
Overload List
Name | Description
LessThan(Int32, Int24) | Returns true if left value is less than right value.
LessThan(Int24, Int24) | Returns true if left value is less than right value.
LessThan(Int24, Int32) | Returns true if left value is less than right value.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.LessThan Operator (Int32, Int24)

Grid Solutions Framework Int24LessThan Operator (Int32, Int24)
Returns true if left value is less than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    int value1,
    Int24 value2
)
Public Shared Operator < (
    value1 As Integer,
    value2 As Int24
) As Boolean
static let inline (<)
        value1 : int *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was less than the right value.
See Also

Reference

Int24 Structure
LessThan Overload
GSF Namespace


Int24.LessThan Operator (Int24, Int24)

Grid Solutions Framework Int24LessThan Operator (Int24, Int24)
Returns true if left value is less than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Int24 value1,
    Int24 value2
)
Public Shared Operator < (
    value1 As Int24,
    value2 As Int24
) As Boolean
static let inline (<)
        value1 : Int24 *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was less than the right value.
See Also

Reference

Int24 Structure
LessThan Overload
GSF Namespace


Int24.LessThan Operator (Int24, Int32)

Grid Solutions Framework Int24LessThan Operator (Int24, Int32)
Returns true if left value is less than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Int24 value1,
    int value2
)
Public Shared Operator < (
    value1 As Int24,
    value2 As Integer
) As Boolean
static let inline (<)
        value1 : Int24 *
        value2 : int  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was less than the right value.
See Also

Reference

Int24 Structure
LessThan Overload
GSF Namespace


Int24.LessThanOrEqual Operator

Grid Solutions Framework Int24LessThanOrEqual Operator
Overload List
Name | Description
LessThanOrEqual(Int32, Int24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(Int24, Int24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(Int24, Int32) | Returns true if left value is less or equal to than right value.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.LessThanOrEqual Operator (Int32, Int24)

Grid Solutions Framework Int24LessThanOrEqual Operator (Int32, Int24)
Returns true if left value is less or equal to than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    int value1,
    Int24 value2
)
Public Shared Operator <= (
    value1 As Integer,
    value2 As Int24
) As Boolean
static let inline (<=)
        value1 : int *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was less than the right value.
See Also

Reference

Int24 Structure
LessThanOrEqual Overload
GSF Namespace


Int24.LessThanOrEqual Operator (Int24, Int24)

Grid Solutions Framework Int24LessThanOrEqual Operator (Int24, Int24)
Returns true if left value is less or equal to than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Int24 value1,
    Int24 value2
)
Public Shared Operator <= (
    value1 As Int24,
    value2 As Int24
) As Boolean
static let inline (<=)
        value1 : Int24 *
        value2 : Int24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was less than the right value.
See Also

Reference

Int24 Structure
LessThanOrEqual Overload
GSF Namespace


Int24.LessThanOrEqual Operator (Int24, Int32)

Grid Solutions Framework Int24LessThanOrEqual Operator (Int24, Int32)
Returns true if left value is less or equal to than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Int24 value1,
    int value2
)
Public Shared Operator <= (
    value1 As Int24,
    value2 As Integer
) As Boolean
static let inline (<=)
        value1 : Int24 *
        value2 : int  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Boolean
Boolean indicating whether the left value was less than the right value.
See Also

Reference

Int24 Structure
LessThanOrEqual Overload
GSF Namespace


Int24.Modulus Operator

Grid Solutions Framework Int24Modulus Operator
Overload List
Name | Description
Modulus(Int32, Int24) | Returns computed remainder after dividing first value by the second.
Modulus(Int24, Int24) | Returns computed remainder after dividing first value by the second.
Modulus(Int24, Int32) | Returns computed remainder after dividing first value by the second.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Modulus Operator (Int32, Int24)

Grid Solutions Framework Int24Modulus Operator (Int32, Int24)
Returns computed remainder after dividing first value by the second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator %(
    int value1,
    Int24 value2
)
Public Shared Operator Mod (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (%)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator %(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Int32 value as numerator.
value2
Type: GSFInt24
Int24 value as denominator.

Return Value

Type: Int32
Int32 as remainder
See Also

Reference

Int24 Structure
Modulus Overload
GSF Namespace


Int24.Modulus Operator (Int24, Int24)

Grid Solutions Framework Int24Modulus Operator (Int24, Int24)
Returns computed remainder after dividing first value by the second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator %(
    Int24 value1,
    Int24 value2
)
Public Shared Operator Mod (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (%)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator %(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Int24 value as numerator.
value2
Type: GSFInt24
Int24 value as denominator.

Return Value

Type: Int24
Int24 as remainder
See Also

Reference

Int24 Structure
Modulus Overload
GSF Namespace


Int24.Modulus Operator (Int24, Int32)

Grid Solutions Framework Int24Modulus Operator (Int24, Int32)
Returns computed remainder after dividing first value by the second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator %(
    Int24 value1,
    int value2
)
Public Shared Operator Mod (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (%)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator %(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Int24 value as numerator.
value2
Type: SystemInt32
Int32 value as denominator.

Return Value

Type: Int32
Int32 as remainder
See Also

Reference

Int24 Structure
Modulus Overload
GSF Namespace


Int24.Multiply Operator

Grid Solutions Framework Int24Multiply Operator
Overload List
Name | Description
Multiply(Int32, Int24) | Returns computed product of values.
Multiply(Int24, Int24) | Returns computed product of values.
Multiply(Int24, Int32) | Returns computed product of values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Multiply Operator (Int32, Int24)

Grid Solutions Framework Int24Multiply Operator (Int32, Int24)
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator *(
    int value1,
    Int24 value2
)
Public Shared Operator * (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (*)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator *(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Int32 value as left hand operand.
value2
Type: GSFInt24
Int24 value as right hand operand.

Return Value

Type: Int32
Int32 as result
See Also

Reference

Int24 Structure
Multiply Overload
GSF Namespace


Int24.Multiply Operator (Int24, Int24)

Grid Solutions Framework Int24Multiply Operator (Int24, Int24)
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator *(
    Int24 value1,
    Int24 value2
)
Public Shared Operator * (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (*)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator *(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Int24 value as left hand operand.
value2
Type: GSFInt24
Int24 value as right hand operand.

Return Value

Type: Int24
Int24 as result
See Also

Reference

Int24 Structure
Multiply Overload
GSF Namespace


Int24.Multiply Operator (Int24, Int32)

Grid Solutions Framework Int24Multiply Operator (Int24, Int32)
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator *(
    Int24 value1,
    int value2
)
Public Shared Operator * (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (*)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator *(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Int24 value as left hand operand.
value2
Type: SystemInt32
Int32 value as right hand operand.

Return Value

Type: Int32
Int32 as result
See Also

Reference

Int24 Structure
Multiply Overload
GSF Namespace


Int24.OnesComplement Operator

Grid Solutions Framework Int24OnesComplement Operator
Returns bitwise complement of value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator ~(
    Int24 value
)
Public Shared Operator ~ (
    value As Int24
) As Int24
F# does not support this operator.
JavaScript does not support overloaded operators.
public:
static Int24 operator ~(
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value as operand.

Return Value

Type: Int24
Int24 as result.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.RightShift Operator

Grid Solutions Framework Int24RightShift Operator
Returns value after right shifts of first value by the number of bits specified by second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator >>(
    Int24 value,
    int shifts
)
Public Shared Operator >> (
    value As Int24,
    shifts As Integer
) As Int24
static let inline (>>>)
        value : Int24 *
        shifts : int  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator >>(
    Int24 value,
    int shifts
)

Parameters

value
Type: GSFInt24
Int24 value to shift.
shifts
Type: SystemInt32
Int32 shifts indicates how many places to shift.

Return Value

Type: Int24
An Int24 value.
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Subtraction Operator

Grid Solutions Framework Int24Subtraction Operator
Overload List
Name | Description
Subtraction(Int32, Int24) | Returns computed difference of values.
Subtraction(Int24, Int24) | Returns computed difference of values.
Subtraction(Int24, Int32) | Returns computed difference of values.
Top
See Also

Reference

Int24 Structure
GSF Namespace


Int24.Subtraction Operator (Int32, Int24)

Grid Solutions Framework Int24Subtraction Operator (Int32, Int24)
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator -(
    int value1,
    Int24 value2
)
Public Shared Operator - (
    value1 As Integer,
    value2 As Int24
) As Integer
static let inline (-)
        value1 : int *
        value2 : Int24  : int
JavaScript does not support overloaded operators.
public:
static int operator -(
    int value1,
    Int24 value2
)

Parameters

value1
Type: SystemInt32
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int32
Integer result of subtraction.
See Also

Reference

Int24 Structure
Subtraction Overload
GSF Namespace


Int24.Subtraction Operator (Int24, Int24)

Grid Solutions Framework Int24Subtraction Operator (Int24, Int24)
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 operator -(
    Int24 value1,
    Int24 value2
)
Public Shared Operator - (
    value1 As Int24,
    value2 As Int24
) As Int24
static let inline (-)
        value1 : Int24 *
        value2 : Int24  : Int24
JavaScript does not support overloaded operators.
public:
static Int24 operator -(
    Int24 value1,
    Int24 value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: GSFInt24
Right hand operand.

Return Value

Type: Int24
Int24 result of subtraction.
See Also

Reference

Int24 Structure
Subtraction Overload
GSF Namespace


Int24.Subtraction Operator (Int24, Int32)

Grid Solutions Framework Int24Subtraction Operator (Int24, Int32)
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int operator -(
    Int24 value1,
    int value2
)
Public Shared Operator - (
    value1 As Int24,
    value2 As Integer
) As Integer
static let inline (-)
        value1 : Int24 *
        value2 : int  : int
JavaScript does not support overloaded operators.
public:
static int operator -(
    Int24 value1,
    int value2
)

Parameters

value1
Type: GSFInt24
Left hand operand.
value2
Type: SystemInt32
Right hand operand.

Return Value

Type: Int32
Integer result of subtraction.
See Also

Reference

Int24 Structure
Subtraction Overload
GSF Namespace


Int24.True Operator

Grid Solutions Framework Int24True Operator
Returns true if value is not zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator true(
    Int24 value
)
Public Shared Operator IsTrue (
    value As Int24
) As Boolean
static let inline (true)
        value : Int24  : bool
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value
Type: GSFInt24
Int24 value to test.

Return Value

Type: Boolean
Boolean to indicate whether the value was not equal to zero.
See Also

Reference

Int24 Structure
GSF Namespace


IProvideStatus Interface

Grid Solutions Framework IProvideStatus Interface
Defines an interface for any object to allow it to provide a name and status that can be displayed for informational purposes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IProvideStatus
Public Interface IProvideStatus
type IProvideStatus =  interface end
GSF.IProvideStatus = function();
GSF.IProvideStatus.createInterface('GSF.IProvideStatus');
public interface class IProvideStatus

The IProvideStatus type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the object providing status information.
Public property | Status | Gets the current status details about object providing status information.
Top
See Also

Reference

GSF Namespace


IProvideStatus Properties

Grid Solutions Framework IProvideStatus Properties

The IProvideStatus type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name of the object providing status information.
Public property | Status | Gets the current status details about object providing status information.
Top
See Also

Reference

IProvideStatus Interface
GSF Namespace


IProvideStatus.Name Property

Grid Solutions Framework IProvideStatusName Property
Gets the name of the object providing status information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
abstract Name : string with get

function get_Name();

property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProvideStatus Interface
GSF Namespace


IProvideStatus.Status Property

Grid Solutions Framework IProvideStatusStatus Property
Gets the current status details about object providing status information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Status { get; }
ReadOnly Property Status As String
    Get
abstract Status : string with get

function get_Status();

property String^ Status {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IProvideStatus Interface
GSF Namespace


ISupportLifecycle Interface

Grid Solutions Framework ISupportLifecycle Interface
Specifies that this object provides support for performing tasks during the key stages of object lifecycle.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ISupportLifecycle : IDisposable
Public Interface ISupportLifecycle
    Inherits IDisposable
type ISupportLifecycle =
    interface
        interface IDisposable
    end
GSF.ISupportLifecycle = function();
GSF.ISupportLifecycle.createInterface('GSF.ISupportLifecycle');
public interface class ISupportLifecycle : IDisposable

The ISupportLifecycle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed.
Top
Remarks
Lifecycle Stage | Equivalent Member
Birth | Initialize
Life (Work/Sleep) | Enabled
Death | Dispose
See Also

Reference

GSF Namespace


ISupportLifecycle Methods

Grid Solutions Framework ISupportLifecycle Methods

The ISupportLifecycle type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object.
Top
See Also

Reference

ISupportLifecycle Interface
GSF Namespace


ISupportLifecycle.Initialize Method

Grid Solutions Framework ISupportLifecycleInitialize Method
Initializes the state of the object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Initialize()
Sub Initialize
abstract Initialize : unit -> unit

function Initialize();
void Initialize()
Remarks

Typical implementation of Initialize should allow the object state to be initialized only once. Initialize should be called automatically from one or more key entry points of the object. For example, if the object is a Component and it implements the ISupportInitialize interface then Initialize should be called from the EndInit method so that the object gets initialized automatically when consumed through the IDE designer surface. In addition to this Initialize should also be called from key or mandatory methods of the object, like 'Start()' or 'Connect()', so that the object gets initialized even when not consumed through the IDE designer surface.

See Also

Reference

ISupportLifecycle Interface
GSF Namespace


ISupportLifecycle Properties

Grid Solutions Framework ISupportLifecycle Properties

The ISupportLifecycle type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Top
See Also

Reference

ISupportLifecycle Interface
GSF Namespace


ISupportLifecycle.Enabled Property

Grid Solutions Framework ISupportLifecycleEnabled Property
Gets or sets a boolean value that indicates whether the object is enabled.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Typical implementation of Enabled should suspend the internal processing when the object is disabled and resume processing when the object is enabled.
See Also

Reference

ISupportLifecycle Interface
GSF Namespace


ISupportLifecycle.IsDisposed Property

Grid Solutions Framework ISupportLifecycleIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool IsDisposed { get; }
ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get

function get_IsDisposed();

property bool IsDisposed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISupportLifecycle Interface
GSF Namespace


ISupportLifecycle Events

Grid Solutions Framework ISupportLifecycle Events

The ISupportLifecycle type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed.
Top
See Also

Reference

ISupportLifecycle Interface
GSF Namespace


ISupportLifecycle.Disposed Event

Grid Solutions Framework ISupportLifecycleDisposed Event
Raised after the source object has been properly disposed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler Disposed
Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>

function add_Disposed(value);
function remove_Disposed(value);
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISupportLifecycle Interface
GSF Namespace


LittleBinaryValue Class

Grid Solutions Framework LittleBinaryValue Class
Represents a little-endian ordered binary data sample stored as a byte array, but implicitly castable to most common native types.
Inheritance Hierarchy
SystemObject
GSFBinaryValueBase LittleEndianOrder
GSFLittleBinaryValue

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LittleBinaryValue : BinaryValueBase<LittleEndianOrder>
Public Class LittleBinaryValue
    Inherits BinaryValueBase(Of LittleEndianOrder)
type LittleBinaryValue =
    class
        inherit BinaryValueBase<LittleEndianOrder>
    end
GSF.LittleBinaryValue = function();

Type.createClass(
    'GSF.LittleBinaryValue',
    GSF.BinaryValueBase`1);
public ref class LittleBinaryValue : public BinaryValueBase<LittleEndianOrder^>

The LittleBinaryValue type exposes the following members.

Constructors
 | Name | Description
Public method | LittleBinaryValue(Byte) | Creates a new little-endian ordered binary value from the given byte array.
Public method | LittleBinaryValue(TypeCode, Byte) | Creates a new little-endian ordered binary value from the given byte array.
Public method | LittleBinaryValue(Byte, Int32, Int32) | Creates a new little-endian ordered binary value from the given byte array.
Public method | LittleBinaryValue(TypeCode, Byte, Int32, Int32) | Creates a new little-endian ordered binary value from the given byte array.
Top
Methods
 | Name | Description
Public method | ConvertToType | Returns a LittleBinaryValue representation of source value converted to specified TypeCode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToString | Returns a String that represents the current LittleBinaryValue. (Overrides ObjectToString.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Top
Operators
Name | Description
(Byte to LittleBinaryValue) | Implicitly converts Byte to LittleBinaryValue.
(Double to LittleBinaryValue) | Implicitly converts Double to LittleBinaryValue.
(Int16 to LittleBinaryValue) | Implicitly converts Int16 to LittleBinaryValue.
(Int32 to LittleBinaryValue) | Implicitly converts Int32 to LittleBinaryValue.
(Int64 to LittleBinaryValue) | Implicitly converts Int64 to LittleBinaryValue.
(Single to LittleBinaryValue) | Implicitly converts Single to LittleBinaryValue.
(UInt16 to LittleBinaryValue) | Implicitly converts UInt16 to LittleBinaryValue.
(UInt32 to LittleBinaryValue) | Implicitly converts UInt32 to LittleBinaryValue.
(UInt64 to LittleBinaryValue) | Implicitly converts UInt64 to LittleBinaryValue.
(Int24 to LittleBinaryValue) | Implicitly converts Int24 to LittleBinaryValue.
(LittleBinaryValue to Byte) | Implicitly converts LittleBinaryValue to Byte.
(LittleBinaryValue to Int16) | Implicitly converts LittleBinaryValue to Int16.
(LittleBinaryValue to UInt16) | Implicitly converts LittleBinaryValue to UInt16.
(LittleBinaryValue to Int24) | Implicitly converts LittleBinaryValue to Int24.
(LittleBinaryValue to UInt24) | Implicitly converts LittleBinaryValue to UInt24.
(LittleBinaryValue to Int32) | Implicitly converts LittleBinaryValue to Int32.
(LittleBinaryValue to UInt32) | Implicitly converts LittleBinaryValue to UInt32.
(LittleBinaryValue to Int64) | Implicitly converts LittleBinaryValue to Int64.
(LittleBinaryValue to UInt64) | Implicitly converts LittleBinaryValue to UInt64.
(LittleBinaryValue to Single) | Implicitly converts LittleBinaryValue to Single.
(LittleBinaryValue to Double) | Implicitly converts LittleBinaryValue to Double.
(UInt24 to LittleBinaryValue) | Implicitly converts UInt24 to LittleBinaryValue.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample. (Inherited from BinaryValueBaseTEndianOrder.)
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents. (Inherited from BinaryValueBaseTEndianOrder.)
Top
See Also

Reference

GSF Namespace


LittleBinaryValue Constructor

Grid Solutions Framework LittleBinaryValue Constructor
Overload List
 | Name | Description
Public method | LittleBinaryValue(Byte) | Creates a new little-endian ordered binary value from the given byte array.
Public method | LittleBinaryValue(TypeCode, Byte) | Creates a new little-endian ordered binary value from the given byte array.
Public method | LittleBinaryValue(Byte, Int32, Int32) | Creates a new little-endian ordered binary value from the given byte array.
Public method | LittleBinaryValue(TypeCode, Byte, Int32, Int32) | Creates a new little-endian ordered binary value from the given byte array.
Top
See Also

Reference

LittleBinaryValue Class
GSF Namespace


LittleBinaryValue Constructor (Byte[])

Grid Solutions Framework LittleBinaryValue Constructor (Byte)
Creates a new little-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue(
    byte[] buffer
)
Public Sub New (
    buffer As Byte()
)
new :
        buffer : byte[] -> LittleBinaryValue
GSF.LittleBinaryValue = function(buffer);
public:
LittleBinaryValue(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
Remarks
This constructor assumes a type code of Empty to represent "undefined".
See Also

Reference

LittleBinaryValue Class
LittleBinaryValue Overload
GSF Namespace


LittleBinaryValue Constructor (TypeCode, Byte[])

Grid Solutions Framework LittleBinaryValue Constructor (TypeCode, Byte)
Creates a new little-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue(
    TypeCode typeCode,
    byte[] buffer
)
Public Sub New (
    typeCode As TypeCode,
    buffer As Byte()
)
new :
        typeCode : TypeCode *
        buffer : byte[] -> LittleBinaryValue
GSF.LittleBinaryValue = function(typeCode, buffer);
public:
LittleBinaryValue(
    TypeCode typeCode,
    array<unsigned char>^ buffer
)

Parameters

typeCode
Type: SystemTypeCode
The type code of the native value that the binary value represents.
buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
See Also

Reference

LittleBinaryValue Class
LittleBinaryValue Overload
GSF Namespace


LittleBinaryValue Constructor (Byte[], Int32, Int32)

Grid Solutions Framework LittleBinaryValue Constructor (Byte, Int32, Int32)
Creates a new little-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> LittleBinaryValue
GSF.LittleBinaryValue = function(buffer, startIndex, length);
public:
LittleBinaryValue(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
startIndex
Type: SystemInt32
The offset in the buffer where the data starts.
length
Type: SystemInt32
The number of data bytes that make up the binary value.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null
ArgumentOutOfRangeException | startIndex is outside the range of the buffer -or- length is less than 0 -or- startIndex and length do not specify a valid region in the buffer
Remarks
This constructor assumes a type code of Empty to represent "undefined".
See Also

Reference

LittleBinaryValue Class
LittleBinaryValue Overload
GSF Namespace


LittleBinaryValue Constructor (TypeCode, Byte[], Int32, Int32)

Grid Solutions Framework LittleBinaryValue Constructor (TypeCode, Byte, Int32, Int32)
Creates a new little-endian ordered binary value from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue(
    TypeCode typeCode,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    typeCode As TypeCode,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        typeCode : TypeCode *
        buffer : byte[] *
        startIndex : int *
        length : int -> LittleBinaryValue
GSF.LittleBinaryValue = function(typeCode, buffer, startIndex, length);
public:
LittleBinaryValue(
    TypeCode typeCode,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

typeCode
Type: SystemTypeCode
The type code of the native value that the binary value represents.
buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
startIndex
Type: SystemInt32
The offset in the buffer where the data starts.
length
Type: SystemInt32
The number of data bytes that make up the binary value.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null
ArgumentOutOfRangeException | startIndex is outside the range of the buffer -or- length is less than 0 -or- startIndex and length do not specify a valid region in the buffer
See Also

Reference

LittleBinaryValue Class
LittleBinaryValue Overload
GSF Namespace


LittleBinaryValue Methods

Grid Solutions Framework LittleBinaryValue Methods

The LittleBinaryValue type exposes the following members.

Methods
 | Name | Description
Public method | ConvertToType | Returns a LittleBinaryValue representation of source value converted to specified TypeCode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToString | Returns a String that represents the current LittleBinaryValue. (Overrides ObjectToString.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LittleBinaryValue Class
GSF Namespace


LittleBinaryValue.ConvertToType Method

Grid Solutions Framework LittleBinaryValueConvertToType Method
Returns a LittleBinaryValue representation of source value converted to specified TypeCode.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue ConvertToType(
    TypeCode typeCode
)
Public Function ConvertToType (
    typeCode As TypeCode
) As LittleBinaryValue
member ConvertToType :
        typeCode : TypeCode -> LittleBinaryValue

function ConvertToType(typeCode);
public:
LittleBinaryValue^ ConvertToType(
    TypeCode typeCode
)

Parameters

typeCode
Type: SystemTypeCode
Desired TypeCode for destination value.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of source value converted to specified TypeCode.
Exceptions
Exception | Condition
InvalidOperationException | Unable to convert binary value to specified type.
See Also

Reference

LittleBinaryValue Class
GSF Namespace


LittleBinaryValue.ToString Method

Grid Solutions Framework LittleBinaryValueToString Method
Returns a String that represents the current LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
GSF Namespace


LittleBinaryValue Type Conversions

Grid Solutions Framework LittleBinaryValue Type Conversions
Operators
Name | Description
(Byte to LittleBinaryValue) | Implicitly converts Byte to LittleBinaryValue.
(Double to LittleBinaryValue) | Implicitly converts Double to LittleBinaryValue.
(Int16 to LittleBinaryValue) | Implicitly converts Int16 to LittleBinaryValue.
(Int32 to LittleBinaryValue) | Implicitly converts Int32 to LittleBinaryValue.
(Int64 to LittleBinaryValue) | Implicitly converts Int64 to LittleBinaryValue.
(Single to LittleBinaryValue) | Implicitly converts Single to LittleBinaryValue.
(UInt16 to LittleBinaryValue) | Implicitly converts UInt16 to LittleBinaryValue.
(UInt32 to LittleBinaryValue) | Implicitly converts UInt32 to LittleBinaryValue.
(UInt64 to LittleBinaryValue) | Implicitly converts UInt64 to LittleBinaryValue.
(Int24 to LittleBinaryValue) | Implicitly converts Int24 to LittleBinaryValue.
(LittleBinaryValue to Byte) | Implicitly converts LittleBinaryValue to Byte.
(LittleBinaryValue to Int16) | Implicitly converts LittleBinaryValue to Int16.
(LittleBinaryValue to UInt16) | Implicitly converts LittleBinaryValue to UInt16.
(LittleBinaryValue to Int24) | Implicitly converts LittleBinaryValue to Int24.
(LittleBinaryValue to UInt24) | Implicitly converts LittleBinaryValue to UInt24.
(LittleBinaryValue to Int32) | Implicitly converts LittleBinaryValue to Int32.
(LittleBinaryValue to UInt32) | Implicitly converts LittleBinaryValue to UInt32.
(LittleBinaryValue to Int64) | Implicitly converts LittleBinaryValue to Int64.
(LittleBinaryValue to UInt64) | Implicitly converts LittleBinaryValue to UInt64.
(LittleBinaryValue to Single) | Implicitly converts LittleBinaryValue to Single.
(LittleBinaryValue to Double) | Implicitly converts LittleBinaryValue to Double.
(UInt24 to LittleBinaryValue) | Implicitly converts UInt24 to LittleBinaryValue.
Top
See Also

Reference

LittleBinaryValue Class
GSF Namespace


LittleBinaryValue Implicit Conversion Operators

Grid Solutions Framework LittleBinaryValue Conversion Operators
Overload List
Name | Description
(Byte to LittleBinaryValue) | Implicitly converts Byte to LittleBinaryValue.
(Double to LittleBinaryValue) | Implicitly converts Double to LittleBinaryValue.
(Int16 to LittleBinaryValue) | Implicitly converts Int16 to LittleBinaryValue.
(Int32 to LittleBinaryValue) | Implicitly converts Int32 to LittleBinaryValue.
(Int64 to LittleBinaryValue) | Implicitly converts Int64 to LittleBinaryValue.
(Single to LittleBinaryValue) | Implicitly converts Single to LittleBinaryValue.
(UInt16 to LittleBinaryValue) | Implicitly converts UInt16 to LittleBinaryValue.
(UInt32 to LittleBinaryValue) | Implicitly converts UInt32 to LittleBinaryValue.
(UInt64 to LittleBinaryValue) | Implicitly converts UInt64 to LittleBinaryValue.
(Int24 to LittleBinaryValue) | Implicitly converts Int24 to LittleBinaryValue.
(LittleBinaryValue to Byte) | Implicitly converts LittleBinaryValue to Byte.
(LittleBinaryValue to Int16) | Implicitly converts LittleBinaryValue to Int16.
(LittleBinaryValue to UInt16) | Implicitly converts LittleBinaryValue to UInt16.
(LittleBinaryValue to Int24) | Implicitly converts LittleBinaryValue to Int24.
(LittleBinaryValue to UInt24) | Implicitly converts LittleBinaryValue to UInt24.
(LittleBinaryValue to Int32) | Implicitly converts LittleBinaryValue to Int32.
(LittleBinaryValue to UInt32) | Implicitly converts LittleBinaryValue to UInt32.
(LittleBinaryValue to Int64) | Implicitly converts LittleBinaryValue to Int64.
(LittleBinaryValue to UInt64) | Implicitly converts LittleBinaryValue to UInt64.
(LittleBinaryValue to Single) | Implicitly converts LittleBinaryValue to Single.
(LittleBinaryValue to Double) | Implicitly converts LittleBinaryValue to Double.
(UInt24 to LittleBinaryValue) | Implicitly converts UInt24 to LittleBinaryValue.
Top
See Also

Reference

LittleBinaryValue Class
GSF Namespace


LittleBinaryValue Implicit Conversion (Byte to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (Byte to LittleBinaryValue)
Implicitly converts Byte to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    byte value
)
Public Shared Widening Operator CType (
    value As Byte
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    unsigned char value
)

Parameters

value
Type: SystemByte
Byte to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of Byte.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (Double to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (Double to LittleBinaryValue)
Implicitly converts Double to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    double value
)

Parameters

value
Type: SystemDouble
Double to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of Double.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (Int16 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (Int16 to LittleBinaryValue)
Implicitly converts Int16 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    short value
)
Public Shared Widening Operator CType (
    value As Short
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    short value
)

Parameters

value
Type: SystemInt16
Int16 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of Int16.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (Int32 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (Int32 to LittleBinaryValue)
Implicitly converts Int32 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    int value
)
Public Shared Widening Operator CType (
    value As Integer
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    int value
)

Parameters

value
Type: SystemInt32
Int32 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of Int32.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (Int64 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (Int64 to LittleBinaryValue)
Implicitly converts Int64 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    long value
)
Public Shared Widening Operator CType (
    value As Long
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    long long value
)

Parameters

value
Type: SystemInt64
Int64 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of Int64.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (Single to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (Single to LittleBinaryValue)
Implicitly converts Single to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    float value
)
Public Shared Widening Operator CType (
    value As Single
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    float value
)

Parameters

value
Type: SystemSingle
Single to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of Single.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (UInt16 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (UInt16 to LittleBinaryValue)
Implicitly converts UInt16 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    ushort value
)
Public Shared Widening Operator CType (
    value As UShort
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    unsigned short value
)

Parameters

value
Type: SystemUInt16
UInt16 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of UInt16.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (UInt32 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (UInt32 to LittleBinaryValue)
Implicitly converts UInt32 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    uint value
)
Public Shared Widening Operator CType (
    value As UInteger
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    unsigned int value
)

Parameters

value
Type: SystemUInt32
UInt32 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of UInt32.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (UInt64 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (UInt64 to LittleBinaryValue)
Implicitly converts UInt64 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    ulong value
)
Public Shared Widening Operator CType (
    value As ULong
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
UInt64 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of UInt64.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (Int24 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (Int24 to LittleBinaryValue)
Implicitly converts Int24 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of Int24.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to Byte)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to Byte)
Implicitly converts LittleBinaryValue to Byte.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator byte (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As Byte
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned char (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to Byte.

Return Value

Type: Byte
A Byte representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to Int16)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to Int16)
Implicitly converts LittleBinaryValue to Int16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator short (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As Short
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator short (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to Int16.

Return Value

Type: Int16
A Int16 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to UInt16)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to UInt16)
Implicitly converts LittleBinaryValue to UInt16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ushort (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As UShort
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned short (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to UInt16.

Return Value

Type: UInt16
A UInt16 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to Int24)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to Int24)
Implicitly converts LittleBinaryValue to Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Int24 (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Int24 (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to Int24.

Return Value

Type: Int24
A Int24 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to UInt24)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to UInt24)
Implicitly converts LittleBinaryValue to UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator UInt24 (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator UInt24 (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to UInt24.

Return Value

Type: UInt24
A UInt24 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to Int32)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to Int32)
Implicitly converts LittleBinaryValue to Int32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator int (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As Integer
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator int (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to Int32.

Return Value

Type: Int32
A Int32 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to UInt32)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to UInt32)
Implicitly converts LittleBinaryValue to UInt32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator uint (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As UInteger
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned int (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to UInt32.

Return Value

Type: UInt32
A UInt32 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to Int64)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to Int64)
Implicitly converts LittleBinaryValue to Int64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator long (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As Long
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator long long (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to Int64.

Return Value

Type: Int64
A Int64 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to UInt64)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to UInt64)
Implicitly converts LittleBinaryValue to UInt64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ulong (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As ULong
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned long long (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to UInt64.

Return Value

Type: UInt64
A UInt64 representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to Single)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to Single)
Implicitly converts LittleBinaryValue to Single.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator float (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As Single
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator float (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to Single.

Return Value

Type: Single
A Single representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (LittleBinaryValue to Double)

Grid Solutions Framework LittleBinaryValue Conversion (LittleBinaryValue to Double)
Implicitly converts LittleBinaryValue to Double.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    LittleBinaryValue value
)
Public Shared Widening Operator CType (
    value As LittleBinaryValue
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    LittleBinaryValue^ value
)

Parameters

value
Type: GSFLittleBinaryValue
LittleBinaryValue to convert to Double.

Return Value

Type: Double
A Double representation of LittleBinaryValue.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Implicit Conversion (UInt24 to LittleBinaryValue)

Grid Solutions Framework LittleBinaryValue Conversion (UInt24 to LittleBinaryValue)
Implicitly converts UInt24 to LittleBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator LittleBinaryValue (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As LittleBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator LittleBinaryValue^ (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 to convert to LittleBinaryValue.

Return Value

Type: LittleBinaryValue
A LittleBinaryValue representation of UInt24.
See Also

Reference

LittleBinaryValue Class
Overload
GSF Namespace


LittleBinaryValue Properties

Grid Solutions Framework LittleBinaryValue Properties

The LittleBinaryValue type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample. (Inherited from BinaryValueBaseTEndianOrder.)
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents. (Inherited from BinaryValueBaseTEndianOrder.)
Top
See Also

Reference

LittleBinaryValue Class
GSF Namespace


LittleEndian Class

Grid Solutions Framework LittleEndian Class
Defines a set of little-endian byte order interoperability functions.
Inheritance Hierarchy
SystemObject
GSFLittleEndian

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class LittleEndian
Public NotInheritable Class LittleEndian
[<AbstractClassAttribute>]
[<SealedAttribute>]
type LittleEndian =  class end
GSF.LittleEndian = function();

Type.createClass(
    'GSF.LittleEndian');
public ref class LittleEndian abstract sealed
Methods
Name | Description
CopyBytes(Boolean, Byte*) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte*) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte*) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte*) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte*) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte*) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte*) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte*) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte*) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte*) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte*) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte*) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte*) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte, Int32) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte*) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
GetBytes(Decimal) | Returns the specified 128-bit decimal value as an array of bytes.
GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
ToBoolean(Byte*) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToBoolean(Byte, Int32) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToChar(Byte*) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToChar(Byte, Int32) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte*) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte, Int32) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte*) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte, Int32) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte*) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte, Int32) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte*) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte, Int32) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte*) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte, Int32) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte*) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte, Int32) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte*) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte, Int32) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte*) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte, Int32) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte*) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte, Int32) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte*) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte, Int32) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte*) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte, Int32) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
Remarks
This class is setup to support aggressive in-lining of little endian conversions. Bounds will not be checked as part of this function call, if bounds are violated, the exception will be thrown at the Array level.
See Also

Reference

GSF Namespace


LittleEndian Methods

Grid Solutions Framework LittleEndian Methods
Methods
Name | Description
CopyBytes(Boolean, Byte*) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte*) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte*) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte*) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte*) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte*) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte*) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte*) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte*) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte*) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte*) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte*) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte*) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte, Int32) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte*) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
GetBytes(Decimal) | Returns the specified 128-bit decimal value as an array of bytes.
GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
ToBoolean(Byte*) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToBoolean(Byte, Int32) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToChar(Byte*) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToChar(Byte, Int32) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte*) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte, Int32) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte*) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte, Int32) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte*) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte, Int32) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte*) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte, Int32) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte*) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte, Int32) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte*) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte, Int32) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte*) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte, Int32) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte*) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte, Int32) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte*) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte, Int32) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte*) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte, Int32) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte*) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte, Int32) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.CopyBytes Method

Grid Solutions Framework LittleEndianCopyBytes Method
Overload List
Name | Description
CopyBytes(Boolean, Byte*) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte*) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte*) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte*) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte*) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte*) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte*) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte*) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte*) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte*) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte*) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte*) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte*) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte*) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.
CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Decimal, Byte, Int32) | Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.
CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.
CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.
CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.
CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.
CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.
CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.CopyBytes Method (Boolean, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Boolean, Byte)
Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    bool value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    bool value,
    unsigned char* destination
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Char, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Char, Byte)
Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    char value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    wchar_t value,
    unsigned char* destination
)

Parameters

value
Type: SystemChar
The Unicode character value to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Decimal, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Decimal, Byte)
Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    decimal value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    Decimal value,
    unsigned char* destination
)

Parameters

value
Type: SystemDecimal
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Double, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Double, Byte)
Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    double value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    double value,
    unsigned char* destination
)

Parameters

value
Type: SystemDouble
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int16, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Int16, Byte)
Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    short value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    short value,
    unsigned char* destination
)

Parameters

value
Type: SystemInt16
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int32, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Int32, Byte)
Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    int value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    int value,
    unsigned char* destination
)

Parameters

value
Type: SystemInt32
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int64, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Int64, Byte)
Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    long value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    long long value,
    unsigned char* destination
)

Parameters

value
Type: SystemInt64
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Single, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Single, Byte)
Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    float value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    float value,
    unsigned char* destination
)

Parameters

value
Type: SystemSingle
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt16, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt16, Byte)
Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ushort value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    unsigned short value,
    unsigned char* destination
)

Parameters

value
Type: SystemUInt16
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt32, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt32, Byte)
Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    uint value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    unsigned int value,
    unsigned char* destination
)

Parameters

value
Type: SystemUInt32
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt64, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt64, Byte)
Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ulong value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    unsigned long long value,
    unsigned char* destination
)

Parameters

value
Type: SystemUInt64
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes(T) Method (T, Byte*)

Grid Solutions Framework LittleEndianCopyBytesT Method (T, Byte)
Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes<T>(
    T value,
    byte* destination
)
where T : struct, new(), IConvertible

Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
static int CopyBytes(
    T value,
    unsigned char* destination
)

Parameters

value
Type: T
The Boolean value to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Int32
Length of bytes copied into array based on size of T.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int24, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (Int24, Byte)
Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    Int24 value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    Int24 value,
    unsigned char* destination
)

Parameters

value
Type: GSFInt24
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt24, Byte*)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt24, Byte)
Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    UInt24 value,
    byte* destination
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int CopyBytes(
    UInt24 value,
    unsigned char* destination
)

Parameters

value
Type: GSFUInt24
The number to convert and copy.
destination
Type: SystemByte*
The destination buffer.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Boolean, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Boolean, Byte, Int32)
Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    bool value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Boolean,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : bool *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    bool value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Char, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Char, Byte, Int32)
Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    char value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Char,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : char *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    wchar_t value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemChar
The Unicode character value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Decimal, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Decimal, Byte, Int32)
Copies the specified 128-bit decimal value as an array of 16 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    decimal value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Decimal,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : decimal *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    Decimal value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemDecimal
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Double, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Double, Byte, Int32)
Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    double value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Double,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : float *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    double value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemDouble
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int16, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Int16, Byte, Int32)
Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    short value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Short,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : int16 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    short value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt16
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int32, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Int32, Byte, Int32)
Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    int value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Integer,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : int *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    int value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt32
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int64, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Int64, Byte, Int32)
Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    long value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Long,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : int64 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    long long value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemInt64
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Single, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Single, Byte, Int32)
Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    float value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Single,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : float32 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    float value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemSingle
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt16, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt16, Byte, Int32)
Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ushort value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As UShort,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : uint16 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    unsigned short value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt16
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt32, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt32, Byte, Int32)
Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    uint value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As UInteger,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : uint32 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    unsigned int value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt32
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt64, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt64, Byte, Int32)
Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    ulong value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As ULong,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : uint64 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    unsigned long long value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: SystemUInt64
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes(T) Method (T, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytesT Method (T, Byte, Int32)
Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes<T>(
    T value,
    byte[] destinationArray,
    int destinationIndex
)
where T : struct, new(), IConvertible

Public Shared Function CopyBytes(Of T As {Structure, New, IConvertible}) (
    value As T,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : 'T *
        destinationArray : byte[] *
        destinationIndex : int -> int  when 'T : struct, new() and IConvertible

JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
static int CopyBytes(
    T value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: T
The Boolean value to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Int32
Length of bytes copied into array based on size of T.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (Int24, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (Int24, Byte, Int32)
Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    Int24 value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As Int24,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : Int24 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    Int24 value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: GSFInt24
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.CopyBytes Method (UInt24, Byte[], Int32)

Grid Solutions Framework LittleEndianCopyBytes Method (UInt24, Byte, Int32)
Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CopyBytes(
    UInt24 value,
    byte[] destinationArray,
    int destinationIndex
)
Public Shared Function CopyBytes (
    value As UInt24,
    destinationArray As Byte(),
    destinationIndex As Integer
) As Integer
static member CopyBytes :
        value : UInt24 *
        destinationArray : byte[] *
        destinationIndex : int -> int

GSF.LittleEndian.CopyBytes = function(value, destinationArray, destinationIndex);
public:
static int CopyBytes(
    UInt24 value,
    array<unsigned char>^ destinationArray,
    int destinationIndex
)

Parameters

value
Type: GSFUInt24
The number to convert and copy.
destinationArray
Type: SystemByte
The destination buffer.
destinationIndex
Type: SystemInt32
The byte offset into destinationArray.

Return Value

Type: Int32
Length of bytes copied into array based on size of value.
See Also

Reference

LittleEndian Class
CopyBytes Overload
GSF Namespace


LittleEndian.GetBytes Method

Grid Solutions Framework LittleEndianGetBytes Method
Overload List
Name | Description
GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order.
GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order.
GetBytes(Decimal) | Returns the specified 128-bit decimal value as an array of bytes.
GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order.
GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes.
GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes.
GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes.
GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order.
GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes.
GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes.
GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes.
GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order.
GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes.
GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.GetBytes Method (Boolean)

Grid Solutions Framework LittleEndianGetBytes Method (Boolean)
Returns the specified Boolean value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    bool value
)
Public Shared Function GetBytes (
    value As Boolean
) As Byte()
static member GetBytes :
        value : bool -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    bool value
)

Parameters

value
Type: SystemBoolean
The Boolean value to convert.

Return Value

Type: Byte
An array of bytes with length 1.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Char)

Grid Solutions Framework LittleEndianGetBytes Method (Char)
Returns the specified Unicode character value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    char value
)
Public Shared Function GetBytes (
    value As Char
) As Byte()
static member GetBytes :
        value : char -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    wchar_t value
)

Parameters

value
Type: SystemChar
The Unicode character value to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Decimal)

Grid Solutions Framework LittleEndianGetBytes Method (Decimal)
Returns the specified 128-bit decimal value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    decimal value
)
Public Shared Function GetBytes (
    value As Decimal
) As Byte()
static member GetBytes :
        value : decimal -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    Decimal value
)

Parameters

value
Type: SystemDecimal
The number to convert.

Return Value

Type: Byte
An array of bytes with length 16.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Double)

Grid Solutions Framework LittleEndianGetBytes Method (Double)
Returns the specified double-precision floating point value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    double value
)
Public Shared Function GetBytes (
    value As Double
) As Byte()
static member GetBytes :
        value : float -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    double value
)

Parameters

value
Type: SystemDouble
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Int16)

Grid Solutions Framework LittleEndianGetBytes Method (Int16)
Returns the specified 16-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    short value
)
Public Shared Function GetBytes (
    value As Short
) As Byte()
static member GetBytes :
        value : int16 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    short value
)

Parameters

value
Type: SystemInt16
The number to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Int32)

Grid Solutions Framework LittleEndianGetBytes Method (Int32)
Returns the specified 32-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    int value
)
Public Shared Function GetBytes (
    value As Integer
) As Byte()
static member GetBytes :
        value : int -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    int value
)

Parameters

value
Type: SystemInt32
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Int64)

Grid Solutions Framework LittleEndianGetBytes Method (Int64)
Returns the specified 64-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    long value
)
Public Shared Function GetBytes (
    value As Long
) As Byte()
static member GetBytes :
        value : int64 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    long long value
)

Parameters

value
Type: SystemInt64
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Single)

Grid Solutions Framework LittleEndianGetBytes Method (Single)
Returns the specified single-precision floating point value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    float value
)
Public Shared Function GetBytes (
    value As Single
) As Byte()
static member GetBytes :
        value : float32 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    float value
)

Parameters

value
Type: SystemSingle
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (UInt16)

Grid Solutions Framework LittleEndianGetBytes Method (UInt16)
Returns the specified 16-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    ushort value
)
Public Shared Function GetBytes (
    value As UShort
) As Byte()
static member GetBytes :
        value : uint16 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    unsigned short value
)

Parameters

value
Type: SystemUInt16
The number to convert.

Return Value

Type: Byte
An array of bytes with length 2.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (UInt32)

Grid Solutions Framework LittleEndianGetBytes Method (UInt32)
Returns the specified 32-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    uint value
)
Public Shared Function GetBytes (
    value As UInteger
) As Byte()
static member GetBytes :
        value : uint32 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
The number to convert.

Return Value

Type: Byte
An array of bytes with length 4.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (UInt64)

Grid Solutions Framework LittleEndianGetBytes Method (UInt64)
Returns the specified 64-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    ulong value
)
Public Shared Function GetBytes (
    value As ULong
) As Byte()
static member GetBytes :
        value : uint64 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
The number to convert.

Return Value

Type: Byte
An array of bytes with length 8.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes(T) Method (T)

Grid Solutions Framework LittleEndianGetBytesT Method (T)
Returns the specified value as an array of bytes in the target endian-order.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes<T>(
    T value
)
where T : struct, new(), IConvertible

Public Shared Function GetBytes(Of T As {Structure, New, IConvertible}) (
    value As T
) As Byte()
static member GetBytes :
        value : 'T -> byte[]  when 'T : struct, new() and IConvertible

JavaScript does not support generic types or methods.
public:
generic<typename T>
where T : value class, gcnew(), IConvertible
static array<unsigned char>^ GetBytes(
    T value
)

Parameters

value
Type: T
The value to convert.

Type Parameters

T
Native value type to get bytes for.

Return Value

Type: Byte
An array of bytes with length 1.
Exceptions
Exception | Condition
ArgumentException | value type is not primitive.
InvalidOperationException | Cannot get bytes for value type.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (Int24)

Grid Solutions Framework LittleEndianGetBytes Method (Int24)
Returns the specified 24-bit signed integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    Int24 value
)
Public Shared Function GetBytes (
    value As Int24
) As Byte()
static member GetBytes :
        value : Int24 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    Int24 value
)

Parameters

value
Type: GSFInt24
The number to convert.

Return Value

Type: Byte
An array of bytes with length 3.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.GetBytes Method (UInt24)

Grid Solutions Framework LittleEndianGetBytes Method (UInt24)
Returns the specified 24-bit unsigned integer value as an array of bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    UInt24 value
)
Public Shared Function GetBytes (
    value As UInt24
) As Byte()
static member GetBytes :
        value : UInt24 -> byte[]

GSF.LittleEndian.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
The number to convert.

Return Value

Type: Byte
An array of bytes with length 3.
See Also

Reference

LittleEndian Class
GetBytes Overload
GSF Namespace


LittleEndian.ToBoolean Method

Grid Solutions Framework LittleEndianToBoolean Method
Overload List
Name | Description
ToBoolean(Byte*) | Returns a Boolean value converted from one byte at a specified position in a byte array.
ToBoolean(Byte, Int32) | Returns a Boolean value converted from one byte at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToBoolean Method (Byte*)

Grid Solutions Framework LittleEndianToBoolean Method (Byte)
Returns a Boolean value converted from one byte at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ToBoolean(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static bool ToBoolean(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes.

Return Value

Type: Boolean
true if the byte at startIndex in value is nonzero; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToBoolean Overload
GSF Namespace


LittleEndian.ToBoolean Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToBoolean Method (Byte, Int32)
Returns a Boolean value converted from one byte at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ToBoolean(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToBoolean (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
static member ToBoolean :
        buffer : byte[] *
        startIndex : int -> bool

GSF.LittleEndian.ToBoolean = function(buffer, startIndex);
public:
static bool ToBoolean(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes.
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Boolean
true if the byte at startIndex in value is nonzero; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToBoolean Overload
GSF Namespace


LittleEndian.ToChar Method

Grid Solutions Framework LittleEndianToChar Method
Overload List
Name | Description
ToChar(Byte*) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToChar(Byte, Int32) | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToChar Method (Byte*)

Grid Solutions Framework LittleEndianToChar Method (Byte)
Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static char ToChar(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static wchar_t ToChar(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Char
A character formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToChar Overload
GSF Namespace


LittleEndian.ToChar Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToChar Method (Byte, Int32)
Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static char ToChar(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToChar (
    buffer As Byte(),
    startIndex As Integer
) As Char
static member ToChar :
        buffer : byte[] *
        startIndex : int -> char

GSF.LittleEndian.ToChar = function(buffer, startIndex);
public:
static wchar_t ToChar(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Char
A character formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToChar Overload
GSF Namespace


LittleEndian.ToDecimal Method

Grid Solutions Framework LittleEndianToDecimal Method
Overload List
Name | Description
ToDecimal(Byte*) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
ToDecimal(Byte, Int32) | Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToDecimal Method (Byte*)

Grid Solutions Framework LittleEndianToDecimal Method (Byte)
Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static decimal ToDecimal(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static Decimal ToDecimal(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Decimal
A 128-bit decimal formed by 16 bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToDecimal Overload
GSF Namespace


LittleEndian.ToDecimal Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToDecimal Method (Byte, Int32)
Returns a 128-bit decimal converted from 16 bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static decimal ToDecimal(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToDecimal (
    buffer As Byte(),
    startIndex As Integer
) As Decimal
static member ToDecimal :
        buffer : byte[] *
        startIndex : int -> decimal

GSF.LittleEndian.ToDecimal = function(buffer, startIndex);
public:
static Decimal ToDecimal(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Decimal
A 128-bit decimal formed by 16 bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToDecimal Overload
GSF Namespace


LittleEndian.ToDouble Method

Grid Solutions Framework LittleEndianToDouble Method
Overload List
Name | Description
ToDouble(Byte*) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToDouble(Byte, Int32) | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToDouble Method (Byte*)

Grid Solutions Framework LittleEndianToDouble Method (Byte)
Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ToDouble(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static double ToDouble(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Double
A double-precision floating point number formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToDouble Overload
GSF Namespace


LittleEndian.ToDouble Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToDouble Method (Byte, Int32)
Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ToDouble(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToDouble (
    buffer As Byte(),
    startIndex As Integer
) As Double
static member ToDouble :
        buffer : byte[] *
        startIndex : int -> float

GSF.LittleEndian.ToDouble = function(buffer, startIndex);
public:
static double ToDouble(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Double
A double-precision floating point number formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToDouble Overload
GSF Namespace


LittleEndian.ToInt16 Method

Grid Solutions Framework LittleEndianToInt16 Method
Overload List
Name | Description
ToInt16(Byte*) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt16(Byte, Int32) | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToInt16 Method (Byte*)

Grid Solutions Framework LittleEndianToInt16 Method (Byte)
Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ToInt16(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static short ToInt16(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int16
A 16-bit signed integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt16 Overload
GSF Namespace


LittleEndian.ToInt16 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToInt16 Method (Byte, Int32)
Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short ToInt16(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt16 (
    buffer As Byte(),
    startIndex As Integer
) As Short
static member ToInt16 :
        buffer : byte[] *
        startIndex : int -> int16

GSF.LittleEndian.ToInt16 = function(buffer, startIndex);
public:
static short ToInt16(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int16
A 16-bit signed integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt16 Overload
GSF Namespace


LittleEndian.ToInt24 Method

Grid Solutions Framework LittleEndianToInt24 Method
Overload List
Name | Description
ToInt24(Byte*) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt24(Byte, Int32) | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToInt24 Method (Byte*)

Grid Solutions Framework LittleEndianToInt24 Method (Byte)
Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ToInt24(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static Int24 ToInt24(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int24
A 24-bit signed integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt24 Overload
GSF Namespace


LittleEndian.ToInt24 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToInt24 Method (Byte, Int32)
Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 ToInt24(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt24 (
    buffer As Byte(),
    startIndex As Integer
) As Int24
static member ToInt24 :
        buffer : byte[] *
        startIndex : int -> Int24

GSF.LittleEndian.ToInt24 = function(buffer, startIndex);
public:
static Int24 ToInt24(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int24
A 24-bit signed integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt24 Overload
GSF Namespace


LittleEndian.ToInt32 Method

Grid Solutions Framework LittleEndianToInt32 Method
Overload List
Name | Description
ToInt32(Byte*) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt32(Byte, Int32) | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToInt32 Method (Byte*)

Grid Solutions Framework LittleEndianToInt32 Method (Byte)
Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToInt32(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static int ToInt32(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int32
A 32-bit signed integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt32 Overload
GSF Namespace


LittleEndian.ToInt32 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToInt32 Method (Byte, Int32)
Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ToInt32(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt32 (
    buffer As Byte(),
    startIndex As Integer
) As Integer
static member ToInt32 :
        buffer : byte[] *
        startIndex : int -> int

GSF.LittleEndian.ToInt32 = function(buffer, startIndex);
public:
static int ToInt32(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int32
A 32-bit signed integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt32 Overload
GSF Namespace


LittleEndian.ToInt64 Method

Grid Solutions Framework LittleEndianToInt64 Method
Overload List
Name | Description
ToInt64(Byte*) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToInt64(Byte, Int32) | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToInt64 Method (Byte*)

Grid Solutions Framework LittleEndianToInt64 Method (Byte)
Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ToInt64(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static long long ToInt64(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Int64
A 64-bit signed integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt64 Overload
GSF Namespace


LittleEndian.ToInt64 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToInt64 Method (Byte, Int32)
Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long ToInt64(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToInt64 (
    buffer As Byte(),
    startIndex As Integer
) As Long
static member ToInt64 :
        buffer : byte[] *
        startIndex : int -> int64

GSF.LittleEndian.ToInt64 = function(buffer, startIndex);
public:
static long long ToInt64(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Int64
A 64-bit signed integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToInt64 Overload
GSF Namespace


LittleEndian.ToSingle Method

Grid Solutions Framework LittleEndianToSingle Method
Overload List
Name | Description
ToSingle(Byte*) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToSingle(Byte, Int32) | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToSingle Method (Byte*)

Grid Solutions Framework LittleEndianToSingle Method (Byte)
Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static float ToSingle(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static float ToSingle(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: Single
A single-precision floating point number formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToSingle Overload
GSF Namespace


LittleEndian.ToSingle Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToSingle Method (Byte, Int32)
Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static float ToSingle(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToSingle (
    buffer As Byte(),
    startIndex As Integer
) As Single
static member ToSingle :
        buffer : byte[] *
        startIndex : int -> float32

GSF.LittleEndian.ToSingle = function(buffer, startIndex);
public:
static float ToSingle(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: Single
A single-precision floating point number formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToSingle Overload
GSF Namespace


LittleEndian.ToUInt16 Method

Grid Solutions Framework LittleEndianToUInt16 Method
Overload List
Name | Description
ToUInt16(Byte*) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt16(Byte, Int32) | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToUInt16 Method (Byte*)

Grid Solutions Framework LittleEndianToUInt16 Method (Byte)
Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ToUInt16(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static unsigned short ToUInt16(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt16
A 16-bit unsigned integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt16 Overload
GSF Namespace


LittleEndian.ToUInt16 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToUInt16 Method (Byte, Int32)
Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ToUInt16(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToUInt16 (
    buffer As Byte(),
    startIndex As Integer
) As UShort
static member ToUInt16 :
        buffer : byte[] *
        startIndex : int -> uint16

GSF.LittleEndian.ToUInt16 = function(buffer, startIndex);
public:
static unsigned short ToUInt16(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt16
A 16-bit unsigned integer formed by two bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt16 Overload
GSF Namespace


LittleEndian.ToUInt24 Method

Grid Solutions Framework LittleEndianToUInt24 Method
Overload List
Name | Description
ToUInt24(Byte*) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt24(Byte, Int32) | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToUInt24 Method (Byte*)

Grid Solutions Framework LittleEndianToUInt24 Method (Byte)
Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ToUInt24(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static UInt24 ToUInt24(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt24
A 24-bit unsigned integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt24 Overload
GSF Namespace


LittleEndian.ToUInt24 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToUInt24 Method (Byte, Int32)
Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ToUInt24(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToUInt24 (
    buffer As Byte(),
    startIndex As Integer
) As UInt24
static member ToUInt24 :
        buffer : byte[] *
        startIndex : int -> UInt24

GSF.LittleEndian.ToUInt24 = function(buffer, startIndex);
public:
static UInt24 ToUInt24(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt24
A 24-bit unsigned integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt24 Overload
GSF Namespace


LittleEndian.ToUInt32 Method

Grid Solutions Framework LittleEndianToUInt32 Method
Overload List
Name | Description
ToUInt32(Byte*) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt32(Byte, Int32) | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToUInt32 Method (Byte*)

Grid Solutions Framework LittleEndianToUInt32 Method (Byte)
Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ToUInt32(
    byte* buffer
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static unsigned int ToUInt32(
    unsigned char* buffer
)

Parameters

buffer
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt32
A 32-bit unsigned integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt32 Overload
GSF Namespace


LittleEndian.ToUInt32 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToUInt32 Method (Byte, Int32)
Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ToUInt32(
    byte[] buffer,
    int startIndex
)
Public Shared Function ToUInt32 (
    buffer As Byte(),
    startIndex As Integer
) As UInteger
static member ToUInt32 :
        buffer : byte[] *
        startIndex : int -> uint32

GSF.LittleEndian.ToUInt32 = function(buffer, startIndex);
public:
static unsigned int ToUInt32(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt32
A 32-bit unsigned integer formed by four bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt32 Overload
GSF Namespace


LittleEndian.ToUInt64 Method

Grid Solutions Framework LittleEndianToUInt64 Method
Overload List
Name | Description
ToUInt64(Byte*) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
ToUInt64(Byte, Int32) | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.
Top
See Also

Reference

LittleEndian Class
GSF Namespace


LittleEndian.ToUInt64 Method (Byte*)

Grid Solutions Framework LittleEndianToUInt64 Method (Byte)
Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ToUInt64(
    byte* value
)
Visual Basic does not support APIs that consume or return unsafe types.
F# does not support APIs that consume or return unsafe types.
JavaScript does not support APIs that consume or return unsafe types.
public:
static unsigned long long ToUInt64(
    unsigned char* value
)

Parameters

value
Type: SystemByte*
An array of bytes (i.e., buffer containing binary image of value).

Return Value

Type: UInt64
A 64-bit unsigned integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt64 Overload
GSF Namespace


LittleEndian.ToUInt64 Method (Byte[], Int32)

Grid Solutions Framework LittleEndianToUInt64 Method (Byte, Int32)
Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ToUInt64(
    byte[] value,
    int startIndex
)
Public Shared Function ToUInt64 (
    value As Byte(),
    startIndex As Integer
) As ULong
static member ToUInt64 :
        value : byte[] *
        startIndex : int -> uint64

GSF.LittleEndian.ToUInt64 = function(value, startIndex);
public:
static unsigned long long ToUInt64(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes (i.e., buffer containing binary image of value).
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt64
A 64-bit unsigned integer formed by eight bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentOutOfRangeException | startIndex is less than zero or greater than the length of value minus 1.
See Also

Reference

LittleEndian Class
ToUInt64 Overload
GSF Namespace


LittleEndianOrder Class

Grid Solutions Framework LittleEndianOrder Class
Represents a little-endian byte order interoperability class.
Inheritance Hierarchy
SystemObject
GSFEndianOrder
GSFLittleEndianOrder

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LittleEndianOrder : EndianOrder
Public Class LittleEndianOrder
    Inherits EndianOrder
type LittleEndianOrder =
    class
        inherit EndianOrder
    end
GSF.LittleEndianOrder = function();

Type.createClass(
    'GSF.LittleEndianOrder',
    GSF.EndianOrder);
public ref class LittleEndianOrder : public EndianOrder

The LittleEndianOrder type exposes the following members.

Constructors
 | Name | Description
Public method | LittleEndianOrder | Constructs a new instance of the LittleEndianOrder class.
Top
Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
 | Default | Returns the default instance of the LittleEndianOrder class.
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Top
See Also

Reference

GSF Namespace


LittleEndianOrder Constructor

Grid Solutions Framework LittleEndianOrder Constructor
Constructs a new instance of the LittleEndianOrder class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleEndianOrder()
Public Sub New
new : unit -> LittleEndianOrder
GSF.LittleEndianOrder = function();
public:
LittleEndianOrder()
See Also

Reference

LittleEndianOrder Class
GSF Namespace


LittleEndianOrder Methods

Grid Solutions Framework LittleEndianOrder Methods

The LittleEndianOrder type exposes the following members.

Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LittleEndianOrder Class
GSF Namespace


LittleEndianOrder Properties

Grid Solutions Framework LittleEndianOrder Properties

The LittleEndianOrder type exposes the following members.

Properties
 | Name | Description
 | Default | Returns the default instance of the LittleEndianOrder class.
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Top
See Also

Reference

LittleEndianOrder Class
GSF Namespace


LittleEndianOrder.Default Property

Grid Solutions Framework LittleEndianOrderDefault Property
Returns the default instance of the LittleEndianOrder class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static LittleEndianOrder Default { get; }
Public Shared ReadOnly Property Default As LittleEndianOrder
    Get
static member Default : LittleEndianOrder with get

GSF.LittleEndianOrder.get_Default = function();

public:
static property LittleEndianOrder^ Default {
    LittleEndianOrder^ get ();
}

Property Value

Type: LittleEndianOrder
See Also

Reference

LittleEndianOrder Class
GSF Namespace


NativeBinaryValue Class

Grid Solutions Framework NativeBinaryValue Class
Represents a binary data sample stored as a byte array ordered in the endianness of the OS, but implicitly castable to most common native types.
Inheritance Hierarchy
SystemObject
GSFBinaryValueBase NativeEndianOrder
GSFNativeBinaryValue

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class NativeBinaryValue : BinaryValueBase<NativeEndianOrder>
Public Class NativeBinaryValue
    Inherits BinaryValueBase(Of NativeEndianOrder)
type NativeBinaryValue =
    class
        inherit BinaryValueBase<NativeEndianOrder>
    end
GSF.NativeBinaryValue = function();

Type.createClass(
    'GSF.NativeBinaryValue',
    GSF.BinaryValueBase`1);
public ref class NativeBinaryValue : public BinaryValueBase<NativeEndianOrder^>

The NativeBinaryValue type exposes the following members.

Constructors
 | Name | Description
Public method | NativeBinaryValue(Byte) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Public method | NativeBinaryValue(TypeCode, Byte) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Public method | NativeBinaryValue(Byte, Int32, Int32) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Public method | NativeBinaryValue(TypeCode, Byte, Int32, Int32) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Top
Methods
 | Name | Description
Public method | ConvertToType | Returns a NativeBinaryValue representation of source value converted to specified TypeCode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToString | Returns a String that represents the current NativeBinaryValue. (Overrides ObjectToString.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Top
Operators
Name | Description
(Byte to NativeBinaryValue) | Implicitly converts Byte to NativeBinaryValue.
(Double to NativeBinaryValue) | Implicitly converts Double to NativeBinaryValue.
(Int16 to NativeBinaryValue) | Implicitly converts Int16 to NativeBinaryValue.
(Int32 to NativeBinaryValue) | Implicitly converts Int32 to NativeBinaryValue.
(Int64 to NativeBinaryValue) | Implicitly converts Int64 to NativeBinaryValue.
(Single to NativeBinaryValue) | Implicitly converts Single to NativeBinaryValue.
(UInt16 to NativeBinaryValue) | Implicitly converts UInt16 to NativeBinaryValue.
(UInt32 to NativeBinaryValue) | Implicitly converts UInt32 to NativeBinaryValue.
(UInt64 to NativeBinaryValue) | Implicitly converts UInt64 to NativeBinaryValue.
(Int24 to NativeBinaryValue) | Implicitly converts Int24 to NativeBinaryValue.
(NativeBinaryValue to Byte) | Implicitly converts NativeBinaryValue to Byte.
(NativeBinaryValue to Int16) | Implicitly converts NativeBinaryValue to Int16.
(NativeBinaryValue to UInt16) | Implicitly converts NativeBinaryValue to UInt16.
(NativeBinaryValue to Int24) | Implicitly converts NativeBinaryValue to Int24.
(NativeBinaryValue to UInt24) | Implicitly converts NativeBinaryValue to UInt24.
(NativeBinaryValue to Int32) | Implicitly converts NativeBinaryValue to Int32.
(NativeBinaryValue to UInt32) | Implicitly converts NativeBinaryValue to UInt32.
(NativeBinaryValue to Int64) | Implicitly converts NativeBinaryValue to Int64.
(NativeBinaryValue to UInt64) | Implicitly converts NativeBinaryValue to UInt64.
(NativeBinaryValue to Single) | Implicitly converts NativeBinaryValue to Single.
(NativeBinaryValue to Double) | Implicitly converts NativeBinaryValue to Double.
(UInt24 to NativeBinaryValue) | Implicitly converts UInt24 to NativeBinaryValue.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample. (Inherited from BinaryValueBaseTEndianOrder.)
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents. (Inherited from BinaryValueBaseTEndianOrder.)
Top
See Also

Reference

GSF Namespace


NativeBinaryValue Constructor

Grid Solutions Framework NativeBinaryValue Constructor
Overload List
 | Name | Description
Public method | NativeBinaryValue(Byte) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Public method | NativeBinaryValue(TypeCode, Byte) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Public method | NativeBinaryValue(Byte, Int32, Int32) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Public method | NativeBinaryValue(TypeCode, Byte, Int32, Int32) | Creates a new binary value, ordered in the endianness of the OS, from the given byte array.
Top
See Also

Reference

NativeBinaryValue Class
GSF Namespace


NativeBinaryValue Constructor (Byte[])

Grid Solutions Framework NativeBinaryValue Constructor (Byte)
Creates a new binary value, ordered in the endianness of the OS, from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NativeBinaryValue(
    byte[] buffer
)
Public Sub New (
    buffer As Byte()
)
new :
        buffer : byte[] -> NativeBinaryValue
GSF.NativeBinaryValue = function(buffer);
public:
NativeBinaryValue(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
Remarks
This constructor assumes a type code of Empty to represent "undefined".
See Also

Reference

NativeBinaryValue Class
NativeBinaryValue Overload
GSF Namespace


NativeBinaryValue Constructor (TypeCode, Byte[])

Grid Solutions Framework NativeBinaryValue Constructor (TypeCode, Byte)
Creates a new binary value, ordered in the endianness of the OS, from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NativeBinaryValue(
    TypeCode typeCode,
    byte[] buffer
)
Public Sub New (
    typeCode As TypeCode,
    buffer As Byte()
)
new :
        typeCode : TypeCode *
        buffer : byte[] -> NativeBinaryValue
GSF.NativeBinaryValue = function(typeCode, buffer);
public:
NativeBinaryValue(
    TypeCode typeCode,
    array<unsigned char>^ buffer
)

Parameters

typeCode
Type: SystemTypeCode
The type code of the native value that the binary value represents.
buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
See Also

Reference

NativeBinaryValue Class
NativeBinaryValue Overload
GSF Namespace


NativeBinaryValue Constructor (Byte[], Int32, Int32)

Grid Solutions Framework NativeBinaryValue Constructor (Byte, Int32, Int32)
Creates a new binary value, ordered in the endianness of the OS, from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NativeBinaryValue(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> NativeBinaryValue
GSF.NativeBinaryValue = function(buffer, startIndex, length);
public:
NativeBinaryValue(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
startIndex
Type: SystemInt32
The offset in the buffer where the data starts.
length
Type: SystemInt32
The number of data bytes that make up the binary value.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null
ArgumentOutOfRangeException | startIndex is outside the range of the buffer -or- length is less than 0 -or- startIndex and length do not specify a valid region in the buffer
Remarks
This constructor assumes a type code of Empty to represent "undefined".
See Also

Reference

NativeBinaryValue Class
NativeBinaryValue Overload
GSF Namespace


NativeBinaryValue Constructor (TypeCode, Byte[], Int32, Int32)

Grid Solutions Framework NativeBinaryValue Constructor (TypeCode, Byte, Int32, Int32)
Creates a new binary value, ordered in the endianness of the OS, from the given byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NativeBinaryValue(
    TypeCode typeCode,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    typeCode As TypeCode,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        typeCode : TypeCode *
        buffer : byte[] *
        startIndex : int *
        length : int -> NativeBinaryValue
GSF.NativeBinaryValue = function(typeCode, buffer, startIndex, length);
public:
NativeBinaryValue(
    TypeCode typeCode,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

typeCode
Type: SystemTypeCode
The type code of the native value that the binary value represents.
buffer
Type: SystemByte
The buffer which contains the binary representation of the value.
startIndex
Type: SystemInt32
The offset in the buffer where the data starts.
length
Type: SystemInt32
The number of data bytes that make up the binary value.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null
ArgumentOutOfRangeException | startIndex is outside the range of the buffer -or- length is less than 0 -or- startIndex and length do not specify a valid region in the buffer
See Also

Reference

NativeBinaryValue Class
NativeBinaryValue Overload
GSF Namespace


NativeBinaryValue Methods

Grid Solutions Framework NativeBinaryValue Methods

The NativeBinaryValue type exposes the following members.

Methods
 | Name | Description
Public method | ConvertToType | Returns a NativeBinaryValue representation of source value converted to specified TypeCode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToByte | Returns a byte from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToString | Returns a String that represents the current NativeBinaryValue. (Overrides ObjectToString.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer, accounting for EndianOrder, converted from the Buffer. (Inherited from BinaryValueBaseTEndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

NativeBinaryValue Class
GSF Namespace


NativeBinaryValue.ConvertToType Method

Grid Solutions Framework NativeBinaryValueConvertToType Method
Returns a NativeBinaryValue representation of source value converted to specified TypeCode.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NativeBinaryValue ConvertToType(
    TypeCode typeCode
)
Public Function ConvertToType (
    typeCode As TypeCode
) As NativeBinaryValue
member ConvertToType :
        typeCode : TypeCode -> NativeBinaryValue

function ConvertToType(typeCode);
public:
NativeBinaryValue^ ConvertToType(
    TypeCode typeCode
)

Parameters

typeCode
Type: SystemTypeCode
Desired TypeCode for destination value.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of source value converted to specified TypeCode.
Exceptions
Exception | Condition
InvalidOperationException | Unable to convert binary value to specified type.
See Also

Reference

NativeBinaryValue Class
GSF Namespace


NativeBinaryValue.ToString Method

Grid Solutions Framework NativeBinaryValueToString Method
Returns a String that represents the current NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
GSF Namespace


NativeBinaryValue Type Conversions

Grid Solutions Framework NativeBinaryValue Type Conversions
Operators
Name | Description
(Byte to NativeBinaryValue) | Implicitly converts Byte to NativeBinaryValue.
(Double to NativeBinaryValue) | Implicitly converts Double to NativeBinaryValue.
(Int16 to NativeBinaryValue) | Implicitly converts Int16 to NativeBinaryValue.
(Int32 to NativeBinaryValue) | Implicitly converts Int32 to NativeBinaryValue.
(Int64 to NativeBinaryValue) | Implicitly converts Int64 to NativeBinaryValue.
(Single to NativeBinaryValue) | Implicitly converts Single to NativeBinaryValue.
(UInt16 to NativeBinaryValue) | Implicitly converts UInt16 to NativeBinaryValue.
(UInt32 to NativeBinaryValue) | Implicitly converts UInt32 to NativeBinaryValue.
(UInt64 to NativeBinaryValue) | Implicitly converts UInt64 to NativeBinaryValue.
(Int24 to NativeBinaryValue) | Implicitly converts Int24 to NativeBinaryValue.
(NativeBinaryValue to Byte) | Implicitly converts NativeBinaryValue to Byte.
(NativeBinaryValue to Int16) | Implicitly converts NativeBinaryValue to Int16.
(NativeBinaryValue to UInt16) | Implicitly converts NativeBinaryValue to UInt16.
(NativeBinaryValue to Int24) | Implicitly converts NativeBinaryValue to Int24.
(NativeBinaryValue to UInt24) | Implicitly converts NativeBinaryValue to UInt24.
(NativeBinaryValue to Int32) | Implicitly converts NativeBinaryValue to Int32.
(NativeBinaryValue to UInt32) | Implicitly converts NativeBinaryValue to UInt32.
(NativeBinaryValue to Int64) | Implicitly converts NativeBinaryValue to Int64.
(NativeBinaryValue to UInt64) | Implicitly converts NativeBinaryValue to UInt64.
(NativeBinaryValue to Single) | Implicitly converts NativeBinaryValue to Single.
(NativeBinaryValue to Double) | Implicitly converts NativeBinaryValue to Double.
(UInt24 to NativeBinaryValue) | Implicitly converts UInt24 to NativeBinaryValue.
Top
See Also

Reference

NativeBinaryValue Class
GSF Namespace


NativeBinaryValue Implicit Conversion Operators

Grid Solutions Framework NativeBinaryValue Conversion Operators
Overload List
Name | Description
(Byte to NativeBinaryValue) | Implicitly converts Byte to NativeBinaryValue.
(Double to NativeBinaryValue) | Implicitly converts Double to NativeBinaryValue.
(Int16 to NativeBinaryValue) | Implicitly converts Int16 to NativeBinaryValue.
(Int32 to NativeBinaryValue) | Implicitly converts Int32 to NativeBinaryValue.
(Int64 to NativeBinaryValue) | Implicitly converts Int64 to NativeBinaryValue.
(Single to NativeBinaryValue) | Implicitly converts Single to NativeBinaryValue.
(UInt16 to NativeBinaryValue) | Implicitly converts UInt16 to NativeBinaryValue.
(UInt32 to NativeBinaryValue) | Implicitly converts UInt32 to NativeBinaryValue.
(UInt64 to NativeBinaryValue) | Implicitly converts UInt64 to NativeBinaryValue.
(Int24 to NativeBinaryValue) | Implicitly converts Int24 to NativeBinaryValue.
(NativeBinaryValue to Byte) | Implicitly converts NativeBinaryValue to Byte.
(NativeBinaryValue to Int16) | Implicitly converts NativeBinaryValue to Int16.
(NativeBinaryValue to UInt16) | Implicitly converts NativeBinaryValue to UInt16.
(NativeBinaryValue to Int24) | Implicitly converts NativeBinaryValue to Int24.
(NativeBinaryValue to UInt24) | Implicitly converts NativeBinaryValue to UInt24.
(NativeBinaryValue to Int32) | Implicitly converts NativeBinaryValue to Int32.
(NativeBinaryValue to UInt32) | Implicitly converts NativeBinaryValue to UInt32.
(NativeBinaryValue to Int64) | Implicitly converts NativeBinaryValue to Int64.
(NativeBinaryValue to UInt64) | Implicitly converts NativeBinaryValue to UInt64.
(NativeBinaryValue to Single) | Implicitly converts NativeBinaryValue to Single.
(NativeBinaryValue to Double) | Implicitly converts NativeBinaryValue to Double.
(UInt24 to NativeBinaryValue) | Implicitly converts UInt24 to NativeBinaryValue.
Top
See Also

Reference

NativeBinaryValue Class
GSF Namespace


NativeBinaryValue Implicit Conversion (Byte to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (Byte to NativeBinaryValue)
Implicitly converts Byte to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    byte value
)
Public Shared Widening Operator CType (
    value As Byte
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    unsigned char value
)

Parameters

value
Type: SystemByte
Byte to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of Byte.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (Double to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (Double to NativeBinaryValue)
Implicitly converts Double to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    double value
)

Parameters

value
Type: SystemDouble
Double to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of Double.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (Int16 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (Int16 to NativeBinaryValue)
Implicitly converts Int16 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    short value
)
Public Shared Widening Operator CType (
    value As Short
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    short value
)

Parameters

value
Type: SystemInt16
Int16 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of Int16.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (Int32 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (Int32 to NativeBinaryValue)
Implicitly converts Int32 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    int value
)
Public Shared Widening Operator CType (
    value As Integer
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    int value
)

Parameters

value
Type: SystemInt32
Int32 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of Int32.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (Int64 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (Int64 to NativeBinaryValue)
Implicitly converts Int64 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    long value
)
Public Shared Widening Operator CType (
    value As Long
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    long long value
)

Parameters

value
Type: SystemInt64
Int64 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of Int64.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (Single to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (Single to NativeBinaryValue)
Implicitly converts Single to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    float value
)
Public Shared Widening Operator CType (
    value As Single
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    float value
)

Parameters

value
Type: SystemSingle
Single to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of Single.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (UInt16 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (UInt16 to NativeBinaryValue)
Implicitly converts UInt16 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    ushort value
)
Public Shared Widening Operator CType (
    value As UShort
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    unsigned short value
)

Parameters

value
Type: SystemUInt16
UInt16 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of UInt16.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (UInt32 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (UInt32 to NativeBinaryValue)
Implicitly converts UInt32 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    uint value
)
Public Shared Widening Operator CType (
    value As UInteger
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    unsigned int value
)

Parameters

value
Type: SystemUInt32
UInt32 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of UInt32.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (UInt64 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (UInt64 to NativeBinaryValue)
Implicitly converts UInt64 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    ulong value
)
Public Shared Widening Operator CType (
    value As ULong
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
UInt64 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of UInt64.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (Int24 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (Int24 to NativeBinaryValue)
Implicitly converts Int24 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    Int24 value
)
Public Shared Widening Operator CType (
    value As Int24
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of Int24.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to Byte)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to Byte)
Implicitly converts NativeBinaryValue to Byte.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator byte (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As Byte
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned char (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to Byte.

Return Value

Type: Byte
A Byte representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to Int16)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to Int16)
Implicitly converts NativeBinaryValue to Int16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator short (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As Short
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator short (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to Int16.

Return Value

Type: Int16
A Int16 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to UInt16)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to UInt16)
Implicitly converts NativeBinaryValue to UInt16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ushort (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As UShort
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned short (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to UInt16.

Return Value

Type: UInt16
A UInt16 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to Int24)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to Int24)
Implicitly converts NativeBinaryValue to Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Int24 (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Int24 (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to Int24.

Return Value

Type: Int24
A Int24 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to UInt24)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to UInt24)
Implicitly converts NativeBinaryValue to UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator UInt24 (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator UInt24 (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to UInt24.

Return Value

Type: UInt24
A UInt24 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to Int32)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to Int32)
Implicitly converts NativeBinaryValue to Int32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator int (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As Integer
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator int (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to Int32.

Return Value

Type: Int32
A Int32 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to UInt32)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to UInt32)
Implicitly converts NativeBinaryValue to UInt32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator uint (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As UInteger
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned int (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to UInt32.

Return Value

Type: UInt32
A UInt32 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to Int64)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to Int64)
Implicitly converts NativeBinaryValue to Int64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator long (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As Long
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator long long (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to Int64.

Return Value

Type: Int64
A Int64 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to UInt64)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to UInt64)
Implicitly converts NativeBinaryValue to UInt64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ulong (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As ULong
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned long long (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to UInt64.

Return Value

Type: UInt64
A UInt64 representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to Single)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to Single)
Implicitly converts NativeBinaryValue to Single.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator float (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As Single
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator float (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to Single.

Return Value

Type: Single
A Single representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (NativeBinaryValue to Double)

Grid Solutions Framework NativeBinaryValue Conversion (NativeBinaryValue to Double)
Implicitly converts NativeBinaryValue to Double.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    NativeBinaryValue value
)
Public Shared Widening Operator CType (
    value As NativeBinaryValue
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    NativeBinaryValue^ value
)

Parameters

value
Type: GSFNativeBinaryValue
NativeBinaryValue to convert to Double.

Return Value

Type: Double
A Double representation of NativeBinaryValue.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Implicit Conversion (UInt24 to NativeBinaryValue)

Grid Solutions Framework NativeBinaryValue Conversion (UInt24 to NativeBinaryValue)
Implicitly converts UInt24 to NativeBinaryValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NativeBinaryValue (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As NativeBinaryValue
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NativeBinaryValue^ (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 to convert to NativeBinaryValue.

Return Value

Type: NativeBinaryValue
A NativeBinaryValue representation of UInt24.
See Also

Reference

NativeBinaryValue Class
Overload
GSF Namespace


NativeBinaryValue Properties

Grid Solutions Framework NativeBinaryValue Properties

The NativeBinaryValue type exposes the following members.

Properties
 | Name | Description
Public property | Buffer | Gets or sets the binary representation of this data sample. (Inherited from BinaryValueBaseTEndianOrder.)
Public property | TypeCode | Gets or sets TypeCode that this binary data sample represents. (Inherited from BinaryValueBaseTEndianOrder.)
Top
See Also

Reference

NativeBinaryValue Class
GSF Namespace


NativeEndianOrder Class

Grid Solutions Framework NativeEndianOrder Class
Represents a native-endian byte order interoperability class.
Inheritance Hierarchy
SystemObject
GSFEndianOrder
GSFNativeEndianOrder

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class NativeEndianOrder : EndianOrder
Public Class NativeEndianOrder
    Inherits EndianOrder
type NativeEndianOrder =
    class
        inherit EndianOrder
    end
GSF.NativeEndianOrder = function();

Type.createClass(
    'GSF.NativeEndianOrder',
    GSF.EndianOrder);
public ref class NativeEndianOrder : public EndianOrder

The NativeEndianOrder type exposes the following members.

Constructors
 | Name | Description
Public method | NativeEndianOrder | Constructs a new instance of the NativeEndianOrder class.
Top
Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
 | Default | Returns the default instance of the NativeEndianOrder class.
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Top
See Also

Reference

GSF Namespace


NativeEndianOrder Constructor

Grid Solutions Framework NativeEndianOrder Constructor
Constructs a new instance of the NativeEndianOrder class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NativeEndianOrder()
Public Sub New
new : unit -> NativeEndianOrder
GSF.NativeEndianOrder = function();
public:
NativeEndianOrder()
See Also

Reference

NativeEndianOrder Class
GSF Namespace


NativeEndianOrder Methods

Grid Solutions Framework NativeEndianOrder Methods

The NativeEndianOrder type exposes the following members.

Methods
 | Name | Description
Public method | CoerceByteOrder | Obsolete. Changes the order of a buffer (reverse or pass-through) based on the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBuffer | Obsolete. Copies a buffer in the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Public method | CopyBytes(Boolean, Byte, Int32) | Copies the specified Boolean value as an array of 1 byte in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Char, Byte, Int32) | Copies the specified Unicode character value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Double, Byte, Int32) | Copies the specified double-precision floating point value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Guid, Byte, Int32) | Obsolete. Copies the specified Guid value as an array of 16 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int16, Byte, Int32) | Copies the specified 16-bit signed integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int32, Byte, Int32) | Copies the specified 32-bit signed integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int64, Byte, Int32) | Copies the specified 64-bit signed integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Single, Byte, Int32) | Copies the specified single-precision floating point value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt16, Byte, Int32) | Copies the specified 16-bit unsigned integer value as an array of 2 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt32, Byte, Int32) | Copies the specified 32-bit unsigned integer value as an array of 4 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt64, Byte, Int32) | Copies the specified 64-bit unsigned integer value as an array of 8 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(Int24, Byte, Int32) | Copies the specified 24-bit signed integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytes(UInt24, Byte, Int32) | Copies the specified 24-bit unsigned integer value as an array of 3 bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | CopyBytesT(T, Byte, Int32) | Copies the specified primitive type value as an array of bytes in the target endian-order to the destination array. (Inherited from EndianOrder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBytes(Boolean) | Returns the specified Boolean value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Char) | Returns the specified Unicode character value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Double) | Returns the specified double-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(Guid) | Obsolete. Returns the specified Guid value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int16) | Returns the specified 16-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int32) | Returns the specified 32-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int64) | Returns the specified 64-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Single) | Returns the specified single-precision floating point value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetBytes(UInt16) | Returns the specified 16-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt32) | Returns the specified 32-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt64) | Returns the specified 64-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(Int24) | Returns the specified 24-bit signed integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytes(UInt24) | Returns the specified 24-bit unsigned integer value as an array of bytes. (Inherited from EndianOrder.)
Public method | GetBytesT(T) | Returns the specified value as an array of bytes in the target endian-order. (Inherited from EndianOrder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToBoolean | Returns a Boolean value converted from one byte at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToChar | Returns a Unicode character converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToDouble | Returns a double-precision floating point number converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToGuid | Obsolete. Returns a Guid converted from sixteen bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt16 | Returns a 16-bit signed integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt24 | Returns a 24-bit signed integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt32 | Returns a 32-bit signed integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToInt64 | Returns a 64-bit signed integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToSingle | Returns a single-precision floating point number converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ToUInt16 | Returns a 16-bit unsigned integer converted from two bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt24 | Returns a 24-bit unsigned integer converted from three bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt32 | Returns a 32-bit unsigned integer converted from four bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Public method | ToUInt64 | Returns a 64-bit unsigned integer converted from eight bytes, accounting for target endian-order, at a specified position in a byte array. (Inherited from EndianOrder.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

NativeEndianOrder Class
GSF Namespace


NativeEndianOrder Properties

Grid Solutions Framework NativeEndianOrder Properties

The NativeEndianOrder type exposes the following members.

Properties
 | Name | Description
 | Default | Returns the default instance of the NativeEndianOrder class.
Public property | TargetEndianness | Returns the target endian-order of this EndianOrder representation. (Inherited from EndianOrder.)
Top
See Also

Reference

NativeEndianOrder Class
GSF Namespace


NativeEndianOrder.Default Property

Grid Solutions Framework NativeEndianOrderDefault Property
Returns the default instance of the NativeEndianOrder class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static NativeEndianOrder Default { get; }
Public Shared ReadOnly Property Default As NativeEndianOrder
    Get
static member Default : NativeEndianOrder with get

GSF.NativeEndianOrder.get_Default = function();

public:
static property NativeEndianOrder^ Default {
    NativeEndianOrder^ get ();
}

Property Value

Type: NativeEndianOrder
See Also

Reference

NativeEndianOrder Class
GSF Namespace


NtpTimeTag Class

Grid Solutions Framework NtpTimeTag Class
Represents a standard Network Time Protocol (NTP) timetag.
Inheritance Hierarchy
SystemObject
GSFTimeTagBase
GSFNtpTimeTag

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class NtpTimeTag : TimeTagBase
<SerializableAttribute>
Public Class NtpTimeTag
    Inherits TimeTagBase
[<SerializableAttribute>]
type NtpTimeTag =
    class
        inherit TimeTagBase
    end
GSF.NtpTimeTag = function();

Type.createClass(
    'GSF.NtpTimeTag',
    GSF.TimeTagBase);
[SerializableAttribute]
public ref class NtpTimeTag : public TimeTagBase

The NtpTimeTag type exposes the following members.

Constructors
 | Name | Description
Public method | NtpTimeTag(Double) | Creates a new NtpTimeTag, given number of seconds since 1/1/1900.
Public method | NtpTimeTag(UInt64) | Creates a new NtpTimeTag, given 64-bit NTP timestamp.
Public method | NtpTimeTag(Ticks) | Creates a new NtpTimeTag, given specified Ticks.
Protected method | NtpTimeTag(SerializationInfo, StreamingContext) | Creates a new NtpTimeTag from serialization parameters.
Public method | NtpTimeTag(UInt32, UInt32) | Creates a new NtpTimeTag, given number of seconds and fractional seconds since 1/1/1900.
Top
Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime. (Inherited from TimeTagBase.)
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object. (Inherited from TimeTagBase.)
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromTicks | Gets 64-bit NTP timestamp given timestamp in Ticks.
 | GetBaseDateOffsetTicks(Double) | Gets proper NTP offset based on seconds value, see RFC-2030.
 | GetBaseDateOffsetTicks(UInt32) | Gets proper NTP offset based on most significant byte on seconds value, see RFC-2030.
 | GetBaseDateOffsetTicks(Ticks) | Gets proper NTP offset based on timestamp value, see RFC-2030.
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from TimeTagBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString | Returns basic textual representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider. (Inherited from TimeTagBase.)
Public method | ToString(String) | Returns textual representation for timetag in the specified format. (Inherited from TimeTagBase.)
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider. (Inherited from TimeTagBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
AlternateBaseTicks | Number of ticks since since 2/7/2036 at 6h 28m 16s UTC when MSB is set.
BaseTicks | Number of ticks since 1/1/1900.
Top
Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation. (Inherited from TimeTagBase.)
Public property | Timestamp | Gets 64-bit NTP timestamp.
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time. (Inherited from TimeTagBase.)
Top
Remarks
As recommended by RFC-2030, all NTP timestamps earlier than 3h 14m 08s UTC on 20 January 1968 are reckoned from 6h 28m 16s UTC on 7 February 2036. This gives the NtpTimeTag class a functioning range of 1968-01-20 03:14:08 to 2104-02-26 09:42:23.
See Also

Reference

GSF Namespace


NtpTimeTag Constructor

Grid Solutions Framework NtpTimeTag Constructor
Overload List
 | Name | Description
Public method | NtpTimeTag(Double) | Creates a new NtpTimeTag, given number of seconds since 1/1/1900.
Public method | NtpTimeTag(UInt64) | Creates a new NtpTimeTag, given 64-bit NTP timestamp.
Public method | NtpTimeTag(Ticks) | Creates a new NtpTimeTag, given specified Ticks.
Protected method | NtpTimeTag(SerializationInfo, StreamingContext) | Creates a new NtpTimeTag from serialization parameters.
Public method | NtpTimeTag(UInt32, UInt32) | Creates a new NtpTimeTag, given number of seconds and fractional seconds since 1/1/1900.
Top
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag Constructor (Double)

Grid Solutions Framework NtpTimeTag Constructor (Double)
Creates a new NtpTimeTag, given number of seconds since 1/1/1900.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag(
    double seconds
)
Public Sub New (
    seconds As Double
)
new :
        seconds : float -> NtpTimeTag
GSF.NtpTimeTag = function(seconds);
public:
NtpTimeTag(
    double seconds
)

Parameters

seconds
Type: SystemDouble
Number of seconds since 1/1/1900.
See Also

Reference

NtpTimeTag Class
NtpTimeTag Overload
GSF Namespace


NtpTimeTag Constructor (UInt64)

Grid Solutions Framework NtpTimeTag Constructor (UInt64)
Creates a new NtpTimeTag, given 64-bit NTP timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag(
    ulong timestamp
)
Public Sub New (
    timestamp As ULong
)
new :
        timestamp : uint64 -> NtpTimeTag
GSF.NtpTimeTag = function(timestamp);
public:
NtpTimeTag(
    unsigned long long timestamp
)

Parameters

timestamp
Type: SystemUInt64
NTP timestamp containing number of seconds since 1/1/1900 in high-word and fractional seconds in low-word.
See Also

Reference

NtpTimeTag Class
NtpTimeTag Overload
GSF Namespace


NtpTimeTag Constructor (Ticks)

Grid Solutions Framework NtpTimeTag Constructor (Ticks)
Creates a new NtpTimeTag, given specified Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag(
    Ticks timestamp
)
Public Sub New (
    timestamp As Ticks
)
new :
        timestamp : Ticks -> NtpTimeTag
GSF.NtpTimeTag = function(timestamp);
public:
NtpTimeTag(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp in Ticks to create Unix timetag from (minimum valid date is 1/1/1900).
Remarks
This constructor will accept a DateTime parameter since Ticks is implicitly castable to a DateTime.
See Also

Reference

NtpTimeTag Class
NtpTimeTag Overload
GSF Namespace


NtpTimeTag Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework NtpTimeTag Constructor (SerializationInfo, StreamingContext)
Creates a new NtpTimeTag from serialization parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected NtpTimeTag(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> NtpTimeTag
GSF.NtpTimeTag = function(info, context);
protected:
NtpTimeTag(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

NtpTimeTag Class
NtpTimeTag Overload
GSF Namespace


NtpTimeTag Constructor (UInt32, UInt32)

Grid Solutions Framework NtpTimeTag Constructor (UInt32, UInt32)
Creates a new NtpTimeTag, given number of seconds and fractional seconds since 1/1/1900.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag(
    uint seconds,
    uint fraction
)
Public Sub New (
    seconds As UInteger,
    fraction As UInteger
)
new :
        seconds : uint32 *
        fraction : uint32 -> NtpTimeTag
GSF.NtpTimeTag = function(seconds, fraction);
public:
NtpTimeTag(
    unsigned int seconds,
    unsigned int fraction
)

Parameters

seconds
Type: SystemUInt32
Number of seconds since 1/1/1900.
fraction
Type: SystemUInt32
Number of fractional seconds, in whole picoseconds.
See Also

Reference

NtpTimeTag Class
NtpTimeTag Overload
GSF Namespace


NtpTimeTag Fields

Grid Solutions Framework NtpTimeTag Fields

The NtpTimeTag type exposes the following members.

Fields
Name | Description
AlternateBaseTicks | Number of ticks since since 2/7/2036 at 6h 28m 16s UTC when MSB is set.
BaseTicks | Number of ticks since 1/1/1900.
Top
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag.AlternateBaseTicks Field

Grid Solutions Framework NtpTimeTagAlternateBaseTicks Field
Number of ticks since since 2/7/2036 at 6h 28m 16s UTC when MSB is set.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Ticks AlternateBaseTicks
Public Shared ReadOnly AlternateBaseTicks As Ticks
static val AlternateBaseTicks: Ticks
var GSF.NtpTimeTag.AlternateBaseTicks
public:
static initonly Ticks AlternateBaseTicks

Field Value

Type: Ticks
Remarks
According to RFC-2030, NTP dates can also be measured as the number of seconds since 2/7/2036 at 6h 28m 16s UTC if MSB is set.
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag.BaseTicks Field

Grid Solutions Framework NtpTimeTagBaseTicks Field
Number of ticks since 1/1/1900.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Ticks BaseTicks
Public Shared ReadOnly BaseTicks As Ticks
static val BaseTicks: Ticks
var GSF.NtpTimeTag.BaseTicks
public:
static initonly Ticks BaseTicks

Field Value

Type: Ticks
Remarks
NTP dates are measured as the number of seconds since 1/1/1900.
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag Methods

Grid Solutions Framework NtpTimeTag Methods

The NtpTimeTag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime. (Inherited from TimeTagBase.)
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object. (Inherited from TimeTagBase.)
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromTicks | Gets 64-bit NTP timestamp given timestamp in Ticks.
 | GetBaseDateOffsetTicks(Double) | Gets proper NTP offset based on seconds value, see RFC-2030.
 | GetBaseDateOffsetTicks(UInt32) | Gets proper NTP offset based on most significant byte on seconds value, see RFC-2030.
 | GetBaseDateOffsetTicks(Ticks) | Gets proper NTP offset based on timestamp value, see RFC-2030.
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from TimeTagBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString | Returns basic textual representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider. (Inherited from TimeTagBase.)
Public method | ToString(String) | Returns textual representation for timetag in the specified format. (Inherited from TimeTagBase.)
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider. (Inherited from TimeTagBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag.FromTicks Method

Grid Solutions Framework NtpTimeTagFromTicks Method
Gets 64-bit NTP timestamp given timestamp in Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong FromTicks(
    Ticks timestamp
)
Public Shared Function FromTicks (
    timestamp As Ticks
) As ULong
static member FromTicks :
        timestamp : Ticks -> uint64

GSF.NtpTimeTag.FromTicks = function(timestamp);
public:
static unsigned long long FromTicks(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp in Ticks.

Return Value

Type: UInt64
Seconds in NTP from given timestamp.
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag.GetBaseDateOffsetTicks Method

Grid Solutions Framework NtpTimeTagGetBaseDateOffsetTicks Method
Overload List
Name | Description
GetBaseDateOffsetTicks(Double) | Gets proper NTP offset based on seconds value, see RFC-2030.
GetBaseDateOffsetTicks(UInt32) | Gets proper NTP offset based on most significant byte on seconds value, see RFC-2030.
GetBaseDateOffsetTicks(Ticks) | Gets proper NTP offset based on timestamp value, see RFC-2030.
Top
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag.GetBaseDateOffsetTicks Method (Double)

Grid Solutions Framework NtpTimeTagGetBaseDateOffsetTicks Method (Double)
Gets proper NTP offset based on seconds value, see RFC-2030.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GetBaseDateOffsetTicks(
    double seconds
)
Public Shared Function GetBaseDateOffsetTicks (
    seconds As Double
) As Long
static member GetBaseDateOffsetTicks :
        seconds : float -> int64

GSF.NtpTimeTag.GetBaseDateOffsetTicks = function(seconds);
public:
static long long GetBaseDateOffsetTicks(
    double seconds
)

Parameters

seconds
Type: SystemDouble
Seconds value.

Return Value

Type: Int64
Proper NTP offset.
See Also

Reference

NtpTimeTag Class
GetBaseDateOffsetTicks Overload
GSF Namespace


NtpTimeTag.GetBaseDateOffsetTicks Method (UInt32)

Grid Solutions Framework NtpTimeTagGetBaseDateOffsetTicks Method (UInt32)
Gets proper NTP offset based on most significant byte on seconds value, see RFC-2030.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GetBaseDateOffsetTicks(
    uint seconds
)
Public Shared Function GetBaseDateOffsetTicks (
    seconds As UInteger
) As Long
static member GetBaseDateOffsetTicks :
        seconds : uint32 -> int64

GSF.NtpTimeTag.GetBaseDateOffsetTicks = function(seconds);
public:
static long long GetBaseDateOffsetTicks(
    unsigned int seconds
)

Parameters

seconds
Type: SystemUInt32
NTP seconds timestamp value.

Return Value

Type: Int64
Proper NTP offset.
See Also

Reference

NtpTimeTag Class
GetBaseDateOffsetTicks Overload
GSF Namespace


NtpTimeTag.GetBaseDateOffsetTicks Method (Ticks)

Grid Solutions Framework NtpTimeTagGetBaseDateOffsetTicks Method (Ticks)
Gets proper NTP offset based on timestamp value, see RFC-2030.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GetBaseDateOffsetTicks(
    Ticks timestamp
)
Public Shared Function GetBaseDateOffsetTicks (
    timestamp As Ticks
) As Long
static member GetBaseDateOffsetTicks :
        timestamp : Ticks -> int64

GSF.NtpTimeTag.GetBaseDateOffsetTicks = function(timestamp);
public:
static long long GetBaseDateOffsetTicks(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Ticks timestamp value.

Return Value

Type: Int64
Proper NTP offset.
See Also

Reference

NtpTimeTag Class
GetBaseDateOffsetTicks Overload
GSF Namespace


NtpTimeTag Properties

Grid Solutions Framework NtpTimeTag Properties

The NtpTimeTag type exposes the following members.

Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation. (Inherited from TimeTagBase.)
Public property | Timestamp | Gets 64-bit NTP timestamp.
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time. (Inherited from TimeTagBase.)
Top
See Also

Reference

NtpTimeTag Class
GSF Namespace


NtpTimeTag.Timestamp Property

Grid Solutions Framework NtpTimeTagTimestamp Property
Gets 64-bit NTP timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong Timestamp { get; }
Public ReadOnly Property Timestamp As ULong
    Get
member Timestamp : uint64 with get

function get_Timestamp();

public:
property unsigned long long Timestamp {
    unsigned long long get ();
}

Property Value

Type: UInt64
See Also

Reference

NtpTimeTag Class
GSF Namespace


NumericExtensions Class

Grid Solutions Framework NumericExtensions Class
Defines extension functions related to numbers.
Inheritance Hierarchy
SystemObject
GSFNumericExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class NumericExtensions
<ExtensionAttribute>
Public NotInheritable Class NumericExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NumericExtensions =  class end
GSF.NumericExtensions = function();

Type.createClass(
    'GSF.NumericExtensions');
[ExtensionAttribute]
public ref class NumericExtensions abstract sealed

The NumericExtensions type exposes the following members.

Methods
Name | Description
NotEqualToT | Ensures test parameter passed to function is not equal to the specified value.
NotGreaterThanT(T, T) | Ensures test parameter passed to function is not greater than the specified value.
NotGreaterThanT(T, T, T) | Ensures test parameter passed to function is not greater than the specified value.
NotGreaterThanOrEqualToT | Ensures test parameter passed to function is not greater than or equal to the specified value.
NotLessThanT(T, T) | Ensures test parameter passed to function is not less than the specified value.
NotLessThanT(T, T, T) | Ensures test parameter passed to function is not less than the specified value.
NotLessThanOrEqualToT | Ensures test parameter passed to function is not less than or equal to the specified value.
NotZeroT(T) | Ensures parameter passed to function is not zero. Returns -1 if source is zero.
NotZeroT(T, T) | Ensures parameter passed to function is not zero.
Top
See Also

Reference

GSF Namespace


NumericExtensions Methods

Grid Solutions Framework NumericExtensions Methods

The NumericExtensions type exposes the following members.

Methods
Name | Description
NotEqualToT | Ensures test parameter passed to function is not equal to the specified value.
NotGreaterThanT(T, T) | Ensures test parameter passed to function is not greater than the specified value.
NotGreaterThanT(T, T, T) | Ensures test parameter passed to function is not greater than the specified value.
NotGreaterThanOrEqualToT | Ensures test parameter passed to function is not greater than or equal to the specified value.
NotLessThanT(T, T) | Ensures test parameter passed to function is not less than the specified value.
NotLessThanT(T, T, T) | Ensures test parameter passed to function is not less than the specified value.
NotLessThanOrEqualToT | Ensures test parameter passed to function is not less than or equal to the specified value.
NotZeroT(T) | Ensures parameter passed to function is not zero. Returns -1 if source is zero.
NotZeroT(T, T) | Ensures parameter passed to function is not zero.
Top
See Also

Reference

NumericExtensions Class
GSF Namespace


NumericExtensions.NotEqualTo(T) Method

Grid Solutions Framework NumericExtensionsNotEqualToT Method
Ensures test parameter passed to function is not equal to the specified value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotEqualTo<T>(
    this T source,
    T notEqualToValue,
    T alternateValue
)
where T : Object, IEquatable<T>

<ExtensionAttribute>
Public Shared Function NotEqualTo(Of T As {Object, IEquatable(Of T)}) (
    source As T,
    notEqualToValue As T,
    alternateValue As T
) As T
static member NotEqualTo :
        source : 'T *
        notEqualToValue : 'T *
        alternateValue : 'T -> 'T  when 'T : Object and IEquatable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IEquatable<T>
static T NotEqualTo(
    T source,
    T notEqualToValue,
    T alternateValue
)

Parameters

source
Type: T
Value to test.
notEqualToValue
Type: T
Value that represents the undesired value (e.g., zero).
alternateValue
Type: T
Value to return if source is equal to the undesired value.

Type Parameters

T
Structure or class that implements IEquatable(Of T) (e.g., Double, Single, Integer, etc.).

Return Value

Type: T
A value not equal to notEqualToValue.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
To optimize performance, this function does not validate that the notEqualToValue is not equal to the alternateValue.
See Also

Reference

NumericExtensions Class
GSF Namespace


NumericExtensions.NotGreaterThan Method

Grid Solutions Framework NumericExtensionsNotGreaterThan Method
Overload List
Name | Description
NotGreaterThanT(T, T) | Ensures test parameter passed to function is not greater than the specified value.
NotGreaterThanT(T, T, T) | Ensures test parameter passed to function is not greater than the specified value.
Top
See Also

Reference

NumericExtensions Class
GSF Namespace


NumericExtensions.NotGreaterThan(T) Method (T, T)

Grid Solutions Framework NumericExtensionsNotGreaterThanT Method (T, T)
Ensures test parameter passed to function is not greater than the specified value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotGreaterThan<T>(
    this T source,
    T notGreaterThanValue
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function NotGreaterThan(Of T As {Object, IComparable(Of T)}) (
    source As T,
    notGreaterThanValue As T
) As T
static member NotGreaterThan :
        source : 'T *
        notGreaterThanValue : 'T -> 'T  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static T NotGreaterThan(
    T source,
    T notGreaterThanValue
)

Parameters

source
Type: T
Value to test.
notGreaterThanValue
Type: T
Value that represents the upper limit for the source. This value is returned if source is greater than notGreaterThanValue.

Type Parameters

T
Structure or class that implements IComparable(Of T) (e.g., Double, Single, Integer, etc.).

Return Value

Type: T
A value not greater than notGreaterThanValue.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If source is greater than notGreaterThanValue, then notGreaterThanValue is returned.
See Also

Reference

NumericExtensions Class
NotGreaterThan Overload
GSF Namespace


NumericExtensions.NotGreaterThan(T) Method (T, T, T)

Grid Solutions Framework NumericExtensionsNotGreaterThanT Method (T, T, T)
Ensures test parameter passed to function is not greater than the specified value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotGreaterThan<T>(
    this T source,
    T notGreaterThanValue,
    T alternateValue
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function NotGreaterThan(Of T As {Object, IComparable(Of T)}) (
    source As T,
    notGreaterThanValue As T,
    alternateValue As T
) As T
static member NotGreaterThan :
        source : 'T *
        notGreaterThanValue : 'T *
        alternateValue : 'T -> 'T  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static T NotGreaterThan(
    T source,
    T notGreaterThanValue,
    T alternateValue
)

Parameters

source
Type: T
Value to test.
notGreaterThanValue
Type: T
Value that represents the upper limit for the source.
alternateValue
Type: T
Value to return if source is greater than notGreaterThanValue.

Type Parameters

T
Structure or class that implements IComparable(Of T) (e.g., Double, Single, Integer, etc.).

Return Value

Type: T
A value not greater than notGreaterThanValue.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
To optimize performance, this function does not validate that the notGreaterThanValue is not greater than the alternateValue
See Also

Reference

NumericExtensions Class
NotGreaterThan Overload
GSF Namespace


NumericExtensions.NotGreaterThanOrEqualTo(T) Method

Grid Solutions Framework NumericExtensionsNotGreaterThanOrEqualToT Method
Ensures test parameter passed to function is not greater than or equal to the specified value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotGreaterThanOrEqualTo<T>(
    this T source,
    T notGreaterThanOrEqualToValue,
    T alternateValue
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function NotGreaterThanOrEqualTo(Of T As {Object, IComparable(Of T)}) (
    source As T,
    notGreaterThanOrEqualToValue As T,
    alternateValue As T
) As T
static member NotGreaterThanOrEqualTo :
        source : 'T *
        notGreaterThanOrEqualToValue : 'T *
        alternateValue : 'T -> 'T  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static T NotGreaterThanOrEqualTo(
    T source,
    T notGreaterThanOrEqualToValue,
    T alternateValue
)

Parameters

source
Type: T
Value to test.
notGreaterThanOrEqualToValue
Type: T
Value that represents the upper limit for the source.
alternateValue
Type: T
Value to return if source is greater than or equal to notGreaterThanOrEqualToValue.

Type Parameters

T
Structure or class that implements IComparable(Of T) (e.g., Double, Single, Integer, etc.).

Return Value

Type: T
A value not greater than or equal to notGreaterThanOrEqualToValue.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
To optimize performance, this function does not validate that the notGreaterThanOrEqualToValue is not greater than or equal to the alternateValue.
See Also

Reference

NumericExtensions Class
GSF Namespace


NumericExtensions.NotLessThan Method

Grid Solutions Framework NumericExtensionsNotLessThan Method
Overload List
Name | Description
NotLessThanT(T, T) | Ensures test parameter passed to function is not less than the specified value.
NotLessThanT(T, T, T) | Ensures test parameter passed to function is not less than the specified value.
Top
See Also

Reference

NumericExtensions Class
GSF Namespace


NumericExtensions.NotLessThan(T) Method (T, T)

Grid Solutions Framework NumericExtensionsNotLessThanT Method (T, T)
Ensures test parameter passed to function is not less than the specified value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotLessThan<T>(
    this T source,
    T notLessThanValue
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function NotLessThan(Of T As {Object, IComparable(Of T)}) (
    source As T,
    notLessThanValue As T
) As T
static member NotLessThan :
        source : 'T *
        notLessThanValue : 'T -> 'T  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static T NotLessThan(
    T source,
    T notLessThanValue
)

Parameters

source
Type: T
Value to test.
notLessThanValue
Type: T
Value that represents the lower limit for the source. This value is returned if source is less than notLessThanValue.

Type Parameters

T
Structure or class that implements IComparable(Of T) (e.g., Double, Single, Integer, etc.).

Return Value

Type: T
A value not less than notLessThanValue.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If source is less than notLessThanValue, then notLessThanValue is returned.
See Also

Reference

NumericExtensions Class
NotLessThan Overload
GSF Namespace


NumericExtensions.NotLessThan(T) Method (T, T, T)

Grid Solutions Framework NumericExtensionsNotLessThanT Method (T, T, T)
Ensures test parameter passed to function is not less than the specified value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotLessThan<T>(
    this T source,
    T notLessThanValue,
    T alternateValue
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function NotLessThan(Of T As {Object, IComparable(Of T)}) (
    source As T,
    notLessThanValue As T,
    alternateValue As T
) As T
static member NotLessThan :
        source : 'T *
        notLessThanValue : 'T *
        alternateValue : 'T -> 'T  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static T NotLessThan(
    T source,
    T notLessThanValue,
    T alternateValue
)

Parameters

source
Type: T
Value to test.
notLessThanValue
Type: T
Value that represents the lower limit for the source.
alternateValue
Type: T
Value to return if source is less than notLessThanValue.

Type Parameters

T
Structure or class that implements IComparable(Of T) (e.g., Double, Single, Integer, etc.).

Return Value

Type: T
A value not less than notLessThanValue.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
To optimize performance, this function does not validate that the notLessThanValue is not less than the alternateValue.
See Also

Reference

NumericExtensions Class
NotLessThan Overload
GSF Namespace


NumericExtensions.NotLessThanOrEqualTo(T) Method

Grid Solutions Framework NumericExtensionsNotLessThanOrEqualToT Method
Ensures test parameter passed to function is not less than or equal to the specified value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotLessThanOrEqualTo<T>(
    this T source,
    T notLessThanOrEqualToValue,
    T alternateValue
)
where T : Object, IComparable<T>

<ExtensionAttribute>
Public Shared Function NotLessThanOrEqualTo(Of T As {Object, IComparable(Of T)}) (
    source As T,
    notLessThanOrEqualToValue As T,
    alternateValue As T
) As T
static member NotLessThanOrEqualTo :
        source : 'T *
        notLessThanOrEqualToValue : 'T *
        alternateValue : 'T -> 'T  when 'T : Object and IComparable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : Object, IComparable<T>
static T NotLessThanOrEqualTo(
    T source,
    T notLessThanOrEqualToValue,
    T alternateValue
)

Parameters

source
Type: T
Value to test.
notLessThanOrEqualToValue
Type: T
Value that represents the lower limit for the source.
alternateValue
Type: T
Value to return if source is less than or equal to notLessThanOrEqualToValue.

Type Parameters

T
Structure or class that implements IComparable(Of T) (e.g., Double, Single, Integer, etc.).

Return Value

Type: T
A value not less than or equal to notLessThanOrEqualToValue.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
To optimize performance, this function does not validate that the notLessThanOrEqualToValue is not less than or equal to the alternateValue.
See Also

Reference

NumericExtensions Class
GSF Namespace


NumericExtensions.NotZero Method

Grid Solutions Framework NumericExtensionsNotZero Method
Overload List
Name | Description
NotZeroT(T) | Ensures parameter passed to function is not zero. Returns -1 if source is zero.
NotZeroT(T, T) | Ensures parameter passed to function is not zero.
Top
See Also

Reference

NumericExtensions Class
GSF Namespace


NumericExtensions.NotZero(T) Method (T)

Grid Solutions Framework NumericExtensionsNotZeroT Method (T)
Ensures parameter passed to function is not zero. Returns -1 if source is zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotZero<T>(
    this T source
)
where T : struct, new(), IEquatable<T>

<ExtensionAttribute>
Public Shared Function NotZero(Of T As {Structure, New, IEquatable(Of T)}) (
    source As T
) As T
static member NotZero :
        source : 'T -> 'T  when 'T : struct, new() and IEquatable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static T NotZero(
    T source
)

Parameters

source
Type: T
Value to test for zero.

Type Parameters

T
Return type used for immediate expression

Return Value

Type: T
A non-zero value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NumericExtensions Class
NotZero Overload
GSF Namespace


NumericExtensions.NotZero(T) Method (T, T)

Grid Solutions Framework NumericExtensionsNotZeroT Method (T, T)
Ensures parameter passed to function is not zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T NotZero<T>(
    this T source,
    T nonZeroReturnValue
)
where T : struct, new(), IEquatable<T>

<ExtensionAttribute>
Public Shared Function NotZero(Of T As {Structure, New, IEquatable(Of T)}) (
    source As T,
    nonZeroReturnValue As T
) As T
static member NotZero :
        source : 'T *
        nonZeroReturnValue : 'T -> 'T  when 'T : struct, new() and IEquatable<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : value class, gcnew(), IEquatable<T>
static T NotZero(
    T source,
    T nonZeroReturnValue
)

Parameters

source
Type: T
Value to test for zero.
nonZeroReturnValue
Type: T
Value to return if source is zero.

Type Parameters

T
Return type used for immediate expression

Return Value

Type: T
A non-zero value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
To optimize performance, this function does not validate that the notZeroReturnValue is not zero.
See Also

Reference

NumericExtensions Class
NotZero Overload
GSF Namespace


ObjectState(TState) Class

Grid Solutions Framework ObjectStateTState Class
A serializable class that can be used to track the current and previous state of an object.
Inheritance Hierarchy
SystemObject
GSFObjectStateTState
GSF.TimeSeries.StatisticsStatisticValueState

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ObjectState<TState>

<SerializableAttribute>
Public Class ObjectState(Of TState)
[<SerializableAttribute>]
type ObjectState<'TState> =  class end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename TState>
public ref class ObjectState

Type Parameters

TState
Type of the state to track.

The ObjectStateTState type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectStateTState(String) | Initializes a new instance of the ObjectStateTState class.
Public method | ObjectStateTState(String, TState) | Initializes a new instance of the ObjectStateTState class.
Public method | ObjectStateTState(String, TState, TState) | Initializes a new instance of the ObjectStateTState class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current state of the object.
Public property | ObjectName | Gets or sets a text label for the object whose state is being tracked.
Public property | PreviousState | Gets or sets the previous state of the object.
Top
See Also

Reference

GSF Namespace


ObjectState(TState) Constructor

Grid Solutions Framework ObjectStateTState Constructor
Overload List
 | Name | Description
Public method | ObjectStateTState(String) | Initializes a new instance of the ObjectStateTState class.
Public method | ObjectStateTState(String, TState) | Initializes a new instance of the ObjectStateTState class.
Public method | ObjectStateTState(String, TState, TState) | Initializes a new instance of the ObjectStateTState class.
Top
See Also

Reference

ObjectStateTState Class
GSF Namespace


ObjectState(TState) Constructor (String)

Grid Solutions Framework ObjectStateTState Constructor (String)
Initializes a new instance of the ObjectStateTState class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ObjectState(
    string objectName
)
Public Sub New (
    objectName As String
)
new :
        objectName : string -> ObjectState
GSF.ObjectState = function(objectName);
public:
ObjectState(
    String^ objectName
)

Parameters

objectName
Type: SystemString
The text label for the object whose state is being tracked.
See Also

Reference

ObjectStateTState Class
ObjectStateTState Overload
GSF Namespace


ObjectState(TState) Constructor (String, TState)

Grid Solutions Framework ObjectStateTState Constructor (String, TState)
Initializes a new instance of the ObjectStateTState class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ObjectState(
    string objectName,
    TState currentState
)
Public Sub New (
    objectName As String,
    currentState As TState
)
new :
        objectName : string *
        currentState : 'TState -> ObjectState
GSF.ObjectState = function(objectName, currentState);
public:
ObjectState(
    String^ objectName,
    TState currentState
)

Parameters

objectName
Type: SystemString
The text label for the object whose state is being tracked.
currentState
Type: TState
The current state of the object.
See Also

Reference

ObjectStateTState Class
ObjectStateTState Overload
GSF Namespace


ObjectState(TState) Constructor (String, TState, TState)

Grid Solutions Framework ObjectStateTState Constructor (String, TState, TState)
Initializes a new instance of the ObjectStateTState class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ObjectState(
    string objectName,
    TState currentState,
    TState previousState
)
Public Sub New (
    objectName As String,
    currentState As TState,
    previousState As TState
)
new :
        objectName : string *
        currentState : 'TState *
        previousState : 'TState -> ObjectState
GSF.ObjectState = function(objectName, currentState, previousState);
public:
ObjectState(
    String^ objectName,
    TState currentState,
    TState previousState
)

Parameters

objectName
Type: SystemString
The text label for the object whose state is being tracked.
currentState
Type: TState
The current state of the object.
previousState
Type: TState
The previous state of the object.
See Also

Reference

ObjectStateTState Class
ObjectStateTState Overload
GSF Namespace


ObjectState(TState) Methods

Grid Solutions Framework ObjectStateTState Methods

The ObjectStateTState generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ObjectStateTState Class
GSF Namespace


ObjectState(TState) Properties

Grid Solutions Framework ObjectStateTState Properties

The ObjectStateTState generic type exposes the following members.

Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current state of the object.
Public property | ObjectName | Gets or sets a text label for the object whose state is being tracked.
Public property | PreviousState | Gets or sets the previous state of the object.
Top
See Also

Reference

ObjectStateTState Class
GSF Namespace


ObjectState(TState).CurrentState Property

Grid Solutions Framework ObjectStateTStateCurrentState Property
Gets or sets the current state of the object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TState CurrentState { get; set; }
Public Property CurrentState As TState
    Get
    Set
member CurrentState : 'TState with get, set

function get_CurrentState();
function set_CurrentState(value);
public:
property TState CurrentState {
    TState get ();
    void set (TState value);
}

Property Value

Type: TState
See Also

Reference

ObjectStateTState Class
GSF Namespace


ObjectState(TState).ObjectName Property

Grid Solutions Framework ObjectStateTStateObjectName Property
Gets or sets a text label for the object whose state is being tracked.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ObjectName { get; set; }
Public Property ObjectName As String
    Get
    Set
member ObjectName : string with get, set

function get_ObjectName();
function set_ObjectName(value);
public:
property String^ ObjectName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ObjectStateTState Class
GSF Namespace


ObjectState(TState).PreviousState Property

Grid Solutions Framework ObjectStateTStatePreviousState Property
Gets or sets the previous state of the object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TState PreviousState { get; set; }
Public Property PreviousState As TState
    Get
    Set
member PreviousState : 'TState with get, set

function get_PreviousState();
function set_PreviousState(value);
public:
property TState PreviousState {
    TState get ();
    void set (TState value);
}

Property Value

Type: TState
See Also

Reference

ObjectStateTState Class
GSF Namespace


PrecisionTimer Class

Grid Solutions Framework PrecisionTimer Class
Represents a high-resolution timer and timestamp class.
Inheritance Hierarchy
SystemObject
GSFPrecisionTimer

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PrecisionTimer : IDisposable
Public Class PrecisionTimer
    Implements IDisposable
type PrecisionTimer =
    class
        interface IDisposable
    end
GSF.PrecisionTimer = function();

Type.createClass(
    'GSF.PrecisionTimer',
    null,
    IDisposable);
public ref class PrecisionTimer : IDisposable

The PrecisionTimer type exposes the following members.

Constructors
 | Name | Description
Public method | PrecisionTimer | Initializes a new instance of the PrecisionTimer class.
Top
Methods
 | Name | Description
 | ClearMinimumTimerResolution | Clears a previously set minimum timer resolution established using SetMinimumTimerResolution(Int32).
Public method | Dispose | Releases all the resources used by the PrecisionTimer object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PrecisionTimer object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the PrecisionTimer object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetMinimumTimerResolution | Requests a minimum resolution for periodic timers such as the PrecisionTimer.
Public method | Start | Starts the PrecisionTimer.
Public method | Start(EventArgs) | Starts the PrecisionTimer with the specified EventArgs.
Public method | Stop | Stops PrecisionTimer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoReset | Gets or sets a value indicating whether the PrecisionTimer should raise the Tick event each time the specified period elapses or only after the first time it elapses.
 | Capabilities | Gets the system multimedia timer capabilities.
Public property | EventArgs | Gets EventArgs specified in Start(EventArgs) used to pass into Tick event.
Public property | IsRunning | Gets a value indicating whether the PrecisionTimer is running.
Public property | Period | Gets or sets the time between Tick events, in milliseconds.
Public property | Resolution | Gets or sets the PrecisionTimer resolution, in milliseconds.
Top
Events
 | Name | Description
Public event | Started | Occurs when the PrecisionTimer has started.
Public event | Stopped | Occurs when the PrecisionTimer has stopped.
Public event | Tick | Occurs when the PrecisionTimer period has elapsed.
Top
Remarks
For Windows deployments, implementation is based on the Windows multimedia timer. For other deployments, e.g., POSIX, implementation uses a basic timer for compatibility - this should have ~10ms of resolution when used on standard Linux systems.
See Also

Reference

GSF Namespace


PrecisionTimer Constructor

Grid Solutions Framework PrecisionTimer Constructor
Initializes a new instance of the PrecisionTimer class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PrecisionTimer()
Public Sub New
new : unit -> PrecisionTimer
GSF.PrecisionTimer = function();
public:
PrecisionTimer()
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer Methods

Grid Solutions Framework PrecisionTimer Methods

The PrecisionTimer type exposes the following members.

Methods
 | Name | Description
 | ClearMinimumTimerResolution | Clears a previously set minimum timer resolution established using SetMinimumTimerResolution(Int32).
Public method | Dispose | Releases all the resources used by the PrecisionTimer object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PrecisionTimer object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the PrecisionTimer object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SetMinimumTimerResolution | Requests a minimum resolution for periodic timers such as the PrecisionTimer.
Public method | Start | Starts the PrecisionTimer.
Public method | Start(EventArgs) | Starts the PrecisionTimer with the specified EventArgs.
Public method | Stop | Stops PrecisionTimer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.ClearMinimumTimerResolution Method

Grid Solutions Framework PrecisionTimerClearMinimumTimerResolution Method
Clears a previously set minimum timer resolution established using SetMinimumTimerResolution(Int32).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ClearMinimumTimerResolution(
    int period
)
Public Shared Sub ClearMinimumTimerResolution (
    period As Integer
)
static member ClearMinimumTimerResolution :
        period : int -> unit

GSF.PrecisionTimer.ClearMinimumTimerResolution = function(period);
public:
static void ClearMinimumTimerResolution(
    int period
)

Parameters

period
Type: SystemInt32
Minimum timer resolution specified in the previous call to the SetMinimumTimerResolution(Int32) function.
Remarks

Call this function immediately after you are finished using the PrecisionTimer. You must match each call to SetMinimumTimerResolution(Int32) with a call to ClearMinimumTimerResolution(Int32), specifying the same minimum resolution period in both calls. An application can make multiple SetMinimumTimerResolution calls as long as each call is matched with a call to ClearMinimumTimerResolution.

This method is currently ignored under Mono deployments.

See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Dispose Method

Grid Solutions Framework PrecisionTimerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the PrecisionTimer object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PrecisionTimer object and optionally releases the managed resources.
Top
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Dispose Method

Grid Solutions Framework PrecisionTimerDispose Method
Releases all the resources used by the PrecisionTimer object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PrecisionTimer Class
Dispose Overload
GSF Namespace


PrecisionTimer.Dispose Method (Boolean)

Grid Solutions Framework PrecisionTimerDispose Method (Boolean)
Releases the unmanaged resources used by the PrecisionTimer object and optionally releases the managed resources.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

PrecisionTimer Class
Dispose Overload
GSF Namespace


PrecisionTimer.Finalize Method

Grid Solutions Framework PrecisionTimerFinalize Method
Releases the unmanaged resources before the PrecisionTimer object is reclaimed by GC.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.SetMinimumTimerResolution Method

Grid Solutions Framework PrecisionTimerSetMinimumTimerResolution Method
Requests a minimum resolution for periodic timers such as the PrecisionTimer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SetMinimumTimerResolution(
    int period
)
Public Shared Sub SetMinimumTimerResolution (
    period As Integer
)
static member SetMinimumTimerResolution :
        period : int -> unit

GSF.PrecisionTimer.SetMinimumTimerResolution = function(period);
public:
static void SetMinimumTimerResolution(
    int period
)

Parameters

period
Type: SystemInt32
Minimum timer resolution, in milliseconds, for the application. A lower value specifies a higher (more accurate) resolution.
Remarks

Call this function immediately before using the PrecisionTimer and call ClearMinimumTimerResolution(Int32) immediately after you are finished using the PrecisionTimer. You must match each call to SetMinimumTimerResolution(Int32) with a call to ClearMinimumTimerResolution specifying the same minimum resolution period in both calls. An application can make multiple ClearMinimumTimerResolution calls as long as each call is matched with a call to ClearMinimumTimerResolution. This function affects a global Windows setting. Windows uses the lowest value (that is, highest resolution) requested by any process. Setting a higher resolution can improve the accuracy of time-out intervals in wait functions. However, it can also reduce overall system performance, because the thread scheduler switches tasks more often. High resolutions can also prevent the CPU power management system from entering power-saving modes. See timeBeginPeriod Windows API for more information.

This method is currently ignored under Mono deployments.

See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Start Method

Grid Solutions Framework PrecisionTimerStart Method
Overload List
 | Name | Description
Public method | Start | Starts the PrecisionTimer.
Public method | Start(EventArgs) | Starts the PrecisionTimer with the specified EventArgs.
Top
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Start Method

Grid Solutions Framework PrecisionTimerStart Method
Starts the PrecisionTimer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start()
Public Sub Start
member Start : unit -> unit

function Start();
public:
void Start()
Exceptions
Exception | Condition
ObjectDisposedException | The timer has already been disposed.
TimerStartException | The timer failed to start.
See Also

Reference

PrecisionTimer Class
Start Overload
GSF Namespace


PrecisionTimer.Start Method (EventArgs)

Grid Solutions Framework PrecisionTimerStart Method (EventArgs)
Starts the PrecisionTimer with the specified EventArgs.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start(
    EventArgs userArgs
)
Public Sub Start (
    userArgs As EventArgs
)
member Start :
        userArgs : EventArgs -> unit

function Start(userArgs);
public:
void Start(
    EventArgs^ userArgs
)

Parameters

userArgs
Type: SystemEventArgs
User defined event arguments to pass into raised Ticks event.
Exceptions
Exception | Condition
ObjectDisposedException | The timer has already been disposed.
TimerStartException | The timer failed to start.
See Also

Reference

PrecisionTimer Class
Start Overload
GSF Namespace


PrecisionTimer.Stop Method

Grid Solutions Framework PrecisionTimerStop Method
Stops PrecisionTimer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Stop()
Public Sub Stop
member Stop : unit -> unit

function Stop();
public:
void Stop()
Exceptions
Exception | Condition
ObjectDisposedException | If the timer has already been disposed.
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer Properties

Grid Solutions Framework PrecisionTimer Properties

The PrecisionTimer type exposes the following members.

Properties
 | Name | Description
Public property | AutoReset | Gets or sets a value indicating whether the PrecisionTimer should raise the Tick event each time the specified period elapses or only after the first time it elapses.
 | Capabilities | Gets the system multimedia timer capabilities.
Public property | EventArgs | Gets EventArgs specified in Start(EventArgs) used to pass into Tick event.
Public property | IsRunning | Gets a value indicating whether the PrecisionTimer is running.
Public property | Period | Gets or sets the time between Tick events, in milliseconds.
Public property | Resolution | Gets or sets the PrecisionTimer resolution, in milliseconds.
Top
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.AutoReset Property

Grid Solutions Framework PrecisionTimerAutoReset Property
Gets or sets a value indicating whether the PrecisionTimer should raise the Tick event each time the specified period elapses or only after the first time it elapses.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AutoReset { get; set; }
Public Property AutoReset As Boolean
    Get
    Set
member AutoReset : bool with get, set

function get_AutoReset();
function set_AutoReset(value);
public:
property bool AutoReset {
    bool get ();
    void set (bool value);
}

Return Value

Type: Boolean
truetrue if the PrecisionTimer should raise the Ticks event each time the interval elapses; false if it should raise the event only once after the first time the interval elapses. The default is true.
Remarks
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Capabilities Property

Grid Solutions Framework PrecisionTimerCapabilities Property
Gets the system multimedia timer capabilities.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimerCapabilities Capabilities { get; }
Public Shared ReadOnly Property Capabilities As TimerCapabilities
    Get
static member Capabilities : TimerCapabilities with get

GSF.PrecisionTimer.get_Capabilities = function();

public:
static property TimerCapabilities Capabilities {
    TimerCapabilities get ();
}

Property Value

Type: TimerCapabilities
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.EventArgs Property

Grid Solutions Framework PrecisionTimerEventArgs Property
Gets EventArgs specified in Start(EventArgs) used to pass into Tick event.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventArgs EventArgs { get; }
Public ReadOnly Property EventArgs As EventArgs
    Get
member EventArgs : EventArgs with get

function get_EventArgs();

public:
property EventArgs^ EventArgs {
    EventArgs^ get ();
}

Property Value

Type: EventArgs
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.IsRunning Property

Grid Solutions Framework PrecisionTimerIsRunning Property
Gets a value indicating whether the PrecisionTimer is running.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
member IsRunning : bool with get

function get_IsRunning();

public:
property bool IsRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Period Property

Grid Solutions Framework PrecisionTimerPeriod Property
Gets or sets the time between Tick events, in milliseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Period { get; set; }
Public Property Period As Integer
    Get
    Set
member Period : int with get, set

function get_Period();
function set_Period(value);
public:
property int Period {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | If the timer has already been disposed.
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Resolution Property

Grid Solutions Framework PrecisionTimerResolution Property
Gets or sets the PrecisionTimer resolution, in milliseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Resolution { get; set; }
Public Property Resolution As Integer
    Get
    Set
member Resolution : int with get, set

function get_Resolution();
function set_Resolution(value);
public:
property int Resolution {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ObjectDisposedException | If the timer has already been disposed.
Remarks

The resolution is in milliseconds. The resolution increases with smaller values; a resolution of 0 indicates periodic events should occur with the greatest possible accuracy. To reduce system overhead, however, you should use the maximum value appropriate for your application.

This property is currently ignored under Mono deployments.

See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer Events

Grid Solutions Framework PrecisionTimer Events

The PrecisionTimer type exposes the following members.

Events
 | Name | Description
Public event | Started | Occurs when the PrecisionTimer has started.
Public event | Stopped | Occurs when the PrecisionTimer has stopped.
Public event | Tick | Occurs when the PrecisionTimer period has elapsed.
Top
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Started Event

Grid Solutions Framework PrecisionTimerStarted Event
Occurs when the PrecisionTimer has started.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Started
Public Event Started As EventHandler
member Started : IEvent<EventHandler,
    EventArgs>

function add_Started(value);
function remove_Started(value);
public:
 event EventHandler^ Started {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Stopped Event

Grid Solutions Framework PrecisionTimerStopped Event
Occurs when the PrecisionTimer has stopped.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Stopped
Public Event Stopped As EventHandler
member Stopped : IEvent<EventHandler,
    EventArgs>

function add_Stopped(value);
function remove_Stopped(value);
public:
 event EventHandler^ Stopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PrecisionTimer Class
GSF Namespace


PrecisionTimer.Tick Event

Grid Solutions Framework PrecisionTimerTick Event
Occurs when the PrecisionTimer period has elapsed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Tick
Public Event Tick As EventHandler
member Tick : IEvent<EventHandler,
    EventArgs>

function add_Tick(value);
function remove_Tick(value);
public:
 event EventHandler^ Tick {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

PrecisionTimer Class
GSF Namespace


ProcessProgress(TUnit) Class

Grid Solutions Framework ProcessProgressTUnit Class
Represents current process progress for an operation.
Inheritance Hierarchy
SystemObject
GSFProcessProgressTUnit

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ProcessProgress<TUnit>
where TUnit : struct, new()

<SerializableAttribute>
Public Class ProcessProgress(Of TUnit As {Structure, New})
[<SerializableAttribute>]
type ProcessProgress<'TUnit when 'TUnit : struct, new()> =  class end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename TUnit>
where TUnit : value class, gcnew()
public ref class ProcessProgress

Type Parameters

TUnit
Unit of progress used (long, double, int, etc.)

The ProcessProgressTUnit type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessProgressTUnit(String) | Constructs a new instance of the ProcessProgressTUnit class using specified process name.
Public method | ProcessProgressTUnit(String, String, TUnit, TUnit) | Constructs a new instance of the ProcessProgressTUnit class using specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Complete | Gets or sets number of units completed processing so far.
Public property | ProcessName | Gets or sets name of process for which progress is being monitored.
Public property | ProgressMessage | Gets or sets current progress message (e.g., current file being copied, etc.)
Public property | Total | Gets or sets total number of units to be processed.
Top
Remarks
Used to track total progress of an identified operation.
See Also

Reference

GSF Namespace


ProcessProgress(TUnit) Constructor

Grid Solutions Framework ProcessProgressTUnit Constructor
Overload List
 | Name | Description
Public method | ProcessProgressTUnit(String) | Constructs a new instance of the ProcessProgressTUnit class using specified process name.
Public method | ProcessProgressTUnit(String, String, TUnit, TUnit) | Constructs a new instance of the ProcessProgressTUnit class using specified parameters.
Top
See Also

Reference

ProcessProgressTUnit Class
GSF Namespace


ProcessProgress(TUnit) Constructor (String)

Grid Solutions Framework ProcessProgressTUnit Constructor (String)
Constructs a new instance of the ProcessProgressTUnit class using specified process name.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessProgress(
    string processName
)
Public Sub New (
    processName As String
)
new :
        processName : string -> ProcessProgress
GSF.ProcessProgress = function(processName);
public:
ProcessProgress(
    String^ processName
)

Parameters

processName
Type: SystemString
Name of process for which progress is being monitored.
See Also

Reference

ProcessProgressTUnit Class
ProcessProgressTUnit Overload
GSF Namespace


ProcessProgress(TUnit) Constructor (String, String, TUnit, TUnit)

Grid Solutions Framework ProcessProgressTUnit Constructor (String, String, TUnit, TUnit)
Constructs a new instance of the ProcessProgressTUnit class using specified parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessProgress(
    string processName,
    string processMessage,
    TUnit total,
    TUnit complete
)
Public Sub New (
    processName As String,
    processMessage As String,
    total As TUnit,
    complete As TUnit
)
new :
        processName : string *
        processMessage : string *
        total : 'TUnit *
        complete : 'TUnit -> ProcessProgress
GSF.ProcessProgress = function(processName, processMessage, total, complete);
public:
ProcessProgress(
    String^ processName,
    String^ processMessage,
    TUnit total,
    TUnit complete
)

Parameters

processName
Type: SystemString
Name of process for which progress is being monitored.
processMessage
Type: SystemString
Current processing message, if any.
total
Type: TUnit
Total number of units to be processed.
complete
Type: TUnit
Number of units completed processing so far.
See Also

Reference

ProcessProgressTUnit Class
ProcessProgressTUnit Overload
GSF Namespace


ProcessProgress(TUnit) Methods

Grid Solutions Framework ProcessProgressTUnit Methods

The ProcessProgressTUnit generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ProcessProgressTUnit Class
GSF Namespace


ProcessProgress(TUnit) Properties

Grid Solutions Framework ProcessProgressTUnit Properties

The ProcessProgressTUnit generic type exposes the following members.

Properties
 | Name | Description
Public property | Complete | Gets or sets number of units completed processing so far.
Public property | ProcessName | Gets or sets name of process for which progress is being monitored.
Public property | ProgressMessage | Gets or sets current progress message (e.g., current file being copied, etc.)
Public property | Total | Gets or sets total number of units to be processed.
Top
See Also

Reference

ProcessProgressTUnit Class
GSF Namespace


ProcessProgress(TUnit).Complete Property

Grid Solutions Framework ProcessProgressTUnitComplete Property
Gets or sets number of units completed processing so far.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TUnit Complete { get; set; }
Public Property Complete As TUnit
    Get
    Set
member Complete : 'TUnit with get, set

function get_Complete();
function set_Complete(value);
public:
property TUnit Complete {
    TUnit get ();
    void set (TUnit value);
}

Property Value

Type: TUnit
See Also

Reference

ProcessProgressTUnit Class
GSF Namespace


ProcessProgress(TUnit).ProcessName Property

Grid Solutions Framework ProcessProgressTUnitProcessName Property
Gets or sets name of process for which progress is being monitored.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ProcessName { get; set; }
Public Property ProcessName As String
    Get
    Set
member ProcessName : string with get, set

function get_ProcessName();
function set_ProcessName(value);
public:
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProcessProgressTUnit Class
GSF Namespace


ProcessProgress(TUnit).ProgressMessage Property

Grid Solutions Framework ProcessProgressTUnitProgressMessage Property
Gets or sets current progress message (e.g., current file being copied, etc.)

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ProgressMessage { get; set; }
Public Property ProgressMessage As String
    Get
    Set
member ProgressMessage : string with get, set

function get_ProgressMessage();
function set_ProgressMessage(value);
public:
property String^ ProgressMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ProcessProgressTUnit Class
GSF Namespace


ProcessProgress(TUnit).Total Property

Grid Solutions Framework ProcessProgressTUnitTotal Property
Gets or sets total number of units to be processed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TUnit Total { get; set; }
Public Property Total As TUnit
    Get
    Set
member Total : 'TUnit with get, set

function get_Total();
function set_Total(value);
public:
property TUnit Total {
    TUnit get ();
    void set (TUnit value);
}

Property Value

Type: TUnit
See Also

Reference

ProcessProgressTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit) Class

Grid Solutions Framework ProcessProgressHandlerTUnit Class
Defines a delegate handler for a ProcessProgressTUnit instance.
Inheritance Hierarchy
SystemObject
GSFProcessProgressHandlerTUnit

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ProcessProgressHandler<TUnit>
where TUnit : struct, new()

Public Class ProcessProgressHandler(Of TUnit As {Structure, New})
type ProcessProgressHandler<'TUnit when 'TUnit : struct, new()> =  class end
JavaScript does not support generic types or methods.
generic<typename TUnit>
where TUnit : value class, gcnew()
public ref class ProcessProgressHandler

Type Parameters

TUnit
Unit of progress used (long, double, int, etc.)

The ProcessProgressHandlerTUnit type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessProgressHandlerTUnit(ActionProcessProgressTUnit, String) | Constructs a new process progress handler for the specified parameters.
Public method | ProcessProgressHandlerTUnit(ActionProcessProgressTUnit, String, TUnit) | Constructs a new process progress handler for the specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateProgress | Calls callback function with updated ProcessProgressTUnit instance so consumer can track progress.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Complete | Gets or sets current process progress (i.e., number of units completed processing so far) - note that when this property value is assigned, the callback function is automatically called with updated ProcessProgressTUnit instance so consumer can track progress.
Public property | ProcessProgress | Gets instance of ProcessProgressTUnit used to track progress for this handler.
Public property | ProgressHandler | Gets or sets reference to delegate handler used as a callback to report process progress.
Public property | Total | Gets or sets total number of units to be processed.
Top
Remarks

This handler is used by methods with an Action delegate parameter (e.g., Action<ProcessProgress<long>>) providing a simple callback mechanism for reporting progress on a long operation.

Examples include: Compress(Stream, Stream, CompressionStrength, ActionProcessProgressInt64), Encrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) and Decrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64)

See Also

Reference

GSF Namespace


ProcessProgressHandler(TUnit) Constructor

Grid Solutions Framework ProcessProgressHandlerTUnit Constructor
Overload List
 | Name | Description
Public method | ProcessProgressHandlerTUnit(ActionProcessProgressTUnit, String) | Constructs a new process progress handler for the specified parameters.
Public method | ProcessProgressHandlerTUnit(ActionProcessProgressTUnit, String, TUnit) | Constructs a new process progress handler for the specified parameters.
Top
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit) Constructor (Action(ProcessProgress(TUnit)), String)

Grid Solutions Framework ProcessProgressHandlerTUnit Constructor (ActionProcessProgressTUnit, String)
Constructs a new process progress handler for the specified parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessProgressHandler(
    Action<ProcessProgress<TUnit>> progressHandler,
    string processName
)
Public Sub New (
    progressHandler As Action(Of ProcessProgress(Of TUnit)),
    processName As String
)
new :
        progressHandler : Action<ProcessProgress<'TUnit>> *
        processName : string -> ProcessProgressHandler
GSF.ProcessProgressHandler = function(progressHandler, processName);
public:
ProcessProgressHandler(
    Action<ProcessProgress<TUnit>^>^ progressHandler,
    String^ processName
)

Parameters

progressHandler
Type: SystemAction ProcessProgress TUnit
Delegate callback to invoke as process progresses.
processName
Type: SystemString
Descriptive name of process, if useful.
See Also

Reference

ProcessProgressHandlerTUnit Class
ProcessProgressHandlerTUnit Overload
GSF Namespace


ProcessProgressHandler(TUnit) Constructor (Action(ProcessProgress(TUnit)), String, TUnit)

Grid Solutions Framework ProcessProgressHandlerTUnit Constructor (ActionProcessProgressTUnit, String, TUnit)
Constructs a new process progress handler for the specified parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessProgressHandler(
    Action<ProcessProgress<TUnit>> progressHandler,
    string processName,
    TUnit total
)
Public Sub New (
    progressHandler As Action(Of ProcessProgress(Of TUnit)),
    processName As String,
    total As TUnit
)
new :
        progressHandler : Action<ProcessProgress<'TUnit>> *
        processName : string *
        total : 'TUnit -> ProcessProgressHandler
GSF.ProcessProgressHandler = function(progressHandler, processName, total);
public:
ProcessProgressHandler(
    Action<ProcessProgress<TUnit>^>^ progressHandler,
    String^ processName,
    TUnit total
)

Parameters

progressHandler
Type: SystemAction ProcessProgress TUnit
Delegate callback to invoke as process progresses.
processName
Type: SystemString
Descriptive name of process, if useful.
total
Type: TUnit
Total number of units to be processed.
See Also

Reference

ProcessProgressHandlerTUnit Class
ProcessProgressHandlerTUnit Overload
GSF Namespace


ProcessProgressHandler(TUnit) Methods

Grid Solutions Framework ProcessProgressHandlerTUnit Methods

The ProcessProgressHandlerTUnit generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateProgress | Calls callback function with updated ProcessProgressTUnit instance so consumer can track progress.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit).UpdateProgress Method

Grid Solutions Framework ProcessProgressHandlerTUnitUpdateProgress Method
Calls callback function with updated ProcessProgressTUnit instance so consumer can track progress.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateProgress(
    TUnit completed
)
Public Sub UpdateProgress (
    completed As TUnit
)
member UpdateProgress :
        completed : 'TUnit -> unit

function UpdateProgress(completed);
public:
void UpdateProgress(
    TUnit completed
)

Parameters

completed
Type: TUnit
Number of units completed processing so far.
Remarks
Note that assigning a value to the Complete property will have the same effect as calling this method.
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit) Properties

Grid Solutions Framework ProcessProgressHandlerTUnit Properties

The ProcessProgressHandlerTUnit generic type exposes the following members.

Properties
 | Name | Description
Public property | Complete | Gets or sets current process progress (i.e., number of units completed processing so far) - note that when this property value is assigned, the callback function is automatically called with updated ProcessProgressTUnit instance so consumer can track progress.
Public property | ProcessProgress | Gets instance of ProcessProgressTUnit used to track progress for this handler.
Public property | ProgressHandler | Gets or sets reference to delegate handler used as a callback to report process progress.
Public property | Total | Gets or sets total number of units to be processed.
Top
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit).Complete Property

Grid Solutions Framework ProcessProgressHandlerTUnitComplete Property
Gets or sets current process progress (i.e., number of units completed processing so far) - note that when this property value is assigned, the callback function is automatically called with updated ProcessProgressTUnit instance so consumer can track progress.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TUnit Complete { get; set; }
Public Property Complete As TUnit
    Get
    Set
member Complete : 'TUnit with get, set

function get_Complete();
function set_Complete(value);
public:
property TUnit Complete {
    TUnit get ();
    void set (TUnit value);
}

Property Value

Type: TUnit
Number of units completed processing so far.
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit).ProcessProgress Property

Grid Solutions Framework ProcessProgressHandlerTUnitProcessProgress Property
Gets instance of ProcessProgressTUnit used to track progress for this handler.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessProgress<TUnit> ProcessProgress { get; }
Public ReadOnly Property ProcessProgress As ProcessProgress(Of TUnit)
    Get
member ProcessProgress : ProcessProgress<'TUnit> with get

function get_ProcessProgress();

public:
property ProcessProgress<TUnit>^ ProcessProgress {
    ProcessProgress<TUnit>^ get ();
}

Property Value

Type: ProcessProgress TUnit
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit).ProgressHandler Property

Grid Solutions Framework ProcessProgressHandlerTUnitProgressHandler Property
Gets or sets reference to delegate handler used as a callback to report process progress.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<ProcessProgress<TUnit>> ProgressHandler { get; set; }
Public Property ProgressHandler As Action(Of ProcessProgress(Of TUnit))
    Get
    Set
member ProgressHandler : Action<ProcessProgress<'TUnit>> with get, set

function get_ProgressHandler();
function set_ProgressHandler(value);
public:
property Action<ProcessProgress<TUnit>^>^ ProgressHandler {
    Action<ProcessProgress<TUnit>^>^ get ();
    void set (Action<ProcessProgress<TUnit>^>^ value);
}

Property Value

Type: Action ProcessProgress TUnit
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


ProcessProgressHandler(TUnit).Total Property

Grid Solutions Framework ProcessProgressHandlerTUnitTotal Property
Gets or sets total number of units to be processed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TUnit Total { get; set; }
Public Property Total As TUnit
    Get
    Set
member Total : 'TUnit with get, set

function get_Total();
function set_Total(value);
public:
property TUnit Total {
    TUnit get ();
    void set (TUnit value);
}

Property Value

Type: TUnit
See Also

Reference

ProcessProgressHandlerTUnit Class
GSF Namespace


Range(T) Class

Grid Solutions Framework RangeT Class
Represents a range of values with a start and end value.
Inheritance Hierarchy
SystemObject
GSFRangeT
GSF.IOOutage

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Range<T>

Public Class Range(Of T)
type Range<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class Range

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GSF.Range`1"]

The RangeT type exposes the following members.

Constructors
 | Name | Description
Public method | RangeT | Creates a new instance of the RangeT class using the default comparer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge(RangeT) | Merges two ranges into one range that fully encompasses both ranges.
 | Merge(IEnumerableRangeT) | Merges all ranges in a collection of ranges.
Public method | Merge(RangeT, IComparerT) | Merges two ranges into one range that fully encompasses both ranges.
Public method | Merge(RangeT, ComparisonT) | Merges two ranges into one range that fully encompasses both ranges.
 | Merge(IEnumerableRangeT, ComparerT) | Merges all ranges in a collection of ranges.
 | Merge(IEnumerableRangeT, ComparisonT) | Merges all ranges in a collection of ranges.
 | MergeAllOverlapping(IEnumerableRangeT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeAllOverlapping(IEnumerableRangeT, IComparerT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeAllOverlapping(IEnumerableRangeT, ComparisonT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeConsecutiveOverlapping(IEnumerableRangeT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeConsecutiveOverlapping(IEnumerableRangeT, IComparerT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeConsecutiveOverlapping(IEnumerableRangeT, ComparisonT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
Public method | Overlaps(RangeT) | Determines whether the range overlaps with the given range.
Public method | Overlaps(RangeT, IComparerT) | Determines whether the range overlaps with the given range.
Public method | Overlaps(RangeT, ComparisonT) | Determines whether the range overlaps with the given range.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | End | Gets the end value of the range.
Public property | Start | Gets the start value of the range.
Top
See Also

Reference

GSF Namespace


Range(T) Constructor

Grid Solutions Framework RangeT Constructor
Creates a new instance of the RangeT class using the default comparer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Range(
    T start,
    T end
)
Public Sub New (
    start As T,
    end As T
)
new :
        start : 'T *
        end : 'T -> Range
GSF.Range = function(start, end);
public:
Range(
    T start,
    T end
)

Parameters

start
Type: T
The start value of the range.
end
Type: T
The end value of the range.
See Also

Reference

RangeT Class
GSF Namespace


Range(T) Methods

Grid Solutions Framework RangeT Methods

The RangeT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge(RangeT) | Merges two ranges into one range that fully encompasses both ranges.
 | Merge(IEnumerableRangeT) | Merges all ranges in a collection of ranges.
Public method | Merge(RangeT, IComparerT) | Merges two ranges into one range that fully encompasses both ranges.
Public method | Merge(RangeT, ComparisonT) | Merges two ranges into one range that fully encompasses both ranges.
 | Merge(IEnumerableRangeT, ComparerT) | Merges all ranges in a collection of ranges.
 | Merge(IEnumerableRangeT, ComparisonT) | Merges all ranges in a collection of ranges.
 | MergeAllOverlapping(IEnumerableRangeT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeAllOverlapping(IEnumerableRangeT, IComparerT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeAllOverlapping(IEnumerableRangeT, ComparisonT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeConsecutiveOverlapping(IEnumerableRangeT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeConsecutiveOverlapping(IEnumerableRangeT, IComparerT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
 | MergeConsecutiveOverlapping(IEnumerableRangeT, ComparisonT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
Public method | Overlaps(RangeT) | Determines whether the range overlaps with the given range.
Public method | Overlaps(RangeT, IComparerT) | Determines whether the range overlaps with the given range.
Public method | Overlaps(RangeT, ComparisonT) | Determines whether the range overlaps with the given range.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RangeT Class
GSF Namespace


Range(T).Merge Method

Grid Solutions Framework RangeTMerge Method
Overload List
 | Name | Description
Public method | Merge(RangeT) | Merges two ranges into one range that fully encompasses both ranges.
 | Merge(IEnumerableRangeT) | Merges all ranges in a collection of ranges.
Public method | Merge(RangeT, IComparerT) | Merges two ranges into one range that fully encompasses both ranges.
Public method | Merge(RangeT, ComparisonT) | Merges two ranges into one range that fully encompasses both ranges.
 | Merge(IEnumerableRangeT, ComparerT) | Merges all ranges in a collection of ranges.
 | Merge(IEnumerableRangeT, ComparisonT) | Merges all ranges in a collection of ranges.
Top
See Also

Reference

RangeT Class
GSF Namespace


Range(T).Merge Method (Range(T))

Grid Solutions Framework RangeTMerge Method (RangeT)
Merges two ranges into one range that fully encompasses both ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Range<T> Merge(
    Range<T> range
)
Public Function Merge (
    range As Range(Of T)
) As Range(Of T)
member Merge :
        range : Range<'T> -> Range<'T>

function Merge(range);
public:
Range<T>^ Merge(
    Range<T>^ range
)

Parameters

range
Type: GSFRange T
The range to be merged with this one.

Return Value

Type: Range T
The range that fully encompasses the merged ranges.
See Also

Reference

RangeT Class
Merge Overload
GSF Namespace


Range(T).Merge Method (IEnumerable(Range(T)))

Grid Solutions Framework RangeTMerge Method (IEnumerableRangeT)
Merges all ranges in a collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Range<T> Merge(
    IEnumerable<Range<T>> ranges
)
Public Shared Function Merge (
    ranges As IEnumerable(Of Range(Of T))
) As Range(Of T)
static member Merge :
        ranges : IEnumerable<Range<'T>> -> Range<'T>

GSF.Range.Merge = function(ranges);
public:
static Range<T>^ Merge(
    IEnumerable<Range<T>^>^ ranges
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges to be merged.

Return Value

Type: Range T
A range that is the result of merging all ranges in the collection.
See Also

Reference

RangeT Class
Merge Overload
GSF Namespace


Range(T).Merge Method (Range(T), IComparer(T))

Grid Solutions Framework RangeTMerge Method (RangeT, IComparerT)
Merges two ranges into one range that fully encompasses both ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Range<T> Merge(
    Range<T> range,
    IComparer<T> comparer
)
Public Function Merge (
    range As Range(Of T),
    comparer As IComparer(Of T)
) As Range(Of T)
member Merge :
        range : Range<'T> *
        comparer : IComparer<'T> -> Range<'T>

function Merge(range, comparer);
public:
Range<T>^ Merge(
    Range<T>^ range,
    IComparer<T>^ comparer
)

Parameters

range
Type: GSFRange T
The range to be merged with this one.
comparer
Type: System.Collections.GenericIComparer T
The comparer used to compare objects of type T.

Return Value

Type: Range T
The range that fully encompasses the merged ranges.
See Also

Reference

RangeT Class
Merge Overload
GSF Namespace


Range(T).Merge Method (Range(T), Comparison(T))

Grid Solutions Framework RangeTMerge Method (RangeT, ComparisonT)
Merges two ranges into one range that fully encompasses both ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Range<T> Merge(
    Range<T> range,
    Comparison<T> comparison
)
Public Function Merge (
    range As Range(Of T),
    comparison As Comparison(Of T)
) As Range(Of T)
member Merge :
        range : Range<'T> *
        comparison : Comparison<'T> -> Range<'T>

function Merge(range, comparison);
public:
Range<T>^ Merge(
    Range<T>^ range,
    Comparison<T>^ comparison
)

Parameters

range
Type: GSFRange T
The range to be merged with this one.
comparison
Type: SystemComparison T
The comparison used to compare objects of type T.

Return Value

Type: Range T
The range that fully encompasses the merged ranges.
See Also

Reference

RangeT Class
Merge Overload
GSF Namespace


Range(T).Merge Method (IEnumerable(Range(T)), Comparer(T))

Grid Solutions Framework RangeTMerge Method (IEnumerableRangeT, ComparerT)
Merges all ranges in a collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Range<T> Merge(
    IEnumerable<Range<T>> ranges,
    Comparer<T> comparer
)
Public Shared Function Merge (
    ranges As IEnumerable(Of Range(Of T)),
    comparer As Comparer(Of T)
) As Range(Of T)
static member Merge :
        ranges : IEnumerable<Range<'T>> *
        comparer : Comparer<'T> -> Range<'T>

GSF.Range.Merge = function(ranges, comparer);
public:
static Range<T>^ Merge(
    IEnumerable<Range<T>^>^ ranges,
    Comparer<T>^ comparer
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges to be merged.
comparer
Type: System.Collections.GenericComparer T
The comparer used to compare objects of type T.

Return Value

Type: Range T
A range that is the result of merging all ranges in the collection.
See Also

Reference

RangeT Class
Merge Overload
GSF Namespace


Range(T).Merge Method (IEnumerable(Range(T)), Comparison(T))

Grid Solutions Framework RangeTMerge Method (IEnumerableRangeT, ComparisonT)
Merges all ranges in a collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Range<T> Merge(
    IEnumerable<Range<T>> ranges,
    Comparison<T> comparison
)
Public Shared Function Merge (
    ranges As IEnumerable(Of Range(Of T)),
    comparison As Comparison(Of T)
) As Range(Of T)
static member Merge :
        ranges : IEnumerable<Range<'T>> *
        comparison : Comparison<'T> -> Range<'T>

GSF.Range.Merge = function(ranges, comparison);
public:
static Range<T>^ Merge(
    IEnumerable<Range<T>^>^ ranges,
    Comparison<T>^ comparison
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges to be merged.
comparison
Type: SystemComparison T
The comparison used to compare objects of type T.

Return Value

Type: Range T
A range that is the result of merging all ranges in the collection.
See Also

Reference

RangeT Class
Merge Overload
GSF Namespace


Range(T).MergeAllOverlapping Method

Grid Solutions Framework RangeTMergeAllOverlapping Method
Overload List
Name | Description
MergeAllOverlapping(IEnumerableRangeT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
MergeAllOverlapping(IEnumerableRangeT, IComparerT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
MergeAllOverlapping(IEnumerableRangeT, ComparisonT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
Top
See Also

Reference

RangeT Class
GSF Namespace


Range(T).MergeAllOverlapping Method (IEnumerable(Range(T)))

Grid Solutions Framework RangeTMergeAllOverlapping Method (IEnumerableRangeT)
Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<Range<T>> MergeAllOverlapping(
    IEnumerable<Range<T>> ranges
)
Public Shared Function MergeAllOverlapping (
    ranges As IEnumerable(Of Range(Of T))
) As IEnumerable(Of Range(Of T))
static member MergeAllOverlapping :
        ranges : IEnumerable<Range<'T>> -> IEnumerable<Range<'T>>

GSF.Range.MergeAllOverlapping = function(ranges);
public:
static IEnumerable<Range<T>^>^ MergeAllOverlapping(
    IEnumerable<Range<T>^>^ ranges
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges.

Return Value

Type: IEnumerable Range T
The collection of merged ranges.
Remarks
This method does not preserve the order of the source collection.
See Also

Reference

RangeT Class
MergeAllOverlapping Overload
GSF Namespace


Range(T).MergeAllOverlapping Method (IEnumerable(Range(T)), IComparer(T))

Grid Solutions Framework RangeTMergeAllOverlapping Method (IEnumerableRangeT, IComparerT)
Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<Range<T>> MergeAllOverlapping(
    IEnumerable<Range<T>> ranges,
    IComparer<T> comparer
)
Public Shared Function MergeAllOverlapping (
    ranges As IEnumerable(Of Range(Of T)),
    comparer As IComparer(Of T)
) As IEnumerable(Of Range(Of T))
static member MergeAllOverlapping :
        ranges : IEnumerable<Range<'T>> *
        comparer : IComparer<'T> -> IEnumerable<Range<'T>>

GSF.Range.MergeAllOverlapping = function(ranges, comparer);
public:
static IEnumerable<Range<T>^>^ MergeAllOverlapping(
    IEnumerable<Range<T>^>^ ranges,
    IComparer<T>^ comparer
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges.
comparer
Type: System.Collections.GenericIComparer T
The comparer used to compare objects of type T.

Return Value

Type: IEnumerable Range T
The collection of merged ranges.
Remarks
This method does not preserve the order of the source collection.
See Also

Reference

RangeT Class
MergeAllOverlapping Overload
GSF Namespace


Range(T).MergeAllOverlapping Method (IEnumerable(Range(T)), Comparison(T))

Grid Solutions Framework RangeTMergeAllOverlapping Method (IEnumerableRangeT, ComparisonT)
Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<Range<T>> MergeAllOverlapping(
    IEnumerable<Range<T>> ranges,
    Comparison<T> comparison
)
Public Shared Function MergeAllOverlapping (
    ranges As IEnumerable(Of Range(Of T)),
    comparison As Comparison(Of T)
) As IEnumerable(Of Range(Of T))
static member MergeAllOverlapping :
        ranges : IEnumerable<Range<'T>> *
        comparison : Comparison<'T> -> IEnumerable<Range<'T>>

GSF.Range.MergeAllOverlapping = function(ranges, comparison);
public:
static IEnumerable<Range<T>^>^ MergeAllOverlapping(
    IEnumerable<Range<T>^>^ ranges,
    Comparison<T>^ comparison
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges.
comparison
Type: SystemComparison T
The comparison used to compare objects of type T.

Return Value

Type: IEnumerable Range T
The collection of merged ranges.
Remarks
This method does not preserve the order of the source collection.
See Also

Reference

RangeT Class
MergeAllOverlapping Overload
GSF Namespace


Range(T).MergeConsecutiveOverlapping Method

Grid Solutions Framework RangeTMergeConsecutiveOverlapping Method
Overload List
Name | Description
MergeConsecutiveOverlapping(IEnumerableRangeT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
MergeConsecutiveOverlapping(IEnumerableRangeT, IComparerT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
MergeConsecutiveOverlapping(IEnumerableRangeT, ComparisonT) | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.
Top
See Also

Reference

RangeT Class
GSF Namespace


Range(T).MergeConsecutiveOverlapping Method (IEnumerable(Range(T)))

Grid Solutions Framework RangeTMergeConsecutiveOverlapping Method (IEnumerableRangeT)
Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<Range<T>> MergeConsecutiveOverlapping(
    IEnumerable<Range<T>> ranges
)
Public Shared Function MergeConsecutiveOverlapping (
    ranges As IEnumerable(Of Range(Of T))
) As IEnumerable(Of Range(Of T))
static member MergeConsecutiveOverlapping :
        ranges : IEnumerable<Range<'T>> -> IEnumerable<Range<'T>>

GSF.Range.MergeConsecutiveOverlapping = function(ranges);
public:
static IEnumerable<Range<T>^>^ MergeConsecutiveOverlapping(
    IEnumerable<Range<T>^>^ ranges
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges.

Return Value

Type: IEnumerable Range T
The collection of merged ranges.
See Also

Reference

RangeT Class
MergeConsecutiveOverlapping Overload
GSF Namespace


Range(T).MergeConsecutiveOverlapping Method (IEnumerable(Range(T)), IComparer(T))

Grid Solutions Framework RangeTMergeConsecutiveOverlapping Method (IEnumerableRangeT, IComparerT)
Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<Range<T>> MergeConsecutiveOverlapping(
    IEnumerable<Range<T>> ranges,
    IComparer<T> comparer
)
Public Shared Function MergeConsecutiveOverlapping (
    ranges As IEnumerable(Of Range(Of T)),
    comparer As IComparer(Of T)
) As IEnumerable(Of Range(Of T))
static member MergeConsecutiveOverlapping :
        ranges : IEnumerable<Range<'T>> *
        comparer : IComparer<'T> -> IEnumerable<Range<'T>>

GSF.Range.MergeConsecutiveOverlapping = function(ranges, comparer);
public:
static IEnumerable<Range<T>^>^ MergeConsecutiveOverlapping(
    IEnumerable<Range<T>^>^ ranges,
    IComparer<T>^ comparer
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges.
comparer
Type: System.Collections.GenericIComparer T
The comparer used to compare objects of type T.

Return Value

Type: IEnumerable Range T
The collection of merged ranges.
See Also

Reference

RangeT Class
MergeConsecutiveOverlapping Overload
GSF Namespace


Range(T).MergeConsecutiveOverlapping Method (IEnumerable(Range(T)), Comparison(T))

Grid Solutions Framework RangeTMergeConsecutiveOverlapping Method (IEnumerableRangeT, ComparisonT)
Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of ranges.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<Range<T>> MergeConsecutiveOverlapping(
    IEnumerable<Range<T>> ranges,
    Comparison<T> comparison
)
Public Shared Function MergeConsecutiveOverlapping (
    ranges As IEnumerable(Of Range(Of T)),
    comparison As Comparison(Of T)
) As IEnumerable(Of Range(Of T))
static member MergeConsecutiveOverlapping :
        ranges : IEnumerable<Range<'T>> *
        comparison : Comparison<'T> -> IEnumerable<Range<'T>>

GSF.Range.MergeConsecutiveOverlapping = function(ranges, comparison);
public:
static IEnumerable<Range<T>^>^ MergeConsecutiveOverlapping(
    IEnumerable<Range<T>^>^ ranges,
    Comparison<T>^ comparison
)

Parameters

ranges
Type: System.Collections.GenericIEnumerable Range T
The collection of ranges.
comparison
Type: SystemComparison T
The comparison used to compare objects of type T.

Return Value

Type: IEnumerable Range T
The collection of merged ranges.
See Also

Reference

RangeT Class
MergeConsecutiveOverlapping Overload
GSF Namespace


Range(T).Overlaps Method

Grid Solutions Framework RangeTOverlaps Method
Overload List
 | Name | Description
Public method | Overlaps(RangeT) | Determines whether the range overlaps with the given range.
Public method | Overlaps(RangeT, IComparerT) | Determines whether the range overlaps with the given range.
Public method | Overlaps(RangeT, ComparisonT) | Determines whether the range overlaps with the given range.
Top
See Also

Reference

RangeT Class
GSF Namespace


Range(T).Overlaps Method (Range(T))

Grid Solutions Framework RangeTOverlaps Method (RangeT)
Determines whether the range overlaps with the given range.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Overlaps(
    Range<T> range
)
Public Function Overlaps (
    range As Range(Of T)
) As Boolean
member Overlaps :
        range : Range<'T> -> bool

function Overlaps(range);
public:
bool Overlaps(
    Range<T>^ range
)

Parameters

range
Type: GSFRange T
The range to be compared with.

Return Value

Type: Boolean
True if the ranges overlap; false otherwise.
See Also

Reference

RangeT Class
Overlaps Overload
GSF Namespace


Range(T).Overlaps Method (Range(T), IComparer(T))

Grid Solutions Framework RangeTOverlaps Method (RangeT, IComparerT)
Determines whether the range overlaps with the given range.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Overlaps(
    Range<T> range,
    IComparer<T> comparer
)
Public Function Overlaps (
    range As Range(Of T),
    comparer As IComparer(Of T)
) As Boolean
member Overlaps :
        range : Range<'T> *
        comparer : IComparer<'T> -> bool

function Overlaps(range, comparer);
public:
bool Overlaps(
    Range<T>^ range,
    IComparer<T>^ comparer
)

Parameters

range
Type: GSFRange T
The range to be compared with.
comparer
Type: System.Collections.GenericIComparer T
The comparer used to compare objects of type T.

Return Value

Type: Boolean
True if the ranges overlap; false otherwise.
See Also

Reference

RangeT Class
Overlaps Overload
GSF Namespace


Range(T).Overlaps Method (Range(T), Comparison(T))

Grid Solutions Framework RangeTOverlaps Method (RangeT, ComparisonT)
Determines whether the range overlaps with the given range.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Overlaps(
    Range<T> range,
    Comparison<T> comparison
)
Public Function Overlaps (
    range As Range(Of T),
    comparison As Comparison(Of T)
) As Boolean
member Overlaps :
        range : Range<'T> *
        comparison : Comparison<'T> -> bool

function Overlaps(range, comparison);
public:
bool Overlaps(
    Range<T>^ range,
    Comparison<T>^ comparison
)

Parameters

range
Type: GSFRange T
The range to be compared with.
comparison
Type: SystemComparison T
The comparison used to compare objects of type T.

Return Value

Type: Boolean
True if the ranges overlap; false otherwise.
See Also

Reference

RangeT Class
Overlaps Overload
GSF Namespace


Range(T) Properties

Grid Solutions Framework RangeT Properties

The RangeT generic type exposes the following members.

Properties
 | Name | Description
Public property | End | Gets the end value of the range.
Public property | Start | Gets the start value of the range.
Top
See Also

Reference

RangeT Class
GSF Namespace


Range(T).End Property

Grid Solutions Framework RangeTEnd Property
Gets the end value of the range.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T End { get; }
Public ReadOnly Property End As T
    Get
member End : 'T with get

function get_End();

public:
property T End {
    T get ();
}

Property Value

Type: T
See Also

Reference

RangeT Class
GSF Namespace


Range(T).Start Property

Grid Solutions Framework RangeTStart Property
Gets the start value of the range.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Start { get; }
Public ReadOnly Property Start As T
    Get
member Start : 'T with get

function get_Start();

public:
property T Start {
    T get ();
}

Property Value

Type: T
See Also

Reference

RangeT Class
GSF Namespace


ReusableObjectPool Class

Grid Solutions Framework ReusableObjectPool Class

Note: This API is now obsolete.

Represents a reusable object pool that can be used by an application.
Inheritance Hierarchy
SystemObject
GSFReusableObjectPool

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")]
public static class ReusableObjectPool
<ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")>
Public NotInheritable Class ReusableObjectPool
[<AbstractClassAttribute>]
[<SealedAttribute>]
[<ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")>]
type ReusableObjectPool =  class end
GSF.ReusableObjectPool = function();

Type.createClass(
    'GSF.ReusableObjectPool');
[ObsoleteAttribute(L"It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")]
public ref class ReusableObjectPool abstract sealed

The ReusableObjectPool type exposes the following members.

Methods
Name | Description
Clear | Releases all the objects currently cached in the specified pool.
ReturnObject | Returns object to the pool.
SetPoolSize | Allocates the pool to the desired size.
TakeObject(Type) | Gets an object from the pool, or creates a new one if no pool items are available.
TakeObjectT(Type) | Gets an object from the pool, or creates a new one if no pool items are available.
Top
Remarks

See ReusableObjectPoolT for more details on using object pooling.

ReusableObjectPool should be used when you only have the Type of an object available (such as when you are using reflection), otherwise you should use the generic ReusableObjectPoolT.

See Also

Reference

GSF Namespace


ReusableObjectPool Methods

Grid Solutions Framework ReusableObjectPool Methods

The ReusableObjectPool type exposes the following members.

Methods
Name | Description
Clear | Releases all the objects currently cached in the specified pool.
ReturnObject | Returns object to the pool.
SetPoolSize | Allocates the pool to the desired size.
TakeObject(Type) | Gets an object from the pool, or creates a new one if no pool items are available.
TakeObjectT(Type) | Gets an object from the pool, or creates a new one if no pool items are available.
Top
See Also

Reference

ReusableObjectPool Class
GSF Namespace


ReusableObjectPool.Clear Method

Grid Solutions Framework ReusableObjectPoolClear Method
Releases all the objects currently cached in the specified pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Clear(
    Type type
)
Public Shared Sub Clear (
    type As Type
)
static member Clear :
        type : Type -> unit

GSF.ReusableObjectPool.Clear = function(type);
public:
static void Clear(
    Type^ type
)

Parameters

type
Type: SystemType
Type of pool to clear.
See Also

Reference

ReusableObjectPool Class
GSF Namespace


ReusableObjectPool.ReturnObject Method

Grid Solutions Framework ReusableObjectPoolReturnObject Method
Returns object to the pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ReturnObject(
    Object item
)
Public Shared Sub ReturnObject (
    item As Object
)
static member ReturnObject :
        item : Object -> unit

GSF.ReusableObjectPool.ReturnObject = function(item);
public:
static void ReturnObject(
    Object^ item
)

Parameters

item
Type: SystemObject
Reference to the object being returned.
Remarks
If type of item implements ISupportLifecycle, the pool will automatically return the item to the pool when the Disposed event is raised, usually when the object's Dispose method is called.
See Also

Reference

ReusableObjectPool Class
GSF Namespace


ReusableObjectPool.SetPoolSize Method

Grid Solutions Framework ReusableObjectPoolSetPoolSize Method
Allocates the pool to the desired size.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SetPoolSize(
    Type type,
    int size
)
Public Shared Sub SetPoolSize (
    type As Type,
    size As Integer
)
static member SetPoolSize :
        type : Type *
        size : int -> unit

GSF.ReusableObjectPool.SetPoolSize = function(type, size);
public:
static void SetPoolSize(
    Type^ type,
    int size
)

Parameters

type
Type: SystemType
Type of pool to initialize.
size
Type: SystemInt32
Desired pool size.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Pool size must at least be one.
See Also

Reference

ReusableObjectPool Class
GSF Namespace


ReusableObjectPool.TakeObject Method

Grid Solutions Framework ReusableObjectPoolTakeObject Method
Overload List
Name | Description
TakeObject(Type) | Gets an object from the pool, or creates a new one if no pool items are available.
TakeObjectT(Type) | Gets an object from the pool, or creates a new one if no pool items are available.
Top
See Also

Reference

ReusableObjectPool Class
GSF Namespace


ReusableObjectPool.TakeObject Method (Type)

Grid Solutions Framework ReusableObjectPoolTakeObject Method (Type)
Gets an object from the pool, or creates a new one if no pool items are available.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object TakeObject(
    Type type
)
Public Shared Function TakeObject (
    type As Type
) As Object
static member TakeObject :
        type : Type -> Object

GSF.ReusableObjectPool.TakeObject = function(type);
public:
static Object^ TakeObject(
    Type^ type
)

Parameters

type
Type: SystemType
Type of object to get from pool.

Return Value

Type: Object
An available object from the pool, or a new one if no pool items are available.
Exceptions
Exception | Condition
InvalidOperationException | type does not support parameterless public constructor.
Remarks
If type implements ISupportLifecycle, the pool will attach to the item's Disposed event such that the object can be automatically restored to the pool upon Dispose. It will be up to class implementors to make sure Initialize makes the class ready for use as this method will always be called for an object being taken from the pool.
See Also

Reference

ReusableObjectPool Class
TakeObject Overload
GSF Namespace


ReusableObjectPool.TakeObject(T) Method (Type)

Grid Solutions Framework ReusableObjectPoolTakeObjectT Method (Type)
Gets an object from the pool, or creates a new one if no pool items are available.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T TakeObject<T>(
    Type type
)

Public Shared Function TakeObject(Of T) (
    type As Type
) As T
static member TakeObject :
        type : Type -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
static T TakeObject(
    Type^ type
)

Parameters

type
Type: SystemType
Type of object to get from pool.

Type Parameters

T
Type of returned object to get from pool.

Return Value

Type: T
An available object from the pool, or a new one if no pool items are available.
Exceptions
Exception | Condition
InvalidOperationException | type does not support parameterless public constructor -or- type is not a subclass or interface implementation of function type definition.
Remarks

This function will validate that T is related to type.

If type implements ISupportLifecycle, the pool will attach to the item's Disposed event such that the object can be automatically restored to the pool upon Dispose. It will be up to class implementors to make sure Initialize makes the class ready for use as this method will always be called for an object being taken from the pool.

See Also

Reference

ReusableObjectPool Class
TakeObject Overload
GSF Namespace


ReusableObjectPool(T) Class

Grid Solutions Framework ReusableObjectPoolT Class

Note: This API is now obsolete.

Represents a reusable object pool that can be used by an application.
Inheritance Hierarchy
SystemObject
GSFReusableObjectPoolT

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")]
public class ReusableObjectPool<T>
where T : class, new()

<ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")>
Public Class ReusableObjectPool(Of T As {Class, New})
[<ObsoleteAttribute("It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")>]
type ReusableObjectPool<'T when 'T : not struct, new()> =  class end
JavaScript does not support generic types or methods.
[ObsoleteAttribute(L"It is not recommended to use this class because the need for pooling is rare and implementations of pooling can be dangerous.")]
generic<typename T>
where T : ref class, gcnew()
public ref class ReusableObjectPool

Type Parameters

T
Type of object to pool.

The ReusableObjectPoolT type exposes the following members.

Constructors
 | Name | Description
Public method | ReusableObjectPoolT | Initializes a new instance of the ReusableObjectPoolT class
Top
Methods
 | Name | Description
Public method | Clear | Releases all the objects currently cached in the pool.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoolSize | Gets the number of items currently contained in the pool.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReturnObject | Returns object to the pool.
Public method | SetPoolSize | Allocates the pool to the desired size.
Public method | TakeObject | Gets an object from the pool, or creates a new one if no pool items are available.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Default | Default static instance which can be shared throughout the application.
Top
Remarks

Object pooling can offer a significant performance boost in some scenarios. It is most effective when the cost of construction is high and/or the rate of instantiation is high.

This object pool is statically created at application startup, one per type, and is available for all components and classes within an application domain. Every time you need to use an object, you take one from the pool, use it, then return it to the pool when done. This process can be much faster than creating a new object every time you need to use one.

When objects implement ISupportLifecycle, the ReusableObjectPoolT will automatically attach to the Disposed event and return the object to the pool when it's disposed. When an object is taken from the pool, the Initialize method will be called to reinstantiate any need member variables. If class tracks a disposed flag, it should be reset during call to the Initialize method so that class will be "un-disposed". Also, typical dispose implementations call SuppressFinalize(Object) in the Dispose method, as such the ReRegisterForFinalize(Object) should be called during Initialize method to make sure class will be disposed by finalizer in case Dispose method is never called.

Examples
Here is an example class that implements ISupportLifecycle such that it will be automatically returned to the pool when the class is disposed and automatically initialized when taken from the pool:
Copy
/// <summary>
/// Class that shows example implementation of reusable <see cref="ISupportLifecycle"/>.
/// </summary>
public class ReusableClass : ISupportLifecycle
{
    #region [ Members ]

    // Events

    /// <summary>
    /// Occurs when the <see cref="ReusableClass"/> is disposed.
    /// </summary>
    public event EventHandler Disposed;

    // Fields
    private System.Timers.Timer m_timer;    // Example member variable that needs initialization and disposal
    private bool m_enabled;
    private bool m_disposed;

    #endregion

    #region [ Constructors ]

    /// <summary>
    /// Releases the unmanaged resources before the <see cref="ReusableClass"/> object is reclaimed by <see cref="GC"/>.
    /// </summary>
    ~ReusableClass()
    {
        Dispose(false);
    }

    #endregion

    #region [ Properties ]

    /// <summary>
    /// Gets or sets a boolean value that indicates whether the <see cref="ReusableClass"/> object is currently enabled.
    /// </summary>
    public bool Enabled
    {
        get
        {
            return m_enabled;
        }
        set
        {
            m_enabled = value;

            if (m_timer != null)
                m_timer.Enabled = m_enabled;
        }
    }

    #endregion

    #region [ Methods ]

    /// <summary>
    /// Initializes the <see cref="ReusableClass"/> object.
    /// </summary>
    public void Initialize()
    {
        // Undispose class instance if it is being reused
        if (m_disposed)
        {
            m_disposed = false;
            GC.ReRegisterForFinalize(this);
        }

        m_enabled = true;

        // Initialize member variables
        if (m_timer == null)
        {
            m_timer = new System.Timers.Timer(2000.0D);
            m_timer.Elapsed += m_timer_Elapsed;
            m_timer.Enabled = m_enabled;
        }
    }

    /// <summary>
    /// Releases all the resources used by the <see cref="ReusableClass"/> object.
    /// </summary>
    public void Dispose()
    {
        Dispose(true);
        GC.SuppressFinalize(this);
    }

    /// <summary>
    /// Releases the unmanaged resources used by the <see cref="ReusableClass"/> object and optionally releases the managed resources.
    /// </summary>
    /// <param name="disposing">true to release both managed and unmanaged resources; false to release only unmanaged resources.</param>
    protected virtual void Dispose(bool disposing)
    {
        if (!m_disposed)
        {
            try
            {
                if (disposing)
                {
                    // Dispose member variables
                    if (m_timer != null)
                    {
                        m_timer.Elapsed -= m_timer_Elapsed;
                        m_timer.Dispose();
                    }
                    m_timer = null;

                    m_enabled = false;
                }
            }
            finally
            {
                m_disposed = true;

                if (Disposed != null)
                    Disposed(this, EventArgs.Empty);
            }
        }
    }

    // Handle timer event
    private void m_timer_Elapsed(object sender, System.Timers.ElapsedEventArgs e)
    {
        // Do work here...
    }

    #endregion
}

If the pool objects do not implement ISupportLifecycle you can still use the object pool, but it will be very imporant to return the object to the pool when you are finished using it. If you are using an object scoped within a method, make sure to use a try/finally so that you can take the object within the try and return the object within the finally. If you are using an object as a member scoped class field, make sure you use the standard dispose pattern and return the object during the Dispose method call. In this mode you will also need to manually initialze your object after you get it from the pool to reset its state.

See Also

Reference

GSF Namespace


ReusableObjectPool(T) Constructor

Grid Solutions Framework ReusableObjectPoolT Constructor
Initializes a new instance of the ReusableObjectPoolT class

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ReusableObjectPool()
Public Sub New
new : unit -> ReusableObjectPool
GSF.ReusableObjectPool = function();
public:
ReusableObjectPool()
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T) Fields

Grid Solutions Framework ReusableObjectPoolT Fields

The ReusableObjectPoolT generic type exposes the following members.

Fields
Name | Description
Default | Default static instance which can be shared throughout the application.
Top
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T).Default Field

Grid Solutions Framework ReusableObjectPoolTDefault Field
Default static instance which can be shared throughout the application.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly ReusableObjectPool<T> Default
Public Shared ReadOnly Default As ReusableObjectPool(Of T)
static val Default: ReusableObjectPool<'T>
var GSF.ReusableObjectPool.Default
public:
static initonly ReusableObjectPool<T>^ Default

Field Value

Type: ReusableObjectPool T
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T) Methods

Grid Solutions Framework ReusableObjectPoolT Methods

The ReusableObjectPoolT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Releases all the objects currently cached in the pool.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPoolSize | Gets the number of items currently contained in the pool.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ReturnObject | Returns object to the pool.
Public method | SetPoolSize | Allocates the pool to the desired size.
Public method | TakeObject | Gets an object from the pool, or creates a new one if no pool items are available.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T).Clear Method

Grid Solutions Framework ReusableObjectPoolTClear Method
Releases all the objects currently cached in the pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T).GetPoolSize Method

Grid Solutions Framework ReusableObjectPoolTGetPoolSize Method
Gets the number of items currently contained in the pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GetPoolSize()
Public Function GetPoolSize As Integer
member GetPoolSize : unit -> int

function GetPoolSize();
public:
int GetPoolSize()

Return Value

Type: Int32
The size of the pool.
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T).ReturnObject Method

Grid Solutions Framework ReusableObjectPoolTReturnObject Method
Returns object to the pool.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ReturnObject(
    T item
)
Public Sub ReturnObject (
    item As T
)
member ReturnObject :
        item : 'T -> unit

function ReturnObject(item);
public:
void ReturnObject(
    T item
)

Parameters

item
Type: T
Reference to the object being returned.
Remarks
If type of T implements ISupportLifecycle, the pool will automatically return the item to the pool when the Disposed event is raised, usually when the object's Dispose method is called.
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T).SetPoolSize Method

Grid Solutions Framework ReusableObjectPoolTSetPoolSize Method
Allocates the pool to the desired size.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetPoolSize(
    int size
)
Public Sub SetPoolSize (
    size As Integer
)
member SetPoolSize :
        size : int -> unit

function SetPoolSize(size);
public:
void SetPoolSize(
    int size
)

Parameters

size
Type: SystemInt32
Desired pool size.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Pool size must at least be one.
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


ReusableObjectPool(T).TakeObject Method

Grid Solutions Framework ReusableObjectPoolTTakeObject Method
Gets an object from the pool, or creates a new one if no pool items are available.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T TakeObject()
Public Function TakeObject As T
member TakeObject : unit -> 'T

function TakeObject();
public:
T TakeObject()

Return Value

Type: T
An available object from the pool, or a new one if no pool items are available.
Remarks
If type of T implements ISupportLifecycle, the pool will attach to the item's Disposed event such that the object can be automatically restored to the pool upon Dispose. It will be up to class implementors to make sure Initialize makes the class ready for use as this method will always be called for an object being taken from the pool.
See Also

Reference

ReusableObjectPoolT Class
GSF Namespace


Serialization Class

Grid Solutions Framework Serialization Class
Common serialization related functions.
Inheritance Hierarchy
SystemObject
GSFSerialization

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Serialization
<ExtensionAttribute>
Public NotInheritable Class Serialization
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Serialization =  class end
GSF.Serialization = function();

Type.createClass(
    'GSF.Serialization');
[ExtensionAttribute]
public ref class Serialization abstract sealed

The Serialization type exposes the following members.

Methods
Name | Description
CloneObjectT | Obsolete. Creates a clone of a serializable object.
DeserializeT(Byte, SerializationFormat) | Deserializes a serialized Object.
DeserializeT(Stream, SerializationFormat) | Deserializes a serialized Object.
GetBytes | Obsolete. Performs binary serialization on the serializable object and returns the output as byte array.
GetObject(Byte) | Obsolete. Performs binary deserialization on the byte array and returns the object for it.
GetObjectT(Byte) | Obsolete. Performs binary deserialization on the byte array and returns the typed object for it.
GetObjectT(String) | Obsolete. Performs XML deserialization on the XML string and returns the typed object for it.
GetOrDefaultT | Gets SerializationInfo value for specified name; otherwise defaultValue.
GetStream | Obsolete. Performs binary serialization on the serializable object and returns the serialized object as a stream.
GetString | Obsolete. Performs XML serialization on the serializable object and returns the output as string.
SerializeT(T, SerializationFormat) | Serializes an Object.
SerializeT(T, SerializationFormat, Stream) | Serializes an Object.
TryDeserializeT(Byte, SerializationFormat, T) | Attempts to deserialize a serialized Object.
TryDeserializeT(Stream, SerializationFormat, T) | Attempts to deserialize a serialized Object.
TryGetObject(Byte, Object) | Obsolete. Attempts binary deserialization on the byte array and returns the typed object for it.
TryGetObjectT(Byte, T) | Obsolete. Attempts binary deserialization on the byte array and returns the typed object for it.
TryGetObjectT(String, T) | Obsolete. Attempts XML deserialization on the XML string and returns the typed object for it.
Top
Fields
Name | Description
LegacyBinder | Serialization binder used to deserialize files that were serialized using the old library frameworks (TVA Code Library, Time Series Framework, TVA.PhasorProtocols, and PMU Connection Tester) into classes in the Grid Solutions Framework.
Top
See Also

Reference

GSF Namespace


Serialization Fields

Grid Solutions Framework Serialization Fields

The Serialization type exposes the following members.

Fields
Name | Description
LegacyBinder | Serialization binder used to deserialize files that were serialized using the old library frameworks (TVA Code Library, Time Series Framework, TVA.PhasorProtocols, and PMU Connection Tester) into classes in the Grid Solutions Framework.
Top
See Also

Reference

Serialization Class
GSF Namespace


Serialization.LegacyBinder Field

Grid Solutions Framework SerializationLegacyBinder Field
Serialization binder used to deserialize files that were serialized using the old library frameworks (TVA Code Library, Time Series Framework, TVA.PhasorProtocols, and PMU Connection Tester) into classes in the Grid Solutions Framework.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly SerializationBinder LegacyBinder
Public Shared ReadOnly LegacyBinder As SerializationBinder
static val LegacyBinder: SerializationBinder
var GSF.Serialization.LegacyBinder
public:
static initonly SerializationBinder^ LegacyBinder

Field Value

Type: SerializationBinder
See Also

Reference

Serialization Class
GSF Namespace


Serialization Methods

Grid Solutions Framework Serialization Methods

The Serialization type exposes the following members.

Methods
Name | Description
CloneObjectT | Obsolete. Creates a clone of a serializable object.
DeserializeT(Byte, SerializationFormat) | Deserializes a serialized Object.
DeserializeT(Stream, SerializationFormat) | Deserializes a serialized Object.
GetBytes | Obsolete. Performs binary serialization on the serializable object and returns the output as byte array.
GetObject(Byte) | Obsolete. Performs binary deserialization on the byte array and returns the object for it.
GetObjectT(Byte) | Obsolete. Performs binary deserialization on the byte array and returns the typed object for it.
GetObjectT(String) | Obsolete. Performs XML deserialization on the XML string and returns the typed object for it.
GetOrDefaultT | Gets SerializationInfo value for specified name; otherwise defaultValue.
GetStream | Obsolete. Performs binary serialization on the serializable object and returns the serialized object as a stream.
GetString | Obsolete. Performs XML serialization on the serializable object and returns the output as string.
SerializeT(T, SerializationFormat) | Serializes an Object.
SerializeT(T, SerializationFormat, Stream) | Serializes an Object.
TryDeserializeT(Byte, SerializationFormat, T) | Attempts to deserialize a serialized Object.
TryDeserializeT(Stream, SerializationFormat, T) | Attempts to deserialize a serialized Object.
TryGetObject(Byte, Object) | Obsolete. Attempts binary deserialization on the byte array and returns the typed object for it.
TryGetObjectT(Byte, T) | Obsolete. Attempts binary deserialization on the byte array and returns the typed object for it.
TryGetObjectT(String, T) | Obsolete. Attempts XML deserialization on the XML string and returns the typed object for it.
Top
See Also

Reference

Serialization Class
GSF Namespace


Serialization.CloneObject(T) Method

Grid Solutions Framework SerializationCloneObjectT Method

Note: This API is now obsolete.

Creates a clone of a serializable object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds.")]
public static T CloneObject<T>(
    T sourceObject
)

<ObsoleteAttribute("This method will be removed in future builds.")>
Public Shared Function CloneObject(Of T) (
    sourceObject As T
) As T
[<ObsoleteAttribute("This method will be removed in future builds.")>]
static member CloneObject :
        sourceObject : 'T -> 'T

JavaScript does not support generic types or methods.
public:
[ObsoleteAttribute(L"This method will be removed in future builds.")]
generic<typename T>
static T CloneObject(
    T sourceObject
)

Parameters

sourceObject
Type: T
The type source to be cloned.

Type Parameters

T
The type of the cloned object.

Return Value

Type: T
A clone of sourceObject.
See Also

Reference

Serialization Class
GSF Namespace


Serialization.Deserialize Method

Grid Solutions Framework SerializationDeserialize Method
Overload List
Name | Description
DeserializeT(Byte, SerializationFormat) | Deserializes a serialized Object.
DeserializeT(Stream, SerializationFormat) | Deserializes a serialized Object.
Top
See Also

Reference

Serialization Class
GSF Namespace


Serialization.Deserialize(T) Method (Byte[], SerializationFormat)

Grid Solutions Framework SerializationDeserializeT Method (Byte, SerializationFormat)
Deserializes a serialized Object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Deserialize<T>(
    byte[] serializedObject,
    SerializationFormat serializationFormat
)

Public Shared Function Deserialize(Of T) (
    serializedObject As Byte(),
    serializationFormat As SerializationFormat
) As T
static member Deserialize :
        serializedObject : byte[] *
        serializationFormat : SerializationFormat -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
static T Deserialize(
    array<unsigned char>^ serializedObject,
    SerializationFormat serializationFormat
)

Parameters

serializedObject
Type: SystemByte
Array of Bytes containing the serialized Object that is to be deserialized.
serializationFormat
Type: GSFSerializationFormat
SerializationFormat in which the serializedObject was serialized.

Type Parameters

T
Type of the deserialized Object to be returned.

Return Value

Type: T
The deserialized Object.
Exceptions
Exception | Condition
ArgumentNullException | serializedObject is null.
NotSupportedException | Specified serializationFormat is not supported.
See Also

Reference

Serialization Class
Deserialize Overload
GSF Namespace


Serialization.Deserialize(T) Method (Stream, SerializationFormat)

Grid Solutions Framework SerializationDeserializeT Method (Stream, SerializationFormat)
Deserializes a serialized Object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Deserialize<T>(
    Stream serializedObject,
    SerializationFormat serializationFormat
)

Public Shared Function Deserialize(Of T) (
    serializedObject As Stream,
    serializationFormat As SerializationFormat
) As T
static member Deserialize :
        serializedObject : Stream *
        serializationFormat : SerializationFormat -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
static T Deserialize(
    Stream^ serializedObject,
    SerializationFormat serializationFormat
)

Parameters

serializedObject
Type: System.IOStream
Stream containing the serialized Object that is to be deserialized.
serializationFormat
Type: GSFSerializationFormat
SerializationFormat in which the serializedObject was serialized.

Type Parameters

T
Type of the deserialized Object to be returned.

Return Value

Type: T
The deserialized Object.
Exceptions
Exception | Condition
ArgumentNullException | serializedObject is null.
NotSupportedException | Specified serializationFormat is not supported.
See Also

Reference

Serialization Class
Deserialize Overload
GSF Namespace


Serialization.GetBytes Method

Grid Solutions Framework SerializationGetBytes Method

Note: This API is now obsolete.

Performs binary serialization on the serializable object and returns the output as byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")]
public static byte[] GetBytes(
    Object serializableObject
)
<ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")>
Public Shared Function GetBytes (
    serializableObject As Object
) As Byte()
[<ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")>]
static member GetBytes :
        serializableObject : Object -> byte[]

GSF.Serialization.GetBytes = function(serializableObject);
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Serialize() method instead.")]
static array<unsigned char>^ GetBytes(
    Object^ serializableObject
)

Parameters

serializableObject
Type: SystemObject
The serializable object.

Return Value

Type: Byte
A byte array representation of the object if the specified object can be serialized; otherwise an empty array.
See Also

Reference

Serialization Class
GSF Namespace


Serialization.GetObject Method

Grid Solutions Framework SerializationGetObject Method
Overload List
Name | Description
GetObjectT(Byte) | Obsolete. Performs binary deserialization on the byte array and returns the typed object for it.
GetObject(Byte) | Obsolete. Performs binary deserialization on the byte array and returns the object for it.
GetObjectT(String) | Obsolete. Performs XML deserialization on the XML string and returns the typed object for it.
Top
See Also

Reference

Serialization Class
GSF Namespace


Serialization.GetObject(T) Method (Byte[])

Grid Solutions Framework SerializationGetObjectT Method (Byte)

Note: This API is now obsolete.

Performs binary deserialization on the byte array and returns the typed object for it.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")]
public static T GetObject<T>(
    byte[] serializedObject
)

<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>
Public Shared Function GetObject(Of T) (
    serializedObject As Byte()
) As T
[<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>]
static member GetObject :
        serializedObject : byte[] -> 'T

JavaScript does not support generic types or methods.
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Deserialize() method instead.")]
generic<typename T>
static T GetObject(
    array<unsigned char>^ serializedObject
)

Parameters

serializedObject
Type: SystemByte
A Byte array representing the object (serializedObject) to deserialize.

Type Parameters

T
The type of the object to create from the serialized byte array serializedObject.

Return Value

Type: T
A type T based on serializedObject.
Exceptions
Exception | Condition
SerializationException | Serialized object data is invalid or length is 0.
SecurityException | The caller does not have the required permission.
Remarks
This function will throw an error during deserialization if the input data is invalid, consider using TryGetObject to prevent needing to implement exception handling.
See Also

Reference

Serialization Class
GetObject Overload
GSF Namespace


Serialization.GetObject Method (Byte[])

Grid Solutions Framework SerializationGetObject Method (Byte)

Note: This API is now obsolete.

Performs binary deserialization on the byte array and returns the object for it.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")]
public static Object GetObject(
    byte[] serializedObject
)
<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>
Public Shared Function GetObject (
    serializedObject As Byte()
) As Object
[<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>]
static member GetObject :
        serializedObject : byte[] -> Object

GSF.Serialization.GetObject = function(serializedObject);
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Deserialize() method instead.")]
static Object^ GetObject(
    array<unsigned char>^ serializedObject
)

Parameters

serializedObject
Type: SystemByte
A Byte array representing the object (serializedObject) to deserialize.

Return Value

Type: Object
An Object based on serializedObject.
Exceptions
Exception | Condition
SerializationException | Serialized object data is invalid or length is 0.
SecurityException | The caller does not have the required permission.
Remarks
This function will throw an error during deserialization if the input data is invalid, consider using TryGetObject to prevent needing to implement exception handling.
See Also

Reference

Serialization Class
GetObject Overload
GSF Namespace


Serialization.GetObject(T) Method (String)

Grid Solutions Framework SerializationGetObjectT Method (String)

Note: This API is now obsolete.

Performs XML deserialization on the XML string and returns the typed object for it.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")]
public static T GetObject<T>(
    string serializedObject
)

<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>
Public Shared Function GetObject(Of T) (
    serializedObject As String
) As T
[<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>]
static member GetObject :
        serializedObject : string -> 'T

JavaScript does not support generic types or methods.
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Deserialize() method instead.")]
generic<typename T>
static T GetObject(
    String^ serializedObject
)

Parameters

serializedObject
Type: SystemString
A String representing the object (serializedObject) to deserialize.

Type Parameters

T
The type of the object to create from the serialized string serializedObject.

Return Value

Type: T
A type T based on serializedObject.
Exceptions
Exception | Condition
InvalidOperationException | An error occurred during deserialization. The original exception is available using the InnerException property.
Remarks
This function will throw an error during deserialization if the input data is invalid, consider using TryGetObject to prevent needing to implement exception handling.
See Also

Reference

Serialization Class
GetObject Overload
GSF Namespace


Serialization.GetOrDefault(T) Method

Grid Solutions Framework SerializationGetOrDefaultT Method
Gets SerializationInfo value for specified name; otherwise defaultValue.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T GetOrDefault<T>(
    this SerializationInfo info,
    string name,
    T defaultValue
)

<ExtensionAttribute>
Public Shared Function GetOrDefault(Of T) (
    info As SerializationInfo,
    name As String,
    defaultValue As T
) As T
static member GetOrDefault :
        info : SerializationInfo *
        name : string *
        defaultValue : 'T -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T GetOrDefault(
    SerializationInfo^ info,
    String^ name,
    T defaultValue
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
SerializationInfo object that contains deserialized values.
name
Type: SystemString
Name of deserialized parameter to retrieve.
defaultValue
Type: T
Default value to return if name does not exist or cannot be deserialized.

Type Parameters

T
Type of parameter to get from SerializationInfo.

Return Value

Type: T
Value for specified name; otherwise defaultValue

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SerializationInfo. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
SerializationInfo do not have a direct way of determining if an item with a specified name exists, so when calling one of the Get(n) functions you will simply get a SerializationException if the parameter does not exist; similarly you will receive this exception if the parameter fails to properly deserialize. This extension method protects against both of these failures and returns a default value if the named parameter does not exist or cannot be deserialized.
See Also

Reference

Serialization Class
GSF Namespace


Serialization.GetStream Method

Grid Solutions Framework SerializationGetStream Method

Note: This API is now obsolete.

Performs binary serialization on the serializable object and returns the serialized object as a stream.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")]
public static MemoryStream GetStream(
    Object serializableObject
)
<ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")>
Public Shared Function GetStream (
    serializableObject As Object
) As MemoryStream
[<ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")>]
static member GetStream :
        serializableObject : Object -> MemoryStream

GSF.Serialization.GetStream = function(serializableObject);
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Serialize() method instead.")]
static MemoryStream^ GetStream(
    Object^ serializableObject
)

Parameters

serializableObject
Type: SystemObject
The serializable object.

Return Value

Type: MemoryStream
A memory stream representation of the object if the specified object can be serialized; otherwise an empty stream.
See Also

Reference

Serialization Class
GSF Namespace


Serialization.GetString Method

Grid Solutions Framework SerializationGetString Method

Note: This API is now obsolete.

Performs XML serialization on the serializable object and returns the output as string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")]
public static string GetString(
    Object serializableObject
)
<ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")>
Public Shared Function GetString (
    serializableObject As Object
) As String
[<ObsoleteAttribute("This method will be removed in future builds, use the Serialize() method instead.")>]
static member GetString :
        serializableObject : Object -> string

GSF.Serialization.GetString = function(serializableObject);
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Serialize() method instead.")]
static String^ GetString(
    Object^ serializableObject
)

Parameters

serializableObject
Type: SystemObject
The serializable object.

Return Value

Type: String
An XML representation of the object if the specified object can be serialized; otherwise an empty string.
See Also

Reference

Serialization Class
GSF Namespace


Serialization.Serialize Method

Grid Solutions Framework SerializationSerialize Method
Overload List
Name | Description
SerializeT(T, SerializationFormat) | Serializes an Object.
SerializeT(T, SerializationFormat, Stream) | Serializes an Object.
Top
See Also

Reference

Serialization Class
GSF Namespace


Serialization.Serialize(T) Method (T, SerializationFormat)

Grid Solutions Framework SerializationSerializeT Method (T, SerializationFormat)
Serializes an Object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Serialize<T>(
    T serializableObject,
    SerializationFormat serializationFormat
)

Public Shared Function Serialize(Of T) (
    serializableObject As T,
    serializationFormat As SerializationFormat
) As Byte()
static member Serialize :
        serializableObject : 'T *
        serializationFormat : SerializationFormat -> byte[]

JavaScript does not support generic types or methods.
public:
generic<typename T>
static array<unsigned char>^ Serialize(
    T serializableObject,
    SerializationFormat serializationFormat
)

Parameters

serializableObject
Type: T
Object to be serialized.
serializationFormat
Type: GSFSerializationFormat
SerializationFormat in which the serializableObject is to be serialized.

Type Parameters

T
Type of the serializableObject.

Return Value

Type: Byte
An Array of Byte of the serialized Object.
Exceptions
Exception | Condition
ArgumentNullException | serializableObject is null.
NotSupportedException | Specified serializationFormat is not supported.
See Also

Reference

Serialization Class
Serialize Overload
GSF Namespace


Serialization.Serialize(T) Method (T, SerializationFormat, Stream)

Grid Solutions Framework SerializationSerializeT Method (T, SerializationFormat, Stream)
Serializes an Object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Serialize<T>(
    T serializableObject,
    SerializationFormat serializationFormat,
    Stream serializedOutput
)

Public Shared Sub Serialize(Of T) (
    serializableObject As T,
    serializationFormat As SerializationFormat,
    serializedOutput As Stream
)
static member Serialize :
        serializableObject : 'T *
        serializationFormat : SerializationFormat *
        serializedOutput : Stream -> unit

JavaScript does not support generic types or methods.
public:
generic<typename T>
static void Serialize(
    T serializableObject,
    SerializationFormat serializationFormat,
    Stream^ serializedOutput
)

Parameters

serializableObject
Type: T
Object to be serialized.
serializationFormat
Type: GSFSerializationFormat
SerializationFormat in which the serializableObject is to be serialized.
serializedOutput
Type: System.IOStream
Stream where the serializableObject is to be serialized.

Type Parameters

T
Type of the serializableObject.
Exceptions
Exception | Condition
ArgumentNullException | serializedOutput or serializableObject is null.
NotSupportedException | Specified serializationFormat is not supported.
See Also

Reference

Serialization Class
Serialize Overload
GSF Namespace


Serialization.TryDeserialize Method

Grid Solutions Framework SerializationTryDeserialize Method
Overload List
Name | Description
TryDeserializeT(Byte, SerializationFormat, T) | Attempts to deserialize a serialized Object.
TryDeserializeT(Stream, SerializationFormat, T) | Attempts to deserialize a serialized Object.
Top
See Also

Reference

Serialization Class
GSF Namespace


Serialization.TryDeserialize(T) Method (Byte[], SerializationFormat, T)

Grid Solutions Framework SerializationTryDeserializeT Method (Byte, SerializationFormat, T)
Attempts to deserialize a serialized Object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryDeserialize<T>(
    byte[] serializedObject,
    SerializationFormat serializationFormat,
    out T deserializedObject
)

Public Shared Function TryDeserialize(Of T) (
    serializedObject As Byte(),
    serializationFormat As SerializationFormat,
    <OutAttribute> ByRef deserializedObject As T
) As Boolean
static member TryDeserialize :
        serializedObject : byte[] *
        serializationFormat : SerializationFormat *
        deserializedObject : 'T byref -> bool

JavaScript does not support generic types or methods.
public:
generic<typename T>
static bool TryDeserialize(
    array<unsigned char>^ serializedObject,
    SerializationFormat serializationFormat,
    [OutAttribute] T% deserializedObject
)

Parameters

serializedObject
Type: SystemByte
Array of Bytes containing the serialized Object that is to be deserialized.
serializationFormat
Type: GSFSerializationFormat
SerializationFormat in which the serializedObject was serialized.
deserializedObject
Type: T
Deserialized Object.

Type Parameters

T
Type of the deserialized Object to be returned.

Return Value

Type: Boolean
trueif deserialization succeeded; otherwise false.
See Also

Reference

Serialization Class
TryDeserialize Overload
GSF Namespace


Serialization.TryDeserialize(T) Method (Stream, SerializationFormat, T)

Grid Solutions Framework SerializationTryDeserializeT Method (Stream, SerializationFormat, T)
Attempts to deserialize a serialized Object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryDeserialize<T>(
    Stream serializedObject,
    SerializationFormat serializationFormat,
    out T deserializedObject
)

Public Shared Function TryDeserialize(Of T) (
    serializedObject As Stream,
    serializationFormat As SerializationFormat,
    <OutAttribute> ByRef deserializedObject As T
) As Boolean
static member TryDeserialize :
        serializedObject : Stream *
        serializationFormat : SerializationFormat *
        deserializedObject : 'T byref -> bool

JavaScript does not support generic types or methods.
public:
generic<typename T>
static bool TryDeserialize(
    Stream^ serializedObject,
    SerializationFormat serializationFormat,
    [OutAttribute] T% deserializedObject
)

Parameters

serializedObject
Type: System.IOStream
Stream containing the serialized Object that is to be deserialized.
serializationFormat
Type: GSFSerializationFormat
SerializationFormat in which the serializedObject was serialized.
deserializedObject
Type: T
Deserialized Object.

Type Parameters

T
Type of the deserialized Object to be returned.

Return Value

Type: Boolean
trueif deserialization succeeded; otherwise false.
See Also

Reference

Serialization Class
TryDeserialize Overload
GSF Namespace


Serialization.TryGetObject Method

Grid Solutions Framework SerializationTryGetObject Method
Overload List
Name | Description
TryGetObject(Byte, Object) | Obsolete. Attempts binary deserialization on the byte array and returns the typed object for it.
TryGetObjectT(Byte, T) | Obsolete. Attempts binary deserialization on the byte array and returns the typed object for it.
TryGetObjectT(String, T) | Obsolete. Attempts XML deserialization on the XML string and returns the typed object for it.
Top
See Also

Reference

Serialization Class
GSF Namespace


Serialization.TryGetObject Method (Byte[], Object)

Grid Solutions Framework SerializationTryGetObject Method (Byte, Object)

Note: This API is now obsolete.

Attempts binary deserialization on the byte array and returns the typed object for it.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")]
public static bool TryGetObject(
    byte[] serializedObject,
    out Object deserializedObject
)
<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>
Public Shared Function TryGetObject (
    serializedObject As Byte(),
    <OutAttribute> ByRef deserializedObject As Object
) As Boolean
[<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>]
static member TryGetObject :
        serializedObject : byte[] *
        deserializedObject : Object byref -> bool

GSF.Serialization.TryGetObject = function(serializedObject, deserializedObject);
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Deserialize() method instead.")]
static bool TryGetObject(
    array<unsigned char>^ serializedObject,
    [OutAttribute] Object^% deserializedObject
)

Parameters

serializedObject
Type: SystemByte
A Byte array representing the object (serializedObject) to deserialize.
deserializedObject
Type: SystemObject
An Object, passed by reference, that is used to be hold the deserialized object.

Return Value

Type: Boolean
A Boolean which indicates whether the deserialization process was successful.
See Also

Reference

Serialization Class
TryGetObject Overload
GSF Namespace


Serialization.TryGetObject(T) Method (Byte[], T)

Grid Solutions Framework SerializationTryGetObjectT Method (Byte, T)

Note: This API is now obsolete.

Attempts binary deserialization on the byte array and returns the typed object for it.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")]
public static bool TryGetObject<T>(
    byte[] serializedObject,
    out T deserializedObject
)

<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>
Public Shared Function TryGetObject(Of T) (
    serializedObject As Byte(),
    <OutAttribute> ByRef deserializedObject As T
) As Boolean
[<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>]
static member TryGetObject :
        serializedObject : byte[] *
        deserializedObject : 'T byref -> bool

JavaScript does not support generic types or methods.
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Deserialize() method instead.")]
generic<typename T>
static bool TryGetObject(
    array<unsigned char>^ serializedObject,
    [OutAttribute] T% deserializedObject
)

Parameters

serializedObject
Type: SystemByte
A Byte array representing the object (serializedObject) to deserialize.
deserializedObject
Type: T
A type T object, passed by reference, that is used to be hold the deserialized object.

Type Parameters

T
The generic type T that is to be deserialized.

Return Value

Type: Boolean
A Boolean which indicates whether the deserialization process was successful.
See Also

Reference

Serialization Class
TryGetObject Overload
GSF Namespace


Serialization.TryGetObject(T) Method (String, T)

Grid Solutions Framework SerializationTryGetObjectT Method (String, T)

Note: This API is now obsolete.

Attempts XML deserialization on the XML string and returns the typed object for it.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")]
public static bool TryGetObject<T>(
    string serializedObject,
    out T deserializedObject
)

<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>
Public Shared Function TryGetObject(Of T) (
    serializedObject As String,
    <OutAttribute> ByRef deserializedObject As T
) As Boolean
[<ObsoleteAttribute("This method will be removed in future builds, use the Deserialize() method instead.")>]
static member TryGetObject :
        serializedObject : string *
        deserializedObject : 'T byref -> bool

JavaScript does not support generic types or methods.
public:
[ObsoleteAttribute(L"This method will be removed in future builds, use the Deserialize() method instead.")]
generic<typename T>
static bool TryGetObject(
    String^ serializedObject,
    [OutAttribute] T% deserializedObject
)

Parameters

serializedObject
Type: SystemString
String that contains the serialized representation of the object.
deserializedObject
Type: T
An object of type T that is passed in as the container to hold the deserialized object from the string serializedObject.

Type Parameters

T
The generic type T that is to be deserialized.

Return Value

Type: Boolean
Boolean value indicating if the deserialization was successful.
See Also

Reference

Serialization Class
TryGetObject Overload
GSF Namespace


SerializationFormat Enumeration

Grid Solutions Framework SerializationFormat Enumeration
Indicates the format of Object serialization or deserialization.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SerializationFormat
Public Enumeration SerializationFormat
type SerializationFormat
GSF.SerializationFormat = function();
GSF.SerializationFormat.createEnum('GSF.SerializationFormat', false);
public enum class SerializationFormat
Members
Member name | Value | Description
Xml | 0 | Object is serialized or deserialized using DataContractSerializer to XML (eXtensible Markup Language) format.
Json | 1 | Object is serialized or deserialized using DataContractJsonSerializer to JSON (JavaScript Object Notation) format.
Binary | 2 | Object is serialized or deserialized using BinaryFormatter to binary format.
See Also

Reference

GSF Namespace


StringExtensions Class

Grid Solutions Framework StringExtensions Class
Defines extension functions related to string manipulation.
Inheritance Hierarchy
SystemObject
GSFStringExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class StringExtensions
<ExtensionAttribute>
Public NotInheritable Class StringExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StringExtensions =  class end
GSF.StringExtensions = function();

Type.createClass(
    'GSF.StringExtensions');
[ExtensionAttribute]
public ref class StringExtensions abstract sealed

The StringExtensions type exposes the following members.

Methods
Name | Description
Base64Decode | Decodes a given base-64 encoded string encoded with Base64Encode(String).
Base64Encode | Encodes a string into a base-64 string.
CenterText(String, Int32) | Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with spaces. If value is greater than specified maximum length, value returned will be truncated from the right.
CenterText(String, Int32, Char) | Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with specified padding character. If value is greater than specified maximum length, value returned will be truncated from the right.
CharCount | Counts the total number of the occurrences of a character in the given string.
ConvertToTypeT(String) | Converts this string into the specified type.
ConvertToTypeT(String, Type) | Converts this string into the specified type.
ConvertToTypeT(String, Type, CultureInfo) | Converts this string into the specified type.
EnsureEnd(String, Char) | Ensures a string ends with a specific character.
EnsureEnd(String, String) | Ensures a string ends with a specific string.
EnsureEnd(String, Char, Boolean) | Ensures a string ends with a specific character.
EnsureStart(String, Char) | Ensures a string starts with a specific character.
EnsureStart(String, String) | Ensures a string starts with a specific string.
EnsureStart(String, Char, Boolean) | Ensures a string starts with a specific character.
GetSegments | Turns source string into an array of string segments - each with a set maximum width - for parsing or displaying.
IndexOfRepeatedChar(String) | Searches a string for an instance of a repeated character.
IndexOfRepeatedChar(String, Char) | Searches a string for a repeated instance of the specified characterToFind.
IndexOfRepeatedChar(String, Int32) | Searches a string for an instance of a repeated character from specified startIndex.
IndexOfRepeatedChar(String, Char, Int32) | Searches a string for a repeated instance of the specified characterToFind from specified startIndex.
IsAllDigits | Tests to see if a string is contains only digits based on Char.IsDigit function.
IsAllLetters(String) | Tests to see if a string contains only letters.
IsAllLetters(String, Boolean) | Tests to see if a string contains only letters.
IsAllLettersOrDigits(String) | Tests to see if a string contains only letters or digits.
IsAllLettersOrDigits(String, Boolean) | Tests to see if a string contains only letters or digits.
IsAllLower | Tests to see if a string's letters are all lower case.
IsAllNumbers | Tests to see if a string contains only numbers based on Char.IsNumber function.
IsAllUpper | Tests to see if a string's letters are all upper case.
JoinKeyValuePairs | Combines a dictionary of key-value pairs in to a string.
NotEmpty(String) | Ensures parameter is not an empty or null string. Returns a single space if test value is empty.
NotEmpty(String, String) | Ensures parameter is not an empty or null string.
ParseBoolean | Parses a string intended to represent a boolean value.
ParseKeyValuePairs | Parses key/value pair expressions from a string. Parameter pairs are delimited by keyValueDelimiter and multiple pairs separated by parameterDelimiter. Supports encapsulated nested expressions.
QuoteWrap | Wraps value in the quoteChar.
RegexDecode | Decodes the specified Regular Expression character back into a standard Unicode character.
RemoveCharacters | Removes all characters passing delegate test from a string.
RemoveControlCharacters | Removes all control characters from a string.
RemoveCrLfs | Removes all carriage returns and line feeds from a string.
RemoveDuplicates | Removes duplicate character strings (adjoining replication) in a string.
RemoveDuplicateWhiteSpace(String) | Replaces all repeating white space with a single space.
RemoveDuplicateWhiteSpace(String, Char) | Replaces all repeating white space with specified spacing character.
RemoveInvalidFileNameCharacters | Removes all invalid file name characters (\ / : * ? " < > |) from a string.
RemoveNull | Removes the terminator ('\0') from a null terminated string.
RemoveWhiteSpace | Removes all white space (as defined by IsWhiteSpace) from a string.
ReplaceCaseInsensitive | Performs a case insensitive string replacement.
ReplaceCharacters | Replaces all characters passing delegate test with specified replacement character.
ReplaceControlCharacters(String) | Replaces all control characters in a string with a single space.
ReplaceControlCharacters(String, Char) | Replaces all control characters in a string with specified replacement character.
ReplaceCrLfs | Replaces all carriage return and line feed characters (as well as CR/LF sequences) in a string with specified replacement character.
ReplaceInvalidFileNameCharacters | Replaces all invalid file name characters (\ / : * ? " < > |) in a string with the specified replacementCharacter.
ReplaceWhiteSpace | Replaces all white space characters (as defined by IsWhiteSpace) with specified replacement character.
Reverse | Reverses the order of the characters in a string.
ToSecureString | Converts the given string into a SecureString.
ToTitleCase | Converts the provided string into title case (upper case first letter of each word).
ToUnsecureString | Converts the given SecureString into a String.
TrimWithEllipsisEnd | Places an ellipsis at the end of a string as it is trimmed to length specified.
TrimWithEllipsisMiddle | Places an ellipsis in the middle of a string as it is trimmed to length specified.
TruncateLeft | Truncates the provided string from the left if it is longer that specified length.
TruncateRight | Truncates the provided string from the right if it is longer that specified length.
UriEncode | Escapes string using URL encoding.
Top
See Also

Reference

GSF Namespace


StringExtensions Methods

Grid Solutions Framework StringExtensions Methods

The StringExtensions type exposes the following members.

Methods
Name | Description
Base64Decode | Decodes a given base-64 encoded string encoded with Base64Encode(String).
Base64Encode | Encodes a string into a base-64 string.
CenterText(String, Int32) | Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with spaces. If value is greater than specified maximum length, value returned will be truncated from the right.
CenterText(String, Int32, Char) | Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with specified padding character. If value is greater than specified maximum length, value returned will be truncated from the right.
CharCount | Counts the total number of the occurrences of a character in the given string.
ConvertToTypeT(String) | Converts this string into the specified type.
ConvertToTypeT(String, Type) | Converts this string into the specified type.
ConvertToTypeT(String, Type, CultureInfo) | Converts this string into the specified type.
EnsureEnd(String, Char) | Ensures a string ends with a specific character.
EnsureEnd(String, String) | Ensures a string ends with a specific string.
EnsureEnd(String, Char, Boolean) | Ensures a string ends with a specific character.
EnsureStart(String, Char) | Ensures a string starts with a specific character.
EnsureStart(String, String) | Ensures a string starts with a specific string.
EnsureStart(String, Char, Boolean) | Ensures a string starts with a specific character.
GetSegments | Turns source string into an array of string segments - each with a set maximum width - for parsing or displaying.
IndexOfRepeatedChar(String) | Searches a string for an instance of a repeated character.
IndexOfRepeatedChar(String, Char) | Searches a string for a repeated instance of the specified characterToFind.
IndexOfRepeatedChar(String, Int32) | Searches a string for an instance of a repeated character from specified startIndex.
IndexOfRepeatedChar(String, Char, Int32) | Searches a string for a repeated instance of the specified characterToFind from specified startIndex.
IsAllDigits | Tests to see if a string is contains only digits based on Char.IsDigit function.
IsAllLetters(String) | Tests to see if a string contains only letters.
IsAllLetters(String, Boolean) | Tests to see if a string contains only letters.
IsAllLettersOrDigits(String) | Tests to see if a string contains only letters or digits.
IsAllLettersOrDigits(String, Boolean) | Tests to see if a string contains only letters or digits.
IsAllLower | Tests to see if a string's letters are all lower case.
IsAllNumbers | Tests to see if a string contains only numbers based on Char.IsNumber function.
IsAllUpper | Tests to see if a string's letters are all upper case.
JoinKeyValuePairs | Combines a dictionary of key-value pairs in to a string.
NotEmpty(String) | Ensures parameter is not an empty or null string. Returns a single space if test value is empty.
NotEmpty(String, String) | Ensures parameter is not an empty or null string.
ParseBoolean | Parses a string intended to represent a boolean value.
ParseKeyValuePairs | Parses key/value pair expressions from a string. Parameter pairs are delimited by keyValueDelimiter and multiple pairs separated by parameterDelimiter. Supports encapsulated nested expressions.
QuoteWrap | Wraps value in the quoteChar.
RegexDecode | Decodes the specified Regular Expression character back into a standard Unicode character.
RemoveCharacters | Removes all characters passing delegate test from a string.
RemoveControlCharacters | Removes all control characters from a string.
RemoveCrLfs | Removes all carriage returns and line feeds from a string.
RemoveDuplicates | Removes duplicate character strings (adjoining replication) in a string.
RemoveDuplicateWhiteSpace(String) | Replaces all repeating white space with a single space.
RemoveDuplicateWhiteSpace(String, Char) | Replaces all repeating white space with specified spacing character.
RemoveInvalidFileNameCharacters | Removes all invalid file name characters (\ / : * ? " < > |) from a string.
RemoveNull | Removes the terminator ('\0') from a null terminated string.
RemoveWhiteSpace | Removes all white space (as defined by IsWhiteSpace) from a string.
ReplaceCaseInsensitive | Performs a case insensitive string replacement.
ReplaceCharacters | Replaces all characters passing delegate test with specified replacement character.
ReplaceControlCharacters(String) | Replaces all control characters in a string with a single space.
ReplaceControlCharacters(String, Char) | Replaces all control characters in a string with specified replacement character.
ReplaceCrLfs | Replaces all carriage return and line feed characters (as well as CR/LF sequences) in a string with specified replacement character.
ReplaceInvalidFileNameCharacters | Replaces all invalid file name characters (\ / : * ? " < > |) in a string with the specified replacementCharacter.
ReplaceWhiteSpace | Replaces all white space characters (as defined by IsWhiteSpace) with specified replacement character.
Reverse | Reverses the order of the characters in a string.
ToSecureString | Converts the given string into a SecureString.
ToTitleCase | Converts the provided string into title case (upper case first letter of each word).
ToUnsecureString | Converts the given SecureString into a String.
TrimWithEllipsisEnd | Places an ellipsis at the end of a string as it is trimmed to length specified.
TrimWithEllipsisMiddle | Places an ellipsis in the middle of a string as it is trimmed to length specified.
TruncateLeft | Truncates the provided string from the left if it is longer that specified length.
TruncateRight | Truncates the provided string from the right if it is longer that specified length.
UriEncode | Escapes string using URL encoding.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.Base64Decode Method

Grid Solutions Framework StringExtensionsBase64Decode Method
Decodes a given base-64 encoded string encoded with Base64Encode(String).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Base64Decode(
    this string value
)
<ExtensionAttribute>
Public Shared Function Base64Decode (
    value As String
) As String
static member Base64Decode :
        value : string -> string

GSF.StringExtensions.Base64Decode = function(value);
public:
[ExtensionAttribute]
static String^ Base64Decode(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
A String value representing the decoded input of value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Note: This function decodes value back into a "String". Use the Convert.FromBase64String function to decode a base-64 encoded string back into a binary data buffer.
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.Base64Encode Method

Grid Solutions Framework StringExtensionsBase64Encode Method
Encodes a string into a base-64 string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Base64Encode(
    this string value
)
<ExtensionAttribute>
Public Shared Function Base64Encode (
    value As String
) As String
static member Base64Encode :
        value : string -> string

GSF.StringExtensions.Base64Encode = function(value);
public:
[ExtensionAttribute]
static String^ Base64Encode(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
A String value representing the encoded input of value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Performs a base-64 style of string encoding useful for data obfuscation or safe XML data string transmission.

Note: This function encodes a "String". Use the Convert.ToBase64String function to encode a binary data buffer.

See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.CenterText Method

Grid Solutions Framework StringExtensionsCenterText Method
Overload List
Name | Description
CenterText(String, Int32) | Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with spaces. If value is greater than specified maximum length, value returned will be truncated from the right.
CenterText(String, Int32, Char) | Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with specified padding character. If value is greater than specified maximum length, value returned will be truncated from the right.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.CenterText Method (String, Int32)

Grid Solutions Framework StringExtensionsCenterText Method (String, Int32)
Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with spaces. If value is greater than specified maximum length, value returned will be truncated from the right.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string CenterText(
    this string value,
    int maxLength
)
<ExtensionAttribute>
Public Shared Function CenterText (
    value As String,
    maxLength As Integer
) As String
static member CenterText :
        value : string *
        maxLength : int -> string

GSF.StringExtensions.CenterText = function(value, maxLength);
public:
[ExtensionAttribute]
static String^ CenterText(
    String^ value,
    int maxLength
)

Parameters

value
Type: SystemString
A String to be centered.
maxLength
Type: SystemInt32
An Int32 that is the maximum length of padding.

Return Value

Type: String
The centered string value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Handles multiple lines of text separated by Environment.NewLine.
See Also

Reference

StringExtensions Class
CenterText Overload
GSF Namespace


StringExtensions.CenterText Method (String, Int32, Char)

Grid Solutions Framework StringExtensionsCenterText Method (String, Int32, Char)
Centers text within the specified maximum length, biased to the left. Text will be padded to the left and right with specified padding character. If value is greater than specified maximum length, value returned will be truncated from the right.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string CenterText(
    this string value,
    int maxLength,
    char paddingCharacter
)
<ExtensionAttribute>
Public Shared Function CenterText (
    value As String,
    maxLength As Integer,
    paddingCharacter As Char
) As String
static member CenterText :
        value : string *
        maxLength : int *
        paddingCharacter : char -> string

GSF.StringExtensions.CenterText = function(value, maxLength, paddingCharacter);
public:
[ExtensionAttribute]
static String^ CenterText(
    String^ value,
    int maxLength,
    wchar_t paddingCharacter
)

Parameters

value
Type: SystemString
A String to be centered.
maxLength
Type: SystemInt32
An Int32 that is the maximum length of padding.
paddingCharacter
Type: SystemChar
The Char value to pad with.

Return Value

Type: String
The centered string value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Handles multiple lines of text separated by Environment.NewLine.
See Also

Reference

StringExtensions Class
CenterText Overload
GSF Namespace


StringExtensions.CharCount Method

Grid Solutions Framework StringExtensionsCharCount Method
Counts the total number of the occurrences of a character in the given string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CharCount(
    this string value,
    char characterToCount
)
<ExtensionAttribute>
Public Shared Function CharCount (
    value As String,
    characterToCount As Char
) As Integer
static member CharCount :
        value : string *
        characterToCount : char -> int

GSF.StringExtensions.CharCount = function(value, characterToCount);
public:
[ExtensionAttribute]
static int CharCount(
    String^ value,
    wchar_t characterToCount
)

Parameters

value
Type: SystemString
Input string.
characterToCount
Type: SystemChar
Character to be counted.

Return Value

Type: Int32
Total number of the occurrences of characterToCount in the given string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ConvertToType Method

Grid Solutions Framework StringExtensionsConvertToType Method
Overload List
Name | Description
ConvertToTypeT(String) | Converts this string into the specified type.
ConvertToTypeT(String, Type) | Converts this string into the specified type.
ConvertToTypeT(String, Type, CultureInfo) | Converts this string into the specified type.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ConvertToType(T) Method (String)

Grid Solutions Framework StringExtensionsConvertToTypeT Method (String)
Converts this string into the specified type.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T ConvertToType<T>(
    this string value
)

<ExtensionAttribute>
Public Shared Function ConvertToType(Of T) (
    value As String
) As T
static member ConvertToType :
        value : string -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T ConvertToType(
    String^ value
)

Parameters

value
Type: SystemString
Source string to convert to type.

Type Parameters

T
Type to convert string to.

Return Value

Type: T
String converted to specified Type; default value of specified type T if conversion fails.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function makes use of a TypeConverter to convert this String to the specified type T, the best way to make sure value can be converted back to its original type is to use the same TypeConverter to convert the original object to a String; see the TypeConvertToString(Object) method for an easy way to do this.
See Also

Reference

StringExtensions Class
ConvertToType Overload
GSF Namespace


StringExtensions.ConvertToType(T) Method (String, Type)

Grid Solutions Framework StringExtensionsConvertToTypeT Method (String, Type)
Converts this string into the specified type.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T ConvertToType<T>(
    this string value,
    Type type
)

<ExtensionAttribute>
Public Shared Function ConvertToType(Of T) (
    value As String,
    type As Type
) As T
static member ConvertToType :
        value : string *
        type : Type -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T ConvertToType(
    String^ value,
    Type^ type
)

Parameters

value
Type: SystemString
Source string to convert to type.
type
Type: SystemType
Type to convert string to.

Type Parameters

T
Type to convert string to.

Return Value

Type: T
String converted to specified Type; default value of specified type T if conversion fails.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function makes use of a TypeConverter to convert this String to the specified type, the best way to make sure value can be converted back to its original type is to use the same TypeConverter to convert the original object to a String; see the TypeConvertToString(Object) method for an easy way to do this.
See Also

Reference

StringExtensions Class
ConvertToType Overload
GSF Namespace


StringExtensions.ConvertToType(T) Method (String, Type, CultureInfo)

Grid Solutions Framework StringExtensionsConvertToTypeT Method (String, Type, CultureInfo)
Converts this string into the specified type.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T ConvertToType<T>(
    this string value,
    Type type,
    CultureInfo culture
)

<ExtensionAttribute>
Public Shared Function ConvertToType(Of T) (
    value As String,
    type As Type,
    culture As CultureInfo
) As T
static member ConvertToType :
        value : string *
        type : Type *
        culture : CultureInfo -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T ConvertToType(
    String^ value,
    Type^ type,
    CultureInfo^ culture
)

Parameters

value
Type: SystemString
Source string to convert to type.
type
Type: SystemType
Type to convert string to.
culture
Type: System.GlobalizationCultureInfo
CultureInfo to use for the conversion.

Type Parameters

T
Type to convert string to.

Return Value

Type: T
String converted to specified Type; default value of specified type T if conversion fails.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function makes use of a TypeConverter to convert this String to the specified type, the best way to make sure value can be converted back to its original type is to use the same TypeConverter to convert the original object to a String; see the TypeConvertToString(Object) method for an easy way to do this.
See Also

Reference

StringExtensions Class
ConvertToType Overload
GSF Namespace


StringExtensions.EnsureEnd Method

Grid Solutions Framework StringExtensionsEnsureEnd Method
Overload List
Name | Description
EnsureEnd(String, Char) | Ensures a string ends with a specific character.
EnsureEnd(String, String) | Ensures a string ends with a specific string.
EnsureEnd(String, Char, Boolean) | Ensures a string ends with a specific character.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.EnsureEnd Method (String, Char)

Grid Solutions Framework StringExtensionsEnsureEnd Method (String, Char)
Ensures a string ends with a specific character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string EnsureEnd(
    this string value,
    char endChar
)
<ExtensionAttribute>
Public Shared Function EnsureEnd (
    value As String,
    endChar As Char
) As String
static member EnsureEnd :
        value : string *
        endChar : char -> string

GSF.StringExtensions.EnsureEnd = function(value, endChar);
public:
[ExtensionAttribute]
static String^ EnsureEnd(
    String^ value,
    wchar_t endChar
)

Parameters

value
Type: SystemString
Input string to process.
endChar
Type: SystemChar
The character desired at string's end.

Return Value

Type: String
The sent string with character at the end.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
EnsureEnd Overload
GSF Namespace


StringExtensions.EnsureEnd Method (String, String)

Grid Solutions Framework StringExtensionsEnsureEnd Method (String, String)
Ensures a string ends with a specific string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string EnsureEnd(
    this string value,
    string endString
)
<ExtensionAttribute>
Public Shared Function EnsureEnd (
    value As String,
    endString As String
) As String
static member EnsureEnd :
        value : string *
        endString : string -> string

GSF.StringExtensions.EnsureEnd = function(value, endString);
public:
[ExtensionAttribute]
static String^ EnsureEnd(
    String^ value,
    String^ endString
)

Parameters

value
Type: SystemString
Input string to process.
endString
Type: SystemString
The string desired at string's end.

Return Value

Type: String
The sent string with string at the end.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
EnsureEnd Overload
GSF Namespace


StringExtensions.EnsureEnd Method (String, Char, Boolean)

Grid Solutions Framework StringExtensionsEnsureEnd Method (String, Char, Boolean)
Ensures a string ends with a specific character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string EnsureEnd(
    this string value,
    char endChar,
    bool removeRepeatingChar
)
<ExtensionAttribute>
Public Shared Function EnsureEnd (
    value As String,
    endChar As Char,
    removeRepeatingChar As Boolean
) As String
static member EnsureEnd :
        value : string *
        endChar : char *
        removeRepeatingChar : bool -> string

GSF.StringExtensions.EnsureEnd = function(value, endChar, removeRepeatingChar);
public:
[ExtensionAttribute]
static String^ EnsureEnd(
    String^ value,
    wchar_t endChar,
    bool removeRepeatingChar
)

Parameters

value
Type: SystemString
Input string to process.
endChar
Type: SystemChar
The character desired at string's end.
removeRepeatingChar
Type: SystemBoolean
Set to true to ensure one and only one instance of endChar.

Return Value

Type: String
The sent string with character at the end.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
EnsureEnd Overload
GSF Namespace


StringExtensions.EnsureStart Method

Grid Solutions Framework StringExtensionsEnsureStart Method
Overload List
Name | Description
EnsureStart(String, Char) | Ensures a string starts with a specific character.
EnsureStart(String, String) | Ensures a string starts with a specific string.
EnsureStart(String, Char, Boolean) | Ensures a string starts with a specific character.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.EnsureStart Method (String, Char)

Grid Solutions Framework StringExtensionsEnsureStart Method (String, Char)
Ensures a string starts with a specific character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string EnsureStart(
    this string value,
    char startChar
)
<ExtensionAttribute>
Public Shared Function EnsureStart (
    value As String,
    startChar As Char
) As String
static member EnsureStart :
        value : string *
        startChar : char -> string

GSF.StringExtensions.EnsureStart = function(value, startChar);
public:
[ExtensionAttribute]
static String^ EnsureStart(
    String^ value,
    wchar_t startChar
)

Parameters

value
Type: SystemString
Input string to process.
startChar
Type: SystemChar
The character desired at string start.

Return Value

Type: String
The sent string with character at the start.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
EnsureStart Overload
GSF Namespace


StringExtensions.EnsureStart Method (String, String)

Grid Solutions Framework StringExtensionsEnsureStart Method (String, String)
Ensures a string starts with a specific string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string EnsureStart(
    this string value,
    string startString
)
<ExtensionAttribute>
Public Shared Function EnsureStart (
    value As String,
    startString As String
) As String
static member EnsureStart :
        value : string *
        startString : string -> string

GSF.StringExtensions.EnsureStart = function(value, startString);
public:
[ExtensionAttribute]
static String^ EnsureStart(
    String^ value,
    String^ startString
)

Parameters

value
Type: SystemString
Input string to process.
startString
Type: SystemString
The string desired at string start.

Return Value

Type: String
The sent string with string at the start.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
EnsureStart Overload
GSF Namespace


StringExtensions.EnsureStart Method (String, Char, Boolean)

Grid Solutions Framework StringExtensionsEnsureStart Method (String, Char, Boolean)
Ensures a string starts with a specific character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string EnsureStart(
    this string value,
    char startChar,
    bool removeRepeatingChar
)
<ExtensionAttribute>
Public Shared Function EnsureStart (
    value As String,
    startChar As Char,
    removeRepeatingChar As Boolean
) As String
static member EnsureStart :
        value : string *
        startChar : char *
        removeRepeatingChar : bool -> string

GSF.StringExtensions.EnsureStart = function(value, startChar, removeRepeatingChar);
public:
[ExtensionAttribute]
static String^ EnsureStart(
    String^ value,
    wchar_t startChar,
    bool removeRepeatingChar
)

Parameters

value
Type: SystemString
Input string to process.
startChar
Type: SystemChar
The character desired at string start.
removeRepeatingChar
Type: SystemBoolean
Set to true to ensure one and only one instance of startChar.

Return Value

Type: String
The sent string with character at the start.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
EnsureStart Overload
GSF Namespace


StringExtensions.GetSegments Method

Grid Solutions Framework StringExtensionsGetSegments Method
Turns source string into an array of string segments - each with a set maximum width - for parsing or displaying.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] GetSegments(
    this string value,
    int segmentSize
)
<ExtensionAttribute>
Public Shared Function GetSegments (
    value As String,
    segmentSize As Integer
) As String()
static member GetSegments :
        value : string *
        segmentSize : int -> string[]

GSF.StringExtensions.GetSegments = function(value, segmentSize);
public:
[ExtensionAttribute]
static array<String^>^ GetSegments(
    String^ value,
    int segmentSize
)

Parameters

value
Type: SystemString
Input string to break up into segments.
segmentSize
Type: SystemInt32
Maximum size of returned segment.

Return Value

Type: String
Array of string segments as parsed from source string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Returns a single element array with an empty string if source string is null or empty.
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.IndexOfRepeatedChar Method

Grid Solutions Framework StringExtensionsIndexOfRepeatedChar Method
Overload List
Name | Description
IndexOfRepeatedChar(String) | Searches a string for an instance of a repeated character.
IndexOfRepeatedChar(String, Char) | Searches a string for a repeated instance of the specified characterToFind.
IndexOfRepeatedChar(String, Int32) | Searches a string for an instance of a repeated character from specified startIndex.
IndexOfRepeatedChar(String, Char, Int32) | Searches a string for a repeated instance of the specified characterToFind from specified startIndex.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.IndexOfRepeatedChar Method (String)

Grid Solutions Framework StringExtensionsIndexOfRepeatedChar Method (String)
Searches a string for an instance of a repeated character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOfRepeatedChar(
    this string value
)
<ExtensionAttribute>
Public Shared Function IndexOfRepeatedChar (
    value As String
) As Integer
static member IndexOfRepeatedChar :
        value : string -> int

GSF.StringExtensions.IndexOfRepeatedChar = function(value);
public:
[ExtensionAttribute]
static int IndexOfRepeatedChar(
    String^ value
)

Parameters

value
Type: SystemString
The string to process.

Return Value

Type: Int32
The index of the first instance of any character that is repeated or (-1) if no repeated chars found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
IndexOfRepeatedChar Overload
GSF Namespace


StringExtensions.IndexOfRepeatedChar Method (String, Char)

Grid Solutions Framework StringExtensionsIndexOfRepeatedChar Method (String, Char)
Searches a string for a repeated instance of the specified characterToFind.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOfRepeatedChar(
    this string value,
    char characterToFind
)
<ExtensionAttribute>
Public Shared Function IndexOfRepeatedChar (
    value As String,
    characterToFind As Char
) As Integer
static member IndexOfRepeatedChar :
        value : string *
        characterToFind : char -> int

GSF.StringExtensions.IndexOfRepeatedChar = function(value, characterToFind);
public:
[ExtensionAttribute]
static int IndexOfRepeatedChar(
    String^ value,
    wchar_t characterToFind
)

Parameters

value
Type: SystemString
The string to process.
characterToFind
Type: SystemChar
The character of interest.

Return Value

Type: Int32
The index of the first instance of the character that is repeated or (-1) if no repeated chars found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
IndexOfRepeatedChar Overload
GSF Namespace


StringExtensions.IndexOfRepeatedChar Method (String, Int32)

Grid Solutions Framework StringExtensionsIndexOfRepeatedChar Method (String, Int32)
Searches a string for an instance of a repeated character from specified startIndex.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOfRepeatedChar(
    this string value,
    int startIndex
)
<ExtensionAttribute>
Public Shared Function IndexOfRepeatedChar (
    value As String,
    startIndex As Integer
) As Integer
static member IndexOfRepeatedChar :
        value : string *
        startIndex : int -> int

GSF.StringExtensions.IndexOfRepeatedChar = function(value, startIndex);
public:
[ExtensionAttribute]
static int IndexOfRepeatedChar(
    String^ value,
    int startIndex
)

Parameters

value
Type: SystemString
The string to process.
startIndex
Type: SystemInt32
The index from which to begin the search.

Return Value

Type: Int32
The index of the first instance of any character that is repeated or (-1) if no repeated chars found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
IndexOfRepeatedChar Overload
GSF Namespace


StringExtensions.IndexOfRepeatedChar Method (String, Char, Int32)

Grid Solutions Framework StringExtensionsIndexOfRepeatedChar Method (String, Char, Int32)
Searches a string for a repeated instance of the specified characterToFind from specified startIndex.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOfRepeatedChar(
    this string value,
    char characterToFind,
    int startIndex
)
<ExtensionAttribute>
Public Shared Function IndexOfRepeatedChar (
    value As String,
    characterToFind As Char,
    startIndex As Integer
) As Integer
static member IndexOfRepeatedChar :
        value : string *
        characterToFind : char *
        startIndex : int -> int

GSF.StringExtensions.IndexOfRepeatedChar = function(value, characterToFind, startIndex);
public:
[ExtensionAttribute]
static int IndexOfRepeatedChar(
    String^ value,
    wchar_t characterToFind,
    int startIndex
)

Parameters

value
Type: SystemString
The string to process.
characterToFind
Type: SystemChar
The character of interest.
startIndex
Type: SystemInt32
The index from which to begin the search.

Return Value

Type: Int32
The index of the first instance of the character that is repeated or (-1) if no repeated chars found.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
IndexOfRepeatedChar Overload
GSF Namespace


StringExtensions.IsAllDigits Method

Grid Solutions Framework StringExtensionsIsAllDigits Method
Tests to see if a string is contains only digits based on Char.IsDigit function.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllDigits(
    this string value
)
<ExtensionAttribute>
Public Shared Function IsAllDigits (
    value As String
) As Boolean
static member IsAllDigits :
        value : string -> bool

GSF.StringExtensions.IsAllDigits = function(value);
public:
[ExtensionAttribute]
static bool IsAllDigits(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: Boolean
True, if all string's characters are digits; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace
CharIsDigit(Char)


StringExtensions.IsAllLetters Method

Grid Solutions Framework StringExtensionsIsAllLetters Method
Overload List
Name | Description
IsAllLetters(String) | Tests to see if a string contains only letters.
IsAllLetters(String, Boolean) | Tests to see if a string contains only letters.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.IsAllLetters Method (String)

Grid Solutions Framework StringExtensionsIsAllLetters Method (String)
Tests to see if a string contains only letters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllLetters(
    this string value
)
<ExtensionAttribute>
Public Shared Function IsAllLetters (
    value As String
) As Boolean
static member IsAllLetters :
        value : string -> bool

GSF.StringExtensions.IsAllLetters = function(value);
public:
[ExtensionAttribute]
static bool IsAllLetters(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: Boolean
True, if all string's characters are letters; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Any non-letter character (e.g., punctuation marks) causes this function to return false (See overload to ignore punctuation marks.).
See Also

Reference

StringExtensions Class
IsAllLetters Overload
GSF Namespace


StringExtensions.IsAllLetters Method (String, Boolean)

Grid Solutions Framework StringExtensionsIsAllLetters Method (String, Boolean)
Tests to see if a string contains only letters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllLetters(
    this string value,
    bool ignorePunctuation
)
<ExtensionAttribute>
Public Shared Function IsAllLetters (
    value As String,
    ignorePunctuation As Boolean
) As Boolean
static member IsAllLetters :
        value : string *
        ignorePunctuation : bool -> bool

GSF.StringExtensions.IsAllLetters = function(value, ignorePunctuation);
public:
[ExtensionAttribute]
static bool IsAllLetters(
    String^ value,
    bool ignorePunctuation
)

Parameters

value
Type: SystemString
Input string.
ignorePunctuation
Type: SystemBoolean
Set to True to ignore punctuation.

Return Value

Type: Boolean
True, if all string's characters are letters; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
IsAllLetters Overload
GSF Namespace


StringExtensions.IsAllLettersOrDigits Method

Grid Solutions Framework StringExtensionsIsAllLettersOrDigits Method
Overload List
Name | Description
IsAllLettersOrDigits(String) | Tests to see if a string contains only letters or digits.
IsAllLettersOrDigits(String, Boolean) | Tests to see if a string contains only letters or digits.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.IsAllLettersOrDigits Method (String)

Grid Solutions Framework StringExtensionsIsAllLettersOrDigits Method (String)
Tests to see if a string contains only letters or digits.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllLettersOrDigits(
    this string value
)
<ExtensionAttribute>
Public Shared Function IsAllLettersOrDigits (
    value As String
) As Boolean
static member IsAllLettersOrDigits :
        value : string -> bool

GSF.StringExtensions.IsAllLettersOrDigits = function(value);
public:
[ExtensionAttribute]
static bool IsAllLettersOrDigits(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: Boolean
True, if all string's characters are either letters or digits; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Any non-letter, non-digit character (e.g., punctuation marks) causes this function to return false (See overload to ignore punctuation marks.).
See Also

Reference

StringExtensions Class
IsAllLettersOrDigits Overload
GSF Namespace


StringExtensions.IsAllLettersOrDigits Method (String, Boolean)

Grid Solutions Framework StringExtensionsIsAllLettersOrDigits Method (String, Boolean)
Tests to see if a string contains only letters or digits.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllLettersOrDigits(
    this string value,
    bool ignorePunctuation
)
<ExtensionAttribute>
Public Shared Function IsAllLettersOrDigits (
    value As String,
    ignorePunctuation As Boolean
) As Boolean
static member IsAllLettersOrDigits :
        value : string *
        ignorePunctuation : bool -> bool

GSF.StringExtensions.IsAllLettersOrDigits = function(value, ignorePunctuation);
public:
[ExtensionAttribute]
static bool IsAllLettersOrDigits(
    String^ value,
    bool ignorePunctuation
)

Parameters

value
Type: SystemString
Input string.
ignorePunctuation
Type: SystemBoolean
Set to True to ignore punctuation.

Return Value

Type: Boolean
True, if all string's characters are letters or digits; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
IsAllLettersOrDigits Overload
GSF Namespace


StringExtensions.IsAllLower Method

Grid Solutions Framework StringExtensionsIsAllLower Method
Tests to see if a string's letters are all lower case.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllLower(
    this string value
)
<ExtensionAttribute>
Public Shared Function IsAllLower (
    value As String
) As Boolean
static member IsAllLower :
        value : string -> bool

GSF.StringExtensions.IsAllLower = function(value);
public:
[ExtensionAttribute]
static bool IsAllLower(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: Boolean
True, if all string's letter characters are lower case; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.IsAllNumbers Method

Grid Solutions Framework StringExtensionsIsAllNumbers Method
Tests to see if a string contains only numbers based on Char.IsNumber function.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllNumbers(
    this string value
)
<ExtensionAttribute>
Public Shared Function IsAllNumbers (
    value As String
) As Boolean
static member IsAllNumbers :
        value : string -> bool

GSF.StringExtensions.IsAllNumbers = function(value);
public:
[ExtensionAttribute]
static bool IsAllNumbers(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: Boolean
True, if all string's characters are numbers; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace
CharIsNumber(Char)


StringExtensions.IsAllUpper Method

Grid Solutions Framework StringExtensionsIsAllUpper Method
Tests to see if a string's letters are all upper case.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsAllUpper(
    this string value
)
<ExtensionAttribute>
Public Shared Function IsAllUpper (
    value As String
) As Boolean
static member IsAllUpper :
        value : string -> bool

GSF.StringExtensions.IsAllUpper = function(value);
public:
[ExtensionAttribute]
static bool IsAllUpper(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: Boolean
True, if all string's letter characters are upper case; otherwise, false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.JoinKeyValuePairs Method

Grid Solutions Framework StringExtensionsJoinKeyValuePairs Method
Combines a dictionary of key-value pairs in to a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string JoinKeyValuePairs(
    this IDictionary<string, string> pairs,
    char parameterDelimiter = ';',
    char keyValueDelimiter = '=',
    char startValueDelimiter = '{',
    char endValueDelimiter = '}'
)
<ExtensionAttribute>
Public Shared Function JoinKeyValuePairs (
    pairs As IDictionary(Of String, String),
    Optional parameterDelimiter As Char = ";"C,
    Optional keyValueDelimiter As Char = "="C,
    Optional startValueDelimiter As Char = "{"C,
    Optional endValueDelimiter As Char = "}"C
) As String
static member JoinKeyValuePairs :
        pairs : IDictionary<string, string> *
        ?parameterDelimiter : char *
        ?keyValueDelimiter : char *
        ?startValueDelimiter : char *
        ?endValueDelimiter : char
(* Defaults:
        let _parameterDelimiter = defaultArg parameterDelimiter ';'
        let _keyValueDelimiter = defaultArg keyValueDelimiter '='
        let _startValueDelimiter = defaultArg startValueDelimiter '{'
        let _endValueDelimiter = defaultArg endValueDelimiter '}'
*)
-> string

GSF.StringExtensions.JoinKeyValuePairs = function(pairs, parameterDelimiter, keyValueDelimiter, startValueDelimiter, endValueDelimiter);
public:
[ExtensionAttribute]
static String^ JoinKeyValuePairs(
    IDictionary<String^, String^>^ pairs,
    wchar_t parameterDelimiter = L';',
    wchar_t keyValueDelimiter = L'=',
    wchar_t startValueDelimiter = L'{',
    wchar_t endValueDelimiter = L'}'
)

Parameters

pairs
Type: System.Collections.GenericIDictionary String, String
Dictionary of key-value pairs.
parameterDelimiter (Optional)
Type: SystemChar
Character that delimits one key-value pair from another (e.g. ';').
keyValueDelimiter (Optional)
Type: SystemChar
Character that delimits a key from its value (e.g. '=').
startValueDelimiter (Optional)
Type: SystemChar
Optional character that marks the start of a value such that value could contain other parameterDelimiter or keyValueDelimiter characters (e.g., "{").
endValueDelimiter (Optional)
Type: SystemChar
Optional character that marks the end of a value such that value could contain other parameterDelimiter or keyValueDelimiter characters (e.g., "}").

Return Value

Type: String
A string of key-value pairs.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary String, String . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Values will be escaped within startValueDelimiter and endValueDelimiter to contain nested key/value pair expressions like the following: normalKVP=-1; nestedKVP={p1=true; p2=0.001}, when either the parameterDelimiter or keyValueDelimiter are detected in the value of the key/value pair.
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.NotEmpty Method

Grid Solutions Framework StringExtensionsNotEmpty Method
Overload List
Name | Description
NotEmpty(String) | Ensures parameter is not an empty or null string. Returns a single space if test value is empty.
NotEmpty(String, String) | Ensures parameter is not an empty or null string.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.NotEmpty Method (String)

Grid Solutions Framework StringExtensionsNotEmpty Method (String)
Ensures parameter is not an empty or null string. Returns a single space if test value is empty.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string NotEmpty(
    this string testValue
)
<ExtensionAttribute>
Public Shared Function NotEmpty (
    testValue As String
) As String
static member NotEmpty :
        testValue : string -> string

GSF.StringExtensions.NotEmpty = function(testValue);
public:
[ExtensionAttribute]
static String^ NotEmpty(
    String^ testValue
)

Parameters

testValue
Type: SystemString
Value to test for null or empty.

Return Value

Type: String
A non-empty string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
NotEmpty Overload
GSF Namespace


StringExtensions.NotEmpty Method (String, String)

Grid Solutions Framework StringExtensionsNotEmpty Method (String, String)
Ensures parameter is not an empty or null string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string NotEmpty(
    this string testValue,
    string nonEmptyReturnValue
)
<ExtensionAttribute>
Public Shared Function NotEmpty (
    testValue As String,
    nonEmptyReturnValue As String
) As String
static member NotEmpty :
        testValue : string *
        nonEmptyReturnValue : string -> string

GSF.StringExtensions.NotEmpty = function(testValue, nonEmptyReturnValue);
public:
[ExtensionAttribute]
static String^ NotEmpty(
    String^ testValue,
    String^ nonEmptyReturnValue
)

Parameters

testValue
Type: SystemString
Value to test for null or empty.
nonEmptyReturnValue
Type: SystemString
Value to return if testValue is null or empty.

Return Value

Type: String
A non-empty string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
NotEmpty Overload
GSF Namespace


StringExtensions.ParseBoolean Method

Grid Solutions Framework StringExtensionsParseBoolean Method
Parses a string intended to represent a boolean value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ParseBoolean(
    this string value
)
<ExtensionAttribute>
Public Shared Function ParseBoolean (
    value As String
) As Boolean
static member ParseBoolean :
        value : string -> bool

GSF.StringExtensions.ParseBoolean = function(value);
public:
[ExtensionAttribute]
static bool ParseBoolean(
    String^ value
)

Parameters

value
Type: SystemString
String representing a boolean value.

Return Value

Type: Boolean
Parsed boolean value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function, unlike Boolean.Parse, correctly parses a boolean value, even if the string value specified is a number (e.g., 0 or -1). Boolean.Parse expects a string to be represented as "True" or "False" (i.e., Boolean.TrueString or Boolean.FalseString respectively).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ParseKeyValuePairs Method

Grid Solutions Framework StringExtensionsParseKeyValuePairs Method
Parses key/value pair expressions from a string. Parameter pairs are delimited by keyValueDelimiter and multiple pairs separated by parameterDelimiter. Supports encapsulated nested expressions.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Dictionary<string, string> ParseKeyValuePairs(
    this string value,
    char parameterDelimiter = ';',
    char keyValueDelimiter = '=',
    char startValueDelimiter = '{',
    char endValueDelimiter = '}',
    bool ignoreDuplicateKeys = true
)
<ExtensionAttribute>
Public Shared Function ParseKeyValuePairs (
    value As String,
    Optional parameterDelimiter As Char = ";"C,
    Optional keyValueDelimiter As Char = "="C,
    Optional startValueDelimiter As Char = "{"C,
    Optional endValueDelimiter As Char = "}"C,
    Optional ignoreDuplicateKeys As Boolean = true
) As Dictionary(Of String, String)
static member ParseKeyValuePairs :
        value : string *
        ?parameterDelimiter : char *
        ?keyValueDelimiter : char *
        ?startValueDelimiter : char *
        ?endValueDelimiter : char *
        ?ignoreDuplicateKeys : bool
(* Defaults:
        let _parameterDelimiter = defaultArg parameterDelimiter ';'
        let _keyValueDelimiter = defaultArg keyValueDelimiter '='
        let _startValueDelimiter = defaultArg startValueDelimiter '{'
        let _endValueDelimiter = defaultArg endValueDelimiter '}'
        let _ignoreDuplicateKeys = defaultArg ignoreDuplicateKeys true
*)
-> Dictionary<string, string>

GSF.StringExtensions.ParseKeyValuePairs = function(value, parameterDelimiter, keyValueDelimiter, startValueDelimiter, endValueDelimiter, ignoreDuplicateKeys);
public:
[ExtensionAttribute]
static Dictionary<String^, String^>^ ParseKeyValuePairs(
    String^ value,
    wchar_t parameterDelimiter = L';',
    wchar_t keyValueDelimiter = L'=',
    wchar_t startValueDelimiter = L'{',
    wchar_t endValueDelimiter = L'}',
    bool ignoreDuplicateKeys = true
)

Parameters

value
Type: SystemString
String containing key/value pair expressions to parse.
parameterDelimiter (Optional)
Type: SystemChar
Character that delimits one key/value pair from another.
keyValueDelimiter (Optional)
Type: SystemChar
Character that delimits key from value.
startValueDelimiter (Optional)
Type: SystemChar
Optional character that marks the start of a value such that value could contain other parameterDelimiter or keyValueDelimiter characters.
endValueDelimiter (Optional)
Type: SystemChar
Optional character that marks the end of a value such that value could contain other parameterDelimiter or keyValueDelimiter characters.
ignoreDuplicateKeys (Optional)
Type: SystemBoolean
Flag determines whether duplicates are ignored. If flag is set to false an ArgumentException will be thrown when all key parameters are not unique.

Return Value

Type: Dictionary String, String
Dictionary of key/value pairs.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | value is null.
ArgumentException | All delimiters must be unique -or- all keys must be unique when ignoreDuplicateKeys is set to false.
FormatException | Total nested key/value pair expressions are mismatched -or- encountered endValueDelimiter before startValueDelimiter.
Remarks

Parses a string containing key/value pair expressions (e.g., "localPort=5001; transportProtocol=UDP; interface=0.0.0.0"). This method treats all "keys" as case-insensitive. Nesting of key/value pair expressions is allowed by encapsulating the value using the startValueDelimiter and endValueDelimiter values (e.g., "dataChannel={Port=-1;Clients=localhost:8800}; commandChannel={Port=8900}; dataFormat=FloatingPoint;"). There must be one endValueDelimiter for each encountered startValueDelimiter in the value or a FormatException will be thrown. Multiple levels of nesting is supported. If the ignoreDuplicateKeys flag is set to false an ArgumentException will be thrown when all key parameters are not unique. Note that keys within nested expressions are considered separate key/value pair strings and are not considered when checking for duplicate keys.

See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.QuoteWrap Method

Grid Solutions Framework StringExtensionsQuoteWrap Method
Wraps value in the quoteChar.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string QuoteWrap(
    this string value,
    char quoteChar = '"'
)
<ExtensionAttribute>
Public Shared Function QuoteWrap (
    value As String,
    Optional quoteChar As Char = """C
) As String
static member QuoteWrap :
        value : string *
        ?quoteChar : char
(* Defaults:
        let _quoteChar = defaultArg quoteChar '"'
*)
-> string

GSF.StringExtensions.QuoteWrap = function(value, quoteChar);
public:
[ExtensionAttribute]
static String^ QuoteWrap(
    String^ value,
    wchar_t quoteChar = L'"'
)

Parameters

value
Type: SystemString
Input string to process
quoteChar (Optional)
Type: SystemChar
The char to wrap value

Return Value

Type: String
value wrapped in quoteChar

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RegexDecode Method

Grid Solutions Framework StringExtensionsRegexDecode Method
Decodes the specified Regular Expression character back into a standard Unicode character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static char RegexDecode(
    this string value
)
<ExtensionAttribute>
Public Shared Function RegexDecode (
    value As String
) As Char
static member RegexDecode :
        value : string -> char

GSF.StringExtensions.RegexDecode = function(value);
public:
[ExtensionAttribute]
static wchar_t RegexDecode(
    String^ value
)

Parameters

value
Type: SystemString
Regular Expression character to decode back into a Unicode character.

Return Value

Type: Char
Standard Unicode character representation of specified Regular Expression character.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveCharacters Method

Grid Solutions Framework StringExtensionsRemoveCharacters Method
Removes all characters passing delegate test from a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveCharacters(
    this string value,
    Func<char, bool> characterTestFunction
)
<ExtensionAttribute>
Public Shared Function RemoveCharacters (
    value As String,
    characterTestFunction As Func(Of Char, Boolean)
) As String
static member RemoveCharacters :
        value : string *
        characterTestFunction : Func<char, bool> -> string

GSF.StringExtensions.RemoveCharacters = function(value, characterTestFunction);
public:
[ExtensionAttribute]
static String^ RemoveCharacters(
    String^ value,
    Func<wchar_t, bool>^ characterTestFunction
)

Parameters

value
Type: SystemString
Input string.
characterTestFunction
Type: SystemFunc Char, Boolean
Delegate used to determine whether or not character should be removed.

Return Value

Type: String
Returns value with all characters passing delegate test removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveControlCharacters Method

Grid Solutions Framework StringExtensionsRemoveControlCharacters Method
Removes all control characters from a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveControlCharacters(
    this string value
)
<ExtensionAttribute>
Public Shared Function RemoveControlCharacters (
    value As String
) As String
static member RemoveControlCharacters :
        value : string -> string

GSF.StringExtensions.RemoveControlCharacters = function(value);
public:
[ExtensionAttribute]
static String^ RemoveControlCharacters(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
Returns value with all control characters removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveCrLfs Method

Grid Solutions Framework StringExtensionsRemoveCrLfs Method
Removes all carriage returns and line feeds from a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveCrLfs(
    this string value
)
<ExtensionAttribute>
Public Shared Function RemoveCrLfs (
    value As String
) As String
static member RemoveCrLfs :
        value : string -> string

GSF.StringExtensions.RemoveCrLfs = function(value);
public:
[ExtensionAttribute]
static String^ RemoveCrLfs(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
Returns value with all CR and LF characters removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveDuplicates Method

Grid Solutions Framework StringExtensionsRemoveDuplicates Method
Removes duplicate character strings (adjoining replication) in a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveDuplicates(
    this string value,
    string duplicatedValue
)
<ExtensionAttribute>
Public Shared Function RemoveDuplicates (
    value As String,
    duplicatedValue As String
) As String
static member RemoveDuplicates :
        value : string *
        duplicatedValue : string -> string

GSF.StringExtensions.RemoveDuplicates = function(value, duplicatedValue);
public:
[ExtensionAttribute]
static String^ RemoveDuplicates(
    String^ value,
    String^ duplicatedValue
)

Parameters

value
Type: SystemString
Input string.
duplicatedValue
Type: SystemString
String whose duplicates are to be removed.

Return Value

Type: String
Returns value with all duplicated duplicatedValue removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveDuplicateWhiteSpace Method

Grid Solutions Framework StringExtensionsRemoveDuplicateWhiteSpace Method
Overload List
Name | Description
RemoveDuplicateWhiteSpace(String) | Replaces all repeating white space with a single space.
RemoveDuplicateWhiteSpace(String, Char) | Replaces all repeating white space with specified spacing character.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveDuplicateWhiteSpace Method (String)

Grid Solutions Framework StringExtensionsRemoveDuplicateWhiteSpace Method (String)
Replaces all repeating white space with a single space.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveDuplicateWhiteSpace(
    this string value
)
<ExtensionAttribute>
Public Shared Function RemoveDuplicateWhiteSpace (
    value As String
) As String
static member RemoveDuplicateWhiteSpace :
        value : string -> string

GSF.StringExtensions.RemoveDuplicateWhiteSpace = function(value);
public:
[ExtensionAttribute]
static String^ RemoveDuplicateWhiteSpace(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
Returns value with all duplicate white space removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
RemoveDuplicateWhiteSpace Overload
GSF Namespace


StringExtensions.RemoveDuplicateWhiteSpace Method (String, Char)

Grid Solutions Framework StringExtensionsRemoveDuplicateWhiteSpace Method (String, Char)
Replaces all repeating white space with specified spacing character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveDuplicateWhiteSpace(
    this string value,
    char spacingCharacter
)
<ExtensionAttribute>
Public Shared Function RemoveDuplicateWhiteSpace (
    value As String,
    spacingCharacter As Char
) As String
static member RemoveDuplicateWhiteSpace :
        value : string *
        spacingCharacter : char -> string

GSF.StringExtensions.RemoveDuplicateWhiteSpace = function(value, spacingCharacter);
public:
[ExtensionAttribute]
static String^ RemoveDuplicateWhiteSpace(
    String^ value,
    wchar_t spacingCharacter
)

Parameters

value
Type: SystemString
Input string.
spacingCharacter
Type: SystemChar
Character value to use to insert as single white space value.

Return Value

Type: String
Returns value with all duplicate white space removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function allows you to specify spacing character (e.g., you may want to use a non-breaking space: Convert.ToChar(160)).
See Also

Reference

StringExtensions Class
RemoveDuplicateWhiteSpace Overload
GSF Namespace


StringExtensions.RemoveInvalidFileNameCharacters Method

Grid Solutions Framework StringExtensionsRemoveInvalidFileNameCharacters Method
Removes all invalid file name characters (\ / : * ? " < > |) from a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveInvalidFileNameCharacters(
    this string value
)
<ExtensionAttribute>
Public Shared Function RemoveInvalidFileNameCharacters (
    value As String
) As String
static member RemoveInvalidFileNameCharacters :
        value : string -> string

GSF.StringExtensions.RemoveInvalidFileNameCharacters = function(value);
public:
[ExtensionAttribute]
static String^ RemoveInvalidFileNameCharacters(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
Returns value with all invalid file name characters removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveNull Method

Grid Solutions Framework StringExtensionsRemoveNull Method
Removes the terminator ('\0') from a null terminated string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveNull(
    this string value
)
<ExtensionAttribute>
Public Shared Function RemoveNull (
    value As String
) As String
static member RemoveNull :
        value : string -> string

GSF.StringExtensions.RemoveNull = function(value);
public:
[ExtensionAttribute]
static String^ RemoveNull(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
Returns value with all characters to the left of the terminator.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.RemoveWhiteSpace Method

Grid Solutions Framework StringExtensionsRemoveWhiteSpace Method
Removes all white space (as defined by IsWhiteSpace) from a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoveWhiteSpace(
    this string value
)
<ExtensionAttribute>
Public Shared Function RemoveWhiteSpace (
    value As String
) As String
static member RemoveWhiteSpace :
        value : string -> string

GSF.StringExtensions.RemoveWhiteSpace = function(value);
public:
[ExtensionAttribute]
static String^ RemoveWhiteSpace(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
Returns value with all white space removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ReplaceCaseInsensitive Method

Grid Solutions Framework StringExtensionsReplaceCaseInsensitive Method
Performs a case insensitive string replacement.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ReplaceCaseInsensitive(
    this string value,
    string fromText,
    string toText
)
<ExtensionAttribute>
Public Shared Function ReplaceCaseInsensitive (
    value As String,
    fromText As String,
    toText As String
) As String
static member ReplaceCaseInsensitive :
        value : string *
        fromText : string *
        toText : string -> string

GSF.StringExtensions.ReplaceCaseInsensitive = function(value, fromText, toText);
public:
[ExtensionAttribute]
static String^ ReplaceCaseInsensitive(
    String^ value,
    String^ fromText,
    String^ toText
)

Parameters

value
Type: SystemString
The string to examine.
fromText
Type: SystemString
The value to replace.
toText
Type: SystemString
The new value to be inserted

Return Value

Type: String
A string with replacements.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ReplaceCharacters Method

Grid Solutions Framework StringExtensionsReplaceCharacters Method
Replaces all characters passing delegate test with specified replacement character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ReplaceCharacters(
    this string value,
    char replacementCharacter,
    Func<char, bool> characterTestFunction
)
<ExtensionAttribute>
Public Shared Function ReplaceCharacters (
    value As String,
    replacementCharacter As Char,
    characterTestFunction As Func(Of Char, Boolean)
) As String
static member ReplaceCharacters :
        value : string *
        replacementCharacter : char *
        characterTestFunction : Func<char, bool> -> string

GSF.StringExtensions.ReplaceCharacters = function(value, replacementCharacter, characterTestFunction);
public:
[ExtensionAttribute]
static String^ ReplaceCharacters(
    String^ value,
    wchar_t replacementCharacter,
    Func<wchar_t, bool>^ characterTestFunction
)

Parameters

value
Type: SystemString
Input string.
replacementCharacter
Type: SystemChar
Character used to replace characters passing delegate test.
characterTestFunction
Type: SystemFunc Char, Boolean
Delegate used to determine whether or not character should be replaced.

Return Value

Type: String
Returns value with all characters passing delegate test replaced.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Allows you to specify a replacement character (e.g., you may want to use a non-breaking space: Convert.ToChar(160)).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ReplaceControlCharacters Method

Grid Solutions Framework StringExtensionsReplaceControlCharacters Method
Overload List
Name | Description
ReplaceControlCharacters(String) | Replaces all control characters in a string with a single space.
ReplaceControlCharacters(String, Char) | Replaces all control characters in a string with specified replacement character.
Top
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ReplaceControlCharacters Method (String)

Grid Solutions Framework StringExtensionsReplaceControlCharacters Method (String)
Replaces all control characters in a string with a single space.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ReplaceControlCharacters(
    this string value
)
<ExtensionAttribute>
Public Shared Function ReplaceControlCharacters (
    value As String
) As String
static member ReplaceControlCharacters :
        value : string -> string

GSF.StringExtensions.ReplaceControlCharacters = function(value);
public:
[ExtensionAttribute]
static String^ ReplaceControlCharacters(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
Returns value with all control characters replaced as a single space.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
ReplaceControlCharacters Overload
GSF Namespace


StringExtensions.ReplaceControlCharacters Method (String, Char)

Grid Solutions Framework StringExtensionsReplaceControlCharacters Method (String, Char)
Replaces all control characters in a string with specified replacement character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ReplaceControlCharacters(
    this string value,
    char replacementCharacter
)
<ExtensionAttribute>
Public Shared Function ReplaceControlCharacters (
    value As String,
    replacementCharacter As Char
) As String
static member ReplaceControlCharacters :
        value : string *
        replacementCharacter : char -> string

GSF.StringExtensions.ReplaceControlCharacters = function(value, replacementCharacter);
public:
[ExtensionAttribute]
static String^ ReplaceControlCharacters(
    String^ value,
    wchar_t replacementCharacter
)

Parameters

value
Type: SystemString
Input string.
replacementCharacter
Type: SystemChar
Character used to "replace" control characters.

Return Value

Type: String
Returns value with all control characters replaced.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Allows you to specify a replacement character (e.g., you may want to use a non-breaking space: Convert.ToChar(160)).
See Also

Reference

StringExtensions Class
ReplaceControlCharacters Overload
GSF Namespace


StringExtensions.ReplaceCrLfs Method

Grid Solutions Framework StringExtensionsReplaceCrLfs Method
Replaces all carriage return and line feed characters (as well as CR/LF sequences) in a string with specified replacement character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ReplaceCrLfs(
    this string value,
    char replacementCharacter
)
<ExtensionAttribute>
Public Shared Function ReplaceCrLfs (
    value As String,
    replacementCharacter As Char
) As String
static member ReplaceCrLfs :
        value : string *
        replacementCharacter : char -> string

GSF.StringExtensions.ReplaceCrLfs = function(value, replacementCharacter);
public:
[ExtensionAttribute]
static String^ ReplaceCrLfs(
    String^ value,
    wchar_t replacementCharacter
)

Parameters

value
Type: SystemString
Input string.
replacementCharacter
Type: SystemChar
Character used to "replace" CR and LF characters.

Return Value

Type: String
Returns value with all CR and LF characters replaced.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Allows you to specify a replacement character (e.g., you may want to use a non-breaking space: Convert.ToChar(160)).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ReplaceInvalidFileNameCharacters Method

Grid Solutions Framework StringExtensionsReplaceInvalidFileNameCharacters Method
Replaces all invalid file name characters (\ / : * ? " < > |) in a string with the specified replacementCharacter.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ReplaceInvalidFileNameCharacters(
    this string value,
    char replacementCharacter
)
<ExtensionAttribute>
Public Shared Function ReplaceInvalidFileNameCharacters (
    value As String,
    replacementCharacter As Char
) As String
static member ReplaceInvalidFileNameCharacters :
        value : string *
        replacementCharacter : char -> string

GSF.StringExtensions.ReplaceInvalidFileNameCharacters = function(value, replacementCharacter);
public:
[ExtensionAttribute]
static String^ ReplaceInvalidFileNameCharacters(
    String^ value,
    wchar_t replacementCharacter
)

Parameters

value
Type: SystemString
Input string.
replacementCharacter
Type: SystemChar
Character used to replace the invalid characters.

Return Value

Type: String
>Returns value with all invalid file name characters replaced.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ReplaceWhiteSpace Method

Grid Solutions Framework StringExtensionsReplaceWhiteSpace Method
Replaces all white space characters (as defined by IsWhiteSpace) with specified replacement character.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ReplaceWhiteSpace(
    this string value,
    char replacementCharacter
)
<ExtensionAttribute>
Public Shared Function ReplaceWhiteSpace (
    value As String,
    replacementCharacter As Char
) As String
static member ReplaceWhiteSpace :
        value : string *
        replacementCharacter : char -> string

GSF.StringExtensions.ReplaceWhiteSpace = function(value, replacementCharacter);
public:
[ExtensionAttribute]
static String^ ReplaceWhiteSpace(
    String^ value,
    wchar_t replacementCharacter
)

Parameters

value
Type: SystemString
Input string.
replacementCharacter
Type: SystemChar
Character used to "replace" white space characters.

Return Value

Type: String
Returns value with all white space characters replaced.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Allows you to specify a replacement character (e.g., you may want to use a non-breaking space: Convert.ToChar(160)).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.Reverse Method

Grid Solutions Framework StringExtensionsReverse Method
Reverses the order of the characters in a string.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Reverse(
    this string value
)
<ExtensionAttribute>
Public Shared Function Reverse (
    value As String
) As String
static member Reverse :
        value : string -> string

GSF.StringExtensions.Reverse = function(value);
public:
[ExtensionAttribute]
static String^ Reverse(
    String^ value
)

Parameters

value
Type: SystemString
Input string to process.

Return Value

Type: String
The reversed string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ToSecureString Method

Grid Solutions Framework StringExtensionsToSecureString Method
Converts the given string into a SecureString.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SecureString ToSecureString(
    this string value
)
<ExtensionAttribute>
Public Shared Function ToSecureString (
    value As String
) As SecureString
static member ToSecureString :
        value : string -> SecureString

GSF.StringExtensions.ToSecureString = function(value);
public:
[ExtensionAttribute]
static SecureString^ ToSecureString(
    String^ value
)

Parameters

value
Type: SystemString
The string to be converted.

Return Value

Type: SecureString
The given string as a SecureString.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ToTitleCase Method

Grid Solutions Framework StringExtensionsToTitleCase Method
Converts the provided string into title case (upper case first letter of each word).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToTitleCase(
    this string value
)
<ExtensionAttribute>
Public Shared Function ToTitleCase (
    value As String
) As String
static member ToTitleCase :
        value : string -> string

GSF.StringExtensions.ToTitleCase = function(value);
public:
[ExtensionAttribute]
static String^ ToTitleCase(
    String^ value
)

Parameters

value
Type: SystemString
Input string.

Return Value

Type: String
A String that has the first letter of each word capitalized.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Note: This function performs "ToLower" in input string then applies TextInfo.ToTitleCase for CurrentCulture. This way, even strings formatted in all-caps will still be properly formatted.
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.ToUnsecureString Method

Grid Solutions Framework StringExtensionsToUnsecureString Method
Converts the given SecureString into a String.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToUnsecureString(
    this SecureString value
)
<ExtensionAttribute>
Public Shared Function ToUnsecureString (
    value As SecureString
) As String
static member ToUnsecureString :
        value : SecureString -> string

GSF.StringExtensions.ToUnsecureString = function(value);
public:
[ExtensionAttribute]
static String^ ToUnsecureString(
    SecureString^ value
)

Parameters

value
Type: System.SecuritySecureString
The SecureString to be converted.

Return Value

Type: String
The given SecureString as a String.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SecureString. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This method is UNSAFE, as it stores your secure string data in clear text in memory. Since strings are immutable, that memory cannot be cleaned up until all references to the string are removed and the garbage collector deallocates it. Only use this method to interface with APIs that do not support the use of SecureString for sensitive text data.
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.TrimWithEllipsisEnd Method

Grid Solutions Framework StringExtensionsTrimWithEllipsisEnd Method
Places an ellipsis at the end of a string as it is trimmed to length specified.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TrimWithEllipsisEnd(
    this string value,
    int length
)
<ExtensionAttribute>
Public Shared Function TrimWithEllipsisEnd (
    value As String,
    length As Integer
) As String
static member TrimWithEllipsisEnd :
        value : string *
        length : int -> string

GSF.StringExtensions.TrimWithEllipsisEnd = function(value, length);
public:
[ExtensionAttribute]
static String^ TrimWithEllipsisEnd(
    String^ value,
    int length
)

Parameters

value
Type: SystemString
The string to process.
length
Type: SystemInt32
The maximum returned string length; minimum value is 5.

Return Value

Type: String
A trimmed string of the specified length or empty string if value is null or empty.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Returned string is not padded to fill field length if value is shorter than length.
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.TrimWithEllipsisMiddle Method

Grid Solutions Framework StringExtensionsTrimWithEllipsisMiddle Method
Places an ellipsis in the middle of a string as it is trimmed to length specified.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TrimWithEllipsisMiddle(
    this string value,
    int length
)
<ExtensionAttribute>
Public Shared Function TrimWithEllipsisMiddle (
    value As String,
    length As Integer
) As String
static member TrimWithEllipsisMiddle :
        value : string *
        length : int -> string

GSF.StringExtensions.TrimWithEllipsisMiddle = function(value, length);
public:
[ExtensionAttribute]
static String^ TrimWithEllipsisMiddle(
    String^ value,
    int length
)

Parameters

value
Type: SystemString
The string to process.
length
Type: SystemInt32
The maximum returned string length; minimum value is 5.

Return Value

Type: String
A trimmed string of the specified length or empty string if value is null or empty.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Returned string is not padded to fill field length if value is shorter than length.
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.TruncateLeft Method

Grid Solutions Framework StringExtensionsTruncateLeft Method
Truncates the provided string from the left if it is longer that specified length.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TruncateLeft(
    this string value,
    int maxLength
)
<ExtensionAttribute>
Public Shared Function TruncateLeft (
    value As String,
    maxLength As Integer
) As String
static member TruncateLeft :
        value : string *
        maxLength : int -> string

GSF.StringExtensions.TruncateLeft = function(value, maxLength);
public:
[ExtensionAttribute]
static String^ TruncateLeft(
    String^ value,
    int maxLength
)

Parameters

value
Type: SystemString
A String value that is to be truncated.
maxLength
Type: SystemInt32
The maximum number of characters that value can be.

Return Value

Type: String
A String that is the truncated version of the value string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.TruncateRight Method

Grid Solutions Framework StringExtensionsTruncateRight Method
Truncates the provided string from the right if it is longer that specified length.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TruncateRight(
    this string value,
    int maxLength
)
<ExtensionAttribute>
Public Shared Function TruncateRight (
    value As String,
    maxLength As Integer
) As String
static member TruncateRight :
        value : string *
        maxLength : int -> string

GSF.StringExtensions.TruncateRight = function(value, maxLength);
public:
[ExtensionAttribute]
static String^ TruncateRight(
    String^ value,
    int maxLength
)

Parameters

value
Type: SystemString
A String value that is to be truncated.
maxLength
Type: SystemInt32
The maximum number of characters that value can be.

Return Value

Type: String
A String that is the truncated version of the value string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


StringExtensions.UriEncode Method

Grid Solutions Framework StringExtensionsUriEncode Method
Escapes string using URL encoding.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string UriEncode(
    this string value
)
<ExtensionAttribute>
Public Shared Function UriEncode (
    value As String
) As String
static member UriEncode :
        value : string -> string

GSF.StringExtensions.UriEncode = function(value);
public:
[ExtensionAttribute]
static String^ UriEncode(
    String^ value
)

Parameters

value
Type: SystemString
The string to escape.

Return Value

Type: String
URL encoded string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StringExtensions Class
GSF Namespace


Ticks Structure

Grid Solutions Framework Ticks Structure
Represents an instant in time, or time period, as a 64-bit signed integer with a value that is expressed as the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Ticks : IComparable, IFormattable,
    IConvertible, IComparable<Ticks>, IComparable<long>, IComparable<DateTime>,
    IComparable<TimeSpan>, IEquatable<Ticks>, IEquatable<long>,
    IEquatable<DateTime>, IEquatable<TimeSpan>
<SerializableAttribute>
Public Structure Ticks
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Ticks),
    IComparable(Of Long), IComparable(Of DateTime), IComparable(Of TimeSpan),
    IEquatable(Of Ticks), IEquatable(Of Long), IEquatable(Of DateTime),
    IEquatable(Of TimeSpan)
[<SealedAttribute>]
[<SerializableAttribute>]
type Ticks =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Ticks>
        interface IComparable<int64>
        interface IComparable<DateTime>
        interface IComparable<TimeSpan>
        interface IEquatable<Ticks>
        interface IEquatable<int64>
        interface IEquatable<DateTime>
        interface IEquatable<TimeSpan>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Ticks : IComparable,
    IFormattable, IConvertible, IComparable<Ticks>, IComparable<long long>,
    IComparable<DateTime>, IComparable<TimeSpan>, IEquatable<Ticks>,
    IEquatable<long long>, IEquatable<DateTime>, IEquatable<TimeSpan>

The Ticks type exposes the following members.

Constructors
 | Name | Description
Public method | Ticks(DateTime) | Creates a new Ticks.
Public method | Ticks(Int64) | Creates a new Ticks.
Public method | Ticks(TimeSpan) | Creates a new Ticks.
Top
Methods
 | Name | Description
 | AlignToMicrosecondDistribution | Returns a floor-aligned microsecond distribution timestamp for given timestamp.
 | AlignToMillisecondDistribution | Returns a floor-aligned millisecond distribution timestamp for given timestamp.
 | AlignToSubsecondDistribution | Returns a floor-aligned sub-second distribution timestamp for given timestamp.
Public method | BaselinedTimestamp | Creates a new Ticks value that represents a base-lined timestamp, in 100-nanoseconds intervals, that begins at the beginning of the specified time interval.
Public method | CompareTo(DateTime) | Compares this instance to a specified DateTime and returns an indication of their relative values.
Public method | CompareTo(Int64) | Compares this instance to a specified Int64 and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(TimeSpan) | Compares this instance to a specified TimeSpan and returns an indication of their relative values.
Public method | CompareTo(Ticks) | Compares this instance to a specified Ticks and returns an indication of their relative values.
Public method | DistanceBeyondSecond | Gets the distance, in 100-nanoseconds intervals, beyond the top of the second in the timestamp represented by the Ticks.
Public method | Equals(DateTime) | Returns a value indicating whether this instance is equal to a specified DateTime value.
Public method | Equals(Int64) | Returns a value indicating whether this instance is equal to a specified Int64 value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(TimeSpan) | Returns a value indicating whether this instance is equal to a specified TimeSpan value.
Public method | Equals(Ticks) | Returns a value indicating whether this instance is equal to a specified Ticks value.
 | FromMicroseconds | Creates a new Ticks from the specified value in microseconds.
 | FromMilliseconds | Creates a new Ticks from the specified value in milliseconds.
 | FromSeconds | Creates a new Ticks from the specified value in seconds.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Int64.
Public method | LocalTimeIsValid(Double, Double) | Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.
Public method | LocalTimeIsValid(Ticks, Ticks) | Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.
 | MicrosecondDistribution | Gets a sub-second time distribution in microseconds for the specified samplesPerSecond.
 | MillisecondDistribution | Gets a sub-second time distribution in milliseconds for the specified samplesPerSecond.
 | Parse(String) | Converts the string representation of a number to its Ticks equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Ticks equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Ticks equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent.
 | SubsecondDistribution | Gets a sub-second time distribution in Ticks for the specified samplesPerSecond.
Public method | TimeIsValid(Ticks, Ticks, Ticks) | Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.
Public method | TimeIsValid(Ticks, Double, Double) | Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.
Public method | ToElapsedTimeString | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds.
Public method | ToElapsedTimeString(Int32, Double) | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Public method | ToElapsedTimeString(Int32, String, Double) | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Public method | ToMicroseconds | Gets the Ticks value in equivalent number of microseconds.
 | ToMicroseconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to microseconds.
Public method | ToMilliseconds | Gets the Ticks value in equivalent number of milliseconds.
 | ToMilliseconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to milliseconds.
Public method | ToSeconds | Gets the Ticks value in equivalent number of seconds.
 | ToSeconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to seconds.
Public method | ToString | Converts the value of the Ticks value to its equivalent DateTime string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the Ticks value to its equivalent string representation, using the specified culture-specific DateTime format information.
Public method | ToString(String) | Converts the Ticks value to its equivalent string representation, using the specified DateTime format.
Public method | ToString(String, IFormatProvider) | Converts the Ticks value to its equivalent string representation, using specified format and culture-specific DateTime format information.
 | TryParse(String, Ticks) | Converts the string representation of a number to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Ticks) | Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.
Public method | UtcTimeIsValid(Double, Double) | Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.
Public method | UtcTimeIsValid(Ticks, Ticks) | Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
BitwiseAnd | Returns logical bitwise AND of values.
BitwiseOr | Returns logical bitwise OR of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
ExclusiveOr | Returns logical bitwise exclusive-OR of values.
Exponent | Returns result of first value raised to power of second value.
False | Returns true if value is equal to zero.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(DateTime to Ticks) | Implicitly converts value, represented as a DateTime, to a Ticks.
(Int64 to Ticks) | Implicitly converts value, represented in ticks, to a Ticks.
(TimeSpan to Ticks) | Implicitly converts value, represented as a TimeSpan, to a Ticks.
(Ticks to Int64) | Implicitly converts Ticks, represented in ticks, to an Int64.
(Ticks to DateTime) | Implicitly converts Ticks, represented in ticks, to a DateTime.
(Ticks to TimeSpan) | Implicitly converts Ticks, represented in ticks, to a TimeSpan.
(Ticks to NtpTimeTag) | Implicitly converts Ticks, represented in ticks, to an NtpTimeTag.
(Ticks to UnixTimeTag) | Implicitly converts Ticks, represented in ticks, to a UnixTimeTag.
(TimeTagBase to Ticks) | Implicitly converts value, represented as a TimeTagBase, to a Ticks.
Inequality | Compares the two values for inequality.
LeftShift | Returns value after left shifts of first value by the number of bits specified by second value.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
OnesComplement | Returns bitwise complement of value.
RightShift | Returns value after right shifts of first value by the number of bits specified by second value.
Subtraction | Returns computed difference of values.
True | Returns true if value is not zero.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
 | MaxValue | Represents the largest possible value of a Ticks. This field is constant.
 | MinValue | Represents the smallest possible value of a Ticks. This field is constant.
 | PerDay | Number of 100-nanosecond ticks in one day.
 | PerHour | Number of 100-nanosecond ticks in one hour.
 | PerMicrosecond | Number of 100-nanosecond ticks in one microsecond.
 | PerMillisecond | Number of 100-nanosecond ticks in one millisecond.
 | PerMinute | Number of 100-nanosecond ticks in one minute.
 | PerSecond | Number of 100-nanosecond ticks in one second.
Public field | Value | Time value stored in ticks.
Top
Remarks

Ticks can represent an "instant in time" and therefore can be used exactly like a DateTime. The difference between Ticks and DateTime is that Ticks is essentially a long integer (i.e., an Int64) which represents the number of ticks that have elapsed since 12:00:00 midnight, January 1, 0001 with each tick having a resolution of 100-nanoseconds. You would use Ticks in places where you needed to directly represent time in high-resolution, i.e., time with sub-second accuracy, using an object that will act like a long integer but handle time conversions. Ticks can also represent a "time period" (e.g., the number of ticks elapsed since a process started) and thus can also be used like a TimeSpan; when used in this manner the ToElapsedTimeString method can be used to convert the Ticks value into a handy textual representation of elapsed years, days, hours, minutes and seconds or sub-seconds.

This class behaves just like an Int64 representing a time in ticks; it is implicitly castable to and from an Int64 and therefore can be generally used "as" an Int64 directly. It is also implicitly castable to and from a DateTime, a TimeSpan, an NtpTimeTag and a UnixTimeTag.

See Also

Reference

GSF Namespace


Ticks Constructor

Grid Solutions Framework Ticks Constructor
Overload List
 | Name | Description
Public method | Ticks(DateTime) | Creates a new Ticks.
Public method | Ticks(Int64) | Creates a new Ticks.
Public method | Ticks(TimeSpan) | Creates a new Ticks.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks Constructor (DateTime)

Grid Solutions Framework Ticks Constructor (DateTime)
Creates a new Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks(
    DateTime value
)
Public Sub New (
    value As DateTime
)
new :
        value : DateTime -> Ticks
GSF.Ticks = function(value);
public:
Ticks(
    DateTime value
)

Parameters

value
Type: SystemDateTime
New time value as a DateTime.
See Also

Reference

Ticks Structure
Ticks Overload
GSF Namespace


Ticks Constructor (Int64)

Grid Solutions Framework Ticks Constructor (Int64)
Creates a new Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks(
    long value
)
Public Sub New (
    value As Long
)
new :
        value : int64 -> Ticks
GSF.Ticks = function(value);
public:
Ticks(
    long long value
)

Parameters

value
Type: SystemInt64
New time value in ticks.
See Also

Reference

Ticks Structure
Ticks Overload
GSF Namespace


Ticks Constructor (TimeSpan)

Grid Solutions Framework Ticks Constructor (TimeSpan)
Creates a new Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks(
    TimeSpan value
)
Public Sub New (
    value As TimeSpan
)
new :
        value : TimeSpan -> Ticks
GSF.Ticks = function(value);
public:
Ticks(
    TimeSpan value
)

Parameters

value
Type: SystemTimeSpan
New time value as a TimeSpan.
See Also

Reference

Ticks Structure
Ticks Overload
GSF Namespace


Ticks Fields

Grid Solutions Framework Ticks Fields

The Ticks type exposes the following members.

Fields
 | Name | Description
 | MaxValue | Represents the largest possible value of a Ticks. This field is constant.
 | MinValue | Represents the smallest possible value of a Ticks. This field is constant.
 | PerDay | Number of 100-nanosecond ticks in one day.
 | PerHour | Number of 100-nanosecond ticks in one hour.
 | PerMicrosecond | Number of 100-nanosecond ticks in one microsecond.
 | PerMillisecond | Number of 100-nanosecond ticks in one millisecond.
 | PerMinute | Number of 100-nanosecond ticks in one minute.
 | PerSecond | Number of 100-nanosecond ticks in one second.
Public field | Value | Time value stored in ticks.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.MaxValue Field

Grid Solutions Framework TicksMaxValue Field
Represents the largest possible value of a Ticks. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Ticks MaxValue
Public Shared ReadOnly MaxValue As Ticks
static val MaxValue: Ticks
var GSF.Ticks.MaxValue
public:
static initonly Ticks MaxValue

Field Value

Type: Ticks
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.MinValue Field

Grid Solutions Framework TicksMinValue Field
Represents the smallest possible value of a Ticks. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Ticks MinValue
Public Shared ReadOnly MinValue As Ticks
static val MinValue: Ticks
var GSF.Ticks.MinValue
public:
static initonly Ticks MinValue

Field Value

Type: Ticks
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.PerDay Field

Grid Solutions Framework TicksPerDay Field
Number of 100-nanosecond ticks in one day.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long PerDay
Public Const PerDay As Long
static val mutable PerDay: int64
var GSF.Ticks.PerDay
public:
literal long long PerDay

Field Value

Type: Int64
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.PerHour Field

Grid Solutions Framework TicksPerHour Field
Number of 100-nanosecond ticks in one hour.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long PerHour
Public Const PerHour As Long
static val mutable PerHour: int64
var GSF.Ticks.PerHour
public:
literal long long PerHour

Field Value

Type: Int64
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.PerMicrosecond Field

Grid Solutions Framework TicksPerMicrosecond Field
Number of 100-nanosecond ticks in one microsecond.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long PerMicrosecond
Public Const PerMicrosecond As Long
static val mutable PerMicrosecond: int64
var GSF.Ticks.PerMicrosecond
public:
literal long long PerMicrosecond

Field Value

Type: Int64
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.PerMillisecond Field

Grid Solutions Framework TicksPerMillisecond Field
Number of 100-nanosecond ticks in one millisecond.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long PerMillisecond
Public Const PerMillisecond As Long
static val mutable PerMillisecond: int64
var GSF.Ticks.PerMillisecond
public:
literal long long PerMillisecond

Field Value

Type: Int64
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.PerMinute Field

Grid Solutions Framework TicksPerMinute Field
Number of 100-nanosecond ticks in one minute.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long PerMinute
Public Const PerMinute As Long
static val mutable PerMinute: int64
var GSF.Ticks.PerMinute
public:
literal long long PerMinute

Field Value

Type: Int64
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.PerSecond Field

Grid Solutions Framework TicksPerSecond Field
Number of 100-nanosecond ticks in one second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long PerSecond
Public Const PerSecond As Long
static val mutable PerSecond: int64
var GSF.Ticks.PerSecond
public:
literal long long PerSecond

Field Value

Type: Int64
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Value Field

Grid Solutions Framework TicksValue Field
Time value stored in ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public readonly long Value
Public ReadOnly Value As Long
val Value: int64
var Value
public:
initonly long long Value

Field Value

Type: Int64
See Also

Reference

Ticks Structure
GSF Namespace


Ticks Methods

Grid Solutions Framework Ticks Methods

The Ticks type exposes the following members.

Methods
 | Name | Description
 | AlignToMicrosecondDistribution | Returns a floor-aligned microsecond distribution timestamp for given timestamp.
 | AlignToMillisecondDistribution | Returns a floor-aligned millisecond distribution timestamp for given timestamp.
 | AlignToSubsecondDistribution | Returns a floor-aligned sub-second distribution timestamp for given timestamp.
Public method | BaselinedTimestamp | Creates a new Ticks value that represents a base-lined timestamp, in 100-nanoseconds intervals, that begins at the beginning of the specified time interval.
Public method | CompareTo(DateTime) | Compares this instance to a specified DateTime and returns an indication of their relative values.
Public method | CompareTo(Int64) | Compares this instance to a specified Int64 and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(TimeSpan) | Compares this instance to a specified TimeSpan and returns an indication of their relative values.
Public method | CompareTo(Ticks) | Compares this instance to a specified Ticks and returns an indication of their relative values.
Public method | DistanceBeyondSecond | Gets the distance, in 100-nanoseconds intervals, beyond the top of the second in the timestamp represented by the Ticks.
Public method | Equals(DateTime) | Returns a value indicating whether this instance is equal to a specified DateTime value.
Public method | Equals(Int64) | Returns a value indicating whether this instance is equal to a specified Int64 value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(TimeSpan) | Returns a value indicating whether this instance is equal to a specified TimeSpan value.
Public method | Equals(Ticks) | Returns a value indicating whether this instance is equal to a specified Ticks value.
 | FromMicroseconds | Creates a new Ticks from the specified value in microseconds.
 | FromMilliseconds | Creates a new Ticks from the specified value in milliseconds.
 | FromSeconds | Creates a new Ticks from the specified value in seconds.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Int64.
Public method | LocalTimeIsValid(Double, Double) | Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.
Public method | LocalTimeIsValid(Ticks, Ticks) | Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.
 | MicrosecondDistribution | Gets a sub-second time distribution in microseconds for the specified samplesPerSecond.
 | MillisecondDistribution | Gets a sub-second time distribution in milliseconds for the specified samplesPerSecond.
 | Parse(String) | Converts the string representation of a number to its Ticks equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Ticks equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Ticks equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent.
 | SubsecondDistribution | Gets a sub-second time distribution in Ticks for the specified samplesPerSecond.
Public method | TimeIsValid(Ticks, Ticks, Ticks) | Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.
Public method | TimeIsValid(Ticks, Double, Double) | Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.
Public method | ToElapsedTimeString | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds.
Public method | ToElapsedTimeString(Int32, Double) | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Public method | ToElapsedTimeString(Int32, String, Double) | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Public method | ToMicroseconds | Gets the Ticks value in equivalent number of microseconds.
 | ToMicroseconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to microseconds.
Public method | ToMilliseconds | Gets the Ticks value in equivalent number of milliseconds.
 | ToMilliseconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to milliseconds.
Public method | ToSeconds | Gets the Ticks value in equivalent number of seconds.
 | ToSeconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to seconds.
Public method | ToString | Converts the value of the Ticks value to its equivalent DateTime string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the Ticks value to its equivalent string representation, using the specified culture-specific DateTime format information.
Public method | ToString(String) | Converts the Ticks value to its equivalent string representation, using the specified DateTime format.
Public method | ToString(String, IFormatProvider) | Converts the Ticks value to its equivalent string representation, using specified format and culture-specific DateTime format information.
 | TryParse(String, Ticks) | Converts the string representation of a number to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Ticks) | Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.
Public method | UtcTimeIsValid(Double, Double) | Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.
Public method | UtcTimeIsValid(Ticks, Ticks) | Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.AlignToMicrosecondDistribution Method

Grid Solutions Framework TicksAlignToMicrosecondDistribution Method
Returns a floor-aligned microsecond distribution timestamp for given timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks AlignToMicrosecondDistribution(
    Ticks timestamp,
    int samplesPerSecond
)
Public Shared Function AlignToMicrosecondDistribution (
    timestamp As Ticks,
    samplesPerSecond As Integer
) As Ticks
static member AlignToMicrosecondDistribution :
        timestamp : Ticks *
        samplesPerSecond : int -> Ticks

GSF.Ticks.AlignToMicrosecondDistribution = function(timestamp, samplesPerSecond);
public:
static Ticks AlignToMicrosecondDistribution(
    Ticks timestamp,
    int samplesPerSecond
)

Parameters

timestamp
Type: GSFTicks
Timestamp to align.
samplesPerSecond
Type: SystemInt32
Samples per second to use for distribution.

Return Value

Type: Ticks
A floor-aligned microsecond distribution timestamp for given timestamp.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.AlignToMillisecondDistribution Method

Grid Solutions Framework TicksAlignToMillisecondDistribution Method
Returns a floor-aligned millisecond distribution timestamp for given timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks AlignToMillisecondDistribution(
    Ticks timestamp,
    int samplesPerSecond
)
Public Shared Function AlignToMillisecondDistribution (
    timestamp As Ticks,
    samplesPerSecond As Integer
) As Ticks
static member AlignToMillisecondDistribution :
        timestamp : Ticks *
        samplesPerSecond : int -> Ticks

GSF.Ticks.AlignToMillisecondDistribution = function(timestamp, samplesPerSecond);
public:
static Ticks AlignToMillisecondDistribution(
    Ticks timestamp,
    int samplesPerSecond
)

Parameters

timestamp
Type: GSFTicks
Timestamp to align.
samplesPerSecond
Type: SystemInt32
Samples per second to use for distribution.

Return Value

Type: Ticks
A floor-aligned millisecond distribution timestamp for given timestamp.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.AlignToSubsecondDistribution Method

Grid Solutions Framework TicksAlignToSubsecondDistribution Method
Returns a floor-aligned sub-second distribution timestamp for given timestamp.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks AlignToSubsecondDistribution(
    Ticks timestamp,
    int samplesPerSecond,
    long timeResolution
)
Public Shared Function AlignToSubsecondDistribution (
    timestamp As Ticks,
    samplesPerSecond As Integer,
    timeResolution As Long
) As Ticks
static member AlignToSubsecondDistribution :
        timestamp : Ticks *
        samplesPerSecond : int *
        timeResolution : int64 -> Ticks

GSF.Ticks.AlignToSubsecondDistribution = function(timestamp, samplesPerSecond, timeResolution);
public:
static Ticks AlignToSubsecondDistribution(
    Ticks timestamp,
    int samplesPerSecond,
    long long timeResolution
)

Parameters

timestamp
Type: GSFTicks
Timestamp to align.
samplesPerSecond
Type: SystemInt32
Samples per second to use for distribution.
timeResolution
Type: SystemInt64
Defines the time resolution to use when aligning timestamp to its proper distribution timestamp.

Return Value

Type: Ticks
A floor-aligned sub-second distribution timestamp for given timestamp.
Remarks
Time resolution value is typically a power of 10 based on the number of ticks per the desired resolution. The following table defines common resolutions and their respective timeResolution values:
Resolution | Time Resolution Value
Seconds | PerSecond
Milliseconds | PerMillisecond
Microseconds | PerMicrosecond
Ticks | 0
If source timestamps have variation, i.e., they are not aligned within common distributions, the timeResolution can be adjusted to include slack to accommodate the variance. When including slack in the time resolution, the value will depend on the samplesPerSecond, for example: you could use 330,000 for 30 samples per second, 160,000 for 60 samples per second, and 80,000 for 120 samples per second. Actual slack value may need to be more or less depending on the size of the source timestamp variation.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.BaselinedTimestamp Method

Grid Solutions Framework TicksBaselinedTimestamp Method
Creates a new Ticks value that represents a base-lined timestamp, in 100-nanoseconds intervals, that begins at the beginning of the specified time interval.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks BaselinedTimestamp(
    BaselineTimeInterval interval
)
Public Function BaselinedTimestamp (
    interval As BaselineTimeInterval
) As Ticks
member BaselinedTimestamp :
        interval : BaselineTimeInterval -> Ticks

function BaselinedTimestamp(interval);
public:
Ticks BaselinedTimestamp(
    BaselineTimeInterval interval
)

Parameters

interval
Type: GSFBaselineTimeInterval
BaselineTimeInterval to which Ticks timestamp should be base-lined.

Return Value

Type: Ticks
A new Ticks value that represents a base-lined timestamp, in 100-nanoseconds intervals, that begins at the specified BaselineTimeInterval.
Remarks
Base-lining to the Second would return the Ticks value starting at zero milliseconds.
Base-lining to the Minute would return the Ticks value starting at zero seconds and milliseconds.
Base-lining to the Hour would return the Ticks value starting at zero minutes, seconds and milliseconds.
Base-lining to the Day would return the Ticks value starting at zero hours, minutes, seconds and milliseconds.
Base-lining to the Month would return the Ticks value starting at day one, zero hours, minutes, seconds and milliseconds.
Base-lining to the Year would return the Ticks value starting at month one, day one, zero hours, minutes, seconds and milliseconds.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.CompareTo Method

Grid Solutions Framework TicksCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(DateTime) | Compares this instance to a specified DateTime and returns an indication of their relative values.
Public method | CompareTo(Int64) | Compares this instance to a specified Int64 and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(TimeSpan) | Compares this instance to a specified TimeSpan and returns an indication of their relative values.
Public method | CompareTo(Ticks) | Compares this instance to a specified Ticks and returns an indication of their relative values.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.CompareTo Method (DateTime)

Grid Solutions Framework TicksCompareTo Method (DateTime)
Compares this instance to a specified DateTime and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    DateTime value
)
Public Function CompareTo (
    value As DateTime
) As Integer
abstract CompareTo :
        value : DateTime -> int
override CompareTo :
        value : DateTime -> int
function CompareTo(value);
public:
virtual int CompareTo(
    DateTime value
) sealed

Parameters

value
Type: SystemDateTime
A DateTime to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Ticks Structure
CompareTo Overload
GSF Namespace


Ticks.CompareTo Method (Int64)

Grid Solutions Framework TicksCompareTo Method (Int64)
Compares this instance to a specified Int64 and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    long value
)
Public Function CompareTo (
    value As Long
) As Integer
abstract CompareTo :
        value : int64 -> int
override CompareTo :
        value : int64 -> int
function CompareTo(value);
public:
virtual int CompareTo(
    long long value
) sealed

Parameters

value
Type: SystemInt64
An Int64 to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Ticks Structure
CompareTo Overload
GSF Namespace


Ticks.CompareTo Method (Object)

Grid Solutions Framework TicksCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not an Int64 or Ticks.
See Also

Reference

Ticks Structure
CompareTo Overload
GSF Namespace


Ticks.CompareTo Method (TimeSpan)

Grid Solutions Framework TicksCompareTo Method (TimeSpan)
Compares this instance to a specified TimeSpan and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    TimeSpan value
)
Public Function CompareTo (
    value As TimeSpan
) As Integer
abstract CompareTo :
        value : TimeSpan -> int
override CompareTo :
        value : TimeSpan -> int
function CompareTo(value);
public:
virtual int CompareTo(
    TimeSpan value
) sealed

Parameters

value
Type: SystemTimeSpan
A TimeSpan to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Ticks Structure
CompareTo Overload
GSF Namespace


Ticks.CompareTo Method (Ticks)

Grid Solutions Framework TicksCompareTo Method (Ticks)
Compares this instance to a specified Ticks and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Ticks value
)
Public Function CompareTo (
    value As Ticks
) As Integer
abstract CompareTo :
        value : Ticks -> int
override CompareTo :
        value : Ticks -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Ticks value
) sealed

Parameters

value
Type: GSFTicks
A Ticks to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Ticks Structure
CompareTo Overload
GSF Namespace


Ticks.DistanceBeyondSecond Method

Grid Solutions Framework TicksDistanceBeyondSecond Method
Gets the distance, in 100-nanoseconds intervals, beyond the top of the second in the timestamp represented by the Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks DistanceBeyondSecond()
Public Function DistanceBeyondSecond As Ticks
member DistanceBeyondSecond : unit -> Ticks

function DistanceBeyondSecond();
public:
Ticks DistanceBeyondSecond()

Return Value

Type: Ticks
Number of 100-nanoseconds intervals Ticks value is from the top of the second.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Equals Method

Grid Solutions Framework TicksEquals Method
Overload List
 | Name | Description
Public method | Equals(DateTime) | Returns a value indicating whether this instance is equal to a specified DateTime value.
Public method | Equals(Int64) | Returns a value indicating whether this instance is equal to a specified Int64 value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(TimeSpan) | Returns a value indicating whether this instance is equal to a specified TimeSpan value.
Public method | Equals(Ticks) | Returns a value indicating whether this instance is equal to a specified Ticks value.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Equals Method (DateTime)

Grid Solutions Framework TicksEquals Method (DateTime)
Returns a value indicating whether this instance is equal to a specified DateTime value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    DateTime obj
)
Public Function Equals (
    obj As DateTime
) As Boolean
abstract Equals :
        obj : DateTime -> bool
override Equals :
        obj : DateTime -> bool
function Equals(obj);
public:
virtual bool Equals(
    DateTime obj
) sealed

Parameters

obj
Type: SystemDateTime
A DateTime value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Ticks Structure
Equals Overload
GSF Namespace


Ticks.Equals Method (Int64)

Grid Solutions Framework TicksEquals Method (Int64)
Returns a value indicating whether this instance is equal to a specified Int64 value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    long obj
)
Public Function Equals (
    obj As Long
) As Boolean
abstract Equals :
        obj : int64 -> bool
override Equals :
        obj : int64 -> bool
function Equals(obj);
public:
virtual bool Equals(
    long long obj
) sealed

Parameters

obj
Type: SystemInt64
An Int64 value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Ticks Structure
Equals Overload
GSF Namespace


Ticks.Equals Method (Object)

Grid Solutions Framework TicksEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Int64 or Ticks and equals the value of this instance; otherwise, False.
See Also

Reference

Ticks Structure
Equals Overload
GSF Namespace


Ticks.Equals Method (TimeSpan)

Grid Solutions Framework TicksEquals Method (TimeSpan)
Returns a value indicating whether this instance is equal to a specified TimeSpan value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    TimeSpan obj
)
Public Function Equals (
    obj As TimeSpan
) As Boolean
abstract Equals :
        obj : TimeSpan -> bool
override Equals :
        obj : TimeSpan -> bool
function Equals(obj);
public:
virtual bool Equals(
    TimeSpan obj
) sealed

Parameters

obj
Type: SystemTimeSpan
A TimeSpan value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Ticks Structure
Equals Overload
GSF Namespace


Ticks.Equals Method (Ticks)

Grid Solutions Framework TicksEquals Method (Ticks)
Returns a value indicating whether this instance is equal to a specified Ticks value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Ticks obj
)
Public Function Equals (
    obj As Ticks
) As Boolean
abstract Equals :
        obj : Ticks -> bool
override Equals :
        obj : Ticks -> bool
function Equals(obj);
public:
virtual bool Equals(
    Ticks obj
) sealed

Parameters

obj
Type: GSFTicks
A Ticks value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Ticks Structure
Equals Overload
GSF Namespace


Ticks.FromMicroseconds Method

Grid Solutions Framework TicksFromMicroseconds Method
Creates a new Ticks from the specified value in microseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks FromMicroseconds(
    double value
)
Public Shared Function FromMicroseconds (
    value As Double
) As Ticks
static member FromMicroseconds :
        value : float -> Ticks

GSF.Ticks.FromMicroseconds = function(value);
public:
static Ticks FromMicroseconds(
    double value
)

Parameters

value
Type: SystemDouble
New Ticks value in microseconds.

Return Value

Type: Ticks
New Ticks object from the specified value in microseconds.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.FromMilliseconds Method

Grid Solutions Framework TicksFromMilliseconds Method
Creates a new Ticks from the specified value in milliseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks FromMilliseconds(
    double value
)
Public Shared Function FromMilliseconds (
    value As Double
) As Ticks
static member FromMilliseconds :
        value : float -> Ticks

GSF.Ticks.FromMilliseconds = function(value);
public:
static Ticks FromMilliseconds(
    double value
)

Parameters

value
Type: SystemDouble
New Ticks value in milliseconds.

Return Value

Type: Ticks
New Ticks object from the specified value in milliseconds.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.FromSeconds Method

Grid Solutions Framework TicksFromSeconds Method
Creates a new Ticks from the specified value in seconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks FromSeconds(
    double value
)
Public Shared Function FromSeconds (
    value As Double
) As Ticks
static member FromSeconds :
        value : float -> Ticks

GSF.Ticks.FromSeconds = function(value);
public:
static Ticks FromSeconds(
    double value
)

Parameters

value
Type: SystemDouble
New Ticks value in seconds.

Return Value

Type: Ticks
New Ticks object from the specified value in seconds.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.GetHashCode Method

Grid Solutions Framework TicksGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.GetTypeCode Method

Grid Solutions Framework TicksGetTypeCode Method
Returns the TypeCode for value type Int64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Int64.

Implements

IConvertibleGetTypeCode
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.LocalTimeIsValid Method

Grid Solutions Framework TicksLocalTimeIsValid Method
Overload List
 | Name | Description
Public method | LocalTimeIsValid(Double, Double) | Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.
Public method | LocalTimeIsValid(Ticks, Ticks) | Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.LocalTimeIsValid Method (Double, Double)

Grid Solutions Framework TicksLocalTimeIsValid Method (Double, Double)
Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool LocalTimeIsValid(
    double lagTime,
    double leadTime
)
Public Function LocalTimeIsValid (
    lagTime As Double,
    leadTime As Double
) As Boolean
member LocalTimeIsValid :
        lagTime : float *
        leadTime : float -> bool

function LocalTimeIsValid(lagTime, leadTime);
public:
bool LocalTimeIsValid(
    double lagTime,
    double leadTime
)

Parameters

lagTime
Type: SystemDouble
The allowed lag time, in seconds, before assuming time is too old to be valid.
leadTime
Type: SystemDouble
The allowed lead time, in seconds, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if local time represented by Ticks value, is within the specified range.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | lagTime and leadTime must be greater than zero, but can be less than one.
Remarks
Time, represented by Ticks value, is considered valid if it exists within the specified lagTime and leadTime range of local system clock time. Note that lagTime and leadTime must be greater than zero, but can be set to sub-second intervals.
See Also

Reference

Ticks Structure
LocalTimeIsValid Overload
GSF Namespace


Ticks.LocalTimeIsValid Method (Ticks, Ticks)

Grid Solutions Framework TicksLocalTimeIsValid Method (Ticks, Ticks)
Determines if time, represented by Ticks value in local time, is valid by comparing it to the system clock.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool LocalTimeIsValid(
    Ticks lagTime,
    Ticks leadTime
)
Public Function LocalTimeIsValid (
    lagTime As Ticks,
    leadTime As Ticks
) As Boolean
member LocalTimeIsValid :
        lagTime : Ticks *
        leadTime : Ticks -> bool

function LocalTimeIsValid(lagTime, leadTime);
public:
bool LocalTimeIsValid(
    Ticks lagTime,
    Ticks leadTime
)

Parameters

lagTime
Type: GSFTicks
The allowed lag time, in ticks, before assuming time is too old to be valid.
leadTime
Type: GSFTicks
The allowed lead time, in ticks, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if local time represented by Ticks value, is within the specified range.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | lagTime and leadTime must be greater than zero.
Remarks
Time, represented by Ticks value, is considered valid if it exists within the specified lagTime and leadTime range of local system clock time. Note that lagTime and leadTime must be greater than zero.
See Also

Reference

Ticks Structure
LocalTimeIsValid Overload
GSF Namespace


Ticks.MicrosecondDistribution Method

Grid Solutions Framework TicksMicrosecondDistribution Method
Gets a sub-second time distribution in microseconds for the specified samplesPerSecond.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int[] MicrosecondDistribution(
    int samplesPerSecond
)
Public Shared Function MicrosecondDistribution (
    samplesPerSecond As Integer
) As Integer()
static member MicrosecondDistribution :
        samplesPerSecond : int -> int[]

GSF.Ticks.MicrosecondDistribution = function(samplesPerSecond);
public:
static array<int>^ MicrosecondDistribution(
    int samplesPerSecond
)

Parameters

samplesPerSecond
Type: SystemInt32
Samples per second.

Return Value

Type: Int32
Array of sub-second time distribution in microseconds.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.MillisecondDistribution Method

Grid Solutions Framework TicksMillisecondDistribution Method
Gets a sub-second time distribution in milliseconds for the specified samplesPerSecond.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int[] MillisecondDistribution(
    int samplesPerSecond
)
Public Shared Function MillisecondDistribution (
    samplesPerSecond As Integer
) As Integer()
static member MillisecondDistribution :
        samplesPerSecond : int -> int[]

GSF.Ticks.MillisecondDistribution = function(samplesPerSecond);
public:
static array<int>^ MillisecondDistribution(
    int samplesPerSecond
)

Parameters

samplesPerSecond
Type: SystemInt32
Samples per second.

Return Value

Type: Int32
Array of sub-second time distribution in milliseconds.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Parse Method

Grid Solutions Framework TicksParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Ticks equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Ticks equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Ticks equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Parse Method (String)

Grid Solutions Framework TicksParse Method (String)
Converts the string representation of a number to its Ticks equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Ticks
static member Parse :
        s : string -> Ticks

GSF.Ticks.Parse = function(s);
public:
static Ticks Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Ticks
A Ticks equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Ticks Structure
Parse Overload
GSF Namespace


Ticks.Parse Method (String, NumberStyles)

Grid Solutions Framework TicksParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Ticks equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Ticks
static member Parse :
        s : string *
        style : NumberStyles -> Ticks

GSF.Ticks.Parse = function(s, style);
public:
static Ticks Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Ticks
A Ticks equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Ticks Structure
Parse Overload
GSF Namespace


Ticks.Parse Method (String, IFormatProvider)

Grid Solutions Framework TicksParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Ticks equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Ticks
static member Parse :
        s : string *
        provider : IFormatProvider -> Ticks

GSF.Ticks.Parse = function(s, provider);
public:
static Ticks Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Ticks
A Ticks equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Ticks Structure
Parse Overload
GSF Namespace


Ticks.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework TicksParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Ticks
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Ticks

GSF.Ticks.Parse = function(s, style, provider);
public:
static Ticks Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Ticks
A Ticks equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Ticks Structure
Parse Overload
GSF Namespace


Ticks.SubsecondDistribution Method

Grid Solutions Framework TicksSubsecondDistribution Method
Gets a sub-second time distribution in Ticks for the specified samplesPerSecond.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks[] SubsecondDistribution(
    int samplesPerSecond
)
Public Shared Function SubsecondDistribution (
    samplesPerSecond As Integer
) As Ticks()
static member SubsecondDistribution :
        samplesPerSecond : int -> Ticks[]

GSF.Ticks.SubsecondDistribution = function(samplesPerSecond);
public:
static array<Ticks>^ SubsecondDistribution(
    int samplesPerSecond
)

Parameters

samplesPerSecond
Type: SystemInt32
Samples per second.

Return Value

Type: Ticks
Array of sub-second time distribution in Ticks.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.TimeIsValid Method

Grid Solutions Framework TicksTimeIsValid Method
Overload List
 | Name | Description
Public method | TimeIsValid(Ticks, Ticks, Ticks) | Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.
Public method | TimeIsValid(Ticks, Double, Double) | Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.TimeIsValid Method (Ticks, Ticks, Ticks)

Grid Solutions Framework TicksTimeIsValid Method (Ticks, Ticks, Ticks)
Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TimeIsValid(
    Ticks currentTime,
    Ticks lagTime,
    Ticks leadTime
)
Public Function TimeIsValid (
    currentTime As Ticks,
    lagTime As Ticks,
    leadTime As Ticks
) As Boolean
member TimeIsValid :
        currentTime : Ticks *
        lagTime : Ticks *
        leadTime : Ticks -> bool

function TimeIsValid(currentTime, lagTime, leadTime);
public:
bool TimeIsValid(
    Ticks currentTime,
    Ticks lagTime,
    Ticks leadTime
)

Parameters

currentTime
Type: GSFTicks
Specified current time (e.g., could be DateTime.Now.Ticks).
lagTime
Type: GSFTicks
The allowed lag time, in ticks, before assuming time is too old to be valid.
leadTime
Type: GSFTicks
The allowed lead time, in ticks, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if time represented by Ticks value, is within the specified range.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | lagTime and leadTime must be greater than zero.
Remarks
Time, represented by Ticks value, is considered valid if it exists within the specified lagTime and leadTime range of currentTime. Note that lagTime and leadTime must be greater than zero.
See Also

Reference

Ticks Structure
TimeIsValid Overload
GSF Namespace


Ticks.TimeIsValid Method (Ticks, Double, Double)

Grid Solutions Framework TicksTimeIsValid Method (Ticks, Double, Double)
Determines if time, represented by Ticks value, is valid by comparing it to the specified current time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TimeIsValid(
    Ticks currentTime,
    double lagTime,
    double leadTime
)
Public Function TimeIsValid (
    currentTime As Ticks,
    lagTime As Double,
    leadTime As Double
) As Boolean
member TimeIsValid :
        currentTime : Ticks *
        lagTime : float *
        leadTime : float -> bool

function TimeIsValid(currentTime, lagTime, leadTime);
public:
bool TimeIsValid(
    Ticks currentTime,
    double lagTime,
    double leadTime
)

Parameters

currentTime
Type: GSFTicks
Specified current time (e.g., could be DateTime.Now.Ticks).
lagTime
Type: SystemDouble
The allowed lag time, in seconds, before assuming time is too old to be valid.
leadTime
Type: SystemDouble
The allowed lead time, in seconds, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if time represented by Ticks value, is within the specified range.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | lagTime and leadTime must be greater than zero, but can be less than one.
Remarks
Time, represented by Ticks value, is considered valid if it exists within the specified lagTime and leadTime range of currentTime. Note that lagTime and leadTime must be greater than zero, but can be set to sub-second intervals.
See Also

Reference

Ticks Structure
TimeIsValid Overload
GSF Namespace


Ticks.ToElapsedTimeString Method

Grid Solutions Framework TicksToElapsedTimeString Method
Overload List
 | Name | Description
Public method | ToElapsedTimeString | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds.
Public method | ToElapsedTimeString(Int32, Double) | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Public method | ToElapsedTimeString(Int32, String, Double) | Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.ToElapsedTimeString Method

Grid Solutions Framework TicksToElapsedTimeString Method
Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToElapsedTimeString()
Public Function ToElapsedTimeString As String
member ToElapsedTimeString : unit -> string

function ToElapsedTimeString();
public:
String^ ToElapsedTimeString()

Return Value

Type: String
The string representation of the value of this instance, consisting of the number of years, days, hours, minutes and seconds represented by this value.
Remarks
Note that this ToElapsedTimeString overload will not display fractional seconds. To allow display of fractional seconds, or completely remove second resolution from the textual representation, use the ToElapsedTimeString(Int32, Double) overload instead.
See Also

Reference

Ticks Structure
ToElapsedTimeString Overload
GSF Namespace


Ticks.ToElapsedTimeString Method (Int32, Double)

Grid Solutions Framework TicksToElapsedTimeString Method (Int32, Double)
Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToElapsedTimeString(
    int secondPrecision,
    double minimumSubSecondResolution = 0.001
)
Public Function ToElapsedTimeString (
    secondPrecision As Integer,
    Optional minimumSubSecondResolution As Double = 0.001
) As String
member ToElapsedTimeString :
        secondPrecision : int *
        ?minimumSubSecondResolution : float
(* Defaults:
        let _minimumSubSecondResolution = defaultArg minimumSubSecondResolution 0.001
*)
-> string

function ToElapsedTimeString(secondPrecision, minimumSubSecondResolution);
public:
String^ ToElapsedTimeString(
    int secondPrecision,
    double minimumSubSecondResolution = 0.001
)

Parameters

secondPrecision
Type: SystemInt32
Number of fractional digits to display for seconds.
minimumSubSecondResolution (Optional)
Type: SystemDouble
Minimum sub-second resolution to display. Defaults to Milli.

Return Value

Type: String
The string representation of the value of this instance, consisting of the number of years, days, hours, minutes and seconds represented by this value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumSubSecondResolution is not less than or equal to Milli or minimumSubSecondResolution is not defined in Factors array.
Remarks
Set secondPrecision to -1 to suppress seconds display, this will force minimum resolution of time display to minutes.
See Also

Reference

Ticks Structure
ToElapsedTimeString Overload
GSF Namespace


Ticks.ToElapsedTimeString Method (Int32, String[], Double)

Grid Solutions Framework TicksToElapsedTimeString Method (Int32, String, Double)
Converts the Ticks value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToElapsedTimeString(
    int secondPrecision,
    string[] timeNames,
    double minimumSubSecondResolution = 0.001
)
Public Function ToElapsedTimeString (
    secondPrecision As Integer,
    timeNames As String(),
    Optional minimumSubSecondResolution As Double = 0.001
) As String
member ToElapsedTimeString :
        secondPrecision : int *
        timeNames : string[] *
        ?minimumSubSecondResolution : float
(* Defaults:
        let _minimumSubSecondResolution = defaultArg minimumSubSecondResolution 0.001
*)
-> string

function ToElapsedTimeString(secondPrecision, timeNames, minimumSubSecondResolution);
public:
String^ ToElapsedTimeString(
    int secondPrecision,
    array<String^>^ timeNames,
    double minimumSubSecondResolution = 0.001
)

Parameters

secondPrecision
Type: SystemInt32
Number of fractional digits to display for seconds.
timeNames
Type: SystemString
Time names array to use during textual conversion.
minimumSubSecondResolution (Optional)
Type: SystemDouble
Minimum sub-second resolution to display. Defaults to Milli.

Return Value

Type: String
The string representation of the value of this instance, consisting of the number of years, days, hours, minutes and seconds represented by this value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumSubSecondResolution is not less than or equal to Milli or minimumSubSecondResolution is not defined in Factors array.
Remarks

Set secondPrecision to -1 to suppress seconds display, this will force minimum resolution of time display to minutes.

timeNames array needs one string entry for each of the following names:
" year", " years", " day", " days", " hour", " hours", " minute", " minutes", " second", " seconds", "less than ".

See Also

Reference

Ticks Structure
ToElapsedTimeString Overload
GSF Namespace


Ticks.ToMicroseconds Method

Grid Solutions Framework TicksToMicroseconds Method
Overload List
 | Name | Description
Public method | ToMicroseconds | Gets the Ticks value in equivalent number of microseconds.
 | ToMicroseconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to microseconds.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.ToMicroseconds Method

Grid Solutions Framework TicksToMicroseconds Method
Gets the Ticks value in equivalent number of microseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMicroseconds()
Public Function ToMicroseconds As Double
member ToMicroseconds : unit -> float

function ToMicroseconds();
public:
double ToMicroseconds()

Return Value

Type: Double
Value of Ticks in microseconds.
Remarks
If Ticks value represents an instant in time, returned value will represent the number of microseconds that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Ticks Structure
ToMicroseconds Overload
GSF Namespace


Ticks.ToMicroseconds Method (Ticks)

Grid Solutions Framework TicksToMicroseconds Method (Ticks)
Converts value, in 100-nanosecond tick intervals, to microseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ToMicroseconds(
    Ticks value
)
Public Shared Function ToMicroseconds (
    value As Ticks
) As Double
static member ToMicroseconds :
        value : Ticks -> float

GSF.Ticks.ToMicroseconds = function(value);
public:
static double ToMicroseconds(
    Ticks value
)

Parameters

value
Type: GSFTicks
Number of ticks to convert to microseconds.

Return Value

Type: Double
Number microseconds represented by specified value in ticks.
Remarks
If value represents an instant in time, returned value will represent the number of microseconds that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Ticks Structure
ToMicroseconds Overload
GSF Namespace


Ticks.ToMilliseconds Method

Grid Solutions Framework TicksToMilliseconds Method
Overload List
 | Name | Description
Public method | ToMilliseconds | Gets the Ticks value in equivalent number of milliseconds.
 | ToMilliseconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to milliseconds.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.ToMilliseconds Method

Grid Solutions Framework TicksToMilliseconds Method
Gets the Ticks value in equivalent number of milliseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMilliseconds()
Public Function ToMilliseconds As Double
member ToMilliseconds : unit -> float

function ToMilliseconds();
public:
double ToMilliseconds()

Return Value

Type: Double
Value of Ticks in milliseconds.
Remarks
If Ticks value represents an instant in time, returned value will represent the number of milliseconds that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Ticks Structure
ToMilliseconds Overload
GSF Namespace


Ticks.ToMilliseconds Method (Ticks)

Grid Solutions Framework TicksToMilliseconds Method (Ticks)
Converts value, in 100-nanosecond tick intervals, to milliseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ToMilliseconds(
    Ticks value
)
Public Shared Function ToMilliseconds (
    value As Ticks
) As Double
static member ToMilliseconds :
        value : Ticks -> float

GSF.Ticks.ToMilliseconds = function(value);
public:
static double ToMilliseconds(
    Ticks value
)

Parameters

value
Type: GSFTicks
Number of ticks to convert to milliseconds.

Return Value

Type: Double
Number milliseconds represented by specified value in ticks.
Remarks
If value represents an instant in time, returned value will represent the number of milliseconds that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Ticks Structure
ToMilliseconds Overload
GSF Namespace


Ticks.ToSeconds Method

Grid Solutions Framework TicksToSeconds Method
Overload List
 | Name | Description
Public method | ToSeconds | Gets the Ticks value in equivalent number of seconds.
 | ToSeconds(Ticks) | Converts value, in 100-nanosecond tick intervals, to seconds.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.ToSeconds Method

Grid Solutions Framework TicksToSeconds Method
Gets the Ticks value in equivalent number of seconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToSeconds()
Public Function ToSeconds As Double
member ToSeconds : unit -> float

function ToSeconds();
public:
double ToSeconds()

Return Value

Type: Double
Value of Ticks in seconds.
Remarks
If Ticks value represents an instant in time, returned value will represent the number of seconds that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Ticks Structure
ToSeconds Overload
GSF Namespace


Ticks.ToSeconds Method (Ticks)

Grid Solutions Framework TicksToSeconds Method (Ticks)
Converts value, in 100-nanosecond tick intervals, to seconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ToSeconds(
    Ticks value
)
Public Shared Function ToSeconds (
    value As Ticks
) As Double
static member ToSeconds :
        value : Ticks -> float

GSF.Ticks.ToSeconds = function(value);
public:
static double ToSeconds(
    Ticks value
)

Parameters

value
Type: GSFTicks
Number of ticks to convert to seconds.

Return Value

Type: Double
Number seconds represented by specified value in ticks.
Remarks
If value represents an instant in time, returned value will represent the number of seconds that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Ticks Structure
ToSeconds Overload
GSF Namespace


Ticks.ToString Method

Grid Solutions Framework TicksToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the value of the Ticks value to its equivalent DateTime string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the Ticks value to its equivalent string representation, using the specified culture-specific DateTime format information.
Public method | ToString(String) | Converts the Ticks value to its equivalent string representation, using the specified DateTime format.
Public method | ToString(String, IFormatProvider) | Converts the Ticks value to its equivalent string representation, using specified format and culture-specific DateTime format information.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.ToString Method

Grid Solutions Framework TicksToString Method
Converts the value of the Ticks value to its equivalent DateTime string representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A DateTime string representation of the Ticks value.
See Also

Reference

Ticks Structure
ToString Overload
GSF Namespace


Ticks.ToString Method (IFormatProvider)

Grid Solutions Framework TicksToString Method (IFormatProvider)
Converts the Ticks value to its equivalent string representation, using the specified culture-specific DateTime format information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Ticks Structure
ToString Overload
GSF Namespace


Ticks.ToString Method (String)

Grid Solutions Framework TicksToString Method (String)
Converts the Ticks value to its equivalent string representation, using the specified DateTime format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Ticks Structure
ToString Overload
GSF Namespace


Ticks.ToString Method (String, IFormatProvider)

Grid Solutions Framework TicksToString Method (String, IFormatProvider)
Converts the Ticks value to its equivalent string representation, using specified format and culture-specific DateTime format information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Ticks Structure
ToString Overload
GSF Namespace


Ticks.TryParse Method

Grid Solutions Framework TicksTryParse Method
Overload List
Name | Description
TryParse(String, Ticks) | Converts the string representation of a number to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Ticks) | Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.TryParse Method (String, Ticks)

Grid Solutions Framework TicksTryParse Method (String, Ticks)
Converts the string representation of a number to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Ticks result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Ticks
) As Boolean
static member TryParse :
        s : string *
        result : Ticks byref -> bool

GSF.Ticks.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Ticks% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSFTicks
When this method returns, contains the Ticks value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Ticks Structure
TryParse Overload
GSF Namespace


Ticks.TryParse Method (String, NumberStyles, IFormatProvider, Ticks)

Grid Solutions Framework TicksTryParse Method (String, NumberStyles, IFormatProvider, Ticks)
Converts the string representation of a number in a specified style and culture-specific format to its Ticks equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Ticks result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Ticks
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Ticks byref -> bool

GSF.Ticks.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Ticks% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSFTicks
When this method returns, contains the Ticks value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Ticks Structure
TryParse Overload
GSF Namespace


Ticks.UtcTimeIsValid Method

Grid Solutions Framework TicksUtcTimeIsValid Method
Overload List
 | Name | Description
Public method | UtcTimeIsValid(Double, Double) | Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.
Public method | UtcTimeIsValid(Ticks, Ticks) | Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.UtcTimeIsValid Method (Double, Double)

Grid Solutions Framework TicksUtcTimeIsValid Method (Double, Double)
Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UtcTimeIsValid(
    double lagTime,
    double leadTime
)
Public Function UtcTimeIsValid (
    lagTime As Double,
    leadTime As Double
) As Boolean
member UtcTimeIsValid :
        lagTime : float *
        leadTime : float -> bool

function UtcTimeIsValid(lagTime, leadTime);
public:
bool UtcTimeIsValid(
    double lagTime,
    double leadTime
)

Parameters

lagTime
Type: SystemDouble
The allowed lag time, in seconds, before assuming time is too old to be valid.
leadTime
Type: SystemDouble
The allowed lead time, in seconds, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if UTC time represented by Ticks value, is within the specified range.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | lagTime and leadTime must be greater than zero, but can be less than one.
Remarks
Time, represented by Ticks value, is considered valid if it exists within the specified lagTime and leadTime range of system clock time in UTC. Note that lagTime and leadTime must be greater than zero, but can be set to sub-second intervals.
See Also

Reference

Ticks Structure
UtcTimeIsValid Overload
GSF Namespace


Ticks.UtcTimeIsValid Method (Ticks, Ticks)

Grid Solutions Framework TicksUtcTimeIsValid Method (Ticks, Ticks)
Determines if time, represented by Ticks value in UTC time, is valid by comparing it to the system clock.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UtcTimeIsValid(
    Ticks lagTime,
    Ticks leadTime
)
Public Function UtcTimeIsValid (
    lagTime As Ticks,
    leadTime As Ticks
) As Boolean
member UtcTimeIsValid :
        lagTime : Ticks *
        leadTime : Ticks -> bool

function UtcTimeIsValid(lagTime, leadTime);
public:
bool UtcTimeIsValid(
    Ticks lagTime,
    Ticks leadTime
)

Parameters

lagTime
Type: GSFTicks
The allowed lag time, in ticks, before assuming time is too old to be valid.
leadTime
Type: GSFTicks
The allowed lead time, in ticks, before assuming time is too advanced to be valid.

Return Value

Type: Boolean
True, if UTC time represented by Ticks value, is within the specified range.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | lagTime and leadTime must be greater than zero.
Remarks
Time, represented by Ticks value, is considered valid if it exists within the specified lagTime and leadTime range of system clock time in UTC. Note that lagTime and leadTime must be greater than zero.
See Also

Reference

Ticks Structure
UtcTimeIsValid Overload
GSF Namespace


Ticks Operators and Type Conversions

Grid Solutions Framework Ticks Operators and Type Conversions

The Ticks type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
BitwiseAnd | Returns logical bitwise AND of values.
BitwiseOr | Returns logical bitwise OR of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
ExclusiveOr | Returns logical bitwise exclusive-OR of values.
Exponent | Returns result of first value raised to power of second value.
False | Returns true if value is equal to zero.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(DateTime to Ticks) | Implicitly converts value, represented as a DateTime, to a Ticks.
(Int64 to Ticks) | Implicitly converts value, represented in ticks, to a Ticks.
(TimeSpan to Ticks) | Implicitly converts value, represented as a TimeSpan, to a Ticks.
(Ticks to Int64) | Implicitly converts Ticks, represented in ticks, to an Int64.
(Ticks to DateTime) | Implicitly converts Ticks, represented in ticks, to a DateTime.
(Ticks to TimeSpan) | Implicitly converts Ticks, represented in ticks, to a TimeSpan.
(Ticks to NtpTimeTag) | Implicitly converts Ticks, represented in ticks, to an NtpTimeTag.
(Ticks to UnixTimeTag) | Implicitly converts Ticks, represented in ticks, to a UnixTimeTag.
(TimeTagBase to Ticks) | Implicitly converts value, represented as a TimeTagBase, to a Ticks.
Inequality | Compares the two values for inequality.
LeftShift | Returns value after left shifts of first value by the number of bits specified by second value.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
OnesComplement | Returns bitwise complement of value.
RightShift | Returns value after right shifts of first value by the number of bits specified by second value.
Subtraction | Returns computed difference of values.
True | Returns true if value is not zero.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Addition Operator

Grid Solutions Framework TicksAddition Operator
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator +(
    Ticks value1,
    Ticks value2
)
Public Shared Operator + (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (+)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator +(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Left hand Ticks operand.
value2
Type: GSFTicks
Right hand Ticks operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.BitwiseAnd Operator

Grid Solutions Framework TicksBitwiseAnd Operator
Returns logical bitwise AND of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator &(
    Ticks value1,
    Ticks value2
)
Public Shared Operator And (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (&&&)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator &(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.BitwiseOr Operator

Grid Solutions Framework TicksBitwiseOr Operator
Returns logical bitwise OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator |(
    Ticks value1,
    Ticks value2
)
Public Shared Operator Or (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (|||)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator |(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Division Operator

Grid Solutions Framework TicksDivision Operator
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator /(
    Ticks value1,
    Ticks value2
)
Public Shared Operator / (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (/)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator /(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Left hand Ticks operand.
value2
Type: GSFTicks
Right hand Ticks operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Equality Operator

Grid Solutions Framework TicksEquality Operator
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Ticks value1,
    Ticks value2
)
Public Shared Operator = (
    value1 As Ticks,
    value2 As Ticks
) As Boolean
static let inline (=)
        value1 : Ticks *
        value2 : Ticks  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.ExclusiveOr Operator

Grid Solutions Framework TicksExclusiveOr Operator
Returns logical bitwise exclusive-OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator ^(
    Ticks value1,
    Ticks value2
)
Public Shared Operator Xor (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (^^^)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator ^(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Exponent Operator

Grid Solutions Framework TicksExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Ticks,
    value2 As Ticks
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSFTicks
Left hand Ticks operand.
value2
Type: GSFTicks
Right hand Ticks operand.

Return Value

Type: Double
Double value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.False Operator

Grid Solutions Framework TicksFalse Operator
Returns true if value is equal to zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator false(
    Ticks value
)
Public Shared Operator IsFalse (
    value As Ticks
) As Boolean
static let inline (false)
        value : Ticks  : bool
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value
Type: GSFTicks
Ticks value to evaluate.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.GreaterThan Operator

Grid Solutions Framework TicksGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Ticks value1,
    Ticks value2
)
Public Shared Operator > (
    value1 As Ticks,
    value2 As Ticks
) As Boolean
static let inline (>)
        value1 : Ticks *
        value2 : Ticks  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.GreaterThanOrEqual Operator

Grid Solutions Framework TicksGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Ticks value1,
    Ticks value2
)
Public Shared Operator >= (
    value1 As Ticks,
    value2 As Ticks
) As Boolean
static let inline (>=)
        value1 : Ticks *
        value2 : Ticks  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks Implicit Conversion Operators

Grid Solutions Framework Ticks Conversion Operators
Overload List
Name | Description
(DateTime to Ticks) | Implicitly converts value, represented as a DateTime, to a Ticks.
(Int64 to Ticks) | Implicitly converts value, represented in ticks, to a Ticks.
(TimeSpan to Ticks) | Implicitly converts value, represented as a TimeSpan, to a Ticks.
(Ticks to Int64) | Implicitly converts Ticks, represented in ticks, to an Int64.
(Ticks to DateTime) | Implicitly converts Ticks, represented in ticks, to a DateTime.
(Ticks to TimeSpan) | Implicitly converts Ticks, represented in ticks, to a TimeSpan.
(Ticks to NtpTimeTag) | Implicitly converts Ticks, represented in ticks, to an NtpTimeTag.
(Ticks to UnixTimeTag) | Implicitly converts Ticks, represented in ticks, to a UnixTimeTag.
(TimeTagBase to Ticks) | Implicitly converts value, represented as a TimeTagBase, to a Ticks.
Top
See Also

Reference

Ticks Structure
GSF Namespace


Ticks Implicit Conversion (DateTime to Ticks)

Grid Solutions Framework Ticks Conversion (DateTime to Ticks)
Implicitly converts value, represented as a DateTime, to a Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Ticks (
    DateTime value
)
Public Shared Widening Operator CType (
    value As DateTime
) As Ticks
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Ticks (
    DateTime value
)

Parameters

value
Type: SystemDateTime
DateTime value to convert.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (Int64 to Ticks)

Grid Solutions Framework Ticks Conversion (Int64 to Ticks)
Implicitly converts value, represented in ticks, to a Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Ticks (
    long value
)
Public Shared Widening Operator CType (
    value As Long
) As Ticks
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Ticks (
    long long value
)

Parameters

value
Type: SystemInt64
Int64 value to convert.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (TimeSpan to Ticks)

Grid Solutions Framework Ticks Conversion (TimeSpan to Ticks)
Implicitly converts value, represented as a TimeSpan, to a Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Ticks (
    TimeSpan value
)
Public Shared Widening Operator CType (
    value As TimeSpan
) As Ticks
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Ticks (
    TimeSpan value
)

Parameters

value
Type: SystemTimeSpan
TimeSpan value to convert.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (Ticks to Int64)

Grid Solutions Framework Ticks Conversion (Ticks to Int64)
Implicitly converts Ticks, represented in ticks, to an Int64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator long (
    Ticks value
)
Public Shared Widening Operator CType (
    value As Ticks
) As Long
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator long long (
    Ticks value
)

Parameters

value
Type: GSFTicks
Ticks value to convert.

Return Value

Type: Int64
Int64 value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (Ticks to DateTime)

Grid Solutions Framework Ticks Conversion (Ticks to DateTime)
Implicitly converts Ticks, represented in ticks, to a DateTime.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator DateTime (
    Ticks value
)
Public Shared Widening Operator CType (
    value As Ticks
) As DateTime
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator DateTime (
    Ticks value
)

Parameters

value
Type: GSFTicks
Ticks value to convert.

Return Value

Type: DateTime
DateTime value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (Ticks to TimeSpan)

Grid Solutions Framework Ticks Conversion (Ticks to TimeSpan)
Implicitly converts Ticks, represented in ticks, to a TimeSpan.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator TimeSpan (
    Ticks value
)
Public Shared Widening Operator CType (
    value As Ticks
) As TimeSpan
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator TimeSpan (
    Ticks value
)

Parameters

value
Type: GSFTicks
Ticks value to convert.

Return Value

Type: TimeSpan
TimeSpan value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (Ticks to NtpTimeTag)

Grid Solutions Framework Ticks Conversion (Ticks to NtpTimeTag)
Implicitly converts Ticks, represented in ticks, to an NtpTimeTag.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator NtpTimeTag (
    Ticks value
)
Public Shared Widening Operator CType (
    value As Ticks
) As NtpTimeTag
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator NtpTimeTag^ (
    Ticks value
)

Parameters

value
Type: GSFTicks
Ticks value to convert.

Return Value

Type: NtpTimeTag
NtpTimeTag value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (Ticks to UnixTimeTag)

Grid Solutions Framework Ticks Conversion (Ticks to UnixTimeTag)
Implicitly converts Ticks, represented in ticks, to a UnixTimeTag.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator UnixTimeTag (
    Ticks value
)
Public Shared Widening Operator CType (
    value As Ticks
) As UnixTimeTag
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator UnixTimeTag^ (
    Ticks value
)

Parameters

value
Type: GSFTicks
Ticks value to convert.

Return Value

Type: UnixTimeTag
UnixTimeTag value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks Implicit Conversion (TimeTagBase to Ticks)

Grid Solutions Framework Ticks Conversion (TimeTagBase to Ticks)
Implicitly converts value, represented as a TimeTagBase, to a Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Ticks (
    TimeTagBase value
)
Public Shared Widening Operator CType (
    value As TimeTagBase
) As Ticks
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Ticks (
    TimeTagBase^ value
)

Parameters

value
Type: GSFTimeTagBase
TimeTagBase value to convert.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
Overload
GSF Namespace


Ticks.Inequality Operator

Grid Solutions Framework TicksInequality Operator
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Ticks value1,
    Ticks value2
)
Public Shared Operator <> (
    value1 As Ticks,
    value2 As Ticks
) As Boolean
static let inline (<>)
        value1 : Ticks *
        value2 : Ticks  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.LeftShift Operator

Grid Solutions Framework TicksLeftShift Operator
Returns value after left shifts of first value by the number of bits specified by second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator <<(
    Ticks value,
    int shifts
)
Public Shared Operator << (
    value As Ticks,
    shifts As Integer
) As Ticks
static let inline (<<<)
        value : Ticks *
        shifts : int  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator <<(
    Ticks value,
    int shifts
)

Parameters

value
Type: GSFTicks
Ticks value to shift.
shifts
Type: SystemInt32
Int32 number of bits to shift.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.LessThan Operator

Grid Solutions Framework TicksLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Ticks value1,
    Ticks value2
)
Public Shared Operator < (
    value1 As Ticks,
    value2 As Ticks
) As Boolean
static let inline (<)
        value1 : Ticks *
        value2 : Ticks  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.LessThanOrEqual Operator

Grid Solutions Framework TicksLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Ticks value1,
    Ticks value2
)
Public Shared Operator <= (
    value1 As Ticks,
    value2 As Ticks
) As Boolean
static let inline (<=)
        value1 : Ticks *
        value2 : Ticks  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Ticks left hand operand.
value2
Type: GSFTicks
Ticks right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Modulus Operator

Grid Solutions Framework TicksModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator %(
    Ticks value1,
    Ticks value2
)
Public Shared Operator Mod (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (%)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator %(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Left hand Ticks operand.
value2
Type: GSFTicks
Right hand Ticks operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Multiply Operator

Grid Solutions Framework TicksMultiply Operator
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator *(
    Ticks value1,
    Ticks value2
)
Public Shared Operator * (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (*)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator *(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Left hand Ticks operand.
value2
Type: GSFTicks
Right hand Ticks operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.OnesComplement Operator

Grid Solutions Framework TicksOnesComplement Operator
Returns bitwise complement of value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator ~(
    Ticks value
)
Public Shared Operator ~ (
    value As Ticks
) As Ticks
F# does not support this operator.
JavaScript does not support overloaded operators.
public:
static Ticks operator ~(
    Ticks value
)

Parameters

value
Type: GSFTicks
Ticks value to evaluate.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.RightShift Operator

Grid Solutions Framework TicksRightShift Operator
Returns value after right shifts of first value by the number of bits specified by second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator >>(
    Ticks value,
    int shifts
)
Public Shared Operator >> (
    value As Ticks,
    shifts As Integer
) As Ticks
static let inline (>>>)
        value : Ticks *
        shifts : int  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator >>(
    Ticks value,
    int shifts
)

Parameters

value
Type: GSFTicks
Ticks value to shift.
shifts
Type: SystemInt32
Int32 number of bits to shift.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.Subtraction Operator

Grid Solutions Framework TicksSubtraction Operator
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Ticks operator -(
    Ticks value1,
    Ticks value2
)
Public Shared Operator - (
    value1 As Ticks,
    value2 As Ticks
) As Ticks
static let inline (-)
        value1 : Ticks *
        value2 : Ticks  : Ticks
JavaScript does not support overloaded operators.
public:
static Ticks operator -(
    Ticks value1,
    Ticks value2
)

Parameters

value1
Type: GSFTicks
Left hand Ticks operand.
value2
Type: GSFTicks
Right hand Ticks operand.

Return Value

Type: Ticks
Ticks value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


Ticks.True Operator

Grid Solutions Framework TicksTrue Operator
Returns true if value is not zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator true(
    Ticks value
)
Public Shared Operator IsTrue (
    value As Ticks
) As Boolean
static let inline (true)
        value : Ticks  : bool
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value
Type: GSFTicks
Ticks value to evaluate.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

Ticks Structure
GSF Namespace


TimerCapabilities Structure

Grid Solutions Framework TimerCapabilities Structure
Represents information about the system's multimedia timer capabilities.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct TimerCapabilities
Public Structure TimerCapabilities
[<SealedAttribute>]
type TimerCapabilities =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class TimerCapabilities

The TimerCapabilities type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | PeriodMaximum | Maximum supported period in milliseconds.
Public field | PeriodMinimum | Minimum supported period in milliseconds.
Top
See Also

Reference

GSF Namespace


TimerCapabilities Fields

Grid Solutions Framework TimerCapabilities Fields

The TimerCapabilities type exposes the following members.

Fields
 | Name | Description
Public field | PeriodMaximum | Maximum supported period in milliseconds.
Public field | PeriodMinimum | Minimum supported period in milliseconds.
Top
See Also

Reference

TimerCapabilities Structure
GSF Namespace


TimerCapabilities.PeriodMaximum Field

Grid Solutions Framework TimerCapabilitiesPeriodMaximum Field
Maximum supported period in milliseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int PeriodMaximum
Public PeriodMaximum As Integer
val mutable PeriodMaximum: int
var PeriodMaximum
public:
int PeriodMaximum

Field Value

Type: Int32
See Also

Reference

TimerCapabilities Structure
GSF Namespace


TimerCapabilities.PeriodMinimum Field

Grid Solutions Framework TimerCapabilitiesPeriodMinimum Field
Minimum supported period in milliseconds.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int PeriodMinimum
Public PeriodMinimum As Integer
val mutable PeriodMinimum: int
var PeriodMinimum
public:
int PeriodMinimum

Field Value

Type: Int32
See Also

Reference

TimerCapabilities Structure
GSF Namespace


TimerCapabilities Methods

Grid Solutions Framework TimerCapabilities Methods

The TimerCapabilities type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TimerCapabilities Structure
GSF Namespace


TimerStartException Class

Grid Solutions Framework TimerStartException Class
Represents an exception that is thrown when a PrecisionTimer fails to start.
Inheritance Hierarchy
SystemObject
SystemException
GSFTimerStartException

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class TimerStartException : Exception
<SerializableAttribute>
Public Class TimerStartException
    Inherits Exception
[<SerializableAttribute>]
type TimerStartException =
    class
        inherit Exception
    end
GSF.TimerStartException = function();

Type.createClass(
    'GSF.TimerStartException',
    Exception);
[SerializableAttribute]
public ref class TimerStartException : public Exception

The TimerStartException type exposes the following members.

Constructors
 | Name | Description
Public method | TimerStartException | Initializes a new instance of the TimerStartException class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF Namespace


TimerStartException Constructor

Grid Solutions Framework TimerStartException Constructor
Initializes a new instance of the TimerStartException class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimerStartException(
    string message
)
Public Sub New (
    message As String
)
new :
        message : string -> TimerStartException
GSF.TimerStartException = function(message);
public:
TimerStartException(
    String^ message
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
See Also

Reference

TimerStartException Class
GSF Namespace


TimerStartException Methods

Grid Solutions Framework TimerStartException Methods

The TimerStartException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TimerStartException Class
GSF Namespace


TimerStartException Properties

Grid Solutions Framework TimerStartException Properties

The TimerStartException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

TimerStartException Class
GSF Namespace


TimerStartException Events

Grid Solutions Framework TimerStartException Events

The TimerStartException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

TimerStartException Class
GSF Namespace


TimeSpanExtensions Class

Grid Solutions Framework TimeSpanExtensions Class
Extends the TimeSpan Class
Inheritance Hierarchy
SystemObject
GSFTimeSpanExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class TimeSpanExtensions
<ExtensionAttribute>
Public NotInheritable Class TimeSpanExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TimeSpanExtensions =  class end
GSF.TimeSpanExtensions = function();

Type.createClass(
    'GSF.TimeSpanExtensions');
[ExtensionAttribute]
public ref class TimeSpanExtensions abstract sealed

The TimeSpanExtensions type exposes the following members.

Methods
Name | Description
ToElapsedTimeString | Converts the TimeSpan value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Top
See Also

Reference

GSF Namespace


TimeSpanExtensions Methods

Grid Solutions Framework TimeSpanExtensions Methods

The TimeSpanExtensions type exposes the following members.

Methods
Name | Description
ToElapsedTimeString | Converts the TimeSpan value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Top
See Also

Reference

TimeSpanExtensions Class
GSF Namespace


TimeSpanExtensions.ToElapsedTimeString Method

Grid Solutions Framework TimeSpanExtensionsToElapsedTimeString Method
Converts the TimeSpan value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToElapsedTimeString(
    this TimeSpan value,
    int secondPrecision = 2,
    double minimumSubSecondResolution = 0.001
)
<ExtensionAttribute>
Public Shared Function ToElapsedTimeString (
    value As TimeSpan,
    Optional secondPrecision As Integer = 2,
    Optional minimumSubSecondResolution As Double = 0.001
) As String
static member ToElapsedTimeString :
        value : TimeSpan *
        ?secondPrecision : int *
        ?minimumSubSecondResolution : float
(* Defaults:
        let _secondPrecision = defaultArg secondPrecision 2
        let _minimumSubSecondResolution = defaultArg minimumSubSecondResolution 0.001
*)
-> string

GSF.TimeSpanExtensions.ToElapsedTimeString = function(value, secondPrecision, minimumSubSecondResolution);
public:
[ExtensionAttribute]
static String^ ToElapsedTimeString(
    TimeSpan value,
    int secondPrecision = 2,
    double minimumSubSecondResolution = 0.001
)

Parameters

value
Type: SystemTimeSpan
The TimeSpan to process.
secondPrecision (Optional)
Type: SystemInt32
Number of fractional digits to display for seconds. Defaults to 2.
minimumSubSecondResolution (Optional)
Type: SystemDouble
Minimum sub-second resolution to display. Defaults to Milli.

Return Value

Type: String
The string representation of the value of this TimeSpan, consisting of the number of years, days, hours, minutes and seconds represented by this value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type TimeSpan. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumSubSecondResolution is not less than or equal to Milli or minimumSubSecondResolution is not defined in Factors array.
Remarks
Set second precision to -1 to suppress seconds display.
Examples
DateTime g_start = DateTime.UtcNow;
DateTime EndTime = DateTime.UtcNow;
TimeSpan duration = EndTime.Subtract(g_start);
Console.WriteLine("Elapsed Time = " + duration.ToElapsedTimeString());
See Also

Reference

TimeSpanExtensions Class
GSF Namespace


TimeTagBase Class

Grid Solutions Framework TimeTagBase Class
Represents the base class for alternate timetag implementations.
Inheritance Hierarchy
SystemObject
GSFTimeTagBase
GSF.HistorianTimeTag
GSFNtpTimeTag
GSFUnixTimeTag

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class TimeTagBase : ISerializable,
    IComparable, IComparable<TimeTagBase>, IComparable<DateTime>,
    IEquatable<TimeTagBase>, IEquatable<DateTime>, IFormattable
<SerializableAttribute>
Public MustInherit Class TimeTagBase
    Implements ISerializable, IComparable, IComparable(Of TimeTagBase),
    IComparable(Of DateTime), IEquatable(Of TimeTagBase), IEquatable(Of DateTime),
    IFormattable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type TimeTagBase =
    class
        interface ISerializable
        interface IComparable
        interface IComparable<TimeTagBase>
        interface IComparable<DateTime>
        interface IEquatable<TimeTagBase>
        interface IEquatable<DateTime>
        interface IFormattable
    end
GSF.TimeTagBase = function();

Type.createClass(
    'GSF.TimeTagBase',
    null,
    ISerializable,
    IComparable,
    IComparable`1,
    IComparable`1,
    IEquatable`1,
    IEquatable`1,
    IFormattable);
[SerializableAttribute]
public ref class TimeTagBase abstract : ISerializable,
    IComparable, IComparable<TimeTagBase^>, IComparable<DateTime>,
    IEquatable<TimeTagBase^>, IEquatable<DateTime>, IFormattable

The TimeTagBase type exposes the following members.

Constructors
 | Name | Description
Protected method | TimeTagBase(Int64, Ticks) | Creates a new TimeTagBase, given standard .NET DateTime.
Protected method | TimeTagBase(Int64, Double) | Creates a new TimeTagBase, given number base time (in ticks) and seconds since base time.
Protected method | TimeTagBase(SerializationInfo, StreamingContext) | Creates a new TimeTagBase from serialization parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime.
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object.
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase.
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Overrides ObjectEquals(Object).)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag.
Public method | ToString | Returns basic textual representation for timetag. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider.
Public method | ToString(String) | Returns textual representation for timetag in the specified format.
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider.
Top
Operators
Name | Description
Equality(DateTime, TimeTagBase) | Returns true if value1 is equal to value2.
Equality(TimeTagBase, TimeTagBase) | Returns true if value1 is equal to value2.
Equality(TimeTagBase, DateTime) | Returns true if value1 is equal to value2.
GreaterThan(DateTime, TimeTagBase) | Returns true if value1 is greater than value2.
GreaterThan(TimeTagBase, TimeTagBase) | Returns true if value1 is greater than value2.
GreaterThan(TimeTagBase, DateTime) | Returns true if value1 is greater than value2.
GreaterThanOrEqual(DateTime, TimeTagBase) | Returns true if value1 is greater than or equal to value2.
GreaterThanOrEqual(TimeTagBase, TimeTagBase) | Returns true if value1 is greater than or equal to value2.
GreaterThanOrEqual(TimeTagBase, DateTime) | Returns true if value1 is greater than or equal to value2.
Inequality(DateTime, TimeTagBase) | Returns true if value1 is not equal to value2.
Inequality(TimeTagBase, TimeTagBase) | Returns true if value1 is not equal to value2.
Inequality(TimeTagBase, DateTime) | Returns true if value1 is not equal to value2.
LessThan(DateTime, TimeTagBase) | Returns true if value1 is less than value2.
LessThan(TimeTagBase, TimeTagBase) | Returns true if value1 is less than value2.
LessThan(TimeTagBase, DateTime) | Returns true if value1 is less than value2.
LessThanOrEqual(DateTime, TimeTagBase) | Returns true if value1 is less than or equal to value2.
LessThanOrEqual(TimeTagBase, TimeTagBase) | Returns true if value1 is less than or equal to value2.
LessThanOrEqual(TimeTagBase, DateTime) | Returns true if value1 is less than or equal to value2.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation.
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time.
Top
See Also

Reference

GSF Namespace


TimeTagBase Constructor

Grid Solutions Framework TimeTagBase Constructor
Overload List
 | Name | Description
Protected method | TimeTagBase(Int64, Ticks) | Creates a new TimeTagBase, given standard .NET DateTime.
Protected method | TimeTagBase(Int64, Double) | Creates a new TimeTagBase, given number base time (in ticks) and seconds since base time.
Protected method | TimeTagBase(SerializationInfo, StreamingContext) | Creates a new TimeTagBase from serialization parameters.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase Constructor (Int64, Ticks)

Grid Solutions Framework TimeTagBase Constructor (Int64, Ticks)
Creates a new TimeTagBase, given standard .NET DateTime.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TimeTagBase(
    long baseDateOffsetTicks,
    Ticks timestamp
)
Protected Sub New (
    baseDateOffsetTicks As Long,
    timestamp As Ticks
)
new :
        baseDateOffsetTicks : int64 *
        timestamp : Ticks -> TimeTagBase
GSF.TimeTagBase = function(baseDateOffsetTicks, timestamp);
protected:
TimeTagBase(
    long long baseDateOffsetTicks,
    Ticks timestamp
)

Parameters

baseDateOffsetTicks
Type: SystemInt64
Ticks of timetag base.
timestamp
Type: GSFTicks
Timestamp in Ticks used to create timetag from.
See Also

Reference

TimeTagBase Class
TimeTagBase Overload
GSF Namespace


TimeTagBase Constructor (Int64, Double)

Grid Solutions Framework TimeTagBase Constructor (Int64, Double)
Creates a new TimeTagBase, given number base time (in ticks) and seconds since base time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TimeTagBase(
    long baseDateOffsetTicks,
    double seconds
)
Protected Sub New (
    baseDateOffsetTicks As Long,
    seconds As Double
)
new :
        baseDateOffsetTicks : int64 *
        seconds : float -> TimeTagBase
GSF.TimeTagBase = function(baseDateOffsetTicks, seconds);
protected:
TimeTagBase(
    long long baseDateOffsetTicks,
    double seconds
)

Parameters

baseDateOffsetTicks
Type: SystemInt64
Ticks of timetag base.
seconds
Type: SystemDouble
Number of seconds since base time.
See Also

Reference

TimeTagBase Class
TimeTagBase Overload
GSF Namespace


TimeTagBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework TimeTagBase Constructor (SerializationInfo, StreamingContext)
Creates a new TimeTagBase from serialization parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TimeTagBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> TimeTagBase
GSF.TimeTagBase = function(info, context);
protected:
TimeTagBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

TimeTagBase Class
TimeTagBase Overload
GSF Namespace


TimeTagBase Methods

Grid Solutions Framework TimeTagBase Methods

The TimeTagBase type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime.
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object.
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase.
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Overrides ObjectEquals(Object).)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag.
Public method | ToString | Returns basic textual representation for timetag. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider.
Public method | ToString(String) | Returns textual representation for timetag in the specified format.
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.CompareTo Method

Grid Solutions Framework TimeTagBaseCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime.
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object.
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.CompareTo Method (DateTime)

Grid Solutions Framework TimeTagBaseCompareTo Method (DateTime)
Compares the TimeTagBase with a DateTime.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    DateTime other
)
Public Function CompareTo (
    other As DateTime
) As Integer
abstract CompareTo :
        other : DateTime -> int
override CompareTo :
        other : DateTime -> int
function CompareTo(other);
public:
virtual int CompareTo(
    DateTime other
) sealed

Parameters

other
Type: SystemDateTime
The DateTime to compare with the current TimeTagBase.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
See Also

Reference

TimeTagBase Class
CompareTo Overload
GSF Namespace


TimeTagBase.CompareTo Method (Object)

Grid Solutions Framework TimeTagBaseCompareTo Method (Object)
Compares the TimeTagBase with the specified Object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
The Object to compare with the current TimeTagBase.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | Object is not an TimeTagBase or a DateTime.
See Also

Reference

TimeTagBase Class
CompareTo Overload
GSF Namespace


TimeTagBase.CompareTo Method (TimeTagBase)

Grid Solutions Framework TimeTagBaseCompareTo Method (TimeTagBase)
Compares the TimeTagBase with another TimeTagBase.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    TimeTagBase other
)
Public Function CompareTo (
    other As TimeTagBase
) As Integer
abstract CompareTo :
        other : TimeTagBase -> int
override CompareTo :
        other : TimeTagBase -> int
function CompareTo(other);
public:
virtual int CompareTo(
    TimeTagBase^ other
) sealed

Parameters

other
Type: GSFTimeTagBase
The TimeTagBase to compare with the current TimeTagBase.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
See Also

Reference

TimeTagBase Class
CompareTo Overload
GSF Namespace


TimeTagBase.Equals Method

Grid Solutions Framework TimeTagBaseEquals Method
Overload List
 | Name | Description
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Overrides ObjectEquals(Object).)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.Equals Method (DateTime)

Grid Solutions Framework TimeTagBaseEquals Method (DateTime)
Determines whether the specified DateTime is equal to the current TimeTagBase.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    DateTime other
)
Public Function Equals (
    other As DateTime
) As Boolean
abstract Equals :
        other : DateTime -> bool
override Equals :
        other : DateTime -> bool
function Equals(other);
public:
virtual bool Equals(
    DateTime other
) sealed

Parameters

other
Type: SystemDateTime
The DateTime to compare with the current TimeTagBase.

Return Value

Type: Boolean
true if the specified DateTime is equal to the current TimeTagBase; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

TimeTagBase Class
Equals Overload
GSF Namespace


TimeTagBase.Equals Method (Object)

Grid Solutions Framework TimeTagBaseEquals Method (Object)
Determines whether the specified Object is equal to the current TimeTagBase.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The Object to compare with the current TimeTagBase.

Return Value

Type: Boolean
true if the specified Object is equal to the current TimeTagBase; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | Object is not an TimeTagBase.
See Also

Reference

TimeTagBase Class
Equals Overload
GSF Namespace


TimeTagBase.Equals Method (TimeTagBase)

Grid Solutions Framework TimeTagBaseEquals Method (TimeTagBase)
Determines whether the specified TimeTagBase is equal to the current TimeTagBase.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    TimeTagBase other
)
Public Function Equals (
    other As TimeTagBase
) As Boolean
abstract Equals :
        other : TimeTagBase -> bool
override Equals :
        other : TimeTagBase -> bool
function Equals(other);
public:
virtual bool Equals(
    TimeTagBase^ other
) sealed

Parameters

other
Type: GSFTimeTagBase
The TimeTagBase to compare with the current TimeTagBase.

Return Value

Type: Boolean
true if the specified TimeTagBase is equal to the current TimeTagBase; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

TimeTagBase Class
Equals Overload
GSF Namespace


TimeTagBase.GetHashCode Method

Grid Solutions Framework TimeTagBaseGetHashCode Method
Serves as a hash function for the current TimeTagBase.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current TimeTagBase.
Remarks
Hash code based on number of seconds timetag represents.
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.GetObjectData Method

Grid Solutions Framework TimeTagBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.ToDateTime Method

Grid Solutions Framework TimeTagBaseToDateTime Method
Returns standard .NET DateTime representation for timetag.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DateTime ToDateTime()
Public Overridable Function ToDateTime As DateTime
abstract ToDateTime : unit -> DateTime
override ToDateTime : unit -> DateTime
function ToDateTime();
public:
virtual DateTime ToDateTime()

Return Value

Type: DateTime
A DateTime.
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.ToString Method

Grid Solutions Framework TimeTagBaseToString Method
Overload List
 | Name | Description
Public method | ToString | Returns basic textual representation for timetag. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider.
Public method | ToString(String) | Returns textual representation for timetag in the specified format.
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.ToString Method

Grid Solutions Framework TimeTagBaseToString Method
Returns basic textual representation for timetag.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String value representing the timetag.
Remarks
Format is "yyyy-MM-dd HH:mm:ss.fff" so that textual representation can be sorted in the correct chronological order.
See Also

Reference

TimeTagBase Class
ToString Overload
GSF Namespace


TimeTagBase.ToString Method (IFormatProvider)

Grid Solutions Framework TimeTagBaseToString Method (IFormatProvider)
Returns textual representation for timetag using the specified provider.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ToString(
    IFormatProvider provider
)
Public Overridable Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
)

Parameters

provider
Type: SystemIFormatProvider
An IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
String of textual representation for timetag.
See Also

Reference

TimeTagBase Class
ToString Overload
GSF Namespace


TimeTagBase.ToString Method (String)

Grid Solutions Framework TimeTagBaseToString Method (String)
Returns textual representation for timetag in the specified format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ToString(
    string format
)
Public Overridable Function ToString (
    format As String
) As String
abstract ToString :
        format : string -> string
override ToString :
        format : string -> string
function ToString(format);
public:
virtual String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
Format of text output.

Return Value

Type: String
String of textual representation for timetag.
See Also

Reference

TimeTagBase Class
ToString Overload
GSF Namespace


TimeTagBase.ToString Method (String, IFormatProvider)

Grid Solutions Framework TimeTagBaseToString Method (String, IFormatProvider)
Returns textual representation for timetag in the specified format using the specified provider.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ToString(
    string format,
    IFormatProvider provider
)
Public Overridable Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
)

Parameters

format
Type: SystemString
Format of text output.
provider
Type: SystemIFormatProvider
An IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
String of textual representation for timetag.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

TimeTagBase Class
ToString Overload
GSF Namespace


TimeTagBase Operators

Grid Solutions Framework TimeTagBase Operators
Operators
Name | Description
Equality(DateTime, TimeTagBase) | Returns true if value1 is equal to value2.
Equality(TimeTagBase, TimeTagBase) | Returns true if value1 is equal to value2.
Equality(TimeTagBase, DateTime) | Returns true if value1 is equal to value2.
GreaterThan(DateTime, TimeTagBase) | Returns true if value1 is greater than value2.
GreaterThan(TimeTagBase, TimeTagBase) | Returns true if value1 is greater than value2.
GreaterThan(TimeTagBase, DateTime) | Returns true if value1 is greater than value2.
GreaterThanOrEqual(DateTime, TimeTagBase) | Returns true if value1 is greater than or equal to value2.
GreaterThanOrEqual(TimeTagBase, TimeTagBase) | Returns true if value1 is greater than or equal to value2.
GreaterThanOrEqual(TimeTagBase, DateTime) | Returns true if value1 is greater than or equal to value2.
Inequality(DateTime, TimeTagBase) | Returns true if value1 is not equal to value2.
Inequality(TimeTagBase, TimeTagBase) | Returns true if value1 is not equal to value2.
Inequality(TimeTagBase, DateTime) | Returns true if value1 is not equal to value2.
LessThan(DateTime, TimeTagBase) | Returns true if value1 is less than value2.
LessThan(TimeTagBase, TimeTagBase) | Returns true if value1 is less than value2.
LessThan(TimeTagBase, DateTime) | Returns true if value1 is less than value2.
LessThanOrEqual(DateTime, TimeTagBase) | Returns true if value1 is less than or equal to value2.
LessThanOrEqual(TimeTagBase, TimeTagBase) | Returns true if value1 is less than or equal to value2.
LessThanOrEqual(TimeTagBase, DateTime) | Returns true if value1 is less than or equal to value2.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.Equality Operator

Grid Solutions Framework TimeTagBaseEquality Operator
Overload List
Name | Description
Equality(DateTime, TimeTagBase) | Returns true if value1 is equal to value2.
Equality(TimeTagBase, TimeTagBase) | Returns true if value1 is equal to value2.
Equality(TimeTagBase, DateTime) | Returns true if value1 is equal to value2.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.Equality Operator (DateTime, TimeTagBase)

Grid Solutions Framework TimeTagBaseEquality Operator (DateTime, TimeTagBase)
Returns true if value1 is equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    DateTime value1,
    TimeTagBase value2
)
Public Shared Operator = (
    value1 As DateTime,
    value2 As TimeTagBase
) As Boolean
static let inline (=)
        value1 : DateTime *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    DateTime value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: SystemDateTime
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
Equality Overload
GSF Namespace


TimeTagBase.Equality Operator (TimeTagBase, TimeTagBase)

Grid Solutions Framework TimeTagBaseEquality Operator (TimeTagBase, TimeTagBase)
Returns true if value1 is equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    TimeTagBase value1,
    TimeTagBase value2
)
Public Shared Operator = (
    value1 As TimeTagBase,
    value2 As TimeTagBase
) As Boolean
static let inline (=)
        value1 : TimeTagBase *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    TimeTagBase^ value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
Equality Overload
GSF Namespace


TimeTagBase.Equality Operator (TimeTagBase, DateTime)

Grid Solutions Framework TimeTagBaseEquality Operator (TimeTagBase, DateTime)
Returns true if value1 is equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    TimeTagBase value1,
    DateTime value2
)
Public Shared Operator = (
    value1 As TimeTagBase,
    value2 As DateTime
) As Boolean
static let inline (=)
        value1 : TimeTagBase *
        value2 : DateTime  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    TimeTagBase^ value1,
    DateTime value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: SystemDateTime
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
Equality Overload
GSF Namespace


TimeTagBase.GreaterThan Operator

Grid Solutions Framework TimeTagBaseGreaterThan Operator
Overload List
Name | Description
GreaterThan(DateTime, TimeTagBase) | Returns true if value1 is greater than value2.
GreaterThan(TimeTagBase, TimeTagBase) | Returns true if value1 is greater than value2.
GreaterThan(TimeTagBase, DateTime) | Returns true if value1 is greater than value2.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.GreaterThan Operator (DateTime, TimeTagBase)

Grid Solutions Framework TimeTagBaseGreaterThan Operator (DateTime, TimeTagBase)
Returns true if value1 is greater than value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    DateTime value1,
    TimeTagBase value2
)
Public Shared Operator > (
    value1 As DateTime,
    value2 As TimeTagBase
) As Boolean
static let inline (>)
        value1 : DateTime *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    DateTime value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: SystemDateTime
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is greater than value2; otherwise false.
See Also

Reference

TimeTagBase Class
GreaterThan Overload
GSF Namespace


TimeTagBase.GreaterThan Operator (TimeTagBase, TimeTagBase)

Grid Solutions Framework TimeTagBaseGreaterThan Operator (TimeTagBase, TimeTagBase)
Returns true if value1 is greater than value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    TimeTagBase value1,
    TimeTagBase value2
)
Public Shared Operator > (
    value1 As TimeTagBase,
    value2 As TimeTagBase
) As Boolean
static let inline (>)
        value1 : TimeTagBase *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    TimeTagBase^ value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is greater than value2; otherwise false.
See Also

Reference

TimeTagBase Class
GreaterThan Overload
GSF Namespace


TimeTagBase.GreaterThan Operator (TimeTagBase, DateTime)

Grid Solutions Framework TimeTagBaseGreaterThan Operator (TimeTagBase, DateTime)
Returns true if value1 is greater than value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    TimeTagBase value1,
    DateTime value2
)
Public Shared Operator > (
    value1 As TimeTagBase,
    value2 As DateTime
) As Boolean
static let inline (>)
        value1 : TimeTagBase *
        value2 : DateTime  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    TimeTagBase^ value1,
    DateTime value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: SystemDateTime
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is greater than value2; otherwise false.
See Also

Reference

TimeTagBase Class
GreaterThan Overload
GSF Namespace


TimeTagBase.GreaterThanOrEqual Operator

Grid Solutions Framework TimeTagBaseGreaterThanOrEqual Operator
Overload List
Name | Description
GreaterThanOrEqual(DateTime, TimeTagBase) | Returns true if value1 is greater than or equal to value2.
GreaterThanOrEqual(TimeTagBase, TimeTagBase) | Returns true if value1 is greater than or equal to value2.
GreaterThanOrEqual(TimeTagBase, DateTime) | Returns true if value1 is greater than or equal to value2.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.GreaterThanOrEqual Operator (DateTime, TimeTagBase)

Grid Solutions Framework TimeTagBaseGreaterThanOrEqual Operator (DateTime, TimeTagBase)
Returns true if value1 is greater than or equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    DateTime value1,
    TimeTagBase value2
)
Public Shared Operator >= (
    value1 As DateTime,
    value2 As TimeTagBase
) As Boolean
static let inline (>=)
        value1 : DateTime *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    DateTime value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: SystemDateTime
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is greater than or equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
GreaterThanOrEqual Overload
GSF Namespace


TimeTagBase.GreaterThanOrEqual Operator (TimeTagBase, TimeTagBase)

Grid Solutions Framework TimeTagBaseGreaterThanOrEqual Operator (TimeTagBase, TimeTagBase)
Returns true if value1 is greater than or equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    TimeTagBase value1,
    TimeTagBase value2
)
Public Shared Operator >= (
    value1 As TimeTagBase,
    value2 As TimeTagBase
) As Boolean
static let inline (>=)
        value1 : TimeTagBase *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    TimeTagBase^ value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is greater than or equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
GreaterThanOrEqual Overload
GSF Namespace


TimeTagBase.GreaterThanOrEqual Operator (TimeTagBase, DateTime)

Grid Solutions Framework TimeTagBaseGreaterThanOrEqual Operator (TimeTagBase, DateTime)
Returns true if value1 is greater than or equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    TimeTagBase value1,
    DateTime value2
)
Public Shared Operator >= (
    value1 As TimeTagBase,
    value2 As DateTime
) As Boolean
static let inline (>=)
        value1 : TimeTagBase *
        value2 : DateTime  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    TimeTagBase^ value1,
    DateTime value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: SystemDateTime
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is greater than or equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
GreaterThanOrEqual Overload
GSF Namespace


TimeTagBase.Inequality Operator

Grid Solutions Framework TimeTagBaseInequality Operator
Overload List
Name | Description
Inequality(DateTime, TimeTagBase) | Returns true if value1 is not equal to value2.
Inequality(TimeTagBase, TimeTagBase) | Returns true if value1 is not equal to value2.
Inequality(TimeTagBase, DateTime) | Returns true if value1 is not equal to value2.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.Inequality Operator (DateTime, TimeTagBase)

Grid Solutions Framework TimeTagBaseInequality Operator (DateTime, TimeTagBase)
Returns true if value1 is not equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    DateTime value1,
    TimeTagBase value2
)
Public Shared Operator <> (
    value1 As DateTime,
    value2 As TimeTagBase
) As Boolean
static let inline (<>)
        value1 : DateTime *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    DateTime value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: SystemDateTime
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is not equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
Inequality Overload
GSF Namespace


TimeTagBase.Inequality Operator (TimeTagBase, TimeTagBase)

Grid Solutions Framework TimeTagBaseInequality Operator (TimeTagBase, TimeTagBase)
Returns true if value1 is not equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    TimeTagBase value1,
    TimeTagBase value2
)
Public Shared Operator <> (
    value1 As TimeTagBase,
    value2 As TimeTagBase
) As Boolean
static let inline (<>)
        value1 : TimeTagBase *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    TimeTagBase^ value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is not equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
Inequality Overload
GSF Namespace


TimeTagBase.Inequality Operator (TimeTagBase, DateTime)

Grid Solutions Framework TimeTagBaseInequality Operator (TimeTagBase, DateTime)
Returns true if value1 is not equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    TimeTagBase value1,
    DateTime value2
)
Public Shared Operator <> (
    value1 As TimeTagBase,
    value2 As DateTime
) As Boolean
static let inline (<>)
        value1 : TimeTagBase *
        value2 : DateTime  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    TimeTagBase^ value1,
    DateTime value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: SystemDateTime
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is not equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
Inequality Overload
GSF Namespace


TimeTagBase.LessThan Operator

Grid Solutions Framework TimeTagBaseLessThan Operator
Overload List
Name | Description
LessThan(DateTime, TimeTagBase) | Returns true if value1 is less than value2.
LessThan(TimeTagBase, TimeTagBase) | Returns true if value1 is less than value2.
LessThan(TimeTagBase, DateTime) | Returns true if value1 is less than value2.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.LessThan Operator (DateTime, TimeTagBase)

Grid Solutions Framework TimeTagBaseLessThan Operator (DateTime, TimeTagBase)
Returns true if value1 is less than value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    DateTime value1,
    TimeTagBase value2
)
Public Shared Operator < (
    value1 As DateTime,
    value2 As TimeTagBase
) As Boolean
static let inline (<)
        value1 : DateTime *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    DateTime value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: SystemDateTime
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is less than value2; otherwise false.
See Also

Reference

TimeTagBase Class
LessThan Overload
GSF Namespace


TimeTagBase.LessThan Operator (TimeTagBase, TimeTagBase)

Grid Solutions Framework TimeTagBaseLessThan Operator (TimeTagBase, TimeTagBase)
Returns true if value1 is less than value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    TimeTagBase value1,
    TimeTagBase value2
)
Public Shared Operator < (
    value1 As TimeTagBase,
    value2 As TimeTagBase
) As Boolean
static let inline (<)
        value1 : TimeTagBase *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    TimeTagBase^ value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is less than value2; otherwise false.
See Also

Reference

TimeTagBase Class
LessThan Overload
GSF Namespace


TimeTagBase.LessThan Operator (TimeTagBase, DateTime)

Grid Solutions Framework TimeTagBaseLessThan Operator (TimeTagBase, DateTime)
Returns true if value1 is less than value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    TimeTagBase value1,
    DateTime value2
)
Public Shared Operator < (
    value1 As TimeTagBase,
    value2 As DateTime
) As Boolean
static let inline (<)
        value1 : TimeTagBase *
        value2 : DateTime  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    TimeTagBase^ value1,
    DateTime value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: SystemDateTime
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is less than value2; otherwise false.
See Also

Reference

TimeTagBase Class
LessThan Overload
GSF Namespace


TimeTagBase.LessThanOrEqual Operator

Grid Solutions Framework TimeTagBaseLessThanOrEqual Operator
Overload List
Name | Description
LessThanOrEqual(DateTime, TimeTagBase) | Returns true if value1 is less than or equal to value2.
LessThanOrEqual(TimeTagBase, TimeTagBase) | Returns true if value1 is less than or equal to value2.
LessThanOrEqual(TimeTagBase, DateTime) | Returns true if value1 is less than or equal to value2.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.LessThanOrEqual Operator (DateTime, TimeTagBase)

Grid Solutions Framework TimeTagBaseLessThanOrEqual Operator (DateTime, TimeTagBase)
Returns true if value1 is less than or equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    DateTime value1,
    TimeTagBase value2
)
Public Shared Operator <= (
    value1 As DateTime,
    value2 As TimeTagBase
) As Boolean
static let inline (<=)
        value1 : DateTime *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    DateTime value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: SystemDateTime
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is less than or equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
LessThanOrEqual Overload
GSF Namespace


TimeTagBase.LessThanOrEqual Operator (TimeTagBase, TimeTagBase)

Grid Solutions Framework TimeTagBaseLessThanOrEqual Operator (TimeTagBase, TimeTagBase)
Returns true if value1 is less than or equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    TimeTagBase value1,
    TimeTagBase value2
)
Public Shared Operator <= (
    value1 As TimeTagBase,
    value2 As TimeTagBase
) As Boolean
static let inline (<=)
        value1 : TimeTagBase *
        value2 : TimeTagBase  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    TimeTagBase^ value1,
    TimeTagBase^ value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: GSFTimeTagBase
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is less than or equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
LessThanOrEqual Overload
GSF Namespace


TimeTagBase.LessThanOrEqual Operator (TimeTagBase, DateTime)

Grid Solutions Framework TimeTagBaseLessThanOrEqual Operator (TimeTagBase, DateTime)
Returns true if value1 is less than or equal to value2.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    TimeTagBase value1,
    DateTime value2
)
Public Shared Operator <= (
    value1 As TimeTagBase,
    value2 As DateTime
) As Boolean
static let inline (<=)
        value1 : TimeTagBase *
        value2 : DateTime  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    TimeTagBase^ value1,
    DateTime value2
)

Parameters

value1
Type: GSFTimeTagBase
Value 1 in the comparision.
value2
Type: SystemDateTime
Value 2 in the comparision.

Return Value

Type: Boolean
true if value1 is less than or equal to value2; otherwise false.
See Also

Reference

TimeTagBase Class
LessThanOrEqual Overload
GSF Namespace


TimeTagBase Properties

Grid Solutions Framework TimeTagBase Properties

The TimeTagBase type exposes the following members.

Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation.
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time.
Top
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.BaseDateOffsetTicks Property

Grid Solutions Framework TimeTagBaseBaseDateOffsetTicks Property
Gets ticks representing the absolute minimum time of this timetag implementation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual long BaseDateOffsetTicks { get; }
Public Overridable ReadOnly Property BaseDateOffsetTicks As Long
    Get
abstract BaseDateOffsetTicks : int64 with get
override BaseDateOffsetTicks : int64 with get
function get_BaseDateOffsetTicks();

public:
virtual property long long BaseDateOffsetTicks {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

TimeTagBase Class
GSF Namespace


TimeTagBase.Value Property

Grid Solutions Framework TimeTagBaseValue Property
Gets or sets number of seconds (including any fractional seconds) since base time.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Value { get; set; }
Public Overridable Property Value As Double
    Get
    Set
abstract Value : float with get, set
override Value : float with get, set
function get_Value();
function set_Value(value);
public:
virtual property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

TimeTagBase Class
GSF Namespace


TransformEqualityComparer(T) Class

Grid Solutions Framework TransformEqualityComparerT Class
Equality comparer that compares objects by the results of a transformation.
Inheritance Hierarchy
SystemObject
GSFTransformEqualityComparerT

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TransformEqualityComparer<T> : IEqualityComparer<T>

Public Class TransformEqualityComparer(Of T)
    Implements IEqualityComparer(Of T)
type TransformEqualityComparer<'T> =
    class
        interface IEqualityComparer<'T>
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class TransformEqualityComparer : IEqualityComparer<T>

Type Parameters

T
The type of the source objects to be compared.

The TransformEqualityComparerT type exposes the following members.

Constructors
 | Name | Description
Public method | TransformEqualityComparerT | Creates a new instance of the TransformEqualityComparerT class.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(T, T) | Determines whether the specified objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(T) | Returns a hash code for the specified object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF Namespace


TransformEqualityComparer(T) Constructor

Grid Solutions Framework TransformEqualityComparerT Constructor
Creates a new instance of the TransformEqualityComparerT class.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TransformEqualityComparer(
    Func<T, Object> transformFunction
)
Public Sub New (
    transformFunction As Func(Of T, Object)
)
new :
        transformFunction : Func<'T, Object> -> TransformEqualityComparer
GSF.TransformEqualityComparer = function(transformFunction);
public:
TransformEqualityComparer(
    Func<T, Object^>^ transformFunction
)

Parameters

transformFunction
Type: SystemFunc T, Object
The function used to transform source objects to the type used for comparison.
See Also

Reference

TransformEqualityComparerT Class
GSF Namespace


TransformEqualityComparer(T) Methods

Grid Solutions Framework TransformEqualityComparerT Methods

The TransformEqualityComparerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(T, T) | Determines whether the specified objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(T) | Returns a hash code for the specified object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TransformEqualityComparerT Class
GSF Namespace


TransformEqualityComparer(T).Equals Method

Grid Solutions Framework TransformEqualityComparerTEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(T, T) | Determines whether the specified objects are equal.
Top
See Also

Reference

TransformEqualityComparerT Class
GSF Namespace


TransformEqualityComparer(T).Equals Method (T, T)

Grid Solutions Framework TransformEqualityComparerTEquals Method (T, T)
Determines whether the specified objects are equal.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    T x,
    T y
)
Public Function Equals (
    x As T,
    y As T
) As Boolean
abstract Equals :
        x : 'T *
        y : 'T -> bool
override Equals :
        x : 'T *
        y : 'T -> bool
function Equals(x, y);
public:
virtual bool Equals(
    T x,
    T y
) sealed

Parameters

x
Type: T
The first object of type T to compare.
y
Type: T
The second object of type T to compare.

Return Value

Type: Boolean
true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

TransformEqualityComparerT Class
Equals Overload
GSF Namespace


TransformEqualityComparer(T).GetHashCode Method

Grid Solutions Framework TransformEqualityComparerTGetHashCode Method
Overload List
 | Name | Description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(T) | Returns a hash code for the specified object.
Top
See Also

Reference

TransformEqualityComparerT Class
GSF Namespace


TransformEqualityComparer(T).GetHashCode Method (T)

Grid Solutions Framework TransformEqualityComparerTGetHashCode Method (T)
Returns a hash code for the specified object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GetHashCode(
    T obj
)
Public Function GetHashCode (
    obj As T
) As Integer
abstract GetHashCode :
        obj : 'T -> int
override GetHashCode :
        obj : 'T -> int
function GetHashCode(obj);
public:
virtual int GetHashCode(
    T obj
) sealed

Parameters

obj
Type: T
The Object for which a hash code is to be returned.

Return Value

Type: Int32
A hash code for the specified object.

Implements

IEqualityComparerTGetHashCode(T)
Exceptions
Exception | Condition
ArgumentNullException | The type of obj is a reference type and obj is null.
See Also

Reference

TransformEqualityComparerT Class
GetHashCode Overload
GSF Namespace


TypeExtensions Class

Grid Solutions Framework TypeExtensions Class
Extensions to all Type objects.
Inheritance Hierarchy
SystemObject
GSFTypeExtensions

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class TypeExtensions
<ExtensionAttribute>
Public NotInheritable Class TypeExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TypeExtensions =  class end
GSF.TypeExtensions = function();

Type.createClass(
    'GSF.TypeExtensions');
[ExtensionAttribute]
public ref class TypeExtensions abstract sealed

The TypeExtensions type exposes the following members.

Methods
Name | Description
GetRootType | Gets the root type in the inheritance hierarchy from which the specified type inherits.
IsNumeric | Determines if the specified type is a native structure that represents a numeric value.
LoadImplementations(Type) | Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, Boolean) | Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, String) | Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, String, Boolean, Boolean) | Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.
Top
See Also

Reference

GSF Namespace


TypeExtensions Methods

Grid Solutions Framework TypeExtensions Methods

The TypeExtensions type exposes the following members.

Methods
Name | Description
GetRootType | Gets the root type in the inheritance hierarchy from which the specified type inherits.
IsNumeric | Determines if the specified type is a native structure that represents a numeric value.
LoadImplementations(Type) | Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, Boolean) | Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, String) | Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, String, Boolean, Boolean) | Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.
Top
See Also

Reference

TypeExtensions Class
GSF Namespace


TypeExtensions.GetRootType Method

Grid Solutions Framework TypeExtensionsGetRootType Method
Gets the root type in the inheritance hierarchy from which the specified type inherits.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Type GetRootType(
    this Type type
)
<ExtensionAttribute>
Public Shared Function GetRootType (
    type As Type
) As Type
static member GetRootType :
        type : Type -> Type

GSF.TypeExtensions.GetRootType = function(type);
public:
[ExtensionAttribute]
static Type^ GetRootType(
    Type^ type
)

Parameters

type
Type: SystemType
The Type whose root type is to be found.

Return Value

Type: Type
The root type in the inheritance hierarchy from which the specified type inherits.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Unless input type is Object or MarshalByRefObject, the returned type will never be Object or MarshalByRefObject, even though all types ultimately inherit from either one of them.
See Also

Reference

TypeExtensions Class
GSF Namespace


TypeExtensions.IsNumeric Method

Grid Solutions Framework TypeExtensionsIsNumeric Method
Determines if the specified type is a native structure that represents a numeric value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsNumeric(
    this Type type
)
<ExtensionAttribute>
Public Shared Function IsNumeric (
    type As Type
) As Boolean
static member IsNumeric :
        type : Type -> bool

GSF.TypeExtensions.IsNumeric = function(type);
public:
[ExtensionAttribute]
static bool IsNumeric(
    Type^ type
)

Parameters

type
Type: SystemType
The Type being tested.

Return Value

Type: Boolean
true if the specified type is a native structure that represents a numeric value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
For this method a boolean value is not considered numeric even though it can be thought of as a bit. This expression returns true if the type is one of the following:

SByte, Byte, Int16, UInt16, Int24, UInt24, Int32, UInt32, Int64, UInt64, Single, Double, Decimal
See Also

Reference

TypeExtensions Class
GSF Namespace


TypeExtensions.LoadImplementations Method

Grid Solutions Framework TypeExtensionsLoadImplementations Method
Overload List
Name | Description
LoadImplementations(Type) | Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, Boolean) | Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, String) | Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.
LoadImplementations(Type, String, Boolean, Boolean) | Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.
Top
See Also

Reference

TypeExtensions Class
GSF Namespace


TypeExtensions.LoadImplementations Method (Type)

Grid Solutions Framework TypeExtensionsLoadImplementations Method (Type)
Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<Type> LoadImplementations(
    this Type type
)
<ExtensionAttribute>
Public Shared Function LoadImplementations (
    type As Type
) As List(Of Type)
static member LoadImplementations :
        type : Type -> List<Type>

GSF.TypeExtensions.LoadImplementations = function(type);
public:
[ExtensionAttribute]
static List<Type^>^ LoadImplementations(
    Type^ type
)

Parameters

type
Type: SystemType
The Type that must be implemented by the public types.

Return Value

Type: List Type
Public types that implement the specified type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TypeExtensions Class
LoadImplementations Overload
GSF Namespace


TypeExtensions.LoadImplementations Method (Type, Boolean)

Grid Solutions Framework TypeExtensionsLoadImplementations Method (Type, Boolean)
Loads public types from assemblies in the application binaries directory that implement the specified type either through class inheritance or interface implementation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<Type> LoadImplementations(
    this Type type,
    bool excludeAbstractTypes
)
<ExtensionAttribute>
Public Shared Function LoadImplementations (
    type As Type,
    excludeAbstractTypes As Boolean
) As List(Of Type)
static member LoadImplementations :
        type : Type *
        excludeAbstractTypes : bool -> List<Type>

GSF.TypeExtensions.LoadImplementations = function(type, excludeAbstractTypes);
public:
[ExtensionAttribute]
static List<Type^>^ LoadImplementations(
    Type^ type,
    bool excludeAbstractTypes
)

Parameters

type
Type: SystemType
The Type that must be implemented by the public types.
excludeAbstractTypes
Type: SystemBoolean
true to exclude public types that are abstract; otherwise false.

Return Value

Type: List Type
Public types that implement the specified type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TypeExtensions Class
LoadImplementations Overload
GSF Namespace


TypeExtensions.LoadImplementations Method (Type, String)

Grid Solutions Framework TypeExtensionsLoadImplementations Method (Type, String)
Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<Type> LoadImplementations(
    this Type type,
    string binariesDirectory
)
<ExtensionAttribute>
Public Shared Function LoadImplementations (
    type As Type,
    binariesDirectory As String
) As List(Of Type)
static member LoadImplementations :
        type : Type *
        binariesDirectory : string -> List<Type>

GSF.TypeExtensions.LoadImplementations = function(type, binariesDirectory);
public:
[ExtensionAttribute]
static List<Type^>^ LoadImplementations(
    Type^ type,
    String^ binariesDirectory
)

Parameters

type
Type: SystemType
The Type that must be implemented by the public types.
binariesDirectory
Type: SystemString
The directory containing the assemblies to be processed.

Return Value

Type: List Type
Public types that implement the specified type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TypeExtensions Class
LoadImplementations Overload
GSF Namespace


TypeExtensions.LoadImplementations Method (Type, String, Boolean, Boolean)

Grid Solutions Framework TypeExtensionsLoadImplementations Method (Type, String, Boolean, Boolean)
Loads public types from assemblies in the specified binariesDirectory that implement the specified type either through class inheritance or interface implementation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<Type> LoadImplementations(
    this Type type,
    string binariesDirectory,
    bool excludeAbstractTypes,
    bool validateReferences = true
)
<ExtensionAttribute>
Public Shared Function LoadImplementations (
    type As Type,
    binariesDirectory As String,
    excludeAbstractTypes As Boolean,
    Optional validateReferences As Boolean = true
) As List(Of Type)
static member LoadImplementations :
        type : Type *
        binariesDirectory : string *
        excludeAbstractTypes : bool *
        ?validateReferences : bool
(* Defaults:
        let _validateReferences = defaultArg validateReferences true
*)
-> List<Type>

GSF.TypeExtensions.LoadImplementations = function(type, binariesDirectory, excludeAbstractTypes, validateReferences);
public:
[ExtensionAttribute]
static List<Type^>^ LoadImplementations(
    Type^ type,
    String^ binariesDirectory,
    bool excludeAbstractTypes,
    bool validateReferences = true
)

Parameters

type
Type: SystemType
The Type that must be implemented by the public types.
binariesDirectory
Type: SystemString
The directory containing the assemblies to be processed.
excludeAbstractTypes
Type: SystemBoolean
true to exclude public types that are abstract; otherwise false.
validateReferences (Optional)
Type: SystemBoolean
True to validate references of loaded assemblies before attempting to instantiate types; false otherwise.

Return Value

Type: List Type
Public types that implement the specified type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

TypeExtensions Class
LoadImplementations Overload
GSF Namespace


UInt24 Structure

Grid Solutions Framework UInt24 Structure
Represents a 3-byte, 24-bit unsigned integer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct UInt24 : IComparable, IFormattable,
    IConvertible, IComparable<UInt24>, IComparable<uint>, IEquatable<UInt24>,
    IEquatable<uint>
<SerializableAttribute>
Public Structure UInt24
    Implements IComparable, IFormattable, IConvertible, IComparable(Of UInt24),
    IComparable(Of UInteger), IEquatable(Of UInt24), IEquatable(Of UInteger)
[<SealedAttribute>]
[<SerializableAttribute>]
type UInt24 =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<UInt24>
        interface IComparable<uint32>
        interface IEquatable<UInt24>
        interface IEquatable<uint32>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class UInt24 : IComparable,
    IFormattable, IConvertible, IComparable<UInt24>, IComparable<unsigned int>,
    IEquatable<UInt24>, IEquatable<unsigned int>

The UInt24 type exposes the following members.

Constructors
 | Name | Description
Public method | UInt24(UInt32) | Creates 24-bit unsigned integer from a 32-bit unsigned integer.
Public method | UInt24(UInt24) | Creates 24-bit unsigned integer from an existing 24-bit unsigned integer.
Public method | UInt24(Byte, Int32) | Creates 24-bit unsigned integer from three bytes at a specified position in a byte array.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(UInt32) | Compares this instance to a specified 32-bit unsigned integer and returns an indication of their relative values.
Public method | CompareTo(UInt24) | Compares this instance to a specified 24-bit unsigned integer and returns an indication of their relative values.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(UInt32) | Returns a value indicating whether this instance is equal to a specified uint value.
Public method | Equals(UInt24) | Returns a value indicating whether this instance is equal to a specified UInt24 value.
Public method | GetBytes | Returns the UInt24 value as an array of three bytes.
 | GetBytes(UInt24) | Returns the specified UInt24 value as an array of three bytes.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the System.TypeCode for value type System.UInt32 (there is no defined type code for an UInt24).
 | GetValue | Returns a 24-bit unsigned integer from three bytes at a specified position in a byte array.
 | Parse(String) | Converts the string representation of a number to its 24-bit unsigned integer equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its 24-bit unsigned integer equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its 24-bit unsigned integer equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, UInt24) | Converts the string representation of a number to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, UInt24) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition(UInt32, UInt24) | Returns computed sum of values.
Addition(UInt24, UInt24) | Returns computed sum of values.
Addition(UInt24, UInt32) | Returns computed sum of values.
BitwiseAnd(UInt32, UInt24) | Returns logical bitwise AND of values.
BitwiseAnd(UInt24, UInt24) | Returns logical bitwise AND of values.
BitwiseAnd(UInt24, UInt32) | Returns logical bitwise AND of values.
BitwiseOr(UInt32, UInt24) | Returns logical bitwise OR of values.
BitwiseOr(UInt24, UInt24) | Returns logical bitwise OR of values.
BitwiseOr(UInt24, UInt32) | Returns logical bitwise OR of values.
Decrement | Returns decremented value.
Division(UInt32, UInt24) | Returns computed division of values.
Division(UInt24, UInt24) | Returns computed division of values.
Division(UInt24, UInt32) | Returns computed division of values.
Equality(UInt32, UInt24) | Compares the two values for equality.
Equality(UInt24, UInt24) | Compares the two values for equality.
Equality(UInt24, UInt32) | Compares the two values for equality.
ExclusiveOr(UInt32, UInt24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(UInt24, UInt24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(UInt24, UInt32) | Returns logical bitwise exclusive-OR of values.
(Decimal to UInt24) | Explicitly converts value to an UInt24.
(Double to UInt24) | Explicitly converts value to an UInt24.
(Enum to UInt24) | Explicitly converts value to an UInt24.
(Single to UInt24) | Explicitly converts value to an UInt24.
(String to UInt24) | Explicitly converts value to an UInt24.
(UInt32 to UInt24) | Explicitly converts value to an UInt24.
(UInt64 to UInt24) | Explicitly converts value to an UInt24.
(Int24 to UInt24) | Explicitly converts value to an UInt24.
(UInt24 to Int24) | Explicitly converts value to an Int24.
(UInt24 to Int16) | Explicitly converts UInt24 to Int16.
(UInt24 to UInt16) | Explicitly converts UInt24 to UInt16.
(UInt24 to Byte) | Explicitly converts UInt24 to Byte.
Exponent(Int32, UInt24) | Returns result of first value raised to power of second value.
Exponent(UInt24, UInt24) | Returns result of first value raised to power of second value.
Exponent(UInt24, Int32) | Returns result of first value raised to power of second value.
False | Returns true if value is equal to zero.
GreaterThan(UInt32, UInt24) | Returns true if left value is greater than right value.
GreaterThan(UInt24, UInt24) | Returns true if left value is greater than right value.
GreaterThan(UInt24, UInt32) | Returns true if left value is greater than right value.
GreaterThanOrEqual(UInt32, UInt24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(UInt24, UInt24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(UInt24, UInt32) | Returns true if left value is greater than or equal to right value.
(Byte to UInt24) | Implicitly converts value to an UInt24.
(Char to UInt24) | Implicitly converts value to an UInt24.
(UInt16 to UInt24) | Implicitly converts value to an UInt24.
(UInt24 to Int32) | Implicitly converts UInt24 to Int32.
(UInt24 to UInt32) | Implicitly converts UInt24 to UInt32.
(UInt24 to Int64) | Implicitly converts UInt24 to Int64.
(UInt24 to UInt64) | Implicitly converts UInt24 to UInt64.
(UInt24 to Double) | Implicitly converts UInt24 to Double.
(UInt24 to Single) | Implicitly converts UInt24 to Single.
(UInt24 to Decimal) | Implicitly converts UInt24 to Decimal.
(UInt24 to String) | Implicitly converts UInt24 to String.
Increment | Returns incremented value.
Inequality(UInt32, UInt24) | Compares the two values for inequality.
Inequality(UInt24, UInt24) | Compares the two values for inequality.
Inequality(UInt24, UInt32) | Compares the two values for inequality.
LeftShift | Returns value after left shifts of first value by the number of bits specified by second value.
LessThan(UInt32, UInt24) | Returns true if left value is less than right value.
LessThan(UInt24, UInt24) | Returns true if left value is less than right value.
LessThan(UInt24, UInt32) | Returns true if left value is less than right value.
LessThanOrEqual(UInt32, UInt24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(UInt24, UInt24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(UInt24, UInt32) | Returns true if left value is less or equal to than right value.
Modulus(UInt32, UInt24) | Returns computed remainder after dividing first value by the second.
Modulus(UInt24, UInt24) | Returns computed remainder after dividing first value by the second.
Modulus(UInt24, UInt32) | Returns computed remainder after dividing first value by the second.
Multiply(UInt32, UInt24) | Returns computed product of values.
Multiply(UInt24, UInt24) | Returns computed product of values.
Multiply(UInt24, UInt32) | Returns computed product of values.
OnesComplement | Returns bitwise complement of value.
RightShift | Returns value after right shifts of first value by the number of bits specified by second value.
Subtraction(UInt32, UInt24) | Returns computed difference of values.
Subtraction(UInt24, UInt24) | Returns computed difference of values.
Subtraction(UInt24, UInt32) | Returns computed difference of values.
True | Returns true if value is greater than zero.
Top
Extension Methods
 | Name | Description
Public Extension Method | BitRotL | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | BitRotR | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(UInt24) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(UInt24, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | ClearBits(Bits) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | ClearBits(UInt24) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetMaskedValue(Bits) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | GetMaskedValue(UInt24) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | SetBits(Bits) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetBits(UInt24) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(Bits, UInt24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(UInt24, UInt24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(Bits) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(UInt24) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Top
Fields
Name | Description
BitMask | High byte bit-mask used when a 24-bit integer is stored within a 32-bit integer. This field is constant.
MaxValue | Represents the largest possible value of an Int24. This field is constant.
MinValue | Represents the smallest possible value of an Int24. This field is constant.
Top
Remarks

This class behaves like most other intrinsic unsigned integers but allows a 3-byte, 24-bit integer implementation that is often found in many digital-signal processing arenas and different kinds of protocol parsing. An unsigned 24-bit integer is typically used to save storage space on disk where its value range of 0 to 16777215 is sufficient, but the unsigned Int16 value range of 0 to 65535 is too small.

This structure uses an UInt32 internally for storage and most other common expected integer functionality, so using a 24-bit integer will not save memory. However, if the 24-bit unsigned integer range (0 to 16777215) suits your data needs you can save disk space by only storing the three bytes that this integer actually consumes. You can do this by calling the UInt24.GetBytes function to return a three byte binary array that can be serialized to the desired destination and then calling the UInt24.GetValue function to restore the UInt24 value from those three bytes.

All the standard operators for the UInt24 have been fully defined for use with both UInt24 and UInt32 unsigned integers; you should find that without the exception UInt24 can be compared and numerically calculated with an UInt24 or UInt32. Necessary casting should be minimal and typical use should be very simple - just as if you are using any other native unsigned integer.

See Also

Reference

GSF Namespace


UInt24 Constructor

Grid Solutions Framework UInt24 Constructor
Overload List
 | Name | Description
Public method | UInt24(UInt32) | Creates 24-bit unsigned integer from a 32-bit unsigned integer.
Public method | UInt24(UInt24) | Creates 24-bit unsigned integer from an existing 24-bit unsigned integer.
Public method | UInt24(Byte, Int32) | Creates 24-bit unsigned integer from three bytes at a specified position in a byte array.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24 Constructor (UInt32)

Grid Solutions Framework UInt24 Constructor (UInt32)
Creates 24-bit unsigned integer from a 32-bit unsigned integer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UInt24(
    uint value
)
Public Sub New (
    value As UInteger
)
new :
        value : uint32 -> UInt24
GSF.UInt24 = function(value);
public:
UInt24(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
32-bit unsigned integer to use as new 24-bit unsigned integer value.
Exceptions
Exception | Condition
OverflowException | Source values over 24-bit max range will cause an overflow exception.
See Also

Reference

UInt24 Structure
UInt24 Overload
GSF Namespace


UInt24 Constructor (UInt24)

Grid Solutions Framework UInt24 Constructor (UInt24)
Creates 24-bit unsigned integer from an existing 24-bit unsigned integer.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UInt24(
    UInt24 value
)
Public Sub New (
    value As UInt24
)
new :
        value : UInt24 -> UInt24
GSF.UInt24 = function(value);
public:
UInt24(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
A UInt24 to create the new value from.
See Also

Reference

UInt24 Structure
UInt24 Overload
GSF Namespace


UInt24 Constructor (Byte[], Int32)

Grid Solutions Framework UInt24 Constructor (Byte, Int32)
Creates 24-bit unsigned integer from three bytes at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UInt24(
    byte[] value,
    int startIndex
)
Public Sub New (
    value As Byte(),
    startIndex As Integer
)
new :
        value : byte[] *
        startIndex : int -> UInt24
GSF.UInt24 = function(value, startIndex);
public:
UInt24(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes.
startIndex
Type: SystemInt32
The starting position within value.
Exceptions
Exception | Condition
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | startIndex is greater than value length.
ArgumentException | value length from startIndex is too small to represent a UInt24.
Remarks

You can use this constructor in-lieu of a System.BitConverter.ToUInt24 function.

Bytes endian order assumed to match that of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

UInt24 Structure
UInt24 Overload
GSF Namespace


UInt24 Fields

Grid Solutions Framework UInt24 Fields

The UInt24 type exposes the following members.

Fields
Name | Description
BitMask | High byte bit-mask used when a 24-bit integer is stored within a 32-bit integer. This field is constant.
MaxValue | Represents the largest possible value of an Int24. This field is constant.
MinValue | Represents the smallest possible value of an Int24. This field is constant.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.BitMask Field

Grid Solutions Framework UInt24BitMask Field
High byte bit-mask used when a 24-bit integer is stored within a 32-bit integer. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint BitMask
Public Const BitMask As UInteger
static val mutable BitMask: uint32
var GSF.UInt24.BitMask
public:
literal unsigned int BitMask

Field Value

Type: UInt32
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.MaxValue Field

Grid Solutions Framework UInt24MaxValue Field
Represents the largest possible value of an Int24. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly UInt24 MaxValue
Public Shared ReadOnly MaxValue As UInt24
static val MaxValue: UInt24
var GSF.UInt24.MaxValue
public:
static initonly UInt24 MaxValue

Field Value

Type: UInt24
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.MinValue Field

Grid Solutions Framework UInt24MinValue Field
Represents the smallest possible value of an Int24. This field is constant.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly UInt24 MinValue
Public Shared ReadOnly MinValue As UInt24
static val MinValue: UInt24
var GSF.UInt24.MinValue
public:
static initonly UInt24 MinValue

Field Value

Type: UInt24
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24 Methods

Grid Solutions Framework UInt24 Methods

The UInt24 type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(UInt32) | Compares this instance to a specified 32-bit unsigned integer and returns an indication of their relative values.
Public method | CompareTo(UInt24) | Compares this instance to a specified 24-bit unsigned integer and returns an indication of their relative values.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(UInt32) | Returns a value indicating whether this instance is equal to a specified uint value.
Public method | Equals(UInt24) | Returns a value indicating whether this instance is equal to a specified UInt24 value.
Public method | GetBytes | Returns the UInt24 value as an array of three bytes.
 | GetBytes(UInt24) | Returns the specified UInt24 value as an array of three bytes.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the System.TypeCode for value type System.UInt32 (there is no defined type code for an UInt24).
 | GetValue | Returns a 24-bit unsigned integer from three bytes at a specified position in a byte array.
 | Parse(String) | Converts the string representation of a number to its 24-bit unsigned integer equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its 24-bit unsigned integer equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its 24-bit unsigned integer equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, UInt24) | Converts the string representation of a number to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, UInt24) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | BitRotL | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | BitRotR | Performs rightwise bit-rotation for the specified number of rotations. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(UInt24) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(Bits, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | CheckBits(UInt24, Boolean) | Overloaded. Determines if specified bits are set. (Defined by BitExtensions.)
Public Extension Method | ClearBits(Bits) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | ClearBits(UInt24) | Overloaded. Returns value with specified bits cleared. (Defined by BitExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetMaskedValue(Bits) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | GetMaskedValue(UInt24) | Overloaded. Returns value stored in the bits represented by the specified bitmask. (Defined by BitExtensions.)
Public Extension Method | SetBits(Bits) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetBits(UInt24) | Overloaded. Returns value with specified bits set. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(Bits, UInt24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | SetMaskedValue(UInt24, UInt24) | Overloaded. Returns value after setting a new value for the bits specified by the bitmask. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(Bits) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Public Extension Method | ToggleBits(UInt24) | Overloaded. Returns value with specified bits toggled. (Defined by BitExtensions.)
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.CompareTo Method

Grid Solutions Framework UInt24CompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(UInt32) | Compares this instance to a specified 32-bit unsigned integer and returns an indication of their relative values.
Public method | CompareTo(UInt24) | Compares this instance to a specified 24-bit unsigned integer and returns an indication of their relative values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.CompareTo Method (Object)

Grid Solutions Framework UInt24CompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not an UInt32 or UInt24.
See Also

Reference

UInt24 Structure
CompareTo Overload
GSF Namespace


UInt24.CompareTo Method (UInt32)

Grid Solutions Framework UInt24CompareTo Method (UInt32)
Compares this instance to a specified 32-bit unsigned integer and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    uint value
)
Public Function CompareTo (
    value As UInteger
) As Integer
abstract CompareTo :
        value : uint32 -> int
override CompareTo :
        value : uint32 -> int
function CompareTo(value);
public:
virtual int CompareTo(
    unsigned int value
) sealed

Parameters

value
Type: SystemUInt32
An integer to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

UInt24 Structure
CompareTo Overload
GSF Namespace


UInt24.CompareTo Method (UInt24)

Grid Solutions Framework UInt24CompareTo Method (UInt24)
Compares this instance to a specified 24-bit unsigned integer and returns an indication of their relative values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    UInt24 value
)
Public Function CompareTo (
    value As UInt24
) As Integer
abstract CompareTo :
        value : UInt24 -> int
override CompareTo :
        value : UInt24 -> int
function CompareTo(value);
public:
virtual int CompareTo(
    UInt24 value
) sealed

Parameters

value
Type: GSFUInt24
An integer to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

UInt24 Structure
CompareTo Overload
GSF Namespace


UInt24.Equals Method

Grid Solutions Framework UInt24Equals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(UInt32) | Returns a value indicating whether this instance is equal to a specified uint value.
Public method | Equals(UInt24) | Returns a value indicating whether this instance is equal to a specified UInt24 value.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Equals Method (Object)

Grid Solutions Framework UInt24Equals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of UInt32 or UInt24 and equals the value of this instance; otherwise, False.
See Also

Reference

UInt24 Structure
Equals Overload
GSF Namespace


UInt24.Equals Method (UInt32)

Grid Solutions Framework UInt24Equals Method (UInt32)
Returns a value indicating whether this instance is equal to a specified uint value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    uint obj
)
Public Function Equals (
    obj As UInteger
) As Boolean
abstract Equals :
        obj : uint32 -> bool
override Equals :
        obj : uint32 -> bool
function Equals(obj);
public:
virtual bool Equals(
    unsigned int obj
) sealed

Parameters

obj
Type: SystemUInt32
An UInt32 value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

UInt24 Structure
Equals Overload
GSF Namespace


UInt24.Equals Method (UInt24)

Grid Solutions Framework UInt24Equals Method (UInt24)
Returns a value indicating whether this instance is equal to a specified UInt24 value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    UInt24 obj
)
Public Function Equals (
    obj As UInt24
) As Boolean
abstract Equals :
        obj : UInt24 -> bool
override Equals :
        obj : UInt24 -> bool
function Equals(obj);
public:
virtual bool Equals(
    UInt24 obj
) sealed

Parameters

obj
Type: GSFUInt24
An UInt24 value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

UInt24 Structure
Equals Overload
GSF Namespace


UInt24.GetBytes Method

Grid Solutions Framework UInt24GetBytes Method
Overload List
 | Name | Description
Public method | GetBytes | Returns the UInt24 value as an array of three bytes.
 | GetBytes(UInt24) | Returns the specified UInt24 value as an array of three bytes.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.GetBytes Method

Grid Solutions Framework UInt24GetBytes Method
Returns the UInt24 value as an array of three bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetBytes()
Public Function GetBytes As Byte()
member GetBytes : unit -> byte[]

function GetBytes();
public:
array<unsigned char>^ GetBytes()

Return Value

Type: Byte
An array of bytes with length 3.
Remarks

You can use this function in-lieu of a System.BitConverter.GetBytes function.

Bytes will be returned in endian order of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

UInt24 Structure
GetBytes Overload
GSF Namespace


UInt24.GetBytes Method (UInt24)

Grid Solutions Framework UInt24GetBytes Method (UInt24)
Returns the specified UInt24 value as an array of three bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] GetBytes(
    UInt24 value
)
Public Shared Function GetBytes (
    value As UInt24
) As Byte()
static member GetBytes :
        value : UInt24 -> byte[]

GSF.UInt24.GetBytes = function(value);
public:
static array<unsigned char>^ GetBytes(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to convert to bytes.

Return Value

Type: Byte
An array of bytes with length 3.
Remarks

You can use this function in-lieu of a System.BitConverter.GetBytes(UInt24) function.

Bytes will be returned in endian order of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

UInt24 Structure
GetBytes Overload
GSF Namespace


UInt24.GetHashCode Method

Grid Solutions Framework UInt24GetHashCode Method
Returns the hash code for this instance.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit unsigned integer hash code.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.GetTypeCode Method

Grid Solutions Framework UInt24GetTypeCode Method
Returns the System.TypeCode for value type System.UInt32 (there is no defined type code for an UInt24).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, System.TypeCode.UInt32.

Implements

IConvertibleGetTypeCode
Remarks
There is no defined UInt24 type code and since an UInt24 will easily fit inside an UInt32, the UInt32 type code is returned.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.GetValue Method

Grid Solutions Framework UInt24GetValue Method
Returns a 24-bit unsigned integer from three bytes at a specified position in a byte array.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 GetValue(
    byte[] value,
    int startIndex
)
Public Shared Function GetValue (
    value As Byte(),
    startIndex As Integer
) As UInt24
static member GetValue :
        value : byte[] *
        startIndex : int -> UInt24

GSF.UInt24.GetValue = function(value, startIndex);
public:
static UInt24 GetValue(
    array<unsigned char>^ value,
    int startIndex
)

Parameters

value
Type: SystemByte
An array of bytes.
startIndex
Type: SystemInt32
The starting position within value.

Return Value

Type: UInt24
A 24-bit unsigned integer formed by three bytes beginning at startIndex.
Exceptions
Exception | Condition
ArgumentNullException | value cannot be null.
ArgumentOutOfRangeException | startIndex is greater than value length.
ArgumentException | value length from startIndex is too small to represent an UInt24.
Remarks

You can use this function in-lieu of a System.BitConverter.ToUInt24 function.

Bytes endian order assumed to match that of currently executing process architecture (little-endian on Intel platforms).

See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Parse Method

Grid Solutions Framework UInt24Parse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its 24-bit unsigned integer equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its 24-bit unsigned integer equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its 24-bit unsigned integer equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Parse Method (String)

Grid Solutions Framework UInt24Parse Method (String)
Converts the string representation of a number to its 24-bit unsigned integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As UInt24
static member Parse :
        s : string -> UInt24

GSF.UInt24.Parse = function(s);
public:
static UInt24 Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: UInt24
A 24-bit unsigned integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than UInt24.MinValue or greater than UInt24.MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

UInt24 Structure
Parse Overload
GSF Namespace


UInt24.Parse Method (String, NumberStyles)

Grid Solutions Framework UInt24Parse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its 24-bit unsigned integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As UInt24
static member Parse :
        s : string *
        style : NumberStyles -> UInt24

GSF.UInt24.Parse = function(s, style);
public:
static UInt24 Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s. A typical value to specify is System.Globalization.NumberStyles.Integer.

Return Value

Type: UInt24
A 24-bit unsigned integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than UInt24.MinValue or greater than UInt24.MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

UInt24 Structure
Parse Overload
GSF Namespace


UInt24.Parse Method (String, IFormatProvider)

Grid Solutions Framework UInt24Parse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its 24-bit unsigned integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As UInt24
static member Parse :
        s : string *
        provider : IFormatProvider -> UInt24

GSF.UInt24.Parse = function(s, provider);
public:
static UInt24 Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: UInt24
A 24-bit unsigned integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than UInt24.MinValue or greater than UInt24.MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

UInt24 Structure
Parse Overload
GSF Namespace


UInt24.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework UInt24Parse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As UInt24
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> UInt24

GSF.UInt24.Parse = function(s, style, provider);
public:
static UInt24 Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s. A typical value to specify is System.Globalization.NumberStyles.Integer.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: UInt24
A 24-bit unsigned integer equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than UInt24.MinValue or greater than UInt24.MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

UInt24 Structure
Parse Overload
GSF Namespace


UInt24.ToString Method

Grid Solutions Framework UInt24ToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.ToString Method

Grid Solutions Framework UInt24ToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

UInt24 Structure
ToString Overload
GSF Namespace


UInt24.ToString Method (IFormatProvider)

Grid Solutions Framework UInt24ToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

UInt24 Structure
ToString Overload
GSF Namespace


UInt24.ToString Method (String)

Grid Solutions Framework UInt24ToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

UInt24 Structure
ToString Overload
GSF Namespace


UInt24.ToString Method (String, IFormatProvider)

Grid Solutions Framework UInt24ToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

UInt24 Structure
ToString Overload
GSF Namespace


UInt24.TryParse Method

Grid Solutions Framework UInt24TryParse Method
Overload List
Name | Description
TryParse(String, UInt24) | Converts the string representation of a number to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, UInt24) | Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.TryParse Method (String, UInt24)

Grid Solutions Framework UInt24TryParse Method (String, UInt24)
Converts the string representation of a number to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out UInt24 result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As UInt24
) As Boolean
static member TryParse :
        s : string *
        result : UInt24 byref -> bool

GSF.UInt24.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] UInt24% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSFUInt24
When this method returns, contains the 24-bit unsigned integer value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not of the correct format, or represents a number less than UInt24.MinValue or greater than UInt24.MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

UInt24 Structure
TryParse Overload
GSF Namespace


UInt24.TryParse Method (String, NumberStyles, IFormatProvider, UInt24)

Grid Solutions Framework UInt24TryParse Method (String, NumberStyles, IFormatProvider, UInt24)
Converts the string representation of a number in a specified style and culture-specific format to its 24-bit unsigned integer equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out UInt24 result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As UInt24
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : UInt24 byref -> bool

GSF.UInt24.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] UInt24% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s. A typical value to specify is System.Globalization.NumberStyles.Integer.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSFUInt24
When this method returns, contains the 24-bit unsigned integer value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not in a format compliant with style, or represents a number less than UInt24.MinValue or greater than UInt24.MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

UInt24 Structure
TryParse Overload
GSF Namespace


UInt24 Operators and Type Conversions

Grid Solutions Framework UInt24 Operators and Type Conversions

The UInt24 type exposes the following members.

Operators
Name | Description
Addition(UInt32, UInt24) | Returns computed sum of values.
Addition(UInt24, UInt24) | Returns computed sum of values.
Addition(UInt24, UInt32) | Returns computed sum of values.
BitwiseAnd(UInt32, UInt24) | Returns logical bitwise AND of values.
BitwiseAnd(UInt24, UInt24) | Returns logical bitwise AND of values.
BitwiseAnd(UInt24, UInt32) | Returns logical bitwise AND of values.
BitwiseOr(UInt32, UInt24) | Returns logical bitwise OR of values.
BitwiseOr(UInt24, UInt24) | Returns logical bitwise OR of values.
BitwiseOr(UInt24, UInt32) | Returns logical bitwise OR of values.
Decrement | Returns decremented value.
Division(UInt32, UInt24) | Returns computed division of values.
Division(UInt24, UInt24) | Returns computed division of values.
Division(UInt24, UInt32) | Returns computed division of values.
Equality(UInt32, UInt24) | Compares the two values for equality.
Equality(UInt24, UInt24) | Compares the two values for equality.
Equality(UInt24, UInt32) | Compares the two values for equality.
ExclusiveOr(UInt32, UInt24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(UInt24, UInt24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(UInt24, UInt32) | Returns logical bitwise exclusive-OR of values.
(Decimal to UInt24) | Explicitly converts value to an UInt24.
(Double to UInt24) | Explicitly converts value to an UInt24.
(Enum to UInt24) | Explicitly converts value to an UInt24.
(Single to UInt24) | Explicitly converts value to an UInt24.
(String to UInt24) | Explicitly converts value to an UInt24.
(UInt32 to UInt24) | Explicitly converts value to an UInt24.
(UInt64 to UInt24) | Explicitly converts value to an UInt24.
(Int24 to UInt24) | Explicitly converts value to an UInt24.
(UInt24 to Int24) | Explicitly converts value to an Int24.
(UInt24 to Int16) | Explicitly converts UInt24 to Int16.
(UInt24 to UInt16) | Explicitly converts UInt24 to UInt16.
(UInt24 to Byte) | Explicitly converts UInt24 to Byte.
Exponent(Int32, UInt24) | Returns result of first value raised to power of second value.
Exponent(UInt24, UInt24) | Returns result of first value raised to power of second value.
Exponent(UInt24, Int32) | Returns result of first value raised to power of second value.
False | Returns true if value is equal to zero.
GreaterThan(UInt32, UInt24) | Returns true if left value is greater than right value.
GreaterThan(UInt24, UInt24) | Returns true if left value is greater than right value.
GreaterThan(UInt24, UInt32) | Returns true if left value is greater than right value.
GreaterThanOrEqual(UInt32, UInt24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(UInt24, UInt24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(UInt24, UInt32) | Returns true if left value is greater than or equal to right value.
(Byte to UInt24) | Implicitly converts value to an UInt24.
(Char to UInt24) | Implicitly converts value to an UInt24.
(UInt16 to UInt24) | Implicitly converts value to an UInt24.
(UInt24 to Int32) | Implicitly converts UInt24 to Int32.
(UInt24 to UInt32) | Implicitly converts UInt24 to UInt32.
(UInt24 to Int64) | Implicitly converts UInt24 to Int64.
(UInt24 to UInt64) | Implicitly converts UInt24 to UInt64.
(UInt24 to Double) | Implicitly converts UInt24 to Double.
(UInt24 to Single) | Implicitly converts UInt24 to Single.
(UInt24 to Decimal) | Implicitly converts UInt24 to Decimal.
(UInt24 to String) | Implicitly converts UInt24 to String.
Increment | Returns incremented value.
Inequality(UInt32, UInt24) | Compares the two values for inequality.
Inequality(UInt24, UInt24) | Compares the two values for inequality.
Inequality(UInt24, UInt32) | Compares the two values for inequality.
LeftShift | Returns value after left shifts of first value by the number of bits specified by second value.
LessThan(UInt32, UInt24) | Returns true if left value is less than right value.
LessThan(UInt24, UInt24) | Returns true if left value is less than right value.
LessThan(UInt24, UInt32) | Returns true if left value is less than right value.
LessThanOrEqual(UInt32, UInt24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(UInt24, UInt24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(UInt24, UInt32) | Returns true if left value is less or equal to than right value.
Modulus(UInt32, UInt24) | Returns computed remainder after dividing first value by the second.
Modulus(UInt24, UInt24) | Returns computed remainder after dividing first value by the second.
Modulus(UInt24, UInt32) | Returns computed remainder after dividing first value by the second.
Multiply(UInt32, UInt24) | Returns computed product of values.
Multiply(UInt24, UInt24) | Returns computed product of values.
Multiply(UInt24, UInt32) | Returns computed product of values.
OnesComplement | Returns bitwise complement of value.
RightShift | Returns value after right shifts of first value by the number of bits specified by second value.
Subtraction(UInt32, UInt24) | Returns computed difference of values.
Subtraction(UInt24, UInt24) | Returns computed difference of values.
Subtraction(UInt24, UInt32) | Returns computed difference of values.
True | Returns true if value is greater than zero.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Addition Operator

Grid Solutions Framework UInt24Addition Operator
Overload List
Name | Description
Addition(UInt32, UInt24) | Returns computed sum of values.
Addition(UInt24, UInt24) | Returns computed sum of values.
Addition(UInt24, UInt32) | Returns computed sum of values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Addition Operator (UInt32, UInt24)

Grid Solutions Framework UInt24Addition Operator (UInt32, UInt24)
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator +(
    uint value1,
    UInt24 value2
)
Public Shared Operator + (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (+)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator +(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of addition operation.
See Also

Reference

UInt24 Structure
Addition Overload
GSF Namespace


UInt24.Addition Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Addition Operator (UInt24, UInt24)
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator +(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator + (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (+)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator +(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value as result of addition operation.
See Also

Reference

UInt24 Structure
Addition Overload
GSF Namespace


UInt24.Addition Operator (UInt24, UInt32)

Grid Solutions Framework UInt24Addition Operator (UInt24, UInt32)
Returns computed sum of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator +(
    UInt24 value1,
    uint value2
)
Public Shared Operator + (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (+)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator +(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of addition operation.
See Also

Reference

UInt24 Structure
Addition Overload
GSF Namespace


UInt24.BitwiseAnd Operator

Grid Solutions Framework UInt24BitwiseAnd Operator
Overload List
Name | Description
BitwiseAnd(UInt32, UInt24) | Returns logical bitwise AND of values.
BitwiseAnd(UInt24, UInt24) | Returns logical bitwise AND of values.
BitwiseAnd(UInt24, UInt32) | Returns logical bitwise AND of values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.BitwiseAnd Operator (UInt32, UInt24)

Grid Solutions Framework UInt24BitwiseAnd Operator (UInt32, UInt24)
Returns logical bitwise AND of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator &(
    uint value1,
    UInt24 value2
)
Public Shared Operator And (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (&&&)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator &(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value representing the logical bitwise AND of the values.
See Also

Reference

UInt24 Structure
BitwiseAnd Overload
GSF Namespace


UInt24.BitwiseAnd Operator (UInt24, UInt24)

Grid Solutions Framework UInt24BitwiseAnd Operator (UInt24, UInt24)
Returns logical bitwise AND of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator &(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator And (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (&&&)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator &(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value representing the logical bitwise AND of the values.
See Also

Reference

UInt24 Structure
BitwiseAnd Overload
GSF Namespace


UInt24.BitwiseAnd Operator (UInt24, UInt32)

Grid Solutions Framework UInt24BitwiseAnd Operator (UInt24, UInt32)
Returns logical bitwise AND of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator &(
    UInt24 value1,
    uint value2
)
Public Shared Operator And (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (&&&)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator &(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value representing the logical bitwise AND of the values.
See Also

Reference

UInt24 Structure
BitwiseAnd Overload
GSF Namespace


UInt24.BitwiseOr Operator

Grid Solutions Framework UInt24BitwiseOr Operator
Overload List
Name | Description
BitwiseOr(UInt32, UInt24) | Returns logical bitwise OR of values.
BitwiseOr(UInt24, UInt24) | Returns logical bitwise OR of values.
BitwiseOr(UInt24, UInt32) | Returns logical bitwise OR of values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.BitwiseOr Operator (UInt32, UInt24)

Grid Solutions Framework UInt24BitwiseOr Operator (UInt32, UInt24)
Returns logical bitwise OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator |(
    uint value1,
    UInt24 value2
)
Public Shared Operator Or (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (|||)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator |(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value representing the logical bitwise OR of the values.
See Also

Reference

UInt24 Structure
BitwiseOr Overload
GSF Namespace


UInt24.BitwiseOr Operator (UInt24, UInt24)

Grid Solutions Framework UInt24BitwiseOr Operator (UInt24, UInt24)
Returns logical bitwise OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator |(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator Or (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (|||)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator |(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value representing the logical bitwise OR of the values.
See Also

Reference

UInt24 Structure
BitwiseOr Overload
GSF Namespace


UInt24.BitwiseOr Operator (UInt24, UInt32)

Grid Solutions Framework UInt24BitwiseOr Operator (UInt24, UInt32)
Returns logical bitwise OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator |(
    UInt24 value1,
    uint value2
)
Public Shared Operator Or (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (|||)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator |(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value representing the logical bitwise OR of the values.
See Also

Reference

UInt24 Structure
BitwiseOr Overload
GSF Namespace


UInt24.Decrement Operator

Grid Solutions Framework UInt24Decrement Operator
Returns decremented value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator --(
    UInt24 value
)
Public Shared Operator -- (
    value As UInt24
) As UInt24
static let inline (--)
        value : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator --(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
The operand.

Return Value

Type: UInt24
UInt24 result of decrement.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Division Operator

Grid Solutions Framework UInt24Division Operator
Overload List
Name | Description
Division(UInt32, UInt24) | Returns computed division of values.
Division(UInt24, UInt24) | Returns computed division of values.
Division(UInt24, UInt32) | Returns computed division of values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Division Operator (UInt32, UInt24)

Grid Solutions Framework UInt24Division Operator (UInt32, UInt24)
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator /(
    uint value1,
    UInt24 value2
)
Public Shared Operator / (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (/)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator /(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of division operation.
See Also

Reference

UInt24 Structure
Division Overload
GSF Namespace


UInt24.Division Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Division Operator (UInt24, UInt24)
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator /(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator / (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (/)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator /(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value as result of division operation.
See Also

Reference

UInt24 Structure
Division Overload
GSF Namespace


UInt24.Division Operator (UInt24, UInt32)

Grid Solutions Framework UInt24Division Operator (UInt24, UInt32)
Returns computed division of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator /(
    UInt24 value1,
    uint value2
)
Public Shared Operator / (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (/)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator /(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of division operation.
See Also

Reference

UInt24 Structure
Division Overload
GSF Namespace


UInt24.Equality Operator

Grid Solutions Framework UInt24Equality Operator
Overload List
Name | Description
Equality(UInt32, UInt24) | Compares the two values for equality.
Equality(UInt24, UInt24) | Compares the two values for equality.
Equality(UInt24, UInt32) | Compares the two values for equality.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Equality Operator (UInt32, UInt24)

Grid Solutions Framework UInt24Equality Operator (UInt32, UInt24)
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    uint value1,
    UInt24 value2
)
Public Shared Operator = (
    value1 As UInteger,
    value2 As UInt24
) As Boolean
static let inline (=)
        value1 : uint32 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
Equality Overload
GSF Namespace


UInt24.Equality Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Equality Operator (UInt24, UInt24)
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator = (
    value1 As UInt24,
    value2 As UInt24
) As Boolean
static let inline (=)
        value1 : UInt24 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
Equality Overload
GSF Namespace


UInt24.Equality Operator (UInt24, UInt32)

Grid Solutions Framework UInt24Equality Operator (UInt24, UInt32)
Compares the two values for equality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    UInt24 value1,
    uint value2
)
Public Shared Operator = (
    value1 As UInt24,
    value2 As UInteger
) As Boolean
static let inline (=)
        value1 : UInt24 *
        value2 : uint32  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
Equality Overload
GSF Namespace


UInt24.ExclusiveOr Operator

Grid Solutions Framework UInt24ExclusiveOr Operator
Overload List
Name | Description
ExclusiveOr(UInt32, UInt24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(UInt24, UInt24) | Returns logical bitwise exclusive-OR of values.
ExclusiveOr(UInt24, UInt32) | Returns logical bitwise exclusive-OR of values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.ExclusiveOr Operator (UInt32, UInt24)

Grid Solutions Framework UInt24ExclusiveOr Operator (UInt32, UInt24)
Returns logical bitwise exclusive-OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator ^(
    uint value1,
    UInt24 value2
)
Public Shared Operator Xor (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (^^^)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator ^(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value representing the logical bitwise exclusive-OR of the values.
See Also

Reference

UInt24 Structure
ExclusiveOr Overload
GSF Namespace


UInt24.ExclusiveOr Operator (UInt24, UInt24)

Grid Solutions Framework UInt24ExclusiveOr Operator (UInt24, UInt24)
Returns logical bitwise exclusive-OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator ^(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator Xor (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (^^^)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator ^(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value representing the logical bitwise exclusive-OR of the values.
See Also

Reference

UInt24 Structure
ExclusiveOr Overload
GSF Namespace


UInt24.ExclusiveOr Operator (UInt24, UInt32)

Grid Solutions Framework UInt24ExclusiveOr Operator (UInt24, UInt32)
Returns logical bitwise exclusive-OR of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator ^(
    UInt24 value1,
    uint value2
)
Public Shared Operator Xor (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (^^^)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator ^(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value representing the logical bitwise exclusive-OR of the values.
See Also

Reference

UInt24 Structure
ExclusiveOr Overload
GSF Namespace


UInt24 Explicit Conversion Operators

Grid Solutions Framework UInt24 Conversion Operators
Overload List
Name | Description
(Decimal to UInt24) | Explicitly converts value to an UInt24.
(Double to UInt24) | Explicitly converts value to an UInt24.
(Enum to UInt24) | Explicitly converts value to an UInt24.
(Single to UInt24) | Explicitly converts value to an UInt24.
(String to UInt24) | Explicitly converts value to an UInt24.
(UInt32 to UInt24) | Explicitly converts value to an UInt24.
(UInt64 to UInt24) | Explicitly converts value to an UInt24.
(Int24 to UInt24) | Explicitly converts value to an UInt24.
(UInt24 to Int24) | Explicitly converts value to an Int24.
(UInt24 to Int16) | Explicitly converts UInt24 to Int16.
(UInt24 to UInt16) | Explicitly converts UInt24 to UInt16.
(UInt24 to Byte) | Explicitly converts UInt24 to Byte.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24 Explicit Conversion (Decimal to UInt24)

Grid Solutions Framework UInt24 Conversion (Decimal to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    decimal value
)
Public Shared Narrowing Operator CType (
    value As Decimal
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    Decimal value
)

Parameters

value
Type: SystemDecimal
Decimal value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (Double to UInt24)

Grid Solutions Framework UInt24 Conversion (Double to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    double value
)
Public Shared Narrowing Operator CType (
    value As Double
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    double value
)

Parameters

value
Type: SystemDouble
Double value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (Enum to UInt24)

Grid Solutions Framework UInt24 Conversion (Enum to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    Enum value
)
Public Shared Narrowing Operator CType (
    value As Enum
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    Enum^ value
)

Parameters

value
Type: SystemEnum
Enum value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (Single to UInt24)

Grid Solutions Framework UInt24 Conversion (Single to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    float value
)
Public Shared Narrowing Operator CType (
    value As Single
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    float value
)

Parameters

value
Type: SystemSingle
Single value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (String to UInt24)

Grid Solutions Framework UInt24 Conversion (String to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    string value
)
Public Shared Narrowing Operator CType (
    value As String
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    String^ value
)

Parameters

value
Type: SystemString
String value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (UInt32 to UInt24)

Grid Solutions Framework UInt24 Conversion (UInt32 to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    uint value
)
Public Shared Narrowing Operator CType (
    value As UInteger
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    unsigned int value
)

Parameters

value
Type: SystemUInt32
UInt32 value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (UInt64 to UInt24)

Grid Solutions Framework UInt24 Conversion (UInt64 to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    ulong value
)
Public Shared Narrowing Operator CType (
    value As ULong
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
UInt64 value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (Int24 to UInt24)

Grid Solutions Framework UInt24 Conversion (Int24 to UInt24)
Explicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator UInt24 (
    Int24 value
)
Public Shared Narrowing Operator CType (
    value As Int24
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator UInt24 (
    Int24 value
)

Parameters

value
Type: GSFInt24
Int24 value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (UInt24 to Int24)

Grid Solutions Framework UInt24 Conversion (UInt24 to Int24)
Explicitly converts value to an Int24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator Int24 (
    UInt24 value
)
Public Shared Narrowing Operator CType (
    value As UInt24
) As Int24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator Int24 (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Int24
Int24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (UInt24 to Int16)

Grid Solutions Framework UInt24 Conversion (UInt24 to Int16)
Explicitly converts UInt24 to Int16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator short (
    UInt24 value
)
Public Shared Narrowing Operator CType (
    value As UInt24
) As Short
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator short (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Int16
Int16 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (UInt24 to UInt16)

Grid Solutions Framework UInt24 Conversion (UInt24 to UInt16)
Explicitly converts UInt24 to UInt16.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator ushort (
    UInt24 value
)
Public Shared Narrowing Operator CType (
    value As UInt24
) As UShort
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator unsigned short (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: UInt16
UInt16 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Explicit Conversion (UInt24 to Byte)

Grid Solutions Framework UInt24 Conversion (UInt24 to Byte)
Explicitly converts UInt24 to Byte.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static explicit operator byte (
    UInt24 value
)
Public Shared Narrowing Operator CType (
    value As UInt24
) As Byte
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static explicit operator unsigned char (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Byte
Byte value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24.Exponent Operator

Grid Solutions Framework UInt24Exponent Operator
Overload List
Name | Description
Exponent(Int32, UInt24) | Returns result of first value raised to power of second value.
Exponent(UInt24, UInt24) | Returns result of first value raised to power of second value.
Exponent(UInt24, Int32) | Returns result of first value raised to power of second value.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Exponent Operator (Int32, UInt24)

Grid Solutions Framework UInt24Exponent Operator (Int32, UInt24)
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Integer,
    value2 As UInt24
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: SystemInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Double
Double value as result of operation.
See Also

Reference

UInt24 Structure
Exponent Overload
GSF Namespace


UInt24.Exponent Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Exponent Operator (UInt24, UInt24)
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As UInt24,
    value2 As UInt24
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Double
Double value as result of operation.
See Also

Reference

UInt24 Structure
Exponent Overload
GSF Namespace


UInt24.Exponent Operator (UInt24, Int32)

Grid Solutions Framework UInt24Exponent Operator (UInt24, Int32)
Returns result of first value raised to power of second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As UInt24,
    value2 As Integer
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemInt32
UInt32 right hand operand.

Return Value

Type: Double
Double value as result of operation.
See Also

Reference

UInt24 Structure
Exponent Overload
GSF Namespace


UInt24.False Operator

Grid Solutions Framework UInt24False Operator
Returns true if value is equal to zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator false(
    UInt24 value
)
Public Shared Operator IsFalse (
    value As UInt24
) As Boolean
static let inline (false)
        value : UInt24  : bool
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value
Type: GSFUInt24
UInt24 value to evaluate.

Return Value

Type: Boolean
Boolean value indicating whether the value is equal than zero.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.GreaterThan Operator

Grid Solutions Framework UInt24GreaterThan Operator
Overload List
Name | Description
GreaterThan(UInt32, UInt24) | Returns true if left value is greater than right value.
GreaterThan(UInt24, UInt24) | Returns true if left value is greater than right value.
GreaterThan(UInt24, UInt32) | Returns true if left value is greater than right value.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.GreaterThan Operator (UInt32, UInt24)

Grid Solutions Framework UInt24GreaterThan Operator (UInt32, UInt24)
Returns true if left value is greater than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    uint value1,
    UInt24 value2
)
Public Shared Operator > (
    value1 As UInteger,
    value2 As UInt24
) As Boolean
static let inline (>)
        value1 : uint32 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
GreaterThan Overload
GSF Namespace


UInt24.GreaterThan Operator (UInt24, UInt24)

Grid Solutions Framework UInt24GreaterThan Operator (UInt24, UInt24)
Returns true if left value is greater than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator > (
    value1 As UInt24,
    value2 As UInt24
) As Boolean
static let inline (>)
        value1 : UInt24 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
GreaterThan Overload
GSF Namespace


UInt24.GreaterThan Operator (UInt24, UInt32)

Grid Solutions Framework UInt24GreaterThan Operator (UInt24, UInt32)
Returns true if left value is greater than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    UInt24 value1,
    uint value2
)
Public Shared Operator > (
    value1 As UInt24,
    value2 As UInteger
) As Boolean
static let inline (>)
        value1 : UInt24 *
        value2 : uint32  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
GreaterThan Overload
GSF Namespace


UInt24.GreaterThanOrEqual Operator

Grid Solutions Framework UInt24GreaterThanOrEqual Operator
Overload List
Name | Description
GreaterThanOrEqual(UInt32, UInt24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(UInt24, UInt24) | Returns true if left value is greater than or equal to right value.
GreaterThanOrEqual(UInt24, UInt32) | Returns true if left value is greater than or equal to right value.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.GreaterThanOrEqual Operator (UInt32, UInt24)

Grid Solutions Framework UInt24GreaterThanOrEqual Operator (UInt32, UInt24)
Returns true if left value is greater than or equal to right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    uint value1,
    UInt24 value2
)
Public Shared Operator >= (
    value1 As UInteger,
    value2 As UInt24
) As Boolean
static let inline (>=)
        value1 : uint32 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
GreaterThanOrEqual Overload
GSF Namespace


UInt24.GreaterThanOrEqual Operator (UInt24, UInt24)

Grid Solutions Framework UInt24GreaterThanOrEqual Operator (UInt24, UInt24)
Returns true if left value is greater than or equal to right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator >= (
    value1 As UInt24,
    value2 As UInt24
) As Boolean
static let inline (>=)
        value1 : UInt24 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
GreaterThanOrEqual Overload
GSF Namespace


UInt24.GreaterThanOrEqual Operator (UInt24, UInt32)

Grid Solutions Framework UInt24GreaterThanOrEqual Operator (UInt24, UInt32)
Returns true if left value is greater than or equal to right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    UInt24 value1,
    uint value2
)
Public Shared Operator >= (
    value1 As UInt24,
    value2 As UInteger
) As Boolean
static let inline (>=)
        value1 : UInt24 *
        value2 : uint32  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
GreaterThanOrEqual Overload
GSF Namespace


UInt24 Implicit Conversion Operators

Grid Solutions Framework UInt24 Conversion Operators
Overload List
Name | Description
(Byte to UInt24) | Implicitly converts value to an UInt24.
(Char to UInt24) | Implicitly converts value to an UInt24.
(UInt16 to UInt24) | Implicitly converts value to an UInt24.
(UInt24 to Int32) | Implicitly converts UInt24 to Int32.
(UInt24 to UInt32) | Implicitly converts UInt24 to UInt32.
(UInt24 to Int64) | Implicitly converts UInt24 to Int64.
(UInt24 to UInt64) | Implicitly converts UInt24 to UInt64.
(UInt24 to Double) | Implicitly converts UInt24 to Double.
(UInt24 to Single) | Implicitly converts UInt24 to Single.
(UInt24 to Decimal) | Implicitly converts UInt24 to Decimal.
(UInt24 to String) | Implicitly converts UInt24 to String.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24 Implicit Conversion (Byte to UInt24)

Grid Solutions Framework UInt24 Conversion (Byte to UInt24)
Implicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator UInt24 (
    byte value
)
Public Shared Widening Operator CType (
    value As Byte
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator UInt24 (
    unsigned char value
)

Parameters

value
Type: SystemByte
Byte value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (Char to UInt24)

Grid Solutions Framework UInt24 Conversion (Char to UInt24)
Implicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator UInt24 (
    char value
)
Public Shared Widening Operator CType (
    value As Char
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator UInt24 (
    wchar_t value
)

Parameters

value
Type: SystemChar
Char value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt16 to UInt24)

Grid Solutions Framework UInt24 Conversion (UInt16 to UInt24)
Implicitly converts value to an UInt24.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator UInt24 (
    ushort value
)
Public Shared Widening Operator CType (
    value As UShort
) As UInt24
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator UInt24 (
    unsigned short value
)

Parameters

value
Type: SystemUInt16
UInt16 value to be converted.

Return Value

Type: UInt24
UInt24 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to Int32)

Grid Solutions Framework UInt24 Conversion (UInt24 to Int32)
Implicitly converts UInt24 to Int32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator int (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As Integer
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator int (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Int32
Int32 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to UInt32)

Grid Solutions Framework UInt24 Conversion (UInt24 to UInt32)
Implicitly converts UInt24 to UInt32.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator uint (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As UInteger
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned int (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: UInt32
UInt32 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to Int64)

Grid Solutions Framework UInt24 Conversion (UInt24 to Int64)
Implicitly converts UInt24 to Int64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator long (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As Long
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator long long (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Int64
Int64 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to UInt64)

Grid Solutions Framework UInt24 Conversion (UInt24 to UInt64)
Implicitly converts UInt24 to UInt64.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ulong (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As ULong
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator unsigned long long (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: UInt64
UInt64 value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to Double)

Grid Solutions Framework UInt24 Conversion (UInt24 to Double)
Implicitly converts UInt24 to Double.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Double
Double value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to Single)

Grid Solutions Framework UInt24 Conversion (UInt24 to Single)
Implicitly converts UInt24 to Single.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator float (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As Single
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator float (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Single
Single value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to Decimal)

Grid Solutions Framework UInt24 Conversion (UInt24 to Decimal)
Implicitly converts UInt24 to Decimal.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator decimal (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As Decimal
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Decimal (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: Decimal
Decimal value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24 Implicit Conversion (UInt24 to String)

Grid Solutions Framework UInt24 Conversion (UInt24 to String)
Implicitly converts UInt24 to String.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator string (
    UInt24 value
)
Public Shared Widening Operator CType (
    value As UInt24
) As String
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator String^ (
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to be converted.

Return Value

Type: String
String value that is the result of the conversion.
See Also

Reference

UInt24 Structure
Overload
GSF Namespace


UInt24.Increment Operator

Grid Solutions Framework UInt24Increment Operator
Returns incremented value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator ++(
    UInt24 value
)
Public Shared Operator ++ (
    value As UInt24
) As UInt24
static let inline (++)
        value : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator ++(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
The operand.

Return Value

Type: UInt24
UInt24 result of increment.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Inequality Operator

Grid Solutions Framework UInt24Inequality Operator
Overload List
Name | Description
Inequality(UInt32, UInt24) | Compares the two values for inequality.
Inequality(UInt24, UInt24) | Compares the two values for inequality.
Inequality(UInt24, UInt32) | Compares the two values for inequality.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Inequality Operator (UInt32, UInt24)

Grid Solutions Framework UInt24Inequality Operator (UInt32, UInt24)
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    uint value1,
    UInt24 value2
)
Public Shared Operator <> (
    value1 As UInteger,
    value2 As UInt24
) As Boolean
static let inline (<>)
        value1 : uint32 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
Inequality Overload
GSF Namespace


UInt24.Inequality Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Inequality Operator (UInt24, UInt24)
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator <> (
    value1 As UInt24,
    value2 As UInt24
) As Boolean
static let inline (<>)
        value1 : UInt24 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
Inequality Overload
GSF Namespace


UInt24.Inequality Operator (UInt24, UInt32)

Grid Solutions Framework UInt24Inequality Operator (UInt24, UInt32)
Compares the two values for inequality.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    UInt24 value1,
    uint value2
)
Public Shared Operator <> (
    value1 As UInt24,
    value2 As UInteger
) As Boolean
static let inline (<>)
        value1 : UInt24 *
        value2 : uint32  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
Inequality Overload
GSF Namespace


UInt24.LeftShift Operator

Grid Solutions Framework UInt24LeftShift Operator
Returns value after left shifts of first value by the number of bits specified by second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator <<(
    UInt24 value,
    int shifts
)
Public Shared Operator << (
    value As UInt24,
    shifts As Integer
) As UInt24
static let inline (<<<)
        value : UInt24 *
        shifts : int  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator <<(
    UInt24 value,
    int shifts
)

Parameters

value
Type: GSFUInt24
UInt24 value to left shift.
shifts
Type: SystemInt32
Int32 value indicating the number of bits to left shift by.

Return Value

Type: UInt24
UInt24 value as result of left shift operation.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.LessThan Operator

Grid Solutions Framework UInt24LessThan Operator
Overload List
Name | Description
LessThan(UInt32, UInt24) | Returns true if left value is less than right value.
LessThan(UInt24, UInt24) | Returns true if left value is less than right value.
LessThan(UInt24, UInt32) | Returns true if left value is less than right value.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.LessThan Operator (UInt32, UInt24)

Grid Solutions Framework UInt24LessThan Operator (UInt32, UInt24)
Returns true if left value is less than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    uint value1,
    UInt24 value2
)
Public Shared Operator < (
    value1 As UInteger,
    value2 As UInt24
) As Boolean
static let inline (<)
        value1 : uint32 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
LessThan Overload
GSF Namespace


UInt24.LessThan Operator (UInt24, UInt24)

Grid Solutions Framework UInt24LessThan Operator (UInt24, UInt24)
Returns true if left value is less than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator < (
    value1 As UInt24,
    value2 As UInt24
) As Boolean
static let inline (<)
        value1 : UInt24 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
LessThan Overload
GSF Namespace


UInt24.LessThan Operator (UInt24, UInt32)

Grid Solutions Framework UInt24LessThan Operator (UInt24, UInt32)
Returns true if left value is less than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    UInt24 value1,
    uint value2
)
Public Shared Operator < (
    value1 As UInt24,
    value2 As UInteger
) As Boolean
static let inline (<)
        value1 : UInt24 *
        value2 : uint32  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
LessThan Overload
GSF Namespace


UInt24.LessThanOrEqual Operator

Grid Solutions Framework UInt24LessThanOrEqual Operator
Overload List
Name | Description
LessThanOrEqual(UInt32, UInt24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(UInt24, UInt24) | Returns true if left value is less or equal to than right value.
LessThanOrEqual(UInt24, UInt32) | Returns true if left value is less or equal to than right value.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.LessThanOrEqual Operator (UInt32, UInt24)

Grid Solutions Framework UInt24LessThanOrEqual Operator (UInt32, UInt24)
Returns true if left value is less or equal to than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    uint value1,
    UInt24 value2
)
Public Shared Operator <= (
    value1 As UInteger,
    value2 As UInt24
) As Boolean
static let inline (<=)
        value1 : uint32 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
LessThanOrEqual Overload
GSF Namespace


UInt24.LessThanOrEqual Operator (UInt24, UInt24)

Grid Solutions Framework UInt24LessThanOrEqual Operator (UInt24, UInt24)
Returns true if left value is less or equal to than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator <= (
    value1 As UInt24,
    value2 As UInt24
) As Boolean
static let inline (<=)
        value1 : UInt24 *
        value2 : UInt24  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
LessThanOrEqual Overload
GSF Namespace


UInt24.LessThanOrEqual Operator (UInt24, UInt32)

Grid Solutions Framework UInt24LessThanOrEqual Operator (UInt24, UInt32)
Returns true if left value is less or equal to than right value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    UInt24 value1,
    uint value2
)
Public Shared Operator <= (
    value1 As UInt24,
    value2 As UInteger
) As Boolean
static let inline (<=)
        value1 : UInt24 *
        value2 : uint32  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: Boolean
Boolean value representing the result.
See Also

Reference

UInt24 Structure
LessThanOrEqual Overload
GSF Namespace


UInt24.Modulus Operator

Grid Solutions Framework UInt24Modulus Operator
Overload List
Name | Description
Modulus(UInt32, UInt24) | Returns computed remainder after dividing first value by the second.
Modulus(UInt24, UInt24) | Returns computed remainder after dividing first value by the second.
Modulus(UInt24, UInt32) | Returns computed remainder after dividing first value by the second.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Modulus Operator (UInt32, UInt24)

Grid Solutions Framework UInt24Modulus Operator (UInt32, UInt24)
Returns computed remainder after dividing first value by the second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator %(
    uint value1,
    UInt24 value2
)
Public Shared Operator Mod (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (%)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator %(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of modulus operation.
See Also

Reference

UInt24 Structure
Modulus Overload
GSF Namespace


UInt24.Modulus Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Modulus Operator (UInt24, UInt24)
Returns computed remainder after dividing first value by the second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator %(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator Mod (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (%)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator %(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value as result of modulus operation.
See Also

Reference

UInt24 Structure
Modulus Overload
GSF Namespace


UInt24.Modulus Operator (UInt24, UInt32)

Grid Solutions Framework UInt24Modulus Operator (UInt24, UInt32)
Returns computed remainder after dividing first value by the second.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator %(
    UInt24 value1,
    uint value2
)
Public Shared Operator Mod (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (%)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator %(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of modulus operation.
See Also

Reference

UInt24 Structure
Modulus Overload
GSF Namespace


UInt24.Multiply Operator

Grid Solutions Framework UInt24Multiply Operator
Overload List
Name | Description
Multiply(UInt32, UInt24) | Returns computed product of values.
Multiply(UInt24, UInt24) | Returns computed product of values.
Multiply(UInt24, UInt32) | Returns computed product of values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Multiply Operator (UInt32, UInt24)

Grid Solutions Framework UInt24Multiply Operator (UInt32, UInt24)
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator *(
    uint value1,
    UInt24 value2
)
Public Shared Operator * (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (*)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator *(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of multiplication operation.
See Also

Reference

UInt24 Structure
Multiply Overload
GSF Namespace


UInt24.Multiply Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Multiply Operator (UInt24, UInt24)
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator *(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator * (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (*)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator *(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value as result of multiplication operation.
See Also

Reference

UInt24 Structure
Multiply Overload
GSF Namespace


UInt24.Multiply Operator (UInt24, UInt32)

Grid Solutions Framework UInt24Multiply Operator (UInt24, UInt32)
Returns computed product of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator *(
    UInt24 value1,
    uint value2
)
Public Shared Operator * (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (*)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator *(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of multiplication operation.
See Also

Reference

UInt24 Structure
Multiply Overload
GSF Namespace


UInt24.OnesComplement Operator

Grid Solutions Framework UInt24OnesComplement Operator
Returns bitwise complement of value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator ~(
    UInt24 value
)
Public Shared Operator ~ (
    value As UInt24
) As UInt24
F# does not support this operator.
JavaScript does not support overloaded operators.
public:
static UInt24 operator ~(
    UInt24 value
)

Parameters

value
Type: GSFUInt24
UInt24 value to evaluate.

Return Value

Type: UInt24
UInt24 value representing the complement of the input value.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.RightShift Operator

Grid Solutions Framework UInt24RightShift Operator
Returns value after right shifts of first value by the number of bits specified by second value.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator >>(
    UInt24 value,
    int shifts
)
Public Shared Operator >> (
    value As UInt24,
    shifts As Integer
) As UInt24
static let inline (>>>)
        value : UInt24 *
        shifts : int  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator >>(
    UInt24 value,
    int shifts
)

Parameters

value
Type: GSFUInt24
UInt24 value to right shift.
shifts
Type: SystemInt32
Int32 value indicating the number of bits to right shift by.

Return Value

Type: UInt24
UInt24 value as result of right shift operation.
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Subtraction Operator

Grid Solutions Framework UInt24Subtraction Operator
Overload List
Name | Description
Subtraction(UInt32, UInt24) | Returns computed difference of values.
Subtraction(UInt24, UInt24) | Returns computed difference of values.
Subtraction(UInt24, UInt32) | Returns computed difference of values.
Top
See Also

Reference

UInt24 Structure
GSF Namespace


UInt24.Subtraction Operator (UInt32, UInt24)

Grid Solutions Framework UInt24Subtraction Operator (UInt32, UInt24)
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator -(
    uint value1,
    UInt24 value2
)
Public Shared Operator - (
    value1 As UInteger,
    value2 As UInt24
) As UInteger
static let inline (-)
        value1 : uint32 *
        value2 : UInt24  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator -(
    unsigned int value1,
    UInt24 value2
)

Parameters

value1
Type: SystemUInt32
UInt32 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of subtraction operation.
See Also

Reference

UInt24 Structure
Subtraction Overload
GSF Namespace


UInt24.Subtraction Operator (UInt24, UInt24)

Grid Solutions Framework UInt24Subtraction Operator (UInt24, UInt24)
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 operator -(
    UInt24 value1,
    UInt24 value2
)
Public Shared Operator - (
    value1 As UInt24,
    value2 As UInt24
) As UInt24
static let inline (-)
        value1 : UInt24 *
        value2 : UInt24  : UInt24
JavaScript does not support overloaded operators.
public:
static UInt24 operator -(
    UInt24 value1,
    UInt24 value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: GSFUInt24
UInt24 right hand operand.

Return Value

Type: UInt24
UInt24 value as result of subtraction operation.
See Also

Reference

UInt24 Structure
Subtraction Overload
GSF Namespace


UInt24.Subtraction Operator (UInt24, UInt32)

Grid Solutions Framework UInt24Subtraction Operator (UInt24, UInt32)
Returns computed difference of values.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint operator -(
    UInt24 value1,
    uint value2
)
Public Shared Operator - (
    value1 As UInt24,
    value2 As UInteger
) As UInteger
static let inline (-)
        value1 : UInt24 *
        value2 : uint32  : uint32
JavaScript does not support overloaded operators.
public:
static unsigned int operator -(
    UInt24 value1,
    unsigned int value2
)

Parameters

value1
Type: GSFUInt24
UInt24 left hand operand.
value2
Type: SystemUInt32
UInt32 right hand operand.

Return Value

Type: UInt32
UInt32 value as result of subtraction operation.
See Also

Reference

UInt24 Structure
Subtraction Overload
GSF Namespace


UInt24.True Operator

Grid Solutions Framework UInt24True Operator
Returns true if value is greater than zero.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator true(
    UInt24 value
)
Public Shared Operator IsTrue (
    value As UInt24
) As Boolean
static let inline (true)
        value : UInt24  : bool
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value
Type: GSFUInt24
UInt24 value to evaluate.

Return Value

Type: Boolean
Boolean value indicating whether the value is greater than zero.
See Also

Reference

UInt24 Structure
GSF Namespace


UnixTimeTag Class

Grid Solutions Framework UnixTimeTag Class
Represents a standard Unix timetag.
Inheritance Hierarchy
SystemObject
GSFTimeTagBase
GSFUnixTimeTag

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class UnixTimeTag : TimeTagBase
<SerializableAttribute>
Public Class UnixTimeTag
    Inherits TimeTagBase
[<SerializableAttribute>]
type UnixTimeTag =
    class
        inherit TimeTagBase
    end
GSF.UnixTimeTag = function();

Type.createClass(
    'GSF.UnixTimeTag',
    GSF.TimeTagBase);
[SerializableAttribute]
public ref class UnixTimeTag : public TimeTagBase

The UnixTimeTag type exposes the following members.

Constructors
 | Name | Description
Public method | UnixTimeTag(Double) | Creates a new UnixTimeTag, given number of seconds since 1/1/1970.
Public method | UnixTimeTag(UInt32) | Creates a new UnixTimeTag, given number of seconds since 1/1/1970.
Public method | UnixTimeTag(Ticks) | Creates a new UnixTimeTag, given specified Ticks.
Protected method | UnixTimeTag(SerializationInfo, StreamingContext) | Creates a new UnixTimeTag from serialization parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime. (Inherited from TimeTagBase.)
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object. (Inherited from TimeTagBase.)
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from TimeTagBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString | Returns basic textual representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider. (Inherited from TimeTagBase.)
Public method | ToString(String) | Returns textual representation for timetag in the specified format. (Inherited from TimeTagBase.)
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider. (Inherited from TimeTagBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
BaseTicks | Number of ticks since 1/1/1970.
Top
Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation. (Inherited from TimeTagBase.)
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time. (Inherited from TimeTagBase.)
Top
See Also

Reference

GSF Namespace


UnixTimeTag Constructor

Grid Solutions Framework UnixTimeTag Constructor
Overload List
 | Name | Description
Public method | UnixTimeTag(Double) | Creates a new UnixTimeTag, given number of seconds since 1/1/1970.
Public method | UnixTimeTag(UInt32) | Creates a new UnixTimeTag, given number of seconds since 1/1/1970.
Public method | UnixTimeTag(Ticks) | Creates a new UnixTimeTag, given specified Ticks.
Protected method | UnixTimeTag(SerializationInfo, StreamingContext) | Creates a new UnixTimeTag from serialization parameters.
Top
See Also

Reference

UnixTimeTag Class
GSF Namespace


UnixTimeTag Constructor (Double)

Grid Solutions Framework UnixTimeTag Constructor (Double)
Creates a new UnixTimeTag, given number of seconds since 1/1/1970.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnixTimeTag(
    double seconds
)
Public Sub New (
    seconds As Double
)
new :
        seconds : float -> UnixTimeTag
GSF.UnixTimeTag = function(seconds);
public:
UnixTimeTag(
    double seconds
)

Parameters

seconds
Type: SystemDouble
Number of seconds since 1/1/1970.
See Also

Reference

UnixTimeTag Class
UnixTimeTag Overload
GSF Namespace


UnixTimeTag Constructor (UInt32)

Grid Solutions Framework UnixTimeTag Constructor (UInt32)
Creates a new UnixTimeTag, given number of seconds since 1/1/1970.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnixTimeTag(
    uint seconds
)
Public Sub New (
    seconds As UInteger
)
new :
        seconds : uint32 -> UnixTimeTag
GSF.UnixTimeTag = function(seconds);
public:
UnixTimeTag(
    unsigned int seconds
)

Parameters

seconds
Type: SystemUInt32
Number of seconds since 1/1/1970.
See Also

Reference

UnixTimeTag Class
UnixTimeTag Overload
GSF Namespace


UnixTimeTag Constructor (Ticks)

Grid Solutions Framework UnixTimeTag Constructor (Ticks)
Creates a new UnixTimeTag, given specified Ticks.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnixTimeTag(
    Ticks timestamp
)
Public Sub New (
    timestamp As Ticks
)
new :
        timestamp : Ticks -> UnixTimeTag
GSF.UnixTimeTag = function(timestamp);
public:
UnixTimeTag(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp in Ticks to create Unix timetag from (minimum valid date is 1/1/1970).
Remarks
This constructor will accept a DateTime parameter since Ticks is implicitly castable to a DateTime.
See Also

Reference

UnixTimeTag Class
UnixTimeTag Overload
GSF Namespace


UnixTimeTag Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework UnixTimeTag Constructor (SerializationInfo, StreamingContext)
Creates a new UnixTimeTag from serialization parameters.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected UnixTimeTag(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> UnixTimeTag
GSF.UnixTimeTag = function(info, context);
protected:
UnixTimeTag(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

UnixTimeTag Class
UnixTimeTag Overload
GSF Namespace


UnixTimeTag Fields

Grid Solutions Framework UnixTimeTag Fields

The UnixTimeTag type exposes the following members.

Fields
Name | Description
BaseTicks | Number of ticks since 1/1/1970.
Top
See Also

Reference

UnixTimeTag Class
GSF Namespace


UnixTimeTag.BaseTicks Field

Grid Solutions Framework UnixTimeTagBaseTicks Field
Number of ticks since 1/1/1970.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Ticks BaseTicks
Public Shared ReadOnly BaseTicks As Ticks
static val BaseTicks: Ticks
var GSF.UnixTimeTag.BaseTicks
public:
static initonly Ticks BaseTicks

Field Value

Type: Ticks
Remarks
Unix dates are measured as the number of seconds since 1/1/1970.
See Also

Reference

UnixTimeTag Class
GSF Namespace


UnixTimeTag Methods

Grid Solutions Framework UnixTimeTag Methods

The UnixTimeTag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime. (Inherited from TimeTagBase.)
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object. (Inherited from TimeTagBase.)
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from TimeTagBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString | Returns basic textual representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider. (Inherited from TimeTagBase.)
Public method | ToString(String) | Returns textual representation for timetag in the specified format. (Inherited from TimeTagBase.)
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider. (Inherited from TimeTagBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UnixTimeTag Class
GSF Namespace


UnixTimeTag Properties

Grid Solutions Framework UnixTimeTag Properties

The UnixTimeTag type exposes the following members.

Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation. (Inherited from TimeTagBase.)
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time. (Inherited from TimeTagBase.)
Top
See Also

Reference

UnixTimeTag Class
GSF Namespace


UpdateType Enumeration

Grid Solutions Framework UpdateType Enumeration
Indicates the type of update.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum UpdateType
Public Enumeration UpdateType
type UpdateType
GSF.UpdateType = function();
GSF.UpdateType.createEnum('GSF.UpdateType', false);
public enum class UpdateType
Members
Member name | Value | Description
Information | 0 | Update is informational.
Warning | 1 | Update is a warning.
Alarm | 2 | Update is an alarm.
See Also

Reference

GSF Namespace


USTimeZones Class

Grid Solutions Framework USTimeZones Class
Defines a few common United States time zones.
Inheritance Hierarchy
SystemObject
GSFUSTimeZones

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class USTimeZones
Public NotInheritable Class USTimeZones
[<AbstractClassAttribute>]
[<SealedAttribute>]
type USTimeZones =  class end
GSF.USTimeZones = function();

Type.createClass(
    'GSF.USTimeZones');
public ref class USTimeZones abstract sealed

The USTimeZones type exposes the following members.

Properties
Name | Description
Alaskan | Gets the Alaskan time zone.
Atlantic | Gets the Atlantic time zone.
Central | Gets the Central time zone.
Eastern | Gets the Eastern time zone.
Hawaiian | Gets the Hawaiian time zone.
Mountain | Gets the Mountain time zone.
Pacific | Gets the Pacific time zone.
Samoa | Gets the Samoa time zone.
WestPacific | Gets the West Pacific time zone.
Top
See Also

Reference

GSF Namespace


USTimeZones Properties

Grid Solutions Framework USTimeZones Properties

The USTimeZones type exposes the following members.

Properties
Name | Description
Alaskan | Gets the Alaskan time zone.
Atlantic | Gets the Atlantic time zone.
Central | Gets the Central time zone.
Eastern | Gets the Eastern time zone.
Hawaiian | Gets the Hawaiian time zone.
Mountain | Gets the Mountain time zone.
Pacific | Gets the Pacific time zone.
Samoa | Gets the Samoa time zone.
WestPacific | Gets the West Pacific time zone.
Top
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Alaskan Property

Grid Solutions Framework USTimeZonesAlaskan Property
Gets the Alaskan time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Alaskan { get; }
Public Shared ReadOnly Property Alaskan As TimeZoneInfo
    Get
static member Alaskan : TimeZoneInfo with get

GSF.USTimeZones.get_Alaskan = function();

public:
static property TimeZoneInfo^ Alaskan {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Atlantic Property

Grid Solutions Framework USTimeZonesAtlantic Property
Gets the Atlantic time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Atlantic { get; }
Public Shared ReadOnly Property Atlantic As TimeZoneInfo
    Get
static member Atlantic : TimeZoneInfo with get

GSF.USTimeZones.get_Atlantic = function();

public:
static property TimeZoneInfo^ Atlantic {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
Remarks
This time zone is used by the Commonwealth of Puerto Rico and the United States Virgin Islands.
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Central Property

Grid Solutions Framework USTimeZonesCentral Property
Gets the Central time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Central { get; }
Public Shared ReadOnly Property Central As TimeZoneInfo
    Get
static member Central : TimeZoneInfo with get

GSF.USTimeZones.get_Central = function();

public:
static property TimeZoneInfo^ Central {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Eastern Property

Grid Solutions Framework USTimeZonesEastern Property
Gets the Eastern time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Eastern { get; }
Public Shared ReadOnly Property Eastern As TimeZoneInfo
    Get
static member Eastern : TimeZoneInfo with get

GSF.USTimeZones.get_Eastern = function();

public:
static property TimeZoneInfo^ Eastern {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Hawaiian Property

Grid Solutions Framework USTimeZonesHawaiian Property
Gets the Hawaiian time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Hawaiian { get; }
Public Shared ReadOnly Property Hawaiian As TimeZoneInfo
    Get
static member Hawaiian : TimeZoneInfo with get

GSF.USTimeZones.get_Hawaiian = function();

public:
static property TimeZoneInfo^ Hawaiian {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Mountain Property

Grid Solutions Framework USTimeZonesMountain Property
Gets the Mountain time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Mountain { get; }
Public Shared ReadOnly Property Mountain As TimeZoneInfo
    Get
static member Mountain : TimeZoneInfo with get

GSF.USTimeZones.get_Mountain = function();

public:
static property TimeZoneInfo^ Mountain {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Pacific Property

Grid Solutions Framework USTimeZonesPacific Property
Gets the Pacific time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Pacific { get; }
Public Shared ReadOnly Property Pacific As TimeZoneInfo
    Get
static member Pacific : TimeZoneInfo with get

GSF.USTimeZones.get_Pacific = function();

public:
static property TimeZoneInfo^ Pacific {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.Samoa Property

Grid Solutions Framework USTimeZonesSamoa Property
Gets the Samoa time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo Samoa { get; }
Public Shared ReadOnly Property Samoa As TimeZoneInfo
    Get
static member Samoa : TimeZoneInfo with get

GSF.USTimeZones.get_Samoa = function();

public:
static property TimeZoneInfo^ Samoa {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
Remarks
This time zone is used by the American Samoa.
See Also

Reference

USTimeZones Class
GSF Namespace


USTimeZones.WestPacific Property

Grid Solutions Framework USTimeZonesWestPacific Property
Gets the West Pacific time zone.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo WestPacific { get; }
Public Shared ReadOnly Property WestPacific As TimeZoneInfo
    Get
static member WestPacific : TimeZoneInfo with get

GSF.USTimeZones.get_WestPacific = function();

public:
static property TimeZoneInfo^ WestPacific {
    TimeZoneInfo^ get ();
}

Property Value

Type: TimeZoneInfo
Remarks

This time zone is used by Guam and the Commonwealth of the Northern Mariana Islands.

This is also known as the Chamorro time zone.

See Also

Reference

USTimeZones Class
GSF Namespace


Word Class

Grid Solutions Framework Word Class
Represents functions and extensions related to 16-bit words, 32-bit double-words and 64-bit quad-words.
Inheritance Hierarchy
SystemObject
GSFWord

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Word
<ExtensionAttribute>
Public NotInheritable Class Word
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Word =  class end
GSF.Word = function();

Type.createClass(
    'GSF.Word');
[ExtensionAttribute]
public ref class Word abstract sealed

The Word type exposes the following members.

Methods
Name | Description
AlignDoubleWord(Int32) | Aligns double-word value on a 32-bit boundary.
AlignDoubleWord(UInt32) | Aligns double-word value on a 32-bit boundary.
AlignQuadWord(Int64) | Aligns quad-word value on a 64-bit boundary.
AlignQuadWord(UInt64) | Aligns quad-word value on a 64-bit boundary.
AlignWord(Int16) | Aligns word value on a 16-bit boundary.
AlignWord(UInt16) | Aligns word value on a 16-bit boundary.
HighByte | Returns the high-byte from an unsigned word (UInt16).
HighDoubleWord | Returns the unsigned high-double-word (UInt32) from an unsigned quad-word (UInt64).
HighNibble | Returns the high-nibble (high 4-bits) from a byte.
HighWord | Returns the unsigned high-word (UInt16) from an unsigned double-word (UInt32).
LowByte | Returns the low-byte from an unsigned word (UInt16).
LowDoubleWord | Returns the unsigned low-double-word (UInt32) from an unsigned quad-word (UInt64).
LowNibble | Returns the low-nibble (low 4-bits) from a byte.
LowWord | Returns the unsigned low-word (UInt16) from an unsigned double-word (UInt32).
MakeDoubleWord | Makes an unsigned double-word (UInt32) from two unsigned words (UInt16).
MakeQuadWord | Makes an unsigned quad-word (UInt64) from two unsigned double-words (UInt32).
MakeWord | Makes an unsigned word (UInt16) from two bytes.
Top
See Also

Reference

GSF Namespace


Word Methods

Grid Solutions Framework Word Methods

The Word type exposes the following members.

Methods
Name | Description
AlignDoubleWord(Int32) | Aligns double-word value on a 32-bit boundary.
AlignDoubleWord(UInt32) | Aligns double-word value on a 32-bit boundary.
AlignQuadWord(Int64) | Aligns quad-word value on a 64-bit boundary.
AlignQuadWord(UInt64) | Aligns quad-word value on a 64-bit boundary.
AlignWord(Int16) | Aligns word value on a 16-bit boundary.
AlignWord(UInt16) | Aligns word value on a 16-bit boundary.
HighByte | Returns the high-byte from an unsigned word (UInt16).
HighDoubleWord | Returns the unsigned high-double-word (UInt32) from an unsigned quad-word (UInt64).
HighNibble | Returns the high-nibble (high 4-bits) from a byte.
HighWord | Returns the unsigned high-word (UInt16) from an unsigned double-word (UInt32).
LowByte | Returns the low-byte from an unsigned word (UInt16).
LowDoubleWord | Returns the unsigned low-double-word (UInt32) from an unsigned quad-word (UInt64).
LowNibble | Returns the low-nibble (low 4-bits) from a byte.
LowWord | Returns the unsigned low-word (UInt16) from an unsigned double-word (UInt32).
MakeDoubleWord | Makes an unsigned double-word (UInt32) from two unsigned words (UInt16).
MakeQuadWord | Makes an unsigned quad-word (UInt64) from two unsigned double-words (UInt32).
MakeWord | Makes an unsigned word (UInt16) from two bytes.
Top
See Also

Reference

Word Class
GSF Namespace


Word.AlignDoubleWord Method

Grid Solutions Framework WordAlignDoubleWord Method
Overload List
Name | Description
AlignDoubleWord(Int32) | Aligns double-word value on a 32-bit boundary.
AlignDoubleWord(UInt32) | Aligns double-word value on a 32-bit boundary.
Top
See Also

Reference

Word Class
GSF Namespace


Word.AlignDoubleWord Method (Int32)

Grid Solutions Framework WordAlignDoubleWord Method (Int32)
Aligns double-word value on a 32-bit boundary.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int AlignDoubleWord(
    this int doubleWord
)
<ExtensionAttribute>
Public Shared Function AlignDoubleWord (
    doubleWord As Integer
) As Integer
static member AlignDoubleWord :
        doubleWord : int -> int

GSF.Word.AlignDoubleWord = function(doubleWord);
public:
[ExtensionAttribute]
static int AlignDoubleWord(
    int doubleWord
)

Parameters

doubleWord
Type: SystemInt32
Double-word value to align.

Return Value

Type: Int32
Double-word value aligned to next 32-bit boundary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
AlignDoubleWord Overload
GSF Namespace


Word.AlignDoubleWord Method (UInt32)

Grid Solutions Framework WordAlignDoubleWord Method (UInt32)
Aligns double-word value on a 32-bit boundary.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint AlignDoubleWord(
    this uint doubleWord
)
<ExtensionAttribute>
Public Shared Function AlignDoubleWord (
    doubleWord As UInteger
) As UInteger
static member AlignDoubleWord :
        doubleWord : uint32 -> uint32

GSF.Word.AlignDoubleWord = function(doubleWord);
public:
[ExtensionAttribute]
static unsigned int AlignDoubleWord(
    unsigned int doubleWord
)

Parameters

doubleWord
Type: SystemUInt32
Double-word value to align.

Return Value

Type: UInt32
Double-word value aligned to next 32-bit boundary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
AlignDoubleWord Overload
GSF Namespace


Word.AlignQuadWord Method

Grid Solutions Framework WordAlignQuadWord Method
Overload List
Name | Description
AlignQuadWord(Int64) | Aligns quad-word value on a 64-bit boundary.
AlignQuadWord(UInt64) | Aligns quad-word value on a 64-bit boundary.
Top
See Also

Reference

Word Class
GSF Namespace


Word.AlignQuadWord Method (Int64)

Grid Solutions Framework WordAlignQuadWord Method (Int64)
Aligns quad-word value on a 64-bit boundary.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long AlignQuadWord(
    this long quadWord
)
<ExtensionAttribute>
Public Shared Function AlignQuadWord (
    quadWord As Long
) As Long
static member AlignQuadWord :
        quadWord : int64 -> int64

GSF.Word.AlignQuadWord = function(quadWord);
public:
[ExtensionAttribute]
static long long AlignQuadWord(
    long long quadWord
)

Parameters

quadWord
Type: SystemInt64
Quad-word value to align.

Return Value

Type: Int64
Quad-word value aligned to next 64-bit boundary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
AlignQuadWord Overload
GSF Namespace


Word.AlignQuadWord Method (UInt64)

Grid Solutions Framework WordAlignQuadWord Method (UInt64)
Aligns quad-word value on a 64-bit boundary.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong AlignQuadWord(
    this ulong quadWord
)
<ExtensionAttribute>
Public Shared Function AlignQuadWord (
    quadWord As ULong
) As ULong
static member AlignQuadWord :
        quadWord : uint64 -> uint64

GSF.Word.AlignQuadWord = function(quadWord);
public:
[ExtensionAttribute]
static unsigned long long AlignQuadWord(
    unsigned long long quadWord
)

Parameters

quadWord
Type: SystemUInt64
Quad-word value to align.

Return Value

Type: UInt64
Quad-word value aligned to next 64-bit boundary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
AlignQuadWord Overload
GSF Namespace


Word.AlignWord Method

Grid Solutions Framework WordAlignWord Method
Overload List
Name | Description
AlignWord(Int16) | Aligns word value on a 16-bit boundary.
AlignWord(UInt16) | Aligns word value on a 16-bit boundary.
Top
See Also

Reference

Word Class
GSF Namespace


Word.AlignWord Method (Int16)

Grid Solutions Framework WordAlignWord Method (Int16)
Aligns word value on a 16-bit boundary.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short AlignWord(
    this short word
)
<ExtensionAttribute>
Public Shared Function AlignWord (
    word As Short
) As Short
static member AlignWord :
        word : int16 -> int16

GSF.Word.AlignWord = function(word);
public:
[ExtensionAttribute]
static short AlignWord(
    short word
)

Parameters

word
Type: SystemInt16
Word value to align.

Return Value

Type: Int16
Word value aligned to next 16-bit boundary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Int16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
AlignWord Overload
GSF Namespace


Word.AlignWord Method (UInt16)

Grid Solutions Framework WordAlignWord Method (UInt16)
Aligns word value on a 16-bit boundary.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort AlignWord(
    this ushort word
)
<ExtensionAttribute>
Public Shared Function AlignWord (
    word As UShort
) As UShort
static member AlignWord :
        word : uint16 -> uint16

GSF.Word.AlignWord = function(word);
public:
[ExtensionAttribute]
static unsigned short AlignWord(
    unsigned short word
)

Parameters

word
Type: SystemUInt16
Word value to align.

Return Value

Type: UInt16
Word value aligned to next 16-bit boundary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
AlignWord Overload
GSF Namespace


Word.HighByte Method

Grid Solutions Framework WordHighByte Method
Returns the high-byte from an unsigned word (UInt16).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte HighByte(
    this ushort word
)
<ExtensionAttribute>
Public Shared Function HighByte (
    word As UShort
) As Byte
static member HighByte :
        word : uint16 -> byte

GSF.Word.HighByte = function(word);
public:
[ExtensionAttribute]
static unsigned char HighByte(
    unsigned short word
)

Parameters

word
Type: SystemUInt16
2-byte, 16-bit unsigned integer value.

Return Value

Type: Byte
The high-order byte of the specified 16-bit unsigned integer value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
On little-endian architectures (e.g., Intel platforms), this will be the byte value whose in-memory representation is the same as the right-most, most-significant-byte of the integer value.
See Also

Reference

Word Class
GSF Namespace


Word.HighDoubleWord Method

Grid Solutions Framework WordHighDoubleWord Method
Returns the unsigned high-double-word (UInt32) from an unsigned quad-word (UInt64).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint HighDoubleWord(
    this ulong quadWord
)
<ExtensionAttribute>
Public Shared Function HighDoubleWord (
    quadWord As ULong
) As UInteger
static member HighDoubleWord :
        quadWord : uint64 -> uint32

GSF.Word.HighDoubleWord = function(quadWord);
public:
[ExtensionAttribute]
static unsigned int HighDoubleWord(
    unsigned long long quadWord
)

Parameters

quadWord
Type: SystemUInt64
8-byte, 64-bit unsigned integer value.

Return Value

Type: UInt32
The high-order double-word of the specified 64-bit unsigned integer value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
On little-endian architectures (e.g., Intel platforms), this will be the word value whose in-memory representation is the same as the right-most, most-significant-word of the integer value.
See Also

Reference

Word Class
GSF Namespace


Word.HighNibble Method

Grid Solutions Framework WordHighNibble Method
Returns the high-nibble (high 4-bits) from a byte.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte HighNibble(
    this byte value
)
<ExtensionAttribute>
Public Shared Function HighNibble (
    value As Byte
) As Byte
static member HighNibble :
        value : byte -> byte

GSF.Word.HighNibble = function(value);
public:
[ExtensionAttribute]
static unsigned char HighNibble(
    unsigned char value
)

Parameters

value
Type: SystemByte
Byte value.

Return Value

Type: Byte
The high-nibble of the specified byte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
GSF Namespace


Word.HighWord Method

Grid Solutions Framework WordHighWord Method
Returns the unsigned high-word (UInt16) from an unsigned double-word (UInt32).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort HighWord(
    this uint doubleWord
)
<ExtensionAttribute>
Public Shared Function HighWord (
    doubleWord As UInteger
) As UShort
static member HighWord :
        doubleWord : uint32 -> uint16

GSF.Word.HighWord = function(doubleWord);
public:
[ExtensionAttribute]
static unsigned short HighWord(
    unsigned int doubleWord
)

Parameters

doubleWord
Type: SystemUInt32
4-byte, 32-bit unsigned integer value.

Return Value

Type: UInt16
The unsigned high-order word of the specified 32-bit unsigned integer value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
On little-endian architectures (e.g., Intel platforms), this will be the word value whose in-memory representation is the same as the right-most, most-significant-word of the integer value.
See Also

Reference

Word Class
GSF Namespace


Word.LowByte Method

Grid Solutions Framework WordLowByte Method
Returns the low-byte from an unsigned word (UInt16).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte LowByte(
    this ushort word
)
<ExtensionAttribute>
Public Shared Function LowByte (
    word As UShort
) As Byte
static member LowByte :
        word : uint16 -> byte

GSF.Word.LowByte = function(word);
public:
[ExtensionAttribute]
static unsigned char LowByte(
    unsigned short word
)

Parameters

word
Type: SystemUInt16
2-byte, 16-bit unsigned integer value.

Return Value

Type: Byte
The low-order byte of the specified 16-bit unsigned integer value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
On little-endian architectures (e.g., Intel platforms), this will be the byte value whose in-memory representation is the same as the left-most, least-significant-byte of the integer value.
See Also

Reference

Word Class
GSF Namespace


Word.LowDoubleWord Method

Grid Solutions Framework WordLowDoubleWord Method
Returns the unsigned low-double-word (UInt32) from an unsigned quad-word (UInt64).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint LowDoubleWord(
    this ulong quadWord
)
<ExtensionAttribute>
Public Shared Function LowDoubleWord (
    quadWord As ULong
) As UInteger
static member LowDoubleWord :
        quadWord : uint64 -> uint32

GSF.Word.LowDoubleWord = function(quadWord);
public:
[ExtensionAttribute]
static unsigned int LowDoubleWord(
    unsigned long long quadWord
)

Parameters

quadWord
Type: SystemUInt64
8-byte, 64-bit unsigned integer value.

Return Value

Type: UInt32
The low-order double-word of the specified 64-bit unsigned integer value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt64. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
On little-endian architectures (e.g., Intel platforms), this will be the word value whose in-memory representation is the same as the left-most, least-significant-word of the integer value.
See Also

Reference

Word Class
GSF Namespace


Word.LowNibble Method

Grid Solutions Framework WordLowNibble Method
Returns the low-nibble (low 4-bits) from a byte.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte LowNibble(
    this byte value
)
<ExtensionAttribute>
Public Shared Function LowNibble (
    value As Byte
) As Byte
static member LowNibble :
        value : byte -> byte

GSF.Word.LowNibble = function(value);
public:
[ExtensionAttribute]
static unsigned char LowNibble(
    unsigned char value
)

Parameters

value
Type: SystemByte
Byte value.

Return Value

Type: Byte
The low-nibble of the specified byte value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Word Class
GSF Namespace


Word.LowWord Method

Grid Solutions Framework WordLowWord Method
Returns the unsigned low-word (UInt16) from an unsigned double-word (UInt32).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort LowWord(
    this uint doubleWord
)
<ExtensionAttribute>
Public Shared Function LowWord (
    doubleWord As UInteger
) As UShort
static member LowWord :
        doubleWord : uint32 -> uint16

GSF.Word.LowWord = function(doubleWord);
public:
[ExtensionAttribute]
static unsigned short LowWord(
    unsigned int doubleWord
)

Parameters

doubleWord
Type: SystemUInt32
4-byte, 32-bit unsigned integer value.

Return Value

Type: UInt16
The unsigned low-order word of the specified 32-bit unsigned integer value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt32. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
On little-endian architectures (e.g., Intel platforms), this will be the word value whose in-memory representation is the same as the left-most, least-significant-word of the integer value.
See Also

Reference

Word Class
GSF Namespace


Word.MakeDoubleWord Method

Grid Solutions Framework WordMakeDoubleWord Method
Makes an unsigned double-word (UInt32) from two unsigned words (UInt16).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint MakeDoubleWord(
    ushort high,
    ushort low
)
Public Shared Function MakeDoubleWord (
    high As UShort,
    low As UShort
) As UInteger
static member MakeDoubleWord :
        high : uint16 *
        low : uint16 -> uint32

GSF.Word.MakeDoubleWord = function(high, low);
public:
static unsigned int MakeDoubleWord(
    unsigned short high,
    unsigned short low
)

Parameters

high
Type: SystemUInt16
High word.
low
Type: SystemUInt16
Low word.

Return Value

Type: UInt32
An unsigned 32-bit double-word made from the two specified unsigned 16-bit words.
See Also

Reference

Word Class
GSF Namespace


Word.MakeQuadWord Method

Grid Solutions Framework WordMakeQuadWord Method
Makes an unsigned quad-word (UInt64) from two unsigned double-words (UInt32).

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong MakeQuadWord(
    uint high,
    uint low
)
Public Shared Function MakeQuadWord (
    high As UInteger,
    low As UInteger
) As ULong
static member MakeQuadWord :
        high : uint32 *
        low : uint32 -> uint64

GSF.Word.MakeQuadWord = function(high, low);
public:
static unsigned long long MakeQuadWord(
    unsigned int high,
    unsigned int low
)

Parameters

high
Type: SystemUInt32
High double-word.
low
Type: SystemUInt32
Low double-word.

Return Value

Type: UInt64
An unsigned 64-bit quad-word made from the two specified unsigned 32-bit double-words.
See Also

Reference

Word Class
GSF Namespace


Word.MakeWord Method

Grid Solutions Framework WordMakeWord Method
Makes an unsigned word (UInt16) from two bytes.

Namespace: GSF
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort MakeWord(
    byte high,
    byte low
)
Public Shared Function MakeWord (
    high As Byte,
    low As Byte
) As UShort
static member MakeWord :
        high : byte *
        low : byte -> uint16

GSF.Word.MakeWord = function(high, low);
public:
static unsigned short MakeWord(
    unsigned char high,
    unsigned char low
)

Parameters

high
Type: SystemByte
High byte.
low
Type: SystemByte
Low byte.

Return Value

Type: UInt16
An unsigned 16-bit word made from the two specified bytes.
See Also

Reference

Word Class
GSF Namespace


GSF.Adapters Namespace

Grid Solutions Framework GSF.Adapters Namespace
Contains classes that facilitate the development of adapter-driven architecture.
Classes
 | Class | Description
Public class | Adapter | Represents an adapter that could execute in isolation in a separate AppDomain.
 | AdapterLoaderT | Represents a generic loader of adapters.
Interfaces
 | Interface | Description
Public interface | IAdapter | Defines an adapter that could execute in isolation in a separate AppDomain.
Enumerations
 | Enumeration | Description
Public enumeration | AdapterFileFormat | Specifies the file format of the adapters to be loaded by the AdapterLoaderT.


Adapter Class

Grid Solutions Framework Adapter Class
Represents an adapter that could execute in isolation in a separate AppDomain.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.MetadataProvidersMetadataProviderBase
GSF.Historian.NotifiersNotifierBase
GSF.Historian.ReplicationReplicationProviderBase
GSF.ServiceModelSelfHostingService
GSF.ServiceProcessServiceMonitorBase

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[DataContractAttribute(Namespace = "")]
public class Adapter : MarshalByRefObject, IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
<SerializableAttribute>
<DataContractAttribute(Namespace := "")>
Public Class Adapter
    Inherits MarshalByRefObject
    Implements IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
[<SerializableAttribute>]
[<DataContractAttribute(Namespace = "")>]
type Adapter =
    class
        inherit MarshalByRefObject
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Adapters.Adapter = function();

Type.createClass(
    'GSF.Adapters.Adapter',
    MarshalByRefObject,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[SerializableAttribute]
[DataContractAttribute(Namespace = L"")]
public ref class Adapter : public MarshalByRefObject,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The Adapter type exposes the following members.

Constructors
 | Name | Description
Public method | Adapter | Initializes a new instance of the Adapter.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Adapter and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the Adapter.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved Adapter settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event.
Protected method | OnExecutionException | Raises the ExecutionException event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event.
Public method | SaveSettings | Saves Adapter settings to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled.
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN.
Public property | Name | Gets the unique identifier of the Adapter.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file.
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Status | Gets the descriptive status of the Adapter.
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed.
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update.
Top
See Also

Reference

GSF.Adapters Namespace
GSF.AdaptersIAdapter
GSF.AdaptersAdapterLoaderT


Adapter Constructor

Grid Solutions Framework Adapter Constructor
Initializes a new instance of the Adapter.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Adapter()
Public Sub New
new : unit -> Adapter
GSF.Adapters.Adapter = function();
public:
Adapter()
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter Methods

Grid Solutions Framework Adapter Methods

The Adapter type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Adapter and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the Adapter.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved Adapter settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event.
Protected method | OnExecutionException | Raises the ExecutionException event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event.
Public method | SaveSettings | Saves Adapter settings to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Dispose Method

Grid Solutions Framework AdapterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Adapter.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Adapter and optionally releases the managed resources.
Top
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Dispose Method

Grid Solutions Framework AdapterDispose Method
Releases all the resources used by the Adapter.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

Adapter Class
Dispose Overload
GSF.Adapters Namespace


Adapter.Dispose Method (Boolean)

Grid Solutions Framework AdapterDispose Method (Boolean)
Releases the unmanaged resources used by the Adapter and optionally releases the managed resources.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

Adapter Class
Dispose Overload
GSF.Adapters Namespace


Adapter.Finalize Method

Grid Solutions Framework AdapterFinalize Method
Releases the unmanaged resources before the Adapter is reclaimed by GC.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Initialize Method

Grid Solutions Framework AdapterInitialize Method
Initializes the Adapter.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize()

Implements

ISupportLifecycleInitialize
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.LoadSettings Method

Grid Solutions Framework AdapterLoadSettings Method
Loads saved Adapter settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void LoadSettings()
Public Overridable Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings()

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.OnDisposed Method

Grid Solutions Framework AdapterOnDisposed Method
Raises the Disposed event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDisposed()
Protected Overridable Sub OnDisposed
abstract OnDisposed : unit -> unit
override OnDisposed : unit -> unit
function OnDisposed();
protected:
virtual void OnDisposed()
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.OnExecutionException Method

Grid Solutions Framework AdapterOnExecutionException Method
Raises the ExecutionException event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnExecutionException(
    string activityDescription,
    Exception encounteredException
)
Protected Overridable Sub OnExecutionException (
    activityDescription As String,
    encounteredException As Exception
)
abstract OnExecutionException :
        activityDescription : string *
        encounteredException : Exception -> unit
override OnExecutionException :
        activityDescription : string *
        encounteredException : Exception -> unit
function OnExecutionException(activityDescription, encounteredException);
protected:
virtual void OnExecutionException(
    String^ activityDescription,
    Exception^ encounteredException
)

Parameters

activityDescription
Type: SystemString
Activity description to send to ExecutionException event.
encounteredException
Type: SystemException
Encountered Exception to send to ExecutionException event.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.OnStatusUpdate Method

Grid Solutions Framework AdapterOnStatusUpdate Method
Raises the StatusUpdate event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusUpdate(
    UpdateType updateType,
    string updateMessage,
    params Object[] args
)
Protected Overridable Sub OnStatusUpdate (
    updateType As UpdateType,
    updateMessage As String,
    ParamArray args As Object()
)
abstract OnStatusUpdate :
        updateType : UpdateType *
        updateMessage : string *
        args : Object[] -> unit
override OnStatusUpdate :
        updateType : UpdateType *
        updateMessage : string *
        args : Object[] -> unit
function OnStatusUpdate(updateType, updateMessage, ... args);
protected:
virtual void OnStatusUpdate(
    UpdateType updateType,
    String^ updateMessage,
    ... array<Object^>^ args
)

Parameters

updateType
Type: GSFUpdateType
UpdateType to send to StatusUpdate event.
updateMessage
Type: SystemString
Update message to send to StatusUpdate event.
args
Type: SystemObject
Arguments to be used when formatting the updateMessage.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.SaveSettings Method

Grid Solutions Framework AdapterSaveSettings Method
Saves Adapter settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SaveSettings()
Public Overridable Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings()

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter Properties

Grid Solutions Framework Adapter Properties

The Adapter type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled.
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN.
Public property | Name | Gets the unique identifier of the Adapter.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file.
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Status | Gets the descriptive status of the Adapter.
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName.
Top
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Domain Property

Grid Solutions Framework AdapterDomain Property
Gets the AppDomain in which the Adapter is executing.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AppDomain Domain { get; }
Public Overridable ReadOnly Property Domain As AppDomain
    Get
abstract Domain : AppDomain with get
override Domain : AppDomain with get
function get_Domain();

public:
virtual property AppDomain^ Domain {
    AppDomain^ get ();
}

Property Value

Type: AppDomain

Implements

IAdapterDomain
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Enabled Property

Grid Solutions Framework AdapterEnabled Property
Gets or sets a boolean value that indicates whether the Adapter is currently enabled.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public virtual bool Enabled { get; set; }
<XmlIgnoreAttribute>
Public Overridable Property Enabled As Boolean
    Get
    Set
[<XmlIgnoreAttribute>]
abstract Enabled : bool with get, set
[<XmlIgnoreAttribute>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[XmlIgnoreAttribute]
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.HostFile Property

Grid Solutions Framework AdapterHostFile Property
Gets or sets the path to the file where the Adapter is housed.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual string HostFile { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<BrowsableAttribute(false)>
<XmlIgnoreAttribute>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property HostFile As String
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
[<XmlIgnoreAttribute>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract HostFile : string with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
[<XmlIgnoreAttribute>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override HostFile : string with get, set
function get_HostFile();
function set_HostFile(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[BrowsableAttribute(false)]
[XmlIgnoreAttribute]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property String^ HostFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterHostFile
Remarks
This can be used to update the Adapter when changes are made to the file where it is housed.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.IsDisposed Property

Grid Solutions Framework AdapterIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public bool IsDisposed { get; }
<XmlIgnoreAttribute>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<XmlIgnoreAttribute>]
abstract IsDisposed : bool with get
[<XmlIgnoreAttribute>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[XmlIgnoreAttribute]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.MemoryUsage Property

Grid Solutions Framework AdapterMemoryUsage Property
Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double MemoryUsage { get; }
Public ReadOnly Property MemoryUsage As Double
    Get
abstract MemoryUsage : float with get
override MemoryUsage : float with get
function get_MemoryUsage();

public:
virtual property double MemoryUsage {
    double get () sealed;
}

Property Value

Type: Double

Implements

IAdapterMemoryUsage
Remarks

MemoryUsage gets updated only after a full blocking collection by GC (e.g. Collect).

This method always returns NaN under Mono deployments.

See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Name Property

Grid Solutions Framework AdapterName Property
Gets the unique identifier of the Adapter.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Name { get; }
Public Overridable ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.PersistSettings Property

Grid Solutions Framework AdapterPersistSettings Property
Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public virtual bool PersistSettings { get; set; }
<XmlIgnoreAttribute>
Public Overridable Property PersistSettings As Boolean
    Get
    Set
[<XmlIgnoreAttribute>]
abstract PersistSettings : bool with get, set
[<XmlIgnoreAttribute>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[XmlIgnoreAttribute]
virtual property bool PersistSettings {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.ProcessorUsage Property

Grid Solutions Framework AdapterProcessorUsage Property
Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ProcessorUsage { get; }
Public ReadOnly Property ProcessorUsage As Double
    Get
abstract ProcessorUsage : float with get
override ProcessorUsage : float with get
function get_ProcessorUsage();

public:
virtual property double ProcessorUsage {
    double get () sealed;
}

Property Value

Type: Double

Implements

IAdapterProcessorUsage
Remarks
This method always returns NaN under Mono deployments.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.SettingsCategory Property

Grid Solutions Framework AdapterSettingsCategory Property
Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public virtual string SettingsCategory { get; set; }
<XmlIgnoreAttribute>
Public Overridable Property SettingsCategory As String
    Get
    Set
[<XmlIgnoreAttribute>]
abstract SettingsCategory : string with get, set
[<XmlIgnoreAttribute>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[XmlIgnoreAttribute]
virtual property String^ SettingsCategory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Status Property

Grid Solutions Framework AdapterStatus Property
Gets the descriptive status of the Adapter.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.TypeName Property

Grid Solutions Framework AdapterTypeName Property
Gets or sets the text representation of the Adapter's TypeName.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual string TypeName { get; set; }
<BrowsableAttribute(false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property TypeName As String
    Get
    Set
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract TypeName : string with get, set
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override TypeName : string with get, set
function get_TypeName();
function set_TypeName(value);
public:
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterTypeName
Remarks
This can be used for looking up the TypeName of the Adapter when deserializing it using XmlSerializer.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter Events

Grid Solutions Framework Adapter Events

The Adapter type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed.
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update.
Top
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.Disposed Event

Grid Solutions Framework AdapterDisposed Event
Occurs when Adapter is disposed.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.ExecutionException Event

Grid Solutions Framework AdapterExecutionException Event
Occurs when the IAdapter encounters an Exception during execution.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string, Exception>> ExecutionException
Public Event ExecutionException As EventHandler(Of EventArgs(Of String, Exception))
abstract ExecutionException : IEvent<EventHandler<EventArgs<string, Exception>>,
    EventArgs<string, Exception>>
override ExecutionException : IEvent<EventHandler<EventArgs<string, Exception>>,
    EventArgs<string, Exception>>
function add_ExecutionException(value);
function remove_ExecutionException(value);
public:
virtual  event EventHandler<EventArgs<String^, Exception^>^>^ ExecutionException {
    void add (EventHandler<EventArgs<String^, Exception^>^>^ value);
    void remove (EventHandler<EventArgs<String^, Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String, Exception

Implements

IAdapterExecutionException
Remarks
Argument1 is the text that describes the activity that was being performed by the IAdapter.
Argument2 is the encountered Exception.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


Adapter.StatusUpdate Event

Grid Solutions Framework AdapterStatusUpdate Event
Occurs when the Adapter wants to provide a status update.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<UpdateType, string>> StatusUpdate
Public Event StatusUpdate As EventHandler(Of EventArgs(Of UpdateType, String))
abstract StatusUpdate : IEvent<EventHandler<EventArgs<UpdateType, string>>,
    EventArgs<UpdateType, string>>
override StatusUpdate : IEvent<EventHandler<EventArgs<UpdateType, string>>,
    EventArgs<UpdateType, string>>
function add_StatusUpdate(value);
function remove_StatusUpdate(value);
public:
virtual  event EventHandler<EventArgs<UpdateType, String^>^>^ StatusUpdate {
    void add (EventHandler<EventArgs<UpdateType, String^>^>^ value);
    void remove (EventHandler<EventArgs<UpdateType, String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs UpdateType, String

Implements

IAdapterStatusUpdate
Remarks
Argument1 is the UpdateType.
Argument2 is the update message.
See Also

Reference

Adapter Class
GSF.Adapters Namespace


AdapterFileFormat Enumeration

Grid Solutions Framework AdapterFileFormat Enumeration
Specifies the file format of the adapters to be loaded by the AdapterLoaderT.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum AdapterFileFormat
Public Enumeration AdapterFileFormat
type AdapterFileFormat
GSF.Adapters.AdapterFileFormat = function();
GSF.Adapters.AdapterFileFormat.createEnum('GSF.Adapters.AdapterFileFormat', false);
public enum class AdapterFileFormat
Members
Member name | Value | Description
Assembly | 0 | Adapters are Types inside Assembly files (DLLs).
SerializedBin | 1 | Adapters are binary serialized instances persisted to files.
SerializedXml | 2 | Adapters are XML serialized instances persisted to files.
See Also

Reference

GSF.Adapters Namespace


AdapterLoader(T) Class

Grid Solutions Framework AdapterLoaderT Class
Represents a generic loader of adapters.
Inheritance Hierarchy
SystemObject
GSF.AdaptersAdapterLoaderT
GSF.Historian.DataServicesDataServices
GSF.Historian.MetadataProvidersMetadataProviders
GSF.Historian.NotifiersNotifiers
GSF.Historian.ReplicationReplicationProviders
GSF.ServiceProcessServiceMonitors

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AdapterLoader<T> : ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings
where T : class, IAdapter

Public Class AdapterLoader(Of T As {Class, IAdapter})
    Implements ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
type AdapterLoader<'T when 'T : not struct and IAdapter> =
    class
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : ref class, IAdapter
public ref class AdapterLoader : ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings

Type Parameters

T
Type of adapters to be loaded.

The AdapterLoaderT type exposes the following members.

Constructors
 | Name | Description
Public method | AdapterLoaderT | Initializes a new instance of the AdapterLoaderT class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data.
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process.
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT.
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT.
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters.
Protected method | OnAdapterCreated | Raises the AdapterCreated event.
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event.
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event.
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event.
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event.
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event.
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it.
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it.
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAdapterDirectory | Specifies the default value for the AdapterDirectory property.
DefaultAdapterFileExtension | Specifies the default value for the AdapterFileExtension property.
DefaultAdapterFileFormat | Specifies the default value for the AdapterFileFormat property.
DefaultAllowableAdapterMemoryUsage | Specifies the default value for the AllowableAdapterMemoryUsage property.
DefaultAllowableAdapterProcessorUsage | Specifies the default value for the AllowableAdapterProcessorUsage property.
DefaultAllowableProcessMemoryUsage | Specifies the default value for the AllowableProcessMemoryUsage property
DefaultAllowableProcessProcessorUsage | Specifies the default value for the AllowableProcessProcessorUsage property.
DefaultIsolateAdapters | Specifies the default value for the IsolateAdapters property.
DefaultMonitorAdapters | Specifies the default value for the MonitorAdapters property.
DefaultWatchForAdapters | Specifies the default value for the WatchForAdapters property.
Top
Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located.
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters.
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters.
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory.
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime.
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process.
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process.
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters.
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters.
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution.
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored.
Public property | Name | Gets the unique identifier of the AdapterLoaderT.
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file.
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Status | Gets the descriptive status of the AdapterLoaderT.
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters.
Top
Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated.
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list.
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter.
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage.
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list.
Public event | Disposed | Occurs when the class has been disposed.
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters.
Top
Examples
This example show how to use the AdapterLoaderT to isolate adapters in separate AppDomains and monitor their resource usage:
Copy
using System;
using System.Collections.Generic;
using System.Text;
using System.Threading;
using GSF;
using GSF.Adapters;
using GSF.Security.Cryptography;

class Program
{
    static AdapterLoader<PublishAdapterBase> s_adapterLoader;

    static void Main(string[] args)
    {
        // Enable app domain resource monitoring.
        AppDomain.MonitoringIsEnabled = true;

        // Load adapters that mimic data publishing.
        s_adapterLoader = new AdapterLoader<PublishAdapterBase>();
        s_adapterLoader.IsolateAdapters = true;
        s_adapterLoader.MonitorAdapters = true;
        s_adapterLoader.AdapterFileExtension = "*.exe";
        s_adapterLoader.AllowableProcessMemoryUsage = 200;
        s_adapterLoader.AllowableProcessProcessorUsage = 50;
        s_adapterLoader.AllowableAdapterMemoryUsage = 100;
        s_adapterLoader.AllowableAdapterProcessorUsage = 25;
        s_adapterLoader.AdapterLoaded += OnAdapterLoaded;
        s_adapterLoader.AdapterUnloaded += OnAdapterUnloaded;
        s_adapterLoader.AdapterResourceUsageExceeded += OnAdapterResourceUsageExceeded;
        s_adapterLoader.Initialize();

        // Shutdown.
        Console.ReadLine();
        s_adapterLoader.Dispose();
    }

    static void OnAdapterLoaded(object sender, EventArgs<PublishAdapterBase> e)
    {
        Console.WriteLine("{0} has been loaded\r\n", e.Argument.GetType().Name);
    }

    static void OnAdapterUnloaded(object sender, EventArgs<PublishAdapterBase> e)
    {
        Console.WriteLine("{0} has been unloaded\r\n", e.Argument.GetType().Name);
    }

    static void OnAdapterResourceUsageExceeded(object sender, GSF.EventArgs<PublishAdapterBase> e)
    {
        Console.WriteLine("{0} status:", e.Argument.Name);
        Console.WriteLine(e.Argument.Status);

        // Remove the adapter in order to reclaim the resources used by it.
        lock (s_adapterLoader.Adapters)
        {
            s_adapterLoader.Adapters.Remove(e.Argument);
        }
    }
}

/// <summary>
/// Base adapter class.
/// </summary>
public abstract class PublishAdapterBase : Adapter
{
    public PublishAdapterBase()
    {
        Data = new List<byte[]>();
    }

    public List<byte[]> Data { get; set; }

    public override void Initialize()
    {
        base.Initialize();
        new Thread(Publish).Start();
    }

    protected abstract void Publish();
}

/// <summary>
/// Adapter that does not manage memory well.
/// </summary>
public class PublishAdapterA : PublishAdapterBase
{
    protected override void Publish()
    {
        while (true)
        {
            for (int i = 0; i < 10000; i++)
            {
                Data.Add(new byte[10]);
            }
            Thread.Sleep(100);
        }
    }
}

/// <summary>
/// Adapter that uses the processor in excess.
/// </summary>
public class PublishAdapterB : PublishAdapterBase
{
    protected override void Publish()
    {
        string text = string.Empty;
        System.Random random = new System.Random();
        while (true)
        {
            for (int i = 0; i < 10; i++)
            {
                for (int j = 0; j < 4; j++)
                {
                    text += (char)random.Next(256);
                }
                Data.Add(Encoding.ASCII.GetBytes(text.Encrypt("C1pH3r", CipherStrength.Aes256)).BlockCopy(0, 1));
            }
            Thread.Sleep(10);
        }
    }
}
See Also

Reference

GSF.Adapters Namespace
GSF.AdaptersAdapter
GSF.AdaptersIAdapter


AdapterLoader(T) Constructor

Grid Solutions Framework AdapterLoaderT Constructor
Initializes a new instance of the AdapterLoaderT class.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdapterLoader()
Public Sub New
new : unit -> AdapterLoader
GSF.Adapters.AdapterLoader = function();
public:
AdapterLoader()
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T) Fields

Grid Solutions Framework AdapterLoaderT Fields

The AdapterLoaderT generic type exposes the following members.

Fields
Name | Description
DefaultAdapterDirectory | Specifies the default value for the AdapterDirectory property.
DefaultAdapterFileExtension | Specifies the default value for the AdapterFileExtension property.
DefaultAdapterFileFormat | Specifies the default value for the AdapterFileFormat property.
DefaultAllowableAdapterMemoryUsage | Specifies the default value for the AllowableAdapterMemoryUsage property.
DefaultAllowableAdapterProcessorUsage | Specifies the default value for the AllowableAdapterProcessorUsage property.
DefaultAllowableProcessMemoryUsage | Specifies the default value for the AllowableProcessMemoryUsage property
DefaultAllowableProcessProcessorUsage | Specifies the default value for the AllowableProcessProcessorUsage property.
DefaultIsolateAdapters | Specifies the default value for the IsolateAdapters property.
DefaultMonitorAdapters | Specifies the default value for the MonitorAdapters property.
DefaultWatchForAdapters | Specifies the default value for the WatchForAdapters property.
Top
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultAdapterDirectory Field

Grid Solutions Framework AdapterLoaderTDefaultAdapterDirectory Field
Specifies the default value for the AdapterDirectory property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultAdapterDirectory
Public Const DefaultAdapterDirectory As String
static val mutable DefaultAdapterDirectory: string
var GSF.Adapters.AdapterLoader.DefaultAdapterDirectory
public:
literal String^ DefaultAdapterDirectory

Field Value

Type: String
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultAdapterFileExtension Field

Grid Solutions Framework AdapterLoaderTDefaultAdapterFileExtension Field
Specifies the default value for the AdapterFileExtension property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultAdapterFileExtension
Public Const DefaultAdapterFileExtension As String
static val mutable DefaultAdapterFileExtension: string
var GSF.Adapters.AdapterLoader.DefaultAdapterFileExtension
public:
literal String^ DefaultAdapterFileExtension

Field Value

Type: String
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultAdapterFileFormat Field

Grid Solutions Framework AdapterLoaderTDefaultAdapterFileFormat Field
Specifies the default value for the AdapterFileFormat property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const AdapterFileFormat DefaultAdapterFileFormat
Public Const DefaultAdapterFileFormat As AdapterFileFormat
static val mutable DefaultAdapterFileFormat: AdapterFileFormat
var GSF.Adapters.AdapterLoader.DefaultAdapterFileFormat
public:
literal AdapterFileFormat DefaultAdapterFileFormat

Field Value

Type: AdapterFileFormat
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultAllowableAdapterMemoryUsage Field

Grid Solutions Framework AdapterLoaderTDefaultAllowableAdapterMemoryUsage Field
Specifies the default value for the AllowableAdapterMemoryUsage property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultAllowableAdapterMemoryUsage
Public Const DefaultAllowableAdapterMemoryUsage As Double
static val mutable DefaultAllowableAdapterMemoryUsage: float
var GSF.Adapters.AdapterLoader.DefaultAllowableAdapterMemoryUsage
public:
literal double DefaultAllowableAdapterMemoryUsage

Field Value

Type: Double
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultAllowableAdapterProcessorUsage Field

Grid Solutions Framework AdapterLoaderTDefaultAllowableAdapterProcessorUsage Field
Specifies the default value for the AllowableAdapterProcessorUsage property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultAllowableAdapterProcessorUsage
Public Const DefaultAllowableAdapterProcessorUsage As Double
static val mutable DefaultAllowableAdapterProcessorUsage: float
var GSF.Adapters.AdapterLoader.DefaultAllowableAdapterProcessorUsage
public:
literal double DefaultAllowableAdapterProcessorUsage

Field Value

Type: Double
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultAllowableProcessMemoryUsage Field

Grid Solutions Framework AdapterLoaderTDefaultAllowableProcessMemoryUsage Field
Specifies the default value for the AllowableProcessMemoryUsage property

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultAllowableProcessMemoryUsage
Public Const DefaultAllowableProcessMemoryUsage As Double
static val mutable DefaultAllowableProcessMemoryUsage: float
var GSF.Adapters.AdapterLoader.DefaultAllowableProcessMemoryUsage
public:
literal double DefaultAllowableProcessMemoryUsage

Field Value

Type: Double
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultAllowableProcessProcessorUsage Field

Grid Solutions Framework AdapterLoaderTDefaultAllowableProcessProcessorUsage Field
Specifies the default value for the AllowableProcessProcessorUsage property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultAllowableProcessProcessorUsage
Public Const DefaultAllowableProcessProcessorUsage As Double
static val mutable DefaultAllowableProcessProcessorUsage: float
var GSF.Adapters.AdapterLoader.DefaultAllowableProcessProcessorUsage
public:
literal double DefaultAllowableProcessProcessorUsage

Field Value

Type: Double
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultIsolateAdapters Field

Grid Solutions Framework AdapterLoaderTDefaultIsolateAdapters Field
Specifies the default value for the IsolateAdapters property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIsolateAdapters
Public Const DefaultIsolateAdapters As Boolean
static val mutable DefaultIsolateAdapters: bool
var GSF.Adapters.AdapterLoader.DefaultIsolateAdapters
public:
literal bool DefaultIsolateAdapters

Field Value

Type: Boolean
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultMonitorAdapters Field

Grid Solutions Framework AdapterLoaderTDefaultMonitorAdapters Field
Specifies the default value for the MonitorAdapters property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultMonitorAdapters
Public Const DefaultMonitorAdapters As Boolean
static val mutable DefaultMonitorAdapters: bool
var GSF.Adapters.AdapterLoader.DefaultMonitorAdapters
public:
literal bool DefaultMonitorAdapters

Field Value

Type: Boolean
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).DefaultWatchForAdapters Field

Grid Solutions Framework AdapterLoaderTDefaultWatchForAdapters Field
Specifies the default value for the WatchForAdapters property.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultWatchForAdapters
Public Const DefaultWatchForAdapters As Boolean
static val mutable DefaultWatchForAdapters: bool
var GSF.Adapters.AdapterLoader.DefaultWatchForAdapters
public:
literal bool DefaultWatchForAdapters

Field Value

Type: Boolean
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T) Methods

Grid Solutions Framework AdapterLoaderT Methods

The AdapterLoaderT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data.
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process.
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT.
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT.
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters.
Protected method | OnAdapterCreated | Raises the AdapterCreated event.
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event.
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event.
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event.
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event.
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event.
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it.
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it.
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Dispose Method

Grid Solutions Framework AdapterLoaderTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources.
Top
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Dispose Method

Grid Solutions Framework AdapterLoaderTDispose Method
Releases all the resources used by the AdapterLoaderT.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

AdapterLoaderT Class
Dispose Overload
GSF.Adapters Namespace


AdapterLoader(T).Dispose Method (Boolean)

Grid Solutions Framework AdapterLoaderTDispose Method (Boolean)
Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

AdapterLoaderT Class
Dispose Overload
GSF.Adapters Namespace


AdapterLoader(T).ExecuteAdapterOperation Method

Grid Solutions Framework AdapterLoaderTExecuteAdapterOperation Method
Executes an operation on the adapter with the given data.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExecuteAdapterOperation(
    T adapter,
    Object data
)
Protected Overridable Sub ExecuteAdapterOperation (
    adapter As T,
    data As Object
)
abstract ExecuteAdapterOperation :
        adapter : 'T *
        data : Object -> unit
override ExecuteAdapterOperation :
        adapter : 'T *
        data : Object -> unit
function ExecuteAdapterOperation(adapter, data);
protected:
virtual void ExecuteAdapterOperation(
    T adapter,
    Object^ data
)

Parameters

adapter
Type: T
Adapter on which an operation is to be executed.
data
Type: SystemObject
Data to be used when executing an operation.
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Finalize Method

Grid Solutions Framework AdapterLoaderTFinalize Method
Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).GetMemoryUsage Method

Grid Solutions Framework AdapterLoaderTGetMemoryUsage Method
Gets the memory usage in bytes of the specified process.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual double GetMemoryUsage(
    Process process
)
Protected Overridable Function GetMemoryUsage (
    process As Process
) As Double
abstract GetMemoryUsage :
        process : Process -> float
override GetMemoryUsage :
        process : Process -> float
function GetMemoryUsage(process);
protected:
virtual double GetMemoryUsage(
    Process^ process
)

Parameters

process
Type: System.DiagnosticsProcess
The Process whose memory usage is to be determined.

Return Value

Type: Double
Memory usage in bytes of the specified process.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).GetProcessorUsage Method

Grid Solutions Framework AdapterLoaderTGetProcessorUsage Method
Gets the % processor usage of the specified process.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual double GetProcessorUsage(
    Process process
)
Protected Overridable Function GetProcessorUsage (
    process As Process
) As Double
abstract GetProcessorUsage :
        process : Process -> float
override GetProcessorUsage :
        process : Process -> float
function GetProcessorUsage(process);
protected:
virtual double GetProcessorUsage(
    Process^ process
)

Parameters

process
Type: System.DiagnosticsProcess
The Process whose processor usage is to be determined.

Return Value

Type: Double
Processor usage in % of the specified process.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Initialize Method

Grid Solutions Framework AdapterLoaderTInitialize Method
Overload List
 | Name | Description
Public method | Initialize | Initializes the AdapterLoaderT.
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT.
Top
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Initialize Method

Grid Solutions Framework AdapterLoaderTInitialize Method
Initializes the AdapterLoaderT.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize()

Implements

ISupportLifecycleInitialize
See Also

Reference

AdapterLoaderT Class
Initialize Overload
GSF.Adapters Namespace


AdapterLoader(T).Initialize Method (IEnumerable(Type))

Grid Solutions Framework AdapterLoaderTInitialize Method (IEnumerableType)
Initializes the AdapterLoaderT.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize(
    IEnumerable<Type> adapterTypes
)
Public Overridable Sub Initialize (
    adapterTypes As IEnumerable(Of Type)
)
abstract Initialize :
        adapterTypes : IEnumerable<Type> -> unit
override Initialize :
        adapterTypes : IEnumerable<Type> -> unit
function Initialize(adapterTypes);
public:
virtual void Initialize(
    IEnumerable<Type^>^ adapterTypes
)

Parameters

adapterTypes
Type: System.Collections.GenericIEnumerable Type
Collection of adapter Types from which Adapters are to be created.
See Also

Reference

AdapterLoaderT Class
Initialize Overload
GSF.Adapters Namespace


AdapterLoader(T).LoadSettings Method

Grid Solutions Framework AdapterLoaderTLoadSettings Method
Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).MonitorAdapterResources Method

Grid Solutions Framework AdapterLoaderTMonitorAdapterResources Method
Monitors the resource utilization of Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void MonitorAdapterResources()
Protected Overridable Sub MonitorAdapterResources
abstract MonitorAdapterResources : unit -> unit
override MonitorAdapterResources : unit -> unit
function MonitorAdapterResources();
protected:
virtual void MonitorAdapterResources()
Remarks
AppDomain monitoring is not enabled under Mono deployments.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OnAdapterCreated Method

Grid Solutions Framework AdapterLoaderTOnAdapterCreated Method
Raises the AdapterCreated event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnAdapterCreated(
    T adapter
)
Protected Overridable Sub OnAdapterCreated (
    adapter As T
)
abstract OnAdapterCreated :
        adapter : 'T -> unit
override OnAdapterCreated :
        adapter : 'T -> unit
function OnAdapterCreated(adapter);
protected:
virtual void OnAdapterCreated(
    T adapter
)

Parameters

adapter
Type: T
Adapter instance to send to AdapterCreated event.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OnAdapterLoaded Method

Grid Solutions Framework AdapterLoaderTOnAdapterLoaded Method
Raises the AdapterLoaded event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnAdapterLoaded(
    T adapter
)
Protected Overridable Sub OnAdapterLoaded (
    adapter As T
)
abstract OnAdapterLoaded :
        adapter : 'T -> unit
override OnAdapterLoaded :
        adapter : 'T -> unit
function OnAdapterLoaded(adapter);
protected:
virtual void OnAdapterLoaded(
    T adapter
)

Parameters

adapter
Type: T
Adapter instance to send to AdapterLoaded event.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OnAdapterLoadException Method

Grid Solutions Framework AdapterLoaderTOnAdapterLoadException Method
Raises the AdapterLoadException event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnAdapterLoadException(
    T adapter,
    Exception exception
)
Protected Overridable Sub OnAdapterLoadException (
    adapter As T,
    exception As Exception
)
abstract OnAdapterLoadException :
        adapter : 'T *
        exception : Exception -> unit
override OnAdapterLoadException :
        adapter : 'T *
        exception : Exception -> unit
function OnAdapterLoadException(adapter, exception);
protected:
virtual void OnAdapterLoadException(
    T adapter,
    Exception^ exception
)

Parameters

adapter
Type: T
Adapter instance that caused the exception.
exception
Type: SystemException
Exception to send to AdapterLoadException event.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OnAdapterResourceUsageExceeded Method

Grid Solutions Framework AdapterLoaderTOnAdapterResourceUsageExceeded Method
Raises the AdapterResourceUsageExceeded event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnAdapterResourceUsageExceeded(
    T adapter
)
Protected Overridable Sub OnAdapterResourceUsageExceeded (
    adapter As T
)
abstract OnAdapterResourceUsageExceeded :
        adapter : 'T -> unit
override OnAdapterResourceUsageExceeded :
        adapter : 'T -> unit
function OnAdapterResourceUsageExceeded(adapter);
protected:
virtual void OnAdapterResourceUsageExceeded(
    T adapter
)

Parameters

adapter
Type: T
Adapter instance to send to AdapterResourceUsageExceeded event.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OnAdapterUnloaded Method

Grid Solutions Framework AdapterLoaderTOnAdapterUnloaded Method
Raises the AdapterUnloaded event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnAdapterUnloaded(
    T adapter
)
Protected Overridable Sub OnAdapterUnloaded (
    adapter As T
)
abstract OnAdapterUnloaded :
        adapter : 'T -> unit
override OnAdapterUnloaded :
        adapter : 'T -> unit
function OnAdapterUnloaded(adapter);
protected:
virtual void OnAdapterUnloaded(
    T adapter
)

Parameters

adapter
Type: T
Adapter instance to send to AdapterUnloaded event.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OnOperationExecutionException Method

Grid Solutions Framework AdapterLoaderTOnOperationExecutionException Method
Raises the OperationExecutionException event.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOperationExecutionException(
    T adapter,
    Exception exception
)
Protected Overridable Sub OnOperationExecutionException (
    adapter As T,
    exception As Exception
)
abstract OnOperationExecutionException :
        adapter : 'T *
        exception : Exception -> unit
override OnOperationExecutionException :
        adapter : 'T *
        exception : Exception -> unit
function OnOperationExecutionException(adapter, exception);
protected:
virtual void OnOperationExecutionException(
    T adapter,
    Exception^ exception
)

Parameters

adapter
Type: T
Adapter instance to send to OperationExecutionException event.
exception
Type: SystemException
Exception to send to OperationExecutionException event.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).ProcessAdapter Method

Grid Solutions Framework AdapterLoaderTProcessAdapter Method
Overload List
 | Name | Description
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it.
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it.
Top
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).ProcessAdapter Method (String)

Grid Solutions Framework AdapterLoaderTProcessAdapter Method (String)
Processes the adapterFile by deserializing it.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ProcessAdapter(
    string adapterFile
)
Protected Overridable Sub ProcessAdapter (
    adapterFile As String
)
abstract ProcessAdapter :
        adapterFile : string -> unit
override ProcessAdapter :
        adapterFile : string -> unit
function ProcessAdapter(adapterFile);
protected:
virtual void ProcessAdapter(
    String^ adapterFile
)

Parameters

adapterFile
Type: SystemString
Path to the adapter file to be deserialized.
See Also

Reference

AdapterLoaderT Class
ProcessAdapter Overload
GSF.Adapters Namespace


AdapterLoader(T).ProcessAdapter Method (Type)

Grid Solutions Framework AdapterLoaderTProcessAdapter Method (Type)
Processes the adapterType by instantiating it.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ProcessAdapter(
    Type adapterType
)
Protected Overridable Sub ProcessAdapter (
    adapterType As Type
)
abstract ProcessAdapter :
        adapterType : Type -> unit
override ProcessAdapter :
        adapterType : Type -> unit
function ProcessAdapter(adapterType);
protected:
virtual void ProcessAdapter(
    Type^ adapterType
)

Parameters

adapterType
Type: SystemType
Type of the adapter to be instantiated.
See Also

Reference

AdapterLoaderT Class
ProcessAdapter Overload
GSF.Adapters Namespace


AdapterLoader(T).SaveSettings Method

Grid Solutions Framework AdapterLoaderTSaveSettings Method
Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T) Properties

Grid Solutions Framework AdapterLoaderT Properties

The AdapterLoaderT generic type exposes the following members.

Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located.
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters.
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters.
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory.
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime.
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process.
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process.
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters.
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters.
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution.
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored.
Public property | Name | Gets the unique identifier of the AdapterLoaderT.
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file.
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Status | Gets the descriptive status of the AdapterLoaderT.
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters.
Top
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterDirectory Property

Grid Solutions Framework AdapterLoaderTAdapterDirectory Property
Gets or sets the directory where Adapters are located.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AdapterDirectory { get; set; }
Public Property AdapterDirectory As String
    Get
    Set
member AdapterDirectory : string with get, set

function get_AdapterDirectory();
function set_AdapterDirectory(value);
public:
property String^ AdapterDirectory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
When an empty string is assigned to AdapterDirectory, Adapters are loaded from the directory where application is executing.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterFileExtension Property

Grid Solutions Framework AdapterLoaderTAdapterFileExtension Property
Gets or sets the file extension of the Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AdapterFileExtension { get; set; }
Public Property AdapterFileExtension As String
    Get
    Set
member AdapterFileExtension : string with get, set

function get_AdapterFileExtension();
function set_AdapterFileExtension(value);
public:
property String^ AdapterFileExtension {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being set is a null or empty string.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterFileFormat Property

Grid Solutions Framework AdapterLoaderTAdapterFileFormat Property
Gets or sets the file format of the Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdapterFileFormat AdapterFileFormat { get; set; }
Public Property AdapterFileFormat As AdapterFileFormat
    Get
    Set
member AdapterFileFormat : AdapterFileFormat with get, set

function get_AdapterFileFormat();
function set_AdapterFileFormat(value);
public:
property AdapterFileFormat AdapterFileFormat {
    AdapterFileFormat get ();
    void set (AdapterFileFormat value);
}

Property Value

Type: AdapterFileFormat
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Adapters Property

Grid Solutions Framework AdapterLoaderTAdapters Property
Gets a list of adapters loaded from the AdapterDirectory.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<T> Adapters { get; }
Public ReadOnly Property Adapters As IList(Of T)
    Get
member Adapters : IList<'T> with get

function get_Adapters();

public:
property IList<T>^ Adapters {
    IList<T>^ get ();
}

Property Value

Type: IList T
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterWatcher Property

Grid Solutions Framework AdapterLoaderTAdapterWatcher Property
Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected SafeFileWatcher AdapterWatcher { get; }
Protected ReadOnly Property AdapterWatcher As SafeFileWatcher
    Get
member AdapterWatcher : SafeFileWatcher with get

function get_AdapterWatcher();

protected:
property SafeFileWatcher^ AdapterWatcher {
    SafeFileWatcher^ get ();
}

Property Value

Type: SafeFileWatcher
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AllowableAdapterMemoryUsage Property

Grid Solutions Framework AdapterLoaderTAllowableAdapterMemoryUsage Property
Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double AllowableAdapterMemoryUsage { get; set; }
Public Property AllowableAdapterMemoryUsage As Double
    Get
    Set
member AllowableAdapterMemoryUsage : float with get, set

function get_AllowableAdapterMemoryUsage();
function set_AllowableAdapterMemoryUsage(value);
public:
property double AllowableAdapterMemoryUsage {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is zero or negative.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AllowableAdapterProcessorUsage Property

Grid Solutions Framework AdapterLoaderTAllowableAdapterProcessorUsage Property
Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double AllowableAdapterProcessorUsage { get; set; }
Public Property AllowableAdapterProcessorUsage As Double
    Get
    Set
member AllowableAdapterProcessorUsage : float with get, set

function get_AllowableAdapterProcessorUsage();
function set_AllowableAdapterProcessorUsage(value);
public:
property double AllowableAdapterProcessorUsage {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is zero or negative.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AllowableProcessMemoryUsage Property

Grid Solutions Framework AdapterLoaderTAllowableProcessMemoryUsage Property
Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double AllowableProcessMemoryUsage { get; set; }
Public Property AllowableProcessMemoryUsage As Double
    Get
    Set
member AllowableProcessMemoryUsage : float with get, set

function get_AllowableProcessMemoryUsage();
function set_AllowableProcessMemoryUsage(value);
public:
property double AllowableProcessMemoryUsage {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is zero or negative.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AllowableProcessProcessorUsage Property

Grid Solutions Framework AdapterLoaderTAllowableProcessProcessorUsage Property
Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double AllowableProcessProcessorUsage { get; set; }
Public Property AllowableProcessProcessorUsage As Double
    Get
    Set
member AllowableProcessProcessorUsage : float with get, set

function get_AllowableProcessProcessorUsage();
function set_AllowableProcessProcessorUsage(value);
public:
property double AllowableProcessProcessorUsage {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is zero or negative.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Enabled Property

Grid Solutions Framework AdapterLoaderTEnabled Property
Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).IsDisposed Property

Grid Solutions Framework AdapterLoaderTIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).IsolateAdapters Property

Grid Solutions Framework AdapterLoaderTIsolateAdapters Property
Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsolateAdapters { get; set; }
Public Property IsolateAdapters As Boolean
    Get
    Set
member IsolateAdapters : bool with get, set

function get_IsolateAdapters();
function set_IsolateAdapters(value);
public:
property bool IsolateAdapters {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).MonitorAdapters Property

Grid Solutions Framework AdapterLoaderTMonitorAdapters Property
Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool MonitorAdapters { get; set; }
Public Property MonitorAdapters As Boolean
    Get
    Set
member MonitorAdapters : bool with get, set

function get_MonitorAdapters();
function set_MonitorAdapters(value);
public:
property bool MonitorAdapters {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

Use AllowableProcessMemoryUsage, AllowableProcessProcessorUsage, AllowableAdapterMemoryUsage and AllowableAdapterProcessorUsage properties to configure how adapter resource utilization is to be monitored.

This option is ignored under Mono deployments.

See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Name Property

Grid Solutions Framework AdapterLoaderTName Property
Gets the unique identifier of the AdapterLoaderT.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OperationQueue Property

Grid Solutions Framework AdapterLoaderTOperationQueue Property
Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AsyncQueue<Object> OperationQueue { get; }
Protected ReadOnly Property OperationQueue As AsyncQueue(Of Object)
    Get
member OperationQueue : AsyncQueue<Object> with get

function get_OperationQueue();

protected:
property AsyncQueue<Object^>^ OperationQueue {
    AsyncQueue<Object^>^ get ();
}

Property Value

Type: AsyncQueue Object
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).PersistSettings Property

Grid Solutions Framework AdapterLoaderTPersistSettings Property
Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PersistSettings { get; set; }
Public Property PersistSettings As Boolean
    Get
    Set
abstract PersistSettings : bool with get, set
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).SettingsCategory Property

Grid Solutions Framework AdapterLoaderTSettingsCategory Property
Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SettingsCategory { get; set; }
Public Property SettingsCategory As String
    Get
    Set
abstract SettingsCategory : string with get, set
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Status Property

Grid Solutions Framework AdapterLoaderTStatus Property
Gets the descriptive status of the AdapterLoaderT.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).WatchForAdapters Property

Grid Solutions Framework AdapterLoaderTWatchForAdapters Property
Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool WatchForAdapters { get; set; }
Public Property WatchForAdapters As Boolean
    Get
    Set
member WatchForAdapters : bool with get, set

function get_WatchForAdapters();
function set_WatchForAdapters(value);
public:
property bool WatchForAdapters {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T) Events

Grid Solutions Framework AdapterLoaderT Events

The AdapterLoaderT generic type exposes the following members.

Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated.
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list.
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter.
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage.
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list.
Public event | Disposed | Occurs when the class has been disposed.
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters.
Top
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterCreated Event

Grid Solutions Framework AdapterLoaderTAdapterCreated Event
Occurs when a new adapter is found and instantiated.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T>> AdapterCreated
Public Event AdapterCreated As EventHandler(Of EventArgs(Of T))
member AdapterCreated : IEvent<EventHandler<EventArgs<'T>>,
    EventArgs<'T>>

function add_AdapterCreated(value);
function remove_AdapterCreated(value);
public:
 event EventHandler<EventArgs<T>^>^ AdapterCreated {
    void add (EventHandler<EventArgs<T>^>^ value);
    void remove (EventHandler<EventArgs<T>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
Remarks
Argument is the adapter that was created.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterLoaded Event

Grid Solutions Framework AdapterLoaderTAdapterLoaded Event
Occurs when a new adapter is loaded to the Adapters list.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T>> AdapterLoaded
Public Event AdapterLoaded As EventHandler(Of EventArgs(Of T))
member AdapterLoaded : IEvent<EventHandler<EventArgs<'T>>,
    EventArgs<'T>>

function add_AdapterLoaded(value);
function remove_AdapterLoaded(value);
public:
 event EventHandler<EventArgs<T>^>^ AdapterLoaded {
    void add (EventHandler<EventArgs<T>^>^ value);
    void remove (EventHandler<EventArgs<T>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
Remarks
Argument is the adapter that was loaded.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterLoadException Event

Grid Solutions Framework AdapterLoaderTAdapterLoadException Event
Occurs when an Exception is encountered when loading an adapter.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> AdapterLoadException
Public Event AdapterLoadException As EventHandler(Of EventArgs(Of Exception))
member AdapterLoadException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_AdapterLoadException(value);
function remove_AdapterLoadException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ AdapterLoadException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception encountered when loading the adapter.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterResourceUsageExceeded Event

Grid Solutions Framework AdapterLoaderTAdapterResourceUsageExceeded Event
Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T>> AdapterResourceUsageExceeded
Public Event AdapterResourceUsageExceeded As EventHandler(Of EventArgs(Of T))
member AdapterResourceUsageExceeded : IEvent<EventHandler<EventArgs<'T>>,
    EventArgs<'T>>

function add_AdapterResourceUsageExceeded(value);
function remove_AdapterResourceUsageExceeded(value);
public:
 event EventHandler<EventArgs<T>^>^ AdapterResourceUsageExceeded {
    void add (EventHandler<EventArgs<T>^>^ value);
    void remove (EventHandler<EventArgs<T>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).AdapterUnloaded Event

Grid Solutions Framework AdapterLoaderTAdapterUnloaded Event
Occurs when an existing adapter is unloaded from the Adapters list.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T>> AdapterUnloaded
Public Event AdapterUnloaded As EventHandler(Of EventArgs(Of T))
member AdapterUnloaded : IEvent<EventHandler<EventArgs<'T>>,
    EventArgs<'T>>

function add_AdapterUnloaded(value);
function remove_AdapterUnloaded(value);
public:
 event EventHandler<EventArgs<T>^>^ AdapterUnloaded {
    void add (EventHandler<EventArgs<T>^>^ value);
    void remove (EventHandler<EventArgs<T>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
Remarks
Argument is the adapter that was unloaded.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).Disposed Event

Grid Solutions Framework AdapterLoaderTDisposed Event
Occurs when the class has been disposed.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


AdapterLoader(T).OperationExecutionException Event

Grid Solutions Framework AdapterLoaderTOperationExecutionException Event
Occurs when an Exception is encountered while executing a queued operation on one the Adapters.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T, Exception>> OperationExecutionException
Public Event OperationExecutionException As EventHandler(Of EventArgs(Of T, Exception))
member OperationExecutionException : IEvent<EventHandler<EventArgs<'T, Exception>>,
    EventArgs<'T, Exception>>

function add_OperationExecutionException(value);
function remove_OperationExecutionException(value);
public:
 event EventHandler<EventArgs<T, Exception^>^>^ OperationExecutionException {
    void add (EventHandler<EventArgs<T, Exception^>^>^ value);
    void remove (EventHandler<EventArgs<T, Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T, Exception
Remarks
Argument1 is the adapter on which the operation was being executed.
Argument2 is the Exception encountered when executing an operation on the adapter.
See Also

Reference

AdapterLoaderT Class
GSF.Adapters Namespace


IAdapter Interface

Grid Solutions Framework IAdapter Interface
Defines an adapter that could execute in isolation in a separate AppDomain.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IAdapter : ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings
Public Interface IAdapter
    Inherits ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
type IAdapter =
    interface
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Adapters.IAdapter = function();
GSF.Adapters.IAdapter.createInterface('GSF.Adapters.IAdapter');
public interface class IAdapter : ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings

The IAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName.
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update.
Top
See Also

Reference

GSF.Adapters Namespace


IAdapter Methods

Grid Solutions Framework IAdapter Methods

The IAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter Properties

Grid Solutions Framework IAdapter Properties

The IAdapter type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName.
Top
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter.Domain Property

Grid Solutions Framework IAdapterDomain Property
Gets the AppDomain in which the IAdapter is executing.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
AppDomain Domain { get; }
ReadOnly Property Domain As AppDomain
    Get
abstract Domain : AppDomain with get

function get_Domain();

property AppDomain^ Domain {
    AppDomain^ get ();
}

Property Value

Type: AppDomain
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter.HostFile Property

Grid Solutions Framework IAdapterHostFile Property
Gets or sets the path to the file where the IAdapter is housed.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string HostFile { get; set; }
Property HostFile As String
    Get
    Set
abstract HostFile : string with get, set

function get_HostFile();
function set_HostFile(value);
property String^ HostFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter.MemoryUsage Property

Grid Solutions Framework IAdapterMemoryUsage Property
Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
double MemoryUsage { get; }
ReadOnly Property MemoryUsage As Double
    Get
abstract MemoryUsage : float with get

function get_MemoryUsage();

property double MemoryUsage {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter.ProcessorUsage Property

Grid Solutions Framework IAdapterProcessorUsage Property
Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
double ProcessorUsage { get; }
ReadOnly Property ProcessorUsage As Double
    Get
abstract ProcessorUsage : float with get

function get_ProcessorUsage();

property double ProcessorUsage {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter.TypeName Property

Grid Solutions Framework IAdapterTypeName Property
Gets or sets the text representation of the IAdapter's TypeName.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string TypeName { get; set; }
Property TypeName As String
    Get
    Set
abstract TypeName : string with get, set

function get_TypeName();
function set_TypeName(value);
property String^ TypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter Events

Grid Solutions Framework IAdapter Events

The IAdapter type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update.
Top
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter.ExecutionException Event

Grid Solutions Framework IAdapterExecutionException Event
Occurs when the IAdapter encounters an Exception during execution.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<string, Exception>> ExecutionException
Event ExecutionException As EventHandler(Of EventArgs(Of String, Exception))
abstract ExecutionException : IEvent<EventHandler<EventArgs<string, Exception>>,
    EventArgs<string, Exception>>

function add_ExecutionException(value);
function remove_ExecutionException(value);
 event EventHandler<EventArgs<String^, Exception^>^>^ ExecutionException {
    void add (EventHandler<EventArgs<String^, Exception^>^>^ value);
    void remove (EventHandler<EventArgs<String^, Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String, Exception
Remarks
Argument1 is the text that describes the activity that was being performed by the IAdapter.
Argument2 is the encountered Exception.
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


IAdapter.StatusUpdate Event

Grid Solutions Framework IAdapterStatusUpdate Event
Occurs when the IAdapter wants to provide a status update.

Namespace: GSF.Adapters
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<UpdateType, string>> StatusUpdate
Event StatusUpdate As EventHandler(Of EventArgs(Of UpdateType, String))
abstract StatusUpdate : IEvent<EventHandler<EventArgs<UpdateType, string>>,
    EventArgs<UpdateType, string>>

function add_StatusUpdate(value);
function remove_StatusUpdate(value);
 event EventHandler<EventArgs<UpdateType, String^>^>^ StatusUpdate {
    void add (EventHandler<EventArgs<UpdateType, String^>^>^ value);
    void remove (EventHandler<EventArgs<UpdateType, String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs UpdateType, String
Remarks
Argument1 is the UpdateType.
Argument2 is the update message.
See Also

Reference

IAdapter Interface
GSF.Adapters Namespace


GSF.ASN1 Namespace

Grid Solutions Framework GSF.ASN1 Namespace

[Missing <summary> documentation for "N:GSF.ASN1"]

Classes
 | Class | Description
Public class | CoderFactory |
Interfaces
 | Interface | Description
Public interface | IDecoder |
Public interface | IEncoder |


CoderFactory Class

Grid Solutions Framework CoderFactory Class

[Missing <summary> documentation for "T:GSF.ASN1.CoderFactory"]

Inheritance Hierarchy
SystemObject
GSF.ASN1CoderFactory

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CoderFactory
Public Class CoderFactory
type CoderFactory =  class end
GSF.ASN1.CoderFactory = function();

Type.createClass(
    'GSF.ASN1.CoderFactory');
public ref class CoderFactory

The CoderFactory type exposes the following members.

Constructors
 | Name | Description
Public method | CoderFactory | Initializes a new instance of the CoderFactory class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getInstance |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newDecoder |
Public method | newDecoder(String) |
Public method | newEncoder |
Public method | newEncoder(String) |
Public method | newPreparedElementData |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1 Namespace


CoderFactory Constructor

Grid Solutions Framework CoderFactory Constructor
Initializes a new instance of the CoderFactory class

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CoderFactory()
Public Sub New
new : unit -> CoderFactory
GSF.ASN1.CoderFactory = function();
public:
CoderFactory()
See Also

Reference

CoderFactory Class
GSF.ASN1 Namespace


CoderFactory Methods

Grid Solutions Framework CoderFactory Methods

The CoderFactory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getInstance |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | newDecoder |
Public method | newDecoder(String) |
Public method | newEncoder |
Public method | newEncoder(String) |
Public method | newPreparedElementData |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CoderFactory Class
GSF.ASN1 Namespace


CoderFactory.getInstance Method

Grid Solutions Framework CoderFactorygetInstance Method

[Missing <summary> documentation for "M:GSF.ASN1.CoderFactory.getInstance"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static CoderFactory getInstance()
Public Shared Function getInstance As CoderFactory
static member getInstance : unit -> CoderFactory

GSF.ASN1.CoderFactory.getInstance = function();
public:
static CoderFactory^ getInstance()

Return Value

Type: CoderFactory

[Missing <returns> documentation for "M:GSF.ASN1.CoderFactory.getInstance"]

See Also

Reference

CoderFactory Class
GSF.ASN1 Namespace


CoderFactory.newDecoder Method

Grid Solutions Framework CoderFactorynewDecoder Method
Overload List
 | Name | Description
Public method | newDecoder |
Public method | newDecoder(String) |
Top
See Also

Reference

CoderFactory Class
GSF.ASN1 Namespace


CoderFactory.newDecoder Method

Grid Solutions Framework CoderFactorynewDecoder Method

[Missing <summary> documentation for "M:GSF.ASN1.CoderFactory.newDecoder"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDecoder newDecoder()
Public Function newDecoder As IDecoder
member newDecoder : unit -> IDecoder

function newDecoder();
public:
IDecoder^ newDecoder()

Return Value

Type: IDecoder

[Missing <returns> documentation for "M:GSF.ASN1.CoderFactory.newDecoder"]

See Also

Reference

CoderFactory Class
newDecoder Overload
GSF.ASN1 Namespace


CoderFactory.newDecoder Method (String)

Grid Solutions Framework CoderFactorynewDecoder Method (String)

[Missing <summary> documentation for "M:GSF.ASN1.CoderFactory.newDecoder(System.String)"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDecoder newDecoder(
    string encodingSchema
)
Public Function newDecoder (
    encodingSchema As String
) As IDecoder
member newDecoder :
        encodingSchema : string -> IDecoder

function newDecoder(encodingSchema);
public:
IDecoder^ newDecoder(
    String^ encodingSchema
)

Parameters

encodingSchema
Type: SystemString

[Missing <param name="encodingSchema"/> documentation for "M:GSF.ASN1.CoderFactory.newDecoder(System.String)"]

Return Value

Type: IDecoder

[Missing <returns> documentation for "M:GSF.ASN1.CoderFactory.newDecoder(System.String)"]

See Also

Reference

CoderFactory Class
newDecoder Overload
GSF.ASN1 Namespace


CoderFactory.newEncoder Method

Grid Solutions Framework CoderFactorynewEncoder Method
Overload List
 | Name | Description
Public method | newEncoder |
Public method | newEncoder(String) |
Top
See Also

Reference

CoderFactory Class
GSF.ASN1 Namespace


CoderFactory.newEncoder Method

Grid Solutions Framework CoderFactorynewEncoder Method

[Missing <summary> documentation for "M:GSF.ASN1.CoderFactory.newEncoder"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEncoder newEncoder()
Public Function newEncoder As IEncoder
member newEncoder : unit -> IEncoder

function newEncoder();
public:
IEncoder^ newEncoder()

Return Value

Type: IEncoder

[Missing <returns> documentation for "M:GSF.ASN1.CoderFactory.newEncoder"]

See Also

Reference

CoderFactory Class
newEncoder Overload
GSF.ASN1 Namespace


CoderFactory.newEncoder Method (String)

Grid Solutions Framework CoderFactorynewEncoder Method (String)

[Missing <summary> documentation for "M:GSF.ASN1.CoderFactory.newEncoder(System.String)"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEncoder newEncoder(
    string encodingSchema
)
Public Function newEncoder (
    encodingSchema As String
) As IEncoder
member newEncoder :
        encodingSchema : string -> IEncoder

function newEncoder(encodingSchema);
public:
IEncoder^ newEncoder(
    String^ encodingSchema
)

Parameters

encodingSchema
Type: SystemString

[Missing <param name="encodingSchema"/> documentation for "M:GSF.ASN1.CoderFactory.newEncoder(System.String)"]

Return Value

Type: IEncoder

[Missing <returns> documentation for "M:GSF.ASN1.CoderFactory.newEncoder(System.String)"]

See Also

Reference

CoderFactory Class
newEncoder Overload
GSF.ASN1 Namespace


CoderFactory.newPreparedElementData Method

Grid Solutions Framework CoderFactorynewPreparedElementData Method

[Missing <summary> documentation for "M:GSF.ASN1.CoderFactory.newPreparedElementData(System.Type)"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IASN1PreparedElementData newPreparedElementData(
    Type typeInfo
)
Public Function newPreparedElementData (
    typeInfo As Type
) As IASN1PreparedElementData
member newPreparedElementData :
        typeInfo : Type -> IASN1PreparedElementData

function newPreparedElementData(typeInfo);
public:
IASN1PreparedElementData^ newPreparedElementData(
    Type^ typeInfo
)

Parameters

typeInfo
Type: SystemType

[Missing <param name="typeInfo"/> documentation for "M:GSF.ASN1.CoderFactory.newPreparedElementData(System.Type)"]

Return Value

Type: IASN1PreparedElementData

[Missing <returns> documentation for "M:GSF.ASN1.CoderFactory.newPreparedElementData(System.Type)"]

See Also

Reference

CoderFactory Class
GSF.ASN1 Namespace


IDecoder Interface

Grid Solutions Framework IDecoder Interface

[Missing <summary> documentation for "T:GSF.ASN1.IDecoder"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDecoder
Public Interface IDecoder
type IDecoder =  interface end
GSF.ASN1.IDecoder = function();
GSF.ASN1.IDecoder.createInterface('GSF.ASN1.IDecoder');
public interface class IDecoder

The IDecoder type exposes the following members.

Methods
 | Name | Description
Public method | decodeT |
Top
See Also

Reference

GSF.ASN1 Namespace


IDecoder Methods

Grid Solutions Framework IDecoder Methods

The IDecoder type exposes the following members.

Methods
 | Name | Description
Public method | decodeT |
Top
See Also

Reference

IDecoder Interface
GSF.ASN1 Namespace


IDecoder.decode(T) Method

Grid Solutions Framework IDecoderdecodeT Method

[Missing <summary> documentation for "M:GSF.ASN1.IDecoder.decode``1(System.IO.Stream)"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
T decode<T>(
    Stream stream
)

Function decode(Of T) (
    stream As Stream
) As T
abstract decode :
        stream : Stream -> 'T

JavaScript does not support generic types or methods.
generic<typename T>
T decode(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.IDecoder.decode``1(System.IO.Stream)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.IDecoder.decode``1(System.IO.Stream)"]

Return Value

Type: T

[Missing <returns> documentation for "M:GSF.ASN1.IDecoder.decode``1(System.IO.Stream)"]

See Also

Reference

IDecoder Interface
GSF.ASN1 Namespace


IEncoder Interface

Grid Solutions Framework IEncoder Interface

[Missing <summary> documentation for "T:GSF.ASN1.IEncoder"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IEncoder
Public Interface IEncoder
type IEncoder =  interface end
GSF.ASN1.IEncoder = function();
GSF.ASN1.IEncoder.createInterface('GSF.ASN1.IEncoder');
public interface class IEncoder

The IEncoder type exposes the following members.

Methods
 | Name | Description
Public method | encodeT |
Top
See Also

Reference

GSF.ASN1 Namespace


IEncoder Methods

Grid Solutions Framework IEncoder Methods

The IEncoder type exposes the following members.

Methods
 | Name | Description
Public method | encodeT |
Top
See Also

Reference

IEncoder Interface
GSF.ASN1 Namespace


IEncoder.encode(T) Method

Grid Solutions Framework IEncoderencodeT Method

[Missing <summary> documentation for "M:GSF.ASN1.IEncoder.encode``1(``0,System.IO.Stream)"]

Namespace: GSF.ASN1
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void encode<T>(
    T obj,
    Stream stream
)

Sub encode(Of T) (
    obj As T,
    stream As Stream
)
abstract encode :
        obj : 'T *
        stream : Stream -> unit

JavaScript does not support generic types or methods.
generic<typename T>
void encode(
    T obj,
    Stream^ stream
)

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.IEncoder.encode``1(``0,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.IEncoder.encode``1(``0,System.IO.Stream)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.IEncoder.encode``1(``0,System.IO.Stream)"]

See Also

Reference

IEncoder Interface
GSF.ASN1 Namespace


GSF.ASN1.Attributes Namespace

Grid Solutions Framework GSF.ASN1.Attributes Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Attributes"]

Classes
 | Class | Description
Public class | ASN1_MMSDataArray |
Public class | ASN1_MMSDataStructure |
Public class | ASN1Any |
Public class | ASN1BitString |
Public class | ASN1Boolean |
Public class | ASN1BoxedType |
Public class | ASN1Choice |
Public class | ASN1Element |
Public class | ASN1Enum |
Public class | ASN1EnumItem |
Public class | ASN1Integer |
Public class | ASN1Module |
Public class | ASN1Null |
Public class | ASN1ObjectIdentifier |
Public class | ASN1OctetString |
Public class | ASN1PreparedElement |
Public class | ASN1Real |
Public class | ASN1Sequence |
Public class | ASN1SequenceOf |
Public class | ASN1String |


ASN1_MMSDataArray Class

Grid Solutions Framework ASN1_MMSDataArray Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1_MMSDataArray"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1_MMSDataArray

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1_MMSDataArray : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1_MMSDataArray
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1_MMSDataArray =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1_MMSDataArray = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1_MMSDataArray',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1_MMSDataArray : public Attribute

The ASN1_MMSDataArray type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1_MMSDataArray | Initializes a new instance of the ASN1_MMSDataArray class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Depth |
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1_MMSDataArray Constructor

Grid Solutions Framework ASN1_MMSDataArray Constructor
Initializes a new instance of the ASN1_MMSDataArray class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1_MMSDataArray()
Public Sub New
new : unit -> ASN1_MMSDataArray
GSF.ASN1.Attributes.ASN1_MMSDataArray = function();
public:
ASN1_MMSDataArray()
See Also

Reference

ASN1_MMSDataArray Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataArray Fields

Grid Solutions Framework ASN1_MMSDataArray Fields

The ASN1_MMSDataArray type exposes the following members.

Fields
Name | Description
Depth |
Top
See Also

Reference

ASN1_MMSDataArray Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataArray.Depth Field

Grid Solutions Framework ASN1_MMSDataArrayDepth Field

[Missing <summary> documentation for "F:GSF.ASN1.Attributes.ASN1_MMSDataArray.Depth"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int Depth
Public Shared Depth As Integer
static val mutable Depth: int
var GSF.ASN1.Attributes.ASN1_MMSDataArray.Depth
public:
static int Depth

Field Value

Type: Int32
See Also

Reference

ASN1_MMSDataArray Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataArray Methods

Grid Solutions Framework ASN1_MMSDataArray Methods

The ASN1_MMSDataArray type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1_MMSDataArray Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataArray Properties

Grid Solutions Framework ASN1_MMSDataArray Properties

The ASN1_MMSDataArray type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1_MMSDataArray Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataArray.Name Property

Grid Solutions Framework ASN1_MMSDataArrayName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1_MMSDataArray.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1_MMSDataArray Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataStructure Class

Grid Solutions Framework ASN1_MMSDataStructure Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1_MMSDataStructure"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1_MMSDataStructure

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1_MMSDataStructure : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1_MMSDataStructure
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1_MMSDataStructure =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1_MMSDataStructure = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1_MMSDataStructure',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1_MMSDataStructure : public Attribute

The ASN1_MMSDataStructure type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1_MMSDataStructure | Initializes a new instance of the ASN1_MMSDataStructure class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Depth |
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1_MMSDataStructure Constructor

Grid Solutions Framework ASN1_MMSDataStructure Constructor
Initializes a new instance of the ASN1_MMSDataStructure class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1_MMSDataStructure()
Public Sub New
new : unit -> ASN1_MMSDataStructure
GSF.ASN1.Attributes.ASN1_MMSDataStructure = function();
public:
ASN1_MMSDataStructure()
See Also

Reference

ASN1_MMSDataStructure Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataStructure Fields

Grid Solutions Framework ASN1_MMSDataStructure Fields

The ASN1_MMSDataStructure type exposes the following members.

Fields
Name | Description
Depth |
Top
See Also

Reference

ASN1_MMSDataStructure Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataStructure.Depth Field

Grid Solutions Framework ASN1_MMSDataStructureDepth Field

[Missing <summary> documentation for "F:GSF.ASN1.Attributes.ASN1_MMSDataStructure.Depth"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int Depth
Public Shared Depth As Integer
static val mutable Depth: int
var GSF.ASN1.Attributes.ASN1_MMSDataStructure.Depth
public:
static int Depth

Field Value

Type: Int32
See Also

Reference

ASN1_MMSDataStructure Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataStructure Methods

Grid Solutions Framework ASN1_MMSDataStructure Methods

The ASN1_MMSDataStructure type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1_MMSDataStructure Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataStructure Properties

Grid Solutions Framework ASN1_MMSDataStructure Properties

The ASN1_MMSDataStructure type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1_MMSDataStructure Class
GSF.ASN1.Attributes Namespace


ASN1_MMSDataStructure.Name Property

Grid Solutions Framework ASN1_MMSDataStructureName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1_MMSDataStructure.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1_MMSDataStructure Class
GSF.ASN1.Attributes Namespace


ASN1Any Class

Grid Solutions Framework ASN1Any Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Any"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Any

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1Any : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1Any
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1Any =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Any = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Any',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1Any : public Attribute

The ASN1Any type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Any | Initializes a new instance of the ASN1Any class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Any Constructor

Grid Solutions Framework ASN1Any Constructor
Initializes a new instance of the ASN1Any class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Any()
Public Sub New
new : unit -> ASN1Any
GSF.ASN1.Attributes.ASN1Any = function();
public:
ASN1Any()
See Also

Reference

ASN1Any Class
GSF.ASN1.Attributes Namespace


ASN1Any Methods

Grid Solutions Framework ASN1Any Methods

The ASN1Any type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Any Class
GSF.ASN1.Attributes Namespace


ASN1Any Properties

Grid Solutions Framework ASN1Any Properties

The ASN1Any type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Any Class
GSF.ASN1.Attributes Namespace


ASN1Any.Name Property

Grid Solutions Framework ASN1AnyName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Any.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Any Class
GSF.ASN1.Attributes Namespace


ASN1BitString Class

Grid Solutions Framework ASN1BitString Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1BitString"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1BitString

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1BitString : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1BitString
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1BitString =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1BitString = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1BitString',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1BitString : public Attribute

The ASN1BitString type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1BitString | Initializes a new instance of the ASN1BitString class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1BitString Constructor

Grid Solutions Framework ASN1BitString Constructor
Initializes a new instance of the ASN1BitString class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BitString()
Public Sub New
new : unit -> ASN1BitString
GSF.ASN1.Attributes.ASN1BitString = function();
public:
ASN1BitString()
See Also

Reference

ASN1BitString Class
GSF.ASN1.Attributes Namespace


ASN1BitString Methods

Grid Solutions Framework ASN1BitString Methods

The ASN1BitString type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1BitString Class
GSF.ASN1.Attributes Namespace


ASN1BitString Properties

Grid Solutions Framework ASN1BitString Properties

The ASN1BitString type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1BitString Class
GSF.ASN1.Attributes Namespace


ASN1BitString.Name Property

Grid Solutions Framework ASN1BitStringName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1BitString.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1BitString Class
GSF.ASN1.Attributes Namespace


ASN1Boolean Class

Grid Solutions Framework ASN1Boolean Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Boolean"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Boolean

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1Boolean : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1Boolean
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1Boolean =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Boolean = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Boolean',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1Boolean : public Attribute

The ASN1Boolean type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Boolean | Initializes a new instance of the ASN1Boolean class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Boolean Constructor

Grid Solutions Framework ASN1Boolean Constructor
Initializes a new instance of the ASN1Boolean class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Boolean()
Public Sub New
new : unit -> ASN1Boolean
GSF.ASN1.Attributes.ASN1Boolean = function();
public:
ASN1Boolean()
See Also

Reference

ASN1Boolean Class
GSF.ASN1.Attributes Namespace


ASN1Boolean Methods

Grid Solutions Framework ASN1Boolean Methods

The ASN1Boolean type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Boolean Class
GSF.ASN1.Attributes Namespace


ASN1Boolean Properties

Grid Solutions Framework ASN1Boolean Properties

The ASN1Boolean type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Boolean Class
GSF.ASN1.Attributes Namespace


ASN1Boolean.Name Property

Grid Solutions Framework ASN1BooleanName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Boolean.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Boolean Class
GSF.ASN1.Attributes Namespace


ASN1BoxedType Class

Grid Solutions Framework ASN1BoxedType Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1BoxedType"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1BoxedType

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class ASN1BoxedType : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false)>
Public Class ASN1BoxedType
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)>]
type ASN1BoxedType =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1BoxedType = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1BoxedType',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class ASN1BoxedType : public Attribute

The ASN1BoxedType type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1BoxedType | Initializes a new instance of the ASN1BoxedType class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1BoxedType Constructor

Grid Solutions Framework ASN1BoxedType Constructor
Initializes a new instance of the ASN1BoxedType class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BoxedType()
Public Sub New
new : unit -> ASN1BoxedType
GSF.ASN1.Attributes.ASN1BoxedType = function();
public:
ASN1BoxedType()
See Also

Reference

ASN1BoxedType Class
GSF.ASN1.Attributes Namespace


ASN1BoxedType Methods

Grid Solutions Framework ASN1BoxedType Methods

The ASN1BoxedType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1BoxedType Class
GSF.ASN1.Attributes Namespace


ASN1BoxedType Properties

Grid Solutions Framework ASN1BoxedType Properties

The ASN1BoxedType type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1BoxedType Class
GSF.ASN1.Attributes Namespace


ASN1BoxedType.Name Property

Grid Solutions Framework ASN1BoxedTypeName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1BoxedType.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1BoxedType Class
GSF.ASN1.Attributes Namespace


ASN1Choice Class

Grid Solutions Framework ASN1Choice Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Choice"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Choice

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class ASN1Choice : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false)>
Public Class ASN1Choice
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)>]
type ASN1Choice =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Choice = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Choice',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class ASN1Choice : public Attribute

The ASN1Choice type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Choice | Initializes a new instance of the ASN1Choice class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Choice Constructor

Grid Solutions Framework ASN1Choice Constructor
Initializes a new instance of the ASN1Choice class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Choice()
Public Sub New
new : unit -> ASN1Choice
GSF.ASN1.Attributes.ASN1Choice = function();
public:
ASN1Choice()
See Also

Reference

ASN1Choice Class
GSF.ASN1.Attributes Namespace


ASN1Choice Methods

Grid Solutions Framework ASN1Choice Methods

The ASN1Choice type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Choice Class
GSF.ASN1.Attributes Namespace


ASN1Choice Properties

Grid Solutions Framework ASN1Choice Properties

The ASN1Choice type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Choice Class
GSF.ASN1.Attributes Namespace


ASN1Choice.Name Property

Grid Solutions Framework ASN1ChoiceName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Choice.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Choice Class
GSF.ASN1.Attributes Namespace


ASN1Element Class

Grid Solutions Framework ASN1Element Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Element"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Element

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1Element : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1Element
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1Element =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Element = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Element',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1Element : public Attribute

The ASN1Element type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Element | Initializes a new instance of the ASN1Element class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | HasDefaultValue |
Public property | HasTag |
Public property | IsImplicitTag |
Public property | IsOptional |
Public property | Name |
Public property | Tag |
Public property | TagClass |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Element Constructor

Grid Solutions Framework ASN1Element Constructor
Initializes a new instance of the ASN1Element class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Element()
Public Sub New
new : unit -> ASN1Element
GSF.ASN1.Attributes.ASN1Element = function();
public:
ASN1Element()
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element Methods

Grid Solutions Framework ASN1Element Methods

The ASN1Element type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element Properties

Grid Solutions Framework ASN1Element Properties

The ASN1Element type exposes the following members.

Properties
 | Name | Description
Public property | HasDefaultValue |
Public property | HasTag |
Public property | IsImplicitTag |
Public property | IsOptional |
Public property | Name |
Public property | Tag |
Public property | TagClass |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element.HasDefaultValue Property

Grid Solutions Framework ASN1ElementHasDefaultValue Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Element.HasDefaultValue"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasDefaultValue { get; set; }
Public Property HasDefaultValue As Boolean
    Get
    Set
member HasDefaultValue : bool with get, set

function get_HasDefaultValue();
function set_HasDefaultValue(value);
public:
property bool HasDefaultValue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element.HasTag Property

Grid Solutions Framework ASN1ElementHasTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Element.HasTag"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasTag { get; set; }
Public Property HasTag As Boolean
    Get
    Set
member HasTag : bool with get, set

function get_HasTag();
function set_HasTag(value);
public:
property bool HasTag {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element.IsImplicitTag Property

Grid Solutions Framework ASN1ElementIsImplicitTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Element.IsImplicitTag"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsImplicitTag { get; set; }
Public Property IsImplicitTag As Boolean
    Get
    Set
member IsImplicitTag : bool with get, set

function get_IsImplicitTag();
function set_IsImplicitTag(value);
public:
property bool IsImplicitTag {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element.IsOptional Property

Grid Solutions Framework ASN1ElementIsOptional Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Element.IsOptional"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsOptional { get; set; }
Public Property IsOptional As Boolean
    Get
    Set
member IsOptional : bool with get, set

function get_IsOptional();
function set_IsOptional(value);
public:
property bool IsOptional {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element.Name Property

Grid Solutions Framework ASN1ElementName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Element.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element.Tag Property

Grid Solutions Framework ASN1ElementTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Element.Tag"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Tag { get; set; }
Public Property Tag As Integer
    Get
    Set
member Tag : int with get, set

function get_Tag();
function set_Tag(value);
public:
property int Tag {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Element.TagClass Property

Grid Solutions Framework ASN1ElementTagClass Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Element.TagClass"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TagClass { get; set; }
Public Property TagClass As Integer
    Get
    Set
member TagClass : int with get, set

function get_TagClass();
function set_TagClass(value);
public:
property int TagClass {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ASN1Element Class
GSF.ASN1.Attributes Namespace


ASN1Enum Class

Grid Solutions Framework ASN1Enum Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Enum"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Enum

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class ASN1Enum : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false)>
Public Class ASN1Enum
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)>]
type ASN1Enum =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Enum = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Enum',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class ASN1Enum : public Attribute

The ASN1Enum type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Enum | Initializes a new instance of the ASN1Enum class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Enum Constructor

Grid Solutions Framework ASN1Enum Constructor
Initializes a new instance of the ASN1Enum class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Enum()
Public Sub New
new : unit -> ASN1Enum
GSF.ASN1.Attributes.ASN1Enum = function();
public:
ASN1Enum()
See Also

Reference

ASN1Enum Class
GSF.ASN1.Attributes Namespace


ASN1Enum Methods

Grid Solutions Framework ASN1Enum Methods

The ASN1Enum type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Enum Class
GSF.ASN1.Attributes Namespace


ASN1Enum Properties

Grid Solutions Framework ASN1Enum Properties

The ASN1Enum type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Enum Class
GSF.ASN1.Attributes Namespace


ASN1Enum.Name Property

Grid Solutions Framework ASN1EnumName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Enum.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Enum Class
GSF.ASN1.Attributes Namespace


ASN1EnumItem Class

Grid Solutions Framework ASN1EnumItem Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1EnumItem"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1EnumItem

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)]
public class ASN1EnumItem : Attribute
<AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple := false)>
Public Class ASN1EnumItem
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Field, AllowMultiple = false)>]
type ASN1EnumItem =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1EnumItem = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1EnumItem',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Field, AllowMultiple = false)]
public ref class ASN1EnumItem : public Attribute

The ASN1EnumItem type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1EnumItem | Initializes a new instance of the ASN1EnumItem class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | HasTag |
Public property | Name |
Public property | Tag |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1EnumItem Constructor

Grid Solutions Framework ASN1EnumItem Constructor
Initializes a new instance of the ASN1EnumItem class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1EnumItem()
Public Sub New
new : unit -> ASN1EnumItem
GSF.ASN1.Attributes.ASN1EnumItem = function();
public:
ASN1EnumItem()
See Also

Reference

ASN1EnumItem Class
GSF.ASN1.Attributes Namespace


ASN1EnumItem Methods

Grid Solutions Framework ASN1EnumItem Methods

The ASN1EnumItem type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1EnumItem Class
GSF.ASN1.Attributes Namespace


ASN1EnumItem Properties

Grid Solutions Framework ASN1EnumItem Properties

The ASN1EnumItem type exposes the following members.

Properties
 | Name | Description
Public property | HasTag |
Public property | Name |
Public property | Tag |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1EnumItem Class
GSF.ASN1.Attributes Namespace


ASN1EnumItem.HasTag Property

Grid Solutions Framework ASN1EnumItemHasTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1EnumItem.HasTag"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasTag { get; set; }
Public Property HasTag As Boolean
    Get
    Set
member HasTag : bool with get, set

function get_HasTag();
function set_HasTag(value);
public:
property bool HasTag {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1EnumItem Class
GSF.ASN1.Attributes Namespace


ASN1EnumItem.Name Property

Grid Solutions Framework ASN1EnumItemName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1EnumItem.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1EnumItem Class
GSF.ASN1.Attributes Namespace


ASN1EnumItem.Tag Property

Grid Solutions Framework ASN1EnumItemTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1EnumItem.Tag"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Tag { get; set; }
Public Property Tag As Integer
    Get
    Set
member Tag : int with get, set

function get_Tag();
function set_Tag(value);
public:
property int Tag {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ASN1EnumItem Class
GSF.ASN1.Attributes Namespace


ASN1Integer Class

Grid Solutions Framework ASN1Integer Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Integer"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Integer

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1Integer : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1Integer
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1Integer =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Integer = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Integer',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1Integer : public Attribute

The ASN1Integer type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Integer | Initializes a new instance of the ASN1Integer class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Integer Constructor

Grid Solutions Framework ASN1Integer Constructor
Initializes a new instance of the ASN1Integer class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Integer()
Public Sub New
new : unit -> ASN1Integer
GSF.ASN1.Attributes.ASN1Integer = function();
public:
ASN1Integer()
See Also

Reference

ASN1Integer Class
GSF.ASN1.Attributes Namespace


ASN1Integer Methods

Grid Solutions Framework ASN1Integer Methods

The ASN1Integer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Integer Class
GSF.ASN1.Attributes Namespace


ASN1Integer Properties

Grid Solutions Framework ASN1Integer Properties

The ASN1Integer type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Integer Class
GSF.ASN1.Attributes Namespace


ASN1Integer.Name Property

Grid Solutions Framework ASN1IntegerName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Integer.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Integer Class
GSF.ASN1.Attributes Namespace


ASN1Module Class

Grid Solutions Framework ASN1Module Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Module"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Module

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class ASN1Module : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false)>
Public Class ASN1Module
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)>]
type ASN1Module =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Module = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Module',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class ASN1Module : public Attribute

The ASN1Module type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Module | Initializes a new instance of the ASN1Module class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsImplicitTags |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Module Constructor

Grid Solutions Framework ASN1Module Constructor
Initializes a new instance of the ASN1Module class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Module()
Public Sub New
new : unit -> ASN1Module
GSF.ASN1.Attributes.ASN1Module = function();
public:
ASN1Module()
See Also

Reference

ASN1Module Class
GSF.ASN1.Attributes Namespace


ASN1Module Methods

Grid Solutions Framework ASN1Module Methods

The ASN1Module type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Module Class
GSF.ASN1.Attributes Namespace


ASN1Module Properties

Grid Solutions Framework ASN1Module Properties

The ASN1Module type exposes the following members.

Properties
 | Name | Description
Public property | IsImplicitTags |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Module Class
GSF.ASN1.Attributes Namespace


ASN1Module.IsImplicitTags Property

Grid Solutions Framework ASN1ModuleIsImplicitTags Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Module.IsImplicitTags"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsImplicitTags { get; set; }
Public Property IsImplicitTags As Boolean
    Get
    Set
member IsImplicitTags : bool with get, set

function get_IsImplicitTags();
function set_IsImplicitTags(value);
public:
property bool IsImplicitTags {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1Module Class
GSF.ASN1.Attributes Namespace


ASN1Module.Name Property

Grid Solutions Framework ASN1ModuleName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Module.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Module Class
GSF.ASN1.Attributes Namespace


ASN1Null Class

Grid Solutions Framework ASN1Null Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Null"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Null

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Property, AllowMultiple = false)]
public class ASN1Null : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1Null
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Property, AllowMultiple = false)>]
type ASN1Null =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Null = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Null',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1Null : public Attribute

The ASN1Null type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Null | Initializes a new instance of the ASN1Null class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Null Constructor

Grid Solutions Framework ASN1Null Constructor
Initializes a new instance of the ASN1Null class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Null()
Public Sub New
new : unit -> ASN1Null
GSF.ASN1.Attributes.ASN1Null = function();
public:
ASN1Null()
See Also

Reference

ASN1Null Class
GSF.ASN1.Attributes Namespace


ASN1Null Methods

Grid Solutions Framework ASN1Null Methods

The ASN1Null type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Null Class
GSF.ASN1.Attributes Namespace


ASN1Null Properties

Grid Solutions Framework ASN1Null Properties

The ASN1Null type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Null Class
GSF.ASN1.Attributes Namespace


ASN1Null.Name Property

Grid Solutions Framework ASN1NullName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Null.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Null Class
GSF.ASN1.Attributes Namespace


ASN1ObjectIdentifier Class

Grid Solutions Framework ASN1ObjectIdentifier Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1ObjectIdentifier"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1ObjectIdentifier

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1ObjectIdentifier : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1ObjectIdentifier
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1ObjectIdentifier =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1ObjectIdentifier = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1ObjectIdentifier',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1ObjectIdentifier : public Attribute

The ASN1ObjectIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1ObjectIdentifier | Initializes a new instance of the ASN1ObjectIdentifier class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1ObjectIdentifier Constructor

Grid Solutions Framework ASN1ObjectIdentifier Constructor
Initializes a new instance of the ASN1ObjectIdentifier class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ObjectIdentifier()
Public Sub New
new : unit -> ASN1ObjectIdentifier
GSF.ASN1.Attributes.ASN1ObjectIdentifier = function();
public:
ASN1ObjectIdentifier()
See Also

Reference

ASN1ObjectIdentifier Class
GSF.ASN1.Attributes Namespace


ASN1ObjectIdentifier Methods

Grid Solutions Framework ASN1ObjectIdentifier Methods

The ASN1ObjectIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1ObjectIdentifier Class
GSF.ASN1.Attributes Namespace


ASN1ObjectIdentifier Properties

Grid Solutions Framework ASN1ObjectIdentifier Properties

The ASN1ObjectIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1ObjectIdentifier Class
GSF.ASN1.Attributes Namespace


ASN1ObjectIdentifier.Name Property

Grid Solutions Framework ASN1ObjectIdentifierName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1ObjectIdentifier.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1ObjectIdentifier Class
GSF.ASN1.Attributes Namespace


ASN1OctetString Class

Grid Solutions Framework ASN1OctetString Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1OctetString"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1OctetString

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1OctetString : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1OctetString
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1OctetString =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1OctetString = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1OctetString',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1OctetString : public Attribute

The ASN1OctetString type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1OctetString | Initializes a new instance of the ASN1OctetString class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1OctetString Constructor

Grid Solutions Framework ASN1OctetString Constructor
Initializes a new instance of the ASN1OctetString class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1OctetString()
Public Sub New
new : unit -> ASN1OctetString
GSF.ASN1.Attributes.ASN1OctetString = function();
public:
ASN1OctetString()
See Also

Reference

ASN1OctetString Class
GSF.ASN1.Attributes Namespace


ASN1OctetString Methods

Grid Solutions Framework ASN1OctetString Methods

The ASN1OctetString type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1OctetString Class
GSF.ASN1.Attributes Namespace


ASN1OctetString Properties

Grid Solutions Framework ASN1OctetString Properties

The ASN1OctetString type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1OctetString Class
GSF.ASN1.Attributes Namespace


ASN1OctetString.Name Property

Grid Solutions Framework ASN1OctetStringName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1OctetString.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1OctetString Class
GSF.ASN1.Attributes Namespace


ASN1PreparedElement Class

Grid Solutions Framework ASN1PreparedElement Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1PreparedElement"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1PreparedElement

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class ASN1PreparedElement : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false)>
Public Class ASN1PreparedElement
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)>]
type ASN1PreparedElement =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1PreparedElement = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1PreparedElement',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class ASN1PreparedElement : public Attribute

The ASN1PreparedElement type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1PreparedElement | Initializes a new instance of the ASN1PreparedElement class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1PreparedElement Constructor

Grid Solutions Framework ASN1PreparedElement Constructor
Initializes a new instance of the ASN1PreparedElement class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1PreparedElement()
Public Sub New
new : unit -> ASN1PreparedElement
GSF.ASN1.Attributes.ASN1PreparedElement = function();
public:
ASN1PreparedElement()
See Also

Reference

ASN1PreparedElement Class
GSF.ASN1.Attributes Namespace


ASN1PreparedElement Methods

Grid Solutions Framework ASN1PreparedElement Methods

The ASN1PreparedElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1PreparedElement Class
GSF.ASN1.Attributes Namespace


ASN1PreparedElement Properties

Grid Solutions Framework ASN1PreparedElement Properties

The ASN1PreparedElement type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1PreparedElement Class
GSF.ASN1.Attributes Namespace


ASN1Real Class

Grid Solutions Framework ASN1Real Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Real"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Real

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1Real : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1Real
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1Real =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Real = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Real',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1Real : public Attribute

The ASN1Real type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Real | Initializes a new instance of the ASN1Real class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Real Constructor

Grid Solutions Framework ASN1Real Constructor
Initializes a new instance of the ASN1Real class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Real()
Public Sub New
new : unit -> ASN1Real
GSF.ASN1.Attributes.ASN1Real = function();
public:
ASN1Real()
See Also

Reference

ASN1Real Class
GSF.ASN1.Attributes Namespace


ASN1Real Methods

Grid Solutions Framework ASN1Real Methods

The ASN1Real type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Real Class
GSF.ASN1.Attributes Namespace


ASN1Real Properties

Grid Solutions Framework ASN1Real Properties

The ASN1Real type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Real Class
GSF.ASN1.Attributes Namespace


ASN1Real.Name Property

Grid Solutions Framework ASN1RealName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Real.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Real Class
GSF.ASN1.Attributes Namespace


ASN1Sequence Class

Grid Solutions Framework ASN1Sequence Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1Sequence"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1Sequence

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class ASN1Sequence : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false)>
Public Class ASN1Sequence
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)>]
type ASN1Sequence =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1Sequence = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1Sequence',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class ASN1Sequence : public Attribute

The ASN1Sequence type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Sequence | Initializes a new instance of the ASN1Sequence class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsSet |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1Sequence Constructor

Grid Solutions Framework ASN1Sequence Constructor
Initializes a new instance of the ASN1Sequence class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Sequence()
Public Sub New
new : unit -> ASN1Sequence
GSF.ASN1.Attributes.ASN1Sequence = function();
public:
ASN1Sequence()
See Also

Reference

ASN1Sequence Class
GSF.ASN1.Attributes Namespace


ASN1Sequence Methods

Grid Solutions Framework ASN1Sequence Methods

The ASN1Sequence type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Sequence Class
GSF.ASN1.Attributes Namespace


ASN1Sequence Properties

Grid Solutions Framework ASN1Sequence Properties

The ASN1Sequence type exposes the following members.

Properties
 | Name | Description
Public property | IsSet |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1Sequence Class
GSF.ASN1.Attributes Namespace


ASN1Sequence.IsSet Property

Grid Solutions Framework ASN1SequenceIsSet Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Sequence.IsSet"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSet { get; set; }
Public Property IsSet As Boolean
    Get
    Set
member IsSet : bool with get, set

function get_IsSet();
function set_IsSet(value);
public:
property bool IsSet {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1Sequence Class
GSF.ASN1.Attributes Namespace


ASN1Sequence.Name Property

Grid Solutions Framework ASN1SequenceName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1Sequence.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1Sequence Class
GSF.ASN1.Attributes Namespace


ASN1SequenceOf Class

Grid Solutions Framework ASN1SequenceOf Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1SequenceOf"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1SequenceOf

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1SequenceOf : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1SequenceOf
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1SequenceOf =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1SequenceOf = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1SequenceOf',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1SequenceOf : public Attribute

The ASN1SequenceOf type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1SequenceOf | Initializes a new instance of the ASN1SequenceOf class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsSetOf |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1SequenceOf Constructor

Grid Solutions Framework ASN1SequenceOf Constructor
Initializes a new instance of the ASN1SequenceOf class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SequenceOf()
Public Sub New
new : unit -> ASN1SequenceOf
GSF.ASN1.Attributes.ASN1SequenceOf = function();
public:
ASN1SequenceOf()
See Also

Reference

ASN1SequenceOf Class
GSF.ASN1.Attributes Namespace


ASN1SequenceOf Methods

Grid Solutions Framework ASN1SequenceOf Methods

The ASN1SequenceOf type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1SequenceOf Class
GSF.ASN1.Attributes Namespace


ASN1SequenceOf Properties

Grid Solutions Framework ASN1SequenceOf Properties

The ASN1SequenceOf type exposes the following members.

Properties
 | Name | Description
Public property | IsSetOf |
Public property | Name |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1SequenceOf Class
GSF.ASN1.Attributes Namespace


ASN1SequenceOf.IsSetOf Property

Grid Solutions Framework ASN1SequenceOfIsSetOf Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1SequenceOf.IsSetOf"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSetOf { get; set; }
Public Property IsSetOf As Boolean
    Get
    Set
member IsSetOf : bool with get, set

function get_IsSetOf();
function set_IsSetOf(value);
public:
property bool IsSetOf {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1SequenceOf Class
GSF.ASN1.Attributes Namespace


ASN1SequenceOf.Name Property

Grid Solutions Framework ASN1SequenceOfName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1SequenceOf.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1SequenceOf Class
GSF.ASN1.Attributes Namespace


ASN1String Class

Grid Solutions Framework ASN1String Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.ASN1String"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.AttributesASN1String

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1String : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1String
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1String =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.ASN1String = function();

Type.createClass(
    'GSF.ASN1.Attributes.ASN1String',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1String : public Attribute

The ASN1String type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1String | Initializes a new instance of the ASN1String class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsUCS |
Public property | Name |
Public property | StringType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes Namespace


ASN1String Constructor

Grid Solutions Framework ASN1String Constructor
Initializes a new instance of the ASN1String class

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1String()
Public Sub New
new : unit -> ASN1String
GSF.ASN1.Attributes.ASN1String = function();
public:
ASN1String()
See Also

Reference

ASN1String Class
GSF.ASN1.Attributes Namespace


ASN1String Methods

Grid Solutions Framework ASN1String Methods

The ASN1String type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1String Class
GSF.ASN1.Attributes Namespace


ASN1String Properties

Grid Solutions Framework ASN1String Properties

The ASN1String type exposes the following members.

Properties
 | Name | Description
Public property | IsUCS |
Public property | Name |
Public property | StringType |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1String Class
GSF.ASN1.Attributes Namespace


ASN1String.IsUCS Property

Grid Solutions Framework ASN1StringIsUCS Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1String.IsUCS"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsUCS { get; set; }
Public Property IsUCS As Boolean
    Get
    Set
member IsUCS : bool with get, set

function get_IsUCS();
function set_IsUCS(value);
public:
property bool IsUCS {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ASN1String Class
GSF.ASN1.Attributes Namespace


ASN1String.Name Property

Grid Solutions Framework ASN1StringName Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1String.Name"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1String Class
GSF.ASN1.Attributes Namespace


ASN1String.StringType Property

Grid Solutions Framework ASN1StringStringType Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.ASN1String.StringType"]

Namespace: GSF.ASN1.Attributes
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int StringType { get; set; }
Public Property StringType As Integer
    Get
    Set
member StringType : int with get, set

function get_StringType();
function set_StringType(value);
public:
property int StringType {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ASN1String Class
GSF.ASN1.Attributes Namespace


GSF.ASN1.Attributes.Constraints Namespace

Grid Solutions Framework GSF.ASN1.Attributes.Constraints Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Attributes.Constraints"]

Classes
 | Class | Description
Public class | ASN1PatternConstraint |
Public class | ASN1SignedNumberConstraint |
Public class | ASN1SizeConstraint |
Public class | ASN1ValueRangeConstraint |


ASN1PatternConstraint Class

Grid Solutions Framework ASN1PatternConstraint Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.Constraints.ASN1PatternConstraint"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.Attributes.ConstraintsASN1PatternConstraint

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1PatternConstraint : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1PatternConstraint
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1PatternConstraint =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.Constraints.ASN1PatternConstraint = function();

Type.createClass(
    'GSF.ASN1.Attributes.Constraints.ASN1PatternConstraint',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1PatternConstraint : public Attribute

The ASN1PatternConstraint type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1PatternConstraint | Initializes a new instance of the ASN1PatternConstraint class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Pattern |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes.Constraints Namespace


ASN1PatternConstraint Constructor

Grid Solutions Framework ASN1PatternConstraint Constructor
Initializes a new instance of the ASN1PatternConstraint class

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1PatternConstraint()
Public Sub New
new : unit -> ASN1PatternConstraint
GSF.ASN1.Attributes.Constraints.ASN1PatternConstraint = function();
public:
ASN1PatternConstraint()
See Also

Reference

ASN1PatternConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1PatternConstraint Methods

Grid Solutions Framework ASN1PatternConstraint Methods

The ASN1PatternConstraint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1PatternConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1PatternConstraint Properties

Grid Solutions Framework ASN1PatternConstraint Properties

The ASN1PatternConstraint type exposes the following members.

Properties
 | Name | Description
Public property | Pattern |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1PatternConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1PatternConstraint.Pattern Property

Grid Solutions Framework ASN1PatternConstraintPattern Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.Constraints.ASN1PatternConstraint.Pattern"]

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Pattern { get; set; }
Public Property Pattern As String
    Get
    Set
member Pattern : string with get, set

function get_Pattern();
function set_Pattern(value);
public:
property String^ Pattern {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ASN1PatternConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1SignedNumberConstraint Class

Grid Solutions Framework ASN1SignedNumberConstraint Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.Constraints.ASN1SignedNumberConstraint"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.Attributes.ConstraintsASN1SignedNumberConstraint

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1SignedNumberConstraint : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1SignedNumberConstraint
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1SignedNumberConstraint =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.Constraints.ASN1SignedNumberConstraint = function();

Type.createClass(
    'GSF.ASN1.Attributes.Constraints.ASN1SignedNumberConstraint',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1SignedNumberConstraint : public Attribute

The ASN1SignedNumberConstraint type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1SignedNumberConstraint | Initializes a new instance of the ASN1SignedNumberConstraint class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes.Constraints Namespace


ASN1SignedNumberConstraint Constructor

Grid Solutions Framework ASN1SignedNumberConstraint Constructor
Initializes a new instance of the ASN1SignedNumberConstraint class

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SignedNumberConstraint()
Public Sub New
new : unit -> ASN1SignedNumberConstraint
GSF.ASN1.Attributes.Constraints.ASN1SignedNumberConstraint = function();
public:
ASN1SignedNumberConstraint()
See Also

Reference

ASN1SignedNumberConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1SignedNumberConstraint Methods

Grid Solutions Framework ASN1SignedNumberConstraint Methods

The ASN1SignedNumberConstraint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1SignedNumberConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1SignedNumberConstraint Properties

Grid Solutions Framework ASN1SignedNumberConstraint Properties

The ASN1SignedNumberConstraint type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1SignedNumberConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1SizeConstraint Class

Grid Solutions Framework ASN1SizeConstraint Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.Constraints.ASN1SizeConstraint"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.Attributes.ConstraintsASN1SizeConstraint

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1SizeConstraint : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1SizeConstraint
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1SizeConstraint =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.Constraints.ASN1SizeConstraint = function();

Type.createClass(
    'GSF.ASN1.Attributes.Constraints.ASN1SizeConstraint',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1SizeConstraint : public Attribute

The ASN1SizeConstraint type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1SizeConstraint | Initializes a new instance of the ASN1SizeConstraint class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Max |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes.Constraints Namespace


ASN1SizeConstraint Constructor

Grid Solutions Framework ASN1SizeConstraint Constructor
Initializes a new instance of the ASN1SizeConstraint class

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SizeConstraint()
Public Sub New
new : unit -> ASN1SizeConstraint
GSF.ASN1.Attributes.Constraints.ASN1SizeConstraint = function();
public:
ASN1SizeConstraint()
See Also

Reference

ASN1SizeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1SizeConstraint Methods

Grid Solutions Framework ASN1SizeConstraint Methods

The ASN1SizeConstraint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1SizeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1SizeConstraint Properties

Grid Solutions Framework ASN1SizeConstraint Properties

The ASN1SizeConstraint type exposes the following members.

Properties
 | Name | Description
Public property | Max |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1SizeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1SizeConstraint.Max Property

Grid Solutions Framework ASN1SizeConstraintMax Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.Constraints.ASN1SizeConstraint.Max"]

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Max { get; set; }
Public Property Max As Long
    Get
    Set
member Max : int64 with get, set

function get_Max();
function set_Max(value);
public:
property long long Max {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ASN1SizeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1ValueRangeConstraint Class

Grid Solutions Framework ASN1ValueRangeConstraint Class

[Missing <summary> documentation for "T:GSF.ASN1.Attributes.Constraints.ASN1ValueRangeConstraint"]

Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ASN1.Attributes.ConstraintsASN1ValueRangeConstraint

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)]
public class ASN1ValueRangeConstraint : Attribute
<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple := false)>
Public Class ASN1ValueRangeConstraint
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Property, AllowMultiple = false)>]
type ASN1ValueRangeConstraint =
    class
        inherit Attribute
    end
GSF.ASN1.Attributes.Constraints.ASN1ValueRangeConstraint = function();

Type.createClass(
    'GSF.ASN1.Attributes.Constraints.ASN1ValueRangeConstraint',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property, AllowMultiple = false)]
public ref class ASN1ValueRangeConstraint : public Attribute

The ASN1ValueRangeConstraint type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1ValueRangeConstraint | Initializes a new instance of the ASN1ValueRangeConstraint class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Max |
Public property | Min |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.ASN1.Attributes.Constraints Namespace


ASN1ValueRangeConstraint Constructor

Grid Solutions Framework ASN1ValueRangeConstraint Constructor
Initializes a new instance of the ASN1ValueRangeConstraint class

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ValueRangeConstraint()
Public Sub New
new : unit -> ASN1ValueRangeConstraint
GSF.ASN1.Attributes.Constraints.ASN1ValueRangeConstraint = function();
public:
ASN1ValueRangeConstraint()
See Also

Reference

ASN1ValueRangeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1ValueRangeConstraint Methods

Grid Solutions Framework ASN1ValueRangeConstraint Methods

The ASN1ValueRangeConstraint type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1ValueRangeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1ValueRangeConstraint Properties

Grid Solutions Framework ASN1ValueRangeConstraint Properties

The ASN1ValueRangeConstraint type exposes the following members.

Properties
 | Name | Description
Public property | Max |
Public property | Min |
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ASN1ValueRangeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1ValueRangeConstraint.Max Property

Grid Solutions Framework ASN1ValueRangeConstraintMax Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.Constraints.ASN1ValueRangeConstraint.Max"]

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Max { get; set; }
Public Property Max As Long
    Get
    Set
member Max : int64 with get, set

function get_Max();
function set_Max(value);
public:
property long long Max {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ASN1ValueRangeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


ASN1ValueRangeConstraint.Min Property

Grid Solutions Framework ASN1ValueRangeConstraintMin Property

[Missing <summary> documentation for "P:GSF.ASN1.Attributes.Constraints.ASN1ValueRangeConstraint.Min"]

Namespace: GSF.ASN1.Attributes.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Min { get; set; }
Public Property Min As Long
    Get
    Set
member Min : int64 with get, set

function get_Min();
function set_Min(value);
public:
property long long Min {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ASN1ValueRangeConstraint Class
GSF.ASN1.Attributes.Constraints Namespace


GSF.ASN1.Coders Namespace

Grid Solutions Framework GSF.ASN1.Coders Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Coders"]

Classes
 | Class | Description
Public class | ASN1PreparedElementData |
Public class | CoderUtils |
Public class | DecodedObjectT |
Public class | Decoder |
Public class | ElementInfo |
Public class | Encoder |
Structures
 | Structure | Description
Public structure | ElementType |
Public structure | TagClasses |
Public structure | UniversalTags |
Interfaces
 | Interface | Description
Public interface | IASN1PreparedElement |
Public interface | IASN1PreparedElementData |
Public interface | IASN1TypesDecoder |
Public interface | IASN1TypesEncoder |


ASN1PreparedElementData Class

Grid Solutions Framework ASN1PreparedElementData Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.ASN1PreparedElementData"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersASN1PreparedElementData

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1PreparedElementData : IASN1PreparedElementData
Public Class ASN1PreparedElementData
    Implements IASN1PreparedElementData
type ASN1PreparedElementData =
    class
        interface IASN1PreparedElementData
    end
GSF.ASN1.Coders.ASN1PreparedElementData = function();

Type.createClass(
    'GSF.ASN1.Coders.ASN1PreparedElementData',
    null,
    GSF.ASN1.Coders.IASN1PreparedElementData);
public ref class ASN1PreparedElementData : IASN1PreparedElementData

The ASN1PreparedElementData type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1PreparedElementData(Type) | Initializes a new instance of the ASN1PreparedElementData class
Public method | ASN1PreparedElementData(Type, PropertyInfo) | Initializes a new instance of the ASN1PreparedElementData class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getProperty |
Public method | getPropertyMetadata |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasASN1ElementInfo |
Public method | hasConstraint |
Public method | invokeDoSelectMethod |
Public method | invokeIsSelectedMethod |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setValueField |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ASN1ElementInfo |
Public property | Constraint |
Public property | IsPresentMethod |
Public property | Properties |
Public property | TypeMetadata |
Public property | ValueMetadata |
Public property | ValueProperty |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


ASN1PreparedElementData Constructor

Grid Solutions Framework ASN1PreparedElementData Constructor
Overload List
 | Name | Description
Public method | ASN1PreparedElementData(Type) | Initializes a new instance of the ASN1PreparedElementData class
Public method | ASN1PreparedElementData(Type, PropertyInfo) | Initializes a new instance of the ASN1PreparedElementData class
Top
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData Constructor (Type)

Grid Solutions Framework ASN1PreparedElementData Constructor (Type)
Initializes a new instance of the ASN1PreparedElementData class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1PreparedElementData(
    Type objectClass
)
Public Sub New (
    objectClass As Type
)
new :
        objectClass : Type -> ASN1PreparedElementData
GSF.ASN1.Coders.ASN1PreparedElementData = function(objectClass);
public:
ASN1PreparedElementData(
    Type^ objectClass
)

Parameters

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.#ctor(System.Type)"]

See Also

Reference

ASN1PreparedElementData Class
ASN1PreparedElementData Overload
GSF.ASN1.Coders Namespace


ASN1PreparedElementData Constructor (Type, PropertyInfo)

Grid Solutions Framework ASN1PreparedElementData Constructor (Type, PropertyInfo)
Initializes a new instance of the ASN1PreparedElementData class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1PreparedElementData(
    Type parentClass,
    PropertyInfo field
)
Public Sub New (
    parentClass As Type,
    field As PropertyInfo
)
new :
        parentClass : Type *
        field : PropertyInfo -> ASN1PreparedElementData
GSF.ASN1.Coders.ASN1PreparedElementData = function(parentClass, field);
public:
ASN1PreparedElementData(
    Type^ parentClass,
    PropertyInfo^ field
)

Parameters

parentClass
Type: SystemType

[Missing <param name="parentClass"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.#ctor(System.Type,System.Reflection.PropertyInfo)"]

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.#ctor(System.Type,System.Reflection.PropertyInfo)"]

See Also

Reference

ASN1PreparedElementData Class
ASN1PreparedElementData Overload
GSF.ASN1.Coders Namespace


ASN1PreparedElementData Methods

Grid Solutions Framework ASN1PreparedElementData Methods

The ASN1PreparedElementData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getProperty |
Public method | getPropertyMetadata |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasASN1ElementInfo |
Public method | hasConstraint |
Public method | invokeDoSelectMethod |
Public method | invokeIsSelectedMethod |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setValueField |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.getProperty Method

Grid Solutions Framework ASN1PreparedElementDatagetProperty Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.getProperty(System.Int32)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PropertyInfo getProperty(
    int index
)
Public Function getProperty (
    index As Integer
) As PropertyInfo
abstract getProperty :
        index : int -> PropertyInfo
override getProperty :
        index : int -> PropertyInfo
function getProperty(index);
public:
virtual PropertyInfo^ getProperty(
    int index
) sealed

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.getProperty(System.Int32)"]

Return Value

Type: PropertyInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.getProperty(System.Int32)"]

Implements

IASN1PreparedElementDatagetProperty(Int32)
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.getPropertyMetadata Method

Grid Solutions Framework ASN1PreparedElementDatagetPropertyMetadata Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.getPropertyMetadata(System.Int32)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1PreparedElementData getPropertyMetadata(
    int index
)
Public Function getPropertyMetadata (
    index As Integer
) As ASN1PreparedElementData
abstract getPropertyMetadata :
        index : int -> ASN1PreparedElementData
override getPropertyMetadata :
        index : int -> ASN1PreparedElementData
function getPropertyMetadata(index);
public:
virtual ASN1PreparedElementData^ getPropertyMetadata(
    int index
) sealed

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.getPropertyMetadata(System.Int32)"]

Return Value

Type: ASN1PreparedElementData

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.getPropertyMetadata(System.Int32)"]

Implements

IASN1PreparedElementDatagetPropertyMetadata(Int32)
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.hasASN1ElementInfo Method

Grid Solutions Framework ASN1PreparedElementDatahasASN1ElementInfo Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.hasASN1ElementInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool hasASN1ElementInfo()
Public Function hasASN1ElementInfo As Boolean
abstract hasASN1ElementInfo : unit -> bool
override hasASN1ElementInfo : unit -> bool
function hasASN1ElementInfo();
public:
virtual bool hasASN1ElementInfo() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.hasASN1ElementInfo"]

Implements

IASN1PreparedElementDatahasASN1ElementInfo
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.hasConstraint Method

Grid Solutions Framework ASN1PreparedElementDatahasConstraint Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.hasConstraint"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool hasConstraint()
Public Function hasConstraint As Boolean
abstract hasConstraint : unit -> bool
override hasConstraint : unit -> bool
function hasConstraint();
public:
virtual bool hasConstraint() sealed

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.hasConstraint"]

Implements

IASN1PreparedElementDatahasConstraint
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.invokeDoSelectMethod Method

Grid Solutions Framework ASN1PreparedElementDatainvokeDoSelectMethod Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object invokeDoSelectMethod(
    Object obj,
    Object param
)
Public Function invokeDoSelectMethod (
    obj As Object,
    param As Object
) As Object
abstract invokeDoSelectMethod :
        obj : Object *
        param : Object -> Object
override invokeDoSelectMethod :
        obj : Object *
        param : Object -> Object
function invokeDoSelectMethod(obj, param);
public:
virtual Object^ invokeDoSelectMethod(
    Object^ obj,
    Object^ param
) sealed

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

Implements

IASN1PreparedElementDatainvokeDoSelectMethod(Object, Object)
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.invokeIsSelectedMethod Method

Grid Solutions Framework ASN1PreparedElementDatainvokeIsSelectedMethod Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object invokeIsSelectedMethod(
    Object obj,
    Object param
)
Public Function invokeIsSelectedMethod (
    obj As Object,
    param As Object
) As Object
abstract invokeIsSelectedMethod :
        obj : Object *
        param : Object -> Object
override invokeIsSelectedMethod :
        obj : Object *
        param : Object -> Object
function invokeIsSelectedMethod(obj, param);
public:
virtual Object^ invokeIsSelectedMethod(
    Object^ obj,
    Object^ param
) sealed

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

Implements

IASN1PreparedElementDatainvokeIsSelectedMethod(Object, Object)
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.setValueField Method

Grid Solutions Framework ASN1PreparedElementDatasetValueField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.setValueField(System.Reflection.PropertyInfo,GSF.ASN1.Coders.ASN1PreparedElementData)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void setValueField(
    PropertyInfo valueProperty,
    ASN1PreparedElementData valuePropertyMeta
)
Public Sub setValueField (
    valueProperty As PropertyInfo,
    valuePropertyMeta As ASN1PreparedElementData
)
member setValueField :
        valueProperty : PropertyInfo *
        valuePropertyMeta : ASN1PreparedElementData -> unit

function setValueField(valueProperty, valuePropertyMeta);
public:
void setValueField(
    PropertyInfo^ valueProperty,
    ASN1PreparedElementData^ valuePropertyMeta
)

Parameters

valueProperty
Type: System.ReflectionPropertyInfo

[Missing <param name="valueProperty"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.setValueField(System.Reflection.PropertyInfo,GSF.ASN1.Coders.ASN1PreparedElementData)"]

valuePropertyMeta
Type: GSF.ASN1.CodersASN1PreparedElementData

[Missing <param name="valuePropertyMeta"/> documentation for "M:GSF.ASN1.Coders.ASN1PreparedElementData.setValueField(System.Reflection.PropertyInfo,GSF.ASN1.Coders.ASN1PreparedElementData)"]

See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData Properties

Grid Solutions Framework ASN1PreparedElementData Properties

The ASN1PreparedElementData type exposes the following members.

Properties
 | Name | Description
Public property | ASN1ElementInfo |
Public property | Constraint |
Public property | IsPresentMethod |
Public property | Properties |
Public property | TypeMetadata |
Public property | ValueMetadata |
Public property | ValueProperty |
Top
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.ASN1ElementInfo Property

Grid Solutions Framework ASN1PreparedElementDataASN1ElementInfo Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ASN1PreparedElementData.ASN1ElementInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ElementMetadata ASN1ElementInfo { get; }
Public ReadOnly Property ASN1ElementInfo As ASN1ElementMetadata
    Get
abstract ASN1ElementInfo : ASN1ElementMetadata with get
override ASN1ElementInfo : ASN1ElementMetadata with get
function get_ASN1ElementInfo();

public:
virtual property ASN1ElementMetadata^ ASN1ElementInfo {
    ASN1ElementMetadata^ get () sealed;
}

Property Value

Type: ASN1ElementMetadata

Implements

IASN1PreparedElementDataASN1ElementInfo
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.Constraint Property

Grid Solutions Framework ASN1PreparedElementDataConstraint Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ASN1PreparedElementData.Constraint"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IASN1ConstraintMetadata Constraint { get; }
Public ReadOnly Property Constraint As IASN1ConstraintMetadata
    Get
abstract Constraint : IASN1ConstraintMetadata with get
override Constraint : IASN1ConstraintMetadata with get
function get_Constraint();

public:
virtual property IASN1ConstraintMetadata^ Constraint {
    IASN1ConstraintMetadata^ get () sealed;
}

Property Value

Type: IASN1ConstraintMetadata

Implements

IASN1PreparedElementDataConstraint
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.IsPresentMethod Property

Grid Solutions Framework ASN1PreparedElementDataIsPresentMethod Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ASN1PreparedElementData.IsPresentMethod"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MethodInfo IsPresentMethod { get; }
Public ReadOnly Property IsPresentMethod As MethodInfo
    Get
abstract IsPresentMethod : MethodInfo with get
override IsPresentMethod : MethodInfo with get
function get_IsPresentMethod();

public:
virtual property MethodInfo^ IsPresentMethod {
    MethodInfo^ get () sealed;
}

Property Value

Type: MethodInfo

Implements

IASN1PreparedElementDataIsPresentMethod
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.Properties Property

Grid Solutions Framework ASN1PreparedElementDataProperties Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ASN1PreparedElementData.Properties"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PropertyInfo[] Properties { get; }
Public ReadOnly Property Properties As PropertyInfo()
    Get
abstract Properties : PropertyInfo[] with get
override Properties : PropertyInfo[] with get
function get_Properties();

public:
virtual property array<PropertyInfo^>^ Properties {
    array<PropertyInfo^>^ get () sealed;
}

Property Value

Type: PropertyInfo

Implements

IASN1PreparedElementDataProperties
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.TypeMetadata Property

Grid Solutions Framework ASN1PreparedElementDataTypeMetadata Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ASN1PreparedElementData.TypeMetadata"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Metadata TypeMetadata { get; }
Public ReadOnly Property TypeMetadata As ASN1Metadata
    Get
abstract TypeMetadata : ASN1Metadata with get
override TypeMetadata : ASN1Metadata with get
function get_TypeMetadata();

public:
virtual property ASN1Metadata^ TypeMetadata {
    ASN1Metadata^ get () sealed;
}

Property Value

Type: ASN1Metadata

Implements

IASN1PreparedElementDataTypeMetadata
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.ValueMetadata Property

Grid Solutions Framework ASN1PreparedElementDataValueMetadata Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ASN1PreparedElementData.ValueMetadata"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1PreparedElementData ValueMetadata { get; }
Public ReadOnly Property ValueMetadata As ASN1PreparedElementData
    Get
abstract ValueMetadata : ASN1PreparedElementData with get
override ValueMetadata : ASN1PreparedElementData with get
function get_ValueMetadata();

public:
virtual property ASN1PreparedElementData^ ValueMetadata {
    ASN1PreparedElementData^ get () sealed;
}

Property Value

Type: ASN1PreparedElementData

Implements

IASN1PreparedElementDataValueMetadata
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


ASN1PreparedElementData.ValueProperty Property

Grid Solutions Framework ASN1PreparedElementDataValueProperty Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ASN1PreparedElementData.ValueProperty"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PropertyInfo ValueProperty { get; }
Public ReadOnly Property ValueProperty As PropertyInfo
    Get
abstract ValueProperty : PropertyInfo with get
override ValueProperty : PropertyInfo with get
function get_ValueProperty();

public:
virtual property PropertyInfo^ ValueProperty {
    PropertyInfo^ get () sealed;
}

Property Value

Type: PropertyInfo

Implements

IASN1PreparedElementDataValueProperty
See Also

Reference

ASN1PreparedElementData Class
GSF.ASN1.Coders Namespace


CoderUtils Class

Grid Solutions Framework CoderUtils Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.CoderUtils"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersCoderUtils

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CoderUtils
Public Class CoderUtils
type CoderUtils =  class end
GSF.ASN1.Coders.CoderUtils = function();

Type.createClass(
    'GSF.ASN1.Coders.CoderUtils');
public ref class CoderUtils

The CoderUtils type exposes the following members.

Constructors
 | Name | Description
Public method | CoderUtils | Initializes a new instance of the CoderUtils class
Top
Methods
 | Name | Description
 | ASN1StringToBuffer |
 | bufferToASN1String |
 | checkConstraints |
 | checkForOptionalField |
 | defStringToOctetString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | findDoSelectMethodForField |
 | findIsPresentMethodForField |
 | findIsSelectedMethodForField |
 | getAttributeT |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getIntegerLength(Int32) |
 | getIntegerLength(Int64) |
 | getPositiveIntegerLength(Int32) |
 | getPositiveIntegerLength(Int64) |
 | getSetOrder |
 | getStringTagForElement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | isAnyField |
 | isAttributePresentT |
 | isImplements |
 | isNullField |
 | isOptional |
 | isOptionalField |
 | isSequenceSet |
 | isSequenceSetOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders Namespace


CoderUtils Constructor

Grid Solutions Framework CoderUtils Constructor
Initializes a new instance of the CoderUtils class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CoderUtils()
Public Sub New
new : unit -> CoderUtils
GSF.ASN1.Coders.CoderUtils = function();
public:
CoderUtils()
See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils Methods

Grid Solutions Framework CoderUtils Methods

The CoderUtils type exposes the following members.

Methods
 | Name | Description
 | ASN1StringToBuffer |
 | bufferToASN1String |
 | checkConstraints |
 | checkForOptionalField |
 | defStringToOctetString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | findDoSelectMethodForField |
 | findIsPresentMethodForField |
 | findIsSelectedMethodForField |
 | getAttributeT |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getIntegerLength(Int32) |
 | getIntegerLength(Int64) |
 | getPositiveIntegerLength(Int32) |
 | getPositiveIntegerLength(Int64) |
 | getSetOrder |
 | getStringTagForElement |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | isAnyField |
 | isAttributePresentT |
 | isImplements |
 | isNullField |
 | isOptional |
 | isOptionalField |
 | isSequenceSet |
 | isSequenceSetOf |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.ASN1StringToBuffer Method

Grid Solutions Framework CoderUtilsASN1StringToBuffer Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.ASN1StringToBuffer(System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] ASN1StringToBuffer(
    Object obj,
    ElementInfo elementInfo
)
Public Shared Function ASN1StringToBuffer (
    obj As Object,
    elementInfo As ElementInfo
) As Byte()
static member ASN1StringToBuffer :
        obj : Object *
        elementInfo : ElementInfo -> byte[]

GSF.ASN1.Coders.CoderUtils.ASN1StringToBuffer = function(obj, elementInfo);
public:
static array<unsigned char>^ ASN1StringToBuffer(
    Object^ obj,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.ASN1StringToBuffer(System.Object,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.ASN1StringToBuffer(System.Object,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.ASN1StringToBuffer(System.Object,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.bufferToASN1String Method

Grid Solutions Framework CoderUtilsbufferToASN1String Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.bufferToASN1String(System.Byte[],GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string bufferToASN1String(
    byte[] byteBuf,
    ElementInfo elementInfo
)
Public Shared Function bufferToASN1String (
    byteBuf As Byte(),
    elementInfo As ElementInfo
) As String
static member bufferToASN1String :
        byteBuf : byte[] *
        elementInfo : ElementInfo -> string

GSF.ASN1.Coders.CoderUtils.bufferToASN1String = function(byteBuf, elementInfo);
public:
static String^ bufferToASN1String(
    array<unsigned char>^ byteBuf,
    ElementInfo^ elementInfo
)

Parameters

byteBuf
Type: SystemByte

[Missing <param name="byteBuf"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.bufferToASN1String(System.Byte[],GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.bufferToASN1String(System.Byte[],GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.bufferToASN1String(System.Byte[],GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.checkConstraints Method

Grid Solutions Framework CoderUtilscheckConstraints Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.checkConstraints(System.Int64,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void checkConstraints(
    long val,
    ElementInfo elementInfo
)
Public Shared Sub checkConstraints (
    val As Long,
    elementInfo As ElementInfo
)
static member checkConstraints :
        val : int64 *
        elementInfo : ElementInfo -> unit

GSF.ASN1.Coders.CoderUtils.checkConstraints = function(val, elementInfo);
public:
static void checkConstraints(
    long long val,
    ElementInfo^ elementInfo
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.checkConstraints(System.Int64,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.checkConstraints(System.Int64,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.checkForOptionalField Method

Grid Solutions Framework CoderUtilscheckForOptionalField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.checkForOptionalField(System.Reflection.PropertyInfo,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void checkForOptionalField(
    PropertyInfo field,
    ElementInfo elementInfo
)
Public Shared Sub checkForOptionalField (
    field As PropertyInfo,
    elementInfo As ElementInfo
)
static member checkForOptionalField :
        field : PropertyInfo *
        elementInfo : ElementInfo -> unit

GSF.ASN1.Coders.CoderUtils.checkForOptionalField = function(field, elementInfo);
public:
static void checkForOptionalField(
    PropertyInfo^ field,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.checkForOptionalField(System.Reflection.PropertyInfo,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.checkForOptionalField(System.Reflection.PropertyInfo,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.defStringToOctetString Method

Grid Solutions Framework CoderUtilsdefStringToOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.defStringToOctetString(System.String)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static BitString defStringToOctetString(
    string bhString
)
Public Shared Function defStringToOctetString (
    bhString As String
) As BitString
static member defStringToOctetString :
        bhString : string -> BitString

GSF.ASN1.Coders.CoderUtils.defStringToOctetString = function(bhString);
public:
static BitString^ defStringToOctetString(
    String^ bhString
)

Parameters

bhString
Type: SystemString

[Missing <param name="bhString"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.defStringToOctetString(System.String)"]

Return Value

Type: BitString

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.defStringToOctetString(System.String)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.findDoSelectMethodForField Method

Grid Solutions Framework CoderUtilsfindDoSelectMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.findDoSelectMethodForField(System.Reflection.PropertyInfo,System.Type)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MethodInfo findDoSelectMethodForField(
    PropertyInfo field,
    Type objClass
)
Public Shared Function findDoSelectMethodForField (
    field As PropertyInfo,
    objClass As Type
) As MethodInfo
static member findDoSelectMethodForField :
        field : PropertyInfo *
        objClass : Type -> MethodInfo

GSF.ASN1.Coders.CoderUtils.findDoSelectMethodForField = function(field, objClass);
public:
static MethodInfo^ findDoSelectMethodForField(
    PropertyInfo^ field,
    Type^ objClass
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.findDoSelectMethodForField(System.Reflection.PropertyInfo,System.Type)"]

objClass
Type: SystemType

[Missing <param name="objClass"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.findDoSelectMethodForField(System.Reflection.PropertyInfo,System.Type)"]

Return Value

Type: MethodInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.findDoSelectMethodForField(System.Reflection.PropertyInfo,System.Type)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.findIsPresentMethodForField Method

Grid Solutions Framework CoderUtilsfindIsPresentMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsPresentMethodForField(System.Reflection.PropertyInfo,System.Type)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MethodInfo findIsPresentMethodForField(
    PropertyInfo field,
    Type objClass
)
Public Shared Function findIsPresentMethodForField (
    field As PropertyInfo,
    objClass As Type
) As MethodInfo
static member findIsPresentMethodForField :
        field : PropertyInfo *
        objClass : Type -> MethodInfo

GSF.ASN1.Coders.CoderUtils.findIsPresentMethodForField = function(field, objClass);
public:
static MethodInfo^ findIsPresentMethodForField(
    PropertyInfo^ field,
    Type^ objClass
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsPresentMethodForField(System.Reflection.PropertyInfo,System.Type)"]

objClass
Type: SystemType

[Missing <param name="objClass"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsPresentMethodForField(System.Reflection.PropertyInfo,System.Type)"]

Return Value

Type: MethodInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsPresentMethodForField(System.Reflection.PropertyInfo,System.Type)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.findIsSelectedMethodForField Method

Grid Solutions Framework CoderUtilsfindIsSelectedMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsSelectedMethodForField(System.Reflection.PropertyInfo,System.Type)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MethodInfo findIsSelectedMethodForField(
    PropertyInfo field,
    Type objClass
)
Public Shared Function findIsSelectedMethodForField (
    field As PropertyInfo,
    objClass As Type
) As MethodInfo
static member findIsSelectedMethodForField :
        field : PropertyInfo *
        objClass : Type -> MethodInfo

GSF.ASN1.Coders.CoderUtils.findIsSelectedMethodForField = function(field, objClass);
public:
static MethodInfo^ findIsSelectedMethodForField(
    PropertyInfo^ field,
    Type^ objClass
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsSelectedMethodForField(System.Reflection.PropertyInfo,System.Type)"]

objClass
Type: SystemType

[Missing <param name="objClass"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsSelectedMethodForField(System.Reflection.PropertyInfo,System.Type)"]

Return Value

Type: MethodInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.findIsSelectedMethodForField(System.Reflection.PropertyInfo,System.Type)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.getAttribute(T) Method

Grid Solutions Framework CoderUtilsgetAttributeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.getAttribute``1(System.Reflection.ICustomAttributeProvider)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T getAttribute<T>(
    ICustomAttributeProvider field
)

Public Shared Function getAttribute(Of T) (
    field As ICustomAttributeProvider
) As T
static member getAttribute :
        field : ICustomAttributeProvider -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
static T getAttribute(
    ICustomAttributeProvider^ field
)

Parameters

field
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getAttribute``1(System.Reflection.ICustomAttributeProvider)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getAttribute``1(System.Reflection.ICustomAttributeProvider)"]

Return Value

Type: T

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.getAttribute``1(System.Reflection.ICustomAttributeProvider)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.getIntegerLength Method

Grid Solutions Framework CoderUtilsgetIntegerLength Method
Overload List
Name | Description
getIntegerLength(Int32) |
getIntegerLength(Int64) |
Top
See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.getIntegerLength Method (Int32)

Grid Solutions Framework CoderUtilsgetIntegerLength Method (Int32)

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.getIntegerLength(System.Int32)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int getIntegerLength(
    int val
)
Public Shared Function getIntegerLength (
    val As Integer
) As Integer
static member getIntegerLength :
        val : int -> int

GSF.ASN1.Coders.CoderUtils.getIntegerLength = function(val);
public:
static int getIntegerLength(
    int val
)

Parameters

val
Type: SystemInt32

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getIntegerLength(System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.getIntegerLength(System.Int32)"]

See Also

Reference

CoderUtils Class
getIntegerLength Overload
GSF.ASN1.Coders Namespace


CoderUtils.getIntegerLength Method (Int64)

Grid Solutions Framework CoderUtilsgetIntegerLength Method (Int64)

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.getIntegerLength(System.Int64)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int getIntegerLength(
    long val
)
Public Shared Function getIntegerLength (
    val As Long
) As Integer
static member getIntegerLength :
        val : int64 -> int

GSF.ASN1.Coders.CoderUtils.getIntegerLength = function(val);
public:
static int getIntegerLength(
    long long val
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getIntegerLength(System.Int64)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.getIntegerLength(System.Int64)"]

See Also

Reference

CoderUtils Class
getIntegerLength Overload
GSF.ASN1.Coders Namespace


CoderUtils.getPositiveIntegerLength Method

Grid Solutions Framework CoderUtilsgetPositiveIntegerLength Method
Overload List
Name | Description
getPositiveIntegerLength(Int32) |
getPositiveIntegerLength(Int64) |
Top
See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.getPositiveIntegerLength Method (Int32)

Grid Solutions Framework CoderUtilsgetPositiveIntegerLength Method (Int32)

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength(System.Int32)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int getPositiveIntegerLength(
    int val
)
Public Shared Function getPositiveIntegerLength (
    val As Integer
) As Integer
static member getPositiveIntegerLength :
        val : int -> int

GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength = function(val);
public:
static int getPositiveIntegerLength(
    int val
)

Parameters

val
Type: SystemInt32

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength(System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength(System.Int32)"]

See Also

Reference

CoderUtils Class
getPositiveIntegerLength Overload
GSF.ASN1.Coders Namespace


CoderUtils.getPositiveIntegerLength Method (Int64)

Grid Solutions Framework CoderUtilsgetPositiveIntegerLength Method (Int64)

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength(System.Int64)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int getPositiveIntegerLength(
    long val
)
Public Shared Function getPositiveIntegerLength (
    val As Long
) As Integer
static member getPositiveIntegerLength :
        val : int64 -> int

GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength = function(val);
public:
static int getPositiveIntegerLength(
    long long val
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength(System.Int64)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.getPositiveIntegerLength(System.Int64)"]

See Also

Reference

CoderUtils Class
getPositiveIntegerLength Overload
GSF.ASN1.Coders Namespace


CoderUtils.getSetOrder Method

Grid Solutions Framework CoderUtilsgetSetOrder Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.getSetOrder(System.Type)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SortedList<int, PropertyInfo> getSetOrder(
    Type objClass
)
Public Shared Function getSetOrder (
    objClass As Type
) As SortedList(Of Integer, PropertyInfo)
static member getSetOrder :
        objClass : Type -> SortedList<int, PropertyInfo>

GSF.ASN1.Coders.CoderUtils.getSetOrder = function(objClass);
public:
static SortedList<int, PropertyInfo^>^ getSetOrder(
    Type^ objClass
)

Parameters

objClass
Type: SystemType

[Missing <param name="objClass"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getSetOrder(System.Type)"]

Return Value

Type: SortedList Int32, PropertyInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.getSetOrder(System.Type)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.getStringTagForElement Method

Grid Solutions Framework CoderUtilsgetStringTagForElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.getStringTagForElement(GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int getStringTagForElement(
    ElementInfo elementInfo
)
Public Shared Function getStringTagForElement (
    elementInfo As ElementInfo
) As Integer
static member getStringTagForElement :
        elementInfo : ElementInfo -> int

GSF.ASN1.Coders.CoderUtils.getStringTagForElement = function(elementInfo);
public:
static int getStringTagForElement(
    ElementInfo^ elementInfo
)

Parameters

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.getStringTagForElement(GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.getStringTagForElement(GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isAnyField Method

Grid Solutions Framework CoderUtilsisAnyField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAnyField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isAnyField(
    ICustomAttributeProvider field,
    ElementInfo elementInfo
)
Public Shared Function isAnyField (
    field As ICustomAttributeProvider,
    elementInfo As ElementInfo
) As Boolean
static member isAnyField :
        field : ICustomAttributeProvider *
        elementInfo : ElementInfo -> bool

GSF.ASN1.Coders.CoderUtils.isAnyField = function(field, elementInfo);
public:
static bool isAnyField(
    ICustomAttributeProvider^ field,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAnyField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAnyField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAnyField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isAttributePresent(T) Method

Grid Solutions Framework CoderUtilsisAttributePresentT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAttributePresent``1(System.Reflection.ICustomAttributeProvider)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isAttributePresent<T>(
    ICustomAttributeProvider field
)

Public Shared Function isAttributePresent(Of T) (
    field As ICustomAttributeProvider
) As Boolean
static member isAttributePresent :
        field : ICustomAttributeProvider -> bool

JavaScript does not support generic types or methods.
public:
generic<typename T>
static bool isAttributePresent(
    ICustomAttributeProvider^ field
)

Parameters

field
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAttributePresent``1(System.Reflection.ICustomAttributeProvider)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAttributePresent``1(System.Reflection.ICustomAttributeProvider)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isAttributePresent``1(System.Reflection.ICustomAttributeProvider)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isImplements Method

Grid Solutions Framework CoderUtilsisImplements Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isImplements(System.Reflection.ICustomAttributeProvider,System.Type)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isImplements(
    ICustomAttributeProvider objectClass,
    Type interfaceClass
)
Public Shared Function isImplements (
    objectClass As ICustomAttributeProvider,
    interfaceClass As Type
) As Boolean
static member isImplements :
        objectClass : ICustomAttributeProvider *
        interfaceClass : Type -> bool

GSF.ASN1.Coders.CoderUtils.isImplements = function(objectClass, interfaceClass);
public:
static bool isImplements(
    ICustomAttributeProvider^ objectClass,
    Type^ interfaceClass
)

Parameters

objectClass
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isImplements(System.Reflection.ICustomAttributeProvider,System.Type)"]

interfaceClass
Type: SystemType

[Missing <param name="interfaceClass"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isImplements(System.Reflection.ICustomAttributeProvider,System.Type)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isImplements(System.Reflection.ICustomAttributeProvider,System.Type)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isNullField Method

Grid Solutions Framework CoderUtilsisNullField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isNullField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isNullField(
    ICustomAttributeProvider field,
    ElementInfo elementInfo
)
Public Shared Function isNullField (
    field As ICustomAttributeProvider,
    elementInfo As ElementInfo
) As Boolean
static member isNullField :
        field : ICustomAttributeProvider *
        elementInfo : ElementInfo -> bool

GSF.ASN1.Coders.CoderUtils.isNullField = function(field, elementInfo);
public:
static bool isNullField(
    ICustomAttributeProvider^ field,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isNullField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isNullField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isNullField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isOptional Method

Grid Solutions Framework CoderUtilsisOptional Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isOptional(GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isOptional(
    ElementInfo elementInfo
)
Public Shared Function isOptional (
    elementInfo As ElementInfo
) As Boolean
static member isOptional :
        elementInfo : ElementInfo -> bool

GSF.ASN1.Coders.CoderUtils.isOptional = function(elementInfo);
public:
static bool isOptional(
    ElementInfo^ elementInfo
)

Parameters

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isOptional(GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isOptional(GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isOptionalField Method

Grid Solutions Framework CoderUtilsisOptionalField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isOptionalField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isOptionalField(
    ICustomAttributeProvider field,
    ElementInfo elementInfo
)
Public Shared Function isOptionalField (
    field As ICustomAttributeProvider,
    elementInfo As ElementInfo
) As Boolean
static member isOptionalField :
        field : ICustomAttributeProvider *
        elementInfo : ElementInfo -> bool

GSF.ASN1.Coders.CoderUtils.isOptionalField = function(field, elementInfo);
public:
static bool isOptionalField(
    ICustomAttributeProvider^ field,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isOptionalField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isOptionalField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isOptionalField(System.Reflection.ICustomAttributeProvider,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isSequenceSet Method

Grid Solutions Framework CoderUtilsisSequenceSet Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isSequenceSet(GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isSequenceSet(
    ElementInfo elementInfo
)
Public Shared Function isSequenceSet (
    elementInfo As ElementInfo
) As Boolean
static member isSequenceSet :
        elementInfo : ElementInfo -> bool

GSF.ASN1.Coders.CoderUtils.isSequenceSet = function(elementInfo);
public:
static bool isSequenceSet(
    ElementInfo^ elementInfo
)

Parameters

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isSequenceSet(GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isSequenceSet(GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


CoderUtils.isSequenceSetOf Method

Grid Solutions Framework CoderUtilsisSequenceSetOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.CoderUtils.isSequenceSetOf(GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool isSequenceSetOf(
    ElementInfo elementInfo
)
Public Shared Function isSequenceSetOf (
    elementInfo As ElementInfo
) As Boolean
static member isSequenceSetOf :
        elementInfo : ElementInfo -> bool

GSF.ASN1.Coders.CoderUtils.isSequenceSetOf = function(elementInfo);
public:
static bool isSequenceSetOf(
    ElementInfo^ elementInfo
)

Parameters

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.CoderUtils.isSequenceSetOf(GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.CoderUtils.isSequenceSetOf(GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

CoderUtils Class
GSF.ASN1.Coders Namespace


DecodedObject(T) Class

Grid Solutions Framework DecodedObjectT Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.DecodedObject`1"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersDecodedObjectT

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DecodedObject<T>

Public Class DecodedObject(Of T)
type DecodedObject<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class DecodedObject

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GSF.ASN1.Coders.DecodedObject`1"]

The DecodedObjectT type exposes the following members.

Constructors
 | Name | Description
Public method | DecodedObjectT | Initializes a new instance of the DecodedObjectT class
Public method | DecodedObjectT(T) | Initializes a new instance of the DecodedObjectT class
Public method | DecodedObjectT(T, Int32) | Initializes a new instance of the DecodedObjectT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Size |
Public property | Value |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


DecodedObject(T) Constructor

Grid Solutions Framework DecodedObjectT Constructor
Overload List
 | Name | Description
Public method | DecodedObjectT | Initializes a new instance of the DecodedObjectT class
Public method | DecodedObjectT(T) | Initializes a new instance of the DecodedObjectT class
Public method | DecodedObjectT(T, Int32) | Initializes a new instance of the DecodedObjectT class
Top
See Also

Reference

DecodedObjectT Class
GSF.ASN1.Coders Namespace


DecodedObject(T) Constructor

Grid Solutions Framework DecodedObjectT Constructor
Initializes a new instance of the DecodedObjectT class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DecodedObject()
Public Sub New
new : unit -> DecodedObject
GSF.ASN1.Coders.DecodedObject = function();
public:
DecodedObject()
See Also

Reference

DecodedObjectT Class
DecodedObjectT Overload
GSF.ASN1.Coders Namespace


DecodedObject(T) Constructor (T)

Grid Solutions Framework DecodedObjectT Constructor (T)
Initializes a new instance of the DecodedObjectT class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DecodedObject(
    T result
)
Public Sub New (
    result As T
)
new :
        result : 'T -> DecodedObject
GSF.ASN1.Coders.DecodedObject = function(result);
public:
DecodedObject(
    T result
)

Parameters

result
Type: T

[Missing <param name="result"/> documentation for "M:GSF.ASN1.Coders.DecodedObject`1.#ctor(`0)"]

See Also

Reference

DecodedObjectT Class
DecodedObjectT Overload
GSF.ASN1.Coders Namespace


DecodedObject(T) Constructor (T, Int32)

Grid Solutions Framework DecodedObjectT Constructor (T, Int32)
Initializes a new instance of the DecodedObjectT class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DecodedObject(
    T result,
    int size
)
Public Sub New (
    result As T,
    size As Integer
)
new :
        result : 'T *
        size : int -> DecodedObject
GSF.ASN1.Coders.DecodedObject = function(result, size);
public:
DecodedObject(
    T result,
    int size
)

Parameters

result
Type: T

[Missing <param name="result"/> documentation for "M:GSF.ASN1.Coders.DecodedObject`1.#ctor(`0,System.Int32)"]

size
Type: SystemInt32

[Missing <param name="size"/> documentation for "M:GSF.ASN1.Coders.DecodedObject`1.#ctor(`0,System.Int32)"]

See Also

Reference

DecodedObjectT Class
DecodedObjectT Overload
GSF.ASN1.Coders Namespace


DecodedObject(T) Methods

Grid Solutions Framework DecodedObjectT Methods

The DecodedObjectT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DecodedObjectT Class
GSF.ASN1.Coders Namespace


DecodedObject(T) Properties

Grid Solutions Framework DecodedObjectT Properties

The DecodedObjectT generic type exposes the following members.

Properties
 | Name | Description
Public property | Size |
Public property | Value |
Top
See Also

Reference

DecodedObjectT Class
GSF.ASN1.Coders Namespace


DecodedObject(T).Size Property

Grid Solutions Framework DecodedObjectTSize Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.DecodedObject`1.Size"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int Size { get; set; }
Public Overridable Property Size As Integer
    Get
    Set
abstract Size : int with get, set
override Size : int with get, set
function get_Size();
function set_Size(value);
public:
virtual property int Size {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DecodedObjectT Class
GSF.ASN1.Coders Namespace


DecodedObject(T).Value Property

Grid Solutions Framework DecodedObjectTValue Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.DecodedObject`1.Value"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set
member Value : 'T with get, set

function get_Value();
function set_Value(value);
public:
property T Value {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

DecodedObjectT Class
GSF.ASN1.Coders Namespace


Decoder Class

Grid Solutions Framework Decoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.Decoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersDecoder
GSF.ASN1.Coders.BERBERDecoder
GSF.ASN1.Coders.PERPERAlignedDecoder

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class Decoder : IASN1TypesDecoder,
    IDecoder
Public MustInherit Class Decoder
    Implements IASN1TypesDecoder, IDecoder
[<AbstractClassAttribute>]
type Decoder =
    class
        interface IASN1TypesDecoder
        interface IDecoder
    end
GSF.ASN1.Coders.Decoder = function();

Type.createClass(
    'GSF.ASN1.Coders.Decoder',
    null,
    GSF.ASN1.Coders.IASN1TypesDecoder,
    GSF.ASN1.IDecoder);
public ref class Decoder abstract : IASN1TypesDecoder,
    IDecoder

The Decoder type exposes the following members.

Constructors
 | Name | Description
Protected method | Decoder | Initializes a new instance of the Decoder class
Top
Methods
 | Name | Description
Public method | createInstanceForElement |
Public method | decodeT |
Public method | decodeAny |
Public method | decodeBitString |
Public method | decodeBoolean |
Public method | decodeBoxedType |
Public method | decodeChoice |
Public method | decodeClassType |
Public method | decodeCSElement |
Public method | decodeCSEnum |
Public method | decodeElement |
Public method | decodeEnum |
Public method | decodeEnumItem |
Public method | decodeInteger |
Public method | decodeNull |
Public method | decodeObjectIdentifier |
Public method | decodeOctetString |
Public method | decodePreparedElement |
Public method | decodeReal |
Public method | decodeSequence |
Public method | decodeSequenceField |
Public method | decodeSequenceOf |
Public method | decodeString |
Public method | decodeTag |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues |
Public method | invokeSelectMethodForField |
Public method | invokeSetterMethodForField |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders Namespace


Decoder Constructor

Grid Solutions Framework Decoder Constructor
Initializes a new instance of the Decoder class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Decoder()
Protected Sub New
new : unit -> Decoder
GSF.ASN1.Coders.Decoder = function();
protected:
Decoder()
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder Methods

Grid Solutions Framework Decoder Methods

The Decoder type exposes the following members.

Methods
 | Name | Description
Public method | createInstanceForElement |
Public method | decodeT |
Public method | decodeAny |
Public method | decodeBitString |
Public method | decodeBoolean |
Public method | decodeBoxedType |
Public method | decodeChoice |
Public method | decodeClassType |
Public method | decodeCSElement |
Public method | decodeCSEnum |
Public method | decodeElement |
Public method | decodeEnum |
Public method | decodeEnumItem |
Public method | decodeInteger |
Public method | decodeNull |
Public method | decodeObjectIdentifier |
Public method | decodeOctetString |
Public method | decodePreparedElement |
Public method | decodeReal |
Public method | decodeSequence |
Public method | decodeSequenceField |
Public method | decodeSequenceOf |
Public method | decodeString |
Public method | decodeTag |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues |
Public method | invokeSelectMethodForField |
Public method | invokeSetterMethodForField |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.createInstanceForElement Method

Grid Solutions Framework DecodercreateInstanceForElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.createInstanceForElement(System.Type,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object createInstanceForElement(
    Type objectClass,
    ElementInfo info
)
Public Function createInstanceForElement (
    objectClass As Type,
    info As ElementInfo
) As Object
member createInstanceForElement :
        objectClass : Type *
        info : ElementInfo -> Object

function createInstanceForElement(objectClass, info);
public:
Object^ createInstanceForElement(
    Type^ objectClass,
    ElementInfo^ info
)

Parameters

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.createInstanceForElement(System.Type,GSF.ASN1.Coders.ElementInfo)"]

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.Decoder.createInstanceForElement(System.Type,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.createInstanceForElement(System.Type,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decode(T) Method

Grid Solutions Framework DecoderdecodeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decode``1(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual T decode<T>(
    Stream stream
)

Public Overridable Function decode(Of T) (
    stream As Stream
) As T
abstract decode :
        stream : Stream -> 'T
override decode :
        stream : Stream -> 'T
JavaScript does not support generic types or methods.
public:
generic<typename T>
virtual T decode(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decode``1(System.IO.Stream)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.Decoder.decode``1(System.IO.Stream)"]

Return Value

Type: T

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decode``1(System.IO.Stream)"]

Implements

IDecoderdecodeT(Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeAny Method

Grid Solutions Framework DecoderdecodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeAny(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeAny (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeAny :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeAny(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeAny(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeAny(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeBitString Method

Grid Solutions Framework DecoderdecodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeBitString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeBitString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBitString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeBitString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeBitString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeBitString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeBoolean Method

Grid Solutions Framework DecoderdecodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeBoolean(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeBoolean (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBoolean :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeBoolean(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeBoolean(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeBoolean(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeBoxedType Method

Grid Solutions Framework DecoderdecodeBoxedType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeBoxedType(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeBoxedType (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBoxedType :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeBoxedType :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeBoxedType(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeBoxedType(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeBoxedType(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeChoice Method

Grid Solutions Framework DecoderdecodeChoice Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeChoice(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeChoice (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeChoice :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeChoice :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeChoice(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeChoice(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeChoice(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeClassType Method

Grid Solutions Framework DecoderdecodeClassType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeClassType(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeClassType (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeClassType :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeClassType :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeClassType(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeClassType(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeClassType(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeCSElement Method

Grid Solutions Framework DecoderdecodeCSElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeCSElement(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeCSElement (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeCSElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeCSElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeCSElement(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeCSElement(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeCSEnum Method

Grid Solutions Framework DecoderdecodeCSEnum Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeCSEnum(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeCSEnum (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeCSEnum :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeCSEnum :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeCSEnum(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeCSEnum(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeCSEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeElement Method

Grid Solutions Framework DecoderdecodeElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeElement(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeElement (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeElement(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeElement(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeElement(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeEnum Method

Grid Solutions Framework DecoderdecodeEnum Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeEnum(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeEnum (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeEnum :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeEnum :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeEnum(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeEnum(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeEnum(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeEnumItem Method

Grid Solutions Framework DecoderdecodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeEnumItem(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    Type enumClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeEnumItem (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    enumClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeEnumItem :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        enumClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeEnumItem(decodedTag, objectClass, enumClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeEnumItem(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    Type^ enumClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeEnumItem(DecodedObjectObject, Type, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeInteger Method

Grid Solutions Framework DecoderdecodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeInteger(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeInteger (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeInteger :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeInteger(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeInteger(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeInteger(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeNull Method

Grid Solutions Framework DecoderdecodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeNull(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeNull (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeNull :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeNull(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeNull(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeNull(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeObjectIdentifier Method

Grid Solutions Framework DecoderdecodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeObjectIdentifier(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeObjectIdentifier (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeObjectIdentifier :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeObjectIdentifier(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeObjectIdentifier(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeObjectIdentifier(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeOctetString Method

Grid Solutions Framework DecoderdecodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeOctetString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeOctetString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeOctetString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeOctetString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeOctetString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeOctetString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodePreparedElement Method

Grid Solutions Framework DecoderdecodePreparedElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DecodedObject<Object> decodePreparedElement(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Function decodePreparedElement (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodePreparedElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodePreparedElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodePreparedElement(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodePreparedElement(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) sealed

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodePreparedElement(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeReal Method

Grid Solutions Framework DecoderdecodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeReal(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeReal (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeReal :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeReal(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeReal(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeReal(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeSequence Method

Grid Solutions Framework DecoderdecodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeSequence(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overridable Function decodeSequence (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequence :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeSequence :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeSequence(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeSequence(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeSequence(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeSequenceField Method

Grid Solutions Framework DecoderdecodeSequenceField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DecodedObject<Object> decodeSequenceField(
    DecodedObject<Object> fieldTag,
    Object sequenceObj,
    int fieldIdx,
    PropertyInfo field,
    Stream stream,
    ElementInfo elementInfo,
    bool checkOptional
)
Public Overridable Function decodeSequenceField (
    fieldTag As DecodedObject(Of Object),
    sequenceObj As Object,
    fieldIdx As Integer,
    field As PropertyInfo,
    stream As Stream,
    elementInfo As ElementInfo,
    checkOptional As Boolean
) As DecodedObject(Of Object)
abstract decodeSequenceField :
        fieldTag : DecodedObject<Object> *
        sequenceObj : Object *
        fieldIdx : int *
        field : PropertyInfo *
        stream : Stream *
        elementInfo : ElementInfo *
        checkOptional : bool -> DecodedObject<Object>
override decodeSequenceField :
        fieldTag : DecodedObject<Object> *
        sequenceObj : Object *
        fieldIdx : int *
        field : PropertyInfo *
        stream : Stream *
        elementInfo : ElementInfo *
        checkOptional : bool -> DecodedObject<Object>
function decodeSequenceField(fieldTag, sequenceObj, fieldIdx, field, stream, elementInfo, checkOptional);
public:
virtual DecodedObject<Object^>^ decodeSequenceField(
    DecodedObject<Object^>^ fieldTag,
    Object^ sequenceObj,
    int fieldIdx,
    PropertyInfo^ field,
    Stream^ stream,
    ElementInfo^ elementInfo,
    bool checkOptional
)

Parameters

fieldTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="fieldTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

sequenceObj
Type: SystemObject

[Missing <param name="sequenceObj"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

fieldIdx
Type: SystemInt32

[Missing <param name="fieldIdx"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

checkOptional
Type: SystemBoolean

[Missing <param name="checkOptional"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceField(GSF.ASN1.Coders.DecodedObject{System.Object},System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo,System.Boolean)"]

See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeSequenceOf Method

Grid Solutions Framework DecoderdecodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeSequenceOf(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeSequenceOf (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequenceOf :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeSequenceOf(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeSequenceOf(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeSequenceOf(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeString Method

Grid Solutions Framework DecoderdecodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decodeString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.decodeTag Method

Grid Solutions Framework DecoderdecodeTag Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.decodeTag(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decodeTag(
    Stream stream
)
Public MustOverride Function decodeTag (
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeTag :
        stream : Stream -> DecodedObject<Object>

function decodeTag(stream);
public:
virtual DecodedObject<Object^>^ decodeTag(
    Stream^ stream
) abstract

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Decoder.decodeTag(System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Decoder.decodeTag(System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeTag(Stream)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.initDefaultValues Method

Grid Solutions Framework DecoderinitDefaultValues Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.initDefaultValues(System.Object)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void initDefaultValues(
    Object obj
)
Public Overridable Sub initDefaultValues (
    obj As Object
)
abstract initDefaultValues :
        obj : Object -> unit
override initDefaultValues :
        obj : Object -> unit
function initDefaultValues(obj);
public:
virtual void initDefaultValues(
    Object^ obj
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Decoder.initDefaultValues(System.Object)"]

See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.invokeSelectMethodForField Method

Grid Solutions Framework DecoderinvokeSelectMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void invokeSelectMethodForField(
    PropertyInfo field,
    Object obj,
    Object param,
    ElementInfo info
)
Public Sub invokeSelectMethodForField (
    field As PropertyInfo,
    obj As Object,
    param As Object,
    info As ElementInfo
)
abstract invokeSelectMethodForField :
        field : PropertyInfo *
        obj : Object *
        param : Object *
        info : ElementInfo -> unit
override invokeSelectMethodForField :
        field : PropertyInfo *
        obj : Object *
        param : Object *
        info : ElementInfo -> unit
function invokeSelectMethodForField(field, obj, param, info);
public:
virtual void invokeSelectMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    Object^ param,
    ElementInfo^ info
) sealed

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesDecoderinvokeSelectMethodForField(PropertyInfo, Object, Object, ElementInfo)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


Decoder.invokeSetterMethodForField Method

Grid Solutions Framework DecoderinvokeSetterMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void invokeSetterMethodForField(
    PropertyInfo field,
    Object obj,
    Object param,
    ElementInfo info
)
Public Sub invokeSetterMethodForField (
    field As PropertyInfo,
    obj As Object,
    param As Object,
    info As ElementInfo
)
abstract invokeSetterMethodForField :
        field : PropertyInfo *
        obj : Object *
        param : Object *
        info : ElementInfo -> unit
override invokeSetterMethodForField :
        field : PropertyInfo *
        obj : Object *
        param : Object *
        info : ElementInfo -> unit
function invokeSetterMethodForField(field, obj, param, info);
public:
virtual void invokeSetterMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    Object^ param,
    ElementInfo^ info
) sealed

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.Decoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesDecoderinvokeSetterMethodForField(PropertyInfo, Object, Object, ElementInfo)
See Also

Reference

Decoder Class
GSF.ASN1.Coders Namespace


ElementInfo Class

Grid Solutions Framework ElementInfo Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.ElementInfo"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersElementInfo

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ElementInfo
Public Class ElementInfo
type ElementInfo =  class end
GSF.ASN1.Coders.ElementInfo = function();

Type.createClass(
    'GSF.ASN1.Coders.ElementInfo');
public ref class ElementInfo

The ElementInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ElementInfo | Initializes a new instance of the ElementInfo class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getAttributeT |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getParentAttributeT |
Public method | getProperties |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasPreparedASN1ElementInfo |
Public method | hasPreparedInfo |
Public method | isAttributePresentT |
Public method | isParentAttributePresentT |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnnotatedClass |
Public property | ASN1ElementInfo |
Public property | MaxAvailableLen |
Public property | ParentAnnotatedClass |
Public property | PreparedASN1ElementInfo |
Public property | PreparedInfo |
Public property | PreparedInstance |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


ElementInfo Constructor

Grid Solutions Framework ElementInfo Constructor
Initializes a new instance of the ElementInfo class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ElementInfo()
Public Sub New
new : unit -> ElementInfo
GSF.ASN1.Coders.ElementInfo = function();
public:
ElementInfo()
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo Methods

Grid Solutions Framework ElementInfo Methods

The ElementInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | getAttributeT |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getParentAttributeT |
Public method | getProperties |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | hasPreparedASN1ElementInfo |
Public method | hasPreparedInfo |
Public method | isAttributePresentT |
Public method | isParentAttributePresentT |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.getAttribute(T) Method

Grid Solutions Framework ElementInfogetAttributeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ElementInfo.getAttribute``1"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T getAttribute<T>()

Public Function getAttribute(Of T) As T
member getAttribute : unit -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T getAttribute()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.ElementInfo.getAttribute``1"]

Return Value

Type: T

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ElementInfo.getAttribute``1"]

See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.getParentAttribute(T) Method

Grid Solutions Framework ElementInfogetParentAttributeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ElementInfo.getParentAttribute``1"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T getParentAttribute<T>()

Public Function getParentAttribute(Of T) As T
member getParentAttribute : unit -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T getParentAttribute()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.ElementInfo.getParentAttribute``1"]

Return Value

Type: T

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ElementInfo.getParentAttribute``1"]

See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.getProperties Method

Grid Solutions Framework ElementInfogetProperties Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ElementInfo.getProperties(System.Type)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PropertyInfo[] getProperties(
    Type objClass
)
Public Function getProperties (
    objClass As Type
) As PropertyInfo()
member getProperties :
        objClass : Type -> PropertyInfo[]

function getProperties(objClass);
public:
array<PropertyInfo^>^ getProperties(
    Type^ objClass
)

Parameters

objClass
Type: SystemType

[Missing <param name="objClass"/> documentation for "M:GSF.ASN1.Coders.ElementInfo.getProperties(System.Type)"]

Return Value

Type: PropertyInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ElementInfo.getProperties(System.Type)"]

See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.hasPreparedASN1ElementInfo Method

Grid Solutions Framework ElementInfohasPreparedASN1ElementInfo Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ElementInfo.hasPreparedASN1ElementInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool hasPreparedASN1ElementInfo()
Public Function hasPreparedASN1ElementInfo As Boolean
member hasPreparedASN1ElementInfo : unit -> bool

function hasPreparedASN1ElementInfo();
public:
bool hasPreparedASN1ElementInfo()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ElementInfo.hasPreparedASN1ElementInfo"]

See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.hasPreparedInfo Method

Grid Solutions Framework ElementInfohasPreparedInfo Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ElementInfo.hasPreparedInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool hasPreparedInfo()
Public Function hasPreparedInfo As Boolean
member hasPreparedInfo : unit -> bool

function hasPreparedInfo();
public:
bool hasPreparedInfo()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ElementInfo.hasPreparedInfo"]

See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.isAttributePresent(T) Method

Grid Solutions Framework ElementInfoisAttributePresentT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ElementInfo.isAttributePresent``1"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool isAttributePresent<T>()

Public Function isAttributePresent(Of T) As Boolean
member isAttributePresent : unit -> bool

JavaScript does not support generic types or methods.
public:
generic<typename T>
bool isAttributePresent()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.ElementInfo.isAttributePresent``1"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ElementInfo.isAttributePresent``1"]

See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.isParentAttributePresent(T) Method

Grid Solutions Framework ElementInfoisParentAttributePresentT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.ElementInfo.isParentAttributePresent``1"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool isParentAttributePresent<T>()

Public Function isParentAttributePresent(Of T) As Boolean
member isParentAttributePresent : unit -> bool

JavaScript does not support generic types or methods.
public:
generic<typename T>
bool isParentAttributePresent()

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.ElementInfo.isParentAttributePresent``1"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.ElementInfo.isParentAttributePresent``1"]

See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo Properties

Grid Solutions Framework ElementInfo Properties

The ElementInfo type exposes the following members.

Properties
 | Name | Description
Public property | AnnotatedClass |
Public property | ASN1ElementInfo |
Public property | MaxAvailableLen |
Public property | ParentAnnotatedClass |
Public property | PreparedASN1ElementInfo |
Public property | PreparedInfo |
Public property | PreparedInstance |
Top
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.AnnotatedClass Property

Grid Solutions Framework ElementInfoAnnotatedClass Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ElementInfo.AnnotatedClass"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICustomAttributeProvider AnnotatedClass { get; set; }
Public Property AnnotatedClass As ICustomAttributeProvider
    Get
    Set
member AnnotatedClass : ICustomAttributeProvider with get, set

function get_AnnotatedClass();
function set_AnnotatedClass(value);
public:
property ICustomAttributeProvider^ AnnotatedClass {
    ICustomAttributeProvider^ get ();
    void set (ICustomAttributeProvider^ value);
}

Property Value

Type: ICustomAttributeProvider
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.ASN1ElementInfo Property

Grid Solutions Framework ElementInfoASN1ElementInfo Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ElementInfo.ASN1ElementInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Element ASN1ElementInfo { get; set; }
Public Property ASN1ElementInfo As ASN1Element
    Get
    Set
member ASN1ElementInfo : ASN1Element with get, set

function get_ASN1ElementInfo();
function set_ASN1ElementInfo(value);
public:
property ASN1Element^ ASN1ElementInfo {
    ASN1Element^ get ();
    void set (ASN1Element^ value);
}

Property Value

Type: ASN1Element
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.MaxAvailableLen Property

Grid Solutions Framework ElementInfoMaxAvailableLen Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ElementInfo.MaxAvailableLen"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaxAvailableLen { get; set; }
Public Property MaxAvailableLen As Integer
    Get
    Set
member MaxAvailableLen : int with get, set

function get_MaxAvailableLen();
function set_MaxAvailableLen(value);
public:
property int MaxAvailableLen {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.ParentAnnotatedClass Property

Grid Solutions Framework ElementInfoParentAnnotatedClass Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ElementInfo.ParentAnnotatedClass"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICustomAttributeProvider ParentAnnotatedClass { get; set; }
Public Property ParentAnnotatedClass As ICustomAttributeProvider
    Get
    Set
member ParentAnnotatedClass : ICustomAttributeProvider with get, set

function get_ParentAnnotatedClass();
function set_ParentAnnotatedClass(value);
public:
property ICustomAttributeProvider^ ParentAnnotatedClass {
    ICustomAttributeProvider^ get ();
    void set (ICustomAttributeProvider^ value);
}

Property Value

Type: ICustomAttributeProvider
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.PreparedASN1ElementInfo Property

Grid Solutions Framework ElementInfoPreparedASN1ElementInfo Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ElementInfo.PreparedASN1ElementInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ElementMetadata PreparedASN1ElementInfo { get; set; }
Public Property PreparedASN1ElementInfo As ASN1ElementMetadata
    Get
    Set
member PreparedASN1ElementInfo : ASN1ElementMetadata with get, set

function get_PreparedASN1ElementInfo();
function set_PreparedASN1ElementInfo(value);
public:
property ASN1ElementMetadata^ PreparedASN1ElementInfo {
    ASN1ElementMetadata^ get ();
    void set (ASN1ElementMetadata^ value);
}

Property Value

Type: ASN1ElementMetadata
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.PreparedInfo Property

Grid Solutions Framework ElementInfoPreparedInfo Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ElementInfo.PreparedInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IASN1PreparedElementData PreparedInfo { get; set; }
Public Property PreparedInfo As IASN1PreparedElementData
    Get
    Set
member PreparedInfo : IASN1PreparedElementData with get, set

function get_PreparedInfo();
function set_PreparedInfo(value);
public:
property IASN1PreparedElementData^ PreparedInfo {
    IASN1PreparedElementData^ get ();
    void set (IASN1PreparedElementData^ value);
}

Property Value

Type: IASN1PreparedElementData
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementInfo.PreparedInstance Property

Grid Solutions Framework ElementInfoPreparedInstance Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.ElementInfo.PreparedInstance"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object PreparedInstance { get; set; }
Public Property PreparedInstance As Object
    Get
    Set
member PreparedInstance : Object with get, set

function get_PreparedInstance();
function set_PreparedInstance(value);
public:
property Object^ PreparedInstance {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ElementInfo Class
GSF.ASN1.Coders Namespace


ElementType Structure

Grid Solutions Framework ElementType Structure

[Missing <summary> documentation for "T:GSF.ASN1.Coders.ElementType"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct ElementType
Public Structure ElementType
[<SealedAttribute>]
type ElementType =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class ElementType

The ElementType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Constructed |
Primitive |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


ElementType Fields

Grid Solutions Framework ElementType Fields

The ElementType type exposes the following members.

Fields
Name | Description
Constructed |
Primitive |
Top
See Also

Reference

ElementType Structure
GSF.ASN1.Coders Namespace


ElementType.Constructed Field

Grid Solutions Framework ElementTypeConstructed Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.ElementType.Constructed"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Constructed
Public Const Constructed As Integer
static val mutable Constructed: int
var GSF.ASN1.Coders.ElementType.Constructed
public:
literal int Constructed

Field Value

Type: Int32
See Also

Reference

ElementType Structure
GSF.ASN1.Coders Namespace


ElementType.Primitive Field

Grid Solutions Framework ElementTypePrimitive Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.ElementType.Primitive"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Primitive
Public Const Primitive As Integer
static val mutable Primitive: int
var GSF.ASN1.Coders.ElementType.Primitive
public:
literal int Primitive

Field Value

Type: Int32
See Also

Reference

ElementType Structure
GSF.ASN1.Coders Namespace


ElementType Methods

Grid Solutions Framework ElementType Methods

The ElementType type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ElementType Structure
GSF.ASN1.Coders Namespace


Encoder Class

Grid Solutions Framework Encoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.Encoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersEncoder
GSF.ASN1.Coders.BERBEREncoder
GSF.ASN1.Coders.PERPERAlignedEncoder

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class Encoder : IASN1TypesEncoder,
    IEncoder
Public MustInherit Class Encoder
    Implements IASN1TypesEncoder, IEncoder
[<AbstractClassAttribute>]
type Encoder =
    class
        interface IASN1TypesEncoder
        interface IEncoder
    end
GSF.ASN1.Coders.Encoder = function();

Type.createClass(
    'GSF.ASN1.Coders.Encoder',
    null,
    GSF.ASN1.Coders.IASN1TypesEncoder,
    GSF.ASN1.IEncoder);
public ref class Encoder abstract : IASN1TypesEncoder,
    IEncoder

The Encoder type exposes the following members.

Constructors
 | Name | Description
Protected method | Encoder | Initializes a new instance of the Encoder class
Top
Methods
 | Name | Description
Public method | encodeT |
Public method | encodeAny |
Public method | encodeBitString |
Public method | encodeBoolean |
Public method | encodeBoxedType |
Public method | encodeChoice |
Public method | encodeClassType |
Public method | encodeCSElement |
Protected method | encodeCSEnum |
Public method | encodeElement |
Public method | encodeEnum |
Public method | encodeEnumItem |
Public method | encodeInteger |
Public method | encodeNull |
Public method | encodeObjectIdentifier |
Public method | encodeOctetString |
Public method | encodePreparedElement |
Public method | encodeReal |
Public method | encodeSequence |
Public method | encodeSequenceField |
Public method | encodeSequenceOf |
Public method | encodeString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField |
Public method | invokeSelectedMethodForField |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders Namespace


Encoder Constructor

Grid Solutions Framework Encoder Constructor
Initializes a new instance of the Encoder class

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Encoder()
Protected Sub New
new : unit -> Encoder
GSF.ASN1.Coders.Encoder = function();
protected:
Encoder()
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder Methods

Grid Solutions Framework Encoder Methods

The Encoder type exposes the following members.

Methods
 | Name | Description
Public method | encodeT |
Public method | encodeAny |
Public method | encodeBitString |
Public method | encodeBoolean |
Public method | encodeBoxedType |
Public method | encodeChoice |
Public method | encodeClassType |
Public method | encodeCSElement |
Protected method | encodeCSEnum |
Public method | encodeElement |
Public method | encodeEnum |
Public method | encodeEnumItem |
Public method | encodeInteger |
Public method | encodeNull |
Public method | encodeObjectIdentifier |
Public method | encodeOctetString |
Public method | encodePreparedElement |
Public method | encodeReal |
Public method | encodeSequence |
Public method | encodeSequenceField |
Public method | encodeSequenceOf |
Public method | encodeString |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField |
Public method | invokeSelectedMethodForField |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encode(T) Method

Grid Solutions Framework EncoderencodeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encode``1(``0,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void encode<T>(
    T obj,
    Stream stream
)

Public Overridable Sub encode(Of T) (
    obj As T,
    stream As Stream
)
abstract encode :
        obj : 'T *
        stream : Stream -> unit
override encode :
        obj : 'T *
        stream : Stream -> unit
JavaScript does not support generic types or methods.
public:
generic<typename T>
virtual void encode(
    T obj,
    Stream^ stream
)

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encode``1(``0,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encode``1(``0,System.IO.Stream)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.Encoder.encode``1(``0,System.IO.Stream)"]

Implements

IEncoderencodeT(T, Stream)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeAny Method

Grid Solutions Framework EncoderencodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeAny(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public MustOverride Function encodeAny (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeAny :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeAny(obj, stream, elementInfo);
public:
virtual int encodeAny(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeAny(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeBitString Method

Grid Solutions Framework EncoderencodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeBitString(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Public MustOverride Function encodeBitString (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBitString :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeBitString(obj, steam, elementInfo);
public:
virtual int encodeBitString(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeBitString(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeBoolean Method

Grid Solutions Framework EncoderencodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeBoolean(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public MustOverride Function encodeBoolean (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBoolean :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeBoolean(obj, stream, elementInfo);
public:
virtual int encodeBoolean(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeBoolean(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeBoxedType Method

Grid Solutions Framework EncoderencodeBoxedType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeBoxedType(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeBoxedType (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBoxedType :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeBoxedType :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeBoxedType(obj, stream, elementInfo);
public:
virtual int encodeBoxedType(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeBoxedType(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeChoice Method

Grid Solutions Framework EncoderencodeChoice Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeChoice(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeChoice (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeChoice :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeChoice :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeChoice(obj, stream, elementInfo);
public:
virtual int encodeChoice(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeChoice(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeClassType Method

Grid Solutions Framework EncoderencodeClassType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeClassType(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeClassType (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeClassType :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeClassType :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeClassType(obj, stream, elementInfo);
public:
virtual int encodeClassType(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeClassType(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeCSElement Method

Grid Solutions Framework EncoderencodeCSElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeCSElement(
    Object obj,
    Stream stream,
    ElementInfo info
)
Public Overridable Function encodeCSElement (
    obj As Object,
    stream As Stream,
    info As ElementInfo
) As Integer
abstract encodeCSElement :
        obj : Object *
        stream : Stream *
        info : ElementInfo -> int
override encodeCSElement :
        obj : Object *
        stream : Stream *
        info : ElementInfo -> int
function encodeCSElement(obj, stream, info);
public:
virtual int encodeCSElement(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ info
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeCSEnum Method

Grid Solutions Framework EncoderencodeCSEnum Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int encodeCSEnum(
    Object obj,
    Stream stream,
    ElementInfo info
)
Protected Function encodeCSEnum (
    obj As Object,
    stream As Stream,
    info As ElementInfo
) As Integer
member encodeCSEnum :
        obj : Object *
        stream : Stream *
        info : ElementInfo -> int

function encodeCSEnum(obj, stream, info);
protected:
int encodeCSEnum(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ info
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeCSEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeElement Method

Grid Solutions Framework EncoderencodeElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeElement(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeElement (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeElement :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeElement :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeElement(obj, stream, elementInfo);
public:
virtual int encodeElement(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeElement(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeEnum Method

Grid Solutions Framework EncoderencodeEnum Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeEnum(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeEnum (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeEnum :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeEnum :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeEnum(obj, stream, elementInfo);
public:
virtual int encodeEnum(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeEnum(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeEnumItem Method

Grid Solutions Framework EncoderencodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeEnumItem(
    Object enumConstant,
    Type enumClass,
    Stream stream,
    ElementInfo elementInfo
)
Public MustOverride Function encodeEnumItem (
    enumConstant As Object,
    enumClass As Type,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeEnumItem :
        enumConstant : Object *
        enumClass : Type *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeEnumItem(enumConstant, enumClass, stream, elementInfo);
public:
virtual int encodeEnumItem(
    Object^ enumConstant,
    Type^ enumClass,
    Stream^ stream,
    ElementInfo^ elementInfo
) abstract

Parameters

enumConstant
Type: SystemObject

[Missing <param name="enumConstant"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeEnumItem(Object, Type, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeInteger Method

Grid Solutions Framework EncoderencodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeInteger(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Public MustOverride Function encodeInteger (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeInteger :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeInteger(obj, steam, elementInfo);
public:
virtual int encodeInteger(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeInteger(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeNull Method

Grid Solutions Framework EncoderencodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeNull(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public MustOverride Function encodeNull (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeNull :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeNull(obj, stream, elementInfo);
public:
virtual int encodeNull(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeNull(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeObjectIdentifier Method

Grid Solutions Framework EncoderencodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeObjectIdentifier(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public MustOverride Function encodeObjectIdentifier (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeObjectIdentifier :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeObjectIdentifier(obj, stream, elementInfo);
public:
virtual int encodeObjectIdentifier(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeObjectIdentifier(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeOctetString Method

Grid Solutions Framework EncoderencodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeOctetString(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Public MustOverride Function encodeOctetString (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeOctetString :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeOctetString(obj, steam, elementInfo);
public:
virtual int encodeOctetString(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeOctetString(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodePreparedElement Method

Grid Solutions Framework EncoderencodePreparedElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int encodePreparedElement(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Function encodePreparedElement (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodePreparedElement :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodePreparedElement :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodePreparedElement(obj, stream, elementInfo);
public:
virtual int encodePreparedElement(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) sealed

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodePreparedElement(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeReal Method

Grid Solutions Framework EncoderencodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeReal(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Public MustOverride Function encodeReal (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeReal :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeReal(obj, steam, elementInfo);
public:
virtual int encodeReal(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeReal(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeSequence Method

Grid Solutions Framework EncoderencodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeSequence(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeSequence (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequence :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSequence :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSequence(obj, stream, elementInfo);
public:
virtual int encodeSequence(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeSequence(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeSequenceField Method

Grid Solutions Framework EncoderencodeSequenceField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceField(System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeSequenceField(
    Object obj,
    int fieldIdx,
    PropertyInfo field,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeSequenceField (
    obj As Object,
    fieldIdx As Integer,
    field As PropertyInfo,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequenceField :
        obj : Object *
        fieldIdx : int *
        field : PropertyInfo *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSequenceField :
        obj : Object *
        fieldIdx : int *
        field : PropertyInfo *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSequenceField(obj, fieldIdx, field, stream, elementInfo);
public:
virtual int encodeSequenceField(
    Object^ obj,
    int fieldIdx,
    PropertyInfo^ field,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceField(System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

fieldIdx
Type: SystemInt32

[Missing <param name="fieldIdx"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceField(System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceField(System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceField(System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceField(System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceField(System.Object,System.Int32,System.Reflection.PropertyInfo,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeSequenceOf Method

Grid Solutions Framework EncoderencodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeSequenceOf(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Public MustOverride Function encodeSequenceOf (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequenceOf :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeSequenceOf(obj, steam, elementInfo);
public:
virtual int encodeSequenceOf(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeSequenceOf(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.encodeString Method

Grid Solutions Framework EncoderencodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encodeString(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Public MustOverride Function encodeString (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeString :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeString(obj, steam, elementInfo);
public:
virtual int encodeString(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
) abstract

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeString(Object, Stream, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.getChoiceSelectedElement Method

Grid Solutions Framework EncodergetChoiceSelectedElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.getChoiceSelectedElement(System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ElementInfo getChoiceSelectedElement(
    Object obj,
    ElementInfo elementInfo
)
Protected Function getChoiceSelectedElement (
    obj As Object,
    elementInfo As ElementInfo
) As ElementInfo
member getChoiceSelectedElement :
        obj : Object *
        elementInfo : ElementInfo -> ElementInfo

function getChoiceSelectedElement(obj, elementInfo);
protected:
ElementInfo^ getChoiceSelectedElement(
    Object^ obj,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.getChoiceSelectedElement(System.Object,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.Encoder.getChoiceSelectedElement(System.Object,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: ElementInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.getChoiceSelectedElement(System.Object,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.invokeGetterMethodForField Method

Grid Solutions Framework EncoderinvokeGetterMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Object invokeGetterMethodForField(
    PropertyInfo field,
    Object obj,
    ElementInfo info
)
Public Overridable Function invokeGetterMethodForField (
    field As PropertyInfo,
    obj As Object,
    info As ElementInfo
) As Object
abstract invokeGetterMethodForField :
        field : PropertyInfo *
        obj : Object *
        info : ElementInfo -> Object
override invokeGetterMethodForField :
        field : PropertyInfo *
        obj : Object *
        info : ElementInfo -> Object
function invokeGetterMethodForField(field, obj, info);
public:
virtual Object^ invokeGetterMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    ElementInfo^ info
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.Encoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.Encoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderinvokeGetterMethodForField(PropertyInfo, Object, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


Encoder.invokeSelectedMethodForField Method

Grid Solutions Framework EncoderinvokeSelectedMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.Encoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool invokeSelectedMethodForField(
    PropertyInfo field,
    Object obj,
    ElementInfo info
)
Public Overridable Function invokeSelectedMethodForField (
    field As PropertyInfo,
    obj As Object,
    info As ElementInfo
) As Boolean
abstract invokeSelectedMethodForField :
        field : PropertyInfo *
        obj : Object *
        info : ElementInfo -> bool
override invokeSelectedMethodForField :
        field : PropertyInfo *
        obj : Object *
        info : ElementInfo -> bool
function invokeSelectedMethodForField(field, obj, info);
public:
virtual bool invokeSelectedMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    ElementInfo^ info
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.Encoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.Encoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.Encoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.Encoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderinvokeSelectedMethodForField(PropertyInfo, Object, ElementInfo)
See Also

Reference

Encoder Class
GSF.ASN1.Coders Namespace


IASN1PreparedElement Interface

Grid Solutions Framework IASN1PreparedElement Interface

[Missing <summary> documentation for "T:GSF.ASN1.Coders.IASN1PreparedElement"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IASN1PreparedElement
Public Interface IASN1PreparedElement
type IASN1PreparedElement =  interface end
GSF.ASN1.Coders.IASN1PreparedElement = function();
GSF.ASN1.Coders.IASN1PreparedElement.createInterface('GSF.ASN1.Coders.IASN1PreparedElement');
public interface class IASN1PreparedElement

The IASN1PreparedElement type exposes the following members.

Methods
 | Name | Description
Public method | initWithDefaults |
Top
Properties
 | Name | Description
Public property | PreparedData |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


IASN1PreparedElement Methods

Grid Solutions Framework IASN1PreparedElement Methods

The IASN1PreparedElement type exposes the following members.

Methods
 | Name | Description
Public method | initWithDefaults |
Top
See Also

Reference

IASN1PreparedElement Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElement.initWithDefaults Method

Grid Solutions Framework IASN1PreparedElementinitWithDefaults Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElement.initWithDefaults"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void initWithDefaults()
Sub initWithDefaults
abstract initWithDefaults : unit -> unit

function initWithDefaults();
void initWithDefaults()
See Also

Reference

IASN1PreparedElement Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElement Properties

Grid Solutions Framework IASN1PreparedElement Properties

The IASN1PreparedElement type exposes the following members.

Properties
 | Name | Description
Public property | PreparedData |
Top
See Also

Reference

IASN1PreparedElement Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElement.PreparedData Property

Grid Solutions Framework IASN1PreparedElementPreparedData Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElement.PreparedData"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IASN1PreparedElementData PreparedData { get; }
ReadOnly Property PreparedData As IASN1PreparedElementData
    Get
abstract PreparedData : IASN1PreparedElementData with get

function get_PreparedData();

property IASN1PreparedElementData^ PreparedData {
    IASN1PreparedElementData^ get ();
}

Property Value

Type: IASN1PreparedElementData
See Also

Reference

IASN1PreparedElement Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData Interface

Grid Solutions Framework IASN1PreparedElementData Interface

[Missing <summary> documentation for "T:GSF.ASN1.Coders.IASN1PreparedElementData"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IASN1PreparedElementData
Public Interface IASN1PreparedElementData
type IASN1PreparedElementData =  interface end
GSF.ASN1.Coders.IASN1PreparedElementData = function();
GSF.ASN1.Coders.IASN1PreparedElementData.createInterface('GSF.ASN1.Coders.IASN1PreparedElementData');
public interface class IASN1PreparedElementData

The IASN1PreparedElementData type exposes the following members.

Methods
 | Name | Description
Public method | getProperty |
Public method | getPropertyMetadata |
Public method | hasASN1ElementInfo |
Public method | hasConstraint |
Public method | invokeDoSelectMethod |
Public method | invokeIsSelectedMethod |
Top
Properties
 | Name | Description
Public property | ASN1ElementInfo |
Public property | Constraint |
Public property | IsPresentMethod |
Public property | Properties |
Public property | TypeMetadata |
Public property | ValueMetadata |
Public property | ValueProperty |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


IASN1PreparedElementData Methods

Grid Solutions Framework IASN1PreparedElementData Methods

The IASN1PreparedElementData type exposes the following members.

Methods
 | Name | Description
Public method | getProperty |
Public method | getPropertyMetadata |
Public method | hasASN1ElementInfo |
Public method | hasConstraint |
Public method | invokeDoSelectMethod |
Public method | invokeIsSelectedMethod |
Top
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.getProperty Method

Grid Solutions Framework IASN1PreparedElementDatagetProperty Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.getProperty(System.Int32)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
PropertyInfo getProperty(
    int index
)
Function getProperty (
    index As Integer
) As PropertyInfo
abstract getProperty :
        index : int -> PropertyInfo

function getProperty(index);
PropertyInfo^ getProperty(
    int index
)

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.getProperty(System.Int32)"]

Return Value

Type: PropertyInfo

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.getProperty(System.Int32)"]

See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.getPropertyMetadata Method

Grid Solutions Framework IASN1PreparedElementDatagetPropertyMetadata Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.getPropertyMetadata(System.Int32)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ASN1PreparedElementData getPropertyMetadata(
    int index
)
Function getPropertyMetadata (
    index As Integer
) As ASN1PreparedElementData
abstract getPropertyMetadata :
        index : int -> ASN1PreparedElementData

function getPropertyMetadata(index);
ASN1PreparedElementData^ getPropertyMetadata(
    int index
)

Parameters

index
Type: SystemInt32

[Missing <param name="index"/> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.getPropertyMetadata(System.Int32)"]

Return Value

Type: ASN1PreparedElementData

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.getPropertyMetadata(System.Int32)"]

See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.hasASN1ElementInfo Method

Grid Solutions Framework IASN1PreparedElementDatahasASN1ElementInfo Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.hasASN1ElementInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool hasASN1ElementInfo()
Function hasASN1ElementInfo As Boolean
abstract hasASN1ElementInfo : unit -> bool

function hasASN1ElementInfo();
bool hasASN1ElementInfo()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.hasASN1ElementInfo"]

See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.hasConstraint Method

Grid Solutions Framework IASN1PreparedElementDatahasConstraint Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.hasConstraint"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool hasConstraint()
Function hasConstraint As Boolean
abstract hasConstraint : unit -> bool

function hasConstraint();
bool hasConstraint()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.hasConstraint"]

See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.invokeDoSelectMethod Method

Grid Solutions Framework IASN1PreparedElementDatainvokeDoSelectMethod Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Object invokeDoSelectMethod(
    Object obj,
    Object param
)
Function invokeDoSelectMethod (
    obj As Object,
    param As Object
) As Object
abstract invokeDoSelectMethod :
        obj : Object *
        param : Object -> Object

function invokeDoSelectMethod(obj, param);
Object^ invokeDoSelectMethod(
    Object^ obj,
    Object^ param
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeDoSelectMethod(System.Object,System.Object)"]

See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.invokeIsSelectedMethod Method

Grid Solutions Framework IASN1PreparedElementDatainvokeIsSelectedMethod Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Object invokeIsSelectedMethod(
    Object obj,
    Object param
)
Function invokeIsSelectedMethod (
    obj As Object,
    param As Object
) As Object
abstract invokeIsSelectedMethod :
        obj : Object *
        param : Object -> Object

function invokeIsSelectedMethod(obj, param);
Object^ invokeIsSelectedMethod(
    Object^ obj,
    Object^ param
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1PreparedElementData.invokeIsSelectedMethod(System.Object,System.Object)"]

See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData Properties

Grid Solutions Framework IASN1PreparedElementData Properties

The IASN1PreparedElementData type exposes the following members.

Properties
 | Name | Description
Public property | ASN1ElementInfo |
Public property | Constraint |
Public property | IsPresentMethod |
Public property | Properties |
Public property | TypeMetadata |
Public property | ValueMetadata |
Public property | ValueProperty |
Top
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.ASN1ElementInfo Property

Grid Solutions Framework IASN1PreparedElementDataASN1ElementInfo Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElementData.ASN1ElementInfo"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ASN1ElementMetadata ASN1ElementInfo { get; }
ReadOnly Property ASN1ElementInfo As ASN1ElementMetadata
    Get
abstract ASN1ElementInfo : ASN1ElementMetadata with get

function get_ASN1ElementInfo();

property ASN1ElementMetadata^ ASN1ElementInfo {
    ASN1ElementMetadata^ get ();
}

Property Value

Type: ASN1ElementMetadata
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.Constraint Property

Grid Solutions Framework IASN1PreparedElementDataConstraint Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElementData.Constraint"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IASN1ConstraintMetadata Constraint { get; }
ReadOnly Property Constraint As IASN1ConstraintMetadata
    Get
abstract Constraint : IASN1ConstraintMetadata with get

function get_Constraint();

property IASN1ConstraintMetadata^ Constraint {
    IASN1ConstraintMetadata^ get ();
}

Property Value

Type: IASN1ConstraintMetadata
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.IsPresentMethod Property

Grid Solutions Framework IASN1PreparedElementDataIsPresentMethod Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElementData.IsPresentMethod"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MethodInfo IsPresentMethod { get; }
ReadOnly Property IsPresentMethod As MethodInfo
    Get
abstract IsPresentMethod : MethodInfo with get

function get_IsPresentMethod();

property MethodInfo^ IsPresentMethod {
    MethodInfo^ get ();
}

Property Value

Type: MethodInfo
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.Properties Property

Grid Solutions Framework IASN1PreparedElementDataProperties Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElementData.Properties"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
PropertyInfo[] Properties { get; }
ReadOnly Property Properties As PropertyInfo()
    Get
abstract Properties : PropertyInfo[] with get

function get_Properties();

property array<PropertyInfo^>^ Properties {
    array<PropertyInfo^>^ get ();
}

Property Value

Type: PropertyInfo
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.TypeMetadata Property

Grid Solutions Framework IASN1PreparedElementDataTypeMetadata Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElementData.TypeMetadata"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ASN1Metadata TypeMetadata { get; }
ReadOnly Property TypeMetadata As ASN1Metadata
    Get
abstract TypeMetadata : ASN1Metadata with get

function get_TypeMetadata();

property ASN1Metadata^ TypeMetadata {
    ASN1Metadata^ get ();
}

Property Value

Type: ASN1Metadata
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.ValueMetadata Property

Grid Solutions Framework IASN1PreparedElementDataValueMetadata Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElementData.ValueMetadata"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ASN1PreparedElementData ValueMetadata { get; }
ReadOnly Property ValueMetadata As ASN1PreparedElementData
    Get
abstract ValueMetadata : ASN1PreparedElementData with get

function get_ValueMetadata();

property ASN1PreparedElementData^ ValueMetadata {
    ASN1PreparedElementData^ get ();
}

Property Value

Type: ASN1PreparedElementData
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1PreparedElementData.ValueProperty Property

Grid Solutions Framework IASN1PreparedElementDataValueProperty Property

[Missing <summary> documentation for "P:GSF.ASN1.Coders.IASN1PreparedElementData.ValueProperty"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
PropertyInfo ValueProperty { get; }
ReadOnly Property ValueProperty As PropertyInfo
    Get
abstract ValueProperty : PropertyInfo with get

function get_ValueProperty();

property PropertyInfo^ ValueProperty {
    PropertyInfo^ get ();
}

Property Value

Type: PropertyInfo
See Also

Reference

IASN1PreparedElementData Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder Interface

Grid Solutions Framework IASN1TypesDecoder Interface

[Missing <summary> documentation for "T:GSF.ASN1.Coders.IASN1TypesDecoder"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IASN1TypesDecoder
Public Interface IASN1TypesDecoder
type IASN1TypesDecoder =  interface end
GSF.ASN1.Coders.IASN1TypesDecoder = function();
GSF.ASN1.Coders.IASN1TypesDecoder.createInterface('GSF.ASN1.Coders.IASN1TypesDecoder');
public interface class IASN1TypesDecoder

The IASN1TypesDecoder type exposes the following members.

Methods
 | Name | Description
Public method | decodeAny |
Public method | decodeBitString |
Public method | decodeBoolean |
Public method | decodeBoxedType |
Public method | decodeChoice |
Public method | decodeClassType |
Public method | decodeElement |
Public method | decodeEnum |
Public method | decodeEnumItem |
Public method | decodeInteger |
Public method | decodeNull |
Public method | decodeObjectIdentifier |
Public method | decodeOctetString |
Public method | decodePreparedElement |
Public method | decodeReal |
Public method | decodeSequence |
Public method | decodeSequenceOf |
Public method | decodeString |
Public method | decodeTag |
Public method | invokeSelectMethodForField |
Public method | invokeSetterMethodForField |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


IASN1TypesDecoder Methods

Grid Solutions Framework IASN1TypesDecoder Methods

The IASN1TypesDecoder type exposes the following members.

Methods
 | Name | Description
Public method | decodeAny |
Public method | decodeBitString |
Public method | decodeBoolean |
Public method | decodeBoxedType |
Public method | decodeChoice |
Public method | decodeClassType |
Public method | decodeElement |
Public method | decodeEnum |
Public method | decodeEnumItem |
Public method | decodeInteger |
Public method | decodeNull |
Public method | decodeObjectIdentifier |
Public method | decodeOctetString |
Public method | decodePreparedElement |
Public method | decodeReal |
Public method | decodeSequence |
Public method | decodeSequenceOf |
Public method | decodeString |
Public method | decodeTag |
Public method | invokeSelectMethodForField |
Public method | invokeSetterMethodForField |
Top
See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeAny Method

Grid Solutions Framework IASN1TypesDecoderdecodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeAny(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeAny (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeAny :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeAny(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeAny(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeBitString Method

Grid Solutions Framework IASN1TypesDecoderdecodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeBitString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeBitString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBitString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeBitString(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeBitString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeBoolean Method

Grid Solutions Framework IASN1TypesDecoderdecodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeBoolean(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeBoolean (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBoolean :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeBoolean(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeBoolean(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeBoxedType Method

Grid Solutions Framework IASN1TypesDecoderdecodeBoxedType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeBoxedType(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeBoxedType (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBoxedType :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeBoxedType(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeBoxedType(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeBoxedType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeChoice Method

Grid Solutions Framework IASN1TypesDecoderdecodeChoice Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeChoice(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeChoice (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeChoice :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeChoice(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeChoice(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeClassType Method

Grid Solutions Framework IASN1TypesDecoderdecodeClassType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeClassType(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeClassType (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeClassType :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeClassType(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeClassType(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeClassType(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeElement Method

Grid Solutions Framework IASN1TypesDecoderdecodeElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeElement(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeElement (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeElement(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeElement(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeEnum Method

Grid Solutions Framework IASN1TypesDecoderdecodeEnum Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeEnum(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeEnum (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeEnum :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeEnum(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeEnum(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnum(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeEnumItem Method

Grid Solutions Framework IASN1TypesDecoderdecodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeEnumItem(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    Type enumClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeEnumItem (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    enumClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeEnumItem :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        enumClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeEnumItem(decodedTag, objectClass, enumClass, elementInfo, stream);
DecodedObject<Object^>^ decodeEnumItem(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    Type^ enumClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeInteger Method

Grid Solutions Framework IASN1TypesDecoderdecodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeInteger(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeInteger (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeInteger :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeInteger(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeInteger(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeNull Method

Grid Solutions Framework IASN1TypesDecoderdecodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeNull(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeNull (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeNull :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeNull(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeNull(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeObjectIdentifier Method

Grid Solutions Framework IASN1TypesDecoderdecodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeObjectIdentifier(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeObjectIdentifier (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeObjectIdentifier :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeObjectIdentifier(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeObjectIdentifier(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeOctetString Method

Grid Solutions Framework IASN1TypesDecoderdecodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeOctetString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeOctetString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeOctetString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeOctetString(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeOctetString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodePreparedElement Method

Grid Solutions Framework IASN1TypesDecoderdecodePreparedElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodePreparedElement(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodePreparedElement (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodePreparedElement :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodePreparedElement(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodePreparedElement(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodePreparedElement(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeReal Method

Grid Solutions Framework IASN1TypesDecoderdecodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeReal(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeReal (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeReal :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeReal(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeReal(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeSequence Method

Grid Solutions Framework IASN1TypesDecoderdecodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeSequence(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeSequence (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequence :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeSequence(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeSequence(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeSequenceOf Method

Grid Solutions Framework IASN1TypesDecoderdecodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeSequenceOf(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeSequenceOf (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequenceOf :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeSequenceOf(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeSequenceOf(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeString Method

Grid Solutions Framework IASN1TypesDecoderdecodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decodeString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decodeString(decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decodeString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.decodeTag Method

Grid Solutions Framework IASN1TypesDecoderdecodeTag Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeTag(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decodeTag(
    Stream stream
)
Function decodeTag (
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeTag :
        stream : Stream -> DecodedObject<Object>

function decodeTag(stream);
DecodedObject<Object^>^ decodeTag(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeTag(System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.decodeTag(System.IO.Stream)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.invokeSelectMethodForField Method

Grid Solutions Framework IASN1TypesDecoderinvokeSelectMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void invokeSelectMethodForField(
    PropertyInfo field,
    Object obj,
    Object param,
    ElementInfo elementInfo
)
Sub invokeSelectMethodForField (
    field As PropertyInfo,
    obj As Object,
    param As Object,
    elementInfo As ElementInfo
)
abstract invokeSelectMethodForField :
        field : PropertyInfo *
        obj : Object *
        param : Object *
        elementInfo : ElementInfo -> unit

function invokeSelectMethodForField(field, obj, param, elementInfo);
void invokeSelectMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    Object^ param,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSelectMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesDecoder.invokeSetterMethodForField Method

Grid Solutions Framework IASN1TypesDecoderinvokeSetterMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void invokeSetterMethodForField(
    PropertyInfo field,
    Object obj,
    Object param,
    ElementInfo elementInfo
)
Sub invokeSetterMethodForField (
    field As PropertyInfo,
    obj As Object,
    param As Object,
    elementInfo As ElementInfo
)
abstract invokeSetterMethodForField :
        field : PropertyInfo *
        obj : Object *
        param : Object *
        elementInfo : ElementInfo -> unit

function invokeSetterMethodForField(field, obj, param, elementInfo);
void invokeSetterMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    Object^ param,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

param
Type: SystemObject

[Missing <param name="param"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesDecoder.invokeSetterMethodForField(System.Reflection.PropertyInfo,System.Object,System.Object,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesDecoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder Interface

Grid Solutions Framework IASN1TypesEncoder Interface

[Missing <summary> documentation for "T:GSF.ASN1.Coders.IASN1TypesEncoder"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IASN1TypesEncoder
Public Interface IASN1TypesEncoder
type IASN1TypesEncoder =  interface end
GSF.ASN1.Coders.IASN1TypesEncoder = function();
GSF.ASN1.Coders.IASN1TypesEncoder.createInterface('GSF.ASN1.Coders.IASN1TypesEncoder');
public interface class IASN1TypesEncoder

The IASN1TypesEncoder type exposes the following members.

Methods
 | Name | Description
Public method | encodeAny |
Public method | encodeBitString |
Public method | encodeBoolean |
Public method | encodeBoxedType |
Public method | encodeChoice |
Public method | encodeClassType |
Public method | encodeElement |
Public method | encodeEnum |
Public method | encodeEnumItem |
Public method | encodeInteger |
Public method | encodeNull |
Public method | encodeObjectIdentifier |
Public method | encodeOctetString |
Public method | encodePreparedElement |
Public method | encodeReal |
Public method | encodeSequence |
Public method | encodeSequenceOf |
Public method | encodeString |
Public method | invokeGetterMethodForField |
Public method | invokeSelectedMethodForField |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


IASN1TypesEncoder Methods

Grid Solutions Framework IASN1TypesEncoder Methods

The IASN1TypesEncoder type exposes the following members.

Methods
 | Name | Description
Public method | encodeAny |
Public method | encodeBitString |
Public method | encodeBoolean |
Public method | encodeBoxedType |
Public method | encodeChoice |
Public method | encodeClassType |
Public method | encodeElement |
Public method | encodeEnum |
Public method | encodeEnumItem |
Public method | encodeInteger |
Public method | encodeNull |
Public method | encodeObjectIdentifier |
Public method | encodeOctetString |
Public method | encodePreparedElement |
Public method | encodeReal |
Public method | encodeSequence |
Public method | encodeSequenceOf |
Public method | encodeString |
Public method | invokeGetterMethodForField |
Public method | invokeSelectedMethodForField |
Top
See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeAny Method

Grid Solutions Framework IASN1TypesEncoderencodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeAny(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeAny (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeAny :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeAny(obj, stream, elementInfo);
int encodeAny(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeBitString Method

Grid Solutions Framework IASN1TypesEncoderencodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeBitString(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Function encodeBitString (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBitString :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeBitString(obj, steam, elementInfo);
int encodeBitString(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeBoolean Method

Grid Solutions Framework IASN1TypesEncoderencodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeBoolean(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeBoolean (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBoolean :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeBoolean(obj, stream, elementInfo);
int encodeBoolean(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeBoxedType Method

Grid Solutions Framework IASN1TypesEncoderencodeBoxedType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeBoxedType(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeBoxedType (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBoxedType :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeBoxedType(obj, stream, elementInfo);
int encodeBoxedType(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeBoxedType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeChoice Method

Grid Solutions Framework IASN1TypesEncoderencodeChoice Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeChoice(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeChoice (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeChoice :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeChoice(obj, stream, elementInfo);
int encodeChoice(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeClassType Method

Grid Solutions Framework IASN1TypesEncoderencodeClassType Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeClassType(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeClassType (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeClassType :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeClassType(obj, stream, elementInfo);
int encodeClassType(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeClassType(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeElement Method

Grid Solutions Framework IASN1TypesEncoderencodeElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeElement(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeElement (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeElement :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeElement(obj, stream, elementInfo);
int encodeElement(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeEnum Method

Grid Solutions Framework IASN1TypesEncoderencodeEnum Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeEnum(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeEnum (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeEnum :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeEnum(obj, stream, elementInfo);
int encodeEnum(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnum(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeEnumItem Method

Grid Solutions Framework IASN1TypesEncoderencodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeEnumItem(
    Object enumConstant,
    Type enumClass,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeEnumItem (
    enumConstant As Object,
    enumClass As Type,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeEnumItem :
        enumConstant : Object *
        enumClass : Type *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeEnumItem(enumConstant, enumClass, stream, elementInfo);
int encodeEnumItem(
    Object^ enumConstant,
    Type^ enumClass,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

enumConstant
Type: SystemObject

[Missing <param name="enumConstant"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeInteger Method

Grid Solutions Framework IASN1TypesEncoderencodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeInteger(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Function encodeInteger (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeInteger :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeInteger(obj, steam, elementInfo);
int encodeInteger(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeNull Method

Grid Solutions Framework IASN1TypesEncoderencodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeNull(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeNull (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeNull :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeNull(obj, stream, elementInfo);
int encodeNull(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeObjectIdentifier Method

Grid Solutions Framework IASN1TypesEncoderencodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeObjectIdentifier(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Function encodeObjectIdentifier (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeObjectIdentifier :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeObjectIdentifier(obj, steam, elementInfo);
int encodeObjectIdentifier(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeOctetString Method

Grid Solutions Framework IASN1TypesEncoderencodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeOctetString(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Function encodeOctetString (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeOctetString :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeOctetString(obj, steam, elementInfo);
int encodeOctetString(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodePreparedElement Method

Grid Solutions Framework IASN1TypesEncoderencodePreparedElement Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodePreparedElement(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodePreparedElement (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodePreparedElement :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodePreparedElement(obj, stream, elementInfo);
int encodePreparedElement(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodePreparedElement(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeReal Method

Grid Solutions Framework IASN1TypesEncoderencodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeReal(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Function encodeReal (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeReal :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeReal(obj, steam, elementInfo);
int encodeReal(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeSequence Method

Grid Solutions Framework IASN1TypesEncoderencodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeSequence(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encodeSequence (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequence :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encodeSequence(obj, stream, elementInfo);
int encodeSequence(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeSequenceOf Method

Grid Solutions Framework IASN1TypesEncoderencodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeSequenceOf(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Function encodeSequenceOf (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequenceOf :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeSequenceOf(obj, steam, elementInfo);
int encodeSequenceOf(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.encodeString Method

Grid Solutions Framework IASN1TypesEncoderencodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encodeString(
    Object obj,
    Stream steam,
    ElementInfo elementInfo
)
Function encodeString (
    obj As Object,
    steam As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeString :
        obj : Object *
        steam : Stream *
        elementInfo : ElementInfo -> int

function encodeString(obj, steam, elementInfo);
int encodeString(
    Object^ obj,
    Stream^ steam,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

steam
Type: System.IOStream

[Missing <param name="steam"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.invokeGetterMethodForField Method

Grid Solutions Framework IASN1TypesEncoderinvokeGetterMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Object invokeGetterMethodForField(
    PropertyInfo field,
    Object obj,
    ElementInfo elementInfo
)
Function invokeGetterMethodForField (
    field As PropertyInfo,
    obj As Object,
    elementInfo As ElementInfo
) As Object
abstract invokeGetterMethodForField :
        field : PropertyInfo *
        obj : Object *
        elementInfo : ElementInfo -> Object

function invokeGetterMethodForField(field, obj, elementInfo);
Object^ invokeGetterMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeGetterMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


IASN1TypesEncoder.invokeSelectedMethodForField Method

Grid Solutions Framework IASN1TypesEncoderinvokeSelectedMethodForField Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool invokeSelectedMethodForField(
    PropertyInfo field,
    Object obj,
    ElementInfo elementInfo
)
Function invokeSelectedMethodForField (
    field As PropertyInfo,
    obj As Object,
    elementInfo As ElementInfo
) As Boolean
abstract invokeSelectedMethodForField :
        field : PropertyInfo *
        obj : Object *
        elementInfo : ElementInfo -> bool

function invokeSelectedMethodForField(field, obj, elementInfo);
bool invokeSelectedMethodForField(
    PropertyInfo^ field,
    Object^ obj,
    ElementInfo^ elementInfo
)

Parameters

field
Type: System.ReflectionPropertyInfo

[Missing <param name="field"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.IASN1TypesEncoder.invokeSelectedMethodForField(System.Reflection.PropertyInfo,System.Object,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1TypesEncoder Interface
GSF.ASN1.Coders Namespace


TagClasses Structure

Grid Solutions Framework TagClasses Structure

[Missing <summary> documentation for "T:GSF.ASN1.Coders.TagClasses"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct TagClasses
Public Structure TagClasses
[<SealedAttribute>]
type TagClasses =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class TagClasses

The TagClasses type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Application |
ContextSpecific |
Private |
Universal |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


TagClasses Fields

Grid Solutions Framework TagClasses Fields

The TagClasses type exposes the following members.

Fields
Name | Description
Application |
ContextSpecific |
Private |
Universal |
Top
See Also

Reference

TagClasses Structure
GSF.ASN1.Coders Namespace


TagClasses.Application Field

Grid Solutions Framework TagClassesApplication Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.TagClasses.Application"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Application
Public Const Application As Integer
static val mutable Application: int
var GSF.ASN1.Coders.TagClasses.Application
public:
literal int Application

Field Value

Type: Int32
See Also

Reference

TagClasses Structure
GSF.ASN1.Coders Namespace


TagClasses.ContextSpecific Field

Grid Solutions Framework TagClassesContextSpecific Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.TagClasses.ContextSpecific"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ContextSpecific
Public Const ContextSpecific As Integer
static val mutable ContextSpecific: int
var GSF.ASN1.Coders.TagClasses.ContextSpecific
public:
literal int ContextSpecific

Field Value

Type: Int32
See Also

Reference

TagClasses Structure
GSF.ASN1.Coders Namespace


TagClasses.Private Field

Grid Solutions Framework TagClassesPrivate Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.TagClasses.Private"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Private
Public Const Private As Integer
static val mutable Private: int
var GSF.ASN1.Coders.TagClasses.Private
public:
literal int Private

Field Value

Type: Int32
See Also

Reference

TagClasses Structure
GSF.ASN1.Coders Namespace


TagClasses.Universal Field

Grid Solutions Framework TagClassesUniversal Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.TagClasses.Universal"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Universal
Public Const Universal As Integer
static val mutable Universal: int
var GSF.ASN1.Coders.TagClasses.Universal
public:
literal int Universal

Field Value

Type: Int32
See Also

Reference

TagClasses Structure
GSF.ASN1.Coders Namespace


TagClasses Methods

Grid Solutions Framework TagClasses Methods

The TagClasses type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TagClasses Structure
GSF.ASN1.Coders Namespace


UniversalTags Structure

Grid Solutions Framework UniversalTags Structure

[Missing <summary> documentation for "T:GSF.ASN1.Coders.UniversalTags"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct UniversalTags
Public Structure UniversalTags
[<SealedAttribute>]
type UniversalTags =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class UniversalTags

The UniversalTags type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Bitstring |
BMPString |
Boolean |
EmbeddedPdv |
Enumerated |
External |
GeneralizedTime |
GeneralString |
GraphicString |
IA5String |
Integer |
LastUniversal |
Null |
NumericString |
ObjectDescriptor |
ObjectIdentifier |
OctetString |
PrintableString |
Real |
RelativeObject |
Reserved0 |
Reserved14 |
Reserved15 |
Sequence |
Set |
TeletexString |
UniversalString |
UnspecifiedString |
UTCTime |
UTF8String |
VideotexString |
VisibleString |
Top
See Also

Reference

GSF.ASN1.Coders Namespace


UniversalTags Fields

Grid Solutions Framework UniversalTags Fields

The UniversalTags type exposes the following members.

Fields
Name | Description
Bitstring |
BMPString |
Boolean |
EmbeddedPdv |
Enumerated |
External |
GeneralizedTime |
GeneralString |
GraphicString |
IA5String |
Integer |
LastUniversal |
Null |
NumericString |
ObjectDescriptor |
ObjectIdentifier |
OctetString |
PrintableString |
Real |
RelativeObject |
Reserved0 |
Reserved14 |
Reserved15 |
Sequence |
Set |
TeletexString |
UniversalString |
UnspecifiedString |
UTCTime |
UTF8String |
VideotexString |
VisibleString |
Top
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Bitstring Field

Grid Solutions Framework UniversalTagsBitstring Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Bitstring"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Bitstring
Public Const Bitstring As Integer
static val mutable Bitstring: int
var GSF.ASN1.Coders.UniversalTags.Bitstring
public:
literal int Bitstring

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.BMPString Field

Grid Solutions Framework UniversalTagsBMPString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.BMPString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int BMPString
Public Const BMPString As Integer
static val mutable BMPString: int
var GSF.ASN1.Coders.UniversalTags.BMPString
public:
literal int BMPString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Boolean Field

Grid Solutions Framework UniversalTagsBoolean Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Boolean"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Boolean
Public Const Boolean As Integer
static val mutable Boolean: int
var GSF.ASN1.Coders.UniversalTags.Boolean
public:
literal int Boolean

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.EmbeddedPdv Field

Grid Solutions Framework UniversalTagsEmbeddedPdv Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.EmbeddedPdv"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int EmbeddedPdv
Public Const EmbeddedPdv As Integer
static val mutable EmbeddedPdv: int
var GSF.ASN1.Coders.UniversalTags.EmbeddedPdv
public:
literal int EmbeddedPdv

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Enumerated Field

Grid Solutions Framework UniversalTagsEnumerated Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Enumerated"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Enumerated
Public Const Enumerated As Integer
static val mutable Enumerated: int
var GSF.ASN1.Coders.UniversalTags.Enumerated
public:
literal int Enumerated

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.External Field

Grid Solutions Framework UniversalTagsExternal Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.External"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int External
Public Const External As Integer
static val mutable External: int
var GSF.ASN1.Coders.UniversalTags.External
public:
literal int External

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.GeneralizedTime Field

Grid Solutions Framework UniversalTagsGeneralizedTime Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.GeneralizedTime"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int GeneralizedTime
Public Const GeneralizedTime As Integer
static val mutable GeneralizedTime: int
var GSF.ASN1.Coders.UniversalTags.GeneralizedTime
public:
literal int GeneralizedTime

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.GeneralString Field

Grid Solutions Framework UniversalTagsGeneralString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.GeneralString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int GeneralString
Public Const GeneralString As Integer
static val mutable GeneralString: int
var GSF.ASN1.Coders.UniversalTags.GeneralString
public:
literal int GeneralString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.GraphicString Field

Grid Solutions Framework UniversalTagsGraphicString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.GraphicString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int GraphicString
Public Const GraphicString As Integer
static val mutable GraphicString: int
var GSF.ASN1.Coders.UniversalTags.GraphicString
public:
literal int GraphicString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.IA5String Field

Grid Solutions Framework UniversalTagsIA5String Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.IA5String"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int IA5String
Public Const IA5String As Integer
static val mutable IA5String: int
var GSF.ASN1.Coders.UniversalTags.IA5String
public:
literal int IA5String

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Integer Field

Grid Solutions Framework UniversalTagsInteger Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Integer"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Integer
Public Const Integer As Integer
static val mutable Integer: int
var GSF.ASN1.Coders.UniversalTags.Integer
public:
literal int Integer

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.LastUniversal Field

Grid Solutions Framework UniversalTagsLastUniversal Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.LastUniversal"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int LastUniversal
Public Const LastUniversal As Integer
static val mutable LastUniversal: int
var GSF.ASN1.Coders.UniversalTags.LastUniversal
public:
literal int LastUniversal

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Null Field

Grid Solutions Framework UniversalTagsNull Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Null"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Null
Public Const Null As Integer
static val mutable Null: int
var GSF.ASN1.Coders.UniversalTags.Null
public:
literal int Null

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.NumericString Field

Grid Solutions Framework UniversalTagsNumericString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.NumericString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int NumericString
Public Const NumericString As Integer
static val mutable NumericString: int
var GSF.ASN1.Coders.UniversalTags.NumericString
public:
literal int NumericString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.ObjectDescriptor Field

Grid Solutions Framework UniversalTagsObjectDescriptor Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.ObjectDescriptor"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ObjectDescriptor
Public Const ObjectDescriptor As Integer
static val mutable ObjectDescriptor: int
var GSF.ASN1.Coders.UniversalTags.ObjectDescriptor
public:
literal int ObjectDescriptor

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.ObjectIdentifier Field

Grid Solutions Framework UniversalTagsObjectIdentifier Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.ObjectIdentifier"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ObjectIdentifier
Public Const ObjectIdentifier As Integer
static val mutable ObjectIdentifier: int
var GSF.ASN1.Coders.UniversalTags.ObjectIdentifier
public:
literal int ObjectIdentifier

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.OctetString Field

Grid Solutions Framework UniversalTagsOctetString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.OctetString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int OctetString
Public Const OctetString As Integer
static val mutable OctetString: int
var GSF.ASN1.Coders.UniversalTags.OctetString
public:
literal int OctetString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.PrintableString Field

Grid Solutions Framework UniversalTagsPrintableString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.PrintableString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int PrintableString
Public Const PrintableString As Integer
static val mutable PrintableString: int
var GSF.ASN1.Coders.UniversalTags.PrintableString
public:
literal int PrintableString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Real Field

Grid Solutions Framework UniversalTagsReal Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Real"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Real
Public Const Real As Integer
static val mutable Real: int
var GSF.ASN1.Coders.UniversalTags.Real
public:
literal int Real

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.RelativeObject Field

Grid Solutions Framework UniversalTagsRelativeObject Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.RelativeObject"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int RelativeObject
Public Const RelativeObject As Integer
static val mutable RelativeObject: int
var GSF.ASN1.Coders.UniversalTags.RelativeObject
public:
literal int RelativeObject

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Reserved0 Field

Grid Solutions Framework UniversalTagsReserved0 Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Reserved0"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Reserved0
Public Const Reserved0 As Integer
static val mutable Reserved0: int
var GSF.ASN1.Coders.UniversalTags.Reserved0
public:
literal int Reserved0

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Reserved14 Field

Grid Solutions Framework UniversalTagsReserved14 Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Reserved14"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Reserved14
Public Const Reserved14 As Integer
static val mutable Reserved14: int
var GSF.ASN1.Coders.UniversalTags.Reserved14
public:
literal int Reserved14

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Reserved15 Field

Grid Solutions Framework UniversalTagsReserved15 Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Reserved15"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Reserved15
Public Const Reserved15 As Integer
static val mutable Reserved15: int
var GSF.ASN1.Coders.UniversalTags.Reserved15
public:
literal int Reserved15

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Sequence Field

Grid Solutions Framework UniversalTagsSequence Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Sequence"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Sequence
Public Const Sequence As Integer
static val mutable Sequence: int
var GSF.ASN1.Coders.UniversalTags.Sequence
public:
literal int Sequence

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.Set Field

Grid Solutions Framework UniversalTagsSet Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.Set"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Set
Public Const Set As Integer
static val mutable Set: int
var GSF.ASN1.Coders.UniversalTags.Set
public:
literal int Set

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.TeletexString Field

Grid Solutions Framework UniversalTagsTeletexString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.TeletexString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int TeletexString
Public Const TeletexString As Integer
static val mutable TeletexString: int
var GSF.ASN1.Coders.UniversalTags.TeletexString
public:
literal int TeletexString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.UniversalString Field

Grid Solutions Framework UniversalTagsUniversalString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.UniversalString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int UniversalString
Public Const UniversalString As Integer
static val mutable UniversalString: int
var GSF.ASN1.Coders.UniversalTags.UniversalString
public:
literal int UniversalString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.UnspecifiedString Field

Grid Solutions Framework UniversalTagsUnspecifiedString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.UnspecifiedString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int UnspecifiedString
Public Const UnspecifiedString As Integer
static val mutable UnspecifiedString: int
var GSF.ASN1.Coders.UniversalTags.UnspecifiedString
public:
literal int UnspecifiedString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.UTCTime Field

Grid Solutions Framework UniversalTagsUTCTime Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.UTCTime"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int UTCTime
Public Const UTCTime As Integer
static val mutable UTCTime: int
var GSF.ASN1.Coders.UniversalTags.UTCTime
public:
literal int UTCTime

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.UTF8String Field

Grid Solutions Framework UniversalTagsUTF8String Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.UTF8String"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int UTF8String
Public Const UTF8String As Integer
static val mutable UTF8String: int
var GSF.ASN1.Coders.UniversalTags.UTF8String
public:
literal int UTF8String

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.VideotexString Field

Grid Solutions Framework UniversalTagsVideotexString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.VideotexString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int VideotexString
Public Const VideotexString As Integer
static val mutable VideotexString: int
var GSF.ASN1.Coders.UniversalTags.VideotexString
public:
literal int VideotexString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags.VisibleString Field

Grid Solutions Framework UniversalTagsVisibleString Field

[Missing <summary> documentation for "F:GSF.ASN1.Coders.UniversalTags.VisibleString"]

Namespace: GSF.ASN1.Coders
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int VisibleString
Public Const VisibleString As Integer
static val mutable VisibleString: int
var GSF.ASN1.Coders.UniversalTags.VisibleString
public:
literal int VisibleString

Field Value

Type: Int32
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


UniversalTags Methods

Grid Solutions Framework UniversalTags Methods

The UniversalTags type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UniversalTags Structure
GSF.ASN1.Coders Namespace


GSF.ASN1.Coders.BER Namespace

Grid Solutions Framework GSF.ASN1.Coders.BER Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Coders.BER"]

Classes
 | Class | Description
Public class | BERDecoder |
Public class | BEREncoder |
Public class | BERObjectIdentifier |


BERDecoder Class

Grid Solutions Framework BERDecoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.BER.BERDecoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersDecoder
GSF.ASN1.Coders.BERBERDecoder

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BERDecoder : Decoder
Public Class BERDecoder
    Inherits Decoder
type BERDecoder =
    class
        inherit Decoder
    end
GSF.ASN1.Coders.BER.BERDecoder = function();

Type.createClass(
    'GSF.ASN1.Coders.BER.BERDecoder',
    GSF.ASN1.Coders.Decoder);
public ref class BERDecoder : public Decoder

The BERDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | BERDecoder | Initializes a new instance of the BERDecoder class
Top
Methods
 | Name | Description
Protected method | checkTagForObject |
Public method | createInstanceForElement | (Inherited from Decoder.)
Public method | decodeT | (Inherited from Decoder.)
Public method | decodeAny | (Overrides DecoderdecodeAny(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBitString | (Overrides DecoderdecodeBitString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoolean | (Overrides DecoderdecodeBoolean(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoxedType | (Inherited from Decoder.)
Public method | decodeChoice | (Overrides DecoderdecodeChoice(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeClassType | (Inherited from Decoder.)
Public method | decodeCSElement | (Inherited from Decoder.)
Public method | decodeCSEnum | (Inherited from Decoder.)
Public method | decodeElement | (Inherited from Decoder.)
Public method | decodeEnum | (Inherited from Decoder.)
Public method | decodeEnumItem | (Overrides DecoderdecodeEnumItem(DecodedObjectObject, Type, Type, ElementInfo, Stream).)
Public method | decodeInteger | (Overrides DecoderdecodeInteger(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeIntegerValue |
Protected method | decodeLength |
Protected method | decodeLongValue(Stream) |
Protected method | decodeLongValue(Stream, DecodedObjectInt32) |
Public method | decodeNull | (Overrides DecoderdecodeNull(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeObjectIdentifier | (Overrides DecoderdecodeObjectIdentifier(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeOctetString | (Overrides DecoderdecodeOctetString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodePreparedElement | (Inherited from Decoder.)
Public method | decodeReal | (Overrides DecoderdecodeReal(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeSequence | (Overrides DecoderdecodeSequence(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeSequenceField | (Inherited from Decoder.)
Public method | decodeSequenceOf | (Overrides DecoderdecodeSequenceOf(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeSet |
Public method | decodeString | (Overrides DecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeTag | (Overrides DecoderdecodeTag(Stream).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues | (Inherited from Decoder.)
Public method | invokeSelectMethodForField | (Inherited from Decoder.)
Public method | invokeSetterMethodForField | (Inherited from Decoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders.BER Namespace


BERDecoder Constructor

Grid Solutions Framework BERDecoder Constructor
Initializes a new instance of the BERDecoder class

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BERDecoder()
Public Sub New
new : unit -> BERDecoder
GSF.ASN1.Coders.BER.BERDecoder = function();
public:
BERDecoder()
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder Methods

Grid Solutions Framework BERDecoder Methods

The BERDecoder type exposes the following members.

Methods
 | Name | Description
Protected method | checkTagForObject |
Public method | createInstanceForElement | (Inherited from Decoder.)
Public method | decodeT | (Inherited from Decoder.)
Public method | decodeAny | (Overrides DecoderdecodeAny(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBitString | (Overrides DecoderdecodeBitString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoolean | (Overrides DecoderdecodeBoolean(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoxedType | (Inherited from Decoder.)
Public method | decodeChoice | (Overrides DecoderdecodeChoice(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeClassType | (Inherited from Decoder.)
Public method | decodeCSElement | (Inherited from Decoder.)
Public method | decodeCSEnum | (Inherited from Decoder.)
Public method | decodeElement | (Inherited from Decoder.)
Public method | decodeEnum | (Inherited from Decoder.)
Public method | decodeEnumItem | (Overrides DecoderdecodeEnumItem(DecodedObjectObject, Type, Type, ElementInfo, Stream).)
Public method | decodeInteger | (Overrides DecoderdecodeInteger(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeIntegerValue |
Protected method | decodeLength |
Protected method | decodeLongValue(Stream) |
Protected method | decodeLongValue(Stream, DecodedObjectInt32) |
Public method | decodeNull | (Overrides DecoderdecodeNull(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeObjectIdentifier | (Overrides DecoderdecodeObjectIdentifier(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeOctetString | (Overrides DecoderdecodeOctetString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodePreparedElement | (Inherited from Decoder.)
Public method | decodeReal | (Overrides DecoderdecodeReal(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeSequence | (Overrides DecoderdecodeSequence(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeSequenceField | (Inherited from Decoder.)
Public method | decodeSequenceOf | (Overrides DecoderdecodeSequenceOf(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeSet |
Public method | decodeString | (Overrides DecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeTag | (Overrides DecoderdecodeTag(Stream).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues | (Inherited from Decoder.)
Public method | invokeSelectMethodForField | (Inherited from Decoder.)
Public method | invokeSetterMethodForField | (Inherited from Decoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.checkTagForObject Method

Grid Solutions Framework BERDecodercheckTagForObject Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.checkTagForObject(GSF.ASN1.Coders.DecodedObject{System.Object},System.Int32,System.Int32,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool checkTagForObject(
    DecodedObject<Object> decodedTag,
    int tagClass,
    int elementType,
    int universalTag,
    ElementInfo elementInfo
)
Protected Function checkTagForObject (
    decodedTag As DecodedObject(Of Object),
    tagClass As Integer,
    elementType As Integer,
    universalTag As Integer,
    elementInfo As ElementInfo
) As Boolean
member checkTagForObject :
        decodedTag : DecodedObject<Object> *
        tagClass : int *
        elementType : int *
        universalTag : int *
        elementInfo : ElementInfo -> bool

function checkTagForObject(decodedTag, tagClass, elementType, universalTag, elementInfo);
protected:
bool checkTagForObject(
    DecodedObject<Object^>^ decodedTag,
    int tagClass,
    int elementType,
    int universalTag,
    ElementInfo^ elementInfo
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.checkTagForObject(GSF.ASN1.Coders.DecodedObject{System.Object},System.Int32,System.Int32,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

tagClass
Type: SystemInt32

[Missing <param name="tagClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.checkTagForObject(GSF.ASN1.Coders.DecodedObject{System.Object},System.Int32,System.Int32,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

elementType
Type: SystemInt32

[Missing <param name="elementType"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.checkTagForObject(GSF.ASN1.Coders.DecodedObject{System.Object},System.Int32,System.Int32,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

universalTag
Type: SystemInt32

[Missing <param name="universalTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.checkTagForObject(GSF.ASN1.Coders.DecodedObject{System.Object},System.Int32,System.Int32,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.checkTagForObject(GSF.ASN1.Coders.DecodedObject{System.Object},System.Int32,System.Int32,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.checkTagForObject(GSF.ASN1.Coders.DecodedObject{System.Object},System.Int32,System.Int32,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeAny Method

Grid Solutions Framework BERDecoderdecodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeAny(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeAny (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeAny :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeAny :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeAny(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeAny(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeAny(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeBitString Method

Grid Solutions Framework BERDecoderdecodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeBitString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeBitString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBitString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeBitString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeBitString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeBitString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeBitString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeBoolean Method

Grid Solutions Framework BERDecoderdecodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeBoolean(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeBoolean (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBoolean :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeBoolean :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeBoolean(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeBoolean(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeBoolean(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeChoice Method

Grid Solutions Framework BERDecoderdecodeChoice Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeChoice(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeChoice (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeChoice :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeChoice :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeChoice(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeChoice(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeChoice(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeEnumItem Method

Grid Solutions Framework BERDecoderdecodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeEnumItem(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    Type enumClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeEnumItem (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    enumClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeEnumItem :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        enumClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeEnumItem :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        enumClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeEnumItem(decodedTag, objectClass, enumClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeEnumItem(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    Type^ enumClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeEnumItem(DecodedObjectObject, Type, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeInteger Method

Grid Solutions Framework BERDecoderdecodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeInteger(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeInteger (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeInteger :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeInteger :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeInteger(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeInteger(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeInteger(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeIntegerValue Method

Grid Solutions Framework BERDecoderdecodeIntegerValue Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeIntegerValue(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DecodedObject<Object> decodeIntegerValue(
    Stream stream
)
Protected Function decodeIntegerValue (
    stream As Stream
) As DecodedObject(Of Object)
member decodeIntegerValue :
        stream : Stream -> DecodedObject<Object>

function decodeIntegerValue(stream);
protected:
DecodedObject<Object^>^ decodeIntegerValue(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeIntegerValue(System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeIntegerValue(System.IO.Stream)"]

See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeLength Method

Grid Solutions Framework BERDecoderdecodeLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLength(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual DecodedObject<int> decodeLength(
    Stream stream
)
Protected Overridable Function decodeLength (
    stream As Stream
) As DecodedObject(Of Integer)
abstract decodeLength :
        stream : Stream -> DecodedObject<int>
override decodeLength :
        stream : Stream -> DecodedObject<int>
function decodeLength(stream);
protected:
virtual DecodedObject<int>^ decodeLength(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLength(System.IO.Stream)"]

Return Value

Type: DecodedObject Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLength(System.IO.Stream)"]

See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeLongValue Method

Grid Solutions Framework BERDecoderdecodeLongValue Method
Overload List
 | Name | Description
Protected method | decodeLongValue(Stream) |
Protected method | decodeLongValue(Stream, DecodedObjectInt32) |
Top
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeLongValue Method (Stream)

Grid Solutions Framework BERDecoderdecodeLongValue Method (Stream)

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLongValue(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DecodedObject<Object> decodeLongValue(
    Stream stream
)
Protected Function decodeLongValue (
    stream As Stream
) As DecodedObject(Of Object)
member decodeLongValue :
        stream : Stream -> DecodedObject<Object>

function decodeLongValue(stream);
protected:
DecodedObject<Object^>^ decodeLongValue(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLongValue(System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLongValue(System.IO.Stream)"]

See Also

Reference

BERDecoder Class
decodeLongValue Overload
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeLongValue Method (Stream, DecodedObject(Int32))

Grid Solutions Framework BERDecoderdecodeLongValue Method (Stream, DecodedObjectInt32)

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLongValue(System.IO.Stream,GSF.ASN1.Coders.DecodedObject{System.Int32})"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual DecodedObject<Object> decodeLongValue(
    Stream stream,
    DecodedObject<int> len
)
Protected Overridable Function decodeLongValue (
    stream As Stream,
    len As DecodedObject(Of Integer)
) As DecodedObject(Of Object)
abstract decodeLongValue :
        stream : Stream *
        len : DecodedObject<int> -> DecodedObject<Object>
override decodeLongValue :
        stream : Stream *
        len : DecodedObject<int> -> DecodedObject<Object>
function decodeLongValue(stream, len);
protected:
virtual DecodedObject<Object^>^ decodeLongValue(
    Stream^ stream,
    DecodedObject<int>^ len
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLongValue(System.IO.Stream,GSF.ASN1.Coders.DecodedObject{System.Int32})"]

len
Type: GSF.ASN1.CodersDecodedObject Int32

[Missing <param name="len"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLongValue(System.IO.Stream,GSF.ASN1.Coders.DecodedObject{System.Int32})"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeLongValue(System.IO.Stream,GSF.ASN1.Coders.DecodedObject{System.Int32})"]

See Also

Reference

BERDecoder Class
decodeLongValue Overload
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeNull Method

Grid Solutions Framework BERDecoderdecodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeNull(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeNull (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeNull :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeNull :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeNull(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeNull(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeNull(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeObjectIdentifier Method

Grid Solutions Framework BERDecoderdecodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeObjectIdentifier(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeObjectIdentifier (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeObjectIdentifier :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeObjectIdentifier :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeObjectIdentifier(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeObjectIdentifier(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeObjectIdentifier(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeOctetString Method

Grid Solutions Framework BERDecoderdecodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeOctetString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeOctetString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeOctetString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeOctetString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeOctetString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeOctetString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeOctetString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeReal Method

Grid Solutions Framework BERDecoderdecodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeReal(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeReal (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeReal :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeReal :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeReal(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeReal(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeReal(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeSequence Method

Grid Solutions Framework BERDecoderdecodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeSequence(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeSequence (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequence :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeSequence :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeSequence(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeSequence(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeSequence(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeSequenceOf Method

Grid Solutions Framework BERDecoderdecodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeSequenceOf(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeSequenceOf (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequenceOf :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeSequenceOf :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeSequenceOf(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeSequenceOf(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeSequenceOf(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeSet Method

Grid Solutions Framework BERDecoderdecodeSet Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSet(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.Int32,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual DecodedObject<Object> decodeSet(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    int len,
    Stream stream
)
Protected Overridable Function decodeSet (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    len As Integer,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSet :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        len : int *
        stream : Stream -> DecodedObject<Object>
override decodeSet :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        len : int *
        stream : Stream -> DecodedObject<Object>
function decodeSet(decodedTag, objectClass, elementInfo, len, stream);
protected:
virtual DecodedObject<Object^>^ decodeSet(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    int len,
    Stream^ stream
)

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSet(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.Int32,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSet(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.Int32,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSet(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.Int32,System.IO.Stream)"]

len
Type: SystemInt32

[Missing <param name="len"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSet(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.Int32,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSet(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.Int32,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeSet(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.Int32,System.IO.Stream)"]

See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeString Method

Grid Solutions Framework BERDecoderdecodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BERDecoder.decodeTag Method

Grid Solutions Framework BERDecoderdecodeTag Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeTag(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeTag(
    Stream stream
)
Public Overrides Function decodeTag (
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeTag :
        stream : Stream -> DecodedObject<Object>
override decodeTag :
        stream : Stream -> DecodedObject<Object>
function decodeTag(stream);
public:
virtual DecodedObject<Object^>^ decodeTag(
    Stream^ stream
) override

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeTag(System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERDecoder.decodeTag(System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeTag(Stream)
See Also

Reference

BERDecoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder Class

Grid Solutions Framework BEREncoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.BER.BEREncoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersEncoder
GSF.ASN1.Coders.BERBEREncoder

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BEREncoder : Encoder
Public Class BEREncoder
    Inherits Encoder
type BEREncoder =
    class
        inherit Encoder
    end
GSF.ASN1.Coders.BER.BEREncoder = function();

Type.createClass(
    'GSF.ASN1.Coders.BER.BEREncoder',
    GSF.ASN1.Coders.Encoder);
public ref class BEREncoder : public Encoder

The BEREncoder type exposes the following members.

Constructors
 | Name | Description
Public method | BEREncoder | Initializes a new instance of the BEREncoder class
Top
Methods
 | Name | Description
Public method | encodeT | (Overrides EncoderencodeT(T, Stream).)
Public method | encodeAny | (Overrides EncoderencodeAny(Object, Stream, ElementInfo).)
Public method | encodeBitString | (Overrides EncoderencodeBitString(Object, Stream, ElementInfo).)
Public method | encodeBoolean | (Overrides EncoderencodeBoolean(Object, Stream, ElementInfo).)
Public method | encodeBoxedType | (Inherited from Encoder.)
Public method | encodeChoice | (Overrides EncoderencodeChoice(Object, Stream, ElementInfo).)
Public method | encodeClassType | (Inherited from Encoder.)
Public method | encodeCSElement | (Inherited from Encoder.)
Protected method | encodeCSEnum | (Inherited from Encoder.)
Public method | encodeElement | (Inherited from Encoder.)
Public method | encodeEnum | (Inherited from Encoder.)
Public method | encodeEnumItem | (Overrides EncoderencodeEnumItem(Object, Type, Stream, ElementInfo).)
Protected method | encodeHeader |
Public method | encodeInteger | (Overrides EncoderencodeInteger(Object, Stream, ElementInfo).)
Protected method | encodeIntegerValue |
Protected method | encodeLength |
Public method | encodeNull | (Overrides EncoderencodeNull(Object, Stream, ElementInfo).)
Public method | encodeObjectIdentifier | (Overrides EncoderencodeObjectIdentifier(Object, Stream, ElementInfo).)
Public method | encodeOctetString | (Overrides EncoderencodeOctetString(Object, Stream, ElementInfo).)
Public method | encodePreparedElement | (Inherited from Encoder.)
Public method | encodeReal | (Overrides EncoderencodeReal(Object, Stream, ElementInfo).)
Public method | encodeSequence | (Overrides EncoderencodeSequence(Object, Stream, ElementInfo).)
Public method | encodeSequenceField | (Inherited from Encoder.)
Public method | encodeSequenceOf | (Overrides EncoderencodeSequenceOf(Object, Stream, ElementInfo).)
Public method | encodeString | (Overrides EncoderencodeString(Object, Stream, ElementInfo).)
Protected method | encodeTag |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement | (Inherited from Encoder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField | (Inherited from Encoder.)
Public method | invokeSelectedMethodForField | (Inherited from Encoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders.BER Namespace


BEREncoder Constructor

Grid Solutions Framework BEREncoder Constructor
Initializes a new instance of the BEREncoder class

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BEREncoder()
Public Sub New
new : unit -> BEREncoder
GSF.ASN1.Coders.BER.BEREncoder = function();
public:
BEREncoder()
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder Methods

Grid Solutions Framework BEREncoder Methods

The BEREncoder type exposes the following members.

Methods
 | Name | Description
Public method | encodeT | (Overrides EncoderencodeT(T, Stream).)
Public method | encodeAny | (Overrides EncoderencodeAny(Object, Stream, ElementInfo).)
Public method | encodeBitString | (Overrides EncoderencodeBitString(Object, Stream, ElementInfo).)
Public method | encodeBoolean | (Overrides EncoderencodeBoolean(Object, Stream, ElementInfo).)
Public method | encodeBoxedType | (Inherited from Encoder.)
Public method | encodeChoice | (Overrides EncoderencodeChoice(Object, Stream, ElementInfo).)
Public method | encodeClassType | (Inherited from Encoder.)
Public method | encodeCSElement | (Inherited from Encoder.)
Protected method | encodeCSEnum | (Inherited from Encoder.)
Public method | encodeElement | (Inherited from Encoder.)
Public method | encodeEnum | (Inherited from Encoder.)
Public method | encodeEnumItem | (Overrides EncoderencodeEnumItem(Object, Type, Stream, ElementInfo).)
Protected method | encodeHeader |
Public method | encodeInteger | (Overrides EncoderencodeInteger(Object, Stream, ElementInfo).)
Protected method | encodeIntegerValue |
Protected method | encodeLength |
Public method | encodeNull | (Overrides EncoderencodeNull(Object, Stream, ElementInfo).)
Public method | encodeObjectIdentifier | (Overrides EncoderencodeObjectIdentifier(Object, Stream, ElementInfo).)
Public method | encodeOctetString | (Overrides EncoderencodeOctetString(Object, Stream, ElementInfo).)
Public method | encodePreparedElement | (Inherited from Encoder.)
Public method | encodeReal | (Overrides EncoderencodeReal(Object, Stream, ElementInfo).)
Public method | encodeSequence | (Overrides EncoderencodeSequence(Object, Stream, ElementInfo).)
Public method | encodeSequenceField | (Inherited from Encoder.)
Public method | encodeSequenceOf | (Overrides EncoderencodeSequenceOf(Object, Stream, ElementInfo).)
Public method | encodeString | (Overrides EncoderencodeString(Object, Stream, ElementInfo).)
Protected method | encodeTag |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement | (Inherited from Encoder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField | (Inherited from Encoder.)
Public method | invokeSelectedMethodForField | (Inherited from Encoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encode(T) Method

Grid Solutions Framework BEREncoderencodeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encode``1(``0,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void encode<T>(
    T obj,
    Stream stream
)

Public Overrides Sub encode(Of T) (
    obj As T,
    stream As Stream
)
abstract encode :
        obj : 'T *
        stream : Stream -> unit
override encode :
        obj : 'T *
        stream : Stream -> unit
JavaScript does not support generic types or methods.
public:
generic<typename T>
virtual void encode(
    T obj,
    Stream^ stream
) override

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encode``1(``0,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encode``1(``0,System.IO.Stream)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encode``1(``0,System.IO.Stream)"]

Implements

IEncoderencodeT(T, Stream)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeAny Method

Grid Solutions Framework BEREncoderencodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeAny(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeAny (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeAny :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeAny :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeAny(obj, stream, elementInfo);
public:
virtual int encodeAny(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeAny(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeBitString Method

Grid Solutions Framework BEREncoderencodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeBitString(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeBitString (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBitString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeBitString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeBitString(obj, stream, elementInfo);
public:
virtual int encodeBitString(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeBitString(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeBoolean Method

Grid Solutions Framework BEREncoderencodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeBoolean(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeBoolean (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBoolean :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeBoolean :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeBoolean(obj, stream, elementInfo);
public:
virtual int encodeBoolean(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeBoolean(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeChoice Method

Grid Solutions Framework BEREncoderencodeChoice Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeChoice(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeChoice (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeChoice :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeChoice :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeChoice(obj, stream, elementInfo);
public:
virtual int encodeChoice(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeChoice(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeEnumItem Method

Grid Solutions Framework BEREncoderencodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeEnumItem(
    Object enumConstant,
    Type enumClass,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeEnumItem (
    enumConstant As Object,
    enumClass As Type,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeEnumItem :
        enumConstant : Object *
        enumClass : Type *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeEnumItem :
        enumConstant : Object *
        enumClass : Type *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeEnumItem(enumConstant, enumClass, stream, elementInfo);
public:
virtual int encodeEnumItem(
    Object^ enumConstant,
    Type^ enumClass,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

enumConstant
Type: SystemObject

[Missing <param name="enumConstant"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeEnumItem(Object, Type, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeHeader Method

Grid Solutions Framework BEREncoderencodeHeader Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeHeader(GSF.ASN1.Coders.DecodedObject{System.Int32},System.Int32,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int encodeHeader(
    DecodedObject<int> tagValue,
    int contentLen,
    Stream stream
)
Protected Function encodeHeader (
    tagValue As DecodedObject(Of Integer),
    contentLen As Integer,
    stream As Stream
) As Integer
member encodeHeader :
        tagValue : DecodedObject<int> *
        contentLen : int *
        stream : Stream -> int

function encodeHeader(tagValue, contentLen, stream);
protected:
int encodeHeader(
    DecodedObject<int>^ tagValue,
    int contentLen,
    Stream^ stream
)

Parameters

tagValue
Type: GSF.ASN1.CodersDecodedObject Int32

[Missing <param name="tagValue"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeHeader(GSF.ASN1.Coders.DecodedObject{System.Int32},System.Int32,System.IO.Stream)"]

contentLen
Type: SystemInt32

[Missing <param name="contentLen"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeHeader(GSF.ASN1.Coders.DecodedObject{System.Int32},System.Int32,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeHeader(GSF.ASN1.Coders.DecodedObject{System.Int32},System.Int32,System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeHeader(GSF.ASN1.Coders.DecodedObject{System.Int32},System.Int32,System.IO.Stream)"]

See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeInteger Method

Grid Solutions Framework BEREncoderencodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeInteger(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeInteger (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeInteger :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeInteger :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeInteger(obj, stream, elementInfo);
public:
virtual int encodeInteger(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeInteger(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeIntegerValue Method

Grid Solutions Framework BEREncoderencodeIntegerValue Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeIntegerValue(System.Int64,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int encodeIntegerValue(
    long val,
    Stream stream
)
Protected Function encodeIntegerValue (
    val As Long,
    stream As Stream
) As Integer
member encodeIntegerValue :
        val : int64 *
        stream : Stream -> int

function encodeIntegerValue(val, stream);
protected:
int encodeIntegerValue(
    long long val,
    Stream^ stream
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeIntegerValue(System.Int64,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeIntegerValue(System.Int64,System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeIntegerValue(System.Int64,System.IO.Stream)"]

See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeLength Method

Grid Solutions Framework BEREncoderencodeLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeLength(System.Int32,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int encodeLength(
    int length,
    Stream stream
)
Protected Function encodeLength (
    length As Integer,
    stream As Stream
) As Integer
member encodeLength :
        length : int *
        stream : Stream -> int

function encodeLength(length, stream);
protected:
int encodeLength(
    int length,
    Stream^ stream
)

Parameters

length
Type: SystemInt32

[Missing <param name="length"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeLength(System.Int32,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeLength(System.Int32,System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeLength(System.Int32,System.IO.Stream)"]

See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeNull Method

Grid Solutions Framework BEREncoderencodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeNull(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeNull (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeNull :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeNull :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeNull(obj, stream, elementInfo);
public:
virtual int encodeNull(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeNull(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeObjectIdentifier Method

Grid Solutions Framework BEREncoderencodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeObjectIdentifier(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeObjectIdentifier (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeObjectIdentifier :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeObjectIdentifier :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeObjectIdentifier(obj, stream, elementInfo);
public:
virtual int encodeObjectIdentifier(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeObjectIdentifier(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeOctetString Method

Grid Solutions Framework BEREncoderencodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeOctetString(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeOctetString (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeOctetString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeOctetString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeOctetString(obj, stream, elementInfo);
public:
virtual int encodeOctetString(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeOctetString(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeReal Method

Grid Solutions Framework BEREncoderencodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeReal(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeReal (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeReal :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeReal :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeReal(obj, stream, elementInfo);
public:
virtual int encodeReal(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeReal(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeSequence Method

Grid Solutions Framework BEREncoderencodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeSequence(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeSequence (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequence :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSequence :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSequence(obj, stream, elementInfo);
public:
virtual int encodeSequence(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeSequence(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeSequenceOf Method

Grid Solutions Framework BEREncoderencodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeSequenceOf(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeSequenceOf (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequenceOf :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSequenceOf :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSequenceOf(obj, stream, elementInfo);
public:
virtual int encodeSequenceOf(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeSequenceOf(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeString Method

Grid Solutions Framework BEREncoderencodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeString(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeString (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeString(obj, stream, elementInfo);
public:
virtual int encodeString(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeString(Object, Stream, ElementInfo)
See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BEREncoder.encodeTag Method

Grid Solutions Framework BEREncoderencodeTag Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeTag(GSF.ASN1.Coders.DecodedObject{System.Int32},System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int encodeTag(
    DecodedObject<int> tagValue,
    Stream stream
)
Protected Function encodeTag (
    tagValue As DecodedObject(Of Integer),
    stream As Stream
) As Integer
member encodeTag :
        tagValue : DecodedObject<int> *
        stream : Stream -> int

function encodeTag(tagValue, stream);
protected:
int encodeTag(
    DecodedObject<int>^ tagValue,
    Stream^ stream
)

Parameters

tagValue
Type: GSF.ASN1.CodersDecodedObject Int32

[Missing <param name="tagValue"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeTag(GSF.ASN1.Coders.DecodedObject{System.Int32},System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeTag(GSF.ASN1.Coders.DecodedObject{System.Int32},System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BEREncoder.encodeTag(GSF.ASN1.Coders.DecodedObject{System.Int32},System.IO.Stream)"]

See Also

Reference

BEREncoder Class
GSF.ASN1.Coders.BER Namespace


BERObjectIdentifier Class

Grid Solutions Framework BERObjectIdentifier Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.BER.BERObjectIdentifier"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.Coders.BERBERObjectIdentifier

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class BERObjectIdentifier
Public NotInheritable Class BERObjectIdentifier
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BERObjectIdentifier =  class end
GSF.ASN1.Coders.BER.BERObjectIdentifier = function();

Type.createClass(
    'GSF.ASN1.Coders.BER.BERObjectIdentifier');
public ref class BERObjectIdentifier abstract sealed

The BERObjectIdentifier type exposes the following members.

Methods
Name | Description
BerByteArrayToIntArray |
Decode |
Encode |
IntArrayToDottedDecimal |
Top
See Also

Reference

GSF.ASN1.Coders.BER Namespace


BERObjectIdentifier Methods

Grid Solutions Framework BERObjectIdentifier Methods

The BERObjectIdentifier type exposes the following members.

Methods
Name | Description
BerByteArrayToIntArray |
Decode |
Encode |
IntArrayToDottedDecimal |
Top
See Also

Reference

BERObjectIdentifier Class
GSF.ASN1.Coders.BER Namespace


BERObjectIdentifier.BerByteArrayToIntArray Method

Grid Solutions Framework BERObjectIdentifierBerByteArrayToIntArray Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.BerByteArrayToIntArray(System.Byte[])"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int[] BerByteArrayToIntArray(
    byte[] berBytes
)
Public Shared Function BerByteArrayToIntArray (
    berBytes As Byte()
) As Integer()
static member BerByteArrayToIntArray :
        berBytes : byte[] -> int[]

GSF.ASN1.Coders.BER.BERObjectIdentifier.BerByteArrayToIntArray = function(berBytes);
public:
static array<int>^ BerByteArrayToIntArray(
    array<unsigned char>^ berBytes
)

Parameters

berBytes
Type: SystemByte

[Missing <param name="berBytes"/> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.BerByteArrayToIntArray(System.Byte[])"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.BerByteArrayToIntArray(System.Byte[])"]

See Also

Reference

BERObjectIdentifier Class
GSF.ASN1.Coders.BER Namespace


BERObjectIdentifier.Decode Method

Grid Solutions Framework BERObjectIdentifierDecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.Decode(System.Byte[])"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Decode(
    byte[] oidBytes
)
Public Shared Function Decode (
    oidBytes As Byte()
) As String
static member Decode :
        oidBytes : byte[] -> string

GSF.ASN1.Coders.BER.BERObjectIdentifier.Decode = function(oidBytes);
public:
static String^ Decode(
    array<unsigned char>^ oidBytes
)

Parameters

oidBytes
Type: SystemByte

[Missing <param name="oidBytes"/> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.Decode(System.Byte[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.Decode(System.Byte[])"]

See Also

Reference

BERObjectIdentifier Class
GSF.ASN1.Coders.BER Namespace


BERObjectIdentifier.Encode Method

Grid Solutions Framework BERObjectIdentifierEncode Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.Encode(System.Int32[])"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Encode(
    int[] oidArcArray
)
Public Shared Function Encode (
    oidArcArray As Integer()
) As Byte()
static member Encode :
        oidArcArray : int[] -> byte[]

GSF.ASN1.Coders.BER.BERObjectIdentifier.Encode = function(oidArcArray);
public:
static array<unsigned char>^ Encode(
    array<int>^ oidArcArray
)

Parameters

oidArcArray
Type: SystemInt32

[Missing <param name="oidArcArray"/> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.Encode(System.Int32[])"]

Return Value

Type: Byte

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.Encode(System.Int32[])"]

See Also

Reference

BERObjectIdentifier Class
GSF.ASN1.Coders.BER Namespace


BERObjectIdentifier.IntArrayToDottedDecimal Method

Grid Solutions Framework BERObjectIdentifierIntArrayToDottedDecimal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.IntArrayToDottedDecimal(System.Int32[])"]

Namespace: GSF.ASN1.Coders.BER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string IntArrayToDottedDecimal(
    int[] oidIntArray
)
Public Shared Function IntArrayToDottedDecimal (
    oidIntArray As Integer()
) As String
static member IntArrayToDottedDecimal :
        oidIntArray : int[] -> string

GSF.ASN1.Coders.BER.BERObjectIdentifier.IntArrayToDottedDecimal = function(oidIntArray);
public:
static String^ IntArrayToDottedDecimal(
    array<int>^ oidIntArray
)

Parameters

oidIntArray
Type: SystemInt32

[Missing <param name="oidIntArray"/> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.IntArrayToDottedDecimal(System.Int32[])"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.ASN1.Coders.BER.BERObjectIdentifier.IntArrayToDottedDecimal(System.Int32[])"]

See Also

Reference

BERObjectIdentifier Class
GSF.ASN1.Coders.BER Namespace


GSF.ASN1.Coders.PER Namespace

Grid Solutions Framework GSF.ASN1.Coders.PER Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Coders.PER"]

Classes
 | Class | Description
Public class | PERAlignedDecoder |
Public class | PERAlignedEncoder |
Public class | PERCoderUtils |
Public class | PERUnalignedDecoder |
Public class | PERUnalignedEncoder |


PERAlignedDecoder Class

Grid Solutions Framework PERAlignedDecoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.PER.PERAlignedDecoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersDecoder
GSF.ASN1.Coders.PERPERAlignedDecoder
GSF.ASN1.Coders.PERPERUnalignedDecoder

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PERAlignedDecoder : Decoder
Public Class PERAlignedDecoder
    Inherits Decoder
type PERAlignedDecoder =
    class
        inherit Decoder
    end
GSF.ASN1.Coders.PER.PERAlignedDecoder = function();

Type.createClass(
    'GSF.ASN1.Coders.PER.PERAlignedDecoder',
    GSF.ASN1.Coders.Decoder);
public ref class PERAlignedDecoder : public Decoder

The PERAlignedDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PERAlignedDecoder | Initializes a new instance of the PERAlignedDecoder class
Top
Methods
 | Name | Description
Public method | createInstanceForElement | (Inherited from Decoder.)
Public method | decodeT | (Overrides DecoderdecodeT(Stream).)
Public method | decodeAny | (Overrides DecoderdecodeAny(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBitString | (Overrides DecoderdecodeBitString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoolean | (Overrides DecoderdecodeBoolean(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoxedType | (Inherited from Decoder.)
Public method | decodeChoice | (Overrides DecoderdecodeChoice(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeClassType | (Inherited from Decoder.)
Protected method | decodeConstraintLengthDeterminant | Decode the constraint length determinant. ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | decodeConstraintNumber | Decode of the constrained whole number ITU-T X.691. 10.5. NOTE – (Tutorial) This subclause is referenced by other clauses, and itself references earlier clauses for the production of a nonnegative-binary-integer or a 2's-complement-binary-integer encoding.
Public method | decodeCSElement | (Inherited from Decoder.)
Public method | decodeCSEnum | (Inherited from Decoder.)
Public method | decodeElement | (Inherited from Decoder.)
Public method | decodeEnum | (Inherited from Decoder.)
Public method | decodeEnumItem | (Overrides DecoderdecodeEnumItem(DecodedObjectObject, Type, Type, ElementInfo, Stream).)
Public method | decodeInteger | (Overrides DecoderdecodeInteger(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeIntegerValueAsBytes |
Protected method | decodeLength |
Protected method | decodeLengthDeterminant | Decode the length determinant ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | decodeNormallySmallNumber | Decode the normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index.
Public method | decodeNull | (Overrides DecoderdecodeNull(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeObjectIdentifier | (Overrides DecoderdecodeObjectIdentifier(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeOctetString | (Overrides DecoderdecodeOctetString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodePreparedElement | (Inherited from Decoder.)
Public method | decodeReal | (Overrides DecoderdecodeReal(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeSemiConstraintNumber | Decode the semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | decodeSequence | (Overrides DecoderdecodeSequence(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeSequenceField | (Inherited from Decoder.)
Public method | decodeSequenceOf | (Overrides DecoderdecodeSequenceOf(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeString | (Overrides DecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeStringLength2 |
Public method | decodeTag | (Overrides DecoderdecodeTag(Stream).)
Protected method | decodeUnconstraintNumber | Decode the unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | getSequencePreambleBitLen |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues | (Inherited from Decoder.)
Public method | invokeSelectMethodForField | (Inherited from Decoder.)
Public method | invokeSetterMethodForField | (Inherited from Decoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | skipAlignedBits |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder Constructor

Grid Solutions Framework PERAlignedDecoder Constructor
Initializes a new instance of the PERAlignedDecoder class

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PERAlignedDecoder()
Public Sub New
new : unit -> PERAlignedDecoder
GSF.ASN1.Coders.PER.PERAlignedDecoder = function();
public:
PERAlignedDecoder()
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder Methods

Grid Solutions Framework PERAlignedDecoder Methods

The PERAlignedDecoder type exposes the following members.

Methods
 | Name | Description
Public method | createInstanceForElement | (Inherited from Decoder.)
Public method | decodeT | (Overrides DecoderdecodeT(Stream).)
Public method | decodeAny | (Overrides DecoderdecodeAny(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBitString | (Overrides DecoderdecodeBitString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoolean | (Overrides DecoderdecodeBoolean(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeBoxedType | (Inherited from Decoder.)
Public method | decodeChoice | (Overrides DecoderdecodeChoice(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeClassType | (Inherited from Decoder.)
Protected method | decodeConstraintLengthDeterminant | Decode the constraint length determinant. ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | decodeConstraintNumber | Decode of the constrained whole number ITU-T X.691. 10.5. NOTE – (Tutorial) This subclause is referenced by other clauses, and itself references earlier clauses for the production of a nonnegative-binary-integer or a 2's-complement-binary-integer encoding.
Public method | decodeCSElement | (Inherited from Decoder.)
Public method | decodeCSEnum | (Inherited from Decoder.)
Public method | decodeElement | (Inherited from Decoder.)
Public method | decodeEnum | (Inherited from Decoder.)
Public method | decodeEnumItem | (Overrides DecoderdecodeEnumItem(DecodedObjectObject, Type, Type, ElementInfo, Stream).)
Public method | decodeInteger | (Overrides DecoderdecodeInteger(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeIntegerValueAsBytes |
Protected method | decodeLength |
Protected method | decodeLengthDeterminant | Decode the length determinant ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | decodeNormallySmallNumber | Decode the normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index.
Public method | decodeNull | (Overrides DecoderdecodeNull(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeObjectIdentifier | (Overrides DecoderdecodeObjectIdentifier(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeOctetString | (Overrides DecoderdecodeOctetString(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodePreparedElement | (Inherited from Decoder.)
Public method | decodeReal | (Overrides DecoderdecodeReal(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeSemiConstraintNumber | Decode the semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | decodeSequence | (Overrides DecoderdecodeSequence(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeSequenceField | (Inherited from Decoder.)
Public method | decodeSequenceOf | (Overrides DecoderdecodeSequenceOf(DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | decodeString | (Overrides DecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeStringLength2 |
Public method | decodeTag | (Overrides DecoderdecodeTag(Stream).)
Protected method | decodeUnconstraintNumber | Decode the unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | getSequencePreambleBitLen |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues | (Inherited from Decoder.)
Public method | invokeSelectMethodForField | (Inherited from Decoder.)
Public method | invokeSetterMethodForField | (Inherited from Decoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | skipAlignedBits |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decode(T) Method

Grid Solutions Framework PERAlignedDecoderdecodeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decode``1(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override T decode<T>(
    Stream stream
)

Public Overrides Function decode(Of T) (
    stream As Stream
) As T
abstract decode :
        stream : Stream -> 'T
override decode :
        stream : Stream -> 'T
JavaScript does not support generic types or methods.
public:
generic<typename T>
virtual T decode(
    Stream^ stream
) override

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decode``1(System.IO.Stream)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decode``1(System.IO.Stream)"]

Return Value

Type: T

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decode``1(System.IO.Stream)"]

Implements

IDecoderdecodeT(Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeAny Method

Grid Solutions Framework PERAlignedDecoderdecodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeAny(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeAny (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeAny :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeAny :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeAny(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeAny(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeAny(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeAny(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeBitString Method

Grid Solutions Framework PERAlignedDecoderdecodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeBitString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeBitString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBitString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeBitString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeBitString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeBitString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBitString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeBitString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeBoolean Method

Grid Solutions Framework PERAlignedDecoderdecodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeBoolean(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeBoolean (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeBoolean :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeBoolean :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeBoolean(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeBoolean(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeBoolean(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeBoolean(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeChoice Method

Grid Solutions Framework PERAlignedDecoderdecodeChoice Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeChoice(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeChoice (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeChoice :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeChoice :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeChoice(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeChoice(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeChoice(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeChoice(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeConstraintLengthDeterminant Method

Grid Solutions Framework PERAlignedDecoderdecodeConstraintLengthDeterminant Method
Decode the constraint length determinant. ITU-T X.691. 10.9. General rules for encoding a length determinant

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int decodeConstraintLengthDeterminant(
    int min,
    int max,
    BitArrayInputStream stream
)
Protected Overridable Function decodeConstraintLengthDeterminant (
    min As Integer,
    max As Integer,
    stream As BitArrayInputStream
) As Integer
abstract decodeConstraintLengthDeterminant :
        min : int *
        max : int *
        stream : BitArrayInputStream -> int
override decodeConstraintLengthDeterminant :
        min : int *
        max : int *
        stream : BitArrayInputStream -> int
function decodeConstraintLengthDeterminant(min, max, stream);
protected:
virtual int decodeConstraintLengthDeterminant(
    int min,
    int max,
    BitArrayInputStream^ stream
)

Parameters

min
Type: SystemInt32

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintLengthDeterminant(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayInputStream)"]

max
Type: SystemInt32

[Missing <param name="max"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintLengthDeterminant(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayInputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayInputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintLengthDeterminant(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayInputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintLengthDeterminant(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayInputStream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeConstraintNumber Method

Grid Solutions Framework PERAlignedDecoderdecodeConstraintNumber Method
Decode of the constrained whole number ITU-T X.691. 10.5. NOTE – (Tutorial) This subclause is referenced by other clauses, and itself references earlier clauses for the production of a nonnegative-binary-integer or a 2's-complement-binary-integer encoding.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual long decodeConstraintNumber(
    long min,
    long max,
    BitArrayInputStream stream
)
Protected Overridable Function decodeConstraintNumber (
    min As Long,
    max As Long,
    stream As BitArrayInputStream
) As Long
abstract decodeConstraintNumber :
        min : int64 *
        max : int64 *
        stream : BitArrayInputStream -> int64
override decodeConstraintNumber :
        min : int64 *
        max : int64 *
        stream : BitArrayInputStream -> int64
function decodeConstraintNumber(min, max, stream);
protected:
virtual long long decodeConstraintNumber(
    long long min,
    long long max,
    BitArrayInputStream^ stream
)

Parameters

min
Type: SystemInt64

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

max
Type: SystemInt64

[Missing <param name="max"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayInputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeEnumItem Method

Grid Solutions Framework PERAlignedDecoderdecodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeEnumItem(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    Type enumClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeEnumItem (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    enumClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeEnumItem :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        enumClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeEnumItem :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        enumClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeEnumItem(decodedTag, objectClass, enumClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeEnumItem(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    Type^ enumClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeEnumItem(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeEnumItem(DecodedObjectObject, Type, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeInteger Method

Grid Solutions Framework PERAlignedDecoderdecodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeInteger(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeInteger (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeInteger :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeInteger :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeInteger(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeInteger(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeInteger(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeInteger(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeIntegerValueAsBytes Method

Grid Solutions Framework PERAlignedDecoderdecodeIntegerValueAsBytes Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeIntegerValueAsBytes(System.Int32,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual long decodeIntegerValueAsBytes(
    int intLen,
    Stream stream
)
Protected Overridable Function decodeIntegerValueAsBytes (
    intLen As Integer,
    stream As Stream
) As Long
abstract decodeIntegerValueAsBytes :
        intLen : int *
        stream : Stream -> int64
override decodeIntegerValueAsBytes :
        intLen : int *
        stream : Stream -> int64
function decodeIntegerValueAsBytes(intLen, stream);
protected:
virtual long long decodeIntegerValueAsBytes(
    int intLen,
    Stream^ stream
)

Parameters

intLen
Type: SystemInt32

[Missing <param name="intLen"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeIntegerValueAsBytes(System.Int32,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeIntegerValueAsBytes(System.Int32,System.IO.Stream)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeIntegerValueAsBytes(System.Int32,System.IO.Stream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeLength Method

Grid Solutions Framework PERAlignedDecoderdecodeLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeLength(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int decodeLength(
    ElementInfo elementInfo,
    Stream stream
)
Protected Overridable Function decodeLength (
    elementInfo As ElementInfo,
    stream As Stream
) As Integer
abstract decodeLength :
        elementInfo : ElementInfo *
        stream : Stream -> int
override decodeLength :
        elementInfo : ElementInfo *
        stream : Stream -> int
function decodeLength(elementInfo, stream);
protected:
virtual int decodeLength(
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeLength(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeLength(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeLength(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeLengthDeterminant Method

Grid Solutions Framework PERAlignedDecoderdecodeLengthDeterminant Method
Decode the length determinant ITU-T X.691. 10.9. General rules for encoding a length determinant

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int decodeLengthDeterminant(
    BitArrayInputStream stream
)
Protected Overridable Function decodeLengthDeterminant (
    stream As BitArrayInputStream
) As Integer
abstract decodeLengthDeterminant :
        stream : BitArrayInputStream -> int
override decodeLengthDeterminant :
        stream : BitArrayInputStream -> int
function decodeLengthDeterminant(stream);
protected:
virtual int decodeLengthDeterminant(
    BitArrayInputStream^ stream
)

Parameters

stream
Type: GSF.ASN1.UtilitiesBitArrayInputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeLengthDeterminant(GSF.ASN1.Utilities.BitArrayInputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeLengthDeterminant(GSF.ASN1.Utilities.BitArrayInputStream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeNormallySmallNumber Method

Grid Solutions Framework PERAlignedDecoderdecodeNormallySmallNumber Method
Decode the normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int decodeNormallySmallNumber(
    BitArrayInputStream stream
)
Protected Overridable Function decodeNormallySmallNumber (
    stream As BitArrayInputStream
) As Integer
abstract decodeNormallySmallNumber :
        stream : BitArrayInputStream -> int
override decodeNormallySmallNumber :
        stream : BitArrayInputStream -> int
function decodeNormallySmallNumber(stream);
protected:
virtual int decodeNormallySmallNumber(
    BitArrayInputStream^ stream
)

Parameters

stream
Type: GSF.ASN1.UtilitiesBitArrayInputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNormallySmallNumber(GSF.ASN1.Utilities.BitArrayInputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNormallySmallNumber(GSF.ASN1.Utilities.BitArrayInputStream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeNull Method

Grid Solutions Framework PERAlignedDecoderdecodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeNull(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeNull (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeNull :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeNull :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeNull(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeNull(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeNull(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeNull(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeObjectIdentifier Method

Grid Solutions Framework PERAlignedDecoderdecodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeObjectIdentifier(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeObjectIdentifier (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeObjectIdentifier :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeObjectIdentifier :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeObjectIdentifier(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeObjectIdentifier(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeObjectIdentifier(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeObjectIdentifier(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeOctetString Method

Grid Solutions Framework PERAlignedDecoderdecodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeOctetString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeOctetString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeOctetString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeOctetString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeOctetString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeOctetString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeOctetString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeOctetString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeReal Method

Grid Solutions Framework PERAlignedDecoderdecodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeReal(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeReal (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeReal :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeReal :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeReal(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeReal(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeReal(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeReal(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeSemiConstraintNumber Method

Grid Solutions Framework PERAlignedDecoderdecodeSemiConstraintNumber Method
Decode the semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int decodeSemiConstraintNumber(
    int min,
    BitArrayInputStream stream
)
Protected Overridable Function decodeSemiConstraintNumber (
    min As Integer,
    stream As BitArrayInputStream
) As Integer
abstract decodeSemiConstraintNumber :
        min : int *
        stream : BitArrayInputStream -> int
override decodeSemiConstraintNumber :
        min : int *
        stream : BitArrayInputStream -> int
function decodeSemiConstraintNumber(min, stream);
protected:
virtual int decodeSemiConstraintNumber(
    int min,
    BitArrayInputStream^ stream
)

Parameters

min
Type: SystemInt32

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSemiConstraintNumber(System.Int32,GSF.ASN1.Utilities.BitArrayInputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayInputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSemiConstraintNumber(System.Int32,GSF.ASN1.Utilities.BitArrayInputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSemiConstraintNumber(System.Int32,GSF.ASN1.Utilities.BitArrayInputStream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeSequence Method

Grid Solutions Framework PERAlignedDecoderdecodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeSequence(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeSequence (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequence :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeSequence :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeSequence(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeSequence(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequence(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeSequence(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeSequenceOf Method

Grid Solutions Framework PERAlignedDecoderdecodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeSequenceOf(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeSequenceOf (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeSequenceOf :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeSequenceOf :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeSequenceOf(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeSequenceOf(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeSequenceOf(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeSequenceOf(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeString Method

Grid Solutions Framework PERAlignedDecoderdecodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeStringLength2 Method

Grid Solutions Framework PERAlignedDecoderdecodeStringLength2 Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeStringLength2(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int decodeStringLength2(
    ElementInfo elementInfo,
    Stream stream
)
Protected Overridable Function decodeStringLength2 (
    elementInfo As ElementInfo,
    stream As Stream
) As Integer
abstract decodeStringLength2 :
        elementInfo : ElementInfo *
        stream : Stream -> int
override decodeStringLength2 :
        elementInfo : ElementInfo *
        stream : Stream -> int
function decodeStringLength2(elementInfo, stream);
protected:
virtual int decodeStringLength2(
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeStringLength2(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeStringLength2(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeStringLength2(GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeTag Method

Grid Solutions Framework PERAlignedDecoderdecodeTag Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeTag(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeTag(
    Stream stream
)
Public Overrides Function decodeTag (
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeTag :
        stream : Stream -> DecodedObject<Object>
override decodeTag :
        stream : Stream -> DecodedObject<Object>
function decodeTag(stream);
public:
virtual DecodedObject<Object^>^ decodeTag(
    Stream^ stream
) override

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeTag(System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeTag(System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeTag(Stream)
See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.decodeUnconstraintNumber Method

Grid Solutions Framework PERAlignedDecoderdecodeUnconstraintNumber Method
Decode the unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int decodeUnconstraintNumber(
    BitArrayInputStream stream
)
Protected Overridable Function decodeUnconstraintNumber (
    stream As BitArrayInputStream
) As Integer
abstract decodeUnconstraintNumber :
        stream : BitArrayInputStream -> int
override decodeUnconstraintNumber :
        stream : BitArrayInputStream -> int
function decodeUnconstraintNumber(stream);
protected:
virtual int decodeUnconstraintNumber(
    BitArrayInputStream^ stream
)

Parameters

stream
Type: GSF.ASN1.UtilitiesBitArrayInputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeUnconstraintNumber(GSF.ASN1.Utilities.BitArrayInputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.decodeUnconstraintNumber(GSF.ASN1.Utilities.BitArrayInputStream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.getSequencePreambleBitLen Method

Grid Solutions Framework PERAlignedDecodergetSequencePreambleBitLen Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.getSequencePreambleBitLen(System.Type,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int getSequencePreambleBitLen(
    Type objectClass,
    ElementInfo elementInfo
)
Protected Overridable Function getSequencePreambleBitLen (
    objectClass As Type,
    elementInfo As ElementInfo
) As Integer
abstract getSequencePreambleBitLen :
        objectClass : Type *
        elementInfo : ElementInfo -> int
override getSequencePreambleBitLen :
        objectClass : Type *
        elementInfo : ElementInfo -> int
function getSequencePreambleBitLen(objectClass, elementInfo);
protected:
virtual int getSequencePreambleBitLen(
    Type^ objectClass,
    ElementInfo^ elementInfo
)

Parameters

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.getSequencePreambleBitLen(System.Type,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.getSequencePreambleBitLen(System.Type,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.getSequencePreambleBitLen(System.Type,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedDecoder.skipAlignedBits Method

Grid Solutions Framework PERAlignedDecoderskipAlignedBits Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.skipAlignedBits(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void skipAlignedBits(
    Stream stream
)
Protected Overridable Sub skipAlignedBits (
    stream As Stream
)
abstract skipAlignedBits :
        stream : Stream -> unit
override skipAlignedBits :
        stream : Stream -> unit
function skipAlignedBits(stream);
protected:
virtual void skipAlignedBits(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedDecoder.skipAlignedBits(System.IO.Stream)"]

See Also

Reference

PERAlignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder Class

Grid Solutions Framework PERAlignedEncoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.PER.PERAlignedEncoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersEncoder
GSF.ASN1.Coders.PERPERAlignedEncoder
GSF.ASN1.Coders.PERPERUnalignedEncoder

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PERAlignedEncoder : Encoder
Public Class PERAlignedEncoder
    Inherits Encoder
type PERAlignedEncoder =
    class
        inherit Encoder
    end
GSF.ASN1.Coders.PER.PERAlignedEncoder = function();

Type.createClass(
    'GSF.ASN1.Coders.PER.PERAlignedEncoder',
    GSF.ASN1.Coders.Encoder);
public ref class PERAlignedEncoder : public Encoder

The PERAlignedEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | PERAlignedEncoder | Initializes a new instance of the PERAlignedEncoder class
Top
Methods
 | Name | Description
Protected method | doAlign |
Public method | encodeT | (Overrides EncoderencodeT(T, Stream).)
Public method | encodeAny | (Overrides EncoderencodeAny(Object, Stream, ElementInfo).)
Public method | encodeBitString | (Overrides EncoderencodeBitString(Object, Stream, ElementInfo).)
Public method | encodeBoolean | (Overrides EncoderencodeBoolean(Object, Stream, ElementInfo).)
Public method | encodeBoxedType | (Inherited from Encoder.)
Public method | encodeChoice | Encoding of the choice structure ITU-T X.691. 22. NOTE – (Tutorial) A choice type is encoded by encoding an index specifying the chosen alternative. This is encoded as for a constrained integer (unless the extension marker is present in the choice type, in which case it is a normally small non-negative whole number) and would therefore typically occupy a fixed length bit-field of the minimum number of bits needed to encode the index. (Although it could in principle be arbitrarily large.) This is followed by the encoding of the chosen alternative, with alternatives that are extension additions encoded as if they were the value of an open type field. Where the choice has only one alternative, there is no encoding for the index. (Overrides EncoderencodeChoice(Object, Stream, ElementInfo).)
Public method | encodeChoicePreamble |
Public method | encodeClassType | (Inherited from Encoder.)
Protected method | encodeConstraintLengthDeterminant | Encoding constraint length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | encodeConstraintNumber | Encoding of a constrained whole number ITU-T X.691. 10.5. NOTE – (Tutorial) This subclause is referenced by other clauses, and itself references earlier clauses for the production of a nonnegative-binary-integer or a 2's-complement-binary-integer encoding.
Public method | encodeCSElement | (Inherited from Encoder.)
Protected method | encodeCSEnum | (Inherited from Encoder.)
Public method | encodeElement | (Inherited from Encoder.)
Public method | encodeEnum | (Inherited from Encoder.)
Public method | encodeEnumItem | (Overrides EncoderencodeEnumItem(Object, Type, Stream, ElementInfo).)
Public method | encodeInteger | (Overrides EncoderencodeInteger(Object, Stream, ElementInfo).)
Protected method | encodeIntegerValueAsBytes |
Protected method | encodeLength |
Protected method | encodeLengthDeterminant | Encoding length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | encodeNormallySmallNumber | Encode normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index.
Public method | encodeNull | (Overrides EncoderencodeNull(Object, Stream, ElementInfo).)
Public method | encodeObjectIdentifier | (Overrides EncoderencodeObjectIdentifier(Object, Stream, ElementInfo).)
Public method | encodeOctetString | (Overrides EncoderencodeOctetString(Object, Stream, ElementInfo).)
Public method | encodePreparedElement | (Inherited from Encoder.)
Public method | encodeReal | (Overrides EncoderencodeReal(Object, Stream, ElementInfo).)
Protected method | encodeSemiConstraintNumber | Encoding of a semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | encodeSequence | (Overrides EncoderencodeSequence(Object, Stream, ElementInfo).)
Public method | encodeSequenceField | (Inherited from Encoder.)
Public method | encodeSequenceOf | (Overrides EncoderencodeSequenceOf(Object, Stream, ElementInfo).)
Public method | encodeSequencePreamble |
Public method | encodeSet |
Public method | encodeString | (Overrides EncoderencodeString(Object, Stream, ElementInfo).)
Protected method | encodeUnconstraintNumber | Encoding of a unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement | (Inherited from Encoder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField | (Inherited from Encoder.)
Public method | invokeSelectedMethodForField | (Inherited from Encoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder Constructor

Grid Solutions Framework PERAlignedEncoder Constructor
Initializes a new instance of the PERAlignedEncoder class

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PERAlignedEncoder()
Public Sub New
new : unit -> PERAlignedEncoder
GSF.ASN1.Coders.PER.PERAlignedEncoder = function();
public:
PERAlignedEncoder()
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder Methods

Grid Solutions Framework PERAlignedEncoder Methods

The PERAlignedEncoder type exposes the following members.

Methods
 | Name | Description
Protected method | doAlign |
Public method | encodeT | (Overrides EncoderencodeT(T, Stream).)
Public method | encodeAny | (Overrides EncoderencodeAny(Object, Stream, ElementInfo).)
Public method | encodeBitString | (Overrides EncoderencodeBitString(Object, Stream, ElementInfo).)
Public method | encodeBoolean | (Overrides EncoderencodeBoolean(Object, Stream, ElementInfo).)
Public method | encodeBoxedType | (Inherited from Encoder.)
Public method | encodeChoice | Encoding of the choice structure ITU-T X.691. 22. NOTE – (Tutorial) A choice type is encoded by encoding an index specifying the chosen alternative. This is encoded as for a constrained integer (unless the extension marker is present in the choice type, in which case it is a normally small non-negative whole number) and would therefore typically occupy a fixed length bit-field of the minimum number of bits needed to encode the index. (Although it could in principle be arbitrarily large.) This is followed by the encoding of the chosen alternative, with alternatives that are extension additions encoded as if they were the value of an open type field. Where the choice has only one alternative, there is no encoding for the index. (Overrides EncoderencodeChoice(Object, Stream, ElementInfo).)
Public method | encodeChoicePreamble |
Public method | encodeClassType | (Inherited from Encoder.)
Protected method | encodeConstraintLengthDeterminant | Encoding constraint length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | encodeConstraintNumber | Encoding of a constrained whole number ITU-T X.691. 10.5. NOTE – (Tutorial) This subclause is referenced by other clauses, and itself references earlier clauses for the production of a nonnegative-binary-integer or a 2's-complement-binary-integer encoding.
Public method | encodeCSElement | (Inherited from Encoder.)
Protected method | encodeCSEnum | (Inherited from Encoder.)
Public method | encodeElement | (Inherited from Encoder.)
Public method | encodeEnum | (Inherited from Encoder.)
Public method | encodeEnumItem | (Overrides EncoderencodeEnumItem(Object, Type, Stream, ElementInfo).)
Public method | encodeInteger | (Overrides EncoderencodeInteger(Object, Stream, ElementInfo).)
Protected method | encodeIntegerValueAsBytes |
Protected method | encodeLength |
Protected method | encodeLengthDeterminant | Encoding length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant
Protected method | encodeNormallySmallNumber | Encode normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index.
Public method | encodeNull | (Overrides EncoderencodeNull(Object, Stream, ElementInfo).)
Public method | encodeObjectIdentifier | (Overrides EncoderencodeObjectIdentifier(Object, Stream, ElementInfo).)
Public method | encodeOctetString | (Overrides EncoderencodeOctetString(Object, Stream, ElementInfo).)
Public method | encodePreparedElement | (Inherited from Encoder.)
Public method | encodeReal | (Overrides EncoderencodeReal(Object, Stream, ElementInfo).)
Protected method | encodeSemiConstraintNumber | Encoding of a semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | encodeSequence | (Overrides EncoderencodeSequence(Object, Stream, ElementInfo).)
Public method | encodeSequenceField | (Inherited from Encoder.)
Public method | encodeSequenceOf | (Overrides EncoderencodeSequenceOf(Object, Stream, ElementInfo).)
Public method | encodeSequencePreamble |
Public method | encodeSet |
Public method | encodeString | (Overrides EncoderencodeString(Object, Stream, ElementInfo).)
Protected method | encodeUnconstraintNumber | Encoding of a unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement | (Inherited from Encoder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField | (Inherited from Encoder.)
Public method | invokeSelectedMethodForField | (Inherited from Encoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.doAlign Method

Grid Solutions Framework PERAlignedEncoderdoAlign Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.doAlign(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void doAlign(
    Stream stream
)
Protected Overridable Sub doAlign (
    stream As Stream
)
abstract doAlign :
        stream : Stream -> unit
override doAlign :
        stream : Stream -> unit
function doAlign(stream);
protected:
virtual void doAlign(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.doAlign(System.IO.Stream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encode(T) Method

Grid Solutions Framework PERAlignedEncoderencodeT Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encode``1(``0,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void encode<T>(
    T obj,
    Stream stream
)

Public Overrides Sub encode(Of T) (
    obj As T,
    stream As Stream
)
abstract encode :
        obj : 'T *
        stream : Stream -> unit
override encode :
        obj : 'T *
        stream : Stream -> unit
JavaScript does not support generic types or methods.
public:
generic<typename T>
virtual void encode(
    T obj,
    Stream^ stream
) override

Parameters

obj
Type: T

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encode``1(``0,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encode``1(``0,System.IO.Stream)"]

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encode``1(``0,System.IO.Stream)"]

Implements

IEncoderencodeT(T, Stream)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeAny Method

Grid Solutions Framework PERAlignedEncoderencodeAny Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeAny(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeAny (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeAny :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeAny :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeAny(obj, stream, elementInfo);
public:
virtual int encodeAny(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeAny(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeAny(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeBitString Method

Grid Solutions Framework PERAlignedEncoderencodeBitString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeBitString(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeBitString (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBitString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeBitString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeBitString(obj, stream, elementInfo);
public:
virtual int encodeBitString(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBitString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeBitString(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeBoolean Method

Grid Solutions Framework PERAlignedEncoderencodeBoolean Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeBoolean(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeBoolean (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeBoolean :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeBoolean :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeBoolean(obj, stream, elementInfo);
public:
virtual int encodeBoolean(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeBoolean(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeBoolean(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeChoice Method

Grid Solutions Framework PERAlignedEncoderencodeChoice Method
Encoding of the choice structure ITU-T X.691. 22. NOTE – (Tutorial) A choice type is encoded by encoding an index specifying the chosen alternative. This is encoded as for a constrained integer (unless the extension marker is present in the choice type, in which case it is a normally small non-negative whole number) and would therefore typically occupy a fixed length bit-field of the minimum number of bits needed to encode the index. (Although it could in principle be arbitrarily large.) This is followed by the encoding of the chosen alternative, with alternatives that are extension additions encoded as if they were the value of an open type field. Where the choice has only one alternative, there is no encoding for the index.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeChoice(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeChoice (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeChoice :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeChoice :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeChoice(obj, stream, elementInfo);
public:
virtual int encodeChoice(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoice(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeChoice(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeChoicePreamble Method

Grid Solutions Framework PERAlignedEncoderencodeChoicePreamble Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoicePreamble(System.Object,System.IO.Stream,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeChoicePreamble(
    Object obj,
    Stream stream,
    int elementIndex,
    ElementInfo elementInfo
)
Public Overridable Function encodeChoicePreamble (
    obj As Object,
    stream As Stream,
    elementIndex As Integer,
    elementInfo As ElementInfo
) As Integer
abstract encodeChoicePreamble :
        obj : Object *
        stream : Stream *
        elementIndex : int *
        elementInfo : ElementInfo -> int
override encodeChoicePreamble :
        obj : Object *
        stream : Stream *
        elementIndex : int *
        elementInfo : ElementInfo -> int
function encodeChoicePreamble(obj, stream, elementIndex, elementInfo);
public:
virtual int encodeChoicePreamble(
    Object^ obj,
    Stream^ stream,
    int elementIndex,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoicePreamble(System.Object,System.IO.Stream,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoicePreamble(System.Object,System.IO.Stream,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

elementIndex
Type: SystemInt32

[Missing <param name="elementIndex"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoicePreamble(System.Object,System.IO.Stream,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoicePreamble(System.Object,System.IO.Stream,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeChoicePreamble(System.Object,System.IO.Stream,System.Int32,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeConstraintLengthDeterminant Method

Grid Solutions Framework PERAlignedEncoderencodeConstraintLengthDeterminant Method
Encoding constraint length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int encodeConstraintLengthDeterminant(
    int length,
    int min,
    int max,
    BitArrayOutputStream stream
)
Protected Overridable Function encodeConstraintLengthDeterminant (
    length As Integer,
    min As Integer,
    max As Integer,
    stream As BitArrayOutputStream
) As Integer
abstract encodeConstraintLengthDeterminant :
        length : int *
        min : int *
        max : int *
        stream : BitArrayOutputStream -> int
override encodeConstraintLengthDeterminant :
        length : int *
        min : int *
        max : int *
        stream : BitArrayOutputStream -> int
function encodeConstraintLengthDeterminant(length, min, max, stream);
protected:
virtual int encodeConstraintLengthDeterminant(
    int length,
    int min,
    int max,
    BitArrayOutputStream^ stream
)

Parameters

length
Type: SystemInt32

[Missing <param name="length"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintLengthDeterminant(System.Int32,System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

min
Type: SystemInt32

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintLengthDeterminant(System.Int32,System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

max
Type: SystemInt32

[Missing <param name="max"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintLengthDeterminant(System.Int32,System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayOutputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintLengthDeterminant(System.Int32,System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintLengthDeterminant(System.Int32,System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeConstraintNumber Method

Grid Solutions Framework PERAlignedEncoderencodeConstraintNumber Method
Encoding of a constrained whole number ITU-T X.691. 10.5. NOTE – (Tutorial) This subclause is referenced by other clauses, and itself references earlier clauses for the production of a nonnegative-binary-integer or a 2's-complement-binary-integer encoding.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int encodeConstraintNumber(
    long val,
    long min,
    long max,
    BitArrayOutputStream stream
)
Protected Overridable Function encodeConstraintNumber (
    val As Long,
    min As Long,
    max As Long,
    stream As BitArrayOutputStream
) As Integer
abstract encodeConstraintNumber :
        val : int64 *
        min : int64 *
        max : int64 *
        stream : BitArrayOutputStream -> int
override encodeConstraintNumber :
        val : int64 *
        min : int64 *
        max : int64 *
        stream : BitArrayOutputStream -> int
function encodeConstraintNumber(val, min, max, stream);
protected:
virtual int encodeConstraintNumber(
    long long val,
    long long min,
    long long max,
    BitArrayOutputStream^ stream
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

min
Type: SystemInt64

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

max
Type: SystemInt64

[Missing <param name="max"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayOutputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeEnumItem Method

Grid Solutions Framework PERAlignedEncoderencodeEnumItem Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeEnumItem(
    Object enumConstant,
    Type enumClass,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeEnumItem (
    enumConstant As Object,
    enumClass As Type,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeEnumItem :
        enumConstant : Object *
        enumClass : Type *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeEnumItem :
        enumConstant : Object *
        enumClass : Type *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeEnumItem(enumConstant, enumClass, stream, elementInfo);
public:
virtual int encodeEnumItem(
    Object^ enumConstant,
    Type^ enumClass,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

enumConstant
Type: SystemObject

[Missing <param name="enumConstant"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeEnumItem(System.Object,System.Type,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeEnumItem(Object, Type, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeInteger Method

Grid Solutions Framework PERAlignedEncoderencodeInteger Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeInteger(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeInteger (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeInteger :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeInteger :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeInteger(obj, stream, elementInfo);
public:
virtual int encodeInteger(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeInteger(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeInteger(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeIntegerValueAsBytes Method

Grid Solutions Framework PERAlignedEncoderencodeIntegerValueAsBytes Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeIntegerValueAsBytes(System.Int64,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int encodeIntegerValueAsBytes(
    long val,
    Stream stream
)
Protected Overridable Function encodeIntegerValueAsBytes (
    val As Long,
    stream As Stream
) As Integer
abstract encodeIntegerValueAsBytes :
        val : int64 *
        stream : Stream -> int
override encodeIntegerValueAsBytes :
        val : int64 *
        stream : Stream -> int
function encodeIntegerValueAsBytes(val, stream);
protected:
virtual int encodeIntegerValueAsBytes(
    long long val,
    Stream^ stream
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeIntegerValueAsBytes(System.Int64,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeIntegerValueAsBytes(System.Int64,System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeIntegerValueAsBytes(System.Int64,System.IO.Stream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeLength Method

Grid Solutions Framework PERAlignedEncoderencodeLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLength(System.Int32,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int encodeLength(
    int val,
    ElementInfo elementInfo,
    Stream stream
)
Protected Function encodeLength (
    val As Integer,
    elementInfo As ElementInfo,
    stream As Stream
) As Integer
member encodeLength :
        val : int *
        elementInfo : ElementInfo *
        stream : Stream -> int

function encodeLength(val, elementInfo, stream);
protected:
int encodeLength(
    int val,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

val
Type: SystemInt32

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLength(System.Int32,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLength(System.Int32,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLength(System.Int32,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLength(System.Int32,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeLengthDeterminant Method

Grid Solutions Framework PERAlignedEncoderencodeLengthDeterminant Method
Encoding length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int encodeLengthDeterminant(
    int length,
    BitArrayOutputStream stream
)
Protected Overridable Function encodeLengthDeterminant (
    length As Integer,
    stream As BitArrayOutputStream
) As Integer
abstract encodeLengthDeterminant :
        length : int *
        stream : BitArrayOutputStream -> int
override encodeLengthDeterminant :
        length : int *
        stream : BitArrayOutputStream -> int
function encodeLengthDeterminant(length, stream);
protected:
virtual int encodeLengthDeterminant(
    int length,
    BitArrayOutputStream^ stream
)

Parameters

length
Type: SystemInt32

[Missing <param name="length"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLengthDeterminant(System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayOutputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLengthDeterminant(System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeLengthDeterminant(System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeNormallySmallNumber Method

Grid Solutions Framework PERAlignedEncoderencodeNormallySmallNumber Method
Encode normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int encodeNormallySmallNumber(
    int val,
    BitArrayOutputStream stream
)
Protected Overridable Function encodeNormallySmallNumber (
    val As Integer,
    stream As BitArrayOutputStream
) As Integer
abstract encodeNormallySmallNumber :
        val : int *
        stream : BitArrayOutputStream -> int
override encodeNormallySmallNumber :
        val : int *
        stream : BitArrayOutputStream -> int
function encodeNormallySmallNumber(val, stream);
protected:
virtual int encodeNormallySmallNumber(
    int val,
    BitArrayOutputStream^ stream
)

Parameters

val
Type: SystemInt32

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNormallySmallNumber(System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayOutputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNormallySmallNumber(System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNormallySmallNumber(System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeNull Method

Grid Solutions Framework PERAlignedEncoderencodeNull Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeNull(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeNull (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeNull :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeNull :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeNull(obj, stream, elementInfo);
public:
virtual int encodeNull(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeNull(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeNull(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeObjectIdentifier Method

Grid Solutions Framework PERAlignedEncoderencodeObjectIdentifier Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeObjectIdentifier(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeObjectIdentifier (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeObjectIdentifier :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeObjectIdentifier :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeObjectIdentifier(obj, stream, elementInfo);
public:
virtual int encodeObjectIdentifier(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeObjectIdentifier(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeObjectIdentifier(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeOctetString Method

Grid Solutions Framework PERAlignedEncoderencodeOctetString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeOctetString(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeOctetString (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeOctetString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeOctetString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeOctetString(obj, stream, elementInfo);
public:
virtual int encodeOctetString(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeOctetString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeOctetString(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeReal Method

Grid Solutions Framework PERAlignedEncoderencodeReal Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeReal(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeReal (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeReal :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeReal :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeReal(obj, stream, elementInfo);
public:
virtual int encodeReal(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeReal(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeReal(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeSemiConstraintNumber Method

Grid Solutions Framework PERAlignedEncoderencodeSemiConstraintNumber Method
Encoding of a semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int encodeSemiConstraintNumber(
    int val,
    int min,
    BitArrayOutputStream stream
)
Protected Overridable Function encodeSemiConstraintNumber (
    val As Integer,
    min As Integer,
    stream As BitArrayOutputStream
) As Integer
abstract encodeSemiConstraintNumber :
        val : int *
        min : int *
        stream : BitArrayOutputStream -> int
override encodeSemiConstraintNumber :
        val : int *
        min : int *
        stream : BitArrayOutputStream -> int
function encodeSemiConstraintNumber(val, min, stream);
protected:
virtual int encodeSemiConstraintNumber(
    int val,
    int min,
    BitArrayOutputStream^ stream
)

Parameters

val
Type: SystemInt32

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSemiConstraintNumber(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

min
Type: SystemInt32

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSemiConstraintNumber(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayOutputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSemiConstraintNumber(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSemiConstraintNumber(System.Int32,System.Int32,GSF.ASN1.Utilities.BitArrayOutputStream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeSequence Method

Grid Solutions Framework PERAlignedEncoderencodeSequence Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeSequence(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeSequence (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequence :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSequence :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSequence(obj, stream, elementInfo);
public:
virtual int encodeSequence(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequence(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeSequence(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeSequenceOf Method

Grid Solutions Framework PERAlignedEncoderencodeSequenceOf Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeSequenceOf(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeSequenceOf (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequenceOf :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSequenceOf :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSequenceOf(obj, stream, elementInfo);
public:
virtual int encodeSequenceOf(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequenceOf(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeSequenceOf(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeSequencePreamble Method

Grid Solutions Framework PERAlignedEncoderencodeSequencePreamble Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequencePreamble(System.Object,System.Reflection.PropertyInfo[],System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeSequencePreamble(
    Object obj,
    PropertyInfo[] fields,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeSequencePreamble (
    obj As Object,
    fields As PropertyInfo(),
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSequencePreamble :
        obj : Object *
        fields : PropertyInfo[] *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSequencePreamble :
        obj : Object *
        fields : PropertyInfo[] *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSequencePreamble(obj, fields, stream, elementInfo);
public:
virtual int encodeSequencePreamble(
    Object^ obj,
    array<PropertyInfo^>^ fields,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequencePreamble(System.Object,System.Reflection.PropertyInfo[],System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

fields
Type: System.ReflectionPropertyInfo

[Missing <param name="fields"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequencePreamble(System.Object,System.Reflection.PropertyInfo[],System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequencePreamble(System.Object,System.Reflection.PropertyInfo[],System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequencePreamble(System.Object,System.Reflection.PropertyInfo[],System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSequencePreamble(System.Object,System.Reflection.PropertyInfo[],System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeSet Method

Grid Solutions Framework PERAlignedEncoderencodeSet Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSet(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int encodeSet(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overridable Function encodeSet (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeSet :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeSet :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeSet(obj, stream, elementInfo);
public:
virtual int encodeSet(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSet(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSet(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSet(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeSet(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeString Method

Grid Solutions Framework PERAlignedEncoderencodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeString(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeString (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeString(obj, stream, elementInfo);
public:
virtual int encodeString(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeString(Object, Stream, ElementInfo)
See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERAlignedEncoder.encodeUnconstraintNumber Method

Grid Solutions Framework PERAlignedEncoderencodeUnconstraintNumber Method
Encoding of a unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures.

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int encodeUnconstraintNumber(
    long val,
    BitArrayOutputStream stream
)
Protected Overridable Function encodeUnconstraintNumber (
    val As Long,
    stream As BitArrayOutputStream
) As Integer
abstract encodeUnconstraintNumber :
        val : int64 *
        stream : BitArrayOutputStream -> int
override encodeUnconstraintNumber :
        val : int64 *
        stream : BitArrayOutputStream -> int
function encodeUnconstraintNumber(val, stream);
protected:
virtual int encodeUnconstraintNumber(
    long long val,
    BitArrayOutputStream^ stream
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeUnconstraintNumber(System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayOutputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeUnconstraintNumber(System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERAlignedEncoder.encodeUnconstraintNumber(System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

See Also

Reference

PERAlignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERCoderUtils Class

Grid Solutions Framework PERCoderUtils Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.PER.PERCoderUtils"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.Coders.PERPERCoderUtils

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PERCoderUtils
Public Class PERCoderUtils
type PERCoderUtils =  class end
GSF.ASN1.Coders.PER.PERCoderUtils = function();

Type.createClass(
    'GSF.ASN1.Coders.PER.PERCoderUtils');
public ref class PERCoderUtils

The PERCoderUtils type exposes the following members.

Constructors
 | Name | Description
Public method | PERCoderUtils | Initializes a new instance of the PERCoderUtils class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getMaxBitLength |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | is7BitEncodedString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders.PER Namespace


PERCoderUtils Constructor

Grid Solutions Framework PERCoderUtils Constructor
Initializes a new instance of the PERCoderUtils class

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PERCoderUtils()
Public Sub New
new : unit -> PERCoderUtils
GSF.ASN1.Coders.PER.PERCoderUtils = function();
public:
PERCoderUtils()
See Also

Reference

PERCoderUtils Class
GSF.ASN1.Coders.PER Namespace


PERCoderUtils Methods

Grid Solutions Framework PERCoderUtils Methods

The PERCoderUtils type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | getMaxBitLength |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | is7BitEncodedString |
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PERCoderUtils Class
GSF.ASN1.Coders.PER Namespace


PERCoderUtils.getMaxBitLength Method

Grid Solutions Framework PERCoderUtilsgetMaxBitLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERCoderUtils.getMaxBitLength(System.Int64)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int getMaxBitLength(
    long val
)
Public Shared Function getMaxBitLength (
    val As Long
) As Integer
static member getMaxBitLength :
        val : int64 -> int

GSF.ASN1.Coders.PER.PERCoderUtils.getMaxBitLength = function(val);
public:
static int getMaxBitLength(
    long long val
)

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERCoderUtils.getMaxBitLength(System.Int64)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERCoderUtils.getMaxBitLength(System.Int64)"]

See Also

Reference

PERCoderUtils Class
GSF.ASN1.Coders.PER Namespace


PERCoderUtils.is7BitEncodedString Method

Grid Solutions Framework PERCoderUtilsis7BitEncodedString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERCoderUtils.is7BitEncodedString(GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool is7BitEncodedString(
    ElementInfo info
)
Public Shared Function is7BitEncodedString (
    info As ElementInfo
) As Boolean
static member is7BitEncodedString :
        info : ElementInfo -> bool

GSF.ASN1.Coders.PER.PERCoderUtils.is7BitEncodedString = function(info);
public:
static bool is7BitEncodedString(
    ElementInfo^ info
)

Parameters

info
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="info"/> documentation for "M:GSF.ASN1.Coders.PER.PERCoderUtils.is7BitEncodedString(GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERCoderUtils.is7BitEncodedString(GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

PERCoderUtils Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedDecoder Class

Grid Solutions Framework PERUnalignedDecoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.PER.PERUnalignedDecoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersDecoder
GSF.ASN1.Coders.PERPERAlignedDecoder
GSF.ASN1.Coders.PERPERUnalignedDecoder

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PERUnalignedDecoder : PERAlignedDecoder
Public Class PERUnalignedDecoder
    Inherits PERAlignedDecoder
type PERUnalignedDecoder =
    class
        inherit PERAlignedDecoder
    end
GSF.ASN1.Coders.PER.PERUnalignedDecoder = function();

Type.createClass(
    'GSF.ASN1.Coders.PER.PERUnalignedDecoder',
    GSF.ASN1.Coders.PER.PERAlignedDecoder);
public ref class PERUnalignedDecoder : public PERAlignedDecoder

The PERUnalignedDecoder type exposes the following members.

Constructors
 | Name | Description
Public method | PERUnalignedDecoder | Initializes a new instance of the PERUnalignedDecoder class
Top
Methods
 | Name | Description
Public method | createInstanceForElement | (Inherited from Decoder.)
Public method | decodeT | (Inherited from PERAlignedDecoder.)
Public method | decodeAny | (Inherited from PERAlignedDecoder.)
Public method | decodeBitString | (Inherited from PERAlignedDecoder.)
Public method | decodeBoolean | (Inherited from PERAlignedDecoder.)
Public method | decodeBoxedType | (Inherited from Decoder.)
Public method | decodeChoice | (Inherited from PERAlignedDecoder.)
Public method | decodeClassType | (Inherited from Decoder.)
Protected method | decodeConstraintLengthDeterminant | Decode the constraint length determinant. ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedDecoder.)
Protected method | decodeConstraintNumber | (Overrides PERAlignedDecoderdecodeConstraintNumber(Int64, Int64, BitArrayInputStream).)
Public method | decodeCSElement | (Inherited from Decoder.)
Public method | decodeCSEnum | (Inherited from Decoder.)
Public method | decodeElement | (Inherited from Decoder.)
Public method | decodeEnum | (Inherited from Decoder.)
Public method | decodeEnumItem | (Inherited from PERAlignedDecoder.)
Public method | decodeInteger | (Inherited from PERAlignedDecoder.)
Protected method | decodeIntegerValueAsBytes | (Inherited from PERAlignedDecoder.)
Protected method | decodeLength | (Inherited from PERAlignedDecoder.)
Protected method | decodeLengthDeterminant | Decode the length determinant ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedDecoder.)
Protected method | decodeNormallySmallNumber | Decode the normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index. (Inherited from PERAlignedDecoder.)
Public method | decodeNull | (Inherited from PERAlignedDecoder.)
Public method | decodeObjectIdentifier | (Inherited from PERAlignedDecoder.)
Public method | decodeOctetString | (Inherited from PERAlignedDecoder.)
Public method | decodePreparedElement | (Inherited from Decoder.)
Public method | decodeReal | (Inherited from PERAlignedDecoder.)
Protected method | decodeSemiConstraintNumber | Decode the semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedDecoder.)
Public method | decodeSequence | (Inherited from PERAlignedDecoder.)
Public method | decodeSequenceField | (Inherited from Decoder.)
Public method | decodeSequenceOf | (Inherited from PERAlignedDecoder.)
Public method | decodeString | (Overrides PERAlignedDecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeStringLength2 | (Inherited from PERAlignedDecoder.)
Public method | decodeTag | (Inherited from PERAlignedDecoder.)
Protected method | decodeUnconstraintNumber | Decode the unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedDecoder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | getSequencePreambleBitLen | (Inherited from PERAlignedDecoder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues | (Inherited from Decoder.)
Public method | invokeSelectMethodForField | (Inherited from Decoder.)
Public method | invokeSetterMethodForField | (Inherited from Decoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | skipAlignedBits | (Overrides PERAlignedDecoderskipAlignedBits(Stream).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders.PER Namespace


PERUnalignedDecoder Constructor

Grid Solutions Framework PERUnalignedDecoder Constructor
Initializes a new instance of the PERUnalignedDecoder class

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PERUnalignedDecoder()
Public Sub New
new : unit -> PERUnalignedDecoder
GSF.ASN1.Coders.PER.PERUnalignedDecoder = function();
public:
PERUnalignedDecoder()
See Also

Reference

PERUnalignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedDecoder Methods

Grid Solutions Framework PERUnalignedDecoder Methods

The PERUnalignedDecoder type exposes the following members.

Methods
 | Name | Description
Public method | createInstanceForElement | (Inherited from Decoder.)
Public method | decodeT | (Inherited from PERAlignedDecoder.)
Public method | decodeAny | (Inherited from PERAlignedDecoder.)
Public method | decodeBitString | (Inherited from PERAlignedDecoder.)
Public method | decodeBoolean | (Inherited from PERAlignedDecoder.)
Public method | decodeBoxedType | (Inherited from Decoder.)
Public method | decodeChoice | (Inherited from PERAlignedDecoder.)
Public method | decodeClassType | (Inherited from Decoder.)
Protected method | decodeConstraintLengthDeterminant | Decode the constraint length determinant. ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedDecoder.)
Protected method | decodeConstraintNumber | (Overrides PERAlignedDecoderdecodeConstraintNumber(Int64, Int64, BitArrayInputStream).)
Public method | decodeCSElement | (Inherited from Decoder.)
Public method | decodeCSEnum | (Inherited from Decoder.)
Public method | decodeElement | (Inherited from Decoder.)
Public method | decodeEnum | (Inherited from Decoder.)
Public method | decodeEnumItem | (Inherited from PERAlignedDecoder.)
Public method | decodeInteger | (Inherited from PERAlignedDecoder.)
Protected method | decodeIntegerValueAsBytes | (Inherited from PERAlignedDecoder.)
Protected method | decodeLength | (Inherited from PERAlignedDecoder.)
Protected method | decodeLengthDeterminant | Decode the length determinant ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedDecoder.)
Protected method | decodeNormallySmallNumber | Decode the normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index. (Inherited from PERAlignedDecoder.)
Public method | decodeNull | (Inherited from PERAlignedDecoder.)
Public method | decodeObjectIdentifier | (Inherited from PERAlignedDecoder.)
Public method | decodeOctetString | (Inherited from PERAlignedDecoder.)
Public method | decodePreparedElement | (Inherited from Decoder.)
Public method | decodeReal | (Inherited from PERAlignedDecoder.)
Protected method | decodeSemiConstraintNumber | Decode the semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedDecoder.)
Public method | decodeSequence | (Inherited from PERAlignedDecoder.)
Public method | decodeSequenceField | (Inherited from Decoder.)
Public method | decodeSequenceOf | (Inherited from PERAlignedDecoder.)
Public method | decodeString | (Overrides PERAlignedDecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream).)
Protected method | decodeStringLength2 | (Inherited from PERAlignedDecoder.)
Public method | decodeTag | (Inherited from PERAlignedDecoder.)
Protected method | decodeUnconstraintNumber | Decode the unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedDecoder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | getSequencePreambleBitLen | (Inherited from PERAlignedDecoder.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | initDefaultValues | (Inherited from Decoder.)
Public method | invokeSelectMethodForField | (Inherited from Decoder.)
Public method | invokeSetterMethodForField | (Inherited from Decoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | skipAlignedBits | (Overrides PERAlignedDecoderskipAlignedBits(Stream).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PERUnalignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedDecoder.decodeConstraintNumber Method

Grid Solutions Framework PERUnalignedDecoderdecodeConstraintNumber Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override long decodeConstraintNumber(
    long min,
    long max,
    BitArrayInputStream stream
)
Protected Overrides Function decodeConstraintNumber (
    min As Long,
    max As Long,
    stream As BitArrayInputStream
) As Long
abstract decodeConstraintNumber :
        min : int64 *
        max : int64 *
        stream : BitArrayInputStream -> int64
override decodeConstraintNumber :
        min : int64 *
        max : int64 *
        stream : BitArrayInputStream -> int64
function decodeConstraintNumber(min, max, stream);
protected:
virtual long long decodeConstraintNumber(
    long long min,
    long long max,
    BitArrayInputStream^ stream
) override

Parameters

min
Type: SystemInt64

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

max
Type: SystemInt64

[Missing <param name="max"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayInputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeConstraintNumber(System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayInputStream)"]

See Also

Reference

PERUnalignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedDecoder.decodeString Method

Grid Solutions Framework PERUnalignedDecoderdecodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decodeString(
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decodeString (
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decodeString :
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decodeString(decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decodeString(
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.decodeString(GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1TypesDecoderdecodeString(DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

PERUnalignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedDecoder.skipAlignedBits Method

Grid Solutions Framework PERUnalignedDecoderskipAlignedBits Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.skipAlignedBits(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void skipAlignedBits(
    Stream stream
)
Protected Overrides Sub skipAlignedBits (
    stream As Stream
)
abstract skipAlignedBits :
        stream : Stream -> unit
override skipAlignedBits :
        stream : Stream -> unit
function skipAlignedBits(stream);
protected:
virtual void skipAlignedBits(
    Stream^ stream
) override

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedDecoder.skipAlignedBits(System.IO.Stream)"]

See Also

Reference

PERUnalignedDecoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedEncoder Class

Grid Solutions Framework PERUnalignedEncoder Class

[Missing <summary> documentation for "T:GSF.ASN1.Coders.PER.PERUnalignedEncoder"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.CodersEncoder
GSF.ASN1.Coders.PERPERAlignedEncoder
GSF.ASN1.Coders.PERPERUnalignedEncoder

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PERUnalignedEncoder : PERAlignedEncoder
Public Class PERUnalignedEncoder
    Inherits PERAlignedEncoder
type PERUnalignedEncoder =
    class
        inherit PERAlignedEncoder
    end
GSF.ASN1.Coders.PER.PERUnalignedEncoder = function();

Type.createClass(
    'GSF.ASN1.Coders.PER.PERUnalignedEncoder',
    GSF.ASN1.Coders.PER.PERAlignedEncoder);
public ref class PERUnalignedEncoder : public PERAlignedEncoder

The PERUnalignedEncoder type exposes the following members.

Constructors
 | Name | Description
Public method | PERUnalignedEncoder | Initializes a new instance of the PERUnalignedEncoder class
Top
Methods
 | Name | Description
Protected method | doAlign | (Overrides PERAlignedEncoderdoAlign(Stream).)
Public method | encodeT | (Inherited from PERAlignedEncoder.)
Public method | encodeAny | (Inherited from PERAlignedEncoder.)
Public method | encodeBitString | (Inherited from PERAlignedEncoder.)
Public method | encodeBoolean | (Inherited from PERAlignedEncoder.)
Public method | encodeBoxedType | (Inherited from Encoder.)
Public method | encodeChoice | Encoding of the choice structure ITU-T X.691. 22. NOTE – (Tutorial) A choice type is encoded by encoding an index specifying the chosen alternative. This is encoded as for a constrained integer (unless the extension marker is present in the choice type, in which case it is a normally small non-negative whole number) and would therefore typically occupy a fixed length bit-field of the minimum number of bits needed to encode the index. (Although it could in principle be arbitrarily large.) This is followed by the encoding of the chosen alternative, with alternatives that are extension additions encoded as if they were the value of an open type field. Where the choice has only one alternative, there is no encoding for the index. (Inherited from PERAlignedEncoder.)
Public method | encodeChoicePreamble | (Inherited from PERAlignedEncoder.)
Public method | encodeClassType | (Inherited from Encoder.)
Protected method | encodeConstraintLengthDeterminant | Encoding constraint length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedEncoder.)
Protected method | encodeConstraintNumber | (Overrides PERAlignedEncoderencodeConstraintNumber(Int64, Int64, Int64, BitArrayOutputStream).)
Public method | encodeCSElement | (Inherited from Encoder.)
Protected method | encodeCSEnum | (Inherited from Encoder.)
Public method | encodeElement | (Inherited from Encoder.)
Public method | encodeEnum | (Inherited from Encoder.)
Public method | encodeEnumItem | (Inherited from PERAlignedEncoder.)
Public method | encodeInteger | (Inherited from PERAlignedEncoder.)
Protected method | encodeIntegerValueAsBytes | (Inherited from PERAlignedEncoder.)
Protected method | encodeLength | (Inherited from PERAlignedEncoder.)
Protected method | encodeLengthDeterminant | Encoding length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedEncoder.)
Protected method | encodeNormallySmallNumber | Encode normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index. (Inherited from PERAlignedEncoder.)
Public method | encodeNull | (Inherited from PERAlignedEncoder.)
Public method | encodeObjectIdentifier | (Inherited from PERAlignedEncoder.)
Public method | encodeOctetString | (Inherited from PERAlignedEncoder.)
Public method | encodePreparedElement | (Inherited from Encoder.)
Public method | encodeReal | (Inherited from PERAlignedEncoder.)
Protected method | encodeSemiConstraintNumber | Encoding of a semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedEncoder.)
Public method | encodeSequence | (Inherited from PERAlignedEncoder.)
Public method | encodeSequenceField | (Inherited from Encoder.)
Public method | encodeSequenceOf | (Inherited from PERAlignedEncoder.)
Public method | encodeSequencePreamble | (Inherited from PERAlignedEncoder.)
Public method | encodeSet | (Inherited from PERAlignedEncoder.)
Public method | encodeString | (Overrides PERAlignedEncoderencodeString(Object, Stream, ElementInfo).)
Protected method | encodeUnconstraintNumber | Encoding of a unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedEncoder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement | (Inherited from Encoder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField | (Inherited from Encoder.)
Public method | invokeSelectedMethodForField | (Inherited from Encoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Coders.PER Namespace


PERUnalignedEncoder Constructor

Grid Solutions Framework PERUnalignedEncoder Constructor
Initializes a new instance of the PERUnalignedEncoder class

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PERUnalignedEncoder()
Public Sub New
new : unit -> PERUnalignedEncoder
GSF.ASN1.Coders.PER.PERUnalignedEncoder = function();
public:
PERUnalignedEncoder()
See Also

Reference

PERUnalignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedEncoder Methods

Grid Solutions Framework PERUnalignedEncoder Methods

The PERUnalignedEncoder type exposes the following members.

Methods
 | Name | Description
Protected method | doAlign | (Overrides PERAlignedEncoderdoAlign(Stream).)
Public method | encodeT | (Inherited from PERAlignedEncoder.)
Public method | encodeAny | (Inherited from PERAlignedEncoder.)
Public method | encodeBitString | (Inherited from PERAlignedEncoder.)
Public method | encodeBoolean | (Inherited from PERAlignedEncoder.)
Public method | encodeBoxedType | (Inherited from Encoder.)
Public method | encodeChoice | Encoding of the choice structure ITU-T X.691. 22. NOTE – (Tutorial) A choice type is encoded by encoding an index specifying the chosen alternative. This is encoded as for a constrained integer (unless the extension marker is present in the choice type, in which case it is a normally small non-negative whole number) and would therefore typically occupy a fixed length bit-field of the minimum number of bits needed to encode the index. (Although it could in principle be arbitrarily large.) This is followed by the encoding of the chosen alternative, with alternatives that are extension additions encoded as if they were the value of an open type field. Where the choice has only one alternative, there is no encoding for the index. (Inherited from PERAlignedEncoder.)
Public method | encodeChoicePreamble | (Inherited from PERAlignedEncoder.)
Public method | encodeClassType | (Inherited from Encoder.)
Protected method | encodeConstraintLengthDeterminant | Encoding constraint length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedEncoder.)
Protected method | encodeConstraintNumber | (Overrides PERAlignedEncoderencodeConstraintNumber(Int64, Int64, Int64, BitArrayOutputStream).)
Public method | encodeCSElement | (Inherited from Encoder.)
Protected method | encodeCSEnum | (Inherited from Encoder.)
Public method | encodeElement | (Inherited from Encoder.)
Public method | encodeEnum | (Inherited from Encoder.)
Public method | encodeEnumItem | (Inherited from PERAlignedEncoder.)
Public method | encodeInteger | (Inherited from PERAlignedEncoder.)
Protected method | encodeIntegerValueAsBytes | (Inherited from PERAlignedEncoder.)
Protected method | encodeLength | (Inherited from PERAlignedEncoder.)
Protected method | encodeLengthDeterminant | Encoding length determinant procedure. ITU-T X.691. 10.9. General rules for encoding a length determinant (Inherited from PERAlignedEncoder.)
Protected method | encodeNormallySmallNumber | Encode normally small number ITU-T X.691. 10.6 NOTE – (Tutorial) This procedure is used when encoding a non-negative whole number that is expected to be small, but whose size is potentially unlimited due to the presence of an extension marker. An example is a choice index. (Inherited from PERAlignedEncoder.)
Public method | encodeNull | (Inherited from PERAlignedEncoder.)
Public method | encodeObjectIdentifier | (Inherited from PERAlignedEncoder.)
Public method | encodeOctetString | (Inherited from PERAlignedEncoder.)
Public method | encodePreparedElement | (Inherited from Encoder.)
Public method | encodeReal | (Inherited from PERAlignedEncoder.)
Protected method | encodeSemiConstraintNumber | Encoding of a semi-constrained whole number ITU-T X.691. 10.7. NOTE – (Tutorial) This procedure is used when a lower bound can be identified but not an upper bound. The encoding procedure places the offset from the lower bound into the minimum number of octets as a non-negative-binary-integer, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedEncoder.)
Public method | encodeSequence | (Inherited from PERAlignedEncoder.)
Public method | encodeSequenceField | (Inherited from Encoder.)
Public method | encodeSequenceOf | (Inherited from PERAlignedEncoder.)
Public method | encodeSequencePreamble | (Inherited from PERAlignedEncoder.)
Public method | encodeSet | (Inherited from PERAlignedEncoder.)
Public method | encodeString | (Overrides PERAlignedEncoderencodeString(Object, Stream, ElementInfo).)
Protected method | encodeUnconstraintNumber | Encoding of a unconstrained whole number ITU-T X.691. 10.8. NOTE – (Tutorial) This case only arises in the encoding of the value of an integer type with no lower bound. The procedure encodes the value as a 2's-complement-binary-integer into the minimum number of octets required to accommodate the encoding, and requires an explicit length encoding (typically a single octet) as specified in later procedures. (Inherited from PERAlignedEncoder.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | getChoiceSelectedElement | (Inherited from Encoder.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | invokeGetterMethodForField | (Inherited from Encoder.)
Public method | invokeSelectedMethodForField | (Inherited from Encoder.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PERUnalignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedEncoder.doAlign Method

Grid Solutions Framework PERUnalignedEncoderdoAlign Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.doAlign(System.IO.Stream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void doAlign(
    Stream stream
)
Protected Overrides Sub doAlign (
    stream As Stream
)
abstract doAlign :
        stream : Stream -> unit
override doAlign :
        stream : Stream -> unit
function doAlign(stream);
protected:
virtual void doAlign(
    Stream^ stream
) override

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.doAlign(System.IO.Stream)"]

See Also

Reference

PERUnalignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedEncoder.encodeConstraintNumber Method

Grid Solutions Framework PERUnalignedEncoderencodeConstraintNumber Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int encodeConstraintNumber(
    long val,
    long min,
    long max,
    BitArrayOutputStream stream
)
Protected Overrides Function encodeConstraintNumber (
    val As Long,
    min As Long,
    max As Long,
    stream As BitArrayOutputStream
) As Integer
abstract encodeConstraintNumber :
        val : int64 *
        min : int64 *
        max : int64 *
        stream : BitArrayOutputStream -> int
override encodeConstraintNumber :
        val : int64 *
        min : int64 *
        max : int64 *
        stream : BitArrayOutputStream -> int
function encodeConstraintNumber(val, min, max, stream);
protected:
virtual int encodeConstraintNumber(
    long long val,
    long long min,
    long long max,
    BitArrayOutputStream^ stream
) override

Parameters

val
Type: SystemInt64

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

min
Type: SystemInt64

[Missing <param name="min"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

max
Type: SystemInt64

[Missing <param name="max"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

stream
Type: GSF.ASN1.UtilitiesBitArrayOutputStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeConstraintNumber(System.Int64,System.Int64,System.Int64,GSF.ASN1.Utilities.BitArrayOutputStream)"]

See Also

Reference

PERUnalignedEncoder Class
GSF.ASN1.Coders.PER Namespace


PERUnalignedEncoder.encodeString Method

Grid Solutions Framework PERUnalignedEncoderencodeString Method

[Missing <summary> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Coders.PER
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encodeString(
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encodeString (
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encodeString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encodeString :
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encodeString(obj, stream, elementInfo);
public:
virtual int encodeString(
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Coders.PER.PERUnalignedEncoder.encodeString(System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1TypesEncoderencodeString(Object, Stream, ElementInfo)
See Also

Reference

PERUnalignedEncoder Class
GSF.ASN1.Coders.PER Namespace


GSF.ASN1.Metadata Namespace

Grid Solutions Framework GSF.ASN1.Metadata Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Metadata"]

Classes
 | Class | Description
Public class | ASN1AnyMetadata |
Public class | ASN1BitStringMetadata |
Public class | ASN1BooleanMetadata |
Public class | ASN1BoxedTypeMetadata |
Public class | ASN1ChoiceMetadata |
Public class | ASN1ElementMetadata |
Public class | ASN1EnumItemMetadata |
Public class | ASN1EnumMetadata |
Public class | ASN1FieldMetadata |
Public class | ASN1IntegerMetadata |
Public class | ASN1Metadata |
Public class | ASN1NullMetadata |
Public class | ASN1ObjectIdentifierMetadata |
Public class | ASN1OctetStringMetadata |
Public class | ASN1RealMetadata |
Public class | ASN1SequenceMetadata |
Public class | ASN1SequenceOfMetadata |
Public class | ASN1StringMetadata |
Public class | ASN1TypeMetadata |
Interfaces
 | Interface | Description
Public interface | IASN1Metadata |


ASN1AnyMetadata Class

Grid Solutions Framework ASN1AnyMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1AnyMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1AnyMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1AnyMetadata : ASN1FieldMetadata
Public Class ASN1AnyMetadata
    Inherits ASN1FieldMetadata
type ASN1AnyMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1AnyMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1AnyMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1AnyMetadata : public ASN1FieldMetadata

The ASN1AnyMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1AnyMetadata(String) | Initializes a new instance of the ASN1AnyMetadata class
Public method | ASN1AnyMetadata(ASN1Any) | Initializes a new instance of the ASN1AnyMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1AnyMetadata Constructor

Grid Solutions Framework ASN1AnyMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1AnyMetadata(String) | Initializes a new instance of the ASN1AnyMetadata class
Public method | ASN1AnyMetadata(ASN1Any) | Initializes a new instance of the ASN1AnyMetadata class
Top
See Also

Reference

ASN1AnyMetadata Class
GSF.ASN1.Metadata Namespace


ASN1AnyMetadata Constructor (String)

Grid Solutions Framework ASN1AnyMetadata Constructor (String)
Initializes a new instance of the ASN1AnyMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1AnyMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1AnyMetadata
GSF.ASN1.Metadata.ASN1AnyMetadata = function(name);
public:
ASN1AnyMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.#ctor(System.String)"]

See Also

Reference

ASN1AnyMetadata Class
ASN1AnyMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1AnyMetadata Constructor (ASN1Any)

Grid Solutions Framework ASN1AnyMetadata Constructor (ASN1Any)
Initializes a new instance of the ASN1AnyMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1AnyMetadata(
    ASN1Any annotation
)
Public Sub New (
    annotation As ASN1Any
)
new :
        annotation : ASN1Any -> ASN1AnyMetadata
GSF.ASN1.Metadata.ASN1AnyMetadata = function(annotation);
public:
ASN1AnyMetadata(
    ASN1Any^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Any

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.#ctor(GSF.ASN1.Attributes.ASN1Any)"]

See Also

Reference

ASN1AnyMetadata Class
ASN1AnyMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1AnyMetadata Methods

Grid Solutions Framework ASN1AnyMetadata Methods

The ASN1AnyMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1AnyMetadata Class
GSF.ASN1.Metadata Namespace


ASN1AnyMetadata.decode Method

Grid Solutions Framework ASN1AnyMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1AnyMetadata Class
GSF.ASN1.Metadata Namespace


ASN1AnyMetadata.encode Method

Grid Solutions Framework ASN1AnyMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1AnyMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1AnyMetadata Class
GSF.ASN1.Metadata Namespace


ASN1AnyMetadata Properties

Grid Solutions Framework ASN1AnyMetadata Properties

The ASN1AnyMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1AnyMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata Class

Grid Solutions Framework ASN1BitStringMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1BitStringMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1BitStringMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1BitStringMetadata : ASN1FieldMetadata
Public Class ASN1BitStringMetadata
    Inherits ASN1FieldMetadata
type ASN1BitStringMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1BitStringMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1BitStringMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1BitStringMetadata : public ASN1FieldMetadata

The ASN1BitStringMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1BitStringMetadata(String) | Initializes a new instance of the ASN1BitStringMetadata class
Public method | ASN1BitStringMetadata(ASN1BitString) | Initializes a new instance of the ASN1BitStringMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata Constructor

Grid Solutions Framework ASN1BitStringMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1BitStringMetadata(String) | Initializes a new instance of the ASN1BitStringMetadata class
Public method | ASN1BitStringMetadata(ASN1BitString) | Initializes a new instance of the ASN1BitStringMetadata class
Top
See Also

Reference

ASN1BitStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata Constructor (String)

Grid Solutions Framework ASN1BitStringMetadata Constructor (String)
Initializes a new instance of the ASN1BitStringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BitStringMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1BitStringMetadata
GSF.ASN1.Metadata.ASN1BitStringMetadata = function(name);
public:
ASN1BitStringMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.#ctor(System.String)"]

See Also

Reference

ASN1BitStringMetadata Class
ASN1BitStringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata Constructor (ASN1BitString)

Grid Solutions Framework ASN1BitStringMetadata Constructor (ASN1BitString)
Initializes a new instance of the ASN1BitStringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BitStringMetadata(
    ASN1BitString annotation
)
Public Sub New (
    annotation As ASN1BitString
)
new :
        annotation : ASN1BitString -> ASN1BitStringMetadata
GSF.ASN1.Metadata.ASN1BitStringMetadata = function(annotation);
public:
ASN1BitStringMetadata(
    ASN1BitString^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1BitString

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.#ctor(GSF.ASN1.Attributes.ASN1BitString)"]

See Also

Reference

ASN1BitStringMetadata Class
ASN1BitStringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata Methods

Grid Solutions Framework ASN1BitStringMetadata Methods

The ASN1BitStringMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1BitStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata.decode Method

Grid Solutions Framework ASN1BitStringMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1BitStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata.encode Method

Grid Solutions Framework ASN1BitStringMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1BitStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1BitStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BitStringMetadata Properties

Grid Solutions Framework ASN1BitStringMetadata Properties

The ASN1BitStringMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1BitStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata Class

Grid Solutions Framework ASN1BooleanMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1BooleanMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1BooleanMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1BooleanMetadata : ASN1FieldMetadata
Public Class ASN1BooleanMetadata
    Inherits ASN1FieldMetadata
type ASN1BooleanMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1BooleanMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1BooleanMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1BooleanMetadata : public ASN1FieldMetadata

The ASN1BooleanMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1BooleanMetadata | Initializes a new instance of the ASN1BooleanMetadata class
Public method | ASN1BooleanMetadata(String) | Initializes a new instance of the ASN1BooleanMetadata class
Public method | ASN1BooleanMetadata(ASN1Boolean) | Initializes a new instance of the ASN1BooleanMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata Constructor

Grid Solutions Framework ASN1BooleanMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1BooleanMetadata | Initializes a new instance of the ASN1BooleanMetadata class
Public method | ASN1BooleanMetadata(String) | Initializes a new instance of the ASN1BooleanMetadata class
Public method | ASN1BooleanMetadata(ASN1Boolean) | Initializes a new instance of the ASN1BooleanMetadata class
Top
See Also

Reference

ASN1BooleanMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata Constructor

Grid Solutions Framework ASN1BooleanMetadata Constructor
Initializes a new instance of the ASN1BooleanMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BooleanMetadata()
Public Sub New
new : unit -> ASN1BooleanMetadata
GSF.ASN1.Metadata.ASN1BooleanMetadata = function();
public:
ASN1BooleanMetadata()
See Also

Reference

ASN1BooleanMetadata Class
ASN1BooleanMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata Constructor (String)

Grid Solutions Framework ASN1BooleanMetadata Constructor (String)
Initializes a new instance of the ASN1BooleanMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BooleanMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1BooleanMetadata
GSF.ASN1.Metadata.ASN1BooleanMetadata = function(name);
public:
ASN1BooleanMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.#ctor(System.String)"]

See Also

Reference

ASN1BooleanMetadata Class
ASN1BooleanMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata Constructor (ASN1Boolean)

Grid Solutions Framework ASN1BooleanMetadata Constructor (ASN1Boolean)
Initializes a new instance of the ASN1BooleanMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BooleanMetadata(
    ASN1Boolean annotation
)
Public Sub New (
    annotation As ASN1Boolean
)
new :
        annotation : ASN1Boolean -> ASN1BooleanMetadata
GSF.ASN1.Metadata.ASN1BooleanMetadata = function(annotation);
public:
ASN1BooleanMetadata(
    ASN1Boolean^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Boolean

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.#ctor(GSF.ASN1.Attributes.ASN1Boolean)"]

See Also

Reference

ASN1BooleanMetadata Class
ASN1BooleanMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata Methods

Grid Solutions Framework ASN1BooleanMetadata Methods

The ASN1BooleanMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1BooleanMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata.decode Method

Grid Solutions Framework ASN1BooleanMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1BooleanMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata.encode Method

Grid Solutions Framework ASN1BooleanMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1BooleanMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1BooleanMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BooleanMetadata Properties

Grid Solutions Framework ASN1BooleanMetadata Properties

The ASN1BooleanMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1BooleanMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata Class

Grid Solutions Framework ASN1BoxedTypeMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1BoxedTypeMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1BoxedTypeMetadata : ASN1FieldMetadata
Public Class ASN1BoxedTypeMetadata
    Inherits ASN1FieldMetadata
type ASN1BoxedTypeMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1BoxedTypeMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1BoxedTypeMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1BoxedTypeMetadata : public ASN1FieldMetadata

The ASN1BoxedTypeMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1BoxedTypeMetadata(String) | Initializes a new instance of the ASN1BoxedTypeMetadata class
Public method | ASN1BoxedTypeMetadata(Type, ASN1BoxedType) | Initializes a new instance of the ASN1BoxedTypeMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | setupValueField |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata Constructor

Grid Solutions Framework ASN1BoxedTypeMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1BoxedTypeMetadata(String) | Initializes a new instance of the ASN1BoxedTypeMetadata class
Public method | ASN1BoxedTypeMetadata(Type, ASN1BoxedType) | Initializes a new instance of the ASN1BoxedTypeMetadata class
Top
See Also

Reference

ASN1BoxedTypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata Constructor (String)

Grid Solutions Framework ASN1BoxedTypeMetadata Constructor (String)
Initializes a new instance of the ASN1BoxedTypeMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BoxedTypeMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1BoxedTypeMetadata
GSF.ASN1.Metadata.ASN1BoxedTypeMetadata = function(name);
public:
ASN1BoxedTypeMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.#ctor(System.String)"]

See Also

Reference

ASN1BoxedTypeMetadata Class
ASN1BoxedTypeMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata Constructor (Type, ASN1BoxedType)

Grid Solutions Framework ASN1BoxedTypeMetadata Constructor (Type, ASN1BoxedType)
Initializes a new instance of the ASN1BoxedTypeMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1BoxedTypeMetadata(
    Type objClass,
    ASN1BoxedType annotation
)
Public Sub New (
    objClass As Type,
    annotation As ASN1BoxedType
)
new :
        objClass : Type *
        annotation : ASN1BoxedType -> ASN1BoxedTypeMetadata
GSF.ASN1.Metadata.ASN1BoxedTypeMetadata = function(objClass, annotation);
public:
ASN1BoxedTypeMetadata(
    Type^ objClass,
    ASN1BoxedType^ annotation
)

Parameters

objClass
Type: SystemType

[Missing <param name="objClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.#ctor(System.Type,GSF.ASN1.Attributes.ASN1BoxedType)"]

annotation
Type: GSF.ASN1.AttributesASN1BoxedType

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.#ctor(System.Type,GSF.ASN1.Attributes.ASN1BoxedType)"]

See Also

Reference

ASN1BoxedTypeMetadata Class
ASN1BoxedTypeMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata Methods

Grid Solutions Framework ASN1BoxedTypeMetadata Methods

The ASN1BoxedTypeMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | setupValueField |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1BoxedTypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata.decode Method

Grid Solutions Framework ASN1BoxedTypeMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1BoxedTypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata.encode Method

Grid Solutions Framework ASN1BoxedTypeMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1BoxedTypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata.setupValueField Method

Grid Solutions Framework ASN1BoxedTypeMetadatasetupValueField Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.setupValueField(System.Type)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void setupValueField(
    Type objClass
)
Public Sub setupValueField (
    objClass As Type
)
member setupValueField :
        objClass : Type -> unit

function setupValueField(objClass);
public:
void setupValueField(
    Type^ objClass
)

Parameters

objClass
Type: SystemType

[Missing <param name="objClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1BoxedTypeMetadata.setupValueField(System.Type)"]

See Also

Reference

ASN1BoxedTypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1BoxedTypeMetadata Properties

Grid Solutions Framework ASN1BoxedTypeMetadata Properties

The ASN1BoxedTypeMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1BoxedTypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata Class

Grid Solutions Framework ASN1ChoiceMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1ChoiceMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1TypeMetadata
GSF.ASN1.MetadataASN1ChoiceMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1ChoiceMetadata : ASN1TypeMetadata
Public Class ASN1ChoiceMetadata
    Inherits ASN1TypeMetadata
type ASN1ChoiceMetadata =
    class
        inherit ASN1TypeMetadata
    end
GSF.ASN1.Metadata.ASN1ChoiceMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1ChoiceMetadata',
    GSF.ASN1.Metadata.ASN1TypeMetadata);
public ref class ASN1ChoiceMetadata : public ASN1TypeMetadata

The ASN1ChoiceMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1ChoiceMetadata(String) | Initializes a new instance of the ASN1ChoiceMetadata class
Public method | ASN1ChoiceMetadata(ASN1Choice) | Initializes a new instance of the ASN1ChoiceMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata Constructor

Grid Solutions Framework ASN1ChoiceMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1ChoiceMetadata(String) | Initializes a new instance of the ASN1ChoiceMetadata class
Public method | ASN1ChoiceMetadata(ASN1Choice) | Initializes a new instance of the ASN1ChoiceMetadata class
Top
See Also

Reference

ASN1ChoiceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata Constructor (String)

Grid Solutions Framework ASN1ChoiceMetadata Constructor (String)
Initializes a new instance of the ASN1ChoiceMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ChoiceMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1ChoiceMetadata
GSF.ASN1.Metadata.ASN1ChoiceMetadata = function(name);
public:
ASN1ChoiceMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.#ctor(System.String)"]

See Also

Reference

ASN1ChoiceMetadata Class
ASN1ChoiceMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata Constructor (ASN1Choice)

Grid Solutions Framework ASN1ChoiceMetadata Constructor (ASN1Choice)
Initializes a new instance of the ASN1ChoiceMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ChoiceMetadata(
    ASN1Choice annotation
)
Public Sub New (
    annotation As ASN1Choice
)
new :
        annotation : ASN1Choice -> ASN1ChoiceMetadata
GSF.ASN1.Metadata.ASN1ChoiceMetadata = function(annotation);
public:
ASN1ChoiceMetadata(
    ASN1Choice^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Choice

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.#ctor(GSF.ASN1.Attributes.ASN1Choice)"]

See Also

Reference

ASN1ChoiceMetadata Class
ASN1ChoiceMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata Methods

Grid Solutions Framework ASN1ChoiceMetadata Methods

The ASN1ChoiceMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1ChoiceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata.decode Method

Grid Solutions Framework ASN1ChoiceMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1ChoiceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata.encode Method

Grid Solutions Framework ASN1ChoiceMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1ChoiceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1ChoiceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ChoiceMetadata Properties

Grid Solutions Framework ASN1ChoiceMetadata Properties

The ASN1ChoiceMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1ChoiceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata Class

Grid Solutions Framework ASN1ElementMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1ElementMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1ElementMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1ElementMetadata : ASN1FieldMetadata
Public Class ASN1ElementMetadata
    Inherits ASN1FieldMetadata
type ASN1ElementMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1ElementMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1ElementMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1ElementMetadata : public ASN1FieldMetadata

The ASN1ElementMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1ElementMetadata(ASN1Element) | Initializes a new instance of the ASN1ElementMetadata class
Public method | ASN1ElementMetadata(String, Boolean, Boolean, Boolean, Int32, Int32, Boolean) | Initializes a new instance of the ASN1ElementMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | HasDefaultValue |
Public property | HasTag |
Public property | IsImplicitTag |
Public property | IsOptional |
Public property | Name | (Inherited from ASN1Metadata.)
Public property | Tag |
Public property | TagClass |
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1ElementMetadata Constructor

Grid Solutions Framework ASN1ElementMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1ElementMetadata(ASN1Element) | Initializes a new instance of the ASN1ElementMetadata class
Public method | ASN1ElementMetadata(String, Boolean, Boolean, Boolean, Int32, Int32, Boolean) | Initializes a new instance of the ASN1ElementMetadata class
Top
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata Constructor (ASN1Element)

Grid Solutions Framework ASN1ElementMetadata Constructor (ASN1Element)
Initializes a new instance of the ASN1ElementMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ElementMetadata(
    ASN1Element annotation
)
Public Sub New (
    annotation As ASN1Element
)
new :
        annotation : ASN1Element -> ASN1ElementMetadata
GSF.ASN1.Metadata.ASN1ElementMetadata = function(annotation);
public:
ASN1ElementMetadata(
    ASN1Element^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Element

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(GSF.ASN1.Attributes.ASN1Element)"]

See Also

Reference

ASN1ElementMetadata Class
ASN1ElementMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata Constructor (String, Boolean, Boolean, Boolean, Int32, Int32, Boolean)

Grid Solutions Framework ASN1ElementMetadata Constructor (String, Boolean, Boolean, Boolean, Int32, Int32, Boolean)
Initializes a new instance of the ASN1ElementMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ElementMetadata(
    string name,
    bool isOptional,
    bool hasTag,
    bool isImplicitTag,
    int tagClass,
    int tag,
    bool hasDefaultValue
)
Public Sub New (
    name As String,
    isOptional As Boolean,
    hasTag As Boolean,
    isImplicitTag As Boolean,
    tagClass As Integer,
    tag As Integer,
    hasDefaultValue As Boolean
)
new :
        name : string *
        isOptional : bool *
        hasTag : bool *
        isImplicitTag : bool *
        tagClass : int *
        tag : int *
        hasDefaultValue : bool -> ASN1ElementMetadata
GSF.ASN1.Metadata.ASN1ElementMetadata = function(name, isOptional, hasTag, isImplicitTag, tagClass, tag, hasDefaultValue);
public:
ASN1ElementMetadata(
    String^ name,
    bool isOptional,
    bool hasTag,
    bool isImplicitTag,
    int tagClass,
    int tag,
    bool hasDefaultValue
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(System.String,System.Boolean,System.Boolean,System.Boolean,System.Int32,System.Int32,System.Boolean)"]

isOptional
Type: SystemBoolean

[Missing <param name="isOptional"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(System.String,System.Boolean,System.Boolean,System.Boolean,System.Int32,System.Int32,System.Boolean)"]

hasTag
Type: SystemBoolean

[Missing <param name="hasTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(System.String,System.Boolean,System.Boolean,System.Boolean,System.Int32,System.Int32,System.Boolean)"]

isImplicitTag
Type: SystemBoolean

[Missing <param name="isImplicitTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(System.String,System.Boolean,System.Boolean,System.Boolean,System.Int32,System.Int32,System.Boolean)"]

tagClass
Type: SystemInt32

[Missing <param name="tagClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(System.String,System.Boolean,System.Boolean,System.Boolean,System.Int32,System.Int32,System.Boolean)"]

tag
Type: SystemInt32

[Missing <param name="tag"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(System.String,System.Boolean,System.Boolean,System.Boolean,System.Int32,System.Int32,System.Boolean)"]

hasDefaultValue
Type: SystemBoolean

[Missing <param name="hasDefaultValue"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.#ctor(System.String,System.Boolean,System.Boolean,System.Boolean,System.Int32,System.Int32,System.Boolean)"]

See Also

Reference

ASN1ElementMetadata Class
ASN1ElementMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata Methods

Grid Solutions Framework ASN1ElementMetadata Methods

The ASN1ElementMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.decode Method

Grid Solutions Framework ASN1ElementMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.encode Method

Grid Solutions Framework ASN1ElementMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1ElementMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata Properties

Grid Solutions Framework ASN1ElementMetadata Properties

The ASN1ElementMetadata type exposes the following members.

Properties
 | Name | Description
Public property | HasDefaultValue |
Public property | HasTag |
Public property | IsImplicitTag |
Public property | IsOptional |
Public property | Name | (Inherited from ASN1Metadata.)
Public property | Tag |
Public property | TagClass |
Top
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.HasDefaultValue Property

Grid Solutions Framework ASN1ElementMetadataHasDefaultValue Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1ElementMetadata.HasDefaultValue"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasDefaultValue { get; }
Public ReadOnly Property HasDefaultValue As Boolean
    Get
member HasDefaultValue : bool with get

function get_HasDefaultValue();

public:
property bool HasDefaultValue {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.HasTag Property

Grid Solutions Framework ASN1ElementMetadataHasTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1ElementMetadata.HasTag"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasTag { get; }
Public ReadOnly Property HasTag As Boolean
    Get
member HasTag : bool with get

function get_HasTag();

public:
property bool HasTag {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.IsImplicitTag Property

Grid Solutions Framework ASN1ElementMetadataIsImplicitTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1ElementMetadata.IsImplicitTag"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsImplicitTag { get; }
Public ReadOnly Property IsImplicitTag As Boolean
    Get
member IsImplicitTag : bool with get

function get_IsImplicitTag();

public:
property bool IsImplicitTag {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.IsOptional Property

Grid Solutions Framework ASN1ElementMetadataIsOptional Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1ElementMetadata.IsOptional"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsOptional { get; }
Public ReadOnly Property IsOptional As Boolean
    Get
member IsOptional : bool with get

function get_IsOptional();

public:
property bool IsOptional {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.Tag Property

Grid Solutions Framework ASN1ElementMetadataTag Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1ElementMetadata.Tag"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Tag { get; }
Public ReadOnly Property Tag As Integer
    Get
member Tag : int with get

function get_Tag();

public:
property int Tag {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ElementMetadata.TagClass Property

Grid Solutions Framework ASN1ElementMetadataTagClass Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1ElementMetadata.TagClass"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TagClass { get; }
Public ReadOnly Property TagClass As Integer
    Get
member TagClass : int with get

function get_TagClass();

public:
property int TagClass {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ASN1ElementMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata Class

Grid Solutions Framework ASN1EnumItemMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1EnumItemMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1EnumItemMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1EnumItemMetadata : ASN1FieldMetadata
Public Class ASN1EnumItemMetadata
    Inherits ASN1FieldMetadata
type ASN1EnumItemMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1EnumItemMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1EnumItemMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1EnumItemMetadata : public ASN1FieldMetadata

The ASN1EnumItemMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1EnumItemMetadata(String, Type) | Initializes a new instance of the ASN1EnumItemMetadata class
Public method | ASN1EnumItemMetadata(ASN1EnumItem, Type) | Initializes a new instance of the ASN1EnumItemMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata Constructor

Grid Solutions Framework ASN1EnumItemMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1EnumItemMetadata(String, Type) | Initializes a new instance of the ASN1EnumItemMetadata class
Public method | ASN1EnumItemMetadata(ASN1EnumItem, Type) | Initializes a new instance of the ASN1EnumItemMetadata class
Top
See Also

Reference

ASN1EnumItemMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata Constructor (String, Type)

Grid Solutions Framework ASN1EnumItemMetadata Constructor (String, Type)
Initializes a new instance of the ASN1EnumItemMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1EnumItemMetadata(
    string name,
    Type enumClass
)
Public Sub New (
    name As String,
    enumClass As Type
)
new :
        name : string *
        enumClass : Type -> ASN1EnumItemMetadata
GSF.ASN1.Metadata.ASN1EnumItemMetadata = function(name, enumClass);
public:
ASN1EnumItemMetadata(
    String^ name,
    Type^ enumClass
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.#ctor(System.String,System.Type)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.#ctor(System.String,System.Type)"]

See Also

Reference

ASN1EnumItemMetadata Class
ASN1EnumItemMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata Constructor (ASN1EnumItem, Type)

Grid Solutions Framework ASN1EnumItemMetadata Constructor (ASN1EnumItem, Type)
Initializes a new instance of the ASN1EnumItemMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1EnumItemMetadata(
    ASN1EnumItem annotation,
    Type enumClass
)
Public Sub New (
    annotation As ASN1EnumItem,
    enumClass As Type
)
new :
        annotation : ASN1EnumItem *
        enumClass : Type -> ASN1EnumItemMetadata
GSF.ASN1.Metadata.ASN1EnumItemMetadata = function(annotation, enumClass);
public:
ASN1EnumItemMetadata(
    ASN1EnumItem^ annotation,
    Type^ enumClass
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1EnumItem

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.#ctor(GSF.ASN1.Attributes.ASN1EnumItem,System.Type)"]

enumClass
Type: SystemType

[Missing <param name="enumClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.#ctor(GSF.ASN1.Attributes.ASN1EnumItem,System.Type)"]

See Also

Reference

ASN1EnumItemMetadata Class
ASN1EnumItemMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata Methods

Grid Solutions Framework ASN1EnumItemMetadata Methods

The ASN1EnumItemMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1EnumItemMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata.decode Method

Grid Solutions Framework ASN1EnumItemMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1EnumItemMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata.encode Method

Grid Solutions Framework ASN1EnumItemMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1EnumItemMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1EnumItemMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumItemMetadata Properties

Grid Solutions Framework ASN1EnumItemMetadata Properties

The ASN1EnumItemMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1EnumItemMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumMetadata Class

Grid Solutions Framework ASN1EnumMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1EnumMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1TypeMetadata
GSF.ASN1.MetadataASN1EnumMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1EnumMetadata : ASN1TypeMetadata
Public Class ASN1EnumMetadata
    Inherits ASN1TypeMetadata
type ASN1EnumMetadata =
    class
        inherit ASN1TypeMetadata
    end
GSF.ASN1.Metadata.ASN1EnumMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1EnumMetadata',
    GSF.ASN1.Metadata.ASN1TypeMetadata);
public ref class ASN1EnumMetadata : public ASN1TypeMetadata

The ASN1EnumMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1EnumMetadata(String) | Initializes a new instance of the ASN1EnumMetadata class
Public method | ASN1EnumMetadata(ASN1Enum) | Initializes a new instance of the ASN1EnumMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1EnumMetadata Constructor

Grid Solutions Framework ASN1EnumMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1EnumMetadata(String) | Initializes a new instance of the ASN1EnumMetadata class
Public method | ASN1EnumMetadata(ASN1Enum) | Initializes a new instance of the ASN1EnumMetadata class
Top
See Also

Reference

ASN1EnumMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumMetadata Constructor (String)

Grid Solutions Framework ASN1EnumMetadata Constructor (String)
Initializes a new instance of the ASN1EnumMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1EnumMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1EnumMetadata
GSF.ASN1.Metadata.ASN1EnumMetadata = function(name);
public:
ASN1EnumMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.#ctor(System.String)"]

See Also

Reference

ASN1EnumMetadata Class
ASN1EnumMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1EnumMetadata Constructor (ASN1Enum)

Grid Solutions Framework ASN1EnumMetadata Constructor (ASN1Enum)
Initializes a new instance of the ASN1EnumMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1EnumMetadata(
    ASN1Enum annotation
)
Public Sub New (
    annotation As ASN1Enum
)
new :
        annotation : ASN1Enum -> ASN1EnumMetadata
GSF.ASN1.Metadata.ASN1EnumMetadata = function(annotation);
public:
ASN1EnumMetadata(
    ASN1Enum^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Enum

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.#ctor(GSF.ASN1.Attributes.ASN1Enum)"]

See Also

Reference

ASN1EnumMetadata Class
ASN1EnumMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1EnumMetadata Methods

Grid Solutions Framework ASN1EnumMetadata Methods

The ASN1EnumMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1EnumMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumMetadata.decode Method

Grid Solutions Framework ASN1EnumMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1EnumMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumMetadata.encode Method

Grid Solutions Framework ASN1EnumMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1EnumMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1EnumMetadata Class
GSF.ASN1.Metadata Namespace


ASN1EnumMetadata Properties

Grid Solutions Framework ASN1EnumMetadata Properties

The ASN1EnumMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1EnumMetadata Class
GSF.ASN1.Metadata Namespace


ASN1FieldMetadata Class

Grid Solutions Framework ASN1FieldMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1FieldMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
More...

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ASN1FieldMetadata : ASN1Metadata
Public MustInherit Class ASN1FieldMetadata
    Inherits ASN1Metadata
[<AbstractClassAttribute>]
type ASN1FieldMetadata =
    class
        inherit ASN1Metadata
    end
GSF.ASN1.Metadata.ASN1FieldMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1FieldMetadata',
    GSF.ASN1.Metadata.ASN1Metadata);
public ref class ASN1FieldMetadata abstract : public ASN1Metadata

The ASN1FieldMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1FieldMetadata | Initializes a new instance of the ASN1FieldMetadata class
Public method | ASN1FieldMetadata(String) | Initializes a new instance of the ASN1FieldMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Inherited from ASN1Metadata.)
Public method | encode | (Inherited from ASN1Metadata.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace
Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1AnyMetadata
GSF.ASN1.MetadataASN1BitStringMetadata
GSF.ASN1.MetadataASN1BooleanMetadata
GSF.ASN1.MetadataASN1BoxedTypeMetadata
GSF.ASN1.MetadataASN1ElementMetadata
GSF.ASN1.MetadataASN1EnumItemMetadata
GSF.ASN1.MetadataASN1IntegerMetadata
GSF.ASN1.MetadataASN1NullMetadata
GSF.ASN1.MetadataASN1ObjectIdentifierMetadata
GSF.ASN1.MetadataASN1OctetStringMetadata
GSF.ASN1.MetadataASN1RealMetadata
GSF.ASN1.MetadataASN1SequenceOfMetadata
GSF.ASN1.MetadataASN1StringMetadata


ASN1FieldMetadata Constructor

Grid Solutions Framework ASN1FieldMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1FieldMetadata | Initializes a new instance of the ASN1FieldMetadata class
Public method | ASN1FieldMetadata(String) | Initializes a new instance of the ASN1FieldMetadata class
Top
See Also

Reference

ASN1FieldMetadata Class
GSF.ASN1.Metadata Namespace


ASN1FieldMetadata Constructor

Grid Solutions Framework ASN1FieldMetadata Constructor
Initializes a new instance of the ASN1FieldMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1FieldMetadata()
Public Sub New
new : unit -> ASN1FieldMetadata
GSF.ASN1.Metadata.ASN1FieldMetadata = function();
public:
ASN1FieldMetadata()
See Also

Reference

ASN1FieldMetadata Class
ASN1FieldMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1FieldMetadata Constructor (String)

Grid Solutions Framework ASN1FieldMetadata Constructor (String)
Initializes a new instance of the ASN1FieldMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1FieldMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1FieldMetadata
GSF.ASN1.Metadata.ASN1FieldMetadata = function(name);
public:
ASN1FieldMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1FieldMetadata.#ctor(System.String)"]

See Also

Reference

ASN1FieldMetadata Class
ASN1FieldMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1FieldMetadata Methods

Grid Solutions Framework ASN1FieldMetadata Methods

The ASN1FieldMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Inherited from ASN1Metadata.)
Public method | encode | (Inherited from ASN1Metadata.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1FieldMetadata Class
GSF.ASN1.Metadata Namespace


ASN1FieldMetadata Properties

Grid Solutions Framework ASN1FieldMetadata Properties

The ASN1FieldMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1FieldMetadata Class
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata Class

Grid Solutions Framework ASN1IntegerMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1IntegerMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1IntegerMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1IntegerMetadata : ASN1FieldMetadata
Public Class ASN1IntegerMetadata
    Inherits ASN1FieldMetadata
type ASN1IntegerMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1IntegerMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1IntegerMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1IntegerMetadata : public ASN1FieldMetadata

The ASN1IntegerMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1IntegerMetadata | Initializes a new instance of the ASN1IntegerMetadata class
Public method | ASN1IntegerMetadata(String) | Initializes a new instance of the ASN1IntegerMetadata class
Public method | ASN1IntegerMetadata(ASN1Integer) | Initializes a new instance of the ASN1IntegerMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata Constructor

Grid Solutions Framework ASN1IntegerMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1IntegerMetadata | Initializes a new instance of the ASN1IntegerMetadata class
Public method | ASN1IntegerMetadata(String) | Initializes a new instance of the ASN1IntegerMetadata class
Public method | ASN1IntegerMetadata(ASN1Integer) | Initializes a new instance of the ASN1IntegerMetadata class
Top
See Also

Reference

ASN1IntegerMetadata Class
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata Constructor

Grid Solutions Framework ASN1IntegerMetadata Constructor
Initializes a new instance of the ASN1IntegerMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1IntegerMetadata()
Public Sub New
new : unit -> ASN1IntegerMetadata
GSF.ASN1.Metadata.ASN1IntegerMetadata = function();
public:
ASN1IntegerMetadata()
See Also

Reference

ASN1IntegerMetadata Class
ASN1IntegerMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata Constructor (String)

Grid Solutions Framework ASN1IntegerMetadata Constructor (String)
Initializes a new instance of the ASN1IntegerMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1IntegerMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1IntegerMetadata
GSF.ASN1.Metadata.ASN1IntegerMetadata = function(name);
public:
ASN1IntegerMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.#ctor(System.String)"]

See Also

Reference

ASN1IntegerMetadata Class
ASN1IntegerMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata Constructor (ASN1Integer)

Grid Solutions Framework ASN1IntegerMetadata Constructor (ASN1Integer)
Initializes a new instance of the ASN1IntegerMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1IntegerMetadata(
    ASN1Integer annotation
)
Public Sub New (
    annotation As ASN1Integer
)
new :
        annotation : ASN1Integer -> ASN1IntegerMetadata
GSF.ASN1.Metadata.ASN1IntegerMetadata = function(annotation);
public:
ASN1IntegerMetadata(
    ASN1Integer^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Integer

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.#ctor(GSF.ASN1.Attributes.ASN1Integer)"]

See Also

Reference

ASN1IntegerMetadata Class
ASN1IntegerMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata Methods

Grid Solutions Framework ASN1IntegerMetadata Methods

The ASN1IntegerMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1IntegerMetadata Class
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata.decode Method

Grid Solutions Framework ASN1IntegerMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1IntegerMetadata Class
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata.encode Method

Grid Solutions Framework ASN1IntegerMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1IntegerMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1IntegerMetadata Class
GSF.ASN1.Metadata Namespace


ASN1IntegerMetadata Properties

Grid Solutions Framework ASN1IntegerMetadata Properties

The ASN1IntegerMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1IntegerMetadata Class
GSF.ASN1.Metadata Namespace


ASN1Metadata Class

Grid Solutions Framework ASN1Metadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1Metadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1TypeMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ASN1Metadata : IASN1Metadata
Public MustInherit Class ASN1Metadata
    Implements IASN1Metadata
[<AbstractClassAttribute>]
type ASN1Metadata =
    class
        interface IASN1Metadata
    end
GSF.ASN1.Metadata.ASN1Metadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1Metadata',
    null,
    GSF.ASN1.Metadata.IASN1Metadata);
public ref class ASN1Metadata abstract : IASN1Metadata

The ASN1Metadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1Metadata | Initializes a new instance of the ASN1Metadata class
Public method | ASN1Metadata(String) | Initializes a new instance of the ASN1Metadata class
Top
Methods
 | Name | Description
Public method | decode |
Public method | encode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1Metadata Constructor

Grid Solutions Framework ASN1Metadata Constructor
Overload List
 | Name | Description
Public method | ASN1Metadata | Initializes a new instance of the ASN1Metadata class
Public method | ASN1Metadata(String) | Initializes a new instance of the ASN1Metadata class
Top
See Also

Reference

ASN1Metadata Class
GSF.ASN1.Metadata Namespace


ASN1Metadata Constructor

Grid Solutions Framework ASN1Metadata Constructor
Initializes a new instance of the ASN1Metadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Metadata()
Public Sub New
new : unit -> ASN1Metadata
GSF.ASN1.Metadata.ASN1Metadata = function();
public:
ASN1Metadata()
See Also

Reference

ASN1Metadata Class
ASN1Metadata Overload
GSF.ASN1.Metadata Namespace


ASN1Metadata Constructor (String)

Grid Solutions Framework ASN1Metadata Constructor (String)
Initializes a new instance of the ASN1Metadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1Metadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1Metadata
GSF.ASN1.Metadata.ASN1Metadata = function(name);
public:
ASN1Metadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.#ctor(System.String)"]

See Also

Reference

ASN1Metadata Class
ASN1Metadata Overload
GSF.ASN1.Metadata Namespace


ASN1Metadata Methods

Grid Solutions Framework ASN1Metadata Methods

The ASN1Metadata type exposes the following members.

Methods
 | Name | Description
Public method | decode |
Public method | encode |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1Metadata Class
GSF.ASN1.Metadata Namespace


ASN1Metadata.decode Method

Grid Solutions Framework ASN1Metadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public MustOverride Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) abstract

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1Metadata Class
GSF.ASN1.Metadata Namespace


ASN1Metadata.encode Method

Grid Solutions Framework ASN1Metadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public MustOverride Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) abstract

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1Metadata Class
GSF.ASN1.Metadata Namespace


ASN1Metadata.setParentAnnotated Method

Grid Solutions Framework ASN1MetadatasetParentAnnotated Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.setParentAnnotated(System.Reflection.ICustomAttributeProvider)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void setParentAnnotated(
    ICustomAttributeProvider parentAnnotated
)
Public Overridable Sub setParentAnnotated (
    parentAnnotated As ICustomAttributeProvider
)
abstract setParentAnnotated :
        parentAnnotated : ICustomAttributeProvider -> unit
override setParentAnnotated :
        parentAnnotated : ICustomAttributeProvider -> unit
function setParentAnnotated(parentAnnotated);
public:
virtual void setParentAnnotated(
    ICustomAttributeProvider^ parentAnnotated
)

Parameters

parentAnnotated
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="parentAnnotated"/> documentation for "M:GSF.ASN1.Metadata.ASN1Metadata.setParentAnnotated(System.Reflection.ICustomAttributeProvider)"]

See Also

Reference

ASN1Metadata Class
GSF.ASN1.Metadata Namespace


ASN1Metadata Properties

Grid Solutions Framework ASN1Metadata Properties

The ASN1Metadata type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

ASN1Metadata Class
GSF.ASN1.Metadata Namespace


ASN1Metadata.Name Property

Grid Solutions Framework ASN1MetadataName Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1Metadata.Name"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IASN1MetadataName
See Also

Reference

ASN1Metadata Class
GSF.ASN1.Metadata Namespace


ASN1NullMetadata Class

Grid Solutions Framework ASN1NullMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1NullMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1NullMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1NullMetadata : ASN1FieldMetadata
Public Class ASN1NullMetadata
    Inherits ASN1FieldMetadata
type ASN1NullMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1NullMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1NullMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1NullMetadata : public ASN1FieldMetadata

The ASN1NullMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1NullMetadata(String) | Initializes a new instance of the ASN1NullMetadata class
Public method | ASN1NullMetadata(ASN1Null) | Initializes a new instance of the ASN1NullMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1NullMetadata Constructor

Grid Solutions Framework ASN1NullMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1NullMetadata(String) | Initializes a new instance of the ASN1NullMetadata class
Public method | ASN1NullMetadata(ASN1Null) | Initializes a new instance of the ASN1NullMetadata class
Top
See Also

Reference

ASN1NullMetadata Class
GSF.ASN1.Metadata Namespace


ASN1NullMetadata Constructor (String)

Grid Solutions Framework ASN1NullMetadata Constructor (String)
Initializes a new instance of the ASN1NullMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1NullMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1NullMetadata
GSF.ASN1.Metadata.ASN1NullMetadata = function(name);
public:
ASN1NullMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.#ctor(System.String)"]

See Also

Reference

ASN1NullMetadata Class
ASN1NullMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1NullMetadata Constructor (ASN1Null)

Grid Solutions Framework ASN1NullMetadata Constructor (ASN1Null)
Initializes a new instance of the ASN1NullMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1NullMetadata(
    ASN1Null annotation
)
Public Sub New (
    annotation As ASN1Null
)
new :
        annotation : ASN1Null -> ASN1NullMetadata
GSF.ASN1.Metadata.ASN1NullMetadata = function(annotation);
public:
ASN1NullMetadata(
    ASN1Null^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Null

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.#ctor(GSF.ASN1.Attributes.ASN1Null)"]

See Also

Reference

ASN1NullMetadata Class
ASN1NullMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1NullMetadata Methods

Grid Solutions Framework ASN1NullMetadata Methods

The ASN1NullMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1NullMetadata Class
GSF.ASN1.Metadata Namespace


ASN1NullMetadata.decode Method

Grid Solutions Framework ASN1NullMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1NullMetadata Class
GSF.ASN1.Metadata Namespace


ASN1NullMetadata.encode Method

Grid Solutions Framework ASN1NullMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1NullMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1NullMetadata Class
GSF.ASN1.Metadata Namespace


ASN1NullMetadata Properties

Grid Solutions Framework ASN1NullMetadata Properties

The ASN1NullMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1NullMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata Class

Grid Solutions Framework ASN1ObjectIdentifierMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1ObjectIdentifierMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1ObjectIdentifierMetadata : ASN1FieldMetadata
Public Class ASN1ObjectIdentifierMetadata
    Inherits ASN1FieldMetadata
type ASN1ObjectIdentifierMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1ObjectIdentifierMetadata : public ASN1FieldMetadata

The ASN1ObjectIdentifierMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1ObjectIdentifierMetadata(String) | Initializes a new instance of the ASN1ObjectIdentifierMetadata class
Public method | ASN1ObjectIdentifierMetadata(ASN1ObjectIdentifier) | Initializes a new instance of the ASN1ObjectIdentifierMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata Constructor

Grid Solutions Framework ASN1ObjectIdentifierMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1ObjectIdentifierMetadata(String) | Initializes a new instance of the ASN1ObjectIdentifierMetadata class
Public method | ASN1ObjectIdentifierMetadata(ASN1ObjectIdentifier) | Initializes a new instance of the ASN1ObjectIdentifierMetadata class
Top
See Also

Reference

ASN1ObjectIdentifierMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata Constructor (String)

Grid Solutions Framework ASN1ObjectIdentifierMetadata Constructor (String)
Initializes a new instance of the ASN1ObjectIdentifierMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ObjectIdentifierMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1ObjectIdentifierMetadata
GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata = function(name);
public:
ASN1ObjectIdentifierMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.#ctor(System.String)"]

See Also

Reference

ASN1ObjectIdentifierMetadata Class
ASN1ObjectIdentifierMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata Constructor (ASN1ObjectIdentifier)

Grid Solutions Framework ASN1ObjectIdentifierMetadata Constructor (ASN1ObjectIdentifier)
Initializes a new instance of the ASN1ObjectIdentifierMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ObjectIdentifierMetadata(
    ASN1ObjectIdentifier annotation
)
Public Sub New (
    annotation As ASN1ObjectIdentifier
)
new :
        annotation : ASN1ObjectIdentifier -> ASN1ObjectIdentifierMetadata
GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata = function(annotation);
public:
ASN1ObjectIdentifierMetadata(
    ASN1ObjectIdentifier^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1ObjectIdentifier

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.#ctor(GSF.ASN1.Attributes.ASN1ObjectIdentifier)"]

See Also

Reference

ASN1ObjectIdentifierMetadata Class
ASN1ObjectIdentifierMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata Methods

Grid Solutions Framework ASN1ObjectIdentifierMetadata Methods

The ASN1ObjectIdentifierMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1ObjectIdentifierMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata.decode Method

Grid Solutions Framework ASN1ObjectIdentifierMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1ObjectIdentifierMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata.encode Method

Grid Solutions Framework ASN1ObjectIdentifierMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1ObjectIdentifierMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1ObjectIdentifierMetadata Class
GSF.ASN1.Metadata Namespace


ASN1ObjectIdentifierMetadata Properties

Grid Solutions Framework ASN1ObjectIdentifierMetadata Properties

The ASN1ObjectIdentifierMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1ObjectIdentifierMetadata Class
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata Class

Grid Solutions Framework ASN1OctetStringMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1OctetStringMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1OctetStringMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1OctetStringMetadata : ASN1FieldMetadata
Public Class ASN1OctetStringMetadata
    Inherits ASN1FieldMetadata
type ASN1OctetStringMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1OctetStringMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1OctetStringMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1OctetStringMetadata : public ASN1FieldMetadata

The ASN1OctetStringMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1OctetStringMetadata | Initializes a new instance of the ASN1OctetStringMetadata class
Public method | ASN1OctetStringMetadata(String) | Initializes a new instance of the ASN1OctetStringMetadata class
Public method | ASN1OctetStringMetadata(ASN1OctetString) | Initializes a new instance of the ASN1OctetStringMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata Constructor

Grid Solutions Framework ASN1OctetStringMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1OctetStringMetadata | Initializes a new instance of the ASN1OctetStringMetadata class
Public method | ASN1OctetStringMetadata(String) | Initializes a new instance of the ASN1OctetStringMetadata class
Public method | ASN1OctetStringMetadata(ASN1OctetString) | Initializes a new instance of the ASN1OctetStringMetadata class
Top
See Also

Reference

ASN1OctetStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata Constructor

Grid Solutions Framework ASN1OctetStringMetadata Constructor
Initializes a new instance of the ASN1OctetStringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1OctetStringMetadata()
Public Sub New
new : unit -> ASN1OctetStringMetadata
GSF.ASN1.Metadata.ASN1OctetStringMetadata = function();
public:
ASN1OctetStringMetadata()
See Also

Reference

ASN1OctetStringMetadata Class
ASN1OctetStringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata Constructor (String)

Grid Solutions Framework ASN1OctetStringMetadata Constructor (String)
Initializes a new instance of the ASN1OctetStringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1OctetStringMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1OctetStringMetadata
GSF.ASN1.Metadata.ASN1OctetStringMetadata = function(name);
public:
ASN1OctetStringMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.#ctor(System.String)"]

See Also

Reference

ASN1OctetStringMetadata Class
ASN1OctetStringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata Constructor (ASN1OctetString)

Grid Solutions Framework ASN1OctetStringMetadata Constructor (ASN1OctetString)
Initializes a new instance of the ASN1OctetStringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1OctetStringMetadata(
    ASN1OctetString annotation
)
Public Sub New (
    annotation As ASN1OctetString
)
new :
        annotation : ASN1OctetString -> ASN1OctetStringMetadata
GSF.ASN1.Metadata.ASN1OctetStringMetadata = function(annotation);
public:
ASN1OctetStringMetadata(
    ASN1OctetString^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1OctetString

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.#ctor(GSF.ASN1.Attributes.ASN1OctetString)"]

See Also

Reference

ASN1OctetStringMetadata Class
ASN1OctetStringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata Methods

Grid Solutions Framework ASN1OctetStringMetadata Methods

The ASN1OctetStringMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1OctetStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata.decode Method

Grid Solutions Framework ASN1OctetStringMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1OctetStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata.encode Method

Grid Solutions Framework ASN1OctetStringMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1OctetStringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1OctetStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1OctetStringMetadata Properties

Grid Solutions Framework ASN1OctetStringMetadata Properties

The ASN1OctetStringMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1OctetStringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1RealMetadata Class

Grid Solutions Framework ASN1RealMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1RealMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1RealMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1RealMetadata : ASN1FieldMetadata
Public Class ASN1RealMetadata
    Inherits ASN1FieldMetadata
type ASN1RealMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1RealMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1RealMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1RealMetadata : public ASN1FieldMetadata

The ASN1RealMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1RealMetadata | Initializes a new instance of the ASN1RealMetadata class
Public method | ASN1RealMetadata(String) | Initializes a new instance of the ASN1RealMetadata class
Public method | ASN1RealMetadata(ASN1Real) | Initializes a new instance of the ASN1RealMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1RealMetadata Constructor

Grid Solutions Framework ASN1RealMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1RealMetadata | Initializes a new instance of the ASN1RealMetadata class
Public method | ASN1RealMetadata(String) | Initializes a new instance of the ASN1RealMetadata class
Public method | ASN1RealMetadata(ASN1Real) | Initializes a new instance of the ASN1RealMetadata class
Top
See Also

Reference

ASN1RealMetadata Class
GSF.ASN1.Metadata Namespace


ASN1RealMetadata Constructor

Grid Solutions Framework ASN1RealMetadata Constructor
Initializes a new instance of the ASN1RealMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1RealMetadata()
Public Sub New
new : unit -> ASN1RealMetadata
GSF.ASN1.Metadata.ASN1RealMetadata = function();
public:
ASN1RealMetadata()
See Also

Reference

ASN1RealMetadata Class
ASN1RealMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1RealMetadata Constructor (String)

Grid Solutions Framework ASN1RealMetadata Constructor (String)
Initializes a new instance of the ASN1RealMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1RealMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1RealMetadata
GSF.ASN1.Metadata.ASN1RealMetadata = function(name);
public:
ASN1RealMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.#ctor(System.String)"]

See Also

Reference

ASN1RealMetadata Class
ASN1RealMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1RealMetadata Constructor (ASN1Real)

Grid Solutions Framework ASN1RealMetadata Constructor (ASN1Real)
Initializes a new instance of the ASN1RealMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1RealMetadata(
    ASN1Real annotation
)
Public Sub New (
    annotation As ASN1Real
)
new :
        annotation : ASN1Real -> ASN1RealMetadata
GSF.ASN1.Metadata.ASN1RealMetadata = function(annotation);
public:
ASN1RealMetadata(
    ASN1Real^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Real

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.#ctor(GSF.ASN1.Attributes.ASN1Real)"]

See Also

Reference

ASN1RealMetadata Class
ASN1RealMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1RealMetadata Methods

Grid Solutions Framework ASN1RealMetadata Methods

The ASN1RealMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1RealMetadata Class
GSF.ASN1.Metadata Namespace


ASN1RealMetadata.decode Method

Grid Solutions Framework ASN1RealMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1RealMetadata Class
GSF.ASN1.Metadata Namespace


ASN1RealMetadata.encode Method

Grid Solutions Framework ASN1RealMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1RealMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1RealMetadata Class
GSF.ASN1.Metadata Namespace


ASN1RealMetadata Properties

Grid Solutions Framework ASN1RealMetadata Properties

The ASN1RealMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1RealMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata Class

Grid Solutions Framework ASN1SequenceMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1SequenceMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1TypeMetadata
GSF.ASN1.MetadataASN1SequenceMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1SequenceMetadata : ASN1TypeMetadata
Public Class ASN1SequenceMetadata
    Inherits ASN1TypeMetadata
type ASN1SequenceMetadata =
    class
        inherit ASN1TypeMetadata
    end
GSF.ASN1.Metadata.ASN1SequenceMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1SequenceMetadata',
    GSF.ASN1.Metadata.ASN1TypeMetadata);
public ref class ASN1SequenceMetadata : public ASN1TypeMetadata

The ASN1SequenceMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1SequenceMetadata(ASN1Sequence) | Initializes a new instance of the ASN1SequenceMetadata class
Public method | ASN1SequenceMetadata(String, Boolean) | Initializes a new instance of the ASN1SequenceMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsSet |
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata Constructor

Grid Solutions Framework ASN1SequenceMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1SequenceMetadata(ASN1Sequence) | Initializes a new instance of the ASN1SequenceMetadata class
Public method | ASN1SequenceMetadata(String, Boolean) | Initializes a new instance of the ASN1SequenceMetadata class
Top
See Also

Reference

ASN1SequenceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata Constructor (ASN1Sequence)

Grid Solutions Framework ASN1SequenceMetadata Constructor (ASN1Sequence)
Initializes a new instance of the ASN1SequenceMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SequenceMetadata(
    ASN1Sequence annotation
)
Public Sub New (
    annotation As ASN1Sequence
)
new :
        annotation : ASN1Sequence -> ASN1SequenceMetadata
GSF.ASN1.Metadata.ASN1SequenceMetadata = function(annotation);
public:
ASN1SequenceMetadata(
    ASN1Sequence^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1Sequence

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.#ctor(GSF.ASN1.Attributes.ASN1Sequence)"]

See Also

Reference

ASN1SequenceMetadata Class
ASN1SequenceMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata Constructor (String, Boolean)

Grid Solutions Framework ASN1SequenceMetadata Constructor (String, Boolean)
Initializes a new instance of the ASN1SequenceMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SequenceMetadata(
    string name,
    bool isSet
)
Public Sub New (
    name As String,
    isSet As Boolean
)
new :
        name : string *
        isSet : bool -> ASN1SequenceMetadata
GSF.ASN1.Metadata.ASN1SequenceMetadata = function(name, isSet);
public:
ASN1SequenceMetadata(
    String^ name,
    bool isSet
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.#ctor(System.String,System.Boolean)"]

isSet
Type: SystemBoolean

[Missing <param name="isSet"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.#ctor(System.String,System.Boolean)"]

See Also

Reference

ASN1SequenceMetadata Class
ASN1SequenceMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata Methods

Grid Solutions Framework ASN1SequenceMetadata Methods

The ASN1SequenceMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1SequenceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata.decode Method

Grid Solutions Framework ASN1SequenceMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1SequenceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata.encode Method

Grid Solutions Framework ASN1SequenceMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1SequenceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata Properties

Grid Solutions Framework ASN1SequenceMetadata Properties

The ASN1SequenceMetadata type exposes the following members.

Properties
 | Name | Description
Public property | IsSet |
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1SequenceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceMetadata.IsSet Property

Grid Solutions Framework ASN1SequenceMetadataIsSet Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1SequenceMetadata.IsSet"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSet { get; }
Public ReadOnly Property IsSet As Boolean
    Get
member IsSet : bool with get

function get_IsSet();

public:
property bool IsSet {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ASN1SequenceMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata Class

Grid Solutions Framework ASN1SequenceOfMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1SequenceOfMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1SequenceOfMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1SequenceOfMetadata : ASN1FieldMetadata
Public Class ASN1SequenceOfMetadata
    Inherits ASN1FieldMetadata
type ASN1SequenceOfMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1SequenceOfMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1SequenceOfMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1SequenceOfMetadata : public ASN1FieldMetadata

The ASN1SequenceOfMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1SequenceOfMetadata(ASN1SequenceOf, Type, ICustomAttributeProvider) | Initializes a new instance of the ASN1SequenceOfMetadata class
Public method | ASN1SequenceOfMetadata(String, Boolean, Type, ICustomAttributeProvider) | Initializes a new instance of the ASN1SequenceOfMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getItemClassMetadata |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsSetOf |
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata Constructor

Grid Solutions Framework ASN1SequenceOfMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1SequenceOfMetadata(ASN1SequenceOf, Type, ICustomAttributeProvider) | Initializes a new instance of the ASN1SequenceOfMetadata class
Public method | ASN1SequenceOfMetadata(String, Boolean, Type, ICustomAttributeProvider) | Initializes a new instance of the ASN1SequenceOfMetadata class
Top
See Also

Reference

ASN1SequenceOfMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata Constructor (ASN1SequenceOf, Type, ICustomAttributeProvider)

Grid Solutions Framework ASN1SequenceOfMetadata Constructor (ASN1SequenceOf, Type, ICustomAttributeProvider)
Initializes a new instance of the ASN1SequenceOfMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SequenceOfMetadata(
    ASN1SequenceOf annotation,
    Type itemClass,
    ICustomAttributeProvider seqFieldAnnotatedElem
)
Public Sub New (
    annotation As ASN1SequenceOf,
    itemClass As Type,
    seqFieldAnnotatedElem As ICustomAttributeProvider
)
new :
        annotation : ASN1SequenceOf *
        itemClass : Type *
        seqFieldAnnotatedElem : ICustomAttributeProvider -> ASN1SequenceOfMetadata
GSF.ASN1.Metadata.ASN1SequenceOfMetadata = function(annotation, itemClass, seqFieldAnnotatedElem);
public:
ASN1SequenceOfMetadata(
    ASN1SequenceOf^ annotation,
    Type^ itemClass,
    ICustomAttributeProvider^ seqFieldAnnotatedElem
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1SequenceOf

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.#ctor(GSF.ASN1.Attributes.ASN1SequenceOf,System.Type,System.Reflection.ICustomAttributeProvider)"]

itemClass
Type: SystemType

[Missing <param name="itemClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.#ctor(GSF.ASN1.Attributes.ASN1SequenceOf,System.Type,System.Reflection.ICustomAttributeProvider)"]

seqFieldAnnotatedElem
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="seqFieldAnnotatedElem"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.#ctor(GSF.ASN1.Attributes.ASN1SequenceOf,System.Type,System.Reflection.ICustomAttributeProvider)"]

See Also

Reference

ASN1SequenceOfMetadata Class
ASN1SequenceOfMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata Constructor (String, Boolean, Type, ICustomAttributeProvider)

Grid Solutions Framework ASN1SequenceOfMetadata Constructor (String, Boolean, Type, ICustomAttributeProvider)
Initializes a new instance of the ASN1SequenceOfMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SequenceOfMetadata(
    string name,
    bool isSetOf,
    Type itemClass,
    ICustomAttributeProvider seqFieldAnnotatedElem
)
Public Sub New (
    name As String,
    isSetOf As Boolean,
    itemClass As Type,
    seqFieldAnnotatedElem As ICustomAttributeProvider
)
new :
        name : string *
        isSetOf : bool *
        itemClass : Type *
        seqFieldAnnotatedElem : ICustomAttributeProvider -> ASN1SequenceOfMetadata
GSF.ASN1.Metadata.ASN1SequenceOfMetadata = function(name, isSetOf, itemClass, seqFieldAnnotatedElem);
public:
ASN1SequenceOfMetadata(
    String^ name,
    bool isSetOf,
    Type^ itemClass,
    ICustomAttributeProvider^ seqFieldAnnotatedElem
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.#ctor(System.String,System.Boolean,System.Type,System.Reflection.ICustomAttributeProvider)"]

isSetOf
Type: SystemBoolean

[Missing <param name="isSetOf"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.#ctor(System.String,System.Boolean,System.Type,System.Reflection.ICustomAttributeProvider)"]

itemClass
Type: SystemType

[Missing <param name="itemClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.#ctor(System.String,System.Boolean,System.Type,System.Reflection.ICustomAttributeProvider)"]

seqFieldAnnotatedElem
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="seqFieldAnnotatedElem"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.#ctor(System.String,System.Boolean,System.Type,System.Reflection.ICustomAttributeProvider)"]

See Also

Reference

ASN1SequenceOfMetadata Class
ASN1SequenceOfMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata Methods

Grid Solutions Framework ASN1SequenceOfMetadata Methods

The ASN1SequenceOfMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getItemClassMetadata |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1SequenceOfMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata.decode Method

Grid Solutions Framework ASN1SequenceOfMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1SequenceOfMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata.encode Method

Grid Solutions Framework ASN1SequenceOfMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1SequenceOfMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata.getItemClassMetadata Method

Grid Solutions Framework ASN1SequenceOfMetadatagetItemClassMetadata Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.getItemClassMetadata"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IASN1PreparedElementData getItemClassMetadata()
Public Function getItemClassMetadata As IASN1PreparedElementData
member getItemClassMetadata : unit -> IASN1PreparedElementData

function getItemClassMetadata();
public:
IASN1PreparedElementData^ getItemClassMetadata()

Return Value

Type: IASN1PreparedElementData

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.getItemClassMetadata"]

See Also

Reference

ASN1SequenceOfMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata Properties

Grid Solutions Framework ASN1SequenceOfMetadata Properties

The ASN1SequenceOfMetadata type exposes the following members.

Properties
 | Name | Description
Public property | IsSetOf |
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1SequenceOfMetadata Class
GSF.ASN1.Metadata Namespace


ASN1SequenceOfMetadata.IsSetOf Property

Grid Solutions Framework ASN1SequenceOfMetadataIsSetOf Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1SequenceOfMetadata.IsSetOf"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSetOf { get; }
Public ReadOnly Property IsSetOf As Boolean
    Get
member IsSetOf : bool with get

function get_IsSetOf();

public:
property bool IsSetOf {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ASN1SequenceOfMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata Class

Grid Solutions Framework ASN1StringMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1StringMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1FieldMetadata
GSF.ASN1.MetadataASN1StringMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1StringMetadata : ASN1FieldMetadata
Public Class ASN1StringMetadata
    Inherits ASN1FieldMetadata
type ASN1StringMetadata =
    class
        inherit ASN1FieldMetadata
    end
GSF.ASN1.Metadata.ASN1StringMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1StringMetadata',
    GSF.ASN1.Metadata.ASN1FieldMetadata);
public ref class ASN1StringMetadata : public ASN1FieldMetadata

The ASN1StringMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1StringMetadata | Initializes a new instance of the ASN1StringMetadata class
Public method | ASN1StringMetadata(ASN1String) | Initializes a new instance of the ASN1StringMetadata class
Public method | ASN1StringMetadata(String, Boolean, Int32) | Initializes a new instance of the ASN1StringMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Overrides ASN1MetadatasetParentAnnotated(ICustomAttributeProvider).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsUCS |
Public property | Name | (Inherited from ASN1Metadata.)
Public property | StringType |
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1StringMetadata Constructor

Grid Solutions Framework ASN1StringMetadata Constructor
Overload List
 | Name | Description
Public method | ASN1StringMetadata | Initializes a new instance of the ASN1StringMetadata class
Public method | ASN1StringMetadata(ASN1String) | Initializes a new instance of the ASN1StringMetadata class
Public method | ASN1StringMetadata(String, Boolean, Int32) | Initializes a new instance of the ASN1StringMetadata class
Top
See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata Constructor

Grid Solutions Framework ASN1StringMetadata Constructor
Initializes a new instance of the ASN1StringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1StringMetadata()
Public Sub New
new : unit -> ASN1StringMetadata
GSF.ASN1.Metadata.ASN1StringMetadata = function();
public:
ASN1StringMetadata()
See Also

Reference

ASN1StringMetadata Class
ASN1StringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1StringMetadata Constructor (ASN1String)

Grid Solutions Framework ASN1StringMetadata Constructor (ASN1String)
Initializes a new instance of the ASN1StringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1StringMetadata(
    ASN1String annotation
)
Public Sub New (
    annotation As ASN1String
)
new :
        annotation : ASN1String -> ASN1StringMetadata
GSF.ASN1.Metadata.ASN1StringMetadata = function(annotation);
public:
ASN1StringMetadata(
    ASN1String^ annotation
)

Parameters

annotation
Type: GSF.ASN1.AttributesASN1String

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.#ctor(GSF.ASN1.Attributes.ASN1String)"]

See Also

Reference

ASN1StringMetadata Class
ASN1StringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1StringMetadata Constructor (String, Boolean, Int32)

Grid Solutions Framework ASN1StringMetadata Constructor (String, Boolean, Int32)
Initializes a new instance of the ASN1StringMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1StringMetadata(
    string name,
    bool isUCS,
    int stringType
)
Public Sub New (
    name As String,
    isUCS As Boolean,
    stringType As Integer
)
new :
        name : string *
        isUCS : bool *
        stringType : int -> ASN1StringMetadata
GSF.ASN1.Metadata.ASN1StringMetadata = function(name, isUCS, stringType);
public:
ASN1StringMetadata(
    String^ name,
    bool isUCS,
    int stringType
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.#ctor(System.String,System.Boolean,System.Int32)"]

isUCS
Type: SystemBoolean

[Missing <param name="isUCS"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.#ctor(System.String,System.Boolean,System.Int32)"]

stringType
Type: SystemInt32

[Missing <param name="stringType"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.#ctor(System.String,System.Boolean,System.Int32)"]

See Also

Reference

ASN1StringMetadata Class
ASN1StringMetadata Overload
GSF.ASN1.Metadata Namespace


ASN1StringMetadata Methods

Grid Solutions Framework ASN1StringMetadata Methods

The ASN1StringMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Overrides ASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream).)
Public method | encode | (Overrides ASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Overrides ASN1MetadatasetParentAnnotated(ICustomAttributeProvider).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata.decode Method

Grid Solutions Framework ASN1StringMetadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Public Overrides Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
override decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>
function decode(decoder, decodedTag, objectClass, elementInfo, stream);
public:
virtual DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
) override

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Implements

IASN1Metadatadecode(IASN1TypesDecoder, DecodedObjectObject, Type, ElementInfo, Stream)
See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata.encode Method

Grid Solutions Framework ASN1StringMetadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Public Overrides Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
override encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int
function encode(encoder, obj, stream, elementInfo);
public:
virtual int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
) override

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Implements

IASN1Metadataencode(IASN1TypesEncoder, Object, Stream, ElementInfo)
See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata.setParentAnnotated Method

Grid Solutions Framework ASN1StringMetadatasetParentAnnotated Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.setParentAnnotated(System.Reflection.ICustomAttributeProvider)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void setParentAnnotated(
    ICustomAttributeProvider parent
)
Public Overrides Sub setParentAnnotated (
    parent As ICustomAttributeProvider
)
abstract setParentAnnotated :
        parent : ICustomAttributeProvider -> unit
override setParentAnnotated :
        parent : ICustomAttributeProvider -> unit
function setParentAnnotated(parent);
public:
virtual void setParentAnnotated(
    ICustomAttributeProvider^ parent
) override

Parameters

parent
Type: System.ReflectionICustomAttributeProvider

[Missing <param name="parent"/> documentation for "M:GSF.ASN1.Metadata.ASN1StringMetadata.setParentAnnotated(System.Reflection.ICustomAttributeProvider)"]

See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata Properties

Grid Solutions Framework ASN1StringMetadata Properties

The ASN1StringMetadata type exposes the following members.

Properties
 | Name | Description
Public property | IsUCS |
Public property | Name | (Inherited from ASN1Metadata.)
Public property | StringType |
Top
See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata.IsUCS Property

Grid Solutions Framework ASN1StringMetadataIsUCS Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1StringMetadata.IsUCS"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsUCS { get; }
Public ReadOnly Property IsUCS As Boolean
    Get
member IsUCS : bool with get

function get_IsUCS();

public:
property bool IsUCS {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1StringMetadata.StringType Property

Grid Solutions Framework ASN1StringMetadataStringType Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.ASN1StringMetadata.StringType"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int StringType { get; }
Public ReadOnly Property StringType As Integer
    Get
member StringType : int with get

function get_StringType();

public:
property int StringType {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ASN1StringMetadata Class
GSF.ASN1.Metadata Namespace


ASN1TypeMetadata Class

Grid Solutions Framework ASN1TypeMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.ASN1TypeMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.MetadataASN1Metadata
GSF.ASN1.MetadataASN1TypeMetadata
GSF.ASN1.MetadataASN1ChoiceMetadata
GSF.ASN1.MetadataASN1EnumMetadata
GSF.ASN1.MetadataASN1SequenceMetadata

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ASN1TypeMetadata : ASN1Metadata
Public MustInherit Class ASN1TypeMetadata
    Inherits ASN1Metadata
[<AbstractClassAttribute>]
type ASN1TypeMetadata =
    class
        inherit ASN1Metadata
    end
GSF.ASN1.Metadata.ASN1TypeMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.ASN1TypeMetadata',
    GSF.ASN1.Metadata.ASN1Metadata);
public ref class ASN1TypeMetadata abstract : public ASN1Metadata

The ASN1TypeMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1TypeMetadata | Initializes a new instance of the ASN1TypeMetadata class
Top
Methods
 | Name | Description
Public method | decode | (Inherited from ASN1Metadata.)
Public method | encode | (Inherited from ASN1Metadata.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


ASN1TypeMetadata Constructor

Grid Solutions Framework ASN1TypeMetadata Constructor
Initializes a new instance of the ASN1TypeMetadata class

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1TypeMetadata(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> ASN1TypeMetadata
GSF.ASN1.Metadata.ASN1TypeMetadata = function(name);
public:
ASN1TypeMetadata(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.ASN1.Metadata.ASN1TypeMetadata.#ctor(System.String)"]

See Also

Reference

ASN1TypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1TypeMetadata Methods

Grid Solutions Framework ASN1TypeMetadata Methods

The ASN1TypeMetadata type exposes the following members.

Methods
 | Name | Description
Public method | decode | (Inherited from ASN1Metadata.)
Public method | encode | (Inherited from ASN1Metadata.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | setParentAnnotated | (Inherited from ASN1Metadata.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1TypeMetadata Class
GSF.ASN1.Metadata Namespace


ASN1TypeMetadata Properties

Grid Solutions Framework ASN1TypeMetadata Properties

The ASN1TypeMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Name | (Inherited from ASN1Metadata.)
Top
See Also

Reference

ASN1TypeMetadata Class
GSF.ASN1.Metadata Namespace


IASN1Metadata Interface

Grid Solutions Framework IASN1Metadata Interface

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.IASN1Metadata"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IASN1Metadata
Public Interface IASN1Metadata
type IASN1Metadata =  interface end
GSF.ASN1.Metadata.IASN1Metadata = function();
GSF.ASN1.Metadata.IASN1Metadata.createInterface('GSF.ASN1.Metadata.IASN1Metadata');
public interface class IASN1Metadata

The IASN1Metadata type exposes the following members.

Methods
 | Name | Description
Public method | decode |
Public method | encode |
Top
Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

GSF.ASN1.Metadata Namespace


IASN1Metadata Methods

Grid Solutions Framework IASN1Metadata Methods

The IASN1Metadata type exposes the following members.

Methods
 | Name | Description
Public method | decode |
Public method | encode |
Top
See Also

Reference

IASN1Metadata Interface
GSF.ASN1.Metadata Namespace


IASN1Metadata.decode Method

Grid Solutions Framework IASN1Metadatadecode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DecodedObject<Object> decode(
    IASN1TypesDecoder decoder,
    DecodedObject<Object> decodedTag,
    Type objectClass,
    ElementInfo elementInfo,
    Stream stream
)
Function decode (
    decoder As IASN1TypesDecoder,
    decodedTag As DecodedObject(Of Object),
    objectClass As Type,
    elementInfo As ElementInfo,
    stream As Stream
) As DecodedObject(Of Object)
abstract decode :
        decoder : IASN1TypesDecoder *
        decodedTag : DecodedObject<Object> *
        objectClass : Type *
        elementInfo : ElementInfo *
        stream : Stream -> DecodedObject<Object>

function decode(decoder, decodedTag, objectClass, elementInfo, stream);
DecodedObject<Object^>^ decode(
    IASN1TypesDecoder^ decoder,
    DecodedObject<Object^>^ decodedTag,
    Type^ objectClass,
    ElementInfo^ elementInfo,
    Stream^ stream
)

Parameters

decoder
Type: GSF.ASN1.CodersIASN1TypesDecoder

[Missing <param name="decoder"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

decodedTag
Type: GSF.ASN1.CodersDecodedObject Object

[Missing <param name="decodedTag"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

objectClass
Type: SystemType

[Missing <param name="objectClass"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

Return Value

Type: DecodedObject Object

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.decode(GSF.ASN1.Coders.IASN1TypesDecoder,GSF.ASN1.Coders.DecodedObject{System.Object},System.Type,GSF.ASN1.Coders.ElementInfo,System.IO.Stream)"]

See Also

Reference

IASN1Metadata Interface
GSF.ASN1.Metadata Namespace


IASN1Metadata.encode Method

Grid Solutions Framework IASN1Metadataencode Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int encode(
    IASN1TypesEncoder encoder,
    Object obj,
    Stream stream,
    ElementInfo elementInfo
)
Function encode (
    encoder As IASN1TypesEncoder,
    obj As Object,
    stream As Stream,
    elementInfo As ElementInfo
) As Integer
abstract encode :
        encoder : IASN1TypesEncoder *
        obj : Object *
        stream : Stream *
        elementInfo : ElementInfo -> int

function encode(encoder, obj, stream, elementInfo);
int encode(
    IASN1TypesEncoder^ encoder,
    Object^ obj,
    Stream^ stream,
    ElementInfo^ elementInfo
)

Parameters

encoder
Type: GSF.ASN1.CodersIASN1TypesEncoder

[Missing <param name="encoder"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

elementInfo
Type: GSF.ASN1.CodersElementInfo

[Missing <param name="elementInfo"/> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.IASN1Metadata.encode(GSF.ASN1.Coders.IASN1TypesEncoder,System.Object,System.IO.Stream,GSF.ASN1.Coders.ElementInfo)"]

See Also

Reference

IASN1Metadata Interface
GSF.ASN1.Metadata Namespace


IASN1Metadata Properties

Grid Solutions Framework IASN1Metadata Properties

The IASN1Metadata type exposes the following members.

Properties
 | Name | Description
Public property | Name |
Top
See Also

Reference

IASN1Metadata Interface
GSF.ASN1.Metadata Namespace


IASN1Metadata.Name Property

Grid Solutions Framework IASN1MetadataName Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.IASN1Metadata.Name"]

Namespace: GSF.ASN1.Metadata
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
abstract Name : string with get

function get_Name();

property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IASN1Metadata Interface
GSF.ASN1.Metadata Namespace


GSF.ASN1.Metadata.Constraints Namespace

Grid Solutions Framework GSF.ASN1.Metadata.Constraints Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Metadata.Constraints"]

Classes
 | Class | Description
Public class | ASN1SizeConstraintMetadata |
Public class | ASN1ValueRangeConstraintMetadata |
Interfaces
 | Interface | Description
Public interface | IASN1ConstraintMetadata |


ASN1SizeConstraintMetadata Class

Grid Solutions Framework ASN1SizeConstraintMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.Metadata.ConstraintsASN1SizeConstraintMetadata

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1SizeConstraintMetadata : IASN1ConstraintMetadata
Public Class ASN1SizeConstraintMetadata
    Implements IASN1ConstraintMetadata
type ASN1SizeConstraintMetadata =
    class
        interface IASN1ConstraintMetadata
    end
GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata',
    null,
    GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata);
public ref class ASN1SizeConstraintMetadata : IASN1ConstraintMetadata

The ASN1SizeConstraintMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1SizeConstraintMetadata | Initializes a new instance of the ASN1SizeConstraintMetadata class
Top
Methods
 | Name | Description
Public method | checkValue |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Max |
Top
See Also

Reference

GSF.ASN1.Metadata.Constraints Namespace


ASN1SizeConstraintMetadata Constructor

Grid Solutions Framework ASN1SizeConstraintMetadata Constructor
Initializes a new instance of the ASN1SizeConstraintMetadata class

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1SizeConstraintMetadata(
    ASN1SizeConstraint annotation
)
Public Sub New (
    annotation As ASN1SizeConstraint
)
new :
        annotation : ASN1SizeConstraint -> ASN1SizeConstraintMetadata
GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata = function(annotation);
public:
ASN1SizeConstraintMetadata(
    ASN1SizeConstraint^ annotation
)

Parameters

annotation
Type: GSF.ASN1.Attributes.ConstraintsASN1SizeConstraint

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata.#ctor(GSF.ASN1.Attributes.Constraints.ASN1SizeConstraint)"]

See Also

Reference

ASN1SizeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1SizeConstraintMetadata Methods

Grid Solutions Framework ASN1SizeConstraintMetadata Methods

The ASN1SizeConstraintMetadata type exposes the following members.

Methods
 | Name | Description
Public method | checkValue |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1SizeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1SizeConstraintMetadata.checkValue Method

Grid Solutions Framework ASN1SizeConstraintMetadatacheckValue Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata.checkValue(System.Int64)"]

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool checkValue(
    long value
)
Public Function checkValue (
    value As Long
) As Boolean
abstract checkValue :
        value : int64 -> bool
override checkValue :
        value : int64 -> bool
function checkValue(value);
public:
virtual bool checkValue(
    long long value
) sealed

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata.checkValue(System.Int64)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata.checkValue(System.Int64)"]

Implements

IASN1ConstraintMetadatacheckValue(Int64)
See Also

Reference

ASN1SizeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1SizeConstraintMetadata Properties

Grid Solutions Framework ASN1SizeConstraintMetadata Properties

The ASN1SizeConstraintMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Max |
Top
See Also

Reference

ASN1SizeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1SizeConstraintMetadata.Max Property

Grid Solutions Framework ASN1SizeConstraintMetadataMax Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.Constraints.ASN1SizeConstraintMetadata.Max"]

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Max { get; }
Public ReadOnly Property Max As Long
    Get
member Max : int64 with get

function get_Max();

public:
property long long Max {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ASN1SizeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1ValueRangeConstraintMetadata Class

Grid Solutions Framework ASN1ValueRangeConstraintMetadata Class

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.Metadata.ConstraintsASN1ValueRangeConstraintMetadata

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ASN1ValueRangeConstraintMetadata : IASN1ConstraintMetadata
Public Class ASN1ValueRangeConstraintMetadata
    Implements IASN1ConstraintMetadata
type ASN1ValueRangeConstraintMetadata =
    class
        interface IASN1ConstraintMetadata
    end
GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata = function();

Type.createClass(
    'GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata',
    null,
    GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata);
public ref class ASN1ValueRangeConstraintMetadata : IASN1ConstraintMetadata

The ASN1ValueRangeConstraintMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | ASN1ValueRangeConstraintMetadata | Initializes a new instance of the ASN1ValueRangeConstraintMetadata class
Top
Methods
 | Name | Description
Public method | checkValue |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Max |
Public property | Min |
Top
See Also

Reference

GSF.ASN1.Metadata.Constraints Namespace


ASN1ValueRangeConstraintMetadata Constructor

Grid Solutions Framework ASN1ValueRangeConstraintMetadata Constructor
Initializes a new instance of the ASN1ValueRangeConstraintMetadata class

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ASN1ValueRangeConstraintMetadata(
    ASN1ValueRangeConstraint annotation
)
Public Sub New (
    annotation As ASN1ValueRangeConstraint
)
new :
        annotation : ASN1ValueRangeConstraint -> ASN1ValueRangeConstraintMetadata
GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata = function(annotation);
public:
ASN1ValueRangeConstraintMetadata(
    ASN1ValueRangeConstraint^ annotation
)

Parameters

annotation
Type: GSF.ASN1.Attributes.ConstraintsASN1ValueRangeConstraint

[Missing <param name="annotation"/> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata.#ctor(GSF.ASN1.Attributes.Constraints.ASN1ValueRangeConstraint)"]

See Also

Reference

ASN1ValueRangeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1ValueRangeConstraintMetadata Methods

Grid Solutions Framework ASN1ValueRangeConstraintMetadata Methods

The ASN1ValueRangeConstraintMetadata type exposes the following members.

Methods
 | Name | Description
Public method | checkValue |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ASN1ValueRangeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1ValueRangeConstraintMetadata.checkValue Method

Grid Solutions Framework ASN1ValueRangeConstraintMetadatacheckValue Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata.checkValue(System.Int64)"]

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool checkValue(
    long value
)
Public Function checkValue (
    value As Long
) As Boolean
abstract checkValue :
        value : int64 -> bool
override checkValue :
        value : int64 -> bool
function checkValue(value);
public:
virtual bool checkValue(
    long long value
) sealed

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata.checkValue(System.Int64)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata.checkValue(System.Int64)"]

Implements

IASN1ConstraintMetadatacheckValue(Int64)
See Also

Reference

ASN1ValueRangeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1ValueRangeConstraintMetadata Properties

Grid Solutions Framework ASN1ValueRangeConstraintMetadata Properties

The ASN1ValueRangeConstraintMetadata type exposes the following members.

Properties
 | Name | Description
Public property | Max |
Public property | Min |
Top
See Also

Reference

ASN1ValueRangeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1ValueRangeConstraintMetadata.Max Property

Grid Solutions Framework ASN1ValueRangeConstraintMetadataMax Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata.Max"]

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Max { get; }
Public ReadOnly Property Max As Long
    Get
member Max : int64 with get

function get_Max();

public:
property long long Max {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ASN1ValueRangeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


ASN1ValueRangeConstraintMetadata.Min Property

Grid Solutions Framework ASN1ValueRangeConstraintMetadataMin Property

[Missing <summary> documentation for "P:GSF.ASN1.Metadata.Constraints.ASN1ValueRangeConstraintMetadata.Min"]

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Min { get; }
Public ReadOnly Property Min As Long
    Get
member Min : int64 with get

function get_Min();

public:
property long long Min {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ASN1ValueRangeConstraintMetadata Class
GSF.ASN1.Metadata.Constraints Namespace


IASN1ConstraintMetadata Interface

Grid Solutions Framework IASN1ConstraintMetadata Interface

[Missing <summary> documentation for "T:GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata"]

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IASN1ConstraintMetadata
Public Interface IASN1ConstraintMetadata
type IASN1ConstraintMetadata =  interface end
GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata = function();
GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata.createInterface('GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata');
public interface class IASN1ConstraintMetadata

The IASN1ConstraintMetadata type exposes the following members.

Methods
 | Name | Description
Public method | checkValue |
Top
See Also

Reference

GSF.ASN1.Metadata.Constraints Namespace


IASN1ConstraintMetadata Methods

Grid Solutions Framework IASN1ConstraintMetadata Methods

The IASN1ConstraintMetadata type exposes the following members.

Methods
 | Name | Description
Public method | checkValue |
Top
See Also

Reference

IASN1ConstraintMetadata Interface
GSF.ASN1.Metadata.Constraints Namespace


IASN1ConstraintMetadata.checkValue Method

Grid Solutions Framework IASN1ConstraintMetadatacheckValue Method

[Missing <summary> documentation for "M:GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata.checkValue(System.Int64)"]

Namespace: GSF.ASN1.Metadata.Constraints
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool checkValue(
    long value
)
Function checkValue (
    value As Long
) As Boolean
abstract checkValue :
        value : int64 -> bool

function checkValue(value);
bool checkValue(
    long long value
)

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata.checkValue(System.Int64)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Metadata.Constraints.IASN1ConstraintMetadata.checkValue(System.Int64)"]

See Also

Reference

IASN1ConstraintMetadata Interface
GSF.ASN1.Metadata.Constraints Namespace


GSF.ASN1.Types Namespace

Grid Solutions Framework GSF.ASN1.Types Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Types"]

Classes
 | Class | Description
Public class | BitString |
Public class | NullObject |
Public class | ObjectIdentifier |


BitString Class

Grid Solutions Framework BitString Class

[Missing <summary> documentation for "T:GSF.ASN1.Types.BitString"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.TypesBitString

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BitString
Public Class BitString
type BitString =  class end
GSF.ASN1.Types.BitString = function();

Type.createClass(
    'GSF.ASN1.Types.BitString');
public ref class BitString

The BitString type exposes the following members.

Constructors
 | Name | Description
Public method | BitString | Initializes a new instance of the BitString class
Public method | BitString(Byte) | Initializes a new instance of the BitString class
Public method | BitString(BitString) | Initializes a new instance of the BitString class
Public method | BitString(Byte, Int32) | Initializes a new instance of the BitString class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getLength |
Public method | getLengthInBits |
Public method | getTrailBitsCnt |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | TrailBitsCnt |
Public property | Value |
Top
See Also

Reference

GSF.ASN1.Types Namespace


BitString Constructor

Grid Solutions Framework BitString Constructor
Overload List
 | Name | Description
Public method | BitString | Initializes a new instance of the BitString class
Public method | BitString(Byte) | Initializes a new instance of the BitString class
Public method | BitString(BitString) | Initializes a new instance of the BitString class
Public method | BitString(Byte, Int32) | Initializes a new instance of the BitString class
Top
See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


BitString Constructor

Grid Solutions Framework BitString Constructor
Initializes a new instance of the BitString class

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BitString()
Public Sub New
new : unit -> BitString
GSF.ASN1.Types.BitString = function();
public:
BitString()
See Also

Reference

BitString Class
BitString Overload
GSF.ASN1.Types Namespace


BitString Constructor (Byte[])

Grid Solutions Framework BitString Constructor (Byte)
Initializes a new instance of the BitString class

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BitString(
    byte[] bitStrValue
)
Public Sub New (
    bitStrValue As Byte()
)
new :
        bitStrValue : byte[] -> BitString
GSF.ASN1.Types.BitString = function(bitStrValue);
public:
BitString(
    array<unsigned char>^ bitStrValue
)

Parameters

bitStrValue
Type: SystemByte

[Missing <param name="bitStrValue"/> documentation for "M:GSF.ASN1.Types.BitString.#ctor(System.Byte[])"]

See Also

Reference

BitString Class
BitString Overload
GSF.ASN1.Types Namespace


BitString Constructor (BitString)

Grid Solutions Framework BitString Constructor (BitString)
Initializes a new instance of the BitString class

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BitString(
    BitString src
)
Public Sub New (
    src As BitString
)
new :
        src : BitString -> BitString
GSF.ASN1.Types.BitString = function(src);
public:
BitString(
    BitString^ src
)

Parameters

src
Type: GSF.ASN1.TypesBitString

[Missing <param name="src"/> documentation for "M:GSF.ASN1.Types.BitString.#ctor(GSF.ASN1.Types.BitString)"]

See Also

Reference

BitString Class
BitString Overload
GSF.ASN1.Types Namespace


BitString Constructor (Byte[], Int32)

Grid Solutions Framework BitString Constructor (Byte, Int32)
Initializes a new instance of the BitString class

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BitString(
    byte[] bitStrValue,
    int trailBitsCnt
)
Public Sub New (
    bitStrValue As Byte(),
    trailBitsCnt As Integer
)
new :
        bitStrValue : byte[] *
        trailBitsCnt : int -> BitString
GSF.ASN1.Types.BitString = function(bitStrValue, trailBitsCnt);
public:
BitString(
    array<unsigned char>^ bitStrValue,
    int trailBitsCnt
)

Parameters

bitStrValue
Type: SystemByte

[Missing <param name="bitStrValue"/> documentation for "M:GSF.ASN1.Types.BitString.#ctor(System.Byte[],System.Int32)"]

trailBitsCnt
Type: SystemInt32

[Missing <param name="trailBitsCnt"/> documentation for "M:GSF.ASN1.Types.BitString.#ctor(System.Byte[],System.Int32)"]

See Also

Reference

BitString Class
BitString Overload
GSF.ASN1.Types Namespace


BitString Methods

Grid Solutions Framework BitString Methods

The BitString type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getLength |
Public method | getLengthInBits |
Public method | getTrailBitsCnt |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


BitString.getLength Method

Grid Solutions Framework BitStringgetLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Types.BitString.getLength"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int getLength()
Public Function getLength As Integer
member getLength : unit -> int

function getLength();
public:
int getLength()

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Types.BitString.getLength"]

See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


BitString.getLengthInBits Method

Grid Solutions Framework BitStringgetLengthInBits Method

[Missing <summary> documentation for "M:GSF.ASN1.Types.BitString.getLengthInBits"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int getLengthInBits()
Public Function getLengthInBits As Integer
member getLengthInBits : unit -> int

function getLengthInBits();
public:
int getLengthInBits()

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Types.BitString.getLengthInBits"]

See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


BitString.getTrailBitsCnt Method

Grid Solutions Framework BitStringgetTrailBitsCnt Method

[Missing <summary> documentation for "M:GSF.ASN1.Types.BitString.getTrailBitsCnt"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int getTrailBitsCnt()
Public Function getTrailBitsCnt As Integer
member getTrailBitsCnt : unit -> int

function getTrailBitsCnt();
public:
int getTrailBitsCnt()

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Types.BitString.getTrailBitsCnt"]

See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


BitString Properties

Grid Solutions Framework BitString Properties

The BitString type exposes the following members.

Properties
 | Name | Description
Public property | TrailBitsCnt |
Public property | Value |
Top
See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


BitString.TrailBitsCnt Property

Grid Solutions Framework BitStringTrailBitsCnt Property

[Missing <summary> documentation for "P:GSF.ASN1.Types.BitString.TrailBitsCnt"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TrailBitsCnt { get; set; }
Public Property TrailBitsCnt As Integer
    Get
    Set
member TrailBitsCnt : int with get, set

function get_TrailBitsCnt();
function set_TrailBitsCnt(value);
public:
property int TrailBitsCnt {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


BitString.Value Property

Grid Solutions Framework BitStringValue Property

[Missing <summary> documentation for "P:GSF.ASN1.Types.BitString.Value"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Value { get; set; }
Public Property Value As Byte()
    Get
    Set
member Value : byte[] with get, set

function get_Value();
function set_Value(value);
public:
property array<unsigned char>^ Value {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
See Also

Reference

BitString Class
GSF.ASN1.Types Namespace


NullObject Class

Grid Solutions Framework NullObject Class

[Missing <summary> documentation for "T:GSF.ASN1.Types.NullObject"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.TypesNullObject

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class NullObject
Public Class NullObject
type NullObject =  class end
GSF.ASN1.Types.NullObject = function();

Type.createClass(
    'GSF.ASN1.Types.NullObject');
public ref class NullObject

The NullObject type exposes the following members.

Constructors
 | Name | Description
Public method | NullObject | Initializes a new instance of the NullObject class
Top
Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ASN1.Types Namespace


NullObject Constructor

Grid Solutions Framework NullObject Constructor
Initializes a new instance of the NullObject class

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NullObject()
Public Sub New
new : unit -> NullObject
GSF.ASN1.Types.NullObject = function();
public:
NullObject()
See Also

Reference

NullObject Class
GSF.ASN1.Types Namespace


NullObject Methods

Grid Solutions Framework NullObject Methods

The NullObject type exposes the following members.

Methods
 | Name | Description
Public method | Equals | (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

NullObject Class
GSF.ASN1.Types Namespace


NullObject.Equals Method

Grid Solutions Framework NullObjectEquals Method

[Missing <summary> documentation for "M:GSF.ASN1.Types.NullObject.Equals(System.Object)"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject

[Missing <param name="obj"/> documentation for "M:GSF.ASN1.Types.NullObject.Equals(System.Object)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ASN1.Types.NullObject.Equals(System.Object)"]

See Also

Reference

NullObject Class
GSF.ASN1.Types Namespace


NullObject.GetHashCode Method

Grid Solutions Framework NullObjectGetHashCode Method

[Missing <summary> documentation for "M:GSF.ASN1.Types.NullObject.GetHashCode"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Types.NullObject.GetHashCode"]

See Also

Reference

NullObject Class
GSF.ASN1.Types Namespace


ObjectIdentifier Class

Grid Solutions Framework ObjectIdentifier Class

[Missing <summary> documentation for "T:GSF.ASN1.Types.ObjectIdentifier"]

Inheritance Hierarchy
SystemObject
GSF.ASN1.TypesObjectIdentifier

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ObjectIdentifier
Public Class ObjectIdentifier
type ObjectIdentifier =  class end
GSF.ASN1.Types.ObjectIdentifier = function();

Type.createClass(
    'GSF.ASN1.Types.ObjectIdentifier');
public ref class ObjectIdentifier

The ObjectIdentifier type exposes the following members.

Constructors
 | Name | Description
Public method | ObjectIdentifier | Initializes a new instance of the ObjectIdentifier class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getIntArray |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value |
Top
See Also

Reference

GSF.ASN1.Types Namespace


ObjectIdentifier Constructor

Grid Solutions Framework ObjectIdentifier Constructor
Initializes a new instance of the ObjectIdentifier class

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ObjectIdentifier(
    string oidString
)
Public Sub New (
    oidString As String
)
new :
        oidString : string -> ObjectIdentifier
GSF.ASN1.Types.ObjectIdentifier = function(oidString);
public:
ObjectIdentifier(
    String^ oidString
)

Parameters

oidString
Type: SystemString

[Missing <param name="oidString"/> documentation for "M:GSF.ASN1.Types.ObjectIdentifier.#ctor(System.String)"]

See Also

Reference

ObjectIdentifier Class
GSF.ASN1.Types Namespace


ObjectIdentifier Methods

Grid Solutions Framework ObjectIdentifier Methods

The ObjectIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | getIntArray |
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ObjectIdentifier Class
GSF.ASN1.Types Namespace


ObjectIdentifier.getIntArray Method

Grid Solutions Framework ObjectIdentifiergetIntArray Method

[Missing <summary> documentation for "M:GSF.ASN1.Types.ObjectIdentifier.getIntArray"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int[] getIntArray()
Public Function getIntArray As Integer()
member getIntArray : unit -> int[]

function getIntArray();
public:
array<int>^ getIntArray()

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Types.ObjectIdentifier.getIntArray"]

See Also

Reference

ObjectIdentifier Class
GSF.ASN1.Types Namespace


ObjectIdentifier Properties

Grid Solutions Framework ObjectIdentifier Properties

The ObjectIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | Value |
Top
See Also

Reference

ObjectIdentifier Class
GSF.ASN1.Types Namespace


ObjectIdentifier.Value Property

Grid Solutions Framework ObjectIdentifierValue Property

[Missing <summary> documentation for "P:GSF.ASN1.Types.ObjectIdentifier.Value"]

Namespace: GSF.ASN1.Types
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
member Value : string with get, set

function get_Value();
function set_Value(value);
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ObjectIdentifier Class
GSF.ASN1.Types Namespace


GSF.ASN1.Utilities Namespace

Grid Solutions Framework GSF.ASN1.Utilities Namespace

[Missing <summary> documentation for "N:GSF.ASN1.Utilities"]

Classes
Class | Description
Public class | BitArrayInputStream
Public class | BitArrayOutputStream
Public class ReverseByteArrayOutputStream
This class implements an output stream in which the data is written into a reverse byte array. The buffer automatically grows as data is written to it. The data can be retrieved using
Copy
toByteArray()
and
Copy
toString()
. Closing a ByteArrayOutputStream has no effect. The methods in this class can be called after the stream has been closed without generating an IOException.


BitArrayInputStream Class

Grid Solutions Framework BitArrayInputStream Class

[Missing <summary> documentation for "T:GSF.ASN1.Utilities.BitArrayInputStream"]

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ASN1.UtilitiesBitArrayInputStream

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BitArrayInputStream : Stream
Public Class BitArrayInputStream
    Inherits Stream
type BitArrayInputStream =
    class
        inherit Stream
    end
GSF.ASN1.Utilities.BitArrayInputStream = function();

Type.createClass(
    'GSF.ASN1.Utilities.BitArrayInputStream',
    Stream);
public ref class BitArrayInputStream : public Stream

The BitArrayInputStream type exposes the following members.

Constructors
 | Name | Description
Public method | BitArrayInputStream | Initializes a new instance of the BitArrayInputStream class
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | readBit |
Public method | readBits |
Public method | ReadByte | (Overrides StreamReadByte.)
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | skipUnreadedBits |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

GSF.ASN1.Utilities Namespace


BitArrayInputStream Constructor

Grid Solutions Framework BitArrayInputStream Constructor
Initializes a new instance of the BitArrayInputStream class

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BitArrayInputStream(
    Stream byteStream
)
Public Sub New (
    byteStream As Stream
)
new :
        byteStream : Stream -> BitArrayInputStream
GSF.ASN1.Utilities.BitArrayInputStream = function(byteStream);
public:
BitArrayInputStream(
    Stream^ byteStream
)

Parameters

byteStream
Type: System.IOStream

[Missing <param name="byteStream"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.#ctor(System.IO.Stream)"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream Methods

Grid Solutions Framework BitArrayInputStream Methods

The BitArrayInputStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | readBit |
Public method | readBits |
Public method | ReadByte | (Overrides StreamReadByte.)
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | skipUnreadedBits |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.Flush Method

Grid Solutions Framework BitArrayInputStreamFlush Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Flush"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Flush()
Public Overrides Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush() override
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.Read Method

Grid Solutions Framework BitArrayInputStreamRead Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Read(System.Byte[],System.Int32,System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
function Read(buffer, offset, count);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Read(System.Byte[],System.Int32,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Read(System.Byte[],System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Read(System.Byte[],System.Int32,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Read(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.readBit Method

Grid Solutions Framework BitArrayInputStreamreadBit Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.readBit"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int readBit()
Public Overridable Function readBit As Integer
abstract readBit : unit -> int
override readBit : unit -> int
function readBit();
public:
virtual int readBit()

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.readBit"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.readBits Method

Grid Solutions Framework BitArrayInputStreamreadBits Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.readBits(System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int readBits(
    int nBits
)
Public Overridable Function readBits (
    nBits As Integer
) As Integer
abstract readBits :
        nBits : int -> int
override readBits :
        nBits : int -> int
function readBits(nBits);
public:
virtual int readBits(
    int nBits
)

Parameters

nBits
Type: SystemInt32

[Missing <param name="nBits"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.readBits(System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.readBits(System.Int32)"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.ReadByte Method

Grid Solutions Framework BitArrayInputStreamReadByte Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.ReadByte"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ReadByte()
Public Overrides Function ReadByte As Integer
abstract ReadByte : unit -> int
override ReadByte : unit -> int
function ReadByte();
public:
virtual int ReadByte() override

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.ReadByte"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.Seek Method

Grid Solutions Framework BitArrayInputStreamSeek Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
function Seek(offset, origin);
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: SystemInt64

[Missing <param name="offset"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

origin
Type: System.IOSeekOrigin

[Missing <param name="origin"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.SetLength Method

Grid Solutions Framework BitArrayInputStreamSetLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.SetLength(System.Int64)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
function SetLength(value);
public:
virtual void SetLength(
    long long value
) override

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.SetLength(System.Int64)"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.skipUnreadedBits Method

Grid Solutions Framework BitArrayInputStreamskipUnreadedBits Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.skipUnreadedBits"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void skipUnreadedBits()
Public Overridable Sub skipUnreadedBits
abstract skipUnreadedBits : unit -> unit
override skipUnreadedBits : unit -> unit
function skipUnreadedBits();
public:
virtual void skipUnreadedBits()
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.Write Method

Grid Solutions Framework BitArrayInputStreamWrite Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Write(System.Byte[],System.Int32,System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Write(buffer, offset, count);
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Write(System.Byte[],System.Int32,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Write(System.Byte[],System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:GSF.ASN1.Utilities.BitArrayInputStream.Write(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream Properties

Grid Solutions Framework BitArrayInputStream Properties

The BitArrayInputStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.CanRead Property

Grid Solutions Framework BitArrayInputStreamCanRead Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayInputStream.CanRead"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.CanSeek Property

Grid Solutions Framework BitArrayInputStreamCanSeek Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayInputStream.CanSeek"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
abstract CanSeek : bool with get
override CanSeek : bool with get
function get_CanSeek();

public:
virtual property bool CanSeek {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.CanWrite Property

Grid Solutions Framework BitArrayInputStreamCanWrite Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayInputStream.CanWrite"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.Length Property

Grid Solutions Framework BitArrayInputStreamLength Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayInputStream.Length"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
abstract Length : int64 with get
override Length : int64 with get
function get_Length();

public:
virtual property long long Length {
    long long get () override;
}

Property Value

Type: Int64
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayInputStream.Position Property

Grid Solutions Framework BitArrayInputStreamPosition Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayInputStream.Position"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
abstract Position : int64 with get, set
override Position : int64 with get, set
function get_Position();
function set_Position(value);
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Property Value

Type: Int64
See Also

Reference

BitArrayInputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream Class

Grid Solutions Framework BitArrayOutputStream Class

[Missing <summary> documentation for "T:GSF.ASN1.Utilities.BitArrayOutputStream"]

Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ASN1.UtilitiesBitArrayOutputStream

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BitArrayOutputStream : Stream
Public Class BitArrayOutputStream
    Inherits Stream
type BitArrayOutputStream =
    class
        inherit Stream
    end
GSF.ASN1.Utilities.BitArrayOutputStream = function();

Type.createClass(
    'GSF.ASN1.Utilities.BitArrayOutputStream',
    Stream);
public ref class BitArrayOutputStream : public Stream

The BitArrayOutputStream type exposes the following members.

Constructors
 | Name | Description
Public method | BitArrayOutputStream | Initializes a new instance of the BitArrayOutputStream class
Public method | BitArrayOutputStream(Int32) | Initializes a new instance of the BitArrayOutputStream class
Top
Methods
 | Name | Description
Public method | align |
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | pushByteToBuffer |
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | reset |
Protected method | ResizeBuffer |
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | writeBit(Boolean) |
Public method | writeBit(Int32) |
Public method | writeBits |
Public method | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Public method | WriteByte(Int32) |
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

GSF.ASN1.Utilities Namespace


BitArrayOutputStream Constructor

Grid Solutions Framework BitArrayOutputStream Constructor
Overload List
 | Name | Description
Public method | BitArrayOutputStream | Initializes a new instance of the BitArrayOutputStream class
Public method | BitArrayOutputStream(Int32) | Initializes a new instance of the BitArrayOutputStream class
Top
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream Constructor

Grid Solutions Framework BitArrayOutputStream Constructor
Initializes a new instance of the BitArrayOutputStream class

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BitArrayOutputStream()
Public Sub New
new : unit -> BitArrayOutputStream
GSF.ASN1.Utilities.BitArrayOutputStream = function();
public:
BitArrayOutputStream()
See Also

Reference

BitArrayOutputStream Class
BitArrayOutputStream Overload
GSF.ASN1.Utilities Namespace


BitArrayOutputStream Constructor (Int32)

Grid Solutions Framework BitArrayOutputStream Constructor (Int32)
Initializes a new instance of the BitArrayOutputStream class

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BitArrayOutputStream(
    int initialSize
)
Public Sub New (
    initialSize As Integer
)
new :
        initialSize : int -> BitArrayOutputStream
GSF.ASN1.Utilities.BitArrayOutputStream = function(initialSize);
public:
BitArrayOutputStream(
    int initialSize
)

Parameters

initialSize
Type: SystemInt32

[Missing <param name="initialSize"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.#ctor(System.Int32)"]

See Also

Reference

BitArrayOutputStream Class
BitArrayOutputStream Overload
GSF.ASN1.Utilities Namespace


BitArrayOutputStream Methods

Grid Solutions Framework BitArrayOutputStream Methods

The BitArrayOutputStream type exposes the following members.

Methods
 | Name | Description
Public method | align |
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | pushByteToBuffer |
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | reset |
Protected method | ResizeBuffer |
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToArray |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | writeBit(Boolean) |
Public method | writeBit(Int32) |
Public method | writeBits |
Public method | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Public method | WriteByte(Int32) |
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.align Method

Grid Solutions Framework BitArrayOutputStreamalign Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.align"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void align()
Public Overridable Sub align
abstract align : unit -> unit
override align : unit -> unit
function align();
public:
virtual void align()
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.Flush Method

Grid Solutions Framework BitArrayOutputStreamFlush Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Flush"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Flush()
Public Overrides Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush() override
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.pushByteToBuffer Method

Grid Solutions Framework BitArrayOutputStreampushByteToBuffer Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.pushByteToBuffer(System.Byte)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void pushByteToBuffer(
    byte bt
)
Protected Sub pushByteToBuffer (
    bt As Byte
)
member pushByteToBuffer :
        bt : byte -> unit

function pushByteToBuffer(bt);
protected:
void pushByteToBuffer(
    unsigned char bt
)

Parameters

bt
Type: SystemByte

[Missing <param name="bt"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.pushByteToBuffer(System.Byte)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.Read Method

Grid Solutions Framework BitArrayOutputStreamRead Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
function Read(buffer, offset, count);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.reset Method

Grid Solutions Framework BitArrayOutputStreamreset Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.reset"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void reset()
Public Sub reset
member reset : unit -> unit

function reset();
public:
void reset()
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.ResizeBuffer Method

Grid Solutions Framework BitArrayOutputStreamResizeBuffer Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.ResizeBuffer(System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void ResizeBuffer(
    int newcount
)
Protected Sub ResizeBuffer (
    newcount As Integer
)
member ResizeBuffer :
        newcount : int -> unit

function ResizeBuffer(newcount);
protected:
void ResizeBuffer(
    int newcount
)

Parameters

newcount
Type: SystemInt32

[Missing <param name="newcount"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.ResizeBuffer(System.Int32)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.Seek Method

Grid Solutions Framework BitArrayOutputStreamSeek Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
function Seek(offset, origin);
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: SystemInt64

[Missing <param name="offset"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

origin
Type: System.IOSeekOrigin

[Missing <param name="origin"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.SetLength Method

Grid Solutions Framework BitArrayOutputStreamSetLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.SetLength(System.Int64)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
function SetLength(value);
public:
virtual void SetLength(
    long long value
) override

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.SetLength(System.Int64)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.ToArray Method

Grid Solutions Framework BitArrayOutputStreamToArray Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.ToArray"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ToArray()
Public Function ToArray As Byte()
member ToArray : unit -> byte[]

function ToArray();
public:
array<unsigned char>^ ToArray()

Return Value

Type: Byte

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.ToArray"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.Write Method

Grid Solutions Framework BitArrayOutputStreamWrite Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] b,
    int off,
    int len
)
Public Overrides Sub Write (
    b As Byte(),
    off As Integer,
    len As Integer
)
abstract Write :
        b : byte[] *
        off : int *
        len : int -> unit
override Write :
        b : byte[] *
        off : int *
        len : int -> unit
function Write(b, off, len);
public:
virtual void Write(
    array<unsigned char>^ b,
    int off,
    int len
) override

Parameters

b
Type: SystemByte

[Missing <param name="b"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

off
Type: SystemInt32

[Missing <param name="off"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

len
Type: SystemInt32

[Missing <param name="len"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.writeBit Method

Grid Solutions Framework BitArrayOutputStreamwriteBit Method
Overload List
 | Name | Description
Public method | writeBit(Boolean) |
Public method | writeBit(Int32) |
Top
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.writeBit Method (Boolean)

Grid Solutions Framework BitArrayOutputStreamwriteBit Method (Boolean)

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.writeBit(System.Boolean)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void writeBit(
    bool val
)
Public Overridable Sub writeBit (
    val As Boolean
)
abstract writeBit :
        val : bool -> unit
override writeBit :
        val : bool -> unit
function writeBit(val);
public:
virtual void writeBit(
    bool val
)

Parameters

val
Type: SystemBoolean

[Missing <param name="val"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.writeBit(System.Boolean)"]

See Also

Reference

BitArrayOutputStream Class
writeBit Overload
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.writeBit Method (Int32)

Grid Solutions Framework BitArrayOutputStreamwriteBit Method (Int32)

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.writeBit(System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void writeBit(
    int bit
)
Public Overridable Sub writeBit (
    bit As Integer
)
abstract writeBit :
        bit : int -> unit
override writeBit :
        bit : int -> unit
function writeBit(bit);
public:
virtual void writeBit(
    int bit
)

Parameters

bit
Type: SystemInt32

[Missing <param name="bit"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.writeBit(System.Int32)"]

See Also

Reference

BitArrayOutputStream Class
writeBit Overload
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.writeBits Method

Grid Solutions Framework BitArrayOutputStreamwriteBits Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.writeBits(System.Int32,System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void writeBits(
    int bt,
    int count
)
Public Sub writeBits (
    bt As Integer,
    count As Integer
)
member writeBits :
        bt : int *
        count : int -> unit

function writeBits(bt, count);
public:
void writeBits(
    int bt,
    int count
)

Parameters

bt
Type: SystemInt32

[Missing <param name="bt"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.writeBits(System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.writeBits(System.Int32,System.Int32)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.WriteByte Method

Grid Solutions Framework BitArrayOutputStreamWriteByte Method
Overload List
 | Name | Description
Public method | WriteByte(Byte) | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Public method | WriteByte(Int32) |
Top
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.WriteByte Method (Int32)

Grid Solutions Framework BitArrayOutputStreamWriteByte Method (Int32)

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.WriteByte(System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteByte(
    int b
)
Public Sub WriteByte (
    b As Integer
)
member WriteByte :
        b : int -> unit

function WriteByte(b);
public:
void WriteByte(
    int b
)

Parameters

b
Type: SystemInt32

[Missing <param name="b"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.WriteByte(System.Int32)"]

See Also

Reference

BitArrayOutputStream Class
WriteByte Overload
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.WriteTo Method

Grid Solutions Framework BitArrayOutputStreamWriteTo Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.WriteTo(System.IO.Stream)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteTo(
    Stream stream
)
Public Sub WriteTo (
    stream As Stream
)
member WriteTo :
        stream : Stream -> unit

function WriteTo(stream);
public:
void WriteTo(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Utilities.BitArrayOutputStream.WriteTo(System.IO.Stream)"]

See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream Properties

Grid Solutions Framework BitArrayOutputStream Properties

The BitArrayOutputStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.CanRead Property

Grid Solutions Framework BitArrayOutputStreamCanRead Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayOutputStream.CanRead"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.CanSeek Property

Grid Solutions Framework BitArrayOutputStreamCanSeek Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayOutputStream.CanSeek"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
abstract CanSeek : bool with get
override CanSeek : bool with get
function get_CanSeek();

public:
virtual property bool CanSeek {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.CanWrite Property

Grid Solutions Framework BitArrayOutputStreamCanWrite Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayOutputStream.CanWrite"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.Length Property

Grid Solutions Framework BitArrayOutputStreamLength Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayOutputStream.Length"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
abstract Length : int64 with get
override Length : int64 with get
function get_Length();

public:
virtual property long long Length {
    long long get () override;
}

Property Value

Type: Int64
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


BitArrayOutputStream.Position Property

Grid Solutions Framework BitArrayOutputStreamPosition Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.BitArrayOutputStream.Position"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
abstract Position : int64 with get, set
override Position : int64 with get, set
function get_Position();
function set_Position(value);
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Property Value

Type: Int64
See Also

Reference

BitArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream Class

Grid Solutions Framework ReverseByteArrayOutputStream Class
This class implements an output stream in which the data is written into a reverse byte array. The buffer automatically grows as data is written to it. The data can be retrieved using
Copy
toByteArray()
and
Copy
toString()
. Closing a ByteArrayOutputStream has no effect. The methods in this class can be called after the stream has been closed without generating an IOException.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ASN1.UtilitiesReverseByteArrayOutputStream

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ReverseByteArrayOutputStream : Stream
Public Class ReverseByteArrayOutputStream
    Inherits Stream
type ReverseByteArrayOutputStream =
    class
        inherit Stream
    end
GSF.ASN1.Utilities.ReverseByteArrayOutputStream = function();

Type.createClass(
    'GSF.ASN1.Utilities.ReverseByteArrayOutputStream',
    Stream);
public ref class ReverseByteArrayOutputStream : public Stream

The ReverseByteArrayOutputStream type exposes the following members.

Constructors
 | Name | Description
Public method | ReverseByteArrayOutputStream | Initializes a new instance of the ReverseByteArrayOutputStream class
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Protected method | ResizeBuffer |
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToArray |
Public method | ToCharArray |
Public method | ToString | (Overrides ObjectToString.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte(Byte) | (Overrides StreamWriteByte(Byte).)
Public method | WriteByte(Int32) |
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream Constructor

Grid Solutions Framework ReverseByteArrayOutputStream Constructor
Initializes a new instance of the ReverseByteArrayOutputStream class

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ReverseByteArrayOutputStream()
Public Sub New
new : unit -> ReverseByteArrayOutputStream
GSF.ASN1.Utilities.ReverseByteArrayOutputStream = function();
public:
ReverseByteArrayOutputStream()
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream Methods

Grid Solutions Framework ReverseByteArrayOutputStream Methods

The ReverseByteArrayOutputStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Protected method | ResizeBuffer |
Public method | Seek | (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | (Overrides StreamSetLength(Int64).)
Public method | ToArray |
Public method | ToCharArray |
Public method | ToString | (Overrides ObjectToString.)
Public method | Write | (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte(Byte) | (Overrides StreamWriteByte(Byte).)
Public method | WriteByte(Int32) |
Public method | WriteTo |
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.Flush Method

Grid Solutions Framework ReverseByteArrayOutputStreamFlush Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Flush"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Flush()
Public Overrides Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush() override
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.Read Method

Grid Solutions Framework ReverseByteArrayOutputStreamRead Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
function Read(buffer, offset, count);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

offset
Type: SystemInt32

[Missing <param name="offset"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

count
Type: SystemInt32

[Missing <param name="count"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Read(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.ResizeBuffer Method

Grid Solutions Framework ReverseByteArrayOutputStreamResizeBuffer Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ResizeBuffer(System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void ResizeBuffer(
    int newcount
)
Protected Sub ResizeBuffer (
    newcount As Integer
)
member ResizeBuffer :
        newcount : int -> unit

function ResizeBuffer(newcount);
protected:
void ResizeBuffer(
    int newcount
)

Parameters

newcount
Type: SystemInt32

[Missing <param name="newcount"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ResizeBuffer(System.Int32)"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.Seek Method

Grid Solutions Framework ReverseByteArrayOutputStreamSeek Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
function Seek(offset, origin);
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: SystemInt64

[Missing <param name="offset"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

origin
Type: System.IOSeekOrigin

[Missing <param name="origin"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

Return Value

Type: Int64

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Seek(System.Int64,System.IO.SeekOrigin)"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.SetLength Method

Grid Solutions Framework ReverseByteArrayOutputStreamSetLength Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.SetLength(System.Int64)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
function SetLength(value);
public:
virtual void SetLength(
    long long value
) override

Parameters

value
Type: SystemInt64

[Missing <param name="value"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.SetLength(System.Int64)"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.ToArray Method

Grid Solutions Framework ReverseByteArrayOutputStreamToArray Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ToArray"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ToArray()
Public Function ToArray As Byte()
member ToArray : unit -> byte[]

function ToArray();
public:
array<unsigned char>^ ToArray()

Return Value

Type: Byte

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ToArray"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.ToCharArray Method

Grid Solutions Framework ReverseByteArrayOutputStreamToCharArray Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ToCharArray"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char[] ToCharArray()
Public Function ToCharArray As Char()
member ToCharArray : unit -> char[]

function ToCharArray();
public:
array<wchar_t>^ ToCharArray()

Return Value

Type: Char

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ToCharArray"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.ToString Method

Grid Solutions Framework ReverseByteArrayOutputStreamToString Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ToString"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.ToString"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.Write Method

Grid Solutions Framework ReverseByteArrayOutputStreamWrite Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] b,
    int off,
    int len
)
Public Overrides Sub Write (
    b As Byte(),
    off As Integer,
    len As Integer
)
abstract Write :
        b : byte[] *
        off : int *
        len : int -> unit
override Write :
        b : byte[] *
        off : int *
        len : int -> unit
function Write(b, off, len);
public:
virtual void Write(
    array<unsigned char>^ b,
    int off,
    int len
) override

Parameters

b
Type: SystemByte

[Missing <param name="b"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

off
Type: SystemInt32

[Missing <param name="off"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

len
Type: SystemInt32

[Missing <param name="len"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Write(System.Byte[],System.Int32,System.Int32)"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.WriteByte Method

Grid Solutions Framework ReverseByteArrayOutputStreamWriteByte Method
Overload List
 | Name | Description
Public method | WriteByte(Byte) | (Overrides StreamWriteByte(Byte).)
Public method | WriteByte(Int32) |
Top
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.WriteByte Method (Byte)

Grid Solutions Framework ReverseByteArrayOutputStreamWriteByte Method (Byte)

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.WriteByte(System.Byte)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void WriteByte(
    byte b
)
Public Overrides Sub WriteByte (
    b As Byte
)
abstract WriteByte :
        b : byte -> unit
override WriteByte :
        b : byte -> unit
function WriteByte(b);
public:
virtual void WriteByte(
    unsigned char b
) override

Parameters

b
Type: SystemByte

[Missing <param name="b"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.WriteByte(System.Byte)"]

See Also

Reference

ReverseByteArrayOutputStream Class
WriteByte Overload
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.WriteByte Method (Int32)

Grid Solutions Framework ReverseByteArrayOutputStreamWriteByte Method (Int32)

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.WriteByte(System.Int32)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteByte(
    int b
)
Public Sub WriteByte (
    b As Integer
)
member WriteByte :
        b : int -> unit

function WriteByte(b);
public:
void WriteByte(
    int b
)

Parameters

b
Type: SystemInt32

[Missing <param name="b"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.WriteByte(System.Int32)"]

See Also

Reference

ReverseByteArrayOutputStream Class
WriteByte Overload
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.WriteTo Method

Grid Solutions Framework ReverseByteArrayOutputStreamWriteTo Method

[Missing <summary> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.WriteTo(System.IO.Stream)"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteTo(
    Stream stream
)
Public Sub WriteTo (
    stream As Stream
)
member WriteTo :
        stream : Stream -> unit

function WriteTo(stream);
public:
void WriteTo(
    Stream^ stream
)

Parameters

stream
Type: System.IOStream

[Missing <param name="stream"/> documentation for "M:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.WriteTo(System.IO.Stream)"]

See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream Properties

Grid Solutions Framework ReverseByteArrayOutputStream Properties

The ReverseByteArrayOutputStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | (Overrides StreamCanRead.)
Public property | CanSeek | (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | (Overrides StreamCanWrite.)
Public property | Length | (Overrides StreamLength.)
Public property | Position | (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.CanRead Property

Grid Solutions Framework ReverseByteArrayOutputStreamCanRead Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.CanRead"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.CanSeek Property

Grid Solutions Framework ReverseByteArrayOutputStreamCanSeek Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.CanSeek"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
abstract CanSeek : bool with get
override CanSeek : bool with get
function get_CanSeek();

public:
virtual property bool CanSeek {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.CanWrite Property

Grid Solutions Framework ReverseByteArrayOutputStreamCanWrite Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.CanWrite"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.Length Property

Grid Solutions Framework ReverseByteArrayOutputStreamLength Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Length"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
abstract Length : int64 with get
override Length : int64 with get
function get_Length();

public:
virtual property long long Length {
    long long get () override;
}

Property Value

Type: Int64
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


ReverseByteArrayOutputStream.Position Property

Grid Solutions Framework ReverseByteArrayOutputStreamPosition Property

[Missing <summary> documentation for "P:GSF.ASN1.Utilities.ReverseByteArrayOutputStream.Position"]

Namespace: GSF.ASN1.Utilities
Assembly: GSF.ASN1 (in GSF.ASN1.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
abstract Position : int64 with get, set
override Position : int64 with get, set
function get_Position();
function set_Position(value);
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Property Value

Type: Int64
See Also

Reference

ReverseByteArrayOutputStream Class
GSF.ASN1.Utilities Namespace


GSF.Collections Namespace

Grid Solutions Framework GSF.Collections Namespace
Contains classes and type extension functions related to any fundamental collection including thread based processing queues.
Classes
 | Class | Description
Public class | AsyncDoubleBufferedQueueT | Combines AsyncQueueT and DoubleBufferedQueueT to provide a low-contention, double-buffered queue suitable for multiple-producer, single-consumer scenarios.
Public class | AsyncQueueT | Creates a fast, light-weight asynchronous processing queue with very low contention.
Public class | CollectionExtensions | Defines extension functions related to manipulation of arrays and collections.
Public class | DictionaryListTKey, TValue | Represents a sorted dictionary style list that supports IList.
Public class | DoubleBufferedQueueT | A thread-safe double-buffered queue that allows for low-contention item processing in single-producer, single-consumer scenarios.
Public class | DoubleBufferedQueueManagerT | Manages queues to reduce contention for a multithreaded, multiple-producer, single-consumer scenario.
Public class | DoubleBufferedQueueProducerT | A producer for a DoubleBufferedQueueT which can only be used to provide items to the queue for consumption.
Public class | FileBackedDictionaryTKey, TValue | Represents a lookup table of key/value pairs backed by a file, with very little memory overhead.
Public class | FileBackedHashSetT | Represents a lookup table backed by a file, with very little memory overhead.
Public class | IsolatedQueueT | Provides a buffer of point data where reads are isolated from writes. However, reads must be synchronized with other reads and writes must be synchronized with other writes.
Public class | ListCollectionT | A faster and functionally equivalent implementation of CollectionT
Public class | PriorityQueueT | Represents a queue of items to which priority can be assigned.
Public class | ProcessDictionaryTKey, TValue | Represents a thread-safe (via locking) keyed collection of items, based on DictionaryListTKey, TValue, that get processed on independent threads with a consumer provided function.
Public class | ProcessQueueT | Represents a thread-safe (via locking) list of items, based on ListT, that get processed on independent threads with a consumer provided function.
Public class | RollingWindowT | Represents a rolling window of data with FIFO semantics that will automatically truncate the data when the window size is exceeded.
 | SettingsCollection | A collection of settings that can be represented as a string of key-value pairs for easy persistence and also provide built-in validation support for the settings.
Structures
 | Structure | Description
Public structure | ProcessQueueStatistics | Represents the statistics of a ProcessQueueT.
Delegates
 | Delegate | Description
Public delegate | ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature | Function signature that determines if a key and value can be currently processed.
Public delegate | ProcessDictionaryTKey, TValueProcessItemFunctionSignature | Function signature that defines a method to process a key and value one at a time.
Public delegate | ProcessQueueTCanProcessItemFunctionSignature | Function signature that determines if an item can be currently processed.
Public delegate | ProcessQueueTProcessItemFunctionSignature | Function signature that defines a method to process items one at a time.
Public delegate | ProcessQueueTProcessItemsFunctionSignature | Function signature that defines a method to process multiple items at once.
Enumerations
 | Enumeration | Description
Public enumeration | QueueProcessingStyle | Enumeration of possible ProcessQueueT processing styles.
Public enumeration | QueueThreadingMode | Enumeration of possible ProcessQueueT threading modes.
Public enumeration | RequeueMode | Enumeration of possible requeue modes.
Public enumeration | RequeueReason | Enumeration of possible requeue reasons.


AsyncDoubleBufferedQueue(T) Class

Grid Solutions Framework AsyncDoubleBufferedQueueT Class
Combines AsyncQueueT and DoubleBufferedQueueT to provide a low-contention, double-buffered queue suitable for multiple-producer, single-consumer scenarios.
Inheritance Hierarchy
SystemObject
GSF.CollectionsAsyncDoubleBufferedQueueT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AsyncDoubleBufferedQueue<T>

Public Class AsyncDoubleBufferedQueue(Of T)
type AsyncDoubleBufferedQueue<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class AsyncDoubleBufferedQueue

Type Parameters

T
Type of items being queued.

The AsyncDoubleBufferedQueueT type exposes the following members.

Constructors
 | Name | Description
Public method | AsyncDoubleBufferedQueueT | Creates a new instance of the AsyncDoubleBufferedQueueT class.
Top
Methods
 | Name | Description
Public method | Enqueue | Enqueues a collection of items into the async double-buffered queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of items in the queue.
Public property | ProcessItemsFunction | Gets or sets item processing function.
Top
Events
 | Name | Description
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the AsyncDoubleBufferedQueueT.
Top
See Also

Reference

GSF.Collections Namespace


AsyncDoubleBufferedQueue(T) Constructor

Grid Solutions Framework AsyncDoubleBufferedQueueT Constructor
Creates a new instance of the AsyncDoubleBufferedQueueT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AsyncDoubleBufferedQueue()
Public Sub New
new : unit -> AsyncDoubleBufferedQueue
GSF.Collections.AsyncDoubleBufferedQueue = function();
public:
AsyncDoubleBufferedQueue()
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncDoubleBufferedQueue(T) Methods

Grid Solutions Framework AsyncDoubleBufferedQueueT Methods

The AsyncDoubleBufferedQueueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Enqueue | Enqueues a collection of items into the async double-buffered queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncDoubleBufferedQueue(T).Enqueue Method

Grid Solutions Framework AsyncDoubleBufferedQueueTEnqueue Method
Enqueues a collection of items into the async double-buffered queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Enqueue(
    IEnumerable<T> items
)
Public Sub Enqueue (
    items As IEnumerable(Of T)
)
member Enqueue :
        items : IEnumerable<'T> -> unit

function Enqueue(items);
public:
void Enqueue(
    IEnumerable<T>^ items
)

Parameters

items
Type: System.Collections.GenericIEnumerable T
The items to be queued.
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncDoubleBufferedQueue(T) Properties

Grid Solutions Framework AsyncDoubleBufferedQueueT Properties

The AsyncDoubleBufferedQueueT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of items in the queue.
Public property | ProcessItemsFunction | Gets or sets item processing function.
Top
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncDoubleBufferedQueue(T).Count Property

Grid Solutions Framework AsyncDoubleBufferedQueueTCount Property
Gets the number of items in the queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
member Count : int with get

function get_Count();

public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncDoubleBufferedQueue(T).ProcessItemsFunction Property

Grid Solutions Framework AsyncDoubleBufferedQueueTProcessItemsFunction Property
Gets or sets item processing function.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<IList<T>> ProcessItemsFunction { get; set; }
Public Property ProcessItemsFunction As Action(Of IList(Of T))
    Get
    Set
member ProcessItemsFunction : Action<IList<'T>> with get, set

function get_ProcessItemsFunction();
function set_ProcessItemsFunction(value);
public:
property Action<IList<T>^>^ ProcessItemsFunction {
    Action<IList<T>^>^ get ();
    void set (Action<IList<T>^>^ value);
}

Property Value

Type: Action IList T
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncDoubleBufferedQueue(T) Events

Grid Solutions Framework AsyncDoubleBufferedQueueT Events

The AsyncDoubleBufferedQueueT generic type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the AsyncDoubleBufferedQueueT.
Top
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncDoubleBufferedQueue(T).ProcessException Event

Grid Solutions Framework AsyncDoubleBufferedQueueTProcessException Event
Event that is raised if an exception is encountered while attempting to processing an item in the AsyncDoubleBufferedQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Processing will not stop for any exceptions thrown by user processing function, but exceptions will be exposed through this event.
See Also

Reference

AsyncDoubleBufferedQueueT Class
GSF.Collections Namespace


AsyncQueue(T) Class

Grid Solutions Framework AsyncQueueT Class
Creates a fast, light-weight asynchronous processing queue with very low contention.
Inheritance Hierarchy
SystemObject
GSF.CollectionsAsyncQueueT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AsyncQueue<T>

Public Class AsyncQueue(Of T)
type AsyncQueue<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class AsyncQueue

Type Parameters

T
Type of items to process.

The AsyncQueueT type exposes the following members.

Constructors
 | Name | Description
Public method | AsyncQueueT | Creates a new AsyncQueueT.
Public method | AsyncQueueT(SynchronizedOperationType) | Creates a new AsyncQueueT.
Top
Methods
 | Name | Description
Public method | Enqueue | Enqueues an item for processing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the total number of items currently in the queue.
Public property | Enabled | Gets or sets flag that enables or disables processing.
Public property | ProcessItemFunction | Gets or sets item processing function.
Top
Events
 | Name | Description
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the AsyncQueueT.
Top
See Also

Reference

GSF.Collections Namespace


AsyncQueue(T) Constructor

Grid Solutions Framework AsyncQueueT Constructor
Overload List
 | Name | Description
Public method | AsyncQueueT | Creates a new AsyncQueueT.
Public method | AsyncQueueT(SynchronizedOperationType) | Creates a new AsyncQueueT.
Top
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T) Constructor

Grid Solutions Framework AsyncQueueT Constructor
Creates a new AsyncQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AsyncQueue()
Public Sub New
new : unit -> AsyncQueue
GSF.Collections.AsyncQueue = function();
public:
AsyncQueue()
See Also

Reference

AsyncQueueT Class
AsyncQueueT Overload
GSF.Collections Namespace


AsyncQueue(T) Constructor (SynchronizedOperationType)

Grid Solutions Framework AsyncQueueT Constructor (SynchronizedOperationType)
Creates a new AsyncQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AsyncQueue(
    SynchronizedOperationType synchronizedOperationType
)
Public Sub New (
    synchronizedOperationType As SynchronizedOperationType
)
new :
        synchronizedOperationType : SynchronizedOperationType -> AsyncQueue
GSF.Collections.AsyncQueue = function(synchronizedOperationType);
public:
AsyncQueue(
    SynchronizedOperationType synchronizedOperationType
)

Parameters

synchronizedOperationType
Type: GSF.ThreadingSynchronizedOperationType
The type of synchronized operation to use to process items in the queue.
See Also

Reference

AsyncQueueT Class
AsyncQueueT Overload
GSF.Collections Namespace


AsyncQueue(T) Methods

Grid Solutions Framework AsyncQueueT Methods

The AsyncQueueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Enqueue | Enqueues an item for processing.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T).Enqueue Method

Grid Solutions Framework AsyncQueueTEnqueue Method
Enqueues an item for processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Enqueue(
    T item
)
Public Sub Enqueue (
    item As T
)
member Enqueue :
        item : 'T -> unit

function Enqueue(item);
public:
void Enqueue(
    T item
)

Parameters

item
Type: T
Item to be queued for processing.
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T) Properties

Grid Solutions Framework AsyncQueueT Properties

The AsyncQueueT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the total number of items currently in the queue.
Public property | Enabled | Gets or sets flag that enables or disables processing.
Public property | ProcessItemFunction | Gets or sets item processing function.
Top
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T).Count Property

Grid Solutions Framework AsyncQueueTCount Property
Gets the total number of items currently in the queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
member Count : int with get

function get_Count();

public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T).Enabled Property

Grid Solutions Framework AsyncQueueTEnabled Property
Gets or sets flag that enables or disables processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
member Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T).ProcessItemFunction Property

Grid Solutions Framework AsyncQueueTProcessItemFunction Property
Gets or sets item processing function.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<T> ProcessItemFunction { get; set; }
Public Property ProcessItemFunction As Action(Of T)
    Get
    Set
member ProcessItemFunction : Action<'T> with get, set

function get_ProcessItemFunction();
function set_ProcessItemFunction(value);
public:
property Action<T>^ ProcessItemFunction {
    Action<T>^ get ();
    void set (Action<T>^ value);
}

Property Value

Type: Action T
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T) Events

Grid Solutions Framework AsyncQueueT Events

The AsyncQueueT generic type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the AsyncQueueT.
Top
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


AsyncQueue(T).ProcessException Event

Grid Solutions Framework AsyncQueueTProcessException Event
Event that is raised if an exception is encountered while attempting to processing an item in the AsyncQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Processing will not stop for any exceptions thrown by user processing function, but exceptions will be exposed through this event.
See Also

Reference

AsyncQueueT Class
GSF.Collections Namespace


CollectionExtensions Class

Grid Solutions Framework CollectionExtensions Class
Defines extension functions related to manipulation of arrays and collections.
Inheritance Hierarchy
SystemObject
GSF.CollectionsCollectionExtensions

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class CollectionExtensions
<ExtensionAttribute>
Public NotInheritable Class CollectionExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CollectionExtensions =  class end
GSF.Collections.CollectionExtensions = function();

Type.createClass(
    'GSF.Collections.CollectionExtensions');
[ExtensionAttribute]
public ref class CollectionExtensions abstract sealed

The CollectionExtensions type exposes the following members.

Methods
Name | Description
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddRangeT | Adds the specified items to the collection.
All | Returns true if all items in BitArray are equal to value.
Any | Returns true if any item in BitArray is equal to value.
CompareToTSource | Compares two arrays.
CopyT | Returns a copy of the Array.
DistinctByTSource, TKey | Returns only the elements whose keys are distinct.
GetOrAddTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.
GetOrAddTKey, TValue(IDictionaryTKey, TValue, TKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.
GetOrDefaultTKey, TValue(IDictionaryTKey, TValue, TKey) | Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.
GetOrDefaultTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.
GetRangeT | Returns elements in the specified range from the collection.
IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found.
LoadDelimitedStringTSource(IListTSource, String, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list.
LoadDelimitedStringTSource(IListTSource, String, Char, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, into the given list.
LoadDelimitedStringTSource(IListTSource, String, String, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, into the given list.
MajorityT(IEnumerableT) | Returns the majority value in the collection, or default type value if no item represents the majority.
MajorityT(IEnumerableT, T) | Returns the majority value in the collection, or defaultValue if no item represents the majority.
MaxTSource(IEnumerableTSource, IComparerTSource) | Returns the largest item from the enumeration.
MaxTSource(IEnumerableTSource, FuncTSource, TSource, Int32) | Returns the largest item from the enumeration.
MaxByTSource, TKey | Selects the largest item from the enumeration.
MergeT, TKey, TValue(T, IDictionaryTKey, TValue) | Merges elements of multiple dictionaries into a single dictionary with no duplicate key values overwritten.
MergeT, TKey, TValue(T, Boolean, IDictionaryTKey, TValue) | Merges elements of multiple dictionaries into a single dictionary.
MinTSource(IEnumerableTSource, IComparerTSource) | Returns the smallest item from the enumeration.
MinTSource(IEnumerableTSource, FuncTSource, TSource, Int32) | Returns the smallest item from the enumeration.
MinByTSource, TKey | Selects the smallest item from the enumeration.
MinorityT(IEnumerableT) | Returns the minority value in the collection, or default type value if no item represents the minority.
MinorityT(IEnumerableT, T) | Returns the minority value in the collection, or defaultValue if no item represents the minority.
ScrambleTSource(IListTSource) | Rearranges all the elements in the list into a highly-random order.
ScrambleTSource(IListTSource, Int32) | Rearranges all the elements in the list into a repeatable pseudo-random order.
ToDelimitedStringTSource(IEnumerableTSource) | Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString.
ToDelimitedStringTSource(IEnumerableTSource, Char) | Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.
ToDelimitedStringTSource(IEnumerableTSource, String) | Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.
UnscrambleTSource | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order.
UpdateRangeT | Updates collection starting at the index with the specified items.
Top
See Also

Reference

GSF.Collections Namespace


CollectionExtensions Methods

Grid Solutions Framework CollectionExtensions Methods

The CollectionExtensions type exposes the following members.

Methods
Name | Description
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddRangeT | Adds the specified items to the collection.
All | Returns true if all items in BitArray are equal to value.
Any | Returns true if any item in BitArray is equal to value.
CompareToTSource | Compares two arrays.
CopyT | Returns a copy of the Array.
DistinctByTSource, TKey | Returns only the elements whose keys are distinct.
GetOrAddTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.
GetOrAddTKey, TValue(IDictionaryTKey, TValue, TKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.
GetOrDefaultTKey, TValue(IDictionaryTKey, TValue, TKey) | Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.
GetOrDefaultTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.
GetRangeT | Returns elements in the specified range from the collection.
IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found.
LoadDelimitedStringTSource(IListTSource, String, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list.
LoadDelimitedStringTSource(IListTSource, String, Char, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, into the given list.
LoadDelimitedStringTSource(IListTSource, String, String, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, into the given list.
MajorityT(IEnumerableT) | Returns the majority value in the collection, or default type value if no item represents the majority.
MajorityT(IEnumerableT, T) | Returns the majority value in the collection, or defaultValue if no item represents the majority.
MaxTSource(IEnumerableTSource, IComparerTSource) | Returns the largest item from the enumeration.
MaxTSource(IEnumerableTSource, FuncTSource, TSource, Int32) | Returns the largest item from the enumeration.
MaxByTSource, TKey | Selects the largest item from the enumeration.
MergeT, TKey, TValue(T, IDictionaryTKey, TValue) | Merges elements of multiple dictionaries into a single dictionary with no duplicate key values overwritten.
MergeT, TKey, TValue(T, Boolean, IDictionaryTKey, TValue) | Merges elements of multiple dictionaries into a single dictionary.
MinTSource(IEnumerableTSource, IComparerTSource) | Returns the smallest item from the enumeration.
MinTSource(IEnumerableTSource, FuncTSource, TSource, Int32) | Returns the smallest item from the enumeration.
MinByTSource, TKey | Selects the smallest item from the enumeration.
MinorityT(IEnumerableT) | Returns the minority value in the collection, or default type value if no item represents the minority.
MinorityT(IEnumerableT, T) | Returns the minority value in the collection, or defaultValue if no item represents the minority.
ScrambleTSource(IListTSource) | Rearranges all the elements in the list into a highly-random order.
ScrambleTSource(IListTSource, Int32) | Rearranges all the elements in the list into a repeatable pseudo-random order.
ToDelimitedStringTSource(IEnumerableTSource) | Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString.
ToDelimitedStringTSource(IEnumerableTSource, Char) | Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.
ToDelimitedStringTSource(IEnumerableTSource, String) | Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.
UnscrambleTSource | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order.
UpdateRangeT | Updates collection starting at the index with the specified items.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.AddOrUpdate Method

Grid Solutions Framework CollectionExtensionsAddOrUpdate Method
Overload List
Name | Description
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
AddOrUpdateTKey, TValue(IDictionaryTKey, TValue, TKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.AddOrUpdate(TKey, TValue) Method (IDictionary(TKey, TValue), TKey, Func(TKey, TValue))

Grid Solutions Framework CollectionExtensionsAddOrUpdateTKey, TValue Method (IDictionaryTKey, TValue, TKey, FuncTKey, TValue)
Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue AddOrUpdate<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    Func<TKey, TValue> valueFactory
)

<ExtensionAttribute>
Public Shared Function AddOrUpdate(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey,
    valueFactory As Func(Of TKey, TValue)
) As TValue
static member AddOrUpdate :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey *
        valueFactory : Func<'TKey, 'TValue> -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue AddOrUpdate(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key,
    Func<TKey, TValue>^ valueFactory
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to add the key/value pair to if the key does not already exist.
key
Type: TKey
The key to be added or updated.
valueFactory
Type: SystemFunc TKey, TValue
The function used to generate a value for the key.

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

Return Value

Type: TValue
The value of the key in the dictionary after updating.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
AddOrUpdate Overload
GSF.Collections Namespace


CollectionExtensions.AddOrUpdate(TKey, TValue) Method (IDictionary(TKey, TValue), TKey, TValue)

Grid Solutions Framework CollectionExtensionsAddOrUpdateTKey, TValue Method (IDictionaryTKey, TValue, TKey, TValue)
Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue AddOrUpdate<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    TValue value
)

<ExtensionAttribute>
Public Shared Function AddOrUpdate(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey,
    value As TValue
) As TValue
static member AddOrUpdate :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey *
        value : 'TValue -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue AddOrUpdate(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key,
    TValue value
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to add the key/value pair to if the key does not already exist.
key
Type: TKey
The key to be added or updated.
value
Type: TValue
The value to be assigned to the key.

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

Return Value

Type: TValue
The value of the key in the dictionary after updating.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
AddOrUpdate Overload
GSF.Collections Namespace


CollectionExtensions.AddOrUpdate(TKey, TValue) Method (IDictionary(TKey, TValue), TKey, Func(TKey, TValue), Func(TKey, TValue, TValue))

Grid Solutions Framework CollectionExtensionsAddOrUpdateTKey, TValue Method (IDictionaryTKey, TValue, TKey, FuncTKey, TValue, FuncTKey, TValue, TValue)
Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue AddOrUpdate<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    Func<TKey, TValue> addValueFactory,
    Func<TKey, TValue, TValue> updateValueFactory
)

<ExtensionAttribute>
Public Shared Function AddOrUpdate(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey,
    addValueFactory As Func(Of TKey, TValue),
    updateValueFactory As Func(Of TKey, TValue, TValue)
) As TValue
static member AddOrUpdate :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey *
        addValueFactory : Func<'TKey, 'TValue> *
        updateValueFactory : Func<'TKey, 'TValue, 'TValue> -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue AddOrUpdate(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key,
    Func<TKey, TValue>^ addValueFactory,
    Func<TKey, TValue, TValue>^ updateValueFactory
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to add the key/value pair to if the key does not already exist.
key
Type: TKey
The key to be added or whose value should be updated
addValueFactory
Type: SystemFunc TKey, TValue
The function used to generate a value for an absent key
updateValueFactory
Type: SystemFunc TKey, TValue, TValue
The function used to generate a new value for an existing key based on the key's existing value

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "M:GSF.Collections.CollectionExtensions.AddOrUpdate``2(System.Collections.Generic.IDictionary{``0,``1},``0,System.Func{``0,``1},System.Func{``0,``1,``1})"]

TValue

[Missing <typeparam name="TValue"/> documentation for "M:GSF.Collections.CollectionExtensions.AddOrUpdate``2(System.Collections.Generic.IDictionary{``0,``1},``0,System.Func{``0,``1},System.Func{``0,``1,``1})"]

Return Value

Type: TValue
The new value for the key. This will be either be the result of addValueFactory (if the key was absent) or the result of updateValueFactory (if the key was present).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
AddOrUpdate Overload
GSF.Collections Namespace


CollectionExtensions.AddOrUpdate(TKey, TValue) Method (IDictionary(TKey, TValue), TKey, TValue, Func(TKey, TValue, TValue))

Grid Solutions Framework CollectionExtensionsAddOrUpdateTKey, TValue Method (IDictionaryTKey, TValue, TKey, TValue, FuncTKey, TValue, TValue)
Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the IDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue AddOrUpdate<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    TValue addValue,
    Func<TKey, TValue, TValue> updateValueFactory
)

<ExtensionAttribute>
Public Shared Function AddOrUpdate(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey,
    addValue As TValue,
    updateValueFactory As Func(Of TKey, TValue, TValue)
) As TValue
static member AddOrUpdate :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey *
        addValue : 'TValue *
        updateValueFactory : Func<'TKey, 'TValue, 'TValue> -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue AddOrUpdate(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key,
    TValue addValue,
    Func<TKey, TValue, TValue>^ updateValueFactory
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to add the key/value pair to if the key does not already exist.
key
Type: TKey
The key to be added or whose value should be updated
addValue
Type: TValue
The value to be added for an absent key
updateValueFactory
Type: SystemFunc TKey, TValue, TValue
The function used to generate a new value for an existing key based on the key's existing value

Type Parameters

TKey

[Missing <typeparam name="TKey"/> documentation for "M:GSF.Collections.CollectionExtensions.AddOrUpdate``2(System.Collections.Generic.IDictionary{``0,``1},``0,``1,System.Func{``0,``1,``1})"]

TValue

[Missing <typeparam name="TValue"/> documentation for "M:GSF.Collections.CollectionExtensions.AddOrUpdate``2(System.Collections.Generic.IDictionary{``0,``1},``0,``1,System.Func{``0,``1,``1})"]

Return Value

Type: TValue
The new value for the key. This will be either be the result of addValueFactory (if the key was absent) or the result of updateValueFactory (if the key was present).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
AddOrUpdate Overload
GSF.Collections Namespace


CollectionExtensions.AddRange(T) Method

Grid Solutions Framework CollectionExtensionsAddRangeT Method
Adds the specified items to the collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void AddRange<T>(
    this IList<T> collection,
    IEnumerable<T> items
)

<ExtensionAttribute>
Public Shared Sub AddRange(Of T) (
    collection As IList(Of T),
    items As IEnumerable(Of T)
)
static member AddRange :
        collection : IList<'T> *
        items : IEnumerable<'T> -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static void AddRange(
    IList<T>^ collection,
    IEnumerable<T>^ items
)

Parameters

collection
Type: System.Collections.GenericIList T
The collection to which the items are to be added.
items
Type: System.Collections.GenericIEnumerable T
The elements to be added to the collection.

Type Parameters

T
Type of elements in the collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.All Method

Grid Solutions Framework CollectionExtensionsAll Method
Returns true if all items in BitArray are equal to value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool All(
    this BitArray source,
    bool value
)
<ExtensionAttribute>
Public Shared Function All (
    source As BitArray,
    value As Boolean
) As Boolean
static member All :
        source : BitArray *
        value : bool -> bool

GSF.Collections.CollectionExtensions.All = function(source, value);
public:
[ExtensionAttribute]
static bool All(
    BitArray^ source,
    bool value
)

Parameters

source
Type: System.CollectionsBitArray
Source BitArray.
value
Type: SystemBoolean
Boolean value to test for.

Return Value

Type: Boolean
true if all items in BitArray are equal to value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BitArray. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Any Method

Grid Solutions Framework CollectionExtensionsAny Method
Returns true if any item in BitArray is equal to value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool Any(
    this BitArray source,
    bool value
)
<ExtensionAttribute>
Public Shared Function Any (
    source As BitArray,
    value As Boolean
) As Boolean
static member Any :
        source : BitArray *
        value : bool -> bool

GSF.Collections.CollectionExtensions.Any = function(source, value);
public:
[ExtensionAttribute]
static bool Any(
    BitArray^ source,
    bool value
)

Parameters

source
Type: System.CollectionsBitArray
Source BitArray.
value
Type: SystemBoolean
Boolean value to test for.

Return Value

Type: Boolean
true if any item in BitArray is equal to value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type BitArray. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.CompareTo(TSource) Method

Grid Solutions Framework CollectionExtensionsCompareToTSource Method
Compares two arrays.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CompareTo<TSource>(
    this TSource[] array1,
    TSource[] array2,
    bool orderIsImportant = true
)

<ExtensionAttribute>
Public Shared Function CompareTo(Of TSource) (
    array1 As TSource(),
    array2 As TSource(),
    Optional orderIsImportant As Boolean = true
) As Integer
static member CompareTo :
        array1 : 'TSource[] *
        array2 : 'TSource[] *
        ?orderIsImportant : bool
(* Defaults:
        let _orderIsImportant = defaultArg orderIsImportant true
*)
-> int

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static int CompareTo(
    array<TSource>^ array1,
    array<TSource>^ array2,
    bool orderIsImportant = true
)

Parameters

array1
Type: TSource
The first type array to compare to.
array2
Type: TSource
The second type array to compare against.
orderIsImportant (Optional)
Type: SystemBoolean
true if order of elements should be considered for equality; otherwise, false.

Type Parameters

TSource
The generic type of the array.

Return Value

Type: Int32
An Int32 which returns 0 if they are equal, 1 if array1 is larger, or -1 if array2 is larger.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Cannot compare multidimensional arrays.
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Copy(T) Method

Grid Solutions Framework CollectionExtensionsCopyT Method
Returns a copy of the Array.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T[] Copy<T>(
    this T[] source,
    int startIndex,
    int length
)

<ExtensionAttribute>
Public Shared Function Copy(Of T) (
    source As T(),
    startIndex As Integer,
    length As Integer
) As T()
static member Copy :
        source : 'T[] *
        startIndex : int *
        length : int -> 'T[]

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static array<T>^ Copy(
    array<T>^ source,
    int startIndex,
    int length
)

Parameters

source
Type: T
The source Array whose elements are to be copied.
startIndex
Type: SystemInt32
The source array index from where the elements are to be copied.
length
Type: SystemInt32
The number of elements to be copied starting from the startIndex.

Type Parameters

T
Type of the Array to be copied.

Return Value

Type: T
An Array of elements copied from the specified portion of the source Array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the source Array -or- length is less than 0.
Remarks
Returned Array will be extended as needed to make it the specified length, but it will never be less than the source Array length - startIndex.
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.DistinctBy(TSource, TKey) Method

Grid Solutions Framework CollectionExtensionsDistinctByTSource, TKey Method
Returns only the elements whose keys are distinct.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<TSource> DistinctBy<TSource, TKey>(
    this IEnumerable<TSource> source,
    Func<TSource, TKey> keySelector
)

<ExtensionAttribute>
Public Shared Function DistinctBy(Of TSource, TKey) (
    source As IEnumerable(Of TSource),
    keySelector As Func(Of TSource, TKey)
) As IEnumerable(Of TSource)
static member DistinctBy :
        source : IEnumerable<'TSource> *
        keySelector : Func<'TSource, 'TKey> -> IEnumerable<'TSource>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource, typename TKey>
static IEnumerable<TSource>^ DistinctBy(
    IEnumerable<TSource>^ source,
    Func<TSource, TKey>^ keySelector
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
The collection of source objects.
keySelector
Type: SystemFunc TSource, TKey
The function used to access the keys of the source objects.

Type Parameters

TSource
The type of the source objects in the collection.
TKey
The type of the keys to be compared.

Return Value

Type: IEnumerable TSource
The elements from source whose keys are distinct.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.GetOrAdd Method

Grid Solutions Framework CollectionExtensionsGetOrAdd Method
Overload List
Name | Description
GetOrAddTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.
GetOrAddTKey, TValue(IDictionaryTKey, TValue, TKey, TValue) | Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.GetOrAdd(TKey, TValue) Method (IDictionary(TKey, TValue), TKey, Func(TKey, TValue))

Grid Solutions Framework CollectionExtensionsGetOrAddTKey, TValue Method (IDictionaryTKey, TValue, TKey, FuncTKey, TValue)
Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue GetOrAdd<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    Func<TKey, TValue> valueFactory
)

<ExtensionAttribute>
Public Shared Function GetOrAdd(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey,
    valueFactory As Func(Of TKey, TValue)
) As TValue
static member GetOrAdd :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey *
        valueFactory : Func<'TKey, 'TValue> -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue GetOrAdd(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key,
    Func<TKey, TValue>^ valueFactory
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to add the key/value pair to if the key does not already exist.
key
Type: TKey
The key to be added to the dictionary if it does not already exist.
valueFactory
Type: SystemFunc TKey, TValue
The function used to generate a value for the key.

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

Return Value

Type: TValue
The value of the key in the dictionary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GetOrAdd Overload
GSF.Collections Namespace


CollectionExtensions.GetOrAdd(TKey, TValue) Method (IDictionary(TKey, TValue), TKey, TValue)

Grid Solutions Framework CollectionExtensionsGetOrAddTKey, TValue Method (IDictionaryTKey, TValue, TKey, TValue)
Adds a key/value pair to the IDictionaryTKey, TValue if the key does not already exist.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue GetOrAdd<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    TValue value
)

<ExtensionAttribute>
Public Shared Function GetOrAdd(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey,
    value As TValue
) As TValue
static member GetOrAdd :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey *
        value : 'TValue -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue GetOrAdd(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key,
    TValue value
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to add the key/value pair to if the key does not already exist.
key
Type: TKey
The key to be added to the dictionary if it does not already exist.
value
Type: TValue
The value to assign to the key if the key does not already exist.

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

Return Value

Type: TValue
The value of the key in the dictionary.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GetOrAdd Overload
GSF.Collections Namespace


CollectionExtensions.GetOrDefault Method

Grid Solutions Framework CollectionExtensionsGetOrDefault Method
Overload List
Name | Description
GetOrDefaultTKey, TValue(IDictionaryTKey, TValue, TKey) | Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.
GetOrDefaultTKey, TValue(IDictionaryTKey, TValue, TKey, FuncTKey, TValue) | Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.GetOrDefault(TKey, TValue) Method (IDictionary(TKey, TValue), TKey)

Grid Solutions Framework CollectionExtensionsGetOrDefaultTKey, TValue Method (IDictionaryTKey, TValue, TKey)
Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue GetOrDefault<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key
)

<ExtensionAttribute>
Public Shared Function GetOrDefault(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey
) As TValue
static member GetOrDefault :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue GetOrDefault(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to check for the given key.
key
Type: TKey
The key to be checked for the existence of a value.

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

Return Value

Type: TValue
The value of the key in the dictionary or the default value if no such value exists.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GetOrDefault Overload
GSF.Collections Namespace


CollectionExtensions.GetOrDefault(TKey, TValue) Method (IDictionary(TKey, TValue), TKey, Func(TKey, TValue))

Grid Solutions Framework CollectionExtensionsGetOrDefaultTKey, TValue Method (IDictionaryTKey, TValue, TKey, FuncTKey, TValue)
Attempts to get the value for the given key and returns the default value instead if the key does not exist in the IDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TValue GetOrDefault<TKey, TValue>(
    this IDictionary<TKey, TValue> dictionary,
    TKey key,
    Func<TKey, TValue> defaultValueFactory
)

<ExtensionAttribute>
Public Shared Function GetOrDefault(Of TKey, TValue) (
    dictionary As IDictionary(Of TKey, TValue),
    key As TKey,
    defaultValueFactory As Func(Of TKey, TValue)
) As TValue
static member GetOrDefault :
        dictionary : IDictionary<'TKey, 'TValue> *
        key : 'TKey *
        defaultValueFactory : Func<'TKey, 'TValue> -> 'TValue

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TKey, typename TValue>
static TValue GetOrDefault(
    IDictionary<TKey, TValue>^ dictionary,
    TKey key,
    Func<TKey, TValue>^ defaultValueFactory
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary to check for the given key.
key
Type: TKey
The key to be checked for the existence of a value.
defaultValueFactory
Type: SystemFunc TKey, TValue
The function used to generate the default value if no value exists for the given key.

Type Parameters

TKey
The type of the keys in the dictionary.
TValue
The type of the values in the dictionary.

Return Value

Type: TValue
The value of the key in the dictionary or the default value if no such value exists.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDictionary TKey, TValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GetOrDefault Overload
GSF.Collections Namespace


CollectionExtensions.GetRange(T) Method

Grid Solutions Framework CollectionExtensionsGetRangeT Method
Returns elements in the specified range from the collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IList<T> GetRange<T>(
    this IList<T> collection,
    int index,
    int count
)

<ExtensionAttribute>
Public Shared Function GetRange(Of T) (
    collection As IList(Of T),
    index As Integer,
    count As Integer
) As IList(Of T)
static member GetRange :
        collection : IList<'T> *
        index : int *
        count : int -> IList<'T>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static IList<T>^ GetRange(
    IList<T>^ collection,
    int index,
    int count
)

Parameters

collection
Type: System.Collections.GenericIList T
The collection from which elements are to be retrieved.
index
Type: SystemInt32
The 0-based index position in the collection from which elements are to be retrieved.
count
Type: SystemInt32
The number of elements to be retrieved from the collection starting at the index.

Type Parameters

T
Type of elements in the collection.

Return Value

Type: IList T
An IListT object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.IndexOf(T) Method

Grid Solutions Framework CollectionExtensionsIndexOfT Method
Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int IndexOf<T>(
    this IList<T> source,
    Func<T, bool> predicate
)

<ExtensionAttribute>
Public Shared Function IndexOf(Of T) (
    source As IList(Of T),
    predicate As Func(Of T, Boolean)
) As Integer
static member IndexOf :
        source : IList<'T> *
        predicate : Func<'T, bool> -> int

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static int IndexOf(
    IList<T>^ source,
    Func<T, bool>^ predicate
)

Parameters

source
Type: System.Collections.GenericIList T
A IListT to find an index in.
predicate
Type: SystemFunc T, Boolean
A function to test each element for a condition.

Type Parameters

T
The type of the elements of source.

Return Value

Type: Int32
Index of the first element in source that matches the specified predicate; otherwise, -1.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.LoadDelimitedString Method

Grid Solutions Framework CollectionExtensionsLoadDelimitedString Method
Overload List
Name | Description
LoadDelimitedStringTSource(IListTSource, String, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list.
LoadDelimitedStringTSource(IListTSource, String, Char, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, into the given list.
LoadDelimitedStringTSource(IListTSource, String, String, FuncString, TSource) | Appends items parsed from delimited string, created with ToDelimitedString, into the given list.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.LoadDelimitedString(TSource) Method (IList(TSource), String, Func(String, TSource))

Grid Solutions Framework CollectionExtensionsLoadDelimitedStringTSource Method (IListTSource, String, FuncString, TSource)
Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void LoadDelimitedString<TSource>(
    this IList<TSource> destination,
    string delimitedString,
    Func<string, TSource> convertFromString
)

<ExtensionAttribute>
Public Shared Sub LoadDelimitedString(Of TSource) (
    destination As IList(Of TSource),
    delimitedString As String,
    convertFromString As Func(Of String, TSource)
)
static member LoadDelimitedString :
        destination : IList<'TSource> *
        delimitedString : string *
        convertFromString : Func<string, 'TSource> -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static void LoadDelimitedString(
    IList<TSource>^ destination,
    String^ delimitedString,
    Func<String^, TSource>^ convertFromString
)

Parameters

destination
Type: System.Collections.GenericIList TSource
The list we are adding items to.
delimitedString
Type: SystemString
The delimited string to parse for items.
convertFromString
Type: SystemFunc String, TSource
Delegate that takes one parameter and converts from string to type TSource.

Type Parameters

TSource
The generic type used.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Items that are converted are added to list. The list is not cleared in advance.
See Also

Reference

CollectionExtensions Class
LoadDelimitedString Overload
GSF.Collections Namespace


CollectionExtensions.LoadDelimitedString(TSource) Method (IList(TSource), String, Char, Func(String, TSource))

Grid Solutions Framework CollectionExtensionsLoadDelimitedStringTSource Method (IListTSource, String, Char, FuncString, TSource)
Appends items parsed from delimited string, created with ToDelimitedString, into the given list.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void LoadDelimitedString<TSource>(
    this IList<TSource> destination,
    string delimitedString,
    char delimiter,
    Func<string, TSource> convertFromString
)

<ExtensionAttribute>
Public Shared Sub LoadDelimitedString(Of TSource) (
    destination As IList(Of TSource),
    delimitedString As String,
    delimiter As Char,
    convertFromString As Func(Of String, TSource)
)
static member LoadDelimitedString :
        destination : IList<'TSource> *
        delimitedString : string *
        delimiter : char *
        convertFromString : Func<string, 'TSource> -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static void LoadDelimitedString(
    IList<TSource>^ destination,
    String^ delimitedString,
    wchar_t delimiter,
    Func<String^, TSource>^ convertFromString
)

Parameters

destination
Type: System.Collections.GenericIList TSource
The list we are adding items to.
delimitedString
Type: SystemString
The delimited string to parse for items.
delimiter
Type: SystemChar
The Char value to look for in the delimitedString as the delimiter.
convertFromString
Type: SystemFunc String, TSource
Delegate that takes one parameter and converts from string to type TSource.

Type Parameters

TSource
The generic type used.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Items that are converted are added to list. The list is not cleared in advance.
See Also

Reference

CollectionExtensions Class
LoadDelimitedString Overload
GSF.Collections Namespace


CollectionExtensions.LoadDelimitedString(TSource) Method (IList(TSource), String, String[], Func(String, TSource))

Grid Solutions Framework CollectionExtensionsLoadDelimitedStringTSource Method (IListTSource, String, String, FuncString, TSource)
Appends items parsed from delimited string, created with ToDelimitedString, into the given list.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void LoadDelimitedString<TSource>(
    this IList<TSource> destination,
    string delimitedString,
    string[] delimiters,
    Func<string, TSource> convertFromString
)

<ExtensionAttribute>
Public Shared Sub LoadDelimitedString(Of TSource) (
    destination As IList(Of TSource),
    delimitedString As String,
    delimiters As String(),
    convertFromString As Func(Of String, TSource)
)
static member LoadDelimitedString :
        destination : IList<'TSource> *
        delimitedString : string *
        delimiters : string[] *
        convertFromString : Func<string, 'TSource> -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static void LoadDelimitedString(
    IList<TSource>^ destination,
    String^ delimitedString,
    array<String^>^ delimiters,
    Func<String^, TSource>^ convertFromString
)

Parameters

destination
Type: System.Collections.GenericIList TSource
The list we are adding items to.
delimitedString
Type: SystemString
The delimited string to parse for items.
delimiters
Type: SystemString
An array of delimiters to look for in the delimitedString as the delimiter.
convertFromString
Type: SystemFunc String, TSource
Delegate that takes a String and converts to type TSource.

Type Parameters

TSource
The generic type used.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Items that are converted are added to list. The list is not cleared in advance.
See Also

Reference

CollectionExtensions Class
LoadDelimitedString Overload
GSF.Collections Namespace


CollectionExtensions.Majority Method

Grid Solutions Framework CollectionExtensionsMajority Method
Overload List
Name | Description
MajorityT(IEnumerableT) | Returns the majority value in the collection, or default type value if no item represents the majority.
MajorityT(IEnumerableT, T) | Returns the majority value in the collection, or defaultValue if no item represents the majority.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Majority(T) Method (IEnumerable(T))

Grid Solutions Framework CollectionExtensionsMajorityT Method (IEnumerableT)
Returns the majority value in the collection, or default type value if no item represents the majority.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Majority<T>(
    this IEnumerable<T> source
)

<ExtensionAttribute>
Public Shared Function Majority(Of T) (
    source As IEnumerable(Of T)
) As T
static member Majority :
        source : IEnumerable<'T> -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T Majority(
    IEnumerable<T>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable T
An enumeration over which to find the majority element.

Type Parameters

T
Type of elements in the source.

Return Value

Type: T
The majority value in the collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Majority Overload
GSF.Collections Namespace


CollectionExtensions.Majority(T) Method (IEnumerable(T), T)

Grid Solutions Framework CollectionExtensionsMajorityT Method (IEnumerableT, T)
Returns the majority value in the collection, or defaultValue if no item represents the majority.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Majority<T>(
    this IEnumerable<T> source,
    T defaultValue
)

<ExtensionAttribute>
Public Shared Function Majority(Of T) (
    source As IEnumerable(Of T),
    defaultValue As T
) As T
static member Majority :
        source : IEnumerable<'T> *
        defaultValue : 'T -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T Majority(
    IEnumerable<T>^ source,
    T defaultValue
)

Parameters

source
Type: System.Collections.GenericIEnumerable T
An enumeration over which to find the majority element.
defaultValue
Type: T
Default value to return if no item represents the majority.

Type Parameters

T
Type of elements in the source.

Return Value

Type: T
The majority value in the collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Majority Overload
GSF.Collections Namespace


CollectionExtensions.Max Method

Grid Solutions Framework CollectionExtensionsMax Method
Overload List
Name | Description
MaxTSource(IEnumerableTSource, IComparerTSource) | Returns the largest item from the enumeration.
MaxTSource(IEnumerableTSource, FuncTSource, TSource, Int32) | Returns the largest item from the enumeration.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Max(TSource) Method (IEnumerable(TSource), IComparer(TSource))

Grid Solutions Framework CollectionExtensionsMaxTSource Method (IEnumerableTSource, IComparerTSource)
Returns the largest item from the enumeration.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TSource Max<TSource>(
    this IEnumerable<TSource> source,
    IComparer<TSource> comparer
)

<ExtensionAttribute>
Public Shared Function Max(Of TSource) (
    source As IEnumerable(Of TSource),
    comparer As IComparer(Of TSource)
) As TSource
static member Max :
        source : IEnumerable<'TSource> *
        comparer : IComparer<'TSource> -> 'TSource

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static TSource Max(
    IEnumerable<TSource>^ source,
    IComparer<TSource>^ comparer
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
An enumeration that is compared against.
comparer
Type: System.Collections.GenericIComparer TSource
A comparer object.

Type Parameters

TSource
The generic type used.

Return Value

Type: TSource
Returns a generic type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Max Overload
GSF.Collections Namespace


CollectionExtensions.Max(TSource) Method (IEnumerable(TSource), Func(TSource, TSource, Int32))

Grid Solutions Framework CollectionExtensionsMaxTSource Method (IEnumerableTSource, FuncTSource, TSource, Int32)
Returns the largest item from the enumeration.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TSource Max<TSource>(
    this IEnumerable<TSource> source,
    Func<TSource, TSource, int> comparer
)

<ExtensionAttribute>
Public Shared Function Max(Of TSource) (
    source As IEnumerable(Of TSource),
    comparer As Func(Of TSource, TSource, Integer)
) As TSource
static member Max :
        source : IEnumerable<'TSource> *
        comparer : Func<'TSource, 'TSource, int> -> 'TSource

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static TSource Max(
    IEnumerable<TSource>^ source,
    Func<TSource, TSource, int>^ comparer
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
An enumeration that is compared against.
comparer
Type: SystemFunc TSource, TSource, Int32
A delegate that takes two generic types to compare, and returns an integer based on the comparison.

Type Parameters

TSource
The generic type used.

Return Value

Type: TSource
Returns a generic type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Max Overload
GSF.Collections Namespace


CollectionExtensions.MaxBy(TSource, TKey) Method

Grid Solutions Framework CollectionExtensionsMaxByTSource, TKey Method
Selects the largest item from the enumeration.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TSource MaxBy<TSource, TKey>(
    this IEnumerable<TSource> source,
    Func<TSource, TKey> keySelector
)
where TKey : IComparable

<ExtensionAttribute>
Public Shared Function MaxBy(Of TSource, TKey As IComparable) (
    source As IEnumerable(Of TSource),
    keySelector As Func(Of TSource, TKey)
) As TSource
static member MaxBy :
        source : IEnumerable<'TSource> *
        keySelector : Func<'TSource, 'TKey> -> 'TSource  when 'TKey : IComparable

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource, typename TKey>
where TKey : IComparable
static TSource MaxBy(
    IEnumerable<TSource>^ source,
    Func<TSource, TKey>^ keySelector
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
An enumeration that contains the objects to be selected from.
keySelector
Type: SystemFunc TSource, TKey
A delegate that takes an object and produces the key for comparison.

Type Parameters

TSource
The generic type of the objects to be selected from.
TKey
The generic type of the objects to be compared.

Return Value

Type: TSource
Returns the largest item from the enumeration.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Merge Method

Grid Solutions Framework CollectionExtensionsMerge Method
Overload List
Name | Description
MergeT, TKey, TValue(T, IDictionaryTKey, TValue) | Merges elements of multiple dictionaries into a single dictionary with no duplicate key values overwritten.
MergeT, TKey, TValue(T, Boolean, IDictionaryTKey, TValue) | Merges elements of multiple dictionaries into a single dictionary.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Merge(T, TKey, TValue) Method (T, IDictionary(TKey, TValue)[])

Grid Solutions Framework CollectionExtensionsMergeT, TKey, TValue Method (T, IDictionaryTKey, TValue)
Merges elements of multiple dictionaries into a single dictionary with no duplicate key values overwritten.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Merge<T, TKey, TValue>(
    this T source,
    params IDictionary<TKey, TValue>[] others
)
where T : new(), Object, IDictionary<TKey, TValue>

<ExtensionAttribute>
Public Shared Function Merge(Of T As {New, Object, IDictionary(Of TKey, TValue)}, TKey, TValue) (
    source As T,
    ParamArray others As IDictionary(Of TKey, TValue)()
) As T
static member Merge :
        source : 'T *
        others : IDictionary<'TKey, 'TValue>[] -> 'T  when 'T : new() and Object and IDictionary<'TKey, 'TValue>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T, typename TKey, typename TValue>
where T : gcnew(), Object, IDictionary<TKey, TValue>
static T Merge(
    T source,
    ... array<IDictionary<TKey, TValue>^>^ others
)

Parameters

source
Type: T
Source dictionary to merge with another dictionary.
others
Type: System.Collections.GenericIDictionary TKey, TValue
Other dictionaries to merge with source dictionary.

Type Parameters

T
Type of IDictionaryTKey, TValue to merge.
TKey
Type of IDictionaryTKey, TValue keys.
TValue
Type of IDictionaryTKey, TValue values.

Return Value

Type: T
A merged collection of all unique dictionary elements, all others merged left to the source with no duplicate key values overwritten (i.e., first encountered key value pair is the one that remains in the returned merged dictionary).

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Merge Overload
GSF.Collections Namespace


CollectionExtensions.Merge(T, TKey, TValue) Method (T, Boolean, IDictionary(TKey, TValue)[])

Grid Solutions Framework CollectionExtensionsMergeT, TKey, TValue Method (T, Boolean, IDictionaryTKey, TValue)
Merges elements of multiple dictionaries into a single dictionary.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Merge<T, TKey, TValue>(
    this T source,
    bool overwriteExisting,
    params IDictionary<TKey, TValue>[] others
)
where T : new(), Object, IDictionary<TKey, TValue>

<ExtensionAttribute>
Public Shared Function Merge(Of T As {New, Object, IDictionary(Of TKey, TValue)}, TKey, TValue) (
    source As T,
    overwriteExisting As Boolean,
    ParamArray others As IDictionary(Of TKey, TValue)()
) As T
static member Merge :
        source : 'T *
        overwriteExisting : bool *
        others : IDictionary<'TKey, 'TValue>[] -> 'T  when 'T : new() and Object and IDictionary<'TKey, 'TValue>

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T, typename TKey, typename TValue>
where T : gcnew(), Object, IDictionary<TKey, TValue>
static T Merge(
    T source,
    bool overwriteExisting,
    ... array<IDictionary<TKey, TValue>^>^ others
)

Parameters

source
Type: T
Source dictionary to merge with another dictionary.
overwriteExisting
Type: SystemBoolean
Set to true to overwrite duplicate key values as they are encountered.
others
Type: System.Collections.GenericIDictionary TKey, TValue
Other dictionaries to merge with source dictionary.

Type Parameters

T
Type of IDictionaryTKey, TValue to merge.
TKey
Type of IDictionaryTKey, TValue keys.
TValue
Type of IDictionaryTKey, TValue values.

Return Value

Type: T
A merged collection of all unique dictionary elements, all others merged left to the source.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Merge Overload
GSF.Collections Namespace


CollectionExtensions.Min Method

Grid Solutions Framework CollectionExtensionsMin Method
Overload List
Name | Description
MinTSource(IEnumerableTSource, IComparerTSource) | Returns the smallest item from the enumeration.
MinTSource(IEnumerableTSource, FuncTSource, TSource, Int32) | Returns the smallest item from the enumeration.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Min(TSource) Method (IEnumerable(TSource), IComparer(TSource))

Grid Solutions Framework CollectionExtensionsMinTSource Method (IEnumerableTSource, IComparerTSource)
Returns the smallest item from the enumeration.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TSource Min<TSource>(
    this IEnumerable<TSource> source,
    IComparer<TSource> comparer
)

<ExtensionAttribute>
Public Shared Function Min(Of TSource) (
    source As IEnumerable(Of TSource),
    comparer As IComparer(Of TSource)
) As TSource
static member Min :
        source : IEnumerable<'TSource> *
        comparer : IComparer<'TSource> -> 'TSource

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static TSource Min(
    IEnumerable<TSource>^ source,
    IComparer<TSource>^ comparer
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
An enumeration that is compared against.
comparer
Type: System.Collections.GenericIComparer TSource
A comparer object.

Type Parameters

TSource
The generic type used.

Return Value

Type: TSource
Returns a generic type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Min Overload
GSF.Collections Namespace


CollectionExtensions.Min(TSource) Method (IEnumerable(TSource), Func(TSource, TSource, Int32))

Grid Solutions Framework CollectionExtensionsMinTSource Method (IEnumerableTSource, FuncTSource, TSource, Int32)
Returns the smallest item from the enumeration.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TSource Min<TSource>(
    this IEnumerable<TSource> source,
    Func<TSource, TSource, int> comparer
)

<ExtensionAttribute>
Public Shared Function Min(Of TSource) (
    source As IEnumerable(Of TSource),
    comparer As Func(Of TSource, TSource, Integer)
) As TSource
static member Min :
        source : IEnumerable<'TSource> *
        comparer : Func<'TSource, 'TSource, int> -> 'TSource

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static TSource Min(
    IEnumerable<TSource>^ source,
    Func<TSource, TSource, int>^ comparer
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
An enumeration that is compared against.
comparer
Type: SystemFunc TSource, TSource, Int32
A delegate that takes two generic types to compare, and returns an integer based on the comparison.

Type Parameters

TSource
The generic type used.

Return Value

Type: TSource
Returns a generic type.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Min Overload
GSF.Collections Namespace


CollectionExtensions.MinBy(TSource, TKey) Method

Grid Solutions Framework CollectionExtensionsMinByTSource, TKey Method
Selects the smallest item from the enumeration.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TSource MinBy<TSource, TKey>(
    this IEnumerable<TSource> source,
    Func<TSource, TKey> keySelector
)
where TKey : IComparable

<ExtensionAttribute>
Public Shared Function MinBy(Of TSource, TKey As IComparable) (
    source As IEnumerable(Of TSource),
    keySelector As Func(Of TSource, TKey)
) As TSource
static member MinBy :
        source : IEnumerable<'TSource> *
        keySelector : Func<'TSource, 'TKey> -> 'TSource  when 'TKey : IComparable

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource, typename TKey>
where TKey : IComparable
static TSource MinBy(
    IEnumerable<TSource>^ source,
    Func<TSource, TKey>^ keySelector
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
An enumeration that contains the objects to be selected from.
keySelector
Type: SystemFunc TSource, TKey
A delegate that takes an object and produces the key for comparison.

Type Parameters

TSource
The generic type of the objects to be selected from.
TKey
The generic type of the objects to be compared.

Return Value

Type: TSource
Returns the smallest item from the enumeration.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Minority Method

Grid Solutions Framework CollectionExtensionsMinority Method
Overload List
Name | Description
MinorityT(IEnumerableT) | Returns the minority value in the collection, or default type value if no item represents the minority.
MinorityT(IEnumerableT, T) | Returns the minority value in the collection, or defaultValue if no item represents the minority.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Minority(T) Method (IEnumerable(T))

Grid Solutions Framework CollectionExtensionsMinorityT Method (IEnumerableT)
Returns the minority value in the collection, or default type value if no item represents the minority.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Minority<T>(
    this IEnumerable<T> source
)

<ExtensionAttribute>
Public Shared Function Minority(Of T) (
    source As IEnumerable(Of T)
) As T
static member Minority :
        source : IEnumerable<'T> -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T Minority(
    IEnumerable<T>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable T
An enumeration over which to find the minority element.

Type Parameters

T
Type of elements in the source.

Return Value

Type: T
The minority value in the collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Minority Overload
GSF.Collections Namespace


CollectionExtensions.Minority(T) Method (IEnumerable(T), T)

Grid Solutions Framework CollectionExtensionsMinorityT Method (IEnumerableT, T)
Returns the minority value in the collection, or defaultValue if no item represents the minority.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T Minority<T>(
    this IEnumerable<T> source,
    T defaultValue
)

<ExtensionAttribute>
Public Shared Function Minority(Of T) (
    source As IEnumerable(Of T),
    defaultValue As T
) As T
static member Minority :
        source : IEnumerable<'T> *
        defaultValue : 'T -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T Minority(
    IEnumerable<T>^ source,
    T defaultValue
)

Parameters

source
Type: System.Collections.GenericIEnumerable T
An enumeration over which to find the minority element.
defaultValue
Type: T
Default value to return if no item represents the minority.

Type Parameters

T
Type of elements in the source.

Return Value

Type: T
The minority value in the collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
Minority Overload
GSF.Collections Namespace


CollectionExtensions.Scramble Method

Grid Solutions Framework CollectionExtensionsScramble Method
Overload List
Name | Description
ScrambleTSource(IListTSource) | Rearranges all the elements in the list into a highly-random order.
ScrambleTSource(IListTSource, Int32) | Rearranges all the elements in the list into a repeatable pseudo-random order.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.Scramble(TSource) Method (IList(TSource))

Grid Solutions Framework CollectionExtensionsScrambleTSource Method (IListTSource)
Rearranges all the elements in the list into a highly-random order.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Scramble<TSource>(
    this IList<TSource> source
)

<ExtensionAttribute>
Public Shared Sub Scramble(Of TSource) (
    source As IList(Of TSource)
)
static member Scramble :
        source : IList<'TSource> -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static void Scramble(
    IList<TSource>^ source
)

Parameters

source
Type: System.Collections.GenericIList TSource
The input list of generic types to scramble.

Type Parameters

TSource
The generic type of the list.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function uses a cryptographically strong random number generator to perform the scramble.
See Also

Reference

CollectionExtensions Class
Scramble Overload
GSF.Collections Namespace


CollectionExtensions.Scramble(TSource) Method (IList(TSource), Int32)

Grid Solutions Framework CollectionExtensionsScrambleTSource Method (IListTSource, Int32)
Rearranges all the elements in the list into a repeatable pseudo-random order.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Scramble<TSource>(
    this IList<TSource> source,
    int seed
)

<ExtensionAttribute>
Public Shared Sub Scramble(Of TSource) (
    source As IList(Of TSource),
    seed As Integer
)
static member Scramble :
        source : IList<'TSource> *
        seed : int -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static void Scramble(
    IList<TSource>^ source,
    int seed
)

Parameters

source
Type: System.Collections.GenericIList TSource
The input list of generic types to scramble.
seed
Type: SystemInt32
A number used to calculate a starting value for the pseudo-random number sequence.

Type Parameters

TSource
The generic type of the list.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function uses the Random generator to perform the scramble using a sequence that is repeatable.
See Also

Reference

CollectionExtensions Class
Scramble Overload
GSF.Collections Namespace


CollectionExtensions.ToDelimitedString Method

Grid Solutions Framework CollectionExtensionsToDelimitedString Method
Overload List
Name | Description
ToDelimitedStringTSource(IEnumerableTSource) | Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString.
ToDelimitedStringTSource(IEnumerableTSource, Char) | Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.
ToDelimitedStringTSource(IEnumerableTSource, String) | Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.
Top
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.ToDelimitedString(TSource) Method (IEnumerable(TSource))

Grid Solutions Framework CollectionExtensionsToDelimitedStringTSource Method (IEnumerableTSource)
Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToDelimitedString<TSource>(
    this IEnumerable<TSource> source
)

<ExtensionAttribute>
Public Shared Function ToDelimitedString(Of TSource) (
    source As IEnumerable(Of TSource)
) As String
static member ToDelimitedString :
        source : IEnumerable<'TSource> -> string

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static String^ ToDelimitedString(
    IEnumerable<TSource>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
The source object to be converted into a delimited string.

Type Parameters

TSource
The generic type used.

Return Value

Type: String
Returns a String that is result of combining all elements in the list delimited by the '|' character.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
ToDelimitedString Overload
GSF.Collections Namespace


CollectionExtensions.ToDelimitedString(TSource) Method (IEnumerable(TSource), Char)

Grid Solutions Framework CollectionExtensionsToDelimitedStringTSource Method (IEnumerableTSource, Char)
Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToDelimitedString<TSource>(
    this IEnumerable<TSource> source,
    char delimiter
)

<ExtensionAttribute>
Public Shared Function ToDelimitedString(Of TSource) (
    source As IEnumerable(Of TSource),
    delimiter As Char
) As String
static member ToDelimitedString :
        source : IEnumerable<'TSource> *
        delimiter : char -> string

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static String^ ToDelimitedString(
    IEnumerable<TSource>^ source,
    wchar_t delimiter
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
The source object to be converted into a delimited string.
delimiter
Type: SystemChar
The delimiting character used.

Type Parameters

TSource
The generic type used.

Return Value

Type: String
Returns a String that is result of combining all elements in the list delimited by delimiter.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
ToDelimitedString Overload
GSF.Collections Namespace


CollectionExtensions.ToDelimitedString(TSource) Method (IEnumerable(TSource), String)

Grid Solutions Framework CollectionExtensionsToDelimitedStringTSource Method (IEnumerableTSource, String)
Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToDelimitedString<TSource>(
    this IEnumerable<TSource> source,
    string delimiter
)

<ExtensionAttribute>
Public Shared Function ToDelimitedString(Of TSource) (
    source As IEnumerable(Of TSource),
    delimiter As String
) As String
static member ToDelimitedString :
        source : IEnumerable<'TSource> *
        delimiter : string -> string

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static String^ ToDelimitedString(
    IEnumerable<TSource>^ source,
    String^ delimiter
)

Parameters

source
Type: System.Collections.GenericIEnumerable TSource
The source object to be converted into a delimited string.
delimiter
Type: SystemString
The delimiting String used.

Type Parameters

TSource
The generic type used.

Return Value

Type: String
Returns a String that is result of combining all elements in the list delimited by delimiter.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CollectionExtensions Class
ToDelimitedString Overload
GSF.Collections Namespace


CollectionExtensions.Unscramble(TSource) Method

Grid Solutions Framework CollectionExtensionsUnscrambleTSource Method
Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Unscramble<TSource>(
    this IList<TSource> source,
    int seed
)

<ExtensionAttribute>
Public Shared Sub Unscramble(Of TSource) (
    source As IList(Of TSource),
    seed As Integer
)
static member Unscramble :
        source : IList<'TSource> *
        seed : int -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TSource>
static void Unscramble(
    IList<TSource>^ source,
    int seed
)

Parameters

source
Type: System.Collections.GenericIList TSource
The input list of generic types to unscramble.
seed
Type: SystemInt32
The same number used in ScrambleTSource(IListTSource, Int32) call to scramble original list.

Type Parameters

TSource
The generic type of the list.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList TSource. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function uses the Random generator to perform the unscramble using a sequence that is repeatable.
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


CollectionExtensions.UpdateRange(T) Method

Grid Solutions Framework CollectionExtensionsUpdateRangeT Method
Updates collection starting at the index with the specified items.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void UpdateRange<T>(
    this IList<T> collection,
    int index,
    IEnumerable<T> items
)

<ExtensionAttribute>
Public Shared Sub UpdateRange(Of T) (
    collection As IList(Of T),
    index As Integer,
    items As IEnumerable(Of T)
)
static member UpdateRange :
        collection : IList<'T> *
        index : int *
        items : IEnumerable<'T> -> unit

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static void UpdateRange(
    IList<T>^ collection,
    int index,
    IEnumerable<T>^ items
)

Parameters

collection
Type: System.Collections.GenericIList T
The collection whose elements are to be updated with the specified items.
index
Type: SystemInt32
The zero-based index in the collection at which elements are to be updated.
items
Type: System.Collections.GenericIEnumerable T
The elements that will replace the collection elements starting at the index.

Type Parameters

T
Type of elements in the collection.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IList T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The specified index is present in the collection.
See Also

Reference

CollectionExtensions Class
GSF.Collections Namespace


DictionaryList(TKey, TValue) Class

Grid Solutions Framework DictionaryListTKey, TValue Class
Represents a sorted dictionary style list that supports IList.
Inheritance Hierarchy
SystemObject
GSF.CollectionsDictionaryListTKey, TValue

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DictionaryList<TKey, TValue> : IList<KeyValuePair<TKey, TValue>>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable

Public Class DictionaryList(Of TKey, TValue)
    Implements IList(Of KeyValuePair(Of TKey, TValue)),
    IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
type DictionaryList<'TKey, 'TValue> =
    class
        interface IList<KeyValuePair<'TKey, 'TValue>>
        interface IDictionary<'TKey, 'TValue>
        interface ICollection<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable
    end
JavaScript does not support generic types or methods.
generic<typename TKey, typename TValue>
public ref class DictionaryList : IList<KeyValuePair<TKey, TValue>>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable

Type Parameters

TKey
Generic key type.
TValue
Generic value type.

The DictionaryListTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | DictionaryListTKey, TValue | Creates a new DictionaryListTKey, TValue.
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the DictionaryListTKey, TValue.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the DictionaryListTKey, TValue.
Public method | Clear | Removes all items from the DictionaryListTKey, TValue.
Public method | Contains | Determines whether the DictionaryListTKey, TValue contains a specific value.
Public method | ContainsKey | Determines whether the DictionaryListTKey, TValue contains an element with the specified key.
Public method | ContainsValue | Determines whether the DictionaryListTKey, TValue contains a specific value.
Public method | CopyTo | Copies the elements of the DictionaryListTKey, TValue to an Array, starting at a particular index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the DictionaryListTKey, TValue.
Public method | IndexOfKey | Searches for the specified key and returns the zero-based index within the entire DictionaryListTKey, TValue.
Public method | IndexOfValue | Searches for the specified value and returns the zero-based index of the first occurrence within the entire DictionaryListTKey, TValue.
Public method | Insert | Inserts an item to the DictionaryListTKey, TValue at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the DictionaryListTKey, TValue.
Public method | Remove(TKey) | Removes the element with the specified key from the DictionaryListTKey, TValue.
Public method | RemoveAt | Removes the DictionaryListTKey, TValue item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeKeyValuePairTKey, TValue | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByKeyValuePairTKey, TValue, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeKeyValuePairTKey, TValue | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfKeyValuePairTKey, TValue | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringKeyValuePairTKey, TValue(String, FuncString, KeyValuePairTKey, TValue) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringKeyValuePairTKey, TValue(String, Char, FuncString, KeyValuePairTKey, TValue) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringKeyValuePairTKey, TValue(String, String, FuncString, KeyValuePairTKey, TValue) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairTKey, TValue, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairTKey, TValue, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleKeyValuePairTKey, TValue | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleKeyValuePairTKey, TValue(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleKeyValuePairTKey, TValue | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeKeyValuePairTKey, TValue | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the DictionaryListTKey, TValue.
Public property | IsReadOnly | Gets a value indicating whether the DictionaryListTKey, TValue is read-only.
Public property | ItemInt32 | Gets or sets the element at the specified index.
Public property | ItemTKey | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
Remarks

Have you ever needed the quick look-up feature on a Dictionary (e.g., Hashtable), but ended up missing the indexed or sequential access like you have in a list? You may have wondered why the .NET dictionary class doesn’t implement the IList interface which allows this. The reason IDictionary implementations do not normally implement the IList interface is because of ambiguity that is caused when implementing an integer key. For example, if you created a dictionary style class with a key of type "Integer" that actually did implement IList(Of T), you would not be able to access items in the IList interface by index without "casting" the class as IList. This is because the Item property in both the IDictionary and IList would have the same parameters. Note, however, that generics in .NET 2.0 gladly allow a class to implement both IDictionary and IList (even specifying as Integer as the key) so long you as you are happy knowing that the compiler will choose if you access your items by index or key. Given that caveat, there are many times when you need a dictionary style collection but also desire an IList implementation so the class can be used in other ways without conversion. As a result of these needs, we’ve added a generic class to code library called a DictionaryList -- which is essentially just a sorted dictionary style list (i.e., SortedList) that implements the IList(Of T) interface (specifically as IList(Of KeyValuePair(Of TKey, TValue))). You will find all of your convenient expected methods related to both dictionaries and lists; that is, you can look-up items by key or by index. The class works perfectly for any non-Integer based key (e.g., String, custom class, etc.) -- note that specifying an Integer as the key for the class won’t cause an error, but it also will not be very useful. However, you can specify the key for your DictionaryList as a "Long," which allows you to use long integers for keyed look-ups and regular integers for indexed access--the best of both worlds! In summary, I would not change your programming habits to start using this for "my collection for everything," as nothing comes for free; however, if you have a need for a "hybrid" collection class, this fits the bill.

Important note about using an "Integer" as the key for this class: IDictionary implementations do not normally implement the IList interface because of ambiguity that is caused when implementing an integer key. For example, if you implement this class with a key of type "Integer" you will not be able to access items in the queue by index without "casting" the class as IList. This is because the Item property in both the IDictionary and IList would have the same parameters.

Note that prior to the addition of Generics in .NET, the class that performed a similar function was the "NameObjectCollectionBase" in the System.Collections.Specialized namespace which specifically allowed item access by either key or by index. This class is similar in function but instead is a generic class allowing use with any strongly typed key or value.

See Also

Reference

GSF.Collections Namespace


DictionaryList(TKey, TValue) Constructor

Grid Solutions Framework DictionaryListTKey, TValue Constructor
Creates a new DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DictionaryList()
Public Sub New
new : unit -> DictionaryList
GSF.Collections.DictionaryList = function();
public:
DictionaryList()
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue) Methods

Grid Solutions Framework DictionaryListTKey, TValue Methods

The DictionaryListTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the DictionaryListTKey, TValue.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the DictionaryListTKey, TValue.
Public method | Clear | Removes all items from the DictionaryListTKey, TValue.
Public method | Contains | Determines whether the DictionaryListTKey, TValue contains a specific value.
Public method | ContainsKey | Determines whether the DictionaryListTKey, TValue contains an element with the specified key.
Public method | ContainsValue | Determines whether the DictionaryListTKey, TValue contains a specific value.
Public method | CopyTo | Copies the elements of the DictionaryListTKey, TValue to an Array, starting at a particular index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the DictionaryListTKey, TValue.
Public method | IndexOfKey | Searches for the specified key and returns the zero-based index within the entire DictionaryListTKey, TValue.
Public method | IndexOfValue | Searches for the specified value and returns the zero-based index of the first occurrence within the entire DictionaryListTKey, TValue.
Public method | Insert | Inserts an item to the DictionaryListTKey, TValue at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the DictionaryListTKey, TValue.
Public method | Remove(TKey) | Removes the element with the specified key from the DictionaryListTKey, TValue.
Public method | RemoveAt | Removes the DictionaryListTKey, TValue item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeKeyValuePairTKey, TValue | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByKeyValuePairTKey, TValue, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeKeyValuePairTKey, TValue | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfKeyValuePairTKey, TValue | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringKeyValuePairTKey, TValue(String, FuncString, KeyValuePairTKey, TValue) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringKeyValuePairTKey, TValue(String, Char, FuncString, KeyValuePairTKey, TValue) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringKeyValuePairTKey, TValue(String, String, FuncString, KeyValuePairTKey, TValue) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairTKey, TValue, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairTKey, TValue, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleKeyValuePairTKey, TValue | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleKeyValuePairTKey, TValue(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleKeyValuePairTKey, TValue | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeKeyValuePairTKey, TValue | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Add Method

Grid Solutions Framework DictionaryListTKey, TValueAdd Method
Overload List
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the DictionaryListTKey, TValue.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the DictionaryListTKey, TValue.
Top
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Add Method (KeyValuePair(TKey, TValue))

Grid Solutions Framework DictionaryListTKey, TValueAdd Method (KeyValuePairTKey, TValue)
Adds an item to the DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    KeyValuePair<TKey, TValue> item
)
Public Sub Add (
    item As KeyValuePair(Of TKey, TValue)
)
abstract Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit
override Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit
function Add(item);
public:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The key value pair item to add.

Implements

ICollectionTAdd(T)
See Also

Reference

DictionaryListTKey, TValue Class
Add Overload
GSF.Collections Namespace


DictionaryList(TKey, TValue).Add Method (TKey, TValue)

Grid Solutions Framework DictionaryListTKey, TValueAdd Method (TKey, TValue)
Adds an element with the provided key and value to the DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)
abstract Add :
        key : 'TKey *
        value : 'TValue -> unit
override Add :
        key : 'TKey *
        value : 'TValue -> unit
function Add(key, value);
public:
virtual void Add(
    TKey key,
    TValue value
) sealed

Parameters

key
Type: TKey
The object to use as the key of the element to add.
value
Type: TValue
The object to use as the value of the element to add.

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
See Also

Reference

DictionaryListTKey, TValue Class
Add Overload
GSF.Collections Namespace


DictionaryList(TKey, TValue).Clear Method

Grid Solutions Framework DictionaryListTKey, TValueClear Method
Removes all items from the DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
abstract Clear : unit -> unit
override Clear : unit -> unit
function Clear();
public:
virtual void Clear() sealed

Implements

ICollectionTClear
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Contains Method

Grid Solutions Framework DictionaryListTKey, TValueContains Method
Determines whether the DictionaryListTKey, TValue contains a specific value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Contains(
    KeyValuePair<TKey, TValue> item
)
Public Function Contains (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
abstract Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool
function Contains(item);
public:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the DictionaryListTKey, TValue.

Return Value

Type: Boolean
true if item is found in the DictionaryListTKey, TValue; otherwise, false

Implements

ICollectionTContains(T)
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).ContainsKey Method

Grid Solutions Framework DictionaryListTKey, TValueContainsKey Method
Determines whether the DictionaryListTKey, TValue contains an element with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey (
    key As TKey
) As Boolean
abstract ContainsKey :
        key : 'TKey -> bool
override ContainsKey :
        key : 'TKey -> bool
function ContainsKey(key);
public:
virtual bool ContainsKey(
    TKey key
) sealed

Parameters

key
Type: TKey
The key to locate in the DictionaryListTKey, TValue.

Return Value

Type: Boolean
true if the DictionaryListTKey, TValue contains an element with the key; otherwise, false.

Implements

IDictionaryTKey, TValueContainsKey(TKey)
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).ContainsValue Method

Grid Solutions Framework DictionaryListTKey, TValueContainsValue Method
Determines whether the DictionaryListTKey, TValue contains a specific value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ContainsValue(
    TValue value
)
Public Function ContainsValue (
    value As TValue
) As Boolean
member ContainsValue :
        value : 'TValue -> bool

function ContainsValue(value);
public:
bool ContainsValue(
    TValue value
)

Parameters

value
Type: TValue
The value to locate in the DictionaryListTKey, TValue. The value can be null for reference types.

Return Value

Type: Boolean
true if the DictionaryListTKey, TValue contains an element with the specified value; otherwise, false.
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).CopyTo Method

Grid Solutions Framework DictionaryListTKey, TValueCopyTo Method
Copies the elements of the DictionaryListTKey, TValue to an Array, starting at a particular index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of TKey, TValue)(),
    arrayIndex As Integer
)
abstract CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit
function CopyTo(array, arrayIndex);
public:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: System.Collections.GenericKeyValuePair TKey, TValue
The one-dimensional Array that is the destination of the elements copied from DictionaryListTKey, TValue. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).GetEnumerator Method

Grid Solutions Framework DictionaryListTKey, TValueGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>
function GetEnumerator();
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed

Return Value

Type: IEnumerator KeyValuePair TKey, TValue
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).IndexOf Method

Grid Solutions Framework DictionaryListTKey, TValueIndexOf Method
Determines the index of a specific item in the DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOf(
    KeyValuePair<TKey, TValue> item
)
Public Function IndexOf (
    item As KeyValuePair(Of TKey, TValue)
) As Integer
abstract IndexOf :
        item : KeyValuePair<'TKey, 'TValue> -> int
override IndexOf :
        item : KeyValuePair<'TKey, 'TValue> -> int
function IndexOf(item);
public:
virtual int IndexOf(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the DictionaryListTKey, TValue.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).IndexOfKey Method

Grid Solutions Framework DictionaryListTKey, TValueIndexOfKey Method
Searches for the specified key and returns the zero-based index within the entire DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOfKey(
    TKey key
)
Public Function IndexOfKey (
    key As TKey
) As Integer
member IndexOfKey :
        key : 'TKey -> int

function IndexOfKey(key);
public:
int IndexOfKey(
    TKey key
)

Parameters

key
Type: TKey
The key to locate in the DictionaryListTKey, TValue.

Return Value

Type: Int32
The zero-based index of key within the entire DictionaryListTKey, TValue, if found; otherwise, -1.
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).IndexOfValue Method

Grid Solutions Framework DictionaryListTKey, TValueIndexOfValue Method
Searches for the specified value and returns the zero-based index of the first occurrence within the entire DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOfValue(
    TValue value
)
Public Function IndexOfValue (
    value As TValue
) As Integer
member IndexOfValue :
        value : 'TValue -> int

function IndexOfValue(value);
public:
int IndexOfValue(
    TValue value
)

Parameters

value
Type: TValue
The value to locate in the DictionaryListTKey, TValue. The value can be null for reference types.

Return Value

Type: Int32
The zero-based index of the first occurrence of value within the entire DictionaryListTKey, TValue, if found; otherwise, -1.
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Insert Method

Grid Solutions Framework DictionaryListTKey, TValueInsert Method
Inserts an item to the DictionaryListTKey, TValue at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Insert(
    int index,
    KeyValuePair<TKey, TValue> item
)
Public Sub Insert (
    index As Integer,
    item As KeyValuePair(Of TKey, TValue)
)
abstract Insert :
        index : int *
        item : KeyValuePair<'TKey, 'TValue> -> unit
override Insert :
        index : int *
        item : KeyValuePair<'TKey, 'TValue> -> unit
function Insert(index, item);
public:
virtual void Insert(
    int index,
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to insert into the DictionaryListTKey, TValue.

Implements

IListTInsert(Int32, T)
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Remove Method

Grid Solutions Framework DictionaryListTKey, TValueRemove Method
Overload List
 | Name | Description
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the DictionaryListTKey, TValue.
Public method | Remove(TKey) | Removes the element with the specified key from the DictionaryListTKey, TValue.
Top
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Remove Method (KeyValuePair(TKey, TValue))

Grid Solutions Framework DictionaryListTKey, TValueRemove Method (KeyValuePairTKey, TValue)
Removes the first occurrence of a specific object from the DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    KeyValuePair<TKey, TValue> item
)
Public Function Remove (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
abstract Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool
function Remove(item);
public:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to remove from the DictionaryListTKey, TValue.

Return Value

Type: Boolean
true if item was successfully removed from the DictionaryListTKey, TValue; otherwise, false. This method also returns false if item is not found in the original DictionaryListTKey, TValue.

Implements

ICollectionTRemove(T)
See Also

Reference

DictionaryListTKey, TValue Class
Remove Overload
GSF.Collections Namespace


DictionaryList(TKey, TValue).Remove Method (TKey)

Grid Solutions Framework DictionaryListTKey, TValueRemove Method (TKey)
Removes the element with the specified key from the DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    TKey key
)
Public Function Remove (
    key As TKey
) As Boolean
abstract Remove :
        key : 'TKey -> bool
override Remove :
        key : 'TKey -> bool
function Remove(key);
public:
virtual bool Remove(
    TKey key
) sealed

Parameters

key
Type: TKey
The key of the element to remove.

Return Value

Type: Boolean
true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original DictionaryListTKey, TValue.

Implements

IDictionaryTKey, TValueRemove(TKey)
See Also

Reference

DictionaryListTKey, TValue Class
Remove Overload
GSF.Collections Namespace


DictionaryList(TKey, TValue).RemoveAt Method

Grid Solutions Framework DictionaryListTKey, TValueRemoveAt Method
Removes the DictionaryListTKey, TValue item at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
function RemoveAt(index);
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).TryGetValue Method

Grid Solutions Framework DictionaryListTKey, TValueTryGetValue Method
Gets the value associated with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue (
    key As TKey,
    <OutAttribute> ByRef value As TValue
) As Boolean
abstract TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
override TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
function TryGetValue(key, value);
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed

Parameters

key
Type: TKey
The key whose value to get.
value
Type: TValue
When this method returns, the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the DictionaryListTKey, TValue contains an element with the specified key; otherwise, false.

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue) Properties

Grid Solutions Framework DictionaryListTKey, TValue Properties

The DictionaryListTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the DictionaryListTKey, TValue.
Public property | IsReadOnly | Gets a value indicating whether the DictionaryListTKey, TValue is read-only.
Public property | ItemInt32 | Gets or sets the element at the specified index.
Public property | ItemTKey | Gets or sets the element with the specified key.
Public property | Keys | Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.
Public property | Values | Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.
Top
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Count Property

Grid Solutions Framework DictionaryListTKey, TValueCount Property
Gets the number of elements contained in the DictionaryListTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).IsReadOnly Property

Grid Solutions Framework DictionaryListTKey, TValueIsReadOnly Property
Gets a value indicating whether the DictionaryListTKey, TValue is read-only.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
function get_IsReadOnly();

public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Item Property

Grid Solutions Framework DictionaryListTKey, TValueItem Property
Overload List
 | Name | Description
Public property | ItemInt32 | Gets or sets the element at the specified index.
Public property | ItemTKey | Gets or sets the element with the specified key.
Top
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Item Property (Int32)

Grid Solutions Framework DictionaryListTKey, TValueItem Property (Int32)
Gets or sets the element at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public KeyValuePair<TKey, TValue> this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As KeyValuePair(Of TKey, TValue)
    Get
    Set
abstract Item : KeyValuePair<'TKey, 'TValue> with get, set
override Item : KeyValuePair<'TKey, 'TValue> with get, set
function get_Item(index);
function set_Item(value);
public:
virtual property KeyValuePair<TKey, TValue> default[int index] {
    KeyValuePair<TKey, TValue> get (int index) sealed;
    void set (int index, KeyValuePair<TKey, TValue> value) sealed;
}

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.

Return Value

Type: KeyValuePair TKey, TValue
The element at the specified index.

Implements

IListTItemInt32
See Also

Reference

DictionaryListTKey, TValue Class
Item Overload
GSF.Collections Namespace


DictionaryList(TKey, TValue).Item Property (TKey)

Grid Solutions Framework DictionaryListTKey, TValueItem Property (TKey)
Gets or sets the element with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set
abstract Item : 'TValue with get, set
override Item : 'TValue with get, set
function get_Item(key);
function set_Item(value);
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}

Parameters

key
Type: TKey
The key of the element to get or set.

Return Value

Type: TValue
The element with the specified key.

Implements

IDictionaryTKey, TValueItemTKey
See Also

Reference

DictionaryListTKey, TValue Class
Item Overload
GSF.Collections Namespace


DictionaryList(TKey, TValue).Keys Property

Grid Solutions Framework DictionaryListTKey, TValueKeys Property
Gets an ICollectionT containing the keys of the IDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
abstract Keys : ICollection<'TKey> with get
override Keys : ICollection<'TKey> with get
function get_Keys();

public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}

Property Value

Type: ICollection TKey

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DictionaryList(TKey, TValue).Values Property

Grid Solutions Framework DictionaryListTKey, TValueValues Property
Gets an ICollectionT containing the values in the IDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
abstract Values : ICollection<'TValue> with get
override Values : ICollection<'TValue> with get
function get_Values();

public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}

Property Value

Type: ICollection TValue

Implements

IDictionaryTKey, TValueValues
See Also

Reference

DictionaryListTKey, TValue Class
GSF.Collections Namespace


DoubleBufferedQueue(T) Class

Grid Solutions Framework DoubleBufferedQueueT Class
A thread-safe double-buffered queue that allows for low-contention item processing in single-producer, single-consumer scenarios.
Inheritance Hierarchy
SystemObject
GSF.CollectionsDoubleBufferedQueueT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DoubleBufferedQueue<T>

Public Class DoubleBufferedQueue(Of T)
type DoubleBufferedQueue<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class DoubleBufferedQueue

Type Parameters

T
Type of items being queued.

The DoubleBufferedQueueT type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedQueueT | Creates a new instance of the DoubleBufferedQueueT class.
Top
Methods
 | Name | Description
Public method | Clear | Empties the producer's buffer so that the items can no longer be consumed by the consumer.
Public method | Dequeue | Dequeues a collection of items from the queue.
Public method | Enqueue | Enqueues a collection of items into the double-buffered queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClear | Attempts to enqueue a collection of items into the double-buffered queue.
Public method | TryDequeue | Attempts to dequeue a collection of items from the queue and returns the number of items left in the queue after dequeuing.
Public method | TryEnqueue | Attempts to enqueue a collection of items into the double-buffered queue.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the current number of items in the queue.
Public property | ProcessItemsFunction | Gets or sets item processing function.
Top
Events
 | Name | Description
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the AsyncQueueT.
Top
Remarks
It is not safe to use this class with multiple consumer threads. The Dequeue method must be called by one thread at a time, and the consumer must not access a list returned by Dequeue after its next call to Dequeue.
See Also

Reference

GSF.Collections Namespace


DoubleBufferedQueue(T) Constructor

Grid Solutions Framework DoubleBufferedQueueT Constructor
Creates a new instance of the DoubleBufferedQueueT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DoubleBufferedQueue()
Public Sub New
new : unit -> DoubleBufferedQueue
GSF.Collections.DoubleBufferedQueue = function();
public:
DoubleBufferedQueue()
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T) Methods

Grid Solutions Framework DoubleBufferedQueueT Methods

The DoubleBufferedQueueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Empties the producer's buffer so that the items can no longer be consumed by the consumer.
Public method | Dequeue | Dequeues a collection of items from the queue.
Public method | Enqueue | Enqueues a collection of items into the double-buffered queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryClear | Attempts to enqueue a collection of items into the double-buffered queue.
Public method | TryDequeue | Attempts to dequeue a collection of items from the queue and returns the number of items left in the queue after dequeuing.
Public method | TryEnqueue | Attempts to enqueue a collection of items into the double-buffered queue.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).Clear Method

Grid Solutions Framework DoubleBufferedQueueTClear Method
Empties the producer's buffer so that the items can no longer be consumed by the consumer.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).Dequeue Method

Grid Solutions Framework DoubleBufferedQueueTDequeue Method
Dequeues a collection of items from the queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<T> Dequeue()
Public Function Dequeue As IList(Of T)
member Dequeue : unit -> IList<'T>

function Dequeue();
public:
IList<T>^ Dequeue()

Return Value

Type: IList T
A collection of items that have previously been enqueued, or no items if none have been enqueued since last dequeue.
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).Enqueue Method

Grid Solutions Framework DoubleBufferedQueueTEnqueue Method
Enqueues a collection of items into the double-buffered queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Enqueue(
    IEnumerable<T> items
)
Public Sub Enqueue (
    items As IEnumerable(Of T)
)
member Enqueue :
        items : IEnumerable<'T> -> unit

function Enqueue(items);
public:
void Enqueue(
    IEnumerable<T>^ items
)

Parameters

items
Type: System.Collections.GenericIEnumerable T
The collection of items to be enqueued.
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).TryClear Method

Grid Solutions Framework DoubleBufferedQueueTTryClear Method
Attempts to enqueue a collection of items into the double-buffered queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryClear()
Public Function TryClear As Boolean
member TryClear : unit -> bool

function TryClear();
public:
bool TryClear()

Return Value

Type: Boolean
True if the items were successfully enqueued; false otherwise.
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).TryDequeue Method

Grid Solutions Framework DoubleBufferedQueueTTryDequeue Method
Attempts to dequeue a collection of items from the queue and returns the number of items left in the queue after dequeuing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TryDequeue(
    out IList<T> items
)
Public Function TryDequeue (
    <OutAttribute> ByRef items As IList(Of T)
) As Integer
member TryDequeue :
        items : IList<'T> byref -> int

function TryDequeue(items);
public:
int TryDequeue(
    [OutAttribute] IList<T>^% items
)

Parameters

items
Type: System.Collections.GenericIList T
The items that were dequeued.

Return Value

Type: Int32
The number of items left in the queue after dequeuing as many items as possible.
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).TryEnqueue Method

Grid Solutions Framework DoubleBufferedQueueTTryEnqueue Method
Attempts to enqueue a collection of items into the double-buffered queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryEnqueue(
    IEnumerable<T> items
)
Public Function TryEnqueue (
    items As IEnumerable(Of T)
) As Boolean
member TryEnqueue :
        items : IEnumerable<'T> -> bool

function TryEnqueue(items);
public:
bool TryEnqueue(
    IEnumerable<T>^ items
)

Parameters

items
Type: System.Collections.GenericIEnumerable T
The collection of items to be enqueued.

Return Value

Type: Boolean
True if the items were successfully enqueued; false otherwise.
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T) Properties

Grid Solutions Framework DoubleBufferedQueueT Properties

The DoubleBufferedQueueT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the current number of items in the queue.
Public property | ProcessItemsFunction | Gets or sets item processing function.
Top
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).Count Property

Grid Solutions Framework DoubleBufferedQueueTCount Property
Gets the current number of items in the queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
member Count : int with get

function get_Count();

public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).ProcessItemsFunction Property

Grid Solutions Framework DoubleBufferedQueueTProcessItemsFunction Property
Gets or sets item processing function.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<IList<T>> ProcessItemsFunction { get; set; }
Public Property ProcessItemsFunction As Action(Of IList(Of T))
    Get
    Set
member ProcessItemsFunction : Action<IList<'T>> with get, set

function get_ProcessItemsFunction();
function set_ProcessItemsFunction(value);
public:
property Action<IList<T>^>^ ProcessItemsFunction {
    Action<IList<T>^>^ get ();
    void set (Action<IList<T>^>^ value);
}

Property Value

Type: Action IList T
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T) Events

Grid Solutions Framework DoubleBufferedQueueT Events

The DoubleBufferedQueueT generic type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the AsyncQueueT.
Top
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueue(T).ProcessException Event

Grid Solutions Framework DoubleBufferedQueueTProcessException Event
Event that is raised if an exception is encountered while attempting to processing an item in the AsyncQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Processing will not stop for any exceptions thrown by user processing function, but exceptions will be exposed through this event.
See Also

Reference

DoubleBufferedQueueT Class
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Class

Grid Solutions Framework DoubleBufferedQueueManagerT Class
Manages queues to reduce contention for a multithreaded, multiple-producer, single-consumer scenario.
Inheritance Hierarchy
SystemObject
GSF.CollectionsDoubleBufferedQueueManagerT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DoubleBufferedQueueManager<T>

Public Class DoubleBufferedQueueManager(Of T)
type DoubleBufferedQueueManager<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class DoubleBufferedQueueManager

Type Parameters

T
The types of items to be queued.

The DoubleBufferedQueueManagerT type exposes the following members.

Constructors
 | Name | Description
Public method | DoubleBufferedQueueManagerT | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(Action) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(ActionIListT) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(Action, ActionException) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(ActionIListT, ActionException) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Top
Methods
 | Name | Description
Public method | Dequeue | Dequeues a list of items produced by the DoubleBufferedQueueProducerTs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProducer | Creates a producer used to produce items to the consumer of this DoubleBufferedQueueManagerT.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ItemsLeft | Gets a flag that indicates whether there are any items left to be consumed after the last call to Dequeue.
Top
Remarks
For best results, each thread that is producing items to the consumer should call GetProducer to receive a producer object that will not contend with any other producer. The consumer should either provide a handler to process the queued items or poll the manager by calling Dequeue (not both!). It is not safe to use this class with multiple consumer threads.
Remarks
It is not safe to use this class with multiple consumer threads. The list returned by Dequeue is not thread-safe and is reused on each Dequeue operation, so no other thread should access the list while another thread is calling Dequeue.
See Also

Reference

GSF.Collections Namespace


DoubleBufferedQueueManager(T) Constructor

Grid Solutions Framework DoubleBufferedQueueManagerT Constructor
Overload List
 | Name | Description
Public method | DoubleBufferedQueueManagerT | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(Action) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(ActionIListT) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(Action, ActionException) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Public method | DoubleBufferedQueueManagerT(ActionIListT, ActionException) | Creates a new instance of the DoubleBufferedQueueManagerT class.
Top
See Also

Reference

DoubleBufferedQueueManagerT Class
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Constructor

Grid Solutions Framework DoubleBufferedQueueManagerT Constructor
Creates a new instance of the DoubleBufferedQueueManagerT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DoubleBufferedQueueManager()
Public Sub New
new : unit -> DoubleBufferedQueueManager
GSF.Collections.DoubleBufferedQueueManager = function();
public:
DoubleBufferedQueueManager()
See Also

Reference

DoubleBufferedQueueManagerT Class
DoubleBufferedQueueManagerT Overload
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Constructor (Action)

Grid Solutions Framework DoubleBufferedQueueManagerT Constructor (Action)
Creates a new instance of the DoubleBufferedQueueManagerT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DoubleBufferedQueueManager(
    Action itemHandler
)
Public Sub New (
    itemHandler As Action
)
new :
        itemHandler : Action -> DoubleBufferedQueueManager
GSF.Collections.DoubleBufferedQueueManager = function(itemHandler);
public:
DoubleBufferedQueueManager(
    Action^ itemHandler
)

Parameters

itemHandler
Type: SystemAction
The method to handle processing of queued items.
See Also

Reference

DoubleBufferedQueueManagerT Class
DoubleBufferedQueueManagerT Overload
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Constructor (Action(IList(T)))

Grid Solutions Framework DoubleBufferedQueueManagerT Constructor (ActionIListT)
Creates a new instance of the DoubleBufferedQueueManagerT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DoubleBufferedQueueManager(
    Action<IList<T>> itemHandler
)
Public Sub New (
    itemHandler As Action(Of IList(Of T))
)
new :
        itemHandler : Action<IList<'T>> -> DoubleBufferedQueueManager
GSF.Collections.DoubleBufferedQueueManager = function(itemHandler);
public:
DoubleBufferedQueueManager(
    Action<IList<T>^>^ itemHandler
)

Parameters

itemHandler
Type: SystemAction IList T
The method to handle processing of queued items.
See Also

Reference

DoubleBufferedQueueManagerT Class
DoubleBufferedQueueManagerT Overload
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Constructor (Action, Action(Exception))

Grid Solutions Framework DoubleBufferedQueueManagerT Constructor (Action, ActionException)
Creates a new instance of the DoubleBufferedQueueManagerT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DoubleBufferedQueueManager(
    Action itemHandler,
    Action<Exception> exceptionHandler
)
Public Sub New (
    itemHandler As Action,
    exceptionHandler As Action(Of Exception)
)
new :
        itemHandler : Action *
        exceptionHandler : Action<Exception> -> DoubleBufferedQueueManager
GSF.Collections.DoubleBufferedQueueManager = function(itemHandler, exceptionHandler);
public:
DoubleBufferedQueueManager(
    Action^ itemHandler,
    Action<Exception^>^ exceptionHandler
)

Parameters

itemHandler
Type: SystemAction
The method to handle processing of queued items.
exceptionHandler
Type: SystemAction Exception
The method to handle exceptions that occur when processing items.
See Also

Reference

DoubleBufferedQueueManagerT Class
DoubleBufferedQueueManagerT Overload
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Constructor (Action(IList(T)), Action(Exception))

Grid Solutions Framework DoubleBufferedQueueManagerT Constructor (ActionIListT, ActionException)
Creates a new instance of the DoubleBufferedQueueManagerT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DoubleBufferedQueueManager(
    Action<IList<T>> itemHandler,
    Action<Exception> exceptionHandler
)
Public Sub New (
    itemHandler As Action(Of IList(Of T)),
    exceptionHandler As Action(Of Exception)
)
new :
        itemHandler : Action<IList<'T>> *
        exceptionHandler : Action<Exception> -> DoubleBufferedQueueManager
GSF.Collections.DoubleBufferedQueueManager = function(itemHandler, exceptionHandler);
public:
DoubleBufferedQueueManager(
    Action<IList<T>^>^ itemHandler,
    Action<Exception^>^ exceptionHandler
)

Parameters

itemHandler
Type: SystemAction IList T
The method to handle processing of queued items.
exceptionHandler
Type: SystemAction Exception
The method to handle exceptions that occur when processing items.
See Also

Reference

DoubleBufferedQueueManagerT Class
DoubleBufferedQueueManagerT Overload
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Methods

Grid Solutions Framework DoubleBufferedQueueManagerT Methods

The DoubleBufferedQueueManagerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dequeue | Dequeues a list of items produced by the DoubleBufferedQueueProducerTs.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetProducer | Creates a producer used to produce items to the consumer of this DoubleBufferedQueueManagerT.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DoubleBufferedQueueManagerT Class
GSF.Collections Namespace


DoubleBufferedQueueManager(T).Dequeue Method

Grid Solutions Framework DoubleBufferedQueueManagerTDequeue Method
Dequeues a list of items produced by the DoubleBufferedQueueProducerTs.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<T> Dequeue()
Public Function Dequeue As IList(Of T)
member Dequeue : unit -> IList<'T>

function Dequeue();
public:
IList<T>^ Dequeue()

Return Value

Type: IList T
A list of items to be consumed.
See Also

Reference

DoubleBufferedQueueManagerT Class
GSF.Collections Namespace


DoubleBufferedQueueManager(T).GetProducer Method

Grid Solutions Framework DoubleBufferedQueueManagerTGetProducer Method
Creates a producer used to produce items to the consumer of this DoubleBufferedQueueManagerT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DoubleBufferedQueueProducer<T> GetProducer()
Public Function GetProducer As DoubleBufferedQueueProducer(Of T)
member GetProducer : unit -> DoubleBufferedQueueProducer<'T>

function GetProducer();
public:
DoubleBufferedQueueProducer<T>^ GetProducer()

Return Value

Type: DoubleBufferedQueueProducer T
A DoubleBufferedQueueProducerT used to produce items to the consumer.
See Also

Reference

DoubleBufferedQueueManagerT Class
GSF.Collections Namespace


DoubleBufferedQueueManager(T) Properties

Grid Solutions Framework DoubleBufferedQueueManagerT Properties

The DoubleBufferedQueueManagerT generic type exposes the following members.

Properties
 | Name | Description
Public property | ItemsLeft | Gets a flag that indicates whether there are any items left to be consumed after the last call to Dequeue.
Top
See Also

Reference

DoubleBufferedQueueManagerT Class
GSF.Collections Namespace


DoubleBufferedQueueManager(T).ItemsLeft Property

Grid Solutions Framework DoubleBufferedQueueManagerTItemsLeft Property
Gets a flag that indicates whether there are any items left to be consumed after the last call to Dequeue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ItemsLeft { get; }
Public ReadOnly Property ItemsLeft As Boolean
    Get
member ItemsLeft : bool with get

function get_ItemsLeft();

public:
property bool ItemsLeft {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DoubleBufferedQueueManagerT Class
GSF.Collections Namespace


DoubleBufferedQueueProducer(T) Class

Grid Solutions Framework DoubleBufferedQueueProducerT Class
A producer for a DoubleBufferedQueueT which can only be used to provide items to the queue for consumption.
Inheritance Hierarchy
SystemObject
GSF.CollectionsDoubleBufferedQueueProducerT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DoubleBufferedQueueProducer<T> : IDisposable

Public Class DoubleBufferedQueueProducer(Of T)
    Implements IDisposable
type DoubleBufferedQueueProducer<'T> =
    class
        interface IDisposable
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class DoubleBufferedQueueProducer : IDisposable

Type Parameters

T
The type of the items produced to the queue.

The DoubleBufferedQueueProducerT type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the DoubleBufferedQueueProducerT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DoubleBufferedQueueProducerT object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the DoubleBufferedQueueProducerT object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Produce | Produces a collection of items to be processed by the consumer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.Collections Namespace


DoubleBufferedQueueProducer(T) Methods

Grid Solutions Framework DoubleBufferedQueueProducerT Methods

The DoubleBufferedQueueProducerT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the DoubleBufferedQueueProducerT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DoubleBufferedQueueProducerT object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the DoubleBufferedQueueProducerT object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Produce | Produces a collection of items to be processed by the consumer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DoubleBufferedQueueProducerT Class
GSF.Collections Namespace


DoubleBufferedQueueProducer(T).Dispose Method

Grid Solutions Framework DoubleBufferedQueueProducerTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the DoubleBufferedQueueProducerT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DoubleBufferedQueueProducerT object and optionally releases the managed resources.
Top
See Also

Reference

DoubleBufferedQueueProducerT Class
GSF.Collections Namespace


DoubleBufferedQueueProducer(T).Dispose Method

Grid Solutions Framework DoubleBufferedQueueProducerTDispose Method
Releases all the resources used by the DoubleBufferedQueueProducerT object.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

DoubleBufferedQueueProducerT Class
Dispose Overload
GSF.Collections Namespace


DoubleBufferedQueueProducer(T).Dispose Method (Boolean)

Grid Solutions Framework DoubleBufferedQueueProducerTDispose Method (Boolean)
Releases the unmanaged resources used by the DoubleBufferedQueueProducerT object and optionally releases the managed resources.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

DoubleBufferedQueueProducerT Class
Dispose Overload
GSF.Collections Namespace


DoubleBufferedQueueProducer(T).Finalize Method

Grid Solutions Framework DoubleBufferedQueueProducerTFinalize Method
Releases the unmanaged resources before the DoubleBufferedQueueProducerT object is reclaimed by GC.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

DoubleBufferedQueueProducerT Class
GSF.Collections Namespace


DoubleBufferedQueueProducer(T).Produce Method

Grid Solutions Framework DoubleBufferedQueueProducerTProduce Method
Produces a collection of items to be processed by the consumer.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Produce(
    IEnumerable<T> items
)
Public Sub Produce (
    items As IEnumerable(Of T)
)
member Produce :
        items : IEnumerable<'T> -> unit

function Produce(items);
public:
void Produce(
    IEnumerable<T>^ items
)

Parameters

items
Type: System.Collections.GenericIEnumerable T
The collection of items to be enqueued.
See Also

Reference

DoubleBufferedQueueProducerT Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Class

Grid Solutions Framework FileBackedDictionaryTKey, TValue Class
Represents a lookup table of key/value pairs backed by a file, with very little memory overhead.
Inheritance Hierarchy
SystemObject
GSF.CollectionsFileBackedDictionaryTKey, TValue

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FileBackedDictionary<TKey, TValue> : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable, IDisposable

Public Class FileBackedDictionary(Of TKey, TValue)
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable,
    IDisposable
type FileBackedDictionary<'TKey, 'TValue> =
    class
        interface IDictionary<'TKey, 'TValue>
        interface ICollection<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable
        interface IDisposable
    end
JavaScript does not support generic types or methods.
generic<typename TKey, typename TValue>
public ref class FileBackedDictionary : IDictionary<TKey, TValue>,
    ICollection<KeyValuePair<TKey, TValue>>, IEnumerable<KeyValuePair<TKey, TValue>>,
    IEnumerable, IDisposable

Type Parameters

TKey
The type of the keys in the lookup table.
TValue
The type of the values in the lookup table.

The FileBackedDictionaryTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | FileBackedDictionaryTKey, TValue | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(IDictionaryTKey, TValue) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(IDictionaryTKey, TValue, IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String, IDictionaryTKey, TValue) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String, IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String, IDictionaryTKey, TValue, IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Top
Methods
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the FileBackedDictionaryTKey, TValue.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the FileBackedDictionaryTKey, TValue.
Public method | Clear | Removes all items from the FileBackedDictionaryTKey, TValue.
Public method | Close | Closes the file backing this dictionary.
Public method | Compact | Defragments the item section of the dictionary, which gets fragmented after removing keys or updating values.
Public method | Contains | Determines whether the FileBackedDictionaryTKey, TValue contains a specific value.
Public method | ContainsKey | Determines whether the FileBackedDictionaryTKey, TValue contains an element with the specified key.
Public method | CopyTo | Copies the elements of the FileBackedDictionaryTKey, TValue to an Array, starting at a particular Array index.
Public method | Dispose | Releases all the resources used by the FileBackedDictionaryTKey, TValue object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileBackedDictionaryTKey, TValue object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Gets an enumerable used to iterate only the keys in the dictionary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Gets an enumerable used to iterate only the values in the dictionary.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the file backing this dictionary.
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the FileBackedDictionaryTKey, TValue.
Public method | Remove(TKey) | Removes the element with the specified key from the FileBackedDictionaryTKey, TValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByKeyValuePairTKey, TValue, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairTKey, TValue, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairTKey, TValue, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | CacheSize | Gets or sets the size of the cache used to store data from the file in memory.
Public property | Count | Gets the number of elements contained in the FileBackedDictionaryTKey, TValue.
Public property | DefaultSignature | Gets the default signature used by the FileBackedDictionaryTKey, TValue if no user-defined signature is supplied.
Public property | FilePath | Gets or sets the path to the file backing this dictionary.
Public property | IsReadOnly | Gets a value indicating whether the FileBackedDictionaryTKey, TValue is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an FileBackedDictionaryTKey, TValue containing the keys of the FileBackedDictionaryTKey, TValue.
Public property | Signature | Gets or sets the signature of the file backing the lookup table.
Public property | Values | Gets an FileBackedDictionaryTKey, TValue containing the values in the FileBackedDictionaryTKey, TValue.
Top
See Also

Reference

GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor
Overload List
 | Name | Description
Public method | FileBackedDictionaryTKey, TValue | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(IDictionaryTKey, TValue) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(IDictionaryTKey, TValue, IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String, IDictionaryTKey, TValue) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String, IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Public method | FileBackedDictionaryTKey, TValue(String, IDictionaryTKey, TValue, IEqualityComparerTKey) | Creates a new instance of the FileBackedDictionaryTKey, TValue class.
Top
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary()
Public Sub New
new : unit -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function();
public:
FileBackedDictionary()
Exceptions
Exception | Condition
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor (IDictionary(TKey, TValue))

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor (IDictionaryTKey, TValue)
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary(
    IDictionary<TKey, TValue> dictionary
)
Public Sub New (
    dictionary As IDictionary(Of TKey, TValue)
)
new :
        dictionary : IDictionary<'TKey, 'TValue> -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function(dictionary);
public:
FileBackedDictionary(
    IDictionary<TKey, TValue>^ dictionary
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary whose elements are copied to this dictionary.
Exceptions
Exception | Condition
ArgumentNullException | dictionary is null.
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor (IEqualityComparer(TKey))

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor (IEqualityComparerTKey)
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary(
    IEqualityComparer<TKey> keyComparer
)
Public Sub New (
    keyComparer As IEqualityComparer(Of TKey)
)
new :
        keyComparer : IEqualityComparer<'TKey> -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function(keyComparer);
public:
FileBackedDictionary(
    IEqualityComparer<TKey>^ keyComparer
)

Parameters

keyComparer
Type: System.Collections.GenericIEqualityComparer TKey
The equality comparer used to compare keys in the dictionary.
Exceptions
Exception | Condition
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor (String)

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor (String)
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary(
    string filePath
)
Public Sub New (
    filePath As String
)
new :
        filePath : string -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function(filePath);
public:
FileBackedDictionary(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null.
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor (IDictionary(TKey, TValue), IEqualityComparer(TKey))

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor (IDictionaryTKey, TValue, IEqualityComparerTKey)
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary(
    IDictionary<TKey, TValue> dictionary,
    IEqualityComparer<TKey> keyComparer
)
Public Sub New (
    dictionary As IDictionary(Of TKey, TValue),
    keyComparer As IEqualityComparer(Of TKey)
)
new :
        dictionary : IDictionary<'TKey, 'TValue> *
        keyComparer : IEqualityComparer<'TKey> -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function(dictionary, keyComparer);
public:
FileBackedDictionary(
    IDictionary<TKey, TValue>^ dictionary,
    IEqualityComparer<TKey>^ keyComparer
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary whose elements are copied to this dictionary.
keyComparer
Type: System.Collections.GenericIEqualityComparer TKey
The equality comparer used to compare keys in the dictionary.
Exceptions
Exception | Condition
ArgumentNullException | dictionary is null.
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor (String, IDictionary(TKey, TValue))

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor (String, IDictionaryTKey, TValue)
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary(
    string filePath,
    IDictionary<TKey, TValue> dictionary
)
Public Sub New (
    filePath As String,
    dictionary As IDictionary(Of TKey, TValue)
)
new :
        filePath : string *
        dictionary : IDictionary<'TKey, 'TValue> -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function(filePath, dictionary);
public:
FileBackedDictionary(
    String^ filePath,
    IDictionary<TKey, TValue>^ dictionary
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary whose elements are copied to this dictionary.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null or dictionary is null.
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor (String, IEqualityComparer(TKey))

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor (String, IEqualityComparerTKey)
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary(
    string filePath,
    IEqualityComparer<TKey> keyComparer
)
Public Sub New (
    filePath As String,
    keyComparer As IEqualityComparer(Of TKey)
)
new :
        filePath : string *
        keyComparer : IEqualityComparer<'TKey> -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function(filePath, keyComparer);
public:
FileBackedDictionary(
    String^ filePath,
    IEqualityComparer<TKey>^ keyComparer
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
keyComparer
Type: System.Collections.GenericIEqualityComparer TKey
The equality comparer used to compare keys in the dictionary.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null.
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Constructor (String, IDictionary(TKey, TValue), IEqualityComparer(TKey))

Grid Solutions Framework FileBackedDictionaryTKey, TValue Constructor (String, IDictionaryTKey, TValue, IEqualityComparerTKey)
Creates a new instance of the FileBackedDictionaryTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedDictionary(
    string filePath,
    IDictionary<TKey, TValue> dictionary,
    IEqualityComparer<TKey> keyComparer
)
Public Sub New (
    filePath As String,
    dictionary As IDictionary(Of TKey, TValue),
    keyComparer As IEqualityComparer(Of TKey)
)
new :
        filePath : string *
        dictionary : IDictionary<'TKey, 'TValue> *
        keyComparer : IEqualityComparer<'TKey> -> FileBackedDictionary
GSF.Collections.FileBackedDictionary = function(filePath, dictionary, keyComparer);
public:
FileBackedDictionary(
    String^ filePath,
    IDictionary<TKey, TValue>^ dictionary,
    IEqualityComparer<TKey>^ keyComparer
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
dictionary
Type: System.Collections.GenericIDictionary TKey, TValue
The dictionary whose elements are copied to this dictionary.
keyComparer
Type: System.Collections.GenericIEqualityComparer TKey
The equality comparer used to compare keys in the dictionary.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null or dictionary is null.
InvalidOperationException | Either TKey or TValue cannot be serialized.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
FileBackedDictionaryTKey, TValue Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Methods

Grid Solutions Framework FileBackedDictionaryTKey, TValue Methods

The FileBackedDictionaryTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the FileBackedDictionaryTKey, TValue.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the FileBackedDictionaryTKey, TValue.
Public method | Clear | Removes all items from the FileBackedDictionaryTKey, TValue.
Public method | Close | Closes the file backing this dictionary.
Public method | Compact | Defragments the item section of the dictionary, which gets fragmented after removing keys or updating values.
Public method | Contains | Determines whether the FileBackedDictionaryTKey, TValue contains a specific value.
Public method | ContainsKey | Determines whether the FileBackedDictionaryTKey, TValue contains an element with the specified key.
Public method | CopyTo | Copies the elements of the FileBackedDictionaryTKey, TValue to an Array, starting at a particular Array index.
Public method | Dispose | Releases all the resources used by the FileBackedDictionaryTKey, TValue object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileBackedDictionaryTKey, TValue object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeys | Gets an enumerable used to iterate only the keys in the dictionary.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValues | Gets an enumerable used to iterate only the values in the dictionary.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the file backing this dictionary.
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the FileBackedDictionaryTKey, TValue.
Public method | Remove(TKey) | Removes the element with the specified key from the FileBackedDictionaryTKey, TValue.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetValue | Gets the value associated with the specified key.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByKeyValuePairTKey, TValue, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairTKey, TValue, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairTKey, TValue, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Add Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueAdd Method
Overload List
 | Name | Description
Public method | Add(KeyValuePairTKey, TValue) | Adds an item to the FileBackedDictionaryTKey, TValue.
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the FileBackedDictionaryTKey, TValue.
Top
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Add Method (KeyValuePair(TKey, TValue))

Grid Solutions Framework FileBackedDictionaryTKey, TValueAdd Method (KeyValuePairTKey, TValue)
Adds an item to the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    KeyValuePair<TKey, TValue> item
)
Public Sub Add (
    item As KeyValuePair(Of TKey, TValue)
)
abstract Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit
override Add :
        item : KeyValuePair<'TKey, 'TValue> -> unit
function Add(item);
public:
virtual void Add(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to add to the FileBackedDictionaryTKey, TValue.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The FileBackedDictionaryTKey, TValue is read-only.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
Add Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Add Method (TKey, TValue)

Grid Solutions Framework FileBackedDictionaryTKey, TValueAdd Method (TKey, TValue)
Adds an element with the provided key and value to the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)
abstract Add :
        key : 'TKey *
        value : 'TValue -> unit
override Add :
        key : 'TKey *
        value : 'TValue -> unit
function Add(key, value);
public:
virtual void Add(
    TKey key,
    TValue value
) sealed

Parameters

key
Type: TKey
The object to use as the key of the element to add.
value
Type: TValue
The object to use as the value of the element to add.

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
ArgumentException | An element with the same key already exists in the FileBackedDictionaryTKey, TValue.
NotSupportedException | The FileBackedDictionaryTKey, TValue is read-only.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
Add Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Clear Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueClear Method
Removes all items from the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
abstract Clear : unit -> unit
override Clear : unit -> unit
function Clear();
public:
virtual void Clear() sealed

Implements

ICollectionTClear
Exceptions
Exception | Condition
NotSupportedException | The FileBackedDictionaryTKey, TValue is read-only.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Close Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueClose Method
Closes the file backing this dictionary.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Compact Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueCompact Method
Defragments the item section of the dictionary, which gets fragmented after removing keys or updating values.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Compact()
Public Sub Compact
member Compact : unit -> unit

function Compact();
public:
void Compact()
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Contains Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueContains Method
Determines whether the FileBackedDictionaryTKey, TValue contains a specific value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Contains(
    KeyValuePair<TKey, TValue> item
)
Public Function Contains (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
abstract Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Contains :
        item : KeyValuePair<'TKey, 'TValue> -> bool
function Contains(item);
public:
virtual bool Contains(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the FileBackedDictionaryTKey, TValue.

Return Value

Type: Boolean
true if item is found in the FileBackedDictionaryTKey, TValue; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).ContainsKey Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueContainsKey Method
Determines whether the FileBackedDictionaryTKey, TValue contains an element with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey (
    key As TKey
) As Boolean
abstract ContainsKey :
        key : 'TKey -> bool
override ContainsKey :
        key : 'TKey -> bool
function ContainsKey(key);
public:
virtual bool ContainsKey(
    TKey key
) sealed

Parameters

key
Type: TKey
The key to locate in the FileBackedDictionaryTKey, TValue.

Return Value

Type: Boolean
true if the FileBackedDictionaryTKey, TValue contains an element with the key; otherwise, false.

Implements

IDictionaryTKey, TValueContainsKey(TKey)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).CopyTo Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueCopyTo Method
Copies the elements of the FileBackedDictionaryTKey, TValue to an Array, starting at a particular Array index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CopyTo(
    KeyValuePair<TKey, TValue>[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As KeyValuePair(Of TKey, TValue)(),
    arrayIndex As Integer
)
abstract CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit
override CopyTo :
        array : KeyValuePair<'TKey, 'TValue>[] *
        arrayIndex : int -> unit
function CopyTo(array, arrayIndex);
public:
virtual void CopyTo(
    array<KeyValuePair<TKey, TValue>>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: System.Collections.GenericKeyValuePair TKey, TValue
The one-dimensional Array that is the destination of the elements copied from FileBackedDictionaryTKey, TValue. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source FileBackedDictionaryTKey, TValue is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Dispose Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the FileBackedDictionaryTKey, TValue object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileBackedDictionaryTKey, TValue object and optionally releases the managed resources.
Top
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Dispose Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueDispose Method
Releases all the resources used by the FileBackedDictionaryTKey, TValue object.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

FileBackedDictionaryTKey, TValue Class
Dispose Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Dispose Method (Boolean)

Grid Solutions Framework FileBackedDictionaryTKey, TValueDispose Method (Boolean)
Releases the unmanaged resources used by the FileBackedDictionaryTKey, TValue object and optionally releases the managed resources.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
Dispose Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).GetEnumerator Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerator<KeyValuePair<TKey, TValue>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of TKey, TValue))
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<'TKey, 'TValue>>
function GetEnumerator();
public:
virtual IEnumerator<KeyValuePair<TKey, TValue>>^ GetEnumerator() sealed

Return Value

Type: IEnumerator KeyValuePair TKey, TValue
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).GetKeys Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueGetKeys Method
Gets an enumerable used to iterate only the keys in the dictionary.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<TKey> GetKeys()
Public Function GetKeys As IEnumerable(Of TKey)
member GetKeys : unit -> IEnumerable<'TKey>

function GetKeys();
public:
IEnumerable<TKey>^ GetKeys()

Return Value

Type: IEnumerable TKey
An enumerable used to iterate only the keys in the dictionary.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).GetValues Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueGetValues Method
Gets an enumerable used to iterate only the values in the dictionary.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<TValue> GetValues()
Public Function GetValues As IEnumerable(Of TValue)
member GetValues : unit -> IEnumerable<'TValue>

function GetValues();
public:
IEnumerable<TValue>^ GetValues()

Return Value

Type: IEnumerable TValue
An enumerable used to iterate only the values in the dictionary.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Open Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueOpen Method
Opens the file backing this dictionary.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open()
Public Sub Open
member Open : unit -> unit

function Open();
public:
void Open()
Exceptions
Exception | Condition
InvalidOperationException | File is already open.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Remove Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueRemove Method
Overload List
 | Name | Description
Public method | Remove(KeyValuePairTKey, TValue) | Removes the first occurrence of a specific object from the FileBackedDictionaryTKey, TValue.
Public method | Remove(TKey) | Removes the element with the specified key from the FileBackedDictionaryTKey, TValue.
Top
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Remove Method (KeyValuePair(TKey, TValue))

Grid Solutions Framework FileBackedDictionaryTKey, TValueRemove Method (KeyValuePairTKey, TValue)
Removes the first occurrence of a specific object from the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    KeyValuePair<TKey, TValue> item
)
Public Function Remove (
    item As KeyValuePair(Of TKey, TValue)
) As Boolean
abstract Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool
override Remove :
        item : KeyValuePair<'TKey, 'TValue> -> bool
function Remove(item);
public:
virtual bool Remove(
    KeyValuePair<TKey, TValue> item
) sealed

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to remove from the FileBackedDictionaryTKey, TValue.

Return Value

Type: Boolean
true if item was successfully removed from the FileBackedDictionaryTKey, TValue; otherwise, false. This method also returns false if item is not found in the original FileBackedDictionaryTKey, TValue.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The FileBackedDictionaryTKey, TValue is read-only.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
Remove Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Remove Method (TKey)

Grid Solutions Framework FileBackedDictionaryTKey, TValueRemove Method (TKey)
Removes the element with the specified key from the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    TKey key
)
Public Function Remove (
    key As TKey
) As Boolean
abstract Remove :
        key : 'TKey -> bool
override Remove :
        key : 'TKey -> bool
function Remove(key);
public:
virtual bool Remove(
    TKey key
) sealed

Parameters

key
Type: TKey
The key of the element to remove.

Return Value

Type: Boolean
true if the element is successfully removed; otherwise, false. This method also returns false if key was not found in the original FileBackedDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueRemove(TKey)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
NotSupportedException | The FileBackedDictionaryTKey, TValue is read-only.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
Remove Overload
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).TryGetValue Method

Grid Solutions Framework FileBackedDictionaryTKey, TValueTryGetValue Method
Gets the value associated with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue (
    key As TKey,
    <OutAttribute> ByRef value As TValue
) As Boolean
abstract TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
override TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
function TryGetValue(key, value);
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed

Parameters

key
Type: TKey
The key whose value to get.
value
Type: TValue
When this method returns, the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if the object that implements FileBackedDictionaryTKey, TValue contains an element with the specified key; otherwise, false.

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue) Properties

Grid Solutions Framework FileBackedDictionaryTKey, TValue Properties

The FileBackedDictionaryTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | CacheSize | Gets or sets the size of the cache used to store data from the file in memory.
Public property | Count | Gets the number of elements contained in the FileBackedDictionaryTKey, TValue.
Public property | DefaultSignature | Gets the default signature used by the FileBackedDictionaryTKey, TValue if no user-defined signature is supplied.
Public property | FilePath | Gets or sets the path to the file backing this dictionary.
Public property | IsReadOnly | Gets a value indicating whether the FileBackedDictionaryTKey, TValue is read-only.
Public property | Item | Gets or sets the element with the specified key.
Public property | Keys | Gets an FileBackedDictionaryTKey, TValue containing the keys of the FileBackedDictionaryTKey, TValue.
Public property | Signature | Gets or sets the signature of the file backing the lookup table.
Public property | Values | Gets an FileBackedDictionaryTKey, TValue containing the values in the FileBackedDictionaryTKey, TValue.
Top
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).CacheSize Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueCacheSize Property
Gets or sets the size of the cache used to store data from the file in memory.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long CacheSize { get; set; }
Public Property CacheSize As Long
    Get
    Set
member CacheSize : int64 with get, set

function get_CacheSize();
function set_CacheSize(value);
public:
property long long CacheSize {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Count Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueCount Property
Gets the number of elements contained in the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get () sealed;
}

Return Value

Type: Int32
The number of elements contained in the FileBackedDictionaryTKey, TValue.

Implements

ICollectionTCount
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).DefaultSignature Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueDefaultSignature Property
Gets the default signature used by the FileBackedDictionaryTKey, TValue if no user-defined signature is supplied.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] DefaultSignature { get; }
Public ReadOnly Property DefaultSignature As Byte()
    Get
member DefaultSignature : byte[] with get

function get_DefaultSignature();

public:
property array<unsigned char>^ DefaultSignature {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).FilePath Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueFilePath Property
Gets or sets the path to the file backing this dictionary.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
member FilePath : string with get, set

function get_FilePath();
function set_FilePath(value);
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentException | FilePath is set and is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
Remarks
Changes to this property will cause the file to close if the file is already opened. Data will not be automatically written from the old file to the new file.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).IsReadOnly Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueIsReadOnly Property
Gets a value indicating whether the FileBackedDictionaryTKey, TValue is read-only.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
function get_IsReadOnly();

public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Return Value

Type: Boolean
true if the FileBackedDictionaryTKey, TValue is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Item Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueItem Property
Gets or sets the element with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set
abstract Item : 'TValue with get, set
override Item : 'TValue with get, set
function get_Item(key);
function set_Item(value);
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}

Parameters

key
Type: TKey
The key of the element to get or set.

Return Value

Type: TValue
The element with the specified key.

Implements

IDictionaryTKey, TValueItemTKey
Exceptions
Exception | Condition
ArgumentNullException | key is null.
KeyNotFoundException | The property is retrieved and key is not found.
NotSupportedException | The property is set and the FileBackedDictionaryTKey, TValue is read-only.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Keys Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueKeys Property
Gets an FileBackedDictionaryTKey, TValue containing the keys of the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
abstract Keys : ICollection<'TKey> with get
override Keys : ICollection<'TKey> with get
function get_Keys();

public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}

Return Value

Type: ICollection TKey
An FileBackedDictionaryTKey, TValue containing the keys of the object that implements FileBackedDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Signature Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueSignature Property
Gets or sets the signature of the file backing the lookup table.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Signature { get; set; }
Public Property Signature As Byte()
    Get
    Set
member Signature : byte[] with get, set

function get_Signature();
function set_Signature(value);
public:
property array<unsigned char>^ Signature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | Attempt is made to set Signature to a null value.
ArgumentException | Attempt is made to set Signature to a value larger than the maximum allowed size.
NotSupportedException | Attempt is made to modify Signature of a read-only lookup table.
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedDictionary(TKey, TValue).Values Property

Grid Solutions Framework FileBackedDictionaryTKey, TValueValues Property
Gets an FileBackedDictionaryTKey, TValue containing the values in the FileBackedDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
abstract Values : ICollection<'TValue> with get
override Values : ICollection<'TValue> with get
function get_Values();

public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}

Return Value

Type: ICollection TValue
An FileBackedDictionaryTKey, TValue containing the values in the object that implements FileBackedDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueValues
See Also

Reference

FileBackedDictionaryTKey, TValue Class
GSF.Collections Namespace


FileBackedHashSet(T) Class

Grid Solutions Framework FileBackedHashSetT Class
Represents a lookup table backed by a file, with very little memory overhead.
Inheritance Hierarchy
SystemObject
GSF.CollectionsFileBackedHashSetT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FileBackedHashSet<T> : ISet<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, IDisposable

Public Class FileBackedHashSet(Of T)
    Implements ISet(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable, IDisposable
type FileBackedHashSet<'T> =
    class
        interface ISet<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
        interface IDisposable
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class FileBackedHashSet : ISet<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, IDisposable

Type Parameters

T
The type of the items in the lookup table.

The FileBackedHashSetT type exposes the following members.

Constructors
 | Name | Description
Public method | FileBackedHashSetT | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(IEnumerableT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(IEnumerableT, IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String, IEnumerableT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String, IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String, IEnumerableT, IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Top
Methods
 | Name | Description
Public method | Add | Adds an element to the current set and returns a value to indicate if the element was successfully added.
Public method | Clear | Removes all items from the FileBackedHashSetT.
Public method | Close | Closes the file backing this hash set.
Public method | Compact | Defragments the item section of the hash set, which gets fragmented after removing items.
Public method | Contains | Determines whether the FileBackedHashSetT contains a specific value.
Public method | CopyTo | Copies the elements of the FileBackedHashSetT to an Array, starting at a particular Array index.
Public method | Dispose | Releases all the resources used by the FileBackedHashSetT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileBackedHashSetT object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExceptWith | Removes all elements in the specified collection from the current set.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Modifies the current set so that it contains only elements that are also in a specified collection.
Public method | IsProperSubsetOf | Determines whether the current set is a proper (strict) subset of a specified collection.
Public method | IsProperSupersetOf | Determines whether the current set is a proper (strict) superset of a specified collection.
Public method | IsSubsetOf | Determines whether a set is a subset of a specified collection.
Public method | IsSupersetOf | Determines whether the current set is a superset of a specified collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the file backing this hash set.
Public method | Overlaps | Determines whether the current set overlaps with the specified collection.
Public method | Remove | Removes the first occurrence of a specific object from the FileBackedHashSetT.
Public method | RemoveWhere | Removes all elements that match the conditions defined by the specified predicate from a FileBackedHashSetT collection.
Public method | SetEquals | Determines whether the current set and the specified collection contain the same elements.
Public method | SymmetricExceptWith | Modifies the current set so that it contains only elements that are present either in the current set or in the specified collection, but not both.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnionWith | Modifies the current set so that it contains all elements that are present in either the current set or the specified collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | CacheSize | Gets or sets the size of the cache used to store data from the file in memory.
Public property | Count | Gets the number of elements contained in the FileBackedHashSetT.
Public property | DefaultSignature | Gets the default signature used by the FileBackedHashSetT if no user-defined signature is supplied.
Public property | FilePath | Gets or sets the path to the file backing this hash set.
Public property | IsReadOnly | Gets a value indicating whether the FileBackedHashSetT is read-only.
Public property | Signature | Gets or sets the signature of the file backing the lookup table.
Top
See Also

Reference

GSF.Collections Namespace


FileBackedHashSet(T) Constructor

Grid Solutions Framework FileBackedHashSetT Constructor
Overload List
 | Name | Description
Public method | FileBackedHashSetT | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(IEnumerableT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(IEnumerableT, IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String, IEnumerableT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String, IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Public method | FileBackedHashSetT(String, IEnumerableT, IEqualityComparerT) | Creates a new instance of the FileBackedHashSetT class.
Top
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T) Constructor

Grid Solutions Framework FileBackedHashSetT Constructor
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet()
Public Sub New
new : unit -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function();
public:
FileBackedHashSet()
Exceptions
Exception | Condition
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Constructor (IEnumerable(T))

Grid Solutions Framework FileBackedHashSetT Constructor (IEnumerableT)
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet(
    IEnumerable<T> enumerable
)
Public Sub New (
    enumerable As IEnumerable(Of T)
)
new :
        enumerable : IEnumerable<'T> -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function(enumerable);
public:
FileBackedHashSet(
    IEnumerable<T>^ enumerable
)

Parameters

enumerable
Type: System.Collections.GenericIEnumerable T
The enumerable whose elements are copied to this hash set.
Exceptions
Exception | Condition
ArgumentNullException | enumerable is null.
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Constructor (IEqualityComparer(T))

Grid Solutions Framework FileBackedHashSetT Constructor (IEqualityComparerT)
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet(
    IEqualityComparer<T> comparer
)
Public Sub New (
    comparer As IEqualityComparer(Of T)
)
new :
        comparer : IEqualityComparer<'T> -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function(comparer);
public:
FileBackedHashSet(
    IEqualityComparer<T>^ comparer
)

Parameters

comparer
Type: System.Collections.GenericIEqualityComparer T
The equality comparer used to compare items in the hash set.
Exceptions
Exception | Condition
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Constructor (String)

Grid Solutions Framework FileBackedHashSetT Constructor (String)
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet(
    string filePath
)
Public Sub New (
    filePath As String
)
new :
        filePath : string -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function(filePath);
public:
FileBackedHashSet(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null.
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Constructor (IEnumerable(T), IEqualityComparer(T))

Grid Solutions Framework FileBackedHashSetT Constructor (IEnumerableT, IEqualityComparerT)
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet(
    IEnumerable<T> enumerable,
    IEqualityComparer<T> comparer
)
Public Sub New (
    enumerable As IEnumerable(Of T),
    comparer As IEqualityComparer(Of T)
)
new :
        enumerable : IEnumerable<'T> *
        comparer : IEqualityComparer<'T> -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function(enumerable, comparer);
public:
FileBackedHashSet(
    IEnumerable<T>^ enumerable,
    IEqualityComparer<T>^ comparer
)

Parameters

enumerable
Type: System.Collections.GenericIEnumerable T
The enumerable whose elements are copied to this hash set.
comparer
Type: System.Collections.GenericIEqualityComparer T
The equality comparer used to compare items in the hash set.
Exceptions
Exception | Condition
ArgumentNullException | enumerable is null.
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Constructor (String, IEnumerable(T))

Grid Solutions Framework FileBackedHashSetT Constructor (String, IEnumerableT)
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet(
    string filePath,
    IEnumerable<T> enumerable
)
Public Sub New (
    filePath As String,
    enumerable As IEnumerable(Of T)
)
new :
        filePath : string *
        enumerable : IEnumerable<'T> -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function(filePath, enumerable);
public:
FileBackedHashSet(
    String^ filePath,
    IEnumerable<T>^ enumerable
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
enumerable
Type: System.Collections.GenericIEnumerable T
The enumerable whose elements are copied to this hash set.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null or enumerable is null.
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Constructor (String, IEqualityComparer(T))

Grid Solutions Framework FileBackedHashSetT Constructor (String, IEqualityComparerT)
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet(
    string filePath,
    IEqualityComparer<T> comparer
)
Public Sub New (
    filePath As String,
    comparer As IEqualityComparer(Of T)
)
new :
        filePath : string *
        comparer : IEqualityComparer<'T> -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function(filePath, comparer);
public:
FileBackedHashSet(
    String^ filePath,
    IEqualityComparer<T>^ comparer
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
comparer
Type: System.Collections.GenericIEqualityComparer T
The equality comparer used to compare items in the hash set.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null.
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Constructor (String, IEnumerable(T), IEqualityComparer(T))

Grid Solutions Framework FileBackedHashSetT Constructor (String, IEnumerableT, IEqualityComparerT)
Creates a new instance of the FileBackedHashSetT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileBackedHashSet(
    string filePath,
    IEnumerable<T> enumerable,
    IEqualityComparer<T> comparer
)
Public Sub New (
    filePath As String,
    enumerable As IEnumerable(Of T),
    comparer As IEqualityComparer(Of T)
)
new :
        filePath : string *
        enumerable : IEnumerable<'T> *
        comparer : IEqualityComparer<'T> -> FileBackedHashSet
GSF.Collections.FileBackedHashSet = function(filePath, enumerable, comparer);
public:
FileBackedHashSet(
    String^ filePath,
    IEnumerable<T>^ enumerable,
    IEqualityComparer<T>^ comparer
)

Parameters

filePath
Type: SystemString
The path to the file used to store the lookup table.
enumerable
Type: System.Collections.GenericIEnumerable T
The enumerable whose elements are copied to this hash set.
comparer
Type: System.Collections.GenericIEqualityComparer T
The equality comparer used to compare items in the hash set.
Exceptions
Exception | Condition
ArgumentException | filePath is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
ArgumentNullException | filePath is null or enumerable is null.
InvalidOperationException | T cannot be serialized.
See Also

Reference

FileBackedHashSetT Class
FileBackedHashSetT Overload
GSF.Collections Namespace


FileBackedHashSet(T) Methods

Grid Solutions Framework FileBackedHashSetT Methods

The FileBackedHashSetT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an element to the current set and returns a value to indicate if the element was successfully added.
Public method | Clear | Removes all items from the FileBackedHashSetT.
Public method | Close | Closes the file backing this hash set.
Public method | Compact | Defragments the item section of the hash set, which gets fragmented after removing items.
Public method | Contains | Determines whether the FileBackedHashSetT contains a specific value.
Public method | CopyTo | Copies the elements of the FileBackedHashSetT to an Array, starting at a particular Array index.
Public method | Dispose | Releases all the resources used by the FileBackedHashSetT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileBackedHashSetT object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExceptWith | Removes all elements in the specified collection from the current set.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IntersectWith | Modifies the current set so that it contains only elements that are also in a specified collection.
Public method | IsProperSubsetOf | Determines whether the current set is a proper (strict) subset of a specified collection.
Public method | IsProperSupersetOf | Determines whether the current set is a proper (strict) superset of a specified collection.
Public method | IsSubsetOf | Determines whether a set is a subset of a specified collection.
Public method | IsSupersetOf | Determines whether the current set is a superset of a specified collection.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the file backing this hash set.
Public method | Overlaps | Determines whether the current set overlaps with the specified collection.
Public method | Remove | Removes the first occurrence of a specific object from the FileBackedHashSetT.
Public method | RemoveWhere | Removes all elements that match the conditions defined by the specified predicate from a FileBackedHashSetT collection.
Public method | SetEquals | Determines whether the current set and the specified collection contain the same elements.
Public method | SymmetricExceptWith | Modifies the current set so that it contains only elements that are present either in the current set or in the specified collection, but not both.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnionWith | Modifies the current set so that it contains all elements that are present in either the current set or the specified collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Add Method

Grid Solutions Framework FileBackedHashSetTAdd Method
Adds an element to the current set and returns a value to indicate if the element was successfully added.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Add(
    T item
)
Public Function Add (
    item As T
) As Boolean
abstract Add :
        item : 'T -> bool
override Add :
        item : 'T -> bool
function Add(item);
public:
virtual bool Add(
    T item
) sealed

Parameters

item
Type: T
The element to add to the set.

Return Value

Type: Boolean
true if the element is added to the set; false if the element is already in the set.

Implements

ISetTAdd(T)
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Clear Method

Grid Solutions Framework FileBackedHashSetTClear Method
Removes all items from the FileBackedHashSetT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
abstract Clear : unit -> unit
override Clear : unit -> unit
function Clear();
public:
virtual void Clear() sealed

Implements

ICollectionTClear
Exceptions
Exception | Condition
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Close Method

Grid Solutions Framework FileBackedHashSetTClose Method
Closes the file backing this hash set.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Compact Method

Grid Solutions Framework FileBackedHashSetTCompact Method
Defragments the item section of the hash set, which gets fragmented after removing items.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Compact()
Public Sub Compact
member Compact : unit -> unit

function Compact();
public:
void Compact()
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Contains Method

Grid Solutions Framework FileBackedHashSetTContains Method
Determines whether the FileBackedHashSetT contains a specific value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool
function Contains(item);
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T
The object to locate in the FileBackedHashSetT.

Return Value

Type: Boolean
true if item is found in the FileBackedHashSetT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).CopyTo Method

Grid Solutions Framework FileBackedHashSetTCopyTo Method
Copies the elements of the FileBackedHashSetT to an Array, starting at a particular Array index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
function CopyTo(array, arrayIndex);
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from FileBackedHashSetT. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source FileBackedHashSetT is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Dispose Method

Grid Solutions Framework FileBackedHashSetTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the FileBackedHashSetT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileBackedHashSetT object and optionally releases the managed resources.
Top
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Dispose Method

Grid Solutions Framework FileBackedHashSetTDispose Method
Releases all the resources used by the FileBackedHashSetT object.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

FileBackedHashSetT Class
Dispose Overload
GSF.Collections Namespace


FileBackedHashSet(T).Dispose Method (Boolean)

Grid Solutions Framework FileBackedHashSetTDispose Method (Boolean)
Releases the unmanaged resources used by the FileBackedHashSetT object and optionally releases the managed resources.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FileBackedHashSetT Class
Dispose Overload
GSF.Collections Namespace


FileBackedHashSet(T).ExceptWith Method

Grid Solutions Framework FileBackedHashSetTExceptWith Method
Removes all elements in the specified collection from the current set.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ExceptWith(
    IEnumerable<T> other
)
Public Sub ExceptWith (
    other As IEnumerable(Of T)
)
abstract ExceptWith :
        other : IEnumerable<'T> -> unit
override ExceptWith :
        other : IEnumerable<'T> -> unit
function ExceptWith(other);
public:
virtual void ExceptWith(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection of items to remove from the set.

Implements

ISetTExceptWith(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).GetEnumerator Method

Grid Solutions Framework FileBackedHashSetTGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>
function GetEnumerator();
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

Type: IEnumerator T
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).IntersectWith Method

Grid Solutions Framework FileBackedHashSetTIntersectWith Method
Modifies the current set so that it contains only elements that are also in a specified collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void IntersectWith(
    IEnumerable<T> other
)
Public Sub IntersectWith (
    other As IEnumerable(Of T)
)
abstract IntersectWith :
        other : IEnumerable<'T> -> unit
override IntersectWith :
        other : IEnumerable<'T> -> unit
function IntersectWith(other);
public:
virtual void IntersectWith(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Implements

ISetTIntersectWith(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).IsProperSubsetOf Method

Grid Solutions Framework FileBackedHashSetTIsProperSubsetOf Method
Determines whether the current set is a proper (strict) subset of a specified collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsProperSubsetOf(
    IEnumerable<T> other
)
Public Function IsProperSubsetOf (
    other As IEnumerable(Of T)
) As Boolean
abstract IsProperSubsetOf :
        other : IEnumerable<'T> -> bool
override IsProperSubsetOf :
        other : IEnumerable<'T> -> bool
function IsProperSubsetOf(other);
public:
virtual bool IsProperSubsetOf(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Return Value

Type: Boolean
true if the current set is a proper subset of other; otherwise, false.

Implements

ISetTIsProperSubsetOf(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).IsProperSupersetOf Method

Grid Solutions Framework FileBackedHashSetTIsProperSupersetOf Method
Determines whether the current set is a proper (strict) superset of a specified collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsProperSupersetOf(
    IEnumerable<T> other
)
Public Function IsProperSupersetOf (
    other As IEnumerable(Of T)
) As Boolean
abstract IsProperSupersetOf :
        other : IEnumerable<'T> -> bool
override IsProperSupersetOf :
        other : IEnumerable<'T> -> bool
function IsProperSupersetOf(other);
public:
virtual bool IsProperSupersetOf(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Return Value

Type: Boolean
true if the current set is a proper superset of other; otherwise, false.

Implements

ISetTIsProperSupersetOf(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).IsSubsetOf Method

Grid Solutions Framework FileBackedHashSetTIsSubsetOf Method
Determines whether a set is a subset of a specified collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSubsetOf(
    IEnumerable<T> other
)
Public Function IsSubsetOf (
    other As IEnumerable(Of T)
) As Boolean
abstract IsSubsetOf :
        other : IEnumerable<'T> -> bool
override IsSubsetOf :
        other : IEnumerable<'T> -> bool
function IsSubsetOf(other);
public:
virtual bool IsSubsetOf(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Return Value

Type: Boolean
true if the current set is a subset of other; otherwise, false.

Implements

ISetTIsSubsetOf(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).IsSupersetOf Method

Grid Solutions Framework FileBackedHashSetTIsSupersetOf Method
Determines whether the current set is a superset of a specified collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSupersetOf(
    IEnumerable<T> other
)
Public Function IsSupersetOf (
    other As IEnumerable(Of T)
) As Boolean
abstract IsSupersetOf :
        other : IEnumerable<'T> -> bool
override IsSupersetOf :
        other : IEnumerable<'T> -> bool
function IsSupersetOf(other);
public:
virtual bool IsSupersetOf(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Return Value

Type: Boolean
true if the current set is a superset of other; otherwise, false.

Implements

ISetTIsSupersetOf(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Open Method

Grid Solutions Framework FileBackedHashSetTOpen Method
Opens the file backing this hash set.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open()
Public Sub Open
member Open : unit -> unit

function Open();
public:
void Open()
Exceptions
Exception | Condition
InvalidOperationException | File is already open.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Overlaps Method

Grid Solutions Framework FileBackedHashSetTOverlaps Method
Determines whether the current set overlaps with the specified collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Overlaps(
    IEnumerable<T> other
)
Public Function Overlaps (
    other As IEnumerable(Of T)
) As Boolean
abstract Overlaps :
        other : IEnumerable<'T> -> bool
override Overlaps :
        other : IEnumerable<'T> -> bool
function Overlaps(other);
public:
virtual bool Overlaps(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Return Value

Type: Boolean
true if the current set and other share at least one common element; otherwise, false.

Implements

ISetTOverlaps(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Remove Method

Grid Solutions Framework FileBackedHashSetTRemove Method
Removes the first occurrence of a specific object from the FileBackedHashSetT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool
function Remove(item);
public:
virtual bool Remove(
    T item
) sealed

Parameters

item
Type: T
The object to remove from the FileBackedHashSetT.

Return Value

Type: Boolean
true if item was successfully removed from the FileBackedHashSetT; otherwise, false. This method also returns false if item is not found in the original FileBackedHashSetT.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).RemoveWhere Method

Grid Solutions Framework FileBackedHashSetTRemoveWhere Method
Removes all elements that match the conditions defined by the specified predicate from a FileBackedHashSetT collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int RemoveWhere(
    Predicate<T> match
)
Public Function RemoveWhere (
    match As Predicate(Of T)
) As Integer
member RemoveWhere :
        match : Predicate<'T> -> int

function RemoveWhere(match);
public:
int RemoveWhere(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The PredicateT delegate that defines the conditions of the elements to remove.

Return Value

Type: Int32
The number of elements that were removed from the FileBackedHashSetT collection.
Exceptions
Exception | Condition
ArgumentNullException | match is null
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).SetEquals Method

Grid Solutions Framework FileBackedHashSetTSetEquals Method
Determines whether the current set and the specified collection contain the same elements.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SetEquals(
    IEnumerable<T> other
)
Public Function SetEquals (
    other As IEnumerable(Of T)
) As Boolean
abstract SetEquals :
        other : IEnumerable<'T> -> bool
override SetEquals :
        other : IEnumerable<'T> -> bool
function SetEquals(other);
public:
virtual bool SetEquals(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Return Value

Type: Boolean
true if the current set is equal to other; otherwise, false.

Implements

ISetTSetEquals(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).SymmetricExceptWith Method

Grid Solutions Framework FileBackedHashSetTSymmetricExceptWith Method
Modifies the current set so that it contains only elements that are present either in the current set or in the specified collection, but not both.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SymmetricExceptWith(
    IEnumerable<T> other
)
Public Sub SymmetricExceptWith (
    other As IEnumerable(Of T)
)
abstract SymmetricExceptWith :
        other : IEnumerable<'T> -> unit
override SymmetricExceptWith :
        other : IEnumerable<'T> -> unit
function SymmetricExceptWith(other);
public:
virtual void SymmetricExceptWith(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Implements

ISetTSymmetricExceptWith(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).UnionWith Method

Grid Solutions Framework FileBackedHashSetTUnionWith Method
Modifies the current set so that it contains all elements that are present in either the current set or the specified collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UnionWith(
    IEnumerable<T> other
)
Public Sub UnionWith (
    other As IEnumerable(Of T)
)
abstract UnionWith :
        other : IEnumerable<'T> -> unit
override UnionWith :
        other : IEnumerable<'T> -> unit
function UnionWith(other);
public:
virtual void UnionWith(
    IEnumerable<T>^ other
) sealed

Parameters

other
Type: System.Collections.GenericIEnumerable T
The collection to compare to the current set.

Implements

ISetTUnionWith(IEnumerableT)
Exceptions
Exception | Condition
ArgumentNullException | other is null.
NotSupportedException | The FileBackedHashSetT is read-only.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T) Properties

Grid Solutions Framework FileBackedHashSetT Properties

The FileBackedHashSetT generic type exposes the following members.

Properties
 | Name | Description
Public property | CacheSize | Gets or sets the size of the cache used to store data from the file in memory.
Public property | Count | Gets the number of elements contained in the FileBackedHashSetT.
Public property | DefaultSignature | Gets the default signature used by the FileBackedHashSetT if no user-defined signature is supplied.
Public property | FilePath | Gets or sets the path to the file backing this hash set.
Public property | IsReadOnly | Gets a value indicating whether the FileBackedHashSetT is read-only.
Public property | Signature | Gets or sets the signature of the file backing the lookup table.
Top
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).CacheSize Property

Grid Solutions Framework FileBackedHashSetTCacheSize Property
Gets or sets the size of the cache used to store data from the file in memory.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long CacheSize { get; set; }
Public Property CacheSize As Long
    Get
    Set
member CacheSize : int64 with get, set

function get_CacheSize();
function set_CacheSize(value);
public:
property long long CacheSize {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Count Property

Grid Solutions Framework FileBackedHashSetTCount Property
Gets the number of elements contained in the FileBackedHashSetT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get () sealed;
}

Return Value

Type: Int32
The number of elements contained in the FileBackedHashSetT.

Implements

ICollectionTCount
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).DefaultSignature Property

Grid Solutions Framework FileBackedHashSetTDefaultSignature Property
Gets the default signature used by the FileBackedHashSetT if no user-defined signature is supplied.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] DefaultSignature { get; }
Public ReadOnly Property DefaultSignature As Byte()
    Get
member DefaultSignature : byte[] with get

function get_DefaultSignature();

public:
property array<unsigned char>^ DefaultSignature {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).FilePath Property

Grid Solutions Framework FileBackedHashSetTFilePath Property
Gets or sets the path to the file backing this hash set.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
member FilePath : string with get, set

function get_FilePath();
function set_FilePath(value);
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentException | FilePath is set and is a zero-length string, contains only white space, or contains one or more invalid characters as defined by GetInvalidPathChars.
Remarks
Changes to this property will cause the file to close if the file is already opened. Data will not be automatically written from the old file to the new file.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).IsReadOnly Property

Grid Solutions Framework FileBackedHashSetTIsReadOnly Property
Gets a value indicating whether the FileBackedHashSetT is read-only.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
function get_IsReadOnly();

public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Return Value

Type: Boolean
true if the FileBackedHashSetT is read-only; otherwise, false.

Implements

ICollectionTIsReadOnly
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


FileBackedHashSet(T).Signature Property

Grid Solutions Framework FileBackedHashSetTSignature Property
Gets or sets the signature of the file backing the lookup table.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Signature { get; set; }
Public Property Signature As Byte()
    Get
    Set
member Signature : byte[] with get, set

function get_Signature();
function set_Signature(value);
public:
property array<unsigned char>^ Signature {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | Attempt is made to set Signature to a null value.
ArgumentException | Attempt is made to set Signature to a value larger than the maximum allowed size.
NotSupportedException | Attempt is made to modify Signature of a read-only lookup table.
See Also

Reference

FileBackedHashSetT Class
GSF.Collections Namespace


IsolatedQueue(T) Class

Grid Solutions Framework IsolatedQueueT Class
Provides a buffer of point data where reads are isolated from writes. However, reads must be synchronized with other reads and writes must be synchronized with other writes.
Inheritance Hierarchy
SystemObject
GSF.CollectionsIsolatedQueueT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IsolatedQueue<T>

Public Class IsolatedQueue(Of T)
type IsolatedQueue<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class IsolatedQueue

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GSF.Collections.IsolatedQueue`1"]

The IsolatedQueueT type exposes the following members.

Constructors
 | Name | Description
Public method | IsolatedQueueT | Creates an IsolatedQueueT
Top
Methods
 | Name | Description
Public method | Dequeue | Dequeues all of the items into the provided array
Public method | Enqueue(T) | Addes the provided item to the IsolatedQueueT.
Public method | Enqueue(T, Int32, Int32) | Addes the provided items to the IsolatedQueueT.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryDequeue | Attempts to dequeue the specified item from the IsolatedQueueT
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Count | The number of elements in the queue
Top
Remarks
This class is about twice as fast as a ConcurrentQueue. However, it has some decent overhead, so small lists may not make much sense. This also uses jagged arrays, and will automatically deallocate memory so is useful for structures that vary in size with time.
See Also

Reference

GSF.Collections Namespace


IsolatedQueue(T) Constructor

Grid Solutions Framework IsolatedQueueT Constructor
Creates an IsolatedQueueT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IsolatedQueue()
Public Sub New
new : unit -> IsolatedQueue
GSF.Collections.IsolatedQueue = function();
public:
IsolatedQueue()
See Also

Reference

IsolatedQueueT Class
GSF.Collections Namespace


IsolatedQueue(T) Methods

Grid Solutions Framework IsolatedQueueT Methods

The IsolatedQueueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dequeue | Dequeues all of the items into the provided array
Public method | Enqueue(T) | Addes the provided item to the IsolatedQueueT.
Public method | Enqueue(T, Int32, Int32) | Addes the provided items to the IsolatedQueueT.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryDequeue | Attempts to dequeue the specified item from the IsolatedQueueT
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IsolatedQueueT Class
GSF.Collections Namespace


IsolatedQueue(T).Dequeue Method

Grid Solutions Framework IsolatedQueueTDequeue Method
Dequeues all of the items into the provided array

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Dequeue(
    T[] items,
    int startingIndex,
    int length
)
Public Function Dequeue (
    items As T(),
    startingIndex As Integer,
    length As Integer
) As Integer
member Dequeue :
        items : 'T[] *
        startingIndex : int *
        length : int -> int

function Dequeue(items, startingIndex, length);
public:
int Dequeue(
    array<T>^ items,
    int startingIndex,
    int length
)

Parameters

items
Type: T
where to put the items
startingIndex
Type: SystemInt32
the starting index
length
Type: SystemInt32
the maximum number of times to store

Return Value

Type: Int32
the number of items dequeued
See Also

Reference

IsolatedQueueT Class
GSF.Collections Namespace


IsolatedQueue(T).Enqueue Method

Grid Solutions Framework IsolatedQueueTEnqueue Method
Overload List
 | Name | Description
Public method | Enqueue(T) | Addes the provided item to the IsolatedQueueT.
Public method | Enqueue(T, Int32, Int32) | Addes the provided items to the IsolatedQueueT.
Top
See Also

Reference

IsolatedQueueT Class
GSF.Collections Namespace


IsolatedQueue(T).Enqueue Method (T)

Grid Solutions Framework IsolatedQueueTEnqueue Method (T)
Addes the provided item to the IsolatedQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Enqueue(
    T item
)
Public Sub Enqueue (
    item As T
)
member Enqueue :
        item : 'T -> unit

function Enqueue(item);
public:
void Enqueue(
    T item
)

Parameters

item
Type: T
See Also

Reference

IsolatedQueueT Class
Enqueue Overload
GSF.Collections Namespace


IsolatedQueue(T).Enqueue Method (T[], Int32, Int32)

Grid Solutions Framework IsolatedQueueTEnqueue Method (T, Int32, Int32)
Addes the provided items to the IsolatedQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Enqueue(
    T[] items,
    int offset,
    int length
)
Public Sub Enqueue (
    items As T(),
    offset As Integer,
    length As Integer
)
member Enqueue :
        items : 'T[] *
        offset : int *
        length : int -> unit

function Enqueue(items, offset, length);
public:
void Enqueue(
    array<T>^ items,
    int offset,
    int length
)

Parameters

items
Type: T
the items to add
offset
Type: SystemInt32
the offset postion
length
Type: SystemInt32
the length
See Also

Reference

IsolatedQueueT Class
Enqueue Overload
GSF.Collections Namespace


IsolatedQueue(T).TryDequeue Method

Grid Solutions Framework IsolatedQueueTTryDequeue Method
Attempts to dequeue the specified item from the IsolatedQueueT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryDequeue(
    out T item
)
Public Function TryDequeue (
    <OutAttribute> ByRef item As T
) As Boolean
member TryDequeue :
        item : 'T byref -> bool

function TryDequeue(item);
public:
bool TryDequeue(
    [OutAttribute] T% item
)

Parameters

item
Type: T
an output for the item

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Collections.IsolatedQueue`1.TryDequeue(`0@)"]

See Also

Reference

IsolatedQueueT Class
GSF.Collections Namespace


IsolatedQueue(T) Properties

Grid Solutions Framework IsolatedQueueT Properties

The IsolatedQueueT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | The number of elements in the queue
Top
See Also

Reference

IsolatedQueueT Class
GSF.Collections Namespace


IsolatedQueue(T).Count Property

Grid Solutions Framework IsolatedQueueTCount Property
The number of elements in the queue

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Count { get; }
Public ReadOnly Property Count As Long
    Get
member Count : int64 with get

function get_Count();

public:
property long long Count {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

IsolatedQueueT Class
GSF.Collections Namespace


ListCollection(T) Class

Grid Solutions Framework ListCollectionT Class
A faster and functionally equivalent implementation of CollectionT
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
GSF.CollectionsListCollectionT
GSF.PhasorProtocolsChannelCollectionBaseT
GSF.TimeSeries.AdaptersAdapterCollectionBaseT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ListCollection<T> : Collection<T>,
    IList<T>, ICollection<T>, IList, ICollection, IReadOnlyList<T>,
    IReadOnlyCollection<T>, IEnumerable<T>, IEnumerable

Public Class ListCollection(Of T)
    Inherits Collection(Of T)
    Implements IList(Of T), ICollection(Of T),
    IList, ICollection, IReadOnlyList(Of T), IReadOnlyCollection(Of T),
    IEnumerable(Of T), IEnumerable
type ListCollection<'T> =
    class
        inherit Collection<'T>
        interface IList<'T>
        interface ICollection<'T>
        interface IList
        interface ICollection
        interface IReadOnlyList<'T>
        interface IReadOnlyCollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class ListCollection : public Collection<T>,
    IList<T>, ICollection<T>, IList, ICollection, IReadOnlyList<T>,
    IReadOnlyCollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type of the element in the collection

The ListCollectionT type exposes the following members.

Constructors
 | Name | Description
Public method | ListCollectionT | Creates a ListCollectionT
Public method | ListCollectionT(ListT) | Creates a ListCollectionT
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Public method | Clear | Removes all items from the ICollectionT.
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides CollectionTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the element at the specified index of the CollectionT.
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | Item | Gets or sets the element at the specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT.
Top
Remarks

CollectionT is based upon an IListT. This means any simple call to the class is a function call that cannot be in-lined. This implementation forces the underlying item to be ListT and shadows many of the methods to call ListT instead of IListT.

Since this class references the same underlying ListT object, it can be successfully implemented as a ListCollectionT or casted it its underlying type CollectionT.

Profiling this class yield a ForEach loop and For loop that executes between 2-4 times faster than CollectionT. This depends on the number of items in the list. The fewer the faster. Other operations such as Add/Insert/Remove are closer to 50% faster. Count is now in-lined (~20 times faster).

This performance is negated if accessing this class via the IList interface. When possible, use only strongly typed names.

See Also

Reference

GSF.Collections Namespace


ListCollection(T) Constructor

Grid Solutions Framework ListCollectionT Constructor
Overload List
 | Name | Description
Public method | ListCollectionT | Creates a ListCollectionT
Public method | ListCollectionT(ListT) | Creates a ListCollectionT
Top
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T) Constructor

Grid Solutions Framework ListCollectionT Constructor
Creates a ListCollectionT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ListCollection()
Public Sub New
new : unit -> ListCollection
GSF.Collections.ListCollection = function();
public:
ListCollection()
See Also

Reference

ListCollectionT Class
ListCollectionT Overload
GSF.Collections Namespace


ListCollection(T) Constructor (List(T))

Grid Solutions Framework ListCollectionT Constructor (ListT)
Creates a ListCollectionT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ListCollection(
    List<T> list
)
Public Sub New (
    list As List(Of T)
)
new :
        list : List<'T> -> ListCollection
GSF.Collections.ListCollection = function(list);
public:
ListCollection(
    List<T>^ list
)

Parameters

list
Type: System.Collections.GenericList T
a list to wrap this class around.
See Also

Reference

ListCollectionT Class
ListCollectionT Overload
GSF.Collections Namespace


ListCollection(T) Methods

Grid Solutions Framework ListCollectionT Methods

The ListCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT.
Public method | Clear | Removes all items from the ICollectionT.
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides CollectionTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value.
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT.
Public method | Insert | Inserts an item to the IListT at the specified index.
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT.
Public method | RemoveAt | Removes the element at the specified index of the CollectionT.
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides CollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Add Method

Grid Solutions Framework ListCollectionTAdd Method
Adds an item to the ICollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    T item
)
Public Sub Add (
    item As T
)
abstract Add :
        item : 'T -> unit
override Add :
        item : 'T -> unit
function Add(item);
public:
virtual void Add(
    T item
) sealed

Parameters

item
Type: T
The object to add to the ICollectionT.

Implements

ICollectionTAdd(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Clear Method

Grid Solutions Framework ListCollectionTClear Method
Removes all items from the ICollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
abstract Clear : unit -> unit
override Clear : unit -> unit
function Clear();
public:
virtual void Clear() sealed

Implements

ICollectionTClear
IListClear
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).ClearItems Method

Grid Solutions Framework ListCollectionTClearItems Method
Removes all elements from the CollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
abstract ClearItems : unit -> unit
override ClearItems : unit -> unit
function ClearItems();
protected:
virtual void ClearItems() override
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Contains Method

Grid Solutions Framework ListCollectionTContains Method
Determines whether the ICollectionT contains a specific value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool
function Contains(item);
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T
The object to locate in the ICollectionT.

Return Value

Type: Boolean
true if item is found in the ICollectionT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).CopyTo Method

Grid Solutions Framework ListCollectionTCopyTo Method
Copies the elements of the ICollectionT to an Array, starting at a particular Array index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CopyTo(
    T[] array,
    int index
)
Public Sub CopyTo (
    array As T(),
    index As Integer
)
abstract CopyTo :
        array : 'T[] *
        index : int -> unit
override CopyTo :
        array : 'T[] *
        index : int -> unit
function CopyTo(array, index);
public:
virtual void CopyTo(
    array<T>^ array,
    int index
) sealed

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from ICollectionT. The Array must have zero-based indexing.
index
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | index is less than 0.
ArgumentException | The number of elements in the source ICollectionT is greater than the available space from index to the end of the destination array.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).GetEnumerator Method

Grid Solutions Framework ListCollectionTGetEnumerator Method
Returns an enumerator that iterates through the CollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ListTEnumerator GetEnumerator()
Public Function GetEnumerator As ListTEnumerator
member GetEnumerator : unit -> ListTEnumerator

function GetEnumerator();
public:
ListTEnumerator GetEnumerator()

Return Value

Type: ListTEnumerator
An IEnumeratorT for the CollectionT.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).IndexOf Method

Grid Solutions Framework ListCollectionTIndexOf Method
Determines the index of a specific item in the IListT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer
abstract IndexOf :
        item : 'T -> int
override IndexOf :
        item : 'T -> int
function IndexOf(item);
public:
virtual int IndexOf(
    T item
) sealed

Parameters

item
Type: T
The object to locate in the IListT.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Insert Method

Grid Solutions Framework ListCollectionTInsert Method
Inserts an item to the IListT at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Insert(
    int index,
    T item
)
Public Sub Insert (
    index As Integer,
    item As T
)
abstract Insert :
        index : int *
        item : 'T -> unit
override Insert :
        index : int *
        item : 'T -> unit
function Insert(index, item);
public:
virtual void Insert(
    int index,
    T item
) sealed

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert into the IListT.

Implements

IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The IListT is read-only.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).InsertItem Method

Grid Solutions Framework ListCollectionTInsertItem Method
Inserts an element into the CollectionT at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)
abstract InsertItem :
        index : int *
        item : 'T -> unit
override InsertItem :
        index : int *
        item : 'T -> unit
function InsertItem(index, item);
protected:
virtual void InsertItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero.-or-index is greater than Count.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Remove Method

Grid Solutions Framework ListCollectionTRemove Method
Removes the first occurrence of a specific object from the ICollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool
function Remove(item);
public:
virtual bool Remove(
    T item
) sealed

Parameters

item
Type: T
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the ICollectionT; otherwise, false. This method also returns false if item is not found in the original ICollectionT.

Implements

ICollectionTRemove(T)
Exceptions
Exception | Condition
NotSupportedException | The ICollectionT is read-only.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).RemoveAt Method

Grid Solutions Framework ListCollectionTRemoveAt Method
Removes the element at the specified index of the CollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
function RemoveAt(index);
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.

Implements

IListTRemoveAt(Int32)
IListRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than Count.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).RemoveItem Method

Grid Solutions Framework ListCollectionTRemoveItem Method
Removes the element at the specified index of the CollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)
abstract RemoveItem :
        index : int -> unit
override RemoveItem :
        index : int -> unit
function RemoveItem(index);
protected:
virtual void RemoveItem(
    int index
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero.-or-index is equal to or greater than Count.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).SetItem Method

Grid Solutions Framework ListCollectionTSetItem Method
Replaces the element at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)
abstract SetItem :
        index : int *
        item : 'T -> unit
override SetItem :
        index : int *
        item : 'T -> unit
function SetItem(index, item);
protected:
virtual void SetItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero.-or-index is greater than Count.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T) Properties

Grid Solutions Framework ListCollectionT Properties

The ListCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the ICollectionT.
Public property | Item | Gets or sets the element at the specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT.
Top
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Count Property

Grid Solutions Framework ListCollectionTCount Property
Gets the number of elements contained in the ICollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get () sealed;
}

Return Value

Type: Int32
The number of elements contained in the ICollectionT.

Implements

ICollectionTCount
ICollectionCount
IReadOnlyCollectionTCount
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Item Property

Grid Solutions Framework ListCollectionTItem Property
Gets or sets the element at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set
abstract Item : 'T with get, set
override Item : 'T with get, set
function get_Item(index);
function set_Item(value);
public:
virtual property T default[int index] {
    T get (int index) sealed;
    void set (int index, T value) sealed;
}

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.

Return Value

Type: T
The element at the specified index.

Implements

IListTItemInt32
IReadOnlyListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the IListT.
NotSupportedException | The property is set and the IListT is read-only.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


ListCollection(T).Items Property

Grid Solutions Framework ListCollectionTItems Property
Gets a IListT wrapper around the CollectionT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected List<T> Items { get; }
Protected ReadOnly Property Items As List(Of T)
    Get
member Items : List<'T> with get

function get_Items();

protected:
property List<T>^ Items {
    List<T>^ get ();
}

Return Value

Type: List T
A IListT wrapper around the CollectionT.
See Also

Reference

ListCollectionT Class
GSF.Collections Namespace


PriorityQueue(T) Class

Grid Solutions Framework PriorityQueueT Class
Represents a queue of items to which priority can be assigned.
Inheritance Hierarchy
SystemObject
GSF.CollectionsPriorityQueueT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PriorityQueue<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Public Class PriorityQueue(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
type PriorityQueue<'T> =
    class
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class PriorityQueue : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type of the items stored in the queue.

The PriorityQueueT type exposes the following members.

Constructors
 | Name | Description
Public method | PriorityQueueT | Creates a new instance of the PriorityQueueT class.
Public method | PriorityQueueT(Int32) | Creates a new instance of the PriorityQueueT class.
Top
Methods
 | Name | Description
Public method | AdjustPriority | Adds the given value to the priority of all values in the priority queue.
Public method | Clear | Removes all items from the PriorityQueueT.
Public method | Contains | Determines whether the PriorityQueueT contains a specific value.
Public method | CopyTo | Copies the elements of the PriorityQueueT to an Array, starting at a particular Array index.
Public method | Dequeue | Gets the item with the highest priority and removes it from the queue.
Public method | Enqueue | Enqueues an item into the queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPriority | Gets the priority of the item at the given index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the PriorityQueueT.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Gets the item with the highest priority.
Public method | Remove | Removes the first occurrence of a specific object from the PriorityQueueT.
Public method | RemoveAt | Removes the PriorityQueueT item at the specified index.
Public method | SetPriority | Sets the priority of the item at the given index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the PriorityQueueT.
Public property | Head | Gets the head of the queue. The value returned is the same as the Peek method.
Public property | IsReadOnly | Gets a value indicating whether the PriorityQueueT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

GSF.Collections Namespace


PriorityQueue(T) Constructor

Grid Solutions Framework PriorityQueueT Constructor
Overload List
 | Name | Description
Public method | PriorityQueueT | Creates a new instance of the PriorityQueueT class.
Public method | PriorityQueueT(Int32) | Creates a new instance of the PriorityQueueT class.
Top
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T) Constructor

Grid Solutions Framework PriorityQueueT Constructor
Creates a new instance of the PriorityQueueT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PriorityQueue()
Public Sub New
new : unit -> PriorityQueue
GSF.Collections.PriorityQueue = function();
public:
PriorityQueue()
See Also

Reference

PriorityQueueT Class
PriorityQueueT Overload
GSF.Collections Namespace


PriorityQueue(T) Constructor (Int32)

Grid Solutions Framework PriorityQueueT Constructor (Int32)
Creates a new instance of the PriorityQueueT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PriorityQueue(
    int capacity
)
Public Sub New (
    capacity As Integer
)
new :
        capacity : int -> PriorityQueue
GSF.Collections.PriorityQueue = function(capacity);
public:
PriorityQueue(
    int capacity
)

Parameters

capacity
Type: SystemInt32
The initial size of the underlying array.
See Also

Reference

PriorityQueueT Class
PriorityQueueT Overload
GSF.Collections Namespace


PriorityQueue(T) Methods

Grid Solutions Framework PriorityQueueT Methods

The PriorityQueueT generic type exposes the following members.

Methods
 | Name | Description
Public method | AdjustPriority | Adds the given value to the priority of all values in the priority queue.
Public method | Clear | Removes all items from the PriorityQueueT.
Public method | Contains | Determines whether the PriorityQueueT contains a specific value.
Public method | CopyTo | Copies the elements of the PriorityQueueT to an Array, starting at a particular Array index.
Public method | Dequeue | Gets the item with the highest priority and removes it from the queue.
Public method | Enqueue | Enqueues an item into the queue.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPriority | Gets the priority of the item at the given index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the PriorityQueueT.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Peek | Gets the item with the highest priority.
Public method | Remove | Removes the first occurrence of a specific object from the PriorityQueueT.
Public method | RemoveAt | Removes the PriorityQueueT item at the specified index.
Public method | SetPriority | Sets the priority of the item at the given index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).AdjustPriority Method

Grid Solutions Framework PriorityQueueTAdjustPriority Method
Adds the given value to the priority of all values in the priority queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AdjustPriority(
    int delta
)
Public Sub AdjustPriority (
    delta As Integer
)
member AdjustPriority :
        delta : int -> unit

function AdjustPriority(delta);
public:
void AdjustPriority(
    int delta
)

Parameters

delta
Type: SystemInt32
The amount by which to adjust priorities.
Remarks
This allows for adjusting the priorities of all items in the heap without having to fix the heap each time a priority is changed. This can be useful to increase the priorities of items that have been in the queue for significant periods of time to prevent starvation. This is an O(n) operation.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Clear Method

Grid Solutions Framework PriorityQueueTClear Method
Removes all items from the PriorityQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
abstract Clear : unit -> unit
override Clear : unit -> unit
function Clear();
public:
virtual void Clear() sealed

Implements

ICollectionTClear
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Contains Method

Grid Solutions Framework PriorityQueueTContains Method
Determines whether the PriorityQueueT contains a specific value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool
function Contains(item);
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T
The object to locate in the PriorityQueueT.

Return Value

Type: Boolean
true if item is found in the PriorityQueueT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).CopyTo Method

Grid Solutions Framework PriorityQueueTCopyTo Method
Copies the elements of the PriorityQueueT to an Array, starting at a particular Array index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
function CopyTo(array, arrayIndex);
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from PriorityQueueT. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source PriorityQueueT is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Dequeue Method

Grid Solutions Framework PriorityQueueTDequeue Method
Gets the item with the highest priority and removes it from the queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Dequeue()
Public Function Dequeue As T
member Dequeue : unit -> 'T

function Dequeue();
public:
T Dequeue()

Return Value

Type: T
The item with the highest priority.
Exceptions
Exception | Condition
InvalidOperationException | The queue is empty.
Remarks
After removing an item from the queue, the heap will need to be fixed, therefore this is an O(log n) operation.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Enqueue Method

Grid Solutions Framework PriorityQueueTEnqueue Method
Enqueues an item into the queue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Enqueue(
    int priority,
    T item
)
Public Sub Enqueue (
    priority As Integer,
    item As T
)
member Enqueue :
        priority : int *
        item : 'T -> unit

function Enqueue(priority, item);
public:
void Enqueue(
    int priority,
    T item
)

Parameters

priority
Type: SystemInt32
The priority of the item.
item
Type: T
The item to be enqueued.
Remarks
After adding an item to the queue, the heap will need to be fixed, therefore this is an O(log n) operation.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).GetEnumerator Method

Grid Solutions Framework PriorityQueueTGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>
function GetEnumerator();
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

Type: IEnumerator T
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
Remarks
The enumerator performs an in-order traversal of the heap, so the caller should expect that items will be iterated in no particular order. Any operations that would modify the collection during iteration will cause the enumerator to throw an InvalidOperationException.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).GetPriority Method

Grid Solutions Framework PriorityQueueTGetPriority Method
Gets the priority of the item at the given index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GetPriority(
    int index
)
Public Function GetPriority (
    index As Integer
) As Integer
member GetPriority :
        index : int -> int

function GetPriority(index);
public:
int GetPriority(
    int index
)

Parameters

index
Type: SystemInt32
The index of the item.

Return Value

Type: Int32
The priority of the item.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Index does not fall within the bounds of the queue.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).IndexOf Method

Grid Solutions Framework PriorityQueueTIndexOf Method
Determines the index of a specific item in the PriorityQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer
abstract IndexOf :
        item : 'T -> int
override IndexOf :
        item : 'T -> int
function IndexOf(item);
public:
virtual int IndexOf(
    T item
) sealed

Parameters

item
Type: T
The object to locate in the PriorityQueueT.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Peek Method

Grid Solutions Framework PriorityQueueTPeek Method
Gets the item with the highest priority.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Peek()
Public Function Peek As T
member Peek : unit -> 'T

function Peek();
public:
T Peek()

Return Value

Type: T
The item with the highest priority.
Exceptions
Exception | Condition
InvalidOperationException | The queue is empty.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Remove Method

Grid Solutions Framework PriorityQueueTRemove Method
Removes the first occurrence of a specific object from the PriorityQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool
function Remove(item);
public:
virtual bool Remove(
    T item
) sealed

Parameters

item
Type: T
The object to remove from the PriorityQueueT.

Return Value

Type: Boolean
true if item was successfully removed from the PriorityQueueT; otherwise, false. This method also returns false if item is not found in the original PriorityQueueT.

Implements

ICollectionTRemove(T)
Remarks
After removing an item from the queue, the heap will need to be fixed, therefore this is an O(log n) operation.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).RemoveAt Method

Grid Solutions Framework PriorityQueueTRemoveAt Method
Removes the PriorityQueueT item at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
function RemoveAt(index);
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the PriorityQueueT.
Remarks
After removing an item from the queue, the heap will need to be fixed, therefore this is an O(log n) operation.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).SetPriority Method

Grid Solutions Framework PriorityQueueTSetPriority Method
Sets the priority of the item at the given index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetPriority(
    int index,
    int priority
)
Public Sub SetPriority (
    index As Integer,
    priority As Integer
)
member SetPriority :
        index : int *
        priority : int -> unit

function SetPriority(index, priority);
public:
void SetPriority(
    int index,
    int priority
)

Parameters

index
Type: SystemInt32
The index of the item.
priority
Type: SystemInt32
The new priority of the item.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Index does not fall within the bounds of the queue.
Remarks
This method can be used to change the priority of the item at the given index. After setting the priority, the queue will have to fix the heap so this is an O(log n) operation.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T) Properties

Grid Solutions Framework PriorityQueueT Properties

The PriorityQueueT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the PriorityQueueT.
Public property | Head | Gets the head of the queue. The value returned is the same as the Peek method.
Public property | IsReadOnly | Gets a value indicating whether the PriorityQueueT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Top
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Count Property

Grid Solutions Framework PriorityQueueTCount Property
Gets the number of elements contained in the PriorityQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get () sealed;
}

Return Value

Type: Int32
The number of elements contained in the PriorityQueueT.

Implements

ICollectionTCount
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Head Property

Grid Solutions Framework PriorityQueueTHead Property
Gets the head of the queue. The value returned is the same as the Peek method.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Head { get; }
Public ReadOnly Property Head As T
    Get
member Head : 'T with get

function get_Head();

public:
property T Head {
    T get ();
}

Property Value

Type: T
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).IsReadOnly Property

Grid Solutions Framework PriorityQueueTIsReadOnly Property
Gets a value indicating whether the PriorityQueueT is read-only.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
function get_IsReadOnly();

public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Return Value

Type: Boolean
False

Implements

ICollectionTIsReadOnly
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


PriorityQueue(T).Item Property

Grid Solutions Framework PriorityQueueTItem Property
Gets or sets the element at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set
abstract Item : 'T with get, set
override Item : 'T with get, set
function get_Item(index);
function set_Item(value);
public:
virtual property T default[int index] {
    T get (int index) sealed;
    void set (int index, T value) sealed;
}

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.

Return Value

Type: T
The element at the specified index.

Implements

IListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the PriorityQueueT.
See Also

Reference

PriorityQueueT Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Class

Grid Solutions Framework ProcessDictionaryTKey, TValue Class
Represents a thread-safe (via locking) keyed collection of items, based on DictionaryListTKey, TValue, that get processed on independent threads with a consumer provided function.
Inheritance Hierarchy
SystemObject
GSF.CollectionsProcessQueue KeyValuePair TKey, TValue
GSF.CollectionsProcessDictionaryTKey, TValue

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ProcessDictionary<TKey, TValue> : ProcessQueue<KeyValuePair<TKey, TValue>>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable

Public Class ProcessDictionary(Of TKey, TValue)
    Inherits ProcessQueue(Of KeyValuePair(Of TKey, TValue))
    Implements IDictionary(Of TKey, TValue), ICollection(Of KeyValuePair(Of TKey, TValue)),
    IEnumerable(Of KeyValuePair(Of TKey, TValue)), IEnumerable
type ProcessDictionary<'TKey, 'TValue> =
    class
        inherit ProcessQueue<KeyValuePair<'TKey, 'TValue>>
        interface IDictionary<'TKey, 'TValue>
        interface ICollection<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable<KeyValuePair<'TKey, 'TValue>>
        interface IEnumerable
    end
JavaScript does not support generic types or methods.
generic<typename TKey, typename TValue>
public ref class ProcessDictionary : public ProcessQueue<KeyValuePair<TKey, TValue>>,
    IDictionary<TKey, TValue>, ICollection<KeyValuePair<TKey, TValue>>,
    IEnumerable<KeyValuePair<TKey, TValue>>, IEnumerable

Type Parameters

TKey
Type of keys used to reference process items.
TValue
Type of values to process.

The ProcessDictionaryTKey, TValue type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessDictionaryTKey, TValue(ProcessDictionaryTKey, TValueProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Public method | ProcessDictionaryTKey, TValue(ProcessQueueKeyValuePairTKey, TValueProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk-item ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Public method | ProcessDictionaryTKey, TValue(ProcessDictionaryTKey, TValueProcessItemFunctionSignature, ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Public method | ProcessDictionaryTKey, TValue(ProcessQueueKeyValuePairTKey, TValueProcessItemsFunctionSignature, ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk-item ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Top
Methods
 | Name | Description
Public method | Add(T) | Adds an item to the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the ProcessDictionaryTKey, TValue.
Public method | AddOrUpdate(TKey, FuncTKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, FuncTKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddRange | Adds the elements of the specified collection to the end of the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | BinarySearch(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(T).)
Public method | BinarySearch(KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(T, IComparerT).)
Public method | BinarySearch(Int32, Int32, KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(Int32, Int32, T, IComparerT).)
Protected method | CanProcessItem | Determines if an item can be processed. (Inherited from ProcessQueueT.)
Protected method | CanProcessItems | Determines if all items can be processed. (Inherited from ProcessQueueT.)
Public method | Clear | Removes all elements from the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | Contains | Determines whether an element is in the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | ContainsKey | Determines whether the ProcessDictionaryTKey, TValue contains an element with the specified key.
Public method | ContainsValue | Determines whether the ProcessDictionaryTKey, TValue contains an element with the specified value.
Public method | ConvertAllTOutput | Converts the elements in the current ProcessQueueT to another type, and returns a ProcessQueueT containing the converted elements. (Inherited from ProcessQueueT.)
Public method | CopyTo | Copies the entire ProcessQueueT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ProcessQueueT.)
Protected method | DataAdded | Notifies queue that data was added and/or modified, so it can begin processing data. (Inherited from ProcessQueueT.)
Public method | Dispose | Releases all the resources used by the ProcessQueueT object. (Inherited from ProcessQueueT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessDictionaryTKey, TValue object and optionally releases the managed resources. (Overrides ProcessQueueTDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ProcessQueueT contains elements that match the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Protected method | Finalize | Releases the unmanaged resources before the ProcessQueueT object is reclaimed by GC. (Inherited from ProcessQueueT.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | FindAll | Retrieves all elements that match the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index. (Inherited from ProcessQueueT.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index. (Inherited from ProcessQueueT.)
Public method | Flush | Blocks the current thread, if the ProcessQueueT is active (i.e., user has called "Start" method), until all items in ProcessQueueT are processed, and then stops the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | ForEach | Performs the specified action on each element of the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOrAdd(TKey, FuncTKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.
Public method | GetOrAdd(TKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTIndexOf(T).)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | IndexOf(KeyValuePairTKey, TValue, Int32, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTIndexOf(T, Int32, Int32).)
Public method | IndexOfKey | Searches for the specified key and returns the zero-based index within the entire ProcessDictionaryTKey, TValue.
Public method | IndexOfValue | Searches for the specified value and returns the zero-based index of the first occurrence within the entire ProcessDictionaryTKey, TValue.
Public method | Insert | Inserts an element into the ProcessQueueT at the specified index. (Inherited from ProcessQueueT.)
Public method | InsertRange | Inserts the elements of a collection into the ProcessQueueT at the specified index. (Inherited from ProcessQueueT.)
Public method | LastIndexOf(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T).)
Public method | LastIndexOf(KeyValuePairTKey, TValue, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T, Int32).)
Public method | LastIndexOf(KeyValuePairTKey, TValue, Int32, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T, Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemProcessed | Raises the base class ItemProcessed event. (Inherited from ProcessQueueT.)
Protected method | OnItemsProcessed | Raises the base class ItemsProcessed event. (Inherited from ProcessQueueT.)
Protected method | OnItemsTimedOut | Raises the base class ItemsTimedOut event. (Inherited from ProcessQueueT.)
Protected method | OnItemTimedOut | Raises the base class ItemTimedOut event. (Inherited from ProcessQueueT.)
Protected method | OnProcessException | Raises the base class ProcessException event. (Inherited from ProcessQueueT.)
Public method | Remove(TKey) | Removes the element with the specified key from the ProcessDictionaryTKey, TValue.
Public method | Remove(T) | Removes the first occurrence of a specific object from the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Public method | RemoveAt | Removes the element at the specified index of the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | RemoveRange | Removes a range of elements from the ProcessQueueT. (Inherited from ProcessQueueT.)
Protected method | RequeueItem | Requeues item into ProcessQueueT according to specified requeue reason. (Inherited from ProcessQueueT.)
Protected method | RequeueItems | Requeues items into ProcessQueueT according to specified requeue reason. (Inherited from ProcessQueueT.)
Public method | Reverse | Reverses the order of the elements in the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ProcessQueueT.)
Public method | SignalDataModified | Manually signals that data has been modified and processing should resume. (Inherited from ProcessQueueT.)
Public method | Sort | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort.)
Public method | Sort(IComparerKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(IComparerT).)
Public method | Sort(ComparisonKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(ComparisonT).)
Public method | Sort(Int32, Int32, IComparerKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(Int32, Int32, IComparerT).)
Public method | Start | Starts item processing. (Inherited from ProcessQueueT.)
Public method | Stop | Stops item processing. (Inherited from ProcessQueueT.)
Public method | ToArray | Copies the elements contained in the ProcessQueueT to a new array. (Inherited from ProcessQueueT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrueForAll | Determines whether every element in the ProcessQueueT matches the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Public method | TryGetValue | Gets the value associated with the specified key.
Public method | TryTake(T) | Attempts to remove and return an object from the ProcessQueueT. (Inherited from ProcessQueueT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByKeyValuePairTKey, TValue, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairTKey, TValue, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairTKey, TValue, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | CanProcessItemFunction | Gets or sets the user function used to determine if an item is ready to be processed.
Public property | Count | Gets the number of elements actually contained in the ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | CurrentStatistics | Gets the current run-time statistics of the ProcessQueueT as a single group of values. (Inherited from ProcessQueueT.)
Public property | Enabled | Gets or sets indicator that the ProcessQueueT is currently enabled. (Inherited from ProcessQueueT.)
Protected property | InternalDictionary | Gets the internal sorted dictionary for direct use by derived classes.
Protected property | InternalEnumerable | Allows derived classes to access the interfaced internal ProcessQueueT directly. (Inherited from ProcessQueueT.)
Protected property | InternalList | Gets the internal list for direct use by ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ProcessQueueT.)
Public property | IsEmpty | Gets a value that indicates whether the ProcessQueueT is empty. (Inherited from ProcessQueueT.)
Public property | IsProcessing | Gets indicator that the ProcessQueueT is actively processing items. (Inherited from ProcessQueueT.)
Public property | IsReadOnly | Gets a value indicating whether the ProcessQueueT is read-only. (Inherited from ProcessQueueT.)
Public property | IsSynchronized | Gets a value indicating whether access to the ProcessQueueT is synchronized (thread safe). Always returns true for ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | ItemTKey | Gets or sets the value associated with the specified key.
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from ProcessQueueT.)
Public property | ItemsBeingProcessed | Gets the total number of items currently being processed. (Inherited from ProcessQueueT.)
Public property | Keys | Gets an ICollection containing the keys of the ProcessDictionaryTKey, TValue.
Public property | MaximumThreads | Gets or sets the maximum number of threads to process simultaneously. (Inherited from ProcessQueueT.)
Public property | Name | Gets the class name. (Overrides ProcessQueueTName.)
Public property | ProcessingIsRealTime | Gets indicator that items will be processed in real-time. (Inherited from ProcessQueueT.)
Public property | ProcessingStyle | Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once). (Inherited from ProcessQueueT.)
Public property | ProcessInterval | Gets or sets the interval, in milliseconds, on which new items begin processing. (Inherited from ProcessQueueT.)
Public property | ProcessItemFunction | Gets or sets the user function used to process items in the list one at a time.
Public property | ProcessItemsFunction | Gets or sets the user function used to process multiple items in the list at once. (Overrides ProcessQueueTProcessItemsFunction.)
Public property | ProcessTimeout | Gets or sets the maximum time, in milliseconds, allowed for processing an item. (Inherited from ProcessQueueT.)
Public property | RequeueModeOnException | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after an exception occurs while processing. (Inherited from ProcessQueueT.)
Public property | RequeueModeOnTimeout | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after processing times out. (Inherited from ProcessQueueT.)
Public property | RequeueOnException | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if an exception occurs while processing. (Inherited from ProcessQueueT.)
Public property | RequeueOnTimeout | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if the processing times out. (Inherited from ProcessQueueT.)
Public property | RunTime | Gets the total amount of time, in seconds, that the ProcessQueueT has been active. (Inherited from ProcessQueueT.)
Public property | Status | Gets current status of ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | SynchronizedOperationType | Gets or sets the type of synchronized operation used to process items in a real-time ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | ThreadCount | Gets the current number of active threads. (Inherited from ProcessQueueT.)
Public property | ThreadingMode | Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous). (Inherited from ProcessQueueT.)
Public property | TotalFunctionCalls | Gets the total number of calls to ProcessItemFunction or ProcessItemsFunction. (Inherited from ProcessQueueT.)
Public property | TotalProcessedItems | Gets the total number of items processed so far. (Inherited from ProcessQueueT.)
Public property | Values | Gets an ICollection containing the values of the ProcessDictionaryTKey, TValue.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed. (Inherited from ProcessQueueT.)
Public event | ItemProcessed | Event that is raised after an item has been successfully processed. (Inherited from ProcessQueueT.)
Public event | ItemsProcessed | Event that is raised after an array of items have been successfully processed. (Inherited from ProcessQueueT.)
Public event | ItemsTimedOut | Event that is raised if the processing time for an array of items exceeds the specified process timeout. (Inherited from ProcessQueueT.)
Public event | ItemTimedOut | Event that is raised if an item's processing time exceeds the specified process timeout. (Inherited from ProcessQueueT.)
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the ProcessQueueT. (Inherited from ProcessQueueT.)
Top
Remarks

This class acts as a strongly-typed sorted dictionary of objects to be processed.

Note that the ProcessDictionaryTKey, TValue will not start processing until the Start method is called.

Because this ProcessDictionaryTKey, TValue represents a dictionary style collection, all keys must be unique.

Be aware that this class is based on a DictionaryListTKey, TValue (i.e., a SortedListTKey, TValue that implements IListT), and since items in this kind of list are automatically sorted, items will be processed in "sorted" order regardless of the order in which they are added to the list.

Important note about using an "Integer" as the key for this class: because the ProcessDictionaryTKey, TValue base class must implement IList, a normal dictionary cannot be used for the base class. IDictionary implementations do not normally implement the IList interface because of ambiguity that is caused when implementing an integer key. For example, if you implement this class with a key of type "Integer," you will not be able to access items in the ProcessDictionaryTKey, TValue by index without "casting" the ProcessDictionaryTKey, TValue as IList. This is because the Item property in both the IDictionary and IList would have the same parameters (see the DictionaryListTKey, TValue class for more details.).

See Also

Reference

GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Constructor

Grid Solutions Framework ProcessDictionaryTKey, TValue Constructor
Overload List
 | Name | Description
Public method | ProcessDictionaryTKey, TValue(ProcessDictionaryTKey, TValueProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Public method | ProcessDictionaryTKey, TValue(ProcessQueueKeyValuePairTKey, TValueProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk-item ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Public method | ProcessDictionaryTKey, TValue(ProcessDictionaryTKey, TValueProcessItemFunctionSignature, ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Public method | ProcessDictionaryTKey, TValue(ProcessQueueKeyValuePairTKey, TValueProcessItemsFunctionSignature, ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk-item ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Constructor (ProcessDictionary(TKey, TValue).ProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessDictionaryTKey, TValue Constructor (ProcessDictionaryTKey, TValueProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessDictionary(
    ProcessDictionaryTKey, TValueProcessItemFunctionSignature processItemFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemFunction As ProcessDictionaryTKey, TValueProcessItemFunctionSignature,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemFunction : ProcessDictionaryTKey, TValueProcessItemFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessDictionary
GSF.Collections.ProcessDictionary = function(processItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessDictionary(
    ProcessDictionaryTKey, TValueProcessItemFunctionSignature^ processItemFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessDictionaryTKey, TValueProcessItemFunctionSignature
A delegate ProcessDictionaryTKey, TValueProcessItemFunctionSignature that defines a function signature to process a key and value one at a time.
processInterval (Optional)
Type: SystemDouble
A Double which represents the process interval.
maximumThreads (Optional)
Type: SystemInt32
An Int32 that represents the max number of threads to use.
processTimeout (Optional)
Type: SystemInt32
An Int32 that represents the amount of time before a process times out.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after a timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after an exception.
See Also

Reference

ProcessDictionaryTKey, TValue Class
ProcessDictionaryTKey, TValue Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Constructor (ProcessQueue(KeyValuePair(TKey, TValue)).ProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessDictionaryTKey, TValue Constructor (ProcessQueueKeyValuePairTKey, TValueProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a bulk-item ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessDictionary(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessDictionary
GSF.Collections.ProcessDictionary = function(processItemsFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessDictionary(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
A delegate ProcessDictionaryTKey, TValueProcessItemFunctionSignature that defines a function signature to process multiple items at once.
processInterval (Optional)
Type: SystemDouble
A Double which represents the process interval.
maximumThreads (Optional)
Type: SystemInt32
An Int32 that represents the max number of threads to use.
processTimeout (Optional)
Type: SystemInt32
An Int32 that represents the amount of time before a process times out.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after a timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after an exception.
See Also

Reference

ProcessDictionaryTKey, TValue Class
ProcessDictionaryTKey, TValue Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Constructor (ProcessDictionary(TKey, TValue).ProcessItemFunctionSignature, ProcessDictionary(TKey, TValue).CanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessDictionaryTKey, TValue Constructor (ProcessDictionaryTKey, TValueProcessItemFunctionSignature, ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessDictionary(
    ProcessDictionaryTKey, TValueProcessItemFunctionSignature processItemFunction,
    ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature canProcessItemFunction = null,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemFunction As ProcessDictionaryTKey, TValueProcessItemFunctionSignature,
    Optional canProcessItemFunction As ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature = Nothing,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemFunction : ProcessDictionaryTKey, TValueProcessItemFunctionSignature *
        ?canProcessItemFunction : ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _canProcessItemFunction = defaultArg canProcessItemFunction null
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessDictionary
GSF.Collections.ProcessDictionary = function(processItemFunction, canProcessItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessDictionary(
    ProcessDictionaryTKey, TValueProcessItemFunctionSignature^ processItemFunction,
    ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature^ canProcessItemFunction = nullptr,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessDictionaryTKey, TValueProcessItemFunctionSignature
A delegate ProcessDictionaryTKey, TValueProcessItemFunctionSignature that defines a function signature to process a key and value one at a time.
canProcessItemFunction (Optional)
Type: GSF.CollectionsProcessDictionaryTKey, TValueCanProcessItemFunctionSignature
A delegate ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature that determines if a key and value can currently be processed.
processInterval (Optional)
Type: SystemDouble
A Double which represents the process interval.
maximumThreads (Optional)
Type: SystemInt32
An Int32 that represents the max number of threads to use.
processTimeout (Optional)
Type: SystemInt32
An Int32 that represents the amount of time before a process times out.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after a timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after an exception.
See Also

Reference

ProcessDictionaryTKey, TValue Class
ProcessDictionaryTKey, TValue Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Constructor (ProcessQueue(KeyValuePair(TKey, TValue)).ProcessItemsFunctionSignature, ProcessDictionary(TKey, TValue).CanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessDictionaryTKey, TValue Constructor (ProcessQueueKeyValuePairTKey, TValueProcessItemsFunctionSignature, ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a bulk-item ProcessDictionaryTKey, TValue based on the generic DictionaryListTKey, TValue class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessDictionary(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature canProcessItemFunction = null,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    Optional canProcessItemFunction As ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature = Nothing,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        ?canProcessItemFunction : ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _canProcessItemFunction = defaultArg canProcessItemFunction null
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessDictionary
GSF.Collections.ProcessDictionary = function(processItemsFunction, canProcessItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessDictionary(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature^ canProcessItemFunction = nullptr,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
A delegate ProcessDictionaryTKey, TValueProcessItemFunctionSignature that defines a function signature to process multiple items at once.
canProcessItemFunction (Optional)
Type: GSF.CollectionsProcessDictionaryTKey, TValueCanProcessItemFunctionSignature
A delegate ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature that determines if a key and value can currently be processed.
processInterval (Optional)
Type: SystemDouble
A Double which represents the process interval.
maximumThreads (Optional)
Type: SystemInt32
An Int32 that represents the max number of threads to use.
processTimeout (Optional)
Type: SystemInt32
An Int32 that represents the amount of time before a process times out.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after a timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether the process should requeue the item after an exception.
See Also

Reference

ProcessDictionaryTKey, TValue Class
ProcessDictionaryTKey, TValue Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Methods

Grid Solutions Framework ProcessDictionaryTKey, TValue Methods

The ProcessDictionaryTKey, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds an item to the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the ProcessDictionaryTKey, TValue.
Public method | AddOrUpdate(TKey, FuncTKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, FuncTKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddRange | Adds the elements of the specified collection to the end of the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | BinarySearch(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(T).)
Public method | BinarySearch(KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(T, IComparerT).)
Public method | BinarySearch(Int32, Int32, KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(Int32, Int32, T, IComparerT).)
Protected method | CanProcessItem | Determines if an item can be processed. (Inherited from ProcessQueueT.)
Protected method | CanProcessItems | Determines if all items can be processed. (Inherited from ProcessQueueT.)
Public method | Clear | Removes all elements from the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | Contains | Determines whether an element is in the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | ContainsKey | Determines whether the ProcessDictionaryTKey, TValue contains an element with the specified key.
Public method | ContainsValue | Determines whether the ProcessDictionaryTKey, TValue contains an element with the specified value.
Public method | ConvertAllTOutput | Converts the elements in the current ProcessQueueT to another type, and returns a ProcessQueueT containing the converted elements. (Inherited from ProcessQueueT.)
Public method | CopyTo | Copies the entire ProcessQueueT to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from ProcessQueueT.)
Protected method | DataAdded | Notifies queue that data was added and/or modified, so it can begin processing data. (Inherited from ProcessQueueT.)
Public method | Dispose | Releases all the resources used by the ProcessQueueT object. (Inherited from ProcessQueueT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessDictionaryTKey, TValue object and optionally releases the managed resources. (Overrides ProcessQueueTDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ProcessQueueT contains elements that match the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Protected method | Finalize | Releases the unmanaged resources before the ProcessQueueT object is reclaimed by GC. (Inherited from ProcessQueueT.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | FindAll | Retrieves all elements that match the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index. (Inherited from ProcessQueueT.)
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index. (Inherited from ProcessQueueT.)
Public method | Flush | Blocks the current thread, if the ProcessQueueT is active (i.e., user has called "Start" method), until all items in ProcessQueueT are processed, and then stops the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | ForEach | Performs the specified action on each element of the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetOrAdd(TKey, FuncTKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.
Public method | GetOrAdd(TKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.
Public method | GetRange | Creates a shallow copy of a range of elements in the source ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTIndexOf(T).)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | IndexOf(KeyValuePairTKey, TValue, Int32, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTIndexOf(T, Int32, Int32).)
Public method | IndexOfKey | Searches for the specified key and returns the zero-based index within the entire ProcessDictionaryTKey, TValue.
Public method | IndexOfValue | Searches for the specified value and returns the zero-based index of the first occurrence within the entire ProcessDictionaryTKey, TValue.
Public method | Insert | Inserts an element into the ProcessQueueT at the specified index. (Inherited from ProcessQueueT.)
Public method | InsertRange | Inserts the elements of a collection into the ProcessQueueT at the specified index. (Inherited from ProcessQueueT.)
Public method | LastIndexOf(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T).)
Public method | LastIndexOf(KeyValuePairTKey, TValue, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T, Int32).)
Public method | LastIndexOf(KeyValuePairTKey, TValue, Int32, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T, Int32, Int32).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemProcessed | Raises the base class ItemProcessed event. (Inherited from ProcessQueueT.)
Protected method | OnItemsProcessed | Raises the base class ItemsProcessed event. (Inherited from ProcessQueueT.)
Protected method | OnItemsTimedOut | Raises the base class ItemsTimedOut event. (Inherited from ProcessQueueT.)
Protected method | OnItemTimedOut | Raises the base class ItemTimedOut event. (Inherited from ProcessQueueT.)
Protected method | OnProcessException | Raises the base class ProcessException event. (Inherited from ProcessQueueT.)
Public method | Remove(TKey) | Removes the element with the specified key from the ProcessDictionaryTKey, TValue.
Public method | Remove(T) | Removes the first occurrence of a specific object from the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Public method | RemoveAt | Removes the element at the specified index of the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | RemoveRange | Removes a range of elements from the ProcessQueueT. (Inherited from ProcessQueueT.)
Protected method | RequeueItem | Requeues item into ProcessQueueT according to specified requeue reason. (Inherited from ProcessQueueT.)
Protected method | RequeueItems | Requeues items into ProcessQueueT according to specified requeue reason. (Inherited from ProcessQueueT.)
Public method | Reverse | Reverses the order of the elements in the entire ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from ProcessQueueT.)
Public method | SignalDataModified | Manually signals that data has been modified and processing should resume. (Inherited from ProcessQueueT.)
Public method | Sort | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort.)
Public method | Sort(IComparerKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(IComparerT).)
Public method | Sort(ComparisonKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(ComparisonT).)
Public method | Sort(Int32, Int32, IComparerKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(Int32, Int32, IComparerT).)
Public method | Start | Starts item processing. (Inherited from ProcessQueueT.)
Public method | Stop | Stops item processing. (Inherited from ProcessQueueT.)
Public method | ToArray | Copies the elements contained in the ProcessQueueT to a new array. (Inherited from ProcessQueueT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrueForAll | Determines whether every element in the ProcessQueueT matches the conditions defined by the specified predicate. (Inherited from ProcessQueueT.)
Public method | TryGetValue | Gets the value associated with the specified key.
Public method | TryTake(T) | Attempts to remove and return an object from the ProcessQueueT. (Inherited from ProcessQueueT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByKeyValuePairTKey, TValue, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairTKey, TValue, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(FuncKeyValuePairTKey, TValue, KeyValuePairTKey, TValue, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairTKey, TValue(IComparerKeyValuePairTKey, TValue) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairTKey, TValue, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairTKey, TValue(KeyValuePairTKey, TValue) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairTKey, TValue(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Add Method

Grid Solutions Framework ProcessDictionaryTKey, TValueAdd Method
Overload List
 | Name | Description
Public method | Add(T) | Adds an item to the ProcessQueueT. (Inherited from ProcessQueueT.)
Public method | Add(TKey, TValue) | Adds an element with the provided key and value to the ProcessDictionaryTKey, TValue.
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Add Method (TKey, TValue)

Grid Solutions Framework ProcessDictionaryTKey, TValueAdd Method (TKey, TValue)
Adds an element with the provided key and value to the ProcessDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    TKey key,
    TValue value
)
Public Sub Add (
    key As TKey,
    value As TValue
)
abstract Add :
        key : 'TKey *
        value : 'TValue -> unit
override Add :
        key : 'TKey *
        value : 'TValue -> unit
function Add(key, value);
public:
virtual void Add(
    TKey key,
    TValue value
) sealed

Parameters

key
Type: TKey
The object to use as the key of the element to add.
value
Type: TValue
The object to use as the value of the element to add.

Implements

IDictionaryTKey, TValueAdd(TKey, TValue)
Exceptions
Exception | Condition
NotSupportedException | The ProcessDictionaryTKey, TValue is read-only.
ArgumentException | An element with the same key already exists in the ProcessDictionaryTKey, TValue.
ArgumentNullException | key is null.
See Also

Reference

ProcessDictionaryTKey, TValue Class
Add Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).AddOrUpdate Method

Grid Solutions Framework ProcessDictionaryTKey, TValueAddOrUpdate Method
Overload List
 | Name | Description
Public method | AddOrUpdate(TKey, FuncTKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, FuncTKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Public method | AddOrUpdate(TKey, TValue, FuncTKey, TValue, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).AddOrUpdate Method (TKey, Func(TKey, TValue))

Grid Solutions Framework ProcessDictionaryTKey, TValueAddOrUpdate Method (TKey, FuncTKey, TValue)
Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue AddOrUpdate(
    TKey key,
    Func<TKey, TValue> valueFactory
)
Public Function AddOrUpdate (
    key As TKey,
    valueFactory As Func(Of TKey, TValue)
) As TValue
member AddOrUpdate :
        key : 'TKey *
        valueFactory : Func<'TKey, 'TValue> -> 'TValue

function AddOrUpdate(key, valueFactory);
public:
TValue AddOrUpdate(
    TKey key,
    Func<TKey, TValue>^ valueFactory
)

Parameters

key
Type: TKey
The key to be added or updated.
valueFactory
Type: SystemFunc TKey, TValue
The function used to generate a value for the key.

Return Value

Type: TValue
The value of the key in the dictionary after updating.
See Also

Reference

ProcessDictionaryTKey, TValue Class
AddOrUpdate Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).AddOrUpdate Method (TKey, TValue)

Grid Solutions Framework ProcessDictionaryTKey, TValueAddOrUpdate Method (TKey, TValue)
Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue AddOrUpdate(
    TKey key,
    TValue value
)
Public Function AddOrUpdate (
    key As TKey,
    value As TValue
) As TValue
member AddOrUpdate :
        key : 'TKey *
        value : 'TValue -> 'TValue

function AddOrUpdate(key, value);
public:
TValue AddOrUpdate(
    TKey key,
    TValue value
)

Parameters

key
Type: TKey
The key to be added or updated.
value
Type: TValue
The value to be assigned to the key.

Return Value

Type: TValue
The value of the key in the dictionary after updating.
See Also

Reference

ProcessDictionaryTKey, TValue Class
AddOrUpdate Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).AddOrUpdate Method (TKey, Func(TKey, TValue), Func(TKey, TValue, TValue))

Grid Solutions Framework ProcessDictionaryTKey, TValueAddOrUpdate Method (TKey, FuncTKey, TValue, FuncTKey, TValue, TValue)
Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue AddOrUpdate(
    TKey key,
    Func<TKey, TValue> addValueFactory,
    Func<TKey, TValue, TValue> updateValueFactory
)
Public Function AddOrUpdate (
    key As TKey,
    addValueFactory As Func(Of TKey, TValue),
    updateValueFactory As Func(Of TKey, TValue, TValue)
) As TValue
member AddOrUpdate :
        key : 'TKey *
        addValueFactory : Func<'TKey, 'TValue> *
        updateValueFactory : Func<'TKey, 'TValue, 'TValue> -> 'TValue

function AddOrUpdate(key, addValueFactory, updateValueFactory);
public:
TValue AddOrUpdate(
    TKey key,
    Func<TKey, TValue>^ addValueFactory,
    Func<TKey, TValue, TValue>^ updateValueFactory
)

Parameters

key
Type: TKey
The key to be added or whose value should be updated
addValueFactory
Type: SystemFunc TKey, TValue
The function used to generate a value for an absent key
updateValueFactory
Type: SystemFunc TKey, TValue, TValue
The function used to generate a new value for an existing key based on the key's existing value

Return Value

Type: TValue
The new value for the key. This will be either be the result of addValueFactory (if the key was absent) or the result of updateValueFactory (if the key was present).
See Also

Reference

ProcessDictionaryTKey, TValue Class
AddOrUpdate Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).AddOrUpdate Method (TKey, TValue, Func(TKey, TValue, TValue))

Grid Solutions Framework ProcessDictionaryTKey, TValueAddOrUpdate Method (TKey, TValue, FuncTKey, TValue, TValue)
Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist, or updates a key/value pair in the ProcessDictionaryTKey, TValue if the key already exists.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue AddOrUpdate(
    TKey key,
    TValue addValue,
    Func<TKey, TValue, TValue> updateValueFactory
)
Public Function AddOrUpdate (
    key As TKey,
    addValue As TValue,
    updateValueFactory As Func(Of TKey, TValue, TValue)
) As TValue
member AddOrUpdate :
        key : 'TKey *
        addValue : 'TValue *
        updateValueFactory : Func<'TKey, 'TValue, 'TValue> -> 'TValue

function AddOrUpdate(key, addValue, updateValueFactory);
public:
TValue AddOrUpdate(
    TKey key,
    TValue addValue,
    Func<TKey, TValue, TValue>^ updateValueFactory
)

Parameters

key
Type: TKey
The key to be added or whose value should be updated
addValue
Type: TValue
The value to be added for an absent key
updateValueFactory
Type: SystemFunc TKey, TValue, TValue
The function used to generate a new value for an existing key based on the key's existing value

Return Value

Type: TValue
The new value for the key. This will be either be the result of addValueFactory (if the key was absent) or the result of updateValueFactory (if the key was present).
See Also

Reference

ProcessDictionaryTKey, TValue Class
AddOrUpdate Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).BinarySearch Method

Grid Solutions Framework ProcessDictionaryTKey, TValueBinarySearch Method
Overload List
 | Name | Description
Public method | BinarySearch(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(T).)
Public method | BinarySearch(KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(T, IComparerT).)
Public method | BinarySearch(Int32, Int32, KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTBinarySearch(Int32, Int32, T, IComparerT).)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).BinarySearch Method (KeyValuePair(TKey, TValue))

Grid Solutions Framework ProcessDictionaryTKey, TValueBinarySearch Method (KeyValuePairTKey, TValue)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int BinarySearch(
    KeyValuePair<TKey, TValue> item
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function BinarySearch (
    item As KeyValuePair(Of TKey, TValue)
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BinarySearch :
        item : KeyValuePair<'TKey, 'TValue> -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BinarySearch :
        item : KeyValuePair<'TKey, 'TValue> -> int
function BinarySearch(item);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int BinarySearch(
    KeyValuePair<TKey, TValue> item
) override

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate. The value can be null for reference types.

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.
See Also

Reference

ProcessDictionaryTKey, TValue Class
BinarySearch Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).BinarySearch Method (KeyValuePair(TKey, TValue), IComparer(KeyValuePair(TKey, TValue)))

Grid Solutions Framework ProcessDictionaryTKey, TValueBinarySearch Method (KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int BinarySearch(
    KeyValuePair<TKey, TValue> item,
    IComparer<KeyValuePair<TKey, TValue>> comparer
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function BinarySearch (
    item As KeyValuePair(Of TKey, TValue),
    comparer As IComparer(Of KeyValuePair(Of TKey, TValue))
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BinarySearch :
        item : KeyValuePair<'TKey, 'TValue> *
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BinarySearch :
        item : KeyValuePair<'TKey, 'TValue> *
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> int
function BinarySearch(item, comparer);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int BinarySearch(
    KeyValuePair<TKey, TValue> item,
    IComparer<KeyValuePair<TKey, TValue>>^ comparer
) override

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate. The value can be null for reference types.
comparer
Type: System.Collections.GenericIComparer KeyValuePair TKey, TValue
The Generic.IComparer implementation to use when comparing elements -or- null to use the default comparer: Generic.Comparer(Of T).Default

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.
See Also

Reference

ProcessDictionaryTKey, TValue Class
BinarySearch Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).BinarySearch Method (Int32, Int32, KeyValuePair(TKey, TValue), IComparer(KeyValuePair(TKey, TValue)))

Grid Solutions Framework ProcessDictionaryTKey, TValueBinarySearch Method (Int32, Int32, KeyValuePairTKey, TValue, IComparerKeyValuePairTKey, TValue)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int BinarySearch(
    int index,
    int count,
    KeyValuePair<TKey, TValue> item,
    IComparer<KeyValuePair<TKey, TValue>> comparer
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function BinarySearch (
    index As Integer,
    count As Integer,
    item As KeyValuePair(Of TKey, TValue),
    comparer As IComparer(Of KeyValuePair(Of TKey, TValue))
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BinarySearch :
        index : int *
        count : int *
        item : KeyValuePair<'TKey, 'TValue> *
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BinarySearch :
        index : int *
        count : int *
        item : KeyValuePair<'TKey, 'TValue> *
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> int
function BinarySearch(index, count, item, comparer);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int BinarySearch(
    int index,
    int count,
    KeyValuePair<TKey, TValue> item,
    IComparer<KeyValuePair<TKey, TValue>>^ comparer
) override

Parameters

index
Type: SystemInt32
The zero-based starting index of the range to search.
count
Type: SystemInt32
The length of the range to search.
item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate. The value can be null for reference types.
comparer
Type: System.Collections.GenericIComparer KeyValuePair TKey, TValue
The Generic.IComparer implementation to use when comparing elements -or- null to use the default comparer: Generic.Comparer(Of T).Default

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.
See Also

Reference

ProcessDictionaryTKey, TValue Class
BinarySearch Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).ContainsKey Method

Grid Solutions Framework ProcessDictionaryTKey, TValueContainsKey Method
Determines whether the ProcessDictionaryTKey, TValue contains an element with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ContainsKey(
    TKey key
)
Public Function ContainsKey (
    key As TKey
) As Boolean
abstract ContainsKey :
        key : 'TKey -> bool
override ContainsKey :
        key : 'TKey -> bool
function ContainsKey(key);
public:
virtual bool ContainsKey(
    TKey key
) sealed

Parameters

key
Type: TKey
The key to locate in the ProcessDictionaryTKey, TValue.

Return Value

Type: Boolean
True, if the ProcessDictionaryTKey, TValue contains an element with the key; otherwise, false.

Implements

IDictionaryTKey, TValueContainsKey(TKey)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).ContainsValue Method

Grid Solutions Framework ProcessDictionaryTKey, TValueContainsValue Method
Determines whether the ProcessDictionaryTKey, TValue contains an element with the specified value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ContainsValue(
    TValue value
)
Public Function ContainsValue (
    value As TValue
) As Boolean
member ContainsValue :
        value : 'TValue -> bool

function ContainsValue(value);
public:
bool ContainsValue(
    TValue value
)

Parameters

value
Type: TValue
The value to locate in the ProcessDictionaryTKey, TValue.

Return Value

Type: Boolean
True, if the ProcessDictionaryTKey, TValue contains an element with the value; otherwise, false.
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Dispose Method

Grid Solutions Framework ProcessDictionaryTKey, TValueDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ProcessQueueT object. (Inherited from ProcessQueueT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessDictionaryTKey, TValue object and optionally releases the managed resources. (Overrides ProcessQueueTDispose(Boolean).)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Dispose Method (Boolean)

Grid Solutions Framework ProcessDictionaryTKey, TValueDispose Method (Boolean)
Releases the unmanaged resources used by the ProcessDictionaryTKey, TValue object and optionally releases the managed resources.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ProcessDictionaryTKey, TValue Class
Dispose Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).GetOrAdd Method

Grid Solutions Framework ProcessDictionaryTKey, TValueGetOrAdd Method
Overload List
 | Name | Description
Public method | GetOrAdd(TKey, FuncTKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.
Public method | GetOrAdd(TKey, TValue) | Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).GetOrAdd Method (TKey, Func(TKey, TValue))

Grid Solutions Framework ProcessDictionaryTKey, TValueGetOrAdd Method (TKey, FuncTKey, TValue)
Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue GetOrAdd(
    TKey key,
    Func<TKey, TValue> valueFactory
)
Public Function GetOrAdd (
    key As TKey,
    valueFactory As Func(Of TKey, TValue)
) As TValue
member GetOrAdd :
        key : 'TKey *
        valueFactory : Func<'TKey, 'TValue> -> 'TValue

function GetOrAdd(key, valueFactory);
public:
TValue GetOrAdd(
    TKey key,
    Func<TKey, TValue>^ valueFactory
)

Parameters

key
Type: TKey
The key to be added to the dictionary if it does not already exist.
valueFactory
Type: SystemFunc TKey, TValue
The function used to generate a value for the key.

Return Value

Type: TValue
The value of the key in the dictionary.
See Also

Reference

ProcessDictionaryTKey, TValue Class
GetOrAdd Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).GetOrAdd Method (TKey, TValue)

Grid Solutions Framework ProcessDictionaryTKey, TValueGetOrAdd Method (TKey, TValue)
Adds a key/value pair to the ProcessDictionaryTKey, TValue if the key does not already exist.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue GetOrAdd(
    TKey key,
    TValue value
)
Public Function GetOrAdd (
    key As TKey,
    value As TValue
) As TValue
member GetOrAdd :
        key : 'TKey *
        value : 'TValue -> 'TValue

function GetOrAdd(key, value);
public:
TValue GetOrAdd(
    TKey key,
    TValue value
)

Parameters

key
Type: TKey
The key to be added to the dictionary if it does not already exist.
value
Type: TValue
The value to assign to the key if the key does not already exist.

Return Value

Type: TValue
The value of the key in the dictionary.
See Also

Reference

ProcessDictionaryTKey, TValue Class
GetOrAdd Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).IndexOf Method

Grid Solutions Framework ProcessDictionaryTKey, TValueIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTIndexOf(T).)
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element. (Inherited from ProcessQueueT.)
Public method | IndexOf(KeyValuePairTKey, TValue, Int32, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTIndexOf(T, Int32, Int32).)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).IndexOf Method (KeyValuePair(TKey, TValue))

Grid Solutions Framework ProcessDictionaryTKey, TValueIndexOf Method (KeyValuePairTKey, TValue)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int IndexOf(
    KeyValuePair<TKey, TValue> item
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function IndexOf (
    item As KeyValuePair(Of TKey, TValue)
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract IndexOf :
        item : KeyValuePair<'TKey, 'TValue> -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override IndexOf :
        item : KeyValuePair<'TKey, 'TValue> -> int
function IndexOf(item);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int IndexOf(
    KeyValuePair<TKey, TValue> item
) override

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the ProcessQueueT. The value can be null for reference types.

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.

Implements

IListTIndexOf(T)
See Also

Reference

ProcessDictionaryTKey, TValue Class
IndexOf Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).IndexOf Method (KeyValuePair(TKey, TValue), Int32, Int32)

Grid Solutions Framework ProcessDictionaryTKey, TValueIndexOf Method (KeyValuePairTKey, TValue, Int32, Int32)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int IndexOf(
    KeyValuePair<TKey, TValue> item,
    int index,
    int count
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function IndexOf (
    item As KeyValuePair(Of TKey, TValue),
    index As Integer,
    count As Integer
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract IndexOf :
        item : KeyValuePair<'TKey, 'TValue> *
        index : int *
        count : int -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override IndexOf :
        item : KeyValuePair<'TKey, 'TValue> *
        index : int *
        count : int -> int
function IndexOf(item, index, count);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int IndexOf(
    KeyValuePair<TKey, TValue> item,
    int index,
    int count
) override

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the ProcessQueueT. The value can be null for reference types.
index
Type: SystemInt32
The zero-based starting index of the search.
count
Type: SystemInt32
The number of elements in the section to search.

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.
See Also

Reference

ProcessDictionaryTKey, TValue Class
IndexOf Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).IndexOfKey Method

Grid Solutions Framework ProcessDictionaryTKey, TValueIndexOfKey Method
Searches for the specified key and returns the zero-based index within the entire ProcessDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOfKey(
    TKey key
)
Public Function IndexOfKey (
    key As TKey
) As Integer
member IndexOfKey :
        key : 'TKey -> int

function IndexOfKey(key);
public:
int IndexOfKey(
    TKey key
)

Parameters

key
Type: TKey
The key to locate in the ProcessDictionaryTKey, TValue.

Return Value

Type: Int32
The zero-based index of key within the entire ProcessDictionaryTKey, TValue, if found; otherwise, -1.
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).IndexOfValue Method

Grid Solutions Framework ProcessDictionaryTKey, TValueIndexOfValue Method
Searches for the specified value and returns the zero-based index of the first occurrence within the entire ProcessDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOfValue(
    TValue value
)
Public Function IndexOfValue (
    value As TValue
) As Integer
member IndexOfValue :
        value : 'TValue -> int

function IndexOfValue(value);
public:
int IndexOfValue(
    TValue value
)

Parameters

value
Type: TValue
The value to locate in the ProcessDictionaryTKey, TValue. The value can be null for reference types.

Return Value

Type: Int32
The zero-based index of the first occurrence of value within the entire ProcessDictionaryTKey, TValue, if found; otherwise, -1.
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).LastIndexOf Method

Grid Solutions Framework ProcessDictionaryTKey, TValueLastIndexOf Method
Overload List
 | Name | Description
Public method | LastIndexOf(KeyValuePairTKey, TValue) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T).)
Public method | LastIndexOf(KeyValuePairTKey, TValue, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T, Int32).)
Public method | LastIndexOf(KeyValuePairTKey, TValue, Int32, Int32) | This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called. (Overrides ProcessQueueTLastIndexOf(T, Int32, Int32).)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).LastIndexOf Method (KeyValuePair(TKey, TValue))

Grid Solutions Framework ProcessDictionaryTKey, TValueLastIndexOf Method (KeyValuePairTKey, TValue)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int LastIndexOf(
    KeyValuePair<TKey, TValue> item
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function LastIndexOf (
    item As KeyValuePair(Of TKey, TValue)
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract LastIndexOf :
        item : KeyValuePair<'TKey, 'TValue> -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override LastIndexOf :
        item : KeyValuePair<'TKey, 'TValue> -> int
function LastIndexOf(item);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int LastIndexOf(
    KeyValuePair<TKey, TValue> item
) override

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the ProcessQueueT. The value can be null for reference types.

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.
See Also

Reference

ProcessDictionaryTKey, TValue Class
LastIndexOf Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).LastIndexOf Method (KeyValuePair(TKey, TValue), Int32)

Grid Solutions Framework ProcessDictionaryTKey, TValueLastIndexOf Method (KeyValuePairTKey, TValue, Int32)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int LastIndexOf(
    KeyValuePair<TKey, TValue> item,
    int index
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function LastIndexOf (
    item As KeyValuePair(Of TKey, TValue),
    index As Integer
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract LastIndexOf :
        item : KeyValuePair<'TKey, 'TValue> *
        index : int -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override LastIndexOf :
        item : KeyValuePair<'TKey, 'TValue> *
        index : int -> int
function LastIndexOf(item, index);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int LastIndexOf(
    KeyValuePair<TKey, TValue> item,
    int index
) override

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the ProcessQueueT. The value can be null for reference types.
index
Type: SystemInt32
The zero-based starting index of the backward search.

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.
See Also

Reference

ProcessDictionaryTKey, TValue Class
LastIndexOf Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).LastIndexOf Method (KeyValuePair(TKey, TValue), Int32, Int32)

Grid Solutions Framework ProcessDictionaryTKey, TValueLastIndexOf Method (KeyValuePairTKey, TValue, Int32, Int32)
This function doesn't have the same meaning in the ProcessDictionaryTKey, TValue as it does in ProcessQueueT, so it is marked as hidden from the editor. However it returns IndexOfKey(TKey) so that it returns a value that at least makes sense in case it gets called.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int LastIndexOf(
    KeyValuePair<TKey, TValue> item,
    int index,
    int count
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function LastIndexOf (
    item As KeyValuePair(Of TKey, TValue),
    index As Integer,
    count As Integer
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract LastIndexOf :
        item : KeyValuePair<'TKey, 'TValue> *
        index : int *
        count : int -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override LastIndexOf :
        item : KeyValuePair<'TKey, 'TValue> *
        index : int *
        count : int -> int
function LastIndexOf(item, index, count);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int LastIndexOf(
    KeyValuePair<TKey, TValue> item,
    int index,
    int count
) override

Parameters

item
Type: System.Collections.GenericKeyValuePair TKey, TValue
The object to locate in the ProcessQueueT. The value can be null for reference types.
index
Type: SystemInt32
The zero-based starting index of the backward search.
count
Type: SystemInt32
The number of elements in the section to search.

Return Value

Type: Int32
This method returns an Int32 that is the index of the item.Key.
See Also

Reference

ProcessDictionaryTKey, TValue Class
LastIndexOf Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Remove Method

Grid Solutions Framework ProcessDictionaryTKey, TValueRemove Method
Overload List
 | Name | Description
Public method | Remove(TKey) | Removes the element with the specified key from the ProcessDictionaryTKey, TValue.
Public method | Remove(T) | Removes the first occurrence of a specific object from the ProcessQueueT. (Inherited from ProcessQueueT.)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Remove Method (TKey)

Grid Solutions Framework ProcessDictionaryTKey, TValueRemove Method (TKey)
Removes the element with the specified key from the ProcessDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    TKey key
)
Public Function Remove (
    key As TKey
) As Boolean
abstract Remove :
        key : 'TKey -> bool
override Remove :
        key : 'TKey -> bool
function Remove(key);
public:
virtual bool Remove(
    TKey key
) sealed

Parameters

key
Type: TKey
The key of the element to remove.

Return Value

Type: Boolean
This method returns a Boolean value indicating whether the item was removed.

Implements

IDictionaryTKey, TValueRemove(TKey)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

ProcessDictionaryTKey, TValue Class
Remove Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Sort Method

Grid Solutions Framework ProcessDictionaryTKey, TValueSort Method
Overload List
 | Name | Description
Public method | Sort | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort.)
Public method | Sort(IComparerKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(IComparerT).)
Public method | Sort(ComparisonKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(ComparisonT).)
Public method | Sort(Int32, Int32, IComparerKeyValuePairTKey, TValue) | ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor. (Overrides ProcessQueueTSort(Int32, Int32, IComparerT).)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Sort Method

Grid Solutions Framework ProcessDictionaryTKey, TValueSort Method
ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override void Sort()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Sub Sort
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Sort : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Sort : unit -> unit
function Sort();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void Sort() override
See Also

Reference

ProcessDictionaryTKey, TValue Class
Sort Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Sort Method (IComparer(KeyValuePair(TKey, TValue)))

Grid Solutions Framework ProcessDictionaryTKey, TValueSort Method (IComparerKeyValuePairTKey, TValue)
ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override void Sort(
    IComparer<KeyValuePair<TKey, TValue>> comparer
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Sub Sort (
    comparer As IComparer(Of KeyValuePair(Of TKey, TValue))
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Sort :
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Sort :
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> unit
function Sort(comparer);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void Sort(
    IComparer<KeyValuePair<TKey, TValue>>^ comparer
) override

Parameters

comparer
Type: System.Collections.GenericIComparer KeyValuePair TKey, TValue
The Generic.IComparer implementation to use when comparing elements -or- null to use the default comparer: Generic.Comparer(Of T).Default
See Also

Reference

ProcessDictionaryTKey, TValue Class
Sort Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Sort Method (Comparison(KeyValuePair(TKey, TValue)))

Grid Solutions Framework ProcessDictionaryTKey, TValueSort Method (ComparisonKeyValuePairTKey, TValue)
ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override void Sort(
    Comparison<KeyValuePair<TKey, TValue>> comparison
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Sub Sort (
    comparison As Comparison(Of KeyValuePair(Of TKey, TValue))
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Sort :
        comparison : Comparison<KeyValuePair<'TKey, 'TValue>> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Sort :
        comparison : Comparison<KeyValuePair<'TKey, 'TValue>> -> unit
function Sort(comparison);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void Sort(
    Comparison<KeyValuePair<TKey, TValue>>^ comparison
) override

Parameters

comparison
Type: SystemComparison KeyValuePair TKey, TValue
The comparison to use when comparing elements.
See Also

Reference

ProcessDictionaryTKey, TValue Class
Sort Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Sort Method (Int32, Int32, IComparer(KeyValuePair(TKey, TValue)))

Grid Solutions Framework ProcessDictionaryTKey, TValueSort Method (Int32, Int32, IComparerKeyValuePairTKey, TValue)
ProcessDictionaryTKey, TValue is based on a DictionaryListTKey, TValue which is already sorted, so calling this function has no effect. As a result this function is marked as hidden from the editor.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override void Sort(
    int index,
    int count,
    IComparer<KeyValuePair<TKey, TValue>> comparer
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Sub Sort (
    index As Integer,
    count As Integer,
    comparer As IComparer(Of KeyValuePair(Of TKey, TValue))
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Sort :
        index : int *
        count : int *
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Sort :
        index : int *
        count : int *
        comparer : IComparer<KeyValuePair<'TKey, 'TValue>> -> unit
function Sort(index, count, comparer);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void Sort(
    int index,
    int count,
    IComparer<KeyValuePair<TKey, TValue>>^ comparer
) override

Parameters

index
Type: SystemInt32
The zero-based starting index of the range to search.
count
Type: SystemInt32
The length of the range to search.
comparer
Type: System.Collections.GenericIComparer KeyValuePair TKey, TValue
The Generic.IComparer implementation to use when comparing elements -or- null to use the default comparer: Generic.Comparer(Of T).Default
See Also

Reference

ProcessDictionaryTKey, TValue Class
Sort Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).TryGetValue Method

Grid Solutions Framework ProcessDictionaryTKey, TValueTryGetValue Method
Gets the value associated with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetValue(
    TKey key,
    out TValue value
)
Public Function TryGetValue (
    key As TKey,
    <OutAttribute> ByRef value As TValue
) As Boolean
abstract TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
override TryGetValue :
        key : 'TKey *
        value : 'TValue byref -> bool
function TryGetValue(key, value);
public:
virtual bool TryGetValue(
    TKey key,
    [OutAttribute] TValue% value
) sealed

Parameters

key
Type: TKey
The key of the value to get.
value
Type: TValue
When this method returns, contains the value associated with the specified key, if the key is found; otherwise, the default value for the type of the value parameter. This parameter is passed uninitialized.

Return Value

Type: Boolean
True, if the ProcessDictionaryTKey, TValue contains an element with the specified key; otherwise, false.

Implements

IDictionaryTKey, TValueTryGetValue(TKey, TValue)
Exceptions
Exception | Condition
ArgumentNullException | key is null.
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Properties

Grid Solutions Framework ProcessDictionaryTKey, TValue Properties

The ProcessDictionaryTKey, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | CanProcessItemFunction | Gets or sets the user function used to determine if an item is ready to be processed.
Public property | Count | Gets the number of elements actually contained in the ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | CurrentStatistics | Gets the current run-time statistics of the ProcessQueueT as a single group of values. (Inherited from ProcessQueueT.)
Public property | Enabled | Gets or sets indicator that the ProcessQueueT is currently enabled. (Inherited from ProcessQueueT.)
Protected property | InternalDictionary | Gets the internal sorted dictionary for direct use by derived classes.
Protected property | InternalEnumerable | Allows derived classes to access the interfaced internal ProcessQueueT directly. (Inherited from ProcessQueueT.)
Protected property | InternalList | Gets the internal list for direct use by ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ProcessQueueT.)
Public property | IsEmpty | Gets a value that indicates whether the ProcessQueueT is empty. (Inherited from ProcessQueueT.)
Public property | IsProcessing | Gets indicator that the ProcessQueueT is actively processing items. (Inherited from ProcessQueueT.)
Public property | IsReadOnly | Gets a value indicating whether the ProcessQueueT is read-only. (Inherited from ProcessQueueT.)
Public property | IsSynchronized | Gets a value indicating whether access to the ProcessQueueT is synchronized (thread safe). Always returns true for ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | ItemTKey | Gets or sets the value associated with the specified key.
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from ProcessQueueT.)
Public property | ItemsBeingProcessed | Gets the total number of items currently being processed. (Inherited from ProcessQueueT.)
Public property | Keys | Gets an ICollection containing the keys of the ProcessDictionaryTKey, TValue.
Public property | MaximumThreads | Gets or sets the maximum number of threads to process simultaneously. (Inherited from ProcessQueueT.)
Public property | Name | Gets the class name. (Overrides ProcessQueueTName.)
Public property | ProcessingIsRealTime | Gets indicator that items will be processed in real-time. (Inherited from ProcessQueueT.)
Public property | ProcessingStyle | Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once). (Inherited from ProcessQueueT.)
Public property | ProcessInterval | Gets or sets the interval, in milliseconds, on which new items begin processing. (Inherited from ProcessQueueT.)
Public property | ProcessItemFunction | Gets or sets the user function used to process items in the list one at a time.
Public property | ProcessItemsFunction | Gets or sets the user function used to process multiple items in the list at once. (Overrides ProcessQueueTProcessItemsFunction.)
Public property | ProcessTimeout | Gets or sets the maximum time, in milliseconds, allowed for processing an item. (Inherited from ProcessQueueT.)
Public property | RequeueModeOnException | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after an exception occurs while processing. (Inherited from ProcessQueueT.)
Public property | RequeueModeOnTimeout | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after processing times out. (Inherited from ProcessQueueT.)
Public property | RequeueOnException | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if an exception occurs while processing. (Inherited from ProcessQueueT.)
Public property | RequeueOnTimeout | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if the processing times out. (Inherited from ProcessQueueT.)
Public property | RunTime | Gets the total amount of time, in seconds, that the ProcessQueueT has been active. (Inherited from ProcessQueueT.)
Public property | Status | Gets current status of ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | SynchronizedOperationType | Gets or sets the type of synchronized operation used to process items in a real-time ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ProcessQueueT. (Inherited from ProcessQueueT.)
Public property | ThreadCount | Gets the current number of active threads. (Inherited from ProcessQueueT.)
Public property | ThreadingMode | Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous). (Inherited from ProcessQueueT.)
Public property | TotalFunctionCalls | Gets the total number of calls to ProcessItemFunction or ProcessItemsFunction. (Inherited from ProcessQueueT.)
Public property | TotalProcessedItems | Gets the total number of items processed so far. (Inherited from ProcessQueueT.)
Public property | Values | Gets an ICollection containing the values of the ProcessDictionaryTKey, TValue.
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).CanProcessItemFunction Property

Grid Solutions Framework ProcessDictionaryTKey, TValueCanProcessItemFunction Property
Gets or sets the user function used to determine if an item is ready to be processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature CanProcessItemFunction { get; set; }
Public Overridable Property CanProcessItemFunction As ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature
    Get
    Set
abstract CanProcessItemFunction : ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature with get, set
override CanProcessItemFunction : ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature with get, set
function get_CanProcessItemFunction();
function set_CanProcessItemFunction(value);
public:
virtual property ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature^ CanProcessItemFunction {
    ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature^ get ();
    void set (ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature^ value);
}

Property Value

Type: ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).InternalDictionary Property

Grid Solutions Framework ProcessDictionaryTKey, TValueInternalDictionary Property
Gets the internal sorted dictionary for direct use by derived classes.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DictionaryList<TKey, TValue> InternalDictionary { get; }
Protected ReadOnly Property InternalDictionary As DictionaryList(Of TKey, TValue)
    Get
member InternalDictionary : DictionaryList<'TKey, 'TValue> with get

function get_InternalDictionary();

protected:
property DictionaryList<TKey, TValue>^ InternalDictionary {
    DictionaryList<TKey, TValue>^ get ();
}

Property Value

Type: DictionaryList TKey, TValue
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Item Property

Grid Solutions Framework ProcessDictionaryTKey, TValueItem Property
Overload List
 | Name | Description
Public property | ItemTKey | Gets or sets the value associated with the specified key.
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from ProcessQueueT.)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Item Property (TKey)

Grid Solutions Framework ProcessDictionaryTKey, TValueItem Property (TKey)
Gets or sets the value associated with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TValue this[
    TKey key
] { get; set; }
Public Default Property Item (
    key As TKey
) As TValue
    Get
    Set
abstract Item : 'TValue with get, set
override Item : 'TValue with get, set
function get_Item(key);
function set_Item(value);
public:
virtual property TValue default[TKey key] {
    TValue get (TKey key) sealed;
    void set (TKey key, TValue value) sealed;
}

Parameters

key
Type: TKey
The key of the value to get or set.

Return Value

Type: TValue
The value associated with the specified key. If the specified key is not found, a get operation throws a KeyNotFoundException, and a set operation creates a new element with the specified key.

Implements

IDictionaryTKey, TValueItemTKey
Exceptions
Exception | Condition
ArgumentNullException | key is null.
KeyNotFoundException | The property is retrieved and key does not exist in the collection.
See Also

Reference

ProcessDictionaryTKey, TValue Class
Item Overload
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Keys Property

Grid Solutions Framework ProcessDictionaryTKey, TValueKeys Property
Gets an ICollection containing the keys of the ProcessDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<TKey> Keys { get; }
Public ReadOnly Property Keys As ICollection(Of TKey)
    Get
abstract Keys : ICollection<'TKey> with get
override Keys : ICollection<'TKey> with get
function get_Keys();

public:
virtual property ICollection<TKey>^ Keys {
    ICollection<TKey>^ get () sealed;
}

Return Value

Type: ICollection TKey
An ICollection containing the keys of the ProcessDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueKeys
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Name Property

Grid Solutions Framework ProcessDictionaryTKey, TValueName Property
Gets the class name.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Name { get; }
Public Overrides ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () override;
}

Return Value

Type: String
Class name.

Implements

IProvideStatusName
Remarks

This name is used for class identification in strings (e.g., used in error message).

Derived classes should override this method with a proper class name.

See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).ProcessItemFunction Property

Grid Solutions Framework ProcessDictionaryTKey, TValueProcessItemFunction Property
Gets or sets the user function used to process items in the list one at a time.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ProcessDictionaryTKey, TValueProcessItemFunctionSignature ProcessItemFunction { get; set; }
Public Overridable Property ProcessItemFunction As ProcessDictionaryTKey, TValueProcessItemFunctionSignature
    Get
    Set
abstract ProcessItemFunction : ProcessDictionaryTKey, TValueProcessItemFunctionSignature with get, set
override ProcessItemFunction : ProcessDictionaryTKey, TValueProcessItemFunctionSignature with get, set
function get_ProcessItemFunction();
function set_ProcessItemFunction(value);
public:
virtual property ProcessDictionaryTKey, TValueProcessItemFunctionSignature^ ProcessItemFunction {
    ProcessDictionaryTKey, TValueProcessItemFunctionSignature^ get ();
    void set (ProcessDictionaryTKey, TValueProcessItemFunctionSignature^ value);
}

Property Value

Type: ProcessDictionaryTKey, TValueProcessItemFunctionSignature
Remarks

This function and ProcessItemFunction cannot be defined at the same time.

A ProcessDictionaryTKey, TValue must be defined to process either a single item at a time or many items at once.

Implementation of this function makes QueueProcessingStyle = OneAtATime.

See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).ProcessItemsFunction Property

Grid Solutions Framework ProcessDictionaryTKey, TValueProcessItemsFunction Property
Gets or sets the user function used to process multiple items in the list at once.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ProcessQueueTProcessItemsFunctionSignature ProcessItemsFunction { get; set; }
Public Overrides Property ProcessItemsFunction As ProcessQueueTProcessItemsFunctionSignature
    Get
    Set
abstract ProcessItemsFunction : ProcessQueueTProcessItemsFunctionSignature with get, set
override ProcessItemsFunction : ProcessQueueTProcessItemsFunctionSignature with get, set
function get_ProcessItemsFunction();
function set_ProcessItemsFunction(value);
public:
virtual property ProcessQueueTProcessItemsFunctionSignature^ ProcessItemsFunction {
    ProcessQueueTProcessItemsFunctionSignature^ get () override;
    void set (ProcessQueueTProcessItemsFunctionSignature^ value) override;
}

Property Value

Type: ProcessQueueTProcessItemsFunctionSignature
Remarks

This function and ProcessItemFunction cannot be defined at the same time.

A ProcessDictionaryTKey, TValue must be defined to process either a single item at a time or many items at once.

Implementation of this function makes QueueProcessingStyle = ManyAtOnce.

See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).Values Property

Grid Solutions Framework ProcessDictionaryTKey, TValueValues Property
Gets an ICollection containing the values of the ProcessDictionaryTKey, TValue.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<TValue> Values { get; }
Public ReadOnly Property Values As ICollection(Of TValue)
    Get
abstract Values : ICollection<'TValue> with get
override Values : ICollection<'TValue> with get
function get_Values();

public:
virtual property ICollection<TValue>^ Values {
    ICollection<TValue>^ get () sealed;
}

Return Value

Type: ICollection TValue
An ICollection containing the values of the ProcessDictionaryTKey, TValue.

Implements

IDictionaryTKey, TValueValues
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue) Events

Grid Solutions Framework ProcessDictionaryTKey, TValue Events

The ProcessDictionaryTKey, TValue generic type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed. (Inherited from ProcessQueueT.)
Public event | ItemProcessed | Event that is raised after an item has been successfully processed. (Inherited from ProcessQueueT.)
Public event | ItemsProcessed | Event that is raised after an array of items have been successfully processed. (Inherited from ProcessQueueT.)
Public event | ItemsTimedOut | Event that is raised if the processing time for an array of items exceeds the specified process timeout. (Inherited from ProcessQueueT.)
Public event | ItemTimedOut | Event that is raised if an item's processing time exceeds the specified process timeout. (Inherited from ProcessQueueT.)
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the ProcessQueueT. (Inherited from ProcessQueueT.)
Top
See Also

Reference

ProcessDictionaryTKey, TValue Class
GSF.Collections Namespace


ProcessDictionary(TKey, TValue).CanProcessItemFunctionSignature Delegate

Grid Solutions Framework ProcessDictionaryTKey, TValueCanProcessItemFunctionSignature Delegate
Function signature that determines if a key and value can be currently processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate bool CanProcessItemFunctionSignature(
    TKey key,
    TValue value
)
Public Delegate Function CanProcessItemFunctionSignature (
    key As TKey,
    value As TValue
) As Boolean
type CanProcessItemFunctionSignature =
    delegate of
        key : 'TKey *
        value : 'TValue -> bool
function(key, value);
public delegate bool CanProcessItemFunctionSignature(
    TKey key,
    TValue value
)

Parameters

key
Type: TKey
key to be checked for processing availability.
value
Type: TValue
value to be checked for processing availability.

Return Value

Type: Boolean
True, if key and value can be processed.
Remarks

Implementation of this function is optional. It will be assumed that an item can be processed if this function is not defined

Items must eventually get to a state where they can be processed or they will remain in the ProcessDictionaryTKey, TValue indefinitely.

Note that when this function is implemented and QueueProcessingStyle = ManyAtOnce (i.e., ProcessItemsFunction is defined), then each item presented for processing must evaluate as "CanProcessItem = True" before any items are processed.

See Also

Reference

GSF.Collections Namespace


ProcessDictionary(TKey, TValue).ProcessItemFunctionSignature Delegate

Grid Solutions Framework ProcessDictionaryTKey, TValueProcessItemFunctionSignature Delegate
Function signature that defines a method to process a key and value one at a time.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate void ProcessItemFunctionSignature(
    TKey key,
    TValue value
)
Public Delegate Sub ProcessItemFunctionSignature (
    key As TKey,
    value As TValue
)
type ProcessItemFunctionSignature =
    delegate of
        key : 'TKey *
        value : 'TValue -> unit
function(key, value);
public delegate void ProcessItemFunctionSignature(
    TKey key,
    TValue value
)

Parameters

key
Type: TKey
key to be processed.
value
Type: TValue
value to be processed.
Remarks

Required unless ProcessItemsFunction is implemented.

Used when creating a ProcessDictionaryTKey, TValue to process one item at a time.

Asynchronous ProcessDictionaryTKey, TValue will process individual items on multiple threads

See Also

Reference

GSF.Collections Namespace


ProcessQueue(T) Class

Grid Solutions Framework ProcessQueueT Class
Represents a thread-safe (via locking) list of items, based on ListT, that get processed on independent threads with a consumer provided function.
Inheritance Hierarchy
SystemObject
GSF.CollectionsProcessQueueT
GSF.CollectionsProcessDictionaryTKey, TValue

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ProcessQueue<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, IProvideStatus, ISupportLifecycle,
    IDisposable

Public Class ProcessQueue(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable, IProvideStatus, ISupportLifecycle, IDisposable
type ProcessQueue<'T> =
    class
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
        interface IProvideStatus
        interface ISupportLifecycle
        interface IDisposable
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class ProcessQueue : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, IProvideStatus, ISupportLifecycle,
    IDisposable

Type Parameters

T
Type of object to process

The ProcessQueueT type exposes the following members.

Constructors
 | Name | Description
Public method | ProcessQueueT(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessQueueT based on the generic List(Of T) class.
Public method | ProcessQueueT(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk item ProcessQueueT based on the generic List(Of T) class.
Public method | ProcessQueueT(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessQueueT based on the generic List(Of T) class.
Public method | ProcessQueueT(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk item ProcessQueueT based on the generic List(Of T) class.
Protected method | ProcessQueueT(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, IListT, Double, Int32, Int32, Boolean, Boolean) | Allows derived classes to define their own instance, if desired.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ProcessQueueT.
Public method | AddRange | Adds the elements of the specified collection to the end of the ProcessQueueT.
Public method | BinarySearch(T) | Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the default comparer and returns the zero-based index of the element.
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.
Protected method | CanProcessItem | Determines if an item can be processed.
Protected method | CanProcessItems | Determines if all items can be processed.
Public method | Clear | Removes all elements from the ProcessQueueT.
Public method | Contains | Determines whether an element is in the ProcessQueueT.
Public method | ConvertAllTOutput | Converts the elements in the current ProcessQueueT to another type, and returns a ProcessQueueT containing the converted elements.
Public method | CopyTo | Copies the entire ProcessQueueT to a compatible one-dimensional array, starting at the beginning of the target array.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Int32) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Int32) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous ProcessQueueT using specified settings.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous, bulk item ProcessQueueT using specified settings.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous ProcessQueueT using specified settings.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous, bulk item ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time, bulk item ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time, bulk item ProcessQueueT using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.
Protected method | DataAdded | Notifies queue that data was added and/or modified, so it can begin processing data.
Public method | Dispose | Releases all the resources used by the ProcessQueueT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessQueueT object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ProcessQueueT contains elements that match the conditions defined by the specified predicate.
Protected method | Finalize | Releases the unmanaged resources before the ProcessQueueT object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ProcessQueueT.
Public method | FindAll | Retrieves all elements that match the conditions defined by the specified predicate.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ProcessQueueT.
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ProcessQueueT.
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.
Public method | Flush | Blocks the current thread, if the ProcessQueueT is active (i.e., user has called "Start" method), until all items in ProcessQueueT are processed, and then stops the ProcessQueueT.
Public method | ForEach | Performs the specified action on each element of the ProcessQueueT.
Public method | GetEnumerator | Returns an enumerator that iterates through the ProcessQueueT.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ProcessQueueT.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ProcessQueueT.
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that starts at the specified index and contains the specified number of elements.
Public method | Insert | Inserts an element into the ProcessQueueT at the specified index.
Public method | InsertRange | Inserts the elements of a collection into the ProcessQueueT at the specified index.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ProcessQueueT.
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemProcessed | Raises the base class ItemProcessed event.
Protected method | OnItemsProcessed | Raises the base class ItemsProcessed event.
Protected method | OnItemsTimedOut | Raises the base class ItemsTimedOut event.
Protected method | OnItemTimedOut | Raises the base class ItemTimedOut event.
Protected method | OnProcessException | Raises the base class ProcessException event.
Public method | Remove | Removes the first occurrence of a specific object from the ProcessQueueT.
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate.
Public method | RemoveAt | Removes the element at the specified index of the ProcessQueueT.
Public method | RemoveRange | Removes a range of elements from the ProcessQueueT.
Protected method | RequeueItem | Requeues item into ProcessQueueT according to specified requeue reason.
Protected method | RequeueItems | Requeues items into ProcessQueueT according to specified requeue reason.
Public method | Reverse | Reverses the order of the elements in the entire ProcessQueueT.
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.
Public method | SignalDataModified | Manually signals that data has been modified and processing should resume.
Public method | Sort | Sorts the elements in the entire ProcessQueueT, using the default comparer.
Public method | Sort(IComparerT) | Sorts the elements in the entire ProcessQueueT, using the specified comparer.
Public method | Sort(ComparisonT) | Sorts the elements in the entire ProcessQueueT, using the specified comparison.
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in the ProcessQueueT, using the specified comparer.
Public method | Start | Starts item processing.
Public method | Stop | Stops item processing.
Public method | ToArray | Copies the elements contained in the ProcessQueueT to a new array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrueForAll | Determines whether every element in the ProcessQueueT matches the conditions defined by the specified predicate.
Public method | TryTake(T) | Attempts to remove and return an object from the ProcessQueueT.
Public method | TryTake(T) | Attempts to remove and return all objects from the ProcessQueueT.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Fields
Name | Description
DefaultMaximumThreads | Default maximum number of processing threads.
DefaultProcessInterval | Default processing interval (in milliseconds).
DefaultProcessTimeout | Default processing timeout (in milliseconds).
DefaultRequeueModeOnException | Default setting for requeuing mode on processing exceptions.
DefaultRequeueModeOnTimeout | Default setting for requeuing mode on processing timeout.
DefaultRequeueOnException | Default setting for requeuing items on processing exceptions.
DefaultRequeueOnTimeout | Default setting for requeuing items on processing timeout.
RealTimeProcessInterval | Default real-time processing interval (in milliseconds).
Top
Properties
 | Name | Description
Public property | CanProcessItemFunction | Gets or sets the user function determining if an item is ready to be processed.
Public property | Count | Gets the number of elements actually contained in the ProcessQueueT.
Public property | CurrentStatistics | Gets the current run-time statistics of the ProcessQueueT as a single group of values.
Public property | Enabled | Gets or sets indicator that the ProcessQueueT is currently enabled.
Protected property | InternalEnumerable | Allows derived classes to access the interfaced internal ProcessQueueT directly.
Protected property | InternalList | Gets the internal list for direct use by ProcessQueueT.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsEmpty | Gets a value that indicates whether the ProcessQueueT is empty.
Public property | IsProcessing | Gets indicator that the ProcessQueueT is actively processing items.
Public property | IsReadOnly | Gets a value indicating whether the ProcessQueueT is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ProcessQueueT is synchronized (thread safe). Always returns true for ProcessQueueT.
Public property | Item | Gets or sets the element at the specified index.
Public property | ItemsBeingProcessed | Gets the total number of items currently being processed.
Public property | MaximumThreads | Gets or sets the maximum number of threads to process simultaneously.
Public property | Name | Gets or sets name for this ProcessQueueT.
Public property | ProcessingIsRealTime | Gets indicator that items will be processed in real-time.
Public property | ProcessingStyle | Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once).
Public property | ProcessInterval | Gets or sets the interval, in milliseconds, on which new items begin processing.
Public property | ProcessItemFunction | Gets or sets the user function for processing individual items in the ProcessQueueT one at a time.
Public property | ProcessItemsFunction | Gets or sets the user function for processing multiple items in the ProcessQueueT at once.
Public property | ProcessTimeout | Gets or sets the maximum time, in milliseconds, allowed for processing an item.
Public property | RequeueModeOnException | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after an exception occurs while processing.
Public property | RequeueModeOnTimeout | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after processing times out.
Public property | RequeueOnException | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if an exception occurs while processing.
Public property | RequeueOnTimeout | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if the processing times out.
Public property | RunTime | Gets the total amount of time, in seconds, that the ProcessQueueT has been active.
Public property | Status | Gets current status of ProcessQueueT.
Public property | SynchronizedOperationType | Gets or sets the type of synchronized operation used to process items in a real-time ProcessQueueT.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ProcessQueueT.
Public property | ThreadCount | Gets the current number of active threads.
Public property | ThreadingMode | Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous).
Public property | TotalFunctionCalls | Gets the total number of calls to ProcessItemFunction or ProcessItemsFunction.
Public property | TotalProcessedItems | Gets the total number of items processed so far.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed.
Public event | ItemProcessed | Event that is raised after an item has been successfully processed.
Public event | ItemsProcessed | Event that is raised after an array of items have been successfully processed.
Public event | ItemsTimedOut | Event that is raised if the processing time for an array of items exceeds the specified process timeout.
Public event | ItemTimedOut | Event that is raised if an item's processing time exceeds the specified process timeout.
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the ProcessQueueT.
Top
Remarks

This class acts as a strongly-typed collection of objects to be processed.

Note that the ProcessQueueT will not start processing until the Start method is called.

See Also

Reference

GSF.Collections Namespace


ProcessQueue(T) Constructor

Grid Solutions Framework ProcessQueueT Constructor
Overload List
 | Name | Description
Public method | ProcessQueueT(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessQueueT based on the generic List(Of T) class.
Public method | ProcessQueueT(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk item ProcessQueueT based on the generic List(Of T) class.
Public method | ProcessQueueT(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a ProcessQueueT based on the generic List(Of T) class.
Public method | ProcessQueueT(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a bulk item ProcessQueueT based on the generic List(Of T) class.
Protected method | ProcessQueueT(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, IListT, Double, Int32, Int32, Boolean, Boolean) | Allows derived classes to define their own instance, if desired.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T) Constructor (ProcessQueue(T).ProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueT Constructor (ProcessQueueTProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a ProcessQueueT based on the generic List(Of T) class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessQueue
GSF.Collections.ProcessQueue = function(processItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that defines a method to process one item at a time.
processInterval (Optional)
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads (Optional)
Type: SystemInt32
The maximum number of threads for the queue to use.
processTimeout (Optional)
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.
See Also

Reference

ProcessQueueT Class
ProcessQueueT Overload
GSF.Collections Namespace


ProcessQueue(T) Constructor (ProcessQueue(T).ProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueT Constructor (ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a bulk item ProcessQueueT based on the generic List(Of T) class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessQueue
GSF.Collections.ProcessQueue = function(processItemsFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
processInterval (Optional)
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads (Optional)
Type: SystemInt32
The maximum number of threads for the queue to use.
processTimeout (Optional)
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.
See Also

Reference

ProcessQueueT Class
ProcessQueueT Overload
GSF.Collections Namespace


ProcessQueue(T) Constructor (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueT Constructor (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a ProcessQueueT based on the generic List(Of T) class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction = null,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    Optional canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature = Nothing,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        ?canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _canProcessItemFunction = defaultArg canProcessItemFunction null
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessQueue
GSF.Collections.ProcessQueue = function(processItemFunction, canProcessItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction = nullptr,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that defines a method to process one item at a time.
canProcessItemFunction (Optional)
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate that determines if an item can currently be processed.
processInterval (Optional)
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads (Optional)
Type: SystemInt32
The maximum number of threads for the queue to use.
processTimeout (Optional)
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.
See Also

Reference

ProcessQueueT Class
ProcessQueueT Overload
GSF.Collections Namespace


ProcessQueue(T) Constructor (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueT Constructor (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a bulk item ProcessQueueT based on the generic List(Of T) class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProcessQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction = null,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)
Public Sub New (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    Optional canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature = Nothing,
    Optional processInterval As Double = 100,
    Optional maximumThreads As Integer = 5,
    Optional processTimeout As Integer = -1,
    Optional requeueOnTimeout As Boolean = false,
    Optional requeueOnException As Boolean = false
)
new :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        ?canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        ?processInterval : float *
        ?maximumThreads : int *
        ?processTimeout : int *
        ?requeueOnTimeout : bool *
        ?requeueOnException : bool
(* Defaults:
        let _canProcessItemFunction = defaultArg canProcessItemFunction null
        let _processInterval = defaultArg processInterval 100
        let _maximumThreads = defaultArg maximumThreads 5
        let _processTimeout = defaultArg processTimeout -1
        let _requeueOnTimeout = defaultArg requeueOnTimeout false
        let _requeueOnException = defaultArg requeueOnException false
*)
-> ProcessQueue
GSF.Collections.ProcessQueue = function(processItemsFunction, canProcessItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
ProcessQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction = nullptr,
    double processInterval = 100,
    int maximumThreads = 5,
    int processTimeout = -1,
    bool requeueOnTimeout = false,
    bool requeueOnException = false
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction (Optional)
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate that determines if an item can currently be processed.
processInterval (Optional)
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads (Optional)
Type: SystemInt32
The maximum number of threads for the queue to use.
processTimeout (Optional)
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException (Optional)
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.
See Also

Reference

ProcessQueueT Class
ProcessQueueT Overload
GSF.Collections Namespace


ProcessQueue(T) Constructor (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, IList(T), Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueT Constructor (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, IListT, Double, Int32, Int32, Boolean, Boolean)
Allows derived classes to define their own instance, if desired.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ProcessQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    IList<T> processList,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Protected Sub New (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    processList As IList(Of T),
    processInterval As Double,
    maximumThreads As Integer,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
)
new :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        processList : IList<'T> *
        processInterval : float *
        maximumThreads : int *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue
GSF.Collections.ProcessQueue = function(processItemFunction, processItemsFunction, canProcessItemFunction, processList, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
protected:
ProcessQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    IList<T>^ processList,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that defines a method to process one item at a time.
processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate that determines if an item can currently be processed.
processList
Type: System.Collections.GenericIList T
A storage list for items to be processed.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads
Type: SystemInt32
The maximum number of threads for the queue to use.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.
See Also

Reference

ProcessQueueT Class
ProcessQueueT Overload
GSF.Collections Namespace


ProcessQueue(T) Fields

Grid Solutions Framework ProcessQueueT Fields

The ProcessQueueT generic type exposes the following members.

Fields
Name | Description
DefaultMaximumThreads | Default maximum number of processing threads.
DefaultProcessInterval | Default processing interval (in milliseconds).
DefaultProcessTimeout | Default processing timeout (in milliseconds).
DefaultRequeueModeOnException | Default setting for requeuing mode on processing exceptions.
DefaultRequeueModeOnTimeout | Default setting for requeuing mode on processing timeout.
DefaultRequeueOnException | Default setting for requeuing items on processing exceptions.
DefaultRequeueOnTimeout | Default setting for requeuing items on processing timeout.
RealTimeProcessInterval | Default real-time processing interval (in milliseconds).
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).DefaultMaximumThreads Field

Grid Solutions Framework ProcessQueueTDefaultMaximumThreads Field
Default maximum number of processing threads.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaximumThreads
Public Const DefaultMaximumThreads As Integer
static val mutable DefaultMaximumThreads: int
var GSF.Collections.ProcessQueue.DefaultMaximumThreads
public:
literal int DefaultMaximumThreads

Field Value

Type: Int32
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).DefaultProcessInterval Field

Grid Solutions Framework ProcessQueueTDefaultProcessInterval Field
Default processing interval (in milliseconds).

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultProcessInterval
Public Const DefaultProcessInterval As Integer
static val mutable DefaultProcessInterval: int
var GSF.Collections.ProcessQueue.DefaultProcessInterval
public:
literal int DefaultProcessInterval

Field Value

Type: Int32
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).DefaultProcessTimeout Field

Grid Solutions Framework ProcessQueueTDefaultProcessTimeout Field
Default processing timeout (in milliseconds).

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultProcessTimeout
Public Const DefaultProcessTimeout As Integer
static val mutable DefaultProcessTimeout: int
var GSF.Collections.ProcessQueue.DefaultProcessTimeout
public:
literal int DefaultProcessTimeout

Field Value

Type: Int32
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).DefaultRequeueModeOnException Field

Grid Solutions Framework ProcessQueueTDefaultRequeueModeOnException Field
Default setting for requeuing mode on processing exceptions.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const RequeueMode DefaultRequeueModeOnException
Public Const DefaultRequeueModeOnException As RequeueMode
static val mutable DefaultRequeueModeOnException: RequeueMode
var GSF.Collections.ProcessQueue.DefaultRequeueModeOnException
public:
literal RequeueMode DefaultRequeueModeOnException

Field Value

Type: RequeueMode
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).DefaultRequeueModeOnTimeout Field

Grid Solutions Framework ProcessQueueTDefaultRequeueModeOnTimeout Field
Default setting for requeuing mode on processing timeout.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const RequeueMode DefaultRequeueModeOnTimeout
Public Const DefaultRequeueModeOnTimeout As RequeueMode
static val mutable DefaultRequeueModeOnTimeout: RequeueMode
var GSF.Collections.ProcessQueue.DefaultRequeueModeOnTimeout
public:
literal RequeueMode DefaultRequeueModeOnTimeout

Field Value

Type: RequeueMode
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).DefaultRequeueOnException Field

Grid Solutions Framework ProcessQueueTDefaultRequeueOnException Field
Default setting for requeuing items on processing exceptions.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultRequeueOnException
Public Const DefaultRequeueOnException As Boolean
static val mutable DefaultRequeueOnException: bool
var GSF.Collections.ProcessQueue.DefaultRequeueOnException
public:
literal bool DefaultRequeueOnException

Field Value

Type: Boolean
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).DefaultRequeueOnTimeout Field

Grid Solutions Framework ProcessQueueTDefaultRequeueOnTimeout Field
Default setting for requeuing items on processing timeout.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultRequeueOnTimeout
Public Const DefaultRequeueOnTimeout As Boolean
static val mutable DefaultRequeueOnTimeout: bool
var GSF.Collections.ProcessQueue.DefaultRequeueOnTimeout
public:
literal bool DefaultRequeueOnTimeout

Field Value

Type: Boolean
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RealTimeProcessInterval Field

Grid Solutions Framework ProcessQueueTRealTimeProcessInterval Field
Default real-time processing interval (in milliseconds).

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double RealTimeProcessInterval
Public Const RealTimeProcessInterval As Double
static val mutable RealTimeProcessInterval: float
var GSF.Collections.ProcessQueue.RealTimeProcessInterval
public:
literal double RealTimeProcessInterval

Field Value

Type: Double
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T) Methods

Grid Solutions Framework ProcessQueueT Methods

The ProcessQueueT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ProcessQueueT.
Public method | AddRange | Adds the elements of the specified collection to the end of the ProcessQueueT.
Public method | BinarySearch(T) | Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the default comparer and returns the zero-based index of the element.
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.
Protected method | CanProcessItem | Determines if an item can be processed.
Protected method | CanProcessItems | Determines if all items can be processed.
Public method | Clear | Removes all elements from the ProcessQueueT.
Public method | Contains | Determines whether an element is in the ProcessQueueT.
Public method | ConvertAllTOutput | Converts the elements in the current ProcessQueueT to another type, and returns a ProcessQueueT containing the converted elements.
Public method | CopyTo | Copies the entire ProcessQueueT to a compatible one-dimensional array, starting at the beginning of the target array.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Int32) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Int32) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous ProcessQueueT using specified settings.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous, bulk item ProcessQueueT using specified settings.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous ProcessQueueT using specified settings.
 | CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous, bulk item ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time, bulk item ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time ProcessQueueT using specified settings.
 | CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time, bulk item ProcessQueueT using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.
 | CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.
Protected method | DataAdded | Notifies queue that data was added and/or modified, so it can begin processing data.
Public method | Dispose | Releases all the resources used by the ProcessQueueT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessQueueT object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Determines whether the ProcessQueueT contains elements that match the conditions defined by the specified predicate.
Protected method | Finalize | Releases the unmanaged resources before the ProcessQueueT object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ProcessQueueT.
Public method | FindAll | Retrieves all elements that match the conditions defined by the specified predicate.
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ProcessQueueT.
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ProcessQueueT.
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.
Public method | Flush | Blocks the current thread, if the ProcessQueueT is active (i.e., user has called "Start" method), until all items in ProcessQueueT are processed, and then stops the ProcessQueueT.
Public method | ForEach | Performs the specified action on each element of the ProcessQueueT.
Public method | GetEnumerator | Returns an enumerator that iterates through the ProcessQueueT.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRange | Creates a shallow copy of a range of elements in the source ProcessQueueT.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ProcessQueueT.
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that starts at the specified index and contains the specified number of elements.
Public method | Insert | Inserts an element into the ProcessQueueT at the specified index.
Public method | InsertRange | Inserts the elements of a collection into the ProcessQueueT at the specified index.
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ProcessQueueT.
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnItemProcessed | Raises the base class ItemProcessed event.
Protected method | OnItemsProcessed | Raises the base class ItemsProcessed event.
Protected method | OnItemsTimedOut | Raises the base class ItemsTimedOut event.
Protected method | OnItemTimedOut | Raises the base class ItemTimedOut event.
Protected method | OnProcessException | Raises the base class ProcessException event.
Public method | Remove | Removes the first occurrence of a specific object from the ProcessQueueT.
Public method | RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate.
Public method | RemoveAt | Removes the element at the specified index of the ProcessQueueT.
Public method | RemoveRange | Removes a range of elements from the ProcessQueueT.
Protected method | RequeueItem | Requeues item into ProcessQueueT according to specified requeue reason.
Protected method | RequeueItems | Requeues items into ProcessQueueT according to specified requeue reason.
Public method | Reverse | Reverses the order of the elements in the entire ProcessQueueT.
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.
Public method | SignalDataModified | Manually signals that data has been modified and processing should resume.
Public method | Sort | Sorts the elements in the entire ProcessQueueT, using the default comparer.
Public method | Sort(IComparerT) | Sorts the elements in the entire ProcessQueueT, using the specified comparer.
Public method | Sort(ComparisonT) | Sorts the elements in the entire ProcessQueueT, using the specified comparison.
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in the ProcessQueueT, using the specified comparer.
Public method | Start | Starts item processing.
Public method | Stop | Stops item processing.
Public method | ToArray | Copies the elements contained in the ProcessQueueT to a new array.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TrueForAll | Determines whether every element in the ProcessQueueT matches the conditions defined by the specified predicate.
Public method | TryTake(T) | Attempts to remove and return an object from the ProcessQueueT.
Public method | TryTake(T) | Attempts to remove and return all objects from the ProcessQueueT.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Add Method

Grid Solutions Framework ProcessQueueTAdd Method
Adds an item to the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    T item
)
Public Sub Add (
    item As T
)
abstract Add :
        item : 'T -> unit
override Add :
        item : 'T -> unit
function Add(item);
public:
virtual void Add(
    T item
) sealed

Parameters

item
Type: T
The item to add to the ProcessQueueT.

Implements

ICollectionTAdd(T)
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).AddRange Method

Grid Solutions Framework ProcessQueueTAddRange Method
Adds the elements of the specified collection to the end of the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddRange(
    IEnumerable<T> collection
)
Public Sub AddRange (
    collection As IEnumerable(Of T)
)
member AddRange :
        collection : IEnumerable<'T> -> unit

function AddRange(collection);
public:
void AddRange(
    IEnumerable<T>^ collection
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection whose elements should be added to the end of the ProcessQueueT. The collection itself cannot be null, but it can contain elements that are null, if type T is a reference type.
Exceptions
Exception | Condition
ArgumentNullException | collection is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).BinarySearch Method

Grid Solutions Framework ProcessQueueTBinarySearch Method
Overload List
 | Name | Description
Public method | BinarySearch(T) | Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the default comparer and returns the zero-based index of the element.
Public method | BinarySearch(T, IComparerT) | Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.
Public method | BinarySearch(Int32, Int32, T, IComparerT) | Searches a range of elements in the sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).BinarySearch Method (T)

Grid Solutions Framework ProcessQueueTBinarySearch Method (T)
Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the default comparer and returns the zero-based index of the element.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int BinarySearch(
    T item
)
Public Overridable Function BinarySearch (
    item As T
) As Integer
abstract BinarySearch :
        item : 'T -> int
override BinarySearch :
        item : 'T -> int
function BinarySearch(item);
public:
virtual int BinarySearch(
    T item
)

Parameters

item
Type: T
The object to locate. The value can be null for reference types.

Return Value

Type: Int32
The zero-based index of item in the sorted ProcessQueueT, if item is found; otherwise, a negative number that is the bitwise complement of the index of the next element that is larger than item or, if there is no larger element, the bitwise complement of count.
Exceptions
Exception | Condition
InvalidOperationException | The default comparer, Generic.Comparer.Default, cannot find an implementation of the IComparable generic interface or the IComparable interface for type T.
Remarks
ProcessQueueT must be sorted in order for this function to return an accurate result.
See Also

Reference

ProcessQueueT Class
BinarySearch Overload
GSF.Collections Namespace


ProcessQueue(T).BinarySearch Method (T, IComparer(T))

Grid Solutions Framework ProcessQueueTBinarySearch Method (T, IComparerT)
Searches the entire sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int BinarySearch(
    T item,
    IComparer<T> comparer
)
Public Overridable Function BinarySearch (
    item As T,
    comparer As IComparer(Of T)
) As Integer
abstract BinarySearch :
        item : 'T *
        comparer : IComparer<'T> -> int
override BinarySearch :
        item : 'T *
        comparer : IComparer<'T> -> int
function BinarySearch(item, comparer);
public:
virtual int BinarySearch(
    T item,
    IComparer<T>^ comparer
)

Parameters

item
Type: T
The object to locate. The value can be null for reference types.
comparer
Type: System.Collections.GenericIComparer T
The Generic.IComparer implementation to use when comparing elements -or- null to use the default comparer: Generic.Comparer(Of T).Default

Return Value

Type: Int32
The zero-based index of item in the sorted ProcessQueueT, if item is found; otherwise, a negative number that is the bitwise complement of the index of the next element that is larger than item or, if there is no larger element, the bitwise complement of count.
Exceptions
Exception | Condition
InvalidOperationException | The default comparer, Generic.Comparer.Default, cannot find an implementation of the IComparable generic interface or the IComparable interface for type T.
Remarks
ProcessQueueT must be sorted in order for this function to return an accurate result.
See Also

Reference

ProcessQueueT Class
BinarySearch Overload
GSF.Collections Namespace


ProcessQueue(T).BinarySearch Method (Int32, Int32, T, IComparer(T))

Grid Solutions Framework ProcessQueueTBinarySearch Method (Int32, Int32, T, IComparerT)
Searches a range of elements in the sorted ProcessQueueT, using a binary search algorithm, for an element using the specified comparer and returns the zero-based index of the element.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int BinarySearch(
    int index,
    int count,
    T item,
    IComparer<T> comparer
)
Public Overridable Function BinarySearch (
    index As Integer,
    count As Integer,
    item As T,
    comparer As IComparer(Of T)
) As Integer
abstract BinarySearch :
        index : int *
        count : int *
        item : 'T *
        comparer : IComparer<'T> -> int
override BinarySearch :
        index : int *
        count : int *
        item : 'T *
        comparer : IComparer<'T> -> int
function BinarySearch(index, count, item, comparer);
public:
virtual int BinarySearch(
    int index,
    int count,
    T item,
    IComparer<T>^ comparer
)

Parameters

index
Type: SystemInt32
The zero-based starting index of the range to search.
count
Type: SystemInt32
The length of the range to search.
item
Type: T
The object to locate. The value can be null for reference types.
comparer
Type: System.Collections.GenericIComparer T
The Generic.IComparer implementation to use when comparing elements -or- null to use the default comparer: Generic.Comparer(Of T).Default

Return Value

Type: Int32
The zero-based index of item in the sorted ProcessQueueT, if item is found; otherwise, a negative number that is the bitwise complement of the index of the next element that is larger than item or, if there is no larger element, the bitwise complement of count.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the ProcessQueueT -or- count is less than 0 -or- startIndex and count do not specify a valid section in the ProcessQueueT
InvalidOperationException | The default comparer, Generic.Comparer.Default, cannot find an implementation of the IComparable generic interface or the IComparable interface for type T.
Remarks
ProcessQueueT must be sorted in order for this function to return an accurate result.
See Also

Reference

ProcessQueueT Class
BinarySearch Overload
GSF.Collections Namespace


ProcessQueue(T).CanProcessItem Method

Grid Solutions Framework ProcessQueueTCanProcessItem Method
Determines if an item can be processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool CanProcessItem(
    T item
)
Protected Overridable Function CanProcessItem (
    item As T
) As Boolean
abstract CanProcessItem :
        item : 'T -> bool
override CanProcessItem :
        item : 'T -> bool
function CanProcessItem(item);
protected:
virtual bool CanProcessItem(
    T item
)

Parameters

item
Type: T
The item T to process.

Return Value

Type: Boolean
A Boolean value indicating whether it can process the item or not.
Remarks

Use this function instead of invoking the CanProcessItemFunction pointer directly, since implementation of this delegate is optional.

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CanProcessItems Method

Grid Solutions Framework ProcessQueueTCanProcessItems Method
Determines if all items can be processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool CanProcessItems(
    T[] items
)
Protected Overridable Function CanProcessItems (
    items As T()
) As Boolean
abstract CanProcessItems :
        items : 'T[] -> bool
override CanProcessItems :
        items : 'T[] -> bool
function CanProcessItems(items);
protected:
virtual bool CanProcessItems(
    array<T>^ items
)

Parameters

items
Type: T
An array of items of type T.

Return Value

Type: Boolean
A Boolean value indicating whether the process queue can process the items.
Remarks

Use this function instead of invoking the CanProcessItemFunction pointer directly, since implementation of this delegate is optional.

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Clear Method

Grid Solutions Framework ProcessQueueTClear Method
Removes all elements from the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
abstract Clear : unit -> unit
override Clear : unit -> unit
function Clear();
public:
virtual void Clear() sealed

Implements

ICollectionTClear
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Contains Method

Grid Solutions Framework ProcessQueueTContains Method
Determines whether an element is in the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Contains(
    T item
)
Public Overridable Function Contains (
    item As T
) As Boolean
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool
function Contains(item);
public:
virtual bool Contains(
    T item
)

Parameters

item
Type: T
The object to locate in the ProcessQueueT. The value can be null for reference types.

Return Value

Type: Boolean
True, if item is found in the ProcessQueueT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ConvertAll(TOutput) Method

Grid Solutions Framework ProcessQueueTConvertAllTOutput Method
Converts the elements in the current ProcessQueueT to another type, and returns a ProcessQueueT containing the converted elements.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual List<TOutput> ConvertAll<TOutput>(
    Converter<T, TOutput> converter
)

Public Overridable Function ConvertAll(Of TOutput) (
    converter As Converter(Of T, TOutput)
) As List(Of TOutput)
abstract ConvertAll :
        converter : Converter<'T, 'TOutput> -> List<'TOutput>
override ConvertAll :
        converter : Converter<'T, 'TOutput> -> List<'TOutput>
JavaScript does not support generic types or methods.
public:
generic<typename TOutput>
virtual List<TOutput>^ ConvertAll(
    Converter<T, TOutput>^ converter
)

Parameters

converter
Type: SystemConverter T, TOutput
A Converter delegate that converts each element from one type to another type.

Type Parameters

TOutput
The generic type used.

Return Value

Type: List TOutput
A generic list of the target type containing the converted elements from the current ProcessQueueT.
Exceptions
Exception | Condition
ArgumentNullException | converter is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CopyTo Method

Grid Solutions Framework ProcessQueueTCopyTo Method
Copies the entire ProcessQueueT to a compatible one-dimensional array, starting at the beginning of the target array.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
function CopyTo(array, arrayIndex);
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: T
The one-dimensional array that is the destination of the elements copied from ProcessQueueT. The array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentException | arrayIndex is equal to or greater than the length of array -or- the number of elements in the source ProcessQueueT is greater than the available space from arrayIndex to the end of the destination array.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentNullException | array is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method
Overload List
Name | Description
CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Int32) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Int32) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32) | Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32) | Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous ProcessQueueT using specified settings.
CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous, bulk item ProcessQueueT using specified settings.
CreateAsynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous ProcessQueueT using specified settings.
CreateAsynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean) | Creates a new asynchronous, bulk item ProcessQueueT using specified settings.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature)
Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction
)
Public Shared Function CreateAsynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemFunction);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature)
Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction
)
Public Shared Function CreateAsynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemsFunction);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature)
Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction
)
Public Shared Function CreateAsynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemFunction, canProcessItemFunction);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, Int32)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, Int32)
Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    int maximumThreads
)
Public Shared Function CreateAsynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    maximumThreads As Integer
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        maximumThreads : int -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemFunction, maximumThreads);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    int maximumThreads
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature)
Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, MaximumThreads = 5, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction
)
Public Shared Function CreateAsynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemsFunction, canProcessItemFunction);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, Int32)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, Int32)
Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    int maximumThreads
)
Public Shared Function CreateAsynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    maximumThreads As Integer
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        maximumThreads : int -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemsFunction, maximumThreads);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    int maximumThreads
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Int32)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32)
Creates a new asynchronous ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    int maximumThreads
)
Public Shared Function CreateAsynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    maximumThreads As Integer
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        maximumThreads : int -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemFunction, canProcessItemFunction, maximumThreads);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    int maximumThreads
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Int32)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32)
Creates a new asynchronous, bulk item ProcessQueueT with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    int maximumThreads
)
Public Shared Function CreateAsynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    maximumThreads As Integer
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        maximumThreads : int -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemsFunction, canProcessItemFunction, maximumThreads);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    int maximumThreads
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a new asynchronous ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateAsynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    processInterval As Double,
    maximumThreads As Integer,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        processInterval : float *
        maximumThreads : int *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a new asynchronous, bulk item ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateAsynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    processInterval As Double,
    maximumThreads As Integer,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        processInterval : float *
        maximumThreads : int *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemsFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a new asynchronous ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateAsynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    processInterval As Double,
    maximumThreads As Integer,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        processInterval : float *
        maximumThreads : int *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemFunction, canProcessItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateAsynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateAsynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Int32, Boolean, Boolean)
Creates a new asynchronous, bulk item ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateAsynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    processInterval As Double,
    maximumThreads As Integer,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateAsynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        processInterval : float *
        maximumThreads : int *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateAsynchronousQueue = function(processItemsFunction, canProcessItemFunction, processInterval, maximumThreads, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateAsynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    double processInterval,
    int maximumThreads,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
maximumThreads
Type: SystemInt32
An Int32 value that determines the maximum number of threads used to process items.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateAsynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method
Overload List
Name | Description
CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time ProcessQueueT using specified settings.
CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time, bulk item ProcessQueueT using specified settings.
CreateRealTimeQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time ProcessQueueT using specified settings.
CreateRealTimeQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean) | Creates a new real-time, bulk item ProcessQueueT using specified settings.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemFunctionSignature)
Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction
)
Public Shared Function CreateRealTimeQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemFunction);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemsFunctionSignature)
Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction
)
Public Shared Function CreateRealTimeQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemsFunction);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature)
Creates a new real-time ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction
)
Public Shared Function CreateRealTimeQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemFunction, canProcessItemFunction);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature)
Creates a new real-time, bulk item ProcessQueueT with the default settings: ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction
)
Public Shared Function CreateRealTimeQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemsFunction, canProcessItemFunction);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemFunctionSignature, Int32, Boolean, Boolean)
Creates a new real-time ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateRealTimeQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemFunction, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemsFunctionSignature, Int32, Boolean, Boolean)
Creates a new real-time, bulk item ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateRealTimeQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemsFunction, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean)
Creates a new real-time ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateRealTimeQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemFunction, canProcessItemFunction, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateRealTimeQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateRealTimeQueue Method (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Int32, Boolean, Boolean)
Creates a new real-time, bulk item ProcessQueueT using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateRealTimeQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateRealTimeQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateRealTimeQueue = function(processItemsFunction, canProcessItemFunction, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateRealTimeQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateRealTimeQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method
Overload List
Name | Description
CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature) | Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.
CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.
CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.
CreateSynchronousQueue(ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.
CreateSynchronousQueue(ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean) | Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature)
Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction
)
Public Shared Function CreateSynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemFunction);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature)
Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction
)
Public Shared Function CreateSynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemsFunction);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature)
Creates a new synchronous ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction
)
Public Shared Function CreateSynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemFunction, canProcessItemFunction);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature)
Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) with the default settings: ProcessInterval = 100, ProcessTimeout = Infinite, RequeueOnTimeout = False, RequeueOnException = False.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction
)
Public Shared Function CreateSynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemsFunction, canProcessItemFunction);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, Double, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, Double, Int32, Boolean, Boolean)
Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateSynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    processInterval As Double,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        processInterval : float *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemFunction, processInterval, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, Double, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, Double, Int32, Boolean, Boolean)
Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateSynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    processInterval As Double,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        processInterval : float *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemsFunction, processInterval, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean)
Creates a new synchronous ProcessQueueT (i.e., single process thread) using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateSynchronousQueue (
    processItemFunction As ProcessQueueTProcessItemFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    processInterval As Double,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemFunction : ProcessQueueTProcessItemFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        processInterval : float *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemFunction, canProcessItemFunction, processInterval, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemFunctionSignature^ processItemFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemFunction
Type: GSF.CollectionsProcessQueueTProcessItemFunctionSignature
Delegate that processes one item at a time.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).CreateSynchronousQueue Method (ProcessQueue(T).ProcessItemsFunctionSignature, ProcessQueue(T).CanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean)

Grid Solutions Framework ProcessQueueTCreateSynchronousQueue Method (ProcessQueueTProcessItemsFunctionSignature, ProcessQueueTCanProcessItemFunctionSignature, Double, Int32, Boolean, Boolean)
Creates a new synchronous, bulk item ProcessQueueT (i.e., single process thread) using specified settings.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ProcessQueue<T> CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature canProcessItemFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)
Public Shared Function CreateSynchronousQueue (
    processItemsFunction As ProcessQueueTProcessItemsFunctionSignature,
    canProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature,
    processInterval As Double,
    processTimeout As Integer,
    requeueOnTimeout As Boolean,
    requeueOnException As Boolean
) As ProcessQueue(Of T)
static member CreateSynchronousQueue :
        processItemsFunction : ProcessQueueTProcessItemsFunctionSignature *
        canProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature *
        processInterval : float *
        processTimeout : int *
        requeueOnTimeout : bool *
        requeueOnException : bool -> ProcessQueue<'T>

GSF.Collections.ProcessQueue.CreateSynchronousQueue = function(processItemsFunction, canProcessItemFunction, processInterval, processTimeout, requeueOnTimeout, requeueOnException);
public:
static ProcessQueue<T>^ CreateSynchronousQueue(
    ProcessQueueTProcessItemsFunctionSignature^ processItemsFunction,
    ProcessQueueTCanProcessItemFunctionSignature^ canProcessItemFunction,
    double processInterval,
    int processTimeout,
    bool requeueOnTimeout,
    bool requeueOnException
)

Parameters

processItemsFunction
Type: GSF.CollectionsProcessQueueTProcessItemsFunctionSignature
Delegate that defines a method to process multiple items at once.
canProcessItemFunction
Type: GSF.CollectionsProcessQueueTCanProcessItemFunctionSignature
Delegate which determines whether an item can be processed.
processInterval
Type: SystemDouble
a Double value which represents the process interval in milliseconds.
processTimeout
Type: SystemInt32
The number of seconds before a process should timeout.
requeueOnTimeout
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue an item on timeout.
requeueOnException
Type: SystemBoolean
A Boolean value that indicates whether a process should requeue after an exception.

Return Value

Type: ProcessQueue T
A ProcessQueue object based on type T.
See Also

Reference

ProcessQueueT Class
CreateSynchronousQueue Overload
GSF.Collections Namespace


ProcessQueue(T).DataAdded Method

Grid Solutions Framework ProcessQueueTDataAdded Method
Notifies queue that data was added and/or modified, so it can begin processing data.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void DataAdded()
Protected Overridable Sub DataAdded
abstract DataAdded : unit -> unit
override DataAdded : unit -> unit
function DataAdded();
protected:
virtual void DataAdded()
Remarks

Derived classes *must* make sure to call this method after data gets added, so that the process timer can be enabled for intervaled ProcessQueueT and data processing can begin.

To make sure items in the ProcessQueueT always get processed, this function is expected to be invoked from within a SyncLock of the exposed SyncRoot (i.e., InternalList).

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Dispose Method

Grid Solutions Framework ProcessQueueTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ProcessQueueT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ProcessQueueT object and optionally releases the managed resources.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Dispose Method

Grid Solutions Framework ProcessQueueTDispose Method
Releases all the resources used by the ProcessQueueT object.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ProcessQueueT Class
Dispose Overload
GSF.Collections Namespace


ProcessQueue(T).Dispose Method (Boolean)

Grid Solutions Framework ProcessQueueTDispose Method (Boolean)
Releases the unmanaged resources used by the ProcessQueueT object and optionally releases the managed resources.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ProcessQueueT Class
Dispose Overload
GSF.Collections Namespace


ProcessQueue(T).Exists Method

Grid Solutions Framework ProcessQueueTExists Method
Determines whether the ProcessQueueT contains elements that match the conditions defined by the specified predicate.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Exists(
    Predicate<T> match
)
Public Overridable Function Exists (
    match As Predicate(Of T)
) As Boolean
abstract Exists :
        match : Predicate<'T> -> bool
override Exists :
        match : Predicate<'T> -> bool
function Exists(match);
public:
virtual bool Exists(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the elements to search for.

Return Value

Type: Boolean
True, if the ProcessQueueT contains one or more elements that match the conditions defined by the specified predicate; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Finalize Method

Grid Solutions Framework ProcessQueueTFinalize Method
Releases the unmanaged resources before the ProcessQueueT object is reclaimed by GC.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Find Method

Grid Solutions Framework ProcessQueueTFind Method
Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual T Find(
    Predicate<T> match
)
Public Overridable Function Find (
    match As Predicate(Of T)
) As T
abstract Find :
        match : Predicate<'T> -> 'T
override Find :
        match : Predicate<'T> -> 'T
function Find(match);
public:
virtual T Find(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: T
The first element that matches the conditions defined by the specified predicate, if found; otherwise, the default value for type T.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).FindAll Method

Grid Solutions Framework ProcessQueueTFindAll Method
Retrieves all elements that match the conditions defined by the specified predicate.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual List<T> FindAll(
    Predicate<T> match
)
Public Overridable Function FindAll (
    match As Predicate(Of T)
) As List(Of T)
abstract FindAll :
        match : Predicate<'T> -> List<'T>
override FindAll :
        match : Predicate<'T> -> List<'T>
function FindAll(match);
public:
virtual List<T>^ FindAll(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the elements to search for.

Return Value

Type: List T
A generic list containing all elements that match the conditions defined by the specified predicate, if found; otherwise, an empty list.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).FindIndex Method

Grid Solutions Framework ProcessQueueTFindIndex Method
Overload List
 | Name | Description
Public method | FindIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | FindIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).FindIndex Method (Predicate(T))

Grid Solutions Framework ProcessQueueTFindIndex Method (PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int FindIndex(
    Predicate<T> match
)
Public Overridable Function FindIndex (
    match As Predicate(Of T)
) As Integer
abstract FindIndex :
        match : Predicate<'T> -> int
override FindIndex :
        match : Predicate<'T> -> int
function FindIndex(match);
public:
virtual int FindIndex(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: Int32
The zero-based index of the first occurrence of an element that matches the conditions defined by match, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
FindIndex Overload
GSF.Collections Namespace


ProcessQueue(T).FindIndex Method (Int32, Predicate(T))

Grid Solutions Framework ProcessQueueTFindIndex Method (Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int FindIndex(
    int startIndex,
    Predicate<T> match
)
Public Overridable Function FindIndex (
    startIndex As Integer,
    match As Predicate(Of T)
) As Integer
abstract FindIndex :
        startIndex : int *
        match : Predicate<'T> -> int
override FindIndex :
        startIndex : int *
        match : Predicate<'T> -> int
function FindIndex(startIndex, match);
public:
virtual int FindIndex(
    int startIndex,
    Predicate<T>^ match
)

Parameters

startIndex
Type: SystemInt32
The zero-based starting index of the search.
match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: Int32
The zero-based index of the first occurrence of an element that matches the conditions defined by match, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the ProcessQueueT.
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
FindIndex Overload
GSF.Collections Namespace


ProcessQueue(T).FindIndex Method (Int32, Int32, Predicate(T))

Grid Solutions Framework ProcessQueueTFindIndex Method (Int32, Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int FindIndex(
    int startIndex,
    int count,
    Predicate<T> match
)
Public Overridable Function FindIndex (
    startIndex As Integer,
    count As Integer,
    match As Predicate(Of T)
) As Integer
abstract FindIndex :
        startIndex : int *
        count : int *
        match : Predicate<'T> -> int
override FindIndex :
        startIndex : int *
        count : int *
        match : Predicate<'T> -> int
function FindIndex(startIndex, count, match);
public:
virtual int FindIndex(
    int startIndex,
    int count,
    Predicate<T>^ match
)

Parameters

startIndex
Type: SystemInt32
The zero-based starting index of the search.
count
Type: SystemInt32
The number of elements in the section to search.
match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: Int32
The zero-based index of the first occurrence of an element that matches the conditions defined by match, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the ProcessQueueT -or- count is less than 0 -or- startIndex and count do not specify a valid section in the ProcessQueueT.
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
FindIndex Overload
GSF.Collections Namespace


ProcessQueue(T).FindLast Method

Grid Solutions Framework ProcessQueueTFindLast Method
Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual T FindLast(
    Predicate<T> match
)
Public Overridable Function FindLast (
    match As Predicate(Of T)
) As T
abstract FindLast :
        match : Predicate<'T> -> 'T
override FindLast :
        match : Predicate<'T> -> 'T
function FindLast(match);
public:
virtual T FindLast(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: T
The last element that matches the conditions defined by the specified predicate, if found; otherwise, the default value for type T.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).FindLastIndex Method

Grid Solutions Framework ProcessQueueTFindLastIndex Method
Overload List
 | Name | Description
Public method | FindLastIndex(PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ProcessQueueT.
Public method | FindLastIndex(Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.
Public method | FindLastIndex(Int32, Int32, PredicateT) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).FindLastIndex Method (Predicate(T))

Grid Solutions Framework ProcessQueueTFindLastIndex Method (PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int FindLastIndex(
    Predicate<T> match
)
Public Overridable Function FindLastIndex (
    match As Predicate(Of T)
) As Integer
abstract FindLastIndex :
        match : Predicate<'T> -> int
override FindLastIndex :
        match : Predicate<'T> -> int
function FindLastIndex(match);
public:
virtual int FindLastIndex(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: Int32
The zero-based index of the last occurrence of an element that matches the conditions defined by match, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
FindLastIndex Overload
GSF.Collections Namespace


ProcessQueue(T).FindLastIndex Method (Int32, Predicate(T))

Grid Solutions Framework ProcessQueueTFindLastIndex Method (Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int FindLastIndex(
    int startIndex,
    Predicate<T> match
)
Public Overridable Function FindLastIndex (
    startIndex As Integer,
    match As Predicate(Of T)
) As Integer
abstract FindLastIndex :
        startIndex : int *
        match : Predicate<'T> -> int
override FindLastIndex :
        startIndex : int *
        match : Predicate<'T> -> int
function FindLastIndex(startIndex, match);
public:
virtual int FindLastIndex(
    int startIndex,
    Predicate<T>^ match
)

Parameters

startIndex
Type: SystemInt32
The zero-based starting index of the backward search.
match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: Int32
The zero-based index of the last occurrence of an element that matches the conditions defined by match, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the ProcessQueueT.
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
FindLastIndex Overload
GSF.Collections Namespace


ProcessQueue(T).FindLastIndex Method (Int32, Int32, Predicate(T))

Grid Solutions Framework ProcessQueueTFindLastIndex Method (Int32, Int32, PredicateT)
Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int FindLastIndex(
    int startIndex,
    int count,
    Predicate<T> match
)
Public Overridable Function FindLastIndex (
    startIndex As Integer,
    count As Integer,
    match As Predicate(Of T)
) As Integer
abstract FindLastIndex :
        startIndex : int *
        count : int *
        match : Predicate<'T> -> int
override FindLastIndex :
        startIndex : int *
        count : int *
        match : Predicate<'T> -> int
function FindLastIndex(startIndex, count, match);
public:
virtual int FindLastIndex(
    int startIndex,
    int count,
    Predicate<T>^ match
)

Parameters

startIndex
Type: SystemInt32
The zero-based starting index of the backward search.
count
Type: SystemInt32
The number of elements in the section to search.
match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the element to search for.

Return Value

Type: Int32
The zero-based index of the last occurrence of an element that matches the conditions defined by match, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | startIndex is outside the range of valid indexes for the ProcessQueueT -or- count is less than 0 -or- startIndex and count do not specify a valid section in the ProcessQueueT.
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
FindLastIndex Overload
GSF.Collections Namespace


ProcessQueue(T).Flush Method

Grid Solutions Framework ProcessQueueTFlush Method
Blocks the current thread, if the ProcessQueueT is active (i.e., user has called "Start" method), until all items in ProcessQueueT are processed, and then stops the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Flush()
Public Overridable Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush()
Remarks

Begins processing items as quickly as possible, regardless of currently defined process interval, until all items in the ProcessQueueT have been processed. Stops the ProcessQueueT when this function ends. This method is typically called on shutdown to make sure any remaining queued items get processed before the ProcessQueueT is destructed.

It is possible for items to be added to the ProcessQueueT while the flush is executing. The flush will continue to process items as quickly as possible until the ProcessQueueT is empty. Unless the user stops queuing items to be processed, the flush call may never return (not a happy situation on shutdown). For this reason, during this function call, requeuing of items on exception or process timeout is temporarily disabled.

The ProcessQueueT does not clear queue prior to destruction. If the user fails to call this method before the class is destructed, there may be items that remain unprocessed in the ProcessQueueT.

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ForEach Method

Grid Solutions Framework ProcessQueueTForEach Method
Performs the specified action on each element of the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void ForEach(
    Action<T> action
)
Public Overridable Sub ForEach (
    action As Action(Of T)
)
abstract ForEach :
        action : Action<'T> -> unit
override ForEach :
        action : Action<'T> -> unit
function ForEach(action);
public:
virtual void ForEach(
    Action<T>^ action
)

Parameters

action
Type: SystemAction T
The Action delegate to perform on each element of the ProcessQueueT.
Exceptions
Exception | Condition
ArgumentNullException | action is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).GetEnumerator Method

Grid Solutions Framework ProcessQueueTGetEnumerator Method
Returns an enumerator that iterates through the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IEnumerator<T> GetEnumerator()
Public Overridable Function GetEnumerator As IEnumerator(Of T)
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>
function GetEnumerator();
public:
virtual IEnumerator<T>^ GetEnumerator()

Return Value

Type: IEnumerator T
An enumerator for the ProcessQueueT.

Implements

IEnumerableTGetEnumerator
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).GetRange Method

Grid Solutions Framework ProcessQueueTGetRange Method
Creates a shallow copy of a range of elements in the source ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual List<T> GetRange(
    int index,
    int count
)
Public Overridable Function GetRange (
    index As Integer,
    count As Integer
) As List(Of T)
abstract GetRange :
        index : int *
        count : int -> List<'T>
override GetRange :
        index : int *
        count : int -> List<'T>
function GetRange(index, count);
public:
virtual List<T>^ GetRange(
    int index,
    int count
)

Parameters

index
Type: SystemInt32
The zero-based ProcessQueueT index at which the range starts.
count
Type: SystemInt32
The number of elements in the range.

Return Value

Type: List T
A shallow copy of a range of elements in the source ProcessQueueT.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than 0 -or- count is less than 0.
ArgumentException | index and count do not denote a valid range of elements in the ProcessQueueT.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).IndexOf Method

Grid Solutions Framework ProcessQueueTIndexOf Method
Overload List
 | Name | Description
Public method | IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire ProcessQueueT.
Public method | IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.
Public method | IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that starts at the specified index and contains the specified number of elements.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).IndexOf Method (T)

Grid Solutions Framework ProcessQueueTIndexOf Method (T)
Searches for the specified object and returns the zero-based index of the first occurrence within the entire ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IndexOf(
    T item
)
Public Overridable Function IndexOf (
    item As T
) As Integer
abstract IndexOf :
        item : 'T -> int
override IndexOf :
        item : 'T -> int
function IndexOf(item);
public:
virtual int IndexOf(
    T item
)

Parameters

item
Type: T
The object to locate in the ProcessQueueT. The value can be null for reference types.

Return Value

Type: Int32
The zero-based index of the first occurrence of item within the entire ProcessQueueT, if found; otherwise, –1.

Implements

IListTIndexOf(T)
See Also

Reference

ProcessQueueT Class
IndexOf Overload
GSF.Collections Namespace


ProcessQueue(T).IndexOf Method (T, Int32)

Grid Solutions Framework ProcessQueueTIndexOf Method (T, Int32)
Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that extends from the specified index to the last element.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IndexOf(
    T item,
    int index
)
Public Overridable Function IndexOf (
    item As T,
    index As Integer
) As Integer
abstract IndexOf :
        item : 'T *
        index : int -> int
override IndexOf :
        item : 'T *
        index : int -> int
function IndexOf(item, index);
public:
virtual int IndexOf(
    T item,
    int index
)

Parameters

item
Type: T
The object to locate in the ProcessQueueT. The value can be null for reference types.
index
Type: SystemInt32
The zero-based starting index of the search.

Return Value

Type: Int32
The zero-based index of the first occurrence of item within the range of elements in the ProcessQueueT that extends from index to the last element, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is outside the range of valid indexes for the ProcessQueueT.
See Also

Reference

ProcessQueueT Class
IndexOf Overload
GSF.Collections Namespace


ProcessQueue(T).IndexOf Method (T, Int32, Int32)

Grid Solutions Framework ProcessQueueTIndexOf Method (T, Int32, Int32)
Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the ProcessQueueT that starts at the specified index and contains the specified number of elements.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IndexOf(
    T item,
    int index,
    int count
)
Public Overridable Function IndexOf (
    item As T,
    index As Integer,
    count As Integer
) As Integer
abstract IndexOf :
        item : 'T *
        index : int *
        count : int -> int
override IndexOf :
        item : 'T *
        index : int *
        count : int -> int
function IndexOf(item, index, count);
public:
virtual int IndexOf(
    T item,
    int index,
    int count
)

Parameters

item
Type: T
The object to locate in the ProcessQueueT. The value can be null for reference types.
index
Type: SystemInt32
The zero-based starting index of the search.
count
Type: SystemInt32
The number of elements in the section to search.

Return Value

Type: Int32
The zero-based index of the first occurrence of item within the range of elements in the ProcessQueueT that starts at index and contains count number of elements, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is outside the range of valid indexes for the ProcessQueueT -or- count is less than 0 -or- index and count do not specify a valid section in the ProcessQueueT.
See Also

Reference

ProcessQueueT Class
IndexOf Overload
GSF.Collections Namespace


ProcessQueue(T).Insert Method

Grid Solutions Framework ProcessQueueTInsert Method
Inserts an element into the ProcessQueueT at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Insert(
    int index,
    T item
)
Public Overridable Sub Insert (
    index As Integer,
    item As T
)
abstract Insert :
        index : int *
        item : 'T -> unit
override Insert :
        index : int *
        item : 'T -> unit
function Insert(index, item);
public:
virtual void Insert(
    int index,
    T item
)

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert. The value can be null for reference types.

Implements

IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than 0 -or- index is greater than ProcessQueueT length.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).InsertRange Method

Grid Solutions Framework ProcessQueueTInsertRange Method
Inserts the elements of a collection into the ProcessQueueT at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void InsertRange(
    int index,
    IEnumerable<T> collection
)
Public Overridable Sub InsertRange (
    index As Integer,
    collection As IEnumerable(Of T)
)
abstract InsertRange :
        index : int *
        collection : IEnumerable<'T> -> unit
override InsertRange :
        index : int *
        collection : IEnumerable<'T> -> unit
function InsertRange(index, collection);
public:
virtual void InsertRange(
    int index,
    IEnumerable<T>^ collection
)

Parameters

index
Type: SystemInt32
The zero-based index at which the new elements should be inserted.
collection
Type: System.Collections.GenericIEnumerable T
The collection whose elements should be inserted into the ProcessQueueT. The collection itself cannot be null, but it can contain elements that are null, if type T is a reference type.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than 0 -or- index is greater than ProcessQueueT length.
ArgumentNullException | collection is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).LastIndexOf Method

Grid Solutions Framework ProcessQueueTLastIndexOf Method
Overload List
 | Name | Description
Public method | LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire ProcessQueueT.
Public method | LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.
Public method | LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).LastIndexOf Method (T)

Grid Solutions Framework ProcessQueueTLastIndexOf Method (T)
Searches for the specified object and returns the zero-based index of the last occurrence within the entire ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int LastIndexOf(
    T item
)
Public Overridable Function LastIndexOf (
    item As T
) As Integer
abstract LastIndexOf :
        item : 'T -> int
override LastIndexOf :
        item : 'T -> int
function LastIndexOf(item);
public:
virtual int LastIndexOf(
    T item
)

Parameters

item
Type: T
The object to locate in the ProcessQueueT. The value can be null for reference types.

Return Value

Type: Int32
The zero-based index of the last occurrence of item within the entire the ProcessQueueT, if found; otherwise, –1.
See Also

Reference

ProcessQueueT Class
LastIndexOf Overload
GSF.Collections Namespace


ProcessQueue(T).LastIndexOf Method (T, Int32)

Grid Solutions Framework ProcessQueueTLastIndexOf Method (T, Int32)
Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that extends from the first element to the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int LastIndexOf(
    T item,
    int index
)
Public Overridable Function LastIndexOf (
    item As T,
    index As Integer
) As Integer
abstract LastIndexOf :
        item : 'T *
        index : int -> int
override LastIndexOf :
        item : 'T *
        index : int -> int
function LastIndexOf(item, index);
public:
virtual int LastIndexOf(
    T item,
    int index
)

Parameters

item
Type: T
The object to locate in the ProcessQueueT. The value can be null for reference types.
index
Type: SystemInt32
The zero-based starting index of the backward search.

Return Value

Type: Int32
The zero-based index of the last occurrence of item within the range of elements in the ProcessQueueT that extends from the first element to index, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is outside the range of valid indexes for the ProcessQueueT.
See Also

Reference

ProcessQueueT Class
LastIndexOf Overload
GSF.Collections Namespace


ProcessQueue(T).LastIndexOf Method (T, Int32, Int32)

Grid Solutions Framework ProcessQueueTLastIndexOf Method (T, Int32, Int32)
Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the ProcessQueueT that contains the specified number of elements and ends at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int LastIndexOf(
    T item,
    int index,
    int count
)
Public Overridable Function LastIndexOf (
    item As T,
    index As Integer,
    count As Integer
) As Integer
abstract LastIndexOf :
        item : 'T *
        index : int *
        count : int -> int
override LastIndexOf :
        item : 'T *
        index : int *
        count : int -> int
function LastIndexOf(item, index, count);
public:
virtual int LastIndexOf(
    T item,
    int index,
    int count
)

Parameters

item
Type: T
The object to locate in the ProcessQueueT. The value can be null for reference types.
index
Type: SystemInt32
The zero-based starting index of the backward search.
count
Type: SystemInt32
The number of elements in the section to search.

Return Value

Type: Int32
The zero-based index of the last occurrence of item within the range of elements in the ProcessQueueT that contains count number of elements and ends at index, if found; otherwise, –1.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is outside the range of valid indexes for the ProcessQueueT -or- count is less than 0 -or- index and count do not specify a valid section in the ProcessQueueT.
See Also

Reference

ProcessQueueT Class
LastIndexOf Overload
GSF.Collections Namespace


ProcessQueue(T).OnItemProcessed Method

Grid Solutions Framework ProcessQueueTOnItemProcessed Method
Raises the base class ItemProcessed event.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnItemProcessed(
    T item
)
Protected Overridable Sub OnItemProcessed (
    item As T
)
abstract OnItemProcessed :
        item : 'T -> unit
override OnItemProcessed :
        item : 'T -> unit
function OnItemProcessed(item);
protected:
virtual void OnItemProcessed(
    T item
)

Parameters

item
Type: T
A generic type T to be passed to ItemProcessed.
Remarks
Derived classes cannot raise events of their base classes, so we expose event wrapper methods to accommodate as needed.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).OnItemsProcessed Method

Grid Solutions Framework ProcessQueueTOnItemsProcessed Method
Raises the base class ItemsProcessed event.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnItemsProcessed(
    T[] items
)
Protected Overridable Sub OnItemsProcessed (
    items As T()
)
abstract OnItemsProcessed :
        items : 'T[] -> unit
override OnItemsProcessed :
        items : 'T[] -> unit
function OnItemsProcessed(items);
protected:
virtual void OnItemsProcessed(
    array<T>^ items
)

Parameters

items
Type: T
An array of generic type T to be passed to ItemsProcessed.
Remarks
Derived classes cannot raise events of their base classes, so we expose event wrapper methods to accommodate as needed.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).OnItemsTimedOut Method

Grid Solutions Framework ProcessQueueTOnItemsTimedOut Method
Raises the base class ItemsTimedOut event.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnItemsTimedOut(
    T[] items
)
Protected Overridable Sub OnItemsTimedOut (
    items As T()
)
abstract OnItemsTimedOut :
        items : 'T[] -> unit
override OnItemsTimedOut :
        items : 'T[] -> unit
function OnItemsTimedOut(items);
protected:
virtual void OnItemsTimedOut(
    array<T>^ items
)

Parameters

items
Type: T
An array of generic type T to be passed to ItemsProcessed.
Remarks
Derived classes cannot raise events of their base classes, so we expose event wrapper methods to accommodate as needed.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).OnItemTimedOut Method

Grid Solutions Framework ProcessQueueTOnItemTimedOut Method
Raises the base class ItemTimedOut event.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnItemTimedOut(
    T item
)
Protected Overridable Sub OnItemTimedOut (
    item As T
)
abstract OnItemTimedOut :
        item : 'T -> unit
override OnItemTimedOut :
        item : 'T -> unit
function OnItemTimedOut(item);
protected:
virtual void OnItemTimedOut(
    T item
)

Parameters

item
Type: T
A generic type T to be passed to ItemProcessed.
Remarks
Derived classes cannot raise events of their base classes, so we expose event wrapper methods to accommodate as needed.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).OnProcessException Method

Grid Solutions Framework ProcessQueueTOnProcessException Method
Raises the base class ProcessException event.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to be passed to ProcessException.
Remarks
Derived classes cannot raise events of their base classes, so we expose event wrapper methods to accommodate as needed.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Remove Method

Grid Solutions Framework ProcessQueueTRemove Method
Removes the first occurrence of a specific object from the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Remove(
    T item
)
Public Overridable Function Remove (
    item As T
) As Boolean
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool
function Remove(item);
public:
virtual bool Remove(
    T item
)

Parameters

item
Type: T
The object to remove from the ProcessQueueT. The value can be null for reference types.

Return Value

Type: Boolean
True, if item is successfully removed; otherwise, false. This method also returns false if item was not found in the ProcessQueueT.

Implements

ICollectionTRemove(T)
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RemoveAll Method

Grid Solutions Framework ProcessQueueTRemoveAll Method
Removes the all the elements that match the conditions defined by the specified predicate.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int RemoveAll(
    Predicate<T> match
)
Public Overridable Function RemoveAll (
    match As Predicate(Of T)
) As Integer
abstract RemoveAll :
        match : Predicate<'T> -> int
override RemoveAll :
        match : Predicate<'T> -> int
function RemoveAll(match);
public:
virtual int RemoveAll(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions of the elements to remove.

Return Value

Type: Int32
The number of elements removed from the ProcessQueueT.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RemoveAt Method

Grid Solutions Framework ProcessQueueTRemoveAt Method
Removes the element at the specified index of the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RemoveAt(
    int index
)
Public Overridable Sub RemoveAt (
    index As Integer
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
function RemoveAt(index);
public:
virtual void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.

Implements

IListTRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than 0 -or- index is equal to or greater than ProcessQueueT length.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RemoveRange Method

Grid Solutions Framework ProcessQueueTRemoveRange Method
Removes a range of elements from the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RemoveRange(
    int index,
    int count
)
Public Overridable Sub RemoveRange (
    index As Integer,
    count As Integer
)
abstract RemoveRange :
        index : int *
        count : int -> unit
override RemoveRange :
        index : int *
        count : int -> unit
function RemoveRange(index, count);
public:
virtual void RemoveRange(
    int index,
    int count
)

Parameters

index
Type: SystemInt32
The zero-based starting index of the range of elements to remove.
count
Type: SystemInt32
The number of elements to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than 0 -or- count is less than 0.
ArgumentException | index and count do not denote a valid range of elements in the ProcessQueueT.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RequeueItem Method

Grid Solutions Framework ProcessQueueTRequeueItem Method
Requeues item into ProcessQueueT according to specified requeue reason.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void RequeueItem(
    T item,
    RequeueReason reason
)
Protected Overridable Sub RequeueItem (
    item As T,
    reason As RequeueReason
)
abstract RequeueItem :
        item : 'T *
        reason : RequeueReason -> unit
override RequeueItem :
        item : 'T *
        reason : RequeueReason -> unit
function RequeueItem(item, reason);
protected:
virtual void RequeueItem(
    T item,
    RequeueReason reason
)

Parameters

item
Type: T
A generic item of type T to be requeued.
reason
Type: GSF.CollectionsRequeueReason
The reason the object is being requeued.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RequeueItems Method

Grid Solutions Framework ProcessQueueTRequeueItems Method
Requeues items into ProcessQueueT according to specified requeue reason.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void RequeueItems(
    T[] items,
    RequeueReason reason
)
Protected Overridable Sub RequeueItems (
    items As T(),
    reason As RequeueReason
)
abstract RequeueItems :
        items : 'T[] *
        reason : RequeueReason -> unit
override RequeueItems :
        items : 'T[] *
        reason : RequeueReason -> unit
function RequeueItems(items, reason);
protected:
virtual void RequeueItems(
    array<T>^ items,
    RequeueReason reason
)

Parameters

items
Type: T
Array of type T to be requeued.
reason
Type: GSF.CollectionsRequeueReason
The reason the object is being requeued.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Reverse Method

Grid Solutions Framework ProcessQueueTReverse Method
Overload List
 | Name | Description
Public method | Reverse | Reverses the order of the elements in the entire ProcessQueueT.
Public method | Reverse(Int32, Int32) | Reverses the order of the elements in the specified range.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Reverse Method

Grid Solutions Framework ProcessQueueTReverse Method
Reverses the order of the elements in the entire ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Reverse()
Public Overridable Sub Reverse
abstract Reverse : unit -> unit
override Reverse : unit -> unit
function Reverse();
public:
virtual void Reverse()
See Also

Reference

ProcessQueueT Class
Reverse Overload
GSF.Collections Namespace


ProcessQueue(T).Reverse Method (Int32, Int32)

Grid Solutions Framework ProcessQueueTReverse Method (Int32, Int32)
Reverses the order of the elements in the specified range.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Reverse(
    int index,
    int count
)
Public Overridable Sub Reverse (
    index As Integer,
    count As Integer
)
abstract Reverse :
        index : int *
        count : int -> unit
override Reverse :
        index : int *
        count : int -> unit
function Reverse(index, count);
public:
virtual void Reverse(
    int index,
    int count
)

Parameters

index
Type: SystemInt32
The zero-based starting index of the range to reverse.
count
Type: SystemInt32
The number of elements in the range to reverse.
Exceptions
Exception | Condition
ArgumentException | index and count do not denote a valid range of elements in the ProcessQueueT.
ArgumentOutOfRangeException | index is less than 0 -or- count is less than 0.
See Also

Reference

ProcessQueueT Class
Reverse Overload
GSF.Collections Namespace


ProcessQueue(T).SignalDataModified Method

Grid Solutions Framework ProcessQueueTSignalDataModified Method
Manually signals that data has been modified and processing should resume.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SignalDataModified()
Public Overridable Sub SignalDataModified
abstract SignalDataModified : unit -> unit
override SignalDataModified : unit -> unit
function SignalDataModified();
public:
virtual void SignalDataModified()
Remarks
This function should be called in cases where a user may need to signal data modification. For example, if T was a dictionary or list that was updated - you would need to manually signal that data had changed in this item.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Sort Method

Grid Solutions Framework ProcessQueueTSort Method
Overload List
 | Name | Description
Public method | Sort | Sorts the elements in the entire ProcessQueueT, using the default comparer.
Public method | Sort(IComparerT) | Sorts the elements in the entire ProcessQueueT, using the specified comparer.
Public method | Sort(ComparisonT) | Sorts the elements in the entire ProcessQueueT, using the specified comparison.
Public method | Sort(Int32, Int32, IComparerT) | Sorts the elements in a range of elements in the ProcessQueueT, using the specified comparer.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Sort Method

Grid Solutions Framework ProcessQueueTSort Method
Sorts the elements in the entire ProcessQueueT, using the default comparer.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Sort()
Public Overridable Sub Sort
abstract Sort : unit -> unit
override Sort : unit -> unit
function Sort();
public:
virtual void Sort()
Exceptions
Exception | Condition
InvalidOperationException | The default comparer, Generic.Comparer.Default, cannot find an implementation of the IComparable generic interface or the IComparable interface for type T.
See Also

Reference

ProcessQueueT Class
Sort Overload
GSF.Collections Namespace


ProcessQueue(T).Sort Method (IComparer(T))

Grid Solutions Framework ProcessQueueTSort Method (IComparerT)
Sorts the elements in the entire ProcessQueueT, using the specified comparer.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Sort(
    IComparer<T> comparer
)
Public Overridable Sub Sort (
    comparer As IComparer(Of T)
)
abstract Sort :
        comparer : IComparer<'T> -> unit
override Sort :
        comparer : IComparer<'T> -> unit
function Sort(comparer);
public:
virtual void Sort(
    IComparer<T>^ comparer
)

Parameters

comparer
Type: System.Collections.GenericIComparer T
The Generic.IComparer implementation to use when comparing elements, or null to use the default comparer: Generic.Comparer.Default.
Exceptions
Exception | Condition
ArgumentException | The implementation of comparer caused an error during the sort. For example, comparer might not return 0 when comparing an item with itself.
InvalidOperationException | the comparer is null and the default comparer, Generic.Comparer.Default, cannot find an implementation of the IComparable generic interface or the IComparable interface for type T.
See Also

Reference

ProcessQueueT Class
Sort Overload
GSF.Collections Namespace


ProcessQueue(T).Sort Method (Comparison(T))

Grid Solutions Framework ProcessQueueTSort Method (ComparisonT)
Sorts the elements in the entire ProcessQueueT, using the specified comparison.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Sort(
    Comparison<T> comparison
)
Public Overridable Sub Sort (
    comparison As Comparison(Of T)
)
abstract Sort :
        comparison : Comparison<'T> -> unit
override Sort :
        comparison : Comparison<'T> -> unit
function Sort(comparison);
public:
virtual void Sort(
    Comparison<T>^ comparison
)

Parameters

comparison
Type: SystemComparison T
The comparison to use when comparing elements.
Exceptions
Exception | Condition
ArgumentException | The implementation of comparison caused an error during the sort. For example, comparison might not return 0 when comparing an item with itself.
ArgumentNullException | comparison is null.
See Also

Reference

ProcessQueueT Class
Sort Overload
GSF.Collections Namespace


ProcessQueue(T).Sort Method (Int32, Int32, IComparer(T))

Grid Solutions Framework ProcessQueueTSort Method (Int32, Int32, IComparerT)
Sorts the elements in a range of elements in the ProcessQueueT, using the specified comparer.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Sort(
    int index,
    int count,
    IComparer<T> comparer
)
Public Overridable Sub Sort (
    index As Integer,
    count As Integer,
    comparer As IComparer(Of T)
)
abstract Sort :
        index : int *
        count : int *
        comparer : IComparer<'T> -> unit
override Sort :
        index : int *
        count : int *
        comparer : IComparer<'T> -> unit
function Sort(index, count, comparer);
public:
virtual void Sort(
    int index,
    int count,
    IComparer<T>^ comparer
)

Parameters

index
Type: SystemInt32
The zero-based starting index of the range to sort.
count
Type: SystemInt32
The length of the range to sort.
comparer
Type: System.Collections.GenericIComparer T
The Generic.IComparer implementation to use when comparing elements, or null to use the default comparer: Generic.Comparer.Default.
Exceptions
Exception | Condition
ArgumentException | The implementation of comparer caused an error during the sort. For example, comparer might not return 0 when comparing an item with itself.
InvalidOperationException | the comparer is null and the default comparer, Generic.Comparer.Default, cannot find an implementation of the IComparable generic interface or the IComparable interface for type T.
ArgumentOutOfRangeException | index is less than 0 -or- count is less than 0.
See Also

Reference

ProcessQueueT Class
Sort Overload
GSF.Collections Namespace


ProcessQueue(T).Start Method

Grid Solutions Framework ProcessQueueTStart Method
Starts item processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Start()
Public Overridable Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start()
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Stop Method

Grid Solutions Framework ProcessQueueTStop Method
Stops item processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Stop()
Public Overridable Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop()
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ToArray Method

Grid Solutions Framework ProcessQueueTToArray Method
Copies the elements contained in the ProcessQueueT to a new array.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual T[] ToArray()
Public Overridable Function ToArray As T()
abstract ToArray : unit -> 'T[]
override ToArray : unit -> 'T[]
function ToArray();
public:
virtual array<T>^ ToArray()

Return Value

Type: T
A new array containing the elements copied from the ProcessQueueT.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).TrueForAll Method

Grid Solutions Framework ProcessQueueTTrueForAll Method
Determines whether every element in the ProcessQueueT matches the conditions defined by the specified predicate.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TrueForAll(
    Predicate<T> match
)
Public Overridable Function TrueForAll (
    match As Predicate(Of T)
) As Boolean
abstract TrueForAll :
        match : Predicate<'T> -> bool
override TrueForAll :
        match : Predicate<'T> -> bool
function TrueForAll(match);
public:
virtual bool TrueForAll(
    Predicate<T>^ match
)

Parameters

match
Type: SystemPredicate T
The Predicate delegate that defines the conditions to check against the elements.

Return Value

Type: Boolean
True, if every element in the ProcessQueueT matches the conditions defined by the specified predicate; otherwise, false. If the ProcessQueueT has no elements, the return value is true.
Exceptions
Exception | Condition
ArgumentNullException | match is null.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).TryTake Method

Grid Solutions Framework ProcessQueueTTryTake Method
Overload List
 | Name | Description
Public method | TryTake(T) | Attempts to remove and return an object from the ProcessQueueT.
Public method | TryTake(T) | Attempts to remove and return all objects from the ProcessQueueT.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).TryTake Method (T)

Grid Solutions Framework ProcessQueueTTryTake Method (T)
Attempts to remove and return an object from the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryTake(
    out T item
)
Public Function TryTake (
    <OutAttribute> ByRef item As T
) As Boolean
member TryTake :
        item : 'T byref -> bool

function TryTake(item);
public:
bool TryTake(
    [OutAttribute] T% item
)

Parameters

item
Type: T
When this method returns, if the object was removed and returned successfully, item contains the removed object. If no object was available to be removed, the value is unspecified.

Return Value

Type: Boolean
true if an object was removed and returned successfully; otherwise, false.
See Also

Reference

ProcessQueueT Class
TryTake Overload
GSF.Collections Namespace


ProcessQueue(T).TryTake Method (T[])

Grid Solutions Framework ProcessQueueTTryTake Method (T)
Attempts to remove and return all objects from the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryTake(
    out T[] items
)
Public Function TryTake (
    <OutAttribute> ByRef items As T()
) As Boolean
member TryTake :
        items : 'T[] byref -> bool

function TryTake(items);
public:
bool TryTake(
    [OutAttribute] array<T>^% items
)

Parameters

items
Type: T
When this method returns, if any objects were removed and returned successfully, item array contains the removed objects. If no object was available to be removed, the value is null.

Return Value

Type: Boolean
true if any objects were removed and returned successfully; otherwise, false.
See Also

Reference

ProcessQueueT Class
TryTake Overload
GSF.Collections Namespace


ProcessQueue(T) Properties

Grid Solutions Framework ProcessQueueT Properties

The ProcessQueueT generic type exposes the following members.

Properties
 | Name | Description
Public property | CanProcessItemFunction | Gets or sets the user function determining if an item is ready to be processed.
Public property | Count | Gets the number of elements actually contained in the ProcessQueueT.
Public property | CurrentStatistics | Gets the current run-time statistics of the ProcessQueueT as a single group of values.
Public property | Enabled | Gets or sets indicator that the ProcessQueueT is currently enabled.
Protected property | InternalEnumerable | Allows derived classes to access the interfaced internal ProcessQueueT directly.
Protected property | InternalList | Gets the internal list for direct use by ProcessQueueT.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsEmpty | Gets a value that indicates whether the ProcessQueueT is empty.
Public property | IsProcessing | Gets indicator that the ProcessQueueT is actively processing items.
Public property | IsReadOnly | Gets a value indicating whether the ProcessQueueT is read-only.
Public property | IsSynchronized | Gets a value indicating whether access to the ProcessQueueT is synchronized (thread safe). Always returns true for ProcessQueueT.
Public property | Item | Gets or sets the element at the specified index.
Public property | ItemsBeingProcessed | Gets the total number of items currently being processed.
Public property | MaximumThreads | Gets or sets the maximum number of threads to process simultaneously.
Public property | Name | Gets or sets name for this ProcessQueueT.
Public property | ProcessingIsRealTime | Gets indicator that items will be processed in real-time.
Public property | ProcessingStyle | Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once).
Public property | ProcessInterval | Gets or sets the interval, in milliseconds, on which new items begin processing.
Public property | ProcessItemFunction | Gets or sets the user function for processing individual items in the ProcessQueueT one at a time.
Public property | ProcessItemsFunction | Gets or sets the user function for processing multiple items in the ProcessQueueT at once.
Public property | ProcessTimeout | Gets or sets the maximum time, in milliseconds, allowed for processing an item.
Public property | RequeueModeOnException | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after an exception occurs while processing.
Public property | RequeueModeOnTimeout | Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after processing times out.
Public property | RequeueOnException | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if an exception occurs while processing.
Public property | RequeueOnTimeout | Gets or sets whether or not to automatically place an item back into the ProcessQueueT if the processing times out.
Public property | RunTime | Gets the total amount of time, in seconds, that the ProcessQueueT has been active.
Public property | Status | Gets current status of ProcessQueueT.
Public property | SynchronizedOperationType | Gets or sets the type of synchronized operation used to process items in a real-time ProcessQueueT.
Public property | SyncRoot | Gets an object that can be used to synchronize access to the ProcessQueueT.
Public property | ThreadCount | Gets the current number of active threads.
Public property | ThreadingMode | Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous).
Public property | TotalFunctionCalls | Gets the total number of calls to ProcessItemFunction or ProcessItemsFunction.
Public property | TotalProcessedItems | Gets the total number of items processed so far.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CanProcessItemFunction Property

Grid Solutions Framework ProcessQueueTCanProcessItemFunction Property
Gets or sets the user function determining if an item is ready to be processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ProcessQueueTCanProcessItemFunctionSignature CanProcessItemFunction { get; set; }
Public Overridable Property CanProcessItemFunction As ProcessQueueTCanProcessItemFunctionSignature
    Get
    Set
abstract CanProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature with get, set
override CanProcessItemFunction : ProcessQueueTCanProcessItemFunctionSignature with get, set
function get_CanProcessItemFunction();
function set_CanProcessItemFunction(value);
public:
virtual property ProcessQueueTCanProcessItemFunctionSignature^ CanProcessItemFunction {
    ProcessQueueTCanProcessItemFunctionSignature^ get ();
    void set (ProcessQueueTCanProcessItemFunctionSignature^ value);
}

Property Value

Type: ProcessQueueTCanProcessItemFunctionSignature
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Count Property

Grid Solutions Framework ProcessQueueTCount Property
Gets the number of elements actually contained in the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get ();
}

Return Value

Type: Int32
The number of elements actually contained in the ProcessQueueT.

Implements

ICollectionTCount
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CurrentStatistics Property

Grid Solutions Framework ProcessQueueTCurrentStatistics Property
Gets the current run-time statistics of the ProcessQueueT as a single group of values.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ProcessQueueStatistics CurrentStatistics { get; }
Public Overridable ReadOnly Property CurrentStatistics As ProcessQueueStatistics
    Get
abstract CurrentStatistics : ProcessQueueStatistics with get
override CurrentStatistics : ProcessQueueStatistics with get
function get_CurrentStatistics();

public:
virtual property ProcessQueueStatistics CurrentStatistics {
    ProcessQueueStatistics get ();
}

Property Value

Type: ProcessQueueStatistics
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Enabled Property

Grid Solutions Framework ProcessQueueTEnabled Property
Gets or sets indicator that the ProcessQueueT is currently enabled.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Enabled { get; set; }
Public Overridable Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).InternalEnumerable Property

Grid Solutions Framework ProcessQueueTInternalEnumerable Property
Allows derived classes to access the interfaced internal ProcessQueueT directly.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IEnumerable<T> InternalEnumerable { get; }
Protected ReadOnly Property InternalEnumerable As IEnumerable(Of T)
    Get
member InternalEnumerable : IEnumerable<'T> with get

function get_InternalEnumerable();

protected:
property IEnumerable<T>^ InternalEnumerable {
    IEnumerable<T>^ get ();
}

Property Value

Type: IEnumerable T
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).InternalList Property

Grid Solutions Framework ProcessQueueTInternalList Property
Gets the internal list for direct use by ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IList<T> InternalList { get; }
Protected ReadOnly Property InternalList As IList(Of T)
    Get
member InternalList : IList<'T> with get

function get_InternalList();

protected:
property IList<T>^ InternalList {
    IList<T>^ get ();
}

Property Value

Type: IList T
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).IsDisposed Property

Grid Solutions Framework ProcessQueueTIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).IsEmpty Property

Grid Solutions Framework ProcessQueueTIsEmpty Property
Gets a value that indicates whether the ProcessQueueT is empty.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get
override IsEmpty : bool with get
function get_IsEmpty();

public:
virtual property bool IsEmpty {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).IsProcessing Property

Grid Solutions Framework ProcessQueueTIsProcessing Property
Gets indicator that the ProcessQueueT is actively processing items.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsProcessing { get; }
Public ReadOnly Property IsProcessing As Boolean
    Get
member IsProcessing : bool with get

function get_IsProcessing();

public:
property bool IsProcessing {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).IsReadOnly Property

Grid Solutions Framework ProcessQueueTIsReadOnly Property
Gets a value indicating whether the ProcessQueueT is read-only.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
function get_IsReadOnly();

public:
virtual property bool IsReadOnly {
    bool get ();
}

Return Value

Type: Boolean
True, if the ProcessQueueT is read-only; otherwise, false. In the default implementation, this property always returns false.

Implements

ICollectionTIsReadOnly
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).IsSynchronized Property

Grid Solutions Framework ProcessQueueTIsSynchronized Property
Gets a value indicating whether access to the ProcessQueueT is synchronized (thread safe). Always returns true for ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSynchronized { get; }
Public ReadOnly Property IsSynchronized As Boolean
    Get
member IsSynchronized : bool with get

function get_IsSynchronized();

public:
property bool IsSynchronized {
    bool get ();
}

Return Value

Type: Boolean
true, ProcessQueueT is always synchronized (thread safe).
Remarks
The ProcessQueueT is effectively "synchronized" since all functions SyncLock operations internally.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Item Property

Grid Solutions Framework ProcessQueueTItem Property
Gets or sets the element at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual T this[
    int index
] { get; set; }
Public Overridable Default Property Item (
    index As Integer
) As T
    Get
    Set
abstract Item : 'T with get, set
override Item : 'T with get, set
function get_Item(index);
function set_Item(value);
public:
virtual property T default[int index] {
    T get (int index);
    void set (int index, T value);
}

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.

Return Value

Type: T
The element at the specified index.

Implements

IListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than 0 -or- index is equal to or greater than ProcessQueueT length.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ItemsBeingProcessed Property

Grid Solutions Framework ProcessQueueTItemsBeingProcessed Property
Gets the total number of items currently being processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ItemsBeingProcessed { get; }
Public ReadOnly Property ItemsBeingProcessed As Long
    Get
member ItemsBeingProcessed : int64 with get

function get_ItemsBeingProcessed();

public:
property long long ItemsBeingProcessed {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).MaximumThreads Property

Grid Solutions Framework ProcessQueueTMaximumThreads Property
Gets or sets the maximum number of threads to process simultaneously.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int MaximumThreads { get; set; }
Public Overridable Property MaximumThreads As Integer
    Get
    Set
abstract MaximumThreads : int with get, set
override MaximumThreads : int with get, set
function get_MaximumThreads();
function set_MaximumThreads(value);
public:
virtual property int MaximumThreads {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Sets the maximum number of processing threads.

Return Value

Type: Int32
Maximum number of processing threads.
Remarks
If MaximumThreads is set to one, item processing will be synchronous (i.e., ThreadingMode = Synchronous)
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Name Property

Grid Solutions Framework ProcessQueueTName Property
Gets or sets name for this ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IProvideStatusName
Remarks
This name is used for class identification in strings (e.g., used in error messages).
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ProcessingIsRealTime Property

Grid Solutions Framework ProcessQueueTProcessingIsRealTime Property
Gets indicator that items will be processed in real-time.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool ProcessingIsRealTime { get; }
Public Overridable ReadOnly Property ProcessingIsRealTime As Boolean
    Get
abstract ProcessingIsRealTime : bool with get
override ProcessingIsRealTime : bool with get
function get_ProcessingIsRealTime();

public:
virtual property bool ProcessingIsRealTime {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ProcessingStyle Property

Grid Solutions Framework ProcessQueueTProcessingStyle Property
Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once).

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual QueueProcessingStyle ProcessingStyle { get; }
Public Overridable ReadOnly Property ProcessingStyle As QueueProcessingStyle
    Get
abstract ProcessingStyle : QueueProcessingStyle with get
override ProcessingStyle : QueueProcessingStyle with get
function get_ProcessingStyle();

public:
virtual property QueueProcessingStyle ProcessingStyle {
    QueueProcessingStyle get ();
}

Return Value

Type: QueueProcessingStyle

OneAtATime, if the ProcessItemFunction is implemented.

ManyAtOnce, if the ProcessItemsFunction is implemented.

Remarks

The implemented item processing function determines the QueueProcessingStyle.

If the QueueProcessingStyle is ManyAtOnce, all available items in the ProcessQueueT are presented for processing at each processing interval. If you expect items to be processed in the order in which they were received, make sure you use a synchronous ProcessQueueT. Real-time ProcessQueueT are inherently synchronous.

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ProcessInterval Property

Grid Solutions Framework ProcessQueueTProcessInterval Property
Gets or sets the interval, in milliseconds, on which new items begin processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double ProcessInterval { get; set; }
Public Overridable Property ProcessInterval As Double
    Get
    Set
abstract ProcessInterval : float with get, set
override ProcessInterval : float with get, set
function get_ProcessInterval();
function set_ProcessInterval(value);
public:
virtual property double ProcessInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ProcessItemFunction Property

Grid Solutions Framework ProcessQueueTProcessItemFunction Property
Gets or sets the user function for processing individual items in the ProcessQueueT one at a time.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ProcessQueueTProcessItemFunctionSignature ProcessItemFunction { get; set; }
Public Overridable Property ProcessItemFunction As ProcessQueueTProcessItemFunctionSignature
    Get
    Set
abstract ProcessItemFunction : ProcessQueueTProcessItemFunctionSignature with get, set
override ProcessItemFunction : ProcessQueueTProcessItemFunctionSignature with get, set
function get_ProcessItemFunction();
function set_ProcessItemFunction(value);
public:
virtual property ProcessQueueTProcessItemFunctionSignature^ ProcessItemFunction {
    ProcessQueueTProcessItemFunctionSignature^ get ();
    void set (ProcessQueueTProcessItemFunctionSignature^ value);
}

Property Value

Type: ProcessQueueTProcessItemFunctionSignature
Remarks

Cannot be defined simultaneously with ProcessItemsFunction.

A ProcessQueueT must be defined to process a single item at a time or many items at once.

Implementation makes ProcessingStyle = OneAtATime.

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ProcessItemsFunction Property

Grid Solutions Framework ProcessQueueTProcessItemsFunction Property
Gets or sets the user function for processing multiple items in the ProcessQueueT at once.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ProcessQueueTProcessItemsFunctionSignature ProcessItemsFunction { get; set; }
Public Overridable Property ProcessItemsFunction As ProcessQueueTProcessItemsFunctionSignature
    Get
    Set
abstract ProcessItemsFunction : ProcessQueueTProcessItemsFunctionSignature with get, set
override ProcessItemsFunction : ProcessQueueTProcessItemsFunctionSignature with get, set
function get_ProcessItemsFunction();
function set_ProcessItemsFunction(value);
public:
virtual property ProcessQueueTProcessItemsFunctionSignature^ ProcessItemsFunction {
    ProcessQueueTProcessItemsFunctionSignature^ get ();
    void set (ProcessQueueTProcessItemsFunctionSignature^ value);
}

Property Value

Type: ProcessQueueTProcessItemsFunctionSignature
Remarks

This function and ProcessItemFunction cannot be defined at the same time

A ProcessQueueT must be defined to process a single item at a time or many items at once

Implementation of this function makes ProcessingStyle = ManyAtOnce

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ProcessTimeout Property

Grid Solutions Framework ProcessQueueTProcessTimeout Property
Gets or sets the maximum time, in milliseconds, allowed for processing an item.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ProcessTimeout { get; set; }
Public Overridable Property ProcessTimeout As Integer
    Get
    Set
abstract ProcessTimeout : int with get, set
override ProcessTimeout : int with get, set
function get_ProcessTimeout();
function set_ProcessTimeout(value);
public:
virtual property int ProcessTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Sets the maximum number of milliseconds allowed to process an item.

Return Value

Type: Int32
The maximum number of milliseconds allowed to process an item.
Remarks
Set to Timeout.Infinite (i.e., -1) to allow processing to take as long as needed.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RequeueModeOnException Property

Grid Solutions Framework ProcessQueueTRequeueModeOnException Property
Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after an exception occurs while processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual RequeueMode RequeueModeOnException { get; set; }
Public Overridable Property RequeueModeOnException As RequeueMode
    Get
    Set
abstract RequeueModeOnException : RequeueMode with get, set
override RequeueModeOnException : RequeueMode with get, set
function get_RequeueModeOnException();
function set_RequeueModeOnException(value);
public:
virtual property RequeueMode RequeueModeOnException {
    RequeueMode get ();
    void set (RequeueMode value);
}

Property Value

Type: RequeueMode
Remarks
Only relevant when RequeueOnException = True.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RequeueModeOnTimeout Property

Grid Solutions Framework ProcessQueueTRequeueModeOnTimeout Property
Gets or sets the mode of insertion used (prefix or suffix) when at item is placed back into the ProcessQueueT after processing times out.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual RequeueMode RequeueModeOnTimeout { get; set; }
Public Overridable Property RequeueModeOnTimeout As RequeueMode
    Get
    Set
abstract RequeueModeOnTimeout : RequeueMode with get, set
override RequeueModeOnTimeout : RequeueMode with get, set
function get_RequeueModeOnTimeout();
function set_RequeueModeOnTimeout(value);
public:
virtual property RequeueMode RequeueModeOnTimeout {
    RequeueMode get ();
    void set (RequeueMode value);
}

Property Value

Type: RequeueMode
Remarks
Only relevant when RequeueOnTimeout = True.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RequeueOnException Property

Grid Solutions Framework ProcessQueueTRequeueOnException Property
Gets or sets whether or not to automatically place an item back into the ProcessQueueT if an exception occurs while processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RequeueOnException { get; set; }
Public Overridable Property RequeueOnException As Boolean
    Get
    Set
abstract RequeueOnException : bool with get, set
override RequeueOnException : bool with get, set
function get_RequeueOnException();
function set_RequeueOnException(value);
public:
virtual property bool RequeueOnException {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RequeueOnTimeout Property

Grid Solutions Framework ProcessQueueTRequeueOnTimeout Property
Gets or sets whether or not to automatically place an item back into the ProcessQueueT if the processing times out.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RequeueOnTimeout { get; set; }
Public Overridable Property RequeueOnTimeout As Boolean
    Get
    Set
abstract RequeueOnTimeout : bool with get, set
override RequeueOnTimeout : bool with get, set
function get_RequeueOnTimeout();
function set_RequeueOnTimeout(value);
public:
virtual property bool RequeueOnTimeout {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Ignored if the ProcessTimeout is set to Timeout.Infinite (i.e., -1).
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).RunTime Property

Grid Solutions Framework ProcessQueueTRunTime Property
Gets the total amount of time, in seconds, that the ProcessQueueT has been active.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Time RunTime { get; }
Public Overridable ReadOnly Property RunTime As Time
    Get
abstract RunTime : Time with get
override RunTime : Time with get
function get_RunTime();

public:
virtual property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Status Property

Grid Solutions Framework ProcessQueueTStatus Property
Gets current status of ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).SynchronizedOperationType Property

Grid Solutions Framework ProcessQueueTSynchronizedOperationType Property
Gets or sets the type of synchronized operation used to process items in a real-time ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual SynchronizedOperationType SynchronizedOperationType { get; set; }
Public Overridable Property SynchronizedOperationType As SynchronizedOperationType
    Get
    Set
abstract SynchronizedOperationType : SynchronizedOperationType with get, set
override SynchronizedOperationType : SynchronizedOperationType with get, set
function get_SynchronizedOperationType();
function set_SynchronizedOperationType(value);
public:
virtual property SynchronizedOperationType SynchronizedOperationType {
    SynchronizedOperationType get ();
    void set (SynchronizedOperationType value);
}

Property Value

Type: SynchronizedOperationType
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).SyncRoot Property

Grid Solutions Framework ProcessQueueTSyncRoot Property
Gets an object that can be used to synchronize access to the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object SyncRoot { get; }
Public ReadOnly Property SyncRoot As Object
    Get
member SyncRoot : Object with get

function get_SyncRoot();

public:
property Object^ SyncRoot {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ThreadCount Property

Grid Solutions Framework ProcessQueueTThreadCount Property
Gets the current number of active threads.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ThreadCount { get; }
Public ReadOnly Property ThreadCount As Integer
    Get
member ThreadCount : int with get

function get_ThreadCount();

public:
property int ThreadCount {
    int get ();
}

Return Value

Type: Int32
Current number of active threads.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ThreadingMode Property

Grid Solutions Framework ProcessQueueTThreadingMode Property
Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous).

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual QueueThreadingMode ThreadingMode { get; }
Public Overridable ReadOnly Property ThreadingMode As QueueThreadingMode
    Get
abstract ThreadingMode : QueueThreadingMode with get
override ThreadingMode : QueueThreadingMode with get
function get_ThreadingMode();

public:
virtual property QueueThreadingMode ThreadingMode {
    QueueThreadingMode get ();
}

Property Value

Type: QueueThreadingMode
Remarks

The maximum number of processing threads determines the QueueThreadingMode.

If the maximum threads are set to one, item processing will be synchronous (i.e., ThreadingMode = Synchronous).

If the maximum threads are more than one, item processing will be asynchronous (i.e., ThreadingMode = Asynchronous).

Note that for asynchronous ProcessQueueT, the processing interval will control how many threads are spawned at once. If items are processed faster than the specified processing interval, only one process thread will ever be spawned at a time. To ensure multiple threads are utilized to ProcessQueueT items, lower the process interval (minimum process interval is 1 millisecond).

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).TotalFunctionCalls Property

Grid Solutions Framework ProcessQueueTTotalFunctionCalls Property
Gets the total number of calls to ProcessItemFunction or ProcessItemsFunction.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalFunctionCalls { get; }
Public ReadOnly Property TotalFunctionCalls As Long
    Get
member TotalFunctionCalls : int64 with get

function get_TotalFunctionCalls();

public:
property long long TotalFunctionCalls {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).TotalProcessedItems Property

Grid Solutions Framework ProcessQueueTTotalProcessedItems Property
Gets the total number of items processed so far.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalProcessedItems { get; }
Public ReadOnly Property TotalProcessedItems As Long
    Get
member TotalProcessedItems : int64 with get

function get_TotalProcessedItems();

public:
property long long TotalProcessedItems {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T) Events

Grid Solutions Framework ProcessQueueT Events

The ProcessQueueT generic type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed.
Public event | ItemProcessed | Event that is raised after an item has been successfully processed.
Public event | ItemsProcessed | Event that is raised after an array of items have been successfully processed.
Public event | ItemsTimedOut | Event that is raised if the processing time for an array of items exceeds the specified process timeout.
Public event | ItemTimedOut | Event that is raised if an item's processing time exceeds the specified process timeout.
Public event | ProcessException | Event that is raised if an exception is encountered while attempting to processing an item in the ProcessQueueT.
Top
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).Disposed Event

Grid Solutions Framework ProcessQueueTDisposed Event
Occurs when the class has been disposed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ItemProcessed Event

Grid Solutions Framework ProcessQueueTItemProcessed Event
Event that is raised after an item has been successfully processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T>> ItemProcessed
Public Event ItemProcessed As EventHandler(Of EventArgs(Of T))
member ItemProcessed : IEvent<EventHandler<EventArgs<'T>>,
    EventArgs<'T>>

function add_ItemProcessed(value);
function remove_ItemProcessed(value);
public:
 event EventHandler<EventArgs<T>^>^ ItemProcessed {
    void add (EventHandler<EventArgs<T>^>^ value);
    void remove (EventHandler<EventArgs<T>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
Remarks

Allows custom handling of successfully processed items.

Allows notification when an item has completed processing in the allowed amount of time, if a process timeout is specified.

Raised only when ProcessingStyle = OneAtATime (i.e., ProcessItemFunction is defined).

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ItemsProcessed Event

Grid Solutions Framework ProcessQueueTItemsProcessed Event
Event that is raised after an array of items have been successfully processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T[]>> ItemsProcessed
Public Event ItemsProcessed As EventHandler(Of EventArgs(Of T()))
member ItemsProcessed : IEvent<EventHandler<EventArgs<'T[]>>,
    EventArgs<'T[]>>

function add_ItemsProcessed(value);
function remove_ItemsProcessed(value);
public:
 event EventHandler<EventArgs<array<T>^>^>^ ItemsProcessed {
    void add (EventHandler<EventArgs<array<T>^>^>^ value);
    void remove (EventHandler<EventArgs<array<T>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
Remarks

Allows custom handling of successfully processed items.

Allows notification when an item has completed processing in the allowed amount of time, if a process timeout is specified.

Raised only when when ProcessingStyle = ManyAtOnce (i.e., ProcessItemsFunction is defined).

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ItemsTimedOut Event

Grid Solutions Framework ProcessQueueTItemsTimedOut Event
Event that is raised if the processing time for an array of items exceeds the specified process timeout.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T[]>> ItemsTimedOut
Public Event ItemsTimedOut As EventHandler(Of EventArgs(Of T()))
member ItemsTimedOut : IEvent<EventHandler<EventArgs<'T[]>>,
    EventArgs<'T[]>>

function add_ItemsTimedOut(value);
function remove_ItemsTimedOut(value);
public:
 event EventHandler<EventArgs<array<T>^>^>^ ItemsTimedOut {
    void add (EventHandler<EventArgs<array<T>^>^>^ value);
    void remove (EventHandler<EventArgs<array<T>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
Remarks

Allows custom handling of items that took too long to process.

Raised only when ProcessingStyle = ManyAtOnce (i.e., ProcessItemsFunction is defined).

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ItemTimedOut Event

Grid Solutions Framework ProcessQueueTItemTimedOut Event
Event that is raised if an item's processing time exceeds the specified process timeout.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<T>> ItemTimedOut
Public Event ItemTimedOut As EventHandler(Of EventArgs(Of T))
member ItemTimedOut : IEvent<EventHandler<EventArgs<'T>>,
    EventArgs<'T>>

function add_ItemTimedOut(value);
function remove_ItemTimedOut(value);
public:
 event EventHandler<EventArgs<T>^>^ ItemTimedOut {
    void add (EventHandler<EventArgs<T>^>^ value);
    void remove (EventHandler<EventArgs<T>^>^ value);
}

Value

Type: SystemEventHandler EventArgs T
Remarks

Allows custom handling of items that took too long to process.

Raised only when ProcessingStyle = OneAtATime (i.e., ProcessItemFunction is defined).

See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).ProcessException Event

Grid Solutions Framework ProcessQueueTProcessException Event
Event that is raised if an exception is encountered while attempting to processing an item in the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Processing will not stop for any exceptions thrown by the user function, but any captured exceptions will be exposed through this event.
See Also

Reference

ProcessQueueT Class
GSF.Collections Namespace


ProcessQueue(T).CanProcessItemFunctionSignature Delegate

Grid Solutions Framework ProcessQueueTCanProcessItemFunctionSignature Delegate
Function signature that determines if an item can be currently processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate bool CanProcessItemFunctionSignature(
    T item
)
Public Delegate Function CanProcessItemFunctionSignature (
    item As T
) As Boolean
type CanProcessItemFunctionSignature =
    delegate of
        item : 'T -> bool
function(item);
public delegate bool CanProcessItemFunctionSignature(
    T item
)

Parameters

item
Type: T
Item to be checked for processing availability.

Return Value

Type: Boolean
True, if item can be processed. The default is true.
Remarks

Implementation of this function is optional. It is assumed that an item can be processed if this function is not defined

Items must eventually get to a state where they can be processed, or they will remain in the ProcessQueueT indefinitely.

Note that when this function is implemented and ProcessingStyle = ManyAtOnce (i.e., ProcessItemsFunction is defined), then each item presented for processing must evaluate as "CanProcessItem = True" before any items are processed.

See Also

Reference

GSF.Collections Namespace


ProcessQueue(T).ProcessItemFunctionSignature Delegate

Grid Solutions Framework ProcessQueueTProcessItemFunctionSignature Delegate
Function signature that defines a method to process items one at a time.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate void ProcessItemFunctionSignature(
    T item
)
Public Delegate Sub ProcessItemFunctionSignature (
    item As T
)
type ProcessItemFunctionSignature =
    delegate of
        item : 'T -> unit
function(item);
public delegate void ProcessItemFunctionSignature(
    T item
)

Parameters

item
Type: T
Item to be processed.
Remarks

Required unless ProcessItemsFunction is implemented.

Creates an asynchronous ProcessQueueT to process individual items - one item at a time - on multiple threads.

See Also

Reference

GSF.Collections Namespace


ProcessQueue(T).ProcessItemsFunctionSignature Delegate

Grid Solutions Framework ProcessQueueTProcessItemsFunctionSignature Delegate
Function signature that defines a method to process multiple items at once.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate void ProcessItemsFunctionSignature(
    T[] items
)
Public Delegate Sub ProcessItemsFunctionSignature (
    items As T()
)
type ProcessItemsFunctionSignature =
    delegate of
        items : 'T[] -> unit
function(items);
public delegate void ProcessItemsFunctionSignature(
    array<T>^ items
)

Parameters

items
Type: T
Items to be processed.
Remarks

Required unless ProcessItemFunction is implemented.

Creates an asynchronous ProcessQueueT to process groups of items simultaneously on multiple threads.

See Also

Reference

GSF.Collections Namespace


ProcessQueueStatistics Structure

Grid Solutions Framework ProcessQueueStatistics Structure
Represents the statistics of a ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct ProcessQueueStatistics
Public Structure ProcessQueueStatistics
[<SealedAttribute>]
type ProcessQueueStatistics =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class ProcessQueueStatistics

The ProcessQueueStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | ActiveThreads | Gets the current number of active threads.
Public field | IsEnabled | Gets indicator that the ProcessQueueT is currently enabled.
Public field | IsProcessing | Gets indicator that the ProcessQueueT is actively processing items.
Public field | ItemsBeingProcessed | Gets the total number of items currently being processed.
Public field | ProcessingInterval | Gets the interval, in milliseconds, on which new items begin processing.
Public field | ProcessingStyle | Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once).
Public field | ProcessTimeout | Gets the maximum time, in milliseconds, allowed for processing an item.
Public field | QueueCount | Gets the number of elements queued for processing in the ProcessQueueT.
Public field | RunTime | Gets the total amount of time, in seconds, that the process ProcessQueueT has been active.
Public field | ThreadingMode | Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous).
Public field | TotalProcessedItems | Gets the total number of items processed so far.
Top
See Also

Reference

GSF.Collections Namespace


ProcessQueueStatistics Fields

Grid Solutions Framework ProcessQueueStatistics Fields

The ProcessQueueStatistics type exposes the following members.

Fields
 | Name | Description
Public field | ActiveThreads | Gets the current number of active threads.
Public field | IsEnabled | Gets indicator that the ProcessQueueT is currently enabled.
Public field | IsProcessing | Gets indicator that the ProcessQueueT is actively processing items.
Public field | ItemsBeingProcessed | Gets the total number of items currently being processed.
Public field | ProcessingInterval | Gets the interval, in milliseconds, on which new items begin processing.
Public field | ProcessingStyle | Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once).
Public field | ProcessTimeout | Gets the maximum time, in milliseconds, allowed for processing an item.
Public field | QueueCount | Gets the number of elements queued for processing in the ProcessQueueT.
Public field | RunTime | Gets the total amount of time, in seconds, that the process ProcessQueueT has been active.
Public field | ThreadingMode | Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous).
Public field | TotalProcessedItems | Gets the total number of items processed so far.
Top
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.ActiveThreads Field

Grid Solutions Framework ProcessQueueStatisticsActiveThreads Field
Gets the current number of active threads.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ActiveThreads
Public ActiveThreads As Integer
val mutable ActiveThreads: int
var ActiveThreads
public:
int ActiveThreads

Field Value

Type: Int32
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.IsEnabled Field

Grid Solutions Framework ProcessQueueStatisticsIsEnabled Field
Gets indicator that the ProcessQueueT is currently enabled.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsEnabled
Public IsEnabled As Boolean
val mutable IsEnabled: bool
var IsEnabled
public:
bool IsEnabled

Field Value

Type: Boolean
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.IsProcessing Field

Grid Solutions Framework ProcessQueueStatisticsIsProcessing Field
Gets indicator that the ProcessQueueT is actively processing items.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsProcessing
Public IsProcessing As Boolean
val mutable IsProcessing: bool
var IsProcessing
public:
bool IsProcessing

Field Value

Type: Boolean
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.ItemsBeingProcessed Field

Grid Solutions Framework ProcessQueueStatisticsItemsBeingProcessed Field
Gets the total number of items currently being processed.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ItemsBeingProcessed
Public ItemsBeingProcessed As Long
val mutable ItemsBeingProcessed: int64
var ItemsBeingProcessed
public:
long long ItemsBeingProcessed

Field Value

Type: Int64
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.ProcessingInterval Field

Grid Solutions Framework ProcessQueueStatisticsProcessingInterval Field
Gets the interval, in milliseconds, on which new items begin processing.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ProcessingInterval
Public ProcessingInterval As Double
val mutable ProcessingInterval: float
var ProcessingInterval
public:
double ProcessingInterval

Field Value

Type: Double
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.ProcessingStyle Field

Grid Solutions Framework ProcessQueueStatisticsProcessingStyle Field
Gets the item QueueProcessingStyle for the ProcessQueueT (i.e., one at a time or many at once).

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public QueueProcessingStyle ProcessingStyle
Public ProcessingStyle As QueueProcessingStyle
val mutable ProcessingStyle: QueueProcessingStyle
var ProcessingStyle
public:
QueueProcessingStyle ProcessingStyle

Field Value

Type: QueueProcessingStyle
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.ProcessTimeout Field

Grid Solutions Framework ProcessQueueStatisticsProcessTimeout Field
Gets the maximum time, in milliseconds, allowed for processing an item.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ProcessTimeout
Public ProcessTimeout As Integer
val mutable ProcessTimeout: int
var ProcessTimeout
public:
int ProcessTimeout

Field Value

Type: Int32
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.QueueCount Field

Grid Solutions Framework ProcessQueueStatisticsQueueCount Field
Gets the number of elements queued for processing in the ProcessQueueT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int QueueCount
Public QueueCount As Integer
val mutable QueueCount: int
var QueueCount
public:
int QueueCount

Field Value

Type: Int32
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.RunTime Field

Grid Solutions Framework ProcessQueueStatisticsRunTime Field
Gets the total amount of time, in seconds, that the process ProcessQueueT has been active.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time RunTime
Public RunTime As Time
val mutable RunTime: Time
var RunTime
public:
Time RunTime

Field Value

Type: Time
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.ThreadingMode Field

Grid Solutions Framework ProcessQueueStatisticsThreadingMode Field
Gets the current QueueThreadingMode for the ProcessQueueT (i.e., synchronous or asynchronous).

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public QueueThreadingMode ThreadingMode
Public ThreadingMode As QueueThreadingMode
val mutable ThreadingMode: QueueThreadingMode
var ThreadingMode
public:
QueueThreadingMode ThreadingMode

Field Value

Type: QueueThreadingMode
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics.TotalProcessedItems Field

Grid Solutions Framework ProcessQueueStatisticsTotalProcessedItems Field
Gets the total number of items processed so far.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalProcessedItems
Public TotalProcessedItems As Long
val mutable TotalProcessedItems: int64
var TotalProcessedItems
public:
long long TotalProcessedItems

Field Value

Type: Int64
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


ProcessQueueStatistics Methods

Grid Solutions Framework ProcessQueueStatistics Methods

The ProcessQueueStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ProcessQueueStatistics Structure
GSF.Collections Namespace


QueueProcessingStyle Enumeration

Grid Solutions Framework QueueProcessingStyle Enumeration
Enumeration of possible ProcessQueueT processing styles.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum QueueProcessingStyle
Public Enumeration QueueProcessingStyle
type QueueProcessingStyle
GSF.Collections.QueueProcessingStyle = function();
GSF.Collections.QueueProcessingStyle.createEnum('GSF.Collections.QueueProcessingStyle', false);
public enum class QueueProcessingStyle
Members
Member name | Value | Description
OneAtATime | 0 | Defines ProcessQueueT processing delegate to process only one item at a time.
ManyAtOnce | 1 | Defines ProcessQueueT processing delegate to process all currently available items in the ProcessQueueT. Items are passed into delegate as an array.
See Also

Reference

GSF.Collections Namespace


QueueThreadingMode Enumeration

Grid Solutions Framework QueueThreadingMode Enumeration
Enumeration of possible ProcessQueueT threading modes.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum QueueThreadingMode
Public Enumeration QueueThreadingMode
type QueueThreadingMode
GSF.Collections.QueueThreadingMode = function();
GSF.Collections.QueueThreadingMode.createEnum('GSF.Collections.QueueThreadingMode', false);
public enum class QueueThreadingMode
Members
Member name | Value | Description
Asynchronous | 0 | Processes several items in the ProcessQueueT at once on different threads, where processing order is not important.
Synchronous | 1 | Processes items in the ProcessQueueT one at a time on a single thread, where processing order is important.
See Also

Reference

GSF.Collections Namespace


RequeueMode Enumeration

Grid Solutions Framework RequeueMode Enumeration
Enumeration of possible requeue modes.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum RequeueMode
Public Enumeration RequeueMode
type RequeueMode
GSF.Collections.RequeueMode = function();
GSF.Collections.RequeueMode.createEnum('GSF.Collections.RequeueMode', false);
public enum class RequeueMode
Members
Member name | Value | Description
Prefix | 0 | Requeues item at the beginning of the ProcessQueueT.
Suffix | 1 | Requeues item at the end of the ProcessQueueT.
See Also

Reference

GSF.Collections Namespace


RequeueReason Enumeration

Grid Solutions Framework RequeueReason Enumeration
Enumeration of possible requeue reasons.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum RequeueReason
Public Enumeration RequeueReason
type RequeueReason
GSF.Collections.RequeueReason = function();
GSF.Collections.RequeueReason.createEnum('GSF.Collections.RequeueReason', false);
public enum class RequeueReason
Members
Member name | Value | Description
CannotProcess | 0 | Requeuing item since it cannot be processed at this time.
Exception | 1 | Requeuing item due to an exception.
Timeout | 2 | Requeing item due to timeout.
See Also

Reference

GSF.Collections Namespace


RollingWindow(T) Class

Grid Solutions Framework RollingWindowT Class
Represents a rolling window of data with FIFO semantics that will automatically truncate the data when the window size is exceeded.
Inheritance Hierarchy
SystemObject
GSF.CollectionsRollingWindowT

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RollingWindow<T> : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Public Class RollingWindow(Of T)
    Implements IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable
type RollingWindow<'T> =
    class
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class RollingWindow : IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable

Type Parameters

T
The type of objects to be stored in the rolling window.

The RollingWindowT type exposes the following members.

Constructors
 | Name | Description
Public method | RollingWindowT | Creates a new instance of the RollingWindowT class.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the RollingWindowT.
Public method | Clear | Removes all items from the RollingWindowT.
Public method | Contains | Determines whether the RollingWindowT contains a specific value.
Public method | CopyTo | Copies the elements of the RollingWindowT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the RollingWindowT.
Public method | Insert | Inserts an item to the RollingWindowT at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the RollingWindowT.
Public method | RemoveAt | Removes the RollingWindowT item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the RollingWindowT.
Public property | IsReadOnly | Gets a value indicating whether the RollingWindowT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Public property | WindowSize | Gets the size of the window maintained by the RollingWindowT.
Top
See Also

Reference

GSF.Collections Namespace


RollingWindow(T) Constructor

Grid Solutions Framework RollingWindowT Constructor
Creates a new instance of the RollingWindowT class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RollingWindow(
    int windowSize
)
Public Sub New (
    windowSize As Integer
)
new :
        windowSize : int -> RollingWindow
GSF.Collections.RollingWindow = function(windowSize);
public:
RollingWindow(
    int windowSize
)

Parameters

windowSize
Type: SystemInt32
The size of the window maintained by the collection.
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T) Methods

Grid Solutions Framework RollingWindowT Methods

The RollingWindowT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the RollingWindowT.
Public method | Clear | Removes all items from the RollingWindowT.
Public method | Contains | Determines whether the RollingWindowT contains a specific value.
Public method | CopyTo | Copies the elements of the RollingWindowT to an Array, starting at a particular Array index.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the RollingWindowT.
Public method | Insert | Inserts an item to the RollingWindowT at the specified index.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the RollingWindowT.
Public method | RemoveAt | Removes the RollingWindowT item at the specified index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).Add Method

Grid Solutions Framework RollingWindowTAdd Method
Adds an item to the RollingWindowT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    T item
)
Public Sub Add (
    item As T
)
abstract Add :
        item : 'T -> unit
override Add :
        item : 'T -> unit
function Add(item);
public:
virtual void Add(
    T item
) sealed

Parameters

item
Type: T
The object to add to the RollingWindowT.

Implements

ICollectionTAdd(T)
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).Clear Method

Grid Solutions Framework RollingWindowTClear Method
Removes all items from the RollingWindowT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
abstract Clear : unit -> unit
override Clear : unit -> unit
function Clear();
public:
virtual void Clear() sealed

Implements

ICollectionTClear
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).Contains Method

Grid Solutions Framework RollingWindowTContains Method
Determines whether the RollingWindowT contains a specific value.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Contains(
    T item
)
Public Function Contains (
    item As T
) As Boolean
abstract Contains :
        item : 'T -> bool
override Contains :
        item : 'T -> bool
function Contains(item);
public:
virtual bool Contains(
    T item
) sealed

Parameters

item
Type: T
The object to locate in the RollingWindowT.

Return Value

Type: Boolean
true if item is found in the RollingWindowT; otherwise, false.

Implements

ICollectionTContains(T)
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).CopyTo Method

Grid Solutions Framework RollingWindowTCopyTo Method
Copies the elements of the RollingWindowT to an Array, starting at a particular Array index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CopyTo(
    T[] array,
    int arrayIndex
)
Public Sub CopyTo (
    array As T(),
    arrayIndex As Integer
)
abstract CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
override CopyTo :
        array : 'T[] *
        arrayIndex : int -> unit
function CopyTo(array, arrayIndex);
public:
virtual void CopyTo(
    array<T>^ array,
    int arrayIndex
) sealed

Parameters

array
Type: T
The one-dimensional Array that is the destination of the elements copied from RollingWindowT. The Array must have zero-based indexing.
arrayIndex
Type: SystemInt32
The zero-based index in array at which copying begins.

Implements

ICollectionTCopyTo(T, Int32)
Exceptions
Exception | Condition
ArgumentNullException | array is null.
ArgumentOutOfRangeException | arrayIndex is less than 0.
ArgumentException | The number of elements in the source RollingWindowT is greater than the available space from arrayIndex to the end of the destination array.
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).GetEnumerator Method

Grid Solutions Framework RollingWindowTGetEnumerator Method
Returns an enumerator that iterates through the collection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerator<T> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of T)
abstract GetEnumerator : unit -> IEnumerator<'T>
override GetEnumerator : unit -> IEnumerator<'T>
function GetEnumerator();
public:
virtual IEnumerator<T>^ GetEnumerator() sealed

Return Value

Type: IEnumerator T
A IEnumeratorT that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).IndexOf Method

Grid Solutions Framework RollingWindowTIndexOf Method
Determines the index of a specific item in the RollingWindowT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOf(
    T item
)
Public Function IndexOf (
    item As T
) As Integer
abstract IndexOf :
        item : 'T -> int
override IndexOf :
        item : 'T -> int
function IndexOf(item);
public:
virtual int IndexOf(
    T item
) sealed

Parameters

item
Type: T
The object to locate in the RollingWindowT.

Return Value

Type: Int32
The index of item if found in the list; otherwise, -1.

Implements

IListTIndexOf(T)
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).Insert Method

Grid Solutions Framework RollingWindowTInsert Method
Inserts an item to the RollingWindowT at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Insert(
    int index,
    T item
)
Public Sub Insert (
    index As Integer,
    item As T
)
abstract Insert :
        index : int *
        item : 'T -> unit
override Insert :
        index : int *
        item : 'T -> unit
function Insert(index, item);
public:
virtual void Insert(
    int index,
    T item
) sealed

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert into the RollingWindowT.

Implements

IListTInsert(Int32, T)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the RollingWindowT.
InvalidOperationException | Rolling window is full (Count = WindowSize.
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).Remove Method

Grid Solutions Framework RollingWindowTRemove Method
Removes the first occurrence of a specific object from the RollingWindowT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    T item
)
Public Function Remove (
    item As T
) As Boolean
abstract Remove :
        item : 'T -> bool
override Remove :
        item : 'T -> bool
function Remove(item);
public:
virtual bool Remove(
    T item
) sealed

Parameters

item
Type: T
The object to remove from the ICollectionT.

Return Value

Type: Boolean
true if item was successfully removed from the RollingWindowT; otherwise, false. This method also returns false if item is not found in the original RollingWindowT.

Implements

ICollectionTRemove(T)
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).RemoveAt Method

Grid Solutions Framework RollingWindowTRemoveAt Method
Removes the RollingWindowT item at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
abstract RemoveAt :
        index : int -> unit
override RemoveAt :
        index : int -> unit
function RemoveAt(index);
public:
virtual void RemoveAt(
    int index
) sealed

Parameters

index
Type: SystemInt32
The zero-based index of the item to remove.

Implements

IListTRemoveAt(Int32)
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the RollingWindowT.
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T) Properties

Grid Solutions Framework RollingWindowT Properties

The RollingWindowT generic type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements contained in the RollingWindowT.
Public property | IsReadOnly | Gets a value indicating whether the RollingWindowT is read-only.
Public property | Item | Gets or sets the element at the specified index.
Public property | WindowSize | Gets the size of the window maintained by the RollingWindowT.
Top
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).Count Property

Grid Solutions Framework RollingWindowTCount Property
Gets the number of elements contained in the RollingWindowT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ICollectionTCount
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).IsReadOnly Property

Grid Solutions Framework RollingWindowTIsReadOnly Property
Gets a value indicating whether the RollingWindowT is read-only.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsReadOnly { get; }
Public ReadOnly Property IsReadOnly As Boolean
    Get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
function get_IsReadOnly();

public:
virtual property bool IsReadOnly {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).Item Property

Grid Solutions Framework RollingWindowTItem Property
Gets or sets the element at the specified index.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As T
    Get
    Set
abstract Item : 'T with get, set
override Item : 'T with get, set
function get_Item(index);
function set_Item(value);
public:
virtual property T default[int index] {
    T get (int index) sealed;
    void set (int index, T value) sealed;
}

Parameters

index
Type: SystemInt32
The zero-based index of the element to get or set.

Return Value

Type: T
The element at the specified index.

Implements

IListTItemInt32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is not a valid index in the RollingWindowT.
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


RollingWindow(T).WindowSize Property

Grid Solutions Framework RollingWindowTWindowSize Property
Gets the size of the window maintained by the RollingWindowT.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int WindowSize { get; }
Public ReadOnly Property WindowSize As Integer
    Get
member WindowSize : int with get

function get_WindowSize();

public:
property int WindowSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

RollingWindowT Class
GSF.Collections Namespace


SettingsCollection Class

Grid Solutions Framework SettingsCollection Class
A collection of settings that can be represented as a string of key-value pairs for easy persistence and also provide built-in validation support for the settings.
Inheritance Hierarchy
SystemObject
System.Collections.GenericDictionary String, String
GSF.CollectionsSettingsCollection

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class SettingsCollection : Dictionary<string, string>
<SerializableAttribute>
Public Class SettingsCollection
    Inherits Dictionary(Of String, String)
[<SerializableAttribute>]
type SettingsCollection =
    class
        inherit Dictionary<string, string>
    end
GSF.Collections.SettingsCollection = function();

Type.createClass(
    'GSF.Collections.SettingsCollection',
    Dictionary`2);
[SerializableAttribute]
public ref class SettingsCollection : public Dictionary<String^, String^>

The SettingsCollection type exposes the following members.

Constructors
 | Name | Description
Public method | SettingsCollection | Initializes a new instance of the SettingsCollection class.
Public method | SettingsCollection(IDictionaryString, String) | Initializes a new instance of the SettingsCollection class.
Public method | SettingsCollection(IEqualityComparerString) | Initializes a new instance of the SettingsCollection class.
Public method | SettingsCollection(IDictionaryString, String, IEqualityComparerString) | Initializes a new instance of the SettingsCollection class.
Top
Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary String, String .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary String, String .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary String, String .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary String, String .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary String, String .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public method | ToString | Gets the String representation of SettingsCollection. (Overrides ObjectToString.)
Public method | TryAdd | Adds an element with the specified key and value if an element is not present with the specified key.
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary String, String .)
Top
Operators
Name | Description
(String to SettingsCollection) | Implicitly converts String to SettingsCollection.
(SettingsCollection to String) | Implicitly converts SettingsCollection to a String.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary String, String .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary String, String .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public property | Validation | Gets the ValidationService object used to perform validation on the Values.
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Top
Examples
This example shows how to use SettingsCollection for key-value pair type settings and apply validation to them:
Copy
using System;
using System.Collections.Generic;
using GSF.Collections;
using GSF.Validation;

class Program
{
    static void Main(string[] args)
    {
        // Initialize settings.
        SettingsCollection settings = "Server=localhost;Port=5000";
        // Add validation rules.
        settings.Validation.AddValidation("Server", new NonNullStringValidator());
        settings.Validation.AddValidation("Port", new NonNullStringValidator());
        settings.Validation.AddValidation("Port", new NumericRangeValidator(1000, 2000));

        // Validate settings.
        string errors;
        if (!settings.Validation.Validate(out errors))
        {
            // Show validation errors.
            Console.WriteLine(string.Format("Settings: {0}\r\n", settings));
            Console.WriteLine(errors);
        }
        else
        {
            // Show stored settings.
            foreach (KeyValuePair<string, string> setting in settings)
            {
                Console.WriteLine(string.Format("Key={0}; Value={1}", setting.Key, setting.Value));
            }
        }

        Console.ReadLine();
    }
}
See Also

Reference

GSF.Collections Namespace
GSF.ValidationValidationService


SettingsCollection Constructor

Grid Solutions Framework SettingsCollection Constructor
Overload List
 | Name | Description
Public method | SettingsCollection | Initializes a new instance of the SettingsCollection class.
Public method | SettingsCollection(IDictionaryString, String) | Initializes a new instance of the SettingsCollection class.
Public method | SettingsCollection(IEqualityComparerString) | Initializes a new instance of the SettingsCollection class.
Public method | SettingsCollection(IDictionaryString, String, IEqualityComparerString) | Initializes a new instance of the SettingsCollection class.
Top
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


SettingsCollection Constructor

Grid Solutions Framework SettingsCollection Constructor
Initializes a new instance of the SettingsCollection class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SettingsCollection()
Public Sub New
new : unit -> SettingsCollection
GSF.Collections.SettingsCollection = function();
public:
SettingsCollection()
See Also

Reference

SettingsCollection Class
SettingsCollection Overload
GSF.Collections Namespace


SettingsCollection Constructor (IDictionary(String, String))

Grid Solutions Framework SettingsCollection Constructor (IDictionaryString, String)
Initializes a new instance of the SettingsCollection class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SettingsCollection(
    IDictionary<string, string> dictionary
)
Public Sub New (
    dictionary As IDictionary(Of String, String)
)
new :
        dictionary : IDictionary<string, string> -> SettingsCollection
GSF.Collections.SettingsCollection = function(dictionary);
public:
SettingsCollection(
    IDictionary<String^, String^>^ dictionary
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary String, String
The IDictionaryTKey, TValue whose elements are to be copied to this SettingsCollection.
See Also

Reference

SettingsCollection Class
SettingsCollection Overload
GSF.Collections Namespace


SettingsCollection Constructor (IEqualityComparer(String))

Grid Solutions Framework SettingsCollection Constructor (IEqualityComparerString)
Initializes a new instance of the SettingsCollection class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SettingsCollection(
    IEqualityComparer<string> comparer
)
Public Sub New (
    comparer As IEqualityComparer(Of String)
)
new :
        comparer : IEqualityComparer<string> -> SettingsCollection
GSF.Collections.SettingsCollection = function(comparer);
public:
SettingsCollection(
    IEqualityComparer<String^>^ comparer
)

Parameters

comparer
Type: System.Collections.GenericIEqualityComparer String
The StringComparer to use when comparing keys or null to use the default StringComparer.
See Also

Reference

SettingsCollection Class
SettingsCollection Overload
GSF.Collections Namespace


SettingsCollection Constructor (IDictionary(String, String), IEqualityComparer(String))

Grid Solutions Framework SettingsCollection Constructor (IDictionaryString, String, IEqualityComparerString)
Initializes a new instance of the SettingsCollection class.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SettingsCollection(
    IDictionary<string, string> dictionary,
    IEqualityComparer<string> comparer
)
Public Sub New (
    dictionary As IDictionary(Of String, String),
    comparer As IEqualityComparer(Of String)
)
new :
        dictionary : IDictionary<string, string> *
        comparer : IEqualityComparer<string> -> SettingsCollection
GSF.Collections.SettingsCollection = function(dictionary, comparer);
public:
SettingsCollection(
    IDictionary<String^, String^>^ dictionary,
    IEqualityComparer<String^>^ comparer
)

Parameters

dictionary
Type: System.Collections.GenericIDictionary String, String
The IDictionaryTKey, TValue whose elements are to be copied to this SettingsCollection.
comparer
Type: System.Collections.GenericIEqualityComparer String
The StringComparer to use when comparing keys or null to use the default StringComparer.
See Also

Reference

SettingsCollection Class
SettingsCollection Overload
GSF.Collections Namespace


SettingsCollection Methods

Grid Solutions Framework SettingsCollection Methods

The SettingsCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds the specified key and value to the dictionary. (Inherited from Dictionary String, String .)
Public method | Clear | Removes all keys and values from the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public method | ContainsKey | Determines whether the DictionaryTKey, TValue contains the specified key. (Inherited from Dictionary String, String .)
Public method | ContainsValue | Determines whether the DictionaryTKey, TValue contains a specific value. (Inherited from Dictionary String, String .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Implements the ISerializable interface and returns the data needed to serialize the DictionaryTKey, TValue instance. (Inherited from Dictionary String, String .)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OnDeserialization | Implements the ISerializable interface and raises the deserialization event when the deserialization is complete. (Inherited from Dictionary String, String .)
Public method | Remove | Removes the value with the specified key from the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public method | ToString | Gets the String representation of SettingsCollection. (Overrides ObjectToString.)
Public method | TryAdd | Adds an element with the specified key and value if an element is not present with the specified key.
Public method | TryGetValue | Gets the value associated with the specified key. (Inherited from Dictionary String, String .)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


SettingsCollection.ToString Method

Grid Solutions Framework SettingsCollectionToString Method
Gets the String representation of SettingsCollection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents SettingsCollection.
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


SettingsCollection.TryAdd Method

Grid Solutions Framework SettingsCollectionTryAdd Method
Adds an element with the specified key and value if an element is not present with the specified key.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryAdd(
    string key,
    string value
)
Public Function TryAdd (
    key As String,
    value As String
) As Boolean
member TryAdd :
        key : string *
        value : string -> bool

function TryAdd(key, value);
public:
bool TryAdd(
    String^ key,
    String^ value
)

Parameters

key
Type: SystemString
The key of the element to add.
value
Type: SystemString
The value of the element to add.

Return Value

Type: Boolean
true if an element is added; otherwise false.
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


SettingsCollection Type Conversions

Grid Solutions Framework SettingsCollection Type Conversions
Operators
Name | Description
(String to SettingsCollection) | Implicitly converts String to SettingsCollection.
(SettingsCollection to String) | Implicitly converts SettingsCollection to a String.
Top
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


SettingsCollection Implicit Conversion Operators

Grid Solutions Framework SettingsCollection Conversion Operators
Overload List
Name | Description
(String to SettingsCollection) | Implicitly converts String to SettingsCollection.
(SettingsCollection to String) | Implicitly converts SettingsCollection to a String.
Top
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


SettingsCollection Implicit Conversion (String to SettingsCollection)

Grid Solutions Framework SettingsCollection Conversion (String to SettingsCollection)
Implicitly converts String to SettingsCollection.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator SettingsCollection (
    string value
)
Public Shared Widening Operator CType (
    value As String
) As SettingsCollection
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator SettingsCollection^ (
    String^ value
)

Parameters

value
Type: SystemString
The String to convert.

Return Value

Type: SettingsCollection
A SettingsCollection object representing the result.
See Also

Reference

SettingsCollection Class
Overload
GSF.Collections Namespace


SettingsCollection Implicit Conversion (SettingsCollection to String)

Grid Solutions Framework SettingsCollection Conversion (SettingsCollection to String)
Implicitly converts SettingsCollection to a String.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator string (
    SettingsCollection value
)
Public Shared Widening Operator CType (
    value As SettingsCollection
) As String
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator String^ (
    SettingsCollection^ value
)

Parameters

value
Type: GSF.CollectionsSettingsCollection
The SettingsCollection to convert.

Return Value

Type: String
A String value representing the result.
See Also

Reference

SettingsCollection Class
Overload
GSF.Collections Namespace


SettingsCollection Properties

Grid Solutions Framework SettingsCollection Properties

The SettingsCollection type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the IEqualityComparerT that is used to determine equality of keys for the dictionary. (Inherited from Dictionary String, String .)
Public property | Count | Gets the number of key/value pairs contained in the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public property | Item | Gets or sets the value associated with the specified key. (Inherited from Dictionary String, String .)
Public property | Keys | Gets a collection containing the keys in the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Public property | Validation | Gets the ValidationService object used to perform validation on the Values.
Public property | Values | Gets a collection containing the values in the DictionaryTKey, TValue. (Inherited from Dictionary String, String .)
Top
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


SettingsCollection.Validation Property

Grid Solutions Framework SettingsCollectionValidation Property
Gets the ValidationService object used to perform validation on the Values.

Namespace: GSF.Collections
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ValidationService Validation { get; }
Public ReadOnly Property Validation As ValidationService
    Get
member Validation : ValidationService with get

function get_Validation();

public:
property ValidationService^ Validation {
    ValidationService^ get ();
}

Property Value

Type: ValidationService
See Also

Reference

SettingsCollection Class
GSF.Collections Namespace


GSF.Communication Namespace

Grid Solutions Framework GSF.Communication Namespace
Contains high-level classes and components related to any data communications including sockets, serial and file based transports used to simplify and standardize data access.
Classes
 | Class | Description
Public class | ClientBase | Base class for a client involved in server-client communication.
 | FileClient | Represents a communication client based on FileStream.
Public class | Payload | A helper class containing methods for manipulation of payload.
 | SerialClient | Represents a communication client based on SerialPort.
Public class | ServerBase | Base class for a server involved in server-client communication.
 | TcpClient | Represents a TCP-based communication client.
 | TcpServer | Represents a TCP-based communication server.
Public class | TlsClient | Represents a TCP-based communication client with SSL authentication and encryption.
Public class | TlsServer | Represents a TCP-based communication server with SSL authentication and encryption.
Public class | TlsServerTlsSocket | Represents a socket that has been wrapped in an SslStream for encryption.
Public class | Transport | Defines helper methods related to IP socket based communications.
Public class | TransportProviderT | A class for managing the communication between server and client.
Public class | TransportStatistics | A class for statistics related to server-client communication.
 | UdpClient | Represents a UDP-based communication server.
 | UdpServer | Represents a UDP-based communication server.
Public class | ZeroMQClient | Represents a ZeroMQ DEALER style socket as a communication client.
Public class | ZeroMQServer | Represents a ZeroMQ ROUTER style socket as a communication server.
Interfaces
 | Interface | Description
Public interface | IClient | Defines a client involved in server-client communication.
Public interface | IServer | Defines a server involved in server-client communication.
Enumerations
 | Enumeration | Description
Public enumeration | ClientIdentificationMode | Defines modes by which the UDP server will identify its clients when receiving messages.
Public enumeration | ClientState | Indicates the current state of the client.
Public enumeration | IPStack | IP stack enumeration.
Public enumeration | ServerState | Indicates the current state of the server.
Public enumeration | TransportProtocol | Indicates the protocol used in server-client communication.
Public enumeration | ZeroMQTransportProtocol | Indicates the transport protocol used in ZeroMQ communications.


ClientBase Class

Grid Solutions Framework ClientBase Class
Base class for a client involved in server-client communication.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
More...

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ClientBase))]
public abstract class ClientBase : Component,
    IClient, ISupportLifecycle, IDisposable, IProvideStatus, ISupportInitialize,
    IPersistSettings
<ToolboxBitmapAttribute(GetType(ClientBase))>
Public MustInherit Class ClientBase
    Inherits Component
    Implements IClient, ISupportLifecycle, IDisposable, IProvideStatus,
    ISupportInitialize, IPersistSettings
[<AbstractClassAttribute>]
[<ToolboxBitmapAttribute(typeof(ClientBase))>]
type ClientBase =
    class
        inherit Component
        interface IClient
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface ISupportInitialize
        interface IPersistSettings
    end
GSF.Communication.ClientBase = function();

Type.createClass(
    'GSF.Communication.ClientBase',
    Component,
    GSF.Communication.IClient,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    ISupportInitialize,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(ClientBase))]
public ref class ClientBase abstract : public Component,
    IClient, ISupportLifecycle, IDisposable, IProvideStatus, ISupportInitialize,
    IPersistSettings

The ClientBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ClientBase | Initializes a new instance of the client.
Protected method | ClientBase(TransportProtocol, String) | Initializes a new instance of the client.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized.
Public method | Connect | Connects the client to the server synchronously.
Public method | ConnectAsync | Connects the client to the server asynchronously.
 | Create | Create a communications client
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | When overridden in a derived class, disconnects client from the server synchronously.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the client and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved client settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event.
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event.
Protected method | OnConnectionException | Raises the ConnectionException event.
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event.
Protected method | OnReceiveData | Raises the ReceiveData event.
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event.
Protected method | OnReceiveDataException | Raises the ReceiveDataException event.
Protected method | OnSendDataComplete | Raises the SendDataComplete event.
Protected method | OnSendDataException | Raises the SendDataException event.
Protected method | OnSendDataStart | Raises the SendDataStart event.
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event.
Public method | Read | When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Public method | SaveSettings | Saves client settings to the config file if the PersistSettings property is set to true.
Public method | Send(Byte) | Sends data to the server synchronously.
Public method | Send(Object) | Sends data to the server synchronously.
Public method | Send(String) | Sends data to the server synchronously.
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously.
Public method | SendAsync(Byte) | Sends data to the server asynchronously.
Public method | SendAsync(Object) | Sends data to the server asynchronously.
Public method | SendAsync(String) | Sends data to the server asynchronously.
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously.
Protected method | SendDataAsync | When overridden in a derived class, sends data to the server asynchronously.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | When overridden in a derived class, validates the specified connectionString.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultMaxConnectionAttempts | Specifies the default value for the MaxConnectionAttempts property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultReceiveBufferSize | Specifies the default value for the ReceiveBufferSize property.
DefaultSendBufferSize | Specifies the default value for the SendBufferSize property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server.
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server.
Public property | Name | Gets the unique identifier of the client.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file.
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call.
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server.
Public property | ServerUri | Gets the server URI.
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client.
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server.
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server.
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server.
Public event | ConnectionEstablished | Occurs when client connection to the server is established.
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server.
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server.
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption.
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server.
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server.
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server.
Public event | SendDataStart | Occurs when the client begins sending data to the server.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

GSF.Communication Namespace
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
GSF.CommunicationFileClient
GSF.CommunicationSerialClient
GSF.CommunicationTcpClient
GSF.CommunicationTlsClient
GSF.CommunicationUdpClient
GSF.CommunicationZeroMQClient


ClientBase Constructor

Grid Solutions Framework ClientBase Constructor
Overload List
 | Name | Description
Protected method | ClientBase | Initializes a new instance of the client.
Protected method | ClientBase(TransportProtocol, String) | Initializes a new instance of the client.
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase Constructor

Grid Solutions Framework ClientBase Constructor
Initializes a new instance of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ClientBase()
Protected Sub New
new : unit -> ClientBase
GSF.Communication.ClientBase = function();
protected:
ClientBase()
See Also

Reference

ClientBase Class
ClientBase Overload
GSF.Communication Namespace


ClientBase Constructor (TransportProtocol, String)

Grid Solutions Framework ClientBase Constructor (TransportProtocol, String)
Initializes a new instance of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ClientBase(
    TransportProtocol transportProtocol,
    string connectionString
)
Protected Sub New (
    transportProtocol As TransportProtocol,
    connectionString As String
)
new :
        transportProtocol : TransportProtocol *
        connectionString : string -> ClientBase
GSF.Communication.ClientBase = function(transportProtocol, connectionString);
protected:
ClientBase(
    TransportProtocol transportProtocol,
    String^ connectionString
)

Parameters

transportProtocol
Type: GSF.CommunicationTransportProtocol
One of the TransportProtocol values.
connectionString
Type: SystemString
The data used by the client for connection to a server.
See Also

Reference

ClientBase Class
ClientBase Overload
GSF.Communication Namespace


ClientBase Fields

Grid Solutions Framework ClientBase Fields

The ClientBase type exposes the following members.

Fields
Name | Description
DefaultMaxConnectionAttempts | Specifies the default value for the MaxConnectionAttempts property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultReceiveBufferSize | Specifies the default value for the ReceiveBufferSize property.
DefaultSendBufferSize | Specifies the default value for the SendBufferSize property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.DefaultMaxConnectionAttempts Field

Grid Solutions Framework ClientBaseDefaultMaxConnectionAttempts Field
Specifies the default value for the MaxConnectionAttempts property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxConnectionAttempts
Public Const DefaultMaxConnectionAttempts As Integer
static val mutable DefaultMaxConnectionAttempts: int
var GSF.Communication.ClientBase.DefaultMaxConnectionAttempts
public:
literal int DefaultMaxConnectionAttempts

Field Value

Type: Int32
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.DefaultPersistSettings Field

Grid Solutions Framework ClientBaseDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.Communication.ClientBase.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.DefaultReceiveBufferSize Field

Grid Solutions Framework ClientBaseDefaultReceiveBufferSize Field
Specifies the default value for the ReceiveBufferSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultReceiveBufferSize
Public Const DefaultReceiveBufferSize As Integer
static val mutable DefaultReceiveBufferSize: int
var GSF.Communication.ClientBase.DefaultReceiveBufferSize
public:
literal int DefaultReceiveBufferSize

Field Value

Type: Int32
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.DefaultSendBufferSize Field

Grid Solutions Framework ClientBaseDefaultSendBufferSize Field
Specifies the default value for the SendBufferSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultSendBufferSize
Public Const DefaultSendBufferSize As Integer
static val mutable DefaultSendBufferSize: int
var GSF.Communication.ClientBase.DefaultSendBufferSize
public:
literal int DefaultSendBufferSize

Field Value

Type: Int32
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.DefaultSettingsCategory Field

Grid Solutions Framework ClientBaseDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.Communication.ClientBase.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase Methods

Grid Solutions Framework ClientBase Methods

The ClientBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized.
Public method | Connect | Connects the client to the server synchronously.
Public method | ConnectAsync | Connects the client to the server asynchronously.
 | Create | Create a communications client
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | When overridden in a derived class, disconnects client from the server synchronously.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the client and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved client settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event.
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event.
Protected method | OnConnectionException | Raises the ConnectionException event.
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event.
Protected method | OnReceiveData | Raises the ReceiveData event.
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event.
Protected method | OnReceiveDataException | Raises the ReceiveDataException event.
Protected method | OnSendDataComplete | Raises the SendDataComplete event.
Protected method | OnSendDataException | Raises the SendDataException event.
Protected method | OnSendDataStart | Raises the SendDataStart event.
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event.
Public method | Read | When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Public method | SaveSettings | Saves client settings to the config file if the PersistSettings property is set to true.
Public method | Send(Byte) | Sends data to the server synchronously.
Public method | Send(Object) | Sends data to the server synchronously.
Public method | Send(String) | Sends data to the server synchronously.
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously.
Public method | SendAsync(Byte) | Sends data to the server asynchronously.
Public method | SendAsync(Object) | Sends data to the server asynchronously.
Public method | SendAsync(String) | Sends data to the server asynchronously.
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously.
Protected method | SendDataAsync | When overridden in a derived class, sends data to the server asynchronously.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | When overridden in a derived class, validates the specified connectionString.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.BeginInit Method

Grid Solutions Framework ClientBaseBeginInit Method
Performs necessary operations before the client properties are initialized.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void BeginInit()
Public Sub BeginInit
abstract BeginInit : unit -> unit
override BeginInit : unit -> unit
function BeginInit();
public:
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the server is consumed through the designer surface of the IDE.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Connect Method

Grid Solutions Framework ClientBaseConnect Method
Connects the client to the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Connect()
Public Overridable Sub Connect
abstract Connect : unit -> unit
override Connect : unit -> unit
function Connect();
public:
virtual void Connect()

Implements

IClientConnect
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ConnectAsync Method

Grid Solutions Framework ClientBaseConnectAsync Method
Connects the client to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle ConnectAsync()
Public Overridable Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle
override ConnectAsync : unit -> WaitHandle
function ConnectAsync();
public:
virtual WaitHandle^ ConnectAsync()

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientConnectAsync
Exceptions
Exception | Condition
FormatException | Server property in ConnectionString is invalid.
InvalidOperationException | Attempt is made to connect the client when it is not disconnected.
Remarks
Derived classes are expected to override this method with protocol specific connection operations. Call the base class method to obtain an operational wait handle if protocol connection operation doesn't provide one already.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Create Method

Grid Solutions Framework ClientBaseCreate Method
Create a communications client

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IClient Create(
    string connectionString
)
Public Shared Function Create (
    connectionString As String
) As IClient
static member Create :
        connectionString : string -> IClient

GSF.Communication.ClientBase.Create = function(connectionString);
public:
static IClient^ Create(
    String^ connectionString
)

Parameters

connectionString
Type: SystemString
Connection string for the client.

Return Value

Type: IClient
A communications client.
Remarks
Note that typical connection string should be prefixed with a "protocol=tcp", "protocol=udp", "protocol=serial" or "protocol=file"
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Disconnect Method

Grid Solutions Framework ClientBaseDisconnect Method
When overridden in a derived class, disconnects client from the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Disconnect()
Public Overridable Sub Disconnect
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit
function Disconnect();
public:
virtual void Disconnect()

Implements

IClientDisconnect
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Dispose Method

Grid Solutions Framework ClientBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the client and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Dispose Method (Boolean)

Grid Solutions Framework ClientBaseDispose Method (Boolean)
Releases the unmanaged resources used by the client and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ClientBase Class
Dispose Overload
GSF.Communication Namespace


ClientBase.EndInit Method

Grid Solutions Framework ClientBaseEndInit Method
Performs necessary operations after the client properties are initialized.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EndInit()
Public Sub EndInit
abstract EndInit : unit -> unit
override EndInit : unit -> unit
function EndInit();
public:
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the server is consumed through the designer surface of the IDE.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Initialize Method

Grid Solutions Framework ClientBaseInitialize Method
Initializes the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the client is not consumed through the designer surface of the IDE.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.LoadSettings Method

Grid Solutions Framework ClientBaseLoadSettings Method
Loads saved client settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void LoadSettings()
Public Overridable Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings()

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnConnectionAttempt Method

Grid Solutions Framework ClientBaseOnConnectionAttempt Method
Raises the ConnectionAttempt event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConnectionAttempt()
Protected Overridable Sub OnConnectionAttempt
abstract OnConnectionAttempt : unit -> unit
override OnConnectionAttempt : unit -> unit
function OnConnectionAttempt();
protected:
virtual void OnConnectionAttempt()
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnConnectionEstablished Method

Grid Solutions Framework ClientBaseOnConnectionEstablished Method
Raises the ConnectionEstablished event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConnectionEstablished()
Protected Overridable Sub OnConnectionEstablished
abstract OnConnectionEstablished : unit -> unit
override OnConnectionEstablished : unit -> unit
function OnConnectionEstablished();
protected:
virtual void OnConnectionEstablished()
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnConnectionException Method

Grid Solutions Framework ClientBaseOnConnectionException Method
Raises the ConnectionException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConnectionException(
    Exception ex
)
Protected Overridable Sub OnConnectionException (
    ex As Exception
)
abstract OnConnectionException :
        ex : Exception -> unit
override OnConnectionException :
        ex : Exception -> unit
function OnConnectionException(ex);
protected:
virtual void OnConnectionException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to ConnectionException event.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnConnectionTerminated Method

Grid Solutions Framework ClientBaseOnConnectionTerminated Method
Raises the ConnectionTerminated event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConnectionTerminated()
Protected Overridable Sub OnConnectionTerminated
abstract OnConnectionTerminated : unit -> unit
override OnConnectionTerminated : unit -> unit
function OnConnectionTerminated();
protected:
virtual void OnConnectionTerminated()
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnReceiveData Method

Grid Solutions Framework ClientBaseOnReceiveData Method
Raises the ReceiveData event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceiveData(
    int size
)
Protected Overridable Sub OnReceiveData (
    size As Integer
)
abstract OnReceiveData :
        size : int -> unit
override OnReceiveData :
        size : int -> unit
function OnReceiveData(size);
protected:
virtual void OnReceiveData(
    int size
)

Parameters

size
Type: SystemInt32
Number of bytes received from the client.
Remarks
This event is automatically raised by call to OnReceiveDataComplete(Byte, Int32) so that inheritors never need to worry about raising this event. This method is only included here in case any custom client implementations need to explicitly raise this event.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnReceiveDataComplete Method

Grid Solutions Framework ClientBaseOnReceiveDataComplete Method
Raises the ReceiveDataComplete event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceiveDataComplete(
    byte[] data,
    int size
)
Protected Overridable Sub OnReceiveDataComplete (
    data As Byte(),
    size As Integer
)
abstract OnReceiveDataComplete :
        data : byte[] *
        size : int -> unit
override OnReceiveDataComplete :
        data : byte[] *
        size : int -> unit
function OnReceiveDataComplete(data, size);
protected:
virtual void OnReceiveDataComplete(
    array<unsigned char>^ data,
    int size
)

Parameters

data
Type: SystemByte
Data received from the client.
size
Type: SystemInt32
Number of bytes received from the client.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnReceiveDataException Method

Grid Solutions Framework ClientBaseOnReceiveDataException Method
Raises the ReceiveDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceiveDataException(
    Exception ex
)
Protected Overridable Sub OnReceiveDataException (
    ex As Exception
)
abstract OnReceiveDataException :
        ex : Exception -> unit
override OnReceiveDataException :
        ex : Exception -> unit
function OnReceiveDataException(ex);
protected:
virtual void OnReceiveDataException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to ReceiveDataException event.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnSendDataComplete Method

Grid Solutions Framework ClientBaseOnSendDataComplete Method
Raises the SendDataComplete event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSendDataComplete()
Protected Overridable Sub OnSendDataComplete
abstract OnSendDataComplete : unit -> unit
override OnSendDataComplete : unit -> unit
function OnSendDataComplete();
protected:
virtual void OnSendDataComplete()
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnSendDataException Method

Grid Solutions Framework ClientBaseOnSendDataException Method
Raises the SendDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSendDataException(
    Exception ex
)
Protected Overridable Sub OnSendDataException (
    ex As Exception
)
abstract OnSendDataException :
        ex : Exception -> unit
override OnSendDataException :
        ex : Exception -> unit
function OnSendDataException(ex);
protected:
virtual void OnSendDataException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to SendDataException event.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnSendDataStart Method

Grid Solutions Framework ClientBaseOnSendDataStart Method
Raises the SendDataStart event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSendDataStart()
Protected Overridable Sub OnSendDataStart
abstract OnSendDataStart : unit -> unit
override OnSendDataStart : unit -> unit
function OnSendDataStart();
protected:
virtual void OnSendDataStart()
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.OnUnhandledUserException Method

Grid Solutions Framework ClientBaseOnUnhandledUserException Method
Raises the UnhandledUserException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnhandledUserException(
    Exception ex
)
Protected Overridable Sub OnUnhandledUserException (
    ex As Exception
)
abstract OnUnhandledUserException :
        ex : Exception -> unit
override OnUnhandledUserException :
        ex : Exception -> unit
function OnUnhandledUserException(ex);
protected:
virtual void OnUnhandledUserException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to UnhandledUserException event.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Read Method

Grid Solutions Framework ClientBaseRead Method
When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public MustOverride Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int

function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) abstract

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IClientRead(Byte, Int32, Int32)
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.SaveSettings Method

Grid Solutions Framework ClientBaseSaveSettings Method
Saves client settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SaveSettings()
Public Overridable Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings()

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Send Method

Grid Solutions Framework ClientBaseSend Method
Overload List
 | Name | Description
Public method | Send(Byte) | Sends data to the server synchronously.
Public method | Send(Object) | Sends data to the server synchronously.
Public method | Send(String) | Sends data to the server synchronously.
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously.
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Send Method (Byte[])

Grid Solutions Framework ClientBaseSend Method (Byte)
Sends data to the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Send(
    byte[] data
)
Public Overridable Sub Send (
    data As Byte()
)
abstract Send :
        data : byte[] -> unit
override Send :
        data : byte[] -> unit
function Send(data);
public:
virtual void Send(
    array<unsigned char>^ data
)

Parameters

data
Type: SystemByte
The binary data that is to be sent.
See Also

Reference

ClientBase Class
Send Overload
GSF.Communication Namespace


ClientBase.Send Method (Object)

Grid Solutions Framework ClientBaseSend Method (Object)
Sends data to the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Send(
    Object serializableObject
)
Public Overridable Sub Send (
    serializableObject As Object
)
abstract Send :
        serializableObject : Object -> unit
override Send :
        serializableObject : Object -> unit
function Send(serializableObject);
public:
virtual void Send(
    Object^ serializableObject
)

Parameters

serializableObject
Type: SystemObject
The serializable object that is to be sent.
See Also

Reference

ClientBase Class
Send Overload
GSF.Communication Namespace


ClientBase.Send Method (String)

Grid Solutions Framework ClientBaseSend Method (String)
Sends data to the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Send(
    string data
)
Public Overridable Sub Send (
    data As String
)
abstract Send :
        data : string -> unit
override Send :
        data : string -> unit
function Send(data);
public:
virtual void Send(
    String^ data
)

Parameters

data
Type: SystemString
The plain-text data that is to be sent.
See Also

Reference

ClientBase Class
Send Overload
GSF.Communication Namespace


ClientBase.Send Method (Byte[], Int32, Int32)

Grid Solutions Framework ClientBaseSend Method (Byte, Int32, Int32)
Sends data to the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Send(
    byte[] data,
    int offset,
    int length
)
Public Overridable Sub Send (
    data As Byte(),
    offset As Integer,
    length As Integer
)
abstract Send :
        data : byte[] *
        offset : int *
        length : int -> unit
override Send :
        data : byte[] *
        offset : int *
        length : int -> unit
function Send(data, offset, length);
public:
virtual void Send(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Implements

IClientSend(Byte, Int32, Int32)
See Also

Reference

ClientBase Class
Send Overload
GSF.Communication Namespace


ClientBase.SendAsync Method

Grid Solutions Framework ClientBaseSendAsync Method
Overload List
 | Name | Description
Public method | SendAsync(Byte) | Sends data to the server asynchronously.
Public method | SendAsync(Object) | Sends data to the server asynchronously.
Public method | SendAsync(String) | Sends data to the server asynchronously.
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously.
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.SendAsync Method (Byte[])

Grid Solutions Framework ClientBaseSendAsync Method (Byte)
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendAsync(
    byte[] data
)
Public Overridable Function SendAsync (
    data As Byte()
) As WaitHandle
abstract SendAsync :
        data : byte[] -> WaitHandle
override SendAsync :
        data : byte[] -> WaitHandle
function SendAsync(data);
public:
virtual WaitHandle^ SendAsync(
    array<unsigned char>^ data
)

Parameters

data
Type: SystemByte
The binary data that is to be sent.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ClientBase Class
SendAsync Overload
GSF.Communication Namespace


ClientBase.SendAsync Method (Object)

Grid Solutions Framework ClientBaseSendAsync Method (Object)
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendAsync(
    Object serializableObject
)
Public Overridable Function SendAsync (
    serializableObject As Object
) As WaitHandle
abstract SendAsync :
        serializableObject : Object -> WaitHandle
override SendAsync :
        serializableObject : Object -> WaitHandle
function SendAsync(serializableObject);
public:
virtual WaitHandle^ SendAsync(
    Object^ serializableObject
)

Parameters

serializableObject
Type: SystemObject
The serializable object that is to be sent.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ClientBase Class
SendAsync Overload
GSF.Communication Namespace


ClientBase.SendAsync Method (String)

Grid Solutions Framework ClientBaseSendAsync Method (String)
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendAsync(
    string data
)
Public Overridable Function SendAsync (
    data As String
) As WaitHandle
abstract SendAsync :
        data : string -> WaitHandle
override SendAsync :
        data : string -> WaitHandle
function SendAsync(data);
public:
virtual WaitHandle^ SendAsync(
    String^ data
)

Parameters

data
Type: SystemString
The plain-text data that is to be sent.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ClientBase Class
SendAsync Overload
GSF.Communication Namespace


ClientBase.SendAsync Method (Byte[], Int32, Int32)

Grid Solutions Framework ClientBaseSendAsync Method (Byte, Int32, Int32)
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendAsync(
    byte[] data,
    int offset,
    int length
)
Public Overridable Function SendAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendAsync(data, offset, length);
public:
virtual WaitHandle^ SendAsync(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientSendAsync(Byte, Int32, Int32)
See Also

Reference

ClientBase Class
SendAsync Overload
GSF.Communication Namespace


ClientBase.SendDataAsync Method

Grid Solutions Framework ClientBaseSendDataAsync Method
When overridden in a derived class, sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract WaitHandle SendDataAsync(
    byte[] data,
    int offset,
    int length
)
Protected MustOverride Function SendDataAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle

function SendDataAsync(data, offset, length);
protected:
virtual WaitHandle^ SendDataAsync(
    array<unsigned char>^ data,
    int offset,
    int length
) abstract

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ValidateConnectionString Method

Grid Solutions Framework ClientBaseValidateConnectionString Method
When overridden in a derived class, validates the specified connectionString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void ValidateConnectionString(
    string connectionString
)
Protected MustOverride Sub ValidateConnectionString (
    connectionString As String
)
abstract ValidateConnectionString :
        connectionString : string -> unit

function ValidateConnectionString(connectionString);
protected:
virtual void ValidateConnectionString(
    String^ connectionString
) abstract

Parameters

connectionString
Type: SystemString
The connection string to be validated.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase Properties

Grid Solutions Framework ClientBase Properties

The ClientBase type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server.
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server.
Public property | Name | Gets the unique identifier of the client.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file.
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call.
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server.
Public property | ServerUri | Gets the server URI.
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client.
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server.
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server.
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ConnectionString Property

Grid Solutions Framework ClientBaseConnectionString Property
Gets or sets the data required by the client to connect to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ConnectionString { get; set; }
Public Overridable Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set
override ConnectionString : string with get, set
function get_ConnectionString();
function set_ConnectionString(value);
public:
virtual property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IClientConnectionString
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ConnectionTime Property

Grid Solutions Framework ClientBaseConnectionTime Property
Gets the Time for which the client has been connected to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual Time ConnectionTime { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property ConnectionTime As Time
    Get
[<BrowsableAttribute(false)>]
abstract ConnectionTime : Time with get
[<BrowsableAttribute(false)>]
override ConnectionTime : Time with get
function get_ConnectionTime();

public:
[BrowsableAttribute(false)]
virtual property Time ConnectionTime {
    Time get ();
}

Property Value

Type: Time

Implements

IClientConnectionTime
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.CurrentState Property

Grid Solutions Framework ClientBaseCurrentState Property
Gets the current ClientState.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual ClientState CurrentState { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property CurrentState As ClientState
    Get
[<BrowsableAttribute(false)>]
abstract CurrentState : ClientState with get
[<BrowsableAttribute(false)>]
override CurrentState : ClientState with get
function get_CurrentState();

public:
[BrowsableAttribute(false)]
virtual property ClientState CurrentState {
    ClientState get ();
}

Property Value

Type: ClientState

Implements

IClientCurrentState
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Enabled Property

Grid Solutions Framework ClientBaseEnabled Property
Gets or sets a boolean value that indicates whether the client is currently enabled.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool Enabled { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Enabled As Boolean
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract Enabled : bool with get, set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Setting Enabled to true will start connection cycle for the client if it is not connected, setting to false will disconnect the client if it is connected.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.IsDisposed Property

Grid Solutions Framework ClientBaseIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool IsDisposed { get; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract IsDisposed : bool with get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.MaxConnectionAttempts Property

Grid Solutions Framework ClientBaseMaxConnectionAttempts Property
Gets or sets the maximum number of times the client will attempt to connect to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(-1)]
public virtual int MaxConnectionAttempts { get; set; }
<DefaultValueAttribute(-1)>
Public Overridable Property MaxConnectionAttempts As Integer
    Get
    Set
[<DefaultValueAttribute(-1)>]
abstract MaxConnectionAttempts : int with get, set
[<DefaultValueAttribute(-1)>]
override MaxConnectionAttempts : int with get, set
function get_MaxConnectionAttempts();
function set_MaxConnectionAttempts(value);
public:
[DefaultValueAttribute(-1)]
virtual property int MaxConnectionAttempts {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IClientMaxConnectionAttempts
Remarks
Set MaxConnectionAttempts to -1 for infinite connection attempts.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Name Property

Grid Solutions Framework ClientBaseName Property
Gets the unique identifier of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual string Name { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.PersistSettings Property

Grid Solutions Framework ClientBasePersistSettings Property
Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ReadIndex Property

Grid Solutions Framework ClientBaseReadIndex Property
Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int ReadIndex { get; set; }
Protected Property ReadIndex As Integer
    Get
    Set
member ReadIndex : int with get, set

function get_ReadIndex();
function set_ReadIndex(value);
protected:
property int ReadIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ReceiveBufferSize Property

Grid Solutions Framework ClientBaseReceiveBufferSize Property
Gets or sets the size of the buffer used by the client for receiving data from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(32768)]
public virtual int ReceiveBufferSize { get; set; }
<DefaultValueAttribute(32768)>
Public Overridable Property ReceiveBufferSize As Integer
    Get
    Set
[<DefaultValueAttribute(32768)>]
abstract ReceiveBufferSize : int with get, set
[<DefaultValueAttribute(32768)>]
override ReceiveBufferSize : int with get, set
function get_ReceiveBufferSize();
function set_ReceiveBufferSize(value);
public:
[DefaultValueAttribute(32768)]
virtual property int ReceiveBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IClientReceiveBufferSize
Exceptions
Exception | Condition
ArgumentException | The value being assigned is either zero or negative.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.SendBufferSize Property

Grid Solutions Framework ClientBaseSendBufferSize Property
Gets or sets the size of the buffer used by the client for sending data to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(32768)]
public virtual int SendBufferSize { get; set; }
<DefaultValueAttribute(32768)>
Public Overridable Property SendBufferSize As Integer
    Get
    Set
[<DefaultValueAttribute(32768)>]
abstract SendBufferSize : int with get, set
[<DefaultValueAttribute(32768)>]
override SendBufferSize : int with get, set
function get_SendBufferSize();
function set_SendBufferSize(value);
public:
[DefaultValueAttribute(32768)]
virtual property int SendBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IClientSendBufferSize
Exceptions
Exception | Condition
ArgumentException | The value being assigned is either zero or negative.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ServerUri Property

Grid Solutions Framework ClientBaseServerUri Property
Gets the server URI.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract string ServerUri { get; }
Public MustOverride ReadOnly Property ServerUri As String
    Get
abstract ServerUri : string with get

function get_ServerUri();

public:
virtual property String^ ServerUri {
    String^ get () abstract;
}

Property Value

Type: String

Implements

IClientServerUri
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.SettingsCategory Property

Grid Solutions Framework ClientBaseSettingsCategory Property
Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("CommunicationClient")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("CommunicationClient")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("CommunicationClient")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("CommunicationClient")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"CommunicationClient")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.Status Property

Grid Solutions Framework ClientBaseStatus Property
Gets the descriptive status of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual string Status { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.TextEncoding Property

Grid Solutions Framework ClientBaseTextEncoding Property
Gets or sets the Encoding to be used for the text sent to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Encoding TextEncoding { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property TextEncoding As Encoding
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract TextEncoding : Encoding with get, set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override TextEncoding : Encoding with get, set
function get_TextEncoding();
function set_TextEncoding(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property Encoding^ TextEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding

Implements

IClientTextEncoding
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.TransportProtocol Property

Grid Solutions Framework ClientBaseTransportProtocol Property
Gets the TransportProtocol used by the client for the transportation of data with the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual TransportProtocol TransportProtocol { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property TransportProtocol As TransportProtocol
    Get
[<BrowsableAttribute(false)>]
abstract TransportProtocol : TransportProtocol with get
[<BrowsableAttribute(false)>]
override TransportProtocol : TransportProtocol with get
function get_TransportProtocol();

public:
[BrowsableAttribute(false)]
virtual property TransportProtocol TransportProtocol {
    TransportProtocol get ();
}

Property Value

Type: TransportProtocol

Implements

IClientTransportProtocol
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase Events

Grid Solutions Framework ClientBase Events

The ClientBase type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server.
Public event | ConnectionEstablished | Occurs when client connection to the server is established.
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server.
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server.
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption.
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server.
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server.
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server.
Public event | SendDataStart | Occurs when the client begins sending data to the server.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ConnectionAttempt Event

Grid Solutions Framework ClientBaseConnectionAttempt Event
Occurs when client is attempting connection to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionAttempt
Public Event ConnectionAttempt As EventHandler
abstract ConnectionAttempt : IEvent<EventHandler,
    EventArgs>
override ConnectionAttempt : IEvent<EventHandler,
    EventArgs>
function add_ConnectionAttempt(value);
function remove_ConnectionAttempt(value);
public:
virtual  event EventHandler^ ConnectionAttempt {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IClientConnectionAttempt
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ConnectionEstablished Event

Grid Solutions Framework ClientBaseConnectionEstablished Event
Occurs when client connection to the server is established.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionEstablished
Public Event ConnectionEstablished As EventHandler
abstract ConnectionEstablished : IEvent<EventHandler,
    EventArgs>
override ConnectionEstablished : IEvent<EventHandler,
    EventArgs>
function add_ConnectionEstablished(value);
function remove_ConnectionEstablished(value);
public:
virtual  event EventHandler^ ConnectionEstablished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IClientConnectionEstablished
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ConnectionException Event

Grid Solutions Framework ClientBaseConnectionException Event
Occurs when an Exception is encountered during connection attempt to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ConnectionException
Public Event ConnectionException As EventHandler(Of EventArgs(Of Exception))
abstract ConnectionException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ConnectionException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ConnectionException(value);
function remove_ConnectionException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ConnectionException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IClientConnectionException
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ConnectionTerminated Event

Grid Solutions Framework ClientBaseConnectionTerminated Event
Occurs when client connection to the server is terminated.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionTerminated
Public Event ConnectionTerminated As EventHandler
abstract ConnectionTerminated : IEvent<EventHandler,
    EventArgs>
override ConnectionTerminated : IEvent<EventHandler,
    EventArgs>
function add_ConnectionTerminated(value);
function remove_ConnectionTerminated(value);
public:
virtual  event EventHandler^ ConnectionTerminated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IClientConnectionTerminated
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ReceiveData Event

Grid Solutions Framework ClientBaseReceiveData Event
Occurs when unprocessed data has been received from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> ReceiveData
Public Event ReceiveData As EventHandler(Of EventArgs(Of Integer))
abstract ReceiveData : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
override ReceiveData : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
function add_ReceiveData(value);
function remove_ReceiveData(value);
public:
virtual  event EventHandler<EventArgs<int>^>^ ReceiveData {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32

Implements

IClientReceiveData
Remarks

This event can be used to receive a notification that server data has arrived. The Read(Byte, Int32, Int32) method can then be used to copy data to an existing buffer. In many cases it will be optimal to use an existing buffer instead of subscribing to the ReceiveDataComplete event.

Argument is the number of bytes received in the buffer from the server.

See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ReceiveDataComplete Event

Grid Solutions Framework ClientBaseReceiveDataComplete Event
Occurs when data received from the server has been processed and is ready for consumption.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<byte[], int>> ReceiveDataComplete
Public Event ReceiveDataComplete As EventHandler(Of EventArgs(Of Byte(), Integer))
abstract ReceiveDataComplete : IEvent<EventHandler<EventArgs<byte[], int>>,
    EventArgs<byte[], int>>
override ReceiveDataComplete : IEvent<EventHandler<EventArgs<byte[], int>>,
    EventArgs<byte[], int>>
function add_ReceiveDataComplete(value);
function remove_ReceiveDataComplete(value);
public:
virtual  event EventHandler<EventArgs<array<unsigned char>^, int>^>^ ReceiveDataComplete {
    void add (EventHandler<EventArgs<array<unsigned char>^, int>^>^ value);
    void remove (EventHandler<EventArgs<array<unsigned char>^, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Byte , Int32

Implements

IClientReceiveDataComplete
Remarks
Argument1 is a new buffer containing post-processed data received from the server starting at index zero.
Argument2 is the number of post-processed bytes received in the buffer from the server.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.ReceiveDataException Event

Grid Solutions Framework ClientBaseReceiveDataException Event
Occurs when an Exception is encountered when receiving data from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ReceiveDataException
Public Event ReceiveDataException As EventHandler(Of EventArgs(Of Exception))
abstract ReceiveDataException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ReceiveDataException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ReceiveDataException(value);
function remove_ReceiveDataException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ReceiveDataException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IClientReceiveDataException
Remarks
Argument is the Exception encountered when receiving data from the server.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.SendDataComplete Event

Grid Solutions Framework ClientBaseSendDataComplete Event
Occurs when the client has successfully sent data to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler SendDataComplete
Public Event SendDataComplete As EventHandler
abstract SendDataComplete : IEvent<EventHandler,
    EventArgs>
override SendDataComplete : IEvent<EventHandler,
    EventArgs>
function add_SendDataComplete(value);
function remove_SendDataComplete(value);
public:
virtual  event EventHandler^ SendDataComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IClientSendDataComplete
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.SendDataException Event

Grid Solutions Framework ClientBaseSendDataException Event
Occurs when an Exception is encountered when sending data to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> SendDataException
Public Event SendDataException As EventHandler(Of EventArgs(Of Exception))
abstract SendDataException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override SendDataException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_SendDataException(value);
function remove_SendDataException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ SendDataException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IClientSendDataException
Remarks
Argument is the Exception encountered when sending data to the server.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.SendDataStart Event

Grid Solutions Framework ClientBaseSendDataStart Event
Occurs when the client begins sending data to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler SendDataStart
Public Event SendDataStart As EventHandler
abstract SendDataStart : IEvent<EventHandler,
    EventArgs>
override SendDataStart : IEvent<EventHandler,
    EventArgs>
function add_SendDataStart(value);
function remove_SendDataStart(value);
public:
virtual  event EventHandler^ SendDataStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IClientSendDataStart
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientBase.UnhandledUserException Event

Grid Solutions Framework ClientBaseUnhandledUserException Event
Occurs when an Exception is encountered in a user-defined function via an event dispatch.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> UnhandledUserException
Public Event UnhandledUserException As EventHandler(Of EventArgs(Of Exception))
abstract UnhandledUserException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override UnhandledUserException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_UnhandledUserException(value);
function remove_UnhandledUserException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ UnhandledUserException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IClientUnhandledUserException
Remarks
Argument is the Exception thrown by the user-defined function.
See Also

Reference

ClientBase Class
GSF.Communication Namespace


ClientIdentificationMode Enumeration

Grid Solutions Framework ClientIdentificationMode Enumeration
Defines modes by which the UDP server will identify its clients when receiving messages.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ClientIdentificationMode
Public Enumeration ClientIdentificationMode
type ClientIdentificationMode
GSF.Communication.ClientIdentificationMode = function();
GSF.Communication.ClientIdentificationMode.createEnum('GSF.Communication.ClientIdentificationMode', false);
public enum class ClientIdentificationMode
Members
Member name | Value | Description
IP | 0 | Identify clients by their IP address.
Port | 1 | Identify clients by the port they are bound to.
EndPoint | 2 | Identify clients by both their IP address and the port they are bound to.
See Also

Reference

GSF.Communication Namespace


ClientState Enumeration

Grid Solutions Framework ClientState Enumeration
Indicates the current state of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ClientState
Public Enumeration ClientState
type ClientState
GSF.Communication.ClientState = function();
GSF.Communication.ClientState.createEnum('GSF.Communication.ClientState', false);
public enum class ClientState
Members
Member name | Value | Description
Connecting | 0 | Client is establishing connection.
Connected | 1 | Client has established connection.
Disconnected | 2 | Client connection is terminated.
See Also

Reference

GSF.Communication Namespace


FileClient Class

Grid Solutions Framework FileClient Class
Represents a communication client based on FileStream.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
GSF.CommunicationFileClient

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FileClient : ClientBase
Public Class FileClient
    Inherits ClientBase
type FileClient =
    class
        inherit ClientBase
    end
GSF.Communication.FileClient = function();

Type.createClass(
    'GSF.Communication.FileClient',
    GSF.Communication.ClientBase);
public ref class FileClient : public ClientBase

The FileClient type exposes the following members.

Constructors
 | Name | Description
Public method | FileClient | Initializes a new instance of the FileClient class.
Public method | FileClient(IContainer) | Initializes a new instance of the FileClient class.
Public method | FileClient(String) | Initializes a new instance of the FileClient class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the FileClient to the FileStream asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the FileClient from the FileStream. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved FileClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | ReadNextBuffer | Reads next data buffer from the FileStream.
Public method | SaveSettings | Saves FileClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends (writes) data to the file asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAutoRepeat | Specifies the default value for the AutoRepeat property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultFileAccessMode | Specifies the default value for the FileAccessMode property.
DefaultFileOpenMode | Specifies the default value for the FileOpenMode property.
DefaultFileShareMode | Specifies the default value for the FileShareMode property.
DefaultReceiveInterval | Specifies the default value for the ReceiveInterval property.
DefaultReceiveOnDemand | Specifies the default value for the ReceiveOnDemand property.
DefaultStartingOffset | Specifies the default value for the StartingOffset property.
Top
Properties
 | Name | Description
Public property | AutoRepeat | Gets or sets a boolean value that indicates whether receiving (reading) of data is to be repeated endlessly.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the FileStream object for the FileClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileAccessMode | Gets or sets the FileAccess value to be used when opening the file.
Public property | FileOpenMode | Gets or sets the FileMode value to be used when opening the file.
Public property | FileShareMode | Gets or set the FileShare value to be used when opening the file.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | ReceiveInterval | Gets or sets the number of milliseconds to pause before receiving (reading) the next available set of data.
Public property | ReceiveOnDemand | Gets or sets a boolean value that indicates whether receiving (reading) of data will be initiated manually by calling ReadNextBuffer.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the FileClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | StartingOffset | Gets or sets the starting point relative to the beginning of the file from where the data is to be received (read).
Public property | Status | Gets the descriptive status of the client. (Inherited from ClientBase.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
Examples
This example shows how to use FileClient for writing data to a file:
Copy
using System;
using GSF.Communication;

class Program
{
    static FileClient s_client;

    static void Main(string[] args)
    {
        // Initialize the client.
        s_client = new FileClient(@"File=c:\File.txt");
        s_client.Initialize();
        // Register event handlers.
        s_client.ConnectionAttempt += s_client_ConnectionAttempt;
        s_client.ConnectionEstablished += s_client_ConnectionEstablished;
        s_client.ConnectionTerminated += s_client_ConnectionTerminated;
        s_client.SendDataComplete += s_client_SendDataComplete;
        // Connect the client.
        s_client.Connect();

        // Write user input to the file.
        string input;
        while (string.Compare(input = Console.ReadLine(), "Exit", true) != 0)
        {
            s_client.Send(input + "\r\n");
        }

        // Disconnect the client on shutdown.
        s_client.Dispose();
    }

    static void s_client_ConnectionAttempt(object sender, EventArgs e)
    {
        Console.WriteLine("Client is connecting to file.");
    }

    static void s_client_ConnectionEstablished(object sender, EventArgs e)
    {
        Console.WriteLine("Client connected to file.");
    }

    static void s_client_ConnectionTerminated(object sender, EventArgs e)
    {
        Console.WriteLine("Client disconnected from file.");
    }

    static void s_client_SendDataComplete(object sender, EventArgs e)
    {
        Console.WriteLine(string.Format("Sent data - {0}", s_client.TextEncoding.GetString(s_client.Client.SendBuffer)));
    }
}
This example shows how to use FileClient for reading data to a file:
Copy
using System;
using GSF;
using GSF.Communication;

class Program
{
    static FileClient s_client;

    static void Main(string[] args)
    {
        // Initialize the client.
        s_client = new FileClient(@"File=c:\File.txt");
        s_client.Initialize();
        // Register event handlers.
        s_client.ConnectionAttempt += s_client_ConnectionAttempt;
        s_client.ConnectionEstablished += s_client_ConnectionEstablished;
        s_client.ConnectionTerminated += s_client_ConnectionTerminated;
        s_client.ReceiveDataComplete += s_client_ReceiveDataComplete;
        // Connect the client.
        s_client.Connect();

        // Wait for client to read data.
        Console.ReadLine();

        // Disconnect the client on shutdown.
        s_client.Dispose();
    }

    static void s_client_ConnectionAttempt(object sender, EventArgs e)
    {
        Console.WriteLine("Client is connecting to file.");
    }

    static void s_client_ConnectionEstablished(object sender, EventArgs e)
    {
        Console.WriteLine("Client connected to file.");
    }

    static void s_client_ConnectionTerminated(object sender, EventArgs e)
    {
        Console.WriteLine("Client disconnected from file.");
    }

    static void s_client_ReceiveDataComplete(object sender, EventArgs<byte[], int> e)
    {
        Console.WriteLine(string.Format("Received data - {0}", s_client.TextEncoding.GetString(e.Argument1, 0, e.Argument2)));
    }
}
See Also

Reference

GSF.Communication Namespace


FileClient Constructor

Grid Solutions Framework FileClient Constructor
Overload List
 | Name | Description
Public method | FileClient | Initializes a new instance of the FileClient class.
Public method | FileClient(IContainer) | Initializes a new instance of the FileClient class.
Public method | FileClient(String) | Initializes a new instance of the FileClient class.
Top
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient Constructor

Grid Solutions Framework FileClient Constructor
Initializes a new instance of the FileClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileClient()
Public Sub New
new : unit -> FileClient
GSF.Communication.FileClient = function();
public:
FileClient()
See Also

Reference

FileClient Class
FileClient Overload
GSF.Communication Namespace


FileClient Constructor (IContainer)

Grid Solutions Framework FileClient Constructor (IContainer)
Initializes a new instance of the FileClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileClient(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> FileClient
GSF.Communication.FileClient = function(container);
public:
FileClient(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the FileClient.
See Also

Reference

FileClient Class
FileClient Overload
GSF.Communication Namespace


FileClient Constructor (String)

Grid Solutions Framework FileClient Constructor (String)
Initializes a new instance of the FileClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileClient(
    string connectString
)
Public Sub New (
    connectString As String
)
new :
        connectString : string -> FileClient
GSF.Communication.FileClient = function(connectString);
public:
FileClient(
    String^ connectString
)

Parameters

connectString
Type: SystemString
Connect string of the FileClient. See DefaultConnectionString for format.
See Also

Reference

FileClient Class
FileClient Overload
GSF.Communication Namespace


FileClient Fields

Grid Solutions Framework FileClient Fields

The FileClient type exposes the following members.

Fields
Name | Description
DefaultAutoRepeat | Specifies the default value for the AutoRepeat property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultFileAccessMode | Specifies the default value for the FileAccessMode property.
DefaultFileOpenMode | Specifies the default value for the FileOpenMode property.
DefaultFileShareMode | Specifies the default value for the FileShareMode property.
DefaultReceiveInterval | Specifies the default value for the ReceiveInterval property.
DefaultReceiveOnDemand | Specifies the default value for the ReceiveOnDemand property.
DefaultStartingOffset | Specifies the default value for the StartingOffset property.
Top
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultAutoRepeat Field

Grid Solutions Framework FileClientDefaultAutoRepeat Field
Specifies the default value for the AutoRepeat property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAutoRepeat
Public Const DefaultAutoRepeat As Boolean
static val mutable DefaultAutoRepeat: bool
var GSF.Communication.FileClient.DefaultAutoRepeat
public:
literal bool DefaultAutoRepeat

Field Value

Type: Boolean
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultConnectionString Field

Grid Solutions Framework FileClientDefaultConnectionString Field
Specifies the default value for the ConnectionString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConnectionString
Public Const DefaultConnectionString As String
static val mutable DefaultConnectionString: string
var GSF.Communication.FileClient.DefaultConnectionString
public:
literal String^ DefaultConnectionString

Field Value

Type: String
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultFileAccessMode Field

Grid Solutions Framework FileClientDefaultFileAccessMode Field
Specifies the default value for the FileAccessMode property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const FileAccess DefaultFileAccessMode
Public Const DefaultFileAccessMode As FileAccess
static val mutable DefaultFileAccessMode: FileAccess
var GSF.Communication.FileClient.DefaultFileAccessMode
public:
literal FileAccess DefaultFileAccessMode

Field Value

Type: FileAccess
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultFileOpenMode Field

Grid Solutions Framework FileClientDefaultFileOpenMode Field
Specifies the default value for the FileOpenMode property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const FileMode DefaultFileOpenMode
Public Const DefaultFileOpenMode As FileMode
static val mutable DefaultFileOpenMode: FileMode
var GSF.Communication.FileClient.DefaultFileOpenMode
public:
literal FileMode DefaultFileOpenMode

Field Value

Type: FileMode
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultFileShareMode Field

Grid Solutions Framework FileClientDefaultFileShareMode Field
Specifies the default value for the FileShareMode property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const FileShare DefaultFileShareMode
Public Const DefaultFileShareMode As FileShare
static val mutable DefaultFileShareMode: FileShare
var GSF.Communication.FileClient.DefaultFileShareMode
public:
literal FileShare DefaultFileShareMode

Field Value

Type: FileShare
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultReceiveInterval Field

Grid Solutions Framework FileClientDefaultReceiveInterval Field
Specifies the default value for the ReceiveInterval property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultReceiveInterval
Public Const DefaultReceiveInterval As Integer
static val mutable DefaultReceiveInterval: int
var GSF.Communication.FileClient.DefaultReceiveInterval
public:
literal int DefaultReceiveInterval

Field Value

Type: Int32
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultReceiveOnDemand Field

Grid Solutions Framework FileClientDefaultReceiveOnDemand Field
Specifies the default value for the ReceiveOnDemand property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultReceiveOnDemand
Public Const DefaultReceiveOnDemand As Boolean
static val mutable DefaultReceiveOnDemand: bool
var GSF.Communication.FileClient.DefaultReceiveOnDemand
public:
literal bool DefaultReceiveOnDemand

Field Value

Type: Boolean
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.DefaultStartingOffset Field

Grid Solutions Framework FileClientDefaultStartingOffset Field
Specifies the default value for the StartingOffset property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long DefaultStartingOffset
Public Const DefaultStartingOffset As Long
static val mutable DefaultStartingOffset: int64
var GSF.Communication.FileClient.DefaultStartingOffset
public:
literal long long DefaultStartingOffset

Field Value

Type: Int64
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient Methods

Grid Solutions Framework FileClient Methods

The FileClient type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the FileClient to the FileStream asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the FileClient from the FileStream. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved FileClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | ReadNextBuffer | Reads next data buffer from the FileStream.
Public method | SaveSettings | Saves FileClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends (writes) data to the file asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.ConnectAsync Method

Grid Solutions Framework FileClientConnectAsync Method
Connects the FileClient to the FileStream asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override WaitHandle ConnectAsync()
Public Overrides Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle
override ConnectAsync : unit -> WaitHandle
function ConnectAsync();
public:
virtual WaitHandle^ ConnectAsync() override

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientConnectAsync
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to connect the FileClient when it is not disconnected.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.Disconnect Method

Grid Solutions Framework FileClientDisconnect Method
Disconnects the FileClient from the FileStream.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Disconnect()
Public Overrides Sub Disconnect
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit
function Disconnect();
public:
virtual void Disconnect() override

Implements

IClientDisconnect
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.Dispose Method

Grid Solutions Framework FileClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FileClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Top
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.Dispose Method (Boolean)

Grid Solutions Framework FileClientDispose Method (Boolean)
Releases the unmanaged resources used by the FileClient and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FileClient Class
Dispose Overload
GSF.Communication Namespace


FileClient.LoadSettings Method

Grid Solutions Framework FileClientLoadSettings Method
Loads saved FileClient settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.OnConnectionException Method

Grid Solutions Framework FileClientOnConnectionException Method
Raises the ConnectionException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnConnectionException(
    Exception ex
)
Protected Overrides Sub OnConnectionException (
    ex As Exception
)
abstract OnConnectionException :
        ex : Exception -> unit
override OnConnectionException :
        ex : Exception -> unit
function OnConnectionException(ex);
protected:
virtual void OnConnectionException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ConnectionException event.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.Read Method

Grid Solutions Framework FileClientRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IClientRead(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.ReadNextBuffer Method

Grid Solutions Framework FileClientReadNextBuffer Method
Reads next data buffer from the FileStream.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ReadNextBuffer()
Public Sub ReadNextBuffer
member ReadNextBuffer : unit -> unit

function ReadNextBuffer();
public:
void ReadNextBuffer()
Exceptions
Exception | Condition
InvalidOperationException | ReadNextBuffer is called when FileClient is not connected.
InvalidOperationException | ReadNextBuffer is called when ReceiveOnDemand is disabled.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.SaveSettings Method

Grid Solutions Framework FileClientSaveSettings Method
Saves FileClient settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.SendDataAsync Method

Grid Solutions Framework FileClientSendDataAsync Method
Sends (writes) data to the file asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataAsync(
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataAsync(data, offset, length);
protected:
virtual WaitHandle^ SendDataAsync(
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent (written).
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending (writing) data.
length
Type: SystemInt32
The number of bytes to be sent (written) from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.ValidateConnectionString Method

Grid Solutions Framework FileClientValidateConnectionString Method
Validates the specified connectionString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConnectionString(
    string connectionString
)
Protected Overrides Sub ValidateConnectionString (
    connectionString As String
)
abstract ValidateConnectionString :
        connectionString : string -> unit
override ValidateConnectionString :
        connectionString : string -> unit
function ValidateConnectionString(connectionString);
protected:
virtual void ValidateConnectionString(
    String^ connectionString
) override

Parameters

connectionString
Type: SystemString
Connection string to be validated.
Exceptions
Exception | Condition
ArgumentException | File property is missing.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient Properties

Grid Solutions Framework FileClient Properties

The FileClient type exposes the following members.

Properties
 | Name | Description
Public property | AutoRepeat | Gets or sets a boolean value that indicates whether receiving (reading) of data is to be repeated endlessly.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the FileStream object for the FileClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileAccessMode | Gets or sets the FileAccess value to be used when opening the file.
Public property | FileOpenMode | Gets or sets the FileMode value to be used when opening the file.
Public property | FileShareMode | Gets or set the FileShare value to be used when opening the file.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | ReceiveInterval | Gets or sets the number of milliseconds to pause before receiving (reading) the next available set of data.
Public property | ReceiveOnDemand | Gets or sets a boolean value that indicates whether receiving (reading) of data will be initiated manually by calling ReadNextBuffer.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the FileClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | StartingOffset | Gets or sets the starting point relative to the beginning of the file from where the data is to be received (read).
Public property | Status | Gets the descriptive status of the client. (Inherited from ClientBase.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.AutoRepeat Property

Grid Solutions Framework FileClientAutoRepeat Property
Gets or sets a boolean value that indicates whether receiving (reading) of data is to be repeated endlessly.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool AutoRepeat { get; set; }
<DefaultValueAttribute(false)>
Public Property AutoRepeat As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member AutoRepeat : bool with get, set

function get_AutoRepeat();
function set_AutoRepeat(value);
public:
[DefaultValueAttribute(false)]
property bool AutoRepeat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
InvalidOperationException | AutoRepeat is enabled when FileAccessMode is ReadWrite
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.Client Property

Grid Solutions Framework FileClientClient Property
Gets the FileStream object for the FileClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public FileStream Client { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Client As FileStream
    Get
[<BrowsableAttribute(false)>]
member Client : FileStream with get

function get_Client();

public:
[BrowsableAttribute(false)]
property FileStream^ Client {
    FileStream^ get ();
}

Property Value

Type: FileStream
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.FileAccessMode Property

Grid Solutions Framework FileClientFileAccessMode Property
Gets or sets the FileAccess value to be used when opening the file.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(FileAccess.ReadWrite)]
public FileAccess FileAccessMode { get; set; }
<DefaultValueAttribute(FileAccess.ReadWrite)>
Public Property FileAccessMode As FileAccess
    Get
    Set
[<DefaultValueAttribute(FileAccess.ReadWrite)>]
member FileAccessMode : FileAccess with get, set

function get_FileAccessMode();
function set_FileAccessMode(value);
public:
[DefaultValueAttribute(FileAccess::ReadWrite)]
property FileAccess FileAccessMode {
    FileAccess get ();
    void set (FileAccess value);
}

Property Value

Type: FileAccess
Exceptions
Exception | Condition
InvalidOperationException | FileAccessMode is set to ReadWrite when AutoRepeat is enabled.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.FileOpenMode Property

Grid Solutions Framework FileClientFileOpenMode Property
Gets or sets the FileMode value to be used when opening the file.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(FileMode.OpenOrCreate)]
public FileMode FileOpenMode { get; set; }
<DefaultValueAttribute(FileMode.OpenOrCreate)>
Public Property FileOpenMode As FileMode
    Get
    Set
[<DefaultValueAttribute(FileMode.OpenOrCreate)>]
member FileOpenMode : FileMode with get, set

function get_FileOpenMode();
function set_FileOpenMode(value);
public:
[DefaultValueAttribute(FileMode::OpenOrCreate)]
property FileMode FileOpenMode {
    FileMode get ();
    void set (FileMode value);
}

Property Value

Type: FileMode
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.FileShareMode Property

Grid Solutions Framework FileClientFileShareMode Property
Gets or set the FileShare value to be used when opening the file.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(FileShare.ReadWrite)]
public FileShare FileShareMode { get; set; }
<DefaultValueAttribute(FileShare.ReadWrite)>
Public Property FileShareMode As FileShare
    Get
    Set
[<DefaultValueAttribute(FileShare.ReadWrite)>]
member FileShareMode : FileShare with get, set

function get_FileShareMode();
function set_FileShareMode(value);
public:
[DefaultValueAttribute(FileShare::ReadWrite)]
property FileShare FileShareMode {
    FileShare get ();
    void set (FileShare value);
}

Property Value

Type: FileShare
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.ReceiveInterval Property

Grid Solutions Framework FileClientReceiveInterval Property
Gets or sets the number of milliseconds to pause before receiving (reading) the next available set of data.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(-1)]
public double ReceiveInterval { get; set; }
<DefaultValueAttribute(-1)>
Public Property ReceiveInterval As Double
    Get
    Set
[<DefaultValueAttribute(-1)>]
member ReceiveInterval : float with get, set

function get_ReceiveInterval();
function set_ReceiveInterval(value);
public:
[DefaultValueAttribute(-1)]
property double ReceiveInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
Set ReceiveInterval = -1 to receive (read) data continuously without pausing.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.ReceiveOnDemand Property

Grid Solutions Framework FileClientReceiveOnDemand Property
Gets or sets a boolean value that indicates whether receiving (reading) of data will be initiated manually by calling ReadNextBuffer.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool ReceiveOnDemand { get; set; }
<DefaultValueAttribute(false)>
Public Property ReceiveOnDemand As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member ReceiveOnDemand : bool with get, set

function get_ReceiveOnDemand();
function set_ReceiveOnDemand(value);
public:
[DefaultValueAttribute(false)]
property bool ReceiveOnDemand {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
ReceiveInterval will be set to -1 when ReceiveOnDemand is enabled.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.ServerUri Property

Grid Solutions Framework FileClientServerUri Property
Gets the server URI of the FileClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override string ServerUri { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ServerUri As String
    Get
[<BrowsableAttribute(false)>]
abstract ServerUri : string with get
[<BrowsableAttribute(false)>]
override ServerUri : string with get
function get_ServerUri();

public:
[BrowsableAttribute(false)]
virtual property String^ ServerUri {
    String^ get () override;
}

Property Value

Type: String

Implements

IClientServerUri
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient.StartingOffset Property

Grid Solutions Framework FileClientStartingOffset Property
Gets or sets the starting point relative to the beginning of the file from where the data is to be received (read).

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(0)]
public long StartingOffset { get; set; }
<DefaultValueAttribute(0)>
Public Property StartingOffset As Long
    Get
    Set
[<DefaultValueAttribute(0)>]
member StartingOffset : int64 with get, set

function get_StartingOffset();
function set_StartingOffset(value);
public:
[DefaultValueAttribute(0)]
property long long StartingOffset {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not a positive number.
See Also

Reference

FileClient Class
GSF.Communication Namespace


FileClient Events

Grid Solutions Framework FileClient Events

The FileClient type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

FileClient Class
GSF.Communication Namespace


IClient Interface

Grid Solutions Framework IClient Interface
Defines a client involved in server-client communication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IClient : ISupportLifecycle,
    IDisposable, IProvideStatus
Public Interface IClient
    Inherits ISupportLifecycle, IDisposable, IProvideStatus
type IClient =
    interface
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.Communication.IClient = function();
GSF.Communication.IClient.createInterface('GSF.Communication.IClient');
public interface class IClient : ISupportLifecycle,
    IDisposable, IProvideStatus

The IClient type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connects client to the server synchronously.
Public method | ConnectAsync | Connects client to the server asynchronously.
Public method | Disconnect | Disconnects client from the server synchronously.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Public method | Send | Sends data to the server synchronously.
Public method | SendAsync | Sends data to the server asynchronously.
Top
Properties
 | Name | Description
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server.
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server.
Public property | CurrentState | Gets the current ClientState.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | ServerUri | Gets the server URI.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server.
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server.
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server.
Public event | ConnectionEstablished | Occurs when client connection to the server is established.
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server.
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server.
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption.
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server.
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server.
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server.
Public event | SendDataStart | Occurs when the client begins sending data to the server.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

GSF.Communication Namespace


IClient Methods

Grid Solutions Framework IClient Methods

The IClient type exposes the following members.

Methods
 | Name | Description
Public method | Connect | Connects client to the server synchronously.
Public method | ConnectAsync | Connects client to the server asynchronously.
Public method | Disconnect | Disconnects client from the server synchronously.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Public method | Send | Sends data to the server synchronously.
Public method | SendAsync | Sends data to the server asynchronously.
Top
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.Connect Method

Grid Solutions Framework IClientConnect Method
Connects client to the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Connect()
Sub Connect
abstract Connect : unit -> unit

function Connect();
void Connect()
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ConnectAsync Method

Grid Solutions Framework IClientConnectAsync Method
Connects client to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
WaitHandle ConnectAsync()
Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle

function ConnectAsync();
WaitHandle^ ConnectAsync()

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.Disconnect Method

Grid Solutions Framework IClientDisconnect Method
Disconnects client from the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Disconnect()
Sub Disconnect
abstract Disconnect : unit -> unit

function Disconnect();
void Disconnect()
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.Read Method

Grid Solutions Framework IClientRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int

function Read(buffer, startIndex, length);
int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.Send Method

Grid Solutions Framework IClientSend Method
Sends data to the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Send(
    byte[] data,
    int offset,
    int length
)
Sub Send (
    data As Byte(),
    offset As Integer,
    length As Integer
)
abstract Send :
        data : byte[] *
        offset : int *
        length : int -> unit

function Send(data, offset, length);
void Send(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.SendAsync Method

Grid Solutions Framework IClientSendAsync Method
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
WaitHandle SendAsync(
    byte[] data,
    int offset,
    int length
)
Function SendAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle

function SendAsync(data, offset, length);
WaitHandle^ SendAsync(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient Properties

Grid Solutions Framework IClient Properties

The IClient type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server.
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server.
Public property | CurrentState | Gets the current ClientState.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | ServerUri | Gets the server URI.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server.
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server.
Top
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ConnectionString Property

Grid Solutions Framework IClientConnectionString Property
Gets or sets the data required by the client to connect to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ConnectionString { get; set; }
Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ConnectionTime Property

Grid Solutions Framework IClientConnectionTime Property
Gets the Time for which the client has been connected to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Time ConnectionTime { get; }
ReadOnly Property ConnectionTime As Time
    Get
abstract ConnectionTime : Time with get

function get_ConnectionTime();

property Time ConnectionTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.CurrentState Property

Grid Solutions Framework IClientCurrentState Property
Gets the current ClientState.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ClientState CurrentState { get; }
ReadOnly Property CurrentState As ClientState
    Get
abstract CurrentState : ClientState with get

function get_CurrentState();

property ClientState CurrentState {
    ClientState get ();
}

Property Value

Type: ClientState
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.MaxConnectionAttempts Property

Grid Solutions Framework IClientMaxConnectionAttempts Property
Gets or sets the maximum number of times the client will attempt to connect to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int MaxConnectionAttempts { get; set; }
Property MaxConnectionAttempts As Integer
    Get
    Set
abstract MaxConnectionAttempts : int with get, set

function get_MaxConnectionAttempts();
function set_MaxConnectionAttempts(value);
property int MaxConnectionAttempts {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ReceiveBufferSize Property

Grid Solutions Framework IClientReceiveBufferSize Property
Gets or sets the size of the buffer used by the client for receiving data from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int ReceiveBufferSize { get; set; }
Property ReceiveBufferSize As Integer
    Get
    Set
abstract ReceiveBufferSize : int with get, set

function get_ReceiveBufferSize();
function set_ReceiveBufferSize(value);
property int ReceiveBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.SendBufferSize Property

Grid Solutions Framework IClientSendBufferSize Property
Gets or sets the size of the buffer used by the client for receiving data from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int SendBufferSize { get; set; }
Property SendBufferSize As Integer
    Get
    Set
abstract SendBufferSize : int with get, set

function get_SendBufferSize();
function set_SendBufferSize(value);
property int SendBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ServerUri Property

Grid Solutions Framework IClientServerUri Property
Gets the server URI.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ServerUri { get; }
ReadOnly Property ServerUri As String
    Get
abstract ServerUri : string with get

function get_ServerUri();

property String^ ServerUri {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.TextEncoding Property

Grid Solutions Framework IClientTextEncoding Property
Gets or sets the Encoding to be used for the text sent to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Encoding TextEncoding { get; set; }
Property TextEncoding As Encoding
    Get
    Set
abstract TextEncoding : Encoding with get, set

function get_TextEncoding();
function set_TextEncoding(value);
property Encoding^ TextEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.TransportProtocol Property

Grid Solutions Framework IClientTransportProtocol Property
Gets the TransportProtocol used by the client for the transportation of data with the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TransportProtocol TransportProtocol { get; }
ReadOnly Property TransportProtocol As TransportProtocol
    Get
abstract TransportProtocol : TransportProtocol with get

function get_TransportProtocol();

property TransportProtocol TransportProtocol {
    TransportProtocol get ();
}

Property Value

Type: TransportProtocol
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient Events

Grid Solutions Framework IClient Events

The IClient type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server.
Public event | ConnectionEstablished | Occurs when client connection to the server is established.
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server.
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server.
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption.
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server.
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server.
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server.
Public event | SendDataStart | Occurs when the client begins sending data to the server.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ConnectionAttempt Event

Grid Solutions Framework IClientConnectionAttempt Event
Occurs when client is attempting connection to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ConnectionAttempt
Event ConnectionAttempt As EventHandler
abstract ConnectionAttempt : IEvent<EventHandler,
    EventArgs>

function add_ConnectionAttempt(value);
function remove_ConnectionAttempt(value);
 event EventHandler^ ConnectionAttempt {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ConnectionEstablished Event

Grid Solutions Framework IClientConnectionEstablished Event
Occurs when client connection to the server is established.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ConnectionEstablished
Event ConnectionEstablished As EventHandler
abstract ConnectionEstablished : IEvent<EventHandler,
    EventArgs>

function add_ConnectionEstablished(value);
function remove_ConnectionEstablished(value);
 event EventHandler^ ConnectionEstablished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ConnectionException Event

Grid Solutions Framework IClientConnectionException Event
Occurs when an Exception is encountered during connection attempt to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ConnectionException
Event ConnectionException As EventHandler(Of EventArgs(Of Exception))
abstract ConnectionException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ConnectionException(value);
function remove_ConnectionException(value);
 event EventHandler<EventArgs<Exception^>^>^ ConnectionException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ConnectionTerminated Event

Grid Solutions Framework IClientConnectionTerminated Event
Occurs when client connection to the server is terminated.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ConnectionTerminated
Event ConnectionTerminated As EventHandler
abstract ConnectionTerminated : IEvent<EventHandler,
    EventArgs>

function add_ConnectionTerminated(value);
function remove_ConnectionTerminated(value);
 event EventHandler^ ConnectionTerminated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ReceiveData Event

Grid Solutions Framework IClientReceiveData Event
Occurs when unprocessed data has been received from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<int>> ReceiveData
Event ReceiveData As EventHandler(Of EventArgs(Of Integer))
abstract ReceiveData : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>

function add_ReceiveData(value);
function remove_ReceiveData(value);
 event EventHandler<EventArgs<int>^>^ ReceiveData {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32
Remarks

This event can be used to receive a notification that server data has arrived. The Read(Byte, Int32, Int32) method can then be used to copy data to an existing buffer. In many cases it will be optimal to use an existing buffer instead of subscribing to the ReceiveDataComplete event, however, the data that is available after calling the Read(Byte, Int32, Int32) method will be the original unprocessed data received by the client, i.e., not optionally decrypted or decompressed data.

Argument is the number of bytes received in the buffer from the server.

See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ReceiveDataComplete Event

Grid Solutions Framework IClientReceiveDataComplete Event
Occurs when data received from the server has been processed and is ready for consumption.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<byte[], int>> ReceiveDataComplete
Event ReceiveDataComplete As EventHandler(Of EventArgs(Of Byte(), Integer))
abstract ReceiveDataComplete : IEvent<EventHandler<EventArgs<byte[], int>>,
    EventArgs<byte[], int>>

function add_ReceiveDataComplete(value);
function remove_ReceiveDataComplete(value);
 event EventHandler<EventArgs<array<unsigned char>^, int>^>^ ReceiveDataComplete {
    void add (EventHandler<EventArgs<array<unsigned char>^, int>^>^ value);
    void remove (EventHandler<EventArgs<array<unsigned char>^, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Byte , Int32
Remarks
Argument1 is a new buffer containing post-processed data received from the server starting at index zero.
Argument2 is the number of post-processed bytes received in the buffer from the server.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.ReceiveDataException Event

Grid Solutions Framework IClientReceiveDataException Event
Occurs when an Exception is encountered when receiving data from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ReceiveDataException
Event ReceiveDataException As EventHandler(Of EventArgs(Of Exception))
abstract ReceiveDataException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ReceiveDataException(value);
function remove_ReceiveDataException(value);
 event EventHandler<EventArgs<Exception^>^>^ ReceiveDataException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception encountered when receiving data from the server.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.SendDataComplete Event

Grid Solutions Framework IClientSendDataComplete Event
Occurs when the client has successfully sent data to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler SendDataComplete
Event SendDataComplete As EventHandler
abstract SendDataComplete : IEvent<EventHandler,
    EventArgs>

function add_SendDataComplete(value);
function remove_SendDataComplete(value);
 event EventHandler^ SendDataComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.SendDataException Event

Grid Solutions Framework IClientSendDataException Event
Occurs when an Exception is encountered when sending data to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> SendDataException
Event SendDataException As EventHandler(Of EventArgs(Of Exception))
abstract SendDataException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_SendDataException(value);
function remove_SendDataException(value);
 event EventHandler<EventArgs<Exception^>^>^ SendDataException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception encountered when sending data to the server.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.SendDataStart Event

Grid Solutions Framework IClientSendDataStart Event
Occurs when the client begins sending data to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler SendDataStart
Event SendDataStart As EventHandler
abstract SendDataStart : IEvent<EventHandler,
    EventArgs>

function add_SendDataStart(value);
function remove_SendDataStart(value);
 event EventHandler^ SendDataStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IClient Interface
GSF.Communication Namespace


IClient.UnhandledUserException Event

Grid Solutions Framework IClientUnhandledUserException Event
Occurs when an Exception is encountered in a user-defined function via an event dispatch.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> UnhandledUserException
Event UnhandledUserException As EventHandler(Of EventArgs(Of Exception))
abstract UnhandledUserException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_UnhandledUserException(value);
function remove_UnhandledUserException(value);
 event EventHandler<EventArgs<Exception^>^>^ UnhandledUserException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception thrown by the user-defined function.
See Also

Reference

IClient Interface
GSF.Communication Namespace


IPStack Enumeration

Grid Solutions Framework IPStack Enumeration
IP stack enumeration.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum IPStack
Public Enumeration IPStack
type IPStack
GSF.Communication.IPStack = function();
GSF.Communication.IPStack.createEnum('GSF.Communication.IPStack', false);
public enum class IPStack
Members
Member name | Value | Description
IPv6 | 0 | IPv6 stack.
IPv4 | 1 | IPv4 stack.
Default | 2 | Default stack.
See Also

Reference

GSF.Communication Namespace


IServer Interface

Grid Solutions Framework IServer Interface
Defines a server involved in server-client communication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IServer : ISupportLifecycle,
    IDisposable, IProvideStatus
Public Interface IServer
    Inherits ISupportLifecycle, IDisposable, IProvideStatus
type IServer =
    interface
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.Communication.IServer = function();
GSF.Communication.IServer.createInterface('GSF.Communication.IServer');
public interface class IServer : ISupportLifecycle,
    IDisposable, IProvideStatus

The IServer type exposes the following members.

Methods
 | Name | Description
Public method | DisconnectAll | Disconnects all of the connected clients.
Public method | DisconnectOne | Disconnects a connected client.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | Multicast | Sends data to all of the connected clients synchronously.
Public method | MulticastAsync | Sends data to all of the connected clients asynchronously.
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Public method | SendTo | Sends data to the specified client synchronously.
Public method | SendToAsync | Sends data to the specified client asynchronously.
Public method | Start | Starts the server.
Public method | Stop | Stops the server.
Top
Properties
 | Name | Description
Public property | ClientIDs | Gets the IDs of clients connected to the server.
Public property | ConfigurationString | Gets or sets the data required by the server to initialize.
Public property | CurrentState | Gets the current ServerState.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients.
Public property | RunTime | Gets the Time for which the server has been running.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | ServerID | Gets the server's ID.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients.
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients.
Top
Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server.
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting.
Public event | ClientDisconnected | Occurs when a client disconnects from the server.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client.
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption.
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client.
Public event | SendClientDataComplete | Occurs when data has been sent to a client.
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client.
Public event | SendClientDataStart | Occurs when data is being sent to a client.
Public event | ServerStarted | Occurs when the server is started.
Public event | ServerStopped | Occurs when the server is stopped.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

GSF.Communication Namespace


IServer Methods

Grid Solutions Framework IServer Methods

The IServer type exposes the following members.

Methods
 | Name | Description
Public method | DisconnectAll | Disconnects all of the connected clients.
Public method | DisconnectOne | Disconnects a connected client.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | Multicast | Sends data to all of the connected clients synchronously.
Public method | MulticastAsync | Sends data to all of the connected clients asynchronously.
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Public method | SendTo | Sends data to the specified client synchronously.
Public method | SendToAsync | Sends data to the specified client asynchronously.
Public method | Start | Starts the server.
Public method | Stop | Stops the server.
Top
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.DisconnectAll Method

Grid Solutions Framework IServerDisconnectAll Method
Disconnects all of the connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void DisconnectAll()
Sub DisconnectAll
abstract DisconnectAll : unit -> unit

function DisconnectAll();
void DisconnectAll()
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.DisconnectOne Method

Grid Solutions Framework IServerDisconnectOne Method
Disconnects a connected client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void DisconnectOne(
    Guid clientID
)
Sub DisconnectOne (
    clientID As Guid
)
abstract DisconnectOne :
        clientID : Guid -> unit

function DisconnectOne(clientID);
void DisconnectOne(
    Guid clientID
)

Parameters

clientID
Type: SystemGuid
ID of the client to be disconnected.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.Multicast Method

Grid Solutions Framework IServerMulticast Method
Sends data to all of the connected clients synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Multicast(
    byte[] data,
    int offset,
    int length
)
Sub Multicast (
    data As Byte(),
    offset As Integer,
    length As Integer
)
abstract Multicast :
        data : byte[] *
        offset : int *
        length : int -> unit

function Multicast(data, offset, length);
void Multicast(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.MulticastAsync Method

Grid Solutions Framework IServerMulticastAsync Method
Sends data to all of the connected clients asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
WaitHandle[] MulticastAsync(
    byte[] data,
    int offset,
    int length
)
Function MulticastAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle()
abstract MulticastAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle[]

function MulticastAsync(data, offset, length);
array<WaitHandle^>^ MulticastAsync(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
Array of WaitHandle for the asynchronous operation.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.Read Method

Grid Solutions Framework IServerRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int Read(
    Guid clientID,
    byte[] buffer,
    int startIndex,
    int length
)
Function Read (
    clientID As Guid,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int

function Read(clientID, buffer, startIndex, length);
int Read(
    Guid clientID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

clientID
Type: SystemGuid
ID of the client from which data buffer should be read.
buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.
Remarks
This function should only be called from within the ReceiveClientData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.SendTo Method

Grid Solutions Framework IServerSendTo Method
Sends data to the specified client synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void SendTo(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Sub SendTo (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
)
abstract SendTo :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> unit

function SendTo(clientID, data, offset, length);
void SendTo(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.SendToAsync Method

Grid Solutions Framework IServerSendToAsync Method
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
WaitHandle SendToAsync(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Function SendToAsync (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle

function SendToAsync(clientID, data, offset, length);
WaitHandle^ SendToAsync(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.Start Method

Grid Solutions Framework IServerStart Method
Starts the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Start()
Sub Start
abstract Start : unit -> unit

function Start();
void Start()
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.Stop Method

Grid Solutions Framework IServerStop Method
Stops the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Stop()
Sub Stop
abstract Stop : unit -> unit

function Stop();
void Stop()
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer Properties

Grid Solutions Framework IServer Properties

The IServer type exposes the following members.

Properties
 | Name | Description
Public property | ClientIDs | Gets the IDs of clients connected to the server.
Public property | ConfigurationString | Gets or sets the data required by the server to initialize.
Public property | CurrentState | Gets the current ServerState.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients.
Public property | RunTime | Gets the Time for which the server has been running.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server.
Public property | ServerID | Gets the server's ID.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients.
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients.
Top
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ClientIDs Property

Grid Solutions Framework IServerClientIDs Property
Gets the IDs of clients connected to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Guid[] ClientIDs { get; }
ReadOnly Property ClientIDs As Guid()
    Get
abstract ClientIDs : Guid[] with get

function get_ClientIDs();

property array<Guid>^ ClientIDs {
    array<Guid>^ get ();
}

Property Value

Type: Guid
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ConfigurationString Property

Grid Solutions Framework IServerConfigurationString Property
Gets or sets the data required by the server to initialize.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ConfigurationString { get; set; }
Property ConfigurationString As String
    Get
    Set
abstract ConfigurationString : string with get, set

function get_ConfigurationString();
function set_ConfigurationString(value);
property String^ ConfigurationString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.CurrentState Property

Grid Solutions Framework IServerCurrentState Property
Gets the current ServerState.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ServerState CurrentState { get; }
ReadOnly Property CurrentState As ServerState
    Get
abstract CurrentState : ServerState with get

function get_CurrentState();

property ServerState CurrentState {
    ServerState get ();
}

Property Value

Type: ServerState
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.MaxClientConnections Property

Grid Solutions Framework IServerMaxClientConnections Property
Gets or sets the maximum number of clients that can connect to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int MaxClientConnections { get; set; }
Property MaxClientConnections As Integer
    Get
    Set
abstract MaxClientConnections : int with get, set

function get_MaxClientConnections();
function set_MaxClientConnections(value);
property int MaxClientConnections {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ReceiveBufferSize Property

Grid Solutions Framework IServerReceiveBufferSize Property
Gets or sets the size of the buffer used by the server for receiving data from the clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int ReceiveBufferSize { get; set; }
Property ReceiveBufferSize As Integer
    Get
    Set
abstract ReceiveBufferSize : int with get, set

function get_ReceiveBufferSize();
function set_ReceiveBufferSize(value);
property int ReceiveBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.RunTime Property

Grid Solutions Framework IServerRunTime Property
Gets the Time for which the server has been running.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Time RunTime { get; }
ReadOnly Property RunTime As Time
    Get
abstract RunTime : Time with get

function get_RunTime();

property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.SendBufferSize Property

Grid Solutions Framework IServerSendBufferSize Property
Gets or sets the size of the buffer used by the client for receiving data from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int SendBufferSize { get; set; }
Property SendBufferSize As Integer
    Get
    Set
abstract SendBufferSize : int with get, set

function get_SendBufferSize();
function set_SendBufferSize(value);
property int SendBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ServerID Property

Grid Solutions Framework IServerServerID Property
Gets the server's ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Guid ServerID { get; }
ReadOnly Property ServerID As Guid
    Get
abstract ServerID : Guid with get

function get_ServerID();

property Guid ServerID {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.TextEncoding Property

Grid Solutions Framework IServerTextEncoding Property
Gets or sets the Encoding to be used for the text sent to the connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Encoding TextEncoding { get; set; }
Property TextEncoding As Encoding
    Get
    Set
abstract TextEncoding : Encoding with get, set

function get_TextEncoding();
function set_TextEncoding(value);
property Encoding^ TextEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.TransportProtocol Property

Grid Solutions Framework IServerTransportProtocol Property
Gets the TransportProtocol used by the server for the transportation of data with the clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TransportProtocol TransportProtocol { get; }
ReadOnly Property TransportProtocol As TransportProtocol
    Get
abstract TransportProtocol : TransportProtocol with get

function get_TransportProtocol();

property TransportProtocol TransportProtocol {
    TransportProtocol get ();
}

Property Value

Type: TransportProtocol
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer Events

Grid Solutions Framework IServer Events

The IServer type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server.
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting.
Public event | ClientDisconnected | Occurs when a client disconnects from the server.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client.
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption.
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client.
Public event | SendClientDataComplete | Occurs when data has been sent to a client.
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client.
Public event | SendClientDataStart | Occurs when data is being sent to a client.
Public event | ServerStarted | Occurs when the server is started.
Public event | ServerStopped | Occurs when the server is stopped.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ClientConnected Event

Grid Solutions Framework IServerClientConnected Event
Occurs when a client connects to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid>> ClientConnected
Event ClientConnected As EventHandler(Of EventArgs(Of Guid))
abstract ClientConnected : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>

function add_ClientConnected(value);
function remove_ClientConnected(value);
 event EventHandler<EventArgs<Guid>^>^ ClientConnected {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid
Remarks
Argument is the ID of the client that connected to the server.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ClientConnectingException Event

Grid Solutions Framework IServerClientConnectingException Event
Occurs when an exception is encountered while a client is connecting.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ClientConnectingException
Event ClientConnectingException As EventHandler(Of EventArgs(Of Exception))
abstract ClientConnectingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ClientConnectingException(value);
function remove_ClientConnectingException(value);
 event EventHandler<EventArgs<Exception^>^>^ ClientConnectingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception encountered when connecting to the client.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ClientDisconnected Event

Grid Solutions Framework IServerClientDisconnected Event
Occurs when a client disconnects from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid>> ClientDisconnected
Event ClientDisconnected As EventHandler(Of EventArgs(Of Guid))
abstract ClientDisconnected : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>

function add_ClientDisconnected(value);
function remove_ClientDisconnected(value);
 event EventHandler<EventArgs<Guid>^>^ ClientDisconnected {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid
Remarks
Argument is the ID of the client that disconnected from the server.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ReceiveClientData Event

Grid Solutions Framework IServerReceiveClientData Event
Occurs when unprocessed data has been received from a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid, int>> ReceiveClientData
Event ReceiveClientData As EventHandler(Of EventArgs(Of Guid, Integer))
abstract ReceiveClientData : IEvent<EventHandler<EventArgs<Guid, int>>,
    EventArgs<Guid, int>>

function add_ReceiveClientData(value);
function remove_ReceiveClientData(value);
 event EventHandler<EventArgs<Guid, int>^>^ ReceiveClientData {
    void add (EventHandler<EventArgs<Guid, int>^>^ value);
    void remove (EventHandler<EventArgs<Guid, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Int32
Remarks

This event can be used to receive a notification that client data has arrived. The Read(Guid, Byte, Int32, Int32) method can then be used to copy data to an existing buffer. In many cases it will be optimal to use an existing buffer instead of subscribing to the ReceiveClientDataComplete event, however, the data that is available after calling the Read(Guid, Byte, Int32, Int32) method will be the original unprocessed data received by the client, i.e., not optionally decrypted or decompressed data.

Argument1 is the ID of the client from which data is received.
Argument2 is the number of bytes received in the buffer from the client.

See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ReceiveClientDataComplete Event

Grid Solutions Framework IServerReceiveClientDataComplete Event
Occurs when data received from a client has been processed and is ready for consumption.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid, byte[], int>> ReceiveClientDataComplete
Event ReceiveClientDataComplete As EventHandler(Of EventArgs(Of Guid, Byte(), Integer))
abstract ReceiveClientDataComplete : IEvent<EventHandler<EventArgs<Guid, byte[], int>>,
    EventArgs<Guid, byte[], int>>

function add_ReceiveClientDataComplete(value);
function remove_ReceiveClientDataComplete(value);
 event EventHandler<EventArgs<Guid, array<unsigned char>^, int>^>^ ReceiveClientDataComplete {
    void add (EventHandler<EventArgs<Guid, array<unsigned char>^, int>^>^ value);
    void remove (EventHandler<EventArgs<Guid, array<unsigned char>^, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Byte , Int32
Remarks
Argument1 is the ID of the client from which data is received.
Argument2 is a new buffer containing post-processed data received from the client starting at index zero.
Argument3 is the number of post-processed bytes received in the buffer from the client.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ReceiveClientDataException Event

Grid Solutions Framework IServerReceiveClientDataException Event
Occurs when an Exception is encountered when receiving data from a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid, Exception>> ReceiveClientDataException
Event ReceiveClientDataException As EventHandler(Of EventArgs(Of Guid, Exception))
abstract ReceiveClientDataException : IEvent<EventHandler<EventArgs<Guid, Exception>>,
    EventArgs<Guid, Exception>>

function add_ReceiveClientDataException(value);
function remove_ReceiveClientDataException(value);
 event EventHandler<EventArgs<Guid, Exception^>^>^ ReceiveClientDataException {
    void add (EventHandler<EventArgs<Guid, Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Guid, Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Exception
Remarks
Argument1 is the ID of the client from which the data was being received.
Argument2 is the Exception encountered when receiving data from a client.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.SendClientDataComplete Event

Grid Solutions Framework IServerSendClientDataComplete Event
Occurs when data has been sent to a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid>> SendClientDataComplete
Event SendClientDataComplete As EventHandler(Of EventArgs(Of Guid))
abstract SendClientDataComplete : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>

function add_SendClientDataComplete(value);
function remove_SendClientDataComplete(value);
 event EventHandler<EventArgs<Guid>^>^ SendClientDataComplete {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid
Remarks
Argument is the ID of the client to which the data has been sent.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.SendClientDataException Event

Grid Solutions Framework IServerSendClientDataException Event
Occurs when an Exception is encountered when sending data to a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid, Exception>> SendClientDataException
Event SendClientDataException As EventHandler(Of EventArgs(Of Guid, Exception))
abstract SendClientDataException : IEvent<EventHandler<EventArgs<Guid, Exception>>,
    EventArgs<Guid, Exception>>

function add_SendClientDataException(value);
function remove_SendClientDataException(value);
 event EventHandler<EventArgs<Guid, Exception^>^>^ SendClientDataException {
    void add (EventHandler<EventArgs<Guid, Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Guid, Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Exception
Remarks
Argument1 is the ID of the client to which the data was being sent.
Argument2 is the Exception encountered when sending data to a client.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.SendClientDataStart Event

Grid Solutions Framework IServerSendClientDataStart Event
Occurs when data is being sent to a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Guid>> SendClientDataStart
Event SendClientDataStart As EventHandler(Of EventArgs(Of Guid))
abstract SendClientDataStart : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>

function add_SendClientDataStart(value);
function remove_SendClientDataStart(value);
 event EventHandler<EventArgs<Guid>^>^ SendClientDataStart {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid
Remarks
Argument is the ID of the client to which the data is being sent.
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ServerStarted Event

Grid Solutions Framework IServerServerStarted Event
Occurs when the server is started.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ServerStarted
Event ServerStarted As EventHandler
abstract ServerStarted : IEvent<EventHandler,
    EventArgs>

function add_ServerStarted(value);
function remove_ServerStarted(value);
 event EventHandler^ ServerStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.ServerStopped Event

Grid Solutions Framework IServerServerStopped Event
Occurs when the server is stopped.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ServerStopped
Event ServerStopped As EventHandler
abstract ServerStopped : IEvent<EventHandler,
    EventArgs>

function add_ServerStopped(value);
function remove_ServerStopped(value);
 event EventHandler^ ServerStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IServer Interface
GSF.Communication Namespace


IServer.UnhandledUserException Event

Grid Solutions Framework IServerUnhandledUserException Event
Occurs when an Exception is encountered in a user-defined function via an event dispatch.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> UnhandledUserException
Event UnhandledUserException As EventHandler(Of EventArgs(Of Exception))
abstract UnhandledUserException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_UnhandledUserException(value);
function remove_UnhandledUserException(value);
 event EventHandler<EventArgs<Exception^>^>^ UnhandledUserException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception thrown by the user-defined function.
See Also

Reference

IServer Interface
GSF.Communication Namespace


Payload Class

Grid Solutions Framework Payload Class
A helper class containing methods for manipulation of payload.
Inheritance Hierarchy
SystemObject
GSF.CommunicationPayload

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Payload
Public NotInheritable Class Payload
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Payload =  class end
GSF.Communication.Payload = function();

Type.createClass(
    'GSF.Communication.Payload');
public ref class Payload abstract sealed

The Payload type exposes the following members.

Methods
Name | Description
AddHeader | Adds header containing the marker to the payload in the buffer for "Payload-Aware" transmission.
ExtractLength | Determines the length of a payload in a "Payload-Aware" transmission from the payload header information.
HasHeader | Determines whether or not the buffer contains the header information of a "Payload-Aware" transmission.
Top
Fields
Name | Description
DefaultMarker | Default byte sequence used to mark the beginning of the payload in a "Payload-Aware" transmissions.
LengthSegment | Specifies the length of the segment in a "Payload-Aware" transmission that contains the payload length.
Top
See Also

Reference

GSF.Communication Namespace


Payload Fields

Grid Solutions Framework Payload Fields

The Payload type exposes the following members.

Fields
Name | Description
DefaultMarker | Default byte sequence used to mark the beginning of the payload in a "Payload-Aware" transmissions.
LengthSegment | Specifies the length of the segment in a "Payload-Aware" transmission that contains the payload length.
Top
See Also

Reference

Payload Class
GSF.Communication Namespace


Payload.DefaultMarker Field

Grid Solutions Framework PayloadDefaultMarker Field
Default byte sequence used to mark the beginning of the payload in a "Payload-Aware" transmissions.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] DefaultMarker
Public Shared DefaultMarker As Byte()
static val mutable DefaultMarker: byte[]
var GSF.Communication.Payload.DefaultMarker
public:
static array<unsigned char>^ DefaultMarker

Field Value

Type: Byte
See Also

Reference

Payload Class
GSF.Communication Namespace


Payload.LengthSegment Field

Grid Solutions Framework PayloadLengthSegment Field
Specifies the length of the segment in a "Payload-Aware" transmission that contains the payload length.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int LengthSegment
Public Const LengthSegment As Integer
static val mutable LengthSegment: int
var GSF.Communication.Payload.LengthSegment
public:
literal int LengthSegment

Field Value

Type: Int32
See Also

Reference

Payload Class
GSF.Communication Namespace


Payload Methods

Grid Solutions Framework Payload Methods

The Payload type exposes the following members.

Methods
Name | Description
AddHeader | Adds header containing the marker to the payload in the buffer for "Payload-Aware" transmission.
ExtractLength | Determines the length of a payload in a "Payload-Aware" transmission from the payload header information.
HasHeader | Determines whether or not the buffer contains the header information of a "Payload-Aware" transmission.
Top
See Also

Reference

Payload Class
GSF.Communication Namespace


Payload.AddHeader Method

Grid Solutions Framework PayloadAddHeader Method
Adds header containing the marker to the payload in the buffer for "Payload-Aware" transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void AddHeader(
    ref byte[] buffer,
    ref int offset,
    ref int length,
    byte[] marker
)
Public Shared Sub AddHeader (
    ByRef buffer As Byte(),
    ByRef offset As Integer,
    ByRef length As Integer,
    marker As Byte()
)
static member AddHeader :
        buffer : byte[] byref *
        offset : int byref *
        length : int byref *
        marker : byte[] -> unit

GSF.Communication.Payload.AddHeader = function(buffer, offset, length, marker);
public:
static void AddHeader(
    array<unsigned char>^% buffer,
    int% offset,
    int% length,
    array<unsigned char>^ marker
)

Parameters

buffer
Type: SystemByte
The buffer containing the payload.
offset
Type: SystemInt32
The offset in the buffer at which the payload starts.
length
Type: SystemInt32
The lenght of the payload in the buffer starting at the offset.
marker
Type: SystemByte
The byte sequence used to mark the beginning of the payload in a "Payload-Aware" transmissions.
See Also

Reference

Payload Class
GSF.Communication Namespace


Payload.ExtractLength Method

Grid Solutions Framework PayloadExtractLength Method
Determines the length of a payload in a "Payload-Aware" transmission from the payload header information.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExtractLength(
    byte[] buffer,
    int length,
    byte[] marker
)
Public Shared Function ExtractLength (
    buffer As Byte(),
    length As Integer,
    marker As Byte()
) As Integer
static member ExtractLength :
        buffer : byte[] *
        length : int *
        marker : byte[] -> int

GSF.Communication.Payload.ExtractLength = function(buffer, length, marker);
public:
static int ExtractLength(
    array<unsigned char>^ buffer,
    int length,
    array<unsigned char>^ marker
)

Parameters

buffer
Type: SystemByte
The buffer containg payload header information starting at index zero.
length
Type: SystemInt32
The length of valid data within in buffer.
marker
Type: SystemByte
The byte sequence used to mark the beginning of the payload in a "Payload-Aware" transmissions.

Return Value

Type: Int32
Length of the payload.
See Also

Reference

Payload Class
GSF.Communication Namespace


Payload.HasHeader Method

Grid Solutions Framework PayloadHasHeader Method
Determines whether or not the buffer contains the header information of a "Payload-Aware" transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool HasHeader(
    byte[] buffer,
    byte[] marker
)
Public Shared Function HasHeader (
    buffer As Byte(),
    marker As Byte()
) As Boolean
static member HasHeader :
        buffer : byte[] *
        marker : byte[] -> bool

GSF.Communication.Payload.HasHeader = function(buffer, marker);
public:
static bool HasHeader(
    array<unsigned char>^ buffer,
    array<unsigned char>^ marker
)

Parameters

buffer
Type: SystemByte
The buffer to be checked at index zero.
marker
Type: SystemByte
The byte sequence used to mark the beginning of the payload in a "Payload-Aware" transmissions.

Return Value

Type: Boolean
true if the buffer contains "Payload-Aware" transmission header; otherwise false.
See Also

Reference

Payload Class
GSF.Communication Namespace


SerialClient Class

Grid Solutions Framework SerialClient Class
Represents a communication client based on SerialPort.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
GSF.CommunicationSerialClient

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SerialClient : ClientBase
Public Class SerialClient
    Inherits ClientBase
type SerialClient =
    class
        inherit ClientBase
    end
GSF.Communication.SerialClient = function();

Type.createClass(
    'GSF.Communication.SerialClient',
    GSF.Communication.ClientBase);
public ref class SerialClient : public ClientBase

The SerialClient type exposes the following members.

Constructors
 | Name | Description
Public method | SerialClient | Initializes a new instance of the SerialClient class.
Public method | SerialClient(IContainer) | Initializes a new instance of the SerialClient class.
Public method | SerialClient(String) | Initializes a new instance of the SerialClient class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the SerialClient to the SerialPort asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the SerialClient from the SerialPort. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SerialClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved client settings from the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves client settings to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends (writes) data to the SerialPort asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultConnectionString | Specifies the default value for the ConnectionString property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the SerialPort object for the SerialClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | ReceivedBytesThreshold | Gets or sets the needed number of bytes in the internal input buffer before a OnReceiveDataComplete(Byte, Int32) event occurs.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the SerialClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Inherited from ClientBase.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
Examples
This example shows how to use SerialClient for communicating with SerialPort:
Copy
using System;
using GSF;
using GSF.Communication;

class Program
{
    static SerialClient s_client;

    static void Main(string[] args)
    {
        // Initialize the client.
        s_client = new SerialClient("Port=COM1; BaudRate=9600; Parity=None; StopBits=One; DataBits=8; DtrEnable=False; RtsEnable=False");
        s_client.Initialize();
        // Register event handlers.
        s_client.ConnectionAttempt += s_client_ConnectionAttempt;
        s_client.ConnectionEstablished += s_client_ConnectionEstablished;
        s_client.ConnectionTerminated += s_client_ConnectionTerminated;
        s_client.SendDataComplete += s_client_SendDataComplete;
        s_client.ReceiveDataComplete += s_client_ReceiveDataComplete;
        // Connect the client.
        s_client.Connect();

        // Write user input to the serial port.
        string input;
        while (string.Compare(input = Console.ReadLine(), "Exit", true) != 0)
        {
            s_client.Send(input);
        }

        // Disconnect the client on shutdown.
        s_client.Dispose();
    }

    static void s_client_ConnectionAttempt(object sender, EventArgs e)
    {
        Console.WriteLine("Client is connecting to serial port.");
    }

    static void s_client_ConnectionEstablished(object sender, EventArgs e)
    {
        Console.WriteLine("Client connected to serial port.");
    }

    static void s_client_ConnectionTerminated(object sender, EventArgs e)
    {
        Console.WriteLine("Client disconnected from serial port.");
    }

    static void s_client_SendDataComplete(object sender, EventArgs e)
    {
        Console.WriteLine(string.Format("Sent data - {0}", s_client.TextEncoding.GetString(s_client.Client.SendBuffer)));
    }

    static void s_client_ReceiveDataComplete(object sender, EventArgs<byte[], int> e)
    {
        Console.WriteLine(string.Format("Received data - {0}", s_client.TextEncoding.GetString(e.Argument1, 0, e.Argument2)));
    }
}
See Also

Reference

GSF.Communication Namespace


SerialClient Constructor

Grid Solutions Framework SerialClient Constructor
Overload List
 | Name | Description
Public method | SerialClient | Initializes a new instance of the SerialClient class.
Public method | SerialClient(IContainer) | Initializes a new instance of the SerialClient class.
Public method | SerialClient(String) | Initializes a new instance of the SerialClient class.
Top
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient Constructor

Grid Solutions Framework SerialClient Constructor
Initializes a new instance of the SerialClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerialClient()
Public Sub New
new : unit -> SerialClient
GSF.Communication.SerialClient = function();
public:
SerialClient()
See Also

Reference

SerialClient Class
SerialClient Overload
GSF.Communication Namespace


SerialClient Constructor (IContainer)

Grid Solutions Framework SerialClient Constructor (IContainer)
Initializes a new instance of the SerialClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerialClient(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> SerialClient
GSF.Communication.SerialClient = function(container);
public:
SerialClient(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the SerialClient.
See Also

Reference

SerialClient Class
SerialClient Overload
GSF.Communication Namespace


SerialClient Constructor (String)

Grid Solutions Framework SerialClient Constructor (String)
Initializes a new instance of the SerialClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerialClient(
    string connectString
)
Public Sub New (
    connectString As String
)
new :
        connectString : string -> SerialClient
GSF.Communication.SerialClient = function(connectString);
public:
SerialClient(
    String^ connectString
)

Parameters

connectString
Type: SystemString
Connect string of the SerialClient. See DefaultConnectionString for format.
See Also

Reference

SerialClient Class
SerialClient Overload
GSF.Communication Namespace


SerialClient Fields

Grid Solutions Framework SerialClient Fields

The SerialClient type exposes the following members.

Fields
Name | Description
DefaultConnectionString | Specifies the default value for the ConnectionString property.
Top
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.DefaultConnectionString Field

Grid Solutions Framework SerialClientDefaultConnectionString Field
Specifies the default value for the ConnectionString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConnectionString
Public Const DefaultConnectionString As String
static val mutable DefaultConnectionString: string
var GSF.Communication.SerialClient.DefaultConnectionString
public:
literal String^ DefaultConnectionString

Field Value

Type: String
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient Methods

Grid Solutions Framework SerialClient Methods

The SerialClient type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the SerialClient to the SerialPort asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the SerialClient from the SerialPort. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SerialClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved client settings from the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Inherited from ClientBase.)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves client settings to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends (writes) data to the SerialPort asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.ConnectAsync Method

Grid Solutions Framework SerialClientConnectAsync Method
Connects the SerialClient to the SerialPort asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override WaitHandle ConnectAsync()
Public Overrides Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle
override ConnectAsync : unit -> WaitHandle
function ConnectAsync();
public:
virtual WaitHandle^ ConnectAsync() override

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientConnectAsync
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to connect the SerialClient when it is connected.
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.Disconnect Method

Grid Solutions Framework SerialClientDisconnect Method
Disconnects the SerialClient from the SerialPort.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Disconnect()
Public Overrides Sub Disconnect
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit
function Disconnect();
public:
virtual void Disconnect() override

Implements

IClientDisconnect
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.Dispose Method

Grid Solutions Framework SerialClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SerialClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Top
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.Dispose Method (Boolean)

Grid Solutions Framework SerialClientDispose Method (Boolean)
Releases the unmanaged resources used by the SerialClient and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

SerialClient Class
Dispose Overload
GSF.Communication Namespace


SerialClient.OnConnectionException Method

Grid Solutions Framework SerialClientOnConnectionException Method
Raises the ConnectionException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnConnectionException(
    Exception ex
)
Protected Overrides Sub OnConnectionException (
    ex As Exception
)
abstract OnConnectionException :
        ex : Exception -> unit
override OnConnectionException :
        ex : Exception -> unit
function OnConnectionException(ex);
protected:
virtual void OnConnectionException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ConnectionException event.
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.Read Method

Grid Solutions Framework SerialClientRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IClientRead(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.SendDataAsync Method

Grid Solutions Framework SerialClientSendDataAsync Method
Sends (writes) data to the SerialPort asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataAsync(
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataAsync(data, offset, length);
protected:
virtual WaitHandle^ SendDataAsync(
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent (written).
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending (writing) data.
length
Type: SystemInt32
The number of bytes to be sent (written) from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.ValidateConnectionString Method

Grid Solutions Framework SerialClientValidateConnectionString Method
Validates the specified connectionString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConnectionString(
    string connectionString
)
Protected Overrides Sub ValidateConnectionString (
    connectionString As String
)
abstract ValidateConnectionString :
        connectionString : string -> unit
override ValidateConnectionString :
        connectionString : string -> unit
function ValidateConnectionString(connectionString);
protected:
virtual void ValidateConnectionString(
    String^ connectionString
) override

Parameters

connectionString
Type: SystemString
Connection string to be validated.
Exceptions
Exception | Condition
ArgumentException | Port property is missing.
ArgumentException | BaudRate property is missing.
ArgumentException | Parity property is missing.
ArgumentException | StopBits property is missing.
ArgumentException | DataBits property is missing.
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient Properties

Grid Solutions Framework SerialClient Properties

The SerialClient type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the SerialPort object for the SerialClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | ReceivedBytesThreshold | Gets or sets the needed number of bytes in the internal input buffer before a OnReceiveDataComplete(Byte, Int32) event occurs.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the SerialClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Inherited from ClientBase.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.Client Property

Grid Solutions Framework SerialClientClient Property
Gets the SerialPort object for the SerialClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public SerialPort Client { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Client As SerialPort
    Get
[<BrowsableAttribute(false)>]
member Client : SerialPort with get

function get_Client();

public:
[BrowsableAttribute(false)]
property SerialPort^ Client {
    SerialPort^ get ();
}

Property Value

Type: SerialPort
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.ReceivedBytesThreshold Property

Grid Solutions Framework SerialClientReceivedBytesThreshold Property
Gets or sets the needed number of bytes in the internal input buffer before a OnReceiveDataComplete(Byte, Int32) event occurs.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ReceivedBytesThreshold { get; set; }
Public Property ReceivedBytesThreshold As Integer
    Get
    Set
member ReceivedBytesThreshold : int with get, set

function get_ReceivedBytesThreshold();
function set_ReceivedBytesThreshold(value);
public:
property int ReceivedBytesThreshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This option is ignored under Mono deployments.
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient.ServerUri Property

Grid Solutions Framework SerialClientServerUri Property
Gets the server URI of the SerialClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override string ServerUri { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ServerUri As String
    Get
[<BrowsableAttribute(false)>]
abstract ServerUri : string with get
[<BrowsableAttribute(false)>]
override ServerUri : string with get
function get_ServerUri();

public:
[BrowsableAttribute(false)]
virtual property String^ ServerUri {
    String^ get () override;
}

Property Value

Type: String

Implements

IClientServerUri
See Also

Reference

SerialClient Class
GSF.Communication Namespace


SerialClient Events

Grid Solutions Framework SerialClient Events

The SerialClient type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

SerialClient Class
GSF.Communication Namespace


ServerBase Class

Grid Solutions Framework ServerBase Class
Base class for a server involved in server-client communication.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationServerBase
GSF.CommunicationTcpServer
GSF.CommunicationTlsServer
GSF.CommunicationUdpServer
GSF.CommunicationZeroMQServer

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ServerBase))]
public abstract class ServerBase : Component,
    IServer, ISupportLifecycle, IDisposable, IProvideStatus, ISupportInitialize,
    IPersistSettings
<ToolboxBitmapAttribute(GetType(ServerBase))>
Public MustInherit Class ServerBase
    Inherits Component
    Implements IServer, ISupportLifecycle, IDisposable, IProvideStatus,
    ISupportInitialize, IPersistSettings
[<AbstractClassAttribute>]
[<ToolboxBitmapAttribute(typeof(ServerBase))>]
type ServerBase =
    class
        inherit Component
        interface IServer
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface ISupportInitialize
        interface IPersistSettings
    end
GSF.Communication.ServerBase = function();

Type.createClass(
    'GSF.Communication.ServerBase',
    Component,
    GSF.Communication.IServer,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    ISupportInitialize,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(ServerBase))]
public ref class ServerBase abstract : public Component,
    IServer, ISupportLifecycle, IDisposable, IProvideStatus, ISupportInitialize,
    IPersistSettings

The ServerBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ServerBase | Initializes a new instance of the server.
Protected method | ServerBase(TransportProtocol, String) | Initializes a new instance of the server.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized.
 | Create | Create a communications server
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients.
Public method | DisconnectOne | When overridden in a derived class, disconnects a connected client.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the server properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved server settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously.
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously.
Public method | Multicast(String) | Sends data to all of the connected clients synchronously.
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously.
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously.
Protected method | OnClientConnected | Raises the ClientConnected event.
Protected method | OnClientConnectingException | Raises the ClientConnectingException event.
Protected method | OnClientDisconnected | Raises the ClientDisconnected event.
Protected method | OnReceiveClientData | Raises the ReceiveClientData event.
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event.
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event.
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event.
Protected method | OnSendClientDataException | Raises the SendClientDataException event.
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event.
Protected method | OnServerStarted | Raises the ServerStarted event.
Protected method | OnServerStopped | Raises the ServerStopped event.
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event.
Public method | Read | When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Protected method | ReStart | Re-starts the server if currently running.
Public method | SaveSettings | Saves server settings to the config file if the PersistSettings property is set to true.
Protected method | SendDataToAsync | When overridden in a derived class, sends data to the specified client asynchronously.
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously.
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously.
Public method | Start | When overridden in a derived class, starts the server.
Public method | Stop | When overridden in a derived class, stops the server.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConfigurationString | When overridden in a derived class, validates the specified configurationString.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultMaxClientConnections | Specifies the default value for the MaxClientConnections property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultReceiveBufferSize | Specifies the default value for the ReceiveBufferSize property.
DefaultSendBufferSize | Specifies the default value for the SendBufferSize property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIDs | Gets the IDs of clients connected to the server.
Public property | ConfigurationString | Gets or sets the data required by the server to initialize.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server.
Public property | Name | Gets the unique identifier of the server.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file.
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call.
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients.
Public property | RunTime | Gets the Time for which the server has been running.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients.
Public property | ServerID | Gets the server's ID.
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the server.
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients.
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients.
Top
Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server.
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting.
Public event | ClientDisconnected | Occurs when a client disconnects from the server.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client.
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption.
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client.
Public event | SendClientDataComplete | Occurs when data has been sent to a client.
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client.
Public event | SendClientDataStart | Occurs when data is being sent to a client.
Public event | ServerStarted | Occurs when the server is started.
Public event | ServerStopped | Occurs when the server is stopped.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

GSF.Communication Namespace


ServerBase Constructor

Grid Solutions Framework ServerBase Constructor
Overload List
 | Name | Description
Protected method | ServerBase | Initializes a new instance of the server.
Protected method | ServerBase(TransportProtocol, String) | Initializes a new instance of the server.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase Constructor

Grid Solutions Framework ServerBase Constructor
Initializes a new instance of the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ServerBase()
Protected Sub New
new : unit -> ServerBase
GSF.Communication.ServerBase = function();
protected:
ServerBase()
See Also

Reference

ServerBase Class
ServerBase Overload
GSF.Communication Namespace


ServerBase Constructor (TransportProtocol, String)

Grid Solutions Framework ServerBase Constructor (TransportProtocol, String)
Initializes a new instance of the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ServerBase(
    TransportProtocol transportProtocol,
    string configurationString
)
Protected Sub New (
    transportProtocol As TransportProtocol,
    configurationString As String
)
new :
        transportProtocol : TransportProtocol *
        configurationString : string -> ServerBase
GSF.Communication.ServerBase = function(transportProtocol, configurationString);
protected:
ServerBase(
    TransportProtocol transportProtocol,
    String^ configurationString
)

Parameters

transportProtocol
Type: GSF.CommunicationTransportProtocol
One of the TransportProtocol values.
configurationString
Type: SystemString
The data used by the server for initialization.
See Also

Reference

ServerBase Class
ServerBase Overload
GSF.Communication Namespace


ServerBase Fields

Grid Solutions Framework ServerBase Fields

The ServerBase type exposes the following members.

Fields
Name | Description
DefaultMaxClientConnections | Specifies the default value for the MaxClientConnections property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultReceiveBufferSize | Specifies the default value for the ReceiveBufferSize property.
DefaultSendBufferSize | Specifies the default value for the SendBufferSize property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.DefaultMaxClientConnections Field

Grid Solutions Framework ServerBaseDefaultMaxClientConnections Field
Specifies the default value for the MaxClientConnections property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxClientConnections
Public Const DefaultMaxClientConnections As Integer
static val mutable DefaultMaxClientConnections: int
var GSF.Communication.ServerBase.DefaultMaxClientConnections
public:
literal int DefaultMaxClientConnections

Field Value

Type: Int32
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.DefaultPersistSettings Field

Grid Solutions Framework ServerBaseDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.Communication.ServerBase.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.DefaultReceiveBufferSize Field

Grid Solutions Framework ServerBaseDefaultReceiveBufferSize Field
Specifies the default value for the ReceiveBufferSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultReceiveBufferSize
Public Const DefaultReceiveBufferSize As Integer
static val mutable DefaultReceiveBufferSize: int
var GSF.Communication.ServerBase.DefaultReceiveBufferSize
public:
literal int DefaultReceiveBufferSize

Field Value

Type: Int32
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.DefaultSendBufferSize Field

Grid Solutions Framework ServerBaseDefaultSendBufferSize Field
Specifies the default value for the SendBufferSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultSendBufferSize
Public Const DefaultSendBufferSize As Integer
static val mutable DefaultSendBufferSize: int
var GSF.Communication.ServerBase.DefaultSendBufferSize
public:
literal int DefaultSendBufferSize

Field Value

Type: Int32
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.DefaultSettingsCategory Field

Grid Solutions Framework ServerBaseDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.Communication.ServerBase.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase Methods

Grid Solutions Framework ServerBase Methods

The ServerBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized.
 | Create | Create a communications server
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients.
Public method | DisconnectOne | When overridden in a derived class, disconnects a connected client.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the server properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved server settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously.
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously.
Public method | Multicast(String) | Sends data to all of the connected clients synchronously.
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously.
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously.
Protected method | OnClientConnected | Raises the ClientConnected event.
Protected method | OnClientConnectingException | Raises the ClientConnectingException event.
Protected method | OnClientDisconnected | Raises the ClientDisconnected event.
Protected method | OnReceiveClientData | Raises the ReceiveClientData event.
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event.
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event.
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event.
Protected method | OnSendClientDataException | Raises the SendClientDataException event.
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event.
Protected method | OnServerStarted | Raises the ServerStarted event.
Protected method | OnServerStopped | Raises the ServerStopped event.
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event.
Public method | Read | When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.
Protected method | ReStart | Re-starts the server if currently running.
Public method | SaveSettings | Saves server settings to the config file if the PersistSettings property is set to true.
Protected method | SendDataToAsync | When overridden in a derived class, sends data to the specified client asynchronously.
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously.
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously.
Public method | Start | When overridden in a derived class, starts the server.
Public method | Stop | When overridden in a derived class, stops the server.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConfigurationString | When overridden in a derived class, validates the specified configurationString.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.BeginInit Method

Grid Solutions Framework ServerBaseBeginInit Method
Performs necessary operations before the server properties are initialized.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the server is consumed through the designer surface of the IDE.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Create Method

Grid Solutions Framework ServerBaseCreate Method
Create a communications server

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IServer Create(
    string configurationString
)
Public Shared Function Create (
    configurationString As String
) As IServer
static member Create :
        configurationString : string -> IServer

GSF.Communication.ServerBase.Create = function(configurationString);
public:
static IServer^ Create(
    String^ configurationString
)

Parameters

configurationString
Type: SystemString
The configuration string for the server.

Return Value

Type: IServer
A communications server.
Remarks
Note that typical configuration string should be prefixed with a "protocol=tcp" or a "protocol=udp"
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.DisconnectAll Method

Grid Solutions Framework ServerBaseDisconnectAll Method
Disconnects all of the connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void DisconnectAll()
Public Overridable Sub DisconnectAll
abstract DisconnectAll : unit -> unit
override DisconnectAll : unit -> unit
function DisconnectAll();
public:
virtual void DisconnectAll()

Implements

IServerDisconnectAll
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.DisconnectOne Method

Grid Solutions Framework ServerBaseDisconnectOne Method
When overridden in a derived class, disconnects a connected client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract void DisconnectOne(
    Guid clientID
)
Public MustOverride Sub DisconnectOne (
    clientID As Guid
)
abstract DisconnectOne :
        clientID : Guid -> unit

function DisconnectOne(clientID);
public:
virtual void DisconnectOne(
    Guid clientID
) abstract

Parameters

clientID
Type: SystemGuid
ID of the client to be disconnected.

Implements

IServerDisconnectOne(Guid)
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Dispose Method

Grid Solutions Framework ServerBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Dispose Method (Boolean)

Grid Solutions Framework ServerBaseDispose Method (Boolean)
Releases the unmanaged resources used by the server and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ServerBase Class
Dispose Overload
GSF.Communication Namespace


ServerBase.EndInit Method

Grid Solutions Framework ServerBaseEndInit Method
Performs necessary operations after the server properties are initialized.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the server is consumed through the designer surface of the IDE.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Initialize Method

Grid Solutions Framework ServerBaseInitialize Method
Initializes the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the server is not consumed through the designer surface of the IDE.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.LoadSettings Method

Grid Solutions Framework ServerBaseLoadSettings Method
Loads saved server settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void LoadSettings()
Public Overridable Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings()

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Multicast Method

Grid Solutions Framework ServerBaseMulticast Method
Overload List
 | Name | Description
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously.
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously.
Public method | Multicast(String) | Sends data to all of the connected clients synchronously.
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Multicast Method (Byte[])

Grid Solutions Framework ServerBaseMulticast Method (Byte)
Sends data to all of the connected clients synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Multicast(
    byte[] data
)
Public Overridable Sub Multicast (
    data As Byte()
)
abstract Multicast :
        data : byte[] -> unit
override Multicast :
        data : byte[] -> unit
function Multicast(data);
public:
virtual void Multicast(
    array<unsigned char>^ data
)

Parameters

data
Type: SystemByte
The binary data that is to be sent.
See Also

Reference

ServerBase Class
Multicast Overload
GSF.Communication Namespace


ServerBase.Multicast Method (Object)

Grid Solutions Framework ServerBaseMulticast Method (Object)
Sends data to all of the connected clients synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Multicast(
    Object serializableObject
)
Public Overridable Sub Multicast (
    serializableObject As Object
)
abstract Multicast :
        serializableObject : Object -> unit
override Multicast :
        serializableObject : Object -> unit
function Multicast(serializableObject);
public:
virtual void Multicast(
    Object^ serializableObject
)

Parameters

serializableObject
Type: SystemObject
The serializable object that is to be sent.
See Also

Reference

ServerBase Class
Multicast Overload
GSF.Communication Namespace


ServerBase.Multicast Method (String)

Grid Solutions Framework ServerBaseMulticast Method (String)
Sends data to all of the connected clients synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Multicast(
    string data
)
Public Overridable Sub Multicast (
    data As String
)
abstract Multicast :
        data : string -> unit
override Multicast :
        data : string -> unit
function Multicast(data);
public:
virtual void Multicast(
    String^ data
)

Parameters

data
Type: SystemString
The plain-text data that is to be sent.
See Also

Reference

ServerBase Class
Multicast Overload
GSF.Communication Namespace


ServerBase.Multicast Method (Byte[], Int32, Int32)

Grid Solutions Framework ServerBaseMulticast Method (Byte, Int32, Int32)
Sends data to all of the connected clients synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Multicast(
    byte[] data,
    int offset,
    int length
)
Public Overridable Sub Multicast (
    data As Byte(),
    offset As Integer,
    length As Integer
)
abstract Multicast :
        data : byte[] *
        offset : int *
        length : int -> unit
override Multicast :
        data : byte[] *
        offset : int *
        length : int -> unit
function Multicast(data, offset, length);
public:
virtual void Multicast(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Implements

IServerMulticast(Byte, Int32, Int32)
See Also

Reference

ServerBase Class
Multicast Overload
GSF.Communication Namespace


ServerBase.MulticastAsync Method

Grid Solutions Framework ServerBaseMulticastAsync Method
Overload List
 | Name | Description
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously.
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.MulticastAsync Method (Byte[])

Grid Solutions Framework ServerBaseMulticastAsync Method (Byte)
Sends data to all of the connected clients asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle[] MulticastAsync(
    byte[] data
)
Public Overridable Function MulticastAsync (
    data As Byte()
) As WaitHandle()
abstract MulticastAsync :
        data : byte[] -> WaitHandle[]
override MulticastAsync :
        data : byte[] -> WaitHandle[]
function MulticastAsync(data);
public:
virtual array<WaitHandle^>^ MulticastAsync(
    array<unsigned char>^ data
)

Parameters

data
Type: SystemByte
The binary data that is to be sent.

Return Value

Type: WaitHandle
Array of WaitHandle for the asynchronous operation.
See Also

Reference

ServerBase Class
MulticastAsync Overload
GSF.Communication Namespace


ServerBase.MulticastAsync Method (Object)

Grid Solutions Framework ServerBaseMulticastAsync Method (Object)
Sends data to all of the connected clients asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle[] MulticastAsync(
    Object serializableObject
)
Public Overridable Function MulticastAsync (
    serializableObject As Object
) As WaitHandle()
abstract MulticastAsync :
        serializableObject : Object -> WaitHandle[]
override MulticastAsync :
        serializableObject : Object -> WaitHandle[]
function MulticastAsync(serializableObject);
public:
virtual array<WaitHandle^>^ MulticastAsync(
    Object^ serializableObject
)

Parameters

serializableObject
Type: SystemObject
The serializable object that is to be sent.

Return Value

Type: WaitHandle
Array of WaitHandle for the asynchronous operation.
See Also

Reference

ServerBase Class
MulticastAsync Overload
GSF.Communication Namespace


ServerBase.MulticastAsync Method (String)

Grid Solutions Framework ServerBaseMulticastAsync Method (String)
Sends data to all of the connected clients asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle[] MulticastAsync(
    string data
)
Public Overridable Function MulticastAsync (
    data As String
) As WaitHandle()
abstract MulticastAsync :
        data : string -> WaitHandle[]
override MulticastAsync :
        data : string -> WaitHandle[]
function MulticastAsync(data);
public:
virtual array<WaitHandle^>^ MulticastAsync(
    String^ data
)

Parameters

data
Type: SystemString
The plain-text data that is to be sent.

Return Value

Type: WaitHandle
Array of WaitHandle for the asynchronous operation.
See Also

Reference

ServerBase Class
MulticastAsync Overload
GSF.Communication Namespace


ServerBase.MulticastAsync Method (Byte[], Int32, Int32)

Grid Solutions Framework ServerBaseMulticastAsync Method (Byte, Int32, Int32)
Sends data to all of the connected clients asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle[] MulticastAsync(
    byte[] data,
    int offset,
    int length
)
Public Overridable Function MulticastAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle()
abstract MulticastAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle[]
override MulticastAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle[]
function MulticastAsync(data, offset, length);
public:
virtual array<WaitHandle^>^ MulticastAsync(
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
Array of WaitHandle for the asynchronous operation.

Implements

IServerMulticastAsync(Byte, Int32, Int32)
See Also

Reference

ServerBase Class
MulticastAsync Overload
GSF.Communication Namespace


ServerBase.OnClientConnected Method

Grid Solutions Framework ServerBaseOnClientConnected Method
Raises the ClientConnected event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnClientConnected(
    Guid clientID
)
Protected Overridable Sub OnClientConnected (
    clientID As Guid
)
abstract OnClientConnected :
        clientID : Guid -> unit
override OnClientConnected :
        clientID : Guid -> unit
function OnClientConnected(clientID);
protected:
virtual void OnClientConnected(
    Guid clientID
)

Parameters

clientID
Type: SystemGuid
ID of client to send to ClientConnected event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnClientConnectingException Method

Grid Solutions Framework ServerBaseOnClientConnectingException Method
Raises the ClientConnectingException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnClientConnectingException(
    Exception ex
)
Protected Overridable Sub OnClientConnectingException (
    ex As Exception
)
abstract OnClientConnectingException :
        ex : Exception -> unit
override OnClientConnectingException :
        ex : Exception -> unit
function OnClientConnectingException(ex);
protected:
virtual void OnClientConnectingException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
The Exception encountered when connecting to the client.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnClientDisconnected Method

Grid Solutions Framework ServerBaseOnClientDisconnected Method
Raises the ClientDisconnected event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnClientDisconnected(
    Guid clientID
)
Protected Overridable Sub OnClientDisconnected (
    clientID As Guid
)
abstract OnClientDisconnected :
        clientID : Guid -> unit
override OnClientDisconnected :
        clientID : Guid -> unit
function OnClientDisconnected(clientID);
protected:
virtual void OnClientDisconnected(
    Guid clientID
)

Parameters

clientID
Type: SystemGuid
ID of client to send to ClientDisconnected event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnReceiveClientData Method

Grid Solutions Framework ServerBaseOnReceiveClientData Method
Raises the ReceiveClientData event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceiveClientData(
    Guid clientID,
    int size
)
Protected Overridable Sub OnReceiveClientData (
    clientID As Guid,
    size As Integer
)
abstract OnReceiveClientData :
        clientID : Guid *
        size : int -> unit
override OnReceiveClientData :
        clientID : Guid *
        size : int -> unit
function OnReceiveClientData(clientID, size);
protected:
virtual void OnReceiveClientData(
    Guid clientID,
    int size
)

Parameters

clientID
Type: SystemGuid
ID of the client from which data is received.
size
Type: SystemInt32
Number of bytes received from the client.
Remarks
This event is automatically raised by call to OnReceiveClientDataComplete(Guid, Byte, Int32) so that inheritors never need to worry about raising this event. This method is only included here in case any custom server implementations need to explicitly raise this event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnReceiveClientDataComplete Method

Grid Solutions Framework ServerBaseOnReceiveClientDataComplete Method
Raises the ReceiveClientDataComplete event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceiveClientDataComplete(
    Guid clientID,
    byte[] data,
    int size
)
Protected Overridable Sub OnReceiveClientDataComplete (
    clientID As Guid,
    data As Byte(),
    size As Integer
)
abstract OnReceiveClientDataComplete :
        clientID : Guid *
        data : byte[] *
        size : int -> unit
override OnReceiveClientDataComplete :
        clientID : Guid *
        data : byte[] *
        size : int -> unit
function OnReceiveClientDataComplete(clientID, data, size);
protected:
virtual void OnReceiveClientDataComplete(
    Guid clientID,
    array<unsigned char>^ data,
    int size
)

Parameters

clientID
Type: SystemGuid
ID of the client from which data is received.
data
Type: SystemByte
Data received from the client.
size
Type: SystemInt32
Number of bytes received from the client.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnReceiveClientDataException Method

Grid Solutions Framework ServerBaseOnReceiveClientDataException Method
Raises the ReceiveClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceiveClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overridable Sub OnReceiveClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnReceiveClientDataException(clientID, ex);
protected:
virtual void OnReceiveClientDataException(
    Guid clientID,
    Exception^ ex
)

Parameters

clientID
Type: SystemGuid
ID of client to send to ReceiveClientDataException event.
ex
Type: SystemException
Exception to send to ReceiveClientDataException event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnSendClientDataComplete Method

Grid Solutions Framework ServerBaseOnSendClientDataComplete Method
Raises the SendClientDataComplete event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSendClientDataComplete(
    Guid clientID
)
Protected Overridable Sub OnSendClientDataComplete (
    clientID As Guid
)
abstract OnSendClientDataComplete :
        clientID : Guid -> unit
override OnSendClientDataComplete :
        clientID : Guid -> unit
function OnSendClientDataComplete(clientID);
protected:
virtual void OnSendClientDataComplete(
    Guid clientID
)

Parameters

clientID
Type: SystemGuid
ID of client to send to SendClientDataComplete event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnSendClientDataException Method

Grid Solutions Framework ServerBaseOnSendClientDataException Method
Raises the SendClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSendClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overridable Sub OnSendClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnSendClientDataException(clientID, ex);
protected:
virtual void OnSendClientDataException(
    Guid clientID,
    Exception^ ex
)

Parameters

clientID
Type: SystemGuid
ID of client to send to SendClientDataException event.
ex
Type: SystemException
Exception to send to SendClientDataException event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnSendClientDataStart Method

Grid Solutions Framework ServerBaseOnSendClientDataStart Method
Raises the SendClientDataStart event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSendClientDataStart(
    Guid clientID
)
Protected Overridable Sub OnSendClientDataStart (
    clientID As Guid
)
abstract OnSendClientDataStart :
        clientID : Guid -> unit
override OnSendClientDataStart :
        clientID : Guid -> unit
function OnSendClientDataStart(clientID);
protected:
virtual void OnSendClientDataStart(
    Guid clientID
)

Parameters

clientID
Type: SystemGuid
ID of client to send to SendClientDataStart event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnServerStarted Method

Grid Solutions Framework ServerBaseOnServerStarted Method
Raises the ServerStarted event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServerStarted()
Protected Overridable Sub OnServerStarted
abstract OnServerStarted : unit -> unit
override OnServerStarted : unit -> unit
function OnServerStarted();
protected:
virtual void OnServerStarted()
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnServerStopped Method

Grid Solutions Framework ServerBaseOnServerStopped Method
Raises the ServerStopped event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServerStopped()
Protected Overridable Sub OnServerStopped
abstract OnServerStopped : unit -> unit
override OnServerStopped : unit -> unit
function OnServerStopped();
protected:
virtual void OnServerStopped()
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.OnUnhandledUserException Method

Grid Solutions Framework ServerBaseOnUnhandledUserException Method
Raises the UnhandledUserException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnhandledUserException(
    Exception ex
)
Protected Overridable Sub OnUnhandledUserException (
    ex As Exception
)
abstract OnUnhandledUserException :
        ex : Exception -> unit
override OnUnhandledUserException :
        ex : Exception -> unit
function OnUnhandledUserException(ex);
protected:
virtual void OnUnhandledUserException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to UnhandledUserException event.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Read Method

Grid Solutions Framework ServerBaseRead Method
When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int Read(
    Guid clientID,
    byte[] buffer,
    int startIndex,
    int length
)
Public MustOverride Function Read (
    clientID As Guid,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int

function Read(clientID, buffer, startIndex, length);
public:
virtual int Read(
    Guid clientID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) abstract

Parameters

clientID
Type: SystemGuid
ID of the client from which data buffer should be read.
buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IServerRead(Guid, Byte, Int32, Int32)
Remarks
This function should only be called from within the ReceiveClientData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ReStart Method

Grid Solutions Framework ServerBaseReStart Method
Re-starts the server if currently running.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void ReStart()
Protected Sub ReStart
member ReStart : unit -> unit

function ReStart();
protected:
void ReStart()
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SaveSettings Method

Grid Solutions Framework ServerBaseSaveSettings Method
Saves server settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SaveSettings()
Public Overridable Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings()

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendDataToAsync Method

Grid Solutions Framework ServerBaseSendDataToAsync Method
When overridden in a derived class, sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract WaitHandle SendDataToAsync(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Protected MustOverride Function SendDataToAsync (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle

function SendDataToAsync(clientID, data, offset, length);
protected:
virtual WaitHandle^ SendDataToAsync(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
) abstract

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendTo Method

Grid Solutions Framework ServerBaseSendTo Method
Overload List
 | Name | Description
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously.
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendTo Method (Guid, Byte[])

Grid Solutions Framework ServerBaseSendTo Method (Guid, Byte)
Sends data to the specified client synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SendTo(
    Guid clientID,
    byte[] data
)
Public Overridable Sub SendTo (
    clientID As Guid,
    data As Byte()
)
abstract SendTo :
        clientID : Guid *
        data : byte[] -> unit
override SendTo :
        clientID : Guid *
        data : byte[] -> unit
function SendTo(clientID, data);
public:
virtual void SendTo(
    Guid clientID,
    array<unsigned char>^ data
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The binary data that is to be sent.
See Also

Reference

ServerBase Class
SendTo Overload
GSF.Communication Namespace


ServerBase.SendTo Method (Guid, Object)

Grid Solutions Framework ServerBaseSendTo Method (Guid, Object)
Sends data to the specified client synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SendTo(
    Guid clientID,
    Object serializableObject
)
Public Overridable Sub SendTo (
    clientID As Guid,
    serializableObject As Object
)
abstract SendTo :
        clientID : Guid *
        serializableObject : Object -> unit
override SendTo :
        clientID : Guid *
        serializableObject : Object -> unit
function SendTo(clientID, serializableObject);
public:
virtual void SendTo(
    Guid clientID,
    Object^ serializableObject
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
serializableObject
Type: SystemObject
The serializable object that is to be sent.
See Also

Reference

ServerBase Class
SendTo Overload
GSF.Communication Namespace


ServerBase.SendTo Method (Guid, String)

Grid Solutions Framework ServerBaseSendTo Method (Guid, String)
Sends data to the specified client synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SendTo(
    Guid clientID,
    string data
)
Public Overridable Sub SendTo (
    clientID As Guid,
    data As String
)
abstract SendTo :
        clientID : Guid *
        data : string -> unit
override SendTo :
        clientID : Guid *
        data : string -> unit
function SendTo(clientID, data);
public:
virtual void SendTo(
    Guid clientID,
    String^ data
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemString
The plain-text data that is to be sent.
See Also

Reference

ServerBase Class
SendTo Overload
GSF.Communication Namespace


ServerBase.SendTo Method (Guid, Byte[], Int32, Int32)

Grid Solutions Framework ServerBaseSendTo Method (Guid, Byte, Int32, Int32)
Sends data to the specified client synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SendTo(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Public Overridable Sub SendTo (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
)
abstract SendTo :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> unit
override SendTo :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> unit
function SendTo(clientID, data, offset, length);
public:
virtual void SendTo(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Implements

IServerSendTo(Guid, Byte, Int32, Int32)
See Also

Reference

ServerBase Class
SendTo Overload
GSF.Communication Namespace


ServerBase.SendToAsync Method

Grid Solutions Framework ServerBaseSendToAsync Method
Overload List
 | Name | Description
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously.
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendToAsync Method (Guid, Byte[])

Grid Solutions Framework ServerBaseSendToAsync Method (Guid, Byte)
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendToAsync(
    Guid clientID,
    byte[] data
)
Public Overridable Function SendToAsync (
    clientID As Guid,
    data As Byte()
) As WaitHandle
abstract SendToAsync :
        clientID : Guid *
        data : byte[] -> WaitHandle
override SendToAsync :
        clientID : Guid *
        data : byte[] -> WaitHandle
function SendToAsync(clientID, data);
public:
virtual WaitHandle^ SendToAsync(
    Guid clientID,
    array<unsigned char>^ data
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The binary data that is to be sent.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ServerBase Class
SendToAsync Overload
GSF.Communication Namespace


ServerBase.SendToAsync Method (Guid, Object)

Grid Solutions Framework ServerBaseSendToAsync Method (Guid, Object)
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendToAsync(
    Guid clientID,
    Object serializableObject
)
Public Overridable Function SendToAsync (
    clientID As Guid,
    serializableObject As Object
) As WaitHandle
abstract SendToAsync :
        clientID : Guid *
        serializableObject : Object -> WaitHandle
override SendToAsync :
        clientID : Guid *
        serializableObject : Object -> WaitHandle
function SendToAsync(clientID, serializableObject);
public:
virtual WaitHandle^ SendToAsync(
    Guid clientID,
    Object^ serializableObject
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
serializableObject
Type: SystemObject
The serializable object that is to be sent.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ServerBase Class
SendToAsync Overload
GSF.Communication Namespace


ServerBase.SendToAsync Method (Guid, String)

Grid Solutions Framework ServerBaseSendToAsync Method (Guid, String)
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendToAsync(
    Guid clientID,
    string data
)
Public Overridable Function SendToAsync (
    clientID As Guid,
    data As String
) As WaitHandle
abstract SendToAsync :
        clientID : Guid *
        data : string -> WaitHandle
override SendToAsync :
        clientID : Guid *
        data : string -> WaitHandle
function SendToAsync(clientID, data);
public:
virtual WaitHandle^ SendToAsync(
    Guid clientID,
    String^ data
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemString
The plain-text data that is to be sent.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ServerBase Class
SendToAsync Overload
GSF.Communication Namespace


ServerBase.SendToAsync Method (Guid, Byte[], Int32, Int32)

Grid Solutions Framework ServerBaseSendToAsync Method (Guid, Byte, Int32, Int32)
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual WaitHandle SendToAsync(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Public Overridable Function SendToAsync (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendToAsync(clientID, data, offset, length);
public:
virtual WaitHandle^ SendToAsync(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
)

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IServerSendToAsync(Guid, Byte, Int32, Int32)
See Also

Reference

ServerBase Class
SendToAsync Overload
GSF.Communication Namespace


ServerBase.Start Method

Grid Solutions Framework ServerBaseStart Method
When overridden in a derived class, starts the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract void Start()
Public MustOverride Sub Start
abstract Start : unit -> unit

function Start();
public:
virtual void Start() abstract

Implements

IServerStart
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Stop Method

Grid Solutions Framework ServerBaseStop Method
When overridden in a derived class, stops the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract void Stop()
Public MustOverride Sub Stop
abstract Stop : unit -> unit

function Stop();
public:
virtual void Stop() abstract

Implements

IServerStop
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ValidateConfigurationString Method

Grid Solutions Framework ServerBaseValidateConfigurationString Method
When overridden in a derived class, validates the specified configurationString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void ValidateConfigurationString(
    string configurationString
)
Protected MustOverride Sub ValidateConfigurationString (
    configurationString As String
)
abstract ValidateConfigurationString :
        configurationString : string -> unit

function ValidateConfigurationString(configurationString);
protected:
virtual void ValidateConfigurationString(
    String^ configurationString
) abstract

Parameters

configurationString
Type: SystemString
The configuration string to be validated.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase Properties

Grid Solutions Framework ServerBase Properties

The ServerBase type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIDs | Gets the IDs of clients connected to the server.
Public property | ConfigurationString | Gets or sets the data required by the server to initialize.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server.
Public property | Name | Gets the unique identifier of the server.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file.
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call.
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients.
Public property | RunTime | Gets the Time for which the server has been running.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients.
Public property | ServerID | Gets the server's ID.
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the server.
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients.
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ClientIDs Property

Grid Solutions Framework ServerBaseClientIDs Property
Gets the IDs of clients connected to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual Guid[] ClientIDs { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property ClientIDs As Guid()
    Get
[<BrowsableAttribute(false)>]
abstract ClientIDs : Guid[] with get
[<BrowsableAttribute(false)>]
override ClientIDs : Guid[] with get
function get_ClientIDs();

public:
[BrowsableAttribute(false)]
virtual property array<Guid>^ ClientIDs {
    array<Guid>^ get ();
}

Property Value

Type: Guid

Implements

IServerClientIDs
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ConfigurationString Property

Grid Solutions Framework ServerBaseConfigurationString Property
Gets or sets the data required by the server to initialize.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ConfigurationString { get; set; }
Public Overridable Property ConfigurationString As String
    Get
    Set
abstract ConfigurationString : string with get, set
override ConfigurationString : string with get, set
function get_ConfigurationString();
function set_ConfigurationString(value);
public:
virtual property String^ ConfigurationString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IServerConfigurationString
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.CurrentState Property

Grid Solutions Framework ServerBaseCurrentState Property
Gets the current ServerState.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ServerState CurrentState { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property CurrentState As ServerState
    Get
[<BrowsableAttribute(false)>]
abstract CurrentState : ServerState with get
[<BrowsableAttribute(false)>]
override CurrentState : ServerState with get
function get_CurrentState();

public:
[BrowsableAttribute(false)]
virtual property ServerState CurrentState {
    ServerState get () sealed;
}

Property Value

Type: ServerState

Implements

IServerCurrentState
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Enabled Property

Grid Solutions Framework ServerBaseEnabled Property
Gets or sets a boolean value that indicates whether the server is currently enabled.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool Enabled { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Enabled As Boolean
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract Enabled : bool with get, set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Setting Enabled to true will start the server if it is not running, setting to false will stop the server if it is running.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Initialized Property

Grid Solutions Framework ServerBaseInitialized Property
Gets a boolean value that indicates whether the server has been initialized.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool Initialized { get; }
Protected ReadOnly Property Initialized As Boolean
    Get
member Initialized : bool with get

function get_Initialized();

protected:
property bool Initialized {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.IsDisposed Property

Grid Solutions Framework ServerBaseIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool IsDisposed { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
abstract IsDisposed : bool with get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.MaxClientConnections Property

Grid Solutions Framework ServerBaseMaxClientConnections Property
Gets or sets the maximum number of clients that can connect to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(-1)]
public virtual int MaxClientConnections { get; set; }
<DefaultValueAttribute(-1)>
Public Overridable Property MaxClientConnections As Integer
    Get
    Set
[<DefaultValueAttribute(-1)>]
abstract MaxClientConnections : int with get, set
[<DefaultValueAttribute(-1)>]
override MaxClientConnections : int with get, set
function get_MaxClientConnections();
function set_MaxClientConnections(value);
public:
[DefaultValueAttribute(-1)]
virtual property int MaxClientConnections {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IServerMaxClientConnections
Remarks
Set MaxClientConnections to -1 to allow infinite client connections.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Name Property

Grid Solutions Framework ServerBaseName Property
Gets the unique identifier of the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.PersistSettings Property

Grid Solutions Framework ServerBasePersistSettings Property
Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ReadIndicies Property

Grid Solutions Framework ServerBaseReadIndicies Property
Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConcurrentDictionary<Guid, int> ReadIndicies { get; }
Protected ReadOnly Property ReadIndicies As ConcurrentDictionary(Of Guid, Integer)
    Get
member ReadIndicies : ConcurrentDictionary<Guid, int> with get

function get_ReadIndicies();

protected:
property ConcurrentDictionary<Guid, int>^ ReadIndicies {
    ConcurrentDictionary<Guid, int>^ get ();
}

Property Value

Type: ConcurrentDictionary Guid, Int32
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ReceiveBufferSize Property

Grid Solutions Framework ServerBaseReceiveBufferSize Property
Gets or sets the size of the buffer used by the server for receiving data from the clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(32768)]
public virtual int ReceiveBufferSize { get; set; }
<DefaultValueAttribute(32768)>
Public Overridable Property ReceiveBufferSize As Integer
    Get
    Set
[<DefaultValueAttribute(32768)>]
abstract ReceiveBufferSize : int with get, set
[<DefaultValueAttribute(32768)>]
override ReceiveBufferSize : int with get, set
function get_ReceiveBufferSize();
function set_ReceiveBufferSize(value);
public:
[DefaultValueAttribute(32768)]
virtual property int ReceiveBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IServerReceiveBufferSize
Exceptions
Exception | Condition
ArgumentException | The value being assigned is either zero or negative.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.RunTime Property

Grid Solutions Framework ServerBaseRunTime Property
Gets the Time for which the server has been running.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual Time RunTime { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property RunTime As Time
    Get
[<BrowsableAttribute(false)>]
abstract RunTime : Time with get
[<BrowsableAttribute(false)>]
override RunTime : Time with get
function get_RunTime();

public:
[BrowsableAttribute(false)]
virtual property Time RunTime {
    Time get ();
}

Property Value

Type: Time

Implements

IServerRunTime
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendBufferSize Property

Grid Solutions Framework ServerBaseSendBufferSize Property
Gets or sets the size of the buffer used by the server for sending data to the clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(32768)]
public virtual int SendBufferSize { get; set; }
<DefaultValueAttribute(32768)>
Public Overridable Property SendBufferSize As Integer
    Get
    Set
[<DefaultValueAttribute(32768)>]
abstract SendBufferSize : int with get, set
[<DefaultValueAttribute(32768)>]
override SendBufferSize : int with get, set
function get_SendBufferSize();
function set_SendBufferSize(value);
public:
[DefaultValueAttribute(32768)]
virtual property int SendBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IServerSendBufferSize
Exceptions
Exception | Condition
ArgumentException | The value being assigned is either zero or negative.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ServerID Property

Grid Solutions Framework ServerBaseServerID Property
Gets the server's ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual Guid ServerID { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property ServerID As Guid
    Get
[<BrowsableAttribute(false)>]
abstract ServerID : Guid with get
[<BrowsableAttribute(false)>]
override ServerID : Guid with get
function get_ServerID();

public:
[BrowsableAttribute(false)]
virtual property Guid ServerID {
    Guid get ();
}

Property Value

Type: Guid

Implements

IServerServerID
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SettingsCategory Property

Grid Solutions Framework ServerBaseSettingsCategory Property
Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("CommunicationServer")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("CommunicationServer")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("CommunicationServer")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("CommunicationServer")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"CommunicationServer")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.Status Property

Grid Solutions Framework ServerBaseStatus Property
Gets the descriptive status of the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual string Status { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.TextEncoding Property

Grid Solutions Framework ServerBaseTextEncoding Property
Gets or sets the Encoding to be used for the text sent to the connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public virtual Encoding TextEncoding { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Overridable Property TextEncoding As Encoding
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
abstract TextEncoding : Encoding with get, set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
override TextEncoding : Encoding with get, set
function get_TextEncoding();
function set_TextEncoding(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
virtual property Encoding^ TextEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding

Implements

IServerTextEncoding
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.TransportProtocol Property

Grid Solutions Framework ServerBaseTransportProtocol Property
Gets the TransportProtocol used by the server for the transportation of data with the clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual TransportProtocol TransportProtocol { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property TransportProtocol As TransportProtocol
    Get
[<BrowsableAttribute(false)>]
abstract TransportProtocol : TransportProtocol with get
[<BrowsableAttribute(false)>]
override TransportProtocol : TransportProtocol with get
function get_TransportProtocol();

public:
[BrowsableAttribute(false)]
virtual property TransportProtocol TransportProtocol {
    TransportProtocol get ();
}

Property Value

Type: TransportProtocol

Implements

IServerTransportProtocol
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase Events

Grid Solutions Framework ServerBase Events

The ServerBase type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server.
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting.
Public event | ClientDisconnected | Occurs when a client disconnects from the server.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client.
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption.
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client.
Public event | SendClientDataComplete | Occurs when data has been sent to a client.
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client.
Public event | SendClientDataStart | Occurs when data is being sent to a client.
Public event | ServerStarted | Occurs when the server is started.
Public event | ServerStopped | Occurs when the server is stopped.
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch.
Top
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ClientConnected Event

Grid Solutions Framework ServerBaseClientConnected Event
Occurs when a client connects to the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid>> ClientConnected
Public Event ClientConnected As EventHandler(Of EventArgs(Of Guid))
abstract ClientConnected : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
override ClientConnected : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
function add_ClientConnected(value);
function remove_ClientConnected(value);
public:
virtual  event EventHandler<EventArgs<Guid>^>^ ClientConnected {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid

Implements

IServerClientConnected
Remarks
Argument is the ID of the client that connected to the server.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ClientConnectingException Event

Grid Solutions Framework ServerBaseClientConnectingException Event
Occurs when an exception is encountered while a client is connecting.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ClientConnectingException
Public Event ClientConnectingException As EventHandler(Of EventArgs(Of Exception))
abstract ClientConnectingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ClientConnectingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ClientConnectingException(value);
function remove_ClientConnectingException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ClientConnectingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IServerClientConnectingException
Remarks
Argument is the Exception encountered when connecting to the client.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ClientDisconnected Event

Grid Solutions Framework ServerBaseClientDisconnected Event
Occurs when a client disconnects from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid>> ClientDisconnected
Public Event ClientDisconnected As EventHandler(Of EventArgs(Of Guid))
abstract ClientDisconnected : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
override ClientDisconnected : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
function add_ClientDisconnected(value);
function remove_ClientDisconnected(value);
public:
virtual  event EventHandler<EventArgs<Guid>^>^ ClientDisconnected {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid

Implements

IServerClientDisconnected
Remarks
Argument is the ID of the client that disconnected from the server.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ReceiveClientData Event

Grid Solutions Framework ServerBaseReceiveClientData Event
Occurs when unprocessed data has been received from a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid, int>> ReceiveClientData
Public Event ReceiveClientData As EventHandler(Of EventArgs(Of Guid, Integer))
abstract ReceiveClientData : IEvent<EventHandler<EventArgs<Guid, int>>,
    EventArgs<Guid, int>>
override ReceiveClientData : IEvent<EventHandler<EventArgs<Guid, int>>,
    EventArgs<Guid, int>>
function add_ReceiveClientData(value);
function remove_ReceiveClientData(value);
public:
virtual  event EventHandler<EventArgs<Guid, int>^>^ ReceiveClientData {
    void add (EventHandler<EventArgs<Guid, int>^>^ value);
    void remove (EventHandler<EventArgs<Guid, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Int32

Implements

IServerReceiveClientData
Remarks

This event can be used to receive a notification that client data has arrived. The Read(Guid, Byte, Int32, Int32) method can then be used to copy data to an existing buffer. In many cases it will be optimal to use an existing buffer instead of subscribing to the ReceiveClientDataComplete event, however, the data that is available after calling the Read(Guid, Byte, Int32, Int32) method will be the original unprocessed data received by the client, i.e., not optionally decrypted or decompressed data.

Argument1 is the ID of the client from which data is received.
Argument2 is the number of bytes received in the buffer from the client.

See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ReceiveClientDataComplete Event

Grid Solutions Framework ServerBaseReceiveClientDataComplete Event
Occurs when data received from a client has been processed and is ready for consumption.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid, byte[], int>> ReceiveClientDataComplete
Public Event ReceiveClientDataComplete As EventHandler(Of EventArgs(Of Guid, Byte(), Integer))
abstract ReceiveClientDataComplete : IEvent<EventHandler<EventArgs<Guid, byte[], int>>,
    EventArgs<Guid, byte[], int>>
override ReceiveClientDataComplete : IEvent<EventHandler<EventArgs<Guid, byte[], int>>,
    EventArgs<Guid, byte[], int>>
function add_ReceiveClientDataComplete(value);
function remove_ReceiveClientDataComplete(value);
public:
virtual  event EventHandler<EventArgs<Guid, array<unsigned char>^, int>^>^ ReceiveClientDataComplete {
    void add (EventHandler<EventArgs<Guid, array<unsigned char>^, int>^>^ value);
    void remove (EventHandler<EventArgs<Guid, array<unsigned char>^, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Byte , Int32

Implements

IServerReceiveClientDataComplete
Remarks
Argument1 is the ID of the client from which data is received.
Argument2 is a new buffer containing post-processed data received from the client starting at index zero.
Argument3 is the number of post-processed bytes received in the buffer from the client.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ReceiveClientDataException Event

Grid Solutions Framework ServerBaseReceiveClientDataException Event
Occurs when an Exception is encountered when receiving data from a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid, Exception>> ReceiveClientDataException
Public Event ReceiveClientDataException As EventHandler(Of EventArgs(Of Guid, Exception))
abstract ReceiveClientDataException : IEvent<EventHandler<EventArgs<Guid, Exception>>,
    EventArgs<Guid, Exception>>
override ReceiveClientDataException : IEvent<EventHandler<EventArgs<Guid, Exception>>,
    EventArgs<Guid, Exception>>
function add_ReceiveClientDataException(value);
function remove_ReceiveClientDataException(value);
public:
virtual  event EventHandler<EventArgs<Guid, Exception^>^>^ ReceiveClientDataException {
    void add (EventHandler<EventArgs<Guid, Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Guid, Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Exception

Implements

IServerReceiveClientDataException
Remarks
Argument1 is the ID of the client from which the data was being received.
Argument2 is the Exception encountered when receiving data from a client.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendClientDataComplete Event

Grid Solutions Framework ServerBaseSendClientDataComplete Event
Occurs when data has been sent to a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid>> SendClientDataComplete
Public Event SendClientDataComplete As EventHandler(Of EventArgs(Of Guid))
abstract SendClientDataComplete : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
override SendClientDataComplete : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
function add_SendClientDataComplete(value);
function remove_SendClientDataComplete(value);
public:
virtual  event EventHandler<EventArgs<Guid>^>^ SendClientDataComplete {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid

Implements

IServerSendClientDataComplete
Remarks
Argument is the ID of the client to which the data has been sent.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendClientDataException Event

Grid Solutions Framework ServerBaseSendClientDataException Event
Occurs when an Exception is encountered when sending data to a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid, Exception>> SendClientDataException
Public Event SendClientDataException As EventHandler(Of EventArgs(Of Guid, Exception))
abstract SendClientDataException : IEvent<EventHandler<EventArgs<Guid, Exception>>,
    EventArgs<Guid, Exception>>
override SendClientDataException : IEvent<EventHandler<EventArgs<Guid, Exception>>,
    EventArgs<Guid, Exception>>
function add_SendClientDataException(value);
function remove_SendClientDataException(value);
public:
virtual  event EventHandler<EventArgs<Guid, Exception^>^>^ SendClientDataException {
    void add (EventHandler<EventArgs<Guid, Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Guid, Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, Exception

Implements

IServerSendClientDataException
Remarks
Argument1 is the ID of the client to which the data was being sent.
Argument2 is the Exception encountered when sending data to a client.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.SendClientDataStart Event

Grid Solutions Framework ServerBaseSendClientDataStart Event
Occurs when data is being sent to a client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid>> SendClientDataStart
Public Event SendClientDataStart As EventHandler(Of EventArgs(Of Guid))
abstract SendClientDataStart : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
override SendClientDataStart : IEvent<EventHandler<EventArgs<Guid>>,
    EventArgs<Guid>>
function add_SendClientDataStart(value);
function remove_SendClientDataStart(value);
public:
virtual  event EventHandler<EventArgs<Guid>^>^ SendClientDataStart {
    void add (EventHandler<EventArgs<Guid>^>^ value);
    void remove (EventHandler<EventArgs<Guid>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid

Implements

IServerSendClientDataStart
Remarks
Argument is the ID of the client to which the data is being sent.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ServerStarted Event

Grid Solutions Framework ServerBaseServerStarted Event
Occurs when the server is started.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServerStarted
Public Event ServerStarted As EventHandler
abstract ServerStarted : IEvent<EventHandler,
    EventArgs>
override ServerStarted : IEvent<EventHandler,
    EventArgs>
function add_ServerStarted(value);
function remove_ServerStarted(value);
public:
virtual  event EventHandler^ ServerStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IServerServerStarted
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.ServerStopped Event

Grid Solutions Framework ServerBaseServerStopped Event
Occurs when the server is stopped.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServerStopped
Public Event ServerStopped As EventHandler
abstract ServerStopped : IEvent<EventHandler,
    EventArgs>
override ServerStopped : IEvent<EventHandler,
    EventArgs>
function add_ServerStopped(value);
function remove_ServerStopped(value);
public:
virtual  event EventHandler^ ServerStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IServerServerStopped
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerBase.UnhandledUserException Event

Grid Solutions Framework ServerBaseUnhandledUserException Event
Occurs when an Exception is encountered in a user-defined function via an event dispatch.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> UnhandledUserException
Public Event UnhandledUserException As EventHandler(Of EventArgs(Of Exception))
abstract UnhandledUserException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override UnhandledUserException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_UnhandledUserException(value);
function remove_UnhandledUserException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ UnhandledUserException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IServerUnhandledUserException
Remarks
Argument is the Exception thrown by the user-defined function.
See Also

Reference

ServerBase Class
GSF.Communication Namespace


ServerState Enumeration

Grid Solutions Framework ServerState Enumeration
Indicates the current state of the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ServerState
Public Enumeration ServerState
type ServerState
GSF.Communication.ServerState = function();
GSF.Communication.ServerState.createEnum('GSF.Communication.ServerState', false);
public enum class ServerState
Members
Member name | Value | Description
Running | 0 | Server is running.
NotRunning | 1 | Server is not running.
See Also

Reference

GSF.Communication Namespace


TcpClient Class

Grid Solutions Framework TcpClient Class
Represents a TCP-based communication client.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
GSF.CommunicationTcpClient

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TcpClient : ClientBase
Public Class TcpClient
    Inherits ClientBase
type TcpClient =
    class
        inherit ClientBase
    end
GSF.Communication.TcpClient = function();

Type.createClass(
    'GSF.Communication.TcpClient',
    GSF.Communication.ClientBase);
public ref class TcpClient : public ClientBase

The TcpClient type exposes the following members.

Constructors
 | Name | Description
Public method | TcpClient | Initializes a new instance of the TcpClient class.
Public method | TcpClient(IContainer) | Initializes a new instance of the TcpClient class.
Public method | TcpClient(String) | Initializes a new instance of the TcpClient class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the TcpClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the TcpClient from the connected server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TcpClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Inherited from ClientBase.)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException(Exception) | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnReceiveDataException(SocketException) | Raises the ReceiveDataException event.
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TcpClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Top
Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the Socket object for the TcpClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the current Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | NetworkCredential | Gets or sets network credential that is used when IntegratedSecurity is set to true.
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the TcpClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ClientBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
Remarks
The socket can be bound to a specified interface on a machine with multiple interfaces by specifying the IP of the interface in the ConnectionString (Example: "Server=localhost:8888; Interface=192.168.1.15")
Examples
This example shows how to use the TcpClient component:
Copy
using System;
using GSF;
using GSF.Communication;
using GSF.Security.Cryptography;
using GSF.IO.Compression;

class Program
{
    static TcpClient s_client;

    static void Main(string[] args)
    {
        // Initialize the client.
        s_client = new TcpClient("Server=localhost:8888");
        s_client.Handshake = false;
        s_client.PayloadAware = false;
        s_client.ReceiveTimeout = -1;
        s_client.MaxConnectionAttempts = 5;
        s_client.Encryption = CipherStrength.None;
        s_client.Compression = CompressionStrength.NoCompression;
        s_client.SecureSession = false;
        s_client.Initialize();
        // Register event handlers.
        s_client.ConnectionAttempt += s_client_ConnectionAttempt;
        s_client.ConnectionEstablished += s_client_ConnectionEstablished;
        s_client.ConnectionTerminated += s_client_ConnectionTerminated;
        s_client.ReceiveDataComplete += s_client_ReceiveDataComplete;
        // Connect the client.
        s_client.Connect();

        // Transmit user input to the server.
        string input;
        while (string.Compare(input = Console.ReadLine(), "Exit", true) != 0)
        {
            s_client.Send(input);
        }

        // Disconnect the client on shutdown.
        s_client.Dispose();
    }

    static void s_client_ConnectionAttempt(object sender, EventArgs e)
    {
        Console.WriteLine("Client is connecting to server.");
    }

    static void s_client_ConnectionEstablished(object sender, EventArgs e)
    {
        Console.WriteLine("Client connected to server.");
    }

    static void s_client_ConnectionTerminated(object sender, EventArgs e)
    {
        Console.WriteLine("Client disconnected from server.");
    }

    static void s_client_ReceiveDataComplete(object sender, EventArgs<byte[], int> e)
    {
        Console.WriteLine(string.Format("Received data - {0}.", s_client.TextEncoding.GetString(e.Argument1, 0, e.Argument2)));
    }
}
See Also

Reference

GSF.Communication Namespace


TcpClient Constructor

Grid Solutions Framework TcpClient Constructor
Overload List
 | Name | Description
Public method | TcpClient | Initializes a new instance of the TcpClient class.
Public method | TcpClient(IContainer) | Initializes a new instance of the TcpClient class.
Public method | TcpClient(String) | Initializes a new instance of the TcpClient class.
Top
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient Constructor

Grid Solutions Framework TcpClient Constructor
Initializes a new instance of the TcpClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TcpClient()
Public Sub New
new : unit -> TcpClient
GSF.Communication.TcpClient = function();
public:
TcpClient()
See Also

Reference

TcpClient Class
TcpClient Overload
GSF.Communication Namespace


TcpClient Constructor (IContainer)

Grid Solutions Framework TcpClient Constructor (IContainer)
Initializes a new instance of the TcpClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TcpClient(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> TcpClient
GSF.Communication.TcpClient = function(container);
public:
TcpClient(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the TcpClient.
See Also

Reference

TcpClient Class
TcpClient Overload
GSF.Communication Namespace


TcpClient Constructor (String)

Grid Solutions Framework TcpClient Constructor (String)
Initializes a new instance of the TcpClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TcpClient(
    string connectString
)
Public Sub New (
    connectString As String
)
new :
        connectString : string -> TcpClient
GSF.Communication.TcpClient = function(connectString);
public:
TcpClient(
    String^ connectString
)

Parameters

connectString
Type: SystemString
Connect string of the TcpClient. See DefaultConnectionString for format.
See Also

Reference

TcpClient Class
TcpClient Overload
GSF.Communication Namespace


TcpClient Fields

Grid Solutions Framework TcpClient Fields

The TcpClient type exposes the following members.

Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Top
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.DefaultAllowDualStackSocket Field

Grid Solutions Framework TcpClientDefaultAllowDualStackSocket Field
Specifies the default value for the AllowDualStackSocket property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowDualStackSocket
Public Const DefaultAllowDualStackSocket As Boolean
static val mutable DefaultAllowDualStackSocket: bool
var GSF.Communication.TcpClient.DefaultAllowDualStackSocket
public:
literal bool DefaultAllowDualStackSocket

Field Value

Type: Boolean
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.DefaultConnectionString Field

Grid Solutions Framework TcpClientDefaultConnectionString Field
Specifies the default value for the ConnectionString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConnectionString
Public Const DefaultConnectionString As String
static val mutable DefaultConnectionString: string
var GSF.Communication.TcpClient.DefaultConnectionString
public:
literal String^ DefaultConnectionString

Field Value

Type: String
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.DefaultIgnoreInvalidCredentials Field

Grid Solutions Framework TcpClientDefaultIgnoreInvalidCredentials Field
Specifies the default value for the IgnoreInvalidCredentials property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIgnoreInvalidCredentials
Public Const DefaultIgnoreInvalidCredentials As Boolean
static val mutable DefaultIgnoreInvalidCredentials: bool
var GSF.Communication.TcpClient.DefaultIgnoreInvalidCredentials
public:
literal bool DefaultIgnoreInvalidCredentials

Field Value

Type: Boolean
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.DefaultIntegratedSecurity Field

Grid Solutions Framework TcpClientDefaultIntegratedSecurity Field
Specifies the default value for the IntegratedSecurity property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIntegratedSecurity
Public Const DefaultIntegratedSecurity As Boolean
static val mutable DefaultIntegratedSecurity: bool
var GSF.Communication.TcpClient.DefaultIntegratedSecurity
public:
literal bool DefaultIntegratedSecurity

Field Value

Type: Boolean
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.DefaultMaxSendQueueSize Field

Grid Solutions Framework TcpClientDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.TcpClient.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.DefaultPayloadAware Field

Grid Solutions Framework TcpClientDefaultPayloadAware Field
Specifies the default value for the PayloadAware property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPayloadAware
Public Const DefaultPayloadAware As Boolean
static val mutable DefaultPayloadAware: bool
var GSF.Communication.TcpClient.DefaultPayloadAware
public:
literal bool DefaultPayloadAware

Field Value

Type: Boolean
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient Methods

Grid Solutions Framework TcpClient Methods

The TcpClient type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the TcpClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the TcpClient from the connected server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TcpClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Inherited from ClientBase.)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException(Exception) | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnReceiveDataException(SocketException) | Raises the ReceiveDataException event.
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TcpClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.ConnectAsync Method

Grid Solutions Framework TcpClientConnectAsync Method
Connects the TcpClient to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override WaitHandle ConnectAsync()
Public Overrides Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle
override ConnectAsync : unit -> WaitHandle
function ConnectAsync();
public:
virtual WaitHandle^ ConnectAsync() override

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientConnectAsync
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to connect the TcpClient when it is not disconnected.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.Disconnect Method

Grid Solutions Framework TcpClientDisconnect Method
Disconnects the TcpClient from the connected server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Disconnect()
Public Overrides Sub Disconnect
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit
function Disconnect();
public:
virtual void Disconnect() override

Implements

IClientDisconnect
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.Dispose Method

Grid Solutions Framework TcpClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TcpClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Top
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.Dispose Method (Boolean)

Grid Solutions Framework TcpClientDispose Method (Boolean)
Releases the unmanaged resources used by the TcpClient and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

TcpClient Class
Dispose Overload
GSF.Communication Namespace


TcpClient.LoadSettings Method

Grid Solutions Framework TcpClientLoadSettings Method
Loads saved TcpClient settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.OnReceiveDataException Method

Grid Solutions Framework TcpClientOnReceiveDataException Method
Overload List
 | Name | Description
Protected method | OnReceiveDataException(Exception) | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnReceiveDataException(SocketException) | Raises the ReceiveDataException event.
Top
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.OnReceiveDataException Method (Exception)

Grid Solutions Framework TcpClientOnReceiveDataException Method (Exception)
Raises the ReceiveDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceiveDataException(
    Exception ex
)
Protected Overrides Sub OnReceiveDataException (
    ex As Exception
)
abstract OnReceiveDataException :
        ex : Exception -> unit
override OnReceiveDataException :
        ex : Exception -> unit
function OnReceiveDataException(ex);
protected:
virtual void OnReceiveDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ReceiveDataException event.
See Also

Reference

TcpClient Class
OnReceiveDataException Overload
GSF.Communication Namespace


TcpClient.OnReceiveDataException Method (SocketException)

Grid Solutions Framework TcpClientOnReceiveDataException Method (SocketException)
Raises the ReceiveDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnReceiveDataException(
    SocketException ex
)
Protected Sub OnReceiveDataException (
    ex As SocketException
)
member OnReceiveDataException :
        ex : SocketException -> unit

function OnReceiveDataException(ex);
protected:
void OnReceiveDataException(
    SocketException^ ex
)

Parameters

ex
Type: System.Net.SocketsSocketException
Exception to send to ReceiveDataException event.
See Also

Reference

TcpClient Class
OnReceiveDataException Overload
GSF.Communication Namespace


TcpClient.OnSendDataException Method

Grid Solutions Framework TcpClientOnSendDataException Method
Raises the SendDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnSendDataException(
    Exception ex
)
Protected Overrides Sub OnSendDataException (
    ex As Exception
)
abstract OnSendDataException :
        ex : Exception -> unit
override OnSendDataException :
        ex : Exception -> unit
function OnSendDataException(ex);
protected:
virtual void OnSendDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to SendDataException event.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.Read Method

Grid Solutions Framework TcpClientRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IClientRead(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.SaveSettings Method

Grid Solutions Framework TcpClientSaveSettings Method
Saves TcpClient settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.SendDataAsync Method

Grid Solutions Framework TcpClientSendDataAsync Method
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataAsync(
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataAsync(data, offset, length);
protected:
virtual WaitHandle^ SendDataAsync(
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.ValidateConnectionString Method

Grid Solutions Framework TcpClientValidateConnectionString Method
Validates the specified connectionString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConnectionString(
    string connectionString
)
Protected Overrides Sub ValidateConnectionString (
    connectionString As String
)
abstract ValidateConnectionString :
        connectionString : string -> unit
override ValidateConnectionString :
        connectionString : string -> unit
function ValidateConnectionString(connectionString);
protected:
virtual void ValidateConnectionString(
    String^ connectionString
) override

Parameters

connectionString
Type: SystemString
Connection string to be validated.
Exceptions
Exception | Condition
ArgumentException | Server property is missing.
FormatException | Server property is invalid.
ArgumentOutOfRangeException | Server port value is not between PortRangeLow and PortRangeHigh.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient Properties

Grid Solutions Framework TcpClient Properties

The TcpClient type exposes the following members.

Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the Socket object for the TcpClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the current Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | NetworkCredential | Gets or sets network credential that is used when IntegratedSecurity is set to true.
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the TcpClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ClientBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.AllowDualStackSocket Property

Grid Solutions Framework TcpClientAllowDualStackSocket Property
Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool AllowDualStackSocket { get; set; }
<DefaultValueAttribute(true)>
Public Property AllowDualStackSocket As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member AllowDualStackSocket : bool with get, set

function get_AllowDualStackSocket();
function set_AllowDualStackSocket(value);
public:
[DefaultValueAttribute(true)]
property bool AllowDualStackSocket {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.Client Property

Grid Solutions Framework TcpClientClient Property
Gets the Socket object for the TcpClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Socket Client { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Client As Socket
    Get
[<BrowsableAttribute(false)>]
member Client : Socket with get

function get_Client();

public:
[BrowsableAttribute(false)]
property Socket^ Client {
    Socket^ get ();
}

Property Value

Type: Socket
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.IgnoreInvalidCredentials Property

Grid Solutions Framework TcpClientIgnoreInvalidCredentials Property
Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IgnoreInvalidCredentials { get; set; }
<DefaultValueAttribute(false)>
Public Property IgnoreInvalidCredentials As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IgnoreInvalidCredentials : bool with get, set

function get_IgnoreInvalidCredentials();
function set_IgnoreInvalidCredentials(value);
public:
[DefaultValueAttribute(false)]
property bool IgnoreInvalidCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This property should only be set to true if there is an alternative by which to authenticate the client when integrated security fails.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.IntegratedSecurity Property

Grid Solutions Framework TcpClientIntegratedSecurity Property
Gets or sets a boolean value that indicates whether the current Windows account credentials are used for authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IntegratedSecurity { get; set; }
<DefaultValueAttribute(false)>
Public Property IntegratedSecurity As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IntegratedSecurity : bool with get, set

function get_IntegratedSecurity();
function set_IntegratedSecurity(value);
public:
[DefaultValueAttribute(false)]
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This option is ignored under Mono deployments.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.MaxSendQueueSize Property

Grid Solutions Framework TcpClientMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.NetworkCredential Property

Grid Solutions Framework TcpClientNetworkCredential Property
Gets or sets network credential that is used when IntegratedSecurity is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NetworkCredential NetworkCredential { get; set; }
Public Property NetworkCredential As NetworkCredential
    Get
    Set
member NetworkCredential : NetworkCredential with get, set

function get_NetworkCredential();
function set_NetworkCredential(value);
public:
property NetworkCredential^ NetworkCredential {
    NetworkCredential^ get ();
    void set (NetworkCredential^ value);
}

Property Value

Type: NetworkCredential
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.PayloadAware Property

Grid Solutions Framework TcpClientPayloadAware Property
Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PayloadAware { get; set; }
<DefaultValueAttribute(false)>
Public Property PayloadAware As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member PayloadAware : bool with get, set

function get_PayloadAware();
function set_PayloadAware(value);
public:
[DefaultValueAttribute(false)]
property bool PayloadAware {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.PayloadMarker Property

Grid Solutions Framework TcpClientPayloadMarker Property
Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public byte[] PayloadMarker { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property PayloadMarker As Byte()
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member PayloadMarker : byte[] with get, set

function get_PayloadMarker();
function set_PayloadMarker(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property array<unsigned char>^ PayloadMarker {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty buffer.
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.ServerUri Property

Grid Solutions Framework TcpClientServerUri Property
Gets the server URI of the TcpClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override string ServerUri { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ServerUri As String
    Get
[<BrowsableAttribute(false)>]
abstract ServerUri : string with get
[<BrowsableAttribute(false)>]
override ServerUri : string with get
function get_ServerUri();

public:
[BrowsableAttribute(false)]
virtual property String^ ServerUri {
    String^ get () override;
}

Property Value

Type: String

Implements

IClientServerUri
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient.Status Property

Grid Solutions Framework TcpClientStatus Property
Gets the descriptive status of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpClient Events

Grid Solutions Framework TcpClient Events

The TcpClient type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

TcpClient Class
GSF.Communication Namespace


TcpServer Class

Grid Solutions Framework TcpServer Class
Represents a TCP-based communication server.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationServerBase
GSF.CommunicationTcpServer

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TcpServer : ServerBase
Public Class TcpServer
    Inherits ServerBase
type TcpServer =
    class
        inherit ServerBase
    end
GSF.Communication.TcpServer = function();

Type.createClass(
    'GSF.Communication.TcpServer',
    GSF.Communication.ServerBase);
public ref class TcpServer : public ServerBase

The TcpServer type exposes the following members.

Constructors
 | Name | Description
Public method | TcpServer | Initializes a new instance of the TcpServer class.
Public method | TcpServer(IContainer) | Initializes a new instance of the TcpServer class.
Public method | TcpServer(String) | Initializes a new instance of the TcpServer class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Inherited from ServerBase.)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Inherited from ServerBase.)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException(Guid, Exception) | Raises the ReceiveClientDataException event. (Overrides ServerBaseOnReceiveClientDataException(Guid, Exception).)
Protected method | OnReceiveClientDataException(Guid, SocketException) | Raises the ReceiveClientDataException event.
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Overrides ServerBaseOnSendClientDataException(Guid, Exception).)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ServerBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the TcpServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the TcpServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Public method | TryGetClientPrincipal | Gets the WindowsPrincipal object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Top
Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the client Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the TcpServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the server. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Inherited from ServerBase.)
Top
Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
Remarks
The Server socket can be bound to a specified interface on a machine with multiple interfaces by specifying the interface in the ConfigurationString (Example: "Port=8888; Interface=127.0.0.1")
Examples
This example shows how to use the TcpServer component:
Copy
using System;
using GSF;
using GSF.Communication;
using GSF.Security.Cryptography;
using GSF.IO.Compression;

class Program
{
    static TcpServer m_server;

    static void Main(string[] args)
    {
        // Initialize the server.
        m_server = new TcpServer("Port=8888");
        m_server.Handshake = false;
        m_server.PayloadAware = false;
        m_server.ReceiveTimeout = -1;
        m_server.Encryption = CipherStrength.None;
        m_server.Compression = CompressionStrength.NoCompression;
        m_server.SecureSession = false;
        m_server.Initialize();
        // Register event handlers.
        m_server.ServerStarted += m_server_ServerStarted;
        m_server.ServerStopped += m_server_ServerStopped;
        m_server.ClientConnected += m_server_ClientConnected;
        m_server.ClientDisconnected += m_server_ClientDisconnected;
        m_server.ReceiveClientDataComplete += m_server_ReceiveClientDataComplete;
        // Start the server.
        m_server.Start();

        // Multicast user input to all connected clients.
        string input;
        while (string.Compare(input = Console.ReadLine(), "Exit", true) != 0)
        {
            m_server.Multicast(input);
        }

        // Stop the server on shutdown.
        m_server.Stop();
    }

    static void m_server_ServerStarted(object sender, EventArgs e)
    {
        Console.WriteLine("Server has been started!");
    }

    static void m_server_ServerStopped(object sender, EventArgs e)
    {
        Console.WriteLine("Server has been stopped!");
    }

    static void m_server_ClientConnected(object sender, EventArgs<Guid> e)
    {
        Console.WriteLine(string.Format("Client connected - {0}.", e.Argument));
    }

    static void m_server_ClientDisconnected(object sender, EventArgs<Guid> e)
    {
        Console.WriteLine(string.Format("Client disconnected - {0}.", e.Argument));
    }

    static void m_server_ReceiveClientDataComplete(object sender, EventArgs<Guid, byte[], int> e)
    {
        Console.WriteLine(string.Format("Received data from {0} - {1}.", e.Argument1, m_server.TextEncoding.GetString(e.Argument2, 0, e.Argument3)));
    }
}
See Also

Reference

GSF.Communication Namespace


TcpServer Constructor

Grid Solutions Framework TcpServer Constructor
Overload List
 | Name | Description
Public method | TcpServer | Initializes a new instance of the TcpServer class.
Public method | TcpServer(IContainer) | Initializes a new instance of the TcpServer class.
Public method | TcpServer(String) | Initializes a new instance of the TcpServer class.
Top
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer Constructor

Grid Solutions Framework TcpServer Constructor
Initializes a new instance of the TcpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TcpServer()
Public Sub New
new : unit -> TcpServer
GSF.Communication.TcpServer = function();
public:
TcpServer()
See Also

Reference

TcpServer Class
TcpServer Overload
GSF.Communication Namespace


TcpServer Constructor (IContainer)

Grid Solutions Framework TcpServer Constructor (IContainer)
Initializes a new instance of the TcpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TcpServer(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> TcpServer
GSF.Communication.TcpServer = function(container);
public:
TcpServer(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the TcpServer.
See Also

Reference

TcpServer Class
TcpServer Overload
GSF.Communication Namespace


TcpServer Constructor (String)

Grid Solutions Framework TcpServer Constructor (String)
Initializes a new instance of the TcpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TcpServer(
    string configString
)
Public Sub New (
    configString As String
)
new :
        configString : string -> TcpServer
GSF.Communication.TcpServer = function(configString);
public:
TcpServer(
    String^ configString
)

Parameters

configString
Type: SystemString
Config string of the TcpServer. See DefaultConfigurationString for format.
See Also

Reference

TcpServer Class
TcpServer Overload
GSF.Communication Namespace


TcpServer Fields

Grid Solutions Framework TcpServer Fields

The TcpServer type exposes the following members.

Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Top
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.DefaultAllowDualStackSocket Field

Grid Solutions Framework TcpServerDefaultAllowDualStackSocket Field
Specifies the default value for the AllowDualStackSocket property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowDualStackSocket
Public Const DefaultAllowDualStackSocket As Boolean
static val mutable DefaultAllowDualStackSocket: bool
var GSF.Communication.TcpServer.DefaultAllowDualStackSocket
public:
literal bool DefaultAllowDualStackSocket

Field Value

Type: Boolean
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.DefaultConfigurationString Field

Grid Solutions Framework TcpServerDefaultConfigurationString Field
Specifies the default value for the ConfigurationString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConfigurationString
Public Const DefaultConfigurationString As String
static val mutable DefaultConfigurationString: string
var GSF.Communication.TcpServer.DefaultConfigurationString
public:
literal String^ DefaultConfigurationString

Field Value

Type: String
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.DefaultIgnoreInvalidCredentials Field

Grid Solutions Framework TcpServerDefaultIgnoreInvalidCredentials Field
Specifies the default value for the IgnoreInvalidCredentials property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIgnoreInvalidCredentials
Public Const DefaultIgnoreInvalidCredentials As Boolean
static val mutable DefaultIgnoreInvalidCredentials: bool
var GSF.Communication.TcpServer.DefaultIgnoreInvalidCredentials
public:
literal bool DefaultIgnoreInvalidCredentials

Field Value

Type: Boolean
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.DefaultIntegratedSecurity Field

Grid Solutions Framework TcpServerDefaultIntegratedSecurity Field
Specifies the default value for the IntegratedSecurity property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIntegratedSecurity
Public Const DefaultIntegratedSecurity As Boolean
static val mutable DefaultIntegratedSecurity: bool
var GSF.Communication.TcpServer.DefaultIntegratedSecurity
public:
literal bool DefaultIntegratedSecurity

Field Value

Type: Boolean
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.DefaultMaxSendQueueSize Field

Grid Solutions Framework TcpServerDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.TcpServer.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.DefaultPayloadAware Field

Grid Solutions Framework TcpServerDefaultPayloadAware Field
Specifies the default value for the PayloadAware property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPayloadAware
Public Const DefaultPayloadAware As Boolean
static val mutable DefaultPayloadAware: bool
var GSF.Communication.TcpServer.DefaultPayloadAware
public:
literal bool DefaultPayloadAware

Field Value

Type: Boolean
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer Methods

Grid Solutions Framework TcpServer Methods

The TcpServer type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Inherited from ServerBase.)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Inherited from ServerBase.)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException(Guid, Exception) | Raises the ReceiveClientDataException event. (Overrides ServerBaseOnReceiveClientDataException(Guid, Exception).)
Protected method | OnReceiveClientDataException(Guid, SocketException) | Raises the ReceiveClientDataException event.
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Overrides ServerBaseOnSendClientDataException(Guid, Exception).)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ServerBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the TcpServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the TcpServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Public method | TryGetClientPrincipal | Gets the WindowsPrincipal object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.DisconnectOne Method

Grid Solutions Framework TcpServerDisconnectOne Method
Disconnects the specified connected client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void DisconnectOne(
    Guid clientID
)
Public Overrides Sub DisconnectOne (
    clientID As Guid
)
abstract DisconnectOne :
        clientID : Guid -> unit
override DisconnectOne :
        clientID : Guid -> unit
function DisconnectOne(clientID);
public:
virtual void DisconnectOne(
    Guid clientID
) override

Parameters

clientID
Type: SystemGuid
ID of the client to be disconnected.

Implements

IServerDisconnectOne(Guid)
Exceptions
Exception | Condition
InvalidOperationException | Client does not exist for the specified clientID.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.LoadSettings Method

Grid Solutions Framework TcpServerLoadSettings Method
Loads saved TcpServer settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.OnReceiveClientDataException Method

Grid Solutions Framework TcpServerOnReceiveClientDataException Method
Overload List
 | Name | Description
Protected method | OnReceiveClientDataException(Guid, Exception) | Raises the ReceiveClientDataException event. (Overrides ServerBaseOnReceiveClientDataException(Guid, Exception).)
Protected method | OnReceiveClientDataException(Guid, SocketException) | Raises the ReceiveClientDataException event.
Top
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.OnReceiveClientDataException Method (Guid, Exception)

Grid Solutions Framework TcpServerOnReceiveClientDataException Method (Guid, Exception)
Raises the ReceiveClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceiveClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overrides Sub OnReceiveClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnReceiveClientDataException(clientID, ex);
protected:
virtual void OnReceiveClientDataException(
    Guid clientID,
    Exception^ ex
) override

Parameters

clientID
Type: SystemGuid
ID of client to send to ReceiveClientDataException event.
ex
Type: SystemException
Exception to send to ReceiveClientDataException event.
See Also

Reference

TcpServer Class
OnReceiveClientDataException Overload
GSF.Communication Namespace


TcpServer.OnReceiveClientDataException Method (Guid, SocketException)

Grid Solutions Framework TcpServerOnReceiveClientDataException Method (Guid, SocketException)
Raises the ReceiveClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceiveClientDataException(
    Guid clientID,
    SocketException ex
)
Protected Overridable Sub OnReceiveClientDataException (
    clientID As Guid,
    ex As SocketException
)
abstract OnReceiveClientDataException :
        clientID : Guid *
        ex : SocketException -> unit
override OnReceiveClientDataException :
        clientID : Guid *
        ex : SocketException -> unit
function OnReceiveClientDataException(clientID, ex);
protected:
virtual void OnReceiveClientDataException(
    Guid clientID,
    SocketException^ ex
)

Parameters

clientID
Type: SystemGuid
ID of client to send to ReceiveClientDataException event.
ex
Type: System.Net.SocketsSocketException
Exception to send to ReceiveClientDataException event.
See Also

Reference

TcpServer Class
OnReceiveClientDataException Overload
GSF.Communication Namespace


TcpServer.OnSendClientDataException Method

Grid Solutions Framework TcpServerOnSendClientDataException Method
Raises the SendClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnSendClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overrides Sub OnSendClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnSendClientDataException(clientID, ex);
protected:
virtual void OnSendClientDataException(
    Guid clientID,
    Exception^ ex
) override

Parameters

clientID
Type: SystemGuid
ID of client to send to SendClientDataException event.
ex
Type: SystemException
Exception to send to SendClientDataException event.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.Read Method

Grid Solutions Framework TcpServerRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    Guid clientID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    clientID As Guid,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(clientID, buffer, startIndex, length);
public:
virtual int Read(
    Guid clientID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client from which data buffer should be read.
buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IServerRead(Guid, Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read -or- Specified clientID does not exist, cannot read buffer.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveClientData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.SaveSettings Method

Grid Solutions Framework TcpServerSaveSettings Method
Saves TcpServer settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.SendDataToAsync Method

Grid Solutions Framework TcpServerSendDataToAsync Method
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataToAsync(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataToAsync (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataToAsync(clientID, data, offset, length);
protected:
virtual WaitHandle^ SendDataToAsync(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.Start Method

Grid Solutions Framework TcpServerStart Method
Starts the TcpServer synchronously and begins accepting client connections asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IServerStart
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to Start the TcpServer when it is running.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.Stop Method

Grid Solutions Framework TcpServerStop Method
Stops the TcpServer synchronously and disconnects all connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Stop()
Public Overrides Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() override

Implements

IServerStop
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.TryGetClient Method

Grid Solutions Framework TcpServerTryGetClient Method
Gets the TransportProviderT object associated with the specified client ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetClient(
    Guid clientID,
    out TransportProvider<Socket> tcpClient
)
Public Function TryGetClient (
    clientID As Guid,
    <OutAttribute> ByRef tcpClient As TransportProvider(Of Socket)
) As Boolean
member TryGetClient :
        clientID : Guid *
        tcpClient : TransportProvider<Socket> byref -> bool

function TryGetClient(clientID, tcpClient);
public:
bool TryGetClient(
    Guid clientID,
    [OutAttribute] TransportProvider<Socket^>^% tcpClient
)

Parameters

clientID
Type: SystemGuid
ID of the client.
tcpClient
Type: GSF.CommunicationTransportProvider Socket
The TCP client.

Return Value

Type: Boolean
A TransportProviderT object.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.TryGetClientPrincipal Method

Grid Solutions Framework TcpServerTryGetClientPrincipal Method
Gets the WindowsPrincipal object associated with the specified client ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetClientPrincipal(
    Guid clientID,
    out WindowsPrincipal clientPrincipal
)
Public Function TryGetClientPrincipal (
    clientID As Guid,
    <OutAttribute> ByRef clientPrincipal As WindowsPrincipal
) As Boolean
member TryGetClientPrincipal :
        clientID : Guid *
        clientPrincipal : WindowsPrincipal byref -> bool

function TryGetClientPrincipal(clientID, clientPrincipal);
public:
bool TryGetClientPrincipal(
    Guid clientID,
    [OutAttribute] WindowsPrincipal^% clientPrincipal
)

Parameters

clientID
Type: SystemGuid
ID of the client.
clientPrincipal
Type: System.Security.PrincipalWindowsPrincipal
The principal of the client.

Return Value

Type: Boolean
A WindowsPrincipal object.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.ValidateConfigurationString Method

Grid Solutions Framework TcpServerValidateConfigurationString Method
Validates the specified configurationString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConfigurationString(
    string configurationString
)
Protected Overrides Sub ValidateConfigurationString (
    configurationString As String
)
abstract ValidateConfigurationString :
        configurationString : string -> unit
override ValidateConfigurationString :
        configurationString : string -> unit
function ValidateConfigurationString(configurationString);
protected:
virtual void ValidateConfigurationString(
    String^ configurationString
) override

Parameters

configurationString
Type: SystemString
Configuration string to be validated.
Exceptions
Exception | Condition
ArgumentException | Port property is missing.
ArgumentOutOfRangeException | Port property value is not between PortRangeLow and PortRangeHigh.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer Properties

Grid Solutions Framework TcpServer Properties

The TcpServer type exposes the following members.

Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the client Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the TcpServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the server. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Inherited from ServerBase.)
Top
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.AllowDualStackSocket Property

Grid Solutions Framework TcpServerAllowDualStackSocket Property
Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool AllowDualStackSocket { get; set; }
<DefaultValueAttribute(true)>
Public Property AllowDualStackSocket As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member AllowDualStackSocket : bool with get, set

function get_AllowDualStackSocket();
function set_AllowDualStackSocket(value);
public:
[DefaultValueAttribute(true)]
property bool AllowDualStackSocket {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.IgnoreInvalidCredentials Property

Grid Solutions Framework TcpServerIgnoreInvalidCredentials Property
Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IgnoreInvalidCredentials { get; set; }
<DefaultValueAttribute(false)>
Public Property IgnoreInvalidCredentials As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IgnoreInvalidCredentials : bool with get, set

function get_IgnoreInvalidCredentials();
function set_IgnoreInvalidCredentials(value);
public:
[DefaultValueAttribute(false)]
property bool IgnoreInvalidCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This property should only be set to true if there is an alternative by which to authenticate the client when integrated security fails. When this is set to true, if the client's credentials are invalid, the TryGetClientPrincipal(Guid, WindowsPrincipal) method will return true for that client, but the principal will still be null.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.IntegratedSecurity Property

Grid Solutions Framework TcpServerIntegratedSecurity Property
Gets or sets a boolean value that indicates whether the client Windows account credentials are used for authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IntegratedSecurity { get; set; }
<DefaultValueAttribute(false)>
Public Property IntegratedSecurity As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IntegratedSecurity : bool with get, set

function get_IntegratedSecurity();
function set_IntegratedSecurity(value);
public:
[DefaultValueAttribute(false)]
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This option is ignored under Mono deployments.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.MaxSendQueueSize Property

Grid Solutions Framework TcpServerMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.PayloadAware Property

Grid Solutions Framework TcpServerPayloadAware Property
Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PayloadAware { get; set; }
<DefaultValueAttribute(false)>
Public Property PayloadAware As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member PayloadAware : bool with get, set

function get_PayloadAware();
function set_PayloadAware(value);
public:
[DefaultValueAttribute(false)]
property bool PayloadAware {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.PayloadMarker Property

Grid Solutions Framework TcpServerPayloadMarker Property
Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public byte[] PayloadMarker { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property PayloadMarker As Byte()
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member PayloadMarker : byte[] with get, set

function get_PayloadMarker();
function set_PayloadMarker(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property array<unsigned char>^ PayloadMarker {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty buffer.
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.Server Property

Grid Solutions Framework TcpServerServer Property
Gets the Socket object for the TcpServer.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Socket Server { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Server As Socket
    Get
[<BrowsableAttribute(false)>]
member Server : Socket with get

function get_Server();

public:
[BrowsableAttribute(false)]
property Socket^ Server {
    Socket^ get ();
}

Property Value

Type: Socket
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer.Status Property

Grid Solutions Framework TcpServerStatus Property
Gets the descriptive status of the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TcpServer Events

Grid Solutions Framework TcpServer Events

The TcpServer type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
See Also

Reference

TcpServer Class
GSF.Communication Namespace


TlsClient Class

Grid Solutions Framework TlsClient Class
Represents a TCP-based communication client with SSL authentication and encryption.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
GSF.CommunicationTlsClient

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TlsClient : ClientBase
Public Class TlsClient
    Inherits ClientBase
type TlsClient =
    class
        inherit ClientBase
    end
GSF.Communication.TlsClient = function();

Type.createClass(
    'GSF.Communication.TlsClient',
    GSF.Communication.ClientBase);
public ref class TlsClient : public ClientBase

The TlsClient type exposes the following members.

Constructors
 | Name | Description
Public method | TlsClient | Initializes a new instance of the TlsClient class.
Public method | TlsClient(IContainer) | Initializes a new instance of the TlsClient class.
Public method | TlsClient(String) | Initializes a new instance of the TlsClient class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the TlsClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | When overridden in a derived class, disconnects client from the server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TlsClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TlsClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Inherited from ClientBase.)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException(Exception) | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnReceiveDataException(SocketException) | Raises the ReceiveDataException event.
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TlsClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | When overridden in a derived class, sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | When overridden in a derived class, validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
 | DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
 | DefaultConnectionString | Specifies the default value for the ConnectionString property.
 | DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
 | DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
 | DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
 | DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Public field | DefaultTrustedCertificatesPath | Specifies the default value for the TrustedCertificatesPath property.
Top
Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Certificate | Gets or sets the local certificate selected by the default LocalCertificateSelectionCallback.
Public property | CertificateChecker | Gets or sets the certificate checker used to validate remote certificates.
Public property | CertificateFile | Gets or sets the path to the certificate used for authentication.
Public property | CheckCertificateRevocation | Gets or sets a boolean value that determines whether the certificate revocation list is checked during authentication.
Public property | Client | Gets the Socket object for the TlsClient.
Public property | ClientCertificates | Gets the collection of X509 certificates for this client.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Public property | EnabledSslProtocols | Gets or sets a set of flags which determine the enabled SslProtocols.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the current Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | LocalCertificateSelectionCallback | Gets or sets the callback used to select a local certificate.
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | NetworkCredential | Gets or sets network credential that is used when IntegratedSecurity is set to true.
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | RemoteCertificateValidationCallback | Gets or sets the callback used to verify remote certificates.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the TlsClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Inherited from ClientBase.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Public property | TrustedCertificatesPath | Gets or sets the path to the directory containing the trusted certificates.
Public property | ValidChainFlags | Gets or sets the set of valid chain flags used when validating remote certificates.
Public property | ValidPolicyErrors | Gets or sets the set of valid policy errors when validating remote certificates.
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

GSF.Communication Namespace
GSF.CommunicationTcpClient


TlsClient Constructor

Grid Solutions Framework TlsClient Constructor
Overload List
 | Name | Description
Public method | TlsClient | Initializes a new instance of the TlsClient class.
Public method | TlsClient(IContainer) | Initializes a new instance of the TlsClient class.
Public method | TlsClient(String) | Initializes a new instance of the TlsClient class.
Top
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient Constructor

Grid Solutions Framework TlsClient Constructor
Initializes a new instance of the TlsClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TlsClient()
Public Sub New
new : unit -> TlsClient
GSF.Communication.TlsClient = function();
public:
TlsClient()
See Also

Reference

TlsClient Class
TlsClient Overload
GSF.Communication Namespace


TlsClient Constructor (IContainer)

Grid Solutions Framework TlsClient Constructor (IContainer)
Initializes a new instance of the TlsClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TlsClient(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> TlsClient
GSF.Communication.TlsClient = function(container);
public:
TlsClient(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the TlsClient.
See Also

Reference

TlsClient Class
TlsClient Overload
GSF.Communication Namespace


TlsClient Constructor (String)

Grid Solutions Framework TlsClient Constructor (String)
Initializes a new instance of the TlsClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TlsClient(
    string connectString
)
Public Sub New (
    connectString As String
)
new :
        connectString : string -> TlsClient
GSF.Communication.TlsClient = function(connectString);
public:
TlsClient(
    String^ connectString
)

Parameters

connectString
Type: SystemString
Connect string of the TlsClient. See DefaultConnectionString for format.
See Also

Reference

TlsClient Class
TlsClient Overload
GSF.Communication Namespace


TlsClient Fields

Grid Solutions Framework TlsClient Fields

The TlsClient type exposes the following members.

Fields
 | Name | Description
 | DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
 | DefaultConnectionString | Specifies the default value for the ConnectionString property.
 | DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
 | DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
 | DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
 | DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Public field | DefaultTrustedCertificatesPath | Specifies the default value for the TrustedCertificatesPath property.
Top
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.DefaultAllowDualStackSocket Field

Grid Solutions Framework TlsClientDefaultAllowDualStackSocket Field
Specifies the default value for the AllowDualStackSocket property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowDualStackSocket
Public Const DefaultAllowDualStackSocket As Boolean
static val mutable DefaultAllowDualStackSocket: bool
var GSF.Communication.TlsClient.DefaultAllowDualStackSocket
public:
literal bool DefaultAllowDualStackSocket

Field Value

Type: Boolean
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.DefaultConnectionString Field

Grid Solutions Framework TlsClientDefaultConnectionString Field
Specifies the default value for the ConnectionString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConnectionString
Public Const DefaultConnectionString As String
static val mutable DefaultConnectionString: string
var GSF.Communication.TlsClient.DefaultConnectionString
public:
literal String^ DefaultConnectionString

Field Value

Type: String
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.DefaultIgnoreInvalidCredentials Field

Grid Solutions Framework TlsClientDefaultIgnoreInvalidCredentials Field
Specifies the default value for the IgnoreInvalidCredentials property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIgnoreInvalidCredentials
Public Const DefaultIgnoreInvalidCredentials As Boolean
static val mutable DefaultIgnoreInvalidCredentials: bool
var GSF.Communication.TlsClient.DefaultIgnoreInvalidCredentials
public:
literal bool DefaultIgnoreInvalidCredentials

Field Value

Type: Boolean
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.DefaultIntegratedSecurity Field

Grid Solutions Framework TlsClientDefaultIntegratedSecurity Field
Specifies the default value for the IntegratedSecurity property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIntegratedSecurity
Public Const DefaultIntegratedSecurity As Boolean
static val mutable DefaultIntegratedSecurity: bool
var GSF.Communication.TlsClient.DefaultIntegratedSecurity
public:
literal bool DefaultIntegratedSecurity

Field Value

Type: Boolean
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.DefaultMaxSendQueueSize Field

Grid Solutions Framework TlsClientDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.TlsClient.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.DefaultPayloadAware Field

Grid Solutions Framework TlsClientDefaultPayloadAware Field
Specifies the default value for the PayloadAware property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPayloadAware
Public Const DefaultPayloadAware As Boolean
static val mutable DefaultPayloadAware: bool
var GSF.Communication.TlsClient.DefaultPayloadAware
public:
literal bool DefaultPayloadAware

Field Value

Type: Boolean
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.DefaultTrustedCertificatesPath Field

Grid Solutions Framework TlsClientDefaultTrustedCertificatesPath Field
Specifies the default value for the TrustedCertificatesPath property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public readonly string DefaultTrustedCertificatesPath
Public ReadOnly DefaultTrustedCertificatesPath As String
val DefaultTrustedCertificatesPath: string
var DefaultTrustedCertificatesPath
public:
initonly String^ DefaultTrustedCertificatesPath

Field Value

Type: String
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient Methods

Grid Solutions Framework TlsClient Methods

The TlsClient type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the TlsClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | When overridden in a derived class, disconnects client from the server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TlsClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TlsClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Inherited from ClientBase.)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException(Exception) | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnReceiveDataException(SocketException) | Raises the ReceiveDataException event.
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TlsClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | When overridden in a derived class, sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | When overridden in a derived class, validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.ConnectAsync Method

Grid Solutions Framework TlsClientConnectAsync Method
Connects the TlsClient to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override WaitHandle ConnectAsync()
Public Overrides Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle
override ConnectAsync : unit -> WaitHandle
function ConnectAsync();
public:
virtual WaitHandle^ ConnectAsync() override

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientConnectAsync
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to connect the TlsClient when it is not disconnected.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.Disconnect Method

Grid Solutions Framework TlsClientDisconnect Method
When overridden in a derived class, disconnects client from the server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Disconnect()
Public Overrides Sub Disconnect
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit
function Disconnect();
public:
virtual void Disconnect() override

Implements

IClientDisconnect
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.Dispose Method

Grid Solutions Framework TlsClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TlsClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Top
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.Dispose Method (Boolean)

Grid Solutions Framework TlsClientDispose Method (Boolean)
Releases the unmanaged resources used by the TlsClient and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

TlsClient Class
Dispose Overload
GSF.Communication Namespace


TlsClient.LoadSettings Method

Grid Solutions Framework TlsClientLoadSettings Method
Loads saved TlsClient settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.OnReceiveDataException Method

Grid Solutions Framework TlsClientOnReceiveDataException Method
Overload List
 | Name | Description
Protected method | OnReceiveDataException(Exception) | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnReceiveDataException(SocketException) | Raises the ReceiveDataException event.
Top
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.OnReceiveDataException Method (Exception)

Grid Solutions Framework TlsClientOnReceiveDataException Method (Exception)
Raises the ReceiveDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceiveDataException(
    Exception ex
)
Protected Overrides Sub OnReceiveDataException (
    ex As Exception
)
abstract OnReceiveDataException :
        ex : Exception -> unit
override OnReceiveDataException :
        ex : Exception -> unit
function OnReceiveDataException(ex);
protected:
virtual void OnReceiveDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ReceiveDataException event.
See Also

Reference

TlsClient Class
OnReceiveDataException Overload
GSF.Communication Namespace


TlsClient.OnReceiveDataException Method (SocketException)

Grid Solutions Framework TlsClientOnReceiveDataException Method (SocketException)
Raises the ReceiveDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnReceiveDataException(
    SocketException ex
)
Protected Sub OnReceiveDataException (
    ex As SocketException
)
member OnReceiveDataException :
        ex : SocketException -> unit

function OnReceiveDataException(ex);
protected:
void OnReceiveDataException(
    SocketException^ ex
)

Parameters

ex
Type: System.Net.SocketsSocketException
Exception to send to ReceiveDataException event.
See Also

Reference

TlsClient Class
OnReceiveDataException Overload
GSF.Communication Namespace


TlsClient.OnSendDataException Method

Grid Solutions Framework TlsClientOnSendDataException Method
Raises the SendDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnSendDataException(
    Exception ex
)
Protected Overrides Sub OnSendDataException (
    ex As Exception
)
abstract OnSendDataException :
        ex : Exception -> unit
override OnSendDataException :
        ex : Exception -> unit
function OnSendDataException(ex);
protected:
virtual void OnSendDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to SendDataException event.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.Read Method

Grid Solutions Framework TlsClientRead Method
When overridden in a derived class, reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IClientRead(Byte, Int32, Int32)
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.SaveSettings Method

Grid Solutions Framework TlsClientSaveSettings Method
Saves TlsClient settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.SendDataAsync Method

Grid Solutions Framework TlsClientSendDataAsync Method
When overridden in a derived class, sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataAsync(
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataAsync(data, offset, length);
protected:
virtual WaitHandle^ SendDataAsync(
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.ValidateConnectionString Method

Grid Solutions Framework TlsClientValidateConnectionString Method
When overridden in a derived class, validates the specified connectionString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConnectionString(
    string connectionString
)
Protected Overrides Sub ValidateConnectionString (
    connectionString As String
)
abstract ValidateConnectionString :
        connectionString : string -> unit
override ValidateConnectionString :
        connectionString : string -> unit
function ValidateConnectionString(connectionString);
protected:
virtual void ValidateConnectionString(
    String^ connectionString
) override

Parameters

connectionString
Type: SystemString
The connection string to be validated.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient Properties

Grid Solutions Framework TlsClient Properties

The TlsClient type exposes the following members.

Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Certificate | Gets or sets the local certificate selected by the default LocalCertificateSelectionCallback.
Public property | CertificateChecker | Gets or sets the certificate checker used to validate remote certificates.
Public property | CertificateFile | Gets or sets the path to the certificate used for authentication.
Public property | CheckCertificateRevocation | Gets or sets a boolean value that determines whether the certificate revocation list is checked during authentication.
Public property | Client | Gets the Socket object for the TlsClient.
Public property | ClientCertificates | Gets the collection of X509 certificates for this client.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Public property | EnabledSslProtocols | Gets or sets a set of flags which determine the enabled SslProtocols.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the current Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | LocalCertificateSelectionCallback | Gets or sets the callback used to select a local certificate.
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | NetworkCredential | Gets or sets network credential that is used when IntegratedSecurity is set to true.
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | RemoteCertificateValidationCallback | Gets or sets the callback used to verify remote certificates.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the TlsClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Inherited from ClientBase.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Public property | TrustedCertificatesPath | Gets or sets the path to the directory containing the trusted certificates.
Public property | ValidChainFlags | Gets or sets the set of valid chain flags used when validating remote certificates.
Public property | ValidPolicyErrors | Gets or sets the set of valid policy errors when validating remote certificates.
Top
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.AllowDualStackSocket Property

Grid Solutions Framework TlsClientAllowDualStackSocket Property
Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool AllowDualStackSocket { get; set; }
<DefaultValueAttribute(true)>
Public Property AllowDualStackSocket As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member AllowDualStackSocket : bool with get, set

function get_AllowDualStackSocket();
function set_AllowDualStackSocket(value);
public:
[DefaultValueAttribute(true)]
property bool AllowDualStackSocket {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.Certificate Property

Grid Solutions Framework TlsClientCertificate Property
Gets or sets the local certificate selected by the default LocalCertificateSelectionCallback.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public X509Certificate Certificate { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Certificate As X509Certificate
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member Certificate : X509Certificate with get, set

function get_Certificate();
function set_Certificate(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property X509Certificate^ Certificate {
    X509Certificate^ get ();
    void set (X509Certificate^ value);
}

Property Value

Type: X509Certificate
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.CertificateChecker Property

Grid Solutions Framework TlsClientCertificateChecker Property
Gets or sets the certificate checker used to validate remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ICertificateChecker CertificateChecker { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property CertificateChecker As ICertificateChecker
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member CertificateChecker : ICertificateChecker with get, set

function get_CertificateChecker();
function set_CertificateChecker(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property ICertificateChecker^ CertificateChecker {
    ICertificateChecker^ get ();
    void set (ICertificateChecker^ value);
}

Property Value

Type: ICertificateChecker
Remarks
The certificate checker will only be used to validate certificates if the RemoteCertificateValidationCallback is set to null.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.CertificateFile Property

Grid Solutions Framework TlsClientCertificateFile Property
Gets or sets the path to the certificate used for authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(null)]
public string CertificateFile { get; set; }
<DefaultValueAttribute(Nothing)>
Public Property CertificateFile As String
    Get
    Set
[<DefaultValueAttribute(null)>]
member CertificateFile : string with get, set

function get_CertificateFile();
function set_CertificateFile(value);
public:
[DefaultValueAttribute(nullptr)]
property String^ CertificateFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.CheckCertificateRevocation Property

Grid Solutions Framework TlsClientCheckCertificateRevocation Property
Gets or sets a boolean value that determines whether the certificate revocation list is checked during authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool CheckCertificateRevocation { get; set; }
<DefaultValueAttribute(true)>
Public Property CheckCertificateRevocation As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member CheckCertificateRevocation : bool with get, set

function get_CheckCertificateRevocation();
function set_CheckCertificateRevocation(value);
public:
[DefaultValueAttribute(true)]
property bool CheckCertificateRevocation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.Client Property

Grid Solutions Framework TlsClientClient Property
Gets the Socket object for the TlsClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Socket Client { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Client As Socket
    Get
[<BrowsableAttribute(false)>]
member Client : Socket with get

function get_Client();

public:
[BrowsableAttribute(false)]
property Socket^ Client {
    Socket^ get ();
}

Property Value

Type: Socket
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.ClientCertificates Property

Grid Solutions Framework TlsClientClientCertificates Property
Gets the collection of X509 certificates for this client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public X509CertificateCollection ClientCertificates { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property ClientCertificates As X509CertificateCollection
    Get
[<BrowsableAttribute(false)>]
member ClientCertificates : X509CertificateCollection with get

function get_ClientCertificates();

public:
[BrowsableAttribute(false)]
property X509CertificateCollection^ ClientCertificates {
    X509CertificateCollection^ get ();
}

Property Value

Type: X509CertificateCollection
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.EnabledSslProtocols Property

Grid Solutions Framework TlsClientEnabledSslProtocols Property
Gets or sets a set of flags which determine the enabled SslProtocols.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(SslProtocols.Tls12)]
public SslProtocols EnabledSslProtocols { get; set; }
<DefaultValueAttribute(SslProtocols.Tls12)>
Public Property EnabledSslProtocols As SslProtocols
    Get
    Set
[<DefaultValueAttribute(SslProtocols.Tls12)>]
member EnabledSslProtocols : SslProtocols with get, set

function get_EnabledSslProtocols();
function set_EnabledSslProtocols(value);
public:
[DefaultValueAttribute(SslProtocols::Tls12)]
property SslProtocols EnabledSslProtocols {
    SslProtocols get ();
    void set (SslProtocols value);
}

Property Value

Type: SslProtocols
Exceptions
Exception | Condition
SecurityException | Failed to write event log entry for security warning about use of less secure TLS/SSL protocols.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.IgnoreInvalidCredentials Property

Grid Solutions Framework TlsClientIgnoreInvalidCredentials Property
Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IgnoreInvalidCredentials { get; set; }
<DefaultValueAttribute(false)>
Public Property IgnoreInvalidCredentials As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IgnoreInvalidCredentials : bool with get, set

function get_IgnoreInvalidCredentials();
function set_IgnoreInvalidCredentials(value);
public:
[DefaultValueAttribute(false)]
property bool IgnoreInvalidCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This property should only be set to true if there is an alternative by which to authenticate the client when integrated security fails.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.IntegratedSecurity Property

Grid Solutions Framework TlsClientIntegratedSecurity Property
Gets or sets a boolean value that indicates whether the current Windows account credentials are used for authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IntegratedSecurity { get; set; }
<DefaultValueAttribute(false)>
Public Property IntegratedSecurity As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IntegratedSecurity : bool with get, set

function get_IntegratedSecurity();
function set_IntegratedSecurity(value);
public:
[DefaultValueAttribute(false)]
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This option is ignored under Mono deployments.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.LocalCertificateSelectionCallback Property

Grid Solutions Framework TlsClientLocalCertificateSelectionCallback Property
Gets or sets the callback used to select a local certificate.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public LocalCertificateSelectionCallback LocalCertificateSelectionCallback { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property LocalCertificateSelectionCallback As LocalCertificateSelectionCallback
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member LocalCertificateSelectionCallback : LocalCertificateSelectionCallback with get, set

function get_LocalCertificateSelectionCallback();
function set_LocalCertificateSelectionCallback(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property LocalCertificateSelectionCallback^ LocalCertificateSelectionCallback {
    LocalCertificateSelectionCallback^ get ();
    void set (LocalCertificateSelectionCallback^ value);
}

Property Value

Type: LocalCertificateSelectionCallback
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.MaxSendQueueSize Property

Grid Solutions Framework TlsClientMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.NetworkCredential Property

Grid Solutions Framework TlsClientNetworkCredential Property
Gets or sets network credential that is used when IntegratedSecurity is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public NetworkCredential NetworkCredential { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property NetworkCredential As NetworkCredential
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member NetworkCredential : NetworkCredential with get, set

function get_NetworkCredential();
function set_NetworkCredential(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property NetworkCredential^ NetworkCredential {
    NetworkCredential^ get ();
    void set (NetworkCredential^ value);
}

Property Value

Type: NetworkCredential
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.PayloadAware Property

Grid Solutions Framework TlsClientPayloadAware Property
Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PayloadAware { get; set; }
<DefaultValueAttribute(false)>
Public Property PayloadAware As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member PayloadAware : bool with get, set

function get_PayloadAware();
function set_PayloadAware(value);
public:
[DefaultValueAttribute(false)]
property bool PayloadAware {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.PayloadMarker Property

Grid Solutions Framework TlsClientPayloadMarker Property
Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public byte[] PayloadMarker { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property PayloadMarker As Byte()
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member PayloadMarker : byte[] with get, set

function get_PayloadMarker();
function set_PayloadMarker(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property array<unsigned char>^ PayloadMarker {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty buffer.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.RemoteCertificateValidationCallback Property

Grid Solutions Framework TlsClientRemoteCertificateValidationCallback Property
Gets or sets the callback used to verify remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public RemoteCertificateValidationCallback RemoteCertificateValidationCallback { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property RemoteCertificateValidationCallback As RemoteCertificateValidationCallback
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member RemoteCertificateValidationCallback : RemoteCertificateValidationCallback with get, set

function get_RemoteCertificateValidationCallback();
function set_RemoteCertificateValidationCallback(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property RemoteCertificateValidationCallback^ RemoteCertificateValidationCallback {
    RemoteCertificateValidationCallback^ get ();
    void set (RemoteCertificateValidationCallback^ value);
}

Property Value

Type: RemoteCertificateValidationCallback
Remarks
Setting this property overrides the validation callback in the CertificateChecker.
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.ServerUri Property

Grid Solutions Framework TlsClientServerUri Property
Gets the server URI of the TlsClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override string ServerUri { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ServerUri As String
    Get
[<BrowsableAttribute(false)>]
abstract ServerUri : string with get
[<BrowsableAttribute(false)>]
override ServerUri : string with get
function get_ServerUri();

public:
[BrowsableAttribute(false)]
virtual property String^ ServerUri {
    String^ get () override;
}

Property Value

Type: String

Implements

IClientServerUri
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.TrustedCertificatesPath Property

Grid Solutions Framework TlsClientTrustedCertificatesPath Property
Gets or sets the path to the directory containing the trusted certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("Trusted Certificates")]
public string TrustedCertificatesPath { get; set; }
<DefaultValueAttribute("Trusted Certificates")>
Public Property TrustedCertificatesPath As String
    Get
    Set
[<DefaultValueAttribute("Trusted Certificates")>]
member TrustedCertificatesPath : string with get, set

function get_TrustedCertificatesPath();
function set_TrustedCertificatesPath(value);
public:
[DefaultValueAttribute(L"Trusted Certificates")]
property String^ TrustedCertificatesPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.ValidChainFlags Property

Grid Solutions Framework TlsClientValidChainFlags Property
Gets or sets the set of valid chain flags used when validating remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(X509ChainStatusFlags.NoError)]
public X509ChainStatusFlags ValidChainFlags { get; set; }
<DefaultValueAttribute(X509ChainStatusFlags.NoError)>
Public Property ValidChainFlags As X509ChainStatusFlags
    Get
    Set
[<DefaultValueAttribute(X509ChainStatusFlags.NoError)>]
member ValidChainFlags : X509ChainStatusFlags with get, set

function get_ValidChainFlags();
function set_ValidChainFlags(value);
public:
[DefaultValueAttribute(X509ChainStatusFlags::NoError)]
property X509ChainStatusFlags ValidChainFlags {
    X509ChainStatusFlags get ();
    void set (X509ChainStatusFlags value);
}

Property Value

Type: X509ChainStatusFlags
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient.ValidPolicyErrors Property

Grid Solutions Framework TlsClientValidPolicyErrors Property
Gets or sets the set of valid policy errors when validating remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(SslPolicyErrors.None)]
public SslPolicyErrors ValidPolicyErrors { get; set; }
<DefaultValueAttribute(SslPolicyErrors.None)>
Public Property ValidPolicyErrors As SslPolicyErrors
    Get
    Set
[<DefaultValueAttribute(SslPolicyErrors.None)>]
member ValidPolicyErrors : SslPolicyErrors with get, set

function get_ValidPolicyErrors();
function set_ValidPolicyErrors(value);
public:
[DefaultValueAttribute(SslPolicyErrors::None)]
property SslPolicyErrors ValidPolicyErrors {
    SslPolicyErrors get ();
    void set (SslPolicyErrors value);
}

Property Value

Type: SslPolicyErrors
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsClient Events

Grid Solutions Framework TlsClient Events

The TlsClient type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

TlsClient Class
GSF.Communication Namespace


TlsServer Class

Grid Solutions Framework TlsServer Class
Represents a TCP-based communication server with SSL authentication and encryption.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationServerBase
GSF.CommunicationTlsServer

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TlsServer : ServerBase
Public Class TlsServer
    Inherits ServerBase
type TlsServer =
    class
        inherit ServerBase
    end
GSF.Communication.TlsServer = function();

Type.createClass(
    'GSF.Communication.TlsServer',
    GSF.Communication.ServerBase);
public ref class TlsServer : public ServerBase

The TlsServer type exposes the following members.

Constructors
 | Name | Description
Public method | TlsServer | Initializes a new instance of the TcpServer class.
Public method | TlsServer(IContainer) | Initializes a new instance of the TcpServer class.
Public method | TlsServer(String) | Initializes a new instance of the TcpServer class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Inherited from ServerBase.)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Inherited from ServerBase.)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event. (Inherited from ServerBase.)
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Inherited from ServerBase.)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ServerBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the TcpServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the TcpServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Public method | TryGetClientPrincipal | Gets the WindowsPrincipal object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
 | DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
 | DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
 | DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
 | DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
 | DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
 | DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Public field | DefaultTrustedCertificatesPath | Specifies the default value for the TrustedCertificatesPath property.
Top
Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Certificate | Gets or sets the certificate used to identify this server.
Public property | CertificateChecker | Gets or sets the certificate checker used to validate remote certificates.
Public property | CertificateFile | Gets or sets the path to the certificate used for authentication.
Public property | CheckCertificateRevocation | Gets or sets a boolean value that determines whether the certificate revocation list is checked during authentication.
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Public property | EnabledSslProtocols | Gets or sets a set of flags which determine the enabled SslProtocols.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the client Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | LocalCertificateSelectionCallback | Gets or sets the callback used to select local certificates.
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RemoteCertificateValidationCallback | Gets or sets the callback used to validate remote certificates.
Public property | RequireClientCertificate | Gets or sets a flag that determines whether a client certificate is required during authentication.
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the TcpServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the server. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Inherited from ServerBase.)
Public property | TrustedCertificatesPath | Gets or sets the path to the directory containing the trusted certificates.
Public property | ValidChainFlags | Gets or sets the set of valid chain flags used when validating remote certificates.
Public property | ValidPolicyErrors | Gets or sets the set of valid policy errors when validating remote certificates.
Top
Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
See Also

Reference

GSF.Communication Namespace


TlsServer Constructor

Grid Solutions Framework TlsServer Constructor
Overload List
 | Name | Description
Public method | TlsServer | Initializes a new instance of the TcpServer class.
Public method | TlsServer(IContainer) | Initializes a new instance of the TcpServer class.
Public method | TlsServer(String) | Initializes a new instance of the TcpServer class.
Top
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer Constructor

Grid Solutions Framework TlsServer Constructor
Initializes a new instance of the TcpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TlsServer()
Public Sub New
new : unit -> TlsServer
GSF.Communication.TlsServer = function();
public:
TlsServer()
See Also

Reference

TlsServer Class
TlsServer Overload
GSF.Communication Namespace


TlsServer Constructor (IContainer)

Grid Solutions Framework TlsServer Constructor (IContainer)
Initializes a new instance of the TcpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TlsServer(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> TlsServer
GSF.Communication.TlsServer = function(container);
public:
TlsServer(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the TcpServer.
See Also

Reference

TlsServer Class
TlsServer Overload
GSF.Communication Namespace


TlsServer Constructor (String)

Grid Solutions Framework TlsServer Constructor (String)
Initializes a new instance of the TcpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TlsServer(
    string configString
)
Public Sub New (
    configString As String
)
new :
        configString : string -> TlsServer
GSF.Communication.TlsServer = function(configString);
public:
TlsServer(
    String^ configString
)

Parameters

configString
Type: SystemString
Config string of the TcpServer. See DefaultConfigurationString for format.
See Also

Reference

TlsServer Class
TlsServer Overload
GSF.Communication Namespace


TlsServer Fields

Grid Solutions Framework TlsServer Fields

The TlsServer type exposes the following members.

Fields
 | Name | Description
 | DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
 | DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
 | DefaultIgnoreInvalidCredentials | Specifies the default value for the IgnoreInvalidCredentials property.
 | DefaultIntegratedSecurity | Specifies the default value for the IntegratedSecurity property.
 | DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
 | DefaultPayloadAware | Specifies the default value for the PayloadAware property.
Public field | DefaultTrustedCertificatesPath | Specifies the default value for the TrustedCertificatesPath property.
Top
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DefaultAllowDualStackSocket Field

Grid Solutions Framework TlsServerDefaultAllowDualStackSocket Field
Specifies the default value for the AllowDualStackSocket property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowDualStackSocket
Public Const DefaultAllowDualStackSocket As Boolean
static val mutable DefaultAllowDualStackSocket: bool
var GSF.Communication.TlsServer.DefaultAllowDualStackSocket
public:
literal bool DefaultAllowDualStackSocket

Field Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DefaultConfigurationString Field

Grid Solutions Framework TlsServerDefaultConfigurationString Field
Specifies the default value for the ConfigurationString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConfigurationString
Public Const DefaultConfigurationString As String
static val mutable DefaultConfigurationString: string
var GSF.Communication.TlsServer.DefaultConfigurationString
public:
literal String^ DefaultConfigurationString

Field Value

Type: String
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DefaultIgnoreInvalidCredentials Field

Grid Solutions Framework TlsServerDefaultIgnoreInvalidCredentials Field
Specifies the default value for the IgnoreInvalidCredentials property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIgnoreInvalidCredentials
Public Const DefaultIgnoreInvalidCredentials As Boolean
static val mutable DefaultIgnoreInvalidCredentials: bool
var GSF.Communication.TlsServer.DefaultIgnoreInvalidCredentials
public:
literal bool DefaultIgnoreInvalidCredentials

Field Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DefaultIntegratedSecurity Field

Grid Solutions Framework TlsServerDefaultIntegratedSecurity Field
Specifies the default value for the IntegratedSecurity property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIntegratedSecurity
Public Const DefaultIntegratedSecurity As Boolean
static val mutable DefaultIntegratedSecurity: bool
var GSF.Communication.TlsServer.DefaultIntegratedSecurity
public:
literal bool DefaultIntegratedSecurity

Field Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DefaultMaxSendQueueSize Field

Grid Solutions Framework TlsServerDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.TlsServer.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DefaultPayloadAware Field

Grid Solutions Framework TlsServerDefaultPayloadAware Field
Specifies the default value for the PayloadAware property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPayloadAware
Public Const DefaultPayloadAware As Boolean
static val mutable DefaultPayloadAware: bool
var GSF.Communication.TlsServer.DefaultPayloadAware
public:
literal bool DefaultPayloadAware

Field Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DefaultTrustedCertificatesPath Field

Grid Solutions Framework TlsServerDefaultTrustedCertificatesPath Field
Specifies the default value for the TrustedCertificatesPath property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public readonly string DefaultTrustedCertificatesPath
Public ReadOnly DefaultTrustedCertificatesPath As String
val DefaultTrustedCertificatesPath: string
var DefaultTrustedCertificatesPath
public:
initonly String^ DefaultTrustedCertificatesPath

Field Value

Type: String
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer Methods

Grid Solutions Framework TlsServer Methods

The TlsServer type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Inherited from ServerBase.)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Inherited from ServerBase.)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event. (Inherited from ServerBase.)
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Inherited from ServerBase.)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ServerBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the TcpServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the TcpServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Public method | TryGetClientPrincipal | Gets the WindowsPrincipal object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.DisconnectOne Method

Grid Solutions Framework TlsServerDisconnectOne Method
Disconnects the specified connected client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void DisconnectOne(
    Guid clientID
)
Public Overrides Sub DisconnectOne (
    clientID As Guid
)
abstract DisconnectOne :
        clientID : Guid -> unit
override DisconnectOne :
        clientID : Guid -> unit
function DisconnectOne(clientID);
public:
virtual void DisconnectOne(
    Guid clientID
) override

Parameters

clientID
Type: SystemGuid
ID of the client to be disconnected.

Implements

IServerDisconnectOne(Guid)
Exceptions
Exception | Condition
InvalidOperationException | Client does not exist for the specified clientID.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.LoadSettings Method

Grid Solutions Framework TlsServerLoadSettings Method
Loads saved TcpServer settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.Read Method

Grid Solutions Framework TlsServerRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    Guid clientID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    clientID As Guid,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(clientID, buffer, startIndex, length);
public:
virtual int Read(
    Guid clientID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client from which data buffer should be read.
buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IServerRead(Guid, Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read -or- Specified clientID does not exist, cannot read buffer.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveClientData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.SaveSettings Method

Grid Solutions Framework TlsServerSaveSettings Method
Saves TcpServer settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.SendDataToAsync Method

Grid Solutions Framework TlsServerSendDataToAsync Method
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataToAsync(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataToAsync (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataToAsync(clientID, data, offset, length);
protected:
virtual WaitHandle^ SendDataToAsync(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.Start Method

Grid Solutions Framework TlsServerStart Method
Starts the TcpServer synchronously and begins accepting client connections asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IServerStart
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to Start the TcpServer when it is running.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.Stop Method

Grid Solutions Framework TlsServerStop Method
Stops the TcpServer synchronously and disconnects all connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Stop()
Public Overrides Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() override

Implements

IServerStop
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.TryGetClient Method

Grid Solutions Framework TlsServerTryGetClient Method
Gets the TransportProviderT object associated with the specified client ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetClient(
    Guid clientID,
    out TransportProvider<TlsServerTlsSocket> tlsClient
)
Public Function TryGetClient (
    clientID As Guid,
    <OutAttribute> ByRef tlsClient As TransportProvider(Of TlsServerTlsSocket)
) As Boolean
member TryGetClient :
        clientID : Guid *
        tlsClient : TransportProvider<TlsServerTlsSocket> byref -> bool

function TryGetClient(clientID, tlsClient);
public:
bool TryGetClient(
    Guid clientID,
    [OutAttribute] TransportProvider<TlsServerTlsSocket^>^% tlsClient
)

Parameters

clientID
Type: SystemGuid
ID of the client.
tlsClient
Type: GSF.CommunicationTransportProvider TlsServerTlsSocket
The TLS client.

Return Value

Type: Boolean
An TransportProviderT object.
Exceptions
Exception | Condition
InvalidOperationException | Client does not exist for the specified clientID.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.TryGetClientPrincipal Method

Grid Solutions Framework TlsServerTryGetClientPrincipal Method
Gets the WindowsPrincipal object associated with the specified client ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetClientPrincipal(
    Guid clientID,
    out WindowsPrincipal clientPrincipal
)
Public Function TryGetClientPrincipal (
    clientID As Guid,
    <OutAttribute> ByRef clientPrincipal As WindowsPrincipal
) As Boolean
member TryGetClientPrincipal :
        clientID : Guid *
        clientPrincipal : WindowsPrincipal byref -> bool

function TryGetClientPrincipal(clientID, clientPrincipal);
public:
bool TryGetClientPrincipal(
    Guid clientID,
    [OutAttribute] WindowsPrincipal^% clientPrincipal
)

Parameters

clientID
Type: SystemGuid
ID of the client.
clientPrincipal
Type: System.Security.PrincipalWindowsPrincipal
The principal of the client.

Return Value

Type: Boolean
A WindowsPrincipal object.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.ValidateConfigurationString Method

Grid Solutions Framework TlsServerValidateConfigurationString Method
Validates the specified configurationString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConfigurationString(
    string configurationString
)
Protected Overrides Sub ValidateConfigurationString (
    configurationString As String
)
abstract ValidateConfigurationString :
        configurationString : string -> unit
override ValidateConfigurationString :
        configurationString : string -> unit
function ValidateConfigurationString(configurationString);
protected:
virtual void ValidateConfigurationString(
    String^ configurationString
) override

Parameters

configurationString
Type: SystemString
Configuration string to be validated.
Exceptions
Exception | Condition
ArgumentException | Port property is missing.
ArgumentOutOfRangeException | Port property value is not between PortRangeLow and PortRangeHigh.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer Properties

Grid Solutions Framework TlsServer Properties

The TlsServer type exposes the following members.

Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Certificate | Gets or sets the certificate used to identify this server.
Public property | CertificateChecker | Gets or sets the certificate checker used to validate remote certificates.
Public property | CertificateFile | Gets or sets the path to the certificate used for authentication.
Public property | CheckCertificateRevocation | Gets or sets a boolean value that determines whether the certificate revocation list is checked during authentication.
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Public property | EnabledSslProtocols | Gets or sets a set of flags which determine the enabled SslProtocols.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IgnoreInvalidCredentials | Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IntegratedSecurity | Gets or sets a boolean value that indicates whether the client Windows account credentials are used for authentication.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | LocalCertificateSelectionCallback | Gets or sets the callback used to select local certificates.
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PayloadAware | Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.
Public property | PayloadMarker | Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RemoteCertificateValidationCallback | Gets or sets the callback used to validate remote certificates.
Public property | RequireClientCertificate | Gets or sets a flag that determines whether a client certificate is required during authentication.
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the TcpServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the server. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Inherited from ServerBase.)
Public property | TrustedCertificatesPath | Gets or sets the path to the directory containing the trusted certificates.
Public property | ValidChainFlags | Gets or sets the set of valid chain flags used when validating remote certificates.
Public property | ValidPolicyErrors | Gets or sets the set of valid policy errors when validating remote certificates.
Top
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.AllowDualStackSocket Property

Grid Solutions Framework TlsServerAllowDualStackSocket Property
Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool AllowDualStackSocket { get; set; }
<DefaultValueAttribute(true)>
Public Property AllowDualStackSocket As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member AllowDualStackSocket : bool with get, set

function get_AllowDualStackSocket();
function set_AllowDualStackSocket(value);
public:
[DefaultValueAttribute(true)]
property bool AllowDualStackSocket {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.Certificate Property

Grid Solutions Framework TlsServerCertificate Property
Gets or sets the certificate used to identify this server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public X509Certificate Certificate { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property Certificate As X509Certificate
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member Certificate : X509Certificate with get, set

function get_Certificate();
function set_Certificate(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property X509Certificate^ Certificate {
    X509Certificate^ get ();
    void set (X509Certificate^ value);
}

Property Value

Type: X509Certificate
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.CertificateChecker Property

Grid Solutions Framework TlsServerCertificateChecker Property
Gets or sets the certificate checker used to validate remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public ICertificateChecker CertificateChecker { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property CertificateChecker As ICertificateChecker
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member CertificateChecker : ICertificateChecker with get, set

function get_CertificateChecker();
function set_CertificateChecker(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property ICertificateChecker^ CertificateChecker {
    ICertificateChecker^ get ();
    void set (ICertificateChecker^ value);
}

Property Value

Type: ICertificateChecker
Remarks
The certificate checker will only be used to validate certificates if the RemoteCertificateValidationCallback is set to null.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.CertificateFile Property

Grid Solutions Framework TlsServerCertificateFile Property
Gets or sets the path to the certificate used for authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(null)]
public string CertificateFile { get; set; }
<DefaultValueAttribute(Nothing)>
Public Property CertificateFile As String
    Get
    Set
[<DefaultValueAttribute(null)>]
member CertificateFile : string with get, set

function get_CertificateFile();
function set_CertificateFile(value);
public:
[DefaultValueAttribute(nullptr)]
property String^ CertificateFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.CheckCertificateRevocation Property

Grid Solutions Framework TlsServerCheckCertificateRevocation Property
Gets or sets a boolean value that determines whether the certificate revocation list is checked during authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool CheckCertificateRevocation { get; set; }
<DefaultValueAttribute(true)>
Public Property CheckCertificateRevocation As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member CheckCertificateRevocation : bool with get, set

function get_CheckCertificateRevocation();
function set_CheckCertificateRevocation(value);
public:
[DefaultValueAttribute(true)]
property bool CheckCertificateRevocation {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.EnabledSslProtocols Property

Grid Solutions Framework TlsServerEnabledSslProtocols Property
Gets or sets a set of flags which determine the enabled SslProtocols.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(SslProtocols.Tls12)]
public SslProtocols EnabledSslProtocols { get; set; }
<DefaultValueAttribute(SslProtocols.Tls12)>
Public Property EnabledSslProtocols As SslProtocols
    Get
    Set
[<DefaultValueAttribute(SslProtocols.Tls12)>]
member EnabledSslProtocols : SslProtocols with get, set

function get_EnabledSslProtocols();
function set_EnabledSslProtocols(value);
public:
[DefaultValueAttribute(SslProtocols::Tls12)]
property SslProtocols EnabledSslProtocols {
    SslProtocols get ();
    void set (SslProtocols value);
}

Property Value

Type: SslProtocols
Exceptions
Exception | Condition
SecurityException | Failed to write event log entry for security warning about use of less secure TLS/SSL protocols.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.IgnoreInvalidCredentials Property

Grid Solutions Framework TlsServerIgnoreInvalidCredentials Property
Gets or sets a boolean value that indicates whether the server should ignore errors when the client's credentials are invalid.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IgnoreInvalidCredentials { get; set; }
<DefaultValueAttribute(false)>
Public Property IgnoreInvalidCredentials As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IgnoreInvalidCredentials : bool with get, set

function get_IgnoreInvalidCredentials();
function set_IgnoreInvalidCredentials(value);
public:
[DefaultValueAttribute(false)]
property bool IgnoreInvalidCredentials {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This property should only be set to true if there is an alternative by which to authenticate the client when integrated security fails. When this is set to true, if the client's credentials are invalid, the TryGetClientPrincipal(Guid, WindowsPrincipal) method will return true for that client, but the principal will still be null.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.IntegratedSecurity Property

Grid Solutions Framework TlsServerIntegratedSecurity Property
Gets or sets a boolean value that indicates whether the client Windows account credentials are used for authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IntegratedSecurity { get; set; }
<DefaultValueAttribute(false)>
Public Property IntegratedSecurity As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IntegratedSecurity : bool with get, set

function get_IntegratedSecurity();
function set_IntegratedSecurity(value);
public:
[DefaultValueAttribute(false)]
property bool IntegratedSecurity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This option is ignored under Mono deployments.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.LocalCertificateSelectionCallback Property

Grid Solutions Framework TlsServerLocalCertificateSelectionCallback Property
Gets or sets the callback used to select local certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public LocalCertificateSelectionCallback LocalCertificateSelectionCallback { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property LocalCertificateSelectionCallback As LocalCertificateSelectionCallback
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member LocalCertificateSelectionCallback : LocalCertificateSelectionCallback with get, set

function get_LocalCertificateSelectionCallback();
function set_LocalCertificateSelectionCallback(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property LocalCertificateSelectionCallback^ LocalCertificateSelectionCallback {
    LocalCertificateSelectionCallback^ get ();
    void set (LocalCertificateSelectionCallback^ value);
}

Property Value

Type: LocalCertificateSelectionCallback
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.MaxSendQueueSize Property

Grid Solutions Framework TlsServerMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.PayloadAware Property

Grid Solutions Framework TlsServerPayloadAware Property
Gets or sets a boolean value that indicates whether the payload boundaries are to be preserved during transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PayloadAware { get; set; }
<DefaultValueAttribute(false)>
Public Property PayloadAware As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member PayloadAware : bool with get, set

function get_PayloadAware();
function set_PayloadAware(value);
public:
[DefaultValueAttribute(false)]
property bool PayloadAware {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.PayloadMarker Property

Grid Solutions Framework TlsServerPayloadMarker Property
Gets or sets the byte sequence used to mark the beginning of a payload in a PayloadAware transmission.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public byte[] PayloadMarker { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property PayloadMarker As Byte()
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member PayloadMarker : byte[] with get, set

function get_PayloadMarker();
function set_PayloadMarker(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property array<unsigned char>^ PayloadMarker {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty buffer.
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.RemoteCertificateValidationCallback Property

Grid Solutions Framework TlsServerRemoteCertificateValidationCallback Property
Gets or sets the callback used to validate remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public RemoteCertificateValidationCallback RemoteCertificateValidationCallback { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property RemoteCertificateValidationCallback As RemoteCertificateValidationCallback
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member RemoteCertificateValidationCallback : RemoteCertificateValidationCallback with get, set

function get_RemoteCertificateValidationCallback();
function set_RemoteCertificateValidationCallback(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property RemoteCertificateValidationCallback^ RemoteCertificateValidationCallback {
    RemoteCertificateValidationCallback^ get ();
    void set (RemoteCertificateValidationCallback^ value);
}

Property Value

Type: RemoteCertificateValidationCallback
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.RequireClientCertificate Property

Grid Solutions Framework TlsServerRequireClientCertificate Property
Gets or sets a flag that determines whether a client certificate is required during authentication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool RequireClientCertificate { get; set; }
<DefaultValueAttribute(false)>
Public Property RequireClientCertificate As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member RequireClientCertificate : bool with get, set

function get_RequireClientCertificate();
function set_RequireClientCertificate(value);
public:
[DefaultValueAttribute(false)]
property bool RequireClientCertificate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.Server Property

Grid Solutions Framework TlsServerServer Property
Gets the Socket object for the TcpServer.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Socket Server { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Server As Socket
    Get
[<BrowsableAttribute(false)>]
member Server : Socket with get

function get_Server();

public:
[BrowsableAttribute(false)]
property Socket^ Server {
    Socket^ get ();
}

Property Value

Type: Socket
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.Status Property

Grid Solutions Framework TlsServerStatus Property
Gets the descriptive status of the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.TrustedCertificatesPath Property

Grid Solutions Framework TlsServerTrustedCertificatesPath Property
Gets or sets the path to the directory containing the trusted certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("Trusted Certificates")]
public string TrustedCertificatesPath { get; set; }
<DefaultValueAttribute("Trusted Certificates")>
Public Property TrustedCertificatesPath As String
    Get
    Set
[<DefaultValueAttribute("Trusted Certificates")>]
member TrustedCertificatesPath : string with get, set

function get_TrustedCertificatesPath();
function set_TrustedCertificatesPath(value);
public:
[DefaultValueAttribute(L"Trusted Certificates")]
property String^ TrustedCertificatesPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.ValidChainFlags Property

Grid Solutions Framework TlsServerValidChainFlags Property
Gets or sets the set of valid chain flags used when validating remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(X509ChainStatusFlags.NoError)]
public X509ChainStatusFlags ValidChainFlags { get; set; }
<DefaultValueAttribute(X509ChainStatusFlags.NoError)>
Public Property ValidChainFlags As X509ChainStatusFlags
    Get
    Set
[<DefaultValueAttribute(X509ChainStatusFlags.NoError)>]
member ValidChainFlags : X509ChainStatusFlags with get, set

function get_ValidChainFlags();
function set_ValidChainFlags(value);
public:
[DefaultValueAttribute(X509ChainStatusFlags::NoError)]
property X509ChainStatusFlags ValidChainFlags {
    X509ChainStatusFlags get ();
    void set (X509ChainStatusFlags value);
}

Property Value

Type: X509ChainStatusFlags
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.ValidPolicyErrors Property

Grid Solutions Framework TlsServerValidPolicyErrors Property
Gets or sets the set of valid policy errors when validating remote certificates.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(SslPolicyErrors.None)]
public SslPolicyErrors ValidPolicyErrors { get; set; }
<DefaultValueAttribute(SslPolicyErrors.None)>
Public Property ValidPolicyErrors As SslPolicyErrors
    Get
    Set
[<DefaultValueAttribute(SslPolicyErrors.None)>]
member ValidPolicyErrors : SslPolicyErrors with get, set

function get_ValidPolicyErrors();
function set_ValidPolicyErrors(value);
public:
[DefaultValueAttribute(SslPolicyErrors::None)]
property SslPolicyErrors ValidPolicyErrors {
    SslPolicyErrors get ();
    void set (SslPolicyErrors value);
}

Property Value

Type: SslPolicyErrors
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer Events

Grid Solutions Framework TlsServer Events

The TlsServer type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
See Also

Reference

TlsServer Class
GSF.Communication Namespace


TlsServer.TlsSocket Class

Grid Solutions Framework TlsServerTlsSocket Class
Represents a socket that has been wrapped in an SslStream for encryption.
Inheritance Hierarchy
SystemObject
GSF.CommunicationTlsServerTlsSocket

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class TlsSocket : IDisposable
Public NotInheritable Class TlsSocket
    Implements IDisposable
[<SealedAttribute>]
type TlsSocket =
    class
        interface IDisposable
    end
GSF.Communication.TlsSocket = function();

Type.createClass(
    'GSF.Communication.TlsSocket',
    null,
    IDisposable);
public ref class TlsSocket sealed : IDisposable

The TlsServerTlsSocket type exposes the following members.

Constructors
 | Name | Description
Public method | TlsServerTlsSocket | Initializes a new instance of the TlsServerTlsSocket class
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Socket | Gets the Socket connected to the remote host.
Public field | SslStream | Gets the stream through which data is passed when sending to or receiving from the remote host.
Top
See Also

Reference

GSF.Communication Namespace


TlsServer.TlsSocket Constructor

Grid Solutions Framework TlsServerTlsSocket Constructor
Initializes a new instance of the TlsServerTlsSocket class

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TlsSocket()
Public Sub New
new : unit -> TlsSocket
GSF.Communication.TlsSocket = function();
public:
TlsSocket()
See Also

Reference

TlsServerTlsSocket Class
GSF.Communication Namespace


TlsSocket Fields

Grid Solutions Framework TlsSocket Fields

The TlsServerTlsSocket type exposes the following members.

Fields
 | Name | Description
Public field | Socket | Gets the Socket connected to the remote host.
Public field | SslStream | Gets the stream through which data is passed when sending to or receiving from the remote host.
Top
See Also

Reference

TlsServerTlsSocket Class
GSF.Communication Namespace


TlsServer.TlsSocket.Socket Field

Grid Solutions Framework TlsServerTlsSocketSocket Field
Gets the Socket connected to the remote host.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Socket Socket
Public Socket As Socket
val mutable Socket: Socket
var Socket
public:
Socket^ Socket

Field Value

Type: Socket
See Also

Reference

TlsServerTlsSocket Class
GSF.Communication Namespace


TlsServer.TlsSocket.SslStream Field

Grid Solutions Framework TlsServerTlsSocketSslStream Field
Gets the stream through which data is passed when sending to or receiving from the remote host.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SslStream SslStream
Public SslStream As SslStream
val mutable SslStream: SslStream
var SslStream
public:
SslStream^ SslStream

Field Value

Type: SslStream
See Also

Reference

TlsServerTlsSocket Class
GSF.Communication Namespace


TlsSocket Methods

Grid Solutions Framework TlsSocket Methods

The TlsServerTlsSocket type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TlsServerTlsSocket Class
GSF.Communication Namespace


TlsServer.TlsSocket.Dispose Method

Grid Solutions Framework TlsServerTlsSocketDispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

TlsServerTlsSocket Class
GSF.Communication Namespace


Transport Class

Grid Solutions Framework Transport Class
Defines helper methods related to IP socket based communications.
Inheritance Hierarchy
SystemObject
GSF.CommunicationTransport

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Transport
Public NotInheritable Class Transport
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Transport =  class end
GSF.Communication.Transport = function();

Type.createClass(
    'GSF.Communication.Transport');
public ref class Transport abstract sealed

The Transport type exposes the following members.

Methods
Name | Description
CreateEndPoint | Creates an IPEndPoint for the specified host name and port number.
CreateSocket | Creates a Socket for the specified port and protocol.
GetDefaultIPStack | Gets the default IP stack for this system.
GetInterfaceIPStack | Derives the desired IPStack from the "interface" setting in the connection string key/value pairs.
IsDestinationReachable | Determines if the specified UDP destination is listening for data.
IsIPv6IP | Determines if the specified ipAddress is an IPv6 IP.
IsLocalAddress | Determines if an IP address (or DNS name) is a local IP address.
IsMulticastIP | Determines if the specified ipAddress is a multicast IP.
IsPortNumberValid | Determines whether the specified port is valid.
Top
Fields
Name | Description
EndpointFormatRegex | Regular expression used to validate the format for an endpoint.
PortRangeHigh | Specifies the highest valid port number for a Socket.
PortRangeLow | Specifies the lowest valid port number for a Socket.
Top
See Also

Reference

GSF.Communication Namespace


Transport Fields

Grid Solutions Framework Transport Fields

The Transport type exposes the following members.

Fields
Name | Description
EndpointFormatRegex | Regular expression used to validate the format for an endpoint.
PortRangeHigh | Specifies the highest valid port number for a Socket.
PortRangeLow | Specifies the lowest valid port number for a Socket.
Top
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.EndpointFormatRegex Field

Grid Solutions Framework TransportEndpointFormatRegex Field
Regular expression used to validate the format for an endpoint.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string EndpointFormatRegex
Public Const EndpointFormatRegex As String
static val mutable EndpointFormatRegex: string
var GSF.Communication.Transport.EndpointFormatRegex
public:
literal String^ EndpointFormatRegex

Field Value

Type: String
Remarks

Matches the following valid input:
- localhost:80
- 127.0.0.1:80
- [::1]:80
- [FEDC:BA98:7654:3210:FEDC:BA98:7654:3210]:80

See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.PortRangeHigh Field

Grid Solutions Framework TransportPortRangeHigh Field
Specifies the highest valid port number for a Socket.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int PortRangeHigh
Public Const PortRangeHigh As Integer
static val mutable PortRangeHigh: int
var GSF.Communication.Transport.PortRangeHigh
public:
literal int PortRangeHigh

Field Value

Type: Int32
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.PortRangeLow Field

Grid Solutions Framework TransportPortRangeLow Field
Specifies the lowest valid port number for a Socket.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int PortRangeLow
Public Const PortRangeLow As Integer
static val mutable PortRangeLow: int
var GSF.Communication.Transport.PortRangeLow
public:
literal int PortRangeLow

Field Value

Type: Int32
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport Methods

Grid Solutions Framework Transport Methods

The Transport type exposes the following members.

Methods
Name | Description
CreateEndPoint | Creates an IPEndPoint for the specified host name and port number.
CreateSocket | Creates a Socket for the specified port and protocol.
GetDefaultIPStack | Gets the default IP stack for this system.
GetInterfaceIPStack | Derives the desired IPStack from the "interface" setting in the connection string key/value pairs.
IsDestinationReachable | Determines if the specified UDP destination is listening for data.
IsIPv6IP | Determines if the specified ipAddress is an IPv6 IP.
IsLocalAddress | Determines if an IP address (or DNS name) is a local IP address.
IsMulticastIP | Determines if the specified ipAddress is a multicast IP.
IsPortNumberValid | Determines whether the specified port is valid.
Top
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.CreateEndPoint Method

Grid Solutions Framework TransportCreateEndPoint Method
Creates an IPEndPoint for the specified host name and port number.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IPEndPoint CreateEndPoint(
    string hostNameOrAddress,
    int port,
    IPStack stack
)
Public Shared Function CreateEndPoint (
    hostNameOrAddress As String,
    port As Integer,
    stack As IPStack
) As IPEndPoint
static member CreateEndPoint :
        hostNameOrAddress : string *
        port : int *
        stack : IPStack -> IPEndPoint

GSF.Communication.Transport.CreateEndPoint = function(hostNameOrAddress, port, stack);
public:
static IPEndPoint^ CreateEndPoint(
    String^ hostNameOrAddress,
    int port,
    IPStack stack
)

Parameters

hostNameOrAddress
Type: SystemString
The host name or IP address to resolve.
port
Type: SystemInt32
The port number to be associated with the address.
stack
Type: GSF.CommunicationIPStack
Desired IP stack to use.

Return Value

Type: IPEndPoint
An IPEndPoint object.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.CreateSocket Method

Grid Solutions Framework TransportCreateSocket Method
Creates a Socket for the specified port and protocol.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Socket CreateSocket(
    string address,
    int port,
    ProtocolType protocol,
    IPStack stack,
    bool allowDualStackSocket = true
)
Public Shared Function CreateSocket (
    address As String,
    port As Integer,
    protocol As ProtocolType,
    stack As IPStack,
    Optional allowDualStackSocket As Boolean = true
) As Socket
static member CreateSocket :
        address : string *
        port : int *
        protocol : ProtocolType *
        stack : IPStack *
        ?allowDualStackSocket : bool
(* Defaults:
        let _allowDualStackSocket = defaultArg allowDualStackSocket true
*)
-> Socket

GSF.Communication.Transport.CreateSocket = function(address, port, protocol, stack, allowDualStackSocket);
public:
static Socket^ CreateSocket(
    String^ address,
    int port,
    ProtocolType protocol,
    IPStack stack,
    bool allowDualStackSocket = true
)

Parameters

address
Type: SystemString
The local address where the Socket will be bound.
port
Type: SystemInt32
The port number at which the Socket will be bound.
protocol
Type: System.Net.SocketsProtocolType
One of the ProtocolType values.
stack
Type: GSF.CommunicationIPStack
Desired IP stack to use.
allowDualStackSocket (Optional)
Type: SystemBoolean
Determines if dual-mode socket is allowed when endpoint address is IPv6.

Return Value

Type: Socket
An Socket object.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.GetDefaultIPStack Method

Grid Solutions Framework TransportGetDefaultIPStack Method
Gets the default IP stack for this system.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IPStack GetDefaultIPStack()
Public Shared Function GetDefaultIPStack As IPStack
static member GetDefaultIPStack : unit -> IPStack

GSF.Communication.Transport.GetDefaultIPStack = function();
public:
static IPStack GetDefaultIPStack()

Return Value

Type: IPStack
System's assumed default IP stack.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.GetInterfaceIPStack Method

Grid Solutions Framework TransportGetInterfaceIPStack Method
Derives the desired IPStack from the "interface" setting in the connection string key/value pairs.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IPStack GetInterfaceIPStack(
    Dictionary<string, string> connectionStringEntries
)
Public Shared Function GetInterfaceIPStack (
    connectionStringEntries As Dictionary(Of String, String)
) As IPStack
static member GetInterfaceIPStack :
        connectionStringEntries : Dictionary<string, string> -> IPStack

GSF.Communication.Transport.GetInterfaceIPStack = function(connectionStringEntries);
public:
static IPStack GetInterfaceIPStack(
    Dictionary<String^, String^>^ connectionStringEntries
)

Parameters

connectionStringEntries
Type: System.Collections.GenericDictionary String, String
Connection string key/value pairs.

Return Value

Type: IPStack
Desired IPStack based on "interface" setting.
Remarks
The "interface" setting will be added to the connectionStringEntries if it doesn't exist, in this case return value will be Default.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.IsDestinationReachable Method

Grid Solutions Framework TransportIsDestinationReachable Method
Determines if the specified UDP destination is listening for data.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsDestinationReachable(
    IPEndPoint targetIPEndPoint
)
Public Shared Function IsDestinationReachable (
    targetIPEndPoint As IPEndPoint
) As Boolean
static member IsDestinationReachable :
        targetIPEndPoint : IPEndPoint -> bool

GSF.Communication.Transport.IsDestinationReachable = function(targetIPEndPoint);
public:
static bool IsDestinationReachable(
    IPEndPoint^ targetIPEndPoint
)

Parameters

targetIPEndPoint
Type: System.NetIPEndPoint
The IPEndPoint for the UDP destination to be checked.

Return Value

Type: Boolean
true if the UDP destination is listening for data; otherwise false.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.IsIPv6IP Method

Grid Solutions Framework TransportIsIPv6IP Method
Determines if the specified ipAddress is an IPv6 IP.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsIPv6IP(
    string ipAddress
)
Public Shared Function IsIPv6IP (
    ipAddress As String
) As Boolean
static member IsIPv6IP :
        ipAddress : string -> bool

GSF.Communication.Transport.IsIPv6IP = function(ipAddress);
public:
static bool IsIPv6IP(
    String^ ipAddress
)

Parameters

ipAddress
Type: SystemString
IP address to check.

Return Value

Type: Boolean
true if the ipAddress is IPv6 IP; otherwise false.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.IsLocalAddress Method

Grid Solutions Framework TransportIsLocalAddress Method
Determines if an IP address (or DNS name) is a local IP address.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsLocalAddress(
    string hostNameOrAddress
)
Public Shared Function IsLocalAddress (
    hostNameOrAddress As String
) As Boolean
static member IsLocalAddress :
        hostNameOrAddress : string -> bool

GSF.Communication.Transport.IsLocalAddress = function(hostNameOrAddress);
public:
static bool IsLocalAddress(
    String^ hostNameOrAddress
)

Parameters

hostNameOrAddress
Type: SystemString
DNS name or IP address to test.

Return Value

Type: Boolean
true if hostNameOrAddress is a local IP address; otherwise false.
Exceptions
Exception | Condition
SocketException | An error is encountered when resolving hostNameOrAddress.
ArgumentException | hostNameOrAddress is an invalid IP address.
ArgumentOutOfRangeException | The length of hostNameOrAddress is greater than 255 characters.
ArgumentNullException | hostNameOrAddress is null.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.IsMulticastIP Method

Grid Solutions Framework TransportIsMulticastIP Method
Determines if the specified ipAddress is a multicast IP.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsMulticastIP(
    IPAddress ipAddress
)
Public Shared Function IsMulticastIP (
    ipAddress As IPAddress
) As Boolean
static member IsMulticastIP :
        ipAddress : IPAddress -> bool

GSF.Communication.Transport.IsMulticastIP = function(ipAddress);
public:
static bool IsMulticastIP(
    IPAddress^ ipAddress
)

Parameters

ipAddress
Type: System.NetIPAddress
IP address to check.

Return Value

Type: Boolean
true if the ipAddress is multicast IP; otherwise false.
See Also

Reference

Transport Class
GSF.Communication Namespace


Transport.IsPortNumberValid Method

Grid Solutions Framework TransportIsPortNumberValid Method
Determines whether the specified port is valid.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsPortNumberValid(
    string port
)
Public Shared Function IsPortNumberValid (
    port As String
) As Boolean
static member IsPortNumberValid :
        port : string -> bool

GSF.Communication.Transport.IsPortNumberValid = function(port);
public:
static bool IsPortNumberValid(
    String^ port
)

Parameters

port
Type: SystemString
The port number to be validated.

Return Value

Type: Boolean
True if the port number is valid.
See Also

Reference

Transport Class
GSF.Communication Namespace


TransportProtocol Enumeration

Grid Solutions Framework TransportProtocol Enumeration
Indicates the protocol used in server-client communication.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum TransportProtocol
Public Enumeration TransportProtocol
type TransportProtocol
GSF.Communication.TransportProtocol = function();
GSF.Communication.TransportProtocol.createEnum('GSF.Communication.TransportProtocol', false);
public enum class TransportProtocol
Members
Member name | Value | Description
Tcp | 0 | TransportProtocol is Transmission Control Protocol.
Udp | 1 | TransportProtocol is User Datagram Protocol.
Serial | 2 | TransportProtocol is serial interface.
File | 3 | TransportProtocol is file-system based.
See Also

Reference

GSF.Communication Namespace


TransportProvider(T) Class

Grid Solutions Framework TransportProviderT Class
A class for managing the communication between server and client.
Inheritance Hierarchy
SystemObject
GSF.CommunicationTransportProviderT

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TransportProvider<T>

Public Class TransportProvider(Of T)
type TransportProvider<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class TransportProvider

Type Parameters

T
Type of the object used for server-client communication.

The TransportProviderT type exposes the following members.

Constructors
 | Name | Description
Public method | TransportProviderT | Initializes a new instance of the TransportProviderT class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets TransportProviderT.
Public method | SetReceiveBuffer | Establishes (or reestablishes) a receive buffer of a given size.
Public method | SetSendBuffer | Establishes (or reestablishes) a send buffer of a given size.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | BytesReceived | Number of bytes received in ReceiveBuffer.
Public field | ID | ID of the TransportProviderT object.
Public field | MulticastMembershipAddresses | Optional multicast membership addresses used when a multicast source address is specified.
Public field | Provider | Provider for the transportation of data.
Public field | Statistics | TransportStatistics for the TransportProviderT object.
Top
Properties
 | Name | Description
Public property | ReceiveBuffer | Gets buffer used for receiving data.
Public property | ReceiveBufferSize | Gets receive buffer requested size.
Public property | SendBuffer | Gets buffer used for sending data.
Public property | SendBufferSize | Gets send buffer requested size.
Top
See Also

Reference

GSF.Communication Namespace


TransportProvider(T) Constructor

Grid Solutions Framework TransportProviderT Constructor
Initializes a new instance of the TransportProviderT class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TransportProvider()
Public Sub New
new : unit -> TransportProvider
GSF.Communication.TransportProvider = function();
public:
TransportProvider()
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T) Fields

Grid Solutions Framework TransportProviderT Fields

The TransportProviderT generic type exposes the following members.

Fields
 | Name | Description
Public field | BytesReceived | Number of bytes received in ReceiveBuffer.
Public field | ID | ID of the TransportProviderT object.
Public field | MulticastMembershipAddresses | Optional multicast membership addresses used when a multicast source address is specified.
Public field | Provider | Provider for the transportation of data.
Public field | Statistics | TransportStatistics for the TransportProviderT object.
Top
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).BytesReceived Field

Grid Solutions Framework TransportProviderTBytesReceived Field
Number of bytes received in ReceiveBuffer.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BytesReceived
Public BytesReceived As Integer
val mutable BytesReceived: int
var BytesReceived
public:
int BytesReceived

Field Value

Type: Int32
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).ID Field

Grid Solutions Framework TransportProviderTID Field
ID of the TransportProviderT object.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid ID
Public ID As Guid
val mutable ID: Guid
var ID
public:
Guid ID

Field Value

Type: Guid
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).MulticastMembershipAddresses Field

Grid Solutions Framework TransportProviderTMulticastMembershipAddresses Field
Optional multicast membership addresses used when a multicast source address is specified.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] MulticastMembershipAddresses
Public MulticastMembershipAddresses As Byte()
val mutable MulticastMembershipAddresses: byte[]
var MulticastMembershipAddresses
public:
array<unsigned char>^ MulticastMembershipAddresses

Field Value

Type: Byte
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).Provider Field

Grid Solutions Framework TransportProviderTProvider Field
Provider for the transportation of data.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Provider
Public Provider As T
val mutable Provider: 'T
var Provider
public:
T Provider

Field Value

Type: T
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).Statistics Field

Grid Solutions Framework TransportProviderTStatistics Field
TransportStatistics for the TransportProviderT object.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TransportStatistics Statistics
Public Statistics As TransportStatistics
val mutable Statistics: TransportStatistics
var Statistics
public:
TransportStatistics^ Statistics

Field Value

Type: TransportStatistics
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T) Methods

Grid Solutions Framework TransportProviderT Methods

The TransportProviderT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets TransportProviderT.
Public method | SetReceiveBuffer | Establishes (or reestablishes) a receive buffer of a given size.
Public method | SetSendBuffer | Establishes (or reestablishes) a send buffer of a given size.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).Reset Method

Grid Solutions Framework TransportProviderTReset Method
Resets TransportProviderT.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).SetReceiveBuffer Method

Grid Solutions Framework TransportProviderTSetReceiveBuffer Method
Establishes (or reestablishes) a receive buffer of a given size.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] SetReceiveBuffer(
    int size
)
Public Function SetReceiveBuffer (
    size As Integer
) As Byte()
member SetReceiveBuffer :
        size : int -> byte[]

function SetReceiveBuffer(size);
public:
array<unsigned char>^ SetReceiveBuffer(
    int size
)

Parameters

size
Type: SystemInt32
Desired minimum size of receive buffer.

Return Value

Type: Byte
New receive buffer.
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).SetSendBuffer Method

Grid Solutions Framework TransportProviderTSetSendBuffer Method
Establishes (or reestablishes) a send buffer of a given size.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] SetSendBuffer(
    int size
)
Public Function SetSendBuffer (
    size As Integer
) As Byte()
member SetSendBuffer :
        size : int -> byte[]

function SetSendBuffer(size);
public:
array<unsigned char>^ SetSendBuffer(
    int size
)

Parameters

size
Type: SystemInt32
Desired minimum size of send buffer.

Return Value

Type: Byte
New send buffer.
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T) Properties

Grid Solutions Framework TransportProviderT Properties

The TransportProviderT generic type exposes the following members.

Properties
 | Name | Description
Public property | ReceiveBuffer | Gets buffer used for receiving data.
Public property | ReceiveBufferSize | Gets receive buffer requested size.
Public property | SendBuffer | Gets buffer used for sending data.
Public property | SendBufferSize | Gets send buffer requested size.
Top
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).ReceiveBuffer Property

Grid Solutions Framework TransportProviderTReceiveBuffer Property
Gets buffer used for receiving data.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ReceiveBuffer { get; }
Public ReadOnly Property ReceiveBuffer As Byte()
    Get
member ReceiveBuffer : byte[] with get

function get_ReceiveBuffer();

public:
property array<unsigned char>^ ReceiveBuffer {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
Remarks
Use SetReceiveBuffer(Int32) to reset and/or establish receive buffer size.
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).ReceiveBufferSize Property

Grid Solutions Framework TransportProviderTReceiveBufferSize Property
Gets receive buffer requested size.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ReceiveBufferSize { get; }
Public ReadOnly Property ReceiveBufferSize As Integer
    Get
member ReceiveBufferSize : int with get

function get_ReceiveBufferSize();

public:
property int ReceiveBufferSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).SendBuffer Property

Grid Solutions Framework TransportProviderTSendBuffer Property
Gets buffer used for sending data.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] SendBuffer { get; }
Public ReadOnly Property SendBuffer As Byte()
    Get
member SendBuffer : byte[] with get

function get_SendBuffer();

public:
property array<unsigned char>^ SendBuffer {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
Remarks
Use SetSendBuffer(Int32) to reset and/or establish send buffer size.
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportProvider(T).SendBufferSize Property

Grid Solutions Framework TransportProviderTSendBufferSize Property
Gets send buffer requested size.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SendBufferSize { get; }
Public ReadOnly Property SendBufferSize As Integer
    Get
member SendBufferSize : int with get

function get_SendBufferSize();

public:
property int SendBufferSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

TransportProviderT Class
GSF.Communication Namespace


TransportStatistics Class

Grid Solutions Framework TransportStatistics Class
A class for statistics related to server-client communication.
Inheritance Hierarchy
SystemObject
GSF.CommunicationTransportStatistics

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TransportStatistics
Public Class TransportStatistics
type TransportStatistics =  class end
GSF.Communication.TransportStatistics = function();

Type.createClass(
    'GSF.Communication.TransportStatistics');
public ref class TransportStatistics

The TransportStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | TransportStatistics | Initializes a new instance of the TransportStatistics class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the TransportStatistics.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateBytesReceived | Updates statistics related to receiving of data.
Public method | UpdateBytesSent | Updates statistics related to sending of data.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | LastBytesReceived | Number of bytes received in the last receive operation.
Public field | LastBytesSent | Number of bytes sent in the last send operation.
Public field | LastReceive | DateTime of the last receive operation. (UTC Time)
Public field | LastSend | DateTime of the last send operation. (UTC Time)
Public field | TotalBytesReceived | Total number of bytes received.
Public field | TotalBytesSent | Total number of bytes sent.
Top
See Also

Reference

GSF.Communication Namespace


TransportStatistics Constructor

Grid Solutions Framework TransportStatistics Constructor
Initializes a new instance of the TransportStatistics class

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TransportStatistics()
Public Sub New
new : unit -> TransportStatistics
GSF.Communication.TransportStatistics = function();
public:
TransportStatistics()
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics Fields

Grid Solutions Framework TransportStatistics Fields

The TransportStatistics type exposes the following members.

Fields
 | Name | Description
Public field | LastBytesReceived | Number of bytes received in the last receive operation.
Public field | LastBytesSent | Number of bytes sent in the last send operation.
Public field | LastReceive | DateTime of the last receive operation. (UTC Time)
Public field | LastSend | DateTime of the last send operation. (UTC Time)
Public field | TotalBytesReceived | Total number of bytes received.
Public field | TotalBytesSent | Total number of bytes sent.
Top
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.LastBytesReceived Field

Grid Solutions Framework TransportStatisticsLastBytesReceived Field
Number of bytes received in the last receive operation.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LastBytesReceived
Public LastBytesReceived As Integer
val mutable LastBytesReceived: int
var LastBytesReceived
public:
int LastBytesReceived

Field Value

Type: Int32
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.LastBytesSent Field

Grid Solutions Framework TransportStatisticsLastBytesSent Field
Number of bytes sent in the last send operation.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LastBytesSent
Public LastBytesSent As Integer
val mutable LastBytesSent: int
var LastBytesSent
public:
int LastBytesSent

Field Value

Type: Int32
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.LastReceive Field

Grid Solutions Framework TransportStatisticsLastReceive Field
DateTime of the last receive operation. (UTC Time)

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime LastReceive
Public LastReceive As DateTime
val mutable LastReceive: DateTime
var LastReceive
public:
DateTime LastReceive

Field Value

Type: DateTime
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.LastSend Field

Grid Solutions Framework TransportStatisticsLastSend Field
DateTime of the last send operation. (UTC Time)

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime LastSend
Public LastSend As DateTime
val mutable LastSend: DateTime
var LastSend
public:
DateTime LastSend

Field Value

Type: DateTime
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.TotalBytesReceived Field

Grid Solutions Framework TransportStatisticsTotalBytesReceived Field
Total number of bytes received.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalBytesReceived
Public TotalBytesReceived As Long
val mutable TotalBytesReceived: int64
var TotalBytesReceived
public:
long long TotalBytesReceived

Field Value

Type: Int64
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.TotalBytesSent Field

Grid Solutions Framework TransportStatisticsTotalBytesSent Field
Total number of bytes sent.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalBytesSent
Public TotalBytesSent As Long
val mutable TotalBytesSent: int64
var TotalBytesSent
public:
long long TotalBytesSent

Field Value

Type: Int64
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics Methods

Grid Solutions Framework TransportStatistics Methods

The TransportStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the TransportStatistics.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateBytesReceived | Updates statistics related to receiving of data.
Public method | UpdateBytesSent | Updates statistics related to sending of data.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.Reset Method

Grid Solutions Framework TransportStatisticsReset Method
Resets the TransportStatistics.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.UpdateBytesReceived Method

Grid Solutions Framework TransportStatisticsUpdateBytesReceived Method
Updates statistics related to receiving of data.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateBytesReceived(
    int bytesReceived
)
Public Sub UpdateBytesReceived (
    bytesReceived As Integer
)
member UpdateBytesReceived :
        bytesReceived : int -> unit

function UpdateBytesReceived(bytesReceived);
public:
void UpdateBytesReceived(
    int bytesReceived
)

Parameters

bytesReceived
Type: SystemInt32
Number of bytes received in the receive operation.
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


TransportStatistics.UpdateBytesSent Method

Grid Solutions Framework TransportStatisticsUpdateBytesSent Method
Updates statistics related to sending of data.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateBytesSent(
    int bytesSent
)
Public Sub UpdateBytesSent (
    bytesSent As Integer
)
member UpdateBytesSent :
        bytesSent : int -> unit

function UpdateBytesSent(bytesSent);
public:
void UpdateBytesSent(
    int bytesSent
)

Parameters

bytesSent
Type: SystemInt32
Number of bytes sent in the send operation.
See Also

Reference

TransportStatistics Class
GSF.Communication Namespace


UdpClient Class

Grid Solutions Framework UdpClient Class
Represents a UDP-based communication server.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
GSF.CommunicationUdpClient

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class UdpClient : ClientBase
Public Class UdpClient
    Inherits ClientBase
type UdpClient =
    class
        inherit ClientBase
    end
GSF.Communication.UdpClient = function();

Type.createClass(
    'GSF.Communication.UdpClient',
    GSF.Communication.ClientBase);
public ref class UdpClient : public ClientBase

The UdpClient type exposes the following members.

Constructors
 | Name | Description
Public method | UdpClient | Initializes a new instance of the UdpClient class.
Public method | UdpClient(IContainer) | Initializes a new instance of the UdpClient class.
Public method | UdpClient(String) | Initializes a new instance of the UdpClient class.
Top
Methods
 | Name | Description
Public method | AddMulticastMembership | Adds a multicast membership to the UDP socket.
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the UdpClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the UdpClient from the connected server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UdpClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | DropMulticastMembership | Drops a multicast membership from the UDP socket.
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Overrides ClientBaseOnConnectionTerminated.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | SendDataToAsync | Sends data to the server asynchronously.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultMaxPacketSize | Specifies the default value for the MaxPacketSize property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
DefaultReceiveBufferSize | Specifies the default value for the ReceiveBufferSize property.
Top
Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the Socket object for the UdpClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxPacketSize | Gets or sets the maximum expected size for packets being received by this UdpClient.
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Overrides ClientBaseReceiveBufferSize.)
Public property | ReceivePacketInfo | Gets or sets the flag that determines whether the UDP client should attempt to receive packet info when receiving data from the socket.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the UdpClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ClientBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | ReceiveDataFrom | Occurs when unprocessed data has been received from the server.
Public event | ReceiveDataFromComplete | Occurs when data received from the server has been processed and is ready for consumption.
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
Remarks

Use UdpClient when the primary purpose is to receive data.

The Client socket can be bound to a specified interface on a machine with multiple interfaces by specifying the interface in the ConnectionString (Example: "Server=localhost:8888; Port=8989; Interface=127.0.0.1")

The Client socket can be used just for transmitting data without being bound to a local interface by specifying -1 for the port number in the ConnectionString (Example: "Server=localhost:8888; Port=-1")

Examples
This example shows how to use the UdpClient component:
Copy
using System;
using GSF;
using GSF.Communication;
using GSF.Security.Cryptography;
using GSF.IO.Compression;

class Program
{
    static UdpClient s_client;

    static void Main(string[] args)
    {
        // Initialize the client.
        s_client = new UdpClient("Server=localhost:8888; Port=8989");
        s_client.Handshake = false;
        s_client.ReceiveTimeout = -1;
        s_client.Encryption = CipherStrength.None;
        s_client.Compression = CompressionStrength.NoCompression;
        s_client.SecureSession = false;
        s_client.Initialize();
        // Register event handlers.
        s_client.ConnectionAttempt += s_client_ConnectionAttempt;
        s_client.ConnectionEstablished += s_client_ConnectionEstablished;
        s_client.ConnectionTerminated += s_client_ConnectionTerminated;
        s_client.ReceiveDataComplete += s_client_ReceiveDataComplete;
        // Connect the client.
        s_client.Connect();

        // Transmit user input to the server.
        string input;
        while (string.Compare(input = Console.ReadLine(), "Exit", true) != 0)
        {
            s_client.Send(input);
        }

        // Disconnect the client on shutdown.
        s_client.Dispose();
    }

    static void s_client_ConnectionAttempt(object sender, EventArgs e)
    {
        Console.WriteLine("Client is connecting to server.");
    }

    static void s_client_ConnectionEstablished(object sender, EventArgs e)
    {
        Console.WriteLine("Client connected to server.");
    }

    static void s_client_ConnectionTerminated(object sender, EventArgs e)
    {
        Console.WriteLine("Client disconnected from server.");
    }

    static void s_client_ReceiveDataComplete(object sender, EventArgs<byte[], int> e)
    {
        Console.WriteLine(string.Format("Received data - {0}.", s_client.TextEncoding.GetString(e.Argument1, 0, e.Argument2)));
    }
}
See Also

Reference

GSF.Communication Namespace


UdpClient Constructor

Grid Solutions Framework UdpClient Constructor
Overload List
 | Name | Description
Public method | UdpClient | Initializes a new instance of the UdpClient class.
Public method | UdpClient(IContainer) | Initializes a new instance of the UdpClient class.
Public method | UdpClient(String) | Initializes a new instance of the UdpClient class.
Top
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient Constructor

Grid Solutions Framework UdpClient Constructor
Initializes a new instance of the UdpClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UdpClient()
Public Sub New
new : unit -> UdpClient
GSF.Communication.UdpClient = function();
public:
UdpClient()
See Also

Reference

UdpClient Class
UdpClient Overload
GSF.Communication Namespace


UdpClient Constructor (IContainer)

Grid Solutions Framework UdpClient Constructor (IContainer)
Initializes a new instance of the UdpClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UdpClient(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> UdpClient
GSF.Communication.UdpClient = function(container);
public:
UdpClient(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the UdpClient.
See Also

Reference

UdpClient Class
UdpClient Overload
GSF.Communication Namespace


UdpClient Constructor (String)

Grid Solutions Framework UdpClient Constructor (String)
Initializes a new instance of the UdpClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UdpClient(
    string connectString
)
Public Sub New (
    connectString As String
)
new :
        connectString : string -> UdpClient
GSF.Communication.UdpClient = function(connectString);
public:
UdpClient(
    String^ connectString
)

Parameters

connectString
Type: SystemString
Connect string of the UdpClient. See DefaultConnectionString for format.
See Also

Reference

UdpClient Class
UdpClient Overload
GSF.Communication Namespace


UdpClient Fields

Grid Solutions Framework UdpClient Fields

The UdpClient type exposes the following members.

Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultMaxPacketSize | Specifies the default value for the MaxPacketSize property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
DefaultReceiveBufferSize | Specifies the default value for the ReceiveBufferSize property.
Top
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.DefaultAllowDualStackSocket Field

Grid Solutions Framework UdpClientDefaultAllowDualStackSocket Field
Specifies the default value for the AllowDualStackSocket property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowDualStackSocket
Public Const DefaultAllowDualStackSocket As Boolean
static val mutable DefaultAllowDualStackSocket: bool
var GSF.Communication.UdpClient.DefaultAllowDualStackSocket
public:
literal bool DefaultAllowDualStackSocket

Field Value

Type: Boolean
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.DefaultConnectionString Field

Grid Solutions Framework UdpClientDefaultConnectionString Field
Specifies the default value for the ConnectionString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConnectionString
Public Const DefaultConnectionString As String
static val mutable DefaultConnectionString: string
var GSF.Communication.UdpClient.DefaultConnectionString
public:
literal String^ DefaultConnectionString

Field Value

Type: String
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.DefaultMaxPacketSize Field

Grid Solutions Framework UdpClientDefaultMaxPacketSize Field
Specifies the default value for the MaxPacketSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxPacketSize
Public Const DefaultMaxPacketSize As Integer
static val mutable DefaultMaxPacketSize: int
var GSF.Communication.UdpClient.DefaultMaxPacketSize
public:
literal int DefaultMaxPacketSize

Field Value

Type: Int32
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.DefaultMaxSendQueueSize Field

Grid Solutions Framework UdpClientDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.UdpClient.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.DefaultReceiveBufferSize Field

Grid Solutions Framework UdpClientDefaultReceiveBufferSize Field
Specifies the default value for the ReceiveBufferSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultReceiveBufferSize
Public Const DefaultReceiveBufferSize As Integer
static val mutable DefaultReceiveBufferSize: int
var GSF.Communication.UdpClient.DefaultReceiveBufferSize
public:
literal int DefaultReceiveBufferSize

Field Value

Type: Int32
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient Methods

Grid Solutions Framework UdpClient Methods

The UdpClient type exposes the following members.

Methods
 | Name | Description
Public method | AddMulticastMembership | Adds a multicast membership to the UDP socket.
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the UdpClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the UdpClient from the connected server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UdpClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | DropMulticastMembership | Drops a multicast membership from the UDP socket.
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Overrides ClientBaseOnConnectionTerminated.)
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ClientBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | SendDataToAsync | Sends data to the server asynchronously.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.AddMulticastMembership Method

Grid Solutions Framework UdpClientAddMulticastMembership Method
Adds a multicast membership to the UDP socket.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddMulticastMembership(
    IPAddress serverAddress,
    IPAddress sourceAddress
)
Public Sub AddMulticastMembership (
    serverAddress As IPAddress,
    sourceAddress As IPAddress
)
member AddMulticastMembership :
        serverAddress : IPAddress *
        sourceAddress : IPAddress -> unit

function AddMulticastMembership(serverAddress, sourceAddress);
public:
void AddMulticastMembership(
    IPAddress^ serverAddress,
    IPAddress^ sourceAddress
)

Parameters

serverAddress
Type: System.NetIPAddress
Multicast address to join.
sourceAddress
Type: System.NetIPAddress
Address which defines the source of the data or null if the membership is not source-specific.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.ConnectAsync Method

Grid Solutions Framework UdpClientConnectAsync Method
Connects the UdpClient to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override WaitHandle ConnectAsync()
Public Overrides Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle
override ConnectAsync : unit -> WaitHandle
function ConnectAsync();
public:
virtual WaitHandle^ ConnectAsync() override

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientConnectAsync
Exceptions
Exception | Condition
FormatException | Server property in ConnectionString is invalid.
InvalidOperationException | Attempt is made to connect the UdpClient when it is not disconnected.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.Disconnect Method

Grid Solutions Framework UdpClientDisconnect Method
Disconnects the UdpClient from the connected server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Disconnect()
Public Overrides Sub Disconnect
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit
function Disconnect();
public:
virtual void Disconnect() override

Implements

IClientDisconnect
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.Dispose Method

Grid Solutions Framework UdpClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the UdpClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Top
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.Dispose Method (Boolean)

Grid Solutions Framework UdpClientDispose Method (Boolean)
Releases the unmanaged resources used by the UdpClient and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

UdpClient Class
Dispose Overload
GSF.Communication Namespace


UdpClient.DropMulticastMembership Method

Grid Solutions Framework UdpClientDropMulticastMembership Method
Drops a multicast membership from the UDP socket.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void DropMulticastMembership(
    IPAddress serverAddress,
    IPAddress sourceAddress
)
Public Sub DropMulticastMembership (
    serverAddress As IPAddress,
    sourceAddress As IPAddress
)
member DropMulticastMembership :
        serverAddress : IPAddress *
        sourceAddress : IPAddress -> unit

function DropMulticastMembership(serverAddress, sourceAddress);
public:
void DropMulticastMembership(
    IPAddress^ serverAddress,
    IPAddress^ sourceAddress
)

Parameters

serverAddress
Type: System.NetIPAddress
Multicast address to drop.
sourceAddress
Type: System.NetIPAddress
Address which defines the source of the data or null if the membership is not source-specific.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.LoadSettings Method

Grid Solutions Framework UdpClientLoadSettings Method
Loads saved TcpServer settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.OnConnectionException Method

Grid Solutions Framework UdpClientOnConnectionException Method
Raises the ConnectionException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnConnectionException(
    Exception ex
)
Protected Overrides Sub OnConnectionException (
    ex As Exception
)
abstract OnConnectionException :
        ex : Exception -> unit
override OnConnectionException :
        ex : Exception -> unit
function OnConnectionException(ex);
protected:
virtual void OnConnectionException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ConnectionException event.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.OnConnectionTerminated Method

Grid Solutions Framework UdpClientOnConnectionTerminated Method
Raises the ConnectionTerminated event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnConnectionTerminated()
Protected Overrides Sub OnConnectionTerminated
abstract OnConnectionTerminated : unit -> unit
override OnConnectionTerminated : unit -> unit
function OnConnectionTerminated();
protected:
virtual void OnConnectionTerminated() override
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.OnReceiveDataException Method

Grid Solutions Framework UdpClientOnReceiveDataException Method
Raises the ReceiveDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceiveDataException(
    Exception ex
)
Protected Overrides Sub OnReceiveDataException (
    ex As Exception
)
abstract OnReceiveDataException :
        ex : Exception -> unit
override OnReceiveDataException :
        ex : Exception -> unit
function OnReceiveDataException(ex);
protected:
virtual void OnReceiveDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ReceiveDataException event.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.OnSendDataException Method

Grid Solutions Framework UdpClientOnSendDataException Method
Raises the SendDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnSendDataException(
    Exception ex
)
Protected Overrides Sub OnSendDataException (
    ex As Exception
)
abstract OnSendDataException :
        ex : Exception -> unit
override OnSendDataException :
        ex : Exception -> unit
function OnSendDataException(ex);
protected:
virtual void OnSendDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to SendDataException event.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.Read Method

Grid Solutions Framework UdpClientRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IClientRead(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.SaveSettings Method

Grid Solutions Framework UdpClientSaveSettings Method
Saves TcpServer settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.SendDataAsync Method

Grid Solutions Framework UdpClientSendDataAsync Method
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataAsync(
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataAsync(data, offset, length);
protected:
virtual WaitHandle^ SendDataAsync(
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.SendDataToAsync Method

Grid Solutions Framework UdpClientSendDataToAsync Method
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaitHandle SendDataToAsync(
    byte[] data,
    int offset,
    int length,
    EndPoint destination
)
Public Function SendDataToAsync (
    data As Byte(),
    offset As Integer,
    length As Integer,
    destination As EndPoint
) As WaitHandle
member SendDataToAsync :
        data : byte[] *
        offset : int *
        length : int *
        destination : EndPoint -> WaitHandle

function SendDataToAsync(data, offset, length, destination);
public:
WaitHandle^ SendDataToAsync(
    array<unsigned char>^ data,
    int offset,
    int length,
    EndPoint^ destination
)

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.
destination
Type: System.NetEndPoint
The end point which identifies the destination for the data.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.ValidateConnectionString Method

Grid Solutions Framework UdpClientValidateConnectionString Method
Validates the specified connectionString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConnectionString(
    string connectionString
)
Protected Overrides Sub ValidateConnectionString (
    connectionString As String
)
abstract ValidateConnectionString :
        connectionString : string -> unit
override ValidateConnectionString :
        connectionString : string -> unit
function ValidateConnectionString(connectionString);
protected:
virtual void ValidateConnectionString(
    String^ connectionString
) override

Parameters

connectionString
Type: SystemString
Connection string to be validated.
Exceptions
Exception | Condition
ArgumentException | Port property is missing.
ArgumentOutOfRangeException | Port property value is not between PortRangeLow and PortRangeHigh.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient Properties

Grid Solutions Framework UdpClient Properties

The UdpClient type exposes the following members.

Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the Socket object for the UdpClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxPacketSize | Gets or sets the maximum expected size for packets being received by this UdpClient.
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Overrides ClientBaseReceiveBufferSize.)
Public property | ReceivePacketInfo | Gets or sets the flag that determines whether the UDP client should attempt to receive packet info when receiving data from the socket.
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the UdpClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ClientBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Inherited from ClientBase.)
Top
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.AllowDualStackSocket Property

Grid Solutions Framework UdpClientAllowDualStackSocket Property
Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool AllowDualStackSocket { get; set; }
<DefaultValueAttribute(true)>
Public Property AllowDualStackSocket As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member AllowDualStackSocket : bool with get, set

function get_AllowDualStackSocket();
function set_AllowDualStackSocket(value);
public:
[DefaultValueAttribute(true)]
property bool AllowDualStackSocket {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.Client Property

Grid Solutions Framework UdpClientClient Property
Gets the Socket object for the UdpClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Socket Client { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Client As Socket
    Get
[<BrowsableAttribute(false)>]
member Client : Socket with get

function get_Client();

public:
[BrowsableAttribute(false)]
property Socket^ Client {
    Socket^ get ();
}

Property Value

Type: Socket
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.MaxPacketSize Property

Grid Solutions Framework UdpClientMaxPacketSize Property
Gets or sets the maximum expected size for packets being received by this UdpClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaxPacketSize { get; set; }
Public Property MaxPacketSize As Integer
    Get
    Set
member MaxPacketSize : int with get, set

function get_MaxPacketSize();
function set_MaxPacketSize(value);
public:
property int MaxPacketSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.MaxSendQueueSize Property

Grid Solutions Framework UdpClientMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.ReceiveBufferSize Property

Grid Solutions Framework UdpClientReceiveBufferSize Property
Gets or sets the size of the buffer used by the client for receiving data from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ReceiveBufferSize { get; set; }
Public Overrides Property ReceiveBufferSize As Integer
    Get
    Set
abstract ReceiveBufferSize : int with get, set
override ReceiveBufferSize : int with get, set
function get_ReceiveBufferSize();
function set_ReceiveBufferSize(value);
public:
virtual property int ReceiveBufferSize {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32

Implements

IClientReceiveBufferSize
Exceptions
Exception | Condition
ArgumentException | The value being assigned is either zero or negative.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.ReceivePacketInfo Property

Grid Solutions Framework UdpClientReceivePacketInfo Property
Gets or sets the flag that determines whether the UDP client should attempt to receive packet info when receiving data from the socket.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReceivePacketInfo { get; set; }
Public Property ReceivePacketInfo As Boolean
    Get
    Set
member ReceivePacketInfo : bool with get, set

function get_ReceivePacketInfo();
function set_ReceivePacketInfo(value);
public:
property bool ReceivePacketInfo {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.ServerUri Property

Grid Solutions Framework UdpClientServerUri Property
Gets the server URI of the UdpClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override string ServerUri { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ServerUri As String
    Get
[<BrowsableAttribute(false)>]
abstract ServerUri : string with get
[<BrowsableAttribute(false)>]
override ServerUri : string with get
function get_ServerUri();

public:
[BrowsableAttribute(false)]
virtual property String^ ServerUri {
    String^ get () override;
}

Property Value

Type: String

Implements

IClientServerUri
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.Status Property

Grid Solutions Framework UdpClientStatus Property
Gets the descriptive status of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient Events

Grid Solutions Framework UdpClient Events

The UdpClient type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | ReceiveDataFrom | Occurs when unprocessed data has been received from the server.
Public event | ReceiveDataFromComplete | Occurs when data received from the server has been processed and is ready for consumption.
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.ReceiveDataFrom Event

Grid Solutions Framework UdpClientReceiveDataFrom Event
Occurs when unprocessed data has been received from the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<EndPoint, IPPacketInformation, int>> ReceiveDataFrom
Public Event ReceiveDataFrom As EventHandler(Of EventArgs(Of EndPoint, IPPacketInformation, Integer))
member ReceiveDataFrom : IEvent<EventHandler<EventArgs<EndPoint, IPPacketInformation, int>>,
    EventArgs<EndPoint, IPPacketInformation, int>>

function add_ReceiveDataFrom(value);
function remove_ReceiveDataFrom(value);
public:
 event EventHandler<EventArgs<EndPoint^, IPPacketInformation, int>^>^ ReceiveDataFrom {
    void add (EventHandler<EventArgs<EndPoint^, IPPacketInformation, int>^>^ value);
    void remove (EventHandler<EventArgs<EndPoint^, IPPacketInformation, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs EndPoint, IPPacketInformation, Int32
Remarks

This event can be used to receive a notification that server data has arrived. The Read(Byte, Int32, Int32) method can then be used to copy data to an existing buffer. In many cases it will be optimal to use an existing buffer instead of subscribing to the ReceiveDataFromComplete event.

Argument1 is the end-point that data has been received from.
Argument2 is the number of bytes received in the buffer from the server.

See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpClient.ReceiveDataFromComplete Event

Grid Solutions Framework UdpClientReceiveDataFromComplete Event
Occurs when data received from the server has been processed and is ready for consumption.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<EndPoint, IPPacketInformation, byte[], int>> ReceiveDataFromComplete
Public Event ReceiveDataFromComplete As EventHandler(Of EventArgs(Of EndPoint, IPPacketInformation, Byte(), Integer))
member ReceiveDataFromComplete : IEvent<EventHandler<EventArgs<EndPoint, IPPacketInformation, byte[], int>>,
    EventArgs<EndPoint, IPPacketInformation, byte[], int>>

function add_ReceiveDataFromComplete(value);
function remove_ReceiveDataFromComplete(value);
public:
 event EventHandler<EventArgs<EndPoint^, IPPacketInformation, array<unsigned char>^, int>^>^ ReceiveDataFromComplete {
    void add (EventHandler<EventArgs<EndPoint^, IPPacketInformation, array<unsigned char>^, int>^>^ value);
    void remove (EventHandler<EventArgs<EndPoint^, IPPacketInformation, array<unsigned char>^, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs EndPoint, IPPacketInformation, Byte , Int32
Remarks
Argument1 is the end-point that data has been received from.
Argument2 is a new buffer containing post-processed data received from the server starting at index zero.
Argument3 is the number of post-processed bytes received in the buffer from the server.
See Also

Reference

UdpClient Class
GSF.Communication Namespace


UdpServer Class

Grid Solutions Framework UdpServer Class
Represents a UDP-based communication server.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationServerBase
GSF.CommunicationUdpServer

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class UdpServer : ServerBase
Public Class UdpServer
    Inherits ServerBase
type UdpServer =
    class
        inherit ServerBase
    end
GSF.Communication.UdpServer = function();

Type.createClass(
    'GSF.Communication.UdpServer',
    GSF.Communication.ServerBase);
public ref class UdpServer : public ServerBase

The UdpServer type exposes the following members.

Constructors
 | Name | Description
Public method | UdpServer | Initializes a new instance of the UdpServer class.
Public method | UdpServer(IContainer) | Initializes a new instance of the UdpServer class.
Public method | UdpServer(String) | Initializes a new instance of the UdpServer class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Inherited from ServerBase.)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Inherited from ServerBase.)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event. (Overrides ServerBaseOnReceiveClientDataException(Guid, Exception).)
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Overrides ServerBaseOnSendClientDataException(Guid, Exception).)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ServerBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the UdpServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the UdpServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultClientIdentificationMode | Specifies the default value for the ClientIdentificationMode property.
DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
DefaultDynamicClientEndPoints | Specifies the default value for the DynamicClientEndPoints property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
Top
Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIdentificationMode | Gets or sets the mode by which the UDP server will identify its clients when receiving messages.
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DynamicClientEndPoints | Gets or sets a boolean value that determines if UDP server should always send responses to clients on the port that data is received from the client.
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the UdpServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Inherited from ServerBase.)
Top
Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
Remarks

Use UdpServer when the primary purpose is to transmit data.

The Server socket can be bound to a specified interface on a machine with multiple interfaces by specifying the interface in the ConfigurationString (Example: "Port=8888; Clients=localhost:8989; Interface=127.0.0.1")

The Server socket can be used just for transmitting data without being bound to a local interface by specifying -1 for the port number in the ConfigurationString (Example: "Port=-1; Clients=localhost:8989")

Examples
This example shows how to use the UdpServer component:
Copy
using System;
using GSF;
using GSF.Communication;
using GSF.Security.Cryptography;
using GSF.IO.Compression;

class Program
{
    static UdpServer m_server;

    static void Main(string[] args)
    {
        // Initialize the server.
        m_server = new UdpServer("Port=8888; Clients=localhost:8989");
        m_server.Handshake = false;
        m_server.ReceiveTimeout = -1;
        m_server.Encryption = CipherStrength.None;
        m_server.Compression = CompressionStrength.NoCompression;
        m_server.SecureSession = false;
        m_server.Initialize();
        // Register event handlers.
        m_server.ServerStarted += m_server_ServerStarted;
        m_server.ServerStopped += m_server_ServerStopped;
        m_server.ClientConnected += m_server_ClientConnected;
        m_server.ClientDisconnected += m_server_ClientDisconnected;
        m_server.ReceiveClientDataComplete += m_server_ReceiveClientDataComplete;
        // Start the server.
        m_server.Start();

        // Multicast user input to all connected clients.
        string input;
        while (string.Compare(input = Console.ReadLine(), "Exit", true) != 0)
        {
            m_server.Multicast(input);
        }

        // Stop the server on shutdown.
        m_server.Stop();
    }

    static void m_server_ServerStarted(object sender, EventArgs e)
    {
        Console.WriteLine("Server has been started!");
    }

    static void m_server_ServerStopped(object sender, EventArgs e)
    {
        Console.WriteLine("Server has been stopped!");
    }

    static void m_server_ClientConnected(object sender, EventArgs<Guid> e)
    {
        Console.WriteLine(string.Format("Client connected - {0}.", e.Argument));
    }

    static void m_server_ClientDisconnected(object sender, EventArgs<Guid> e)
    {
        Console.WriteLine(string.Format("Client disconnected - {0}.", e.Argument));
    }

    static void m_server_ReceiveClientDataComplete(object sender, EventArgs<Guid, byte[], int> e)
    {
        Console.WriteLine(string.Format("Received data from {0} - {1}.", e.Argument1, m_server.TextEncoding.GetString(e.Argument2, 0, e.Argument3)));
    }
}
See Also

Reference

GSF.Communication Namespace


UdpServer Constructor

Grid Solutions Framework UdpServer Constructor
Overload List
 | Name | Description
Public method | UdpServer | Initializes a new instance of the UdpServer class.
Public method | UdpServer(IContainer) | Initializes a new instance of the UdpServer class.
Public method | UdpServer(String) | Initializes a new instance of the UdpServer class.
Top
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer Constructor

Grid Solutions Framework UdpServer Constructor
Initializes a new instance of the UdpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UdpServer()
Public Sub New
new : unit -> UdpServer
GSF.Communication.UdpServer = function();
public:
UdpServer()
See Also

Reference

UdpServer Class
UdpServer Overload
GSF.Communication Namespace


UdpServer Constructor (IContainer)

Grid Solutions Framework UdpServer Constructor (IContainer)
Initializes a new instance of the UdpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UdpServer(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> UdpServer
GSF.Communication.UdpServer = function(container);
public:
UdpServer(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the UdpServer.
See Also

Reference

UdpServer Class
UdpServer Overload
GSF.Communication Namespace


UdpServer Constructor (String)

Grid Solutions Framework UdpServer Constructor (String)
Initializes a new instance of the UdpServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UdpServer(
    string configString
)
Public Sub New (
    configString As String
)
new :
        configString : string -> UdpServer
GSF.Communication.UdpServer = function(configString);
public:
UdpServer(
    String^ configString
)

Parameters

configString
Type: SystemString
Configuration string of the UdpServer. See DefaultConfigurationString for format.
See Also

Reference

UdpServer Class
UdpServer Overload
GSF.Communication Namespace


UdpServer Fields

Grid Solutions Framework UdpServer Fields

The UdpServer type exposes the following members.

Fields
Name | Description
DefaultAllowDualStackSocket | Specifies the default value for the AllowDualStackSocket property.
DefaultClientIdentificationMode | Specifies the default value for the ClientIdentificationMode property.
DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
DefaultDynamicClientEndPoints | Specifies the default value for the DynamicClientEndPoints property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
Top
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.DefaultAllowDualStackSocket Field

Grid Solutions Framework UdpServerDefaultAllowDualStackSocket Field
Specifies the default value for the AllowDualStackSocket property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowDualStackSocket
Public Const DefaultAllowDualStackSocket As Boolean
static val mutable DefaultAllowDualStackSocket: bool
var GSF.Communication.UdpServer.DefaultAllowDualStackSocket
public:
literal bool DefaultAllowDualStackSocket

Field Value

Type: Boolean
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.DefaultClientIdentificationMode Field

Grid Solutions Framework UdpServerDefaultClientIdentificationMode Field
Specifies the default value for the ClientIdentificationMode property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ClientIdentificationMode DefaultClientIdentificationMode
Public Const DefaultClientIdentificationMode As ClientIdentificationMode
static val mutable DefaultClientIdentificationMode: ClientIdentificationMode
var GSF.Communication.UdpServer.DefaultClientIdentificationMode
public:
literal ClientIdentificationMode DefaultClientIdentificationMode

Field Value

Type: ClientIdentificationMode
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.DefaultConfigurationString Field

Grid Solutions Framework UdpServerDefaultConfigurationString Field
Specifies the default value for the ConfigurationString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConfigurationString
Public Const DefaultConfigurationString As String
static val mutable DefaultConfigurationString: string
var GSF.Communication.UdpServer.DefaultConfigurationString
public:
literal String^ DefaultConfigurationString

Field Value

Type: String
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.DefaultDynamicClientEndPoints Field

Grid Solutions Framework UdpServerDefaultDynamicClientEndPoints Field
Specifies the default value for the DynamicClientEndPoints property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultDynamicClientEndPoints
Public Const DefaultDynamicClientEndPoints As Boolean
static val mutable DefaultDynamicClientEndPoints: bool
var GSF.Communication.UdpServer.DefaultDynamicClientEndPoints
public:
literal bool DefaultDynamicClientEndPoints

Field Value

Type: Boolean
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.DefaultMaxSendQueueSize Field

Grid Solutions Framework UdpServerDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.UdpServer.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer Methods

Grid Solutions Framework UdpServer Methods

The UdpServer type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the server and optionally releases the managed resources. (Inherited from ServerBase.)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Inherited from ServerBase.)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event. (Overrides ServerBaseOnReceiveClientDataException(Guid, Exception).)
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Overrides ServerBaseOnSendClientDataException(Guid, Exception).)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Inherited from ServerBase.)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves TcpServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the UdpServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the UdpServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.DisconnectOne Method

Grid Solutions Framework UdpServerDisconnectOne Method
Disconnects the specified connected client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void DisconnectOne(
    Guid clientID
)
Public Overrides Sub DisconnectOne (
    clientID As Guid
)
abstract DisconnectOne :
        clientID : Guid -> unit
override DisconnectOne :
        clientID : Guid -> unit
function DisconnectOne(clientID);
public:
virtual void DisconnectOne(
    Guid clientID
) override

Parameters

clientID
Type: SystemGuid
ID of the client to be disconnected.

Implements

IServerDisconnectOne(Guid)
Exceptions
Exception | Condition
InvalidOperationException | Client does not exist for the specified clientID.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.LoadSettings Method

Grid Solutions Framework UdpServerLoadSettings Method
Loads saved TcpServer settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.OnReceiveClientDataException Method

Grid Solutions Framework UdpServerOnReceiveClientDataException Method
Raises the ReceiveClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceiveClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overrides Sub OnReceiveClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnReceiveClientDataException(clientID, ex);
protected:
virtual void OnReceiveClientDataException(
    Guid clientID,
    Exception^ ex
) override

Parameters

clientID
Type: SystemGuid
ID of client to send to ReceiveClientDataException event.
ex
Type: SystemException
Exception to send to ReceiveClientDataException event.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.OnSendClientDataException Method

Grid Solutions Framework UdpServerOnSendClientDataException Method
Raises the SendClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnSendClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overrides Sub OnSendClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnSendClientDataException(clientID, ex);
protected:
virtual void OnSendClientDataException(
    Guid clientID,
    Exception^ ex
) override

Parameters

clientID
Type: SystemGuid
ID of client to send to SendClientDataException event.
ex
Type: SystemException
Exception to send to SendClientDataException event.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.Read Method

Grid Solutions Framework UdpServerRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    Guid clientID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    clientID As Guid,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(clientID, buffer, startIndex, length);
public:
virtual int Read(
    Guid clientID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client from which data buffer should be read.
buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IServerRead(Guid, Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read -or- Specified clientID does not exist, cannot read buffer.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveClientData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.SaveSettings Method

Grid Solutions Framework UdpServerSaveSettings Method
Saves TcpServer settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.SendDataToAsync Method

Grid Solutions Framework UdpServerSendDataToAsync Method
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataToAsync(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataToAsync (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataToAsync(clientID, data, offset, length);
protected:
virtual WaitHandle^ SendDataToAsync(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.Start Method

Grid Solutions Framework UdpServerStart Method
Starts the UdpServer synchronously and begins accepting client connections asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IServerStart
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to Start the UdpServer when it is running.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.Stop Method

Grid Solutions Framework UdpServerStop Method
Stops the UdpServer synchronously and disconnects all connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Stop()
Public Overrides Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() override

Implements

IServerStop
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.TryGetClient Method

Grid Solutions Framework UdpServerTryGetClient Method
Gets the TransportProviderT object associated with the specified client ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetClient(
    Guid clientID,
    out TransportProvider<EndPoint> udpClient
)
Public Function TryGetClient (
    clientID As Guid,
    <OutAttribute> ByRef udpClient As TransportProvider(Of EndPoint)
) As Boolean
member TryGetClient :
        clientID : Guid *
        udpClient : TransportProvider<EndPoint> byref -> bool

function TryGetClient(clientID, udpClient);
public:
bool TryGetClient(
    Guid clientID,
    [OutAttribute] TransportProvider<EndPoint^>^% udpClient
)

Parameters

clientID
Type: SystemGuid
ID of the client.
udpClient
Type: GSF.CommunicationTransportProvider EndPoint
The UDP client.

Return Value

Type: Boolean
An TransportProviderT object.
Exceptions
Exception | Condition
InvalidOperationException | Client does not exist for the specified clientID.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.ValidateConfigurationString Method

Grid Solutions Framework UdpServerValidateConfigurationString Method
Validates the specified configurationString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConfigurationString(
    string configurationString
)
Protected Overrides Sub ValidateConfigurationString (
    configurationString As String
)
abstract ValidateConfigurationString :
        configurationString : string -> unit
override ValidateConfigurationString :
        configurationString : string -> unit
function ValidateConfigurationString(configurationString);
protected:
virtual void ValidateConfigurationString(
    String^ configurationString
) override

Parameters

configurationString
Type: SystemString
Configuration string to be validated.
Exceptions
Exception | Condition
ArgumentException | Port property is missing.
ArgumentOutOfRangeException | Port property value is not between PortRangeLow and PortRangeHigh.
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer Properties

Grid Solutions Framework UdpServer Properties

The UdpServer type exposes the following members.

Properties
 | Name | Description
Public property | AllowDualStackSocket | Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIdentificationMode | Gets or sets the mode by which the UDP server will identify its clients when receiving messages.
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DynamicClientEndPoints | Gets or sets a boolean value that determines if UDP server should always send responses to clients on the port that data is received from the client.
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the UdpServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Inherited from ServerBase.)
Top
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.AllowDualStackSocket Property

Grid Solutions Framework UdpServerAllowDualStackSocket Property
Gets or sets a boolean value that determines if dual-mode socket is allowed when endpoint address is IPv6.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool AllowDualStackSocket { get; set; }
<DefaultValueAttribute(true)>
Public Property AllowDualStackSocket As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member AllowDualStackSocket : bool with get, set

function get_AllowDualStackSocket();
function set_AllowDualStackSocket(value);
public:
[DefaultValueAttribute(true)]
property bool AllowDualStackSocket {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.ClientIdentificationMode Property

Grid Solutions Framework UdpServerClientIdentificationMode Property
Gets or sets the mode by which the UDP server will identify its clients when receiving messages.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(ClientIdentificationMode.EndPoint)]
public ClientIdentificationMode ClientIdentificationMode { get; set; }
<DefaultValueAttribute(ClientIdentificationMode.EndPoint)>
Public Property ClientIdentificationMode As ClientIdentificationMode
    Get
    Set
[<DefaultValueAttribute(ClientIdentificationMode.EndPoint)>]
member ClientIdentificationMode : ClientIdentificationMode with get, set

function get_ClientIdentificationMode();
function set_ClientIdentificationMode(value);
public:
[DefaultValueAttribute(ClientIdentificationMode::EndPoint)]
property ClientIdentificationMode ClientIdentificationMode {
    ClientIdentificationMode get ();
    void set (ClientIdentificationMode value);
}

Property Value

Type: ClientIdentificationMode
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.DynamicClientEndPoints Property

Grid Solutions Framework UdpServerDynamicClientEndPoints Property
Gets or sets a boolean value that determines if UDP server should always send responses to clients on the port that data is received from the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool DynamicClientEndPoints { get; set; }
<DefaultValueAttribute(false)>
Public Property DynamicClientEndPoints As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member DynamicClientEndPoints : bool with get, set

function get_DynamicClientEndPoints();
function set_DynamicClientEndPoints(value);
public:
[DefaultValueAttribute(false)]
property bool DynamicClientEndPoints {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.MaxSendQueueSize Property

Grid Solutions Framework UdpServerMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.Server Property

Grid Solutions Framework UdpServerServer Property
Gets the Socket object for the UdpServer.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Socket Server { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Server As Socket
    Get
[<BrowsableAttribute(false)>]
member Server : Socket with get

function get_Server();

public:
[BrowsableAttribute(false)]
property Socket^ Server {
    Socket^ get ();
}

Property Value

Type: Socket
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer.Status Property

Grid Solutions Framework UdpServerStatus Property
Gets the descriptive status of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

UdpServer Class
GSF.Communication Namespace


UdpServer Events

Grid Solutions Framework UdpServer Events

The UdpServer type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
See Also

Reference

UdpServer Class
GSF.Communication Namespace


ZeroMQClient Class

Grid Solutions Framework ZeroMQClient Class
Represents a ZeroMQ DEALER style socket as a communication client.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationClientBase
GSF.CommunicationZeroMQClient

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ZeroMQClient : ClientBase
Public Class ZeroMQClient
    Inherits ClientBase
type ZeroMQClient =
    class
        inherit ClientBase
    end
GSF.Communication.ZeroMQClient = function();

Type.createClass(
    'GSF.Communication.ZeroMQClient',
    GSF.Communication.ClientBase);
public ref class ZeroMQClient : public ClientBase

The ZeroMQClient type exposes the following members.

Constructors
 | Name | Description
Public method | ZeroMQClient | Initializes a new instance of the ZeroMQClient class.
Public method | ZeroMQClient(IContainer) | Initializes a new instance of the ZeroMQClient class.
Public method | ZeroMQClient(String) | Initializes a new instance of the ZeroMQClient class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the ZeroMQClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the ZeroMQClient from the connected server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ZeroMQClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnDisconnectException | Raises the SendDataException event for disconnect exceptions.
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Overrides ClientBaseOnUnhandledUserException(Exception).)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TcpClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultMaxReceiveQueueSize | Specifies the default value for the MaxReceiveQueueSize property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the Socket object for the ZeroMQClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxReceiveQueueSize | Gets or sets the maximum size for the receive queue before payloads are dumped from the queue.
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the ZeroMQClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ClientBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Overrides ClientBaseTransportProtocol.)
Public property | ZeroMQTransportProtocol | Gets or sets the ZeroMQ transport protocol to use for the ZeroMQClient.
Top
Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

GSF.Communication Namespace


ZeroMQClient Constructor

Grid Solutions Framework ZeroMQClient Constructor
Overload List
 | Name | Description
Public method | ZeroMQClient | Initializes a new instance of the ZeroMQClient class.
Public method | ZeroMQClient(IContainer) | Initializes a new instance of the ZeroMQClient class.
Public method | ZeroMQClient(String) | Initializes a new instance of the ZeroMQClient class.
Top
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient Constructor

Grid Solutions Framework ZeroMQClient Constructor
Initializes a new instance of the ZeroMQClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ZeroMQClient()
Public Sub New
new : unit -> ZeroMQClient
GSF.Communication.ZeroMQClient = function();
public:
ZeroMQClient()
See Also

Reference

ZeroMQClient Class
ZeroMQClient Overload
GSF.Communication Namespace


ZeroMQClient Constructor (IContainer)

Grid Solutions Framework ZeroMQClient Constructor (IContainer)
Initializes a new instance of the ZeroMQClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ZeroMQClient(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ZeroMQClient
GSF.Communication.ZeroMQClient = function(container);
public:
ZeroMQClient(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the ZeroMQClient.
See Also

Reference

ZeroMQClient Class
ZeroMQClient Overload
GSF.Communication Namespace


ZeroMQClient Constructor (String)

Grid Solutions Framework ZeroMQClient Constructor (String)
Initializes a new instance of the ZeroMQClient class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ZeroMQClient(
    string connectString
)
Public Sub New (
    connectString As String
)
new :
        connectString : string -> ZeroMQClient
GSF.Communication.ZeroMQClient = function(connectString);
public:
ZeroMQClient(
    String^ connectString
)

Parameters

connectString
Type: SystemString
Connect string of the ZeroMQClient. See DefaultConnectionString for format.
See Also

Reference

ZeroMQClient Class
ZeroMQClient Overload
GSF.Communication Namespace


ZeroMQClient Fields

Grid Solutions Framework ZeroMQClient Fields

The ZeroMQClient type exposes the following members.

Fields
Name | Description
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultMaxReceiveQueueSize | Specifies the default value for the MaxReceiveQueueSize property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
Top
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.DefaultConnectionString Field

Grid Solutions Framework ZeroMQClientDefaultConnectionString Field
Specifies the default value for the ConnectionString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConnectionString
Public Const DefaultConnectionString As String
static val mutable DefaultConnectionString: string
var GSF.Communication.ZeroMQClient.DefaultConnectionString
public:
literal String^ DefaultConnectionString

Field Value

Type: String
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.DefaultMaxReceiveQueueSize Field

Grid Solutions Framework ZeroMQClientDefaultMaxReceiveQueueSize Field
Specifies the default value for the MaxReceiveQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxReceiveQueueSize
Public Const DefaultMaxReceiveQueueSize As Integer
static val mutable DefaultMaxReceiveQueueSize: int
var GSF.Communication.ZeroMQClient.DefaultMaxReceiveQueueSize
public:
literal int DefaultMaxReceiveQueueSize

Field Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for inbound messages.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.DefaultMaxSendQueueSize Field

Grid Solutions Framework ZeroMQClientDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.ZeroMQClient.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for outbound messages.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient Methods

Grid Solutions Framework ZeroMQClient Methods

The ZeroMQClient type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the client properties are initialized. (Inherited from ClientBase.)
Public method | Connect | Connects the client to the server synchronously. (Inherited from ClientBase.)
Public method | ConnectAsync | Connects the ZeroMQClient to the server asynchronously. (Overrides ClientBaseConnectAsync.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects the ZeroMQClient from the connected server synchronously. (Overrides ClientBaseDisconnect.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ZeroMQClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the client properties are initialized. (Inherited from ClientBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the client. (Inherited from ClientBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved TcpClient settings from the config file if the PersistSettings property is set to true. (Overrides ClientBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnConnectionAttempt | Raises the ConnectionAttempt event. (Inherited from ClientBase.)
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event. (Inherited from ClientBase.)
Protected method | OnConnectionException | Raises the ConnectionException event. (Overrides ClientBaseOnConnectionException(Exception).)
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event. (Inherited from ClientBase.)
Protected method | OnDisconnectException | Raises the SendDataException event for disconnect exceptions.
Protected method | OnReceiveData | Raises the ReceiveData event. (Inherited from ClientBase.)
Protected method | OnReceiveDataComplete | Raises the ReceiveDataComplete event. (Inherited from ClientBase.)
Protected method | OnReceiveDataException | Raises the ReceiveDataException event. (Overrides ClientBaseOnReceiveDataException(Exception).)
Protected method | OnSendDataComplete | Raises the SendDataComplete event. (Inherited from ClientBase.)
Protected method | OnSendDataException | Raises the SendDataException event. (Overrides ClientBaseOnSendDataException(Exception).)
Protected method | OnSendDataStart | Raises the SendDataStart event. (Inherited from ClientBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Overrides ClientBaseOnUnhandledUserException(Exception).)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ClientBaseRead(Byte, Int32, Int32).)
Public method | SaveSettings | Saves TcpClient settings to the config file if the PersistSettings property is set to true. (Overrides ClientBaseSaveSettings.)
Public method | Send(Byte) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Object) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(String) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | Send(Byte, Int32, Int32) | Sends data to the server synchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Object) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(String) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Public method | SendAsync(Byte, Int32, Int32) | Sends data to the server asynchronously. (Inherited from ClientBase.)
Protected method | SendDataAsync | Sends data to the server asynchronously. (Overrides ClientBaseSendDataAsync(Byte, Int32, Int32).)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | ValidateConnectionString | Validates the specified connectionString. (Overrides ClientBaseValidateConnectionString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.ConnectAsync Method

Grid Solutions Framework ZeroMQClientConnectAsync Method
Connects the ZeroMQClient to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override WaitHandle ConnectAsync()
Public Overrides Function ConnectAsync As WaitHandle
abstract ConnectAsync : unit -> WaitHandle
override ConnectAsync : unit -> WaitHandle
function ConnectAsync();
public:
virtual WaitHandle^ ConnectAsync() override

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.

Implements

IClientConnectAsync
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to connect the ZeroMQClient when it is not disconnected.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.Disconnect Method

Grid Solutions Framework ZeroMQClientDisconnect Method
Disconnects the ZeroMQClient from the connected server synchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Disconnect()
Public Overrides Sub Disconnect
abstract Disconnect : unit -> unit
override Disconnect : unit -> unit
function Disconnect();
public:
virtual void Disconnect() override

Implements

IClientDisconnect
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.Dispose Method

Grid Solutions Framework ZeroMQClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ZeroMQClient and optionally releases the managed resources. (Overrides ClientBaseDispose(Boolean).)
Top
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.Dispose Method (Boolean)

Grid Solutions Framework ZeroMQClientDispose Method (Boolean)
Releases the unmanaged resources used by the ZeroMQClient and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ZeroMQClient Class
Dispose Overload
GSF.Communication Namespace


ZeroMQClient.LoadSettings Method

Grid Solutions Framework ZeroMQClientLoadSettings Method
Loads saved TcpClient settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.OnConnectionException Method

Grid Solutions Framework ZeroMQClientOnConnectionException Method
Raises the ConnectionException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnConnectionException(
    Exception ex
)
Protected Overrides Sub OnConnectionException (
    ex As Exception
)
abstract OnConnectionException :
        ex : Exception -> unit
override OnConnectionException :
        ex : Exception -> unit
function OnConnectionException(ex);
protected:
virtual void OnConnectionException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ConnectionException event.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.OnDisconnectException Method

Grid Solutions Framework ZeroMQClientOnDisconnectException Method
Raises the SendDataException event for disconnect exceptions.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDisconnectException(
    Exception ex
)
Protected Overridable Sub OnDisconnectException (
    ex As Exception
)
abstract OnDisconnectException :
        ex : Exception -> unit
override OnDisconnectException :
        ex : Exception -> unit
function OnDisconnectException(ex);
protected:
virtual void OnDisconnectException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Disconnect exception to send to SendDataException event.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.OnReceiveDataException Method

Grid Solutions Framework ZeroMQClientOnReceiveDataException Method
Raises the ReceiveDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceiveDataException(
    Exception ex
)
Protected Overrides Sub OnReceiveDataException (
    ex As Exception
)
abstract OnReceiveDataException :
        ex : Exception -> unit
override OnReceiveDataException :
        ex : Exception -> unit
function OnReceiveDataException(ex);
protected:
virtual void OnReceiveDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to ReceiveDataException event.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.OnSendDataException Method

Grid Solutions Framework ZeroMQClientOnSendDataException Method
Raises the SendDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnSendDataException(
    Exception ex
)
Protected Overrides Sub OnSendDataException (
    ex As Exception
)
abstract OnSendDataException :
        ex : Exception -> unit
override OnSendDataException :
        ex : Exception -> unit
function OnSendDataException(ex);
protected:
virtual void OnSendDataException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to SendDataException event.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.OnUnhandledUserException Method

Grid Solutions Framework ZeroMQClientOnUnhandledUserException Method
Raises the UnhandledUserException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnUnhandledUserException(
    Exception ex
)
Protected Overrides Sub OnUnhandledUserException (
    ex As Exception
)
abstract OnUnhandledUserException :
        ex : Exception -> unit
override OnUnhandledUserException :
        ex : Exception -> unit
function OnUnhandledUserException(ex);
protected:
virtual void OnUnhandledUserException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to UnhandledUserException event.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.Read Method

Grid Solutions Framework ZeroMQClientRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IClientRead(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.SaveSettings Method

Grid Solutions Framework ZeroMQClientSaveSettings Method
Saves TcpClient settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.SendDataAsync Method

Grid Solutions Framework ZeroMQClientSendDataAsync Method
Sends data to the server asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataAsync(
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataAsync (
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataAsync :
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataAsync(data, offset, length);
protected:
virtual WaitHandle^ SendDataAsync(
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.ValidateConnectionString Method

Grid Solutions Framework ZeroMQClientValidateConnectionString Method
Validates the specified connectionString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConnectionString(
    string connectionString
)
Protected Overrides Sub ValidateConnectionString (
    connectionString As String
)
abstract ValidateConnectionString :
        connectionString : string -> unit
override ValidateConnectionString :
        connectionString : string -> unit
function ValidateConnectionString(connectionString);
protected:
virtual void ValidateConnectionString(
    String^ connectionString
) override

Parameters

connectionString
Type: SystemString
Connection string to be validated.
Exceptions
Exception | Condition
ArgumentException | Server property is missing.
FormatException | Server property is invalid.
ArgumentOutOfRangeException | Server port value is not between PortRangeLow and PortRangeHigh.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient Properties

Grid Solutions Framework ZeroMQClient Properties

The ZeroMQClient type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Client | Gets the Socket object for the ZeroMQClient.
Public property | ConnectionString | Gets or sets the data required by the client to connect to the server. (Inherited from ClientBase.)
Public property | ConnectionTime | Gets the Time for which the client has been connected to the server. (Inherited from ClientBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ClientState. (Inherited from ClientBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the client is currently enabled. (Inherited from ClientBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ClientBase.)
Public property | MaxConnectionAttempts | Gets or sets the maximum number of times the client will attempt to connect to the server. (Inherited from ClientBase.)
Public property | MaxReceiveQueueSize | Gets or sets the maximum size for the receive queue before payloads are dumped from the queue.
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the client. (Inherited from ClientBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the client settings are to be saved to the config file. (Inherited from ClientBase.)
Protected property | ReadIndex | Gets or sets current read index for received data buffer incremented at each Read(Byte, Int32, Int32) call. (Inherited from ClientBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the client for receiving data from the server. (Inherited from ClientBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the client for sending data to the server. (Inherited from ClientBase.)
Public property | ServerUri | Gets the server URI of the ZeroMQClient. (Overrides ClientBaseServerUri.)
Public property | SettingsCategory | Gets or sets the category under which the client settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ClientBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ClientBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the server. (Inherited from ClientBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the client for the transportation of data with the server. (Overrides ClientBaseTransportProtocol.)
Public property | ZeroMQTransportProtocol | Gets or sets the ZeroMQ transport protocol to use for the ZeroMQClient.
Top
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.Client Property

Grid Solutions Framework ZeroMQClientClient Property
Gets the Socket object for the ZeroMQClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ZSocket Client { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Client As ZSocket
    Get
[<BrowsableAttribute(false)>]
member Client : ZSocket with get

function get_Client();

public:
[BrowsableAttribute(false)]
property ZSocket^ Client {
    ZSocket^ get ();
}

Property Value

Type: ZSocket
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.MaxReceiveQueueSize Property

Grid Solutions Framework ZeroMQClientMaxReceiveQueueSize Property
Gets or sets the maximum size for the receive queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxReceiveQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxReceiveQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxReceiveQueueSize : int with get, set

function get_MaxReceiveQueueSize();
function set_MaxReceiveQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxReceiveQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for inbound messages.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.MaxSendQueueSize Property

Grid Solutions Framework ZeroMQClientMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for outbound messages.
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.ServerUri Property

Grid Solutions Framework ZeroMQClientServerUri Property
Gets the server URI of the ZeroMQClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override string ServerUri { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ServerUri As String
    Get
[<BrowsableAttribute(false)>]
abstract ServerUri : string with get
[<BrowsableAttribute(false)>]
override ServerUri : string with get
function get_ServerUri();

public:
[BrowsableAttribute(false)]
virtual property String^ ServerUri {
    String^ get () override;
}

Property Value

Type: String

Implements

IClientServerUri
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.Status Property

Grid Solutions Framework ZeroMQClientStatus Property
Gets the descriptive status of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.TransportProtocol Property

Grid Solutions Framework ZeroMQClientTransportProtocol Property
Gets the TransportProtocol used by the client for the transportation of data with the server.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override TransportProtocol TransportProtocol { get; }
Public Overrides ReadOnly Property TransportProtocol As TransportProtocol
    Get
abstract TransportProtocol : TransportProtocol with get
override TransportProtocol : TransportProtocol with get
function get_TransportProtocol();

public:
virtual property TransportProtocol TransportProtocol {
    TransportProtocol get () override;
}

Property Value

Type: TransportProtocol

Implements

IClientTransportProtocol
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient.ZeroMQTransportProtocol Property

Grid Solutions Framework ZeroMQClientZeroMQTransportProtocol Property
Gets or sets the ZeroMQ transport protocol to use for the ZeroMQClient.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(ZeroMQTransportProtocol.Tcp)]
public ZeroMQTransportProtocol ZeroMQTransportProtocol { get; set; }
<DefaultValueAttribute(ZeroMQTransportProtocol.Tcp)>
Public Property ZeroMQTransportProtocol As ZeroMQTransportProtocol
    Get
    Set
[<DefaultValueAttribute(ZeroMQTransportProtocol.Tcp)>]
member ZeroMQTransportProtocol : ZeroMQTransportProtocol with get, set

function get_ZeroMQTransportProtocol();
function set_ZeroMQTransportProtocol(value);
public:
[DefaultValueAttribute(ZeroMQTransportProtocol::Tcp)]
property ZeroMQTransportProtocol ZeroMQTransportProtocol {
    ZeroMQTransportProtocol get ();
    void set (ZeroMQTransportProtocol value);
}

Property Value

Type: ZeroMQTransportProtocol
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQClient Events

Grid Solutions Framework ZeroMQClient Events

The ZeroMQClient type exposes the following members.

Events
 | Name | Description
Public event | ConnectionAttempt | Occurs when client is attempting connection to the server. (Inherited from ClientBase.)
Public event | ConnectionEstablished | Occurs when client connection to the server is established. (Inherited from ClientBase.)
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to the server. (Inherited from ClientBase.)
Public event | ConnectionTerminated | Occurs when client connection to the server is terminated. (Inherited from ClientBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveData | Occurs when unprocessed data has been received from the server. (Inherited from ClientBase.)
Public event | ReceiveDataComplete | Occurs when data received from the server has been processed and is ready for consumption. (Inherited from ClientBase.)
Public event | ReceiveDataException | Occurs when an Exception is encountered when receiving data from the server. (Inherited from ClientBase.)
Public event | SendDataComplete | Occurs when the client has successfully sent data to the server. (Inherited from ClientBase.)
Public event | SendDataException | Occurs when an Exception is encountered when sending data to the server. (Inherited from ClientBase.)
Public event | SendDataStart | Occurs when the client begins sending data to the server. (Inherited from ClientBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ClientBase.)
Top
See Also

Reference

ZeroMQClient Class
GSF.Communication Namespace


ZeroMQServer Class

Grid Solutions Framework ZeroMQServer Class
Represents a ZeroMQ ROUTER style socket as a communication server.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.CommunicationServerBase
GSF.CommunicationZeroMQServer

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ZeroMQServer : ServerBase
Public Class ZeroMQServer
    Inherits ServerBase
type ZeroMQServer =
    class
        inherit ServerBase
    end
GSF.Communication.ZeroMQServer = function();

Type.createClass(
    'GSF.Communication.ZeroMQServer',
    GSF.Communication.ServerBase);
public ref class ZeroMQServer : public ServerBase

The ZeroMQServer type exposes the following members.

Constructors
 | Name | Description
Public method | ZeroMQServer | Initializes a new instance of the ZeroMQServer class.
Public method | ZeroMQServer(IContainer) | Initializes a new instance of the ZeroMQServer class.
Public method | ZeroMQServer(String) | Initializes a new instance of the ZeroMQServer class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ZeroMQServer object and optionally releases the managed resources. (Overrides ServerBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved ZeroMQServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Overrides ServerBaseOnClientConnectingException(Exception).)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event. (Overrides ServerBaseOnReceiveClientDataException(Guid, Exception).)
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Overrides ServerBaseOnSendClientDataException(Guid, Exception).)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Overrides ServerBaseOnUnhandledUserException(Exception).)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves ZeroMQServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the ZeroMQServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the ZeroMQServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
DefaultMaxReceiveQueueSize | Specifies the default value for the MaxReceiveQueueSize property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
EndpointFormatRegex | Regular expression used to validate the format for a ZeroMQ endpoint.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxReceiveQueueSize | Gets or sets the maximum size for the receive queue before payloads are dumped from the queue.
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the ZeroMQServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Overrides ServerBaseTransportProtocol.)
Public property | ZeroMQTransportProtocol | Gets or sets the ZeroMQ transport protocol to use for the ZeroMQServer.
Top
Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
See Also

Reference

GSF.Communication Namespace


ZeroMQServer Constructor

Grid Solutions Framework ZeroMQServer Constructor
Overload List
 | Name | Description
Public method | ZeroMQServer | Initializes a new instance of the ZeroMQServer class.
Public method | ZeroMQServer(IContainer) | Initializes a new instance of the ZeroMQServer class.
Public method | ZeroMQServer(String) | Initializes a new instance of the ZeroMQServer class.
Top
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer Constructor

Grid Solutions Framework ZeroMQServer Constructor
Initializes a new instance of the ZeroMQServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ZeroMQServer()
Public Sub New
new : unit -> ZeroMQServer
GSF.Communication.ZeroMQServer = function();
public:
ZeroMQServer()
See Also

Reference

ZeroMQServer Class
ZeroMQServer Overload
GSF.Communication Namespace


ZeroMQServer Constructor (IContainer)

Grid Solutions Framework ZeroMQServer Constructor (IContainer)
Initializes a new instance of the ZeroMQServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ZeroMQServer(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ZeroMQServer
GSF.Communication.ZeroMQServer = function(container);
public:
ZeroMQServer(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the ZeroMQServer.
See Also

Reference

ZeroMQServer Class
ZeroMQServer Overload
GSF.Communication Namespace


ZeroMQServer Constructor (String)

Grid Solutions Framework ZeroMQServer Constructor (String)
Initializes a new instance of the ZeroMQServer class.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ZeroMQServer(
    string configString
)
Public Sub New (
    configString As String
)
new :
        configString : string -> ZeroMQServer
GSF.Communication.ZeroMQServer = function(configString);
public:
ZeroMQServer(
    String^ configString
)

Parameters

configString
Type: SystemString
Config string of the ZeroMQServer. See DefaultConfigurationString for format.
See Also

Reference

ZeroMQServer Class
ZeroMQServer Overload
GSF.Communication Namespace


ZeroMQServer Fields

Grid Solutions Framework ZeroMQServer Fields

The ZeroMQServer type exposes the following members.

Fields
Name | Description
DefaultConfigurationString | Specifies the default value for the ConfigurationString property.
DefaultMaxReceiveQueueSize | Specifies the default value for the MaxReceiveQueueSize property.
DefaultMaxSendQueueSize | Specifies the default value for the MaxSendQueueSize property.
EndpointFormatRegex | Regular expression used to validate the format for a ZeroMQ endpoint.
Top
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.DefaultConfigurationString Field

Grid Solutions Framework ZeroMQServerDefaultConfigurationString Field
Specifies the default value for the ConfigurationString property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConfigurationString
Public Const DefaultConfigurationString As String
static val mutable DefaultConfigurationString: string
var GSF.Communication.ZeroMQServer.DefaultConfigurationString
public:
literal String^ DefaultConfigurationString

Field Value

Type: String
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.DefaultMaxReceiveQueueSize Field

Grid Solutions Framework ZeroMQServerDefaultMaxReceiveQueueSize Field
Specifies the default value for the MaxReceiveQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxReceiveQueueSize
Public Const DefaultMaxReceiveQueueSize As Integer
static val mutable DefaultMaxReceiveQueueSize: int
var GSF.Communication.ZeroMQServer.DefaultMaxReceiveQueueSize
public:
literal int DefaultMaxReceiveQueueSize

Field Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for inbound messages.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.DefaultMaxSendQueueSize Field

Grid Solutions Framework ZeroMQServerDefaultMaxSendQueueSize Field
Specifies the default value for the MaxSendQueueSize property.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxSendQueueSize
Public Const DefaultMaxSendQueueSize As Integer
static val mutable DefaultMaxSendQueueSize: int
var GSF.Communication.ZeroMQServer.DefaultMaxSendQueueSize
public:
literal int DefaultMaxSendQueueSize

Field Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for outbound messages.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.EndpointFormatRegex Field

Grid Solutions Framework ZeroMQServerEndpointFormatRegex Field
Regular expression used to validate the format for a ZeroMQ endpoint.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string EndpointFormatRegex
Public Const EndpointFormatRegex As String
static val mutable EndpointFormatRegex: string
var GSF.Communication.ZeroMQServer.EndpointFormatRegex
public:
literal String^ EndpointFormatRegex

Field Value

Type: String
Remarks

Matches the following valid example input:
- tcp://127.0.0.1:5959
- tcp://[::1]:5959
- tcp://dnsname.org:8186
- pgm://[FF01:0:0:0:0:0:0:1]:6565
- pgm://224.0.0.1:6565
- inproc://pipe-name

See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer Methods

Grid Solutions Framework ZeroMQServer Methods

The ZeroMQServer type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the server properties are initialized. (Inherited from ServerBase.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DisconnectAll | Disconnects all of the connected clients. (Inherited from ServerBase.)
Public method | DisconnectOne | Disconnects the specified connected client. (Overrides ServerBaseDisconnectOne(Guid).)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ZeroMQServer object and optionally releases the managed resources. (Overrides ServerBaseDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the server properties are initialized. (Inherited from ServerBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the server. (Inherited from ServerBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved ZeroMQServer settings from the config file if the PersistSettings property is set to true. (Overrides ServerBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Multicast(Byte) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Object) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(String) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | Multicast(Byte, Int32, Int32) | Sends data to all of the connected clients synchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Object) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(String) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Public method | MulticastAsync(Byte, Int32, Int32) | Sends data to all of the connected clients asynchronously. (Inherited from ServerBase.)
Protected method | OnClientConnected | Raises the ClientConnected event. (Inherited from ServerBase.)
Protected method | OnClientConnectingException | Raises the ClientConnectingException event. (Overrides ServerBaseOnClientConnectingException(Exception).)
Protected method | OnClientDisconnected | Raises the ClientDisconnected event. (Inherited from ServerBase.)
Protected method | OnReceiveClientData | Raises the ReceiveClientData event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataComplete | Raises the ReceiveClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnReceiveClientDataException | Raises the ReceiveClientDataException event. (Overrides ServerBaseOnReceiveClientDataException(Guid, Exception).)
Protected method | OnSendClientDataComplete | Raises the SendClientDataComplete event. (Inherited from ServerBase.)
Protected method | OnSendClientDataException | Raises the SendClientDataException event. (Overrides ServerBaseOnSendClientDataException(Guid, Exception).)
Protected method | OnSendClientDataStart | Raises the SendClientDataStart event. (Inherited from ServerBase.)
Protected method | OnServerStarted | Raises the ServerStarted event. (Inherited from ServerBase.)
Protected method | OnServerStopped | Raises the ServerStopped event. (Inherited from ServerBase.)
Protected method | OnUnhandledUserException | Raises the UnhandledUserException event. (Overrides ServerBaseOnUnhandledUserException(Exception).)
Public method | Read | Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset. (Overrides ServerBaseRead(Guid, Byte, Int32, Int32).)
Protected method | ReStart | Re-starts the server if currently running. (Inherited from ServerBase.)
Public method | SaveSettings | Saves ZeroMQServer settings to the config file if the PersistSettings property is set to true. (Overrides ServerBaseSaveSettings.)
Protected method | SendDataToAsync | Sends data to the specified client asynchronously. (Overrides ServerBaseSendDataToAsync(Guid, Byte, Int32, Int32).)
Public method | SendTo(Guid, Byte) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Object) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, String) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendTo(Guid, Byte, Int32, Int32) | Sends data to the specified client synchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Object) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, String) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | SendToAsync(Guid, Byte, Int32, Int32) | Sends data to the specified client asynchronously. (Inherited from ServerBase.)
Public method | Start | Starts the ZeroMQServer synchronously and begins accepting client connections asynchronously. (Overrides ServerBaseStart.)
Public method | Stop | Stops the ZeroMQServer synchronously and disconnects all connected clients. (Overrides ServerBaseStop.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | TryGetClient | Gets the TransportProviderT object associated with the specified client ID.
Protected method | ValidateConfigurationString | Validates the specified configurationString. (Overrides ServerBaseValidateConfigurationString(String).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.DisconnectOne Method

Grid Solutions Framework ZeroMQServerDisconnectOne Method
Disconnects the specified connected client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void DisconnectOne(
    Guid clientID
)
Public Overrides Sub DisconnectOne (
    clientID As Guid
)
abstract DisconnectOne :
        clientID : Guid -> unit
override DisconnectOne :
        clientID : Guid -> unit
function DisconnectOne(clientID);
public:
virtual void DisconnectOne(
    Guid clientID
) override

Parameters

clientID
Type: SystemGuid
ID of the client to be disconnected.

Implements

IServerDisconnectOne(Guid)
Exceptions
Exception | Condition
InvalidOperationException | Client does not exist for the specified clientID.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.Dispose Method

Grid Solutions Framework ZeroMQServerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ZeroMQServer object and optionally releases the managed resources. (Overrides ServerBaseDispose(Boolean).)
Top
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.Dispose Method (Boolean)

Grid Solutions Framework ZeroMQServerDispose Method (Boolean)
Releases the unmanaged resources used by the ZeroMQServer object and optionally releases the managed resources.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ZeroMQServer Class
Dispose Overload
GSF.Communication Namespace


ZeroMQServer.LoadSettings Method

Grid Solutions Framework ZeroMQServerLoadSettings Method
Loads saved ZeroMQServer settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.OnClientConnectingException Method

Grid Solutions Framework ZeroMQServerOnClientConnectingException Method
Raises the ClientConnectingException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnClientConnectingException(
    Exception ex
)
Protected Overrides Sub OnClientConnectingException (
    ex As Exception
)
abstract OnClientConnectingException :
        ex : Exception -> unit
override OnClientConnectingException :
        ex : Exception -> unit
function OnClientConnectingException(ex);
protected:
virtual void OnClientConnectingException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
The Exception encountered when connecting to the client.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.OnReceiveClientDataException Method

Grid Solutions Framework ZeroMQServerOnReceiveClientDataException Method
Raises the ReceiveClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceiveClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overrides Sub OnReceiveClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnReceiveClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnReceiveClientDataException(clientID, ex);
protected:
virtual void OnReceiveClientDataException(
    Guid clientID,
    Exception^ ex
) override

Parameters

clientID
Type: SystemGuid
ID of client to send to ReceiveClientDataException event.
ex
Type: SystemException
Exception to send to ReceiveClientDataException event.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.OnSendClientDataException Method

Grid Solutions Framework ZeroMQServerOnSendClientDataException Method
Raises the SendClientDataException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnSendClientDataException(
    Guid clientID,
    Exception ex
)
Protected Overrides Sub OnSendClientDataException (
    clientID As Guid,
    ex As Exception
)
abstract OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
override OnSendClientDataException :
        clientID : Guid *
        ex : Exception -> unit
function OnSendClientDataException(clientID, ex);
protected:
virtual void OnSendClientDataException(
    Guid clientID,
    Exception^ ex
) override

Parameters

clientID
Type: SystemGuid
ID of client to send to SendClientDataException event.
ex
Type: SystemException
Exception to send to SendClientDataException event.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.OnUnhandledUserException Method

Grid Solutions Framework ZeroMQServerOnUnhandledUserException Method
Raises the UnhandledUserException event.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnUnhandledUserException(
    Exception ex
)
Protected Overrides Sub OnUnhandledUserException (
    ex As Exception
)
abstract OnUnhandledUserException :
        ex : Exception -> unit
override OnUnhandledUserException :
        ex : Exception -> unit
function OnUnhandledUserException(ex);
protected:
virtual void OnUnhandledUserException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
Exception to send to UnhandledUserException event.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.Read Method

Grid Solutions Framework ZeroMQServerRead Method
Reads a number of bytes from the current received data buffer and writes those bytes into a byte array at the specified offset.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    Guid clientID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    clientID As Guid,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        clientID : Guid *
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(clientID, buffer, startIndex, length);
public:
virtual int Read(
    Guid clientID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client from which data buffer should be read.
buffer
Type: SystemByte
Destination buffer used to hold copied bytes.
startIndex
Type: SystemInt32
0-based starting index into destination buffer to begin writing data.
length
Type: SystemInt32
The number of bytes to read from current received data buffer and write into buffer.

Return Value

Type: Int32
The number of bytes read.

Implements

IServerRead(Guid, Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | No received data buffer has been defined to read -or- Specified clientID does not exist, cannot read buffer.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This function should only be called from within the ReceiveClientData event handler. Calling this method outside this event will have unexpected results.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.SaveSettings Method

Grid Solutions Framework ZeroMQServerSaveSettings Method
Saves ZeroMQServer settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.SendDataToAsync Method

Grid Solutions Framework ZeroMQServerSendDataToAsync Method
Sends data to the specified client asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override WaitHandle SendDataToAsync(
    Guid clientID,
    byte[] data,
    int offset,
    int length
)
Protected Overrides Function SendDataToAsync (
    clientID As Guid,
    data As Byte(),
    offset As Integer,
    length As Integer
) As WaitHandle
abstract SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
override SendDataToAsync :
        clientID : Guid *
        data : byte[] *
        offset : int *
        length : int -> WaitHandle
function SendDataToAsync(clientID, data, offset, length);
protected:
virtual WaitHandle^ SendDataToAsync(
    Guid clientID,
    array<unsigned char>^ data,
    int offset,
    int length
) override

Parameters

clientID
Type: SystemGuid
ID of the client to which the data is to be sent.
data
Type: SystemByte
The buffer that contains the binary data to be sent.
offset
Type: SystemInt32
The zero-based position in the data at which to begin sending data.
length
Type: SystemInt32
The number of bytes to be sent from data starting at the offset.

Return Value

Type: WaitHandle
WaitHandle for the asynchronous operation.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.Start Method

Grid Solutions Framework ZeroMQServerStart Method
Starts the ZeroMQServer synchronously and begins accepting client connections asynchronously.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IServerStart
Exceptions
Exception | Condition
InvalidOperationException | Attempt is made to Start the ZeroMQServer when it is running.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.Stop Method

Grid Solutions Framework ZeroMQServerStop Method
Stops the ZeroMQServer synchronously and disconnects all connected clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Stop()
Public Overrides Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() override

Implements

IServerStop
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.TryGetClient Method

Grid Solutions Framework ZeroMQServerTryGetClient Method
Gets the TransportProviderT object associated with the specified client ID.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetClient(
    Guid clientID,
    out TransportProvider<DateTime> clientInfo
)
Public Function TryGetClient (
    clientID As Guid,
    <OutAttribute> ByRef clientInfo As TransportProvider(Of DateTime)
) As Boolean
member TryGetClient :
        clientID : Guid *
        clientInfo : TransportProvider<DateTime> byref -> bool

function TryGetClient(clientID, clientInfo);
public:
bool TryGetClient(
    Guid clientID,
    [OutAttribute] TransportProvider<DateTime>^% clientInfo
)

Parameters

clientID
Type: SystemGuid
ID of the client.
clientInfo
Type: GSF.CommunicationTransportProvider DateTime
Client information.

Return Value

Type: Boolean
true if client exists; otherwise, false.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.ValidateConfigurationString Method

Grid Solutions Framework ZeroMQServerValidateConfigurationString Method
Validates the specified configurationString.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ValidateConfigurationString(
    string configurationString
)
Protected Overrides Sub ValidateConfigurationString (
    configurationString As String
)
abstract ValidateConfigurationString :
        configurationString : string -> unit
override ValidateConfigurationString :
        configurationString : string -> unit
function ValidateConfigurationString(configurationString);
protected:
virtual void ValidateConfigurationString(
    String^ configurationString
) override

Parameters

configurationString
Type: SystemString
Configuration string to be validated.
Exceptions
Exception | Condition
ArgumentException | Port property is missing.
ArgumentOutOfRangeException | Port property value is not between PortRangeLow and PortRangeHigh.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer Properties

Grid Solutions Framework ZeroMQServer Properties

The ZeroMQServer type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientIDs | Gets the IDs of clients connected to the server. (Inherited from ServerBase.)
Public property | ConfigurationString | Gets or sets the data required by the server to initialize. (Inherited from ServerBase.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentState | Gets the current ServerState. (Inherited from ServerBase.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the server is currently enabled. (Inherited from ServerBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Protected property | Initialized | Gets a boolean value that indicates whether the server has been initialized. (Inherited from ServerBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ServerBase.)
Public property | MaxClientConnections | Gets or sets the maximum number of clients that can connect to the server. (Inherited from ServerBase.)
Public property | MaxReceiveQueueSize | Gets or sets the maximum size for the receive queue before payloads are dumped from the queue.
Public property | MaxSendQueueSize | Gets or sets the maximum size for the send queue before payloads are dumped from the queue.
Public property | Name | Gets the unique identifier of the server. (Inherited from ServerBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the server settings are to be saved to the config file. (Inherited from ServerBase.)
Protected property | ReadIndicies | Gets current read indices for received data buffers incremented at each Read(Guid, Byte, Int32, Int32) call. (Inherited from ServerBase.)
Public property | ReceiveBufferSize | Gets or sets the size of the buffer used by the server for receiving data from the clients. (Inherited from ServerBase.)
Public property | RunTime | Gets the Time for which the server has been running. (Inherited from ServerBase.)
Public property | SendBufferSize | Gets or sets the size of the buffer used by the server for sending data to the clients. (Inherited from ServerBase.)
Public property | Server | Gets the Socket object for the ZeroMQServer.
Public property | ServerID | Gets the server's ID. (Inherited from ServerBase.)
Public property | SettingsCategory | Gets or sets the category under which the server settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ServerBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the client. (Overrides ServerBaseStatus.)
Public property | TextEncoding | Gets or sets the Encoding to be used for the text sent to the connected clients. (Inherited from ServerBase.)
Public property | TransportProtocol | Gets the TransportProtocol used by the server for the transportation of data with the clients. (Overrides ServerBaseTransportProtocol.)
Public property | ZeroMQTransportProtocol | Gets or sets the ZeroMQ transport protocol to use for the ZeroMQServer.
Top
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.MaxReceiveQueueSize Property

Grid Solutions Framework ZeroMQServerMaxReceiveQueueSize Property
Gets or sets the maximum size for the receive queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxReceiveQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxReceiveQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxReceiveQueueSize : int with get, set

function get_MaxReceiveQueueSize();
function set_MaxReceiveQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxReceiveQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for inbound messages.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.MaxSendQueueSize Property

Grid Solutions Framework ZeroMQServerMaxSendQueueSize Property
Gets or sets the maximum size for the send queue before payloads are dumped from the queue.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(500000)]
public int MaxSendQueueSize { get; set; }
<DefaultValueAttribute(500000)>
Public Property MaxSendQueueSize As Integer
    Get
    Set
[<DefaultValueAttribute(500000)>]
member MaxSendQueueSize : int with get, set

function get_MaxSendQueueSize();
function set_MaxSendQueueSize(value);
public:
[DefaultValueAttribute(500000)]
property int MaxSendQueueSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Maps to ZeroMQ high water mark setting for outbound messages.
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.Server Property

Grid Solutions Framework ZeroMQServerServer Property
Gets the Socket object for the ZeroMQServer.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ZSocket Server { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Server As ZSocket
    Get
[<BrowsableAttribute(false)>]
member Server : ZSocket with get

function get_Server();

public:
[BrowsableAttribute(false)]
property ZSocket^ Server {
    ZSocket^ get ();
}

Property Value

Type: ZSocket
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.Status Property

Grid Solutions Framework ZeroMQServerStatus Property
Gets the descriptive status of the client.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.TransportProtocol Property

Grid Solutions Framework ZeroMQServerTransportProtocol Property
Gets the TransportProtocol used by the server for the transportation of data with the clients.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override TransportProtocol TransportProtocol { get; }
Public Overrides ReadOnly Property TransportProtocol As TransportProtocol
    Get
abstract TransportProtocol : TransportProtocol with get
override TransportProtocol : TransportProtocol with get
function get_TransportProtocol();

public:
virtual property TransportProtocol TransportProtocol {
    TransportProtocol get () override;
}

Property Value

Type: TransportProtocol

Implements

IServerTransportProtocol
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer.ZeroMQTransportProtocol Property

Grid Solutions Framework ZeroMQServerZeroMQTransportProtocol Property
Gets or sets the ZeroMQ transport protocol to use for the ZeroMQServer.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(ZeroMQTransportProtocol.Tcp)]
public ZeroMQTransportProtocol ZeroMQTransportProtocol { get; set; }
<DefaultValueAttribute(ZeroMQTransportProtocol.Tcp)>
Public Property ZeroMQTransportProtocol As ZeroMQTransportProtocol
    Get
    Set
[<DefaultValueAttribute(ZeroMQTransportProtocol.Tcp)>]
member ZeroMQTransportProtocol : ZeroMQTransportProtocol with get, set

function get_ZeroMQTransportProtocol();
function set_ZeroMQTransportProtocol(value);
public:
[DefaultValueAttribute(ZeroMQTransportProtocol::Tcp)]
property ZeroMQTransportProtocol ZeroMQTransportProtocol {
    ZeroMQTransportProtocol get ();
    void set (ZeroMQTransportProtocol value);
}

Property Value

Type: ZeroMQTransportProtocol
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQServer Events

Grid Solutions Framework ZeroMQServer Events

The ZeroMQServer type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Occurs when a client connects to the server. (Inherited from ServerBase.)
Public event | ClientConnectingException | Occurs when an exception is encountered while a client is connecting. (Inherited from ServerBase.)
Public event | ClientDisconnected | Occurs when a client disconnects from the server. (Inherited from ServerBase.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ReceiveClientData | Occurs when unprocessed data has been received from a client. (Inherited from ServerBase.)
Public event | ReceiveClientDataComplete | Occurs when data received from a client has been processed and is ready for consumption. (Inherited from ServerBase.)
Public event | ReceiveClientDataException | Occurs when an Exception is encountered when receiving data from a client. (Inherited from ServerBase.)
Public event | SendClientDataComplete | Occurs when data has been sent to a client. (Inherited from ServerBase.)
Public event | SendClientDataException | Occurs when an Exception is encountered when sending data to a client. (Inherited from ServerBase.)
Public event | SendClientDataStart | Occurs when data is being sent to a client. (Inherited from ServerBase.)
Public event | ServerStarted | Occurs when the server is started. (Inherited from ServerBase.)
Public event | ServerStopped | Occurs when the server is stopped. (Inherited from ServerBase.)
Public event | UnhandledUserException | Occurs when an Exception is encountered in a user-defined function via an event dispatch. (Inherited from ServerBase.)
Top
See Also

Reference

ZeroMQServer Class
GSF.Communication Namespace


ZeroMQTransportProtocol Enumeration

Grid Solutions Framework ZeroMQTransportProtocol Enumeration
Indicates the transport protocol used in ZeroMQ communications.

Namespace: GSF.Communication
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ZeroMQTransportProtocol
Public Enumeration ZeroMQTransportProtocol
type ZeroMQTransportProtocol
GSF.Communication.ZeroMQTransportProtocol = function();
GSF.Communication.ZeroMQTransportProtocol.createEnum('GSF.Communication.ZeroMQTransportProtocol', false);
public enum class ZeroMQTransportProtocol
Members
Member name | Value | Description
Tcp | 0 | Transmission Control Protocol.
InProc | 1 | In-process Transmissions.
Pgm | 2 | Pragmatic General Multicast.
Epgm | 2 | Encapsulated PGM.
See Also

Reference

GSF.Communication Namespace


GSF.Communication.Radius Namespace

Grid Solutions Framework GSF.Communication.Radius Namespace
Contains classes for RADIUS (Remote Authentication Dial In User Service) based server and client communication.
Classes
 | Class | Description
Public class | RadiusClient | Represents a RADIUS communication client.
Public class | RadiusPacket | Represents a data packet transferred between RADIUS client and server.
Public class | RadiusPacketAttribute | Represents an attribute of RadiusPacket.
Enumerations
 | Enumeration | Description
Public enumeration | AttributeType | Specifies the type of RadiusPacketAttribute.
Public enumeration | PacketType | Specifies the type of the RadiusPacket.


AttributeType Enumeration

Grid Solutions Framework AttributeType Enumeration
Specifies the type of RadiusPacketAttribute.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum AttributeType
Public Enumeration AttributeType
type AttributeType
GSF.Communication.Radius.AttributeType = function();
GSF.Communication.Radius.AttributeType.createEnum('GSF.Communication.Radius.AttributeType', false);
public enum class AttributeType
Members
Member name | Value | Description
UserName | 1 | Attribute indicates the name of the user to be authenticated.
UserPassword | 2 | Attribute indicates the password of the user to be authenticated.
ChapPassword | 3 | Attribute indicates the response provided by a PPP CHAP user in reponse to the challenge.
NasIpAddress | 4 | Attribute indicates the identifying IP address of the NAS requesting user authentication.
NasPort | 5 | Attribute indicates the physical port number of the NAS which is authenticating the user.
ServiceType | 6 | Attribute indicates the type of service the user has requested, or the type of service to be provided.
FramedProtocol | 7 | Attribute indicates the framing to be used for framed access.
FramedIpAddress | 8 | Attribute indicates the address to be configured for the user.
FramedIpNetmask | 9 | Attribute indicates the IP netmask to be configured for the user when user is a router to a network.
FramedRouting | 10 | Attribute indicates the routing method for the user when user is a router to a network.
FilterId | 11 | Attribute indicates the name of the filter list for this user.
FramedMtu | 12 | Attribute indicates the MTU to be configured for the user when it is not negotiated by some other means.
FramedCompression | 13 | Attribute indicates a compression protocol to be used for the link.
LoginIpHost | 14 | Attribute indicates the system with which to connect the user when LoginService attribute is included.
LoginService | 15 | Attribute indicates the service to use to connect the user to the login host.
LoginTcpPort | 16 | Attribute indicates the TCP port with which the user is to be connected when LoginService attribute is included.
ReplyMessage | 18 | Attribute indicates the text which may be displayed to the user.
CallbackNumber | 19 | Attribute indicates a dialing string to be used for callback.
CallbackId | 20 | Attribute indicates the name of a place to be called.
FramedRoute | 22 | Attribute provides routing information to be configured for the user on the NAS.
FramedIpxNetwork | 23 | Attribute indicates the IPX Network number to be configured for the user.
State | 24 | Attribute available to be sent by the server to the client in an AccessChallenge and must be sent unmodified from the client to the server in the new AccessRequest reply to the challenge.
Class | 25 | Attribute available to be sent by the server to the client in an AccessAccept and should be sent unmodified by the client to the accounting server as part of the AccountingRequest.
VendorSpecific | 26 | Attribute available to allow vendors to support their own extended attributes.
SessionTimeout | 27 | Attribute sets the maximum number of seconds of service to be provided to the user before termination of the session or prompt.
IdleTimeout | 28 | Attribute sets the maximum number of consecutive seconds of idle connection allowed to the user before termination of the session or prompt.
TerminationAction | 29 | Attribute indicates the action the NAS should take when the specified service is complete.
CallerStationId | 30 | Attribute indicates the phone number that the user called using DNIS or similar technology.
CallingStationId | 31 | Attribute indicates the phone number the call came from using ANI or similar technology.
NasIdentifier | 32 | Attribute indicates a string identifier for the NAS originating the AccessRequest.
ProxyState | 33 | Attribute indicates the state a proxy server forwarding requests to the server.
LoginLatService | 34 | Attribute indicates the system with which the user is to be connected by LAT.
LoginLatNode | 35 | Attribute indicates the Node with which the user is to be automatically connected by LAT.
LoginLatGroup | 36 | Attribute indicates the string identifier for the LAT group codes which the user is authorized to use.
FramedAppleTalkLink | 37 | Attribute indicates the AppleTalk network number which should be used for the serial link to the user.
FramedAppleTalkNetwork | 38 | Attribute indicates the AppleTalk Network number which the NAS should probe to allocate an AppleTalk node for the user.
FramedAppleTalkZone | 39 | Attribute indicates the AppleTalk Default Zone to be used for this user.
ChapChallenge | 60 | Attribute contains the CHAP Challenge sent by the NAS to a PPP CHAP user.
NasPortType | 61 | Attribute indicates the type of physical port of the NAS which is authenticating the user.
PortLimit | 62 | Attribute sets the maximum number of ports to be provided to the user by the NAS.
LoginLatPort | 63 | Attribute indicates the Port with which the user is to be connected by the LAT.
See Also

Reference

GSF.Communication.Radius Namespace


PacketType Enumeration

Grid Solutions Framework PacketType Enumeration
Specifies the type of the RadiusPacket.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum PacketType
Public Enumeration PacketType
type PacketType
GSF.Communication.Radius.PacketType = function();
GSF.Communication.Radius.PacketType.createEnum('GSF.Communication.Radius.PacketType', false);
public enum class PacketType
Members
Member name | Value | Description
AccessRequest | 1 | Packet sent to a RADIUS server for verification of credentials.
AccessAccept | 2 | Packet sent by a RADIUS server when credential verification is successful.
AccessReject | 3 | Packet sent by a RADIUS server when credential verification is unsuccessful.
AccountingRequest | 4 | Not used. No description available. [RFC 2882]
AccountingResponse | 5 | Not used. No description available. [RFC 2882]
AccountingStatus | 6 | Not used. No description available. [RFC 2882]
PasswordRequest | 7 | Not used. No description available. [RFC 2882]
PasswordAccept | 8 | Not used. No description available. [RFC 2882]
PasswordReject | 9 | Not used. No description available. [RFC 2882]
AccountingMessage | 10 | Not used. No description available. [RFC 2882]
AccessChallenge | 11 | Packet sent by a RADIUS server when further information is needed for credential verification.
StatuServer | 12 | Not used. No description available. [RFC 2882]
StatusClient | 13 | Not used. No description available. [RFC 2882]
See Also

Reference

GSF.Communication.Radius Namespace


RadiusClient Class

Grid Solutions Framework RadiusClient Class
Represents a RADIUS communication client.
Inheritance Hierarchy
SystemObject
GSF.Communication.RadiusRadiusClient

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RadiusClient : IDisposable
Public Class RadiusClient
    Implements IDisposable
type RadiusClient =
    class
        interface IDisposable
    end
GSF.Communication.Radius.RadiusClient = function();

Type.createClass(
    'GSF.Communication.Radius.RadiusClient',
    null,
    IDisposable);
public ref class RadiusClient : IDisposable

The RadiusClient type exposes the following members.

Constructors
 | Name | Description
Public method | RadiusClient(String, String) | Creates an instance of RADIUS client for sending request to a RADIUS server.
Public method | RadiusClient(String, Int32, String) | Creates an instance of RADIUS client for sending request to a RADIUS server.
Top
Methods
 | Name | Description
Public method | Authenticate(String, String) | Authenticates the username and password against the RADIUS server.
Public method | Authenticate(String, String, Byte) | Authenticates the username and password against the RADIUS server.
Protected method | CheckDisposed | Helper method to check whether or not the object instance has been disposed.
Public method | CreateNewPin | Create a new pin for the user.
Public method | Dispose | Releases the used resources.
Protected method | Dispose(Boolean) | Releases the used resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsUserInNewPinMode | Determines whether or not the response indicates that the user account is in "New Pin" mode.
Public method | IsUserInNextTokenMode | Determines whether or not the response indicates that the user account is in "Next Token" mode.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | Send a request to the server and waits for a response back.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultNewPinModeMessage1 | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 1 (ensuring that the user account is in the "New Pin" mode) of creating a new pin was successful.
DefaultNewPinModeMessage2 | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 2 (new pin is accepted in attempt #1) of creating a new pin was successful.
DefaultNewPinModeMessage3 | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 3 (new pin is accepted in attempts #2) of creating a new pin was successful.
DefaultNextTokenModeMessage | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not a user account is in the "Next Token" mode.
DefaultServerPort | Default port of the RADIUS server.
Top
Properties
 | Name | Description
Public property | NewPinModeMessage1 | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 1 (ensuring that the user account is in the "New Pin" mode) of creating a new pin was successful.
Public property | NewPinModeMessage2 | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 2 (new pin is accepted in attempt #1) of creating a new pin was successful.
Public property | NewPinModeMessage3 | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 3 (new pin is accepted in attempts #2) of creating a new pin was successful.
Public property | NextTokenModeMessage | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not a user account is in the "Next Token" mode.
Public property | ReponseTimeout | Gets or sets the time (in milliseconds) to wait for a response from server after sending a request.
Public property | RequestAttempts | Gets or sets the number of time a request is to sent to the server until a valid response is received.
Public property | ServerName | Gets or sets the name or address of the RADIUS server.
Public property | ServerPort | Gets or sets the port number of the RADIUS server.
Public property | SharedSecret | Gets or sets the shared secret used between the client and server for encryption and authentication.
Top
See Also

Reference

GSF.Communication.Radius Namespace


RadiusClient Constructor

Grid Solutions Framework RadiusClient Constructor
Overload List
 | Name | Description
Public method | RadiusClient(String, String) | Creates an instance of RADIUS client for sending request to a RADIUS server.
Public method | RadiusClient(String, Int32, String) | Creates an instance of RADIUS client for sending request to a RADIUS server.
Top
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient Constructor (String, String)

Grid Solutions Framework RadiusClient Constructor (String, String)
Creates an instance of RADIUS client for sending request to a RADIUS server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusClient(
    string serverName,
    string sharedSecret
)
Public Sub New (
    serverName As String,
    sharedSecret As String
)
new :
        serverName : string *
        sharedSecret : string -> RadiusClient
GSF.Communication.Radius.RadiusClient = function(serverName, sharedSecret);
public:
RadiusClient(
    String^ serverName,
    String^ sharedSecret
)

Parameters

serverName
Type: SystemString
Name or address of the RADIUS server.
sharedSecret
Type: SystemString
Shared secret used for encryption and authentication.
See Also

Reference

RadiusClient Class
RadiusClient Overload
GSF.Communication.Radius Namespace


RadiusClient Constructor (String, Int32, String)

Grid Solutions Framework RadiusClient Constructor (String, Int32, String)
Creates an instance of RADIUS client for sending request to a RADIUS server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusClient(
    string serverName,
    int serverPort,
    string sharedSecret
)
Public Sub New (
    serverName As String,
    serverPort As Integer,
    sharedSecret As String
)
new :
        serverName : string *
        serverPort : int *
        sharedSecret : string -> RadiusClient
GSF.Communication.Radius.RadiusClient = function(serverName, serverPort, sharedSecret);
public:
RadiusClient(
    String^ serverName,
    int serverPort,
    String^ sharedSecret
)

Parameters

serverName
Type: SystemString
Name or address of the RADIUS server.
serverPort
Type: SystemInt32
Port number of the RADIUS server.
sharedSecret
Type: SystemString
Shared secret used for encryption and authentication.
Remarks
See Also

Reference

RadiusClient Class
RadiusClient Overload
GSF.Communication.Radius Namespace


RadiusClient Fields

Grid Solutions Framework RadiusClient Fields

The RadiusClient type exposes the following members.

Fields
Name | Description
DefaultNewPinModeMessage1 | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 1 (ensuring that the user account is in the "New Pin" mode) of creating a new pin was successful.
DefaultNewPinModeMessage2 | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 2 (new pin is accepted in attempt #1) of creating a new pin was successful.
DefaultNewPinModeMessage3 | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 3 (new pin is accepted in attempts #2) of creating a new pin was successful.
DefaultNextTokenModeMessage | Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not a user account is in the "Next Token" mode.
DefaultServerPort | Default port of the RADIUS server.
Top
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.DefaultNewPinModeMessage1 Field

Grid Solutions Framework RadiusClientDefaultNewPinModeMessage1 Field
Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 1 (ensuring that the user account is in the "New Pin" mode) of creating a new pin was successful.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultNewPinModeMessage1
Public Const DefaultNewPinModeMessage1 As String
static val mutable DefaultNewPinModeMessage1: string
var GSF.Communication.Radius.RadiusClient.DefaultNewPinModeMessage1
public:
literal String^ DefaultNewPinModeMessage1

Field Value

Type: String
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.DefaultNewPinModeMessage2 Field

Grid Solutions Framework RadiusClientDefaultNewPinModeMessage2 Field
Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 2 (new pin is accepted in attempt #1) of creating a new pin was successful.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultNewPinModeMessage2
Public Const DefaultNewPinModeMessage2 As String
static val mutable DefaultNewPinModeMessage2: string
var GSF.Communication.Radius.RadiusClient.DefaultNewPinModeMessage2
public:
literal String^ DefaultNewPinModeMessage2

Field Value

Type: String
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.DefaultNewPinModeMessage3 Field

Grid Solutions Framework RadiusClientDefaultNewPinModeMessage3 Field
Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 3 (new pin is accepted in attempts #2) of creating a new pin was successful.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultNewPinModeMessage3
Public Const DefaultNewPinModeMessage3 As String
static val mutable DefaultNewPinModeMessage3: string
var GSF.Communication.Radius.RadiusClient.DefaultNewPinModeMessage3
public:
literal String^ DefaultNewPinModeMessage3

Field Value

Type: String
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.DefaultNextTokenModeMessage Field

Grid Solutions Framework RadiusClientDefaultNextTokenModeMessage Field
Default text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not a user account is in the "Next Token" mode.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultNextTokenModeMessage
Public Const DefaultNextTokenModeMessage As String
static val mutable DefaultNextTokenModeMessage: string
var GSF.Communication.Radius.RadiusClient.DefaultNextTokenModeMessage
public:
literal String^ DefaultNextTokenModeMessage

Field Value

Type: String
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.DefaultServerPort Field

Grid Solutions Framework RadiusClientDefaultServerPort Field
Default port of the RADIUS server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultServerPort
Public Const DefaultServerPort As Integer
static val mutable DefaultServerPort: int
var GSF.Communication.Radius.RadiusClient.DefaultServerPort
public:
literal int DefaultServerPort

Field Value

Type: Int32
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient Methods

Grid Solutions Framework RadiusClient Methods

The RadiusClient type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate(String, String) | Authenticates the username and password against the RADIUS server.
Public method | Authenticate(String, String, Byte) | Authenticates the username and password against the RADIUS server.
Protected method | CheckDisposed | Helper method to check whether or not the object instance has been disposed.
Public method | CreateNewPin | Create a new pin for the user.
Public method | Dispose | Releases the used resources.
Protected method | Dispose(Boolean) | Releases the used resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsUserInNewPinMode | Determines whether or not the response indicates that the user account is in "New Pin" mode.
Public method | IsUserInNextTokenMode | Determines whether or not the response indicates that the user account is in "Next Token" mode.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ProcessRequest | Send a request to the server and waits for a response back.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.Authenticate Method

Grid Solutions Framework RadiusClientAuthenticate Method
Overload List
 | Name | Description
Public method | Authenticate(String, String) | Authenticates the username and password against the RADIUS server.
Public method | Authenticate(String, String, Byte) | Authenticates the username and password against the RADIUS server.
Top
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.Authenticate Method (String, String)

Grid Solutions Framework RadiusClientAuthenticate Method (String, String)
Authenticates the username and password against the RADIUS server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacket Authenticate(
    string username,
    string password
)
Public Function Authenticate (
    username As String,
    password As String
) As RadiusPacket
member Authenticate :
        username : string *
        password : string -> RadiusPacket

function Authenticate(username, password);
public:
RadiusPacket^ Authenticate(
    String^ username,
    String^ password
)

Parameters

username
Type: SystemString
Username to be authenticated.
password
Type: SystemString
Password to be authenticated.

Return Value

Type: RadiusPacket
Response packet received from the server for the authentication request.
Remarks

The type of response packet (if any) will be one of the following: AccessAccept: If the authentication is successful.AccessReject: If the authentication is not successful.AccessChallenge: If the server need more information from the user.

When an AccessChallenge response packet is received from the server, it contains a State attribute that must be included in the AccessRequest packet that is being sent in response to the AccessChallenge response. So if this method returns an AccessChallenge packet, then this method is to be called again with the requested information (from ReplyMessage attribute) in the password field and the value State attribute.

See Also

Reference

RadiusClient Class
Authenticate Overload
GSF.Communication.Radius Namespace


RadiusClient.Authenticate Method (String, String, Byte[])

Grid Solutions Framework RadiusClientAuthenticate Method (String, String, Byte)
Authenticates the username and password against the RADIUS server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacket Authenticate(
    string username,
    string password,
    byte[] state
)
Public Function Authenticate (
    username As String,
    password As String,
    state As Byte()
) As RadiusPacket
member Authenticate :
        username : string *
        password : string *
        state : byte[] -> RadiusPacket

function Authenticate(username, password, state);
public:
RadiusPacket^ Authenticate(
    String^ username,
    String^ password,
    array<unsigned char>^ state
)

Parameters

username
Type: SystemString
Username to be authenticated.
password
Type: SystemString
Password to be authenticated.
state
Type: SystemByte
State value from a previous challenge response.

Return Value

Type: RadiusPacket
Response packet received from the server for the authentication request.
Remarks

The type of response packet (if any) will be one of the following: AccessAccept: If the authentication is successful.AccessReject: If the authentication is not successful.AccessChallenge: If the server need more information from the user.

When an AccessChallenge response packet is received from the server, it contains a State attribute that must be included in the AccessRequest packet that is being sent in response to the AccessChallenge response. So if this method returns an AccessChallenge packet, then this method is to be called again with the requested information (from ReplyMessage attribute) in the password field and the value State attribute.

See Also

Reference

RadiusClient Class
Authenticate Overload
GSF.Communication.Radius Namespace


RadiusClient.CheckDisposed Method

Grid Solutions Framework RadiusClientCheckDisposed Method
Helper method to check whether or not the object instance has been disposed.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void CheckDisposed()
Protected Sub CheckDisposed
member CheckDisposed : unit -> unit

function CheckDisposed();
protected:
void CheckDisposed()
Remarks
This method is to be called before performing any operation.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.CreateNewPin Method

Grid Solutions Framework RadiusClientCreateNewPin Method
Create a new pin for the user.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CreateNewPin(
    string username,
    string token,
    string pin
)
Public Function CreateNewPin (
    username As String,
    token As String,
    pin As String
) As Boolean
member CreateNewPin :
        username : string *
        token : string *
        pin : string -> bool

function CreateNewPin(username, token, pin);
public:
bool CreateNewPin(
    String^ username,
    String^ token,
    String^ pin
)

Parameters

username
Type: SystemString
Name of the user.
token
Type: SystemString
Current token of the user.
pin
Type: SystemString
New pin of the user.

Return Value

Type: Boolean
True if a new pin is created for the user successfully; otherwise False.
Remarks
NOTE: This method is specific to RSA RADIUS implementation.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.Dispose Method

Grid Solutions Framework RadiusClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases the used resources.
Protected method | Dispose(Boolean) | Releases the used resources.
Top
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.Dispose Method

Grid Solutions Framework RadiusClientDispose Method
Releases the used resources.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

RadiusClient Class
Dispose Overload
GSF.Communication.Radius Namespace


RadiusClient.Dispose Method (Boolean)

Grid Solutions Framework RadiusClientDispose Method (Boolean)
Releases the used resources.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
True to release both managed and unmanaged resources; false to release only unmanaged resources
See Also

Reference

RadiusClient Class
Dispose Overload
GSF.Communication.Radius Namespace


RadiusClient.IsUserInNewPinMode Method

Grid Solutions Framework RadiusClientIsUserInNewPinMode Method
Determines whether or not the response indicates that the user account is in "New Pin" mode.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsUserInNewPinMode(
    RadiusPacket response
)
Public Function IsUserInNewPinMode (
    response As RadiusPacket
) As Boolean
member IsUserInNewPinMode :
        response : RadiusPacket -> bool

function IsUserInNewPinMode(response);
public:
bool IsUserInNewPinMode(
    RadiusPacket^ response
)

Parameters

response
Type: GSF.Communication.RadiusRadiusPacket
Response packet sent by the server.

Return Value

Type: Boolean
True if the user account is in "New Pin" mode; otherwise False.
Remarks

A user's account can be in the "New Pin" mode when set on the server.

NOTE: This method is specific to RSA RADIUS implementation.

See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.IsUserInNextTokenMode Method

Grid Solutions Framework RadiusClientIsUserInNextTokenMode Method
Determines whether or not the response indicates that the user account is in "Next Token" mode.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsUserInNextTokenMode(
    RadiusPacket response
)
Public Function IsUserInNextTokenMode (
    response As RadiusPacket
) As Boolean
member IsUserInNextTokenMode :
        response : RadiusPacket -> bool

function IsUserInNextTokenMode(response);
public:
bool IsUserInNextTokenMode(
    RadiusPacket^ response
)

Parameters

response
Type: GSF.Communication.RadiusRadiusPacket
Response packet sent by the server.

Return Value

Type: Boolean
True if the user account is in "Next Token" mode; otherwise False.
Remarks

A user's account can enter the "Next Token" mode after the user enters incorrect passwords for a few times (3 times by default) and then enters the correct password. Note that repeatedly entering incorrect passwords will disable the user account.

NOTE: This method is specific to RSA RADIUS implementation.

See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.ProcessRequest Method

Grid Solutions Framework RadiusClientProcessRequest Method
Send a request to the server and waits for a response back.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacket ProcessRequest(
    RadiusPacket request
)
Public Function ProcessRequest (
    request As RadiusPacket
) As RadiusPacket
member ProcessRequest :
        request : RadiusPacket -> RadiusPacket

function ProcessRequest(request);
public:
RadiusPacket^ ProcessRequest(
    RadiusPacket^ request
)

Parameters

request
Type: GSF.Communication.RadiusRadiusPacket
Request to be sent to the server.

Return Value

Type: RadiusPacket
Response packet if a valid response is received from the server; otherwise Nothing.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient Properties

Grid Solutions Framework RadiusClient Properties

The RadiusClient type exposes the following members.

Properties
 | Name | Description
Public property | NewPinModeMessage1 | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 1 (ensuring that the user account is in the "New Pin" mode) of creating a new pin was successful.
Public property | NewPinModeMessage2 | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 2 (new pin is accepted in attempt #1) of creating a new pin was successful.
Public property | NewPinModeMessage3 | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 3 (new pin is accepted in attempts #2) of creating a new pin was successful.
Public property | NextTokenModeMessage | Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not a user account is in the "Next Token" mode.
Public property | ReponseTimeout | Gets or sets the time (in milliseconds) to wait for a response from server after sending a request.
Public property | RequestAttempts | Gets or sets the number of time a request is to sent to the server until a valid response is received.
Public property | ServerName | Gets or sets the name or address of the RADIUS server.
Public property | ServerPort | Gets or sets the port number of the RADIUS server.
Public property | SharedSecret | Gets or sets the shared secret used between the client and server for encryption and authentication.
Top
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.NewPinModeMessage1 Property

Grid Solutions Framework RadiusClientNewPinModeMessage1 Property
Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 1 (ensuring that the user account is in the "New Pin" mode) of creating a new pin was successful.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string NewPinModeMessage1 { get; set; }
Public Property NewPinModeMessage1 As String
    Get
    Set
member NewPinModeMessage1 : string with get, set

function get_NewPinModeMessage1();
function set_NewPinModeMessage1(value);
public:
property String^ NewPinModeMessage1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Return Value

Type: String
Text for "New Pin" mode's first message.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.NewPinModeMessage2 Property

Grid Solutions Framework RadiusClientNewPinModeMessage2 Property
Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 2 (new pin is accepted in attempt #1) of creating a new pin was successful.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string NewPinModeMessage2 { get; set; }
Public Property NewPinModeMessage2 As String
    Get
    Set
member NewPinModeMessage2 : string with get, set

function get_NewPinModeMessage2();
function set_NewPinModeMessage2(value);
public:
property String^ NewPinModeMessage2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Return Value

Type: String
Text for "New Pin" mode's second message.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.NewPinModeMessage3 Property

Grid Solutions Framework RadiusClientNewPinModeMessage3 Property
Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not Step 3 (new pin is accepted in attempts #2) of creating a new pin was successful.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string NewPinModeMessage3 { get; set; }
Public Property NewPinModeMessage3 As String
    Get
    Set
member NewPinModeMessage3 : string with get, set

function get_NewPinModeMessage3();
function set_NewPinModeMessage3(value);
public:
property String^ NewPinModeMessage3 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Return Value

Type: String
Text for "New Pin" mode's third message.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.NextTokenModeMessage Property

Grid Solutions Framework RadiusClientNextTokenModeMessage Property
Gets or sets the text for comparing with the text of ReplyMessage attribute in an AccessChallenge server response to determine whether or not a user account is in the "Next Token" mode.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string NextTokenModeMessage { get; set; }
Public Property NextTokenModeMessage As String
    Get
    Set
member NextTokenModeMessage : string with get, set

function get_NextTokenModeMessage();
function set_NextTokenModeMessage(value);
public:
property String^ NextTokenModeMessage {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Return Value

Type: String
Text for "Next Token" mode.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.ReponseTimeout Property

Grid Solutions Framework RadiusClientReponseTimeout Property
Gets or sets the time (in milliseconds) to wait for a response from server after sending a request.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ReponseTimeout { get; set; }
Public Property ReponseTimeout As Integer
    Get
    Set
member ReponseTimeout : int with get, set

function get_ReponseTimeout();
function set_ReponseTimeout(value);
public:
property int ReponseTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Return Value

Type: Int32
Time (in milliseconds) to wait for a response from server after sending a request.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.RequestAttempts Property

Grid Solutions Framework RadiusClientRequestAttempts Property
Gets or sets the number of time a request is to sent to the server until a valid response is received.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short RequestAttempts { get; set; }
Public Property RequestAttempts As Short
    Get
    Set
member RequestAttempts : int16 with get, set

function get_RequestAttempts();
function set_RequestAttempts(value);
public:
property short RequestAttempts {
    short get ();
    void set (short value);
}

Property Value

Type: Int16

Return Value

Type: Int16
Number of time a request is to sent to the server until a valid response is received.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.ServerName Property

Grid Solutions Framework RadiusClientServerName Property
Gets or sets the name or address of the RADIUS server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ServerName { get; set; }
Public Property ServerName As String
    Get
    Set
member ServerName : string with get, set

function get_ServerName();
function set_ServerName(value);
public:
property String^ ServerName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Return Value

Type: String
Name or address of RADIUS server.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.ServerPort Property

Grid Solutions Framework RadiusClientServerPort Property
Gets or sets the port number of the RADIUS server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ServerPort { get; set; }
Public Property ServerPort As Integer
    Get
    Set
member ServerPort : int with get, set

function get_ServerPort();
function set_ServerPort(value);
public:
property int ServerPort {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Return Value

Type: Int32
Port number of the RADIUS server.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusClient.SharedSecret Property

Grid Solutions Framework RadiusClientSharedSecret Property
Gets or sets the shared secret used between the client and server for encryption and authentication.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SharedSecret { get; set; }
Public Property SharedSecret As String
    Get
    Set
member SharedSecret : string with get, set

function get_SharedSecret();
function set_SharedSecret(value);
public:
property String^ SharedSecret {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Return Value

Type: String
Shared secret used between the client and server for encryption and authentication.
See Also

Reference

RadiusClient Class
GSF.Communication.Radius Namespace


RadiusPacket Class

Grid Solutions Framework RadiusPacket Class
Represents a data packet transferred between RADIUS client and server.
Inheritance Hierarchy
SystemObject
GSF.Communication.RadiusRadiusPacket

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RadiusPacket : ISupportBinaryImage
Public Class RadiusPacket
    Implements ISupportBinaryImage
type RadiusPacket =
    class
        interface ISupportBinaryImage
    end
GSF.Communication.Radius.RadiusPacket = function();

Type.createClass(
    'GSF.Communication.Radius.RadiusPacket',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class RadiusPacket : ISupportBinaryImage

The RadiusPacket type exposes the following members.

Constructors
 | Name | Description
Public method | RadiusPacket | Initializes a new instance of the RadiusPacket class.
Public method | RadiusPacket(PacketType) | Initializes a new instance of the RadiusPacket class.
Public method | RadiusPacket(Byte, Int32, Int32) | Initializes a new instance of the RadiusPacket class.
Top
Methods
 | Name | Description
 | CreateRequestAuthenticator | Generates an "Authenticator" value used in a RADIUS request packet sent by the client to server.
 | CreateResponseAuthenticator | Generates an "Authenticator" value used in a RADIUS response packet sent by the server to client.
 | EncryptPassword | Generates an encrypted password using the RADIUS protocol specification (RFC 2285).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RadiusPacket object and copies it into the given buffer.
Public method | GetAttributeValue | Gets the value of the specified attributeType if it is present in the RadiusPacket.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses RadiusPacket object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
Encoding | Encoding format for encoding text.
EndianOrder | EndianOrder to use for byte conversion.
Top
Properties
 | Name | Description
Public property | Attributes | Gets a list of RadiusPacketAttributes.
Public property | Authenticator | Gets or sets the RadiusPacket authenticator.
Public property | BinaryLength | Gets the length of the RadiusPacket.
Public property | Identifier | Gets or sets the RadiusPacket identifier.
Public property | Type | Gets or sets the type of the RadiusPacket.
Top
See Also

Reference

GSF.Communication.Radius Namespace
GSF.Communication.RadiusRadiusPacketAttribute
GSF.Communication.RadiusRadiusClient


RadiusPacket Constructor

Grid Solutions Framework RadiusPacket Constructor
Overload List
 | Name | Description
Public method | RadiusPacket | Initializes a new instance of the RadiusPacket class.
Public method | RadiusPacket(PacketType) | Initializes a new instance of the RadiusPacket class.
Public method | RadiusPacket(Byte, Int32, Int32) | Initializes a new instance of the RadiusPacket class.
Top
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket Constructor

Grid Solutions Framework RadiusPacket Constructor
Initializes a new instance of the RadiusPacket class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacket()
Public Sub New
new : unit -> RadiusPacket
GSF.Communication.Radius.RadiusPacket = function();
public:
RadiusPacket()
See Also

Reference

RadiusPacket Class
RadiusPacket Overload
GSF.Communication.Radius Namespace


RadiusPacket Constructor (PacketType)

Grid Solutions Framework RadiusPacket Constructor (PacketType)
Initializes a new instance of the RadiusPacket class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacket(
    PacketType type
)
Public Sub New (
    type As PacketType
)
new :
        type : PacketType -> RadiusPacket
GSF.Communication.Radius.RadiusPacket = function(type);
public:
RadiusPacket(
    PacketType type
)

Parameters

type
Type: GSF.Communication.RadiusPacketType
Type of the RadiusPacket.
See Also

Reference

RadiusPacket Class
RadiusPacket Overload
GSF.Communication.Radius Namespace


RadiusPacket Constructor (Byte[], Int32, Int32)

Grid Solutions Framework RadiusPacket Constructor (Byte, Int32, Int32)
Initializes a new instance of the RadiusPacket class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacket(
    byte[] binaryImage,
    int startIndex,
    int length
)
Public Sub New (
    binaryImage As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        binaryImage : byte[] *
        startIndex : int *
        length : int -> RadiusPacket
GSF.Communication.Radius.RadiusPacket = function(binaryImage, startIndex, length);
public:
RadiusPacket(
    array<unsigned char>^ binaryImage,
    int startIndex,
    int length
)

Parameters

binaryImage
Type: SystemByte
Binary image to be used for initializing RadiusPacket.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the binaryImage.
length
Type: SystemInt32
Valid number of bytes in binaryImage from startIndex.
See Also

Reference

RadiusPacket Class
RadiusPacket Overload
GSF.Communication.Radius Namespace


RadiusPacket Fields

Grid Solutions Framework RadiusPacket Fields

The RadiusPacket type exposes the following members.

Fields
Name | Description
Encoding | Encoding format for encoding text.
EndianOrder | EndianOrder to use for byte conversion.
Top
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.Encoding Field

Grid Solutions Framework RadiusPacketEncoding Field
Encoding format for encoding text.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Encoding Encoding
Public Shared Encoding As Encoding
static val mutable Encoding: Encoding
var GSF.Communication.Radius.RadiusPacket.Encoding
public:
static Encoding^ Encoding

Field Value

Type: Encoding
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.EndianOrder Field

Grid Solutions Framework RadiusPacketEndianOrder Field
EndianOrder to use for byte conversion.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static EndianOrder EndianOrder
Public Shared EndianOrder As EndianOrder
static val mutable EndianOrder: EndianOrder
var GSF.Communication.Radius.RadiusPacket.EndianOrder
public:
static EndianOrder^ EndianOrder

Field Value

Type: EndianOrder
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket Methods

Grid Solutions Framework RadiusPacket Methods

The RadiusPacket type exposes the following members.

Methods
 | Name | Description
 | CreateRequestAuthenticator | Generates an "Authenticator" value used in a RADIUS request packet sent by the client to server.
 | CreateResponseAuthenticator | Generates an "Authenticator" value used in a RADIUS response packet sent by the server to client.
 | EncryptPassword | Generates an encrypted password using the RADIUS protocol specification (RFC 2285).
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RadiusPacket object and copies it into the given buffer.
Public method | GetAttributeValue | Gets the value of the specified attributeType if it is present in the RadiusPacket.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses RadiusPacket object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.CreateRequestAuthenticator Method

Grid Solutions Framework RadiusPacketCreateRequestAuthenticator Method
Generates an "Authenticator" value used in a RADIUS request packet sent by the client to server.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] CreateRequestAuthenticator(
    string sharedSecret
)
Public Shared Function CreateRequestAuthenticator (
    sharedSecret As String
) As Byte()
static member CreateRequestAuthenticator :
        sharedSecret : string -> byte[]

GSF.Communication.Radius.RadiusPacket.CreateRequestAuthenticator = function(sharedSecret);
public:
static array<unsigned char>^ CreateRequestAuthenticator(
    String^ sharedSecret
)

Parameters

sharedSecret
Type: SystemString
The shared secret to be used in generating the output.

Return Value

Type: Byte
A byte array.
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.CreateResponseAuthenticator Method

Grid Solutions Framework RadiusPacketCreateResponseAuthenticator Method
Generates an "Authenticator" value used in a RADIUS response packet sent by the server to client.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] CreateResponseAuthenticator(
    string sharedSecret,
    RadiusPacket requestPacket,
    RadiusPacket responsePacket
)
Public Shared Function CreateResponseAuthenticator (
    sharedSecret As String,
    requestPacket As RadiusPacket,
    responsePacket As RadiusPacket
) As Byte()
static member CreateResponseAuthenticator :
        sharedSecret : string *
        requestPacket : RadiusPacket *
        responsePacket : RadiusPacket -> byte[]

GSF.Communication.Radius.RadiusPacket.CreateResponseAuthenticator = function(sharedSecret, requestPacket, responsePacket);
public:
static array<unsigned char>^ CreateResponseAuthenticator(
    String^ sharedSecret,
    RadiusPacket^ requestPacket,
    RadiusPacket^ responsePacket
)

Parameters

sharedSecret
Type: SystemString
The shared secret key.
requestPacket
Type: GSF.Communication.RadiusRadiusPacket
RADIUS packet sent from client to server.
responsePacket
Type: GSF.Communication.RadiusRadiusPacket
RADIUS packet sent from server to client.

Return Value

Type: Byte
A byte array.
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.EncryptPassword Method

Grid Solutions Framework RadiusPacketEncryptPassword Method
Generates an encrypted password using the RADIUS protocol specification (RFC 2285).

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] EncryptPassword(
    string password,
    string sharedSecret,
    byte[] requestAuthenticator
)
Public Shared Function EncryptPassword (
    password As String,
    sharedSecret As String,
    requestAuthenticator As Byte()
) As Byte()
static member EncryptPassword :
        password : string *
        sharedSecret : string *
        requestAuthenticator : byte[] -> byte[]

GSF.Communication.Radius.RadiusPacket.EncryptPassword = function(password, sharedSecret, requestAuthenticator);
public:
static array<unsigned char>^ EncryptPassword(
    String^ password,
    String^ sharedSecret,
    array<unsigned char>^ requestAuthenticator
)

Parameters

password
Type: SystemString
User's password.
sharedSecret
Type: SystemString
Shared secret key.
requestAuthenticator
Type: SystemByte
Request authenticator byte array.

Return Value

Type: Byte
A byte array.
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.GenerateBinaryImage Method

Grid Solutions Framework RadiusPacketGenerateBinaryImage Method
Generates a binary representation of this RadiusPacket object and copies it into the given buffer.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.GetAttributeValue Method

Grid Solutions Framework RadiusPacketGetAttributeValue Method
Gets the value of the specified attributeType if it is present in the RadiusPacket.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetAttributeValue(
    AttributeType attributeType
)
Public Function GetAttributeValue (
    attributeType As AttributeType
) As Byte()
member GetAttributeValue :
        attributeType : AttributeType -> byte[]

function GetAttributeValue(attributeType);
public:
array<unsigned char>^ GetAttributeValue(
    AttributeType attributeType
)

Parameters

attributeType
Type: GSF.Communication.RadiusAttributeType
Type of the RadiusPacketAttribute whose value is to be retrieved.

Return Value

Type: Byte
RadiusPacketAttribute.Value if RadiusPacketAttribute is present; otherwise null.
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.ParseBinaryImage Method

Grid Solutions Framework RadiusPacketParseBinaryImage Method
Parses RadiusPacket object by parsing the specified buffer containing a binary image.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed), or 0 if not enough data.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket Properties

Grid Solutions Framework RadiusPacket Properties

The RadiusPacket type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a list of RadiusPacketAttributes.
Public property | Authenticator | Gets or sets the RadiusPacket authenticator.
Public property | BinaryLength | Gets the length of the RadiusPacket.
Public property | Identifier | Gets or sets the RadiusPacket identifier.
Public property | Type | Gets or sets the type of the RadiusPacket.
Top
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.Attributes Property

Grid Solutions Framework RadiusPacketAttributes Property
Gets a list of RadiusPacketAttributes.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<RadiusPacketAttribute> Attributes { get; }
Public ReadOnly Property Attributes As List(Of RadiusPacketAttribute)
    Get
member Attributes : List<RadiusPacketAttribute> with get

function get_Attributes();

public:
property List<RadiusPacketAttribute^>^ Attributes {
    List<RadiusPacketAttribute^>^ get ();
}

Property Value

Type: List RadiusPacketAttribute
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.Authenticator Property

Grid Solutions Framework RadiusPacketAuthenticator Property
Gets or sets the RadiusPacket authenticator.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Authenticator { get; set; }
Public Property Authenticator As Byte()
    Get
    Set
member Authenticator : byte[] with get, set

function get_Authenticator();
function set_Authenticator(value);
public:
property array<unsigned char>^ Authenticator {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
ArgumentException | The value being assigned is not 16-bytes in length.
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.BinaryLength Property

Grid Solutions Framework RadiusPacketBinaryLength Property
Gets the length of the RadiusPacket.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.Identifier Property

Grid Solutions Framework RadiusPacketIdentifier Property
Gets or sets the RadiusPacket identifier.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Identifier { get; set; }
Public Property Identifier As Byte
    Get
    Set
member Identifier : byte with get, set

function get_Identifier();
function set_Identifier(value);
public:
property unsigned char Identifier {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacket.Type Property

Grid Solutions Framework RadiusPacketType Property
Gets or sets the type of the RadiusPacket.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType Type { get; set; }
Public Property Type As PacketType
    Get
    Set
member Type : PacketType with get, set

function get_Type();
function set_Type(value);
public:
property PacketType Type {
    PacketType get ();
    void set (PacketType value);
}

Property Value

Type: PacketType
See Also

Reference

RadiusPacket Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute Class

Grid Solutions Framework RadiusPacketAttribute Class
Represents an attribute of RadiusPacket.
Inheritance Hierarchy
SystemObject
GSF.Communication.RadiusRadiusPacketAttribute

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RadiusPacketAttribute : ISupportBinaryImage
Public Class RadiusPacketAttribute
    Implements ISupportBinaryImage
type RadiusPacketAttribute =
    class
        interface ISupportBinaryImage
    end
GSF.Communication.Radius.RadiusPacketAttribute = function();

Type.createClass(
    'GSF.Communication.Radius.RadiusPacketAttribute',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class RadiusPacketAttribute : ISupportBinaryImage

The RadiusPacketAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RadiusPacketAttribute | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, Byte) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, IPAddress) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, String) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, UInt32) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(Byte, Int32, Int32) | Initializes a new instance of the RadiusPacketAttribute class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RadiusPacketAttribute object and copies it into the given buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses RadiusPacketAttribute object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the RadiusPacketAttribute.
Public property | Type | Gets or sets the type of the RadiusPacketAttribute.
Public property | Value | Gets or sets the value of the RadiusPacketAttribute.
Top
See Also

Reference

GSF.Communication.Radius Namespace
GSF.Communication.RadiusRadiusPacket
GSF.Communication.RadiusRadiusClient


RadiusPacketAttribute Constructor

Grid Solutions Framework RadiusPacketAttribute Constructor
Overload List
 | Name | Description
Public method | RadiusPacketAttribute | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, Byte) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, IPAddress) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, String) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(AttributeType, UInt32) | Initializes a new instance of the RadiusPacketAttribute class.
Public method | RadiusPacketAttribute(Byte, Int32, Int32) | Initializes a new instance of the RadiusPacketAttribute class.
Top
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute Constructor

Grid Solutions Framework RadiusPacketAttribute Constructor
Initializes a new instance of the RadiusPacketAttribute class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacketAttribute()
Public Sub New
new : unit -> RadiusPacketAttribute
GSF.Communication.Radius.RadiusPacketAttribute = function();
public:
RadiusPacketAttribute()
See Also

Reference

RadiusPacketAttribute Class
RadiusPacketAttribute Overload
GSF.Communication.Radius Namespace


RadiusPacketAttribute Constructor (AttributeType, Byte[])

Grid Solutions Framework RadiusPacketAttribute Constructor (AttributeType, Byte)
Initializes a new instance of the RadiusPacketAttribute class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacketAttribute(
    AttributeType type,
    byte[] value
)
Public Sub New (
    type As AttributeType,
    value As Byte()
)
new :
        type : AttributeType *
        value : byte[] -> RadiusPacketAttribute
GSF.Communication.Radius.RadiusPacketAttribute = function(type, value);
public:
RadiusPacketAttribute(
    AttributeType type,
    array<unsigned char>^ value
)

Parameters

type
Type: GSF.Communication.RadiusAttributeType
Type of the RadiusPacketAttribute.
value
Type: SystemByte
Byte array value of the RadiusPacketAttribute.
See Also

Reference

RadiusPacketAttribute Class
RadiusPacketAttribute Overload
GSF.Communication.Radius Namespace


RadiusPacketAttribute Constructor (AttributeType, IPAddress)

Grid Solutions Framework RadiusPacketAttribute Constructor (AttributeType, IPAddress)
Initializes a new instance of the RadiusPacketAttribute class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacketAttribute(
    AttributeType type,
    IPAddress value
)
Public Sub New (
    type As AttributeType,
    value As IPAddress
)
new :
        type : AttributeType *
        value : IPAddress -> RadiusPacketAttribute
GSF.Communication.Radius.RadiusPacketAttribute = function(type, value);
public:
RadiusPacketAttribute(
    AttributeType type,
    IPAddress^ value
)

Parameters

type
Type: GSF.Communication.RadiusAttributeType
Type of the RadiusPacketAttribute.
value
Type: System.NetIPAddress
IP address value of the RadiusPacketAttribute.
See Also

Reference

RadiusPacketAttribute Class
RadiusPacketAttribute Overload
GSF.Communication.Radius Namespace


RadiusPacketAttribute Constructor (AttributeType, String)

Grid Solutions Framework RadiusPacketAttribute Constructor (AttributeType, String)
Initializes a new instance of the RadiusPacketAttribute class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacketAttribute(
    AttributeType type,
    string value
)
Public Sub New (
    type As AttributeType,
    value As String
)
new :
        type : AttributeType *
        value : string -> RadiusPacketAttribute
GSF.Communication.Radius.RadiusPacketAttribute = function(type, value);
public:
RadiusPacketAttribute(
    AttributeType type,
    String^ value
)

Parameters

type
Type: GSF.Communication.RadiusAttributeType
Type of the RadiusPacketAttribute.
value
Type: SystemString
Text value of the RadiusPacketAttribute.
See Also

Reference

RadiusPacketAttribute Class
RadiusPacketAttribute Overload
GSF.Communication.Radius Namespace


RadiusPacketAttribute Constructor (AttributeType, UInt32)

Grid Solutions Framework RadiusPacketAttribute Constructor (AttributeType, UInt32)
Initializes a new instance of the RadiusPacketAttribute class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacketAttribute(
    AttributeType type,
    uint value
)
Public Sub New (
    type As AttributeType,
    value As UInteger
)
new :
        type : AttributeType *
        value : uint32 -> RadiusPacketAttribute
GSF.Communication.Radius.RadiusPacketAttribute = function(type, value);
public:
RadiusPacketAttribute(
    AttributeType type,
    unsigned int value
)

Parameters

type
Type: GSF.Communication.RadiusAttributeType
Type of the RadiusPacketAttribute.
value
Type: SystemUInt32
32-bit unsigned integer value of the RadiusPacketAttribute.
See Also

Reference

RadiusPacketAttribute Class
RadiusPacketAttribute Overload
GSF.Communication.Radius Namespace


RadiusPacketAttribute Constructor (Byte[], Int32, Int32)

Grid Solutions Framework RadiusPacketAttribute Constructor (Byte, Int32, Int32)
Initializes a new instance of the RadiusPacketAttribute class.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RadiusPacketAttribute(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> RadiusPacketAttribute
GSF.Communication.Radius.RadiusPacketAttribute = function(buffer, startIndex, length);
public:
RadiusPacketAttribute(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer containing binary image to be used for initializing RadiusPacketAttribute.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

RadiusPacketAttribute Class
RadiusPacketAttribute Overload
GSF.Communication.Radius Namespace


RadiusPacketAttribute Methods

Grid Solutions Framework RadiusPacketAttribute Methods

The RadiusPacketAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RadiusPacketAttribute object and copies it into the given buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses RadiusPacketAttribute object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute.GenerateBinaryImage Method

Grid Solutions Framework RadiusPacketAttributeGenerateBinaryImage Method
Generates a binary representation of this RadiusPacketAttribute object and copies it into the given buffer.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute.ParseBinaryImage Method

Grid Solutions Framework RadiusPacketAttributeParseBinaryImage Method
Parses RadiusPacketAttribute object by parsing the specified buffer containing a binary image.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed), or 0 if not enough data.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute Properties

Grid Solutions Framework RadiusPacketAttribute Properties

The RadiusPacketAttribute type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the RadiusPacketAttribute.
Public property | Type | Gets or sets the type of the RadiusPacketAttribute.
Public property | Value | Gets or sets the value of the RadiusPacketAttribute.
Top
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute.BinaryLength Property

Grid Solutions Framework RadiusPacketAttributeBinaryLength Property
Gets the length of the RadiusPacketAttribute.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute.Type Property

Grid Solutions Framework RadiusPacketAttributeType Property
Gets or sets the type of the RadiusPacketAttribute.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AttributeType Type { get; set; }
Public Property Type As AttributeType
    Get
    Set
member Type : AttributeType with get, set

function get_Type();
function set_Type(value);
public:
property AttributeType Type {
    AttributeType get ();
    void set (AttributeType value);
}

Property Value

Type: AttributeType
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


RadiusPacketAttribute.Value Property

Grid Solutions Framework RadiusPacketAttributeValue Property
Gets or sets the value of the RadiusPacketAttribute.

Namespace: GSF.Communication.Radius
Assembly: GSF.Communication (in GSF.Communication.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Value { get; set; }
Public Property Value As Byte()
    Get
    Set
member Value : byte[] with get, set

function get_Value();
function set_Value(value);
public:
property array<unsigned char>^ Value {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or zero-length byte array.
See Also

Reference

RadiusPacketAttribute Class
GSF.Communication.Radius Namespace


GSF.COMTRADE Namespace

Grid Solutions Framework GSF.COMTRADE Namespace

[Missing <summary> documentation for "N:GSF.COMTRADE"]

Classes
 | Class | Description
Public class | AnalogChannel | Represents an analog channel definition of the Schema.
Public class | ChannelMetadataSorter | Defines a comparison class to property sort metadata.
Public class | DigitalChannel | Represents a digital channel definition of the Schema.
Public class | Parser | COMTRADE data file(s) parser.
Public class | Schema | Represents the schema for a configuration file in the COMTRADE file standard, IEEE Std C37.111-1999.
Public class | Writer | COMTRADE data and config file writer.
Structures
 | Structure | Description
Public structure | ChannelMetadata | Defines a minimal set of channel metadata for a COMTRADE config file.
Public structure | SampleRate | Represents a sample rate with associated ending sample using the COMTRADE file standard, IEEE Std C37.111-1999.
Public structure | Timestamp | Represents a timestamp in the COMTRADE file standard format, IEEE Std C37.111-1999..
Enumerations
 | Enumeration | Description
Public enumeration | FileType | Schema file type enumeration.


AnalogChannel Class

Grid Solutions Framework AnalogChannel Class
Represents an analog channel definition of the Schema.
Inheritance Hierarchy
SystemObject
GSF.COMTRADEAnalogChannel

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AnalogChannel
Public Class AnalogChannel
type AnalogChannel =  class end
GSF.COMTRADE.AnalogChannel = function();

Type.createClass(
    'GSF.COMTRADE.AnalogChannel');
public ref class AnalogChannel

The AnalogChannel type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogChannel | Creates a new instance of the AnalogChannel.
Public method | AnalogChannel(String) | Creates a new instance of the AnalogChannel from an existing line image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts AnalogChannel to its string format. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Adder | Gets or sets adder of this AnalogChannel.
Public property | ChannelName | Gets or sets channel name component of this AnalogChannel.
Public property | CircuitComponent | Gets or sets circuit component of this AnalogChannel.
Public property | CoordinateFormat | Gets or sets coordinate format of this AnalogChannel.
Public property | Index | Gets or sets index of this AnalogChannel.
Public property | MaxValue | Gets or sets maximum unscaled value of this AnalogChannel.
Public property | MinValue | Gets or sets minimum unscaled value of this AnalogChannel.
Public property | Multiplier | Gets or sets value multipler of this AnalogChannel.
Public property | Name | Gets or sets name of this AnalogChannel formatted as station_name:channel_name.
Public property | NominalFrequency | Gets or sets nominal frequency of this AnalogChannel.
Public property | PhaseDesignation | Gets or sets phase designation of this AnalogChannel.
Public property | PhaseID | Gets or sets the 2-character phase identifier for this AnalogChannel.
Public property | PhasorType | Gets or sets phasor type of this AnalogChannel, if applicable.
Public property | PrimaryRatio | Gets or sets the channel voltage or current transformer ratio primary factor of this AnalogChannel.
Public property | ScalingIdentifier | Gets or sets the the primary or secondary data scaling identifer of this AnalogChannel.
Public property | SecondaryRatio | Gets or sets the channel voltage or current transformer ratio secondary factor of this AnalogChannel.
Public property | SignalKind | Gets or sets signal kind of this AnalogChannel.
Public property | Skew | Gets or sets time skew between channels of this AnalogChannel.
Public property | StationName | Gets or sets station name component of this AnalogChannel.
Public property | Units | Gets or sets units of this AnalogChannel.
Top
See Also

Reference

GSF.COMTRADE Namespace


AnalogChannel Constructor

Grid Solutions Framework AnalogChannel Constructor
Overload List
 | Name | Description
Public method | AnalogChannel | Creates a new instance of the AnalogChannel.
Public method | AnalogChannel(String) | Creates a new instance of the AnalogChannel from an existing line image.
Top
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel Constructor

Grid Solutions Framework AnalogChannel Constructor
Creates a new instance of the AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogChannel()
Public Sub New
new : unit -> AnalogChannel
GSF.COMTRADE.AnalogChannel = function();
public:
AnalogChannel()
See Also

Reference

AnalogChannel Class
AnalogChannel Overload
GSF.COMTRADE Namespace


AnalogChannel Constructor (String)

Grid Solutions Framework AnalogChannel Constructor (String)
Creates a new instance of the AnalogChannel from an existing line image.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogChannel(
    string lineImage
)
Public Sub New (
    lineImage As String
)
new :
        lineImage : string -> AnalogChannel
GSF.COMTRADE.AnalogChannel = function(lineImage);
public:
AnalogChannel(
    String^ lineImage
)

Parameters

lineImage
Type: SystemString
Line image to parse.
See Also

Reference

AnalogChannel Class
AnalogChannel Overload
GSF.COMTRADE Namespace


AnalogChannel Methods

Grid Solutions Framework AnalogChannel Methods

The AnalogChannel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts AnalogChannel to its string format. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.ToString Method

Grid Solutions Framework AnalogChannelToString Method
Converts AnalogChannel to its string format.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.COMTRADE.AnalogChannel.ToString"]

See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel Properties

Grid Solutions Framework AnalogChannel Properties

The AnalogChannel type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Gets or sets adder of this AnalogChannel.
Public property | ChannelName | Gets or sets channel name component of this AnalogChannel.
Public property | CircuitComponent | Gets or sets circuit component of this AnalogChannel.
Public property | CoordinateFormat | Gets or sets coordinate format of this AnalogChannel.
Public property | Index | Gets or sets index of this AnalogChannel.
Public property | MaxValue | Gets or sets maximum unscaled value of this AnalogChannel.
Public property | MinValue | Gets or sets minimum unscaled value of this AnalogChannel.
Public property | Multiplier | Gets or sets value multipler of this AnalogChannel.
Public property | Name | Gets or sets name of this AnalogChannel formatted as station_name:channel_name.
Public property | NominalFrequency | Gets or sets nominal frequency of this AnalogChannel.
Public property | PhaseDesignation | Gets or sets phase designation of this AnalogChannel.
Public property | PhaseID | Gets or sets the 2-character phase identifier for this AnalogChannel.
Public property | PhasorType | Gets or sets phasor type of this AnalogChannel, if applicable.
Public property | PrimaryRatio | Gets or sets the channel voltage or current transformer ratio primary factor of this AnalogChannel.
Public property | ScalingIdentifier | Gets or sets the the primary or secondary data scaling identifer of this AnalogChannel.
Public property | SecondaryRatio | Gets or sets the channel voltage or current transformer ratio secondary factor of this AnalogChannel.
Public property | SignalKind | Gets or sets signal kind of this AnalogChannel.
Public property | Skew | Gets or sets time skew between channels of this AnalogChannel.
Public property | StationName | Gets or sets station name component of this AnalogChannel.
Public property | Units | Gets or sets units of this AnalogChannel.
Top
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.Adder Property

Grid Solutions Framework AnalogChannelAdder Property
Gets or sets adder of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Adder { get; set; }
Public Property Adder As Double
    Get
    Set
member Adder : float with get, set

function get_Adder();
function set_Adder(value);
public:
property double Adder {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.ChannelName Property

Grid Solutions Framework AnalogChannelChannelName Property
Gets or sets channel name component of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ChannelName { get; set; }
Public Property ChannelName As String
    Get
    Set
member ChannelName : string with get, set

function get_ChannelName();
function set_ChannelName(value);
public:
property String^ ChannelName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.CircuitComponent Property

Grid Solutions Framework AnalogChannelCircuitComponent Property
Gets or sets circuit component of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CircuitComponent { get; set; }
Public Property CircuitComponent As String
    Get
    Set
member CircuitComponent : string with get, set

function get_CircuitComponent();
function set_CircuitComponent(value);
public:
property String^ CircuitComponent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.CoordinateFormat Property

Grid Solutions Framework AnalogChannelCoordinateFormat Property
Gets or sets coordinate format of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CoordinateFormat CoordinateFormat { get; set; }
Public Property CoordinateFormat As CoordinateFormat
    Get
    Set
member CoordinateFormat : CoordinateFormat with get, set

function get_CoordinateFormat();
function set_CoordinateFormat(value);
public:
property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
    void set (CoordinateFormat value);
}

Property Value

Type: CoordinateFormat
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.Index Property

Grid Solutions Framework AnalogChannelIndex Property
Gets or sets index of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
member Index : int with get, set

function get_Index();
function set_Index(value);
public:
property int Index {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.MaxValue Property

Grid Solutions Framework AnalogChannelMaxValue Property
Gets or sets maximum unscaled value of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaxValue { get; set; }
Public Property MaxValue As Integer
    Get
    Set
member MaxValue : int with get, set

function get_MaxValue();
function set_MaxValue(value);
public:
property int MaxValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.MinValue Property

Grid Solutions Framework AnalogChannelMinValue Property
Gets or sets minimum unscaled value of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MinValue { get; set; }
Public Property MinValue As Integer
    Get
    Set
member MinValue : int with get, set

function get_MinValue();
function set_MinValue(value);
public:
property int MinValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.Multiplier Property

Grid Solutions Framework AnalogChannelMultiplier Property
Gets or sets value multipler of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Multiplier { get; set; }
Public Property Multiplier As Double
    Get
    Set
member Multiplier : float with get, set

function get_Multiplier();
function set_Multiplier(value);
public:
property double Multiplier {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.Name Property

Grid Solutions Framework AnalogChannelName Property
Gets or sets name of this AnalogChannel formatted as station_name:channel_name.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
FormatException | Name must be formatted as station_name:channel_name.
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.NominalFrequency Property

Grid Solutions Framework AnalogChannelNominalFrequency Property
Gets or sets nominal frequency of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double NominalFrequency { get; set; }
Public Property NominalFrequency As Double
    Get
    Set
member NominalFrequency : float with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
public:
property double NominalFrequency {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.PhaseDesignation Property

Grid Solutions Framework AnalogChannelPhaseDesignation Property
Gets or sets phase designation of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string PhaseDesignation { get; set; }
Public Property PhaseDesignation As String
    Get
    Set
member PhaseDesignation : string with get, set

function get_PhaseDesignation();
function set_PhaseDesignation(value);
public:
property String^ PhaseDesignation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentException | Value is not a valid phase designation.
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.PhaseID Property

Grid Solutions Framework AnalogChannelPhaseID Property
Gets or sets the 2-character phase identifier for this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string PhaseID { get; set; }
Public Property PhaseID As String
    Get
    Set
member PhaseID : string with get, set

function get_PhaseID();
function set_PhaseID(value);
public:
property String^ PhaseID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.PhasorType Property

Grid Solutions Framework AnalogChannelPhasorType Property
Gets or sets phasor type of this AnalogChannel, if applicable.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorType PhasorType { get; set; }
Public Property PhasorType As PhasorType
    Get
    Set
member PhasorType : PhasorType with get, set

function get_PhasorType();
function set_PhasorType(value);
public:
property PhasorType PhasorType {
    PhasorType get ();
    void set (PhasorType value);
}

Property Value

Type: PhasorType
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.PrimaryRatio Property

Grid Solutions Framework AnalogChannelPrimaryRatio Property
Gets or sets the channel voltage or current transformer ratio primary factor of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double PrimaryRatio { get; set; }
Public Property PrimaryRatio As Double
    Get
    Set
member PrimaryRatio : float with get, set

function get_PrimaryRatio();
function set_PrimaryRatio(value);
public:
property double PrimaryRatio {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.ScalingIdentifier Property

Grid Solutions Framework AnalogChannelScalingIdentifier Property
Gets or sets the the primary or secondary data scaling identifer of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char ScalingIdentifier { get; set; }
Public Property ScalingIdentifier As Char
    Get
    Set
member ScalingIdentifier : char with get, set

function get_ScalingIdentifier();
function set_ScalingIdentifier(value);
public:
property wchar_t ScalingIdentifier {
    wchar_t get ();
    void set (wchar_t value);
}

Property Value

Type: Char
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.SecondaryRatio Property

Grid Solutions Framework AnalogChannelSecondaryRatio Property
Gets or sets the channel voltage or current transformer ratio secondary factor of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double SecondaryRatio { get; set; }
Public Property SecondaryRatio As Double
    Get
    Set
member SecondaryRatio : float with get, set

function get_SecondaryRatio();
function set_SecondaryRatio(value);
public:
property double SecondaryRatio {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.SignalKind Property

Grid Solutions Framework AnalogChannelSignalKind Property
Gets or sets signal kind of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SignalKind SignalKind { get; set; }
Public Property SignalKind As SignalKind
    Get
    Set
member SignalKind : SignalKind with get, set

function get_SignalKind();
function set_SignalKind(value);
public:
property SignalKind SignalKind {
    SignalKind get ();
    void set (SignalKind value);
}

Property Value

Type: SignalKind
Exceptions
Exception | Condition
ArgumentException | Value is not a valid analog signal kind.
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.Skew Property

Grid Solutions Framework AnalogChannelSkew Property
Gets or sets time skew between channels of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Skew { get; set; }
Public Property Skew As Double
    Get
    Set
member Skew : float with get, set

function get_Skew();
function set_Skew(value);
public:
property double Skew {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.StationName Property

Grid Solutions Framework AnalogChannelStationName Property
Gets or sets station name component of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StationName { get; set; }
Public Property StationName As String
    Get
    Set
member StationName : string with get, set

function get_StationName();
function set_StationName(value);
public:
property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


AnalogChannel.Units Property

Grid Solutions Framework AnalogChannelUnits Property
Gets or sets units of this AnalogChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Units { get; set; }
Public Property Units As String
    Get
    Set
member Units : string with get, set

function get_Units();
function set_Units(value);
public:
property String^ Units {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AnalogChannel Class
GSF.COMTRADE Namespace


ChannelMetadata Structure

Grid Solutions Framework ChannelMetadata Structure
Defines a minimal set of channel metadata for a COMTRADE config file.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct ChannelMetadata
Public Structure ChannelMetadata
[<SealedAttribute>]
type ChannelMetadata =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class ChannelMetadata

The ChannelMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | IsDigital | Determines if channel is a digital.
Public field | Name | Channel name.
Public field | SignalType | Channel signal type.
Top
See Also

Reference

GSF.COMTRADE Namespace


ChannelMetadata Fields

Grid Solutions Framework ChannelMetadata Fields

The ChannelMetadata type exposes the following members.

Fields
 | Name | Description
Public field | IsDigital | Determines if channel is a digital.
Public field | Name | Channel name.
Public field | SignalType | Channel signal type.
Top
See Also

Reference

ChannelMetadata Structure
GSF.COMTRADE Namespace


ChannelMetadata.IsDigital Field

Grid Solutions Framework ChannelMetadataIsDigital Field
Determines if channel is a digital.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDigital
Public IsDigital As Boolean
val mutable IsDigital: bool
var IsDigital
public:
bool IsDigital

Field Value

Type: Boolean
Remarks
Channel is assumed to be an analog if field is false.
See Also

Reference

ChannelMetadata Structure
GSF.COMTRADE Namespace


ChannelMetadata.Name Field

Grid Solutions Framework ChannelMetadataName Field
Channel name.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name
Public Name As String
val mutable Name: string
var Name
public:
String^ Name

Field Value

Type: String
See Also

Reference

ChannelMetadata Structure
GSF.COMTRADE Namespace


ChannelMetadata.SignalType Field

Grid Solutions Framework ChannelMetadataSignalType Field
Channel signal type.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SignalType SignalType
Public SignalType As SignalType
val mutable SignalType: SignalType
var SignalType
public:
SignalType SignalType

Field Value

Type: SignalType
See Also

Reference

ChannelMetadata Structure
GSF.COMTRADE Namespace


ChannelMetadata Methods

Grid Solutions Framework ChannelMetadata Methods

The ChannelMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelMetadata Structure
GSF.COMTRADE Namespace


ChannelMetadataSorter Class

Grid Solutions Framework ChannelMetadataSorter Class
Defines a comparison class to property sort metadata.
Inheritance Hierarchy
SystemObject
GSF.COMTRADEChannelMetadataSorter

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ChannelMetadataSorter : IComparer<ChannelMetadata>
Public Class ChannelMetadataSorter
    Implements IComparer(Of ChannelMetadata)
type ChannelMetadataSorter =
    class
        interface IComparer<ChannelMetadata>
    end
GSF.COMTRADE.ChannelMetadataSorter = function();

Type.createClass(
    'GSF.COMTRADE.ChannelMetadataSorter',
    null,
    IComparer`1);
public ref class ChannelMetadataSorter : IComparer<ChannelMetadata>

The ChannelMetadataSorter type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelMetadataSorter | Initializes a new instance of the ChannelMetadataSorter class
Top
Methods
 | Name | Description
Public method | Compare | Compares one metadata record to another.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Default | Default instance of the metadata record sorter.
Top
See Also

Reference

GSF.COMTRADE Namespace


ChannelMetadataSorter Constructor

Grid Solutions Framework ChannelMetadataSorter Constructor
Initializes a new instance of the ChannelMetadataSorter class

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelMetadataSorter()
Public Sub New
new : unit -> ChannelMetadataSorter
GSF.COMTRADE.ChannelMetadataSorter = function();
public:
ChannelMetadataSorter()
See Also

Reference

ChannelMetadataSorter Class
GSF.COMTRADE Namespace


ChannelMetadataSorter Fields

Grid Solutions Framework ChannelMetadataSorter Fields

The ChannelMetadataSorter type exposes the following members.

Fields
Name | Description
Default | Default instance of the metadata record sorter.
Top
See Also

Reference

ChannelMetadataSorter Class
GSF.COMTRADE Namespace


ChannelMetadataSorter.Default Field

Grid Solutions Framework ChannelMetadataSorterDefault Field
Default instance of the metadata record sorter.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly ChannelMetadataSorter Default
Public Shared ReadOnly Default As ChannelMetadataSorter
static val Default: ChannelMetadataSorter
var GSF.COMTRADE.ChannelMetadataSorter.Default
public:
static initonly ChannelMetadataSorter^ Default

Field Value

Type: ChannelMetadataSorter
See Also

Reference

ChannelMetadataSorter Class
GSF.COMTRADE Namespace


ChannelMetadataSorter Methods

Grid Solutions Framework ChannelMetadataSorter Methods

The ChannelMetadataSorter type exposes the following members.

Methods
 | Name | Description
Public method | Compare | Compares one metadata record to another.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelMetadataSorter Class
GSF.COMTRADE Namespace


ChannelMetadataSorter.Compare Method

Grid Solutions Framework ChannelMetadataSorterCompare Method
Compares one metadata record to another.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compare(
    ChannelMetadata left,
    ChannelMetadata right
)
Public Function Compare (
    left As ChannelMetadata,
    right As ChannelMetadata
) As Integer
abstract Compare :
        left : ChannelMetadata *
        right : ChannelMetadata -> int
override Compare :
        left : ChannelMetadata *
        right : ChannelMetadata -> int
function Compare(left, right);
public:
virtual int Compare(
    ChannelMetadata left,
    ChannelMetadata right
) sealed

Parameters

left
Type: GSF.COMTRADEChannelMetadata
Left metadata record to compare.
right
Type: GSF.COMTRADEChannelMetadata
Right metadata record to compare.

Return Value

Type: Int32
Comparison sort order of metadata record.

Implements

IComparerTCompare(T, T)
See Also

Reference

ChannelMetadataSorter Class
GSF.COMTRADE Namespace


DigitalChannel Class

Grid Solutions Framework DigitalChannel Class
Represents a digital channel definition of the Schema.
Inheritance Hierarchy
SystemObject
GSF.COMTRADEDigitalChannel

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DigitalChannel
Public Class DigitalChannel
type DigitalChannel =  class end
GSF.COMTRADE.DigitalChannel = function();

Type.createClass(
    'GSF.COMTRADE.DigitalChannel');
public ref class DigitalChannel

The DigitalChannel type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalChannel | Creates a new instance of the DigitalChannel.
Public method | DigitalChannel(String) | Creates a new instance of the DigitalChannel from an existing line image.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts DigitalChannel to its string format. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ChannelName | Gets or sets channel name component of this DigitalChannel.
Public property | CircuitComponent | Gets or sets circuit component of this DigitalChannel.
Public property | Index | Gets or sets index of this DigitalChannel.
Public property | Name | Gets or sets name of this DigitalChannel formatted as station_name:channel_name.
Public property | NormalState | Gets or sets normal state of this DigitalChannel.
Public property | PhaseID | Gets or sets the 2-character phase identifier for this DigitalChannel.
Public property | StationName | Gets or sets station name component of this DigitalChannel.
Top
See Also

Reference

GSF.COMTRADE Namespace


DigitalChannel Constructor

Grid Solutions Framework DigitalChannel Constructor
Overload List
 | Name | Description
Public method | DigitalChannel | Creates a new instance of the DigitalChannel.
Public method | DigitalChannel(String) | Creates a new instance of the DigitalChannel from an existing line image.
Top
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel Constructor

Grid Solutions Framework DigitalChannel Constructor
Creates a new instance of the DigitalChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalChannel()
Public Sub New
new : unit -> DigitalChannel
GSF.COMTRADE.DigitalChannel = function();
public:
DigitalChannel()
See Also

Reference

DigitalChannel Class
DigitalChannel Overload
GSF.COMTRADE Namespace


DigitalChannel Constructor (String)

Grid Solutions Framework DigitalChannel Constructor (String)
Creates a new instance of the DigitalChannel from an existing line image.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalChannel(
    string lineImage
)
Public Sub New (
    lineImage As String
)
new :
        lineImage : string -> DigitalChannel
GSF.COMTRADE.DigitalChannel = function(lineImage);
public:
DigitalChannel(
    String^ lineImage
)

Parameters

lineImage
Type: SystemString
Line image to parse.
See Also

Reference

DigitalChannel Class
DigitalChannel Overload
GSF.COMTRADE Namespace


DigitalChannel Methods

Grid Solutions Framework DigitalChannel Methods

The DigitalChannel type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Converts DigitalChannel to its string format. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.ToString Method

Grid Solutions Framework DigitalChannelToString Method
Converts DigitalChannel to its string format.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.COMTRADE.DigitalChannel.ToString"]

See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel Properties

Grid Solutions Framework DigitalChannel Properties

The DigitalChannel type exposes the following members.

Properties
 | Name | Description
Public property | ChannelName | Gets or sets channel name component of this DigitalChannel.
Public property | CircuitComponent | Gets or sets circuit component of this DigitalChannel.
Public property | Index | Gets or sets index of this DigitalChannel.
Public property | Name | Gets or sets name of this DigitalChannel formatted as station_name:channel_name.
Public property | NormalState | Gets or sets normal state of this DigitalChannel.
Public property | PhaseID | Gets or sets the 2-character phase identifier for this DigitalChannel.
Public property | StationName | Gets or sets station name component of this DigitalChannel.
Top
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.ChannelName Property

Grid Solutions Framework DigitalChannelChannelName Property
Gets or sets channel name component of this DigitalChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ChannelName { get; set; }
Public Property ChannelName As String
    Get
    Set
member ChannelName : string with get, set

function get_ChannelName();
function set_ChannelName(value);
public:
property String^ ChannelName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.CircuitComponent Property

Grid Solutions Framework DigitalChannelCircuitComponent Property
Gets or sets circuit component of this DigitalChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CircuitComponent { get; set; }
Public Property CircuitComponent As String
    Get
    Set
member CircuitComponent : string with get, set

function get_CircuitComponent();
function set_CircuitComponent(value);
public:
property String^ CircuitComponent {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.Index Property

Grid Solutions Framework DigitalChannelIndex Property
Gets or sets index of this DigitalChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Index { get; set; }
Public Property Index As Integer
    Get
    Set
member Index : int with get, set

function get_Index();
function set_Index(value);
public:
property int Index {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.Name Property

Grid Solutions Framework DigitalChannelName Property
Gets or sets name of this DigitalChannel formatted as station_name:channel_name.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
FormatException | Name must be formatted as station_name:channel_name.
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.NormalState Property

Grid Solutions Framework DigitalChannelNormalState Property
Gets or sets normal state of this DigitalChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool NormalState { get; set; }
Public Property NormalState As Boolean
    Get
    Set
member NormalState : bool with get, set

function get_NormalState();
function set_NormalState(value);
public:
property bool NormalState {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.PhaseID Property

Grid Solutions Framework DigitalChannelPhaseID Property
Gets or sets the 2-character phase identifier for this DigitalChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string PhaseID { get; set; }
Public Property PhaseID As String
    Get
    Set
member PhaseID : string with get, set

function get_PhaseID();
function set_PhaseID(value);
public:
property String^ PhaseID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


DigitalChannel.StationName Property

Grid Solutions Framework DigitalChannelStationName Property
Gets or sets station name component of this DigitalChannel.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StationName { get; set; }
Public Property StationName As String
    Get
    Set
member StationName : string with get, set

function get_StationName();
function set_StationName(value);
public:
property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DigitalChannel Class
GSF.COMTRADE Namespace


FileType Enumeration

Grid Solutions Framework FileType Enumeration
Schema file type enumeration.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum FileType
Public Enumeration FileType
type FileType
GSF.COMTRADE.FileType = function();
GSF.COMTRADE.FileType.createEnum('GSF.COMTRADE.FileType', false);
public enum class FileType
Members
Member name | Value | Description
Ascii | 0 | ASCII file type.
Binary | 1 | Binary file type.
See Also

Reference

GSF.COMTRADE Namespace


Parser Class

Grid Solutions Framework Parser Class
COMTRADE data file(s) parser.
Inheritance Hierarchy
SystemObject
GSF.COMTRADEParser

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Parser : IDisposable
Public Class Parser
    Implements IDisposable
type Parser =
    class
        interface IDisposable
    end
GSF.COMTRADE.Parser = function();

Type.createClass(
    'GSF.COMTRADE.Parser',
    null,
    IDisposable);
public ref class Parser : IDisposable

The Parser type exposes the following members.

Constructors
 | Name | Description
Public method | Parser | Creates a new instance of the COMTRADE Parser.
Top
Methods
 | Name | Description
Public method | CloseFiles | Closes all COMTRADE data file streams.
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Parser object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFiles | Opens all COMTRADE data file streams.
Public method | ReadNext | Reads next COMTRADE record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | FileName | Gets or sets COMTRADE data filename. If there are more than one data files in a set, this should be set to first file name in the set, e.g., DATA123.D00.
Public property | InferTimeFromSampleRates | Gets or sets flag that determines if time should be inferred from sample rates.
Public property | PrimaryValues | Gets values of current record with secondary analog channels scaled to primary values.
Public property | Schema | Gets or sets associated COMTRADE schema for this Parser.
Public property | SecondaryValues | Gets values of current record with primary analog channels scaled to secondary values.
Public property | Timestamp | Gets timestamp of current record.
Public property | Values | Gets values of current record.
Top
See Also

Reference

GSF.COMTRADE Namespace


Parser Constructor

Grid Solutions Framework Parser Constructor
Creates a new instance of the COMTRADE Parser.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Parser()
Public Sub New
new : unit -> Parser
GSF.COMTRADE.Parser = function();
public:
Parser()
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser Methods

Grid Solutions Framework Parser Methods

The Parser type exposes the following members.

Methods
 | Name | Description
Public method | CloseFiles | Closes all COMTRADE data file streams.
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Parser object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFiles | Opens all COMTRADE data file streams.
Public method | ReadNext | Reads next COMTRADE record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.CloseFiles Method

Grid Solutions Framework ParserCloseFiles Method
Closes all COMTRADE data file streams.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CloseFiles()
Public Sub CloseFiles
member CloseFiles : unit -> unit

function CloseFiles();
public:
void CloseFiles()
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.Dispose Method

Grid Solutions Framework ParserDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Top
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.Dispose Method

Grid Solutions Framework ParserDispose Method
Releases all the resources used by the Parser object.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

Parser Class
Dispose Overload
GSF.COMTRADE Namespace


Parser.Dispose Method (Boolean)

Grid Solutions Framework ParserDispose Method (Boolean)
Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

Parser Class
Dispose Overload
GSF.COMTRADE Namespace


Parser.Finalize Method

Grid Solutions Framework ParserFinalize Method
Releases the unmanaged resources before the Parser object is reclaimed by GC.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.OpenFiles Method

Grid Solutions Framework ParserOpenFiles Method
Opens all COMTRADE data file streams.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void OpenFiles()
Public Sub OpenFiles
member OpenFiles : unit -> unit

function OpenFiles();
public:
void OpenFiles()
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.ReadNext Method

Grid Solutions Framework ParserReadNext Method
Reads next COMTRADE record.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReadNext()
Public Function ReadNext As Boolean
member ReadNext : unit -> bool

function ReadNext();
public:
bool ReadNext()

Return Value

Type: Boolean
true if read succeeded; otherwise false if end of data set was reached.
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser Properties

Grid Solutions Framework Parser Properties

The Parser type exposes the following members.

Properties
 | Name | Description
Public property | FileName | Gets or sets COMTRADE data filename. If there are more than one data files in a set, this should be set to first file name in the set, e.g., DATA123.D00.
Public property | InferTimeFromSampleRates | Gets or sets flag that determines if time should be inferred from sample rates.
Public property | PrimaryValues | Gets values of current record with secondary analog channels scaled to primary values.
Public property | Schema | Gets or sets associated COMTRADE schema for this Parser.
Public property | SecondaryValues | Gets values of current record with primary analog channels scaled to secondary values.
Public property | Timestamp | Gets timestamp of current record.
Public property | Values | Gets values of current record.
Top
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.FileName Property

Grid Solutions Framework ParserFileName Property
Gets or sets COMTRADE data filename. If there are more than one data files in a set, this should be set to first file name in the set, e.g., DATA123.D00.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.InferTimeFromSampleRates Property

Grid Solutions Framework ParserInferTimeFromSampleRates Property
Gets or sets flag that determines if time should be inferred from sample rates.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InferTimeFromSampleRates { get; set; }
Public Property InferTimeFromSampleRates As Boolean
    Get
    Set
member InferTimeFromSampleRates : bool with get, set

function get_InferTimeFromSampleRates();
function set_InferTimeFromSampleRates(value);
public:
property bool InferTimeFromSampleRates {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.PrimaryValues Property

Grid Solutions Framework ParserPrimaryValues Property
Gets values of current record with secondary analog channels scaled to primary values.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double[] PrimaryValues { get; }
Public ReadOnly Property PrimaryValues As Double()
    Get
member PrimaryValues : float[] with get

function get_PrimaryValues();

public:
property array<double>^ PrimaryValues {
    array<double>^ get ();
}

Property Value

Type: Double
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.Schema Property

Grid Solutions Framework ParserSchema Property
Gets or sets associated COMTRADE schema for this Parser.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schema Schema { get; set; }
Public Property Schema As Schema
    Get
    Set
member Schema : Schema with get, set

function get_Schema();
function set_Schema(value);
public:
property Schema^ Schema {
    Schema^ get ();
    void set (Schema^ value);
}

Property Value

Type: Schema
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.SecondaryValues Property

Grid Solutions Framework ParserSecondaryValues Property
Gets values of current record with primary analog channels scaled to secondary values.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double[] SecondaryValues { get; }
Public ReadOnly Property SecondaryValues As Double()
    Get
member SecondaryValues : float[] with get

function get_SecondaryValues();

public:
property array<double>^ SecondaryValues {
    array<double>^ get ();
}

Property Value

Type: Double
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.Timestamp Property

Grid Solutions Framework ParserTimestamp Property
Gets timestamp of current record.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Timestamp { get; }
Public ReadOnly Property Timestamp As DateTime
    Get
member Timestamp : DateTime with get

function get_Timestamp();

public:
property DateTime Timestamp {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


Parser.Values Property

Grid Solutions Framework ParserValues Property
Gets values of current record.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double[] Values { get; }
Public ReadOnly Property Values As Double()
    Get
member Values : float[] with get

function get_Values();

public:
property array<double>^ Values {
    array<double>^ get ();
}

Property Value

Type: Double
See Also

Reference

Parser Class
GSF.COMTRADE Namespace


SampleRate Structure

Grid Solutions Framework SampleRate Structure
Represents a sample rate with associated ending sample using the COMTRADE file standard, IEEE Std C37.111-1999.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SampleRate
Public Structure SampleRate
[<SealedAttribute>]
type SampleRate =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SampleRate

The SampleRate type exposes the following members.

Constructors
 | Name | Description
Public method | SampleRate | Creates a new instance of the SampleRate from an existing line image.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts SampleRate to its string format. (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | EndSample | Last sample number at sample rate.
Public field | Rate | Sample rate in Hertz (Hz).
Top
See Also

Reference

GSF.COMTRADE Namespace


SampleRate Constructor

Grid Solutions Framework SampleRate Constructor
Creates a new instance of the SampleRate from an existing line image.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SampleRate(
    string lineImage
)
Public Sub New (
    lineImage As String
)
new :
        lineImage : string -> SampleRate
GSF.COMTRADE.SampleRate = function(lineImage);
public:
SampleRate(
    String^ lineImage
)

Parameters

lineImage
Type: SystemString
Line image to parse.
See Also

Reference

SampleRate Structure
GSF.COMTRADE Namespace


SampleRate Fields

Grid Solutions Framework SampleRate Fields

The SampleRate type exposes the following members.

Fields
 | Name | Description
Public field | EndSample | Last sample number at sample rate.
Public field | Rate | Sample rate in Hertz (Hz).
Top
See Also

Reference

SampleRate Structure
GSF.COMTRADE Namespace


SampleRate.EndSample Field

Grid Solutions Framework SampleRateEndSample Field
Last sample number at sample rate.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int EndSample
Public EndSample As Integer
val mutable EndSample: int
var EndSample
public:
int EndSample

Field Value

Type: Int32
See Also

Reference

SampleRate Structure
GSF.COMTRADE Namespace


SampleRate.Rate Field

Grid Solutions Framework SampleRateRate Field
Sample rate in Hertz (Hz).

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Rate
Public Rate As Double
val mutable Rate: float
var Rate
public:
double Rate

Field Value

Type: Double
See Also

Reference

SampleRate Structure
GSF.COMTRADE Namespace


SampleRate Methods

Grid Solutions Framework SampleRate Methods

The SampleRate type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts SampleRate to its string format. (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SampleRate Structure
GSF.COMTRADE Namespace


SampleRate.ToString Method

Grid Solutions Framework SampleRateToString Method
Converts SampleRate to its string format.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.COMTRADE.SampleRate.ToString"]

See Also

Reference

SampleRate Structure
GSF.COMTRADE Namespace


Schema Class

Grid Solutions Framework Schema Class
Represents the schema for a configuration file in the COMTRADE file standard, IEEE Std C37.111-1999.
Inheritance Hierarchy
SystemObject
GSF.COMTRADESchema

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Schema
Public Class Schema
type Schema =  class end
GSF.COMTRADE.Schema = function();

Type.createClass(
    'GSF.COMTRADE.Schema');
public ref class Schema

The Schema type exposes the following members.

Constructors
 | Name | Description
Public method | Schema | Creates a new instance of the Schema.
Public method | Schema(String) | Creates a new instance of the Schema from an existing configuration file name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogChannels | Gets or sets analog channels of this Schema.
Public property | BinaryRecordLength | Calculates the size of a record, in bytes, when the file type is binary.
Public property | DeviceID | Gets or sets free-form device ID for this Schema.
Public property | DigitalChannels | Gets or sets digital channels of this Schema.
Public property | DigitalWords | Gets the total digital words for given number of digital values when the file type is binary.
Public property | FileImage | Gets the file image of this Schema.
Public property | FileType | Gets or sets file type of this Schema.
Public property | NominalFrequency | Gets or sets nominal frequency of this Schema.
Public property | SampleRates | Gets or sets sampling rates of this Schema. A file of phasor data will normally be made using a single sampling rate, so this will usually be 1.
Public property | StartTime | Gets or sets start timestamp of this Schema.
Public property | StationName | Gets or sets free-form station name for this Schema.
Public property | TimeFactor | Gets or sets the multiplication factor for the time differential (timestamp) field in this Schema.
Public property | TotalAnalogChannels | Gets total number of analog channels of this Schema.
Public property | TotalChannels | Gets total number of analog and digital channels of this Schema.
Public property | TotalDigitalChannels | Gets total number of digital channels of this Schema.
Public property | TotalSampleRates | Gets total number of sample rates of this Schema.
Public property | TriggerTime | Gets or sets trigger timestamp of this Schema.
Public property | Version | Gets or sets version number of the IEEE Std C37.111 used by this Schema.
Top
See Also

Reference

GSF.COMTRADE Namespace


Schema Constructor

Grid Solutions Framework Schema Constructor
Overload List
 | Name | Description
Public method | Schema | Creates a new instance of the Schema.
Public method | Schema(String) | Creates a new instance of the Schema from an existing configuration file name.
Top
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema Constructor

Grid Solutions Framework Schema Constructor
Creates a new instance of the Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schema()
Public Sub New
new : unit -> Schema
GSF.COMTRADE.Schema = function();
public:
Schema()
See Also

Reference

Schema Class
Schema Overload
GSF.COMTRADE Namespace


Schema Constructor (String)

Grid Solutions Framework Schema Constructor (String)
Creates a new instance of the Schema from an existing configuration file name.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schema(
    string fileName
)
Public Sub New (
    fileName As String
)
new :
        fileName : string -> Schema
GSF.COMTRADE.Schema = function(fileName);
public:
Schema(
    String^ fileName
)

Parameters

fileName
Type: SystemString
File name of configuration file to parse.
See Also

Reference

Schema Class
Schema Overload
GSF.COMTRADE Namespace


Schema Methods

Grid Solutions Framework Schema Methods

The Schema type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema Properties

Grid Solutions Framework Schema Properties

The Schema type exposes the following members.

Properties
 | Name | Description
Public property | AnalogChannels | Gets or sets analog channels of this Schema.
Public property | BinaryRecordLength | Calculates the size of a record, in bytes, when the file type is binary.
Public property | DeviceID | Gets or sets free-form device ID for this Schema.
Public property | DigitalChannels | Gets or sets digital channels of this Schema.
Public property | DigitalWords | Gets the total digital words for given number of digital values when the file type is binary.
Public property | FileImage | Gets the file image of this Schema.
Public property | FileType | Gets or sets file type of this Schema.
Public property | NominalFrequency | Gets or sets nominal frequency of this Schema.
Public property | SampleRates | Gets or sets sampling rates of this Schema. A file of phasor data will normally be made using a single sampling rate, so this will usually be 1.
Public property | StartTime | Gets or sets start timestamp of this Schema.
Public property | StationName | Gets or sets free-form station name for this Schema.
Public property | TimeFactor | Gets or sets the multiplication factor for the time differential (timestamp) field in this Schema.
Public property | TotalAnalogChannels | Gets total number of analog channels of this Schema.
Public property | TotalChannels | Gets total number of analog and digital channels of this Schema.
Public property | TotalDigitalChannels | Gets total number of digital channels of this Schema.
Public property | TotalSampleRates | Gets total number of sample rates of this Schema.
Public property | TriggerTime | Gets or sets trigger timestamp of this Schema.
Public property | Version | Gets or sets version number of the IEEE Std C37.111 used by this Schema.
Top
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.AnalogChannels Property

Grid Solutions Framework SchemaAnalogChannels Property
Gets or sets analog channels of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogChannel[] AnalogChannels { get; set; }
Public Property AnalogChannels As AnalogChannel()
    Get
    Set
member AnalogChannels : AnalogChannel[] with get, set

function get_AnalogChannels();
function set_AnalogChannels(value);
public:
property array<AnalogChannel^>^ AnalogChannels {
    array<AnalogChannel^>^ get ();
    void set (array<AnalogChannel^>^ value);
}

Property Value

Type: AnalogChannel
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.BinaryRecordLength Property

Grid Solutions Framework SchemaBinaryRecordLength Property
Calculates the size of a record, in bytes, when the file type is binary.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryRecordLength { get; }
Public ReadOnly Property BinaryRecordLength As Integer
    Get
member BinaryRecordLength : int with get

function get_BinaryRecordLength();

public:
property int BinaryRecordLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.DeviceID Property

Grid Solutions Framework SchemaDeviceID Property
Gets or sets free-form device ID for this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DeviceID { get; set; }
Public Property DeviceID As String
    Get
    Set
member DeviceID : string with get, set

function get_DeviceID();
function set_DeviceID(value);
public:
property String^ DeviceID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.DigitalChannels Property

Grid Solutions Framework SchemaDigitalChannels Property
Gets or sets digital channels of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalChannel[] DigitalChannels { get; set; }
Public Property DigitalChannels As DigitalChannel()
    Get
    Set
member DigitalChannels : DigitalChannel[] with get, set

function get_DigitalChannels();
function set_DigitalChannels(value);
public:
property array<DigitalChannel^>^ DigitalChannels {
    array<DigitalChannel^>^ get ();
    void set (array<DigitalChannel^>^ value);
}

Property Value

Type: DigitalChannel
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.DigitalWords Property

Grid Solutions Framework SchemaDigitalWords Property
Gets the total digital words for given number of digital values when the file type is binary.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DigitalWords { get; }
Public ReadOnly Property DigitalWords As Integer
    Get
member DigitalWords : int with get

function get_DigitalWords();

public:
property int DigitalWords {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.FileImage Property

Grid Solutions Framework SchemaFileImage Property
Gets the file image of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileImage { get; }
Public ReadOnly Property FileImage As String
    Get
member FileImage : string with get

function get_FileImage();

public:
property String^ FileImage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.FileType Property

Grid Solutions Framework SchemaFileType Property
Gets or sets file type of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileType FileType { get; set; }
Public Property FileType As FileType
    Get
    Set
member FileType : FileType with get, set

function get_FileType();
function set_FileType(value);
public:
property FileType FileType {
    FileType get ();
    void set (FileType value);
}

Property Value

Type: FileType
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.NominalFrequency Property

Grid Solutions Framework SchemaNominalFrequency Property
Gets or sets nominal frequency of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double NominalFrequency { get; set; }
Public Property NominalFrequency As Double
    Get
    Set
member NominalFrequency : float with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
public:
property double NominalFrequency {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.SampleRates Property

Grid Solutions Framework SchemaSampleRates Property
Gets or sets sampling rates of this Schema. A file of phasor data will normally be made using a single sampling rate, so this will usually be 1.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SampleRate[] SampleRates { get; set; }
Public Property SampleRates As SampleRate()
    Get
    Set
member SampleRates : SampleRate[] with get, set

function get_SampleRates();
function set_SampleRates(value);
public:
property array<SampleRate>^ SampleRates {
    array<SampleRate>^ get ();
    void set (array<SampleRate>^ value);
}

Property Value

Type: SampleRate
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.StartTime Property

Grid Solutions Framework SchemaStartTime Property
Gets or sets start timestamp of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Timestamp StartTime { get; set; }
Public Property StartTime As Timestamp
    Get
    Set
member StartTime : Timestamp with get, set

function get_StartTime();
function set_StartTime(value);
public:
property Timestamp StartTime {
    Timestamp get ();
    void set (Timestamp value);
}

Property Value

Type: Timestamp
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.StationName Property

Grid Solutions Framework SchemaStationName Property
Gets or sets free-form station name for this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StationName { get; set; }
Public Property StationName As String
    Get
    Set
member StationName : string with get, set

function get_StationName();
function set_StationName(value);
public:
property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.TimeFactor Property

Grid Solutions Framework SchemaTimeFactor Property
Gets or sets the multiplication factor for the time differential (timestamp) field in this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double TimeFactor { get; set; }
Public Property TimeFactor As Double
    Get
    Set
member TimeFactor : float with get, set

function get_TimeFactor();
function set_TimeFactor(value);
public:
property double TimeFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.TotalAnalogChannels Property

Grid Solutions Framework SchemaTotalAnalogChannels Property
Gets total number of analog channels of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TotalAnalogChannels { get; }
Public ReadOnly Property TotalAnalogChannels As Integer
    Get
member TotalAnalogChannels : int with get

function get_TotalAnalogChannels();

public:
property int TotalAnalogChannels {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.TotalChannels Property

Grid Solutions Framework SchemaTotalChannels Property
Gets total number of analog and digital channels of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TotalChannels { get; }
Public ReadOnly Property TotalChannels As Integer
    Get
member TotalChannels : int with get

function get_TotalChannels();

public:
property int TotalChannels {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.TotalDigitalChannels Property

Grid Solutions Framework SchemaTotalDigitalChannels Property
Gets total number of digital channels of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TotalDigitalChannels { get; }
Public ReadOnly Property TotalDigitalChannels As Integer
    Get
member TotalDigitalChannels : int with get

function get_TotalDigitalChannels();

public:
property int TotalDigitalChannels {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.TotalSampleRates Property

Grid Solutions Framework SchemaTotalSampleRates Property
Gets total number of sample rates of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TotalSampleRates { get; }
Public ReadOnly Property TotalSampleRates As Integer
    Get
member TotalSampleRates : int with get

function get_TotalSampleRates();

public:
property int TotalSampleRates {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.TriggerTime Property

Grid Solutions Framework SchemaTriggerTime Property
Gets or sets trigger timestamp of this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Timestamp TriggerTime { get; set; }
Public Property TriggerTime As Timestamp
    Get
    Set
member TriggerTime : Timestamp with get, set

function get_TriggerTime();
function set_TriggerTime(value);
public:
property Timestamp TriggerTime {
    Timestamp get ();
    void set (Timestamp value);
}

Property Value

Type: Timestamp
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Schema.Version Property

Grid Solutions Framework SchemaVersion Property
Gets or sets version number of the IEEE Std C37.111 used by this Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Version { get; set; }
Public Property Version As Integer
    Get
    Set
member Version : int with get, set

function get_Version();
function set_Version(value);
public:
property int Version {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Only IEEE Std C37.111 version 1999 is supported by this implementation of the phasor data schema.
See Also

Reference

Schema Class
GSF.COMTRADE Namespace


Timestamp Structure

Grid Solutions Framework Timestamp Structure
Represents a timestamp in the COMTRADE file standard format, IEEE Std C37.111-1999..

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct Timestamp
Public Structure Timestamp
[<SealedAttribute>]
type Timestamp =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class Timestamp

The Timestamp type exposes the following members.

Constructors
 | Name | Description
Public method | Timestamp | Creates a new instance of the Timestamp from an existing line image.
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts Timestamp to its string format. (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Value | Timestamp in ticks.
Top
See Also

Reference

GSF.COMTRADE Namespace


Timestamp Constructor

Grid Solutions Framework Timestamp Constructor
Creates a new instance of the Timestamp from an existing line image.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Timestamp(
    string lineImage
)
Public Sub New (
    lineImage As String
)
new :
        lineImage : string -> Timestamp
GSF.COMTRADE.Timestamp = function(lineImage);
public:
Timestamp(
    String^ lineImage
)

Parameters

lineImage
Type: SystemString
Line image to parse.
See Also

Reference

Timestamp Structure
GSF.COMTRADE Namespace


Timestamp Fields

Grid Solutions Framework Timestamp Fields

The Timestamp type exposes the following members.

Fields
 | Name | Description
Public field | Value | Timestamp in ticks.
Top
See Also

Reference

Timestamp Structure
GSF.COMTRADE Namespace


Timestamp.Value Field

Grid Solutions Framework TimestampValue Field
Timestamp in ticks.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks Value
Public Value As Ticks
val mutable Value: Ticks
var Value
public:
Ticks Value

Field Value

Type: Ticks
See Also

Reference

Timestamp Structure
GSF.COMTRADE Namespace


Timestamp Methods

Grid Solutions Framework Timestamp Methods

The Timestamp type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Converts Timestamp to its string format. (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Timestamp Structure
GSF.COMTRADE Namespace


Timestamp.ToString Method

Grid Solutions Framework TimestampToString Method
Converts Timestamp to its string format.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.COMTRADE.Timestamp.ToString"]

See Also

Reference

Timestamp Structure
GSF.COMTRADE Namespace


Writer Class

Grid Solutions Framework Writer Class
COMTRADE data and config file writer.
Inheritance Hierarchy
SystemObject
GSF.COMTRADEWriter

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Writer
Public NotInheritable Class Writer
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Writer =  class end
GSF.COMTRADE.Writer = function();

Type.createClass(
    'GSF.COMTRADE.Writer');
public ref class Writer abstract sealed

The Writer type exposes the following members.

Methods
Name | Description
CreateSchema | Creates a new COMTRADE configuration Schema.
WriteNextRecordAscii | Writes next COMTRADE record in ASCII format.
WriteNextRecordBinary | Writes next COMTRADE record in binary format.
Top
See Also

Reference

GSF.COMTRADE Namespace


Writer Methods

Grid Solutions Framework Writer Methods

The Writer type exposes the following members.

Methods
Name | Description
CreateSchema | Creates a new COMTRADE configuration Schema.
WriteNextRecordAscii | Writes next COMTRADE record in ASCII format.
WriteNextRecordBinary | Writes next COMTRADE record in binary format.
Top
See Also

Reference

Writer Class
GSF.COMTRADE Namespace


Writer.CreateSchema Method

Grid Solutions Framework WriterCreateSchema Method
Creates a new COMTRADE configuration Schema.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Schema CreateSchema(
    IEnumerable<ChannelMetadata> metadata,
    string stationName,
    string deviceID,
    Ticks dataStartTime,
    int sampleCount,
    bool isBinary = true,
    double timeFactor = 1,
    double samplingRate = 30,
    double nominalFrequency = 60,
    bool includeFracSecDefinition = true
)
Public Shared Function CreateSchema (
    metadata As IEnumerable(Of ChannelMetadata),
    stationName As String,
    deviceID As String,
    dataStartTime As Ticks,
    sampleCount As Integer,
    Optional isBinary As Boolean = true,
    Optional timeFactor As Double = 1,
    Optional samplingRate As Double = 30,
    Optional nominalFrequency As Double = 60,
    Optional includeFracSecDefinition As Boolean = true
) As Schema
static member CreateSchema :
        metadata : IEnumerable<ChannelMetadata> *
        stationName : string *
        deviceID : string *
        dataStartTime : Ticks *
        sampleCount : int *
        ?isBinary : bool *
        ?timeFactor : float *
        ?samplingRate : float *
        ?nominalFrequency : float *
        ?includeFracSecDefinition : bool
(* Defaults:
        let _isBinary = defaultArg isBinary true
        let _timeFactor = defaultArg timeFactor 1
        let _samplingRate = defaultArg samplingRate 30
        let _nominalFrequency = defaultArg nominalFrequency 60
        let _includeFracSecDefinition = defaultArg includeFracSecDefinition true
*)
-> Schema

GSF.COMTRADE.Writer.CreateSchema = function(metadata, stationName, deviceID, dataStartTime, sampleCount, isBinary, timeFactor, samplingRate, nominalFrequency, includeFracSecDefinition);
public:
static Schema^ CreateSchema(
    IEnumerable<ChannelMetadata>^ metadata,
    String^ stationName,
    String^ deviceID,
    Ticks dataStartTime,
    int sampleCount,
    bool isBinary = true,
    double timeFactor = 1,
    double samplingRate = 30,
    double nominalFrequency = 60,
    bool includeFracSecDefinition = true
)

Parameters

metadata
Type: System.Collections.GenericIEnumerable ChannelMetadata
Schema ChannelMetadata records.
stationName
Type: SystemString
Station name for the schema.
deviceID
Type: SystemString
Device ID for the schema.
dataStartTime
Type: GSFTicks
Data start time.
sampleCount
Type: SystemInt32
Total data samples (i.e., total number of rows).
isBinary (Optional)
Type: SystemBoolean
Determines if data file should be binary or ASCII - defaults to true for binary.
timeFactor (Optional)
Type: SystemDouble
Time factor to use in schema - defaults to 1000.
samplingRate (Optional)
Type: SystemDouble
Desired sampling rate - defaults to 33.3333Hz.
nominalFrequency (Optional)
Type: SystemDouble
Nominal frequency - defaults to 60Hz.
includeFracSecDefinition (Optional)
Type: SystemBoolean
Determines if the FRACSEC word digital definitions should be included - defaults to true.

Return Value

Type: Schema
New COMTRADE configuration Schema.
Remarks
This function is primarily intended to create a configuration based on synchrophasor data (see Annex H: Schema for Phasor Data 2150 Using the COMTRADE File Standard in IEEE C37.111-2010), it may be necessary to manually create a schema object for other COMTRADE needs. You can call the FileImage property to return a string that that can be written to a file that will be the contents of the configuration file.
See Also

Reference

Writer Class
GSF.COMTRADE Namespace


Writer.WriteNextRecordAscii Method

Grid Solutions Framework WriterWriteNextRecordAscii Method
Writes next COMTRADE record in ASCII format.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WriteNextRecordAscii(
    StreamWriter output,
    Schema schema,
    Ticks timestamp,
    double[] values,
    uint sample,
    bool injectFracSecValue = true,
    ushort fracSecValue = 0
)
Public Shared Sub WriteNextRecordAscii (
    output As StreamWriter,
    schema As Schema,
    timestamp As Ticks,
    values As Double(),
    sample As UInteger,
    Optional injectFracSecValue As Boolean = true,
    Optional fracSecValue As UShort = 0
)
static member WriteNextRecordAscii :
        output : StreamWriter *
        schema : Schema *
        timestamp : Ticks *
        values : float[] *
        sample : uint32 *
        ?injectFracSecValue : bool *
        ?fracSecValue : uint16
(* Defaults:
        let _injectFracSecValue = defaultArg injectFracSecValue true
        let _fracSecValue = defaultArg fracSecValue 0
*)
-> unit

GSF.COMTRADE.Writer.WriteNextRecordAscii = function(output, schema, timestamp, values, sample, injectFracSecValue, fracSecValue);
public:
static void WriteNextRecordAscii(
    StreamWriter^ output,
    Schema^ schema,
    Ticks timestamp,
    array<double>^ values,
    unsigned int sample,
    bool injectFracSecValue = true,
    unsigned short fracSecValue = 0
)

Parameters

output
Type: System.IOStreamWriter
Destination stream.
schema
Type: GSF.COMTRADESchema
Source schema.
timestamp
Type: GSFTicks
Record timestamp (implicitly castable as DateTime).
values
Type: SystemDouble
Values to write - 16-bit digitals should exist as a word in an individual double value, method will write out bits.
sample
Type: SystemUInt32
User incremented sample index.
injectFracSecValue (Optional)
Type: SystemBoolean
Determines if FRACSEC value should be automatically injected into stream as first digital - defaults to true.
fracSecValue (Optional)
Type: SystemUInt16
FRACSEC value to inject into output stream - defaults to 0x0000.
Remarks
This function is primarily intended to write COMTRADE ASCII data records based on synchrophasor data (see Annex H: Schema for Phasor Data 2150 Using the COMTRADE File Standard in IEEE C37.111-2010), it may be necessary to manually write records for other COMTRADE needs (e.g., non 16-bit digitals).
See Also

Reference

Writer Class
GSF.COMTRADE Namespace


Writer.WriteNextRecordBinary Method

Grid Solutions Framework WriterWriteNextRecordBinary Method
Writes next COMTRADE record in binary format.

Namespace: GSF.COMTRADE
Assembly: GSF.COMTRADE (in GSF.COMTRADE.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WriteNextRecordBinary(
    Stream output,
    Schema schema,
    Ticks timestamp,
    double[] values,
    uint sample,
    bool injectFracSecValue = true,
    ushort fracSecValue = 0
)
Public Shared Sub WriteNextRecordBinary (
    output As Stream,
    schema As Schema,
    timestamp As Ticks,
    values As Double(),
    sample As UInteger,
    Optional injectFracSecValue As Boolean = true,
    Optional fracSecValue As UShort = 0
)
static member WriteNextRecordBinary :
        output : Stream *
        schema : Schema *
        timestamp : Ticks *
        values : float[] *
        sample : uint32 *
        ?injectFracSecValue : bool *
        ?fracSecValue : uint16
(* Defaults:
        let _injectFracSecValue = defaultArg injectFracSecValue true
        let _fracSecValue = defaultArg fracSecValue 0
*)
-> unit

GSF.COMTRADE.Writer.WriteNextRecordBinary = function(output, schema, timestamp, values, sample, injectFracSecValue, fracSecValue);
public:
static void WriteNextRecordBinary(
    Stream^ output,
    Schema^ schema,
    Ticks timestamp,
    array<double>^ values,
    unsigned int sample,
    bool injectFracSecValue = true,
    unsigned short fracSecValue = 0
)

Parameters

output
Type: System.IOStream
Destination stream.
schema
Type: GSF.COMTRADESchema
Source schema.
timestamp
Type: GSFTicks
Record timestamp (implicitly castable as DateTime).
values
Type: SystemDouble
Values to write - 16-bit digitals should exist as a word in an individual double value.
sample
Type: SystemUInt32
User incremented sample index.
injectFracSecValue (Optional)
Type: SystemBoolean
Determines if FRACSEC value should be automatically injected into stream as first digital - defaults to true.
fracSecValue (Optional)
Type: SystemUInt16
FRACSEC value to inject into output stream - defaults to 0x0000.
Remarks
This function is primarily intended to write COMTRADE binary data records based on synchrophasor data (see Annex H: Schema for Phasor Data 2150 Using the COMTRADE File Standard in IEEE C37.111-2010), it may be necessary to manually write records for other COMTRADE needs (e.g., non 16-bit digitals).
See Also

Reference

Writer Class
GSF.COMTRADE Namespace


GSF.Configuration Namespace

Grid Solutions Framework GSF.Configuration Namespace
Contains classes, base classes and attributes related to simplifying access to configuration files including creating a categorized settings section.
Classes
 | Class | Description
Public class | AppSettingsBase | Represents the base class for application settings that are synchronized with the "appSettings" section in a configuration file.
Public class | CategorizedSettingsBase | Represents the base class for application settings that are synchronized with a categorized section in a configuration file.
Public class | CategorizedSettingsElement | Represents a settings entry in the config file.
Public class | CategorizedSettingsElementCollection | Represents a collection of CategorizedSettingsElement objects.
Public class | CategorizedSettingsSection | Represents a section in the config file with one or more CategorizedSettingsElementCollection representing categories, each containing one or more CategorizedSettingsElement objects representing settings under a specific category.
 | ConfigurationFile | Represents a configuration file of a Windows or Web application.
Public class | ConnectionStringParser | Parses connection strings based on a settings object whose properties are annotated with the SerializeSettingAttribute.
Protected class | ConnectionStringParserConnectionStringProperty | Stores reflected information from a PropertyInfo object used to parse connection strings.
Public class | ConnectionStringParserTParameterAttribute | Parses connection strings based on a settings object whose properties are annotated with TParameterAttribute.
Public class | ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute | Parses connection strings based on a settings object whose properties are annotated with TParameterAttribute and TNestedSettingsAttribute.
Public class | EncryptSettingAttribute | Represents an attribute that determines if a property or field in a class derived from CategorizedSettingsBase or AppSettingsBase should be encrypted when it is serialized to the configuration file.
Public class | IniSettingsBase | Represents the base class for application settings that are synchronized to an INI file.
Public class | RegistrySettingsBase | Represents the base class for application settings that are synchronized to the registry.
Public class | SerializeSettingAttribute | Represents an attribute that determines if a property or field in a class derived from CategorizedSettingsBase or AppSettingsBase should be serialized to the configuration file.
Public class | SettingNameAttribute | Represents an attribute that defines the setting name of a property or field in a class derived from CategorizedSettingsBase or AppSettingsBase when serializing the value to the configuration file.
Public class | SettingsBase | Represents the base class for application settings that are synchronized with its configuration file.
Interfaces
 | Interface | Description
Public interface | IPersistSettings | Defines as interface that specifies that this object can persists settings to a config file.
Enumerations
 | Enumeration | Description
Public enumeration | SettingScope | Specifies the scope of a setting represented by CategorizedSettingsElement.


AppSettingsBase Class

Grid Solutions Framework AppSettingsBase Class
Represents the base class for application settings that are synchronized with the "appSettings" section in a configuration file.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationSettingsBase
GSF.ConfigurationAppSettingsBase

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class AppSettingsBase : SettingsBase
Public MustInherit Class AppSettingsBase
    Inherits SettingsBase
[<AbstractClassAttribute>]
type AppSettingsBase =
    class
        inherit SettingsBase
    end
GSF.Configuration.AppSettingsBase = function();

Type.createClass(
    'GSF.Configuration.AppSettingsBase',
    GSF.Configuration.SettingsBase);
public ref class AppSettingsBase abstract : public SettingsBase

The AppSettingsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AppSettingsBase | Creates a new instance of the AppSettingsBase class for the application's configuration file.
Protected method | AppSettingsBase(ConfigurationFile, Boolean, Boolean) | Creates a new instance of the AppSettingsBase class for the application's configuration file.
Top
Methods
 | Name | Description
Protected method | CreateSetting | Create setting in configuration file if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persist any pending changes to configuration file. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from configuration file. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to configuration file. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ConfigFile | Gets or sets reference to working configuration file.
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Top
Remarks

In order to make custom types serializable for the configuration file, implement a TypeConverter for the type.
See MSDN for details.

Examples
Here is an example class derived from AppSettingsBase that automatically serializes its fields and properties to the configuration file.
Copy
public enum MyEnum
 {
     One,
     Two,
     Three
 }

 public class MySettings : AppSettingsBase
 {
     // Private property fields (private fields will not be serialized)
     private double m_doubleVal;

     // Public settings fields
     public bool BoolVal = true;
     public int IntVal = 1;
     public float FloatVal = 3.14F;
     public string StrVal = "This is a test...";
     public MyEnum EnumVal = MyEnum.Three;

     [SettingName("UserOptions"), EncryptSetting()]
     public string Password = "default";

     // Mark this field to not be serialized to INI file...
     [SerializeSetting(false)]
     public decimal DecimalVal;

     [Category("OtherSettings"), DefaultValue(1.159D)]
     public double DoubleVal
     {
         get
         {
             return m_doubleVal;
         }
         set
         {
             m_doubleVal = value;
         }
     }

     [SerializeSetting(false)]
     public bool DontSerializeMe { get; set; }
 }
See Also

Reference

GSF.Configuration Namespace


AppSettingsBase Constructor

Grid Solutions Framework AppSettingsBase Constructor
Overload List
 | Name | Description
Protected method | AppSettingsBase | Creates a new instance of the AppSettingsBase class for the application's configuration file.
Protected method | AppSettingsBase(ConfigurationFile, Boolean, Boolean) | Creates a new instance of the AppSettingsBase class for the application's configuration file.
Top
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


AppSettingsBase Constructor

Grid Solutions Framework AppSettingsBase Constructor
Creates a new instance of the AppSettingsBase class for the application's configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AppSettingsBase()
Protected Sub New
new : unit -> AppSettingsBase
GSF.Configuration.AppSettingsBase = function();
protected:
AppSettingsBase()
See Also

Reference

AppSettingsBase Class
AppSettingsBase Overload
GSF.Configuration Namespace


AppSettingsBase Constructor (ConfigurationFile, Boolean, Boolean)

Grid Solutions Framework AppSettingsBase Constructor (ConfigurationFile, Boolean, Boolean)
Creates a new instance of the AppSettingsBase class for the application's configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AppSettingsBase(
    ConfigurationFile configFile,
    bool requireSerializeSettingAttribute,
    bool initialize
)
Protected Sub New (
    configFile As ConfigurationFile,
    requireSerializeSettingAttribute As Boolean,
    initialize As Boolean
)
new :
        configFile : ConfigurationFile *
        requireSerializeSettingAttribute : bool *
        initialize : bool -> AppSettingsBase
GSF.Configuration.AppSettingsBase = function(configFile, requireSerializeSettingAttribute, initialize);
protected:
AppSettingsBase(
    ConfigurationFile^ configFile,
    bool requireSerializeSettingAttribute,
    bool initialize
)

Parameters

configFile
Type: GSF.ConfigurationConfigurationFile
Configuration file used for accessing settings.
requireSerializeSettingAttribute
Type: SystemBoolean
Assigns flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file.
initialize
Type: SystemBoolean
Determines if Initialize method should be called from constructor.
Remarks
Note that some .NET languages (e.g., Visual Basic) will not initialize member elements before call to constuctor, in this case initialize should be set to false, then the Initialize method should be called manually after all properties have been initialized. Alternately, consider using the DefaultValueAttribute on the fields or properties and this will be used to initialize the values.
See Also

Reference

AppSettingsBase Class
AppSettingsBase Overload
GSF.Configuration Namespace


AppSettingsBase Methods

Grid Solutions Framework AppSettingsBase Methods

The AppSettingsBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateSetting | Create setting in configuration file if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persist any pending changes to configuration file. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from configuration file. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to configuration file. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


AppSettingsBase.CreateSetting Method

Grid Solutions Framework AppSettingsBaseCreateSetting Method
Create setting in configuration file if it doesn't already exist. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void CreateSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub CreateSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
function CreateSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void CreateSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


AppSettingsBase.PersistSettings Method

Grid Solutions Framework AppSettingsBasePersistSettings Method
Persist any pending changes to configuration file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void PersistSettings()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub PersistSettings
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract PersistSettings : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override PersistSettings : unit -> unit
function PersistSettings();
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void PersistSettings() override
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


AppSettingsBase.RetrieveSetting Method

Grid Solutions Framework AppSettingsBaseRetrieveSetting Method
Retrieves setting from configuration file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override string RetrieveSetting(
    string name,
    string setting
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Function RetrieveSetting (
    name As String,
    setting As String
) As String
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract RetrieveSetting :
        name : string *
        setting : string -> string
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override RetrieveSetting :
        name : string *
        setting : string -> string
function RetrieveSetting(name, setting);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual String^ RetrieveSetting(
    String^ name,
    String^ setting
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.

Return Value

Type: String
Setting value.
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


AppSettingsBase.StoreSetting Method

Grid Solutions Framework AppSettingsBaseStoreSetting Method
Stores setting to configuration file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void StoreSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub StoreSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
function StoreSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void StoreSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


AppSettingsBase Properties

Grid Solutions Framework AppSettingsBase Properties

The AppSettingsBase type exposes the following members.

Properties
 | Name | Description
Protected property | ConfigFile | Gets or sets reference to working configuration file.
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Top
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


AppSettingsBase.ConfigFile Property

Grid Solutions Framework AppSettingsBaseConfigFile Property
Gets or sets reference to working configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFile ConfigFile { get; set; }
Protected Property ConfigFile As ConfigurationFile
    Get
    Set
member ConfigFile : ConfigurationFile with get, set

function get_ConfigFile();
function set_ConfigFile(value);
protected:
property ConfigurationFile^ ConfigFile {
    ConfigurationFile^ get ();
    void set (ConfigurationFile^ value);
}

Property Value

Type: ConfigurationFile
Exceptions
Exception | Condition
NullReferenceException | value cannot be null.
See Also

Reference

AppSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase Class

Grid Solutions Framework CategorizedSettingsBase Class
Represents the base class for application settings that are synchronized with a categorized section in a configuration file.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationSettingsBase
GSF.ConfigurationCategorizedSettingsBase

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class CategorizedSettingsBase : SettingsBase
Public MustInherit Class CategorizedSettingsBase
    Inherits SettingsBase
[<AbstractClassAttribute>]
type CategorizedSettingsBase =
    class
        inherit SettingsBase
    end
GSF.Configuration.CategorizedSettingsBase = function();

Type.createClass(
    'GSF.Configuration.CategorizedSettingsBase',
    GSF.Configuration.SettingsBase);
public ref class CategorizedSettingsBase abstract : public SettingsBase

The CategorizedSettingsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CategorizedSettingsBase(String) | Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.
Protected method | CategorizedSettingsBase(String, Boolean, Boolean) | Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.
Protected method | CategorizedSettingsBase(ConfigurationFile, String, Boolean, Boolean, Boolean) | Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.
Top
Methods
 | Name | Description
Protected method | CreateSetting | Create setting in configuration file if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetFieldCategoryName | Gets the category name to use for the specified field or property.
Public method | GetFieldDescription | Gets the description specified by DescriptionAttribute, if any, applied to the specified field or property.
Public method | GetFieldSettingScope | Gets the SettingScope specified by UserScopedSettingAttribute, if any, applied to the specified field or property.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persist any pending changes to configuration file. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from configuration file. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to configuration file. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CategoryName | Gets or sets default category name of section used to access settings in configuration file.
Protected property | ConfigFile | Gets or sets reference to working configuration file.
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Public property | UseCategoryAttributes | Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the category name.
Top
Remarks

In order to make custom types serializable for the configuration file, implement a TypeConverter for the type.
See MSDN for details.

Examples
Here is an example class derived from CategorizedSettingsBase that automatically serializes its fields and properties to the configuration file.
Copy
public enum MyEnum
 {
     One,
     Two,
     Three
 }

 public class MySettings : CategorizedSettingsBase
 {
     // Private property fields (private fields will not be serialized)
     private double m_doubleVal;

     // Public settings fields
     public bool BoolVal = true;
     public int IntVal = 1;
     public float FloatVal = 3.14F;
     public string StrVal = "This is a test...";
     public MyEnum EnumVal = MyEnum.Three;

     [SettingName("UserOptions"), EncryptSetting()]
     public string Password = "default";

     // Mark this field to not be serialized to configuration file...
     [SerializeSetting(false)]
     public decimal DecimalVal;

     public MySettings()
         : base("GeneralSettings") {}

     [Category("OtherSettings"), Description("My double value setting description."), DefaultValue(1.159D)]
     public double DoubleVal
     {
         get
         {
             return m_doubleVal;
         }
         set
         {
             m_doubleVal = value;
         }
     }

     [SerializeSetting(false)]
     public bool DontSerializeMe { get; set; }
 }
See Also

Reference

GSF.Configuration Namespace


CategorizedSettingsBase Constructor

Grid Solutions Framework CategorizedSettingsBase Constructor
Overload List
 | Name | Description
Protected method | CategorizedSettingsBase(String) | Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.
Protected method | CategorizedSettingsBase(String, Boolean, Boolean) | Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.
Protected method | CategorizedSettingsBase(ConfigurationFile, String, Boolean, Boolean, Boolean) | Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.
Top
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase Constructor (String)

Grid Solutions Framework CategorizedSettingsBase Constructor (String)
Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CategorizedSettingsBase(
    string categoryName
)
Protected Sub New (
    categoryName As String
)
new :
        categoryName : string -> CategorizedSettingsBase
GSF.Configuration.CategorizedSettingsBase = function(categoryName);
protected:
CategorizedSettingsBase(
    String^ categoryName
)

Parameters

categoryName
Type: SystemString
Name of default category to use to get and set settings from configuration file.
See Also

Reference

CategorizedSettingsBase Class
CategorizedSettingsBase Overload
GSF.Configuration Namespace


CategorizedSettingsBase Constructor (String, Boolean, Boolean)

Grid Solutions Framework CategorizedSettingsBase Constructor (String, Boolean, Boolean)
Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CategorizedSettingsBase(
    string categoryName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute
)
Protected Sub New (
    categoryName As String,
    useCategoryAttributes As Boolean,
    requireSerializeSettingAttribute As Boolean
)
new :
        categoryName : string *
        useCategoryAttributes : bool *
        requireSerializeSettingAttribute : bool -> CategorizedSettingsBase
GSF.Configuration.CategorizedSettingsBase = function(categoryName, useCategoryAttributes, requireSerializeSettingAttribute);
protected:
CategorizedSettingsBase(
    String^ categoryName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute
)

Parameters

categoryName
Type: SystemString
Name of default category to use to get and set settings from configuration file.
useCategoryAttributes
Type: SystemBoolean
Determines if category attributes will be used for category names.
requireSerializeSettingAttribute
Type: SystemBoolean
Assigns flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file.
Remarks
If useCategoryAttributes is false, all settings will be placed in section labeled by the categoryName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the configuration file in a section labeled the same as the Category value and if the attribute doesn't exist the member value will serialized into the section labeled by the categoryName value.
See Also

Reference

CategorizedSettingsBase Class
CategorizedSettingsBase Overload
GSF.Configuration Namespace


CategorizedSettingsBase Constructor (ConfigurationFile, String, Boolean, Boolean, Boolean)

Grid Solutions Framework CategorizedSettingsBase Constructor (ConfigurationFile, String, Boolean, Boolean, Boolean)
Creates a new instance of the CategorizedSettingsBase class for the application's configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CategorizedSettingsBase(
    ConfigurationFile configFile,
    string categoryName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute,
    bool initialize
)
Protected Sub New (
    configFile As ConfigurationFile,
    categoryName As String,
    useCategoryAttributes As Boolean,
    requireSerializeSettingAttribute As Boolean,
    initialize As Boolean
)
new :
        configFile : ConfigurationFile *
        categoryName : string *
        useCategoryAttributes : bool *
        requireSerializeSettingAttribute : bool *
        initialize : bool -> CategorizedSettingsBase
GSF.Configuration.CategorizedSettingsBase = function(configFile, categoryName, useCategoryAttributes, requireSerializeSettingAttribute, initialize);
protected:
CategorizedSettingsBase(
    ConfigurationFile^ configFile,
    String^ categoryName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute,
    bool initialize
)

Parameters

configFile
Type: GSF.ConfigurationConfigurationFile
Configuration file used for accessing settings.
categoryName
Type: SystemString
Name of default category to use to get and set settings from configuration file.
useCategoryAttributes
Type: SystemBoolean
Determines if category attributes will be used for category names.
requireSerializeSettingAttribute
Type: SystemBoolean
Assigns flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file.
initialize
Type: SystemBoolean
Determines if Initialize method should be called from constructor.
Remarks

If useCategoryAttributes is false, all settings will be placed in section labeled by the categoryName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the configuration file in a section labeled the same as the Category value and if the attribute doesn't exist the member value will serialized into the section labeled by the categoryName value.

Note that some .NET languages (e.g., Visual Basic) will not initialize member elements before call to constuctor, in this case initialize should be set to false, then the Initialize method should be called manually after all properties have been initialized. Alternately, consider using the DefaultValueAttribute on the fields or properties and this will be used to initialize the values.

See Also

Reference

CategorizedSettingsBase Class
CategorizedSettingsBase Overload
GSF.Configuration Namespace


CategorizedSettingsBase Methods

Grid Solutions Framework CategorizedSettingsBase Methods

The CategorizedSettingsBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateSetting | Create setting in configuration file if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetFieldCategoryName | Gets the category name to use for the specified field or property.
Public method | GetFieldDescription | Gets the description specified by DescriptionAttribute, if any, applied to the specified field or property.
Public method | GetFieldSettingScope | Gets the SettingScope specified by UserScopedSettingAttribute, if any, applied to the specified field or property.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persist any pending changes to configuration file. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from configuration file. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to configuration file. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.CreateSetting Method

Grid Solutions Framework CategorizedSettingsBaseCreateSetting Method
Create setting in configuration file if it doesn't already exist. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void CreateSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub CreateSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
function CreateSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void CreateSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.GetFieldCategoryName Method

Grid Solutions Framework CategorizedSettingsBaseGetFieldCategoryName Method
Gets the category name to use for the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetFieldCategoryName(
    string name
)
Public Function GetFieldCategoryName (
    name As String
) As String
member GetFieldCategoryName :
        name : string -> string

function GetFieldCategoryName(name);
public:
String^ GetFieldCategoryName(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: String
Category applied to specified field or property; or CategoryName if attribute does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
Remarks
Category will only be returned if UseCategoryAttributes is true; otherwise CategoryName value will be returned.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.GetFieldDescription Method

Grid Solutions Framework CategorizedSettingsBaseGetFieldDescription Method
Gets the description specified by DescriptionAttribute, if any, applied to the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetFieldDescription(
    string name
)
Public Function GetFieldDescription (
    name As String
) As String
member GetFieldDescription :
        name : string -> string

function GetFieldDescription(name);
public:
String^ GetFieldDescription(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: String
Description applied to specified field or property; or null if one does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.GetFieldSettingScope Method

Grid Solutions Framework CategorizedSettingsBaseGetFieldSettingScope Method
Gets the SettingScope specified by UserScopedSettingAttribute, if any, applied to the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SettingScope GetFieldSettingScope(
    string name
)
Public Function GetFieldSettingScope (
    name As String
) As SettingScope
member GetFieldSettingScope :
        name : string -> SettingScope

function GetFieldSettingScope(name);
public:
SettingScope GetFieldSettingScope(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: SettingScope
Description applied to specified field or property; or null if one does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.PersistSettings Method

Grid Solutions Framework CategorizedSettingsBasePersistSettings Method
Persist any pending changes to configuration file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void PersistSettings()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub PersistSettings
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract PersistSettings : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override PersistSettings : unit -> unit
function PersistSettings();
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void PersistSettings() override
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.RetrieveSetting Method

Grid Solutions Framework CategorizedSettingsBaseRetrieveSetting Method
Retrieves setting from configuration file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override string RetrieveSetting(
    string name,
    string setting
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Function RetrieveSetting (
    name As String,
    setting As String
) As String
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract RetrieveSetting :
        name : string *
        setting : string -> string
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override RetrieveSetting :
        name : string *
        setting : string -> string
function RetrieveSetting(name, setting);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual String^ RetrieveSetting(
    String^ name,
    String^ setting
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.

Return Value

Type: String
Setting value.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.StoreSetting Method

Grid Solutions Framework CategorizedSettingsBaseStoreSetting Method
Stores setting to configuration file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void StoreSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub StoreSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
function StoreSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void StoreSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase Properties

Grid Solutions Framework CategorizedSettingsBase Properties

The CategorizedSettingsBase type exposes the following members.

Properties
 | Name | Description
Public property | CategoryName | Gets or sets default category name of section used to access settings in configuration file.
Protected property | ConfigFile | Gets or sets reference to working configuration file.
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Public property | UseCategoryAttributes | Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the category name.
Top
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.CategoryName Property

Grid Solutions Framework CategorizedSettingsBaseCategoryName Property
Gets or sets default category name of section used to access settings in configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
public string CategoryName { get; set; }
<SerializeSettingAttribute(false)>
<BrowsableAttribute(false)>
Public Property CategoryName As String
    Get
    Set
[<SerializeSettingAttribute(false)>]
[<BrowsableAttribute(false)>]
member CategoryName : string with get, set

function get_CategoryName();
function set_CategoryName(value);
public:
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
property String^ CategoryName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.ConfigFile Property

Grid Solutions Framework CategorizedSettingsBaseConfigFile Property
Gets or sets reference to working configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFile ConfigFile { get; set; }
Protected Property ConfigFile As ConfigurationFile
    Get
    Set
member ConfigFile : ConfigurationFile with get, set

function get_ConfigFile();
function set_ConfigFile(value);
protected:
property ConfigurationFile^ ConfigFile {
    ConfigurationFile^ get ();
    void set (ConfigurationFile^ value);
}

Property Value

Type: ConfigurationFile
Exceptions
Exception | Condition
NullReferenceException | value cannot be null.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsBase.UseCategoryAttributes Property

Grid Solutions Framework CategorizedSettingsBaseUseCategoryAttributes Property
Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the category name.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
public bool UseCategoryAttributes { get; set; }
<SerializeSettingAttribute(false)>
<BrowsableAttribute(false)>
Public Property UseCategoryAttributes As Boolean
    Get
    Set
[<SerializeSettingAttribute(false)>]
[<BrowsableAttribute(false)>]
member UseCategoryAttributes : bool with get, set

function get_UseCategoryAttributes();
function set_UseCategoryAttributes(value);
public:
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
property bool UseCategoryAttributes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
If UseCategoryAttributes is false, all settings will be placed in section labeled by the CategoryName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the configuration file in a section labeled the same as the Category value and if the attribute doesn't exist the member value will serialized into the section labeled by the CategoryName value.
See Also

Reference

CategorizedSettingsBase Class
GSF.Configuration Namespace


CategorizedSettingsElement Class

Grid Solutions Framework CategorizedSettingsElement Class
Represents a settings entry in the config file.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
GSF.ConfigurationCategorizedSettingsElement

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CategorizedSettingsElement : ConfigurationElement
Public Class CategorizedSettingsElement
    Inherits ConfigurationElement
type CategorizedSettingsElement =
    class
        inherit ConfigurationElement
    end
GSF.Configuration.CategorizedSettingsElement = function();

Type.createClass(
    'GSF.Configuration.CategorizedSettingsElement',
    ConfigurationElement);
public ref class CategorizedSettingsElement : public ConfigurationElement

The CategorizedSettingsElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting the Value.
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Public method | Update(Object) | Updates setting information.
Public method | Update(Object, String) | Updates setting information.
Public method | Update(Object, String, Boolean) | Updates setting information.
Public method | Update(Object, String, Boolean, SettingScope) | Updates setting information.
Public method | ValueAsT | Gets the setting value as the specified type.
Public method | ValueAsT(T) | Gets the setting value as the specified type.
Public method | ValueAsBoolean | Gets the setting value as a boolean.
Public method | ValueAsBoolean(Boolean) | Gets the setting value as a boolean.
Public method | ValueAsByte | Gets the setting value as a byte.
Public method | ValueAsByte(Byte) | Gets the setting value as a byte.
Public method | ValueAsChar | Gets the setting value as a char.
Public method | ValueAsChar(Char) | Gets the setting value as a char.
Public method | ValueAsDateTime | Gets the setting value as DateTime.
Public method | ValueAsDateTime(DateTime) | Gets the setting value as DateTime.
Public method | ValueAsDecimal | Gets the setting value as a decimal.
Public method | ValueAsDecimal(Decimal) | Gets the setting value as a decimal.
Public method | ValueAsDouble | Gets the setting value as a double.
Public method | ValueAsDouble(Double) | Gets the setting value as a double.
Public method | ValueAsInt16 | Gets the setting value as a short.
Public method | ValueAsInt16(Int16) | Gets the setting value as a short.
Public method | ValueAsInt32 | Gets the setting value as an int.
Public method | ValueAsInt32(Int32) | Gets the setting value as an int.
Public method | ValueAsInt64 | Gets the setting value as a long.
Public method | ValueAsInt64(Int64) | Gets the setting value as a long.
Public method | ValueAsSByte | Gets the setting value as a signed byte.
Public method | ValueAsSByte(SByte) | Gets the setting value as a signed byte.
Public method | ValueAsSingle | Gets the setting value as a float.
Public method | ValueAsSingle(Single) | Gets the setting value as a float.
Public method | ValueAsString | Gets the setting value as a string.
Public method | ValueAsString(String) | Gets the setting value as a string.
Public method | ValueAsUInt16 | Gets the setting value as an unsigned short.
Public method | ValueAsUInt16(UInt16) | Gets the setting value as an unsigned short.
Public method | ValueAsUInt32 | Gets the setting value as an unsigned int.
Public method | ValueAsUInt32(UInt32) | Gets the setting value as an unsigned int.
Public method | ValueAsUInt64 | Gets the setting value as an unsigned long.
Public method | ValueAsUInt64(UInt64) | Gets the setting value as an unsigned long.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultDescription | Specifies the default value for the Description property.
DefaultEncrypted | Specifies the default value for the Encrypted property.
DefaultScope | Specifies the default value for the Scope property.
DefaultValue | Specifies the default value for the Value property.
Top
Properties
 | Name | Description
Public property | Category | Gets or sets the CategorizedSettingsElementCollection to which this CategorizedSettingsElement belongs.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | Description | Gets or sets the description of the setting.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | Encrypted | Gets or sets a boolean value that indicates whether the setting value is to be encrypted.
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Name | Gets or sets the identifier of the setting.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Scope | Gets or sets the SettingScope.
Public property | SerializedValue | Gets value that will actually be serialized to the configuration file.
Public property | Value | Gets or sets the value of the setting.
Top
See Also

Reference

GSF.Configuration Namespace


CategorizedSettingsElement Fields

Grid Solutions Framework CategorizedSettingsElement Fields

The CategorizedSettingsElement type exposes the following members.

Fields
Name | Description
DefaultDescription | Specifies the default value for the Description property.
DefaultEncrypted | Specifies the default value for the Encrypted property.
DefaultScope | Specifies the default value for the Scope property.
DefaultValue | Specifies the default value for the Value property.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.DefaultDescription Field

Grid Solutions Framework CategorizedSettingsElementDefaultDescription Field
Specifies the default value for the Description property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultDescription
Public Const DefaultDescription As String
static val mutable DefaultDescription: string
var GSF.Configuration.CategorizedSettingsElement.DefaultDescription
public:
literal String^ DefaultDescription

Field Value

Type: String
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.DefaultEncrypted Field

Grid Solutions Framework CategorizedSettingsElementDefaultEncrypted Field
Specifies the default value for the Encrypted property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultEncrypted
Public Const DefaultEncrypted As Boolean
static val mutable DefaultEncrypted: bool
var GSF.Configuration.CategorizedSettingsElement.DefaultEncrypted
public:
literal bool DefaultEncrypted

Field Value

Type: Boolean
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.DefaultScope Field

Grid Solutions Framework CategorizedSettingsElementDefaultScope Field
Specifies the default value for the Scope property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const SettingScope DefaultScope
Public Const DefaultScope As SettingScope
static val mutable DefaultScope: SettingScope
var GSF.Configuration.CategorizedSettingsElement.DefaultScope
public:
literal SettingScope DefaultScope

Field Value

Type: SettingScope
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.DefaultValue Field

Grid Solutions Framework CategorizedSettingsElementDefaultValue Field
Specifies the default value for the Value property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultValue
Public Const DefaultValue As String
static val mutable DefaultValue: string
var GSF.Configuration.CategorizedSettingsElement.DefaultValue
public:
literal String^ DefaultValue

Field Value

Type: String
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement Methods

Grid Solutions Framework CategorizedSettingsElement Methods

The CategorizedSettingsElement type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded, when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting the Value.
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Public method | Update(Object) | Updates setting information.
Public method | Update(Object, String) | Updates setting information.
Public method | Update(Object, String, Boolean) | Updates setting information.
Public method | Update(Object, String, Boolean, SettingScope) | Updates setting information.
Public method | ValueAsT | Gets the setting value as the specified type.
Public method | ValueAsT(T) | Gets the setting value as the specified type.
Public method | ValueAsBoolean | Gets the setting value as a boolean.
Public method | ValueAsBoolean(Boolean) | Gets the setting value as a boolean.
Public method | ValueAsByte | Gets the setting value as a byte.
Public method | ValueAsByte(Byte) | Gets the setting value as a byte.
Public method | ValueAsChar | Gets the setting value as a char.
Public method | ValueAsChar(Char) | Gets the setting value as a char.
Public method | ValueAsDateTime | Gets the setting value as DateTime.
Public method | ValueAsDateTime(DateTime) | Gets the setting value as DateTime.
Public method | ValueAsDecimal | Gets the setting value as a decimal.
Public method | ValueAsDecimal(Decimal) | Gets the setting value as a decimal.
Public method | ValueAsDouble | Gets the setting value as a double.
Public method | ValueAsDouble(Double) | Gets the setting value as a double.
Public method | ValueAsInt16 | Gets the setting value as a short.
Public method | ValueAsInt16(Int16) | Gets the setting value as a short.
Public method | ValueAsInt32 | Gets the setting value as an int.
Public method | ValueAsInt32(Int32) | Gets the setting value as an int.
Public method | ValueAsInt64 | Gets the setting value as a long.
Public method | ValueAsInt64(Int64) | Gets the setting value as a long.
Public method | ValueAsSByte | Gets the setting value as a signed byte.
Public method | ValueAsSByte(SByte) | Gets the setting value as a signed byte.
Public method | ValueAsSingle | Gets the setting value as a float.
Public method | ValueAsSingle(Single) | Gets the setting value as a float.
Public method | ValueAsString | Gets the setting value as a string.
Public method | ValueAsString(String) | Gets the setting value as a string.
Public method | ValueAsUInt16 | Gets the setting value as an unsigned short.
Public method | ValueAsUInt16(UInt16) | Gets the setting value as an unsigned short.
Public method | ValueAsUInt32 | Gets the setting value as an unsigned int.
Public method | ValueAsUInt32(UInt32) | Gets the setting value as an unsigned int.
Public method | ValueAsUInt64 | Gets the setting value as an unsigned long.
Public method | ValueAsUInt64(UInt64) | Gets the setting value as an unsigned long.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.SetCryptoKey Method

Grid Solutions Framework CategorizedSettingsElementSetCryptoKey Method
Sets the key to be used for encrypting and decrypting the Value.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCryptoKey(
    string cryptoKey
)
Public Sub SetCryptoKey (
    cryptoKey As String
)
member SetCryptoKey :
        cryptoKey : string -> unit

function SetCryptoKey(cryptoKey);
public:
void SetCryptoKey(
    String^ cryptoKey
)

Parameters

cryptoKey
Type: SystemString
New crypto key.
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Update Method

Grid Solutions Framework CategorizedSettingsElementUpdate Method
Overload List
 | Name | Description
Public method | Update(Object) | Updates setting information.
Public method | Update(Object, String) | Updates setting information.
Public method | Update(Object, String, Boolean) | Updates setting information.
Public method | Update(Object, String, Boolean, SettingScope) | Updates setting information.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Update Method (Object)

Grid Solutions Framework CategorizedSettingsElementUpdate Method (Object)
Updates setting information.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    Object value
)
Public Sub Update (
    value As Object
)
member Update :
        value : Object -> unit

function Update(value);
public:
void Update(
    Object^ value
)

Parameters

value
Type: SystemObject
New setting value.
See Also

Reference

CategorizedSettingsElement Class
Update Overload
GSF.Configuration Namespace


CategorizedSettingsElement.Update Method (Object, String)

Grid Solutions Framework CategorizedSettingsElementUpdate Method (Object, String)
Updates setting information.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    Object value,
    string description
)
Public Sub Update (
    value As Object,
    description As String
)
member Update :
        value : Object *
        description : string -> unit

function Update(value, description);
public:
void Update(
    Object^ value,
    String^ description
)

Parameters

value
Type: SystemObject
New setting value.
description
Type: SystemString
New setting description.
See Also

Reference

CategorizedSettingsElement Class
Update Overload
GSF.Configuration Namespace


CategorizedSettingsElement.Update Method (Object, String, Boolean)

Grid Solutions Framework CategorizedSettingsElementUpdate Method (Object, String, Boolean)
Updates setting information.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    Object value,
    string description,
    bool encrypted
)
Public Sub Update (
    value As Object,
    description As String,
    encrypted As Boolean
)
member Update :
        value : Object *
        description : string *
        encrypted : bool -> unit

function Update(value, description, encrypted);
public:
void Update(
    Object^ value,
    String^ description,
    bool encrypted
)

Parameters

value
Type: SystemObject
New setting value.
description
Type: SystemString
New setting description.
encrypted
Type: SystemBoolean
A boolean value that indicated whether the new setting value is to be encrypted.
See Also

Reference

CategorizedSettingsElement Class
Update Overload
GSF.Configuration Namespace


CategorizedSettingsElement.Update Method (Object, String, Boolean, SettingScope)

Grid Solutions Framework CategorizedSettingsElementUpdate Method (Object, String, Boolean, SettingScope)
Updates setting information.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    Object value,
    string description,
    bool encrypted,
    SettingScope scope
)
Public Sub Update (
    value As Object,
    description As String,
    encrypted As Boolean,
    scope As SettingScope
)
member Update :
        value : Object *
        description : string *
        encrypted : bool *
        scope : SettingScope -> unit

function Update(value, description, encrypted, scope);
public:
void Update(
    Object^ value,
    String^ description,
    bool encrypted,
    SettingScope scope
)

Parameters

value
Type: SystemObject
New setting value.
description
Type: SystemString
New setting description.
encrypted
Type: SystemBoolean
A boolean value that indicated whether the new setting value is to be encrypted.
scope
Type: GSF.ConfigurationSettingScope
One of the SettingScope values.
See Also

Reference

CategorizedSettingsElement Class
Update Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAs Method

Grid Solutions Framework CategorizedSettingsElementValueAs Method
Overload List
 | Name | Description
Public method | ValueAsT | Gets the setting value as the specified type.
Public method | ValueAsT(T) | Gets the setting value as the specified type.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAs(T) Method

Grid Solutions Framework CategorizedSettingsElementValueAsT Method
Gets the setting value as the specified type.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T ValueAs<T>()

Public Function ValueAs(Of T) As T
member ValueAs : unit -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T ValueAs()

Type Parameters

T
Type to which the setting value is to be converted.

Return Value

Type: T
The type-coerced value of the setting.
Remarks
If this function fails to properly coerce value to specified type, the default value is returned.
See Also

Reference

CategorizedSettingsElement Class
ValueAs Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAs(T) Method (T)

Grid Solutions Framework CategorizedSettingsElementValueAsT Method (T)
Gets the setting value as the specified type.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T ValueAs<T>(
    T defaultValue
)

Public Function ValueAs(Of T) (
    defaultValue As T
) As T
member ValueAs :
        defaultValue : 'T -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T ValueAs(
    T defaultValue
)

Parameters

defaultValue
Type: T
The default value to return if the setting value is empty.

Type Parameters

T
Type to which the setting value is to be converted.

Return Value

Type: T
The type-coerced value of the setting.
Remarks
If this function fails to properly coerce value to specified type, the default value is returned.
See Also

Reference

CategorizedSettingsElement Class
ValueAs Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsBoolean Method

Grid Solutions Framework CategorizedSettingsElementValueAsBoolean Method
Overload List
 | Name | Description
Public method | ValueAsBoolean | Gets the setting value as a boolean.
Public method | ValueAsBoolean(Boolean) | Gets the setting value as a boolean.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsBoolean Method

Grid Solutions Framework CategorizedSettingsElementValueAsBoolean Method
Gets the setting value as a boolean.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValueAsBoolean()
Public Function ValueAsBoolean As Boolean
member ValueAsBoolean : unit -> bool

function ValueAsBoolean();
public:
bool ValueAsBoolean()

Return Value

Type: Boolean
Value as boolean.
See Also

Reference

CategorizedSettingsElement Class
ValueAsBoolean Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsBoolean Method (Boolean)

Grid Solutions Framework CategorizedSettingsElementValueAsBoolean Method (Boolean)
Gets the setting value as a boolean.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValueAsBoolean(
    bool defaultValue
)
Public Function ValueAsBoolean (
    defaultValue As Boolean
) As Boolean
member ValueAsBoolean :
        defaultValue : bool -> bool

function ValueAsBoolean(defaultValue);
public:
bool ValueAsBoolean(
    bool defaultValue
)

Parameters

defaultValue
Type: SystemBoolean
The default value to return if the setting value is empty.

Return Value

Type: Boolean
Value as boolean.
See Also

Reference

CategorizedSettingsElement Class
ValueAsBoolean Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsByte Method

Grid Solutions Framework CategorizedSettingsElementValueAsByte Method
Overload List
 | Name | Description
Public method | ValueAsByte | Gets the setting value as a byte.
Public method | ValueAsByte(Byte) | Gets the setting value as a byte.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsByte Method

Grid Solutions Framework CategorizedSettingsElementValueAsByte Method
Gets the setting value as a byte.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte ValueAsByte()
Public Function ValueAsByte As Byte
member ValueAsByte : unit -> byte

function ValueAsByte();
public:
unsigned char ValueAsByte()

Return Value

Type: Byte
Value as byte.
See Also

Reference

CategorizedSettingsElement Class
ValueAsByte Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsByte Method (Byte)

Grid Solutions Framework CategorizedSettingsElementValueAsByte Method (Byte)
Gets the setting value as a byte.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte ValueAsByte(
    byte defaultValue
)
Public Function ValueAsByte (
    defaultValue As Byte
) As Byte
member ValueAsByte :
        defaultValue : byte -> byte

function ValueAsByte(defaultValue);
public:
unsigned char ValueAsByte(
    unsigned char defaultValue
)

Parameters

defaultValue
Type: SystemByte
The default value to return if the setting value is empty.

Return Value

Type: Byte
Value as byte.
See Also

Reference

CategorizedSettingsElement Class
ValueAsByte Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsChar Method

Grid Solutions Framework CategorizedSettingsElementValueAsChar Method
Overload List
 | Name | Description
Public method | ValueAsChar | Gets the setting value as a char.
Public method | ValueAsChar(Char) | Gets the setting value as a char.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsChar Method

Grid Solutions Framework CategorizedSettingsElementValueAsChar Method
Gets the setting value as a char.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char ValueAsChar()
Public Function ValueAsChar As Char
member ValueAsChar : unit -> char

function ValueAsChar();
public:
wchar_t ValueAsChar()

Return Value

Type: Char
Value as char.
See Also

Reference

CategorizedSettingsElement Class
ValueAsChar Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsChar Method (Char)

Grid Solutions Framework CategorizedSettingsElementValueAsChar Method (Char)
Gets the setting value as a char.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char ValueAsChar(
    char defaultValue
)
Public Function ValueAsChar (
    defaultValue As Char
) As Char
member ValueAsChar :
        defaultValue : char -> char

function ValueAsChar(defaultValue);
public:
wchar_t ValueAsChar(
    wchar_t defaultValue
)

Parameters

defaultValue
Type: SystemChar
The default value to return if the setting value is empty.

Return Value

Type: Char
Value as char.
See Also

Reference

CategorizedSettingsElement Class
ValueAsChar Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDateTime Method

Grid Solutions Framework CategorizedSettingsElementValueAsDateTime Method
Overload List
 | Name | Description
Public method | ValueAsDateTime | Gets the setting value as DateTime.
Public method | ValueAsDateTime(DateTime) | Gets the setting value as DateTime.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDateTime Method

Grid Solutions Framework CategorizedSettingsElementValueAsDateTime Method
Gets the setting value as DateTime.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ValueAsDateTime()
Public Function ValueAsDateTime As DateTime
member ValueAsDateTime : unit -> DateTime

function ValueAsDateTime();
public:
DateTime ValueAsDateTime()

Return Value

Type: DateTime
Value as DateTime.
See Also

Reference

CategorizedSettingsElement Class
ValueAsDateTime Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDateTime Method (DateTime)

Grid Solutions Framework CategorizedSettingsElementValueAsDateTime Method (DateTime)
Gets the setting value as DateTime.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ValueAsDateTime(
    DateTime defaultValue
)
Public Function ValueAsDateTime (
    defaultValue As DateTime
) As DateTime
member ValueAsDateTime :
        defaultValue : DateTime -> DateTime

function ValueAsDateTime(defaultValue);
public:
DateTime ValueAsDateTime(
    DateTime defaultValue
)

Parameters

defaultValue
Type: SystemDateTime
The default value to return if the setting value is empty.

Return Value

Type: DateTime
Value as DateTime.
See Also

Reference

CategorizedSettingsElement Class
ValueAsDateTime Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDecimal Method

Grid Solutions Framework CategorizedSettingsElementValueAsDecimal Method
Overload List
 | Name | Description
Public method | ValueAsDecimal | Gets the setting value as a decimal.
Public method | ValueAsDecimal(Decimal) | Gets the setting value as a decimal.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDecimal Method

Grid Solutions Framework CategorizedSettingsElementValueAsDecimal Method
Gets the setting value as a decimal.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public decimal ValueAsDecimal()
Public Function ValueAsDecimal As Decimal
member ValueAsDecimal : unit -> decimal

function ValueAsDecimal();
public:
Decimal ValueAsDecimal()

Return Value

Type: Decimal
Value as decimal.
See Also

Reference

CategorizedSettingsElement Class
ValueAsDecimal Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDecimal Method (Decimal)

Grid Solutions Framework CategorizedSettingsElementValueAsDecimal Method (Decimal)
Gets the setting value as a decimal.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public decimal ValueAsDecimal(
    decimal defaultValue
)
Public Function ValueAsDecimal (
    defaultValue As Decimal
) As Decimal
member ValueAsDecimal :
        defaultValue : decimal -> decimal

function ValueAsDecimal(defaultValue);
public:
Decimal ValueAsDecimal(
    Decimal defaultValue
)

Parameters

defaultValue
Type: SystemDecimal
The default value to return if the setting value is empty.

Return Value

Type: Decimal
Value as decimal.
See Also

Reference

CategorizedSettingsElement Class
ValueAsDecimal Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDouble Method

Grid Solutions Framework CategorizedSettingsElementValueAsDouble Method
Overload List
 | Name | Description
Public method | ValueAsDouble | Gets the setting value as a double.
Public method | ValueAsDouble(Double) | Gets the setting value as a double.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDouble Method

Grid Solutions Framework CategorizedSettingsElementValueAsDouble Method
Gets the setting value as a double.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ValueAsDouble()
Public Function ValueAsDouble As Double
member ValueAsDouble : unit -> float

function ValueAsDouble();
public:
double ValueAsDouble()

Return Value

Type: Double
Value as double.
See Also

Reference

CategorizedSettingsElement Class
ValueAsDouble Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsDouble Method (Double)

Grid Solutions Framework CategorizedSettingsElementValueAsDouble Method (Double)
Gets the setting value as a double.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ValueAsDouble(
    double defaultValue
)
Public Function ValueAsDouble (
    defaultValue As Double
) As Double
member ValueAsDouble :
        defaultValue : float -> float

function ValueAsDouble(defaultValue);
public:
double ValueAsDouble(
    double defaultValue
)

Parameters

defaultValue
Type: SystemDouble
The default value to return if the setting value is empty.

Return Value

Type: Double
Value as double.
See Also

Reference

CategorizedSettingsElement Class
ValueAsDouble Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt16 Method

Grid Solutions Framework CategorizedSettingsElementValueAsInt16 Method
Overload List
 | Name | Description
Public method | ValueAsInt16 | Gets the setting value as a short.
Public method | ValueAsInt16(Int16) | Gets the setting value as a short.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt16 Method

Grid Solutions Framework CategorizedSettingsElementValueAsInt16 Method
Gets the setting value as a short.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short ValueAsInt16()
Public Function ValueAsInt16 As Short
member ValueAsInt16 : unit -> int16

function ValueAsInt16();
public:
short ValueAsInt16()

Return Value

Type: Int16
Value as short.
See Also

Reference

CategorizedSettingsElement Class
ValueAsInt16 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt16 Method (Int16)

Grid Solutions Framework CategorizedSettingsElementValueAsInt16 Method (Int16)
Gets the setting value as a short.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short ValueAsInt16(
    short defaultValue
)
Public Function ValueAsInt16 (
    defaultValue As Short
) As Short
member ValueAsInt16 :
        defaultValue : int16 -> int16

function ValueAsInt16(defaultValue);
public:
short ValueAsInt16(
    short defaultValue
)

Parameters

defaultValue
Type: SystemInt16
The default value to return if the setting value is empty.

Return Value

Type: Int16
Value as short.
See Also

Reference

CategorizedSettingsElement Class
ValueAsInt16 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt32 Method

Grid Solutions Framework CategorizedSettingsElementValueAsInt32 Method
Overload List
 | Name | Description
Public method | ValueAsInt32 | Gets the setting value as an int.
Public method | ValueAsInt32(Int32) | Gets the setting value as an int.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt32 Method

Grid Solutions Framework CategorizedSettingsElementValueAsInt32 Method
Gets the setting value as an int.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ValueAsInt32()
Public Function ValueAsInt32 As Integer
member ValueAsInt32 : unit -> int

function ValueAsInt32();
public:
int ValueAsInt32()

Return Value

Type: Int32
Value as int.
See Also

Reference

CategorizedSettingsElement Class
ValueAsInt32 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt32 Method (Int32)

Grid Solutions Framework CategorizedSettingsElementValueAsInt32 Method (Int32)
Gets the setting value as an int.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ValueAsInt32(
    int defaultValue
)
Public Function ValueAsInt32 (
    defaultValue As Integer
) As Integer
member ValueAsInt32 :
        defaultValue : int -> int

function ValueAsInt32(defaultValue);
public:
int ValueAsInt32(
    int defaultValue
)

Parameters

defaultValue
Type: SystemInt32
The default value to return if the setting value is empty.

Return Value

Type: Int32
Value as int.
See Also

Reference

CategorizedSettingsElement Class
ValueAsInt32 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt64 Method

Grid Solutions Framework CategorizedSettingsElementValueAsInt64 Method
Overload List
 | Name | Description
Public method | ValueAsInt64 | Gets the setting value as a long.
Public method | ValueAsInt64(Int64) | Gets the setting value as a long.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt64 Method

Grid Solutions Framework CategorizedSettingsElementValueAsInt64 Method
Gets the setting value as a long.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ValueAsInt64()
Public Function ValueAsInt64 As Long
member ValueAsInt64 : unit -> int64

function ValueAsInt64();
public:
long long ValueAsInt64()

Return Value

Type: Int64
Value as long.
See Also

Reference

CategorizedSettingsElement Class
ValueAsInt64 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsInt64 Method (Int64)

Grid Solutions Framework CategorizedSettingsElementValueAsInt64 Method (Int64)
Gets the setting value as a long.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ValueAsInt64(
    long defaultValue
)
Public Function ValueAsInt64 (
    defaultValue As Long
) As Long
member ValueAsInt64 :
        defaultValue : int64 -> int64

function ValueAsInt64(defaultValue);
public:
long long ValueAsInt64(
    long long defaultValue
)

Parameters

defaultValue
Type: SystemInt64
The default value to return if the setting value is empty.

Return Value

Type: Int64
Value as long.
See Also

Reference

CategorizedSettingsElement Class
ValueAsInt64 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsSByte Method

Grid Solutions Framework CategorizedSettingsElementValueAsSByte Method
Overload List
 | Name | Description
Public method | ValueAsSByte | Gets the setting value as a signed byte.
Public method | ValueAsSByte(SByte) | Gets the setting value as a signed byte.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsSByte Method

Grid Solutions Framework CategorizedSettingsElementValueAsSByte Method
Gets the setting value as a signed byte.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sbyte ValueAsSByte()
Public Function ValueAsSByte As SByte
member ValueAsSByte : unit -> sbyte

function ValueAsSByte();
public:
signed char ValueAsSByte()

Return Value

Type: SByte
Value as signed byte.
See Also

Reference

CategorizedSettingsElement Class
ValueAsSByte Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsSByte Method (SByte)

Grid Solutions Framework CategorizedSettingsElementValueAsSByte Method (SByte)
Gets the setting value as a signed byte.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sbyte ValueAsSByte(
    sbyte defaultValue
)
Public Function ValueAsSByte (
    defaultValue As SByte
) As SByte
member ValueAsSByte :
        defaultValue : sbyte -> sbyte

function ValueAsSByte(defaultValue);
public:
signed char ValueAsSByte(
    signed char defaultValue
)

Parameters

defaultValue
Type: SystemSByte
The default value to return if the setting value is empty.

Return Value

Type: SByte
Value as signed byte.
See Also

Reference

CategorizedSettingsElement Class
ValueAsSByte Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsSingle Method

Grid Solutions Framework CategorizedSettingsElementValueAsSingle Method
Overload List
 | Name | Description
Public method | ValueAsSingle | Gets the setting value as a float.
Public method | ValueAsSingle(Single) | Gets the setting value as a float.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsSingle Method

Grid Solutions Framework CategorizedSettingsElementValueAsSingle Method
Gets the setting value as a float.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ValueAsSingle()
Public Function ValueAsSingle As Single
member ValueAsSingle : unit -> float32

function ValueAsSingle();
public:
float ValueAsSingle()

Return Value

Type: Single
Value as float.
See Also

Reference

CategorizedSettingsElement Class
ValueAsSingle Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsSingle Method (Single)

Grid Solutions Framework CategorizedSettingsElementValueAsSingle Method (Single)
Gets the setting value as a float.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ValueAsSingle(
    float defaultValue
)
Public Function ValueAsSingle (
    defaultValue As Single
) As Single
member ValueAsSingle :
        defaultValue : float32 -> float32

function ValueAsSingle(defaultValue);
public:
float ValueAsSingle(
    float defaultValue
)

Parameters

defaultValue
Type: SystemSingle
The default value to return if the setting value is empty.

Return Value

Type: Single
Value as float.
See Also

Reference

CategorizedSettingsElement Class
ValueAsSingle Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsString Method

Grid Solutions Framework CategorizedSettingsElementValueAsString Method
Overload List
 | Name | Description
Public method | ValueAsString | Gets the setting value as a string.
Public method | ValueAsString(String) | Gets the setting value as a string.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsString Method

Grid Solutions Framework CategorizedSettingsElementValueAsString Method
Gets the setting value as a string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ValueAsString()
Public Function ValueAsString As String
member ValueAsString : unit -> string

function ValueAsString();
public:
String^ ValueAsString()

Return Value

Type: String
Value as string.
See Also

Reference

CategorizedSettingsElement Class
ValueAsString Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsString Method (String)

Grid Solutions Framework CategorizedSettingsElementValueAsString Method (String)
Gets the setting value as a string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ValueAsString(
    string defaultValue
)
Public Function ValueAsString (
    defaultValue As String
) As String
member ValueAsString :
        defaultValue : string -> string

function ValueAsString(defaultValue);
public:
String^ ValueAsString(
    String^ defaultValue
)

Parameters

defaultValue
Type: SystemString
The default value to return if the setting value is empty.

Return Value

Type: String
Value as string.
See Also

Reference

CategorizedSettingsElement Class
ValueAsString Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt16 Method

Grid Solutions Framework CategorizedSettingsElementValueAsUInt16 Method
Overload List
 | Name | Description
Public method | ValueAsUInt16 | Gets the setting value as an unsigned short.
Public method | ValueAsUInt16(UInt16) | Gets the setting value as an unsigned short.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt16 Method

Grid Solutions Framework CategorizedSettingsElementValueAsUInt16 Method
Gets the setting value as an unsigned short.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ValueAsUInt16()
Public Function ValueAsUInt16 As UShort
member ValueAsUInt16 : unit -> uint16

function ValueAsUInt16();
public:
unsigned short ValueAsUInt16()

Return Value

Type: UInt16
Value as unsigned short.
See Also

Reference

CategorizedSettingsElement Class
ValueAsUInt16 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt16 Method (UInt16)

Grid Solutions Framework CategorizedSettingsElementValueAsUInt16 Method (UInt16)
Gets the setting value as an unsigned short.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ValueAsUInt16(
    ushort defaultValue
)
Public Function ValueAsUInt16 (
    defaultValue As UShort
) As UShort
member ValueAsUInt16 :
        defaultValue : uint16 -> uint16

function ValueAsUInt16(defaultValue);
public:
unsigned short ValueAsUInt16(
    unsigned short defaultValue
)

Parameters

defaultValue
Type: SystemUInt16
The default value to return if the setting value is empty.

Return Value

Type: UInt16
Value as unsigned short.
See Also

Reference

CategorizedSettingsElement Class
ValueAsUInt16 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt32 Method

Grid Solutions Framework CategorizedSettingsElementValueAsUInt32 Method
Overload List
 | Name | Description
Public method | ValueAsUInt32 | Gets the setting value as an unsigned int.
Public method | ValueAsUInt32(UInt32) | Gets the setting value as an unsigned int.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt32 Method

Grid Solutions Framework CategorizedSettingsElementValueAsUInt32 Method
Gets the setting value as an unsigned int.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ValueAsUInt32()
Public Function ValueAsUInt32 As UInteger
member ValueAsUInt32 : unit -> uint32

function ValueAsUInt32();
public:
unsigned int ValueAsUInt32()

Return Value

Type: UInt32
Value as unsigned int.
See Also

Reference

CategorizedSettingsElement Class
ValueAsUInt32 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt32 Method (UInt32)

Grid Solutions Framework CategorizedSettingsElementValueAsUInt32 Method (UInt32)
Gets the setting value as an unsigned int.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ValueAsUInt32(
    uint defaultValue
)
Public Function ValueAsUInt32 (
    defaultValue As UInteger
) As UInteger
member ValueAsUInt32 :
        defaultValue : uint32 -> uint32

function ValueAsUInt32(defaultValue);
public:
unsigned int ValueAsUInt32(
    unsigned int defaultValue
)

Parameters

defaultValue
Type: SystemUInt32
The default value to return if the setting value is empty.

Return Value

Type: UInt32
Value as unsigned int.
See Also

Reference

CategorizedSettingsElement Class
ValueAsUInt32 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt64 Method

Grid Solutions Framework CategorizedSettingsElementValueAsUInt64 Method
Overload List
 | Name | Description
Public method | ValueAsUInt64 | Gets the setting value as an unsigned long.
Public method | ValueAsUInt64(UInt64) | Gets the setting value as an unsigned long.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt64 Method

Grid Solutions Framework CategorizedSettingsElementValueAsUInt64 Method
Gets the setting value as an unsigned long.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong ValueAsUInt64()
Public Function ValueAsUInt64 As ULong
member ValueAsUInt64 : unit -> uint64

function ValueAsUInt64();
public:
unsigned long long ValueAsUInt64()

Return Value

Type: UInt64
Value as unsigned long.
See Also

Reference

CategorizedSettingsElement Class
ValueAsUInt64 Overload
GSF.Configuration Namespace


CategorizedSettingsElement.ValueAsUInt64 Method (UInt64)

Grid Solutions Framework CategorizedSettingsElementValueAsUInt64 Method (UInt64)
Gets the setting value as an unsigned long.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong ValueAsUInt64(
    ulong defaultValue
)
Public Function ValueAsUInt64 (
    defaultValue As ULong
) As ULong
member ValueAsUInt64 :
        defaultValue : uint64 -> uint64

function ValueAsUInt64(defaultValue);
public:
unsigned long long ValueAsUInt64(
    unsigned long long defaultValue
)

Parameters

defaultValue
Type: SystemUInt64
The default value to return if the setting value is empty.

Return Value

Type: UInt64
Value as unsigned long.
See Also

Reference

CategorizedSettingsElement Class
ValueAsUInt64 Overload
GSF.Configuration Namespace


CategorizedSettingsElement Properties

Grid Solutions Framework CategorizedSettingsElement Properties

The CategorizedSettingsElement type exposes the following members.

Properties
 | Name | Description
Public property | Category | Gets or sets the CategorizedSettingsElementCollection to which this CategorizedSettingsElement belongs.
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | Description | Gets or sets the description of the setting.
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | Encrypted | Gets or sets a boolean value that indicates whether the setting value is to be encrypted.
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Protected property | ItemString | Gets or sets a property, attribute, or child element of this configuration element. (Inherited from ConfigurationElement.)
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Name | Gets or sets the identifier of the setting.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | Scope | Gets or sets the SettingScope.
Public property | SerializedValue | Gets value that will actually be serialized to the configuration file.
Public property | Value | Gets or sets the value of the setting.
Top
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Category Property

Grid Solutions Framework CategorizedSettingsElementCategory Property
Gets or sets the CategorizedSettingsElementCollection to which this CategorizedSettingsElement belongs.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsElementCollection Category { get; }
Public ReadOnly Property Category As CategorizedSettingsElementCollection
    Get
member Category : CategorizedSettingsElementCollection with get

function get_Category();

public:
property CategorizedSettingsElementCollection^ Category {
    CategorizedSettingsElementCollection^ get ();
}

Property Value

Type: CategorizedSettingsElementCollection
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Description Property

Grid Solutions Framework CategorizedSettingsElementDescription Property
Gets or sets the description of the setting.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConfigurationPropertyAttribute("description", IsRequired = true, DefaultValue = "")]
public string Description { get; set; }
<ConfigurationPropertyAttribute("description", IsRequired := true, DefaultValue := "")>
Public Property Description As String
    Get
    Set
[<ConfigurationPropertyAttribute("description", IsRequired = true, DefaultValue = "")>]
member Description : string with get, set

function get_Description();
function set_Description(value);
public:
[ConfigurationPropertyAttribute(L"description", IsRequired = true, DefaultValue = L"")]
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Return Value

Type: String
The description of the setting.
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Encrypted Property

Grid Solutions Framework CategorizedSettingsElementEncrypted Property
Gets or sets a boolean value that indicates whether the setting value is to be encrypted.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConfigurationPropertyAttribute("encrypted", IsRequired = true, DefaultValue = false)]
public bool Encrypted { get; set; }
<ConfigurationPropertyAttribute("encrypted", IsRequired := true, DefaultValue := false)>
Public Property Encrypted As Boolean
    Get
    Set
[<ConfigurationPropertyAttribute("encrypted", IsRequired = true, DefaultValue = false)>]
member Encrypted : bool with get, set

function get_Encrypted();
function set_Encrypted(value);
public:
[ConfigurationPropertyAttribute(L"encrypted", IsRequired = true, DefaultValue = false)]
property bool Encrypted {
    bool get ();
    void set (bool value);
}

Return Value

Type: Boolean
true, if the setting value is to be encrypted; otherwise false.
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Name Property

Grid Solutions Framework CategorizedSettingsElementName Property
Gets or sets the identifier of the setting.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConfigurationPropertyAttribute("name", IsKey = true, IsRequired = true)]
public string Name { get; set; }
<ConfigurationPropertyAttribute("name", IsKey := true, IsRequired := true)>
Public Property Name As String
    Get
    Set
[<ConfigurationPropertyAttribute("name", IsKey = true, IsRequired = true)>]
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
[ConfigurationPropertyAttribute(L"name", IsKey = true, IsRequired = true)]
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Return Value

Type: String
The identifier of the setting.
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Scope Property

Grid Solutions Framework CategorizedSettingsElementScope Property
Gets or sets the SettingScope.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConfigurationPropertyAttribute("scope", IsRequired = false, DefaultValue = SettingScope.Application)]
public SettingScope Scope { get; set; }
<ConfigurationPropertyAttribute("scope", IsRequired := false, DefaultValue := SettingScope.Application)>
Public Property Scope As SettingScope
    Get
    Set
[<ConfigurationPropertyAttribute("scope", IsRequired = false, DefaultValue = SettingScope.Application)>]
member Scope : SettingScope with get, set

function get_Scope();
function set_Scope(value);
public:
[ConfigurationPropertyAttribute(L"scope", IsRequired = false, DefaultValue = SettingScope::Application)]
property SettingScope Scope {
    SettingScope get ();
    void set (SettingScope value);
}

Property Value

Type: SettingScope
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.SerializedValue Property

Grid Solutions Framework CategorizedSettingsElementSerializedValue Property
Gets value that will actually be serialized to the configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SerializedValue { get; }
Public ReadOnly Property SerializedValue As String
    Get
member SerializedValue : string with get

function get_SerializedValue();

public:
property String^ SerializedValue {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElement.Value Property

Grid Solutions Framework CategorizedSettingsElementValue Property
Gets or sets the value of the setting.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConfigurationPropertyAttribute("value", IsRequired = true, DefaultValue = "")]
public string Value { get; set; }
<ConfigurationPropertyAttribute("value", IsRequired := true, DefaultValue := "")>
Public Property Value As String
    Get
    Set
[<ConfigurationPropertyAttribute("value", IsRequired = true, DefaultValue = "")>]
member Value : string with get, set

function get_Value();
function set_Value(value);
public:
[ConfigurationPropertyAttribute(L"value", IsRequired = true, DefaultValue = L"")]
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Return Value

Type: String
The value of the setting.
Remarks
Value can reference the value of another setting using Eval([Section].[Setting]) syntax or the value of a known .NET type's static member (field, non-indexed property or parameterless method) using Eval([Type].[Member]) syntax as shown in the example below:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <database>
      <add name="SettingsTable" value="dbo.Settings" description="Table that contains the settings."
        encrypted="false" />
      <add name="AdminEmail" value="SELECT * FROM Eval(Database.SettingsTable) WHERE Name = 'AdminEmail'"
        description="Email address of the administrator." encrypted="false" />
      <add name="AuditQuery" value="SELECT * FROM dbo.Log WHERE EntryTime < 'Eval(System.DateTime.UtcNow)'"
        description="Query for retrieving audit records." encrypted="false" />
    </database>
  </categorizedSettings>
</configuration>
See Also

Reference

CategorizedSettingsElement Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection Class

Grid Solutions Framework CategorizedSettingsElementCollection Class
Represents a collection of CategorizedSettingsElement objects.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationElementCollection
GSF.ConfigurationCategorizedSettingsElementCollection

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CategorizedSettingsElementCollection : ConfigurationElementCollection
Public Class CategorizedSettingsElementCollection
    Inherits ConfigurationElementCollection
type CategorizedSettingsElementCollection =
    class
        inherit ConfigurationElementCollection
    end
GSF.Configuration.CategorizedSettingsElementCollection = function();

Type.createClass(
    'GSF.Configuration.CategorizedSettingsElementCollection',
    ConfigurationElementCollection);
public ref class CategorizedSettingsElementCollection : public ConfigurationElementCollection

The CategorizedSettingsElementCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CategorizedSettingsElementCollection | Initializes a new instance of the CategorizedSettingsElementCollection class
Top
Methods
 | Name | Description
Public method | Add(CategorizedSettingsElement) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String, Boolean) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String, Boolean, SettingScope) | Adds a new CategorizedSettingsElement object if one does not exist.
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | Removes all existing CategorizedSettingsElement objects.
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | Creates a new CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionCreateNewElement(String).)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Gets the key for a CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of the specified CategorizedSettingsElement object.
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove(String) | Removes a CategorizedSettingsElement object if it exists.
Public method | Remove(CategorizedSettingsElement) | Removes a CategorizedSettingsElement object if it exists.
Public method | RemoveAt | Removes the CategorizedSettingsElement object at the specified index location.
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting setting values.
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets or sets the CategorizedSettingsElement object at the specified index.
Public property | ItemString | Gets the CategorizedSettingsElement object with the specified name.
Public property | ItemString, Boolean | Gets the CategorizedSettingsElement object with the specified name.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Name | Gets or sets the name of the CategorizedSettingsElementCollection.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | Section | Gets or sets the CategorizedSettingsSection to which this CategorizedSettingsElementCollection belongs.
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

GSF.Configuration Namespace


CategorizedSettingsElementCollection Constructor

Grid Solutions Framework CategorizedSettingsElementCollection Constructor
Initializes a new instance of the CategorizedSettingsElementCollection class

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsElementCollection()
Public Sub New
new : unit -> CategorizedSettingsElementCollection
GSF.Configuration.CategorizedSettingsElementCollection = function();
public:
CategorizedSettingsElementCollection()
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection Methods

Grid Solutions Framework CategorizedSettingsElementCollection Methods

The CategorizedSettingsElementCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add(CategorizedSettingsElement) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String, Boolean) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String, Boolean, SettingScope) | Adds a new CategorizedSettingsElement object if one does not exist.
Protected method | BaseAdd(ConfigurationElement) | Adds a configuration element to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(ConfigurationElement, Boolean) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseAdd(Int32, ConfigurationElement) | Adds a configuration element to the configuration element collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseClear | Removes all configuration element objects from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Object) | Returns the configuration element with the specified key. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGet(Int32) | Gets the configuration element at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetAllKeys | Returns an array of the keys for all of the configuration elements contained in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseGetKey | Gets the key for the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIndexOf | Indicates the index of the specified ConfigurationElement. (Inherited from ConfigurationElementCollection.)
Protected method | BaseIsRemoved | Indicates whether the ConfigurationElement with the specified key has been removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemove | Removes a ConfigurationElement from the collection. (Inherited from ConfigurationElementCollection.)
Protected method | BaseRemoveAt | Removes the ConfigurationElement at the specified index location. (Inherited from ConfigurationElementCollection.)
Public method | Clear | Removes all existing CategorizedSettingsElement objects.
Public method | CopyTo | Copies the contents of the ConfigurationElementCollection to an array. (Inherited from ConfigurationElementCollection.)
Protected method | CreateNewElement | Creates a new CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionCreateNewElement(String).)
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Public method | Equals | Compares the ConfigurationElementCollection to the specified object. (Inherited from ConfigurationElementCollection.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetElementKey | Gets the key for a CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionGetElementKey(ConfigurationElement).)
Public method | GetEnumerator | Gets an IEnumerator which is used to iterate through the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public method | GetHashCode | Gets a unique value representing the ConfigurationElementCollection instance. (Inherited from ConfigurationElementCollection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Gets the index of the specified CategorizedSettingsElement object.
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsElementName | Indicates whether the specified ConfigurationElement exists in the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsElementRemovable | Indicates whether the specified ConfigurationElement can be removed from the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected method | IsModified | Indicates whether this ConfigurationElementCollection has been modified since it was last saved or loaded when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public method | IsReadOnly | Indicates whether the ConfigurationElementCollection object is read only. (Inherited from ConfigurationElementCollection.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Causes the configuration system to throw an exception. (Inherited from ConfigurationElementCollection.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove(String) | Removes a CategorizedSettingsElement object if it exists.
Public method | Remove(CategorizedSettingsElement) | Removes a CategorizedSettingsElement object if it exists.
Public method | RemoveAt | Removes the CategorizedSettingsElement object at the specified index location.
Protected method | Reset | Resets the ConfigurationElementCollection to its unmodified state when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | ResetModified | Resets the value of the IsModified property to false when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeElement | Writes the configuration data to an XML element in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting setting values.
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElementCollection object and for all sub-elements. (Inherited from ConfigurationElementCollection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Reverses the effect of merging configuration information from different levels of the configuration hierarchy (Inherited from ConfigurationElementCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Add Method

Grid Solutions Framework CategorizedSettingsElementCollectionAdd Method
Overload List
 | Name | Description
Public method | Add(CategorizedSettingsElement) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String, Boolean) | Adds a new CategorizedSettingsElement object if one does not exist.
Public method | Add(String, Object, String, Boolean, SettingScope) | Adds a new CategorizedSettingsElement object if one does not exist.
Top
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Add Method (CategorizedSettingsElement)

Grid Solutions Framework CategorizedSettingsElementCollectionAdd Method (CategorizedSettingsElement)
Adds a new CategorizedSettingsElement object if one does not exist.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    CategorizedSettingsElement setting
)
Public Sub Add (
    setting As CategorizedSettingsElement
)
member Add :
        setting : CategorizedSettingsElement -> unit

function Add(setting);
public:
void Add(
    CategorizedSettingsElement^ setting
)

Parameters

setting
Type: GSF.ConfigurationCategorizedSettingsElement
The CategorizedSettingsElement object to add.
See Also

Reference

CategorizedSettingsElementCollection Class
Add Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Add Method (String, Object)

Grid Solutions Framework CategorizedSettingsElementCollectionAdd Method (String, Object)
Adds a new CategorizedSettingsElement object if one does not exist.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    string name,
    Object value
)
Public Sub Add (
    name As String,
    value As Object
)
member Add :
        name : string *
        value : Object -> unit

function Add(name, value);
public:
void Add(
    String^ name,
    Object^ value
)

Parameters

name
Type: SystemString
Name of the CategorizedSettingsElement object.
value
Type: SystemObject
Value of the CategorizedSettingsElement object.
See Also

Reference

CategorizedSettingsElementCollection Class
Add Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Add Method (String, Object, String)

Grid Solutions Framework CategorizedSettingsElementCollectionAdd Method (String, Object, String)
Adds a new CategorizedSettingsElement object if one does not exist.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    string name,
    Object value,
    string description
)
Public Sub Add (
    name As String,
    value As Object,
    description As String
)
member Add :
        name : string *
        value : Object *
        description : string -> unit

function Add(name, value, description);
public:
void Add(
    String^ name,
    Object^ value,
    String^ description
)

Parameters

name
Type: SystemString
Name of the CategorizedSettingsElement object.
value
Type: SystemObject
Value of the CategorizedSettingsElement object.
description
Type: SystemString
Description of the CategorizedSettingsElement object.
See Also

Reference

CategorizedSettingsElementCollection Class
Add Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Add Method (String, Object, String, Boolean)

Grid Solutions Framework CategorizedSettingsElementCollectionAdd Method (String, Object, String, Boolean)
Adds a new CategorizedSettingsElement object if one does not exist.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    string name,
    Object value,
    string description,
    bool encryptValue
)
Public Sub Add (
    name As String,
    value As Object,
    description As String,
    encryptValue As Boolean
)
member Add :
        name : string *
        value : Object *
        description : string *
        encryptValue : bool -> unit

function Add(name, value, description, encryptValue);
public:
void Add(
    String^ name,
    Object^ value,
    String^ description,
    bool encryptValue
)

Parameters

name
Type: SystemString
Name of the CategorizedSettingsElement object.
value
Type: SystemObject
Value of the CategorizedSettingsElement object.
description
Type: SystemString
Description of the CategorizedSettingsElement object.
encryptValue
Type: SystemBoolean
true if the Value of CategorizedSettingsElement object is to be encrypted; otherwise false.
See Also

Reference

CategorizedSettingsElementCollection Class
Add Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Add Method (String, Object, String, Boolean, SettingScope)

Grid Solutions Framework CategorizedSettingsElementCollectionAdd Method (String, Object, String, Boolean, SettingScope)
Adds a new CategorizedSettingsElement object if one does not exist.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    string name,
    Object value,
    string description,
    bool encryptValue,
    SettingScope scope
)
Public Sub Add (
    name As String,
    value As Object,
    description As String,
    encryptValue As Boolean,
    scope As SettingScope
)
member Add :
        name : string *
        value : Object *
        description : string *
        encryptValue : bool *
        scope : SettingScope -> unit

function Add(name, value, description, encryptValue, scope);
public:
void Add(
    String^ name,
    Object^ value,
    String^ description,
    bool encryptValue,
    SettingScope scope
)

Parameters

name
Type: SystemString
Name of the CategorizedSettingsElement object.
value
Type: SystemObject
Value of the CategorizedSettingsElement object.
description
Type: SystemString
Description of the CategorizedSettingsElement object.
encryptValue
Type: SystemBoolean
true if the Value of CategorizedSettingsElement object is to be encrypted; otherwise false.
scope
Type: GSF.ConfigurationSettingScope
One of the SettingScope values.
See Also

Reference

CategorizedSettingsElementCollection Class
Add Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Clear Method

Grid Solutions Framework CategorizedSettingsElementCollectionClear Method
Removes all existing CategorizedSettingsElement objects.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.CreateNewElement Method

Grid Solutions Framework CategorizedSettingsElementCollectionCreateNewElement Method
Overload List
 | Name | Description
Protected method | CreateNewElement | Creates a new CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionCreateNewElement.)
Protected method | CreateNewElement(String) | Creates a new CategorizedSettingsElement object. (Overrides ConfigurationElementCollectionCreateNewElement(String).)
Top
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.CreateNewElement Method

Grid Solutions Framework CategorizedSettingsElementCollectionCreateNewElement Method
Creates a new CategorizedSettingsElement object.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ConfigurationElement CreateNewElement()
Protected Overrides Function CreateNewElement As ConfigurationElement
abstract CreateNewElement : unit -> ConfigurationElement
override CreateNewElement : unit -> ConfigurationElement
function CreateNewElement();
protected:
virtual ConfigurationElement^ CreateNewElement() override

Return Value

Type: ConfigurationElement
Instance of CategorizedSettingsElement.
See Also

Reference

CategorizedSettingsElementCollection Class
CreateNewElement Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.CreateNewElement Method (String)

Grid Solutions Framework CategorizedSettingsElementCollectionCreateNewElement Method (String)
Creates a new CategorizedSettingsElement object.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ConfigurationElement CreateNewElement(
    string elementName
)
Protected Overrides Function CreateNewElement (
    elementName As String
) As ConfigurationElement
abstract CreateNewElement :
        elementName : string -> ConfigurationElement
override CreateNewElement :
        elementName : string -> ConfigurationElement
function CreateNewElement(elementName);
protected:
virtual ConfigurationElement^ CreateNewElement(
    String^ elementName
) override

Parameters

elementName
Type: SystemString
Name identifying the CategorizedSettingsElement object.

Return Value

Type: ConfigurationElement
Instance of CategorizedSettingsElement.
See Also

Reference

CategorizedSettingsElementCollection Class
CreateNewElement Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.GetElementKey Method

Grid Solutions Framework CategorizedSettingsElementCollectionGetElementKey Method
Gets the key for a CategorizedSettingsElement object.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override Object GetElementKey(
    ConfigurationElement element
)
Protected Overrides Function GetElementKey (
    element As ConfigurationElement
) As Object
abstract GetElementKey :
        element : ConfigurationElement -> Object
override GetElementKey :
        element : ConfigurationElement -> Object
function GetElementKey(element);
protected:
virtual Object^ GetElementKey(
    ConfigurationElement^ element
) override

Parameters

element
Type: System.ConfigurationConfigurationElement
CategorizedSettingsElement object whose key is to be retrieved.

Return Value

Type: Object
String key value for a CategorizedSettingsElement object.
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.IndexOf Method

Grid Solutions Framework CategorizedSettingsElementCollectionIndexOf Method
Gets the index of the specified CategorizedSettingsElement object.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int IndexOf(
    CategorizedSettingsElement setting
)
Public Function IndexOf (
    setting As CategorizedSettingsElement
) As Integer
member IndexOf :
        setting : CategorizedSettingsElement -> int

function IndexOf(setting);
public:
int IndexOf(
    CategorizedSettingsElement^ setting
)

Parameters

setting
Type: GSF.ConfigurationCategorizedSettingsElement
The CategorizedSettingsElement object whose index is to be retrieved.

Return Value

Type: Int32
Index of the specified CategorizedSettingsElement object if found; otherwise -1.
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Remove Method

Grid Solutions Framework CategorizedSettingsElementCollectionRemove Method
Overload List
 | Name | Description
Public method | Remove(String) | Removes a CategorizedSettingsElement object if it exists.
Public method | Remove(CategorizedSettingsElement) | Removes a CategorizedSettingsElement object if it exists.
Top
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Remove Method (String)

Grid Solutions Framework CategorizedSettingsElementCollectionRemove Method (String)
Removes a CategorizedSettingsElement object if it exists.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    string name
)
Public Sub Remove (
    name As String
)
member Remove :
        name : string -> unit

function Remove(name);
public:
void Remove(
    String^ name
)

Parameters

name
Type: SystemString
Name of the CategorizedSettingsElement object to remove.
See Also

Reference

CategorizedSettingsElementCollection Class
Remove Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Remove Method (CategorizedSettingsElement)

Grid Solutions Framework CategorizedSettingsElementCollectionRemove Method (CategorizedSettingsElement)
Removes a CategorizedSettingsElement object if it exists.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    CategorizedSettingsElement setting
)
Public Sub Remove (
    setting As CategorizedSettingsElement
)
member Remove :
        setting : CategorizedSettingsElement -> unit

function Remove(setting);
public:
void Remove(
    CategorizedSettingsElement^ setting
)

Parameters

setting
Type: GSF.ConfigurationCategorizedSettingsElement
The CategorizedSettingsElement object to remove.
See Also

Reference

CategorizedSettingsElementCollection Class
Remove Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.RemoveAt Method

Grid Solutions Framework CategorizedSettingsElementCollectionRemoveAt Method
Removes the CategorizedSettingsElement object at the specified index location.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveAt(
    int index
)
Public Sub RemoveAt (
    index As Integer
)
member RemoveAt :
        index : int -> unit

function RemoveAt(index);
public:
void RemoveAt(
    int index
)

Parameters

index
Type: SystemInt32
Index location of the CategorizedSettingsElement object to remove.
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.SetCryptoKey Method

Grid Solutions Framework CategorizedSettingsElementCollectionSetCryptoKey Method
Sets the key to be used for encrypting and decrypting setting values.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCryptoKey(
    string cryptoKey
)
Public Sub SetCryptoKey (
    cryptoKey As String
)
member SetCryptoKey :
        cryptoKey : string -> unit

function SetCryptoKey(cryptoKey);
public:
void SetCryptoKey(
    String^ cryptoKey
)

Parameters

cryptoKey
Type: SystemString
New crypto key.
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection Properties

Grid Solutions Framework CategorizedSettingsElementCollection Properties

The CategorizedSettingsElementCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AddElementName | Gets or sets the name of the ConfigurationElement to associate with the add operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ClearElementName | Gets or sets the name for the ConfigurationElement to associate with the clear operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | CollectionType | Gets the type of the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Public property | Count | Gets the number of elements in the collection. (Inherited from ConfigurationElementCollection.)
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementName | Gets the name used to identify this collection of elements in the configuration file when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Public property | EmitClear | Gets or sets a value that specifies whether the collection has been cleared. (Inherited from ConfigurationElementCollection.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Public property | IsSynchronized | Gets a value indicating whether access to the collection is synchronized. (Inherited from ConfigurationElementCollection.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets or sets the CategorizedSettingsElement object at the specified index.
Public property | ItemString | Gets the CategorizedSettingsElement object with the specified name.
Public property | ItemString, Boolean | Gets the CategorizedSettingsElement object with the specified name.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Public property | Name | Gets or sets the name of the CategorizedSettingsElementCollection.
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Protected property | RemoveElementName | Gets or sets the name of the ConfigurationElement to associate with the remove operation in the ConfigurationElementCollection when overridden in a derived class. (Inherited from ConfigurationElementCollection.)
Public property | Section | Gets or sets the CategorizedSettingsSection to which this CategorizedSettingsElementCollection belongs.
Public property | SyncRoot | Gets an object used to synchronize access to the ConfigurationElementCollection. (Inherited from ConfigurationElementCollection.)
Protected property | ThrowOnDuplicate | Gets a value indicating whether an attempt to add a duplicate ConfigurationElement to the ConfigurationElementCollection will cause an exception to be thrown. (Inherited from ConfigurationElementCollection.)
Top
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Item Property

Grid Solutions Framework CategorizedSettingsElementCollectionItem Property
Overload List
 | Name | Description
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemInt32 | Gets or sets the CategorizedSettingsElement object at the specified index.
Public property | ItemString | Gets the CategorizedSettingsElement object with the specified name.
Public property | ItemString, Boolean | Gets the CategorizedSettingsElement object with the specified name.
Top
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Item Property (Int32)

Grid Solutions Framework CategorizedSettingsElementCollectionItem Property (Int32)
Gets or sets the CategorizedSettingsElement object at the specified index.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsElement this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As CategorizedSettingsElement
    Get
    Set
member Item : CategorizedSettingsElement with get, set

function get_Item(index);
function set_Item(value);
public:
property CategorizedSettingsElement^ default[int index] {
    CategorizedSettingsElement^ get (int index);
    void set (int index, CategorizedSettingsElement^ value);
}

Parameters

index
Type: SystemInt32
Zero-based index for the CategorizedSettingsElement object to retrieve.

Return Value

Type: CategorizedSettingsElement
The CategorizedSettingsElement object at the specified index if it exists; otherwise null.
See Also

Reference

CategorizedSettingsElementCollection Class
Item Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Item Property (String)

Grid Solutions Framework CategorizedSettingsElementCollectionItem Property (String)
Gets the CategorizedSettingsElement object with the specified name.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsElement this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As CategorizedSettingsElement
    Get
member Item : CategorizedSettingsElement with get

function get_Item(name);

public:
property CategorizedSettingsElement^ default[String^ name] {
    CategorizedSettingsElement^ get (String^ name);
}

Parameters

name
Type: SystemString
Name of the CategorizedSettingsElement object to retrieve.

Return Value

Type: CategorizedSettingsElement
The CategorizedSettingsElement object with the specified name if it exists; otherwise null.
See Also

Reference

CategorizedSettingsElementCollection Class
Item Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Item Property (String, Boolean)

Grid Solutions Framework CategorizedSettingsElementCollectionItem Property (String, Boolean)
Gets the CategorizedSettingsElement object with the specified name.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsElement this[
    string name,
    bool ensureExistance
] { get; }
Public ReadOnly Default Property Item (
    name As String,
    ensureExistance As Boolean
) As CategorizedSettingsElement
    Get
member Item : CategorizedSettingsElement with get

function get_Item(name, ensureExistance);

public:
property CategorizedSettingsElement^ default[String^ name, bool ensureExistance] {
    CategorizedSettingsElement^ get (String^ name, bool ensureExistance);
}

Parameters

name
Type: SystemString
Name of the CategorizedSettingsElement object to retrieve.
ensureExistance
Type: SystemBoolean
true if the CategorizedSettingsElement object is to be created if it does not exist; otherwise false.

Return Value

Type: CategorizedSettingsElement
The CategorizedSettingsElement object with the specified name if it exists; otherwise null.
See Also

Reference

CategorizedSettingsElementCollection Class
Item Overload
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Name Property

Grid Solutions Framework CategorizedSettingsElementCollectionName Property
Gets or sets the name of the CategorizedSettingsElementCollection.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
member Name : string with get

function get_Name();

public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsElementCollection.Section Property

Grid Solutions Framework CategorizedSettingsElementCollectionSection Property
Gets or sets the CategorizedSettingsSection to which this CategorizedSettingsElementCollection belongs.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsSection Section { get; }
Public ReadOnly Property Section As CategorizedSettingsSection
    Get
member Section : CategorizedSettingsSection with get

function get_Section();

public:
property CategorizedSettingsSection^ Section {
    CategorizedSettingsSection^ get ();
}

Property Value

Type: CategorizedSettingsSection
See Also

Reference

CategorizedSettingsElementCollection Class
GSF.Configuration Namespace


CategorizedSettingsSection Class

Grid Solutions Framework CategorizedSettingsSection Class
Represents a section in the config file with one or more CategorizedSettingsElementCollection representing categories, each containing one or more CategorizedSettingsElement objects representing settings under a specific category.
Inheritance Hierarchy
SystemObject
System.ConfigurationConfigurationElement
System.ConfigurationConfigurationSection
GSF.ConfigurationCategorizedSettingsSection

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CategorizedSettingsSection : ConfigurationSection
Public Class CategorizedSettingsSection
    Inherits ConfigurationSection
type CategorizedSettingsSection =
    class
        inherit ConfigurationSection
    end
GSF.Configuration.CategorizedSettingsSection = function();

Type.createClass(
    'GSF.Configuration.CategorizedSettingsSection',
    ConfigurationSection);
public ref class CategorizedSettingsSection : public ConfigurationSection

The CategorizedSettingsSection type exposes the following members.

Constructors
 | Name | Description
Public method | CategorizedSettingsSection | Creates a new CategorizedSettingsSection.
Top
Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Overrides ConfigurationSectionDeserializeSection(XmlReader).)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | Removes the specified category name including its associated settings.
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Overrides ConfigurationSectionSerializeSection(ConfigurationElement, String, ConfigurationSaveMode).)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting setting values.
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Protected method | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | File | Gets or sets the ConfigurationFile to which this CategorizedSettingsSection belongs.
Public property | General | Gets the CategorizedSettingsElementCollection object representing settings under "general" category.
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemString | Gets the CategorizedSettingsElementCollection object representing settings under the specified category name.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Top
See Also

Reference

GSF.Configuration Namespace
GSF.ConfigurationCategorizedSettingsElement
GSF.ConfigurationCategorizedSettingsElementCollection


CategorizedSettingsSection Constructor

Grid Solutions Framework CategorizedSettingsSection Constructor
Creates a new CategorizedSettingsSection.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsSection()
Public Sub New
new : unit -> CategorizedSettingsSection
GSF.Configuration.CategorizedSettingsSection = function();
public:
CategorizedSettingsSection()
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection Methods

Grid Solutions Framework CategorizedSettingsSection Methods

The CategorizedSettingsSection type exposes the following members.

Methods
 | Name | Description
Protected method | DeserializeElement | Reads XML from the configuration file. (Inherited from ConfigurationElement.)
Protected method | DeserializeSection | Reads XML from the configuration file. (Overrides ConfigurationSectionDeserializeSection(XmlReader).)
Public method | Equals | Compares the current ConfigurationElement instance to the specified object. (Inherited from ConfigurationElement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a unique value representing the current ConfigurationElement instance. (Inherited from ConfigurationElement.)
Protected method | GetRuntimeObject | Returns a custom object when overridden in a derived class. (Inherited from ConfigurationSection.)
Protected method | GetTransformedAssemblyString | Returns the transformed version of the specified assembly name. (Inherited from ConfigurationElement.)
Protected method | GetTransformedTypeString | Returns the transformed version of the specified type name. (Inherited from ConfigurationElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Init | Sets the ConfigurationElement object to its initial state. (Inherited from ConfigurationElement.)
Protected method | InitializeDefault | Used to initialize a default set of values for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected method | IsModified | Indicates whether this configuration element has been modified since it was last saved or loaded when implemented in a derived class. (Inherited from ConfigurationSection.)
Public method | IsReadOnly | Gets a value indicating whether the ConfigurationElement object is read-only. (Inherited from ConfigurationElement.)
Protected method | ListErrors | Adds the invalid-property errors in this ConfigurationElement object, and in all subelements, to the passed list. (Inherited from ConfigurationElement.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDeserializeUnrecognizedAttribute | Gets a value indicating whether an unknown attribute is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnDeserializeUnrecognizedElement | Gets a value indicating whether an unknown element is encountered during deserialization. (Inherited from ConfigurationElement.)
Protected method | OnRequiredPropertyNotFound | Throws an exception when a required property is not found. (Inherited from ConfigurationElement.)
Protected method | PostDeserialize | Called after deserialization. (Inherited from ConfigurationElement.)
Protected method | PreSerialize | Called before serialization. (Inherited from ConfigurationElement.)
Public method | Remove | Removes the specified category name including its associated settings.
Protected method | Reset | Resets the internal state of the ConfigurationElement object, including the locks and the properties collections. (Inherited from ConfigurationElement.)
Protected method | ResetModified | Resets the value of the IsModified method to false when implemented in a derived class. (Inherited from ConfigurationSection.)
Protected method | SerializeElement | Writes the contents of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Protected method | SerializeSection | Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file. (Overrides ConfigurationSectionSerializeSection(ConfigurationElement, String, ConfigurationSaveMode).)
Protected method | SerializeToXmlElement | Writes the outer tags of this configuration element to the configuration file when implemented in a derived class. (Inherited from ConfigurationElement.)
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting setting values.
Protected method | SetPropertyValue | Sets a property to the specified value. (Inherited from ConfigurationElement.)
Protected method | SetReadOnly | Sets the IsReadOnly property for the ConfigurationElement object and all subelements. (Inherited from ConfigurationElement.)
Protected method | ShouldSerializeElementInTargetVersion | Indicates whether the specified element should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializePropertyInTargetVersion | Indicates whether the specified property should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Protected method | ShouldSerializeSectionInTargetVersion | Indicates whether the current ConfigurationSection instance should be serialized when the configuration object hierarchy is serialized for the specified target version of the .NET Framework. (Inherited from ConfigurationSection.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | Unmerge | Modifies the ConfigurationElement object to remove all values that should not be saved. (Inherited from ConfigurationElement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.DeserializeSection Method

Grid Solutions Framework CategorizedSettingsSectionDeserializeSection Method
Reads XML from the configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void DeserializeSection(
    XmlReader reader
)
Protected Overrides Sub DeserializeSection (
    reader As XmlReader
)
abstract DeserializeSection :
        reader : XmlReader -> unit
override DeserializeSection :
        reader : XmlReader -> unit
function DeserializeSection(reader);
protected:
virtual void DeserializeSection(
    XmlReader^ reader
) override

Parameters

reader
Type: System.XmlXmlReader
The XmlReader object, which reads from the configuration file.
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.Remove Method

Grid Solutions Framework CategorizedSettingsSectionRemove Method
Removes the specified category name including its associated settings.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    string name
)
Public Sub Remove (
    name As String
)
member Remove :
        name : string -> unit

function Remove(name);
public:
void Remove(
    String^ name
)

Parameters

name
Type: SystemString
Name of the category to be removed.
Exceptions
Exception | Condition
ArgumentNullException | name is null or empty string.
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.SerializeSection Method

Grid Solutions Framework CategorizedSettingsSectionSerializeSection Method
Creates an XML string containing an unmerged view of the ConfigurationSection object as a single section to write to a file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override string SerializeSection(
    ConfigurationElement parentElement,
    string name,
    ConfigurationSaveMode saveMode
)
Protected Overrides Function SerializeSection (
    parentElement As ConfigurationElement,
    name As String,
    saveMode As ConfigurationSaveMode
) As String
abstract SerializeSection :
        parentElement : ConfigurationElement *
        name : string *
        saveMode : ConfigurationSaveMode -> string
override SerializeSection :
        parentElement : ConfigurationElement *
        name : string *
        saveMode : ConfigurationSaveMode -> string
function SerializeSection(parentElement, name, saveMode);
protected:
virtual String^ SerializeSection(
    ConfigurationElement^ parentElement,
    String^ name,
    ConfigurationSaveMode saveMode
) override

Parameters

parentElement
Type: System.ConfigurationConfigurationElement
The ConfigurationElement instance to use as the parent when performing the un-merge.
name
Type: SystemString
The name of the section to create.
saveMode
Type: System.ConfigurationConfigurationSaveMode
The ConfigurationSaveMode instance to use when writing to a string.

Return Value

Type: String
An XML string containing an unmerged view of the ConfigurationSection object.
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.SetCryptoKey Method

Grid Solutions Framework CategorizedSettingsSectionSetCryptoKey Method
Sets the key to be used for encrypting and decrypting setting values.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCryptoKey(
    string cryptoKey
)
Public Sub SetCryptoKey (
    cryptoKey As String
)
member SetCryptoKey :
        cryptoKey : string -> unit

function SetCryptoKey(cryptoKey);
public:
void SetCryptoKey(
    String^ cryptoKey
)

Parameters

cryptoKey
Type: SystemString
New crypto key.
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection Properties

Grid Solutions Framework CategorizedSettingsSection Properties

The CategorizedSettingsSection type exposes the following members.

Properties
 | Name | Description
Public property | CurrentConfiguration | Gets a reference to the top-level Configuration instance that represents the configuration hierarchy that the current ConfigurationElement instance belongs to. (Inherited from ConfigurationElement.)
Public property | ElementInformation | Gets an ElementInformation object that contains the non-customizable information and functionality of the ConfigurationElement object. (Inherited from ConfigurationElement.)
Protected property | ElementProperty | Gets the ConfigurationElementProperty object that represents the ConfigurationElement object itself. (Inherited from ConfigurationElement.)
Protected property | EvaluationContext | Gets the ContextInformation object for the ConfigurationElement object. (Inherited from ConfigurationElement.)
Public property | File | Gets or sets the ConfigurationFile to which this CategorizedSettingsSection belongs.
Public property | General | Gets the CategorizedSettingsElementCollection object representing settings under "general" category.
Protected property | HasContext | Gets a value that indicates whether the CurrentConfiguration property is null. (Inherited from ConfigurationElement.)
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemString | Gets the CategorizedSettingsElementCollection object representing settings under the specified category name.
Public property | LockAllAttributesExcept | Gets the collection of locked attributes. (Inherited from ConfigurationElement.)
Public property | LockAllElementsExcept | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockAttributes | Gets the collection of locked attributes (Inherited from ConfigurationElement.)
Public property | LockElements | Gets the collection of locked elements. (Inherited from ConfigurationElement.)
Public property | LockItem | Gets or sets a value indicating whether the element is locked. (Inherited from ConfigurationElement.)
Protected property | Properties | Gets the collection of properties. (Inherited from ConfigurationElement.)
Public property | SectionInformation | Gets a SectionInformation object that contains the non-customizable information and functionality of the ConfigurationSection object. (Inherited from ConfigurationSection.)
Top
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.File Property

Grid Solutions Framework CategorizedSettingsSectionFile Property
Gets or sets the ConfigurationFile to which this CategorizedSettingsSection belongs.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFile File { get; }
Public ReadOnly Property File As ConfigurationFile
    Get
member File : ConfigurationFile with get

function get_File();

public:
property ConfigurationFile^ File {
    ConfigurationFile^ get ();
}

Property Value

Type: ConfigurationFile
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.General Property

Grid Solutions Framework CategorizedSettingsSectionGeneral Property
Gets the CategorizedSettingsElementCollection object representing settings under "general" category.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsElementCollection General { get; }
Public ReadOnly Property General As CategorizedSettingsElementCollection
    Get
member General : CategorizedSettingsElementCollection with get

function get_General();

public:
property CategorizedSettingsElementCollection^ General {
    CategorizedSettingsElementCollection^ get ();
}

Return Value

Type: CategorizedSettingsElementCollection
CategorizedSettingsElementCollection object with settings under the "general" category.
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.Item Property

Grid Solutions Framework CategorizedSettingsSectionItem Property
Overload List
 | Name | Description
Protected property | ItemConfigurationProperty | Gets or sets a property or attribute of this configuration element. (Inherited from ConfigurationElement.)
Public property | ItemString | Gets the CategorizedSettingsElementCollection object representing settings under the specified category name.
Top
See Also

Reference

CategorizedSettingsSection Class
GSF.Configuration Namespace


CategorizedSettingsSection.Item Property (String)

Grid Solutions Framework CategorizedSettingsSectionItem Property (String)
Gets the CategorizedSettingsElementCollection object representing settings under the specified category name.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsElementCollection this[
    string name
] { get; }
Public ReadOnly Default Property Item (
    name As String
) As CategorizedSettingsElementCollection
    Get
member Item : CategorizedSettingsElementCollection with get

function get_Item(name);

public:
property CategorizedSettingsElementCollection^ default[String^ name] {
    CategorizedSettingsElementCollection^ get (String^ name);
}

Parameters

name
Type: SystemString
Name of the category whose settings are to be retrieved.

Return Value

Type: CategorizedSettingsElementCollection
CategorizedSettingsElementCollection object with settings under the specified category name.
Exceptions
Exception | Condition
ArgumentNullException | name is null or empty string.
See Also

Reference

CategorizedSettingsSection Class
Item Overload
GSF.Configuration Namespace


ConfigurationFile Class

Grid Solutions Framework ConfigurationFile Class
Represents a configuration file of a Windows or Web application.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationConfigurationFile

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConfigurationFile
Public Class ConfigurationFile
type ConfigurationFile =  class end
GSF.Configuration.ConfigurationFile = function();

Type.createClass(
    'GSF.Configuration.ConfigurationFile');
public ref class ConfigurationFile

The ConfigurationFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open | Opens application config file at the specified configFilePath.
Public method | Reload | Reloads the current configuration settings from the configuration file that the ConfigurationFile represents.
Public method | RestoreDefaultUserSettings | Restores all the default settings for User scoped settings.
Public method | Save | Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.
Public method | Save(ConfigurationSaveMode) | Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.
Public method | SaveAs | Writes the configuration settings contained within this ConfigurationFile object to the specified configuration file.
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting values of Settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Configuration | Get the underlying Configuration that can be accessed using this ConfigurationFile object.
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String.
 | Current | Gets the ConfigurationFile object that represents the config file of the currently executing Windows or Web application.
Public property | Settings | Gets the CategorizedSettingsSection object representing settings under the "categorizedSettings" section of the config file.
Top
Examples
This example shows how to save and read settings from the config file:
Copy
using System;
using System.Configuration;
using GSF;
using GSF.Configuration;

class Program
{
    static void Main(string[] args)
    {
        // Get the application config file.
        ConfigurationFile config = ConfigurationFile.Current;

        // Get the sections of config file.
        CategorizedSettingsElementCollection startup = config.Settings["Startup"];
        CategorizedSettingsElementCollection passwords = config.Settings["Passwords"];
        CategorizedSettingsElementCollection monitoring = config.Settings["Monitoring"];
        KeyValueConfigurationCollection appSettings = config.Configuration.AppSettings.Settings;
        ConnectionStringSettingsCollection connStrings = config.Configuration.ConnectionStrings.ConnectionStrings;

        // Add settings to the config file under the "appSettings" section.
        appSettings.Add("SaveSettingOnExit", true.ToString());
        // Add settings to the config file under the "connectionStrings" section.
        connStrings.Add(new ConnectionStringSettings("DevSql", "Server=SqlServer;Database=Sandbox;Trusted_Connection=True"));
        // Add settings to the config (if they don't exist) under a custom "monitoring" section.
        monitoring.Add("RefreshInterval", 5, "Interval in seconds at which the Monitor screen is to be refreshed.");
        monitoring.Add("MessagesSnapshot", 30000, "Maximum messages length to be displayed on the Monitor screen.");
        // Add password to the config file encrypted (if it doesn't exist) under a custom "passwords" section.
        passwords.Add("Admin", "Adm1nP4ss", "Password used for performing administrative tasks.", true);
        // Add user-scope setting to the config (if it doesn't exist) under a custom "startup" section.
        startup.Add("Theme", "Default", "Application theme to use for the session.", false, SettingScope.User);
        config.Save();  // Save settings to the config file.

        // Read saved settings from the config file.
        bool saveSettingsOnExit = appSettings["SaveSettingOnExit"].Value.ParseBoolean();
        string devConnectionString = connStrings["DevSql"].ConnectionString;
        string appTheme = startup["Theme"].Value;
        string adminPassword = passwords["Admin"].Value;
        int refreshInterval = monitoring["RefreshInterval"].ValueAsInt32();
        int messagesSnapshot = monitoring["MessagesSnapshot"].ValueAsInt32();

        // Print the retrieved settings to the console.
        Console.WriteLine("SaveSettingOnExit = {0}", saveSettingsOnExit);
        Console.WriteLine("DevSql = {0}", devConnectionString);
        Console.WriteLine("Theme = {0}", appTheme);
        Console.WriteLine("Admin = {0}", adminPassword);
        Console.WriteLine("RefreshInterval = {0}", refreshInterval);
        Console.WriteLine("MessagesSnapshot = {0}", messagesSnapshot);

        Console.ReadLine();
    }
}
This example shows the content of the config file from the sample code above:
Copy
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <appSettings>
    <add key="SaveSettingOnExit" value="True" />
  </appSettings>
  <categorizedSettings>
    <startup>
      <add name="Theme" value="Default" description="Application theme to use for the session."
        encrypted="false" scope="User" />
    </startup>
    <passwords>
      <add name="Admin" value="C+0j6fE/N0Q9b5xaeDKgvRmSeY9zJkO1EQCr7cHoG3x24tztlbBB54PfWsuMGXc/"
        description="Password used for performing administrative tasks."
        encrypted="true" />
    </passwords>
    <monitoring>
      <add name="RefreshInterval" value="5" description="Interval in seconds at which the Monitor screen is to be refreshed."
        encrypted="false" />
      <add name="MessagesSnapshot" value="30000" description="Maximum messages length to be displayed on the Monitor screen."
        encrypted="false" />
    </monitoring>
  </categorizedSettings>
  <connectionStrings>
    <add name="DevSql" connectionString="Server=SqlServer;Database=Sandbox;Trusted_Connection=True" />
  </connectionStrings>
</configuration>
See Also

Reference

GSF.Configuration Namespace
GSF.ConfigurationCategorizedSettingsSection
GSF.ConfigurationCategorizedSettingsElement
GSF.ConfigurationCategorizedSettingsElementCollection


ConfigurationFile Methods

Grid Solutions Framework ConfigurationFile Methods

The ConfigurationFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Open | Opens application config file at the specified configFilePath.
Public method | Reload | Reloads the current configuration settings from the configuration file that the ConfigurationFile represents.
Public method | RestoreDefaultUserSettings | Restores all the default settings for User scoped settings.
Public method | Save | Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.
Public method | Save(ConfigurationSaveMode) | Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.
Public method | SaveAs | Writes the configuration settings contained within this ConfigurationFile object to the specified configuration file.
Public method | SetCryptoKey | Sets the key to be used for encrypting and decrypting values of Settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Open Method

Grid Solutions Framework ConfigurationFileOpen Method
Opens application config file at the specified configFilePath.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ConfigurationFile Open(
    string configFilePath
)
Public Shared Function Open (
    configFilePath As String
) As ConfigurationFile
static member Open :
        configFilePath : string -> ConfigurationFile

GSF.Configuration.ConfigurationFile.Open = function(configFilePath);
public:
static ConfigurationFile^ Open(
    String^ configFilePath
)

Parameters

configFilePath
Type: SystemString
Path of the config file that belongs to a Windows or Web application.

Return Value

Type: ConfigurationFile
An ConfigurationFile object.
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Reload Method

Grid Solutions Framework ConfigurationFileReload Method
Reloads the current configuration settings from the configuration file that the ConfigurationFile represents.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reload()
Public Sub Reload
member Reload : unit -> unit

function Reload();
public:
void Reload()
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.RestoreDefaultUserSettings Method

Grid Solutions Framework ConfigurationFileRestoreDefaultUserSettings Method
Restores all the default settings for User scoped settings.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RestoreDefaultUserSettings()
Public Sub RestoreDefaultUserSettings
member RestoreDefaultUserSettings : unit -> unit

function RestoreDefaultUserSettings();
public:
void RestoreDefaultUserSettings()
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Save Method

Grid Solutions Framework ConfigurationFileSave Method
Overload List
 | Name | Description
Public method | Save | Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.
Public method | Save(ConfigurationSaveMode) | Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.
Top
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Save Method

Grid Solutions Framework ConfigurationFileSave Method
Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Save()
Public Sub Save
member Save : unit -> unit

function Save();
public:
void Save()
See Also

Reference

ConfigurationFile Class
Save Overload
GSF.Configuration Namespace


ConfigurationFile.Save Method (ConfigurationSaveMode)

Grid Solutions Framework ConfigurationFileSave Method (ConfigurationSaveMode)
Writes the configuration settings contained within this ConfigurationFile object to the configuration file that it represents.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Save(
    ConfigurationSaveMode saveMode
)
Public Sub Save (
    saveMode As ConfigurationSaveMode
)
member Save :
        saveMode : ConfigurationSaveMode -> unit

function Save(saveMode);
public:
void Save(
    ConfigurationSaveMode saveMode
)

Parameters

saveMode
Type: System.ConfigurationConfigurationSaveMode
One of the ConfigurationSaveMode values.
See Also

Reference

ConfigurationFile Class
Save Overload
GSF.Configuration Namespace


ConfigurationFile.SaveAs Method

Grid Solutions Framework ConfigurationFileSaveAs Method
Writes the configuration settings contained within this ConfigurationFile object to the specified configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveAs(
    string fileName
)
Public Sub SaveAs (
    fileName As String
)
member SaveAs :
        fileName : string -> unit

function SaveAs(fileName);
public:
void SaveAs(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The path and file name to save the configuration file to.
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.SetCryptoKey Method

Grid Solutions Framework ConfigurationFileSetCryptoKey Method
Sets the key to be used for encrypting and decrypting values of Settings.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCryptoKey(
    string cryptoKey
)
Public Sub SetCryptoKey (
    cryptoKey As String
)
member SetCryptoKey :
        cryptoKey : string -> unit

function SetCryptoKey(cryptoKey);
public:
void SetCryptoKey(
    String^ cryptoKey
)

Parameters

cryptoKey
Type: SystemString
New crypto key.
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile Properties

Grid Solutions Framework ConfigurationFile Properties

The ConfigurationFile type exposes the following members.

Properties
 | Name | Description
Public property | Configuration | Get the underlying Configuration that can be accessed using this ConfigurationFile object.
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String.
 | Current | Gets the ConfigurationFile object that represents the config file of the currently executing Windows or Web application.
Public property | Settings | Gets the CategorizedSettingsSection object representing settings under the "categorizedSettings" section of the config file.
Top
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Configuration Property

Grid Solutions Framework ConfigurationFileConfiguration Property
Get the underlying Configuration that can be accessed using this ConfigurationFile object.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Configuration Configuration { get; }
Public ReadOnly Property Configuration As Configuration
    Get
member Configuration : Configuration with get

function get_Configuration();

public:
property Configuration^ Configuration {
    Configuration^ get ();
}

Property Value

Type: Configuration
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Culture Property

Grid Solutions Framework ConfigurationFileCulture Property
Gets or sets the CultureInfo to use for the conversion of setting values to and from String.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CultureInfo Culture { get; set; }
Public Property Culture As CultureInfo
    Get
    Set
member Culture : CultureInfo with get, set

function get_Culture();
function set_Culture(value);
public:
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

Property Value

Type: CultureInfo
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Current Property

Grid Solutions Framework ConfigurationFileCurrent Property
Gets the ConfigurationFile object that represents the config file of the currently executing Windows or Web application.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ConfigurationFile Current { get; }
Public Shared ReadOnly Property Current As ConfigurationFile
    Get
static member Current : ConfigurationFile with get

GSF.Configuration.ConfigurationFile.get_Current = function();

public:
static property ConfigurationFile^ Current {
    ConfigurationFile^ get ();
}

Property Value

Type: ConfigurationFile
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConfigurationFile.Settings Property

Grid Solutions Framework ConfigurationFileSettings Property
Gets the CategorizedSettingsSection object representing settings under the "categorizedSettings" section of the config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CategorizedSettingsSection Settings { get; }
Public ReadOnly Property Settings As CategorizedSettingsSection
    Get
member Settings : CategorizedSettingsSection with get

function get_Settings();

public:
property CategorizedSettingsSection^ Settings {
    CategorizedSettingsSection^ get ();
}

Property Value

Type: CategorizedSettingsSection
See Also

Reference

ConfigurationFile Class
GSF.Configuration Namespace


ConnectionStringParser Class

Grid Solutions Framework ConnectionStringParser Class
Parses connection strings based on a settings object whose properties are annotated with the SerializeSettingAttribute.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationConnectionStringParser
GSF.ConfigurationConnectionStringParserTParameterAttribute

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConnectionStringParser
Public Class ConnectionStringParser
type ConnectionStringParser =  class end
GSF.Configuration.ConnectionStringParser = function();

Type.createClass(
    'GSF.Configuration.ConnectionStringParser');
public ref class ConnectionStringParser

The ConnectionStringParser type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStringParser | Creates a new instance of the ConnectionStringParser class.
Top
Methods
 | Name | Description
Public method | ComposeConnectionString | Serializes the given settingsObject into a connection string.
Protected method | ConvertToPropertyType | Converts the given string value to the type of the given property.
Protected method | ConvertToString | Converts the given object to a string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConnectionStringProperties | Gets the set of properties which are part of the connection string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseConnectionString | Deserializes the connection string parameters into the given settingsObject.
 | ToConnectionString | Converts XML to a connection string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToXML | Converts a connection string to XML.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultEndValueDelimiter | Default value for the EndValueDelimiter property.
DefaultExplicitlySpecifyDefaults | Default value for the ExplicitlySpecifyDefaults property.
DefaultKeyValueDelimiter | Default value for the KeyValueDelimiter property.
DefaultParameterDelimiter | Default value for the ParameterDelimiter property.
DefaultSerializeUnspecifiedProperties | Default value for the SerializeUnspecifiedProperties property.
DefaultStartValueDelimiter | Default value for the StartValueDelimiter property.
Top
Properties
 | Name | Description
Public property | EndValueDelimiter | Gets or sets the end value delimiter used to denote the end of a value in the cases where the value contains one of the delimiters defined for the connection string.
Public property | ExplicitlySpecifyDefaults | Gets or sets the flag that determines whether to explicitly specify parameter values that match their defaults when serializing settings to a connection string.
Public property | KeyValueDelimiter | Gets or sets the key-value delimiter used to separate keys from values in the connection string.
Public property | ParameterDelimiter | Gets or sets the parameter delimiter used to separate key-value pairs in the connection string.
Public property | SerializeUnspecifiedProperties | Gets or sets the flag that determines whether to include properties which are not annotated with the SerializeSettingAttribute in the connection string.
Public property | StartValueDelimiter | Gets or sets the start value delimiter used to denote the start of a value in the cases where the value contains one of the delimiters defined for the connection string.
Top
See Also

Reference

GSF.Configuration Namespace


ConnectionStringParser Constructor

Grid Solutions Framework ConnectionStringParser Constructor
Creates a new instance of the ConnectionStringParser class.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionStringParser()
Public Sub New
new : unit -> ConnectionStringParser
GSF.Configuration.ConnectionStringParser = function();
public:
ConnectionStringParser()
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser Fields

Grid Solutions Framework ConnectionStringParser Fields

The ConnectionStringParser type exposes the following members.

Fields
Name | Description
DefaultEndValueDelimiter | Default value for the EndValueDelimiter property.
DefaultExplicitlySpecifyDefaults | Default value for the ExplicitlySpecifyDefaults property.
DefaultKeyValueDelimiter | Default value for the KeyValueDelimiter property.
DefaultParameterDelimiter | Default value for the ParameterDelimiter property.
DefaultSerializeUnspecifiedProperties | Default value for the SerializeUnspecifiedProperties property.
DefaultStartValueDelimiter | Default value for the StartValueDelimiter property.
Top
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.DefaultEndValueDelimiter Field

Grid Solutions Framework ConnectionStringParserDefaultEndValueDelimiter Field
Default value for the EndValueDelimiter property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const char DefaultEndValueDelimiter
Public Const DefaultEndValueDelimiter As Char
static val mutable DefaultEndValueDelimiter: char
var GSF.Configuration.ConnectionStringParser.DefaultEndValueDelimiter
public:
literal wchar_t DefaultEndValueDelimiter

Field Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.DefaultExplicitlySpecifyDefaults Field

Grid Solutions Framework ConnectionStringParserDefaultExplicitlySpecifyDefaults Field
Default value for the ExplicitlySpecifyDefaults property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultExplicitlySpecifyDefaults
Public Const DefaultExplicitlySpecifyDefaults As Boolean
static val mutable DefaultExplicitlySpecifyDefaults: bool
var GSF.Configuration.ConnectionStringParser.DefaultExplicitlySpecifyDefaults
public:
literal bool DefaultExplicitlySpecifyDefaults

Field Value

Type: Boolean
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.DefaultKeyValueDelimiter Field

Grid Solutions Framework ConnectionStringParserDefaultKeyValueDelimiter Field
Default value for the KeyValueDelimiter property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const char DefaultKeyValueDelimiter
Public Const DefaultKeyValueDelimiter As Char
static val mutable DefaultKeyValueDelimiter: char
var GSF.Configuration.ConnectionStringParser.DefaultKeyValueDelimiter
public:
literal wchar_t DefaultKeyValueDelimiter

Field Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.DefaultParameterDelimiter Field

Grid Solutions Framework ConnectionStringParserDefaultParameterDelimiter Field
Default value for the ParameterDelimiter property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const char DefaultParameterDelimiter
Public Const DefaultParameterDelimiter As Char
static val mutable DefaultParameterDelimiter: char
var GSF.Configuration.ConnectionStringParser.DefaultParameterDelimiter
public:
literal wchar_t DefaultParameterDelimiter

Field Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.DefaultSerializeUnspecifiedProperties Field

Grid Solutions Framework ConnectionStringParserDefaultSerializeUnspecifiedProperties Field
Default value for the SerializeUnspecifiedProperties property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultSerializeUnspecifiedProperties
Public Const DefaultSerializeUnspecifiedProperties As Boolean
static val mutable DefaultSerializeUnspecifiedProperties: bool
var GSF.Configuration.ConnectionStringParser.DefaultSerializeUnspecifiedProperties
public:
literal bool DefaultSerializeUnspecifiedProperties

Field Value

Type: Boolean
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.DefaultStartValueDelimiter Field

Grid Solutions Framework ConnectionStringParserDefaultStartValueDelimiter Field
Default value for the StartValueDelimiter property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const char DefaultStartValueDelimiter
Public Const DefaultStartValueDelimiter As Char
static val mutable DefaultStartValueDelimiter: char
var GSF.Configuration.ConnectionStringParser.DefaultStartValueDelimiter
public:
literal wchar_t DefaultStartValueDelimiter

Field Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser Methods

Grid Solutions Framework ConnectionStringParser Methods

The ConnectionStringParser type exposes the following members.

Methods
 | Name | Description
Public method | ComposeConnectionString | Serializes the given settingsObject into a connection string.
Protected method | ConvertToPropertyType | Converts the given string value to the type of the given property.
Protected method | ConvertToString | Converts the given object to a string.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConnectionStringProperties | Gets the set of properties which are part of the connection string.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseConnectionString | Deserializes the connection string parameters into the given settingsObject.
 | ToConnectionString | Converts XML to a connection string.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ToXML | Converts a connection string to XML.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ComposeConnectionString Method

Grid Solutions Framework ConnectionStringParserComposeConnectionString Method
Serializes the given settingsObject into a connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ComposeConnectionString(
    Object settingsObject
)
Public Overridable Function ComposeConnectionString (
    settingsObject As Object
) As String
abstract ComposeConnectionString :
        settingsObject : Object -> string
override ComposeConnectionString :
        settingsObject : Object -> string
function ComposeConnectionString(settingsObject);
public:
virtual String^ ComposeConnectionString(
    Object^ settingsObject
)

Parameters

settingsObject
Type: SystemObject
The object whose properties are to be serialized.

Return Value

Type: String
A connection string containing the serialized properties.
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ConvertToPropertyType Method

Grid Solutions Framework ConnectionStringParserConvertToPropertyType Method
Converts the given string value to the type of the given property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual Object ConvertToPropertyType(
    string value,
    ConnectionStringParserConnectionStringProperty property
)
Protected Overridable Function ConvertToPropertyType (
    value As String,
    property As ConnectionStringParserConnectionStringProperty
) As Object
abstract ConvertToPropertyType :
        value : string *
        property : ConnectionStringParserConnectionStringProperty -> Object
override ConvertToPropertyType :
        value : string *
        property : ConnectionStringParserConnectionStringProperty -> Object
function ConvertToPropertyType(value, property);
protected:
virtual Object^ ConvertToPropertyType(
    String^ value,
    ConnectionStringParserConnectionStringProperty^ property
)

Parameters

value
Type: SystemString
The string value to be converted.
property
Type: GSF.ConfigurationConnectionStringParserConnectionStringProperty
The property used to determine what type to convert to.

Return Value

Type: Object
The given string converted to the type of the given property.
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ConvertToString Method

Grid Solutions Framework ConnectionStringParserConvertToString Method
Converts the given object to a string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string ConvertToString(
    Object obj,
    ConnectionStringParserConnectionStringProperty property
)
Protected Overridable Function ConvertToString (
    obj As Object,
    property As ConnectionStringParserConnectionStringProperty
) As String
abstract ConvertToString :
        obj : Object *
        property : ConnectionStringParserConnectionStringProperty -> string
override ConvertToString :
        obj : Object *
        property : ConnectionStringParserConnectionStringProperty -> string
function ConvertToString(obj, property);
protected:
virtual String^ ConvertToString(
    Object^ obj,
    ConnectionStringParserConnectionStringProperty^ property
)

Parameters

obj
Type: SystemObject
The object to be converted.
property
Type: GSF.ConfigurationConnectionStringParserConnectionStringProperty
The property which defines the type of the object.

Return Value

Type: String
The object converted to a string.
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.GetConnectionStringProperties Method

Grid Solutions Framework ConnectionStringParserGetConnectionStringProperties Method
Gets the set of properties which are part of the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual ConnectionStringParserConnectionStringProperty[] GetConnectionStringProperties(
    Type settingsObjectType
)
Protected Overridable Function GetConnectionStringProperties (
    settingsObjectType As Type
) As ConnectionStringParserConnectionStringProperty()
abstract GetConnectionStringProperties :
        settingsObjectType : Type -> ConnectionStringParserConnectionStringProperty[]
override GetConnectionStringProperties :
        settingsObjectType : Type -> ConnectionStringParserConnectionStringProperty[]
function GetConnectionStringProperties(settingsObjectType);
protected:
virtual array<ConnectionStringParserConnectionStringProperty^>^ GetConnectionStringProperties(
    Type^ settingsObjectType
)

Parameters

settingsObjectType
Type: SystemType
The type of the settings object used to look up properties via reflection.

Return Value

Type: ConnectionStringParserConnectionStringProperty
The set of properties which are part of the connection string.
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ParseConnectionString Method

Grid Solutions Framework ConnectionStringParserParseConnectionString Method
Deserializes the connection string parameters into the given settingsObject.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void ParseConnectionString(
    string connectionString,
    Object settingsObject
)
Public Overridable Sub ParseConnectionString (
    connectionString As String,
    settingsObject As Object
)
abstract ParseConnectionString :
        connectionString : string *
        settingsObject : Object -> unit
override ParseConnectionString :
        connectionString : string *
        settingsObject : Object -> unit
function ParseConnectionString(connectionString, settingsObject);
public:
virtual void ParseConnectionString(
    String^ connectionString,
    Object^ settingsObject
)

Parameters

connectionString
Type: SystemString
The connection string to be parsed.
settingsObject
Type: SystemObject
The object whose properties are to be populated with values from the connection string.
Exceptions
Exception | Condition
ArgumentNullException | settingsObject is null.
ArgumentException | A required connection string parameter cannot be found in the connection string.
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ToConnectionString Method

Grid Solutions Framework ConnectionStringParserToConnectionString Method
Converts XML to a connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToConnectionString(
    XElement element
)
Public Shared Function ToConnectionString (
    element As XElement
) As String
static member ToConnectionString :
        element : XElement -> string

GSF.Configuration.ConnectionStringParser.ToConnectionString = function(element);
public:
static String^ ToConnectionString(
    XElement^ element
)

Parameters

element
Type: System.Xml.LinqXElement
The root element of the XML to be converted to a connection string.

Return Value

Type: String
A connection string converted from XML.
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ToXML Method

Grid Solutions Framework ConnectionStringParserToXML Method
Converts a connection string to XML.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static XElement ToXML(
    string connectionString
)
Public Shared Function ToXML (
    connectionString As String
) As XElement
static member ToXML :
        connectionString : string -> XElement

GSF.Configuration.ConnectionStringParser.ToXML = function(connectionString);
public:
static XElement^ ToXML(
    String^ connectionString
)

Parameters

connectionString
Type: SystemString
The connection string to be converted to XML.

Return Value

Type: XElement
The XML root element converted from the connection string.
Exceptions
Exception | Condition
InvalidOperationException | The connection string does not define exactly one root element.
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser Properties

Grid Solutions Framework ConnectionStringParser Properties

The ConnectionStringParser type exposes the following members.

Properties
 | Name | Description
Public property | EndValueDelimiter | Gets or sets the end value delimiter used to denote the end of a value in the cases where the value contains one of the delimiters defined for the connection string.
Public property | ExplicitlySpecifyDefaults | Gets or sets the flag that determines whether to explicitly specify parameter values that match their defaults when serializing settings to a connection string.
Public property | KeyValueDelimiter | Gets or sets the key-value delimiter used to separate keys from values in the connection string.
Public property | ParameterDelimiter | Gets or sets the parameter delimiter used to separate key-value pairs in the connection string.
Public property | SerializeUnspecifiedProperties | Gets or sets the flag that determines whether to include properties which are not annotated with the SerializeSettingAttribute in the connection string.
Public property | StartValueDelimiter | Gets or sets the start value delimiter used to denote the start of a value in the cases where the value contains one of the delimiters defined for the connection string.
Top
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.EndValueDelimiter Property

Grid Solutions Framework ConnectionStringParserEndValueDelimiter Property
Gets or sets the end value delimiter used to denote the end of a value in the cases where the value contains one of the delimiters defined for the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char EndValueDelimiter { get; set; }
Public Property EndValueDelimiter As Char
    Get
    Set
member EndValueDelimiter : char with get, set

function get_EndValueDelimiter();
function set_EndValueDelimiter(value);
public:
property wchar_t EndValueDelimiter {
    wchar_t get ();
    void set (wchar_t value);
}

Property Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ExplicitlySpecifyDefaults Property

Grid Solutions Framework ConnectionStringParserExplicitlySpecifyDefaults Property
Gets or sets the flag that determines whether to explicitly specify parameter values that match their defaults when serializing settings to a connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ExplicitlySpecifyDefaults { get; set; }
Public Property ExplicitlySpecifyDefaults As Boolean
    Get
    Set
member ExplicitlySpecifyDefaults : bool with get, set

function get_ExplicitlySpecifyDefaults();
function set_ExplicitlySpecifyDefaults(value);
public:
property bool ExplicitlySpecifyDefaults {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.KeyValueDelimiter Property

Grid Solutions Framework ConnectionStringParserKeyValueDelimiter Property
Gets or sets the key-value delimiter used to separate keys from values in the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char KeyValueDelimiter { get; set; }
Public Property KeyValueDelimiter As Char
    Get
    Set
member KeyValueDelimiter : char with get, set

function get_KeyValueDelimiter();
function set_KeyValueDelimiter(value);
public:
property wchar_t KeyValueDelimiter {
    wchar_t get ();
    void set (wchar_t value);
}

Property Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ParameterDelimiter Property

Grid Solutions Framework ConnectionStringParserParameterDelimiter Property
Gets or sets the parameter delimiter used to separate key-value pairs in the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char ParameterDelimiter { get; set; }
Public Property ParameterDelimiter As Char
    Get
    Set
member ParameterDelimiter : char with get, set

function get_ParameterDelimiter();
function set_ParameterDelimiter(value);
public:
property wchar_t ParameterDelimiter {
    wchar_t get ();
    void set (wchar_t value);
}

Property Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.SerializeUnspecifiedProperties Property

Grid Solutions Framework ConnectionStringParserSerializeUnspecifiedProperties Property
Gets or sets the flag that determines whether to include properties which are not annotated with the SerializeSettingAttribute in the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SerializeUnspecifiedProperties { get; set; }
Public Property SerializeUnspecifiedProperties As Boolean
    Get
    Set
member SerializeUnspecifiedProperties : bool with get, set

function get_SerializeUnspecifiedProperties();
function set_SerializeUnspecifiedProperties(value);
public:
property bool SerializeUnspecifiedProperties {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.StartValueDelimiter Property

Grid Solutions Framework ConnectionStringParserStartValueDelimiter Property
Gets or sets the start value delimiter used to denote the start of a value in the cases where the value contains one of the delimiters defined for the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char StartValueDelimiter { get; set; }
Public Property StartValueDelimiter As Char
    Get
    Set
member StartValueDelimiter : char with get, set

function get_StartValueDelimiter();
function set_StartValueDelimiter(value);
public:
property wchar_t StartValueDelimiter {
    wchar_t get ();
    void set (wchar_t value);
}

Property Value

Type: Char
See Also

Reference

ConnectionStringParser Class
GSF.Configuration Namespace


ConnectionStringParser.ConnectionStringProperty Class

Grid Solutions Framework ConnectionStringParserConnectionStringProperty Class
Stores reflected information from a PropertyInfo object used to parse connection strings.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationConnectionStringParserConnectionStringProperty

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected class ConnectionStringProperty
Protected Class ConnectionStringProperty
type ConnectionStringProperty =  class end
GSF.Configuration.ConnectionStringProperty = function();

Type.createClass(
    'GSF.Configuration.ConnectionStringProperty');
protected ref class ConnectionStringProperty

The ConnectionStringParserConnectionStringProperty type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStringParserConnectionStringProperty | Creates a new instance of the ConnectionStringParserConnectionStringProperty class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Converter | The type converter used to convert the value of this property to and from a string.
Public field | DefaultValue | The default value of the property if its value is not explicitly specified in the connection string.
Public field | Names | The name of the property as it appears in the connection string.
Public field | PropertyInfo | The PropertyInfo object.
Public field | Required | Indicates whether or not the property is required to be explicitly defined in the connection string.
Top
See Also

Reference

GSF.Configuration Namespace


ConnectionStringParser.ConnectionStringProperty Constructor

Grid Solutions Framework ConnectionStringParserConnectionStringProperty Constructor
Creates a new instance of the ConnectionStringParserConnectionStringProperty class.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionStringProperty(
    PropertyInfo propertyInfo
)
Public Sub New (
    propertyInfo As PropertyInfo
)
new :
        propertyInfo : PropertyInfo -> ConnectionStringProperty
GSF.Configuration.ConnectionStringProperty = function(propertyInfo);
public:
ConnectionStringProperty(
    PropertyInfo^ propertyInfo
)

Parameters

propertyInfo
Type: System.ReflectionPropertyInfo
The PropertyInfo object.
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringProperty Fields

Grid Solutions Framework ConnectionStringProperty Fields

The ConnectionStringParserConnectionStringProperty type exposes the following members.

Fields
 | Name | Description
Public field | Converter | The type converter used to convert the value of this property to and from a string.
Public field | DefaultValue | The default value of the property if its value is not explicitly specified in the connection string.
Public field | Names | The name of the property as it appears in the connection string.
Public field | PropertyInfo | The PropertyInfo object.
Public field | Required | Indicates whether or not the property is required to be explicitly defined in the connection string.
Top
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringParser.ConnectionStringProperty.Converter Field

Grid Solutions Framework ConnectionStringParserConnectionStringPropertyConverter Field
The type converter used to convert the value of this property to and from a string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeConverter Converter
Public Converter As TypeConverter
val mutable Converter: TypeConverter
var Converter
public:
TypeConverter^ Converter

Field Value

Type: TypeConverter
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringParser.ConnectionStringProperty.DefaultValue Field

Grid Solutions Framework ConnectionStringParserConnectionStringPropertyDefaultValue Field
The default value of the property if its value is not explicitly specified in the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object DefaultValue
Public DefaultValue As Object
val mutable DefaultValue: Object
var DefaultValue
public:
Object^ DefaultValue

Field Value

Type: Object
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringParser.ConnectionStringProperty.Names Field

Grid Solutions Framework ConnectionStringParserConnectionStringPropertyNames Field
The name of the property as it appears in the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] Names
Public Names As String()
val mutable Names: string[]
var Names
public:
array<String^>^ Names

Field Value

Type: String
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringParser.ConnectionStringProperty.PropertyInfo Field

Grid Solutions Framework ConnectionStringParserConnectionStringPropertyPropertyInfo Field
The PropertyInfo object.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PropertyInfo PropertyInfo
Public PropertyInfo As PropertyInfo
val mutable PropertyInfo: PropertyInfo
var PropertyInfo
public:
PropertyInfo^ PropertyInfo

Field Value

Type: PropertyInfo
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringParser.ConnectionStringProperty.Required Field

Grid Solutions Framework ConnectionStringParserConnectionStringPropertyRequired Field
Indicates whether or not the property is required to be explicitly defined in the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Required
Public Required As Boolean
val mutable Required: bool
var Required
public:
bool Required

Field Value

Type: Boolean
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringProperty Methods

Grid Solutions Framework ConnectionStringProperty Methods

The ConnectionStringParserConnectionStringProperty type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionStringParserConnectionStringProperty Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute) Class

Grid Solutions Framework ConnectionStringParserTParameterAttribute Class
Parses connection strings based on a settings object whose properties are annotated with TParameterAttribute.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationConnectionStringParser
GSF.ConfigurationConnectionStringParserTParameterAttribute
GSF.ConfigurationConnectionStringParserTParameterAttribute, TNestedSettingsAttribute

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConnectionStringParser<TParameterAttribute> : ConnectionStringParser
where TParameterAttribute : Attribute

Public Class ConnectionStringParser(Of TParameterAttribute As Attribute)
    Inherits ConnectionStringParser
type ConnectionStringParser<'TParameterAttribute when 'TParameterAttribute : Attribute> =
    class
        inherit ConnectionStringParser
    end
JavaScript does not support generic types or methods.
generic<typename TParameterAttribute>
where TParameterAttribute : Attribute
public ref class ConnectionStringParser : public ConnectionStringParser

Type Parameters

TParameterAttribute
The type of the attribute to search for when determining whether to serialize a property to the connection string.

The ConnectionStringParserTParameterAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStringParserTParameterAttribute | Initializes a new instance of the ConnectionStringParserTParameterAttribute class
Top
Methods
 | Name | Description
Public method | ComposeConnectionString | Serializes the given settingsObject into a connection string. (Inherited from ConnectionStringParser.)
Protected method | ConvertToPropertyType | Converts the given string value to the type of the given property. (Inherited from ConnectionStringParser.)
Protected method | ConvertToString | Converts the given object to a string. (Inherited from ConnectionStringParser.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConnectionStringProperties | Gets the set of properties which are part of the connection string. (Overrides ConnectionStringParserGetConnectionStringProperties(Type).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseConnectionString | Deserializes the connection string parameters into the given settingsObject. (Inherited from ConnectionStringParser.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | EndValueDelimiter | Gets or sets the end value delimiter used to denote the end of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Public property | ExplicitlySpecifyDefaults | Gets or sets the flag that determines whether to explicitly specify parameter values that match their defaults when serializing settings to a connection string. (Inherited from ConnectionStringParser.)
Public property | KeyValueDelimiter | Gets or sets the key-value delimiter used to separate keys from values in the connection string. (Inherited from ConnectionStringParser.)
Public property | ParameterDelimiter | Gets or sets the parameter delimiter used to separate key-value pairs in the connection string. (Inherited from ConnectionStringParser.)
Public property | SerializeUnspecifiedProperties | Redefined to throw an exception. This property has no meaning when property serialization is determined by the existence of the typed parameter.
Public property | StartValueDelimiter | Gets or sets the start value delimiter used to denote the start of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Top
See Also

Reference

GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute) Constructor

Grid Solutions Framework ConnectionStringParserTParameterAttribute Constructor
Initializes a new instance of the ConnectionStringParserTParameterAttribute class

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionStringParser()
Public Sub New
new : unit -> ConnectionStringParser
GSF.Configuration.ConnectionStringParser = function();
public:
ConnectionStringParser()
See Also

Reference

ConnectionStringParserTParameterAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute) Methods

Grid Solutions Framework ConnectionStringParserTParameterAttribute Methods

The ConnectionStringParserTParameterAttribute generic type exposes the following members.

Methods
 | Name | Description
Public method | ComposeConnectionString | Serializes the given settingsObject into a connection string. (Inherited from ConnectionStringParser.)
Protected method | ConvertToPropertyType | Converts the given string value to the type of the given property. (Inherited from ConnectionStringParser.)
Protected method | ConvertToString | Converts the given object to a string. (Inherited from ConnectionStringParser.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConnectionStringProperties | Gets the set of properties which are part of the connection string. (Overrides ConnectionStringParserGetConnectionStringProperties(Type).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseConnectionString | Deserializes the connection string parameters into the given settingsObject. (Inherited from ConnectionStringParser.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionStringParserTParameterAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute).GetConnectionStringProperties Method

Grid Solutions Framework ConnectionStringParserTParameterAttributeGetConnectionStringProperties Method
Gets the set of properties which are part of the connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ConnectionStringParserConnectionStringProperty[] GetConnectionStringProperties(
    Type settingsObjectType
)
Protected Overrides Function GetConnectionStringProperties (
    settingsObjectType As Type
) As ConnectionStringParserConnectionStringProperty()
abstract GetConnectionStringProperties :
        settingsObjectType : Type -> ConnectionStringParserConnectionStringProperty[]
override GetConnectionStringProperties :
        settingsObjectType : Type -> ConnectionStringParserConnectionStringProperty[]
function GetConnectionStringProperties(settingsObjectType);
protected:
virtual array<ConnectionStringParserConnectionStringProperty^>^ GetConnectionStringProperties(
    Type^ settingsObjectType
) override

Parameters

settingsObjectType
Type: SystemType
The type of the settings object used to look up properties via reflection.

Return Value

Type: ConnectionStringParserConnectionStringProperty
The set of properties which are part of the connection string.
See Also

Reference

ConnectionStringParserTParameterAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute) Properties

Grid Solutions Framework ConnectionStringParserTParameterAttribute Properties

The ConnectionStringParserTParameterAttribute generic type exposes the following members.

Properties
 | Name | Description
Public property | EndValueDelimiter | Gets or sets the end value delimiter used to denote the end of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Public property | ExplicitlySpecifyDefaults | Gets or sets the flag that determines whether to explicitly specify parameter values that match their defaults when serializing settings to a connection string. (Inherited from ConnectionStringParser.)
Public property | KeyValueDelimiter | Gets or sets the key-value delimiter used to separate keys from values in the connection string. (Inherited from ConnectionStringParser.)
Public property | ParameterDelimiter | Gets or sets the parameter delimiter used to separate key-value pairs in the connection string. (Inherited from ConnectionStringParser.)
Public property | SerializeUnspecifiedProperties | Redefined to throw an exception. This property has no meaning when property serialization is determined by the existence of the typed parameter.
Public property | StartValueDelimiter | Gets or sets the start value delimiter used to denote the start of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Top
See Also

Reference

ConnectionStringParserTParameterAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute).SerializeUnspecifiedProperties Property

Grid Solutions Framework ConnectionStringParserTParameterAttributeSerializeUnspecifiedProperties Property
Redefined to throw an exception. This property has no meaning when property serialization is determined by the existence of the typed parameter.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool SerializeUnspecifiedProperties { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Property SerializeUnspecifiedProperties As Boolean
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
member SerializeUnspecifiedProperties : bool with get, set

function get_SerializeUnspecifiedProperties();
function set_SerializeUnspecifiedProperties(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
property bool SerializeUnspecifiedProperties {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionStringParserTParameterAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute, TNestedSettingsAttribute) Class

Grid Solutions Framework ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Class
Parses connection strings based on a settings object whose properties are annotated with TParameterAttribute and TNestedSettingsAttribute.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationConnectionStringParser
GSF.ConfigurationConnectionStringParser TParameterAttribute
GSF.ConfigurationConnectionStringParserTParameterAttribute, TNestedSettingsAttribute

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConnectionStringParser<TParameterAttribute, TNestedSettingsAttribute> : ConnectionStringParser<TParameterAttribute>
where TParameterAttribute : Attribute
where TNestedSettingsAttribute : Attribute

Public Class ConnectionStringParser(Of TParameterAttribute As Attribute, TNestedSettingsAttribute As Attribute)
    Inherits ConnectionStringParser(Of TParameterAttribute)
type ConnectionStringParser<'TParameterAttribute, 'TNestedSettingsAttribute when 'TParameterAttribute : Attribute when 'TNestedSettingsAttribute : Attribute> =
    class
        inherit ConnectionStringParser<'TParameterAttribute>
    end
JavaScript does not support generic types or methods.
generic<typename TParameterAttribute, typename TNestedSettingsAttribute>
where TParameterAttribute : Attribute
where TNestedSettingsAttribute : Attribute
public ref class ConnectionStringParser : public ConnectionStringParser<TParameterAttribute>

Type Parameters

TParameterAttribute
The type of the attribute to search for when determining whether to serialize a property to the connection string.
TNestedSettingsAttribute
The type of the attribute to search for when determining which parameters are to be parsed recursively as connection strings.

The ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute | Initializes a new instance of the ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute class
Top
Methods
 | Name | Description
Public method | ComposeConnectionString | Serializes the given settingsObject into a connection string. (Overrides ConnectionStringParserComposeConnectionString(Object).)
Protected method | ConvertToPropertyType | Converts the given string value to the type of the given property. (Inherited from ConnectionStringParser.)
Protected method | ConvertToString | Converts the given object to a string. (Inherited from ConnectionStringParser.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConnectionStringProperties | Gets the set of properties which are part of the connection string. (Inherited from ConnectionStringParserTParameterAttribute.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseConnectionString | Deserializes the connection string parameters into the given settingsObject. (Overrides ConnectionStringParserParseConnectionString(String, Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | EndValueDelimiter | Gets or sets the end value delimiter used to denote the end of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Public property | ExplicitlySpecifyDefaults | Gets or sets the flag that determines whether to explicitly specify parameter values that match their defaults when serializing settings to a connection string. (Inherited from ConnectionStringParser.)
Public property | KeyValueDelimiter | Gets or sets the key-value delimiter used to separate keys from values in the connection string. (Inherited from ConnectionStringParser.)
Public property | ParameterDelimiter | Gets or sets the parameter delimiter used to separate key-value pairs in the connection string. (Inherited from ConnectionStringParser.)
Public property | SerializeUnspecifiedProperties | Redefined to throw an exception. This property has no meaning when property serialization is determined by the existence of the typed parameter. (Inherited from ConnectionStringParserTParameterAttribute.)
Public property | StartValueDelimiter | Gets or sets the start value delimiter used to denote the start of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Top
See Also

Reference

GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute, TNestedSettingsAttribute) Constructor

Grid Solutions Framework ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Constructor
Initializes a new instance of the ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute class

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionStringParser()
Public Sub New
new : unit -> ConnectionStringParser
GSF.Configuration.ConnectionStringParser = function();
public:
ConnectionStringParser()
See Also

Reference

ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute, TNestedSettingsAttribute) Methods

Grid Solutions Framework ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Methods

The ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute generic type exposes the following members.

Methods
 | Name | Description
Public method | ComposeConnectionString | Serializes the given settingsObject into a connection string. (Overrides ConnectionStringParserComposeConnectionString(Object).)
Protected method | ConvertToPropertyType | Converts the given string value to the type of the given property. (Inherited from ConnectionStringParser.)
Protected method | ConvertToString | Converts the given object to a string. (Inherited from ConnectionStringParser.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Protected method | GetConnectionStringProperties | Gets the set of properties which are part of the connection string. (Inherited from ConnectionStringParserTParameterAttribute.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseConnectionString | Deserializes the connection string parameters into the given settingsObject. (Overrides ConnectionStringParserParseConnectionString(String, Object).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute, TNestedSettingsAttribute).ComposeConnectionString Method

Grid Solutions Framework ConnectionStringParserTParameterAttribute, TNestedSettingsAttributeComposeConnectionString Method
Serializes the given settingsObject into a connection string.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ComposeConnectionString(
    Object settingsObject
)
Public Overrides Function ComposeConnectionString (
    settingsObject As Object
) As String
abstract ComposeConnectionString :
        settingsObject : Object -> string
override ComposeConnectionString :
        settingsObject : Object -> string
function ComposeConnectionString(settingsObject);
public:
virtual String^ ComposeConnectionString(
    Object^ settingsObject
) override

Parameters

settingsObject
Type: SystemObject
The object whose properties are to be serialized.

Return Value

Type: String
A connection string containing the serialized properties.
See Also

Reference

ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute, TNestedSettingsAttribute).ParseConnectionString Method

Grid Solutions Framework ConnectionStringParserTParameterAttribute, TNestedSettingsAttributeParseConnectionString Method
Deserializes the connection string parameters into the given settingsObject.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void ParseConnectionString(
    string connectionString,
    Object settingsObject
)
Public Overrides Sub ParseConnectionString (
    connectionString As String,
    settingsObject As Object
)
abstract ParseConnectionString :
        connectionString : string *
        settingsObject : Object -> unit
override ParseConnectionString :
        connectionString : string *
        settingsObject : Object -> unit
function ParseConnectionString(connectionString, settingsObject);
public:
virtual void ParseConnectionString(
    String^ connectionString,
    Object^ settingsObject
) override

Parameters

connectionString
Type: SystemString
The connection string to be parsed.
settingsObject
Type: SystemObject
The object whose properties are to be populated with values from the connection string.
Exceptions
Exception | Condition
ArgumentNullException | settingsObject is null.
ArgumentException | A required connection string parameter cannot be found in the connection string.
See Also

Reference

ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Class
GSF.Configuration Namespace


ConnectionStringParser(TParameterAttribute, TNestedSettingsAttribute) Properties

Grid Solutions Framework ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Properties

The ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute generic type exposes the following members.

Properties
 | Name | Description
Public property | EndValueDelimiter | Gets or sets the end value delimiter used to denote the end of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Public property | ExplicitlySpecifyDefaults | Gets or sets the flag that determines whether to explicitly specify parameter values that match their defaults when serializing settings to a connection string. (Inherited from ConnectionStringParser.)
Public property | KeyValueDelimiter | Gets or sets the key-value delimiter used to separate keys from values in the connection string. (Inherited from ConnectionStringParser.)
Public property | ParameterDelimiter | Gets or sets the parameter delimiter used to separate key-value pairs in the connection string. (Inherited from ConnectionStringParser.)
Public property | SerializeUnspecifiedProperties | Redefined to throw an exception. This property has no meaning when property serialization is determined by the existence of the typed parameter. (Inherited from ConnectionStringParserTParameterAttribute.)
Public property | StartValueDelimiter | Gets or sets the start value delimiter used to denote the start of a value in the cases where the value contains one of the delimiters defined for the connection string. (Inherited from ConnectionStringParser.)
Top
See Also

Reference

ConnectionStringParserTParameterAttribute, TNestedSettingsAttribute Class
GSF.Configuration Namespace


EncryptSettingAttribute Class

Grid Solutions Framework EncryptSettingAttribute Class
Represents an attribute that determines if a property or field in a class derived from CategorizedSettingsBase or AppSettingsBase should be encrypted when it is serialized to the configuration file.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ConfigurationEncryptSettingAttribute

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)]
public sealed class EncryptSettingAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field)>
Public NotInheritable Class EncryptSettingAttribute
    Inherits Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)>]
type EncryptSettingAttribute =
    class
        inherit Attribute
    end
GSF.Configuration.EncryptSettingAttribute = function();

Type.createClass(
    'GSF.Configuration.EncryptSettingAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property|AttributeTargets::Field)]
public ref class EncryptSettingAttribute sealed : public Attribute

The EncryptSettingAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | EncryptSettingAttribute | Creates a new EncryptSettingAttribute; defaults to Encrypt = true.
Public method | EncryptSettingAttribute(Boolean) | Creates a new EncryptSettingAttribute with the specified encrypt value.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Encrypt | Gets or sets flag that determines if the property or field this EncryptSettingAttribute modifies should be encrypted when serialized to the configuration file.
Public property | PrivateKey | Gets or sets optional encryption key that will be used on a setting for added security.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.Configuration Namespace


EncryptSettingAttribute Constructor

Grid Solutions Framework EncryptSettingAttribute Constructor
Overload List
 | Name | Description
Public method | EncryptSettingAttribute | Creates a new EncryptSettingAttribute; defaults to Encrypt = true.
Public method | EncryptSettingAttribute(Boolean) | Creates a new EncryptSettingAttribute with the specified encrypt value.
Top
See Also

Reference

EncryptSettingAttribute Class
GSF.Configuration Namespace


EncryptSettingAttribute Constructor

Grid Solutions Framework EncryptSettingAttribute Constructor
Creates a new EncryptSettingAttribute; defaults to Encrypt = true.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EncryptSettingAttribute()
Public Sub New
new : unit -> EncryptSettingAttribute
GSF.Configuration.EncryptSettingAttribute = function();
public:
EncryptSettingAttribute()
See Also

Reference

EncryptSettingAttribute Class
EncryptSettingAttribute Overload
GSF.Configuration Namespace


EncryptSettingAttribute Constructor (Boolean)

Grid Solutions Framework EncryptSettingAttribute Constructor (Boolean)
Creates a new EncryptSettingAttribute with the specified encrypt value.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EncryptSettingAttribute(
    bool encrypt
)
Public Sub New (
    encrypt As Boolean
)
new :
        encrypt : bool -> EncryptSettingAttribute
GSF.Configuration.EncryptSettingAttribute = function(encrypt);
public:
EncryptSettingAttribute(
    bool encrypt
)

Parameters

encrypt
Type: SystemBoolean
Assigns flag that determines if the property or field this EncryptSettingAttribute modifies should be encrypted when serialized to the configuration file.
See Also

Reference

EncryptSettingAttribute Class
EncryptSettingAttribute Overload
GSF.Configuration Namespace


EncryptSettingAttribute Methods

Grid Solutions Framework EncryptSettingAttribute Methods

The EncryptSettingAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EncryptSettingAttribute Class
GSF.Configuration Namespace


EncryptSettingAttribute Properties

Grid Solutions Framework EncryptSettingAttribute Properties

The EncryptSettingAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Encrypt | Gets or sets flag that determines if the property or field this EncryptSettingAttribute modifies should be encrypted when serialized to the configuration file.
Public property | PrivateKey | Gets or sets optional encryption key that will be used on a setting for added security.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

EncryptSettingAttribute Class
GSF.Configuration Namespace


EncryptSettingAttribute.Encrypt Property

Grid Solutions Framework EncryptSettingAttributeEncrypt Property
Gets or sets flag that determines if the property or field this EncryptSettingAttribute modifies should be encrypted when serialized to the configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Encrypt { get; }
Public ReadOnly Property Encrypt As Boolean
    Get
member Encrypt : bool with get

function get_Encrypt();

public:
property bool Encrypt {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

EncryptSettingAttribute Class
GSF.Configuration Namespace


EncryptSettingAttribute.PrivateKey Property

Grid Solutions Framework EncryptSettingAttributePrivateKey Property
Gets or sets optional encryption key that will be used on a setting for added security.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string PrivateKey { get; set; }
Public Property PrivateKey As String
    Get
    Set
member PrivateKey : string with get, set

function get_PrivateKey();
function set_PrivateKey(value);
public:
property String^ PrivateKey {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This key is not the actual key used for encryption, it is used for hash lookup of the actual AES key. If this key is not specified, the property name will be used for the hash lookup.
See Also

Reference

EncryptSettingAttribute Class
GSF.Configuration Namespace


IniSettingsBase Class

Grid Solutions Framework IniSettingsBase Class
Represents the base class for application settings that are synchronized to an INI file.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationSettingsBase
GSF.ConfigurationIniSettingsBase

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class IniSettingsBase : SettingsBase
Public MustInherit Class IniSettingsBase
    Inherits SettingsBase
[<AbstractClassAttribute>]
type IniSettingsBase =
    class
        inherit SettingsBase
    end
GSF.Configuration.IniSettingsBase = function();

Type.createClass(
    'GSF.Configuration.IniSettingsBase',
    GSF.Configuration.SettingsBase);
public ref class IniSettingsBase abstract : public SettingsBase

The IniSettingsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | IniSettingsBase(String, String) | Creates a new instance of the IniSettingsBase class for the application's INI file.
Protected method | IniSettingsBase(String, String, Boolean, Boolean) | Creates a new instance of the IniSettingsBase class for the application's INI file.
Protected method | IniSettingsBase(IniFile, String, Boolean, Boolean, Boolean) | Creates a new instance of the IniSettingsBase class for the application's INI file.
Top
Methods
 | Name | Description
Protected method | CreateSetting | Create setting in INI file if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetFieldSectionName | Gets the section name to use for the specified field or property.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persists any pending changes to INI file. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from INI file. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to INI file. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Protected property | IniFile | Gets or sets reference to working INI file.
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Public property | SectionName | Gets or sets default name of section used to access settings in INI file.
Public property | UseCategoryAttributes | Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the section name.
Top
Remarks

In order to make custom types serializable for the INI file, implement a TypeConverter for the type.
See MSDN for details.

Examples
Here is an example class derived from IniSettingsBase that automatically serializes its fields and properties to the INI file.
Copy
public enum MyEnum
 {
     One,
     Two,
     Three
 }

 public class MySettings : IniSettingsBase
 {
     // Private property fields (private fields will not be serialized)
     private double m_doubleVal;

     // Public settings fields
     public bool BoolVal = true;
     public int IntVal = 1;
     public float FloatVal = 3.14F;
     public string StrVal = "This is a test...";
     public MyEnum EnumVal = MyEnum.Three;

     [SettingName("UserOptions"), EncryptSetting()]
     public string Password = "default";

     // Mark this field to not be serialized to INI file...
     [SerializeSetting(false)]
     public decimal DecimalVal;

     public MySettings()
         : base(FilePath.GetAbsolutePath("MySettings.ini"), "GeneralSettings") {}

     [Category("OtherSettings"), DefaultValue(1.159D)]
     public double DoubleVal
     {
         get
         {
             return m_doubleVal;
         }
         set
         {
             m_doubleVal = value;
         }
     }

     [SerializeSetting(false)]
     public bool DontSerializeMe { get; set; }
 }
See Also

Reference

GSF.Configuration Namespace


IniSettingsBase Constructor

Grid Solutions Framework IniSettingsBase Constructor
Overload List
 | Name | Description
Protected method | IniSettingsBase(String, String) | Creates a new instance of the IniSettingsBase class for the application's INI file.
Protected method | IniSettingsBase(String, String, Boolean, Boolean) | Creates a new instance of the IniSettingsBase class for the application's INI file.
Protected method | IniSettingsBase(IniFile, String, Boolean, Boolean, Boolean) | Creates a new instance of the IniSettingsBase class for the application's INI file.
Top
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase Constructor (String, String)

Grid Solutions Framework IniSettingsBase Constructor (String, String)
Creates a new instance of the IniSettingsBase class for the application's INI file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IniSettingsBase(
    string iniFileName,
    string sectionName
)
Protected Sub New (
    iniFileName As String,
    sectionName As String
)
new :
        iniFileName : string *
        sectionName : string -> IniSettingsBase
GSF.Configuration.IniSettingsBase = function(iniFileName, sectionName);
protected:
IniSettingsBase(
    String^ iniFileName,
    String^ sectionName
)

Parameters

iniFileName
Type: SystemString
Name of INI file to use for accessing settings.
sectionName
Type: SystemString
Name of default section to use to get and set settings from INI file.
See Also

Reference

IniSettingsBase Class
IniSettingsBase Overload
GSF.Configuration Namespace


IniSettingsBase Constructor (String, String, Boolean, Boolean)

Grid Solutions Framework IniSettingsBase Constructor (String, String, Boolean, Boolean)
Creates a new instance of the IniSettingsBase class for the application's INI file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IniSettingsBase(
    string iniFileName,
    string sectionName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute
)
Protected Sub New (
    iniFileName As String,
    sectionName As String,
    useCategoryAttributes As Boolean,
    requireSerializeSettingAttribute As Boolean
)
new :
        iniFileName : string *
        sectionName : string *
        useCategoryAttributes : bool *
        requireSerializeSettingAttribute : bool -> IniSettingsBase
GSF.Configuration.IniSettingsBase = function(iniFileName, sectionName, useCategoryAttributes, requireSerializeSettingAttribute);
protected:
IniSettingsBase(
    String^ iniFileName,
    String^ sectionName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute
)

Parameters

iniFileName
Type: SystemString
Name of INI file to use for accessing settings.
sectionName
Type: SystemString
Name of default section to use to get and set settings from INI file.
useCategoryAttributes
Type: SystemBoolean
Determines if category attributes will be used for section names.
requireSerializeSettingAttribute
Type: SystemBoolean
Assigns flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the INI file.
Remarks
If useCategoryAttributes is false, all settings will be placed in section labeled by the sectionName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the INI file in a section labeled the same as the Category value and if the attribute doesn't exist the member value will serialized into the section labeled by the sectionName value.
See Also

Reference

IniSettingsBase Class
IniSettingsBase Overload
GSF.Configuration Namespace


IniSettingsBase Constructor (IniFile, String, Boolean, Boolean, Boolean)

Grid Solutions Framework IniSettingsBase Constructor (IniFile, String, Boolean, Boolean, Boolean)
Creates a new instance of the IniSettingsBase class for the application's INI file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IniSettingsBase(
    IniFile iniFile,
    string sectionName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute,
    bool initialize
)
Protected Sub New (
    iniFile As IniFile,
    sectionName As String,
    useCategoryAttributes As Boolean,
    requireSerializeSettingAttribute As Boolean,
    initialize As Boolean
)
new :
        iniFile : IniFile *
        sectionName : string *
        useCategoryAttributes : bool *
        requireSerializeSettingAttribute : bool *
        initialize : bool -> IniSettingsBase
GSF.Configuration.IniSettingsBase = function(iniFile, sectionName, useCategoryAttributes, requireSerializeSettingAttribute, initialize);
protected:
IniSettingsBase(
    IniFile^ iniFile,
    String^ sectionName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute,
    bool initialize
)

Parameters

iniFile
Type: GSF.InteropIniFile
INI file to use for accessing settings.
sectionName
Type: SystemString
Name of default section to use to get and set settings from INI file.
useCategoryAttributes
Type: SystemBoolean
Determines if category attributes will be used for section names.
requireSerializeSettingAttribute
Type: SystemBoolean
Assigns flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the INI file.
initialize
Type: SystemBoolean
Determines if Initialize method should be called from constructor.
Remarks

If useCategoryAttributes is false, all settings will be placed in section labeled by the sectionName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the INI file in a section labeled the same as the Category value and if the attribute doesn't exist the member value will serialized into the section labeled by the sectionName value.

Note that some .NET languages (e.g., Visual Basic) will not initialize member elements before call to constuctor, in this case initialize should be set to false, then the Initialize method should be called manually after all properties have been initialized. Alternately, consider using the DefaultValueAttribute on the fields or properties and this will be used to initialize the values.

See Also

Reference

IniSettingsBase Class
IniSettingsBase Overload
GSF.Configuration Namespace


IniSettingsBase Methods

Grid Solutions Framework IniSettingsBase Methods

The IniSettingsBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateSetting | Create setting in INI file if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetFieldSectionName | Gets the section name to use for the specified field or property.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persists any pending changes to INI file. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from INI file. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to INI file. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.CreateSetting Method

Grid Solutions Framework IniSettingsBaseCreateSetting Method
Create setting in INI file if it doesn't already exist. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void CreateSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub CreateSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
function CreateSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void CreateSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.GetFieldSectionName Method

Grid Solutions Framework IniSettingsBaseGetFieldSectionName Method
Gets the section name to use for the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetFieldSectionName(
    string name
)
Public Function GetFieldSectionName (
    name As String
) As String
member GetFieldSectionName :
        name : string -> string

function GetFieldSectionName(name);
public:
String^ GetFieldSectionName(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: String
Category applied to specified field or property; or SectionName if attribute does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
Remarks
Category will only be returned if UseCategoryAttributes is true; otherwise SectionName value will be returned.
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.PersistSettings Method

Grid Solutions Framework IniSettingsBasePersistSettings Method
Persists any pending changes to INI file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void PersistSettings()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub PersistSettings
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract PersistSettings : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override PersistSettings : unit -> unit
function PersistSettings();
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void PersistSettings() override
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.RetrieveSetting Method

Grid Solutions Framework IniSettingsBaseRetrieveSetting Method
Retrieves setting from INI file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override string RetrieveSetting(
    string name,
    string setting
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Function RetrieveSetting (
    name As String,
    setting As String
) As String
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract RetrieveSetting :
        name : string *
        setting : string -> string
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override RetrieveSetting :
        name : string *
        setting : string -> string
function RetrieveSetting(name, setting);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual String^ RetrieveSetting(
    String^ name,
    String^ setting
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.

Return Value

Type: String
Setting value.
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.StoreSetting Method

Grid Solutions Framework IniSettingsBaseStoreSetting Method
Stores setting to INI file. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void StoreSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub StoreSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
function StoreSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void StoreSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase Properties

Grid Solutions Framework IniSettingsBase Properties

The IniSettingsBase type exposes the following members.

Properties
 | Name | Description
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Protected property | IniFile | Gets or sets reference to working INI file.
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Public property | SectionName | Gets or sets default name of section used to access settings in INI file.
Public property | UseCategoryAttributes | Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the section name.
Top
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.IniFile Property

Grid Solutions Framework IniSettingsBaseIniFile Property
Gets or sets reference to working INI file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IniFile IniFile { get; set; }
Protected Property IniFile As IniFile
    Get
    Set
member IniFile : IniFile with get, set

function get_IniFile();
function set_IniFile(value);
protected:
property IniFile^ IniFile {
    IniFile^ get ();
    void set (IniFile^ value);
}

Property Value

Type: IniFile
Exceptions
Exception | Condition
NullReferenceException | value cannot be null.
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.SectionName Property

Grid Solutions Framework IniSettingsBaseSectionName Property
Gets or sets default name of section used to access settings in INI file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SectionName { get; set; }
Public Property SectionName As String
    Get
    Set
member SectionName : string with get, set

function get_SectionName();
function set_SectionName(value);
public:
property String^ SectionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IniSettingsBase.UseCategoryAttributes Property

Grid Solutions Framework IniSettingsBaseUseCategoryAttributes Property
Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the section name.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseCategoryAttributes { get; set; }
Public Property UseCategoryAttributes As Boolean
    Get
    Set
member UseCategoryAttributes : bool with get, set

function get_UseCategoryAttributes();
function set_UseCategoryAttributes(value);
public:
property bool UseCategoryAttributes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
If UseCategoryAttributes is false, all settings will be placed in section labeled by the SectionName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the INI file in a section labeled the same as the Category value and if the attribute doesn't exist the member value will serialized into the section labeled by the SectionName value.
See Also

Reference

IniSettingsBase Class
GSF.Configuration Namespace


IPersistSettings Interface

Grid Solutions Framework IPersistSettings Interface
Defines as interface that specifies that this object can persists settings to a config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IPersistSettings
Public Interface IPersistSettings
type IPersistSettings =  interface end
GSF.Configuration.IPersistSettings = function();
GSF.Configuration.IPersistSettings.createInterface('GSF.Configuration.IPersistSettings');
public interface class IPersistSettings

The IPersistSettings type exposes the following members.

Methods
 | Name | Description
Public method | LoadSettings | Loads saved settings from the config file.
Public method | SaveSettings | Saves settings to the config file.
Top
Properties
 | Name | Description
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file.
Top
See Also

Reference

GSF.Configuration Namespace


IPersistSettings Methods

Grid Solutions Framework IPersistSettings Methods

The IPersistSettings type exposes the following members.

Methods
 | Name | Description
Public method | LoadSettings | Loads saved settings from the config file.
Public method | SaveSettings | Saves settings to the config file.
Top
See Also

Reference

IPersistSettings Interface
GSF.Configuration Namespace


IPersistSettings.LoadSettings Method

Grid Solutions Framework IPersistSettingsLoadSettings Method
Loads saved settings from the config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void LoadSettings()
Sub LoadSettings
abstract LoadSettings : unit -> unit

function LoadSettings();
void LoadSettings()
See Also

Reference

IPersistSettings Interface
GSF.Configuration Namespace


IPersistSettings.SaveSettings Method

Grid Solutions Framework IPersistSettingsSaveSettings Method
Saves settings to the config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void SaveSettings()
Sub SaveSettings
abstract SaveSettings : unit -> unit

function SaveSettings();
void SaveSettings()
See Also

Reference

IPersistSettings Interface
GSF.Configuration Namespace


IPersistSettings Properties

Grid Solutions Framework IPersistSettings Properties

The IPersistSettings type exposes the following members.

Properties
 | Name | Description
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file.
Top
See Also

Reference

IPersistSettings Interface
GSF.Configuration Namespace


IPersistSettings.PersistSettings Property

Grid Solutions Framework IPersistSettingsPersistSettings Property
Determines whether the object settings are to be persisted to the config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool PersistSettings { get; set; }
Property PersistSettings As Boolean
    Get
    Set
abstract PersistSettings : bool with get, set

function get_PersistSettings();
function set_PersistSettings(value);
property bool PersistSettings {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IPersistSettings Interface
GSF.Configuration Namespace


IPersistSettings.SettingsCategory Property

Grid Solutions Framework IPersistSettingsSettingsCategory Property
Gets or sets the category name under which the object settings are persisted in the config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string SettingsCategory { get; set; }
Property SettingsCategory As String
    Get
    Set
abstract SettingsCategory : string with get, set

function get_SettingsCategory();
function set_SettingsCategory(value);
property String^ SettingsCategory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IPersistSettings Interface
GSF.Configuration Namespace


RegistrySettingsBase Class

Grid Solutions Framework RegistrySettingsBase Class
Represents the base class for application settings that are synchronized to the registry.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationSettingsBase
GSF.ConfigurationRegistrySettingsBase

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class RegistrySettingsBase : SettingsBase
Public MustInherit Class RegistrySettingsBase
    Inherits SettingsBase
[<AbstractClassAttribute>]
type RegistrySettingsBase =
    class
        inherit SettingsBase
    end
GSF.Configuration.RegistrySettingsBase = function();

Type.createClass(
    'GSF.Configuration.RegistrySettingsBase',
    GSF.Configuration.SettingsBase);
public ref class RegistrySettingsBase abstract : public SettingsBase

The RegistrySettingsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | RegistrySettingsBase(String, String) | Creates a new instance of the RegistrySettingsBase class for the application's registry based settings.
Protected method | RegistrySettingsBase(String, String, Boolean, Boolean, Boolean) | Creates a new instance of the RegistrySettingsBase class for the application's registry based settings.
Top
Methods
 | Name | Description
Protected method | CreateSetting | Create setting in registry if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetFieldKeyName | Gets the key name to use for storing the specified field or property in the registry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persist any pending changes to registry. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from registry. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to registry. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Public property | KeyName | Gets or sets name of default key used to access settings in the registry (e.g., "General Settings").
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Public property | RootPath | Gets or sets root registry path used to access settings in the registry (e.g., "HKEY_CURRENT_USER\\Software\\My Company\\My Product\\").
Public property | UseCategoryAttributes | Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the registry key names.
Top
Remarks

In order to make custom types serializable for the registry, implement a TypeConverter for the type.
See MSDN for details.

Examples
Here is an example class derived from RegistrySettingsBase that automatically serializes its fields and properties to the registry.
Copy
public enum MyEnum
 {
     One,
     Two,
     Three
 }

 public class MySettings : RegistrySettingsBase
 {
     // Private property fields (private fields will not be serialized)
     private double m_doubleVal;

     // Public settings fields
     public bool BoolVal = true;
     public int IntVal = 1;
     public float FloatVal = 3.14F;
     public string StrVal = "This is a test...";
     public MyEnum EnumVal = MyEnum.Three;

     [SettingName("UserOptions"), EncryptSetting()]
     public string Password = "default";

     // Mark this field to not be serialized to registry...
     [SerializeSetting(false)]
     public decimal DecimalVal;

     public MySettings()
         : base("HKEY_CURRENT_USER\\Software\\My Company\\My Product\\", "General Settings") {}

     [Category("OtherSettings"), DefaultValue(1.159D)]
     public double DoubleVal
     {
         get
         {
             return m_doubleVal;
         }
         set
         {
             m_doubleVal = value;
         }
     }

     [SerializeSetting(false)]
     public bool DontSerializeMe { get; set; }
 }
See Also

Reference

GSF.Configuration Namespace


RegistrySettingsBase Constructor

Grid Solutions Framework RegistrySettingsBase Constructor
Overload List
 | Name | Description
Protected method | RegistrySettingsBase(String, String) | Creates a new instance of the RegistrySettingsBase class for the application's registry based settings.
Protected method | RegistrySettingsBase(String, String, Boolean, Boolean, Boolean) | Creates a new instance of the RegistrySettingsBase class for the application's registry based settings.
Top
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase Constructor (String, String)

Grid Solutions Framework RegistrySettingsBase Constructor (String, String)
Creates a new instance of the RegistrySettingsBase class for the application's registry based settings.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RegistrySettingsBase(
    string rootPath,
    string keyName
)
Protected Sub New (
    rootPath As String,
    keyName As String
)
new :
        rootPath : string *
        keyName : string -> RegistrySettingsBase
GSF.Configuration.RegistrySettingsBase = function(rootPath, keyName);
protected:
RegistrySettingsBase(
    String^ rootPath,
    String^ keyName
)

Parameters

rootPath
Type: SystemString
Defines the root registry path used to access settings in the registry (e.g., "HKEY_CURRENT_USER\\Software\\My Company\\My Product\\").
keyName
Type: SystemString
Defines the name of default key used to access settings in the registry (e.g., "General Settings").
See Also

Reference

RegistrySettingsBase Class
RegistrySettingsBase Overload
GSF.Configuration Namespace


RegistrySettingsBase Constructor (String, String, Boolean, Boolean, Boolean)

Grid Solutions Framework RegistrySettingsBase Constructor (String, String, Boolean, Boolean, Boolean)
Creates a new instance of the RegistrySettingsBase class for the application's registry based settings.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RegistrySettingsBase(
    string rootPath,
    string keyName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute,
    bool initialize
)
Protected Sub New (
    rootPath As String,
    keyName As String,
    useCategoryAttributes As Boolean,
    requireSerializeSettingAttribute As Boolean,
    initialize As Boolean
)
new :
        rootPath : string *
        keyName : string *
        useCategoryAttributes : bool *
        requireSerializeSettingAttribute : bool *
        initialize : bool -> RegistrySettingsBase
GSF.Configuration.RegistrySettingsBase = function(rootPath, keyName, useCategoryAttributes, requireSerializeSettingAttribute, initialize);
protected:
RegistrySettingsBase(
    String^ rootPath,
    String^ keyName,
    bool useCategoryAttributes,
    bool requireSerializeSettingAttribute,
    bool initialize
)

Parameters

rootPath
Type: SystemString
Defines the root registry path used to access settings in the registry (e.g., "HKEY_CURRENT_USER\\Software\\My Company\\My Product\\").
keyName
Type: SystemString
Defines the name of default key used to access settings in the registry (e.g., "General Settings").
useCategoryAttributes
Type: SystemBoolean
Determines if category attributes will be used for the registry key names.
requireSerializeSettingAttribute
Type: SystemBoolean
Assigns flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the registry.
initialize
Type: SystemBoolean
Determines if Initialize method should be called from constructor.
Remarks

If useCategoryAttributes is false, all settings will be placed in section labeled by the keyName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the registry in a section labeled the same as the Category value and if the attribute doesn't exist the member value will serialized into the section labeled by the keyName value.

Note that some .NET languages (e.g., Visual Basic) will not initialize member elements before call to constuctor, in this case initialize should be set to false, then the Initialize method should be called manually after all properties have been initialized. Alternately, consider using the DefaultValueAttribute on the fields or properties and this will be used to initialize the values.

See Also

Reference

RegistrySettingsBase Class
RegistrySettingsBase Overload
GSF.Configuration Namespace


RegistrySettingsBase Methods

Grid Solutions Framework RegistrySettingsBase Methods

The RegistrySettingsBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateSetting | Create setting in registry if it doesn't already exist. This method is for internal use. (Overrides SettingsBaseCreateSetting(String, String, String).)
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist. (Inherited from SettingsBase.)
Protected method | DeriveDefaultValue | Attempts to get best default value for given member. (Inherited from SettingsBase.)
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object. (Inherited from SettingsBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources. (Inherited from SettingsBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields. (Inherited from SettingsBase.)
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties. (Inherited from SettingsBase.)
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Inherited from SettingsBase.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value. (Inherited from SettingsBase.)
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property. (Inherited from SettingsBase.)
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file. (Inherited from SettingsBase.)
Public method | GetFieldKeyName | Gets the key name to use for storing the specified field or property in the registry.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property. (Inherited from SettingsBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type. (Inherited from SettingsBase.)
Public method | GetValueT(String, T) | Copies the specified application setting into the given value. (Inherited from SettingsBase.)
Protected method | Initialize | Initializes configuration settings from derived class fields or properties. (Inherited from SettingsBase.)
Public method | Load | Loads configuration file into setting fields. (Inherited from SettingsBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Persist any pending changes to registry. This method is for internal use. (Overrides SettingsBasePersistSettings.)
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file. (Inherited from SettingsBase.)
Protected method | RetrieveSetting | Retrieves setting from registry. This method is for internal use. (Overrides SettingsBaseRetrieveSetting(String, String).)
Public method | Save | Saves setting fields into configuration file. (Inherited from SettingsBase.)
Public method | SetValue | Copies the given value into the specified application setting. (Inherited from SettingsBase.)
Protected method | StoreSetting | Stores setting to registry. This method is for internal use. (Overrides SettingsBaseStoreSetting(String, String, String).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.CreateSetting Method

Grid Solutions Framework RegistrySettingsBaseCreateSetting Method
Create setting in registry if it doesn't already exist. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void CreateSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub CreateSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override CreateSetting :
        name : string *
        setting : string *
        value : string -> unit
function CreateSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void CreateSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.GetFieldKeyName Method

Grid Solutions Framework RegistrySettingsBaseGetFieldKeyName Method
Gets the key name to use for storing the specified field or property in the registry.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetFieldKeyName(
    string name
)
Public Function GetFieldKeyName (
    name As String
) As String
member GetFieldKeyName :
        name : string -> string

function GetFieldKeyName(name);
public:
String^ GetFieldKeyName(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: String
Category applied to specified field or property; or KeyName if attribute does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
Remarks
Category will only be returned if UseCategoryAttributes is true; otherwise KeyName value will be returned.
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.PersistSettings Method

Grid Solutions Framework RegistrySettingsBasePersistSettings Method
Persist any pending changes to registry. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void PersistSettings()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub PersistSettings
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract PersistSettings : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override PersistSettings : unit -> unit
function PersistSettings();
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void PersistSettings() override
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.RetrieveSetting Method

Grid Solutions Framework RegistrySettingsBaseRetrieveSetting Method
Retrieves setting from registry. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override string RetrieveSetting(
    string name,
    string setting
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Function RetrieveSetting (
    name As String,
    setting As String
) As String
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract RetrieveSetting :
        name : string *
        setting : string -> string
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override RetrieveSetting :
        name : string *
        setting : string -> string
function RetrieveSetting(name, setting);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual String^ RetrieveSetting(
    String^ name,
    String^ setting
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.

Return Value

Type: String
Setting value.
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.StoreSetting Method

Grid Solutions Framework RegistrySettingsBaseStoreSetting Method
Stores setting to registry. This method is for internal use.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void StoreSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub StoreSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override StoreSetting :
        name : string *
        setting : string *
        value : string -> unit
function StoreSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void StoreSetting(
    String^ name,
    String^ setting,
    String^ value
) override

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase Properties

Grid Solutions Framework RegistrySettingsBase Properties

The RegistrySettingsBase type exposes the following members.

Properties
 | Name | Description
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String. (Inherited from SettingsBase.)
Public property | Item | Gets or sets the value of the specified field or property. (Inherited from SettingsBase.)
Public property | KeyName | Gets or sets name of default key used to access settings in the registry (e.g., "General Settings").
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class. (Inherited from SettingsBase.)
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False. (Inherited from SettingsBase.)
Public property | RootPath | Gets or sets root registry path used to access settings in the registry (e.g., "HKEY_CURRENT_USER\\Software\\My Company\\My Product\\").
Public property | UseCategoryAttributes | Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the registry key names.
Top
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.KeyName Property

Grid Solutions Framework RegistrySettingsBaseKeyName Property
Gets or sets name of default key used to access settings in the registry (e.g., "General Settings").

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
public string KeyName { get; set; }
<SerializeSettingAttribute(false)>
<BrowsableAttribute(false)>
Public Property KeyName As String
    Get
    Set
[<SerializeSettingAttribute(false)>]
[<BrowsableAttribute(false)>]
member KeyName : string with get, set

function get_KeyName();
function set_KeyName(value);
public:
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
property String^ KeyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.RootPath Property

Grid Solutions Framework RegistrySettingsBaseRootPath Property
Gets or sets root registry path used to access settings in the registry (e.g., "HKEY_CURRENT_USER\\Software\\My Company\\My Product\\").

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
public string RootPath { get; set; }
<SerializeSettingAttribute(false)>
<BrowsableAttribute(false)>
Public Property RootPath As String
    Get
    Set
[<SerializeSettingAttribute(false)>]
[<BrowsableAttribute(false)>]
member RootPath : string with get, set

function get_RootPath();
function set_RootPath(value);
public:
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
property String^ RootPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


RegistrySettingsBase.UseCategoryAttributes Property

Grid Solutions Framework RegistrySettingsBaseUseCategoryAttributes Property
Gets or sets value that determines whether a CategoryAttribute applied to a field or property will be used for the registry key names.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
public bool UseCategoryAttributes { get; set; }
<SerializeSettingAttribute(false)>
<BrowsableAttribute(false)>
Public Property UseCategoryAttributes As Boolean
    Get
    Set
[<SerializeSettingAttribute(false)>]
[<BrowsableAttribute(false)>]
member UseCategoryAttributes : bool with get, set

function get_UseCategoryAttributes();
function set_UseCategoryAttributes(value);
public:
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
property bool UseCategoryAttributes {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
If UseCategoryAttributes is false, all settings will be placed in section labeled by the KeyName value; otherwise, if a CategoryAttribute exists on a field or property then the member value will serialized into the registry in a section labeled the same as the Category value and if the attribute doesn't exist the member value will stored in the registry key identified by the KeyName value.
See Also

Reference

RegistrySettingsBase Class
GSF.Configuration Namespace


SerializeSettingAttribute Class

Grid Solutions Framework SerializeSettingAttribute Class
Represents an attribute that determines if a property or field in a class derived from CategorizedSettingsBase or AppSettingsBase should be serialized to the configuration file.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ConfigurationSerializeSettingAttribute

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)]
public sealed class SerializeSettingAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field)>
Public NotInheritable Class SerializeSettingAttribute
    Inherits Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)>]
type SerializeSettingAttribute =
    class
        inherit Attribute
    end
GSF.Configuration.SerializeSettingAttribute = function();

Type.createClass(
    'GSF.Configuration.SerializeSettingAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property|AttributeTargets::Field)]
public ref class SerializeSettingAttribute sealed : public Attribute

The SerializeSettingAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SerializeSettingAttribute | Creates a new SerializeSettingAttribute; defaults to Serialize = true.
Public method | SerializeSettingAttribute(Boolean) | Creates a new SerializeSettingAttribute with the specified serialize value.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Serialize | Gets or sets flag that determines if the property or field this SerializeSettingAttribute modifies should be serialized to the configuration file.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.Configuration Namespace


SerializeSettingAttribute Constructor

Grid Solutions Framework SerializeSettingAttribute Constructor
Overload List
 | Name | Description
Public method | SerializeSettingAttribute | Creates a new SerializeSettingAttribute; defaults to Serialize = true.
Public method | SerializeSettingAttribute(Boolean) | Creates a new SerializeSettingAttribute with the specified serialize value.
Top
See Also

Reference

SerializeSettingAttribute Class
GSF.Configuration Namespace


SerializeSettingAttribute Constructor

Grid Solutions Framework SerializeSettingAttribute Constructor
Creates a new SerializeSettingAttribute; defaults to Serialize = true.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializeSettingAttribute()
Public Sub New
new : unit -> SerializeSettingAttribute
GSF.Configuration.SerializeSettingAttribute = function();
public:
SerializeSettingAttribute()
See Also

Reference

SerializeSettingAttribute Class
SerializeSettingAttribute Overload
GSF.Configuration Namespace


SerializeSettingAttribute Constructor (Boolean)

Grid Solutions Framework SerializeSettingAttribute Constructor (Boolean)
Creates a new SerializeSettingAttribute with the specified serialize value.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializeSettingAttribute(
    bool serialize
)
Public Sub New (
    serialize As Boolean
)
new :
        serialize : bool -> SerializeSettingAttribute
GSF.Configuration.SerializeSettingAttribute = function(serialize);
public:
SerializeSettingAttribute(
    bool serialize
)

Parameters

serialize
Type: SystemBoolean
Assigns flag that determines if the property or field this SerializeSettingAttribute modifies should be serialized to the configuration file.
See Also

Reference

SerializeSettingAttribute Class
SerializeSettingAttribute Overload
GSF.Configuration Namespace


SerializeSettingAttribute Methods

Grid Solutions Framework SerializeSettingAttribute Methods

The SerializeSettingAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SerializeSettingAttribute Class
GSF.Configuration Namespace


SerializeSettingAttribute Properties

Grid Solutions Framework SerializeSettingAttribute Properties

The SerializeSettingAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Serialize | Gets or sets flag that determines if the property or field this SerializeSettingAttribute modifies should be serialized to the configuration file.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

SerializeSettingAttribute Class
GSF.Configuration Namespace


SerializeSettingAttribute.Serialize Property

Grid Solutions Framework SerializeSettingAttributeSerialize Property
Gets or sets flag that determines if the property or field this SerializeSettingAttribute modifies should be serialized to the configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Serialize { get; }
Public ReadOnly Property Serialize As Boolean
    Get
member Serialize : bool with get

function get_Serialize();

public:
property bool Serialize {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SerializeSettingAttribute Class
GSF.Configuration Namespace


SettingNameAttribute Class

Grid Solutions Framework SettingNameAttribute Class
Represents an attribute that defines the setting name of a property or field in a class derived from CategorizedSettingsBase or AppSettingsBase when serializing the value to the configuration file.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.ConfigurationSettingNameAttribute

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)]
public sealed class SettingNameAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property Or AttributeTargets.Field)>
Public NotInheritable Class SettingNameAttribute
    Inherits Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property|AttributeTargets.Field)>]
type SettingNameAttribute =
    class
        inherit Attribute
    end
GSF.Configuration.SettingNameAttribute = function();

Type.createClass(
    'GSF.Configuration.SettingNameAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property|AttributeTargets::Field)]
public ref class SettingNameAttribute sealed : public Attribute

The SettingNameAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | SettingNameAttribute | Creates a new SettingNameAttribute with the specified names value.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | Gets the name used to serialize field or property into config file.
Public property | Names | Gets the names used to serialize field or property into config file.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Remarks
This attribute allows consumers to override the name of the setting going into the configuration file, if the attribute doesn't exist the property or field name is used.
See Also

Reference

GSF.Configuration Namespace


SettingNameAttribute Constructor

Grid Solutions Framework SettingNameAttribute Constructor
Creates a new SettingNameAttribute with the specified names value.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SettingNameAttribute(
    params string[] names
)
Public Sub New (
    ParamArray names As String()
)
new :
        names : string[] -> SettingNameAttribute
GSF.Configuration.SettingNameAttribute = function(... names);
public:
SettingNameAttribute(
    ... array<String^>^ names
)

Parameters

names
Type: SystemString
Assigns name(s) used to serialize setting into config file.
See Also

Reference

SettingNameAttribute Class
GSF.Configuration Namespace


SettingNameAttribute Methods

Grid Solutions Framework SettingNameAttribute Methods

The SettingNameAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SettingNameAttribute Class
GSF.Configuration Namespace


SettingNameAttribute Properties

Grid Solutions Framework SettingNameAttribute Properties

The SettingNameAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets the name used to serialize field or property into config file.
Public property | Names | Gets the names used to serialize field or property into config file.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

SettingNameAttribute Class
GSF.Configuration Namespace


SettingNameAttribute.Name Property

Grid Solutions Framework SettingNameAttributeName Property
Gets the name used to serialize field or property into config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
member Name : string with get

function get_Name();

public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SettingNameAttribute Class
GSF.Configuration Namespace


SettingNameAttribute.Names Property

Grid Solutions Framework SettingNameAttributeNames Property
Gets the names used to serialize field or property into config file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] Names { get; }
Public ReadOnly Property Names As String()
    Get
member Names : string[] with get

function get_Names();

public:
property array<String^>^ Names {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

SettingNameAttribute Class
GSF.Configuration Namespace


SettingsBase Class

Grid Solutions Framework SettingsBase Class
Represents the base class for application settings that are synchronized with its configuration file.
Inheritance Hierarchy
SystemObject
GSF.ConfigurationSettingsBase
GSF.ConfigurationAppSettingsBase
GSF.ConfigurationCategorizedSettingsBase
GSF.ConfigurationIniSettingsBase
GSF.ConfigurationRegistrySettingsBase

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public abstract class SettingsBase : IDisposable,
    IEnumerable<string>, IEnumerable
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public MustInherit Class SettingsBase
    Implements IDisposable, IEnumerable(Of String),
    IEnumerable
[<AbstractClassAttribute>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type SettingsBase =
    class
        interface IDisposable
        interface IEnumerable<string>
        interface IEnumerable
    end
GSF.Configuration.SettingsBase = function();

Type.createClass(
    'GSF.Configuration.SettingsBase',
    null,
    IDisposable,
    IEnumerable`1,
    IEnumerable);
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public ref class SettingsBase abstract : IDisposable,
    IEnumerable<String^>, IEnumerable

The SettingsBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SettingsBase | Creates a new instance of the SettingsBase class for the application's configuration file.
Top
Methods
 | Name | Description
Protected method | CreateSetting | Implementor should create setting in configuration file (or other location).
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist.
Protected method | DeriveDefaultValue | Attempts to get best default value for given member.
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields.
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties.
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value.
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property.
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property.
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property.
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type.
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type.
Public method | GetValueT(String, T) | Copies the specified application setting into the given value.
Protected method | Initialize | Initializes configuration settings from derived class fields or properties.
Public method | Load | Loads configuration file into setting fields.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Implementor should persist any pending changes to configuration file (or other location).
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file.
Protected method | RetrieveSetting | Implementor should retrieve setting from configuration file (or other location).
Public method | Save | Saves setting fields into configuration file.
Public method | SetValue | Copies the given value into the specified application setting.
Protected method | StoreSetting | Implementor should store setting to configuration file (or other location).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByString, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityString | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityString(String) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxString(FuncString, String, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxString(IComparerString) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByString, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinString(FuncString, String, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinString(IComparerString) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByString, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityString | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityString(String) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringString | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringString(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringString(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String.
Public property | Item | Gets or sets the value of the specified field or property.
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class.
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False.
Top
Remarks
In order to make custom types serializable for the configuration file, implement a TypeConverter for the type.
See MSDN for details.
See Also

Reference

GSF.Configuration Namespace


SettingsBase Constructor

Grid Solutions Framework SettingsBase Constructor
Creates a new instance of the SettingsBase class for the application's configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected SettingsBase(
    bool requireSerializeSettingAttribute
)
Protected Sub New (
    requireSerializeSettingAttribute As Boolean
)
new :
        requireSerializeSettingAttribute : bool -> SettingsBase
GSF.Configuration.SettingsBase = function(requireSerializeSettingAttribute);
protected:
SettingsBase(
    bool requireSerializeSettingAttribute
)

Parameters

requireSerializeSettingAttribute
Type: SystemBoolean
Assigns flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase Methods

Grid Solutions Framework SettingsBase Methods

The SettingsBase type exposes the following members.

Methods
 | Name | Description
Protected method | CreateSetting | Implementor should create setting in configuration file (or other location).
Public method | CreateValue | Adds a setting to the application's configuration file, if it doesn't already exist.
Protected method | DeriveDefaultValue | Attempts to get best default value for given member.
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteActionForFields | Executes specified action over all public derived class member fields.
Protected method | ExecuteActionForProperties | Executes specified action over all public derived class properties.
Protected method | Finalize | Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Protected method | GetAttributeValueTAttribute, TValue | Attempts to find specified attribute and return specified value.
Public method | GetDefaultValue | Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property.
Public method | GetEncryptKey | Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property.
Public method | GetEncryptStatus | Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property.
Public method | GetEnumerator | Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSettingName | Gets setting name to use for specified field or property.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type.
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type.
Public method | GetValueT(String, T) | Copies the specified application setting into the given value.
Protected method | Initialize | Initializes configuration settings from derived class fields or properties.
Public method | Load | Loads configuration file into setting fields.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | PersistSettings | Implementor should persist any pending changes to configuration file (or other location).
Public method | RestoreDefaultSettings | Restores the default settings of the configuration file.
Protected method | RetrieveSetting | Implementor should retrieve setting from configuration file (or other location).
Public method | Save | Saves setting fields into configuration file.
Public method | SetValue | Copies the given value into the specified application setting.
Protected method | StoreSetting | Implementor should store setting to configuration file (or other location).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByString, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityString | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityString(String) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxString(FuncString, String, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxString(IComparerString) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByString, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinString(FuncString, String, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinString(IComparerString) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByString, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityString | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityString(String) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringString | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringString(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringString(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.CreateSetting Method

Grid Solutions Framework SettingsBaseCreateSetting Method
Implementor should create setting in configuration file (or other location).

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected abstract void CreateSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected MustOverride Sub CreateSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
abstract CreateSetting :
        name : string *
        setting : string *
        value : string -> unit

function CreateSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
virtual void CreateSetting(
    String^ name,
    String^ setting,
    String^ value
) abstract

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.CreateValue Method

Grid Solutions Framework SettingsBaseCreateValue Method
Adds a setting to the application's configuration file, if it doesn't already exist.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CreateValue(
    string name,
    Object value
)
Public Sub CreateValue (
    name As String,
    value As Object
)
member CreateValue :
        name : string *
        value : Object -> unit

function CreateValue(name, value);
public:
void CreateValue(
    String^ name,
    Object^ value
)

Parameters

name
Type: SystemString
Field or property name.
value
Type: SystemObject
Setting value.
Remarks
Use this function to ensure a setting exists, it will not override an existing value.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.DeriveDefaultValue Method

Grid Solutions Framework SettingsBaseDeriveDefaultValue Method
Attempts to get best default value for given member.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected Object DeriveDefaultValue(
    string name,
    Object value
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Function DeriveDefaultValue (
    name As String,
    value As Object
) As Object
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member DeriveDefaultValue :
        name : string *
        value : Object -> Object

function DeriveDefaultValue(name, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
Object^ DeriveDefaultValue(
    String^ name,
    Object^ value
)

Parameters

name
Type: SystemString
Field or property name.
value
Type: SystemObject
Current field or property value.

Return Value

Type: Object
The object that is the best default value.
Remarks
If value is equal to its default(type) value, then any value derived from DefaultValueAttribute will be used instead.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.Dispose Method

Grid Solutions Framework SettingsBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the CategorizedSettingsBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources.
Top
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.Dispose Method

Grid Solutions Framework SettingsBaseDispose Method
Releases all the resources used by the CategorizedSettingsBase object.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

SettingsBase Class
Dispose Overload
GSF.Configuration Namespace


SettingsBase.Dispose Method (Boolean)

Grid Solutions Framework SettingsBaseDispose Method (Boolean)
Releases the unmanaged resources used by the CategorizedSettingsBase object and optionally releases the managed resources.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

SettingsBase Class
Dispose Overload
GSF.Configuration Namespace


SettingsBase.ExecuteActionForFields Method

Grid Solutions Framework SettingsBaseExecuteActionForFields Method
Executes specified action over all public derived class member fields.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void ExecuteActionForFields(
    Action<FieldInfo> fieldAction
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub ExecuteActionForFields (
    fieldAction As Action(Of FieldInfo)
)
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member ExecuteActionForFields :
        fieldAction : Action<FieldInfo> -> unit

function ExecuteActionForFields(fieldAction);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void ExecuteActionForFields(
    Action<FieldInfo^>^ fieldAction
)

Parameters

fieldAction
Type: SystemAction FieldInfo
Action to execute for all derived class member fields.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.ExecuteActionForProperties Method

Grid Solutions Framework SettingsBaseExecuteActionForProperties Method
Executes specified action over all public derived class properties.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected void ExecuteActionForProperties(
    Action<PropertyInfo> propertyAction,
    BindingFlags isGetOrSet
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Sub ExecuteActionForProperties (
    propertyAction As Action(Of PropertyInfo),
    isGetOrSet As BindingFlags
)
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member ExecuteActionForProperties :
        propertyAction : Action<PropertyInfo> *
        isGetOrSet : BindingFlags -> unit

function ExecuteActionForProperties(propertyAction, isGetOrSet);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void ExecuteActionForProperties(
    Action<PropertyInfo^>^ propertyAction,
    BindingFlags isGetOrSet
)

Parameters

propertyAction
Type: SystemAction PropertyInfo
Action to execute for all properties.
isGetOrSet
Type: System.ReflectionBindingFlags
GetProperty or SetProperty.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.Finalize Method

Grid Solutions Framework SettingsBaseFinalize Method
Releases the unmanaged resources before the CategorizedSettingsBase object is reclaimed by GC.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetAttributeValue(TAttribute, TValue) Method

Grid Solutions Framework SettingsBaseGetAttributeValueTAttribute, TValue Method
Attempts to find specified attribute and return specified value.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected TValue GetAttributeValue<TAttribute, TValue>(
    string name,
    TValue defaultValue,
    Func<TAttribute, TValue> attributeValue
)
where TAttribute : Attribute

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Function GetAttributeValue(Of TAttribute As Attribute, TValue) (
    name As String,
    defaultValue As TValue,
    attributeValue As Func(Of TAttribute, TValue)
) As TValue
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member GetAttributeValue :
        name : string *
        defaultValue : 'TValue *
        attributeValue : Func<'TAttribute, 'TValue> -> 'TValue  when 'TAttribute : Attribute

JavaScript does not support generic types or methods.
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
generic<typename TAttribute, typename TValue>
where TAttribute : Attribute
TValue GetAttributeValue(
    String^ name,
    TValue defaultValue,
    Func<TAttribute, TValue>^ attributeValue
)

Parameters

name
Type: SystemString
Name of field or property to search for attribute.
defaultValue
Type: TValue
Default value to return if attribute doesn't exist.
attributeValue
Type: SystemFunc TAttribute, TValue
Function delegate used to return desired attribute property.

Type Parameters

TAttribute
Type of Attribute to find.
TValue
Type of value attribute delegate returns.

Return Value

Type: TValue
Specified attribute value if it exists; otherwise default value.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetDefaultValue Method

Grid Solutions Framework SettingsBaseGetDefaultValue Method
Gets the default value specified by DefaultValueAttribute, if any, applied to the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object GetDefaultValue(
    string name
)
Public Function GetDefaultValue (
    name As String
) As Object
member GetDefaultValue :
        name : string -> Object

function GetDefaultValue(name);
public:
Object^ GetDefaultValue(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: Object
Default value applied to specified field or property; or null if one does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetEncryptKey Method

Grid Solutions Framework SettingsBaseGetEncryptKey Method
Gets the optional private encryption key specified by EncryptSettingAttribute, if any, applied to the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetEncryptKey(
    string name
)
Public Function GetEncryptKey (
    name As String
) As String
member GetEncryptKey :
        name : string -> string

function GetEncryptKey(name);
public:
String^ GetEncryptKey(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: String
Encryption private key applied to specified field or property; or null if one does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetEncryptStatus Method

Grid Solutions Framework SettingsBaseGetEncryptStatus Method
Gets the encryption status specified by EncryptSettingAttribute, if any, applied to the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool GetEncryptStatus(
    string name
)
Public Function GetEncryptStatus (
    name As String
) As Boolean
member GetEncryptStatus :
        name : string -> bool

function GetEncryptStatus(name);
public:
bool GetEncryptStatus(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: Boolean
Encryption status applied to specified field or property; or false if one does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetEnumerator Method

Grid Solutions Framework SettingsBaseGetEnumerator Method
Returns an enumerator based on String elements that iterates over the field and property names of this class that are targeted for serialization to the configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerator<string> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of String)
abstract GetEnumerator : unit -> IEnumerator<string>
override GetEnumerator : unit -> IEnumerator<string>
function GetEnumerator();
public:
virtual IEnumerator<String^>^ GetEnumerator() sealed

Return Value

Type: IEnumerator String
An IEnumerator object that can be used to iterate through the collection.

Implements

IEnumerableTGetEnumerator
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetSettingName Method

Grid Solutions Framework SettingsBaseGetSettingName Method
Gets setting name to use for specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetSettingName(
    string name
)
Public Function GetSettingName (
    name As String
) As String
member GetSettingName :
        name : string -> string

function GetSettingName(name);
public:
String^ GetSettingName(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: String
Name applied to specified field or property; or name if attribute does not exist.
Exceptions
Exception | Condition
ArgumentException | name cannot be null or empty.
Remarks
Field or property name will be used for setting name unless user applied a SettingNameAttribute on the field or property to override name used to serialize value in configuration file.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetValue Method

Grid Solutions Framework SettingsBaseGetValue Method
Overload List
 | Name | Description
Public method | GetValueT(String) | Gets the application's configuration file setting converted to the given type.
Public method | GetValue(String, Type) | Gets the application's configuration file setting converted to the given type.
Public method | GetValueT(String, T) | Copies the specified application setting into the given value.
Top
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.GetValue(T) Method (String)

Grid Solutions Framework SettingsBaseGetValueT Method (String)
Gets the application's configuration file setting converted to the given type.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T GetValue<T>(
    string name
)

Public Function GetValue(Of T) (
    name As String
) As T
member GetValue :
        name : string -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T GetValue(
    String^ name
)

Parameters

name
Type: SystemString
Field or property name.

Type Parameters

T
Type to use for setting conversion.

Return Value

Type: T
Value of specified configuration file setting converted to the given type.
See Also

Reference

SettingsBase Class
GetValue Overload
GSF.Configuration Namespace


SettingsBase.GetValue Method (String, Type)

Grid Solutions Framework SettingsBaseGetValue Method (String, Type)
Gets the application's configuration file setting converted to the given type.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object GetValue(
    string name,
    Type type
)
Public Function GetValue (
    name As String,
    type As Type
) As Object
member GetValue :
        name : string *
        type : Type -> Object

function GetValue(name, type);
public:
Object^ GetValue(
    String^ name,
    Type^ type
)

Parameters

name
Type: SystemString
Field or property name.
type
Type: SystemType
Setting type.

Return Value

Type: Object
Value of specified configuration file setting converted to the given type.
See Also

Reference

SettingsBase Class
GetValue Overload
GSF.Configuration Namespace


SettingsBase.GetValue(T) Method (String, T)

Grid Solutions Framework SettingsBaseGetValueT Method (String, T)
Copies the specified application setting into the given value.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetValue<T>(
    string name,
    out T value
)

Public Sub GetValue(Of T) (
    name As String,
    <OutAttribute> ByRef value As T
)
member GetValue :
        name : string *
        value : 'T byref -> unit

JavaScript does not support generic types or methods.
public:
generic<typename T>
void GetValue(
    String^ name,
    [OutAttribute] T% value
)

Parameters

name
Type: SystemString
Field or property name.
value
Type: T
Setting value.

Type Parameters

T
Type to use for setting conversion.
See Also

Reference

SettingsBase Class
GetValue Overload
GSF.Configuration Namespace


SettingsBase.Initialize Method

Grid Solutions Framework SettingsBaseInitialize Method
Initializes configuration settings from derived class fields or properties.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Initialize()
Protected Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
protected:
virtual void Initialize()
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.Load Method

Grid Solutions Framework SettingsBaseLoad Method
Loads configuration file into setting fields.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Load()
Public Overridable Sub Load
abstract Load : unit -> unit
override Load : unit -> unit
function Load();
public:
virtual void Load()
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.PersistSettings Method

Grid Solutions Framework SettingsBasePersistSettings Method
Implementor should persist any pending changes to configuration file (or other location).

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected abstract void PersistSettings()
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected MustOverride Sub PersistSettings
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
abstract PersistSettings : unit -> unit

function PersistSettings();
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
virtual void PersistSettings() abstract
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.RestoreDefaultSettings Method

Grid Solutions Framework SettingsBaseRestoreDefaultSettings Method
Restores the default settings of the configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RestoreDefaultSettings()
Public Overridable Sub RestoreDefaultSettings
abstract RestoreDefaultSettings : unit -> unit
override RestoreDefaultSettings : unit -> unit
function RestoreDefaultSettings();
public:
virtual void RestoreDefaultSettings()
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.RetrieveSetting Method

Grid Solutions Framework SettingsBaseRetrieveSetting Method
Implementor should retrieve setting from configuration file (or other location).

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected abstract string RetrieveSetting(
    string name,
    string setting
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected MustOverride Function RetrieveSetting (
    name As String,
    setting As String
) As String
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
abstract RetrieveSetting :
        name : string *
        setting : string -> string

function RetrieveSetting(name, setting);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
virtual String^ RetrieveSetting(
    String^ name,
    String^ setting
) abstract

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.

Return Value

Type: String
Setting value.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.Save Method

Grid Solutions Framework SettingsBaseSave Method
Saves setting fields into configuration file.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Save()
Public Overridable Sub Save
abstract Save : unit -> unit
override Save : unit -> unit
function Save();
public:
virtual void Save()
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.SetValue Method

Grid Solutions Framework SettingsBaseSetValue Method
Copies the given value into the specified application setting.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetValue(
    string name,
    Object value
)
Public Sub SetValue (
    name As String,
    value As Object
)
member SetValue :
        name : string *
        value : Object -> unit

function SetValue(name, value);
public:
void SetValue(
    String^ name,
    Object^ value
)

Parameters

name
Type: SystemString
Field or property name.
value
Type: SystemObject
Setting value.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.StoreSetting Method

Grid Solutions Framework SettingsBaseStoreSetting Method
Implementor should store setting to configuration file (or other location).

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected abstract void StoreSetting(
    string name,
    string setting,
    string value
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected MustOverride Sub StoreSetting (
    name As String,
    setting As String,
    value As String
)
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
abstract StoreSetting :
        name : string *
        setting : string *
        value : string -> unit

function StoreSetting(name, setting, value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
virtual void StoreSetting(
    String^ name,
    String^ setting,
    String^ value
) abstract

Parameters

name
Type: SystemString
Field or property name, if useful (can be different from setting name).
setting
Type: SystemString
Setting name.
value
Type: SystemString
Setting value.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase Properties

Grid Solutions Framework SettingsBase Properties

The SettingsBase type exposes the following members.

Properties
 | Name | Description
Public property | Culture | Gets or sets the CultureInfo to use for the conversion of setting values to and from String.
Public property | Item | Gets or sets the value of the specified field or property.
Protected property | MemberAccessBindingFlags | Gets or sets BindingFlags used to access fields and properties of derived class.
Public property | RequireSerializeSettingAttribute | Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False.
Top
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.Culture Property

Grid Solutions Framework SettingsBaseCulture Property
Gets or sets the CultureInfo to use for the conversion of setting values to and from String.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
public CultureInfo Culture { get; set; }
<SerializeSettingAttribute(false)>
<BrowsableAttribute(false)>
Public Property Culture As CultureInfo
    Get
    Set
[<SerializeSettingAttribute(false)>]
[<BrowsableAttribute(false)>]
member Culture : CultureInfo with get, set

function get_Culture();
function set_Culture(value);
public:
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
property CultureInfo^ Culture {
    CultureInfo^ get ();
    void set (CultureInfo^ value);
}

Property Value

Type: CultureInfo
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.Item Property

Grid Solutions Framework SettingsBaseItem Property
Gets or sets the value of the specified field or property.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string this[
    string name
] { get; set; }
Public Default Property Item (
    name As String
) As String
    Get
    Set
member Item : string with get, set

function get_Item(name);
function set_Item(value);
public:
property String^ default[String^ name] {
    String^ get (String^ name);
    void set (String^ name, String^ value);
}

Parameters

name
Type: SystemString
Field or property name.

Return Value

Type: String
Value of setting.
Remarks
This is the default member of this class.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.MemberAccessBindingFlags Property

Grid Solutions Framework SettingsBaseMemberAccessBindingFlags Property
Gets or sets BindingFlags used to access fields and properties of derived class.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
protected virtual BindingFlags MemberAccessBindingFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Protected Overridable Property MemberAccessBindingFlags As BindingFlags
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
abstract MemberAccessBindingFlags : BindingFlags with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
override MemberAccessBindingFlags : BindingFlags with get, set
function get_MemberAccessBindingFlags();
function set_MemberAccessBindingFlags(value);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
virtual property BindingFlags MemberAccessBindingFlags {
    BindingFlags get ();
    void set (BindingFlags value);
}

Property Value

Type: BindingFlags
Remarks
Value defaults to Public | Instance | DeclaredOnly.
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingsBase.RequireSerializeSettingAttribute Property

Grid Solutions Framework SettingsBaseRequireSerializeSettingAttribute Property
Gets or sets flag that determines if SerializeSettingAttribute is required to exist before a field or property is serialized to the configuration file; defaults to False.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
public bool RequireSerializeSettingAttribute { get; set; }
<SerializeSettingAttribute(false)>
<BrowsableAttribute(false)>
Public Property RequireSerializeSettingAttribute As Boolean
    Get
    Set
[<SerializeSettingAttribute(false)>]
[<BrowsableAttribute(false)>]
member RequireSerializeSettingAttribute : bool with get, set

function get_RequireSerializeSettingAttribute();
function set_RequireSerializeSettingAttribute(value);
public:
[SerializeSettingAttribute(false)]
[BrowsableAttribute(false)]
property bool RequireSerializeSettingAttribute {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SettingsBase Class
GSF.Configuration Namespace


SettingScope Enumeration

Grid Solutions Framework SettingScope Enumeration
Specifies the scope of a setting represented by CategorizedSettingsElement.

Namespace: GSF.Configuration
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SettingScope
Public Enumeration SettingScope
type SettingScope
GSF.Configuration.SettingScope = function();
GSF.Configuration.SettingScope.createEnum('GSF.Configuration.SettingScope', false);
public enum class SettingScope
Members
Member name | Value | Description
User | 0 | Settings is intended for user specific use.
Application | 1 | Settings is intended for application wide use.
See Also

Reference

GSF.Configuration Namespace


GSF.Console Namespace

Grid Solutions Framework GSF.Console Namespace
Contains classes used for parsing command line parameters and managing console applications.
Classes
 | Class | Description
 | Arguments | Represents an ordered set of arguments along with optional arguments parsed from a command-line.
Public class | Command | Defines methods related to command line operations
Public class | CommandException | Represents an exception that is thrown when Execute(String, String, Int32) reports standard error output.
Public class | CommandResponse | Represents a response that is returned from Execute(String, String, Int32) with standard output and exit code.
 | Events | Defines a set of consumable events that can be raised by a console application.


Arguments Class

Grid Solutions Framework Arguments Class
Represents an ordered set of arguments along with optional arguments parsed from a command-line.
Inheritance Hierarchy
SystemObject
GSF.ConsoleArguments

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class Arguments : IEnumerable<KeyValuePair<string, string>>,
    IEnumerable, ISerializable
<SerializableAttribute>
Public Class Arguments
    Implements IEnumerable(Of KeyValuePair(Of String, String)),
    IEnumerable, ISerializable
[<SerializableAttribute>]
type Arguments =
    class
        interface IEnumerable<KeyValuePair<string, string>>
        interface IEnumerable
        interface ISerializable
    end
GSF.Console.Arguments = function();

Type.createClass(
    'GSF.Console.Arguments',
    null,
    IEnumerable`1,
    IEnumerable,
    ISerializable);
[SerializableAttribute]
public ref class Arguments : IEnumerable<KeyValuePair<String^, String^>>,
    IEnumerable, ISerializable

The Arguments type exposes the following members.

Constructors
 | Name | Description
Public method | Arguments(String) | Initializes a new instance of the Arguments class.
Protected method | Arguments(SerializationInfo, StreamingContext) | Creates a new Arguments from serialization parameters.
Public method | Arguments(String, Boolean) | Initializes a new instance of the Arguments class.
Public method | Arguments(String, String) | Initializes a new instance of the Arguments class.
Public method | Arguments(String, String, Boolean) | Initializes a new instance of the Arguments class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Gets a boolean value that indicates whether the specified argument is present in the command-line command.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator for iterating through all the command-line command arguments.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseCommand | This function can be used to parse a single parameterized string and turn it into an array of parameters.
Public method | ToString | Gets a string representation of the Arguments object. (Overrides ObjectToString.)
Public method | TryGetValue | Gets the value associated with the specified argument in the command-line command.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByKeyValuePairString, String, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityKeyValuePairString, String | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairString, String(KeyValuePairString, String) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairString, String(FuncKeyValuePairString, String, KeyValuePairString, String, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairString, String(IComparerKeyValuePairString, String) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairString, String, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairString, String(FuncKeyValuePairString, String, KeyValuePairString, String, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairString, String(IComparerKeyValuePairString, String) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairString, String, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairString, String | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairString, String(KeyValuePairString, String) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairString, String | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairString, String(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairString, String(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
Fields
Name | Description
DefaultOrderedArgID | Default value for OrderedArgID.
Top
Properties
 | Name | Description
Public property | ContainsHelpRequest | Gets a boolean value that indicates whether the command-line command contains request for displaying help.
Public property | Count | Gets the total number of arguments (ordered and optional) present in the command-line command.
Protected property | InternalDictionary | Gets the dictionary containing all of the arguments present in the command-line command.
Public property | Item | Gets the value for the specified argument from the command-line command.
Public property | OrderedArgCount | Gets the total number of ordered arguments in the command-line command.
Public property | OrderedArgID | Gets the prefix text in the identifier of ordered arguments present in the command-line command.
Public property | OrderedArgs | Gets the ordered arguments as an array of strings.
Top
Examples
This example shows how to parse a command-line command that does not contain an executable name:
Copy
using System;
using GSF;
using GSF.Console;

class Program
{
    static void Main()
    {
        Arguments args = new Arguments("Sample.txt -wrap=true");
        string file = args["OrderedArg1"];
        bool wrapText = args["wrap"].ParseBoolean();

        Console.WriteLine(string.Format("File: {0}", file));
        Console.WriteLine(string.Format("Wrap text: {0}", wrapText));
        Console.ReadLine();
    }
}
This example shows how to parse a command-line command that contains an executable name in it:
Copy
using System;
using GSF.Console;

class Program
{
    static void Main()
    {
        // Environment.CommandLine = @"""c:\program files\tva\theme application\app.exe"" Document1.dcx -theme=default"
        Arguments args = new Arguments(Environment.CommandLine, true);
        string doc = args["OrderedArg1"];
        string theme = args["theme"];

        Console.WriteLine(string.Format("Document: {0}", doc));
        Console.WriteLine(string.Format("Application theme: {0}", theme));
        Console.ReadLine();
    }
}
See Also

Reference

GSF.Console Namespace


Arguments Constructor

Grid Solutions Framework Arguments Constructor
Overload List
 | Name | Description
Public method | Arguments(String) | Initializes a new instance of the Arguments class.
Protected method | Arguments(SerializationInfo, StreamingContext) | Creates a new Arguments from serialization parameters.
Public method | Arguments(String, Boolean) | Initializes a new instance of the Arguments class.
Public method | Arguments(String, String) | Initializes a new instance of the Arguments class.
Public method | Arguments(String, String, Boolean) | Initializes a new instance of the Arguments class.
Top
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments Constructor (String)

Grid Solutions Framework Arguments Constructor (String)
Initializes a new instance of the Arguments class.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Arguments(
    string commandLine
)
Public Sub New (
    commandLine As String
)
new :
        commandLine : string -> Arguments
GSF.Console.Arguments = function(commandLine);
public:
Arguments(
    String^ commandLine
)

Parameters

commandLine
Type: SystemString
The command-line command to be parsed.
See Also

Reference

Arguments Class
Arguments Overload
GSF.Console Namespace


Arguments Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework Arguments Constructor (SerializationInfo, StreamingContext)
Creates a new Arguments from serialization parameters.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Arguments(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> Arguments
GSF.Console.Arguments = function(info, context);
protected:
Arguments(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

Arguments Class
Arguments Overload
GSF.Console Namespace


Arguments Constructor (String, Boolean)

Grid Solutions Framework Arguments Constructor (String, Boolean)
Initializes a new instance of the Arguments class.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Arguments(
    string commandLine,
    bool skipFirstArgument
)
Public Sub New (
    commandLine As String,
    skipFirstArgument As Boolean
)
new :
        commandLine : string *
        skipFirstArgument : bool -> Arguments
GSF.Console.Arguments = function(commandLine, skipFirstArgument);
public:
Arguments(
    String^ commandLine,
    bool skipFirstArgument
)

Parameters

commandLine
Type: SystemString
The command-line command to be parsed.
skipFirstArgument
Type: SystemBoolean
true if the first argument in the command-line command is to be skipped from being processed; otherwise false.
See Also

Reference

Arguments Class
Arguments Overload
GSF.Console Namespace


Arguments Constructor (String, String)

Grid Solutions Framework Arguments Constructor (String, String)
Initializes a new instance of the Arguments class.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Arguments(
    string commandLine,
    string orderedArgID
)
Public Sub New (
    commandLine As String,
    orderedArgID As String
)
new :
        commandLine : string *
        orderedArgID : string -> Arguments
GSF.Console.Arguments = function(commandLine, orderedArgID);
public:
Arguments(
    String^ commandLine,
    String^ orderedArgID
)

Parameters

commandLine
Type: SystemString
The command-line command to be parsed.
orderedArgID
Type: SystemString
The prefix to be used in the identifier of ordered arguments.
See Also

Reference

Arguments Class
Arguments Overload
GSF.Console Namespace


Arguments Constructor (String, String, Boolean)

Grid Solutions Framework Arguments Constructor (String, String, Boolean)
Initializes a new instance of the Arguments class.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Arguments(
    string commandLine,
    string orderedArgID,
    bool skipFirstArgument
)
Public Sub New (
    commandLine As String,
    orderedArgID As String,
    skipFirstArgument As Boolean
)
new :
        commandLine : string *
        orderedArgID : string *
        skipFirstArgument : bool -> Arguments
GSF.Console.Arguments = function(commandLine, orderedArgID, skipFirstArgument);
public:
Arguments(
    String^ commandLine,
    String^ orderedArgID,
    bool skipFirstArgument
)

Parameters

commandLine
Type: SystemString
The command-line command to be parsed.
orderedArgID
Type: SystemString
The prefix to be used in the identifier of ordered arguments.
skipFirstArgument
Type: SystemBoolean
true if the first argument in the command-line command is to be skipped from being processed; otherwise false.
See Also

Reference

Arguments Class
Arguments Overload
GSF.Console Namespace


Arguments Fields

Grid Solutions Framework Arguments Fields

The Arguments type exposes the following members.

Fields
Name | Description
DefaultOrderedArgID | Default value for OrderedArgID.
Top
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.DefaultOrderedArgID Field

Grid Solutions Framework ArgumentsDefaultOrderedArgID Field
Default value for OrderedArgID.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultOrderedArgID
Public Const DefaultOrderedArgID As String
static val mutable DefaultOrderedArgID: string
var GSF.Console.Arguments.DefaultOrderedArgID
public:
literal String^ DefaultOrderedArgID

Field Value

Type: String
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments Methods

Grid Solutions Framework Arguments Methods

The Arguments type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Exists | Gets a boolean value that indicates whether the specified argument is present in the command-line command.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an IEnumerator for iterating through all the command-line command arguments.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseCommand | This function can be used to parse a single parameterized string and turn it into an array of parameters.
Public method | ToString | Gets a string representation of the Arguments object. (Overrides ObjectToString.)
Public method | TryGetValue | Gets the value associated with the specified argument in the command-line command.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByKeyValuePairString, String, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityKeyValuePairString, String | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityKeyValuePairString, String(KeyValuePairString, String) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairString, String(FuncKeyValuePairString, String, KeyValuePairString, String, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxKeyValuePairString, String(IComparerKeyValuePairString, String) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByKeyValuePairString, String, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairString, String(FuncKeyValuePairString, String, KeyValuePairString, String, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinKeyValuePairString, String(IComparerKeyValuePairString, String) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByKeyValuePairString, String, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairString, String | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityKeyValuePairString, String(KeyValuePairString, String) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairString, String | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairString, String(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringKeyValuePairString, String(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.Exists Method

Grid Solutions Framework ArgumentsExists Method
Gets a boolean value that indicates whether the specified argument is present in the command-line command.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Exists(
    string argument
)
Public Overridable Function Exists (
    argument As String
) As Boolean
abstract Exists :
        argument : string -> bool
override Exists :
        argument : string -> bool
function Exists(argument);
public:
virtual bool Exists(
    String^ argument
)

Parameters

argument
Type: SystemString
The argument to be checked.

Return Value

Type: Boolean
true if the argument exists in the command-line command; otherwise false.
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.GetEnumerator Method

Grid Solutions Framework ArgumentsGetEnumerator Method
Returns an IEnumerator for iterating through all the command-line command arguments.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerator<KeyValuePair<string, string>> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of KeyValuePair(Of String, String))
abstract GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>
override GetEnumerator : unit -> IEnumerator<KeyValuePair<string, string>>
function GetEnumerator();
public:
virtual IEnumerator<KeyValuePair<String^, String^>>^ GetEnumerator() sealed

Return Value

Type: IEnumerator KeyValuePair String, String
An IEnumerator for the command-line command arguments.

Implements

IEnumerableTGetEnumerator
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.GetObjectData Method

Grid Solutions Framework ArgumentsGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.ParseCommand Method

Grid Solutions Framework ArgumentsParseCommand Method
This function can be used to parse a single parameterized string and turn it into an array of parameters.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] ParseCommand(
    string command
)
Public Shared Function ParseCommand (
    command As String
) As String()
static member ParseCommand :
        command : string -> string[]

GSF.Console.Arguments.ParseCommand = function(command);
public:
static array<String^>^ ParseCommand(
    String^ command
)

Parameters

command
Type: SystemString
String of parameters.

Return Value

Type: String
Array of parameters.
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.ToString Method

Grid Solutions Framework ArgumentsToString Method
Gets a string representation of the Arguments object.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A string representation of the Arguments object.
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.TryGetValue Method

Grid Solutions Framework ArgumentsTryGetValue Method
Gets the value associated with the specified argument in the command-line command.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryGetValue(
    string argument,
    out string value
)
Public Overridable Function TryGetValue (
    argument As String,
    <OutAttribute> ByRef value As String
) As Boolean
abstract TryGetValue :
        argument : string *
        value : string byref -> bool
override TryGetValue :
        argument : string *
        value : string byref -> bool
function TryGetValue(argument, value);
public:
virtual bool TryGetValue(
    String^ argument,
    [OutAttribute] String^% value
)

Parameters

argument
Type: SystemString
The argument whose value is to be retrieved.
value
Type: SystemString
Value associated with the specified argument if it exists in the command-line command, otherwise null.

Return Value

Type: Boolean
true if argument existed and was returned; otherwise false.
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments Properties

Grid Solutions Framework Arguments Properties

The Arguments type exposes the following members.

Properties
 | Name | Description
Public property | ContainsHelpRequest | Gets a boolean value that indicates whether the command-line command contains request for displaying help.
Public property | Count | Gets the total number of arguments (ordered and optional) present in the command-line command.
Protected property | InternalDictionary | Gets the dictionary containing all of the arguments present in the command-line command.
Public property | Item | Gets the value for the specified argument from the command-line command.
Public property | OrderedArgCount | Gets the total number of ordered arguments in the command-line command.
Public property | OrderedArgID | Gets the prefix text in the identifier of ordered arguments present in the command-line command.
Public property | OrderedArgs | Gets the ordered arguments as an array of strings.
Top
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.ContainsHelpRequest Property

Grid Solutions Framework ArgumentsContainsHelpRequest Property
Gets a boolean value that indicates whether the command-line command contains request for displaying help.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool ContainsHelpRequest { get; }
Public Overridable ReadOnly Property ContainsHelpRequest As Boolean
    Get
abstract ContainsHelpRequest : bool with get
override ContainsHelpRequest : bool with get
function get_ContainsHelpRequest();

public:
virtual property bool ContainsHelpRequest {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.Count Property

Grid Solutions Framework ArgumentsCount Property
Gets the total number of arguments (ordered and optional) present in the command-line command.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int Count { get; }
Public Overridable ReadOnly Property Count As Integer
    Get
abstract Count : int with get
override Count : int with get
function get_Count();

public:
virtual property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.InternalDictionary Property

Grid Solutions Framework ArgumentsInternalDictionary Property
Gets the dictionary containing all of the arguments present in the command-line command.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Dictionary<string, string> InternalDictionary { get; }
Protected ReadOnly Property InternalDictionary As Dictionary(Of String, String)
    Get
member InternalDictionary : Dictionary<string, string> with get

function get_InternalDictionary();

protected:
property Dictionary<String^, String^>^ InternalDictionary {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary String, String
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.Item Property

Grid Solutions Framework ArgumentsItem Property
Gets the value for the specified argument from the command-line command.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string this[
    string argument
] { get; }
Public Overridable ReadOnly Default Property Item (
    argument As String
) As String
    Get
abstract Item : string with get
override Item : string with get
function get_Item(argument);

public:
virtual property String^ default[String^ argument] {
    String^ get (String^ argument);
}

Parameters

argument
Type: SystemString
The argument whose value is to retrieved.

Return Value

Type: String
Value for the specified argument if found; otherwise null.
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.OrderedArgCount Property

Grid Solutions Framework ArgumentsOrderedArgCount Property
Gets the total number of ordered arguments in the command-line command.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int OrderedArgCount { get; }
Public Overridable ReadOnly Property OrderedArgCount As Integer
    Get
abstract OrderedArgCount : int with get
override OrderedArgCount : int with get
function get_OrderedArgCount();

public:
virtual property int OrderedArgCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.OrderedArgID Property

Grid Solutions Framework ArgumentsOrderedArgID Property
Gets the prefix text in the identifier of ordered arguments present in the command-line command.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string OrderedArgID { get; }
Public Overridable ReadOnly Property OrderedArgID As String
    Get
abstract OrderedArgID : string with get
override OrderedArgID : string with get
function get_OrderedArgID();

public:
virtual property String^ OrderedArgID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

Arguments Class
GSF.Console Namespace


Arguments.OrderedArgs Property

Grid Solutions Framework ArgumentsOrderedArgs Property
Gets the ordered arguments as an array of strings.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] OrderedArgs { get; }
Public Overridable ReadOnly Property OrderedArgs As String()
    Get
abstract OrderedArgs : string[] with get
override OrderedArgs : string[] with get
function get_OrderedArgs();

public:
virtual property array<String^>^ OrderedArgs {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

Arguments Class
GSF.Console Namespace


Command Class

Grid Solutions Framework Command Class
Defines methods related to command line operations
Inheritance Hierarchy
SystemObject
GSF.ConsoleCommand

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Command
<ExtensionAttribute>
Public NotInheritable Class Command
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Command =  class end
GSF.Console.Command = function();

Type.createClass(
    'GSF.Console.Command');
[ExtensionAttribute]
public ref class Command abstract sealed

The Command type exposes the following members.

Methods
Name | Description
Execute(String, String, Int32) | Executes a command line operation and returns its standard output and exit code or throws an exception with the standard error.
Execute(String, String, String, String, Int32) | Executes a command line operation and returns true if there was no standard error reported.
Execute(String, String, String, String, Boolean, Int32, Int32) | Executes a command line operation and returns true if there was no standard error reported.
ShellDecode | Decodes a command line parameter previously encoded by ShellEncode(String).
ShellEncode | Shell encodes a command line parameter by converting "\" to "\\".
Top
See Also

Reference

GSF.Console Namespace


Command Methods

Grid Solutions Framework Command Methods

The Command type exposes the following members.

Methods
Name | Description
Execute(String, String, Int32) | Executes a command line operation and returns its standard output and exit code or throws an exception with the standard error.
Execute(String, String, String, String, Int32) | Executes a command line operation and returns true if there was no standard error reported.
Execute(String, String, String, String, Boolean, Int32, Int32) | Executes a command line operation and returns true if there was no standard error reported.
ShellDecode | Decodes a command line parameter previously encoded by ShellEncode(String).
ShellEncode | Shell encodes a command line parameter by converting "\" to "\\".
Top
See Also

Reference

Command Class
GSF.Console Namespace


Command.Execute Method

Grid Solutions Framework CommandExecute Method
Overload List
Name | Description
Execute(String, String, Int32) | Executes a command line operation and returns its standard output and exit code or throws an exception with the standard error.
Execute(String, String, String, String, Int32) | Executes a command line operation and returns true if there was no standard error reported.
Execute(String, String, String, String, Boolean, Int32, Int32) | Executes a command line operation and returns true if there was no standard error reported.
Top
See Also

Reference

Command Class
GSF.Console Namespace


Command.Execute Method (String, String, Int32)

Grid Solutions Framework CommandExecute Method (String, String, Int32)
Executes a command line operation and returns its standard output and exit code or throws an exception with the standard error.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static CommandResponse Execute(
    string fileName,
    string arguments = null,
    int timeout = -1
)
Public Shared Function Execute (
    fileName As String,
    Optional arguments As String = Nothing,
    Optional timeout As Integer = -1
) As CommandResponse
static member Execute :
        fileName : string *
        ?arguments : string *
        ?timeout : int
(* Defaults:
        let _arguments = defaultArg arguments null
        let _timeout = defaultArg timeout -1
*)
-> CommandResponse

GSF.Console.Command.Execute = function(fileName, arguments, timeout);
public:
static CommandResponse^ Execute(
    String^ fileName,
    String^ arguments = nullptr,
    int timeout = -1
)

Parameters

fileName
Type: SystemString
Command line file name to execute.
arguments (Optional)
Type: SystemString
Command line arguments to use, if any.
timeout (Optional)
Type: SystemInt32
Timeout, in milliseconds, to wait for command line operation to complete.

Return Value

Type: CommandResponse
A CommandResponse containing the standard output received from command and the exit code.
Exceptions
Exception | Condition
CommandException | Exception occurs when executed command process reports standard error output or process times-out.
See Also

Reference

Command Class
Execute Overload
GSF.Console Namespace


Command.Execute Method (String, String, String, String, Int32)

Grid Solutions Framework CommandExecute Method (String, String, String, String, Int32)
Executes a command line operation and returns true if there was no standard error reported.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool Execute(
    string fileName,
    string arguments,
    out string standardOutput,
    out string standardError,
    out int exitCode
)
Public Shared Function Execute (
    fileName As String,
    arguments As String,
    <OutAttribute> ByRef standardOutput As String,
    <OutAttribute> ByRef standardError As String,
    <OutAttribute> ByRef exitCode As Integer
) As Boolean
static member Execute :
        fileName : string *
        arguments : string *
        standardOutput : string byref *
        standardError : string byref *
        exitCode : int byref -> bool

GSF.Console.Command.Execute = function(fileName, arguments, standardOutput, standardError, exitCode);
public:
static bool Execute(
    String^ fileName,
    String^ arguments,
    [OutAttribute] String^% standardOutput,
    [OutAttribute] String^% standardError,
    [OutAttribute] int% exitCode
)

Parameters

fileName
Type: SystemString
Command line file name to execute.
arguments
Type: SystemString
Command line arguments to use, if any.
standardOutput
Type: SystemString
Any standard output reported by the command line operation.
standardError
Type: SystemString
Any standard error reported by the command line operation.
exitCode
Type: SystemInt32
Exit code of the process, assuming process successfully completed.

Return Value

Type: Boolean
true if there was no standard error reported; otherwise, false.
Remarks
This function waits indefinitely for the command line operation to complete.
See Also

Reference

Command Class
Execute Overload
GSF.Console Namespace


Command.Execute Method (String, String, String, String, Boolean, Int32, Int32)

Grid Solutions Framework CommandExecute Method (String, String, String, String, Boolean, Int32, Int32)
Executes a command line operation and returns true if there was no standard error reported.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool Execute(
    string fileName,
    string arguments,
    out string standardOutput,
    out string standardError,
    out bool processCompleted,
    out int exitCode,
    int timeout
)
Public Shared Function Execute (
    fileName As String,
    arguments As String,
    <OutAttribute> ByRef standardOutput As String,
    <OutAttribute> ByRef standardError As String,
    <OutAttribute> ByRef processCompleted As Boolean,
    <OutAttribute> ByRef exitCode As Integer,
    timeout As Integer
) As Boolean
static member Execute :
        fileName : string *
        arguments : string *
        standardOutput : string byref *
        standardError : string byref *
        processCompleted : bool byref *
        exitCode : int byref *
        timeout : int -> bool

GSF.Console.Command.Execute = function(fileName, arguments, standardOutput, standardError, processCompleted, exitCode, timeout);
public:
static bool Execute(
    String^ fileName,
    String^ arguments,
    [OutAttribute] String^% standardOutput,
    [OutAttribute] String^% standardError,
    [OutAttribute] bool% processCompleted,
    [OutAttribute] int% exitCode,
    int timeout
)

Parameters

fileName
Type: SystemString
Command line file name to execute.
arguments
Type: SystemString
Command line arguments to use, if any.
standardOutput
Type: SystemString
Any standard output reported by the command line operation.
standardError
Type: SystemString
Any standard error reported by the command line operation.
processCompleted
Type: SystemBoolean
Flag that determines if process completed or timed-out. This is only relevant if timeout is not -1.
exitCode
Type: SystemInt32
Exit code of the process, assuming process successfully completed.
timeout
Type: SystemInt32
Timeout, in milliseconds, to wait for command line operation to complete. Set to Infinite, i.e., -1, for infinite wait.

Return Value

Type: Boolean
true if there was no standard error reported; otherwise, false.
See Also

Reference

Command Class
Execute Overload
GSF.Console Namespace


Command.ShellDecode Method

Grid Solutions Framework CommandShellDecode Method
Decodes a command line parameter previously encoded by ShellEncode(String).

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ShellDecode(
    this string parameter
)
<ExtensionAttribute>
Public Shared Function ShellDecode (
    parameter As String
) As String
static member ShellDecode :
        parameter : string -> string

GSF.Console.Command.ShellDecode = function(parameter);
public:
[ExtensionAttribute]
static String^ ShellDecode(
    String^ parameter
)

Parameters

parameter
Type: SystemString
Parameter to decode.

Return Value

Type: String
Decoded parameter.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Command Class
GSF.Console Namespace


Command.ShellEncode Method

Grid Solutions Framework CommandShellEncode Method
Shell encodes a command line parameter by converting "\" to "\\".

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ShellEncode(
    this string parameter
)
<ExtensionAttribute>
Public Shared Function ShellEncode (
    parameter As String
) As String
static member ShellEncode :
        parameter : string -> string

GSF.Console.Command.ShellEncode = function(parameter);
public:
[ExtensionAttribute]
static String^ ShellEncode(
    String^ parameter
)

Parameters

parameter
Type: SystemString
Parameter to shell encode.

Return Value

Type: String
Shell encoded parameter.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Command Class
GSF.Console Namespace


CommandException Class

Grid Solutions Framework CommandException Class
Represents an exception that is thrown when Execute(String, String, Int32) reports standard error output.
Inheritance Hierarchy
SystemObject
SystemException
GSF.ConsoleCommandException

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandException : Exception
<SerializableAttribute>
Public Class CommandException
    Inherits Exception
[<SerializableAttribute>]
type CommandException =
    class
        inherit Exception
    end
GSF.Console.CommandException = function();

Type.createClass(
    'GSF.Console.CommandException',
    Exception);
[SerializableAttribute]
public ref class CommandException : public Exception

The CommandException type exposes the following members.

Constructors
 | Name | Description
Public method | CommandException | Creates a new CommandException.
Public method | CommandException(String, Boolean, Int32, Exception) | Creates a new CommandException with the specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExitCode | Gets exit code from command process, assuming successful process completion.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ProcessCompleted | Gets flag that determines if the source of this command exception completed processing.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Console Namespace


CommandException Constructor

Grid Solutions Framework CommandException Constructor
Overload List
 | Name | Description
Public method | CommandException | Creates a new CommandException.
Public method | CommandException(String, Boolean, Int32, Exception) | Creates a new CommandException with the specified parameters.
Top
See Also

Reference

CommandException Class
GSF.Console Namespace


CommandException Constructor

Grid Solutions Framework CommandException Constructor
Creates a new CommandException.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandException()
Public Sub New
new : unit -> CommandException
GSF.Console.CommandException = function();
public:
CommandException()
See Also

Reference

CommandException Class
CommandException Overload
GSF.Console Namespace


CommandException Constructor (String, Boolean, Int32, Exception)

Grid Solutions Framework CommandException Constructor (String, Boolean, Int32, Exception)
Creates a new CommandException with the specified parameters.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandException(
    string message,
    bool processCompleted,
    int exitCode,
    Exception innerException = null
)
Public Sub New (
    message As String,
    processCompleted As Boolean,
    exitCode As Integer,
    Optional innerException As Exception = Nothing
)
new :
        message : string *
        processCompleted : bool *
        exitCode : int *
        ?innerException : Exception
(* Defaults:
        let _innerException = defaultArg innerException null
*)
-> CommandException
GSF.Console.CommandException = function(message, processCompleted, exitCode, innerException);
public:
CommandException(
    String^ message,
    bool processCompleted,
    int exitCode,
    Exception^ innerException = nullptr
)

Parameters

message
Type: SystemString
The error message that explains the reason for the exception.
processCompleted
Type: SystemBoolean
Flag that determines if the source of command exception completed processing.
exitCode
Type: SystemInt32
Exit code of command process, assuming process successfully completed.
innerException (Optional)
Type: SystemException
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

CommandException Class
CommandException Overload
GSF.Console Namespace


CommandException Methods

Grid Solutions Framework CommandException Methods

The CommandException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandException Class
GSF.Console Namespace


CommandException Properties

Grid Solutions Framework CommandException Properties

The CommandException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | ExitCode | Gets exit code from command process, assuming successful process completion.
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ProcessCompleted | Gets flag that determines if the source of this command exception completed processing.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CommandException Class
GSF.Console Namespace


CommandException.ExitCode Property

Grid Solutions Framework CommandExceptionExitCode Property
Gets exit code from command process, assuming successful process completion.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ExitCode { get; }
Public ReadOnly Property ExitCode As Integer
    Get
member ExitCode : int with get

function get_ExitCode();

public:
property int ExitCode {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

CommandException Class
GSF.Console Namespace


CommandException.ProcessCompleted Property

Grid Solutions Framework CommandExceptionProcessCompleted Property
Gets flag that determines if the source of this command exception completed processing.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ProcessCompleted { get; }
Public ReadOnly Property ProcessCompleted As Boolean
    Get
member ProcessCompleted : bool with get

function get_ProcessCompleted();

public:
property bool ProcessCompleted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

CommandException Class
GSF.Console Namespace


CommandException Events

Grid Solutions Framework CommandException Events

The CommandException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CommandException Class
GSF.Console Namespace


CommandResponse Class

Grid Solutions Framework CommandResponse Class
Represents a response that is returned from Execute(String, String, Int32) with standard output and exit code.
Inheritance Hierarchy
SystemObject
GSF.ConsoleCommandResponse

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CommandResponse
Public Class CommandResponse
type CommandResponse =  class end
GSF.Console.CommandResponse = function();

Type.createClass(
    'GSF.Console.CommandResponse');
public ref class CommandResponse

The CommandResponse type exposes the following members.

Constructors
 | Name | Description
Public method | CommandResponse | Creates a new CommandResponse.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ExitCode | Gets exit code from command process.
Public property | StandardOutput | Gets standard output reported by command process.
Top
See Also

Reference

GSF.Console Namespace


CommandResponse Constructor

Grid Solutions Framework CommandResponse Constructor
Creates a new CommandResponse.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandResponse(
    string standardOutput,
    int exitCode
)
Public Sub New (
    standardOutput As String,
    exitCode As Integer
)
new :
        standardOutput : string *
        exitCode : int -> CommandResponse
GSF.Console.CommandResponse = function(standardOutput, exitCode);
public:
CommandResponse(
    String^ standardOutput,
    int exitCode
)

Parameters

standardOutput
Type: SystemString
Standard output of command process.
exitCode
Type: SystemInt32
Exit code of command process.
See Also

Reference

CommandResponse Class
GSF.Console Namespace


CommandResponse Methods

Grid Solutions Framework CommandResponse Methods

The CommandResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandResponse Class
GSF.Console Namespace


CommandResponse Properties

Grid Solutions Framework CommandResponse Properties

The CommandResponse type exposes the following members.

Properties
 | Name | Description
Public property | ExitCode | Gets exit code from command process.
Public property | StandardOutput | Gets standard output reported by command process.
Top
See Also

Reference

CommandResponse Class
GSF.Console Namespace


CommandResponse.ExitCode Property

Grid Solutions Framework CommandResponseExitCode Property
Gets exit code from command process.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ExitCode { get; }
Public ReadOnly Property ExitCode As Integer
    Get
member ExitCode : int with get

function get_ExitCode();

public:
property int ExitCode {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

CommandResponse Class
GSF.Console Namespace


CommandResponse.StandardOutput Property

Grid Solutions Framework CommandResponseStandardOutput Property
Gets standard output reported by command process.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StandardOutput { get; }
Public ReadOnly Property StandardOutput As String
    Get
member StandardOutput : string with get

function get_StandardOutput();

public:
property String^ StandardOutput {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

CommandResponse Class
GSF.Console Namespace


Events Class

Grid Solutions Framework Events Class
Defines a set of consumable events that can be raised by a console application.
Inheritance Hierarchy
SystemObject
GSF.ConsoleEvents

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Events
Public NotInheritable Class Events
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Events =  class end
GSF.Console.Events = function();

Type.createClass(
    'GSF.Console.Events');
public ref class Events abstract sealed

The Events type exposes the following members.

Methods
Name | Description
DisableRaisingEvents | Enables the raising of console application Events.
EnableRaisingEvents | Enables the raising of console application Events. Prior to calling this method, handlers must be defined for the Events raised by a console application.
Top
Events
Name | Description
BreakKeyPress | Occurs when CTRL+BREAK signal is received from keyboard input.
CancelKeyPress | Occurs when CTRL+C signal is received from keyboard input.
ConsoleClosing | Occurs when the user closes the console application window.
SystemShutdown | Occurs when the system is shutting down.
UserLoggingOff | Occurs when the user is logging off.
Top
Remarks
Note that no events will be raised by this class when running under Mono deployments, the class remains available in the Mono build as a stub to allow existing code to still compile and run.
Examples
This example shows how to subscribe to console application events:
Copy
using System;
using GSF.Console;

class Program
{
    static void Main(string[] args)
    {
        // Subscribe to console events.
        Events.CancelKeyPress += Events_CancelKeyPress;
        Events.ConsoleClosing += Events_ConsoleClosing;
        Events.EnableRaisingEvents();

        Console.ReadLine();
    }

    static void Events_CancelKeyPress(object sender, System.ComponentModel.CancelEventArgs e)
    {
        // Abort processing.
    }

    static void Events_ConsoleClosing(object sender, System.ComponentModel.CancelEventArgs e)
    {
        // Put clean-up code.
    }
}
See Also

Reference

GSF.Console Namespace


Events Methods

Grid Solutions Framework Events Methods

The Events type exposes the following members.

Methods
Name | Description
DisableRaisingEvents | Enables the raising of console application Events.
EnableRaisingEvents | Enables the raising of console application Events. Prior to calling this method, handlers must be defined for the Events raised by a console application.
Top
See Also

Reference

Events Class
GSF.Console Namespace


Events.DisableRaisingEvents Method

Grid Solutions Framework EventsDisableRaisingEvents Method
Enables the raising of console application Events.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DisableRaisingEvents()
Public Shared Sub DisableRaisingEvents
static member DisableRaisingEvents : unit -> unit

GSF.Console.Events.DisableRaisingEvents = function();
public:
static void DisableRaisingEvents()
Remarks
This method is currently ignored under Mono deployments.
See Also

Reference

Events Class
GSF.Console Namespace


Events.EnableRaisingEvents Method

Grid Solutions Framework EventsEnableRaisingEvents Method
Enables the raising of console application Events. Prior to calling this method, handlers must be defined for the Events raised by a console application.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EnableRaisingEvents()
Public Shared Sub EnableRaisingEvents
static member EnableRaisingEvents : unit -> unit

GSF.Console.Events.EnableRaisingEvents = function();
public:
static void EnableRaisingEvents()
Remarks
This method is currently ignored under Mono deployments.
See Also

Reference

Events Class
GSF.Console Namespace


Events Events

Grid Solutions Framework Events Events

The Events type exposes the following members.

Events
Name | Description
BreakKeyPress | Occurs when CTRL+BREAK signal is received from keyboard input.
CancelKeyPress | Occurs when CTRL+C signal is received from keyboard input.
ConsoleClosing | Occurs when the user closes the console application window.
SystemShutdown | Occurs when the system is shutting down.
UserLoggingOff | Occurs when the user is logging off.
Top
See Also

Reference

Events Class
GSF.Console Namespace


Events.BreakKeyPress Event

Grid Solutions Framework EventsBreakKeyPress Event
Occurs when CTRL+BREAK signal is received from keyboard input.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static event EventHandler<CancelEventArgs> BreakKeyPress
Public Shared Event BreakKeyPress As EventHandler(Of CancelEventArgs)
member BreakKeyPress : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

function add_BreakKeyPress(value);
function remove_BreakKeyPress(value);
public:
static  event EventHandler<CancelEventArgs^>^ BreakKeyPress {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}

Value

Type: SystemEventHandler CancelEventArgs
Remarks
EnableRaisingEvents method must be called to enable event publication.
See Also

Reference

Events Class
GSF.Console Namespace


Events.CancelKeyPress Event

Grid Solutions Framework EventsCancelKeyPress Event
Occurs when CTRL+C signal is received from keyboard input.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static event EventHandler<CancelEventArgs> CancelKeyPress
Public Shared Event CancelKeyPress As EventHandler(Of CancelEventArgs)
member CancelKeyPress : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

function add_CancelKeyPress(value);
function remove_CancelKeyPress(value);
public:
static  event EventHandler<CancelEventArgs^>^ CancelKeyPress {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}

Value

Type: SystemEventHandler CancelEventArgs
Remarks
EnableRaisingEvents method must be called to enable event publication.
See Also

Reference

Events Class
GSF.Console Namespace


Events.ConsoleClosing Event

Grid Solutions Framework EventsConsoleClosing Event
Occurs when the user closes the console application window.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static event EventHandler<CancelEventArgs> ConsoleClosing
Public Shared Event ConsoleClosing As EventHandler(Of CancelEventArgs)
member ConsoleClosing : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

function add_ConsoleClosing(value);
function remove_ConsoleClosing(value);
public:
static  event EventHandler<CancelEventArgs^>^ ConsoleClosing {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}

Value

Type: SystemEventHandler CancelEventArgs
Remarks
EnableRaisingEvents method must be called to enable event publication.
See Also

Reference

Events Class
GSF.Console Namespace


Events.SystemShutdown Event

Grid Solutions Framework EventsSystemShutdown Event
Occurs when the system is shutting down.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static event EventHandler SystemShutdown
Public Shared Event SystemShutdown As EventHandler
member SystemShutdown : IEvent<EventHandler,
    EventArgs>

function add_SystemShutdown(value);
function remove_SystemShutdown(value);
public:
static  event EventHandler^ SystemShutdown {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks
EnableRaisingEvents method must be called to enable event publication.
See Also

Reference

Events Class
GSF.Console Namespace


Events.UserLoggingOff Event

Grid Solutions Framework EventsUserLoggingOff Event
Occurs when the user is logging off.

Namespace: GSF.Console
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static event EventHandler UserLoggingOff
Public Shared Event UserLoggingOff As EventHandler
member UserLoggingOff : IEvent<EventHandler,
    EventArgs>

function add_UserLoggingOff(value);
function remove_UserLoggingOff(value);
public:
static  event EventHandler^ UserLoggingOff {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks
EnableRaisingEvents method must be called to enable event publication.
See Also

Reference

Events Class
GSF.Console Namespace


GSF.Data Namespace

Grid Solutions Framework GSF.Data Namespace
Contains extension functions used to simplify and standardize database access.
Classes
 | Class | Description
Public class | AdoDataConnection | Creates a new IDbConnection from any specified or configured ADO.NET data source.
Public class | DataExtensions | Defines extension functions related to database and SQL interaction.
Public class | DataSetEqualityComparer | Equality comparer for DataSet objects.
Public class | DataSetExtensions | Defines extension functions related to DataSet instances.
Enumerations
 | Enumeration | Description
Public enumeration | DatabaseType | Specifies the database type underlying an AdoDataConnection.
Public enumeration | DataType | Data types available to a DataSet object.


AdoDataConnection Class

Grid Solutions Framework AdoDataConnection Class
Creates a new IDbConnection from any specified or configured ADO.NET data source.
Inheritance Hierarchy
SystemObject
GSF.DataAdoDataConnection

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AdoDataConnection : IDisposable
Public Class AdoDataConnection
    Implements IDisposable
type AdoDataConnection =
    class
        interface IDisposable
    end
GSF.Data.AdoDataConnection = function();

Type.createClass(
    'GSF.Data.AdoDataConnection',
    null,
    IDisposable);
public ref class AdoDataConnection : IDisposable

The AdoDataConnection type exposes the following members.

Constructors
 | Name | Description
Public method | AdoDataConnection(String) | Creates and opens a new AdoDataConnection based on connection settings in configuration file.
Public method | AdoDataConnection(String, String) | Creates and opens a new AdoDataConnection from specified connectionString and dataProviderString.
Public method | AdoDataConnection(IDbConnection, Type, Boolean) | Creates a new AdoDataConnection from specified connection and adapterType.
Public method | AdoDataConnection(String, Type, Type) | Creates and opens a new AdoDataConnection from specified connectionString, connectionType, and adapterType.
Top
Methods
 | Name | Description
Public method | Bool | Returns proper Boolean implementation for connected AdoDataConnection database type.
Public method | Dispose | Releases all the resources used by the AdoDataConnection object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdoDataConnection object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery(String, Object) | Executes the SQL statement using Connection, and returns the number of rows affected.
Public method | ExecuteNonQuery(Int32, String, Object) | Executes the SQL statement using Connection, and returns the number of rows affected.
Public method | ExecuteReader(String, Object) | Executes the SQL statement using Connection, and builds a IDataReader.
Public method | ExecuteReader(Int32, String, Object) | Executes the SQL statement using Connection, and builds a IDataReader.
Public method | ExecuteScalar(String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.
Public method | ExecuteScalar(Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.
Public method | ExecuteScalarT(String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.
Public method | ExecuteScalarT(Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.
Public method | ExecuteScalarT(T, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.
Public method | ExecuteScalarT(T, Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.
Protected method | Finalize | Releases the unmanaged resources before the AdoDataConnection object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Guid(Guid) | Returns proper Guid implementation for connected AdoDataConnection database type.
Public method | Guid(DataRow, String) | Retrieves Guid from a DataRow field based on database type.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParameterizedQueryString | Creates a parameterized query string for the underlying database type based on the given format string and parameter names.
 | ReloadConfigurationSettings | Forces a reload of cached configuration connection settings.
Public method | RetrieveData(String, Object) | Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.
Public method | RetrieveData(Int32, String, Object) | Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.
Public method | RetrieveDataSet(String, Object) | Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
Public method | RetrieveDataSet(Int32, String, Object) | Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
Public method | RetrieveRow(String, Object) | Executes the SQL statement using Connection, and returns the first DataRow in the result set.
Public method | RetrieveRow(Int32, String, Object) | Executes the SQL statement using Connection, and returns the first DataRow in the result set.
 | ToDataProviderString | Generates a data provider string for the given connection type and adapter type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AdapterType | Gets the type of data adapter for configured ADO.NET data source.
Public property | Connection | Gets an open IDbConnection to configured ADO.NET data source.
Public property | DatabaseType | Gets or sets the type of the database underlying the AdoDataConnection.
Public property | DefaultIsloationLevel | Gets the default IsolationLevel for the connected AdoDataConnection database type.
Public property | IsJetEngine | Gets a value to indicate whether source database is Microsoft Access.
Public property | IsMySQL | Gets a value to indicate whether source database is MySQL.
Public property | IsOracle | Gets a value to indicate whether source database is Oracle.
Public property | IsSqlite | Gets a value to indicate whether source database is SQLite.
Public property | IsSQLServer | Gets a value to indicate whether source database is Microsoft SQL Server.
Public property | UtcNow | Gets current UTC date-time in an implementation that is proper for the connected AdoDataConnection database type.
Top
Remarks
Example connection and data provider strings:
Database type Example connection string / data provider string
SQL Server ConnectionString = "Data Source=serverName; Initial Catalog=databaseName; User ID=userName; Password=password"
DataProviderString = "AssemblyName={System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089}; ConnectionType=System.Data.SqlClient.SqlConnection; AdapterType=System.Data.SqlClient.SqlDataAdapter"
Oracle ConnectionString = "Data Source=tnsName; User ID=schemaUserName; Password=schemaPassword"
DataProviderString = "AssemblyName={Oracle.DataAccess, Version=2.112.2.0, Culture=neutral, PublicKeyToken=89b483f429c47342}; ConnectionType=Oracle.DataAccess.Client.OracleConnection; AdapterType=Oracle.DataAccess.Client.OracleDataAdapter"
MySQL ConnectionString = "Server=serverName; Database=databaseName; Uid=root; Pwd=password; allow user variables = true"
DataProviderString = "AssemblyName={MySql.Data, Version=6.3.6.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d}; ConnectionType=MySql.Data.MySqlClient.MySqlConnection; AdapterType=MySql.Data.MySqlClient.MySqlDataAdapter"
SQLite ConnectionString = "Data Source=databaseName.db; Version=3; Foreign Keys=True; FailIfMissing=True"
DataProviderString = "AssemblyName={System.Data.SQLite, Version=1.0.93.0, Culture=neutral, PublicKeyToken=db937bc2d44ff139}; ConnectionType=System.Data.SQLite.SQLiteConnection; AdapterType=System.Data.SQLite.SQLiteDataAdapter"
SQLite (Mono native driver) ConnectionString = "Data Source=./databaseName.db; Version=3; Foreign Keys=True; FailIfMissing=True"
DataProviderString = "AssemblyName={Mono.Data.Sqlite, Version=4.0.0.0, Culture=neutral, PublicKeyToken=0738eb9f132ed756}; ConnectionType=Mono.Data.Sqlite.SqliteConnection; AdapterType=Mono.Data.Sqlite.SqliteDataAdapter"
Access / OleDB ConnectionString = "Provider=Microsoft.Jet.OLEDB.4.0; Data Source=databaseName.mdb"
DataProviderString = "AssemblyName={System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089}; ConnectionType=System.Data.OleDb.OleDbConnection; AdapterType=System.Data.OleDb.OleDbDataAdapter"
ODBC Connection ConnectionString = "Driver={SQL Server Native Client 10.0}; Server=serverName; Database=databaseName; Uid=userName; Pwd=password"
DataProviderString = "AssemblyName={System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089}; ConnectionType=System.Data.Odbc.OdbcConnection; AdapterType=System.Data.Odbc.OdbcDataAdapter"
Example configuration file that defines connection settings:
Copy
<?xml version="1.0" encoding="utf-8"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <systemSettings>
      <add name="ConnectionString" value="Data Source=localhost\SQLEXPRESS; Initial Catalog=MyDatabase; Integrated Security=SSPI" description="ADO database connection string" encrypted="false" />
      <add name="DataProviderString" value="AssemblyName={System.Data, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089}; ConnectionType=System.Data.SqlClient.SqlConnection; AdapterType=System.Data.SqlClient.SqlDataAdapter" description="ADO database provider string" encrypted="false" />
    </systemSettings>
  </categorizedSettings>
  <startup>
    <supportedRuntime version="v4.0" sku=".NETFramework,Version=v4.5" />
  </startup>
</configuration>
See Also

Reference

GSF.Data Namespace


AdoDataConnection Constructor

Grid Solutions Framework AdoDataConnection Constructor
Overload List
 | Name | Description
Public method | AdoDataConnection(String) | Creates and opens a new AdoDataConnection based on connection settings in configuration file.
Public method | AdoDataConnection(String, String) | Creates and opens a new AdoDataConnection from specified connectionString and dataProviderString.
Public method | AdoDataConnection(IDbConnection, Type, Boolean) | Creates a new AdoDataConnection from specified connection and adapterType.
Public method | AdoDataConnection(String, Type, Type) | Creates and opens a new AdoDataConnection from specified connectionString, connectionType, and adapterType.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection Constructor (String)

Grid Solutions Framework AdoDataConnection Constructor (String)
Creates and opens a new AdoDataConnection based on connection settings in configuration file.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdoDataConnection(
    string settingsCategory
)
Public Sub New (
    settingsCategory As String
)
new :
        settingsCategory : string -> AdoDataConnection
GSF.Data.AdoDataConnection = function(settingsCategory);
public:
AdoDataConnection(
    String^ settingsCategory
)

Parameters

settingsCategory
Type: SystemString
Settings category to use for connection settings.
See Also

Reference

AdoDataConnection Class
AdoDataConnection Overload
GSF.Data Namespace


AdoDataConnection Constructor (String, String)

Grid Solutions Framework AdoDataConnection Constructor (String, String)
Creates and opens a new AdoDataConnection from specified connectionString and dataProviderString.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdoDataConnection(
    string connectionString,
    string dataProviderString
)
Public Sub New (
    connectionString As String,
    dataProviderString As String
)
new :
        connectionString : string *
        dataProviderString : string -> AdoDataConnection
GSF.Data.AdoDataConnection = function(connectionString, dataProviderString);
public:
AdoDataConnection(
    String^ connectionString,
    String^ dataProviderString
)

Parameters

connectionString
Type: SystemString
Database specific ADO connection string.
dataProviderString
Type: SystemString
Key/value pairs that define which ADO assembly and types to load.
See Also

Reference

AdoDataConnection Class
AdoDataConnection Overload
GSF.Data Namespace


AdoDataConnection Constructor (IDbConnection, Type, Boolean)

Grid Solutions Framework AdoDataConnection Constructor (IDbConnection, Type, Boolean)
Creates a new AdoDataConnection from specified connection and adapterType.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdoDataConnection(
    IDbConnection connection,
    Type adapterType,
    bool disposeConnection
)
Public Sub New (
    connection As IDbConnection,
    adapterType As Type,
    disposeConnection As Boolean
)
new :
        connection : IDbConnection *
        adapterType : Type *
        disposeConnection : bool -> AdoDataConnection
GSF.Data.AdoDataConnection = function(connection, adapterType, disposeConnection);
public:
AdoDataConnection(
    IDbConnection^ connection,
    Type^ adapterType,
    bool disposeConnection
)

Parameters

connection
Type: System.DataIDbConnection
The database connection.
adapterType
Type: SystemType
The ADO type used to load data into DataTables.
disposeConnection
Type: SystemBoolean
True if the database connection should be closed when the AdoDataConnection is disposed; false otherwise.
See Also

Reference

AdoDataConnection Class
AdoDataConnection Overload
GSF.Data Namespace


AdoDataConnection Constructor (String, Type, Type)

Grid Solutions Framework AdoDataConnection Constructor (String, Type, Type)
Creates and opens a new AdoDataConnection from specified connectionString, connectionType, and adapterType.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdoDataConnection(
    string connectionString,
    Type connectionType,
    Type adapterType
)
Public Sub New (
    connectionString As String,
    connectionType As Type,
    adapterType As Type
)
new :
        connectionString : string *
        connectionType : Type *
        adapterType : Type -> AdoDataConnection
GSF.Data.AdoDataConnection = function(connectionString, connectionType, adapterType);
public:
AdoDataConnection(
    String^ connectionString,
    Type^ connectionType,
    Type^ adapterType
)

Parameters

connectionString
Type: SystemString
Database specific ADO connection string.
connectionType
Type: SystemType
The ADO type used to establish the database connection.
adapterType
Type: SystemType
The ADO type used to load data into DataTables.
See Also

Reference

AdoDataConnection Class
AdoDataConnection Overload
GSF.Data Namespace


AdoDataConnection Methods

Grid Solutions Framework AdoDataConnection Methods

The AdoDataConnection type exposes the following members.

Methods
 | Name | Description
Public method | Bool | Returns proper Boolean implementation for connected AdoDataConnection database type.
Public method | Dispose | Releases all the resources used by the AdoDataConnection object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdoDataConnection object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExecuteNonQuery(String, Object) | Executes the SQL statement using Connection, and returns the number of rows affected.
Public method | ExecuteNonQuery(Int32, String, Object) | Executes the SQL statement using Connection, and returns the number of rows affected.
Public method | ExecuteReader(String, Object) | Executes the SQL statement using Connection, and builds a IDataReader.
Public method | ExecuteReader(Int32, String, Object) | Executes the SQL statement using Connection, and builds a IDataReader.
Public method | ExecuteScalar(String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.
Public method | ExecuteScalar(Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.
Public method | ExecuteScalarT(String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.
Public method | ExecuteScalarT(Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.
Public method | ExecuteScalarT(T, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.
Public method | ExecuteScalarT(T, Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.
Protected method | Finalize | Releases the unmanaged resources before the AdoDataConnection object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Guid(Guid) | Returns proper Guid implementation for connected AdoDataConnection database type.
Public method | Guid(DataRow, String) | Retrieves Guid from a DataRow field based on database type.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParameterizedQueryString | Creates a parameterized query string for the underlying database type based on the given format string and parameter names.
 | ReloadConfigurationSettings | Forces a reload of cached configuration connection settings.
Public method | RetrieveData(String, Object) | Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.
Public method | RetrieveData(Int32, String, Object) | Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.
Public method | RetrieveDataSet(String, Object) | Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
Public method | RetrieveDataSet(Int32, String, Object) | Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
Public method | RetrieveRow(String, Object) | Executes the SQL statement using Connection, and returns the first DataRow in the result set.
Public method | RetrieveRow(Int32, String, Object) | Executes the SQL statement using Connection, and returns the first DataRow in the result set.
 | ToDataProviderString | Generates a data provider string for the given connection type and adapter type.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.Bool Method

Grid Solutions Framework AdoDataConnectionBool Method
Returns proper Boolean implementation for connected AdoDataConnection database type.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object Bool(
    bool value
)
Public Function Bool (
    value As Boolean
) As Object
member Bool :
        value : bool -> Object

function Bool(value);
public:
Object^ Bool(
    bool value
)

Parameters

value
Type: SystemBoolean
Boolean to format per database type.

Return Value

Type: Object
Proper Boolean implementation for connected AdoDataConnection database type.
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.Dispose Method

Grid Solutions Framework AdoDataConnectionDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdoDataConnection object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdoDataConnection object and optionally releases the managed resources.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.Dispose Method

Grid Solutions Framework AdoDataConnectionDispose Method
Releases all the resources used by the AdoDataConnection object.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

AdoDataConnection Class
Dispose Overload
GSF.Data Namespace


AdoDataConnection.Dispose Method (Boolean)

Grid Solutions Framework AdoDataConnectionDispose Method (Boolean)
Releases the unmanaged resources used by the AdoDataConnection object and optionally releases the managed resources.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

AdoDataConnection Class
Dispose Overload
GSF.Data Namespace


AdoDataConnection.ExecuteNonQuery Method

Grid Solutions Framework AdoDataConnectionExecuteNonQuery Method
Overload List
 | Name | Description
Public method | ExecuteNonQuery(String, Object) | Executes the SQL statement using Connection, and returns the number of rows affected.
Public method | ExecuteNonQuery(Int32, String, Object) | Executes the SQL statement using Connection, and returns the number of rows affected.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.ExecuteNonQuery Method (String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteNonQuery Method (String, Object)
Executes the SQL statement using Connection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ExecuteNonQuery(
    string sqlFormat,
    params Object[] parameters
)
Public Function ExecuteNonQuery (
    sqlFormat As String,
    ParamArray parameters As Object()
) As Integer
member ExecuteNonQuery :
        sqlFormat : string *
        parameters : Object[] -> int

function ExecuteNonQuery(sqlFormat, ... parameters);
public:
int ExecuteNonQuery(
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: Int32
The number of rows affected.
See Also

Reference

AdoDataConnection Class
ExecuteNonQuery Overload
GSF.Data Namespace


AdoDataConnection.ExecuteNonQuery Method (Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteNonQuery Method (Int32, String, Object)
Executes the SQL statement using Connection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ExecuteNonQuery(
    int timeout,
    string sqlFormat,
    params Object[] parameters
)
Public Function ExecuteNonQuery (
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As Integer
member ExecuteNonQuery :
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> int

function ExecuteNonQuery(timeout, sqlFormat, ... parameters);
public:
int ExecuteNonQuery(
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: Int32
The number of rows affected.
See Also

Reference

AdoDataConnection Class
ExecuteNonQuery Overload
GSF.Data Namespace


AdoDataConnection.ExecuteReader Method

Grid Solutions Framework AdoDataConnectionExecuteReader Method
Overload List
 | Name | Description
Public method | ExecuteReader(String, Object) | Executes the SQL statement using Connection, and builds a IDataReader.
Public method | ExecuteReader(Int32, String, Object) | Executes the SQL statement using Connection, and builds a IDataReader.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.ExecuteReader Method (String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteReader Method (String, Object)
Executes the SQL statement using Connection, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDataReader ExecuteReader(
    string sqlFormat,
    params Object[] parameters
)
Public Function ExecuteReader (
    sqlFormat As String,
    ParamArray parameters As Object()
) As IDataReader
member ExecuteReader :
        sqlFormat : string *
        parameters : Object[] -> IDataReader

function ExecuteReader(sqlFormat, ... parameters);
public:
IDataReader^ ExecuteReader(
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: IDataReader
A IDataReader object.
See Also

Reference

AdoDataConnection Class
ExecuteReader Overload
GSF.Data Namespace


AdoDataConnection.ExecuteReader Method (Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteReader Method (Int32, String, Object)
Executes the SQL statement using Connection, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDataReader ExecuteReader(
    int timeout,
    string sqlFormat,
    params Object[] parameters
)
Public Function ExecuteReader (
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As IDataReader
member ExecuteReader :
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> IDataReader

function ExecuteReader(timeout, sqlFormat, ... parameters);
public:
IDataReader^ ExecuteReader(
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: IDataReader
A IDataReader object.
See Also

Reference

AdoDataConnection Class
ExecuteReader Overload
GSF.Data Namespace


AdoDataConnection.ExecuteScalar Method

Grid Solutions Framework AdoDataConnectionExecuteScalar Method
Overload List
 | Name | Description
Public method | ExecuteScalarT(String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.
Public method | ExecuteScalar(String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.
Public method | ExecuteScalarT(Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.
Public method | ExecuteScalar(Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.
Public method | ExecuteScalarT(T, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.
Public method | ExecuteScalarT(T, Int32, String, Object) | Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.ExecuteScalar(T) Method (String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteScalarT Method (String, Object)
Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T ExecuteScalar<T>(
    string sqlFormat,
    params Object[] parameters
)

Public Function ExecuteScalar(Of T) (
    sqlFormat As String,
    ParamArray parameters As Object()
) As T
member ExecuteScalar :
        sqlFormat : string *
        parameters : Object[] -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T ExecuteScalar(
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.Data.AdoDataConnection.ExecuteScalar``1(System.String,System.Object[])"]

Return Value

Type: T
Value in the first column of the first row in the result set.
See Also

Reference

AdoDataConnection Class
ExecuteScalar Overload
GSF.Data Namespace


AdoDataConnection.ExecuteScalar Method (String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteScalar Method (String, Object)
Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object ExecuteScalar(
    string sqlFormat,
    params Object[] parameters
)
Public Function ExecuteScalar (
    sqlFormat As String,
    ParamArray parameters As Object()
) As Object
member ExecuteScalar :
        sqlFormat : string *
        parameters : Object[] -> Object

function ExecuteScalar(sqlFormat, ... parameters);
public:
Object^ ExecuteScalar(
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: Object
Value in the first column of the first row in the result set.
See Also

Reference

AdoDataConnection Class
ExecuteScalar Overload
GSF.Data Namespace


AdoDataConnection.ExecuteScalar(T) Method (Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteScalarT Method (Int32, String, Object)
Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T ExecuteScalar<T>(
    int timeout,
    string sqlFormat,
    params Object[] parameters
)

Public Function ExecuteScalar(Of T) (
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As T
member ExecuteScalar :
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T ExecuteScalar(
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.Data.AdoDataConnection.ExecuteScalar``1(System.Int32,System.String,System.Object[])"]

Return Value

Type: T
Value in the first column of the first row in the result set.
See Also

Reference

AdoDataConnection Class
ExecuteScalar Overload
GSF.Data Namespace


AdoDataConnection.ExecuteScalar Method (Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteScalar Method (Int32, String, Object)
Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object ExecuteScalar(
    int timeout,
    string sqlFormat,
    params Object[] parameters
)
Public Function ExecuteScalar (
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As Object
member ExecuteScalar :
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> Object

function ExecuteScalar(timeout, sqlFormat, ... parameters);
public:
Object^ ExecuteScalar(
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: Object
Value in the first column of the first row in the result set.
See Also

Reference

AdoDataConnection Class
ExecuteScalar Overload
GSF.Data Namespace


AdoDataConnection.ExecuteScalar(T) Method (T, String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteScalarT Method (T, String, Object)
Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T ExecuteScalar<T>(
    T defaultValue,
    string sqlFormat,
    params Object[] parameters
)

Public Function ExecuteScalar(Of T) (
    defaultValue As T,
    sqlFormat As String,
    ParamArray parameters As Object()
) As T
member ExecuteScalar :
        defaultValue : 'T *
        sqlFormat : string *
        parameters : Object[] -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T ExecuteScalar(
    T defaultValue,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

defaultValue
Type: T
The value to be substituted if Value is retrieved.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.Data.AdoDataConnection.ExecuteScalar``1(``0,System.String,System.Object[])"]

Return Value

Type: T
Value in the first column of the first row in the result set.
See Also

Reference

AdoDataConnection Class
ExecuteScalar Overload
GSF.Data Namespace


AdoDataConnection.ExecuteScalar(T) Method (T, Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionExecuteScalarT Method (T, Int32, String, Object)
Executes the SQL statement using Connection, and returns the value in the first column of the first row in the result set as type T, substituting defaultValue if Value is retrieved.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T ExecuteScalar<T>(
    T defaultValue,
    int timeout,
    string sqlFormat,
    params Object[] parameters
)

Public Function ExecuteScalar(Of T) (
    defaultValue As T,
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As T
member ExecuteScalar :
        defaultValue : 'T *
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> 'T

JavaScript does not support generic types or methods.
public:
generic<typename T>
T ExecuteScalar(
    T defaultValue,
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

defaultValue
Type: T
The value to be substituted if Value is retrieved.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.Data.AdoDataConnection.ExecuteScalar``1(``0,System.Int32,System.String,System.Object[])"]

Return Value

Type: T
Value in the first column of the first row in the result set.
See Also

Reference

AdoDataConnection Class
ExecuteScalar Overload
GSF.Data Namespace


AdoDataConnection.Finalize Method

Grid Solutions Framework AdoDataConnectionFinalize Method
Releases the unmanaged resources before the AdoDataConnection object is reclaimed by GC.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.Guid Method

Grid Solutions Framework AdoDataConnectionGuid Method
Overload List
 | Name | Description
Public method | Guid(Guid) | Returns proper Guid implementation for connected AdoDataConnection database type.
Public method | Guid(DataRow, String) | Retrieves Guid from a DataRow field based on database type.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.Guid Method (Guid)

Grid Solutions Framework AdoDataConnectionGuid Method (Guid)
Returns proper Guid implementation for connected AdoDataConnection database type.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object Guid(
    Guid value
)
Public Function Guid (
    value As Guid
) As Object
member Guid :
        value : Guid -> Object

function Guid(value);
public:
Object^ Guid(
    Guid value
)

Parameters

value
Type: SystemGuid
Guid to format per database type.

Return Value

Type: Object
Proper Guid implementation for connected AdoDataConnection database type.
See Also

Reference

AdoDataConnection Class
Guid Overload
GSF.Data Namespace


AdoDataConnection.Guid Method (DataRow, String)

Grid Solutions Framework AdoDataConnectionGuid Method (DataRow, String)
Retrieves Guid from a DataRow field based on database type.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid Guid(
    DataRow row,
    string fieldName
)
Public Function Guid (
    row As DataRow,
    fieldName As String
) As Guid
member Guid :
        row : DataRow *
        fieldName : string -> Guid

function Guid(row, fieldName);
public:
Guid Guid(
    DataRow^ row,
    String^ fieldName
)

Parameters

row
Type: System.DataDataRow
DataRow from which value needs to be retrieved.
fieldName
Type: SystemString
Name of the field which contains Guid.

Return Value

Type: Guid
Guid.
See Also

Reference

AdoDataConnection Class
Guid Overload
GSF.Data Namespace


AdoDataConnection.ParameterizedQueryString Method

Grid Solutions Framework AdoDataConnectionParameterizedQueryString Method
Creates a parameterized query string for the underlying database type based on the given format string and parameter names.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ParameterizedQueryString(
    string format,
    params string[] parameterNames
)
Public Function ParameterizedQueryString (
    format As String,
    ParamArray parameterNames As String()
) As String
member ParameterizedQueryString :
        format : string *
        parameterNames : string[] -> string

function ParameterizedQueryString(format, ... parameterNames);
public:
String^ ParameterizedQueryString(
    String^ format,
    ... array<String^>^ parameterNames
)

Parameters

format
Type: SystemString
A composite format string.
parameterNames
Type: SystemString
A string array that contains zero or more parameter names to format.

Return Value

Type: String
A parameterized query string based on the given format and parameter names.
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.ReloadConfigurationSettings Method

Grid Solutions Framework AdoDataConnectionReloadConfigurationSettings Method
Forces a reload of cached configuration connection settings.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ReloadConfigurationSettings()
Public Shared Sub ReloadConfigurationSettings
static member ReloadConfigurationSettings : unit -> unit

GSF.Data.AdoDataConnection.ReloadConfigurationSettings = function();
public:
static void ReloadConfigurationSettings()
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.RetrieveData Method

Grid Solutions Framework AdoDataConnectionRetrieveData Method
Overload List
 | Name | Description
Public method | RetrieveData(String, Object) | Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.
Public method | RetrieveData(Int32, String, Object) | Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.RetrieveData Method (String, Object[])

Grid Solutions Framework AdoDataConnectionRetrieveData Method (String, Object)
Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataTable RetrieveData(
    string sqlFormat,
    params Object[] parameters
)
Public Function RetrieveData (
    sqlFormat As String,
    ParamArray parameters As Object()
) As DataTable
member RetrieveData :
        sqlFormat : string *
        parameters : Object[] -> DataTable

function RetrieveData(sqlFormat, ... parameters);
public:
DataTable^ RetrieveData(
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: DataTable
A DataTable object.
See Also

Reference

AdoDataConnection Class
RetrieveData Overload
GSF.Data Namespace


AdoDataConnection.RetrieveData Method (Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionRetrieveData Method (Int32, String, Object)
Executes the SQL statement using Connection, and returns the first DataTable of result set, if the result set contains at least one table.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataTable RetrieveData(
    int timeout,
    string sqlFormat,
    params Object[] parameters
)
Public Function RetrieveData (
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As DataTable
member RetrieveData :
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> DataTable

function RetrieveData(timeout, sqlFormat, ... parameters);
public:
DataTable^ RetrieveData(
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: DataTable
A DataTable object.
See Also

Reference

AdoDataConnection Class
RetrieveData Overload
GSF.Data Namespace


AdoDataConnection.RetrieveDataSet Method

Grid Solutions Framework AdoDataConnectionRetrieveDataSet Method
Overload List
 | Name | Description
Public method | RetrieveDataSet(String, Object) | Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
Public method | RetrieveDataSet(Int32, String, Object) | Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.RetrieveDataSet Method (String, Object[])

Grid Solutions Framework AdoDataConnectionRetrieveDataSet Method (String, Object)
Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet RetrieveDataSet(
    string sqlFormat,
    params Object[] parameters
)
Public Function RetrieveDataSet (
    sqlFormat As String,
    ParamArray parameters As Object()
) As DataSet
member RetrieveDataSet :
        sqlFormat : string *
        parameters : Object[] -> DataSet

function RetrieveDataSet(sqlFormat, ... parameters);
public:
DataSet^ RetrieveDataSet(
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: DataSet
A DataSet object.
See Also

Reference

AdoDataConnection Class
RetrieveDataSet Overload
GSF.Data Namespace


AdoDataConnection.RetrieveDataSet Method (Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionRetrieveDataSet Method (Int32, String, Object)
Executes the SQL statement using Connection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet RetrieveDataSet(
    int timeout,
    string sqlFormat,
    params Object[] parameters
)
Public Function RetrieveDataSet (
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As DataSet
member RetrieveDataSet :
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> DataSet

function RetrieveDataSet(timeout, sqlFormat, ... parameters);
public:
DataSet^ RetrieveDataSet(
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: DataSet
A DataSet object.
See Also

Reference

AdoDataConnection Class
RetrieveDataSet Overload
GSF.Data Namespace


AdoDataConnection.RetrieveRow Method

Grid Solutions Framework AdoDataConnectionRetrieveRow Method
Overload List
 | Name | Description
Public method | RetrieveRow(String, Object) | Executes the SQL statement using Connection, and returns the first DataRow in the result set.
Public method | RetrieveRow(Int32, String, Object) | Executes the SQL statement using Connection, and returns the first DataRow in the result set.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.RetrieveRow Method (String, Object[])

Grid Solutions Framework AdoDataConnectionRetrieveRow Method (String, Object)
Executes the SQL statement using Connection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataRow RetrieveRow(
    string sqlFormat,
    params Object[] parameters
)
Public Function RetrieveRow (
    sqlFormat As String,
    ParamArray parameters As Object()
) As DataRow
member RetrieveRow :
        sqlFormat : string *
        parameters : Object[] -> DataRow

function RetrieveRow(sqlFormat, ... parameters);
public:
DataRow^ RetrieveRow(
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: DataRow
The first DataRow in the result set.
See Also

Reference

AdoDataConnection Class
RetrieveRow Overload
GSF.Data Namespace


AdoDataConnection.RetrieveRow Method (Int32, String, Object[])

Grid Solutions Framework AdoDataConnectionRetrieveRow Method (Int32, String, Object)
Executes the SQL statement using Connection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataRow RetrieveRow(
    int timeout,
    string sqlFormat,
    params Object[] parameters
)
Public Function RetrieveRow (
    timeout As Integer,
    sqlFormat As String,
    ParamArray parameters As Object()
) As DataRow
member RetrieveRow :
        timeout : int *
        sqlFormat : string *
        parameters : Object[] -> DataRow

function RetrieveRow(timeout, sqlFormat, ... parameters);
public:
DataRow^ RetrieveRow(
    int timeout,
    String^ sqlFormat,
    ... array<Object^>^ parameters
)

Parameters

timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
sqlFormat
Type: SystemString
Format string for the SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters.

Return Value

Type: DataRow
The first DataRow in the result set.
See Also

Reference

AdoDataConnection Class
RetrieveRow Overload
GSF.Data Namespace


AdoDataConnection.ToDataProviderString Method

Grid Solutions Framework AdoDataConnectionToDataProviderString Method
Generates a data provider string for the given connection type and adapter type.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToDataProviderString(
    Type connectionType,
    Type adapterType
)
Public Shared Function ToDataProviderString (
    connectionType As Type,
    adapterType As Type
) As String
static member ToDataProviderString :
        connectionType : Type *
        adapterType : Type -> string

GSF.Data.AdoDataConnection.ToDataProviderString = function(connectionType, adapterType);
public:
static String^ ToDataProviderString(
    Type^ connectionType,
    Type^ adapterType
)

Parameters

connectionType
Type: SystemType
The type used to establish a connection to the database.
adapterType
Type: SystemType
The type used to load data from the database into a data table.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.Data.AdoDataConnection.ToDataProviderString(System.Type,System.Type)"]

See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection Properties

Grid Solutions Framework AdoDataConnection Properties

The AdoDataConnection type exposes the following members.

Properties
 | Name | Description
Public property | AdapterType | Gets the type of data adapter for configured ADO.NET data source.
Public property | Connection | Gets an open IDbConnection to configured ADO.NET data source.
Public property | DatabaseType | Gets or sets the type of the database underlying the AdoDataConnection.
Public property | DefaultIsloationLevel | Gets the default IsolationLevel for the connected AdoDataConnection database type.
Public property | IsJetEngine | Gets a value to indicate whether source database is Microsoft Access.
Public property | IsMySQL | Gets a value to indicate whether source database is MySQL.
Public property | IsOracle | Gets a value to indicate whether source database is Oracle.
Public property | IsSqlite | Gets a value to indicate whether source database is SQLite.
Public property | IsSQLServer | Gets a value to indicate whether source database is Microsoft SQL Server.
Public property | UtcNow | Gets current UTC date-time in an implementation that is proper for the connected AdoDataConnection database type.
Top
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.AdapterType Property

Grid Solutions Framework AdoDataConnectionAdapterType Property
Gets the type of data adapter for configured ADO.NET data source.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Type AdapterType { get; }
Public ReadOnly Property AdapterType As Type
    Get
member AdapterType : Type with get

function get_AdapterType();

public:
property Type^ AdapterType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.Connection Property

Grid Solutions Framework AdoDataConnectionConnection Property
Gets an open IDbConnection to configured ADO.NET data source.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDbConnection Connection { get; }
Public ReadOnly Property Connection As IDbConnection
    Get
member Connection : IDbConnection with get

function get_Connection();

public:
property IDbConnection^ Connection {
    IDbConnection^ get ();
}

Property Value

Type: IDbConnection
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.DatabaseType Property

Grid Solutions Framework AdoDataConnectionDatabaseType Property
Gets or sets the type of the database underlying the AdoDataConnection.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DatabaseType DatabaseType { get; set; }
Public Property DatabaseType As DatabaseType
    Get
    Set
member DatabaseType : DatabaseType with get, set

function get_DatabaseType();
function set_DatabaseType(value);
public:
property DatabaseType DatabaseType {
    DatabaseType get ();
    void set (DatabaseType value);
}

Property Value

Type: DatabaseType
Remarks
This value is automatically assigned based on the adapter type specified in the data provider string, however, if the database type cannot be determined it will be set to Other. In this case, if you know the behavior of your custom ADO database connection matches that of another defined database type, you can manually assign the database type to allow for database interaction interoperability.
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.DefaultIsloationLevel Property

Grid Solutions Framework AdoDataConnectionDefaultIsloationLevel Property
Gets the default IsolationLevel for the connected AdoDataConnection database type.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IsolationLevel DefaultIsloationLevel { get; }
Public ReadOnly Property DefaultIsloationLevel As IsolationLevel
    Get
member DefaultIsloationLevel : IsolationLevel with get

function get_DefaultIsloationLevel();

public:
property IsolationLevel DefaultIsloationLevel {
    IsolationLevel get ();
}

Property Value

Type: IsolationLevel
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.IsJetEngine Property

Grid Solutions Framework AdoDataConnectionIsJetEngine Property
Gets a value to indicate whether source database is Microsoft Access.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsJetEngine { get; }
Public ReadOnly Property IsJetEngine As Boolean
    Get
member IsJetEngine : bool with get

function get_IsJetEngine();

public:
property bool IsJetEngine {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.IsMySQL Property

Grid Solutions Framework AdoDataConnectionIsMySQL Property
Gets a value to indicate whether source database is MySQL.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsMySQL { get; }
Public ReadOnly Property IsMySQL As Boolean
    Get
member IsMySQL : bool with get

function get_IsMySQL();

public:
property bool IsMySQL {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.IsOracle Property

Grid Solutions Framework AdoDataConnectionIsOracle Property
Gets a value to indicate whether source database is Oracle.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsOracle { get; }
Public ReadOnly Property IsOracle As Boolean
    Get
member IsOracle : bool with get

function get_IsOracle();

public:
property bool IsOracle {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.IsSqlite Property

Grid Solutions Framework AdoDataConnectionIsSqlite Property
Gets a value to indicate whether source database is SQLite.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSqlite { get; }
Public ReadOnly Property IsSqlite As Boolean
    Get
member IsSqlite : bool with get

function get_IsSqlite();

public:
property bool IsSqlite {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.IsSQLServer Property

Grid Solutions Framework AdoDataConnectionIsSQLServer Property
Gets a value to indicate whether source database is Microsoft SQL Server.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSQLServer { get; }
Public ReadOnly Property IsSQLServer As Boolean
    Get
member IsSQLServer : bool with get

function get_IsSQLServer();

public:
property bool IsSQLServer {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


AdoDataConnection.UtcNow Property

Grid Solutions Framework AdoDataConnectionUtcNow Property
Gets current UTC date-time in an implementation that is proper for the connected AdoDataConnection database type.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object UtcNow { get; }
Public ReadOnly Property UtcNow As Object
    Get
member UtcNow : Object with get

function get_UtcNow();

public:
property Object^ UtcNow {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

AdoDataConnection Class
GSF.Data Namespace


DatabaseType Enumeration

Grid Solutions Framework DatabaseType Enumeration
Specifies the database type underlying an AdoDataConnection.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DatabaseType
Public Enumeration DatabaseType
type DatabaseType
GSF.Data.DatabaseType = function();
GSF.Data.DatabaseType.createEnum('GSF.Data.DatabaseType', false);
public enum class DatabaseType
Members
Member name | Value | Description
Access | 0 | Underlying ADO database type is Microsoft Access.
SQLServer | 1 | Underlying ADO database type is SQL Server.
MySQL | 2 | Underlying ADO database type is MySQL.
Oracle | 3 | Underlying ADO database type is Oracle.
SQLite | 4 | Underlying ADO database type is SQLite.
Other | 5 | Underlying ADO database type is unknown.
See Also

Reference

GSF.Data Namespace


DataExtensions Class

Grid Solutions Framework DataExtensions Class
Defines extension functions related to database and SQL interaction.
Inheritance Hierarchy
SystemObject
GSF.DataDataExtensions

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class DataExtensions
<ExtensionAttribute>
Public NotInheritable Class DataExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataExtensions =  class end
GSF.Data.DataExtensions = function();

Type.createClass(
    'GSF.Data.DataExtensions');
[ExtensionAttribute]
public ref class DataExtensions abstract sealed

The DataExtensions type exposes the following members.

Methods
Name | Description
AddParametersWithValues | Creates and adds a new IDbDataParameter for each of the specified values to the IDbCommand object.
AddParameterWithValue | Creates and adds an IDbDataParameter to the IDbCommand object with the specified value.
ConvertFieldT | Provides strongly-typed access to each of the column values in the specified row. Automatically applies type conversion to the column values.
ConvertNullableFieldT | Provides strongly-typed access to each of the column values in the specified row. Automatically applies type conversion to the column values.
CreateParameterizedCommand | Creates and returns a parameterized IDbCommand. Parameter names are embedded in the SQL statement passed as a parameter to this method.
ExecuteNonQuery(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the number of rows affected.
ExecuteNonQuery(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the number of rows affected.
ExecuteNonQuery(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the number of rows affected.
ExecuteNonQuery(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the number of rows affected.
ExecuteNonQuery(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the number of rows affected.
ExecuteNonQuery(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the number of rows affected.
ExecuteNonQuery(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the number of rows affected.
ExecuteNonQuery(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the number of rows affected.
ExecuteNonQueryTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and returns the number of rows affected.
ExecuteNonQueryTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the number of rows affected.
ExecuteReader(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.
ExecuteReader(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.
ExecuteReader(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.
ExecuteReader(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.
ExecuteReader(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and builds a SqlDataReader.
ExecuteReader(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and builds a SqlDataReader.
ExecuteReader(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(IDbCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(OdbcCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.
ExecuteReader(OdbcConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.
ExecuteReader(OleDbCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.
ExecuteReader(OleDbConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.
ExecuteReader(SqlCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using SqlCommand, and builds a SqlDataReader.
ExecuteReader(SqlConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using SqlConnection, and builds a SqlDataReader.
ExecuteReaderTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteReaderTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteReaderTConnection(TConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteScalar(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalarTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalarTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.
PopulateParameters(OdbcCommand, Object) | Takes the OdbcCommand object and populates it with the given parameters.
PopulateParameters(OleDbCommand, Object) | Takes the OleDbCommand object and populates it with the given parameters.
PopulateParameters(SqlCommand, Object) | Takes the SqlCommand object and populates it with the given parameters.
PopulateParameters(OdbcCommand, Object, Object) | Takes the OdbcCommand object and populates it with the given parameters.
PopulateParameters(OleDbCommand, Object, Object) | Takes the OleDbCommand object and populates it with the given parameters.
PopulateParameters(SqlCommand, Object, Object) | Takes the SqlCommand object and populates it with the given parameters.
PopulateParametersTDbCommand(TDbCommand, ActionTDbCommand, Object) | Takes the IDbCommand object and populates it with the given parameters.
RetrieveData(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Int32, Int32, Int32) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Int32, Int32, Int32) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveDataSet(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple table depending on the SQL statement.
RetrieveDataSet(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple table depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables depending on the SQL statement.
RetrieveDataSet(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Int32, Int32, Int32) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Int32, Int32, Int32) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveRow(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Int32) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Int32) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Int32) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Int32) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Int32) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Int32) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.
RetrieveRow(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.
RetrieveRow(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.
SQLEncode | Performs SQL encoding on given SQL string.
ToDataTable | Converts a delimited string into a DataTable.
ToDelimitedString | Converts the DataTable to a multi-line delimited string (e.g., CSV export).
UpdateData(OdbcConnection, DataTable, String) | Updates the underlying data of the DataTable using OdbcConnection, and returns the number of rows successfully updated.
UpdateData(OleDbConnection, DataTable, String) | Updates the underlying data of the DataTable using OleDbConnection, and returns the number of rows successfully updated.
UpdateData(SqlConnection, DataTable, String) | Updates the underlying data of the DataTable using SqlConnection, and returns the number of rows successfully updated.
Top
Fields
Name | Description
DefaultTimeoutDuration | The default timeout duration used for executing SQL statements when timeout duration is not specified.
Top
See Also

Reference

GSF.Data Namespace


DataExtensions Fields

Grid Solutions Framework DataExtensions Fields

The DataExtensions type exposes the following members.

Fields
Name | Description
DefaultTimeoutDuration | The default timeout duration used for executing SQL statements when timeout duration is not specified.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.DefaultTimeoutDuration Field

Grid Solutions Framework DataExtensionsDefaultTimeoutDuration Field
The default timeout duration used for executing SQL statements when timeout duration is not specified.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultTimeoutDuration
Public Const DefaultTimeoutDuration As Integer
static val mutable DefaultTimeoutDuration: int
var GSF.Data.DataExtensions.DefaultTimeoutDuration
public:
literal int DefaultTimeoutDuration

Field Value

Type: Int32
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions Methods

Grid Solutions Framework DataExtensions Methods

The DataExtensions type exposes the following members.

Methods
Name | Description
AddParametersWithValues | Creates and adds a new IDbDataParameter for each of the specified values to the IDbCommand object.
AddParameterWithValue | Creates and adds an IDbDataParameter to the IDbCommand object with the specified value.
ConvertFieldT | Provides strongly-typed access to each of the column values in the specified row. Automatically applies type conversion to the column values.
ConvertNullableFieldT | Provides strongly-typed access to each of the column values in the specified row. Automatically applies type conversion to the column values.
CreateParameterizedCommand | Creates and returns a parameterized IDbCommand. Parameter names are embedded in the SQL statement passed as a parameter to this method.
ExecuteNonQuery(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the number of rows affected.
ExecuteNonQuery(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the number of rows affected.
ExecuteNonQuery(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the number of rows affected.
ExecuteNonQuery(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the number of rows affected.
ExecuteNonQuery(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the number of rows affected.
ExecuteNonQuery(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the number of rows affected.
ExecuteNonQuery(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the number of rows affected.
ExecuteNonQuery(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the number of rows affected.
ExecuteNonQueryTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and returns the number of rows affected.
ExecuteNonQueryTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the number of rows affected.
ExecuteReader(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.
ExecuteReader(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.
ExecuteReader(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.
ExecuteReader(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.
ExecuteReader(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and builds a SqlDataReader.
ExecuteReader(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and builds a SqlDataReader.
ExecuteReader(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(IDbCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(OdbcCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.
ExecuteReader(OdbcConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.
ExecuteReader(OleDbCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.
ExecuteReader(OleDbConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.
ExecuteReader(SqlCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using SqlCommand, and builds a SqlDataReader.
ExecuteReader(SqlConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using SqlConnection, and builds a SqlDataReader.
ExecuteReaderTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteReaderTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteReaderTConnection(TConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteScalar(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalarTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalarTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.
PopulateParameters(OdbcCommand, Object) | Takes the OdbcCommand object and populates it with the given parameters.
PopulateParameters(OleDbCommand, Object) | Takes the OleDbCommand object and populates it with the given parameters.
PopulateParameters(SqlCommand, Object) | Takes the SqlCommand object and populates it with the given parameters.
PopulateParameters(OdbcCommand, Object, Object) | Takes the OdbcCommand object and populates it with the given parameters.
PopulateParameters(OleDbCommand, Object, Object) | Takes the OleDbCommand object and populates it with the given parameters.
PopulateParameters(SqlCommand, Object, Object) | Takes the SqlCommand object and populates it with the given parameters.
PopulateParametersTDbCommand(TDbCommand, ActionTDbCommand, Object) | Takes the IDbCommand object and populates it with the given parameters.
RetrieveData(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Int32, Int32, Int32) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Int32, Int32, Int32) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveDataSet(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple table depending on the SQL statement.
RetrieveDataSet(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple table depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables depending on the SQL statement.
RetrieveDataSet(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Int32, Int32, Int32) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Int32, Int32, Int32) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveRow(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Int32) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Int32) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Int32) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Int32) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Int32) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Int32) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.
RetrieveRow(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.
RetrieveRow(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.
SQLEncode | Performs SQL encoding on given SQL string.
ToDataTable | Converts a delimited string into a DataTable.
ToDelimitedString | Converts the DataTable to a multi-line delimited string (e.g., CSV export).
UpdateData(OdbcConnection, DataTable, String) | Updates the underlying data of the DataTable using OdbcConnection, and returns the number of rows successfully updated.
UpdateData(OleDbConnection, DataTable, String) | Updates the underlying data of the DataTable using OleDbConnection, and returns the number of rows successfully updated.
UpdateData(SqlConnection, DataTable, String) | Updates the underlying data of the DataTable using SqlConnection, and returns the number of rows successfully updated.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.AddParametersWithValues Method

Grid Solutions Framework DataExtensionsAddParametersWithValues Method
Creates and adds a new IDbDataParameter for each of the specified values to the IDbCommand object.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void AddParametersWithValues(
    this IDbCommand command,
    string sql,
    params Object[] values
)
<ExtensionAttribute>
Public Shared Sub AddParametersWithValues (
    command As IDbCommand,
    sql As String,
    ParamArray values As Object()
)
static member AddParametersWithValues :
        command : IDbCommand *
        sql : string *
        values : Object[] -> unit

GSF.Data.DataExtensions.AddParametersWithValues = function(command, sql, ... values);
public:
[ExtensionAttribute]
static void AddParametersWithValues(
    IDbCommand^ command,
    String^ sql,
    ... array<Object^>^ values
)

Parameters

command
Type: System.DataIDbCommand
IDbCommand to which parameters need to be added.
sql
Type: SystemString
The SQL statement.
values
Type: SystemObject
The values for the parameters of the IDbCommand in the order that they appear in the SQL statement.

Return Value

Type:
The fully populated parameterized command.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Number of IDbDataParameter arguments in sql expression, identified by '@', do not match number of supplied parameter values.
Remarks

This method does very rudimentary parsing of the SQL statement so parameter names should start with the '@' character and should be surrounded by either spaces, parentheses, or commas.

Do not use the same parameter name twice in the expression so that each parameter, identified by '@', will have a corresponding value.

See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.AddParameterWithValue Method

Grid Solutions Framework DataExtensionsAddParameterWithValue Method
Creates and adds an IDbDataParameter to the IDbCommand object with the specified value.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void AddParameterWithValue(
    this IDbCommand command,
    string name,
    Object value,
    ParameterDirection direction = ParameterDirection.Input
)
<ExtensionAttribute>
Public Shared Sub AddParameterWithValue (
    command As IDbCommand,
    name As String,
    value As Object,
    Optional direction As ParameterDirection = ParameterDirection.Input
)
static member AddParameterWithValue :
        command : IDbCommand *
        name : string *
        value : Object *
        ?direction : ParameterDirection
(* Defaults:
        let _direction = defaultArg direction ParameterDirection.Input
*)
-> unit

GSF.Data.DataExtensions.AddParameterWithValue = function(command, name, value, direction);
public:
[ExtensionAttribute]
static void AddParameterWithValue(
    IDbCommand^ command,
    String^ name,
    Object^ value,
    ParameterDirection direction = ParameterDirection::Input
)

Parameters

command
Type: System.DataIDbCommand
IDbCommand to which parameter needs to be added.
name
Type: SystemString
Name of the IDbDataParameter to be added.
value
Type: SystemObject
Value of the IDbDataParameter to be added.
direction (Optional)
Type: System.DataParameterDirection
ParameterDirection for IDbDataParameter.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ConvertField(T) Method

Grid Solutions Framework DataExtensionsConvertFieldT Method
Provides strongly-typed access to each of the column values in the specified row. Automatically applies type conversion to the column values.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static T ConvertField<T>(
    this DataRow row,
    string field
)

<ExtensionAttribute>
Public Shared Function ConvertField(Of T) (
    row As DataRow,
    field As String
) As T
static member ConvertField :
        row : DataRow *
        field : string -> 'T

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
static T ConvertField(
    DataRow^ row,
    String^ field
)

Parameters

row
Type: System.DataDataRow
The input DataRow, which acts as the this instance for the extension method.
field
Type: SystemString
The name of the column to return the value of.

Type Parameters

T
A generic parameter that specifies the return type of the column.

Return Value

Type: T
The value, of type T, of the DataColumn specified by columnName.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataRow. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ConvertNullableField(T) Method

Grid Solutions Framework DataExtensionsConvertNullableFieldT Method
Provides strongly-typed access to each of the column values in the specified row. Automatically applies type conversion to the column values.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Nullable<T> ConvertNullableField<T>(
    this DataRow row,
    string field
)
where T : struct, new()

<ExtensionAttribute>
Public Shared Function ConvertNullableField(Of T As {Structure, New}) (
    row As DataRow,
    field As String
) As Nullable(Of T)
static member ConvertNullableField :
        row : DataRow *
        field : string -> Nullable<'T>  when 'T : struct, new()

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : value class, gcnew()
static Nullable<T> ConvertNullableField(
    DataRow^ row,
    String^ field
)

Parameters

row
Type: System.DataDataRow
The input DataRow, which acts as the this instance for the extension method.
field
Type: SystemString
The name of the column to return the value of.

Type Parameters

T
A generic parameter that specifies the return type of the column.

Return Value

Type: Nullable T
The value, of type T, of the DataColumn specified by columnName.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataRow. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.CreateParameterizedCommand Method

Grid Solutions Framework DataExtensionsCreateParameterizedCommand Method
Creates and returns a parameterized IDbCommand. Parameter names are embedded in the SQL statement passed as a parameter to this method.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IDbCommand CreateParameterizedCommand(
    this IDbConnection connection,
    string sql,
    params Object[] values
)
<ExtensionAttribute>
Public Shared Function CreateParameterizedCommand (
    connection As IDbConnection,
    sql As String,
    ParamArray values As Object()
) As IDbCommand
static member CreateParameterizedCommand :
        connection : IDbConnection *
        sql : string *
        values : Object[] -> IDbCommand

GSF.Data.DataExtensions.CreateParameterizedCommand = function(connection, sql, ... values);
public:
[ExtensionAttribute]
static IDbCommand^ CreateParameterizedCommand(
    IDbConnection^ connection,
    String^ sql,
    ... array<Object^>^ values
)

Parameters

connection
Type: System.DataIDbConnection
The database connection.
sql
Type: SystemString
The SQL statement.
values
Type: SystemObject
The values for the parameters of the IDbCommand in the order that they appear in the SQL statement.

Return Value

Type: IDbCommand
The fully populated parameterized command.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Number of IDbDataParameter arguments in sql expression, identified by '@', do not match number of supplied parameter values.
Remarks

This method does very rudimentary parsing of the SQL statement so parameter names should start with the '@' character and should be surrounded by either spaces, parentheses, or commas.

Do not use the same parameter name twice in the expression so that each parameter, identified by '@', will have a corresponding value.

See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method

Grid Solutions Framework DataExtensionsExecuteNonQuery Method
Overload List
Name | Description
ExecuteNonQuery(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the number of rows affected.
ExecuteNonQuery(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the number of rows affected.
ExecuteNonQuery(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the number of rows affected.
ExecuteNonQuery(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the number of rows affected.
ExecuteNonQueryTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and returns the number of rows affected.
ExecuteNonQuery(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the number of rows affected.
ExecuteNonQuery(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the number of rows affected.
ExecuteNonQuery(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the number of rows affected.
ExecuteNonQuery(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the number of rows affected.
ExecuteNonQuery(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the number of rows affected.
ExecuteNonQuery(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the number of rows affected.
ExecuteNonQueryTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the number of rows affected.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (IDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (IDbCommand, String, Object)
Executes the SQL statement using IDbCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this IDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As IDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : IDbCommand *
        sql : string *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    IDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OdbcCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OdbcCommand, String, Object)
Executes the SQL statement using OdbcCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OdbcCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As OdbcCommand,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : OdbcCommand *
        sql : string *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OdbcCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OdbcConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OdbcConnection, String, Object)
Executes the SQL statement using OdbcConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OdbcConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    connection As OdbcConnection,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : OdbcConnection *
        sql : string *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OdbcConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OleDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OleDbCommand, String, Object)
Executes the SQL statement using OleDbCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OleDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As OleDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : OleDbCommand *
        sql : string *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OleDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OleDbConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OleDbConnection, String, Object)
Executes the SQL statement using OleDbConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OleDbConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    connection As OleDbConnection,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : OleDbConnection *
        sql : string *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OleDbConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (SqlCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (SqlCommand, String, Object)
Executes the SQL statement using SqlCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this SqlCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As SqlCommand,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : SqlCommand *
        sql : string *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    SqlCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (SqlConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (SqlConnection, String, Object)
Executes the SQL statement using SqlConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this SqlConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    connection As SqlConnection,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : SqlConnection *
        sql : string *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    SqlConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery(TConnection) Method (TConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQueryTConnection Method (TConnection, String, Object)
Executes the SQL statement using IDbConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery<TConnection>(
    this TConnection connection,
    string sql,
    params Object[] parameters
)
where TConnection : IDbConnection

<ExtensionAttribute>
Public Shared Function ExecuteNonQuery(Of TConnection As IDbConnection) (
    connection As TConnection,
    sql As String,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : 'TConnection *
        sql : string *
        parameters : Object[] -> int  when 'TConnection : IDbConnection

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TConnection>
where TConnection : IDbConnection
static int ExecuteNonQuery(
    TConnection connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: TConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Type Parameters

TConnection
Type of IDbConnection to use.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (IDbCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (IDbCommand, String, Int32, Object)
Executes the SQL statement using IDbCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this IDbCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As IDbCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : IDbCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    IDbCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OdbcCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OdbcCommand, String, Int32, Object)
Executes the SQL statement using OdbcCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OdbcCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As OdbcCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : OdbcCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OdbcCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OdbcConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OdbcConnection, String, Int32, Object)
Executes the SQL statement using OdbcConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OdbcConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    connection As OdbcConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : OdbcConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OdbcConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OleDbCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OleDbCommand, String, Int32, Object)
Executes the SQL statement using OleDbCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OleDbCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As OleDbCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : OleDbCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OleDbCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (OleDbConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (OleDbConnection, String, Int32, Object)
Executes the SQL statement using OleDbConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this OleDbConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    connection As OleDbConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : OleDbConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    OleDbConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (SqlCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (SqlCommand, String, Int32, Object)
Executes the SQL statement using SqlCommand, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this SqlCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    command As SqlCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        command : SqlCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    SqlCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery Method (SqlConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQuery Method (SqlConnection, String, Int32, Object)
Executes the SQL statement using SqlConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery(
    this SqlConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteNonQuery (
    connection As SqlConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : SqlConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> int

GSF.Data.DataExtensions.ExecuteNonQuery = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static int ExecuteNonQuery(
    SqlConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteNonQuery(TConnection) Method (TConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteNonQueryTConnection Method (TConnection, String, Int32, Object)
Executes the SQL statement using IDbConnection, and returns the number of rows affected.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ExecuteNonQuery<TConnection>(
    this TConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
where TConnection : IDbConnection

<ExtensionAttribute>
Public Shared Function ExecuteNonQuery(Of TConnection As IDbConnection) (
    connection As TConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Integer
static member ExecuteNonQuery :
        connection : 'TConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> int  when 'TConnection : IDbConnection

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TConnection>
where TConnection : IDbConnection
static int ExecuteNonQuery(
    TConnection connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: TConnection
The IDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Type Parameters

TConnection
Type of IDbConnection to use.

Return Value

Type: Int32
The number of rows affected.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteNonQuery Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method

Grid Solutions Framework DataExtensionsExecuteReader Method
Overload List
Name | Description
ExecuteReader(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.
ExecuteReader(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.
ExecuteReader(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.
ExecuteReader(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.
ExecuteReader(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and builds a SqlDataReader.
ExecuteReader(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and builds a SqlDataReader.
ExecuteReaderTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteReader(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReaderTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
ExecuteReader(IDbCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using IDbCommand, and builds a IDataReader.
ExecuteReader(OdbcCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.
ExecuteReader(OdbcConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.
ExecuteReader(OleDbCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.
ExecuteReader(OleDbConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.
ExecuteReader(SqlCommand, String, CommandBehavior, Int32, Object) | Executes the SQL statement using SqlCommand, and builds a SqlDataReader.
ExecuteReader(SqlConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using SqlConnection, and builds a SqlDataReader.
ExecuteReaderTConnection(TConnection, String, CommandBehavior, Int32, Object) | Executes the SQL statement using IDbConnection, and builds a IDataReader.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ExecuteReader Method (IDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (IDbCommand, String, Object)
Executes the SQL statement using IDbCommand, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IDataReader ExecuteReader(
    this IDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As IDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As IDataReader
static member ExecuteReader :
        command : IDbCommand *
        sql : string *
        parameters : Object[] -> IDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static IDataReader^ ExecuteReader(
    IDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: IDataReader
A IDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OdbcCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OdbcCommand, String, Object)
Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OdbcDataReader ExecuteReader(
    this OdbcCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As OdbcCommand,
    sql As String,
    ParamArray parameters As Object()
) As OdbcDataReader
static member ExecuteReader :
        command : OdbcCommand *
        sql : string *
        parameters : Object[] -> OdbcDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static OdbcDataReader^ ExecuteReader(
    OdbcCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OdbcDataReader
A OdbcDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OdbcConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OdbcConnection, String, Object)
Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OdbcDataReader ExecuteReader(
    this OdbcConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    connection As OdbcConnection,
    sql As String,
    ParamArray parameters As Object()
) As OdbcDataReader
static member ExecuteReader :
        connection : OdbcConnection *
        sql : string *
        parameters : Object[] -> OdbcDataReader

GSF.Data.DataExtensions.ExecuteReader = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static OdbcDataReader^ ExecuteReader(
    OdbcConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OdbcDataReader
A OdbcDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OleDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OleDbCommand, String, Object)
Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OleDbDataReader ExecuteReader(
    this OleDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As OleDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As OleDbDataReader
static member ExecuteReader :
        command : OleDbCommand *
        sql : string *
        parameters : Object[] -> OleDbDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static OleDbDataReader^ ExecuteReader(
    OleDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OleDbDataReader
A OleDbDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OleDbConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OleDbConnection, String, Object)
Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OleDbDataReader ExecuteReader(
    this OleDbConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    connection As OleDbConnection,
    sql As String,
    ParamArray parameters As Object()
) As OleDbDataReader
static member ExecuteReader :
        connection : OleDbConnection *
        sql : string *
        parameters : Object[] -> OleDbDataReader

GSF.Data.DataExtensions.ExecuteReader = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static OleDbDataReader^ ExecuteReader(
    OleDbConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OleDbDataReader
A OleDbDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (SqlCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (SqlCommand, String, Object)
Executes the SQL statement using SqlCommand, and builds a SqlDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SqlDataReader ExecuteReader(
    this SqlCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As SqlCommand,
    sql As String,
    ParamArray parameters As Object()
) As SqlDataReader
static member ExecuteReader :
        command : SqlCommand *
        sql : string *
        parameters : Object[] -> SqlDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static SqlDataReader^ ExecuteReader(
    SqlCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: SqlDataReader
A SqlDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (SqlConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (SqlConnection, String, Object)
Executes the SQL statement using SqlConnection, and builds a SqlDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SqlDataReader ExecuteReader(
    this SqlConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    connection As SqlConnection,
    sql As String,
    ParamArray parameters As Object()
) As SqlDataReader
static member ExecuteReader :
        connection : SqlConnection *
        sql : string *
        parameters : Object[] -> SqlDataReader

GSF.Data.DataExtensions.ExecuteReader = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static SqlDataReader^ ExecuteReader(
    SqlConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: SqlDataReader
A SqlDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader(TConnection) Method (TConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteReaderTConnection Method (TConnection, String, Object)
Executes the SQL statement using IDbConnection, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IDataReader ExecuteReader<TConnection>(
    this TConnection connection,
    string sql,
    params Object[] parameters
)
where TConnection : IDbConnection

<ExtensionAttribute>
Public Shared Function ExecuteReader(Of TConnection As IDbConnection) (
    connection As TConnection,
    sql As String,
    ParamArray parameters As Object()
) As IDataReader
static member ExecuteReader :
        connection : 'TConnection *
        sql : string *
        parameters : Object[] -> IDataReader  when 'TConnection : IDbConnection

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TConnection>
where TConnection : IDbConnection
static IDataReader^ ExecuteReader(
    TConnection connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: TConnection
The IDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Type Parameters

TConnection
Type of IDbConnection to use.

Return Value

Type: IDataReader
A IDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (IDbCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (IDbCommand, String, Int32, Object)
Executes the SQL statement using IDbCommand, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IDataReader ExecuteReader(
    this IDbCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As IDbCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As IDataReader
static member ExecuteReader :
        command : IDbCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> IDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static IDataReader^ ExecuteReader(
    IDbCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: IDataReader
A IDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader(TConnection) Method (TConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReaderTConnection Method (TConnection, String, Int32, Object)
Executes the SQL statement using IDbConnection, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IDataReader ExecuteReader<TConnection>(
    this TConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
where TConnection : IDbConnection

<ExtensionAttribute>
Public Shared Function ExecuteReader(Of TConnection As IDbConnection) (
    connection As TConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As IDataReader
static member ExecuteReader :
        connection : 'TConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> IDataReader  when 'TConnection : IDbConnection

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TConnection>
where TConnection : IDbConnection
static IDataReader^ ExecuteReader(
    TConnection connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: TConnection
The IDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Type Parameters

TConnection
Type of IDbConnection to use.

Return Value

Type: IDataReader
A IDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (IDbCommand, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (IDbCommand, String, CommandBehavior, Int32, Object)
Executes the SQL statement using IDbCommand, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IDataReader ExecuteReader(
    this IDbCommand command,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As IDbCommand,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As IDataReader
static member ExecuteReader :
        command : IDbCommand *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> IDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, behavior, timeout, ... parameters);
public:
[ExtensionAttribute]
static IDataReader^ ExecuteReader(
    IDbCommand^ command,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: IDataReader
A IDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OdbcCommand, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OdbcCommand, String, CommandBehavior, Int32, Object)
Executes the SQL statement using OdbcCommand, and builds a OdbcDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OdbcDataReader ExecuteReader(
    this OdbcCommand command,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As OdbcCommand,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As OdbcDataReader
static member ExecuteReader :
        command : OdbcCommand *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> OdbcDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, behavior, timeout, ... parameters);
public:
[ExtensionAttribute]
static OdbcDataReader^ ExecuteReader(
    OdbcCommand^ command,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OdbcDataReader
A OdbcDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OdbcConnection, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OdbcConnection, String, CommandBehavior, Int32, Object)
Executes the SQL statement using OdbcConnection, and builds a OdbcDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OdbcDataReader ExecuteReader(
    this OdbcConnection connection,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    connection As OdbcConnection,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As OdbcDataReader
static member ExecuteReader :
        connection : OdbcConnection *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> OdbcDataReader

GSF.Data.DataExtensions.ExecuteReader = function(connection, sql, behavior, timeout, ... parameters);
public:
[ExtensionAttribute]
static OdbcDataReader^ ExecuteReader(
    OdbcConnection^ connection,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OdbcDataReader
A OdbcDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OleDbCommand, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OleDbCommand, String, CommandBehavior, Int32, Object)
Executes the SQL statement using OleDbCommand, and builds a OleDbDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OleDbDataReader ExecuteReader(
    this OleDbCommand command,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As OleDbCommand,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As OleDbDataReader
static member ExecuteReader :
        command : OleDbCommand *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> OleDbDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, behavior, timeout, ... parameters);
public:
[ExtensionAttribute]
static OleDbDataReader^ ExecuteReader(
    OleDbCommand^ command,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OleDbDataReader
A OleDbDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (OleDbConnection, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (OleDbConnection, String, CommandBehavior, Int32, Object)
Executes the SQL statement using OleDbConnection, and builds a OleDbDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OleDbDataReader ExecuteReader(
    this OleDbConnection connection,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    connection As OleDbConnection,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As OleDbDataReader
static member ExecuteReader :
        connection : OleDbConnection *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> OleDbDataReader

GSF.Data.DataExtensions.ExecuteReader = function(connection, sql, behavior, timeout, ... parameters);
public:
[ExtensionAttribute]
static OleDbDataReader^ ExecuteReader(
    OleDbConnection^ connection,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: OleDbDataReader
A OleDbDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (SqlCommand, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (SqlCommand, String, CommandBehavior, Int32, Object)
Executes the SQL statement using SqlCommand, and builds a SqlDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SqlDataReader ExecuteReader(
    this SqlCommand command,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    command As SqlCommand,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As SqlDataReader
static member ExecuteReader :
        command : SqlCommand *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> SqlDataReader

GSF.Data.DataExtensions.ExecuteReader = function(command, sql, behavior, timeout, ... parameters);
public:
[ExtensionAttribute]
static SqlDataReader^ ExecuteReader(
    SqlCommand^ command,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: SqlDataReader
A SqlDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader Method (SqlConnection, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReader Method (SqlConnection, String, CommandBehavior, Int32, Object)
Executes the SQL statement using SqlConnection, and builds a SqlDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SqlDataReader ExecuteReader(
    this SqlConnection connection,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteReader (
    connection As SqlConnection,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As SqlDataReader
static member ExecuteReader :
        connection : SqlConnection *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> SqlDataReader

GSF.Data.DataExtensions.ExecuteReader = function(connection, sql, behavior, timeout, ... parameters);
public:
[ExtensionAttribute]
static SqlDataReader^ ExecuteReader(
    SqlConnection^ connection,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: SqlDataReader
A SqlDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteReader(TConnection) Method (TConnection, String, CommandBehavior, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteReaderTConnection Method (TConnection, String, CommandBehavior, Int32, Object)
Executes the SQL statement using IDbConnection, and builds a IDataReader.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IDataReader ExecuteReader<TConnection>(
    this TConnection connection,
    string sql,
    CommandBehavior behavior,
    int timeout,
    params Object[] parameters
)
where TConnection : IDbConnection

<ExtensionAttribute>
Public Shared Function ExecuteReader(Of TConnection As IDbConnection) (
    connection As TConnection,
    sql As String,
    behavior As CommandBehavior,
    timeout As Integer,
    ParamArray parameters As Object()
) As IDataReader
static member ExecuteReader :
        connection : 'TConnection *
        sql : string *
        behavior : CommandBehavior *
        timeout : int *
        parameters : Object[] -> IDataReader  when 'TConnection : IDbConnection

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TConnection>
where TConnection : IDbConnection
static IDataReader^ ExecuteReader(
    TConnection connection,
    String^ sql,
    CommandBehavior behavior,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: TConnection
The IDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
behavior
Type: System.DataCommandBehavior
One of the CommandBehavior values.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Type Parameters

TConnection
Type of IDbConnection to use.

Return Value

Type: IDataReader
A IDataReader object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteReader Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method

Grid Solutions Framework DataExtensionsExecuteScalar Method
Overload List
Name | Description
ExecuteScalar(IDbCommand, String, Object) | Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalarTConnection(TConnection, String, Object) | Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(IDbCommand, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.
ExecuteScalar(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.
ExecuteScalarTConnection(TConnection, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (IDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (IDbCommand, String, Object)
Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this IDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As IDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : IDbCommand *
        sql : string *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    IDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OdbcCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OdbcCommand, String, Object)
Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OdbcCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As OdbcCommand,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : OdbcCommand *
        sql : string *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OdbcCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OdbcConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OdbcConnection, String, Object)
Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OdbcConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    connection As OdbcConnection,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : OdbcConnection *
        sql : string *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OdbcConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OleDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OleDbCommand, String, Object)
Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OleDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As OleDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : OleDbCommand *
        sql : string *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OleDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OleDbConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OleDbConnection, String, Object)
Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OleDbConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    connection As OleDbConnection,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : OleDbConnection *
        sql : string *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OleDbConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (SqlCommand, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (SqlCommand, String, Object)
Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this SqlCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As SqlCommand,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : SqlCommand *
        sql : string *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    SqlCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (SqlConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (SqlConnection, String, Object)
Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this SqlConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    connection As SqlConnection,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : SqlConnection *
        sql : string *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    SqlConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar(TConnection) Method (TConnection, String, Object[])

Grid Solutions Framework DataExtensionsExecuteScalarTConnection Method (TConnection, String, Object)
Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar<TConnection>(
    this TConnection connection,
    string sql,
    params Object[] parameters
)
where TConnection : IDbConnection

<ExtensionAttribute>
Public Shared Function ExecuteScalar(Of TConnection As IDbConnection) (
    connection As TConnection,
    sql As String,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : 'TConnection *
        sql : string *
        parameters : Object[] -> Object  when 'TConnection : IDbConnection

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TConnection>
where TConnection : IDbConnection
static Object^ ExecuteScalar(
    TConnection connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: TConnection
The IDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Type Parameters

TConnection
Type of IDbConnection to use.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (IDbCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (IDbCommand, String, Int32, Object)
Executes the SQL statement using IDbCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this IDbCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As IDbCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : IDbCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    IDbCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OdbcCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OdbcCommand, String, Int32, Object)
Executes the SQL statement using OdbcCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OdbcCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As OdbcCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : OdbcCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OdbcCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OdbcConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OdbcConnection, String, Int32, Object)
Executes the SQL statement using OdbcConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OdbcConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    connection As OdbcConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : OdbcConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OdbcConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OleDbCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OleDbCommand, String, Int32, Object)
Executes the SQL statement using OleDbCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OleDbCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As OleDbCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : OleDbCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OleDbCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (OleDbConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (OleDbConnection, String, Int32, Object)
Executes the SQL statement using OleDbConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this OleDbConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    connection As OleDbConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : OleDbConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    OleDbConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (SqlCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (SqlCommand, String, Int32, Object)
Executes the SQL statement using SqlCommand, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this SqlCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    command As SqlCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        command : SqlCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    SqlCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar Method (SqlConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalar Method (SqlConnection, String, Int32, Object)
Executes the SQL statement using SqlConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar(
    this SqlConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function ExecuteScalar (
    connection As SqlConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : SqlConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object

GSF.Data.DataExtensions.ExecuteScalar = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static Object^ ExecuteScalar(
    SqlConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.ExecuteScalar(TConnection) Method (TConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsExecuteScalarTConnection Method (TConnection, String, Int32, Object)
Executes the SQL statement using IDbConnection, and returns the value in the first column of the first row in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Object ExecuteScalar<TConnection>(
    this TConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
where TConnection : IDbConnection

<ExtensionAttribute>
Public Shared Function ExecuteScalar(Of TConnection As IDbConnection) (
    connection As TConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As Object
static member ExecuteScalar :
        connection : 'TConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> Object  when 'TConnection : IDbConnection

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TConnection>
where TConnection : IDbConnection
static Object^ ExecuteScalar(
    TConnection connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: TConnection
The IDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Type Parameters

TConnection
Type of IDbConnection to use.

Return Value

Type: Object
Value in the first column of the first row in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
ExecuteScalar Overload
GSF.Data Namespace


DataExtensions.PopulateParameters Method

Grid Solutions Framework DataExtensionsPopulateParameters Method
Overload List
Name | Description
PopulateParameters(OdbcCommand, Object) | Takes the OdbcCommand object and populates it with the given parameters.
PopulateParameters(OleDbCommand, Object) | Takes the OleDbCommand object and populates it with the given parameters.
PopulateParameters(SqlCommand, Object) | Takes the SqlCommand object and populates it with the given parameters.
PopulateParameters(OdbcCommand, Object, Object) | Takes the OdbcCommand object and populates it with the given parameters.
PopulateParameters(OleDbCommand, Object, Object) | Takes the OleDbCommand object and populates it with the given parameters.
PopulateParameters(SqlCommand, Object, Object) | Takes the SqlCommand object and populates it with the given parameters.
PopulateParametersTDbCommand(TDbCommand, ActionTDbCommand, Object) | Takes the IDbCommand object and populates it with the given parameters.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.PopulateParameters Method (OdbcCommand, Object[])

Grid Solutions Framework DataExtensionsPopulateParameters Method (OdbcCommand, Object)
Takes the OdbcCommand object and populates it with the given parameters.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PopulateParameters(
    this OdbcCommand command,
    Object[] parameters
)
<ExtensionAttribute>
Public Shared Sub PopulateParameters (
    command As OdbcCommand,
    parameters As Object()
)
static member PopulateParameters :
        command : OdbcCommand *
        parameters : Object[] -> unit

GSF.Data.DataExtensions.PopulateParameters = function(command, parameters);
public:
[ExtensionAttribute]
static void PopulateParameters(
    OdbcCommand^ command,
    array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand whose parameters are to be populated.
parameters
Type: SystemObject
The parameter values to populate the OdbcCommand parameters with.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Automatic parameter derivation is currently not support for ODBC connections under Mono deployments.
See Also

Reference

DataExtensions Class
PopulateParameters Overload
GSF.Data Namespace


DataExtensions.PopulateParameters Method (OleDbCommand, Object[])

Grid Solutions Framework DataExtensionsPopulateParameters Method (OleDbCommand, Object)
Takes the OleDbCommand object and populates it with the given parameters.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PopulateParameters(
    this OleDbCommand command,
    Object[] parameters
)
<ExtensionAttribute>
Public Shared Sub PopulateParameters (
    command As OleDbCommand,
    parameters As Object()
)
static member PopulateParameters :
        command : OleDbCommand *
        parameters : Object[] -> unit

GSF.Data.DataExtensions.PopulateParameters = function(command, parameters);
public:
[ExtensionAttribute]
static void PopulateParameters(
    OleDbCommand^ command,
    array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand whose parameters are to be populated.
parameters
Type: SystemObject
The parameter values to populate the OleDbCommand parameters with.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Automatic parameter derivation is currently not support for OleDB connections under Mono deployments.
See Also

Reference

DataExtensions Class
PopulateParameters Overload
GSF.Data Namespace


DataExtensions.PopulateParameters Method (SqlCommand, Object[])

Grid Solutions Framework DataExtensionsPopulateParameters Method (SqlCommand, Object)
Takes the SqlCommand object and populates it with the given parameters.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PopulateParameters(
    this SqlCommand command,
    Object[] parameters
)
<ExtensionAttribute>
Public Shared Sub PopulateParameters (
    command As SqlCommand,
    parameters As Object()
)
static member PopulateParameters :
        command : SqlCommand *
        parameters : Object[] -> unit

GSF.Data.DataExtensions.PopulateParameters = function(command, parameters);
public:
[ExtensionAttribute]
static void PopulateParameters(
    SqlCommand^ command,
    array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand whose parameters are to be populated.
parameters
Type: SystemObject
The parameter values to populate the SqlCommand parameters with.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
PopulateParameters Overload
GSF.Data Namespace


DataExtensions.PopulateParameters Method (OdbcCommand, Object, Object[])

Grid Solutions Framework DataExtensionsPopulateParameters Method (OdbcCommand, Object, Object)
Takes the OdbcCommand object and populates it with the given parameters.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PopulateParameters(
    this OdbcCommand command,
    Object parameter1,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Sub PopulateParameters (
    command As OdbcCommand,
    parameter1 As Object,
    ParamArray parameters As Object()
)
static member PopulateParameters :
        command : OdbcCommand *
        parameter1 : Object *
        parameters : Object[] -> unit

GSF.Data.DataExtensions.PopulateParameters = function(command, parameter1, ... parameters);
public:
[ExtensionAttribute]
static void PopulateParameters(
    OdbcCommand^ command,
    Object^ parameter1,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand whose parameters are to be populated.
parameter1
Type: SystemObject
The first parameter value to populate the OdbcCommand parameters with.
parameters
Type: SystemObject
The remaining parameter values to populate the OdbcCommand parameters with.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
PopulateParameters Overload
GSF.Data Namespace


DataExtensions.PopulateParameters Method (OleDbCommand, Object, Object[])

Grid Solutions Framework DataExtensionsPopulateParameters Method (OleDbCommand, Object, Object)
Takes the OleDbCommand object and populates it with the given parameters.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PopulateParameters(
    this OleDbCommand command,
    Object parameter1,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Sub PopulateParameters (
    command As OleDbCommand,
    parameter1 As Object,
    ParamArray parameters As Object()
)
static member PopulateParameters :
        command : OleDbCommand *
        parameter1 : Object *
        parameters : Object[] -> unit

GSF.Data.DataExtensions.PopulateParameters = function(command, parameter1, ... parameters);
public:
[ExtensionAttribute]
static void PopulateParameters(
    OleDbCommand^ command,
    Object^ parameter1,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand whose parameters are to be populated.
parameter1
Type: SystemObject
The first parameter value to populate the OleDbCommand parameters with.
parameters
Type: SystemObject
The remaining parameter values to populate the OleDbCommand parameters with.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
PopulateParameters Overload
GSF.Data Namespace


DataExtensions.PopulateParameters Method (SqlCommand, Object, Object[])

Grid Solutions Framework DataExtensionsPopulateParameters Method (SqlCommand, Object, Object)
Takes the SqlCommand object and populates it with the given parameters.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PopulateParameters(
    this SqlCommand command,
    Object parameter1,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Sub PopulateParameters (
    command As SqlCommand,
    parameter1 As Object,
    ParamArray parameters As Object()
)
static member PopulateParameters :
        command : SqlCommand *
        parameter1 : Object *
        parameters : Object[] -> unit

GSF.Data.DataExtensions.PopulateParameters = function(command, parameter1, ... parameters);
public:
[ExtensionAttribute]
static void PopulateParameters(
    SqlCommand^ command,
    Object^ parameter1,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand whose parameters are to be populated.
parameter1
Type: SystemObject
The first parameter value to populate the SqlCommand parameters with.
parameters
Type: SystemObject
The remaining parameter values to populate the SqlCommand parameters with.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
PopulateParameters Overload
GSF.Data Namespace


DataExtensions.PopulateParameters(TDbCommand) Method (TDbCommand, Action(TDbCommand), Object[])

Grid Solutions Framework DataExtensionsPopulateParametersTDbCommand Method (TDbCommand, ActionTDbCommand, Object)
Takes the IDbCommand object and populates it with the given parameters.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PopulateParameters<TDbCommand>(
    this TDbCommand command,
    Action<TDbCommand> deriveParameters,
    Object[] values
)
where TDbCommand : IDbCommand

<ExtensionAttribute>
Public Shared Sub PopulateParameters(Of TDbCommand As IDbCommand) (
    command As TDbCommand,
    deriveParameters As Action(Of TDbCommand),
    values As Object()
)
static member PopulateParameters :
        command : 'TDbCommand *
        deriveParameters : Action<'TDbCommand> *
        values : Object[] -> unit  when 'TDbCommand : IDbCommand

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TDbCommand>
where TDbCommand : IDbCommand
static void PopulateParameters(
    TDbCommand command,
    Action<TDbCommand>^ deriveParameters,
    array<Object^>^ values
)

Parameters

command
Type: TDbCommand
The IDbCommand whose parameters are to be populated.
deriveParameters
Type: SystemAction TDbCommand
The DeriveParameters() implementation of the command to use to populate parameters.
values
Type: SystemObject
The parameter values to populate the IDbCommand parameters with.

Type Parameters

TDbCommand
Then IDbCommand type to be used.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentException | Number of IDbDataParameter arguments in CommandText of this command, identified by '@', do not match number of supplied parameter values -or- You have supplied more values than parameters listed for the stored procedure.
See Also

Reference

DataExtensions Class
PopulateParameters Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method

Grid Solutions Framework DataExtensionsRetrieveData Method
Overload List
Name | Description
RetrieveData(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Int32, Int32, Int32) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Int32, Int32, Int32) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OdbcConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(OleDbConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.
RetrieveData(SqlConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcCommand, String)

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcCommand, String)
Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OdbcCommand,
    sql As String
) As DataTable
static member RetrieveData :
        command : OdbcCommand *
        sql : string -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcConnection, String)

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcConnection, String)
Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OdbcConnection,
    sql As String
) As DataTable
static member RetrieveData :
        connection : OdbcConnection *
        sql : string -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbCommand, String)

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbCommand, String)
Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OleDbCommand,
    sql As String
) As DataTable
static member RetrieveData :
        command : OleDbCommand *
        sql : string -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbConnection, String)

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbConnection, String)
Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OleDbConnection,
    sql As String
) As DataTable
static member RetrieveData :
        connection : OleDbConnection *
        sql : string -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlCommand, String)

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlCommand, String)
Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As SqlCommand,
    sql As String
) As DataTable
static member RetrieveData :
        command : SqlCommand *
        sql : string -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlConnection, String)

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlConnection, String)
Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As SqlConnection,
    sql As String
) As DataTable
static member RetrieveData :
        connection : SqlConnection *
        sql : string -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcCommand, String, Object)
Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OdbcCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : OdbcCommand *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcConnection, String, Object)
Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OdbcConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : OdbcConnection *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbCommand, String, Object)
Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OleDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : OleDbCommand *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbConnection, String, Object)
Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OleDbConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : OleDbConnection *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlCommand, String, Object)
Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As SqlCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : SqlCommand *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlConnection, String, Object)
Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As SqlConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : SqlConnection *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (IDbCommand, Type, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (IDbCommand, Type, String, Object)
Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this IDbCommand command,
    Type dataAdapterType,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As IDbCommand,
    dataAdapterType As Type,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : IDbCommand *
        dataAdapterType : Type *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, dataAdapterType, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    IDbCommand^ command,
    Type^ dataAdapterType,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (IDbConnection, Type, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (IDbConnection, Type, String, Object)
Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this IDbConnection connection,
    Type dataAdapterType,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As IDbConnection,
    dataAdapterType As Type,
    sql As String,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : IDbConnection *
        dataAdapterType : Type *
        sql : string *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, dataAdapterType, sql, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    IDbConnection^ connection,
    Type^ dataAdapterType,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.DataIDbConnection
The IDbConnection to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (IDbCommand, Type, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (IDbCommand, Type, String, Int32, Object)
Executes the SQL statement using IDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this IDbCommand command,
    Type dataAdapterType,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As IDbCommand,
    dataAdapterType As Type,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : IDbCommand *
        dataAdapterType : Type *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, dataAdapterType, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    IDbCommand^ command,
    Type^ dataAdapterType,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (IDbConnection, Type, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (IDbConnection, Type, String, Int32, Object)
Executes the SQL statement using IDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this IDbConnection connection,
    Type dataAdapterType,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As IDbConnection,
    dataAdapterType As Type,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : IDbConnection *
        dataAdapterType : Type *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, dataAdapterType, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    IDbConnection^ connection,
    Type^ dataAdapterType,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.DataIDbConnection
The IDbConnection to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcCommand, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcCommand, String, Int32, Int32, Int32)
Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OdbcCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataTable
static member RetrieveData :
        command : OdbcCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcConnection, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcConnection, String, Int32, Int32, Int32)
Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OdbcConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataTable
static member RetrieveData :
        connection : OdbcConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbCommand, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbCommand, String, Int32, Int32, Int32)
Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OleDbCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataTable
static member RetrieveData :
        command : OleDbCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbConnection, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbConnection, String, Int32, Int32, Int32)
Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OleDbConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataTable
static member RetrieveData :
        connection : OleDbConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlCommand, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlCommand, String, Int32, Int32, Int32)
Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As SqlCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataTable
static member RetrieveData :
        command : SqlCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlConnection, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlConnection, String, Int32, Int32, Int32)
Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As SqlConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataTable
static member RetrieveData :
        connection : SqlConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcCommand, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcCommand, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OdbcCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OdbcCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : OdbcCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OdbcConnection, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OdbcConnection, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OdbcConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OdbcConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OdbcConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : OdbcConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OdbcConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbCommand, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbCommand, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OleDbCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As OleDbCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : OleDbCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (OleDbConnection, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (OleDbConnection, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OleDbConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this OleDbConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As OleDbConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : OleDbConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    OleDbConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlCommand, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlCommand, String, Int32, Int32, Int32, Object)
Executes the SQL statement using SqlCommand, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    command As SqlCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        command : SqlCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(command, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveData Method (SqlConnection, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveData Method (SqlConnection, String, Int32, Int32, Int32, Object)
Executes the SQL statement using SqlConnection, and returns the first DataTable of result set, if the result set contains multiple tables.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable RetrieveData(
    this SqlConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveData (
    connection As SqlConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataTable
static member RetrieveData :
        connection : SqlConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataTable

GSF.Data.DataExtensions.RetrieveData = function(connection, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataTable^ RetrieveData(
    SqlConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveData Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method

Grid Solutions Framework DataExtensionsRetrieveDataSet Method
Overload List
Name | Description
RetrieveDataSet(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple table depending on the SQL statement.
RetrieveDataSet(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple table depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables depending on the SQL statement.
RetrieveDataSet(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Int32, Int32, Int32) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Int32, Int32, Int32) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Int32, Int32, Int32) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OdbcConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(OleDbConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlCommand, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
RetrieveDataSet(SqlConnection, String, Int32, Int32, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcCommand, String)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcCommand, String)
Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OdbcCommand,
    sql As String
) As DataSet
static member RetrieveDataSet :
        command : OdbcCommand *
        sql : string -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcConnection, String)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcConnection, String)
Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OdbcConnection,
    sql As String
) As DataSet
static member RetrieveDataSet :
        connection : OdbcConnection *
        sql : string -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbCommand, String)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbCommand, String)
Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OleDbCommand,
    sql As String
) As DataSet
static member RetrieveDataSet :
        command : OleDbCommand *
        sql : string -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbConnection, String)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbConnection, String)
Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OleDbConnection,
    sql As String
) As DataSet
static member RetrieveDataSet :
        connection : OleDbConnection *
        sql : string -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlCommand, String)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlCommand, String)
Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple table depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As SqlCommand,
    sql As String
) As DataSet
static member RetrieveDataSet :
        command : SqlCommand *
        sql : string -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlConnection, String)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlConnection, String)
Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple table depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As SqlConnection,
    sql As String
) As DataSet
static member RetrieveDataSet :
        connection : SqlConnection *
        sql : string -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcCommand, String, Object)
Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OdbcCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : OdbcCommand *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcConnection, String, Object)
Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OdbcConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : OdbcConnection *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbCommand, String, Object)
Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OleDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : OleDbCommand *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbConnection, String, Object)
Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OleDbConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : OleDbConnection *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlCommand, String, Object)
Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As SqlCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : SqlCommand *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlConnection, String, Object)
Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As SqlConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : SqlConnection *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (IDbCommand, Type, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (IDbCommand, Type, String, Object)
Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this IDbCommand command,
    Type dataAdapterType,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As IDbCommand,
    dataAdapterType As Type,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : IDbCommand *
        dataAdapterType : Type *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, dataAdapterType, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    IDbCommand^ command,
    Type^ dataAdapterType,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (IDbConnection, Type, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (IDbConnection, Type, String, Object)
Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this IDbConnection connection,
    Type dataAdapterType,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As IDbConnection,
    dataAdapterType As Type,
    sql As String,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : IDbConnection *
        dataAdapterType : Type *
        sql : string *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, dataAdapterType, sql, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    IDbConnection^ connection,
    Type^ dataAdapterType,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.DataIDbConnection
The IDbConnection to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (IDbCommand, Type, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (IDbCommand, Type, String, Int32, Object)
Executes the SQL statement using IDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this IDbCommand command,
    Type dataAdapterType,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As IDbCommand,
    dataAdapterType As Type,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : IDbCommand *
        dataAdapterType : Type *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, dataAdapterType, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    IDbCommand^ command,
    Type^ dataAdapterType,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (IDbConnection, Type, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (IDbConnection, Type, String, Int32, Object)
Executes the SQL statement using IDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this IDbConnection connection,
    Type dataAdapterType,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As IDbConnection,
    dataAdapterType As Type,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : IDbConnection *
        dataAdapterType : Type *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, dataAdapterType, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    IDbConnection^ connection,
    Type^ dataAdapterType,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.DataIDbConnection
The IDbConnection to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcCommand, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcCommand, String, Int32, Int32, Int32)
Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OdbcCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataSet
static member RetrieveDataSet :
        command : OdbcCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcConnection, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcConnection, String, Int32, Int32, Int32)
Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OdbcConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataSet
static member RetrieveDataSet :
        connection : OdbcConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbCommand, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbCommand, String, Int32, Int32, Int32)
Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OleDbCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataSet
static member RetrieveDataSet :
        command : OleDbCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbConnection, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbConnection, String, Int32, Int32, Int32)
Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OleDbConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataSet
static member RetrieveDataSet :
        connection : OleDbConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlCommand, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlCommand, String, Int32, Int32, Int32)
Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As SqlCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataSet
static member RetrieveDataSet :
        command : SqlCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlConnection, String, Int32, Int32, Int32)

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlConnection, String, Int32, Int32, Int32)
Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As SqlConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer
) As DataSet
static member RetrieveDataSet :
        connection : SqlConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, startRow, maxRows, timeout);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcCommand, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcCommand, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OdbcCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OdbcCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : OdbcCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OdbcConnection, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OdbcConnection, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OdbcConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OdbcConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OdbcConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : OdbcConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OdbcConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbCommand, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbCommand, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OleDbCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As OleDbCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : OleDbCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (OleDbConnection, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (OleDbConnection, String, Int32, Int32, Int32, Object)
Executes the SQL statement using OleDbConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this OleDbConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As OleDbConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : OleDbConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    OleDbConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlCommand, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlCommand, String, Int32, Int32, Int32, Object)
Executes the SQL statement using SqlCommand, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlCommand command,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    command As SqlCommand,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        command : SqlCommand *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(command, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlCommand^ command,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveDataSet Method (SqlConnection, String, Int32, Int32, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveDataSet Method (SqlConnection, String, Int32, Int32, Int32, Object)
Executes the SQL statement using SqlConnection, and returns the DataSet that may contain multiple tables, depending on the SQL statement.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet RetrieveDataSet(
    this SqlConnection connection,
    string sql,
    int startRow,
    int maxRows,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveDataSet (
    connection As SqlConnection,
    sql As String,
    startRow As Integer,
    maxRows As Integer,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataSet
static member RetrieveDataSet :
        connection : SqlConnection *
        sql : string *
        startRow : int *
        maxRows : int *
        timeout : int *
        parameters : Object[] -> DataSet

GSF.Data.DataExtensions.RetrieveDataSet = function(connection, sql, startRow, maxRows, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataSet^ RetrieveDataSet(
    SqlConnection^ connection,
    String^ sql,
    int startRow,
    int maxRows,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
startRow
Type: SystemInt32
The zero-based record number to start with.
maxRows
Type: SystemInt32
The maximum number of records to retrieve.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveDataSet Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method

Grid Solutions Framework DataExtensionsRetrieveRow Method
Overload List
Name | Description
RetrieveRow(OdbcCommand, String) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Int32) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Int32) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Int32) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Int32) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Int32) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Object) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Int32) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Object) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(IDbCommand, Type, String, Object) | Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.
RetrieveRow(IDbConnection, Type, String, Object) | Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.
RetrieveRow(OdbcCommand, String, Int32, Object) | Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.
RetrieveRow(OdbcConnection, String, Int32, Object) | Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.
RetrieveRow(OleDbCommand, String, Int32, Object) | Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.
RetrieveRow(OleDbConnection, String, Int32, Object) | Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.
RetrieveRow(SqlCommand, String, Int32, Object) | Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.
RetrieveRow(SqlConnection, String, Int32, Object) | Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.
RetrieveRow(IDbCommand, Type, String, Int32, Object) | Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.
RetrieveRow(IDbConnection, Type, String, Int32, Object) | Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcCommand, String)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcCommand, String)
Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OdbcCommand,
    sql As String
) As DataRow
static member RetrieveRow :
        command : OdbcCommand *
        sql : string -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcConnection, String)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcConnection, String)
Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OdbcConnection,
    sql As String
) As DataRow
static member RetrieveRow :
        connection : OdbcConnection *
        sql : string -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbCommand, String)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbCommand, String)
Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OleDbCommand,
    sql As String
) As DataRow
static member RetrieveRow :
        command : OleDbCommand *
        sql : string -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbConnection, String)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbConnection, String)
Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OleDbConnection,
    sql As String
) As DataRow
static member RetrieveRow :
        connection : OleDbConnection *
        sql : string -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlCommand, String)

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlCommand, String)
Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlCommand command,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As SqlCommand,
    sql As String
) As DataRow
static member RetrieveRow :
        command : SqlCommand *
        sql : string -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlCommand^ command,
    String^ sql
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlConnection, String)

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlConnection, String)
Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlConnection connection,
    string sql
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As SqlConnection,
    sql As String
) As DataRow
static member RetrieveRow :
        connection : SqlConnection *
        sql : string -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlConnection^ connection,
    String^ sql
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcCommand, String, Int32)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcCommand, String, Int32)
Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcCommand command,
    string sql,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OdbcCommand,
    sql As String,
    timeout As Integer
) As DataRow
static member RetrieveRow :
        command : OdbcCommand *
        sql : string *
        timeout : int -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, timeout);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcCommand^ command,
    String^ sql,
    int timeout
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcCommand, String, Object)
Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OdbcCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : OdbcCommand *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcConnection, String, Int32)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcConnection, String, Int32)
Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcConnection connection,
    string sql,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OdbcConnection,
    sql As String,
    timeout As Integer
) As DataRow
static member RetrieveRow :
        connection : OdbcConnection *
        sql : string *
        timeout : int -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, timeout);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcConnection^ connection,
    String^ sql,
    int timeout
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcConnection, String, Object)
Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OdbcConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : OdbcConnection *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbCommand, String, Int32)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbCommand, String, Int32)
Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbCommand command,
    string sql,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OleDbCommand,
    sql As String,
    timeout As Integer
) As DataRow
static member RetrieveRow :
        command : OleDbCommand *
        sql : string *
        timeout : int -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, timeout);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbCommand^ command,
    String^ sql,
    int timeout
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbCommand, String, Object)
Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OleDbCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : OleDbCommand *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbConnection, String, Int32)

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbConnection, String, Int32)
Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbConnection connection,
    string sql,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OleDbConnection,
    sql As String,
    timeout As Integer
) As DataRow
static member RetrieveRow :
        connection : OleDbConnection *
        sql : string *
        timeout : int -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, timeout);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbConnection^ connection,
    String^ sql,
    int timeout
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbConnection, String, Object)
Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OleDbConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : OleDbConnection *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlCommand, String, Int32)

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlCommand, String, Int32)
Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlCommand command,
    string sql,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As SqlCommand,
    sql As String,
    timeout As Integer
) As DataRow
static member RetrieveRow :
        command : SqlCommand *
        sql : string *
        timeout : int -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, timeout);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlCommand^ command,
    String^ sql,
    int timeout
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlCommand, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlCommand, String, Object)
Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlCommand command,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As SqlCommand,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : SqlCommand *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlCommand^ command,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlConnection, String, Int32)

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlConnection, String, Int32)
Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlConnection connection,
    string sql,
    int timeout
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As SqlConnection,
    sql As String,
    timeout As Integer
) As DataRow
static member RetrieveRow :
        connection : SqlConnection *
        sql : string *
        timeout : int -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, timeout);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlConnection^ connection,
    String^ sql,
    int timeout
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlConnection, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlConnection, String, Object)
Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlConnection connection,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As SqlConnection,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : SqlConnection *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlConnection^ connection,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (IDbCommand, Type, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (IDbCommand, Type, String, Object)
Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this IDbCommand command,
    Type dataAdapterType,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As IDbCommand,
    dataAdapterType As Type,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : IDbCommand *
        dataAdapterType : Type *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, dataAdapterType, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    IDbCommand^ command,
    Type^ dataAdapterType,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (IDbConnection, Type, String, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (IDbConnection, Type, String, Object)
Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this IDbConnection connection,
    Type dataAdapterType,
    string sql,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As IDbConnection,
    dataAdapterType As Type,
    sql As String,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : IDbConnection *
        dataAdapterType : Type *
        sql : string *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, dataAdapterType, sql, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    IDbConnection^ connection,
    Type^ dataAdapterType,
    String^ sql,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.DataIDbConnection
The IDbConnection to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcCommand, String, Int32, Object)
Executes the SQL statement using OdbcCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OdbcCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : OdbcCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OdbcOdbcCommand
The OdbcCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OdbcConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OdbcConnection, String, Int32, Object)
Executes the SQL statement using OdbcConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OdbcConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OdbcConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : OdbcConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OdbcConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbCommand, String, Int32, Object)
Executes the SQL statement using OleDbCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As OleDbCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : OleDbCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.OleDbOleDbCommand
The OleDbCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (OleDbConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (OleDbConnection, String, Int32, Object)
Executes the SQL statement using OleDbConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this OleDbConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As OleDbConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : OleDbConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    OleDbConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlCommand, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlCommand, String, Int32, Object)
Executes the SQL statement using SqlCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlCommand command,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As SqlCommand,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : SqlCommand *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlCommand^ command,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.Data.SqlClientSqlCommand
The SqlCommand to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (SqlConnection, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (SqlConnection, String, Int32, Object)
Executes the SQL statement using SqlConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this SqlConnection connection,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As SqlConnection,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : SqlConnection *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    SqlConnection^ connection,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for executing the SQL statement.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression -or- the parameter values to be passed into stored procedure being executed.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (IDbCommand, Type, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (IDbCommand, Type, String, Int32, Object)
Executes the SQL statement using IDbCommand, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this IDbCommand command,
    Type dataAdapterType,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    command As IDbCommand,
    dataAdapterType As Type,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        command : IDbCommand *
        dataAdapterType : Type *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(command, dataAdapterType, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    IDbCommand^ command,
    Type^ dataAdapterType,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

command
Type: System.DataIDbCommand
The IDbCommand to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbCommand. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.RetrieveRow Method (IDbConnection, Type, String, Int32, Object[])

Grid Solutions Framework DataExtensionsRetrieveRow Method (IDbConnection, Type, String, Int32, Object)
Executes the SQL statement using IDbConnection, and returns the first DataRow in the result set.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataRow RetrieveRow(
    this IDbConnection connection,
    Type dataAdapterType,
    string sql,
    int timeout,
    params Object[] parameters
)
<ExtensionAttribute>
Public Shared Function RetrieveRow (
    connection As IDbConnection,
    dataAdapterType As Type,
    sql As String,
    timeout As Integer,
    ParamArray parameters As Object()
) As DataRow
static member RetrieveRow :
        connection : IDbConnection *
        dataAdapterType : Type *
        sql : string *
        timeout : int *
        parameters : Object[] -> DataRow

GSF.Data.DataExtensions.RetrieveRow = function(connection, dataAdapterType, sql, timeout, ... parameters);
public:
[ExtensionAttribute]
static DataRow^ RetrieveRow(
    IDbConnection^ connection,
    Type^ dataAdapterType,
    String^ sql,
    int timeout,
    ... array<Object^>^ parameters
)

Parameters

connection
Type: System.DataIDbConnection
The IDbConnection to use for executing the SQL statement.
dataAdapterType
Type: SystemType
The Type of data adapter to use to retreieve data.
sql
Type: SystemString
The SQL statement to be executed.
timeout
Type: SystemInt32
The time in seconds to wait for the SQL statement to execute.
parameters
Type: SystemObject
The parameter values to be used to fill in IDbDataParameter parameters identified by '@' prefix in sql expression.

Return Value

Type: DataRow
The first DataRow in the result set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
RetrieveRow Overload
GSF.Data Namespace


DataExtensions.SQLEncode Method

Grid Solutions Framework DataExtensionsSQLEncode Method
Performs SQL encoding on given SQL string.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string SQLEncode(
    this string sql,
    DatabaseType databaseType = DatabaseType.Other
)
<ExtensionAttribute>
Public Shared Function SQLEncode (
    sql As String,
    Optional databaseType As DatabaseType = DatabaseType.Other
) As String
static member SQLEncode :
        sql : string *
        ?databaseType : DatabaseType
(* Defaults:
        let _databaseType = defaultArg databaseType DatabaseType.Other
*)
-> string

GSF.Data.DataExtensions.SQLEncode = function(sql, databaseType);
public:
[ExtensionAttribute]
static String^ SQLEncode(
    String^ sql,
    DatabaseType databaseType = DatabaseType::Other
)

Parameters

sql
Type: SystemString
The string on which SQL encoding is to be performed.
databaseType (Optional)
Type: GSF.DataDatabaseType
Database type for the SQL encoding.

Return Value

Type: String
The SQL encoded string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ToDataTable Method

Grid Solutions Framework DataExtensionsToDataTable Method
Converts a delimited string into a DataTable.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataTable ToDataTable(
    this string delimitedData,
    string delimiter,
    bool header
)
<ExtensionAttribute>
Public Shared Function ToDataTable (
    delimitedData As String,
    delimiter As String,
    header As Boolean
) As DataTable
static member ToDataTable :
        delimitedData : string *
        delimiter : string *
        header : bool -> DataTable

GSF.Data.DataExtensions.ToDataTable = function(delimitedData, delimiter, header);
public:
[ExtensionAttribute]
static DataTable^ ToDataTable(
    String^ delimitedData,
    String^ delimiter,
    bool header
)

Parameters

delimitedData
Type: SystemString
The delimited text to be converted to DataTable.
delimiter
Type: SystemString
The character(s) used for delimiting the text.
header
Type: SystemBoolean
true, if the delimited text contains header information; otherwise, false.

Return Value

Type: DataTable
A DataTable object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.ToDelimitedString Method

Grid Solutions Framework DataExtensionsToDelimitedString Method
Converts the DataTable to a multi-line delimited string (e.g., CSV export).

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToDelimitedString(
    this DataTable table,
    string delimiter,
    bool quoted,
    bool header
)
<ExtensionAttribute>
Public Shared Function ToDelimitedString (
    table As DataTable,
    delimiter As String,
    quoted As Boolean,
    header As Boolean
) As String
static member ToDelimitedString :
        table : DataTable *
        delimiter : string *
        quoted : bool *
        header : bool -> string

GSF.Data.DataExtensions.ToDelimitedString = function(table, delimiter, quoted, header);
public:
[ExtensionAttribute]
static String^ ToDelimitedString(
    DataTable^ table,
    String^ delimiter,
    bool quoted,
    bool header
)

Parameters

table
Type: System.DataDataTable
The DataTable whose data is to be converted to delimited text.
delimiter
Type: SystemString
The character(s) to be used for delimiting the text.
quoted
Type: SystemBoolean
true, if text is to be surrounded by quotes; otherwise, false.
header
Type: SystemBoolean
true, if the delimited text should have header information.

Return Value

Type: String
A string of delimited text.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataTable. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.UpdateData Method

Grid Solutions Framework DataExtensionsUpdateData Method
Overload List
Name | Description
UpdateData(OdbcConnection, DataTable, String) | Updates the underlying data of the DataTable using OdbcConnection, and returns the number of rows successfully updated.
UpdateData(OleDbConnection, DataTable, String) | Updates the underlying data of the DataTable using OleDbConnection, and returns the number of rows successfully updated.
UpdateData(SqlConnection, DataTable, String) | Updates the underlying data of the DataTable using SqlConnection, and returns the number of rows successfully updated.
Top
See Also

Reference

DataExtensions Class
GSF.Data Namespace


DataExtensions.UpdateData Method (OdbcConnection, DataTable, String)

Grid Solutions Framework DataExtensionsUpdateData Method (OdbcConnection, DataTable, String)
Updates the underlying data of the DataTable using OdbcConnection, and returns the number of rows successfully updated.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int UpdateData(
    this OdbcConnection connection,
    DataTable sourceData,
    string sourceSql
)
<ExtensionAttribute>
Public Shared Function UpdateData (
    connection As OdbcConnection,
    sourceData As DataTable,
    sourceSql As String
) As Integer
static member UpdateData :
        connection : OdbcConnection *
        sourceData : DataTable *
        sourceSql : string -> int

GSF.Data.DataExtensions.UpdateData = function(connection, sourceData, sourceSql);
public:
[ExtensionAttribute]
static int UpdateData(
    OdbcConnection^ connection,
    DataTable^ sourceData,
    String^ sourceSql
)

Parameters

connection
Type: System.Data.OdbcOdbcConnection
The OdbcConnection to use for updating the underlying data source.
sourceData
Type: System.DataDataTable
The DataTable used to update the underlying data source.
sourceSql
Type: SystemString
The SQL statement used initially to populate the DataTable.

Return Value

Type: Int32
The number of rows successfully updated from the DataTable.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OdbcConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
UpdateData Overload
GSF.Data Namespace


DataExtensions.UpdateData Method (OleDbConnection, DataTable, String)

Grid Solutions Framework DataExtensionsUpdateData Method (OleDbConnection, DataTable, String)
Updates the underlying data of the DataTable using OleDbConnection, and returns the number of rows successfully updated.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int UpdateData(
    this OleDbConnection connection,
    DataTable sourceData,
    string sourceSql
)
<ExtensionAttribute>
Public Shared Function UpdateData (
    connection As OleDbConnection,
    sourceData As DataTable,
    sourceSql As String
) As Integer
static member UpdateData :
        connection : OleDbConnection *
        sourceData : DataTable *
        sourceSql : string -> int

GSF.Data.DataExtensions.UpdateData = function(connection, sourceData, sourceSql);
public:
[ExtensionAttribute]
static int UpdateData(
    OleDbConnection^ connection,
    DataTable^ sourceData,
    String^ sourceSql
)

Parameters

connection
Type: System.Data.OleDbOleDbConnection
The OleDbConnection to use for updating the underlying data source.
sourceData
Type: System.DataDataTable
The DataTable used to update the underlying data source.
sourceSql
Type: SystemString
The SQL statement used initially to populate the DataTable.

Return Value

Type: Int32
The number of rows successfully updated from the DataTable.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type OleDbConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
UpdateData Overload
GSF.Data Namespace


DataExtensions.UpdateData Method (SqlConnection, DataTable, String)

Grid Solutions Framework DataExtensionsUpdateData Method (SqlConnection, DataTable, String)
Updates the underlying data of the DataTable using SqlConnection, and returns the number of rows successfully updated.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int UpdateData(
    this SqlConnection connection,
    DataTable sourceData,
    string sourceSql
)
<ExtensionAttribute>
Public Shared Function UpdateData (
    connection As SqlConnection,
    sourceData As DataTable,
    sourceSql As String
) As Integer
static member UpdateData :
        connection : SqlConnection *
        sourceData : DataTable *
        sourceSql : string -> int

GSF.Data.DataExtensions.UpdateData = function(connection, sourceData, sourceSql);
public:
[ExtensionAttribute]
static int UpdateData(
    SqlConnection^ connection,
    DataTable^ sourceData,
    String^ sourceSql
)

Parameters

connection
Type: System.Data.SqlClientSqlConnection
The SqlConnection to use for updating the underlying data source.
sourceData
Type: System.DataDataTable
The DataTable used to update the underlying data source.
sourceSql
Type: SystemString
The SQL statement used initially to populate the DataTable.

Return Value

Type: Int32
The number of rows successfully updated from the DataTable.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SqlConnection. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataExtensions Class
UpdateData Overload
GSF.Data Namespace


DataSetEqualityComparer Class

Grid Solutions Framework DataSetEqualityComparer Class
Equality comparer for DataSet objects.
Inheritance Hierarchy
SystemObject
GSF.DataDataSetEqualityComparer

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataSetEqualityComparer : IEqualityComparer<DataSet>
Public Class DataSetEqualityComparer
    Implements IEqualityComparer(Of DataSet)
type DataSetEqualityComparer =
    class
        interface IEqualityComparer<DataSet>
    end
GSF.Data.DataSetEqualityComparer = function();

Type.createClass(
    'GSF.Data.DataSetEqualityComparer',
    null,
    IEqualityComparer`1);
public ref class DataSetEqualityComparer : IEqualityComparer<DataSet^>

The DataSetEqualityComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(DataSet, DataSet) | Determines whether the specified objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(DataSet) | Returns a hash code for the specified object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Default | Default instance of the DataSetEqualityComparer class.
Top
See Also

Reference

GSF.Data Namespace


DataSetEqualityComparer Fields

Grid Solutions Framework DataSetEqualityComparer Fields

The DataSetEqualityComparer type exposes the following members.

Fields
Name | Description
Default | Default instance of the DataSetEqualityComparer class.
Top
See Also

Reference

DataSetEqualityComparer Class
GSF.Data Namespace


DataSetEqualityComparer.Default Field

Grid Solutions Framework DataSetEqualityComparerDefault Field
Default instance of the DataSetEqualityComparer class.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly DataSetEqualityComparer Default
Public Shared ReadOnly Default As DataSetEqualityComparer
static val Default: DataSetEqualityComparer
var GSF.Data.DataSetEqualityComparer.Default
public:
static initonly DataSetEqualityComparer^ Default

Field Value

Type: DataSetEqualityComparer
See Also

Reference

DataSetEqualityComparer Class
GSF.Data Namespace


DataSetEqualityComparer Methods

Grid Solutions Framework DataSetEqualityComparer Methods

The DataSetEqualityComparer type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(DataSet, DataSet) | Determines whether the specified objects are equal.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(DataSet) | Returns a hash code for the specified object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataSetEqualityComparer Class
GSF.Data Namespace


DataSetEqualityComparer.Equals Method

Grid Solutions Framework DataSetEqualityComparerEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Equals(DataSet, DataSet) | Determines whether the specified objects are equal.
Top
See Also

Reference

DataSetEqualityComparer Class
GSF.Data Namespace


DataSetEqualityComparer.Equals Method (DataSet, DataSet)

Grid Solutions Framework DataSetEqualityComparerEquals Method (DataSet, DataSet)
Determines whether the specified objects are equal.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    DataSet x,
    DataSet y
)
Public Function Equals (
    x As DataSet,
    y As DataSet
) As Boolean
abstract Equals :
        x : DataSet *
        y : DataSet -> bool
override Equals :
        x : DataSet *
        y : DataSet -> bool
function Equals(x, y);
public:
virtual bool Equals(
    DataSet^ x,
    DataSet^ y
) sealed

Parameters

x
Type: System.DataDataSet
The first object of type DataSet to compare.
y
Type: System.DataDataSet
The second object of type DataSet to compare.

Return Value

Type: Boolean
true if the specified objects are equal; otherwise, false.

Implements

IEqualityComparerTEquals(T, T)
See Also

Reference

DataSetEqualityComparer Class
Equals Overload
GSF.Data Namespace


DataSetEqualityComparer.GetHashCode Method

Grid Solutions Framework DataSetEqualityComparerGetHashCode Method
Overload List
 | Name | Description
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetHashCode(DataSet) | Returns a hash code for the specified object.
Top
See Also

Reference

DataSetEqualityComparer Class
GSF.Data Namespace


DataSetEqualityComparer.GetHashCode Method (DataSet)

Grid Solutions Framework DataSetEqualityComparerGetHashCode Method (DataSet)
Returns a hash code for the specified object.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GetHashCode(
    DataSet obj
)
Public Function GetHashCode (
    obj As DataSet
) As Integer
abstract GetHashCode :
        obj : DataSet -> int
override GetHashCode :
        obj : DataSet -> int
function GetHashCode(obj);
public:
virtual int GetHashCode(
    DataSet^ obj
) sealed

Parameters

obj
Type: System.DataDataSet
The DataSet for which a hash code is to be returned.

Return Value

Type: Int32
A hash code for the specified object.

Implements

IEqualityComparerTGetHashCode(T)
Exceptions
Exception | Condition
ArgumentNullException | The type of obj is a reference type and obj is null.
See Also

Reference

DataSetEqualityComparer Class
GetHashCode Overload
GSF.Data Namespace


DataSetExtensions Class

Grid Solutions Framework DataSetExtensions Class
Defines extension functions related to DataSet instances.
Inheritance Hierarchy
SystemObject
GSF.DataDataSetExtensions

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class DataSetExtensions
<ExtensionAttribute>
Public NotInheritable Class DataSetExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataSetExtensions =  class end
GSF.Data.DataSetExtensions = function();

Type.createClass(
    'GSF.Data.DataSetExtensions');
[ExtensionAttribute]
public ref class DataSetExtensions abstract sealed

The DataSetExtensions type exposes the following members.

Methods
Name | Description
DeriveColumnType | Gets column object Type from given DataType.
DeserializeToDataSet | Deserializes a DataSet from a Stream.
GetDataType | Attempts to derive DataType based on object Type.
SerializeToStream | Serializes a DataSet to a destination Stream.
Top
See Also

Reference

GSF.Data Namespace


DataSetExtensions Methods

Grid Solutions Framework DataSetExtensions Methods

The DataSetExtensions type exposes the following members.

Methods
Name | Description
DeriveColumnType | Gets column object Type from given DataType.
DeserializeToDataSet | Deserializes a DataSet from a Stream.
GetDataType | Attempts to derive DataType based on object Type.
SerializeToStream | Serializes a DataSet to a destination Stream.
Top
See Also

Reference

DataSetExtensions Class
GSF.Data Namespace


DataSetExtensions.DeriveColumnType Method

Grid Solutions Framework DataSetExtensionsDeriveColumnType Method
Gets column object Type from given DataType.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Type DeriveColumnType(
    this DataType dataType
)
<ExtensionAttribute>
Public Shared Function DeriveColumnType (
    dataType As DataType
) As Type
static member DeriveColumnType :
        dataType : DataType -> Type

GSF.Data.DataSetExtensions.DeriveColumnType = function(dataType);
public:
[ExtensionAttribute]
static Type^ DeriveColumnType(
    DataType dataType
)

Parameters

dataType
Type: GSF.DataDataType
DataType to derive object Type from.

Return Value

Type: Type
Object Type derived from given DataType.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataSetExtensions Class
GSF.Data Namespace


DataSetExtensions.DeserializeToDataSet Method

Grid Solutions Framework DataSetExtensionsDeserializeToDataSet Method
Deserializes a DataSet from a Stream.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet DeserializeToDataSet(
    this Stream source
)
<ExtensionAttribute>
Public Shared Function DeserializeToDataSet (
    source As Stream
) As DataSet
static member DeserializeToDataSet :
        source : Stream -> DataSet

GSF.Data.DataSetExtensions.DeserializeToDataSet = function(source);
public:
[ExtensionAttribute]
static DataSet^ DeserializeToDataSet(
    Stream^ source
)

Parameters

source
Type: System.IOStream
Stream to deserialize DataSet from.

Return Value

Type: DataSet

[Missing <returns> documentation for "M:GSF.Data.DataSetExtensions.DeserializeToDataSet(System.IO.Stream)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataSetExtensions Class
GSF.Data Namespace


DataSetExtensions.GetDataType Method

Grid Solutions Framework DataSetExtensionsGetDataType Method
Attempts to derive DataType based on object Type.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataType GetDataType(
    this Type objectType,
    bool assumeStringForUnknownTypes = true
)
<ExtensionAttribute>
Public Shared Function GetDataType (
    objectType As Type,
    Optional assumeStringForUnknownTypes As Boolean = true
) As DataType
static member GetDataType :
        objectType : Type *
        ?assumeStringForUnknownTypes : bool
(* Defaults:
        let _assumeStringForUnknownTypes = defaultArg assumeStringForUnknownTypes true
*)
-> DataType

GSF.Data.DataSetExtensions.GetDataType = function(objectType, assumeStringForUnknownTypes);
public:
[ExtensionAttribute]
static DataType GetDataType(
    Type^ objectType,
    bool assumeStringForUnknownTypes = true
)

Parameters

objectType
Type: SystemType
Type of object to test.
assumeStringForUnknownTypes (Optional)
Type: SystemBoolean
Flag to determine if unknown column types should be serialized as strings.

Return Value

Type: DataType
Derived DataType based on object Type if matched; otherwise Object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Type. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataSetExtensions Class
GSF.Data Namespace


DataSetExtensions.SerializeToStream Method

Grid Solutions Framework DataSetExtensionsSerializeToStream Method
Serializes a DataSet to a destination Stream.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SerializeToStream(
    this DataSet source,
    Stream destination,
    bool assumeStringForUnknownTypes = true
)
<ExtensionAttribute>
Public Shared Sub SerializeToStream (
    source As DataSet,
    destination As Stream,
    Optional assumeStringForUnknownTypes As Boolean = true
)
static member SerializeToStream :
        source : DataSet *
        destination : Stream *
        ?assumeStringForUnknownTypes : bool
(* Defaults:
        let _assumeStringForUnknownTypes = defaultArg assumeStringForUnknownTypes true
*)
-> unit

GSF.Data.DataSetExtensions.SerializeToStream = function(source, destination, assumeStringForUnknownTypes);
public:
[ExtensionAttribute]
static void SerializeToStream(
    DataSet^ source,
    Stream^ destination,
    bool assumeStringForUnknownTypes = true
)

Parameters

source
Type: System.DataDataSet
DataSet to serialize.
destination
Type: System.IOStream
Stream to serialize DataSet on.
assumeStringForUnknownTypes (Optional)
Type: SystemBoolean
Flag to determine if unknown column types should be serialized as strings.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type DataSet. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

DataSetExtensions Class
GSF.Data Namespace


DataType Enumeration

Grid Solutions Framework DataType Enumeration
Data types available to a DataSet object.

Namespace: GSF.Data
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DataType
Public Enumeration DataType
type DataType
GSF.Data.DataType = function();
GSF.Data.DataType.createEnum('GSF.Data.DataType', false);
public enum class DataType
Members
Member name | Value | Description
Boolean | 0 | Boolean data type, Boolean.
Byte | 1 | Unsigned 8-bit byte data type, Byte.
Char | 2 | 16-bit character data type, Char.
DateTime | 3 | Date/time data type, DateTime.
Decimal | 4 | Decimal data type, Decimal.
Double | 5 | 64-bit double precision floating point numeric data type, Double.
Guid | 6 | Unsigned 128-bit Guid integer data type, Guid.
Int16 | 7 | Signed 16-bit integer data type, Int16.
Int32 | 8 | Signed 32-bit integer data type, Int32.
Int64 | 9 | Signed 64-bit integer data type, Int64
SByte | 10 | Signed byte data type, SByte.
Single | 11 | 32-bit single precision floating point numeric data type, Single.
String | 12 | Character array data type, String.
TimeSpan | 13 | Time-span data type, TimeSpan.
UInt16 | 14 | Unsigned 16-bit integer data type, UInt16.
UInt32 | 15 | Unsigned 32-bit integer data type, UInt32.
UInt64 | 16 | Unsigned 64-bit integer data type, UInt64.
Blob | 17 | Unsigned byte array data type.
Object | 18 | User defined/other data type.
See Also

Reference

GSF.Data Namespace


GSF.Diagnostics Namespace

Grid Solutions Framework GSF.Diagnostics Namespace
Contains classes used to simplify and standardize performance monitoring for applications.
Classes
Class | Description
PerformanceCounter | Represents an extension of the basic PerformanceCounter providing additional statistical logic.
PerformanceMonitor | Represents a process performance monitor that operates similar to the Windows Performance Monitor utility that can be used to monitor system performance.


PerformanceCounter Class

Grid Solutions Framework PerformanceCounter Class
Represents an extension of the basic PerformanceCounter providing additional statistical logic.
Inheritance Hierarchy
SystemObject
GSF.DiagnosticsPerformanceCounter

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PerformanceCounter : IDisposable
Public Class PerformanceCounter
    Implements IDisposable
type PerformanceCounter =
    class
        interface IDisposable
    end
GSF.Diagnostics.PerformanceCounter = function();

Type.createClass(
    'GSF.Diagnostics.PerformanceCounter',
    null,
    IDisposable);
public ref class PerformanceCounter : IDisposable

The PerformanceCounter type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceCounter(String, String, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, String, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, String, String, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, String, String, String, Single, Boolean) | Initializes a new instance of the PerformanceCounter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the PerformanceCounter object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PerformanceCounter object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the PerformanceCounter object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the PerformanceCounter object to its initial state.
Public method | Sample | Obtains a sample value from the BaseCounter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultSamplingWindow | Default number of samples over which statistical values are to be calculated.
DefaultValueDivisor | Default divisor to be applied to the statistical value.
DefaultValueUnit | Default measurement unit of the statistical values.
Top
Properties
 | Name | Description
Public property | AliasName | Gets or sets an alias name for the PerformanceCounter.
Public property | AverageValue | Gets the average value from the samples of the BaseCounter.
Public property | BaseCounter | Gets the PerformanceCounter object that this PerformanceCounter objects wraps.
Public property | LastValue | Gets the last sample value from the samples of the BaseCounter.
Public property | LifetimeAverageValue | Gets the average sample value over the entire lifetime of the BaseCounter.
Public property | LifetimeMaximumValue | Gets the maximum sample value over the entire lifetime of the BaseCounter.
Public property | LifetimeSampleCount | Gets the total values sampled over the entire lifetime of the BaseCounter.
Public property | MaximumValue | Gets the maximum sample value from the samples of the BaseCounter.
Public property | MinimumValue | Gets the minimum sample value from the samples of the BaseCounter.
Public property | Samples | Gets a list of sampled values from the BaseCounter
Public property | SamplingWindow | Gets or sets the number of samples to use to determine the LastValue, MinimumValue, MaximumValue and AverageValue.
Public property | ValueDivisor | Gets or sets the divisor to be applied to the LastValue, MinimumValue, MaximumValue and AverageValue.
Public property | ValueUnit | Gets or sets the measurement unit of LastValue, MinimumValue, MaximumValue and AverageValue
Top
Examples
This example shows how to create a performance counter for processor utilization:
Copy
using System;
using System.Threading;
using GSF.Diagnostics;

class Program
{
    static void Main(string[] args)
    {
        PerformanceCounter counter = new PerformanceCounter("Processor", "% Processor Time", "_Total");
        while (true)
        {
            Thread.Sleep(1000);
            counter.Sample();
            Console.WriteLine(string.Format("Last value: {0}", counter.LastValue));
            Console.WriteLine(string.Format("Minimum value: {0}", counter.MinimumValue));
            Console.WriteLine(string.Format("Maximum value: {0}", counter.MaximumValue));
            Console.WriteLine(string.Format("Average value: {0}", counter.AverageValue));
            Console.WriteLine(new string('-', 30));
        }
    }
}
See Also

Reference

GSF.Diagnostics Namespace


PerformanceCounter Constructor

Grid Solutions Framework PerformanceCounter Constructor
Overload List
 | Name | Description
Public method | PerformanceCounter(String, String, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, String, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, String, String, String) | Initializes a new instance of the PerformanceCounter class.
Public method | PerformanceCounter(String, String, String, String, String, Single, Boolean) | Initializes a new instance of the PerformanceCounter class.
Top
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter Constructor (String, String, String)

Grid Solutions Framework PerformanceCounter Constructor (String, String, String)
Initializes a new instance of the PerformanceCounter class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter(
    string categoryName,
    string counterName,
    string instanceName
)
Public Sub New (
    categoryName As String,
    counterName As String,
    instanceName As String
)
new :
        categoryName : string *
        counterName : string *
        instanceName : string -> PerformanceCounter
GSF.Diagnostics.PerformanceCounter = function(categoryName, counterName, instanceName);
public:
PerformanceCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
See Also

Reference

PerformanceCounter Class
PerformanceCounter Overload
GSF.Diagnostics Namespace


PerformanceCounter Constructor (String, String, String, String)

Grid Solutions Framework PerformanceCounter Constructor (String, String, String, String)
Initializes a new instance of the PerformanceCounter class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter(
    string categoryName,
    string counterName,
    string instanceName,
    string aliasName
)
Public Sub New (
    categoryName As String,
    counterName As String,
    instanceName As String,
    aliasName As String
)
new :
        categoryName : string *
        counterName : string *
        instanceName : string *
        aliasName : string -> PerformanceCounter
GSF.Diagnostics.PerformanceCounter = function(categoryName, counterName, instanceName, aliasName);
public:
PerformanceCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName,
    String^ aliasName
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
aliasName
Type: SystemString
The alias name for the PerformanceCounter object.
See Also

Reference

PerformanceCounter Class
PerformanceCounter Overload
GSF.Diagnostics Namespace


PerformanceCounter Constructor (String, String, String, String, String)

Grid Solutions Framework PerformanceCounter Constructor (String, String, String, String, String)
Initializes a new instance of the PerformanceCounter class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter(
    string categoryName,
    string counterName,
    string instanceName,
    string aliasName,
    string valueUnit
)
Public Sub New (
    categoryName As String,
    counterName As String,
    instanceName As String,
    aliasName As String,
    valueUnit As String
)
new :
        categoryName : string *
        counterName : string *
        instanceName : string *
        aliasName : string *
        valueUnit : string -> PerformanceCounter
GSF.Diagnostics.PerformanceCounter = function(categoryName, counterName, instanceName, aliasName, valueUnit);
public:
PerformanceCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName,
    String^ aliasName,
    String^ valueUnit
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
aliasName
Type: SystemString
The alias name for the PerformanceCounter object.
valueUnit
Type: SystemString
The measurement unit for the statistical values of the PerformanceCounter object.
See Also

Reference

PerformanceCounter Class
PerformanceCounter Overload
GSF.Diagnostics Namespace


PerformanceCounter Constructor (String, String, String, String, String, Single, Boolean)

Grid Solutions Framework PerformanceCounter Constructor (String, String, String, String, String, Single, Boolean)
Initializes a new instance of the PerformanceCounter class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter(
    string categoryName,
    string counterName,
    string instanceName,
    string aliasName,
    string valueUnit,
    float valueDivisor,
    bool readOnly = true
)
Public Sub New (
    categoryName As String,
    counterName As String,
    instanceName As String,
    aliasName As String,
    valueUnit As String,
    valueDivisor As Single,
    Optional readOnly As Boolean = true
)
new :
        categoryName : string *
        counterName : string *
        instanceName : string *
        aliasName : string *
        valueUnit : string *
        valueDivisor : float32 *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly true
*)
-> PerformanceCounter
GSF.Diagnostics.PerformanceCounter = function(categoryName, counterName, instanceName, aliasName, valueUnit, valueDivisor, readOnly);
public:
PerformanceCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName,
    String^ aliasName,
    String^ valueUnit,
    float valueDivisor,
    bool readOnly = true
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
aliasName
Type: SystemString
The alias name for the PerformanceCounter object.
valueUnit
Type: SystemString
The measurement unit for the statistical values of the PerformanceCounter object.
valueDivisor
Type: SystemSingle
The divisor to be applied to the statistical values of the PerformanceCounter object.
readOnly (Optional)
Type: SystemBoolean
Flag that determines if this counter is read-only.
See Also

Reference

PerformanceCounter Class
PerformanceCounter Overload
GSF.Diagnostics Namespace


PerformanceCounter Fields

Grid Solutions Framework PerformanceCounter Fields

The PerformanceCounter type exposes the following members.

Fields
Name | Description
DefaultSamplingWindow | Default number of samples over which statistical values are to be calculated.
DefaultValueDivisor | Default divisor to be applied to the statistical value.
DefaultValueUnit | Default measurement unit of the statistical values.
Top
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.DefaultSamplingWindow Field

Grid Solutions Framework PerformanceCounterDefaultSamplingWindow Field
Default number of samples over which statistical values are to be calculated.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultSamplingWindow
Public Const DefaultSamplingWindow As Integer
static val mutable DefaultSamplingWindow: int
var GSF.Diagnostics.PerformanceCounter.DefaultSamplingWindow
public:
literal int DefaultSamplingWindow

Field Value

Type: Int32
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.DefaultValueDivisor Field

Grid Solutions Framework PerformanceCounterDefaultValueDivisor Field
Default divisor to be applied to the statistical value.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const float DefaultValueDivisor
Public Const DefaultValueDivisor As Single
static val mutable DefaultValueDivisor: float32
var GSF.Diagnostics.PerformanceCounter.DefaultValueDivisor
public:
literal float DefaultValueDivisor

Field Value

Type: Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.DefaultValueUnit Field

Grid Solutions Framework PerformanceCounterDefaultValueUnit Field
Default measurement unit of the statistical values.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultValueUnit
Public Const DefaultValueUnit As String
static val mutable DefaultValueUnit: string
var GSF.Diagnostics.PerformanceCounter.DefaultValueUnit
public:
literal String^ DefaultValueUnit

Field Value

Type: String
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter Methods

Grid Solutions Framework PerformanceCounter Methods

The PerformanceCounter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the PerformanceCounter object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PerformanceCounter object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the PerformanceCounter object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the PerformanceCounter object to its initial state.
Public method | Sample | Obtains a sample value from the BaseCounter.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.Dispose Method

Grid Solutions Framework PerformanceCounterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the PerformanceCounter object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PerformanceCounter object and optionally releases the managed resources.
Top
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.Dispose Method

Grid Solutions Framework PerformanceCounterDispose Method
Releases all the resources used by the PerformanceCounter object.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PerformanceCounter Class
Dispose Overload
GSF.Diagnostics Namespace


PerformanceCounter.Dispose Method (Boolean)

Grid Solutions Framework PerformanceCounterDispose Method (Boolean)
Releases the unmanaged resources used by the PerformanceCounter object and optionally releases the managed resources.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

PerformanceCounter Class
Dispose Overload
GSF.Diagnostics Namespace


PerformanceCounter.Finalize Method

Grid Solutions Framework PerformanceCounterFinalize Method
Releases the unmanaged resources before the PerformanceCounter object is reclaimed by GC.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.Reset Method

Grid Solutions Framework PerformanceCounterReset Method
Resets the PerformanceCounter object to its initial state.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.Sample Method

Grid Solutions Framework PerformanceCounterSample Method
Obtains a sample value from the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Sample()
Public Sub Sample
member Sample : unit -> unit

function Sample();
public:
void Sample()
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter Properties

Grid Solutions Framework PerformanceCounter Properties

The PerformanceCounter type exposes the following members.

Properties
 | Name | Description
Public property | AliasName | Gets or sets an alias name for the PerformanceCounter.
Public property | AverageValue | Gets the average value from the samples of the BaseCounter.
Public property | BaseCounter | Gets the PerformanceCounter object that this PerformanceCounter objects wraps.
Public property | LastValue | Gets the last sample value from the samples of the BaseCounter.
Public property | LifetimeAverageValue | Gets the average sample value over the entire lifetime of the BaseCounter.
Public property | LifetimeMaximumValue | Gets the maximum sample value over the entire lifetime of the BaseCounter.
Public property | LifetimeSampleCount | Gets the total values sampled over the entire lifetime of the BaseCounter.
Public property | MaximumValue | Gets the maximum sample value from the samples of the BaseCounter.
Public property | MinimumValue | Gets the minimum sample value from the samples of the BaseCounter.
Public property | Samples | Gets a list of sampled values from the BaseCounter
Public property | SamplingWindow | Gets or sets the number of samples to use to determine the LastValue, MinimumValue, MaximumValue and AverageValue.
Public property | ValueDivisor | Gets or sets the divisor to be applied to the LastValue, MinimumValue, MaximumValue and AverageValue.
Public property | ValueUnit | Gets or sets the measurement unit of LastValue, MinimumValue, MaximumValue and AverageValue
Top
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.AliasName Property

Grid Solutions Framework PerformanceCounterAliasName Property
Gets or sets an alias name for the PerformanceCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AliasName { get; set; }
Public Property AliasName As String
    Get
    Set
member AliasName : string with get, set

function get_AliasName();
function set_AliasName(value);
public:
property String^ AliasName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.AverageValue Property

Grid Solutions Framework PerformanceCounterAverageValue Property
Gets the average value from the samples of the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float AverageValue { get; }
Public ReadOnly Property AverageValue As Single
    Get
member AverageValue : float32 with get

function get_AverageValue();

public:
property float AverageValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.BaseCounter Property

Grid Solutions Framework PerformanceCounterBaseCounter Property
Gets the PerformanceCounter object that this PerformanceCounter objects wraps.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter BaseCounter { get; }
Public ReadOnly Property BaseCounter As PerformanceCounter
    Get
member BaseCounter : PerformanceCounter with get

function get_BaseCounter();

public:
property PerformanceCounter^ BaseCounter {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.LastValue Property

Grid Solutions Framework PerformanceCounterLastValue Property
Gets the last sample value from the samples of the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LastValue { get; }
Public ReadOnly Property LastValue As Single
    Get
member LastValue : float32 with get

function get_LastValue();

public:
property float LastValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.LifetimeAverageValue Property

Grid Solutions Framework PerformanceCounterLifetimeAverageValue Property
Gets the average sample value over the entire lifetime of the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LifetimeAverageValue { get; }
Public ReadOnly Property LifetimeAverageValue As Single
    Get
member LifetimeAverageValue : float32 with get

function get_LifetimeAverageValue();

public:
property float LifetimeAverageValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.LifetimeMaximumValue Property

Grid Solutions Framework PerformanceCounterLifetimeMaximumValue Property
Gets the maximum sample value over the entire lifetime of the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LifetimeMaximumValue { get; }
Public ReadOnly Property LifetimeMaximumValue As Single
    Get
member LifetimeMaximumValue : float32 with get

function get_LifetimeMaximumValue();

public:
property float LifetimeMaximumValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.LifetimeSampleCount Property

Grid Solutions Framework PerformanceCounterLifetimeSampleCount Property
Gets the total values sampled over the entire lifetime of the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long LifetimeSampleCount { get; }
Public ReadOnly Property LifetimeSampleCount As Long
    Get
member LifetimeSampleCount : int64 with get

function get_LifetimeSampleCount();

public:
property long long LifetimeSampleCount {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.MaximumValue Property

Grid Solutions Framework PerformanceCounterMaximumValue Property
Gets the maximum sample value from the samples of the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float MaximumValue { get; }
Public ReadOnly Property MaximumValue As Single
    Get
member MaximumValue : float32 with get

function get_MaximumValue();

public:
property float MaximumValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.MinimumValue Property

Grid Solutions Framework PerformanceCounterMinimumValue Property
Gets the minimum sample value from the samples of the BaseCounter.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float MinimumValue { get; }
Public ReadOnly Property MinimumValue As Single
    Get
member MinimumValue : float32 with get

function get_MinimumValue();

public:
property float MinimumValue {
    float get ();
}

Property Value

Type: Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.Samples Property

Grid Solutions Framework PerformanceCounterSamples Property
Gets a list of sampled values from the BaseCounter

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<float> Samples { get; }
Public ReadOnly Property Samples As List(Of Single)
    Get
member Samples : List<float32> with get

function get_Samples();

public:
property List<float>^ Samples {
    List<float>^ get ();
}

Property Value

Type: List Single
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.SamplingWindow Property

Grid Solutions Framework PerformanceCounterSamplingWindow Property
Gets or sets the number of samples to use to determine the LastValue, MinimumValue, MaximumValue and AverageValue.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SamplingWindow { get; set; }
Public Property SamplingWindow As Integer
    Get
    Set
member SamplingWindow : int with get, set

function get_SamplingWindow();
function set_SamplingWindow(value);
public:
property int SamplingWindow {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is not greater than 0.
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.ValueDivisor Property

Grid Solutions Framework PerformanceCounterValueDivisor Property
Gets or sets the divisor to be applied to the LastValue, MinimumValue, MaximumValue and AverageValue.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ValueDivisor { get; set; }
Public Property ValueDivisor As Single
    Get
    Set
member ValueDivisor : float32 with get, set

function get_ValueDivisor();
function set_ValueDivisor(value);
public:
property float ValueDivisor {
    float get ();
    void set (float value);
}

Property Value

Type: Single
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is not greater than 0.
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceCounter.ValueUnit Property

Grid Solutions Framework PerformanceCounterValueUnit Property
Gets or sets the measurement unit of LastValue, MinimumValue, MaximumValue and AverageValue

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ValueUnit { get; set; }
Public Property ValueUnit As String
    Get
    Set
member ValueUnit : string with get, set

function get_ValueUnit();
function set_ValueUnit(value);
public:
property String^ ValueUnit {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

PerformanceCounter Class
GSF.Diagnostics Namespace


PerformanceMonitor Class

Grid Solutions Framework PerformanceMonitor Class
Represents a process performance monitor that operates similar to the Windows Performance Monitor utility that can be used to monitor system performance.
Inheritance Hierarchy
SystemObject
GSF.DiagnosticsPerformanceMonitor

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PerformanceMonitor : IDisposable,
    IProvideStatus
Public Class PerformanceMonitor
    Implements IDisposable, IProvideStatus
type PerformanceMonitor =
    class
        interface IDisposable
        interface IProvideStatus
    end
GSF.Diagnostics.PerformanceMonitor = function();

Type.createClass(
    'GSF.Diagnostics.PerformanceMonitor',
    null,
    IDisposable,
    GSF.IProvideStatus);
public ref class PerformanceMonitor : IDisposable,
    IProvideStatus

The PerformanceMonitor type exposes the following members.

Constructors
 | Name | Description
Public method | PerformanceMonitor | Initializes a new instance of the PerformanceMonitor class.
Public method | PerformanceMonitor(Double, Boolean) | Initializes a new instance of the PerformanceMonitor class.
Public method | PerformanceMonitor(String, Boolean) | Initializes a new instance of the PerformanceMonitor class.
Public method | PerformanceMonitor(String, Double, Boolean) | Initializes a new instance of the PerformanceMonitor class.
Top
Methods
 | Name | Description
Public method | AddCounter(PerformanceCounter) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String, String, Single, Boolean) | Adds a PerformanceCounter to be monitored.
Public method | Dispose | Releases all the resources used by the PerformanceMonitor object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PerformanceMonitor object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the PerformanceMonitor object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | FindCounter(String) | Returns a PerformanceCounter object matching the specified counter name.
Public method | FindCounter(String, String) | Returns a PerformanceCounter object matching the specified counter name.
Public method | FindCounters(String) | Returns PerformanceCounter array matching the specified counter name.
Public method | FindCounters(String, String) | Returns PerformanceCounter array matching the specified counter name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCounter | Removes a PerformanceCounter being monitored.
Public method | SampleCounters | Sample all defined counters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultSamplingInterval | Default interval for sampling the Counters.
ThreadPoolCountersCategoryName | Name of the custom thread pool counters category.
Top
Properties
 | Name | Description
Public property | Counters | Gets a read-only list of the PerformanceCounter objects monitored by the PerformanceMonitor object.
Public property | CPUUsage | Gets the PerformanceCounter that monitors the processor utilization of the monitored process.
Public property | HandleCount | Gets the PerformanceCounter that monitors the total number of handles currently open by the monitored process.
Public property | IOActivity | Gets the PerformanceCounter that monitors the rate at which the monitored process is issuing read and write I/O operations.
Public property | IOUsage | Gets the PerformanceCounter that monitors the rate at which the monitored process is issuing bytes to I/O operations that do not involve data such as control operations.
Public property | IPDataReceiveRate | Gets the PerformanceCounter that monitors the IP based datagrams received / second of the system.
Public property | IPDataSendRate | Gets the PerformanceCounter that monitors the IP based datagrams sent / second of the system.
Public property | LifetimeStatus | Gets the lifetime status statistics of the PerformanceMonitor object.
Public property | MemoryUsage | Gets the PerformanceCounter that monitors the memory utilization of the monitored process.
Public property | Name | Gets the friendly name of the PerformanceMonitor object.
Public property | ProcessName | Gets or sets the name of the Process to be monitored.
Public property | SamplingInterval | Gets or sets the interval, in milliseconds, at which the Counters are to be sampled.
Public property | Status | Gets the current status of the PerformanceMonitor object.
Public property | ThreadCount | Gets the PerformanceCounter that monitors the number of threads currently active in the monitored process.
Public property | ThreadingContentionRate | Gets the PerformanceCounter that monitors the .NET threading contention rate / second of the process.
Top
Examples
This example shows how to use PerformanceMonitor for monitoring application performance:
Copy
using System;
using System.Threading;
using GSF.Diagnostics;

class Program
{
    static void Main(string[] args)
    {
        PerformanceMonitor perfMon = new PerformanceMonitor();
        while (true)
        {
            // Display process performance.
            Thread.Sleep(5000);
            Console.WriteLine("");
            Console.Write(perfMon.Status);
        }
    }
}
See Also

Reference

GSF.Diagnostics Namespace
GSF.DiagnosticsPerformanceCounter


PerformanceMonitor Constructor

Grid Solutions Framework PerformanceMonitor Constructor
Overload List
 | Name | Description
Public method | PerformanceMonitor | Initializes a new instance of the PerformanceMonitor class.
Public method | PerformanceMonitor(Double, Boolean) | Initializes a new instance of the PerformanceMonitor class.
Public method | PerformanceMonitor(String, Boolean) | Initializes a new instance of the PerformanceMonitor class.
Public method | PerformanceMonitor(String, Double, Boolean) | Initializes a new instance of the PerformanceMonitor class.
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor Constructor

Grid Solutions Framework PerformanceMonitor Constructor
Initializes a new instance of the PerformanceMonitor class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceMonitor()
Public Sub New
new : unit -> PerformanceMonitor
GSF.Diagnostics.PerformanceMonitor = function();
public:
PerformanceMonitor()
See Also

Reference

PerformanceMonitor Class
PerformanceMonitor Overload
GSF.Diagnostics Namespace


PerformanceMonitor Constructor (Double, Boolean)

Grid Solutions Framework PerformanceMonitor Constructor (Double, Boolean)
Initializes a new instance of the PerformanceMonitor class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceMonitor(
    double samplingInterval,
    bool addDefaultCounters = true
)
Public Sub New (
    samplingInterval As Double,
    Optional addDefaultCounters As Boolean = true
)
new :
        samplingInterval : float *
        ?addDefaultCounters : bool
(* Defaults:
        let _addDefaultCounters = defaultArg addDefaultCounters true
*)
-> PerformanceMonitor
GSF.Diagnostics.PerformanceMonitor = function(samplingInterval, addDefaultCounters);
public:
PerformanceMonitor(
    double samplingInterval,
    bool addDefaultCounters = true
)

Parameters

samplingInterval
Type: SystemDouble
Interval, in milliseconds, at which the Counters are to be sampled.
addDefaultCounters (Optional)
Type: SystemBoolean
Set to true to add default counters; otherwise false.
See Also

Reference

PerformanceMonitor Class
PerformanceMonitor Overload
GSF.Diagnostics Namespace


PerformanceMonitor Constructor (String, Boolean)

Grid Solutions Framework PerformanceMonitor Constructor (String, Boolean)
Initializes a new instance of the PerformanceMonitor class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceMonitor(
    string processName,
    bool addDefaultCounters = true
)
Public Sub New (
    processName As String,
    Optional addDefaultCounters As Boolean = true
)
new :
        processName : string *
        ?addDefaultCounters : bool
(* Defaults:
        let _addDefaultCounters = defaultArg addDefaultCounters true
*)
-> PerformanceMonitor
GSF.Diagnostics.PerformanceMonitor = function(processName, addDefaultCounters);
public:
PerformanceMonitor(
    String^ processName,
    bool addDefaultCounters = true
)

Parameters

processName
Type: SystemString
Name of the Process whose performance is to be monitored.
addDefaultCounters (Optional)
Type: SystemBoolean
Set to true to add default counters; otherwise false.
See Also

Reference

PerformanceMonitor Class
PerformanceMonitor Overload
GSF.Diagnostics Namespace


PerformanceMonitor Constructor (String, Double, Boolean)

Grid Solutions Framework PerformanceMonitor Constructor (String, Double, Boolean)
Initializes a new instance of the PerformanceMonitor class.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceMonitor(
    string processName,
    double samplingInterval,
    bool addDefaultCounters = true
)
Public Sub New (
    processName As String,
    samplingInterval As Double,
    Optional addDefaultCounters As Boolean = true
)
new :
        processName : string *
        samplingInterval : float *
        ?addDefaultCounters : bool
(* Defaults:
        let _addDefaultCounters = defaultArg addDefaultCounters true
*)
-> PerformanceMonitor
GSF.Diagnostics.PerformanceMonitor = function(processName, samplingInterval, addDefaultCounters);
public:
PerformanceMonitor(
    String^ processName,
    double samplingInterval,
    bool addDefaultCounters = true
)

Parameters

processName
Type: SystemString
Name of the Process whose performance is to be monitored.
samplingInterval
Type: SystemDouble
Interval, in milliseconds, at which the Counters are to be sampled.
addDefaultCounters (Optional)
Type: SystemBoolean
Set to true to add default counters; otherwise false.
See Also

Reference

PerformanceMonitor Class
PerformanceMonitor Overload
GSF.Diagnostics Namespace


PerformanceMonitor Fields

Grid Solutions Framework PerformanceMonitor Fields

The PerformanceMonitor type exposes the following members.

Fields
Name | Description
DefaultSamplingInterval | Default interval for sampling the Counters.
ThreadPoolCountersCategoryName | Name of the custom thread pool counters category.
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.DefaultSamplingInterval Field

Grid Solutions Framework PerformanceMonitorDefaultSamplingInterval Field
Default interval for sampling the Counters.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultSamplingInterval
Public Const DefaultSamplingInterval As Double
static val mutable DefaultSamplingInterval: float
var GSF.Diagnostics.PerformanceMonitor.DefaultSamplingInterval
public:
literal double DefaultSamplingInterval

Field Value

Type: Double
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.ThreadPoolCountersCategoryName Field

Grid Solutions Framework PerformanceMonitorThreadPoolCountersCategoryName Field
Name of the custom thread pool counters category.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string ThreadPoolCountersCategoryName
Public Const ThreadPoolCountersCategoryName As String
static val mutable ThreadPoolCountersCategoryName: string
var GSF.Diagnostics.PerformanceMonitor.ThreadPoolCountersCategoryName
public:
literal String^ ThreadPoolCountersCategoryName

Field Value

Type: String
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor Methods

Grid Solutions Framework PerformanceMonitor Methods

The PerformanceMonitor type exposes the following members.

Methods
 | Name | Description
Public method | AddCounter(PerformanceCounter) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String, String, Single, Boolean) | Adds a PerformanceCounter to be monitored.
Public method | Dispose | Releases all the resources used by the PerformanceMonitor object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PerformanceMonitor object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the PerformanceMonitor object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | FindCounter(String) | Returns a PerformanceCounter object matching the specified counter name.
Public method | FindCounter(String, String) | Returns a PerformanceCounter object matching the specified counter name.
Public method | FindCounters(String) | Returns PerformanceCounter array matching the specified counter name.
Public method | FindCounters(String, String) | Returns PerformanceCounter array matching the specified counter name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveCounter | Removes a PerformanceCounter being monitored.
Public method | SampleCounters | Sample all defined counters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.AddCounter Method

Grid Solutions Framework PerformanceMonitorAddCounter Method
Overload List
 | Name | Description
Public method | AddCounter(PerformanceCounter) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String, String) | Adds a PerformanceCounter to be monitored.
Public method | AddCounter(String, String, String, String, String, Single, Boolean) | Adds a PerformanceCounter to be monitored.
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.AddCounter Method (PerformanceCounter)

Grid Solutions Framework PerformanceMonitorAddCounter Method (PerformanceCounter)
Adds a PerformanceCounter to be monitored.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddCounter(
    PerformanceCounter counter
)
Public Sub AddCounter (
    counter As PerformanceCounter
)
member AddCounter :
        counter : PerformanceCounter -> unit

function AddCounter(counter);
public:
void AddCounter(
    PerformanceCounter^ counter
)

Parameters

counter
Type: GSF.DiagnosticsPerformanceCounter
The PerformanceCounter object to be monitored.
See Also

Reference

PerformanceMonitor Class
AddCounter Overload
GSF.Diagnostics Namespace


PerformanceMonitor.AddCounter Method (String, String, String)

Grid Solutions Framework PerformanceMonitorAddCounter Method (String, String, String)
Adds a PerformanceCounter to be monitored.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddCounter(
    string categoryName,
    string counterName,
    string instanceName
)
Public Sub AddCounter (
    categoryName As String,
    counterName As String,
    instanceName As String
)
member AddCounter :
        categoryName : string *
        counterName : string *
        instanceName : string -> unit

function AddCounter(categoryName, counterName, instanceName);
public:
void AddCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
See Also

Reference

PerformanceMonitor Class
AddCounter Overload
GSF.Diagnostics Namespace


PerformanceMonitor.AddCounter Method (String, String, String, String)

Grid Solutions Framework PerformanceMonitorAddCounter Method (String, String, String, String)
Adds a PerformanceCounter to be monitored.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddCounter(
    string categoryName,
    string counterName,
    string instanceName,
    string aliasName
)
Public Sub AddCounter (
    categoryName As String,
    counterName As String,
    instanceName As String,
    aliasName As String
)
member AddCounter :
        categoryName : string *
        counterName : string *
        instanceName : string *
        aliasName : string -> unit

function AddCounter(categoryName, counterName, instanceName, aliasName);
public:
void AddCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName,
    String^ aliasName
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
aliasName
Type: SystemString
The alias name for the PerformanceCounter object.
See Also

Reference

PerformanceMonitor Class
AddCounter Overload
GSF.Diagnostics Namespace


PerformanceMonitor.AddCounter Method (String, String, String, String, String)

Grid Solutions Framework PerformanceMonitorAddCounter Method (String, String, String, String, String)
Adds a PerformanceCounter to be monitored.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddCounter(
    string categoryName,
    string counterName,
    string instanceName,
    string aliasName,
    string valueUnit
)
Public Sub AddCounter (
    categoryName As String,
    counterName As String,
    instanceName As String,
    aliasName As String,
    valueUnit As String
)
member AddCounter :
        categoryName : string *
        counterName : string *
        instanceName : string *
        aliasName : string *
        valueUnit : string -> unit

function AddCounter(categoryName, counterName, instanceName, aliasName, valueUnit);
public:
void AddCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName,
    String^ aliasName,
    String^ valueUnit
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
aliasName
Type: SystemString
The alias name for the PerformanceCounter object.
valueUnit
Type: SystemString
The measurement unit for the statistical values of the PerformanceCounter object.
See Also

Reference

PerformanceMonitor Class
AddCounter Overload
GSF.Diagnostics Namespace


PerformanceMonitor.AddCounter Method (String, String, String, String, String, Single, Boolean)

Grid Solutions Framework PerformanceMonitorAddCounter Method (String, String, String, String, String, Single, Boolean)
Adds a PerformanceCounter to be monitored.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddCounter(
    string categoryName,
    string counterName,
    string instanceName,
    string aliasName,
    string valueUnit,
    float valueDivisor,
    bool readOnly = true
)
Public Sub AddCounter (
    categoryName As String,
    counterName As String,
    instanceName As String,
    aliasName As String,
    valueUnit As String,
    valueDivisor As Single,
    Optional readOnly As Boolean = true
)
member AddCounter :
        categoryName : string *
        counterName : string *
        instanceName : string *
        aliasName : string *
        valueUnit : string *
        valueDivisor : float32 *
        ?readOnly : bool
(* Defaults:
        let _readOnly = defaultArg readOnly true
*)
-> unit

function AddCounter(categoryName, counterName, instanceName, aliasName, valueUnit, valueDivisor, readOnly);
public:
void AddCounter(
    String^ categoryName,
    String^ counterName,
    String^ instanceName,
    String^ aliasName,
    String^ valueUnit,
    float valueDivisor,
    bool readOnly = true
)

Parameters

categoryName
Type: SystemString
The name of the performance counter category (performance object) with which this performance counter is associated.
counterName
Type: SystemString
The name of the performance counter.
instanceName
Type: SystemString
The name of the performance counter category instance, or an empty string (""), if the category contains a single instance.
aliasName
Type: SystemString
The alias name for the PerformanceCounter object.
valueUnit
Type: SystemString
The measurement unit for the statistical values of the PerformanceCounter object.
valueDivisor
Type: SystemSingle
The divisor to be applied to the statistical values of the PerformanceCounter object.
readOnly (Optional)
Type: SystemBoolean
Flag that determines if this counter is read-only.
See Also

Reference

PerformanceMonitor Class
AddCounter Overload
GSF.Diagnostics Namespace


PerformanceMonitor.Dispose Method

Grid Solutions Framework PerformanceMonitorDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the PerformanceMonitor object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the PerformanceMonitor object and optionally releases the managed resources.
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.Dispose Method

Grid Solutions Framework PerformanceMonitorDispose Method
Releases all the resources used by the PerformanceMonitor object.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PerformanceMonitor Class
Dispose Overload
GSF.Diagnostics Namespace


PerformanceMonitor.Dispose Method (Boolean)

Grid Solutions Framework PerformanceMonitorDispose Method (Boolean)
Releases the unmanaged resources used by the PerformanceMonitor object and optionally releases the managed resources.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

PerformanceMonitor Class
Dispose Overload
GSF.Diagnostics Namespace


PerformanceMonitor.Finalize Method

Grid Solutions Framework PerformanceMonitorFinalize Method
Releases the unmanaged resources before the PerformanceMonitor object is reclaimed by GC.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.FindCounter Method

Grid Solutions Framework PerformanceMonitorFindCounter Method
Overload List
 | Name | Description
Public method | FindCounter(String) | Returns a PerformanceCounter object matching the specified counter name.
Public method | FindCounter(String, String) | Returns a PerformanceCounter object matching the specified counter name.
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.FindCounter Method (String)

Grid Solutions Framework PerformanceMonitorFindCounter Method (String)
Returns a PerformanceCounter object matching the specified counter name.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter FindCounter(
    string counterName
)
Public Function FindCounter (
    counterName As String
) As PerformanceCounter
member FindCounter :
        counterName : string -> PerformanceCounter

function FindCounter(counterName);
public:
PerformanceCounter^ FindCounter(
    String^ counterName
)

Parameters

counterName
Type: SystemString
Name of the PerformanceCounter to be retrieved.

Return Value

Type: PerformanceCounter
A PerformanceCounter object if a match is found; otherwise null.
Remarks
First PerformanceCounter with matching name is returned. If same name exists within multiple monitored categories, use FindCounter(String, String) overload instead.
See Also

Reference

PerformanceMonitor Class
FindCounter Overload
GSF.Diagnostics Namespace


PerformanceMonitor.FindCounter Method (String, String)

Grid Solutions Framework PerformanceMonitorFindCounter Method (String, String)
Returns a PerformanceCounter object matching the specified counter name.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter FindCounter(
    string categoryName,
    string counterName
)
Public Function FindCounter (
    categoryName As String,
    counterName As String
) As PerformanceCounter
member FindCounter :
        categoryName : string *
        counterName : string -> PerformanceCounter

function FindCounter(categoryName, counterName);
public:
PerformanceCounter^ FindCounter(
    String^ categoryName,
    String^ counterName
)

Parameters

categoryName
Type: SystemString
Category of the PerformanceCounter to be retrieved.
counterName
Type: SystemString
Name of the PerformanceCounter to be retrieved.

Return Value

Type: PerformanceCounter
A PerformanceCounter object if a match is found; otherwise null.
See Also

Reference

PerformanceMonitor Class
FindCounter Overload
GSF.Diagnostics Namespace


PerformanceMonitor.FindCounters Method

Grid Solutions Framework PerformanceMonitorFindCounters Method
Overload List
 | Name | Description
Public method | FindCounters(String) | Returns PerformanceCounter array matching the specified counter name.
Public method | FindCounters(String, String) | Returns PerformanceCounter array matching the specified counter name.
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.FindCounters Method (String)

Grid Solutions Framework PerformanceMonitorFindCounters Method (String)
Returns PerformanceCounter array matching the specified counter name.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter[] FindCounters(
    string counterName
)
Public Function FindCounters (
    counterName As String
) As PerformanceCounter()
member FindCounters :
        counterName : string -> PerformanceCounter[]

function FindCounters(counterName);
public:
array<PerformanceCounter^>^ FindCounters(
    String^ counterName
)

Parameters

counterName
Type: SystemString
Name of the PerformanceCounter to be retrieved.

Return Value

Type: PerformanceCounter
A PerformanceCounter array of found matches, if any.
See Also

Reference

PerformanceMonitor Class
FindCounters Overload
GSF.Diagnostics Namespace


PerformanceMonitor.FindCounters Method (String, String)

Grid Solutions Framework PerformanceMonitorFindCounters Method (String, String)
Returns PerformanceCounter array matching the specified counter name.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter[] FindCounters(
    string categoryName,
    string counterName
)
Public Function FindCounters (
    categoryName As String,
    counterName As String
) As PerformanceCounter()
member FindCounters :
        categoryName : string *
        counterName : string -> PerformanceCounter[]

function FindCounters(categoryName, counterName);
public:
array<PerformanceCounter^>^ FindCounters(
    String^ categoryName,
    String^ counterName
)

Parameters

categoryName
Type: SystemString
Category of the PerformanceCounter to be retrieved.
counterName
Type: SystemString
Name of the PerformanceCounter to be retrieved.

Return Value

Type: PerformanceCounter
A PerformanceCounter array of found matches, if any.
See Also

Reference

PerformanceMonitor Class
FindCounters Overload
GSF.Diagnostics Namespace


PerformanceMonitor.RemoveCounter Method

Grid Solutions Framework PerformanceMonitorRemoveCounter Method
Removes a PerformanceCounter being monitored.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveCounter(
    PerformanceCounter counter
)
Public Sub RemoveCounter (
    counter As PerformanceCounter
)
member RemoveCounter :
        counter : PerformanceCounter -> unit

function RemoveCounter(counter);
public:
void RemoveCounter(
    PerformanceCounter^ counter
)

Parameters

counter
Type: GSF.DiagnosticsPerformanceCounter
The PerformanceCounter object to be unmonitored.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.SampleCounters Method

Grid Solutions Framework PerformanceMonitorSampleCounters Method
Sample all defined counters.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SampleCounters()
Public Sub SampleCounters
member SampleCounters : unit -> unit

function SampleCounters();
public:
void SampleCounters()
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor Properties

Grid Solutions Framework PerformanceMonitor Properties

The PerformanceMonitor type exposes the following members.

Properties
 | Name | Description
Public property | Counters | Gets a read-only list of the PerformanceCounter objects monitored by the PerformanceMonitor object.
Public property | CPUUsage | Gets the PerformanceCounter that monitors the processor utilization of the monitored process.
Public property | HandleCount | Gets the PerformanceCounter that monitors the total number of handles currently open by the monitored process.
Public property | IOActivity | Gets the PerformanceCounter that monitors the rate at which the monitored process is issuing read and write I/O operations.
Public property | IOUsage | Gets the PerformanceCounter that monitors the rate at which the monitored process is issuing bytes to I/O operations that do not involve data such as control operations.
Public property | IPDataReceiveRate | Gets the PerformanceCounter that monitors the IP based datagrams received / second of the system.
Public property | IPDataSendRate | Gets the PerformanceCounter that monitors the IP based datagrams sent / second of the system.
Public property | LifetimeStatus | Gets the lifetime status statistics of the PerformanceMonitor object.
Public property | MemoryUsage | Gets the PerformanceCounter that monitors the memory utilization of the monitored process.
Public property | Name | Gets the friendly name of the PerformanceMonitor object.
Public property | ProcessName | Gets or sets the name of the Process to be monitored.
Public property | SamplingInterval | Gets or sets the interval, in milliseconds, at which the Counters are to be sampled.
Public property | Status | Gets the current status of the PerformanceMonitor object.
Public property | ThreadCount | Gets the PerformanceCounter that monitors the number of threads currently active in the monitored process.
Public property | ThreadingContentionRate | Gets the PerformanceCounter that monitors the .NET threading contention rate / second of the process.
Top
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.Counters Property

Grid Solutions Framework PerformanceMonitorCounters Property
Gets a read-only list of the PerformanceCounter objects monitored by the PerformanceMonitor object.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ReadOnlyCollection<PerformanceCounter> Counters { get; }
Public ReadOnly Property Counters As ReadOnlyCollection(Of PerformanceCounter)
    Get
member Counters : ReadOnlyCollection<PerformanceCounter> with get

function get_Counters();

public:
property ReadOnlyCollection<PerformanceCounter^>^ Counters {
    ReadOnlyCollection<PerformanceCounter^>^ get ();
}

Property Value

Type: ReadOnlyCollection PerformanceCounter
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.CPUUsage Property

Grid Solutions Framework PerformanceMonitorCPUUsage Property
Gets the PerformanceCounter that monitors the processor utilization of the monitored process.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter CPUUsage { get; }
Public ReadOnly Property CPUUsage As PerformanceCounter
    Get
member CPUUsage : PerformanceCounter with get

function get_CPUUsage();

public:
property PerformanceCounter^ CPUUsage {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.HandleCount Property

Grid Solutions Framework PerformanceMonitorHandleCount Property
Gets the PerformanceCounter that monitors the total number of handles currently open by the monitored process.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter HandleCount { get; }
Public ReadOnly Property HandleCount As PerformanceCounter
    Get
member HandleCount : PerformanceCounter with get

function get_HandleCount();

public:
property PerformanceCounter^ HandleCount {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.IOActivity Property

Grid Solutions Framework PerformanceMonitorIOActivity Property
Gets the PerformanceCounter that monitors the rate at which the monitored process is issuing read and write I/O operations.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter IOActivity { get; }
Public ReadOnly Property IOActivity As PerformanceCounter
    Get
member IOActivity : PerformanceCounter with get

function get_IOActivity();

public:
property PerformanceCounter^ IOActivity {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.IOUsage Property

Grid Solutions Framework PerformanceMonitorIOUsage Property
Gets the PerformanceCounter that monitors the rate at which the monitored process is issuing bytes to I/O operations that do not involve data such as control operations.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter IOUsage { get; }
Public ReadOnly Property IOUsage As PerformanceCounter
    Get
member IOUsage : PerformanceCounter with get

function get_IOUsage();

public:
property PerformanceCounter^ IOUsage {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.IPDataReceiveRate Property

Grid Solutions Framework PerformanceMonitorIPDataReceiveRate Property
Gets the PerformanceCounter that monitors the IP based datagrams received / second of the system.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter IPDataReceiveRate { get; }
Public ReadOnly Property IPDataReceiveRate As PerformanceCounter
    Get
member IPDataReceiveRate : PerformanceCounter with get

function get_IPDataReceiveRate();

public:
property PerformanceCounter^ IPDataReceiveRate {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.IPDataSendRate Property

Grid Solutions Framework PerformanceMonitorIPDataSendRate Property
Gets the PerformanceCounter that monitors the IP based datagrams sent / second of the system.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter IPDataSendRate { get; }
Public ReadOnly Property IPDataSendRate As PerformanceCounter
    Get
member IPDataSendRate : PerformanceCounter with get

function get_IPDataSendRate();

public:
property PerformanceCounter^ IPDataSendRate {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.LifetimeStatus Property

Grid Solutions Framework PerformanceMonitorLifetimeStatus Property
Gets the lifetime status statistics of the PerformanceMonitor object.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LifetimeStatus { get; }
Public ReadOnly Property LifetimeStatus As String
    Get
member LifetimeStatus : string with get

function get_LifetimeStatus();

public:
property String^ LifetimeStatus {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.MemoryUsage Property

Grid Solutions Framework PerformanceMonitorMemoryUsage Property
Gets the PerformanceCounter that monitors the memory utilization of the monitored process.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter MemoryUsage { get; }
Public ReadOnly Property MemoryUsage As PerformanceCounter
    Get
member MemoryUsage : PerformanceCounter with get

function get_MemoryUsage();

public:
property PerformanceCounter^ MemoryUsage {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.Name Property

Grid Solutions Framework PerformanceMonitorName Property
Gets the friendly name of the PerformanceMonitor object.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.ProcessName Property

Grid Solutions Framework PerformanceMonitorProcessName Property
Gets or sets the name of the Process to be monitored.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ProcessName { get; set; }
Public Property ProcessName As String
    Get
    Set
member ProcessName : string with get, set

function get_ProcessName();
function set_ProcessName(value);
public:
property String^ ProcessName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.SamplingInterval Property

Grid Solutions Framework PerformanceMonitorSamplingInterval Property
Gets or sets the interval, in milliseconds, at which the Counters are to be sampled.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double SamplingInterval { get; set; }
Public Property SamplingInterval As Double
    Get
    Set
member SamplingInterval : float with get, set

function get_SamplingInterval();
function set_SamplingInterval(value);
public:
property double SamplingInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.Status Property

Grid Solutions Framework PerformanceMonitorStatus Property
Gets the current status of the PerformanceMonitor object.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.ThreadCount Property

Grid Solutions Framework PerformanceMonitorThreadCount Property
Gets the PerformanceCounter that monitors the number of threads currently active in the monitored process.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter ThreadCount { get; }
Public ReadOnly Property ThreadCount As PerformanceCounter
    Get
member ThreadCount : PerformanceCounter with get

function get_ThreadCount();

public:
property PerformanceCounter^ ThreadCount {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


PerformanceMonitor.ThreadingContentionRate Property

Grid Solutions Framework PerformanceMonitorThreadingContentionRate Property
Gets the PerformanceCounter that monitors the .NET threading contention rate / second of the process.

Namespace: GSF.Diagnostics
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PerformanceCounter ThreadingContentionRate { get; }
Public ReadOnly Property ThreadingContentionRate As PerformanceCounter
    Get
member ThreadingContentionRate : PerformanceCounter with get

function get_ThreadingContentionRate();

public:
property PerformanceCounter^ ThreadingContentionRate {
    PerformanceCounter^ get ();
}

Property Value

Type: PerformanceCounter
Remarks
This PerformanceCounter is added by default.
See Also

Reference

PerformanceMonitor Class
GSF.Diagnostics Namespace


GSF.Drawing Namespace

Grid Solutions Framework GSF.Drawing Namespace
Contains extension functions used to simplify managing images.
Classes
 | Class | Description
Public class | BitmapExtensions | Defines extension functions related to bitmap image manipulation.


BitmapExtensions Class

Grid Solutions Framework BitmapExtensions Class
Defines extension functions related to bitmap image manipulation.
Inheritance Hierarchy
SystemObject
GSF.DrawingBitmapExtensions

Namespace: GSF.Drawing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class BitmapExtensions
<ExtensionAttribute>
Public NotInheritable Class BitmapExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type BitmapExtensions =  class end
GSF.Drawing.BitmapExtensions = function();

Type.createClass(
    'GSF.Drawing.BitmapExtensions');
[ExtensionAttribute]
public ref class BitmapExtensions abstract sealed
Methods
Name | Description
ConvertTo(Image, ImageFormat) | Converts a Bitmap image to the specified ImageFormat.
ConvertTo(Image, ImageFormat, Boolean) | Converts a Bitmap image to the specified ImageFormat.
Crop(Image, Rectangle) | Returns a cropped Bitmap image of the original.
Crop(Image, Rectangle, Boolean) | Returns a cropped Bitmap image of the original.
Resize(Image, Size) | Returns a resized Bitmap image of the original.
Resize(Image, Size, Boolean) | Returns a resized Bitmap image of the original.
Top
See Also

Reference

GSF.Drawing Namespace


BitmapExtensions Methods

Grid Solutions Framework BitmapExtensions Methods
Methods
Name | Description
ConvertTo(Image, ImageFormat) | Converts a Bitmap image to the specified ImageFormat.
ConvertTo(Image, ImageFormat, Boolean) | Converts a Bitmap image to the specified ImageFormat.
Crop(Image, Rectangle) | Returns a cropped Bitmap image of the original.
Crop(Image, Rectangle, Boolean) | Returns a cropped Bitmap image of the original.
Resize(Image, Size) | Returns a resized Bitmap image of the original.
Resize(Image, Size, Boolean) | Returns a resized Bitmap image of the original.
Top
See Also

Reference

BitmapExtensions Class
GSF.Drawing Namespace


BitmapExtensions.ConvertTo Method

Grid Solutions Framework BitmapExtensionsConvertTo Method
Overload List
Name | Description
ConvertTo(Image, ImageFormat) | Converts a Bitmap image to the specified ImageFormat.
ConvertTo(Image, ImageFormat, Boolean) | Converts a Bitmap image to the specified ImageFormat.
Top
See Also

Reference

BitmapExtensions Class
GSF.Drawing Namespace


BitmapExtensions.ConvertTo Method (Image, ImageFormat)

Grid Solutions Framework BitmapExtensionsConvertTo Method (Image, ImageFormat)
Converts a Bitmap image to the specified ImageFormat.

Namespace: GSF.Drawing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap ConvertTo(
    this Image originalImage,
    ImageFormat newFormat
)
<ExtensionAttribute>
Public Shared Function ConvertTo (
    originalImage As Image,
    newFormat As ImageFormat
) As Bitmap
static member ConvertTo :
        originalImage : Image *
        newFormat : ImageFormat -> Bitmap

GSF.Drawing.BitmapExtensions.ConvertTo = function(originalImage, newFormat);
public:
[ExtensionAttribute]
static Bitmap^ ConvertTo(
    Image^ originalImage,
    ImageFormat^ newFormat
)

Parameters

originalImage
Type: System.DrawingImage
The Bitmap image to be converted.
newFormat
Type: System.Drawing.ImagingImageFormat
The new ImageFormat of the image.

Return Value

Type: Bitmap
A Bitmap instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Image. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
This example shows how to convert the format of an image:
Copy
using System;
using System.Drawing;
using System.Drawing.Imaging;
using GSF.Drawing;

class Program
{
    static void Main(string[] args)
    {
        // Load the original image.
        Bitmap original = (Bitmap)Bitmap.FromFile("Original.jpg");
        // Convert the original image.
        Bitmap originalGif = original.ConvertTo(ImageFormat.Gif);
        // Save the converted image to file.
        originalGif.Save("OriginalGif.gif");

        // Clean-up.
        original.Dispose();
        originalGif.Dispose();

        Console.ReadLine();
    }
}
See Also

Reference

BitmapExtensions Class
ConvertTo Overload
GSF.Drawing Namespace


BitmapExtensions.ConvertTo Method (Image, ImageFormat, Boolean)

Grid Solutions Framework BitmapExtensionsConvertTo Method (Image, ImageFormat, Boolean)
Converts a Bitmap image to the specified ImageFormat.

Namespace: GSF.Drawing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap ConvertTo(
    this Image originalImage,
    ImageFormat newFormat,
    bool disposeOriginal
)
<ExtensionAttribute>
Public Shared Function ConvertTo (
    originalImage As Image,
    newFormat As ImageFormat,
    disposeOriginal As Boolean
) As Bitmap
static member ConvertTo :
        originalImage : Image *
        newFormat : ImageFormat *
        disposeOriginal : bool -> Bitmap

GSF.Drawing.BitmapExtensions.ConvertTo = function(originalImage, newFormat, disposeOriginal);
public:
[ExtensionAttribute]
static Bitmap^ ConvertTo(
    Image^ originalImage,
    ImageFormat^ newFormat,
    bool disposeOriginal
)

Parameters

originalImage
Type: System.DrawingImage
The Bitmap image to be converted.
newFormat
Type: System.Drawing.ImagingImageFormat
The new ImageFormat of the image.
disposeOriginal
Type: SystemBoolean
true if the original image is to be disposed after converting it; otherwise false.

Return Value

Type: Bitmap
A Bitmap instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Image. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
This example shows how to convert the format of an image and dispose the original image that was converted:
Copy
using System;
using System.Drawing;
using System.Drawing.Imaging;
using GSF.Drawing;

class Program
{
    static void Main(string[] args)
    {
        // Load original, convert it, and dispose original.
        using (Bitmap converted = ((Bitmap)Bitmap.FromFile("Original.jpg")).ConvertTo(ImageFormat.Gif))
        {
            // Save the converted image to file.
            converted.Save("OriginalGif.gif");
        }

        Console.ReadLine();
    }
}
See Also

Reference

BitmapExtensions Class
ConvertTo Overload
GSF.Drawing Namespace


BitmapExtensions.Crop Method

Grid Solutions Framework BitmapExtensionsCrop Method
Overload List
Name | Description
Crop(Image, Rectangle) | Returns a cropped Bitmap image of the original.
Crop(Image, Rectangle, Boolean) | Returns a cropped Bitmap image of the original.
Top
See Also

Reference

BitmapExtensions Class
GSF.Drawing Namespace


BitmapExtensions.Crop Method (Image, Rectangle)

Grid Solutions Framework BitmapExtensionsCrop Method (Image, Rectangle)
Returns a cropped Bitmap image of the original.

Namespace: GSF.Drawing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Crop(
    this Image originalImage,
    Rectangle croppedArea
)
<ExtensionAttribute>
Public Shared Function Crop (
    originalImage As Image,
    croppedArea As Rectangle
) As Bitmap
static member Crop :
        originalImage : Image *
        croppedArea : Rectangle -> Bitmap

GSF.Drawing.BitmapExtensions.Crop = function(originalImage, croppedArea);
public:
[ExtensionAttribute]
static Bitmap^ Crop(
    Image^ originalImage,
    Rectangle croppedArea
)

Parameters

originalImage
Type: System.DrawingImage
The original Bitmap image to be cropped.
croppedArea
Type: System.DrawingRectangle
The Rectangle area of the original image to be cropped.

Return Value

Type: Bitmap
A Bitmap instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Image. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
This example shows how to crop an image:
Copy
using System;
using System.Drawing;
using GSF.Drawing;

class Program
{
    static void Main(string[] args)
    {
        // Load the original image.
        Bitmap original = (Bitmap)Bitmap.FromFile("Original.jpg");
        // Crop the original image.
        Bitmap originalCropped = original.Crop(new Rectangle(0, 0, 300, 300));
        // Save the cropped image to file.
        originalCropped.Save("OriginalCropped.jpg");

        // Clean-up.
        original.Dispose();
        originalCropped.Dispose();

        Console.ReadLine();
    }
}
See Also

Reference

BitmapExtensions Class
Crop Overload
GSF.Drawing Namespace


BitmapExtensions.Crop Method (Image, Rectangle, Boolean)

Grid Solutions Framework BitmapExtensionsCrop Method (Image, Rectangle, Boolean)
Returns a cropped Bitmap image of the original.

Namespace: GSF.Drawing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Crop(
    this Image originalImage,
    Rectangle croppedArea,
    bool disposeOriginal
)
<ExtensionAttribute>
Public Shared Function Crop (
    originalImage As Image,
    croppedArea As Rectangle,
    disposeOriginal As Boolean
) As Bitmap
static member Crop :
        originalImage : Image *
        croppedArea : Rectangle *
        disposeOriginal : bool -> Bitmap

GSF.Drawing.BitmapExtensions.Crop = function(originalImage, croppedArea, disposeOriginal);
public:
[ExtensionAttribute]
static Bitmap^ Crop(
    Image^ originalImage,
    Rectangle croppedArea,
    bool disposeOriginal
)

Parameters

originalImage
Type: System.DrawingImage
The original Bitmap image to be cropped.
croppedArea
Type: System.DrawingRectangle
The Rectangle area of the original image to be cropped.
disposeOriginal
Type: SystemBoolean
true if the original image is to be disposed after cropping it; otherwise false.

Return Value

Type: Bitmap
A Bitmap instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Image. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
This example shows how to crop an image and dispose the original image that was cropped:
Copy
using System;
using System.Drawing;
using GSF.Drawing;

class Program
{
    static void Main(string[] args)
    {
        // Load original, crop it, and dispose original.
        using (Bitmap cropped = ((Bitmap)Bitmap.FromFile("Original.jpg")).Crop(new Rectangle(0, 0, 300, 300), true))
        {
            // Save the cropped image to file.
            cropped.Save("OriginalCropped.jpg");
        }

        Console.ReadLine();
    }
}
See Also

Reference

BitmapExtensions Class
Crop Overload
GSF.Drawing Namespace


BitmapExtensions.Resize Method

Grid Solutions Framework BitmapExtensionsResize Method
Overload List
Name | Description
Resize(Image, Size) | Returns a resized Bitmap image of the original.
Resize(Image, Size, Boolean) | Returns a resized Bitmap image of the original.
Top
See Also

Reference

BitmapExtensions Class
GSF.Drawing Namespace


BitmapExtensions.Resize Method (Image, Size)

Grid Solutions Framework BitmapExtensionsResize Method (Image, Size)
Returns a resized Bitmap image of the original.

Namespace: GSF.Drawing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Resize(
    this Image originalImage,
    Size newSize
)
<ExtensionAttribute>
Public Shared Function Resize (
    originalImage As Image,
    newSize As Size
) As Bitmap
static member Resize :
        originalImage : Image *
        newSize : Size -> Bitmap

GSF.Drawing.BitmapExtensions.Resize = function(originalImage, newSize);
public:
[ExtensionAttribute]
static Bitmap^ Resize(
    Image^ originalImage,
    Size newSize
)

Parameters

originalImage
Type: System.DrawingImage
The original Bitmap image to be resized.
newSize
Type: System.DrawingSize
The Size to which the original image is to be resized.

Return Value

Type: Bitmap
A Bitmap instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Image. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
This example shows how to resize an image:
Copy
using System;
using GSF.Drawing;
using System.Drawing;

class Program
{
    static void Main(string[] args)
    {
        // Load the original image.
        Bitmap original = (Bitmap)Bitmap.FromFile("Original.jpg");
        // Resize the original image.
        Bitmap originalResized = original.Resize(new Size(800, 600));
        // Save the resized image to file.
        originalResized.Save("OriginalResized.jpg");

        // Clean-up.
        original.Dispose();
        originalResized.Dispose();

        Console.ReadLine();
    }
}
See Also

Reference

BitmapExtensions Class
Resize Overload
GSF.Drawing Namespace


BitmapExtensions.Resize Method (Image, Size, Boolean)

Grid Solutions Framework BitmapExtensionsResize Method (Image, Size, Boolean)
Returns a resized Bitmap image of the original.

Namespace: GSF.Drawing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Resize(
    this Image originalImage,
    Size newSize,
    bool disposeOriginal
)
<ExtensionAttribute>
Public Shared Function Resize (
    originalImage As Image,
    newSize As Size,
    disposeOriginal As Boolean
) As Bitmap
static member Resize :
        originalImage : Image *
        newSize : Size *
        disposeOriginal : bool -> Bitmap

GSF.Drawing.BitmapExtensions.Resize = function(originalImage, newSize, disposeOriginal);
public:
[ExtensionAttribute]
static Bitmap^ Resize(
    Image^ originalImage,
    Size newSize,
    bool disposeOriginal
)

Parameters

originalImage
Type: System.DrawingImage
The original Bitmap image to be resized.
newSize
Type: System.DrawingSize
The Size to which the original image is to be resized.
disposeOriginal
Type: SystemBoolean
true if the original image is to be disposed after resizing it; otherwise false.

Return Value

Type: Bitmap
A Bitmap instance.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Image. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Examples
This example shows how to resize an image and dispose the original image that was resized:
Copy
using System;
using System.Drawing;
using GSF.Drawing;

class Program
{
    static void Main(string[] args)
    {
        // Load original, resize it, and dispose original.
        using (Bitmap resized = ((Bitmap)Bitmap.FromFile("Original.jpg")).Resize(new Size(800, 600), true))
        {
            // Save the resized image to file.
            resized.Save("OriginalResized.jpg");
        }

        Console.ReadLine();
    }
}
See Also

Reference

BitmapExtensions Class
Resize Overload
GSF.Drawing Namespace


GSF.EMAX Namespace

Grid Solutions Framework GSF.EMAX Namespace

[Missing <summary> documentation for "N:GSF.EMAX"]

Classes
 | Class | Description
Public class | ControlFile | Represents an EMAX control file (i.e., a .CTL file).
Public class | ControlFileStructureExtensions |
Public class | CorrectiveParser | EMAX data file(s) parser that calculates timestamps based on sample rate and attempts to correct inverted values.
Public class | Parser | EMAX data file(s) parser.
Structures
 | Structure | Description
Public structure | _complex |
Public structure | A_E_RESULTS |
Public structure | A_E_RSLTS |
Public structure | A_SELECTION |
Public structure | ANALOG_GROUP |
Public structure | ANLG_CHNL_NEW |
Public structure | BoardAnalogEventChannels |
Public structure | BREAKER_TRIP_TIMES |
Public structure | CTL_FILE_STRUCT |
Public structure | CTL_HEADER |
Public structure | E_GRP_SELECT |
Public structure | EVENT_DISPLAY |
Public structure | EVENT_GROUP |
Public structure | EVNT_CHNL_NEW |
Public structure | FAULT_LIST |
Public structure | FAULT_LOCATION |
Public structure | FAULT_LOCATIONS |
Public structure | FREQUENCY_RSLTS |
Public structure | IDENTSTRING |
Public structure | LINE_CONSTANT |
Public structure | LINE_CONSTANTS |
Public structure | LINE_NAME |
Public structure | LINE_NAMES |
Public structure | PHASOR_GROUP |
Public structure | PHASOR_GROUPS |
Public structure | SENS_RSLTS |
Public structure | SEQ_RSLTS |
Public structure | SEQUENCE_CHANNEL |
Public structure | SEQUENCE_CHANNELS |
Public structure | SWING_RSLTS |
Public structure | SYS_SETTINGS |
Public structure | SYSTEM_PARAMETERS |
Public structure | SYSTEMTIME |
Public structure | TFreqRslts |
Public structure | THD_RSLTS |
Public structure | TIME_ZONE_INFORMATION |
Public structure | TPwrRcd |
Public structure | TPwrRslt |
Enumerations
 | Enumeration | Description
Public enumeration | DataSize |
Public enumeration | FAULT_LIST_FLAGS |
Public enumeration | StructureType |


_complex Structure

Grid Solutions Framework _complex Structure

[Missing <summary> documentation for "T:GSF.EMAX._complex"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct _complex
Public Structure _complex
[<SealedAttribute>]
type _complex =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class _complex

The _complex type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | x |
Public field | y |
Top
See Also

Reference

GSF.EMAX Namespace


_complex Fields

Grid Solutions Framework _complex Fields

The _complex type exposes the following members.

Fields
 | Name | Description
Public field | x |
Public field | y |
Top
See Also

Reference

_complex Structure
GSF.EMAX Namespace


_complex.x Field

Grid Solutions Framework _complexx Field

[Missing <summary> documentation for "F:GSF.EMAX._complex.x"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double x
Public x As Double
val mutable x: float
var x
public:
double x

Field Value

Type: Double
See Also

Reference

_complex Structure
GSF.EMAX Namespace


_complex.y Field

Grid Solutions Framework _complexy Field

[Missing <summary> documentation for "F:GSF.EMAX._complex.y"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double y
Public y As Double
val mutable y: float
var y
public:
double y

Field Value

Type: Double
See Also

Reference

_complex Structure
GSF.EMAX Namespace


_complex Methods

Grid Solutions Framework _complex Methods

The _complex type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

_complex Structure
GSF.EMAX Namespace


A_E_RESULTS Structure

Grid Solutions Framework A_E_RESULTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.A_E_RESULTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct A_E_RESULTS
Public Structure A_E_RESULTS
[<SealedAttribute>]
type A_E_RESULTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class A_E_RESULTS

The A_E_RESULTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | flag_fault_r |
Public field | flag_on_r |
Public field | flag_rtn_r |
Public field | limit_count_r |
Public field | rms_counter |
Public field | running_sum |
Top
See Also

Reference

GSF.EMAX Namespace


A_E_RESULTS Fields

Grid Solutions Framework A_E_RESULTS Fields

The A_E_RESULTS type exposes the following members.

Fields
 | Name | Description
Public field | flag_fault_r |
Public field | flag_on_r |
Public field | flag_rtn_r |
Public field | limit_count_r |
Public field | rms_counter |
Public field | running_sum |
Top
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RESULTS.flag_fault_r Field

Grid Solutions Framework A_E_RESULTSflag_fault_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RESULTS.flag_fault_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_fault_r
Public flag_fault_r As UShort
val mutable flag_fault_r: uint16
var flag_fault_r
public:
unsigned short flag_fault_r

Field Value

Type: UInt16
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RESULTS.flag_on_r Field

Grid Solutions Framework A_E_RESULTSflag_on_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RESULTS.flag_on_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_on_r
Public flag_on_r As UShort
val mutable flag_on_r: uint16
var flag_on_r
public:
unsigned short flag_on_r

Field Value

Type: UInt16
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RESULTS.flag_rtn_r Field

Grid Solutions Framework A_E_RESULTSflag_rtn_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RESULTS.flag_rtn_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_rtn_r
Public flag_rtn_r As UShort
val mutable flag_rtn_r: uint16
var flag_rtn_r
public:
unsigned short flag_rtn_r

Field Value

Type: UInt16
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RESULTS.limit_count_r Field

Grid Solutions Framework A_E_RESULTSlimit_count_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RESULTS.limit_count_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort limit_count_r
Public limit_count_r As UShort
val mutable limit_count_r: uint16
var limit_count_r
public:
unsigned short limit_count_r

Field Value

Type: UInt16
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RESULTS.rms_counter Field

Grid Solutions Framework A_E_RESULTSrms_counter Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RESULTS.rms_counter"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort rms_counter
Public rms_counter As UShort
val mutable rms_counter: uint16
var rms_counter
public:
unsigned short rms_counter

Field Value

Type: UInt16
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RESULTS.running_sum Field

Grid Solutions Framework A_E_RESULTSrunning_sum Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RESULTS.running_sum"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double running_sum
Public running_sum As Double
val mutable running_sum: float
var running_sum
public:
double running_sum

Field Value

Type: Double
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RESULTS Methods

Grid Solutions Framework A_E_RESULTS Methods

The A_E_RESULTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

A_E_RESULTS Structure
GSF.EMAX Namespace


A_E_RSLTS Structure

Grid Solutions Framework A_E_RSLTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.A_E_RSLTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct A_E_RSLTS
Public Structure A_E_RSLTS
[<SealedAttribute>]
type A_E_RSLTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class A_E_RSLTS

The A_E_RSLTS type exposes the following members.

Constructors
 | Name | Description
Public method | A_E_RSLTS | Initializes a new instance of the A_E_RSLTS class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | aer |
Public field | channel_r |
Public field | flag_r |
Public field | mSec_r |
Public field | offset_r |
Public field | rcd_sample_count_r |
Public field | sequence_r |
Public field | time_fault_r |
Top
See Also

Reference

GSF.EMAX Namespace


A_E_RSLTS Constructor

Grid Solutions Framework A_E_RSLTS Constructor
Initializes a new instance of the A_E_RSLTS class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public A_E_RSLTS(
    BinaryReader reader,
    int channels,
    int analogGroups
)
Public Sub New (
    reader As BinaryReader,
    channels As Integer,
    analogGroups As Integer
)
new :
        reader : BinaryReader *
        channels : int *
        analogGroups : int -> A_E_RSLTS
GSF.EMAX.A_E_RSLTS = function(reader, channels, analogGroups);
public:
A_E_RSLTS(
    BinaryReader^ reader,
    int channels,
    int analogGroups
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.A_E_RSLTS.#ctor(System.IO.BinaryReader,System.Int32,System.Int32)"]

channels
Type: SystemInt32

[Missing <param name="channels"/> documentation for "M:GSF.EMAX.A_E_RSLTS.#ctor(System.IO.BinaryReader,System.Int32,System.Int32)"]

analogGroups
Type: SystemInt32

[Missing <param name="analogGroups"/> documentation for "M:GSF.EMAX.A_E_RSLTS.#ctor(System.IO.BinaryReader,System.Int32,System.Int32)"]

See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS Fields

Grid Solutions Framework A_E_RSLTS Fields

The A_E_RSLTS type exposes the following members.

Fields
 | Name | Description
Public field | aer |
Public field | channel_r |
Public field | flag_r |
Public field | mSec_r |
Public field | offset_r |
Public field | rcd_sample_count_r |
Public field | sequence_r |
Public field | time_fault_r |
Top
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.aer Field

Grid Solutions Framework A_E_RSLTSaer Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.aer"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public A_E_RESULTS[] aer
Public aer As A_E_RESULTS()
val mutable aer: A_E_RESULTS[]
var aer
public:
array<A_E_RESULTS>^ aer

Field Value

Type: A_E_RESULTS
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.channel_r Field

Grid Solutions Framework A_E_RSLTSchannel_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.channel_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort channel_r
Public channel_r As UShort
val mutable channel_r: uint16
var channel_r
public:
unsigned short channel_r

Field Value

Type: UInt16
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.flag_r Field

Grid Solutions Framework A_E_RSLTSflag_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.flag_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_r
Public flag_r As UShort
val mutable flag_r: uint16
var flag_r
public:
unsigned short flag_r

Field Value

Type: UInt16
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.mSec_r Field

Grid Solutions Framework A_E_RSLTSmSec_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.mSec_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort mSec_r
Public mSec_r As UShort
val mutable mSec_r: uint16
var mSec_r
public:
unsigned short mSec_r

Field Value

Type: UInt16
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.offset_r Field

Grid Solutions Framework A_E_RSLTSoffset_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.offset_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort offset_r
Public offset_r As UShort
val mutable offset_r: uint16
var offset_r
public:
unsigned short offset_r

Field Value

Type: UInt16
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.rcd_sample_count_r Field

Grid Solutions Framework A_E_RSLTSrcd_sample_count_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.rcd_sample_count_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int rcd_sample_count_r
Public rcd_sample_count_r As Integer
val mutable rcd_sample_count_r: int
var rcd_sample_count_r
public:
int rcd_sample_count_r

Field Value

Type: Int32
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.sequence_r Field

Grid Solutions Framework A_E_RSLTSsequence_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.sequence_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short sequence_r
Public sequence_r As Short
val mutable sequence_r: int16
var sequence_r
public:
short sequence_r

Field Value

Type: Int16
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS.time_fault_r Field

Grid Solutions Framework A_E_RSLTStime_fault_r Field

[Missing <summary> documentation for "F:GSF.EMAX.A_E_RSLTS.time_fault_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint time_fault_r
Public time_fault_r As UInteger
val mutable time_fault_r: uint32
var time_fault_r
public:
unsigned int time_fault_r

Field Value

Type: UInt32
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_E_RSLTS Methods

Grid Solutions Framework A_E_RSLTS Methods

The A_E_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

A_E_RSLTS Structure
GSF.EMAX Namespace


A_SELECTION Structure

Grid Solutions Framework A_SELECTION Structure

[Missing <summary> documentation for "T:GSF.EMAX.A_SELECTION"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct A_SELECTION
Public Structure A_SELECTION
[<SealedAttribute>]
type A_SELECTION =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class A_SELECTION

The A_SELECTION type exposes the following members.

Constructors
 | Name | Description
Public method | A_SELECTION | Initializes a new instance of the A_SELECTION class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | size |
Public field | value |
Top
See Also

Reference

GSF.EMAX Namespace


A_SELECTION Constructor

Grid Solutions Framework A_SELECTION Constructor
Initializes a new instance of the A_SELECTION class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public A_SELECTION(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> A_SELECTION
GSF.EMAX.A_SELECTION = function(reader);
public:
A_SELECTION(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.A_SELECTION.#ctor(System.IO.BinaryReader)"]

See Also

Reference

A_SELECTION Structure
GSF.EMAX Namespace


A_SELECTION Fields

Grid Solutions Framework A_SELECTION Fields

The A_SELECTION type exposes the following members.

Fields
 | Name | Description
Public field | size |
Public field | value |
Top
See Also

Reference

A_SELECTION Structure
GSF.EMAX Namespace


A_SELECTION.size Field

Grid Solutions Framework A_SELECTIONsize Field

[Missing <summary> documentation for "F:GSF.EMAX.A_SELECTION.size"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short size
Public size As Short
val mutable size: int16
var size
public:
short size

Field Value

Type: Int16
See Also

Reference

A_SELECTION Structure
GSF.EMAX Namespace


A_SELECTION.value Field

Grid Solutions Framework A_SELECTIONvalue Field

[Missing <summary> documentation for "F:GSF.EMAX.A_SELECTION.value"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] value
Public value As Byte()
val mutable value: byte[]
var value
public:
array<unsigned char>^ value

Field Value

Type: Byte
See Also

Reference

A_SELECTION Structure
GSF.EMAX Namespace


A_SELECTION Methods

Grid Solutions Framework A_SELECTION Methods

The A_SELECTION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

A_SELECTION Structure
GSF.EMAX Namespace


ANALOG_GROUP Structure

Grid Solutions Framework ANALOG_GROUP Structure

[Missing <summary> documentation for "T:GSF.EMAX.ANALOG_GROUP"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct ANALOG_GROUP
Public Structure ANALOG_GROUP
[<SealedAttribute>]
type ANALOG_GROUP =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class ANALOG_GROUP

The ANALOG_GROUP type exposes the following members.

Constructors
 | Name | Description
Public method | ANALOG_GROUP | Initializes a new instance of the ANALOG_GROUP class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | avg_phasor |
Public field | avg_phasor_count |
Public field | cycle_compare |
Public field | cycle_value |
Public field | flag_high |
Public field | flag_high_end |
Public field | flag_limit |
Public field | flag_low |
Public field | flag_low_end |
Public field | flag_slope |
Public field | high_set |
Public field | limit_count |
Public field | limit_set |
Public field | low_set |
Public field | mask_high |
Public field | mask_limit |
Public field | mask_low |
Public field | mask_slope |
Public field | on |
Public field | sign_flag |
Public field | slope_rate |
Public field | triggerdelayunder |
Top
See Also

Reference

GSF.EMAX Namespace


ANALOG_GROUP Constructor

Grid Solutions Framework ANALOG_GROUP Constructor
Initializes a new instance of the ANALOG_GROUP class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ANALOG_GROUP(
    BinaryReader reader,
    int channels
)
Public Sub New (
    reader As BinaryReader,
    channels As Integer
)
new :
        reader : BinaryReader *
        channels : int -> ANALOG_GROUP
GSF.EMAX.ANALOG_GROUP = function(reader, channels);
public:
ANALOG_GROUP(
    BinaryReader^ reader,
    int channels
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.ANALOG_GROUP.#ctor(System.IO.BinaryReader,System.Int32)"]

channels
Type: SystemInt32

[Missing <param name="channels"/> documentation for "M:GSF.EMAX.ANALOG_GROUP.#ctor(System.IO.BinaryReader,System.Int32)"]

See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP Fields

Grid Solutions Framework ANALOG_GROUP Fields

The ANALOG_GROUP type exposes the following members.

Fields
 | Name | Description
Public field | avg_phasor |
Public field | avg_phasor_count |
Public field | cycle_compare |
Public field | cycle_value |
Public field | flag_high |
Public field | flag_high_end |
Public field | flag_limit |
Public field | flag_low |
Public field | flag_low_end |
Public field | flag_slope |
Public field | high_set |
Public field | limit_count |
Public field | limit_set |
Public field | low_set |
Public field | mask_high |
Public field | mask_limit |
Public field | mask_low |
Public field | mask_slope |
Public field | on |
Public field | sign_flag |
Public field | slope_rate |
Public field | triggerdelayunder |
Top
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.avg_phasor Field

Grid Solutions Framework ANALOG_GROUPavg_phasor Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.avg_phasor"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] avg_phasor
Public avg_phasor As UShort()
val mutable avg_phasor: uint16[]
var avg_phasor
public:
array<unsigned short>^ avg_phasor

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.avg_phasor_count Field

Grid Solutions Framework ANALOG_GROUPavg_phasor_count Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.avg_phasor_count"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] avg_phasor_count
Public avg_phasor_count As UShort()
val mutable avg_phasor_count: uint16[]
var avg_phasor_count
public:
array<unsigned short>^ avg_phasor_count

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.cycle_compare Field

Grid Solutions Framework ANALOG_GROUPcycle_compare Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.cycle_compare"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short[] cycle_compare
Public cycle_compare As Short()
val mutable cycle_compare: int16[]
var cycle_compare
public:
array<short>^ cycle_compare

Field Value

Type: Int16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.cycle_value Field

Grid Solutions Framework ANALOG_GROUPcycle_value Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.cycle_value"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short[][] cycle_value
Public cycle_value As Short()()
val mutable cycle_value: int16[][]
var cycle_value
public:
array<array<short>^>^ cycle_value

Field Value

Type: Int16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.flag_high Field

Grid Solutions Framework ANALOG_GROUPflag_high Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.flag_high"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_high
Public flag_high As UShort
val mutable flag_high: uint16
var flag_high
public:
unsigned short flag_high

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.flag_high_end Field

Grid Solutions Framework ANALOG_GROUPflag_high_end Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.flag_high_end"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_high_end
Public flag_high_end As UShort
val mutable flag_high_end: uint16
var flag_high_end
public:
unsigned short flag_high_end

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.flag_limit Field

Grid Solutions Framework ANALOG_GROUPflag_limit Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.flag_limit"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_limit
Public flag_limit As UShort
val mutable flag_limit: uint16
var flag_limit
public:
unsigned short flag_limit

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.flag_low Field

Grid Solutions Framework ANALOG_GROUPflag_low Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.flag_low"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_low
Public flag_low As UShort
val mutable flag_low: uint16
var flag_low
public:
unsigned short flag_low

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.flag_low_end Field

Grid Solutions Framework ANALOG_GROUPflag_low_end Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.flag_low_end"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_low_end
Public flag_low_end As UShort
val mutable flag_low_end: uint16
var flag_low_end
public:
unsigned short flag_low_end

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.flag_slope Field

Grid Solutions Framework ANALOG_GROUPflag_slope Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.flag_slope"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_slope
Public flag_slope As UShort
val mutable flag_slope: uint16
var flag_slope
public:
unsigned short flag_slope

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.high_set Field

Grid Solutions Framework ANALOG_GROUPhigh_set Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.high_set"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short[] high_set
Public high_set As Short()
val mutable high_set: int16[]
var high_set
public:
array<short>^ high_set

Field Value

Type: Int16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.limit_count Field

Grid Solutions Framework ANALOG_GROUPlimit_count Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.limit_count"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] limit_count
Public limit_count As UShort()
val mutable limit_count: uint16[]
var limit_count
public:
array<unsigned short>^ limit_count

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.limit_set Field

Grid Solutions Framework ANALOG_GROUPlimit_set Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.limit_set"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] limit_set
Public limit_set As UShort()
val mutable limit_set: uint16[]
var limit_set
public:
array<unsigned short>^ limit_set

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.low_set Field

Grid Solutions Framework ANALOG_GROUPlow_set Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.low_set"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] low_set
Public low_set As UShort()
val mutable low_set: uint16[]
var low_set
public:
array<unsigned short>^ low_set

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.mask_high Field

Grid Solutions Framework ANALOG_GROUPmask_high Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.mask_high"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort mask_high
Public mask_high As UShort
val mutable mask_high: uint16
var mask_high
public:
unsigned short mask_high

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.mask_limit Field

Grid Solutions Framework ANALOG_GROUPmask_limit Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.mask_limit"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort mask_limit
Public mask_limit As UShort
val mutable mask_limit: uint16
var mask_limit
public:
unsigned short mask_limit

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.mask_low Field

Grid Solutions Framework ANALOG_GROUPmask_low Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.mask_low"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort mask_low
Public mask_low As UShort
val mutable mask_low: uint16
var mask_low
public:
unsigned short mask_low

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.mask_slope Field

Grid Solutions Framework ANALOG_GROUPmask_slope Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.mask_slope"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort mask_slope
Public mask_slope As UShort
val mutable mask_slope: uint16
var mask_slope
public:
unsigned short mask_slope

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.on Field

Grid Solutions Framework ANALOG_GROUPon Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.on"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort on
Public on As UShort
val mutable on: uint16
var on
public:
unsigned short on

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.sign_flag Field

Grid Solutions Framework ANALOG_GROUPsign_flag Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.sign_flag"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] sign_flag
Public sign_flag As UShort()
val mutable sign_flag: uint16[]
var sign_flag
public:
array<unsigned short>^ sign_flag

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.slope_rate Field

Grid Solutions Framework ANALOG_GROUPslope_rate Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.slope_rate"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short[] slope_rate
Public slope_rate As Short()
val mutable slope_rate: int16[]
var slope_rate
public:
array<short>^ slope_rate

Field Value

Type: Int16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP.triggerdelayunder Field

Grid Solutions Framework ANALOG_GROUPtriggerdelayunder Field

[Missing <summary> documentation for "F:GSF.EMAX.ANALOG_GROUP.triggerdelayunder"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] triggerdelayunder
Public triggerdelayunder As UShort()
val mutable triggerdelayunder: uint16[]
var triggerdelayunder
public:
array<unsigned short>^ triggerdelayunder

Field Value

Type: UInt16
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANALOG_GROUP Methods

Grid Solutions Framework ANALOG_GROUP Methods

The ANALOG_GROUP type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ANALOG_GROUP Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW Structure

Grid Solutions Framework ANLG_CHNL_NEW Structure

[Missing <summary> documentation for "T:GSF.EMAX.ANLG_CHNL_NEW"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct ANLG_CHNL_NEW
Public Structure ANLG_CHNL_NEW
[<SealedAttribute>]
type ANLG_CHNL_NEW =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class ANLG_CHNL_NEW

The ANLG_CHNL_NEW type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | cal_in |
Public field | cal_ref |
Public field | chanlnum |
Public field | cr_lf |
Public field | ct_ratio |
Public field | display_location |
Public field | display_scale |
Public field | limit_on_off |
Public field | limit_set |
Public field | mult_factor |
Public field | over_on_off |
Public field | over_set |
Public field | peak_cal |
Public field | primary |
Public field | rate_on_off |
Public field | rate_set |
Public field | secondary |
Public field | shunt |
Public field | title |
Public field | type |
Public field | under_on_off |
Public field | under_set |
Top
Properties
 | Name | Description
Public property | ChannelNumber |
Public property | ScalingFactor |
Top
See Also

Reference

GSF.EMAX Namespace


ANLG_CHNL_NEW Fields

Grid Solutions Framework ANLG_CHNL_NEW Fields

The ANLG_CHNL_NEW type exposes the following members.

Fields
 | Name | Description
Public field | cal_in |
Public field | cal_ref |
Public field | chanlnum |
Public field | cr_lf |
Public field | ct_ratio |
Public field | display_location |
Public field | display_scale |
Public field | limit_on_off |
Public field | limit_set |
Public field | mult_factor |
Public field | over_on_off |
Public field | over_set |
Public field | peak_cal |
Public field | primary |
Public field | rate_on_off |
Public field | rate_set |
Public field | secondary |
Public field | shunt |
Public field | title |
Public field | type |
Public field | under_on_off |
Public field | under_set |
Top
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.cal_in Field

Grid Solutions Framework ANLG_CHNL_NEWcal_in Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.cal_in"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string cal_in
Public cal_in As String
val mutable cal_in: string
var cal_in
public:
String^ cal_in

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.cal_ref Field

Grid Solutions Framework ANLG_CHNL_NEWcal_ref Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.cal_ref"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string cal_ref
Public cal_ref As String
val mutable cal_ref: string
var cal_ref
public:
String^ cal_ref

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.chanlnum Field

Grid Solutions Framework ANLG_CHNL_NEWchanlnum Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.chanlnum"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string chanlnum
Public chanlnum As String
val mutable chanlnum: string
var chanlnum
public:
String^ chanlnum

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.cr_lf Field

Grid Solutions Framework ANLG_CHNL_NEWcr_lf Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.cr_lf"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string cr_lf
Public cr_lf As String
val mutable cr_lf: string
var cr_lf
public:
String^ cr_lf

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.ct_ratio Field

Grid Solutions Framework ANLG_CHNL_NEWct_ratio Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.ct_ratio"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ct_ratio
Public ct_ratio As String
val mutable ct_ratio: string
var ct_ratio
public:
String^ ct_ratio

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.display_location Field

Grid Solutions Framework ANLG_CHNL_NEWdisplay_location Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.display_location"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string display_location
Public display_location As String
val mutable display_location: string
var display_location
public:
String^ display_location

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.display_scale Field

Grid Solutions Framework ANLG_CHNL_NEWdisplay_scale Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.display_scale"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string display_scale
Public display_scale As String
val mutable display_scale: string
var display_scale
public:
String^ display_scale

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.limit_on_off Field

Grid Solutions Framework ANLG_CHNL_NEWlimit_on_off Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.limit_on_off"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string limit_on_off
Public limit_on_off As String
val mutable limit_on_off: string
var limit_on_off
public:
String^ limit_on_off

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.limit_set Field

Grid Solutions Framework ANLG_CHNL_NEWlimit_set Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.limit_set"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string limit_set
Public limit_set As String
val mutable limit_set: string
var limit_set
public:
String^ limit_set

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.mult_factor Field

Grid Solutions Framework ANLG_CHNL_NEWmult_factor Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.mult_factor"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string mult_factor
Public mult_factor As String
val mutable mult_factor: string
var mult_factor
public:
String^ mult_factor

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.over_on_off Field

Grid Solutions Framework ANLG_CHNL_NEWover_on_off Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.over_on_off"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string over_on_off
Public over_on_off As String
val mutable over_on_off: string
var over_on_off
public:
String^ over_on_off

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.over_set Field

Grid Solutions Framework ANLG_CHNL_NEWover_set Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.over_set"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string over_set
Public over_set As String
val mutable over_set: string
var over_set
public:
String^ over_set

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.peak_cal Field

Grid Solutions Framework ANLG_CHNL_NEWpeak_cal Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.peak_cal"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string peak_cal
Public peak_cal As String
val mutable peak_cal: string
var peak_cal
public:
String^ peak_cal

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.primary Field

Grid Solutions Framework ANLG_CHNL_NEWprimary Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.primary"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string primary
Public primary As String
val mutable primary: string
var primary
public:
String^ primary

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.rate_on_off Field

Grid Solutions Framework ANLG_CHNL_NEWrate_on_off Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.rate_on_off"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string rate_on_off
Public rate_on_off As String
val mutable rate_on_off: string
var rate_on_off
public:
String^ rate_on_off

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.rate_set Field

Grid Solutions Framework ANLG_CHNL_NEWrate_set Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.rate_set"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string rate_set
Public rate_set As String
val mutable rate_set: string
var rate_set
public:
String^ rate_set

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.secondary Field

Grid Solutions Framework ANLG_CHNL_NEWsecondary Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.secondary"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string secondary
Public secondary As String
val mutable secondary: string
var secondary
public:
String^ secondary

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.shunt Field

Grid Solutions Framework ANLG_CHNL_NEWshunt Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.shunt"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string shunt
Public shunt As String
val mutable shunt: string
var shunt
public:
String^ shunt

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.title Field

Grid Solutions Framework ANLG_CHNL_NEWtitle Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.title"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string title
Public title As String
val mutable title: string
var title
public:
String^ title

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.type Field

Grid Solutions Framework ANLG_CHNL_NEWtype Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.type"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string type
Public type As String
val mutable type: string
var type
public:
String^ type

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.under_on_off Field

Grid Solutions Framework ANLG_CHNL_NEWunder_on_off Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.under_on_off"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string under_on_off
Public under_on_off As String
val mutable under_on_off: string
var under_on_off
public:
String^ under_on_off

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.under_set Field

Grid Solutions Framework ANLG_CHNL_NEWunder_set Field

[Missing <summary> documentation for "F:GSF.EMAX.ANLG_CHNL_NEW.under_set"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string under_set
Public under_set As String
val mutable under_set: string
var under_set
public:
String^ under_set

Field Value

Type: String
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW Methods

Grid Solutions Framework ANLG_CHNL_NEW Methods

The ANLG_CHNL_NEW type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.ToString Method

Grid Solutions Framework ANLG_CHNL_NEWToString Method

[Missing <summary> documentation for "M:GSF.EMAX.ANLG_CHNL_NEW.ToString"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.EMAX.ANLG_CHNL_NEW.ToString"]

See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW Properties

Grid Solutions Framework ANLG_CHNL_NEW Properties

The ANLG_CHNL_NEW type exposes the following members.

Properties
 | Name | Description
Public property | ChannelNumber |
Public property | ScalingFactor |
Top
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.ChannelNumber Property

Grid Solutions Framework ANLG_CHNL_NEWChannelNumber Property

[Missing <summary> documentation for "P:GSF.EMAX.ANLG_CHNL_NEW.ChannelNumber"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ChannelNumber { get; }
Public ReadOnly Property ChannelNumber As Integer
    Get
member ChannelNumber : int with get

function get_ChannelNumber();

public:
property int ChannelNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


ANLG_CHNL_NEW.ScalingFactor Property

Grid Solutions Framework ANLG_CHNL_NEWScalingFactor Property

[Missing <summary> documentation for "P:GSF.EMAX.ANLG_CHNL_NEW.ScalingFactor"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ScalingFactor { get; }
Public ReadOnly Property ScalingFactor As Double
    Get
member ScalingFactor : float with get

function get_ScalingFactor();

public:
property double ScalingFactor {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ANLG_CHNL_NEW Structure
GSF.EMAX Namespace


BoardAnalogEventChannels Structure

Grid Solutions Framework BoardAnalogEventChannels Structure

[Missing <summary> documentation for "T:GSF.EMAX.BoardAnalogEventChannels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct BoardAnalogEventChannels
Public Structure BoardAnalogEventChannels
[<SealedAttribute>]
type BoardAnalogEventChannels =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class BoardAnalogEventChannels

The BoardAnalogEventChannels type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | analyze_board1_analog_channels |
Public field | analyze_board1_event_channels |
Public field | analyze_board2_analog_channels |
Public field | analyze_board2_event_channels |
Top
See Also

Reference

GSF.EMAX Namespace


BoardAnalogEventChannels Fields

Grid Solutions Framework BoardAnalogEventChannels Fields

The BoardAnalogEventChannels type exposes the following members.

Fields
 | Name | Description
Public field | analyze_board1_analog_channels |
Public field | analyze_board1_event_channels |
Public field | analyze_board2_analog_channels |
Public field | analyze_board2_event_channels |
Top
See Also

Reference

BoardAnalogEventChannels Structure
GSF.EMAX Namespace


BoardAnalogEventChannels.analyze_board1_analog_channels Field

Grid Solutions Framework BoardAnalogEventChannelsanalyze_board1_analog_channels Field

[Missing <summary> documentation for "F:GSF.EMAX.BoardAnalogEventChannels.analyze_board1_analog_channels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short analyze_board1_analog_channels
Public analyze_board1_analog_channels As Short
val mutable analyze_board1_analog_channels: int16
var analyze_board1_analog_channels
public:
short analyze_board1_analog_channels

Field Value

Type: Int16
See Also

Reference

BoardAnalogEventChannels Structure
GSF.EMAX Namespace


BoardAnalogEventChannels.analyze_board1_event_channels Field

Grid Solutions Framework BoardAnalogEventChannelsanalyze_board1_event_channels Field

[Missing <summary> documentation for "F:GSF.EMAX.BoardAnalogEventChannels.analyze_board1_event_channels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short analyze_board1_event_channels
Public analyze_board1_event_channels As Short
val mutable analyze_board1_event_channels: int16
var analyze_board1_event_channels
public:
short analyze_board1_event_channels

Field Value

Type: Int16
See Also

Reference

BoardAnalogEventChannels Structure
GSF.EMAX Namespace


BoardAnalogEventChannels.analyze_board2_analog_channels Field

Grid Solutions Framework BoardAnalogEventChannelsanalyze_board2_analog_channels Field

[Missing <summary> documentation for "F:GSF.EMAX.BoardAnalogEventChannels.analyze_board2_analog_channels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short analyze_board2_analog_channels
Public analyze_board2_analog_channels As Short
val mutable analyze_board2_analog_channels: int16
var analyze_board2_analog_channels
public:
short analyze_board2_analog_channels

Field Value

Type: Int16
See Also

Reference

BoardAnalogEventChannels Structure
GSF.EMAX Namespace


BoardAnalogEventChannels.analyze_board2_event_channels Field

Grid Solutions Framework BoardAnalogEventChannelsanalyze_board2_event_channels Field

[Missing <summary> documentation for "F:GSF.EMAX.BoardAnalogEventChannels.analyze_board2_event_channels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short analyze_board2_event_channels
Public analyze_board2_event_channels As Short
val mutable analyze_board2_event_channels: int16
var analyze_board2_event_channels
public:
short analyze_board2_event_channels

Field Value

Type: Int16
See Also

Reference

BoardAnalogEventChannels Structure
GSF.EMAX Namespace


BoardAnalogEventChannels Methods

Grid Solutions Framework BoardAnalogEventChannels Methods

The BoardAnalogEventChannels type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BoardAnalogEventChannels Structure
GSF.EMAX Namespace


BREAKER_TRIP_TIMES Structure

Grid Solutions Framework BREAKER_TRIP_TIMES Structure

[Missing <summary> documentation for "T:GSF.EMAX.BREAKER_TRIP_TIMES"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct BREAKER_TRIP_TIMES
Public Structure BREAKER_TRIP_TIMES
[<SealedAttribute>]
type BREAKER_TRIP_TIMES =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class BREAKER_TRIP_TIMES

The BREAKER_TRIP_TIMES type exposes the following members.

Constructors
 | Name | Description
Public method | BREAKER_TRIP_TIMES | Initializes a new instance of the BREAKER_TRIP_TIMES class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | accumulated_breaker_trip_time |
Public field | breaker_trip_time |
Public field | zero_trip_percent |
Public field | zero_trip_time |
Top
See Also

Reference

GSF.EMAX Namespace


BREAKER_TRIP_TIMES Constructor

Grid Solutions Framework BREAKER_TRIP_TIMES Constructor
Initializes a new instance of the BREAKER_TRIP_TIMES class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BREAKER_TRIP_TIMES(
    BinaryReader reader,
    int channels,
    int analogGroups
)
Public Sub New (
    reader As BinaryReader,
    channels As Integer,
    analogGroups As Integer
)
new :
        reader : BinaryReader *
        channels : int *
        analogGroups : int -> BREAKER_TRIP_TIMES
GSF.EMAX.BREAKER_TRIP_TIMES = function(reader, channels, analogGroups);
public:
BREAKER_TRIP_TIMES(
    BinaryReader^ reader,
    int channels,
    int analogGroups
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.BREAKER_TRIP_TIMES.#ctor(System.IO.BinaryReader,System.Int32,System.Int32)"]

channels
Type: SystemInt32

[Missing <param name="channels"/> documentation for "M:GSF.EMAX.BREAKER_TRIP_TIMES.#ctor(System.IO.BinaryReader,System.Int32,System.Int32)"]

analogGroups
Type: SystemInt32

[Missing <param name="analogGroups"/> documentation for "M:GSF.EMAX.BREAKER_TRIP_TIMES.#ctor(System.IO.BinaryReader,System.Int32,System.Int32)"]

See Also

Reference

BREAKER_TRIP_TIMES Structure
GSF.EMAX Namespace


BREAKER_TRIP_TIMES Fields

Grid Solutions Framework BREAKER_TRIP_TIMES Fields

The BREAKER_TRIP_TIMES type exposes the following members.

Fields
 | Name | Description
Public field | accumulated_breaker_trip_time |
Public field | breaker_trip_time |
Public field | zero_trip_percent |
Public field | zero_trip_time |
Top
See Also

Reference

BREAKER_TRIP_TIMES Structure
GSF.EMAX Namespace


BREAKER_TRIP_TIMES.accumulated_breaker_trip_time Field

Grid Solutions Framework BREAKER_TRIP_TIMESaccumulated_breaker_trip_time Field

[Missing <summary> documentation for "F:GSF.EMAX.BREAKER_TRIP_TIMES.accumulated_breaker_trip_time"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float[] accumulated_breaker_trip_time
Public accumulated_breaker_trip_time As Single()
val mutable accumulated_breaker_trip_time: float32[]
var accumulated_breaker_trip_time
public:
array<float>^ accumulated_breaker_trip_time

Field Value

Type: Single
See Also

Reference

BREAKER_TRIP_TIMES Structure
GSF.EMAX Namespace


BREAKER_TRIP_TIMES.breaker_trip_time Field

Grid Solutions Framework BREAKER_TRIP_TIMESbreaker_trip_time Field

[Missing <summary> documentation for "F:GSF.EMAX.BREAKER_TRIP_TIMES.breaker_trip_time"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float[] breaker_trip_time
Public breaker_trip_time As Single()
val mutable breaker_trip_time: float32[]
var breaker_trip_time
public:
array<float>^ breaker_trip_time

Field Value

Type: Single
See Also

Reference

BREAKER_TRIP_TIMES Structure
GSF.EMAX Namespace


BREAKER_TRIP_TIMES.zero_trip_percent Field

Grid Solutions Framework BREAKER_TRIP_TIMESzero_trip_percent Field

[Missing <summary> documentation for "F:GSF.EMAX.BREAKER_TRIP_TIMES.zero_trip_percent"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float[] zero_trip_percent
Public zero_trip_percent As Single()
val mutable zero_trip_percent: float32[]
var zero_trip_percent
public:
array<float>^ zero_trip_percent

Field Value

Type: Single
See Also

Reference

BREAKER_TRIP_TIMES Structure
GSF.EMAX Namespace


BREAKER_TRIP_TIMES.zero_trip_time Field

Grid Solutions Framework BREAKER_TRIP_TIMESzero_trip_time Field

[Missing <summary> documentation for "F:GSF.EMAX.BREAKER_TRIP_TIMES.zero_trip_time"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float[] zero_trip_time
Public zero_trip_time As Single()
val mutable zero_trip_time: float32[]
var zero_trip_time
public:
array<float>^ zero_trip_time

Field Value

Type: Single
See Also

Reference

BREAKER_TRIP_TIMES Structure
GSF.EMAX Namespace


BREAKER_TRIP_TIMES Methods

Grid Solutions Framework BREAKER_TRIP_TIMES Methods

The BREAKER_TRIP_TIMES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BREAKER_TRIP_TIMES Structure
GSF.EMAX Namespace


ControlFile Class

Grid Solutions Framework ControlFile Class
Represents an EMAX control file (i.e., a .CTL file).
Inheritance Hierarchy
SystemObject
GSF.EMAXControlFile

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ControlFile
Public Class ControlFile
type ControlFile =  class end
GSF.EMAX.ControlFile = function();

Type.createClass(
    'GSF.EMAX.ControlFile');
public ref class ControlFile

The ControlFile type exposes the following members.

Constructors
 | Name | Description
Public method | ControlFile | Creates a new ControlFile.
Public method | ControlFile(String) | Creates a new ControlFile for the specified fileName and attempts to parse.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parses the ControlFile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | AnalogChannelSettings |
Public field | AnalogEventResults |
Public field | AnalogGroup |
Public field | AnalogSelection |
Public field | BoardAnalogEventChannels |
Public field | BreakerTripTimes |
Public field | DataSize |
Public field | EventChannelSettings |
Public field | EventDisplay |
Public field | EventGroup |
Public field | EventGroupSelection |
Public field | FaultLocations |
Public field | FileName |
Public field | FileStructures |
Public field | Header |
Public field | IdentityString |
Public field | LineConstants |
Public field | LineNames |
Public field | PhasorGroups |
Public field | PowerRecord |
Public field | ScalingFactors |
Public field | SensorResults |
Public field | SequenceChannels |
Public field | SystemParameters |
Public field | SystemSettings |
Top
Properties
 | Name | Description
Public property | AnalogChannelCount | Gets the analog channel count for the ControlFile.
Public property | ConfiguredAnalogChannels | Gets configured analog channels.
Public property | ConfiguredDigitalChannels | Gets the digital channel count for the ControlFile.
Public property | EventGroupCount | Gets the event group count for the ControlFile.
Public property | FrameLength | Gets the calculated frame length for the ControlFile.
Public property | ParsedFailures | Gets StructureType instances that failed to parse.
Public property | ParsedSuccesses | Gets StructureType instances that were parsed successfully.
Top
See Also

Reference

GSF.EMAX Namespace


ControlFile Constructor

Grid Solutions Framework ControlFile Constructor
Overload List
 | Name | Description
Public method | ControlFile | Creates a new ControlFile.
Public method | ControlFile(String) | Creates a new ControlFile for the specified fileName and attempts to parse.
Top
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile Constructor

Grid Solutions Framework ControlFile Constructor
Creates a new ControlFile.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ControlFile()
Public Sub New
new : unit -> ControlFile
GSF.EMAX.ControlFile = function();
public:
ControlFile()
See Also

Reference

ControlFile Class
ControlFile Overload
GSF.EMAX Namespace


ControlFile Constructor (String)

Grid Solutions Framework ControlFile Constructor (String)
Creates a new ControlFile for the specified fileName and attempts to parse.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ControlFile(
    string fileName
)
Public Sub New (
    fileName As String
)
new :
        fileName : string -> ControlFile
GSF.EMAX.ControlFile = function(fileName);
public:
ControlFile(
    String^ fileName
)

Parameters

fileName
Type: SystemString
Control file name.
See Also

Reference

ControlFile Class
ControlFile Overload
GSF.EMAX Namespace


ControlFile Fields

Grid Solutions Framework ControlFile Fields

The ControlFile type exposes the following members.

Fields
 | Name | Description
Public field | AnalogChannelSettings |
Public field | AnalogEventResults |
Public field | AnalogGroup |
Public field | AnalogSelection |
Public field | BoardAnalogEventChannels |
Public field | BreakerTripTimes |
Public field | DataSize |
Public field | EventChannelSettings |
Public field | EventDisplay |
Public field | EventGroup |
Public field | EventGroupSelection |
Public field | FaultLocations |
Public field | FileName |
Public field | FileStructures |
Public field | Header |
Public field | IdentityString |
Public field | LineConstants |
Public field | LineNames |
Public field | PhasorGroups |
Public field | PowerRecord |
Public field | ScalingFactors |
Public field | SensorResults |
Public field | SequenceChannels |
Public field | SystemParameters |
Public field | SystemSettings |
Top
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.AnalogChannelSettings Field

Grid Solutions Framework ControlFileAnalogChannelSettings Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.AnalogChannelSettings"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<int, ANLG_CHNL_NEW> AnalogChannelSettings
Public AnalogChannelSettings As Dictionary(Of Integer, ANLG_CHNL_NEW)
val mutable AnalogChannelSettings: Dictionary<int, ANLG_CHNL_NEW>
var AnalogChannelSettings
public:
Dictionary<int, ANLG_CHNL_NEW>^ AnalogChannelSettings

Field Value

Type: Dictionary Int32, ANLG_CHNL_NEW
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.AnalogEventResults Field

Grid Solutions Framework ControlFileAnalogEventResults Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.AnalogEventResults"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public A_E_RSLTS AnalogEventResults
Public AnalogEventResults As A_E_RSLTS
val mutable AnalogEventResults: A_E_RSLTS
var AnalogEventResults
public:
A_E_RSLTS AnalogEventResults

Field Value

Type: A_E_RSLTS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.AnalogGroup Field

Grid Solutions Framework ControlFileAnalogGroup Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.AnalogGroup"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ANALOG_GROUP AnalogGroup
Public AnalogGroup As ANALOG_GROUP
val mutable AnalogGroup: ANALOG_GROUP
var AnalogGroup
public:
ANALOG_GROUP AnalogGroup

Field Value

Type: ANALOG_GROUP
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.AnalogSelection Field

Grid Solutions Framework ControlFileAnalogSelection Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.AnalogSelection"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public A_SELECTION AnalogSelection
Public AnalogSelection As A_SELECTION
val mutable AnalogSelection: A_SELECTION
var AnalogSelection
public:
A_SELECTION AnalogSelection

Field Value

Type: A_SELECTION
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.BoardAnalogEventChannels Field

Grid Solutions Framework ControlFileBoardAnalogEventChannels Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.BoardAnalogEventChannels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BoardAnalogEventChannels BoardAnalogEventChannels
Public BoardAnalogEventChannels As BoardAnalogEventChannels
val mutable BoardAnalogEventChannels: BoardAnalogEventChannels
var BoardAnalogEventChannels
public:
BoardAnalogEventChannels BoardAnalogEventChannels

Field Value

Type: BoardAnalogEventChannels
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.BreakerTripTimes Field

Grid Solutions Framework ControlFileBreakerTripTimes Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.BreakerTripTimes"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BREAKER_TRIP_TIMES BreakerTripTimes
Public BreakerTripTimes As BREAKER_TRIP_TIMES
val mutable BreakerTripTimes: BREAKER_TRIP_TIMES
var BreakerTripTimes
public:
BREAKER_TRIP_TIMES BreakerTripTimes

Field Value

Type: BREAKER_TRIP_TIMES
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.DataSize Field

Grid Solutions Framework ControlFileDataSize Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.DataSize"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSize DataSize
Public DataSize As DataSize
val mutable DataSize: DataSize
var DataSize
public:
DataSize DataSize

Field Value

Type: DataSize
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.EventChannelSettings Field

Grid Solutions Framework ControlFileEventChannelSettings Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.EventChannelSettings"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<int, EVNT_CHNL_NEW> EventChannelSettings
Public EventChannelSettings As Dictionary(Of Integer, EVNT_CHNL_NEW)
val mutable EventChannelSettings: Dictionary<int, EVNT_CHNL_NEW>
var EventChannelSettings
public:
Dictionary<int, EVNT_CHNL_NEW>^ EventChannelSettings

Field Value

Type: Dictionary Int32, EVNT_CHNL_NEW
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.EventDisplay Field

Grid Solutions Framework ControlFileEventDisplay Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.EventDisplay"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EVENT_DISPLAY EventDisplay
Public EventDisplay As EVENT_DISPLAY
val mutable EventDisplay: EVENT_DISPLAY
var EventDisplay
public:
EVENT_DISPLAY EventDisplay

Field Value

Type: EVENT_DISPLAY
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.EventGroup Field

Grid Solutions Framework ControlFileEventGroup Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.EventGroup"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EVENT_GROUP EventGroup
Public EventGroup As EVENT_GROUP
val mutable EventGroup: EVENT_GROUP
var EventGroup
public:
EVENT_GROUP EventGroup

Field Value

Type: EVENT_GROUP
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.EventGroupSelection Field

Grid Solutions Framework ControlFileEventGroupSelection Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.EventGroupSelection"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public E_GRP_SELECT EventGroupSelection
Public EventGroupSelection As E_GRP_SELECT
val mutable EventGroupSelection: E_GRP_SELECT
var EventGroupSelection
public:
E_GRP_SELECT EventGroupSelection

Field Value

Type: E_GRP_SELECT
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.FaultLocations Field

Grid Solutions Framework ControlFileFaultLocations Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.FaultLocations"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FAULT_LOCATIONS FaultLocations
Public FaultLocations As FAULT_LOCATIONS
val mutable FaultLocations: FAULT_LOCATIONS
var FaultLocations
public:
FAULT_LOCATIONS FaultLocations

Field Value

Type: FAULT_LOCATIONS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.FileName Field

Grid Solutions Framework ControlFileFileName Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.FileName"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName
Public FileName As String
val mutable FileName: string
var FileName
public:
String^ FileName

Field Value

Type: String
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.FileStructures Field

Grid Solutions Framework ControlFileFileStructures Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.FileStructures"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CTL_FILE_STRUCT[] FileStructures
Public FileStructures As CTL_FILE_STRUCT()
val mutable FileStructures: CTL_FILE_STRUCT[]
var FileStructures
public:
array<CTL_FILE_STRUCT>^ FileStructures

Field Value

Type: CTL_FILE_STRUCT
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.Header Field

Grid Solutions Framework ControlFileHeader Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.Header"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CTL_HEADER Header
Public Header As CTL_HEADER
val mutable Header: CTL_HEADER
var Header
public:
CTL_HEADER Header

Field Value

Type: CTL_HEADER
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.IdentityString Field

Grid Solutions Framework ControlFileIdentityString Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.IdentityString"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDENTSTRING IdentityString
Public IdentityString As IDENTSTRING
val mutable IdentityString: IDENTSTRING
var IdentityString
public:
IDENTSTRING IdentityString

Field Value

Type: IDENTSTRING
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.LineConstants Field

Grid Solutions Framework ControlFileLineConstants Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.LineConstants"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LINE_CONSTANTS LineConstants
Public LineConstants As LINE_CONSTANTS
val mutable LineConstants: LINE_CONSTANTS
var LineConstants
public:
LINE_CONSTANTS LineConstants

Field Value

Type: LINE_CONSTANTS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.LineNames Field

Grid Solutions Framework ControlFileLineNames Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.LineNames"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LINE_NAMES LineNames
Public LineNames As LINE_NAMES
val mutable LineNames: LINE_NAMES
var LineNames
public:
LINE_NAMES LineNames

Field Value

Type: LINE_NAMES
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.PhasorGroups Field

Grid Solutions Framework ControlFilePhasorGroups Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.PhasorGroups"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PHASOR_GROUPS PhasorGroups
Public PhasorGroups As PHASOR_GROUPS
val mutable PhasorGroups: PHASOR_GROUPS
var PhasorGroups
public:
PHASOR_GROUPS PhasorGroups

Field Value

Type: PHASOR_GROUPS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.PowerRecord Field

Grid Solutions Framework ControlFilePowerRecord Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.PowerRecord"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TPwrRcd PowerRecord
Public PowerRecord As TPwrRcd
val mutable PowerRecord: TPwrRcd
var PowerRecord
public:
TPwrRcd PowerRecord

Field Value

Type: TPwrRcd
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.ScalingFactors Field

Grid Solutions Framework ControlFileScalingFactors Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.ScalingFactors"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<int, double> ScalingFactors
Public ScalingFactors As Dictionary(Of Integer, Double)
val mutable ScalingFactors: Dictionary<int, float>
var ScalingFactors
public:
Dictionary<int, double>^ ScalingFactors

Field Value

Type: Dictionary Int32, Double
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.SensorResults Field

Grid Solutions Framework ControlFileSensorResults Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.SensorResults"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SENS_RSLTS SensorResults
Public SensorResults As SENS_RSLTS
val mutable SensorResults: SENS_RSLTS
var SensorResults
public:
SENS_RSLTS SensorResults

Field Value

Type: SENS_RSLTS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.SequenceChannels Field

Grid Solutions Framework ControlFileSequenceChannels Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.SequenceChannels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SEQUENCE_CHANNELS SequenceChannels
Public SequenceChannels As SEQUENCE_CHANNELS
val mutable SequenceChannels: SEQUENCE_CHANNELS
var SequenceChannels
public:
SEQUENCE_CHANNELS SequenceChannels

Field Value

Type: SEQUENCE_CHANNELS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.SystemParameters Field

Grid Solutions Framework ControlFileSystemParameters Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.SystemParameters"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SYSTEM_PARAMETERS SystemParameters
Public SystemParameters As SYSTEM_PARAMETERS
val mutable SystemParameters: SYSTEM_PARAMETERS
var SystemParameters
public:
SYSTEM_PARAMETERS SystemParameters

Field Value

Type: SYSTEM_PARAMETERS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.SystemSettings Field

Grid Solutions Framework ControlFileSystemSettings Field

[Missing <summary> documentation for "F:GSF.EMAX.ControlFile.SystemSettings"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SYS_SETTINGS SystemSettings
Public SystemSettings As SYS_SETTINGS
val mutable SystemSettings: SYS_SETTINGS
var SystemSettings
public:
SYS_SETTINGS SystemSettings

Field Value

Type: SYS_SETTINGS
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile Methods

Grid Solutions Framework ControlFile Methods

The ControlFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Parse | Parses the ControlFile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.Parse Method

Grid Solutions Framework ControlFileParse Method
Parses the ControlFile.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Parse()
Public Sub Parse
member Parse : unit -> unit

function Parse();
public:
void Parse()
Exceptions
Exception | Condition
InvalidOperationException | "No EMAX control file name was specified.
FileNotFoundException | EMAX control file was not found.
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile Properties

Grid Solutions Framework ControlFile Properties

The ControlFile type exposes the following members.

Properties
 | Name | Description
Public property | AnalogChannelCount | Gets the analog channel count for the ControlFile.
Public property | ConfiguredAnalogChannels | Gets configured analog channels.
Public property | ConfiguredDigitalChannels | Gets the digital channel count for the ControlFile.
Public property | EventGroupCount | Gets the event group count for the ControlFile.
Public property | FrameLength | Gets the calculated frame length for the ControlFile.
Public property | ParsedFailures | Gets StructureType instances that failed to parse.
Public property | ParsedSuccesses | Gets StructureType instances that were parsed successfully.
Top
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.AnalogChannelCount Property

Grid Solutions Framework ControlFileAnalogChannelCount Property
Gets the analog channel count for the ControlFile.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int AnalogChannelCount { get; }
Public ReadOnly Property AnalogChannelCount As Integer
    Get
member AnalogChannelCount : int with get

function get_AnalogChannelCount();

public:
property int AnalogChannelCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.ConfiguredAnalogChannels Property

Grid Solutions Framework ControlFileConfiguredAnalogChannels Property
Gets configured analog channels.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ConfiguredAnalogChannels { get; }
Public ReadOnly Property ConfiguredAnalogChannels As Integer
    Get
member ConfiguredAnalogChannels : int with get

function get_ConfiguredAnalogChannels();

public:
property int ConfiguredAnalogChannels {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.ConfiguredDigitalChannels Property

Grid Solutions Framework ControlFileConfiguredDigitalChannels Property
Gets the digital channel count for the ControlFile.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ConfiguredDigitalChannels { get; }
Public ReadOnly Property ConfiguredDigitalChannels As Integer
    Get
member ConfiguredDigitalChannels : int with get

function get_ConfiguredDigitalChannels();

public:
property int ConfiguredDigitalChannels {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.EventGroupCount Property

Grid Solutions Framework ControlFileEventGroupCount Property
Gets the event group count for the ControlFile.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int EventGroupCount { get; }
Public ReadOnly Property EventGroupCount As Integer
    Get
member EventGroupCount : int with get

function get_EventGroupCount();

public:
property int EventGroupCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.FrameLength Property

Grid Solutions Framework ControlFileFrameLength Property
Gets the calculated frame length for the ControlFile.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int FrameLength { get; }
Public ReadOnly Property FrameLength As Integer
    Get
member FrameLength : int with get

function get_FrameLength();

public:
property int FrameLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.ParsedFailures Property

Grid Solutions Framework ControlFileParsedFailures Property
Gets StructureType instances that failed to parse.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<Tuple<StructureType, Exception>> ParsedFailures { get; }
Public ReadOnly Property ParsedFailures As IEnumerable(Of Tuple(Of StructureType, Exception))
    Get
member ParsedFailures : IEnumerable<Tuple<StructureType, Exception>> with get

function get_ParsedFailures();

public:
property IEnumerable<Tuple<StructureType, Exception^>^>^ ParsedFailures {
    IEnumerable<Tuple<StructureType, Exception^>^>^ get ();
}

Property Value

Type: IEnumerable Tuple StructureType, Exception
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFile.ParsedSuccesses Property

Grid Solutions Framework ControlFileParsedSuccesses Property
Gets StructureType instances that were parsed successfully.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<StructureType> ParsedSuccesses { get; }
Public ReadOnly Property ParsedSuccesses As IEnumerable(Of StructureType)
    Get
member ParsedSuccesses : IEnumerable<StructureType> with get

function get_ParsedSuccesses();

public:
property IEnumerable<StructureType>^ ParsedSuccesses {
    IEnumerable<StructureType>^ get ();
}

Property Value

Type: IEnumerable StructureType
See Also

Reference

ControlFile Class
GSF.EMAX Namespace


ControlFileStructureExtensions Class

Grid Solutions Framework ControlFileStructureExtensions Class

[Missing <summary> documentation for "T:GSF.EMAX.ControlFileStructureExtensions"]

Inheritance Hierarchy
SystemObject
GSF.EMAXControlFileStructureExtensions

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ControlFileStructureExtensions
<ExtensionAttribute>
Public NotInheritable Class ControlFileStructureExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ControlFileStructureExtensions =  class end
GSF.EMAX.ControlFileStructureExtensions = function();

Type.createClass(
    'GSF.EMAX.ControlFileStructureExtensions');
[ExtensionAttribute]
public ref class ControlFileStructureExtensions abstract sealed

The ControlFileStructureExtensions type exposes the following members.

Methods
Name | Description
GetTimeZoneInfo |
Top
See Also

Reference

GSF.EMAX Namespace


ControlFileStructureExtensions Methods

Grid Solutions Framework ControlFileStructureExtensions Methods

The ControlFileStructureExtensions type exposes the following members.

Methods
Name | Description
GetTimeZoneInfo |
Top
See Also

Reference

ControlFileStructureExtensions Class
GSF.EMAX Namespace


ControlFileStructureExtensions.GetTimeZoneInfo Method

Grid Solutions Framework ControlFileStructureExtensionsGetTimeZoneInfo Method

[Missing <summary> documentation for "M:GSF.EMAX.ControlFileStructureExtensions.GetTimeZoneInfo(GSF.EMAX.SYSTEM_PARAMETERS)"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeZoneInfo GetTimeZoneInfo(
    this SYSTEM_PARAMETERS systemParameters
)
<ExtensionAttribute>
Public Shared Function GetTimeZoneInfo (
    systemParameters As SYSTEM_PARAMETERS
) As TimeZoneInfo
static member GetTimeZoneInfo :
        systemParameters : SYSTEM_PARAMETERS -> TimeZoneInfo

GSF.EMAX.ControlFileStructureExtensions.GetTimeZoneInfo = function(systemParameters);
public:
[ExtensionAttribute]
static TimeZoneInfo^ GetTimeZoneInfo(
    SYSTEM_PARAMETERS systemParameters
)

Parameters

systemParameters
Type: GSF.EMAXSYSTEM_PARAMETERS

[Missing <param name="systemParameters"/> documentation for "M:GSF.EMAX.ControlFileStructureExtensions.GetTimeZoneInfo(GSF.EMAX.SYSTEM_PARAMETERS)"]

Return Value

Type: TimeZoneInfo

[Missing <returns> documentation for "M:GSF.EMAX.ControlFileStructureExtensions.GetTimeZoneInfo(GSF.EMAX.SYSTEM_PARAMETERS)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SYSTEM_PARAMETERS. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ControlFileStructureExtensions Class
GSF.EMAX Namespace


CorrectiveParser Class

Grid Solutions Framework CorrectiveParser Class
EMAX data file(s) parser that calculates timestamps based on sample rate and attempts to correct inverted values.
Inheritance Hierarchy
SystemObject
GSF.EMAXCorrectiveParser

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CorrectiveParser : IDisposable
Public Class CorrectiveParser
    Implements IDisposable
type CorrectiveParser =
    class
        interface IDisposable
    end
GSF.EMAX.CorrectiveParser = function();

Type.createClass(
    'GSF.EMAX.CorrectiveParser',
    null,
    IDisposable);
public ref class CorrectiveParser : IDisposable

The CorrectiveParser type exposes the following members.

Constructors
 | Name | Description
Public method | CorrectiveParser | Creates a new instance of the CorrectiveParser class.
Top
Methods
 | Name | Description
Public method | CloseFiles | Closes all EMAX data file streams.
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFiles | Opens all EMAX data file streams.
Public method | ReadNext | Reads next EMAX record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CalculatedTimestamp | Gets calculated timestamp of current record in the timezone of provided IRIG signal.
Public property | CalculatedTimestampAsUtc | Attempts to get calculated timestamp of current record converted to UTC.
Public property | ControlFile | Gets or sets associated EMAX control file for this Parser.
Public property | CorrectedValues | Gets corrected values, which may be inverted based on the difference between the calculated timestamp and the parsed timestamp.
Public property | EventGroups | Gets event groups for current record.
Public property | FileName | Gets or sets EMAX data filename.
Public property | ParsedTimestamp | Gets timestamp of current record, parsed from the file, in the timezone of provided IRIG signal.
Public property | ParsedTimestampAsUtc | Attempts to get current timestamp, parsed from the file, converted to UTC.
Public property | Values | Gets values of current record.
Top
See Also

Reference

GSF.EMAX Namespace


CorrectiveParser Constructor

Grid Solutions Framework CorrectiveParser Constructor
Creates a new instance of the CorrectiveParser class.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CorrectiveParser()
Public Sub New
new : unit -> CorrectiveParser
GSF.EMAX.CorrectiveParser = function();
public:
CorrectiveParser()
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser Methods

Grid Solutions Framework CorrectiveParser Methods

The CorrectiveParser type exposes the following members.

Methods
 | Name | Description
Public method | CloseFiles | Closes all EMAX data file streams.
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFiles | Opens all EMAX data file streams.
Public method | ReadNext | Reads next EMAX record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.CloseFiles Method

Grid Solutions Framework CorrectiveParserCloseFiles Method
Closes all EMAX data file streams.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CloseFiles()
Public Sub CloseFiles
member CloseFiles : unit -> unit

function CloseFiles();
public:
void CloseFiles()
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.Dispose Method

Grid Solutions Framework CorrectiveParserDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Top
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.Dispose Method

Grid Solutions Framework CorrectiveParserDispose Method
Releases all the resources used by the Parser object.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

CorrectiveParser Class
Dispose Overload
GSF.EMAX Namespace


CorrectiveParser.Dispose Method (Boolean)

Grid Solutions Framework CorrectiveParserDispose Method (Boolean)
Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

CorrectiveParser Class
Dispose Overload
GSF.EMAX Namespace


CorrectiveParser.OpenFiles Method

Grid Solutions Framework CorrectiveParserOpenFiles Method
Opens all EMAX data file streams.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void OpenFiles()
Public Sub OpenFiles
member OpenFiles : unit -> unit

function OpenFiles();
public:
void OpenFiles()
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.ReadNext Method

Grid Solutions Framework CorrectiveParserReadNext Method
Reads next EMAX record.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReadNext()
Public Function ReadNext As Boolean
member ReadNext : unit -> bool

function ReadNext();
public:
bool ReadNext()

Return Value

Type: Boolean
true if read succeeded; otherwise false if end of data set was reached.
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser Properties

Grid Solutions Framework CorrectiveParser Properties

The CorrectiveParser type exposes the following members.

Properties
 | Name | Description
Public property | CalculatedTimestamp | Gets calculated timestamp of current record in the timezone of provided IRIG signal.
Public property | CalculatedTimestampAsUtc | Attempts to get calculated timestamp of current record converted to UTC.
Public property | ControlFile | Gets or sets associated EMAX control file for this Parser.
Public property | CorrectedValues | Gets corrected values, which may be inverted based on the difference between the calculated timestamp and the parsed timestamp.
Public property | EventGroups | Gets event groups for current record.
Public property | FileName | Gets or sets EMAX data filename.
Public property | ParsedTimestamp | Gets timestamp of current record, parsed from the file, in the timezone of provided IRIG signal.
Public property | ParsedTimestampAsUtc | Attempts to get current timestamp, parsed from the file, converted to UTC.
Public property | Values | Gets values of current record.
Top
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.CalculatedTimestamp Property

Grid Solutions Framework CorrectiveParserCalculatedTimestamp Property
Gets calculated timestamp of current record in the timezone of provided IRIG signal.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime CalculatedTimestamp { get; }
Public ReadOnly Property CalculatedTimestamp As DateTime
    Get
member CalculatedTimestamp : DateTime with get

function get_CalculatedTimestamp();

public:
property DateTime CalculatedTimestamp {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.CalculatedTimestampAsUtc Property

Grid Solutions Framework CorrectiveParserCalculatedTimestampAsUtc Property
Attempts to get calculated timestamp of current record converted to UTC.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime CalculatedTimestampAsUtc { get; }
Public ReadOnly Property CalculatedTimestampAsUtc As DateTime
    Get
member CalculatedTimestampAsUtc : DateTime with get

function get_CalculatedTimestampAsUtc();

public:
property DateTime CalculatedTimestampAsUtc {
    DateTime get ();
}

Property Value

Type: DateTime
Remarks
This will only be accurate if timezone configured in device matches IRIG clock.
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.ControlFile Property

Grid Solutions Framework CorrectiveParserControlFile Property
Gets or sets associated EMAX control file for this Parser.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ControlFile ControlFile { get; set; }
Public Property ControlFile As ControlFile
    Get
    Set
member ControlFile : ControlFile with get, set

function get_ControlFile();
function set_ControlFile(value);
public:
property ControlFile^ ControlFile {
    ControlFile^ get ();
    void set (ControlFile^ value);
}

Property Value

Type: ControlFile
Remarks
This is similar in function to a COMTRADE schema file.
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.CorrectedValues Property

Grid Solutions Framework CorrectiveParserCorrectedValues Property
Gets corrected values, which may be inverted based on the difference between the calculated timestamp and the parsed timestamp.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double[] CorrectedValues { get; }
Public ReadOnly Property CorrectedValues As Double()
    Get
member CorrectedValues : float[] with get

function get_CorrectedValues();

public:
property array<double>^ CorrectedValues {
    array<double>^ get ();
}

Property Value

Type: Double
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.EventGroups Property

Grid Solutions Framework CorrectiveParserEventGroups Property
Gets event groups for current record.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] EventGroups { get; }
Public ReadOnly Property EventGroups As UShort()
    Get
member EventGroups : uint16[] with get

function get_EventGroups();

public:
property array<unsigned short>^ EventGroups {
    array<unsigned short>^ get ();
}

Property Value

Type: UInt16
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.FileName Property

Grid Solutions Framework CorrectiveParserFileName Property
Gets or sets EMAX data filename.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
If there are more than one data files in a set (e.g., RCL/RCU), this should be set to first file name in the set, e.g., DATA123.RCL.
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.ParsedTimestamp Property

Grid Solutions Framework CorrectiveParserParsedTimestamp Property
Gets timestamp of current record, parsed from the file, in the timezone of provided IRIG signal.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ParsedTimestamp { get; }
Public ReadOnly Property ParsedTimestamp As DateTime
    Get
member ParsedTimestamp : DateTime with get

function get_ParsedTimestamp();

public:
property DateTime ParsedTimestamp {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.ParsedTimestampAsUtc Property

Grid Solutions Framework CorrectiveParserParsedTimestampAsUtc Property
Attempts to get current timestamp, parsed from the file, converted to UTC.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ParsedTimestampAsUtc { get; }
Public ReadOnly Property ParsedTimestampAsUtc As DateTime
    Get
member ParsedTimestampAsUtc : DateTime with get

function get_ParsedTimestampAsUtc();

public:
property DateTime ParsedTimestampAsUtc {
    DateTime get ();
}

Property Value

Type: DateTime
Remarks
This will only be accurate if timezone configured in device matches IRIG clock.
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CorrectiveParser.Values Property

Grid Solutions Framework CorrectiveParserValues Property
Gets values of current record.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double[] Values { get; }
Public ReadOnly Property Values As Double()
    Get
member Values : float[] with get

function get_Values();

public:
property array<double>^ Values {
    array<double>^ get ();
}

Property Value

Type: Double
See Also

Reference

CorrectiveParser Class
GSF.EMAX Namespace


CTL_FILE_STRUCT Structure

Grid Solutions Framework CTL_FILE_STRUCT Structure

[Missing <summary> documentation for "T:GSF.EMAX.CTL_FILE_STRUCT"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct CTL_FILE_STRUCT
Public Structure CTL_FILE_STRUCT
[<SealedAttribute>]
type CTL_FILE_STRUCT =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class CTL_FILE_STRUCT

The CTL_FILE_STRUCT type exposes the following members.

Constructors
 | Name | Description
Public method | CTL_FILE_STRUCT | Initializes a new instance of the CTL_FILE_STRUCT class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | offset |
Public field | type |
Top
See Also

Reference

GSF.EMAX Namespace


CTL_FILE_STRUCT Constructor

Grid Solutions Framework CTL_FILE_STRUCT Constructor
Initializes a new instance of the CTL_FILE_STRUCT class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CTL_FILE_STRUCT(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> CTL_FILE_STRUCT
GSF.EMAX.CTL_FILE_STRUCT = function(reader);
public:
CTL_FILE_STRUCT(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.CTL_FILE_STRUCT.#ctor(System.IO.BinaryReader)"]

See Also

Reference

CTL_FILE_STRUCT Structure
GSF.EMAX Namespace


CTL_FILE_STRUCT Fields

Grid Solutions Framework CTL_FILE_STRUCT Fields

The CTL_FILE_STRUCT type exposes the following members.

Fields
 | Name | Description
Public field | offset |
Public field | type |
Top
See Also

Reference

CTL_FILE_STRUCT Structure
GSF.EMAX Namespace


CTL_FILE_STRUCT.offset Field

Grid Solutions Framework CTL_FILE_STRUCToffset Field

[Missing <summary> documentation for "F:GSF.EMAX.CTL_FILE_STRUCT.offset"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint offset
Public offset As UInteger
val mutable offset: uint32
var offset
public:
unsigned int offset

Field Value

Type: UInt32
See Also

Reference

CTL_FILE_STRUCT Structure
GSF.EMAX Namespace


CTL_FILE_STRUCT.type Field

Grid Solutions Framework CTL_FILE_STRUCTtype Field

[Missing <summary> documentation for "F:GSF.EMAX.CTL_FILE_STRUCT.type"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StructureType type
Public type As StructureType
val mutable type: StructureType
var type
public:
StructureType type

Field Value

Type: StructureType
See Also

Reference

CTL_FILE_STRUCT Structure
GSF.EMAX Namespace


CTL_FILE_STRUCT Methods

Grid Solutions Framework CTL_FILE_STRUCT Methods

The CTL_FILE_STRUCT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CTL_FILE_STRUCT Structure
GSF.EMAX Namespace


CTL_HEADER Structure

Grid Solutions Framework CTL_HEADER Structure

[Missing <summary> documentation for "T:GSF.EMAX.CTL_HEADER"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct CTL_HEADER
Public Structure CTL_HEADER
[<SealedAttribute>]
type CTL_HEADER =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class CTL_HEADER

The CTL_HEADER type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | id |
Public field | num_of_structs |
Public field | time |
Top
Properties
 | Name | Description
Public property | Timestamp |
Top
See Also

Reference

GSF.EMAX Namespace


CTL_HEADER Fields

Grid Solutions Framework CTL_HEADER Fields

The CTL_HEADER type exposes the following members.

Fields
 | Name | Description
Public field | id |
Public field | num_of_structs |
Public field | time |
Top
See Also

Reference

CTL_HEADER Structure
GSF.EMAX Namespace


CTL_HEADER.id Field

Grid Solutions Framework CTL_HEADERid Field

[Missing <summary> documentation for "F:GSF.EMAX.CTL_HEADER.id"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort id
Public id As UShort
val mutable id: uint16
var id
public:
unsigned short id

Field Value

Type: UInt16
See Also

Reference

CTL_HEADER Structure
GSF.EMAX Namespace


CTL_HEADER.num_of_structs Field

Grid Solutions Framework CTL_HEADERnum_of_structs Field

[Missing <summary> documentation for "F:GSF.EMAX.CTL_HEADER.num_of_structs"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte num_of_structs
Public num_of_structs As Byte
val mutable num_of_structs: byte
var num_of_structs
public:
unsigned char num_of_structs

Field Value

Type: Byte
See Also

Reference

CTL_HEADER Structure
GSF.EMAX Namespace


CTL_HEADER.time Field

Grid Solutions Framework CTL_HEADERtime Field

[Missing <summary> documentation for "F:GSF.EMAX.CTL_HEADER.time"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint time
Public time As UInteger
val mutable time: uint32
var time
public:
unsigned int time

Field Value

Type: UInt32
See Also

Reference

CTL_HEADER Structure
GSF.EMAX Namespace


CTL_HEADER Methods

Grid Solutions Framework CTL_HEADER Methods

The CTL_HEADER type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CTL_HEADER Structure
GSF.EMAX Namespace


CTL_HEADER Properties

Grid Solutions Framework CTL_HEADER Properties

The CTL_HEADER type exposes the following members.

Properties
 | Name | Description
Public property | Timestamp |
Top
See Also

Reference

CTL_HEADER Structure
GSF.EMAX Namespace


CTL_HEADER.Timestamp Property

Grid Solutions Framework CTL_HEADERTimestamp Property

[Missing <summary> documentation for "P:GSF.EMAX.CTL_HEADER.Timestamp"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Timestamp { get; }
Public ReadOnly Property Timestamp As DateTime
    Get
member Timestamp : DateTime with get

function get_Timestamp();

public:
property DateTime Timestamp {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

CTL_HEADER Structure
GSF.EMAX Namespace


DataSize Enumeration

Grid Solutions Framework DataSize Enumeration

[Missing <summary> documentation for "T:GSF.EMAX.DataSize"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DataSize
Public Enumeration DataSize
type DataSize
GSF.EMAX.DataSize = function();
GSF.EMAX.DataSize.createEnum('GSF.EMAX.DataSize', false);
public enum class DataSize
Members
Member name | Value | Description
Bits12 | 175 |
Bits16 | 171 |
See Also

Reference

GSF.EMAX Namespace


E_GRP_SELECT Structure

Grid Solutions Framework E_GRP_SELECT Structure

[Missing <summary> documentation for "T:GSF.EMAX.E_GRP_SELECT"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct E_GRP_SELECT
Public Structure E_GRP_SELECT
[<SealedAttribute>]
type E_GRP_SELECT =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class E_GRP_SELECT

The E_GRP_SELECT type exposes the following members.

Constructors
 | Name | Description
Public method | E_GRP_SELECT | Initializes a new instance of the E_GRP_SELECT class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | size |
Public field | value |
Top
See Also

Reference

GSF.EMAX Namespace


E_GRP_SELECT Constructor

Grid Solutions Framework E_GRP_SELECT Constructor
Initializes a new instance of the E_GRP_SELECT class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public E_GRP_SELECT(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> E_GRP_SELECT
GSF.EMAX.E_GRP_SELECT = function(reader);
public:
E_GRP_SELECT(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.E_GRP_SELECT.#ctor(System.IO.BinaryReader)"]

See Also

Reference

E_GRP_SELECT Structure
GSF.EMAX Namespace


E_GRP_SELECT Fields

Grid Solutions Framework E_GRP_SELECT Fields

The E_GRP_SELECT type exposes the following members.

Fields
 | Name | Description
Public field | size |
Public field | value |
Top
See Also

Reference

E_GRP_SELECT Structure
GSF.EMAX Namespace


E_GRP_SELECT.size Field

Grid Solutions Framework E_GRP_SELECTsize Field

[Missing <summary> documentation for "F:GSF.EMAX.E_GRP_SELECT.size"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short size
Public size As Short
val mutable size: int16
var size
public:
short size

Field Value

Type: Int16
See Also

Reference

E_GRP_SELECT Structure
GSF.EMAX Namespace


E_GRP_SELECT.value Field

Grid Solutions Framework E_GRP_SELECTvalue Field

[Missing <summary> documentation for "F:GSF.EMAX.E_GRP_SELECT.value"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] value
Public value As Byte()
val mutable value: byte[]
var value
public:
array<unsigned char>^ value

Field Value

Type: Byte
See Also

Reference

E_GRP_SELECT Structure
GSF.EMAX Namespace


E_GRP_SELECT Methods

Grid Solutions Framework E_GRP_SELECT Methods

The E_GRP_SELECT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

E_GRP_SELECT Structure
GSF.EMAX Namespace


EVENT_DISPLAY Structure

Grid Solutions Framework EVENT_DISPLAY Structure

[Missing <summary> documentation for "T:GSF.EMAX.EVENT_DISPLAY"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct EVENT_DISPLAY
Public Structure EVENT_DISPLAY
[<SealedAttribute>]
type EVENT_DISPLAY =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class EVENT_DISPLAY

The EVENT_DISPLAY type exposes the following members.

Constructors
 | Name | Description
Public method | EVENT_DISPLAY | Initializes a new instance of the EVENT_DISPLAY class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | values |
Top
See Also

Reference

GSF.EMAX Namespace


EVENT_DISPLAY Constructor

Grid Solutions Framework EVENT_DISPLAY Constructor
Initializes a new instance of the EVENT_DISPLAY class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EVENT_DISPLAY(
    BinaryReader reader,
    int eventGroups
)
Public Sub New (
    reader As BinaryReader,
    eventGroups As Integer
)
new :
        reader : BinaryReader *
        eventGroups : int -> EVENT_DISPLAY
GSF.EMAX.EVENT_DISPLAY = function(reader, eventGroups);
public:
EVENT_DISPLAY(
    BinaryReader^ reader,
    int eventGroups
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.EVENT_DISPLAY.#ctor(System.IO.BinaryReader,System.Int32)"]

eventGroups
Type: SystemInt32

[Missing <param name="eventGroups"/> documentation for "M:GSF.EMAX.EVENT_DISPLAY.#ctor(System.IO.BinaryReader,System.Int32)"]

See Also

Reference

EVENT_DISPLAY Structure
GSF.EMAX Namespace


EVENT_DISPLAY Fields

Grid Solutions Framework EVENT_DISPLAY Fields

The EVENT_DISPLAY type exposes the following members.

Fields
 | Name | Description
Public field | values |
Top
See Also

Reference

EVENT_DISPLAY Structure
GSF.EMAX Namespace


EVENT_DISPLAY.values Field

Grid Solutions Framework EVENT_DISPLAYvalues Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_DISPLAY.values"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short[] values
Public values As Short()
val mutable values: int16[]
var values
public:
array<short>^ values

Field Value

Type: Int16
See Also

Reference

EVENT_DISPLAY Structure
GSF.EMAX Namespace


EVENT_DISPLAY Methods

Grid Solutions Framework EVENT_DISPLAY Methods

The EVENT_DISPLAY type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EVENT_DISPLAY Structure
GSF.EMAX Namespace


EVENT_GROUP Structure

Grid Solutions Framework EVENT_GROUP Structure

[Missing <summary> documentation for "T:GSF.EMAX.EVENT_GROUP"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct EVENT_GROUP
Public Structure EVENT_GROUP
[<SealedAttribute>]
type EVENT_GROUP =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class EVENT_GROUP

The EVENT_GROUP type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | dir_change |
Public field | flag_fault |
Public field | flag_rtn |
Public field | mask_fault |
Public field | mask_rtn |
Public field | on |
Public field | previous |
Top
See Also

Reference

GSF.EMAX Namespace


EVENT_GROUP Fields

Grid Solutions Framework EVENT_GROUP Fields

The EVENT_GROUP type exposes the following members.

Fields
 | Name | Description
Public field | dir_change |
Public field | flag_fault |
Public field | flag_rtn |
Public field | mask_fault |
Public field | mask_rtn |
Public field | on |
Public field | previous |
Top
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP.dir_change Field

Grid Solutions Framework EVENT_GROUPdir_change Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_GROUP.dir_change"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort dir_change
Public dir_change As UShort
val mutable dir_change: uint16
var dir_change
public:
unsigned short dir_change

Field Value

Type: UInt16
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP.flag_fault Field

Grid Solutions Framework EVENT_GROUPflag_fault Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_GROUP.flag_fault"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_fault
Public flag_fault As UShort
val mutable flag_fault: uint16
var flag_fault
public:
unsigned short flag_fault

Field Value

Type: UInt16
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP.flag_rtn Field

Grid Solutions Framework EVENT_GROUPflag_rtn Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_GROUP.flag_rtn"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_rtn
Public flag_rtn As UShort
val mutable flag_rtn: uint16
var flag_rtn
public:
unsigned short flag_rtn

Field Value

Type: UInt16
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP.mask_fault Field

Grid Solutions Framework EVENT_GROUPmask_fault Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_GROUP.mask_fault"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort mask_fault
Public mask_fault As UShort
val mutable mask_fault: uint16
var mask_fault
public:
unsigned short mask_fault

Field Value

Type: UInt16
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP.mask_rtn Field

Grid Solutions Framework EVENT_GROUPmask_rtn Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_GROUP.mask_rtn"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort mask_rtn
Public mask_rtn As UShort
val mutable mask_rtn: uint16
var mask_rtn
public:
unsigned short mask_rtn

Field Value

Type: UInt16
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP.on Field

Grid Solutions Framework EVENT_GROUPon Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_GROUP.on"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort on
Public on As UShort
val mutable on: uint16
var on
public:
unsigned short on

Field Value

Type: UInt16
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP.previous Field

Grid Solutions Framework EVENT_GROUPprevious Field

[Missing <summary> documentation for "F:GSF.EMAX.EVENT_GROUP.previous"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort previous
Public previous As UShort
val mutable previous: uint16
var previous
public:
unsigned short previous

Field Value

Type: UInt16
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVENT_GROUP Methods

Grid Solutions Framework EVENT_GROUP Methods

The EVENT_GROUP type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EVENT_GROUP Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW Structure

Grid Solutions Framework EVNT_CHNL_NEW Structure

[Missing <summary> documentation for "T:GSF.EMAX.EVNT_CHNL_NEW"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct EVNT_CHNL_NEW
Public Structure EVNT_CHNL_NEW
[<SealedAttribute>]
type EVNT_CHNL_NEW =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class EVNT_CHNL_NEW

The EVNT_CHNL_NEW type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | alarm_on_off |
Public field | e_title |
Public field | eveentdebouncems |
Public field | eventnum |
Public field | nc_no |
Public field | rtn_on_off |
Top
Properties
 | Name | Description
Public property | EventNumber |
Top
See Also

Reference

GSF.EMAX Namespace


EVNT_CHNL_NEW Fields

Grid Solutions Framework EVNT_CHNL_NEW Fields

The EVNT_CHNL_NEW type exposes the following members.

Fields
 | Name | Description
Public field | alarm_on_off |
Public field | e_title |
Public field | eveentdebouncems |
Public field | eventnum |
Public field | nc_no |
Public field | rtn_on_off |
Top
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.alarm_on_off Field

Grid Solutions Framework EVNT_CHNL_NEWalarm_on_off Field

[Missing <summary> documentation for "F:GSF.EMAX.EVNT_CHNL_NEW.alarm_on_off"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string alarm_on_off
Public alarm_on_off As String
val mutable alarm_on_off: string
var alarm_on_off
public:
String^ alarm_on_off

Field Value

Type: String
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.e_title Field

Grid Solutions Framework EVNT_CHNL_NEWe_title Field

[Missing <summary> documentation for "F:GSF.EMAX.EVNT_CHNL_NEW.e_title"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string e_title
Public e_title As String
val mutable e_title: string
var e_title
public:
String^ e_title

Field Value

Type: String
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.eveentdebouncems Field

Grid Solutions Framework EVNT_CHNL_NEWeveentdebouncems Field

[Missing <summary> documentation for "F:GSF.EMAX.EVNT_CHNL_NEW.eveentdebouncems"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort eveentdebouncems
Public eveentdebouncems As UShort
val mutable eveentdebouncems: uint16
var eveentdebouncems
public:
unsigned short eveentdebouncems

Field Value

Type: UInt16
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.eventnum Field

Grid Solutions Framework EVNT_CHNL_NEWeventnum Field

[Missing <summary> documentation for "F:GSF.EMAX.EVNT_CHNL_NEW.eventnum"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string eventnum
Public eventnum As String
val mutable eventnum: string
var eventnum
public:
String^ eventnum

Field Value

Type: String
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.nc_no Field

Grid Solutions Framework EVNT_CHNL_NEWnc_no Field

[Missing <summary> documentation for "F:GSF.EMAX.EVNT_CHNL_NEW.nc_no"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string nc_no
Public nc_no As String
val mutable nc_no: string
var nc_no
public:
String^ nc_no

Field Value

Type: String
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.rtn_on_off Field

Grid Solutions Framework EVNT_CHNL_NEWrtn_on_off Field

[Missing <summary> documentation for "F:GSF.EMAX.EVNT_CHNL_NEW.rtn_on_off"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string rtn_on_off
Public rtn_on_off As String
val mutable rtn_on_off: string
var rtn_on_off
public:
String^ rtn_on_off

Field Value

Type: String
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW Methods

Grid Solutions Framework EVNT_CHNL_NEW Methods

The EVNT_CHNL_NEW type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.ToString Method

Grid Solutions Framework EVNT_CHNL_NEWToString Method

[Missing <summary> documentation for "M:GSF.EMAX.EVNT_CHNL_NEW.ToString"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.EMAX.EVNT_CHNL_NEW.ToString"]

See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW Properties

Grid Solutions Framework EVNT_CHNL_NEW Properties

The EVNT_CHNL_NEW type exposes the following members.

Properties
 | Name | Description
Public property | EventNumber |
Top
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


EVNT_CHNL_NEW.EventNumber Property

Grid Solutions Framework EVNT_CHNL_NEWEventNumber Property

[Missing <summary> documentation for "P:GSF.EMAX.EVNT_CHNL_NEW.EventNumber"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int EventNumber { get; }
Public ReadOnly Property EventNumber As Integer
    Get
member EventNumber : int with get

function get_EventNumber();

public:
property int EventNumber {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

EVNT_CHNL_NEW Structure
GSF.EMAX Namespace


FAULT_LIST Structure

Grid Solutions Framework FAULT_LIST Structure

[Missing <summary> documentation for "T:GSF.EMAX.FAULT_LIST"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct FAULT_LIST
Public Structure FAULT_LIST
[<SealedAttribute>]
type FAULT_LIST =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class FAULT_LIST

The FAULT_LIST type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | chanlnum |
Public field | duration_mS |
Public field | duration_sec |
Public field | fault_mS |
Public field | fault_sec |
Public field | flag |
Public field | fvalue |
Public field | rms_offset |
Public field | rms_value |
Top
See Also

Reference

GSF.EMAX Namespace


FAULT_LIST Fields

Grid Solutions Framework FAULT_LIST Fields

The FAULT_LIST type exposes the following members.

Fields
 | Name | Description
Public field | chanlnum |
Public field | duration_mS |
Public field | duration_sec |
Public field | fault_mS |
Public field | fault_sec |
Public field | flag |
Public field | fvalue |
Public field | rms_offset |
Public field | rms_value |
Top
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.chanlnum Field

Grid Solutions Framework FAULT_LISTchanlnum Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.chanlnum"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short chanlnum
Public chanlnum As Short
val mutable chanlnum: int16
var chanlnum
public:
short chanlnum

Field Value

Type: Int16
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.duration_mS Field

Grid Solutions Framework FAULT_LISTduration_mS Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.duration_mS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short duration_mS
Public duration_mS As Short
val mutable duration_mS: int16
var duration_mS
public:
short duration_mS

Field Value

Type: Int16
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.duration_sec Field

Grid Solutions Framework FAULT_LISTduration_sec Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.duration_sec"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short duration_sec
Public duration_sec As Short
val mutable duration_sec: int16
var duration_sec
public:
short duration_sec

Field Value

Type: Int16
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.fault_mS Field

Grid Solutions Framework FAULT_LISTfault_mS Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.fault_mS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short fault_mS
Public fault_mS As Short
val mutable fault_mS: int16
var fault_mS
public:
short fault_mS

Field Value

Type: Int16
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.fault_sec Field

Grid Solutions Framework FAULT_LISTfault_sec Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.fault_sec"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short fault_sec
Public fault_sec As Short
val mutable fault_sec: int16
var fault_sec
public:
short fault_sec

Field Value

Type: Int16
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.flag Field

Grid Solutions Framework FAULT_LISTflag Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.flag"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FAULT_LIST_FLAGS flag
Public flag As FAULT_LIST_FLAGS
val mutable flag: FAULT_LIST_FLAGS
var flag
public:
FAULT_LIST_FLAGS flag

Field Value

Type: FAULT_LIST_FLAGS
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.fvalue Field

Grid Solutions Framework FAULT_LISTfvalue Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.fvalue"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float fvalue
Public fvalue As Single
val mutable fvalue: float32
var fvalue
public:
float fvalue

Field Value

Type: Single
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.rms_offset Field

Grid Solutions Framework FAULT_LISTrms_offset Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.rms_offset"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int rms_offset
Public rms_offset As Integer
val mutable rms_offset: int
var rms_offset
public:
int rms_offset

Field Value

Type: Int32
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST.rms_value Field

Grid Solutions Framework FAULT_LISTrms_value Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LIST.rms_value"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float rms_value
Public rms_value As Single
val mutable rms_value: float32
var rms_value
public:
float rms_value

Field Value

Type: Single
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST Methods

Grid Solutions Framework FAULT_LIST Methods

The FAULT_LIST type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FAULT_LIST Structure
GSF.EMAX Namespace


FAULT_LIST_FLAGS Enumeration

Grid Solutions Framework FAULT_LIST_FLAGS Enumeration

[Missing <summary> documentation for "T:GSF.EMAX.FAULT_LIST_FLAGS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum FAULT_LIST_FLAGS
<FlagsAttribute>
Public Enumeration FAULT_LIST_FLAGS
[<FlagsAttribute>]
type FAULT_LIST_FLAGS
GSF.EMAX.FAULT_LIST_FLAGS = function();
GSF.EMAX.FAULT_LIST_FLAGS.createEnum('GSF.EMAX.FAULT_LIST_FLAGS', true);
[FlagsAttribute]
public enum class FAULT_LIST_FLAGS
Members
Member name | Value | Description
MASK_UNDER | 16 |
MASK_OVER | 32 |
MASK_SLOPE | 64 |
MASK_LIMIT | 128 |
MASK_FAULT | 1 |
MSK_ZERO | 256 |
MSK_POS_OVER | 512 |
MSK_POS_UNDER | 1024 |
MSK_NEG | 2048 |
MSK_FREQ | 4096 |
MSK_HARM | 8192 |
MSK_SWING | 16384 |
MSK_PWR | 32768 |
See Also

Reference

GSF.EMAX Namespace


FAULT_LOCATION Structure

Grid Solutions Framework FAULT_LOCATION Structure

[Missing <summary> documentation for "T:GSF.EMAX.FAULT_LOCATION"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct FAULT_LOCATION
Public Structure FAULT_LOCATION
[<SealedAttribute>]
type FAULT_LOCATION =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class FAULT_LOCATION

The FAULT_LOCATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | k |
Public field | type |
Top
See Also

Reference

GSF.EMAX Namespace


FAULT_LOCATION Fields

Grid Solutions Framework FAULT_LOCATION Fields

The FAULT_LOCATION type exposes the following members.

Fields
 | Name | Description
Public field | k |
Public field | type |
Top
See Also

Reference

FAULT_LOCATION Structure
GSF.EMAX Namespace


FAULT_LOCATION.k Field

Grid Solutions Framework FAULT_LOCATIONk Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LOCATION.k"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float k
Public k As Single
val mutable k: float32
var k
public:
float k

Field Value

Type: Single
See Also

Reference

FAULT_LOCATION Structure
GSF.EMAX Namespace


FAULT_LOCATION.type Field

Grid Solutions Framework FAULT_LOCATIONtype Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LOCATION.type"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short type
Public type As Short
val mutable type: int16
var type
public:
short type

Field Value

Type: Int16
See Also

Reference

FAULT_LOCATION Structure
GSF.EMAX Namespace


FAULT_LOCATION Methods

Grid Solutions Framework FAULT_LOCATION Methods

The FAULT_LOCATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FAULT_LOCATION Structure
GSF.EMAX Namespace


FAULT_LOCATIONS Structure

Grid Solutions Framework FAULT_LOCATIONS Structure

[Missing <summary> documentation for "T:GSF.EMAX.FAULT_LOCATIONS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct FAULT_LOCATIONS
Public Structure FAULT_LOCATIONS
[<SealedAttribute>]
type FAULT_LOCATIONS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class FAULT_LOCATIONS

The FAULT_LOCATIONS type exposes the following members.

Constructors
 | Name | Description
Public method | FAULT_LOCATIONS | Initializes a new instance of the FAULT_LOCATIONS class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | length |
Public field | locations |
Top
See Also

Reference

GSF.EMAX Namespace


FAULT_LOCATIONS Constructor

Grid Solutions Framework FAULT_LOCATIONS Constructor
Initializes a new instance of the FAULT_LOCATIONS class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FAULT_LOCATIONS(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> FAULT_LOCATIONS
GSF.EMAX.FAULT_LOCATIONS = function(reader);
public:
FAULT_LOCATIONS(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.FAULT_LOCATIONS.#ctor(System.IO.BinaryReader)"]

See Also

Reference

FAULT_LOCATIONS Structure
GSF.EMAX Namespace


FAULT_LOCATIONS Fields

Grid Solutions Framework FAULT_LOCATIONS Fields

The FAULT_LOCATIONS type exposes the following members.

Fields
 | Name | Description
Public field | length |
Public field | locations |
Top
See Also

Reference

FAULT_LOCATIONS Structure
GSF.EMAX Namespace


FAULT_LOCATIONS.length Field

Grid Solutions Framework FAULT_LOCATIONSlength Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LOCATIONS.length"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short length
Public length As Short
val mutable length: int16
var length
public:
short length

Field Value

Type: Int16
See Also

Reference

FAULT_LOCATIONS Structure
GSF.EMAX Namespace


FAULT_LOCATIONS.locations Field

Grid Solutions Framework FAULT_LOCATIONSlocations Field

[Missing <summary> documentation for "F:GSF.EMAX.FAULT_LOCATIONS.locations"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FAULT_LOCATION[] locations
Public locations As FAULT_LOCATION()
val mutable locations: FAULT_LOCATION[]
var locations
public:
array<FAULT_LOCATION>^ locations

Field Value

Type: FAULT_LOCATION
See Also

Reference

FAULT_LOCATIONS Structure
GSF.EMAX Namespace


FAULT_LOCATIONS Methods

Grid Solutions Framework FAULT_LOCATIONS Methods

The FAULT_LOCATIONS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FAULT_LOCATIONS Structure
GSF.EMAX Namespace


FREQUENCY_RSLTS Structure

Grid Solutions Framework FREQUENCY_RSLTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.FREQUENCY_RSLTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct FREQUENCY_RSLTS
Public Structure FREQUENCY_RSLTS
[<SealedAttribute>]
type FREQUENCY_RSLTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class FREQUENCY_RSLTS

The FREQUENCY_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | f_flag |
Public field | f_offset |
Public field | f_result |
Top
See Also

Reference

GSF.EMAX Namespace


FREQUENCY_RSLTS Fields

Grid Solutions Framework FREQUENCY_RSLTS Fields

The FREQUENCY_RSLTS type exposes the following members.

Fields
 | Name | Description
Public field | f_flag |
Public field | f_offset |
Public field | f_result |
Top
See Also

Reference

FREQUENCY_RSLTS Structure
GSF.EMAX Namespace


FREQUENCY_RSLTS.f_flag Field

Grid Solutions Framework FREQUENCY_RSLTSf_flag Field

[Missing <summary> documentation for "F:GSF.EMAX.FREQUENCY_RSLTS.f_flag"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort f_flag
Public f_flag As UShort
val mutable f_flag: uint16
var f_flag
public:
unsigned short f_flag

Field Value

Type: UInt16
See Also

Reference

FREQUENCY_RSLTS Structure
GSF.EMAX Namespace


FREQUENCY_RSLTS.f_offset Field

Grid Solutions Framework FREQUENCY_RSLTSf_offset Field

[Missing <summary> documentation for "F:GSF.EMAX.FREQUENCY_RSLTS.f_offset"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short f_offset
Public f_offset As Short
val mutable f_offset: int16
var f_offset
public:
short f_offset

Field Value

Type: Int16
See Also

Reference

FREQUENCY_RSLTS Structure
GSF.EMAX Namespace


FREQUENCY_RSLTS.f_result Field

Grid Solutions Framework FREQUENCY_RSLTSf_result Field

[Missing <summary> documentation for "F:GSF.EMAX.FREQUENCY_RSLTS.f_result"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float f_result
Public f_result As Single
val mutable f_result: float32
var f_result
public:
float f_result

Field Value

Type: Single
See Also

Reference

FREQUENCY_RSLTS Structure
GSF.EMAX Namespace


FREQUENCY_RSLTS Methods

Grid Solutions Framework FREQUENCY_RSLTS Methods

The FREQUENCY_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FREQUENCY_RSLTS Structure
GSF.EMAX Namespace


IDENTSTRING Structure

Grid Solutions Framework IDENTSTRING Structure

[Missing <summary> documentation for "T:GSF.EMAX.IDENTSTRING"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct IDENTSTRING
Public Structure IDENTSTRING
[<SealedAttribute>]
type IDENTSTRING =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class IDENTSTRING

The IDENTSTRING type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | length |
Public field | value |
Top
See Also

Reference

GSF.EMAX Namespace


IDENTSTRING Fields

Grid Solutions Framework IDENTSTRING Fields

The IDENTSTRING type exposes the following members.

Fields
 | Name | Description
Public field | length |
Public field | value |
Top
See Also

Reference

IDENTSTRING Structure
GSF.EMAX Namespace


IDENTSTRING.length Field

Grid Solutions Framework IDENTSTRINGlength Field

[Missing <summary> documentation for "F:GSF.EMAX.IDENTSTRING.length"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short length
Public length As Short
val mutable length: int16
var length
public:
short length

Field Value

Type: Int16
See Also

Reference

IDENTSTRING Structure
GSF.EMAX Namespace


IDENTSTRING.value Field

Grid Solutions Framework IDENTSTRINGvalue Field

[Missing <summary> documentation for "F:GSF.EMAX.IDENTSTRING.value"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string value
Public value As String
val mutable value: string
var value
public:
String^ value

Field Value

Type: String
See Also

Reference

IDENTSTRING Structure
GSF.EMAX Namespace


IDENTSTRING Methods

Grid Solutions Framework IDENTSTRING Methods

The IDENTSTRING type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IDENTSTRING Structure
GSF.EMAX Namespace


LINE_CONSTANT Structure

Grid Solutions Framework LINE_CONSTANT Structure

[Missing <summary> documentation for "T:GSF.EMAX.LINE_CONSTANT"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct LINE_CONSTANT
Public Structure LINE_CONSTANT
[<SealedAttribute>]
type LINE_CONSTANT =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class LINE_CONSTANT

The LINE_CONSTANT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | fault_percent_of_full_scale |
Public field | line_len |
Public field | units |
Public field | z0 |
Public field | z1 |
Public field | zaa |
Public field | zab |
Public field | zbb |
Public field | zbc |
Public field | zca |
Public field | zcc |
Top
See Also

Reference

GSF.EMAX Namespace


LINE_CONSTANT Fields

Grid Solutions Framework LINE_CONSTANT Fields

The LINE_CONSTANT type exposes the following members.

Fields
 | Name | Description
Public field | fault_percent_of_full_scale |
Public field | line_len |
Public field | units |
Public field | z0 |
Public field | z1 |
Public field | zaa |
Public field | zab |
Public field | zbb |
Public field | zbc |
Public field | zca |
Public field | zcc |
Top
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.fault_percent_of_full_scale Field

Grid Solutions Framework LINE_CONSTANTfault_percent_of_full_scale Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.fault_percent_of_full_scale"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float fault_percent_of_full_scale
Public fault_percent_of_full_scale As Single
val mutable fault_percent_of_full_scale: float32
var fault_percent_of_full_scale
public:
float fault_percent_of_full_scale

Field Value

Type: Single
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.line_len Field

Grid Solutions Framework LINE_CONSTANTline_len Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.line_len"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float line_len
Public line_len As Single
val mutable line_len: float32
var line_len
public:
float line_len

Field Value

Type: Single
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.units Field

Grid Solutions Framework LINE_CONSTANTunits Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.units"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string units
Public units As String
val mutable units: string
var units
public:
String^ units

Field Value

Type: String
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.z0 Field

Grid Solutions Framework LINE_CONSTANTz0 Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.z0"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex z0
Public z0 As _complex
val mutable z0: _complex
var z0
public:
_complex z0

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.z1 Field

Grid Solutions Framework LINE_CONSTANTz1 Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.z1"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex z1
Public z1 As _complex
val mutable z1: _complex
var z1
public:
_complex z1

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.zaa Field

Grid Solutions Framework LINE_CONSTANTzaa Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.zaa"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex zaa
Public zaa As _complex
val mutable zaa: _complex
var zaa
public:
_complex zaa

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.zab Field

Grid Solutions Framework LINE_CONSTANTzab Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.zab"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex zab
Public zab As _complex
val mutable zab: _complex
var zab
public:
_complex zab

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.zbb Field

Grid Solutions Framework LINE_CONSTANTzbb Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.zbb"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex zbb
Public zbb As _complex
val mutable zbb: _complex
var zbb
public:
_complex zbb

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.zbc Field

Grid Solutions Framework LINE_CONSTANTzbc Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.zbc"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex zbc
Public zbc As _complex
val mutable zbc: _complex
var zbc
public:
_complex zbc

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.zca Field

Grid Solutions Framework LINE_CONSTANTzca Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.zca"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex zca
Public zca As _complex
val mutable zca: _complex
var zca
public:
_complex zca

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT.zcc Field

Grid Solutions Framework LINE_CONSTANTzcc Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANT.zcc"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public _complex zcc
Public zcc As _complex
val mutable zcc: _complex
var zcc
public:
_complex zcc

Field Value

Type: _complex
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANT Methods

Grid Solutions Framework LINE_CONSTANT Methods

The LINE_CONSTANT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LINE_CONSTANT Structure
GSF.EMAX Namespace


LINE_CONSTANTS Structure

Grid Solutions Framework LINE_CONSTANTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.LINE_CONSTANTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct LINE_CONSTANTS
Public Structure LINE_CONSTANTS
[<SealedAttribute>]
type LINE_CONSTANTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class LINE_CONSTANTS

The LINE_CONSTANTS type exposes the following members.

Constructors
 | Name | Description
Public method | LINE_CONSTANTS | Initializes a new instance of the LINE_CONSTANTS class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | constants |
Public field | length |
Top
See Also

Reference

GSF.EMAX Namespace


LINE_CONSTANTS Constructor

Grid Solutions Framework LINE_CONSTANTS Constructor
Initializes a new instance of the LINE_CONSTANTS class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LINE_CONSTANTS(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> LINE_CONSTANTS
GSF.EMAX.LINE_CONSTANTS = function(reader);
public:
LINE_CONSTANTS(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.LINE_CONSTANTS.#ctor(System.IO.BinaryReader)"]

See Also

Reference

LINE_CONSTANTS Structure
GSF.EMAX Namespace


LINE_CONSTANTS Fields

Grid Solutions Framework LINE_CONSTANTS Fields

The LINE_CONSTANTS type exposes the following members.

Fields
 | Name | Description
Public field | constants |
Public field | length |
Top
See Also

Reference

LINE_CONSTANTS Structure
GSF.EMAX Namespace


LINE_CONSTANTS.constants Field

Grid Solutions Framework LINE_CONSTANTSconstants Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANTS.constants"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LINE_CONSTANT[] constants
Public constants As LINE_CONSTANT()
val mutable constants: LINE_CONSTANT[]
var constants
public:
array<LINE_CONSTANT>^ constants

Field Value

Type: LINE_CONSTANT
See Also

Reference

LINE_CONSTANTS Structure
GSF.EMAX Namespace


LINE_CONSTANTS.length Field

Grid Solutions Framework LINE_CONSTANTSlength Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_CONSTANTS.length"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short length
Public length As Short
val mutable length: int16
var length
public:
short length

Field Value

Type: Int16
See Also

Reference

LINE_CONSTANTS Structure
GSF.EMAX Namespace


LINE_CONSTANTS Methods

Grid Solutions Framework LINE_CONSTANTS Methods

The LINE_CONSTANTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LINE_CONSTANTS Structure
GSF.EMAX Namespace


LINE_NAME Structure

Grid Solutions Framework LINE_NAME Structure

[Missing <summary> documentation for "T:GSF.EMAX.LINE_NAME"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct LINE_NAME
Public Structure LINE_NAME
[<SealedAttribute>]
type LINE_NAME =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class LINE_NAME

The LINE_NAME type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | value |
Top
See Also

Reference

GSF.EMAX Namespace


LINE_NAME Fields

Grid Solutions Framework LINE_NAME Fields

The LINE_NAME type exposes the following members.

Fields
 | Name | Description
Public field | value |
Top
See Also

Reference

LINE_NAME Structure
GSF.EMAX Namespace


LINE_NAME.value Field

Grid Solutions Framework LINE_NAMEvalue Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_NAME.value"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string value
Public value As String
val mutable value: string
var value
public:
String^ value

Field Value

Type: String
See Also

Reference

LINE_NAME Structure
GSF.EMAX Namespace


LINE_NAME Methods

Grid Solutions Framework LINE_NAME Methods

The LINE_NAME type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LINE_NAME Structure
GSF.EMAX Namespace


LINE_NAMES Structure

Grid Solutions Framework LINE_NAMES Structure

[Missing <summary> documentation for "T:GSF.EMAX.LINE_NAMES"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct LINE_NAMES
Public Structure LINE_NAMES
[<SealedAttribute>]
type LINE_NAMES =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class LINE_NAMES

The LINE_NAMES type exposes the following members.

Constructors
 | Name | Description
Public method | LINE_NAMES | Initializes a new instance of the LINE_NAMES class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | length |
Public field | names |
Top
See Also

Reference

GSF.EMAX Namespace


LINE_NAMES Constructor

Grid Solutions Framework LINE_NAMES Constructor
Initializes a new instance of the LINE_NAMES class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LINE_NAMES(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> LINE_NAMES
GSF.EMAX.LINE_NAMES = function(reader);
public:
LINE_NAMES(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.LINE_NAMES.#ctor(System.IO.BinaryReader)"]

See Also

Reference

LINE_NAMES Structure
GSF.EMAX Namespace


LINE_NAMES Fields

Grid Solutions Framework LINE_NAMES Fields

The LINE_NAMES type exposes the following members.

Fields
 | Name | Description
Public field | length |
Public field | names |
Top
See Also

Reference

LINE_NAMES Structure
GSF.EMAX Namespace


LINE_NAMES.length Field

Grid Solutions Framework LINE_NAMESlength Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_NAMES.length"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short length
Public length As Short
val mutable length: int16
var length
public:
short length

Field Value

Type: Int16
See Also

Reference

LINE_NAMES Structure
GSF.EMAX Namespace


LINE_NAMES.names Field

Grid Solutions Framework LINE_NAMESnames Field

[Missing <summary> documentation for "F:GSF.EMAX.LINE_NAMES.names"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LINE_NAME[] names
Public names As LINE_NAME()
val mutable names: LINE_NAME[]
var names
public:
array<LINE_NAME>^ names

Field Value

Type: LINE_NAME
See Also

Reference

LINE_NAMES Structure
GSF.EMAX Namespace


LINE_NAMES Methods

Grid Solutions Framework LINE_NAMES Methods

The LINE_NAMES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LINE_NAMES Structure
GSF.EMAX Namespace


Parser Class

Grid Solutions Framework Parser Class
EMAX data file(s) parser.
Inheritance Hierarchy
SystemObject
GSF.EMAXParser

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Parser : IDisposable
Public Class Parser
    Implements IDisposable
type Parser =
    class
        interface IDisposable
    end
GSF.EMAX.Parser = function();

Type.createClass(
    'GSF.EMAX.Parser',
    null,
    IDisposable);
public ref class Parser : IDisposable

The Parser type exposes the following members.

Constructors
 | Name | Description
Public method | Parser | Initializes a new instance of the Parser class
Top
Methods
 | Name | Description
Public method | CloseFiles | Closes all EMAX data file streams.
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Parser object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFiles | Opens all EMAX data file streams.
Public method | ReadNext | Reads next EMAX record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ControlFile | Gets or sets associated EMAX control file for this Parser.
Public property | EventGroups | Gets event groups for current record.
Public property | FileName | Gets or sets EMAX data filename.
Public property | Timestamp | Gets timestamp of current record in the timezone of provided IRIG signal.
Public property | TimestampAsUtc | Attempts to get current timestamp converted to UTC.
Public property | Values | Gets values of current record.
Top
See Also

Reference

GSF.EMAX Namespace


Parser Constructor

Grid Solutions Framework Parser Constructor
Initializes a new instance of the Parser class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Parser()
Public Sub New
new : unit -> Parser
GSF.EMAX.Parser = function();
public:
Parser()
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser Methods

Grid Solutions Framework Parser Methods

The Parser type exposes the following members.

Methods
 | Name | Description
Public method | CloseFiles | Closes all EMAX data file streams.
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Parser object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | OpenFiles | Opens all EMAX data file streams.
Public method | ReadNext | Reads next EMAX record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.CloseFiles Method

Grid Solutions Framework ParserCloseFiles Method
Closes all EMAX data file streams.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CloseFiles()
Public Sub CloseFiles
member CloseFiles : unit -> unit

function CloseFiles();
public:
void CloseFiles()
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.Dispose Method

Grid Solutions Framework ParserDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Parser object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.
Top
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.Dispose Method

Grid Solutions Framework ParserDispose Method
Releases all the resources used by the Parser object.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

Parser Class
Dispose Overload
GSF.EMAX Namespace


Parser.Dispose Method (Boolean)

Grid Solutions Framework ParserDispose Method (Boolean)
Releases the unmanaged resources used by the Parser object and optionally releases the managed resources.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

Parser Class
Dispose Overload
GSF.EMAX Namespace


Parser.Finalize Method

Grid Solutions Framework ParserFinalize Method
Releases the unmanaged resources before the Parser object is reclaimed by GC.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.OpenFiles Method

Grid Solutions Framework ParserOpenFiles Method
Opens all EMAX data file streams.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void OpenFiles()
Public Sub OpenFiles
member OpenFiles : unit -> unit

function OpenFiles();
public:
void OpenFiles()
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.ReadNext Method

Grid Solutions Framework ParserReadNext Method
Reads next EMAX record.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReadNext()
Public Function ReadNext As Boolean
member ReadNext : unit -> bool

function ReadNext();
public:
bool ReadNext()

Return Value

Type: Boolean
true if read succeeded; otherwise false if end of data set was reached.
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser Properties

Grid Solutions Framework Parser Properties

The Parser type exposes the following members.

Properties
 | Name | Description
Public property | ControlFile | Gets or sets associated EMAX control file for this Parser.
Public property | EventGroups | Gets event groups for current record.
Public property | FileName | Gets or sets EMAX data filename.
Public property | Timestamp | Gets timestamp of current record in the timezone of provided IRIG signal.
Public property | TimestampAsUtc | Attempts to get current timestamp converted to UTC.
Public property | Values | Gets values of current record.
Top
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.ControlFile Property

Grid Solutions Framework ParserControlFile Property
Gets or sets associated EMAX control file for this Parser.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ControlFile ControlFile { get; set; }
Public Property ControlFile As ControlFile
    Get
    Set
member ControlFile : ControlFile with get, set

function get_ControlFile();
function set_ControlFile(value);
public:
property ControlFile^ ControlFile {
    ControlFile^ get ();
    void set (ControlFile^ value);
}

Property Value

Type: ControlFile
Remarks
This is similar in function to a COMTRADE schema file.
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.EventGroups Property

Grid Solutions Framework ParserEventGroups Property
Gets event groups for current record.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort[] EventGroups { get; }
Public ReadOnly Property EventGroups As UShort()
    Get
member EventGroups : uint16[] with get

function get_EventGroups();

public:
property array<unsigned short>^ EventGroups {
    array<unsigned short>^ get ();
}

Property Value

Type: UInt16
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.FileName Property

Grid Solutions Framework ParserFileName Property
Gets or sets EMAX data filename.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
If there are more than one data files in a set (e.g., RCL/RCU), this should be set to first file name in the set, e.g., DATA123.RCL.
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.Timestamp Property

Grid Solutions Framework ParserTimestamp Property
Gets timestamp of current record in the timezone of provided IRIG signal.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Timestamp { get; }
Public ReadOnly Property Timestamp As DateTime
    Get
member Timestamp : DateTime with get

function get_Timestamp();

public:
property DateTime Timestamp {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.TimestampAsUtc Property

Grid Solutions Framework ParserTimestampAsUtc Property
Attempts to get current timestamp converted to UTC.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime TimestampAsUtc { get; }
Public ReadOnly Property TimestampAsUtc As DateTime
    Get
member TimestampAsUtc : DateTime with get

function get_TimestampAsUtc();

public:
property DateTime TimestampAsUtc {
    DateTime get ();
}

Property Value

Type: DateTime
Remarks
This will only be accurate if timezone configured in device matches IRIG clock.
See Also

Reference

Parser Class
GSF.EMAX Namespace


Parser.Values Property

Grid Solutions Framework ParserValues Property
Gets values of current record.

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double[] Values { get; }
Public ReadOnly Property Values As Double()
    Get
member Values : float[] with get

function get_Values();

public:
property array<double>^ Values {
    array<double>^ get ();
}

Property Value

Type: Double
See Also

Reference

Parser Class
GSF.EMAX Namespace


PHASOR_GROUP Structure

Grid Solutions Framework PHASOR_GROUP Structure

[Missing <summary> documentation for "T:GSF.EMAX.PHASOR_GROUP"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct PHASOR_GROUP
Public Structure PHASOR_GROUP
[<SealedAttribute>]
type PHASOR_GROUP =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class PHASOR_GROUP

The PHASOR_GROUP type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | values |
Top
See Also

Reference

GSF.EMAX Namespace


PHASOR_GROUP Fields

Grid Solutions Framework PHASOR_GROUP Fields

The PHASOR_GROUP type exposes the following members.

Fields
 | Name | Description
Public field | values |
Top
See Also

Reference

PHASOR_GROUP Structure
GSF.EMAX Namespace


PHASOR_GROUP.values Field

Grid Solutions Framework PHASOR_GROUPvalues Field

[Missing <summary> documentation for "F:GSF.EMAX.PHASOR_GROUP.values"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short[] values
Public values As Short()
val mutable values: int16[]
var values
public:
array<short>^ values

Field Value

Type: Int16
See Also

Reference

PHASOR_GROUP Structure
GSF.EMAX Namespace


PHASOR_GROUP Methods

Grid Solutions Framework PHASOR_GROUP Methods

The PHASOR_GROUP type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PHASOR_GROUP Structure
GSF.EMAX Namespace


PHASOR_GROUPS Structure

Grid Solutions Framework PHASOR_GROUPS Structure

[Missing <summary> documentation for "T:GSF.EMAX.PHASOR_GROUPS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct PHASOR_GROUPS
Public Structure PHASOR_GROUPS
[<SealedAttribute>]
type PHASOR_GROUPS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class PHASOR_GROUPS

The PHASOR_GROUPS type exposes the following members.

Constructors
 | Name | Description
Public method | PHASOR_GROUPS | Initializes a new instance of the PHASOR_GROUPS class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | groups |
Public field | length |
Top
See Also

Reference

GSF.EMAX Namespace


PHASOR_GROUPS Constructor

Grid Solutions Framework PHASOR_GROUPS Constructor
Initializes a new instance of the PHASOR_GROUPS class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PHASOR_GROUPS(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> PHASOR_GROUPS
GSF.EMAX.PHASOR_GROUPS = function(reader);
public:
PHASOR_GROUPS(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.PHASOR_GROUPS.#ctor(System.IO.BinaryReader)"]

See Also

Reference

PHASOR_GROUPS Structure
GSF.EMAX Namespace


PHASOR_GROUPS Fields

Grid Solutions Framework PHASOR_GROUPS Fields

The PHASOR_GROUPS type exposes the following members.

Fields
 | Name | Description
Public field | groups |
Public field | length |
Top
See Also

Reference

PHASOR_GROUPS Structure
GSF.EMAX Namespace


PHASOR_GROUPS.groups Field

Grid Solutions Framework PHASOR_GROUPSgroups Field

[Missing <summary> documentation for "F:GSF.EMAX.PHASOR_GROUPS.groups"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PHASOR_GROUP[] groups
Public groups As PHASOR_GROUP()
val mutable groups: PHASOR_GROUP[]
var groups
public:
array<PHASOR_GROUP>^ groups

Field Value

Type: PHASOR_GROUP
See Also

Reference

PHASOR_GROUPS Structure
GSF.EMAX Namespace


PHASOR_GROUPS.length Field

Grid Solutions Framework PHASOR_GROUPSlength Field

[Missing <summary> documentation for "F:GSF.EMAX.PHASOR_GROUPS.length"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short length
Public length As Short
val mutable length: int16
var length
public:
short length

Field Value

Type: Int16
See Also

Reference

PHASOR_GROUPS Structure
GSF.EMAX Namespace


PHASOR_GROUPS Methods

Grid Solutions Framework PHASOR_GROUPS Methods

The PHASOR_GROUPS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PHASOR_GROUPS Structure
GSF.EMAX Namespace


SENS_RSLTS Structure

Grid Solutions Framework SENS_RSLTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.SENS_RSLTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SENS_RSLTS
Public Structure SENS_RSLTS
[<SealedAttribute>]
type SENS_RSLTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SENS_RSLTS

The SENS_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | freq_rslts |
Public field | seq_rslts |
Public field | swing_rslts |
Public field | thd_rslts |
Public field | vFreqRslts |
Public field | vNFreqChnls |
Top
See Also

Reference

GSF.EMAX Namespace


SENS_RSLTS Fields

Grid Solutions Framework SENS_RSLTS Fields

The SENS_RSLTS type exposes the following members.

Fields
 | Name | Description
Public field | freq_rslts |
Public field | seq_rslts |
Public field | swing_rslts |
Public field | thd_rslts |
Public field | vFreqRslts |
Public field | vNFreqChnls |
Top
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SENS_RSLTS.freq_rslts Field

Grid Solutions Framework SENS_RSLTSfreq_rslts Field

[Missing <summary> documentation for "F:GSF.EMAX.SENS_RSLTS.freq_rslts"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FREQUENCY_RSLTS freq_rslts
Public freq_rslts As FREQUENCY_RSLTS
val mutable freq_rslts: FREQUENCY_RSLTS
var freq_rslts
public:
FREQUENCY_RSLTS freq_rslts

Field Value

Type: FREQUENCY_RSLTS
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SENS_RSLTS.seq_rslts Field

Grid Solutions Framework SENS_RSLTSseq_rslts Field

[Missing <summary> documentation for "F:GSF.EMAX.SENS_RSLTS.seq_rslts"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SEQ_RSLTS[] seq_rslts
Public seq_rslts As SEQ_RSLTS()
val mutable seq_rslts: SEQ_RSLTS[]
var seq_rslts
public:
array<SEQ_RSLTS>^ seq_rslts

Field Value

Type: SEQ_RSLTS
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SENS_RSLTS.swing_rslts Field

Grid Solutions Framework SENS_RSLTSswing_rslts Field

[Missing <summary> documentation for "F:GSF.EMAX.SENS_RSLTS.swing_rslts"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SWING_RSLTS[] swing_rslts
Public swing_rslts As SWING_RSLTS()
val mutable swing_rslts: SWING_RSLTS[]
var swing_rslts
public:
array<SWING_RSLTS>^ swing_rslts

Field Value

Type: SWING_RSLTS
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SENS_RSLTS.thd_rslts Field

Grid Solutions Framework SENS_RSLTSthd_rslts Field

[Missing <summary> documentation for "F:GSF.EMAX.SENS_RSLTS.thd_rslts"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public THD_RSLTS thd_rslts
Public thd_rslts As THD_RSLTS
val mutable thd_rslts: THD_RSLTS
var thd_rslts
public:
THD_RSLTS thd_rslts

Field Value

Type: THD_RSLTS
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SENS_RSLTS.vFreqRslts Field

Grid Solutions Framework SENS_RSLTSvFreqRslts Field

[Missing <summary> documentation for "F:GSF.EMAX.SENS_RSLTS.vFreqRslts"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TFreqRslts[] vFreqRslts
Public vFreqRslts As TFreqRslts()
val mutable vFreqRslts: TFreqRslts[]
var vFreqRslts
public:
array<TFreqRslts>^ vFreqRslts

Field Value

Type: TFreqRslts
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SENS_RSLTS.vNFreqChnls Field

Grid Solutions Framework SENS_RSLTSvNFreqChnls Field

[Missing <summary> documentation for "F:GSF.EMAX.SENS_RSLTS.vNFreqChnls"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vNFreqChnls
Public vNFreqChnls As Short
val mutable vNFreqChnls: int16
var vNFreqChnls
public:
short vNFreqChnls

Field Value

Type: Int16
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SENS_RSLTS Methods

Grid Solutions Framework SENS_RSLTS Methods

The SENS_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SENS_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS Structure

Grid Solutions Framework SEQ_RSLTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.SEQ_RSLTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SEQ_RSLTS
Public Structure SEQ_RSLTS
[<SealedAttribute>]
type SEQ_RSLTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SEQ_RSLTS

The SEQ_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | flag_seq |
Public field | mag_neg_o |
Public field | mag_pos_o |
Public field | mag_pos_u |
Public field | mag_zero_o |
Public field | offset_neg_seq |
Public field | offset_pos_seq_over |
Public field | offset_pos_seq_under |
Public field | offset_zero_seq |
Top
See Also

Reference

GSF.EMAX Namespace


SEQ_RSLTS Fields

Grid Solutions Framework SEQ_RSLTS Fields

The SEQ_RSLTS type exposes the following members.

Fields
 | Name | Description
Public field | flag_seq |
Public field | mag_neg_o |
Public field | mag_pos_o |
Public field | mag_pos_u |
Public field | mag_zero_o |
Public field | offset_neg_seq |
Public field | offset_pos_seq_over |
Public field | offset_pos_seq_under |
Public field | offset_zero_seq |
Top
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.flag_seq Field

Grid Solutions Framework SEQ_RSLTSflag_seq Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.flag_seq"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort flag_seq
Public flag_seq As UShort
val mutable flag_seq: uint16
var flag_seq
public:
unsigned short flag_seq

Field Value

Type: UInt16
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.mag_neg_o Field

Grid Solutions Framework SEQ_RSLTSmag_neg_o Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.mag_neg_o"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float mag_neg_o
Public mag_neg_o As Single
val mutable mag_neg_o: float32
var mag_neg_o
public:
float mag_neg_o

Field Value

Type: Single
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.mag_pos_o Field

Grid Solutions Framework SEQ_RSLTSmag_pos_o Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.mag_pos_o"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float mag_pos_o
Public mag_pos_o As Single
val mutable mag_pos_o: float32
var mag_pos_o
public:
float mag_pos_o

Field Value

Type: Single
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.mag_pos_u Field

Grid Solutions Framework SEQ_RSLTSmag_pos_u Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.mag_pos_u"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float mag_pos_u
Public mag_pos_u As Single
val mutable mag_pos_u: float32
var mag_pos_u
public:
float mag_pos_u

Field Value

Type: Single
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.mag_zero_o Field

Grid Solutions Framework SEQ_RSLTSmag_zero_o Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.mag_zero_o"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float mag_zero_o
Public mag_zero_o As Single
val mutable mag_zero_o: float32
var mag_zero_o
public:
float mag_zero_o

Field Value

Type: Single
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.offset_neg_seq Field

Grid Solutions Framework SEQ_RSLTSoffset_neg_seq Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.offset_neg_seq"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short offset_neg_seq
Public offset_neg_seq As Short
val mutable offset_neg_seq: int16
var offset_neg_seq
public:
short offset_neg_seq

Field Value

Type: Int16
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.offset_pos_seq_over Field

Grid Solutions Framework SEQ_RSLTSoffset_pos_seq_over Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.offset_pos_seq_over"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short offset_pos_seq_over
Public offset_pos_seq_over As Short
val mutable offset_pos_seq_over: int16
var offset_pos_seq_over
public:
short offset_pos_seq_over

Field Value

Type: Int16
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.offset_pos_seq_under Field

Grid Solutions Framework SEQ_RSLTSoffset_pos_seq_under Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.offset_pos_seq_under"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short offset_pos_seq_under
Public offset_pos_seq_under As Short
val mutable offset_pos_seq_under: int16
var offset_pos_seq_under
public:
short offset_pos_seq_under

Field Value

Type: Int16
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS.offset_zero_seq Field

Grid Solutions Framework SEQ_RSLTSoffset_zero_seq Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQ_RSLTS.offset_zero_seq"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short offset_zero_seq
Public offset_zero_seq As Short
val mutable offset_zero_seq: int16
var offset_zero_seq
public:
short offset_zero_seq

Field Value

Type: Int16
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQ_RSLTS Methods

Grid Solutions Framework SEQ_RSLTS Methods

The SEQ_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SEQ_RSLTS Structure
GSF.EMAX Namespace


SEQUENCE_CHANNEL Structure

Grid Solutions Framework SEQUENCE_CHANNEL Structure

[Missing <summary> documentation for "T:GSF.EMAX.SEQUENCE_CHANNEL"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SEQUENCE_CHANNEL
Public Structure SEQUENCE_CHANNEL
[<SealedAttribute>]
type SEQUENCE_CHANNEL =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SEQUENCE_CHANNEL

The SEQUENCE_CHANNEL type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | values |
Top
See Also

Reference

GSF.EMAX Namespace


SEQUENCE_CHANNEL Fields

Grid Solutions Framework SEQUENCE_CHANNEL Fields

The SEQUENCE_CHANNEL type exposes the following members.

Fields
 | Name | Description
Public field | values |
Top
See Also

Reference

SEQUENCE_CHANNEL Structure
GSF.EMAX Namespace


SEQUENCE_CHANNEL.values Field

Grid Solutions Framework SEQUENCE_CHANNELvalues Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQUENCE_CHANNEL.values"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short[] values
Public values As Short()
val mutable values: int16[]
var values
public:
array<short>^ values

Field Value

Type: Int16
See Also

Reference

SEQUENCE_CHANNEL Structure
GSF.EMAX Namespace


SEQUENCE_CHANNEL Methods

Grid Solutions Framework SEQUENCE_CHANNEL Methods

The SEQUENCE_CHANNEL type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SEQUENCE_CHANNEL Structure
GSF.EMAX Namespace


SEQUENCE_CHANNELS Structure

Grid Solutions Framework SEQUENCE_CHANNELS Structure

[Missing <summary> documentation for "T:GSF.EMAX.SEQUENCE_CHANNELS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SEQUENCE_CHANNELS
Public Structure SEQUENCE_CHANNELS
[<SealedAttribute>]
type SEQUENCE_CHANNELS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SEQUENCE_CHANNELS

The SEQUENCE_CHANNELS type exposes the following members.

Constructors
 | Name | Description
Public method | SEQUENCE_CHANNELS | Initializes a new instance of the SEQUENCE_CHANNELS class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | channels |
Public field | length |
Top
See Also

Reference

GSF.EMAX Namespace


SEQUENCE_CHANNELS Constructor

Grid Solutions Framework SEQUENCE_CHANNELS Constructor
Initializes a new instance of the SEQUENCE_CHANNELS class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SEQUENCE_CHANNELS(
    BinaryReader reader
)
Public Sub New (
    reader As BinaryReader
)
new :
        reader : BinaryReader -> SEQUENCE_CHANNELS
GSF.EMAX.SEQUENCE_CHANNELS = function(reader);
public:
SEQUENCE_CHANNELS(
    BinaryReader^ reader
)

Parameters

reader
Type: System.IOBinaryReader

[Missing <param name="reader"/> documentation for "M:GSF.EMAX.SEQUENCE_CHANNELS.#ctor(System.IO.BinaryReader)"]

See Also

Reference

SEQUENCE_CHANNELS Structure
GSF.EMAX Namespace


SEQUENCE_CHANNELS Fields

Grid Solutions Framework SEQUENCE_CHANNELS Fields

The SEQUENCE_CHANNELS type exposes the following members.

Fields
 | Name | Description
Public field | channels |
Public field | length |
Top
See Also

Reference

SEQUENCE_CHANNELS Structure
GSF.EMAX Namespace


SEQUENCE_CHANNELS.channels Field

Grid Solutions Framework SEQUENCE_CHANNELSchannels Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQUENCE_CHANNELS.channels"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SEQUENCE_CHANNEL[] channels
Public channels As SEQUENCE_CHANNEL()
val mutable channels: SEQUENCE_CHANNEL[]
var channels
public:
array<SEQUENCE_CHANNEL>^ channels

Field Value

Type: SEQUENCE_CHANNEL
See Also

Reference

SEQUENCE_CHANNELS Structure
GSF.EMAX Namespace


SEQUENCE_CHANNELS.length Field

Grid Solutions Framework SEQUENCE_CHANNELSlength Field

[Missing <summary> documentation for "F:GSF.EMAX.SEQUENCE_CHANNELS.length"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short length
Public length As Short
val mutable length: int16
var length
public:
short length

Field Value

Type: Int16
See Also

Reference

SEQUENCE_CHANNELS Structure
GSF.EMAX Namespace


SEQUENCE_CHANNELS Methods

Grid Solutions Framework SEQUENCE_CHANNELS Methods

The SEQUENCE_CHANNELS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SEQUENCE_CHANNELS Structure
GSF.EMAX Namespace


StructureType Enumeration

Grid Solutions Framework StructureType Enumeration

[Missing <summary> documentation for "T:GSF.EMAX.StructureType"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum StructureType
Public Enumeration StructureType
type StructureType
GSF.EMAX.StructureType = function();
GSF.EMAX.StructureType.createEnum('GSF.EMAX.StructureType', false);
public enum class StructureType
Members
Member name | Value | Description
EndOfStructures | 0 |
SYSTEM_PARAMETERS | 1 |
A_E_RSLTS | 3 |
ANALOG_GROUP | 4 |
EVENT_GROUP | 5 |
ANLG_CHNL_NEW | 6 |
EVNT_CHNL_NEW | 7 |
ANLG_CHNLS | 8 |
SYS_SETTINGS | 11 |
SHORT_HEADER | 13 |
FAULT_HEADER | 269 |
EVENT_DISPLAY | 14 |
IDENTSTRING | 16 |
A_SELECTION | 64 |
E_GROUP_SELECT | 65 |
PHASOR_GROUP | 66 |
LINE_CONSTANTS | 67 |
LINE_NAMES | 68 |
FAULT_LOCATION | 69 |
SENS_RSLTS | 80 |
SEQUENCE_CHANNELS | 81 |
TPwrRcd | 82 |
BoardAnalogEventChannels | 96 |
BREAKER_TRIP_TIMES | 97 |
Unknown | 65535 |
See Also

Reference

GSF.EMAX Namespace


SWING_RSLTS Structure

Grid Solutions Framework SWING_RSLTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.SWING_RSLTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SWING_RSLTS
Public Structure SWING_RSLTS
[<SealedAttribute>]
type SWING_RSLTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SWING_RSLTS

The SWING_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | s_flag_r |
Public field | s_offset |
Public field | s_val_max0 |
Public field | s_val_min0 |
Top
See Also

Reference

GSF.EMAX Namespace


SWING_RSLTS Fields

Grid Solutions Framework SWING_RSLTS Fields

The SWING_RSLTS type exposes the following members.

Fields
 | Name | Description
Public field | s_flag_r |
Public field | s_offset |
Public field | s_val_max0 |
Public field | s_val_min0 |
Top
See Also

Reference

SWING_RSLTS Structure
GSF.EMAX Namespace


SWING_RSLTS.s_flag_r Field

Grid Solutions Framework SWING_RSLTSs_flag_r Field

[Missing <summary> documentation for "F:GSF.EMAX.SWING_RSLTS.s_flag_r"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort s_flag_r
Public s_flag_r As UShort
val mutable s_flag_r: uint16
var s_flag_r
public:
unsigned short s_flag_r

Field Value

Type: UInt16
See Also

Reference

SWING_RSLTS Structure
GSF.EMAX Namespace


SWING_RSLTS.s_offset Field

Grid Solutions Framework SWING_RSLTSs_offset Field

[Missing <summary> documentation for "F:GSF.EMAX.SWING_RSLTS.s_offset"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short s_offset
Public s_offset As Short
val mutable s_offset: int16
var s_offset
public:
short s_offset

Field Value

Type: Int16
See Also

Reference

SWING_RSLTS Structure
GSF.EMAX Namespace


SWING_RSLTS.s_val_max0 Field

Grid Solutions Framework SWING_RSLTSs_val_max0 Field

[Missing <summary> documentation for "F:GSF.EMAX.SWING_RSLTS.s_val_max0"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float s_val_max0
Public s_val_max0 As Single
val mutable s_val_max0: float32
var s_val_max0
public:
float s_val_max0

Field Value

Type: Single
See Also

Reference

SWING_RSLTS Structure
GSF.EMAX Namespace


SWING_RSLTS.s_val_min0 Field

Grid Solutions Framework SWING_RSLTSs_val_min0 Field

[Missing <summary> documentation for "F:GSF.EMAX.SWING_RSLTS.s_val_min0"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float s_val_min0
Public s_val_min0 As Single
val mutable s_val_min0: float32
var s_val_min0
public:
float s_val_min0

Field Value

Type: Single
See Also

Reference

SWING_RSLTS Structure
GSF.EMAX Namespace


SWING_RSLTS Methods

Grid Solutions Framework SWING_RSLTS Methods

The SWING_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SWING_RSLTS Structure
GSF.EMAX Namespace


SYS_SETTINGS Structure

Grid Solutions Framework SYS_SETTINGS Structure

[Missing <summary> documentation for "T:GSF.EMAX.SYS_SETTINGS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SYS_SETTINGS
Public Structure SYS_SETTINGS
[<SealedAttribute>]
type SYS_SETTINGS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SYS_SETTINGS

The SYS_SETTINGS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | analog_groups |
Public field | event_groups |
Public field | frequency |
Public field | local_ident |
Public field | postfault_time |
Public field | postfault_time_max |
Public field | prefault_smpls_disp |
Public field | record_fill |
Public field | samples_per_second |
Public field | time_zone |
Public field | time_zone_information |
Public field | version_string |
Public field | vXtndFlt |
Top
See Also

Reference

GSF.EMAX Namespace


SYS_SETTINGS Fields

Grid Solutions Framework SYS_SETTINGS Fields

The SYS_SETTINGS type exposes the following members.

Fields
 | Name | Description
Public field | analog_groups |
Public field | event_groups |
Public field | frequency |
Public field | local_ident |
Public field | postfault_time |
Public field | postfault_time_max |
Public field | prefault_smpls_disp |
Public field | record_fill |
Public field | samples_per_second |
Public field | time_zone |
Public field | time_zone_information |
Public field | version_string |
Public field | vXtndFlt |
Top
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.analog_groups Field

Grid Solutions Framework SYS_SETTINGSanalog_groups Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.analog_groups"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short analog_groups
Public analog_groups As Short
val mutable analog_groups: int16
var analog_groups
public:
short analog_groups

Field Value

Type: Int16
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.event_groups Field

Grid Solutions Framework SYS_SETTINGSevent_groups Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.event_groups"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short event_groups
Public event_groups As Short
val mutable event_groups: int16
var event_groups
public:
short event_groups

Field Value

Type: Int16
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.frequency Field

Grid Solutions Framework SYS_SETTINGSfrequency Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.frequency"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sbyte frequency
Public frequency As SByte
val mutable frequency: sbyte
var frequency
public:
signed char frequency

Field Value

Type: SByte
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.local_ident Field

Grid Solutions Framework SYS_SETTINGSlocal_ident Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.local_ident"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string local_ident
Public local_ident As String
val mutable local_ident: string
var local_ident
public:
String^ local_ident

Field Value

Type: String
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.postfault_time Field

Grid Solutions Framework SYS_SETTINGSpostfault_time Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.postfault_time"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short postfault_time
Public postfault_time As Short
val mutable postfault_time: int16
var postfault_time
public:
short postfault_time

Field Value

Type: Int16
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.postfault_time_max Field

Grid Solutions Framework SYS_SETTINGSpostfault_time_max Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.postfault_time_max"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short postfault_time_max
Public postfault_time_max As Short
val mutable postfault_time_max: int16
var postfault_time_max
public:
short postfault_time_max

Field Value

Type: Int16
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.prefault_smpls_disp Field

Grid Solutions Framework SYS_SETTINGSprefault_smpls_disp Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.prefault_smpls_disp"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short prefault_smpls_disp
Public prefault_smpls_disp As Short
val mutable prefault_smpls_disp: int16
var prefault_smpls_disp
public:
short prefault_smpls_disp

Field Value

Type: Int16
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.record_fill Field

Grid Solutions Framework SYS_SETTINGSrecord_fill Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.record_fill"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short record_fill
Public record_fill As Short
val mutable record_fill: int16
var record_fill
public:
short record_fill

Field Value

Type: Int16
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.samples_per_second Field

Grid Solutions Framework SYS_SETTINGSsamples_per_second Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.samples_per_second"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort samples_per_second
Public samples_per_second As UShort
val mutable samples_per_second: uint16
var samples_per_second
public:
unsigned short samples_per_second

Field Value

Type: UInt16
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.time_zone Field

Grid Solutions Framework SYS_SETTINGStime_zone Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.time_zone"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string time_zone
Public time_zone As String
val mutable time_zone: string
var time_zone
public:
String^ time_zone

Field Value

Type: String
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.time_zone_information Field

Grid Solutions Framework SYS_SETTINGStime_zone_information Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.time_zone_information"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TIME_ZONE_INFORMATION time_zone_information
Public time_zone_information As TIME_ZONE_INFORMATION
val mutable time_zone_information: TIME_ZONE_INFORMATION
var time_zone_information
public:
TIME_ZONE_INFORMATION time_zone_information

Field Value

Type: TIME_ZONE_INFORMATION
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.version_string Field

Grid Solutions Framework SYS_SETTINGSversion_string Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.version_string"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string version_string
Public version_string As String
val mutable version_string: string
var version_string
public:
String^ version_string

Field Value

Type: String
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS.vXtndFlt Field

Grid Solutions Framework SYS_SETTINGSvXtndFlt Field

[Missing <summary> documentation for "F:GSF.EMAX.SYS_SETTINGS.vXtndFlt"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sbyte vXtndFlt
Public vXtndFlt As SByte
val mutable vXtndFlt: sbyte
var vXtndFlt
public:
signed char vXtndFlt

Field Value

Type: SByte
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYS_SETTINGS Methods

Grid Solutions Framework SYS_SETTINGS Methods

The SYS_SETTINGS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SYS_SETTINGS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS Structure

Grid Solutions Framework SYSTEM_PARAMETERS Structure

[Missing <summary> documentation for "T:GSF.EMAX.SYSTEM_PARAMETERS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SYSTEM_PARAMETERS
Public Structure SYSTEM_PARAMETERS
[<SealedAttribute>]
type SYSTEM_PARAMETERS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SYSTEM_PARAMETERS

The SYSTEM_PARAMETERS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetTimeZoneInfo | (Defined by ControlFileStructureExtensions.)
Top
Fields
 | Name | Description
Public field | analog_groups |
Public field | board1_scan_multiplier |
Public field | board2_scan_multiplier |
Public field | channel_offset |
Public field | event_groups |
Public field | flag |
Public field | frequency |
Public field | local_ident |
Public field | mS_time |
Public field | postfault_samples |
Public field | postfault_samples_max |
Public field | postfault_time |
Public field | postfault_time_max |
Public field | prefault_samples |
Public field | prefault_smpls_disp |
Public field | rcd_sample_count |
Public field | record_fill |
Public field | samples_per_second |
Public field | sequence |
Public field | start_offset_samples |
Public field | time_fault |
Public field | time_flag1 |
Public field | time_rtc |
Public field | time_startup |
Public field | time_sys |
Public field | time_zone |
Public field | time_zone_information |
Public field | version_string |
Public field | vXtndFlt |
Top
Properties
 | Name | Description
Public property | FaultTime |
Top
See Also

Reference

GSF.EMAX Namespace


SYSTEM_PARAMETERS Fields

Grid Solutions Framework SYSTEM_PARAMETERS Fields

The SYSTEM_PARAMETERS type exposes the following members.

Fields
 | Name | Description
Public field | analog_groups |
Public field | board1_scan_multiplier |
Public field | board2_scan_multiplier |
Public field | channel_offset |
Public field | event_groups |
Public field | flag |
Public field | frequency |
Public field | local_ident |
Public field | mS_time |
Public field | postfault_samples |
Public field | postfault_samples_max |
Public field | postfault_time |
Public field | postfault_time_max |
Public field | prefault_samples |
Public field | prefault_smpls_disp |
Public field | rcd_sample_count |
Public field | record_fill |
Public field | samples_per_second |
Public field | sequence |
Public field | start_offset_samples |
Public field | time_fault |
Public field | time_flag1 |
Public field | time_rtc |
Public field | time_startup |
Public field | time_sys |
Public field | time_zone |
Public field | time_zone_information |
Public field | version_string |
Public field | vXtndFlt |
Top
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.analog_groups Field

Grid Solutions Framework SYSTEM_PARAMETERSanalog_groups Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.analog_groups"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short analog_groups
Public analog_groups As Short
val mutable analog_groups: int16
var analog_groups
public:
short analog_groups

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.board1_scan_multiplier Field

Grid Solutions Framework SYSTEM_PARAMETERSboard1_scan_multiplier Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.board1_scan_multiplier"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte board1_scan_multiplier
Public board1_scan_multiplier As Byte
val mutable board1_scan_multiplier: byte
var board1_scan_multiplier
public:
unsigned char board1_scan_multiplier

Field Value

Type: Byte
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.board2_scan_multiplier Field

Grid Solutions Framework SYSTEM_PARAMETERSboard2_scan_multiplier Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.board2_scan_multiplier"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte board2_scan_multiplier
Public board2_scan_multiplier As Byte
val mutable board2_scan_multiplier: byte
var board2_scan_multiplier
public:
unsigned char board2_scan_multiplier

Field Value

Type: Byte
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.channel_offset Field

Grid Solutions Framework SYSTEM_PARAMETERSchannel_offset Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.channel_offset"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short channel_offset
Public channel_offset As Short
val mutable channel_offset: int16
var channel_offset
public:
short channel_offset

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.event_groups Field

Grid Solutions Framework SYSTEM_PARAMETERSevent_groups Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.event_groups"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short event_groups
Public event_groups As Short
val mutable event_groups: int16
var event_groups
public:
short event_groups

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.flag Field

Grid Solutions Framework SYSTEM_PARAMETERSflag Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.flag"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short flag
Public flag As Short
val mutable flag: int16
var flag
public:
short flag

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.frequency Field

Grid Solutions Framework SYSTEM_PARAMETERSfrequency Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.frequency"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sbyte frequency
Public frequency As SByte
val mutable frequency: sbyte
var frequency
public:
signed char frequency

Field Value

Type: SByte
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.local_ident Field

Grid Solutions Framework SYSTEM_PARAMETERSlocal_ident Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.local_ident"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string local_ident
Public local_ident As String
val mutable local_ident: string
var local_ident
public:
String^ local_ident

Field Value

Type: String
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.mS_time Field

Grid Solutions Framework SYSTEM_PARAMETERSmS_time Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.mS_time"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short mS_time
Public mS_time As Short
val mutable mS_time: int16
var mS_time
public:
short mS_time

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.postfault_samples Field

Grid Solutions Framework SYSTEM_PARAMETERSpostfault_samples Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.postfault_samples"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int postfault_samples
Public postfault_samples As Integer
val mutable postfault_samples: int
var postfault_samples
public:
int postfault_samples

Field Value

Type: Int32
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.postfault_samples_max Field

Grid Solutions Framework SYSTEM_PARAMETERSpostfault_samples_max Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.postfault_samples_max"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int postfault_samples_max
Public postfault_samples_max As Integer
val mutable postfault_samples_max: int
var postfault_samples_max
public:
int postfault_samples_max

Field Value

Type: Int32
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.postfault_time Field

Grid Solutions Framework SYSTEM_PARAMETERSpostfault_time Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.postfault_time"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short postfault_time
Public postfault_time As Short
val mutable postfault_time: int16
var postfault_time
public:
short postfault_time

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.postfault_time_max Field

Grid Solutions Framework SYSTEM_PARAMETERSpostfault_time_max Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.postfault_time_max"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short postfault_time_max
Public postfault_time_max As Short
val mutable postfault_time_max: int16
var postfault_time_max
public:
short postfault_time_max

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.prefault_samples Field

Grid Solutions Framework SYSTEM_PARAMETERSprefault_samples Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.prefault_samples"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short prefault_samples
Public prefault_samples As Short
val mutable prefault_samples: int16
var prefault_samples
public:
short prefault_samples

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.prefault_smpls_disp Field

Grid Solutions Framework SYSTEM_PARAMETERSprefault_smpls_disp Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.prefault_smpls_disp"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short prefault_smpls_disp
Public prefault_smpls_disp As Short
val mutable prefault_smpls_disp: int16
var prefault_smpls_disp
public:
short prefault_smpls_disp

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.rcd_sample_count Field

Grid Solutions Framework SYSTEM_PARAMETERSrcd_sample_count Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.rcd_sample_count"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int rcd_sample_count
Public rcd_sample_count As Integer
val mutable rcd_sample_count: int
var rcd_sample_count
public:
int rcd_sample_count

Field Value

Type: Int32
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.record_fill Field

Grid Solutions Framework SYSTEM_PARAMETERSrecord_fill Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.record_fill"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short record_fill
Public record_fill As Short
val mutable record_fill: int16
var record_fill
public:
short record_fill

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.samples_per_second Field

Grid Solutions Framework SYSTEM_PARAMETERSsamples_per_second Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.samples_per_second"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort samples_per_second
Public samples_per_second As UShort
val mutable samples_per_second: uint16
var samples_per_second
public:
unsigned short samples_per_second

Field Value

Type: UInt16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.sequence Field

Grid Solutions Framework SYSTEM_PARAMETERSsequence Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.sequence"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short sequence
Public sequence As Short
val mutable sequence: int16
var sequence
public:
short sequence

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.start_offset_samples Field

Grid Solutions Framework SYSTEM_PARAMETERSstart_offset_samples Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.start_offset_samples"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short start_offset_samples
Public start_offset_samples As Short
val mutable start_offset_samples: int16
var start_offset_samples
public:
short start_offset_samples

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.time_fault Field

Grid Solutions Framework SYSTEM_PARAMETERStime_fault Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.time_fault"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint time_fault
Public time_fault As UInteger
val mutable time_fault: uint32
var time_fault
public:
unsigned int time_fault

Field Value

Type: UInt32
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.time_flag1 Field

Grid Solutions Framework SYSTEM_PARAMETERStime_flag1 Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.time_flag1"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short time_flag1
Public time_flag1 As Short
val mutable time_flag1: int16
var time_flag1
public:
short time_flag1

Field Value

Type: Int16
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.time_rtc Field

Grid Solutions Framework SYSTEM_PARAMETERStime_rtc Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.time_rtc"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint time_rtc
Public time_rtc As UInteger
val mutable time_rtc: uint32
var time_rtc
public:
unsigned int time_rtc

Field Value

Type: UInt32
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.time_startup Field

Grid Solutions Framework SYSTEM_PARAMETERStime_startup Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.time_startup"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint time_startup
Public time_startup As UInteger
val mutable time_startup: uint32
var time_startup
public:
unsigned int time_startup

Field Value

Type: UInt32
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.time_sys Field

Grid Solutions Framework SYSTEM_PARAMETERStime_sys Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.time_sys"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint time_sys
Public time_sys As UInteger
val mutable time_sys: uint32
var time_sys
public:
unsigned int time_sys

Field Value

Type: UInt32
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.time_zone Field

Grid Solutions Framework SYSTEM_PARAMETERStime_zone Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.time_zone"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string time_zone
Public time_zone As String
val mutable time_zone: string
var time_zone
public:
String^ time_zone

Field Value

Type: String
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.time_zone_information Field

Grid Solutions Framework SYSTEM_PARAMETERStime_zone_information Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.time_zone_information"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TIME_ZONE_INFORMATION time_zone_information
Public time_zone_information As TIME_ZONE_INFORMATION
val mutable time_zone_information: TIME_ZONE_INFORMATION
var time_zone_information
public:
TIME_ZONE_INFORMATION time_zone_information

Field Value

Type: TIME_ZONE_INFORMATION
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.version_string Field

Grid Solutions Framework SYSTEM_PARAMETERSversion_string Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.version_string"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string version_string
Public version_string As String
val mutable version_string: string
var version_string
public:
String^ version_string

Field Value

Type: String
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.vXtndFlt Field

Grid Solutions Framework SYSTEM_PARAMETERSvXtndFlt Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEM_PARAMETERS.vXtndFlt"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sbyte vXtndFlt
Public vXtndFlt As SByte
val mutable vXtndFlt: sbyte
var vXtndFlt
public:
signed char vXtndFlt

Field Value

Type: SByte
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS Methods

Grid Solutions Framework SYSTEM_PARAMETERS Methods

The SYSTEM_PARAMETERS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetTimeZoneInfo | (Defined by ControlFileStructureExtensions.)
Top
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS Properties

Grid Solutions Framework SYSTEM_PARAMETERS Properties

The SYSTEM_PARAMETERS type exposes the following members.

Properties
 | Name | Description
Public property | FaultTime |
Top
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEM_PARAMETERS.FaultTime Property

Grid Solutions Framework SYSTEM_PARAMETERSFaultTime Property

[Missing <summary> documentation for "P:GSF.EMAX.SYSTEM_PARAMETERS.FaultTime"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime FaultTime { get; }
Public ReadOnly Property FaultTime As DateTime
    Get
member FaultTime : DateTime with get

function get_FaultTime();

public:
property DateTime FaultTime {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

SYSTEM_PARAMETERS Structure
GSF.EMAX Namespace


SYSTEMTIME Structure

Grid Solutions Framework SYSTEMTIME Structure

[Missing <summary> documentation for "T:GSF.EMAX.SYSTEMTIME"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SYSTEMTIME
Public Structure SYSTEMTIME
[<SealedAttribute>]
type SYSTEMTIME =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SYSTEMTIME

The SYSTEMTIME type exposes the following members.

Constructors
 | Name | Description
Public method | SYSTEMTIME | Initializes a new instance of the SYSTEMTIME class
Top
Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Day |
Public field | DayOfWeek |
Public field | Hour |
Public field | Milliseconds |
Public field | Minute |
Public field | Month |
Public field | Second |
Public field | Year |
Top
See Also

Reference

GSF.EMAX Namespace


SYSTEMTIME Constructor

Grid Solutions Framework SYSTEMTIME Constructor
Initializes a new instance of the SYSTEMTIME class

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SYSTEMTIME(
    DateTime dt
)
Public Sub New (
    dt As DateTime
)
new :
        dt : DateTime -> SYSTEMTIME
GSF.EMAX.SYSTEMTIME = function(dt);
public:
SYSTEMTIME(
    DateTime dt
)

Parameters

dt
Type: SystemDateTime

[Missing <param name="dt"/> documentation for "M:GSF.EMAX.SYSTEMTIME.#ctor(System.DateTime)"]

See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME Fields

Grid Solutions Framework SYSTEMTIME Fields

The SYSTEMTIME type exposes the following members.

Fields
 | Name | Description
Public field | Day |
Public field | DayOfWeek |
Public field | Hour |
Public field | Milliseconds |
Public field | Minute |
Public field | Month |
Public field | Second |
Public field | Year |
Top
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.Day Field

Grid Solutions Framework SYSTEMTIMEDay Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.Day"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Day
Public Day As UShort
val mutable Day: uint16
var Day
public:
unsigned short Day

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.DayOfWeek Field

Grid Solutions Framework SYSTEMTIMEDayOfWeek Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.DayOfWeek"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DayOfWeek
Public DayOfWeek As UShort
val mutable DayOfWeek: uint16
var DayOfWeek
public:
unsigned short DayOfWeek

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.Hour Field

Grid Solutions Framework SYSTEMTIMEHour Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.Hour"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Hour
Public Hour As UShort
val mutable Hour: uint16
var Hour
public:
unsigned short Hour

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.Milliseconds Field

Grid Solutions Framework SYSTEMTIMEMilliseconds Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.Milliseconds"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Milliseconds
Public Milliseconds As UShort
val mutable Milliseconds: uint16
var Milliseconds
public:
unsigned short Milliseconds

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.Minute Field

Grid Solutions Framework SYSTEMTIMEMinute Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.Minute"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Minute
Public Minute As UShort
val mutable Minute: uint16
var Minute
public:
unsigned short Minute

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.Month Field

Grid Solutions Framework SYSTEMTIMEMonth Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.Month"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Month
Public Month As UShort
val mutable Month: uint16
var Month
public:
unsigned short Month

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.Second Field

Grid Solutions Framework SYSTEMTIMESecond Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.Second"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Second
Public Second As UShort
val mutable Second: uint16
var Second
public:
unsigned short Second

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME.Year Field

Grid Solutions Framework SYSTEMTIMEYear Field

[Missing <summary> documentation for "F:GSF.EMAX.SYSTEMTIME.Year"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Year
Public Year As UShort
val mutable Year: uint16
var Year
public:
unsigned short Year

Field Value

Type: UInt16
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


SYSTEMTIME Methods

Grid Solutions Framework SYSTEMTIME Methods

The SYSTEMTIME type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SYSTEMTIME Structure
GSF.EMAX Namespace


TFreqRslts Structure

Grid Solutions Framework TFreqRslts Structure

[Missing <summary> documentation for "T:GSF.EMAX.TFreqRslts"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct TFreqRslts
Public Structure TFreqRslts
[<SealedAttribute>]
type TFreqRslts =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class TFreqRslts

The TFreqRslts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | f_flag |
Public field | f_offset |
Public field | f_result |
Top
See Also

Reference

GSF.EMAX Namespace


TFreqRslts Fields

Grid Solutions Framework TFreqRslts Fields

The TFreqRslts type exposes the following members.

Fields
 | Name | Description
Public field | f_flag |
Public field | f_offset |
Public field | f_result |
Top
See Also

Reference

TFreqRslts Structure
GSF.EMAX Namespace


TFreqRslts.f_flag Field

Grid Solutions Framework TFreqRsltsf_flag Field

[Missing <summary> documentation for "F:GSF.EMAX.TFreqRslts.f_flag"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort f_flag
Public f_flag As UShort
val mutable f_flag: uint16
var f_flag
public:
unsigned short f_flag

Field Value

Type: UInt16
See Also

Reference

TFreqRslts Structure
GSF.EMAX Namespace


TFreqRslts.f_offset Field

Grid Solutions Framework TFreqRsltsf_offset Field

[Missing <summary> documentation for "F:GSF.EMAX.TFreqRslts.f_offset"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short f_offset
Public f_offset As Short
val mutable f_offset: int16
var f_offset
public:
short f_offset

Field Value

Type: Int16
See Also

Reference

TFreqRslts Structure
GSF.EMAX Namespace


TFreqRslts.f_result Field

Grid Solutions Framework TFreqRsltsf_result Field

[Missing <summary> documentation for "F:GSF.EMAX.TFreqRslts.f_result"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float f_result
Public f_result As Single
val mutable f_result: float32
var f_result
public:
float f_result

Field Value

Type: Single
See Also

Reference

TFreqRslts Structure
GSF.EMAX Namespace


TFreqRslts Methods

Grid Solutions Framework TFreqRslts Methods

The TFreqRslts type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TFreqRslts Structure
GSF.EMAX Namespace


THD_RSLTS Structure

Grid Solutions Framework THD_RSLTS Structure

[Missing <summary> documentation for "T:GSF.EMAX.THD_RSLTS"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct THD_RSLTS
Public Structure THD_RSLTS
[<SealedAttribute>]
type THD_RSLTS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class THD_RSLTS

The THD_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | thd_flag |
Public field | thd_offset |
Public field | thd_result |
Top
See Also

Reference

GSF.EMAX Namespace


THD_RSLTS Fields

Grid Solutions Framework THD_RSLTS Fields

The THD_RSLTS type exposes the following members.

Fields
 | Name | Description
Public field | thd_flag |
Public field | thd_offset |
Public field | thd_result |
Top
See Also

Reference

THD_RSLTS Structure
GSF.EMAX Namespace


THD_RSLTS.thd_flag Field

Grid Solutions Framework THD_RSLTSthd_flag Field

[Missing <summary> documentation for "F:GSF.EMAX.THD_RSLTS.thd_flag"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort thd_flag
Public thd_flag As UShort
val mutable thd_flag: uint16
var thd_flag
public:
unsigned short thd_flag

Field Value

Type: UInt16
See Also

Reference

THD_RSLTS Structure
GSF.EMAX Namespace


THD_RSLTS.thd_offset Field

Grid Solutions Framework THD_RSLTSthd_offset Field

[Missing <summary> documentation for "F:GSF.EMAX.THD_RSLTS.thd_offset"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short thd_offset
Public thd_offset As Short
val mutable thd_offset: int16
var thd_offset
public:
short thd_offset

Field Value

Type: Int16
See Also

Reference

THD_RSLTS Structure
GSF.EMAX Namespace


THD_RSLTS.thd_result Field

Grid Solutions Framework THD_RSLTSthd_result Field

[Missing <summary> documentation for "F:GSF.EMAX.THD_RSLTS.thd_result"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float thd_result
Public thd_result As Single
val mutable thd_result: float32
var thd_result
public:
float thd_result

Field Value

Type: Single
See Also

Reference

THD_RSLTS Structure
GSF.EMAX Namespace


THD_RSLTS Methods

Grid Solutions Framework THD_RSLTS Methods

The THD_RSLTS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

THD_RSLTS Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION Structure

Grid Solutions Framework TIME_ZONE_INFORMATION Structure

[Missing <summary> documentation for "T:GSF.EMAX.TIME_ZONE_INFORMATION"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct TIME_ZONE_INFORMATION
Public Structure TIME_ZONE_INFORMATION
[<SealedAttribute>]
type TIME_ZONE_INFORMATION =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class TIME_ZONE_INFORMATION

The TIME_ZONE_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Bias |
Public field | DaylightBias |
Public field | DaylightDate |
Public field | DaylightName |
Public field | StandardBias |
Public field | StandardDate |
Public field | StandardName |
Top
See Also

Reference

GSF.EMAX Namespace


TIME_ZONE_INFORMATION Fields

Grid Solutions Framework TIME_ZONE_INFORMATION Fields

The TIME_ZONE_INFORMATION type exposes the following members.

Fields
 | Name | Description
Public field | Bias |
Public field | DaylightBias |
Public field | DaylightDate |
Public field | DaylightName |
Public field | StandardBias |
Public field | StandardDate |
Public field | StandardName |
Top
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION.Bias Field

Grid Solutions Framework TIME_ZONE_INFORMATIONBias Field

[Missing <summary> documentation for "F:GSF.EMAX.TIME_ZONE_INFORMATION.Bias"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Bias
Public Bias As Integer
val mutable Bias: int
var Bias
public:
int Bias

Field Value

Type: Int32
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION.DaylightBias Field

Grid Solutions Framework TIME_ZONE_INFORMATIONDaylightBias Field

[Missing <summary> documentation for "F:GSF.EMAX.TIME_ZONE_INFORMATION.DaylightBias"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DaylightBias
Public DaylightBias As Integer
val mutable DaylightBias: int
var DaylightBias
public:
int DaylightBias

Field Value

Type: Int32
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION.DaylightDate Field

Grid Solutions Framework TIME_ZONE_INFORMATIONDaylightDate Field

[Missing <summary> documentation for "F:GSF.EMAX.TIME_ZONE_INFORMATION.DaylightDate"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SYSTEMTIME DaylightDate
Public DaylightDate As SYSTEMTIME
val mutable DaylightDate: SYSTEMTIME
var DaylightDate
public:
SYSTEMTIME DaylightDate

Field Value

Type: SYSTEMTIME
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION.DaylightName Field

Grid Solutions Framework TIME_ZONE_INFORMATIONDaylightName Field

[Missing <summary> documentation for "F:GSF.EMAX.TIME_ZONE_INFORMATION.DaylightName"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DaylightName
Public DaylightName As String
val mutable DaylightName: string
var DaylightName
public:
String^ DaylightName

Field Value

Type: String
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION.StandardBias Field

Grid Solutions Framework TIME_ZONE_INFORMATIONStandardBias Field

[Missing <summary> documentation for "F:GSF.EMAX.TIME_ZONE_INFORMATION.StandardBias"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int StandardBias
Public StandardBias As Integer
val mutable StandardBias: int
var StandardBias
public:
int StandardBias

Field Value

Type: Int32
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION.StandardDate Field

Grid Solutions Framework TIME_ZONE_INFORMATIONStandardDate Field

[Missing <summary> documentation for "F:GSF.EMAX.TIME_ZONE_INFORMATION.StandardDate"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SYSTEMTIME StandardDate
Public StandardDate As SYSTEMTIME
val mutable StandardDate: SYSTEMTIME
var StandardDate
public:
SYSTEMTIME StandardDate

Field Value

Type: SYSTEMTIME
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION.StandardName Field

Grid Solutions Framework TIME_ZONE_INFORMATIONStandardName Field

[Missing <summary> documentation for "F:GSF.EMAX.TIME_ZONE_INFORMATION.StandardName"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StandardName
Public StandardName As String
val mutable StandardName: string
var StandardName
public:
String^ StandardName

Field Value

Type: String
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TIME_ZONE_INFORMATION Methods

Grid Solutions Framework TIME_ZONE_INFORMATION Methods

The TIME_ZONE_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TIME_ZONE_INFORMATION Structure
GSF.EMAX Namespace


TPwrRcd Structure

Grid Solutions Framework TPwrRcd Structure

[Missing <summary> documentation for "T:GSF.EMAX.TPwrRcd"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct TPwrRcd
Public Structure TPwrRcd
[<SealedAttribute>]
type TPwrRcd =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class TPwrRcd

The TPwrRcd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | vaPwrRslt |
Public field | vNPwrTrigs |
Public field | vRcdSize |
Public field | vRevId |
Top
See Also

Reference

GSF.EMAX Namespace


TPwrRcd Fields

Grid Solutions Framework TPwrRcd Fields

The TPwrRcd type exposes the following members.

Fields
 | Name | Description
Public field | vaPwrRslt |
Public field | vNPwrTrigs |
Public field | vRcdSize |
Public field | vRevId |
Top
See Also

Reference

TPwrRcd Structure
GSF.EMAX Namespace


TPwrRcd.vaPwrRslt Field

Grid Solutions Framework TPwrRcdvaPwrRslt Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRcd.vaPwrRslt"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TPwrRslt[] vaPwrRslt
Public vaPwrRslt As TPwrRslt()
val mutable vaPwrRslt: TPwrRslt[]
var vaPwrRslt
public:
array<TPwrRslt>^ vaPwrRslt

Field Value

Type: TPwrRslt
See Also

Reference

TPwrRcd Structure
GSF.EMAX Namespace


TPwrRcd.vNPwrTrigs Field

Grid Solutions Framework TPwrRcdvNPwrTrigs Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRcd.vNPwrTrigs"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vNPwrTrigs
Public vNPwrTrigs As Short
val mutable vNPwrTrigs: int16
var vNPwrTrigs
public:
short vNPwrTrigs

Field Value

Type: Int16
See Also

Reference

TPwrRcd Structure
GSF.EMAX Namespace


TPwrRcd.vRcdSize Field

Grid Solutions Framework TPwrRcdvRcdSize Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRcd.vRcdSize"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vRcdSize
Public vRcdSize As Short
val mutable vRcdSize: int16
var vRcdSize
public:
short vRcdSize

Field Value

Type: Int16
See Also

Reference

TPwrRcd Structure
GSF.EMAX Namespace


TPwrRcd.vRevId Field

Grid Solutions Framework TPwrRcdvRevId Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRcd.vRevId"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort vRevId
Public vRevId As UShort
val mutable vRevId: uint16
var vRevId
public:
unsigned short vRevId

Field Value

Type: UInt16
See Also

Reference

TPwrRcd Structure
GSF.EMAX Namespace


TPwrRcd Methods

Grid Solutions Framework TPwrRcd Methods

The TPwrRcd type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TPwrRcd Structure
GSF.EMAX Namespace


TPwrRslt Structure

Grid Solutions Framework TPwrRslt Structure

[Missing <summary> documentation for "T:GSF.EMAX.TPwrRslt"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct TPwrRslt
Public Structure TPwrRslt
[<SealedAttribute>]
type TPwrRslt =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class TPwrRslt

The TPwrRslt type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | vBlkCnt |
Public field | vIsLim |
Public field | vLineGp |
Public field | vOfs |
Public field | vPwr |
Public field | vTrigFlg |
Top
See Also

Reference

GSF.EMAX Namespace


TPwrRslt Fields

Grid Solutions Framework TPwrRslt Fields

The TPwrRslt type exposes the following members.

Fields
 | Name | Description
Public field | vBlkCnt |
Public field | vIsLim |
Public field | vLineGp |
Public field | vOfs |
Public field | vPwr |
Public field | vTrigFlg |
Top
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


TPwrRslt.vBlkCnt Field

Grid Solutions Framework TPwrRsltvBlkCnt Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRslt.vBlkCnt"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vBlkCnt
Public vBlkCnt As Short
val mutable vBlkCnt: int16
var vBlkCnt
public:
short vBlkCnt

Field Value

Type: Int16
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


TPwrRslt.vIsLim Field

Grid Solutions Framework TPwrRsltvIsLim Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRslt.vIsLim"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vIsLim
Public vIsLim As Short
val mutable vIsLim: int16
var vIsLim
public:
short vIsLim

Field Value

Type: Int16
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


TPwrRslt.vLineGp Field

Grid Solutions Framework TPwrRsltvLineGp Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRslt.vLineGp"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vLineGp
Public vLineGp As Short
val mutable vLineGp: int16
var vLineGp
public:
short vLineGp

Field Value

Type: Int16
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


TPwrRslt.vOfs Field

Grid Solutions Framework TPwrRsltvOfs Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRslt.vOfs"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vOfs
Public vOfs As Short
val mutable vOfs: int16
var vOfs
public:
short vOfs

Field Value

Type: Int16
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


TPwrRslt.vPwr Field

Grid Solutions Framework TPwrRsltvPwr Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRslt.vPwr"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float vPwr
Public vPwr As Single
val mutable vPwr: float32
var vPwr
public:
float vPwr

Field Value

Type: Single
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


TPwrRslt.vTrigFlg Field

Grid Solutions Framework TPwrRsltvTrigFlg Field

[Missing <summary> documentation for "F:GSF.EMAX.TPwrRslt.vTrigFlg"]

Namespace: GSF.EMAX
Assembly: GSF.EMAX (in GSF.EMAX.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short vTrigFlg
Public vTrigFlg As Short
val mutable vTrigFlg: int16
var vTrigFlg
public:
short vTrigFlg

Field Value

Type: Int16
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


TPwrRslt Methods

Grid Solutions Framework TPwrRslt Methods

The TPwrRslt type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TPwrRslt Structure
GSF.EMAX Namespace


GSF.ErrorManagement Namespace

Grid Solutions Framework GSF.ErrorManagement Namespace
Contains classes used to simplify and standardize error management for applications.
Classes
Class | Description
ErrorLogger | Represents a logger that can be used for logging handled as well as unhandled exceptions across multiple application types (Console Application, Windows Service, Web Application, Web Service).
ErrorModule | Represents an HTTP module that can be used to handle exceptions globally in Web Sites and Web Services.
SmtpTraceListener | Represents an e-mail based TraceListener.


ErrorLogger Class

Grid Solutions Framework ErrorLogger Class
Represents a logger that can be used for logging handled as well as unhandled exceptions across multiple application types (Console Application, Windows Service, Web Application, Web Service).
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.ErrorManagementErrorLogger
GSF.Windows.ErrorManagementErrorLogger

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ErrorLogger))]
public class ErrorLogger : Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings
<ToolboxBitmapAttribute(GetType(ErrorLogger))>
Public Class ErrorLogger
    Inherits Component
    Implements ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings
[<ToolboxBitmapAttribute(typeof(ErrorLogger))>]
type ErrorLogger =
    class
        inherit Component
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.ErrorManagement.ErrorLogger = function();

Type.createClass(
    'GSF.ErrorManagement.ErrorLogger',
    Component,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(ErrorLogger))]
public ref class ErrorLogger : public Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings

The ErrorLogger type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorLogger | Initializes a new instance of the ErrorLogger class.
Public method | ErrorLogger(IContainer) | Initializes a new instance of the ErrorLogger class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ErrorLogger object properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ErrorLogger object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ErrorLogger object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExceptionToDatabase | Logs encountered Exception to the database.
Protected method | ExceptionToEmail | Logs encountered Exception to an e-mail message.
Protected method | ExceptionToEventLog | Logs encountered Exception to the EventLog.
Protected method | ExceptionToFile | Logs encountered Exception to the ErrorLog.
Protected method | ExceptionToUI | Logs encountered Exception to the application UI.
Protected method | ExceptionToWebPage | Shows Exception information in a Web Site.
Protected method | ExceptionToWindowsCui | Shows Exception information in a Console Application.
Protected method | ExceptionToWindowsGui | Shows Exception information in a Windows Application.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Protected method | GetEmailAttachments | Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message.
 | GetExceptionInfo | Gets information about an Exception complete with system and application information.
Protected method | GetExtendedMoreInfoText | Allows other loggers to extend "more info text".
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetMoreInfoText | Default Delegate for MoreInfoTextMethod.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ErrorLogger object.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ErrorLogger object from the config file if the PersistSettings property is set to true.
Public method | Log(Exception) | Logs information about the encountered Exception.
Public method | Log(Exception, Boolean) | Logs information about the encountered Exception.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnLoggingException | Raises the LoggingException event.
Protected method | Register | Registers the ErrorLogger object to handle unhandled Exception if the HandleUnhandledException property is set to true.
Public method | SaveSettings | Saves settings for the ErrorLogger object to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | Unregister | Unregister the ErrorLogger object from handling unhandled Exception.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultContactEmail | Specifies the default value for the ContactEmail property.
DefaultContactName | Specifies the default value for the ContactName property.
DefaultContactPhone | Specifies the default value for the ContactPhone property.
DefaultExitOnUnhandledException | Specifies the default value for the ExitOnUnhandledException property.
DefaultHandleUnhandledException | Specifies the default value for the HandleUnhandledException property.
DefaultLogToDatabase | Specifies the default value for the LogToDatabase property.
DefaultLogToEmail | Specifies the default value for the LogToEmail property.
DefaultLogToEventLog | Specifies the default value for the LogToEventLog property.
DefaultLogToFile | Specifies the default value for the LogToFile property.
DefaultLogToUI | Specifies the default value for the LogToUI property.
DefaultLogUserInfo | Specifies the default value for the LogUserInfo property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
DefaultSmtpServer | Specifies the default value for the SmtpServer property.
Top
Properties
 | Name | Description
 | ActionTextMethod | Gets or sets the Delegate that provides text stating the action(s) that can be taken by the end-user after an Exception is encountered.
Public property | ApplicationName | Gets the name of the currently executing application.
Public property | ApplicationType | Gets the type of the currently executing application.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ContactEmail | Gets or sets the e-mail address where e-mail messages containing Exception information are to be sent when the LogToEmail property is set to true.
Public property | ContactName | Gets or sets the name of the person who can be contacted by the end-user in case of an Exception.
Public property | ContactPhone | Gets or sets the phone number that can be used by the end-user to communicate about an encountered Exception.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DatabaseLogSize | Gets or sets the maximum exception log size to maintain when logging exceptions to the database.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ErrorLogger object is currently enabled.
Public property | ErrorLog | Get the LogFile object used for logging Exception information to a file.
 | ErrorTextMethod | Gets or sets the Delegate that provides common text stating what could have possibly caused the Exception.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExitOnUnhandledException | Gets or sets a boolean value that indicates whether the application will terminate after logging an unhandled Exception.
Public property | HandleUnhandledException | Gets or sets a boolean value that indicates whether the ErrorLogger object must register itself to handle Exception that are not trapped inside of a try-catch block.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LastException | Get the last encountered Exception.
Public property | Loggers | Gets a list of methods registered for logging information about an encountered Exception.
Public property | LogToDatabase | Gets or sets a boolean value that indicates whether Exception information is to be written to the database.
Public property | LogToEmail | Gets or sets a boolean value that indicates whether Exception information is to be sent in an e-mail to the ContactEmail address.
Public property | LogToEventLog | Gets or sets a boolean value that indicates whether Exception information is to be written to the EventLog.
Public property | LogToFile | Gets or sets a boolean value that indicates whether Exception information is to be written to the ErrorLog.
Public property | LogToUI | Gets or sets a boolean value that indicates whether Exception information is to be displayed on the application UI.
Public property | LogUserInfo | Gets or sets a boolean value that indicates whether information about local user (for windows applications) or remote user (for web applications) is to be logged when logging an Exception.
Public property | MoreInfoTextMethod | Gets or sets the Delegate that provides text containing detailed information about the encountered Exception.
Public property | Name | Gets the unique identifier of the ErrorLogger object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ErrorLogger object are to be saved to the config file.
 | ScopeTextMethod | Gets or sets the Delegate that provides text stating what is going to happen as a result of the Exception.
Public property | SettingsCategory | Gets or sets the category under which the settings of ErrorLogger object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmtpServer | Gets or sets the SMTP server to be used for sending e-mail messages containing Exception information to the ContactEmail address.
Public property | Status | Gets the descriptive status of the ErrorLogger object.
Public property | SuppressInteractiveLogging | Gets or sets flag that controls if Loggers requiring interaction either directly or indirectly when logging handled Exception using the Log(Exception) method are enabled.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | LoggingException | Occurs when an Exception is encountered while logging an Exception.
Top
Remarks

Adapted from exception handling code by Jeff Atwood of CodingHorror.com. Demo projects for handling unhandled exception in both windows and web environment by Jeff Atwood are available at The Code Project web site. See: http://www.codeproject.com/script/articles/list_articles.asp?userid=450027

Error logger with Windows Forms capabilities can be found in the GSF.Windows assembly.

Examples
This example shows how to use the ErrorLogger component to log handled and unhandled exceptions:
Copy
using System;
using System.IO;
using GSF.ErrorManagement;

class Program
{
    static ErrorLogger s_logger;

    static Program()
    {
        s_logger = new ErrorLogger();
        s_logger.LogToUI = true;                    // Show exception info on the UI.
        s_logger.LogToFile = true;                  // Log exception info to a file.
        s_logger.LogToEmail = true;                 // Send exception info in an e-mail.
        s_logger.LogToEventLog = true;              // Log exception info to the event log.
        s_logger.ContactEmail = "dev@email.com";    // Provide an e-mail address.
        s_logger.HandleUnhandledException = true;   // Configure to handle unhandled exceptions.
        s_logger.PersistSettings = true;            // Save settings to the config file.
        s_logger.Initialize();                      // Initialize ErrorLogger component for use.
    }

    static void Main(string[] args)
    {
        try
        {
            // This may cause a handled FileNotFoundException if the file doesn't exist.
            string data = File.ReadAllText(@"c:\NonExistentFile.txt");
        }
        catch (Exception ex)
        {
            // When logging handled exceptions we want to disable loggers (UI logger and E-mail logger) that
            // may require interaction either directly or indirectly as it can be annoying. All the loggers
            // are enabled automatically after the handled exception has been logged.
            s_logger.SuppressInteractiveLogging();
            s_logger.Log(ex);
        }

        int numerator = 1;
        int denominator = 0;
        int result = numerator / denominator;   // This will cause an unhandled DivideByZeroException.

        Console.ReadLine();
    }
}
See Also

Reference

GSF.ErrorManagement Namespace
GSF.ErrorManagementErrorModule


ErrorLogger Constructor

Grid Solutions Framework ErrorLogger Constructor
Overload List
 | Name | Description
Public method | ErrorLogger | Initializes a new instance of the ErrorLogger class.
Public method | ErrorLogger(IContainer) | Initializes a new instance of the ErrorLogger class.
Top
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger Constructor

Grid Solutions Framework ErrorLogger Constructor
Initializes a new instance of the ErrorLogger class.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorLogger()
Public Sub New
new : unit -> ErrorLogger
GSF.ErrorManagement.ErrorLogger = function();
public:
ErrorLogger()
See Also

Reference

ErrorLogger Class
ErrorLogger Overload
GSF.ErrorManagement Namespace


ErrorLogger Constructor (IContainer)

Grid Solutions Framework ErrorLogger Constructor (IContainer)
Initializes a new instance of the ErrorLogger class.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorLogger(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ErrorLogger
GSF.ErrorManagement.ErrorLogger = function(container);
public:
ErrorLogger(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the ErrorLogger.
See Also

Reference

ErrorLogger Class
ErrorLogger Overload
GSF.ErrorManagement Namespace


ErrorLogger Fields

Grid Solutions Framework ErrorLogger Fields

The ErrorLogger type exposes the following members.

Fields
Name | Description
DefaultContactEmail | Specifies the default value for the ContactEmail property.
DefaultContactName | Specifies the default value for the ContactName property.
DefaultContactPhone | Specifies the default value for the ContactPhone property.
DefaultExitOnUnhandledException | Specifies the default value for the ExitOnUnhandledException property.
DefaultHandleUnhandledException | Specifies the default value for the HandleUnhandledException property.
DefaultLogToDatabase | Specifies the default value for the LogToDatabase property.
DefaultLogToEmail | Specifies the default value for the LogToEmail property.
DefaultLogToEventLog | Specifies the default value for the LogToEventLog property.
DefaultLogToFile | Specifies the default value for the LogToFile property.
DefaultLogToUI | Specifies the default value for the LogToUI property.
DefaultLogUserInfo | Specifies the default value for the LogUserInfo property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
DefaultSmtpServer | Specifies the default value for the SmtpServer property.
Top
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultContactEmail Field

Grid Solutions Framework ErrorLoggerDefaultContactEmail Field
Specifies the default value for the ContactEmail property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultContactEmail
Public Const DefaultContactEmail As String
static val mutable DefaultContactEmail: string
var GSF.ErrorManagement.ErrorLogger.DefaultContactEmail
public:
literal String^ DefaultContactEmail

Field Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultContactName Field

Grid Solutions Framework ErrorLoggerDefaultContactName Field
Specifies the default value for the ContactName property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultContactName
Public Const DefaultContactName As String
static val mutable DefaultContactName: string
var GSF.ErrorManagement.ErrorLogger.DefaultContactName
public:
literal String^ DefaultContactName

Field Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultContactPhone Field

Grid Solutions Framework ErrorLoggerDefaultContactPhone Field
Specifies the default value for the ContactPhone property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultContactPhone
Public Const DefaultContactPhone As String
static val mutable DefaultContactPhone: string
var GSF.ErrorManagement.ErrorLogger.DefaultContactPhone
public:
literal String^ DefaultContactPhone

Field Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultExitOnUnhandledException Field

Grid Solutions Framework ErrorLoggerDefaultExitOnUnhandledException Field
Specifies the default value for the ExitOnUnhandledException property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultExitOnUnhandledException
Public Const DefaultExitOnUnhandledException As Boolean
static val mutable DefaultExitOnUnhandledException: bool
var GSF.ErrorManagement.ErrorLogger.DefaultExitOnUnhandledException
public:
literal bool DefaultExitOnUnhandledException

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultHandleUnhandledException Field

Grid Solutions Framework ErrorLoggerDefaultHandleUnhandledException Field
Specifies the default value for the HandleUnhandledException property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultHandleUnhandledException
Public Const DefaultHandleUnhandledException As Boolean
static val mutable DefaultHandleUnhandledException: bool
var GSF.ErrorManagement.ErrorLogger.DefaultHandleUnhandledException
public:
literal bool DefaultHandleUnhandledException

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultLogToDatabase Field

Grid Solutions Framework ErrorLoggerDefaultLogToDatabase Field
Specifies the default value for the LogToDatabase property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogToDatabase
Public Const DefaultLogToDatabase As Boolean
static val mutable DefaultLogToDatabase: bool
var GSF.ErrorManagement.ErrorLogger.DefaultLogToDatabase
public:
literal bool DefaultLogToDatabase

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultLogToEmail Field

Grid Solutions Framework ErrorLoggerDefaultLogToEmail Field
Specifies the default value for the LogToEmail property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogToEmail
Public Const DefaultLogToEmail As Boolean
static val mutable DefaultLogToEmail: bool
var GSF.ErrorManagement.ErrorLogger.DefaultLogToEmail
public:
literal bool DefaultLogToEmail

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultLogToEventLog Field

Grid Solutions Framework ErrorLoggerDefaultLogToEventLog Field
Specifies the default value for the LogToEventLog property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogToEventLog
Public Const DefaultLogToEventLog As Boolean
static val mutable DefaultLogToEventLog: bool
var GSF.ErrorManagement.ErrorLogger.DefaultLogToEventLog
public:
literal bool DefaultLogToEventLog

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultLogToFile Field

Grid Solutions Framework ErrorLoggerDefaultLogToFile Field
Specifies the default value for the LogToFile property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogToFile
Public Const DefaultLogToFile As Boolean
static val mutable DefaultLogToFile: bool
var GSF.ErrorManagement.ErrorLogger.DefaultLogToFile
public:
literal bool DefaultLogToFile

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultLogToUI Field

Grid Solutions Framework ErrorLoggerDefaultLogToUI Field
Specifies the default value for the LogToUI property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogToUI
Public Const DefaultLogToUI As Boolean
static val mutable DefaultLogToUI: bool
var GSF.ErrorManagement.ErrorLogger.DefaultLogToUI
public:
literal bool DefaultLogToUI

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultLogUserInfo Field

Grid Solutions Framework ErrorLoggerDefaultLogUserInfo Field
Specifies the default value for the LogUserInfo property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogUserInfo
Public Const DefaultLogUserInfo As Boolean
static val mutable DefaultLogUserInfo: bool
var GSF.ErrorManagement.ErrorLogger.DefaultLogUserInfo
public:
literal bool DefaultLogUserInfo

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultPersistSettings Field

Grid Solutions Framework ErrorLoggerDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.ErrorManagement.ErrorLogger.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultSettingsCategory Field

Grid Solutions Framework ErrorLoggerDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.ErrorManagement.ErrorLogger.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DefaultSmtpServer Field

Grid Solutions Framework ErrorLoggerDefaultSmtpServer Field
Specifies the default value for the SmtpServer property.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSmtpServer
Public Const DefaultSmtpServer As String
static val mutable DefaultSmtpServer: string
var GSF.ErrorManagement.ErrorLogger.DefaultSmtpServer
public:
literal String^ DefaultSmtpServer

Field Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger Methods

Grid Solutions Framework ErrorLogger Methods

The ErrorLogger type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ErrorLogger object properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ErrorLogger object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ErrorLogger object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExceptionToDatabase | Logs encountered Exception to the database.
Protected method | ExceptionToEmail | Logs encountered Exception to an e-mail message.
Protected method | ExceptionToEventLog | Logs encountered Exception to the EventLog.
Protected method | ExceptionToFile | Logs encountered Exception to the ErrorLog.
Protected method | ExceptionToUI | Logs encountered Exception to the application UI.
Protected method | ExceptionToWebPage | Shows Exception information in a Web Site.
Protected method | ExceptionToWindowsCui | Shows Exception information in a Console Application.
Protected method | ExceptionToWindowsGui | Shows Exception information in a Windows Application.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Protected method | GetEmailAttachments | Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message.
 | GetExceptionInfo | Gets information about an Exception complete with system and application information.
Protected method | GetExtendedMoreInfoText | Allows other loggers to extend "more info text".
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetMoreInfoText | Default Delegate for MoreInfoTextMethod.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ErrorLogger object.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ErrorLogger object from the config file if the PersistSettings property is set to true.
Public method | Log(Exception) | Logs information about the encountered Exception.
Public method | Log(Exception, Boolean) | Logs information about the encountered Exception.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnLoggingException | Raises the LoggingException event.
Protected method | Register | Registers the ErrorLogger object to handle unhandled Exception if the HandleUnhandledException property is set to true.
Public method | SaveSettings | Saves settings for the ErrorLogger object to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | Unregister | Unregister the ErrorLogger object from handling unhandled Exception.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.BeginInit Method

Grid Solutions Framework ErrorLoggerBeginInit Method
Performs necessary operations before the ErrorLogger object properties are initialized.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the ErrorLogger object is consumed through the designer surface of the IDE.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Dispose Method

Grid Solutions Framework ErrorLoggerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ErrorLogger object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Dispose Method (Boolean)

Grid Solutions Framework ErrorLoggerDispose Method (Boolean)
Releases the unmanaged resources used by the ErrorLogger object and optionally releases the managed resources.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ErrorLogger Class
Dispose Overload
GSF.ErrorManagement Namespace


ErrorLogger.EndInit Method

Grid Solutions Framework ErrorLoggerEndInit Method
Performs necessary operations after the ErrorLogger object properties are initialized.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the ErrorLogger object is consumed through the designer surface of the IDE.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToDatabase Method

Grid Solutions Framework ErrorLoggerExceptionToDatabase Method
Logs encountered Exception to the database.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToDatabase(
    Exception exception
)
Protected Overridable Sub ExceptionToDatabase (
    exception As Exception
)
abstract ExceptionToDatabase :
        exception : Exception -> unit
override ExceptionToDatabase :
        exception : Exception -> unit
function ExceptionToDatabase(exception);
protected:
virtual void ExceptionToDatabase(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception that was encountered.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToEmail Method

Grid Solutions Framework ErrorLoggerExceptionToEmail Method
Logs encountered Exception to an e-mail message.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToEmail(
    Exception exception
)
Protected Overridable Sub ExceptionToEmail (
    exception As Exception
)
abstract ExceptionToEmail :
        exception : Exception -> unit
override ExceptionToEmail :
        exception : Exception -> unit
function ExceptionToEmail(exception);
protected:
virtual void ExceptionToEmail(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception that was encountered.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToEventLog Method

Grid Solutions Framework ErrorLoggerExceptionToEventLog Method
Logs encountered Exception to the EventLog.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToEventLog(
    Exception exception
)
Protected Overridable Sub ExceptionToEventLog (
    exception As Exception
)
abstract ExceptionToEventLog :
        exception : Exception -> unit
override ExceptionToEventLog :
        exception : Exception -> unit
function ExceptionToEventLog(exception);
protected:
virtual void ExceptionToEventLog(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception that was encountered.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToFile Method

Grid Solutions Framework ErrorLoggerExceptionToFile Method
Logs encountered Exception to the ErrorLog.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToFile(
    Exception exception
)
Protected Overridable Sub ExceptionToFile (
    exception As Exception
)
abstract ExceptionToFile :
        exception : Exception -> unit
override ExceptionToFile :
        exception : Exception -> unit
function ExceptionToFile(exception);
protected:
virtual void ExceptionToFile(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception that was encountered.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToUI Method

Grid Solutions Framework ErrorLoggerExceptionToUI Method
Logs encountered Exception to the application UI.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToUI(
    Exception exception
)
Protected Overridable Sub ExceptionToUI (
    exception As Exception
)
abstract ExceptionToUI :
        exception : Exception -> unit
override ExceptionToUI :
        exception : Exception -> unit
function ExceptionToUI(exception);
protected:
virtual void ExceptionToUI(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception that was encountered.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToWebPage Method

Grid Solutions Framework ErrorLoggerExceptionToWebPage Method
Shows Exception information in a Web Site.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToWebPage()
Protected Overridable Sub ExceptionToWebPage
abstract ExceptionToWebPage : unit -> unit
override ExceptionToWebPage : unit -> unit
function ExceptionToWebPage();
protected:
virtual void ExceptionToWebPage()
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToWindowsCui Method

Grid Solutions Framework ErrorLoggerExceptionToWindowsCui Method
Shows Exception information in a Console Application.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToWindowsCui()
Protected Overridable Sub ExceptionToWindowsCui
abstract ExceptionToWindowsCui : unit -> unit
override ExceptionToWindowsCui : unit -> unit
function ExceptionToWindowsCui();
protected:
virtual void ExceptionToWindowsCui()
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExceptionToWindowsGui Method

Grid Solutions Framework ErrorLoggerExceptionToWindowsGui Method
Shows Exception information in a Windows Application.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToWindowsGui()
Protected Overridable Sub ExceptionToWindowsGui
abstract ExceptionToWindowsGui : unit -> unit
override ExceptionToWindowsGui : unit -> unit
function ExceptionToWindowsGui();
protected:
virtual void ExceptionToWindowsGui()
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.GetEmailAttachments Method

Grid Solutions Framework ErrorLoggerGetEmailAttachments Method
Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetEmailAttachments()
Protected Overridable Function GetEmailAttachments As String
abstract GetEmailAttachments : unit -> string
override GetEmailAttachments : unit -> string
function GetEmailAttachments();
protected:
virtual String^ GetEmailAttachments()

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.ErrorManagement.ErrorLogger.GetEmailAttachments"]

See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.GetExceptionInfo Method

Grid Solutions Framework ErrorLoggerGetExceptionInfo Method
Gets information about an Exception complete with system and application information.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetExceptionInfo(
    Exception ex,
    bool includeUserInfo
)
Public Shared Function GetExceptionInfo (
    ex As Exception,
    includeUserInfo As Boolean
) As String
static member GetExceptionInfo :
        ex : Exception *
        includeUserInfo : bool -> string

GSF.ErrorManagement.ErrorLogger.GetExceptionInfo = function(ex, includeUserInfo);
public:
static String^ GetExceptionInfo(
    Exception^ ex,
    bool includeUserInfo
)

Parameters

ex
Type: SystemException
Exception whose information is to be retrieved.
includeUserInfo
Type: SystemBoolean
true if user information is to be include; otherwise false.

Return Value

Type: String
Exception information in text.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.GetExtendedMoreInfoText Method

Grid Solutions Framework ErrorLoggerGetExtendedMoreInfoText Method
Allows other loggers to extend "more info text".

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetExtendedMoreInfoText(
    string bullet
)
Protected Overridable Function GetExtendedMoreInfoText (
    bullet As String
) As String
abstract GetExtendedMoreInfoText :
        bullet : string -> string
override GetExtendedMoreInfoText :
        bullet : string -> string
function GetExtendedMoreInfoText(bullet);
protected:
virtual String^ GetExtendedMoreInfoText(
    String^ bullet
)

Parameters

bullet
Type: SystemString
Type of bullet to use for extended info text.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.ErrorManagement.ErrorLogger.GetExtendedMoreInfoText(System.String)"]

See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.GetMoreInfoText Method

Grid Solutions Framework ErrorLoggerGetMoreInfoText Method
Default Delegate for MoreInfoTextMethod.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected string GetMoreInfoText()
Protected Function GetMoreInfoText As String
member GetMoreInfoText : unit -> string

function GetMoreInfoText();
protected:
String^ GetMoreInfoText()

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.ErrorManagement.ErrorLogger.GetMoreInfoText"]

See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Initialize Method

Grid Solutions Framework ErrorLoggerInitialize Method
Initializes the ErrorLogger object.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the ErrorLogger object is not consumed through the designer surface of the IDE.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LoadSettings Method

Grid Solutions Framework ErrorLoggerLoadSettings Method
Loads saved settings for the ErrorLogger object from the config file if the PersistSettings property is set to true.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void LoadSettings()
Public Overridable Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings()

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Log Method

Grid Solutions Framework ErrorLoggerLog Method
Overload List
 | Name | Description
Public method | Log(Exception) | Logs information about the encountered Exception.
Public method | Log(Exception, Boolean) | Logs information about the encountered Exception.
Top
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Log Method (Exception)

Grid Solutions Framework ErrorLoggerLog Method (Exception)
Logs information about the encountered Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Log(
    Exception exception
)
Public Sub Log (
    exception As Exception
)
member Log :
        exception : Exception -> unit

function Log(exception);
public:
void Log(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Encountered Exception whose information is to be logged.
See Also

Reference

ErrorLogger Class
Log Overload
GSF.ErrorManagement Namespace


ErrorLogger.Log Method (Exception, Boolean)

Grid Solutions Framework ErrorLoggerLog Method (Exception, Boolean)
Logs information about the encountered Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Log(
    Exception exception,
    bool exitApplication
)
Public Sub Log (
    exception As Exception,
    exitApplication As Boolean
)
member Log :
        exception : Exception *
        exitApplication : bool -> unit

function Log(exception, exitApplication);
public:
void Log(
    Exception^ exception,
    bool exitApplication
)

Parameters

exception
Type: SystemException
Encountered Exception whose information is to be logged.
exitApplication
Type: SystemBoolean
true to exit the application; otherwise false.
See Also

Reference

ErrorLogger Class
Log Overload
GSF.ErrorManagement Namespace


ErrorLogger.OnLoggingException Method

Grid Solutions Framework ErrorLoggerOnLoggingException Method
Raises the LoggingException event.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnLoggingException(
    Exception exception
)
Protected Overridable Sub OnLoggingException (
    exception As Exception
)
abstract OnLoggingException :
        exception : Exception -> unit
override OnLoggingException :
        exception : Exception -> unit
function OnLoggingException(exception);
protected:
virtual void OnLoggingException(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception to send to LoggingException event.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Register Method

Grid Solutions Framework ErrorLoggerRegister Method
Registers the ErrorLogger object to handle unhandled Exception if the HandleUnhandledException property is set to true.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool Register()
Protected Overridable Function Register As Boolean
abstract Register : unit -> bool
override Register : unit -> bool
function Register();
protected:
virtual bool Register()

Return Value

Type: Boolean
true if handlers were registered; otherwise false.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.SaveSettings Method

Grid Solutions Framework ErrorLoggerSaveSettings Method
Saves settings for the ErrorLogger object to the config file if the PersistSettings property is set to true.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SaveSettings()
Public Overridable Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings()

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Unregister Method

Grid Solutions Framework ErrorLoggerUnregister Method
Unregister the ErrorLogger object from handling unhandled Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool Unregister()
Protected Overridable Function Unregister As Boolean
abstract Unregister : unit -> bool
override Unregister : unit -> bool
function Unregister();
protected:
virtual bool Unregister()

Return Value

Type: Boolean
true if handlers were unregistered; otherwise false.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger Properties

Grid Solutions Framework ErrorLogger Properties

The ErrorLogger type exposes the following members.

Properties
 | Name | Description
 | ActionTextMethod | Gets or sets the Delegate that provides text stating the action(s) that can be taken by the end-user after an Exception is encountered.
Public property | ApplicationName | Gets the name of the currently executing application.
Public property | ApplicationType | Gets the type of the currently executing application.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ContactEmail | Gets or sets the e-mail address where e-mail messages containing Exception information are to be sent when the LogToEmail property is set to true.
Public property | ContactName | Gets or sets the name of the person who can be contacted by the end-user in case of an Exception.
Public property | ContactPhone | Gets or sets the phone number that can be used by the end-user to communicate about an encountered Exception.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DatabaseLogSize | Gets or sets the maximum exception log size to maintain when logging exceptions to the database.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ErrorLogger object is currently enabled.
Public property | ErrorLog | Get the LogFile object used for logging Exception information to a file.
 | ErrorTextMethod | Gets or sets the Delegate that provides common text stating what could have possibly caused the Exception.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExitOnUnhandledException | Gets or sets a boolean value that indicates whether the application will terminate after logging an unhandled Exception.
Public property | HandleUnhandledException | Gets or sets a boolean value that indicates whether the ErrorLogger object must register itself to handle Exception that are not trapped inside of a try-catch block.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LastException | Get the last encountered Exception.
Public property | Loggers | Gets a list of methods registered for logging information about an encountered Exception.
Public property | LogToDatabase | Gets or sets a boolean value that indicates whether Exception information is to be written to the database.
Public property | LogToEmail | Gets or sets a boolean value that indicates whether Exception information is to be sent in an e-mail to the ContactEmail address.
Public property | LogToEventLog | Gets or sets a boolean value that indicates whether Exception information is to be written to the EventLog.
Public property | LogToFile | Gets or sets a boolean value that indicates whether Exception information is to be written to the ErrorLog.
Public property | LogToUI | Gets or sets a boolean value that indicates whether Exception information is to be displayed on the application UI.
Public property | LogUserInfo | Gets or sets a boolean value that indicates whether information about local user (for windows applications) or remote user (for web applications) is to be logged when logging an Exception.
Public property | MoreInfoTextMethod | Gets or sets the Delegate that provides text containing detailed information about the encountered Exception.
Public property | Name | Gets the unique identifier of the ErrorLogger object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ErrorLogger object are to be saved to the config file.
 | ScopeTextMethod | Gets or sets the Delegate that provides text stating what is going to happen as a result of the Exception.
Public property | SettingsCategory | Gets or sets the category under which the settings of ErrorLogger object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmtpServer | Gets or sets the SMTP server to be used for sending e-mail messages containing Exception information to the ContactEmail address.
Public property | Status | Gets the descriptive status of the ErrorLogger object.
Public property | SuppressInteractiveLogging | Gets or sets flag that controls if Loggers requiring interaction either directly or indirectly when logging handled Exception using the Log(Exception) method are enabled.
Top
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ActionTextMethod Property

Grid Solutions Framework ErrorLoggerActionTextMethod Property
Gets or sets the Delegate that provides text stating the action(s) that can be taken by the end-user after an Exception is encountered.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Func<string> ActionTextMethod { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ActionTextMethod As Func(Of String)
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member ActionTextMethod : Func<string> with get, set

function get_ActionTextMethod();
function set_ActionTextMethod(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property Func<String^>^ ActionTextMethod {
    Func<String^>^ get ();
    void set (Func<String^>^ value);
}

Property Value

Type: Func String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
Examples
Sample text:

Close your browser, navigate back to the website, and try repeating you last action.

See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ApplicationName Property

Grid Solutions Framework ErrorLoggerApplicationName Property
Gets the name of the currently executing application.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string ApplicationName { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property ApplicationName As String
    Get
[<BrowsableAttribute(false)>]
member ApplicationName : string with get

function get_ApplicationName();

public:
[BrowsableAttribute(false)]
property String^ ApplicationName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ApplicationType Property

Grid Solutions Framework ErrorLoggerApplicationType Property
Gets the type of the currently executing application.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ApplicationType ApplicationType { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property ApplicationType As ApplicationType
    Get
[<BrowsableAttribute(false)>]
member ApplicationType : ApplicationType with get

function get_ApplicationType();

public:
[BrowsableAttribute(false)]
property ApplicationType ApplicationType {
    ApplicationType get ();
}

Property Value

Type: ApplicationType
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ContactEmail Property

Grid Solutions Framework ErrorLoggerContactEmail Property
Gets or sets the e-mail address where e-mail messages containing Exception information are to be sent when the LogToEmail property is set to true.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("")]
public string ContactEmail { get; set; }
<DefaultValueAttribute("")>
Public Property ContactEmail As String
    Get
    Set
[<DefaultValueAttribute("")>]
member ContactEmail : string with get, set

function get_ContactEmail();
function set_ContactEmail(value);
public:
[DefaultValueAttribute(L"")]
property String^ ContactEmail {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ContactName Property

Grid Solutions Framework ErrorLoggerContactName Property
Gets or sets the name of the person who can be contacted by the end-user in case of an Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("")]
public string ContactName { get; set; }
<DefaultValueAttribute("")>
Public Property ContactName As String
    Get
    Set
[<DefaultValueAttribute("")>]
member ContactName : string with get, set

function get_ContactName();
function set_ContactName(value);
public:
[DefaultValueAttribute(L"")]
property String^ ContactName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ContactPhone Property

Grid Solutions Framework ErrorLoggerContactPhone Property
Gets or sets the phone number that can be used by the end-user to communicate about an encountered Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("")]
public string ContactPhone { get; set; }
<DefaultValueAttribute("")>
Public Property ContactPhone As String
    Get
    Set
[<DefaultValueAttribute("")>]
member ContactPhone : string with get, set

function get_ContactPhone();
function set_ContactPhone(value);
public:
[DefaultValueAttribute(L"")]
property String^ ContactPhone {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.DatabaseLogSize Property

Grid Solutions Framework ErrorLoggerDatabaseLogSize Property
Gets or sets the maximum exception log size to maintain when logging exceptions to the database.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(2000)]
public int DatabaseLogSize { get; set; }
<DefaultValueAttribute(2000)>
Public Property DatabaseLogSize As Integer
    Get
    Set
[<DefaultValueAttribute(2000)>]
member DatabaseLogSize : int with get, set

function get_DatabaseLogSize();
function set_DatabaseLogSize(value);
public:
[DefaultValueAttribute(2000)]
property int DatabaseLogSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Enabled Property

Grid Solutions Framework ErrorLoggerEnabled Property
Gets or sets a boolean value that indicates whether the ErrorLogger object is currently enabled.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public bool Enabled { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<BrowsableAttribute(false)>
Public Property Enabled As Boolean
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
abstract Enabled : bool with get, set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[BrowsableAttribute(false)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Enabled property is not be set by user-code directly.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ErrorLog Property

Grid Solutions Framework ErrorLoggerErrorLog Property
Get the LogFile object used for logging Exception information to a file.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public LogFile ErrorLog { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property ErrorLog As LogFile
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>]
member ErrorLog : LogFile with get

function get_ErrorLog();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
property LogFile^ ErrorLog {
    LogFile^ get ();
}

Property Value

Type: LogFile
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ErrorTextMethod Property

Grid Solutions Framework ErrorLoggerErrorTextMethod Property
Gets or sets the Delegate that provides common text stating what could have possibly caused the Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public Func<string> ErrorTextMethod { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property ErrorTextMethod As Func(Of String)
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
member ErrorTextMethod : Func<string> with get, set

function get_ErrorTextMethod();
function set_ErrorTextMethod(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
property Func<String^>^ ErrorTextMethod {
    Func<String^>^ get ();
    void set (Func<String^>^ value);
}

Property Value

Type: Func String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
Examples
Sample text:

An unexpected exception has occurred in RogueApplication. This may be due to an inconsistent system state or a programming error.

See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ExitOnUnhandledException Property

Grid Solutions Framework ErrorLoggerExitOnUnhandledException Property
Gets or sets a boolean value that indicates whether the application will terminate after logging an unhandled Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool ExitOnUnhandledException { get; set; }
<DefaultValueAttribute(false)>
Public Property ExitOnUnhandledException As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member ExitOnUnhandledException : bool with get, set

function get_ExitOnUnhandledException();
function set_ExitOnUnhandledException(value);
public:
[DefaultValueAttribute(false)]
property bool ExitOnUnhandledException {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.HandleUnhandledException Property

Grid Solutions Framework ErrorLoggerHandleUnhandledException Property
Gets or sets a boolean value that indicates whether the ErrorLogger object must register itself to handle Exception that are not trapped inside of a try-catch block.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool HandleUnhandledException { get; set; }
<DefaultValueAttribute(true)>
Public Property HandleUnhandledException As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member HandleUnhandledException : bool with get, set

function get_HandleUnhandledException();
function set_HandleUnhandledException(value);
public:
[DefaultValueAttribute(true)]
property bool HandleUnhandledException {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.IsDisposed Property

Grid Solutions Framework ErrorLoggerIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public bool IsDisposed { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<BrowsableAttribute(false)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
abstract IsDisposed : bool with get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[BrowsableAttribute(false)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LastException Property

Grid Solutions Framework ErrorLoggerLastException Property
Get the last encountered Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Exception LastException { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property LastException As Exception
    Get
[<BrowsableAttribute(false)>]
member LastException : Exception with get

function get_LastException();

public:
[BrowsableAttribute(false)]
property Exception^ LastException {
    Exception^ get ();
}

Property Value

Type: Exception
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Loggers Property

Grid Solutions Framework ErrorLoggerLoggers Property
Gets a list of methods registered for logging information about an encountered Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public List<Action<Exception>> Loggers { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Loggers As List(Of Action(Of Exception))
    Get
[<BrowsableAttribute(false)>]
member Loggers : List<Action<Exception>> with get

function get_Loggers();

public:
[BrowsableAttribute(false)]
property List<Action<Exception^>^>^ Loggers {
    List<Action<Exception^>^>^ get ();
}

Property Value

Type: List Action Exception
Remarks
This property can be used to register additional methods for logging information about an encountered Exception. When an Exception is logged, all registered methods that take Exception as a parameter are invoked.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LogToDatabase Property

Grid Solutions Framework ErrorLoggerLogToDatabase Property
Gets or sets a boolean value that indicates whether Exception information is to be written to the database.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool LogToDatabase { get; set; }
<DefaultValueAttribute(false)>
Public Property LogToDatabase As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member LogToDatabase : bool with get, set

function get_LogToDatabase();
function set_LogToDatabase(value);
public:
[DefaultValueAttribute(false)]
property bool LogToDatabase {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LogToEmail Property

Grid Solutions Framework ErrorLoggerLogToEmail Property
Gets or sets a boolean value that indicates whether Exception information is to be sent in an e-mail to the ContactEmail address.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool LogToEmail { get; set; }
<DefaultValueAttribute(false)>
Public Property LogToEmail As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member LogToEmail : bool with get, set

function get_LogToEmail();
function set_LogToEmail(value);
public:
[DefaultValueAttribute(false)]
property bool LogToEmail {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LogToEventLog Property

Grid Solutions Framework ErrorLoggerLogToEventLog Property
Gets or sets a boolean value that indicates whether Exception information is to be written to the EventLog.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool LogToEventLog { get; set; }
<DefaultValueAttribute(true)>
Public Property LogToEventLog As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member LogToEventLog : bool with get, set

function get_LogToEventLog();
function set_LogToEventLog(value);
public:
[DefaultValueAttribute(true)]
property bool LogToEventLog {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LogToFile Property

Grid Solutions Framework ErrorLoggerLogToFile Property
Gets or sets a boolean value that indicates whether Exception information is to be written to the ErrorLog.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool LogToFile { get; set; }
<DefaultValueAttribute(true)>
Public Property LogToFile As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member LogToFile : bool with get, set

function get_LogToFile();
function set_LogToFile(value);
public:
[DefaultValueAttribute(true)]
property bool LogToFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LogToUI Property

Grid Solutions Framework ErrorLoggerLogToUI Property
Gets or sets a boolean value that indicates whether Exception information is to be displayed on the application UI.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool LogToUI { get; set; }
<DefaultValueAttribute(false)>
Public Property LogToUI As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member LogToUI : bool with get, set

function get_LogToUI();
function set_LogToUI(value);
public:
[DefaultValueAttribute(false)]
property bool LogToUI {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This setting is ignored in Windows Service and Web Service application types.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LogUserInfo Property

Grid Solutions Framework ErrorLoggerLogUserInfo Property
Gets or sets a boolean value that indicates whether information about local user (for windows applications) or remote user (for web applications) is to be logged when logging an Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool LogUserInfo { get; set; }
<DefaultValueAttribute(false)>
Public Property LogUserInfo As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member LogUserInfo : bool with get, set

function get_LogUserInfo();
function set_LogUserInfo(value);
public:
[DefaultValueAttribute(false)]
property bool LogUserInfo {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.MoreInfoTextMethod Property

Grid Solutions Framework ErrorLoggerMoreInfoTextMethod Property
Gets or sets the Delegate that provides text containing detailed information about the encountered Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Func<string> MoreInfoTextMethod { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property MoreInfoTextMethod As Func(Of String)
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member MoreInfoTextMethod : Func<string> with get, set

function get_MoreInfoTextMethod();
function set_MoreInfoTextMethod(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property Func<String^>^ MoreInfoTextMethod {
    Func<String^>^ get ();
    void set (Func<String^>^ value);
}

Property Value

Type: Func String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Name Property

Grid Solutions Framework ErrorLoggerName Property
Gets the unique identifier of the ErrorLogger object.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.PersistSettings Property

Grid Solutions Framework ErrorLoggerPersistSettings Property
Gets or sets a boolean value that indicates whether the settings of ErrorLogger object are to be saved to the config file.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.ScopeTextMethod Property

Grid Solutions Framework ErrorLoggerScopeTextMethod Property
Gets or sets the Delegate that provides text stating what is going to happen as a result of the Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public Func<string> ScopeTextMethod { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property ScopeTextMethod As Func(Of String)
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member ScopeTextMethod : Func<string> with get, set

function get_ScopeTextMethod();
function set_ScopeTextMethod(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property Func<String^>^ ScopeTextMethod {
    Func<String^>^ get ();
    void set (Func<String^>^ value);
}

Property Value

Type: Func String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
Examples
Sample text:

The action you requested was not performed.

See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.SettingsCategory Property

Grid Solutions Framework ErrorLoggerSettingsCategory Property
Gets or sets the category under which the settings of ErrorLogger object are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("ErrorLogger")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("ErrorLogger")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("ErrorLogger")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("ErrorLogger")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"ErrorLogger")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.SmtpServer Property

Grid Solutions Framework ErrorLoggerSmtpServer Property
Gets or sets the SMTP server to be used for sending e-mail messages containing Exception information to the ContactEmail address.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("localhost")]
public string SmtpServer { get; set; }
<DefaultValueAttribute("localhost")>
Public Property SmtpServer As String
    Get
    Set
[<DefaultValueAttribute("localhost")>]
member SmtpServer : string with get, set

function get_SmtpServer();
function set_SmtpServer(value);
public:
[DefaultValueAttribute(L"localhost")]
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.Status Property

Grid Solutions Framework ErrorLoggerStatus Property
Gets the descriptive status of the ErrorLogger object.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual string Status { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.SuppressInteractiveLogging Property

Grid Solutions Framework ErrorLoggerSuppressInteractiveLogging Property
Gets or sets flag that controls if Loggers requiring interaction either directly or indirectly when logging handled Exception using the Log(Exception) method are enabled.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SuppressInteractiveLogging { get; protected set; }
Public Property SuppressInteractiveLogging As Boolean
    Get
    Protected Set
member SuppressInteractiveLogging : bool with get, set

function get_SuppressInteractiveLogging();
function set_SuppressInteractiveLogging(value);
public:
property bool SuppressInteractiveLogging {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger Events

Grid Solutions Framework ErrorLogger Events

The ErrorLogger type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | LoggingException | Occurs when an Exception is encountered while logging an Exception.
Top
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorLogger.LoggingException Event

Grid Solutions Framework ErrorLoggerLoggingException Event
Occurs when an Exception is encountered while logging an Exception.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> LoggingException
Public Event LoggingException As EventHandler(Of EventArgs(Of Exception))
member LoggingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_LoggingException(value);
function remove_LoggingException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ LoggingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception that was encountered while logging an Exception.
See Also

Reference

ErrorLogger Class
GSF.ErrorManagement Namespace


ErrorModule Class

Grid Solutions Framework ErrorModule Class
Represents an HTTP module that can be used to handle exceptions globally in Web Sites and Web Services.
Inheritance Hierarchy
SystemObject
GSF.ErrorManagementErrorModule

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ErrorModule : IHttpModule
Public Class ErrorModule
    Implements IHttpModule
type ErrorModule =
    class
        interface IHttpModule
    end
GSF.ErrorManagement.ErrorModule = function();

Type.createClass(
    'GSF.ErrorManagement.ErrorModule',
    null,
    IHttpModule);
public ref class ErrorModule : IHttpModule

The ErrorModule type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorModule | Initializes a new instance of the ErrorModule class
Top
Methods
 | Name | Description
Public method | Dispose | Disposes the resources (other than memory) used by the ErrorModule.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes the ErrorModule and prepares it to handle requests.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
Name | Description
Logger | Gets the ErrorLogger object used by the ErrorModule object for logging exceptions.
Top
Examples
Below is the config file entry required for enabling error handling using ErrorModule:
Copy
<configuration>
  <system.web>
    <httpModules>
      <add name="ErrorModule" type="GSF.ErrorManagement.ErrorModule, GSF.Core" />
    </httpModules>
  </system.web>
</configuration>
Below is the config file entry required for changing the settings of Logger:
Copy
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <errorLogger>
      <add name="LogToUI" value="False" description="True if an encountered exception is to be logged to the User Interface; otherwise False."
        encrypted="false" />
      <add name="LogToFile" value="True" description="True if an encountered exception is to be logged to a file; otherwise False."
        encrypted="false" />
      <add name="LogToEmail" value="False" description="True if an email is to be sent to ContactEmail with the details of an encountered exception; otherwise False."
        encrypted="false" />
      <add name="LogToEventLog" value="True" description="True if an encountered exception is to be logged to the Event Log; otherwise False."
        encrypted="false" />
      <add name="LogToScreenshot" value="False" description="True if a screenshot is to be taken when an exception is encountered; otherwise False."
        encrypted="false" />
      <add name="SmtpServer" value="smtp.email.com" description="Name of the SMTP server to be used for sending the email messages."
        encrypted="false" />
      <add name="ContactEmail" value="" description="Comma-seperated list of recipient email addresses for the email message."
        encrypted="false" />
      <add name="ContactName" value="" description="Name of the person that the end-user can contact when an exception is encountered."
        encrypted="false" />
      <add name="ContactPhone" value="" description="Phone number of the person that the end-user can contact when an exception is encountered."
        encrypted="false" />
      <add name="HandleUnhandledException" value="True" description="True if unhandled exceptions are to be handled automatically; otherwise False."
        encrypted="false" />
      <add name="ExitOnUnhandledException" value="False" description="True if the application must exit when an unhandled exception is encountered; otherwise False."
        encrypted="false" />
    </errorLogger>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.ErrorManagement Namespace
GSF.ErrorManagementErrorLogger


ErrorModule Constructor

Grid Solutions Framework ErrorModule Constructor
Initializes a new instance of the ErrorModule class

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorModule()
Public Sub New
new : unit -> ErrorModule
GSF.ErrorManagement.ErrorModule = function();
public:
ErrorModule()
See Also

Reference

ErrorModule Class
GSF.ErrorManagement Namespace


ErrorModule Methods

Grid Solutions Framework ErrorModule Methods

The ErrorModule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Disposes the resources (other than memory) used by the ErrorModule.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes the ErrorModule and prepares it to handle requests.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ErrorModule Class
GSF.ErrorManagement Namespace


ErrorModule.Dispose Method

Grid Solutions Framework ErrorModuleDispose Method
Disposes the resources (other than memory) used by the ErrorModule.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IHttpModuleDispose
See Also

Reference

ErrorModule Class
GSF.ErrorManagement Namespace


ErrorModule.Init Method

Grid Solutions Framework ErrorModuleInit Method
Initializes the ErrorModule and prepares it to handle requests.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Init(
    HttpApplication context
)
Public Sub Init (
    context As HttpApplication
)
abstract Init :
        context : HttpApplication -> unit
override Init :
        context : HttpApplication -> unit
function Init(context);
public:
virtual void Init(
    HttpApplication^ context
) sealed

Parameters

context
Type: System.WebHttpApplication
The HttpApplication to use for initialization.

Implements

IHttpModuleInit(HttpApplication)
See Also

Reference

ErrorModule Class
GSF.ErrorManagement Namespace


ErrorModule Properties

Grid Solutions Framework ErrorModule Properties

The ErrorModule type exposes the following members.

Properties
Name | Description
Logger | Gets the ErrorLogger object used by the ErrorModule object for logging exceptions.
Top
See Also

Reference

ErrorModule Class
GSF.ErrorManagement Namespace


ErrorModule.Logger Property

Grid Solutions Framework ErrorModuleLogger Property
Gets the ErrorLogger object used by the ErrorModule object for logging exceptions.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ErrorLogger Logger { get; }
Public Shared ReadOnly Property Logger As ErrorLogger
    Get
static member Logger : ErrorLogger with get

GSF.ErrorManagement.ErrorModule.get_Logger = function();

public:
static property ErrorLogger^ Logger {
    ErrorLogger^ get ();
}

Property Value

Type: ErrorLogger
Remarks
Logger property can be used for logging handled exception throughout the web application.
Examples
This example shows the use of Logger for logging handled exception:
Copy
using System;
using GSF.ErrorManagement;

namespace WebApp
{
    public partial class _Default : System.Web.UI.Page
    {
        protected void Page_Load(object sender, EventArgs e)
        {
            try
            {
                string s = null;
                s.ToCharArray();            // This will result in NullReferenceException.
            }
            catch (Exception ex)
            {
                ErrorModule.Logger.Log(ex); // Log the encountered exception.
            }
        }
    }
}
See Also

Reference

ErrorModule Class
GSF.ErrorManagement Namespace


SmtpTraceListener Class

Grid Solutions Framework SmtpTraceListener Class
Represents an e-mail based TraceListener.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.DiagnosticsTraceListener
GSF.ErrorManagementSmtpTraceListener

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SmtpTraceListener : TraceListener
Public Class SmtpTraceListener
    Inherits TraceListener
type SmtpTraceListener =
    class
        inherit TraceListener
    end
GSF.ErrorManagement.SmtpTraceListener = function();

Type.createClass(
    'GSF.ErrorManagement.SmtpTraceListener',
    TraceListener);
public ref class SmtpTraceListener : public TraceListener

The SmtpTraceListener type exposes the following members.

Constructors
 | Name | Description
Public method | SmtpTraceListener | Initializes a new instance of the SmtpTraceListener class.
Public method | SmtpTraceListener(String) | Initializes a new instance of the SmtpTraceListener class.
Top
Methods
 | Name | Description
Public method | Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (Inherited from TraceListener.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TraceListener. (Inherited from TraceListener.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TraceListener and optionally releases the managed resources. (Inherited from TraceListener.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Fail(String) | Emits an error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Fail(String, String) | Emits an error message and a detailed error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, flushes the output buffer. (Inherited from TraceListener.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (Inherited from TraceListener.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, a data object and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, an array of data objects and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | Writes trace information, a message, and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object) | Writes trace information, a formatted array of objects and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (Inherited from TraceListener.)
Public method | Write(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(String) | Sends an e-mail message containing the specified message. (Overrides TraceListenerWrite(String).)
Public method | Write(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Protected method | WriteIndent | Writes the indent to the listener you create when you implement this class, and resets the NeedIndent property to false. (Inherited from TraceListener.)
Public method | WriteLine(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(String) | Sends an e-mail message containing the specified message. (Overrides TraceListenerWriteLine(String).)
Public method | WriteLine(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets the custom trace listener attributes defined in the application configuration file. (Inherited from TraceListener.)
Public property | Filter | Gets and sets the trace filter for the trace listener. (Inherited from TraceListener.)
Public property | IndentLevel | Gets or sets the indent level. (Inherited from TraceListener.)
Public property | IndentSize | Gets or sets the number of spaces in an indent. (Inherited from TraceListener.)
Public property | IsThreadSafe | Gets a value indicating whether the trace listener is thread safe. (Inherited from TraceListener.)
Public property | Name | Gets or sets a name for this TraceListener. (Inherited from TraceListener.)
Protected property | NeedIndent | Gets or sets a value indicating whether to indent the output. (Inherited from TraceListener.)
Public property | TraceOutputOptions | Gets or sets the trace output options. (Inherited from TraceListener.)
Top
Examples
Below is the config file entry required for enabling e-mail based tracing using SmtpTraceListener:
Copy
<configuration>
  <system.diagnostics>
    <trace>
      <listeners>
        <add name="SmtpTraceListener" type="GSF.ErrorManagement.SmtpTraceListener,GSF.Core" initializeData="sender@email.com,recipient@email.com,smtp.email.com"/>
      </listeners>
    </trace>
  </system.diagnostics>
</configuration>
See Also

Reference

GSF.ErrorManagement Namespace


SmtpTraceListener Constructor

Grid Solutions Framework SmtpTraceListener Constructor
Overload List
 | Name | Description
Public method | SmtpTraceListener | Initializes a new instance of the SmtpTraceListener class.
Public method | SmtpTraceListener(String) | Initializes a new instance of the SmtpTraceListener class.
Top
See Also

Reference

SmtpTraceListener Class
GSF.ErrorManagement Namespace


SmtpTraceListener Constructor

Grid Solutions Framework SmtpTraceListener Constructor
Initializes a new instance of the SmtpTraceListener class.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SmtpTraceListener()
Public Sub New
new : unit -> SmtpTraceListener
GSF.ErrorManagement.SmtpTraceListener = function();
public:
SmtpTraceListener()
See Also

Reference

SmtpTraceListener Class
SmtpTraceListener Overload
GSF.ErrorManagement Namespace


SmtpTraceListener Constructor (String)

Grid Solutions Framework SmtpTraceListener Constructor (String)
Initializes a new instance of the SmtpTraceListener class.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SmtpTraceListener(
    string initializationData
)
Public Sub New (
    initializationData As String
)
new :
        initializationData : string -> SmtpTraceListener
GSF.ErrorManagement.SmtpTraceListener = function(initializationData);
public:
SmtpTraceListener(
    String^ initializationData
)

Parameters

initializationData
Type: SystemString
Initialization text in the format of "sender@email.com,recipient@email.com,smtp.email.com".
See Also

Reference

SmtpTraceListener Class
SmtpTraceListener Overload
GSF.ErrorManagement Namespace


SmtpTraceListener Methods

Grid Solutions Framework SmtpTraceListener Methods

The SmtpTraceListener type exposes the following members.

Methods
 | Name | Description
Public method | Close | When overridden in a derived class, closes the output stream so it no longer receives tracing or debugging output. (Inherited from TraceListener.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the TraceListener. (Inherited from TraceListener.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the TraceListener and optionally releases the managed resources. (Inherited from TraceListener.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Fail(String) | Emits an error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Fail(String, String) | Emits an error message and a detailed error message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, flushes the output buffer. (Inherited from TraceListener.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetSupportedAttributes | Gets the custom attributes supported by the trace listener. (Inherited from TraceListener.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, a data object and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceData(TraceEventCache, String, TraceEventType, Int32, Object) | Writes trace information, an array of data objects and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32) | Writes trace and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String) | Writes trace information, a message, and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceEvent(TraceEventCache, String, TraceEventType, Int32, String, Object) | Writes trace information, a formatted array of objects and event information to the listener specific output. (Inherited from TraceListener.)
Public method | TraceTransfer | Writes trace information, a message, a related activity identity and event information to the listener specific output. (Inherited from TraceListener.)
Public method | Write(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(String) | Sends an e-mail message containing the specified message. (Overrides TraceListenerWrite(String).)
Public method | Write(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Protected method | WriteIndent | Writes the indent to the listener you create when you implement this class, and resets the NeedIndent property to false. (Inherited from TraceListener.)
Public method | WriteLine(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(String) | Sends an e-mail message containing the specified message. (Overrides TraceListenerWriteLine(String).)
Public method | WriteLine(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SmtpTraceListener Class
GSF.ErrorManagement Namespace


SmtpTraceListener.Write Method

Grid Solutions Framework SmtpTraceListenerWrite Method
Overload List
 | Name | Description
Public method | Write(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(String) | Sends an e-mail message containing the specified message. (Overrides TraceListenerWrite(String).)
Public method | Write(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Public method | Write(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class. (Inherited from TraceListener.)
Top
See Also

Reference

SmtpTraceListener Class
GSF.ErrorManagement Namespace


SmtpTraceListener.Write Method (String)

Grid Solutions Framework SmtpTraceListenerWrite Method (String)
Sends an e-mail message containing the specified message.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    string message
)
Public Overrides Sub Write (
    message As String
)
abstract Write :
        message : string -> unit
override Write :
        message : string -> unit
function Write(message);
public:
virtual void Write(
    String^ message
) override

Parameters

message
Type: SystemString
The message to be sent in the e-mail message.
See Also

Reference

SmtpTraceListener Class
Write Overload
GSF.ErrorManagement Namespace


SmtpTraceListener.WriteLine Method

Grid Solutions Framework SmtpTraceListenerWriteLine Method
Overload List
 | Name | Description
Public method | WriteLine(Object) | Writes the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(String) | Sends an e-mail message containing the specified message. (Overrides TraceListenerWriteLine(String).)
Public method | WriteLine(String, String) | Writes a category name and a message to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Public method | WriteLine(Object, String) | Writes a category name and the value of the object's ToString method to the listener you create when you implement the TraceListener class, followed by a line terminator. (Inherited from TraceListener.)
Top
See Also

Reference

SmtpTraceListener Class
GSF.ErrorManagement Namespace


SmtpTraceListener.WriteLine Method (String)

Grid Solutions Framework SmtpTraceListenerWriteLine Method (String)
Sends an e-mail message containing the specified message.

Namespace: GSF.ErrorManagement
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void WriteLine(
    string message
)
Public Overrides Sub WriteLine (
    message As String
)
abstract WriteLine :
        message : string -> unit
override WriteLine :
        message : string -> unit
function WriteLine(message);
public:
virtual void WriteLine(
    String^ message
) override

Parameters

message
Type: SystemString
The message to be sent in the e-mail message.
See Also

Reference

SmtpTraceListener Class
WriteLine Overload
GSF.ErrorManagement Namespace


SmtpTraceListener Properties

Grid Solutions Framework SmtpTraceListener Properties

The SmtpTraceListener type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets the custom trace listener attributes defined in the application configuration file. (Inherited from TraceListener.)
Public property | Filter | Gets and sets the trace filter for the trace listener. (Inherited from TraceListener.)
Public property | IndentLevel | Gets or sets the indent level. (Inherited from TraceListener.)
Public property | IndentSize | Gets or sets the number of spaces in an indent. (Inherited from TraceListener.)
Public property | IsThreadSafe | Gets a value indicating whether the trace listener is thread safe. (Inherited from TraceListener.)
Public property | Name | Gets or sets a name for this TraceListener. (Inherited from TraceListener.)
Protected property | NeedIndent | Gets or sets a value indicating whether to indent the output. (Inherited from TraceListener.)
Public property | TraceOutputOptions | Gets or sets the trace output options. (Inherited from TraceListener.)
Top
See Also

Reference

SmtpTraceListener Class
GSF.ErrorManagement Namespace


GSF.FuzzyStrings Namespace

Grid Solutions Framework GSF.FuzzyStrings Namespace

[Missing <summary> documentation for "N:GSF.FuzzyStrings"]

Classes
 | Class | Description
Public class | ComparisonMetrics |
Public class | Operations |
Enumerations
 | Enumeration | Description
Public enumeration | FuzzyStringComparisonOptions |
Public enumeration | FuzzyStringComparisonTolerance | Fuzzy string comparison tolerances.


ComparisonMetrics Class

Grid Solutions Framework ComparisonMetrics Class

[Missing <summary> documentation for "T:GSF.FuzzyStrings.ComparisonMetrics"]

Inheritance Hierarchy
SystemObject
GSF.FuzzyStringsComparisonMetrics

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ComparisonMetrics
<ExtensionAttribute>
Public NotInheritable Class ComparisonMetrics
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ComparisonMetrics =  class end
GSF.FuzzyStrings.ComparisonMetrics = function();

Type.createClass(
    'GSF.FuzzyStrings.ComparisonMetrics');
[ExtensionAttribute]
public ref class ComparisonMetrics abstract sealed

The ComparisonMetrics type exposes the following members.

Methods
Name | Description
ApproximatelyEquals |
HammingDistance |
JaccardDistance |
JaccardIndex |
JaroDistance |
JaroWinklerDistance |
JaroWinklerDistanceWithPrefixScale |
LevenshteinDistance |
LevenshteinDistanceLowerBounds |
LevenshteinDistanceUpperBounds |
LongestCommonSubsequence |
LongestCommonSubstring |
NormalizedLevenshteinDistance |
OverlapCoefficient |
RatcliffObershelpSimilarity |
SorensenDiceDistance |
SorensenDiceIndex |
TanimotoCoefficient |
Top
See Also

Reference

GSF.FuzzyStrings Namespace


ComparisonMetrics Methods

Grid Solutions Framework ComparisonMetrics Methods

The ComparisonMetrics type exposes the following members.

Methods
Name | Description
ApproximatelyEquals |
HammingDistance |
JaccardDistance |
JaccardIndex |
JaroDistance |
JaroWinklerDistance |
JaroWinklerDistanceWithPrefixScale |
LevenshteinDistance |
LevenshteinDistanceLowerBounds |
LevenshteinDistanceUpperBounds |
LongestCommonSubsequence |
LongestCommonSubstring |
NormalizedLevenshteinDistance |
OverlapCoefficient |
RatcliffObershelpSimilarity |
SorensenDiceDistance |
SorensenDiceIndex |
TanimotoCoefficient |
Top
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.ApproximatelyEquals Method

Grid Solutions Framework ComparisonMetricsApproximatelyEquals Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.ApproximatelyEquals(System.String,System.String,GSF.FuzzyStrings.FuzzyStringComparisonOptions,GSF.FuzzyStrings.FuzzyStringComparisonTolerance)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ApproximatelyEquals(
    this string source,
    string target,
    FuzzyStringComparisonOptions options,
    FuzzyStringComparisonTolerance tolerance
)
<ExtensionAttribute>
Public Shared Function ApproximatelyEquals (
    source As String,
    target As String,
    options As FuzzyStringComparisonOptions,
    tolerance As FuzzyStringComparisonTolerance
) As Boolean
static member ApproximatelyEquals :
        source : string *
        target : string *
        options : FuzzyStringComparisonOptions *
        tolerance : FuzzyStringComparisonTolerance -> bool

GSF.FuzzyStrings.ComparisonMetrics.ApproximatelyEquals = function(source, target, options, tolerance);
public:
[ExtensionAttribute]
static bool ApproximatelyEquals(
    String^ source,
    String^ target,
    FuzzyStringComparisonOptions options,
    FuzzyStringComparisonTolerance tolerance
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.ApproximatelyEquals(System.String,System.String,GSF.FuzzyStrings.FuzzyStringComparisonOptions,GSF.FuzzyStrings.FuzzyStringComparisonTolerance)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.ApproximatelyEquals(System.String,System.String,GSF.FuzzyStrings.FuzzyStringComparisonOptions,GSF.FuzzyStrings.FuzzyStringComparisonTolerance)"]

options
Type: GSF.FuzzyStringsFuzzyStringComparisonOptions

[Missing <param name="options"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.ApproximatelyEquals(System.String,System.String,GSF.FuzzyStrings.FuzzyStringComparisonOptions,GSF.FuzzyStrings.FuzzyStringComparisonTolerance)"]

tolerance
Type: GSF.FuzzyStringsFuzzyStringComparisonTolerance

[Missing <param name="tolerance"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.ApproximatelyEquals(System.String,System.String,GSF.FuzzyStrings.FuzzyStringComparisonOptions,GSF.FuzzyStrings.FuzzyStringComparisonTolerance)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.ApproximatelyEquals(System.String,System.String,GSF.FuzzyStrings.FuzzyStringComparisonOptions,GSF.FuzzyStrings.FuzzyStringComparisonTolerance)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.HammingDistance Method

Grid Solutions Framework ComparisonMetricsHammingDistance Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.HammingDistance(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int HammingDistance(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function HammingDistance (
    source As String,
    target As String
) As Integer
static member HammingDistance :
        source : string *
        target : string -> int

GSF.FuzzyStrings.ComparisonMetrics.HammingDistance = function(source, target);
public:
[ExtensionAttribute]
static int HammingDistance(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.HammingDistance(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.HammingDistance(System.String,System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.HammingDistance(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.JaccardDistance Method

Grid Solutions Framework ComparisonMetricsJaccardDistance Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardDistance(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double JaccardDistance(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function JaccardDistance (
    source As String,
    target As String
) As Double
static member JaccardDistance :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.JaccardDistance = function(source, target);
public:
[ExtensionAttribute]
static double JaccardDistance(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardDistance(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardDistance(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardDistance(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.JaccardIndex Method

Grid Solutions Framework ComparisonMetricsJaccardIndex Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardIndex(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double JaccardIndex(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function JaccardIndex (
    source As String,
    target As String
) As Double
static member JaccardIndex :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.JaccardIndex = function(source, target);
public:
[ExtensionAttribute]
static double JaccardIndex(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardIndex(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardIndex(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaccardIndex(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.JaroDistance Method

Grid Solutions Framework ComparisonMetricsJaroDistance Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroDistance(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double JaroDistance(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function JaroDistance (
    source As String,
    target As String
) As Double
static member JaroDistance :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.JaroDistance = function(source, target);
public:
[ExtensionAttribute]
static double JaroDistance(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroDistance(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroDistance(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroDistance(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.JaroWinklerDistance Method

Grid Solutions Framework ComparisonMetricsJaroWinklerDistance Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistance(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double JaroWinklerDistance(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function JaroWinklerDistance (
    source As String,
    target As String
) As Double
static member JaroWinklerDistance :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistance = function(source, target);
public:
[ExtensionAttribute]
static double JaroWinklerDistance(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistance(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistance(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistance(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.JaroWinklerDistanceWithPrefixScale Method

Grid Solutions Framework ComparisonMetricsJaroWinklerDistanceWithPrefixScale Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistanceWithPrefixScale(System.String,System.String,System.Double)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double JaroWinklerDistanceWithPrefixScale(
    string source,
    string target,
    double p
)
Public Shared Function JaroWinklerDistanceWithPrefixScale (
    source As String,
    target As String,
    p As Double
) As Double
static member JaroWinklerDistanceWithPrefixScale :
        source : string *
        target : string *
        p : float -> float

GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistanceWithPrefixScale = function(source, target, p);
public:
static double JaroWinklerDistanceWithPrefixScale(
    String^ source,
    String^ target,
    double p
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistanceWithPrefixScale(System.String,System.String,System.Double)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistanceWithPrefixScale(System.String,System.String,System.Double)"]

p
Type: SystemDouble

[Missing <param name="p"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistanceWithPrefixScale(System.String,System.String,System.Double)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.JaroWinklerDistanceWithPrefixScale(System.String,System.String,System.Double)"]

See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.LevenshteinDistance Method

Grid Solutions Framework ComparisonMetricsLevenshteinDistance Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistance(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int LevenshteinDistance(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function LevenshteinDistance (
    source As String,
    target As String
) As Integer
static member LevenshteinDistance :
        source : string *
        target : string -> int

GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistance = function(source, target);
public:
[ExtensionAttribute]
static int LevenshteinDistance(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistance(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistance(System.String,System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistance(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.LevenshteinDistanceLowerBounds Method

Grid Solutions Framework ComparisonMetricsLevenshteinDistanceLowerBounds Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceLowerBounds(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int LevenshteinDistanceLowerBounds(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function LevenshteinDistanceLowerBounds (
    source As String,
    target As String
) As Integer
static member LevenshteinDistanceLowerBounds :
        source : string *
        target : string -> int

GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceLowerBounds = function(source, target);
public:
[ExtensionAttribute]
static int LevenshteinDistanceLowerBounds(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceLowerBounds(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceLowerBounds(System.String,System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceLowerBounds(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.LevenshteinDistanceUpperBounds Method

Grid Solutions Framework ComparisonMetricsLevenshteinDistanceUpperBounds Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceUpperBounds(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int LevenshteinDistanceUpperBounds(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function LevenshteinDistanceUpperBounds (
    source As String,
    target As String
) As Integer
static member LevenshteinDistanceUpperBounds :
        source : string *
        target : string -> int

GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceUpperBounds = function(source, target);
public:
[ExtensionAttribute]
static int LevenshteinDistanceUpperBounds(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceUpperBounds(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceUpperBounds(System.String,System.String)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LevenshteinDistanceUpperBounds(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.LongestCommonSubsequence Method

Grid Solutions Framework ComparisonMetricsLongestCommonSubsequence Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubsequence(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string LongestCommonSubsequence(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function LongestCommonSubsequence (
    source As String,
    target As String
) As String
static member LongestCommonSubsequence :
        source : string *
        target : string -> string

GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubsequence = function(source, target);
public:
[ExtensionAttribute]
static String^ LongestCommonSubsequence(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubsequence(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubsequence(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubsequence(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.LongestCommonSubstring Method

Grid Solutions Framework ComparisonMetricsLongestCommonSubstring Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubstring(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string LongestCommonSubstring(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function LongestCommonSubstring (
    source As String,
    target As String
) As String
static member LongestCommonSubstring :
        source : string *
        target : string -> string

GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubstring = function(source, target);
public:
[ExtensionAttribute]
static String^ LongestCommonSubstring(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubstring(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubstring(System.String,System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.LongestCommonSubstring(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.NormalizedLevenshteinDistance Method

Grid Solutions Framework ComparisonMetricsNormalizedLevenshteinDistance Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.NormalizedLevenshteinDistance(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double NormalizedLevenshteinDistance(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function NormalizedLevenshteinDistance (
    source As String,
    target As String
) As Double
static member NormalizedLevenshteinDistance :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.NormalizedLevenshteinDistance = function(source, target);
public:
[ExtensionAttribute]
static double NormalizedLevenshteinDistance(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.NormalizedLevenshteinDistance(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.NormalizedLevenshteinDistance(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.NormalizedLevenshteinDistance(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.OverlapCoefficient Method

Grid Solutions Framework ComparisonMetricsOverlapCoefficient Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.OverlapCoefficient(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double OverlapCoefficient(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function OverlapCoefficient (
    source As String,
    target As String
) As Double
static member OverlapCoefficient :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.OverlapCoefficient = function(source, target);
public:
[ExtensionAttribute]
static double OverlapCoefficient(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.OverlapCoefficient(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.OverlapCoefficient(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.OverlapCoefficient(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.RatcliffObershelpSimilarity Method

Grid Solutions Framework ComparisonMetricsRatcliffObershelpSimilarity Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.RatcliffObershelpSimilarity(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double RatcliffObershelpSimilarity(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function RatcliffObershelpSimilarity (
    source As String,
    target As String
) As Double
static member RatcliffObershelpSimilarity :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.RatcliffObershelpSimilarity = function(source, target);
public:
[ExtensionAttribute]
static double RatcliffObershelpSimilarity(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.RatcliffObershelpSimilarity(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.RatcliffObershelpSimilarity(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.RatcliffObershelpSimilarity(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.SorensenDiceDistance Method

Grid Solutions Framework ComparisonMetricsSorensenDiceDistance Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceDistance(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double SorensenDiceDistance(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function SorensenDiceDistance (
    source As String,
    target As String
) As Double
static member SorensenDiceDistance :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceDistance = function(source, target);
public:
[ExtensionAttribute]
static double SorensenDiceDistance(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceDistance(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceDistance(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceDistance(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.SorensenDiceIndex Method

Grid Solutions Framework ComparisonMetricsSorensenDiceIndex Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceIndex(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double SorensenDiceIndex(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function SorensenDiceIndex (
    source As String,
    target As String
) As Double
static member SorensenDiceIndex :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceIndex = function(source, target);
public:
[ExtensionAttribute]
static double SorensenDiceIndex(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceIndex(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceIndex(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.SorensenDiceIndex(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


ComparisonMetrics.TanimotoCoefficient Method

Grid Solutions Framework ComparisonMetricsTanimotoCoefficient Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.TanimotoCoefficient(System.String,System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double TanimotoCoefficient(
    this string source,
    string target
)
<ExtensionAttribute>
Public Shared Function TanimotoCoefficient (
    source As String,
    target As String
) As Double
static member TanimotoCoefficient :
        source : string *
        target : string -> float

GSF.FuzzyStrings.ComparisonMetrics.TanimotoCoefficient = function(source, target);
public:
[ExtensionAttribute]
static double TanimotoCoefficient(
    String^ source,
    String^ target
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.TanimotoCoefficient(System.String,System.String)"]

target
Type: SystemString

[Missing <param name="target"/> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.TanimotoCoefficient(System.String,System.String)"]

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.FuzzyStrings.ComparisonMetrics.TanimotoCoefficient(System.String,System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ComparisonMetrics Class
GSF.FuzzyStrings Namespace


FuzzyStringComparisonOptions Enumeration

Grid Solutions Framework FuzzyStringComparisonOptions Enumeration

[Missing <summary> documentation for "T:GSF.FuzzyStrings.FuzzyStringComparisonOptions"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum FuzzyStringComparisonOptions
<FlagsAttribute>
Public Enumeration FuzzyStringComparisonOptions
[<FlagsAttribute>]
type FuzzyStringComparisonOptions
GSF.FuzzyStrings.FuzzyStringComparisonOptions = function();
GSF.FuzzyStrings.FuzzyStringComparisonOptions.createEnum('GSF.FuzzyStrings.FuzzyStringComparisonOptions', true);
[FlagsAttribute]
public enum class FuzzyStringComparisonOptions
Members
Member name | Value | Description
UseHammingDistance | 1 |
UseJaccardDistance | 2 |
UseJaroDistance | 4 |
UseJaroWinklerDistance | 8 |
UseLevenshteinDistance | 16 |
UseLongestCommonSubsequence | 32 |
UseLongestCommonSubstring | 64 |
UseNormalizedLevenshteinDistance | 128 |
UseOverlapCoefficient | 256 |
UseRatcliffObershelpSimilarity | 512 |
UseSorensenDiceDistance | 1024 |
UseTanimotoCoefficient | 2048 |
CaseSensitive | 4096 |
See Also

Reference

GSF.FuzzyStrings Namespace


FuzzyStringComparisonTolerance Enumeration

Grid Solutions Framework FuzzyStringComparisonTolerance Enumeration
Fuzzy string comparison tolerances.

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum FuzzyStringComparisonTolerance
Public Enumeration FuzzyStringComparisonTolerance
type FuzzyStringComparisonTolerance
GSF.FuzzyStrings.FuzzyStringComparisonTolerance = function();
GSF.FuzzyStrings.FuzzyStringComparisonTolerance.createEnum('GSF.FuzzyStrings.FuzzyStringComparisonTolerance', false);
public enum class FuzzyStringComparisonTolerance
Members
Member name | Value | Description
Strong | 0 | Strong comparison tolerance.
Normal | 1 | Normal comparison tolerance.
Weak | 2 | Weak comparison tolerance.
Manual | 3 | Manual comparison tolerance.
See Also

Reference

GSF.FuzzyStrings Namespace


Operations Class

Grid Solutions Framework Operations Class

[Missing <summary> documentation for "T:GSF.FuzzyStrings.Operations"]

Inheritance Hierarchy
SystemObject
GSF.FuzzyStringsOperations

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Operations
<ExtensionAttribute>
Public NotInheritable Class Operations
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Operations =  class end
GSF.FuzzyStrings.Operations = function();

Type.createClass(
    'GSF.FuzzyStrings.Operations');
[ExtensionAttribute]
public ref class Operations abstract sealed

The Operations type exposes the following members.

Methods
Name | Description
Capitalize |
ListBigrams |
ListNGrams |
ListPrefixes |
ListTriGrams |
MergeIndividualElementsIntoString |
SplitIntoIndividualElements |
Top
See Also

Reference

GSF.FuzzyStrings Namespace


Operations Methods

Grid Solutions Framework Operations Methods

The Operations type exposes the following members.

Methods
Name | Description
Capitalize |
ListBigrams |
ListNGrams |
ListPrefixes |
ListTriGrams |
MergeIndividualElementsIntoString |
SplitIntoIndividualElements |
Top
See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


Operations.Capitalize Method

Grid Solutions Framework OperationsCapitalize Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.Operations.Capitalize(System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Capitalize(
    this string source
)
<ExtensionAttribute>
Public Shared Function Capitalize (
    source As String
) As String
static member Capitalize :
        source : string -> string

GSF.FuzzyStrings.Operations.Capitalize = function(source);
public:
[ExtensionAttribute]
static String^ Capitalize(
    String^ source
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.Operations.Capitalize(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.Operations.Capitalize(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


Operations.ListBigrams Method

Grid Solutions Framework OperationsListBigrams Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.Operations.ListBigrams(System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<string> ListBigrams(
    this string source
)
<ExtensionAttribute>
Public Shared Function ListBigrams (
    source As String
) As List(Of String)
static member ListBigrams :
        source : string -> List<string>

GSF.FuzzyStrings.Operations.ListBigrams = function(source);
public:
[ExtensionAttribute]
static List<String^>^ ListBigrams(
    String^ source
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.Operations.ListBigrams(System.String)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.Operations.ListBigrams(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


Operations.ListNGrams Method

Grid Solutions Framework OperationsListNGrams Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.Operations.ListNGrams(System.String,System.Int32)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<string> ListNGrams(
    this string source,
    int n
)
<ExtensionAttribute>
Public Shared Function ListNGrams (
    source As String,
    n As Integer
) As List(Of String)
static member ListNGrams :
        source : string *
        n : int -> List<string>

GSF.FuzzyStrings.Operations.ListNGrams = function(source, n);
public:
[ExtensionAttribute]
static List<String^>^ ListNGrams(
    String^ source,
    int n
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.Operations.ListNGrams(System.String,System.Int32)"]

n
Type: SystemInt32

[Missing <param name="n"/> documentation for "M:GSF.FuzzyStrings.Operations.ListNGrams(System.String,System.Int32)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.Operations.ListNGrams(System.String,System.Int32)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


Operations.ListPrefixes Method

Grid Solutions Framework OperationsListPrefixes Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.Operations.ListPrefixes(System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<string> ListPrefixes(
    this string source
)
<ExtensionAttribute>
Public Shared Function ListPrefixes (
    source As String
) As List(Of String)
static member ListPrefixes :
        source : string -> List<string>

GSF.FuzzyStrings.Operations.ListPrefixes = function(source);
public:
[ExtensionAttribute]
static List<String^>^ ListPrefixes(
    String^ source
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.Operations.ListPrefixes(System.String)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.Operations.ListPrefixes(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


Operations.ListTriGrams Method

Grid Solutions Framework OperationsListTriGrams Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.Operations.ListTriGrams(System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static List<string> ListTriGrams(
    this string source
)
<ExtensionAttribute>
Public Shared Function ListTriGrams (
    source As String
) As List(Of String)
static member ListTriGrams :
        source : string -> List<string>

GSF.FuzzyStrings.Operations.ListTriGrams = function(source);
public:
[ExtensionAttribute]
static List<String^>^ ListTriGrams(
    String^ source
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.Operations.ListTriGrams(System.String)"]

Return Value

Type: List String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.Operations.ListTriGrams(System.String)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


Operations.MergeIndividualElementsIntoString Method

Grid Solutions Framework OperationsMergeIndividualElementsIntoString Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.Operations.MergeIndividualElementsIntoString(System.Collections.Generic.IEnumerable{System.String})"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string MergeIndividualElementsIntoString(
    IEnumerable<string> source
)
Public Shared Function MergeIndividualElementsIntoString (
    source As IEnumerable(Of String)
) As String
static member MergeIndividualElementsIntoString :
        source : IEnumerable<string> -> string

GSF.FuzzyStrings.Operations.MergeIndividualElementsIntoString = function(source);
public:
static String^ MergeIndividualElementsIntoString(
    IEnumerable<String^>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable String

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.Operations.MergeIndividualElementsIntoString(System.Collections.Generic.IEnumerable{System.String})"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.Operations.MergeIndividualElementsIntoString(System.Collections.Generic.IEnumerable{System.String})"]

See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


Operations.SplitIntoIndividualElements Method

Grid Solutions Framework OperationsSplitIntoIndividualElements Method

[Missing <summary> documentation for "M:GSF.FuzzyStrings.Operations.SplitIntoIndividualElements(System.String)"]

Namespace: GSF.FuzzyStrings
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] SplitIntoIndividualElements(
    string source
)
Public Shared Function SplitIntoIndividualElements (
    source As String
) As String()
static member SplitIntoIndividualElements :
        source : string -> string[]

GSF.FuzzyStrings.Operations.SplitIntoIndividualElements = function(source);
public:
static array<String^>^ SplitIntoIndividualElements(
    String^ source
)

Parameters

source
Type: SystemString

[Missing <param name="source"/> documentation for "M:GSF.FuzzyStrings.Operations.SplitIntoIndividualElements(System.String)"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.FuzzyStrings.Operations.SplitIntoIndividualElements(System.String)"]

See Also

Reference

Operations Class
GSF.FuzzyStrings Namespace


GSF.Historian Namespace

Grid Solutions Framework GSF.Historian Namespace
Contains fundamental classes used by all historian code.
Classes
 | Class | Description
Public class | DataListener | Represents a listener that can receive time-series data in real-time using Sockets.
Public class | QualityExtensions | Defines extension methods for (and related to) Quality enumeration.
Public class | TimeTag | Represents a historian time tag as number of seconds from the BaseDate.
Interfaces
 | Interface | Description
Public interface | IArchive | Defines a repository where time-series data is warehoused by a historian.
Public interface | IDataPoint | Defines time-series data warehoused by a historian.
Enumerations
 | Enumeration | Description
Public enumeration | Quality | Indicates the quality of time-series data.


DataListener Class

Grid Solutions Framework DataListener Class
Represents a listener that can receive time-series data in real-time using Sockets.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.HistorianDataListener

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(DataListener))]
public class DataListener : Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings
<ToolboxBitmapAttribute(GetType(DataListener))>
Public Class DataListener
    Inherits Component
    Implements ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings
[<ToolboxBitmapAttribute(typeof(DataListener))>]
type DataListener =
    class
        inherit Component
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.DataListener = function();

Type.createClass(
    'GSF.Historian.DataListener',
    Component,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(DataListener))]
public ref class DataListener : public Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings

The DataListener type exposes the following members.

Constructors
 | Name | Description
Public method | DataListener | Initializes a new instance of the DataListener class.
Public method | DataListener(IContainer) | Initializes a new instance of the DataListener class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the DataListener properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataListener and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the DataListener properties are initialized.
Public method | Equals | Determines whether the current DataListener object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindData | Gets the current data for the specified historianID.
Public method | GetHashCode | Returns the hash code for the current DataListener object. (Overrides ObjectGetHashCode.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the DataListener.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the DataListener from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDataChanged | Raises the DataChanged event.
Protected method | OnDataExtracted | Raises the DataExtracted event.
Protected method | OnDataInitComplete | Raises the DataInitComplete event.
Protected method | OnDataInitFailure | Raises the DataInitFailure event.
Protected method | OnDataInitPartial | Raises the DataInitPartial event.
Protected method | OnDataInitStart | Raises the DataInitStart event.
Protected method | OnListenerStarted | Raises the ListenerStarted event.
Protected method | OnListenerStarting | Raises the ListenerStarting event.
Protected method | OnListenerStopped | Raises the ListenerStopped event.
Protected method | OnListenerStopping | Raises the ListenerStopping event.
Protected method | OnSocketConnected | Raises the SocketConnected event.
Protected method | OnSocketConnecting | Raises the SocketConnecting event.
Protected method | OnSocketDisconnected | Raises the SocketDisconnected event.
Public method | SaveSettings | Saves settings for the DataListener to the config file if the PersistSettings property is set to true.
Public method | Start | Starts the DataListener synchronously.
Public method | StartAsync | Starts the DataListener asynchronously.
Public method | Stop | Stops the DataListener.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultCacheData | Specifies the default value for the CacheData property.
DefaultConnectToServer | Specifies the default value for the ConnectToServer property.
DefaultID | Specifies the default value for the ID property.
DefaultInitializeData | Specifies the default value for the InitializeData property.
DefaultInitializeDataTimeout | Specifies the default value for the InitializeDataTimeout property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultPort | Specifies the default value for the Port property.
DefaultProtocol | Specifies the default value for the Protocol property.
DefaultServer | Specifies the default value for the Server property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Public property | CacheData | Gets or sets a boolean value that indicates whether the Data is to be updated with the latest time-series data.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ConnectToServer | Gets or sets a boolean value that indicates whether the DataListener will connect to the Server for receiving the time-series data or the Server will make a connection to the DataListener on the specified Port for sending time-series data.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Data | Gets the newest time-series data received by the DataListener.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the DataListener is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ID | Gets or sets the alpha-numeric identifier of the DataListener.
Public property | InitializeData | Gets or sets a boolean value that indicates whether the DataListener will initialize the Data from the Server on startup.
Public property | InitializeDataTimeout | Gets or sets the time (in milliseconds) to wait for the Data to be initialized from the Server on Startup.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | Name | Gets the unique identifier of the DataListener.
Public property | Parser | Gets the underlying PacketParser used the DataListener for extracting the time-series data.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of DataListener are to be saved to the config file.
Public property | Port | Gets or sets the network port of the Server where the DataListener will connect to get the time-series data.
Public property | Protocol | Gets or sets the TransportProtocol to be used for receiving time-series data from the Server.
Public property | RunTime | Gets the up-time (in seconds) of the DataListener.
Public property | Server | Gets or sets the DNS name or IP address of the server from where the DataListener will get the time-series data.
Public property | SettingsCategory | Gets or sets the category under which the settings of DataListener are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the DataListener.
Public property | TotalBytesReceived | Gets the total number of bytes received by the DataListener since it was Started.
Public property | TotalPacketsReceived | Gets the total number of packets received by the DataListener since it was Started.
Top
Events
 | Name | Description
Public event | DataChanged | Occurs when the Data has changed.
Public event | DataExtracted | Occurs when time-series data is extracted from the received packets.
Public event | DataInitComplete | Occurs when the Data is populated completely on Startup.
Public event | DataInitFailure | Occurs when the Data cannot be populated on Startup due to the unavailability of the Server.
Public event | DataInitPartial | Occurs when the Data cannot be populated completely on Startup.
Public event | DataInitStart | Occurs when the Data is being populated on Startup.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ListenerStarted | Occurs when the DataListener has started.
Public event | ListenerStarting | Occurs when the DataListener is starting up.
Public event | ListenerStopped | Occurs when DataListener has stopped.
Public event | ListenerStopping | Occurs when the DataListener is being stopped.
Public event | SocketConnected | Occurs when the underlying Socket connection for receiving time-series data is established.
Public event | SocketConnecting | Occurs when the underlying Socket connection for receiving time-series data is being attempted.
Public event | SocketDisconnected | Occurs when the underlying Socket connection for receiving time-series data is terminated.
Top
See Also

Reference

GSF.Historian Namespace
GSF.HistorianIDataPoint
GSF.Historian.PacketsPacketParser


DataListener Constructor

Grid Solutions Framework DataListener Constructor
Overload List
 | Name | Description
Public method | DataListener | Initializes a new instance of the DataListener class.
Public method | DataListener(IContainer) | Initializes a new instance of the DataListener class.
Top
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener Constructor

Grid Solutions Framework DataListener Constructor
Initializes a new instance of the DataListener class.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataListener()
Public Sub New
new : unit -> DataListener
GSF.Historian.DataListener = function();
public:
DataListener()
See Also

Reference

DataListener Class
DataListener Overload
GSF.Historian Namespace


DataListener Constructor (IContainer)

Grid Solutions Framework DataListener Constructor (IContainer)
Initializes a new instance of the DataListener class.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataListener(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> DataListener
GSF.Historian.DataListener = function(container);
public:
DataListener(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the DataListener.
See Also

Reference

DataListener Class
DataListener Overload
GSF.Historian Namespace


DataListener Fields

Grid Solutions Framework DataListener Fields

The DataListener type exposes the following members.

Fields
Name | Description
DefaultCacheData | Specifies the default value for the CacheData property.
DefaultConnectToServer | Specifies the default value for the ConnectToServer property.
DefaultID | Specifies the default value for the ID property.
DefaultInitializeData | Specifies the default value for the InitializeData property.
DefaultInitializeDataTimeout | Specifies the default value for the InitializeDataTimeout property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultPort | Specifies the default value for the Port property.
DefaultProtocol | Specifies the default value for the Protocol property.
DefaultServer | Specifies the default value for the Server property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultCacheData Field

Grid Solutions Framework DataListenerDefaultCacheData Field
Specifies the default value for the CacheData property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultCacheData
Public Const DefaultCacheData As Boolean
static val mutable DefaultCacheData: bool
var GSF.Historian.DataListener.DefaultCacheData
public:
literal bool DefaultCacheData

Field Value

Type: Boolean
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultConnectToServer Field

Grid Solutions Framework DataListenerDefaultConnectToServer Field
Specifies the default value for the ConnectToServer property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultConnectToServer
Public Const DefaultConnectToServer As Boolean
static val mutable DefaultConnectToServer: bool
var GSF.Historian.DataListener.DefaultConnectToServer
public:
literal bool DefaultConnectToServer

Field Value

Type: Boolean
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultID Field

Grid Solutions Framework DataListenerDefaultID Field
Specifies the default value for the ID property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultID
Public Const DefaultID As String
static val mutable DefaultID: string
var GSF.Historian.DataListener.DefaultID
public:
literal String^ DefaultID

Field Value

Type: String
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultInitializeData Field

Grid Solutions Framework DataListenerDefaultInitializeData Field
Specifies the default value for the InitializeData property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultInitializeData
Public Const DefaultInitializeData As Boolean
static val mutable DefaultInitializeData: bool
var GSF.Historian.DataListener.DefaultInitializeData
public:
literal bool DefaultInitializeData

Field Value

Type: Boolean
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultInitializeDataTimeout Field

Grid Solutions Framework DataListenerDefaultInitializeDataTimeout Field
Specifies the default value for the InitializeDataTimeout property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultInitializeDataTimeout
Public Const DefaultInitializeDataTimeout As Integer
static val mutable DefaultInitializeDataTimeout: int
var GSF.Historian.DataListener.DefaultInitializeDataTimeout
public:
literal int DefaultInitializeDataTimeout

Field Value

Type: Int32
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultPersistSettings Field

Grid Solutions Framework DataListenerDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.Historian.DataListener.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultPort Field

Grid Solutions Framework DataListenerDefaultPort Field
Specifies the default value for the Port property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultPort
Public Const DefaultPort As Integer
static val mutable DefaultPort: int
var GSF.Historian.DataListener.DefaultPort
public:
literal int DefaultPort

Field Value

Type: Int32
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultProtocol Field

Grid Solutions Framework DataListenerDefaultProtocol Field
Specifies the default value for the Protocol property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const TransportProtocol DefaultProtocol
Public Const DefaultProtocol As TransportProtocol
static val mutable DefaultProtocol: TransportProtocol
var GSF.Historian.DataListener.DefaultProtocol
public:
literal TransportProtocol DefaultProtocol

Field Value

Type: TransportProtocol
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultServer Field

Grid Solutions Framework DataListenerDefaultServer Field
Specifies the default value for the Server property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultServer
Public Const DefaultServer As String
static val mutable DefaultServer: string
var GSF.Historian.DataListener.DefaultServer
public:
literal String^ DefaultServer

Field Value

Type: String
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DefaultSettingsCategory Field

Grid Solutions Framework DataListenerDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.Historian.DataListener.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener Methods

Grid Solutions Framework DataListener Methods

The DataListener type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the DataListener properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataListener and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the DataListener properties are initialized.
Public method | Equals | Determines whether the current DataListener object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindData | Gets the current data for the specified historianID.
Public method | GetHashCode | Returns the hash code for the current DataListener object. (Overrides ObjectGetHashCode.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the DataListener.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the DataListener from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDataChanged | Raises the DataChanged event.
Protected method | OnDataExtracted | Raises the DataExtracted event.
Protected method | OnDataInitComplete | Raises the DataInitComplete event.
Protected method | OnDataInitFailure | Raises the DataInitFailure event.
Protected method | OnDataInitPartial | Raises the DataInitPartial event.
Protected method | OnDataInitStart | Raises the DataInitStart event.
Protected method | OnListenerStarted | Raises the ListenerStarted event.
Protected method | OnListenerStarting | Raises the ListenerStarting event.
Protected method | OnListenerStopped | Raises the ListenerStopped event.
Protected method | OnListenerStopping | Raises the ListenerStopping event.
Protected method | OnSocketConnected | Raises the SocketConnected event.
Protected method | OnSocketConnecting | Raises the SocketConnecting event.
Protected method | OnSocketDisconnected | Raises the SocketDisconnected event.
Public method | SaveSettings | Saves settings for the DataListener to the config file if the PersistSettings property is set to true.
Public method | Start | Starts the DataListener synchronously.
Public method | StartAsync | Starts the DataListener asynchronously.
Public method | Stop | Stops the DataListener.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.BeginInit Method

Grid Solutions Framework DataListenerBeginInit Method
Performs necessary operations before the DataListener properties are initialized.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the DataListener is consumed through the designer surface of the IDE.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Dispose Method

Grid Solutions Framework DataListenerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataListener and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Dispose Method (Boolean)

Grid Solutions Framework DataListenerDispose Method (Boolean)
Releases the unmanaged resources used by the DataListener and optionally releases the managed resources.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

DataListener Class
Dispose Overload
GSF.Historian Namespace


DataListener.EndInit Method

Grid Solutions Framework DataListenerEndInit Method
Performs necessary operations after the DataListener properties are initialized.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the DataListener is consumed through the designer surface of the IDE.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Equals Method

Grid Solutions Framework DataListenerEquals Method
Determines whether the current DataListener object is equal to obj.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current DataListener object is to be compared for equality.

Return Value

Type: Boolean
true if the current DataListener object is equal to obj; otherwise false.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.FindData Method

Grid Solutions Framework DataListenerFindData Method
Gets the current data for the specified historianID.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDataPoint FindData(
    int historianID
)
Public Function FindData (
    historianID As Integer
) As IDataPoint
member FindData :
        historianID : int -> IDataPoint

function FindData(historianID);
public:
IDataPoint^ FindData(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier whose current data is to be retrieved.

Return Value

Type: IDataPoint
IDataPoint if a match is found; otherwise null.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.GetHashCode Method

Grid Solutions Framework DataListenerGetHashCode Method
Returns the hash code for the current DataListener object.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Initialize Method

Grid Solutions Framework DataListenerInitialize Method
Initializes the DataListener.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the DataListener is not consumed through the designer surface of the IDE.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.LoadSettings Method

Grid Solutions Framework DataListenerLoadSettings Method
Loads saved settings for the DataListener from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnDataChanged Method

Grid Solutions Framework DataListenerOnDataChanged Method
Raises the DataChanged event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataChanged()
Protected Overridable Sub OnDataChanged
abstract OnDataChanged : unit -> unit
override OnDataChanged : unit -> unit
function OnDataChanged();
protected:
virtual void OnDataChanged()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnDataExtracted Method

Grid Solutions Framework DataListenerOnDataExtracted Method
Raises the DataExtracted event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataExtracted(
    IList<IDataPoint> data
)
Protected Overridable Sub OnDataExtracted (
    data As IList(Of IDataPoint)
)
abstract OnDataExtracted :
        data : IList<IDataPoint> -> unit
override OnDataExtracted :
        data : IList<IDataPoint> -> unit
function OnDataExtracted(data);
protected:
virtual void OnDataExtracted(
    IList<IDataPoint^>^ data
)

Parameters

data
Type: System.Collections.GenericIList IDataPoint
Extracted time-series data to send to DataExtracted event.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnDataInitComplete Method

Grid Solutions Framework DataListenerOnDataInitComplete Method
Raises the DataInitComplete event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataInitComplete()
Protected Overridable Sub OnDataInitComplete
abstract OnDataInitComplete : unit -> unit
override OnDataInitComplete : unit -> unit
function OnDataInitComplete();
protected:
virtual void OnDataInitComplete()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnDataInitFailure Method

Grid Solutions Framework DataListenerOnDataInitFailure Method
Raises the DataInitFailure event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataInitFailure()
Protected Overridable Sub OnDataInitFailure
abstract OnDataInitFailure : unit -> unit
override OnDataInitFailure : unit -> unit
function OnDataInitFailure();
protected:
virtual void OnDataInitFailure()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnDataInitPartial Method

Grid Solutions Framework DataListenerOnDataInitPartial Method
Raises the DataInitPartial event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataInitPartial()
Protected Overridable Sub OnDataInitPartial
abstract OnDataInitPartial : unit -> unit
override OnDataInitPartial : unit -> unit
function OnDataInitPartial();
protected:
virtual void OnDataInitPartial()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnDataInitStart Method

Grid Solutions Framework DataListenerOnDataInitStart Method
Raises the DataInitStart event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataInitStart()
Protected Overridable Sub OnDataInitStart
abstract OnDataInitStart : unit -> unit
override OnDataInitStart : unit -> unit
function OnDataInitStart();
protected:
virtual void OnDataInitStart()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnListenerStarted Method

Grid Solutions Framework DataListenerOnListenerStarted Method
Raises the ListenerStarted event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnListenerStarted()
Protected Overridable Sub OnListenerStarted
abstract OnListenerStarted : unit -> unit
override OnListenerStarted : unit -> unit
function OnListenerStarted();
protected:
virtual void OnListenerStarted()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnListenerStarting Method

Grid Solutions Framework DataListenerOnListenerStarting Method
Raises the ListenerStarting event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnListenerStarting()
Protected Overridable Sub OnListenerStarting
abstract OnListenerStarting : unit -> unit
override OnListenerStarting : unit -> unit
function OnListenerStarting();
protected:
virtual void OnListenerStarting()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnListenerStopped Method

Grid Solutions Framework DataListenerOnListenerStopped Method
Raises the ListenerStopped event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnListenerStopped()
Protected Overridable Sub OnListenerStopped
abstract OnListenerStopped : unit -> unit
override OnListenerStopped : unit -> unit
function OnListenerStopped();
protected:
virtual void OnListenerStopped()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnListenerStopping Method

Grid Solutions Framework DataListenerOnListenerStopping Method
Raises the ListenerStopping event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnListenerStopping()
Protected Overridable Sub OnListenerStopping
abstract OnListenerStopping : unit -> unit
override OnListenerStopping : unit -> unit
function OnListenerStopping();
protected:
virtual void OnListenerStopping()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnSocketConnected Method

Grid Solutions Framework DataListenerOnSocketConnected Method
Raises the SocketConnected event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSocketConnected()
Protected Overridable Sub OnSocketConnected
abstract OnSocketConnected : unit -> unit
override OnSocketConnected : unit -> unit
function OnSocketConnected();
protected:
virtual void OnSocketConnected()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnSocketConnecting Method

Grid Solutions Framework DataListenerOnSocketConnecting Method
Raises the SocketConnecting event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSocketConnecting()
Protected Overridable Sub OnSocketConnecting
abstract OnSocketConnecting : unit -> unit
override OnSocketConnecting : unit -> unit
function OnSocketConnecting();
protected:
virtual void OnSocketConnecting()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.OnSocketDisconnected Method

Grid Solutions Framework DataListenerOnSocketDisconnected Method
Raises the SocketDisconnected event.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSocketDisconnected()
Protected Overridable Sub OnSocketDisconnected
abstract OnSocketDisconnected : unit -> unit
override OnSocketDisconnected : unit -> unit
function OnSocketDisconnected();
protected:
virtual void OnSocketDisconnected()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.SaveSettings Method

Grid Solutions Framework DataListenerSaveSettings Method
Saves settings for the DataListener to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Start Method

Grid Solutions Framework DataListenerStart Method
Starts the DataListener synchronously.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start()
Public Sub Start
member Start : unit -> unit

function Start();
public:
void Start()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.StartAsync Method

Grid Solutions Framework DataListenerStartAsync Method
Starts the DataListener asynchronously.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void StartAsync()
Public Sub StartAsync
member StartAsync : unit -> unit

function StartAsync();
public:
void StartAsync()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Stop Method

Grid Solutions Framework DataListenerStop Method
Stops the DataListener.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Stop()
Public Sub Stop
member Stop : unit -> unit

function Stop();
public:
void Stop()
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener Properties

Grid Solutions Framework DataListener Properties

The DataListener type exposes the following members.

Properties
 | Name | Description
Public property | CacheData | Gets or sets a boolean value that indicates whether the Data is to be updated with the latest time-series data.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ConnectToServer | Gets or sets a boolean value that indicates whether the DataListener will connect to the Server for receiving the time-series data or the Server will make a connection to the DataListener on the specified Port for sending time-series data.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Data | Gets the newest time-series data received by the DataListener.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the DataListener is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ID | Gets or sets the alpha-numeric identifier of the DataListener.
Public property | InitializeData | Gets or sets a boolean value that indicates whether the DataListener will initialize the Data from the Server on startup.
Public property | InitializeDataTimeout | Gets or sets the time (in milliseconds) to wait for the Data to be initialized from the Server on Startup.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | Name | Gets the unique identifier of the DataListener.
Public property | Parser | Gets the underlying PacketParser used the DataListener for extracting the time-series data.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of DataListener are to be saved to the config file.
Public property | Port | Gets or sets the network port of the Server where the DataListener will connect to get the time-series data.
Public property | Protocol | Gets or sets the TransportProtocol to be used for receiving time-series data from the Server.
Public property | RunTime | Gets the up-time (in seconds) of the DataListener.
Public property | Server | Gets or sets the DNS name or IP address of the server from where the DataListener will get the time-series data.
Public property | SettingsCategory | Gets or sets the category under which the settings of DataListener are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the DataListener.
Public property | TotalBytesReceived | Gets the total number of bytes received by the DataListener since it was Started.
Public property | TotalPacketsReceived | Gets the total number of packets received by the DataListener since it was Started.
Top
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.CacheData Property

Grid Solutions Framework DataListenerCacheData Property
Gets or sets a boolean value that indicates whether the Data is to be updated with the latest time-series data.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool CacheData { get; set; }
<DefaultValueAttribute(true)>
Public Property CacheData As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member CacheData : bool with get, set

function get_CacheData();
function set_CacheData(value);
public:
[DefaultValueAttribute(true)]
property bool CacheData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
InvalidOperationException | CacheData is being disabled when InitializeData is enabled.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.ConnectToServer Property

Grid Solutions Framework DataListenerConnectToServer Property
Gets or sets a boolean value that indicates whether the DataListener will connect to the Server for receiving the time-series data or the Server will make a connection to the DataListener on the specified Port for sending time-series data.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool ConnectToServer { get; set; }
<DefaultValueAttribute(true)>
Public Property ConnectToServer As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member ConnectToServer : bool with get, set

function get_ConnectToServer();
function set_ConnectToServer(value);
public:
[DefaultValueAttribute(true)]
property bool ConnectToServer {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Data Property

Grid Solutions Framework DataListenerData Property
Gets the newest time-series data received by the DataListener.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public IList<IDataPoint> Data { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Data As IList(Of IDataPoint)
    Get
[<BrowsableAttribute(false)>]
member Data : IList<IDataPoint> with get

function get_Data();

public:
[BrowsableAttribute(false)]
property IList<IDataPoint^>^ Data {
    IList<IDataPoint^>^ get ();
}

Property Value

Type: IList IDataPoint
Remarks
WARNING: Data is thread unsafe. Synchronized access is required.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Enabled Property

Grid Solutions Framework DataListenerEnabled Property
Gets or sets a boolean value that indicates whether the DataListener is currently enabled.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool Enabled { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Property Enabled As Boolean
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Enabled : bool with get, set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Enabled property is not be set by user-code directly.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.ID Property

Grid Solutions Framework DataListenerID Property
Gets or sets the alpha-numeric identifier of the DataListener.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("Default")]
public string ID { get; set; }
<DefaultValueAttribute("Default")>
Public Property ID As String
    Get
    Set
[<DefaultValueAttribute("Default")>]
member ID : string with get, set

function get_ID();
function set_ID(value);
public:
[DefaultValueAttribute(L"Default")]
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.InitializeData Property

Grid Solutions Framework DataListenerInitializeData Property
Gets or sets a boolean value that indicates whether the DataListener will initialize the Data from the Server on startup.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool InitializeData { get; set; }
<DefaultValueAttribute(true)>
Public Property InitializeData As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member InitializeData : bool with get, set

function get_InitializeData();
function set_InitializeData(value);
public:
[DefaultValueAttribute(true)]
property bool InitializeData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
InvalidOperationException | InitializeData is being enabled when CacheData is disabled.
Remarks
InitializeData should be enabled only if the Server software on port 1003 is programmed to accept PacketType11.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.InitializeDataTimeout Property

Grid Solutions Framework DataListenerInitializeDataTimeout Property
Gets or sets the time (in milliseconds) to wait for the Data to be initialized from the Server on Startup.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(60000)]
public int InitializeDataTimeout { get; set; }
<DefaultValueAttribute(60000)>
Public Property InitializeDataTimeout As Integer
    Get
    Set
[<DefaultValueAttribute(60000)>]
member InitializeDataTimeout : int with get, set

function get_InitializeDataTimeout();
function set_InitializeDataTimeout(value);
public:
[DefaultValueAttribute(60000)]
property int InitializeDataTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.IsDisposed Property

Grid Solutions Framework DataListenerIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool IsDisposed { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
abstract IsDisposed : bool with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Name Property

Grid Solutions Framework DataListenerName Property
Gets the unique identifier of the DataListener.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Parser Property

Grid Solutions Framework DataListenerParser Property
Gets the underlying PacketParser used the DataListener for extracting the time-series data.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public PacketParser Parser { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Parser As PacketParser
    Get
[<BrowsableAttribute(false)>]
member Parser : PacketParser with get

function get_Parser();

public:
[BrowsableAttribute(false)]
property PacketParser^ Parser {
    PacketParser^ get ();
}

Property Value

Type: PacketParser
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.PersistSettings Property

Grid Solutions Framework DataListenerPersistSettings Property
Gets or sets a boolean value that indicates whether the settings of DataListener are to be saved to the config file.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Port Property

Grid Solutions Framework DataListenerPort Property
Gets or sets the network port of the Server where the DataListener will connect to get the time-series data.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(1004)]
public int Port { get; set; }
<DefaultValueAttribute(1004)>
Public Property Port As Integer
    Get
    Set
[<DefaultValueAttribute(1004)>]
member Port : int with get, set

function get_Port();
function set_Port(value);
public:
[DefaultValueAttribute(1004)]
property int Port {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 0 and 65535.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Protocol Property

Grid Solutions Framework DataListenerProtocol Property
Gets or sets the TransportProtocol to be used for receiving time-series data from the Server.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(TransportProtocol.Udp)]
public TransportProtocol Protocol { get; set; }
<DefaultValueAttribute(TransportProtocol.Udp)>
Public Property Protocol As TransportProtocol
    Get
    Set
[<DefaultValueAttribute(TransportProtocol.Udp)>]
member Protocol : TransportProtocol with get, set

function get_Protocol();
function set_Protocol(value);
public:
[DefaultValueAttribute(TransportProtocol::Udp)]
property TransportProtocol Protocol {
    TransportProtocol get ();
    void set (TransportProtocol value);
}

Property Value

Type: TransportProtocol
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not Tcp or Udp.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.RunTime Property

Grid Solutions Framework DataListenerRunTime Property
Gets the up-time (in seconds) of the DataListener.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public Time RunTime { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property RunTime As Time
    Get
[<BrowsableAttribute(false)>]
member RunTime : Time with get

function get_RunTime();

public:
[BrowsableAttribute(false)]
property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Server Property

Grid Solutions Framework DataListenerServer Property
Gets or sets the DNS name or IP address of the server from where the DataListener will get the time-series data.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("localhost")]
public string Server { get; set; }
<DefaultValueAttribute("localhost")>
Public Property Server As String
    Get
    Set
[<DefaultValueAttribute("localhost")>]
member Server : string with get, set

function get_Server();
function set_Server(value);
public:
[DefaultValueAttribute(L"localhost")]
property String^ Server {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.SettingsCategory Property

Grid Solutions Framework DataListenerSettingsCategory Property
Gets or sets the category under which the settings of DataListener are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("DataListener")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("DataListener")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("DataListener")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("DataListener")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"DataListener")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.Status Property

Grid Solutions Framework DataListenerStatus Property
Gets the descriptive status of the DataListener.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Status { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.TotalBytesReceived Property

Grid Solutions Framework DataListenerTotalBytesReceived Property
Gets the total number of bytes received by the DataListener since it was Started.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public long TotalBytesReceived { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property TotalBytesReceived As Long
    Get
[<BrowsableAttribute(false)>]
member TotalBytesReceived : int64 with get

function get_TotalBytesReceived();

public:
[BrowsableAttribute(false)]
property long long TotalBytesReceived {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.TotalPacketsReceived Property

Grid Solutions Framework DataListenerTotalPacketsReceived Property
Gets the total number of packets received by the DataListener since it was Started.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public long TotalPacketsReceived { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property TotalPacketsReceived As Long
    Get
[<BrowsableAttribute(false)>]
member TotalPacketsReceived : int64 with get

function get_TotalPacketsReceived();

public:
[BrowsableAttribute(false)]
property long long TotalPacketsReceived {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener Events

Grid Solutions Framework DataListener Events

The DataListener type exposes the following members.

Events
 | Name | Description
Public event | DataChanged | Occurs when the Data has changed.
Public event | DataExtracted | Occurs when time-series data is extracted from the received packets.
Public event | DataInitComplete | Occurs when the Data is populated completely on Startup.
Public event | DataInitFailure | Occurs when the Data cannot be populated on Startup due to the unavailability of the Server.
Public event | DataInitPartial | Occurs when the Data cannot be populated completely on Startup.
Public event | DataInitStart | Occurs when the Data is being populated on Startup.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ListenerStarted | Occurs when the DataListener has started.
Public event | ListenerStarting | Occurs when the DataListener is starting up.
Public event | ListenerStopped | Occurs when DataListener has stopped.
Public event | ListenerStopping | Occurs when the DataListener is being stopped.
Public event | SocketConnected | Occurs when the underlying Socket connection for receiving time-series data is established.
Public event | SocketConnecting | Occurs when the underlying Socket connection for receiving time-series data is being attempted.
Public event | SocketDisconnected | Occurs when the underlying Socket connection for receiving time-series data is terminated.
Top
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DataChanged Event

Grid Solutions Framework DataListenerDataChanged Event
Occurs when the Data has changed.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataChanged
Public Event DataChanged As EventHandler
member DataChanged : IEvent<EventHandler,
    EventArgs>

function add_DataChanged(value);
function remove_DataChanged(value);
public:
 event EventHandler^ DataChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DataExtracted Event

Grid Solutions Framework DataListenerDataExtracted Event
Occurs when time-series data is extracted from the received packets.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IList<IDataPoint>>> DataExtracted
Public Event DataExtracted As EventHandler(Of EventArgs(Of IList(Of IDataPoint)))
member DataExtracted : IEvent<EventHandler<EventArgs<IList<IDataPoint>>>,
    EventArgs<IList<IDataPoint>>>

function add_DataExtracted(value);
function remove_DataExtracted(value);
public:
 event EventHandler<EventArgs<IList<IDataPoint^>^>^>^ DataExtracted {
    void add (EventHandler<EventArgs<IList<IDataPoint^>^>^>^ value);
    void remove (EventHandler<EventArgs<IList<IDataPoint^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IList IDataPoint
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DataInitComplete Event

Grid Solutions Framework DataListenerDataInitComplete Event
Occurs when the Data is populated completely on Startup.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataInitComplete
Public Event DataInitComplete As EventHandler
member DataInitComplete : IEvent<EventHandler,
    EventArgs>

function add_DataInitComplete(value);
function remove_DataInitComplete(value);
public:
 event EventHandler^ DataInitComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DataInitFailure Event

Grid Solutions Framework DataListenerDataInitFailure Event
Occurs when the Data cannot be populated on Startup due to the unavailability of the Server.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataInitFailure
Public Event DataInitFailure As EventHandler
member DataInitFailure : IEvent<EventHandler,
    EventArgs>

function add_DataInitFailure(value);
function remove_DataInitFailure(value);
public:
 event EventHandler^ DataInitFailure {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DataInitPartial Event

Grid Solutions Framework DataListenerDataInitPartial Event
Occurs when the Data cannot be populated completely on Startup.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataInitPartial
Public Event DataInitPartial As EventHandler
member DataInitPartial : IEvent<EventHandler,
    EventArgs>

function add_DataInitPartial(value);
function remove_DataInitPartial(value);
public:
 event EventHandler^ DataInitPartial {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.DataInitStart Event

Grid Solutions Framework DataListenerDataInitStart Event
Occurs when the Data is being populated on Startup.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataInitStart
Public Event DataInitStart As EventHandler
member DataInitStart : IEvent<EventHandler,
    EventArgs>

function add_DataInitStart(value);
function remove_DataInitStart(value);
public:
 event EventHandler^ DataInitStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.ListenerStarted Event

Grid Solutions Framework DataListenerListenerStarted Event
Occurs when the DataListener has started.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ListenerStarted
Public Event ListenerStarted As EventHandler
member ListenerStarted : IEvent<EventHandler,
    EventArgs>

function add_ListenerStarted(value);
function remove_ListenerStarted(value);
public:
 event EventHandler^ ListenerStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.ListenerStarting Event

Grid Solutions Framework DataListenerListenerStarting Event
Occurs when the DataListener is starting up.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ListenerStarting
Public Event ListenerStarting As EventHandler
member ListenerStarting : IEvent<EventHandler,
    EventArgs>

function add_ListenerStarting(value);
function remove_ListenerStarting(value);
public:
 event EventHandler^ ListenerStarting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.ListenerStopped Event

Grid Solutions Framework DataListenerListenerStopped Event
Occurs when DataListener has stopped.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ListenerStopped
Public Event ListenerStopped As EventHandler
member ListenerStopped : IEvent<EventHandler,
    EventArgs>

function add_ListenerStopped(value);
function remove_ListenerStopped(value);
public:
 event EventHandler^ ListenerStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.ListenerStopping Event

Grid Solutions Framework DataListenerListenerStopping Event
Occurs when the DataListener is being stopped.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ListenerStopping
Public Event ListenerStopping As EventHandler
member ListenerStopping : IEvent<EventHandler,
    EventArgs>

function add_ListenerStopping(value);
function remove_ListenerStopping(value);
public:
 event EventHandler^ ListenerStopping {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.SocketConnected Event

Grid Solutions Framework DataListenerSocketConnected Event
Occurs when the underlying Socket connection for receiving time-series data is established.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler SocketConnected
Public Event SocketConnected As EventHandler
member SocketConnected : IEvent<EventHandler,
    EventArgs>

function add_SocketConnected(value);
function remove_SocketConnected(value);
public:
 event EventHandler^ SocketConnected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.SocketConnecting Event

Grid Solutions Framework DataListenerSocketConnecting Event
Occurs when the underlying Socket connection for receiving time-series data is being attempted.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler SocketConnecting
Public Event SocketConnecting As EventHandler
member SocketConnecting : IEvent<EventHandler,
    EventArgs>

function add_SocketConnecting(value);
function remove_SocketConnecting(value);
public:
 event EventHandler^ SocketConnecting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


DataListener.SocketDisconnected Event

Grid Solutions Framework DataListenerSocketDisconnected Event
Occurs when the underlying Socket connection for receiving time-series data is terminated.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler SocketDisconnected
Public Event SocketDisconnected As EventHandler
member SocketDisconnected : IEvent<EventHandler,
    EventArgs>

function add_SocketDisconnected(value);
function remove_SocketDisconnected(value);
public:
 event EventHandler^ SocketDisconnected {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataListener Class
GSF.Historian Namespace


IArchive Interface

Grid Solutions Framework IArchive Interface
Defines a repository where time-series data is warehoused by a historian.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IArchive
Public Interface IArchive
type IArchive =  interface end
GSF.Historian.IArchive = function();
GSF.Historian.IArchive.createInterface('GSF.Historian.IArchive');
public interface class IArchive

The IArchive type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the repository.
Public method | Open | Opens the repository.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads time-series data from the repository.
Public method | ReadData(Int32, String, String, Boolean) | Reads time-series data from the repository.
Public method | ReadMetaData | Read meta information for the specified historianID.
Public method | ReadMetaDataSummary | Reads meta information summary for the specified historianID.
Public method | ReadStateData | Reads state information for the specified historianID.
Public method | ReadStateDataSummary | Read state information summary for the specified historianID.
Public method | WriteData | Writes time-series data to the repository.
Public method | WriteMetaData | Writes meta information for the specified historianID to the repository.
Public method | WriteStateData | Writes state information for the specified historianID to the repository.
Top
See Also

Reference

GSF.Historian Namespace
GSF.HistorianIDataPoint


IArchive Methods

Grid Solutions Framework IArchive Methods

The IArchive type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the repository.
Public method | Open | Opens the repository.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads time-series data from the repository.
Public method | ReadData(Int32, String, String, Boolean) | Reads time-series data from the repository.
Public method | ReadMetaData | Read meta information for the specified historianID.
Public method | ReadMetaDataSummary | Reads meta information summary for the specified historianID.
Public method | ReadStateData | Reads state information for the specified historianID.
Public method | ReadStateDataSummary | Read state information summary for the specified historianID.
Public method | WriteData | Writes time-series data to the repository.
Public method | WriteMetaData | Writes meta information for the specified historianID to the repository.
Public method | WriteStateData | Writes state information for the specified historianID to the repository.
Top
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.Close Method

Grid Solutions Framework IArchiveClose Method
Closes the repository.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Close()
Sub Close
abstract Close : unit -> unit

function Close();
void Close()
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.Open Method

Grid Solutions Framework IArchiveOpen Method
Opens the repository.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Open()
Sub Open
abstract Open : unit -> unit

function Open();
void Open()
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.ReadData Method

Grid Solutions Framework IArchiveReadData Method
Overload List
 | Name | Description
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads time-series data from the repository.
Public method | ReadData(Int32, String, String, Boolean) | Reads time-series data from the repository.
Top
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.ReadData Method (IEnumerable(Int32), String, String, Boolean)

Grid Solutions Framework IArchiveReadData Method (IEnumerableInt32, String, String, Boolean)
Reads time-series data from the repository.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    string startTime,
    string endTime,
    bool timeSorted = true
)
Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As String,
    endTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
abstract ReadData :
        historianIDs : IEnumerable<int> *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, endTime, timeSorted);
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    String^ startTime,
    String^ endTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which IDataPoints are to be read.
startTime
Type: SystemString
String representation of the start time (in UTC) of the timespan for which IDataPoints are to be read.
endTime
Type: SystemString
String representation of the end time (in UTC) of the timespan for which IDataPoints are to be read.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more IDataPoints.
See Also

Reference

IArchive Interface
ReadData Overload
GSF.Historian Namespace


IArchive.ReadData Method (Int32, String, String, Boolean)

Grid Solutions Framework IArchiveReadData Method (Int32, String, String, Boolean)
Reads time-series data from the repository.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IEnumerable<IDataPoint> ReadData(
    int historianID,
    string startTime,
    string endTime,
    bool timeSorted = true
)
Function ReadData (
    historianID As Integer,
    startTime As String,
    endTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
abstract ReadData :
        historianID : int *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, endTime, timeSorted);
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    String^ startTime,
    String^ endTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which IDataPoints are to be read.
startTime
Type: SystemString
String representation of the start time (in UTC) of the timespan for which IDataPoints are to be read.
endTime
Type: SystemString
String representation of the end time (in UTC) of the timespan for which IDataPoints are to be read.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more IDataPoints.
See Also

Reference

IArchive Interface
ReadData Overload
GSF.Historian Namespace


IArchive.ReadMetaData Method

Grid Solutions Framework IArchiveReadMetaData Method
Read meta information for the specified historianID.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] ReadMetaData(
    int historianID
)
Function ReadMetaData (
    historianID As Integer
) As Byte()
abstract ReadMetaData :
        historianID : int -> byte[]

function ReadMetaData(historianID);
array<unsigned char>^ ReadMetaData(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing meta information.
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.ReadMetaDataSummary Method

Grid Solutions Framework IArchiveReadMetaDataSummary Method
Reads meta information summary for the specified historianID.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] ReadMetaDataSummary(
    int historianID
)
Function ReadMetaDataSummary (
    historianID As Integer
) As Byte()
abstract ReadMetaDataSummary :
        historianID : int -> byte[]

function ReadMetaDataSummary(historianID);
array<unsigned char>^ ReadMetaDataSummary(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing meta information summary.
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.ReadStateData Method

Grid Solutions Framework IArchiveReadStateData Method
Reads state information for the specified historianID.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] ReadStateData(
    int historianID
)
Function ReadStateData (
    historianID As Integer
) As Byte()
abstract ReadStateData :
        historianID : int -> byte[]

function ReadStateData(historianID);
array<unsigned char>^ ReadStateData(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing state information.
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.ReadStateDataSummary Method

Grid Solutions Framework IArchiveReadStateDataSummary Method
Read state information summary for the specified historianID.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] ReadStateDataSummary(
    int historianID
)
Function ReadStateDataSummary (
    historianID As Integer
) As Byte()
abstract ReadStateDataSummary :
        historianID : int -> byte[]

function ReadStateDataSummary(historianID);
array<unsigned char>^ ReadStateDataSummary(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing state information summary.
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.WriteData Method

Grid Solutions Framework IArchiveWriteData Method
Writes time-series data to the repository.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void WriteData(
    IDataPoint dataPoint
)
Sub WriteData (
    dataPoint As IDataPoint
)
abstract WriteData :
        dataPoint : IDataPoint -> unit

function WriteData(dataPoint);
void WriteData(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint to be written.
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.WriteMetaData Method

Grid Solutions Framework IArchiveWriteMetaData Method
Writes meta information for the specified historianID to the repository.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void WriteMetaData(
    int historianID,
    byte[] metaData
)
Sub WriteMetaData (
    historianID As Integer,
    metaData As Byte()
)
abstract WriteMetaData :
        historianID : int *
        metaData : byte[] -> unit

function WriteMetaData(historianID, metaData);
void WriteMetaData(
    int historianID,
    array<unsigned char>^ metaData
)

Parameters

historianID
Type: SystemInt32
Historian identifier.
metaData
Type: SystemByte
Binary image of the meta information.
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IArchive.WriteStateData Method

Grid Solutions Framework IArchiveWriteStateData Method
Writes state information for the specified historianID to the repository.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void WriteStateData(
    int historianID,
    byte[] stateData
)
Sub WriteStateData (
    historianID As Integer,
    stateData As Byte()
)
abstract WriteStateData :
        historianID : int *
        stateData : byte[] -> unit

function WriteStateData(historianID, stateData);
void WriteStateData(
    int historianID,
    array<unsigned char>^ stateData
)

Parameters

historianID
Type: SystemInt32
Historian identifier.
stateData
Type: SystemByte
Binary image of the state information.
See Also

Reference

IArchive Interface
GSF.Historian Namespace


IDataPoint Interface

Grid Solutions Framework IDataPoint Interface
Defines time-series data warehoused by a historian.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDataPoint : ISupportBinaryImage,
    IComparable, IFormattable
Public Interface IDataPoint
    Inherits ISupportBinaryImage, IComparable, IFormattable
type IDataPoint =
    interface
        interface ISupportBinaryImage
        interface IComparable
        interface IFormattable
    end
GSF.Historian.IDataPoint = function();
GSF.Historian.IDataPoint.createInterface('GSF.Historian.IDataPoint');
public interface class IDataPoint : ISupportBinaryImage,
    IComparable, IFormattable

The IDataPoint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | ToString | Formats the value of the current instance using the specified format. (Inherited from IFormattable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | HistorianID | Gets or sets the historian identifier of the time-series data point.
Public property | Metadata | Gets or sets associated MetadataRecord of the time-series data point.
Public property | Quality | Gets or sets the Quality of the time-series data point.
Public property | Time | Gets or sets the TimeTag of the time-series data point.
Public property | Value | Gets or sets the value of the time-series data point.
Top
See Also

Reference

GSF.Historian Namespace
GSF.HistorianTimeTag
IDataPointQuality


IDataPoint Methods

Grid Solutions Framework IDataPoint Methods

The IDataPoint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | ToString | Formats the value of the current instance using the specified format. (Inherited from IFormattable.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IDataPoint Interface
GSF.Historian Namespace


IDataPoint Properties

Grid Solutions Framework IDataPoint Properties

The IDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | HistorianID | Gets or sets the historian identifier of the time-series data point.
Public property | Metadata | Gets or sets associated MetadataRecord of the time-series data point.
Public property | Quality | Gets or sets the Quality of the time-series data point.
Public property | Time | Gets or sets the TimeTag of the time-series data point.
Public property | Value | Gets or sets the value of the time-series data point.
Top
See Also

Reference

IDataPoint Interface
GSF.Historian Namespace


IDataPoint.HistorianID Property

Grid Solutions Framework IDataPointHistorianID Property
Gets or sets the historian identifier of the time-series data point.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int HistorianID { get; set; }
Property HistorianID As Integer
    Get
    Set
abstract HistorianID : int with get, set

function get_HistorianID();
function set_HistorianID(value);
property int HistorianID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IDataPoint Interface
GSF.Historian Namespace


IDataPoint.Metadata Property

Grid Solutions Framework IDataPointMetadata Property
Gets or sets associated MetadataRecord of the time-series data point.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MetadataRecord Metadata { get; set; }
Property Metadata As MetadataRecord
    Get
    Set
abstract Metadata : MetadataRecord with get, set

function get_Metadata();
function set_Metadata(value);
property MetadataRecord^ Metadata {
    MetadataRecord^ get ();
    void set (MetadataRecord^ value);
}

Property Value

Type: MetadataRecord
See Also

Reference

IDataPoint Interface
GSF.Historian Namespace


IDataPoint.Quality Property

Grid Solutions Framework IDataPointQuality Property
Gets or sets the Quality of the time-series data point.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Quality Quality { get; set; }
Property Quality As Quality
    Get
    Set
abstract Quality : Quality with get, set

function get_Quality();
function set_Quality(value);
property Quality Quality {
    Quality get ();
    void set (Quality value);
}

Property Value

Type: Quality
See Also

Reference

IDataPoint Interface
GSF.Historian Namespace


IDataPoint.Time Property

Grid Solutions Framework IDataPointTime Property
Gets or sets the TimeTag of the time-series data point.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TimeTag Time { get; set; }
Property Time As TimeTag
    Get
    Set
abstract Time : TimeTag with get, set

function get_Time();
function set_Time(value);
property TimeTag^ Time {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
See Also

Reference

IDataPoint Interface
GSF.Historian Namespace


IDataPoint.Value Property

Grid Solutions Framework IDataPointValue Property
Gets or sets the value of the time-series data point.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
float Value { get; set; }
Property Value As Single
    Get
    Set
abstract Value : float32 with get, set

function get_Value();
function set_Value(value);
property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

IDataPoint Interface
GSF.Historian Namespace


Quality Enumeration

Grid Solutions Framework Quality Enumeration
Indicates the quality of time-series data.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum Quality
Public Enumeration Quality
type Quality
GSF.Historian.Quality = function();
GSF.Historian.Quality.createEnum('GSF.Historian.Quality', false);
public enum class Quality
Members
Member name | Value | Description
Unknown | 0 | Unknown
DeletedFromProcessing | 1 | DeletedFromProcessing
CouldNotCalculate | 2 | CouldNotCalculate
FrontEndHardwareError | 3 | FrontEndHardwareError
SensorReadError | 4 | SensorReadError
OpenThermocouple | 5 | OpenThermocouple
InputCountsOutOfSensorRange | 6 | InputCountsOutOfSensorRange
UnreasonableHigh | 7 | UnreasonableHigh
UnreasonableLow | 8 | UnreasonableLow
Old | 9 | Old
SuspectValueAboveHiHiLimit | 10 | SuspectValueAboveHiHiLimit
SuspectValueBelowLoLoLimit | 11 | SuspectValueBelowLoLoLimit
SuspectValueAboveHiLimit | 12 | SuspectValueAboveHiLimit
SuspectValueBelowLoLimit | 13 | SuspectValueBelowLoLimit
SuspectData | 14 | SuspectData
DigitalSuspectAlarm | 15 | DigitalSuspectAlarm
InsertedValueAboveHiHiLimit | 16 | InsertedValueAboveHiHiLimit
InsertedValueBelowLoLoLimit | 17 | InsertedValueBelowLoLoLimit
InsertedValueAboveHiLimit | 18 | InsertedValueAboveHiLimit
InsertedValueBelowLoLimit | 19 | InsertedValueBelowLoLimit
InsertedValue | 20 | InsertedValue
DigitalInsertedStatusInAlarm | 21 | DigitalInsertedStatusInAlarm
LogicalAlarm | 22 | LogicalAlarm
ValueAboveHiHiAlarm | 23 | ValueAboveHiHiAlarm
ValueBelowLoLoAlarm | 24 | ValueBelowLoLoAlarm
ValueAboveHiAlarm | 25 | ValueAboveHiAlarm
ValueBelowLoAlarm | 26 | ValueBelowLoAlarm
DeletedFromAlarmChecks | 27 | DeletedFromAlarmChecks
InhibitedByCutoutPoint | 28 | InhibitedByCutoutPoint
Good | 29 | Good
See Also

Reference

GSF.Historian Namespace


QualityExtensions Class

Grid Solutions Framework QualityExtensions Class
Defines extension methods for (and related to) Quality enumeration.
Inheritance Hierarchy
SystemObject
GSF.HistorianQualityExtensions

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class QualityExtensions
<ExtensionAttribute>
Public NotInheritable Class QualityExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QualityExtensions =  class end
GSF.Historian.QualityExtensions = function();

Type.createClass(
    'GSF.Historian.QualityExtensions');
[ExtensionAttribute]
public ref class QualityExtensions abstract sealed

The QualityExtensions type exposes the following members.

Methods
Name | Description
HistorianQuality | Gets a Quality value from a IMeasurement value.
MeasurementQuality | Gets a MeasurementStateFlags value from a Quality value.
Top
See Also

Reference

GSF.Historian Namespace


QualityExtensions Methods

Grid Solutions Framework QualityExtensions Methods

The QualityExtensions type exposes the following members.

Methods
Name | Description
HistorianQuality | Gets a Quality value from a IMeasurement value.
MeasurementQuality | Gets a MeasurementStateFlags value from a Quality value.
Top
See Also

Reference

QualityExtensions Class
GSF.Historian Namespace


QualityExtensions.HistorianQuality Method

Grid Solutions Framework QualityExtensionsHistorianQuality Method
Gets a Quality value from a IMeasurement value.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Quality HistorianQuality(
    this IMeasurement measurement
)
<ExtensionAttribute>
Public Shared Function HistorianQuality (
    measurement As IMeasurement
) As Quality
static member HistorianQuality :
        measurement : IMeasurement -> Quality

GSF.Historian.QualityExtensions.HistorianQuality = function(measurement);
public:
[ExtensionAttribute]
static Quality HistorianQuality(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement value to interpret.

Return Value

Type: Quality
Quality value from a IMeasurement value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMeasurement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

QualityExtensions Class
GSF.Historian Namespace


QualityExtensions.MeasurementQuality Method

Grid Solutions Framework QualityExtensionsMeasurementQuality Method
Gets a MeasurementStateFlags value from a Quality value.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementStateFlags MeasurementQuality(
    this Quality quality
)
<ExtensionAttribute>
Public Shared Function MeasurementQuality (
    quality As Quality
) As MeasurementStateFlags
static member MeasurementQuality :
        quality : Quality -> MeasurementStateFlags

GSF.Historian.QualityExtensions.MeasurementQuality = function(quality);
public:
[ExtensionAttribute]
static MeasurementStateFlags MeasurementQuality(
    Quality quality
)

Parameters

quality
Type: GSF.HistorianQuality
Quality value to interpret.

Return Value

Type: MeasurementStateFlags
MeasurementStateFlags value from a Quality value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Quality. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

QualityExtensions Class
GSF.Historian Namespace


TimeTag Class

Grid Solutions Framework TimeTag Class
Represents a historian time tag as number of seconds from the BaseDate.
Inheritance Hierarchy
SystemObject
GSFTimeTagBase
GSF.HistorianTimeTag

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TimeTag : TimeTagBase, IComparable<TimeTag>
Public Class TimeTag
    Inherits TimeTagBase
    Implements IComparable(Of TimeTag)
type TimeTag =
    class
        inherit TimeTagBase
        interface IComparable<TimeTag>
    end
GSF.Historian.TimeTag = function();

Type.createClass(
    'GSF.Historian.TimeTag',
    GSF.TimeTagBase,
    IComparable`1);
public ref class TimeTag : public TimeTagBase,
    IComparable<TimeTag^>

The TimeTag type exposes the following members.

Constructors
 | Name | Description
Public method | TimeTag(DateTime) | Initializes a new instance of the TimeTag class.
Public method | TimeTag(Double) | Initializes a new instance of the TimeTag class.
Public method | TimeTag(Int64) | Initializes a new instance of the TimeTag class.
Top
Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime. (Inherited from TimeTagBase.)
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object. (Inherited from TimeTagBase.)
Public method | CompareTo(TimeTag) | Compares this time tag instance to another time tag instance and returns an integer that indicates whether the value of this instance is less than, equal to, or greater than the value of the other time tag.
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from TimeTagBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the specified string representation of a date and time to its TimeTag equivalent.
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString | Returns the default text representation of TimeTag. (Overrides TimeTagBaseToString.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider. (Inherited from TimeTagBase.)
Public method | ToString(String) | Returns textual representation for timetag in the specified format. (Inherited from TimeTagBase.)
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider. (Inherited from TimeTagBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
BaseDate | Represents the base DateTime (01/01/1995) for TimeTag.
MaxValue | Represents the largest possible value of TimeTag.
MinValue | Represents the smallest possible value of TimeTag.
Top
Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation. (Inherited from TimeTagBase.)
 | Now | Gets a TimeTag object that is set to the current date and time on this computer, expressed as the local time.
 | UtcNow | Gets a TimeTag object that is set to the current date and time on this computer, expressed as the Coordinated Universal Time (UTC).
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time. (Inherited from TimeTagBase.)
Top
See Also

Reference

GSF.Historian Namespace


TimeTag Constructor

Grid Solutions Framework TimeTag Constructor
Overload List
 | Name | Description
Public method | TimeTag(DateTime) | Initializes a new instance of the TimeTag class.
Public method | TimeTag(Double) | Initializes a new instance of the TimeTag class.
Public method | TimeTag(Int64) | Initializes a new instance of the TimeTag class.
Top
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag Constructor (DateTime)

Grid Solutions Framework TimeTag Constructor (DateTime)
Initializes a new instance of the TimeTag class.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag(
    DateTime timestamp
)
Public Sub New (
    timestamp As DateTime
)
new :
        timestamp : DateTime -> TimeTag
GSF.Historian.TimeTag = function(timestamp);
public:
TimeTag(
    DateTime timestamp
)

Parameters

timestamp
Type: SystemDateTime
DateTime value on or past the BaseDate.
See Also

Reference

TimeTag Class
TimeTag Overload
GSF.Historian Namespace


TimeTag Constructor (Double)

Grid Solutions Framework TimeTag Constructor (Double)
Initializes a new instance of the TimeTag class.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag(
    double seconds
)
Public Sub New (
    seconds As Double
)
new :
        seconds : float -> TimeTag
GSF.Historian.TimeTag = function(seconds);
public:
TimeTag(
    double seconds
)

Parameters

seconds
Type: SystemDouble
Number of seconds since the BaseDate.
See Also

Reference

TimeTag Class
TimeTag Overload
GSF.Historian Namespace


TimeTag Constructor (Int64)

Grid Solutions Framework TimeTag Constructor (Int64)
Initializes a new instance of the TimeTag class.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag(
    long ticks
)
Public Sub New (
    ticks As Long
)
new :
        ticks : int64 -> TimeTag
GSF.Historian.TimeTag = function(ticks);
public:
TimeTag(
    long long ticks
)

Parameters

ticks
Type: SystemInt64
Number of ticks since the BaseDate.
See Also

Reference

TimeTag Class
TimeTag Overload
GSF.Historian Namespace


TimeTag Fields

Grid Solutions Framework TimeTag Fields

The TimeTag type exposes the following members.

Fields
Name | Description
BaseDate | Represents the base DateTime (01/01/1995) for TimeTag.
MaxValue | Represents the largest possible value of TimeTag.
MinValue | Represents the smallest possible value of TimeTag.
Top
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.BaseDate Field

Grid Solutions Framework TimeTagBaseDate Field
Represents the base DateTime (01/01/1995) for TimeTag.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly DateTime BaseDate
Public Shared ReadOnly BaseDate As DateTime
static val BaseDate: DateTime
var GSF.Historian.TimeTag.BaseDate
public:
static initonly DateTime BaseDate

Field Value

Type: DateTime
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.MaxValue Field

Grid Solutions Framework TimeTagMaxValue Field
Represents the largest possible value of TimeTag.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly TimeTag MaxValue
Public Shared ReadOnly MaxValue As TimeTag
static val MaxValue: TimeTag
var GSF.Historian.TimeTag.MaxValue
public:
static initonly TimeTag^ MaxValue

Field Value

Type: TimeTag
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.MinValue Field

Grid Solutions Framework TimeTagMinValue Field
Represents the smallest possible value of TimeTag.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly TimeTag MinValue
Public Shared ReadOnly MinValue As TimeTag
static val MinValue: TimeTag
var GSF.Historian.TimeTag.MinValue
public:
static initonly TimeTag^ MinValue

Field Value

Type: TimeTag
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag Methods

Grid Solutions Framework TimeTag Methods

The TimeTag type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime. (Inherited from TimeTagBase.)
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object. (Inherited from TimeTagBase.)
Public method | CompareTo(TimeTag) | Compares this time tag instance to another time tag instance and returns an integer that indicates whether the value of this instance is less than, equal to, or greater than the value of the other time tag.
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(DateTime) | Determines whether the specified DateTime is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | Equals(TimeTagBase) | Determines whether the specified TimeTagBase is equal to the current TimeTagBase. (Inherited from TimeTagBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current TimeTagBase. (Inherited from TimeTagBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from TimeTagBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the specified string representation of a date and time to its TimeTag equivalent.
Public method | ToDateTime | Returns standard .NET DateTime representation for timetag. (Inherited from TimeTagBase.)
Public method | ToString | Returns the default text representation of TimeTag. (Overrides TimeTagBaseToString.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider. (Inherited from TimeTagBase.)
Public method | ToString(String) | Returns textual representation for timetag in the specified format. (Inherited from TimeTagBase.)
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider. (Inherited from TimeTagBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.CompareTo Method

Grid Solutions Framework TimeTagCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(DateTime) | Compares the TimeTagBase with a DateTime. (Inherited from TimeTagBase.)
Public method | CompareTo(Object) | Compares the TimeTagBase with the specified Object. (Inherited from TimeTagBase.)
Public method | CompareTo(TimeTag) | Compares this time tag instance to another time tag instance and returns an integer that indicates whether the value of this instance is less than, equal to, or greater than the value of the other time tag.
Public method | CompareTo(TimeTagBase) | Compares the TimeTagBase with another TimeTagBase. (Inherited from TimeTagBase.)
Top
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.CompareTo Method (TimeTag)

Grid Solutions Framework TimeTagCompareTo Method (TimeTag)
Compares this time tag instance to another time tag instance and returns an integer that indicates whether the value of this instance is less than, equal to, or greater than the value of the other time tag.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    TimeTag other
)
Public Function CompareTo (
    other As TimeTag
) As Integer
abstract CompareTo :
        other : TimeTag -> int
override CompareTo :
        other : TimeTag -> int
function CompareTo(other);
public:
virtual int CompareTo(
    TimeTag^ other
) sealed

Parameters

other
Type: GSF.HistorianTimeTag
A TimeTag instance to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and the other value.

Implements

IComparableTCompareTo(T)
Remarks
Time tags are compared by their value.
See Also

Reference

TimeTag Class
CompareTo Overload
GSF.Historian Namespace


TimeTag.Parse Method

Grid Solutions Framework TimeTagParse Method
Converts the specified string representation of a date and time to its TimeTag equivalent.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeTag Parse(
    string timetag
)
Public Shared Function Parse (
    timetag As String
) As TimeTag
static member Parse :
        timetag : string -> TimeTag

GSF.Historian.TimeTag.Parse = function(timetag);
public:
static TimeTag^ Parse(
    String^ timetag
)

Parameters

timetag
Type: SystemString
A string containing the date and time to convert.

Return Value

Type: TimeTag
A TimeTag object.
Remarks
timetag can be specified in one of the following format:
Time Format | Format Description
12-30-2000 23:59:59 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.ToString Method

Grid Solutions Framework TimeTagToString Method
Overload List
 | Name | Description
Public method | ToString | Returns the default text representation of TimeTag. (Overrides TimeTagBaseToString.)
Public method | ToString(IFormatProvider) | Returns textual representation for timetag using the specified provider. (Inherited from TimeTagBase.)
Public method | ToString(String) | Returns textual representation for timetag in the specified format. (Inherited from TimeTagBase.)
Public method | ToString(String, IFormatProvider) | Returns textual representation for timetag in the specified format using the specified provider. (Inherited from TimeTagBase.)
Top
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.ToString Method

Grid Solutions Framework TimeTagToString Method
Returns the default text representation of TimeTag.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
String that represents TimeTag.
See Also

Reference

TimeTag Class
ToString Overload
GSF.Historian Namespace


TimeTag Properties

Grid Solutions Framework TimeTag Properties

The TimeTag type exposes the following members.

Properties
 | Name | Description
Public property | BaseDateOffsetTicks | Gets ticks representing the absolute minimum time of this timetag implementation. (Inherited from TimeTagBase.)
 | Now | Gets a TimeTag object that is set to the current date and time on this computer, expressed as the local time.
 | UtcNow | Gets a TimeTag object that is set to the current date and time on this computer, expressed as the Coordinated Universal Time (UTC).
Public property | Value | Gets or sets number of seconds (including any fractional seconds) since base time. (Inherited from TimeTagBase.)
Top
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.Now Property

Grid Solutions Framework TimeTagNow Property
Gets a TimeTag object that is set to the current date and time on this computer, expressed as the local time.

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeTag Now { get; }
Public Shared ReadOnly Property Now As TimeTag
    Get
static member Now : TimeTag with get

GSF.Historian.TimeTag.get_Now = function();

public:
static property TimeTag^ Now {
    TimeTag^ get ();
}

Property Value

Type: TimeTag
See Also

Reference

TimeTag Class
GSF.Historian Namespace


TimeTag.UtcNow Property

Grid Solutions Framework TimeTagUtcNow Property
Gets a TimeTag object that is set to the current date and time on this computer, expressed as the Coordinated Universal Time (UTC).

Namespace: GSF.Historian
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TimeTag UtcNow { get; }
Public Shared ReadOnly Property UtcNow As TimeTag
    Get
static member UtcNow : TimeTag with get

GSF.Historian.TimeTag.get_UtcNow = function();

public:
static property TimeTag^ UtcNow {
    TimeTag^ get ();
}

Property Value

Type: TimeTag
See Also

Reference

TimeTag Class
GSF.Historian Namespace


GSF.Historian.DataServices Namespace

Grid Solutions Framework GSF.Historian.DataServices Namespace
Contains classes that define the fundamental data web services for a historian.
Classes
 | Class | Description
Public class | DataService | A base class for web service that can send and receive historian data over REST (Representational State Transfer) interface.
Public class | DataServices | A class that loads all of the data web services.
Public class | MetadataService | Represents a REST web service for historian metadata.
 | SerializableMetadata | Represents a container for SerializableMetadataRecords that can be serialized using XmlSerializer or DataContractJsonSerializer.
 | SerializableMetadataRecord | Represents a flattened MetadataRecord that can be serialized using XmlSerializer, DataContractSerializer or DataContractJsonSerializer.
Public class | SerializableReadRequestData | Represents a container for JSON serialized time-series data read request.
 | SerializableTimeSeriesData | Represents a container for SerializableTimeSeriesDataPoints that can be serialized using XmlSerializer or DataContractJsonSerializer.
 | SerializableTimeSeriesDataPoint | Represents a time-series data-point that can be serialized using XmlSerializer, DataContractSerializer or DataContractJsonSerializer.
Public class | TimeSeriesDataService | Represents a REST web service for time-series data.
Interfaces
 | Interface | Description
Public interface | IDataService | Defines a web service that can send and receive historian data over REST (Representational State Transfer) interface.
Public interface | IMetadataService | Defines a REST web service for historian metadata.
Public interface | ITimeSeriesDataService | Defines a REST web service for time-series data.
Enumerations
 | Enumeration | Description
Public enumeration | DataFlowDirection | Indicates the direction in which data will be flowing from a web service.


DataFlowDirection Enumeration

Grid Solutions Framework DataFlowDirection Enumeration
Indicates the direction in which data will be flowing from a web service.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DataFlowDirection
Public Enumeration DataFlowDirection
type DataFlowDirection
GSF.Historian.DataServices.DataFlowDirection = function();
GSF.Historian.DataServices.DataFlowDirection.createEnum('GSF.Historian.DataServices.DataFlowDirection', false);
public enum class DataFlowDirection
Members
Member name | Value | Description
Incoming | 0 | Data will be flowing in to the web service.
Outgoing | 1 | Data will be flowing out from the web service.
BothWays | 2 | Data will be flowing both in and out from the web service.
See Also

Reference

GSF.Historian.DataServices Namespace


DataService Class

Grid Solutions Framework DataService Class
A base class for web service that can send and receive historian data over REST (Representational State Transfer) interface.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.ServiceModelSelfHostingService
GSF.Historian.DataServicesDataService
GSF.Historian.DataServicesMetadataService
GSF.Historian.DataServicesTimeSeriesDataService

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataService : SelfHostingService,
    IDataService, ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
Public Class DataService
    Inherits SelfHostingService
    Implements IDataService, ISelfHostingService, IAdapter, ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings
type DataService =
    class
        inherit SelfHostingService
        interface IDataService
        interface ISelfHostingService
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.DataServices.DataService = function();

Type.createClass(
    'GSF.Historian.DataServices.DataService',
    GSF.ServiceModel.SelfHostingService,
    GSF.Historian.DataServices.IDataService,
    GSF.ServiceModel.ISelfHostingService,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
public ref class DataService : public SelfHostingService,
    IDataService, ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings

The DataService type exposes the following members.

Constructors
 | Name | Description
Protected method | DataService | Initializes a new instance of historian data web service.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Overrides SelfHostingServiceOnServiceHostCreated.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | Archive | Gets or sets the IArchive used by the web service for its data.
Public property | CloseTimeout | Gets or sets the desired CloseTimeout used as the interval of time provided for a connection to close before the transport raises an exception.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.DataServices Namespace


DataService Constructor

Grid Solutions Framework DataService Constructor
Initializes a new instance of historian data web service.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataService()
Protected Sub New
new : unit -> DataService
GSF.Historian.DataServices.DataService = function();
protected:
DataService()
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService Methods

Grid Solutions Framework DataService Methods

The DataService type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Overrides SelfHostingServiceOnServiceHostCreated.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService.LoadSettings Method

Grid Solutions Framework DataServiceLoadSettings Method
Loads saved web service settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService.OnServiceHostCreated Method

Grid Solutions Framework DataServiceOnServiceHostCreated Method
Raises the ServiceHostCreated event.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnServiceHostCreated()
Protected Overrides Sub OnServiceHostCreated
abstract OnServiceHostCreated : unit -> unit
override OnServiceHostCreated : unit -> unit
function OnServiceHostCreated();
protected:
virtual void OnServiceHostCreated() override
Remarks
We override default behavior to update the default close timeout and to make sure the maximum number of items are allowed in the returned graph.
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService.SaveSettings Method

Grid Solutions Framework DataServiceSaveSettings Method
Saves web service settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService Properties

Grid Solutions Framework DataService Properties

The DataService type exposes the following members.

Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | Archive | Gets or sets the IArchive used by the web service for its data.
Public property | CloseTimeout | Gets or sets the desired CloseTimeout used as the interval of time provided for a connection to close before the transport raises an exception.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService.Archive Property

Grid Solutions Framework DataServiceArchive Property
Gets or sets the IArchive used by the web service for its data.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IArchive Archive { get; set; }
Public Property Archive As IArchive
    Get
    Set
abstract Archive : IArchive with get, set
override Archive : IArchive with get, set
function get_Archive();
function set_Archive(value);
public:
virtual property IArchive^ Archive {
    IArchive^ get () sealed;
    void set (IArchive^ value) sealed;
}

Property Value

Type: IArchive

Implements

IDataServiceArchive
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService.CloseTimeout Property

Grid Solutions Framework DataServiceCloseTimeout Property
Gets or sets the desired CloseTimeout used as the interval of time provided for a connection to close before the transport raises an exception.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeSpan CloseTimeout { get; set; }
Public Property CloseTimeout As TimeSpan
    Get
    Set
member CloseTimeout : TimeSpan with get, set

function get_CloseTimeout();
function set_CloseTimeout(value);
public:
property TimeSpan CloseTimeout {
    TimeSpan get ();
    void set (TimeSpan value);
}

Property Value

Type: TimeSpan
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataService Events

Grid Solutions Framework DataService Events

The DataService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

DataService Class
GSF.Historian.DataServices Namespace


DataServices Class

Grid Solutions Framework DataServices Class
A class that loads all of the data web services.
Inheritance Hierarchy
SystemObject
GSF.AdaptersAdapterLoader IDataService
GSF.Historian.DataServicesDataServices

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataServices : AdapterLoader<IDataService>
Public Class DataServices
    Inherits AdapterLoader(Of IDataService)
type DataServices =
    class
        inherit AdapterLoader<IDataService>
    end
GSF.Historian.DataServices.DataServices = function();

Type.createClass(
    'GSF.Historian.DataServices.DataServices',
    GSF.Adapters.AdapterLoader`1);
public ref class DataServices : public AdapterLoader<IDataService^>

The DataServices type exposes the following members.

Constructors
 | Name | Description
Public method | DataServices | Initializes a new instance of the DataServices class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data. (Inherited from AdapterLoaderT.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

GSF.Historian.DataServices Namespace


DataServices Constructor

Grid Solutions Framework DataServices Constructor
Initializes a new instance of the DataServices class

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataServices()
Public Sub New
new : unit -> DataServices
GSF.Historian.DataServices.DataServices = function();
public:
DataServices()
See Also

Reference

DataServices Class
GSF.Historian.DataServices Namespace


DataServices Methods

Grid Solutions Framework DataServices Methods

The DataServices type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data. (Inherited from AdapterLoaderT.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataServices Class
GSF.Historian.DataServices Namespace


DataServices Properties

Grid Solutions Framework DataServices Properties

The DataServices type exposes the following members.

Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

DataServices Class
GSF.Historian.DataServices Namespace


DataServices Events

Grid Solutions Framework DataServices Events

The DataServices type exposes the following members.

Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

DataServices Class
GSF.Historian.DataServices Namespace


IDataService Interface

Grid Solutions Framework IDataService Interface
Defines a web service that can send and receive historian data over REST (Representational State Transfer) interface.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDataService : ISelfHostingService,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
Public Interface IDataService
    Inherits ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
type IDataService =
    interface
        interface ISelfHostingService
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.DataServices.IDataService = function();
GSF.Historian.DataServices.IDataService.createInterface('GSF.Historian.DataServices.IDataService');
public interface class IDataService : ISelfHostingService,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The IDataService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | Archive | Gets or sets the IArchive used by the web service for its data.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from ISelfHostingService.)
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from ISelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | ServiceHost | Gets the ServiceHost hosting the web service. (Inherited from ISelfHostingService.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from ISelfHostingService.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from ISelfHostingService.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.Historian.DataServices Namespace


IDataService Methods

Grid Solutions Framework IDataService Methods

The IDataService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

IDataService Interface
GSF.Historian.DataServices Namespace


IDataService Properties

Grid Solutions Framework IDataService Properties

The IDataService type exposes the following members.

Properties
 | Name | Description
Public property | Archive | Gets or sets the IArchive used by the web service for its data.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from ISelfHostingService.)
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from ISelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | ServiceHost | Gets the ServiceHost hosting the web service. (Inherited from ISelfHostingService.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from ISelfHostingService.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

IDataService Interface
GSF.Historian.DataServices Namespace


IDataService.Archive Property

Grid Solutions Framework IDataServiceArchive Property
Gets or sets the IArchive used by the web service for its data.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IArchive Archive { get; set; }
Property Archive As IArchive
    Get
    Set
abstract Archive : IArchive with get, set

function get_Archive();
function set_Archive(value);
property IArchive^ Archive {
    IArchive^ get ();
    void set (IArchive^ value);
}

Property Value

Type: IArchive
See Also

Reference

IDataService Interface
GSF.Historian.DataServices Namespace


IDataService Events

Grid Solutions Framework IDataService Events

The IDataService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from ISelfHostingService.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

IDataService Interface
GSF.Historian.DataServices Namespace


IMetadataService Interface

Grid Solutions Framework IMetadataService Interface
Defines a REST web service for historian metadata.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceContractAttribute]
public interface IMetadataService
<ServiceContractAttribute>
Public Interface IMetadataService
[<ServiceContractAttribute>]
type IMetadataService =  interface end
GSF.Historian.DataServices.IMetadataService = function();
GSF.Historian.DataServices.IMetadataService.createInterface('GSF.Historian.DataServices.IMetadataService');
[ServiceContractAttribute]
public interface class IMetadataService

The IMetadataService type exposes the following members.

Methods
 | Name | Description
Public method | ReadAllMetadataAsJson | Reads all metadata from the Archive and sends it in Json format.
Public method | ReadAllMetadataAsXml | Reads all metadata from the Archive and sends it in Xml format.
Public method | ReadRangeMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadRangeMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | ReadSelectMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadSelectMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | WriteMetadataAsJson | Writes metadata received in Json format to the Archive.
Public method | WriteMetadataAsXml | Writes metadata received in Xml format to the Archive.
Top
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.Historian.DataServicesSerializableMetadata


IMetadataService Methods

Grid Solutions Framework IMetadataService Methods

The IMetadataService type exposes the following members.

Methods
 | Name | Description
Public method | ReadAllMetadataAsJson | Reads all metadata from the Archive and sends it in Json format.
Public method | ReadAllMetadataAsXml | Reads all metadata from the Archive and sends it in Xml format.
Public method | ReadRangeMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadRangeMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | ReadSelectMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadSelectMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | WriteMetadataAsJson | Writes metadata received in Json format to the Archive.
Public method | WriteMetadataAsXml | Writes metadata received in Xml format to the Archive.
Top
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.ReadAllMetadataAsJson Method

Grid Solutions Framework IMetadataServiceReadAllMetadataAsJson Method
Reads all metadata from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/metadata/read/json")]
SerializableMetadata ReadAllMetadataAsJson()
<OperationContractAttribute>
<WebGetAttribute(ResponseFormat := WebMessageFormat.Json, UriTemplate := "/metadata/read/json")>
Function ReadAllMetadataAsJson As SerializableMetadata
[<OperationContractAttribute>]
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/metadata/read/json")>]
abstract ReadAllMetadataAsJson : unit -> SerializableMetadata

function ReadAllMetadataAsJson();
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat::Json, UriTemplate = L"/metadata/read/json")]
SerializableMetadata^ ReadAllMetadataAsJson()

Return Value

Type: SerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.ReadAllMetadataAsXml Method

Grid Solutions Framework IMetadataServiceReadAllMetadataAsXml Method
Reads all metadata from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/metadata/read/xml")]
SerializableMetadata ReadAllMetadataAsXml()
<OperationContractAttribute>
<WebGetAttribute(ResponseFormat := WebMessageFormat.Xml, UriTemplate := "/metadata/read/xml")>
Function ReadAllMetadataAsXml As SerializableMetadata
[<OperationContractAttribute>]
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/metadata/read/xml")>]
abstract ReadAllMetadataAsXml : unit -> SerializableMetadata

function ReadAllMetadataAsXml();
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat::Xml, UriTemplate = L"/metadata/read/xml")]
SerializableMetadata^ ReadAllMetadataAsXml()

Return Value

Type: SerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.ReadRangeMetadataAsJson Method

Grid Solutions Framework IMetadataServiceReadRangeMetadataAsJson Method
Reads a subset of metadata from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/metadata/read/{fromID}-{toID}/json")]
[OperationContractAttribute]
SerializableMetadata ReadRangeMetadataAsJson(
    string fromID,
    string toID
)
<WebGetAttribute(ResponseFormat := WebMessageFormat.Json, UriTemplate := "/metadata/read/{fromID}-{toID}/json")>
<OperationContractAttribute>
Function ReadRangeMetadataAsJson (
    fromID As String,
    toID As String
) As SerializableMetadata
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/metadata/read/{fromID}-{toID}/json")>]
[<OperationContractAttribute>]
abstract ReadRangeMetadataAsJson :
        fromID : string *
        toID : string -> SerializableMetadata

function ReadRangeMetadataAsJson(fromID, toID);
[WebGetAttribute(ResponseFormat = WebMessageFormat::Json, UriTemplate = L"/metadata/read/{fromID}-{toID}/json")]
[OperationContractAttribute]
SerializableMetadata^ ReadRangeMetadataAsJson(
    String^ fromID,
    String^ toID
)

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which metadata is to be read.
toID
Type: SystemString
Ending ID in the ID range for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.ReadRangeMetadataAsXml Method

Grid Solutions Framework IMetadataServiceReadRangeMetadataAsXml Method
Reads a subset of metadata from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/metadata/read/{fromID}-{toID}/xml")]
[OperationContractAttribute]
SerializableMetadata ReadRangeMetadataAsXml(
    string fromID,
    string toID
)
<WebGetAttribute(ResponseFormat := WebMessageFormat.Xml, UriTemplate := "/metadata/read/{fromID}-{toID}/xml")>
<OperationContractAttribute>
Function ReadRangeMetadataAsXml (
    fromID As String,
    toID As String
) As SerializableMetadata
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/metadata/read/{fromID}-{toID}/xml")>]
[<OperationContractAttribute>]
abstract ReadRangeMetadataAsXml :
        fromID : string *
        toID : string -> SerializableMetadata

function ReadRangeMetadataAsXml(fromID, toID);
[WebGetAttribute(ResponseFormat = WebMessageFormat::Xml, UriTemplate = L"/metadata/read/{fromID}-{toID}/xml")]
[OperationContractAttribute]
SerializableMetadata^ ReadRangeMetadataAsXml(
    String^ fromID,
    String^ toID
)

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which metadata is to be read.
toID
Type: SystemString
Ending ID in the ID range for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.ReadSelectMetadataAsJson Method

Grid Solutions Framework IMetadataServiceReadSelectMetadataAsJson Method
Reads a subset of metadata from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/metadata/read/{idList}/json")]
SerializableMetadata ReadSelectMetadataAsJson(
    string idList
)
<OperationContractAttribute>
<WebGetAttribute(ResponseFormat := WebMessageFormat.Json, UriTemplate := "/metadata/read/{idList}/json")>
Function ReadSelectMetadataAsJson (
    idList As String
) As SerializableMetadata
[<OperationContractAttribute>]
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/metadata/read/{idList}/json")>]
abstract ReadSelectMetadataAsJson :
        idList : string -> SerializableMetadata

function ReadSelectMetadataAsJson(idList);
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat::Json, UriTemplate = L"/metadata/read/{idList}/json")]
SerializableMetadata^ ReadSelectMetadataAsJson(
    String^ idList
)

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.ReadSelectMetadataAsXml Method

Grid Solutions Framework IMetadataServiceReadSelectMetadataAsXml Method
Reads a subset of metadata from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/metadata/read/{idList}/xml")]
[OperationContractAttribute]
SerializableMetadata ReadSelectMetadataAsXml(
    string idList
)
<WebGetAttribute(ResponseFormat := WebMessageFormat.Xml, UriTemplate := "/metadata/read/{idList}/xml")>
<OperationContractAttribute>
Function ReadSelectMetadataAsXml (
    idList As String
) As SerializableMetadata
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/metadata/read/{idList}/xml")>]
[<OperationContractAttribute>]
abstract ReadSelectMetadataAsXml :
        idList : string -> SerializableMetadata

function ReadSelectMetadataAsXml(idList);
[WebGetAttribute(ResponseFormat = WebMessageFormat::Xml, UriTemplate = L"/metadata/read/{idList}/xml")]
[OperationContractAttribute]
SerializableMetadata^ ReadSelectMetadataAsXml(
    String^ idList
)

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.WriteMetadataAsJson Method

Grid Solutions Framework IMetadataServiceWriteMetadataAsJson Method
Writes metadata received in Json format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Json,
    UriTemplate = "/metadata/write/json")]
[OperationContractAttribute]
void WriteMetadataAsJson(
    SerializableMetadata metadata
)
<WebInvokeAttribute(Method := "POST", RequestFormat := WebMessageFormat.Json,
    UriTemplate := "/metadata/write/json")>
<OperationContractAttribute>
Sub WriteMetadataAsJson (
    metadata As SerializableMetadata
)
[<WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Json,
    UriTemplate = "/metadata/write/json")>]
[<OperationContractAttribute>]
abstract WriteMetadataAsJson :
        metadata : SerializableMetadata -> unit

function WriteMetadataAsJson(metadata);
[WebInvokeAttribute(Method = L"POST", RequestFormat = WebMessageFormat::Json,
    UriTemplate = L"/metadata/write/json")]
[OperationContractAttribute]
void WriteMetadataAsJson(
    SerializableMetadata^ metadata
)

Parameters

metadata
Type: GSF.Historian.DataServicesSerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


IMetadataService.WriteMetadataAsXml Method

Grid Solutions Framework IMetadataServiceWriteMetadataAsXml Method
Writes metadata received in Xml format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Xml,
    UriTemplate = "/metadata/write/xml")]
void WriteMetadataAsXml(
    SerializableMetadata metadata
)
<OperationContractAttribute>
<WebInvokeAttribute(Method := "POST", RequestFormat := WebMessageFormat.Xml,
    UriTemplate := "/metadata/write/xml")>
Sub WriteMetadataAsXml (
    metadata As SerializableMetadata
)
[<OperationContractAttribute>]
[<WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Xml,
    UriTemplate = "/metadata/write/xml")>]
abstract WriteMetadataAsXml :
        metadata : SerializableMetadata -> unit

function WriteMetadataAsXml(metadata);
[OperationContractAttribute]
[WebInvokeAttribute(Method = L"POST", RequestFormat = WebMessageFormat::Xml,
    UriTemplate = L"/metadata/write/xml")]
void WriteMetadataAsXml(
    SerializableMetadata^ metadata
)

Parameters

metadata
Type: GSF.Historian.DataServicesSerializableMetadata
An SerializableMetadata object.
See Also

Reference

IMetadataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService Interface

Grid Solutions Framework ITimeSeriesDataService Interface
Defines a REST web service for time-series data.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceContractAttribute]
public interface ITimeSeriesDataService
<ServiceContractAttribute>
Public Interface ITimeSeriesDataService
[<ServiceContractAttribute>]
type ITimeSeriesDataService =  interface end
GSF.Historian.DataServices.ITimeSeriesDataService = function();
GSF.Historian.DataServices.ITimeSeriesDataService.createInterface('GSF.Historian.DataServices.ITimeSeriesDataService');
[ServiceContractAttribute]
public interface class ITimeSeriesDataService

The ITimeSeriesDataService type exposes the following members.

Methods
 | Name | Description
Public method | ReadRangeCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadRangeCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadRangeHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadRangeHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadSelectCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsJsonPost | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | WriteTimeSeriesDataAsJson | Writes data received in Json format to the Archive.
Public method | WriteTimeSeriesDataAsXml | Writes data received in Xml format to the Archive.
Top
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.Historian.DataServicesSerializableTimeSeriesData


ITimeSeriesDataService Methods

Grid Solutions Framework ITimeSeriesDataService Methods

The ITimeSeriesDataService type exposes the following members.

Methods
 | Name | Description
Public method | ReadRangeCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadRangeCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadRangeHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadRangeHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadSelectCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsJsonPost | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | WriteTimeSeriesDataAsJson | Writes data received in Json format to the Archive.
Public method | WriteTimeSeriesDataAsXml | Writes data received in Xml format to the Archive.
Top
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadRangeCurrentTimeSeriesDataAsJson Method

Grid Solutions Framework ITimeSeriesDataServiceReadRangeCurrentTimeSeriesDataAsJson Method
Reads current time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/current/{fromID}-{toID}/json")]
SerializableTimeSeriesData ReadRangeCurrentTimeSeriesDataAsJson(
    string fromID,
    string toID
)
<OperationContractAttribute>
<WebGetAttribute(ResponseFormat := WebMessageFormat.Json, UriTemplate := "/timeseriesdata/read/current/{fromID}-{toID}/json")>
Function ReadRangeCurrentTimeSeriesDataAsJson (
    fromID As String,
    toID As String
) As SerializableTimeSeriesData
[<OperationContractAttribute>]
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/current/{fromID}-{toID}/json")>]
abstract ReadRangeCurrentTimeSeriesDataAsJson :
        fromID : string *
        toID : string -> SerializableTimeSeriesData

function ReadRangeCurrentTimeSeriesDataAsJson(fromID, toID);
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat::Json, UriTemplate = L"/timeseriesdata/read/current/{fromID}-{toID}/json")]
SerializableTimeSeriesData^ ReadRangeCurrentTimeSeriesDataAsJson(
    String^ fromID,
    String^ toID
)

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which current time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadRangeCurrentTimeSeriesDataAsXml Method

Grid Solutions Framework ITimeSeriesDataServiceReadRangeCurrentTimeSeriesDataAsXml Method
Reads current time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/current/{fromID}-{toID}/xml")]
[OperationContractAttribute]
SerializableTimeSeriesData ReadRangeCurrentTimeSeriesDataAsXml(
    string fromID,
    string toID
)
<WebGetAttribute(ResponseFormat := WebMessageFormat.Xml, UriTemplate := "/timeseriesdata/read/current/{fromID}-{toID}/xml")>
<OperationContractAttribute>
Function ReadRangeCurrentTimeSeriesDataAsXml (
    fromID As String,
    toID As String
) As SerializableTimeSeriesData
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/current/{fromID}-{toID}/xml")>]
[<OperationContractAttribute>]
abstract ReadRangeCurrentTimeSeriesDataAsXml :
        fromID : string *
        toID : string -> SerializableTimeSeriesData

function ReadRangeCurrentTimeSeriesDataAsXml(fromID, toID);
[WebGetAttribute(ResponseFormat = WebMessageFormat::Xml, UriTemplate = L"/timeseriesdata/read/current/{fromID}-{toID}/xml")]
[OperationContractAttribute]
SerializableTimeSeriesData^ ReadRangeCurrentTimeSeriesDataAsXml(
    String^ fromID,
    String^ toID
)

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which current time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadRangeHistoricTimeSeriesDataAsJson Method

Grid Solutions Framework ITimeSeriesDataServiceReadRangeHistoricTimeSeriesDataAsJson Method
Reads historic time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/json")]
[OperationContractAttribute]
SerializableTimeSeriesData ReadRangeHistoricTimeSeriesDataAsJson(
    string fromID,
    string toID,
    string startTime,
    string endTime
)
<WebGetAttribute(ResponseFormat := WebMessageFormat.Json, UriTemplate := "/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/json")>
<OperationContractAttribute>
Function ReadRangeHistoricTimeSeriesDataAsJson (
    fromID As String,
    toID As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/json")>]
[<OperationContractAttribute>]
abstract ReadRangeHistoricTimeSeriesDataAsJson :
        fromID : string *
        toID : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData

function ReadRangeHistoricTimeSeriesDataAsJson(fromID, toID, startTime, endTime);
[WebGetAttribute(ResponseFormat = WebMessageFormat::Json, UriTemplate = L"/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/json")]
[OperationContractAttribute]
SerializableTimeSeriesData^ ReadRangeHistoricTimeSeriesDataAsJson(
    String^ fromID,
    String^ toID,
    String^ startTime,
    String^ endTime
)

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which historic time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadRangeHistoricTimeSeriesDataAsXml Method

Grid Solutions Framework ITimeSeriesDataServiceReadRangeHistoricTimeSeriesDataAsXml Method
Reads historic time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/xml")]
[OperationContractAttribute]
SerializableTimeSeriesData ReadRangeHistoricTimeSeriesDataAsXml(
    string fromID,
    string toID,
    string startTime,
    string endTime
)
<WebGetAttribute(ResponseFormat := WebMessageFormat.Xml, UriTemplate := "/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/xml")>
<OperationContractAttribute>
Function ReadRangeHistoricTimeSeriesDataAsXml (
    fromID As String,
    toID As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/xml")>]
[<OperationContractAttribute>]
abstract ReadRangeHistoricTimeSeriesDataAsXml :
        fromID : string *
        toID : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData

function ReadRangeHistoricTimeSeriesDataAsXml(fromID, toID, startTime, endTime);
[WebGetAttribute(ResponseFormat = WebMessageFormat::Xml, UriTemplate = L"/timeseriesdata/read/historic/{fromID}-{toID}/{startTime}/{endTime}/xml")]
[OperationContractAttribute]
SerializableTimeSeriesData^ ReadRangeHistoricTimeSeriesDataAsXml(
    String^ fromID,
    String^ toID,
    String^ startTime,
    String^ endTime
)

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which historic time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadSelectCurrentTimeSeriesDataAsJson Method

Grid Solutions Framework ITimeSeriesDataServiceReadSelectCurrentTimeSeriesDataAsJson Method
Reads current time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/current/{idList}/json")]
SerializableTimeSeriesData ReadSelectCurrentTimeSeriesDataAsJson(
    string idList
)
<OperationContractAttribute>
<WebGetAttribute(ResponseFormat := WebMessageFormat.Json, UriTemplate := "/timeseriesdata/read/current/{idList}/json")>
Function ReadSelectCurrentTimeSeriesDataAsJson (
    idList As String
) As SerializableTimeSeriesData
[<OperationContractAttribute>]
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/current/{idList}/json")>]
abstract ReadSelectCurrentTimeSeriesDataAsJson :
        idList : string -> SerializableTimeSeriesData

function ReadSelectCurrentTimeSeriesDataAsJson(idList);
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat::Json, UriTemplate = L"/timeseriesdata/read/current/{idList}/json")]
SerializableTimeSeriesData^ ReadSelectCurrentTimeSeriesDataAsJson(
    String^ idList
)

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadSelectCurrentTimeSeriesDataAsXml Method

Grid Solutions Framework ITimeSeriesDataServiceReadSelectCurrentTimeSeriesDataAsXml Method
Reads current time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/current/{idList}/xml")]
SerializableTimeSeriesData ReadSelectCurrentTimeSeriesDataAsXml(
    string idList
)
<OperationContractAttribute>
<WebGetAttribute(ResponseFormat := WebMessageFormat.Xml, UriTemplate := "/timeseriesdata/read/current/{idList}/xml")>
Function ReadSelectCurrentTimeSeriesDataAsXml (
    idList As String
) As SerializableTimeSeriesData
[<OperationContractAttribute>]
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/current/{idList}/xml")>]
abstract ReadSelectCurrentTimeSeriesDataAsXml :
        idList : string -> SerializableTimeSeriesData

function ReadSelectCurrentTimeSeriesDataAsXml(idList);
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat::Xml, UriTemplate = L"/timeseriesdata/read/current/{idList}/xml")]
SerializableTimeSeriesData^ ReadSelectCurrentTimeSeriesDataAsXml(
    String^ idList
)

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadSelectHistoricTimeSeriesDataAsJson Method

Grid Solutions Framework ITimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsJson Method
Reads historic time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/json")]
[OperationContractAttribute]
SerializableTimeSeriesData ReadSelectHistoricTimeSeriesDataAsJson(
    string idList,
    string startTime,
    string endTime
)
<WebGetAttribute(ResponseFormat := WebMessageFormat.Json, UriTemplate := "/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/json")>
<OperationContractAttribute>
Function ReadSelectHistoricTimeSeriesDataAsJson (
    idList As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Json, UriTemplate = "/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/json")>]
[<OperationContractAttribute>]
abstract ReadSelectHistoricTimeSeriesDataAsJson :
        idList : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData

function ReadSelectHistoricTimeSeriesDataAsJson(idList, startTime, endTime);
[WebGetAttribute(ResponseFormat = WebMessageFormat::Json, UriTemplate = L"/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/json")]
[OperationContractAttribute]
SerializableTimeSeriesData^ ReadSelectHistoricTimeSeriesDataAsJson(
    String^ idList,
    String^ startTime,
    String^ endTime
)

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadSelectHistoricTimeSeriesDataAsJsonPost Method

Grid Solutions Framework ITimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsJsonPost Method
Reads historic time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebInvokeAttribute(Method = "POST", ResponseFormat = WebMessageFormat.Json,
    UriTemplate = "/timeseriesdata/read/historic/json")]
SerializableTimeSeriesData ReadSelectHistoricTimeSeriesDataAsJsonPost(
    SerializableReadRequestData data
)
<OperationContractAttribute>
<WebInvokeAttribute(Method := "POST", ResponseFormat := WebMessageFormat.Json,
    UriTemplate := "/timeseriesdata/read/historic/json")>
Function ReadSelectHistoricTimeSeriesDataAsJsonPost (
    data As SerializableReadRequestData
) As SerializableTimeSeriesData
[<OperationContractAttribute>]
[<WebInvokeAttribute(Method = "POST", ResponseFormat = WebMessageFormat.Json,
    UriTemplate = "/timeseriesdata/read/historic/json")>]
abstract ReadSelectHistoricTimeSeriesDataAsJsonPost :
        data : SerializableReadRequestData -> SerializableTimeSeriesData

function ReadSelectHistoricTimeSeriesDataAsJsonPost(data);
[OperationContractAttribute]
[WebInvokeAttribute(Method = L"POST", ResponseFormat = WebMessageFormat::Json,
    UriTemplate = L"/timeseriesdata/read/historic/json")]
SerializableTimeSeriesData^ ReadSelectHistoricTimeSeriesDataAsJsonPost(
    SerializableReadRequestData^ data
)

Parameters

data
Type: GSF.Historian.DataServicesSerializableReadRequestData
JSON serialized post request.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.ReadSelectHistoricTimeSeriesDataAsXml Method

Grid Solutions Framework ITimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsXml Method
Reads historic time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/xml")]
SerializableTimeSeriesData ReadSelectHistoricTimeSeriesDataAsXml(
    string idList,
    string startTime,
    string endTime
)
<OperationContractAttribute>
<WebGetAttribute(ResponseFormat := WebMessageFormat.Xml, UriTemplate := "/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/xml")>
Function ReadSelectHistoricTimeSeriesDataAsXml (
    idList As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
[<OperationContractAttribute>]
[<WebGetAttribute(ResponseFormat = WebMessageFormat.Xml, UriTemplate = "/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/xml")>]
abstract ReadSelectHistoricTimeSeriesDataAsXml :
        idList : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData

function ReadSelectHistoricTimeSeriesDataAsXml(idList, startTime, endTime);
[OperationContractAttribute]
[WebGetAttribute(ResponseFormat = WebMessageFormat::Xml, UriTemplate = L"/timeseriesdata/read/historic/{idList}/{startTime}/{endTime}/xml")]
SerializableTimeSeriesData^ ReadSelectHistoricTimeSeriesDataAsXml(
    String^ idList,
    String^ startTime,
    String^ endTime
)

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.WriteTimeSeriesDataAsJson Method

Grid Solutions Framework ITimeSeriesDataServiceWriteTimeSeriesDataAsJson Method
Writes data received in Json format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Json,
    UriTemplate = "/timeseriesdata/write/json")]
[OperationContractAttribute]
void WriteTimeSeriesDataAsJson(
    SerializableTimeSeriesData data
)
<WebInvokeAttribute(Method := "POST", RequestFormat := WebMessageFormat.Json,
    UriTemplate := "/timeseriesdata/write/json")>
<OperationContractAttribute>
Sub WriteTimeSeriesDataAsJson (
    data As SerializableTimeSeriesData
)
[<WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Json,
    UriTemplate = "/timeseriesdata/write/json")>]
[<OperationContractAttribute>]
abstract WriteTimeSeriesDataAsJson :
        data : SerializableTimeSeriesData -> unit

function WriteTimeSeriesDataAsJson(data);
[WebInvokeAttribute(Method = L"POST", RequestFormat = WebMessageFormat::Json,
    UriTemplate = L"/timeseriesdata/write/json")]
[OperationContractAttribute]
void WriteTimeSeriesDataAsJson(
    SerializableTimeSeriesData^ data
)

Parameters

data
Type: GSF.Historian.DataServicesSerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


ITimeSeriesDataService.WriteTimeSeriesDataAsXml Method

Grid Solutions Framework ITimeSeriesDataServiceWriteTimeSeriesDataAsXml Method
Writes data received in Xml format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Xml,
    UriTemplate = "/timeseriesdata/write/xml")]
[OperationContractAttribute]
void WriteTimeSeriesDataAsXml(
    SerializableTimeSeriesData data
)
<WebInvokeAttribute(Method := "POST", RequestFormat := WebMessageFormat.Xml,
    UriTemplate := "/timeseriesdata/write/xml")>
<OperationContractAttribute>
Sub WriteTimeSeriesDataAsXml (
    data As SerializableTimeSeriesData
)
[<WebInvokeAttribute(Method = "POST", RequestFormat = WebMessageFormat.Xml,
    UriTemplate = "/timeseriesdata/write/xml")>]
[<OperationContractAttribute>]
abstract WriteTimeSeriesDataAsXml :
        data : SerializableTimeSeriesData -> unit

function WriteTimeSeriesDataAsXml(data);
[WebInvokeAttribute(Method = L"POST", RequestFormat = WebMessageFormat::Xml,
    UriTemplate = L"/timeseriesdata/write/xml")]
[OperationContractAttribute]
void WriteTimeSeriesDataAsXml(
    SerializableTimeSeriesData^ data
)

Parameters

data
Type: GSF.Historian.DataServicesSerializableTimeSeriesData
An SerializableTimeSeriesData object.
See Also

Reference

ITimeSeriesDataService Interface
GSF.Historian.DataServices Namespace


MetadataService Class

Grid Solutions Framework MetadataService Class
Represents a REST web service for historian metadata.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.ServiceModelSelfHostingService
GSF.Historian.DataServicesDataService
GSF.Historian.DataServicesMetadataService

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, ConcurrencyMode = ConcurrencyMode.Multiple)]
public class MetadataService : DataService,
    IMetadataService
<ServiceBehaviorAttribute(InstanceContextMode := InstanceContextMode.Single, ConcurrencyMode := ConcurrencyMode.Multiple)>
Public Class MetadataService
    Inherits DataService
    Implements IMetadataService
[<ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, ConcurrencyMode = ConcurrencyMode.Multiple)>]
type MetadataService =
    class
        inherit DataService
        interface IMetadataService
    end
GSF.Historian.DataServices.MetadataService = function();

Type.createClass(
    'GSF.Historian.DataServices.MetadataService',
    GSF.Historian.DataServices.DataService,
    GSF.Historian.DataServices.IMetadataService);
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode::Single, ConcurrencyMode = ConcurrencyMode::Multiple)]
public ref class MetadataService : public DataService,
    IMetadataService

The MetadataService type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataService | Initializes a new instance of the MetadataService class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Inherited from DataService.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | ReadAllMetadataAsJson | Reads all metadata from the Archive and sends it in Json format.
Public method | ReadAllMetadataAsXml | Reads all metadata from the Archive and sends it in Xml format.
Public method | ReadRangeMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadRangeMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | ReadSelectMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadSelectMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteMetadataAsJson | Writes metadata received in Json format to the Archive.
Public method | WriteMetadataAsXml | Writes metadata received in Xml format to the Archive.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | Archive | Gets or sets the IArchive used by the web service for its data. (Inherited from DataService.)
Public property | CloseTimeout | Gets or sets the desired CloseTimeout used as the interval of time provided for a connection to close before the transport raises an exception. (Inherited from DataService.)
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.Historian.DataServicesSerializableMetadata


MetadataService Constructor

Grid Solutions Framework MetadataService Constructor
Initializes a new instance of the MetadataService class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataService()
Public Sub New
new : unit -> MetadataService
GSF.Historian.DataServices.MetadataService = function();
public:
MetadataService()
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService Methods

Grid Solutions Framework MetadataService Methods

The MetadataService type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Inherited from DataService.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | ReadAllMetadataAsJson | Reads all metadata from the Archive and sends it in Json format.
Public method | ReadAllMetadataAsXml | Reads all metadata from the Archive and sends it in Xml format.
Public method | ReadRangeMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadRangeMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | ReadSelectMetadataAsJson | Reads a subset of metadata from the Archive and sends it in Json format.
Public method | ReadSelectMetadataAsXml | Reads a subset of metadata from the Archive and sends it in Xml format.
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteMetadataAsJson | Writes metadata received in Json format to the Archive.
Public method | WriteMetadataAsXml | Writes metadata received in Xml format to the Archive.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.ReadAllMetadataAsJson Method

Grid Solutions Framework MetadataServiceReadAllMetadataAsJson Method
Reads all metadata from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata ReadAllMetadataAsJson()
Public Function ReadAllMetadataAsJson As SerializableMetadata
abstract ReadAllMetadataAsJson : unit -> SerializableMetadata
override ReadAllMetadataAsJson : unit -> SerializableMetadata
function ReadAllMetadataAsJson();
public:
virtual SerializableMetadata^ ReadAllMetadataAsJson() sealed

Return Value

Type: SerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceReadAllMetadataAsJson
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.ReadAllMetadataAsXml Method

Grid Solutions Framework MetadataServiceReadAllMetadataAsXml Method
Reads all metadata from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata ReadAllMetadataAsXml()
Public Function ReadAllMetadataAsXml As SerializableMetadata
abstract ReadAllMetadataAsXml : unit -> SerializableMetadata
override ReadAllMetadataAsXml : unit -> SerializableMetadata
function ReadAllMetadataAsXml();
public:
virtual SerializableMetadata^ ReadAllMetadataAsXml() sealed

Return Value

Type: SerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceReadAllMetadataAsXml
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.ReadRangeMetadataAsJson Method

Grid Solutions Framework MetadataServiceReadRangeMetadataAsJson Method
Reads a subset of metadata from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata ReadRangeMetadataAsJson(
    string fromID,
    string toID
)
Public Function ReadRangeMetadataAsJson (
    fromID As String,
    toID As String
) As SerializableMetadata
abstract ReadRangeMetadataAsJson :
        fromID : string *
        toID : string -> SerializableMetadata
override ReadRangeMetadataAsJson :
        fromID : string *
        toID : string -> SerializableMetadata
function ReadRangeMetadataAsJson(fromID, toID);
public:
virtual SerializableMetadata^ ReadRangeMetadataAsJson(
    String^ fromID,
    String^ toID
) sealed

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which metadata is to be read.
toID
Type: SystemString
Ending ID in the ID range for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceReadRangeMetadataAsJson(String, String)
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.ReadRangeMetadataAsXml Method

Grid Solutions Framework MetadataServiceReadRangeMetadataAsXml Method
Reads a subset of metadata from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata ReadRangeMetadataAsXml(
    string fromID,
    string toID
)
Public Function ReadRangeMetadataAsXml (
    fromID As String,
    toID As String
) As SerializableMetadata
abstract ReadRangeMetadataAsXml :
        fromID : string *
        toID : string -> SerializableMetadata
override ReadRangeMetadataAsXml :
        fromID : string *
        toID : string -> SerializableMetadata
function ReadRangeMetadataAsXml(fromID, toID);
public:
virtual SerializableMetadata^ ReadRangeMetadataAsXml(
    String^ fromID,
    String^ toID
) sealed

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which metadata is to be read.
toID
Type: SystemString
Ending ID in the ID range for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceReadRangeMetadataAsXml(String, String)
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.ReadSelectMetadataAsJson Method

Grid Solutions Framework MetadataServiceReadSelectMetadataAsJson Method
Reads a subset of metadata from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata ReadSelectMetadataAsJson(
    string idList
)
Public Function ReadSelectMetadataAsJson (
    idList As String
) As SerializableMetadata
abstract ReadSelectMetadataAsJson :
        idList : string -> SerializableMetadata
override ReadSelectMetadataAsJson :
        idList : string -> SerializableMetadata
function ReadSelectMetadataAsJson(idList);
public:
virtual SerializableMetadata^ ReadSelectMetadataAsJson(
    String^ idList
) sealed

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceReadSelectMetadataAsJson(String)
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.ReadSelectMetadataAsXml Method

Grid Solutions Framework MetadataServiceReadSelectMetadataAsXml Method
Reads a subset of metadata from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata ReadSelectMetadataAsXml(
    string idList
)
Public Function ReadSelectMetadataAsXml (
    idList As String
) As SerializableMetadata
abstract ReadSelectMetadataAsXml :
        idList : string -> SerializableMetadata
override ReadSelectMetadataAsXml :
        idList : string -> SerializableMetadata
function ReadSelectMetadataAsXml(idList);
public:
virtual SerializableMetadata^ ReadSelectMetadataAsXml(
    String^ idList
) sealed

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which metadata is to be read.

Return Value

Type: SerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceReadSelectMetadataAsXml(String)
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.WriteMetadataAsJson Method

Grid Solutions Framework MetadataServiceWriteMetadataAsJson Method
Writes metadata received in Json format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteMetadataAsJson(
    SerializableMetadata metadata
)
Public Sub WriteMetadataAsJson (
    metadata As SerializableMetadata
)
abstract WriteMetadataAsJson :
        metadata : SerializableMetadata -> unit
override WriteMetadataAsJson :
        metadata : SerializableMetadata -> unit
function WriteMetadataAsJson(metadata);
public:
virtual void WriteMetadataAsJson(
    SerializableMetadata^ metadata
) sealed

Parameters

metadata
Type: GSF.Historian.DataServicesSerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceWriteMetadataAsJson(SerializableMetadata)
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService.WriteMetadataAsXml Method

Grid Solutions Framework MetadataServiceWriteMetadataAsXml Method
Writes metadata received in Xml format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteMetadataAsXml(
    SerializableMetadata metadata
)
Public Sub WriteMetadataAsXml (
    metadata As SerializableMetadata
)
abstract WriteMetadataAsXml :
        metadata : SerializableMetadata -> unit
override WriteMetadataAsXml :
        metadata : SerializableMetadata -> unit
function WriteMetadataAsXml(metadata);
public:
virtual void WriteMetadataAsXml(
    SerializableMetadata^ metadata
) sealed

Parameters

metadata
Type: GSF.Historian.DataServicesSerializableMetadata
An SerializableMetadata object.

Implements

IMetadataServiceWriteMetadataAsXml(SerializableMetadata)
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService Properties

Grid Solutions Framework MetadataService Properties

The MetadataService type exposes the following members.

Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | Archive | Gets or sets the IArchive used by the web service for its data. (Inherited from DataService.)
Public property | CloseTimeout | Gets or sets the desired CloseTimeout used as the interval of time provided for a connection to close before the transport raises an exception. (Inherited from DataService.)
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


MetadataService Events

Grid Solutions Framework MetadataService Events

The MetadataService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

MetadataService Class
GSF.Historian.DataServices Namespace


SerializableMetadata Class

Grid Solutions Framework SerializableMetadata Class
Represents a container for SerializableMetadataRecords that can be serialized using XmlSerializer or DataContractJsonSerializer.
Inheritance Hierarchy
SystemObject
GSF.Historian.DataServicesSerializableMetadata

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlTypeAttribute("Metadata")]
[DataContractAttribute(Name = "Metadata", Namespace = "")]
public class SerializableMetadata
<XmlTypeAttribute("Metadata")>
<DataContractAttribute(Name := "Metadata", Namespace := "")>
Public Class SerializableMetadata
[<XmlTypeAttribute("Metadata")>]
[<DataContractAttribute(Name = "Metadata", Namespace = "")>]
type SerializableMetadata =  class end
GSF.Historian.DataServices.SerializableMetadata = function();

Type.createClass(
    'GSF.Historian.DataServices.SerializableMetadata');
[XmlTypeAttribute(L"Metadata")]
[DataContractAttribute(Name = L"Metadata", Namespace = L"")]
public ref class SerializableMetadata

The SerializableMetadata type exposes the following members.

Constructors
 | Name | Description
Public method | SerializableMetadata | Initializes a new instance of the SerializableMetadata class.
Public method | SerializableMetadata(MetadataFile) | Initializes a new instance of the SerializableMetadata class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | MetadataRecords | Gets or sets the SerializableMetadataRecords contained in the SerializableMetadata.
Top
Examples
This is the output for SerializableMetadata serialized using XmlSerializer:
Copy
<?xml version="1.0" encoding="utf-8" ?>
<Metadata xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <MetadataRecords>
    <MetadataRecord HistorianID="1" DataType="0" Name="TVA_CORD-BUS2:ABBV" Synonym1="4-PM1" Synonym2="VPHM" Synonym3=""
      Description="Cordova ABB-521 500 kV Bus 2 Positive Sequence Voltage Magnitude" HardwareInfo="ABB RES521" Remarks=""
      PlantCode="P1" UnitNumber="1" SystemName="CORD" SourceID="3" Enabled="true" ScanRate="0.0333333351" CompressionMinTime="0"
      CompressionMaxTime="0" EngineeringUnits="Volts" LowWarning="475000" HighWarning="525000" LowAlarm="450000" HighAlarm="550000"
      LowRange="475000" HighRange="525000" CompressionLimit="0" ExceptionLimit="0" DisplayDigits="7" SetDescription="" ClearDescription=""
      AlarmState="0" ChangeSecurity="5" AccessSecurity="0" StepCheck="false" AlarmEnabled="false" AlarmFlags="0" AlarmDelay="0" AlarmToFile="false"
      AlarmByEmail="false" AlarmByPager="false" AlarmByPhone="false" AlarmEmails="" AlarmPagers="" AlarmPhones="" />
  </MetadataRecords>
</Metadata>
This is the output for SerializableMetadata serialized using DataContractSerializer:
Copy
<Metadata xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
  <MetadataRecords>
    <MetadataRecord>
      <HistorianID>1</HistorianID>
      <DataType>0</DataType>
      <Name>TVA_CORD-BUS2:ABBV</Name>
      <Synonym1>4-PM1</Synonym1>
      <Synonym2>VPHM</Synonym2>
      <Synonym3 />
      <Description>Cordova ABB-521 500 kV Bus 2 Positive Sequence Voltage Magnitude</Description>
      <HardwareInfo>ABB RES521</HardwareInfo>
      <Remarks />
      <PlantCode>P1</PlantCode>
      <UnitNumber>1</UnitNumber>
      <SystemName>CORD</SystemName>
      <SourceID>3</SourceID>
      <Enabled>true</Enabled>
      <ScanRate>0.0333333351</ScanRate>
      <CompressionMinTime>0</CompressionMinTime>
      <CompressionMaxTime>0</CompressionMaxTime>
      <EngineeringUnits>Volts</EngineeringUnits>
      <LowWarning>475000</LowWarning>
      <HighWarning>525000</HighWarning>
      <LowAlarm>450000</LowAlarm>
      <HighAlarm>550000</HighAlarm>
      <LowRange>475000</LowRange>
      <HighRange>525000</HighRange>
      <CompressionLimit>0</CompressionLimit>
      <ExceptionLimit>0</ExceptionLimit>
      <DisplayDigits>7</DisplayDigits>
      <SetDescription />
      <ClearDescription />
      <AlarmState>0</AlarmState>
      <ChangeSecurity>5</ChangeSecurity>
      <AccessSecurity>0</AccessSecurity>
      <StepCheck>false</StepCheck>
      <AlarmEnabled>false</AlarmEnabled>
      <AlarmFlags>0</AlarmFlags>
      <AlarmDelay>0</AlarmDelay>
      <AlarmToFile>false</AlarmToFile>
      <AlarmByEmail>false</AlarmByEmail>
      <AlarmByPager>false</AlarmByPager>
      <AlarmByPhone>false</AlarmByPhone>
      <AlarmEmails />
      <AlarmPagers />
      <AlarmPhones />
    </MetadataRecord>
  </MetadataRecords>
</Metadata>
This is the output for SerializableMetadata serialized using DataContractJsonSerializer:
Copy
{
  "MetadataRecords":
    [{"HistorianID":1,
      "DataType":0,
      "Name":"TVA_CORD-BUS2:ABBV",
      "Synonym1":"4-PM1",
      "Synonym2":"VPHM",
      "Synonym3":"",
      "Description":"Cordova ABB-521 500 kV Bus 2 Positive Sequence Voltage Magnitude",
      "HardwareInfo":"ABB RES521",
      "Remarks":"",
      "PlantCode":"P1",
      "UnitNumber":1,
      "SystemName":"CORD",
      "SourceID":3,
      "Enabled":true,
      "ScanRate":0.0333333351,
      "CompressionMinTime":0,
      "CompressionMaxTime":0,
      "EngineeringUnits":"Volts",
      "LowWarning":475000,
      "HighWarning":525000,
      "LowAlarm":450000,
      "HighAlarm":550000,
      "LowRange":475000,
      "HighRange":525000,
      "CompressionLimit":0,
      "ExceptionLimit":0,
      "DisplayDigits":7,
      "SetDescription":"",
      "ClearDescription":"",
      "AlarmState":0,
      "ChangeSecurity":5,
      "AccessSecurity":0,
      "StepCheck":false,
      "AlarmEnabled":false,
      "AlarmFlags":0,
      "AlarmDelay":0,
      "AlarmToFile":false,
      "AlarmByEmail":false,
      "AlarmByPager":false,
      "AlarmByPhone":false,
      "AlarmEmails":"",
      "AlarmPagers":"",
      "AlarmPhones":""}]
}
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.Historian.FilesMetadataFile
GSF.Historian.DataServicesSerializableMetadataRecord
System.Xml.SerializationXmlSerializer
System.Runtime.SerializationDataContractSerializer
System.Runtime.Serialization.JsonDataContractJsonSerializer


SerializableMetadata Constructor

Grid Solutions Framework SerializableMetadata Constructor
Overload List
 | Name | Description
Public method | SerializableMetadata | Initializes a new instance of the SerializableMetadata class.
Public method | SerializableMetadata(MetadataFile) | Initializes a new instance of the SerializableMetadata class.
Top
See Also

Reference

SerializableMetadata Class
GSF.Historian.DataServices Namespace


SerializableMetadata Constructor

Grid Solutions Framework SerializableMetadata Constructor
Initializes a new instance of the SerializableMetadata class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata()
Public Sub New
new : unit -> SerializableMetadata
GSF.Historian.DataServices.SerializableMetadata = function();
public:
SerializableMetadata()
See Also

Reference

SerializableMetadata Class
SerializableMetadata Overload
GSF.Historian.DataServices Namespace


SerializableMetadata Constructor (MetadataFile)

Grid Solutions Framework SerializableMetadata Constructor (MetadataFile)
Initializes a new instance of the SerializableMetadata class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadata(
    MetadataFile metadataFile
)
Public Sub New (
    metadataFile As MetadataFile
)
new :
        metadataFile : MetadataFile -> SerializableMetadata
GSF.Historian.DataServices.SerializableMetadata = function(metadataFile);
public:
SerializableMetadata(
    MetadataFile^ metadataFile
)

Parameters

metadataFile
Type: GSF.Historian.FilesMetadataFile
MetadataFile object from which SerializableMetadata is to be initialized.
Exceptions
Exception | Condition
ArgumentNullException | metadataFile is null.
ArgumentException | metadataFile is closed.
See Also

Reference

SerializableMetadata Class
SerializableMetadata Overload
GSF.Historian.DataServices Namespace


SerializableMetadata Methods

Grid Solutions Framework SerializableMetadata Methods

The SerializableMetadata type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SerializableMetadata Class
GSF.Historian.DataServices Namespace


SerializableMetadata Properties

Grid Solutions Framework SerializableMetadata Properties

The SerializableMetadata type exposes the following members.

Properties
 | Name | Description
Public property | MetadataRecords | Gets or sets the SerializableMetadataRecords contained in the SerializableMetadata.
Top
See Also

Reference

SerializableMetadata Class
GSF.Historian.DataServices Namespace


SerializableMetadata.MetadataRecords Property

Grid Solutions Framework SerializableMetadataMetadataRecords Property
Gets or sets the SerializableMetadataRecords contained in the SerializableMetadata.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
[XmlArrayAttribute]
public SerializableMetadataRecord[] MetadataRecords { get; set; }
<DataMemberAttribute>
<XmlArrayAttribute>
Public Property MetadataRecords As SerializableMetadataRecord()
    Get
    Set
[<DataMemberAttribute>]
[<XmlArrayAttribute>]
member MetadataRecords : SerializableMetadataRecord[] with get, set

function get_MetadataRecords();
function set_MetadataRecords(value);
public:
[DataMemberAttribute]
[XmlArrayAttribute]
property array<SerializableMetadataRecord^>^ MetadataRecords {
    array<SerializableMetadataRecord^>^ get ();
    void set (array<SerializableMetadataRecord^>^ value);
}

Property Value

Type: SerializableMetadataRecord
See Also

Reference

SerializableMetadata Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord Class

Grid Solutions Framework SerializableMetadataRecord Class
Represents a flattened MetadataRecord that can be serialized using XmlSerializer, DataContractSerializer or DataContractJsonSerializer.
Inheritance Hierarchy
SystemObject
GSF.Historian.DataServicesSerializableMetadataRecord

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataContractAttribute(Name = "MetadataRecord", Namespace = "")]
[XmlTypeAttribute("MetadataRecord")]
public class SerializableMetadataRecord
<DataContractAttribute(Name := "MetadataRecord", Namespace := "")>
<XmlTypeAttribute("MetadataRecord")>
Public Class SerializableMetadataRecord
[<DataContractAttribute(Name = "MetadataRecord", Namespace = "")>]
[<XmlTypeAttribute("MetadataRecord")>]
type SerializableMetadataRecord =  class end
GSF.Historian.DataServices.SerializableMetadataRecord = function();

Type.createClass(
    'GSF.Historian.DataServices.SerializableMetadataRecord');
[DataContractAttribute(Name = L"MetadataRecord", Namespace = L"")]
[XmlTypeAttribute(L"MetadataRecord")]
public ref class SerializableMetadataRecord

The SerializableMetadataRecord type exposes the following members.

Constructors
 | Name | Description
Public method | SerializableMetadataRecord | Initializes a new instance of the SerializableMetadataRecord class.
Public method | SerializableMetadataRecord(MetadataRecord) | Initializes a new instance of the SerializableMetadataRecord class.
Top
Methods
 | Name | Description
Public method | Deflate | Returns an MetadataRecord object for this SerializableMetadataRecord.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AccessSecurity | Gets or sets the AccessSecurity.
Public property | AlarmByEmail | Gets or sets the AlarmByEmail.
Public property | AlarmByPager | Gets or sets the AlarmByPager.
Public property | AlarmByPhone | Gets or sets the AlarmByPhone.
Public property | AlarmDelay | Gets or sets the AlarmDelay or AlarmDelay.
Public property | AlarmEmails | Gets or sets the AlarmEmails.
Public property | AlarmEnabled | Gets or sets the AlarmEnabled.
Public property | AlarmFlags | Gets or sets the Value.
Public property | AlarmPagers | Gets or sets the AlarmPagers.
Public property | AlarmPhones | Gets or sets the AlarmPhones.
Public property | AlarmState | Gets or sets the AlarmState.
Public property | AlarmToFile | Gets or sets the AlarmToFile.
Public property | ChangeSecurity | Gets or sets the ChangeSecurity.
Public property | ClearDescription | Gets or sets the ClearDescription.
Public property | CompressionLimit | Gets or sets the CompressionLimit.
Public property | CompressionMaxTime | Gets or sets the CompressionMaxTime.
Public property | CompressionMinTime | Gets or sets the CompressionMinTime.
Public property | DataType | Gets or sets the DataType.
Public property | Description | Gets or sets the Description.
Public property | DisplayDigits | Gets or sets the DisplayDigits.
Public property | Enabled | Gets or sets the Enabled.
Public property | EngineeringUnits | Gets or sets the EngineeringUnits.
Public property | ExceptionLimit | Gets or sets the ExceptionLimit.
Public property | HardwareInfo | Gets or sets the HardwareInfo.
Public property | HighAlarm | Gets or sets the HighAlarm.
Public property | HighRange | Gets or sets the HighRange.
Public property | HighWarning | Gets or sets the HighWarning.
Public property | HistorianID | Gets or sets the HistorianID.
Public property | LowAlarm | Gets or sets the LowAlarm.
Public property | LowRange | Gets or sets the LowRange.
Public property | LowWarning | Gets or sets the LowWarning.
Public property | Name | Gets or sets the Name.
Public property | PlantCode | Gets or sets the PlantCode.
Public property | Remarks | Gets or sets the Remarks.
Public property | ScanRate | Gets or sets the ScanRate.
Public property | SetDescription | Gets or sets the SetDescription.
Public property | SourceID | Gets or sets the SourceID.
Public property | StepCheck | Gets or sets the StepCheck.
Public property | Synonym1 | Gets or sets the Synonym1.
Public property | Synonym2 | Gets or sets the Synonym2.
Public property | Synonym3 | Gets or sets the Synonym3.
Public property | SystemName | Gets or sets the SystemName.
Public property | UnitNumber | Gets or sets the UnitNumber.
Top
Examples
This is the output for SerializableMetadataRecord serialized using XmlSerializer:
Copy
<?xml version="1.0" encoding="utf-8" ?>
<MetadataRecord HistorianID="1" DataType="0" Name="TVA_CORD-BUS2:ABBV" Synonym1="4-PM1" Synonym2="VPHM" Synonym3="" Description="Cordova ABB-521 500 kV Bus 2 Positive Sequence Voltage Magnitude" HardwareInfo="ABB RES521"
  Remarks="" PlantCode="P1" UnitNumber="1" SystemName="CORD" SourceID="3" Enabled="true" ScanRate="0.0333333351" CompressionMinTime="0" CompressionMaxTime="0" EngineeringUnits="Volts" LowWarning="475000" HighWarning="525000"
  LowAlarm="450000" HighAlarm="550000" LowRange="475000" HighRange="525000" CompressionLimit="0" ExceptionLimit="0" DisplayDigits="7" SetDescription="" ClearDescription="" AlarmState="0" ChangeSecurity="5" AccessSecurity="0"
  StepCheck="false" AlarmEnabled="false" AlarmFlags="0" AlarmDelay="0" AlarmToFile="false" AlarmByEmail="false" AlarmByPager="false" AlarmByPhone="false" AlarmEmails="" AlarmPagers="" AlarmPhones=""
  xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema" />
This is the output for SerializableMetadataRecord serialized using DataContractSerializer:
Copy
<MetadataRecord xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
  <HistorianID>1</HistorianID>
  <DataType>0</DataType>
  <Name>TVA_CORD-BUS2:ABBV</Name>
  <Synonym1>4-PM1</Synonym1>
  <Synonym2>VPHM</Synonym2>
  <Synonym3 />
  <Description>Cordova ABB-521 500 kV Bus 2 Positive Sequence Voltage Magnitude</Description>
  <HardwareInfo>ABB RES521</HardwareInfo>
  <Remarks />
  <PlantCode>P1</PlantCode>
  <UnitNumber>1</UnitNumber>
  <SystemName>CORD</SystemName>
  <SourceID>3</SourceID>
  <Enabled>true</Enabled>
  <ScanRate>0.0333333351</ScanRate>
  <CompressionMinTime>0</CompressionMinTime>
  <CompressionMaxTime>0</CompressionMaxTime>
  <EngineeringUnits>Volts</EngineeringUnits>
  <LowWarning>475000</LowWarning>
  <HighWarning>525000</HighWarning>
  <LowAlarm>450000</LowAlarm>
  <HighAlarm>550000</HighAlarm>
  <LowRange>475000</LowRange>
  <HighRange>525000</HighRange>
  <CompressionLimit>0</CompressionLimit>
  <ExceptionLimit>0</ExceptionLimit>
  <DisplayDigits>7</DisplayDigits>
  <SetDescription />
  <ClearDescription />
  <AlarmState>0</AlarmState>
  <ChangeSecurity>5</ChangeSecurity>
  <AccessSecurity>0</AccessSecurity>
  <StepCheck>false</StepCheck>
  <AlarmEnabled>false</AlarmEnabled>
  <AlarmFlags>0</AlarmFlags>
  <AlarmDelay>0</AlarmDelay>
  <AlarmToFile>false</AlarmToFile>
  <AlarmByEmail>false</AlarmByEmail>
  <AlarmByPager>false</AlarmByPager>
  <AlarmByPhone>false</AlarmByPhone>
  <AlarmEmails />
  <AlarmPagers />
  <AlarmPhones />
</MetadataRecord>
This is the output for SerializableMetadataRecord serialized using DataContractJsonSerializer:
Copy
{
  "HistorianID":1,
  "DataType":0,
  "Name":"TVA_CORD-BUS2:ABBV",
  "Synonym1":"4-PM1",
  "Synonym2":"VPHM",
  "Synonym3":"",
  "Description":"Cordova ABB-521 500 kV Bus 2 Positive Sequence Voltage Magnitude",
  "HardwareInfo":"ABB RES521",
  "Remarks":"",
  "PlantCode":"P1",
  "UnitNumber":1,
  "SystemName":"CORD",
  "SourceID":3,
  "Enabled":true,
  "ScanRate":0.0333333351,
  "CompressionMinTime":0,
  "CompressionMaxTime":0,
  "EngineeringUnits":"Volts",
  "LowWarning":475000,
  "HighWarning":525000,
  "LowAlarm":450000,
  "HighAlarm":550000,
  "LowRange":475000,
  "HighRange":525000,
  "CompressionLimit":0,
  "ExceptionLimit":0,
  "DisplayDigits":7,
  "SetDescription":"",
  "ClearDescription":"",
  "AlarmState":0,
  "ChangeSecurity":5,
  "AccessSecurity":0,
  "StepCheck":false,
  "AlarmEnabled":false,
  "AlarmFlags":0,
  "AlarmDelay":0,
  "AlarmToFile":false,
  "AlarmByEmail":false,
  "AlarmByPager":false,
  "AlarmByPhone":false,
  "AlarmEmails":"",
  "AlarmPagers":"",
  "AlarmPhones":""
}
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.Historian.FilesMetadataRecord
System.Xml.SerializationXmlSerializer
System.Runtime.SerializationDataContractSerializer
System.Runtime.Serialization.JsonDataContractJsonSerializer


SerializableMetadataRecord Constructor

Grid Solutions Framework SerializableMetadataRecord Constructor
Overload List
 | Name | Description
Public method | SerializableMetadataRecord | Initializes a new instance of the SerializableMetadataRecord class.
Public method | SerializableMetadataRecord(MetadataRecord) | Initializes a new instance of the SerializableMetadataRecord class.
Top
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord Constructor

Grid Solutions Framework SerializableMetadataRecord Constructor
Initializes a new instance of the SerializableMetadataRecord class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadataRecord()
Public Sub New
new : unit -> SerializableMetadataRecord
GSF.Historian.DataServices.SerializableMetadataRecord = function();
public:
SerializableMetadataRecord()
See Also

Reference

SerializableMetadataRecord Class
SerializableMetadataRecord Overload
GSF.Historian.DataServices Namespace


SerializableMetadataRecord Constructor (MetadataRecord)

Grid Solutions Framework SerializableMetadataRecord Constructor (MetadataRecord)
Initializes a new instance of the SerializableMetadataRecord class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMetadataRecord(
    MetadataRecord metadataRecord
)
Public Sub New (
    metadataRecord As MetadataRecord
)
new :
        metadataRecord : MetadataRecord -> SerializableMetadataRecord
GSF.Historian.DataServices.SerializableMetadataRecord = function(metadataRecord);
public:
SerializableMetadataRecord(
    MetadataRecord^ metadataRecord
)

Parameters

metadataRecord
Type: GSF.Historian.FilesMetadataRecord
MetadataRecord from which SerializableMetadataRecord is to be initialized.
Exceptions
Exception | Condition
ArgumentNullException | metadataRecord is null.
See Also

Reference

SerializableMetadataRecord Class
SerializableMetadataRecord Overload
GSF.Historian.DataServices Namespace


SerializableMetadataRecord Methods

Grid Solutions Framework SerializableMetadataRecord Methods

The SerializableMetadataRecord type exposes the following members.

Methods
 | Name | Description
Public method | Deflate | Returns an MetadataRecord object for this SerializableMetadataRecord.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Deflate Method

Grid Solutions Framework SerializableMetadataRecordDeflate Method
Returns an MetadataRecord object for this SerializableMetadataRecord.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecord Deflate()
Public Function Deflate As MetadataRecord
member Deflate : unit -> MetadataRecord

function Deflate();
public:
MetadataRecord^ Deflate()

Return Value

Type: MetadataRecord
An MetadataRecord object.
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord Properties

Grid Solutions Framework SerializableMetadataRecord Properties

The SerializableMetadataRecord type exposes the following members.

Properties
 | Name | Description
Public property | AccessSecurity | Gets or sets the AccessSecurity.
Public property | AlarmByEmail | Gets or sets the AlarmByEmail.
Public property | AlarmByPager | Gets or sets the AlarmByPager.
Public property | AlarmByPhone | Gets or sets the AlarmByPhone.
Public property | AlarmDelay | Gets or sets the AlarmDelay or AlarmDelay.
Public property | AlarmEmails | Gets or sets the AlarmEmails.
Public property | AlarmEnabled | Gets or sets the AlarmEnabled.
Public property | AlarmFlags | Gets or sets the Value.
Public property | AlarmPagers | Gets or sets the AlarmPagers.
Public property | AlarmPhones | Gets or sets the AlarmPhones.
Public property | AlarmState | Gets or sets the AlarmState.
Public property | AlarmToFile | Gets or sets the AlarmToFile.
Public property | ChangeSecurity | Gets or sets the ChangeSecurity.
Public property | ClearDescription | Gets or sets the ClearDescription.
Public property | CompressionLimit | Gets or sets the CompressionLimit.
Public property | CompressionMaxTime | Gets or sets the CompressionMaxTime.
Public property | CompressionMinTime | Gets or sets the CompressionMinTime.
Public property | DataType | Gets or sets the DataType.
Public property | Description | Gets or sets the Description.
Public property | DisplayDigits | Gets or sets the DisplayDigits.
Public property | Enabled | Gets or sets the Enabled.
Public property | EngineeringUnits | Gets or sets the EngineeringUnits.
Public property | ExceptionLimit | Gets or sets the ExceptionLimit.
Public property | HardwareInfo | Gets or sets the HardwareInfo.
Public property | HighAlarm | Gets or sets the HighAlarm.
Public property | HighRange | Gets or sets the HighRange.
Public property | HighWarning | Gets or sets the HighWarning.
Public property | HistorianID | Gets or sets the HistorianID.
Public property | LowAlarm | Gets or sets the LowAlarm.
Public property | LowRange | Gets or sets the LowRange.
Public property | LowWarning | Gets or sets the LowWarning.
Public property | Name | Gets or sets the Name.
Public property | PlantCode | Gets or sets the PlantCode.
Public property | Remarks | Gets or sets the Remarks.
Public property | ScanRate | Gets or sets the ScanRate.
Public property | SetDescription | Gets or sets the SetDescription.
Public property | SourceID | Gets or sets the SourceID.
Public property | StepCheck | Gets or sets the StepCheck.
Public property | Synonym1 | Gets or sets the Synonym1.
Public property | Synonym2 | Gets or sets the Synonym2.
Public property | Synonym3 | Gets or sets the Synonym3.
Public property | SystemName | Gets or sets the SystemName.
Public property | UnitNumber | Gets or sets the UnitNumber.
Top
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AccessSecurity Property

Grid Solutions Framework SerializableMetadataRecordAccessSecurity Property
Gets or sets the AccessSecurity.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 31)]
public int AccessSecurity { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 31)>
Public Property AccessSecurity As Integer
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 31)>]
member AccessSecurity : int with get, set

function get_AccessSecurity();
function set_AccessSecurity(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 31)]
property int AccessSecurity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmByEmail Property

Grid Solutions Framework SerializableMetadataRecordAlarmByEmail Property
Gets or sets the AlarmByEmail.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 36)]
public bool AlarmByEmail { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 36)>
Public Property AlarmByEmail As Boolean
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 36)>]
member AlarmByEmail : bool with get, set

function get_AlarmByEmail();
function set_AlarmByEmail(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 36)]
property bool AlarmByEmail {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmByPager Property

Grid Solutions Framework SerializableMetadataRecordAlarmByPager Property
Gets or sets the AlarmByPager.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 37)]
public bool AlarmByPager { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 37)>
Public Property AlarmByPager As Boolean
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 37)>]
member AlarmByPager : bool with get, set

function get_AlarmByPager();
function set_AlarmByPager(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 37)]
property bool AlarmByPager {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmByPhone Property

Grid Solutions Framework SerializableMetadataRecordAlarmByPhone Property
Gets or sets the AlarmByPhone.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 38)]
[XmlAttributeAttribute]
public bool AlarmByPhone { get; set; }
<DataMemberAttribute(Order := 38)>
<XmlAttributeAttribute>
Public Property AlarmByPhone As Boolean
    Get
    Set
[<DataMemberAttribute(Order = 38)>]
[<XmlAttributeAttribute>]
member AlarmByPhone : bool with get, set

function get_AlarmByPhone();
function set_AlarmByPhone(value);
public:
[DataMemberAttribute(Order = 38)]
[XmlAttributeAttribute]
property bool AlarmByPhone {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmDelay Property

Grid Solutions Framework SerializableMetadataRecordAlarmDelay Property
Gets or sets the AlarmDelay or AlarmDelay.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 34)]
public float AlarmDelay { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 34)>
Public Property AlarmDelay As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 34)>]
member AlarmDelay : float32 with get, set

function get_AlarmDelay();
function set_AlarmDelay(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 34)]
property float AlarmDelay {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmEmails Property

Grid Solutions Framework SerializableMetadataRecordAlarmEmails Property
Gets or sets the AlarmEmails.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 39)]
public string AlarmEmails { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 39)>
Public Property AlarmEmails As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 39)>]
member AlarmEmails : string with get, set

function get_AlarmEmails();
function set_AlarmEmails(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 39)]
property String^ AlarmEmails {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmEnabled Property

Grid Solutions Framework SerializableMetadataRecordAlarmEnabled Property
Gets or sets the AlarmEnabled.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 33)]
public bool AlarmEnabled { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 33)>
Public Property AlarmEnabled As Boolean
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 33)>]
member AlarmEnabled : bool with get, set

function get_AlarmEnabled();
function set_AlarmEnabled(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 33)]
property bool AlarmEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmFlags Property

Grid Solutions Framework SerializableMetadataRecordAlarmFlags Property
Gets or sets the Value.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 33)]
[XmlAttributeAttribute]
public int AlarmFlags { get; set; }
<DataMemberAttribute(Order := 33)>
<XmlAttributeAttribute>
Public Property AlarmFlags As Integer
    Get
    Set
[<DataMemberAttribute(Order = 33)>]
[<XmlAttributeAttribute>]
member AlarmFlags : int with get, set

function get_AlarmFlags();
function set_AlarmFlags(value);
public:
[DataMemberAttribute(Order = 33)]
[XmlAttributeAttribute]
property int AlarmFlags {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmPagers Property

Grid Solutions Framework SerializableMetadataRecordAlarmPagers Property
Gets or sets the AlarmPagers.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 40)]
[XmlAttributeAttribute]
public string AlarmPagers { get; set; }
<DataMemberAttribute(Order := 40)>
<XmlAttributeAttribute>
Public Property AlarmPagers As String
    Get
    Set
[<DataMemberAttribute(Order = 40)>]
[<XmlAttributeAttribute>]
member AlarmPagers : string with get, set

function get_AlarmPagers();
function set_AlarmPagers(value);
public:
[DataMemberAttribute(Order = 40)]
[XmlAttributeAttribute]
property String^ AlarmPagers {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmPhones Property

Grid Solutions Framework SerializableMetadataRecordAlarmPhones Property
Gets or sets the AlarmPhones.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 41)]
public string AlarmPhones { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 41)>
Public Property AlarmPhones As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 41)>]
member AlarmPhones : string with get, set

function get_AlarmPhones();
function set_AlarmPhones(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 41)]
property String^ AlarmPhones {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmState Property

Grid Solutions Framework SerializableMetadataRecordAlarmState Property
Gets or sets the AlarmState.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 29)]
[XmlAttributeAttribute]
public int AlarmState { get; set; }
<DataMemberAttribute(Order := 29)>
<XmlAttributeAttribute>
Public Property AlarmState As Integer
    Get
    Set
[<DataMemberAttribute(Order = 29)>]
[<XmlAttributeAttribute>]
member AlarmState : int with get, set

function get_AlarmState();
function set_AlarmState(value);
public:
[DataMemberAttribute(Order = 29)]
[XmlAttributeAttribute]
property int AlarmState {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.AlarmToFile Property

Grid Solutions Framework SerializableMetadataRecordAlarmToFile Property
Gets or sets the AlarmToFile.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 35)]
public bool AlarmToFile { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 35)>
Public Property AlarmToFile As Boolean
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 35)>]
member AlarmToFile : bool with get, set

function get_AlarmToFile();
function set_AlarmToFile(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 35)]
property bool AlarmToFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.ChangeSecurity Property

Grid Solutions Framework SerializableMetadataRecordChangeSecurity Property
Gets or sets the ChangeSecurity.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 30)]
[XmlAttributeAttribute]
public int ChangeSecurity { get; set; }
<DataMemberAttribute(Order := 30)>
<XmlAttributeAttribute>
Public Property ChangeSecurity As Integer
    Get
    Set
[<DataMemberAttribute(Order = 30)>]
[<XmlAttributeAttribute>]
member ChangeSecurity : int with get, set

function get_ChangeSecurity();
function set_ChangeSecurity(value);
public:
[DataMemberAttribute(Order = 30)]
[XmlAttributeAttribute]
property int ChangeSecurity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.ClearDescription Property

Grid Solutions Framework SerializableMetadataRecordClearDescription Property
Gets or sets the ClearDescription.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 28)]
[XmlAttributeAttribute]
public string ClearDescription { get; set; }
<DataMemberAttribute(Order := 28)>
<XmlAttributeAttribute>
Public Property ClearDescription As String
    Get
    Set
[<DataMemberAttribute(Order = 28)>]
[<XmlAttributeAttribute>]
member ClearDescription : string with get, set

function get_ClearDescription();
function set_ClearDescription(value);
public:
[DataMemberAttribute(Order = 28)]
[XmlAttributeAttribute]
property String^ ClearDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.CompressionLimit Property

Grid Solutions Framework SerializableMetadataRecordCompressionLimit Property
Gets or sets the CompressionLimit.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 24)]
[XmlAttributeAttribute]
public float CompressionLimit { get; set; }
<DataMemberAttribute(Order := 24)>
<XmlAttributeAttribute>
Public Property CompressionLimit As Single
    Get
    Set
[<DataMemberAttribute(Order = 24)>]
[<XmlAttributeAttribute>]
member CompressionLimit : float32 with get, set

function get_CompressionLimit();
function set_CompressionLimit(value);
public:
[DataMemberAttribute(Order = 24)]
[XmlAttributeAttribute]
property float CompressionLimit {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.CompressionMaxTime Property

Grid Solutions Framework SerializableMetadataRecordCompressionMaxTime Property
Gets or sets the CompressionMaxTime.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 16)]
[XmlAttributeAttribute]
public int CompressionMaxTime { get; set; }
<DataMemberAttribute(Order := 16)>
<XmlAttributeAttribute>
Public Property CompressionMaxTime As Integer
    Get
    Set
[<DataMemberAttribute(Order = 16)>]
[<XmlAttributeAttribute>]
member CompressionMaxTime : int with get, set

function get_CompressionMaxTime();
function set_CompressionMaxTime(value);
public:
[DataMemberAttribute(Order = 16)]
[XmlAttributeAttribute]
property int CompressionMaxTime {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.CompressionMinTime Property

Grid Solutions Framework SerializableMetadataRecordCompressionMinTime Property
Gets or sets the CompressionMinTime.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 15)]
public int CompressionMinTime { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 15)>
Public Property CompressionMinTime As Integer
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 15)>]
member CompressionMinTime : int with get, set

function get_CompressionMinTime();
function set_CompressionMinTime(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 15)]
property int CompressionMinTime {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.DataType Property

Grid Solutions Framework SerializableMetadataRecordDataType Property
Gets or sets the DataType.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 1)]
public int DataType { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 1)>
Public Property DataType As Integer
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 1)>]
member DataType : int with get, set

function get_DataType();
function set_DataType(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 1)]
property int DataType {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Description Property

Grid Solutions Framework SerializableMetadataRecordDescription Property
Gets or sets the Description.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 6)]
public string Description { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 6)>
Public Property Description As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 6)>]
member Description : string with get, set

function get_Description();
function set_Description(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 6)]
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.DisplayDigits Property

Grid Solutions Framework SerializableMetadataRecordDisplayDigits Property
Gets or sets the DisplayDigits.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 26)]
[XmlAttributeAttribute]
public int DisplayDigits { get; set; }
<DataMemberAttribute(Order := 26)>
<XmlAttributeAttribute>
Public Property DisplayDigits As Integer
    Get
    Set
[<DataMemberAttribute(Order = 26)>]
[<XmlAttributeAttribute>]
member DisplayDigits : int with get, set

function get_DisplayDigits();
function set_DisplayDigits(value);
public:
[DataMemberAttribute(Order = 26)]
[XmlAttributeAttribute]
property int DisplayDigits {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Enabled Property

Grid Solutions Framework SerializableMetadataRecordEnabled Property
Gets or sets the Enabled.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 13)]
[XmlAttributeAttribute]
public bool Enabled { get; set; }
<DataMemberAttribute(Order := 13)>
<XmlAttributeAttribute>
Public Property Enabled As Boolean
    Get
    Set
[<DataMemberAttribute(Order = 13)>]
[<XmlAttributeAttribute>]
member Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
public:
[DataMemberAttribute(Order = 13)]
[XmlAttributeAttribute]
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.EngineeringUnits Property

Grid Solutions Framework SerializableMetadataRecordEngineeringUnits Property
Gets or sets the EngineeringUnits.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 17)]
[XmlAttributeAttribute]
public string EngineeringUnits { get; set; }
<DataMemberAttribute(Order := 17)>
<XmlAttributeAttribute>
Public Property EngineeringUnits As String
    Get
    Set
[<DataMemberAttribute(Order = 17)>]
[<XmlAttributeAttribute>]
member EngineeringUnits : string with get, set

function get_EngineeringUnits();
function set_EngineeringUnits(value);
public:
[DataMemberAttribute(Order = 17)]
[XmlAttributeAttribute]
property String^ EngineeringUnits {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.ExceptionLimit Property

Grid Solutions Framework SerializableMetadataRecordExceptionLimit Property
Gets or sets the ExceptionLimit.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 25)]
public float ExceptionLimit { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 25)>
Public Property ExceptionLimit As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 25)>]
member ExceptionLimit : float32 with get, set

function get_ExceptionLimit();
function set_ExceptionLimit(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 25)]
property float ExceptionLimit {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.HardwareInfo Property

Grid Solutions Framework SerializableMetadataRecordHardwareInfo Property
Gets or sets the HardwareInfo.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 7)]
[XmlAttributeAttribute]
public string HardwareInfo { get; set; }
<DataMemberAttribute(Order := 7)>
<XmlAttributeAttribute>
Public Property HardwareInfo As String
    Get
    Set
[<DataMemberAttribute(Order = 7)>]
[<XmlAttributeAttribute>]
member HardwareInfo : string with get, set

function get_HardwareInfo();
function set_HardwareInfo(value);
public:
[DataMemberAttribute(Order = 7)]
[XmlAttributeAttribute]
property String^ HardwareInfo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.HighAlarm Property

Grid Solutions Framework SerializableMetadataRecordHighAlarm Property
Gets or sets the HighAlarm.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 21)]
[XmlAttributeAttribute]
public float HighAlarm { get; set; }
<DataMemberAttribute(Order := 21)>
<XmlAttributeAttribute>
Public Property HighAlarm As Single
    Get
    Set
[<DataMemberAttribute(Order = 21)>]
[<XmlAttributeAttribute>]
member HighAlarm : float32 with get, set

function get_HighAlarm();
function set_HighAlarm(value);
public:
[DataMemberAttribute(Order = 21)]
[XmlAttributeAttribute]
property float HighAlarm {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.HighRange Property

Grid Solutions Framework SerializableMetadataRecordHighRange Property
Gets or sets the HighRange.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 23)]
public float HighRange { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 23)>
Public Property HighRange As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 23)>]
member HighRange : float32 with get, set

function get_HighRange();
function set_HighRange(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 23)]
property float HighRange {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.HighWarning Property

Grid Solutions Framework SerializableMetadataRecordHighWarning Property
Gets or sets the HighWarning.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 19)]
public float HighWarning { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 19)>
Public Property HighWarning As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 19)>]
member HighWarning : float32 with get, set

function get_HighWarning();
function set_HighWarning(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 19)]
property float HighWarning {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.HistorianID Property

Grid Solutions Framework SerializableMetadataRecordHistorianID Property
Gets or sets the HistorianID.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 0)]
[XmlAttributeAttribute]
public int HistorianID { get; set; }
<DataMemberAttribute(Order := 0)>
<XmlAttributeAttribute>
Public Property HistorianID As Integer
    Get
    Set
[<DataMemberAttribute(Order = 0)>]
[<XmlAttributeAttribute>]
member HistorianID : int with get, set

function get_HistorianID();
function set_HistorianID(value);
public:
[DataMemberAttribute(Order = 0)]
[XmlAttributeAttribute]
property int HistorianID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.LowAlarm Property

Grid Solutions Framework SerializableMetadataRecordLowAlarm Property
Gets or sets the LowAlarm.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 20)]
public float LowAlarm { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 20)>
Public Property LowAlarm As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 20)>]
member LowAlarm : float32 with get, set

function get_LowAlarm();
function set_LowAlarm(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 20)]
property float LowAlarm {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.LowRange Property

Grid Solutions Framework SerializableMetadataRecordLowRange Property
Gets or sets the LowRange.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 22)]
public float LowRange { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 22)>
Public Property LowRange As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 22)>]
member LowRange : float32 with get, set

function get_LowRange();
function set_LowRange(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 22)]
property float LowRange {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.LowWarning Property

Grid Solutions Framework SerializableMetadataRecordLowWarning Property
Gets or sets the LowWarning.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 18)]
public float LowWarning { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 18)>
Public Property LowWarning As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 18)>]
member LowWarning : float32 with get, set

function get_LowWarning();
function set_LowWarning(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 18)]
property float LowWarning {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Name Property

Grid Solutions Framework SerializableMetadataRecordName Property
Gets or sets the Name.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 2)]
public string Name { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 2)>
Public Property Name As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 2)>]
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 2)]
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.PlantCode Property

Grid Solutions Framework SerializableMetadataRecordPlantCode Property
Gets or sets the PlantCode.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 9)]
[XmlAttributeAttribute]
public string PlantCode { get; set; }
<DataMemberAttribute(Order := 9)>
<XmlAttributeAttribute>
Public Property PlantCode As String
    Get
    Set
[<DataMemberAttribute(Order = 9)>]
[<XmlAttributeAttribute>]
member PlantCode : string with get, set

function get_PlantCode();
function set_PlantCode(value);
public:
[DataMemberAttribute(Order = 9)]
[XmlAttributeAttribute]
property String^ PlantCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Remarks Property

Grid Solutions Framework SerializableMetadataRecordRemarks Property
Gets or sets the Remarks.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 8)]
public string Remarks { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 8)>
Public Property Remarks As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 8)>]
member Remarks : string with get, set

function get_Remarks();
function set_Remarks(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 8)]
property String^ Remarks {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.ScanRate Property

Grid Solutions Framework SerializableMetadataRecordScanRate Property
Gets or sets the ScanRate.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 14)]
public float ScanRate { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 14)>
Public Property ScanRate As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 14)>]
member ScanRate : float32 with get, set

function get_ScanRate();
function set_ScanRate(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 14)]
property float ScanRate {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.SetDescription Property

Grid Solutions Framework SerializableMetadataRecordSetDescription Property
Gets or sets the SetDescription.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 27)]
public string SetDescription { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 27)>
Public Property SetDescription As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 27)>]
member SetDescription : string with get, set

function get_SetDescription();
function set_SetDescription(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 27)]
property String^ SetDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.SourceID Property

Grid Solutions Framework SerializableMetadataRecordSourceID Property
Gets or sets the SourceID.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 12)]
public int SourceID { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 12)>
Public Property SourceID As Integer
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 12)>]
member SourceID : int with get, set

function get_SourceID();
function set_SourceID(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 12)]
property int SourceID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.StepCheck Property

Grid Solutions Framework SerializableMetadataRecordStepCheck Property
Gets or sets the StepCheck.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 32)]
[XmlAttributeAttribute]
public bool StepCheck { get; set; }
<DataMemberAttribute(Order := 32)>
<XmlAttributeAttribute>
Public Property StepCheck As Boolean
    Get
    Set
[<DataMemberAttribute(Order = 32)>]
[<XmlAttributeAttribute>]
member StepCheck : bool with get, set

function get_StepCheck();
function set_StepCheck(value);
public:
[DataMemberAttribute(Order = 32)]
[XmlAttributeAttribute]
property bool StepCheck {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Synonym1 Property

Grid Solutions Framework SerializableMetadataRecordSynonym1 Property
Gets or sets the Synonym1.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 3)]
[XmlAttributeAttribute]
public string Synonym1 { get; set; }
<DataMemberAttribute(Order := 3)>
<XmlAttributeAttribute>
Public Property Synonym1 As String
    Get
    Set
[<DataMemberAttribute(Order = 3)>]
[<XmlAttributeAttribute>]
member Synonym1 : string with get, set

function get_Synonym1();
function set_Synonym1(value);
public:
[DataMemberAttribute(Order = 3)]
[XmlAttributeAttribute]
property String^ Synonym1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Synonym2 Property

Grid Solutions Framework SerializableMetadataRecordSynonym2 Property
Gets or sets the Synonym2.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 4)]
[XmlAttributeAttribute]
public string Synonym2 { get; set; }
<DataMemberAttribute(Order := 4)>
<XmlAttributeAttribute>
Public Property Synonym2 As String
    Get
    Set
[<DataMemberAttribute(Order = 4)>]
[<XmlAttributeAttribute>]
member Synonym2 : string with get, set

function get_Synonym2();
function set_Synonym2(value);
public:
[DataMemberAttribute(Order = 4)]
[XmlAttributeAttribute]
property String^ Synonym2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.Synonym3 Property

Grid Solutions Framework SerializableMetadataRecordSynonym3 Property
Gets or sets the Synonym3.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 5)]
[XmlAttributeAttribute]
public string Synonym3 { get; set; }
<DataMemberAttribute(Order := 5)>
<XmlAttributeAttribute>
Public Property Synonym3 As String
    Get
    Set
[<DataMemberAttribute(Order = 5)>]
[<XmlAttributeAttribute>]
member Synonym3 : string with get, set

function get_Synonym3();
function set_Synonym3(value);
public:
[DataMemberAttribute(Order = 5)]
[XmlAttributeAttribute]
property String^ Synonym3 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.SystemName Property

Grid Solutions Framework SerializableMetadataRecordSystemName Property
Gets or sets the SystemName.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 11)]
[XmlAttributeAttribute]
public string SystemName { get; set; }
<DataMemberAttribute(Order := 11)>
<XmlAttributeAttribute>
Public Property SystemName As String
    Get
    Set
[<DataMemberAttribute(Order = 11)>]
[<XmlAttributeAttribute>]
member SystemName : string with get, set

function get_SystemName();
function set_SystemName(value);
public:
[DataMemberAttribute(Order = 11)]
[XmlAttributeAttribute]
property String^ SystemName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableMetadataRecord.UnitNumber Property

Grid Solutions Framework SerializableMetadataRecordUnitNumber Property
Gets or sets the UnitNumber.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 10)]
public int UnitNumber { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 10)>
Public Property UnitNumber As Integer
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 10)>]
member UnitNumber : int with get, set

function get_UnitNumber();
function set_UnitNumber(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 10)]
property int UnitNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableMetadataRecord Class
GSF.Historian.DataServices Namespace


SerializableReadRequestData Class

Grid Solutions Framework SerializableReadRequestData Class
Represents a container for JSON serialized time-series data read request.
Inheritance Hierarchy
SystemObject
GSF.Historian.DataServicesSerializableReadRequestData

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataContractAttribute(Name = "ReadRequestData")]
[XmlTypeAttribute("ReadRequestData")]
public class SerializableReadRequestData
<DataContractAttribute(Name := "ReadRequestData")>
<XmlTypeAttribute("ReadRequestData")>
Public Class SerializableReadRequestData
[<DataContractAttribute(Name = "ReadRequestData")>]
[<XmlTypeAttribute("ReadRequestData")>]
type SerializableReadRequestData =  class end
GSF.Historian.DataServices.SerializableReadRequestData = function();

Type.createClass(
    'GSF.Historian.DataServices.SerializableReadRequestData');
[DataContractAttribute(Name = L"ReadRequestData")]
[XmlTypeAttribute(L"ReadRequestData")]
public ref class SerializableReadRequestData

The SerializableReadRequestData type exposes the following members.

Constructors
 | Name | Description
Public method | SerializableReadRequestData | Initializes a new instance of the SerializableReadRequestData class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | endTime | End time.
Public property | idArray | XML array of integer historian ID's.
Public property | startTime | Start time.
Top
See Also

Reference

GSF.Historian.DataServices Namespace


SerializableReadRequestData Constructor

Grid Solutions Framework SerializableReadRequestData Constructor
Initializes a new instance of the SerializableReadRequestData class

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableReadRequestData()
Public Sub New
new : unit -> SerializableReadRequestData
GSF.Historian.DataServices.SerializableReadRequestData = function();
public:
SerializableReadRequestData()
See Also

Reference

SerializableReadRequestData Class
GSF.Historian.DataServices Namespace


SerializableReadRequestData Methods

Grid Solutions Framework SerializableReadRequestData Methods

The SerializableReadRequestData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SerializableReadRequestData Class
GSF.Historian.DataServices Namespace


SerializableReadRequestData Properties

Grid Solutions Framework SerializableReadRequestData Properties

The SerializableReadRequestData type exposes the following members.

Properties
 | Name | Description
Public property | endTime | End time.
Public property | idArray | XML array of integer historian ID's.
Public property | startTime | Start time.
Top
See Also

Reference

SerializableReadRequestData Class
GSF.Historian.DataServices Namespace


SerializableReadRequestData.endTime Property

Grid Solutions Framework SerializableReadRequestDataendTime Property
End time.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 2)]
public string endTime { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 2)>
Public Property endTime As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 2)>]
member endTime : string with get, set

function get_endTime();
function set_endTime(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 2)]
property String^ endTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableReadRequestData Class
GSF.Historian.DataServices Namespace


SerializableReadRequestData.idArray Property

Grid Solutions Framework SerializableReadRequestDataidArray Property
XML array of integer historian ID's.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 0)]
[XmlArrayAttribute]
public int[] idArray { get; set; }
<DataMemberAttribute(Order := 0)>
<XmlArrayAttribute>
Public Property idArray As Integer()
    Get
    Set
[<DataMemberAttribute(Order = 0)>]
[<XmlArrayAttribute>]
member idArray : int[] with get, set

function get_idArray();
function set_idArray(value);
public:
[DataMemberAttribute(Order = 0)]
[XmlArrayAttribute]
property array<int>^ idArray {
    array<int>^ get ();
    void set (array<int>^ value);
}

Property Value

Type: Int32
See Also

Reference

SerializableReadRequestData Class
GSF.Historian.DataServices Namespace


SerializableReadRequestData.startTime Property

Grid Solutions Framework SerializableReadRequestDatastartTime Property
Start time.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 1)]
[XmlAttributeAttribute]
public string startTime { get; set; }
<DataMemberAttribute(Order := 1)>
<XmlAttributeAttribute>
Public Property startTime As String
    Get
    Set
[<DataMemberAttribute(Order = 1)>]
[<XmlAttributeAttribute>]
member startTime : string with get, set

function get_startTime();
function set_startTime(value);
public:
[DataMemberAttribute(Order = 1)]
[XmlAttributeAttribute]
property String^ startTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableReadRequestData Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesData Class

Grid Solutions Framework SerializableTimeSeriesData Class
Represents a container for SerializableTimeSeriesDataPoints that can be serialized using XmlSerializer or DataContractJsonSerializer.
Inheritance Hierarchy
SystemObject
GSF.Historian.DataServicesSerializableTimeSeriesData

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlTypeAttribute("TimeSeriesData")]
[DataContractAttribute(Name = "TimeSeriesData", Namespace = "")]
public class SerializableTimeSeriesData
<XmlTypeAttribute("TimeSeriesData")>
<DataContractAttribute(Name := "TimeSeriesData", Namespace := "")>
Public Class SerializableTimeSeriesData
[<XmlTypeAttribute("TimeSeriesData")>]
[<DataContractAttribute(Name = "TimeSeriesData", Namespace = "")>]
type SerializableTimeSeriesData =  class end
GSF.Historian.DataServices.SerializableTimeSeriesData = function();

Type.createClass(
    'GSF.Historian.DataServices.SerializableTimeSeriesData');
[XmlTypeAttribute(L"TimeSeriesData")]
[DataContractAttribute(Name = L"TimeSeriesData", Namespace = L"")]
public ref class SerializableTimeSeriesData

The SerializableTimeSeriesData type exposes the following members.

Constructors
 | Name | Description
Public method | SerializableTimeSeriesData | Initializes a new instance of the SerializableTimeSeriesData class.
Public method | SerializableTimeSeriesData(IEnumerableIDataPoint) | Initializes a new instance of the SerializableTimeSeriesData class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | TimeSeriesDataPoints | Gets or sets the SerializableTimeSeriesDataPoints contained in the SerializableTimeSeriesData.
Top
Examples
This is the output for SerializableTimeSeriesData serialized using XmlSerializer:
Copy
<?xml version="1.0" encoding="utf-8" ?>
<TimeSeriesData xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <TimeSeriesDataPoints>
    <TimeSeriesDataPoint HistorianID="1" Time="21-Aug-2009 14:29:52.634" Value="59.9537773" Quality="Good" />
    <TimeSeriesDataPoint HistorianID="2" Time="21-Aug-2009 14:29:52.668" Value="60.0351028" Quality="Good" />
    <TimeSeriesDataPoint HistorianID="3" Time="21-Aug-2009 14:29:52.702" Value="59.99268" Quality="Good" />
    <TimeSeriesDataPoint HistorianID="4" Time="21-Aug-2009 14:29:52.736" Value="59.99003" Quality="Good" />
    <TimeSeriesDataPoint HistorianID="5" Time="21-Aug-2009 14:29:52.770" Value="59.9532661" Quality="Good" />
  </TimeSeriesDataPoints>
</TimeSeriesData>
This is the output for SerializableTimeSeriesData serialized using DataContractSerializer:
Copy
<TimeSeriesData xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
  <TimeSeriesDataPoints>
    <TimeSeriesDataPoint>
      <HistorianID>1</HistorianID>
      <Time>21-Aug-2009 14:31:56.176</Time>
      <Value>60.0272522</Value>
      <Quality>Good</Quality>
    </TimeSeriesDataPoint>
    <TimeSeriesDataPoint>
      <HistorianID>2</HistorianID>
      <Time>21-Aug-2009 14:31:56.210</Time>
      <Value>60.0283241</Value>
      <Quality>Good</Quality>
    </TimeSeriesDataPoint>
    <TimeSeriesDataPoint>
      <HistorianID>3</HistorianID>
      <Time>21-Aug-2009 14:31:56.244</Time>
      <Value>60.0418167</Value>
      <Quality>Good</Quality>
    </TimeSeriesDataPoint>
    <TimeSeriesDataPoint>
      <HistorianID>4</HistorianID>
      <Time>21-Aug-2009 14:31:56.278</Time>
      <Value>60.0049438</Value>
      <Quality>Good</Quality>
    </TimeSeriesDataPoint>
    <TimeSeriesDataPoint>
      <HistorianID>5</HistorianID>
      <Time>21-Aug-2009 14:31:56.312</Time>
      <Value>59.9982834</Value>
      <Quality>Good</Quality>
    </TimeSeriesDataPoint>
  </TimeSeriesDataPoints>
</TimeSeriesData>
This is the output for SerializableTimeSeriesData serialized using DataContractJsonSerializer:
Copy
{
  "TimeSeriesDataPoints":
    [{"HistorianID":1,
      "Time":"21-Aug-2009 14:37:04.804",
      "Value":59.9637527,
      "Quality":29},
     {"HistorianID":2,
      "Time":"21-Aug-2009 14:37:04.838",
      "Value":60.0154762,
      "Quality":29},
     {"HistorianID":3,
      "Time":"21-Aug-2009 14:37:04.872",
      "Value":59.977684,
      "Quality":29},
     {"HistorianID":3,
      "Time":"21-Aug-2009 14:37:04.906",
      "Value":59.97335,
      "Quality":29},
     {"HistorianID":5,
      "Time":"21-Aug-2009 14:37:04.940",
      "Value":59.974678,
      "Quality":29}]
}
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.Historian.DataServicesSerializableTimeSeriesDataPoint
System.Xml.SerializationXmlSerializer
System.Runtime.SerializationDataContractSerializer
System.Runtime.Serialization.JsonDataContractJsonSerializer


SerializableTimeSeriesData Constructor

Grid Solutions Framework SerializableTimeSeriesData Constructor
Overload List
 | Name | Description
Public method | SerializableTimeSeriesData | Initializes a new instance of the SerializableTimeSeriesData class.
Public method | SerializableTimeSeriesData(IEnumerableIDataPoint) | Initializes a new instance of the SerializableTimeSeriesData class.
Top
See Also

Reference

SerializableTimeSeriesData Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesData Constructor

Grid Solutions Framework SerializableTimeSeriesData Constructor
Initializes a new instance of the SerializableTimeSeriesData class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData()
Public Sub New
new : unit -> SerializableTimeSeriesData
GSF.Historian.DataServices.SerializableTimeSeriesData = function();
public:
SerializableTimeSeriesData()
See Also

Reference

SerializableTimeSeriesData Class
SerializableTimeSeriesData Overload
GSF.Historian.DataServices Namespace


SerializableTimeSeriesData Constructor (IEnumerable(IDataPoint))

Grid Solutions Framework SerializableTimeSeriesData Constructor (IEnumerableIDataPoint)
Initializes a new instance of the SerializableTimeSeriesData class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData(
    IEnumerable<IDataPoint> dataPoints
)
Public Sub New (
    dataPoints As IEnumerable(Of IDataPoint)
)
new :
        dataPoints : IEnumerable<IDataPoint> -> SerializableTimeSeriesData
GSF.Historian.DataServices.SerializableTimeSeriesData = function(dataPoints);
public:
SerializableTimeSeriesData(
    IEnumerable<IDataPoint^>^ dataPoints
)

Parameters

dataPoints
Type: System.Collections.GenericIEnumerable IDataPoint
List of IDataPoint from which SerializableTimeSeriesData is to be initialized.
Exceptions
Exception | Condition
ArgumentNullException | dataPoints is null.
See Also

Reference

SerializableTimeSeriesData Class
SerializableTimeSeriesData Overload
GSF.Historian.DataServices Namespace


SerializableTimeSeriesData Methods

Grid Solutions Framework SerializableTimeSeriesData Methods

The SerializableTimeSeriesData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SerializableTimeSeriesData Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesData Properties

Grid Solutions Framework SerializableTimeSeriesData Properties

The SerializableTimeSeriesData type exposes the following members.

Properties
 | Name | Description
Public property | TimeSeriesDataPoints | Gets or sets the SerializableTimeSeriesDataPoints contained in the SerializableTimeSeriesData.
Top
See Also

Reference

SerializableTimeSeriesData Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesData.TimeSeriesDataPoints Property

Grid Solutions Framework SerializableTimeSeriesDataTimeSeriesDataPoints Property
Gets or sets the SerializableTimeSeriesDataPoints contained in the SerializableTimeSeriesData.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlArrayAttribute]
[DataMemberAttribute]
public SerializableTimeSeriesDataPoint[] TimeSeriesDataPoints { get; set; }
<XmlArrayAttribute>
<DataMemberAttribute>
Public Property TimeSeriesDataPoints As SerializableTimeSeriesDataPoint()
    Get
    Set
[<XmlArrayAttribute>]
[<DataMemberAttribute>]
member TimeSeriesDataPoints : SerializableTimeSeriesDataPoint[] with get, set

function get_TimeSeriesDataPoints();
function set_TimeSeriesDataPoints(value);
public:
[XmlArrayAttribute]
[DataMemberAttribute]
property array<SerializableTimeSeriesDataPoint^>^ TimeSeriesDataPoints {
    array<SerializableTimeSeriesDataPoint^>^ get ();
    void set (array<SerializableTimeSeriesDataPoint^>^ value);
}

Property Value

Type: SerializableTimeSeriesDataPoint
See Also

Reference

SerializableTimeSeriesData Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint Class

Grid Solutions Framework SerializableTimeSeriesDataPoint Class
Represents a time-series data-point that can be serialized using XmlSerializer, DataContractSerializer or DataContractJsonSerializer.
Inheritance Hierarchy
SystemObject
GSF.Historian.DataServicesSerializableTimeSeriesDataPoint

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlTypeAttribute("TimeSeriesDataPoint")]
[DataContractAttribute(Name = "TimeSeriesDataPoint", Namespace = "")]
public class SerializableTimeSeriesDataPoint
<XmlTypeAttribute("TimeSeriesDataPoint")>
<DataContractAttribute(Name := "TimeSeriesDataPoint", Namespace := "")>
Public Class SerializableTimeSeriesDataPoint
[<XmlTypeAttribute("TimeSeriesDataPoint")>]
[<DataContractAttribute(Name = "TimeSeriesDataPoint", Namespace = "")>]
type SerializableTimeSeriesDataPoint =  class end
GSF.Historian.DataServices.SerializableTimeSeriesDataPoint = function();

Type.createClass(
    'GSF.Historian.DataServices.SerializableTimeSeriesDataPoint');
[XmlTypeAttribute(L"TimeSeriesDataPoint")]
[DataContractAttribute(Name = L"TimeSeriesDataPoint", Namespace = L"")]
public ref class SerializableTimeSeriesDataPoint

The SerializableTimeSeriesDataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | SerializableTimeSeriesDataPoint | Initializes a new instance of the SerializableTimeSeriesDataPoint class.
Public method | SerializableTimeSeriesDataPoint(IDataPoint) | Initializes a new instance of the SerializableTimeSeriesDataPoint class.
Top
Methods
 | Name | Description
Public method | Deflate | Returns an IDataPoint object for this SerializableTimeSeriesDataPoint.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | HistorianID | Gets or sets the HistorianID.
Public property | Quality | Gets or sets the Quality.
Public property | Time | Gets or sets the String representation of Time.
Public property | Value | Gets or sets the Value.
Top
Examples
This is the output for SerializableTimeSeriesDataPoint serialized using XmlSerializer:
Copy
<?xml version="1.0"?>
<TimeSeriesDataPoint xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
  HistorianID="1" Time="2009-08-21 14:21:23.236" Value="60.0419579" Quality="Good" />
This is the output for SerializableTimeSeriesDataPoint serialized using DataContractSerializer:
Copy
<TimeSeriesDataPoint xmlns:i="http://www.w3.org/2001/XMLSchema-instance">
  <HistorianID>1</HistorianID>
  <Time>2009-08-21 14:21:54.612</Time>
  <Value>60.025547</Value>
  <Quality>Good</Quality>
</TimeSeriesDataPoint>
This is the output for SerializableTimeSeriesDataPoint serialized using DataContractJsonSerializer:
Copy
{
  "HistorianID":1,
  "Time":"2009-08-21 14:22:26.971",
  "Value":59.9974136,
  "Quality":29
}
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.HistorianIDataPoint
System.Xml.SerializationXmlSerializer
System.Runtime.SerializationDataContractSerializer
System.Runtime.Serialization.JsonDataContractJsonSerializer


SerializableTimeSeriesDataPoint Constructor

Grid Solutions Framework SerializableTimeSeriesDataPoint Constructor
Overload List
 | Name | Description
Public method | SerializableTimeSeriesDataPoint | Initializes a new instance of the SerializableTimeSeriesDataPoint class.
Public method | SerializableTimeSeriesDataPoint(IDataPoint) | Initializes a new instance of the SerializableTimeSeriesDataPoint class.
Top
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint Constructor

Grid Solutions Framework SerializableTimeSeriesDataPoint Constructor
Initializes a new instance of the SerializableTimeSeriesDataPoint class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesDataPoint()
Public Sub New
new : unit -> SerializableTimeSeriesDataPoint
GSF.Historian.DataServices.SerializableTimeSeriesDataPoint = function();
public:
SerializableTimeSeriesDataPoint()
See Also

Reference

SerializableTimeSeriesDataPoint Class
SerializableTimeSeriesDataPoint Overload
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint Constructor (IDataPoint)

Grid Solutions Framework SerializableTimeSeriesDataPoint Constructor (IDataPoint)
Initializes a new instance of the SerializableTimeSeriesDataPoint class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesDataPoint(
    IDataPoint dataPoint
)
Public Sub New (
    dataPoint As IDataPoint
)
new :
        dataPoint : IDataPoint -> SerializableTimeSeriesDataPoint
GSF.Historian.DataServices.SerializableTimeSeriesDataPoint = function(dataPoint);
public:
SerializableTimeSeriesDataPoint(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint from which SerializableTimeSeriesDataPoint is to be initialized.
Exceptions
Exception | Condition
ArgumentNullException | dataPoint is null.
See Also

Reference

SerializableTimeSeriesDataPoint Class
SerializableTimeSeriesDataPoint Overload
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint Methods

Grid Solutions Framework SerializableTimeSeriesDataPoint Methods

The SerializableTimeSeriesDataPoint type exposes the following members.

Methods
 | Name | Description
Public method | Deflate | Returns an IDataPoint object for this SerializableTimeSeriesDataPoint.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint.Deflate Method

Grid Solutions Framework SerializableTimeSeriesDataPointDeflate Method
Returns an IDataPoint object for this SerializableTimeSeriesDataPoint.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDataPoint Deflate()
Public Function Deflate As IDataPoint
member Deflate : unit -> IDataPoint

function Deflate();
public:
IDataPoint^ Deflate()

Return Value

Type: IDataPoint
An IDataPoint object.
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint Properties

Grid Solutions Framework SerializableTimeSeriesDataPoint Properties

The SerializableTimeSeriesDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | HistorianID | Gets or sets the HistorianID.
Public property | Quality | Gets or sets the Quality.
Public property | Time | Gets or sets the String representation of Time.
Public property | Value | Gets or sets the Value.
Top
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint.HistorianID Property

Grid Solutions Framework SerializableTimeSeriesDataPointHistorianID Property
Gets or sets the HistorianID.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 0)]
[XmlAttributeAttribute]
public int HistorianID { get; set; }
<DataMemberAttribute(Order := 0)>
<XmlAttributeAttribute>
Public Property HistorianID As Integer
    Get
    Set
[<DataMemberAttribute(Order = 0)>]
[<XmlAttributeAttribute>]
member HistorianID : int with get, set

function get_HistorianID();
function set_HistorianID(value);
public:
[DataMemberAttribute(Order = 0)]
[XmlAttributeAttribute]
property int HistorianID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint.Quality Property

Grid Solutions Framework SerializableTimeSeriesDataPointQuality Property
Gets or sets the Quality.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 3)]
[XmlAttributeAttribute]
public Quality Quality { get; set; }
<DataMemberAttribute(Order := 3)>
<XmlAttributeAttribute>
Public Property Quality As Quality
    Get
    Set
[<DataMemberAttribute(Order = 3)>]
[<XmlAttributeAttribute>]
member Quality : Quality with get, set

function get_Quality();
function set_Quality(value);
public:
[DataMemberAttribute(Order = 3)]
[XmlAttributeAttribute]
property Quality Quality {
    Quality get ();
    void set (Quality value);
}

Property Value

Type: Quality
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint.Time Property

Grid Solutions Framework SerializableTimeSeriesDataPointTime Property
Gets or sets the String representation of Time.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 1)]
public string Time { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 1)>
Public Property Time As String
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 1)>]
member Time : string with get, set

function get_Time();
function set_Time(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 1)]
property String^ Time {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


SerializableTimeSeriesDataPoint.Value Property

Grid Solutions Framework SerializableTimeSeriesDataPointValue Property
Gets or sets the Value.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 2)]
public float Value { get; set; }
<XmlAttributeAttribute>
<DataMemberAttribute(Order := 2)>
Public Property Value As Single
    Get
    Set
[<XmlAttributeAttribute>]
[<DataMemberAttribute(Order = 2)>]
member Value : float32 with get, set

function get_Value();
function set_Value(value);
public:
[XmlAttributeAttribute]
[DataMemberAttribute(Order = 2)]
property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

SerializableTimeSeriesDataPoint Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService Class

Grid Solutions Framework TimeSeriesDataService Class
Represents a REST web service for time-series data.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.ServiceModelSelfHostingService
GSF.Historian.DataServicesDataService
GSF.Historian.DataServicesTimeSeriesDataService

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, ConcurrencyMode = ConcurrencyMode.Multiple)]
public class TimeSeriesDataService : DataService,
    ITimeSeriesDataService
<ServiceBehaviorAttribute(InstanceContextMode := InstanceContextMode.Single, ConcurrencyMode := ConcurrencyMode.Multiple)>
Public Class TimeSeriesDataService
    Inherits DataService
    Implements ITimeSeriesDataService
[<ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, ConcurrencyMode = ConcurrencyMode.Multiple)>]
type TimeSeriesDataService =
    class
        inherit DataService
        interface ITimeSeriesDataService
    end
GSF.Historian.DataServices.TimeSeriesDataService = function();

Type.createClass(
    'GSF.Historian.DataServices.TimeSeriesDataService',
    GSF.Historian.DataServices.DataService,
    GSF.Historian.DataServices.ITimeSeriesDataService);
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode::Single, ConcurrencyMode = ConcurrencyMode::Multiple)]
public ref class TimeSeriesDataService : public DataService,
    ITimeSeriesDataService

The TimeSeriesDataService type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSeriesDataService | Initializes a new instance of the TimeSeriesDataService class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Inherited from DataService.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | ReadRangeCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadRangeCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadRangeHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadRangeHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadSelectCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsJsonPost | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteTimeSeriesDataAsJson | Writes data received in Json format to the Archive.
Public method | WriteTimeSeriesDataAsXml | Writes data received in Xml format to the Archive.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | Archive | Gets or sets the IArchive used by the web service for its data. (Inherited from DataService.)
Public property | CloseTimeout | Gets or sets the desired CloseTimeout used as the interval of time provided for a connection to close before the transport raises an exception. (Inherited from DataService.)
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.DataServices Namespace
GSF.Historian.DataServicesSerializableTimeSeriesData


TimeSeriesDataService Constructor

Grid Solutions Framework TimeSeriesDataService Constructor
Initializes a new instance of the TimeSeriesDataService class.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeSeriesDataService()
Public Sub New
new : unit -> TimeSeriesDataService
GSF.Historian.DataServices.TimeSeriesDataService = function();
public:
TimeSeriesDataService()
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService Methods

Grid Solutions Framework TimeSeriesDataService Methods

The TimeSeriesDataService type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Inherited from DataService.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | ReadRangeCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadRangeCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadRangeHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadRangeHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectCurrentTimeSeriesDataAsJson | Reads current time-series data from the Archive and sends it in Json format.
Public method | ReadSelectCurrentTimeSeriesDataAsXml | Reads current time-series data from the Archive and sends it in Xml format.
Public method | ReadSelectHistoricTimeSeriesDataAsJson | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsJsonPost | Reads historic time-series data from the Archive and sends it in Json format.
Public method | ReadSelectHistoricTimeSeriesDataAsXml | Reads historic time-series data from the Archive and sends it in Xml format.
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Inherited from DataService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteTimeSeriesDataAsJson | Writes data received in Json format to the Archive.
Public method | WriteTimeSeriesDataAsXml | Writes data received in Xml format to the Archive.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadRangeCurrentTimeSeriesDataAsJson Method

Grid Solutions Framework TimeSeriesDataServiceReadRangeCurrentTimeSeriesDataAsJson Method
Reads current time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadRangeCurrentTimeSeriesDataAsJson(
    string fromID,
    string toID
)
Public Function ReadRangeCurrentTimeSeriesDataAsJson (
    fromID As String,
    toID As String
) As SerializableTimeSeriesData
abstract ReadRangeCurrentTimeSeriesDataAsJson :
        fromID : string *
        toID : string -> SerializableTimeSeriesData
override ReadRangeCurrentTimeSeriesDataAsJson :
        fromID : string *
        toID : string -> SerializableTimeSeriesData
function ReadRangeCurrentTimeSeriesDataAsJson(fromID, toID);
public:
virtual SerializableTimeSeriesData^ ReadRangeCurrentTimeSeriesDataAsJson(
    String^ fromID,
    String^ toID
) sealed

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which current time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadRangeCurrentTimeSeriesDataAsJson(String, String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadRangeCurrentTimeSeriesDataAsXml Method

Grid Solutions Framework TimeSeriesDataServiceReadRangeCurrentTimeSeriesDataAsXml Method
Reads current time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadRangeCurrentTimeSeriesDataAsXml(
    string fromID,
    string toID
)
Public Function ReadRangeCurrentTimeSeriesDataAsXml (
    fromID As String,
    toID As String
) As SerializableTimeSeriesData
abstract ReadRangeCurrentTimeSeriesDataAsXml :
        fromID : string *
        toID : string -> SerializableTimeSeriesData
override ReadRangeCurrentTimeSeriesDataAsXml :
        fromID : string *
        toID : string -> SerializableTimeSeriesData
function ReadRangeCurrentTimeSeriesDataAsXml(fromID, toID);
public:
virtual SerializableTimeSeriesData^ ReadRangeCurrentTimeSeriesDataAsXml(
    String^ fromID,
    String^ toID
) sealed

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which current time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadRangeCurrentTimeSeriesDataAsXml(String, String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadRangeHistoricTimeSeriesDataAsJson Method

Grid Solutions Framework TimeSeriesDataServiceReadRangeHistoricTimeSeriesDataAsJson Method
Reads historic time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadRangeHistoricTimeSeriesDataAsJson(
    string fromID,
    string toID,
    string startTime,
    string endTime
)
Public Function ReadRangeHistoricTimeSeriesDataAsJson (
    fromID As String,
    toID As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
abstract ReadRangeHistoricTimeSeriesDataAsJson :
        fromID : string *
        toID : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
override ReadRangeHistoricTimeSeriesDataAsJson :
        fromID : string *
        toID : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
function ReadRangeHistoricTimeSeriesDataAsJson(fromID, toID, startTime, endTime);
public:
virtual SerializableTimeSeriesData^ ReadRangeHistoricTimeSeriesDataAsJson(
    String^ fromID,
    String^ toID,
    String^ startTime,
    String^ endTime
) sealed

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which historic time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadRangeHistoricTimeSeriesDataAsJson(String, String, String, String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadRangeHistoricTimeSeriesDataAsXml Method

Grid Solutions Framework TimeSeriesDataServiceReadRangeHistoricTimeSeriesDataAsXml Method
Reads historic time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadRangeHistoricTimeSeriesDataAsXml(
    string fromID,
    string toID,
    string startTime,
    string endTime
)
Public Function ReadRangeHistoricTimeSeriesDataAsXml (
    fromID As String,
    toID As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
abstract ReadRangeHistoricTimeSeriesDataAsXml :
        fromID : string *
        toID : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
override ReadRangeHistoricTimeSeriesDataAsXml :
        fromID : string *
        toID : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
function ReadRangeHistoricTimeSeriesDataAsXml(fromID, toID, startTime, endTime);
public:
virtual SerializableTimeSeriesData^ ReadRangeHistoricTimeSeriesDataAsXml(
    String^ fromID,
    String^ toID,
    String^ startTime,
    String^ endTime
) sealed

Parameters

fromID
Type: SystemString
Starting ID in the ID range for which historic time-series data is to be read.
toID
Type: SystemString
Ending ID in the ID range for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadRangeHistoricTimeSeriesDataAsXml(String, String, String, String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadSelectCurrentTimeSeriesDataAsJson Method

Grid Solutions Framework TimeSeriesDataServiceReadSelectCurrentTimeSeriesDataAsJson Method
Reads current time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadSelectCurrentTimeSeriesDataAsJson(
    string idList
)
Public Function ReadSelectCurrentTimeSeriesDataAsJson (
    idList As String
) As SerializableTimeSeriesData
abstract ReadSelectCurrentTimeSeriesDataAsJson :
        idList : string -> SerializableTimeSeriesData
override ReadSelectCurrentTimeSeriesDataAsJson :
        idList : string -> SerializableTimeSeriesData
function ReadSelectCurrentTimeSeriesDataAsJson(idList);
public:
virtual SerializableTimeSeriesData^ ReadSelectCurrentTimeSeriesDataAsJson(
    String^ idList
) sealed

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadSelectCurrentTimeSeriesDataAsJson(String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadSelectCurrentTimeSeriesDataAsXml Method

Grid Solutions Framework TimeSeriesDataServiceReadSelectCurrentTimeSeriesDataAsXml Method
Reads current time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadSelectCurrentTimeSeriesDataAsXml(
    string idList
)
Public Function ReadSelectCurrentTimeSeriesDataAsXml (
    idList As String
) As SerializableTimeSeriesData
abstract ReadSelectCurrentTimeSeriesDataAsXml :
        idList : string -> SerializableTimeSeriesData
override ReadSelectCurrentTimeSeriesDataAsXml :
        idList : string -> SerializableTimeSeriesData
function ReadSelectCurrentTimeSeriesDataAsXml(idList);
public:
virtual SerializableTimeSeriesData^ ReadSelectCurrentTimeSeriesDataAsXml(
    String^ idList
) sealed

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which current time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadSelectCurrentTimeSeriesDataAsXml(String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadSelectHistoricTimeSeriesDataAsJson Method

Grid Solutions Framework TimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsJson Method
Reads historic time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadSelectHistoricTimeSeriesDataAsJson(
    string idList,
    string startTime,
    string endTime
)
Public Function ReadSelectHistoricTimeSeriesDataAsJson (
    idList As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
abstract ReadSelectHistoricTimeSeriesDataAsJson :
        idList : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
override ReadSelectHistoricTimeSeriesDataAsJson :
        idList : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
function ReadSelectHistoricTimeSeriesDataAsJson(idList, startTime, endTime);
public:
virtual SerializableTimeSeriesData^ ReadSelectHistoricTimeSeriesDataAsJson(
    String^ idList,
    String^ startTime,
    String^ endTime
) sealed

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsJson(String, String, String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadSelectHistoricTimeSeriesDataAsJsonPost Method

Grid Solutions Framework TimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsJsonPost Method
Reads historic time-series data from the Archive and sends it in Json format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadSelectHistoricTimeSeriesDataAsJsonPost(
    SerializableReadRequestData data
)
Public Function ReadSelectHistoricTimeSeriesDataAsJsonPost (
    data As SerializableReadRequestData
) As SerializableTimeSeriesData
abstract ReadSelectHistoricTimeSeriesDataAsJsonPost :
        data : SerializableReadRequestData -> SerializableTimeSeriesData
override ReadSelectHistoricTimeSeriesDataAsJsonPost :
        data : SerializableReadRequestData -> SerializableTimeSeriesData
function ReadSelectHistoricTimeSeriesDataAsJsonPost(data);
public:
virtual SerializableTimeSeriesData^ ReadSelectHistoricTimeSeriesDataAsJsonPost(
    SerializableReadRequestData^ data
) sealed

Parameters

data
Type: GSF.Historian.DataServicesSerializableReadRequestData
JSON serialized post request.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsJsonPost(SerializableReadRequestData)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.ReadSelectHistoricTimeSeriesDataAsXml Method

Grid Solutions Framework TimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsXml Method
Reads historic time-series data from the Archive and sends it in Xml format.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableTimeSeriesData ReadSelectHistoricTimeSeriesDataAsXml(
    string idList,
    string startTime,
    string endTime
)
Public Function ReadSelectHistoricTimeSeriesDataAsXml (
    idList As String,
    startTime As String,
    endTime As String
) As SerializableTimeSeriesData
abstract ReadSelectHistoricTimeSeriesDataAsXml :
        idList : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
override ReadSelectHistoricTimeSeriesDataAsXml :
        idList : string *
        startTime : string *
        endTime : string -> SerializableTimeSeriesData
function ReadSelectHistoricTimeSeriesDataAsXml(idList, startTime, endTime);
public:
virtual SerializableTimeSeriesData^ ReadSelectHistoricTimeSeriesDataAsXml(
    String^ idList,
    String^ startTime,
    String^ endTime
) sealed

Parameters

idList
Type: SystemString
A comma or semi-colon delimited list of IDs for which historic time-series data is to be read.
startTime
Type: SystemString
Start time in String format of the timespan for which historic time-series data is to be read.
endTime
Type: SystemString
End time in String format of the timespan for which historic time-series data is to be read.

Return Value

Type: SerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceReadSelectHistoricTimeSeriesDataAsXml(String, String, String)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.WriteTimeSeriesDataAsJson Method

Grid Solutions Framework TimeSeriesDataServiceWriteTimeSeriesDataAsJson Method
Writes data received in Json format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteTimeSeriesDataAsJson(
    SerializableTimeSeriesData data
)
Public Sub WriteTimeSeriesDataAsJson (
    data As SerializableTimeSeriesData
)
abstract WriteTimeSeriesDataAsJson :
        data : SerializableTimeSeriesData -> unit
override WriteTimeSeriesDataAsJson :
        data : SerializableTimeSeriesData -> unit
function WriteTimeSeriesDataAsJson(data);
public:
virtual void WriteTimeSeriesDataAsJson(
    SerializableTimeSeriesData^ data
) sealed

Parameters

data
Type: GSF.Historian.DataServicesSerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceWriteTimeSeriesDataAsJson(SerializableTimeSeriesData)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService.WriteTimeSeriesDataAsXml Method

Grid Solutions Framework TimeSeriesDataServiceWriteTimeSeriesDataAsXml Method
Writes data received in Xml format to the Archive.

Namespace: GSF.Historian.DataServices
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteTimeSeriesDataAsXml(
    SerializableTimeSeriesData data
)
Public Sub WriteTimeSeriesDataAsXml (
    data As SerializableTimeSeriesData
)
abstract WriteTimeSeriesDataAsXml :
        data : SerializableTimeSeriesData -> unit
override WriteTimeSeriesDataAsXml :
        data : SerializableTimeSeriesData -> unit
function WriteTimeSeriesDataAsXml(data);
public:
virtual void WriteTimeSeriesDataAsXml(
    SerializableTimeSeriesData^ data
) sealed

Parameters

data
Type: GSF.Historian.DataServicesSerializableTimeSeriesData
An SerializableTimeSeriesData object.

Implements

ITimeSeriesDataServiceWriteTimeSeriesDataAsXml(SerializableTimeSeriesData)
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService Properties

Grid Solutions Framework TimeSeriesDataService Properties

The TimeSeriesDataService type exposes the following members.

Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | Archive | Gets or sets the IArchive used by the web service for its data. (Inherited from DataService.)
Public property | CloseTimeout | Gets or sets the desired CloseTimeout used as the interval of time provided for a connection to close before the transport raises an exception. (Inherited from DataService.)
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


TimeSeriesDataService Events

Grid Solutions Framework TimeSeriesDataService Events

The TimeSeriesDataService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

TimeSeriesDataService Class
GSF.Historian.DataServices Namespace


GSF.Historian.Exporters Namespace

Grid Solutions Framework GSF.Historian.Exporters Namespace
Contains classes used for automating data exports in a variety of formats.
Classes
 | Class | Description
 | CsvExporter | Represents an exporter that can export the current time-series data in CSV format to a file.
 | DataMonitorExporter | Represents an exporter that can export real-time time-series data over a TCP server socket.
Public class | Export | A class with information that can be used by an exporter for exporting time-series data.
Public class | ExporterBase | Base class for an exporter of real-time time-series data.
Protected class | ExporterBaseRealTimeData | A class that can be used to save real-time time-series data for Exports of type RealTime.
Public class | ExportRecord | A class that can be used to define the time-series data to be exported for an Export.
Public class | ExportSetting | A class that can be used to add custom settings to an Export.
Public class | FileHelper | A class with helper methods for file related operations.
 | RawDataExporter | Represents an exporter that can export real-time time-series data in CSV or XML format to a file.
 | RebroadcastExporter | Represents an exporter that can export real-time time-series data using TCP or UDP to a listening Socket.
 | RollingHistoryExporter | Represents an exporter that can export current and runtime historic time-series data in CSV or XML format to a file.
 | StatisticsExporter | Represents an exporter that can export the StatisticsExporterStatistics in CSV or XML format to a file.
Protected class | StatisticsExporterStatistics | A class for calculating the MIN, MAX and AVG of time-series data over a period of time.
 | XmlExporter | Represents an exporter that can export the current time-series data in XML format to a file.
Interfaces
 | Interface | Description
Public interface | IExporter | Defines an exporter of real-time time-series data.
Enumerations
 | Enumeration | Description
Public enumeration | ExportProcessResult | Indicates the processing result of an Export.
Public enumeration | ExportType | Indicates the processing frequency of an Export.


CsvExporter Class

Grid Solutions Framework CsvExporter Class
Represents an exporter that can export the current time-series data in CSV format to a file.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersCsvExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CsvExporter : ExporterBase
Public Class CsvExporter
    Inherits ExporterBase
type CsvExporter =
    class
        inherit ExporterBase
    end
GSF.Historian.Exporters.CsvExporter = function();

Type.createClass(
    'GSF.Historian.Exporters.CsvExporter',
    GSF.Historian.Exporters.ExporterBase);
public ref class CsvExporter : public ExporterBase

The CsvExporter type exposes the following members.

Constructors
 | Name | Description
Public method | CsvExporter | Initializes a new instance of the CsvExporter class.
Protected method | CsvExporter(String) | Initializes a new instance of the CsvExporter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
Examples
Definition of a sample Export that can be processed by CsvExporter:
Copy
<?xml version="1.0" encoding="utf-16"?>
<Export xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>CsvExport</Name>
  <Type>Intervaled</Type>
  <Interval>60</Interval>
  <Exporter>CsvExporter</Exporter>
  <Settings>
    <ExportSetting>
      <Name>OutputFile</Name>
      <Value>c:\CsvExportOutput.csv</Value>
    </ExportSetting>
  </Settings>
  <Records>
    <ExportRecord>
      <Instance>P2</Instance>
      <Identifier>1885</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>P2</Instance>
      <Identifier>2711</Identifier>
    </ExportRecord>
  </Records>
</Export>

Description of custom settings required by CsvExporter in an Export:

Setting Name | Setting Description
OutputFile | Name of the CSV file (including path) where export data is to be written.

See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


CsvExporter Constructor

Grid Solutions Framework CsvExporter Constructor
Overload List
 | Name | Description
Public method | CsvExporter | Initializes a new instance of the CsvExporter class.
Protected method | CsvExporter(String) | Initializes a new instance of the CsvExporter class.
Top
See Also

Reference

CsvExporter Class
GSF.Historian.Exporters Namespace


CsvExporter Constructor

Grid Solutions Framework CsvExporter Constructor
Initializes a new instance of the CsvExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CsvExporter()
Public Sub New
new : unit -> CsvExporter
GSF.Historian.Exporters.CsvExporter = function();
public:
CsvExporter()
See Also

Reference

CsvExporter Class
CsvExporter Overload
GSF.Historian.Exporters Namespace


CsvExporter Constructor (String)

Grid Solutions Framework CsvExporter Constructor (String)
Initializes a new instance of the CsvExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CsvExporter(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> CsvExporter
GSF.Historian.Exporters.CsvExporter = function(name);
protected:
CsvExporter(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

CsvExporter Class
CsvExporter Overload
GSF.Historian.Exporters Namespace


CsvExporter Methods

Grid Solutions Framework CsvExporter Methods

The CsvExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CsvExporter Class
GSF.Historian.Exporters Namespace


CsvExporter.ProcessExport Method

Grid Solutions Framework CsvExporterProcessExport Method
Overload List
 | Name | Description
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Top
See Also

Reference

CsvExporter Class
GSF.Historian.Exporters Namespace


CsvExporter.ProcessExport Method (Export)

Grid Solutions Framework CsvExporterProcessExport Method (Export)
Processes the export using the current Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessExport(
    Export export
)
Protected Overrides Sub ProcessExport (
    export As Export
)
abstract ProcessExport :
        export : Export -> unit
override ProcessExport :
        export : Export -> unit
function ProcessExport(export);
protected:
virtual void ProcessExport(
    Export^ export
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
Exceptions
Exception | Condition
ArgumentException | OutputFile setting is missing from the Settings of the export.
See Also

Reference

CsvExporter Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


CsvExporter.ProcessRealTimeExport Method

Grid Solutions Framework CsvExporterProcessRealTimeExport Method
Processes the export using the real-time data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void ProcessRealTimeExport(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub ProcessRealTimeExport (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
function ProcessRealTimeExport(export, listener, data);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void ProcessRealTimeExport(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
listener
Type: GSF.HistorianDataListener
DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
Real-time time-series data received by the listener.
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

CsvExporter Class
GSF.Historian.Exporters Namespace


CsvExporter Properties

Grid Solutions Framework CsvExporter Properties

The CsvExporter type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
See Also

Reference

CsvExporter Class
GSF.Historian.Exporters Namespace


CsvExporter Events

Grid Solutions Framework CsvExporter Events

The CsvExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
See Also

Reference

CsvExporter Class
GSF.Historian.Exporters Namespace


DataMonitorExporter Class

Grid Solutions Framework DataMonitorExporter Class
Represents an exporter that can export real-time time-series data over a TCP server socket.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersRebroadcastExporter
GSF.Historian.ExportersDataMonitorExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataMonitorExporter : RebroadcastExporter
Public Class DataMonitorExporter
    Inherits RebroadcastExporter
type DataMonitorExporter =
    class
        inherit RebroadcastExporter
    end
GSF.Historian.Exporters.DataMonitorExporter = function();

Type.createClass(
    'GSF.Historian.Exporters.DataMonitorExporter',
    GSF.Historian.Exporters.RebroadcastExporter);
public ref class DataMonitorExporter : public RebroadcastExporter

The DataMonitorExporter type exposes the following members.

Constructors
 | Name | Description
Public method | DataMonitorExporter | Initializes a new instance of the DataMonitorExporter class.
Protected method | DataMonitorExporter(String) | Initializes a new instance of the DataMonitorExporter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Inherited from RebroadcastExporter.)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Inherited from RebroadcastExporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransmitData | Performs the transmission of time-series data for the export. (Overrides RebroadcastExporterTransmitData(Export, IListIDataPoint).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
Examples
Definition of a sample Export that can be processed by DataMonitorExporter:
Copy
<?xml version="1.0" encoding="utf-16"?>
<Export xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>DataMonitorExport</Name>
  <Type>RealTime</Type>
  <Interval>0</Interval>
  <Exporter>DataMonitorExporter</Exporter>
  <Settings>
    <ExportSetting>
      <Name>ServerPort</Name>
      <Value>8500</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>LegacyMode</Name>
      <Value>True</Value>
    </ExportSetting>
  </Settings>
  <Records>
    <ExportRecord>
      <Instance>P2</Instance>
      <Identifier>1885</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>P2</Instance>
      <Identifier>2711</Identifier>
    </ExportRecord>
  </Records>
</Export>

Description of custom settings required by DataMonitorExporter in an Export:

Setting Name | Setting Description
ServerPort | TCP server socket port number over which export data is to be transmitted.
LegacyMode (Optional) | True if export data is to be transmitted in PacketType1 and False if export data is to be transmitted in PacketType101.

See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


DataMonitorExporter Constructor

Grid Solutions Framework DataMonitorExporter Constructor
Overload List
 | Name | Description
Public method | DataMonitorExporter | Initializes a new instance of the DataMonitorExporter class.
Protected method | DataMonitorExporter(String) | Initializes a new instance of the DataMonitorExporter class.
Top
See Also

Reference

DataMonitorExporter Class
GSF.Historian.Exporters Namespace


DataMonitorExporter Constructor

Grid Solutions Framework DataMonitorExporter Constructor
Initializes a new instance of the DataMonitorExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataMonitorExporter()
Public Sub New
new : unit -> DataMonitorExporter
GSF.Historian.Exporters.DataMonitorExporter = function();
public:
DataMonitorExporter()
See Also

Reference

DataMonitorExporter Class
DataMonitorExporter Overload
GSF.Historian.Exporters Namespace


DataMonitorExporter Constructor (String)

Grid Solutions Framework DataMonitorExporter Constructor (String)
Initializes a new instance of the DataMonitorExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataMonitorExporter(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> DataMonitorExporter
GSF.Historian.Exporters.DataMonitorExporter = function(name);
protected:
DataMonitorExporter(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

DataMonitorExporter Class
DataMonitorExporter Overload
GSF.Historian.Exporters Namespace


DataMonitorExporter Methods

Grid Solutions Framework DataMonitorExporter Methods

The DataMonitorExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Inherited from RebroadcastExporter.)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Inherited from RebroadcastExporter.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransmitData | Performs the transmission of time-series data for the export. (Overrides RebroadcastExporterTransmitData(Export, IListIDataPoint).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataMonitorExporter Class
GSF.Historian.Exporters Namespace


DataMonitorExporter.TransmitData Method

Grid Solutions Framework DataMonitorExporterTransmitData Method
Performs the transmission of time-series data for the export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void TransmitData(
    Export export,
    IList<IDataPoint> dataToTransmit
)
Protected Overrides Sub TransmitData (
    export As Export,
    dataToTransmit As IList(Of IDataPoint)
)
abstract TransmitData :
        export : Export *
        dataToTransmit : IList<IDataPoint> -> unit
override TransmitData :
        export : Export *
        dataToTransmit : IList<IDataPoint> -> unit
function TransmitData(export, dataToTransmit);
protected:
virtual void TransmitData(
    Export^ export,
    IList<IDataPoint^>^ dataToTransmit
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export whose time-series data os to be transmitted.
dataToTransmit
Type: System.Collections.GenericIList IDataPoint
Collection of time-series data to be transmitted.
See Also

Reference

DataMonitorExporter Class
GSF.Historian.Exporters Namespace


DataMonitorExporter Properties

Grid Solutions Framework DataMonitorExporter Properties

The DataMonitorExporter type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
See Also

Reference

DataMonitorExporter Class
GSF.Historian.Exporters Namespace


DataMonitorExporter Events

Grid Solutions Framework DataMonitorExporter Events

The DataMonitorExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
See Also

Reference

DataMonitorExporter Class
GSF.Historian.Exporters Namespace


Export Class

Grid Solutions Framework Export Class
A class with information that can be used by an exporter for exporting time-series data.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExport

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class Export
<SerializableAttribute>
Public Class Export
[<SerializableAttribute>]
type Export =  class end
GSF.Historian.Exporters.Export = function();

Type.createClass(
    'GSF.Historian.Exporters.Export');
[SerializableAttribute]
public ref class Export

The Export type exposes the following members.

Constructors
 | Name | Description
Public method | Export | Initializes a new instance of the Export class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the current Export object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindRecord | Returns the ExportRecord for the specified instance and identifier from the Records.
Public method | FindRecords | Returns the ExportRecords for the specified instance from the Records.
Public method | FindSetting | Returns the ExportSetting for the specified settingName from the Settings.
Public method | GetHashCode | Returns the hash code for the current Export object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShouldProcess | Determines if it is time to process the Export if its Type is Intervaled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Exporter | Gets or sets the name of the exporter (any Type that implements the IExporter interface) responsible for processing the export.
Public property | Interval | Gets or sets the interval (in seconds) at which the Export is to be processed if its Type is Intervaled.
Public property | LastProcessError | Gets or sets any Exception encountered when the Export was last processed.
Public property | LastProcessResult | Gets or sets the ExportProcessResult of the Export when it was last processed.
Public property | LastProcessTime | Gets or sets the Time it took to process the Export when it was last processed.
Public property | LastProcessTimestamp | Gets or sets the DateTime of when the Export was last processed.
Public property | Name | Gets or sets the name of the Export.
Public property | Records | Gets the ExportRecords whose time-series data is to be exported by the Exporter.
Public property | Settings | Gets the custom ExportSettings used by the Exporter of the Export.
Public property | Type | Gets or sets the ExportType of the Export.
Top
See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExportRecord
GSF.Historian.ExportersExportSetting


Export Constructor

Grid Solutions Framework Export Constructor
Initializes a new instance of the Export class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Export()
Public Sub New
new : unit -> Export
GSF.Historian.Exporters.Export = function();
public:
Export()
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExportRecord
GSF.Historian.ExportersExportSetting


Export Methods

Grid Solutions Framework Export Methods

The Export type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the current Export object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindRecord | Returns the ExportRecord for the specified instance and identifier from the Records.
Public method | FindRecords | Returns the ExportRecords for the specified instance from the Records.
Public method | FindSetting | Returns the ExportSetting for the specified settingName from the Settings.
Public method | GetHashCode | Returns the hash code for the current Export object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ShouldProcess | Determines if it is time to process the Export if its Type is Intervaled.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.Equals Method

Grid Solutions Framework ExportEquals Method
Determines whether the current Export object is equal to obj.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current Export object is to be compared for equality.

Return Value

Type: Boolean
true if the current Export object is equal to obj; otherwise false.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.FindRecord Method

Grid Solutions Framework ExportFindRecord Method
Returns the ExportRecord for the specified instance and identifier from the Records.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportRecord FindRecord(
    string instance,
    int identifier
)
Public Function FindRecord (
    instance As String,
    identifier As Integer
) As ExportRecord
member FindRecord :
        instance : string *
        identifier : int -> ExportRecord

function FindRecord(instance, identifier);
public:
ExportRecord^ FindRecord(
    String^ instance,
    int identifier
)

Parameters

instance
Type: SystemString
Instance name of the ExportRecord to be retrieved.
identifier
Type: SystemInt32
Identifier of the ExportRecord to be retrieved.

Return Value

Type: ExportRecord
An ExportRecord object if a match is found; otherwise null.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.FindRecords Method

Grid Solutions Framework ExportFindRecords Method
Returns the ExportRecords for the specified instance from the Records.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<ExportRecord> FindRecords(
    string instance
)
Public Function FindRecords (
    instance As String
) As IList(Of ExportRecord)
member FindRecords :
        instance : string -> IList<ExportRecord>

function FindRecords(instance);
public:
IList<ExportRecord^>^ FindRecords(
    String^ instance
)

Parameters

instance
Type: SystemString
Instance name of the ExportRecords to be retrieved.

Return Value

Type: IList ExportRecord
An ListT object containing matching ExportRecords.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.FindSetting Method

Grid Solutions Framework ExportFindSetting Method
Returns the ExportSetting for the specified settingName from the Settings.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportSetting FindSetting(
    string settingName
)
Public Function FindSetting (
    settingName As String
) As ExportSetting
member FindSetting :
        settingName : string -> ExportSetting

function FindSetting(settingName);
public:
ExportSetting^ FindSetting(
    String^ settingName
)

Parameters

settingName
Type: SystemString
Name of the ExportSetting to be retrieved.

Return Value

Type: ExportSetting
An ExportSetting object if a match is found; otherwise null.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.GetHashCode Method

Grid Solutions Framework ExportGetHashCode Method
Returns the hash code for the current Export object.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.ShouldProcess Method

Grid Solutions Framework ExportShouldProcess Method
Determines if it is time to process the Export if its Type is Intervaled.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ShouldProcess()
Public Function ShouldProcess As Boolean
member ShouldProcess : unit -> bool

function ShouldProcess();
public:
bool ShouldProcess()

Return Value

Type: Boolean
Boolean indicating whether it is time to process the Export.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export Properties

Grid Solutions Framework Export Properties

The Export type exposes the following members.

Properties
 | Name | Description
Public property | Exporter | Gets or sets the name of the exporter (any Type that implements the IExporter interface) responsible for processing the export.
Public property | Interval | Gets or sets the interval (in seconds) at which the Export is to be processed if its Type is Intervaled.
Public property | LastProcessError | Gets or sets any Exception encountered when the Export was last processed.
Public property | LastProcessResult | Gets or sets the ExportProcessResult of the Export when it was last processed.
Public property | LastProcessTime | Gets or sets the Time it took to process the Export when it was last processed.
Public property | LastProcessTimestamp | Gets or sets the DateTime of when the Export was last processed.
Public property | Name | Gets or sets the name of the Export.
Public property | Records | Gets the ExportRecords whose time-series data is to be exported by the Exporter.
Public property | Settings | Gets the custom ExportSettings used by the Exporter of the Export.
Public property | Type | Gets or sets the ExportType of the Export.
Top
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.Exporter Property

Grid Solutions Framework ExportExporter Property
Gets or sets the name of the exporter (any Type that implements the IExporter interface) responsible for processing the export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Exporter { get; set; }
Public Property Exporter As String
    Get
    Set
member Exporter : string with get, set

function get_Exporter();
function set_Exporter(value);
public:
property String^ Exporter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.Interval Property

Grid Solutions Framework ExportInterval Property
Gets or sets the interval (in seconds) at which the Export is to be processed if its Type is Intervaled.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Interval { get; set; }
Public Property Interval As Double
    Get
    Set
member Interval : float with get, set

function get_Interval();
function set_Interval(value);
public:
property double Interval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.LastProcessError Property

Grid Solutions Framework ExportLastProcessError Property
Gets or sets any Exception encountered when the Export was last processed.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public Exception LastProcessError { get; set; }
<XmlIgnoreAttribute>
Public Property LastProcessError As Exception
    Get
    Set
[<XmlIgnoreAttribute>]
member LastProcessError : Exception with get, set

function get_LastProcessError();
function set_LastProcessError(value);
public:
[XmlIgnoreAttribute]
property Exception^ LastProcessError {
    Exception^ get ();
    void set (Exception^ value);
}

Property Value

Type: Exception
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.LastProcessResult Property

Grid Solutions Framework ExportLastProcessResult Property
Gets or sets the ExportProcessResult of the Export when it was last processed.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public ExportProcessResult LastProcessResult { get; set; }
<XmlIgnoreAttribute>
Public Property LastProcessResult As ExportProcessResult
    Get
    Set
[<XmlIgnoreAttribute>]
member LastProcessResult : ExportProcessResult with get, set

function get_LastProcessResult();
function set_LastProcessResult(value);
public:
[XmlIgnoreAttribute]
property ExportProcessResult LastProcessResult {
    ExportProcessResult get ();
    void set (ExportProcessResult value);
}

Property Value

Type: ExportProcessResult
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.LastProcessTime Property

Grid Solutions Framework ExportLastProcessTime Property
Gets or sets the Time it took to process the Export when it was last processed.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public Time LastProcessTime { get; set; }
<XmlIgnoreAttribute>
Public Property LastProcessTime As Time
    Get
    Set
[<XmlIgnoreAttribute>]
member LastProcessTime : Time with get, set

function get_LastProcessTime();
function set_LastProcessTime(value);
public:
[XmlIgnoreAttribute]
property Time LastProcessTime {
    Time get ();
    void set (Time value);
}

Property Value

Type: Time
Remarks
LastProcessTime will be zero if the Type is RealTime.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.LastProcessTimestamp Property

Grid Solutions Framework ExportLastProcessTimestamp Property
Gets or sets the DateTime of when the Export was last processed.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public DateTime LastProcessTimestamp { get; set; }
<XmlIgnoreAttribute>
Public Property LastProcessTimestamp As DateTime
    Get
    Set
[<XmlIgnoreAttribute>]
member LastProcessTimestamp : DateTime with get, set

function get_LastProcessTimestamp();
function set_LastProcessTimestamp(value);
public:
[XmlIgnoreAttribute]
property DateTime LastProcessTimestamp {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
Remarks
LastProcessTimestamp will be MinValue if the Type is RealTime.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.Name Property

Grid Solutions Framework ExportName Property
Gets or sets the name of the Export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.Records Property

Grid Solutions Framework ExportRecords Property
Gets the ExportRecords whose time-series data is to be exported by the Exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual List<ExportRecord> Records { get; }
Public Overridable ReadOnly Property Records As List(Of ExportRecord)
    Get
abstract Records : List<ExportRecord> with get
override Records : List<ExportRecord> with get
function get_Records();

public:
virtual property List<ExportRecord^>^ Records {
    List<ExportRecord^>^ get ();
}

Property Value

Type: List ExportRecord
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.Settings Property

Grid Solutions Framework ExportSettings Property
Gets the custom ExportSettings used by the Exporter of the Export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual List<ExportSetting> Settings { get; }
Public Overridable ReadOnly Property Settings As List(Of ExportSetting)
    Get
abstract Settings : List<ExportSetting> with get
override Settings : List<ExportSetting> with get
function get_Settings();

public:
virtual property List<ExportSetting^>^ Settings {
    List<ExportSetting^>^ get ();
}

Property Value

Type: List ExportSetting
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


Export.Type Property

Grid Solutions Framework ExportType Property
Gets or sets the ExportType of the Export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportType Type { get; set; }
Public Property Type As ExportType
    Get
    Set
member Type : ExportType with get, set

function get_Type();
function set_Type(value);
public:
property ExportType Type {
    ExportType get ();
    void set (ExportType value);
}

Property Value

Type: ExportType
See Also

Reference

Export Class
GSF.Historian.Exporters Namespace


ExporterBase Class

Grid Solutions Framework ExporterBase Class
Base class for an exporter of real-time time-series data.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersCsvExporter
GSF.Historian.ExportersRawDataExporter
GSF.Historian.ExportersRebroadcastExporter
GSF.Historian.ExportersRollingHistoryExporter
GSF.Historian.ExportersXmlExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ExporterBase : IExporter,
    IDisposable
Public MustInherit Class ExporterBase
    Implements IExporter, IDisposable
[<AbstractClassAttribute>]
type ExporterBase =
    class
        interface IExporter
        interface IDisposable
    end
GSF.Historian.Exporters.ExporterBase = function();

Type.createClass(
    'GSF.Historian.Exporters.ExporterBase',
    null,
    GSF.Historian.Exporters.IExporter,
    IDisposable);
public ref class ExporterBase abstract : IExporter,
    IDisposable

The ExporterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ExporterBase | Initializes a new instance of the exporter.
Top
Methods
 | Name | Description
 | DatasetTemplate | Returns a template DataSet that can be used for storing time-series data in a tabular format.
Public method | Dispose | Releases all the resources used by the exporter.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources.
Public method | Equals | Determines whether the current exporter object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports.
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners.
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener.
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet.
Public method | GetHashCode | Returns the hash code for the current exporter object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event.
Protected method | OnExportProcessException | Raises the ExportProcessException event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event.
Public method | ProcessExport(String) | Processes Export with the specified exportName.
Protected method | ProcessExport(Export) | When overridden in a derived class, processes the export using the current Data.
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners.
Protected method | ProcessRealTimeExport | When overridden in a derived class, processes the export using the real-time data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FileLockWaitTime | Number of seconds to wait to obtain a write lock on a file.
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports.
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports.
Public property | Exports | Gets the Exports associated with the exporter.
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated.
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter.
Public property | Name | Gets or sets the name of the exporter.
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime.
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export.
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception.
Public event | StatusUpdate | Occurs when the exporter want to provide a status update.
Top
See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport
GSF.HistorianDataListener


ExporterBase Constructor

Grid Solutions Framework ExporterBase Constructor
Initializes a new instance of the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ExporterBase(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> ExporterBase
GSF.Historian.Exporters.ExporterBase = function(name);
protected:
ExporterBase(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase Fields

Grid Solutions Framework ExporterBase Fields

The ExporterBase type exposes the following members.

Fields
Name | Description
FileLockWaitTime | Number of seconds to wait to obtain a write lock on a file.
Top
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.FileLockWaitTime Field

Grid Solutions Framework ExporterBaseFileLockWaitTime Field
Number of seconds to wait to obtain a write lock on a file.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FileLockWaitTime
Public Const FileLockWaitTime As Integer
static val mutable FileLockWaitTime: int
var GSF.Historian.Exporters.ExporterBase.FileLockWaitTime
public:
literal int FileLockWaitTime

Field Value

Type: Int32
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase Methods

Grid Solutions Framework ExporterBase Methods

The ExporterBase type exposes the following members.

Methods
 | Name | Description
 | DatasetTemplate | Returns a template DataSet that can be used for storing time-series data in a tabular format.
Public method | Dispose | Releases all the resources used by the exporter.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources.
Public method | Equals | Determines whether the current exporter object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports.
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners.
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener.
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet.
Public method | GetHashCode | Returns the hash code for the current exporter object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event.
Protected method | OnExportProcessException | Raises the ExportProcessException event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event.
Public method | ProcessExport(String) | Processes Export with the specified exportName.
Protected method | ProcessExport(Export) | When overridden in a derived class, processes the export using the current Data.
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners.
Protected method | ProcessRealTimeExport | When overridden in a derived class, processes the export using the real-time data.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.DatasetTemplate Method

Grid Solutions Framework ExporterBaseDatasetTemplate Method
Returns a template DataSet that can be used for storing time-series data in a tabular format.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet DatasetTemplate(
    string dataTableName
)
Public Shared Function DatasetTemplate (
    dataTableName As String
) As DataSet
static member DatasetTemplate :
        dataTableName : string -> DataSet

GSF.Historian.Exporters.ExporterBase.DatasetTemplate = function(dataTableName);
public:
static DataSet^ DatasetTemplate(
    String^ dataTableName
)

Parameters

dataTableName
Type: SystemString
Name of the DataTable that will be used for storing the time-series data.

Return Value

Type: DataSet
A DataSet object.
Remarks

The returned DataSet consists of two DataTables with the following structure:

Table 1 is to be used for storing time-series data.

Column Name | Column Description
Instance | Historian instance providing the time-series data.
ID | HistorianID of the time-series data.
Time | Time of the time-series data.
Value | Value of the time-series data.
Quality | Quality of the time-series data.
Table 2 is to be used for providing information about Table 1.
Column Name | Column Description
RunTime | DateTime (in UTC) when the data in Table 1 was populated.
RecordCount | Number of time-series data points in Table 1.
RefreshSchedule | Interval (in seconds) at which the data in Table 1 is to be refreshed.

See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.Dispose Method

Grid Solutions Framework ExporterBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources.
Top
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.Dispose Method

Grid Solutions Framework ExporterBaseDispose Method
Releases all the resources used by the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ExporterBase Class
Dispose Overload
GSF.Historian.Exporters Namespace


ExporterBase.Dispose Method (Boolean)

Grid Solutions Framework ExporterBaseDispose Method (Boolean)
Releases the unmanaged resources used by the exporter and optionally releases the managed resources.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ExporterBase Class
Dispose Overload
GSF.Historian.Exporters Namespace


ExporterBase.Equals Method

Grid Solutions Framework ExporterBaseEquals Method
Determines whether the current exporter object is equal to obj.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current exporter object is to be compared for equality.

Return Value

Type: Boolean
true if the current exporter object is equal to obj; otherwise false.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.Finalize Method

Grid Solutions Framework ExporterBaseFinalize Method
Releases the unmanaged resources before the exporter is reclaimed by GC.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.FindExport Method

Grid Solutions Framework ExporterBaseFindExport Method
Returns the Export for the specified exportName from the Exports.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Export FindExport(
    string exportName
)
Public Function FindExport (
    exportName As String
) As Export
member FindExport :
        exportName : string -> Export

function FindExport(exportName);
public:
Export^ FindExport(
    String^ exportName
)

Parameters

exportName
Type: SystemString
Name of the Export to be retrieved.

Return Value

Type: Export
An Export object if a match is found; otherwise null.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.FindListener Method

Grid Solutions Framework ExporterBaseFindListener Method
Returns the DataListener for the specified listenerName from the Listeners.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataListener FindListener(
    string listenerName
)
Public Function FindListener (
    listenerName As String
) As DataListener
member FindListener :
        listenerName : string -> DataListener

function FindListener(listenerName);
public:
DataListener^ FindListener(
    String^ listenerName
)

Parameters

listenerName
Type: SystemString
Name of the DataListener to be retrieved.

Return Value

Type: DataListener
A DataListener object if a match is found; otherwise null.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.GetExportData Method

Grid Solutions Framework ExporterBaseGetExportData Method
Returns the current time-series data for the specified export organized by listener.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Dictionary<string, IList<IDataPoint>> GetExportData(
    Export export
)
Protected Function GetExportData (
    export As Export
) As Dictionary(Of String, IList(Of IDataPoint))
member GetExportData :
        export : Export -> Dictionary<string, IList<IDataPoint>>

function GetExportData(export);
protected:
Dictionary<String^, IList<IDataPoint^>^>^ GetExportData(
    Export^ export
)

Parameters

export
Type: GSF.Historian.ExportersExport
Export whose current time-series data is to be returned.

Return Value

Type: Dictionary String, IList IDataPoint
A DictionaryTKey, TValue object where the key is the Name and value is the time-series data.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.GetExportDataAsDataset Method

Grid Solutions Framework ExporterBaseGetExportDataAsDataset Method
Returns the current time-series data for the specified export in a DataSet.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataSet GetExportDataAsDataset(
    Export export,
    string dataTableName
)
Protected Function GetExportDataAsDataset (
    export As Export,
    dataTableName As String
) As DataSet
member GetExportDataAsDataset :
        export : Export *
        dataTableName : string -> DataSet

function GetExportDataAsDataset(export, dataTableName);
protected:
DataSet^ GetExportDataAsDataset(
    Export^ export,
    String^ dataTableName
)

Parameters

export
Type: GSF.Historian.ExportersExport
Export whose current time-series data is to be returned.
dataTableName
Type: SystemString
Name of the DataTable containing the time-series data.

Return Value

Type: DataSet
A DataSet object.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.GetHashCode Method

Grid Solutions Framework ExporterBaseGetHashCode Method
Returns the hash code for the current exporter object.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.OnExportProcessed Method

Grid Solutions Framework ExporterBaseOnExportProcessed Method
Raises the ExportProcessed event.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnExportProcessed(
    Export export
)
Protected Overridable Sub OnExportProcessed (
    export As Export
)
abstract OnExportProcessed :
        export : Export -> unit
override OnExportProcessed :
        export : Export -> unit
function OnExportProcessed(export);
protected:
virtual void OnExportProcessed(
    Export^ export
)

Parameters

export
Type: GSF.Historian.ExportersExport
Export to send to ExportProcessed event.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.OnExportProcessException Method

Grid Solutions Framework ExporterBaseOnExportProcessException Method
Raises the ExportProcessException event.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnExportProcessException(
    Export export,
    Exception exception
)
Protected Overridable Sub OnExportProcessException (
    export As Export,
    exception As Exception
)
abstract OnExportProcessException :
        export : Export *
        exception : Exception -> unit
override OnExportProcessException :
        export : Export *
        exception : Exception -> unit
function OnExportProcessException(export, exception);
protected:
virtual void OnExportProcessException(
    Export^ export,
    Exception^ exception
)

Parameters

export
Type: GSF.Historian.ExportersExport
Export to send to ExportProcessException event.
exception
Type: SystemException
Exception to send to ExportProcessException event.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.OnStatusUpdate Method

Grid Solutions Framework ExporterBaseOnStatusUpdate Method
Raises the StatusUpdate event.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusUpdate(
    string status
)
Protected Overridable Sub OnStatusUpdate (
    status As String
)
abstract OnStatusUpdate :
        status : string -> unit
override OnStatusUpdate :
        status : string -> unit
function OnStatusUpdate(status);
protected:
virtual void OnStatusUpdate(
    String^ status
)

Parameters

status
Type: SystemString
Status update message to send to StatusUpdate event.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ProcessExport Method

Grid Solutions Framework ExporterBaseProcessExport Method
Overload List
 | Name | Description
Public method | ProcessExport(String) | Processes Export with the specified exportName.
Protected method | ProcessExport(Export) | When overridden in a derived class, processes the export using the current Data.
Top
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ProcessExport Method (String)

Grid Solutions Framework ExporterBaseProcessExport Method (String)
Processes Export with the specified exportName.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ProcessExport(
    string exportName
)
Public Sub ProcessExport (
    exportName As String
)
abstract ProcessExport :
        exportName : string -> unit
override ProcessExport :
        exportName : string -> unit
function ProcessExport(exportName);
public:
virtual void ProcessExport(
    String^ exportName
) sealed

Parameters

exportName
Type: SystemString
Name of the Export to be processed.

Implements

IExporterProcessExport(String)
Exceptions
Exception | Condition
InvalidOperationException | Export does not exist for the specified exportName.
See Also

Reference

ExporterBase Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


ExporterBase.ProcessExport Method (Export)

Grid Solutions Framework ExporterBaseProcessExport Method (Export)
When overridden in a derived class, processes the export using the current Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void ProcessExport(
    Export export
)
Protected MustOverride Sub ProcessExport (
    export As Export
)
abstract ProcessExport :
        export : Export -> unit

function ProcessExport(export);
protected:
virtual void ProcessExport(
    Export^ export
) abstract

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
See Also

Reference

ExporterBase Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


ExporterBase.ProcessRealTimeData Method

Grid Solutions Framework ExporterBaseProcessRealTimeData Method
Handles the DataExtracted event for all the Listeners.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ProcessRealTimeData(
    Object sender,
    EventArgs<IList<IDataPoint>> e
)
Protected Overridable Sub ProcessRealTimeData (
    sender As Object,
    e As EventArgs(Of IList(Of IDataPoint))
)
abstract ProcessRealTimeData :
        sender : Object *
        e : EventArgs<IList<IDataPoint>> -> unit
override ProcessRealTimeData :
        sender : Object *
        e : EventArgs<IList<IDataPoint>> -> unit
function ProcessRealTimeData(sender, e);
protected:
virtual void ProcessRealTimeData(
    Object^ sender,
    EventArgs<IList<IDataPoint^>^>^ e
)

Parameters

sender
Type: SystemObject
DataListener object that raised the event.
e
Type: GSFEventArgs IList IDataPoint
EventArgsT object where Argument is the collection of real-time time-sereis data received.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ProcessRealTimeExport Method

Grid Solutions Framework ExporterBaseProcessRealTimeExport Method
When overridden in a derived class, processes the export using the real-time data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void ProcessRealTimeExport(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
Protected MustOverride Sub ProcessRealTimeExport (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
abstract ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit

function ProcessRealTimeExport(export, listener, data);
protected:
virtual void ProcessRealTimeExport(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
) abstract

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
listener
Type: GSF.HistorianDataListener
DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
Real-time time-series data received by the listener.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase Properties

Grid Solutions Framework ExporterBase Properties

The ExporterBase type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports.
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports.
Public property | Exports | Gets the Exports associated with the exporter.
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated.
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter.
Public property | Name | Gets or sets the name of the exporter.
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime.
Top
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ExportAddedHandler Property

Grid Solutions Framework ExporterBaseExportAddedHandler Property
Gets or sets the Delegate to be invoked when a new Export is added to the Exports.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Action<Export> ExportAddedHandler { get; set; }
Protected Property ExportAddedHandler As Action(Of Export)
    Get
    Set
member ExportAddedHandler : Action<Export> with get, set

function get_ExportAddedHandler();
function set_ExportAddedHandler(value);
protected:
property Action<Export^>^ ExportAddedHandler {
    Action<Export^>^ get ();
    void set (Action<Export^>^ value);
}

Property Value

Type: Action Export
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ExportRemovedHandler Property

Grid Solutions Framework ExporterBaseExportRemovedHandler Property
Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Action<Export> ExportRemovedHandler { get; set; }
Protected Property ExportRemovedHandler As Action(Of Export)
    Get
    Set
member ExportRemovedHandler : Action<Export> with get, set

function get_ExportRemovedHandler();
function set_ExportRemovedHandler(value);
protected:
property Action<Export^>^ ExportRemovedHandler {
    Action<Export^>^ get ();
    void set (Action<Export^>^ value);
}

Property Value

Type: Action Export
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.Exports Property

Grid Solutions Framework ExporterBaseExports Property
Gets the Exports associated with the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<Export> Exports { get; }
Public ReadOnly Property Exports As IList(Of Export)
    Get
abstract Exports : IList<Export> with get
override Exports : IList<Export> with get
function get_Exports();

public:
virtual property IList<Export^>^ Exports {
    IList<Export^>^ get () sealed;
}

Property Value

Type: IList Export

Implements

IExporterExports
Remarks
WARNING: Exports is therad unsafe. Synchronized access is required.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ExportUpdatedHandler Property

Grid Solutions Framework ExporterBaseExportUpdatedHandler Property
Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Action<Export> ExportUpdatedHandler { get; set; }
Protected Property ExportUpdatedHandler As Action(Of Export)
    Get
    Set
member ExportUpdatedHandler : Action<Export> with get, set

function get_ExportUpdatedHandler();
function set_ExportUpdatedHandler(value);
protected:
property Action<Export^>^ ExportUpdatedHandler {
    Action<Export^>^ get ();
    void set (Action<Export^>^ value);
}

Property Value

Type: Action Export
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.Listeners Property

Grid Solutions Framework ExporterBaseListeners Property
Gets the DataListeners providing real-time time-series data to the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<DataListener> Listeners { get; }
Public ReadOnly Property Listeners As IList(Of DataListener)
    Get
abstract Listeners : IList<DataListener> with get
override Listeners : IList<DataListener> with get
function get_Listeners();

public:
virtual property IList<DataListener^>^ Listeners {
    IList<DataListener^>^ get () sealed;
}

Property Value

Type: IList DataListener

Implements

IExporterListeners
Remarks
WARNING: Listeners is therad unsafe. Synchronized access is required.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.Name Property

Grid Solutions Framework ExporterBaseName Property
Gets or sets the name of the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IExporterName
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.RealTimeExportQueue Property

Grid Solutions Framework ExporterBaseRealTimeExportQueue Property
Gets the internal ProcessQueueT used for processing Exports defined as RealTime.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ProcessQueue<ExporterBaseRealTimeData> RealTimeExportQueue { get; }
Protected ReadOnly Property RealTimeExportQueue As ProcessQueue(Of ExporterBaseRealTimeData)
    Get
member RealTimeExportQueue : ProcessQueue<ExporterBaseRealTimeData> with get

function get_RealTimeExportQueue();

protected:
property ProcessQueue<ExporterBaseRealTimeData^>^ RealTimeExportQueue {
    ProcessQueue<ExporterBaseRealTimeData^>^ get ();
}

Property Value

Type: ProcessQueue ExporterBaseRealTimeData
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase Events

Grid Solutions Framework ExporterBase Events

The ExporterBase type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export.
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception.
Public event | StatusUpdate | Occurs when the exporter want to provide a status update.
Top
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ExportProcessed Event

Grid Solutions Framework ExporterBaseExportProcessed Event
Occurs when the exporter finishes processing an Export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Export>> ExportProcessed
Public Event ExportProcessed As EventHandler(Of EventArgs(Of Export))
abstract ExportProcessed : IEvent<EventHandler<EventArgs<Export>>,
    EventArgs<Export>>
override ExportProcessed : IEvent<EventHandler<EventArgs<Export>>,
    EventArgs<Export>>
function add_ExportProcessed(value);
function remove_ExportProcessed(value);
public:
virtual  event EventHandler<EventArgs<Export^>^>^ ExportProcessed {
    void add (EventHandler<EventArgs<Export^>^>^ value);
    void remove (EventHandler<EventArgs<Export^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Export

Implements

IExporterExportProcessed
Remarks
Argument is the Export that the exporter finished processing.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.ExportProcessException Event

Grid Solutions Framework ExporterBaseExportProcessException Event
Occurs when the exporter fails to process an Export due to an Exception.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Export>> ExportProcessException
Public Event ExportProcessException As EventHandler(Of EventArgs(Of Export))
abstract ExportProcessException : IEvent<EventHandler<EventArgs<Export>>,
    EventArgs<Export>>
override ExportProcessException : IEvent<EventHandler<EventArgs<Export>>,
    EventArgs<Export>>
function add_ExportProcessException(value);
function remove_ExportProcessException(value);
public:
virtual  event EventHandler<EventArgs<Export^>^>^ ExportProcessException {
    void add (EventHandler<EventArgs<Export^>^>^ value);
    void remove (EventHandler<EventArgs<Export^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Export

Implements

IExporterExportProcessException
Remarks
Argument is the Export that the exporter failed to process.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.StatusUpdate Event

Grid Solutions Framework ExporterBaseStatusUpdate Event
Occurs when the exporter want to provide a status update.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusUpdate
Public Event StatusUpdate As EventHandler(Of EventArgs(Of String))
abstract StatusUpdate : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusUpdate : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusUpdate(value);
function remove_StatusUpdate(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusUpdate {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IExporterStatusUpdate
Remarks
Argument is the status update message.
See Also

Reference

ExporterBase Class
GSF.Historian.Exporters Namespace


ExporterBase.RealTimeData Class

Grid Solutions Framework ExporterBaseRealTimeData Class
A class that can be used to save real-time time-series data for Exports of type RealTime.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBaseRealTimeData

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected class RealTimeData
Protected Class RealTimeData
type RealTimeData =  class end
GSF.Historian.Exporters.RealTimeData = function();

Type.createClass(
    'GSF.Historian.Exporters.RealTimeData');
protected ref class RealTimeData

The ExporterBaseRealTimeData type exposes the following members.

Constructors
 | Name | Description
Public method | ExporterBaseRealTimeData | Initializes a new instance of the ExporterBaseRealTimeData class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Data | Gets or sets the real-time time-series data received by the Listener.
Public field | Export | Gets or sets the Export to which the Data belongs.
Public field | Listener | Gets or sets the DataListener that provided the Data.
Top
See Also

Reference

GSF.Historian.Exporters Namespace
ExporterBaseRealTimeDataExport


ExporterBase.RealTimeData Constructor

Grid Solutions Framework ExporterBaseRealTimeData Constructor
Initializes a new instance of the ExporterBaseRealTimeData class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RealTimeData(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
Public Sub New (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
new :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> RealTimeData
GSF.Historian.Exporters.RealTimeData = function(export, listener, data);
public:
RealTimeData(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
)

Parameters

export
Type: GSF.Historian.ExportersExport
The Export to which the data belongs.
listener
Type: GSF.HistorianDataListener
The DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
The real-time time-series data received by the listener.
See Also

Reference

ExporterBaseRealTimeData Class
GSF.Historian.Exporters Namespace


RealTimeData Fields

Grid Solutions Framework RealTimeData Fields

The ExporterBaseRealTimeData type exposes the following members.

Fields
 | Name | Description
Public field | Data | Gets or sets the real-time time-series data received by the Listener.
Public field | Export | Gets or sets the Export to which the Data belongs.
Public field | Listener | Gets or sets the DataListener that provided the Data.
Top
See Also

Reference

ExporterBaseRealTimeData Class
GSF.Historian.Exporters Namespace


ExporterBase.RealTimeData.Data Field

Grid Solutions Framework ExporterBaseRealTimeDataData Field
Gets or sets the real-time time-series data received by the Listener.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<IDataPoint> Data
Public Data As IList(Of IDataPoint)
val mutable Data: IList<IDataPoint>
var Data
public:
IList<IDataPoint^>^ Data

Field Value

Type: IList IDataPoint
See Also

Reference

ExporterBaseRealTimeData Class
GSF.Historian.Exporters Namespace


ExporterBase.RealTimeData.Export Field

Grid Solutions Framework ExporterBaseRealTimeDataExport Field
Gets or sets the Export to which the Data belongs.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Export Export
Public Export As Export
val mutable Export: Export
var Export
public:
Export^ Export

Field Value

Type: Export
See Also

Reference

ExporterBaseRealTimeData Class
GSF.Historian.Exporters Namespace


ExporterBase.RealTimeData.Listener Field

Grid Solutions Framework ExporterBaseRealTimeDataListener Field
Gets or sets the DataListener that provided the Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataListener Listener
Public Listener As DataListener
val mutable Listener: DataListener
var Listener
public:
DataListener^ Listener

Field Value

Type: DataListener
See Also

Reference

ExporterBaseRealTimeData Class
GSF.Historian.Exporters Namespace


RealTimeData Methods

Grid Solutions Framework RealTimeData Methods

The ExporterBaseRealTimeData type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ExporterBaseRealTimeData Class
GSF.Historian.Exporters Namespace


ExportProcessResult Enumeration

Grid Solutions Framework ExportProcessResult Enumeration
Indicates the processing result of an Export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ExportProcessResult
Public Enumeration ExportProcessResult
type ExportProcessResult
GSF.Historian.Exporters.ExportProcessResult = function();
GSF.Historian.Exporters.ExportProcessResult.createEnum('GSF.Historian.Exporters.ExportProcessResult', false);
public enum class ExportProcessResult
Members
Member name | Value | Description
Unknown | 0 | Export has not been processed yet.
Success | 1 | Export was processed successfully.
Failure | 2 | Export failed to process successfully.
See Also

Reference

GSF.Historian.Exporters Namespace


ExportRecord Class

Grid Solutions Framework ExportRecord Class
A class that can be used to define the time-series data to be exported for an Export.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExportRecord

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ExportRecord : IComparable
<SerializableAttribute>
Public Class ExportRecord
    Implements IComparable
[<SerializableAttribute>]
type ExportRecord =
    class
        interface IComparable
    end
GSF.Historian.Exporters.ExportRecord = function();

Type.createClass(
    'GSF.Historian.Exporters.ExportRecord',
    null,
    IComparable);
[SerializableAttribute]
public ref class ExportRecord : IComparable

The ExportRecord type exposes the following members.

Constructors
 | Name | Description
Public method | ExportRecord | Initializes a new instance of the ExportRecord class.
Public method | ExportRecord(String, Int32) | Initializes a new instance of the ExportRecord class.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current ExportRecord object to obj.
Public method | Equals | Determines whether the current ExportRecord object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the current ExportRecord object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Identifier | Gets or sets the historian identifier of the Instance whose time-series data is to be exported.
Public property | Instance | Gets or sets the name of the historian instance providing the time-series data.
Top
See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


ExportRecord Constructor

Grid Solutions Framework ExportRecord Constructor
Overload List
 | Name | Description
Public method | ExportRecord | Initializes a new instance of the ExportRecord class.
Public method | ExportRecord(String, Int32) | Initializes a new instance of the ExportRecord class.
Top
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportRecord Constructor

Grid Solutions Framework ExportRecord Constructor
Initializes a new instance of the ExportRecord class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportRecord()
Public Sub New
new : unit -> ExportRecord
GSF.Historian.Exporters.ExportRecord = function();
public:
ExportRecord()
See Also

Reference

ExportRecord Class
ExportRecord Overload
GSF.Historian.Exporters Namespace


ExportRecord Constructor (String, Int32)

Grid Solutions Framework ExportRecord Constructor (String, Int32)
Initializes a new instance of the ExportRecord class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportRecord(
    string instance,
    int identifier
)
Public Sub New (
    instance As String,
    identifier As Integer
)
new :
        instance : string *
        identifier : int -> ExportRecord
GSF.Historian.Exporters.ExportRecord = function(instance, identifier);
public:
ExportRecord(
    String^ instance,
    int identifier
)

Parameters

instance
Type: SystemString
Name of the historian instance providing the time-series data.
identifier
Type: SystemInt32
Historian identifier of the instance whose time-series data is to be exported.
See Also

Reference

ExportRecord Class
ExportRecord Overload
GSF.Historian.Exporters Namespace


ExportRecord Methods

Grid Solutions Framework ExportRecord Methods

The ExportRecord type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current ExportRecord object to obj.
Public method | Equals | Determines whether the current ExportRecord object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for the current ExportRecord object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportRecord.CompareTo Method

Grid Solutions Framework ExportRecordCompareTo Method
Compares the current ExportRecord object to obj.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
Object against which the current ExportRecord object is to be compared.

Return Value

Type: Int32
Negative value if the current ExportRecord object is less than obj, Zero if the current ExportRecord object is equal to obj, Positive value if the current ExportRecord object is greater than obj.

Implements

IComparableCompareTo(Object)
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportRecord.Equals Method

Grid Solutions Framework ExportRecordEquals Method
Determines whether the current ExportRecord object is equal to obj.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current ExportRecord object is to be compared for equality.

Return Value

Type: Boolean
true if the current ExportRecord object is equal to obj; otherwise false.
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportRecord.GetHashCode Method

Grid Solutions Framework ExportRecordGetHashCode Method
Returns the hash code for the current ExportRecord object.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportRecord Properties

Grid Solutions Framework ExportRecord Properties

The ExportRecord type exposes the following members.

Properties
 | Name | Description
Public property | Identifier | Gets or sets the historian identifier of the Instance whose time-series data is to be exported.
Public property | Instance | Gets or sets the name of the historian instance providing the time-series data.
Top
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportRecord.Identifier Property

Grid Solutions Framework ExportRecordIdentifier Property
Gets or sets the historian identifier of the Instance whose time-series data is to be exported.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Identifier { get; set; }
Public Property Identifier As Integer
    Get
    Set
member Identifier : int with get, set

function get_Identifier();
function set_Identifier(value);
public:
property int Identifier {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or -1.
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportRecord.Instance Property

Grid Solutions Framework ExportRecordInstance Property
Gets or sets the name of the historian instance providing the time-series data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Instance { get; set; }
Public Property Instance As String
    Get
    Set
member Instance : string with get, set

function get_Instance();
function set_Instance(value);
public:
property String^ Instance {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ExportRecord Class
GSF.Historian.Exporters Namespace


ExportSetting Class

Grid Solutions Framework ExportSetting Class
A class that can be used to add custom settings to an Export.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExportSetting

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ExportSetting
<SerializableAttribute>
Public Class ExportSetting
[<SerializableAttribute>]
type ExportSetting =  class end
GSF.Historian.Exporters.ExportSetting = function();

Type.createClass(
    'GSF.Historian.Exporters.ExportSetting');
[SerializableAttribute]
public ref class ExportSetting

The ExportSetting type exposes the following members.

Constructors
 | Name | Description
Public method | ExportSetting | Initializes a new instance of the ExportSetting class.
Public method | ExportSetting(String, String) | Initializes a new instance of the ExportSetting class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Name | Gets or sets the name of the ExportSetting.
Public property | Value | Gets or sets the value of the ExportSetting.
Top
See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


ExportSetting Constructor

Grid Solutions Framework ExportSetting Constructor
Overload List
 | Name | Description
Public method | ExportSetting | Initializes a new instance of the ExportSetting class.
Public method | ExportSetting(String, String) | Initializes a new instance of the ExportSetting class.
Top
See Also

Reference

ExportSetting Class
GSF.Historian.Exporters Namespace


ExportSetting Constructor

Grid Solutions Framework ExportSetting Constructor
Initializes a new instance of the ExportSetting class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportSetting()
Public Sub New
new : unit -> ExportSetting
GSF.Historian.Exporters.ExportSetting = function();
public:
ExportSetting()
See Also

Reference

ExportSetting Class
ExportSetting Overload
GSF.Historian.Exporters Namespace


ExportSetting Constructor (String, String)

Grid Solutions Framework ExportSetting Constructor (String, String)
Initializes a new instance of the ExportSetting class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportSetting(
    string name,
    string value
)
Public Sub New (
    name As String,
    value As String
)
new :
        name : string *
        value : string -> ExportSetting
GSF.Historian.Exporters.ExportSetting = function(name, value);
public:
ExportSetting(
    String^ name,
    String^ value
)

Parameters

name
Type: SystemString
Name of the ExportSetting.
value
Type: SystemString
Value of the ExportSetting.
See Also

Reference

ExportSetting Class
ExportSetting Overload
GSF.Historian.Exporters Namespace


ExportSetting Methods

Grid Solutions Framework ExportSetting Methods

The ExportSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ExportSetting Class
GSF.Historian.Exporters Namespace


ExportSetting Properties

Grid Solutions Framework ExportSetting Properties

The ExportSetting type exposes the following members.

Properties
 | Name | Description
Public property | Name | Gets or sets the name of the ExportSetting.
Public property | Value | Gets or sets the value of the ExportSetting.
Top
See Also

Reference

ExportSetting Class
GSF.Historian.Exporters Namespace


ExportSetting.Name Property

Grid Solutions Framework ExportSettingName Property
Gets or sets the name of the ExportSetting.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ExportSetting Class
GSF.Historian.Exporters Namespace


ExportSetting.Value Property

Grid Solutions Framework ExportSettingValue Property
Gets or sets the value of the ExportSetting.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Value { get; set; }
Public Property Value As String
    Get
    Set
member Value : string with get, set

function get_Value();
function set_Value(value);
public:
property String^ Value {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ExportSetting Class
GSF.Historian.Exporters Namespace


ExportType Enumeration

Grid Solutions Framework ExportType Enumeration
Indicates the processing frequency of an Export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ExportType
Public Enumeration ExportType
type ExportType
GSF.Historian.Exporters.ExportType = function();
GSF.Historian.Exporters.ExportType.createEnum('GSF.Historian.Exporters.ExportType', false);
public enum class ExportType
Members
Member name | Value | Description
Manual | 0 | Export is to be processed only when a request is made to process it.
RealTime | 1 | Export is to be processed as time-series data is received in real-time.
Intervaled | 2 | Export is to be processed at a set interval regardless of change in the time-series data.
See Also

Reference

GSF.Historian.Exporters Namespace


FileHelper Class

Grid Solutions Framework FileHelper Class
A class with helper methods for file related operations.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersFileHelper

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class FileHelper
Public NotInheritable Class FileHelper
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FileHelper =  class end
GSF.Historian.Exporters.FileHelper = function();

Type.createClass(
    'GSF.Historian.Exporters.FileHelper');
public ref class FileHelper abstract sealed
Methods
Name | Description
WriteToFile(String, String) | Writes the specified text to the specified files.
WriteToFile(String, String, DataSet) | Writes data to the specified files in the specified format.
Top
See Also

Reference

GSF.Historian.Exporters Namespace


FileHelper Methods

Grid Solutions Framework FileHelper Methods
Methods
Name | Description
WriteToFile(String, String) | Writes the specified text to the specified files.
WriteToFile(String, String, DataSet) | Writes data to the specified files in the specified format.
Top
See Also

Reference

FileHelper Class
GSF.Historian.Exporters Namespace


FileHelper.WriteToFile Method

Grid Solutions Framework FileHelperWriteToFile Method
Overload List
Name | Description
WriteToFile(String, String) | Writes the specified text to the specified files.
WriteToFile(String, String, DataSet) | Writes data to the specified files in the specified format.
Top
See Also

Reference

FileHelper Class
GSF.Historian.Exporters Namespace


FileHelper.WriteToFile Method (String, String)

Grid Solutions Framework FileHelperWriteToFile Method (String, String)
Writes the specified text to the specified files.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WriteToFile(
    string files,
    string text
)
Public Shared Sub WriteToFile (
    files As String,
    text As String
)
static member WriteToFile :
        files : string *
        text : string -> unit

GSF.Historian.Exporters.FileHelper.WriteToFile = function(files, text);
public:
static void WriteToFile(
    String^ files,
    String^ text
)

Parameters

files
Type: SystemString
Comma or semi-colon delimitted list of file names to which the text is to be written.
text
Type: SystemString
Text to be written to the files.
See Also

Reference

FileHelper Class
WriteToFile Overload
GSF.Historian.Exporters Namespace


FileHelper.WriteToFile Method (String, String, DataSet)

Grid Solutions Framework FileHelperWriteToFile Method (String, String, DataSet)
Writes data to the specified files in the specified format.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WriteToFile(
    string files,
    string format,
    DataSet data
)
Public Shared Sub WriteToFile (
    files As String,
    format As String,
    data As DataSet
)
static member WriteToFile :
        files : string *
        format : string *
        data : DataSet -> unit

GSF.Historian.Exporters.FileHelper.WriteToFile = function(files, format, data);
public:
static void WriteToFile(
    String^ files,
    String^ format,
    DataSet^ data
)

Parameters

files
Type: SystemString
Comma or semi-colon delimitted list of file names to which data is to be written.
format
Type: SystemString
Format (CSV or XML) in which data is to be written to the files.
data
Type: System.DataDataSet
DataSet containing the data to be written to the files.
See Also

Reference

FileHelper Class
WriteToFile Overload
GSF.Historian.Exporters Namespace


IExporter Interface

Grid Solutions Framework IExporter Interface
Defines an exporter of real-time time-series data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IExporter : IDisposable
Public Interface IExporter
    Inherits IDisposable
type IExporter =
    interface
        interface IDisposable
    end
GSF.Historian.Exporters.IExporter = function();
GSF.Historian.Exporters.IExporter.createInterface('GSF.Historian.Exporters.IExporter');
public interface class IExporter : IDisposable

The IExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ProcessExport | Causes the Export with the specified exportName to be processed.
Top
Properties
 | Name | Description
Public property | Exports | Gets the Exports associated with the exporter.
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter.
Public property | Name | Gets or sets the name of the exporter.
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export.
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception.
Public event | StatusUpdate | Occurs when the exporter want to provide a status update.
Top
See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport
GSF.HistorianDataListener


IExporter Methods

Grid Solutions Framework IExporter Methods

The IExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | ProcessExport | Causes the Export with the specified exportName to be processed.
Top
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter.ProcessExport Method

Grid Solutions Framework IExporterProcessExport Method
Causes the Export with the specified exportName to be processed.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void ProcessExport(
    string exportName
)
Sub ProcessExport (
    exportName As String
)
abstract ProcessExport :
        exportName : string -> unit

function ProcessExport(exportName);
void ProcessExport(
    String^ exportName
)

Parameters

exportName
Type: SystemString
Name of the Export to be processed.
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter Properties

Grid Solutions Framework IExporter Properties

The IExporter type exposes the following members.

Properties
 | Name | Description
Public property | Exports | Gets the Exports associated with the exporter.
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter.
Public property | Name | Gets or sets the name of the exporter.
Top
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter.Exports Property

Grid Solutions Framework IExporterExports Property
Gets the Exports associated with the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IList<Export> Exports { get; }
ReadOnly Property Exports As IList(Of Export)
    Get
abstract Exports : IList<Export> with get

function get_Exports();

property IList<Export^>^ Exports {
    IList<Export^>^ get ();
}

Property Value

Type: IList Export
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter.Listeners Property

Grid Solutions Framework IExporterListeners Property
Gets the DataListeners providing real-time time-series data to the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IList<DataListener> Listeners { get; }
ReadOnly Property Listeners As IList(Of DataListener)
    Get
abstract Listeners : IList<DataListener> with get

function get_Listeners();

property IList<DataListener^>^ Listeners {
    IList<DataListener^>^ get ();
}

Property Value

Type: IList DataListener
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter.Name Property

Grid Solutions Framework IExporterName Property
Gets or sets the name of the exporter.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
abstract Name : string with get, set

function get_Name();
function set_Name(value);
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter Events

Grid Solutions Framework IExporter Events

The IExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export.
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception.
Public event | StatusUpdate | Occurs when the exporter want to provide a status update.
Top
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter.ExportProcessed Event

Grid Solutions Framework IExporterExportProcessed Event
Occurs when the exporter finishes processing an Export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Export>> ExportProcessed
Event ExportProcessed As EventHandler(Of EventArgs(Of Export))
abstract ExportProcessed : IEvent<EventHandler<EventArgs<Export>>,
    EventArgs<Export>>

function add_ExportProcessed(value);
function remove_ExportProcessed(value);
 event EventHandler<EventArgs<Export^>^>^ ExportProcessed {
    void add (EventHandler<EventArgs<Export^>^>^ value);
    void remove (EventHandler<EventArgs<Export^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Export
Remarks
Argument is the Export that the exporter finished processing.
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter.ExportProcessException Event

Grid Solutions Framework IExporterExportProcessException Event
Occurs when the exporter fails to process an Export due to an Exception.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Export>> ExportProcessException
Event ExportProcessException As EventHandler(Of EventArgs(Of Export))
abstract ExportProcessException : IEvent<EventHandler<EventArgs<Export>>,
    EventArgs<Export>>

function add_ExportProcessException(value);
function remove_ExportProcessException(value);
 event EventHandler<EventArgs<Export^>^>^ ExportProcessException {
    void add (EventHandler<EventArgs<Export^>^>^ value);
    void remove (EventHandler<EventArgs<Export^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Export
Remarks
Argument is the Export that the exporter failed to process.
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


IExporter.StatusUpdate Event

Grid Solutions Framework IExporterStatusUpdate Event
Occurs when the exporter want to provide a status update.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<string>> StatusUpdate
Event StatusUpdate As EventHandler(Of EventArgs(Of String))
abstract StatusUpdate : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_StatusUpdate(value);
function remove_StatusUpdate(value);
 event EventHandler<EventArgs<String^>^>^ StatusUpdate {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is the status update message.
See Also

Reference

IExporter Interface
GSF.Historian.Exporters Namespace


RawDataExporter Class

Grid Solutions Framework RawDataExporter Class
Represents an exporter that can export real-time time-series data in CSV or XML format to a file.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersRawDataExporter
GSF.Historian.ExportersStatisticsExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RawDataExporter : ExporterBase
Public Class RawDataExporter
    Inherits ExporterBase
type RawDataExporter =
    class
        inherit ExporterBase
    end
GSF.Historian.Exporters.RawDataExporter = function();

Type.createClass(
    'GSF.Historian.Exporters.RawDataExporter',
    GSF.Historian.Exporters.ExporterBase);
public ref class RawDataExporter : public ExporterBase

The RawDataExporter type exposes the following members.

Constructors
 | Name | Description
Public method | RawDataExporter | Initializes a new instance of the RawDataExporter class.
Protected method | RawDataExporter(String) | Initializes a new instance of the RawDataExporter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetBufferedData | Returns a DataSet containing the buffered real-time time-series data.
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Overrides ExporterBaseProcessRealTimeData(Object, EventArgsIListIDataPoint).)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
Examples
Definition of a sample Export that can be processed by RawDataExporter:
Copy
<?xml version="1.0" encoding="utf-16"?>
<Export xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>RawDataExport</Name>
  <Type>Intervaled</Type>
  <Interval>10</Interval>
  <Exporter>RawDataExporter</Exporter>
  <Settings>
    <ExportSetting>
      <Name>OutputFile</Name>
      <Value>c:\RawDataExporterOutput.xml</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>OutputFormat</Name>
      <Value>XML</Value>
    </ExportSetting>
  </Settings>
  <Records>
    <ExportRecord>
      <Instance>P3</Instance>
      <Identifier>3261</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>P3</Instance>
      <Identifier>3266</Identifier>
    </ExportRecord>
 </Records>
</Export>

Description of custom settings required by RawDataExporter in an Export:

Setting Name | Setting Description
OutputFile | Name of the CSV or XML file (including path) where export data is to be written.
OutputFormat | Format (CSV or XML) in which export data is to be written to the output file.

See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


RawDataExporter Constructor

Grid Solutions Framework RawDataExporter Constructor
Overload List
 | Name | Description
Public method | RawDataExporter | Initializes a new instance of the RawDataExporter class.
Protected method | RawDataExporter(String) | Initializes a new instance of the RawDataExporter class.
Top
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RawDataExporter Constructor

Grid Solutions Framework RawDataExporter Constructor
Initializes a new instance of the RawDataExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RawDataExporter()
Public Sub New
new : unit -> RawDataExporter
GSF.Historian.Exporters.RawDataExporter = function();
public:
RawDataExporter()
See Also

Reference

RawDataExporter Class
RawDataExporter Overload
GSF.Historian.Exporters Namespace


RawDataExporter Constructor (String)

Grid Solutions Framework RawDataExporter Constructor (String)
Initializes a new instance of the RawDataExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RawDataExporter(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> RawDataExporter
GSF.Historian.Exporters.RawDataExporter = function(name);
protected:
RawDataExporter(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

RawDataExporter Class
RawDataExporter Overload
GSF.Historian.Exporters Namespace


RawDataExporter Methods

Grid Solutions Framework RawDataExporter Methods

The RawDataExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetBufferedData | Returns a DataSet containing the buffered real-time time-series data.
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Overrides ExporterBaseProcessRealTimeData(Object, EventArgsIListIDataPoint).)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RawDataExporter.GetBufferedData Method

Grid Solutions Framework RawDataExporterGetBufferedData Method
Returns a DataSet containing the buffered real-time time-series data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataSet GetBufferedData(
    string exportName
)
Protected Function GetBufferedData (
    exportName As String
) As DataSet
member GetBufferedData :
        exportName : string -> DataSet

function GetBufferedData(exportName);
protected:
DataSet^ GetBufferedData(
    String^ exportName
)

Parameters

exportName
Type: SystemString
Name of the export whose buffered data is to be retrieved.

Return Value

Type: DataSet
A DataSet object if buffered data exists; otherwise null.
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RawDataExporter.ProcessExport Method

Grid Solutions Framework RawDataExporterProcessExport Method
Overload List
 | Name | Description
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Top
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RawDataExporter.ProcessExport Method (Export)

Grid Solutions Framework RawDataExporterProcessExport Method (Export)
Processes the export using the current Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessExport(
    Export export
)
Protected Overrides Sub ProcessExport (
    export As Export
)
abstract ProcessExport :
        export : Export -> unit
override ProcessExport :
        export : Export -> unit
function ProcessExport(export);
protected:
virtual void ProcessExport(
    Export^ export
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
Exceptions
Exception | Condition
ArgumentException | OutputFile or OutputFormat setting is missing from the Settings of the export.
See Also

Reference

RawDataExporter Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


RawDataExporter.ProcessRealTimeData Method

Grid Solutions Framework RawDataExporterProcessRealTimeData Method
Handles the DataExtracted event for all the Listeners.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessRealTimeData(
    Object sender,
    EventArgs<IList<IDataPoint>> e
)
Protected Overrides Sub ProcessRealTimeData (
    sender As Object,
    e As EventArgs(Of IList(Of IDataPoint))
)
abstract ProcessRealTimeData :
        sender : Object *
        e : EventArgs<IList<IDataPoint>> -> unit
override ProcessRealTimeData :
        sender : Object *
        e : EventArgs<IList<IDataPoint>> -> unit
function ProcessRealTimeData(sender, e);
protected:
virtual void ProcessRealTimeData(
    Object^ sender,
    EventArgs<IList<IDataPoint^>^>^ e
) override

Parameters

sender
Type: SystemObject
DataListener object that raised the event.
e
Type: GSFEventArgs IList IDataPoint
EventArgsT object where Argument is the collection of real-time time-sereis data received.
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RawDataExporter.ProcessRealTimeExport Method

Grid Solutions Framework RawDataExporterProcessRealTimeExport Method
Processes the export using the real-time data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void ProcessRealTimeExport(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub ProcessRealTimeExport (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
function ProcessRealTimeExport(export, listener, data);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void ProcessRealTimeExport(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
listener
Type: GSF.HistorianDataListener
DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
Real-time time-series data received by the listener.
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RawDataExporter Properties

Grid Solutions Framework RawDataExporter Properties

The RawDataExporter type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RawDataExporter Events

Grid Solutions Framework RawDataExporter Events

The RawDataExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
See Also

Reference

RawDataExporter Class
GSF.Historian.Exporters Namespace


RebroadcastExporter Class

Grid Solutions Framework RebroadcastExporter Class
Represents an exporter that can export real-time time-series data using TCP or UDP to a listening Socket.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersRebroadcastExporter
GSF.Historian.ExportersDataMonitorExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RebroadcastExporter : ExporterBase
Public Class RebroadcastExporter
    Inherits ExporterBase
type RebroadcastExporter =
    class
        inherit ExporterBase
    end
GSF.Historian.Exporters.RebroadcastExporter = function();

Type.createClass(
    'GSF.Historian.Exporters.RebroadcastExporter',
    GSF.Historian.Exporters.ExporterBase);
public ref class RebroadcastExporter : public ExporterBase

The RebroadcastExporter type exposes the following members.

Constructors
 | Name | Description
Public method | RebroadcastExporter | Initializes a new instance of the RebroadcastExporter class.
Protected method | RebroadcastExporter(String) | Initializes a new instance of the RebroadcastExporter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransmitData | Performs the transmission of time-series data for the export.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
Examples
Definition of a sample Export that can be processed by RebroadcastExporter:
Copy
<?xml version="1.0" encoding="utf-16"?>
<Export xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>RebroadcastExport</Name>
  <Type>RealTime</Type>
  <Interval>0</Interval>
  <Exporter>RebroadcastExporter</Exporter>
  <Settings>
    <ExportSetting>
      <Name>CommunicationConfiguration</Name>
      <Value>Protocol=TCP;Server=localhost:1002</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>LegacyMode</Name>
      <Value>True</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>PacketSize</Name>
      <Value>1100</Value>
    </ExportSetting>
  </Settings>
  <Records>
    <ExportRecord>
      <Instance>P2</Instance>
      <Identifier>1885</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>P2</Instance>
      <Identifier>2711</Identifier>
    </ExportRecord>
  </Records>
</Export>

Description of custom settings required by RebroadcastExporter in an Export:

Setting Name | Setting Description
CommunicationConfiguration | Connection information for connecting to a remote Socket. TCP example: Protocol=TCP;Server=localhost:1002 UDP example: Protocol=UDP;Server=localhost:1002 where the value of Server must be in the format of [Remote IP or DNS Name]:[Remote Port]
LegacyMode (Optional) | True if export data is to be transmitted in PacketType1 and False if export data is to be transmitted in PacketType101.
PacketSize (Optional) | Maximum size of the packet in which the export data is to be transmitted.

See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


RebroadcastExporter Constructor

Grid Solutions Framework RebroadcastExporter Constructor
Overload List
 | Name | Description
Public method | RebroadcastExporter | Initializes a new instance of the RebroadcastExporter class.
Protected method | RebroadcastExporter(String) | Initializes a new instance of the RebroadcastExporter class.
Top
See Also

Reference

RebroadcastExporter Class
GSF.Historian.Exporters Namespace


RebroadcastExporter Constructor

Grid Solutions Framework RebroadcastExporter Constructor
Initializes a new instance of the RebroadcastExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RebroadcastExporter()
Public Sub New
new : unit -> RebroadcastExporter
GSF.Historian.Exporters.RebroadcastExporter = function();
public:
RebroadcastExporter()
See Also

Reference

RebroadcastExporter Class
RebroadcastExporter Overload
GSF.Historian.Exporters Namespace


RebroadcastExporter Constructor (String)

Grid Solutions Framework RebroadcastExporter Constructor (String)
Initializes a new instance of the RebroadcastExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RebroadcastExporter(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> RebroadcastExporter
GSF.Historian.Exporters.RebroadcastExporter = function(name);
protected:
RebroadcastExporter(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

RebroadcastExporter Class
RebroadcastExporter Overload
GSF.Historian.Exporters Namespace


RebroadcastExporter Methods

Grid Solutions Framework RebroadcastExporter Methods

The RebroadcastExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TransmitData | Performs the transmission of time-series data for the export.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RebroadcastExporter Class
GSF.Historian.Exporters Namespace


RebroadcastExporter.ProcessExport Method

Grid Solutions Framework RebroadcastExporterProcessExport Method
Overload List
 | Name | Description
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Top
See Also

Reference

RebroadcastExporter Class
GSF.Historian.Exporters Namespace


RebroadcastExporter.ProcessExport Method (Export)

Grid Solutions Framework RebroadcastExporterProcessExport Method (Export)
Processes the export using the current Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessExport(
    Export export
)
Protected Overrides Sub ProcessExport (
    export As Export
)
abstract ProcessExport :
        export : Export -> unit
override ProcessExport :
        export : Export -> unit
function ProcessExport(export);
protected:
virtual void ProcessExport(
    Export^ export
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
See Also

Reference

RebroadcastExporter Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


RebroadcastExporter.ProcessRealTimeExport Method

Grid Solutions Framework RebroadcastExporterProcessRealTimeExport Method
Processes the export using the real-time data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessRealTimeExport(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
Protected Overrides Sub ProcessRealTimeExport (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
abstract ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
override ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
function ProcessRealTimeExport(export, listener, data);
protected:
virtual void ProcessRealTimeExport(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
listener
Type: GSF.HistorianDataListener
DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
Real-time time-series data received by the listener.
See Also

Reference

RebroadcastExporter Class
GSF.Historian.Exporters Namespace


RebroadcastExporter.TransmitData Method

Grid Solutions Framework RebroadcastExporterTransmitData Method
Performs the transmission of time-series data for the export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void TransmitData(
    Export export,
    IList<IDataPoint> dataToTransmit
)
Protected Overridable Sub TransmitData (
    export As Export,
    dataToTransmit As IList(Of IDataPoint)
)
abstract TransmitData :
        export : Export *
        dataToTransmit : IList<IDataPoint> -> unit
override TransmitData :
        export : Export *
        dataToTransmit : IList<IDataPoint> -> unit
function TransmitData(export, dataToTransmit);
protected:
virtual void TransmitData(
    Export^ export,
    IList<IDataPoint^>^ dataToTransmit
)

Parameters

export
Type: GSF.Historian.ExportersExport
Export whose time-series data os to be transmitted.
dataToTransmit
Type: System.Collections.GenericIList IDataPoint
Collection of time-series data to be transmitted.
See Also

Reference

RebroadcastExporter Class
GSF.Historian.Exporters Namespace


RebroadcastExporter Properties

Grid Solutions Framework RebroadcastExporter Properties

The RebroadcastExporter type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
See Also

Reference

RebroadcastExporter Class
GSF.Historian.Exporters Namespace


RebroadcastExporter Events

Grid Solutions Framework RebroadcastExporter Events

The RebroadcastExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
See Also

Reference

RebroadcastExporter Class
GSF.Historian.Exporters Namespace


RollingHistoryExporter Class

Grid Solutions Framework RollingHistoryExporter Class
Represents an exporter that can export current and runtime historic time-series data in CSV or XML format to a file.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersRollingHistoryExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RollingHistoryExporter : ExporterBase
Public Class RollingHistoryExporter
    Inherits ExporterBase
type RollingHistoryExporter =
    class
        inherit ExporterBase
    end
GSF.Historian.Exporters.RollingHistoryExporter = function();

Type.createClass(
    'GSF.Historian.Exporters.RollingHistoryExporter',
    GSF.Historian.Exporters.ExporterBase);
public ref class RollingHistoryExporter : public ExporterBase

The RollingHistoryExporter type exposes the following members.

Constructors
 | Name | Description
Public method | RollingHistoryExporter | Initializes a new instance of the RollingHistoryExporter class.
Protected method | RollingHistoryExporter(String) | Initializes a new instance of the RollingHistoryExporter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
Examples
Definition of a sample Export that can be processed by RollingHistoryExporter:
Copy
<?xml version="1.0" encoding="utf-16"?>
<Export xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>RollingHistoryExport</Name>
  <Type>Intervaled</Type>
  <Interval>60</Interval>
  <Exporter>RollingHistoryExporter</Exporter>
  <Settings>
    <ExportSetting>
      <Name>OutputFile</Name>
      <Value>c:\RollingHistoryExportOutput.xml</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>OutputFormat</Name>
      <Value>XML</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>OutputTimespan</Name>
      <Value>360</Value>
    </ExportSetting>
  </Settings>
  <Records>
    <ExportRecord>
      <Instance>TP</Instance>
      <Identifier>25609</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>TP</Instance>
      <Identifier>41517</Identifier>
    </ExportRecord>
 </Records>
</Export>

Description of custom settings required by RollingHistoryExporter in an Export:

Setting Name | Setting Description
OutputFile | Name of the CSV or XML file (including path) where export data is to be written.
OutputFormat | Format (CSV or XML) in which export data is to be written to the output file.
OutputTimespan | Span (represented in seconds) of the moving window for which the runtime historic data is to be exported.

See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


RollingHistoryExporter Constructor

Grid Solutions Framework RollingHistoryExporter Constructor
Overload List
 | Name | Description
Public method | RollingHistoryExporter | Initializes a new instance of the RollingHistoryExporter class.
Protected method | RollingHistoryExporter(String) | Initializes a new instance of the RollingHistoryExporter class.
Top
See Also

Reference

RollingHistoryExporter Class
GSF.Historian.Exporters Namespace


RollingHistoryExporter Constructor

Grid Solutions Framework RollingHistoryExporter Constructor
Initializes a new instance of the RollingHistoryExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RollingHistoryExporter()
Public Sub New
new : unit -> RollingHistoryExporter
GSF.Historian.Exporters.RollingHistoryExporter = function();
public:
RollingHistoryExporter()
See Also

Reference

RollingHistoryExporter Class
RollingHistoryExporter Overload
GSF.Historian.Exporters Namespace


RollingHistoryExporter Constructor (String)

Grid Solutions Framework RollingHistoryExporter Constructor (String)
Initializes a new instance of the RollingHistoryExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RollingHistoryExporter(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> RollingHistoryExporter
GSF.Historian.Exporters.RollingHistoryExporter = function(name);
protected:
RollingHistoryExporter(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

RollingHistoryExporter Class
RollingHistoryExporter Overload
GSF.Historian.Exporters Namespace


RollingHistoryExporter Methods

Grid Solutions Framework RollingHistoryExporter Methods

The RollingHistoryExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RollingHistoryExporter Class
GSF.Historian.Exporters Namespace


RollingHistoryExporter.ProcessExport Method

Grid Solutions Framework RollingHistoryExporterProcessExport Method
Overload List
 | Name | Description
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Top
See Also

Reference

RollingHistoryExporter Class
GSF.Historian.Exporters Namespace


RollingHistoryExporter.ProcessExport Method (Export)

Grid Solutions Framework RollingHistoryExporterProcessExport Method (Export)
Processes the export using the current Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessExport(
    Export export
)
Protected Overrides Sub ProcessExport (
    export As Export
)
abstract ProcessExport :
        export : Export -> unit
override ProcessExport :
        export : Export -> unit
function ProcessExport(export);
protected:
virtual void ProcessExport(
    Export^ export
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
Exceptions
Exception | Condition
ArgumentException | OutputFile, OutputFormat or OutputTimespan setting is missing from the Settings of the export.
See Also

Reference

RollingHistoryExporter Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


RollingHistoryExporter.ProcessRealTimeExport Method

Grid Solutions Framework RollingHistoryExporterProcessRealTimeExport Method
Processes the export using the real-time data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void ProcessRealTimeExport(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub ProcessRealTimeExport (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
function ProcessRealTimeExport(export, listener, data);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void ProcessRealTimeExport(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
listener
Type: GSF.HistorianDataListener
DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
Real-time time-series data received by the listener.
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

RollingHistoryExporter Class
GSF.Historian.Exporters Namespace


RollingHistoryExporter Properties

Grid Solutions Framework RollingHistoryExporter Properties

The RollingHistoryExporter type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
See Also

Reference

RollingHistoryExporter Class
GSF.Historian.Exporters Namespace


RollingHistoryExporter Events

Grid Solutions Framework RollingHistoryExporter Events

The RollingHistoryExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
See Also

Reference

RollingHistoryExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter Class

Grid Solutions Framework StatisticsExporter Class
Represents an exporter that can export the StatisticsExporterStatistics in CSV or XML format to a file.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersRawDataExporter
GSF.Historian.ExportersStatisticsExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class StatisticsExporter : RawDataExporter
Public Class StatisticsExporter
    Inherits RawDataExporter
type StatisticsExporter =
    class
        inherit RawDataExporter
    end
GSF.Historian.Exporters.StatisticsExporter = function();

Type.createClass(
    'GSF.Historian.Exporters.StatisticsExporter',
    GSF.Historian.Exporters.RawDataExporter);
public ref class StatisticsExporter : public RawDataExporter

The StatisticsExporter type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsExporter | Initializes a new instance of the StatisticsExporter class.
Protected method | StatisticsExporter(String) | Initializes a new instance of the StatisticsExporter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetBufferedData | Returns a DataSet containing the buffered real-time time-series data. (Inherited from RawDataExporter.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Protected method | GetStatistics | Returns the calculated StatisticsExporterStatistics from buffered data of the specified export.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides RawDataExporterProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from RawDataExporter.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides RawDataExporterProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
Examples
Definition of a sample Export that can be processed by StatisticsExporter:
Copy
<?xml version="1.0" encoding="utf-16"?>
<Export xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>StatisticsExporte</Name>
  <Type>Intervaled</Type>
  <Interval>10</Interval>
  <Exporter>StatisticsExporter</Exporter>
  <Settings>
    <ExportSetting>
      <Name>OutputFile</Name>
      <Value>\\trotibco\XML\EIRA.xml</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>OutputFormat</Name>
      <Value>XML</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>FilterClause</Name>
      <Value>Value&gt;=59 And Value&lt;=61</Value>
    </ExportSetting>
    <ExportSetting>
      <Name>SlopeThreshold</Name>
      <Value>.9</Value>
    </ExportSetting>
  </Settings>
  <Records>
    <ExportRecord>
      <Instance>P1</Instance>
      <Identifier>1285</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>P2</Instance>
      <Identifier>3173</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>P3</Instance>
      <Identifier>1838</Identifier>
    </ExportRecord>
 </Records>
</Export>

Description of custom settings required by StatisticsExporter in an Export:

Setting Name | Setting Description
OutputFile | Name of the CSV or XML file (including path) where export data is to be written.
OutputFormat | Format (CSV or XML) in which export data is to be written to the output file.
FilterClause (Optional) | SQL-like expression to be used for limiting the data included in the calculation.
SlopeThreshold (Optional) | Floating point value to be used for eliminating data with a slope exceeding the specified threshold.

See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


StatisticsExporter Constructor

Grid Solutions Framework StatisticsExporter Constructor
Overload List
 | Name | Description
Public method | StatisticsExporter | Initializes a new instance of the StatisticsExporter class.
Protected method | StatisticsExporter(String) | Initializes a new instance of the StatisticsExporter class.
Top
See Also

Reference

StatisticsExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter Constructor

Grid Solutions Framework StatisticsExporter Constructor
Initializes a new instance of the StatisticsExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatisticsExporter()
Public Sub New
new : unit -> StatisticsExporter
GSF.Historian.Exporters.StatisticsExporter = function();
public:
StatisticsExporter()
See Also

Reference

StatisticsExporter Class
StatisticsExporter Overload
GSF.Historian.Exporters Namespace


StatisticsExporter Constructor (String)

Grid Solutions Framework StatisticsExporter Constructor (String)
Initializes a new instance of the StatisticsExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected StatisticsExporter(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> StatisticsExporter
GSF.Historian.Exporters.StatisticsExporter = function(name);
protected:
StatisticsExporter(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

StatisticsExporter Class
StatisticsExporter Overload
GSF.Historian.Exporters Namespace


StatisticsExporter Methods

Grid Solutions Framework StatisticsExporter Methods

The StatisticsExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetBufferedData | Returns a DataSet containing the buffered real-time time-series data. (Inherited from RawDataExporter.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Protected method | GetStatistics | Returns the calculated StatisticsExporterStatistics from buffered data of the specified export.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides RawDataExporterProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from RawDataExporter.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides RawDataExporterProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

StatisticsExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter.GetStatistics Method

Grid Solutions Framework StatisticsExporterGetStatistics Method
Returns the calculated StatisticsExporterStatistics from buffered data of the specified export.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual StatisticsExporterStatistics GetStatistics(
    Export export
)
Protected Overridable Function GetStatistics (
    export As Export
) As StatisticsExporterStatistics
abstract GetStatistics :
        export : Export -> StatisticsExporterStatistics
override GetStatistics :
        export : Export -> StatisticsExporterStatistics
function GetStatistics(export);
protected:
virtual StatisticsExporterStatistics^ GetStatistics(
    Export^ export
)

Parameters

export
Type: GSF.Historian.ExportersExport
Export for which statistical values are to be calculated.

Return Value

Type: StatisticsExporterStatistics
The calculated StatisticsExporterStatistics from buffered data of the specified export.
See Also

Reference

StatisticsExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter.ProcessExport Method

Grid Solutions Framework StatisticsExporterProcessExport Method
Overload List
 | Name | Description
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides RawDataExporterProcessExport(Export).)
Top
See Also

Reference

StatisticsExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter.ProcessExport Method (Export)

Grid Solutions Framework StatisticsExporterProcessExport Method (Export)
Processes the export using the current Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessExport(
    Export export
)
Protected Overrides Sub ProcessExport (
    export As Export
)
abstract ProcessExport :
        export : Export -> unit
override ProcessExport :
        export : Export -> unit
function ProcessExport(export);
protected:
virtual void ProcessExport(
    Export^ export
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
Exceptions
Exception | Condition
ArgumentException | OutputFile or OutputFormat setting is missing from the Settings of the export.
See Also

Reference

StatisticsExporter Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


StatisticsExporter.ProcessRealTimeExport Method

Grid Solutions Framework StatisticsExporterProcessRealTimeExport Method
Processes the export using the real-time data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void ProcessRealTimeExport(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub ProcessRealTimeExport (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
function ProcessRealTimeExport(export, listener, data);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void ProcessRealTimeExport(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
listener
Type: GSF.HistorianDataListener
DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
Real-time time-series data received by the listener.
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

StatisticsExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter Properties

Grid Solutions Framework StatisticsExporter Properties

The StatisticsExporter type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
See Also

Reference

StatisticsExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter Events

Grid Solutions Framework StatisticsExporter Events

The StatisticsExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
See Also

Reference

StatisticsExporter Class
GSF.Historian.Exporters Namespace


StatisticsExporter.Statistics Class

Grid Solutions Framework StatisticsExporterStatistics Class
A class for calculating the MIN, MAX and AVG of time-series data over a period of time.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersStatisticsExporterStatistics

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected class Statistics
Protected Class Statistics
type Statistics =  class end
GSF.Historian.Exporters.Statistics = function();

Type.createClass(
    'GSF.Historian.Exporters.Statistics');
protected ref class Statistics

The StatisticsExporterStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsExporterStatistics | Initializes a new instance of the StatisticsExporterStatistics class.
Top
Methods
 | Name | Description
Public method | Calculate | Calculates StatisticsExporterStatistics from the provided data and clear the data when done.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | AverageValue | The average value in the time-series data.
Public field | MaximumValue | The largest value in the time-series data.
Public field | MinimumValue | The smallest value in the time-series data.
Top
See Also

Reference

GSF.Historian.Exporters Namespace


StatisticsExporter.Statistics Constructor

Grid Solutions Framework StatisticsExporterStatistics Constructor
Initializes a new instance of the StatisticsExporterStatistics class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Statistics()
Public Sub New
new : unit -> Statistics
GSF.Historian.Exporters.Statistics = function();
public:
Statistics()
See Also

Reference

StatisticsExporterStatistics Class
GSF.Historian.Exporters Namespace


Statistics Fields

Grid Solutions Framework Statistics Fields

The StatisticsExporterStatistics type exposes the following members.

Fields
 | Name | Description
Public field | AverageValue | The average value in the time-series data.
Public field | MaximumValue | The largest value in the time-series data.
Public field | MinimumValue | The smallest value in the time-series data.
Top
See Also

Reference

StatisticsExporterStatistics Class
GSF.Historian.Exporters Namespace


StatisticsExporter.Statistics.AverageValue Field

Grid Solutions Framework StatisticsExporterStatisticsAverageValue Field
The average value in the time-series data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double AverageValue
Public AverageValue As Double
val mutable AverageValue: float
var AverageValue
public:
double AverageValue

Field Value

Type: Double
See Also

Reference

StatisticsExporterStatistics Class
GSF.Historian.Exporters Namespace


StatisticsExporter.Statistics.MaximumValue Field

Grid Solutions Framework StatisticsExporterStatisticsMaximumValue Field
The largest value in the time-series data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double MaximumValue
Public MaximumValue As Double
val mutable MaximumValue: float
var MaximumValue
public:
double MaximumValue

Field Value

Type: Double
See Also

Reference

StatisticsExporterStatistics Class
GSF.Historian.Exporters Namespace


StatisticsExporter.Statistics.MinimumValue Field

Grid Solutions Framework StatisticsExporterStatisticsMinimumValue Field
The smallest value in the time-series data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double MinimumValue
Public MinimumValue As Double
val mutable MinimumValue: float
var MinimumValue
public:
double MinimumValue

Field Value

Type: Double
See Also

Reference

StatisticsExporterStatistics Class
GSF.Historian.Exporters Namespace


Statistics Methods

Grid Solutions Framework Statistics Methods

The StatisticsExporterStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Calculates StatisticsExporterStatistics from the provided data and clear the data when done.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

StatisticsExporterStatistics Class
GSF.Historian.Exporters Namespace


StatisticsExporter.Statistics.Calculate Method

Grid Solutions Framework StatisticsExporterStatisticsCalculate Method
Calculates StatisticsExporterStatistics from the provided data and clear the data when done.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Calculate(
    DataSet data,
    string filerClause
)
Public Sub Calculate (
    data As DataSet,
    filerClause As String
)
member Calculate :
        data : DataSet *
        filerClause : string -> unit

function Calculate(data, filerClause);
public:
void Calculate(
    DataSet^ data,
    String^ filerClause
)

Parameters

data
Type: System.DataDataSet
A DataSet containing buffered real-time time-series data.
filerClause
Type: SystemString
Filter clause to be applied for limiting the data included in the calculation.
See Also

Reference

StatisticsExporterStatistics Class
GSF.Historian.Exporters Namespace


XmlExporter Class

Grid Solutions Framework XmlExporter Class
Represents an exporter that can export the current time-series data in XML format to a file.
Inheritance Hierarchy
SystemObject
GSF.Historian.ExportersExporterBase
GSF.Historian.ExportersXmlExporter

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class XmlExporter : ExporterBase
Public Class XmlExporter
    Inherits ExporterBase
type XmlExporter =
    class
        inherit ExporterBase
    end
GSF.Historian.Exporters.XmlExporter = function();

Type.createClass(
    'GSF.Historian.Exporters.XmlExporter',
    GSF.Historian.Exporters.ExporterBase);
public ref class XmlExporter : public ExporterBase

The XmlExporter type exposes the following members.

Constructors
 | Name | Description
Public method | XmlExporter | Initializes a new instance of the XmlExporter class.
Protected method | XmlExporter(String) | Initializes a new instance of the XmlExporter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
Examples
Definition of a sample Export that can be processed by XmlExporter:
Copy
<?xml version="1.0" encoding="utf-16"?>
<Export xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
  <Name>XmlExport</Name>
  <Type>Intervaled</Type>
  <Interval>60</Interval>
  <Exporter>XmlExporter</Exporter>
  <Settings>
    <ExportSetting>
      <Name>OutputFile</Name>
      <Value>c:\XmlExportOutput.xml</Value>
    </ExportSetting>
  </Settings>
  <Records>
    <ExportRecord>
      <Instance>TP</Instance>
      <Identifier>25609</Identifier>
    </ExportRecord>
    <ExportRecord>
      <Instance>TP</Instance>
      <Identifier>41517</Identifier>
    </ExportRecord>
  </Records>
</Export>

Description of custom settings required by XmlExporter in an Export:

Setting Name | Setting Description
OutputFile | Name of the XML file (including path) where export data is to be written.

See Also

Reference

GSF.Historian.Exporters Namespace
GSF.Historian.ExportersExport


XmlExporter Constructor

Grid Solutions Framework XmlExporter Constructor
Overload List
 | Name | Description
Public method | XmlExporter | Initializes a new instance of the XmlExporter class.
Protected method | XmlExporter(String) | Initializes a new instance of the XmlExporter class.
Top
See Also

Reference

XmlExporter Class
GSF.Historian.Exporters Namespace


XmlExporter Constructor

Grid Solutions Framework XmlExporter Constructor
Initializes a new instance of the XmlExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public XmlExporter()
Public Sub New
new : unit -> XmlExporter
GSF.Historian.Exporters.XmlExporter = function();
public:
XmlExporter()
See Also

Reference

XmlExporter Class
XmlExporter Overload
GSF.Historian.Exporters Namespace


XmlExporter Constructor (String)

Grid Solutions Framework XmlExporter Constructor (String)
Initializes a new instance of the XmlExporter class.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected XmlExporter(
    string name
)
Protected Sub New (
    name As String
)
new :
        name : string -> XmlExporter
GSF.Historian.Exporters.XmlExporter = function(name);
protected:
XmlExporter(
    String^ name
)

Parameters

name
Type: SystemString
Name of the exporter.
See Also

Reference

XmlExporter Class
XmlExporter Overload
GSF.Historian.Exporters Namespace


XmlExporter Methods

Grid Solutions Framework XmlExporter Methods

The XmlExporter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the exporter. (Inherited from ExporterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the exporter and optionally releases the managed resources. (Inherited from ExporterBase.)
Public method | Equals | Determines whether the current exporter object is equal to obj. (Inherited from ExporterBase.)
Protected method | Finalize | Releases the unmanaged resources before the exporter is reclaimed by GC. (Inherited from ExporterBase.)
Public method | FindExport | Returns the Export for the specified exportName from the Exports. (Inherited from ExporterBase.)
Public method | FindListener | Returns the DataListener for the specified listenerName from the Listeners. (Inherited from ExporterBase.)
Protected method | GetExportData | Returns the current time-series data for the specified export organized by listener. (Inherited from ExporterBase.)
Protected method | GetExportDataAsDataset | Returns the current time-series data for the specified export in a DataSet. (Inherited from ExporterBase.)
Public method | GetHashCode | Returns the hash code for the current exporter object. (Inherited from ExporterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnExportProcessed | Raises the ExportProcessed event. (Inherited from ExporterBase.)
Protected method | OnExportProcessException | Raises the ExportProcessException event. (Inherited from ExporterBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from ExporterBase.)
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Protected method | ProcessRealTimeData | Handles the DataExtracted event for all the Listeners. (Inherited from ExporterBase.)
Protected method | ProcessRealTimeExport | Processes the export using the real-time data. (Overrides ExporterBaseProcessRealTimeExport(Export, DataListener, IListIDataPoint).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

XmlExporter Class
GSF.Historian.Exporters Namespace


XmlExporter.ProcessExport Method

Grid Solutions Framework XmlExporterProcessExport Method
Overload List
 | Name | Description
Public method | ProcessExport(String) | Processes Export with the specified exportName. (Inherited from ExporterBase.)
Protected method | ProcessExport(Export) | Processes the export using the current Data. (Overrides ExporterBaseProcessExport(Export).)
Top
See Also

Reference

XmlExporter Class
GSF.Historian.Exporters Namespace


XmlExporter.ProcessExport Method (Export)

Grid Solutions Framework XmlExporterProcessExport Method (Export)
Processes the export using the current Data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ProcessExport(
    Export export
)
Protected Overrides Sub ProcessExport (
    export As Export
)
abstract ProcessExport :
        export : Export -> unit
override ProcessExport :
        export : Export -> unit
function ProcessExport(export);
protected:
virtual void ProcessExport(
    Export^ export
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
Exceptions
Exception | Condition
ArgumentException | OutputFile setting is missing from the Settings of the export.
See Also

Reference

XmlExporter Class
ProcessExport Overload
GSF.Historian.Exporters Namespace


XmlExporter.ProcessRealTimeExport Method

Grid Solutions Framework XmlExporterProcessRealTimeExport Method
Processes the export using the real-time data.

Namespace: GSF.Historian.Exporters
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
protected override void ProcessRealTimeExport(
    Export export,
    DataListener listener,
    IList<IDataPoint> data
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Protected Overrides Sub ProcessRealTimeExport (
    export As Export,
    listener As DataListener,
    data As IList(Of IDataPoint)
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ProcessRealTimeExport :
        export : Export *
        listener : DataListener *
        data : IList<IDataPoint> -> unit
function ProcessRealTimeExport(export, listener, data);
protected:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void ProcessRealTimeExport(
    Export^ export,
    DataListener^ listener,
    IList<IDataPoint^>^ data
) override

Parameters

export
Type: GSF.Historian.ExportersExport
Export to be processed.
listener
Type: GSF.HistorianDataListener
DataListener that provided the data.
data
Type: System.Collections.GenericIList IDataPoint
Real-time time-series data received by the listener.
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

XmlExporter Class
GSF.Historian.Exporters Namespace


XmlExporter Properties

Grid Solutions Framework XmlExporter Properties

The XmlExporter type exposes the following members.

Properties
 | Name | Description
Protected property | ExportAddedHandler | Gets or sets the Delegate to be invoked when a new Export is added to the Exports. (Inherited from ExporterBase.)
Protected property | ExportRemovedHandler | Gets or sets the Delegate to be invoked when an existing Export is removed from the Exports. (Inherited from ExporterBase.)
Public property | Exports | Gets the Exports associated with the exporter. (Inherited from ExporterBase.)
Protected property | ExportUpdatedHandler | Gets or sets the Delegate to be invoked when an existing Export from the Exports is updated. (Inherited from ExporterBase.)
Public property | Listeners | Gets the DataListeners providing real-time time-series data to the exporter. (Inherited from ExporterBase.)
Public property | Name | Gets or sets the name of the exporter. (Inherited from ExporterBase.)
Protected property | RealTimeExportQueue | Gets the internal ProcessQueueT used for processing Exports defined as RealTime. (Inherited from ExporterBase.)
Top
See Also

Reference

XmlExporter Class
GSF.Historian.Exporters Namespace


XmlExporter Events

Grid Solutions Framework XmlExporter Events

The XmlExporter type exposes the following members.

Events
 | Name | Description
Public event | ExportProcessed | Occurs when the exporter finishes processing an Export. (Inherited from ExporterBase.)
Public event | ExportProcessException | Occurs when the exporter fails to process an Export due to an Exception. (Inherited from ExporterBase.)
Public event | StatusUpdate | Occurs when the exporter want to provide a status update. (Inherited from ExporterBase.)
Top
See Also

Reference

XmlExporter Class
GSF.Historian.Exporters Namespace


GSF.Historian.Files Namespace

Grid Solutions Framework GSF.Historian.Files Namespace
Contains classes used for manipulating archive files.
Classes
 | Class | Description
Public class | ArchiveDataBlock | Represents a block of ArchiveDataPoints in an ArchiveFile.
Public class | ArchiveDataBlockPointer | Represents a pointer to an ArchiveDataBlock.
Public class | ArchiveDataBlockPointerExtensions | Extension methods for the ArchiveDataBlockPointer.
Public class | ArchiveDataPoint | Represents time-series data stored in ArchiveFile.
Public class | ArchiveFile | Represents a file that contains ArchiveDataPoints.
Public class | ArchiveFileAllocationTable | Represents the File Allocation Table of an ArchiveFile.
Public class | ArchiveFileScanner | Scans an archive file for data points in a given time range and returns them in the order that they are scanned.
Public class | ArchiveFileStatistics | A class that contains the statistics of an ArchiveFile.
Public class | ArchiveReader | Opens a local set of historian files for reading with active archive file being monitored for roll-over.
Public class | IntercomFile | Represents a file containing IntercomRecords.
Public class | IntercomRecord | Represents a record in the IntercomFile that contains runtime information of a historian.
Public class | MetadataFile | Represents a file containing MetadataRecords.
Public class | MetadataRecord | Represents a record in the MetadataFile that contains the various attributes associates to a HistorianID.
Public class | MetadataRecordAlarmFlags | Defines which data Quality should trigger an alarm notification.
Public class | MetadataRecordAnalogFields | Defines specific fields for MetadataRecords that are of type Analog.
Public class | MetadataRecordComposedFields | Defines specific fields for MetadataRecords that are of type Composed.
Public class | MetadataRecordConstantFields | Defines specific fields for MetadataRecords that are of type Constant.
Public class | MetadataRecordDigitalFields | Defines specific fields for MetadataRecords that are of type Digital.
Public class | MetadataRecordGeneralFlags | Defines general boolean settings for a MetadataRecord.
Public class | MetadataRecordSecurityFlags | Defines the security level for a MetadataRecord.
Public class | MetadataRecordSummary | A class with a subset of information defined in MetadataRecord. The generated binary image of MetadataRecordSummary is sent back as a reply to PacketType3 and PacketType4.
Public class | StateFile | Represents a file containing StateRecords.
Public class | StateRecord | Represents a record in the StateFile that contains the state information associated to a HistorianID.
Public class | StateRecordDataPoint | Represents time-series data stored in StateFile.
Public class | StateRecordSummary | A class with just CurrentData. The generated binary image of MetadataRecordSummary is sent back as a reply to PacketType11.
Public class | TimeSortedArchiveFileScanner | Reads a series of data points from an ArchiveFile in sorted order.
Interfaces
 | Interface | Description
Public interface | IArchiveFileScanner | Represents a scanner that reads data points from an archive file for a given time range.
Enumerations
 | Enumeration | Description
Public enumeration | ArchiveFileType | Indicates the type of ArchiveFile.
Public enumeration | DataType | Indicates the type of data being archived for a MetadataRecord.
Public enumeration | MetadataFileLegacyMode | Defines legacy operational modes for the MetadataFile.


ArchiveDataBlock Class

Grid Solutions Framework ArchiveDataBlock Class
Represents a block of ArchiveDataPoints in an ArchiveFile.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveDataBlock

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ArchiveDataBlock
Public Class ArchiveDataBlock
type ArchiveDataBlock =  class end
GSF.Historian.Files.ArchiveDataBlock = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveDataBlock');
public ref class ArchiveDataBlock

The ArchiveDataBlock type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataReadException | Raises the DataReadException event.
Public method | Read | Reads existing ArchiveDataPoints from the ArchiveDataBlock.
Public method | Reset | Resets the ArchiveDataBlock by overwriting existing ArchiveDataPoints with empty ArchiveDataPoints.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes the dataPoint to the ArchiveDataBlock.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Capacity | Gets the maximum number of ArchiveDataPoints that can be stored in the ArchiveDataBlock.
Public property | Index | Gets the 0-based index of the ArchiveDataBlock.
Public property | IsActive | Gets a boolean value that indicates whether the ArchiveDataBlock is being actively used.
Public property | Location | Gets the start location (byte position) of the ArchiveDataBlock in the ArchiveFile.
Public property | SlotsAvailable | Gets the number of ArchiveDataPoints that can to written to the ArchiveDataBlock.
Public property | SlotsUsed | Gets the number of ArchiveDataPoints that have been written to the ArchiveDataBlock.
Top
Events
 | Name | Description
Public event | DataReadException | Occurs when an Exception is encountered while reading IDataPoint from the ArchiveDataBlock.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesArchiveFile
GSF.Historian.FilesArchiveDataPoint


ArchiveDataBlock Methods

Grid Solutions Framework ArchiveDataBlock Methods

The ArchiveDataBlock type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataReadException | Raises the DataReadException event.
Public method | Read | Reads existing ArchiveDataPoints from the ArchiveDataBlock.
Public method | Reset | Resets the ArchiveDataBlock by overwriting existing ArchiveDataPoints with empty ArchiveDataPoints.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes the dataPoint to the ArchiveDataBlock.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.OnDataReadException Method

Grid Solutions Framework ArchiveDataBlockOnDataReadException Method
Raises the DataReadException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataReadException(
    Exception ex
)
Protected Overridable Sub OnDataReadException (
    ex As Exception
)
abstract OnDataReadException :
        ex : Exception -> unit
override OnDataReadException :
        ex : Exception -> unit
function OnDataReadException(ex);
protected:
virtual void OnDataReadException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to DataReadException event.
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.Read Method

Grid Solutions Framework ArchiveDataBlockRead Method
Reads existing ArchiveDataPoints from the ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> Read()
Public Function Read As IEnumerable(Of IDataPoint)
member Read : unit -> IEnumerable<IDataPoint>

function Read();
public:
IEnumerable<IDataPoint^>^ Read()

Return Value

Type: IEnumerable IDataPoint
Returns ArchiveDataPoints from the ArchiveDataBlock.
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.Reset Method

Grid Solutions Framework ArchiveDataBlockReset Method
Resets the ArchiveDataBlock by overwriting existing ArchiveDataPoints with empty ArchiveDataPoints.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.Write Method

Grid Solutions Framework ArchiveDataBlockWrite Method
Writes the dataPoint to the ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Write(
    IDataPoint dataPoint
)
Public Sub Write (
    dataPoint As IDataPoint
)
member Write :
        dataPoint : IDataPoint -> unit

function Write(dataPoint);
public:
void Write(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint to write.
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock Properties

Grid Solutions Framework ArchiveDataBlock Properties

The ArchiveDataBlock type exposes the following members.

Properties
 | Name | Description
Public property | Capacity | Gets the maximum number of ArchiveDataPoints that can be stored in the ArchiveDataBlock.
Public property | Index | Gets the 0-based index of the ArchiveDataBlock.
Public property | IsActive | Gets a boolean value that indicates whether the ArchiveDataBlock is being actively used.
Public property | Location | Gets the start location (byte position) of the ArchiveDataBlock in the ArchiveFile.
Public property | SlotsAvailable | Gets the number of ArchiveDataPoints that can to written to the ArchiveDataBlock.
Public property | SlotsUsed | Gets the number of ArchiveDataPoints that have been written to the ArchiveDataBlock.
Top
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.Capacity Property

Grid Solutions Framework ArchiveDataBlockCapacity Property
Gets the maximum number of ArchiveDataPoints that can be stored in the ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Capacity { get; }
Public ReadOnly Property Capacity As Integer
    Get
member Capacity : int with get

function get_Capacity();

public:
property int Capacity {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.Index Property

Grid Solutions Framework ArchiveDataBlockIndex Property
Gets the 0-based index of the ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
member Index : int with get

function get_Index();

public:
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.IsActive Property

Grid Solutions Framework ArchiveDataBlockIsActive Property
Gets a boolean value that indicates whether the ArchiveDataBlock is being actively used.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsActive { get; }
Public ReadOnly Property IsActive As Boolean
    Get
member IsActive : bool with get

function get_IsActive();

public:
property bool IsActive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.Location Property

Grid Solutions Framework ArchiveDataBlockLocation Property
Gets the start location (byte position) of the ArchiveDataBlock in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Location { get; }
Public ReadOnly Property Location As Long
    Get
member Location : int64 with get

function get_Location();

public:
property long long Location {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.SlotsAvailable Property

Grid Solutions Framework ArchiveDataBlockSlotsAvailable Property
Gets the number of ArchiveDataPoints that can to written to the ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SlotsAvailable { get; }
Public ReadOnly Property SlotsAvailable As Integer
    Get
member SlotsAvailable : int with get

function get_SlotsAvailable();

public:
property int SlotsAvailable {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.SlotsUsed Property

Grid Solutions Framework ArchiveDataBlockSlotsUsed Property
Gets the number of ArchiveDataPoints that have been written to the ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SlotsUsed { get; }
Public ReadOnly Property SlotsUsed As Integer
    Get
member SlotsUsed : int with get

function get_SlotsUsed();

public:
property int SlotsUsed {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock Events

Grid Solutions Framework ArchiveDataBlock Events

The ArchiveDataBlock type exposes the following members.

Events
 | Name | Description
Public event | DataReadException | Occurs when an Exception is encountered while reading IDataPoint from the ArchiveDataBlock.
Top
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlock.DataReadException Event

Grid Solutions Framework ArchiveDataBlockDataReadException Event
Occurs when an Exception is encountered while reading IDataPoint from the ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> DataReadException
Public Event DataReadException As EventHandler(Of EventArgs(Of Exception))
member DataReadException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_DataReadException(value);
function remove_DataReadException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ DataReadException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveDataBlock Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer Class

Grid Solutions Framework ArchiveDataBlockPointer Class
Represents a pointer to an ArchiveDataBlock.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveDataBlockPointer

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ArchiveDataBlockPointer : IComparable,
    ISupportBinaryImage
Public Class ArchiveDataBlockPointer
    Implements IComparable, ISupportBinaryImage
type ArchiveDataBlockPointer =
    class
        interface IComparable
        interface ISupportBinaryImage
    end
GSF.Historian.Files.ArchiveDataBlockPointer = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveDataBlockPointer',
    null,
    IComparable,
    GSF.Parsing.ISupportBinaryImage);
public ref class ArchiveDataBlockPointer : IComparable,
    ISupportBinaryImage

The ArchiveDataBlockPointer type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataBlockPointer object to obj.
Public method | Equals | Determines whether the current ArchiveDataBlockPointer object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the ArchiveDataBlockPointer and copies it into the given buffer, for BinaryLength bytes.
Public method | GetDataBlock | Gets the ArchiveDataBlock associated with this ArchiveDataBlockPointer.
Public method | GetHashCode | Returns the hash code for the current ArchiveDataBlock object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes ArchiveDataBlockPointer from the specified buffer.
Public method | Reset | Deallocates the DataBlock to store new ArchiveDataPoints.
Public method | ToString | Returns the text representation of ArchiveDataBlockPointer object. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | Matches | Tests if the dataBlockPointer matches the specified search criteria. (Defined by ArchiveDataBlockPointerExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of ArchiveDataBlockPointer.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the ArchiveDataBlockPointer.
Public property | DataBlock | Gets the ArchiveDataBlock corresponding to the ArchiveDataBlockPointer.
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataBlockPointer.
Public property | Index | Gets the 0-based index of the ArchiveDataBlockPointer.
Public property | IsAllocated | Gets a boolean value that indicates whether the DataBlock has been allocated to contain ArchiveDataPoints.
Public property | StartTime | Gets or sets the TimeTag of first ArchiveDataPoint in the DataBlock.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesArchiveFile
GSF.Historian.FilesArchiveDataBlock


ArchiveDataBlockPointer Fields

Grid Solutions Framework ArchiveDataBlockPointer Fields

The ArchiveDataBlockPointer type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of ArchiveDataBlockPointer.
Top
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.FixedLength Field

Grid Solutions Framework ArchiveDataBlockPointerFixedLength Field
Specifies the number of bytes in the binary image of ArchiveDataBlockPointer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.ArchiveDataBlockPointer.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer Methods

Grid Solutions Framework ArchiveDataBlockPointer Methods

The ArchiveDataBlockPointer type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataBlockPointer object to obj.
Public method | Equals | Determines whether the current ArchiveDataBlockPointer object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the ArchiveDataBlockPointer and copies it into the given buffer, for BinaryLength bytes.
Public method | GetDataBlock | Gets the ArchiveDataBlock associated with this ArchiveDataBlockPointer.
Public method | GetHashCode | Returns the hash code for the current ArchiveDataBlock object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes ArchiveDataBlockPointer from the specified buffer.
Public method | Reset | Deallocates the DataBlock to store new ArchiveDataPoints.
Public method | ToString | Returns the text representation of ArchiveDataBlockPointer object. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | Matches | Tests if the dataBlockPointer matches the specified search criteria. (Defined by ArchiveDataBlockPointerExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.CompareTo Method

Grid Solutions Framework ArchiveDataBlockPointerCompareTo Method
Compares the current ArchiveDataBlockPointer object to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
Object against which the current ArchiveDataBlockPointer object is to be compared.

Return Value

Type: Int32
Negative value if the current ArchiveDataBlockPointer object is less than obj, Zero if the current ArchiveDataBlockPointer object is equal to obj, Positive value if the current ArchiveDataBlockPointer object is greater than obj.

Implements

IComparableCompareTo(Object)
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.Equals Method

Grid Solutions Framework ArchiveDataBlockPointerEquals Method
Determines whether the current ArchiveDataBlockPointer object is equal to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current ArchiveDataBlockPointer object is to be compared for equality.

Return Value

Type: Boolean
true if the current ArchiveDataBlockPointer object is equal to obj; otherwise false.
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.GenerateBinaryImage Method

Grid Solutions Framework ArchiveDataBlockPointerGenerateBinaryImage Method
Generates binary image of the ArchiveDataBlockPointer and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.GetDataBlock Method

Grid Solutions Framework ArchiveDataBlockPointerGetDataBlock Method
Gets the ArchiveDataBlock associated with this ArchiveDataBlockPointer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataBlock GetDataBlock(
    bool preRead
)
Public Function GetDataBlock (
    preRead As Boolean
) As ArchiveDataBlock
member GetDataBlock :
        preRead : bool -> ArchiveDataBlock

function GetDataBlock(preRead);
public:
ArchiveDataBlock^ GetDataBlock(
    bool preRead
)

Parameters

preRead
Type: SystemBoolean
true to pre-read data to locate write cursor.

Return Value

Type: ArchiveDataBlock
The ArchiveDataBlock associated with this ArchiveDataBlockPointer.
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.GetHashCode Method

Grid Solutions Framework ArchiveDataBlockPointerGetHashCode Method
Returns the hash code for the current ArchiveDataBlock object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.ParseBinaryImage Method

Grid Solutions Framework ArchiveDataBlockPointerParseBinaryImage Method
Initializes ArchiveDataBlockPointer from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing ArchiveDataBlockPointer.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing ArchiveDataBlockPointer.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.Reset Method

Grid Solutions Framework ArchiveDataBlockPointerReset Method
Deallocates the DataBlock to store new ArchiveDataPoints.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.ToString Method

Grid Solutions Framework ArchiveDataBlockPointerToString Method
Returns the text representation of ArchiveDataBlockPointer object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String value.
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer Properties

Grid Solutions Framework ArchiveDataBlockPointer Properties

The ArchiveDataBlockPointer type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the ArchiveDataBlockPointer.
Public property | DataBlock | Gets the ArchiveDataBlock corresponding to the ArchiveDataBlockPointer.
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataBlockPointer.
Public property | Index | Gets the 0-based index of the ArchiveDataBlockPointer.
Public property | IsAllocated | Gets a boolean value that indicates whether the DataBlock has been allocated to contain ArchiveDataPoints.
Public property | StartTime | Gets or sets the TimeTag of first ArchiveDataPoint in the DataBlock.
Top
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.BinaryLength Property

Grid Solutions Framework ArchiveDataBlockPointerBinaryLength Property
Gets the length of the ArchiveDataBlockPointer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.DataBlock Property

Grid Solutions Framework ArchiveDataBlockPointerDataBlock Property
Gets the ArchiveDataBlock corresponding to the ArchiveDataBlockPointer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataBlock DataBlock { get; }
Public ReadOnly Property DataBlock As ArchiveDataBlock
    Get
member DataBlock : ArchiveDataBlock with get

function get_DataBlock();

public:
property ArchiveDataBlock^ DataBlock {
    ArchiveDataBlock^ get ();
}

Property Value

Type: ArchiveDataBlock
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.HistorianID Property

Grid Solutions Framework ArchiveDataBlockPointerHistorianID Property
Gets or sets the historian identifier of ArchiveDataBlockPointer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; set; }
Public Property HistorianID As Integer
    Get
    Set
member HistorianID : int with get, set

function get_HistorianID();
function set_HistorianID(value);
public:
property int HistorianID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or -1.
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.Index Property

Grid Solutions Framework ArchiveDataBlockPointerIndex Property
Gets the 0-based index of the ArchiveDataBlockPointer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Index { get; }
Public ReadOnly Property Index As Integer
    Get
member Index : int with get

function get_Index();

public:
property int Index {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.IsAllocated Property

Grid Solutions Framework ArchiveDataBlockPointerIsAllocated Property
Gets a boolean value that indicates whether the DataBlock has been allocated to contain ArchiveDataPoints.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsAllocated { get; }
Public ReadOnly Property IsAllocated As Boolean
    Get
member IsAllocated : bool with get

function get_IsAllocated();

public:
property bool IsAllocated {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointer.StartTime Property

Grid Solutions Framework ArchiveDataBlockPointerStartTime Property
Gets or sets the TimeTag of first ArchiveDataPoint in the DataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag StartTime { get; set; }
Public Property StartTime As TimeTag
    Get
    Set
member StartTime : TimeTag with get, set

function get_StartTime();
function set_StartTime(value);
public:
property TimeTag^ StartTime {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 01/01/1995 and 01/19/2063.
See Also

Reference

ArchiveDataBlockPointer Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointerExtensions Class

Grid Solutions Framework ArchiveDataBlockPointerExtensions Class
Extension methods for the ArchiveDataBlockPointer.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveDataBlockPointerExtensions

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ArchiveDataBlockPointerExtensions
<ExtensionAttribute>
Public NotInheritable Class ArchiveDataBlockPointerExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ArchiveDataBlockPointerExtensions =  class end
GSF.Historian.Files.ArchiveDataBlockPointerExtensions = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveDataBlockPointerExtensions');
[ExtensionAttribute]
public ref class ArchiveDataBlockPointerExtensions abstract sealed

The ArchiveDataBlockPointerExtensions type exposes the following members.

Methods
Name | Description
Matches | Tests if the dataBlockPointer matches the specified search criteria.
Top
See Also

Reference

GSF.Historian.Files Namespace


ArchiveDataBlockPointerExtensions Methods

Grid Solutions Framework ArchiveDataBlockPointerExtensions Methods

The ArchiveDataBlockPointerExtensions type exposes the following members.

Methods
Name | Description
Matches | Tests if the dataBlockPointer matches the specified search criteria.
Top
See Also

Reference

ArchiveDataBlockPointerExtensions Class
GSF.Historian.Files Namespace


ArchiveDataBlockPointerExtensions.Matches Method

Grid Solutions Framework ArchiveDataBlockPointerExtensionsMatches Method
Tests if the dataBlockPointer matches the specified search criteria.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool Matches(
    this ArchiveDataBlockPointer dataBlockPointer,
    int historianID,
    TimeTag startTime,
    TimeTag endTime
)
<ExtensionAttribute>
Public Shared Function Matches (
    dataBlockPointer As ArchiveDataBlockPointer,
    historianID As Integer,
    startTime As TimeTag,
    endTime As TimeTag
) As Boolean
static member Matches :
        dataBlockPointer : ArchiveDataBlockPointer *
        historianID : int *
        startTime : TimeTag *
        endTime : TimeTag -> bool

GSF.Historian.Files.ArchiveDataBlockPointerExtensions.Matches = function(dataBlockPointer, historianID, startTime, endTime);
public:
[ExtensionAttribute]
static bool Matches(
    ArchiveDataBlockPointer^ dataBlockPointer,
    int historianID,
    TimeTag^ startTime,
    TimeTag^ endTime
)

Parameters

dataBlockPointer
Type: GSF.Historian.FilesArchiveDataBlockPointer
ArchiveDataBlockPointer to test.
historianID
Type: SystemInt32
Desired historian ID.
startTime
Type: GSF.HistorianTimeTag
Desired start time.
endTime
Type: GSF.HistorianTimeTag
Desired end time.

Return Value

Type: Boolean
true if the specified dataBlockPointer is for historianID and falls within the startTime and endTime; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ArchiveDataBlockPointer. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ArchiveDataBlockPointerExtensions Class
GSF.Historian.Files Namespace


ArchiveDataPoint Class

Grid Solutions Framework ArchiveDataPoint Class
Represents time-series data stored in ArchiveFile.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveDataPoint
GSF.Historian.FilesStateRecordDataPoint
GSF.Historian.PacketsPacketType101DataPoint

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ArchiveDataPoint : IDataPoint,
    ISupportBinaryImage, IComparable, IFormattable
Public Class ArchiveDataPoint
    Implements IDataPoint, ISupportBinaryImage, IComparable, IFormattable
type ArchiveDataPoint =
    class
        interface IDataPoint
        interface ISupportBinaryImage
        interface IComparable
        interface IFormattable
    end
GSF.Historian.Files.ArchiveDataPoint = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveDataPoint',
    null,
    GSF.Historian.IDataPoint,
    GSF.Parsing.ISupportBinaryImage,
    IComparable,
    IFormattable);
public ref class ArchiveDataPoint : IDataPoint,
    ISupportBinaryImage, IComparable, IFormattable

The ArchiveDataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveDataPoint(Int32) | Initializes a new instance of the ArchiveDataPoint class.
Public method | ArchiveDataPoint(IDataPoint) | Initializes a new instance of the ArchiveDataPoint class.
Public method | ArchiveDataPoint(IMeasurement) | Initializes a new instance of the ArchiveDataPoint class from a IMeasurement value.
Public method | ArchiveDataPoint(IMeasurement, Quality) | Initializes a new instance of the ArchiveDataPoint class from a IMeasurement value.
Public method | ArchiveDataPoint(Int32, TimeTag, Single, Quality) | Initializes a new instance of the ArchiveDataPoint class.
Public method | ArchiveDataPoint(Int32, Byte, Int32, Int32) | Initializes a new instance of the ArchiveDataPoint class.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataPoint object to obj.
Public method | Equals | Determines whether the current ArchiveDataPoint object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the ArchiveDataPoint and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Returns the hash code for the current ArchiveDataPoint object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes ArchiveDataPoint from the specified buffer.
Public method | ToString | Returns the text representation of ArchiveDataPoint object. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns the text representation of ArchiveDataPoint object using the specified provider.
Public method | ToString(String) | Returns the text representation of ArchiveDataPoint object in the specified format.
Public method | ToString(String, IFormatProvider) | Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of ArchiveDataPoint.
MillisecondMask | Specifies the bit-mask for TimeTag milliseconds stored in Flags.
QualityMask | Specifies the bit-mask for Quality stored in Flags.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the ArchiveDataPoint.
Protected property | Flags | Gets or sets the 32-bit word used for storing data of ArchiveDataPoint.
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataPoint.
Public property | IsEmpty | Gets a boolean value that indicates whether ArchiveDataPoint contains any data.
Public property | Metadata | Gets or sets the associated MetadataRecord with this ArchiveDataPoint.
Public property | Quality | Gets or sets the Quality of ArchiveDataPoint.
Public property | Time | Gets or sets the TimeTag of ArchiveDataPoint.
Public property | Value | Gets or sets the floating-point value of ArchiveDataPoint.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesArchiveFile
GSF.Historian.FilesArchiveFileAllocationTable
GSF.Historian.FilesArchiveDataBlock
GSF.Historian.FilesArchiveDataBlockPointer


ArchiveDataPoint Constructor

Grid Solutions Framework ArchiveDataPoint Constructor
Overload List
 | Name | Description
Public method | ArchiveDataPoint(Int32) | Initializes a new instance of the ArchiveDataPoint class.
Public method | ArchiveDataPoint(IDataPoint) | Initializes a new instance of the ArchiveDataPoint class.
Public method | ArchiveDataPoint(IMeasurement) | Initializes a new instance of the ArchiveDataPoint class from a IMeasurement value.
Public method | ArchiveDataPoint(IMeasurement, Quality) | Initializes a new instance of the ArchiveDataPoint class from a IMeasurement value.
Public method | ArchiveDataPoint(Int32, TimeTag, Single, Quality) | Initializes a new instance of the ArchiveDataPoint class.
Public method | ArchiveDataPoint(Int32, Byte, Int32, Int32) | Initializes a new instance of the ArchiveDataPoint class.
Top
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint Constructor (Int32)

Grid Solutions Framework ArchiveDataPoint Constructor (Int32)
Initializes a new instance of the ArchiveDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataPoint(
    int historianID
)
Public Sub New (
    historianID As Integer
)
new :
        historianID : int -> ArchiveDataPoint
GSF.Historian.Files.ArchiveDataPoint = function(historianID);
public:
ArchiveDataPoint(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier of ArchiveDataPoint.
See Also

Reference

ArchiveDataPoint Class
ArchiveDataPoint Overload
GSF.Historian.Files Namespace


ArchiveDataPoint Constructor (IDataPoint)

Grid Solutions Framework ArchiveDataPoint Constructor (IDataPoint)
Initializes a new instance of the ArchiveDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataPoint(
    IDataPoint dataPoint
)
Public Sub New (
    dataPoint As IDataPoint
)
new :
        dataPoint : IDataPoint -> ArchiveDataPoint
GSF.Historian.Files.ArchiveDataPoint = function(dataPoint);
public:
ArchiveDataPoint(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
A time-series data point.
See Also

Reference

ArchiveDataPoint Class
ArchiveDataPoint Overload
GSF.Historian.Files Namespace


ArchiveDataPoint Constructor (IMeasurement)

Grid Solutions Framework ArchiveDataPoint Constructor (IMeasurement)
Initializes a new instance of the ArchiveDataPoint class from a IMeasurement value.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataPoint(
    IMeasurement measurement
)
Public Sub New (
    measurement As IMeasurement
)
new :
        measurement : IMeasurement -> ArchiveDataPoint
GSF.Historian.Files.ArchiveDataPoint = function(measurement);
public:
ArchiveDataPoint(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Object that implements the IMeasurement interface.
See Also

Reference

ArchiveDataPoint Class
ArchiveDataPoint Overload
GSF.Historian.Files Namespace


ArchiveDataPoint Constructor (IMeasurement, Quality)

Grid Solutions Framework ArchiveDataPoint Constructor (IMeasurement, Quality)
Initializes a new instance of the ArchiveDataPoint class from a IMeasurement value.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataPoint(
    IMeasurement measurement,
    Quality quality
)
Public Sub New (
    measurement As IMeasurement,
    quality As Quality
)
new :
        measurement : IMeasurement *
        quality : Quality -> ArchiveDataPoint
GSF.Historian.Files.ArchiveDataPoint = function(measurement, quality);
public:
ArchiveDataPoint(
    IMeasurement^ measurement,
    Quality quality
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Object that implements the IMeasurement interface.
quality
Type: GSF.HistorianQuality
Specific Quality value to apply to new ArchiveDataPoint.
See Also

Reference

ArchiveDataPoint Class
ArchiveDataPoint Overload
GSF.Historian.Files Namespace


ArchiveDataPoint Constructor (Int32, TimeTag, Single, Quality)

Grid Solutions Framework ArchiveDataPoint Constructor (Int32, TimeTag, Single, Quality)
Initializes a new instance of the ArchiveDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataPoint(
    int historianID,
    TimeTag time,
    float value,
    Quality quality
)
Public Sub New (
    historianID As Integer,
    time As TimeTag,
    value As Single,
    quality As Quality
)
new :
        historianID : int *
        time : TimeTag *
        value : float32 *
        quality : Quality -> ArchiveDataPoint
GSF.Historian.Files.ArchiveDataPoint = function(historianID, time, value, quality);
public:
ArchiveDataPoint(
    int historianID,
    TimeTag^ time,
    float value,
    Quality quality
)

Parameters

historianID
Type: SystemInt32
Historian identifier of ArchiveDataPoint.
time
Type: GSF.HistorianTimeTag
TimeTag of ArchiveDataPoint.
value
Type: SystemSingle
Floating-point value of ArchiveDataPoint.
quality
Type: GSF.HistorianQuality
Quality of ArchiveDataPoint.
See Also

Reference

ArchiveDataPoint Class
ArchiveDataPoint Overload
GSF.Historian.Files Namespace


ArchiveDataPoint Constructor (Int32, Byte[], Int32, Int32)

Grid Solutions Framework ArchiveDataPoint Constructor (Int32, Byte, Int32, Int32)
Initializes a new instance of the ArchiveDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataPoint(
    int historianID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    historianID As Integer,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        historianID : int *
        buffer : byte[] *
        startIndex : int *
        length : int -> ArchiveDataPoint
GSF.Historian.Files.ArchiveDataPoint = function(historianID, buffer, startIndex, length);
public:
ArchiveDataPoint(
    int historianID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

historianID
Type: SystemInt32
Historian identifier of ArchiveDataPoint.
buffer
Type: SystemByte
Binary image to be used for initializing ArchiveDataPoint.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

ArchiveDataPoint Class
ArchiveDataPoint Overload
GSF.Historian.Files Namespace


ArchiveDataPoint Fields

Grid Solutions Framework ArchiveDataPoint Fields

The ArchiveDataPoint type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of ArchiveDataPoint.
MillisecondMask | Specifies the bit-mask for TimeTag milliseconds stored in Flags.
QualityMask | Specifies the bit-mask for Quality stored in Flags.
Top
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.FixedLength Field

Grid Solutions Framework ArchiveDataPointFixedLength Field
Specifies the number of bytes in the binary image of ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.ArchiveDataPoint.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.MillisecondMask Field

Grid Solutions Framework ArchiveDataPointMillisecondMask Field
Specifies the bit-mask for TimeTag milliseconds stored in Flags.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected const Bits MillisecondMask
Protected Const MillisecondMask As Bits
static val mutable MillisecondMask: Bits
var GSF.Historian.Files.ArchiveDataPoint.MillisecondMask
protected:
literal Bits MillisecondMask

Field Value

Type: Bits
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.QualityMask Field

Grid Solutions Framework ArchiveDataPointQualityMask Field
Specifies the bit-mask for Quality stored in Flags.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected const Bits QualityMask
Protected Const QualityMask As Bits
static val mutable QualityMask: Bits
var GSF.Historian.Files.ArchiveDataPoint.QualityMask
protected:
literal Bits QualityMask

Field Value

Type: Bits
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint Methods

Grid Solutions Framework ArchiveDataPoint Methods

The ArchiveDataPoint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataPoint object to obj.
Public method | Equals | Determines whether the current ArchiveDataPoint object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the ArchiveDataPoint and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Returns the hash code for the current ArchiveDataPoint object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes ArchiveDataPoint from the specified buffer.
Public method | ToString | Returns the text representation of ArchiveDataPoint object. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns the text representation of ArchiveDataPoint object using the specified provider.
Public method | ToString(String) | Returns the text representation of ArchiveDataPoint object in the specified format.
Public method | ToString(String, IFormatProvider) | Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.CompareTo Method

Grid Solutions Framework ArchiveDataPointCompareTo Method
Compares the current ArchiveDataPoint object to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
Object against which the current ArchiveDataPoint object is to be compared.

Return Value

Type: Int32
Negative value if the current ArchiveDataPoint object is less than obj, Zero if the current ArchiveDataPoint object is equal to obj, Positive value if the current ArchiveDataPoint object is greater than obj.

Implements

IComparableCompareTo(Object)
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.Equals Method

Grid Solutions Framework ArchiveDataPointEquals Method
Determines whether the current ArchiveDataPoint object is equal to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current ArchiveDataPoint object is to be compared for equality.

Return Value

Type: Boolean
true if the current ArchiveDataPoint object is equal to obj; otherwise false.
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.GenerateBinaryImage Method

Grid Solutions Framework ArchiveDataPointGenerateBinaryImage Method
Generates binary image of the ArchiveDataPoint and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.GetHashCode Method

Grid Solutions Framework ArchiveDataPointGetHashCode Method
Returns the hash code for the current ArchiveDataPoint object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.ParseBinaryImage Method

Grid Solutions Framework ArchiveDataPointParseBinaryImage Method
Initializes ArchiveDataPoint from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overridable Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing ArchiveDataPoint.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing ArchiveDataPoint.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.ToString Method

Grid Solutions Framework ArchiveDataPointToString Method
Overload List
 | Name | Description
Public method | ToString | Returns the text representation of ArchiveDataPoint object. (Overrides ObjectToString.)
Public method | ToString(IFormatProvider) | Returns the text representation of ArchiveDataPoint object using the specified provider.
Public method | ToString(String) | Returns the text representation of ArchiveDataPoint object in the specified format.
Public method | ToString(String, IFormatProvider) | Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider.
Top
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.ToString Method

Grid Solutions Framework ArchiveDataPointToString Method
Returns the text representation of ArchiveDataPoint object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String value.
See Also

Reference

ArchiveDataPoint Class
ToString Overload
GSF.Historian.Files Namespace


ArchiveDataPoint.ToString Method (IFormatProvider)

Grid Solutions Framework ArchiveDataPointToString Method (IFormatProvider)
Returns the text representation of ArchiveDataPoint object using the specified provider.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ToString(
    IFormatProvider provider
)
Public Overridable Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
)

Parameters

provider
Type: SystemIFormatProvider
An IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
A String value.
See Also

Reference

ArchiveDataPoint Class
ToString Overload
GSF.Historian.Files Namespace


ArchiveDataPoint.ToString Method (String)

Grid Solutions Framework ArchiveDataPointToString Method (String)
Returns the text representation of ArchiveDataPoint object in the specified format.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ToString(
    string format
)
Public Overridable Function ToString (
    format As String
) As String
abstract ToString :
        format : string -> string
override ToString :
        format : string -> string
function ToString(format);
public:
virtual String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
Format of text output (I for ID, T for Time, V for Value, Q for Quality).

Return Value

Type: String
A String value.
See Also

Reference

ArchiveDataPoint Class
ToString Overload
GSF.Historian.Files Namespace


ArchiveDataPoint.ToString Method (String, IFormatProvider)

Grid Solutions Framework ArchiveDataPointToString Method (String, IFormatProvider)
Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ToString(
    string format,
    IFormatProvider provider
)
Public Overridable Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
)

Parameters

format
Type: SystemString
Format of text output (I for ID, T for Time, V for Value, Q for Quality).
provider
Type: SystemIFormatProvider
An IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
A String value.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

ArchiveDataPoint Class
ToString Overload
GSF.Historian.Files Namespace


ArchiveDataPoint Properties

Grid Solutions Framework ArchiveDataPoint Properties

The ArchiveDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the ArchiveDataPoint.
Protected property | Flags | Gets or sets the 32-bit word used for storing data of ArchiveDataPoint.
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataPoint.
Public property | IsEmpty | Gets a boolean value that indicates whether ArchiveDataPoint contains any data.
Public property | Metadata | Gets or sets the associated MetadataRecord with this ArchiveDataPoint.
Public property | Quality | Gets or sets the Quality of ArchiveDataPoint.
Public property | Time | Gets or sets the TimeTag of ArchiveDataPoint.
Public property | Value | Gets or sets the floating-point value of ArchiveDataPoint.
Top
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.BinaryLength Property

Grid Solutions Framework ArchiveDataPointBinaryLength Property
Gets the length of the ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int BinaryLength { get; }
Public Overridable ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get ();
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.Flags Property

Grid Solutions Framework ArchiveDataPointFlags Property
Gets or sets the 32-bit word used for storing data of ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int Flags { get; set; }
Protected Overridable Property Flags As Integer
    Get
    Set
abstract Flags : int with get, set
override Flags : int with get, set
function get_Flags();
function set_Flags(value);
protected:
virtual property int Flags {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.HistorianID Property

Grid Solutions Framework ArchiveDataPointHistorianID Property
Gets or sets the historian identifier of ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; set; }
Public Property HistorianID As Integer
    Get
    Set
abstract HistorianID : int with get, set
override HistorianID : int with get, set
function get_HistorianID();
function set_HistorianID(value);
public:
virtual property int HistorianID {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IDataPointHistorianID
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or -1.
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.IsEmpty Property

Grid Solutions Framework ArchiveDataPointIsEmpty Property
Gets a boolean value that indicates whether ArchiveDataPoint contains any data.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool IsEmpty { get; }
Public Overridable ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get
override IsEmpty : bool with get
function get_IsEmpty();

public:
virtual property bool IsEmpty {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.Metadata Property

Grid Solutions Framework ArchiveDataPointMetadata Property
Gets or sets the associated MetadataRecord with this ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MetadataRecord Metadata { get; set; }
Public Overridable Property Metadata As MetadataRecord
    Get
    Set
abstract Metadata : MetadataRecord with get, set
override Metadata : MetadataRecord with get, set
function get_Metadata();
function set_Metadata(value);
public:
virtual property MetadataRecord^ Metadata {
    MetadataRecord^ get ();
    void set (MetadataRecord^ value);
}

Property Value

Type: MetadataRecord

Implements

IDataPointMetadata
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.Quality Property

Grid Solutions Framework ArchiveDataPointQuality Property
Gets or sets the Quality of ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Quality Quality { get; set; }
Public Overridable Property Quality As Quality
    Get
    Set
abstract Quality : Quality with get, set
override Quality : Quality with get, set
function get_Quality();
function set_Quality(value);
public:
virtual property Quality Quality {
    Quality get ();
    void set (Quality value);
}

Property Value

Type: Quality

Implements

IDataPointQuality
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.Time Property

Grid Solutions Framework ArchiveDataPointTime Property
Gets or sets the TimeTag of ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual TimeTag Time { get; set; }
Public Overridable Property Time As TimeTag
    Get
    Set
abstract Time : TimeTag with get, set
override Time : TimeTag with get, set
function get_Time();
function set_Time(value);
public:
virtual property TimeTag^ Time {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag

Implements

IDataPointTime
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 01/01/1995 and 01/19/2063.
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveDataPoint.Value Property

Grid Solutions Framework ArchiveDataPointValue Property
Gets or sets the floating-point value of ArchiveDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual float Value { get; set; }
Public Overridable Property Value As Single
    Get
    Set
abstract Value : float32 with get, set
override Value : float32 with get, set
function get_Value();
function set_Value(value);
public:
virtual property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single

Implements

IDataPointValue
See Also

Reference

ArchiveDataPoint Class
GSF.Historian.Files Namespace


ArchiveFile Class

Grid Solutions Framework ArchiveFile Class
Represents a file that contains ArchiveDataPoints.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.Historian.FilesArchiveFile

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ArchiveFile))]
public class ArchiveFile : Component,
    IArchive, ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings
<ToolboxBitmapAttribute(GetType(ArchiveFile))>
Public Class ArchiveFile
    Inherits Component
    Implements IArchive, ISupportLifecycle, IDisposable, ISupportInitialize,
    IProvideStatus, IPersistSettings
[<ToolboxBitmapAttribute(typeof(ArchiveFile))>]
type ArchiveFile =
    class
        inherit Component
        interface IArchive
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.Files.ArchiveFile = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveFile',
    Component,
    GSF.Historian.IArchive,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(ArchiveFile))]
public ref class ArchiveFile : public Component,
    IArchive, ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings

The ArchiveFile type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveFile | Initializes a new instance of the ArchiveFile class.
Public method | ArchiveFile(IContainer) | Initializes a new instance of the ArchiveFile class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ArchiveFile properties are initialized.
Public method | Close | Closes the ArchiveFile if it IsOpen.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ArchiveFile and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ArchiveFile properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ArchiveFile.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ArchiveFile from the config file if the PersistSettings property is set to true.
 | MaximumDataBlocks | Returns the number of ArchiveDataBlocks an ArchiveFile can have.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDataReadException | Raises the DataReadException event.
Protected method | OnDataWriteException | Raises the DataWriteException event.
Protected method | OnFileFull | Raises the FileFull event.
Protected method | OnFutureDataReceived | Raises the FutureDataReceived event.
Protected method | OnHistoricDataReceived | Raises the HistoricDataReceived event.
Protected method | OnHistoricFileListBuildComplete | Raises the HistoricFileListBuildComplete event.
Protected method | OnHistoricFileListBuildException | Raise the HistoricFileListBuildException event.
Protected method | OnHistoricFileListBuildStart | Raises the HistoricFileListBuildStart event.
Protected method | OnHistoricFileListUpdated | Raises the HistoricFileListUpdated event.
Protected method | OnOffloadComplete | Raises the OffloadComplete event.
Protected method | OnOffloadException | Raises the OffloadException event.
Protected method | OnOffloadProgress | Raises the OffloadProgress event.
Protected method | OnOffloadStart | Raises the OffloadStart event.
Protected method | OnOrphanDataReceived | Raises the OrphanDataReceived event.
Protected method | OnOutOfSequenceDataReceived | Raises the OutOfSequenceDataReceived event.
Protected method | OnProcessAlarmNotification | Raises the ProcessAlarmNotification event.
Protected method | OnRolloverComplete | Raises the RolloverComplete event.
Protected method | OnRolloverException | Raises the RolloverException event.
Protected method | OnRolloverPreparationComplete | Raises the RolloverPreparationComplete event.
Protected method | OnRolloverPreparationException | Raises the RolloverPreparationException event.
Protected method | OnRolloverPreparationStart | Raises the RolloverPreparationStart event.
Protected method | OnRolloverStart | Raises the RolloverStart event.
Public method | Open | Opens the ArchiveFile for use.
Public method | ReadData(IEnumerableInt32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.
Public method | ReadData(Int32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.
Public method | ReadData(IEnumerableInt32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadMetaData | Reads MetadataRecord for the specified historianID.
Public method | ReadMetaDataSummary | Reads MetadataRecordSummary for the specified historianID.
Public method | ReadStateData | Reads StateRecord for the specified historianID.
Public method | ReadStateDataSummary | Reads StateRecordSummary for the specified historianID.
Public method | Rollover | Performs rollover of active ArchiveFile to a new ArchiveFile.
Public method | Save | Saves the ArchiveFile.
Public method | SaveSettings | Saves settings for the ArchiveFile to the config file if the PersistSettings property is set to true.
Public method | SynchronizeStateFile | Requests a resynchronization of the state file.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | WaitForReadersRelease | Waits for all readers to relinquish read locks on active file.
Public method | WriteData(IDataPoint) | Writes the specified dataPoint to the ArchiveFile.
Public method | WriteData(IEnumerableIDataPoint) | Writes the specified dataPoints to the ArchiveFile.
Public method | WriteMetaData | Writes metadata for the specified historianID.
Public method | WriteStateData | Writes statedata for the specified historianID.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultArchiveOffloadCount | Specifies the default value for the ArchiveOffloadCount property.
DefaultArchiveOffloadLocation | Specifies the default value for the ArchiveOffloadLocation property.
DefaultArchiveOffloadMaxAge | Specifies the default value for the ArchiveOffloadMaxAge property.
DefaultArchiveOffloadThreshold | Specifies the default value for the ArchiveOffloadThreshold property.
DefaultCacheWrites | Specifies the default value for the CacheWrites property.
DefaultCompressData | Specifies the default value for the CompressData property.
DefaultConserveMemory | Specifies the default value for the ConserveMemory property.
DefaultDataBlockSize | Specifies the default value for the DataBlockSize property.
DefaultDiscardOutOfSequenceData | Specifies the default value for the DiscardOutOfSequenceData property.
DefaultFileAccessMode | Specifies the default value for the FileAccessMode property.
DefaultFileName | Specifies the default value for the FileName property.
DefaultFileSize | Specifies the default value for the FileSize property.
DefaultFileType | Specifies the default value for the FileType property.
DefaultLeadTimeTolerance | Specifies the default value for the LeadTimeTolerance property.
DefaultMaxHistoricArchiveFiles | Specifies the default value for the MaxHistoricArchiveFiles property.
DefaultMonitorNewArchiveFiles | Specifies the default value for the MonitorNewArchiveFiles property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultRolloverPreparationThreshold | Specifies the default value for the RolloverPreparationThreshold property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Public property | ArchiveOffloadCount | Gets or sets the number of historic ArchiveFiles to be offloaded to the ArchiveOffloadLocation.
Public property | ArchiveOffloadLocation | Gets or sets the path to the directory where historic ArchiveFiles are to be offloaded to make space in the primary archive location. Set to *DELETE* to remove historic files instead of moving them to an offload location.
Public property | ArchiveOffloadMaxAge | Gets or sets the maximum number of days before an archive file triggers the offload of historic ArchiveFiles.
Public property | ArchiveOffloadThreshold | Gets or sets the free disk space (in %) of the primary archive location that triggers the offload of historic ArchiveFiles.
Public property | CacheWrites | Gets or sets a boolean value that indicates whether writes to the disk are to be cached for performance efficiency.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CompressData | Gets or set a boolean value that indicates whether incoming ArchiveDataPoints are to be compressed to save space.
Public property | ConserveMemory | Gets or sets a boolean value that indicates whether memory usage is to be kept low for performance efficiency.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentWriteStatistics | Gets the ProcessQueueStatistics for the internal current data write ProcessQueueT.
Public property | DataBlockSize | Gets or sets the size (in KB) of the ArchiveDataBlocks.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DiscardOutOfSequenceData | Gets or sets a boolean value that indicates whether incoming ArchiveDataPoints with out-of-sequence TimeTag are to be discarded.
Public property | Enabled | Gets or sets a boolean value that indicates whether the ArchiveFile is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Fat | Gets the ArchiveFileAllocationTable of the ArchiveFile.
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the ArchiveFile.
Public property | FileData | Gets the underlying FileStream of the ArchiveFile.
Public property | FileName | Gets or sets the name of the ArchiveFile.
Public property | FileSize | Gets or sets the size (in MB) of the ArchiveFile.
Public property | FileType | Gets or sets the ArchiveFileType of the ArchiveFile.
Public property | HistoricWriteStatistics | Gets the ProcessQueueStatistics for the internal historic data write ProcessQueueT.
Public property | IntercomFile | Gets or sets the IntercomFile used by the ArchiveFile.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsOpen | Gets a boolean value that indicates whether the ArchiveFile is currently open.
Public property | LeadTimeTolerance | Gets or sets the number of minutes by which incoming ArchiveDataPoint can be ahead of local system clock and still be considered valid.
Public property | MaxHistoricArchiveFiles | Gets or sets the maximum number of historic ArchiveFiles to be kept at both the primary and offload locations combined.
Public property | MetadataFile | Gets or sets the MetadataFile used by the ArchiveFile.
Public property | MonitorNewArchiveFiles | Gets or sets a boolean value that indicates whether to monitor and load newly encountered archive files.
Public property | Name | Gets the unique identifier of the ArchiveFile.
Public property | OutOfSequenceWriteStatistics | Gets the ProcessQueueStatistics for the internal out-of-sequence data write ProcessQueueT.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ArchiveFile are to be saved to the config file.
Public property | RolloverPreparationThreshold | Gets or sets the ArchiveFile usage (in %) that will trigger the creation of an empty ArchiveFile for rollover.
Protected property | RolloverWaitHandle | Gets wait handle used to synchronize roll-over access.
Public property | SettingsCategory | Gets or sets the category under which the settings of ArchiveFile are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | StateFile | Gets or sets the StateFile used by the ArchiveFile.
Public property | Statistics | Gets the ArchiveFileStatistics object of the ArchiveFile.
Public property | Status | Gets the descriptive status of the ArchiveFile.
Top
Events
 | Name | Description
Public event | DataReadException | Occurs when an Exception is encountered while reading IDataPoint from the current or historic ArchiveFile.
Public event | DataWriteException | Occurs when an Exception is encountered while writing IDataPoint to the current or historic ArchiveFile.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileFull | Occurs when the active ArchiveFile if full.
Public event | FutureDataReceived | Occurs when IDataPoint is received with TimeTag ahead of the local clock by more than the LeadTimeTolerance.
Public event | HistoricDataReceived | Occurs when IDataPoint that belongs to a historic ArchiveFile is received for archival.
Public event | HistoricFileListBuildComplete | Occurs when the process of building historic ArchiveFile list is complete.
Public event | HistoricFileListBuildException | Occurs when an Exception is encountered in historic ArchiveFile list building process.
Public event | HistoricFileListBuildStart | Occurs when the process of building historic ArchiveFile list is started.
Public event | HistoricFileListUpdated | Occurs when the historic ArchiveFile list is updated to reflect addition or deletion of historic ArchiveFiles.
Public event | OffloadComplete | Occurs when the process of offloading historic ArchiveFiles is complete.
Public event | OffloadException | Occurs when an Exception is encountered during the historic ArchiveFile offload process.
Public event | OffloadProgress | Occurs when an historic ArchiveFile is being offloaded.
Public event | OffloadStart | Occurs when the process of offloading historic ArchiveFiles is started.
Public event | OrphanDataReceived | Occurs when IDataPoint is received for which a StateRecord or MetadataRecord does not exist or is marked as disabled.
Public event | OutOfSequenceDataReceived | Occurs when misaligned (by time) IDataPoint is received for archival.
Public event | ProcessAlarmNotification | Occurs when IDataPoint triggers an alarm notification.
Public event | RolloverComplete | Occurs when Rollover to a new ArchiveFile is complete.
Public event | RolloverException | Occurs when an Exception is encountered during the Rollover process.
Public event | RolloverPreparationComplete | Occurs when the process of creating a standby ArchiveFile is complete.
Public event | RolloverPreparationException | Occurs when an Exception is encountered during the standby ArchiveFile creation process.
Public event | RolloverPreparationStart | Occurs when the process of creating a standby ArchiveFile is started.
Public event | RolloverStart | Occurs when Rollover to a new ArchiveFile is started.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesArchiveDataPoint
GSF.Historian.FilesArchiveFileAllocationTable


ArchiveFile Constructor

Grid Solutions Framework ArchiveFile Constructor
Overload List
 | Name | Description
Public method | ArchiveFile | Initializes a new instance of the ArchiveFile class.
Public method | ArchiveFile(IContainer) | Initializes a new instance of the ArchiveFile class.
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile Constructor

Grid Solutions Framework ArchiveFile Constructor
Initializes a new instance of the ArchiveFile class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveFile()
Public Sub New
new : unit -> ArchiveFile
GSF.Historian.Files.ArchiveFile = function();
public:
ArchiveFile()
See Also

Reference

ArchiveFile Class
ArchiveFile Overload
GSF.Historian.Files Namespace


ArchiveFile Constructor (IContainer)

Grid Solutions Framework ArchiveFile Constructor (IContainer)
Initializes a new instance of the ArchiveFile class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveFile(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ArchiveFile
GSF.Historian.Files.ArchiveFile = function(container);
public:
ArchiveFile(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the ArchiveFile.
See Also

Reference

ArchiveFile Class
ArchiveFile Overload
GSF.Historian.Files Namespace


ArchiveFile Fields

Grid Solutions Framework ArchiveFile Fields

The ArchiveFile type exposes the following members.

Fields
Name | Description
DefaultArchiveOffloadCount | Specifies the default value for the ArchiveOffloadCount property.
DefaultArchiveOffloadLocation | Specifies the default value for the ArchiveOffloadLocation property.
DefaultArchiveOffloadMaxAge | Specifies the default value for the ArchiveOffloadMaxAge property.
DefaultArchiveOffloadThreshold | Specifies the default value for the ArchiveOffloadThreshold property.
DefaultCacheWrites | Specifies the default value for the CacheWrites property.
DefaultCompressData | Specifies the default value for the CompressData property.
DefaultConserveMemory | Specifies the default value for the ConserveMemory property.
DefaultDataBlockSize | Specifies the default value for the DataBlockSize property.
DefaultDiscardOutOfSequenceData | Specifies the default value for the DiscardOutOfSequenceData property.
DefaultFileAccessMode | Specifies the default value for the FileAccessMode property.
DefaultFileName | Specifies the default value for the FileName property.
DefaultFileSize | Specifies the default value for the FileSize property.
DefaultFileType | Specifies the default value for the FileType property.
DefaultLeadTimeTolerance | Specifies the default value for the LeadTimeTolerance property.
DefaultMaxHistoricArchiveFiles | Specifies the default value for the MaxHistoricArchiveFiles property.
DefaultMonitorNewArchiveFiles | Specifies the default value for the MonitorNewArchiveFiles property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultRolloverPreparationThreshold | Specifies the default value for the RolloverPreparationThreshold property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultArchiveOffloadCount Field

Grid Solutions Framework ArchiveFileDefaultArchiveOffloadCount Field
Specifies the default value for the ArchiveOffloadCount property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultArchiveOffloadCount
Public Const DefaultArchiveOffloadCount As Integer
static val mutable DefaultArchiveOffloadCount: int
var GSF.Historian.Files.ArchiveFile.DefaultArchiveOffloadCount
public:
literal int DefaultArchiveOffloadCount

Field Value

Type: Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultArchiveOffloadLocation Field

Grid Solutions Framework ArchiveFileDefaultArchiveOffloadLocation Field
Specifies the default value for the ArchiveOffloadLocation property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultArchiveOffloadLocation
Public Const DefaultArchiveOffloadLocation As String
static val mutable DefaultArchiveOffloadLocation: string
var GSF.Historian.Files.ArchiveFile.DefaultArchiveOffloadLocation
public:
literal String^ DefaultArchiveOffloadLocation

Field Value

Type: String
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultArchiveOffloadMaxAge Field

Grid Solutions Framework ArchiveFileDefaultArchiveOffloadMaxAge Field
Specifies the default value for the ArchiveOffloadMaxAge property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultArchiveOffloadMaxAge
Public Const DefaultArchiveOffloadMaxAge As Integer
static val mutable DefaultArchiveOffloadMaxAge: int
var GSF.Historian.Files.ArchiveFile.DefaultArchiveOffloadMaxAge
public:
literal int DefaultArchiveOffloadMaxAge

Field Value

Type: Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultArchiveOffloadThreshold Field

Grid Solutions Framework ArchiveFileDefaultArchiveOffloadThreshold Field
Specifies the default value for the ArchiveOffloadThreshold property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultArchiveOffloadThreshold
Public Const DefaultArchiveOffloadThreshold As Double
static val mutable DefaultArchiveOffloadThreshold: float
var GSF.Historian.Files.ArchiveFile.DefaultArchiveOffloadThreshold
public:
literal double DefaultArchiveOffloadThreshold

Field Value

Type: Double
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultCacheWrites Field

Grid Solutions Framework ArchiveFileDefaultCacheWrites Field
Specifies the default value for the CacheWrites property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultCacheWrites
Public Const DefaultCacheWrites As Boolean
static val mutable DefaultCacheWrites: bool
var GSF.Historian.Files.ArchiveFile.DefaultCacheWrites
public:
literal bool DefaultCacheWrites

Field Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultCompressData Field

Grid Solutions Framework ArchiveFileDefaultCompressData Field
Specifies the default value for the CompressData property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultCompressData
Public Const DefaultCompressData As Boolean
static val mutable DefaultCompressData: bool
var GSF.Historian.Files.ArchiveFile.DefaultCompressData
public:
literal bool DefaultCompressData

Field Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultConserveMemory Field

Grid Solutions Framework ArchiveFileDefaultConserveMemory Field
Specifies the default value for the ConserveMemory property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultConserveMemory
Public Const DefaultConserveMemory As Boolean
static val mutable DefaultConserveMemory: bool
var GSF.Historian.Files.ArchiveFile.DefaultConserveMemory
public:
literal bool DefaultConserveMemory

Field Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultDataBlockSize Field

Grid Solutions Framework ArchiveFileDefaultDataBlockSize Field
Specifies the default value for the DataBlockSize property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultDataBlockSize
Public Const DefaultDataBlockSize As Integer
static val mutable DefaultDataBlockSize: int
var GSF.Historian.Files.ArchiveFile.DefaultDataBlockSize
public:
literal int DefaultDataBlockSize

Field Value

Type: Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultDiscardOutOfSequenceData Field

Grid Solutions Framework ArchiveFileDefaultDiscardOutOfSequenceData Field
Specifies the default value for the DiscardOutOfSequenceData property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultDiscardOutOfSequenceData
Public Const DefaultDiscardOutOfSequenceData As Boolean
static val mutable DefaultDiscardOutOfSequenceData: bool
var GSF.Historian.Files.ArchiveFile.DefaultDiscardOutOfSequenceData
public:
literal bool DefaultDiscardOutOfSequenceData

Field Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultFileAccessMode Field

Grid Solutions Framework ArchiveFileDefaultFileAccessMode Field
Specifies the default value for the FileAccessMode property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const FileAccess DefaultFileAccessMode
Public Const DefaultFileAccessMode As FileAccess
static val mutable DefaultFileAccessMode: FileAccess
var GSF.Historian.Files.ArchiveFile.DefaultFileAccessMode
public:
literal FileAccess DefaultFileAccessMode

Field Value

Type: FileAccess
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultFileName Field

Grid Solutions Framework ArchiveFileDefaultFileName Field
Specifies the default value for the FileName property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultFileName
Public Const DefaultFileName As String
static val mutable DefaultFileName: string
var GSF.Historian.Files.ArchiveFile.DefaultFileName
public:
literal String^ DefaultFileName

Field Value

Type: String
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultFileSize Field

Grid Solutions Framework ArchiveFileDefaultFileSize Field
Specifies the default value for the FileSize property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultFileSize
Public Const DefaultFileSize As Integer
static val mutable DefaultFileSize: int
var GSF.Historian.Files.ArchiveFile.DefaultFileSize
public:
literal int DefaultFileSize

Field Value

Type: Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultFileType Field

Grid Solutions Framework ArchiveFileDefaultFileType Field
Specifies the default value for the FileType property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ArchiveFileType DefaultFileType
Public Const DefaultFileType As ArchiveFileType
static val mutable DefaultFileType: ArchiveFileType
var GSF.Historian.Files.ArchiveFile.DefaultFileType
public:
literal ArchiveFileType DefaultFileType

Field Value

Type: ArchiveFileType
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultLeadTimeTolerance Field

Grid Solutions Framework ArchiveFileDefaultLeadTimeTolerance Field
Specifies the default value for the LeadTimeTolerance property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultLeadTimeTolerance
Public Const DefaultLeadTimeTolerance As Integer
static val mutable DefaultLeadTimeTolerance: int
var GSF.Historian.Files.ArchiveFile.DefaultLeadTimeTolerance
public:
literal int DefaultLeadTimeTolerance

Field Value

Type: Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultMaxHistoricArchiveFiles Field

Grid Solutions Framework ArchiveFileDefaultMaxHistoricArchiveFiles Field
Specifies the default value for the MaxHistoricArchiveFiles property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxHistoricArchiveFiles
Public Const DefaultMaxHistoricArchiveFiles As Integer
static val mutable DefaultMaxHistoricArchiveFiles: int
var GSF.Historian.Files.ArchiveFile.DefaultMaxHistoricArchiveFiles
public:
literal int DefaultMaxHistoricArchiveFiles

Field Value

Type: Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultMonitorNewArchiveFiles Field

Grid Solutions Framework ArchiveFileDefaultMonitorNewArchiveFiles Field
Specifies the default value for the MonitorNewArchiveFiles property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultMonitorNewArchiveFiles
Public Const DefaultMonitorNewArchiveFiles As Boolean
static val mutable DefaultMonitorNewArchiveFiles: bool
var GSF.Historian.Files.ArchiveFile.DefaultMonitorNewArchiveFiles
public:
literal bool DefaultMonitorNewArchiveFiles

Field Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultPersistSettings Field

Grid Solutions Framework ArchiveFileDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.Historian.Files.ArchiveFile.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultRolloverPreparationThreshold Field

Grid Solutions Framework ArchiveFileDefaultRolloverPreparationThreshold Field
Specifies the default value for the RolloverPreparationThreshold property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultRolloverPreparationThreshold
Public Const DefaultRolloverPreparationThreshold As Double
static val mutable DefaultRolloverPreparationThreshold: float
var GSF.Historian.Files.ArchiveFile.DefaultRolloverPreparationThreshold
public:
literal double DefaultRolloverPreparationThreshold

Field Value

Type: Double
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DefaultSettingsCategory Field

Grid Solutions Framework ArchiveFileDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.Historian.Files.ArchiveFile.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile Methods

Grid Solutions Framework ArchiveFile Methods

The ArchiveFile type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ArchiveFile properties are initialized.
Public method | Close | Closes the ArchiveFile if it IsOpen.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ArchiveFile and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ArchiveFile properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ArchiveFile.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ArchiveFile from the config file if the PersistSettings property is set to true.
 | MaximumDataBlocks | Returns the number of ArchiveDataBlocks an ArchiveFile can have.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDataReadException | Raises the DataReadException event.
Protected method | OnDataWriteException | Raises the DataWriteException event.
Protected method | OnFileFull | Raises the FileFull event.
Protected method | OnFutureDataReceived | Raises the FutureDataReceived event.
Protected method | OnHistoricDataReceived | Raises the HistoricDataReceived event.
Protected method | OnHistoricFileListBuildComplete | Raises the HistoricFileListBuildComplete event.
Protected method | OnHistoricFileListBuildException | Raise the HistoricFileListBuildException event.
Protected method | OnHistoricFileListBuildStart | Raises the HistoricFileListBuildStart event.
Protected method | OnHistoricFileListUpdated | Raises the HistoricFileListUpdated event.
Protected method | OnOffloadComplete | Raises the OffloadComplete event.
Protected method | OnOffloadException | Raises the OffloadException event.
Protected method | OnOffloadProgress | Raises the OffloadProgress event.
Protected method | OnOffloadStart | Raises the OffloadStart event.
Protected method | OnOrphanDataReceived | Raises the OrphanDataReceived event.
Protected method | OnOutOfSequenceDataReceived | Raises the OutOfSequenceDataReceived event.
Protected method | OnProcessAlarmNotification | Raises the ProcessAlarmNotification event.
Protected method | OnRolloverComplete | Raises the RolloverComplete event.
Protected method | OnRolloverException | Raises the RolloverException event.
Protected method | OnRolloverPreparationComplete | Raises the RolloverPreparationComplete event.
Protected method | OnRolloverPreparationException | Raises the RolloverPreparationException event.
Protected method | OnRolloverPreparationStart | Raises the RolloverPreparationStart event.
Protected method | OnRolloverStart | Raises the RolloverStart event.
Public method | Open | Opens the ArchiveFile for use.
Public method | ReadData(IEnumerableInt32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.
Public method | ReadData(Int32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.
Public method | ReadData(IEnumerableInt32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadMetaData | Reads MetadataRecord for the specified historianID.
Public method | ReadMetaDataSummary | Reads MetadataRecordSummary for the specified historianID.
Public method | ReadStateData | Reads StateRecord for the specified historianID.
Public method | ReadStateDataSummary | Reads StateRecordSummary for the specified historianID.
Public method | Rollover | Performs rollover of active ArchiveFile to a new ArchiveFile.
Public method | Save | Saves the ArchiveFile.
Public method | SaveSettings | Saves settings for the ArchiveFile to the config file if the PersistSettings property is set to true.
Public method | SynchronizeStateFile | Requests a resynchronization of the state file.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | WaitForReadersRelease | Waits for all readers to relinquish read locks on active file.
Public method | WriteData(IDataPoint) | Writes the specified dataPoint to the ArchiveFile.
Public method | WriteData(IEnumerableIDataPoint) | Writes the specified dataPoints to the ArchiveFile.
Public method | WriteMetaData | Writes metadata for the specified historianID.
Public method | WriteStateData | Writes statedata for the specified historianID.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.BeginInit Method

Grid Solutions Framework ArchiveFileBeginInit Method
Performs necessary operations before the ArchiveFile properties are initialized.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the ArchiveFile is consumed through the designer surface of the IDE.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Close Method

Grid Solutions Framework ArchiveFileClose Method
Closes the ArchiveFile if it IsOpen.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
abstract Close : unit -> unit
override Close : unit -> unit
function Close();
public:
virtual void Close() sealed

Implements

IArchiveClose
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Dispose Method

Grid Solutions Framework ArchiveFileDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ArchiveFile and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Dispose Method (Boolean)

Grid Solutions Framework ArchiveFileDispose Method (Boolean)
Releases the unmanaged resources used by the ArchiveFile and optionally releases the managed resources.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ArchiveFile Class
Dispose Overload
GSF.Historian.Files Namespace


ArchiveFile.EndInit Method

Grid Solutions Framework ArchiveFileEndInit Method
Performs necessary operations after the ArchiveFile properties are initialized.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the ArchiveFile is consumed through the designer surface of the IDE.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Initialize Method

Grid Solutions Framework ArchiveFileInitialize Method
Initializes the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the ArchiveFile is not consumed through the designer surface of the IDE.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.LoadSettings Method

Grid Solutions Framework ArchiveFileLoadSettings Method
Loads saved settings for the ArchiveFile from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.MaximumDataBlocks Method

Grid Solutions Framework ArchiveFileMaximumDataBlocks Method
Returns the number of ArchiveDataBlocks an ArchiveFile can have.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int MaximumDataBlocks(
    double fileSize,
    int blockSize
)
Public Shared Function MaximumDataBlocks (
    fileSize As Double,
    blockSize As Integer
) As Integer
static member MaximumDataBlocks :
        fileSize : float *
        blockSize : int -> int

GSF.Historian.Files.ArchiveFile.MaximumDataBlocks = function(fileSize, blockSize);
public:
static int MaximumDataBlocks(
    double fileSize,
    int blockSize
)

Parameters

fileSize
Type: SystemDouble
Size (in MB) of the ArchiveFile.
blockSize
Type: SystemInt32
Size (in KB) of the ArchiveDataBlocks in the ArchiveFile.

Return Value

Type: Int32
A 32-bit signed integer for the number of ArchiveDataBlocks an ArchiveFile can have.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnDataReadException Method

Grid Solutions Framework ArchiveFileOnDataReadException Method
Raises the DataReadException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataReadException(
    Exception ex
)
Protected Overridable Sub OnDataReadException (
    ex As Exception
)
abstract OnDataReadException :
        ex : Exception -> unit
override OnDataReadException :
        ex : Exception -> unit
function OnDataReadException(ex);
protected:
virtual void OnDataReadException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to DataReadException event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnDataWriteException Method

Grid Solutions Framework ArchiveFileOnDataWriteException Method
Raises the DataWriteException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataWriteException(
    Exception ex
)
Protected Overridable Sub OnDataWriteException (
    ex As Exception
)
abstract OnDataWriteException :
        ex : Exception -> unit
override OnDataWriteException :
        ex : Exception -> unit
function OnDataWriteException(ex);
protected:
virtual void OnDataWriteException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to DataWriteException event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnFileFull Method

Grid Solutions Framework ArchiveFileOnFileFull Method
Raises the FileFull event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnFileFull()
Protected Overridable Sub OnFileFull
abstract OnFileFull : unit -> unit
override OnFileFull : unit -> unit
function OnFileFull();
protected:
virtual void OnFileFull()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnFutureDataReceived Method

Grid Solutions Framework ArchiveFileOnFutureDataReceived Method
Raises the FutureDataReceived event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnFutureDataReceived(
    IDataPoint dataPoint
)
Protected Overridable Sub OnFutureDataReceived (
    dataPoint As IDataPoint
)
abstract OnFutureDataReceived :
        dataPoint : IDataPoint -> unit
override OnFutureDataReceived :
        dataPoint : IDataPoint -> unit
function OnFutureDataReceived(dataPoint);
protected:
virtual void OnFutureDataReceived(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint to send to FutureDataReceived event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnHistoricDataReceived Method

Grid Solutions Framework ArchiveFileOnHistoricDataReceived Method
Raises the HistoricDataReceived event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricDataReceived(
    IDataPoint dataPoint
)
Protected Overridable Sub OnHistoricDataReceived (
    dataPoint As IDataPoint
)
abstract OnHistoricDataReceived :
        dataPoint : IDataPoint -> unit
override OnHistoricDataReceived :
        dataPoint : IDataPoint -> unit
function OnHistoricDataReceived(dataPoint);
protected:
virtual void OnHistoricDataReceived(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint to send to HistoricDataReceived event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnHistoricFileListBuildComplete Method

Grid Solutions Framework ArchiveFileOnHistoricFileListBuildComplete Method
Raises the HistoricFileListBuildComplete event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListBuildComplete()
Protected Overridable Sub OnHistoricFileListBuildComplete
abstract OnHistoricFileListBuildComplete : unit -> unit
override OnHistoricFileListBuildComplete : unit -> unit
function OnHistoricFileListBuildComplete();
protected:
virtual void OnHistoricFileListBuildComplete()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnHistoricFileListBuildException Method

Grid Solutions Framework ArchiveFileOnHistoricFileListBuildException Method
Raise the HistoricFileListBuildException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListBuildException(
    Exception ex
)
Protected Overridable Sub OnHistoricFileListBuildException (
    ex As Exception
)
abstract OnHistoricFileListBuildException :
        ex : Exception -> unit
override OnHistoricFileListBuildException :
        ex : Exception -> unit
function OnHistoricFileListBuildException(ex);
protected:
virtual void OnHistoricFileListBuildException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to HistoricFileListBuildException event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnHistoricFileListBuildStart Method

Grid Solutions Framework ArchiveFileOnHistoricFileListBuildStart Method
Raises the HistoricFileListBuildStart event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListBuildStart()
Protected Overridable Sub OnHistoricFileListBuildStart
abstract OnHistoricFileListBuildStart : unit -> unit
override OnHistoricFileListBuildStart : unit -> unit
function OnHistoricFileListBuildStart();
protected:
virtual void OnHistoricFileListBuildStart()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnHistoricFileListUpdated Method

Grid Solutions Framework ArchiveFileOnHistoricFileListUpdated Method
Raises the HistoricFileListUpdated event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListUpdated()
Protected Overridable Sub OnHistoricFileListUpdated
abstract OnHistoricFileListUpdated : unit -> unit
override OnHistoricFileListUpdated : unit -> unit
function OnHistoricFileListUpdated();
protected:
virtual void OnHistoricFileListUpdated()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnOffloadComplete Method

Grid Solutions Framework ArchiveFileOnOffloadComplete Method
Raises the OffloadComplete event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOffloadComplete()
Protected Overridable Sub OnOffloadComplete
abstract OnOffloadComplete : unit -> unit
override OnOffloadComplete : unit -> unit
function OnOffloadComplete();
protected:
virtual void OnOffloadComplete()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnOffloadException Method

Grid Solutions Framework ArchiveFileOnOffloadException Method
Raises the OffloadException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOffloadException(
    Exception ex
)
Protected Overridable Sub OnOffloadException (
    ex As Exception
)
abstract OnOffloadException :
        ex : Exception -> unit
override OnOffloadException :
        ex : Exception -> unit
function OnOffloadException(ex);
protected:
virtual void OnOffloadException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to OffloadException event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnOffloadProgress Method

Grid Solutions Framework ArchiveFileOnOffloadProgress Method
Raises the OffloadProgress event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOffloadProgress(
    ProcessProgress<int> offloadProgress
)
Protected Overridable Sub OnOffloadProgress (
    offloadProgress As ProcessProgress(Of Integer)
)
abstract OnOffloadProgress :
        offloadProgress : ProcessProgress<int> -> unit
override OnOffloadProgress :
        offloadProgress : ProcessProgress<int> -> unit
function OnOffloadProgress(offloadProgress);
protected:
virtual void OnOffloadProgress(
    ProcessProgress<int>^ offloadProgress
)

Parameters

offloadProgress
Type: GSFProcessProgress Int32
ProcessProgressTUnit to send to OffloadProgress event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnOffloadStart Method

Grid Solutions Framework ArchiveFileOnOffloadStart Method
Raises the OffloadStart event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOffloadStart()
Protected Overridable Sub OnOffloadStart
abstract OnOffloadStart : unit -> unit
override OnOffloadStart : unit -> unit
function OnOffloadStart();
protected:
virtual void OnOffloadStart()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnOrphanDataReceived Method

Grid Solutions Framework ArchiveFileOnOrphanDataReceived Method
Raises the OrphanDataReceived event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOrphanDataReceived(
    IDataPoint dataPoint
)
Protected Overridable Sub OnOrphanDataReceived (
    dataPoint As IDataPoint
)
abstract OnOrphanDataReceived :
        dataPoint : IDataPoint -> unit
override OnOrphanDataReceived :
        dataPoint : IDataPoint -> unit
function OnOrphanDataReceived(dataPoint);
protected:
virtual void OnOrphanDataReceived(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint to send to OrphanDataReceived event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnOutOfSequenceDataReceived Method

Grid Solutions Framework ArchiveFileOnOutOfSequenceDataReceived Method
Raises the OutOfSequenceDataReceived event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOutOfSequenceDataReceived(
    IDataPoint dataPoint
)
Protected Overridable Sub OnOutOfSequenceDataReceived (
    dataPoint As IDataPoint
)
abstract OnOutOfSequenceDataReceived :
        dataPoint : IDataPoint -> unit
override OnOutOfSequenceDataReceived :
        dataPoint : IDataPoint -> unit
function OnOutOfSequenceDataReceived(dataPoint);
protected:
virtual void OnOutOfSequenceDataReceived(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint to send to OutOfSequenceDataReceived event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnProcessAlarmNotification Method

Grid Solutions Framework ArchiveFileOnProcessAlarmNotification Method
Raises the ProcessAlarmNotification event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessAlarmNotification(
    StateRecord pointState
)
Protected Overridable Sub OnProcessAlarmNotification (
    pointState As StateRecord
)
abstract OnProcessAlarmNotification :
        pointState : StateRecord -> unit
override OnProcessAlarmNotification :
        pointState : StateRecord -> unit
function OnProcessAlarmNotification(pointState);
protected:
virtual void OnProcessAlarmNotification(
    StateRecord^ pointState
)

Parameters

pointState
Type: GSF.Historian.FilesStateRecord
StateRecord to send to ProcessAlarmNotification event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnRolloverComplete Method

Grid Solutions Framework ArchiveFileOnRolloverComplete Method
Raises the RolloverComplete event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverComplete()
Protected Overridable Sub OnRolloverComplete
abstract OnRolloverComplete : unit -> unit
override OnRolloverComplete : unit -> unit
function OnRolloverComplete();
protected:
virtual void OnRolloverComplete()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnRolloverException Method

Grid Solutions Framework ArchiveFileOnRolloverException Method
Raises the RolloverException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverException(
    Exception ex
)
Protected Overridable Sub OnRolloverException (
    ex As Exception
)
abstract OnRolloverException :
        ex : Exception -> unit
override OnRolloverException :
        ex : Exception -> unit
function OnRolloverException(ex);
protected:
virtual void OnRolloverException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to RolloverException event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnRolloverPreparationComplete Method

Grid Solutions Framework ArchiveFileOnRolloverPreparationComplete Method
Raises the RolloverPreparationComplete event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverPreparationComplete()
Protected Overridable Sub OnRolloverPreparationComplete
abstract OnRolloverPreparationComplete : unit -> unit
override OnRolloverPreparationComplete : unit -> unit
function OnRolloverPreparationComplete();
protected:
virtual void OnRolloverPreparationComplete()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnRolloverPreparationException Method

Grid Solutions Framework ArchiveFileOnRolloverPreparationException Method
Raises the RolloverPreparationException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverPreparationException(
    Exception ex
)
Protected Overridable Sub OnRolloverPreparationException (
    ex As Exception
)
abstract OnRolloverPreparationException :
        ex : Exception -> unit
override OnRolloverPreparationException :
        ex : Exception -> unit
function OnRolloverPreparationException(ex);
protected:
virtual void OnRolloverPreparationException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to RolloverPreparationException event.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnRolloverPreparationStart Method

Grid Solutions Framework ArchiveFileOnRolloverPreparationStart Method
Raises the RolloverPreparationStart event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverPreparationStart()
Protected Overridable Sub OnRolloverPreparationStart
abstract OnRolloverPreparationStart : unit -> unit
override OnRolloverPreparationStart : unit -> unit
function OnRolloverPreparationStart();
protected:
virtual void OnRolloverPreparationStart()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OnRolloverStart Method

Grid Solutions Framework ArchiveFileOnRolloverStart Method
Raises the RolloverStart event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverStart()
Protected Overridable Sub OnRolloverStart
abstract OnRolloverStart : unit -> unit
override OnRolloverStart : unit -> unit
function OnRolloverStart();
protected:
virtual void OnRolloverStart()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Open Method

Grid Solutions Framework ArchiveFileOpen Method
Opens the ArchiveFile for use.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open()
Public Sub Open
abstract Open : unit -> unit
override Open : unit -> unit
function Open();
public:
virtual void Open() sealed

Implements

IArchiveOpen
Exceptions
Exception | Condition
InvalidOperationException | One or all of the StateFile, IntercomFile or MetadataFile properties are not set.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method

Grid Solutions Framework ArchiveFileReadData Method
Overload List
 | Name | Description
Public method | ReadData(IEnumerableInt32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.
Public method | ReadData(Int32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.
Public method | ReadData(IEnumerableInt32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (IEnumerable(Int32), Boolean)

Grid Solutions Framework ArchiveFileReadData Method (IEnumerableInt32, Boolean)
Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (Int32, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (Int32, Boolean)
Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (IEnumerable(Int32), TimeTag, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (IEnumerableInt32, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    TimeTag startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    TimeTag^ startTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (IEnumerable(Int32), DateTime, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (IEnumerableInt32, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    DateTime startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    DateTime startTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (IEnumerable(Int32), String, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (IEnumerableInt32, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    string startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    String^ startTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (Int32, TimeTag, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (Int32, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    TimeTag startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    TimeTag^ startTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (Int32, DateTime, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (Int32, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    DateTime startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    DateTime startTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (Int32, String, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (Int32, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    string startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    String^ startTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (IEnumerable(Int32), TimeTag, TimeTag, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (IEnumerableInt32, TimeTag, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    TimeTag startTime,
    TimeTag endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As TimeTag,
    endTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : TimeTag *
        endTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    TimeTag^ startTime,
    TimeTag^ endTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: GSF.HistorianTimeTag
End TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (IEnumerable(Int32), DateTime, DateTime, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (IEnumerableInt32, DateTime, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As DateTime,
    endTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : DateTime *
        endTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemDateTime
End DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (IEnumerable(Int32), String, String, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (IEnumerableInt32, String, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    string startTime,
    string endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As String,
    endTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
abstract ReadData :
        historianIDs : IEnumerable<int> *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>
override ReadData :
        historianIDs : IEnumerable<int> *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>
function ReadData(historianIDs, startTime, endTime, timeSorted);
public:
virtual IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    String^ startTime,
    String^ endTime,
    bool timeSorted = true
) sealed

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemString
String representation of the end time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.

Implements

IArchiveReadData(IEnumerableInt32, String, String, Boolean)
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (Int32, TimeTag, TimeTag, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (Int32, TimeTag, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    TimeTag startTime,
    TimeTag endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As TimeTag,
    endTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : TimeTag *
        endTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    TimeTag^ startTime,
    TimeTag^ endTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: GSF.HistorianTimeTag
End TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (Int32, DateTime, DateTime, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (Int32, DateTime, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As DateTime,
    endTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : DateTime *
        endTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemDateTime
End DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadData Method (Int32, String, String, Boolean)

Grid Solutions Framework ArchiveFileReadData Method (Int32, String, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    string startTime,
    string endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As String,
    endTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
abstract ReadData :
        historianID : int *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>
override ReadData :
        historianID : int *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>
function ReadData(historianID, startTime, endTime, timeSorted);
public:
virtual IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    String^ startTime,
    String^ endTime,
    bool timeSorted = true
) sealed

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemString
String representation of the end time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.

Implements

IArchiveReadData(Int32, String, String, Boolean)
See Also

Reference

ArchiveFile Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveFile.ReadMetaData Method

Grid Solutions Framework ArchiveFileReadMetaData Method
Reads MetadataRecord for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ReadMetaData(
    int historianID
)
Public Function ReadMetaData (
    historianID As Integer
) As Byte()
abstract ReadMetaData :
        historianID : int -> byte[]
override ReadMetaData :
        historianID : int -> byte[]
function ReadMetaData(historianID);
public:
virtual array<unsigned char>^ ReadMetaData(
    int historianID
) sealed

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing MetadataRecord of MetadataRecord if found; otherwise null.

Implements

IArchiveReadMetaData(Int32)
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ReadMetaDataSummary Method

Grid Solutions Framework ArchiveFileReadMetaDataSummary Method
Reads MetadataRecordSummary for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ReadMetaDataSummary(
    int historianID
)
Public Function ReadMetaDataSummary (
    historianID As Integer
) As Byte()
abstract ReadMetaDataSummary :
        historianID : int -> byte[]
override ReadMetaDataSummary :
        historianID : int -> byte[]
function ReadMetaDataSummary(historianID);
public:
virtual array<unsigned char>^ ReadMetaDataSummary(
    int historianID
) sealed

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing MetadataRecordSummary of MetadataRecordSummary if found; otherwise null.

Implements

IArchiveReadMetaDataSummary(Int32)
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ReadStateData Method

Grid Solutions Framework ArchiveFileReadStateData Method
Reads StateRecord for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ReadStateData(
    int historianID
)
Public Function ReadStateData (
    historianID As Integer
) As Byte()
abstract ReadStateData :
        historianID : int -> byte[]
override ReadStateData :
        historianID : int -> byte[]
function ReadStateData(historianID);
public:
virtual array<unsigned char>^ ReadStateData(
    int historianID
) sealed

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing StateRecord of StateRecord if found; otherwise null.

Implements

IArchiveReadStateData(Int32)
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ReadStateDataSummary Method

Grid Solutions Framework ArchiveFileReadStateDataSummary Method
Reads StateRecordSummary for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ReadStateDataSummary(
    int historianID
)
Public Function ReadStateDataSummary (
    historianID As Integer
) As Byte()
abstract ReadStateDataSummary :
        historianID : int -> byte[]
override ReadStateDataSummary :
        historianID : int -> byte[]
function ReadStateDataSummary(historianID);
public:
virtual array<unsigned char>^ ReadStateDataSummary(
    int historianID
) sealed

Parameters

historianID
Type: SystemInt32
Historian identifier.

Return Value

Type: Byte
A Byte array containing StateRecordSummary of StateRecordSummary if found; otherwise null.

Implements

IArchiveReadStateDataSummary(Int32)
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Rollover Method

Grid Solutions Framework ArchiveFileRollover Method
Performs rollover of active ArchiveFile to a new ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Rollover()
Public Sub Rollover
member Rollover : unit -> unit

function Rollover();
public:
void Rollover()
Exceptions
Exception | Condition
InvalidOperationException | ArchiveFile is not Active.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Save Method

Grid Solutions Framework ArchiveFileSave Method
Saves the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Save()
Public Sub Save
member Save : unit -> unit

function Save();
public:
void Save()
Exceptions
Exception | Condition
InvalidOperationException | ArchiveFile is not open.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.SaveSettings Method

Grid Solutions Framework ArchiveFileSaveSettings Method
Saves settings for the ArchiveFile to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.SynchronizeStateFile Method

Grid Solutions Framework ArchiveFileSynchronizeStateFile Method
Requests a resynchronization of the state file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SynchronizeStateFile()
Public Sub SynchronizeStateFile
member SynchronizeStateFile : unit -> unit

function SynchronizeStateFile();
public:
void SynchronizeStateFile()
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.WaitForReadersRelease Method

Grid Solutions Framework ArchiveFileWaitForReadersRelease Method
Waits for all readers to relinquish read locks on active file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool WaitForReadersRelease()
Protected Function WaitForReadersRelease As Boolean
member WaitForReadersRelease : unit -> bool

function WaitForReadersRelease();
protected:
bool WaitForReadersRelease()

Return Value

Type: Boolean
True if readers released read locks in timely fashion.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.WriteData Method

Grid Solutions Framework ArchiveFileWriteData Method
Overload List
 | Name | Description
Public method | WriteData(IDataPoint) | Writes the specified dataPoint to the ArchiveFile.
Public method | WriteData(IEnumerableIDataPoint) | Writes the specified dataPoints to the ArchiveFile.
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.WriteData Method (IDataPoint)

Grid Solutions Framework ArchiveFileWriteData Method (IDataPoint)
Writes the specified dataPoint to the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteData(
    IDataPoint dataPoint
)
Public Sub WriteData (
    dataPoint As IDataPoint
)
abstract WriteData :
        dataPoint : IDataPoint -> unit
override WriteData :
        dataPoint : IDataPoint -> unit
function WriteData(dataPoint);
public:
virtual void WriteData(
    IDataPoint^ dataPoint
) sealed

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
IDataPoint to be written.

Implements

IArchiveWriteData(IDataPoint)
See Also

Reference

ArchiveFile Class
WriteData Overload
GSF.Historian.Files Namespace


ArchiveFile.WriteData Method (IEnumerable(IDataPoint))

Grid Solutions Framework ArchiveFileWriteData Method (IEnumerableIDataPoint)
Writes the specified dataPoints to the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteData(
    IEnumerable<IDataPoint> dataPoints
)
Public Sub WriteData (
    dataPoints As IEnumerable(Of IDataPoint)
)
member WriteData :
        dataPoints : IEnumerable<IDataPoint> -> unit

function WriteData(dataPoints);
public:
void WriteData(
    IEnumerable<IDataPoint^>^ dataPoints
)

Parameters

dataPoints
Type: System.Collections.GenericIEnumerable IDataPoint
ArchiveDataPoint points to be written.
See Also

Reference

ArchiveFile Class
WriteData Overload
GSF.Historian.Files Namespace


ArchiveFile.WriteMetaData Method

Grid Solutions Framework ArchiveFileWriteMetaData Method
Writes metadata for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteMetaData(
    int historianID,
    byte[] metadata
)
Public Sub WriteMetaData (
    historianID As Integer,
    metadata As Byte()
)
abstract WriteMetaData :
        historianID : int *
        metadata : byte[] -> unit
override WriteMetaData :
        historianID : int *
        metadata : byte[] -> unit
function WriteMetaData(historianID, metadata);
public:
virtual void WriteMetaData(
    int historianID,
    array<unsigned char>^ metadata
) sealed

Parameters

historianID
Type: SystemInt32
Historian identifier.
metadata
Type: SystemByte
MetadataRecord data.

Implements

IArchiveWriteMetaData(Int32, Byte)
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.WriteStateData Method

Grid Solutions Framework ArchiveFileWriteStateData Method
Writes statedata for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteStateData(
    int historianID,
    byte[] statedata
)
Public Sub WriteStateData (
    historianID As Integer,
    statedata As Byte()
)
abstract WriteStateData :
        historianID : int *
        statedata : byte[] -> unit
override WriteStateData :
        historianID : int *
        statedata : byte[] -> unit
function WriteStateData(historianID, statedata);
public:
virtual void WriteStateData(
    int historianID,
    array<unsigned char>^ statedata
) sealed

Parameters

historianID
Type: SystemInt32
Historian identifier.
statedata
Type: SystemByte
StateRecord data.

Implements

IArchiveWriteStateData(Int32, Byte)
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile Properties

Grid Solutions Framework ArchiveFile Properties

The ArchiveFile type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveOffloadCount | Gets or sets the number of historic ArchiveFiles to be offloaded to the ArchiveOffloadLocation.
Public property | ArchiveOffloadLocation | Gets or sets the path to the directory where historic ArchiveFiles are to be offloaded to make space in the primary archive location. Set to *DELETE* to remove historic files instead of moving them to an offload location.
Public property | ArchiveOffloadMaxAge | Gets or sets the maximum number of days before an archive file triggers the offload of historic ArchiveFiles.
Public property | ArchiveOffloadThreshold | Gets or sets the free disk space (in %) of the primary archive location that triggers the offload of historic ArchiveFiles.
Public property | CacheWrites | Gets or sets a boolean value that indicates whether writes to the disk are to be cached for performance efficiency.
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CompressData | Gets or set a boolean value that indicates whether incoming ArchiveDataPoints are to be compressed to save space.
Public property | ConserveMemory | Gets or sets a boolean value that indicates whether memory usage is to be kept low for performance efficiency.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | CurrentWriteStatistics | Gets the ProcessQueueStatistics for the internal current data write ProcessQueueT.
Public property | DataBlockSize | Gets or sets the size (in KB) of the ArchiveDataBlocks.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DiscardOutOfSequenceData | Gets or sets a boolean value that indicates whether incoming ArchiveDataPoints with out-of-sequence TimeTag are to be discarded.
Public property | Enabled | Gets or sets a boolean value that indicates whether the ArchiveFile is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Fat | Gets the ArchiveFileAllocationTable of the ArchiveFile.
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the ArchiveFile.
Public property | FileData | Gets the underlying FileStream of the ArchiveFile.
Public property | FileName | Gets or sets the name of the ArchiveFile.
Public property | FileSize | Gets or sets the size (in MB) of the ArchiveFile.
Public property | FileType | Gets or sets the ArchiveFileType of the ArchiveFile.
Public property | HistoricWriteStatistics | Gets the ProcessQueueStatistics for the internal historic data write ProcessQueueT.
Public property | IntercomFile | Gets or sets the IntercomFile used by the ArchiveFile.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsOpen | Gets a boolean value that indicates whether the ArchiveFile is currently open.
Public property | LeadTimeTolerance | Gets or sets the number of minutes by which incoming ArchiveDataPoint can be ahead of local system clock and still be considered valid.
Public property | MaxHistoricArchiveFiles | Gets or sets the maximum number of historic ArchiveFiles to be kept at both the primary and offload locations combined.
Public property | MetadataFile | Gets or sets the MetadataFile used by the ArchiveFile.
Public property | MonitorNewArchiveFiles | Gets or sets a boolean value that indicates whether to monitor and load newly encountered archive files.
Public property | Name | Gets the unique identifier of the ArchiveFile.
Public property | OutOfSequenceWriteStatistics | Gets the ProcessQueueStatistics for the internal out-of-sequence data write ProcessQueueT.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ArchiveFile are to be saved to the config file.
Public property | RolloverPreparationThreshold | Gets or sets the ArchiveFile usage (in %) that will trigger the creation of an empty ArchiveFile for rollover.
Protected property | RolloverWaitHandle | Gets wait handle used to synchronize roll-over access.
Public property | SettingsCategory | Gets or sets the category under which the settings of ArchiveFile are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | StateFile | Gets or sets the StateFile used by the ArchiveFile.
Public property | Statistics | Gets the ArchiveFileStatistics object of the ArchiveFile.
Public property | Status | Gets the descriptive status of the ArchiveFile.
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ArchiveOffloadCount Property

Grid Solutions Framework ArchiveFileArchiveOffloadCount Property
Gets or sets the number of historic ArchiveFiles to be offloaded to the ArchiveOffloadLocation.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(5)]
public int ArchiveOffloadCount { get; set; }
<DefaultValueAttribute(5)>
Public Property ArchiveOffloadCount As Integer
    Get
    Set
[<DefaultValueAttribute(5)>]
member ArchiveOffloadCount : int with get, set

function get_ArchiveOffloadCount();
function set_ArchiveOffloadCount(value);
public:
[DefaultValueAttribute(5)]
property int ArchiveOffloadCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ArchiveOffloadLocation Property

Grid Solutions Framework ArchiveFileArchiveOffloadLocation Property
Gets or sets the path to the directory where historic ArchiveFiles are to be offloaded to make space in the primary archive location. Set to *DELETE* to remove historic files instead of moving them to an offload location.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("")]
public string ArchiveOffloadLocation { get; set; }
<DefaultValueAttribute("")>
Public Property ArchiveOffloadLocation As String
    Get
    Set
[<DefaultValueAttribute("")>]
member ArchiveOffloadLocation : string with get, set

function get_ArchiveOffloadLocation();
function set_ArchiveOffloadLocation(value);
public:
[DefaultValueAttribute(L"")]
property String^ ArchiveOffloadLocation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ArchiveOffloadMaxAge Property

Grid Solutions Framework ArchiveFileArchiveOffloadMaxAge Property
Gets or sets the maximum number of days before an archive file triggers the offload of historic ArchiveFiles.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(-1)]
public int ArchiveOffloadMaxAge { get; set; }
<DefaultValueAttribute(-1)>
Public Property ArchiveOffloadMaxAge As Integer
    Get
    Set
[<DefaultValueAttribute(-1)>]
member ArchiveOffloadMaxAge : int with get, set

function get_ArchiveOffloadMaxAge();
function set_ArchiveOffloadMaxAge(value);
public:
[DefaultValueAttribute(-1)]
property int ArchiveOffloadMaxAge {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ArchiveOffloadThreshold Property

Grid Solutions Framework ArchiveFileArchiveOffloadThreshold Property
Gets or sets the free disk space (in %) of the primary archive location that triggers the offload of historic ArchiveFiles.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(90)]
public double ArchiveOffloadThreshold { get; set; }
<DefaultValueAttribute(90)>
Public Property ArchiveOffloadThreshold As Double
    Get
    Set
[<DefaultValueAttribute(90)>]
member ArchiveOffloadThreshold : float with get, set

function get_ArchiveOffloadThreshold();
function set_ArchiveOffloadThreshold(value);
public:
[DefaultValueAttribute(90)]
property double ArchiveOffloadThreshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is not between 0 and 99.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.CacheWrites Property

Grid Solutions Framework ArchiveFileCacheWrites Property
Gets or sets a boolean value that indicates whether writes to the disk are to be cached for performance efficiency.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool CacheWrites { get; set; }
<DefaultValueAttribute(false)>
Public Property CacheWrites As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member CacheWrites : bool with get, set

function get_CacheWrites();
function set_CacheWrites(value);
public:
[DefaultValueAttribute(false)]
property bool CacheWrites {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.CompressData Property

Grid Solutions Framework ArchiveFileCompressData Property
Gets or set a boolean value that indicates whether incoming ArchiveDataPoints are to be compressed to save space.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool CompressData { get; set; }
<DefaultValueAttribute(true)>
Public Property CompressData As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member CompressData : bool with get, set

function get_CompressData();
function set_CompressData(value);
public:
[DefaultValueAttribute(true)]
property bool CompressData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ConserveMemory Property

Grid Solutions Framework ArchiveFileConserveMemory Property
Gets or sets a boolean value that indicates whether memory usage is to be kept low for performance efficiency.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool ConserveMemory { get; set; }
<DefaultValueAttribute(true)>
Public Property ConserveMemory As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member ConserveMemory : bool with get, set

function get_ConserveMemory();
function set_ConserveMemory(value);
public:
[DefaultValueAttribute(true)]
property bool ConserveMemory {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.CurrentWriteStatistics Property

Grid Solutions Framework ArchiveFileCurrentWriteStatistics Property
Gets the ProcessQueueStatistics for the internal current data write ProcessQueueT.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ProcessQueueStatistics CurrentWriteStatistics { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property CurrentWriteStatistics As ProcessQueueStatistics
    Get
[<BrowsableAttribute(false)>]
member CurrentWriteStatistics : ProcessQueueStatistics with get

function get_CurrentWriteStatistics();

public:
[BrowsableAttribute(false)]
property ProcessQueueStatistics CurrentWriteStatistics {
    ProcessQueueStatistics get ();
}

Property Value

Type: ProcessQueueStatistics
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DataBlockSize Property

Grid Solutions Framework ArchiveFileDataBlockSize Property
Gets or sets the size (in KB) of the ArchiveDataBlocks.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(8)]
public int DataBlockSize { get; set; }
<DefaultValueAttribute(8)>
Public Property DataBlockSize As Integer
    Get
    Set
[<DefaultValueAttribute(8)>]
member DataBlockSize : int with get, set

function get_DataBlockSize();
function set_DataBlockSize(value);
public:
[DefaultValueAttribute(8)]
property int DataBlockSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DiscardOutOfSequenceData Property

Grid Solutions Framework ArchiveFileDiscardOutOfSequenceData Property
Gets or sets a boolean value that indicates whether incoming ArchiveDataPoints with out-of-sequence TimeTag are to be discarded.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool DiscardOutOfSequenceData { get; set; }
<DefaultValueAttribute(true)>
Public Property DiscardOutOfSequenceData As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member DiscardOutOfSequenceData : bool with get, set

function get_DiscardOutOfSequenceData();
function set_DiscardOutOfSequenceData(value);
public:
[DefaultValueAttribute(true)]
property bool DiscardOutOfSequenceData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Enabled Property

Grid Solutions Framework ArchiveFileEnabled Property
Gets or sets a boolean value that indicates whether the ArchiveFile is currently enabled.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[BrowsableAttribute(false)]
public bool Enabled { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<BrowsableAttribute(false)>
Public Property Enabled As Boolean
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
abstract Enabled : bool with get, set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<BrowsableAttribute(false)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[BrowsableAttribute(false)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Enabled property is not be set by user-code directly.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Fat Property

Grid Solutions Framework ArchiveFileFat Property
Gets the ArchiveFileAllocationTable of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ArchiveFileAllocationTable Fat { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Fat As ArchiveFileAllocationTable
    Get
[<BrowsableAttribute(false)>]
member Fat : ArchiveFileAllocationTable with get

function get_Fat();

public:
[BrowsableAttribute(false)]
property ArchiveFileAllocationTable^ Fat {
    ArchiveFileAllocationTable^ get ();
}

Property Value

Type: ArchiveFileAllocationTable
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.FileAccessMode Property

Grid Solutions Framework ArchiveFileFileAccessMode Property
Gets or sets the FileAccess value to use when opening the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(FileAccess.ReadWrite)]
public FileAccess FileAccessMode { get; set; }
<DefaultValueAttribute(FileAccess.ReadWrite)>
Public Property FileAccessMode As FileAccess
    Get
    Set
[<DefaultValueAttribute(FileAccess.ReadWrite)>]
member FileAccessMode : FileAccess with get, set

function get_FileAccessMode();
function set_FileAccessMode(value);
public:
[DefaultValueAttribute(FileAccess::ReadWrite)]
property FileAccess FileAccessMode {
    FileAccess get ();
    void set (FileAccess value);
}

Property Value

Type: FileAccess
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.FileData Property

Grid Solutions Framework ArchiveFileFileData Property
Gets the underlying FileStream of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public FileStream FileData { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property FileData As FileStream
    Get
[<BrowsableAttribute(false)>]
member FileData : FileStream with get

function get_FileData();

public:
[BrowsableAttribute(false)]
property FileStream^ FileData {
    FileStream^ get ();
}

Property Value

Type: FileStream
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.FileName Property

Grid Solutions Framework ArchiveFileFileName Property
Gets or sets the name of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("ArchiveFile.d")]
public string FileName { get; set; }
<DefaultValueAttribute("ArchiveFile.d")>
Public Property FileName As String
    Get
    Set
[<DefaultValueAttribute("ArchiveFile.d")>]
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
[DefaultValueAttribute(L"ArchiveFile.d")]
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
ArgumentException | The value being assigned contains an invalid file extension.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.FileSize Property

Grid Solutions Framework ArchiveFileFileSize Property
Gets or sets the size (in MB) of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(1500)]
public double FileSize { get; set; }
<DefaultValueAttribute(1500)>
Public Property FileSize As Double
    Get
    Set
[<DefaultValueAttribute(1500)>]
member FileSize : float with get, set

function get_FileSize();
function set_FileSize(value);
public:
[DefaultValueAttribute(1500)]
property double FileSize {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.FileType Property

Grid Solutions Framework ArchiveFileFileType Property
Gets or sets the ArchiveFileType of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(ArchiveFileType.Active)]
public ArchiveFileType FileType { get; set; }
<DefaultValueAttribute(ArchiveFileType.Active)>
Public Property FileType As ArchiveFileType
    Get
    Set
[<DefaultValueAttribute(ArchiveFileType.Active)>]
member FileType : ArchiveFileType with get, set

function get_FileType();
function set_FileType(value);
public:
[DefaultValueAttribute(ArchiveFileType::Active)]
property ArchiveFileType FileType {
    ArchiveFileType get ();
    void set (ArchiveFileType value);
}

Property Value

Type: ArchiveFileType
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.HistoricWriteStatistics Property

Grid Solutions Framework ArchiveFileHistoricWriteStatistics Property
Gets the ProcessQueueStatistics for the internal historic data write ProcessQueueT.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ProcessQueueStatistics HistoricWriteStatistics { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property HistoricWriteStatistics As ProcessQueueStatistics
    Get
[<BrowsableAttribute(false)>]
member HistoricWriteStatistics : ProcessQueueStatistics with get

function get_HistoricWriteStatistics();

public:
[BrowsableAttribute(false)]
property ProcessQueueStatistics HistoricWriteStatistics {
    ProcessQueueStatistics get ();
}

Property Value

Type: ProcessQueueStatistics
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.IntercomFile Property

Grid Solutions Framework ArchiveFileIntercomFile Property
Gets or sets the IntercomFile used by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntercomFile IntercomFile { get; set; }
Public Property IntercomFile As IntercomFile
    Get
    Set
member IntercomFile : IntercomFile with get, set

function get_IntercomFile();
function set_IntercomFile(value);
public:
property IntercomFile^ IntercomFile {
    IntercomFile^ get ();
    void set (IntercomFile^ value);
}

Property Value

Type: IntercomFile
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.IsDisposed Property

Grid Solutions Framework ArchiveFileIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool IsDisposed { get; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract IsDisposed : bool with get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.IsOpen Property

Grid Solutions Framework ArchiveFileIsOpen Property
Gets a boolean value that indicates whether the ArchiveFile is currently open.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public bool IsOpen { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property IsOpen As Boolean
    Get
[<BrowsableAttribute(false)>]
member IsOpen : bool with get

function get_IsOpen();

public:
[BrowsableAttribute(false)]
property bool IsOpen {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.LeadTimeTolerance Property

Grid Solutions Framework ArchiveFileLeadTimeTolerance Property
Gets or sets the number of minutes by which incoming ArchiveDataPoint can be ahead of local system clock and still be considered valid.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(15)]
public double LeadTimeTolerance { get; set; }
<DefaultValueAttribute(15)>
Public Property LeadTimeTolerance As Double
    Get
    Set
[<DefaultValueAttribute(15)>]
member LeadTimeTolerance : float with get, set

function get_LeadTimeTolerance();
function set_LeadTimeTolerance(value);
public:
[DefaultValueAttribute(15)]
property double LeadTimeTolerance {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not zero or positive.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.MaxHistoricArchiveFiles Property

Grid Solutions Framework ArchiveFileMaxHistoricArchiveFiles Property
Gets or sets the maximum number of historic ArchiveFiles to be kept at both the primary and offload locations combined.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(-1)]
public int MaxHistoricArchiveFiles { get; set; }
<DefaultValueAttribute(-1)>
Public Property MaxHistoricArchiveFiles As Integer
    Get
    Set
[<DefaultValueAttribute(-1)>]
member MaxHistoricArchiveFiles : int with get, set

function get_MaxHistoricArchiveFiles();
function set_MaxHistoricArchiveFiles(value);
public:
[DefaultValueAttribute(-1)]
property int MaxHistoricArchiveFiles {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Set MaxHistoricArchiveFiles to -1 to keep historic ArchiveFiles indefinitely.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.MetadataFile Property

Grid Solutions Framework ArchiveFileMetadataFile Property
Gets or sets the MetadataFile used by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataFile MetadataFile { get; set; }
Public Property MetadataFile As MetadataFile
    Get
    Set
member MetadataFile : MetadataFile with get, set

function get_MetadataFile();
function set_MetadataFile(value);
public:
property MetadataFile^ MetadataFile {
    MetadataFile^ get ();
    void set (MetadataFile^ value);
}

Property Value

Type: MetadataFile
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.MonitorNewArchiveFiles Property

Grid Solutions Framework ArchiveFileMonitorNewArchiveFiles Property
Gets or sets a boolean value that indicates whether to monitor and load newly encountered archive files.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool MonitorNewArchiveFiles { get; set; }
<DefaultValueAttribute(false)>
Public Property MonitorNewArchiveFiles As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member MonitorNewArchiveFiles : bool with get, set

function get_MonitorNewArchiveFiles();
function set_MonitorNewArchiveFiles(value);
public:
[DefaultValueAttribute(false)]
property bool MonitorNewArchiveFiles {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Name Property

Grid Solutions Framework ArchiveFileName Property
Gets the unique identifier of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OutOfSequenceWriteStatistics Property

Grid Solutions Framework ArchiveFileOutOfSequenceWriteStatistics Property
Gets the ProcessQueueStatistics for the internal out-of-sequence data write ProcessQueueT.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ProcessQueueStatistics OutOfSequenceWriteStatistics { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property OutOfSequenceWriteStatistics As ProcessQueueStatistics
    Get
[<BrowsableAttribute(false)>]
member OutOfSequenceWriteStatistics : ProcessQueueStatistics with get

function get_OutOfSequenceWriteStatistics();

public:
[BrowsableAttribute(false)]
property ProcessQueueStatistics OutOfSequenceWriteStatistics {
    ProcessQueueStatistics get ();
}

Property Value

Type: ProcessQueueStatistics
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.PersistSettings Property

Grid Solutions Framework ArchiveFilePersistSettings Property
Gets or sets a boolean value that indicates whether the settings of ArchiveFile are to be saved to the config file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverPreparationThreshold Property

Grid Solutions Framework ArchiveFileRolloverPreparationThreshold Property
Gets or sets the ArchiveFile usage (in %) that will trigger the creation of an empty ArchiveFile for rollover.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(75)]
public double RolloverPreparationThreshold { get; set; }
<DefaultValueAttribute(75)>
Public Property RolloverPreparationThreshold As Double
    Get
    Set
[<DefaultValueAttribute(75)>]
member RolloverPreparationThreshold : float with get, set

function get_RolloverPreparationThreshold();
function set_RolloverPreparationThreshold(value);
public:
[DefaultValueAttribute(75)]
property double RolloverPreparationThreshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 1 and 95.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverWaitHandle Property

Grid Solutions Framework ArchiveFileRolloverWaitHandle Property
Gets wait handle used to synchronize roll-over access.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ManualResetEvent RolloverWaitHandle { get; }
Protected ReadOnly Property RolloverWaitHandle As ManualResetEvent
    Get
member RolloverWaitHandle : ManualResetEvent with get

function get_RolloverWaitHandle();

protected:
property ManualResetEvent^ RolloverWaitHandle {
    ManualResetEvent^ get ();
}

Property Value

Type: ManualResetEvent
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.SettingsCategory Property

Grid Solutions Framework ArchiveFileSettingsCategory Property
Gets or sets the category under which the settings of ArchiveFile are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("ArchiveFile")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("ArchiveFile")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("ArchiveFile")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("ArchiveFile")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"ArchiveFile")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.StateFile Property

Grid Solutions Framework ArchiveFileStateFile Property
Gets or sets the StateFile used by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateFile StateFile { get; set; }
Public Property StateFile As StateFile
    Get
    Set
member StateFile : StateFile with get, set

function get_StateFile();
function set_StateFile(value);
public:
property StateFile^ StateFile {
    StateFile^ get ();
    void set (StateFile^ value);
}

Property Value

Type: StateFile
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Statistics Property

Grid Solutions Framework ArchiveFileStatistics Property
Gets the ArchiveFileStatistics object of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public ArchiveFileStatistics Statistics { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Statistics As ArchiveFileStatistics
    Get
[<BrowsableAttribute(false)>]
member Statistics : ArchiveFileStatistics with get

function get_Statistics();

public:
[BrowsableAttribute(false)]
property ArchiveFileStatistics^ Statistics {
    ArchiveFileStatistics^ get ();
}

Property Value

Type: ArchiveFileStatistics
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.Status Property

Grid Solutions Framework ArchiveFileStatus Property
Gets the descriptive status of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Status { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile Events

Grid Solutions Framework ArchiveFile Events

The ArchiveFile type exposes the following members.

Events
 | Name | Description
Public event | DataReadException | Occurs when an Exception is encountered while reading IDataPoint from the current or historic ArchiveFile.
Public event | DataWriteException | Occurs when an Exception is encountered while writing IDataPoint to the current or historic ArchiveFile.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileFull | Occurs when the active ArchiveFile if full.
Public event | FutureDataReceived | Occurs when IDataPoint is received with TimeTag ahead of the local clock by more than the LeadTimeTolerance.
Public event | HistoricDataReceived | Occurs when IDataPoint that belongs to a historic ArchiveFile is received for archival.
Public event | HistoricFileListBuildComplete | Occurs when the process of building historic ArchiveFile list is complete.
Public event | HistoricFileListBuildException | Occurs when an Exception is encountered in historic ArchiveFile list building process.
Public event | HistoricFileListBuildStart | Occurs when the process of building historic ArchiveFile list is started.
Public event | HistoricFileListUpdated | Occurs when the historic ArchiveFile list is updated to reflect addition or deletion of historic ArchiveFiles.
Public event | OffloadComplete | Occurs when the process of offloading historic ArchiveFiles is complete.
Public event | OffloadException | Occurs when an Exception is encountered during the historic ArchiveFile offload process.
Public event | OffloadProgress | Occurs when an historic ArchiveFile is being offloaded.
Public event | OffloadStart | Occurs when the process of offloading historic ArchiveFiles is started.
Public event | OrphanDataReceived | Occurs when IDataPoint is received for which a StateRecord or MetadataRecord does not exist or is marked as disabled.
Public event | OutOfSequenceDataReceived | Occurs when misaligned (by time) IDataPoint is received for archival.
Public event | ProcessAlarmNotification | Occurs when IDataPoint triggers an alarm notification.
Public event | RolloverComplete | Occurs when Rollover to a new ArchiveFile is complete.
Public event | RolloverException | Occurs when an Exception is encountered during the Rollover process.
Public event | RolloverPreparationComplete | Occurs when the process of creating a standby ArchiveFile is complete.
Public event | RolloverPreparationException | Occurs when an Exception is encountered during the standby ArchiveFile creation process.
Public event | RolloverPreparationStart | Occurs when the process of creating a standby ArchiveFile is started.
Public event | RolloverStart | Occurs when Rollover to a new ArchiveFile is started.
Top
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DataReadException Event

Grid Solutions Framework ArchiveFileDataReadException Event
Occurs when an Exception is encountered while reading IDataPoint from the current or historic ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> DataReadException
Public Event DataReadException As EventHandler(Of EventArgs(Of Exception))
member DataReadException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_DataReadException(value);
function remove_DataReadException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ DataReadException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.DataWriteException Event

Grid Solutions Framework ArchiveFileDataWriteException Event
Occurs when an Exception is encountered while writing IDataPoint to the current or historic ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> DataWriteException
Public Event DataWriteException As EventHandler(Of EventArgs(Of Exception))
member DataWriteException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_DataWriteException(value);
function remove_DataWriteException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ DataWriteException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.FileFull Event

Grid Solutions Framework ArchiveFileFileFull Event
Occurs when the active ArchiveFile if full.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler FileFull
Public Event FileFull As EventHandler
member FileFull : IEvent<EventHandler,
    EventArgs>

function add_FileFull(value);
function remove_FileFull(value);
public:
 event EventHandler^ FileFull {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.FutureDataReceived Event

Grid Solutions Framework ArchiveFileFutureDataReceived Event
Occurs when IDataPoint is received with TimeTag ahead of the local clock by more than the LeadTimeTolerance.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IDataPoint>> FutureDataReceived
Public Event FutureDataReceived As EventHandler(Of EventArgs(Of IDataPoint))
member FutureDataReceived : IEvent<EventHandler<EventArgs<IDataPoint>>,
    EventArgs<IDataPoint>>

function add_FutureDataReceived(value);
function remove_FutureDataReceived(value);
public:
 event EventHandler<EventArgs<IDataPoint^>^>^ FutureDataReceived {
    void add (EventHandler<EventArgs<IDataPoint^>^>^ value);
    void remove (EventHandler<EventArgs<IDataPoint^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IDataPoint
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.HistoricDataReceived Event

Grid Solutions Framework ArchiveFileHistoricDataReceived Event
Occurs when IDataPoint that belongs to a historic ArchiveFile is received for archival.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IDataPoint>> HistoricDataReceived
Public Event HistoricDataReceived As EventHandler(Of EventArgs(Of IDataPoint))
member HistoricDataReceived : IEvent<EventHandler<EventArgs<IDataPoint>>,
    EventArgs<IDataPoint>>

function add_HistoricDataReceived(value);
function remove_HistoricDataReceived(value);
public:
 event EventHandler<EventArgs<IDataPoint^>^>^ HistoricDataReceived {
    void add (EventHandler<EventArgs<IDataPoint^>^>^ value);
    void remove (EventHandler<EventArgs<IDataPoint^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IDataPoint
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.HistoricFileListBuildComplete Event

Grid Solutions Framework ArchiveFileHistoricFileListBuildComplete Event
Occurs when the process of building historic ArchiveFile list is complete.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler HistoricFileListBuildComplete
Public Event HistoricFileListBuildComplete As EventHandler
member HistoricFileListBuildComplete : IEvent<EventHandler,
    EventArgs>

function add_HistoricFileListBuildComplete(value);
function remove_HistoricFileListBuildComplete(value);
public:
 event EventHandler^ HistoricFileListBuildComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.HistoricFileListBuildException Event

Grid Solutions Framework ArchiveFileHistoricFileListBuildException Event
Occurs when an Exception is encountered in historic ArchiveFile list building process.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> HistoricFileListBuildException
Public Event HistoricFileListBuildException As EventHandler(Of EventArgs(Of Exception))
member HistoricFileListBuildException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_HistoricFileListBuildException(value);
function remove_HistoricFileListBuildException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ HistoricFileListBuildException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.HistoricFileListBuildStart Event

Grid Solutions Framework ArchiveFileHistoricFileListBuildStart Event
Occurs when the process of building historic ArchiveFile list is started.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler HistoricFileListBuildStart
Public Event HistoricFileListBuildStart As EventHandler
member HistoricFileListBuildStart : IEvent<EventHandler,
    EventArgs>

function add_HistoricFileListBuildStart(value);
function remove_HistoricFileListBuildStart(value);
public:
 event EventHandler^ HistoricFileListBuildStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.HistoricFileListUpdated Event

Grid Solutions Framework ArchiveFileHistoricFileListUpdated Event
Occurs when the historic ArchiveFile list is updated to reflect addition or deletion of historic ArchiveFiles.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler HistoricFileListUpdated
Public Event HistoricFileListUpdated As EventHandler
member HistoricFileListUpdated : IEvent<EventHandler,
    EventArgs>

function add_HistoricFileListUpdated(value);
function remove_HistoricFileListUpdated(value);
public:
 event EventHandler^ HistoricFileListUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OffloadComplete Event

Grid Solutions Framework ArchiveFileOffloadComplete Event
Occurs when the process of offloading historic ArchiveFiles is complete.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler OffloadComplete
Public Event OffloadComplete As EventHandler
member OffloadComplete : IEvent<EventHandler,
    EventArgs>

function add_OffloadComplete(value);
function remove_OffloadComplete(value);
public:
 event EventHandler^ OffloadComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OffloadException Event

Grid Solutions Framework ArchiveFileOffloadException Event
Occurs when an Exception is encountered during the historic ArchiveFile offload process.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> OffloadException
Public Event OffloadException As EventHandler(Of EventArgs(Of Exception))
member OffloadException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_OffloadException(value);
function remove_OffloadException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ OffloadException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OffloadProgress Event

Grid Solutions Framework ArchiveFileOffloadProgress Event
Occurs when an historic ArchiveFile is being offloaded.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ProcessProgress<int>>> OffloadProgress
Public Event OffloadProgress As EventHandler(Of EventArgs(Of ProcessProgress(Of Integer)))
member OffloadProgress : IEvent<EventHandler<EventArgs<ProcessProgress<int>>>,
    EventArgs<ProcessProgress<int>>>

function add_OffloadProgress(value);
function remove_OffloadProgress(value);
public:
 event EventHandler<EventArgs<ProcessProgress<int>^>^>^ OffloadProgress {
    void add (EventHandler<EventArgs<ProcessProgress<int>^>^>^ value);
    void remove (EventHandler<EventArgs<ProcessProgress<int>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ProcessProgress Int32
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OffloadStart Event

Grid Solutions Framework ArchiveFileOffloadStart Event
Occurs when the process of offloading historic ArchiveFiles is started.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler OffloadStart
Public Event OffloadStart As EventHandler
member OffloadStart : IEvent<EventHandler,
    EventArgs>

function add_OffloadStart(value);
function remove_OffloadStart(value);
public:
 event EventHandler^ OffloadStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OrphanDataReceived Event

Grid Solutions Framework ArchiveFileOrphanDataReceived Event
Occurs when IDataPoint is received for which a StateRecord or MetadataRecord does not exist or is marked as disabled.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IDataPoint>> OrphanDataReceived
Public Event OrphanDataReceived As EventHandler(Of EventArgs(Of IDataPoint))
member OrphanDataReceived : IEvent<EventHandler<EventArgs<IDataPoint>>,
    EventArgs<IDataPoint>>

function add_OrphanDataReceived(value);
function remove_OrphanDataReceived(value);
public:
 event EventHandler<EventArgs<IDataPoint^>^>^ OrphanDataReceived {
    void add (EventHandler<EventArgs<IDataPoint^>^>^ value);
    void remove (EventHandler<EventArgs<IDataPoint^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IDataPoint
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.OutOfSequenceDataReceived Event

Grid Solutions Framework ArchiveFileOutOfSequenceDataReceived Event
Occurs when misaligned (by time) IDataPoint is received for archival.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IDataPoint>> OutOfSequenceDataReceived
Public Event OutOfSequenceDataReceived As EventHandler(Of EventArgs(Of IDataPoint))
member OutOfSequenceDataReceived : IEvent<EventHandler<EventArgs<IDataPoint>>,
    EventArgs<IDataPoint>>

function add_OutOfSequenceDataReceived(value);
function remove_OutOfSequenceDataReceived(value);
public:
 event EventHandler<EventArgs<IDataPoint^>^>^ OutOfSequenceDataReceived {
    void add (EventHandler<EventArgs<IDataPoint^>^>^ value);
    void remove (EventHandler<EventArgs<IDataPoint^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IDataPoint
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.ProcessAlarmNotification Event

Grid Solutions Framework ArchiveFileProcessAlarmNotification Event
Occurs when IDataPoint triggers an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<StateRecord>> ProcessAlarmNotification
Public Event ProcessAlarmNotification As EventHandler(Of EventArgs(Of StateRecord))
member ProcessAlarmNotification : IEvent<EventHandler<EventArgs<StateRecord>>,
    EventArgs<StateRecord>>

function add_ProcessAlarmNotification(value);
function remove_ProcessAlarmNotification(value);
public:
 event EventHandler<EventArgs<StateRecord^>^>^ ProcessAlarmNotification {
    void add (EventHandler<EventArgs<StateRecord^>^>^ value);
    void remove (EventHandler<EventArgs<StateRecord^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs StateRecord
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverComplete Event

Grid Solutions Framework ArchiveFileRolloverComplete Event
Occurs when Rollover to a new ArchiveFile is complete.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler RolloverComplete
Public Event RolloverComplete As EventHandler
member RolloverComplete : IEvent<EventHandler,
    EventArgs>

function add_RolloverComplete(value);
function remove_RolloverComplete(value);
public:
 event EventHandler^ RolloverComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverException Event

Grid Solutions Framework ArchiveFileRolloverException Event
Occurs when an Exception is encountered during the Rollover process.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> RolloverException
Public Event RolloverException As EventHandler(Of EventArgs(Of Exception))
member RolloverException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_RolloverException(value);
function remove_RolloverException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ RolloverException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverPreparationComplete Event

Grid Solutions Framework ArchiveFileRolloverPreparationComplete Event
Occurs when the process of creating a standby ArchiveFile is complete.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler RolloverPreparationComplete
Public Event RolloverPreparationComplete As EventHandler
member RolloverPreparationComplete : IEvent<EventHandler,
    EventArgs>

function add_RolloverPreparationComplete(value);
function remove_RolloverPreparationComplete(value);
public:
 event EventHandler^ RolloverPreparationComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverPreparationException Event

Grid Solutions Framework ArchiveFileRolloverPreparationException Event
Occurs when an Exception is encountered during the standby ArchiveFile creation process.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> RolloverPreparationException
Public Event RolloverPreparationException As EventHandler(Of EventArgs(Of Exception))
member RolloverPreparationException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_RolloverPreparationException(value);
function remove_RolloverPreparationException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ RolloverPreparationException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverPreparationStart Event

Grid Solutions Framework ArchiveFileRolloverPreparationStart Event
Occurs when the process of creating a standby ArchiveFile is started.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler RolloverPreparationStart
Public Event RolloverPreparationStart As EventHandler
member RolloverPreparationStart : IEvent<EventHandler,
    EventArgs>

function add_RolloverPreparationStart(value);
function remove_RolloverPreparationStart(value);
public:
 event EventHandler^ RolloverPreparationStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFile.RolloverStart Event

Grid Solutions Framework ArchiveFileRolloverStart Event
Occurs when Rollover to a new ArchiveFile is started.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler RolloverStart
Public Event RolloverStart As EventHandler
member RolloverStart : IEvent<EventHandler,
    EventArgs>

function add_RolloverStart(value);
function remove_RolloverStart(value);
public:
 event EventHandler^ RolloverStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveFile Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable Class

Grid Solutions Framework ArchiveFileAllocationTable Class
Represents the File Allocation Table of an ArchiveFile.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveFileAllocationTable

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ArchiveFileAllocationTable : ISupportBinaryImage
Public Class ArchiveFileAllocationTable
    Implements ISupportBinaryImage
type ArchiveFileAllocationTable =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.ArchiveFileAllocationTable = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveFileAllocationTable',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class ArchiveFileAllocationTable : ISupportBinaryImage

The ArchiveFileAllocationTable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Extend | Extends the ArchiveFile by one ArchiveDataBlock.
Public method | Extend(Int32) | Extends the ArchiveFile by the specified number of ArchiveDataBlocks.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindDataBlock | Returns the first ArchiveDataBlock in the ArchiveFile for the specified historianID.
Public method | FindDataBlocks(Int32, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID.
Public method | FindDataBlocks(Int32, TimeTag, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoint points later than the specified startTime.
Public method | FindDataBlocks(Int32, TimeTag, TimeTag, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoints between the specified startTime and endTime.
Public method | FindLastDataBlock | Returns the last ArchiveDataBlock in the ArchiveFile for the specified historianID.
Public method | GenerateBinaryImage | Generates binary image of the ArchiveFileAllocationTable and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the ArchiveFileAllocationTable data to the ArchiveFile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the ArchiveFileAllocationTable.
Public property | DataBlockCount | Gets the total number of ArchiveDataBlocks in the ArchiveFile.
Public property | DataBlockPointers | Gets the ArchiveDataBlockPointers to the ArchiveDataBlocks in the ArchiveFile.
Public property | DataBlocksAvailable | Gets the number of unused ArchiveDataBlocks in the ArchiveFile.
Public property | DataBlockSize | Gets the size (in KB) of a single ArchiveDataBlock in the ArchiveFile.
Public property | DataBlocksUsed | Gets the number of used ArchiveDataBlocks in the ArchiveFile.
Public property | DataPointsArchived | Gets or sets the number ArchiveDataPoints archived by the ArchiveFile.
Public property | DataPointsReceived | Gets or sets the number ArchiveDataPoints received by the ArchiveFile for archival.
Public property | FileEndTime | Gets or sets the TimeTag of the newest ArchiveDataBlock in the ArchiveFile.
Public property | FileStartTime | Gets or sets the TimeTag of the oldest ArchiveDataBlock in the ArchiveFile.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesArchiveFile
GSF.Historian.FilesArchiveDataBlock
GSF.Historian.FilesArchiveDataBlockPointer


ArchiveFileAllocationTable Methods

Grid Solutions Framework ArchiveFileAllocationTable Methods

The ArchiveFileAllocationTable type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Extend | Extends the ArchiveFile by one ArchiveDataBlock.
Public method | Extend(Int32) | Extends the ArchiveFile by the specified number of ArchiveDataBlocks.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindDataBlock | Returns the first ArchiveDataBlock in the ArchiveFile for the specified historianID.
Public method | FindDataBlocks(Int32, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID.
Public method | FindDataBlocks(Int32, TimeTag, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoint points later than the specified startTime.
Public method | FindDataBlocks(Int32, TimeTag, TimeTag, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoints between the specified startTime and endTime.
Public method | FindLastDataBlock | Returns the last ArchiveDataBlock in the ArchiveFile for the specified historianID.
Public method | GenerateBinaryImage | Generates binary image of the ArchiveFileAllocationTable and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Saves the ArchiveFileAllocationTable data to the ArchiveFile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.Extend Method

Grid Solutions Framework ArchiveFileAllocationTableExtend Method
Overload List
 | Name | Description
Public method | Extend | Extends the ArchiveFile by one ArchiveDataBlock.
Public method | Extend(Int32) | Extends the ArchiveFile by the specified number of ArchiveDataBlocks.
Top
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.Extend Method

Grid Solutions Framework ArchiveFileAllocationTableExtend Method
Extends the ArchiveFile by one ArchiveDataBlock.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Extend()
Public Sub Extend
member Extend : unit -> unit

function Extend();
public:
void Extend()
See Also

Reference

ArchiveFileAllocationTable Class
Extend Overload
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.Extend Method (Int32)

Grid Solutions Framework ArchiveFileAllocationTableExtend Method (Int32)
Extends the ArchiveFile by the specified number of ArchiveDataBlocks.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Extend(
    int dataBlocksToAdd
)
Public Sub Extend (
    dataBlocksToAdd As Integer
)
member Extend :
        dataBlocksToAdd : int -> unit

function Extend(dataBlocksToAdd);
public:
void Extend(
    int dataBlocksToAdd
)

Parameters

dataBlocksToAdd
Type: SystemInt32
Number of ArchiveDataBlocks to add to the ArchiveFile.
See Also

Reference

ArchiveFileAllocationTable Class
Extend Overload
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FindDataBlock Method

Grid Solutions Framework ArchiveFileAllocationTableFindDataBlock Method
Returns the first ArchiveDataBlock in the ArchiveFile for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataBlock FindDataBlock(
    int historianID,
    bool preRead = true
)
Public Function FindDataBlock (
    historianID As Integer,
    Optional preRead As Boolean = true
) As ArchiveDataBlock
member FindDataBlock :
        historianID : int *
        ?preRead : bool
(* Defaults:
        let _preRead = defaultArg preRead true
*)
-> ArchiveDataBlock

function FindDataBlock(historianID, preRead);
public:
ArchiveDataBlock^ FindDataBlock(
    int historianID,
    bool preRead = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier whose ArchiveDataBlock is to be retrieved.
preRead (Optional)
Type: SystemBoolean
true to pre-read data to locate write cursor.

Return Value

Type: ArchiveDataBlock
ArchiveDataBlock object if a match is found; otherwise null.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FindDataBlocks Method

Grid Solutions Framework ArchiveFileAllocationTableFindDataBlocks Method
Overload List
 | Name | Description
Public method | FindDataBlocks(Int32, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID.
Public method | FindDataBlocks(Int32, TimeTag, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoint points later than the specified startTime.
Public method | FindDataBlocks(Int32, TimeTag, TimeTag, Boolean) | Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoints between the specified startTime and endTime.
Top
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FindDataBlocks Method (Int32, Boolean)

Grid Solutions Framework ArchiveFileAllocationTableFindDataBlocks Method (Int32, Boolean)
Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<ArchiveDataBlock> FindDataBlocks(
    int historianID,
    bool preRead = true
)
Public Function FindDataBlocks (
    historianID As Integer,
    Optional preRead As Boolean = true
) As List(Of ArchiveDataBlock)
member FindDataBlocks :
        historianID : int *
        ?preRead : bool
(* Defaults:
        let _preRead = defaultArg preRead true
*)
-> List<ArchiveDataBlock>

function FindDataBlocks(historianID, preRead);
public:
List<ArchiveDataBlock^>^ FindDataBlocks(
    int historianID,
    bool preRead = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier.
preRead (Optional)
Type: SystemBoolean
true to pre-read data to locate write cursor.

Return Value

Type: List ArchiveDataBlock
A collection of ArchiveDataBlocks.
See Also

Reference

ArchiveFileAllocationTable Class
FindDataBlocks Overload
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FindDataBlocks Method (Int32, TimeTag, Boolean)

Grid Solutions Framework ArchiveFileAllocationTableFindDataBlocks Method (Int32, TimeTag, Boolean)
Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoint points later than the specified startTime.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<ArchiveDataBlock> FindDataBlocks(
    int historianID,
    TimeTag startTime,
    bool preRead = true
)
Public Function FindDataBlocks (
    historianID As Integer,
    startTime As TimeTag,
    Optional preRead As Boolean = true
) As List(Of ArchiveDataBlock)
member FindDataBlocks :
        historianID : int *
        startTime : TimeTag *
        ?preRead : bool
(* Defaults:
        let _preRead = defaultArg preRead true
*)
-> List<ArchiveDataBlock>

function FindDataBlocks(historianID, startTime, preRead);
public:
List<ArchiveDataBlock^>^ FindDataBlocks(
    int historianID,
    TimeTag^ startTime,
    bool preRead = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag.
preRead (Optional)
Type: SystemBoolean
true to pre-read data to locate write cursor.

Return Value

Type: List ArchiveDataBlock
A collection of ArchiveDataBlocks.
See Also

Reference

ArchiveFileAllocationTable Class
FindDataBlocks Overload
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FindDataBlocks Method (Int32, TimeTag, TimeTag, Boolean)

Grid Solutions Framework ArchiveFileAllocationTableFindDataBlocks Method (Int32, TimeTag, TimeTag, Boolean)
Returns all ArchiveDataBlocks in the ArchiveFile for the specified historianID with ArchiveDataPoints between the specified startTime and endTime.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<ArchiveDataBlock> FindDataBlocks(
    int historianID,
    TimeTag startTime,
    TimeTag endTime,
    bool preRead = true
)
Public Function FindDataBlocks (
    historianID As Integer,
    startTime As TimeTag,
    endTime As TimeTag,
    Optional preRead As Boolean = true
) As List(Of ArchiveDataBlock)
member FindDataBlocks :
        historianID : int *
        startTime : TimeTag *
        endTime : TimeTag *
        ?preRead : bool
(* Defaults:
        let _preRead = defaultArg preRead true
*)
-> List<ArchiveDataBlock>

function FindDataBlocks(historianID, startTime, endTime, preRead);
public:
List<ArchiveDataBlock^>^ FindDataBlocks(
    int historianID,
    TimeTag^ startTime,
    TimeTag^ endTime,
    bool preRead = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag.
endTime
Type: GSF.HistorianTimeTag
End TimeTag.
preRead (Optional)
Type: SystemBoolean
true to pre-read data to locate write cursor.

Return Value

Type: List ArchiveDataBlock
A collection of ArchiveDataBlocks.
See Also

Reference

ArchiveFileAllocationTable Class
FindDataBlocks Overload
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FindLastDataBlock Method

Grid Solutions Framework ArchiveFileAllocationTableFindLastDataBlock Method
Returns the last ArchiveDataBlock in the ArchiveFile for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveDataBlock FindLastDataBlock(
    int historianID,
    bool preRead = true
)
Public Function FindLastDataBlock (
    historianID As Integer,
    Optional preRead As Boolean = true
) As ArchiveDataBlock
member FindLastDataBlock :
        historianID : int *
        ?preRead : bool
(* Defaults:
        let _preRead = defaultArg preRead true
*)
-> ArchiveDataBlock

function FindLastDataBlock(historianID, preRead);
public:
ArchiveDataBlock^ FindLastDataBlock(
    int historianID,
    bool preRead = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier.
preRead (Optional)
Type: SystemBoolean
true to pre-read data to locate write cursor.

Return Value

Type: ArchiveDataBlock
ArchiveDataBlock object if a match is found; otherwise null.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.GenerateBinaryImage Method

Grid Solutions Framework ArchiveFileAllocationTableGenerateBinaryImage Method
Generates binary image of the ArchiveFileAllocationTable and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.Save Method

Grid Solutions Framework ArchiveFileAllocationTableSave Method
Saves the ArchiveFileAllocationTable data to the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Save(
    bool forceFlush = false
)
Public Sub Save (
    Optional forceFlush As Boolean = false
)
member Save :
        ?forceFlush : bool
(* Defaults:
        let _forceFlush = defaultArg forceFlush false
*)
-> unit

function Save(forceFlush);
public:
void Save(
    bool forceFlush = false
)

Parameters

forceFlush (Optional)
Type: SystemBoolean
Forces an immediate disk flush for save.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable Properties

Grid Solutions Framework ArchiveFileAllocationTable Properties

The ArchiveFileAllocationTable type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the ArchiveFileAllocationTable.
Public property | DataBlockCount | Gets the total number of ArchiveDataBlocks in the ArchiveFile.
Public property | DataBlockPointers | Gets the ArchiveDataBlockPointers to the ArchiveDataBlocks in the ArchiveFile.
Public property | DataBlocksAvailable | Gets the number of unused ArchiveDataBlocks in the ArchiveFile.
Public property | DataBlockSize | Gets the size (in KB) of a single ArchiveDataBlock in the ArchiveFile.
Public property | DataBlocksUsed | Gets the number of used ArchiveDataBlocks in the ArchiveFile.
Public property | DataPointsArchived | Gets or sets the number ArchiveDataPoints archived by the ArchiveFile.
Public property | DataPointsReceived | Gets or sets the number ArchiveDataPoints received by the ArchiveFile for archival.
Public property | FileEndTime | Gets or sets the TimeTag of the newest ArchiveDataBlock in the ArchiveFile.
Public property | FileStartTime | Gets or sets the TimeTag of the oldest ArchiveDataBlock in the ArchiveFile.
Top
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.BinaryLength Property

Grid Solutions Framework ArchiveFileAllocationTableBinaryLength Property
Gets the length of the ArchiveFileAllocationTable.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.DataBlockCount Property

Grid Solutions Framework ArchiveFileAllocationTableDataBlockCount Property
Gets the total number of ArchiveDataBlocks in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataBlockCount { get; }
Public ReadOnly Property DataBlockCount As Integer
    Get
member DataBlockCount : int with get

function get_DataBlockCount();

public:
property int DataBlockCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.DataBlockPointers Property

Grid Solutions Framework ArchiveFileAllocationTableDataBlockPointers Property
Gets the ArchiveDataBlockPointers to the ArchiveDataBlocks in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<ArchiveDataBlockPointer> DataBlockPointers { get; }
Public ReadOnly Property DataBlockPointers As IList(Of ArchiveDataBlockPointer)
    Get
member DataBlockPointers : IList<ArchiveDataBlockPointer> with get

function get_DataBlockPointers();

public:
property IList<ArchiveDataBlockPointer^>^ DataBlockPointers {
    IList<ArchiveDataBlockPointer^>^ get ();
}

Property Value

Type: IList ArchiveDataBlockPointer
Remarks
WARNING: DataBlockPointers is not thread safe. Synchronized access is required.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.DataBlocksAvailable Property

Grid Solutions Framework ArchiveFileAllocationTableDataBlocksAvailable Property
Gets the number of unused ArchiveDataBlocks in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataBlocksAvailable { get; }
Public ReadOnly Property DataBlocksAvailable As Integer
    Get
member DataBlocksAvailable : int with get

function get_DataBlocksAvailable();

public:
property int DataBlocksAvailable {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.DataBlockSize Property

Grid Solutions Framework ArchiveFileAllocationTableDataBlockSize Property
Gets the size (in KB) of a single ArchiveDataBlock in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataBlockSize { get; }
Public ReadOnly Property DataBlockSize As Integer
    Get
member DataBlockSize : int with get

function get_DataBlockSize();

public:
property int DataBlockSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.DataBlocksUsed Property

Grid Solutions Framework ArchiveFileAllocationTableDataBlocksUsed Property
Gets the number of used ArchiveDataBlocks in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataBlocksUsed { get; }
Public ReadOnly Property DataBlocksUsed As Integer
    Get
member DataBlocksUsed : int with get

function get_DataBlocksUsed();

public:
property int DataBlocksUsed {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.DataPointsArchived Property

Grid Solutions Framework ArchiveFileAllocationTableDataPointsArchived Property
Gets or sets the number ArchiveDataPoints archived by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataPointsArchived { get; set; }
Public Property DataPointsArchived As Integer
    Get
    Set
member DataPointsArchived : int with get, set

function get_DataPointsArchived();
function set_DataPointsArchived(value);
public:
property int DataPointsArchived {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or zero.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.DataPointsReceived Property

Grid Solutions Framework ArchiveFileAllocationTableDataPointsReceived Property
Gets or sets the number ArchiveDataPoints received by the ArchiveFile for archival.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataPointsReceived { get; set; }
Public Property DataPointsReceived As Integer
    Get
    Set
member DataPointsReceived : int with get, set

function get_DataPointsReceived();
function set_DataPointsReceived(value);
public:
property int DataPointsReceived {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or zero.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FileEndTime Property

Grid Solutions Framework ArchiveFileAllocationTableFileEndTime Property
Gets or sets the TimeTag of the newest ArchiveDataBlock in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag FileEndTime { get; set; }
Public Property FileEndTime As TimeTag
    Get
    Set
member FileEndTime : TimeTag with get, set

function get_FileEndTime();
function set_FileEndTime(value);
public:
property TimeTag^ FileEndTime {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 01/01/1995 and 01/19/2063.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileAllocationTable.FileStartTime Property

Grid Solutions Framework ArchiveFileAllocationTableFileStartTime Property
Gets or sets the TimeTag of the oldest ArchiveDataBlock in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag FileStartTime { get; set; }
Public Property FileStartTime As TimeTag
    Get
    Set
member FileStartTime : TimeTag with get, set

function get_FileStartTime();
function set_FileStartTime(value);
public:
property TimeTag^ FileStartTime {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 01/01/1995 and 01/19/2063.
See Also

Reference

ArchiveFileAllocationTable Class
GSF.Historian.Files Namespace


ArchiveFileScanner Class

Grid Solutions Framework ArchiveFileScanner Class
Scans an archive file for data points in a given time range and returns them in the order that they are scanned.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveFileScanner

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ArchiveFileScanner : IArchiveFileScanner
Public Class ArchiveFileScanner
    Implements IArchiveFileScanner
type ArchiveFileScanner =
    class
        interface IArchiveFileScanner
    end
GSF.Historian.Files.ArchiveFileScanner = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveFileScanner',
    null,
    GSF.Historian.Files.IArchiveFileScanner);
public ref class ArchiveFileScanner : IArchiveFileScanner

The ArchiveFileScanner type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveFileScanner | Initializes a new instance of the ArchiveFileScanner class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads all IDataPoints for the specified historian IDs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | DataReadExceptionHandler | Gets or sets the handler used to handle errors that occur while scanning the file.
Public property | EndTime | Gets or sets the maximum value of the timestamps of the data points returned by the scanner.
Public property | FileAllocationTable | Gets or sets the file allocation table of the file that this scanner is reading from.
Public property | HistorianIDs | Gets or sets the collection of point IDs to be scanned from the file.
Public property | ResumeFrom | Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.
Public property | StartTime | Gets or sets the minimum value of the timestamps of the data points returned by the scanner.
Top
See Also

Reference

GSF.Historian.Files Namespace


ArchiveFileScanner Constructor

Grid Solutions Framework ArchiveFileScanner Constructor
Initializes a new instance of the ArchiveFileScanner class

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveFileScanner()
Public Sub New
new : unit -> ArchiveFileScanner
GSF.Historian.Files.ArchiveFileScanner = function();
public:
ArchiveFileScanner()
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner Methods

Grid Solutions Framework ArchiveFileScanner Methods

The ArchiveFileScanner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads all IDataPoints for the specified historian IDs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner.Read Method

Grid Solutions Framework ArchiveFileScannerRead Method
Reads all IDataPoints for the specified historian IDs.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> Read()
Public Function Read As IEnumerable(Of IDataPoint)
abstract Read : unit -> IEnumerable<IDataPoint>
override Read : unit -> IEnumerable<IDataPoint>
function Read();
public:
virtual IEnumerable<IDataPoint^>^ Read() sealed

Return Value

Type: IEnumerable IDataPoint
Each IDataPoint for the specified historian IDs.

Implements

IArchiveFileScannerRead
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner Properties

Grid Solutions Framework ArchiveFileScanner Properties

The ArchiveFileScanner type exposes the following members.

Properties
 | Name | Description
Public property | DataReadExceptionHandler | Gets or sets the handler used to handle errors that occur while scanning the file.
Public property | EndTime | Gets or sets the maximum value of the timestamps of the data points returned by the scanner.
Public property | FileAllocationTable | Gets or sets the file allocation table of the file that this scanner is reading from.
Public property | HistorianIDs | Gets or sets the collection of point IDs to be scanned from the file.
Public property | ResumeFrom | Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.
Public property | StartTime | Gets or sets the minimum value of the timestamps of the data points returned by the scanner.
Top
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner.DataReadExceptionHandler Property

Grid Solutions Framework ArchiveFileScannerDataReadExceptionHandler Property
Gets or sets the handler used to handle errors that occur while scanning the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventHandler<EventArgs<Exception>> DataReadExceptionHandler { get; set; }
Public Property DataReadExceptionHandler As EventHandler(Of EventArgs(Of Exception))
    Get
    Set
abstract DataReadExceptionHandler : EventHandler<EventArgs<Exception>> with get, set
override DataReadExceptionHandler : EventHandler<EventArgs<Exception>> with get, set
function get_DataReadExceptionHandler();
function set_DataReadExceptionHandler(value);
public:
virtual property EventHandler<EventArgs<Exception^>^>^ DataReadExceptionHandler {
    EventHandler<EventArgs<Exception^>^>^ get () sealed;
    void set (EventHandler<EventArgs<Exception^>^>^ value) sealed;
}

Property Value

Type: EventHandler EventArgs Exception

Implements

IArchiveFileScannerDataReadExceptionHandler
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner.EndTime Property

Grid Solutions Framework ArchiveFileScannerEndTime Property
Gets or sets the maximum value of the timestamps of the data points returned by the scanner.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag EndTime { get; set; }
Public Property EndTime As TimeTag
    Get
    Set
abstract EndTime : TimeTag with get, set
override EndTime : TimeTag with get, set
function get_EndTime();
function set_EndTime(value);
public:
virtual property TimeTag^ EndTime {
    TimeTag^ get () sealed;
    void set (TimeTag^ value) sealed;
}

Property Value

Type: TimeTag

Implements

IArchiveFileScannerEndTime
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner.FileAllocationTable Property

Grid Solutions Framework ArchiveFileScannerFileAllocationTable Property
Gets or sets the file allocation table of the file that this scanner is reading from.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveFileAllocationTable FileAllocationTable { get; set; }
Public Property FileAllocationTable As ArchiveFileAllocationTable
    Get
    Set
abstract FileAllocationTable : ArchiveFileAllocationTable with get, set
override FileAllocationTable : ArchiveFileAllocationTable with get, set
function get_FileAllocationTable();
function set_FileAllocationTable(value);
public:
virtual property ArchiveFileAllocationTable^ FileAllocationTable {
    ArchiveFileAllocationTable^ get () sealed;
    void set (ArchiveFileAllocationTable^ value) sealed;
}

Property Value

Type: ArchiveFileAllocationTable

Implements

IArchiveFileScannerFileAllocationTable
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner.HistorianIDs Property

Grid Solutions Framework ArchiveFileScannerHistorianIDs Property
Gets or sets the collection of point IDs to be scanned from the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<int> HistorianIDs { get; set; }
Public Property HistorianIDs As IEnumerable(Of Integer)
    Get
    Set
abstract HistorianIDs : IEnumerable<int> with get, set
override HistorianIDs : IEnumerable<int> with get, set
function get_HistorianIDs();
function set_HistorianIDs(value);
public:
virtual property IEnumerable<int>^ HistorianIDs {
    IEnumerable<int>^ get () sealed;
    void set (IEnumerable<int>^ value) sealed;
}

Property Value

Type: IEnumerable Int32

Implements

IArchiveFileScannerHistorianIDs
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner.ResumeFrom Property

Grid Solutions Framework ArchiveFileScannerResumeFrom Property
Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDataPoint ResumeFrom { get; set; }
Public Property ResumeFrom As IDataPoint
    Get
    Set
abstract ResumeFrom : IDataPoint with get, set
override ResumeFrom : IDataPoint with get, set
function get_ResumeFrom();
function set_ResumeFrom(value);
public:
virtual property IDataPoint^ ResumeFrom {
    IDataPoint^ get () sealed;
    void set (IDataPoint^ value) sealed;
}

Property Value

Type: IDataPoint

Implements

IArchiveFileScannerResumeFrom
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileScanner.StartTime Property

Grid Solutions Framework ArchiveFileScannerStartTime Property
Gets or sets the minimum value of the timestamps of the data points returned by the scanner.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag StartTime { get; set; }
Public Property StartTime As TimeTag
    Get
    Set
abstract StartTime : TimeTag with get, set
override StartTime : TimeTag with get, set
function get_StartTime();
function set_StartTime(value);
public:
virtual property TimeTag^ StartTime {
    TimeTag^ get () sealed;
    void set (TimeTag^ value) sealed;
}

Property Value

Type: TimeTag

Implements

IArchiveFileScannerStartTime
See Also

Reference

ArchiveFileScanner Class
GSF.Historian.Files Namespace


ArchiveFileStatistics Class

Grid Solutions Framework ArchiveFileStatistics Class
A class that contains the statistics of an ArchiveFile.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveFileStatistics

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ArchiveFileStatistics
Public Class ArchiveFileStatistics
type ArchiveFileStatistics =  class end
GSF.Historian.Files.ArchiveFileStatistics = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveFileStatistics');
public ref class ArchiveFileStatistics

The ArchiveFileStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | AverageWriteSpeed | Average number of time-series data points written to the ArchiveFile in one second.
Public field | AveragingWindow | Time over which the AverageWriteSpeed is calculated.
Public field | CompressionRate | Current rate of data compression (in %) in the ArchiveFile.
Public field | FileUsage | Current usage (in %) of the ArchiveFile.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesArchiveFile


ArchiveFileStatistics Fields

Grid Solutions Framework ArchiveFileStatistics Fields

The ArchiveFileStatistics type exposes the following members.

Fields
 | Name | Description
Public field | AverageWriteSpeed | Average number of time-series data points written to the ArchiveFile in one second.
Public field | AveragingWindow | Time over which the AverageWriteSpeed is calculated.
Public field | CompressionRate | Current rate of data compression (in %) in the ArchiveFile.
Public field | FileUsage | Current usage (in %) of the ArchiveFile.
Top
See Also

Reference

ArchiveFileStatistics Class
GSF.Historian.Files Namespace


ArchiveFileStatistics.AverageWriteSpeed Field

Grid Solutions Framework ArchiveFileStatisticsAverageWriteSpeed Field
Average number of time-series data points written to the ArchiveFile in one second.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int AverageWriteSpeed
Public AverageWriteSpeed As Integer
val mutable AverageWriteSpeed: int
var AverageWriteSpeed
public:
int AverageWriteSpeed

Field Value

Type: Int32
See Also

Reference

ArchiveFileStatistics Class
GSF.Historian.Files Namespace


ArchiveFileStatistics.AveragingWindow Field

Grid Solutions Framework ArchiveFileStatisticsAveragingWindow Field
Time over which the AverageWriteSpeed is calculated.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time AveragingWindow
Public AveragingWindow As Time
val mutable AveragingWindow: Time
var AveragingWindow
public:
Time AveragingWindow

Field Value

Type: Time
See Also

Reference

ArchiveFileStatistics Class
GSF.Historian.Files Namespace


ArchiveFileStatistics.CompressionRate Field

Grid Solutions Framework ArchiveFileStatisticsCompressionRate Field
Current rate of data compression (in %) in the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float CompressionRate
Public CompressionRate As Single
val mutable CompressionRate: float32
var CompressionRate
public:
float CompressionRate

Field Value

Type: Single
See Also

Reference

ArchiveFileStatistics Class
GSF.Historian.Files Namespace


ArchiveFileStatistics.FileUsage Field

Grid Solutions Framework ArchiveFileStatisticsFileUsage Field
Current usage (in %) of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float FileUsage
Public FileUsage As Single
val mutable FileUsage: float32
var FileUsage
public:
float FileUsage

Field Value

Type: Single
See Also

Reference

ArchiveFileStatistics Class
GSF.Historian.Files Namespace


ArchiveFileStatistics Methods

Grid Solutions Framework ArchiveFileStatistics Methods

The ArchiveFileStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ArchiveFileStatistics Class
GSF.Historian.Files Namespace


ArchiveFileType Enumeration

Grid Solutions Framework ArchiveFileType Enumeration
Indicates the type of ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ArchiveFileType
Public Enumeration ArchiveFileType
type ArchiveFileType
GSF.Historian.Files.ArchiveFileType = function();
GSF.Historian.Files.ArchiveFileType.createEnum('GSF.Historian.Files.ArchiveFileType', false);
public enum class ArchiveFileType
Members
Member name | Value | Description
Active | 0 | ArchiveFile is being used for archiving current data.
Standby | 1 | ArchiveFile to be used in the rollover process.
Historic | 2 | ArchiveFile is full and is not to be used for current data.
See Also

Reference

GSF.Historian.Files Namespace


ArchiveReader Class

Grid Solutions Framework ArchiveReader Class
Opens a local set of historian files for reading with active archive file being monitored for roll-over.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveReader

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ArchiveReader : IDisposable
Public Class ArchiveReader
    Implements IDisposable
type ArchiveReader =
    class
        interface IDisposable
    end
GSF.Historian.Files.ArchiveReader = function();

Type.createClass(
    'GSF.Historian.Files.ArchiveReader',
    null,
    IDisposable);
public ref class ArchiveReader : IDisposable

The ArchiveReader type exposes the following members.

Constructors
 | Name | Description
Public method | ArchiveReader | Creates a new ArchiveReader.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the ArchiveReader object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ArchiveReader object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ArchiveReader object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataReadException | Raises the DataReadException event.
Protected method | OnHistoricFileListBuildComplete | Raises the HistoricFileListBuildComplete event.
Protected method | OnHistoricFileListBuildException | Raise the HistoricFileListBuildException event.
Protected method | OnHistoricFileListBuildStart | Raises the HistoricFileListBuildStart event.
Protected method | OnHistoricFileListUpdated | Raises the HistoricFileListUpdated event.
Protected method | OnRolloverComplete | Raises the RolloverComplete event.
Protected method | OnRolloverStart | Raises the RolloverStart event.
Public method | Open | Opens the ArchiveFile for use.
Public method | ReadData(IEnumerableInt32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.
Public method | ReadData(Int32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.
Public method | ReadData(IEnumerableInt32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ArchiveOffloadLocation | Gets the path to the offload location used by the ArchiveFile.
Public property | FileName | Gets the name of the ArchiveFile.
Public property | IntercomFile | Gets the IntercomFile used by the ArchiveFile.
Public property | MetadataFile | Gets the MetadataFile used by the ArchiveFile.
Public property | StateFile | Gets the StateFile used by the ArchiveFile.
Public property | Status | Gets the descriptive status of the internal ArchiveFile.
Top
Events
 | Name | Description
Public event | DataReadException | Occurs when an Exception is encountered while reading IDataPoint from the current or historic ArchiveFile.
Public event | HistoricFileListBuildComplete | Occurs when the process of building historic ArchiveFile list is complete.
Public event | HistoricFileListBuildException | Occurs when an Exception is encountered in historic ArchiveFile list building process.
Public event | HistoricFileListBuildStart | Occurs when the process of building historic ArchiveFile list is started.
Public event | HistoricFileListUpdated | Occurs when the historic ArchiveFile list is updated to reflect addition or deletion of historic ArchiveFiles.
Public event | RolloverComplete | Occurs when Rollover to a new ArchiveFile is complete.
Public event | RolloverStart | Occurs when Rollover to a new ArchiveFile is started.
Top
Remarks
This class is expected to be used as an out-of-process instance of the ArchiveFile that will properly open archive files as read-only and yield to roll-over processing.
See Also

Reference

GSF.Historian.Files Namespace


ArchiveReader Constructor

Grid Solutions Framework ArchiveReader Constructor
Creates a new ArchiveReader.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveReader()
Public Sub New
new : unit -> ArchiveReader
GSF.Historian.Files.ArchiveReader = function();
public:
ArchiveReader()
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader Methods

Grid Solutions Framework ArchiveReader Methods

The ArchiveReader type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the ArchiveReader object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ArchiveReader object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ArchiveReader object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataReadException | Raises the DataReadException event.
Protected method | OnHistoricFileListBuildComplete | Raises the HistoricFileListBuildComplete event.
Protected method | OnHistoricFileListBuildException | Raise the HistoricFileListBuildException event.
Protected method | OnHistoricFileListBuildStart | Raises the HistoricFileListBuildStart event.
Protected method | OnHistoricFileListUpdated | Raises the HistoricFileListUpdated event.
Protected method | OnRolloverComplete | Raises the RolloverComplete event.
Protected method | OnRolloverStart | Raises the RolloverStart event.
Public method | Open | Opens the ArchiveFile for use.
Public method | ReadData(IEnumerableInt32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.
Public method | ReadData(Int32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.
Public method | ReadData(IEnumerableInt32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.Dispose Method

Grid Solutions Framework ArchiveReaderDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ArchiveReader object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ArchiveReader object and optionally releases the managed resources.
Top
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.Dispose Method

Grid Solutions Framework ArchiveReaderDispose Method
Releases all the resources used by the ArchiveReader object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ArchiveReader Class
Dispose Overload
GSF.Historian.Files Namespace


ArchiveReader.Dispose Method (Boolean)

Grid Solutions Framework ArchiveReaderDispose Method (Boolean)
Releases the unmanaged resources used by the ArchiveReader object and optionally releases the managed resources.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ArchiveReader Class
Dispose Overload
GSF.Historian.Files Namespace


ArchiveReader.Finalize Method

Grid Solutions Framework ArchiveReaderFinalize Method
Releases the unmanaged resources before the ArchiveReader object is reclaimed by GC.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.OnDataReadException Method

Grid Solutions Framework ArchiveReaderOnDataReadException Method
Raises the DataReadException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataReadException(
    Exception ex
)
Protected Overridable Sub OnDataReadException (
    ex As Exception
)
abstract OnDataReadException :
        ex : Exception -> unit
override OnDataReadException :
        ex : Exception -> unit
function OnDataReadException(ex);
protected:
virtual void OnDataReadException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to DataReadException event.
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.OnHistoricFileListBuildComplete Method

Grid Solutions Framework ArchiveReaderOnHistoricFileListBuildComplete Method
Raises the HistoricFileListBuildComplete event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListBuildComplete()
Protected Overridable Sub OnHistoricFileListBuildComplete
abstract OnHistoricFileListBuildComplete : unit -> unit
override OnHistoricFileListBuildComplete : unit -> unit
function OnHistoricFileListBuildComplete();
protected:
virtual void OnHistoricFileListBuildComplete()
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.OnHistoricFileListBuildException Method

Grid Solutions Framework ArchiveReaderOnHistoricFileListBuildException Method
Raise the HistoricFileListBuildException event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListBuildException(
    Exception ex
)
Protected Overridable Sub OnHistoricFileListBuildException (
    ex As Exception
)
abstract OnHistoricFileListBuildException :
        ex : Exception -> unit
override OnHistoricFileListBuildException :
        ex : Exception -> unit
function OnHistoricFileListBuildException(ex);
protected:
virtual void OnHistoricFileListBuildException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to HistoricFileListBuildException event.
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.OnHistoricFileListBuildStart Method

Grid Solutions Framework ArchiveReaderOnHistoricFileListBuildStart Method
Raises the HistoricFileListBuildStart event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListBuildStart()
Protected Overridable Sub OnHistoricFileListBuildStart
abstract OnHistoricFileListBuildStart : unit -> unit
override OnHistoricFileListBuildStart : unit -> unit
function OnHistoricFileListBuildStart();
protected:
virtual void OnHistoricFileListBuildStart()
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.OnHistoricFileListUpdated Method

Grid Solutions Framework ArchiveReaderOnHistoricFileListUpdated Method
Raises the HistoricFileListUpdated event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnHistoricFileListUpdated()
Protected Overridable Sub OnHistoricFileListUpdated
abstract OnHistoricFileListUpdated : unit -> unit
override OnHistoricFileListUpdated : unit -> unit
function OnHistoricFileListUpdated();
protected:
virtual void OnHistoricFileListUpdated()
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.OnRolloverComplete Method

Grid Solutions Framework ArchiveReaderOnRolloverComplete Method
Raises the RolloverComplete event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverComplete()
Protected Overridable Sub OnRolloverComplete
abstract OnRolloverComplete : unit -> unit
override OnRolloverComplete : unit -> unit
function OnRolloverComplete();
protected:
virtual void OnRolloverComplete()
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.OnRolloverStart Method

Grid Solutions Framework ArchiveReaderOnRolloverStart Method
Raises the RolloverStart event.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRolloverStart()
Protected Overridable Sub OnRolloverStart
abstract OnRolloverStart : unit -> unit
override OnRolloverStart : unit -> unit
function OnRolloverStart();
protected:
virtual void OnRolloverStart()
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.Open Method

Grid Solutions Framework ArchiveReaderOpen Method
Opens the ArchiveFile for use.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open(
    string fileName,
    string offloadLocation = ""
)
Public Sub Open (
    fileName As String,
    Optional offloadLocation As String = ""
)
member Open :
        fileName : string *
        ?offloadLocation : string
(* Defaults:
        let _offloadLocation = defaultArg offloadLocation ""
*)
-> unit

function Open(fileName, offloadLocation);
public:
void Open(
    String^ fileName,
    String^ offloadLocation = L""
)

Parameters

fileName
Type: SystemString
Archive .D archive file name.
offloadLocation (Optional)
Type: SystemString
Path to archive offload location.
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method

Grid Solutions Framework ArchiveReaderReadData Method
Overload List
 | Name | Description
Public method | ReadData(IEnumerableInt32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.
Public method | ReadData(Int32, Boolean) | Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.
Public method | ReadData(IEnumerableInt32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(IEnumerableInt32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, TimeTag, TimeTag, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, DateTime, DateTime, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Public method | ReadData(Int32, String, String, Boolean) | Reads ArchiveDataPoints from the ArchiveFile.
Top
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (IEnumerable(Int32), Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (IEnumerableInt32, Boolean)
Reads all ArchiveDataPoints from the ArchiveFile for the specified historianIDs.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (Int32, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (Int32, Boolean)
Reads all ArchiveDataPoints from the ArchiveFile for the specified historianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (IEnumerable(Int32), TimeTag, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (IEnumerableInt32, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    TimeTag startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    TimeTag^ startTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (IEnumerable(Int32), DateTime, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (IEnumerableInt32, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    DateTime startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    DateTime startTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (IEnumerable(Int32), String, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (IEnumerableInt32, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    string startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    String^ startTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (Int32, TimeTag, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (Int32, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    TimeTag startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    TimeTag^ startTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (Int32, DateTime, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (Int32, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    DateTime startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    DateTime startTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (Int32, String, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (Int32, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    string startTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    String^ startTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (IEnumerable(Int32), TimeTag, TimeTag, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (IEnumerableInt32, TimeTag, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    TimeTag startTime,
    TimeTag endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As TimeTag,
    endTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : TimeTag *
        endTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    TimeTag^ startTime,
    TimeTag^ endTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: GSF.HistorianTimeTag
End TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (IEnumerable(Int32), DateTime, DateTime, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (IEnumerableInt32, DateTime, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As DateTime,
    endTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : DateTime *
        endTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemDateTime
End DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (IEnumerable(Int32), String, String, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (IEnumerableInt32, String, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    IEnumerable<int> historianIDs,
    string startTime,
    string endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianIDs As IEnumerable(Of Integer),
    startTime As String,
    endTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianIDs : IEnumerable<int> *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianIDs, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    IEnumerable<int>^ historianIDs,
    String^ startTime,
    String^ endTime,
    bool timeSorted = true
)

Parameters

historianIDs
Type: System.Collections.GenericIEnumerable Int32
Historian identifiers for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemString
String representation of the end time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (Int32, TimeTag, TimeTag, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (Int32, TimeTag, TimeTag, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    TimeTag startTime,
    TimeTag endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As TimeTag,
    endTime As TimeTag,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : TimeTag *
        endTime : TimeTag *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    TimeTag^ startTime,
    TimeTag^ endTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: GSF.HistorianTimeTag
Start TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: GSF.HistorianTimeTag
End TimeTag (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (Int32, DateTime, DateTime, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (Int32, DateTime, DateTime, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As DateTime,
    endTime As DateTime,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : DateTime *
        endTime : DateTime *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    DateTime startTime,
    DateTime endTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemDateTime
Start DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemDateTime
End DateTime (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader.ReadData Method (Int32, String, String, Boolean)

Grid Solutions Framework ArchiveReaderReadData Method (Int32, String, String, Boolean)
Reads ArchiveDataPoints from the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> ReadData(
    int historianID,
    string startTime,
    string endTime,
    bool timeSorted = true
)
Public Function ReadData (
    historianID As Integer,
    startTime As String,
    endTime As String,
    Optional timeSorted As Boolean = true
) As IEnumerable(Of IDataPoint)
member ReadData :
        historianID : int *
        startTime : string *
        endTime : string *
        ?timeSorted : bool
(* Defaults:
        let _timeSorted = defaultArg timeSorted true
*)
-> IEnumerable<IDataPoint>

function ReadData(historianID, startTime, endTime, timeSorted);
public:
IEnumerable<IDataPoint^>^ ReadData(
    int historianID,
    String^ startTime,
    String^ endTime,
    bool timeSorted = true
)

Parameters

historianID
Type: SystemInt32
Historian identifier for which ArchiveDataPoints are to be retrieved.
startTime
Type: SystemString
String representation of the start time (in UTC) for the ArchiveDataPoints to be retrieved.
endTime
Type: SystemString
String representation of the end time (in UTC) for the ArchiveDataPoints to be retrieved.
timeSorted (Optional)
Type: SystemBoolean
Indicates whether the data retrieved from the archive should be time sorted.

Return Value

Type: IEnumerable IDataPoint
IEnumerableT object containing zero or more ArchiveDataPoints.
See Also

Reference

ArchiveReader Class
ReadData Overload
GSF.Historian.Files Namespace


ArchiveReader Properties

Grid Solutions Framework ArchiveReader Properties

The ArchiveReader type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveOffloadLocation | Gets the path to the offload location used by the ArchiveFile.
Public property | FileName | Gets the name of the ArchiveFile.
Public property | IntercomFile | Gets the IntercomFile used by the ArchiveFile.
Public property | MetadataFile | Gets the MetadataFile used by the ArchiveFile.
Public property | StateFile | Gets the StateFile used by the ArchiveFile.
Public property | Status | Gets the descriptive status of the internal ArchiveFile.
Top
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.ArchiveOffloadLocation Property

Grid Solutions Framework ArchiveReaderArchiveOffloadLocation Property
Gets the path to the offload location used by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ArchiveOffloadLocation { get; }
Public ReadOnly Property ArchiveOffloadLocation As String
    Get
member ArchiveOffloadLocation : string with get

function get_ArchiveOffloadLocation();

public:
property String^ ArchiveOffloadLocation {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.FileName Property

Grid Solutions Framework ArchiveReaderFileName Property
Gets the name of the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; }
Public ReadOnly Property FileName As String
    Get
member FileName : string with get

function get_FileName();

public:
property String^ FileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.IntercomFile Property

Grid Solutions Framework ArchiveReaderIntercomFile Property
Gets the IntercomFile used by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntercomFile IntercomFile { get; }
Public ReadOnly Property IntercomFile As IntercomFile
    Get
member IntercomFile : IntercomFile with get

function get_IntercomFile();

public:
property IntercomFile^ IntercomFile {
    IntercomFile^ get ();
}

Property Value

Type: IntercomFile
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.MetadataFile Property

Grid Solutions Framework ArchiveReaderMetadataFile Property
Gets the MetadataFile used by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataFile MetadataFile { get; }
Public ReadOnly Property MetadataFile As MetadataFile
    Get
member MetadataFile : MetadataFile with get

function get_MetadataFile();

public:
property MetadataFile^ MetadataFile {
    MetadataFile^ get ();
}

Property Value

Type: MetadataFile
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.StateFile Property

Grid Solutions Framework ArchiveReaderStateFile Property
Gets the StateFile used by the ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateFile StateFile { get; }
Public ReadOnly Property StateFile As StateFile
    Get
member StateFile : StateFile with get

function get_StateFile();

public:
property StateFile^ StateFile {
    StateFile^ get ();
}

Property Value

Type: StateFile
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.Status Property

Grid Solutions Framework ArchiveReaderStatus Property
Gets the descriptive status of the internal ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
member Status : string with get

function get_Status();

public:
property String^ Status {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader Events

Grid Solutions Framework ArchiveReader Events

The ArchiveReader type exposes the following members.

Events
 | Name | Description
Public event | DataReadException | Occurs when an Exception is encountered while reading IDataPoint from the current or historic ArchiveFile.
Public event | HistoricFileListBuildComplete | Occurs when the process of building historic ArchiveFile list is complete.
Public event | HistoricFileListBuildException | Occurs when an Exception is encountered in historic ArchiveFile list building process.
Public event | HistoricFileListBuildStart | Occurs when the process of building historic ArchiveFile list is started.
Public event | HistoricFileListUpdated | Occurs when the historic ArchiveFile list is updated to reflect addition or deletion of historic ArchiveFiles.
Public event | RolloverComplete | Occurs when Rollover to a new ArchiveFile is complete.
Public event | RolloverStart | Occurs when Rollover to a new ArchiveFile is started.
Top
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.DataReadException Event

Grid Solutions Framework ArchiveReaderDataReadException Event
Occurs when an Exception is encountered while reading IDataPoint from the current or historic ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> DataReadException
Public Event DataReadException As EventHandler(Of EventArgs(Of Exception))
member DataReadException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_DataReadException(value);
function remove_DataReadException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ DataReadException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.HistoricFileListBuildComplete Event

Grid Solutions Framework ArchiveReaderHistoricFileListBuildComplete Event
Occurs when the process of building historic ArchiveFile list is complete.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler HistoricFileListBuildComplete
Public Event HistoricFileListBuildComplete As EventHandler
member HistoricFileListBuildComplete : IEvent<EventHandler,
    EventArgs>

function add_HistoricFileListBuildComplete(value);
function remove_HistoricFileListBuildComplete(value);
public:
 event EventHandler^ HistoricFileListBuildComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.HistoricFileListBuildException Event

Grid Solutions Framework ArchiveReaderHistoricFileListBuildException Event
Occurs when an Exception is encountered in historic ArchiveFile list building process.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> HistoricFileListBuildException
Public Event HistoricFileListBuildException As EventHandler(Of EventArgs(Of Exception))
member HistoricFileListBuildException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_HistoricFileListBuildException(value);
function remove_HistoricFileListBuildException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ HistoricFileListBuildException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.HistoricFileListBuildStart Event

Grid Solutions Framework ArchiveReaderHistoricFileListBuildStart Event
Occurs when the process of building historic ArchiveFile list is started.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler HistoricFileListBuildStart
Public Event HistoricFileListBuildStart As EventHandler
member HistoricFileListBuildStart : IEvent<EventHandler,
    EventArgs>

function add_HistoricFileListBuildStart(value);
function remove_HistoricFileListBuildStart(value);
public:
 event EventHandler^ HistoricFileListBuildStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.HistoricFileListUpdated Event

Grid Solutions Framework ArchiveReaderHistoricFileListUpdated Event
Occurs when the historic ArchiveFile list is updated to reflect addition or deletion of historic ArchiveFiles.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler HistoricFileListUpdated
Public Event HistoricFileListUpdated As EventHandler
member HistoricFileListUpdated : IEvent<EventHandler,
    EventArgs>

function add_HistoricFileListUpdated(value);
function remove_HistoricFileListUpdated(value);
public:
 event EventHandler^ HistoricFileListUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.RolloverComplete Event

Grid Solutions Framework ArchiveReaderRolloverComplete Event
Occurs when Rollover to a new ArchiveFile is complete.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler RolloverComplete
Public Event RolloverComplete As EventHandler
member RolloverComplete : IEvent<EventHandler,
    EventArgs>

function add_RolloverComplete(value);
function remove_RolloverComplete(value);
public:
 event EventHandler^ RolloverComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


ArchiveReader.RolloverStart Event

Grid Solutions Framework ArchiveReaderRolloverStart Event
Occurs when Rollover to a new ArchiveFile is started.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler RolloverStart
Public Event RolloverStart As EventHandler
member RolloverStart : IEvent<EventHandler,
    EventArgs>

function add_RolloverStart(value);
function remove_RolloverStart(value);
public:
 event EventHandler^ RolloverStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ArchiveReader Class
GSF.Historian.Files Namespace


DataType Enumeration

Grid Solutions Framework DataType Enumeration
Indicates the type of data being archived for a MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DataType
Public Enumeration DataType
type DataType
GSF.Historian.Files.DataType = function();
GSF.Historian.Files.DataType.createEnum('GSF.Historian.Files.DataType', false);
public enum class DataType
Members
Member name | Value | Description
Analog | 0 | Data value is analog in nature.
Digital | 1 | Data value is digital in nature.
Composed | 2 | Data value is calculated based on an equation upon retrieval.
Constant | 3 | Data value is a constant and no real-time time-series data is received.
See Also

Reference

GSF.Historian.Files Namespace


IArchiveFileScanner Interface

Grid Solutions Framework IArchiveFileScanner Interface
Represents a scanner that reads data points from an archive file for a given time range.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IArchiveFileScanner
Public Interface IArchiveFileScanner
type IArchiveFileScanner =  interface end
GSF.Historian.Files.IArchiveFileScanner = function();
GSF.Historian.Files.IArchiveFileScanner.createInterface('GSF.Historian.Files.IArchiveFileScanner');
public interface class IArchiveFileScanner

The IArchiveFileScanner type exposes the following members.

Methods
 | Name | Description
Public method | Read | Reads all IDataPoints for the specified historian IDs.
Top
Properties
 | Name | Description
Public property | DataReadExceptionHandler | Gets or sets the handler used to handle errors that occur while scanning the file.
Public property | EndTime | Gets or sets the maximum value of the timestamps of the data points returned by the scanner.
Public property | FileAllocationTable | Gets or sets the file allocation table of the file that this scanner is reading from.
Public property | HistorianIDs | Gets or sets the collection of point IDs to be scanned from the file.
Public property | ResumeFrom | Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.
Public property | StartTime | Gets or sets the minimum value of the timestamps of the data points returned by the scanner.
Top
See Also

Reference

GSF.Historian.Files Namespace


IArchiveFileScanner Methods

Grid Solutions Framework IArchiveFileScanner Methods

The IArchiveFileScanner type exposes the following members.

Methods
 | Name | Description
Public method | Read | Reads all IDataPoints for the specified historian IDs.
Top
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner.Read Method

Grid Solutions Framework IArchiveFileScannerRead Method
Reads all IDataPoints for the specified historian IDs.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IEnumerable<IDataPoint> Read()
Function Read As IEnumerable(Of IDataPoint)
abstract Read : unit -> IEnumerable<IDataPoint>

function Read();
IEnumerable<IDataPoint^>^ Read()

Return Value

Type: IEnumerable IDataPoint
Each IDataPoint for the specified historian IDs.
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner Properties

Grid Solutions Framework IArchiveFileScanner Properties

The IArchiveFileScanner type exposes the following members.

Properties
 | Name | Description
Public property | DataReadExceptionHandler | Gets or sets the handler used to handle errors that occur while scanning the file.
Public property | EndTime | Gets or sets the maximum value of the timestamps of the data points returned by the scanner.
Public property | FileAllocationTable | Gets or sets the file allocation table of the file that this scanner is reading from.
Public property | HistorianIDs | Gets or sets the collection of point IDs to be scanned from the file.
Public property | ResumeFrom | Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.
Public property | StartTime | Gets or sets the minimum value of the timestamps of the data points returned by the scanner.
Top
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner.DataReadExceptionHandler Property

Grid Solutions Framework IArchiveFileScannerDataReadExceptionHandler Property
Gets or sets the handler used to handle errors that occur while scanning the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
EventHandler<EventArgs<Exception>> DataReadExceptionHandler { get; set; }
Property DataReadExceptionHandler As EventHandler(Of EventArgs(Of Exception))
    Get
    Set
abstract DataReadExceptionHandler : EventHandler<EventArgs<Exception>> with get, set

function get_DataReadExceptionHandler();
function set_DataReadExceptionHandler(value);
property EventHandler<EventArgs<Exception^>^>^ DataReadExceptionHandler {
    EventHandler<EventArgs<Exception^>^>^ get ();
    void set (EventHandler<EventArgs<Exception^>^>^ value);
}

Property Value

Type: EventHandler EventArgs Exception
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner.EndTime Property

Grid Solutions Framework IArchiveFileScannerEndTime Property
Gets or sets the maximum value of the timestamps of the data points returned by the scanner.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TimeTag EndTime { get; set; }
Property EndTime As TimeTag
    Get
    Set
abstract EndTime : TimeTag with get, set

function get_EndTime();
function set_EndTime(value);
property TimeTag^ EndTime {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner.FileAllocationTable Property

Grid Solutions Framework IArchiveFileScannerFileAllocationTable Property
Gets or sets the file allocation table of the file that this scanner is reading from.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ArchiveFileAllocationTable FileAllocationTable { get; set; }
Property FileAllocationTable As ArchiveFileAllocationTable
    Get
    Set
abstract FileAllocationTable : ArchiveFileAllocationTable with get, set

function get_FileAllocationTable();
function set_FileAllocationTable(value);
property ArchiveFileAllocationTable^ FileAllocationTable {
    ArchiveFileAllocationTable^ get ();
    void set (ArchiveFileAllocationTable^ value);
}

Property Value

Type: ArchiveFileAllocationTable
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner.HistorianIDs Property

Grid Solutions Framework IArchiveFileScannerHistorianIDs Property
Gets or sets the collection of point IDs to be scanned from the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IEnumerable<int> HistorianIDs { get; set; }
Property HistorianIDs As IEnumerable(Of Integer)
    Get
    Set
abstract HistorianIDs : IEnumerable<int> with get, set

function get_HistorianIDs();
function set_HistorianIDs(value);
property IEnumerable<int>^ HistorianIDs {
    IEnumerable<int>^ get ();
    void set (IEnumerable<int>^ value);
}

Property Value

Type: IEnumerable Int32
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner.ResumeFrom Property

Grid Solutions Framework IArchiveFileScannerResumeFrom Property
Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IDataPoint ResumeFrom { get; set; }
Property ResumeFrom As IDataPoint
    Get
    Set
abstract ResumeFrom : IDataPoint with get, set

function get_ResumeFrom();
function set_ResumeFrom(value);
property IDataPoint^ ResumeFrom {
    IDataPoint^ get ();
    void set (IDataPoint^ value);
}

Property Value

Type: IDataPoint
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IArchiveFileScanner.StartTime Property

Grid Solutions Framework IArchiveFileScannerStartTime Property
Gets or sets the minimum value of the timestamps of the data points returned by the scanner.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TimeTag StartTime { get; set; }
Property StartTime As TimeTag
    Get
    Set
abstract StartTime : TimeTag with get, set

function get_StartTime();
function set_StartTime(value);
property TimeTag^ StartTime {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
See Also

Reference

IArchiveFileScanner Interface
GSF.Historian.Files Namespace


IntercomFile Class

Grid Solutions Framework IntercomFile Class
Represents a file containing IntercomRecords.
Inheritance Hierarchy
SystemObject
GSF.IOIsamDataFileBase IntercomRecord
GSF.Historian.FilesIntercomFile

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(IntercomFile))]
public class IntercomFile : IsamDataFileBase<IntercomRecord>
<ToolboxBitmapAttribute(GetType(IntercomFile))>
Public Class IntercomFile
    Inherits IsamDataFileBase(Of IntercomRecord)
[<ToolboxBitmapAttribute(typeof(IntercomFile))>]
type IntercomFile =
    class
        inherit IsamDataFileBase<IntercomRecord>
    end
GSF.Historian.Files.IntercomFile = function();

Type.createClass(
    'GSF.Historian.Files.IntercomFile',
    GSF.IO.IsamDataFileBase`1);
[ToolboxBitmapAttribute(typeof(IntercomFile))]
public ref class IntercomFile : public IsamDataFileBase<IntercomRecord^>

The IntercomFile type exposes the following members.

Constructors
 | Name | Description
Public method | IntercomFile | Initializes a new instance of the IntercomFile class.
Top
Methods
 | Name | Description
Public method | Close | Closes the file. (Inherited from IsamDataFileBaseT.)
Protected method | CreateNewRecord | Creates a new IntercomRecord with the specified recordIndex. (Overrides IsamDataFileBaseTCreateNewRecord(Int32).)
Public method | Dispose | Releases all the resources used by the file. (Inherited from IsamDataFileBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources. (Inherited from IsamDataFileBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Inherited from IsamDataFileBaseT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | Gets the binary size of a IntercomRecord. (Overrides IsamDataFileBaseTGetRecordSize.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file. (Inherited from IsamDataFileBaseT.)
Public method | Load | Loads records from disk into memory. (Inherited from IsamDataFileBaseT.)
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataLoading | Raises the DataLoading event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaved | Raises the DataSaved event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaving | Raises the DataSaving event. (Inherited from IsamDataFileBaseT.)
Protected method | OnFileModified | Raises the FileModified event. (Inherited from IsamDataFileBaseT.)
Public method | Open | Opens the file. (Inherited from IsamDataFileBaseT.)
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory. (Inherited from IsamDataFileBaseT.)
Public method | Save | Saves records loaded in memory to disk. (Inherited from IsamDataFileBaseT.)
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableT) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Write(Int32, T) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory. (Inherited from IsamDataFileBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk. (Inherited from IsamDataFileBaseT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled. (Inherited from IsamDataFileBaseT.)
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileData | Gets the underlying FileStream of the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileDataLock | Gets the locking object for the FileData stream. (Inherited from IsamDataFileBaseT.)
Public property | FileName | Gets or sets the name of the file. (Inherited from IsamDataFileBaseT.)
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt. (Inherited from IsamDataFileBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from IsamDataFileBaseT.)
Public property | IsOpen | Gets a boolean value that indicates whether the file is open. (Inherited from IsamDataFileBaseT.)
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened. (Inherited from IsamDataFileBaseT.)
Protected property | LoadWaitHandle | Gets wait handle for loading data. (Inherited from IsamDataFileBaseT.)
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file. (Inherited from IsamDataFileBaseT.)
Public property | Name | Gets the unique identifier of the file. (Inherited from IsamDataFileBaseT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file. (Inherited from IsamDataFileBaseT.)
Public property | RecordsInMemory | Gets the number of file records loaded in memory. (Inherited from IsamDataFileBaseT.)
Public property | RecordsOnDisk | Gets the number of file records on the disk. (Inherited from IsamDataFileBaseT.)
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk. (Inherited from IsamDataFileBaseT.)
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed. (Inherited from IsamDataFileBaseT.)
Protected property | SaveWaitHandle | Gets wait handle for saving data. (Inherited from IsamDataFileBaseT.)
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public property | Status | Gets the descriptive status of the file. (Inherited from IsamDataFileBaseT.)
Top
Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataLoading | Occurs when data is being read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataSaved | Occurs when data has been saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | DataSaving | Occurs when data is being saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from IsamDataFileBaseT.)
Public event | FileModified | Occurs when file data on the disk is modified. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesIntercomRecord


IntercomFile Constructor

Grid Solutions Framework IntercomFile Constructor
Initializes a new instance of the IntercomFile class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntercomFile()
Public Sub New
new : unit -> IntercomFile
GSF.Historian.Files.IntercomFile = function();
public:
IntercomFile()
See Also

Reference

IntercomFile Class
GSF.Historian.Files Namespace


IntercomFile Methods

Grid Solutions Framework IntercomFile Methods

The IntercomFile type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the file. (Inherited from IsamDataFileBaseT.)
Protected method | CreateNewRecord | Creates a new IntercomRecord with the specified recordIndex. (Overrides IsamDataFileBaseTCreateNewRecord(Int32).)
Public method | Dispose | Releases all the resources used by the file. (Inherited from IsamDataFileBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources. (Inherited from IsamDataFileBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Inherited from IsamDataFileBaseT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | Gets the binary size of a IntercomRecord. (Overrides IsamDataFileBaseTGetRecordSize.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file. (Inherited from IsamDataFileBaseT.)
Public method | Load | Loads records from disk into memory. (Inherited from IsamDataFileBaseT.)
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataLoading | Raises the DataLoading event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaved | Raises the DataSaved event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaving | Raises the DataSaving event. (Inherited from IsamDataFileBaseT.)
Protected method | OnFileModified | Raises the FileModified event. (Inherited from IsamDataFileBaseT.)
Public method | Open | Opens the file. (Inherited from IsamDataFileBaseT.)
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory. (Inherited from IsamDataFileBaseT.)
Public method | Save | Saves records loaded in memory to disk. (Inherited from IsamDataFileBaseT.)
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableT) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Write(Int32, T) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory. (Inherited from IsamDataFileBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IntercomFile Class
GSF.Historian.Files Namespace


IntercomFile.CreateNewRecord Method

Grid Solutions Framework IntercomFileCreateNewRecord Method
Creates a new IntercomRecord with the specified recordIndex.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override IntercomRecord CreateNewRecord(
    int recordIndex
)
Protected Overrides Function CreateNewRecord (
    recordIndex As Integer
) As IntercomRecord
abstract CreateNewRecord :
        recordIndex : int -> IntercomRecord
override CreateNewRecord :
        recordIndex : int -> IntercomRecord
function CreateNewRecord(recordIndex);
protected:
virtual IntercomRecord^ CreateNewRecord(
    int recordIndex
) override

Parameters

recordIndex
Type: SystemInt32
1-based index of the IntercomRecord.

Return Value

Type: IntercomRecord
A IntercomRecord object.
See Also

Reference

IntercomFile Class
GSF.Historian.Files Namespace


IntercomFile.GetRecordSize Method

Grid Solutions Framework IntercomFileGetRecordSize Method
Gets the binary size of a IntercomRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int GetRecordSize()
Protected Overrides Function GetRecordSize As Integer
abstract GetRecordSize : unit -> int
override GetRecordSize : unit -> int
function GetRecordSize();
protected:
virtual int GetRecordSize() override

Return Value

Type: Int32
A 32-bit signed integer.
See Also

Reference

IntercomFile Class
GSF.Historian.Files Namespace


IntercomFile Properties

Grid Solutions Framework IntercomFile Properties

The IntercomFile type exposes the following members.

Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk. (Inherited from IsamDataFileBaseT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled. (Inherited from IsamDataFileBaseT.)
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileData | Gets the underlying FileStream of the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileDataLock | Gets the locking object for the FileData stream. (Inherited from IsamDataFileBaseT.)
Public property | FileName | Gets or sets the name of the file. (Inherited from IsamDataFileBaseT.)
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt. (Inherited from IsamDataFileBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from IsamDataFileBaseT.)
Public property | IsOpen | Gets a boolean value that indicates whether the file is open. (Inherited from IsamDataFileBaseT.)
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened. (Inherited from IsamDataFileBaseT.)
Protected property | LoadWaitHandle | Gets wait handle for loading data. (Inherited from IsamDataFileBaseT.)
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file. (Inherited from IsamDataFileBaseT.)
Public property | Name | Gets the unique identifier of the file. (Inherited from IsamDataFileBaseT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file. (Inherited from IsamDataFileBaseT.)
Public property | RecordsInMemory | Gets the number of file records loaded in memory. (Inherited from IsamDataFileBaseT.)
Public property | RecordsOnDisk | Gets the number of file records on the disk. (Inherited from IsamDataFileBaseT.)
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk. (Inherited from IsamDataFileBaseT.)
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed. (Inherited from IsamDataFileBaseT.)
Protected property | SaveWaitHandle | Gets wait handle for saving data. (Inherited from IsamDataFileBaseT.)
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public property | Status | Gets the descriptive status of the file. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

IntercomFile Class
GSF.Historian.Files Namespace


IntercomFile Events

Grid Solutions Framework IntercomFile Events

The IntercomFile type exposes the following members.

Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataLoading | Occurs when data is being read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataSaved | Occurs when data has been saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | DataSaving | Occurs when data is being saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from IsamDataFileBaseT.)
Public event | FileModified | Occurs when file data on the disk is modified. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

IntercomFile Class
GSF.Historian.Files Namespace


IntercomRecord Class

Grid Solutions Framework IntercomRecord Class
Represents a record in the IntercomFile that contains runtime information of a historian.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesIntercomRecord

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IntercomRecord : ISupportBinaryImage
Public Class IntercomRecord
    Implements ISupportBinaryImage
type IntercomRecord =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.IntercomRecord = function();

Type.createClass(
    'GSF.Historian.Files.IntercomRecord',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class IntercomRecord : ISupportBinaryImage

The IntercomRecord type exposes the following members.

Constructors
 | Name | Description
Public method | IntercomRecord(Int32) | Initializes a new instance of the IntercomRecord class.
Public method | IntercomRecord(Int32, Byte, Int32, Int32) | Initializes a new instance of the IntercomRecord class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the IntercomRecord and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes IntercomRecord from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of IntercomRecord.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the IntercomRecord.
Public property | DataBlocksUsed | Gets or sets the number of allocated ArchiveDataBlocks in the active ArchiveFile.
Public property | LatestDataID | Gets or sets the historian identifier of latest ArchiveDataPoint received by the active ArchiveFile.
Public property | LatestDataTime | Gets or sets the TimeTag of latest ArchiveDataPoint received by the active ArchiveFile.
Public property | RolloverInProgress | Gets or sets a boolean value that indicates whether the active ArchiveFile if being rolled-over.
Public property | SourceLatestDataTime | Gets a list of TimeTags of the latest ArchiveDataPoint received from each of the SourceIDs.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesIntercomFile


IntercomRecord Constructor

Grid Solutions Framework IntercomRecord Constructor
Overload List
 | Name | Description
Public method | IntercomRecord(Int32) | Initializes a new instance of the IntercomRecord class.
Public method | IntercomRecord(Int32, Byte, Int32, Int32) | Initializes a new instance of the IntercomRecord class.
Top
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord Constructor (Int32)

Grid Solutions Framework IntercomRecord Constructor (Int32)
Initializes a new instance of the IntercomRecord class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntercomRecord(
    int recordID
)
Public Sub New (
    recordID As Integer
)
new :
        recordID : int -> IntercomRecord
GSF.Historian.Files.IntercomRecord = function(recordID);
public:
IntercomRecord(
    int recordID
)

Parameters

recordID
Type: SystemInt32
ID of the IntercomRecord.
See Also

Reference

IntercomRecord Class
IntercomRecord Overload
GSF.Historian.Files Namespace


IntercomRecord Constructor (Int32, Byte[], Int32, Int32)

Grid Solutions Framework IntercomRecord Constructor (Int32, Byte, Int32, Int32)
Initializes a new instance of the IntercomRecord class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntercomRecord(
    int recordID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    recordID As Integer,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        recordID : int *
        buffer : byte[] *
        startIndex : int *
        length : int -> IntercomRecord
GSF.Historian.Files.IntercomRecord = function(recordID, buffer, startIndex, length);
public:
IntercomRecord(
    int recordID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

recordID
Type: SystemInt32
ID of the IntercomRecord.
buffer
Type: SystemByte
Binary image to be used for initializing IntercomRecord.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

IntercomRecord Class
IntercomRecord Overload
GSF.Historian.Files Namespace


IntercomRecord Fields

Grid Solutions Framework IntercomRecord Fields

The IntercomRecord type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of IntercomRecord.
Top
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.FixedLength Field

Grid Solutions Framework IntercomRecordFixedLength Field
Specifies the number of bytes in the binary image of IntercomRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.IntercomRecord.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord Methods

Grid Solutions Framework IntercomRecord Methods

The IntercomRecord type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the IntercomRecord and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes IntercomRecord from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.GenerateBinaryImage Method

Grid Solutions Framework IntercomRecordGenerateBinaryImage Method
Generates binary image of the IntercomRecord and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.ParseBinaryImage Method

Grid Solutions Framework IntercomRecordParseBinaryImage Method
Initializes IntercomRecord from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing IntercomRecord.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing IntercomRecord.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord Properties

Grid Solutions Framework IntercomRecord Properties

The IntercomRecord type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the IntercomRecord.
Public property | DataBlocksUsed | Gets or sets the number of allocated ArchiveDataBlocks in the active ArchiveFile.
Public property | LatestDataID | Gets or sets the historian identifier of latest ArchiveDataPoint received by the active ArchiveFile.
Public property | LatestDataTime | Gets or sets the TimeTag of latest ArchiveDataPoint received by the active ArchiveFile.
Public property | RolloverInProgress | Gets or sets a boolean value that indicates whether the active ArchiveFile if being rolled-over.
Public property | SourceLatestDataTime | Gets a list of TimeTags of the latest ArchiveDataPoint received from each of the SourceIDs.
Top
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.BinaryLength Property

Grid Solutions Framework IntercomRecordBinaryLength Property
Gets the length of the IntercomRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.DataBlocksUsed Property

Grid Solutions Framework IntercomRecordDataBlocksUsed Property
Gets or sets the number of allocated ArchiveDataBlocks in the active ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataBlocksUsed { get; set; }
Public Property DataBlocksUsed As Integer
    Get
    Set
member DataBlocksUsed : int with get, set

function get_DataBlocksUsed();
function set_DataBlocksUsed(value);
public:
property int DataBlocksUsed {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or zero.
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.LatestDataID Property

Grid Solutions Framework IntercomRecordLatestDataID Property
Gets or sets the historian identifier of latest ArchiveDataPoint received by the active ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LatestDataID { get; set; }
Public Property LatestDataID As Integer
    Get
    Set
member LatestDataID : int with get, set

function get_LatestDataID();
function set_LatestDataID(value);
public:
property int LatestDataID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.LatestDataTime Property

Grid Solutions Framework IntercomRecordLatestDataTime Property
Gets or sets the TimeTag of latest ArchiveDataPoint received by the active ArchiveFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag LatestDataTime { get; set; }
Public Property LatestDataTime As TimeTag
    Get
    Set
member LatestDataTime : TimeTag with get, set

function get_LatestDataTime();
function set_LatestDataTime(value);
public:
property TimeTag^ LatestDataTime {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.RolloverInProgress Property

Grid Solutions Framework IntercomRecordRolloverInProgress Property
Gets or sets a boolean value that indicates whether the active ArchiveFile if being rolled-over.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RolloverInProgress { get; set; }
Public Property RolloverInProgress As Boolean
    Get
    Set
member RolloverInProgress : bool with get, set

function get_RolloverInProgress();
function set_RolloverInProgress(value);
public:
property bool RolloverInProgress {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


IntercomRecord.SourceLatestDataTime Property

Grid Solutions Framework IntercomRecordSourceLatestDataTime Property
Gets a list of TimeTags of the latest ArchiveDataPoint received from each of the SourceIDs.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<TimeTag> SourceLatestDataTime { get; }
Public ReadOnly Property SourceLatestDataTime As IList(Of TimeTag)
    Get
member SourceLatestDataTime : IList<TimeTag> with get

function get_SourceLatestDataTime();

public:
property IList<TimeTag^>^ SourceLatestDataTime {
    IList<TimeTag^>^ get ();
}

Property Value

Type: IList TimeTag
See Also

Reference

IntercomRecord Class
GSF.Historian.Files Namespace


MetadataFile Class

Grid Solutions Framework MetadataFile Class
Represents a file containing MetadataRecords.
Inheritance Hierarchy
SystemObject
GSF.IOIsamDataFileBase MetadataRecord
GSF.Historian.FilesMetadataFile

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(MetadataFile))]
public class MetadataFile : IsamDataFileBase<MetadataRecord>
<ToolboxBitmapAttribute(GetType(MetadataFile))>
Public Class MetadataFile
    Inherits IsamDataFileBase(Of MetadataRecord)
[<ToolboxBitmapAttribute(typeof(MetadataFile))>]
type MetadataFile =
    class
        inherit IsamDataFileBase<MetadataRecord>
    end
GSF.Historian.Files.MetadataFile = function();

Type.createClass(
    'GSF.Historian.Files.MetadataFile',
    GSF.IO.IsamDataFileBase`1);
[ToolboxBitmapAttribute(typeof(MetadataFile))]
public ref class MetadataFile : public IsamDataFileBase<MetadataRecord^>

The MetadataFile type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataFile | Initializes a new instance of the MetadataFile class.
Top
Methods
 | Name | Description
Public method | Close | Closes the file. (Inherited from IsamDataFileBaseT.)
Protected method | CreateNewRecord | Creates a new MetadataRecord with the specified recordIndex. (Overrides IsamDataFileBaseTCreateNewRecord(Int32).)
Public method | Dispose | Releases all the resources used by the file. (Inherited from IsamDataFileBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources. (Inherited from IsamDataFileBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Inherited from IsamDataFileBaseT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | Gets the binary size of a MetadataRecord. (Overrides IsamDataFileBaseTGetRecordSize.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file. (Inherited from IsamDataFileBaseT.)
Public method | Load | Loads records from disk into memory. (Overrides IsamDataFileBaseTLoad.)
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true. (Overrides IsamDataFileBaseTLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataLoading | Raises the DataLoading event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaved | Raises the DataSaved event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaving | Raises the DataSaving event. (Inherited from IsamDataFileBaseT.)
Protected method | OnFileModified | Raises the FileModified event. (Inherited from IsamDataFileBaseT.)
Public method | Open | Opens the file. (Overrides IsamDataFileBaseTOpen.)
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory. (Overrides IsamDataFileBaseTRead.)
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory. (Overrides IsamDataFileBaseTRead(Int32).)
Public method | Read(String) | Reads MetadataRecords that matches the searchPattern.
Public method | Save | Saves records loaded in memory to disk. (Overrides IsamDataFileBaseTSave.)
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true. (Overrides IsamDataFileBaseTSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableMetadataRecord) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory. (Overrides IsamDataFileBaseTWrite(IEnumerableT).)
Public method | Write(Int32, MetadataRecord) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory. (Overrides IsamDataFileBaseTWrite(Int32, T).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk. (Inherited from IsamDataFileBaseT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled. (Inherited from IsamDataFileBaseT.)
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileData | Gets the underlying FileStream of the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileDataLock | Gets the locking object for the FileData stream. (Inherited from IsamDataFileBaseT.)
Public property | FileName | Gets or sets the name of the file. (Overrides IsamDataFileBaseTFileName.)
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt. (Overrides IsamDataFileBaseTIsCorrupt.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from IsamDataFileBaseT.)
Public property | IsOpen | Gets a boolean value that indicates whether the file is open. (Inherited from IsamDataFileBaseT.)
Public property | LegacyMode | Determines legacy operation mode for the MetadataFile.
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened. (Inherited from IsamDataFileBaseT.)
Protected property | LoadWaitHandle | Gets wait handle for loading data. (Inherited from IsamDataFileBaseT.)
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file. (Inherited from IsamDataFileBaseT.)
Public property | Name | Gets the unique identifier of the file. (Inherited from IsamDataFileBaseT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file. (Inherited from IsamDataFileBaseT.)
Public property | RecordsInMemory | Gets the number of file records loaded in memory. (Overrides IsamDataFileBaseTRecordsInMemory.)
Public property | RecordsOnDisk | Gets the number of file records on the disk. (Overrides IsamDataFileBaseTRecordsOnDisk.)
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk. (Inherited from IsamDataFileBaseT.)
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed. (Inherited from IsamDataFileBaseT.)
Protected property | SaveWaitHandle | Gets wait handle for saving data. (Inherited from IsamDataFileBaseT.)
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public property | Status | Gets the descriptive status of the MetadataFile. (Overrides IsamDataFileBaseTStatus.)
Top
Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataLoading | Occurs when data is being read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataSaved | Occurs when data has been saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | DataSaving | Occurs when data is being saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from IsamDataFileBaseT.)
Public event | FileModified | Occurs when file data on the disk is modified. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataFile Constructor

Grid Solutions Framework MetadataFile Constructor
Initializes a new instance of the MetadataFile class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataFile()
Public Sub New
new : unit -> MetadataFile
GSF.Historian.Files.MetadataFile = function();
public:
MetadataFile()
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile Methods

Grid Solutions Framework MetadataFile Methods

The MetadataFile type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the file. (Inherited from IsamDataFileBaseT.)
Protected method | CreateNewRecord | Creates a new MetadataRecord with the specified recordIndex. (Overrides IsamDataFileBaseTCreateNewRecord(Int32).)
Public method | Dispose | Releases all the resources used by the file. (Inherited from IsamDataFileBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources. (Inherited from IsamDataFileBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Inherited from IsamDataFileBaseT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | Gets the binary size of a MetadataRecord. (Overrides IsamDataFileBaseTGetRecordSize.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file. (Inherited from IsamDataFileBaseT.)
Public method | Load | Loads records from disk into memory. (Overrides IsamDataFileBaseTLoad.)
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true. (Overrides IsamDataFileBaseTLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataLoading | Raises the DataLoading event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaved | Raises the DataSaved event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaving | Raises the DataSaving event. (Inherited from IsamDataFileBaseT.)
Protected method | OnFileModified | Raises the FileModified event. (Inherited from IsamDataFileBaseT.)
Public method | Open | Opens the file. (Overrides IsamDataFileBaseTOpen.)
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory. (Overrides IsamDataFileBaseTRead.)
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory. (Overrides IsamDataFileBaseTRead(Int32).)
Public method | Read(String) | Reads MetadataRecords that matches the searchPattern.
Public method | Save | Saves records loaded in memory to disk. (Overrides IsamDataFileBaseTSave.)
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true. (Overrides IsamDataFileBaseTSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableMetadataRecord) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory. (Overrides IsamDataFileBaseTWrite(IEnumerableT).)
Public method | Write(Int32, MetadataRecord) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory. (Overrides IsamDataFileBaseTWrite(Int32, T).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.CreateNewRecord Method

Grid Solutions Framework MetadataFileCreateNewRecord Method
Creates a new MetadataRecord with the specified recordIndex.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override MetadataRecord CreateNewRecord(
    int recordIndex
)
Protected Overrides Function CreateNewRecord (
    recordIndex As Integer
) As MetadataRecord
abstract CreateNewRecord :
        recordIndex : int -> MetadataRecord
override CreateNewRecord :
        recordIndex : int -> MetadataRecord
function CreateNewRecord(recordIndex);
protected:
virtual MetadataRecord^ CreateNewRecord(
    int recordIndex
) override

Parameters

recordIndex
Type: SystemInt32
1-based index of the MetadataRecord.

Return Value

Type: MetadataRecord
A MetadataRecord object.
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.GetRecordSize Method

Grid Solutions Framework MetadataFileGetRecordSize Method
Gets the binary size of a MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int GetRecordSize()
Protected Overrides Function GetRecordSize As Integer
abstract GetRecordSize : unit -> int
override GetRecordSize : unit -> int
function GetRecordSize();
protected:
virtual int GetRecordSize() override

Return Value

Type: Int32
A 32-bit signed integer.
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.Load Method

Grid Solutions Framework MetadataFileLoad Method
Loads records from disk into memory.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Load()
Public Overrides Sub Load
abstract Load : unit -> unit
override Load : unit -> unit
function Load();
public:
virtual void Load() override
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.LoadSettings Method

Grid Solutions Framework MetadataFileLoadSettings Method
Loads saved settings of the file from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.Open Method

Grid Solutions Framework MetadataFileOpen Method
Opens the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Open()
Public Overrides Sub Open
abstract Open : unit -> unit
override Open : unit -> unit
function Open();
public:
virtual void Open() override
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.Read Method

Grid Solutions Framework MetadataFileRead Method
Overload List
 | Name | Description
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory. (Overrides IsamDataFileBaseTRead.)
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory. (Overrides IsamDataFileBaseTRead(Int32).)
Public method | Read(String) | Reads MetadataRecords that matches the searchPattern.
Top
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.Read Method

Grid Solutions Framework MetadataFileRead Method
Reads file records from disk if records were not loaded in memory otherwise returns the records in memory.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IEnumerable<MetadataRecord> Read()
Public Overrides Function Read As IEnumerable(Of MetadataRecord)
abstract Read : unit -> IEnumerable<MetadataRecord>
override Read : unit -> IEnumerable<MetadataRecord>
function Read();
public:
virtual IEnumerable<MetadataRecord^>^ Read() override

Return Value

Type: IEnumerable MetadataRecord
Records of the file.
See Also

Reference

MetadataFile Class
Read Overload
GSF.Historian.Files Namespace


MetadataFile.Read Method (Int32)

Grid Solutions Framework MetadataFileRead Method (Int32)
Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override MetadataRecord Read(
    int recordIndex
)
Public Overrides Function Read (
    recordIndex As Integer
) As MetadataRecord
abstract Read :
        recordIndex : int -> MetadataRecord
override Read :
        recordIndex : int -> MetadataRecord
function Read(recordIndex);
public:
virtual MetadataRecord^ Read(
    int recordIndex
) override

Parameters

recordIndex
Type: SystemInt32
1-based index of the record to be read.

Return Value

Type: MetadataRecord
Record with the specified ID if it exists; otherwise null.
See Also

Reference

MetadataFile Class
Read Overload
GSF.Historian.Files Namespace


MetadataFile.Read Method (String)

Grid Solutions Framework MetadataFileRead Method (String)
Reads MetadataRecords that matches the searchPattern.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<MetadataRecord> Read(
    string searchPattern
)
Public Function Read (
    searchPattern As String
) As IEnumerable(Of MetadataRecord)
member Read :
        searchPattern : string -> IEnumerable<MetadataRecord>

function Read(searchPattern);
public:
IEnumerable<MetadataRecord^>^ Read(
    String^ searchPattern
)

Parameters

searchPattern
Type: SystemString
Comma or semi-colon delimited list of IDs or text for which the matching MetadataRecords are to be retrieved.

Return Value

Type: IEnumerable MetadataRecord
An IEnumerableT object of MetadataRecord.
See Also

Reference

MetadataFile Class
Read Overload
GSF.Historian.Files Namespace


MetadataFile.Save Method

Grid Solutions Framework MetadataFileSave Method
Saves records loaded in memory to disk.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Save()
Public Overrides Sub Save
abstract Save : unit -> unit
override Save : unit -> unit
function Save();
public:
virtual void Save() override
Remarks
Save is equivalent to Flush when records are not loaded in memory.
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.SaveSettings Method

Grid Solutions Framework MetadataFileSaveSettings Method
Saves settings of the file to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.Write Method

Grid Solutions Framework MetadataFileWrite Method
Overload List
 | Name | Description
Public method | Write(IEnumerableMetadataRecord) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory. (Overrides IsamDataFileBaseTWrite(IEnumerableT).)
Public method | Write(Int32, MetadataRecord) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory. (Overrides IsamDataFileBaseTWrite(Int32, T).)
Top
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.Write Method (IEnumerable(MetadataRecord))

Grid Solutions Framework MetadataFileWrite Method (IEnumerableMetadataRecord)
Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    IEnumerable<MetadataRecord> records
)
Public Overrides Sub Write (
    records As IEnumerable(Of MetadataRecord)
)
abstract Write :
        records : IEnumerable<MetadataRecord> -> unit
override Write :
        records : IEnumerable<MetadataRecord> -> unit
function Write(records);
public:
virtual void Write(
    IEnumerable<MetadataRecord^>^ records
) override

Parameters

records
Type: System.Collections.GenericIEnumerable MetadataRecord
Records to be written.
Remarks
This operation will causes existing records to be deleted and replaced with the ones specified.
See Also

Reference

MetadataFile Class
Write Overload
GSF.Historian.Files Namespace


MetadataFile.Write Method (Int32, MetadataRecord)

Grid Solutions Framework MetadataFileWrite Method (Int32, MetadataRecord)
Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    int recordIndex,
    MetadataRecord record
)
Public Overrides Sub Write (
    recordIndex As Integer,
    record As MetadataRecord
)
abstract Write :
        recordIndex : int *
        record : MetadataRecord -> unit
override Write :
        recordIndex : int *
        record : MetadataRecord -> unit
function Write(recordIndex, record);
public:
virtual void Write(
    int recordIndex,
    MetadataRecord^ record
) override

Parameters

recordIndex
Type: SystemInt32
1-based index of the record to be written.
record
Type: GSF.Historian.FilesMetadataRecord
Record to be written.
See Also

Reference

MetadataFile Class
Write Overload
GSF.Historian.Files Namespace


MetadataFile Properties

Grid Solutions Framework MetadataFile Properties

The MetadataFile type exposes the following members.

Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk. (Inherited from IsamDataFileBaseT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled. (Inherited from IsamDataFileBaseT.)
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileData | Gets the underlying FileStream of the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileDataLock | Gets the locking object for the FileData stream. (Inherited from IsamDataFileBaseT.)
Public property | FileName | Gets or sets the name of the file. (Overrides IsamDataFileBaseTFileName.)
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt. (Overrides IsamDataFileBaseTIsCorrupt.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from IsamDataFileBaseT.)
Public property | IsOpen | Gets a boolean value that indicates whether the file is open. (Inherited from IsamDataFileBaseT.)
Public property | LegacyMode | Determines legacy operation mode for the MetadataFile.
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened. (Inherited from IsamDataFileBaseT.)
Protected property | LoadWaitHandle | Gets wait handle for loading data. (Inherited from IsamDataFileBaseT.)
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file. (Inherited from IsamDataFileBaseT.)
Public property | Name | Gets the unique identifier of the file. (Inherited from IsamDataFileBaseT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file. (Inherited from IsamDataFileBaseT.)
Public property | RecordsInMemory | Gets the number of file records loaded in memory. (Overrides IsamDataFileBaseTRecordsInMemory.)
Public property | RecordsOnDisk | Gets the number of file records on the disk. (Overrides IsamDataFileBaseTRecordsOnDisk.)
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk. (Inherited from IsamDataFileBaseT.)
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed. (Inherited from IsamDataFileBaseT.)
Protected property | SaveWaitHandle | Gets wait handle for saving data. (Inherited from IsamDataFileBaseT.)
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public property | Status | Gets the descriptive status of the MetadataFile. (Overrides IsamDataFileBaseTStatus.)
Top
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.FileName Property

Grid Solutions Framework MetadataFileFileName Property
Gets or sets the name of the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string FileName { get; set; }
Public Overrides Property FileName As String
    Get
    Set
abstract FileName : string with get, set
override FileName : string with get, set
function get_FileName();
function set_FileName(value);
public:
virtual property String^ FileName {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String
Remarks
Changing the FileName when the file is open will cause the file to be re-opened.
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.IsCorrupt Property

Grid Solutions Framework MetadataFileIsCorrupt Property
Gets a boolean value that indicates whether the file data on disk is corrupt.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool IsCorrupt { get; }
Public Overrides ReadOnly Property IsCorrupt As Boolean
    Get
abstract IsCorrupt : bool with get
override IsCorrupt : bool with get
function get_IsCorrupt();

public:
virtual property bool IsCorrupt {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.LegacyMode Property

Grid Solutions Framework MetadataFileLegacyMode Property
Determines legacy operation mode for the MetadataFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataFileLegacyMode LegacyMode { get; set; }
Public Property LegacyMode As MetadataFileLegacyMode
    Get
    Set
member LegacyMode : MetadataFileLegacyMode with get, set

function get_LegacyMode();
function set_LegacyMode(value);
public:
property MetadataFileLegacyMode LegacyMode {
    MetadataFileLegacyMode get ();
    void set (MetadataFileLegacyMode value);
}

Property Value

Type: MetadataFileLegacyMode
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.RecordsInMemory Property

Grid Solutions Framework MetadataFileRecordsInMemory Property
Gets the number of file records loaded in memory.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int RecordsInMemory { get; }
Public Overrides ReadOnly Property RecordsInMemory As Integer
    Get
abstract RecordsInMemory : int with get
override RecordsInMemory : int with get
function get_RecordsInMemory();

public:
virtual property int RecordsInMemory {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.RecordsOnDisk Property

Grid Solutions Framework MetadataFileRecordsOnDisk Property
Gets the number of file records on the disk.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int RecordsOnDisk { get; }
Public Overrides ReadOnly Property RecordsOnDisk As Integer
    Get
abstract RecordsOnDisk : int with get
override RecordsOnDisk : int with get
function get_RecordsOnDisk();

public:
virtual property int RecordsOnDisk {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile.Status Property

Grid Solutions Framework MetadataFileStatus Property
Gets the descriptive status of the MetadataFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFile Events

Grid Solutions Framework MetadataFile Events

The MetadataFile type exposes the following members.

Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataLoading | Occurs when data is being read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataSaved | Occurs when data has been saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | DataSaving | Occurs when data is being saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from IsamDataFileBaseT.)
Public event | FileModified | Occurs when file data on the disk is modified. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

MetadataFile Class
GSF.Historian.Files Namespace


MetadataFileLegacyMode Enumeration

Grid Solutions Framework MetadataFileLegacyMode Enumeration
Defines legacy operational modes for the MetadataFile.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum MetadataFileLegacyMode
Public Enumeration MetadataFileLegacyMode
type MetadataFileLegacyMode
GSF.Historian.Files.MetadataFileLegacyMode = function();
GSF.Historian.Files.MetadataFileLegacyMode.createEnum('GSF.Historian.Files.MetadataFileLegacyMode', false);
public enum class MetadataFileLegacyMode
Members
Member name | Value | Description
Disabled | 0 | Only use new "..._dbase.dat2" format.
Compatible | 1 | Use new "..._dbase.dat2" format and also maintain a legacy "..._dbase.dat" file.
Enabled | 2 | Only use legacy "..._dbase.dat" file.
See Also

Reference

GSF.Historian.Files Namespace


MetadataRecord Class

Grid Solutions Framework MetadataRecord Class
Represents a record in the MetadataFile that contains the various attributes associates to a HistorianID.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecord

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecord : ISupportBinaryImage,
    IComparable
Public Class MetadataRecord
    Implements ISupportBinaryImage, IComparable
type MetadataRecord =
    class
        interface ISupportBinaryImage
        interface IComparable
    end
GSF.Historian.Files.MetadataRecord = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecord',
    null,
    GSF.Parsing.ISupportBinaryImage,
    IComparable);
public ref class MetadataRecord : ISupportBinaryImage,
    IComparable

The MetadataRecord type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataRecord(Int32, MetadataFileLegacyMode) | Initializes a new instance of the MetadataRecord class.
Public method | MetadataRecord(Int32, MetadataFileLegacyMode, Byte, Int32, Int32) | Initializes a new instance of the MetadataRecord class.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current MetadataRecord object to obj.
Public method | Equals | Determines whether the current MetadataRecord object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecord and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Returns the hash code for the current MetadataRecord object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecord from the specified buffer.
Public method | ToString | Returns the text representation of MetadataRecord object. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecord.
Top
Properties
 | Name | Description
Public property | AlarmEmails | Gets or sets a comma-separated list of email addresses that will receive alarm notification email messages based on the AlarmFlags settings for the HistorianID.
Public property | AlarmFlags | Gets or sets the MetadataRecordAlarmFlags associated with the HistorianID.
Public property | AlarmPagers | Gets or sets a comma-separated list of pager numbers that will receive alarm notification text messages based on the AlarmFlags settings for the HistorianID.
Public property | AlarmPhones | Gets or sets a comma-separated list of phone numbers that will receive alarm notification voice messages based on the AlarmFlags settings for the HistorianID.
Public property | AnalogFields | Gets or sets the MetadataRecordAnalogFields associated with the HistorianID.
Public property | BinaryLength | Gets the length of the MetadataRecord.
Public property | ComposedFields | Gets or sets the MetadataRecordComposedFields associated with the HistorianID.
Public property | CompressionMaxTime | Gets or sets the maximum time (in seconds) after which data is to be archived for the HistorianID.
Public property | CompressionMinTime | Gets or sets the minimum allowable time (in seconds) between archived data for the HistorianID.
Public property | ConstantFields | Gets or sets the MetadataRecordConstantFields associated with the HistorianID.
Public property | CurrentData | Gets or sets the time, value and quality of the most current data received for the HistorianID.
Public property | Description | Gets or sets the description associated with the HistorianID.
Public property | DigitalFields | Gets or sets the MetadataRecordDigitalFields associated with the HistorianID.
Public property | EmailTime | Gets or sets the data and time when an alarm notification is sent based on the AlarmFlags settings for the HistorianID.
Public property | GeneralFlags | Gets or sets the MetadataRecordGeneralFlags associated with the HistorianID.
Public property | HardwareInfo | Gets or sets hardware information associated with the HistorianID.
Public property | HistorianID | Gets the historian identifier of MetadataRecord.
Public property | Name | Gets or sets a alpha-numeric name for the HistorianID.
Public property | PlantCode | Gets or sets the name of the plant to which the HistorianID is associated.
Public property | Remarks | Gets or sets any remarks associated with the HistorianID.
Public property | ScanRate | Gets or sets the rate at which the source device scans and sends data for the HistorianID.
Public property | SecurityFlags | Gets or sets the MetadataRecordSecurityFlags associated with the HistorianID.
Public property | SourceID | Gets or sets the numeric identifier of the data source for the HistorianID.
Public property | Summary | Gets the MetadataRecordSummary object for MetadataRecord.
Public property | Synonym1 | Gets or sets an alternate Name for the HistorianID.
Public property | Synonym2 | Gets or sets an alternate Name for the HistorianID.
Public property | Synonym3 | Gets or sets an alternate Name for the HistorianID.
Public property | SystemName | Gets or sets the alpha-numeric system identifier for the HistorianID.
Public property | UnitNumber | Gets or sets the unit (i.e. generator) to which the HistorianID is associated.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataFile
GSF.Historian.FilesMetadataRecordAlarmFlags
GSF.Historian.FilesMetadataRecordGeneralFlags
GSF.Historian.FilesMetadataRecordSecurityFlags
GSF.Historian.FilesMetadataRecordAnalogFields
GSF.Historian.FilesMetadataRecordComposedFields
GSF.Historian.FilesMetadataRecordConstantFields
GSF.Historian.FilesMetadataRecordDigitalFields
GSF.Historian.FilesMetadataRecordSummary


MetadataRecord Constructor

Grid Solutions Framework MetadataRecord Constructor
Overload List
 | Name | Description
Public method | MetadataRecord(Int32, MetadataFileLegacyMode) | Initializes a new instance of the MetadataRecord class.
Public method | MetadataRecord(Int32, MetadataFileLegacyMode, Byte, Int32, Int32) | Initializes a new instance of the MetadataRecord class.
Top
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord Constructor (Int32, MetadataFileLegacyMode)

Grid Solutions Framework MetadataRecord Constructor (Int32, MetadataFileLegacyMode)
Initializes a new instance of the MetadataRecord class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecord(
    int historianID,
    MetadataFileLegacyMode legacyMode
)
Public Sub New (
    historianID As Integer,
    legacyMode As MetadataFileLegacyMode
)
new :
        historianID : int *
        legacyMode : MetadataFileLegacyMode -> MetadataRecord
GSF.Historian.Files.MetadataRecord = function(historianID, legacyMode);
public:
MetadataRecord(
    int historianID,
    MetadataFileLegacyMode legacyMode
)

Parameters

historianID
Type: SystemInt32
Historian identifier of MetadataRecord.
legacyMode
Type: GSF.Historian.FilesMetadataFileLegacyMode
Legacy mode of MetadataFile.
See Also

Reference

MetadataRecord Class
MetadataRecord Overload
GSF.Historian.Files Namespace


MetadataRecord Constructor (Int32, MetadataFileLegacyMode, Byte[], Int32, Int32)

Grid Solutions Framework MetadataRecord Constructor (Int32, MetadataFileLegacyMode, Byte, Int32, Int32)
Initializes a new instance of the MetadataRecord class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecord(
    int historianID,
    MetadataFileLegacyMode legacyMode,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    historianID As Integer,
    legacyMode As MetadataFileLegacyMode,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        historianID : int *
        legacyMode : MetadataFileLegacyMode *
        buffer : byte[] *
        startIndex : int *
        length : int -> MetadataRecord
GSF.Historian.Files.MetadataRecord = function(historianID, legacyMode, buffer, startIndex, length);
public:
MetadataRecord(
    int historianID,
    MetadataFileLegacyMode legacyMode,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

historianID
Type: SystemInt32
Historian identifier of MetadataRecord.
legacyMode
Type: GSF.Historian.FilesMetadataFileLegacyMode
Legacy mode of MetadataFile.
buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecord.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

MetadataRecord Class
MetadataRecord Overload
GSF.Historian.Files Namespace


MetadataRecord Fields

Grid Solutions Framework MetadataRecord Fields

The MetadataRecord type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecord.
Top
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.FixedLength Field

Grid Solutions Framework MetadataRecordFixedLength Field
Specifies the number of bytes in the binary image of MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.MetadataRecord.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord Methods

Grid Solutions Framework MetadataRecord Methods

The MetadataRecord type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current MetadataRecord object to obj.
Public method | Equals | Determines whether the current MetadataRecord object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecord and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Returns the hash code for the current MetadataRecord object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecord from the specified buffer.
Public method | ToString | Returns the text representation of MetadataRecord object. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.CompareTo Method

Grid Solutions Framework MetadataRecordCompareTo Method
Compares the current MetadataRecord object to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
Object against which the current MetadataRecord object is to be compared.

Return Value

Type: Int32
Negative value if the current MetadataRecord object is less than obj, Zero if the current MetadataRecord object is equal to obj, Positive value if the current MetadataRecord object is greater than obj.

Implements

IComparableCompareTo(Object)
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Equals Method

Grid Solutions Framework MetadataRecordEquals Method
Determines whether the current MetadataRecord object is equal to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current MetadataRecord object is to be compared for equality.

Return Value

Type: Boolean
true if the current MetadataRecord object is equal to obj; otherwise false.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.GenerateBinaryImage Method

Grid Solutions Framework MetadataRecordGenerateBinaryImage Method
Generates binary image of the MetadataRecord and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.GetHashCode Method

Grid Solutions Framework MetadataRecordGetHashCode Method
Returns the hash code for the current MetadataRecord object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.ParseBinaryImage Method

Grid Solutions Framework MetadataRecordParseBinaryImage Method
Initializes MetadataRecord from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecord.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing MetadataRecord.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.ToString Method

Grid Solutions Framework MetadataRecordToString Method
Returns the text representation of MetadataRecord object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String value.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord Properties

Grid Solutions Framework MetadataRecord Properties

The MetadataRecord type exposes the following members.

Properties
 | Name | Description
Public property | AlarmEmails | Gets or sets a comma-separated list of email addresses that will receive alarm notification email messages based on the AlarmFlags settings for the HistorianID.
Public property | AlarmFlags | Gets or sets the MetadataRecordAlarmFlags associated with the HistorianID.
Public property | AlarmPagers | Gets or sets a comma-separated list of pager numbers that will receive alarm notification text messages based on the AlarmFlags settings for the HistorianID.
Public property | AlarmPhones | Gets or sets a comma-separated list of phone numbers that will receive alarm notification voice messages based on the AlarmFlags settings for the HistorianID.
Public property | AnalogFields | Gets or sets the MetadataRecordAnalogFields associated with the HistorianID.
Public property | BinaryLength | Gets the length of the MetadataRecord.
Public property | ComposedFields | Gets or sets the MetadataRecordComposedFields associated with the HistorianID.
Public property | CompressionMaxTime | Gets or sets the maximum time (in seconds) after which data is to be archived for the HistorianID.
Public property | CompressionMinTime | Gets or sets the minimum allowable time (in seconds) between archived data for the HistorianID.
Public property | ConstantFields | Gets or sets the MetadataRecordConstantFields associated with the HistorianID.
Public property | CurrentData | Gets or sets the time, value and quality of the most current data received for the HistorianID.
Public property | Description | Gets or sets the description associated with the HistorianID.
Public property | DigitalFields | Gets or sets the MetadataRecordDigitalFields associated with the HistorianID.
Public property | EmailTime | Gets or sets the data and time when an alarm notification is sent based on the AlarmFlags settings for the HistorianID.
Public property | GeneralFlags | Gets or sets the MetadataRecordGeneralFlags associated with the HistorianID.
Public property | HardwareInfo | Gets or sets hardware information associated with the HistorianID.
Public property | HistorianID | Gets the historian identifier of MetadataRecord.
Public property | Name | Gets or sets a alpha-numeric name for the HistorianID.
Public property | PlantCode | Gets or sets the name of the plant to which the HistorianID is associated.
Public property | Remarks | Gets or sets any remarks associated with the HistorianID.
Public property | ScanRate | Gets or sets the rate at which the source device scans and sends data for the HistorianID.
Public property | SecurityFlags | Gets or sets the MetadataRecordSecurityFlags associated with the HistorianID.
Public property | SourceID | Gets or sets the numeric identifier of the data source for the HistorianID.
Public property | Summary | Gets the MetadataRecordSummary object for MetadataRecord.
Public property | Synonym1 | Gets or sets an alternate Name for the HistorianID.
Public property | Synonym2 | Gets or sets an alternate Name for the HistorianID.
Public property | Synonym3 | Gets or sets an alternate Name for the HistorianID.
Public property | SystemName | Gets or sets the alpha-numeric system identifier for the HistorianID.
Public property | UnitNumber | Gets or sets the unit (i.e. generator) to which the HistorianID is associated.
Top
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.AlarmEmails Property

Grid Solutions Framework MetadataRecordAlarmEmails Property
Gets or sets a comma-separated list of email addresses that will receive alarm notification email messages based on the AlarmFlags settings for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AlarmEmails { get; set; }
Public Property AlarmEmails As String
    Get
    Set
member AlarmEmails : string with get, set

function get_AlarmEmails();
function set_AlarmEmails(value);
public:
property String^ AlarmEmails {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for AlarmEmails is 512 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.AlarmFlags Property

Grid Solutions Framework MetadataRecordAlarmFlags Property
Gets or sets the MetadataRecordAlarmFlags associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordAlarmFlags AlarmFlags { get; set; }
Public Property AlarmFlags As MetadataRecordAlarmFlags
    Get
    Set
member AlarmFlags : MetadataRecordAlarmFlags with get, set

function get_AlarmFlags();
function set_AlarmFlags(value);
public:
property MetadataRecordAlarmFlags^ AlarmFlags {
    MetadataRecordAlarmFlags^ get ();
    void set (MetadataRecordAlarmFlags^ value);
}

Property Value

Type: MetadataRecordAlarmFlags
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.AlarmPagers Property

Grid Solutions Framework MetadataRecordAlarmPagers Property
Gets or sets a comma-separated list of pager numbers that will receive alarm notification text messages based on the AlarmFlags settings for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AlarmPagers { get; set; }
Public Property AlarmPagers As String
    Get
    Set
member AlarmPagers : string with get, set

function get_AlarmPagers();
function set_AlarmPagers(value);
public:
property String^ AlarmPagers {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for AlarmPagers is 40 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.AlarmPhones Property

Grid Solutions Framework MetadataRecordAlarmPhones Property
Gets or sets a comma-separated list of phone numbers that will receive alarm notification voice messages based on the AlarmFlags settings for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AlarmPhones { get; set; }
Public Property AlarmPhones As String
    Get
    Set
member AlarmPhones : string with get, set

function get_AlarmPhones();
function set_AlarmPhones(value);
public:
property String^ AlarmPhones {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for AlarmPhones is 40 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.AnalogFields Property

Grid Solutions Framework MetadataRecordAnalogFields Property
Gets or sets the MetadataRecordAnalogFields associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordAnalogFields AnalogFields { get; set; }
Public Property AnalogFields As MetadataRecordAnalogFields
    Get
    Set
member AnalogFields : MetadataRecordAnalogFields with get, set

function get_AnalogFields();
function set_AnalogFields(value);
public:
property MetadataRecordAnalogFields^ AnalogFields {
    MetadataRecordAnalogFields^ get ();
    void set (MetadataRecordAnalogFields^ value);
}

Property Value

Type: MetadataRecordAnalogFields
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.BinaryLength Property

Grid Solutions Framework MetadataRecordBinaryLength Property
Gets the length of the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.ComposedFields Property

Grid Solutions Framework MetadataRecordComposedFields Property
Gets or sets the MetadataRecordComposedFields associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordComposedFields ComposedFields { get; set; }
Public Property ComposedFields As MetadataRecordComposedFields
    Get
    Set
member ComposedFields : MetadataRecordComposedFields with get, set

function get_ComposedFields();
function set_ComposedFields(value);
public:
property MetadataRecordComposedFields^ ComposedFields {
    MetadataRecordComposedFields^ get ();
    void set (MetadataRecordComposedFields^ value);
}

Property Value

Type: MetadataRecordComposedFields
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.CompressionMaxTime Property

Grid Solutions Framework MetadataRecordCompressionMaxTime Property
Gets or sets the maximum time (in seconds) after which data is to be archived for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompressionMaxTime { get; set; }
Public Property CompressionMaxTime As Integer
    Get
    Set
member CompressionMaxTime : int with get, set

function get_CompressionMaxTime();
function set_CompressionMaxTime(value);
public:
property int CompressionMaxTime {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
CompressionMaxTime ensures that archived data exist every "n" seconds for the HistorianID, which would otherwise be omitted due to compression.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.CompressionMinTime Property

Grid Solutions Framework MetadataRecordCompressionMinTime Property
Gets or sets the minimum allowable time (in seconds) between archived data for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompressionMinTime { get; set; }
Public Property CompressionMinTime As Integer
    Get
    Set
member CompressionMinTime : int with get, set

function get_CompressionMinTime();
function set_CompressionMinTime(value);
public:
property int CompressionMinTime {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
CompressionMinTime is useful for limiting archived data for noisy HistorianIDs.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.ConstantFields Property

Grid Solutions Framework MetadataRecordConstantFields Property
Gets or sets the MetadataRecordConstantFields associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordConstantFields ConstantFields { get; set; }
Public Property ConstantFields As MetadataRecordConstantFields
    Get
    Set
member ConstantFields : MetadataRecordConstantFields with get, set

function get_ConstantFields();
function set_ConstantFields(value);
public:
property MetadataRecordConstantFields^ ConstantFields {
    MetadataRecordConstantFields^ get ();
    void set (MetadataRecordConstantFields^ value);
}

Property Value

Type: MetadataRecordConstantFields
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.CurrentData Property

Grid Solutions Framework MetadataRecordCurrentData Property
Gets or sets the time, value and quality of the most current data received for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CurrentData { get; set; }
Public Property CurrentData As String
    Get
    Set
member CurrentData : string with get, set

function get_CurrentData();
function set_CurrentData(value);
public:
property String^ CurrentData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for CurrentData is 80 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Description Property

Grid Solutions Framework MetadataRecordDescription Property
Gets or sets the description associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
member Description : string with get, set

function get_Description();
function set_Description(value);
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for Description is 80 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.DigitalFields Property

Grid Solutions Framework MetadataRecordDigitalFields Property
Gets or sets the MetadataRecordDigitalFields associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordDigitalFields DigitalFields { get; set; }
Public Property DigitalFields As MetadataRecordDigitalFields
    Get
    Set
member DigitalFields : MetadataRecordDigitalFields with get, set

function get_DigitalFields();
function set_DigitalFields(value);
public:
property MetadataRecordDigitalFields^ DigitalFields {
    MetadataRecordDigitalFields^ get ();
    void set (MetadataRecordDigitalFields^ value);
}

Property Value

Type: MetadataRecordDigitalFields
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.EmailTime Property

Grid Solutions Framework MetadataRecordEmailTime Property
Gets or sets the data and time when an alarm notification is sent based on the AlarmFlags settings for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string EmailTime { get; set; }
Public Property EmailTime As String
    Get
    Set
member EmailTime : string with get, set

function get_EmailTime();
function set_EmailTime(value);
public:
property String^ EmailTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for EmailTime is 40 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.GeneralFlags Property

Grid Solutions Framework MetadataRecordGeneralFlags Property
Gets or sets the MetadataRecordGeneralFlags associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordGeneralFlags GeneralFlags { get; set; }
Public Property GeneralFlags As MetadataRecordGeneralFlags
    Get
    Set
member GeneralFlags : MetadataRecordGeneralFlags with get, set

function get_GeneralFlags();
function set_GeneralFlags(value);
public:
property MetadataRecordGeneralFlags^ GeneralFlags {
    MetadataRecordGeneralFlags^ get ();
    void set (MetadataRecordGeneralFlags^ value);
}

Property Value

Type: MetadataRecordGeneralFlags
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.HardwareInfo Property

Grid Solutions Framework MetadataRecordHardwareInfo Property
Gets or sets hardware information associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string HardwareInfo { get; set; }
Public Property HardwareInfo As String
    Get
    Set
member HardwareInfo : string with get, set

function get_HardwareInfo();
function set_HardwareInfo(value);
public:
property String^ HardwareInfo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for HardwareInfo is 512 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.HistorianID Property

Grid Solutions Framework MetadataRecordHistorianID Property
Gets the historian identifier of MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; }
Public ReadOnly Property HistorianID As Integer
    Get
member HistorianID : int with get

function get_HistorianID();

public:
property int HistorianID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Name Property

Grid Solutions Framework MetadataRecordName Property
Gets or sets a alpha-numeric name for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for Name is 40 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.PlantCode Property

Grid Solutions Framework MetadataRecordPlantCode Property
Gets or sets the name of the plant to which the HistorianID is associated.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string PlantCode { get; set; }
Public Property PlantCode As String
    Get
    Set
member PlantCode : string with get, set

function get_PlantCode();
function set_PlantCode(value);
public:
property String^ PlantCode {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for PlantCode is 24 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Remarks Property

Grid Solutions Framework MetadataRecordRemarks Property
Gets or sets any remarks associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Remarks { get; set; }
Public Property Remarks As String
    Get
    Set
member Remarks : string with get, set

function get_Remarks();
function set_Remarks(value);
public:
property String^ Remarks {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for Remarks is 512 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.ScanRate Property

Grid Solutions Framework MetadataRecordScanRate Property
Gets or sets the rate at which the source device scans and sends data for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ScanRate { get; set; }
Public Property ScanRate As Single
    Get
    Set
member ScanRate : float32 with get, set

function get_ScanRate();
function set_ScanRate(value);
public:
property float ScanRate {
    float get ();
    void set (float value);
}

Property Value

Type: Single
Remarks
ScanRate is used by data acquisition components for polling data from the actual device.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.SecurityFlags Property

Grid Solutions Framework MetadataRecordSecurityFlags Property
Gets or sets the MetadataRecordSecurityFlags associated with the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordSecurityFlags SecurityFlags { get; set; }
Public Property SecurityFlags As MetadataRecordSecurityFlags
    Get
    Set
member SecurityFlags : MetadataRecordSecurityFlags with get, set

function get_SecurityFlags();
function set_SecurityFlags(value);
public:
property MetadataRecordSecurityFlags^ SecurityFlags {
    MetadataRecordSecurityFlags^ get ();
    void set (MetadataRecordSecurityFlags^ value);
}

Property Value

Type: MetadataRecordSecurityFlags
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.SourceID Property

Grid Solutions Framework MetadataRecordSourceID Property
Gets or sets the numeric identifier of the data source for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SourceID { get; set; }
Public Property SourceID As Integer
    Get
    Set
member SourceID : int with get, set

function get_SourceID();
function set_SourceID(value);
public:
property int SourceID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or zero.
Remarks
SourceID is used for the determination of "global time" when that client option is in effect. When "global time" is in effect, the historian returns the current data time for a HistorianID based on the latest time received for all HistorianIDs with the same SourceID.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Summary Property

Grid Solutions Framework MetadataRecordSummary Property
Gets the MetadataRecordSummary object for MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordSummary Summary { get; }
Public ReadOnly Property Summary As MetadataRecordSummary
    Get
member Summary : MetadataRecordSummary with get

function get_Summary();

public:
property MetadataRecordSummary^ Summary {
    MetadataRecordSummary^ get ();
}

Property Value

Type: MetadataRecordSummary
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Synonym1 Property

Grid Solutions Framework MetadataRecordSynonym1 Property
Gets or sets an alternate Name for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Synonym1 { get; set; }
Public Property Synonym1 As String
    Get
    Set
member Synonym1 : string with get, set

function get_Synonym1();
function set_Synonym1(value);
public:
property String^ Synonym1 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for Synonym1 is 40 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Synonym2 Property

Grid Solutions Framework MetadataRecordSynonym2 Property
Gets or sets an alternate Name for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Synonym2 { get; set; }
Public Property Synonym2 As String
    Get
    Set
member Synonym2 : string with get, set

function get_Synonym2();
function set_Synonym2(value);
public:
property String^ Synonym2 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for Synonym2 is 40 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.Synonym3 Property

Grid Solutions Framework MetadataRecordSynonym3 Property
Gets or sets an alternate Name for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Synonym3 { get; set; }
Public Property Synonym3 As String
    Get
    Set
member Synonym3 : string with get, set

function get_Synonym3();
function set_Synonym3(value);
public:
property String^ Synonym3 {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for Synonym3 is 40 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.SystemName Property

Grid Solutions Framework MetadataRecordSystemName Property
Gets or sets the alpha-numeric system identifier for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SystemName { get; set; }
Public Property SystemName As String
    Get
    Set
member SystemName : string with get, set

function get_SystemName();
function set_SystemName(value);
public:
property String^ SystemName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null string.
Remarks
Maximum length for SystemName is 24 characters.
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecord.UnitNumber Property

Grid Solutions Framework MetadataRecordUnitNumber Property
Gets or sets the unit (i.e. generator) to which the HistorianID is associated.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int UnitNumber { get; set; }
Public Property UnitNumber As Integer
    Get
    Set
member UnitNumber : int with get, set

function get_UnitNumber();
function set_UnitNumber(value);
public:
property int UnitNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecord Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags Class

Grid Solutions Framework MetadataRecordAlarmFlags Class
Defines which data Quality should trigger an alarm notification.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordAlarmFlags

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordAlarmFlags
Public Class MetadataRecordAlarmFlags
type MetadataRecordAlarmFlags =  class end
GSF.Historian.Files.MetadataRecordAlarmFlags = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordAlarmFlags');
public ref class MetadataRecordAlarmFlags

The MetadataRecordAlarmFlags type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataRecordAlarmFlags | Initializes a new instance of the MetadataRecordAlarmFlags class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CouldNotCalculate | Gets or sets a boolean value that indicates whether a data Quality of CouldNotCalculate should trigger an alarm notification.
Public property | DeletedFromAlarmChecks | Gets or sets a boolean value that indicates whether a data Quality of DeletedFromAlarmChecks should trigger an alarm notification.
Public property | DeletedFromProcessing | Gets or sets a boolean value that indicates whether a data Quality of DeletedFromProcessing should trigger an alarm notification.
Public property | DigitalInsertedStatusInAlarm | Gets or sets a boolean value that indicates whether a data Quality of DigitalInsertedStatusInAlarm should trigger an alarm notification.
Public property | DigitalSuspectAlarm | Gets or sets a boolean value that indicates whether a data Quality of DigitalSuspectAlarm should trigger an alarm notification.
Public property | FrontEndHardwareError | Gets or sets a boolean value that indicates whether a data Quality of FrontEndHardwareError should trigger an alarm notification.
Public property | Good | Gets or sets a boolean value that indicates whether a data Quality of Good should trigger an alarm notification.
Public property | InhibitedByCutoutPoint | Gets or sets a boolean value that indicates whether a data Quality of InhibitedByCutoutPoint should trigger an alarm notification.
Public property | InputCountsOutOfSensorRange | Gets or sets a boolean value that indicates whether a data Quality of InputCountsOutOfSensorRange should trigger an alarm notification.
Public property | InsertedValue | Gets or sets a boolean value that indicates whether a data Quality of InsertedValue should trigger an alarm notification.
Public property | InsertedValueAboveHiHiLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueAboveHiHiLimit should trigger an alarm notification.
Public property | InsertedValueAboveHiLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueAboveHiLimit should trigger an alarm notification.
Public property | InsertedValueBelowLoLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueBelowLoLimit should trigger an alarm notification.
Public property | InsertedValueBelowLoLoLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueBelowLoLoLimit should trigger an alarm notification.
Public property | LogicalAlarm | Gets or sets a boolean value that indicates whether a data Quality of LogicalAlarm should trigger an alarm notification.
Public property | Old | Gets or sets a boolean value that indicates whether a data Quality of Old should trigger an alarm notification.
Public property | OpenThermocouple | Gets or sets a boolean value that indicates whether a data Quality of OpenThermocouple should trigger an alarm notification.
Public property | SensorReadError | Gets or sets a boolean value that indicates whether a data Quality of SensorReadError should trigger an alarm notification.
Public property | SuspectData | Gets or sets a boolean value that indicates whether a data Quality of SuspectData should trigger an alarm notification.
Public property | SuspectValueAboveHiHiLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueAboveHiHiLimit should trigger an alarm notification.
Public property | SuspectValueAboveHiLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueAboveHiLimit should trigger an alarm notification.
Public property | SuspectValueBelowLoLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueBelowLoLimit should trigger an alarm notification.
Public property | SuspectValueBelowLoLoLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueBelowLoLoLimit should trigger an alarm notification.
Public property | Unknown | Gets or sets a boolean value that indicates whether a data Quality of Unknown should trigger an alarm notification.
Public property | UnreasonableHigh | Gets or sets a boolean value that indicates whether a data Quality of UnreasonableHigh should trigger an alarm notification.
Public property | UnreasonableLow | Gets or sets a boolean value that indicates whether a data Quality of UnreasonableLow should trigger an alarm notification.
Public property | Value | Gets or sets the 32-bit integer value used for defining which data Quality should trigger an alarm notification.
Public property | ValueAboveHiAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueAboveHiAlarm should trigger an alarm notification.
Public property | ValueAboveHiHiAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueAboveHiHiAlarm should trigger an alarm notification.
Public property | ValueBelowLoAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueBelowLoAlarm should trigger an alarm notification.
Public property | ValueBelowLoLoAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueBelowLoLoAlarm should trigger an alarm notification.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordAlarmFlags Constructor

Grid Solutions Framework MetadataRecordAlarmFlags Constructor
Initializes a new instance of the MetadataRecordAlarmFlags class

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordAlarmFlags()
Public Sub New
new : unit -> MetadataRecordAlarmFlags
GSF.Historian.Files.MetadataRecordAlarmFlags = function();
public:
MetadataRecordAlarmFlags()
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags Methods

Grid Solutions Framework MetadataRecordAlarmFlags Methods

The MetadataRecordAlarmFlags type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags Properties

Grid Solutions Framework MetadataRecordAlarmFlags Properties

The MetadataRecordAlarmFlags type exposes the following members.

Properties
 | Name | Description
Public property | CouldNotCalculate | Gets or sets a boolean value that indicates whether a data Quality of CouldNotCalculate should trigger an alarm notification.
Public property | DeletedFromAlarmChecks | Gets or sets a boolean value that indicates whether a data Quality of DeletedFromAlarmChecks should trigger an alarm notification.
Public property | DeletedFromProcessing | Gets or sets a boolean value that indicates whether a data Quality of DeletedFromProcessing should trigger an alarm notification.
Public property | DigitalInsertedStatusInAlarm | Gets or sets a boolean value that indicates whether a data Quality of DigitalInsertedStatusInAlarm should trigger an alarm notification.
Public property | DigitalSuspectAlarm | Gets or sets a boolean value that indicates whether a data Quality of DigitalSuspectAlarm should trigger an alarm notification.
Public property | FrontEndHardwareError | Gets or sets a boolean value that indicates whether a data Quality of FrontEndHardwareError should trigger an alarm notification.
Public property | Good | Gets or sets a boolean value that indicates whether a data Quality of Good should trigger an alarm notification.
Public property | InhibitedByCutoutPoint | Gets or sets a boolean value that indicates whether a data Quality of InhibitedByCutoutPoint should trigger an alarm notification.
Public property | InputCountsOutOfSensorRange | Gets or sets a boolean value that indicates whether a data Quality of InputCountsOutOfSensorRange should trigger an alarm notification.
Public property | InsertedValue | Gets or sets a boolean value that indicates whether a data Quality of InsertedValue should trigger an alarm notification.
Public property | InsertedValueAboveHiHiLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueAboveHiHiLimit should trigger an alarm notification.
Public property | InsertedValueAboveHiLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueAboveHiLimit should trigger an alarm notification.
Public property | InsertedValueBelowLoLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueBelowLoLimit should trigger an alarm notification.
Public property | InsertedValueBelowLoLoLimit | Gets or sets a boolean value that indicates whether a data Quality of InsertedValueBelowLoLoLimit should trigger an alarm notification.
Public property | LogicalAlarm | Gets or sets a boolean value that indicates whether a data Quality of LogicalAlarm should trigger an alarm notification.
Public property | Old | Gets or sets a boolean value that indicates whether a data Quality of Old should trigger an alarm notification.
Public property | OpenThermocouple | Gets or sets a boolean value that indicates whether a data Quality of OpenThermocouple should trigger an alarm notification.
Public property | SensorReadError | Gets or sets a boolean value that indicates whether a data Quality of SensorReadError should trigger an alarm notification.
Public property | SuspectData | Gets or sets a boolean value that indicates whether a data Quality of SuspectData should trigger an alarm notification.
Public property | SuspectValueAboveHiHiLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueAboveHiHiLimit should trigger an alarm notification.
Public property | SuspectValueAboveHiLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueAboveHiLimit should trigger an alarm notification.
Public property | SuspectValueBelowLoLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueBelowLoLimit should trigger an alarm notification.
Public property | SuspectValueBelowLoLoLimit | Gets or sets a boolean value that indicates whether a data Quality of SuspectValueBelowLoLoLimit should trigger an alarm notification.
Public property | Unknown | Gets or sets a boolean value that indicates whether a data Quality of Unknown should trigger an alarm notification.
Public property | UnreasonableHigh | Gets or sets a boolean value that indicates whether a data Quality of UnreasonableHigh should trigger an alarm notification.
Public property | UnreasonableLow | Gets or sets a boolean value that indicates whether a data Quality of UnreasonableLow should trigger an alarm notification.
Public property | Value | Gets or sets the 32-bit integer value used for defining which data Quality should trigger an alarm notification.
Public property | ValueAboveHiAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueAboveHiAlarm should trigger an alarm notification.
Public property | ValueAboveHiHiAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueAboveHiHiAlarm should trigger an alarm notification.
Public property | ValueBelowLoAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueBelowLoAlarm should trigger an alarm notification.
Public property | ValueBelowLoLoAlarm | Gets or sets a boolean value that indicates whether a data Quality of ValueBelowLoLoAlarm should trigger an alarm notification.
Top
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.CouldNotCalculate Property

Grid Solutions Framework MetadataRecordAlarmFlagsCouldNotCalculate Property
Gets or sets a boolean value that indicates whether a data Quality of CouldNotCalculate should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CouldNotCalculate { get; set; }
Public Property CouldNotCalculate As Boolean
    Get
    Set
member CouldNotCalculate : bool with get, set

function get_CouldNotCalculate();
function set_CouldNotCalculate(value);
public:
property bool CouldNotCalculate {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.DeletedFromAlarmChecks Property

Grid Solutions Framework MetadataRecordAlarmFlagsDeletedFromAlarmChecks Property
Gets or sets a boolean value that indicates whether a data Quality of DeletedFromAlarmChecks should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DeletedFromAlarmChecks { get; set; }
Public Property DeletedFromAlarmChecks As Boolean
    Get
    Set
member DeletedFromAlarmChecks : bool with get, set

function get_DeletedFromAlarmChecks();
function set_DeletedFromAlarmChecks(value);
public:
property bool DeletedFromAlarmChecks {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.DeletedFromProcessing Property

Grid Solutions Framework MetadataRecordAlarmFlagsDeletedFromProcessing Property
Gets or sets a boolean value that indicates whether a data Quality of DeletedFromProcessing should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DeletedFromProcessing { get; set; }
Public Property DeletedFromProcessing As Boolean
    Get
    Set
member DeletedFromProcessing : bool with get, set

function get_DeletedFromProcessing();
function set_DeletedFromProcessing(value);
public:
property bool DeletedFromProcessing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.DigitalInsertedStatusInAlarm Property

Grid Solutions Framework MetadataRecordAlarmFlagsDigitalInsertedStatusInAlarm Property
Gets or sets a boolean value that indicates whether a data Quality of DigitalInsertedStatusInAlarm should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DigitalInsertedStatusInAlarm { get; set; }
Public Property DigitalInsertedStatusInAlarm As Boolean
    Get
    Set
member DigitalInsertedStatusInAlarm : bool with get, set

function get_DigitalInsertedStatusInAlarm();
function set_DigitalInsertedStatusInAlarm(value);
public:
property bool DigitalInsertedStatusInAlarm {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.DigitalSuspectAlarm Property

Grid Solutions Framework MetadataRecordAlarmFlagsDigitalSuspectAlarm Property
Gets or sets a boolean value that indicates whether a data Quality of DigitalSuspectAlarm should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DigitalSuspectAlarm { get; set; }
Public Property DigitalSuspectAlarm As Boolean
    Get
    Set
member DigitalSuspectAlarm : bool with get, set

function get_DigitalSuspectAlarm();
function set_DigitalSuspectAlarm(value);
public:
property bool DigitalSuspectAlarm {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.FrontEndHardwareError Property

Grid Solutions Framework MetadataRecordAlarmFlagsFrontEndHardwareError Property
Gets or sets a boolean value that indicates whether a data Quality of FrontEndHardwareError should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool FrontEndHardwareError { get; set; }
Public Property FrontEndHardwareError As Boolean
    Get
    Set
member FrontEndHardwareError : bool with get, set

function get_FrontEndHardwareError();
function set_FrontEndHardwareError(value);
public:
property bool FrontEndHardwareError {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.Good Property

Grid Solutions Framework MetadataRecordAlarmFlagsGood Property
Gets or sets a boolean value that indicates whether a data Quality of Good should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Good { get; set; }
Public Property Good As Boolean
    Get
    Set
member Good : bool with get, set

function get_Good();
function set_Good(value);
public:
property bool Good {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.InhibitedByCutoutPoint Property

Grid Solutions Framework MetadataRecordAlarmFlagsInhibitedByCutoutPoint Property
Gets or sets a boolean value that indicates whether a data Quality of InhibitedByCutoutPoint should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InhibitedByCutoutPoint { get; set; }
Public Property InhibitedByCutoutPoint As Boolean
    Get
    Set
member InhibitedByCutoutPoint : bool with get, set

function get_InhibitedByCutoutPoint();
function set_InhibitedByCutoutPoint(value);
public:
property bool InhibitedByCutoutPoint {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.InputCountsOutOfSensorRange Property

Grid Solutions Framework MetadataRecordAlarmFlagsInputCountsOutOfSensorRange Property
Gets or sets a boolean value that indicates whether a data Quality of InputCountsOutOfSensorRange should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InputCountsOutOfSensorRange { get; set; }
Public Property InputCountsOutOfSensorRange As Boolean
    Get
    Set
member InputCountsOutOfSensorRange : bool with get, set

function get_InputCountsOutOfSensorRange();
function set_InputCountsOutOfSensorRange(value);
public:
property bool InputCountsOutOfSensorRange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.InsertedValue Property

Grid Solutions Framework MetadataRecordAlarmFlagsInsertedValue Property
Gets or sets a boolean value that indicates whether a data Quality of InsertedValue should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InsertedValue { get; set; }
Public Property InsertedValue As Boolean
    Get
    Set
member InsertedValue : bool with get, set

function get_InsertedValue();
function set_InsertedValue(value);
public:
property bool InsertedValue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.InsertedValueAboveHiHiLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsInsertedValueAboveHiHiLimit Property
Gets or sets a boolean value that indicates whether a data Quality of InsertedValueAboveHiHiLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InsertedValueAboveHiHiLimit { get; set; }
Public Property InsertedValueAboveHiHiLimit As Boolean
    Get
    Set
member InsertedValueAboveHiHiLimit : bool with get, set

function get_InsertedValueAboveHiHiLimit();
function set_InsertedValueAboveHiHiLimit(value);
public:
property bool InsertedValueAboveHiHiLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.InsertedValueAboveHiLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsInsertedValueAboveHiLimit Property
Gets or sets a boolean value that indicates whether a data Quality of InsertedValueAboveHiLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InsertedValueAboveHiLimit { get; set; }
Public Property InsertedValueAboveHiLimit As Boolean
    Get
    Set
member InsertedValueAboveHiLimit : bool with get, set

function get_InsertedValueAboveHiLimit();
function set_InsertedValueAboveHiLimit(value);
public:
property bool InsertedValueAboveHiLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.InsertedValueBelowLoLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsInsertedValueBelowLoLimit Property
Gets or sets a boolean value that indicates whether a data Quality of InsertedValueBelowLoLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InsertedValueBelowLoLimit { get; set; }
Public Property InsertedValueBelowLoLimit As Boolean
    Get
    Set
member InsertedValueBelowLoLimit : bool with get, set

function get_InsertedValueBelowLoLimit();
function set_InsertedValueBelowLoLimit(value);
public:
property bool InsertedValueBelowLoLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.InsertedValueBelowLoLoLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsInsertedValueBelowLoLoLimit Property
Gets or sets a boolean value that indicates whether a data Quality of InsertedValueBelowLoLoLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InsertedValueBelowLoLoLimit { get; set; }
Public Property InsertedValueBelowLoLoLimit As Boolean
    Get
    Set
member InsertedValueBelowLoLoLimit : bool with get, set

function get_InsertedValueBelowLoLoLimit();
function set_InsertedValueBelowLoLoLimit(value);
public:
property bool InsertedValueBelowLoLoLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.LogicalAlarm Property

Grid Solutions Framework MetadataRecordAlarmFlagsLogicalAlarm Property
Gets or sets a boolean value that indicates whether a data Quality of LogicalAlarm should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool LogicalAlarm { get; set; }
Public Property LogicalAlarm As Boolean
    Get
    Set
member LogicalAlarm : bool with get, set

function get_LogicalAlarm();
function set_LogicalAlarm(value);
public:
property bool LogicalAlarm {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.Old Property

Grid Solutions Framework MetadataRecordAlarmFlagsOld Property
Gets or sets a boolean value that indicates whether a data Quality of Old should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Old { get; set; }
Public Property Old As Boolean
    Get
    Set
member Old : bool with get, set

function get_Old();
function set_Old(value);
public:
property bool Old {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.OpenThermocouple Property

Grid Solutions Framework MetadataRecordAlarmFlagsOpenThermocouple Property
Gets or sets a boolean value that indicates whether a data Quality of OpenThermocouple should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool OpenThermocouple { get; set; }
Public Property OpenThermocouple As Boolean
    Get
    Set
member OpenThermocouple : bool with get, set

function get_OpenThermocouple();
function set_OpenThermocouple(value);
public:
property bool OpenThermocouple {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.SensorReadError Property

Grid Solutions Framework MetadataRecordAlarmFlagsSensorReadError Property
Gets or sets a boolean value that indicates whether a data Quality of SensorReadError should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SensorReadError { get; set; }
Public Property SensorReadError As Boolean
    Get
    Set
member SensorReadError : bool with get, set

function get_SensorReadError();
function set_SensorReadError(value);
public:
property bool SensorReadError {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.SuspectData Property

Grid Solutions Framework MetadataRecordAlarmFlagsSuspectData Property
Gets or sets a boolean value that indicates whether a data Quality of SuspectData should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SuspectData { get; set; }
Public Property SuspectData As Boolean
    Get
    Set
member SuspectData : bool with get, set

function get_SuspectData();
function set_SuspectData(value);
public:
property bool SuspectData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.SuspectValueAboveHiHiLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsSuspectValueAboveHiHiLimit Property
Gets or sets a boolean value that indicates whether a data Quality of SuspectValueAboveHiHiLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SuspectValueAboveHiHiLimit { get; set; }
Public Property SuspectValueAboveHiHiLimit As Boolean
    Get
    Set
member SuspectValueAboveHiHiLimit : bool with get, set

function get_SuspectValueAboveHiHiLimit();
function set_SuspectValueAboveHiHiLimit(value);
public:
property bool SuspectValueAboveHiHiLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.SuspectValueAboveHiLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsSuspectValueAboveHiLimit Property
Gets or sets a boolean value that indicates whether a data Quality of SuspectValueAboveHiLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SuspectValueAboveHiLimit { get; set; }
Public Property SuspectValueAboveHiLimit As Boolean
    Get
    Set
member SuspectValueAboveHiLimit : bool with get, set

function get_SuspectValueAboveHiLimit();
function set_SuspectValueAboveHiLimit(value);
public:
property bool SuspectValueAboveHiLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.SuspectValueBelowLoLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsSuspectValueBelowLoLimit Property
Gets or sets a boolean value that indicates whether a data Quality of SuspectValueBelowLoLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SuspectValueBelowLoLimit { get; set; }
Public Property SuspectValueBelowLoLimit As Boolean
    Get
    Set
member SuspectValueBelowLoLimit : bool with get, set

function get_SuspectValueBelowLoLimit();
function set_SuspectValueBelowLoLimit(value);
public:
property bool SuspectValueBelowLoLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.SuspectValueBelowLoLoLimit Property

Grid Solutions Framework MetadataRecordAlarmFlagsSuspectValueBelowLoLoLimit Property
Gets or sets a boolean value that indicates whether a data Quality of SuspectValueBelowLoLoLimit should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SuspectValueBelowLoLoLimit { get; set; }
Public Property SuspectValueBelowLoLoLimit As Boolean
    Get
    Set
member SuspectValueBelowLoLoLimit : bool with get, set

function get_SuspectValueBelowLoLoLimit();
function set_SuspectValueBelowLoLoLimit(value);
public:
property bool SuspectValueBelowLoLoLimit {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.Unknown Property

Grid Solutions Framework MetadataRecordAlarmFlagsUnknown Property
Gets or sets a boolean value that indicates whether a data Quality of Unknown should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Unknown { get; set; }
Public Property Unknown As Boolean
    Get
    Set
member Unknown : bool with get, set

function get_Unknown();
function set_Unknown(value);
public:
property bool Unknown {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.UnreasonableHigh Property

Grid Solutions Framework MetadataRecordAlarmFlagsUnreasonableHigh Property
Gets or sets a boolean value that indicates whether a data Quality of UnreasonableHigh should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UnreasonableHigh { get; set; }
Public Property UnreasonableHigh As Boolean
    Get
    Set
member UnreasonableHigh : bool with get, set

function get_UnreasonableHigh();
function set_UnreasonableHigh(value);
public:
property bool UnreasonableHigh {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.UnreasonableLow Property

Grid Solutions Framework MetadataRecordAlarmFlagsUnreasonableLow Property
Gets or sets a boolean value that indicates whether a data Quality of UnreasonableLow should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UnreasonableLow { get; set; }
Public Property UnreasonableLow As Boolean
    Get
    Set
member UnreasonableLow : bool with get, set

function get_UnreasonableLow();
function set_UnreasonableLow(value);
public:
property bool UnreasonableLow {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.Value Property

Grid Solutions Framework MetadataRecordAlarmFlagsValue Property
Gets or sets the 32-bit integer value used for defining which data Quality should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
member Value : int with get, set

function get_Value();
function set_Value(value);
public:
property int Value {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.ValueAboveHiAlarm Property

Grid Solutions Framework MetadataRecordAlarmFlagsValueAboveHiAlarm Property
Gets or sets a boolean value that indicates whether a data Quality of ValueAboveHiAlarm should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValueAboveHiAlarm { get; set; }
Public Property ValueAboveHiAlarm As Boolean
    Get
    Set
member ValueAboveHiAlarm : bool with get, set

function get_ValueAboveHiAlarm();
function set_ValueAboveHiAlarm(value);
public:
property bool ValueAboveHiAlarm {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.ValueAboveHiHiAlarm Property

Grid Solutions Framework MetadataRecordAlarmFlagsValueAboveHiHiAlarm Property
Gets or sets a boolean value that indicates whether a data Quality of ValueAboveHiHiAlarm should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValueAboveHiHiAlarm { get; set; }
Public Property ValueAboveHiHiAlarm As Boolean
    Get
    Set
member ValueAboveHiHiAlarm : bool with get, set

function get_ValueAboveHiHiAlarm();
function set_ValueAboveHiHiAlarm(value);
public:
property bool ValueAboveHiHiAlarm {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.ValueBelowLoAlarm Property

Grid Solutions Framework MetadataRecordAlarmFlagsValueBelowLoAlarm Property
Gets or sets a boolean value that indicates whether a data Quality of ValueBelowLoAlarm should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValueBelowLoAlarm { get; set; }
Public Property ValueBelowLoAlarm As Boolean
    Get
    Set
member ValueBelowLoAlarm : bool with get, set

function get_ValueBelowLoAlarm();
function set_ValueBelowLoAlarm(value);
public:
property bool ValueBelowLoAlarm {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAlarmFlags.ValueBelowLoLoAlarm Property

Grid Solutions Framework MetadataRecordAlarmFlagsValueBelowLoLoAlarm Property
Gets or sets a boolean value that indicates whether a data Quality of ValueBelowLoLoAlarm should trigger an alarm notification.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValueBelowLoLoAlarm { get; set; }
Public Property ValueBelowLoLoAlarm As Boolean
    Get
    Set
member ValueBelowLoLoAlarm : bool with get, set

function get_ValueBelowLoLoAlarm();
function set_ValueBelowLoLoAlarm(value);
public:
property bool ValueBelowLoLoAlarm {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordAlarmFlags Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields Class

Grid Solutions Framework MetadataRecordAnalogFields Class
Defines specific fields for MetadataRecords that are of type Analog.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordAnalogFields

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordAnalogFields : ISupportBinaryImage
Public Class MetadataRecordAnalogFields
    Implements ISupportBinaryImage
type MetadataRecordAnalogFields =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.MetadataRecordAnalogFields = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordAnalogFields',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class MetadataRecordAnalogFields : ISupportBinaryImage

The MetadataRecordAnalogFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordAnalogFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordAnalogFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordAnalogFields.
Top
Properties
 | Name | Description
Public property | AlarmDelay | Gets or sets the time (in seconds) to wait before consecutive alarm notifications are sent for the MetadataRecord.
Public property | BinaryLength | Gets the length of the MetadataRecordAnalogFields.
Public property | CompressionLimit | Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must changed before being archived.
Public property | DisplayDigits | Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.
Public property | EngineeringUnits | Gets or sets the engineering units of archived data values for the MetadataRecord.
Public property | ExceptionLimit | Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must change before being sent for archival by the data aquisition source.
Public property | HighAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiHiAlarm.
Public property | HighRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableHigh.
Public property | HighWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiAlarm.
Public property | LowAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoLoAlarm.
Public property | LowRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableLow.
Public property | LowWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoAlarm.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordAnalogFields Fields

Grid Solutions Framework MetadataRecordAnalogFields Fields

The MetadataRecordAnalogFields type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordAnalogFields.
Top
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.FixedLength Field

Grid Solutions Framework MetadataRecordAnalogFieldsFixedLength Field
Specifies the number of bytes in the binary image of MetadataRecordAnalogFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.MetadataRecordAnalogFields.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields Methods

Grid Solutions Framework MetadataRecordAnalogFields Methods

The MetadataRecordAnalogFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordAnalogFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordAnalogFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.GenerateBinaryImage Method

Grid Solutions Framework MetadataRecordAnalogFieldsGenerateBinaryImage Method
Generates binary image of the MetadataRecordAnalogFields and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.ParseBinaryImage Method

Grid Solutions Framework MetadataRecordAnalogFieldsParseBinaryImage Method
Initializes MetadataRecordAnalogFields from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecordAnalogFields.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing MetadataRecordAnalogFields.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields Properties

Grid Solutions Framework MetadataRecordAnalogFields Properties

The MetadataRecordAnalogFields type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDelay | Gets or sets the time (in seconds) to wait before consecutive alarm notifications are sent for the MetadataRecord.
Public property | BinaryLength | Gets the length of the MetadataRecordAnalogFields.
Public property | CompressionLimit | Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must changed before being archived.
Public property | DisplayDigits | Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.
Public property | EngineeringUnits | Gets or sets the engineering units of archived data values for the MetadataRecord.
Public property | ExceptionLimit | Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must change before being sent for archival by the data aquisition source.
Public property | HighAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiHiAlarm.
Public property | HighRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableHigh.
Public property | HighWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiAlarm.
Public property | LowAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoLoAlarm.
Public property | LowRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableLow.
Public property | LowWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoAlarm.
Top
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.AlarmDelay Property

Grid Solutions Framework MetadataRecordAnalogFieldsAlarmDelay Property
Gets or sets the time (in seconds) to wait before consecutive alarm notifications are sent for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float AlarmDelay { get; set; }
Public Property AlarmDelay As Single
    Get
    Set
member AlarmDelay : float32 with get, set

function get_AlarmDelay();
function set_AlarmDelay(value);
public:
property float AlarmDelay {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.BinaryLength Property

Grid Solutions Framework MetadataRecordAnalogFieldsBinaryLength Property
Gets the length of the MetadataRecordAnalogFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.CompressionLimit Property

Grid Solutions Framework MetadataRecordAnalogFieldsCompressionLimit Property
Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must changed before being archived.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float CompressionLimit { get; set; }
Public Property CompressionLimit As Single
    Get
    Set
member CompressionLimit : float32 with get, set

function get_CompressionLimit();
function set_CompressionLimit(value);
public:
property float CompressionLimit {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.DisplayDigits Property

Grid Solutions Framework MetadataRecordAnalogFieldsDisplayDigits Property
Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DisplayDigits { get; set; }
Public Property DisplayDigits As Integer
    Get
    Set
member DisplayDigits : int with get, set

function get_DisplayDigits();
function set_DisplayDigits(value);
public:
property int DisplayDigits {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.EngineeringUnits Property

Grid Solutions Framework MetadataRecordAnalogFieldsEngineeringUnits Property
Gets or sets the engineering units of archived data values for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string EngineeringUnits { get; set; }
Public Property EngineeringUnits As String
    Get
    Set
member EngineeringUnits : string with get, set

function get_EngineeringUnits();
function set_EngineeringUnits(value);
public:
property String^ EngineeringUnits {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
Remarks
Maximum length for EngineeringUnits is 24 characters.
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.ExceptionLimit Property

Grid Solutions Framework MetadataRecordAnalogFieldsExceptionLimit Property
Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must change before being sent for archival by the data aquisition source.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ExceptionLimit { get; set; }
Public Property ExceptionLimit As Single
    Get
    Set
member ExceptionLimit : float32 with get, set

function get_ExceptionLimit();
function set_ExceptionLimit(value);
public:
property float ExceptionLimit {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.HighAlarm Property

Grid Solutions Framework MetadataRecordAnalogFieldsHighAlarm Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiHiAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighAlarm { get; set; }
Public Property HighAlarm As Single
    Get
    Set
member HighAlarm : float32 with get, set

function get_HighAlarm();
function set_HighAlarm(value);
public:
property float HighAlarm {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.HighRange Property

Grid Solutions Framework MetadataRecordAnalogFieldsHighRange Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableHigh.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighRange { get; set; }
Public Property HighRange As Single
    Get
    Set
member HighRange : float32 with get, set

function get_HighRange();
function set_HighRange(value);
public:
property float HighRange {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.HighWarning Property

Grid Solutions Framework MetadataRecordAnalogFieldsHighWarning Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighWarning { get; set; }
Public Property HighWarning As Single
    Get
    Set
member HighWarning : float32 with get, set

function get_HighWarning();
function set_HighWarning(value);
public:
property float HighWarning {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.LowAlarm Property

Grid Solutions Framework MetadataRecordAnalogFieldsLowAlarm Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoLoAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowAlarm { get; set; }
Public Property LowAlarm As Single
    Get
    Set
member LowAlarm : float32 with get, set

function get_LowAlarm();
function set_LowAlarm(value);
public:
property float LowAlarm {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.LowRange Property

Grid Solutions Framework MetadataRecordAnalogFieldsLowRange Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableLow.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowRange { get; set; }
Public Property LowRange As Single
    Get
    Set
member LowRange : float32 with get, set

function get_LowRange();
function set_LowRange(value);
public:
property float LowRange {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordAnalogFields.LowWarning Property

Grid Solutions Framework MetadataRecordAnalogFieldsLowWarning Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowWarning { get; set; }
Public Property LowWarning As Single
    Get
    Set
member LowWarning : float32 with get, set

function get_LowWarning();
function set_LowWarning(value);
public:
property float LowWarning {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordAnalogFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields Class

Grid Solutions Framework MetadataRecordComposedFields Class
Defines specific fields for MetadataRecords that are of type Composed.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordComposedFields

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordComposedFields : ISupportBinaryImage
Public Class MetadataRecordComposedFields
    Implements ISupportBinaryImage
type MetadataRecordComposedFields =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.MetadataRecordComposedFields = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordComposedFields',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class MetadataRecordComposedFields : ISupportBinaryImage

The MetadataRecordComposedFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordComposedFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordComposedFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordComposedFields.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the MetadataRecordComposedFields.
Public property | CompressionLimit | Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must changed before being archived.
Public property | DisplayDigits | Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.
Public property | EngineeringUnits | Gets or sets the engineering units of archived data values for the MetadataRecord.
Public property | Equation | Gets or sets the mathematical equation used for calculating the data value for the MetadataRecord.
Public property | HighAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiHiAlarm.
Public property | HighRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableHigh.
Public property | HighWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiAlarm.
Public property | InputPointers | Gets or sets the historian identifiers being used in the Equation.
Public property | LowAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoLoAlarm.
Public property | LowRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableLow.
Public property | LowWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoAlarm.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordComposedFields Fields

Grid Solutions Framework MetadataRecordComposedFields Fields

The MetadataRecordComposedFields type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordComposedFields.
Top
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.FixedLength Field

Grid Solutions Framework MetadataRecordComposedFieldsFixedLength Field
Specifies the number of bytes in the binary image of MetadataRecordComposedFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.MetadataRecordComposedFields.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields Methods

Grid Solutions Framework MetadataRecordComposedFields Methods

The MetadataRecordComposedFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordComposedFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordComposedFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.GenerateBinaryImage Method

Grid Solutions Framework MetadataRecordComposedFieldsGenerateBinaryImage Method
Generates binary image of the MetadataRecordComposedFields and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.ParseBinaryImage Method

Grid Solutions Framework MetadataRecordComposedFieldsParseBinaryImage Method
Initializes MetadataRecordComposedFields from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecordComposedFields.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing MetadataRecordComposedFields.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields Properties

Grid Solutions Framework MetadataRecordComposedFields Properties

The MetadataRecordComposedFields type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the MetadataRecordComposedFields.
Public property | CompressionLimit | Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must changed before being archived.
Public property | DisplayDigits | Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.
Public property | EngineeringUnits | Gets or sets the engineering units of archived data values for the MetadataRecord.
Public property | Equation | Gets or sets the mathematical equation used for calculating the data value for the MetadataRecord.
Public property | HighAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiHiAlarm.
Public property | HighRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableHigh.
Public property | HighWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiAlarm.
Public property | InputPointers | Gets or sets the historian identifiers being used in the Equation.
Public property | LowAlarm | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoLoAlarm.
Public property | LowRange | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableLow.
Public property | LowWarning | Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoAlarm.
Top
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.BinaryLength Property

Grid Solutions Framework MetadataRecordComposedFieldsBinaryLength Property
Gets the length of the MetadataRecordComposedFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.CompressionLimit Property

Grid Solutions Framework MetadataRecordComposedFieldsCompressionLimit Property
Gets or sets the amount, expressed in EngineeringUnits, by which data values for the MetadataRecord must changed before being archived.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float CompressionLimit { get; set; }
Public Property CompressionLimit As Single
    Get
    Set
member CompressionLimit : float32 with get, set

function get_CompressionLimit();
function set_CompressionLimit(value);
public:
property float CompressionLimit {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.DisplayDigits Property

Grid Solutions Framework MetadataRecordComposedFieldsDisplayDigits Property
Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DisplayDigits { get; set; }
Public Property DisplayDigits As Integer
    Get
    Set
member DisplayDigits : int with get, set

function get_DisplayDigits();
function set_DisplayDigits(value);
public:
property int DisplayDigits {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.EngineeringUnits Property

Grid Solutions Framework MetadataRecordComposedFieldsEngineeringUnits Property
Gets or sets the engineering units of archived data values for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string EngineeringUnits { get; set; }
Public Property EngineeringUnits As String
    Get
    Set
member EngineeringUnits : string with get, set

function get_EngineeringUnits();
function set_EngineeringUnits(value);
public:
property String^ EngineeringUnits {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.Equation Property

Grid Solutions Framework MetadataRecordComposedFieldsEquation Property
Gets or sets the mathematical equation used for calculating the data value for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Equation { get; set; }
Public Property Equation As String
    Get
    Set
member Equation : string with get, set

function get_Equation();
function set_Equation(value);
public:
property String^ Equation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.HighAlarm Property

Grid Solutions Framework MetadataRecordComposedFieldsHighAlarm Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiHiAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighAlarm { get; set; }
Public Property HighAlarm As Single
    Get
    Set
member HighAlarm : float32 with get, set

function get_HighAlarm();
function set_HighAlarm(value);
public:
property float HighAlarm {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.HighRange Property

Grid Solutions Framework MetadataRecordComposedFieldsHighRange Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableHigh.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighRange { get; set; }
Public Property HighRange As Single
    Get
    Set
member HighRange : float32 with get, set

function get_HighRange();
function set_HighRange(value);
public:
property float HighRange {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.HighWarning Property

Grid Solutions Framework MetadataRecordComposedFieldsHighWarning Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueAboveHiAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighWarning { get; set; }
Public Property HighWarning As Single
    Get
    Set
member HighWarning : float32 with get, set

function get_HighWarning();
function set_HighWarning(value);
public:
property float HighWarning {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.InputPointers Property

Grid Solutions Framework MetadataRecordComposedFieldsInputPointers Property
Gets or sets the historian identifiers being used in the Equation.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<int> InputPointers { get; }
Public ReadOnly Property InputPointers As IList(Of Integer)
    Get
member InputPointers : IList<int> with get

function get_InputPointers();

public:
property IList<int>^ InputPointers {
    IList<int>^ get ();
}

Property Value

Type: IList Int32
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.LowAlarm Property

Grid Solutions Framework MetadataRecordComposedFieldsLowAlarm Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoLoAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowAlarm { get; set; }
Public Property LowAlarm As Single
    Get
    Set
member LowAlarm : float32 with get, set

function get_LowAlarm();
function set_LowAlarm(value);
public:
property float LowAlarm {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.LowRange Property

Grid Solutions Framework MetadataRecordComposedFieldsLowRange Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of UnreasonableLow.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowRange { get; set; }
Public Property LowRange As Single
    Get
    Set
member LowRange : float32 with get, set

function get_LowRange();
function set_LowRange(value);
public:
property float LowRange {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordComposedFields.LowWarning Property

Grid Solutions Framework MetadataRecordComposedFieldsLowWarning Property
Gets or sets the value above which archived data for the MetadataRecord is assigned a quality of ValueBelowLoAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowWarning { get; set; }
Public Property LowWarning As Single
    Get
    Set
member LowWarning : float32 with get, set

function get_LowWarning();
function set_LowWarning(value);
public:
property float LowWarning {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordComposedFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields Class

Grid Solutions Framework MetadataRecordConstantFields Class
Defines specific fields for MetadataRecords that are of type Constant.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordConstantFields

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordConstantFields : ISupportBinaryImage
Public Class MetadataRecordConstantFields
    Implements ISupportBinaryImage
type MetadataRecordConstantFields =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.MetadataRecordConstantFields = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordConstantFields',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class MetadataRecordConstantFields : ISupportBinaryImage

The MetadataRecordConstantFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordConstantFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordConstantFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordConstantFields.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the MetadataRecordConstantFields.
Public property | DisplayDigits | Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.
Public property | Value | Gets or sets the constant value of the MetadataRecord.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordConstantFields Fields

Grid Solutions Framework MetadataRecordConstantFields Fields

The MetadataRecordConstantFields type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordConstantFields.
Top
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields.FixedLength Field

Grid Solutions Framework MetadataRecordConstantFieldsFixedLength Field
Specifies the number of bytes in the binary image of MetadataRecordConstantFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.MetadataRecordConstantFields.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields Methods

Grid Solutions Framework MetadataRecordConstantFields Methods

The MetadataRecordConstantFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordConstantFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordConstantFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields.GenerateBinaryImage Method

Grid Solutions Framework MetadataRecordConstantFieldsGenerateBinaryImage Method
Generates binary image of the MetadataRecordConstantFields and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields.ParseBinaryImage Method

Grid Solutions Framework MetadataRecordConstantFieldsParseBinaryImage Method
Initializes MetadataRecordConstantFields from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecordConstantFields.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing MetadataRecordConstantFields.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields Properties

Grid Solutions Framework MetadataRecordConstantFields Properties

The MetadataRecordConstantFields type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the MetadataRecordConstantFields.
Public property | DisplayDigits | Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.
Public property | Value | Gets or sets the constant value of the MetadataRecord.
Top
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields.BinaryLength Property

Grid Solutions Framework MetadataRecordConstantFieldsBinaryLength Property
Gets the length of the MetadataRecordConstantFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields.DisplayDigits Property

Grid Solutions Framework MetadataRecordConstantFieldsDisplayDigits Property
Gets or sets the number of digits after the decimal point to be displayed for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DisplayDigits { get; set; }
Public Property DisplayDigits As Integer
    Get
    Set
member DisplayDigits : int with get, set

function get_DisplayDigits();
function set_DisplayDigits(value);
public:
property int DisplayDigits {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordConstantFields.Value Property

Grid Solutions Framework MetadataRecordConstantFieldsValue Property
Gets or sets the constant value of the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float Value { get; set; }
Public Property Value As Single
    Get
    Set
member Value : float32 with get, set

function get_Value();
function set_Value(value);
public:
property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordConstantFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields Class

Grid Solutions Framework MetadataRecordDigitalFields Class
Defines specific fields for MetadataRecords that are of type Digital.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordDigitalFields

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordDigitalFields : ISupportBinaryImage
Public Class MetadataRecordDigitalFields
    Implements ISupportBinaryImage
type MetadataRecordDigitalFields =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.MetadataRecordDigitalFields = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordDigitalFields',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class MetadataRecordDigitalFields : ISupportBinaryImage

The MetadataRecordDigitalFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordDigitalFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordDigitalFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordDigitalFields.
Top
Properties
 | Name | Description
Public property | AlarmDelay | Gets or sets the time (in seconds) to wait before consecutive alarm notifications are sent for the MetadataRecord.
Public property | AlarmState | Gets or sets the value (0 or 1) that indicates alarm state for the MetadataRecord.
Public property | BinaryLength | Gets the length of the MetadataRecordDigitalFields.
Public property | ClearDescription | Gets or sets the text description of the data value for the MetadataRecord when it is 0.
Public property | SetDescription | Gets or sets the text description of the data value for the MetadataRecord when it is 1.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordDigitalFields Fields

Grid Solutions Framework MetadataRecordDigitalFields Fields

The MetadataRecordDigitalFields type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordDigitalFields.
Top
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.FixedLength Field

Grid Solutions Framework MetadataRecordDigitalFieldsFixedLength Field
Specifies the number of bytes in the binary image of MetadataRecordDigitalFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.MetadataRecordDigitalFields.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields Methods

Grid Solutions Framework MetadataRecordDigitalFields Methods

The MetadataRecordDigitalFields type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordDigitalFields and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordDigitalFields from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.GenerateBinaryImage Method

Grid Solutions Framework MetadataRecordDigitalFieldsGenerateBinaryImage Method
Generates binary image of the MetadataRecordDigitalFields and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.ParseBinaryImage Method

Grid Solutions Framework MetadataRecordDigitalFieldsParseBinaryImage Method
Initializes MetadataRecordDigitalFields from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecordDigitalFields.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing MetadataRecordDigitalFields.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields Properties

Grid Solutions Framework MetadataRecordDigitalFields Properties

The MetadataRecordDigitalFields type exposes the following members.

Properties
 | Name | Description
Public property | AlarmDelay | Gets or sets the time (in seconds) to wait before consecutive alarm notifications are sent for the MetadataRecord.
Public property | AlarmState | Gets or sets the value (0 or 1) that indicates alarm state for the MetadataRecord.
Public property | BinaryLength | Gets the length of the MetadataRecordDigitalFields.
Public property | ClearDescription | Gets or sets the text description of the data value for the MetadataRecord when it is 0.
Public property | SetDescription | Gets or sets the text description of the data value for the MetadataRecord when it is 1.
Top
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.AlarmDelay Property

Grid Solutions Framework MetadataRecordDigitalFieldsAlarmDelay Property
Gets or sets the time (in seconds) to wait before consecutive alarm notifications are sent for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float AlarmDelay { get; set; }
Public Property AlarmDelay As Single
    Get
    Set
member AlarmDelay : float32 with get, set

function get_AlarmDelay();
function set_AlarmDelay(value);
public:
property float AlarmDelay {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.AlarmState Property

Grid Solutions Framework MetadataRecordDigitalFieldsAlarmState Property
Gets or sets the value (0 or 1) that indicates alarm state for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int AlarmState { get; set; }
Public Property AlarmState As Integer
    Get
    Set
member AlarmState : int with get, set

function get_AlarmState();
function set_AlarmState(value);
public:
property int AlarmState {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not -1, 0 or 1.
Remarks
A value of -1 indicates no alarm state.
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.BinaryLength Property

Grid Solutions Framework MetadataRecordDigitalFieldsBinaryLength Property
Gets the length of the MetadataRecordDigitalFields.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.ClearDescription Property

Grid Solutions Framework MetadataRecordDigitalFieldsClearDescription Property
Gets or sets the text description of the data value for the MetadataRecord when it is 0.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ClearDescription { get; set; }
Public Property ClearDescription As String
    Get
    Set
member ClearDescription : string with get, set

function get_ClearDescription();
function set_ClearDescription(value);
public:
property String^ ClearDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Maximum length for ClearDescription is 24 characters.
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordDigitalFields.SetDescription Property

Grid Solutions Framework MetadataRecordDigitalFieldsSetDescription Property
Gets or sets the text description of the data value for the MetadataRecord when it is 1.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SetDescription { get; set; }
Public Property SetDescription As String
    Get
    Set
member SetDescription : string with get, set

function get_SetDescription();
function set_SetDescription(value);
public:
property String^ SetDescription {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Maximum length for SetDescription is 24 characters.
See Also

Reference

MetadataRecordDigitalFields Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags Class

Grid Solutions Framework MetadataRecordGeneralFlags Class
Defines general boolean settings for a MetadataRecord.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordGeneralFlags

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordGeneralFlags
Public Class MetadataRecordGeneralFlags
type MetadataRecordGeneralFlags =  class end
GSF.Historian.Files.MetadataRecordGeneralFlags = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordGeneralFlags');
public ref class MetadataRecordGeneralFlags

The MetadataRecordGeneralFlags type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataRecordGeneralFlags | Initializes a new instance of the MetadataRecordGeneralFlags class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AlarmByEmail | Gets or sets a boolean value that indicates whether email alarm notifications are to be sent for the MetadataRecord.
Public property | AlarmByPager | Gets or sets a boolean value that indicates whether text alarm notifications are to be sent for the MetadataRecord.
Public property | AlarmByPhone | Gets or sets a boolean value that indicates whether voice alarm notifications are to be sent for the MetadataRecord.
Public property | AlarmEnabled | Gets or sets a boolean value that indicates whether alarm notifications are enabled for the MetadataRecord.
Public property | AlarmToFile | Gets or sets a boolean value that indicates whether alarm notifications for the MetadataRecord are to be logged to a text file.
Public property | Changed | Gets or sets a boolean value that indicates whether the MetadataRecord has been modified.
Public property | DataType | Gets or sets the DataType of archived data for the MetadataRecord.
Public property | Enabled | Gets or sets a boolean value that indicates whether the MetadataRecord is currently enabled for archival of new data.
Public property | StepCheck | Gets or sets a boolean value that indicates whether a "step change" operation is to be performed on incoming time-series data for the MetadataRecord.
Public property | Used | Gets or sets a boolean value that indicates whether the MetadataRecord is being used (need to be verify).
Public property | Value | Gets or sets the 32-bit integer value used for defining general boolean settings for a MetadataRecord.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordGeneralFlags Constructor

Grid Solutions Framework MetadataRecordGeneralFlags Constructor
Initializes a new instance of the MetadataRecordGeneralFlags class

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordGeneralFlags()
Public Sub New
new : unit -> MetadataRecordGeneralFlags
GSF.Historian.Files.MetadataRecordGeneralFlags = function();
public:
MetadataRecordGeneralFlags()
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags Methods

Grid Solutions Framework MetadataRecordGeneralFlags Methods

The MetadataRecordGeneralFlags type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags Properties

Grid Solutions Framework MetadataRecordGeneralFlags Properties

The MetadataRecordGeneralFlags type exposes the following members.

Properties
 | Name | Description
Public property | AlarmByEmail | Gets or sets a boolean value that indicates whether email alarm notifications are to be sent for the MetadataRecord.
Public property | AlarmByPager | Gets or sets a boolean value that indicates whether text alarm notifications are to be sent for the MetadataRecord.
Public property | AlarmByPhone | Gets or sets a boolean value that indicates whether voice alarm notifications are to be sent for the MetadataRecord.
Public property | AlarmEnabled | Gets or sets a boolean value that indicates whether alarm notifications are enabled for the MetadataRecord.
Public property | AlarmToFile | Gets or sets a boolean value that indicates whether alarm notifications for the MetadataRecord are to be logged to a text file.
Public property | Changed | Gets or sets a boolean value that indicates whether the MetadataRecord has been modified.
Public property | DataType | Gets or sets the DataType of archived data for the MetadataRecord.
Public property | Enabled | Gets or sets a boolean value that indicates whether the MetadataRecord is currently enabled for archival of new data.
Public property | StepCheck | Gets or sets a boolean value that indicates whether a "step change" operation is to be performed on incoming time-series data for the MetadataRecord.
Public property | Used | Gets or sets a boolean value that indicates whether the MetadataRecord is being used (need to be verify).
Public property | Value | Gets or sets the 32-bit integer value used for defining general boolean settings for a MetadataRecord.
Top
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.AlarmByEmail Property

Grid Solutions Framework MetadataRecordGeneralFlagsAlarmByEmail Property
Gets or sets a boolean value that indicates whether email alarm notifications are to be sent for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AlarmByEmail { get; set; }
Public Property AlarmByEmail As Boolean
    Get
    Set
member AlarmByEmail : bool with get, set

function get_AlarmByEmail();
function set_AlarmByEmail(value);
public:
property bool AlarmByEmail {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.AlarmByPager Property

Grid Solutions Framework MetadataRecordGeneralFlagsAlarmByPager Property
Gets or sets a boolean value that indicates whether text alarm notifications are to be sent for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AlarmByPager { get; set; }
Public Property AlarmByPager As Boolean
    Get
    Set
member AlarmByPager : bool with get, set

function get_AlarmByPager();
function set_AlarmByPager(value);
public:
property bool AlarmByPager {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.AlarmByPhone Property

Grid Solutions Framework MetadataRecordGeneralFlagsAlarmByPhone Property
Gets or sets a boolean value that indicates whether voice alarm notifications are to be sent for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AlarmByPhone { get; set; }
Public Property AlarmByPhone As Boolean
    Get
    Set
member AlarmByPhone : bool with get, set

function get_AlarmByPhone();
function set_AlarmByPhone(value);
public:
property bool AlarmByPhone {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.AlarmEnabled Property

Grid Solutions Framework MetadataRecordGeneralFlagsAlarmEnabled Property
Gets or sets a boolean value that indicates whether alarm notifications are enabled for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AlarmEnabled { get; set; }
Public Property AlarmEnabled As Boolean
    Get
    Set
member AlarmEnabled : bool with get, set

function get_AlarmEnabled();
function set_AlarmEnabled(value);
public:
property bool AlarmEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.AlarmToFile Property

Grid Solutions Framework MetadataRecordGeneralFlagsAlarmToFile Property
Gets or sets a boolean value that indicates whether alarm notifications for the MetadataRecord are to be logged to a text file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AlarmToFile { get; set; }
Public Property AlarmToFile As Boolean
    Get
    Set
member AlarmToFile : bool with get, set

function get_AlarmToFile();
function set_AlarmToFile(value);
public:
property bool AlarmToFile {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.Changed Property

Grid Solutions Framework MetadataRecordGeneralFlagsChanged Property
Gets or sets a boolean value that indicates whether the MetadataRecord has been modified.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Changed { get; set; }
Public Property Changed As Boolean
    Get
    Set
member Changed : bool with get, set

function get_Changed();
function set_Changed(value);
public:
property bool Changed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.DataType Property

Grid Solutions Framework MetadataRecordGeneralFlagsDataType Property
Gets or sets the DataType of archived data for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataType DataType { get; set; }
Public Property DataType As DataType
    Get
    Set
member DataType : DataType with get, set

function get_DataType();
function set_DataType(value);
public:
property DataType DataType {
    DataType get ();
    void set (DataType value);
}

Property Value

Type: DataType
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.Enabled Property

Grid Solutions Framework MetadataRecordGeneralFlagsEnabled Property
Gets or sets a boolean value that indicates whether the MetadataRecord is currently enabled for archival of new data.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
member Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.StepCheck Property

Grid Solutions Framework MetadataRecordGeneralFlagsStepCheck Property
Gets or sets a boolean value that indicates whether a "step change" operation is to be performed on incoming time-series data for the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool StepCheck { get; set; }
Public Property StepCheck As Boolean
    Get
    Set
member StepCheck : bool with get, set

function get_StepCheck();
function set_StepCheck(value);
public:
property bool StepCheck {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.Used Property

Grid Solutions Framework MetadataRecordGeneralFlagsUsed Property
Gets or sets a boolean value that indicates whether the MetadataRecord is being used (need to be verify).

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Used { get; set; }
Public Property Used As Boolean
    Get
    Set
member Used : bool with get, set

function get_Used();
function set_Used(value);
public:
property bool Used {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordGeneralFlags.Value Property

Grid Solutions Framework MetadataRecordGeneralFlagsValue Property
Gets or sets the 32-bit integer value used for defining general boolean settings for a MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
member Value : int with get, set

function get_Value();
function set_Value(value);
public:
property int Value {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordGeneralFlags Class
GSF.Historian.Files Namespace


MetadataRecordSecurityFlags Class

Grid Solutions Framework MetadataRecordSecurityFlags Class
Defines the security level for a MetadataRecord.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordSecurityFlags

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordSecurityFlags
Public Class MetadataRecordSecurityFlags
type MetadataRecordSecurityFlags =  class end
GSF.Historian.Files.MetadataRecordSecurityFlags = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordSecurityFlags');
public ref class MetadataRecordSecurityFlags

The MetadataRecordSecurityFlags type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataRecordSecurityFlags | Initializes a new instance of the MetadataRecordSecurityFlags class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AccessSecurity | Gets or sets the access level required for a user to retrieve archived data associated to a MetadataRecord.
Public property | ChangeSecurity | Gets or sets the access level required for a user to edit the MetadataRecord.
Public property | Value | Gets or sets the 32-bit integer value used for defining the security level for a MetadataRecord.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordSecurityFlags Constructor

Grid Solutions Framework MetadataRecordSecurityFlags Constructor
Initializes a new instance of the MetadataRecordSecurityFlags class

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordSecurityFlags()
Public Sub New
new : unit -> MetadataRecordSecurityFlags
GSF.Historian.Files.MetadataRecordSecurityFlags = function();
public:
MetadataRecordSecurityFlags()
See Also

Reference

MetadataRecordSecurityFlags Class
GSF.Historian.Files Namespace


MetadataRecordSecurityFlags Methods

Grid Solutions Framework MetadataRecordSecurityFlags Methods

The MetadataRecordSecurityFlags type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataRecordSecurityFlags Class
GSF.Historian.Files Namespace


MetadataRecordSecurityFlags Properties

Grid Solutions Framework MetadataRecordSecurityFlags Properties

The MetadataRecordSecurityFlags type exposes the following members.

Properties
 | Name | Description
Public property | AccessSecurity | Gets or sets the access level required for a user to retrieve archived data associated to a MetadataRecord.
Public property | ChangeSecurity | Gets or sets the access level required for a user to edit the MetadataRecord.
Public property | Value | Gets or sets the 32-bit integer value used for defining the security level for a MetadataRecord.
Top
See Also

Reference

MetadataRecordSecurityFlags Class
GSF.Historian.Files Namespace


MetadataRecordSecurityFlags.AccessSecurity Property

Grid Solutions Framework MetadataRecordSecurityFlagsAccessSecurity Property
Gets or sets the access level required for a user to retrieve archived data associated to a MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int AccessSecurity { get; set; }
Public Property AccessSecurity As Integer
    Get
    Set
member AccessSecurity : int with get, set

function get_AccessSecurity();
function set_AccessSecurity(value);
public:
property int AccessSecurity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordSecurityFlags Class
GSF.Historian.Files Namespace


MetadataRecordSecurityFlags.ChangeSecurity Property

Grid Solutions Framework MetadataRecordSecurityFlagsChangeSecurity Property
Gets or sets the access level required for a user to edit the MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ChangeSecurity { get; set; }
Public Property ChangeSecurity As Integer
    Get
    Set
member ChangeSecurity : int with get, set

function get_ChangeSecurity();
function set_ChangeSecurity(value);
public:
property int ChangeSecurity {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordSecurityFlags Class
GSF.Historian.Files Namespace


MetadataRecordSecurityFlags.Value Property

Grid Solutions Framework MetadataRecordSecurityFlagsValue Property
Gets or sets the 32-bit integer value used for defining the security level for a MetadataRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Value { get; set; }
Public Property Value As Integer
    Get
    Set
member Value : int with get, set

function get_Value();
function set_Value(value);
public:
property int Value {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MetadataRecordSecurityFlags Class
GSF.Historian.Files Namespace


MetadataRecordSummary Class

Grid Solutions Framework MetadataRecordSummary Class
A class with a subset of information defined in MetadataRecord. The generated binary image of MetadataRecordSummary is sent back as a reply to PacketType3 and PacketType4.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesMetadataRecordSummary

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataRecordSummary : ISupportBinaryImage
Public Class MetadataRecordSummary
    Implements ISupportBinaryImage
type MetadataRecordSummary =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.MetadataRecordSummary = function();

Type.createClass(
    'GSF.Historian.Files.MetadataRecordSummary',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class MetadataRecordSummary : ISupportBinaryImage

The MetadataRecordSummary type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataRecordSummary(MetadataRecord) | Initializes a new instance of the MetadataRecordSummary class.
Public method | MetadataRecordSummary(Byte, Int32, Int32) | Initializes a new instance of the MetadataRecordSummary class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordSummary and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordSummary from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordSummary.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the MetadataRecordSummary.
Public property | Enabled | Same as Enabled.
Public property | ExceptionLimit | Same as ExceptionLimit.
Public property | HighAlarm | Same as HighAlarm.
Public property | HighRange | Same as HighRange.
Public property | HighWarning | Same as HighWarning.
Public property | HistorianID | Same as HistorianID.
Public property | LowAlarm | Same as LowAlarm.
Public property | LowRange | Same as LowRange.
Public property | LowWarning | Same as LowWarning.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesMetadataRecord


MetadataRecordSummary Constructor

Grid Solutions Framework MetadataRecordSummary Constructor
Overload List
 | Name | Description
Public method | MetadataRecordSummary(MetadataRecord) | Initializes a new instance of the MetadataRecordSummary class.
Public method | MetadataRecordSummary(Byte, Int32, Int32) | Initializes a new instance of the MetadataRecordSummary class.
Top
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary Constructor (MetadataRecord)

Grid Solutions Framework MetadataRecordSummary Constructor (MetadataRecord)
Initializes a new instance of the MetadataRecordSummary class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordSummary(
    MetadataRecord record
)
Public Sub New (
    record As MetadataRecord
)
new :
        record : MetadataRecord -> MetadataRecordSummary
GSF.Historian.Files.MetadataRecordSummary = function(record);
public:
MetadataRecordSummary(
    MetadataRecord^ record
)

Parameters

record
Type: GSF.Historian.FilesMetadataRecord
A MetadataRecord object.
See Also

Reference

MetadataRecordSummary Class
MetadataRecordSummary Overload
GSF.Historian.Files Namespace


MetadataRecordSummary Constructor (Byte[], Int32, Int32)

Grid Solutions Framework MetadataRecordSummary Constructor (Byte, Int32, Int32)
Initializes a new instance of the MetadataRecordSummary class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataRecordSummary(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> MetadataRecordSummary
GSF.Historian.Files.MetadataRecordSummary = function(buffer, startIndex, length);
public:
MetadataRecordSummary(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecordSummary.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

MetadataRecordSummary Class
MetadataRecordSummary Overload
GSF.Historian.Files Namespace


MetadataRecordSummary Fields

Grid Solutions Framework MetadataRecordSummary Fields

The MetadataRecordSummary type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of MetadataRecordSummary.
Top
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.FixedLength Field

Grid Solutions Framework MetadataRecordSummaryFixedLength Field
Specifies the number of bytes in the binary image of MetadataRecordSummary.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.MetadataRecordSummary.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary Methods

Grid Solutions Framework MetadataRecordSummary Methods

The MetadataRecordSummary type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the MetadataRecordSummary and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes MetadataRecordSummary from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.GenerateBinaryImage Method

Grid Solutions Framework MetadataRecordSummaryGenerateBinaryImage Method
Generates binary image of the MetadataRecordSummary and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.ParseBinaryImage Method

Grid Solutions Framework MetadataRecordSummaryParseBinaryImage Method
Initializes MetadataRecordSummary from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing MetadataRecordSummary.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing MetadataRecordSummary.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary Properties

Grid Solutions Framework MetadataRecordSummary Properties

The MetadataRecordSummary type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the MetadataRecordSummary.
Public property | Enabled | Same as Enabled.
Public property | ExceptionLimit | Same as ExceptionLimit.
Public property | HighAlarm | Same as HighAlarm.
Public property | HighRange | Same as HighRange.
Public property | HighWarning | Same as HighWarning.
Public property | HistorianID | Same as HistorianID.
Public property | LowAlarm | Same as LowAlarm.
Public property | LowRange | Same as LowRange.
Public property | LowWarning | Same as LowWarning.
Top
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.BinaryLength Property

Grid Solutions Framework MetadataRecordSummaryBinaryLength Property
Gets the length of the MetadataRecordSummary.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.Enabled Property

Grid Solutions Framework MetadataRecordSummaryEnabled Property
Same as Enabled.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; }
Public ReadOnly Property Enabled As Boolean
    Get
member Enabled : bool with get

function get_Enabled();

public:
property bool Enabled {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.ExceptionLimit Property

Grid Solutions Framework MetadataRecordSummaryExceptionLimit Property
Same as ExceptionLimit.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float ExceptionLimit { get; }
Public ReadOnly Property ExceptionLimit As Single
    Get
member ExceptionLimit : float32 with get

function get_ExceptionLimit();

public:
property float ExceptionLimit {
    float get ();
}

Property Value

Type: Single
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.HighAlarm Property

Grid Solutions Framework MetadataRecordSummaryHighAlarm Property
Same as HighAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighAlarm { get; }
Public ReadOnly Property HighAlarm As Single
    Get
member HighAlarm : float32 with get

function get_HighAlarm();

public:
property float HighAlarm {
    float get ();
}

Property Value

Type: Single
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.HighRange Property

Grid Solutions Framework MetadataRecordSummaryHighRange Property
Same as HighRange.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighRange { get; }
Public ReadOnly Property HighRange As Single
    Get
member HighRange : float32 with get

function get_HighRange();

public:
property float HighRange {
    float get ();
}

Property Value

Type: Single
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.HighWarning Property

Grid Solutions Framework MetadataRecordSummaryHighWarning Property
Same as HighWarning.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float HighWarning { get; }
Public ReadOnly Property HighWarning As Single
    Get
member HighWarning : float32 with get

function get_HighWarning();

public:
property float HighWarning {
    float get ();
}

Property Value

Type: Single
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.HistorianID Property

Grid Solutions Framework MetadataRecordSummaryHistorianID Property
Same as HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; }
Public ReadOnly Property HistorianID As Integer
    Get
member HistorianID : int with get

function get_HistorianID();

public:
property int HistorianID {
    int get ();
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or -1.
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.LowAlarm Property

Grid Solutions Framework MetadataRecordSummaryLowAlarm Property
Same as LowAlarm.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowAlarm { get; }
Public ReadOnly Property LowAlarm As Single
    Get
member LowAlarm : float32 with get

function get_LowAlarm();

public:
property float LowAlarm {
    float get ();
}

Property Value

Type: Single
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.LowRange Property

Grid Solutions Framework MetadataRecordSummaryLowRange Property
Same as LowRange.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowRange { get; }
Public ReadOnly Property LowRange As Single
    Get
member LowRange : float32 with get

function get_LowRange();

public:
property float LowRange {
    float get ();
}

Property Value

Type: Single
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


MetadataRecordSummary.LowWarning Property

Grid Solutions Framework MetadataRecordSummaryLowWarning Property
Same as LowWarning.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float LowWarning { get; }
Public ReadOnly Property LowWarning As Single
    Get
member LowWarning : float32 with get

function get_LowWarning();

public:
property float LowWarning {
    float get ();
}

Property Value

Type: Single
See Also

Reference

MetadataRecordSummary Class
GSF.Historian.Files Namespace


StateFile Class

Grid Solutions Framework StateFile Class
Represents a file containing StateRecords.
Inheritance Hierarchy
SystemObject
GSF.IOIsamDataFileBase StateRecord
GSF.Historian.FilesStateFile

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(StateFile))]
public class StateFile : IsamDataFileBase<StateRecord>
<ToolboxBitmapAttribute(GetType(StateFile))>
Public Class StateFile
    Inherits IsamDataFileBase(Of StateRecord)
[<ToolboxBitmapAttribute(typeof(StateFile))>]
type StateFile =
    class
        inherit IsamDataFileBase<StateRecord>
    end
GSF.Historian.Files.StateFile = function();

Type.createClass(
    'GSF.Historian.Files.StateFile',
    GSF.IO.IsamDataFileBase`1);
[ToolboxBitmapAttribute(typeof(StateFile))]
public ref class StateFile : public IsamDataFileBase<StateRecord^>

The StateFile type exposes the following members.

Constructors
 | Name | Description
Public method | StateFile | Initializes a new instance of the StateFile class.
Top
Methods
 | Name | Description
Public method | Close | Closes the file. (Inherited from IsamDataFileBaseT.)
Protected method | CreateNewRecord | Creates a new StateRecord with the specified recordIndex. (Overrides IsamDataFileBaseTCreateNewRecord(Int32).)
Public method | Dispose | Releases all the resources used by the file. (Inherited from IsamDataFileBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources. (Inherited from IsamDataFileBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Inherited from IsamDataFileBaseT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | Gets the binary size of a StateRecord. (Overrides IsamDataFileBaseTGetRecordSize.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file. (Inherited from IsamDataFileBaseT.)
Public method | Load | Loads records from disk into memory. (Inherited from IsamDataFileBaseT.)
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataLoading | Raises the DataLoading event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaved | Raises the DataSaved event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaving | Raises the DataSaving event. (Inherited from IsamDataFileBaseT.)
Protected method | OnFileModified | Raises the FileModified event. (Inherited from IsamDataFileBaseT.)
Public method | Open | Opens the file. (Inherited from IsamDataFileBaseT.)
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory. (Inherited from IsamDataFileBaseT.)
Public method | Save | Saves records loaded in memory to disk. (Inherited from IsamDataFileBaseT.)
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableT) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Write(Int32, T) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory. (Inherited from IsamDataFileBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk. (Inherited from IsamDataFileBaseT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled. (Inherited from IsamDataFileBaseT.)
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileData | Gets the underlying FileStream of the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileDataLock | Gets the locking object for the FileData stream. (Inherited from IsamDataFileBaseT.)
Public property | FileName | Gets or sets the name of the file. (Inherited from IsamDataFileBaseT.)
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt. (Inherited from IsamDataFileBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from IsamDataFileBaseT.)
Public property | IsOpen | Gets a boolean value that indicates whether the file is open. (Inherited from IsamDataFileBaseT.)
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened. (Inherited from IsamDataFileBaseT.)
Protected property | LoadWaitHandle | Gets wait handle for loading data. (Inherited from IsamDataFileBaseT.)
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file. (Inherited from IsamDataFileBaseT.)
Public property | Name | Gets the unique identifier of the file. (Inherited from IsamDataFileBaseT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file. (Inherited from IsamDataFileBaseT.)
Public property | RecordsInMemory | Gets the number of file records loaded in memory. (Inherited from IsamDataFileBaseT.)
Public property | RecordsOnDisk | Gets the number of file records on the disk. (Inherited from IsamDataFileBaseT.)
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk. (Inherited from IsamDataFileBaseT.)
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed. (Inherited from IsamDataFileBaseT.)
Protected property | SaveWaitHandle | Gets wait handle for saving data. (Inherited from IsamDataFileBaseT.)
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public property | Status | Gets the descriptive status of the file. (Inherited from IsamDataFileBaseT.)
Top
Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataLoading | Occurs when data is being read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataSaved | Occurs when data has been saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | DataSaving | Occurs when data is being saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from IsamDataFileBaseT.)
Public event | FileModified | Occurs when file data on the disk is modified. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesStateRecord


StateFile Constructor

Grid Solutions Framework StateFile Constructor
Initializes a new instance of the StateFile class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateFile()
Public Sub New
new : unit -> StateFile
GSF.Historian.Files.StateFile = function();
public:
StateFile()
See Also

Reference

StateFile Class
GSF.Historian.Files Namespace


StateFile Methods

Grid Solutions Framework StateFile Methods

The StateFile type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the file. (Inherited from IsamDataFileBaseT.)
Protected method | CreateNewRecord | Creates a new StateRecord with the specified recordIndex. (Overrides IsamDataFileBaseTCreateNewRecord(Int32).)
Public method | Dispose | Releases all the resources used by the file. (Inherited from IsamDataFileBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources. (Inherited from IsamDataFileBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Inherited from IsamDataFileBaseT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | Gets the binary size of a StateRecord. (Overrides IsamDataFileBaseTGetRecordSize.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file. (Inherited from IsamDataFileBaseT.)
Public method | Load | Loads records from disk into memory. (Inherited from IsamDataFileBaseT.)
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataLoading | Raises the DataLoading event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaved | Raises the DataSaved event. (Inherited from IsamDataFileBaseT.)
Protected method | OnDataSaving | Raises the DataSaving event. (Inherited from IsamDataFileBaseT.)
Protected method | OnFileModified | Raises the FileModified event. (Inherited from IsamDataFileBaseT.)
Public method | Open | Opens the file. (Inherited from IsamDataFileBaseT.)
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory. (Inherited from IsamDataFileBaseT.)
Public method | Save | Saves records loaded in memory to disk. (Inherited from IsamDataFileBaseT.)
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableT) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory. (Inherited from IsamDataFileBaseT.)
Public method | Write(Int32, T) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory. (Inherited from IsamDataFileBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

StateFile Class
GSF.Historian.Files Namespace


StateFile.CreateNewRecord Method

Grid Solutions Framework StateFileCreateNewRecord Method
Creates a new StateRecord with the specified recordIndex.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override StateRecord CreateNewRecord(
    int recordIndex
)
Protected Overrides Function CreateNewRecord (
    recordIndex As Integer
) As StateRecord
abstract CreateNewRecord :
        recordIndex : int -> StateRecord
override CreateNewRecord :
        recordIndex : int -> StateRecord
function CreateNewRecord(recordIndex);
protected:
virtual StateRecord^ CreateNewRecord(
    int recordIndex
) override

Parameters

recordIndex
Type: SystemInt32
1-based index of the StateRecord.

Return Value

Type: StateRecord
A StateRecord object.
See Also

Reference

StateFile Class
GSF.Historian.Files Namespace


StateFile.GetRecordSize Method

Grid Solutions Framework StateFileGetRecordSize Method
Gets the binary size of a StateRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int GetRecordSize()
Protected Overrides Function GetRecordSize As Integer
abstract GetRecordSize : unit -> int
override GetRecordSize : unit -> int
function GetRecordSize();
protected:
virtual int GetRecordSize() override

Return Value

Type: Int32
A 32-bit signed integer.
See Also

Reference

StateFile Class
GSF.Historian.Files Namespace


StateFile Properties

Grid Solutions Framework StateFile Properties

The StateFile type exposes the following members.

Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk. (Inherited from IsamDataFileBaseT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled. (Inherited from IsamDataFileBaseT.)
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileData | Gets the underlying FileStream of the file. (Inherited from IsamDataFileBaseT.)
Protected property | FileDataLock | Gets the locking object for the FileData stream. (Inherited from IsamDataFileBaseT.)
Public property | FileName | Gets or sets the name of the file. (Inherited from IsamDataFileBaseT.)
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt. (Inherited from IsamDataFileBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from IsamDataFileBaseT.)
Public property | IsOpen | Gets a boolean value that indicates whether the file is open. (Inherited from IsamDataFileBaseT.)
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened. (Inherited from IsamDataFileBaseT.)
Protected property | LoadWaitHandle | Gets wait handle for loading data. (Inherited from IsamDataFileBaseT.)
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file. (Inherited from IsamDataFileBaseT.)
Public property | Name | Gets the unique identifier of the file. (Inherited from IsamDataFileBaseT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file. (Inherited from IsamDataFileBaseT.)
Public property | RecordsInMemory | Gets the number of file records loaded in memory. (Inherited from IsamDataFileBaseT.)
Public property | RecordsOnDisk | Gets the number of file records on the disk. (Inherited from IsamDataFileBaseT.)
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk. (Inherited from IsamDataFileBaseT.)
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed. (Inherited from IsamDataFileBaseT.)
Protected property | SaveWaitHandle | Gets wait handle for saving data. (Inherited from IsamDataFileBaseT.)
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from IsamDataFileBaseT.)
Public property | Status | Gets the descriptive status of the file. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

StateFile Class
GSF.Historian.Files Namespace


StateFile Events

Grid Solutions Framework StateFile Events

The StateFile type exposes the following members.

Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataLoading | Occurs when data is being read from disk into memory. (Inherited from IsamDataFileBaseT.)
Public event | DataSaved | Occurs when data has been saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | DataSaving | Occurs when data is being saved from memory onto disk. (Inherited from IsamDataFileBaseT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from IsamDataFileBaseT.)
Public event | FileModified | Occurs when file data on the disk is modified. (Inherited from IsamDataFileBaseT.)
Top
See Also

Reference

StateFile Class
GSF.Historian.Files Namespace


StateRecord Class

Grid Solutions Framework StateRecord Class
Represents a record in the StateFile that contains the state information associated to a HistorianID.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesStateRecord

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class StateRecord : ISupportBinaryImage,
    IComparable
Public Class StateRecord
    Implements ISupportBinaryImage, IComparable
type StateRecord =
    class
        interface ISupportBinaryImage
        interface IComparable
    end
GSF.Historian.Files.StateRecord = function();

Type.createClass(
    'GSF.Historian.Files.StateRecord',
    null,
    GSF.Parsing.ISupportBinaryImage,
    IComparable);
public ref class StateRecord : ISupportBinaryImage,
    IComparable

The StateRecord type exposes the following members.

Constructors
 | Name | Description
Public method | StateRecord(Int32) | Initializes a new instance of the StateRecord class.
Public method | StateRecord(Int32, Byte, Int32, Int32) | Initializes a new instance of the StateRecord class.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current StateRecord object to obj.
Public method | Equals | Determines whether the current StateRecord object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the StateRecord and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Returns the hash code for the current StateRecord object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes StateRecord from the specified buffer.
Public method | ToString | Returns the text representation of StateRecord object. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of StateRecord.
Top
Properties
 | Name | Description
Public property | ActiveDataBlockIndex | Gets or sets the 0-based index of the active ArchiveDataBlock for the HistorianID.
Public property | ActiveDataBlockSlot | Gets or sets the next slot position in the active ArchiveDataBlock for the HistorianID where data can be written.
Public property | ArchivedData | Gets or sets the most recently archived StateRecordDataPoint for the HistorianID.
Public property | BinaryLength | Gets the length of the StateRecord.
Public property | CurrentData | Gets or sets the most current StateRecordDataPoint received for the HistorianID.
Public property | HistorianID | Gets the historian identifier of StateRecord.
Public property | PreviousData | Gets or sets the previous StateRecordDataPoint received for the HistorianID.
Public property | Slope1 | Gets or sets slope #1 used in the piece-wise linear compression of data.
Public property | Slope2 | Gets or sets slope #2 used in the piece-wise linear compression of data.
Public property | Summary | Gets the StateRecordSummary object for StateRecord.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesStateFile
GSF.Historian.FilesStateRecordSummary
GSF.Historian.FilesStateRecordDataPoint


StateRecord Constructor

Grid Solutions Framework StateRecord Constructor
Overload List
 | Name | Description
Public method | StateRecord(Int32) | Initializes a new instance of the StateRecord class.
Public method | StateRecord(Int32, Byte, Int32, Int32) | Initializes a new instance of the StateRecord class.
Top
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord Constructor (Int32)

Grid Solutions Framework StateRecord Constructor (Int32)
Initializes a new instance of the StateRecord class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecord(
    int historianID
)
Public Sub New (
    historianID As Integer
)
new :
        historianID : int -> StateRecord
GSF.Historian.Files.StateRecord = function(historianID);
public:
StateRecord(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier of StateRecord.
See Also

Reference

StateRecord Class
StateRecord Overload
GSF.Historian.Files Namespace


StateRecord Constructor (Int32, Byte[], Int32, Int32)

Grid Solutions Framework StateRecord Constructor (Int32, Byte, Int32, Int32)
Initializes a new instance of the StateRecord class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecord(
    int historianID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    historianID As Integer,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        historianID : int *
        buffer : byte[] *
        startIndex : int *
        length : int -> StateRecord
GSF.Historian.Files.StateRecord = function(historianID, buffer, startIndex, length);
public:
StateRecord(
    int historianID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

historianID
Type: SystemInt32
Historian identifier of StateRecord.
buffer
Type: SystemByte
Binary image to be used for initializing StateRecord.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

StateRecord Class
StateRecord Overload
GSF.Historian.Files Namespace


StateRecord Fields

Grid Solutions Framework StateRecord Fields

The StateRecord type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of StateRecord.
Top
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.FixedLength Field

Grid Solutions Framework StateRecordFixedLength Field
Specifies the number of bytes in the binary image of StateRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.StateRecord.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord Methods

Grid Solutions Framework StateRecord Methods

The StateRecord type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current StateRecord object to obj.
Public method | Equals | Determines whether the current StateRecord object is equal to obj. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the StateRecord and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Returns the hash code for the current StateRecord object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes StateRecord from the specified buffer.
Public method | ToString | Returns the text representation of StateRecord object. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.CompareTo Method

Grid Solutions Framework StateRecordCompareTo Method
Compares the current StateRecord object to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
Object against which the current StateRecord object is to be compared.

Return Value

Type: Int32
Negative value if the current StateRecord object is less than obj, Zero if the current StateRecord object is equal to obj, Positive value if the current StateRecord object is greater than obj.

Implements

IComparableCompareTo(Object)
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.Equals Method

Grid Solutions Framework StateRecordEquals Method
Determines whether the current StateRecord object is equal to obj.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Object against which the current StateRecord object is to be compared for equality.

Return Value

Type: Boolean
true if the current StateRecord object is equal to obj; otherwise false.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.GenerateBinaryImage Method

Grid Solutions Framework StateRecordGenerateBinaryImage Method
Generates binary image of the StateRecord and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.GetHashCode Method

Grid Solutions Framework StateRecordGetHashCode Method
Returns the hash code for the current StateRecord object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer value.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.ParseBinaryImage Method

Grid Solutions Framework StateRecordParseBinaryImage Method
Initializes StateRecord from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing StateRecord.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing StateRecord.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.ToString Method

Grid Solutions Framework StateRecordToString Method
Returns the text representation of StateRecord object.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String value.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord Properties

Grid Solutions Framework StateRecord Properties

The StateRecord type exposes the following members.

Properties
 | Name | Description
Public property | ActiveDataBlockIndex | Gets or sets the 0-based index of the active ArchiveDataBlock for the HistorianID.
Public property | ActiveDataBlockSlot | Gets or sets the next slot position in the active ArchiveDataBlock for the HistorianID where data can be written.
Public property | ArchivedData | Gets or sets the most recently archived StateRecordDataPoint for the HistorianID.
Public property | BinaryLength | Gets the length of the StateRecord.
Public property | CurrentData | Gets or sets the most current StateRecordDataPoint received for the HistorianID.
Public property | HistorianID | Gets the historian identifier of StateRecord.
Public property | PreviousData | Gets or sets the previous StateRecordDataPoint received for the HistorianID.
Public property | Slope1 | Gets or sets slope #1 used in the piece-wise linear compression of data.
Public property | Slope2 | Gets or sets slope #2 used in the piece-wise linear compression of data.
Public property | Summary | Gets the StateRecordSummary object for StateRecord.
Top
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.ActiveDataBlockIndex Property

Grid Solutions Framework StateRecordActiveDataBlockIndex Property
Gets or sets the 0-based index of the active ArchiveDataBlock for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ActiveDataBlockIndex { get; set; }
Public Property ActiveDataBlockIndex As Integer
    Get
    Set
member ActiveDataBlockIndex : int with get, set

function get_ActiveDataBlockIndex();
function set_ActiveDataBlockIndex(value);
public:
property int ActiveDataBlockIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Index is persisted to disk as 1-based index for backwards compatibility.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.ActiveDataBlockSlot Property

Grid Solutions Framework StateRecordActiveDataBlockSlot Property
Gets or sets the next slot position in the active ArchiveDataBlock for the HistorianID where data can be written.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ActiveDataBlockSlot { get; set; }
Public Property ActiveDataBlockSlot As Integer
    Get
    Set
member ActiveDataBlockSlot : int with get, set

function get_ActiveDataBlockSlot();
function set_ActiveDataBlockSlot(value);
public:
property int ActiveDataBlockSlot {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.ArchivedData Property

Grid Solutions Framework StateRecordArchivedData Property
Gets or sets the most recently archived StateRecordDataPoint for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint ArchivedData { get; set; }
Public Property ArchivedData As StateRecordDataPoint
    Get
    Set
member ArchivedData : StateRecordDataPoint with get, set

function get_ArchivedData();
function set_ArchivedData(value);
public:
property StateRecordDataPoint^ ArchivedData {
    StateRecordDataPoint^ get ();
    void set (StateRecordDataPoint^ value);
}

Property Value

Type: StateRecordDataPoint
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.BinaryLength Property

Grid Solutions Framework StateRecordBinaryLength Property
Gets the length of the StateRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.CurrentData Property

Grid Solutions Framework StateRecordCurrentData Property
Gets or sets the most current StateRecordDataPoint received for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint CurrentData { get; set; }
Public Property CurrentData As StateRecordDataPoint
    Get
    Set
member CurrentData : StateRecordDataPoint with get, set

function get_CurrentData();
function set_CurrentData(value);
public:
property StateRecordDataPoint^ CurrentData {
    StateRecordDataPoint^ get ();
    void set (StateRecordDataPoint^ value);
}

Property Value

Type: StateRecordDataPoint
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.HistorianID Property

Grid Solutions Framework StateRecordHistorianID Property
Gets the historian identifier of StateRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; }
Public ReadOnly Property HistorianID As Integer
    Get
member HistorianID : int with get

function get_HistorianID();

public:
property int HistorianID {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.PreviousData Property

Grid Solutions Framework StateRecordPreviousData Property
Gets or sets the previous StateRecordDataPoint received for the HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint PreviousData { get; set; }
Public Property PreviousData As StateRecordDataPoint
    Get
    Set
member PreviousData : StateRecordDataPoint with get, set

function get_PreviousData();
function set_PreviousData(value);
public:
property StateRecordDataPoint^ PreviousData {
    StateRecordDataPoint^ get ();
    void set (StateRecordDataPoint^ value);
}

Property Value

Type: StateRecordDataPoint
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.Slope1 Property

Grid Solutions Framework StateRecordSlope1 Property
Gets or sets slope #1 used in the piece-wise linear compression of data.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Slope1 { get; set; }
Public Property Slope1 As Double
    Get
    Set
member Slope1 : float with get, set

function get_Slope1();
function set_Slope1(value);
public:
property double Slope1 {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.Slope2 Property

Grid Solutions Framework StateRecordSlope2 Property
Gets or sets slope #2 used in the piece-wise linear compression of data.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Slope2 { get; set; }
Public Property Slope2 As Double
    Get
    Set
member Slope2 : float with get, set

function get_Slope2();
function set_Slope2(value);
public:
property double Slope2 {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecord.Summary Property

Grid Solutions Framework StateRecordSummary Property
Gets the StateRecordSummary object for StateRecord.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordSummary Summary { get; }
Public ReadOnly Property Summary As StateRecordSummary
    Get
member Summary : StateRecordSummary with get

function get_Summary();

public:
property StateRecordSummary^ Summary {
    StateRecordSummary^ get ();
}

Property Value

Type: StateRecordSummary
See Also

Reference

StateRecord Class
GSF.Historian.Files Namespace


StateRecordDataPoint Class

Grid Solutions Framework StateRecordDataPoint Class
Represents time-series data stored in StateFile.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveDataPoint
GSF.Historian.FilesStateRecordDataPoint

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class StateRecordDataPoint : ArchiveDataPoint
Public Class StateRecordDataPoint
    Inherits ArchiveDataPoint
type StateRecordDataPoint =
    class
        inherit ArchiveDataPoint
    end
GSF.Historian.Files.StateRecordDataPoint = function();

Type.createClass(
    'GSF.Historian.Files.StateRecordDataPoint',
    GSF.Historian.Files.ArchiveDataPoint);
public ref class StateRecordDataPoint : public ArchiveDataPoint

The StateRecordDataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | StateRecordDataPoint(Int32) | Initializes a new instance of the StateRecordDataPoint class.
Public method | StateRecordDataPoint(IDataPoint) | Initializes a new instance of the StateRecordDataPoint class.
Public method | StateRecordDataPoint(Int32, TimeTag, Single, Quality) | Initializes a new instance of the StateRecordDataPoint class.
Public method | StateRecordDataPoint(Int32, Byte, Int32, Int32) | Initializes a new instance of the StateRecordDataPoint class.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataPoint object to obj. (Inherited from ArchiveDataPoint.)
Public method | Equals | Determines whether the current ArchiveDataPoint object is equal to obj. (Inherited from ArchiveDataPoint.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the StateRecordDataPoint and copies it into the given buffer, for BinaryLength bytes. (Overrides ArchiveDataPointGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Returns the hash code for the current ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes StateRecordDataPoint from the specified buffer. (Overrides ArchiveDataPointParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns the text representation of ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | ToString(IFormatProvider) | Returns the text representation of ArchiveDataPoint object using the specified provider. (Inherited from ArchiveDataPoint.)
Public method | ToString(String) | Returns the text representation of ArchiveDataPoint object in the specified format. (Inherited from ArchiveDataPoint.)
Public method | ToString(String, IFormatProvider) | Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider. (Inherited from ArchiveDataPoint.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DstMask | Specifies the bit-mask for DaylightSavingsTime stored in Flags.
FixedLength | Specifies the number of bytes in the binary image of StateRecordDataPoint.
TziMask | Specifies the bit-mask for TimeZoneIndex stored in Flags.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the StateRecordDataPoint. (Overrides ArchiveDataPointBinaryLength.)
Public property | DaylightSavingsTime | Gets a boolean value that indicates whether daylight savings time is in effect.
Protected property | Flags | Gets or sets the 32-bit word used for storing data of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | IsEmpty | Gets a boolean value that indicates whether ArchiveDataPoint contains any data. (Inherited from ArchiveDataPoint.)
Public property | Metadata | Gets or sets the associated MetadataRecord with this ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Quality | Gets or sets the Quality of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Time | Gets or sets the TimeTag of StateRecordDataPoint. (Overrides ArchiveDataPointTime.)
Public property | TimeZoneIndex | Gets or sets the 0-based index of the time-zone for the Time.
Public property | Value | Gets or sets the floating-point value of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesStateFile
GSF.Historian.FilesStateRecord
GSF.Historian.FilesStateRecordSummary


StateRecordDataPoint Constructor

Grid Solutions Framework StateRecordDataPoint Constructor
Overload List
 | Name | Description
Public method | StateRecordDataPoint(Int32) | Initializes a new instance of the StateRecordDataPoint class.
Public method | StateRecordDataPoint(IDataPoint) | Initializes a new instance of the StateRecordDataPoint class.
Public method | StateRecordDataPoint(Int32, TimeTag, Single, Quality) | Initializes a new instance of the StateRecordDataPoint class.
Public method | StateRecordDataPoint(Int32, Byte, Int32, Int32) | Initializes a new instance of the StateRecordDataPoint class.
Top
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint Constructor (Int32)

Grid Solutions Framework StateRecordDataPoint Constructor (Int32)
Initializes a new instance of the StateRecordDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint(
    int historianID
)
Public Sub New (
    historianID As Integer
)
new :
        historianID : int -> StateRecordDataPoint
GSF.Historian.Files.StateRecordDataPoint = function(historianID);
public:
StateRecordDataPoint(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier of StateRecordDataPoint.
See Also

Reference

StateRecordDataPoint Class
StateRecordDataPoint Overload
GSF.Historian.Files Namespace


StateRecordDataPoint Constructor (IDataPoint)

Grid Solutions Framework StateRecordDataPoint Constructor (IDataPoint)
Initializes a new instance of the StateRecordDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint(
    IDataPoint dataPoint
)
Public Sub New (
    dataPoint As IDataPoint
)
new :
        dataPoint : IDataPoint -> StateRecordDataPoint
GSF.Historian.Files.StateRecordDataPoint = function(dataPoint);
public:
StateRecordDataPoint(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
A time-series data point.
See Also

Reference

StateRecordDataPoint Class
StateRecordDataPoint Overload
GSF.Historian.Files Namespace


StateRecordDataPoint Constructor (Int32, TimeTag, Single, Quality)

Grid Solutions Framework StateRecordDataPoint Constructor (Int32, TimeTag, Single, Quality)
Initializes a new instance of the StateRecordDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint(
    int historianID,
    TimeTag time,
    float value,
    Quality quality
)
Public Sub New (
    historianID As Integer,
    time As TimeTag,
    value As Single,
    quality As Quality
)
new :
        historianID : int *
        time : TimeTag *
        value : float32 *
        quality : Quality -> StateRecordDataPoint
GSF.Historian.Files.StateRecordDataPoint = function(historianID, time, value, quality);
public:
StateRecordDataPoint(
    int historianID,
    TimeTag^ time,
    float value,
    Quality quality
)

Parameters

historianID
Type: SystemInt32
Historian identifier of StateRecordDataPoint.
time
Type: GSF.HistorianTimeTag
TimeTag of StateRecordDataPoint.
value
Type: SystemSingle
Floating-point value of StateRecordDataPoint.
quality
Type: GSF.HistorianQuality
Quality of StateRecordDataPoint.
See Also

Reference

StateRecordDataPoint Class
StateRecordDataPoint Overload
GSF.Historian.Files Namespace


StateRecordDataPoint Constructor (Int32, Byte[], Int32, Int32)

Grid Solutions Framework StateRecordDataPoint Constructor (Int32, Byte, Int32, Int32)
Initializes a new instance of the StateRecordDataPoint class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint(
    int historianID,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    historianID As Integer,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        historianID : int *
        buffer : byte[] *
        startIndex : int *
        length : int -> StateRecordDataPoint
GSF.Historian.Files.StateRecordDataPoint = function(historianID, buffer, startIndex, length);
public:
StateRecordDataPoint(
    int historianID,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

historianID
Type: SystemInt32
Historian identifier of StateRecordDataPoint.
buffer
Type: SystemByte
Binary image to be used for initializing StateRecordDataPoint.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

StateRecordDataPoint Class
StateRecordDataPoint Overload
GSF.Historian.Files Namespace


StateRecordDataPoint Fields

Grid Solutions Framework StateRecordDataPoint Fields

The StateRecordDataPoint type exposes the following members.

Fields
Name | Description
DstMask | Specifies the bit-mask for DaylightSavingsTime stored in Flags.
FixedLength | Specifies the number of bytes in the binary image of StateRecordDataPoint.
TziMask | Specifies the bit-mask for TimeZoneIndex stored in Flags.
Top
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.DstMask Field

Grid Solutions Framework StateRecordDataPointDstMask Field
Specifies the bit-mask for DaylightSavingsTime stored in Flags.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected const Bits DstMask
Protected Const DstMask As Bits
static val mutable DstMask: Bits
var GSF.Historian.Files.StateRecordDataPoint.DstMask
protected:
literal Bits DstMask

Field Value

Type: Bits
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.FixedLength Field

Grid Solutions Framework StateRecordDataPointFixedLength Field
Specifies the number of bytes in the binary image of StateRecordDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.StateRecordDataPoint.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.TziMask Field

Grid Solutions Framework StateRecordDataPointTziMask Field
Specifies the bit-mask for TimeZoneIndex stored in Flags.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected const Bits TziMask
Protected Const TziMask As Bits
static val mutable TziMask: Bits
var GSF.Historian.Files.StateRecordDataPoint.TziMask
protected:
literal Bits TziMask

Field Value

Type: Bits
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint Methods

Grid Solutions Framework StateRecordDataPoint Methods

The StateRecordDataPoint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataPoint object to obj. (Inherited from ArchiveDataPoint.)
Public method | Equals | Determines whether the current ArchiveDataPoint object is equal to obj. (Inherited from ArchiveDataPoint.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the StateRecordDataPoint and copies it into the given buffer, for BinaryLength bytes. (Overrides ArchiveDataPointGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Returns the hash code for the current ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes StateRecordDataPoint from the specified buffer. (Overrides ArchiveDataPointParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns the text representation of ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | ToString(IFormatProvider) | Returns the text representation of ArchiveDataPoint object using the specified provider. (Inherited from ArchiveDataPoint.)
Public method | ToString(String) | Returns the text representation of ArchiveDataPoint object in the specified format. (Inherited from ArchiveDataPoint.)
Public method | ToString(String, IFormatProvider) | Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider. (Inherited from ArchiveDataPoint.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.GenerateBinaryImage Method

Grid Solutions Framework StateRecordDataPointGenerateBinaryImage Method
Generates binary image of the StateRecordDataPoint and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.ParseBinaryImage Method

Grid Solutions Framework StateRecordDataPointParseBinaryImage Method
Initializes StateRecordDataPoint from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing StateRecordDataPoint.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing StateRecordDataPoint.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint Properties

Grid Solutions Framework StateRecordDataPoint Properties

The StateRecordDataPoint type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the StateRecordDataPoint. (Overrides ArchiveDataPointBinaryLength.)
Public property | DaylightSavingsTime | Gets a boolean value that indicates whether daylight savings time is in effect.
Protected property | Flags | Gets or sets the 32-bit word used for storing data of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | IsEmpty | Gets a boolean value that indicates whether ArchiveDataPoint contains any data. (Inherited from ArchiveDataPoint.)
Public property | Metadata | Gets or sets the associated MetadataRecord with this ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Quality | Gets or sets the Quality of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Time | Gets or sets the TimeTag of StateRecordDataPoint. (Overrides ArchiveDataPointTime.)
Public property | TimeZoneIndex | Gets or sets the 0-based index of the time-zone for the Time.
Public property | Value | Gets or sets the floating-point value of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Top
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.BinaryLength Property

Grid Solutions Framework StateRecordDataPointBinaryLength Property
Gets the length of the StateRecordDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.DaylightSavingsTime Property

Grid Solutions Framework StateRecordDataPointDaylightSavingsTime Property
Gets a boolean value that indicates whether daylight savings time is in effect.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DaylightSavingsTime { get; set; }
Public Property DaylightSavingsTime As Boolean
    Get
    Set
member DaylightSavingsTime : bool with get, set

function get_DaylightSavingsTime();
function set_DaylightSavingsTime(value);
public:
property bool DaylightSavingsTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.Time Property

Grid Solutions Framework StateRecordDataPointTime Property
Gets or sets the TimeTag of StateRecordDataPoint.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override TimeTag Time { get; set; }
Public Overrides Property Time As TimeTag
    Get
    Set
abstract Time : TimeTag with get, set
override Time : TimeTag with get, set
function get_Time();
function set_Time(value);
public:
virtual property TimeTag^ Time {
    TimeTag^ get () override;
    void set (TimeTag^ value) override;
}

Property Value

Type: TimeTag

Implements

IDataPointTime
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 01/01/1995 and 01/19/2063.
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordDataPoint.TimeZoneIndex Property

Grid Solutions Framework StateRecordDataPointTimeZoneIndex Property
Gets or sets the 0-based index of the time-zone for the Time.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short TimeZoneIndex { get; set; }
Public Property TimeZoneIndex As Short
    Get
    Set
member TimeZoneIndex : int16 with get, set

function get_TimeZoneIndex();
function set_TimeZoneIndex(value);
public:
property short TimeZoneIndex {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or zero.
See Also

Reference

StateRecordDataPoint Class
GSF.Historian.Files Namespace


StateRecordSummary Class

Grid Solutions Framework StateRecordSummary Class
A class with just CurrentData. The generated binary image of MetadataRecordSummary is sent back as a reply to PacketType11.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesStateRecordSummary

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class StateRecordSummary : ISupportBinaryImage
Public Class StateRecordSummary
    Implements ISupportBinaryImage
type StateRecordSummary =
    class
        interface ISupportBinaryImage
    end
GSF.Historian.Files.StateRecordSummary = function();

Type.createClass(
    'GSF.Historian.Files.StateRecordSummary',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class StateRecordSummary : ISupportBinaryImage

The StateRecordSummary type exposes the following members.

Constructors
 | Name | Description
Public method | StateRecordSummary(StateRecord) | Initializes a new instance of the StateRecordSummary class.
Public method | StateRecordSummary(Byte, Int32, Int32) | Initializes a new instance of the StateRecordSummary class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the StateRecordSummary and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes StateRecordSummary from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of StateRecordSummary.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the StateRecordSummary.
Public property | CurrentData | Same as CurrentData.
Public property | HistorianID | Same as HistorianID.
Top
See Also

Reference

GSF.Historian.Files Namespace
GSF.Historian.FilesStateRecord
GSF.Historian.PacketsPacketType11


StateRecordSummary Constructor

Grid Solutions Framework StateRecordSummary Constructor
Overload List
 | Name | Description
Public method | StateRecordSummary(StateRecord) | Initializes a new instance of the StateRecordSummary class.
Public method | StateRecordSummary(Byte, Int32, Int32) | Initializes a new instance of the StateRecordSummary class.
Top
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary Constructor (StateRecord)

Grid Solutions Framework StateRecordSummary Constructor (StateRecord)
Initializes a new instance of the StateRecordSummary class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordSummary(
    StateRecord record
)
Public Sub New (
    record As StateRecord
)
new :
        record : StateRecord -> StateRecordSummary
GSF.Historian.Files.StateRecordSummary = function(record);
public:
StateRecordSummary(
    StateRecord^ record
)

Parameters

record
Type: GSF.Historian.FilesStateRecord
A StateRecord object.
See Also

Reference

StateRecordSummary Class
StateRecordSummary Overload
GSF.Historian.Files Namespace


StateRecordSummary Constructor (Byte[], Int32, Int32)

Grid Solutions Framework StateRecordSummary Constructor (Byte, Int32, Int32)
Initializes a new instance of the StateRecordSummary class.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordSummary(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> StateRecordSummary
GSF.Historian.Files.StateRecordSummary = function(buffer, startIndex, length);
public:
StateRecordSummary(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing StateRecordSummary.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

StateRecordSummary Class
StateRecordSummary Overload
GSF.Historian.Files Namespace


StateRecordSummary Fields

Grid Solutions Framework StateRecordSummary Fields

The StateRecordSummary type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of StateRecordSummary.
Top
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary.FixedLength Field

Grid Solutions Framework StateRecordSummaryFixedLength Field
Specifies the number of bytes in the binary image of StateRecordSummary.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Files.StateRecordSummary.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary Methods

Grid Solutions Framework StateRecordSummary Methods

The StateRecordSummary type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the StateRecordSummary and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes StateRecordSummary from the specified buffer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary.GenerateBinaryImage Method

Grid Solutions Framework StateRecordSummaryGenerateBinaryImage Method
Generates binary image of the StateRecordSummary and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary.ParseBinaryImage Method

Grid Solutions Framework StateRecordSummaryParseBinaryImage Method
Initializes StateRecordSummary from the specified buffer.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing StateRecordSummary.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing StateRecordSummary.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary Properties

Grid Solutions Framework StateRecordSummary Properties

The StateRecordSummary type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the StateRecordSummary.
Public property | CurrentData | Same as CurrentData.
Public property | HistorianID | Same as HistorianID.
Top
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary.BinaryLength Property

Grid Solutions Framework StateRecordSummaryBinaryLength Property
Gets the length of the StateRecordSummary.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary.CurrentData Property

Grid Solutions Framework StateRecordSummaryCurrentData Property
Same as CurrentData.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StateRecordDataPoint CurrentData { get; }
Public ReadOnly Property CurrentData As StateRecordDataPoint
    Get
member CurrentData : StateRecordDataPoint with get

function get_CurrentData();

public:
property StateRecordDataPoint^ CurrentData {
    StateRecordDataPoint^ get ();
}

Property Value

Type: StateRecordDataPoint
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null.
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


StateRecordSummary.HistorianID Property

Grid Solutions Framework StateRecordSummaryHistorianID Property
Same as HistorianID.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; }
Public ReadOnly Property HistorianID As Integer
    Get
member HistorianID : int with get

function get_HistorianID();

public:
property int HistorianID {
    int get ();
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive or -1.
See Also

Reference

StateRecordSummary Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner Class

Grid Solutions Framework TimeSortedArchiveFileScanner Class
Reads a series of data points from an ArchiveFile in sorted order.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesTimeSortedArchiveFileScanner

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TimeSortedArchiveFileScanner : IArchiveFileScanner
Public Class TimeSortedArchiveFileScanner
    Implements IArchiveFileScanner
type TimeSortedArchiveFileScanner =
    class
        interface IArchiveFileScanner
    end
GSF.Historian.Files.TimeSortedArchiveFileScanner = function();

Type.createClass(
    'GSF.Historian.Files.TimeSortedArchiveFileScanner',
    null,
    GSF.Historian.Files.IArchiveFileScanner);
public ref class TimeSortedArchiveFileScanner : IArchiveFileScanner

The TimeSortedArchiveFileScanner type exposes the following members.

Constructors
 | Name | Description
Public method | TimeSortedArchiveFileScanner | Initializes a new instance of the TimeSortedArchiveFileScanner class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads all IDataPoints in time sorted order for the specified historian IDs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | DataReadExceptionHandler | Gets or sets the handler used to handle errors that occur while scanning the file.
Public property | EndTime | Gets or sets the maximum value of the timestamps of the data points returned by the scanner.
Public property | FileAllocationTable | Gets or sets the file allocation table of the file that this scanner is reading from.
Public property | HistorianIDs | Gets or sets the collection of point IDs to be scanned from the file.
Public property | ResumeFrom | Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.
Public property | StartTime | Gets or sets the minimum value of the timestamps of the data points returned by the scanner.
Top
See Also

Reference

GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner Constructor

Grid Solutions Framework TimeSortedArchiveFileScanner Constructor
Initializes a new instance of the TimeSortedArchiveFileScanner class

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeSortedArchiveFileScanner()
Public Sub New
new : unit -> TimeSortedArchiveFileScanner
GSF.Historian.Files.TimeSortedArchiveFileScanner = function();
public:
TimeSortedArchiveFileScanner()
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner Methods

Grid Solutions Framework TimeSortedArchiveFileScanner Methods

The TimeSortedArchiveFileScanner type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Read | Reads all IDataPoints in time sorted order for the specified historian IDs.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner.Read Method

Grid Solutions Framework TimeSortedArchiveFileScannerRead Method
Reads all IDataPoints in time sorted order for the specified historian IDs.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<IDataPoint> Read()
Public Function Read As IEnumerable(Of IDataPoint)
abstract Read : unit -> IEnumerable<IDataPoint>
override Read : unit -> IEnumerable<IDataPoint>
function Read();
public:
virtual IEnumerable<IDataPoint^>^ Read() sealed

Return Value

Type: IEnumerable IDataPoint
Each IDataPoint for the specified historian IDs.

Implements

IArchiveFileScannerRead
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner Properties

Grid Solutions Framework TimeSortedArchiveFileScanner Properties

The TimeSortedArchiveFileScanner type exposes the following members.

Properties
 | Name | Description
Public property | DataReadExceptionHandler | Gets or sets the handler used to handle errors that occur while scanning the file.
Public property | EndTime | Gets or sets the maximum value of the timestamps of the data points returned by the scanner.
Public property | FileAllocationTable | Gets or sets the file allocation table of the file that this scanner is reading from.
Public property | HistorianIDs | Gets or sets the collection of point IDs to be scanned from the file.
Public property | ResumeFrom | Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.
Public property | StartTime | Gets or sets the minimum value of the timestamps of the data points returned by the scanner.
Top
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner.DataReadExceptionHandler Property

Grid Solutions Framework TimeSortedArchiveFileScannerDataReadExceptionHandler Property
Gets or sets the handler used to handle errors that occur while scanning the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventHandler<EventArgs<Exception>> DataReadExceptionHandler { get; set; }
Public Property DataReadExceptionHandler As EventHandler(Of EventArgs(Of Exception))
    Get
    Set
abstract DataReadExceptionHandler : EventHandler<EventArgs<Exception>> with get, set
override DataReadExceptionHandler : EventHandler<EventArgs<Exception>> with get, set
function get_DataReadExceptionHandler();
function set_DataReadExceptionHandler(value);
public:
virtual property EventHandler<EventArgs<Exception^>^>^ DataReadExceptionHandler {
    EventHandler<EventArgs<Exception^>^>^ get () sealed;
    void set (EventHandler<EventArgs<Exception^>^>^ value) sealed;
}

Property Value

Type: EventHandler EventArgs Exception

Implements

IArchiveFileScannerDataReadExceptionHandler
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner.EndTime Property

Grid Solutions Framework TimeSortedArchiveFileScannerEndTime Property
Gets or sets the maximum value of the timestamps of the data points returned by the scanner.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag EndTime { get; set; }
Public Property EndTime As TimeTag
    Get
    Set
abstract EndTime : TimeTag with get, set
override EndTime : TimeTag with get, set
function get_EndTime();
function set_EndTime(value);
public:
virtual property TimeTag^ EndTime {
    TimeTag^ get () sealed;
    void set (TimeTag^ value) sealed;
}

Property Value

Type: TimeTag

Implements

IArchiveFileScannerEndTime
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner.FileAllocationTable Property

Grid Solutions Framework TimeSortedArchiveFileScannerFileAllocationTable Property
Gets or sets the file allocation table of the file that this scanner is reading from.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ArchiveFileAllocationTable FileAllocationTable { get; set; }
Public Property FileAllocationTable As ArchiveFileAllocationTable
    Get
    Set
abstract FileAllocationTable : ArchiveFileAllocationTable with get, set
override FileAllocationTable : ArchiveFileAllocationTable with get, set
function get_FileAllocationTable();
function set_FileAllocationTable(value);
public:
virtual property ArchiveFileAllocationTable^ FileAllocationTable {
    ArchiveFileAllocationTable^ get () sealed;
    void set (ArchiveFileAllocationTable^ value) sealed;
}

Property Value

Type: ArchiveFileAllocationTable

Implements

IArchiveFileScannerFileAllocationTable
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner.HistorianIDs Property

Grid Solutions Framework TimeSortedArchiveFileScannerHistorianIDs Property
Gets or sets the collection of point IDs to be scanned from the file.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<int> HistorianIDs { get; set; }
Public Property HistorianIDs As IEnumerable(Of Integer)
    Get
    Set
abstract HistorianIDs : IEnumerable<int> with get, set
override HistorianIDs : IEnumerable<int> with get, set
function get_HistorianIDs();
function set_HistorianIDs(value);
public:
virtual property IEnumerable<int>^ HistorianIDs {
    IEnumerable<int>^ get () sealed;
    void set (IEnumerable<int>^ value) sealed;
}

Property Value

Type: IEnumerable Int32

Implements

IArchiveFileScannerHistorianIDs
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner.ResumeFrom Property

Grid Solutions Framework TimeSortedArchiveFileScannerResumeFrom Property
Gets or sets the data point from which to resume the scan if it was interrupted by a rollover.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IDataPoint ResumeFrom { get; set; }
Public Property ResumeFrom As IDataPoint
    Get
    Set
abstract ResumeFrom : IDataPoint with get, set
override ResumeFrom : IDataPoint with get, set
function get_ResumeFrom();
function set_ResumeFrom(value);
public:
virtual property IDataPoint^ ResumeFrom {
    IDataPoint^ get () sealed;
    void set (IDataPoint^ value) sealed;
}

Property Value

Type: IDataPoint

Implements

IArchiveFileScannerResumeFrom
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


TimeSortedArchiveFileScanner.StartTime Property

Grid Solutions Framework TimeSortedArchiveFileScannerStartTime Property
Gets or sets the minimum value of the timestamps of the data points returned by the scanner.

Namespace: GSF.Historian.Files
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag StartTime { get; set; }
Public Property StartTime As TimeTag
    Get
    Set
abstract StartTime : TimeTag with get, set
override StartTime : TimeTag with get, set
function get_StartTime();
function set_StartTime(value);
public:
virtual property TimeTag^ StartTime {
    TimeTag^ get () sealed;
    void set (TimeTag^ value) sealed;
}

Property Value

Type: TimeTag

Implements

IArchiveFileScannerStartTime
See Also

Reference

TimeSortedArchiveFileScanner Class
GSF.Historian.Files Namespace


GSF.Historian.MetadataProviders Namespace

Grid Solutions Framework GSF.Historian.MetadataProviders Namespace
Contains classes that allow the historian to collect its required point metadata definitions from a variety of sources.
Classes
 | Class | Description
Public class | AdoMetadataProvider | Represents a provider of data to a MetadataFile from any ADO.NET based data store.
Public class | MetadataProviderBase | Base class for a provider of updates to the data in a MetadataFile.
Public class | MetadataProviders | A class that loads all Metadata Provider adapters.
Public class | MetadataUpdater | A class that can update data in a MetadataFile.
Public class | OleDbMetadataProvider | Represents a provider of data to a MetadataFile from any OLE DB data store.
Public class | RestWebServiceMetadataProvider | Represents a provider of data to a MetadataFile from a REST (Representational State Transfer) web service.
Interfaces
 | Interface | Description
Public interface | IMetadataProvider | Defines a provider of updates to the data in a MetadataFile.


AdoMetadataProvider Class

Grid Solutions Framework AdoMetadataProvider Class
Represents a provider of data to a MetadataFile from any ADO.NET based data store.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.MetadataProvidersMetadataProviderBase
GSF.Historian.MetadataProvidersAdoMetadataProvider

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AdoMetadataProvider : MetadataProviderBase
Public Class AdoMetadataProvider
    Inherits MetadataProviderBase
type AdoMetadataProvider =
    class
        inherit MetadataProviderBase
    end
GSF.Historian.MetadataProviders.AdoMetadataProvider = function();

Type.createClass(
    'GSF.Historian.MetadataProviders.AdoMetadataProvider',
    GSF.Historian.MetadataProviders.MetadataProviderBase);
public ref class AdoMetadataProvider : public MetadataProviderBase

The AdoMetadataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | AdoMetadataProvider | Initializes a new instance of the AdoMetadataProvider class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Inherited from MetadataProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Inherited from MetadataProviderBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved AdoMetadataProvider settings from the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event. (Inherited from MetadataProviderBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source. (Inherited from MetadataProviderBase.)
Protected method | RefreshMetadata | Refreshes the Metadata from an ADO.NET based data store. (Overrides MetadataProviderBaseRefreshMetadata.)
Public method | SaveSettings | Saves AdoMetadataProvider settings to the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConnectionString | Gets or sets the connection string for connecting to the ADO.NET based data store of metadata.
Public property | DataProviderString | Gets or sets the ADO.NET data provider assembly type creation string.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider. (Inherited from MetadataProviderBase.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically. (Inherited from MetadataProviderBase.)
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete. (Inherited from MetadataProviderBase.)
Public property | SelectString | Gets or sets the SELECT statement for retrieving metadata from the ADO.NET based data store.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out. (Inherited from MetadataProviderBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.MetadataProviders Namespace
GSF.Historian.MetadataProvidersMetadataUpdater


AdoMetadataProvider Constructor

Grid Solutions Framework AdoMetadataProvider Constructor
Initializes a new instance of the AdoMetadataProvider class.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdoMetadataProvider()
Public Sub New
new : unit -> AdoMetadataProvider
GSF.Historian.MetadataProviders.AdoMetadataProvider = function();
public:
AdoMetadataProvider()
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider Methods

Grid Solutions Framework AdoMetadataProvider Methods

The AdoMetadataProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Inherited from MetadataProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Inherited from MetadataProviderBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved AdoMetadataProvider settings from the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event. (Inherited from MetadataProviderBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source. (Inherited from MetadataProviderBase.)
Protected method | RefreshMetadata | Refreshes the Metadata from an ADO.NET based data store. (Overrides MetadataProviderBaseRefreshMetadata.)
Public method | SaveSettings | Saves AdoMetadataProvider settings to the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider.LoadSettings Method

Grid Solutions Framework AdoMetadataProviderLoadSettings Method
Loads saved AdoMetadataProvider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider.RefreshMetadata Method

Grid Solutions Framework AdoMetadataProviderRefreshMetadata Method
Refreshes the Metadata from an ADO.NET based data store.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RefreshMetadata()
Protected Overrides Sub RefreshMetadata
abstract RefreshMetadata : unit -> unit
override RefreshMetadata : unit -> unit
function RefreshMetadata();
protected:
virtual void RefreshMetadata() override
Exceptions
Exception | Condition
ArgumentNullException | ConnectionString or SelectString is set to a null or empty string.
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider.SaveSettings Method

Grid Solutions Framework AdoMetadataProviderSaveSettings Method
Saves AdoMetadataProvider settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider Properties

Grid Solutions Framework AdoMetadataProvider Properties

The AdoMetadataProvider type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString | Gets or sets the connection string for connecting to the ADO.NET based data store of metadata.
Public property | DataProviderString | Gets or sets the ADO.NET data provider assembly type creation string.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider. (Inherited from MetadataProviderBase.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically. (Inherited from MetadataProviderBase.)
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete. (Inherited from MetadataProviderBase.)
Public property | SelectString | Gets or sets the SELECT statement for retrieving metadata from the ADO.NET based data store.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider.ConnectionString Property

Grid Solutions Framework AdoMetadataProviderConnectionString Property
Gets or sets the connection string for connecting to the ADO.NET based data store of metadata.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
member ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider.DataProviderString Property

Grid Solutions Framework AdoMetadataProviderDataProviderString Property
Gets or sets the ADO.NET data provider assembly type creation string.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DataProviderString { get; set; }
Public Property DataProviderString As String
    Get
    Set
member DataProviderString : string with get, set

function get_DataProviderString();
function set_DataProviderString(value);
public:
property String^ DataProviderString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Expected keys: AssemblyName;ConnectionType
Examples:
Database Connection Type | Example ADO.NET Data Provider String
SQL Server | AssemblyName={System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089};ConnectionType=System.Data.SqlClient.SqlConnection
MySQL | AssemblyName={MySql.Data, Version=5.2.7.0, Culture=neutral, PublicKeyToken=c5687fc88969c44d};ConnectionType=MySql.Data.MySqlClient.MySqlConnection
Oracle | AssemblyName={System.Data.OracleClient, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089};ConnectionType=System.Data.OracleClient.OracleConnection
OleDb | AssemblyName={System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089};ConnectionType=System.Data.OleDb.OleDbConnection
ODBC | AssemblyName={System.Data, Version=2.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089};ConnectionType=System.Data.Odbc.OdbcConnection
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider.SelectString Property

Grid Solutions Framework AdoMetadataProviderSelectString Property
Gets or sets the SELECT statement for retrieving metadata from the ADO.NET based data store.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SelectString { get; set; }
Public Property SelectString As String
    Get
    Set
member SelectString : string with get, set

function get_SelectString();
function set_SelectString(value);
public:
property String^ SelectString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


AdoMetadataProvider Events

Grid Solutions Framework AdoMetadataProvider Events

The AdoMetadataProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out. (Inherited from MetadataProviderBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

AdoMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


IMetadataProvider Interface

Grid Solutions Framework IMetadataProvider Interface
Defines a provider of updates to the data in a MetadataFile.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IMetadataProvider : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
Public Interface IMetadataProvider
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
type IMetadataProvider =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.MetadataProviders.IMetadataProvider = function();
GSF.Historian.MetadataProviders.IMetadataProvider.createInterface('GSF.Historian.MetadataProviders.IMetadataProvider');
public interface class IMetadataProvider : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The IMetadataProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Refresh | Refreshes the Metadata from an external source.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | RefreshInterval | Gets or sets the number of minutes at which the Metadata if to be refreshed automatically.
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed.
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata.
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started.
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.Historian.MetadataProviders Namespace
GSF.Historian.FilesMetadataFile


IMetadataProvider Methods

Grid Solutions Framework IMetadataProvider Methods

The IMetadataProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Refresh | Refreshes the Metadata from an external source.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.Refresh Method

Grid Solutions Framework IMetadataProviderRefresh Method
Refreshes the Metadata from an external source.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Refresh()
Function Refresh As Boolean
abstract Refresh : unit -> bool

function Refresh();
bool Refresh()

Return Value

Type: Boolean
true if the Metadata is refreshed; otherwise false.
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider Properties

Grid Solutions Framework IMetadataProvider Properties

The IMetadataProvider type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | RefreshInterval | Gets or sets the number of minutes at which the Metadata if to be refreshed automatically.
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.Metadata Property

Grid Solutions Framework IMetadataProviderMetadata Property
Gets or sets the MetadataFile to be refreshed by the metadata provider.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MetadataFile Metadata { get; set; }
Property Metadata As MetadataFile
    Get
    Set
abstract Metadata : MetadataFile with get, set

function get_Metadata();
function set_Metadata(value);
property MetadataFile^ Metadata {
    MetadataFile^ get ();
    void set (MetadataFile^ value);
}

Property Value

Type: MetadataFile
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.RefreshInterval Property

Grid Solutions Framework IMetadataProviderRefreshInterval Property
Gets or sets the number of minutes at which the Metadata if to be refreshed automatically.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int RefreshInterval { get; set; }
Property RefreshInterval As Integer
    Get
    Set
abstract RefreshInterval : int with get, set

function get_RefreshInterval();
function set_RefreshInterval(value);
property int RefreshInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.RefreshTimeout Property

Grid Solutions Framework IMetadataProviderRefreshTimeout Property
Gets or sets the number of seconds to wait for the Refresh to complete.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int RefreshTimeout { get; set; }
Property RefreshTimeout As Integer
    Get
    Set
abstract RefreshTimeout : int with get, set

function get_RefreshTimeout();
function set_RefreshTimeout(value);
property int RefreshTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider Events

Grid Solutions Framework IMetadataProvider Events

The IMetadataProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed.
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata.
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started.
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.MetadataRefreshComplete Event

Grid Solutions Framework IMetadataProviderMetadataRefreshComplete Event
Occurs when Refresh of Metadata is completed.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler MetadataRefreshComplete
Event MetadataRefreshComplete As EventHandler
abstract MetadataRefreshComplete : IEvent<EventHandler,
    EventArgs>

function add_MetadataRefreshComplete(value);
function remove_MetadataRefreshComplete(value);
 event EventHandler^ MetadataRefreshComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.MetadataRefreshException Event

Grid Solutions Framework IMetadataProviderMetadataRefreshException Event
Occurs when an Exception is encountered during Refresh of Metadata.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> MetadataRefreshException
Event MetadataRefreshException As EventHandler(Of EventArgs(Of Exception))
abstract MetadataRefreshException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_MetadataRefreshException(value);
function remove_MetadataRefreshException(value);
 event EventHandler<EventArgs<Exception^>^>^ MetadataRefreshException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.MetadataRefreshStart Event

Grid Solutions Framework IMetadataProviderMetadataRefreshStart Event
Occurs when Refresh of Metadata is started.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler MetadataRefreshStart
Event MetadataRefreshStart As EventHandler
abstract MetadataRefreshStart : IEvent<EventHandler,
    EventArgs>

function add_MetadataRefreshStart(value);
function remove_MetadataRefreshStart(value);
 event EventHandler^ MetadataRefreshStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


IMetadataProvider.MetadataRefreshTimeout Event

Grid Solutions Framework IMetadataProviderMetadataRefreshTimeout Event
Occurs when Refresh of Metadata times out.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler MetadataRefreshTimeout
Event MetadataRefreshTimeout As EventHandler
abstract MetadataRefreshTimeout : IEvent<EventHandler,
    EventArgs>

function add_MetadataRefreshTimeout(value);
function remove_MetadataRefreshTimeout(value);
 event EventHandler^ MetadataRefreshTimeout {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IMetadataProvider Interface
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase Class

Grid Solutions Framework MetadataProviderBase Class
Base class for a provider of updates to the data in a MetadataFile.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.MetadataProvidersMetadataProviderBase
GSF.Historian.MetadataProvidersAdoMetadataProvider
GSF.Historian.MetadataProvidersOleDbMetadataProvider
GSF.Historian.MetadataProvidersRestWebServiceMetadataProvider

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class MetadataProviderBase : Adapter,
    IMetadataProvider, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
Public MustInherit Class MetadataProviderBase
    Inherits Adapter
    Implements IMetadataProvider, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
[<AbstractClassAttribute>]
type MetadataProviderBase =
    class
        inherit Adapter
        interface IMetadataProvider
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.MetadataProviders.MetadataProviderBase = function();

Type.createClass(
    'GSF.Historian.MetadataProviders.MetadataProviderBase',
    GSF.Adapters.Adapter,
    GSF.Historian.MetadataProviders.IMetadataProvider,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
public ref class MetadataProviderBase abstract : public Adapter,
    IMetadataProvider, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings

The MetadataProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | MetadataProviderBase | Initializes a new instance of the metadata provider.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Overrides AdapterInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved metadata provider settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event.
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event.
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event.
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source.
Protected method | RefreshMetadata | When overridden in a derived class, refreshes the Metadata from an external source.
Public method | SaveSettings | Saves metadata provider settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider.
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically.
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed.
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata.
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started.
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.MetadataProviders Namespace


MetadataProviderBase Constructor

Grid Solutions Framework MetadataProviderBase Constructor
Initializes a new instance of the metadata provider.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected MetadataProviderBase()
Protected Sub New
new : unit -> MetadataProviderBase
GSF.Historian.MetadataProviders.MetadataProviderBase = function();
protected:
MetadataProviderBase()
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase Methods

Grid Solutions Framework MetadataProviderBase Methods

The MetadataProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Overrides AdapterInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved metadata provider settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event.
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event.
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event.
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source.
Protected method | RefreshMetadata | When overridden in a derived class, refreshes the Metadata from an external source.
Public method | SaveSettings | Saves metadata provider settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.Dispose Method

Grid Solutions Framework MetadataProviderBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Top
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.Dispose Method (Boolean)

Grid Solutions Framework MetadataProviderBaseDispose Method (Boolean)
Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

MetadataProviderBase Class
Dispose Overload
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.Initialize Method

Grid Solutions Framework MetadataProviderBaseInitialize Method
Initializes the metadata provider.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.LoadSettings Method

Grid Solutions Framework MetadataProviderBaseLoadSettings Method
Loads saved metadata provider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.OnMetadataRefreshComplete Method

Grid Solutions Framework MetadataProviderBaseOnMetadataRefreshComplete Method
Raises the MetadataRefreshComplete event.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnMetadataRefreshComplete()
Protected Overridable Sub OnMetadataRefreshComplete
abstract OnMetadataRefreshComplete : unit -> unit
override OnMetadataRefreshComplete : unit -> unit
function OnMetadataRefreshComplete();
protected:
virtual void OnMetadataRefreshComplete()
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.OnMetadataRefreshException Method

Grid Solutions Framework MetadataProviderBaseOnMetadataRefreshException Method
Raises the MetadataRefreshException event.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnMetadataRefreshException(
    Exception ex
)
Protected Overridable Sub OnMetadataRefreshException (
    ex As Exception
)
abstract OnMetadataRefreshException :
        ex : Exception -> unit
override OnMetadataRefreshException :
        ex : Exception -> unit
function OnMetadataRefreshException(ex);
protected:
virtual void OnMetadataRefreshException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to MetadataRefreshException event.
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.OnMetadataRefreshStart Method

Grid Solutions Framework MetadataProviderBaseOnMetadataRefreshStart Method
Raises the MetadataRefreshStart event.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnMetadataRefreshStart()
Protected Overridable Sub OnMetadataRefreshStart
abstract OnMetadataRefreshStart : unit -> unit
override OnMetadataRefreshStart : unit -> unit
function OnMetadataRefreshStart();
protected:
virtual void OnMetadataRefreshStart()
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.OnMetadataRefreshTimeout Method

Grid Solutions Framework MetadataProviderBaseOnMetadataRefreshTimeout Method
Raises the MetadataRefreshTimeout event.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnMetadataRefreshTimeout()
Protected Overridable Sub OnMetadataRefreshTimeout
abstract OnMetadataRefreshTimeout : unit -> unit
override OnMetadataRefreshTimeout : unit -> unit
function OnMetadataRefreshTimeout();
protected:
virtual void OnMetadataRefreshTimeout()
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.Refresh Method

Grid Solutions Framework MetadataProviderBaseRefresh Method
Refreshes the Metadata from an external source.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Refresh()
Public Function Refresh As Boolean
abstract Refresh : unit -> bool
override Refresh : unit -> bool
function Refresh();
public:
virtual bool Refresh() sealed

Return Value

Type: Boolean
true if the Metadata is refreshed; otherwise false.

Implements

IMetadataProviderRefresh
Exceptions
Exception | Condition
ArgumentNullException | Metadata is null.
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.RefreshMetadata Method

Grid Solutions Framework MetadataProviderBaseRefreshMetadata Method
When overridden in a derived class, refreshes the Metadata from an external source.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void RefreshMetadata()
Protected MustOverride Sub RefreshMetadata
abstract RefreshMetadata : unit -> unit

function RefreshMetadata();
protected:
virtual void RefreshMetadata() abstract
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.SaveSettings Method

Grid Solutions Framework MetadataProviderBaseSaveSettings Method
Saves metadata provider settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase Properties

Grid Solutions Framework MetadataProviderBase Properties

The MetadataProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider.
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically.
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.Metadata Property

Grid Solutions Framework MetadataProviderBaseMetadata Property
Gets or sets the MetadataFile to be refreshed by the metadata provider.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataFile Metadata { get; set; }
Public Property Metadata As MetadataFile
    Get
    Set
abstract Metadata : MetadataFile with get, set
override Metadata : MetadataFile with get, set
function get_Metadata();
function set_Metadata(value);
public:
virtual property MetadataFile^ Metadata {
    MetadataFile^ get () sealed;
    void set (MetadataFile^ value) sealed;
}

Property Value

Type: MetadataFile

Implements

IMetadataProviderMetadata
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.RefreshInterval Property

Grid Solutions Framework MetadataProviderBaseRefreshInterval Property
Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int RefreshInterval { get; set; }
Public Property RefreshInterval As Integer
    Get
    Set
abstract RefreshInterval : int with get, set
override RefreshInterval : int with get, set
function get_RefreshInterval();
function set_RefreshInterval(value);
public:
virtual property int RefreshInterval {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IMetadataProviderRefreshInterval
Remarks
Set RefreshInterval to -1 to disable auto Refresh.
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.RefreshTimeout Property

Grid Solutions Framework MetadataProviderBaseRefreshTimeout Property
Gets or sets the number of seconds to wait for the Refresh to complete.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int RefreshTimeout { get; set; }
Public Property RefreshTimeout As Integer
    Get
    Set
abstract RefreshTimeout : int with get, set
override RefreshTimeout : int with get, set
function get_RefreshTimeout();
function set_RefreshTimeout(value);
public:
virtual property int RefreshTimeout {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IMetadataProviderRefreshTimeout
Remarks
Set RefreshTimeout to -1 to wait indefinitely on Refresh.
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase Events

Grid Solutions Framework MetadataProviderBase Events

The MetadataProviderBase type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed.
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata.
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started.
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.MetadataRefreshComplete Event

Grid Solutions Framework MetadataProviderBaseMetadataRefreshComplete Event
Occurs when Refresh of Metadata is completed.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler MetadataRefreshComplete
Public Event MetadataRefreshComplete As EventHandler
abstract MetadataRefreshComplete : IEvent<EventHandler,
    EventArgs>
override MetadataRefreshComplete : IEvent<EventHandler,
    EventArgs>
function add_MetadataRefreshComplete(value);
function remove_MetadataRefreshComplete(value);
public:
virtual  event EventHandler^ MetadataRefreshComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IMetadataProviderMetadataRefreshComplete
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.MetadataRefreshException Event

Grid Solutions Framework MetadataProviderBaseMetadataRefreshException Event
Occurs when an Exception is encountered during Refresh of Metadata.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> MetadataRefreshException
Public Event MetadataRefreshException As EventHandler(Of EventArgs(Of Exception))
abstract MetadataRefreshException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override MetadataRefreshException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_MetadataRefreshException(value);
function remove_MetadataRefreshException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ MetadataRefreshException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IMetadataProviderMetadataRefreshException
Remarks
Argument is the Exception encountered during Refresh.
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.MetadataRefreshStart Event

Grid Solutions Framework MetadataProviderBaseMetadataRefreshStart Event
Occurs when Refresh of Metadata is started.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler MetadataRefreshStart
Public Event MetadataRefreshStart As EventHandler
abstract MetadataRefreshStart : IEvent<EventHandler,
    EventArgs>
override MetadataRefreshStart : IEvent<EventHandler,
    EventArgs>
function add_MetadataRefreshStart(value);
function remove_MetadataRefreshStart(value);
public:
virtual  event EventHandler^ MetadataRefreshStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IMetadataProviderMetadataRefreshStart
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviderBase.MetadataRefreshTimeout Event

Grid Solutions Framework MetadataProviderBaseMetadataRefreshTimeout Event
Occurs when Refresh of Metadata times out.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler MetadataRefreshTimeout
Public Event MetadataRefreshTimeout As EventHandler
abstract MetadataRefreshTimeout : IEvent<EventHandler,
    EventArgs>
override MetadataRefreshTimeout : IEvent<EventHandler,
    EventArgs>
function add_MetadataRefreshTimeout(value);
function remove_MetadataRefreshTimeout(value);
public:
virtual  event EventHandler^ MetadataRefreshTimeout {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IMetadataProviderMetadataRefreshTimeout
See Also

Reference

MetadataProviderBase Class
GSF.Historian.MetadataProviders Namespace


MetadataProviders Class

Grid Solutions Framework MetadataProviders Class
A class that loads all Metadata Provider adapters.
Inheritance Hierarchy
SystemObject
GSF.AdaptersAdapterLoader IMetadataProvider
GSF.Historian.MetadataProvidersMetadataProviders

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataProviders : AdapterLoader<IMetadataProvider>
Public Class MetadataProviders
    Inherits AdapterLoader(Of IMetadataProvider)
type MetadataProviders =
    class
        inherit AdapterLoader<IMetadataProvider>
    end
GSF.Historian.MetadataProviders.MetadataProviders = function();

Type.createClass(
    'GSF.Historian.MetadataProviders.MetadataProviders',
    GSF.Adapters.AdapterLoader`1);
public ref class MetadataProviders : public AdapterLoader<IMetadataProvider^>

The MetadataProviders type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataProviders | Initializes a new instance of the MetadataProviders class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes Refresh on the specified metadata provider adapter. (Overrides AdapterLoaderTExecuteAdapterOperation(T, Object).)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | RefreshAll | Refreshes the Metadata using all loaded metadata provider Adapters.
Public method | RefreshOne | Refreshes the Metadata using the specified provider from the loaded metadata provider Adapters.
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

GSF.Historian.MetadataProviders Namespace
GSF.Historian.MetadataProvidersIMetadataProvider


MetadataProviders Constructor

Grid Solutions Framework MetadataProviders Constructor
Initializes a new instance of the MetadataProviders class

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataProviders()
Public Sub New
new : unit -> MetadataProviders
GSF.Historian.MetadataProviders.MetadataProviders = function();
public:
MetadataProviders()
See Also

Reference

MetadataProviders Class
GSF.Historian.MetadataProviders Namespace


MetadataProviders Methods

Grid Solutions Framework MetadataProviders Methods

The MetadataProviders type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes Refresh on the specified metadata provider adapter. (Overrides AdapterLoaderTExecuteAdapterOperation(T, Object).)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | RefreshAll | Refreshes the Metadata using all loaded metadata provider Adapters.
Public method | RefreshOne | Refreshes the Metadata using the specified provider from the loaded metadata provider Adapters.
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataProviders Class
GSF.Historian.MetadataProviders Namespace


MetadataProviders.ExecuteAdapterOperation Method

Grid Solutions Framework MetadataProvidersExecuteAdapterOperation Method
Executes Refresh on the specified metadata provider adapter.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExecuteAdapterOperation(
    IMetadataProvider adapter,
    Object data
)
Protected Overrides Sub ExecuteAdapterOperation (
    adapter As IMetadataProvider,
    data As Object
)
abstract ExecuteAdapterOperation :
        adapter : IMetadataProvider *
        data : Object -> unit
override ExecuteAdapterOperation :
        adapter : IMetadataProvider *
        data : Object -> unit
function ExecuteAdapterOperation(adapter, data);
protected:
virtual void ExecuteAdapterOperation(
    IMetadataProvider^ adapter,
    Object^ data
) override

Parameters

adapter
Type: GSF.Historian.MetadataProvidersIMetadataProvider
An IMetadataProvider object.
data
Type: SystemObject
Name of the adapter.
See Also

Reference

MetadataProviders Class
GSF.Historian.MetadataProviders Namespace


MetadataProviders.RefreshAll Method

Grid Solutions Framework MetadataProvidersRefreshAll Method
Refreshes the Metadata using all loaded metadata provider Adapters.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RefreshAll()
Public Sub RefreshAll
member RefreshAll : unit -> unit

function RefreshAll();
public:
void RefreshAll()
See Also

Reference

MetadataProviders Class
GSF.Historian.MetadataProviders Namespace


MetadataProviders.RefreshOne Method

Grid Solutions Framework MetadataProvidersRefreshOne Method
Refreshes the Metadata using the specified provider from the loaded metadata provider Adapters.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RefreshOne(
    string provider
)
Public Sub RefreshOne (
    provider As String
)
member RefreshOne :
        provider : string -> unit

function RefreshOne(provider);
public:
void RefreshOne(
    String^ provider
)

Parameters

provider
Type: SystemString
Name of the IMetadataProvider to use for the Refresh.
See Also

Reference

MetadataProviders Class
GSF.Historian.MetadataProviders Namespace


MetadataProviders Properties

Grid Solutions Framework MetadataProviders Properties

The MetadataProviders type exposes the following members.

Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

MetadataProviders Class
GSF.Historian.MetadataProviders Namespace


MetadataProviders Events

Grid Solutions Framework MetadataProviders Events

The MetadataProviders type exposes the following members.

Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

MetadataProviders Class
GSF.Historian.MetadataProviders Namespace


MetadataUpdater Class

Grid Solutions Framework MetadataUpdater Class
A class that can update data in a MetadataFile.
Inheritance Hierarchy
SystemObject
GSF.Historian.MetadataProvidersMetadataUpdater

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MetadataUpdater
Public Class MetadataUpdater
type MetadataUpdater =  class end
GSF.Historian.MetadataProviders.MetadataUpdater = function();

Type.createClass(
    'GSF.Historian.MetadataProviders.MetadataUpdater');
public ref class MetadataUpdater

The MetadataUpdater type exposes the following members.

Constructors
 | Name | Description
Public method | MetadataUpdater | Initializes a new instance of the MetadataUpdater class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateMetadata(DataTable) | Updates the Metadata from tableData
Public method | UpdateMetadata(IDataReader) | Updates the Metadata from readerData
Public method | UpdateMetadata(Stream, SerializationFormat) | Updates the Metadata from streamData
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Metadata | Gets the MetadataFile to be updated.
Top
See Also

Reference

GSF.Historian.MetadataProviders Namespace
GSF.Historian.FilesMetadataFile


MetadataUpdater Constructor

Grid Solutions Framework MetadataUpdater Constructor
Initializes a new instance of the MetadataUpdater class.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataUpdater(
    MetadataFile metadata
)
Public Sub New (
    metadata As MetadataFile
)
new :
        metadata : MetadataFile -> MetadataUpdater
GSF.Historian.MetadataProviders.MetadataUpdater = function(metadata);
public:
MetadataUpdater(
    MetadataFile^ metadata
)

Parameters

metadata
Type: GSF.Historian.FilesMetadataFile
MetadataFile that is to be updated.
Exceptions
Exception | Condition
ArgumentNullException | metadata is null
See Also

Reference

MetadataUpdater Class
GSF.Historian.MetadataProviders Namespace


MetadataUpdater Methods

Grid Solutions Framework MetadataUpdater Methods

The MetadataUpdater type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateMetadata(DataTable) | Updates the Metadata from tableData
Public method | UpdateMetadata(IDataReader) | Updates the Metadata from readerData
Public method | UpdateMetadata(Stream, SerializationFormat) | Updates the Metadata from streamData
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MetadataUpdater Class
GSF.Historian.MetadataProviders Namespace


MetadataUpdater.UpdateMetadata Method

Grid Solutions Framework MetadataUpdaterUpdateMetadata Method
Overload List
 | Name | Description
Public method | UpdateMetadata(DataTable) | Updates the Metadata from tableData
Public method | UpdateMetadata(IDataReader) | Updates the Metadata from readerData
Public method | UpdateMetadata(Stream, SerializationFormat) | Updates the Metadata from streamData
Top
See Also

Reference

MetadataUpdater Class
GSF.Historian.MetadataProviders Namespace


MetadataUpdater.UpdateMetadata Method (DataTable)

Grid Solutions Framework MetadataUpdaterUpdateMetadata Method (DataTable)
Updates the Metadata from tableData

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateMetadata(
    DataTable tableData
)
Public Sub UpdateMetadata (
    tableData As DataTable
)
member UpdateMetadata :
        tableData : DataTable -> unit

function UpdateMetadata(tableData);
public:
void UpdateMetadata(
    DataTable^ tableData
)

Parameters

tableData
Type: System.DataDataTable
DataTable containing the new metadata.
Exceptions
Exception | Condition
ArgumentNullException | tableData is null.
ArgumentException | tableData does not contain 43 columns.
See Also

Reference

MetadataUpdater Class
UpdateMetadata Overload
GSF.Historian.MetadataProviders Namespace


MetadataUpdater.UpdateMetadata Method (IDataReader)

Grid Solutions Framework MetadataUpdaterUpdateMetadata Method (IDataReader)
Updates the Metadata from readerData

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateMetadata(
    IDataReader readerData
)
Public Sub UpdateMetadata (
    readerData As IDataReader
)
member UpdateMetadata :
        readerData : IDataReader -> unit

function UpdateMetadata(readerData);
public:
void UpdateMetadata(
    IDataReader^ readerData
)

Parameters

readerData
Type: System.DataIDataReader
IDataReader providing the new metadata.
Exceptions
Exception | Condition
ArgumentNullException | readerData is null.
ArgumentException | readerData does not contain 43 columns.
See Also

Reference

MetadataUpdater Class
UpdateMetadata Overload
GSF.Historian.MetadataProviders Namespace


MetadataUpdater.UpdateMetadata Method (Stream, SerializationFormat)

Grid Solutions Framework MetadataUpdaterUpdateMetadata Method (Stream, SerializationFormat)
Updates the Metadata from streamData

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateMetadata(
    Stream streamData,
    SerializationFormat dataFormat
)
Public Sub UpdateMetadata (
    streamData As Stream,
    dataFormat As SerializationFormat
)
member UpdateMetadata :
        streamData : Stream *
        dataFormat : SerializationFormat -> unit

function UpdateMetadata(streamData, dataFormat);
public:
void UpdateMetadata(
    Stream^ streamData,
    SerializationFormat dataFormat
)

Parameters

streamData
Type: System.IOStream
Stream containing serialized SerializableMetadata.
dataFormat
Type: GSFSerializationFormat
SerializationFormat in which the SerializableMetadata was serialized to streamData.
See Also

Reference

MetadataUpdater Class
UpdateMetadata Overload
GSF.Historian.MetadataProviders Namespace


MetadataUpdater Properties

Grid Solutions Framework MetadataUpdater Properties

The MetadataUpdater type exposes the following members.

Properties
 | Name | Description
Public property | Metadata | Gets the MetadataFile to be updated.
Top
See Also

Reference

MetadataUpdater Class
GSF.Historian.MetadataProviders Namespace


MetadataUpdater.Metadata Property

Grid Solutions Framework MetadataUpdaterMetadata Property
Gets the MetadataFile to be updated.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MetadataFile Metadata { get; }
Public ReadOnly Property Metadata As MetadataFile
    Get
member Metadata : MetadataFile with get

function get_Metadata();

public:
property MetadataFile^ Metadata {
    MetadataFile^ get ();
}

Property Value

Type: MetadataFile
See Also

Reference

MetadataUpdater Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider Class

Grid Solutions Framework OleDbMetadataProvider Class
Represents a provider of data to a MetadataFile from any OLE DB data store.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.MetadataProvidersMetadataProviderBase
GSF.Historian.MetadataProvidersOleDbMetadataProvider

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class OleDbMetadataProvider : MetadataProviderBase
Public Class OleDbMetadataProvider
    Inherits MetadataProviderBase
type OleDbMetadataProvider =
    class
        inherit MetadataProviderBase
    end
GSF.Historian.MetadataProviders.OleDbMetadataProvider = function();

Type.createClass(
    'GSF.Historian.MetadataProviders.OleDbMetadataProvider',
    GSF.Historian.MetadataProviders.MetadataProviderBase);
public ref class OleDbMetadataProvider : public MetadataProviderBase

The OleDbMetadataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | OleDbMetadataProvider | Initializes a new instance of the OleDbMetadataProvider class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Inherited from MetadataProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Inherited from MetadataProviderBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved OleDbMetadataProvider settings from the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event. (Inherited from MetadataProviderBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source. (Inherited from MetadataProviderBase.)
Protected method | RefreshMetadata | Refreshes the Metadata from an OLE DB data store. (Overrides MetadataProviderBaseRefreshMetadata.)
Public method | SaveSettings | Saves OleDbMetadataProvider settings to the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConnectionString | Gets or sets the connection string for connecting to the OLE DB data store of metadata.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider. (Inherited from MetadataProviderBase.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically. (Inherited from MetadataProviderBase.)
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete. (Inherited from MetadataProviderBase.)
Public property | SelectString | Gets or sets the SELECT statement for retrieving metadata from the OLE DB data store.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out. (Inherited from MetadataProviderBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.MetadataProviders Namespace
GSF.Historian.MetadataProvidersMetadataUpdater


OleDbMetadataProvider Constructor

Grid Solutions Framework OleDbMetadataProvider Constructor
Initializes a new instance of the OleDbMetadataProvider class.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OleDbMetadataProvider()
Public Sub New
new : unit -> OleDbMetadataProvider
GSF.Historian.MetadataProviders.OleDbMetadataProvider = function();
public:
OleDbMetadataProvider()
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider Methods

Grid Solutions Framework OleDbMetadataProvider Methods

The OleDbMetadataProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Inherited from MetadataProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Inherited from MetadataProviderBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved OleDbMetadataProvider settings from the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event. (Inherited from MetadataProviderBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source. (Inherited from MetadataProviderBase.)
Protected method | RefreshMetadata | Refreshes the Metadata from an OLE DB data store. (Overrides MetadataProviderBaseRefreshMetadata.)
Public method | SaveSettings | Saves OleDbMetadataProvider settings to the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider.LoadSettings Method

Grid Solutions Framework OleDbMetadataProviderLoadSettings Method
Loads saved OleDbMetadataProvider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider.RefreshMetadata Method

Grid Solutions Framework OleDbMetadataProviderRefreshMetadata Method
Refreshes the Metadata from an OLE DB data store.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RefreshMetadata()
Protected Overrides Sub RefreshMetadata
abstract RefreshMetadata : unit -> unit
override RefreshMetadata : unit -> unit
function RefreshMetadata();
protected:
virtual void RefreshMetadata() override
Exceptions
Exception | Condition
ArgumentNullException | ConnectionString or SelectString is set to a null or empty string.
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider.SaveSettings Method

Grid Solutions Framework OleDbMetadataProviderSaveSettings Method
Saves OleDbMetadataProvider settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider Properties

Grid Solutions Framework OleDbMetadataProvider Properties

The OleDbMetadataProvider type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString | Gets or sets the connection string for connecting to the OLE DB data store of metadata.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider. (Inherited from MetadataProviderBase.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically. (Inherited from MetadataProviderBase.)
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete. (Inherited from MetadataProviderBase.)
Public property | SelectString | Gets or sets the SELECT statement for retrieving metadata from the OLE DB data store.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider.ConnectionString Property

Grid Solutions Framework OleDbMetadataProviderConnectionString Property
Gets or sets the connection string for connecting to the OLE DB data store of metadata.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
member ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider.SelectString Property

Grid Solutions Framework OleDbMetadataProviderSelectString Property
Gets or sets the SELECT statement for retrieving metadata from the OLE DB data store.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SelectString { get; set; }
Public Property SelectString As String
    Get
    Set
member SelectString : string with get, set

function get_SelectString();
function set_SelectString(value);
public:
property String^ SelectString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


OleDbMetadataProvider Events

Grid Solutions Framework OleDbMetadataProvider Events

The OleDbMetadataProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out. (Inherited from MetadataProviderBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

OleDbMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider Class

Grid Solutions Framework RestWebServiceMetadataProvider Class
Represents a provider of data to a MetadataFile from a REST (Representational State Transfer) web service.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.MetadataProvidersMetadataProviderBase
GSF.Historian.MetadataProvidersRestWebServiceMetadataProvider

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RestWebServiceMetadataProvider : MetadataProviderBase
Public Class RestWebServiceMetadataProvider
    Inherits MetadataProviderBase
type RestWebServiceMetadataProvider =
    class
        inherit MetadataProviderBase
    end
GSF.Historian.MetadataProviders.RestWebServiceMetadataProvider = function();

Type.createClass(
    'GSF.Historian.MetadataProviders.RestWebServiceMetadataProvider',
    GSF.Historian.MetadataProviders.MetadataProviderBase);
public ref class RestWebServiceMetadataProvider : public MetadataProviderBase

The RestWebServiceMetadataProvider type exposes the following members.

Constructors
 | Name | Description
Public method | RestWebServiceMetadataProvider | Initializes a new instance of the RestWebServiceMetadataProvider class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Inherited from MetadataProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Inherited from MetadataProviderBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved RestWebServiceMetadataProvider settings from the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event. (Inherited from MetadataProviderBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source. (Inherited from MetadataProviderBase.)
Protected method | RefreshMetadata | Refreshes the Metadata from a REST web service. (Overrides MetadataProviderBaseRefreshMetadata.)
Public method | SaveSettings | Saves RestWebServiceMetadataProvider settings to the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider. (Inherited from MetadataProviderBase.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically. (Inherited from MetadataProviderBase.)
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete. (Inherited from MetadataProviderBase.)
Public property | ServiceDataFormat | Gets or sets the SerializationFormat in which the REST web service exposes the data.
Public property | ServiceUri | Gets or sets the URI where the REST web service is hosted.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out. (Inherited from MetadataProviderBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.MetadataProviders Namespace
GSF.Historian.MetadataProvidersMetadataUpdater


RestWebServiceMetadataProvider Constructor

Grid Solutions Framework RestWebServiceMetadataProvider Constructor
Initializes a new instance of the RestWebServiceMetadataProvider class.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RestWebServiceMetadataProvider()
Public Sub New
new : unit -> RestWebServiceMetadataProvider
GSF.Historian.MetadataProviders.RestWebServiceMetadataProvider = function();
public:
RestWebServiceMetadataProvider()
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider Methods

Grid Solutions Framework RestWebServiceMetadataProvider Methods

The RestWebServiceMetadataProvider type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the metadata provider and optionally releases the managed resources. (Inherited from MetadataProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the metadata provider. (Inherited from MetadataProviderBase.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved RestWebServiceMetadataProvider settings from the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnMetadataRefreshComplete | Raises the MetadataRefreshComplete event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshException | Raises the MetadataRefreshException event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshStart | Raises the MetadataRefreshStart event. (Inherited from MetadataProviderBase.)
Protected method | OnMetadataRefreshTimeout | Raises the MetadataRefreshTimeout event. (Inherited from MetadataProviderBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Refresh | Refreshes the Metadata from an external source. (Inherited from MetadataProviderBase.)
Protected method | RefreshMetadata | Refreshes the Metadata from a REST web service. (Overrides MetadataProviderBaseRefreshMetadata.)
Public method | SaveSettings | Saves RestWebServiceMetadataProvider settings to the config file if the PersistSettings property is set to true. (Overrides MetadataProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider.LoadSettings Method

Grid Solutions Framework RestWebServiceMetadataProviderLoadSettings Method
Loads saved RestWebServiceMetadataProvider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider.RefreshMetadata Method

Grid Solutions Framework RestWebServiceMetadataProviderRefreshMetadata Method
Refreshes the Metadata from a REST web service.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RefreshMetadata()
Protected Overrides Sub RefreshMetadata
abstract RefreshMetadata : unit -> unit
override RefreshMetadata : unit -> unit
function RefreshMetadata();
protected:
virtual void RefreshMetadata() override
Exceptions
Exception | Condition
ArgumentNullException | ServiceUri is set to a null or empty string.
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider.SaveSettings Method

Grid Solutions Framework RestWebServiceMetadataProviderSaveSettings Method
Saves RestWebServiceMetadataProvider settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider Properties

Grid Solutions Framework RestWebServiceMetadataProvider Properties

The RestWebServiceMetadataProvider type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Metadata | Gets or sets the MetadataFile to be refreshed by the metadata provider. (Inherited from MetadataProviderBase.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | RefreshInterval | Gets or sets the interval in minutes at which the Metadata if to be refreshed automatically. (Inherited from MetadataProviderBase.)
Public property | RefreshTimeout | Gets or sets the number of seconds to wait for the Refresh to complete. (Inherited from MetadataProviderBase.)
Public property | ServiceDataFormat | Gets or sets the SerializationFormat in which the REST web service exposes the data.
Public property | ServiceUri | Gets or sets the URI where the REST web service is hosted.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider.ServiceDataFormat Property

Grid Solutions Framework RestWebServiceMetadataProviderServiceDataFormat Property
Gets or sets the SerializationFormat in which the REST web service exposes the data.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializationFormat ServiceDataFormat { get; set; }
Public Property ServiceDataFormat As SerializationFormat
    Get
    Set
member ServiceDataFormat : SerializationFormat with get, set

function get_ServiceDataFormat();
function set_ServiceDataFormat(value);
public:
property SerializationFormat ServiceDataFormat {
    SerializationFormat get ();
    void set (SerializationFormat value);
}

Property Value

Type: SerializationFormat
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider.ServiceUri Property

Grid Solutions Framework RestWebServiceMetadataProviderServiceUri Property
Gets or sets the URI where the REST web service is hosted.

Namespace: GSF.Historian.MetadataProviders
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ServiceUri { get; set; }
Public Property ServiceUri As String
    Get
    Set
member ServiceUri : string with get, set

function get_ServiceUri();
function set_ServiceUri(value);
public:
property String^ ServiceUri {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


RestWebServiceMetadataProvider Events

Grid Solutions Framework RestWebServiceMetadataProvider Events

The RestWebServiceMetadataProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | MetadataRefreshComplete | Occurs when Refresh of Metadata is completed. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshException | Occurs when an Exception is encountered during Refresh of Metadata. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshStart | Occurs when Refresh of Metadata is started. (Inherited from MetadataProviderBase.)
Public event | MetadataRefreshTimeout | Occurs when Refresh of Metadata times out. (Inherited from MetadataProviderBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

RestWebServiceMetadataProvider Class
GSF.Historian.MetadataProviders Namespace


GSF.Historian.Notifiers Namespace

Grid Solutions Framework GSF.Historian.Notifiers Namespace
Contains classes and interfaces that allow standard and custom historian notifications about critical system events.
Classes
 | Class | Description
Public class | EmailNotifier | Represents a notifier that can send notifications in email messages.
Public class | NotifierBase | Base class for a notifier that can process notification messages.
Public class | Notifiers | A class that loads all Notifier adapters.
Interfaces
 | Interface | Description
Public interface | INotifier | Defines a notifier that can process notification messages.
Enumerations
 | Enumeration | Description
Public enumeration | NotificationTypes | Indicates the type of notification being sent using a Notifier.


EmailNotifier Class

Grid Solutions Framework EmailNotifier Class
Represents a notifier that can send notifications in email messages.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.NotifiersNotifierBase
GSF.Historian.NotifiersEmailNotifier

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EmailNotifier : NotifierBase
Public Class EmailNotifier
    Inherits NotifierBase
type EmailNotifier =
    class
        inherit NotifierBase
    end
GSF.Historian.Notifiers.EmailNotifier = function();

Type.createClass(
    'GSF.Historian.Notifiers.EmailNotifier',
    GSF.Historian.Notifiers.NotifierBase);
public ref class EmailNotifier : public NotifierBase

The EmailNotifier type exposes the following members.

Constructors
 | Name | Description
Public method | EmailNotifier | Initializes a new instance of the EmailNotifier class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the notifier and optionally releases the managed resources. (Inherited from NotifierBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the Adapter. (Inherited from Adapter.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved EmailNotifier settings from the config file if the PersistSettings property is set to true. (Overrides NotifierBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Notify | Process a notification. (Inherited from NotifierBase.)
Protected method | NotifyAlarm | Processes a Alarm notification. (Overrides NotifierBaseNotifyAlarm(String, String, String).)
Protected method | NotifyHeartbeat | Processes a Heartbeat notification. (Overrides NotifierBaseNotifyHeartbeat(String, String, String).)
Protected method | NotifyInformation | Processes a Information notification. (Overrides NotifierBaseNotifyInformation(String, String, String).)
Protected method | NotifyWarning | Processes a Warning notification. (Overrides NotifierBaseNotifyWarning(String, String, String).)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnNotificationSendComplete | Raises the NotificationSendComplete event. (Inherited from NotifierBase.)
Protected method | OnNotificationSendException | Raises the NotificationSendException event. (Inherited from NotifierBase.)
Protected method | OnNotificationSendStart | Raises the NotificationSendStart event. (Inherited from NotifierBase.)
Protected method | OnNotificationSendTimeout | Raises the NotificationSendTimeout event. (Inherited from NotifierBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves EmailNotifier settings to the config file if the PersistSettings property is set to true. (Overrides NotifierBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | EmailRecipients | Gets or sets the email addresses (comma or semicolon delimited) where the email messages are to be sent.
Public property | EmailSender | Gets or sets the email address to be used for sending the email messages.
Public property | EmailServer | Gets or sets the SMTP server to use for sending the email messages.
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | NotifyOptions | Gets or set NotificationTypes that can be processed by the notifier. (Inherited from NotifierBase.)
Public property | NotifyTimeout | Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete. (Inherited from NotifierBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | NotificationSendComplete | Occurs when a notification has been sent. (Inherited from NotifierBase.)
Public event | NotificationSendException | Occurs when an Exception is encountered while sending a notification. (Inherited from NotifierBase.)
Public event | NotificationSendStart | Occurs when a notification is being sent. (Inherited from NotifierBase.)
Public event | NotificationSendTimeout | Occurs when a timeout is encountered while sending a notification. (Inherited from NotifierBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.Notifiers Namespace


EmailNotifier Constructor

Grid Solutions Framework EmailNotifier Constructor
Initializes a new instance of the EmailNotifier class.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EmailNotifier()
Public Sub New
new : unit -> EmailNotifier
GSF.Historian.Notifiers.EmailNotifier = function();
public:
EmailNotifier()
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier Methods

Grid Solutions Framework EmailNotifier Methods

The EmailNotifier type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the notifier and optionally releases the managed resources. (Inherited from NotifierBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the Adapter. (Inherited from Adapter.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved EmailNotifier settings from the config file if the PersistSettings property is set to true. (Overrides NotifierBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Notify | Process a notification. (Inherited from NotifierBase.)
Protected method | NotifyAlarm | Processes a Alarm notification. (Overrides NotifierBaseNotifyAlarm(String, String, String).)
Protected method | NotifyHeartbeat | Processes a Heartbeat notification. (Overrides NotifierBaseNotifyHeartbeat(String, String, String).)
Protected method | NotifyInformation | Processes a Information notification. (Overrides NotifierBaseNotifyInformation(String, String, String).)
Protected method | NotifyWarning | Processes a Warning notification. (Overrides NotifierBaseNotifyWarning(String, String, String).)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnNotificationSendComplete | Raises the NotificationSendComplete event. (Inherited from NotifierBase.)
Protected method | OnNotificationSendException | Raises the NotificationSendException event. (Inherited from NotifierBase.)
Protected method | OnNotificationSendStart | Raises the NotificationSendStart event. (Inherited from NotifierBase.)
Protected method | OnNotificationSendTimeout | Raises the NotificationSendTimeout event. (Inherited from NotifierBase.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves EmailNotifier settings to the config file if the PersistSettings property is set to true. (Overrides NotifierBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.LoadSettings Method

Grid Solutions Framework EmailNotifierLoadSettings Method
Loads saved EmailNotifier settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.NotifyAlarm Method

Grid Solutions Framework EmailNotifierNotifyAlarm Method
Processes a Alarm notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void NotifyAlarm(
    string subject,
    string message,
    string details
)
Protected Overrides Sub NotifyAlarm (
    subject As String,
    message As String,
    details As String
)
abstract NotifyAlarm :
        subject : string *
        message : string *
        details : string -> unit
override NotifyAlarm :
        subject : string *
        message : string *
        details : string -> unit
function NotifyAlarm(subject, message, details);
protected:
virtual void NotifyAlarm(
    String^ subject,
    String^ message,
    String^ details
) override

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.NotifyHeartbeat Method

Grid Solutions Framework EmailNotifierNotifyHeartbeat Method
Processes a Heartbeat notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void NotifyHeartbeat(
    string subject,
    string message,
    string details
)
Protected Overrides Sub NotifyHeartbeat (
    subject As String,
    message As String,
    details As String
)
abstract NotifyHeartbeat :
        subject : string *
        message : string *
        details : string -> unit
override NotifyHeartbeat :
        subject : string *
        message : string *
        details : string -> unit
function NotifyHeartbeat(subject, message, details);
protected:
virtual void NotifyHeartbeat(
    String^ subject,
    String^ message,
    String^ details
) override

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.NotifyInformation Method

Grid Solutions Framework EmailNotifierNotifyInformation Method
Processes a Information notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void NotifyInformation(
    string subject,
    string message,
    string details
)
Protected Overrides Sub NotifyInformation (
    subject As String,
    message As String,
    details As String
)
abstract NotifyInformation :
        subject : string *
        message : string *
        details : string -> unit
override NotifyInformation :
        subject : string *
        message : string *
        details : string -> unit
function NotifyInformation(subject, message, details);
protected:
virtual void NotifyInformation(
    String^ subject,
    String^ message,
    String^ details
) override

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.NotifyWarning Method

Grid Solutions Framework EmailNotifierNotifyWarning Method
Processes a Warning notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void NotifyWarning(
    string subject,
    string message,
    string details
)
Protected Overrides Sub NotifyWarning (
    subject As String,
    message As String,
    details As String
)
abstract NotifyWarning :
        subject : string *
        message : string *
        details : string -> unit
override NotifyWarning :
        subject : string *
        message : string *
        details : string -> unit
function NotifyWarning(subject, message, details);
protected:
virtual void NotifyWarning(
    String^ subject,
    String^ message,
    String^ details
) override

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.SaveSettings Method

Grid Solutions Framework EmailNotifierSaveSettings Method
Saves EmailNotifier settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier Properties

Grid Solutions Framework EmailNotifier Properties

The EmailNotifier type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | EmailRecipients | Gets or sets the email addresses (comma or semicolon delimited) where the email messages are to be sent.
Public property | EmailSender | Gets or sets the email address to be used for sending the email messages.
Public property | EmailServer | Gets or sets the SMTP server to use for sending the email messages.
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | NotifyOptions | Gets or set NotificationTypes that can be processed by the notifier. (Inherited from NotifierBase.)
Public property | NotifyTimeout | Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete. (Inherited from NotifierBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.EmailRecipients Property

Grid Solutions Framework EmailNotifierEmailRecipients Property
Gets or sets the email addresses (comma or semicolon delimited) where the email messages are to be sent.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string EmailRecipients { get; set; }
Public Property EmailRecipients As String
    Get
    Set
member EmailRecipients : string with get, set

function get_EmailRecipients();
function set_EmailRecipients(value);
public:
property String^ EmailRecipients {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Email address can be provided in the <Email Address>:sms format (Example: 123456789@provider.com:sms), to indicate that the reciepient is a mobile device and a very brief email message is to be sent.
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.EmailSender Property

Grid Solutions Framework EmailNotifierEmailSender Property
Gets or sets the email address to be used for sending the email messages.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string EmailSender { get; set; }
Public Property EmailSender As String
    Get
    Set
member EmailSender : string with get, set

function get_EmailSender();
function set_EmailSender(value);
public:
property String^ EmailSender {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier.EmailServer Property

Grid Solutions Framework EmailNotifierEmailServer Property
Gets or sets the SMTP server to use for sending the email messages.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string EmailServer { get; set; }
Public Property EmailServer As String
    Get
    Set
member EmailServer : string with get, set

function get_EmailServer();
function set_EmailServer(value);
public:
property String^ EmailServer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


EmailNotifier Events

Grid Solutions Framework EmailNotifier Events

The EmailNotifier type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | NotificationSendComplete | Occurs when a notification has been sent. (Inherited from NotifierBase.)
Public event | NotificationSendException | Occurs when an Exception is encountered while sending a notification. (Inherited from NotifierBase.)
Public event | NotificationSendStart | Occurs when a notification is being sent. (Inherited from NotifierBase.)
Public event | NotificationSendTimeout | Occurs when a timeout is encountered while sending a notification. (Inherited from NotifierBase.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

EmailNotifier Class
GSF.Historian.Notifiers Namespace


INotifier Interface

Grid Solutions Framework INotifier Interface
Defines a notifier that can process notification messages.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface INotifier : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
Public Interface INotifier
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
type INotifier =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.Notifiers.INotifier = function();
GSF.Historian.Notifiers.INotifier.createInterface('GSF.Historian.Notifiers.INotifier');
public interface class INotifier : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The INotifier type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Notify | Process a notification.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | NotifyOptions | Gets or set NotificationTypes that can be processed by the notifier.
Public property | NotifyTimeout | Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | NotificationSendComplete | Occurs when a notification has been sent.
Public event | NotificationSendException | Occurs when an Exception is encountered while sending a notification.
Public event | NotificationSendStart | Occurs when a notification is being sent.
Public event | NotificationSendTimeout | Occurs when a timeout is encountered while sending a notification.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.Historian.Notifiers Namespace
GSF.Historian.NotifiersNotificationTypes


INotifier Methods

Grid Solutions Framework INotifier Methods

The INotifier type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Notify | Process a notification.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier.Notify Method

Grid Solutions Framework INotifierNotify Method
Process a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Notify(
    string subject,
    string message,
    string details,
    NotificationTypes notificationType
)
Function Notify (
    subject As String,
    message As String,
    details As String,
    notificationType As NotificationTypes
) As Boolean
abstract Notify :
        subject : string *
        message : string *
        details : string *
        notificationType : NotificationTypes -> bool

function Notify(subject, message, details, notificationType);
bool Notify(
    String^ subject,
    String^ message,
    String^ details,
    NotificationTypes notificationType
)

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
notificationType
Type: GSF.Historian.NotifiersNotificationTypes
One of the NotificationTypes values.

Return Value

Type: Boolean
true if notification is processed successfully; otherwise false.
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier Properties

Grid Solutions Framework INotifier Properties

The INotifier type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | NotifyOptions | Gets or set NotificationTypes that can be processed by the notifier.
Public property | NotifyTimeout | Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier.NotifyOptions Property

Grid Solutions Framework INotifierNotifyOptions Property
Gets or set NotificationTypes that can be processed by the notifier.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
NotificationTypes NotifyOptions { get; set; }
Property NotifyOptions As NotificationTypes
    Get
    Set
abstract NotifyOptions : NotificationTypes with get, set

function get_NotifyOptions();
function set_NotifyOptions(value);
property NotificationTypes NotifyOptions {
    NotificationTypes get ();
    void set (NotificationTypes value);
}

Property Value

Type: NotificationTypes
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier.NotifyTimeout Property

Grid Solutions Framework INotifierNotifyTimeout Property
Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int NotifyTimeout { get; set; }
Property NotifyTimeout As Integer
    Get
    Set
abstract NotifyTimeout : int with get, set

function get_NotifyTimeout();
function set_NotifyTimeout(value);
property int NotifyTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier Events

Grid Solutions Framework INotifier Events

The INotifier type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | NotificationSendComplete | Occurs when a notification has been sent.
Public event | NotificationSendException | Occurs when an Exception is encountered while sending a notification.
Public event | NotificationSendStart | Occurs when a notification is being sent.
Public event | NotificationSendTimeout | Occurs when a timeout is encountered while sending a notification.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier.NotificationSendComplete Event

Grid Solutions Framework INotifierNotificationSendComplete Event
Occurs when a notification has been sent.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler NotificationSendComplete
Event NotificationSendComplete As EventHandler
abstract NotificationSendComplete : IEvent<EventHandler,
    EventArgs>

function add_NotificationSendComplete(value);
function remove_NotificationSendComplete(value);
 event EventHandler^ NotificationSendComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier.NotificationSendException Event

Grid Solutions Framework INotifierNotificationSendException Event
Occurs when an Exception is encountered while sending a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> NotificationSendException
Event NotificationSendException As EventHandler(Of EventArgs(Of Exception))
abstract NotificationSendException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_NotificationSendException(value);
function remove_NotificationSendException(value);
 event EventHandler<EventArgs<Exception^>^>^ NotificationSendException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier.NotificationSendStart Event

Grid Solutions Framework INotifierNotificationSendStart Event
Occurs when a notification is being sent.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler NotificationSendStart
Event NotificationSendStart As EventHandler
abstract NotificationSendStart : IEvent<EventHandler,
    EventArgs>

function add_NotificationSendStart(value);
function remove_NotificationSendStart(value);
 event EventHandler^ NotificationSendStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


INotifier.NotificationSendTimeout Event

Grid Solutions Framework INotifierNotificationSendTimeout Event
Occurs when a timeout is encountered while sending a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler NotificationSendTimeout
Event NotificationSendTimeout As EventHandler
abstract NotificationSendTimeout : IEvent<EventHandler,
    EventArgs>

function add_NotificationSendTimeout(value);
function remove_NotificationSendTimeout(value);
 event EventHandler^ NotificationSendTimeout {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

INotifier Interface
GSF.Historian.Notifiers Namespace


NotificationTypes Enumeration

Grid Solutions Framework NotificationTypes Enumeration
Indicates the type of notification being sent using a Notifier.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum NotificationTypes
<FlagsAttribute>
Public Enumeration NotificationTypes
[<FlagsAttribute>]
type NotificationTypes
GSF.Historian.Notifiers.NotificationTypes = function();
GSF.Historian.Notifiers.NotificationTypes.createEnum('GSF.Historian.Notifiers.NotificationTypes', true);
[FlagsAttribute]
public enum class NotificationTypes
Members
Member name | Value | Description
Unknown | 0 | Notification is of unknown type.
Information | 1 | Notification is informational in nature.
Warning | 2 | Notification is being sent to report a warning.
Alarm | 4 | Notification is being sent to report an alarm.
Heartbeat | 8 | Notification is being sent to report activity.
See Also

Reference

GSF.Historian.Notifiers Namespace


NotifierBase Class

Grid Solutions Framework NotifierBase Class
Base class for a notifier that can process notification messages.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.NotifiersNotifierBase
GSF.Historian.NotifiersEmailNotifier

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class NotifierBase : Adapter,
    INotifier, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
Public MustInherit Class NotifierBase
    Inherits Adapter
    Implements INotifier, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
[<AbstractClassAttribute>]
type NotifierBase =
    class
        inherit Adapter
        interface INotifier
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.Notifiers.NotifierBase = function();

Type.createClass(
    'GSF.Historian.Notifiers.NotifierBase',
    GSF.Adapters.Adapter,
    GSF.Historian.Notifiers.INotifier,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
public ref class NotifierBase abstract : public Adapter,
    INotifier, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings

The NotifierBase type exposes the following members.

Constructors
 | Name | Description
Public method | NotifierBase | Initializes a new instance of the notifier.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the notifier and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the Adapter. (Inherited from Adapter.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved notifier settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Notify | Process a notification.
Protected method | NotifyAlarm | When overridden in a derived class, processes a Alarm notification.
Protected method | NotifyHeartbeat | When overridden in a derived class, processes a Heartbeat notification.
Protected method | NotifyInformation | When overridden in a derived class, processes a Information notification.
Protected method | NotifyWarning | When overridden in a derived class, processes a Warning notification.
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnNotificationSendComplete | Raises the NotificationSendComplete event.
Protected method | OnNotificationSendException | Raises the NotificationSendException event.
Protected method | OnNotificationSendStart | Raises the NotificationSendStart event.
Protected method | OnNotificationSendTimeout | Raises the NotificationSendTimeout event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves notifier settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | NotifyOptions | Gets or set NotificationTypes that can be processed by the notifier.
Public property | NotifyTimeout | Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | NotificationSendComplete | Occurs when a notification has been sent.
Public event | NotificationSendException | Occurs when an Exception is encountered while sending a notification.
Public event | NotificationSendStart | Occurs when a notification is being sent.
Public event | NotificationSendTimeout | Occurs when a timeout is encountered while sending a notification.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.Notifiers Namespace


NotifierBase Constructor

Grid Solutions Framework NotifierBase Constructor
Initializes a new instance of the notifier.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NotifierBase(
    NotificationTypes notifyOptions
)
Public Sub New (
    notifyOptions As NotificationTypes
)
new :
        notifyOptions : NotificationTypes -> NotifierBase
GSF.Historian.Notifiers.NotifierBase = function(notifyOptions);
public:
NotifierBase(
    NotificationTypes notifyOptions
)

Parameters

notifyOptions
Type: GSF.Historian.NotifiersNotificationTypes
NotificationTypes that can be processed by the notifier.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase Methods

Grid Solutions Framework NotifierBase Methods

The NotifierBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the notifier and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the Adapter. (Inherited from Adapter.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved notifier settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Notify | Process a notification.
Protected method | NotifyAlarm | When overridden in a derived class, processes a Alarm notification.
Protected method | NotifyHeartbeat | When overridden in a derived class, processes a Heartbeat notification.
Protected method | NotifyInformation | When overridden in a derived class, processes a Information notification.
Protected method | NotifyWarning | When overridden in a derived class, processes a Warning notification.
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnNotificationSendComplete | Raises the NotificationSendComplete event.
Protected method | OnNotificationSendException | Raises the NotificationSendException event.
Protected method | OnNotificationSendStart | Raises the NotificationSendStart event.
Protected method | OnNotificationSendTimeout | Raises the NotificationSendTimeout event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves notifier settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.Dispose Method

Grid Solutions Framework NotifierBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the notifier and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Top
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.Dispose Method (Boolean)

Grid Solutions Framework NotifierBaseDispose Method (Boolean)
Releases the unmanaged resources used by the notifier and optionally releases the managed resources.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

NotifierBase Class
Dispose Overload
GSF.Historian.Notifiers Namespace


NotifierBase.LoadSettings Method

Grid Solutions Framework NotifierBaseLoadSettings Method
Loads saved notifier settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.Notify Method

Grid Solutions Framework NotifierBaseNotify Method
Process a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Notify(
    string subject,
    string message,
    string details,
    NotificationTypes notificationType
)
Public Function Notify (
    subject As String,
    message As String,
    details As String,
    notificationType As NotificationTypes
) As Boolean
abstract Notify :
        subject : string *
        message : string *
        details : string *
        notificationType : NotificationTypes -> bool
override Notify :
        subject : string *
        message : string *
        details : string *
        notificationType : NotificationTypes -> bool
function Notify(subject, message, details, notificationType);
public:
virtual bool Notify(
    String^ subject,
    String^ message,
    String^ details,
    NotificationTypes notificationType
) sealed

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
notificationType
Type: GSF.Historian.NotifiersNotificationTypes
One of the NotificationTypes values.

Return Value

Type: Boolean
true if notification is processed successfully; otherwise false.

Implements

INotifierNotify(String, String, String, NotificationTypes)
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotifyAlarm Method

Grid Solutions Framework NotifierBaseNotifyAlarm Method
When overridden in a derived class, processes a Alarm notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void NotifyAlarm(
    string subject,
    string message,
    string details
)
Protected MustOverride Sub NotifyAlarm (
    subject As String,
    message As String,
    details As String
)
abstract NotifyAlarm :
        subject : string *
        message : string *
        details : string -> unit

function NotifyAlarm(subject, message, details);
protected:
virtual void NotifyAlarm(
    String^ subject,
    String^ message,
    String^ details
) abstract

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotifyHeartbeat Method

Grid Solutions Framework NotifierBaseNotifyHeartbeat Method
When overridden in a derived class, processes a Heartbeat notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void NotifyHeartbeat(
    string subject,
    string message,
    string details
)
Protected MustOverride Sub NotifyHeartbeat (
    subject As String,
    message As String,
    details As String
)
abstract NotifyHeartbeat :
        subject : string *
        message : string *
        details : string -> unit

function NotifyHeartbeat(subject, message, details);
protected:
virtual void NotifyHeartbeat(
    String^ subject,
    String^ message,
    String^ details
) abstract

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotifyInformation Method

Grid Solutions Framework NotifierBaseNotifyInformation Method
When overridden in a derived class, processes a Information notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void NotifyInformation(
    string subject,
    string message,
    string details
)
Protected MustOverride Sub NotifyInformation (
    subject As String,
    message As String,
    details As String
)
abstract NotifyInformation :
        subject : string *
        message : string *
        details : string -> unit

function NotifyInformation(subject, message, details);
protected:
virtual void NotifyInformation(
    String^ subject,
    String^ message,
    String^ details
) abstract

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotifyWarning Method

Grid Solutions Framework NotifierBaseNotifyWarning Method
When overridden in a derived class, processes a Warning notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void NotifyWarning(
    string subject,
    string message,
    string details
)
Protected MustOverride Sub NotifyWarning (
    subject As String,
    message As String,
    details As String
)
abstract NotifyWarning :
        subject : string *
        message : string *
        details : string -> unit

function NotifyWarning(subject, message, details);
protected:
virtual void NotifyWarning(
    String^ subject,
    String^ message,
    String^ details
) abstract

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.OnNotificationSendComplete Method

Grid Solutions Framework NotifierBaseOnNotificationSendComplete Method
Raises the NotificationSendComplete event.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNotificationSendComplete()
Protected Overridable Sub OnNotificationSendComplete
abstract OnNotificationSendComplete : unit -> unit
override OnNotificationSendComplete : unit -> unit
function OnNotificationSendComplete();
protected:
virtual void OnNotificationSendComplete()
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.OnNotificationSendException Method

Grid Solutions Framework NotifierBaseOnNotificationSendException Method
Raises the NotificationSendException event.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNotificationSendException(
    Exception exception
)
Protected Overridable Sub OnNotificationSendException (
    exception As Exception
)
abstract OnNotificationSendException :
        exception : Exception -> unit
override OnNotificationSendException :
        exception : Exception -> unit
function OnNotificationSendException(exception);
protected:
virtual void OnNotificationSendException(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception to send to NotificationSendException event.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.OnNotificationSendStart Method

Grid Solutions Framework NotifierBaseOnNotificationSendStart Method
Raises the NotificationSendStart event.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNotificationSendStart()
Protected Overridable Sub OnNotificationSendStart
abstract OnNotificationSendStart : unit -> unit
override OnNotificationSendStart : unit -> unit
function OnNotificationSendStart();
protected:
virtual void OnNotificationSendStart()
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.OnNotificationSendTimeout Method

Grid Solutions Framework NotifierBaseOnNotificationSendTimeout Method
Raises the NotificationSendTimeout event.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNotificationSendTimeout()
Protected Overridable Sub OnNotificationSendTimeout
abstract OnNotificationSendTimeout : unit -> unit
override OnNotificationSendTimeout : unit -> unit
function OnNotificationSendTimeout();
protected:
virtual void OnNotificationSendTimeout()
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.SaveSettings Method

Grid Solutions Framework NotifierBaseSaveSettings Method
Saves notifier settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase Properties

Grid Solutions Framework NotifierBase Properties

The NotifierBase type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | NotifyOptions | Gets or set NotificationTypes that can be processed by the notifier.
Public property | NotifyTimeout | Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotifyOptions Property

Grid Solutions Framework NotifierBaseNotifyOptions Property
Gets or set NotificationTypes that can be processed by the notifier.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NotificationTypes NotifyOptions { get; set; }
Public Property NotifyOptions As NotificationTypes
    Get
    Set
abstract NotifyOptions : NotificationTypes with get, set
override NotifyOptions : NotificationTypes with get, set
function get_NotifyOptions();
function set_NotifyOptions(value);
public:
virtual property NotificationTypes NotifyOptions {
    NotificationTypes get () sealed;
    void set (NotificationTypes value) sealed;
}

Property Value

Type: NotificationTypes

Implements

INotifierNotifyOptions
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotifyTimeout Property

Grid Solutions Framework NotifierBaseNotifyTimeout Property
Gets or sets the number of seconds to wait for Notify(String, String, String, NotificationTypes) to complete.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int NotifyTimeout { get; set; }
Public Property NotifyTimeout As Integer
    Get
    Set
abstract NotifyTimeout : int with get, set
override NotifyTimeout : int with get, set
function get_NotifyTimeout();
function set_NotifyTimeout(value);
public:
virtual property int NotifyTimeout {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

INotifierNotifyTimeout
Remarks
Set NotifyTimeout to -1 to wait indefinitely on Notify(String, String, String, NotificationTypes).
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase Events

Grid Solutions Framework NotifierBase Events

The NotifierBase type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | NotificationSendComplete | Occurs when a notification has been sent.
Public event | NotificationSendException | Occurs when an Exception is encountered while sending a notification.
Public event | NotificationSendStart | Occurs when a notification is being sent.
Public event | NotificationSendTimeout | Occurs when a timeout is encountered while sending a notification.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotificationSendComplete Event

Grid Solutions Framework NotifierBaseNotificationSendComplete Event
Occurs when a notification has been sent.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler NotificationSendComplete
Public Event NotificationSendComplete As EventHandler
abstract NotificationSendComplete : IEvent<EventHandler,
    EventArgs>
override NotificationSendComplete : IEvent<EventHandler,
    EventArgs>
function add_NotificationSendComplete(value);
function remove_NotificationSendComplete(value);
public:
virtual  event EventHandler^ NotificationSendComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

INotifierNotificationSendComplete
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotificationSendException Event

Grid Solutions Framework NotifierBaseNotificationSendException Event
Occurs when an Exception is encountered while sending a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> NotificationSendException
Public Event NotificationSendException As EventHandler(Of EventArgs(Of Exception))
abstract NotificationSendException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override NotificationSendException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_NotificationSendException(value);
function remove_NotificationSendException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ NotificationSendException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

INotifierNotificationSendException
Remarks
Argument is the exception encountered while sending a notification.
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotificationSendStart Event

Grid Solutions Framework NotifierBaseNotificationSendStart Event
Occurs when a notification is being sent.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler NotificationSendStart
Public Event NotificationSendStart As EventHandler
abstract NotificationSendStart : IEvent<EventHandler,
    EventArgs>
override NotificationSendStart : IEvent<EventHandler,
    EventArgs>
function add_NotificationSendStart(value);
function remove_NotificationSendStart(value);
public:
virtual  event EventHandler^ NotificationSendStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

INotifierNotificationSendStart
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


NotifierBase.NotificationSendTimeout Event

Grid Solutions Framework NotifierBaseNotificationSendTimeout Event
Occurs when a timeout is encountered while sending a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler NotificationSendTimeout
Public Event NotificationSendTimeout As EventHandler
abstract NotificationSendTimeout : IEvent<EventHandler,
    EventArgs>
override NotificationSendTimeout : IEvent<EventHandler,
    EventArgs>
function add_NotificationSendTimeout(value);
function remove_NotificationSendTimeout(value);
public:
virtual  event EventHandler^ NotificationSendTimeout {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

INotifierNotificationSendTimeout
See Also

Reference

NotifierBase Class
GSF.Historian.Notifiers Namespace


Notifiers Class

Grid Solutions Framework Notifiers Class
A class that loads all Notifier adapters.
Inheritance Hierarchy
SystemObject
GSF.AdaptersAdapterLoader INotifier
GSF.Historian.NotifiersNotifiers

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Notifiers : AdapterLoader<INotifier>
Public Class Notifiers
    Inherits AdapterLoader(Of INotifier)
type Notifiers =
    class
        inherit AdapterLoader<INotifier>
    end
GSF.Historian.Notifiers.Notifiers = function();

Type.createClass(
    'GSF.Historian.Notifiers.Notifiers',
    GSF.Adapters.AdapterLoader`1);
public ref class Notifiers : public AdapterLoader<INotifier^>

The Notifiers type exposes the following members.

Constructors
 | Name | Description
Public method | Notifiers | Initializes a new instance of the Notifiers class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes Notify(String, String, String, NotificationTypes) on the specified notifier adapter. (Overrides AdapterLoaderTExecuteAdapterOperation(T, Object).)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | SendNotification(String, String, NotificationTypes) | Sends a notification.
Public method | SendNotification(String, String, String, NotificationTypes) | Sends a notification.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

GSF.Historian.Notifiers Namespace
GSF.Historian.NotifiersINotifier


Notifiers Constructor

Grid Solutions Framework Notifiers Constructor
Initializes a new instance of the Notifiers class

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Notifiers()
Public Sub New
new : unit -> Notifiers
GSF.Historian.Notifiers.Notifiers = function();
public:
Notifiers()
See Also

Reference

Notifiers Class
GSF.Historian.Notifiers Namespace


Notifiers Methods

Grid Solutions Framework Notifiers Methods

The Notifiers type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes Notify(String, String, String, NotificationTypes) on the specified notifier adapter. (Overrides AdapterLoaderTExecuteAdapterOperation(T, Object).)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | SendNotification(String, String, NotificationTypes) | Sends a notification.
Public method | SendNotification(String, String, String, NotificationTypes) | Sends a notification.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Notifiers Class
GSF.Historian.Notifiers Namespace


Notifiers.ExecuteAdapterOperation Method

Grid Solutions Framework NotifiersExecuteAdapterOperation Method
Executes Notify(String, String, String, NotificationTypes) on the specified notifier adapter.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExecuteAdapterOperation(
    INotifier adapter,
    Object data
)
Protected Overrides Sub ExecuteAdapterOperation (
    adapter As INotifier,
    data As Object
)
abstract ExecuteAdapterOperation :
        adapter : INotifier *
        data : Object -> unit
override ExecuteAdapterOperation :
        adapter : INotifier *
        data : Object -> unit
function ExecuteAdapterOperation(adapter, data);
protected:
virtual void ExecuteAdapterOperation(
    INotifier^ adapter,
    Object^ data
) override

Parameters

adapter
Type: GSF.Historian.NotifiersINotifier
An INotifier object.
data
Type: SystemObject
Data about the notification.
See Also

Reference

Notifiers Class
GSF.Historian.Notifiers Namespace


Notifiers.SendNotification Method

Grid Solutions Framework NotifiersSendNotification Method
Overload List
 | Name | Description
Public method | SendNotification(String, String, NotificationTypes) | Sends a notification.
Public method | SendNotification(String, String, String, NotificationTypes) | Sends a notification.
Top
See Also

Reference

Notifiers Class
GSF.Historian.Notifiers Namespace


Notifiers.SendNotification Method (String, String, NotificationTypes)

Grid Solutions Framework NotifiersSendNotification Method (String, String, NotificationTypes)
Sends a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendNotification(
    string subject,
    string message,
    NotificationTypes notificationType
)
Public Sub SendNotification (
    subject As String,
    message As String,
    notificationType As NotificationTypes
)
member SendNotification :
        subject : string *
        message : string *
        notificationType : NotificationTypes -> unit

function SendNotification(subject, message, notificationType);
public:
void SendNotification(
    String^ subject,
    String^ message,
    NotificationTypes notificationType
)

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
notificationType
Type: GSF.Historian.NotifiersNotificationTypes
One of the NotificationTypes values.
See Also

Reference

Notifiers Class
SendNotification Overload
GSF.Historian.Notifiers Namespace


Notifiers.SendNotification Method (String, String, String, NotificationTypes)

Grid Solutions Framework NotifiersSendNotification Method (String, String, String, NotificationTypes)
Sends a notification.

Namespace: GSF.Historian.Notifiers
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendNotification(
    string subject,
    string message,
    string details,
    NotificationTypes notificationType
)
Public Sub SendNotification (
    subject As String,
    message As String,
    details As String,
    notificationType As NotificationTypes
)
member SendNotification :
        subject : string *
        message : string *
        details : string *
        notificationType : NotificationTypes -> unit

function SendNotification(subject, message, details, notificationType);
public:
void SendNotification(
    String^ subject,
    String^ message,
    String^ details,
    NotificationTypes notificationType
)

Parameters

subject
Type: SystemString
Subject matter for the notification.
message
Type: SystemString
Brief message for the notification.
details
Type: SystemString
Detailed message for the notification.
notificationType
Type: GSF.Historian.NotifiersNotificationTypes
One of the NotificationTypes values.
See Also

Reference

Notifiers Class
SendNotification Overload
GSF.Historian.Notifiers Namespace


Notifiers Properties

Grid Solutions Framework Notifiers Properties

The Notifiers type exposes the following members.

Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

Notifiers Class
GSF.Historian.Notifiers Namespace


Notifiers Events

Grid Solutions Framework Notifiers Events

The Notifiers type exposes the following members.

Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

Notifiers Class
GSF.Historian.Notifiers Namespace


GSF.Historian.Packets Namespace

Grid Solutions Framework GSF.Historian.Packets Namespace
Contains classes that define packet definitions used for transmission of data points and metadata.
Classes
 | Class | Description
Public class | PacketBase | Base class for a binary packet received by a historian.
Public class | PacketCommonHeader | Represents the common header information that is present in the binary image of all Types that implement the IPacket interface.
Public class | PacketParser | Represents a data parser that can parse binary data in to IPackets.
Public class | PacketType1 | Represents a packet to be used for sending single time-series data point to a historian for archival.
Public class | PacketType101 | Represents a packet that can be used to send multiple time-series data points to a historian for archival.
Public class | PacketType101DataPoint | Represents time-series data transmitted in PacketType101.
Public class | PacketType11 | Represents a packet to be used for requesting Summary for the RequestIDs.
Public class | PacketType2 | Represents a packet to be used for sending single time (expanded format) series data point to a historian for archival.
Public class | PacketType3 | Represents a packet to be used for requesting Summary for the RequestIDs.
Public class | PacketType4 | Represents a packet to be used for requesting Summary for the RequestIDs only if the MetadataRecord has changed.
Public class | PacketType5 | Represents a packet that can be used to query the status of a historian.
Public class | QueryPacketBase | Base class for a packet to be used for requesting information from a historian.
Interfaces
 | Interface | Description
Public interface | IPacket | Defines a binary packet received by a historian.


IPacket Interface

Grid Solutions Framework IPacket Interface
Defines a binary packet received by a historian.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IPacket : ISupportSourceIdentifiableFrameImage<Guid, short>,
    ISupportFrameImage<short>, ISupportBinaryImage
Public Interface IPacket
    Inherits ISupportSourceIdentifiableFrameImage(Of Guid, Short), ISupportFrameImage(Of Short),
    ISupportBinaryImage
type IPacket =
    interface
        interface ISupportSourceIdentifiableFrameImage<Guid, int16>
        interface ISupportFrameImage<int16>
        interface ISupportBinaryImage
    end
GSF.Historian.Packets.IPacket = function();
GSF.Historian.Packets.IPacket.createInterface('GSF.Historian.Packets.IPacket');
public interface class IPacket : ISupportSourceIdentifiableFrameImage<Guid, short>,
    ISupportFrameImage<short>, ISupportBinaryImage

The IPacket type exposes the following members.

Methods
 | Name | Description
Public method | ExtractTimeSeriesData | Extracts time-series data from the packet.
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | Archive | Gets or sets the current IArchive.
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonHeader | Gets or sets current ICommonHeaderTTypeIdentifier. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet.
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier.)
Public property | TypeID | Gets the identifier that can be used for identifying the Type. (Inherited from ISupportFrameImageTTypeIdentifier.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


IPacket Methods

Grid Solutions Framework IPacket Methods

The IPacket type exposes the following members.

Methods
 | Name | Description
Public method | ExtractTimeSeriesData | Extracts time-series data from the packet.
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IPacket Interface
GSF.Historian.Packets Namespace


IPacket.ExtractTimeSeriesData Method

Grid Solutions Framework IPacketExtractTimeSeriesData Method
Extracts time-series data from the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IEnumerable<IDataPoint> ExtractTimeSeriesData()
Function ExtractTimeSeriesData As IEnumerable(Of IDataPoint)
abstract ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>

function ExtractTimeSeriesData();
IEnumerable<IDataPoint^>^ ExtractTimeSeriesData()

Return Value

Type: IEnumerable IDataPoint
An IEnumerableT object of IDataPoints if the packet contains time-series data; otherwise null.
See Also

Reference

IPacket Interface
GSF.Historian.Packets Namespace


IPacket Properties

Grid Solutions Framework IPacket Properties

The IPacket type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | Archive | Gets or sets the current IArchive.
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonHeader | Gets or sets current ICommonHeaderTTypeIdentifier. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet.
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier.)
Public property | TypeID | Gets the identifier that can be used for identifying the Type. (Inherited from ISupportFrameImageTTypeIdentifier.)
Top
See Also

Reference

IPacket Interface
GSF.Historian.Packets Namespace


IPacket.Archive Property

Grid Solutions Framework IPacketArchive Property
Gets or sets the current IArchive.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IArchive Archive { get; set; }
Property Archive As IArchive
    Get
    Set
abstract Archive : IArchive with get, set

function get_Archive();
function set_Archive(value);
property IArchive^ Archive {
    IArchive^ get ();
    void set (IArchive^ value);
}

Property Value

Type: IArchive
See Also

Reference

IPacket Interface
GSF.Historian.Packets Namespace


IPacket.PreProcessHandler Property

Grid Solutions Framework IPacketPreProcessHandler Property
Gets or sets the Delegate that pre-processes the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Func<IEnumerable<byte[]>> PreProcessHandler { get; set; }
Property PreProcessHandler As Func(Of IEnumerable(Of Byte()))
    Get
    Set
abstract PreProcessHandler : Func<IEnumerable<byte[]>> with get, set

function get_PreProcessHandler();
function set_PreProcessHandler(value);
property Func<IEnumerable<array<unsigned char>^>^>^ PreProcessHandler {
    Func<IEnumerable<array<unsigned char>^>^>^ get ();
    void set (Func<IEnumerable<array<unsigned char>^>^>^ value);
}

Property Value

Type: Func IEnumerable Byte
Remarks
FuncTResult returns an IEnumerableT object containing the binary data to be sent back to the packet sender.
See Also

Reference

IPacket Interface
GSF.Historian.Packets Namespace


IPacket.ProcessHandler Property

Grid Solutions Framework IPacketProcessHandler Property
Gets or sets the Delegate that processes the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Func<IEnumerable<byte[]>> ProcessHandler { get; set; }
Property ProcessHandler As Func(Of IEnumerable(Of Byte()))
    Get
    Set
abstract ProcessHandler : Func<IEnumerable<byte[]>> with get, set

function get_ProcessHandler();
function set_ProcessHandler(value);
property Func<IEnumerable<array<unsigned char>^>^>^ ProcessHandler {
    Func<IEnumerable<array<unsigned char>^>^>^ get ();
    void set (Func<IEnumerable<array<unsigned char>^>^>^ value);
}

Property Value

Type: Func IEnumerable Byte
Remarks
FuncTResult returns an IEnumerableT object containing the binary data to be sent back to the packet sender.
See Also

Reference

IPacket Interface
GSF.Historian.Packets Namespace


PacketBase Class

Grid Solutions Framework PacketBase Class
Base class for a binary packet received by a historian.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsPacketType1
GSF.Historian.PacketsPacketType101
GSF.Historian.PacketsPacketType2
GSF.Historian.PacketsPacketType5
GSF.Historian.PacketsQueryPacketBase

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class PacketBase : IPacket,
    ISupportSourceIdentifiableFrameImage<Guid, short>, ISupportFrameImage<short>, ISupportBinaryImage
Public MustInherit Class PacketBase
    Implements IPacket, ISupportSourceIdentifiableFrameImage(Of Guid, Short),
    ISupportFrameImage(Of Short), ISupportBinaryImage
[<AbstractClassAttribute>]
type PacketBase =
    class
        interface IPacket
        interface ISupportSourceIdentifiableFrameImage<Guid, int16>
        interface ISupportFrameImage<int16>
        interface ISupportBinaryImage
    end
GSF.Historian.Packets.PacketBase = function();

Type.createClass(
    'GSF.Historian.Packets.PacketBase',
    null,
    GSF.Historian.Packets.IPacket,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
public ref class PacketBase abstract : IPacket,
    ISupportSourceIdentifiableFrameImage<Guid, short>, ISupportFrameImage<short>, ISupportBinaryImage

The PacketBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PacketBase | Initializes a new instance of the packet.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the packet.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the packet and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes packet by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of the packet.
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately.
Public property | Archive | Gets or sets the current IArchive.
Public property | BinaryLength | Gets the length of the packet's binary representation.
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet.
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet.
Public property | Source | Gets or sets the data source identifier of the frame image.
Public property | TypeID | Gets or sets the numeric identifier for the packet type.
Top
See Also

Reference

GSF.Historian.Packets Namespace
GSF.Historian.PacketsIPacket


PacketBase Constructor

Grid Solutions Framework PacketBase Constructor
Initializes a new instance of the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PacketBase(
    short packetID
)
Protected Sub New (
    packetID As Short
)
new :
        packetID : int16 -> PacketBase
GSF.Historian.Packets.PacketBase = function(packetID);
protected:
PacketBase(
    short packetID
)

Parameters

packetID
Type: SystemInt16
Numeric identifier for the packet type.
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase Fields

Grid Solutions Framework PacketBase Fields

The PacketBase type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of the packet.
Top
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.FixedLength Field

Grid Solutions Framework PacketBaseFixedLength Field
Specifies the number of bytes in the binary image of the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Packets.PacketBase.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
Remarks
A value of -1 indicates that the binary image of the packet is of variable length.
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase Methods

Grid Solutions Framework PacketBase Methods

The PacketBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the packet.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the packet and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes packet by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.ExtractTimeSeriesData Method

Grid Solutions Framework PacketBaseExtractTimeSeriesData Method
Extracts time-series data from the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract IEnumerable<IDataPoint> ExtractTimeSeriesData()
Public MustOverride Function ExtractTimeSeriesData As IEnumerable(Of IDataPoint)
abstract ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>

function ExtractTimeSeriesData();
public:
virtual IEnumerable<IDataPoint^>^ ExtractTimeSeriesData() abstract

Return Value

Type: IEnumerable IDataPoint
An IEnumerableT of IDataPoints if the packet contains time-series data; otherwise null.

Implements

IPacketExtractTimeSeriesData
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.GenerateBinaryImage Method

Grid Solutions Framework PacketBaseGenerateBinaryImage Method
Generates binary image of the packet and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public MustOverride Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int

function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) abstract

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Remarks
Implementers should validate startIndex and BinaryLength against buffer length. The ValidateParametersT(T, Int32, Int32) method can be used to perform this validation.
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.ParseBinaryImage Method

Grid Solutions Framework PacketBaseParseBinaryImage Method
Initializes packet by parsing the specified buffer containing a binary image.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public MustOverride Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int

function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) abstract

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
Implementers should validate startIndex and length against buffer length. The ValidateParametersT(T, Int32, Int32) method can be used to perform this validation.
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase Properties

Grid Solutions Framework PacketBase Properties

The PacketBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately.
Public property | Archive | Gets or sets the current IArchive.
Public property | BinaryLength | Gets the length of the packet's binary representation.
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet.
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet.
Public property | Source | Gets or sets the data source identifier of the frame image.
Public property | TypeID | Gets or sets the numeric identifier for the packet type.
Top
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.AllowQueuedPublication Property

Grid Solutions Framework PacketBaseAllowQueuedPublication Property
Gets flag that determines if frame image can queued for publication or should be processed immediately.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllowQueuedPublication { get; }
Public ReadOnly Property AllowQueuedPublication As Boolean
    Get
abstract AllowQueuedPublication : bool with get
override AllowQueuedPublication : bool with get
function get_AllowQueuedPublication();

public:
virtual property bool AllowQueuedPublication {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportFrameImageTTypeIdentifierAllowQueuedPublication
Remarks
Some frames, e.g., a configuration or key frame, may be critical to processing of other frames. In this case, these types of frames should be published immediately so that subsequent frame parsing can have access to needed critical information.
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.Archive Property

Grid Solutions Framework PacketBaseArchive Property
Gets or sets the current IArchive.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IArchive Archive { get; set; }
Public Property Archive As IArchive
    Get
    Set
abstract Archive : IArchive with get, set
override Archive : IArchive with get, set
function get_Archive();
function set_Archive(value);
public:
virtual property IArchive^ Archive {
    IArchive^ get () sealed;
    void set (IArchive^ value) sealed;
}

Property Value

Type: IArchive

Implements

IPacketArchive
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.BinaryLength Property

Grid Solutions Framework PacketBaseBinaryLength Property
Gets the length of the packet's binary representation.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int BinaryLength { get; }
Public MustOverride ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get

function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () abstract;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.CommonHeader Property

Grid Solutions Framework PacketBaseCommonHeader Property
Gets or sets the PacketCommonHeader for the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICommonHeader<short> CommonHeader { get; set; }
Public Property CommonHeader As ICommonHeader(Of Short)
    Get
    Set
abstract CommonHeader : ICommonHeader<int16> with get, set
override CommonHeader : ICommonHeader<int16> with get, set
function get_CommonHeader();
function set_CommonHeader(value);
public:
virtual property ICommonHeader<short>^ CommonHeader {
    ICommonHeader<short>^ get () sealed;
    void set (ICommonHeader<short>^ value) sealed;
}

Property Value

Type: ICommonHeader Int16

Implements

ISupportFrameImageTTypeIdentifierCommonHeader
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.PreProcessHandler Property

Grid Solutions Framework PacketBasePreProcessHandler Property
Gets or sets the Delegate that pre-processes the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Func<IEnumerable<byte[]>> PreProcessHandler { get; set; }
Public Property PreProcessHandler As Func(Of IEnumerable(Of Byte()))
    Get
    Set
abstract PreProcessHandler : Func<IEnumerable<byte[]>> with get, set
override PreProcessHandler : Func<IEnumerable<byte[]>> with get, set
function get_PreProcessHandler();
function set_PreProcessHandler(value);
public:
virtual property Func<IEnumerable<array<unsigned char>^>^>^ PreProcessHandler {
    Func<IEnumerable<array<unsigned char>^>^>^ get () sealed;
    void set (Func<IEnumerable<array<unsigned char>^>^>^ value) sealed;
}

Property Value

Type: Func IEnumerable Byte

Implements

IPacketPreProcessHandler
Remarks
FuncTResult returns an IEnumerableT object containing the binary data to be sent back to the packet sender.
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.ProcessHandler Property

Grid Solutions Framework PacketBaseProcessHandler Property
Gets or sets the Delegate that processes the packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Func<IEnumerable<byte[]>> ProcessHandler { get; set; }
Public Property ProcessHandler As Func(Of IEnumerable(Of Byte()))
    Get
    Set
abstract ProcessHandler : Func<IEnumerable<byte[]>> with get, set
override ProcessHandler : Func<IEnumerable<byte[]>> with get, set
function get_ProcessHandler();
function set_ProcessHandler(value);
public:
virtual property Func<IEnumerable<array<unsigned char>^>^>^ ProcessHandler {
    Func<IEnumerable<array<unsigned char>^>^>^ get () sealed;
    void set (Func<IEnumerable<array<unsigned char>^>^>^ value) sealed;
}

Property Value

Type: Func IEnumerable Byte

Implements

IPacketProcessHandler
Remarks
FuncTResult returns an IEnumerableT object containing the binary data to be sent back to the packet sender.
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.Source Property

Grid Solutions Framework PacketBaseSource Property
Gets or sets the data source identifier of the frame image.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid Source { get; set; }
Public Property Source As Guid
    Get
    Set
abstract Source : Guid with get, set
override Source : Guid with get, set
function get_Source();
function set_Source(value);
public:
virtual property Guid Source {
    Guid get () sealed;
    void set (Guid value) sealed;
}

Property Value

Type: Guid

Implements

ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifierSource
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketBase.TypeID Property

Grid Solutions Framework PacketBaseTypeID Property
Gets or sets the numeric identifier for the packet type.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short TypeID { get; }
Public ReadOnly Property TypeID As Short
    Get
abstract TypeID : int16 with get
override TypeID : int16 with get
function get_TypeID();

public:
virtual property short TypeID {
    short get () sealed;
}

Property Value

Type: Int16

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

PacketBase Class
GSF.Historian.Packets Namespace


PacketCommonHeader Class

Grid Solutions Framework PacketCommonHeader Class
Represents the common header information that is present in the binary image of all Types that implement the IPacket interface.
Inheritance Hierarchy
SystemObject
GSF.ParsingCommonHeaderBase Int16
GSF.Historian.PacketsPacketCommonHeader

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketCommonHeader : CommonHeaderBase<short>
Public Class PacketCommonHeader
    Inherits CommonHeaderBase(Of Short)
type PacketCommonHeader =
    class
        inherit CommonHeaderBase<int16>
    end
GSF.Historian.Packets.PacketCommonHeader = function();

Type.createClass(
    'GSF.Historian.Packets.PacketCommonHeader',
    GSF.Parsing.CommonHeaderBase`1);
public ref class PacketCommonHeader : public CommonHeaderBase<short>

The PacketCommonHeader type exposes the following members.

Constructors
 | Name | Description
Public method | PacketCommonHeader | Initializes a new instance of the PacketCommonHeader class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketCommonHeader Constructor

Grid Solutions Framework PacketCommonHeader Constructor
Initializes a new instance of the PacketCommonHeader class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketCommonHeader(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketCommonHeader
GSF.Historian.Packets.PacketCommonHeader = function(buffer, startIndex, length);
public:
PacketCommonHeader(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer containing binary image to be used for initializing PacketCommonHeader.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
Exceptions
Exception | Condition
InvalidOperationException | Not enough length available to parse PacketCommonHeader.
See Also

Reference

PacketCommonHeader Class
GSF.Historian.Packets Namespace


PacketCommonHeader Methods

Grid Solutions Framework PacketCommonHeader Methods

The PacketCommonHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketCommonHeader Class
GSF.Historian.Packets Namespace


PacketCommonHeader Properties

Grid Solutions Framework PacketCommonHeader Properties

The PacketCommonHeader type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
See Also

Reference

PacketCommonHeader Class
GSF.Historian.Packets Namespace


PacketParser Class

Grid Solutions Framework PacketParser Class
Represents a data parser that can parse binary data in to IPackets.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase Int16, IPacket
GSF.ParsingMultiSourceFrameImageParserBase Guid, Int16, IPacket
GSF.Historian.PacketsPacketParser

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketParser : MultiSourceFrameImageParserBase<Guid, short, IPacket>
Public Class PacketParser
    Inherits MultiSourceFrameImageParserBase(Of Guid, Short, IPacket)
type PacketParser =
    class
        inherit MultiSourceFrameImageParserBase<Guid, int16, IPacket>
    end
GSF.Historian.Packets.PacketParser = function();

Type.createClass(
    'GSF.Historian.Packets.PacketParser',
    GSF.Parsing.MultiSourceFrameImageParserBase`3);
public ref class PacketParser : public MultiSourceFrameImageParserBase<Guid, short, IPacket^>

The PacketParser type exposes the following members.

Constructors
 | Name | Description
Public method | PacketParser | Initializes a new instance of the PacketParser class
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Returns an PacketCommonHeader object. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the streaming data parser. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Returns false since the protocol implementation of IPacket does not use synchronization. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current status of FrameImageParserBaseTTypeIdentifier, TOutputType. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketParser Constructor

Grid Solutions Framework PacketParser Constructor
Initializes a new instance of the PacketParser class

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketParser()
Public Sub New
new : unit -> PacketParser
GSF.Historian.Packets.PacketParser = function();
public:
PacketParser()
See Also

Reference

PacketParser Class
GSF.Historian.Packets Namespace


PacketParser Fields

Grid Solutions Framework PacketParser Fields

The PacketParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

PacketParser Class
GSF.Historian.Packets Namespace


PacketParser Methods

Grid Solutions Framework PacketParser Methods

The PacketParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Returns an PacketCommonHeader object. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the streaming data parser. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

PacketParser Class
GSF.Historian.Packets Namespace


PacketParser.ParseCommonHeader Method

Grid Solutions Framework PacketParserParseCommonHeader Method
Returns an PacketCommonHeader object.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<short> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of Short)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<int16>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<int16>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<short>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader Int16
A PacketCommonHeader object parsed from the buffer, or null if not enough buffer is available..
See Also

Reference

PacketParser Class
GSF.Historian.Packets Namespace


PacketParser Properties

Grid Solutions Framework PacketParser Properties

The PacketParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Returns false since the protocol implementation of IPacket does not use synchronization. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current status of FrameImageParserBaseTTypeIdentifier, TOutputType. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

PacketParser Class
GSF.Historian.Packets Namespace


PacketParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework PacketParserProtocolUsesSyncBytes Property
Returns false since the protocol implementation of IPacket does not use synchronization.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

PacketParser Class
GSF.Historian.Packets Namespace


PacketParser Events

Grid Solutions Framework PacketParser Events

The PacketParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

PacketParser Class
GSF.Historian.Packets Namespace


PacketType1 Class

Grid Solutions Framework PacketType1 Class
Represents a packet to be used for sending single time-series data point to a historian for archival.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsPacketType1

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType1 : PacketBase
Public Class PacketType1
    Inherits PacketBase
type PacketType1 =
    class
        inherit PacketBase
    end
GSF.Historian.Packets.PacketType1 = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType1',
    GSF.Historian.Packets.PacketBase);
public ref class PacketType1 : public PacketBase

The PacketType1 type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType1 | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(Int32) | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(IDataPoint) | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(IMeasurement) | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(Byte, Int32, Int32) | Initializes a new instance of the PacketType1 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType1. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType1 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType1 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | PreProcess | Pre-processes PacketType1.
Protected method | Process | Processes PacketType1.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType1.
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType1. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | HistorianID | Gets or sets the historian identifier of the time-series data.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Quality | Gets or sets the Quality of the time-series data.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | Time | Gets or sets the TimeTag of the time-series data.
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Public property | Value | Gets or sets the value of the time-series data.
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketType1 Constructor

Grid Solutions Framework PacketType1 Constructor
Overload List
 | Name | Description
Public method | PacketType1 | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(Int32) | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(IDataPoint) | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(IMeasurement) | Initializes a new instance of the PacketType1 class.
Public method | PacketType1(Byte, Int32, Int32) | Initializes a new instance of the PacketType1 class.
Top
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1 Constructor

Grid Solutions Framework PacketType1 Constructor
Initializes a new instance of the PacketType1 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType1()
Public Sub New
new : unit -> PacketType1
GSF.Historian.Packets.PacketType1 = function();
public:
PacketType1()
See Also

Reference

PacketType1 Class
PacketType1 Overload
GSF.Historian.Packets Namespace


PacketType1 Constructor (Int32)

Grid Solutions Framework PacketType1 Constructor (Int32)
Initializes a new instance of the PacketType1 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType1(
    int historianID
)
Public Sub New (
    historianID As Integer
)
new :
        historianID : int -> PacketType1
GSF.Historian.Packets.PacketType1 = function(historianID);
public:
PacketType1(
    int historianID
)

Parameters

historianID
Type: SystemInt32
Historian identifier.
See Also

Reference

PacketType1 Class
PacketType1 Overload
GSF.Historian.Packets Namespace


PacketType1 Constructor (IDataPoint)

Grid Solutions Framework PacketType1 Constructor (IDataPoint)
Initializes a new instance of the PacketType1 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType1(
    IDataPoint dataPoint
)
Public Sub New (
    dataPoint As IDataPoint
)
new :
        dataPoint : IDataPoint -> PacketType1
GSF.Historian.Packets.PacketType1 = function(dataPoint);
public:
PacketType1(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
Object that implements the IDataPoint interface.
See Also

Reference

PacketType1 Class
PacketType1 Overload
GSF.Historian.Packets Namespace


PacketType1 Constructor (IMeasurement)

Grid Solutions Framework PacketType1 Constructor (IMeasurement)
Initializes a new instance of the PacketType1 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType1(
    IMeasurement measurement
)
Public Sub New (
    measurement As IMeasurement
)
new :
        measurement : IMeasurement -> PacketType1
GSF.Historian.Packets.PacketType1 = function(measurement);
public:
PacketType1(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Object that implements the IMeasurement interface.
See Also

Reference

PacketType1 Class
PacketType1 Overload
GSF.Historian.Packets Namespace


PacketType1 Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType1 Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType1 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType1(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType1
GSF.Historian.Packets.PacketType1 = function(buffer, startIndex, length);
public:
PacketType1(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType1.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType1 Class
PacketType1 Overload
GSF.Historian.Packets Namespace


PacketType1 Fields

Grid Solutions Framework PacketType1 Fields

The PacketType1 type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType1.
Top
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.FixedLength Field

Grid Solutions Framework PacketType1FixedLength Field
Specifies the number of bytes in the binary image of PacketType1.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Packets.PacketType1.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1 Methods

Grid Solutions Framework PacketType1 Methods

The PacketType1 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType1. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType1 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType1 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | PreProcess | Pre-processes PacketType1.
Protected method | Process | Processes PacketType1.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.ExtractTimeSeriesData Method

Grid Solutions Framework PacketType1ExtractTimeSeriesData Method
Extracts time-series data from PacketType1.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IEnumerable<IDataPoint> ExtractTimeSeriesData()
Public Overrides Function ExtractTimeSeriesData As IEnumerable(Of IDataPoint)
abstract ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
override ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
function ExtractTimeSeriesData();
public:
virtual IEnumerable<IDataPoint^>^ ExtractTimeSeriesData() override

Return Value

Type: IEnumerable IDataPoint
An IEnumerableT object of ArchiveDataPoints.

Implements

IPacketExtractTimeSeriesData
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.GenerateBinaryImage Method

Grid Solutions Framework PacketType1GenerateBinaryImage Method
Generates binary image of the PacketType1 and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.ParseBinaryImage Method

Grid Solutions Framework PacketType1ParseBinaryImage Method
Initializes PacketType1 from the specified buffer.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType1.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing PacketType1.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.PreProcess Method

Grid Solutions Framework PacketType1PreProcess Method
Pre-processes PacketType1.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> PreProcess()
Protected Overridable Function PreProcess As IEnumerable(Of Byte())
abstract PreProcess : unit -> IEnumerable<byte[]>
override PreProcess : unit -> IEnumerable<byte[]>
function PreProcess();
protected:
virtual IEnumerable<array<unsigned char>^>^ PreProcess()

Return Value

Type: IEnumerable Byte
A Byte array for "ACK".
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.Process Method

Grid Solutions Framework PacketType1Process Method
Processes PacketType1.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> Process()
Protected Overridable Function Process As IEnumerable(Of Byte())
abstract Process : unit -> IEnumerable<byte[]>
override Process : unit -> IEnumerable<byte[]>
function Process();
protected:
virtual IEnumerable<array<unsigned char>^>^ Process()

Return Value

Type: IEnumerable Byte
A null reference.
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1 Properties

Grid Solutions Framework PacketType1 Properties

The PacketType1 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType1. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | HistorianID | Gets or sets the historian identifier of the time-series data.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Quality | Gets or sets the Quality of the time-series data.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | Time | Gets or sets the TimeTag of the time-series data.
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Public property | Value | Gets or sets the value of the time-series data.
Top
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.BinaryLength Property

Grid Solutions Framework PacketType1BinaryLength Property
Gets the length of the PacketType1.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.HistorianID Property

Grid Solutions Framework PacketType1HistorianID Property
Gets or sets the historian identifier of the time-series data.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; set; }
Public Property HistorianID As Integer
    Get
    Set
member HistorianID : int with get, set

function get_HistorianID();
function set_HistorianID(value);
public:
property int HistorianID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive.
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.Quality Property

Grid Solutions Framework PacketType1Quality Property
Gets or sets the Quality of the time-series data.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Quality Quality { get; set; }
Public Property Quality As Quality
    Get
    Set
member Quality : Quality with get, set

function get_Quality();
function set_Quality(value);
public:
property Quality Quality {
    Quality get ();
    void set (Quality value);
}

Property Value

Type: Quality
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.Time Property

Grid Solutions Framework PacketType1Time Property
Gets or sets the TimeTag of the time-series data.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeTag Time { get; set; }
Public Property Time As TimeTag
    Get
    Set
member Time : TimeTag with get, set

function get_Time();
function set_Time(value);
public:
property TimeTag^ Time {
    TimeTag^ get ();
    void set (TimeTag^ value);
}

Property Value

Type: TimeTag
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 01/01/1995 and 01/19/2063.
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType1.Value Property

Grid Solutions Framework PacketType1Value Property
Gets or sets the value of the time-series data.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float Value { get; set; }
Public Property Value As Single
    Get
    Set
member Value : float32 with get, set

function get_Value();
function set_Value(value);
public:
property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PacketType1 Class
GSF.Historian.Packets Namespace


PacketType101 Class

Grid Solutions Framework PacketType101 Class
Represents a packet that can be used to send multiple time-series data points to a historian for archival.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsPacketType101

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType101 : PacketBase
Public Class PacketType101
    Inherits PacketBase
type PacketType101 =
    class
        inherit PacketBase
    end
GSF.Historian.Packets.PacketType101 = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType101',
    GSF.Historian.Packets.PacketBase);
public ref class PacketType101 : public PacketBase

The PacketType101 type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType101 | Initializes a new instance of the PacketType101 class.
Public method | PacketType101(IEnumerableIDataPoint) | Initializes a new instance of the PacketType101 class.
Public method | PacketType101(IEnumerableIMeasurement) | Initializes a new instance of the PacketType101 class.
Public method | PacketType101(Byte, Int32, Int32) | Initializes a new instance of the PacketType101 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType101. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType101 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType101 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | PreProcess | Pre-processes PacketType101.
Protected method | Process | Processes PacketType101.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType101. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | Data | Gets the time-series data in PacketType101.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

GSF.Historian.Packets Namespace
GSF.Historian.PacketsPacketType101DataPoint


PacketType101 Constructor

Grid Solutions Framework PacketType101 Constructor
Overload List
 | Name | Description
Public method | PacketType101 | Initializes a new instance of the PacketType101 class.
Public method | PacketType101(IEnumerableIDataPoint) | Initializes a new instance of the PacketType101 class.
Public method | PacketType101(IEnumerableIMeasurement) | Initializes a new instance of the PacketType101 class.
Public method | PacketType101(Byte, Int32, Int32) | Initializes a new instance of the PacketType101 class.
Top
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101 Constructor

Grid Solutions Framework PacketType101 Constructor
Initializes a new instance of the PacketType101 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101()
Public Sub New
new : unit -> PacketType101
GSF.Historian.Packets.PacketType101 = function();
public:
PacketType101()
See Also

Reference

PacketType101 Class
PacketType101 Overload
GSF.Historian.Packets Namespace


PacketType101 Constructor (IEnumerable(IDataPoint))

Grid Solutions Framework PacketType101 Constructor (IEnumerableIDataPoint)
Initializes a new instance of the PacketType101 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101(
    IEnumerable<IDataPoint> dataPoints
)
Public Sub New (
    dataPoints As IEnumerable(Of IDataPoint)
)
new :
        dataPoints : IEnumerable<IDataPoint> -> PacketType101
GSF.Historian.Packets.PacketType101 = function(dataPoints);
public:
PacketType101(
    IEnumerable<IDataPoint^>^ dataPoints
)

Parameters

dataPoints
Type: System.Collections.GenericIEnumerable IDataPoint
A collection of time-series data points.
See Also

Reference

PacketType101 Class
PacketType101 Overload
GSF.Historian.Packets Namespace


PacketType101 Constructor (IEnumerable(IMeasurement))

Grid Solutions Framework PacketType101 Constructor (IEnumerableIMeasurement)
Initializes a new instance of the PacketType101 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101(
    IEnumerable<IMeasurement> measurements
)
Public Sub New (
    measurements As IEnumerable(Of IMeasurement)
)
new :
        measurements : IEnumerable<IMeasurement> -> PacketType101
GSF.Historian.Packets.PacketType101 = function(measurements);
public:
PacketType101(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
A collection of mesurements.
See Also

Reference

PacketType101 Class
PacketType101 Overload
GSF.Historian.Packets Namespace


PacketType101 Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType101 Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType101 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType101
GSF.Historian.Packets.PacketType101 = function(buffer, startIndex, length);
public:
PacketType101(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType101.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType101 Class
PacketType101 Overload
GSF.Historian.Packets Namespace


PacketType101 Methods

Grid Solutions Framework PacketType101 Methods

The PacketType101 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType101. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType101 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType101 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | PreProcess | Pre-processes PacketType101.
Protected method | Process | Processes PacketType101.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101.ExtractTimeSeriesData Method

Grid Solutions Framework PacketType101ExtractTimeSeriesData Method
Extracts time-series data from PacketType101.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IEnumerable<IDataPoint> ExtractTimeSeriesData()
Public Overrides Function ExtractTimeSeriesData As IEnumerable(Of IDataPoint)
abstract ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
override ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
function ExtractTimeSeriesData();
public:
virtual IEnumerable<IDataPoint^>^ ExtractTimeSeriesData() override

Return Value

Type: IEnumerable IDataPoint
An IEnumerableT object of ArchiveDataPoints.

Implements

IPacketExtractTimeSeriesData
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101.GenerateBinaryImage Method

Grid Solutions Framework PacketType101GenerateBinaryImage Method
Generates binary image of the PacketType101 and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101.ParseBinaryImage Method

Grid Solutions Framework PacketType101ParseBinaryImage Method
Initializes PacketType101 from the specified buffer.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType101.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing PacketType101.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101.PreProcess Method

Grid Solutions Framework PacketType101PreProcess Method
Pre-processes PacketType101.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> PreProcess()
Protected Overridable Function PreProcess As IEnumerable(Of Byte())
abstract PreProcess : unit -> IEnumerable<byte[]>
override PreProcess : unit -> IEnumerable<byte[]>
function PreProcess();
protected:
virtual IEnumerable<array<unsigned char>^>^ PreProcess()

Return Value

Type: IEnumerable Byte
A Byte array for "ACK".
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101.Process Method

Grid Solutions Framework PacketType101Process Method
Processes PacketType101.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> Process()
Protected Overridable Function Process As IEnumerable(Of Byte())
abstract Process : unit -> IEnumerable<byte[]>
override Process : unit -> IEnumerable<byte[]>
function Process();
protected:
virtual IEnumerable<array<unsigned char>^>^ Process()

Return Value

Type: IEnumerable Byte
A null reference.
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101 Properties

Grid Solutions Framework PacketType101 Properties

The PacketType101 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType101. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | Data | Gets the time-series data in PacketType101.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101.BinaryLength Property

Grid Solutions Framework PacketType101BinaryLength Property
Gets the length of the PacketType101.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101.Data Property

Grid Solutions Framework PacketType101Data Property
Gets the time-series data in PacketType101.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<IDataPoint> Data { get; }
Public ReadOnly Property Data As IList(Of IDataPoint)
    Get
member Data : IList<IDataPoint> with get

function get_Data();

public:
property IList<IDataPoint^>^ Data {
    IList<IDataPoint^>^ get ();
}

Property Value

Type: IList IDataPoint
See Also

Reference

PacketType101 Class
GSF.Historian.Packets Namespace


PacketType101DataPoint Class

Grid Solutions Framework PacketType101DataPoint Class
Represents time-series data transmitted in PacketType101.
Inheritance Hierarchy
SystemObject
GSF.Historian.FilesArchiveDataPoint
GSF.Historian.PacketsPacketType101DataPoint

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType101DataPoint : ArchiveDataPoint
Public Class PacketType101DataPoint
    Inherits ArchiveDataPoint
type PacketType101DataPoint =
    class
        inherit ArchiveDataPoint
    end
GSF.Historian.Packets.PacketType101DataPoint = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType101DataPoint',
    GSF.Historian.Files.ArchiveDataPoint);
public ref class PacketType101DataPoint : public ArchiveDataPoint

The PacketType101DataPoint type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType101DataPoint(IDataPoint) | Initializes a new instance of the PacketType101DataPoint class.
Public method | PacketType101DataPoint(IMeasurement) | Initializes a new instance of the PacketType101DataPoint class.
Public method | PacketType101DataPoint(Byte, Int32, Int32) | Initializes a new instance of the PacketType101DataPoint class.
Public method | PacketType101DataPoint(Int32, TimeTag, Single, Quality) | Initializes a new instance of the PacketType101DataPoint class.
Top
Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataPoint object to obj. (Inherited from ArchiveDataPoint.)
Public method | Equals | Determines whether the current ArchiveDataPoint object is equal to obj. (Inherited from ArchiveDataPoint.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType101DataPoint and copies it into the given buffer, for BinaryLength bytes. (Overrides ArchiveDataPointGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Returns the hash code for the current ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType101DataPoint from the specified buffer. (Overrides ArchiveDataPointParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns the text representation of ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | ToString(IFormatProvider) | Returns the text representation of ArchiveDataPoint object using the specified provider. (Inherited from ArchiveDataPoint.)
Public method | ToString(String) | Returns the text representation of ArchiveDataPoint object in the specified format. (Inherited from ArchiveDataPoint.)
Public method | ToString(String, IFormatProvider) | Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider. (Inherited from ArchiveDataPoint.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType101DataPoint.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the PacketType101DataPoint. (Overrides ArchiveDataPointBinaryLength.)
Protected property | Flags | Gets or sets the 32-bit word used for storing data of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | IsEmpty | Gets a boolean value that indicates whether ArchiveDataPoint contains any data. (Inherited from ArchiveDataPoint.)
Public property | Metadata | Gets or sets the associated MetadataRecord with this ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Quality | Gets or sets the Quality of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Time | Gets or sets the TimeTag of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Value | Gets or sets the floating-point value of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Top
See Also

Reference

GSF.Historian.Packets Namespace
GSF.Historian.PacketsPacketType101


PacketType101DataPoint Constructor

Grid Solutions Framework PacketType101DataPoint Constructor
Overload List
 | Name | Description
Public method | PacketType101DataPoint(IDataPoint) | Initializes a new instance of the PacketType101DataPoint class.
Public method | PacketType101DataPoint(IMeasurement) | Initializes a new instance of the PacketType101DataPoint class.
Public method | PacketType101DataPoint(Byte, Int32, Int32) | Initializes a new instance of the PacketType101DataPoint class.
Public method | PacketType101DataPoint(Int32, TimeTag, Single, Quality) | Initializes a new instance of the PacketType101DataPoint class.
Top
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType101DataPoint Constructor (IDataPoint)

Grid Solutions Framework PacketType101DataPoint Constructor (IDataPoint)
Initializes a new instance of the PacketType101DataPoint class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101DataPoint(
    IDataPoint dataPoint
)
Public Sub New (
    dataPoint As IDataPoint
)
new :
        dataPoint : IDataPoint -> PacketType101DataPoint
GSF.Historian.Packets.PacketType101DataPoint = function(dataPoint);
public:
PacketType101DataPoint(
    IDataPoint^ dataPoint
)

Parameters

dataPoint
Type: GSF.HistorianIDataPoint
A time-series data point.
See Also

Reference

PacketType101DataPoint Class
PacketType101DataPoint Overload
GSF.Historian.Packets Namespace


PacketType101DataPoint Constructor (IMeasurement)

Grid Solutions Framework PacketType101DataPoint Constructor (IMeasurement)
Initializes a new instance of the PacketType101DataPoint class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101DataPoint(
    IMeasurement measurement
)
Public Sub New (
    measurement As IMeasurement
)
new :
        measurement : IMeasurement -> PacketType101DataPoint
GSF.Historian.Packets.PacketType101DataPoint = function(measurement);
public:
PacketType101DataPoint(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Object that implements the IMeasurement interface.
See Also

Reference

PacketType101DataPoint Class
PacketType101DataPoint Overload
GSF.Historian.Packets Namespace


PacketType101DataPoint Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType101DataPoint Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType101DataPoint class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101DataPoint(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType101DataPoint
GSF.Historian.Packets.PacketType101DataPoint = function(buffer, startIndex, length);
public:
PacketType101DataPoint(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType101DataPoint.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType101DataPoint Class
PacketType101DataPoint Overload
GSF.Historian.Packets Namespace


PacketType101DataPoint Constructor (Int32, TimeTag, Single, Quality)

Grid Solutions Framework PacketType101DataPoint Constructor (Int32, TimeTag, Single, Quality)
Initializes a new instance of the PacketType101DataPoint class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType101DataPoint(
    int historianID,
    TimeTag time,
    float value,
    Quality quality
)
Public Sub New (
    historianID As Integer,
    time As TimeTag,
    value As Single,
    quality As Quality
)
new :
        historianID : int *
        time : TimeTag *
        value : float32 *
        quality : Quality -> PacketType101DataPoint
GSF.Historian.Packets.PacketType101DataPoint = function(historianID, time, value, quality);
public:
PacketType101DataPoint(
    int historianID,
    TimeTag^ time,
    float value,
    Quality quality
)

Parameters

historianID
Type: SystemInt32
Historian identifier of PacketType101DataPoint.
time
Type: GSF.HistorianTimeTag
TimeTag of PacketType101DataPoint.
value
Type: SystemSingle
Floating-point value of PacketType101DataPoint.
quality
Type: GSF.HistorianQuality
Quality of PacketType101DataPoint.
See Also

Reference

PacketType101DataPoint Class
PacketType101DataPoint Overload
GSF.Historian.Packets Namespace


PacketType101DataPoint Fields

Grid Solutions Framework PacketType101DataPoint Fields

The PacketType101DataPoint type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType101DataPoint.
Top
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType101DataPoint.FixedLength Field

Grid Solutions Framework PacketType101DataPointFixedLength Field
Specifies the number of bytes in the binary image of PacketType101DataPoint.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Packets.PacketType101DataPoint.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType101DataPoint Methods

Grid Solutions Framework PacketType101DataPoint Methods

The PacketType101DataPoint type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares the current ArchiveDataPoint object to obj. (Inherited from ArchiveDataPoint.)
Public method | Equals | Determines whether the current ArchiveDataPoint object is equal to obj. (Inherited from ArchiveDataPoint.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType101DataPoint and copies it into the given buffer, for BinaryLength bytes. (Overrides ArchiveDataPointGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Returns the hash code for the current ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType101DataPoint from the specified buffer. (Overrides ArchiveDataPointParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns the text representation of ArchiveDataPoint object. (Inherited from ArchiveDataPoint.)
Public method | ToString(IFormatProvider) | Returns the text representation of ArchiveDataPoint object using the specified provider. (Inherited from ArchiveDataPoint.)
Public method | ToString(String) | Returns the text representation of ArchiveDataPoint object in the specified format. (Inherited from ArchiveDataPoint.)
Public method | ToString(String, IFormatProvider) | Returns the text representation of ArchiveDataPoint object in the specified format using the specified provider. (Inherited from ArchiveDataPoint.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType101DataPoint.GenerateBinaryImage Method

Grid Solutions Framework PacketType101DataPointGenerateBinaryImage Method
Generates binary image of the PacketType101DataPoint and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType101DataPoint.ParseBinaryImage Method

Grid Solutions Framework PacketType101DataPointParseBinaryImage Method
Initializes PacketType101DataPoint from the specified buffer.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType101DataPoint.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing PacketType101DataPoint.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType101DataPoint Properties

Grid Solutions Framework PacketType101DataPoint Properties

The PacketType101DataPoint type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the PacketType101DataPoint. (Overrides ArchiveDataPointBinaryLength.)
Protected property | Flags | Gets or sets the 32-bit word used for storing data of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | HistorianID | Gets or sets the historian identifier of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | IsEmpty | Gets a boolean value that indicates whether ArchiveDataPoint contains any data. (Inherited from ArchiveDataPoint.)
Public property | Metadata | Gets or sets the associated MetadataRecord with this ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Quality | Gets or sets the Quality of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Time | Gets or sets the TimeTag of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Public property | Value | Gets or sets the floating-point value of ArchiveDataPoint. (Inherited from ArchiveDataPoint.)
Top
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType101DataPoint.BinaryLength Property

Grid Solutions Framework PacketType101DataPointBinaryLength Property
Gets the length of the PacketType101DataPoint.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

PacketType101DataPoint Class
GSF.Historian.Packets Namespace


PacketType11 Class

Grid Solutions Framework PacketType11 Class
Represents a packet to be used for requesting Summary for the RequestIDs.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsQueryPacketBase
GSF.Historian.PacketsPacketType11

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType11 : QueryPacketBase
Public Class PacketType11
    Inherits QueryPacketBase
type PacketType11 =
    class
        inherit QueryPacketBase
    end
GSF.Historian.Packets.PacketType11 = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType11',
    GSF.Historian.Packets.QueryPacketBase);
public ref class PacketType11 : public QueryPacketBase

The PacketType11 type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType11 | Initializes a new instance of the PacketType11 class.
Public method | PacketType11(Byte, Int32, Int32) | Initializes a new instance of the PacketType11 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Inherited from QueryPacketBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Inherited from QueryPacketBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Inherited from QueryPacketBase.)
Protected method | Process | Processes PacketType11.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Inherited from QueryPacketBase.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested. (Inherited from QueryPacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketType11 Constructor

Grid Solutions Framework PacketType11 Constructor
Overload List
 | Name | Description
Public method | PacketType11 | Initializes a new instance of the PacketType11 class.
Public method | PacketType11(Byte, Int32, Int32) | Initializes a new instance of the PacketType11 class.
Top
See Also

Reference

PacketType11 Class
GSF.Historian.Packets Namespace


PacketType11 Constructor

Grid Solutions Framework PacketType11 Constructor
Initializes a new instance of the PacketType11 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType11()
Public Sub New
new : unit -> PacketType11
GSF.Historian.Packets.PacketType11 = function();
public:
PacketType11()
See Also

Reference

PacketType11 Class
PacketType11 Overload
GSF.Historian.Packets Namespace


PacketType11 Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType11 Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType11 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType11(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType11
GSF.Historian.Packets.PacketType11 = function(buffer, startIndex, length);
public:
PacketType11(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType11.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType11 Class
PacketType11 Overload
GSF.Historian.Packets Namespace


PacketType11 Methods

Grid Solutions Framework PacketType11 Methods

The PacketType11 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Inherited from QueryPacketBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Inherited from QueryPacketBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Inherited from QueryPacketBase.)
Protected method | Process | Processes PacketType11.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType11 Class
GSF.Historian.Packets Namespace


PacketType11.Process Method

Grid Solutions Framework PacketType11Process Method
Processes PacketType11.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> Process()
Protected Overridable Function Process As IEnumerable(Of Byte())
abstract Process : unit -> IEnumerable<byte[]>
override Process : unit -> IEnumerable<byte[]>
function Process();
protected:
virtual IEnumerable<array<unsigned char>^>^ Process()

Return Value

Type: IEnumerable Byte
An IEnumerableT object containing the binary images of Summary for the RequestIDs.
See Also

Reference

PacketType11 Class
GSF.Historian.Packets Namespace


PacketType11 Properties

Grid Solutions Framework PacketType11 Properties

The PacketType11 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Inherited from QueryPacketBase.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested. (Inherited from QueryPacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

PacketType11 Class
GSF.Historian.Packets Namespace


PacketType2 Class

Grid Solutions Framework PacketType2 Class
Represents a packet to be used for sending single time (expanded format) series data point to a historian for archival.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsPacketType2

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType2 : PacketBase
Public Class PacketType2
    Inherits PacketBase
type PacketType2 =
    class
        inherit PacketBase
    end
GSF.Historian.Packets.PacketType2 = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType2',
    GSF.Historian.Packets.PacketBase);
public ref class PacketType2 : public PacketBase

The PacketType2 type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType2 | Initializes a new instance of the PacketType2 class.
Public method | PacketType2(Byte, Int32, Int32) | Initializes a new instance of the PacketType2 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType2. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType2 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType2 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | PreProcess | Pre-processes PacketType2.
Protected method | Process | Processes PacketType2.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType2.
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType2. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | Day | Gets or sets the day-part of the time.
Public property | GmtOffset | Gets or sets the difference, in hours, between the local time and Greenwich Mean Time (Universal Coordinated Time).
Public property | HistorianID | Gets or sets the historian identifier of the time-series data.
Public property | Hour | Gets or sets the hour-part of the time.
Public property | Millisecond | Gets or sets the millisecond-part of the time.
Public property | Minute | Gets or sets the minute-part of the time.
Public property | Month | Gets or sets the month-part of the time.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Quality | Gets or sets the Quality of the time-series data.
Public property | Second | Gets or sets the second-part of the time.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Public property | Value | Gets or sets the value of the time-series data.
Public property | Year | Gets or sets the year-part of the time.
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketType2 Constructor

Grid Solutions Framework PacketType2 Constructor
Overload List
 | Name | Description
Public method | PacketType2 | Initializes a new instance of the PacketType2 class.
Public method | PacketType2(Byte, Int32, Int32) | Initializes a new instance of the PacketType2 class.
Top
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2 Constructor

Grid Solutions Framework PacketType2 Constructor
Initializes a new instance of the PacketType2 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType2()
Public Sub New
new : unit -> PacketType2
GSF.Historian.Packets.PacketType2 = function();
public:
PacketType2()
See Also

Reference

PacketType2 Class
PacketType2 Overload
GSF.Historian.Packets Namespace


PacketType2 Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType2 Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType2 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType2(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType2
GSF.Historian.Packets.PacketType2 = function(buffer, startIndex, length);
public:
PacketType2(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType2.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType2 Class
PacketType2 Overload
GSF.Historian.Packets Namespace


PacketType2 Fields

Grid Solutions Framework PacketType2 Fields

The PacketType2 type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType2.
Top
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.FixedLength Field

Grid Solutions Framework PacketType2FixedLength Field
Specifies the number of bytes in the binary image of PacketType2.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Packets.PacketType2.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2 Methods

Grid Solutions Framework PacketType2 Methods

The PacketType2 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType2. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType2 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType2 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | PreProcess | Pre-processes PacketType2.
Protected method | Process | Processes PacketType2.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.ExtractTimeSeriesData Method

Grid Solutions Framework PacketType2ExtractTimeSeriesData Method
Extracts time-series data from PacketType2.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IEnumerable<IDataPoint> ExtractTimeSeriesData()
Public Overrides Function ExtractTimeSeriesData As IEnumerable(Of IDataPoint)
abstract ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
override ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
function ExtractTimeSeriesData();
public:
virtual IEnumerable<IDataPoint^>^ ExtractTimeSeriesData() override

Return Value

Type: IEnumerable IDataPoint
An IEnumerableT object of ArchiveDataPoints.

Implements

IPacketExtractTimeSeriesData
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.GenerateBinaryImage Method

Grid Solutions Framework PacketType2GenerateBinaryImage Method
Generates binary image of the PacketType2 and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.ParseBinaryImage Method

Grid Solutions Framework PacketType2ParseBinaryImage Method
Initializes PacketType2 from the specified buffer.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType2.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing PacketType2.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.PreProcess Method

Grid Solutions Framework PacketType2PreProcess Method
Pre-processes PacketType2.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> PreProcess()
Protected Overridable Function PreProcess As IEnumerable(Of Byte())
abstract PreProcess : unit -> IEnumerable<byte[]>
override PreProcess : unit -> IEnumerable<byte[]>
function PreProcess();
protected:
virtual IEnumerable<array<unsigned char>^>^ PreProcess()

Return Value

Type: IEnumerable Byte
A Byte array for "ACK".
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Process Method

Grid Solutions Framework PacketType2Process Method
Processes PacketType2.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> Process()
Protected Overridable Function Process As IEnumerable(Of Byte())
abstract Process : unit -> IEnumerable<byte[]>
override Process : unit -> IEnumerable<byte[]>
function Process();
protected:
virtual IEnumerable<array<unsigned char>^>^ Process()

Return Value

Type: IEnumerable Byte
A null reference.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2 Properties

Grid Solutions Framework PacketType2 Properties

The PacketType2 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType2. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | Day | Gets or sets the day-part of the time.
Public property | GmtOffset | Gets or sets the difference, in hours, between the local time and Greenwich Mean Time (Universal Coordinated Time).
Public property | HistorianID | Gets or sets the historian identifier of the time-series data.
Public property | Hour | Gets or sets the hour-part of the time.
Public property | Millisecond | Gets or sets the millisecond-part of the time.
Public property | Minute | Gets or sets the minute-part of the time.
Public property | Month | Gets or sets the month-part of the time.
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Quality | Gets or sets the Quality of the time-series data.
Public property | Second | Gets or sets the second-part of the time.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Public property | Value | Gets or sets the value of the time-series data.
Public property | Year | Gets or sets the year-part of the time.
Top
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.BinaryLength Property

Grid Solutions Framework PacketType2BinaryLength Property
Gets the length of the PacketType2.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Day Property

Grid Solutions Framework PacketType2Day Property
Gets or sets the day-part of the time.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Day { get; set; }
Public Property Day As Short
    Get
    Set
member Day : int16 with get, set

function get_Day();
function set_Day(value);
public:
property short Day {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 1 and 31.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.GmtOffset Property

Grid Solutions Framework PacketType2GmtOffset Property
Gets or sets the difference, in hours, between the local time and Greenwich Mean Time (Universal Coordinated Time).

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short GmtOffset { get; set; }
Public Property GmtOffset As Short
    Get
    Set
member GmtOffset : int16 with get, set

function get_GmtOffset();
function set_GmtOffset(value);
public:
property short GmtOffset {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.HistorianID Property

Grid Solutions Framework PacketType2HistorianID Property
Gets or sets the historian identifier of the time-series data.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HistorianID { get; set; }
Public Property HistorianID As Integer
    Get
    Set
member HistorianID : int with get, set

function get_HistorianID();
function set_HistorianID(value);
public:
property int HistorianID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not positive.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Hour Property

Grid Solutions Framework PacketType2Hour Property
Gets or sets the hour-part of the time.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Hour { get; set; }
Public Property Hour As Short
    Get
    Set
member Hour : int16 with get, set

function get_Hour();
function set_Hour(value);
public:
property short Hour {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 0 and 23.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Millisecond Property

Grid Solutions Framework PacketType2Millisecond Property
Gets or sets the millisecond-part of the time.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Millisecond { get; set; }
Public Property Millisecond As Short
    Get
    Set
member Millisecond : int16 with get, set

function get_Millisecond();
function set_Millisecond(value);
public:
property short Millisecond {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 0 and 999.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Minute Property

Grid Solutions Framework PacketType2Minute Property
Gets or sets the minute-part of the time.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Minute { get; set; }
Public Property Minute As Short
    Get
    Set
member Minute : int16 with get, set

function get_Minute();
function set_Minute(value);
public:
property short Minute {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 0 and 59.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Month Property

Grid Solutions Framework PacketType2Month Property
Gets or sets the month-part of the time.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Month { get; set; }
Public Property Month As Short
    Get
    Set
member Month : int16 with get, set

function get_Month();
function set_Month(value);
public:
property short Month {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 1 and 12.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Quality Property

Grid Solutions Framework PacketType2Quality Property
Gets or sets the Quality of the time-series data.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Quality Quality { get; set; }
Public Property Quality As Quality
    Get
    Set
member Quality : Quality with get, set

function get_Quality();
function set_Quality(value);
public:
property Quality Quality {
    Quality get ();
    void set (Quality value);
}

Property Value

Type: Quality
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Second Property

Grid Solutions Framework PacketType2Second Property
Gets or sets the second-part of the time.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Second { get; set; }
Public Property Second As Short
    Get
    Set
member Second : int16 with get, set

function get_Second();
function set_Second(value);
public:
property short Second {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 0 and 59.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Value Property

Grid Solutions Framework PacketType2Value Property
Gets or sets the value of the time-series data.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float Value { get; set; }
Public Property Value As Single
    Get
    Set
member Value : float32 with get, set

function get_Value();
function set_Value(value);
public:
property float Value {
    float get ();
    void set (float value);
}

Property Value

Type: Single
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType2.Year Property

Grid Solutions Framework PacketType2Year Property
Gets or sets the year-part of the time.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Year { get; set; }
Public Property Year As Short
    Get
    Set
member Year : int16 with get, set

function get_Year();
function set_Year(value);
public:
property short Year {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Exceptions
Exception | Condition
ArgumentException | The value being assigned is not between 1995 and 2063.
See Also

Reference

PacketType2 Class
GSF.Historian.Packets Namespace


PacketType3 Class

Grid Solutions Framework PacketType3 Class
Represents a packet to be used for requesting Summary for the RequestIDs.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsQueryPacketBase
GSF.Historian.PacketsPacketType3

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType3 : QueryPacketBase
Public Class PacketType3
    Inherits QueryPacketBase
type PacketType3 =
    class
        inherit QueryPacketBase
    end
GSF.Historian.Packets.PacketType3 = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType3',
    GSF.Historian.Packets.QueryPacketBase);
public ref class PacketType3 : public QueryPacketBase

The PacketType3 type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType3 | Initializes a new instance of the PacketType3 class.
Public method | PacketType3(Byte, Int32, Int32) | Initializes a new instance of the PacketType3 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Inherited from QueryPacketBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Inherited from QueryPacketBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Inherited from QueryPacketBase.)
Protected method | Process | Processes PacketType3.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Inherited from QueryPacketBase.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested. (Inherited from QueryPacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketType3 Constructor

Grid Solutions Framework PacketType3 Constructor
Overload List
 | Name | Description
Public method | PacketType3 | Initializes a new instance of the PacketType3 class.
Public method | PacketType3(Byte, Int32, Int32) | Initializes a new instance of the PacketType3 class.
Top
See Also

Reference

PacketType3 Class
GSF.Historian.Packets Namespace


PacketType3 Constructor

Grid Solutions Framework PacketType3 Constructor
Initializes a new instance of the PacketType3 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType3()
Public Sub New
new : unit -> PacketType3
GSF.Historian.Packets.PacketType3 = function();
public:
PacketType3()
See Also

Reference

PacketType3 Class
PacketType3 Overload
GSF.Historian.Packets Namespace


PacketType3 Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType3 Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType3 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType3(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType3
GSF.Historian.Packets.PacketType3 = function(buffer, startIndex, length);
public:
PacketType3(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType3.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType3 Class
PacketType3 Overload
GSF.Historian.Packets Namespace


PacketType3 Methods

Grid Solutions Framework PacketType3 Methods

The PacketType3 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Inherited from QueryPacketBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Inherited from QueryPacketBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Inherited from QueryPacketBase.)
Protected method | Process | Processes PacketType3.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType3 Class
GSF.Historian.Packets Namespace


PacketType3.Process Method

Grid Solutions Framework PacketType3Process Method
Processes PacketType3.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> Process()
Protected Overridable Function Process As IEnumerable(Of Byte())
abstract Process : unit -> IEnumerable<byte[]>
override Process : unit -> IEnumerable<byte[]>
function Process();
protected:
virtual IEnumerable<array<unsigned char>^>^ Process()

Return Value

Type: IEnumerable Byte
An IEnumerableT object containing the binary images of Summary for the RequestIDs.
See Also

Reference

PacketType3 Class
GSF.Historian.Packets Namespace


PacketType3 Properties

Grid Solutions Framework PacketType3 Properties

The PacketType3 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Inherited from QueryPacketBase.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested. (Inherited from QueryPacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

PacketType3 Class
GSF.Historian.Packets Namespace


PacketType4 Class

Grid Solutions Framework PacketType4 Class
Represents a packet to be used for requesting Summary for the RequestIDs only if the MetadataRecord has changed.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsQueryPacketBase
GSF.Historian.PacketsPacketType4

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType4 : QueryPacketBase
Public Class PacketType4
    Inherits QueryPacketBase
type PacketType4 =
    class
        inherit QueryPacketBase
    end
GSF.Historian.Packets.PacketType4 = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType4',
    GSF.Historian.Packets.QueryPacketBase);
public ref class PacketType4 : public QueryPacketBase

The PacketType4 type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType4 | Initializes a new instance of the PacketType4 class.
Public method | PacketType4(Byte, Int32, Int32) | Initializes a new instance of the PacketType4 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Inherited from QueryPacketBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Inherited from QueryPacketBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Inherited from QueryPacketBase.)
Protected method | Process | Processes PacketType4.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Inherited from QueryPacketBase.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested. (Inherited from QueryPacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketType4 Constructor

Grid Solutions Framework PacketType4 Constructor
Overload List
 | Name | Description
Public method | PacketType4 | Initializes a new instance of the PacketType4 class.
Public method | PacketType4(Byte, Int32, Int32) | Initializes a new instance of the PacketType4 class.
Top
See Also

Reference

PacketType4 Class
GSF.Historian.Packets Namespace


PacketType4 Constructor

Grid Solutions Framework PacketType4 Constructor
Initializes a new instance of the PacketType4 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType4()
Public Sub New
new : unit -> PacketType4
GSF.Historian.Packets.PacketType4 = function();
public:
PacketType4()
See Also

Reference

PacketType4 Class
PacketType4 Overload
GSF.Historian.Packets Namespace


PacketType4 Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType4 Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType4 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType4(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType4
GSF.Historian.Packets.PacketType4 = function(buffer, startIndex, length);
public:
PacketType4(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType4.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType4 Class
PacketType4 Overload
GSF.Historian.Packets Namespace


PacketType4 Methods

Grid Solutions Framework PacketType4 Methods

The PacketType4 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Inherited from QueryPacketBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Inherited from QueryPacketBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Inherited from QueryPacketBase.)
Protected method | Process | Processes PacketType4.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType4 Class
GSF.Historian.Packets Namespace


PacketType4.Process Method

Grid Solutions Framework PacketType4Process Method
Processes PacketType4.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IEnumerable<byte[]> Process()
Protected Overridable Function Process As IEnumerable(Of Byte())
abstract Process : unit -> IEnumerable<byte[]>
override Process : unit -> IEnumerable<byte[]>
function Process();
protected:
virtual IEnumerable<array<unsigned char>^>^ Process()

Return Value

Type: IEnumerable Byte
An IEnumerableT object containing the binary images of Summary for the RequestIDs.
See Also

Reference

PacketType4 Class
GSF.Historian.Packets Namespace


PacketType4 Properties

Grid Solutions Framework PacketType4 Properties

The PacketType4 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Inherited from QueryPacketBase.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested. (Inherited from QueryPacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

PacketType4 Class
GSF.Historian.Packets Namespace


PacketType5 Class

Grid Solutions Framework PacketType5 Class
Represents a packet that can be used to query the status of a historian.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsPacketType5

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PacketType5 : PacketBase
Public Class PacketType5
    Inherits PacketBase
type PacketType5 =
    class
        inherit PacketBase
    end
GSF.Historian.Packets.PacketType5 = function();

Type.createClass(
    'GSF.Historian.Packets.PacketType5',
    GSF.Historian.Packets.PacketBase);
public ref class PacketType5 : public PacketBase

The PacketType5 type exposes the following members.

Constructors
 | Name | Description
Public method | PacketType5 | Initializes a new instance of the PacketType5 class.
Public method | PacketType5(Byte, Int32, Int32) | Initializes a new instance of the PacketType5 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType5. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType5 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType5 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType5.
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType5. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


PacketType5 Constructor

Grid Solutions Framework PacketType5 Constructor
Overload List
 | Name | Description
Public method | PacketType5 | Initializes a new instance of the PacketType5 class.
Public method | PacketType5(Byte, Int32, Int32) | Initializes a new instance of the PacketType5 class.
Top
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5 Constructor

Grid Solutions Framework PacketType5 Constructor
Initializes a new instance of the PacketType5 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType5()
Public Sub New
new : unit -> PacketType5
GSF.Historian.Packets.PacketType5 = function();
public:
PacketType5()
See Also

Reference

PacketType5 Class
PacketType5 Overload
GSF.Historian.Packets Namespace


PacketType5 Constructor (Byte[], Int32, Int32)

Grid Solutions Framework PacketType5 Constructor (Byte, Int32, Int32)
Initializes a new instance of the PacketType5 class.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PacketType5(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> PacketType5
GSF.Historian.Packets.PacketType5 = function(buffer, startIndex, length);
public:
PacketType5(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType5.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.
See Also

Reference

PacketType5 Class
PacketType5 Overload
GSF.Historian.Packets Namespace


PacketType5 Fields

Grid Solutions Framework PacketType5 Fields

The PacketType5 type exposes the following members.

Fields
Name | Description
FixedLength | Specifies the number of bytes in the binary image of PacketType5.
Top
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5.FixedLength Field

Grid Solutions Framework PacketType5FixedLength Field
Specifies the number of bytes in the binary image of PacketType5.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Historian.Packets.PacketType5.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5 Methods

Grid Solutions Framework PacketType5 Methods

The PacketType5 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from PacketType5. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the PacketType5 and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes PacketType5 from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5.ExtractTimeSeriesData Method

Grid Solutions Framework PacketType5ExtractTimeSeriesData Method
Extracts time-series data from PacketType5.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IEnumerable<IDataPoint> ExtractTimeSeriesData()
Public Overrides Function ExtractTimeSeriesData As IEnumerable(Of IDataPoint)
abstract ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
override ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
function ExtractTimeSeriesData();
public:
virtual IEnumerable<IDataPoint^>^ ExtractTimeSeriesData() override

Return Value

Type: IEnumerable IDataPoint
A null reference.

Implements

IPacketExtractTimeSeriesData
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5.GenerateBinaryImage Method

Grid Solutions Framework PacketType5GenerateBinaryImage Method
Generates binary image of the PacketType5 and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5.ParseBinaryImage Method

Grid Solutions Framework PacketType5ParseBinaryImage Method
Initializes PacketType5 from the specified buffer.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing PacketType5.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing PacketType5.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5 Properties

Grid Solutions Framework PacketType5 Properties

The PacketType5 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the PacketType5. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


PacketType5.BinaryLength Property

Grid Solutions Framework PacketType5BinaryLength Property
Gets the length of the PacketType5.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

PacketType5 Class
GSF.Historian.Packets Namespace


QueryPacketBase Class

Grid Solutions Framework QueryPacketBase Class
Base class for a packet to be used for requesting information from a historian.
Inheritance Hierarchy
SystemObject
GSF.Historian.PacketsPacketBase
GSF.Historian.PacketsQueryPacketBase
GSF.Historian.PacketsPacketType11
GSF.Historian.PacketsPacketType3
GSF.Historian.PacketsPacketType4

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class QueryPacketBase : PacketBase
Public MustInherit Class QueryPacketBase
    Inherits PacketBase
[<AbstractClassAttribute>]
type QueryPacketBase =
    class
        inherit PacketBase
    end
GSF.Historian.Packets.QueryPacketBase = function();

Type.createClass(
    'GSF.Historian.Packets.QueryPacketBase',
    GSF.Historian.Packets.PacketBase);
public ref class QueryPacketBase abstract : public PacketBase

The QueryPacketBase type exposes the following members.

Constructors
 | Name | Description
Protected method | QueryPacketBase | Initializes a new instance of the query packet.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

GSF.Historian.Packets Namespace


QueryPacketBase Constructor

Grid Solutions Framework QueryPacketBase Constructor
Initializes a new instance of the query packet.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected QueryPacketBase(
    short packetID
)
Protected Sub New (
    packetID As Short
)
new :
        packetID : int16 -> QueryPacketBase
GSF.Historian.Packets.QueryPacketBase = function(packetID);
protected:
QueryPacketBase(
    short packetID
)

Parameters

packetID
Type: SystemInt16
Numeric identifier for the packet type.
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


QueryPacketBase Methods

Grid Solutions Framework QueryPacketBase Methods

The QueryPacketBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExtractTimeSeriesData | Extracts time-series data from the query packet type. (Overrides PacketBaseExtractTimeSeriesData.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes. (Overrides PacketBaseGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the query packet from the specified buffer. (Overrides PacketBaseParseBinaryImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


QueryPacketBase.ExtractTimeSeriesData Method

Grid Solutions Framework QueryPacketBaseExtractTimeSeriesData Method
Extracts time-series data from the query packet type.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IEnumerable<IDataPoint> ExtractTimeSeriesData()
Public Overrides Function ExtractTimeSeriesData As IEnumerable(Of IDataPoint)
abstract ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
override ExtractTimeSeriesData : unit -> IEnumerable<IDataPoint>
function ExtractTimeSeriesData();
public:
virtual IEnumerable<IDataPoint^>^ ExtractTimeSeriesData() override

Return Value

Type: IEnumerable IDataPoint
A null reference.

Implements

IPacketExtractTimeSeriesData
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


QueryPacketBase.GenerateBinaryImage Method

Grid Solutions Framework QueryPacketBaseGenerateBinaryImage Method
Generates binary image of the QueryPacketBase and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


QueryPacketBase.ParseBinaryImage Method

Grid Solutions Framework QueryPacketBaseParseBinaryImage Method
Initializes the query packet from the specified buffer.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to be used for initializing the query packet.
startIndex
Type: SystemInt32
0-based starting index of initialization data in the buffer.
length
Type: SystemInt32
Valid number of bytes in buffer from startIndex.

Return Value

Type: Int32
Number of bytes used from the buffer for initializing the query packet.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


QueryPacketBase Properties

Grid Solutions Framework QueryPacketBase Properties

The QueryPacketBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from PacketBase.)
Public property | Archive | Gets or sets the current IArchive. (Inherited from PacketBase.)
Public property | BinaryLength | Gets the length of the QueryPacketBase. (Overrides PacketBaseBinaryLength.)
Public property | CommonHeader | Gets or sets the PacketCommonHeader for the packet. (Inherited from PacketBase.)
Public property | PreProcessHandler | Gets or sets the Delegate that pre-processes the packet. (Inherited from PacketBase.)
Public property | ProcessHandler | Gets or sets the Delegate that processes the packet. (Inherited from PacketBase.)
Public property | RequestIDs | Gets a list of historian identifiers whose information is being requested.
Public property | Source | Gets or sets the data source identifier of the frame image. (Inherited from PacketBase.)
Public property | TypeID | Gets or sets the numeric identifier for the packet type. (Inherited from PacketBase.)
Top
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


QueryPacketBase.BinaryLength Property

Grid Solutions Framework QueryPacketBaseBinaryLength Property
Gets the length of the QueryPacketBase.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


QueryPacketBase.RequestIDs Property

Grid Solutions Framework QueryPacketBaseRequestIDs Property
Gets a list of historian identifiers whose information is being requested.

Namespace: GSF.Historian.Packets
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<int> RequestIDs { get; }
Public ReadOnly Property RequestIDs As IList(Of Integer)
    Get
member RequestIDs : IList<int> with get

function get_RequestIDs();

public:
property IList<int>^ RequestIDs {
    IList<int>^ get ();
}

Property Value

Type: IList Int32
Remarks
A singe entry with ID of -1 can be used to request information for all defined historian identifiers.
See Also

Reference

QueryPacketBase Class
GSF.Historian.Packets Namespace


GSF.Historian.Replication Namespace

Grid Solutions Framework GSF.Historian.Replication Namespace
Contains classes and interfaces that allow for the replication of the time-series data archive.
Classes
 | Class | Description
Public class | ReplicationProviderBase | Base class for a provider of replication mechanism for the IArchive.
Public class | ReplicationProviders | A class that loads all of the replication providers.
Interfaces
 | Interface | Description
Public interface | IReplicationProvider | Defines a provider of replication mechanism for the IArchive.


IReplicationProvider Interface

Grid Solutions Framework IReplicationProvider Interface
Defines a provider of replication mechanism for the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IReplicationProvider : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
Public Interface IReplicationProvider
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
type IReplicationProvider =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.Replication.IReplicationProvider = function();
GSF.Historian.Replication.IReplicationProvider.createInterface('GSF.Historian.Replication.IReplicationProvider');
public interface class IReplicationProvider : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The IReplicationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Replicate | Replicates the IArchive.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | ArchiveLocation | Gets or sets the primary location of the IArchive.
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | ReplicaLocation | Gets or sets the mirrored location of the IArchive.
Public property | ReplicationInterval | Gets or sets the interval in milliseconds at which the IArchive is to be replicated.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ReplicationComplete | Occurs when the process of replicating the IArchive is complete.
Public event | ReplicationException | Occurs when an Exception is encountered during the replication process of IArchive.
Public event | ReplicationProgress | Occurs when the IArchive is being replicated.
Public event | ReplicationStart | Occurs when the process of replicating the IArchive is started.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.Historian.Replication Namespace


IReplicationProvider Methods

Grid Solutions Framework IReplicationProvider Methods

The IReplicationProvider type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Replicate | Replicates the IArchive.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.Replicate Method

Grid Solutions Framework IReplicationProviderReplicate Method
Replicates the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Replicate()
Function Replicate As Boolean
abstract Replicate : unit -> bool

function Replicate();
bool Replicate()

Return Value

Type: Boolean
true if the replication is successful; otherwise false.
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider Properties

Grid Solutions Framework IReplicationProvider Properties

The IReplicationProvider type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveLocation | Gets or sets the primary location of the IArchive.
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | ReplicaLocation | Gets or sets the mirrored location of the IArchive.
Public property | ReplicationInterval | Gets or sets the interval in milliseconds at which the IArchive is to be replicated.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.ArchiveLocation Property

Grid Solutions Framework IReplicationProviderArchiveLocation Property
Gets or sets the primary location of the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ArchiveLocation { get; set; }
Property ArchiveLocation As String
    Get
    Set
abstract ArchiveLocation : string with get, set

function get_ArchiveLocation();
function set_ArchiveLocation(value);
property String^ ArchiveLocation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.ReplicaLocation Property

Grid Solutions Framework IReplicationProviderReplicaLocation Property
Gets or sets the mirrored location of the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ReplicaLocation { get; set; }
Property ReplicaLocation As String
    Get
    Set
abstract ReplicaLocation : string with get, set

function get_ReplicaLocation();
function set_ReplicaLocation(value);
property String^ ReplicaLocation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.ReplicationInterval Property

Grid Solutions Framework IReplicationProviderReplicationInterval Property
Gets or sets the interval in milliseconds at which the IArchive is to be replicated.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int ReplicationInterval { get; set; }
Property ReplicationInterval As Integer
    Get
    Set
abstract ReplicationInterval : int with get, set

function get_ReplicationInterval();
function set_ReplicationInterval(value);
property int ReplicationInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider Events

Grid Solutions Framework IReplicationProvider Events

The IReplicationProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ReplicationComplete | Occurs when the process of replicating the IArchive is complete.
Public event | ReplicationException | Occurs when an Exception is encountered during the replication process of IArchive.
Public event | ReplicationProgress | Occurs when the IArchive is being replicated.
Public event | ReplicationStart | Occurs when the process of replicating the IArchive is started.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.ReplicationComplete Event

Grid Solutions Framework IReplicationProviderReplicationComplete Event
Occurs when the process of replicating the IArchive is complete.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ReplicationComplete
Event ReplicationComplete As EventHandler
abstract ReplicationComplete : IEvent<EventHandler,
    EventArgs>

function add_ReplicationComplete(value);
function remove_ReplicationComplete(value);
 event EventHandler^ ReplicationComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.ReplicationException Event

Grid Solutions Framework IReplicationProviderReplicationException Event
Occurs when an Exception is encountered during the replication process of IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ReplicationException
Event ReplicationException As EventHandler(Of EventArgs(Of Exception))
abstract ReplicationException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ReplicationException(value);
function remove_ReplicationException(value);
 event EventHandler<EventArgs<Exception^>^>^ ReplicationException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.ReplicationProgress Event

Grid Solutions Framework IReplicationProviderReplicationProgress Event
Occurs when the IArchive is being replicated.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<ProcessProgress<int>>> ReplicationProgress
Event ReplicationProgress As EventHandler(Of EventArgs(Of ProcessProgress(Of Integer)))
abstract ReplicationProgress : IEvent<EventHandler<EventArgs<ProcessProgress<int>>>,
    EventArgs<ProcessProgress<int>>>

function add_ReplicationProgress(value);
function remove_ReplicationProgress(value);
 event EventHandler<EventArgs<ProcessProgress<int>^>^>^ ReplicationProgress {
    void add (EventHandler<EventArgs<ProcessProgress<int>^>^>^ value);
    void remove (EventHandler<EventArgs<ProcessProgress<int>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ProcessProgress Int32
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


IReplicationProvider.ReplicationStart Event

Grid Solutions Framework IReplicationProviderReplicationStart Event
Occurs when the process of replicating the IArchive is started.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ReplicationStart
Event ReplicationStart As EventHandler
abstract ReplicationStart : IEvent<EventHandler,
    EventArgs>

function add_ReplicationStart(value);
function remove_ReplicationStart(value);
 event EventHandler^ ReplicationStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IReplicationProvider Interface
GSF.Historian.Replication Namespace


ReplicationProviderBase Class

Grid Solutions Framework ReplicationProviderBase Class
Base class for a provider of replication mechanism for the IArchive.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.Historian.ReplicationReplicationProviderBase

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ReplicationProviderBase : Adapter,
    IReplicationProvider, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
Public MustInherit Class ReplicationProviderBase
    Inherits Adapter
    Implements IReplicationProvider, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
[<AbstractClassAttribute>]
type ReplicationProviderBase =
    class
        inherit Adapter
        interface IReplicationProvider
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Historian.Replication.ReplicationProviderBase = function();

Type.createClass(
    'GSF.Historian.Replication.ReplicationProviderBase',
    GSF.Adapters.Adapter,
    GSF.Historian.Replication.IReplicationProvider,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
public ref class ReplicationProviderBase abstract : public Adapter,
    IReplicationProvider, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings

The ReplicationProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ReplicationProviderBase | Initializes a new instance of the replication provider.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the replication provider and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the replication provider. (Overrides AdapterInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved replication provider settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnReplicationComplete | Raises the ReplicationComplete event.
Protected method | OnReplicationException | Raises the ReplicationException event.
Protected method | OnReplicationProgress | Raises the ReplicationProgress event.
Protected method | OnReplicationStart | Raises the ReplicationStart event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Replicate | Replicates the IArchive.
Protected method | ReplicateArchive | When overridden in a derived class, replicates the IArchive.
Public method | SaveSettings | Saves replication provider settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ArchiveLocation | Gets or sets the primary location of the IArchive.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | ReplicaLocation | Gets or sets the mirrored location of the IArchive.
Public property | ReplicationInterval | Gets or sets the interval in minutes at which the IArchive is to be replicated.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ReplicationComplete | Occurs when the process of replicating the IArchive is complete.
Public event | ReplicationException | Occurs when an Exception is encountered during the replication process of IArchive.
Public event | ReplicationProgress | Occurs when the IArchive is being replicated.
Public event | ReplicationStart | Occurs when the process of replicating the IArchive is started.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.Historian.Replication Namespace


ReplicationProviderBase Constructor

Grid Solutions Framework ReplicationProviderBase Constructor
Initializes a new instance of the replication provider.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ReplicationProviderBase()
Protected Sub New
new : unit -> ReplicationProviderBase
GSF.Historian.Replication.ReplicationProviderBase = function();
protected:
ReplicationProviderBase()
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase Methods

Grid Solutions Framework ReplicationProviderBase Methods

The ReplicationProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the replication provider and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the replication provider. (Overrides AdapterInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved replication provider settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnReplicationComplete | Raises the ReplicationComplete event.
Protected method | OnReplicationException | Raises the ReplicationException event.
Protected method | OnReplicationProgress | Raises the ReplicationProgress event.
Protected method | OnReplicationStart | Raises the ReplicationStart event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Replicate | Replicates the IArchive.
Protected method | ReplicateArchive | When overridden in a derived class, replicates the IArchive.
Public method | SaveSettings | Saves replication provider settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.Dispose Method

Grid Solutions Framework ReplicationProviderBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the replication provider and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Top
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.Dispose Method (Boolean)

Grid Solutions Framework ReplicationProviderBaseDispose Method (Boolean)
Releases the unmanaged resources used by the replication provider and optionally releases the managed resources.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ReplicationProviderBase Class
Dispose Overload
GSF.Historian.Replication Namespace


ReplicationProviderBase.Initialize Method

Grid Solutions Framework ReplicationProviderBaseInitialize Method
Initializes the replication provider.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.LoadSettings Method

Grid Solutions Framework ReplicationProviderBaseLoadSettings Method
Loads saved replication provider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.OnReplicationComplete Method

Grid Solutions Framework ReplicationProviderBaseOnReplicationComplete Method
Raises the ReplicationComplete event.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReplicationComplete()
Protected Overridable Sub OnReplicationComplete
abstract OnReplicationComplete : unit -> unit
override OnReplicationComplete : unit -> unit
function OnReplicationComplete();
protected:
virtual void OnReplicationComplete()
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.OnReplicationException Method

Grid Solutions Framework ReplicationProviderBaseOnReplicationException Method
Raises the ReplicationException event.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReplicationException(
    Exception ex
)
Protected Overridable Sub OnReplicationException (
    ex As Exception
)
abstract OnReplicationException :
        ex : Exception -> unit
override OnReplicationException :
        ex : Exception -> unit
function OnReplicationException(ex);
protected:
virtual void OnReplicationException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to ReplicationException event.
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.OnReplicationProgress Method

Grid Solutions Framework ReplicationProviderBaseOnReplicationProgress Method
Raises the ReplicationProgress event.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReplicationProgress(
    ProcessProgress<int> replicationProgress
)
Protected Overridable Sub OnReplicationProgress (
    replicationProgress As ProcessProgress(Of Integer)
)
abstract OnReplicationProgress :
        replicationProgress : ProcessProgress<int> -> unit
override OnReplicationProgress :
        replicationProgress : ProcessProgress<int> -> unit
function OnReplicationProgress(replicationProgress);
protected:
virtual void OnReplicationProgress(
    ProcessProgress<int>^ replicationProgress
)

Parameters

replicationProgress
Type: GSFProcessProgress Int32
ProcessProgressTUnit to send to ReplicationProgress event.
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.OnReplicationStart Method

Grid Solutions Framework ReplicationProviderBaseOnReplicationStart Method
Raises the ReplicationStart event.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReplicationStart()
Protected Overridable Sub OnReplicationStart
abstract OnReplicationStart : unit -> unit
override OnReplicationStart : unit -> unit
function OnReplicationStart();
protected:
virtual void OnReplicationStart()
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.Replicate Method

Grid Solutions Framework ReplicationProviderBaseReplicate Method
Replicates the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Replicate()
Public Function Replicate As Boolean
abstract Replicate : unit -> bool
override Replicate : unit -> bool
function Replicate();
public:
virtual bool Replicate() sealed

Return Value

Type: Boolean
true if the replication is successful; otherwise false.

Implements

IReplicationProviderReplicate
Exceptions
Exception | Condition
ArgumentNullException | ArchiveLocation or ReplicaLocation is null or empty string.
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ReplicateArchive Method

Grid Solutions Framework ReplicationProviderBaseReplicateArchive Method
When overridden in a derived class, replicates the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void ReplicateArchive()
Protected MustOverride Sub ReplicateArchive
abstract ReplicateArchive : unit -> unit

function ReplicateArchive();
protected:
virtual void ReplicateArchive() abstract
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.SaveSettings Method

Grid Solutions Framework ReplicationProviderBaseSaveSettings Method
Saves replication provider settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase Properties

Grid Solutions Framework ReplicationProviderBase Properties

The ReplicationProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveLocation | Gets or sets the primary location of the IArchive.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | ReplicaLocation | Gets or sets the mirrored location of the IArchive.
Public property | ReplicationInterval | Gets or sets the interval in minutes at which the IArchive is to be replicated.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ArchiveLocation Property

Grid Solutions Framework ReplicationProviderBaseArchiveLocation Property
Gets or sets the primary location of the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ArchiveLocation { get; set; }
Public Property ArchiveLocation As String
    Get
    Set
abstract ArchiveLocation : string with get, set
override ArchiveLocation : string with get, set
function get_ArchiveLocation();
function set_ArchiveLocation(value);
public:
virtual property String^ ArchiveLocation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReplicationProviderArchiveLocation
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ReplicaLocation Property

Grid Solutions Framework ReplicationProviderBaseReplicaLocation Property
Gets or sets the mirrored location of the IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ReplicaLocation { get; set; }
Public Property ReplicaLocation As String
    Get
    Set
abstract ReplicaLocation : string with get, set
override ReplicaLocation : string with get, set
function get_ReplicaLocation();
function set_ReplicaLocation(value);
public:
virtual property String^ ReplicaLocation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReplicationProviderReplicaLocation
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ReplicationInterval Property

Grid Solutions Framework ReplicationProviderBaseReplicationInterval Property
Gets or sets the interval in minutes at which the IArchive is to be replicated.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ReplicationInterval { get; set; }
Public Property ReplicationInterval As Integer
    Get
    Set
abstract ReplicationInterval : int with get, set
override ReplicationInterval : int with get, set
function get_ReplicationInterval();
function set_ReplicationInterval(value);
public:
virtual property int ReplicationInterval {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IReplicationProviderReplicationInterval
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase Events

Grid Solutions Framework ReplicationProviderBase Events

The ReplicationProviderBase type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ReplicationComplete | Occurs when the process of replicating the IArchive is complete.
Public event | ReplicationException | Occurs when an Exception is encountered during the replication process of IArchive.
Public event | ReplicationProgress | Occurs when the IArchive is being replicated.
Public event | ReplicationStart | Occurs when the process of replicating the IArchive is started.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ReplicationComplete Event

Grid Solutions Framework ReplicationProviderBaseReplicationComplete Event
Occurs when the process of replicating the IArchive is complete.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ReplicationComplete
Public Event ReplicationComplete As EventHandler
abstract ReplicationComplete : IEvent<EventHandler,
    EventArgs>
override ReplicationComplete : IEvent<EventHandler,
    EventArgs>
function add_ReplicationComplete(value);
function remove_ReplicationComplete(value);
public:
virtual  event EventHandler^ ReplicationComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IReplicationProviderReplicationComplete
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ReplicationException Event

Grid Solutions Framework ReplicationProviderBaseReplicationException Event
Occurs when an Exception is encountered during the replication process of IArchive.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ReplicationException
Public Event ReplicationException As EventHandler(Of EventArgs(Of Exception))
abstract ReplicationException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ReplicationException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ReplicationException(value);
function remove_ReplicationException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ReplicationException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IReplicationProviderReplicationException
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ReplicationProgress Event

Grid Solutions Framework ReplicationProviderBaseReplicationProgress Event
Occurs when the IArchive is being replicated.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ProcessProgress<int>>> ReplicationProgress
Public Event ReplicationProgress As EventHandler(Of EventArgs(Of ProcessProgress(Of Integer)))
abstract ReplicationProgress : IEvent<EventHandler<EventArgs<ProcessProgress<int>>>,
    EventArgs<ProcessProgress<int>>>
override ReplicationProgress : IEvent<EventHandler<EventArgs<ProcessProgress<int>>>,
    EventArgs<ProcessProgress<int>>>
function add_ReplicationProgress(value);
function remove_ReplicationProgress(value);
public:
virtual  event EventHandler<EventArgs<ProcessProgress<int>^>^>^ ReplicationProgress {
    void add (EventHandler<EventArgs<ProcessProgress<int>^>^>^ value);
    void remove (EventHandler<EventArgs<ProcessProgress<int>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ProcessProgress Int32

Implements

IReplicationProviderReplicationProgress
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviderBase.ReplicationStart Event

Grid Solutions Framework ReplicationProviderBaseReplicationStart Event
Occurs when the process of replicating the IArchive is started.

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ReplicationStart
Public Event ReplicationStart As EventHandler
abstract ReplicationStart : IEvent<EventHandler,
    EventArgs>
override ReplicationStart : IEvent<EventHandler,
    EventArgs>
function add_ReplicationStart(value);
function remove_ReplicationStart(value);
public:
virtual  event EventHandler^ ReplicationStart {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IReplicationProviderReplicationStart
See Also

Reference

ReplicationProviderBase Class
GSF.Historian.Replication Namespace


ReplicationProviders Class

Grid Solutions Framework ReplicationProviders Class
A class that loads all of the replication providers.
Inheritance Hierarchy
SystemObject
GSF.AdaptersAdapterLoader IReplicationProvider
GSF.Historian.ReplicationReplicationProviders

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ReplicationProviders : AdapterLoader<IReplicationProvider>
Public Class ReplicationProviders
    Inherits AdapterLoader(Of IReplicationProvider)
type ReplicationProviders =
    class
        inherit AdapterLoader<IReplicationProvider>
    end
GSF.Historian.Replication.ReplicationProviders = function();

Type.createClass(
    'GSF.Historian.Replication.ReplicationProviders',
    GSF.Adapters.AdapterLoader`1);
public ref class ReplicationProviders : public AdapterLoader<IReplicationProvider^>

The ReplicationProviders type exposes the following members.

Constructors
 | Name | Description
Public method | ReplicationProviders | Initializes a new instance of the ReplicationProviders class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data. (Inherited from AdapterLoaderT.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

GSF.Historian.Replication Namespace


ReplicationProviders Constructor

Grid Solutions Framework ReplicationProviders Constructor
Initializes a new instance of the ReplicationProviders class

Namespace: GSF.Historian.Replication
Assembly: GSF.Historian (in GSF.Historian.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ReplicationProviders()
Public Sub New
new : unit -> ReplicationProviders
GSF.Historian.Replication.ReplicationProviders = function();
public:
ReplicationProviders()
See Also

Reference

ReplicationProviders Class
GSF.Historian.Replication Namespace


ReplicationProviders Methods

Grid Solutions Framework ReplicationProviders Methods

The ReplicationProviders type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data. (Inherited from AdapterLoaderT.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ReplicationProviders Class
GSF.Historian.Replication Namespace


ReplicationProviders Properties

Grid Solutions Framework ReplicationProviders Properties

The ReplicationProviders type exposes the following members.

Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

ReplicationProviders Class
GSF.Historian.Replication Namespace


ReplicationProviders Events

Grid Solutions Framework ReplicationProviders Events

The ReplicationProviders type exposes the following members.

Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

ReplicationProviders Class
GSF.Historian.Replication Namespace


GSF.Identity Namespace

Grid Solutions Framework GSF.Identity Namespace
Contains classes used to simplify and standardize access to information about a domain user retrieved from Active Directory.
Classes
 | Class | Description
Public class | UserAccountControl | Provides facilities for enabling and disabling User Account Control (UAC), determining elevation and virtualization status, and launching a process under elevated credentials.
 | UserInfo | Represents information about a local user or a domain user (e.g., from Active Directory).


UserAccountControl Class

Grid Solutions Framework UserAccountControl Class
Provides facilities for enabling and disabling User Account Control (UAC), determining elevation and virtualization status, and launching a process under elevated credentials.
Inheritance Hierarchy
SystemObject
GSF.IdentityUserAccountControl

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class UserAccountControl
Public NotInheritable Class UserAccountControl
[<AbstractClassAttribute>]
[<SealedAttribute>]
type UserAccountControl =  class end
GSF.Identity.UserAccountControl = function();

Type.createClass(
    'GSF.Identity.UserAccountControl');
public ref class UserAccountControl abstract sealed

The UserAccountControl type exposes the following members.

Methods
Name | Description
CreateProcessAsAdmin | Creates a process under the elevated token, regardless of UAC settings or the manifest associated with that process.
CreateProcessAsStandardUser | Creates a process under the standard user if the current process is elevated. The identity of the standard user is determined by retrieving the user token of the currently running Explorer (shell) process.
DisableUac | Disables User Account Control by changing the LUA registry key. The changes do not have effect until the system is restarted.
DisableUacAndRestartWindows | Disables User Account Control and restarts the system.
EnableUac | Enables User Account Control by changing the LUA registry key. The changes do not have effect until the system is restarted.
EnableUacAndRestartWindows | Enables User Account Control and restarts the system.
Top
Properties
Name | Description
IsCurrentProcessElevated | Returns true if the current process is elevated, i.e. if the process went through an elevation consent phase.
IsCurrentProcessVirtualized | Returns true if the current process is using UAC virtualization.
IsUacEnabled | Returns true if User Account Control (UAC) is enabled on this machine.
IsUserAdmin | Returns true if the current user has administrator privileges.
Top
See Also

Reference

GSF.Identity Namespace


UserAccountControl Methods

Grid Solutions Framework UserAccountControl Methods

The UserAccountControl type exposes the following members.

Methods
Name | Description
CreateProcessAsAdmin | Creates a process under the elevated token, regardless of UAC settings or the manifest associated with that process.
CreateProcessAsStandardUser | Creates a process under the standard user if the current process is elevated. The identity of the standard user is determined by retrieving the user token of the currently running Explorer (shell) process.
DisableUac | Disables User Account Control by changing the LUA registry key. The changes do not have effect until the system is restarted.
DisableUacAndRestartWindows | Disables User Account Control and restarts the system.
EnableUac | Enables User Account Control by changing the LUA registry key. The changes do not have effect until the system is restarted.
EnableUacAndRestartWindows | Enables User Account Control and restarts the system.
Top
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.CreateProcessAsAdmin Method

Grid Solutions Framework UserAccountControlCreateProcessAsAdmin Method
Creates a process under the elevated token, regardless of UAC settings or the manifest associated with that process.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Process CreateProcessAsAdmin(
    string fileName,
    string arguments = ""
)
Public Shared Function CreateProcessAsAdmin (
    fileName As String,
    Optional arguments As String = ""
) As Process
static member CreateProcessAsAdmin :
        fileName : string *
        ?arguments : string
(* Defaults:
        let _arguments = defaultArg arguments ""
*)
-> Process

GSF.Identity.UserAccountControl.CreateProcessAsAdmin = function(fileName, arguments);
public:
static Process^ CreateProcessAsAdmin(
    String^ fileName,
    String^ arguments = L""
)

Parameters

fileName
Type: SystemString
The path to the executable file.
arguments (Optional)
Type: SystemString
The command-line arguments to pass to the process.

Return Value

Type: Process
A Process object representing the newly created process.
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.CreateProcessAsStandardUser Method

Grid Solutions Framework UserAccountControlCreateProcessAsStandardUser Method
Creates a process under the standard user if the current process is elevated. The identity of the standard user is determined by retrieving the user token of the currently running Explorer (shell) process.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Process CreateProcessAsStandardUser(
    string fileName,
    string arguments = ""
)
Public Shared Function CreateProcessAsStandardUser (
    fileName As String,
    Optional arguments As String = ""
) As Process
static member CreateProcessAsStandardUser :
        fileName : string *
        ?arguments : string
(* Defaults:
        let _arguments = defaultArg arguments ""
*)
-> Process

GSF.Identity.UserAccountControl.CreateProcessAsStandardUser = function(fileName, arguments);
public:
static Process^ CreateProcessAsStandardUser(
    String^ fileName,
    String^ arguments = L""
)

Parameters

fileName
Type: SystemString
The path to the executable file.
arguments (Optional)
Type: SystemString
The command-line arguments to pass to the process.

Return Value

Type: Process
A Process object representing the newly created process.
Remarks

This method requires administrative privileges. An exception will be thrown if the current user is not elevated.

This is an especially useful function if you are trying to shell an application from an installation program. With UAC enabled, an application spawned from a setup program will be the "NT AUTHORITY\SYSTEM" user - not the local user that executed the installer; this can wreak havoc if the spawned application needs to authenticate the local user.

See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.DisableUac Method

Grid Solutions Framework UserAccountControlDisableUac Method
Disables User Account Control by changing the LUA registry key. The changes do not have effect until the system is restarted.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DisableUac()
Public Shared Sub DisableUac
static member DisableUac : unit -> unit

GSF.Identity.UserAccountControl.DisableUac = function();
public:
static void DisableUac()
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.DisableUacAndRestartWindows Method

Grid Solutions Framework UserAccountControlDisableUacAndRestartWindows Method
Disables User Account Control and restarts the system.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DisableUacAndRestartWindows()
Public Shared Sub DisableUacAndRestartWindows
static member DisableUacAndRestartWindows : unit -> unit

GSF.Identity.UserAccountControl.DisableUacAndRestartWindows = function();
public:
static void DisableUacAndRestartWindows()
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.EnableUac Method

Grid Solutions Framework UserAccountControlEnableUac Method
Enables User Account Control by changing the LUA registry key. The changes do not have effect until the system is restarted.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EnableUac()
Public Shared Sub EnableUac
static member EnableUac : unit -> unit

GSF.Identity.UserAccountControl.EnableUac = function();
public:
static void EnableUac()
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.EnableUacAndRestartWindows Method

Grid Solutions Framework UserAccountControlEnableUacAndRestartWindows Method
Enables User Account Control and restarts the system.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EnableUacAndRestartWindows()
Public Shared Sub EnableUacAndRestartWindows
static member EnableUacAndRestartWindows : unit -> unit

GSF.Identity.UserAccountControl.EnableUacAndRestartWindows = function();
public:
static void EnableUacAndRestartWindows()
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl Properties

Grid Solutions Framework UserAccountControl Properties

The UserAccountControl type exposes the following members.

Properties
Name | Description
IsCurrentProcessElevated | Returns true if the current process is elevated, i.e. if the process went through an elevation consent phase.
IsCurrentProcessVirtualized | Returns true if the current process is using UAC virtualization.
IsUacEnabled | Returns true if User Account Control (UAC) is enabled on this machine.
IsUserAdmin | Returns true if the current user has administrator privileges.
Top
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.IsCurrentProcessElevated Property

Grid Solutions Framework UserAccountControlIsCurrentProcessElevated Property
Returns true if the current process is elevated, i.e. if the process went through an elevation consent phase.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsCurrentProcessElevated { get; }
Public Shared ReadOnly Property IsCurrentProcessElevated As Boolean
    Get
static member IsCurrentProcessElevated : bool with get

GSF.Identity.UserAccountControl.get_IsCurrentProcessElevated = function();

public:
static property bool IsCurrentProcessElevated {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This property will return false if UAC is disabled and the process is running as admin. It only determines whether the process went through the elevation procedure.
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.IsCurrentProcessVirtualized Property

Grid Solutions Framework UserAccountControlIsCurrentProcessVirtualized Property
Returns true if the current process is using UAC virtualization.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsCurrentProcessVirtualized { get; }
Public Shared ReadOnly Property IsCurrentProcessVirtualized As Boolean
    Get
static member IsCurrentProcessVirtualized : bool with get

GSF.Identity.UserAccountControl.get_IsCurrentProcessVirtualized = function();

public:
static property bool IsCurrentProcessVirtualized {
    bool get ();
}

Property Value

Type: Boolean
Remarks
Under UAC virtualization, file system and registry accesses to specific locations performed by an application are redirected to provide backwards compatibility. 64-bit applications or applications that have an associated manifest do not enjoy UAC virtualization because they are assumed to be compatible with Vista and UAC.
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.IsUacEnabled Property

Grid Solutions Framework UserAccountControlIsUacEnabled Property
Returns true if User Account Control (UAC) is enabled on this machine.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsUacEnabled { get; }
Public Shared ReadOnly Property IsUacEnabled As Boolean
    Get
static member IsUacEnabled : bool with get

GSF.Identity.UserAccountControl.get_IsUacEnabled = function();

public:
static property bool IsUacEnabled {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This value is obtained by checking the LUA registry key. It is possible that the user has not restarted the machine after enabling/disabling UAC. In that case, the value of the registry key does not reflect the true state of affairs.
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserAccountControl.IsUserAdmin Property

Grid Solutions Framework UserAccountControlIsUserAdmin Property
Returns true if the current user has administrator privileges.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsUserAdmin { get; }
Public Shared ReadOnly Property IsUserAdmin As Boolean
    Get
static member IsUserAdmin : bool with get

GSF.Identity.UserAccountControl.get_IsUserAdmin = function();

public:
static property bool IsUserAdmin {
    bool get ();
}

Property Value

Type: Boolean
Remarks
If UAC is on, then this property will return true even if the current process is not running elevated. If UAC is off, then this property will return true if the user is part of the built-in Administrators group.
See Also

Reference

UserAccountControl Class
GSF.Identity Namespace


UserInfo Class

Grid Solutions Framework UserInfo Class
Represents information about a local user or a domain user (e.g., from Active Directory).
Inheritance Hierarchy
SystemObject
GSF.IdentityUserInfo

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class UserInfo : ISupportLifecycle,
    IDisposable, IPersistSettings
Public NotInheritable Class UserInfo
    Implements ISupportLifecycle, IDisposable, IPersistSettings
[<SealedAttribute>]
type UserInfo =
    class
        interface ISupportLifecycle
        interface IDisposable
        interface IPersistSettings
    end
GSF.Identity.UserInfo = function();

Type.createClass(
    'GSF.Identity.UserInfo',
    null,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.Configuration.IPersistSettings);
public ref class UserInfo sealed : ISupportLifecycle,
    IDisposable, IPersistSettings

The UserInfo type exposes the following members.

Constructors
 | Name | Description
Public method | UserInfo(String) | Initializes a new instance of the UserInfo class.
Public method | UserInfo(String, String) | Initializes a new instance of the UserInfo class.
Top
Methods
 | Name | Description
 | AddUserToLocalGroup | Adds an existing user to the specified local groupName.
 | AuthenticateUser(String, String, String) | Authenticates the specified user credentials.
 | AuthenticateUser(String, String, String, String) | Authenticates the specified user credentials.
Public method | ChangePassword | Attempts to change the user's password.
 | CreateLocalGroup | Creates a new local group if it does not exist already.
 | CreateLocalUser | Creates a new local user if it does not exist already.
 | DefinePrivilegedAccount | Defines the credentials of a privileged domain account that can be used for impersonation prior to the retrieval of user information from the Active Directory.
Public method | Dispose | Releases all the resources used by the UserInfo object.
 | EndImpersonation | Ends the impersonation of the specified user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetBuiltInLocalGroups | Returns a sorted list of the common built-in local groups. On Windows these groups have a domain name of BUILTIN.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalGroupUserList | Gets a list of users that exist in the specified local groupName.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserPropertyValue | Returns the value for specified active directory property.
 | GroupNameToSID | Converts the given group name to the SID corresponding to that name.
Public method | ImpersonatePrivilegedAccount | Impersonates the defined privileged domain account.
 | ImpersonateUser | Impersonates the specified user.
Public method | Initialize | Initializes the UserInfo object.
 | IsGroupSID | Determines whether the given security identifier identifies a group.
 | IsLocalDomain | Determines if specified domain is the local domain (i.e., local machine).
 | IsUserSID | Determines whether the given security identifier identifies a user account.
Public method | LoadSettings | Loads saved settings for the UserInfo object from the config file if the PersistSettings property is set to true.
 | LocalGroupExists | Determines if local group exists.
 | LocalUserExists | Determines if local user exists.
 | RemoveLocalGroup | Removes local group if it exists.
 | RemoveLocalUser | Removes local user if it exists.
 | RemoveUserFromLocalGroup | Removes an existing user from the specified local groupName.
Public method | SaveSettings | Saves settings for the UserInfo object to the config file if the PersistSettings property is set to true.
 | SetLocalUserPassword | Sets local user's password.
 | SIDToAccountName | Converts the given SID to the corresponding account name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UserIsInLocalGroup | Determines if user is in the specified local groupName.
 | UserNameToSID | Converts the given user name to the SID corresponding to that name.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Public property | AccountCreationDate | Gets the DateTime when the account was created.
Public property | AccountIsDisabled | Gets flag that determines if account is disabled for this user.
Public property | AccountIsLockedOut | Gets flag that determines if account is locked-out for this user.
Public property | City | Gets the City where the user works.
Public property | Company | Gets the Company of the user.
 | CurrentUserID | Gets the ID name of the current user.
 | CurrentUserInfo | Gets the UserInfo object for the CurrentUserID.
Public property | Department | Gets the Department where the user works.
Public property | Description | Gets the description specified for the user.
Public property | DisplayName | Gets the Display Name the user.
Public property | Domain | Gets the domain for the user.
Public property | DomainRespondsForUser | Gets flag that determines if domain is responding to user existence.
Public property | Email | Gets the E-Mail address of the user.
Public property | Exists | Gets flag that determines if user exists.
Public property | FirstName | Gets the First Name of the user.
Public property | FullName | Gets the Full Name of the user.
Public property | Groups | Gets all the groups associated with the user - this includes local groups and Active Directory groups if applicable.
Public property | IsLocalAccount | Gets flag that determines if this UserInfo instance is based on a local account instead of found through LDAP.
Public property | LastLogon | Gets the last login time of the user.
Public property | LastName | Gets the Last Name of the user.
Public property | LdapID | Gets the ID of the user in LDAP format.
Public property | LdapPath | Gets LDAP path defined for this user, if any.
Public property | LocalGroups | Gets the local groups the user is a member of.
Public property | LoginID | Gets the Login ID of the user.
 | MachineIsJoinedToDomain | Gets a boolean value that indicates whether the current machine is joined to a domain (non-local such as AD or LDAP).
Public property | Mailbox | Gets the Mailbox address of where the user works.
Public property | MaximumPasswordAge | Gets this maximum password age for the user.
Public property | MiddleInitial | Gets the Middle Initial of the user.
Public property | NextPasswordChangeDate | Gets the DateTime, in UTC, of next password change for the user.
Public property | Office | Gets the Office location of the user.
Public property | PasswordCannotChange | Gets flag that determines if account password cannot change for this user.
Public property | PasswordDoesNotExpire | Gets flag that determines if account password does not expire for this user.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of UserInfo object are to be saved to the config file.
 | RemoteUserID | Gets the LoginID of the remote web user.
 | RemoteUserInfo | Gets the UserInfo object for the RemoteUserID.
Public property | SettingsCategory | Gets or sets the category under which the settings of UserInfo object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Telephone | Gets the Telephone Number of the user.
Public property | Title | Gets the Title of the user.
Public property | UserAccountControl | Gets the account control information of the user.
Public property | UserName | Gets the user name of the user.
Public property | Webpage | Gets the web page address of the user.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed.
Top
Remarks
See http://msdn.microsoft.com/en-us/library/ms677980.aspx for more information on active directory properties.
Examples
This example shows how to retrieve user information from Active Directory:
Copy
using System;
using GSF.Identity;

class Program
{
    static void Main(string[] args)
    {
        // Retrieve and display user information from Active Directory.
        using (UserInfo user = new UserInfo("XYZCorp\\johndoe"))
        {
            Console.WriteLine(string.Format("First Name: {0}", user.FirstName));
            Console.WriteLine(string.Format("Last Name: {0}", user.LastName));
            Console.WriteLine(string.Format("Middle Initial: {0}", user.MiddleInitial));
            Console.WriteLine(string.Format("Email Address: {0}", user.Email));
            Console.WriteLine(string.Format("Telephone Number: {0}", user.Telephone));
        }

        Console.ReadLine();
    }
}
This example shows the config file section that can be used to specify the domain account to be used for Active Directory queries:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.Identity Namespace


UserInfo Constructor

Grid Solutions Framework UserInfo Constructor
Overload List
 | Name | Description
Public method | UserInfo(String) | Initializes a new instance of the UserInfo class.
Public method | UserInfo(String, String) | Initializes a new instance of the UserInfo class.
Top
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo Constructor (String)

Grid Solutions Framework UserInfo Constructor (String)
Initializes a new instance of the UserInfo class.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserInfo(
    string loginID
)
Public Sub New (
    loginID As String
)
new :
        loginID : string -> UserInfo
GSF.Identity.UserInfo = function(loginID);
public:
UserInfo(
    String^ loginID
)

Parameters

loginID
Type: SystemString
Login ID in 'domain\username' format of the user's account whose information is to be retrieved. Login ID can also be specified in 'username' format without the domain name, in which case the domain name will be approximated based on the privileged user domain if specified, default logon domain of the host machine if available, or the domain of the identity that owns the host process.
Exceptions
Exception | Condition
ArgumentNullException | loginID is a null or empty string.
See Also

Reference

UserInfo Class
UserInfo Overload
GSF.Identity Namespace


UserInfo Constructor (String, String)

Grid Solutions Framework UserInfo Constructor (String, String)
Initializes a new instance of the UserInfo class.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserInfo(
    string loginID,
    string ldapPath
)
Public Sub New (
    loginID As String,
    ldapPath As String
)
new :
        loginID : string *
        ldapPath : string -> UserInfo
GSF.Identity.UserInfo = function(loginID, ldapPath);
public:
UserInfo(
    String^ loginID,
    String^ ldapPath
)

Parameters

loginID
Type: SystemString
Login ID in 'domain\username' format of the user's account whose information is to be retrieved. Login ID can also be specified in 'username' format without the domain name, in which case the domain name will be approximated based on the privileged user domain if specified, default logon domain of the host machine if available, or the domain of the identity that owns the host process.
ldapPath
Type: SystemString
String in 'LDAP://' format that specifies the Active Directory node where search for the user starts.
Exceptions
Exception | Condition
ArgumentNullException | loginID is a null or empty string.
See Also

Reference

UserInfo Class
UserInfo Overload
GSF.Identity Namespace


UserInfo Fields

Grid Solutions Framework UserInfo Fields

The UserInfo type exposes the following members.

Fields
Name | Description
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.DefaultPersistSettings Field

Grid Solutions Framework UserInfoDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.Identity.UserInfo.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.DefaultSettingsCategory Field

Grid Solutions Framework UserInfoDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.Identity.UserInfo.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo Methods

Grid Solutions Framework UserInfo Methods

The UserInfo type exposes the following members.

Methods
 | Name | Description
 | AddUserToLocalGroup | Adds an existing user to the specified local groupName.
 | AuthenticateUser(String, String, String) | Authenticates the specified user credentials.
 | AuthenticateUser(String, String, String, String) | Authenticates the specified user credentials.
Public method | ChangePassword | Attempts to change the user's password.
 | CreateLocalGroup | Creates a new local group if it does not exist already.
 | CreateLocalUser | Creates a new local user if it does not exist already.
 | DefinePrivilegedAccount | Defines the credentials of a privileged domain account that can be used for impersonation prior to the retrieval of user information from the Active Directory.
Public method | Dispose | Releases all the resources used by the UserInfo object.
 | EndImpersonation | Ends the impersonation of the specified user.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | GetBuiltInLocalGroups | Returns a sorted list of the common built-in local groups. On Windows these groups have a domain name of BUILTIN.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLocalGroupUserList | Gets a list of users that exist in the specified local groupName.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUserPropertyValue | Returns the value for specified active directory property.
 | GroupNameToSID | Converts the given group name to the SID corresponding to that name.
Public method | ImpersonatePrivilegedAccount | Impersonates the defined privileged domain account.
 | ImpersonateUser | Impersonates the specified user.
Public method | Initialize | Initializes the UserInfo object.
 | IsGroupSID | Determines whether the given security identifier identifies a group.
 | IsLocalDomain | Determines if specified domain is the local domain (i.e., local machine).
 | IsUserSID | Determines whether the given security identifier identifies a user account.
Public method | LoadSettings | Loads saved settings for the UserInfo object from the config file if the PersistSettings property is set to true.
 | LocalGroupExists | Determines if local group exists.
 | LocalUserExists | Determines if local user exists.
 | RemoveLocalGroup | Removes local group if it exists.
 | RemoveLocalUser | Removes local user if it exists.
 | RemoveUserFromLocalGroup | Removes an existing user from the specified local groupName.
Public method | SaveSettings | Saves settings for the UserInfo object to the config file if the PersistSettings property is set to true.
 | SetLocalUserPassword | Sets local user's password.
 | SIDToAccountName | Converts the given SID to the corresponding account name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | UserIsInLocalGroup | Determines if user is in the specified local groupName.
 | UserNameToSID | Converts the given user name to the SID corresponding to that name.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.AddUserToLocalGroup Method

Grid Solutions Framework UserInfoAddUserToLocalGroup Method
Adds an existing user to the specified local groupName.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool AddUserToLocalGroup(
    string groupName,
    string userName
)
Public Shared Function AddUserToLocalGroup (
    groupName As String,
    userName As String
) As Boolean
static member AddUserToLocalGroup :
        groupName : string *
        userName : string -> bool

GSF.Identity.UserInfo.AddUserToLocalGroup = function(groupName, userName);
public:
static bool AddUserToLocalGroup(
    String^ groupName,
    String^ userName
)

Parameters

groupName
Type: SystemString
Group name to add local user to.
userName
Type: SystemString
Existing local user name.

Return Value

Type: Boolean
true if user was added to local group; otherwise, false meaning user was already in group.
Exceptions
Exception | Condition
ArgumentNullException | groupName or userName was null.
ArgumentException | No groupName or userName was specified.
InvalidOperationException | Could not add user to local group.
Remarks
This function will handle Windows service virtual accounts by specifying the complete virtual account name, such as @"NT SERVICE\MyService", as the userName. This function can also add Active Directory user accounts and groups to the local group the when the userName is prefixed with a domain name and a backslash "\".
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.AuthenticateUser Method

Grid Solutions Framework UserInfoAuthenticateUser Method
Overload List
Name | Description
AuthenticateUser(String, String, String) | Authenticates the specified user credentials.
AuthenticateUser(String, String, String, String) | Authenticates the specified user credentials.
Top
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.AuthenticateUser Method (String, String, String)

Grid Solutions Framework UserInfoAuthenticateUser Method (String, String, String)
Authenticates the specified user credentials.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IPrincipal AuthenticateUser(
    string domain,
    string userName,
    string password
)
Public Shared Function AuthenticateUser (
    domain As String,
    userName As String,
    password As String
) As IPrincipal
static member AuthenticateUser :
        domain : string *
        userName : string *
        password : string -> IPrincipal

GSF.Identity.UserInfo.AuthenticateUser = function(domain, userName, password);
public:
static IPrincipal^ AuthenticateUser(
    String^ domain,
    String^ userName,
    String^ password
)

Parameters

domain
Type: SystemString
Domain of user to authenticate.
userName
Type: SystemString
Username of user to authenticate.
password
Type: SystemString
Password of user to authenticate.

Return Value

Type: IPrincipal
true if the user credentials are authenticated successfully; otherwise false.
Remarks
This method always returns null under Mono deployments.
Examples
This example shows how to validate a user's credentials:
Copy
using System;
using GSF.Identity;

class Program
{
    static void Main(string[] args)
    {
        string domain = "XYZCorp";
        string username = "johndoe";
        string password = "password";

        // Authenticate user credentials.
        if ((object)UserInfo.AuthenticateUser(domain, username, password) != null)
            Console.WriteLine("Successfully authenticated user \"{0}\\{1}\".", domain, username);
        else
            Console.WriteLine("Failed to authenticate user \"{0}\\{1}\".", domain, username);

        Console.ReadLine();
    }
}
See Also

Reference

UserInfo Class
AuthenticateUser Overload
GSF.Identity Namespace


UserInfo.AuthenticateUser Method (String, String, String, String)

Grid Solutions Framework UserInfoAuthenticateUser Method (String, String, String, String)
Authenticates the specified user credentials.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IPrincipal AuthenticateUser(
    string domain,
    string userName,
    string password,
    out string errorMessage
)
Public Shared Function AuthenticateUser (
    domain As String,
    userName As String,
    password As String,
    <OutAttribute> ByRef errorMessage As String
) As IPrincipal
static member AuthenticateUser :
        domain : string *
        userName : string *
        password : string *
        errorMessage : string byref -> IPrincipal

GSF.Identity.UserInfo.AuthenticateUser = function(domain, userName, password, errorMessage);
public:
static IPrincipal^ AuthenticateUser(
    String^ domain,
    String^ userName,
    String^ password,
    [OutAttribute] String^% errorMessage
)

Parameters

domain
Type: SystemString
Domain of user to authenticate.
userName
Type: SystemString
Username of user to authenticate.
password
Type: SystemString
Password of user to authenticate.
errorMessage
Type: SystemString
Error message returned, if authentication fails.

Return Value

Type: IPrincipal
true if the user credentials are authenticated successfully; otherwise false.
Remarks
This method always returns null under Mono deployments.
Examples
This example shows how to validate a user's credentials and retrieve an error message if validation fails:
Copy
using System;
using GSF.Identity;

class Program
{
    static void Main(string[] args)
    {
        string domain = "XYZCorp";
        string username = "johndoe";
        string password = "password";
        string errorMessage;

        // Authenticate user credentials.
        if ((object)UserInfo.AuthenticateUser(domain, username, password, out errorMessage) != null)
            Console.WriteLine("Successfully authenticated user \"{0}\\{1}\".", domain, username);
        else
            Console.WriteLine("Failed to authenticate user \"{0}\\{1}\" due to exception: {2}", domain, username, errorMessage);

        Console.ReadLine();
    }
}
See Also

Reference

UserInfo Class
AuthenticateUser Overload
GSF.Identity Namespace


UserInfo.ChangePassword Method

Grid Solutions Framework UserInfoChangePassword Method
Attempts to change the user's password.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ChangePassword(
    string oldPassword,
    string newPassword
)
Public Sub ChangePassword (
    oldPassword As String,
    newPassword As String
)
member ChangePassword :
        oldPassword : string *
        newPassword : string -> unit

function ChangePassword(oldPassword, newPassword);
public:
void ChangePassword(
    String^ oldPassword,
    String^ newPassword
)

Parameters

oldPassword
Type: SystemString
Old password.
newPassword
Type: SystemString
New password.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.CreateLocalGroup Method

Grid Solutions Framework UserInfoCreateLocalGroup Method
Creates a new local group if it does not exist already.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CreateLocalGroup(
    string groupName,
    string groupDescription = null
)
Public Shared Function CreateLocalGroup (
    groupName As String,
    Optional groupDescription As String = Nothing
) As Boolean
static member CreateLocalGroup :
        groupName : string *
        ?groupDescription : string
(* Defaults:
        let _groupDescription = defaultArg groupDescription null
*)
-> bool

GSF.Identity.UserInfo.CreateLocalGroup = function(groupName, groupDescription);
public:
static bool CreateLocalGroup(
    String^ groupName,
    String^ groupDescription = nullptr
)

Parameters

groupName
Type: SystemString
Group name to create if it doesn't exist.
groupDescription (Optional)
Type: SystemString
Optional group description.

Return Value

Type: Boolean
true if group was created; otherwise, false if group already existed.
Exceptions
Exception | Condition
ArgumentNullException | groupName was null.
ArgumentException | No groupName was specified.
InvalidOperationException | Could not create local group.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.CreateLocalUser Method

Grid Solutions Framework UserInfoCreateLocalUser Method
Creates a new local user if it does not exist already.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CreateLocalUser(
    string userName,
    string password,
    string userDescription = null
)
Public Shared Function CreateLocalUser (
    userName As String,
    password As String,
    Optional userDescription As String = Nothing
) As Boolean
static member CreateLocalUser :
        userName : string *
        password : string *
        ?userDescription : string
(* Defaults:
        let _userDescription = defaultArg userDescription null
*)
-> bool

GSF.Identity.UserInfo.CreateLocalUser = function(userName, password, userDescription);
public:
static bool CreateLocalUser(
    String^ userName,
    String^ password,
    String^ userDescription = nullptr
)

Parameters

userName
Type: SystemString
User name to create if it doesn't exist.
password
Type: SystemString
Password to user for new user.
userDescription (Optional)
Type: SystemString
Optional user description.

Return Value

Type: Boolean
true if user was created; otherwise, false if user already existed.
Exceptions
Exception | Condition
ArgumentNullException | userName or password was null.
ArgumentException | No userName was specified.
InvalidOperationException | Could not create local user.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.DefinePrivilegedAccount Method

Grid Solutions Framework UserInfoDefinePrivilegedAccount Method
Defines the credentials of a privileged domain account that can be used for impersonation prior to the retrieval of user information from the Active Directory.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void DefinePrivilegedAccount(
    string domain,
    string username,
    string password
)
Public Sub DefinePrivilegedAccount (
    domain As String,
    username As String,
    password As String
)
member DefinePrivilegedAccount :
        domain : string *
        username : string *
        password : string -> unit

function DefinePrivilegedAccount(domain, username, password);
public:
void DefinePrivilegedAccount(
    String^ domain,
    String^ username,
    String^ password
)

Parameters

domain
Type: SystemString
Domain of privileged domain user account.
username
Type: SystemString
Username of privileged domain user account.
password
Type: SystemString
Password of privileged domain user account.
Examples
This example shows how to define the identity of the user to be used for retrieving information from Active Directory:
Copy
using System;
using GSF.Identity;

class Program
{
    static void Main(string[] args)
    {
        using (UserInfo user = new UserInfo("XYZCorp\\johndoe"))
        {
            // Define the identity to use for retrieving Active Directory information.
            // Persist identity credentials encrypted to the config for easy access.
            user.PersistSettings = true;
            user.DefinePrivilegedAccount("XYZCorp", "admin", "Passw0rd");

            // Retrieve and display user information from Active Directory.
            Console.WriteLine(string.Format("First Name: {0}", user.FirstName));
            Console.WriteLine(string.Format("Last Name: {0}", user.LastName));
            Console.WriteLine(string.Format("Middle Initial: {0}", user.MiddleInitial));
            Console.WriteLine(string.Format("Email Address: {0}", user.Email));
            Console.WriteLine(string.Format("Telephone Number: {0}", user.Telephone));
        }

        Console.ReadLine();
    }
}
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Dispose Method

Grid Solutions Framework UserInfoDispose Method
Releases all the resources used by the UserInfo object.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.EndImpersonation Method

Grid Solutions Framework UserInfoEndImpersonation Method
Ends the impersonation of the specified user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EndImpersonation(
    WindowsImpersonationContext impersonatedUser
)
Public Shared Sub EndImpersonation (
    impersonatedUser As WindowsImpersonationContext
)
static member EndImpersonation :
        impersonatedUser : WindowsImpersonationContext -> unit

GSF.Identity.UserInfo.EndImpersonation = function(impersonatedUser);
public:
static void EndImpersonation(
    WindowsImpersonationContext^ impersonatedUser
)

Parameters

impersonatedUser
Type: System.Security.PrincipalWindowsImpersonationContext
WindowsImpersonationContext of the impersonated user.
Examples
This example shows how to terminate an active user impersonation:
Copy
using System;
using System.IO;
using System.Security.Principal;
using GSF.Identity;

class Program
{
    static void Main(string[] args)
    {
        // Impersonate user.
        WindowsImpersonationContext context = UserInfo.ImpersonateUser("XYZCorp", "johndoe", "password");
        // Perform operation requiring elevated privileges.
        Console.WriteLine(File.ReadAllText(@"\\server\share\file.xml"));
        // End the impersonation.
        UserInfo.EndImpersonation(context);

        Console.ReadLine();
    }
}
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.GetBuiltInLocalGroups Method

Grid Solutions Framework UserInfoGetBuiltInLocalGroups Method
Returns a sorted list of the common built-in local groups. On Windows these groups have a domain name of BUILTIN.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] GetBuiltInLocalGroups()
Public Shared Function GetBuiltInLocalGroups As String()
static member GetBuiltInLocalGroups : unit -> string[]

GSF.Identity.UserInfo.GetBuiltInLocalGroups = function();
public:
static array<String^>^ GetBuiltInLocalGroups()

Return Value

Type: String
Sorted list of the common built-in local groups.
Remarks
Names in this list will not have a "BUILTIN\" prefix.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.GetLocalGroupUserList Method

Grid Solutions Framework UserInfoGetLocalGroupUserList Method
Gets a list of users that exist in the specified local groupName.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] GetLocalGroupUserList(
    string groupName
)
Public Shared Function GetLocalGroupUserList (
    groupName As String
) As String()
static member GetLocalGroupUserList :
        groupName : string -> string[]

GSF.Identity.UserInfo.GetLocalGroupUserList = function(groupName);
public:
static array<String^>^ GetLocalGroupUserList(
    String^ groupName
)

Parameters

groupName
Type: SystemString
Group name to remove local user from.

Return Value

Type: String
List of users that exist in the in group.
Exceptions
Exception | Condition
ArgumentNullException | groupName was null.
ArgumentException | No groupName was specified.
InvalidOperationException | Could not get members for local group.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.GetUserPropertyValue Method

Grid Solutions Framework UserInfoGetUserPropertyValue Method
Returns the value for specified active directory property.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetUserPropertyValue(
    string propertyName
)
Public Function GetUserPropertyValue (
    propertyName As String
) As String
member GetUserPropertyValue :
        propertyName : string -> string

function GetUserPropertyValue(propertyName);
public:
String^ GetUserPropertyValue(
    String^ propertyName
)

Parameters

propertyName
Type: SystemString
Name of the active directory property whose value is to be retrieved.

Return Value

Type: String
String value for the specified active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.GroupNameToSID Method

Grid Solutions Framework UserInfoGroupNameToSID Method
Converts the given group name to the SID corresponding to that name.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GroupNameToSID(
    string groupName
)
Public Shared Function GroupNameToSID (
    groupName As String
) As String
static member GroupNameToSID :
        groupName : string -> string

GSF.Identity.UserInfo.GroupNameToSID = function(groupName);
public:
static String^ GroupNameToSID(
    String^ groupName
)

Parameters

groupName
Type: SystemString
The group name for which to look up the SID.

Return Value

Type: String
The SID for the given group name, or the group name if no SID can be found.
Remarks
If the groupName cannot be converted to a SID, groupName will be the return value.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.ImpersonatePrivilegedAccount Method

Grid Solutions Framework UserInfoImpersonatePrivilegedAccount Method
Impersonates the defined privileged domain account.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WindowsImpersonationContext ImpersonatePrivilegedAccount()
Public Function ImpersonatePrivilegedAccount As WindowsImpersonationContext
member ImpersonatePrivilegedAccount : unit -> WindowsImpersonationContext

function ImpersonatePrivilegedAccount();
public:
WindowsImpersonationContext^ ImpersonatePrivilegedAccount()

Return Value

Type: WindowsImpersonationContext
An WindowsImpersonationContext if privileged domain account has been defined, otherwise null.
Remarks
This method always returns null under Mono deployments.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.ImpersonateUser Method

Grid Solutions Framework UserInfoImpersonateUser Method
Impersonates the specified user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WindowsImpersonationContext ImpersonateUser(
    string domain,
    string userName,
    string password
)
Public Shared Function ImpersonateUser (
    domain As String,
    userName As String,
    password As String
) As WindowsImpersonationContext
static member ImpersonateUser :
        domain : string *
        userName : string *
        password : string -> WindowsImpersonationContext

GSF.Identity.UserInfo.ImpersonateUser = function(domain, userName, password);
public:
static WindowsImpersonationContext^ ImpersonateUser(
    String^ domain,
    String^ userName,
    String^ password
)

Parameters

domain
Type: SystemString
Domain of user to impersonate.
userName
Type: SystemString
Username of user to impersonate.
password
Type: SystemString
Password of user to impersonate.

Return Value

Type: WindowsImpersonationContext
A WindowsImpersonationContext object of the impersonated user.
Remarks

After impersonating a user the code executes under the impersonated user's identity.

This method always returns null under Mono deployments.

Examples
This example shows how to impersonate a user:
Copy
using System;
using GSF.Identity;

class Program
{
    static void Main(string[] args)
    {
        Console.WriteLine(string.Format("User before impersonation: {0}", UserInfo.CurrentUserID));
        UserInfo.ImpersonateUser("XYZCorp", "johndoe", "password"); // Impersonate user.
        Console.WriteLine(string.Format("User after impersonation: {0}", UserInfo.CurrentUserID));

        Console.ReadLine();
    }
}
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Initialize Method

Grid Solutions Framework UserInfoInitialize Method
Initializes the UserInfo object.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Exceptions
Exception | Condition
InitializationException | Failed to initialize directory entry for LoginID.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.IsGroupSID Method

Grid Solutions Framework UserInfoIsGroupSID Method
Determines whether the given security identifier identifies a group.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsGroupSID(
    string sid
)
Public Shared Function IsGroupSID (
    sid As String
) As Boolean
static member IsGroupSID :
        sid : string -> bool

GSF.Identity.UserInfo.IsGroupSID = function(sid);
public:
static bool IsGroupSID(
    String^ sid
)

Parameters

sid
Type: SystemString
The security identifier.

Return Value

Type: Boolean
True if the security identifier identifies a group; false otherwise.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.IsLocalDomain Method

Grid Solutions Framework UserInfoIsLocalDomain Method
Determines if specified domain is the local domain (i.e., local machine).

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsLocalDomain(
    string domain
)
Public Shared Function IsLocalDomain (
    domain As String
) As Boolean
static member IsLocalDomain :
        domain : string -> bool

GSF.Identity.UserInfo.IsLocalDomain = function(domain);
public:
static bool IsLocalDomain(
    String^ domain
)

Parameters

domain
Type: SystemString
Domain name to check.

Return Value

Type: Boolean
trueif specified domain is the local domain (i.e., local machine); otherwise, false.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.IsUserSID Method

Grid Solutions Framework UserInfoIsUserSID Method
Determines whether the given security identifier identifies a user account.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsUserSID(
    string sid
)
Public Shared Function IsUserSID (
    sid As String
) As Boolean
static member IsUserSID :
        sid : string -> bool

GSF.Identity.UserInfo.IsUserSID = function(sid);
public:
static bool IsUserSID(
    String^ sid
)

Parameters

sid
Type: SystemString
The security identifier.

Return Value

Type: Boolean
True if the security identifier identifies a user account; false otherwise.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LoadSettings Method

Grid Solutions Framework UserInfoLoadSettings Method
Loads saved settings for the UserInfo object from the config file if the PersistSettings property is set to true.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LocalGroupExists Method

Grid Solutions Framework UserInfoLocalGroupExists Method
Determines if local group exists.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool LocalGroupExists(
    string groupName
)
Public Shared Function LocalGroupExists (
    groupName As String
) As Boolean
static member LocalGroupExists :
        groupName : string -> bool

GSF.Identity.UserInfo.LocalGroupExists = function(groupName);
public:
static bool LocalGroupExists(
    String^ groupName
)

Parameters

groupName
Type: SystemString
Group name to test for existence.

Return Value

Type: Boolean
true if groupName exists; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | groupName was null.
ArgumentException | No groupName was specified.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LocalUserExists Method

Grid Solutions Framework UserInfoLocalUserExists Method
Determines if local user exists.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool LocalUserExists(
    string userName
)
Public Shared Function LocalUserExists (
    userName As String
) As Boolean
static member LocalUserExists :
        userName : string -> bool

GSF.Identity.UserInfo.LocalUserExists = function(userName);
public:
static bool LocalUserExists(
    String^ userName
)

Parameters

userName
Type: SystemString
User name to test for existence.

Return Value

Type: Boolean
true if userName exists; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | userName was null.
ArgumentException | No userName was specified.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.RemoveLocalGroup Method

Grid Solutions Framework UserInfoRemoveLocalGroup Method
Removes local group if it exists.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool RemoveLocalGroup(
    string groupName
)
Public Shared Function RemoveLocalGroup (
    groupName As String
) As Boolean
static member RemoveLocalGroup :
        groupName : string -> bool

GSF.Identity.UserInfo.RemoveLocalGroup = function(groupName);
public:
static bool RemoveLocalGroup(
    String^ groupName
)

Parameters

groupName
Type: SystemString
Group name to remove if it exists.

Return Value

Type: Boolean
true if group was removed; otherwise, false if group did not exist.
Exceptions
Exception | Condition
ArgumentNullException | groupName was null.
ArgumentException | No groupName was specified.
InvalidOperationException | Could not remove local group.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.RemoveLocalUser Method

Grid Solutions Framework UserInfoRemoveLocalUser Method
Removes local user if it exists.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool RemoveLocalUser(
    string userName
)
Public Shared Function RemoveLocalUser (
    userName As String
) As Boolean
static member RemoveLocalUser :
        userName : string -> bool

GSF.Identity.UserInfo.RemoveLocalUser = function(userName);
public:
static bool RemoveLocalUser(
    String^ userName
)

Parameters

userName
Type: SystemString
User name to remove if it exists.

Return Value

Type: Boolean
true if user was removed; otherwise, false if user did not exist.
Exceptions
Exception | Condition
ArgumentNullException | userName was null.
ArgumentException | No userName was specified.
InvalidOperationException | Could not remove local user.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.RemoveUserFromLocalGroup Method

Grid Solutions Framework UserInfoRemoveUserFromLocalGroup Method
Removes an existing user from the specified local groupName.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool RemoveUserFromLocalGroup(
    string groupName,
    string userName
)
Public Shared Function RemoveUserFromLocalGroup (
    groupName As String,
    userName As String
) As Boolean
static member RemoveUserFromLocalGroup :
        groupName : string *
        userName : string -> bool

GSF.Identity.UserInfo.RemoveUserFromLocalGroup = function(groupName, userName);
public:
static bool RemoveUserFromLocalGroup(
    String^ groupName,
    String^ userName
)

Parameters

groupName
Type: SystemString
Group name to remove local user from.
userName
Type: SystemString
Existing local user name.

Return Value

Type: Boolean
true if user was removed from local group; otherwise, false meaning user did not exist in group.
Exceptions
Exception | Condition
ArgumentNullException | groupName or userName was null.
ArgumentException | No groupName or userName was specified.
InvalidOperationException | Could not remove user from local group.
Remarks
This function will handle Windows service virtual accounts by specifying the complete virtual account name, such as @"NT SERVICE\MyService", as the userName. This function can also remove Active Directory user accounts and groups from the local group the when the userName is prefixed with a domain name and a backslash "\".
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.SaveSettings Method

Grid Solutions Framework UserInfoSaveSettings Method
Saves settings for the UserInfo object to the config file if the PersistSettings property is set to true.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.SetLocalUserPassword Method

Grid Solutions Framework UserInfoSetLocalUserPassword Method
Sets local user's password.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SetLocalUserPassword(
    string userName,
    string password
)
Public Shared Sub SetLocalUserPassword (
    userName As String,
    password As String
)
static member SetLocalUserPassword :
        userName : string *
        password : string -> unit

GSF.Identity.UserInfo.SetLocalUserPassword = function(userName, password);
public:
static void SetLocalUserPassword(
    String^ userName,
    String^ password
)

Parameters

userName
Type: SystemString
User name to change password for.
password
Type: SystemString
New password fro user.
Exceptions
Exception | Condition
ArgumentNullException | userName or password was null.
ArgumentException | No userName was specified or user does not exist.
InvalidOperationException | Could not set password for local user.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.SIDToAccountName Method

Grid Solutions Framework UserInfoSIDToAccountName Method
Converts the given SID to the corresponding account name.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string SIDToAccountName(
    string sid
)
Public Shared Function SIDToAccountName (
    sid As String
) As String
static member SIDToAccountName :
        sid : string -> string

GSF.Identity.UserInfo.SIDToAccountName = function(sid);
public:
static String^ SIDToAccountName(
    String^ sid
)

Parameters

sid
Type: SystemString
The SID for which to look up the account name.

Return Value

Type: String
The account name for the given SID, or the SID if no account name can be found.
Remarks
If the sid cannot be converted to an account name, sid will be the return value.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.UserIsInLocalGroup Method

Grid Solutions Framework UserInfoUserIsInLocalGroup Method
Determines if user is in the specified local groupName.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool UserIsInLocalGroup(
    string groupName,
    string userName
)
Public Shared Function UserIsInLocalGroup (
    groupName As String,
    userName As String
) As Boolean
static member UserIsInLocalGroup :
        groupName : string *
        userName : string -> bool

GSF.Identity.UserInfo.UserIsInLocalGroup = function(groupName, userName);
public:
static bool UserIsInLocalGroup(
    String^ groupName,
    String^ userName
)

Parameters

groupName
Type: SystemString
Group name to test.
userName
Type: SystemString
User name to test.

Return Value

Type: Boolean
true if user is in group; otherwise, false.
Exceptions
Exception | Condition
ArgumentNullException | groupName or userName was null.
ArgumentException | No groupName or userName was specified.
InvalidOperationException | Could not determine if user was in local group.
Remarks
This function will handle Windows service virtual accounts by specifying the complete virtual account name, such as @"NT SERVICE\MyService", as the userName. This function can also detect Active Directory user accounts and groups that may exist in the local group when the userName is prefixed with a domain name and a backslash "\".
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.UserNameToSID Method

Grid Solutions Framework UserInfoUserNameToSID Method
Converts the given user name to the SID corresponding to that name.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string UserNameToSID(
    string userName
)
Public Shared Function UserNameToSID (
    userName As String
) As String
static member UserNameToSID :
        userName : string -> string

GSF.Identity.UserInfo.UserNameToSID = function(userName);
public:
static String^ UserNameToSID(
    String^ userName
)

Parameters

userName
Type: SystemString
The user name for which to look up the SID.

Return Value

Type: String
The SID for the given user name, or the user name if no SID can be found.
Remarks
If the userName cannot be converted to a SID, userName will be the return value.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo Properties

Grid Solutions Framework UserInfo Properties

The UserInfo type exposes the following members.

Properties
 | Name | Description
Public property | AccountCreationDate | Gets the DateTime when the account was created.
Public property | AccountIsDisabled | Gets flag that determines if account is disabled for this user.
Public property | AccountIsLockedOut | Gets flag that determines if account is locked-out for this user.
Public property | City | Gets the City where the user works.
Public property | Company | Gets the Company of the user.
 | CurrentUserID | Gets the ID name of the current user.
 | CurrentUserInfo | Gets the UserInfo object for the CurrentUserID.
Public property | Department | Gets the Department where the user works.
Public property | Description | Gets the description specified for the user.
Public property | DisplayName | Gets the Display Name the user.
Public property | Domain | Gets the domain for the user.
Public property | DomainRespondsForUser | Gets flag that determines if domain is responding to user existence.
Public property | Email | Gets the E-Mail address of the user.
Public property | Exists | Gets flag that determines if user exists.
Public property | FirstName | Gets the First Name of the user.
Public property | FullName | Gets the Full Name of the user.
Public property | Groups | Gets all the groups associated with the user - this includes local groups and Active Directory groups if applicable.
Public property | IsLocalAccount | Gets flag that determines if this UserInfo instance is based on a local account instead of found through LDAP.
Public property | LastLogon | Gets the last login time of the user.
Public property | LastName | Gets the Last Name of the user.
Public property | LdapID | Gets the ID of the user in LDAP format.
Public property | LdapPath | Gets LDAP path defined for this user, if any.
Public property | LocalGroups | Gets the local groups the user is a member of.
Public property | LoginID | Gets the Login ID of the user.
 | MachineIsJoinedToDomain | Gets a boolean value that indicates whether the current machine is joined to a domain (non-local such as AD or LDAP).
Public property | Mailbox | Gets the Mailbox address of where the user works.
Public property | MaximumPasswordAge | Gets this maximum password age for the user.
Public property | MiddleInitial | Gets the Middle Initial of the user.
Public property | NextPasswordChangeDate | Gets the DateTime, in UTC, of next password change for the user.
Public property | Office | Gets the Office location of the user.
Public property | PasswordCannotChange | Gets flag that determines if account password cannot change for this user.
Public property | PasswordDoesNotExpire | Gets flag that determines if account password does not expire for this user.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of UserInfo object are to be saved to the config file.
 | RemoteUserID | Gets the LoginID of the remote web user.
 | RemoteUserInfo | Gets the UserInfo object for the RemoteUserID.
Public property | SettingsCategory | Gets or sets the category under which the settings of UserInfo object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Telephone | Gets the Telephone Number of the user.
Public property | Title | Gets the Title of the user.
Public property | UserAccountControl | Gets the account control information of the user.
Public property | UserName | Gets the user name of the user.
Public property | Webpage | Gets the web page address of the user.
Top
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.AccountCreationDate Property

Grid Solutions Framework UserInfoAccountCreationDate Property
Gets the DateTime when the account was created.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime AccountCreationDate { get; }
Public ReadOnly Property AccountCreationDate As DateTime
    Get
member AccountCreationDate : DateTime with get

function get_AccountCreationDate();

public:
property DateTime AccountCreationDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.AccountIsDisabled Property

Grid Solutions Framework UserInfoAccountIsDisabled Property
Gets flag that determines if account is disabled for this user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AccountIsDisabled { get; }
Public ReadOnly Property AccountIsDisabled As Boolean
    Get
member AccountIsDisabled : bool with get

function get_AccountIsDisabled();

public:
property bool AccountIsDisabled {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
SecurityException | User account control information cannot be obtained, may not have needed rights.
InvalidOperationException | Unknown error. Invalid value returned when querying user account control.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.AccountIsLockedOut Property

Grid Solutions Framework UserInfoAccountIsLockedOut Property
Gets flag that determines if account is locked-out for this user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AccountIsLockedOut { get; }
Public ReadOnly Property AccountIsLockedOut As Boolean
    Get
member AccountIsLockedOut : bool with get

function get_AccountIsLockedOut();

public:
property bool AccountIsLockedOut {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
SecurityException | User account control information cannot be obtained, may not have needed rights.
InvalidOperationException | Unknown error. Invalid value returned when querying user account control.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.City Property

Grid Solutions Framework UserInfoCity Property
Gets the City where the user works.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string City { get; }
Public ReadOnly Property City As String
    Get
member City : string with get

function get_City();

public:
property String^ City {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "l" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Company Property

Grid Solutions Framework UserInfoCompany Property
Gets the Company of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Company { get; }
Public ReadOnly Property Company As String
    Get
member Company : string with get

function get_Company();

public:
property String^ Company {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "company" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.CurrentUserID Property

Grid Solutions Framework UserInfoCurrentUserID Property
Gets the ID name of the current user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string CurrentUserID { get; }
Public Shared ReadOnly Property CurrentUserID As String
    Get
static member CurrentUserID : string with get

GSF.Identity.UserInfo.get_CurrentUserID = function();

public:
static property String^ CurrentUserID {
    String^ get ();
}

Property Value

Type: String
Remarks
The ID name returned is that of the user account under which the code is executing.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.CurrentUserInfo Property

Grid Solutions Framework UserInfoCurrentUserInfo Property
Gets the UserInfo object for the CurrentUserID.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UserInfo CurrentUserInfo { get; }
Public Shared ReadOnly Property CurrentUserInfo As UserInfo
    Get
static member CurrentUserInfo : UserInfo with get

GSF.Identity.UserInfo.get_CurrentUserInfo = function();

public:
static property UserInfo^ CurrentUserInfo {
    UserInfo^ get ();
}

Property Value

Type: UserInfo
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Department Property

Grid Solutions Framework UserInfoDepartment Property
Gets the Department where the user works.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Department { get; }
Public ReadOnly Property Department As String
    Get
member Department : string with get

function get_Department();

public:
property String^ Department {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "department" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Description Property

Grid Solutions Framework UserInfoDescription Property
Gets the description specified for the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
member Description : string with get

function get_Description();

public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "description" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.DisplayName Property

Grid Solutions Framework UserInfoDisplayName Property
Gets the Display Name the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DisplayName { get; }
Public ReadOnly Property DisplayName As String
    Get
member DisplayName : string with get

function get_DisplayName();

public:
property String^ DisplayName {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "displayName" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Domain Property

Grid Solutions Framework UserInfoDomain Property
Gets the domain for the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Domain { get; }
Public ReadOnly Property Domain As String
    Get
member Domain : string with get

function get_Domain();

public:
property String^ Domain {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.DomainRespondsForUser Property

Grid Solutions Framework UserInfoDomainRespondsForUser Property
Gets flag that determines if domain is responding to user existence.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DomainRespondsForUser { get; }
Public ReadOnly Property DomainRespondsForUser As Boolean
    Get
member DomainRespondsForUser : bool with get

function get_DomainRespondsForUser();

public:
property bool DomainRespondsForUser {
    bool get ();
}

Return Value

Type: Boolean
true if domain responds and user exists; otherwise false.
Remarks
Note that when the domain is unavailable, this function will return false.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Email Property

Grid Solutions Framework UserInfoEmail Property
Gets the E-Mail address of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Email { get; }
Public ReadOnly Property Email As String
    Get
member Email : string with get

function get_Email();

public:
property String^ Email {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "mail" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Exists Property

Grid Solutions Framework UserInfoExists Property
Gets flag that determines if user exists.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Exists { get; }
Public ReadOnly Property Exists As Boolean
    Get
member Exists : bool with get

function get_Exists();

public:
property bool Exists {
    bool get ();
}

Return Value

Type: Boolean
true if user is found to exist; otherwise false.
Remarks

Unlike other properties in this class, Exists will still work even if the domain server is unavailable. Calling this property without access to a domain server will return true if the user is authenticated. This only succeeds if the current user is the same as the LoginID, there is no way to determine if a user other than the currently authenticated user exists without access to the domain server. Local accounts are not subject to these constraints since the domain server will effectively be your local computer which is always accessible.

Since this property can check the WindowsPrincipal to determine if the current thread identity is authenticated, it is important that consumers add the following code at application startup:

Copy
AppDomain.CurrentDomain.SetPrincipalPolicy(PrincipalPolicy.WindowsPrincipal);

If a laptop user that's normally connected to the domain takes their computer on the road without VPN or other connectivity to the domain, the user can still login to the laptop using cached credentials therefore they are still considered to exist. Without access to the domain, no user information will be available (such as the Groups listing) - if this data is needed offline it will need to be cached by the application in anticipation of offline access.

See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.FirstName Property

Grid Solutions Framework UserInfoFirstName Property
Gets the First Name of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FirstName { get; }
Public ReadOnly Property FirstName As String
    Get
member FirstName : string with get

function get_FirstName();

public:
property String^ FirstName {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "givenName" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.FullName Property

Grid Solutions Framework UserInfoFullName Property
Gets the Full Name of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get
member FullName : string with get

function get_FullName();

public:
property String^ FullName {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the concatenation of FirstName, MiddleInitial and LastName properties.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Groups Property

Grid Solutions Framework UserInfoGroups Property
Gets all the groups associated with the user - this includes local groups and Active Directory groups if applicable.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] Groups { get; }
Public ReadOnly Property Groups As String()
    Get
member Groups : string[] with get

function get_Groups();

public:
property array<String^>^ Groups {
    array<String^>^ get ();
}

Property Value

Type: String
Remarks

Groups names are prefixed with their associated domain, computer name or BUILTIN.

This method always returns an empty string array (i.e., a string array with no elements) under Mono deployments.

See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.IsLocalAccount Property

Grid Solutions Framework UserInfoIsLocalAccount Property
Gets flag that determines if this UserInfo instance is based on a local account instead of found through LDAP.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsLocalAccount { get; }
Public ReadOnly Property IsLocalAccount As Boolean
    Get
member IsLocalAccount : bool with get

function get_IsLocalAccount();

public:
property bool IsLocalAccount {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LastLogon Property

Grid Solutions Framework UserInfoLastLogon Property
Gets the last login time of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime LastLogon { get; }
Public ReadOnly Property LastLogon As DateTime
    Get
member LastLogon : DateTime with get

function get_LastLogon();

public:
property DateTime LastLogon {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LastName Property

Grid Solutions Framework UserInfoLastName Property
Gets the Last Name of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LastName { get; }
Public ReadOnly Property LastName As String
    Get
member LastName : string with get

function get_LastName();

public:
property String^ LastName {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "sn" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LdapID Property

Grid Solutions Framework UserInfoLdapID Property
Gets the ID of the user in LDAP format.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LdapID { get; }
Public ReadOnly Property LdapID As String
    Get
member LdapID : string with get

function get_LdapID();

public:
property String^ LdapID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LdapPath Property

Grid Solutions Framework UserInfoLdapPath Property
Gets LDAP path defined for this user, if any.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LdapPath { get; }
Public ReadOnly Property LdapPath As String
    Get
member LdapPath : string with get

function get_LdapPath();

public:
property String^ LdapPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LocalGroups Property

Grid Solutions Framework UserInfoLocalGroups Property
Gets the local groups the user is a member of.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] LocalGroups { get; }
Public ReadOnly Property LocalGroups As String()
    Get
member LocalGroups : string[] with get

function get_LocalGroups();

public:
property array<String^>^ LocalGroups {
    array<String^>^ get ();
}

Property Value

Type: String
Remarks

Groups names are prefixed with BUILTIN or computer name.

This method always returns an empty string array (i.e., a string array with no elements) under Mono deployments.

See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.LoginID Property

Grid Solutions Framework UserInfoLoginID Property
Gets the Login ID of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LoginID { get; }
Public ReadOnly Property LoginID As String
    Get
member LoginID : string with get

function get_LoginID();

public:
property String^ LoginID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.MachineIsJoinedToDomain Property

Grid Solutions Framework UserInfoMachineIsJoinedToDomain Property
Gets a boolean value that indicates whether the current machine is joined to a domain (non-local such as AD or LDAP).

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool MachineIsJoinedToDomain { get; }
Public Shared ReadOnly Property MachineIsJoinedToDomain As Boolean
    Get
static member MachineIsJoinedToDomain : bool with get

GSF.Identity.UserInfo.get_MachineIsJoinedToDomain = function();

public:
static property bool MachineIsJoinedToDomain {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Mailbox Property

Grid Solutions Framework UserInfoMailbox Property
Gets the Mailbox address of where the user works.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Mailbox { get; }
Public ReadOnly Property Mailbox As String
    Get
member Mailbox : string with get

function get_Mailbox();

public:
property String^ Mailbox {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "streetAddress" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.MaximumPasswordAge Property

Grid Solutions Framework UserInfoMaximumPasswordAge Property
Gets this maximum password age for the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks MaximumPasswordAge { get; }
Public ReadOnly Property MaximumPasswordAge As Ticks
    Get
member MaximumPasswordAge : Ticks with get

function get_MaximumPasswordAge();

public:
property Ticks MaximumPasswordAge {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.MiddleInitial Property

Grid Solutions Framework UserInfoMiddleInitial Property
Gets the Middle Initial of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string MiddleInitial { get; }
Public ReadOnly Property MiddleInitial As String
    Get
member MiddleInitial : string with get

function get_MiddleInitial();

public:
property String^ MiddleInitial {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "initials" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.NextPasswordChangeDate Property

Grid Solutions Framework UserInfoNextPasswordChangeDate Property
Gets the DateTime, in UTC, of next password change for the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime NextPasswordChangeDate { get; }
Public ReadOnly Property NextPasswordChangeDate As DateTime
    Get
member NextPasswordChangeDate : DateTime with get

function get_NextPasswordChangeDate();

public:
property DateTime NextPasswordChangeDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Office Property

Grid Solutions Framework UserInfoOffice Property
Gets the Office location of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Office { get; }
Public ReadOnly Property Office As String
    Get
member Office : string with get

function get_Office();

public:
property String^ Office {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "physicalDeliveryOfficeName" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.PasswordCannotChange Property

Grid Solutions Framework UserInfoPasswordCannotChange Property
Gets flag that determines if account password cannot change for this user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PasswordCannotChange { get; }
Public ReadOnly Property PasswordCannotChange As Boolean
    Get
member PasswordCannotChange : bool with get

function get_PasswordCannotChange();

public:
property bool PasswordCannotChange {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
SecurityException | User account control information cannot be obtained, may not have needed rights.
InvalidOperationException | Unknown error. Invalid value returned when querying user account control.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.PasswordDoesNotExpire Property

Grid Solutions Framework UserInfoPasswordDoesNotExpire Property
Gets flag that determines if account password does not expire for this user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PasswordDoesNotExpire { get; }
Public ReadOnly Property PasswordDoesNotExpire As Boolean
    Get
member PasswordDoesNotExpire : bool with get

function get_PasswordDoesNotExpire();

public:
property bool PasswordDoesNotExpire {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
SecurityException | User account control information cannot be obtained, may not have needed rights.
InvalidOperationException | Unknown error. Invalid value returned when querying user account control.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.PersistSettings Property

Grid Solutions Framework UserInfoPersistSettings Property
Gets or sets a boolean value that indicates whether the settings of UserInfo object are to be saved to the config file.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PersistSettings { get; set; }
Public Property PersistSettings As Boolean
    Get
    Set
abstract PersistSettings : bool with get, set
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.RemoteUserID Property

Grid Solutions Framework UserInfoRemoteUserID Property
Gets the LoginID of the remote web user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemoteUserID { get; }
Public Shared ReadOnly Property RemoteUserID As String
    Get
static member RemoteUserID : string with get

GSF.Identity.UserInfo.get_RemoteUserID = function();

public:
static property String^ RemoteUserID {
    String^ get ();
}

Property Value

Type: String
Remarks
The LoginID returned is that of the remote user accessing the web application. This is available only if the virtual directory hosting the web application is configured to use "Integrated Windows Authentication".
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.RemoteUserInfo Property

Grid Solutions Framework UserInfoRemoteUserInfo Property
Gets the UserInfo object for the RemoteUserID.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UserInfo RemoteUserInfo { get; }
Public Shared ReadOnly Property RemoteUserInfo As UserInfo
    Get
static member RemoteUserInfo : UserInfo with get

GSF.Identity.UserInfo.get_RemoteUserInfo = function();

public:
static property UserInfo^ RemoteUserInfo {
    UserInfo^ get ();
}

Property Value

Type: UserInfo
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.SettingsCategory Property

Grid Solutions Framework UserInfoSettingsCategory Property
Gets or sets the category under which the settings of UserInfo object are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SettingsCategory { get; set; }
Public Property SettingsCategory As String
    Get
    Set
abstract SettingsCategory : string with get, set
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Telephone Property

Grid Solutions Framework UserInfoTelephone Property
Gets the Telephone Number of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Telephone { get; }
Public ReadOnly Property Telephone As String
    Get
member Telephone : string with get

function get_Telephone();

public:
property String^ Telephone {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "telephoneNumber" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Title Property

Grid Solutions Framework UserInfoTitle Property
Gets the Title of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
member Title : string with get

function get_Title();

public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "title" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.UserAccountControl Property

Grid Solutions Framework UserInfoUserAccountControl Property
Gets the account control information of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int UserAccountControl { get; }
Public ReadOnly Property UserAccountControl As Integer
    Get
member UserAccountControl : int with get

function get_UserAccountControl();

public:
property int UserAccountControl {
    int get ();
}

Property Value

Type: Int32
Exceptions
Exception | Condition
SecurityException | User account control information cannot be obtained, may not have needed rights.
InvalidOperationException | Unknown error. Invalid value returned when querying user account control.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.UserName Property

Grid Solutions Framework UserInfoUserName Property
Gets the user name of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string UserName { get; }
Public ReadOnly Property UserName As String
    Get
member UserName : string with get

function get_UserName();

public:
property String^ UserName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Webpage Property

Grid Solutions Framework UserInfoWebpage Property
Gets the web page address of the user.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Webpage { get; }
Public ReadOnly Property Webpage As String
    Get
member Webpage : string with get

function get_Webpage();

public:
property String^ Webpage {
    String^ get ();
}

Property Value

Type: String
Remarks
Returns the value retrieved for the "wWWHomePage" active directory property.
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo Events

Grid Solutions Framework UserInfo Events

The UserInfo type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed.
Top
See Also

Reference

UserInfo Class
GSF.Identity Namespace


UserInfo.Disposed Event

Grid Solutions Framework UserInfoDisposed Event
Occurs when the class has been disposed.

Namespace: GSF.Identity
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

UserInfo Class
GSF.Identity Namespace


GSF.Interop Namespace

Grid Solutions Framework GSF.Interop Namespace
Contains classes used to handle interoperability with older legacy applications.
Classes
 | Class | Description
Public class | IniFile | Represents a Windows INI style configuration file.
Public class | VBArrayDescriptor | Represents an old style Visual Basic array descriptor.
Public class | WindowsApi | Defines common Windows API constants, enumerations, structures and functions.
Public class | WindowsApiCRYPT_OID_INFO | Win32 CRYPT_OID_INFO class.
Public class | WindowsIniFile | Represents a Windows INI style configuration file.
Structures
 | Structure | Description
Public structure | WindowsApiCRYPTOAPI_BLOB | Win32 CRYPTOAPI_BLOB structure.
Public structure | WindowsApiLSA_OBJECT_ATTRIBUTES | Win32 LSA_OBJECT_ATTRIBUTES structure.
Public structure | WindowsApiLSA_UNICODE_STRING | Win32 LSA_UNICODE_STRING structure.
Public structure | WindowsApiLUID_AND_ATTRIBUTES | Win32 LUID_AND_ATTRIBUTES structure.
Public structure | WindowsApiPROCESS_INFORMATION | Win32 PROCESS_INFORMATION structure.
Public structure | WindowsApiSC_ACTION | Win32 SC_ACTION structure.
Public structure | WindowsApiSECURITY_ATTRIBUTES | Win32 SECURITY_ATTRIBUTES structure.
Public structure | WindowsApiSERVICE_DESCRIPTION | Win32 SERVICE_DESCRIPTION structure.
Public structure | WindowsApiSERVICE_FAILURE_ACTIONS | Win32 SERVICE_FAILURE_ACTIONS structure.
Public structure | WindowsApiSERVICE_FAILURE_ACTIONS_FLAG | Win32 SERVICE_FAILURE_ACTIONS_FLAG structure.
Public structure | WindowsApiSTARTUPINFO | Win32 STARTUPINFO structure.
Public structure | WindowsApiTOKEN_PRIVILEGES | Win32 TOKEN_PRIVILEGES structure.
Interfaces
 | Interface | Description
Public interface | IIniFile | Represents an interface for common INI functions.
Enumerations
 | Enumeration | Description
Public enumeration | WindowsApiCreationFlags | Win32 CreationFlags enumeration.
Public enumeration | WindowsApiLogonFlags | Win32 LogonFlags enumeration.
Public enumeration | WindowsApiLsaAccess | LSA API policy access enumeration.
Public enumeration | WindowsApiProcessAccessTypes | Win32 ProcessAccessTypes enumeration.
Public enumeration | WindowsApiSC_ACTION_TYPE | Win32 SC_ACTION_TYPE enumeration.
Public enumeration | WindowsApiSECURITY_IMPERSONATION_LEVEL | Win32 SECURITY_IMPERSONATION_LEVEL enumeration.
Public enumeration | WindowsApiShutdownReason | Win32 ShutdownReason enumeration.
Public enumeration | WindowsApiTOKEN_ELEVATION_TYPE | Win32 TOKEN_ELEVATION_TYPE enumeration.
Public enumeration | WindowsApiTOKEN_INFORMATION_CLASS | Win32 TOKEN_INFORMATION_CLASS enumeration.
Public enumeration | WindowsApiTOKEN_TYPE | Win32 TOKEN_TYPE enumeration.


IIniFile Interface

Grid Solutions Framework IIniFile Interface
Represents an interface for common INI functions.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IIniFile
Public Interface IIniFile
type IIniFile =  interface end
GSF.Interop.IIniFile = function();
GSF.Interop.IIniFile.createInterface('GSF.Interop.IIniFile');
public interface class IIniFile

The IIniFile type exposes the following members.

Methods
 | Name | Description
Public method | GetSectionKeys | Gets an array of keys from the specified section in the INI file.
Public method | GetSectionNames | Gets an array of that section names that exist in the INI file.
Top
Properties
 | Name | Description
Public property | FileName | File name of the INI file.
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

GSF.Interop Namespace


IIniFile Methods

Grid Solutions Framework IIniFile Methods

The IIniFile type exposes the following members.

Methods
 | Name | Description
Public method | GetSectionKeys | Gets an array of keys from the specified section in the INI file.
Public method | GetSectionNames | Gets an array of that section names that exist in the INI file.
Top
See Also

Reference

IIniFile Interface
GSF.Interop Namespace


IIniFile.GetSectionKeys Method

Grid Solutions Framework IIniFileGetSectionKeys Method
Gets an array of keys from the specified section in the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string[] GetSectionKeys(
    string section
)
Function GetSectionKeys (
    section As String
) As String()
abstract GetSectionKeys :
        section : string -> string[]

function GetSectionKeys(section);
array<String^>^ GetSectionKeys(
    String^ section
)

Parameters

section
Type: SystemString
Section to retrieve keys from.

Return Value

Type: String
Array of String keys from the specified section of the INI file.
See Also

Reference

IIniFile Interface
GSF.Interop Namespace


IIniFile.GetSectionNames Method

Grid Solutions Framework IIniFileGetSectionNames Method
Gets an array of that section names that exist in the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string[] GetSectionNames()
Function GetSectionNames As String()
abstract GetSectionNames : unit -> string[]

function GetSectionNames();
array<String^>^ GetSectionNames()

Return Value

Type: String
Array of String section names from the INI file.
See Also

Reference

IIniFile Interface
GSF.Interop Namespace


IIniFile Properties

Grid Solutions Framework IIniFile Properties

The IIniFile type exposes the following members.

Properties
 | Name | Description
Public property | FileName | File name of the INI file.
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

IIniFile Interface
GSF.Interop Namespace


IIniFile.FileName Property

Grid Solutions Framework IIniFileFileName Property
File name of the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string FileName { get; set; }
Property FileName As String
    Get
    Set
abstract FileName : string with get, set

function get_FileName();
function set_FileName(value);
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IIniFile Interface
GSF.Interop Namespace


IIniFile.Item Property

Grid Solutions Framework IIniFileItem Property
Overload List
 | Name | Description
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

IIniFile Interface
GSF.Interop Namespace


IIniFile.Item Property (String, String)

Grid Solutions Framework IIniFileItem Property (String, String)
Gets or sets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string this[
    string section,
    string entry
] { set; }
WriteOnly Default Property Item (
    section As String,
    entry As String
) As String
    Set
abstract Item : string with set

function set_Item(value);
property String^ default[String^ section, String^ entry] {
    void set (String^ section, String^ entry, String^ value);
}

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.

Property Value

Type: String
The new key value to store in the INI file.

Return Value

Type: String
Value of key.
Remarks
This is the default member of this class.
See Also

Reference

IIniFile Interface
Item Overload
GSF.Interop Namespace


IIniFile.Item Property (String, String, String)

Grid Solutions Framework IIniFileItem Property (String, String, String)
Gets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string this[
    string section,
    string entry,
    string defaultValue
] { get; }
ReadOnly Default Property Item (
    section As String,
    entry As String,
    defaultValue As String
) As String
    Get
abstract Item : string with get

function get_Item(section, entry, defaultValue);

property String^ default[String^ section, String^ entry, String^ defaultValue] {
    String^ get (String^ section, String^ entry, String^ defaultValue);
}

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.
defaultValue
Type: SystemString
Default value of key.

Return Value

Type: String
Value of key.
Remarks
This is the default member of this class.
See Also

Reference

IIniFile Interface
Item Overload
GSF.Interop Namespace


IniFile Class

Grid Solutions Framework IniFile Class
Represents a Windows INI style configuration file.
Inheritance Hierarchy
SystemObject
GSF.InteropIniFile

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IniFile
Public Class IniFile
type IniFile =  class end
GSF.Interop.IniFile = function();

Type.createClass(
    'GSF.Interop.IniFile');
public ref class IniFile

The IniFile type exposes the following members.

Constructors
 | Name | Description
Public method | IniFile | Creates a new IniFile.
Public method | IniFile(String) | Creates a new IniFile using the specified INI file name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyValue(String, String) | Gets the value of the specified key.
Public method | GetKeyValue(String, String, String) | Gets the value of the specified key.
Public method | GetSectionKeys | Gets an array of keys from the specified section in the INI file.
Public method | GetSectionNames | Gets an array of that section names that exist in the INI file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetKeyValue | Sets the value of the specified key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | FileName | File name of the INI file.
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

GSF.Interop Namespace


IniFile Constructor

Grid Solutions Framework IniFile Constructor
Overload List
 | Name | Description
Public method | IniFile | Creates a new IniFile.
Public method | IniFile(String) | Creates a new IniFile using the specified INI file name.
Top
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile Constructor

Grid Solutions Framework IniFile Constructor
Creates a new IniFile.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IniFile()
Public Sub New
new : unit -> IniFile
GSF.Interop.IniFile = function();
public:
IniFile()
Remarks
INI file name defaults to "Win.ini" - change using FileName property.
See Also

Reference

IniFile Class
IniFile Overload
GSF.Interop Namespace


IniFile Constructor (String)

Grid Solutions Framework IniFile Constructor (String)
Creates a new IniFile using the specified INI file name.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IniFile(
    string fileName
)
Public Sub New (
    fileName As String
)
new :
        fileName : string -> IniFile
GSF.Interop.IniFile = function(fileName);
public:
IniFile(
    String^ fileName
)

Parameters

fileName
Type: SystemString
Specified INI file name to use.
See Also

Reference

IniFile Class
IniFile Overload
GSF.Interop Namespace


IniFile Methods

Grid Solutions Framework IniFile Methods

The IniFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetKeyValue(String, String) | Gets the value of the specified key.
Public method | GetKeyValue(String, String, String) | Gets the value of the specified key.
Public method | GetSectionKeys | Gets an array of keys from the specified section in the INI file.
Public method | GetSectionNames | Gets an array of that section names that exist in the INI file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetKeyValue | Sets the value of the specified key.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile.GetKeyValue Method

Grid Solutions Framework IniFileGetKeyValue Method
Overload List
 | Name | Description
Public method | GetKeyValue(String, String) | Gets the value of the specified key.
Public method | GetKeyValue(String, String, String) | Gets the value of the specified key.
Top
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile.GetKeyValue Method (String, String)

Grid Solutions Framework IniFileGetKeyValue Method (String, String)
Gets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetKeyValue(
    string section,
    string entry
)
Public Function GetKeyValue (
    section As String,
    entry As String
) As String
member GetKeyValue :
        section : string *
        entry : string -> string

function GetKeyValue(section, entry);
public:
String^ GetKeyValue(
    String^ section,
    String^ entry
)

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.

Return Value

Type: String
Value of key.
See Also

Reference

IniFile Class
GetKeyValue Overload
GSF.Interop Namespace


IniFile.GetKeyValue Method (String, String, String)

Grid Solutions Framework IniFileGetKeyValue Method (String, String, String)
Gets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetKeyValue(
    string section,
    string entry,
    string defaultValue
)
Public Function GetKeyValue (
    section As String,
    entry As String,
    defaultValue As String
) As String
member GetKeyValue :
        section : string *
        entry : string *
        defaultValue : string -> string

function GetKeyValue(section, entry, defaultValue);
public:
String^ GetKeyValue(
    String^ section,
    String^ entry,
    String^ defaultValue
)

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.
defaultValue
Type: SystemString
Default value of key.

Return Value

Type: String
Value of key.
See Also

Reference

IniFile Class
GetKeyValue Overload
GSF.Interop Namespace


IniFile.GetSectionKeys Method

Grid Solutions Framework IniFileGetSectionKeys Method
Gets an array of keys from the specified section in the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] GetSectionKeys(
    string section
)
Public Function GetSectionKeys (
    section As String
) As String()
member GetSectionKeys :
        section : string -> string[]

function GetSectionKeys(section);
public:
array<String^>^ GetSectionKeys(
    String^ section
)

Parameters

section
Type: SystemString
Section to retrieve keys from.

Return Value

Type: String
Array of String keys from the specified section of the INI file.
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile.GetSectionNames Method

Grid Solutions Framework IniFileGetSectionNames Method
Gets an array of that section names that exist in the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] GetSectionNames()
Public Function GetSectionNames As String()
member GetSectionNames : unit -> string[]

function GetSectionNames();
public:
array<String^>^ GetSectionNames()

Return Value

Type: String
Array of String section names from the INI file.
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile.SetKeyValue Method

Grid Solutions Framework IniFileSetKeyValue Method
Sets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetKeyValue(
    string section,
    string entry,
    string newValue
)
Public Sub SetKeyValue (
    section As String,
    entry As String,
    newValue As String
)
member SetKeyValue :
        section : string *
        entry : string *
        newValue : string -> unit

function SetKeyValue(section, entry, newValue);
public:
void SetKeyValue(
    String^ section,
    String^ entry,
    String^ newValue
)

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.
newValue
Type: SystemString
The new key value to store in the INI file.
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile Properties

Grid Solutions Framework IniFile Properties

The IniFile type exposes the following members.

Properties
 | Name | Description
Public property | FileName | File name of the INI file.
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile.FileName Property

Grid Solutions Framework IniFileFileName Property
File name of the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile.Item Property

Grid Solutions Framework IniFileItem Property
Overload List
 | Name | Description
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

IniFile Class
GSF.Interop Namespace


IniFile.Item Property (String, String)

Grid Solutions Framework IniFileItem Property (String, String)
Gets or sets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string this[
    string section,
    string entry
] { get; set; }
Public Default Property Item (
    section As String,
    entry As String
) As String
    Get
    Set
member Item : string with get, set

function get_Item(section, entry);
function set_Item(value);
public:
property String^ default[String^ section, String^ entry] {
    String^ get (String^ section, String^ entry);
    void set (String^ section, String^ entry, String^ value);
}

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.

Property Value

Type: String
The new key value to store in the INI file.

Return Value

Type: String
Value of key.
Remarks
This is the default member of this class.
See Also

Reference

IniFile Class
Item Overload
GSF.Interop Namespace


IniFile.Item Property (String, String, String)

Grid Solutions Framework IniFileItem Property (String, String, String)
Gets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string this[
    string section,
    string entry,
    string defaultValue
] { get; }
Public ReadOnly Default Property Item (
    section As String,
    entry As String,
    defaultValue As String
) As String
    Get
member Item : string with get

function get_Item(section, entry, defaultValue);

public:
property String^ default[String^ section, String^ entry, String^ defaultValue] {
    String^ get (String^ section, String^ entry, String^ defaultValue);
}

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.
defaultValue
Type: SystemString
Default value of key.

Return Value

Type: String
Value of key.
Remarks
This is the default member of this class.
See Also

Reference

IniFile Class
Item Overload
GSF.Interop Namespace


VBArrayDescriptor Class

Grid Solutions Framework VBArrayDescriptor Class
Represents an old style Visual Basic array descriptor.
Inheritance Hierarchy
SystemObject
GSF.InteropVBArrayDescriptor

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class VBArrayDescriptor : ISupportBinaryImage
Public NotInheritable Class VBArrayDescriptor
    Implements ISupportBinaryImage
[<SealedAttribute>]
type VBArrayDescriptor =
    class
        interface ISupportBinaryImage
    end
GSF.Interop.VBArrayDescriptor = function();

Type.createClass(
    'GSF.Interop.VBArrayDescriptor',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class VBArrayDescriptor sealed : ISupportBinaryImage

The VBArrayDescriptor type exposes the following members.

Constructors
 | Name | Description
Public method | VBArrayDescriptor | Initializes a new instance of the VBArrayDescriptor class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | OneBasedOneDimensionalArray | Returns a VBArrayDescriptor object for a one dimensional array with one-based index.
 | OneBasedTwoDimensionalArray | Returns a VBArrayDescriptor object for a two dimensional array with one-based index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ZeroBasedOneDimensionalArray | Returns a VBArrayDescriptor object for a one dimensional array with zero-based index.
 | ZeroBasedTwoDimensionalArray | Returns a VBArrayDescriptor object for a two dimensional array with zero-based index.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of serialized VBArrayDescriptor.
Top
Remarks
This class is used to mimic the binary array descriptor used when an array is serialized into a file using older Visual Basic applications (VB 6 and prior), this way old VB apps can still deserialize an array stored in a file written by a .NET application and vice versa.
See Also

Reference

GSF.Interop Namespace


VBArrayDescriptor Constructor

Grid Solutions Framework VBArrayDescriptor Constructor
Initializes a new instance of the VBArrayDescriptor class.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public VBArrayDescriptor(
    int[] arrayLengths,
    int[] arrayLowerBounds
)
Public Sub New (
    arrayLengths As Integer(),
    arrayLowerBounds As Integer()
)
new :
        arrayLengths : int[] *
        arrayLowerBounds : int[] -> VBArrayDescriptor
GSF.Interop.VBArrayDescriptor = function(arrayLengths, arrayLowerBounds);
public:
VBArrayDescriptor(
    array<int>^ arrayLengths,
    array<int>^ arrayLowerBounds
)

Parameters

arrayLengths
Type: SystemInt32
Length of array per dimension.
arrayLowerBounds
Type: SystemInt32
Lower bound of array per dimension.
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor Methods

Grid Solutions Framework VBArrayDescriptor Methods

The VBArrayDescriptor type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | OneBasedOneDimensionalArray | Returns a VBArrayDescriptor object for a one dimensional array with one-based index.
 | OneBasedTwoDimensionalArray | Returns a VBArrayDescriptor object for a two dimensional array with one-based index.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | ZeroBasedOneDimensionalArray | Returns a VBArrayDescriptor object for a one dimensional array with zero-based index.
 | ZeroBasedTwoDimensionalArray | Returns a VBArrayDescriptor object for a two dimensional array with zero-based index.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor.GenerateBinaryImage Method

Grid Solutions Framework VBArrayDescriptorGenerateBinaryImage Method
Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor.OneBasedOneDimensionalArray Method

Grid Solutions Framework VBArrayDescriptorOneBasedOneDimensionalArray Method
Returns a VBArrayDescriptor object for a one dimensional array with one-based index.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static VBArrayDescriptor OneBasedOneDimensionalArray(
    int arrayLength
)
Public Shared Function OneBasedOneDimensionalArray (
    arrayLength As Integer
) As VBArrayDescriptor
static member OneBasedOneDimensionalArray :
        arrayLength : int -> VBArrayDescriptor

GSF.Interop.VBArrayDescriptor.OneBasedOneDimensionalArray = function(arrayLength);
public:
static VBArrayDescriptor^ OneBasedOneDimensionalArray(
    int arrayLength
)

Parameters

arrayLength
Type: SystemInt32
Length of the array.

Return Value

Type: VBArrayDescriptor
A VBArrayDescriptor object.
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor.OneBasedTwoDimensionalArray Method

Grid Solutions Framework VBArrayDescriptorOneBasedTwoDimensionalArray Method
Returns a VBArrayDescriptor object for a two dimensional array with one-based index.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static VBArrayDescriptor OneBasedTwoDimensionalArray(
    int dimensionOneLength,
    int dimensionTwoLength
)
Public Shared Function OneBasedTwoDimensionalArray (
    dimensionOneLength As Integer,
    dimensionTwoLength As Integer
) As VBArrayDescriptor
static member OneBasedTwoDimensionalArray :
        dimensionOneLength : int *
        dimensionTwoLength : int -> VBArrayDescriptor

GSF.Interop.VBArrayDescriptor.OneBasedTwoDimensionalArray = function(dimensionOneLength, dimensionTwoLength);
public:
static VBArrayDescriptor^ OneBasedTwoDimensionalArray(
    int dimensionOneLength,
    int dimensionTwoLength
)

Parameters

dimensionOneLength
Type: SystemInt32
Length of array in dimension one.
dimensionTwoLength
Type: SystemInt32
Length of array in dimension two.

Return Value

Type: VBArrayDescriptor
A VBArrayDescriptor object.
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor.ZeroBasedOneDimensionalArray Method

Grid Solutions Framework VBArrayDescriptorZeroBasedOneDimensionalArray Method
Returns a VBArrayDescriptor object for a one dimensional array with zero-based index.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static VBArrayDescriptor ZeroBasedOneDimensionalArray(
    int arrayLength
)
Public Shared Function ZeroBasedOneDimensionalArray (
    arrayLength As Integer
) As VBArrayDescriptor
static member ZeroBasedOneDimensionalArray :
        arrayLength : int -> VBArrayDescriptor

GSF.Interop.VBArrayDescriptor.ZeroBasedOneDimensionalArray = function(arrayLength);
public:
static VBArrayDescriptor^ ZeroBasedOneDimensionalArray(
    int arrayLength
)

Parameters

arrayLength
Type: SystemInt32
Length of the array.

Return Value

Type: VBArrayDescriptor
A VBArrayDescriptor object.
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor.ZeroBasedTwoDimensionalArray Method

Grid Solutions Framework VBArrayDescriptorZeroBasedTwoDimensionalArray Method
Returns a VBArrayDescriptor object for a two dimensional array with zero-based index.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static VBArrayDescriptor ZeroBasedTwoDimensionalArray(
    int dimensionOneLength,
    int dimensionTwoLength
)
Public Shared Function ZeroBasedTwoDimensionalArray (
    dimensionOneLength As Integer,
    dimensionTwoLength As Integer
) As VBArrayDescriptor
static member ZeroBasedTwoDimensionalArray :
        dimensionOneLength : int *
        dimensionTwoLength : int -> VBArrayDescriptor

GSF.Interop.VBArrayDescriptor.ZeroBasedTwoDimensionalArray = function(dimensionOneLength, dimensionTwoLength);
public:
static VBArrayDescriptor^ ZeroBasedTwoDimensionalArray(
    int dimensionOneLength,
    int dimensionTwoLength
)

Parameters

dimensionOneLength
Type: SystemInt32
Length of array in dimension one.
dimensionTwoLength
Type: SystemInt32
Length of array in dimension two.

Return Value

Type: VBArrayDescriptor
A VBArrayDescriptor object.
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor Properties

Grid Solutions Framework VBArrayDescriptor Properties

The VBArrayDescriptor type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of serialized VBArrayDescriptor.
Top
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


VBArrayDescriptor.BinaryLength Property

Grid Solutions Framework VBArrayDescriptorBinaryLength Property
Gets the length of serialized VBArrayDescriptor.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

VBArrayDescriptor Class
GSF.Interop Namespace


WindowsApi Class

Grid Solutions Framework WindowsApi Class
Defines common Windows API constants, enumerations, structures and functions.
Inheritance Hierarchy
SystemObject
GSF.InteropWindowsApi

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class WindowsApi
Public NotInheritable Class WindowsApi
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WindowsApi =  class end
GSF.Interop.WindowsApi = function();

Type.createClass(
    'GSF.Interop.WindowsApi');
public ref class WindowsApi abstract sealed

The WindowsApi type exposes the following members.

Methods
Name | Description
AdjustTokenPrivileges | Win32 AdjustTokenPrivileges function.
ChangeServiceConfig2(IntPtr, Int32, WindowsApiSERVICE_DESCRIPTION) | Win32 ChangeServiceConfig2 function.
ChangeServiceConfig2(IntPtr, Int32, WindowsApiSERVICE_FAILURE_ACTIONS_FLAG) | Win32 ChangeServiceConfig2 function.
ChangeServiceConfig2(IntPtr, Int32, IntPtr) | Win32 ChangeServiceConfig2 function.
CloseHandle | Win32 CloseHandle function.
CloseServiceHandle | Win32 CloseServiceHandle function.
CreateProcessWithTokenW | Win32 CreateProcessWithTokenW function.
CryptFindOIDInfo | Win32 CryptFindOIDInfo function.
CryptRegisterOIDInfo | Win32 CryptRegisterOIDInfo function.
CryptUnregisterOIDInfo | Win32 CryptUnregisterOIDInfo function.
DuplicateToken | Win32 DuplicateToken function.
DuplicateTokenEx(IntPtr, UInt32, WindowsApiSECURITY_ATTRIBUTES, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr) | Win32 DuplicateTokenEx function.
DuplicateTokenEx(IntPtr, UInt32, IntPtr, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr) | Win32 DuplicateTokenEx function.
FormatMessage | Win32 FormatMessage function.
FreeSid | Win32 FreeSid function.
GetCurrentProcess | Win32 GetCurrentProcess function.
GetErrorMessage | Formats and returns a .NET string containing the Windows API level error message corresponding to the specified error code.
GetLastError | Win32 GetLastError function.
GetLastErrorMessage | Formats and returns a .NET string containing the Windows API level error message from the last Win32 call.
GetShellWindow | Win32 GetShellWindow function.
GetTokenInformation(IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, WindowsApiTOKEN_ELEVATION_TYPE, UInt32, UInt32) | Win32 GetTokenInformation function.
GetTokenInformation(IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, UInt32, UInt32, UInt32) | Win32 GetTokenInformation function.
GetWindowThreadProcessId | Win32 GetWindowThreadProcessId function.
InitiateSystemShutdownEx | Win32 InitiateSystemShutdownEx function.
IsWow64Process | Win32 IsWow64Process function.
LockServiceDatabase | Win32 LockServiceDatabase function.
LogonUser | Win32 LogonUser function.
LookupAccountName | Win32 LookupAccountName function.
LookupPrivilegeValue | Win32 LookupPrivilegeValue function.
LsaAddAccountRights | Win32 LsaAddAccountRights function.
LsaClose | Win32 LsaClose function.
LsaOpenPolicy | Win32 LsaOpenPolicy function.
OpenProcess | Win32 OpenProcess function.
OpenProcessToken | Win32 OpenProcessToken function.
OpenSCManager | Win32 OpenSCManager function.
OpenService | Win32 OpenService function.
UnlockServiceDatabase | Win32 UnlockServiceDatabase function.
Top
Fields
Name | Description
CRYPT_INSTALL_OID_INFO_BEFORE_FLAG |
CRYPT_OID_DISABLE_SEARCH_DS_FLAG |
CRYPT_OID_INFO_NAME_KEY |
CRYPT_OID_INFO_OID_KEY |
ERROR_ACCESS_DENIED | Access is denied.
LOGON32_LOGON_INTERACTIVE | This logon type is intended for users who will be interactively using the computer, such as a user being logged on by a terminal server, remote shell, or similar process. This logon type has the additional expense of caching logon information for disconnected operations; therefore, it is inappropriate for some client/server applications, such as a mail server.
LOGON32_LOGON_NETWORK | This logon type is intended for high performance servers to authenticate plaintext passwords. The LogonUserEx function does not cache credentials for this logon type.
LOGON32_PROVIDER_DEFAULT | Use the standard logon provider for the system. The default security provider is NTLM.
SE_ASSIGNPRIMARYTOKEN_NAME |
SE_AUDIT_NAME |
SE_BACKUP_NAME |
SE_CHANGE_NOTIFY_NAME |
SE_CREATE_GLOBAL_NAME |
SE_CREATE_PAGEFILE_NAME |
SE_CREATE_PERMANENT_NAME |
SE_CREATE_SYMBOLIC_LINK_NAME |
SE_CREATE_TOKEN_NAME |
SE_DEBUG_NAME |
SE_ENABLE_DELEGATION_NAME |
SE_IMPERSONATE_NAME |
SE_INC_BASE_PRIORITY_NAME |
SE_INC_WORKING_SET_NAME |
SE_INCREASE_QUOTA_NAME |
SE_LOAD_DRIVER_NAME |
SE_LOCK_MEMORY_NAME |
SE_MACHINE_ACCOUNT_NAME |
SE_MANAGE_VOLUME_NAME |
SE_PRIVILEGE_ENABLED |
SE_PRIVILEGE_ENABLED_BY_DEFAULT |
SE_PRIVILEGE_REMOVED |
SE_PRIVILEGE_USED_FOR_ACCESS |
SE_PROF_SINGLE_PROCESS_NAME |
SE_RELABEL_NAME |
SE_REMOTE_SHUTDOWN_NAME |
SE_RESTORE_NAME |
SE_SECURITY_NAME |
SE_SHUTDOWN_NAME |
SE_SYNC_AGENT_NAME |
SE_SYSTEM_ENVIRONMENT_NAME |
SE_SYSTEM_PROFILE_NAME |
SE_SYSTEMTIME_NAME |
SE_TAKE_OWNERSHIP_NAME |
SE_TCB_NAME |
SE_TIME_ZONE_NAME |
SE_TRUSTED_CREDMAN_ACCESS_NAME |
SE_UNDOCK_NAME |
SE_UNSOLICITED_INPUT_NAME |
SECURITY_IMPERSONATION | Impersonate a client at the impersonation level.
STANDARD_RIGHTS_READ |
STANDARD_RIGHTS_REQUIRED |
TOKEN_ADJUST_DEFAULT |
TOKEN_ADJUST_GROUPS |
TOKEN_ADJUST_PRIVILEGES |
TOKEN_ADJUST_SESSIONID |
TOKEN_ALL_ACCESS |
TOKEN_ASSIGN_PRIMARY |
TOKEN_DUPLICATE |
TOKEN_IMPERSONATE |
TOKEN_QUERY |
TOKEN_QUERY_SOURCE |
TOKEN_READ |
Top
See Also

Reference

GSF.Interop Namespace


WindowsApi Fields

Grid Solutions Framework WindowsApi Fields

The WindowsApi type exposes the following members.

Fields
Name | Description
CRYPT_INSTALL_OID_INFO_BEFORE_FLAG |
CRYPT_OID_DISABLE_SEARCH_DS_FLAG |
CRYPT_OID_INFO_NAME_KEY |
CRYPT_OID_INFO_OID_KEY |
ERROR_ACCESS_DENIED | Access is denied.
LOGON32_LOGON_INTERACTIVE | This logon type is intended for users who will be interactively using the computer, such as a user being logged on by a terminal server, remote shell, or similar process. This logon type has the additional expense of caching logon information for disconnected operations; therefore, it is inappropriate for some client/server applications, such as a mail server.
LOGON32_LOGON_NETWORK | This logon type is intended for high performance servers to authenticate plaintext passwords. The LogonUserEx function does not cache credentials for this logon type.
LOGON32_PROVIDER_DEFAULT | Use the standard logon provider for the system. The default security provider is NTLM.
SE_ASSIGNPRIMARYTOKEN_NAME |
SE_AUDIT_NAME |
SE_BACKUP_NAME |
SE_CHANGE_NOTIFY_NAME |
SE_CREATE_GLOBAL_NAME |
SE_CREATE_PAGEFILE_NAME |
SE_CREATE_PERMANENT_NAME |
SE_CREATE_SYMBOLIC_LINK_NAME |
SE_CREATE_TOKEN_NAME |
SE_DEBUG_NAME |
SE_ENABLE_DELEGATION_NAME |
SE_IMPERSONATE_NAME |
SE_INC_BASE_PRIORITY_NAME |
SE_INC_WORKING_SET_NAME |
SE_INCREASE_QUOTA_NAME |
SE_LOAD_DRIVER_NAME |
SE_LOCK_MEMORY_NAME |
SE_MACHINE_ACCOUNT_NAME |
SE_MANAGE_VOLUME_NAME |
SE_PRIVILEGE_ENABLED |
SE_PRIVILEGE_ENABLED_BY_DEFAULT |
SE_PRIVILEGE_REMOVED |
SE_PRIVILEGE_USED_FOR_ACCESS |
SE_PROF_SINGLE_PROCESS_NAME |
SE_RELABEL_NAME |
SE_REMOTE_SHUTDOWN_NAME |
SE_RESTORE_NAME |
SE_SECURITY_NAME |
SE_SHUTDOWN_NAME |
SE_SYNC_AGENT_NAME |
SE_SYSTEM_ENVIRONMENT_NAME |
SE_SYSTEM_PROFILE_NAME |
SE_SYSTEMTIME_NAME |
SE_TAKE_OWNERSHIP_NAME |
SE_TCB_NAME |
SE_TIME_ZONE_NAME |
SE_TRUSTED_CREDMAN_ACCESS_NAME |
SE_UNDOCK_NAME |
SE_UNSOLICITED_INPUT_NAME |
SECURITY_IMPERSONATION | Impersonate a client at the impersonation level.
STANDARD_RIGHTS_READ |
STANDARD_RIGHTS_REQUIRED |
TOKEN_ADJUST_DEFAULT |
TOKEN_ADJUST_GROUPS |
TOKEN_ADJUST_PRIVILEGES |
TOKEN_ADJUST_SESSIONID |
TOKEN_ALL_ACCESS |
TOKEN_ASSIGN_PRIMARY |
TOKEN_DUPLICATE |
TOKEN_IMPERSONATE |
TOKEN_QUERY |
TOKEN_QUERY_SOURCE |
TOKEN_READ |
Top
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CRYPT_INSTALL_OID_INFO_BEFORE_FLAG Field

Grid Solutions Framework WindowsApiCRYPT_INSTALL_OID_INFO_BEFORE_FLAG Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_INSTALL_OID_INFO_BEFORE_FLAG"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int CRYPT_INSTALL_OID_INFO_BEFORE_FLAG
Public Const CRYPT_INSTALL_OID_INFO_BEFORE_FLAG As Integer
static val mutable CRYPT_INSTALL_OID_INFO_BEFORE_FLAG: int
var GSF.Interop.WindowsApi.CRYPT_INSTALL_OID_INFO_BEFORE_FLAG
public:
literal int CRYPT_INSTALL_OID_INFO_BEFORE_FLAG

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_DISABLE_SEARCH_DS_FLAG Field

Grid Solutions Framework WindowsApiCRYPT_OID_DISABLE_SEARCH_DS_FLAG Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_DISABLE_SEARCH_DS_FLAG"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint CRYPT_OID_DISABLE_SEARCH_DS_FLAG
Public Const CRYPT_OID_DISABLE_SEARCH_DS_FLAG As UInteger
static val mutable CRYPT_OID_DISABLE_SEARCH_DS_FLAG: uint32
var GSF.Interop.WindowsApi.CRYPT_OID_DISABLE_SEARCH_DS_FLAG
public:
literal unsigned int CRYPT_OID_DISABLE_SEARCH_DS_FLAG

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO_NAME_KEY Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFO_NAME_KEY Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO_NAME_KEY"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int CRYPT_OID_INFO_NAME_KEY
Public Const CRYPT_OID_INFO_NAME_KEY As Integer
static val mutable CRYPT_OID_INFO_NAME_KEY: int
var GSF.Interop.WindowsApi.CRYPT_OID_INFO_NAME_KEY
public:
literal int CRYPT_OID_INFO_NAME_KEY

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO_OID_KEY Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFO_OID_KEY Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO_OID_KEY"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int CRYPT_OID_INFO_OID_KEY
Public Const CRYPT_OID_INFO_OID_KEY As Integer
static val mutable CRYPT_OID_INFO_OID_KEY: int
var GSF.Interop.WindowsApi.CRYPT_OID_INFO_OID_KEY
public:
literal int CRYPT_OID_INFO_OID_KEY

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.ERROR_ACCESS_DENIED Field

Grid Solutions Framework WindowsApiERROR_ACCESS_DENIED Field
Access is denied.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ERROR_ACCESS_DENIED
Public Const ERROR_ACCESS_DENIED As Integer
static val mutable ERROR_ACCESS_DENIED: int
var GSF.Interop.WindowsApi.ERROR_ACCESS_DENIED
public:
literal int ERROR_ACCESS_DENIED

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LOGON32_LOGON_INTERACTIVE Field

Grid Solutions Framework WindowsApiLOGON32_LOGON_INTERACTIVE Field
This logon type is intended for users who will be interactively using the computer, such as a user being logged on by a terminal server, remote shell, or similar process. This logon type has the additional expense of caching logon information for disconnected operations; therefore, it is inappropriate for some client/server applications, such as a mail server.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int LOGON32_LOGON_INTERACTIVE
Public Const LOGON32_LOGON_INTERACTIVE As Integer
static val mutable LOGON32_LOGON_INTERACTIVE: int
var GSF.Interop.WindowsApi.LOGON32_LOGON_INTERACTIVE
public:
literal int LOGON32_LOGON_INTERACTIVE

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LOGON32_LOGON_NETWORK Field

Grid Solutions Framework WindowsApiLOGON32_LOGON_NETWORK Field
This logon type is intended for high performance servers to authenticate plaintext passwords. The LogonUserEx function does not cache credentials for this logon type.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int LOGON32_LOGON_NETWORK
Public Const LOGON32_LOGON_NETWORK As Integer
static val mutable LOGON32_LOGON_NETWORK: int
var GSF.Interop.WindowsApi.LOGON32_LOGON_NETWORK
public:
literal int LOGON32_LOGON_NETWORK

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LOGON32_PROVIDER_DEFAULT Field

Grid Solutions Framework WindowsApiLOGON32_PROVIDER_DEFAULT Field
Use the standard logon provider for the system. The default security provider is NTLM.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int LOGON32_PROVIDER_DEFAULT
Public Const LOGON32_PROVIDER_DEFAULT As Integer
static val mutable LOGON32_PROVIDER_DEFAULT: int
var GSF.Interop.WindowsApi.LOGON32_PROVIDER_DEFAULT
public:
literal int LOGON32_PROVIDER_DEFAULT

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_ASSIGNPRIMARYTOKEN_NAME Field

Grid Solutions Framework WindowsApiSE_ASSIGNPRIMARYTOKEN_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_ASSIGNPRIMARYTOKEN_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_ASSIGNPRIMARYTOKEN_NAME
Public Const SE_ASSIGNPRIMARYTOKEN_NAME As String
static val mutable SE_ASSIGNPRIMARYTOKEN_NAME: string
var GSF.Interop.WindowsApi.SE_ASSIGNPRIMARYTOKEN_NAME
public:
literal String^ SE_ASSIGNPRIMARYTOKEN_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_AUDIT_NAME Field

Grid Solutions Framework WindowsApiSE_AUDIT_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_AUDIT_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_AUDIT_NAME
Public Const SE_AUDIT_NAME As String
static val mutable SE_AUDIT_NAME: string
var GSF.Interop.WindowsApi.SE_AUDIT_NAME
public:
literal String^ SE_AUDIT_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_BACKUP_NAME Field

Grid Solutions Framework WindowsApiSE_BACKUP_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_BACKUP_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_BACKUP_NAME
Public Const SE_BACKUP_NAME As String
static val mutable SE_BACKUP_NAME: string
var GSF.Interop.WindowsApi.SE_BACKUP_NAME
public:
literal String^ SE_BACKUP_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_CHANGE_NOTIFY_NAME Field

Grid Solutions Framework WindowsApiSE_CHANGE_NOTIFY_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_CHANGE_NOTIFY_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_CHANGE_NOTIFY_NAME
Public Const SE_CHANGE_NOTIFY_NAME As String
static val mutable SE_CHANGE_NOTIFY_NAME: string
var GSF.Interop.WindowsApi.SE_CHANGE_NOTIFY_NAME
public:
literal String^ SE_CHANGE_NOTIFY_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_CREATE_GLOBAL_NAME Field

Grid Solutions Framework WindowsApiSE_CREATE_GLOBAL_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_CREATE_GLOBAL_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_CREATE_GLOBAL_NAME
Public Const SE_CREATE_GLOBAL_NAME As String
static val mutable SE_CREATE_GLOBAL_NAME: string
var GSF.Interop.WindowsApi.SE_CREATE_GLOBAL_NAME
public:
literal String^ SE_CREATE_GLOBAL_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_CREATE_PAGEFILE_NAME Field

Grid Solutions Framework WindowsApiSE_CREATE_PAGEFILE_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_CREATE_PAGEFILE_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_CREATE_PAGEFILE_NAME
Public Const SE_CREATE_PAGEFILE_NAME As String
static val mutable SE_CREATE_PAGEFILE_NAME: string
var GSF.Interop.WindowsApi.SE_CREATE_PAGEFILE_NAME
public:
literal String^ SE_CREATE_PAGEFILE_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_CREATE_PERMANENT_NAME Field

Grid Solutions Framework WindowsApiSE_CREATE_PERMANENT_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_CREATE_PERMANENT_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_CREATE_PERMANENT_NAME
Public Const SE_CREATE_PERMANENT_NAME As String
static val mutable SE_CREATE_PERMANENT_NAME: string
var GSF.Interop.WindowsApi.SE_CREATE_PERMANENT_NAME
public:
literal String^ SE_CREATE_PERMANENT_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_CREATE_SYMBOLIC_LINK_NAME Field

Grid Solutions Framework WindowsApiSE_CREATE_SYMBOLIC_LINK_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_CREATE_SYMBOLIC_LINK_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_CREATE_SYMBOLIC_LINK_NAME
Public Const SE_CREATE_SYMBOLIC_LINK_NAME As String
static val mutable SE_CREATE_SYMBOLIC_LINK_NAME: string
var GSF.Interop.WindowsApi.SE_CREATE_SYMBOLIC_LINK_NAME
public:
literal String^ SE_CREATE_SYMBOLIC_LINK_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_CREATE_TOKEN_NAME Field

Grid Solutions Framework WindowsApiSE_CREATE_TOKEN_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_CREATE_TOKEN_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_CREATE_TOKEN_NAME
Public Const SE_CREATE_TOKEN_NAME As String
static val mutable SE_CREATE_TOKEN_NAME: string
var GSF.Interop.WindowsApi.SE_CREATE_TOKEN_NAME
public:
literal String^ SE_CREATE_TOKEN_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_DEBUG_NAME Field

Grid Solutions Framework WindowsApiSE_DEBUG_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_DEBUG_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_DEBUG_NAME
Public Const SE_DEBUG_NAME As String
static val mutable SE_DEBUG_NAME: string
var GSF.Interop.WindowsApi.SE_DEBUG_NAME
public:
literal String^ SE_DEBUG_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_ENABLE_DELEGATION_NAME Field

Grid Solutions Framework WindowsApiSE_ENABLE_DELEGATION_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_ENABLE_DELEGATION_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_ENABLE_DELEGATION_NAME
Public Const SE_ENABLE_DELEGATION_NAME As String
static val mutable SE_ENABLE_DELEGATION_NAME: string
var GSF.Interop.WindowsApi.SE_ENABLE_DELEGATION_NAME
public:
literal String^ SE_ENABLE_DELEGATION_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_IMPERSONATE_NAME Field

Grid Solutions Framework WindowsApiSE_IMPERSONATE_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_IMPERSONATE_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_IMPERSONATE_NAME
Public Const SE_IMPERSONATE_NAME As String
static val mutable SE_IMPERSONATE_NAME: string
var GSF.Interop.WindowsApi.SE_IMPERSONATE_NAME
public:
literal String^ SE_IMPERSONATE_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_INC_BASE_PRIORITY_NAME Field

Grid Solutions Framework WindowsApiSE_INC_BASE_PRIORITY_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_INC_BASE_PRIORITY_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_INC_BASE_PRIORITY_NAME
Public Const SE_INC_BASE_PRIORITY_NAME As String
static val mutable SE_INC_BASE_PRIORITY_NAME: string
var GSF.Interop.WindowsApi.SE_INC_BASE_PRIORITY_NAME
public:
literal String^ SE_INC_BASE_PRIORITY_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_INC_WORKING_SET_NAME Field

Grid Solutions Framework WindowsApiSE_INC_WORKING_SET_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_INC_WORKING_SET_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_INC_WORKING_SET_NAME
Public Const SE_INC_WORKING_SET_NAME As String
static val mutable SE_INC_WORKING_SET_NAME: string
var GSF.Interop.WindowsApi.SE_INC_WORKING_SET_NAME
public:
literal String^ SE_INC_WORKING_SET_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_INCREASE_QUOTA_NAME Field

Grid Solutions Framework WindowsApiSE_INCREASE_QUOTA_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_INCREASE_QUOTA_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_INCREASE_QUOTA_NAME
Public Const SE_INCREASE_QUOTA_NAME As String
static val mutable SE_INCREASE_QUOTA_NAME: string
var GSF.Interop.WindowsApi.SE_INCREASE_QUOTA_NAME
public:
literal String^ SE_INCREASE_QUOTA_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_LOAD_DRIVER_NAME Field

Grid Solutions Framework WindowsApiSE_LOAD_DRIVER_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_LOAD_DRIVER_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_LOAD_DRIVER_NAME
Public Const SE_LOAD_DRIVER_NAME As String
static val mutable SE_LOAD_DRIVER_NAME: string
var GSF.Interop.WindowsApi.SE_LOAD_DRIVER_NAME
public:
literal String^ SE_LOAD_DRIVER_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_LOCK_MEMORY_NAME Field

Grid Solutions Framework WindowsApiSE_LOCK_MEMORY_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_LOCK_MEMORY_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_LOCK_MEMORY_NAME
Public Const SE_LOCK_MEMORY_NAME As String
static val mutable SE_LOCK_MEMORY_NAME: string
var GSF.Interop.WindowsApi.SE_LOCK_MEMORY_NAME
public:
literal String^ SE_LOCK_MEMORY_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_MACHINE_ACCOUNT_NAME Field

Grid Solutions Framework WindowsApiSE_MACHINE_ACCOUNT_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_MACHINE_ACCOUNT_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_MACHINE_ACCOUNT_NAME
Public Const SE_MACHINE_ACCOUNT_NAME As String
static val mutable SE_MACHINE_ACCOUNT_NAME: string
var GSF.Interop.WindowsApi.SE_MACHINE_ACCOUNT_NAME
public:
literal String^ SE_MACHINE_ACCOUNT_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_MANAGE_VOLUME_NAME Field

Grid Solutions Framework WindowsApiSE_MANAGE_VOLUME_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_MANAGE_VOLUME_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_MANAGE_VOLUME_NAME
Public Const SE_MANAGE_VOLUME_NAME As String
static val mutable SE_MANAGE_VOLUME_NAME: string
var GSF.Interop.WindowsApi.SE_MANAGE_VOLUME_NAME
public:
literal String^ SE_MANAGE_VOLUME_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_PRIVILEGE_ENABLED Field

Grid Solutions Framework WindowsApiSE_PRIVILEGE_ENABLED Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_PRIVILEGE_ENABLED"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint SE_PRIVILEGE_ENABLED
Public Const SE_PRIVILEGE_ENABLED As UInteger
static val mutable SE_PRIVILEGE_ENABLED: uint32
var GSF.Interop.WindowsApi.SE_PRIVILEGE_ENABLED
public:
literal unsigned int SE_PRIVILEGE_ENABLED

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_PRIVILEGE_ENABLED_BY_DEFAULT Field

Grid Solutions Framework WindowsApiSE_PRIVILEGE_ENABLED_BY_DEFAULT Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_PRIVILEGE_ENABLED_BY_DEFAULT"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint SE_PRIVILEGE_ENABLED_BY_DEFAULT
Public Const SE_PRIVILEGE_ENABLED_BY_DEFAULT As UInteger
static val mutable SE_PRIVILEGE_ENABLED_BY_DEFAULT: uint32
var GSF.Interop.WindowsApi.SE_PRIVILEGE_ENABLED_BY_DEFAULT
public:
literal unsigned int SE_PRIVILEGE_ENABLED_BY_DEFAULT

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_PRIVILEGE_REMOVED Field

Grid Solutions Framework WindowsApiSE_PRIVILEGE_REMOVED Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_PRIVILEGE_REMOVED"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint SE_PRIVILEGE_REMOVED
Public Const SE_PRIVILEGE_REMOVED As UInteger
static val mutable SE_PRIVILEGE_REMOVED: uint32
var GSF.Interop.WindowsApi.SE_PRIVILEGE_REMOVED
public:
literal unsigned int SE_PRIVILEGE_REMOVED

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_PRIVILEGE_USED_FOR_ACCESS Field

Grid Solutions Framework WindowsApiSE_PRIVILEGE_USED_FOR_ACCESS Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_PRIVILEGE_USED_FOR_ACCESS"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint SE_PRIVILEGE_USED_FOR_ACCESS
Public Const SE_PRIVILEGE_USED_FOR_ACCESS As UInteger
static val mutable SE_PRIVILEGE_USED_FOR_ACCESS: uint32
var GSF.Interop.WindowsApi.SE_PRIVILEGE_USED_FOR_ACCESS
public:
literal unsigned int SE_PRIVILEGE_USED_FOR_ACCESS

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_PROF_SINGLE_PROCESS_NAME Field

Grid Solutions Framework WindowsApiSE_PROF_SINGLE_PROCESS_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_PROF_SINGLE_PROCESS_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_PROF_SINGLE_PROCESS_NAME
Public Const SE_PROF_SINGLE_PROCESS_NAME As String
static val mutable SE_PROF_SINGLE_PROCESS_NAME: string
var GSF.Interop.WindowsApi.SE_PROF_SINGLE_PROCESS_NAME
public:
literal String^ SE_PROF_SINGLE_PROCESS_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_RELABEL_NAME Field

Grid Solutions Framework WindowsApiSE_RELABEL_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_RELABEL_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_RELABEL_NAME
Public Const SE_RELABEL_NAME As String
static val mutable SE_RELABEL_NAME: string
var GSF.Interop.WindowsApi.SE_RELABEL_NAME
public:
literal String^ SE_RELABEL_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_REMOTE_SHUTDOWN_NAME Field

Grid Solutions Framework WindowsApiSE_REMOTE_SHUTDOWN_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_REMOTE_SHUTDOWN_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_REMOTE_SHUTDOWN_NAME
Public Const SE_REMOTE_SHUTDOWN_NAME As String
static val mutable SE_REMOTE_SHUTDOWN_NAME: string
var GSF.Interop.WindowsApi.SE_REMOTE_SHUTDOWN_NAME
public:
literal String^ SE_REMOTE_SHUTDOWN_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_RESTORE_NAME Field

Grid Solutions Framework WindowsApiSE_RESTORE_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_RESTORE_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_RESTORE_NAME
Public Const SE_RESTORE_NAME As String
static val mutable SE_RESTORE_NAME: string
var GSF.Interop.WindowsApi.SE_RESTORE_NAME
public:
literal String^ SE_RESTORE_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_SECURITY_NAME Field

Grid Solutions Framework WindowsApiSE_SECURITY_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_SECURITY_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_SECURITY_NAME
Public Const SE_SECURITY_NAME As String
static val mutable SE_SECURITY_NAME: string
var GSF.Interop.WindowsApi.SE_SECURITY_NAME
public:
literal String^ SE_SECURITY_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_SHUTDOWN_NAME Field

Grid Solutions Framework WindowsApiSE_SHUTDOWN_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_SHUTDOWN_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_SHUTDOWN_NAME
Public Const SE_SHUTDOWN_NAME As String
static val mutable SE_SHUTDOWN_NAME: string
var GSF.Interop.WindowsApi.SE_SHUTDOWN_NAME
public:
literal String^ SE_SHUTDOWN_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_SYNC_AGENT_NAME Field

Grid Solutions Framework WindowsApiSE_SYNC_AGENT_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_SYNC_AGENT_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_SYNC_AGENT_NAME
Public Const SE_SYNC_AGENT_NAME As String
static val mutable SE_SYNC_AGENT_NAME: string
var GSF.Interop.WindowsApi.SE_SYNC_AGENT_NAME
public:
literal String^ SE_SYNC_AGENT_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_SYSTEM_ENVIRONMENT_NAME Field

Grid Solutions Framework WindowsApiSE_SYSTEM_ENVIRONMENT_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_SYSTEM_ENVIRONMENT_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_SYSTEM_ENVIRONMENT_NAME
Public Const SE_SYSTEM_ENVIRONMENT_NAME As String
static val mutable SE_SYSTEM_ENVIRONMENT_NAME: string
var GSF.Interop.WindowsApi.SE_SYSTEM_ENVIRONMENT_NAME
public:
literal String^ SE_SYSTEM_ENVIRONMENT_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_SYSTEM_PROFILE_NAME Field

Grid Solutions Framework WindowsApiSE_SYSTEM_PROFILE_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_SYSTEM_PROFILE_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_SYSTEM_PROFILE_NAME
Public Const SE_SYSTEM_PROFILE_NAME As String
static val mutable SE_SYSTEM_PROFILE_NAME: string
var GSF.Interop.WindowsApi.SE_SYSTEM_PROFILE_NAME
public:
literal String^ SE_SYSTEM_PROFILE_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_SYSTEMTIME_NAME Field

Grid Solutions Framework WindowsApiSE_SYSTEMTIME_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_SYSTEMTIME_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_SYSTEMTIME_NAME
Public Const SE_SYSTEMTIME_NAME As String
static val mutable SE_SYSTEMTIME_NAME: string
var GSF.Interop.WindowsApi.SE_SYSTEMTIME_NAME
public:
literal String^ SE_SYSTEMTIME_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_TAKE_OWNERSHIP_NAME Field

Grid Solutions Framework WindowsApiSE_TAKE_OWNERSHIP_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_TAKE_OWNERSHIP_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_TAKE_OWNERSHIP_NAME
Public Const SE_TAKE_OWNERSHIP_NAME As String
static val mutable SE_TAKE_OWNERSHIP_NAME: string
var GSF.Interop.WindowsApi.SE_TAKE_OWNERSHIP_NAME
public:
literal String^ SE_TAKE_OWNERSHIP_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_TCB_NAME Field

Grid Solutions Framework WindowsApiSE_TCB_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_TCB_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_TCB_NAME
Public Const SE_TCB_NAME As String
static val mutable SE_TCB_NAME: string
var GSF.Interop.WindowsApi.SE_TCB_NAME
public:
literal String^ SE_TCB_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_TIME_ZONE_NAME Field

Grid Solutions Framework WindowsApiSE_TIME_ZONE_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_TIME_ZONE_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_TIME_ZONE_NAME
Public Const SE_TIME_ZONE_NAME As String
static val mutable SE_TIME_ZONE_NAME: string
var GSF.Interop.WindowsApi.SE_TIME_ZONE_NAME
public:
literal String^ SE_TIME_ZONE_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_TRUSTED_CREDMAN_ACCESS_NAME Field

Grid Solutions Framework WindowsApiSE_TRUSTED_CREDMAN_ACCESS_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_TRUSTED_CREDMAN_ACCESS_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_TRUSTED_CREDMAN_ACCESS_NAME
Public Const SE_TRUSTED_CREDMAN_ACCESS_NAME As String
static val mutable SE_TRUSTED_CREDMAN_ACCESS_NAME: string
var GSF.Interop.WindowsApi.SE_TRUSTED_CREDMAN_ACCESS_NAME
public:
literal String^ SE_TRUSTED_CREDMAN_ACCESS_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_UNDOCK_NAME Field

Grid Solutions Framework WindowsApiSE_UNDOCK_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_UNDOCK_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_UNDOCK_NAME
Public Const SE_UNDOCK_NAME As String
static val mutable SE_UNDOCK_NAME: string
var GSF.Interop.WindowsApi.SE_UNDOCK_NAME
public:
literal String^ SE_UNDOCK_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SE_UNSOLICITED_INPUT_NAME Field

Grid Solutions Framework WindowsApiSE_UNSOLICITED_INPUT_NAME Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SE_UNSOLICITED_INPUT_NAME"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string SE_UNSOLICITED_INPUT_NAME
Public Const SE_UNSOLICITED_INPUT_NAME As String
static val mutable SE_UNSOLICITED_INPUT_NAME: string
var GSF.Interop.WindowsApi.SE_UNSOLICITED_INPUT_NAME
public:
literal String^ SE_UNSOLICITED_INPUT_NAME

Field Value

Type: String
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.SECURITY_IMPERSONATION Field

Grid Solutions Framework WindowsApiSECURITY_IMPERSONATION Field
Impersonate a client at the impersonation level.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int SECURITY_IMPERSONATION
Public Const SECURITY_IMPERSONATION As Integer
static val mutable SECURITY_IMPERSONATION: int
var GSF.Interop.WindowsApi.SECURITY_IMPERSONATION
public:
literal int SECURITY_IMPERSONATION

Field Value

Type: Int32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.STANDARD_RIGHTS_READ Field

Grid Solutions Framework WindowsApiSTANDARD_RIGHTS_READ Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STANDARD_RIGHTS_READ"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint STANDARD_RIGHTS_READ
Public Const STANDARD_RIGHTS_READ As UInteger
static val mutable STANDARD_RIGHTS_READ: uint32
var GSF.Interop.WindowsApi.STANDARD_RIGHTS_READ
public:
literal unsigned int STANDARD_RIGHTS_READ

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.STANDARD_RIGHTS_REQUIRED Field

Grid Solutions Framework WindowsApiSTANDARD_RIGHTS_REQUIRED Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STANDARD_RIGHTS_REQUIRED"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint STANDARD_RIGHTS_REQUIRED
Public Const STANDARD_RIGHTS_REQUIRED As UInteger
static val mutable STANDARD_RIGHTS_REQUIRED: uint32
var GSF.Interop.WindowsApi.STANDARD_RIGHTS_REQUIRED
public:
literal unsigned int STANDARD_RIGHTS_REQUIRED

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_ADJUST_DEFAULT Field

Grid Solutions Framework WindowsApiTOKEN_ADJUST_DEFAULT Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_ADJUST_DEFAULT"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_ADJUST_DEFAULT
Public Const TOKEN_ADJUST_DEFAULT As UInteger
static val mutable TOKEN_ADJUST_DEFAULT: uint32
var GSF.Interop.WindowsApi.TOKEN_ADJUST_DEFAULT
public:
literal unsigned int TOKEN_ADJUST_DEFAULT

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_ADJUST_GROUPS Field

Grid Solutions Framework WindowsApiTOKEN_ADJUST_GROUPS Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_ADJUST_GROUPS"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_ADJUST_GROUPS
Public Const TOKEN_ADJUST_GROUPS As UInteger
static val mutable TOKEN_ADJUST_GROUPS: uint32
var GSF.Interop.WindowsApi.TOKEN_ADJUST_GROUPS
public:
literal unsigned int TOKEN_ADJUST_GROUPS

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_ADJUST_PRIVILEGES Field

Grid Solutions Framework WindowsApiTOKEN_ADJUST_PRIVILEGES Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_ADJUST_PRIVILEGES"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_ADJUST_PRIVILEGES
Public Const TOKEN_ADJUST_PRIVILEGES As UInteger
static val mutable TOKEN_ADJUST_PRIVILEGES: uint32
var GSF.Interop.WindowsApi.TOKEN_ADJUST_PRIVILEGES
public:
literal unsigned int TOKEN_ADJUST_PRIVILEGES

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_ADJUST_SESSIONID Field

Grid Solutions Framework WindowsApiTOKEN_ADJUST_SESSIONID Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_ADJUST_SESSIONID"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_ADJUST_SESSIONID
Public Const TOKEN_ADJUST_SESSIONID As UInteger
static val mutable TOKEN_ADJUST_SESSIONID: uint32
var GSF.Interop.WindowsApi.TOKEN_ADJUST_SESSIONID
public:
literal unsigned int TOKEN_ADJUST_SESSIONID

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_ALL_ACCESS Field

Grid Solutions Framework WindowsApiTOKEN_ALL_ACCESS Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_ALL_ACCESS"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_ALL_ACCESS
Public Const TOKEN_ALL_ACCESS As UInteger
static val mutable TOKEN_ALL_ACCESS: uint32
var GSF.Interop.WindowsApi.TOKEN_ALL_ACCESS
public:
literal unsigned int TOKEN_ALL_ACCESS

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_ASSIGN_PRIMARY Field

Grid Solutions Framework WindowsApiTOKEN_ASSIGN_PRIMARY Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_ASSIGN_PRIMARY"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_ASSIGN_PRIMARY
Public Const TOKEN_ASSIGN_PRIMARY As UInteger
static val mutable TOKEN_ASSIGN_PRIMARY: uint32
var GSF.Interop.WindowsApi.TOKEN_ASSIGN_PRIMARY
public:
literal unsigned int TOKEN_ASSIGN_PRIMARY

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_DUPLICATE Field

Grid Solutions Framework WindowsApiTOKEN_DUPLICATE Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_DUPLICATE"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_DUPLICATE
Public Const TOKEN_DUPLICATE As UInteger
static val mutable TOKEN_DUPLICATE: uint32
var GSF.Interop.WindowsApi.TOKEN_DUPLICATE
public:
literal unsigned int TOKEN_DUPLICATE

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_IMPERSONATE Field

Grid Solutions Framework WindowsApiTOKEN_IMPERSONATE Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_IMPERSONATE"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_IMPERSONATE
Public Const TOKEN_IMPERSONATE As UInteger
static val mutable TOKEN_IMPERSONATE: uint32
var GSF.Interop.WindowsApi.TOKEN_IMPERSONATE
public:
literal unsigned int TOKEN_IMPERSONATE

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_QUERY Field

Grid Solutions Framework WindowsApiTOKEN_QUERY Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_QUERY"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_QUERY
Public Const TOKEN_QUERY As UInteger
static val mutable TOKEN_QUERY: uint32
var GSF.Interop.WindowsApi.TOKEN_QUERY
public:
literal unsigned int TOKEN_QUERY

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_QUERY_SOURCE Field

Grid Solutions Framework WindowsApiTOKEN_QUERY_SOURCE Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_QUERY_SOURCE"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_QUERY_SOURCE
Public Const TOKEN_QUERY_SOURCE As UInteger
static val mutable TOKEN_QUERY_SOURCE: uint32
var GSF.Interop.WindowsApi.TOKEN_QUERY_SOURCE
public:
literal unsigned int TOKEN_QUERY_SOURCE

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.TOKEN_READ Field

Grid Solutions Framework WindowsApiTOKEN_READ Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.TOKEN_READ"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TOKEN_READ
Public Const TOKEN_READ As UInteger
static val mutable TOKEN_READ: uint32
var GSF.Interop.WindowsApi.TOKEN_READ
public:
literal unsigned int TOKEN_READ

Field Value

Type: UInt32
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi Methods

Grid Solutions Framework WindowsApi Methods

The WindowsApi type exposes the following members.

Methods
Name | Description
AdjustTokenPrivileges | Win32 AdjustTokenPrivileges function.
ChangeServiceConfig2(IntPtr, Int32, WindowsApiSERVICE_DESCRIPTION) | Win32 ChangeServiceConfig2 function.
ChangeServiceConfig2(IntPtr, Int32, WindowsApiSERVICE_FAILURE_ACTIONS_FLAG) | Win32 ChangeServiceConfig2 function.
ChangeServiceConfig2(IntPtr, Int32, IntPtr) | Win32 ChangeServiceConfig2 function.
CloseHandle | Win32 CloseHandle function.
CloseServiceHandle | Win32 CloseServiceHandle function.
CreateProcessWithTokenW | Win32 CreateProcessWithTokenW function.
CryptFindOIDInfo | Win32 CryptFindOIDInfo function.
CryptRegisterOIDInfo | Win32 CryptRegisterOIDInfo function.
CryptUnregisterOIDInfo | Win32 CryptUnregisterOIDInfo function.
DuplicateToken | Win32 DuplicateToken function.
DuplicateTokenEx(IntPtr, UInt32, WindowsApiSECURITY_ATTRIBUTES, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr) | Win32 DuplicateTokenEx function.
DuplicateTokenEx(IntPtr, UInt32, IntPtr, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr) | Win32 DuplicateTokenEx function.
FormatMessage | Win32 FormatMessage function.
FreeSid | Win32 FreeSid function.
GetCurrentProcess | Win32 GetCurrentProcess function.
GetErrorMessage | Formats and returns a .NET string containing the Windows API level error message corresponding to the specified error code.
GetLastError | Win32 GetLastError function.
GetLastErrorMessage | Formats and returns a .NET string containing the Windows API level error message from the last Win32 call.
GetShellWindow | Win32 GetShellWindow function.
GetTokenInformation(IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, WindowsApiTOKEN_ELEVATION_TYPE, UInt32, UInt32) | Win32 GetTokenInformation function.
GetTokenInformation(IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, UInt32, UInt32, UInt32) | Win32 GetTokenInformation function.
GetWindowThreadProcessId | Win32 GetWindowThreadProcessId function.
InitiateSystemShutdownEx | Win32 InitiateSystemShutdownEx function.
IsWow64Process | Win32 IsWow64Process function.
LockServiceDatabase | Win32 LockServiceDatabase function.
LogonUser | Win32 LogonUser function.
LookupAccountName | Win32 LookupAccountName function.
LookupPrivilegeValue | Win32 LookupPrivilegeValue function.
LsaAddAccountRights | Win32 LsaAddAccountRights function.
LsaClose | Win32 LsaClose function.
LsaOpenPolicy | Win32 LsaOpenPolicy function.
OpenProcess | Win32 OpenProcess function.
OpenProcessToken | Win32 OpenProcessToken function.
OpenSCManager | Win32 OpenSCManager function.
OpenService | Win32 OpenService function.
UnlockServiceDatabase | Win32 UnlockServiceDatabase function.
Top
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.AdjustTokenPrivileges Method

Grid Solutions Framework WindowsApiAdjustTokenPrivileges Method
Win32 AdjustTokenPrivileges function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool AdjustTokenPrivileges(
    IntPtr TokenHandle,
    bool DisableAllPrivileges,
    ref WindowsApiTOKEN_PRIVILEGES NewState,
    int BufferLength,
    IntPtr PreviousState,
    ref int ReturnLength
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function AdjustTokenPrivileges (
    TokenHandle As IntPtr,
    DisableAllPrivileges As Boolean,
    ByRef NewState As WindowsApiTOKEN_PRIVILEGES,
    BufferLength As Integer,
    PreviousState As IntPtr,
    ByRef ReturnLength As Integer
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member AdjustTokenPrivileges :
        TokenHandle : IntPtr *
        DisableAllPrivileges : bool *
        NewState : WindowsApiTOKEN_PRIVILEGES byref *
        BufferLength : int *
        PreviousState : IntPtr *
        ReturnLength : int byref -> bool

GSF.Interop.WindowsApi.AdjustTokenPrivileges = function(TokenHandle, DisableAllPrivileges, NewState, BufferLength, PreviousState, ReturnLength);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool AdjustTokenPrivileges(
    IntPtr TokenHandle,
    bool DisableAllPrivileges,
    WindowsApiTOKEN_PRIVILEGES% NewState,
    int BufferLength,
    IntPtr PreviousState,
    int% ReturnLength
)

Parameters

TokenHandle
Type: SystemIntPtr

[Missing <param name="TokenHandle"/> documentation for "M:GSF.Interop.WindowsApi.AdjustTokenPrivileges(System.IntPtr,System.Boolean,GSF.Interop.WindowsApi.TOKEN_PRIVILEGES@,System.Int32,System.IntPtr,System.Int32@)"]

DisableAllPrivileges
Type: SystemBoolean

[Missing <param name="DisableAllPrivileges"/> documentation for "M:GSF.Interop.WindowsApi.AdjustTokenPrivileges(System.IntPtr,System.Boolean,GSF.Interop.WindowsApi.TOKEN_PRIVILEGES@,System.Int32,System.IntPtr,System.Int32@)"]

NewState
Type: GSF.InteropWindowsApiTOKEN_PRIVILEGES

[Missing <param name="NewState"/> documentation for "M:GSF.Interop.WindowsApi.AdjustTokenPrivileges(System.IntPtr,System.Boolean,GSF.Interop.WindowsApi.TOKEN_PRIVILEGES@,System.Int32,System.IntPtr,System.Int32@)"]

BufferLength
Type: SystemInt32

[Missing <param name="BufferLength"/> documentation for "M:GSF.Interop.WindowsApi.AdjustTokenPrivileges(System.IntPtr,System.Boolean,GSF.Interop.WindowsApi.TOKEN_PRIVILEGES@,System.Int32,System.IntPtr,System.Int32@)"]

PreviousState
Type: SystemIntPtr

[Missing <param name="PreviousState"/> documentation for "M:GSF.Interop.WindowsApi.AdjustTokenPrivileges(System.IntPtr,System.Boolean,GSF.Interop.WindowsApi.TOKEN_PRIVILEGES@,System.Int32,System.IntPtr,System.Int32@)"]

ReturnLength
Type: SystemInt32

[Missing <param name="ReturnLength"/> documentation for "M:GSF.Interop.WindowsApi.AdjustTokenPrivileges(System.IntPtr,System.Boolean,GSF.Interop.WindowsApi.TOKEN_PRIVILEGES@,System.Int32,System.IntPtr,System.Int32@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.AdjustTokenPrivileges(System.IntPtr,System.Boolean,GSF.Interop.WindowsApi.TOKEN_PRIVILEGES@,System.Int32,System.IntPtr,System.Int32@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.ChangeServiceConfig2 Method

Grid Solutions Framework WindowsApiChangeServiceConfig2 Method
Overload List
Name | Description
ChangeServiceConfig2(IntPtr, Int32, WindowsApiSERVICE_DESCRIPTION) | Win32 ChangeServiceConfig2 function.
ChangeServiceConfig2(IntPtr, Int32, WindowsApiSERVICE_FAILURE_ACTIONS_FLAG) | Win32 ChangeServiceConfig2 function.
ChangeServiceConfig2(IntPtr, Int32, IntPtr) | Win32 ChangeServiceConfig2 function.
Top
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.ChangeServiceConfig2 Method (IntPtr, Int32, WindowsApi.SERVICE_DESCRIPTION)

Grid Solutions Framework WindowsApiChangeServiceConfig2 Method (IntPtr, Int32, WindowsApiSERVICE_DESCRIPTION)
Win32 ChangeServiceConfig2 function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool ChangeServiceConfig2(
    IntPtr hService,
    int dwInfoLevel,
    ref WindowsApiSERVICE_DESCRIPTION lpInfo
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function ChangeServiceConfig2 (
    hService As IntPtr,
    dwInfoLevel As Integer,
    ByRef lpInfo As WindowsApiSERVICE_DESCRIPTION
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member ChangeServiceConfig2 :
        hService : IntPtr *
        dwInfoLevel : int *
        lpInfo : WindowsApiSERVICE_DESCRIPTION byref -> bool

GSF.Interop.WindowsApi.ChangeServiceConfig2 = function(hService, dwInfoLevel, lpInfo);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool ChangeServiceConfig2(
    IntPtr hService,
    int dwInfoLevel,
    WindowsApiSERVICE_DESCRIPTION% lpInfo
)

Parameters

hService
Type: SystemIntPtr

[Missing <param name="hService"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_DESCRIPTION@)"]

dwInfoLevel
Type: SystemInt32

[Missing <param name="dwInfoLevel"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_DESCRIPTION@)"]

lpInfo
Type: GSF.InteropWindowsApiSERVICE_DESCRIPTION

[Missing <param name="lpInfo"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_DESCRIPTION@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_DESCRIPTION@)"]

See Also

Reference

WindowsApi Class
ChangeServiceConfig2 Overload
GSF.Interop Namespace


WindowsApi.ChangeServiceConfig2 Method (IntPtr, Int32, WindowsApi.SERVICE_FAILURE_ACTIONS_FLAG)

Grid Solutions Framework WindowsApiChangeServiceConfig2 Method (IntPtr, Int32, WindowsApiSERVICE_FAILURE_ACTIONS_FLAG)
Win32 ChangeServiceConfig2 function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool ChangeServiceConfig2(
    IntPtr hService,
    int dwInfoLevel,
    ref WindowsApiSERVICE_FAILURE_ACTIONS_FLAG lpInfo
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function ChangeServiceConfig2 (
    hService As IntPtr,
    dwInfoLevel As Integer,
    ByRef lpInfo As WindowsApiSERVICE_FAILURE_ACTIONS_FLAG
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member ChangeServiceConfig2 :
        hService : IntPtr *
        dwInfoLevel : int *
        lpInfo : WindowsApiSERVICE_FAILURE_ACTIONS_FLAG byref -> bool

GSF.Interop.WindowsApi.ChangeServiceConfig2 = function(hService, dwInfoLevel, lpInfo);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool ChangeServiceConfig2(
    IntPtr hService,
    int dwInfoLevel,
    WindowsApiSERVICE_FAILURE_ACTIONS_FLAG% lpInfo
)

Parameters

hService
Type: SystemIntPtr

[Missing <param name="hService"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_FAILURE_ACTIONS_FLAG@)"]

dwInfoLevel
Type: SystemInt32

[Missing <param name="dwInfoLevel"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_FAILURE_ACTIONS_FLAG@)"]

lpInfo
Type: GSF.InteropWindowsApiSERVICE_FAILURE_ACTIONS_FLAG

[Missing <param name="lpInfo"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_FAILURE_ACTIONS_FLAG@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,GSF.Interop.WindowsApi.SERVICE_FAILURE_ACTIONS_FLAG@)"]

See Also

Reference

WindowsApi Class
ChangeServiceConfig2 Overload
GSF.Interop Namespace


WindowsApi.ChangeServiceConfig2 Method (IntPtr, Int32, IntPtr)

Grid Solutions Framework WindowsApiChangeServiceConfig2 Method (IntPtr, Int32, IntPtr)
Win32 ChangeServiceConfig2 function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool ChangeServiceConfig2(
    IntPtr hService,
    int dwInfoLevel,
    IntPtr lpInfo
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function ChangeServiceConfig2 (
    hService As IntPtr,
    dwInfoLevel As Integer,
    lpInfo As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member ChangeServiceConfig2 :
        hService : IntPtr *
        dwInfoLevel : int *
        lpInfo : IntPtr -> bool

GSF.Interop.WindowsApi.ChangeServiceConfig2 = function(hService, dwInfoLevel, lpInfo);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool ChangeServiceConfig2(
    IntPtr hService,
    int dwInfoLevel,
    IntPtr lpInfo
)

Parameters

hService
Type: SystemIntPtr

[Missing <param name="hService"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,System.IntPtr)"]

dwInfoLevel
Type: SystemInt32

[Missing <param name="dwInfoLevel"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,System.IntPtr)"]

lpInfo
Type: SystemIntPtr

[Missing <param name="lpInfo"/> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,System.IntPtr)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.ChangeServiceConfig2(System.IntPtr,System.Int32,System.IntPtr)"]

See Also

Reference

WindowsApi Class
ChangeServiceConfig2 Overload
GSF.Interop Namespace


WindowsApi.CloseHandle Method

Grid Solutions Framework WindowsApiCloseHandle Method
Win32 CloseHandle function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("kernel32.dll")]
public static bool CloseHandle(
    IntPtr hndl
)
<DllImportAttribute("kernel32.dll">]
Public Shared Function CloseHandle (
    hndl As IntPtr
) As Boolean
[<DllImportAttribute("kernel32.dll")>]
static member CloseHandle :
        hndl : IntPtr -> bool

GSF.Interop.WindowsApi.CloseHandle = function(hndl);
public:
[DllImportAttribute(L"kernel32.dll")]
static bool CloseHandle(
    IntPtr hndl
)

Parameters

hndl
Type: SystemIntPtr

[Missing <param name="hndl"/> documentation for "M:GSF.Interop.WindowsApi.CloseHandle(System.IntPtr)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.CloseHandle(System.IntPtr)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CloseServiceHandle Method

Grid Solutions Framework WindowsApiCloseServiceHandle Method
Win32 CloseServiceHandle function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool CloseServiceHandle(
    IntPtr hSCObject
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function CloseServiceHandle (
    hSCObject As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member CloseServiceHandle :
        hSCObject : IntPtr -> bool

GSF.Interop.WindowsApi.CloseServiceHandle = function(hSCObject);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool CloseServiceHandle(
    IntPtr hSCObject
)

Parameters

hSCObject
Type: SystemIntPtr

[Missing <param name="hSCObject"/> documentation for "M:GSF.Interop.WindowsApi.CloseServiceHandle(System.IntPtr)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.CloseServiceHandle(System.IntPtr)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CreateProcessWithTokenW Method

Grid Solutions Framework WindowsApiCreateProcessWithTokenW Method
Win32 CreateProcessWithTokenW function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32", CharSet = CharSet.Unicode, SetLastError = true)]
public static bool CreateProcessWithTokenW(
    IntPtr hToken,
    WindowsApiLogonFlags dwLogonFlags,
    string lpApplicationName,
    string lpCommandLine,
    WindowsApiCreationFlags dwCreationFlags,
    IntPtr lpEnvironment,
    string lpCurrentDirectory,
    ref WindowsApiSTARTUPINFO lpStartupInfo,
    out WindowsApiPROCESS_INFORMATION lpProcessInformation
)
<DllImportAttribute("advapi32", CharSet := CharSet.Unicode, SetLastError := true>]
Public Shared Function CreateProcessWithTokenW (
    hToken As IntPtr,
    dwLogonFlags As WindowsApiLogonFlags,
    lpApplicationName As String,
    lpCommandLine As String,
    dwCreationFlags As WindowsApiCreationFlags,
    lpEnvironment As IntPtr,
    lpCurrentDirectory As String,
    ByRef lpStartupInfo As WindowsApiSTARTUPINFO,
    <OutAttribute> ByRef lpProcessInformation As WindowsApiPROCESS_INFORMATION
) As Boolean
[<DllImportAttribute("advapi32", CharSet = CharSet.Unicode, SetLastError = true)>]
static member CreateProcessWithTokenW :
        hToken : IntPtr *
        dwLogonFlags : WindowsApiLogonFlags *
        lpApplicationName : string *
        lpCommandLine : string *
        dwCreationFlags : WindowsApiCreationFlags *
        lpEnvironment : IntPtr *
        lpCurrentDirectory : string *
        lpStartupInfo : WindowsApiSTARTUPINFO byref *
        lpProcessInformation : WindowsApiPROCESS_INFORMATION byref -> bool

GSF.Interop.WindowsApi.CreateProcessWithTokenW = function(hToken, dwLogonFlags, lpApplicationName, lpCommandLine, dwCreationFlags, lpEnvironment, lpCurrentDirectory, lpStartupInfo, lpProcessInformation);
public:
[DllImportAttribute(L"advapi32", CharSet = CharSet::Unicode, SetLastError = true)]
static bool CreateProcessWithTokenW(
    IntPtr hToken,
    WindowsApiLogonFlags dwLogonFlags,
    String^ lpApplicationName,
    String^ lpCommandLine,
    WindowsApiCreationFlags dwCreationFlags,
    IntPtr lpEnvironment,
    String^ lpCurrentDirectory,
    [InAttribute] WindowsApiSTARTUPINFO% lpStartupInfo,
    [OutAttribute] WindowsApiPROCESS_INFORMATION% lpProcessInformation
)

Parameters

hToken
Type: SystemIntPtr

[Missing <param name="hToken"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

dwLogonFlags
Type: GSF.InteropWindowsApiLogonFlags

[Missing <param name="dwLogonFlags"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

lpApplicationName
Type: SystemString

[Missing <param name="lpApplicationName"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

lpCommandLine
Type: SystemString

[Missing <param name="lpCommandLine"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

dwCreationFlags
Type: GSF.InteropWindowsApiCreationFlags

[Missing <param name="dwCreationFlags"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

lpEnvironment
Type: SystemIntPtr

[Missing <param name="lpEnvironment"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

lpCurrentDirectory
Type: SystemString

[Missing <param name="lpCurrentDirectory"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

lpStartupInfo
Type: GSF.InteropWindowsApiSTARTUPINFO

[Missing <param name="lpStartupInfo"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

lpProcessInformation
Type: GSF.InteropWindowsApiPROCESS_INFORMATION

[Missing <param name="lpProcessInformation"/> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.CreateProcessWithTokenW(System.IntPtr,GSF.Interop.WindowsApi.LogonFlags,System.String,System.String,GSF.Interop.WindowsApi.CreationFlags,System.IntPtr,System.String,GSF.Interop.WindowsApi.STARTUPINFO@,GSF.Interop.WindowsApi.PROCESS_INFORMATION@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CryptFindOIDInfo Method

Grid Solutions Framework WindowsApiCryptFindOIDInfo Method
Win32 CryptFindOIDInfo function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("crypt32.dll", SetLastError = true)]
public static IntPtr CryptFindOIDInfo(
    int dwKeyType,
    string pvKey,
    uint dwGroupId
)
<DllImportAttribute("crypt32.dll", SetLastError := true>]
Public Shared Function CryptFindOIDInfo (
    dwKeyType As Integer,
    pvKey As String,
    dwGroupId As UInteger
) As IntPtr
[<DllImportAttribute("crypt32.dll", SetLastError = true)>]
static member CryptFindOIDInfo :
        dwKeyType : int *
        pvKey : string *
        dwGroupId : uint32 -> IntPtr

GSF.Interop.WindowsApi.CryptFindOIDInfo = function(dwKeyType, pvKey, dwGroupId);
public:
[DllImportAttribute(L"crypt32.dll", SetLastError = true)]
static IntPtr CryptFindOIDInfo(
    int dwKeyType,
    String^ pvKey,
    unsigned int dwGroupId
)

Parameters

dwKeyType
Type: SystemInt32

[Missing <param name="dwKeyType"/> documentation for "M:GSF.Interop.WindowsApi.CryptFindOIDInfo(System.Int32,System.String,System.UInt32)"]

pvKey
Type: SystemString

[Missing <param name="pvKey"/> documentation for "M:GSF.Interop.WindowsApi.CryptFindOIDInfo(System.Int32,System.String,System.UInt32)"]

dwGroupId
Type: SystemUInt32

[Missing <param name="dwGroupId"/> documentation for "M:GSF.Interop.WindowsApi.CryptFindOIDInfo(System.Int32,System.String,System.UInt32)"]

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.CryptFindOIDInfo(System.Int32,System.String,System.UInt32)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CryptRegisterOIDInfo Method

Grid Solutions Framework WindowsApiCryptRegisterOIDInfo Method
Win32 CryptRegisterOIDInfo function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("crypt32.dll", SetLastError = true)]
public static bool CryptRegisterOIDInfo(
    IntPtr pInfo,
    int dwFlags
)
<DllImportAttribute("crypt32.dll", SetLastError := true>]
Public Shared Function CryptRegisterOIDInfo (
    pInfo As IntPtr,
    dwFlags As Integer
) As Boolean
[<DllImportAttribute("crypt32.dll", SetLastError = true)>]
static member CryptRegisterOIDInfo :
        pInfo : IntPtr *
        dwFlags : int -> bool

GSF.Interop.WindowsApi.CryptRegisterOIDInfo = function(pInfo, dwFlags);
public:
[DllImportAttribute(L"crypt32.dll", SetLastError = true)]
static bool CryptRegisterOIDInfo(
    IntPtr pInfo,
    int dwFlags
)

Parameters

pInfo
Type: SystemIntPtr

[Missing <param name="pInfo"/> documentation for "M:GSF.Interop.WindowsApi.CryptRegisterOIDInfo(System.IntPtr,System.Int32)"]

dwFlags
Type: SystemInt32

[Missing <param name="dwFlags"/> documentation for "M:GSF.Interop.WindowsApi.CryptRegisterOIDInfo(System.IntPtr,System.Int32)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.CryptRegisterOIDInfo(System.IntPtr,System.Int32)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CryptUnregisterOIDInfo Method

Grid Solutions Framework WindowsApiCryptUnregisterOIDInfo Method
Win32 CryptUnregisterOIDInfo function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("crypt32.dll", SetLastError = true)]
public static bool CryptUnregisterOIDInfo(
    IntPtr pInfo
)
<DllImportAttribute("crypt32.dll", SetLastError := true>]
Public Shared Function CryptUnregisterOIDInfo (
    pInfo As IntPtr
) As Boolean
[<DllImportAttribute("crypt32.dll", SetLastError = true)>]
static member CryptUnregisterOIDInfo :
        pInfo : IntPtr -> bool

GSF.Interop.WindowsApi.CryptUnregisterOIDInfo = function(pInfo);
public:
[DllImportAttribute(L"crypt32.dll", SetLastError = true)]
static bool CryptUnregisterOIDInfo(
    IntPtr pInfo
)

Parameters

pInfo
Type: SystemIntPtr

[Missing <param name="pInfo"/> documentation for "M:GSF.Interop.WindowsApi.CryptUnregisterOIDInfo(System.IntPtr)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.CryptUnregisterOIDInfo(System.IntPtr)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.DuplicateToken Method

Grid Solutions Framework WindowsApiDuplicateToken Method
Win32 DuplicateToken function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool DuplicateToken(
    IntPtr existingTokenHandle,
    int securityImpersonationLevel,
    ref IntPtr duplicateTokenHandle
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function DuplicateToken (
    existingTokenHandle As IntPtr,
    securityImpersonationLevel As Integer,
    ByRef duplicateTokenHandle As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member DuplicateToken :
        existingTokenHandle : IntPtr *
        securityImpersonationLevel : int *
        duplicateTokenHandle : IntPtr byref -> bool

GSF.Interop.WindowsApi.DuplicateToken = function(existingTokenHandle, securityImpersonationLevel, duplicateTokenHandle);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool DuplicateToken(
    IntPtr existingTokenHandle,
    int securityImpersonationLevel,
    IntPtr% duplicateTokenHandle
)

Parameters

existingTokenHandle
Type: SystemIntPtr

[Missing <param name="existingTokenHandle"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateToken(System.IntPtr,System.Int32,System.IntPtr@)"]

securityImpersonationLevel
Type: SystemInt32

[Missing <param name="securityImpersonationLevel"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateToken(System.IntPtr,System.Int32,System.IntPtr@)"]

duplicateTokenHandle
Type: SystemIntPtr

[Missing <param name="duplicateTokenHandle"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateToken(System.IntPtr,System.Int32,System.IntPtr@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.DuplicateToken(System.IntPtr,System.Int32,System.IntPtr@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.DuplicateTokenEx Method

Grid Solutions Framework WindowsApiDuplicateTokenEx Method
Overload List
Name | Description
DuplicateTokenEx(IntPtr, UInt32, WindowsApiSECURITY_ATTRIBUTES, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr) | Win32 DuplicateTokenEx function.
DuplicateTokenEx(IntPtr, UInt32, IntPtr, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr) | Win32 DuplicateTokenEx function.
Top
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.DuplicateTokenEx Method (IntPtr, UInt32, WindowsApi.SECURITY_ATTRIBUTES, WindowsApi.SECURITY_IMPERSONATION_LEVEL, WindowsApi.TOKEN_TYPE, IntPtr)

Grid Solutions Framework WindowsApiDuplicateTokenEx Method (IntPtr, UInt32, WindowsApiSECURITY_ATTRIBUTES, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr)
Win32 DuplicateTokenEx function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)]
public static bool DuplicateTokenEx(
    IntPtr hExistingToken,
    uint dwDesiredAccess,
    ref WindowsApiSECURITY_ATTRIBUTES lpTokenAttributes,
    WindowsApiSECURITY_IMPERSONATION_LEVEL ImpersonationLevel,
    WindowsApiTOKEN_TYPE TokenType,
    out IntPtr phNewToken
)
<DllImportAttribute("advapi32.dll", CharSet := CharSet.Auto, SetLastError := true>]
Public Shared Function DuplicateTokenEx (
    hExistingToken As IntPtr,
    dwDesiredAccess As UInteger,
    ByRef lpTokenAttributes As WindowsApiSECURITY_ATTRIBUTES,
    ImpersonationLevel As WindowsApiSECURITY_IMPERSONATION_LEVEL,
    TokenType As WindowsApiTOKEN_TYPE,
    <OutAttribute> ByRef phNewToken As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)>]
static member DuplicateTokenEx :
        hExistingToken : IntPtr *
        dwDesiredAccess : uint32 *
        lpTokenAttributes : WindowsApiSECURITY_ATTRIBUTES byref *
        ImpersonationLevel : WindowsApiSECURITY_IMPERSONATION_LEVEL *
        TokenType : WindowsApiTOKEN_TYPE *
        phNewToken : IntPtr byref -> bool

GSF.Interop.WindowsApi.DuplicateTokenEx = function(hExistingToken, dwDesiredAccess, lpTokenAttributes, ImpersonationLevel, TokenType, phNewToken);
public:
[DllImportAttribute(L"advapi32.dll", CharSet = CharSet::Auto, SetLastError = true)]
static bool DuplicateTokenEx(
    IntPtr hExistingToken,
    unsigned int dwDesiredAccess,
    WindowsApiSECURITY_ATTRIBUTES% lpTokenAttributes,
    WindowsApiSECURITY_IMPERSONATION_LEVEL ImpersonationLevel,
    WindowsApiTOKEN_TYPE TokenType,
    [OutAttribute] IntPtr% phNewToken
)

Parameters

hExistingToken
Type: SystemIntPtr

[Missing <param name="hExistingToken"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES@,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

dwDesiredAccess
Type: SystemUInt32

[Missing <param name="dwDesiredAccess"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES@,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

lpTokenAttributes
Type: GSF.InteropWindowsApiSECURITY_ATTRIBUTES

[Missing <param name="lpTokenAttributes"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES@,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

ImpersonationLevel
Type: GSF.InteropWindowsApiSECURITY_IMPERSONATION_LEVEL

[Missing <param name="ImpersonationLevel"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES@,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

TokenType
Type: GSF.InteropWindowsApiTOKEN_TYPE

[Missing <param name="TokenType"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES@,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

phNewToken
Type: SystemIntPtr

[Missing <param name="phNewToken"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES@,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES@,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

See Also

Reference

WindowsApi Class
DuplicateTokenEx Overload
GSF.Interop Namespace


WindowsApi.DuplicateTokenEx Method (IntPtr, UInt32, IntPtr, WindowsApi.SECURITY_IMPERSONATION_LEVEL, WindowsApi.TOKEN_TYPE, IntPtr)

Grid Solutions Framework WindowsApiDuplicateTokenEx Method (IntPtr, UInt32, IntPtr, WindowsApiSECURITY_IMPERSONATION_LEVEL, WindowsApiTOKEN_TYPE, IntPtr)
Win32 DuplicateTokenEx function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)]
public static bool DuplicateTokenEx(
    IntPtr hExistingToken,
    uint dwDesiredAccess,
    IntPtr lpTokenAttributes,
    WindowsApiSECURITY_IMPERSONATION_LEVEL ImpersonationLevel,
    WindowsApiTOKEN_TYPE TokenType,
    out IntPtr phNewToken
)
<DllImportAttribute("advapi32.dll", CharSet := CharSet.Auto, SetLastError := true>]
Public Shared Function DuplicateTokenEx (
    hExistingToken As IntPtr,
    dwDesiredAccess As UInteger,
    lpTokenAttributes As IntPtr,
    ImpersonationLevel As WindowsApiSECURITY_IMPERSONATION_LEVEL,
    TokenType As WindowsApiTOKEN_TYPE,
    <OutAttribute> ByRef phNewToken As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)>]
static member DuplicateTokenEx :
        hExistingToken : IntPtr *
        dwDesiredAccess : uint32 *
        lpTokenAttributes : IntPtr *
        ImpersonationLevel : WindowsApiSECURITY_IMPERSONATION_LEVEL *
        TokenType : WindowsApiTOKEN_TYPE *
        phNewToken : IntPtr byref -> bool

GSF.Interop.WindowsApi.DuplicateTokenEx = function(hExistingToken, dwDesiredAccess, lpTokenAttributes, ImpersonationLevel, TokenType, phNewToken);
public:
[DllImportAttribute(L"advapi32.dll", CharSet = CharSet::Auto, SetLastError = true)]
static bool DuplicateTokenEx(
    IntPtr hExistingToken,
    unsigned int dwDesiredAccess,
    IntPtr lpTokenAttributes,
    WindowsApiSECURITY_IMPERSONATION_LEVEL ImpersonationLevel,
    WindowsApiTOKEN_TYPE TokenType,
    [OutAttribute] IntPtr% phNewToken
)

Parameters

hExistingToken
Type: SystemIntPtr

[Missing <param name="hExistingToken"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,System.IntPtr,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

dwDesiredAccess
Type: SystemUInt32

[Missing <param name="dwDesiredAccess"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,System.IntPtr,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

lpTokenAttributes
Type: SystemIntPtr

[Missing <param name="lpTokenAttributes"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,System.IntPtr,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

ImpersonationLevel
Type: GSF.InteropWindowsApiSECURITY_IMPERSONATION_LEVEL

[Missing <param name="ImpersonationLevel"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,System.IntPtr,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

TokenType
Type: GSF.InteropWindowsApiTOKEN_TYPE

[Missing <param name="TokenType"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,System.IntPtr,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

phNewToken
Type: SystemIntPtr

[Missing <param name="phNewToken"/> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,System.IntPtr,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.DuplicateTokenEx(System.IntPtr,System.UInt32,System.IntPtr,GSF.Interop.WindowsApi.SECURITY_IMPERSONATION_LEVEL,GSF.Interop.WindowsApi.TOKEN_TYPE,System.IntPtr@)"]

See Also

Reference

WindowsApi Class
DuplicateTokenEx Overload
GSF.Interop Namespace


WindowsApi.FormatMessage Method

Grid Solutions Framework WindowsApiFormatMessage Method
Win32 FormatMessage function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("kernel32.dll")]
public static int FormatMessage(
    int dwFlags,
    ref IntPtr lpSource,
    int dwMessageId,
    int dwLanguageId,
    ref string lpBuffer,
    int nSize,
    ref IntPtr Arguments
)
<DllImportAttribute("kernel32.dll">]
Public Shared Function FormatMessage (
    dwFlags As Integer,
    ByRef lpSource As IntPtr,
    dwMessageId As Integer,
    dwLanguageId As Integer,
    ByRef lpBuffer As String,
    nSize As Integer,
    ByRef Arguments As IntPtr
) As Integer
[<DllImportAttribute("kernel32.dll")>]
static member FormatMessage :
        dwFlags : int *
        lpSource : IntPtr byref *
        dwMessageId : int *
        dwLanguageId : int *
        lpBuffer : string byref *
        nSize : int *
        Arguments : IntPtr byref -> int

GSF.Interop.WindowsApi.FormatMessage = function(dwFlags, lpSource, dwMessageId, dwLanguageId, lpBuffer, nSize, Arguments);
public:
[DllImportAttribute(L"kernel32.dll")]
static int FormatMessage(
    int dwFlags,
    IntPtr% lpSource,
    int dwMessageId,
    int dwLanguageId,
    String^% lpBuffer,
    int nSize,
    IntPtr% Arguments
)

Parameters

dwFlags
Type: SystemInt32

[Missing <param name="dwFlags"/> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

lpSource
Type: SystemIntPtr

[Missing <param name="lpSource"/> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

dwMessageId
Type: SystemInt32

[Missing <param name="dwMessageId"/> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

dwLanguageId
Type: SystemInt32

[Missing <param name="dwLanguageId"/> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

lpBuffer
Type: SystemString

[Missing <param name="lpBuffer"/> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

nSize
Type: SystemInt32

[Missing <param name="nSize"/> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

Arguments
Type: SystemIntPtr

[Missing <param name="Arguments"/> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.FormatMessage(System.Int32,System.IntPtr@,System.Int32,System.Int32,System.String@,System.Int32,System.IntPtr@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.FreeSid Method

Grid Solutions Framework WindowsApiFreeSid Method
Win32 FreeSid function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll")]
public static IntPtr FreeSid(
    IntPtr pSid
)
<DllImportAttribute("advapi32.dll">]
Public Shared Function FreeSid (
    pSid As IntPtr
) As IntPtr
[<DllImportAttribute("advapi32.dll")>]
static member FreeSid :
        pSid : IntPtr -> IntPtr

GSF.Interop.WindowsApi.FreeSid = function(pSid);
public:
[DllImportAttribute(L"advapi32.dll")]
static IntPtr FreeSid(
    IntPtr pSid
)

Parameters

pSid
Type: SystemIntPtr

[Missing <param name="pSid"/> documentation for "M:GSF.Interop.WindowsApi.FreeSid(System.IntPtr)"]

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.FreeSid(System.IntPtr)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.GetCurrentProcess Method

Grid Solutions Framework WindowsApiGetCurrentProcess Method
Win32 GetCurrentProcess function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("kernel32.dll", SetLastError = true)]
public static IntPtr GetCurrentProcess()
<DllImportAttribute("kernel32.dll", SetLastError := true>]
Public Shared Function GetCurrentProcess As IntPtr
[<DllImportAttribute("kernel32.dll", SetLastError = true)>]
static member GetCurrentProcess : unit -> IntPtr

GSF.Interop.WindowsApi.GetCurrentProcess = function();
public:
[DllImportAttribute(L"kernel32.dll", SetLastError = true)]
static IntPtr GetCurrentProcess()

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.GetCurrentProcess"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.GetErrorMessage Method

Grid Solutions Framework WindowsApiGetErrorMessage Method
Formats and returns a .NET string containing the Windows API level error message corresponding to the specified error code.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetErrorMessage(
    int errorCode
)
Public Shared Function GetErrorMessage (
    errorCode As Integer
) As String
static member GetErrorMessage :
        errorCode : int -> string

GSF.Interop.WindowsApi.GetErrorMessage = function(errorCode);
public:
static String^ GetErrorMessage(
    int errorCode
)

Parameters

errorCode
Type: SystemInt32
An Int32 value corresponding to the specified error code.

Return Value

Type: String
A formatted error message corresponding to the specified error code.
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.GetLastError Method

Grid Solutions Framework WindowsApiGetLastError Method
Win32 GetLastError function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("kernel32.dll")]
public static int GetLastError()
<DllImportAttribute("kernel32.dll">]
Public Shared Function GetLastError As Integer
[<DllImportAttribute("kernel32.dll")>]
static member GetLastError : unit -> int

GSF.Interop.WindowsApi.GetLastError = function();
public:
[DllImportAttribute(L"kernel32.dll")]
static int GetLastError()

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.GetLastError"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.GetLastErrorMessage Method

Grid Solutions Framework WindowsApiGetLastErrorMessage Method
Formats and returns a .NET string containing the Windows API level error message from the last Win32 call.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetLastErrorMessage()
Public Shared Function GetLastErrorMessage As String
static member GetLastErrorMessage : unit -> string

GSF.Interop.WindowsApi.GetLastErrorMessage = function();
public:
static String^ GetLastErrorMessage()

Return Value

Type: String
A formatted error message corresponding to the last Win32 call error code.
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.GetShellWindow Method

Grid Solutions Framework WindowsApiGetShellWindow Method
Win32 GetShellWindow function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("user32.dll", SetLastError = true)]
public static IntPtr GetShellWindow()
<DllImportAttribute("user32.dll", SetLastError := true>]
Public Shared Function GetShellWindow As IntPtr
[<DllImportAttribute("user32.dll", SetLastError = true)>]
static member GetShellWindow : unit -> IntPtr

GSF.Interop.WindowsApi.GetShellWindow = function();
public:
[DllImportAttribute(L"user32.dll", SetLastError = true)]
static IntPtr GetShellWindow()

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.GetShellWindow"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.GetTokenInformation Method

Grid Solutions Framework WindowsApiGetTokenInformation Method
Overload List
Name | Description
GetTokenInformation(IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, WindowsApiTOKEN_ELEVATION_TYPE, UInt32, UInt32) | Win32 GetTokenInformation function.
GetTokenInformation(IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, UInt32, UInt32, UInt32) | Win32 GetTokenInformation function.
Top
See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.GetTokenInformation Method (IntPtr, WindowsApi.TOKEN_INFORMATION_CLASS, WindowsApi.TOKEN_ELEVATION_TYPE, UInt32, UInt32)

Grid Solutions Framework WindowsApiGetTokenInformation Method (IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, WindowsApiTOKEN_ELEVATION_TYPE, UInt32, UInt32)
Win32 GetTokenInformation function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool GetTokenInformation(
    IntPtr TokenHandle,
    WindowsApiTOKEN_INFORMATION_CLASS TokenInformationClass,
    ref WindowsApiTOKEN_ELEVATION_TYPE TokenInformation,
    uint TokenInformationLength,
    out uint ReturnLength
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function GetTokenInformation (
    TokenHandle As IntPtr,
    TokenInformationClass As WindowsApiTOKEN_INFORMATION_CLASS,
    ByRef TokenInformation As WindowsApiTOKEN_ELEVATION_TYPE,
    TokenInformationLength As UInteger,
    <OutAttribute> ByRef ReturnLength As UInteger
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member GetTokenInformation :
        TokenHandle : IntPtr *
        TokenInformationClass : WindowsApiTOKEN_INFORMATION_CLASS *
        TokenInformation : WindowsApiTOKEN_ELEVATION_TYPE byref *
        TokenInformationLength : uint32 *
        ReturnLength : uint32 byref -> bool

GSF.Interop.WindowsApi.GetTokenInformation = function(TokenHandle, TokenInformationClass, TokenInformation, TokenInformationLength, ReturnLength);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool GetTokenInformation(
    IntPtr TokenHandle,
    WindowsApiTOKEN_INFORMATION_CLASS TokenInformationClass,
    WindowsApiTOKEN_ELEVATION_TYPE% TokenInformation,
    unsigned int TokenInformationLength,
    [OutAttribute] unsigned int% ReturnLength
)

Parameters

TokenHandle
Type: SystemIntPtr

[Missing <param name="TokenHandle"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,GSF.Interop.WindowsApi.TOKEN_ELEVATION_TYPE@,System.UInt32,System.UInt32@)"]

TokenInformationClass
Type: GSF.InteropWindowsApiTOKEN_INFORMATION_CLASS

[Missing <param name="TokenInformationClass"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,GSF.Interop.WindowsApi.TOKEN_ELEVATION_TYPE@,System.UInt32,System.UInt32@)"]

TokenInformation
Type: GSF.InteropWindowsApiTOKEN_ELEVATION_TYPE

[Missing <param name="TokenInformation"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,GSF.Interop.WindowsApi.TOKEN_ELEVATION_TYPE@,System.UInt32,System.UInt32@)"]

TokenInformationLength
Type: SystemUInt32

[Missing <param name="TokenInformationLength"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,GSF.Interop.WindowsApi.TOKEN_ELEVATION_TYPE@,System.UInt32,System.UInt32@)"]

ReturnLength
Type: SystemUInt32

[Missing <param name="ReturnLength"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,GSF.Interop.WindowsApi.TOKEN_ELEVATION_TYPE@,System.UInt32,System.UInt32@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,GSF.Interop.WindowsApi.TOKEN_ELEVATION_TYPE@,System.UInt32,System.UInt32@)"]

See Also

Reference

WindowsApi Class
GetTokenInformation Overload
GSF.Interop Namespace


WindowsApi.GetTokenInformation Method (IntPtr, WindowsApi.TOKEN_INFORMATION_CLASS, UInt32, UInt32, UInt32)

Grid Solutions Framework WindowsApiGetTokenInformation Method (IntPtr, WindowsApiTOKEN_INFORMATION_CLASS, UInt32, UInt32, UInt32)
Win32 GetTokenInformation function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool GetTokenInformation(
    IntPtr TokenHandle,
    WindowsApiTOKEN_INFORMATION_CLASS TokenInformationClass,
    ref uint TokenInformation,
    uint TokenInformationLength,
    out uint ReturnLength
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function GetTokenInformation (
    TokenHandle As IntPtr,
    TokenInformationClass As WindowsApiTOKEN_INFORMATION_CLASS,
    ByRef TokenInformation As UInteger,
    TokenInformationLength As UInteger,
    <OutAttribute> ByRef ReturnLength As UInteger
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member GetTokenInformation :
        TokenHandle : IntPtr *
        TokenInformationClass : WindowsApiTOKEN_INFORMATION_CLASS *
        TokenInformation : uint32 byref *
        TokenInformationLength : uint32 *
        ReturnLength : uint32 byref -> bool

GSF.Interop.WindowsApi.GetTokenInformation = function(TokenHandle, TokenInformationClass, TokenInformation, TokenInformationLength, ReturnLength);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool GetTokenInformation(
    IntPtr TokenHandle,
    WindowsApiTOKEN_INFORMATION_CLASS TokenInformationClass,
    unsigned int% TokenInformation,
    unsigned int TokenInformationLength,
    [OutAttribute] unsigned int% ReturnLength
)

Parameters

TokenHandle
Type: SystemIntPtr

[Missing <param name="TokenHandle"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,System.UInt32@,System.UInt32,System.UInt32@)"]

TokenInformationClass
Type: GSF.InteropWindowsApiTOKEN_INFORMATION_CLASS

[Missing <param name="TokenInformationClass"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,System.UInt32@,System.UInt32,System.UInt32@)"]

TokenInformation
Type: SystemUInt32

[Missing <param name="TokenInformation"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,System.UInt32@,System.UInt32,System.UInt32@)"]

TokenInformationLength
Type: SystemUInt32

[Missing <param name="TokenInformationLength"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,System.UInt32@,System.UInt32,System.UInt32@)"]

ReturnLength
Type: SystemUInt32

[Missing <param name="ReturnLength"/> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,System.UInt32@,System.UInt32,System.UInt32@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.GetTokenInformation(System.IntPtr,GSF.Interop.WindowsApi.TOKEN_INFORMATION_CLASS,System.UInt32@,System.UInt32,System.UInt32@)"]

See Also

Reference

WindowsApi Class
GetTokenInformation Overload
GSF.Interop Namespace


WindowsApi.GetWindowThreadProcessId Method

Grid Solutions Framework WindowsApiGetWindowThreadProcessId Method
Win32 GetWindowThreadProcessId function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("user32.dll", SetLastError = true)]
public static uint GetWindowThreadProcessId(
    IntPtr hWnd,
    out uint lpdwProcessId
)
<DllImportAttribute("user32.dll", SetLastError := true>]
Public Shared Function GetWindowThreadProcessId (
    hWnd As IntPtr,
    <OutAttribute> ByRef lpdwProcessId As UInteger
) As UInteger
[<DllImportAttribute("user32.dll", SetLastError = true)>]
static member GetWindowThreadProcessId :
        hWnd : IntPtr *
        lpdwProcessId : uint32 byref -> uint32

GSF.Interop.WindowsApi.GetWindowThreadProcessId = function(hWnd, lpdwProcessId);
public:
[DllImportAttribute(L"user32.dll", SetLastError = true)]
static unsigned int GetWindowThreadProcessId(
    IntPtr hWnd,
    [OutAttribute] unsigned int% lpdwProcessId
)

Parameters

hWnd
Type: SystemIntPtr

[Missing <param name="hWnd"/> documentation for "M:GSF.Interop.WindowsApi.GetWindowThreadProcessId(System.IntPtr,System.UInt32@)"]

lpdwProcessId
Type: SystemUInt32

[Missing <param name="lpdwProcessId"/> documentation for "M:GSF.Interop.WindowsApi.GetWindowThreadProcessId(System.IntPtr,System.UInt32@)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.GetWindowThreadProcessId(System.IntPtr,System.UInt32@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.InitiateSystemShutdownEx Method

Grid Solutions Framework WindowsApiInitiateSystemShutdownEx Method
Win32 InitiateSystemShutdownEx function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)]
public static bool InitiateSystemShutdownEx(
    string lpMachineName,
    string lpMessage,
    uint dwTimeout,
    bool bForceAppsClosed,
    bool bRebootAfterShutdown,
    WindowsApiShutdownReason dwReason
)
<DllImportAttribute("advapi32.dll", CharSet := CharSet.Auto, SetLastError := true>]
Public Shared Function InitiateSystemShutdownEx (
    lpMachineName As String,
    lpMessage As String,
    dwTimeout As UInteger,
    bForceAppsClosed As Boolean,
    bRebootAfterShutdown As Boolean,
    dwReason As WindowsApiShutdownReason
) As Boolean
[<DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)>]
static member InitiateSystemShutdownEx :
        lpMachineName : string *
        lpMessage : string *
        dwTimeout : uint32 *
        bForceAppsClosed : bool *
        bRebootAfterShutdown : bool *
        dwReason : WindowsApiShutdownReason -> bool

GSF.Interop.WindowsApi.InitiateSystemShutdownEx = function(lpMachineName, lpMessage, dwTimeout, bForceAppsClosed, bRebootAfterShutdown, dwReason);
public:
[DllImportAttribute(L"advapi32.dll", CharSet = CharSet::Auto, SetLastError = true)]
static bool InitiateSystemShutdownEx(
    String^ lpMachineName,
    String^ lpMessage,
    unsigned int dwTimeout,
    bool bForceAppsClosed,
    bool bRebootAfterShutdown,
    WindowsApiShutdownReason dwReason
)

Parameters

lpMachineName
Type: SystemString

[Missing <param name="lpMachineName"/> documentation for "M:GSF.Interop.WindowsApi.InitiateSystemShutdownEx(System.String,System.String,System.UInt32,System.Boolean,System.Boolean,GSF.Interop.WindowsApi.ShutdownReason)"]

lpMessage
Type: SystemString

[Missing <param name="lpMessage"/> documentation for "M:GSF.Interop.WindowsApi.InitiateSystemShutdownEx(System.String,System.String,System.UInt32,System.Boolean,System.Boolean,GSF.Interop.WindowsApi.ShutdownReason)"]

dwTimeout
Type: SystemUInt32

[Missing <param name="dwTimeout"/> documentation for "M:GSF.Interop.WindowsApi.InitiateSystemShutdownEx(System.String,System.String,System.UInt32,System.Boolean,System.Boolean,GSF.Interop.WindowsApi.ShutdownReason)"]

bForceAppsClosed
Type: SystemBoolean

[Missing <param name="bForceAppsClosed"/> documentation for "M:GSF.Interop.WindowsApi.InitiateSystemShutdownEx(System.String,System.String,System.UInt32,System.Boolean,System.Boolean,GSF.Interop.WindowsApi.ShutdownReason)"]

bRebootAfterShutdown
Type: SystemBoolean

[Missing <param name="bRebootAfterShutdown"/> documentation for "M:GSF.Interop.WindowsApi.InitiateSystemShutdownEx(System.String,System.String,System.UInt32,System.Boolean,System.Boolean,GSF.Interop.WindowsApi.ShutdownReason)"]

dwReason
Type: GSF.InteropWindowsApiShutdownReason

[Missing <param name="dwReason"/> documentation for "M:GSF.Interop.WindowsApi.InitiateSystemShutdownEx(System.String,System.String,System.UInt32,System.Boolean,System.Boolean,GSF.Interop.WindowsApi.ShutdownReason)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.InitiateSystemShutdownEx(System.String,System.String,System.UInt32,System.Boolean,System.Boolean,GSF.Interop.WindowsApi.ShutdownReason)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.IsWow64Process Method

Grid Solutions Framework WindowsApiIsWow64Process Method
Win32 IsWow64Process function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("kernel32.dll", SetLastError = true)]
public static bool IsWow64Process(
    IntPtr hProcess,
    ref bool Wow64Process
)
<DllImportAttribute("kernel32.dll", SetLastError := true>]
Public Shared Function IsWow64Process (
    hProcess As IntPtr,
    ByRef Wow64Process As Boolean
) As Boolean
[<DllImportAttribute("kernel32.dll", SetLastError = true)>]
static member IsWow64Process :
        hProcess : IntPtr *
        Wow64Process : bool byref -> bool

GSF.Interop.WindowsApi.IsWow64Process = function(hProcess, Wow64Process);
public:
[DllImportAttribute(L"kernel32.dll", SetLastError = true)]
static bool IsWow64Process(
    IntPtr hProcess,
    bool% Wow64Process
)

Parameters

hProcess
Type: SystemIntPtr

[Missing <param name="hProcess"/> documentation for "M:GSF.Interop.WindowsApi.IsWow64Process(System.IntPtr,System.Boolean@)"]

Wow64Process
Type: SystemBoolean

[Missing <param name="Wow64Process"/> documentation for "M:GSF.Interop.WindowsApi.IsWow64Process(System.IntPtr,System.Boolean@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.IsWow64Process(System.IntPtr,System.Boolean@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LockServiceDatabase Method

Grid Solutions Framework WindowsApiLockServiceDatabase Method
Win32 LockServiceDatabase function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static IntPtr LockServiceDatabase(
    IntPtr hSCManager
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function LockServiceDatabase (
    hSCManager As IntPtr
) As IntPtr
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member LockServiceDatabase :
        hSCManager : IntPtr -> IntPtr

GSF.Interop.WindowsApi.LockServiceDatabase = function(hSCManager);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static IntPtr LockServiceDatabase(
    IntPtr hSCManager
)

Parameters

hSCManager
Type: SystemIntPtr

[Missing <param name="hSCManager"/> documentation for "M:GSF.Interop.WindowsApi.LockServiceDatabase(System.IntPtr)"]

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.LockServiceDatabase(System.IntPtr)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LogonUser Method

Grid Solutions Framework WindowsApiLogonUser Method
Win32 LogonUser function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", CharSet = CharSet.Unicode, SetLastError = true)]
public static bool LogonUser(
    string lpszUsername,
    string lpszDomain,
    string lpszPassword,
    int dwLogonType,
    int dwLogonProvider,
    out IntPtr phToken
)
<DllImportAttribute("advapi32.dll", CharSet := CharSet.Unicode, SetLastError := true>]
Public Shared Function LogonUser (
    lpszUsername As String,
    lpszDomain As String,
    lpszPassword As String,
    dwLogonType As Integer,
    dwLogonProvider As Integer,
    <OutAttribute> ByRef phToken As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", CharSet = CharSet.Unicode, SetLastError = true)>]
static member LogonUser :
        lpszUsername : string *
        lpszDomain : string *
        lpszPassword : string *
        dwLogonType : int *
        dwLogonProvider : int *
        phToken : IntPtr byref -> bool

GSF.Interop.WindowsApi.LogonUser = function(lpszUsername, lpszDomain, lpszPassword, dwLogonType, dwLogonProvider, phToken);
public:
[DllImportAttribute(L"advapi32.dll", CharSet = CharSet::Unicode, SetLastError = true)]
static bool LogonUser(
    String^ lpszUsername,
    String^ lpszDomain,
    String^ lpszPassword,
    int dwLogonType,
    int dwLogonProvider,
    [OutAttribute] IntPtr% phToken
)

Parameters

lpszUsername
Type: SystemString

[Missing <param name="lpszUsername"/> documentation for "M:GSF.Interop.WindowsApi.LogonUser(System.String,System.String,System.String,System.Int32,System.Int32,System.IntPtr@)"]

lpszDomain
Type: SystemString

[Missing <param name="lpszDomain"/> documentation for "M:GSF.Interop.WindowsApi.LogonUser(System.String,System.String,System.String,System.Int32,System.Int32,System.IntPtr@)"]

lpszPassword
Type: SystemString

[Missing <param name="lpszPassword"/> documentation for "M:GSF.Interop.WindowsApi.LogonUser(System.String,System.String,System.String,System.Int32,System.Int32,System.IntPtr@)"]

dwLogonType
Type: SystemInt32

[Missing <param name="dwLogonType"/> documentation for "M:GSF.Interop.WindowsApi.LogonUser(System.String,System.String,System.String,System.Int32,System.Int32,System.IntPtr@)"]

dwLogonProvider
Type: SystemInt32

[Missing <param name="dwLogonProvider"/> documentation for "M:GSF.Interop.WindowsApi.LogonUser(System.String,System.String,System.String,System.Int32,System.Int32,System.IntPtr@)"]

phToken
Type: SystemIntPtr

[Missing <param name="phToken"/> documentation for "M:GSF.Interop.WindowsApi.LogonUser(System.String,System.String,System.String,System.Int32,System.Int32,System.IntPtr@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.LogonUser(System.String,System.String,System.String,System.Int32,System.Int32,System.IntPtr@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LookupAccountName Method

Grid Solutions Framework WindowsApiLookupAccountName Method
Win32 LookupAccountName function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)]
public static bool LookupAccountName(
    string lpSystemName,
    string lpAccountName,
    IntPtr psid,
    ref int cbsid,
    StringBuilder domainName,
    ref int cbdomainLength,
    ref int use
)
<DllImportAttribute("advapi32.dll", CharSet := CharSet.Auto, SetLastError := true>]
Public Shared Function LookupAccountName (
    lpSystemName As String,
    lpAccountName As String,
    psid As IntPtr,
    ByRef cbsid As Integer,
    domainName As StringBuilder,
    ByRef cbdomainLength As Integer,
    ByRef use As Integer
) As Boolean
[<DllImportAttribute("advapi32.dll", CharSet = CharSet.Auto, SetLastError = true)>]
static member LookupAccountName :
        lpSystemName : string *
        lpAccountName : string *
        psid : IntPtr *
        cbsid : int byref *
        domainName : StringBuilder *
        cbdomainLength : int byref *
        use : int byref -> bool

GSF.Interop.WindowsApi.LookupAccountName = function(lpSystemName, lpAccountName, psid, cbsid, domainName, cbdomainLength, use);
public:
[DllImportAttribute(L"advapi32.dll", CharSet = CharSet::Auto, SetLastError = true)]
static bool LookupAccountName(
    String^ lpSystemName,
    String^ lpAccountName,
    IntPtr psid,
    int% cbsid,
    StringBuilder^ domainName,
    int% cbdomainLength,
    int% use
)

Parameters

lpSystemName
Type: SystemString

[Missing <param name="lpSystemName"/> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

lpAccountName
Type: SystemString

[Missing <param name="lpAccountName"/> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

psid
Type: SystemIntPtr

[Missing <param name="psid"/> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

cbsid
Type: SystemInt32

[Missing <param name="cbsid"/> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

domainName
Type: System.TextStringBuilder

[Missing <param name="domainName"/> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

cbdomainLength
Type: SystemInt32

[Missing <param name="cbdomainLength"/> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

use
Type: SystemInt32

[Missing <param name="use"/> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.LookupAccountName(System.String,System.String,System.IntPtr,System.Int32@,System.Text.StringBuilder,System.Int32@,System.Int32@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LookupPrivilegeValue Method

Grid Solutions Framework WindowsApiLookupPrivilegeValue Method
Win32 LookupPrivilegeValue function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool LookupPrivilegeValue(
    string lpSystemName,
    string lpName,
    ref long lpLuid
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function LookupPrivilegeValue (
    lpSystemName As String,
    lpName As String,
    ByRef lpLuid As Long
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member LookupPrivilegeValue :
        lpSystemName : string *
        lpName : string *
        lpLuid : int64 byref -> bool

GSF.Interop.WindowsApi.LookupPrivilegeValue = function(lpSystemName, lpName, lpLuid);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool LookupPrivilegeValue(
    String^ lpSystemName,
    String^ lpName,
    long long% lpLuid
)

Parameters

lpSystemName
Type: SystemString

[Missing <param name="lpSystemName"/> documentation for "M:GSF.Interop.WindowsApi.LookupPrivilegeValue(System.String,System.String,System.Int64@)"]

lpName
Type: SystemString

[Missing <param name="lpName"/> documentation for "M:GSF.Interop.WindowsApi.LookupPrivilegeValue(System.String,System.String,System.Int64@)"]

lpLuid
Type: SystemInt64

[Missing <param name="lpLuid"/> documentation for "M:GSF.Interop.WindowsApi.LookupPrivilegeValue(System.String,System.String,System.Int64@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.LookupPrivilegeValue(System.String,System.String,System.Int64@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LsaAddAccountRights Method

Grid Solutions Framework WindowsApiLsaAddAccountRights Method
Win32 LsaAddAccountRights function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static uint LsaAddAccountRights(
    IntPtr PolicyHandle,
    IntPtr AccountSid,
    WindowsApiLSA_UNICODE_STRING[] UserRights,
    uint CountOfRights
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function LsaAddAccountRights (
    PolicyHandle As IntPtr,
    AccountSid As IntPtr,
    UserRights As WindowsApiLSA_UNICODE_STRING(),
    CountOfRights As UInteger
) As UInteger
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member LsaAddAccountRights :
        PolicyHandle : IntPtr *
        AccountSid : IntPtr *
        UserRights : WindowsApiLSA_UNICODE_STRING[] *
        CountOfRights : uint32 -> uint32

GSF.Interop.WindowsApi.LsaAddAccountRights = function(PolicyHandle, AccountSid, UserRights, CountOfRights);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static unsigned int LsaAddAccountRights(
    IntPtr PolicyHandle,
    IntPtr AccountSid,
    array<WindowsApiLSA_UNICODE_STRING>^ UserRights,
    unsigned int CountOfRights
)

Parameters

PolicyHandle
Type: SystemIntPtr

[Missing <param name="PolicyHandle"/> documentation for "M:GSF.Interop.WindowsApi.LsaAddAccountRights(System.IntPtr,System.IntPtr,GSF.Interop.WindowsApi.LSA_UNICODE_STRING[],System.UInt32)"]

AccountSid
Type: SystemIntPtr

[Missing <param name="AccountSid"/> documentation for "M:GSF.Interop.WindowsApi.LsaAddAccountRights(System.IntPtr,System.IntPtr,GSF.Interop.WindowsApi.LSA_UNICODE_STRING[],System.UInt32)"]

UserRights
Type: GSF.InteropWindowsApiLSA_UNICODE_STRING

[Missing <param name="UserRights"/> documentation for "M:GSF.Interop.WindowsApi.LsaAddAccountRights(System.IntPtr,System.IntPtr,GSF.Interop.WindowsApi.LSA_UNICODE_STRING[],System.UInt32)"]

CountOfRights
Type: SystemUInt32

[Missing <param name="CountOfRights"/> documentation for "M:GSF.Interop.WindowsApi.LsaAddAccountRights(System.IntPtr,System.IntPtr,GSF.Interop.WindowsApi.LSA_UNICODE_STRING[],System.UInt32)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.LsaAddAccountRights(System.IntPtr,System.IntPtr,GSF.Interop.WindowsApi.LSA_UNICODE_STRING[],System.UInt32)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LsaClose Method

Grid Solutions Framework WindowsApiLsaClose Method
Win32 LsaClose function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32")]
public static uint LsaClose(
    IntPtr PolicyHandle
)
<DllImportAttribute("advapi32">]
Public Shared Function LsaClose (
    PolicyHandle As IntPtr
) As UInteger
[<DllImportAttribute("advapi32")>]
static member LsaClose :
        PolicyHandle : IntPtr -> uint32

GSF.Interop.WindowsApi.LsaClose = function(PolicyHandle);
public:
[DllImportAttribute(L"advapi32")]
static unsigned int LsaClose(
    IntPtr PolicyHandle
)

Parameters

PolicyHandle
Type: SystemIntPtr

[Missing <param name="PolicyHandle"/> documentation for "M:GSF.Interop.WindowsApi.LsaClose(System.IntPtr)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.LsaClose(System.IntPtr)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.LsaOpenPolicy Method

Grid Solutions Framework WindowsApiLsaOpenPolicy Method
Win32 LsaOpenPolicy function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll")]
public static uint LsaOpenPolicy(
    ref WindowsApiLSA_UNICODE_STRING SystemName,
    ref WindowsApiLSA_OBJECT_ATTRIBUTES ObjectAttributes,
    int DesiredAccess,
    out IntPtr PolicyHandle
)
<DllImportAttribute("advapi32.dll">]
Public Shared Function LsaOpenPolicy (
    ByRef SystemName As WindowsApiLSA_UNICODE_STRING,
    ByRef ObjectAttributes As WindowsApiLSA_OBJECT_ATTRIBUTES,
    DesiredAccess As Integer,
    <OutAttribute> ByRef PolicyHandle As IntPtr
) As UInteger
[<DllImportAttribute("advapi32.dll")>]
static member LsaOpenPolicy :
        SystemName : WindowsApiLSA_UNICODE_STRING byref *
        ObjectAttributes : WindowsApiLSA_OBJECT_ATTRIBUTES byref *
        DesiredAccess : int *
        PolicyHandle : IntPtr byref -> uint32

GSF.Interop.WindowsApi.LsaOpenPolicy = function(SystemName, ObjectAttributes, DesiredAccess, PolicyHandle);
public:
[DllImportAttribute(L"advapi32.dll")]
static unsigned int LsaOpenPolicy(
    WindowsApiLSA_UNICODE_STRING% SystemName,
    WindowsApiLSA_OBJECT_ATTRIBUTES% ObjectAttributes,
    int DesiredAccess,
    [OutAttribute] IntPtr% PolicyHandle
)

Parameters

SystemName
Type: GSF.InteropWindowsApiLSA_UNICODE_STRING

[Missing <param name="SystemName"/> documentation for "M:GSF.Interop.WindowsApi.LsaOpenPolicy(GSF.Interop.WindowsApi.LSA_UNICODE_STRING@,GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES@,System.Int32,System.IntPtr@)"]

ObjectAttributes
Type: GSF.InteropWindowsApiLSA_OBJECT_ATTRIBUTES

[Missing <param name="ObjectAttributes"/> documentation for "M:GSF.Interop.WindowsApi.LsaOpenPolicy(GSF.Interop.WindowsApi.LSA_UNICODE_STRING@,GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES@,System.Int32,System.IntPtr@)"]

DesiredAccess
Type: SystemInt32

[Missing <param name="DesiredAccess"/> documentation for "M:GSF.Interop.WindowsApi.LsaOpenPolicy(GSF.Interop.WindowsApi.LSA_UNICODE_STRING@,GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES@,System.Int32,System.IntPtr@)"]

PolicyHandle
Type: SystemIntPtr

[Missing <param name="PolicyHandle"/> documentation for "M:GSF.Interop.WindowsApi.LsaOpenPolicy(GSF.Interop.WindowsApi.LSA_UNICODE_STRING@,GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES@,System.Int32,System.IntPtr@)"]

Return Value

Type: UInt32

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.LsaOpenPolicy(GSF.Interop.WindowsApi.LSA_UNICODE_STRING@,GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES@,System.Int32,System.IntPtr@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.OpenProcess Method

Grid Solutions Framework WindowsApiOpenProcess Method
Win32 OpenProcess function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("kernel32.dll", SetLastError = true)]
public static IntPtr OpenProcess(
    WindowsApiProcessAccessTypes dwDesiredAccess,
    bool bInheritHandle,
    uint dwProcessId
)
<DllImportAttribute("kernel32.dll", SetLastError := true>]
Public Shared Function OpenProcess (
    dwDesiredAccess As WindowsApiProcessAccessTypes,
    bInheritHandle As Boolean,
    dwProcessId As UInteger
) As IntPtr
[<DllImportAttribute("kernel32.dll", SetLastError = true)>]
static member OpenProcess :
        dwDesiredAccess : WindowsApiProcessAccessTypes *
        bInheritHandle : bool *
        dwProcessId : uint32 -> IntPtr

GSF.Interop.WindowsApi.OpenProcess = function(dwDesiredAccess, bInheritHandle, dwProcessId);
public:
[DllImportAttribute(L"kernel32.dll", SetLastError = true)]
static IntPtr OpenProcess(
    WindowsApiProcessAccessTypes dwDesiredAccess,
    bool bInheritHandle,
    unsigned int dwProcessId
)

Parameters

dwDesiredAccess
Type: GSF.InteropWindowsApiProcessAccessTypes

[Missing <param name="dwDesiredAccess"/> documentation for "M:GSF.Interop.WindowsApi.OpenProcess(GSF.Interop.WindowsApi.ProcessAccessTypes,System.Boolean,System.UInt32)"]

bInheritHandle
Type: SystemBoolean

[Missing <param name="bInheritHandle"/> documentation for "M:GSF.Interop.WindowsApi.OpenProcess(GSF.Interop.WindowsApi.ProcessAccessTypes,System.Boolean,System.UInt32)"]

dwProcessId
Type: SystemUInt32

[Missing <param name="dwProcessId"/> documentation for "M:GSF.Interop.WindowsApi.OpenProcess(GSF.Interop.WindowsApi.ProcessAccessTypes,System.Boolean,System.UInt32)"]

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.OpenProcess(GSF.Interop.WindowsApi.ProcessAccessTypes,System.Boolean,System.UInt32)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.OpenProcessToken Method

Grid Solutions Framework WindowsApiOpenProcessToken Method
Win32 OpenProcessToken function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool OpenProcessToken(
    IntPtr ProcessHandle,
    uint DesiredAccess,
    ref IntPtr TokenHandle
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function OpenProcessToken (
    ProcessHandle As IntPtr,
    DesiredAccess As UInteger,
    ByRef TokenHandle As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member OpenProcessToken :
        ProcessHandle : IntPtr *
        DesiredAccess : uint32 *
        TokenHandle : IntPtr byref -> bool

GSF.Interop.WindowsApi.OpenProcessToken = function(ProcessHandle, DesiredAccess, TokenHandle);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool OpenProcessToken(
    IntPtr ProcessHandle,
    unsigned int DesiredAccess,
    IntPtr% TokenHandle
)

Parameters

ProcessHandle
Type: SystemIntPtr

[Missing <param name="ProcessHandle"/> documentation for "M:GSF.Interop.WindowsApi.OpenProcessToken(System.IntPtr,System.UInt32,System.IntPtr@)"]

DesiredAccess
Type: SystemUInt32

[Missing <param name="DesiredAccess"/> documentation for "M:GSF.Interop.WindowsApi.OpenProcessToken(System.IntPtr,System.UInt32,System.IntPtr@)"]

TokenHandle
Type: SystemIntPtr

[Missing <param name="TokenHandle"/> documentation for "M:GSF.Interop.WindowsApi.OpenProcessToken(System.IntPtr,System.UInt32,System.IntPtr@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.OpenProcessToken(System.IntPtr,System.UInt32,System.IntPtr@)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.OpenSCManager Method

Grid Solutions Framework WindowsApiOpenSCManager Method
Win32 OpenSCManager function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static IntPtr OpenSCManager(
    string lpMachineName,
    string lpDatabaseName,
    int dwDesiredAccess
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function OpenSCManager (
    lpMachineName As String,
    lpDatabaseName As String,
    dwDesiredAccess As Integer
) As IntPtr
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member OpenSCManager :
        lpMachineName : string *
        lpDatabaseName : string *
        dwDesiredAccess : int -> IntPtr

GSF.Interop.WindowsApi.OpenSCManager = function(lpMachineName, lpDatabaseName, dwDesiredAccess);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static IntPtr OpenSCManager(
    String^ lpMachineName,
    String^ lpDatabaseName,
    int dwDesiredAccess
)

Parameters

lpMachineName
Type: SystemString

[Missing <param name="lpMachineName"/> documentation for "M:GSF.Interop.WindowsApi.OpenSCManager(System.String,System.String,System.Int32)"]

lpDatabaseName
Type: SystemString

[Missing <param name="lpDatabaseName"/> documentation for "M:GSF.Interop.WindowsApi.OpenSCManager(System.String,System.String,System.Int32)"]

dwDesiredAccess
Type: SystemInt32

[Missing <param name="dwDesiredAccess"/> documentation for "M:GSF.Interop.WindowsApi.OpenSCManager(System.String,System.String,System.Int32)"]

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.OpenSCManager(System.String,System.String,System.Int32)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.OpenService Method

Grid Solutions Framework WindowsApiOpenService Method
Win32 OpenService function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static IntPtr OpenService(
    IntPtr hSCManager,
    string lpServiceName,
    int dwDesiredAccess
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function OpenService (
    hSCManager As IntPtr,
    lpServiceName As String,
    dwDesiredAccess As Integer
) As IntPtr
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member OpenService :
        hSCManager : IntPtr *
        lpServiceName : string *
        dwDesiredAccess : int -> IntPtr

GSF.Interop.WindowsApi.OpenService = function(hSCManager, lpServiceName, dwDesiredAccess);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static IntPtr OpenService(
    IntPtr hSCManager,
    String^ lpServiceName,
    int dwDesiredAccess
)

Parameters

hSCManager
Type: SystemIntPtr

[Missing <param name="hSCManager"/> documentation for "M:GSF.Interop.WindowsApi.OpenService(System.IntPtr,System.String,System.Int32)"]

lpServiceName
Type: SystemString

[Missing <param name="lpServiceName"/> documentation for "M:GSF.Interop.WindowsApi.OpenService(System.IntPtr,System.String,System.Int32)"]

dwDesiredAccess
Type: SystemInt32

[Missing <param name="dwDesiredAccess"/> documentation for "M:GSF.Interop.WindowsApi.OpenService(System.IntPtr,System.String,System.Int32)"]

Return Value

Type: IntPtr

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.OpenService(System.IntPtr,System.String,System.Int32)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.UnlockServiceDatabase Method

Grid Solutions Framework WindowsApiUnlockServiceDatabase Method
Win32 UnlockServiceDatabase function.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DllImportAttribute("advapi32.dll", SetLastError = true)]
public static bool UnlockServiceDatabase(
    IntPtr hSCManager
)
<DllImportAttribute("advapi32.dll", SetLastError := true>]
Public Shared Function UnlockServiceDatabase (
    hSCManager As IntPtr
) As Boolean
[<DllImportAttribute("advapi32.dll", SetLastError = true)>]
static member UnlockServiceDatabase :
        hSCManager : IntPtr -> bool

GSF.Interop.WindowsApi.UnlockServiceDatabase = function(hSCManager);
public:
[DllImportAttribute(L"advapi32.dll", SetLastError = true)]
static bool UnlockServiceDatabase(
    IntPtr hSCManager
)

Parameters

hSCManager
Type: SystemIntPtr

[Missing <param name="hSCManager"/> documentation for "M:GSF.Interop.WindowsApi.UnlockServiceDatabase(System.IntPtr)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.Interop.WindowsApi.UnlockServiceDatabase(System.IntPtr)"]

See Also

Reference

WindowsApi Class
GSF.Interop Namespace


WindowsApi.CreationFlags Enumeration

Grid Solutions Framework WindowsApiCreationFlags Enumeration
Win32 CreationFlags enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum CreationFlags
<FlagsAttribute>
Public Enumeration CreationFlags
[<FlagsAttribute>]
type CreationFlags
GSF.Interop.CreationFlags = function();
GSF.Interop.CreationFlags.createEnum('GSF.Interop.CreationFlags', true);
[FlagsAttribute]
public enum class CreationFlags
Members
Member name | Value | Description
CREATE_SUSPENDED | 4 |
CREATE_NEW_CONSOLE | 16 |
CREATE_NEW_PROCESS_GROUP | 512 |
CREATE_UNICODE_ENVIRONMENT | 1024 |
CREATE_SEPARATE_WOW_VDM | 2048 |
CREATE_DEFAULT_ERROR_MODE | 67108864 |
See Also

Reference

GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO Class

Grid Solutions Framework WindowsApiCRYPT_OID_INFO Class
Win32 CRYPT_OID_INFO class.
Inheritance Hierarchy
SystemObject
GSF.InteropWindowsApiCRYPT_OID_INFO

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[StructLayoutAttribute(LayoutKind.Sequential, CharSet = CharSet.Ansi)]
public class CRYPT_OID_INFO
<StructLayoutAttribute(LayoutKind.Sequential, CharSet := CharSet.Ansi)>
Public Class CRYPT_OID_INFO
[<StructLayoutAttribute(LayoutKind.Sequential, CharSet = CharSet.Ansi)>]
type CRYPT_OID_INFO =  class end
GSF.Interop.CRYPT_OID_INFO = function();

Type.createClass(
    'GSF.Interop.CRYPT_OID_INFO');
[StructLayoutAttribute(LayoutKind::Sequential, CharSet = CharSet::Ansi)]
public ref class CRYPT_OID_INFO

The WindowsApiCRYPT_OID_INFO type exposes the following members.

Constructors
 | Name | Description
Public method | WindowsApiCRYPT_OID_INFO | Initializes a new instance of the WindowsApiCRYPT_OID_INFO class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | cbSize |
Public field | dwGroupId |
Public field | dwValueOrAlgidordwLength |
Public field | ExtraInfo |
Public field | pszOID |
Public field | pwszCNGAlgid |
Public field | pwszCNGExtraAlgid |
Public field | pwszName |
Top
See Also

Reference

GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO Constructor

Grid Solutions Framework WindowsApiCRYPT_OID_INFO Constructor
Initializes a new instance of the WindowsApiCRYPT_OID_INFO class

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CRYPT_OID_INFO()
Public Sub New
new : unit -> CRYPT_OID_INFO
GSF.Interop.CRYPT_OID_INFO = function();
public:
CRYPT_OID_INFO()
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


CRYPT_OID_INFO Fields

Grid Solutions Framework CRYPT_OID_INFO Fields

The WindowsApiCRYPT_OID_INFO type exposes the following members.

Fields
 | Name | Description
Public field | cbSize |
Public field | dwGroupId |
Public field | dwValueOrAlgidordwLength |
Public field | ExtraInfo |
Public field | pszOID |
Public field | pwszCNGAlgid |
Public field | pwszCNGExtraAlgid |
Public field | pwszName |
Top
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.cbSize Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOcbSize Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.cbSize"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int cbSize
Public cbSize As Integer
val mutable cbSize: int
var cbSize
public:
int cbSize

Field Value

Type: Int32
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.dwGroupId Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOdwGroupId Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.dwGroupId"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int dwGroupId
Public dwGroupId As Integer
val mutable dwGroupId: int
var dwGroupId
public:
int dwGroupId

Field Value

Type: Int32
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.dwValueOrAlgidordwLength Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOdwValueOrAlgidordwLength Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.dwValueOrAlgidordwLength"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int dwValueOrAlgidordwLength
Public dwValueOrAlgidordwLength As Integer
val mutable dwValueOrAlgidordwLength: int
var dwValueOrAlgidordwLength
public:
int dwValueOrAlgidordwLength

Field Value

Type: Int32
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.ExtraInfo Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOExtraInfo Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.ExtraInfo"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WindowsApiCRYPTOAPI_BLOB ExtraInfo
Public ExtraInfo As WindowsApiCRYPTOAPI_BLOB
val mutable ExtraInfo: WindowsApiCRYPTOAPI_BLOB
var ExtraInfo
public:
WindowsApiCRYPTOAPI_BLOB ExtraInfo

Field Value

Type: WindowsApiCRYPTOAPI_BLOB
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.pszOID Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOpszOID Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.pszOID"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string pszOID
Public pszOID As String
val mutable pszOID: string
var pszOID
public:
String^ pszOID

Field Value

Type: String
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.pwszCNGAlgid Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOpwszCNGAlgid Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.pwszCNGAlgid"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string pwszCNGAlgid
Public pwszCNGAlgid As String
val mutable pwszCNGAlgid: string
var pwszCNGAlgid
public:
String^ pwszCNGAlgid

Field Value

Type: String
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.pwszCNGExtraAlgid Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOpwszCNGExtraAlgid Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.pwszCNGExtraAlgid"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string pwszCNGExtraAlgid
Public pwszCNGExtraAlgid As String
val mutable pwszCNGExtraAlgid: string
var pwszCNGExtraAlgid
public:
String^ pwszCNGExtraAlgid

Field Value

Type: String
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPT_OID_INFO.pwszName Field

Grid Solutions Framework WindowsApiCRYPT_OID_INFOpwszName Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPT_OID_INFO.pwszName"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string pwszName
Public pwszName As String
val mutable pwszName: string
var pwszName
public:
String^ pwszName

Field Value

Type: String
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


CRYPT_OID_INFO Methods

Grid Solutions Framework CRYPT_OID_INFO Methods

The WindowsApiCRYPT_OID_INFO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiCRYPT_OID_INFO Class
GSF.Interop Namespace


WindowsApi.CRYPTOAPI_BLOB Structure

Grid Solutions Framework WindowsApiCRYPTOAPI_BLOB Structure
Win32 CRYPTOAPI_BLOB structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct CRYPTOAPI_BLOB
Public Structure CRYPTOAPI_BLOB
[<SealedAttribute>]
type CRYPTOAPI_BLOB =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class CRYPTOAPI_BLOB

The WindowsApiCRYPTOAPI_BLOB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | cbData |
Public field | pbData |
Top
See Also

Reference

GSF.Interop Namespace


CRYPTOAPI_BLOB Fields

Grid Solutions Framework CRYPTOAPI_BLOB Fields

The WindowsApiCRYPTOAPI_BLOB type exposes the following members.

Fields
 | Name | Description
Public field | cbData |
Public field | pbData |
Top
See Also

Reference

WindowsApiCRYPTOAPI_BLOB Structure
GSF.Interop Namespace


WindowsApi.CRYPTOAPI_BLOB.cbData Field

Grid Solutions Framework WindowsApiCRYPTOAPI_BLOBcbData Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPTOAPI_BLOB.cbData"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int cbData
Public cbData As Integer
val mutable cbData: int
var cbData
public:
int cbData

Field Value

Type: Int32
See Also

Reference

WindowsApiCRYPTOAPI_BLOB Structure
GSF.Interop Namespace


WindowsApi.CRYPTOAPI_BLOB.pbData Field

Grid Solutions Framework WindowsApiCRYPTOAPI_BLOBpbData Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.CRYPTOAPI_BLOB.pbData"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr pbData
Public pbData As IntPtr
val mutable pbData: IntPtr
var pbData
public:
IntPtr pbData

Field Value

Type: IntPtr
See Also

Reference

WindowsApiCRYPTOAPI_BLOB Structure
GSF.Interop Namespace


CRYPTOAPI_BLOB Methods

Grid Solutions Framework CRYPTOAPI_BLOB Methods

The WindowsApiCRYPTOAPI_BLOB type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiCRYPTOAPI_BLOB Structure
GSF.Interop Namespace


WindowsApi.LogonFlags Enumeration

Grid Solutions Framework WindowsApiLogonFlags Enumeration
Win32 LogonFlags enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum LogonFlags
<FlagsAttribute>
Public Enumeration LogonFlags
[<FlagsAttribute>]
type LogonFlags
GSF.Interop.LogonFlags = function();
GSF.Interop.LogonFlags.createEnum('GSF.Interop.LogonFlags', true);
[FlagsAttribute]
public enum class LogonFlags
Members
Member name | Value | Description
WithProfile | 1 | Log on, then load the user's profile in the HKEY_USERS registry key. The function returns after the profile has been loaded. Loading the profile can be time-consuming, so it is best to use this value only if you must access the information in the HKEY_CURRENT_USER registry key. NOTE: Windows Server 2003: The profile is unloaded after the new process has been terminated, regardless of whether it has created child processes.
NetCredentialsOnly | 2 | Log on, but use the specified credentials on the network only. The new process uses the same token as the caller, but the system creates a new logon session within LSA, and the process uses the specified credentials as the default credentials. This value can be used to create a process that uses a different set of credentials locally than it does remotely. This is useful in inter-domain scenarios where there is no trust relationship. The system does not validate the specified credentials. Therefore, the process can start, but it may not have access to network resources.
See Also

Reference

GSF.Interop Namespace


WindowsApi.LSA_OBJECT_ATTRIBUTES Structure

Grid Solutions Framework WindowsApiLSA_OBJECT_ATTRIBUTES Structure
Win32 LSA_OBJECT_ATTRIBUTES structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct LSA_OBJECT_ATTRIBUTES
Public Structure LSA_OBJECT_ATTRIBUTES
[<SealedAttribute>]
type LSA_OBJECT_ATTRIBUTES =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class LSA_OBJECT_ATTRIBUTES

The WindowsApiLSA_OBJECT_ATTRIBUTES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Attributes |
Public field | Length |
Public field | ObjectName |
Public field | RootDirectory |
Public field | SecurityDescriptor |
Public field | SecurityQualityOfService |
Top
See Also

Reference

GSF.Interop Namespace


LSA_OBJECT_ATTRIBUTES Fields

Grid Solutions Framework LSA_OBJECT_ATTRIBUTES Fields

The WindowsApiLSA_OBJECT_ATTRIBUTES type exposes the following members.

Fields
 | Name | Description
Public field | Attributes |
Public field | Length |
Public field | ObjectName |
Public field | RootDirectory |
Public field | SecurityDescriptor |
Public field | SecurityQualityOfService |
Top
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LSA_OBJECT_ATTRIBUTES.Attributes Field

Grid Solutions Framework WindowsApiLSA_OBJECT_ATTRIBUTESAttributes Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES.Attributes"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Attributes
Public Attributes As Integer
val mutable Attributes: int
var Attributes
public:
int Attributes

Field Value

Type: Int32
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LSA_OBJECT_ATTRIBUTES.Length Field

Grid Solutions Framework WindowsApiLSA_OBJECT_ATTRIBUTESLength Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES.Length"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Length
Public Length As Integer
val mutable Length: int
var Length
public:
int Length

Field Value

Type: Int32
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LSA_OBJECT_ATTRIBUTES.ObjectName Field

Grid Solutions Framework WindowsApiLSA_OBJECT_ATTRIBUTESObjectName Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES.ObjectName"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr ObjectName
Public ObjectName As IntPtr
val mutable ObjectName: IntPtr
var ObjectName
public:
IntPtr ObjectName

Field Value

Type: IntPtr
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LSA_OBJECT_ATTRIBUTES.RootDirectory Field

Grid Solutions Framework WindowsApiLSA_OBJECT_ATTRIBUTESRootDirectory Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES.RootDirectory"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr RootDirectory
Public RootDirectory As IntPtr
val mutable RootDirectory: IntPtr
var RootDirectory
public:
IntPtr RootDirectory

Field Value

Type: IntPtr
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LSA_OBJECT_ATTRIBUTES.SecurityDescriptor Field

Grid Solutions Framework WindowsApiLSA_OBJECT_ATTRIBUTESSecurityDescriptor Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES.SecurityDescriptor"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr SecurityDescriptor
Public SecurityDescriptor As IntPtr
val mutable SecurityDescriptor: IntPtr
var SecurityDescriptor
public:
IntPtr SecurityDescriptor

Field Value

Type: IntPtr
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LSA_OBJECT_ATTRIBUTES.SecurityQualityOfService Field

Grid Solutions Framework WindowsApiLSA_OBJECT_ATTRIBUTESSecurityQualityOfService Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.LSA_OBJECT_ATTRIBUTES.SecurityQualityOfService"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr SecurityQualityOfService
Public SecurityQualityOfService As IntPtr
val mutable SecurityQualityOfService: IntPtr
var SecurityQualityOfService
public:
IntPtr SecurityQualityOfService

Field Value

Type: IntPtr
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


LSA_OBJECT_ATTRIBUTES Methods

Grid Solutions Framework LSA_OBJECT_ATTRIBUTES Methods

The WindowsApiLSA_OBJECT_ATTRIBUTES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiLSA_OBJECT_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LSA_UNICODE_STRING Structure

Grid Solutions Framework WindowsApiLSA_UNICODE_STRING Structure
Win32 LSA_UNICODE_STRING structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct LSA_UNICODE_STRING
Public Structure LSA_UNICODE_STRING
[<SealedAttribute>]
type LSA_UNICODE_STRING =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class LSA_UNICODE_STRING

The WindowsApiLSA_UNICODE_STRING type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Buffer | Pointer to string data.
Public field | Length | Specifies the length of the string.
Public field | MaximumLength | Specifies the maximum length of the string.
Top
See Also

Reference

GSF.Interop Namespace


LSA_UNICODE_STRING Fields

Grid Solutions Framework LSA_UNICODE_STRING Fields

The WindowsApiLSA_UNICODE_STRING type exposes the following members.

Fields
 | Name | Description
Public field | Buffer | Pointer to string data.
Public field | Length | Specifies the length of the string.
Public field | MaximumLength | Specifies the maximum length of the string.
Top
See Also

Reference

WindowsApiLSA_UNICODE_STRING Structure
GSF.Interop Namespace


WindowsApi.LSA_UNICODE_STRING.Buffer Field

Grid Solutions Framework WindowsApiLSA_UNICODE_STRINGBuffer Field
Pointer to string data.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr Buffer
Public Buffer As IntPtr
val mutable Buffer: IntPtr
var Buffer
public:
IntPtr Buffer

Field Value

Type: IntPtr
See Also

Reference

WindowsApiLSA_UNICODE_STRING Structure
GSF.Interop Namespace


WindowsApi.LSA_UNICODE_STRING.Length Field

Grid Solutions Framework WindowsApiLSA_UNICODE_STRINGLength Field
Specifies the length of the string.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Length
Public Length As UShort
val mutable Length: uint16
var Length
public:
unsigned short Length

Field Value

Type: UInt16
See Also

Reference

WindowsApiLSA_UNICODE_STRING Structure
GSF.Interop Namespace


WindowsApi.LSA_UNICODE_STRING.MaximumLength Field

Grid Solutions Framework WindowsApiLSA_UNICODE_STRINGMaximumLength Field
Specifies the maximum length of the string.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort MaximumLength
Public MaximumLength As UShort
val mutable MaximumLength: uint16
var MaximumLength
public:
unsigned short MaximumLength

Field Value

Type: UInt16
See Also

Reference

WindowsApiLSA_UNICODE_STRING Structure
GSF.Interop Namespace


LSA_UNICODE_STRING Methods

Grid Solutions Framework LSA_UNICODE_STRING Methods

The WindowsApiLSA_UNICODE_STRING type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiLSA_UNICODE_STRING Structure
GSF.Interop Namespace


WindowsApi.LsaAccess Enumeration

Grid Solutions Framework WindowsApiLsaAccess Enumeration
LSA API policy access enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum LsaAccess
Public Enumeration LsaAccess
type LsaAccess
GSF.Interop.LsaAccess = function();
GSF.Interop.LsaAccess.createEnum('GSF.Interop.LsaAccess', false);
public enum class LsaAccess
Members
Member name | Value | Description
POLICY_READ | 131078 |
POLICY_ALL_ACCESS | 987135 |
POLICY_EXECUTE | 133121 |
POLICY_WRITE | 133112 |
See Also

Reference

GSF.Interop Namespace


WindowsApi.LUID_AND_ATTRIBUTES Structure

Grid Solutions Framework WindowsApiLUID_AND_ATTRIBUTES Structure
Win32 LUID_AND_ATTRIBUTES structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct LUID_AND_ATTRIBUTES
Public Structure LUID_AND_ATTRIBUTES
[<SealedAttribute>]
type LUID_AND_ATTRIBUTES =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class LUID_AND_ATTRIBUTES

The WindowsApiLUID_AND_ATTRIBUTES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Attributes | Specifies attributes of the LUID. This value contains up to 32 one-bit flags. Its meaning is dependent on the definition and use of the LUID.
Public field | Luid | Specifies an LUID value.
Top
Remarks
An LUID_AND_ATTRIBUTES structure can represent an LUID whose attributes change frequently, such as when the LUID is used to represent privileges in the PRIVILEGE_SET structure. Privileges are represented by LUIDs and have attributes indicating whether they are currently enabled or disabled.
See Also

Reference

GSF.Interop Namespace


LUID_AND_ATTRIBUTES Fields

Grid Solutions Framework LUID_AND_ATTRIBUTES Fields

The WindowsApiLUID_AND_ATTRIBUTES type exposes the following members.

Fields
 | Name | Description
Public field | Attributes | Specifies attributes of the LUID. This value contains up to 32 one-bit flags. Its meaning is dependent on the definition and use of the LUID.
Public field | Luid | Specifies an LUID value.
Top
See Also

Reference

WindowsApiLUID_AND_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LUID_AND_ATTRIBUTES.Attributes Field

Grid Solutions Framework WindowsApiLUID_AND_ATTRIBUTESAttributes Field
Specifies attributes of the LUID. This value contains up to 32 one-bit flags. Its meaning is dependent on the definition and use of the LUID.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Attributes
Public Attributes As UInteger
val mutable Attributes: uint32
var Attributes
public:
unsigned int Attributes

Field Value

Type: UInt32
See Also

Reference

WindowsApiLUID_AND_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.LUID_AND_ATTRIBUTES.Luid Field

Grid Solutions Framework WindowsApiLUID_AND_ATTRIBUTESLuid Field
Specifies an LUID value.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Luid
Public Luid As Long
val mutable Luid: int64
var Luid
public:
long long Luid

Field Value

Type: Int64
See Also

Reference

WindowsApiLUID_AND_ATTRIBUTES Structure
GSF.Interop Namespace


LUID_AND_ATTRIBUTES Methods

Grid Solutions Framework LUID_AND_ATTRIBUTES Methods

The WindowsApiLUID_AND_ATTRIBUTES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiLUID_AND_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.PROCESS_INFORMATION Structure

Grid Solutions Framework WindowsApiPROCESS_INFORMATION Structure
Win32 PROCESS_INFORMATION structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct PROCESS_INFORMATION
Public Structure PROCESS_INFORMATION
[<SealedAttribute>]
type PROCESS_INFORMATION =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class PROCESS_INFORMATION

The WindowsApiPROCESS_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | hProcess |
Public field | hThread |
Public field | ProcessId |
Public field | ThreadId |
Top
See Also

Reference

GSF.Interop Namespace


PROCESS_INFORMATION Fields

Grid Solutions Framework PROCESS_INFORMATION Fields

The WindowsApiPROCESS_INFORMATION type exposes the following members.

Fields
 | Name | Description
Public field | hProcess |
Public field | hThread |
Public field | ProcessId |
Public field | ThreadId |
Top
See Also

Reference

WindowsApiPROCESS_INFORMATION Structure
GSF.Interop Namespace


WindowsApi.PROCESS_INFORMATION.hProcess Field

Grid Solutions Framework WindowsApiPROCESS_INFORMATIONhProcess Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.PROCESS_INFORMATION.hProcess"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr hProcess
Public hProcess As IntPtr
val mutable hProcess: IntPtr
var hProcess
public:
IntPtr hProcess

Field Value

Type: IntPtr
See Also

Reference

WindowsApiPROCESS_INFORMATION Structure
GSF.Interop Namespace


WindowsApi.PROCESS_INFORMATION.hThread Field

Grid Solutions Framework WindowsApiPROCESS_INFORMATIONhThread Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.PROCESS_INFORMATION.hThread"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr hThread
Public hThread As IntPtr
val mutable hThread: IntPtr
var hThread
public:
IntPtr hThread

Field Value

Type: IntPtr
See Also

Reference

WindowsApiPROCESS_INFORMATION Structure
GSF.Interop Namespace


WindowsApi.PROCESS_INFORMATION.ProcessId Field

Grid Solutions Framework WindowsApiPROCESS_INFORMATIONProcessId Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.PROCESS_INFORMATION.ProcessId"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ProcessId
Public ProcessId As Integer
val mutable ProcessId: int
var ProcessId
public:
int ProcessId

Field Value

Type: Int32
See Also

Reference

WindowsApiPROCESS_INFORMATION Structure
GSF.Interop Namespace


WindowsApi.PROCESS_INFORMATION.ThreadId Field

Grid Solutions Framework WindowsApiPROCESS_INFORMATIONThreadId Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.PROCESS_INFORMATION.ThreadId"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ThreadId
Public ThreadId As Integer
val mutable ThreadId: int
var ThreadId
public:
int ThreadId

Field Value

Type: Int32
See Also

Reference

WindowsApiPROCESS_INFORMATION Structure
GSF.Interop Namespace


PROCESS_INFORMATION Methods

Grid Solutions Framework PROCESS_INFORMATION Methods

The WindowsApiPROCESS_INFORMATION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiPROCESS_INFORMATION Structure
GSF.Interop Namespace


WindowsApi.ProcessAccessTypes Enumeration

Grid Solutions Framework WindowsApiProcessAccessTypes Enumeration
Win32 ProcessAccessTypes enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum ProcessAccessTypes
<FlagsAttribute>
Public Enumeration ProcessAccessTypes
[<FlagsAttribute>]
type ProcessAccessTypes
GSF.Interop.ProcessAccessTypes = function();
GSF.Interop.ProcessAccessTypes.createEnum('GSF.Interop.ProcessAccessTypes', true);
[FlagsAttribute]
public enum class ProcessAccessTypes
Members
Member name | Value | Description
PROCESS_TERMINATE | 1 | Enables usage of the process handle in the TerminateProcess function to terminate the process.
PROCESS_CREATE_THREAD | 2 | Enables usage of the process handle in the CreateRemoteThread function to create a thread in the process.
PROCESS_SET_SESSIONID | 4 | Sets the session ID.
PROCESS_VM_OPERATION | 8 | Enables usage of the process handle in the VirtualProtectEx and WriteProcessMemory functions to modify the virtual memory of the process.
PROCESS_VM_READ | 16 | Enables usage of the process handle in the ReadProcessMemory function to read from the virtual memory of the process.
PROCESS_VM_WRITE | 32 | Enables usage of the process handle in the WriteProcessMemory function to write to the virtual memory of the process.
PROCESS_DUP_HANDLE | 64 | Enables usage of the process handle as either the source or target process in the DuplicateHandle function to duplicate a handle.
PROCESS_CREATE_PROCESS | 128 | Creates a process.
PROCESS_SET_QUOTA | 256 | Sets quota.
PROCESS_SET_INFORMATION | 512 | Enables usage of the process handle in the SetPriorityClass function to set the priority class of the process.
PROCESS_QUERY_INFORMATION | 1024 | Enables usage of the process handle in the GetExitCodeProcess and GetPriorityClass functions to read information from the process object.
STANDARD_RIGHTS_REQUIRED | 983040 | Standard rights required.
SYNCHRONIZE | 1048576 | Enables usage of the process handle in any of the wait functions to wait for the process to terminate.
PROCESS_ALL_ACCESS | 2033663 | Specifies all possible access flags for the process object.
See Also

Reference

GSF.Interop Namespace


WindowsApi.SC_ACTION Structure

Grid Solutions Framework WindowsApiSC_ACTION Structure
Win32 SC_ACTION structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SC_ACTION
Public Structure SC_ACTION
[<SealedAttribute>]
type SC_ACTION =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SC_ACTION

The WindowsApiSC_ACTION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Delay | The time to wait before performing the specified action, in milliseconds.
Public field | Type | The WindowsApiSC_ACTION_TYPE to be performed.
Top
See Also

Reference

GSF.Interop Namespace


SC_ACTION Fields

Grid Solutions Framework SC_ACTION Fields

The WindowsApiSC_ACTION type exposes the following members.

Fields
 | Name | Description
Public field | Delay | The time to wait before performing the specified action, in milliseconds.
Public field | Type | The WindowsApiSC_ACTION_TYPE to be performed.
Top
See Also

Reference

WindowsApiSC_ACTION Structure
GSF.Interop Namespace


WindowsApi.SC_ACTION.Delay Field

Grid Solutions Framework WindowsApiSC_ACTIONDelay Field
The time to wait before performing the specified action, in milliseconds.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Delay
Public Delay As Integer
val mutable Delay: int
var Delay
public:
int Delay

Field Value

Type: Int32
See Also

Reference

WindowsApiSC_ACTION Structure
GSF.Interop Namespace


WindowsApi.SC_ACTION.Type Field

Grid Solutions Framework WindowsApiSC_ACTIONType Field
The WindowsApiSC_ACTION_TYPE to be performed.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WindowsApiSC_ACTION_TYPE Type
Public Type As WindowsApiSC_ACTION_TYPE
val mutable Type: WindowsApiSC_ACTION_TYPE
var Type
public:
WindowsApiSC_ACTION_TYPE Type

Field Value

Type: WindowsApiSC_ACTION_TYPE
See Also

Reference

WindowsApiSC_ACTION Structure
GSF.Interop Namespace


SC_ACTION Methods

Grid Solutions Framework SC_ACTION Methods

The WindowsApiSC_ACTION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiSC_ACTION Structure
GSF.Interop Namespace


WindowsApi.SC_ACTION_TYPE Enumeration

Grid Solutions Framework WindowsApiSC_ACTION_TYPE Enumeration
Win32 SC_ACTION_TYPE enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SC_ACTION_TYPE
Public Enumeration SC_ACTION_TYPE
type SC_ACTION_TYPE
GSF.Interop.SC_ACTION_TYPE = function();
GSF.Interop.SC_ACTION_TYPE.createEnum('GSF.Interop.SC_ACTION_TYPE', false);
public enum class SC_ACTION_TYPE
Members
Member name | Value | Description
SC_ACTION_NONE | 0 | No action.
SC_ACTION_RESTART | 1 | Restart the service.
SC_ACTION_REBOOT | 2 | Reboot the computer.
SC_ACTION_RUN_COMMAND | 3 | Run a command.
See Also

Reference

GSF.Interop Namespace


WindowsApi.SECURITY_ATTRIBUTES Structure

Grid Solutions Framework WindowsApiSECURITY_ATTRIBUTES Structure
Win32 SECURITY_ATTRIBUTES structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SECURITY_ATTRIBUTES
Public Structure SECURITY_ATTRIBUTES
[<SealedAttribute>]
type SECURITY_ATTRIBUTES =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SECURITY_ATTRIBUTES

The WindowsApiSECURITY_ATTRIBUTES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | bInheritHandle |
Public field | lpSecurityDescriptor |
Public field | nLength |
Top
See Also

Reference

GSF.Interop Namespace


SECURITY_ATTRIBUTES Fields

Grid Solutions Framework SECURITY_ATTRIBUTES Fields

The WindowsApiSECURITY_ATTRIBUTES type exposes the following members.

Fields
 | Name | Description
Public field | bInheritHandle |
Public field | lpSecurityDescriptor |
Public field | nLength |
Top
See Also

Reference

WindowsApiSECURITY_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.SECURITY_ATTRIBUTES.bInheritHandle Field

Grid Solutions Framework WindowsApiSECURITY_ATTRIBUTESbInheritHandle Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES.bInheritHandle"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int bInheritHandle
Public bInheritHandle As Integer
val mutable bInheritHandle: int
var bInheritHandle
public:
int bInheritHandle

Field Value

Type: Int32
See Also

Reference

WindowsApiSECURITY_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.SECURITY_ATTRIBUTES.lpSecurityDescriptor Field

Grid Solutions Framework WindowsApiSECURITY_ATTRIBUTESlpSecurityDescriptor Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES.lpSecurityDescriptor"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr lpSecurityDescriptor
Public lpSecurityDescriptor As IntPtr
val mutable lpSecurityDescriptor: IntPtr
var lpSecurityDescriptor
public:
IntPtr lpSecurityDescriptor

Field Value

Type: IntPtr
See Also

Reference

WindowsApiSECURITY_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.SECURITY_ATTRIBUTES.nLength Field

Grid Solutions Framework WindowsApiSECURITY_ATTRIBUTESnLength Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.SECURITY_ATTRIBUTES.nLength"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int nLength
Public nLength As Integer
val mutable nLength: int
var nLength
public:
int nLength

Field Value

Type: Int32
See Also

Reference

WindowsApiSECURITY_ATTRIBUTES Structure
GSF.Interop Namespace


SECURITY_ATTRIBUTES Methods

Grid Solutions Framework SECURITY_ATTRIBUTES Methods

The WindowsApiSECURITY_ATTRIBUTES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiSECURITY_ATTRIBUTES Structure
GSF.Interop Namespace


WindowsApi.SECURITY_IMPERSONATION_LEVEL Enumeration

Grid Solutions Framework WindowsApiSECURITY_IMPERSONATION_LEVEL Enumeration
Win32 SECURITY_IMPERSONATION_LEVEL enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SECURITY_IMPERSONATION_LEVEL
Public Enumeration SECURITY_IMPERSONATION_LEVEL
type SECURITY_IMPERSONATION_LEVEL
GSF.Interop.SECURITY_IMPERSONATION_LEVEL = function();
GSF.Interop.SECURITY_IMPERSONATION_LEVEL.createEnum('GSF.Interop.SECURITY_IMPERSONATION_LEVEL', false);
public enum class SECURITY_IMPERSONATION_LEVEL
Members
Member name | Value | Description
SecurityAnonymous | 0 |
SecurityIdentification | 1 |
SecurityImpersonation | 2 |
SecurityDelegation | 3 |
See Also

Reference

GSF.Interop Namespace


WindowsApi.SERVICE_DESCRIPTION Structure

Grid Solutions Framework WindowsApiSERVICE_DESCRIPTION Structure
Win32 SERVICE_DESCRIPTION structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SERVICE_DESCRIPTION
Public Structure SERVICE_DESCRIPTION
[<SealedAttribute>]
type SERVICE_DESCRIPTION =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SERVICE_DESCRIPTION

The WindowsApiSERVICE_DESCRIPTION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | lpDescription | The description of the service.
Top
Remarks

A description of NULL indicates no service description exists. The service description is NULL when the service is created.

The description is simply a comment that explains the purpose of the service. For example, for the DHCP service, you could use the description "Provides internet addresses for computer on your network."

See Also

Reference

GSF.Interop Namespace


SERVICE_DESCRIPTION Fields

Grid Solutions Framework SERVICE_DESCRIPTION Fields

The WindowsApiSERVICE_DESCRIPTION type exposes the following members.

Fields
 | Name | Description
Public field | lpDescription | The description of the service.
Top
See Also

Reference

WindowsApiSERVICE_DESCRIPTION Structure
GSF.Interop Namespace


WindowsApi.SERVICE_DESCRIPTION.lpDescription Field

Grid Solutions Framework WindowsApiSERVICE_DESCRIPTIONlpDescription Field
The description of the service.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string lpDescription
Public lpDescription As String
val mutable lpDescription: string
var lpDescription
public:
String^ lpDescription

Field Value

Type: String
Remarks
If this member is NULL, the description remains unchanged. If this value is an empty string (""), the current description is deleted.
See Also

Reference

WindowsApiSERVICE_DESCRIPTION Structure
GSF.Interop Namespace


SERVICE_DESCRIPTION Methods

Grid Solutions Framework SERVICE_DESCRIPTION Methods

The WindowsApiSERVICE_DESCRIPTION type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiSERVICE_DESCRIPTION Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS Structure

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONS Structure
Win32 SERVICE_FAILURE_ACTIONS structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SERVICE_FAILURE_ACTIONS
Public Structure SERVICE_FAILURE_ACTIONS
[<SealedAttribute>]
type SERVICE_FAILURE_ACTIONS =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SERVICE_FAILURE_ACTIONS

The WindowsApiSERVICE_FAILURE_ACTIONS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | cActions | The number of elements in the lpsaActions array.
Public field | dwResetPeriod | The time after which to reset the failure count to zero if there are no failures, in seconds. Specify INFINITE to indicate that this value should never be reset.
Public field | lpCommand | The command line of the process for the CreateProcess function to execute in response to the SC_ACTION_RUN_COMMAND service controller action. This process runs under the same account as the service.
Public field | lpRebootMsg | The message to be broadcast to server users before rebooting in response to the SC_ACTION_REBOOT service controller action.
Public field | lpsaActions | A pointer to an array of SC_ACTION structures.
Top
Remarks
Represents the action the service controller should take on each failure of a service. A service is considered failed when it terminates without reporting a status of SERVICE_STOPPED to the service controller.
See Also

Reference

GSF.Interop Namespace


SERVICE_FAILURE_ACTIONS Fields

Grid Solutions Framework SERVICE_FAILURE_ACTIONS Fields

The WindowsApiSERVICE_FAILURE_ACTIONS type exposes the following members.

Fields
 | Name | Description
Public field | cActions | The number of elements in the lpsaActions array.
Public field | dwResetPeriod | The time after which to reset the failure count to zero if there are no failures, in seconds. Specify INFINITE to indicate that this value should never be reset.
Public field | lpCommand | The command line of the process for the CreateProcess function to execute in response to the SC_ACTION_RUN_COMMAND service controller action. This process runs under the same account as the service.
Public field | lpRebootMsg | The message to be broadcast to server users before rebooting in response to the SC_ACTION_REBOOT service controller action.
Public field | lpsaActions | A pointer to an array of SC_ACTION structures.
Top
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS.cActions Field

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONScActions Field
The number of elements in the lpsaActions array.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int cActions
Public cActions As Integer
val mutable cActions: int
var cActions
public:
int cActions

Field Value

Type: Int32
Remarks
If this value is 0, but lpsaActions is not NULL, the reset period and array of failure actions are deleted.
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS.dwResetPeriod Field

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONSdwResetPeriod Field
The time after which to reset the failure count to zero if there are no failures, in seconds. Specify INFINITE to indicate that this value should never be reset.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int dwResetPeriod
Public dwResetPeriod As Integer
val mutable dwResetPeriod: int
var dwResetPeriod
public:
int dwResetPeriod

Field Value

Type: Int32
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS.lpCommand Field

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONSlpCommand Field
The command line of the process for the CreateProcess function to execute in response to the SC_ACTION_RUN_COMMAND service controller action. This process runs under the same account as the service.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string lpCommand
Public lpCommand As String
val mutable lpCommand: string
var lpCommand
public:
String^ lpCommand

Field Value

Type: String
Remarks
If this value is NULL, the command is unchanged. If the value is an empty string (""), the command is deleted and no program is run when the service fails.
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS.lpRebootMsg Field

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONSlpRebootMsg Field
The message to be broadcast to server users before rebooting in response to the SC_ACTION_REBOOT service controller action.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string lpRebootMsg
Public lpRebootMsg As String
val mutable lpRebootMsg: string
var lpRebootMsg
public:
String^ lpRebootMsg

Field Value

Type: String
Remarks
If this value is NULL, the reboot message is unchanged. If the value is an empty string (""), the reboot message is deleted and no message is broadcast.
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS.lpsaActions Field

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONSlpsaActions Field
A pointer to an array of SC_ACTION structures.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr lpsaActions
Public lpsaActions As IntPtr
val mutable lpsaActions: IntPtr
var lpsaActions
public:
IntPtr lpsaActions

Field Value

Type: IntPtr
Remarks
If this value is NULL, the cActions and dwResetPeriod members are ignored.
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS Structure
GSF.Interop Namespace


SERVICE_FAILURE_ACTIONS Methods

Grid Solutions Framework SERVICE_FAILURE_ACTIONS Methods

The WindowsApiSERVICE_FAILURE_ACTIONS type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS_FLAG Structure

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONS_FLAG Structure
Win32 SERVICE_FAILURE_ACTIONS_FLAG structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SERVICE_FAILURE_ACTIONS_FLAG
Public Structure SERVICE_FAILURE_ACTIONS_FLAG
[<SealedAttribute>]
type SERVICE_FAILURE_ACTIONS_FLAG =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SERVICE_FAILURE_ACTIONS_FLAG

The WindowsApiSERVICE_FAILURE_ACTIONS_FLAG type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | bFailureAction | If this member is TRUE and the service has configured failure actions, the failure actions are queued if the service process terminates without reporting a status of SERVICE_STOPPED or if it enters the SERVICE_STOPPED state but the dwWin32ExitCode member of the SERVICE_STATUS structure is not ERROR_SUCCESS (0). If this member is FALSE and the service has configured failure actions, the failure actions are queued only if the service terminates without reporting a status of SERVICE_STOPPED.
Top
Remarks
Contains the failure actions flag setting of a service. This setting determines when failure actions are to be executed.
See Also

Reference

GSF.Interop Namespace


SERVICE_FAILURE_ACTIONS_FLAG Fields

Grid Solutions Framework SERVICE_FAILURE_ACTIONS_FLAG Fields

The WindowsApiSERVICE_FAILURE_ACTIONS_FLAG type exposes the following members.

Fields
 | Name | Description
Public field | bFailureAction | If this member is TRUE and the service has configured failure actions, the failure actions are queued if the service process terminates without reporting a status of SERVICE_STOPPED or if it enters the SERVICE_STOPPED state but the dwWin32ExitCode member of the SERVICE_STATUS structure is not ERROR_SUCCESS (0). If this member is FALSE and the service has configured failure actions, the failure actions are queued only if the service terminates without reporting a status of SERVICE_STOPPED.
Top
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS_FLAG Structure
GSF.Interop Namespace


WindowsApi.SERVICE_FAILURE_ACTIONS_FLAG.bFailureAction Field

Grid Solutions Framework WindowsApiSERVICE_FAILURE_ACTIONS_FLAGbFailureAction Field
If this member is TRUE and the service has configured failure actions, the failure actions are queued if the service process terminates without reporting a status of SERVICE_STOPPED or if it enters the SERVICE_STOPPED state but the dwWin32ExitCode member of the SERVICE_STATUS structure is not ERROR_SUCCESS (0). If this member is FALSE and the service has configured failure actions, the failure actions are queued only if the service terminates without reporting a status of SERVICE_STOPPED.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool bFailureAction
Public bFailureAction As Boolean
val mutable bFailureAction: bool
var bFailureAction
public:
bool bFailureAction

Field Value

Type: Boolean
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS_FLAG Structure
GSF.Interop Namespace


SERVICE_FAILURE_ACTIONS_FLAG Methods

Grid Solutions Framework SERVICE_FAILURE_ACTIONS_FLAG Methods

The WindowsApiSERVICE_FAILURE_ACTIONS_FLAG type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiSERVICE_FAILURE_ACTIONS_FLAG Structure
GSF.Interop Namespace


WindowsApi.ShutdownReason Enumeration

Grid Solutions Framework WindowsApiShutdownReason Enumeration
Win32 ShutdownReason enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum ShutdownReason
<FlagsAttribute>
Public Enumeration ShutdownReason
[<FlagsAttribute>]
type ShutdownReason
GSF.Interop.ShutdownReason = function();
GSF.Interop.ShutdownReason.createEnum('GSF.Interop.ShutdownReason', true);
[FlagsAttribute]
public enum class ShutdownReason
Members
Member name | Value | Description
SHTDN_REASON_MAJOR_OTHER | 0 |
SHTDN_REASON_MAJOR_NONE | 0 |
SHTDN_REASON_MAJOR_HARDWARE | 65536 |
SHTDN_REASON_MAJOR_OPERATINGSYSTEM | 131072 |
SHTDN_REASON_MAJOR_SOFTWARE | 196608 |
SHTDN_REASON_MAJOR_APPLICATION | 262144 |
SHTDN_REASON_MAJOR_SYSTEM | 327680 |
SHTDN_REASON_MAJOR_POWER | 393216 |
SHTDN_REASON_MAJOR_LEGACY_API | 458752 |
SHTDN_REASON_MINOR_OTHER | 0 |
SHTDN_REASON_MINOR_NONE | 255 |
SHTDN_REASON_MINOR_MAINTENANCE | 1 |
SHTDN_REASON_MINOR_INSTALLATION | 2 |
SHTDN_REASON_MINOR_UPGRADE | 3 |
SHTDN_REASON_MINOR_RECONFIG | 4 |
SHTDN_REASON_MINOR_HUNG | 5 |
SHTDN_REASON_MINOR_UNSTABLE | 6 |
SHTDN_REASON_MINOR_DISK | 7 |
SHTDN_REASON_MINOR_PROCESSOR | 8 |
SHTDN_REASON_MINOR_NETWORKCARD | 0 |
SHTDN_REASON_MINOR_POWER_SUPPLY | 10 |
SHTDN_REASON_MINOR_CORDUNPLUGGED | 11 |
SHTDN_REASON_MINOR_ENVIRONMENT | 12 |
SHTDN_REASON_MINOR_HARDWARE_DRIVER | 13 |
SHTDN_REASON_MINOR_OTHERDRIVER | 14 |
SHTDN_REASON_MINOR_BLUESCREEN | 15 |
SHTDN_REASON_MINOR_SERVICEPACK | 16 |
SHTDN_REASON_MINOR_HOTFIX | 17 |
SHTDN_REASON_MINOR_SECURITYFIX | 18 |
SHTDN_REASON_MINOR_SECURITY | 19 |
SHTDN_REASON_MINOR_NETWORK_CONNECTIVITY | 20 |
SHTDN_REASON_MINOR_WMI | 21 |
SHTDN_REASON_MINOR_SERVICEPACK_UNINSTALL | 22 |
SHTDN_REASON_MINOR_HOTFIX_UNINSTALL | 23 |
SHTDN_REASON_MINOR_SECURITYFIX_UNINSTALL | 24 |
SHTDN_REASON_MINOR_MMC | 25 |
SHTDN_REASON_MINOR_TERMSRV | 32 |
SHTDN_REASON_FLAG_USER_DEFINED | 1073741824 |
SHTDN_REASON_FLAG_PLANNED | 2147483648 |
SHTDN_REASON_UNKNOWN | 255 |
SHTDN_REASON_LEGACY_API | 2147942400 |
SHTDN_REASON_VALID_BIT_MASK | 3238002687 |
See Also

Reference

GSF.Interop Namespace


WindowsApi.STARTUPINFO Structure

Grid Solutions Framework WindowsApiSTARTUPINFO Structure
Win32 STARTUPINFO structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct STARTUPINFO
Public Structure STARTUPINFO
[<SealedAttribute>]
type STARTUPINFO =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class STARTUPINFO

The WindowsApiSTARTUPINFO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | cb |
Public field | cbReserved2 |
Public field | dwFillAttribute |
Public field | dwFlags |
Public field | dwX |
Public field | dwXCountChars |
Public field | dwXSize |
Public field | dwY |
Public field | dwYCountChars |
Public field | dwYSize |
Public field | hStdError |
Public field | hStdInput |
Public field | hStdOutput |
Public field | lpDesktop |
Public field | lpReserved |
Public field | lpReserved2 |
Public field | lpTitle |
Public field | wShowWindow |
Top
See Also

Reference

GSF.Interop Namespace


STARTUPINFO Fields

Grid Solutions Framework STARTUPINFO Fields

The WindowsApiSTARTUPINFO type exposes the following members.

Fields
 | Name | Description
Public field | cb |
Public field | cbReserved2 |
Public field | dwFillAttribute |
Public field | dwFlags |
Public field | dwX |
Public field | dwXCountChars |
Public field | dwXSize |
Public field | dwY |
Public field | dwYCountChars |
Public field | dwYSize |
Public field | hStdError |
Public field | hStdInput |
Public field | hStdOutput |
Public field | lpDesktop |
Public field | lpReserved |
Public field | lpReserved2 |
Public field | lpTitle |
Public field | wShowWindow |
Top
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.cb Field

Grid Solutions Framework WindowsApiSTARTUPINFOcb Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.cb"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int cb
Public cb As Integer
val mutable cb: int
var cb
public:
int cb

Field Value

Type: Int32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.cbReserved2 Field

Grid Solutions Framework WindowsApiSTARTUPINFOcbReserved2 Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.cbReserved2"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short cbReserved2
Public cbReserved2 As Short
val mutable cbReserved2: int16
var cbReserved2
public:
short cbReserved2

Field Value

Type: Int16
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwFillAttribute Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwFillAttribute Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwFillAttribute"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwFillAttribute
Public dwFillAttribute As UInteger
val mutable dwFillAttribute: uint32
var dwFillAttribute
public:
unsigned int dwFillAttribute

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwFlags Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwFlags Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwFlags"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwFlags
Public dwFlags As UInteger
val mutable dwFlags: uint32
var dwFlags
public:
unsigned int dwFlags

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwX Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwX Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwX"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwX
Public dwX As UInteger
val mutable dwX: uint32
var dwX
public:
unsigned int dwX

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwXCountChars Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwXCountChars Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwXCountChars"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwXCountChars
Public dwXCountChars As UInteger
val mutable dwXCountChars: uint32
var dwXCountChars
public:
unsigned int dwXCountChars

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwXSize Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwXSize Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwXSize"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwXSize
Public dwXSize As UInteger
val mutable dwXSize: uint32
var dwXSize
public:
unsigned int dwXSize

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwY Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwY Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwY"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwY
Public dwY As UInteger
val mutable dwY: uint32
var dwY
public:
unsigned int dwY

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwYCountChars Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwYCountChars Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwYCountChars"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwYCountChars
Public dwYCountChars As UInteger
val mutable dwYCountChars: uint32
var dwYCountChars
public:
unsigned int dwYCountChars

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.dwYSize Field

Grid Solutions Framework WindowsApiSTARTUPINFOdwYSize Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.dwYSize"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint dwYSize
Public dwYSize As UInteger
val mutable dwYSize: uint32
var dwYSize
public:
unsigned int dwYSize

Field Value

Type: UInt32
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.hStdError Field

Grid Solutions Framework WindowsApiSTARTUPINFOhStdError Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.hStdError"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr hStdError
Public hStdError As IntPtr
val mutable hStdError: IntPtr
var hStdError
public:
IntPtr hStdError

Field Value

Type: IntPtr
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.hStdInput Field

Grid Solutions Framework WindowsApiSTARTUPINFOhStdInput Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.hStdInput"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr hStdInput
Public hStdInput As IntPtr
val mutable hStdInput: IntPtr
var hStdInput
public:
IntPtr hStdInput

Field Value

Type: IntPtr
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.hStdOutput Field

Grid Solutions Framework WindowsApiSTARTUPINFOhStdOutput Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.hStdOutput"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr hStdOutput
Public hStdOutput As IntPtr
val mutable hStdOutput: IntPtr
var hStdOutput
public:
IntPtr hStdOutput

Field Value

Type: IntPtr
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.lpDesktop Field

Grid Solutions Framework WindowsApiSTARTUPINFOlpDesktop Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.lpDesktop"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string lpDesktop
Public lpDesktop As String
val mutable lpDesktop: string
var lpDesktop
public:
String^ lpDesktop

Field Value

Type: String
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.lpReserved Field

Grid Solutions Framework WindowsApiSTARTUPINFOlpReserved Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.lpReserved"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string lpReserved
Public lpReserved As String
val mutable lpReserved: string
var lpReserved
public:
String^ lpReserved

Field Value

Type: String
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.lpReserved2 Field

Grid Solutions Framework WindowsApiSTARTUPINFOlpReserved2 Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.lpReserved2"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IntPtr lpReserved2
Public lpReserved2 As IntPtr
val mutable lpReserved2: IntPtr
var lpReserved2
public:
IntPtr lpReserved2

Field Value

Type: IntPtr
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.lpTitle Field

Grid Solutions Framework WindowsApiSTARTUPINFOlpTitle Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.lpTitle"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string lpTitle
Public lpTitle As String
val mutable lpTitle: string
var lpTitle
public:
String^ lpTitle

Field Value

Type: String
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.STARTUPINFO.wShowWindow Field

Grid Solutions Framework WindowsApiSTARTUPINFOwShowWindow Field

[Missing <summary> documentation for "F:GSF.Interop.WindowsApi.STARTUPINFO.wShowWindow"]

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short wShowWindow
Public wShowWindow As Short
val mutable wShowWindow: int16
var wShowWindow
public:
short wShowWindow

Field Value

Type: Int16
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


STARTUPINFO Methods

Grid Solutions Framework STARTUPINFO Methods

The WindowsApiSTARTUPINFO type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiSTARTUPINFO Structure
GSF.Interop Namespace


WindowsApi.TOKEN_ELEVATION_TYPE Enumeration

Grid Solutions Framework WindowsApiTOKEN_ELEVATION_TYPE Enumeration
Win32 TOKEN_ELEVATION_TYPE enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum TOKEN_ELEVATION_TYPE
Public Enumeration TOKEN_ELEVATION_TYPE
type TOKEN_ELEVATION_TYPE
GSF.Interop.TOKEN_ELEVATION_TYPE = function();
GSF.Interop.TOKEN_ELEVATION_TYPE.createEnum('GSF.Interop.TOKEN_ELEVATION_TYPE', false);
public enum class TOKEN_ELEVATION_TYPE
Members
Member name | Value | Description
TokenElevationTypeDefault | 1 | The token does not have a linked token.
TokenElevationTypeFull | 2 | The token is an elevated token.
TokenElevationTypeLimited | 3 | The token is a limited token.
Remarks
Enumeration indicates the elevation type of token being queried by the GetTokenInformation function or set by the SetTokenInformation function.
See Also

Reference

GSF.Interop Namespace


WindowsApi.TOKEN_INFORMATION_CLASS Enumeration

Grid Solutions Framework WindowsApiTOKEN_INFORMATION_CLASS Enumeration
Win32 TOKEN_INFORMATION_CLASS enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum TOKEN_INFORMATION_CLASS
Public Enumeration TOKEN_INFORMATION_CLASS
type TOKEN_INFORMATION_CLASS
GSF.Interop.TOKEN_INFORMATION_CLASS = function();
GSF.Interop.TOKEN_INFORMATION_CLASS.createEnum('GSF.Interop.TOKEN_INFORMATION_CLASS', false);
public enum class TOKEN_INFORMATION_CLASS
Members
Member name | Value | Description
TokenUser | 1 | The buffer receives a TOKEN_USER structure that contains the user account of the token.
TokenGroups | 2 | The buffer receives a TOKEN_GROUPS structure that contains the group accounts associated with the token.
TokenPrivileges | 3 | The buffer receives a TOKEN_PRIVILEGES structure that contains the privileges of the token.
TokenOwner | 4 | The buffer receives a TOKEN_OWNER structure that contains the default owner security identifier (SID) for newly created objects.
TokenPrimaryGroup | 5 | The buffer receives a TOKEN_PRIMARY_GROUP structure that contains the default primary group SID for newly created objects.
TokenDefaultDacl | 6 | The buffer receives a TOKEN_DEFAULT_DACL structure that contains the default DACL for newly created objects.
TokenSource | 7 | The buffer receives a TOKEN_SOURCE structure that contains the source of the token. TOKEN_QUERY_SOURCE access is needed to retrieve this information.
TokenType | 8 | The buffer receives a TOKEN_TYPE value that indicates whether the token is a primary or impersonation token.
TokenImpersonationLevel | 9 | The buffer receives a SECURITY_IMPERSONATION_LEVEL value that indicates the impersonation level of the token. If the access token is not an impersonation token, the function fails.
TokenStatistics | 10 | The buffer receives a TOKEN_STATISTICS structure that contains various token statistics.
TokenRestrictedSids | 11 | The buffer receives a TOKEN_GROUPS structure that contains the list of restricting SIDs in a restricted token.
TokenSessionId | 12 | The buffer receives a DWORD value that indicates the Terminal Services session identifier that is associated with the token.
TokenGroupsAndPrivileges | 13 | The buffer receives a TOKEN_GROUPS_AND_PRIVILEGES structure that contains the user SID, the group accounts, the restricted SIDs, and the authentication ID associated with the token.
TokenSessionReference | 14 | Reserved.
TokenSandBoxInert | 15 | The buffer receives a DWORD value that is nonzero if the token includes the SANDBOX_INERT flag.
TokenAuditPolicy | 16 | Reserved.
TokenOrigin | 17 | The buffer receives a TOKEN_ORIGIN value.
TokenElevationType | 18 | The buffer receives a TOKEN_ELEVATION_TYPE value that specifies the elevation level of the token.
TokenLinkedToken | 19 | The buffer receives a TOKEN_LINKED_TOKEN structure that contains a handle to another token that is linked to this token.
TokenElevation | 20 | The buffer receives a TOKEN_ELEVATION structure that specifies whether the token is elevated.
TokenHasRestrictions | 21 | The buffer receives a DWORD value that is nonzero if the token has ever been filtered.
TokenAccessInformation | 22 | The buffer receives a TOKEN_ACCESS_INFORMATION structure that specifies security information contained in the token.
TokenVirtualizationAllowed | 23 | The buffer receives a DWORD value that is nonzero if virtualization is allowed for the token.
TokenVirtualizationEnabled | 24 | The buffer receives a DWORD value that is nonzero if virtualization is enabled for the token.
TokenIntegrityLevel | 25 | The buffer receives a TOKEN_MANDATORY_LABEL structure that specifies the token's integrity level.
TokenUIAccess | 26 | The buffer receives a DWORD value that is nonzero if the token has the UIAccess flag set.
TokenMandatoryPolicy | 27 | The buffer receives a TOKEN_MANDATORY_POLICY structure that specifies the token's mandatory integrity policy.
TokenLogonSid | 28 | The buffer receives the token's logon security identifier (SID).
MaxTokenInfoClass | 29 | The maximum value for this enumeration
See Also

Reference

GSF.Interop Namespace


WindowsApi.TOKEN_PRIVILEGES Structure

Grid Solutions Framework WindowsApiTOKEN_PRIVILEGES Structure
Win32 TOKEN_PRIVILEGES structure.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct TOKEN_PRIVILEGES
Public Structure TOKEN_PRIVILEGES
[<SealedAttribute>]
type TOKEN_PRIVILEGES =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class TOKEN_PRIVILEGES

The WindowsApiTOKEN_PRIVILEGES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | PrivilegeCount | This must be set to the number of entries in the Privileges array.
Public field | Privileges | Specifies an array of LUID_AND_ATTRIBUTES structures. Each structure contains the LUID and attributes of a privilege.
Top
Remarks
The TOKEN_PRIVILEGES structure contains information about a set of privileges for an access token.
See Also

Reference

GSF.Interop Namespace


TOKEN_PRIVILEGES Fields

Grid Solutions Framework TOKEN_PRIVILEGES Fields

The WindowsApiTOKEN_PRIVILEGES type exposes the following members.

Fields
 | Name | Description
Public field | PrivilegeCount | This must be set to the number of entries in the Privileges array.
Public field | Privileges | Specifies an array of LUID_AND_ATTRIBUTES structures. Each structure contains the LUID and attributes of a privilege.
Top
See Also

Reference

WindowsApiTOKEN_PRIVILEGES Structure
GSF.Interop Namespace


WindowsApi.TOKEN_PRIVILEGES.PrivilegeCount Field

Grid Solutions Framework WindowsApiTOKEN_PRIVILEGESPrivilegeCount Field
This must be set to the number of entries in the Privileges array.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int PrivilegeCount
Public PrivilegeCount As Integer
val mutable PrivilegeCount: int
var PrivilegeCount
public:
int PrivilegeCount

Field Value

Type: Int32
See Also

Reference

WindowsApiTOKEN_PRIVILEGES Structure
GSF.Interop Namespace


WindowsApi.TOKEN_PRIVILEGES.Privileges Field

Grid Solutions Framework WindowsApiTOKEN_PRIVILEGESPrivileges Field
Specifies an array of LUID_AND_ATTRIBUTES structures. Each structure contains the LUID and attributes of a privilege.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WindowsApiLUID_AND_ATTRIBUTES Privileges
Public Privileges As WindowsApiLUID_AND_ATTRIBUTES
val mutable Privileges: WindowsApiLUID_AND_ATTRIBUTES
var Privileges
public:
WindowsApiLUID_AND_ATTRIBUTES Privileges

Field Value

Type: WindowsApiLUID_AND_ATTRIBUTES
See Also

Reference

WindowsApiTOKEN_PRIVILEGES Structure
GSF.Interop Namespace


TOKEN_PRIVILEGES Methods

Grid Solutions Framework TOKEN_PRIVILEGES Methods

The WindowsApiTOKEN_PRIVILEGES type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsApiTOKEN_PRIVILEGES Structure
GSF.Interop Namespace


WindowsApi.TOKEN_TYPE Enumeration

Grid Solutions Framework WindowsApiTOKEN_TYPE Enumeration
Win32 TOKEN_TYPE enumeration.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum TOKEN_TYPE
Public Enumeration TOKEN_TYPE
type TOKEN_TYPE
GSF.Interop.TOKEN_TYPE = function();
GSF.Interop.TOKEN_TYPE.createEnum('GSF.Interop.TOKEN_TYPE', false);
public enum class TOKEN_TYPE
Members
Member name | Value | Description
TokenPrimary | 1 |
TokenImpersonation | 2 |
See Also

Reference

GSF.Interop Namespace


WindowsIniFile Class

Grid Solutions Framework WindowsIniFile Class
Represents a Windows INI style configuration file.
Inheritance Hierarchy
SystemObject
GSF.InteropWindowsIniFile

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class WindowsIniFile : IIniFile
Public Class WindowsIniFile
    Implements IIniFile
type WindowsIniFile =
    class
        interface IIniFile
    end
GSF.Interop.WindowsIniFile = function();

Type.createClass(
    'GSF.Interop.WindowsIniFile',
    null,
    GSF.Interop.IIniFile);
public ref class WindowsIniFile : IIniFile

The WindowsIniFile type exposes the following members.

Constructors
 | Name | Description
Public method | WindowsIniFile | Creates a new WindowsIniFile using the specified INI file name.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSectionKeys | Gets an array of keys from the specified section in the INI file.
Public method | GetSectionNames | Gets an array of that section names that exist in the INI file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | FileName | File name of the INI file.
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

GSF.Interop Namespace


WindowsIniFile Constructor

Grid Solutions Framework WindowsIniFile Constructor
Creates a new WindowsIniFile using the specified INI file name.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WindowsIniFile(
    string fileName
)
Public Sub New (
    fileName As String
)
new :
        fileName : string -> WindowsIniFile
GSF.Interop.WindowsIniFile = function(fileName);
public:
WindowsIniFile(
    String^ fileName
)

Parameters

fileName
Type: SystemString
Specified INI file name to use.
See Also

Reference

WindowsIniFile Class
GSF.Interop Namespace


WindowsIniFile Methods

Grid Solutions Framework WindowsIniFile Methods

The WindowsIniFile type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSectionKeys | Gets an array of keys from the specified section in the INI file.
Public method | GetSectionNames | Gets an array of that section names that exist in the INI file.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WindowsIniFile Class
GSF.Interop Namespace


WindowsIniFile.GetSectionKeys Method

Grid Solutions Framework WindowsIniFileGetSectionKeys Method
Gets an array of keys from the specified section in the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] GetSectionKeys(
    string section
)
Public Function GetSectionKeys (
    section As String
) As String()
abstract GetSectionKeys :
        section : string -> string[]
override GetSectionKeys :
        section : string -> string[]
function GetSectionKeys(section);
public:
virtual array<String^>^ GetSectionKeys(
    String^ section
) sealed

Parameters

section
Type: SystemString
Section to retrieve keys from.

Return Value

Type: String
Array of String keys from the specified section of the INI file.

Implements

IIniFileGetSectionKeys(String)
See Also

Reference

WindowsIniFile Class
GSF.Interop Namespace


WindowsIniFile.GetSectionNames Method

Grid Solutions Framework WindowsIniFileGetSectionNames Method
Gets an array of that section names that exist in the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] GetSectionNames()
Public Function GetSectionNames As String()
abstract GetSectionNames : unit -> string[]
override GetSectionNames : unit -> string[]
function GetSectionNames();
public:
virtual array<String^>^ GetSectionNames() sealed

Return Value

Type: String
Array of String section names from the INI file.

Implements

IIniFileGetSectionNames
See Also

Reference

WindowsIniFile Class
GSF.Interop Namespace


WindowsIniFile Properties

Grid Solutions Framework WindowsIniFile Properties

The WindowsIniFile type exposes the following members.

Properties
 | Name | Description
Public property | FileName | File name of the INI file.
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

WindowsIniFile Class
GSF.Interop Namespace


WindowsIniFile.FileName Property

Grid Solutions Framework WindowsIniFileFileName Property
File name of the INI file.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
abstract FileName : string with get, set
override FileName : string with get, set
function get_FileName();
function set_FileName(value);
public:
virtual property String^ FileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IIniFileFileName
See Also

Reference

WindowsIniFile Class
GSF.Interop Namespace


WindowsIniFile.Item Property

Grid Solutions Framework WindowsIniFileItem Property
Overload List
 | Name | Description
Public property | ItemString, String | Gets or sets the value of the specified key.
Public property | ItemString, String, String | Gets the value of the specified key.
Top
See Also

Reference

WindowsIniFile Class
GSF.Interop Namespace


WindowsIniFile.Item Property (String, String)

Grid Solutions Framework WindowsIniFileItem Property (String, String)
Gets or sets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string this[
    string section,
    string entry
] { get; set; }
Public Default Property Item (
    section As String,
    entry As String
) As String
    Get
    Set
member Item : string with get, set

function get_Item(section, entry);
function set_Item(value);
public:
property String^ default[String^ section, String^ entry] {
    String^ get (String^ section, String^ entry);
    void set (String^ section, String^ entry, String^ value);
}

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.

Property Value

Type: String
The new key value to store in the INI file.

Return Value

Type: String
Value of key.
Remarks
This is the default member of this class.
See Also

Reference

WindowsIniFile Class
Item Overload
GSF.Interop Namespace


WindowsIniFile.Item Property (String, String, String)

Grid Solutions Framework WindowsIniFileItem Property (String, String, String)
Gets the value of the specified key.

Namespace: GSF.Interop
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string this[
    string section,
    string entry,
    string defaultValue
] { get; }
Public ReadOnly Default Property Item (
    section As String,
    entry As String,
    defaultValue As String
) As String
    Get
abstract Item : string with get
override Item : string with get
function get_Item(section, entry, defaultValue);

public:
virtual property String^ default[String^ section, String^ entry, String^ defaultValue] {
    String^ get (String^ section, String^ entry, String^ defaultValue) sealed;
}

Parameters

section
Type: SystemString
Section key exists in.
entry
Type: SystemString
Name of key.
defaultValue
Type: SystemString
Default value of key.

Return Value

Type: String
Value of key.

Implements

IIniFileItemString, String, String
Remarks
This is the default member of this class.
See Also

Reference

WindowsIniFile Class
Item Overload
GSF.Interop Namespace


GSF.IO Namespace

Grid Solutions Framework GSF.IO Namespace
Contains classes and extension functions used to simplify and standardize operations related to files and streams.
Classes
 | Class | Description
Public class | BlockAllocatedMemoryStream | Defines a stream whose backing store is memory. Externally this class operates similar to a MemoryStream, internally it uses dynamically allocated buffer blocks instead of one large contiguous array of data.
Public class | CachedFileStream | Represents a file stream that caches recently used blocks in memory.
Public class | ExportDestination | Represents a destination location when exporting data using MultipleDestinationExporter.
Public class | FilePath | Contains File and Path manipulation methods.
Public class | FileProcessor | Tracks files processed in a list of directories, and notifies when new files become available to be processed.
Public class | FileProcessorEventArgs | Arguments to events triggered by the FileProcessor.
Public class | InterprocessCache | Represents a serialized data cache that can be saved or read from multiple applications using inter-process synchronization.
 | IsamDataFileBaseT | An abstract class that defines the read/write capabilities for ISAM (Indexed Sequential Access Method) file.
 | LogFile | Represents a file that can be used for logging messages in real-time.
 | MultipleDestinationExporter | Handles the exporting of a file to multiple destinations that are defined in the config file.
Public class | Outage | Represents an outage as a start time and an end time.
Public class | OutageLog | Represents a persisted log of outages as a list of start and stop times.
Public class | OutageLogProcessor | Represents a thread-safe OutageLog processor that will operate on each Outage with a consumer provided function on independent threads.
Public class | RunTimeLog | Represents a persisted run-time log that tracks last start, stop and running times.
Public class | SafeFileWatcher | Represents a wrapper around the native .NET FileSystemWatcher that avoids problems with dangling references when using a file watcher instance as a class member that never gets disposed.
Public class | StreamExtensions | Defines extension functions related to Stream manipulation.
Enumerations
 | Enumeration | Description
Public enumeration | LogFileFullOperation | Specifies the operation to be performed on the LogFile when it is full.


BlockAllocatedMemoryStream Class

Grid Solutions Framework BlockAllocatedMemoryStream Class
Defines a stream whose backing store is memory. Externally this class operates similar to a MemoryStream, internally it uses dynamically allocated buffer blocks instead of one large contiguous array of data.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.IOBlockAllocatedMemoryStream

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BlockAllocatedMemoryStream : Stream
Public Class BlockAllocatedMemoryStream
    Inherits Stream
type BlockAllocatedMemoryStream =
    class
        inherit Stream
    end
GSF.IO.BlockAllocatedMemoryStream = function();

Type.createClass(
    'GSF.IO.BlockAllocatedMemoryStream',
    Stream);
public ref class BlockAllocatedMemoryStream : public Stream

The BlockAllocatedMemoryStream type exposes the following members.

Constructors
 | Name | Description
Public method | BlockAllocatedMemoryStream | Initializes a new instance of BlockAllocatedMemoryStream.
Public method | BlockAllocatedMemoryStream(Byte) | Initializes a new instance of BlockAllocatedMemoryStream from specified buffer.
Public method | BlockAllocatedMemoryStream(Int32) | Initializes a new instance of BlockAllocatedMemoryStream for specified capacity.
Public method | BlockAllocatedMemoryStream(Byte, Int32) | Initializes a new instance of BlockAllocatedMemoryStream from specified buffer and desired block size.
Public method | BlockAllocatedMemoryStream(Int32, Int32) | Initializes a new instance of BlockAllocatedMemoryStream for specified capacity and desired block size.
Public method | BlockAllocatedMemoryStream(Byte, Int32, Int32) | Initializes a new instance of BlockAllocatedMemoryStream from specified region of buffer.
Public method | BlockAllocatedMemoryStream(Byte, Int32, Int32, Int32) | Initializes a new instance of BlockAllocatedMemoryStream from specified region of buffer and desired block size.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Clear | Clears the entire BlockAllocatedMemoryStream contents and releases any allocated memory blocks.
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BlockAllocatedMemoryStream object and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Protected method | EnsureCapacity | Makes sure desired length can be accommodated by future data accesses.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Overrides the Flush method so that no action is performed. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads a block of bytes from the current stream and writes the data to buffer. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the current stream. (Overrides StreamReadByte.)
Public method | ReadFrom | Reads specified number of bytes from source stream into this BlockAllocatedMemoryStream starting at the current position.
Public method | Seek | Sets the Position within the current stream to the specified value relative the origin. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | Sets the length of the current stream to the specified value. (Overrides StreamSetLength(Int64).)
Public method | ToArray | Writes the stream contents to a byte array, regardless of the Position property.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes a block of bytes to the current stream using data read from buffer. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current stream at the current position. (Overrides StreamWriteByte(Byte).)
Public method | WriteTo | Writes the entire stream into destination, regardless of Position, which remains unchanged.
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
Name | Description
DefaultBlockSize | Default value for BlockSize property.
Top
Properties
 | Name | Description
Protected property | Block | Gets the block of memory currently addressed by Position.
Protected property | BlockIndex | Gets the index of the block currently addressed by Position.
Protected property | BlockOffset | Gets the offset of the byte currently addressed by Position relative to the block that contains it.
Public property | BlockSize | Gets current block size defined for this BlockAllocatedMemoryStream instance.
Public property | CanRead | Gets a value that indicates whether the BlockAllocatedMemoryStream object supports reading. This is always true. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value that indicates whether the BlockAllocatedMemoryStream object supports seeking. This is always true. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value that indicates whether the BlockAllocatedMemoryStream object supports writing. This is always true. (Overrides StreamCanWrite.)
Public property | Length | Gets current stream length for this BlockAllocatedMemoryStream instance. (Overrides StreamLength.)
Public property | Position | Gets current stream position for this BlockAllocatedMemoryStream instance. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Remarks

The BlockAllocatedMemoryStream has two primary benefits over a normal MemoryStream, first, the allocation of a large contiguous array of data in MemoryStream can fail when the requested amount of contiguous memory is unavailable - the BlockAllocatedMemoryStream prevents this; second, a MemoryStream will constantly reallocate the buffer size as the stream grows and shrinks and then copy all the data from the old buffer to the new - the BlockAllocatedMemoryStream maintains its blocks over its life cycle, unless manually cleared, thus eliminating unnecessary allocations and garbage collections when growing and reusing a stream.

Important: Unlike MemoryStream, the BlockAllocatedMemoryStream will not use a user provided buffer as its backing buffer. Any user provided buffers used to instantiate the class will be copied into internally managed reusable memory buffers. Subsequently, the BlockAllocatedMemoryStream does not support the notion of a non-expandable stream. If you are using a MemoryStream with your own buffer, the BlockAllocatedMemoryStream will not provide any immediate benefit.

Note that the BlockAllocatedMemoryStream will maintain all allocated blocks for stream use until the Clear method is called or the class is disposed.

No members in the BlockAllocatedMemoryStream are guaranteed to be thread safe. Make sure any calls are synchronized when simultaneously accessed from different threads.

See Also

Reference

GSF.IO Namespace


BlockAllocatedMemoryStream Constructor

Grid Solutions Framework BlockAllocatedMemoryStream Constructor
Overload List
 | Name | Description
Public method | BlockAllocatedMemoryStream | Initializes a new instance of BlockAllocatedMemoryStream.
Public method | BlockAllocatedMemoryStream(Byte) | Initializes a new instance of BlockAllocatedMemoryStream from specified buffer.
Public method | BlockAllocatedMemoryStream(Int32) | Initializes a new instance of BlockAllocatedMemoryStream for specified capacity.
Public method | BlockAllocatedMemoryStream(Byte, Int32) | Initializes a new instance of BlockAllocatedMemoryStream from specified buffer and desired block size.
Public method | BlockAllocatedMemoryStream(Int32, Int32) | Initializes a new instance of BlockAllocatedMemoryStream for specified capacity and desired block size.
Public method | BlockAllocatedMemoryStream(Byte, Int32, Int32) | Initializes a new instance of BlockAllocatedMemoryStream from specified region of buffer.
Public method | BlockAllocatedMemoryStream(Byte, Int32, Int32, Int32) | Initializes a new instance of BlockAllocatedMemoryStream from specified region of buffer and desired block size.
Top
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream Constructor

Grid Solutions Framework BlockAllocatedMemoryStream Constructor
Initializes a new instance of BlockAllocatedMemoryStream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BlockAllocatedMemoryStream()
Public Sub New
new : unit -> BlockAllocatedMemoryStream
GSF.IO.BlockAllocatedMemoryStream = function();
public:
BlockAllocatedMemoryStream()
See Also

Reference

BlockAllocatedMemoryStream Class
BlockAllocatedMemoryStream Overload
GSF.IO Namespace


BlockAllocatedMemoryStream Constructor (Byte[])

Grid Solutions Framework BlockAllocatedMemoryStream Constructor (Byte)
Initializes a new instance of BlockAllocatedMemoryStream from specified buffer.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BlockAllocatedMemoryStream(
    byte[] buffer
)
Public Sub New (
    buffer As Byte()
)
new :
        buffer : byte[] -> BlockAllocatedMemoryStream
GSF.IO.BlockAllocatedMemoryStream = function(buffer);
public:
BlockAllocatedMemoryStream(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
Initial buffer to copy into stream.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
Remarks
Unlike MemoryStream, the BlockAllocatedMemoryStream will not use the provided buffer as its backing buffer. The buffer will be copied into internally managed reusable memory buffers. Subsequently, the notion of a non-expandable stream is not supported.
See Also

Reference

BlockAllocatedMemoryStream Class
BlockAllocatedMemoryStream Overload
GSF.IO Namespace


BlockAllocatedMemoryStream Constructor (Int32)

Grid Solutions Framework BlockAllocatedMemoryStream Constructor (Int32)
Initializes a new instance of BlockAllocatedMemoryStream for specified capacity.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BlockAllocatedMemoryStream(
    int capacity
)
Public Sub New (
    capacity As Integer
)
new :
        capacity : int -> BlockAllocatedMemoryStream
GSF.IO.BlockAllocatedMemoryStream = function(capacity);
public:
BlockAllocatedMemoryStream(
    int capacity
)

Parameters

capacity
Type: SystemInt32
Initial length of the stream.
See Also

Reference

BlockAllocatedMemoryStream Class
BlockAllocatedMemoryStream Overload
GSF.IO Namespace


BlockAllocatedMemoryStream Constructor (Byte[], Int32)

Grid Solutions Framework BlockAllocatedMemoryStream Constructor (Byte, Int32)
Initializes a new instance of BlockAllocatedMemoryStream from specified buffer and desired block size.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BlockAllocatedMemoryStream(
    byte[] buffer,
    int blockSize
)
Public Sub New (
    buffer As Byte(),
    blockSize As Integer
)
new :
        buffer : byte[] *
        blockSize : int -> BlockAllocatedMemoryStream
GSF.IO.BlockAllocatedMemoryStream = function(buffer, blockSize);
public:
BlockAllocatedMemoryStream(
    array<unsigned char>^ buffer,
    int blockSize
)

Parameters

buffer
Type: SystemByte
Initial buffer to copy into stream.
blockSize
Type: SystemInt32
Desired size of memory blocks.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | Block size must be greater than zero.
Remarks
Unlike MemoryStream, the BlockAllocatedMemoryStream will not use the provided buffer as its backing buffer. The buffer will be copied into internally managed reusable memory buffers. Subsequently, the notion of a non-expandable stream is not supported.
See Also

Reference

BlockAllocatedMemoryStream Class
BlockAllocatedMemoryStream Overload
GSF.IO Namespace


BlockAllocatedMemoryStream Constructor (Int32, Int32)

Grid Solutions Framework BlockAllocatedMemoryStream Constructor (Int32, Int32)
Initializes a new instance of BlockAllocatedMemoryStream for specified capacity and desired block size.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BlockAllocatedMemoryStream(
    int capacity,
    int blockSize
)
Public Sub New (
    capacity As Integer,
    blockSize As Integer
)
new :
        capacity : int *
        blockSize : int -> BlockAllocatedMemoryStream
GSF.IO.BlockAllocatedMemoryStream = function(capacity, blockSize);
public:
BlockAllocatedMemoryStream(
    int capacity,
    int blockSize
)

Parameters

capacity
Type: SystemInt32
Initial length of the stream.
blockSize
Type: SystemInt32
Desired size of memory blocks.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Block size must be greater than zero.
See Also

Reference

BlockAllocatedMemoryStream Class
BlockAllocatedMemoryStream Overload
GSF.IO Namespace


BlockAllocatedMemoryStream Constructor (Byte[], Int32, Int32)

Grid Solutions Framework BlockAllocatedMemoryStream Constructor (Byte, Int32, Int32)
Initializes a new instance of BlockAllocatedMemoryStream from specified region of buffer.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BlockAllocatedMemoryStream(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> BlockAllocatedMemoryStream
GSF.IO.BlockAllocatedMemoryStream = function(buffer, startIndex, length);
public:
BlockAllocatedMemoryStream(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Initial buffer to copy into stream.
startIndex
Type: SystemInt32
0-based start index into the buffer.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
Unlike MemoryStream, the BlockAllocatedMemoryStream will not use the provided buffer as its backing buffer. The buffer will be copied into internally managed reusable memory buffers. Subsequently, the notion of a non-expandable stream is not supported.
See Also

Reference

BlockAllocatedMemoryStream Class
BlockAllocatedMemoryStream Overload
GSF.IO Namespace


BlockAllocatedMemoryStream Constructor (Byte[], Int32, Int32, Int32)

Grid Solutions Framework BlockAllocatedMemoryStream Constructor (Byte, Int32, Int32, Int32)
Initializes a new instance of BlockAllocatedMemoryStream from specified region of buffer and desired block size.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BlockAllocatedMemoryStream(
    byte[] buffer,
    int startIndex,
    int length,
    int blockSize
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer,
    blockSize As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int *
        blockSize : int -> BlockAllocatedMemoryStream
GSF.IO.BlockAllocatedMemoryStream = function(buffer, startIndex, length, blockSize);
public:
BlockAllocatedMemoryStream(
    array<unsigned char>^ buffer,
    int startIndex,
    int length,
    int blockSize
)

Parameters

buffer
Type: SystemByte
Initial buffer to copy into stream.
startIndex
Type: SystemInt32
0-based start index into the buffer.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.
blockSize
Type: SystemInt32
Desired size of memory blocks.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
ArgumentOutOfRangeException | Block size must be greater than zero.
Remarks
Unlike MemoryStream, the BlockAllocatedMemoryStream will not use the provided buffer as its backing buffer. The buffer will be copied into internally managed reusable memory buffers. Subsequently, the notion of a non-expandable stream is not supported.
See Also

Reference

BlockAllocatedMemoryStream Class
BlockAllocatedMemoryStream Overload
GSF.IO Namespace


BlockAllocatedMemoryStream Fields

Grid Solutions Framework BlockAllocatedMemoryStream Fields

The BlockAllocatedMemoryStream type exposes the following members.

Fields
Name | Description
DefaultBlockSize | Default value for BlockSize property.
Top
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.DefaultBlockSize Field

Grid Solutions Framework BlockAllocatedMemoryStreamDefaultBlockSize Field
Default value for BlockSize property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultBlockSize
Public Const DefaultBlockSize As Integer
static val mutable DefaultBlockSize: int
var GSF.IO.BlockAllocatedMemoryStream.DefaultBlockSize
public:
literal int DefaultBlockSize

Field Value

Type: Int32
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream Methods

Grid Solutions Framework BlockAllocatedMemoryStream Methods

The BlockAllocatedMemoryStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Clear | Clears the entire BlockAllocatedMemoryStream contents and releases any allocated memory blocks.
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BlockAllocatedMemoryStream object and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Protected method | EnsureCapacity | Makes sure desired length can be accommodated by future data accesses.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Overrides the Flush method so that no action is performed. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads a block of bytes from the current stream and writes the data to buffer. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the current stream. (Overrides StreamReadByte.)
Public method | ReadFrom | Reads specified number of bytes from source stream into this BlockAllocatedMemoryStream starting at the current position.
Public method | Seek | Sets the Position within the current stream to the specified value relative the origin. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | Sets the length of the current stream to the specified value. (Overrides StreamSetLength(Int64).)
Public method | ToArray | Writes the stream contents to a byte array, regardless of the Position property.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes a block of bytes to the current stream using data read from buffer. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current stream at the current position. (Overrides StreamWriteByte(Byte).)
Public method | WriteTo | Writes the entire stream into destination, regardless of Position, which remains unchanged.
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Clear Method

Grid Solutions Framework BlockAllocatedMemoryStreamClear Method
Clears the entire BlockAllocatedMemoryStream contents and releases any allocated memory blocks.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Dispose Method

Grid Solutions Framework BlockAllocatedMemoryStreamDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the BlockAllocatedMemoryStream object and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Top
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Dispose Method (Boolean)

Grid Solutions Framework BlockAllocatedMemoryStreamDispose Method (Boolean)
Releases the unmanaged resources used by the BlockAllocatedMemoryStream object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

BlockAllocatedMemoryStream Class
Dispose Overload
GSF.IO Namespace


BlockAllocatedMemoryStream.EnsureCapacity Method

Grid Solutions Framework BlockAllocatedMemoryStreamEnsureCapacity Method
Makes sure desired length can be accommodated by future data accesses.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void EnsureCapacity(
    long length
)
Protected Sub EnsureCapacity (
    length As Long
)
member EnsureCapacity :
        length : int64 -> unit

function EnsureCapacity(length);
protected:
void EnsureCapacity(
    long long length
)

Parameters

length
Type: SystemInt64
Minimum desired stream capacity.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Flush Method

Grid Solutions Framework BlockAllocatedMemoryStreamFlush Method
Overrides the Flush method so that no action is performed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Flush()
Public Overrides Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush() override
Remarks

This method overrides the Flush method.

Because any data written to a BlockAllocatedMemoryStream object is written into RAM, this method is superfluous.

See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Read Method

Grid Solutions Framework BlockAllocatedMemoryStreamRead Method
Reads a block of bytes from the current stream and writes the data to buffer.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function Read (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override Read :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function Read(buffer, startIndex, length);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
When this method returns, contains the specified byte array with the values between startIndex and (startIndex + length - 1) replaced by the characters read from the current stream.
startIndex
Type: SystemInt32
The byte offset in buffer at which to begin reading.
length
Type: SystemInt32
The maximum number of bytes to read.

Return Value

Type: Int32
The total number of bytes written into the buffer. This can be less than the number of bytes requested if that number of bytes are not currently available, or zero if the end of the stream is reached before any bytes are read.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.ReadByte Method

Grid Solutions Framework BlockAllocatedMemoryStreamReadByte Method
Reads a byte from the current stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ReadByte()
Public Overrides Function ReadByte As Integer
abstract ReadByte : unit -> int
override ReadByte : unit -> int
function ReadByte();
public:
virtual int ReadByte() override

Return Value

Type: Int32
The current byte cast to an Int32, or -1 if the end of the stream has been reached.
Exceptions
Exception | Condition
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.ReadFrom Method

Grid Solutions Framework BlockAllocatedMemoryStreamReadFrom Method
Reads specified number of bytes from source stream into this BlockAllocatedMemoryStream starting at the current position.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ReadFrom(
    Stream source,
    long length
)
Public Sub ReadFrom (
    source As Stream,
    length As Long
)
member ReadFrom :
        source : Stream *
        length : int64 -> unit

function ReadFrom(source, length);
public:
void ReadFrom(
    Stream^ source,
    long long length
)

Parameters

source
Type: System.IOStream
The stream containing the data to copy
length
Type: SystemInt64
The number of bytes to copy
Exceptions
Exception | Condition
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Seek Method

Grid Solutions Framework BlockAllocatedMemoryStreamSeek Method
Sets the Position within the current stream to the specified value relative the origin.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
function Seek(offset, origin);
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: SystemInt64
The new position within the stream. This is relative to the origin parameter, and can be positive or negative.
origin
Type: System.IOSeekOrigin
A value of type SeekOrigin, which acts as the seek reference point.

Return Value

Type: Int64
The new position within the stream, calculated by combining the initial reference point and the offset.
Exceptions
Exception | Condition
IOException | Seeking was attempted before the beginning of the stream.
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.SetLength Method

Grid Solutions Framework BlockAllocatedMemoryStreamSetLength Method
Sets the length of the current stream to the specified value.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
function SetLength(value);
public:
virtual void SetLength(
    long long value
) override

Parameters

value
Type: SystemInt64
The value at which to set the length.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.ToArray Method

Grid Solutions Framework BlockAllocatedMemoryStreamToArray Method
Writes the stream contents to a byte array, regardless of the Position property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ToArray()
Public Function ToArray As Byte()
member ToArray : unit -> byte[]

function ToArray();
public:
array<unsigned char>^ ToArray()

Return Value

Type: Byte
A Byte[] containing the current data in the stream
Exceptions
Exception | Condition
InvalidOperationException | Cannot create a byte array with more than 2,147,483,591 elements.
ObjectDisposedException | The stream is closed.
Remarks
This may fail if there is not enough contiguous memory available to hold current size of stream. When possible use methods which operate on streams directly instead.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Write Method

Grid Solutions Framework BlockAllocatedMemoryStreamWrite Method
Writes a block of bytes to the current stream using data read from buffer.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Sub Write (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
abstract Write :
        buffer : byte[] *
        startIndex : int *
        length : int -> unit
override Write :
        buffer : byte[] *
        startIndex : int *
        length : int -> unit
function Write(buffer, startIndex, length);
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
The buffer to write data from.
startIndex
Type: SystemInt32
The byte offset in buffer at which to begin writing from.
length
Type: SystemInt32
The maximum number of bytes to write.
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.WriteByte Method

Grid Solutions Framework BlockAllocatedMemoryStreamWriteByte Method
Writes a byte to the current stream at the current position.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void WriteByte(
    byte value
)
Public Overrides Sub WriteByte (
    value As Byte
)
abstract WriteByte :
        value : byte -> unit
override WriteByte :
        value : byte -> unit
function WriteByte(value);
public:
virtual void WriteByte(
    unsigned char value
) override

Parameters

value
Type: SystemByte
The byte to write.
Exceptions
Exception | Condition
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.WriteTo Method

Grid Solutions Framework BlockAllocatedMemoryStreamWriteTo Method
Writes the entire stream into destination, regardless of Position, which remains unchanged.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteTo(
    Stream destination
)
Public Sub WriteTo (
    destination As Stream
)
member WriteTo :
        destination : Stream -> unit

function WriteTo(destination);
public:
void WriteTo(
    Stream^ destination
)

Parameters

destination
Type: System.IOStream
The stream onto which to write the current contents.
Exceptions
Exception | Condition
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream Properties

Grid Solutions Framework BlockAllocatedMemoryStream Properties

The BlockAllocatedMemoryStream type exposes the following members.

Properties
 | Name | Description
Protected property | Block | Gets the block of memory currently addressed by Position.
Protected property | BlockIndex | Gets the index of the block currently addressed by Position.
Protected property | BlockOffset | Gets the offset of the byte currently addressed by Position relative to the block that contains it.
Public property | BlockSize | Gets current block size defined for this BlockAllocatedMemoryStream instance.
Public property | CanRead | Gets a value that indicates whether the BlockAllocatedMemoryStream object supports reading. This is always true. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value that indicates whether the BlockAllocatedMemoryStream object supports seeking. This is always true. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value that indicates whether the BlockAllocatedMemoryStream object supports writing. This is always true. (Overrides StreamCanWrite.)
Public property | Length | Gets current stream length for this BlockAllocatedMemoryStream instance. (Overrides StreamLength.)
Public property | Position | Gets current stream position for this BlockAllocatedMemoryStream instance. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Block Property

Grid Solutions Framework BlockAllocatedMemoryStreamBlock Property
Gets the block of memory currently addressed by Position.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected byte[] Block { get; }
Protected ReadOnly Property Block As Byte()
    Get
member Block : byte[] with get

function get_Block();

protected:
property array<unsigned char>^ Block {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
Remarks
The buffer returned by the property is owned and managed by this BlockAllocatedMemoryStream, make sure direct access to this buffer is maintained within this class and not exposed externally.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.BlockIndex Property

Grid Solutions Framework BlockAllocatedMemoryStreamBlockIndex Property
Gets the index of the block currently addressed by Position.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int BlockIndex { get; }
Protected ReadOnly Property BlockIndex As Integer
    Get
member BlockIndex : int with get

function get_BlockIndex();

protected:
property int BlockIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.BlockOffset Property

Grid Solutions Framework BlockAllocatedMemoryStreamBlockOffset Property
Gets the offset of the byte currently addressed by Position relative to the block that contains it.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int BlockOffset { get; }
Protected ReadOnly Property BlockOffset As Integer
    Get
member BlockOffset : int with get

function get_BlockOffset();

protected:
property int BlockOffset {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.BlockSize Property

Grid Solutions Framework BlockAllocatedMemoryStreamBlockSize Property
Gets current block size defined for this BlockAllocatedMemoryStream instance.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BlockSize { get; }
Public ReadOnly Property BlockSize As Integer
    Get
member BlockSize : int with get

function get_BlockSize();

public:
property int BlockSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.CanRead Property

Grid Solutions Framework BlockAllocatedMemoryStreamCanRead Property
Gets a value that indicates whether the BlockAllocatedMemoryStream object supports reading. This is always true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.CanSeek Property

Grid Solutions Framework BlockAllocatedMemoryStreamCanSeek Property
Gets a value that indicates whether the BlockAllocatedMemoryStream object supports seeking. This is always true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
abstract CanSeek : bool with get
override CanSeek : bool with get
function get_CanSeek();

public:
virtual property bool CanSeek {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.CanWrite Property

Grid Solutions Framework BlockAllocatedMemoryStreamCanWrite Property
Gets a value that indicates whether the BlockAllocatedMemoryStream object supports writing. This is always true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Length Property

Grid Solutions Framework BlockAllocatedMemoryStreamLength Property
Gets current stream length for this BlockAllocatedMemoryStream instance.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
abstract Length : int64 with get
override Length : int64 with get
function get_Length();

public:
virtual property long long Length {
    long long get () override;
}

Property Value

Type: Int64
Exceptions
Exception | Condition
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


BlockAllocatedMemoryStream.Position Property

Grid Solutions Framework BlockAllocatedMemoryStreamPosition Property
Gets current stream position for this BlockAllocatedMemoryStream instance.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
abstract Position : int64 with get, set
override Position : int64 with get, set
function get_Position();
function set_Position(value);
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Property Value

Type: Int64
Exceptions
Exception | Condition
IOException | Seeking was attempted before the beginning of the stream.
ObjectDisposedException | The stream is closed.
See Also

Reference

BlockAllocatedMemoryStream Class
GSF.IO Namespace


CachedFileStream Class

Grid Solutions Framework CachedFileStream Class
Represents a file stream that caches recently used blocks in memory.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.IOCachedFileStream

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CachedFileStream : Stream
Public Class CachedFileStream
    Inherits Stream
type CachedFileStream =
    class
        inherit Stream
    end
GSF.IO.CachedFileStream = function();

Type.createClass(
    'GSF.IO.CachedFileStream',
    Stream);
public ref class CachedFileStream : public Stream

The CachedFileStream type exposes the following members.

Constructors
 | Name | Description
Public method | CachedFileStream(String, FileMode) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare, Int32) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare, Int32, Boolean) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare, Int32, FileOptions) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileSystemRights, FileShare, Int32, FileOptions) | Initializes a new instance of the FileStream class with the specified path, creation mode, access rights and sharing permission, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileSystemRights, FileShare, Int32, FileOptions, FileSecurity) | Initializes a new instance of the FileStream class with the specified path, creation mode, access rights and sharing permission, the buffer size, additional file options, access control and audit security.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears buffers for this stream and causes any buffered data to be written to the file. (Overrides StreamFlush.)
Public method | Flush(Boolean) | Clears buffers for this stream and causes any buffered data to be written to the file, and also clears all intermediate file buffers.
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | When overridden in a derived class, sets the position within the current stream. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | When overridden in a derived class, sets the length of the current stream. (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
Name | Description
DefaultBlockSize | Default value for the BlockSize property.
DefaultCacheSize | Default value for the CacheSize property.
Top
Properties
 | Name | Description
Public property | BlockSize | Gets the size of the cached blocks.
Public property | CacheSize | Gets or sets the maximum size of the cache.
Public property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides StreamCanRead.)
Public property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides StreamCanWrite.)
Public property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides StreamLength.)
Public property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Remarks

This class was developed as a wrapper around FileStream with the same basic functionality. This stream treats the file as a collection of contiguous blocks which can be loaded into an in-memory lookup table to greatly improve seek times. This class generally performs significantly better than the standard FileStream class when maintaining multiple file pointers and frequently seeking back and forth between them. For an example of a good use-case, consider copying a list of serialized objects from one location in the file to another without loading the whole list into memory.

This class likely will not perform significantly better or worse than the standard FileStream when performing strictly sequential reads or writes. For an example of a bad use-case, consider reading a list of objects into memory or simply appending new data to the end of the file. In both of these cases, it may be better to use the standard FileStream for less memory overhead and more predictable flush behavior.

Blocks are loaded into memory as they are used (for read/write operations) and will be kept in memory for as long as possible. Blocks can only be flushed from the cache by decreasing the cache size or by accessing a non-cached block when the cache is already full. In these cases, a least recently used algorithm is executed to determine which blocks should be removed from the cache either to decrease the size of the cache or to make room for a new block.

Write operations are also cached such that they will not be committed to the file until the block is removed from the cache or a call to Flush has been made. This can have some additional implications as compared to the standard FileStream. For instance, write operations may not be committed to the file in the order in which they were executed. Users of this class will need to be judicious about when and how often they call Flush.

See Also

Reference

GSF.IO Namespace


CachedFileStream Constructor

Grid Solutions Framework CachedFileStream Constructor
Overload List
 | Name | Description
Public method | CachedFileStream(String, FileMode) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare, Int32) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare, Int32, Boolean) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileAccess, FileShare, Int32, FileOptions) | Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileSystemRights, FileShare, Int32, FileOptions) | Initializes a new instance of the FileStream class with the specified path, creation mode, access rights and sharing permission, the buffer size, and additional file options.
Public method | CachedFileStream(String, FileMode, FileSystemRights, FileShare, Int32, FileOptions, FileSecurity) | Initializes a new instance of the FileStream class with the specified path, creation mode, access rights and sharing permission, the buffer size, additional file options, access control and audit security.
Top
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode)
Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode
)
Public Sub New (
    path As String,
    mode As FileMode
)
new :
        path : string *
        mode : FileMode -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode);
public:
CachedFileStream(
    String^ path,
    FileMode mode
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | mode contains an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred.-or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode, FileAccess)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode, FileAccess)
Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode,
    FileAccess access
)
Public Sub New (
    path As String,
    mode As FileMode,
    access As FileAccess
)
new :
        path : string *
        mode : FileMode *
        access : FileAccess -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode, access);
public:
CachedFileStream(
    String^ path,
    FileMode mode,
    FileAccess access
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
access
Type: System.IOFileAccess
A constant that determines how the file can be accessed by the FileStream object. This gets the CanRead and CanWrite properties of the FileStream object. CanSeek is true if path specifies a disk file.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | mode or access contain an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred.-or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
UnauthorizedAccessException | The access requested is not permitted by the operating system for the specified path, such as when access is Write or ReadWrite and the file or directory is set for read-only access.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode, FileAccess, FileShare)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode, FileAccess, FileShare)
Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share
)
Public Sub New (
    path As String,
    mode As FileMode,
    access As FileAccess,
    share As FileShare
)
new :
        path : string *
        mode : FileMode *
        access : FileAccess *
        share : FileShare -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode, access, share);
public:
CachedFileStream(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
access
Type: System.IOFileAccess
A constant that determines how the file can be accessed by the FileStream object. This gets the CanRead and CanWrite properties of the FileStream object. CanSeek is true if path specifies a disk file.
share
Type: System.IOFileShare
A constant that determines how the file will be shared by processes.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | mode, access, or share contain an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred.-or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
UnauthorizedAccessException | The access requested is not permitted by the operating system for the specified path, such as when access is Write or ReadWrite and the file or directory is set for read-only access.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32)
Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int blockSize
)
Public Sub New (
    path As String,
    mode As FileMode,
    access As FileAccess,
    share As FileShare,
    blockSize As Integer
)
new :
        path : string *
        mode : FileMode *
        access : FileAccess *
        share : FileShare *
        blockSize : int -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode, access, share, blockSize);
public:
CachedFileStream(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int blockSize
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
access
Type: System.IOFileAccess
A constant that determines how the file can be accessed by the FileStream object. This gets the CanRead and CanWrite properties of the FileStream object. CanSeek is true if path specifies a disk file.
share
Type: System.IOFileShare
A constant that determines how the file will be shared by processes.
blockSize
Type: SystemInt32
A positive Int32 value greater than 0 indicating the block size. For blockSize values between one and eight, the actual block size is set to eight bytes.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | blockSize is negative or zero.-or- mode, access, or share contain an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred.-or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
UnauthorizedAccessException | The access requested is not permitted by the operating system for the specified path, such as when access is Write or ReadWrite and the file or directory is set for read-only access.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32, Boolean)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32, Boolean)
Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int blockSize,
    bool useAsync
)
Public Sub New (
    path As String,
    mode As FileMode,
    access As FileAccess,
    share As FileShare,
    blockSize As Integer,
    useAsync As Boolean
)
new :
        path : string *
        mode : FileMode *
        access : FileAccess *
        share : FileShare *
        blockSize : int *
        useAsync : bool -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode, access, share, blockSize, useAsync);
public:
CachedFileStream(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int blockSize,
    bool useAsync
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
access
Type: System.IOFileAccess
A constant that determines how the file can be accessed by the FileStream object. This gets the CanRead and CanWrite properties of the FileStream object. CanSeek is true if path specifies a disk file.
share
Type: System.IOFileShare
A constant that determines how the file will be shared by processes.
blockSize
Type: SystemInt32
A positive Int32 value greater than 0 indicating the block size. For blockSize values between one and eight, the actual block size is set to eight bytes.
useAsync
Type: SystemBoolean
Specifies whether to use asynchronous I/O or synchronous I/O. However, note that the underlying operating system might not support asynchronous I/O, so when specifying true, the handle might be opened synchronously depending on the platform. When opened asynchronously, the BeginRead(Byte, Int32, Int32, AsyncCallback, Object) and BeginWrite(Byte, Int32, Int32, AsyncCallback, Object) methods perform better on large reads or writes, but they might be much slower for small reads or writes. If the application is designed to take advantage of asynchronous I/O, set the useAsync parameter to true. Using asynchronous I/O correctly can speed up applications by as much as a factor of 10, but using it without redesigning the application for asynchronous I/O can decrease performance by as much as a factor of 10.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | blockSize is negative or zero.-or- mode, access, or share contain an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred.-or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
UnauthorizedAccessException | The access requested is not permitted by the operating system for the specified path, such as when access is Write or ReadWrite and the file or directory is set for read-only access.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32, FileOptions)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode, FileAccess, FileShare, Int32, FileOptions)
Initializes a new instance of the FileStream class with the specified path, creation mode, read/write and sharing permission, the access other FileStreams can have to the same file, the buffer size, and additional file options.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int blockSize,
    FileOptions options
)
Public Sub New (
    path As String,
    mode As FileMode,
    access As FileAccess,
    share As FileShare,
    blockSize As Integer,
    options As FileOptions
)
new :
        path : string *
        mode : FileMode *
        access : FileAccess *
        share : FileShare *
        blockSize : int *
        options : FileOptions -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode, access, share, blockSize, options);
public:
CachedFileStream(
    String^ path,
    FileMode mode,
    FileAccess access,
    FileShare share,
    int blockSize,
    FileOptions options
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
access
Type: System.IOFileAccess
A constant that determines how the file can be accessed by the FileStream object. This gets the CanRead and CanWrite properties of the FileStream object. CanSeek is true if path specifies a disk file.
share
Type: System.IOFileShare
A constant that determines how the file will be shared by processes.
blockSize
Type: SystemInt32
A positive Int32 value greater than 0 indicating the block size. For blockSize values between one and eight, the actual block size is set to eight bytes.
options
Type: System.IOFileOptions
A value that specifies additional file options.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | blockSize is negative or zero.-or- mode, access, or share contain an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred.-or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
UnauthorizedAccessException | The access requested is not permitted by the operating system for the specified path, such as when access is Write or ReadWrite and the file or directory is set for read-only access. -or-Encrypted is specified for options, but file encryption is not supported on the current platform.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode, FileSystemRights, FileShare, Int32, FileOptions)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode, FileSystemRights, FileShare, Int32, FileOptions)
Initializes a new instance of the FileStream class with the specified path, creation mode, access rights and sharing permission, the buffer size, and additional file options.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode,
    FileSystemRights rights,
    FileShare share,
    int blockSize,
    FileOptions options
)
Public Sub New (
    path As String,
    mode As FileMode,
    rights As FileSystemRights,
    share As FileShare,
    blockSize As Integer,
    options As FileOptions
)
new :
        path : string *
        mode : FileMode *
        rights : FileSystemRights *
        share : FileShare *
        blockSize : int *
        options : FileOptions -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode, rights, share, blockSize, options);
public:
CachedFileStream(
    String^ path,
    FileMode mode,
    FileSystemRights rights,
    FileShare share,
    int blockSize,
    FileOptions options
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
rights
Type: System.Security.AccessControlFileSystemRights
A constant that determines the access rights to use when creating access and audit rules for the file.
share
Type: System.IOFileShare
A constant that determines how the file will be shared by processes.
blockSize
Type: SystemInt32
A positive Int32 value greater than 0 indicating the block size. For blockSize values between one and eight, the actual block size is set to eight bytes.
options
Type: System.IOFileOptions
A constant that specifies additional file options.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | blockSize is negative or zero.-or- mode, access, or share contain an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
PlatformNotSupportedException | The current operating system is not Windows NT or later.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred. -or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
UnauthorizedAccessException | The access requested is not permitted by the operating system for the specified path, such as when access is Write or ReadWrite and the file or directory is set for read-only access. -or-Encrypted is specified for options, but file encryption is not supported on the current platform.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Constructor (String, FileMode, FileSystemRights, FileShare, Int32, FileOptions, FileSecurity)

Grid Solutions Framework CachedFileStream Constructor (String, FileMode, FileSystemRights, FileShare, Int32, FileOptions, FileSecurity)
Initializes a new instance of the FileStream class with the specified path, creation mode, access rights and sharing permission, the buffer size, additional file options, access control and audit security.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CachedFileStream(
    string path,
    FileMode mode,
    FileSystemRights rights,
    FileShare share,
    int blockSize,
    FileOptions options,
    FileSecurity fileSecurity
)
Public Sub New (
    path As String,
    mode As FileMode,
    rights As FileSystemRights,
    share As FileShare,
    blockSize As Integer,
    options As FileOptions,
    fileSecurity As FileSecurity
)
new :
        path : string *
        mode : FileMode *
        rights : FileSystemRights *
        share : FileShare *
        blockSize : int *
        options : FileOptions *
        fileSecurity : FileSecurity -> CachedFileStream
GSF.IO.CachedFileStream = function(path, mode, rights, share, blockSize, options, fileSecurity);
public:
CachedFileStream(
    String^ path,
    FileMode mode,
    FileSystemRights rights,
    FileShare share,
    int blockSize,
    FileOptions options,
    FileSecurity^ fileSecurity
)

Parameters

path
Type: SystemString
A relative or absolute path for the file that the current FileStream object will encapsulate.
mode
Type: System.IOFileMode
A constant that determines how to open or create the file.
rights
Type: System.Security.AccessControlFileSystemRights
A constant that determines the access rights to use when creating access and audit rules for the file.
share
Type: System.IOFileShare
A constant that determines how the file will be shared by processes.
blockSize
Type: SystemInt32
A positive Int32 value greater than 0 indicating the block size. For blockSize values between one and eight, the actual block size is set to eight bytes.
options
Type: System.IOFileOptions
A constant that specifies additional file options.
fileSecurity
Type: System.Security.AccessControlFileSecurity
A constant that determines the access control and audit security for the file.
Exceptions
Exception | Condition
ArgumentNullException | path is null.
ArgumentException | path is an empty string (""), contains only white space, or contains one or more invalid characters. -or-path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in an NTFS environment.
NotSupportedException | path refers to a non-file device, such as "con:", "com1:", "lpt1:", etc. in a non-NTFS environment.
ArgumentOutOfRangeException | blockSize is negative or zero.-or- mode, access, or share contain an invalid value.
FileNotFoundException | The file cannot be found, such as when mode is FileMode.Truncate or FileMode.Open, and the file specified by path does not exist. The file must already exist in these modes.
IOException | An I/O error, such as specifying FileMode.CreateNew when the file specified by path already exists, occurred. -or-The stream has been closed.
SecurityException | The caller does not have the required permission.
DirectoryNotFoundException | The specified path is invalid, such as being on an unmapped drive.
UnauthorizedAccessException | The access requested is not permitted by the operating system for the specified path, such as when access is Write or ReadWrite and the file or directory is set for read-only access. -or-Encrypted is specified for options, but file encryption is not supported on the current platform.
PathTooLongException | The specified path, file name, or both exceed the system-defined maximum length. For example, on Windows-based platforms, paths must be less than 248 characters, and file names must be less than 260 characters.
PlatformNotSupportedException | The current operating system is not Windows NT or later.
See Also

Reference

CachedFileStream Class
CachedFileStream Overload
GSF.IO Namespace


CachedFileStream Fields

Grid Solutions Framework CachedFileStream Fields

The CachedFileStream type exposes the following members.

Fields
Name | Description
DefaultBlockSize | Default value for the BlockSize property.
DefaultCacheSize | Default value for the CacheSize property.
Top
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.DefaultBlockSize Field

Grid Solutions Framework CachedFileStreamDefaultBlockSize Field
Default value for the BlockSize property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultBlockSize
Public Const DefaultBlockSize As Integer
static val mutable DefaultBlockSize: int
var GSF.IO.CachedFileStream.DefaultBlockSize
public:
literal int DefaultBlockSize

Field Value

Type: Int32
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.DefaultCacheSize Field

Grid Solutions Framework CachedFileStreamDefaultCacheSize Field
Default value for the CacheSize property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long DefaultCacheSize
Public Const DefaultCacheSize As Long
static val mutable DefaultCacheSize: int64
var GSF.IO.CachedFileStream.DefaultCacheSize
public:
literal long long DefaultCacheSize

Field Value

Type: Int64
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream Methods

Grid Solutions Framework CachedFileStream Methods

The CachedFileStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears buffers for this stream and causes any buffered data to be written to the file. (Overrides StreamFlush.)
Public method | Flush(Boolean) | Clears buffers for this stream and causes any buffered data to be written to the file, and also clears all intermediate file buffers.
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | When overridden in a derived class, sets the position within the current stream. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | When overridden in a derived class, sets the length of the current stream. (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.Dispose Method

Grid Solutions Framework CachedFileStreamDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Top
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.Dispose Method (Boolean)

Grid Solutions Framework CachedFileStreamDispose Method (Boolean)
Releases the unmanaged resources used by the Stream and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

CachedFileStream Class
Dispose Overload
GSF.IO Namespace


CachedFileStream.Flush Method

Grid Solutions Framework CachedFileStreamFlush Method
Overload List
 | Name | Description
Public method | Flush | Clears buffers for this stream and causes any buffered data to be written to the file. (Overrides StreamFlush.)
Public method | Flush(Boolean) | Clears buffers for this stream and causes any buffered data to be written to the file, and also clears all intermediate file buffers.
Top
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.Flush Method

Grid Solutions Framework CachedFileStreamFlush Method
Clears buffers for this stream and causes any buffered data to be written to the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Flush()
Public Overrides Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush() override
Exceptions
Exception | Condition
IOException | An I/O error occurs.
See Also

Reference

CachedFileStream Class
Flush Overload
GSF.IO Namespace


CachedFileStream.Flush Method (Boolean)

Grid Solutions Framework CachedFileStreamFlush Method (Boolean)
Clears buffers for this stream and causes any buffered data to be written to the file, and also clears all intermediate file buffers.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Flush(
    bool flushToDisk
)
Public Sub Flush (
    flushToDisk As Boolean
)
member Flush :
        flushToDisk : bool -> unit

function Flush(flushToDisk);
public:
void Flush(
    bool flushToDisk
)

Parameters

flushToDisk
Type: SystemBoolean
true to flush all intermediate file buffers; otherwise, false.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
See Also

Reference

CachedFileStream Class
Flush Overload
GSF.IO Namespace


CachedFileStream.Read Method

Grid Solutions Framework CachedFileStreamRead Method
When overridden in a derived class, reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
function Read(buffer, offset, count);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
Type: SystemInt32
The maximum number of bytes to be read from the current stream.

Return Value

Type: Int32
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.
Exceptions
Exception | Condition
ArgumentException | offset and count describe an invalid range in buffer.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support reading.
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.Seek Method

Grid Solutions Framework CachedFileStreamSeek Method
When overridden in a derived class, sets the position within the current stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
function Seek(offset, origin);
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: SystemInt64
A byte offset relative to the origin parameter.
origin
Type: System.IOSeekOrigin
A value of type SeekOrigin indicating the reference point used to obtain the new position.

Return Value

Type: Int64
The new position within the current stream.
Exceptions
Exception | Condition
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.SetLength Method

Grid Solutions Framework CachedFileStreamSetLength Method
When overridden in a derived class, sets the length of the current stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SetLength(
    long value
)
Public Overrides Sub SetLength (
    value As Long
)
abstract SetLength :
        value : int64 -> unit
override SetLength :
        value : int64 -> unit
function SetLength(value);
public:
virtual void SetLength(
    long long value
) override

Parameters

value
Type: SystemInt64
The desired length of the current stream in bytes.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Attempted to set the value parameter to less than 0.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support both writing and seeking.
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.Write Method

Grid Solutions Framework CachedFileStreamWrite Method
When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Write(buffer, offset, count);
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: SystemInt32
The number of bytes to be written to the current stream.
Exceptions
Exception | Condition
ArgumentException | offset and count describe an invalid range in buffer.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | offset or count is negative.
IOException | An I/O error occurs.
NotSupportedException | The stream does not support writing.
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream Properties

Grid Solutions Framework CachedFileStream Properties

The CachedFileStream type exposes the following members.

Properties
 | Name | Description
Public property | BlockSize | Gets the size of the cached blocks.
Public property | CacheSize | Gets or sets the maximum size of the cache.
Public property | CanRead | When overridden in a derived class, gets a value indicating whether the current stream supports reading. (Overrides StreamCanRead.)
Public property | CanSeek | When overridden in a derived class, gets a value indicating whether the current stream supports seeking. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | When overridden in a derived class, gets a value indicating whether the current stream supports writing. (Overrides StreamCanWrite.)
Public property | Length | When overridden in a derived class, gets the length in bytes of the stream. (Overrides StreamLength.)
Public property | Position | When overridden in a derived class, gets or sets the position within the current stream. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.BlockSize Property

Grid Solutions Framework CachedFileStreamBlockSize Property
Gets the size of the cached blocks.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BlockSize { get; }
Public ReadOnly Property BlockSize As Integer
    Get
member BlockSize : int with get

function get_BlockSize();

public:
property int BlockSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.CacheSize Property

Grid Solutions Framework CachedFileStreamCacheSize Property
Gets or sets the maximum size of the cache.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long CacheSize { get; set; }
Public Property CacheSize As Long
    Get
    Set
member CacheSize : int64 with get, set

function get_CacheSize();
function set_CacheSize(value);
public:
property long long CacheSize {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Cache size is set to a value less than zero.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.CanRead Property

Grid Solutions Framework CachedFileStreamCanRead Property
When overridden in a derived class, gets a value indicating whether the current stream supports reading.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Return Value

Type: Boolean
true if the stream supports reading; otherwise, false.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.CanSeek Property

Grid Solutions Framework CachedFileStreamCanSeek Property
When overridden in a derived class, gets a value indicating whether the current stream supports seeking.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
abstract CanSeek : bool with get
override CanSeek : bool with get
function get_CanSeek();

public:
virtual property bool CanSeek {
    bool get () override;
}

Return Value

Type: Boolean
true if the stream supports seeking; otherwise, false.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.CanWrite Property

Grid Solutions Framework CachedFileStreamCanWrite Property
When overridden in a derived class, gets a value indicating whether the current stream supports writing.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Return Value

Type: Boolean
true if the stream supports writing; otherwise, false.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.Length Property

Grid Solutions Framework CachedFileStreamLength Property
When overridden in a derived class, gets the length in bytes of the stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
abstract Length : int64 with get
override Length : int64 with get
function get_Length();

public:
virtual property long long Length {
    long long get () override;
}

Return Value

Type: Int64
A long value representing the length of the stream in bytes.
Exceptions
Exception | Condition
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


CachedFileStream.Position Property

Grid Solutions Framework CachedFileStreamPosition Property
When overridden in a derived class, gets or sets the position within the current stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
abstract Position : int64 with get, set
override Position : int64 with get, set
function get_Position();
function set_Position(value);
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Return Value

Type: Int64
The current position within the stream.
Exceptions
Exception | Condition
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

CachedFileStream Class
GSF.IO Namespace


ExportDestination Class

Grid Solutions Framework ExportDestination Class
Represents a destination location when exporting data using MultipleDestinationExporter.
Inheritance Hierarchy
SystemObject
GSF.IOExportDestination

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ExportDestination
Public Class ExportDestination
type ExportDestination =  class end
GSF.IO.ExportDestination = function();

Type.createClass(
    'GSF.IO.ExportDestination');
public ref class ExportDestination

The ExportDestination type exposes the following members.

Constructors
 | Name | Description
Public method | ExportDestination | Constructs a new ExportDestination.
Public method | ExportDestination(String, Boolean, String, String, String) | Constructs a new ExportDestination given the specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current ExportDestination. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConnectToShare | Determines whether or not to attempt network connection to share specified in DestinationFile.
Public property | DestinationFile | Path and file name of export destination.
Public property | Domain | Domain used to authenticate network connection if ConnectToShare is true.
Public property | FileName | Path and filename of DestinationFile without drive or server share prefix.
Public property | Password | Password used to authenticate network connection if ConnectToShare is true.
Public property | Share | Path root of DestinationFile (e.g., E:\ or \\server\share).
Public property | UserName | User name used to authenticate network connection if ConnectToShare is true.
Top
See Also

Reference

GSF.IO Namespace
GSF.IOMultipleDestinationExporter


ExportDestination Constructor

Grid Solutions Framework ExportDestination Constructor
Overload List
 | Name | Description
Public method | ExportDestination | Constructs a new ExportDestination.
Public method | ExportDestination(String, Boolean, String, String, String) | Constructs a new ExportDestination given the specified parameters.
Top
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination Constructor

Grid Solutions Framework ExportDestination Constructor
Constructs a new ExportDestination.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportDestination()
Public Sub New
new : unit -> ExportDestination
GSF.IO.ExportDestination = function();
public:
ExportDestination()
See Also

Reference

ExportDestination Class
ExportDestination Overload
GSF.IO Namespace


ExportDestination Constructor (String, Boolean, String, String, String)

Grid Solutions Framework ExportDestination Constructor (String, Boolean, String, String, String)
Constructs a new ExportDestination given the specified parameters.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ExportDestination(
    string destinationFile,
    bool connectToShare,
    string domain = "",
    string userName = "",
    string password = ""
)
Public Sub New (
    destinationFile As String,
    connectToShare As Boolean,
    Optional domain As String = "",
    Optional userName As String = "",
    Optional password As String = ""
)
new :
        destinationFile : string *
        connectToShare : bool *
        ?domain : string *
        ?userName : string *
        ?password : string
(* Defaults:
        let _domain = defaultArg domain ""
        let _userName = defaultArg userName ""
        let _password = defaultArg password ""
*)
-> ExportDestination
GSF.IO.ExportDestination = function(destinationFile, connectToShare, domain, userName, password);
public:
ExportDestination(
    String^ destinationFile,
    bool connectToShare,
    String^ domain = L"",
    String^ userName = L"",
    String^ password = L""
)

Parameters

destinationFile
Type: SystemString
Path and file name of export destination.
connectToShare
Type: SystemBoolean
Determines whether or not to attempt network connection to share specified in destinationFile.
domain (Optional)
Type: SystemString
Domain used to authenticate network connection if connectToShare is true.
userName (Optional)
Type: SystemString
User name used to authenticate network connection if connectToShare is true.
password (Optional)
Type: SystemString
Password used to authenticate network connection if connectToShare is true.
See Also

Reference

ExportDestination Class
ExportDestination Overload
GSF.IO Namespace


ExportDestination Methods

Grid Solutions Framework ExportDestination Methods

The ExportDestination type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current ExportDestination. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.ToString Method

Grid Solutions Framework ExportDestinationToString Method
Returns a String that represents the current ExportDestination.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current ExportDestination.
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination Properties

Grid Solutions Framework ExportDestination Properties

The ExportDestination type exposes the following members.

Properties
 | Name | Description
Public property | ConnectToShare | Determines whether or not to attempt network connection to share specified in DestinationFile.
Public property | DestinationFile | Path and file name of export destination.
Public property | Domain | Domain used to authenticate network connection if ConnectToShare is true.
Public property | FileName | Path and filename of DestinationFile without drive or server share prefix.
Public property | Password | Password used to authenticate network connection if ConnectToShare is true.
Public property | Share | Path root of DestinationFile (e.g., E:\ or \\server\share).
Public property | UserName | User name used to authenticate network connection if ConnectToShare is true.
Top
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.ConnectToShare Property

Grid Solutions Framework ExportDestinationConnectToShare Property
Determines whether or not to attempt network connection to share specified in DestinationFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ConnectToShare { get; set; }
Public Property ConnectToShare As Boolean
    Get
    Set
member ConnectToShare : bool with get, set

function get_ConnectToShare();
function set_ConnectToShare(value);
public:
property bool ConnectToShare {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This option is ignored under Mono deployments.
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.DestinationFile Property

Grid Solutions Framework ExportDestinationDestinationFile Property
Path and file name of export destination.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorAttribute(typeof(FileNameEditor), typeof(UITypeEditor))]
public string DestinationFile { get; set; }
<EditorAttribute(GetType(FileNameEditor), GetType(UITypeEditor))>
Public Property DestinationFile As String
    Get
    Set
[<EditorAttribute(typeof(FileNameEditor), typeof(UITypeEditor))>]
member DestinationFile : string with get, set

function get_DestinationFile();
function set_DestinationFile(value);
public:
[EditorAttribute(typeof(FileNameEditor), typeof(UITypeEditor))]
property String^ DestinationFile {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.Domain Property

Grid Solutions Framework ExportDestinationDomain Property
Domain used to authenticate network connection if ConnectToShare is true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Domain { get; set; }
Public Property Domain As String
    Get
    Set
member Domain : string with get, set

function get_Domain();
function set_Domain(value);
public:
property String^ Domain {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This option is ignored under Mono deployments.
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.FileName Property

Grid Solutions Framework ExportDestinationFileName Property
Path and filename of DestinationFile without drive or server share prefix.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string FileName { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property FileName As String
    Get
[<BrowsableAttribute(false)>]
member FileName : string with get

function get_FileName();

public:
[BrowsableAttribute(false)]
property String^ FileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.Password Property

Grid Solutions Framework ExportDestinationPassword Property
Password used to authenticate network connection if ConnectToShare is true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
member Password : string with get, set

function get_Password();
function set_Password(value);
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This option is ignored under Mono deployments.
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.Share Property

Grid Solutions Framework ExportDestinationShare Property
Path root of DestinationFile (e.g., E:\ or \\server\share).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Share { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Share As String
    Get
[<BrowsableAttribute(false)>]
member Share : string with get

function get_Share();

public:
[BrowsableAttribute(false)]
property String^ Share {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ExportDestination Class
GSF.IO Namespace


ExportDestination.UserName Property

Grid Solutions Framework ExportDestinationUserName Property
User name used to authenticate network connection if ConnectToShare is true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string UserName { get; set; }
Public Property UserName As String
    Get
    Set
member UserName : string with get, set

function get_UserName();
function set_UserName(value);
public:
property String^ UserName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This option is ignored under Mono deployments.
See Also

Reference

ExportDestination Class
GSF.IO Namespace


FilePath Class

Grid Solutions Framework FilePath Class
Contains File and Path manipulation methods.
Inheritance Hierarchy
SystemObject
GSF.IOFilePath

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class FilePath
Public NotInheritable Class FilePath
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FilePath =  class end
GSF.IO.FilePath = function();

Type.createClass(
    'GSF.IO.FilePath');
public ref class FilePath abstract sealed

The FilePath type exposes the following members.

Methods
Name | Description
AddPathSuffix | Makes sure path is suffixed with standard DirectorySeparatorChar.
ConnectToNetworkShare | Connects to a network share with the specified user's credentials.
DisconnectFromNetworkShare(String) | Disconnects the specified network share.
DisconnectFromNetworkShare(String, Boolean) | Disconnects the specified network share.
DropPathRoot | Remove any path root present in the path.
GetAbsolutePath | Gets the absolute file path for the specified file name or relative file path.
GetApplicationDataFolder | Gets the path to the folder where data related to the current application can be stored.
GetCommonApplicationDataFolder | Gets the path to the folder where data related to the current application can be stored as well as shared among different users.
GetDirectoryName | Gets the directory information from the specified file path.
GetExtension | Gets the extension from the specified file path.
GetFileLength | Gets the size of the specified file.
GetFileList | Gets a list of files under the specified path. Search wildcard pattern (c:\Data\*.dat) can be used for including only the files matching the pattern or path wildcard pattern (c:\Data\*\*.dat) to indicate the inclusion of files under all subdirectories in the list.
GetFileName | Gets the file name and extension from the specified file path.
GetFileNameWithoutExtension | Gets the file name without extension from the specified file path.
GetFilePatternRegularExpression | Gets a regular expression pattern that simulates wildcard matching for filenames (wildcards are defined as '*' or '?' characters).
GetLastDirectoryName | Gets the last directory name from a file path.
GetUniqueFilePath | Gets a unique file path for the given file by checking for name collisions and adding a sequence number to the end of the file name if there is a collision.
GetUniqueFilePathWithBinarySearch | Gets a unique file path for the given file by checking for name collisions and adding a sequence number to the end of the file name if there is a collision.
GetValidFileName | Gets a valid file name by replacing invalid file name characters with replaceWithCharacter.
GetValidFilePath | Gets a valid file path by replacing invalid file or directory name characters with replaceWithCharacter.
InApplicationPath | Determines if the specified filePath is contained with the current executable path.
IsFilePatternMatch(String, String, Boolean) | Determines whether the specified file name matches the given file spec (wildcards are defined as '*' or '?' characters).
IsFilePatternMatch(String, String, Boolean) | Determines whether the specified file name matches any of the given file specs (wildcards are defined as '*' or '?' characters).
IsValidFileName | Determines if the specified file name and path is valid.
RemovePathSuffix | Makes sure path is not suffixed with DirectorySeparatorChar or AltDirectorySeparatorChar.
TrimFileName | Returns a file name, for display purposes, of the specified length using "..." to indicate a longer name.
TryGetReadLock | Attempts to get read access on a file.
TryGetReadLockExclusive | Attempts to get read access on a file.
TryGetWriteLock | Attempts to get write access on a file.
WaitForReadLock(String) | Waits for the default duration (5 seconds) for read access on a file.
WaitForReadLock(String, Double) | Waits for read access on a file for the specified number of seconds.
WaitForReadLockExclusive(String) | Waits for the default duration (5 seconds) for read access on a file.
WaitForReadLockExclusive(String, Double) | Waits for read access on a file for the specified number of seconds.
WaitForWriteLock(String) | Waits for the default duration (5 seconds) for write access on a file.
WaitForWriteLock(String, Double) | Waits for write access on a file for the specified number of seconds.
WaitTillExists(String) | Waits for the default duration (5 seconds) for a file to exist.
WaitTillExists(String, Double) | Waits for a file to exist for the specified number of seconds.
Top
See Also

Reference

GSF.IO Namespace


FilePath Methods

Grid Solutions Framework FilePath Methods

The FilePath type exposes the following members.

Methods
Name | Description
AddPathSuffix | Makes sure path is suffixed with standard DirectorySeparatorChar.
ConnectToNetworkShare | Connects to a network share with the specified user's credentials.
DisconnectFromNetworkShare(String) | Disconnects the specified network share.
DisconnectFromNetworkShare(String, Boolean) | Disconnects the specified network share.
DropPathRoot | Remove any path root present in the path.
GetAbsolutePath | Gets the absolute file path for the specified file name or relative file path.
GetApplicationDataFolder | Gets the path to the folder where data related to the current application can be stored.
GetCommonApplicationDataFolder | Gets the path to the folder where data related to the current application can be stored as well as shared among different users.
GetDirectoryName | Gets the directory information from the specified file path.
GetExtension | Gets the extension from the specified file path.
GetFileLength | Gets the size of the specified file.
GetFileList | Gets a list of files under the specified path. Search wildcard pattern (c:\Data\*.dat) can be used for including only the files matching the pattern or path wildcard pattern (c:\Data\*\*.dat) to indicate the inclusion of files under all subdirectories in the list.
GetFileName | Gets the file name and extension from the specified file path.
GetFileNameWithoutExtension | Gets the file name without extension from the specified file path.
GetFilePatternRegularExpression | Gets a regular expression pattern that simulates wildcard matching for filenames (wildcards are defined as '*' or '?' characters).
GetLastDirectoryName | Gets the last directory name from a file path.
GetUniqueFilePath | Gets a unique file path for the given file by checking for name collisions and adding a sequence number to the end of the file name if there is a collision.
GetUniqueFilePathWithBinarySearch | Gets a unique file path for the given file by checking for name collisions and adding a sequence number to the end of the file name if there is a collision.
GetValidFileName | Gets a valid file name by replacing invalid file name characters with replaceWithCharacter.
GetValidFilePath | Gets a valid file path by replacing invalid file or directory name characters with replaceWithCharacter.
InApplicationPath | Determines if the specified filePath is contained with the current executable path.
IsFilePatternMatch(String, String, Boolean) | Determines whether the specified file name matches the given file spec (wildcards are defined as '*' or '?' characters).
IsFilePatternMatch(String, String, Boolean) | Determines whether the specified file name matches any of the given file specs (wildcards are defined as '*' or '?' characters).
IsValidFileName | Determines if the specified file name and path is valid.
RemovePathSuffix | Makes sure path is not suffixed with DirectorySeparatorChar or AltDirectorySeparatorChar.
TrimFileName | Returns a file name, for display purposes, of the specified length using "..." to indicate a longer name.
TryGetReadLock | Attempts to get read access on a file.
TryGetReadLockExclusive | Attempts to get read access on a file.
TryGetWriteLock | Attempts to get write access on a file.
WaitForReadLock(String) | Waits for the default duration (5 seconds) for read access on a file.
WaitForReadLock(String, Double) | Waits for read access on a file for the specified number of seconds.
WaitForReadLockExclusive(String) | Waits for the default duration (5 seconds) for read access on a file.
WaitForReadLockExclusive(String, Double) | Waits for read access on a file for the specified number of seconds.
WaitForWriteLock(String) | Waits for the default duration (5 seconds) for write access on a file.
WaitForWriteLock(String, Double) | Waits for write access on a file for the specified number of seconds.
WaitTillExists(String) | Waits for the default duration (5 seconds) for a file to exist.
WaitTillExists(String, Double) | Waits for a file to exist for the specified number of seconds.
Top
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.AddPathSuffix Method

Grid Solutions Framework FilePathAddPathSuffix Method
Makes sure path is suffixed with standard DirectorySeparatorChar.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string AddPathSuffix(
    string filePath
)
Public Shared Function AddPathSuffix (
    filePath As String
) As String
static member AddPathSuffix :
        filePath : string -> string

GSF.IO.FilePath.AddPathSuffix = function(filePath);
public:
static String^ AddPathSuffix(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path to be suffixed.

Return Value

Type: String
Suffixed path.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.ConnectToNetworkShare Method

Grid Solutions Framework FilePathConnectToNetworkShare Method
Connects to a network share with the specified user's credentials.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ConnectToNetworkShare(
    string sharename,
    string userName,
    string password,
    string domain
)
Public Shared Sub ConnectToNetworkShare (
    sharename As String,
    userName As String,
    password As String,
    domain As String
)
static member ConnectToNetworkShare :
        sharename : string *
        userName : string *
        password : string *
        domain : string -> unit

GSF.IO.FilePath.ConnectToNetworkShare = function(sharename, userName, password, domain);
public:
static void ConnectToNetworkShare(
    String^ sharename,
    String^ userName,
    String^ password,
    String^ domain
)

Parameters

sharename
Type: SystemString
UNC share name to connect to.
userName
Type: SystemString
User name to use for connection.
password
Type: SystemString
Password to use for connection.
domain
Type: SystemString
Domain name to use for connection. Specify the computer name for local system accounts.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.DisconnectFromNetworkShare Method

Grid Solutions Framework FilePathDisconnectFromNetworkShare Method
Overload List
Name | Description
DisconnectFromNetworkShare(String) | Disconnects the specified network share.
DisconnectFromNetworkShare(String, Boolean) | Disconnects the specified network share.
Top
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.DisconnectFromNetworkShare Method (String)

Grid Solutions Framework FilePathDisconnectFromNetworkShare Method (String)
Disconnects the specified network share.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DisconnectFromNetworkShare(
    string sharename
)
Public Shared Sub DisconnectFromNetworkShare (
    sharename As String
)
static member DisconnectFromNetworkShare :
        sharename : string -> unit

GSF.IO.FilePath.DisconnectFromNetworkShare = function(sharename);
public:
static void DisconnectFromNetworkShare(
    String^ sharename
)

Parameters

sharename
Type: SystemString
UNC share name to disconnect from.
See Also

Reference

FilePath Class
DisconnectFromNetworkShare Overload
GSF.IO Namespace


FilePath.DisconnectFromNetworkShare Method (String, Boolean)

Grid Solutions Framework FilePathDisconnectFromNetworkShare Method (String, Boolean)
Disconnects the specified network share.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DisconnectFromNetworkShare(
    string sharename,
    bool force
)
Public Shared Sub DisconnectFromNetworkShare (
    sharename As String,
    force As Boolean
)
static member DisconnectFromNetworkShare :
        sharename : string *
        force : bool -> unit

GSF.IO.FilePath.DisconnectFromNetworkShare = function(sharename, force);
public:
static void DisconnectFromNetworkShare(
    String^ sharename,
    bool force
)

Parameters

sharename
Type: SystemString
UNC share name to disconnect from.
force
Type: SystemBoolean
true to force a disconnect; otherwise false.
See Also

Reference

FilePath Class
DisconnectFromNetworkShare Overload
GSF.IO Namespace


FilePath.DropPathRoot Method

Grid Solutions Framework FilePathDropPathRoot Method
Remove any path root present in the path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string DropPathRoot(
    string filePath
)
Public Shared Function DropPathRoot (
    filePath As String
) As String
static member DropPathRoot :
        filePath : string -> string

GSF.IO.FilePath.DropPathRoot = function(filePath);
public:
static String^ DropPathRoot(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path whose root is to be removed.

Return Value

Type: String
The path with the root removed if it was present.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetAbsolutePath Method

Grid Solutions Framework FilePathGetAbsolutePath Method
Gets the absolute file path for the specified file name or relative file path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetAbsolutePath(
    string filePath
)
Public Shared Function GetAbsolutePath (
    filePath As String
) As String
static member GetAbsolutePath :
        filePath : string -> string

GSF.IO.FilePath.GetAbsolutePath = function(filePath);
public:
static String^ GetAbsolutePath(
    String^ filePath
)

Parameters

filePath
Type: SystemString
File name or relative file path.

Return Value

Type: String
Absolute file path for the specified file name or relative file path.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetApplicationDataFolder Method

Grid Solutions Framework FilePathGetApplicationDataFolder Method
Gets the path to the folder where data related to the current application can be stored.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetApplicationDataFolder()
Public Shared Function GetApplicationDataFolder As String
static member GetApplicationDataFolder : unit -> string

GSF.IO.FilePath.GetApplicationDataFolder = function();
public:
static String^ GetApplicationDataFolder()

Return Value

Type: String
Path to the folder where data related to the current application can be stored.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetCommonApplicationDataFolder Method

Grid Solutions Framework FilePathGetCommonApplicationDataFolder Method
Gets the path to the folder where data related to the current application can be stored as well as shared among different users.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetCommonApplicationDataFolder()
Public Shared Function GetCommonApplicationDataFolder As String
static member GetCommonApplicationDataFolder : unit -> string

GSF.IO.FilePath.GetCommonApplicationDataFolder = function();
public:
static String^ GetCommonApplicationDataFolder()

Return Value

Type: String
Path to the folder where data related to the current application can be stored.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetDirectoryName Method

Grid Solutions Framework FilePathGetDirectoryName Method
Gets the directory information from the specified file path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetDirectoryName(
    string filePath
)
Public Shared Function GetDirectoryName (
    filePath As String
) As String
static member GetDirectoryName :
        filePath : string -> string

GSF.IO.FilePath.GetDirectoryName = function(filePath);
public:
static String^ GetDirectoryName(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path from which the directory information is to be obtained.

Return Value

Type: String
Directory information.
Remarks
This differs from GetDirectoryName(String) in that it will see if last name in path is a directory and, if it exists, will properly treat that part of path as a directory. The .NET path function always assumes last entry is a file name if path is not suffixed with a slash. For example: Path.GetDirectoryName(@"C:\Music") will return "C:\", however, FilePath.GetDirectoryName(@"C:\Music") will return "C:\Music\", so long as Music directory exists.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetExtension Method

Grid Solutions Framework FilePathGetExtension Method
Gets the extension from the specified file path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetExtension(
    string filePath
)
Public Shared Function GetExtension (
    filePath As String
) As String
static member GetExtension :
        filePath : string -> string

GSF.IO.FilePath.GetExtension = function(filePath);
public:
static String^ GetExtension(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path from which the extension is to be obtained.

Return Value

Type: String
File extension.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetFileLength Method

Grid Solutions Framework FilePathGetFileLength Method
Gets the size of the specified file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GetFileLength(
    string fileName
)
Public Shared Function GetFileLength (
    fileName As String
) As Long
static member GetFileLength :
        fileName : string -> int64

GSF.IO.FilePath.GetFileLength = function(fileName);
public:
static long long GetFileLength(
    String^ fileName
)

Parameters

fileName
Type: SystemString
Name of file whose size is to be retrieved.

Return Value

Type: Int64
The size of the specified file.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetFileList Method

Grid Solutions Framework FilePathGetFileList Method
Gets a list of files under the specified path. Search wildcard pattern (c:\Data\*.dat) can be used for including only the files matching the pattern or path wildcard pattern (c:\Data\*\*.dat) to indicate the inclusion of files under all subdirectories in the list.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] GetFileList(
    string path
)
Public Shared Function GetFileList (
    path As String
) As String()
static member GetFileList :
        path : string -> string[]

GSF.IO.FilePath.GetFileList = function(path);
public:
static array<String^>^ GetFileList(
    String^ path
)

Parameters

path
Type: SystemString
The path for which a list of files is to be returned.

Return Value

Type: String
A list of files under the given path.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetFileName Method

Grid Solutions Framework FilePathGetFileName Method
Gets the file name and extension from the specified file path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetFileName(
    string filePath
)
Public Shared Function GetFileName (
    filePath As String
) As String
static member GetFileName :
        filePath : string -> string

GSF.IO.FilePath.GetFileName = function(filePath);
public:
static String^ GetFileName(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path from which the file name and extension is to be obtained.

Return Value

Type: String
File name and extension if the file path has it; otherwise empty string.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetFileNameWithoutExtension Method

Grid Solutions Framework FilePathGetFileNameWithoutExtension Method
Gets the file name without extension from the specified file path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetFileNameWithoutExtension(
    string filePath
)
Public Shared Function GetFileNameWithoutExtension (
    filePath As String
) As String
static member GetFileNameWithoutExtension :
        filePath : string -> string

GSF.IO.FilePath.GetFileNameWithoutExtension = function(filePath);
public:
static String^ GetFileNameWithoutExtension(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path from which the file name is to be obtained.

Return Value

Type: String
File name without the extension if the file path has it; otherwise empty string.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetFilePatternRegularExpression Method

Grid Solutions Framework FilePathGetFilePatternRegularExpression Method
Gets a regular expression pattern that simulates wildcard matching for filenames (wildcards are defined as '*' or '?' characters).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetFilePatternRegularExpression(
    string fileSpec
)
Public Shared Function GetFilePatternRegularExpression (
    fileSpec As String
) As String
static member GetFilePatternRegularExpression :
        fileSpec : string -> string

GSF.IO.FilePath.GetFilePatternRegularExpression = function(fileSpec);
public:
static String^ GetFilePatternRegularExpression(
    String^ fileSpec
)

Parameters

fileSpec
Type: SystemString
The file spec for which the regular expression pattern if to be generated.

Return Value

Type: String
Regular expression pattern that simulates wildcard matching for filenames.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetLastDirectoryName Method

Grid Solutions Framework FilePathGetLastDirectoryName Method
Gets the last directory name from a file path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetLastDirectoryName(
    string filePath
)
Public Shared Function GetLastDirectoryName (
    filePath As String
) As String
static member GetLastDirectoryName :
        filePath : string -> string

GSF.IO.FilePath.GetLastDirectoryName = function(filePath);
public:
static String^ GetLastDirectoryName(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path from where the last directory name is to be retrieved.

Return Value

Type: String
The last directory name from a file path.
Remarks
GetLastDirectoryName(String) would return sub2 from c:\windows\sub2\filename.ext.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetUniqueFilePath Method

Grid Solutions Framework FilePathGetUniqueFilePath Method
Gets a unique file path for the given file by checking for name collisions and adding a sequence number to the end of the file name if there is a collision.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetUniqueFilePath(
    string originalFilePath
)
Public Shared Function GetUniqueFilePath (
    originalFilePath As String
) As String
static member GetUniqueFilePath :
        originalFilePath : string -> string

GSF.IO.FilePath.GetUniqueFilePath = function(originalFilePath);
public:
static String^ GetUniqueFilePath(
    String^ originalFilePath
)

Parameters

originalFilePath
Type: SystemString
The path to the original file before adding the sequence number.

Return Value

Type: String
The unique path to the file.
Remarks
This method is designed to handle the case where the user wishes to create a file in a folder with a given name when there is a possibility that the name is already taken. Using this method, it is possible to create files with names in the following format:
  • File.ext
  • File (1).ext
  • File (2).ext
  • ...
This method uses a linear search to find a unique file name, so it is suitable for situations where there are a small number of collisions for each file name. This will detect and fill gaps that can occur when files are deleted (for instance, if "File (1).ext" were deleted from the list above).
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetUniqueFilePathWithBinarySearch Method

Grid Solutions Framework FilePathGetUniqueFilePathWithBinarySearch Method
Gets a unique file path for the given file by checking for name collisions and adding a sequence number to the end of the file name if there is a collision.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetUniqueFilePathWithBinarySearch(
    string originalFilePath
)
Public Shared Function GetUniqueFilePathWithBinarySearch (
    originalFilePath As String
) As String
static member GetUniqueFilePathWithBinarySearch :
        originalFilePath : string -> string

GSF.IO.FilePath.GetUniqueFilePathWithBinarySearch = function(originalFilePath);
public:
static String^ GetUniqueFilePathWithBinarySearch(
    String^ originalFilePath
)

Parameters

originalFilePath
Type: SystemString
The path to the original file before adding the sequence number.

Return Value

Type: String
The unique path to the file.
Remarks
This method is designed to handle the case where the user wishes to create a file in a folder with a given name when there is a possibility that the name is already taken. Using this method, it is possible to create files with names in the following format:
  • File.ext
  • File (1).ext
  • File (2).ext
  • ...
This method uses a binary search to find a unique file name, so it is suitable for situations where a large number of files will be created with the same file name, and the next unique file name needs to be found relatively quickly. It will not always detect gaps in the sequence numbers that can occur when files are deleted (for instance, if "File (1).ext" were deleted from the list above).
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetValidFileName Method

Grid Solutions Framework FilePathGetValidFileName Method
Gets a valid file name by replacing invalid file name characters with replaceWithCharacter.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetValidFileName(
    string fileName,
    char replaceWithCharacter = '_'
)
Public Shared Function GetValidFileName (
    fileName As String,
    Optional replaceWithCharacter As Char = "_"C
) As String
static member GetValidFileName :
        fileName : string *
        ?replaceWithCharacter : char
(* Defaults:
        let _replaceWithCharacter = defaultArg replaceWithCharacter '_'
*)
-> string

GSF.IO.FilePath.GetValidFileName = function(fileName, replaceWithCharacter);
public:
static String^ GetValidFileName(
    String^ fileName,
    wchar_t replaceWithCharacter = L'_'
)

Parameters

fileName
Type: SystemString
File name to validate.
replaceWithCharacter (Optional)
Type: SystemChar
Character to replace invalid file name characters with. Set to '\0' to remove invalid file name characters.

Return Value

Type: String
A valid file name with no invalid file name characters.
Remarks
This function expects a file name, not a file name with a path. To properly get a valid file path, where all directory names and the file name are validated, use the GetValidFilePath(String, Char). Calling the GetValidFileName(String, Char) function will a full path will yield all directory separators replaced with the replaceWithCharacter.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.GetValidFilePath Method

Grid Solutions Framework FilePathGetValidFilePath Method
Gets a valid file path by replacing invalid file or directory name characters with replaceWithCharacter.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetValidFilePath(
    string filePath,
    char replaceWithCharacter = '_'
)
Public Shared Function GetValidFilePath (
    filePath As String,
    Optional replaceWithCharacter As Char = "_"C
) As String
static member GetValidFilePath :
        filePath : string *
        ?replaceWithCharacter : char
(* Defaults:
        let _replaceWithCharacter = defaultArg replaceWithCharacter '_'
*)
-> string

GSF.IO.FilePath.GetValidFilePath = function(filePath, replaceWithCharacter);
public:
static String^ GetValidFilePath(
    String^ filePath,
    wchar_t replaceWithCharacter = L'_'
)

Parameters

filePath
Type: SystemString
File path to validate.
replaceWithCharacter (Optional)
Type: SystemChar
Character to replace invalid file or directory name characters with. Set to '\0' to remove invalid file or directory name characters.

Return Value

Type: String
A valid file path with no invalid file or directory name characters.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.InApplicationPath Method

Grid Solutions Framework FilePathInApplicationPath Method
Determines if the specified filePath is contained with the current executable path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool InApplicationPath(
    string filePath
)
Public Shared Function InApplicationPath (
    filePath As String
) As Boolean
static member InApplicationPath :
        filePath : string -> bool

GSF.IO.FilePath.InApplicationPath = function(filePath);
public:
static bool InApplicationPath(
    String^ filePath
)

Parameters

filePath
Type: SystemString
File name or relative file path.

Return Value

Type: Boolean
true if the specified filePath is contained with the current executable path; otherwise false.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.IsFilePatternMatch Method

Grid Solutions Framework FilePathIsFilePatternMatch Method
Overload List
Name | Description
IsFilePatternMatch(String, String, Boolean) | Determines whether the specified file name matches the given file spec (wildcards are defined as '*' or '?' characters).
IsFilePatternMatch(String, String, Boolean) | Determines whether the specified file name matches any of the given file specs (wildcards are defined as '*' or '?' characters).
Top
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.IsFilePatternMatch Method (String, String, Boolean)

Grid Solutions Framework FilePathIsFilePatternMatch Method (String, String, Boolean)
Determines whether the specified file name matches the given file spec (wildcards are defined as '*' or '?' characters).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsFilePatternMatch(
    string fileSpec,
    string fileName,
    bool ignoreCase
)
Public Shared Function IsFilePatternMatch (
    fileSpec As String,
    fileName As String,
    ignoreCase As Boolean
) As Boolean
static member IsFilePatternMatch :
        fileSpec : string *
        fileName : string *
        ignoreCase : bool -> bool

GSF.IO.FilePath.IsFilePatternMatch = function(fileSpec, fileName, ignoreCase);
public:
static bool IsFilePatternMatch(
    String^ fileSpec,
    String^ fileName,
    bool ignoreCase
)

Parameters

fileSpec
Type: SystemString
The file spec used for matching the specified file name.
fileName
Type: SystemString
The file name to be tested against the specified file spec for a match.
ignoreCase
Type: SystemBoolean
true to specify a case-insensitive match; otherwise false.

Return Value

Type: Boolean
true if the specified file name matches the given file spec; otherwise false.
See Also

Reference

FilePath Class
IsFilePatternMatch Overload
GSF.IO Namespace


FilePath.IsFilePatternMatch Method (String[], String, Boolean)

Grid Solutions Framework FilePathIsFilePatternMatch Method (String, String, Boolean)
Determines whether the specified file name matches any of the given file specs (wildcards are defined as '*' or '?' characters).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsFilePatternMatch(
    string[] fileSpecs,
    string fileName,
    bool ignoreCase
)
Public Shared Function IsFilePatternMatch (
    fileSpecs As String(),
    fileName As String,
    ignoreCase As Boolean
) As Boolean
static member IsFilePatternMatch :
        fileSpecs : string[] *
        fileName : string *
        ignoreCase : bool -> bool

GSF.IO.FilePath.IsFilePatternMatch = function(fileSpecs, fileName, ignoreCase);
public:
static bool IsFilePatternMatch(
    array<String^>^ fileSpecs,
    String^ fileName,
    bool ignoreCase
)

Parameters

fileSpecs
Type: SystemString
The file specs used for matching the specified file name.
fileName
Type: SystemString
The file name to be tested against the specified file specs for a match.
ignoreCase
Type: SystemBoolean
true to specify a case-insensitive match; otherwise false.

Return Value

Type: Boolean
true if the specified file name matches any of the given file specs; otherwise false.
See Also

Reference

FilePath Class
IsFilePatternMatch Overload
GSF.IO Namespace


FilePath.IsValidFileName Method

Grid Solutions Framework FilePathIsValidFileName Method
Determines if the specified file name and path is valid.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsValidFileName(
    string filePath
)
Public Shared Function IsValidFileName (
    filePath As String
) As Boolean
static member IsValidFileName :
        filePath : string -> bool

GSF.IO.FilePath.IsValidFileName = function(filePath);
public:
static bool IsValidFileName(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file name with optional path to test for validity.

Return Value

Type: Boolean
true if the specified filePath is a valid name; otherwise false.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.RemovePathSuffix Method

Grid Solutions Framework FilePathRemovePathSuffix Method
Makes sure path is not suffixed with DirectorySeparatorChar or AltDirectorySeparatorChar.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RemovePathSuffix(
    string filePath
)
Public Shared Function RemovePathSuffix (
    filePath As String
) As String
static member RemovePathSuffix :
        filePath : string -> string

GSF.IO.FilePath.RemovePathSuffix = function(filePath);
public:
static String^ RemovePathSuffix(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The file path to be unsuffixed.

Return Value

Type: String
Unsuffixed path.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.TrimFileName Method

Grid Solutions Framework FilePathTrimFileName Method
Returns a file name, for display purposes, of the specified length using "..." to indicate a longer name.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TrimFileName(
    string filePath,
    int length
)
Public Shared Function TrimFileName (
    filePath As String,
    length As Integer
) As String
static member TrimFileName :
        filePath : string *
        length : int -> string

GSF.IO.FilePath.TrimFileName = function(filePath, length);
public:
static String^ TrimFileName(
    String^ filePath,
    int length
)

Parameters

filePath
Type: SystemString
The file path to be trimmed.
length
Type: SystemInt32
The maximum length of the trimmed file path.

Return Value

Type: String
Trimmed file path.
Remarks
Minimum value for the length parameter is 12. 12 will be used for any value specified as less than 12.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.TryGetReadLock Method

Grid Solutions Framework FilePathTryGetReadLock Method
Attempts to get read access on a file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetReadLock(
    string fileName
)
Public Shared Function TryGetReadLock (
    fileName As String
) As Boolean
static member TryGetReadLock :
        fileName : string -> bool

GSF.IO.FilePath.TryGetReadLock = function(fileName);
public:
static bool TryGetReadLock(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The file to check for read access.

Return Value

Type: Boolean
True if read access is obtained; false otherwise.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.TryGetReadLockExclusive Method

Grid Solutions Framework FilePathTryGetReadLockExclusive Method
Attempts to get read access on a file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetReadLockExclusive(
    string fileName
)
Public Shared Function TryGetReadLockExclusive (
    fileName As String
) As Boolean
static member TryGetReadLockExclusive :
        fileName : string -> bool

GSF.IO.FilePath.TryGetReadLockExclusive = function(fileName);
public:
static bool TryGetReadLockExclusive(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The file to check for read access.

Return Value

Type: Boolean
True if read access is obtained; false otherwise.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.TryGetWriteLock Method

Grid Solutions Framework FilePathTryGetWriteLock Method
Attempts to get write access on a file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetWriteLock(
    string fileName
)
Public Shared Function TryGetWriteLock (
    fileName As String
) As Boolean
static member TryGetWriteLock :
        fileName : string -> bool

GSF.IO.FilePath.TryGetWriteLock = function(fileName);
public:
static bool TryGetWriteLock(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The file to check for write access.

Return Value

Type: Boolean
True if write access is obtained; false otherwise.
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.WaitForReadLock Method

Grid Solutions Framework FilePathWaitForReadLock Method
Overload List
Name | Description
WaitForReadLock(String) | Waits for the default duration (5 seconds) for read access on a file.
WaitForReadLock(String, Double) | Waits for read access on a file for the specified number of seconds.
Top
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.WaitForReadLock Method (String)

Grid Solutions Framework FilePathWaitForReadLock Method (String)
Waits for the default duration (5 seconds) for read access on a file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitForReadLock(
    string fileName
)
Public Shared Sub WaitForReadLock (
    fileName As String
)
static member WaitForReadLock :
        fileName : string -> unit

GSF.IO.FilePath.WaitForReadLock = function(fileName);
public:
static void WaitForReadLock(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The name of the file to wait for to obtain read access.
See Also

Reference

FilePath Class
WaitForReadLock Overload
GSF.IO Namespace


FilePath.WaitForReadLock Method (String, Double)

Grid Solutions Framework FilePathWaitForReadLock Method (String, Double)
Waits for read access on a file for the specified number of seconds.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitForReadLock(
    string fileName,
    double secondsToWait
)
Public Shared Sub WaitForReadLock (
    fileName As String,
    secondsToWait As Double
)
static member WaitForReadLock :
        fileName : string *
        secondsToWait : float -> unit

GSF.IO.FilePath.WaitForReadLock = function(fileName, secondsToWait);
public:
static void WaitForReadLock(
    String^ fileName,
    double secondsToWait
)

Parameters

fileName
Type: SystemString
The name of the file to wait for to obtain read access.
secondsToWait
Type: SystemDouble
The time to wait for in seconds to obtain read access on a file. Set to zero to wait infinitely.
See Also

Reference

FilePath Class
WaitForReadLock Overload
GSF.IO Namespace


FilePath.WaitForReadLockExclusive Method

Grid Solutions Framework FilePathWaitForReadLockExclusive Method
Overload List
Name | Description
WaitForReadLockExclusive(String) | Waits for the default duration (5 seconds) for read access on a file.
WaitForReadLockExclusive(String, Double) | Waits for read access on a file for the specified number of seconds.
Top
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.WaitForReadLockExclusive Method (String)

Grid Solutions Framework FilePathWaitForReadLockExclusive Method (String)
Waits for the default duration (5 seconds) for read access on a file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitForReadLockExclusive(
    string fileName
)
Public Shared Sub WaitForReadLockExclusive (
    fileName As String
)
static member WaitForReadLockExclusive :
        fileName : string -> unit

GSF.IO.FilePath.WaitForReadLockExclusive = function(fileName);
public:
static void WaitForReadLockExclusive(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The name of the file to wait for to obtain read access.
See Also

Reference

FilePath Class
WaitForReadLockExclusive Overload
GSF.IO Namespace


FilePath.WaitForReadLockExclusive Method (String, Double)

Grid Solutions Framework FilePathWaitForReadLockExclusive Method (String, Double)
Waits for read access on a file for the specified number of seconds.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitForReadLockExclusive(
    string fileName,
    double secondsToWait
)
Public Shared Sub WaitForReadLockExclusive (
    fileName As String,
    secondsToWait As Double
)
static member WaitForReadLockExclusive :
        fileName : string *
        secondsToWait : float -> unit

GSF.IO.FilePath.WaitForReadLockExclusive = function(fileName, secondsToWait);
public:
static void WaitForReadLockExclusive(
    String^ fileName,
    double secondsToWait
)

Parameters

fileName
Type: SystemString
The name of the file to wait for to obtain read access.
secondsToWait
Type: SystemDouble
The time to wait for in seconds to obtain read access on a file. Set to zero to wait infinitely.
See Also

Reference

FilePath Class
WaitForReadLockExclusive Overload
GSF.IO Namespace


FilePath.WaitForWriteLock Method

Grid Solutions Framework FilePathWaitForWriteLock Method
Overload List
Name | Description
WaitForWriteLock(String) | Waits for the default duration (5 seconds) for write access on a file.
WaitForWriteLock(String, Double) | Waits for write access on a file for the specified number of seconds.
Top
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.WaitForWriteLock Method (String)

Grid Solutions Framework FilePathWaitForWriteLock Method (String)
Waits for the default duration (5 seconds) for write access on a file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitForWriteLock(
    string fileName
)
Public Shared Sub WaitForWriteLock (
    fileName As String
)
static member WaitForWriteLock :
        fileName : string -> unit

GSF.IO.FilePath.WaitForWriteLock = function(fileName);
public:
static void WaitForWriteLock(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The name of the file to wait for to obtain write access.
See Also

Reference

FilePath Class
WaitForWriteLock Overload
GSF.IO Namespace


FilePath.WaitForWriteLock Method (String, Double)

Grid Solutions Framework FilePathWaitForWriteLock Method (String, Double)
Waits for write access on a file for the specified number of seconds.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitForWriteLock(
    string fileName,
    double secondsToWait
)
Public Shared Sub WaitForWriteLock (
    fileName As String,
    secondsToWait As Double
)
static member WaitForWriteLock :
        fileName : string *
        secondsToWait : float -> unit

GSF.IO.FilePath.WaitForWriteLock = function(fileName, secondsToWait);
public:
static void WaitForWriteLock(
    String^ fileName,
    double secondsToWait
)

Parameters

fileName
Type: SystemString
The name of the file to wait for to obtain write access.
secondsToWait
Type: SystemDouble
The time to wait for in seconds to obtain write access on a file. Set to zero to wait infinitely.
See Also

Reference

FilePath Class
WaitForWriteLock Overload
GSF.IO Namespace


FilePath.WaitTillExists Method

Grid Solutions Framework FilePathWaitTillExists Method
Overload List
Name | Description
WaitTillExists(String) | Waits for the default duration (5 seconds) for a file to exist.
WaitTillExists(String, Double) | Waits for a file to exist for the specified number of seconds.
Top
See Also

Reference

FilePath Class
GSF.IO Namespace


FilePath.WaitTillExists Method (String)

Grid Solutions Framework FilePathWaitTillExists Method (String)
Waits for the default duration (5 seconds) for a file to exist.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitTillExists(
    string fileName
)
Public Shared Sub WaitTillExists (
    fileName As String
)
static member WaitTillExists :
        fileName : string -> unit

GSF.IO.FilePath.WaitTillExists = function(fileName);
public:
static void WaitTillExists(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The name of the file to wait for until it is created.
See Also

Reference

FilePath Class
WaitTillExists Overload
GSF.IO Namespace


FilePath.WaitTillExists Method (String, Double)

Grid Solutions Framework FilePathWaitTillExists Method (String, Double)
Waits for a file to exist for the specified number of seconds.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void WaitTillExists(
    string fileName,
    double secondsToWait
)
Public Shared Sub WaitTillExists (
    fileName As String,
    secondsToWait As Double
)
static member WaitTillExists :
        fileName : string *
        secondsToWait : float -> unit

GSF.IO.FilePath.WaitTillExists = function(fileName, secondsToWait);
public:
static void WaitTillExists(
    String^ fileName,
    double secondsToWait
)

Parameters

fileName
Type: SystemString
The name of the file to wait for until it is created.
secondsToWait
Type: SystemDouble
The time to wait for in seconds for the file to be created. Set to zero to wait infinitely.
See Also

Reference

FilePath Class
WaitTillExists Overload
GSF.IO Namespace


FileProcessor Class

Grid Solutions Framework FileProcessor Class
Tracks files processed in a list of directories, and notifies when new files become available to be processed.
Inheritance Hierarchy
SystemObject
GSF.IOFileProcessor

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class FileProcessor : IDisposable
Public NotInheritable Class FileProcessor
    Implements IDisposable
[<SealedAttribute>]
type FileProcessor =
    class
        interface IDisposable
    end
GSF.IO.FileProcessor = function();

Type.createClass(
    'GSF.IO.FileProcessor',
    null,
    IDisposable);
public ref class FileProcessor sealed : IDisposable

The FileProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | FileProcessor | Creates a new instance of the FileProcessor class.
Top
Methods
 | Name | Description
Public method | AddTrackedDirectory | Adds a directory to the list of directories tracked by this FileProcessor.
Public method | ClearTrackedDirectories | Empties the list of directories tracked by this FileProcessor.
Public method | Dispose | Releases all the resources used by the FileProcessor object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveTrackedDirectory | Removes a directory from the list of directories tracked by this FileProcessor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultCachePath | Default value for the CachePath property.
DefaultFilter | Default value for the Filter property.
DefaultInternalBufferSize | Default value for the InternalBufferSize property.
DefaultTrackChanges | Default value for the TrackChanges property.
Top
Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to the cache where the list of processed files will be persisted.
Public property | Filter | Gets or sets the filter used to determine whether a file should be processed.
Public property | InternalBufferSize | Gets or sets the internal buffer size of each of the SafeFileWatchers instantiated by this file processor.
Public property | TrackChanges | Gets or sets a flag that determines whether files should be processed on change.
Public property | TrackedDirectories | Gets the list of directories currently being tracked by the FileProcessor.
Top
Events
 | Name | Description
Public event | Error | Event triggered when an unexpected error occurs during normal operation of the FileProcessor.
Public event | Processing | Event triggered when a file is to be processed.
Top
See Also

Reference

GSF.IO Namespace


FileProcessor Constructor

Grid Solutions Framework FileProcessor Constructor
Creates a new instance of the FileProcessor class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileProcessor(
    Guid processorID
)
Public Sub New (
    processorID As Guid
)
new :
        processorID : Guid -> FileProcessor
GSF.IO.FileProcessor = function(processorID);
public:
FileProcessor(
    Guid processorID
)

Parameters

processorID
Type: SystemGuid
Identifies the file processor so that it can locate its processed file cache.
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor Fields

Grid Solutions Framework FileProcessor Fields

The FileProcessor type exposes the following members.

Fields
Name | Description
DefaultCachePath | Default value for the CachePath property.
DefaultFilter | Default value for the Filter property.
DefaultInternalBufferSize | Default value for the InternalBufferSize property.
DefaultTrackChanges | Default value for the TrackChanges property.
Top
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.DefaultCachePath Field

Grid Solutions Framework FileProcessorDefaultCachePath Field
Default value for the CachePath property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly string DefaultCachePath
Public Shared ReadOnly DefaultCachePath As String
static val DefaultCachePath: string
var GSF.IO.FileProcessor.DefaultCachePath
public:
static initonly String^ DefaultCachePath

Field Value

Type: String
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.DefaultFilter Field

Grid Solutions Framework FileProcessorDefaultFilter Field
Default value for the Filter property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultFilter
Public Const DefaultFilter As String
static val mutable DefaultFilter: string
var GSF.IO.FileProcessor.DefaultFilter
public:
literal String^ DefaultFilter

Field Value

Type: String
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.DefaultInternalBufferSize Field

Grid Solutions Framework FileProcessorDefaultInternalBufferSize Field
Default value for the InternalBufferSize property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultInternalBufferSize
Public Const DefaultInternalBufferSize As Integer
static val mutable DefaultInternalBufferSize: int
var GSF.IO.FileProcessor.DefaultInternalBufferSize
public:
literal int DefaultInternalBufferSize

Field Value

Type: Int32
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.DefaultTrackChanges Field

Grid Solutions Framework FileProcessorDefaultTrackChanges Field
Default value for the TrackChanges property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultTrackChanges
Public Const DefaultTrackChanges As Boolean
static val mutable DefaultTrackChanges: bool
var GSF.IO.FileProcessor.DefaultTrackChanges
public:
literal bool DefaultTrackChanges

Field Value

Type: Boolean
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor Methods

Grid Solutions Framework FileProcessor Methods

The FileProcessor type exposes the following members.

Methods
 | Name | Description
Public method | AddTrackedDirectory | Adds a directory to the list of directories tracked by this FileProcessor.
Public method | ClearTrackedDirectories | Empties the list of directories tracked by this FileProcessor.
Public method | Dispose | Releases all the resources used by the FileProcessor object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveTrackedDirectory | Removes a directory from the list of directories tracked by this FileProcessor.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.AddTrackedDirectory Method

Grid Solutions Framework FileProcessorAddTrackedDirectory Method
Adds a directory to the list of directories tracked by this FileProcessor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddTrackedDirectory(
    string path
)
Public Sub AddTrackedDirectory (
    path As String
)
member AddTrackedDirectory :
        path : string -> unit

function AddTrackedDirectory(path);
public:
void AddTrackedDirectory(
    String^ path
)

Parameters

path
Type: SystemString
The path to the directory to be tracked.
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.ClearTrackedDirectories Method

Grid Solutions Framework FileProcessorClearTrackedDirectories Method
Empties the list of directories tracked by this FileProcessor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ClearTrackedDirectories()
Public Sub ClearTrackedDirectories
member ClearTrackedDirectories : unit -> unit

function ClearTrackedDirectories();
public:
void ClearTrackedDirectories()
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.Dispose Method

Grid Solutions Framework FileProcessorDispose Method
Releases all the resources used by the FileProcessor object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.RemoveTrackedDirectory Method

Grid Solutions Framework FileProcessorRemoveTrackedDirectory Method
Removes a directory from the list of directories tracked by this FileProcessor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveTrackedDirectory(
    string path
)
Public Sub RemoveTrackedDirectory (
    path As String
)
member RemoveTrackedDirectory :
        path : string -> unit

function RemoveTrackedDirectory(path);
public:
void RemoveTrackedDirectory(
    String^ path
)

Parameters

path
Type: SystemString
The path to the directory to stop tracking.
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor Properties

Grid Solutions Framework FileProcessor Properties

The FileProcessor type exposes the following members.

Properties
 | Name | Description
Public property | CachePath | Gets or sets the path to the cache where the list of processed files will be persisted.
Public property | Filter | Gets or sets the filter used to determine whether a file should be processed.
Public property | InternalBufferSize | Gets or sets the internal buffer size of each of the SafeFileWatchers instantiated by this file processor.
Public property | TrackChanges | Gets or sets a flag that determines whether files should be processed on change.
Public property | TrackedDirectories | Gets the list of directories currently being tracked by the FileProcessor.
Top
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.CachePath Property

Grid Solutions Framework FileProcessorCachePath Property
Gets or sets the path to the cache where the list of processed files will be persisted.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CachePath { get; set; }
Public Property CachePath As String
    Get
    Set
member CachePath : string with get, set

function get_CachePath();
function set_CachePath(value);
public:
property String^ CachePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.Filter Property

Grid Solutions Framework FileProcessorFilter Property
Gets or sets the filter used to determine whether a file should be processed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set
member Filter : string with get, set

function get_Filter();
function set_Filter(value);
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.InternalBufferSize Property

Grid Solutions Framework FileProcessorInternalBufferSize Property
Gets or sets the internal buffer size of each of the SafeFileWatchers instantiated by this file processor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int InternalBufferSize { get; set; }
Public Property InternalBufferSize As Integer
    Get
    Set
member InternalBufferSize : int with get, set

function get_InternalBufferSize();
function set_InternalBufferSize(value);
public:
property int InternalBufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.TrackChanges Property

Grid Solutions Framework FileProcessorTrackChanges Property
Gets or sets a flag that determines whether files should be processed on change.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TrackChanges { get; set; }
Public Property TrackChanges As Boolean
    Get
    Set
member TrackChanges : bool with get, set

function get_TrackChanges();
function set_TrackChanges(value);
public:
property bool TrackChanges {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.TrackedDirectories Property

Grid Solutions Framework FileProcessorTrackedDirectories Property
Gets the list of directories currently being tracked by the FileProcessor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<string> TrackedDirectories { get; }
Public ReadOnly Property TrackedDirectories As IList(Of String)
    Get
member TrackedDirectories : IList<string> with get

function get_TrackedDirectories();

public:
property IList<String^>^ TrackedDirectories {
    IList<String^>^ get ();
}

Property Value

Type: IList String
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor Events

Grid Solutions Framework FileProcessor Events

The FileProcessor type exposes the following members.

Events
 | Name | Description
Public event | Error | Event triggered when an unexpected error occurs during normal operation of the FileProcessor.
Public event | Processing | Event triggered when a file is to be processed.
Top
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.Error Event

Grid Solutions Framework FileProcessorError Event
Event triggered when an unexpected error occurs during normal operation of the FileProcessor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<ErrorEventArgs> Error
Public Event Error As EventHandler(Of ErrorEventArgs)
member Error : IEvent<EventHandler<ErrorEventArgs>,
    ErrorEventArgs>

function add_Error(value);
function remove_Error(value);
public:
 event EventHandler<ErrorEventArgs^>^ Error {
    void add (EventHandler<ErrorEventArgs^>^ value);
    void remove (EventHandler<ErrorEventArgs^>^ value);
}

Value

Type: SystemEventHandler ErrorEventArgs
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessor.Processing Event

Grid Solutions Framework FileProcessorProcessing Event
Event triggered when a file is to be processed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<FileProcessorEventArgs> Processing
Public Event Processing As EventHandler(Of FileProcessorEventArgs)
member Processing : IEvent<EventHandler<FileProcessorEventArgs>,
    FileProcessorEventArgs>

function add_Processing(value);
function remove_Processing(value);
public:
 event EventHandler<FileProcessorEventArgs^>^ Processing {
    void add (EventHandler<FileProcessorEventArgs^>^ value);
    void remove (EventHandler<FileProcessorEventArgs^>^ value);
}

Value

Type: SystemEventHandler FileProcessorEventArgs
See Also

Reference

FileProcessor Class
GSF.IO Namespace


FileProcessorEventArgs Class

Grid Solutions Framework FileProcessorEventArgs Class
Arguments to events triggered by the FileProcessor.
Inheritance Hierarchy
SystemObject
SystemEventArgs
GSF.IOFileProcessorEventArgs

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FileProcessorEventArgs : EventArgs
Public Class FileProcessorEventArgs
    Inherits EventArgs
type FileProcessorEventArgs =
    class
        inherit EventArgs
    end
GSF.IO.FileProcessorEventArgs = function();

Type.createClass(
    'GSF.IO.FileProcessorEventArgs',
    EventArgs);
public ref class FileProcessorEventArgs : public EventArgs

The FileProcessorEventArgs type exposes the following members.

Constructors
 | Name | Description
Public method | FileProcessorEventArgs | Creates a new instance of the FileProcessorEventArgs class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AlreadyProcessed | Gets the flag that indicates whether this file has been processed before.
Public property | FullPath | Gets the full path to the file to be processed.
Public property | Requeue | Gets or sets a flag that indicates whether the file should be requeued by the file processor.
Top
See Also

Reference

GSF.IO Namespace


FileProcessorEventArgs Constructor

Grid Solutions Framework FileProcessorEventArgs Constructor
Creates a new instance of the FileProcessorEventArgs class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileProcessorEventArgs(
    string fullPath,
    bool alreadyProcessed
)
Public Sub New (
    fullPath As String,
    alreadyProcessed As Boolean
)
new :
        fullPath : string *
        alreadyProcessed : bool -> FileProcessorEventArgs
GSF.IO.FileProcessorEventArgs = function(fullPath, alreadyProcessed);
public:
FileProcessorEventArgs(
    String^ fullPath,
    bool alreadyProcessed
)

Parameters

fullPath
Type: SystemString
The full path to the file to be processed.
alreadyProcessed
Type: SystemBoolean
Flag indicating whether this file has been processed before.
See Also

Reference

FileProcessorEventArgs Class
GSF.IO Namespace


FileProcessorEventArgs Methods

Grid Solutions Framework FileProcessorEventArgs Methods

The FileProcessorEventArgs type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FileProcessorEventArgs Class
GSF.IO Namespace


FileProcessorEventArgs Properties

Grid Solutions Framework FileProcessorEventArgs Properties

The FileProcessorEventArgs type exposes the following members.

Properties
 | Name | Description
Public property | AlreadyProcessed | Gets the flag that indicates whether this file has been processed before.
Public property | FullPath | Gets the full path to the file to be processed.
Public property | Requeue | Gets or sets a flag that indicates whether the file should be requeued by the file processor.
Top
See Also

Reference

FileProcessorEventArgs Class
GSF.IO Namespace


FileProcessorEventArgs.AlreadyProcessed Property

Grid Solutions Framework FileProcessorEventArgsAlreadyProcessed Property
Gets the flag that indicates whether this file has been processed before.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AlreadyProcessed { get; }
Public ReadOnly Property AlreadyProcessed As Boolean
    Get
member AlreadyProcessed : bool with get

function get_AlreadyProcessed();

public:
property bool AlreadyProcessed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FileProcessorEventArgs Class
GSF.IO Namespace


FileProcessorEventArgs.FullPath Property

Grid Solutions Framework FileProcessorEventArgsFullPath Property
Gets the full path to the file to be processed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
member FullPath : string with get

function get_FullPath();

public:
property String^ FullPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

FileProcessorEventArgs Class
GSF.IO Namespace


FileProcessorEventArgs.Requeue Property

Grid Solutions Framework FileProcessorEventArgsRequeue Property
Gets or sets a flag that indicates whether the file should be requeued by the file processor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Requeue { get; set; }
Public Property Requeue As Boolean
    Get
    Set
member Requeue : bool with get, set

function get_Requeue();
function set_Requeue(value);
public:
property bool Requeue {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FileProcessorEventArgs Class
GSF.IO Namespace


InterprocessCache Class

Grid Solutions Framework InterprocessCache Class
Represents a serialized data cache that can be saved or read from multiple applications using inter-process synchronization.
Inheritance Hierarchy
SystemObject
GSF.IOInterprocessCache
GSF.SecurityAdoSecurityCache
GSF.SecurityUserDataCache
GSF.SecurityUserRoleCache

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class InterprocessCache : IDisposable
Public Class InterprocessCache
    Implements IDisposable
type InterprocessCache =
    class
        interface IDisposable
    end
GSF.IO.InterprocessCache = function();

Type.createClass(
    'GSF.IO.InterprocessCache',
    null,
    IDisposable);
public ref class InterprocessCache : IDisposable

The InterprocessCache type exposes the following members.

Constructors
 | Name | Description
Public method | InterprocessCache | Creates a new instance of the InterprocessCache.
Public method | InterprocessCache(Int32) | Creates a new instance of the InterprocessCache with the specified number of maximumConcurrentLocks.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Initiates inter-process synchronized cache file load.
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Initiates inter-process synchronized cache file save.
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete.
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultMaximumRetryAttempts | Default maximum retry attempts allowed for loading InterprocessCache.
DefaultRetryDelayInterval | Default wait interval, in milliseconds, before retrying load of InterprocessCache.
Top
Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated.
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded.
Public property | FileName | Path and file name for the cache needing inter-process synchronization.
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed.
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data.
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData.
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data.
Top
Remarks
Note that all file data in this class gets serialized to and from memory, as such, the design intention for this class is for use with smaller data sets such as serialized lists or dictionaries that need inter-process synchronized loading and saving.
See Also

Reference

GSF.IO Namespace


InterprocessCache Constructor

Grid Solutions Framework InterprocessCache Constructor
Overload List
 | Name | Description
Public method | InterprocessCache | Creates a new instance of the InterprocessCache.
Public method | InterprocessCache(Int32) | Creates a new instance of the InterprocessCache with the specified number of maximumConcurrentLocks.
Top
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache Constructor

Grid Solutions Framework InterprocessCache Constructor
Creates a new instance of the InterprocessCache.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InterprocessCache()
Public Sub New
new : unit -> InterprocessCache
GSF.IO.InterprocessCache = function();
public:
InterprocessCache()
See Also

Reference

InterprocessCache Class
InterprocessCache Overload
GSF.IO Namespace


InterprocessCache Constructor (Int32)

Grid Solutions Framework InterprocessCache Constructor (Int32)
Creates a new instance of the InterprocessCache with the specified number of maximumConcurrentLocks.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InterprocessCache(
    int maximumConcurrentLocks
)
Public Sub New (
    maximumConcurrentLocks As Integer
)
new :
        maximumConcurrentLocks : int -> InterprocessCache
GSF.IO.InterprocessCache = function(maximumConcurrentLocks);
public:
InterprocessCache(
    int maximumConcurrentLocks
)

Parameters

maximumConcurrentLocks
Type: SystemInt32
Maximum concurrent reader locks to allow.
See Also

Reference

InterprocessCache Class
InterprocessCache Overload
GSF.IO Namespace


InterprocessCache Fields

Grid Solutions Framework InterprocessCache Fields

The InterprocessCache type exposes the following members.

Fields
Name | Description
DefaultMaximumRetryAttempts | Default maximum retry attempts allowed for loading InterprocessCache.
DefaultRetryDelayInterval | Default wait interval, in milliseconds, before retrying load of InterprocessCache.
Top
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.DefaultMaximumRetryAttempts Field

Grid Solutions Framework InterprocessCacheDefaultMaximumRetryAttempts Field
Default maximum retry attempts allowed for loading InterprocessCache.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaximumRetryAttempts
Public Const DefaultMaximumRetryAttempts As Integer
static val mutable DefaultMaximumRetryAttempts: int
var GSF.IO.InterprocessCache.DefaultMaximumRetryAttempts
public:
literal int DefaultMaximumRetryAttempts

Field Value

Type: Int32
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.DefaultRetryDelayInterval Field

Grid Solutions Framework InterprocessCacheDefaultRetryDelayInterval Field
Default wait interval, in milliseconds, before retrying load of InterprocessCache.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultRetryDelayInterval
Public Const DefaultRetryDelayInterval As Double
static val mutable DefaultRetryDelayInterval: float
var GSF.IO.InterprocessCache.DefaultRetryDelayInterval
public:
literal double DefaultRetryDelayInterval

Field Value

Type: Double
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache Methods

Grid Solutions Framework InterprocessCache Methods

The InterprocessCache type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Initiates inter-process synchronized cache file load.
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Initiates inter-process synchronized cache file save.
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge).
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete.
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.Dispose Method

Grid Solutions Framework InterprocessCacheDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources.
Top
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.Dispose Method

Grid Solutions Framework InterprocessCacheDispose Method
Releases all the resources used by the InterprocessCache object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

InterprocessCache Class
Dispose Overload
GSF.IO Namespace


InterprocessCache.Dispose Method (Boolean)

Grid Solutions Framework InterprocessCacheDispose Method (Boolean)
Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

InterprocessCache Class
Dispose Overload
GSF.IO Namespace


InterprocessCache.Finalize Method

Grid Solutions Framework InterprocessCacheFinalize Method
Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.Load Method

Grid Solutions Framework InterprocessCacheLoad Method
Initiates inter-process synchronized cache file load.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Load()
Public Overridable Sub Load
abstract Load : unit -> unit
override Load : unit -> unit
function Load();
public:
virtual void Load()
Remarks
Subclasses should always call WaitForLoad before calling this method.
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.LoadFileData Method

Grid Solutions Framework InterprocessCacheLoadFileData Method
Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual byte[] LoadFileData(
    FileStream fileStream
)
Protected Overridable Function LoadFileData (
    fileStream As FileStream
) As Byte()
abstract LoadFileData :
        fileStream : FileStream -> byte[]
override LoadFileData :
        fileStream : FileStream -> byte[]
function LoadFileData(fileStream);
protected:
virtual array<unsigned char>^ LoadFileData(
    FileStream^ fileStream
)

Parameters

fileStream
Type: System.IOFileStream
FileStream used to deserialize data.

Return Value

Type: Byte
Deserialized file data.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.Save Method

Grid Solutions Framework InterprocessCacheSave Method
Initiates inter-process synchronized cache file save.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Save()
Public Overridable Sub Save
abstract Save : unit -> unit
override Save : unit -> unit
function Save();
public:
virtual void Save()
Remarks
Subclasses should always call WaitForLoad before calling this method.
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.SaveFileData Method

Grid Solutions Framework InterprocessCacheSaveFileData Method
Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void SaveFileData(
    FileStream fileStream,
    byte[] fileData
)
Protected Overridable Sub SaveFileData (
    fileStream As FileStream,
    fileData As Byte()
)
abstract SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
override SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
function SaveFileData(fileStream, fileData);
protected:
virtual void SaveFileData(
    FileStream^ fileStream,
    array<unsigned char>^ fileData
)

Parameters

fileStream
Type: System.IOFileStream
FileStream used to serialize data.
fileData
Type: SystemByte
File data to be serialized.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.WaitForLoad Method

Grid Solutions Framework InterprocessCacheWaitForLoad Method
Overload List
 | Name | Description
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete.
Top
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.WaitForLoad Method

Grid Solutions Framework InterprocessCacheWaitForLoad Method
Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void WaitForLoad()
Public Overridable Sub WaitForLoad
abstract WaitForLoad : unit -> unit
override WaitForLoad : unit -> unit
function WaitForLoad();
public:
virtual void WaitForLoad()
See Also

Reference

InterprocessCache Class
WaitForLoad Overload
GSF.IO Namespace


InterprocessCache.WaitForLoad Method (Int32)

Grid Solutions Framework InterprocessCacheWaitForLoad Method (Int32)
Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void WaitForLoad(
    int millisecondsTimeout
)
Public Overridable Sub WaitForLoad (
    millisecondsTimeout As Integer
)
abstract WaitForLoad :
        millisecondsTimeout : int -> unit
override WaitForLoad :
        millisecondsTimeout : int -> unit
function WaitForLoad(millisecondsTimeout);
public:
virtual void WaitForLoad(
    int millisecondsTimeout
)

Parameters

millisecondsTimeout
Type: SystemInt32
The number of milliseconds to wait, or Infinite(-1) to wait indefinitely.
See Also

Reference

InterprocessCache Class
WaitForLoad Overload
GSF.IO Namespace


InterprocessCache.WaitForSave Method

Grid Solutions Framework InterprocessCacheWaitForSave Method
Overload List
 | Name | Description
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete.
Top
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.WaitForSave Method

Grid Solutions Framework InterprocessCacheWaitForSave Method
Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void WaitForSave()
Public Overridable Sub WaitForSave
abstract WaitForSave : unit -> unit
override WaitForSave : unit -> unit
function WaitForSave();
public:
virtual void WaitForSave()
See Also

Reference

InterprocessCache Class
WaitForSave Overload
GSF.IO Namespace


InterprocessCache.WaitForSave Method (Int32)

Grid Solutions Framework InterprocessCacheWaitForSave Method (Int32)
Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void WaitForSave(
    int millisecondsTimeout
)
Public Overridable Sub WaitForSave (
    millisecondsTimeout As Integer
)
abstract WaitForSave :
        millisecondsTimeout : int -> unit
override WaitForSave :
        millisecondsTimeout : int -> unit
function WaitForSave(millisecondsTimeout);
public:
virtual void WaitForSave(
    int millisecondsTimeout
)

Parameters

millisecondsTimeout
Type: SystemInt32
The number of milliseconds to wait, or Infinite(-1) to wait indefinitely.
See Also

Reference

InterprocessCache Class
WaitForSave Overload
GSF.IO Namespace


InterprocessCache Properties

Grid Solutions Framework InterprocessCache Properties

The InterprocessCache type exposes the following members.

Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated.
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded.
Public property | FileName | Path and file name for the cache needing inter-process synchronization.
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed.
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data.
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData.
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data.
Top
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.AutoSave Property

Grid Solutions Framework InterprocessCacheAutoSave Property
Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AutoSave { get; set; }
Public Property AutoSave As Boolean
    Get
    Set
member AutoSave : bool with get, set

function get_AutoSave();
function set_AutoSave(value);
public:
property bool AutoSave {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.FileData Property

Grid Solutions Framework InterprocessCacheFileData Property
Gets or sets file data for the cache to be saved or that has been loaded.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] FileData { get; set; }
Public Property FileData As Byte()
    Get
    Set
member FileData : byte[] with get, set

function get_FileData();
function set_FileData(value);
public:
property array<unsigned char>^ FileData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Remarks
Setting value to null will create a zero-length file.
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.FileName Property

Grid Solutions Framework InterprocessCacheFileName Property
Path and file name for the cache needing inter-process synchronization.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.MaximumConcurrentLocks Property

Grid Solutions Framework InterprocessCacheMaximumConcurrentLocks Property
Gets the maximum concurrent reader locks allowed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaximumConcurrentLocks { get; }
Public ReadOnly Property MaximumConcurrentLocks As Integer
    Get
member MaximumConcurrentLocks : int with get

function get_MaximumConcurrentLocks();

public:
property int MaximumConcurrentLocks {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.MaximumRetryAttempts Property

Grid Solutions Framework InterprocessCacheMaximumRetryAttempts Property
Maximum retry attempts allowed for loading or saving cache file data.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaximumRetryAttempts { get; set; }
Public Property MaximumRetryAttempts As Integer
    Get
    Set
member MaximumRetryAttempts : int with get, set

function get_MaximumRetryAttempts();
function set_MaximumRetryAttempts(value);
public:
property int MaximumRetryAttempts {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.ReloadOnChange Property

Grid Solutions Framework InterprocessCacheReloadOnChange Property
Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReloadOnChange { get; set; }
Public Property ReloadOnChange As Boolean
    Get
    Set
member ReloadOnChange : bool with get, set

function get_ReloadOnChange();
function set_ReloadOnChange(value);
public:
property bool ReloadOnChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Use extreme caution when enabling this property - it will be critical to dispose of this class when this property is set to true since it will create a file watcher that attaches to an event referenced by this class using pinned memory, as a result, this class will not get garbage collected until this class is disposed thus detaching the associated event.
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


InterprocessCache.RetryDelayInterval Property

Grid Solutions Framework InterprocessCacheRetryDelayInterval Property
Wait interval, in milliseconds, before retrying load or save of cache file data.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double RetryDelayInterval { get; set; }
Public Property RetryDelayInterval As Double
    Get
    Set
member RetryDelayInterval : float with get, set

function get_RetryDelayInterval();
function set_RetryDelayInterval(value);
public:
property double RetryDelayInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

InterprocessCache Class
GSF.IO Namespace


IsamDataFileBase(T) Class

Grid Solutions Framework IsamDataFileBaseT Class
An abstract class that defines the read/write capabilities for ISAM (Indexed Sequential Access Method) file.
Inheritance Hierarchy
SystemObject
GSF.IOIsamDataFileBaseT
GSF.Historian.FilesIntercomFile
GSF.Historian.FilesMetadataFile
GSF.Historian.FilesStateFile

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class IsamDataFileBase<T> : ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings
where T : ISupportBinaryImage

Public MustInherit Class IsamDataFileBase(Of T As ISupportBinaryImage)
    Implements ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
[<AbstractClassAttribute>]
type IsamDataFileBase<'T when 'T : ISupportBinaryImage> =
    class
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : ISupportBinaryImage
public ref class IsamDataFileBase abstract : ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings

Type Parameters

T
Type of the records the file contains. This Type must implement the ISupportBinaryImage interface.

The IsamDataFileBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | IsamDataFileBaseT | Initializes a new instance of the IsamDataFileBaseT class.
Top
Methods
 | Name | Description
Public method | Close | Closes the file.
Protected method | CreateNewRecord | When overridden in a derived class, returns a new empty record.
Public method | Dispose | Releases all the resources used by the file.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | When overridden in a derived class, gets the size of a record (in bytes).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file.
Public method | Load | Loads records from disk into memory.
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event.
Protected method | OnDataLoading | Raises the DataLoading event.
Protected method | OnDataSaved | Raises the DataSaved event.
Protected method | OnDataSaving | Raises the DataSaving event.
Protected method | OnFileModified | Raises the FileModified event.
Public method | Open | Opens the file.
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory.
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory.
Public method | Save | Saves records loaded in memory to disk.
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableT) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory.
Public method | Write(Int32, T) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAutoSaveInterval | Specifies the default value for the AutoSaveInterval property.
DefaultFileAccessMode | Specifies the default value for the FileAccessMode property.
DefaultFileName | Specifies the default value for the FileName property.
DefaultLoadOnOpen | Specifies the default value for the LoadOnOpen property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultReloadOnModify | Specifies the default value for the ReloadOnModify property.
DefaultSaveOnClose | Specifies the default value for the SaveOnClose property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk.
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled.
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file.
Protected property | FileData | Gets the underlying FileStream of the file.
Protected property | FileDataLock | Gets the locking object for the FileData stream.
Public property | FileName | Gets or sets the name of the file.
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsOpen | Gets a boolean value that indicates whether the file is open.
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened.
Protected property | LoadWaitHandle | Gets wait handle for loading data.
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file.
Public property | Name | Gets the unique identifier of the file.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file.
Public property | RecordsInMemory | Gets the number of file records loaded in memory.
Public property | RecordsOnDisk | Gets the number of file records on the disk.
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk.
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed.
Protected property | SaveWaitHandle | Gets wait handle for saving data.
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Status | Gets the descriptive status of the file.
Top
Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory.
Public event | DataLoading | Occurs when data is being read from disk into memory.
Public event | DataSaved | Occurs when data has been saved from memory onto disk.
Public event | DataSaving | Occurs when data is being saved from memory onto disk.
Public event | Disposed | Occurs when the class has been disposed.
Public event | FileModified | Occurs when file data on the disk is modified.
Top
Remarks

This ISAM implementation keeps all the records in memory, so it may not be suitable for very large files. Since data is stored in memory using a list, the maximum number of possible supported records will be 2,147,483,647 (i.e., Int32.MaxValue).

See http://en.wikipedia.org/wiki/ISAM for more information on ISAM files.

Examples
This example shows a sample implementation of IsamDataFileBaseT:
Copy
using System;
using System.Text;
using GSF;
using GSF.IO;
using GSF.Parsing;

class Program
{
    static void Main(string[] args)
    {
        // Create a few test records.
        TestIsamFileRecord r1 = new TestIsamFileRecord(1);
        r1.Name = "TestRecord1";
        r1.Value = double.MinValue;
        r1.Description = "Test record with minimum double value";
        TestIsamFileRecord r2 = new TestIsamFileRecord(2);
        r2.Name = "TestRecord2";
        r2.Value = double.MaxValue;
        r2.Description = "Test record with maximum double value";

        // Open ISAM file.
        TestIsamFile testFile = new TestIsamFile();
        testFile.FileName = "TestIsamFile.dat";
        testFile.Open();

        // Write test records.
        testFile.Write(r1.Index, r1);
        testFile.Write(r2.Index, r2);

        // Read test records.
        Console.WriteLine(testFile.Read(1));
        Console.WriteLine(testFile.Read(2));

        // Close ISAM file.
        testFile.Close();

        Console.ReadLine();
    }
}

class TestIsamFile : IsamDataFileBase<TestIsamFileRecord>
{
    /// <summary>
    /// Size of a single file record.
    /// </summary>
    protected override int GetRecordSize()
    {
        return TestIsamFileRecord.RecordLength;
    }

    /// <summary>
    /// Creates a new empty file record.
    /// </summary>
    protected override TestIsamFileRecord CreateNewRecord(int id)
    {
        return new TestIsamFileRecord(id);
    }
}

class TestIsamFileRecord : ISupportBinaryImage
{
    private int m_index;
    private string m_name;                  // 20  * 1 =  20
    private double m_value;                 // 1   * 8 =   8
    private string m_description;           // 100 * 1 = 100

    public const int RecordLength = 128;    // Total   = 128

    public TestIsamFileRecord(int recordIndex)
    {
        m_index = recordIndex;

        Name = string.Empty;
        Value = double.NaN;
        Description = string.Empty;
    }

    /// <summary>
    /// 1-based index of the record.
    /// </summary>
    public int Index
    {
        get { return m_index; }
    }

    /// <summary>
    /// Name of the record.
    /// </summary>
    public string Name
    {
        get { return m_name; }
        set { m_name = value.TruncateRight(20).PadRight(20); }
    }

    /// <summary>
    /// Value of the record.
    /// </summary>
    public double Value
    {
        get { return m_value; }
        set { m_value = value; }
    }

    /// <summary>
    /// Description of the record.
    /// </summary>
    public string Description
    {
        get { return m_description; }
        set { m_description = value.TruncateRight(100).PadRight(100); }
    }

    /// <summary>
    /// Serialized record length.
    /// </summary>
    public int BinaryLength
    {
        get { return RecordLength; }
    }

    /// <summary>
    /// Serialized record data.
    /// </summary>
    public byte[] BinaryImage
    {
        get
        {
            // Serialize TestIsamFileRecord into byte array.
            byte[] image = new byte[RecordLength];
            Buffer.BlockCopy(Encoding.ASCII.GetBytes(Name), 0, image, 0, 20);
            Buffer.BlockCopy(BitConverter.GetBytes(Value), 0, image, 20, 8);
            Buffer.BlockCopy(Encoding.ASCII.GetBytes(Description), 0, image, 28, 100);

            return image;
        }
    }

    /// <summary>
    /// Deserializes the record.
    /// </summary>
    public int Initialize(byte[] binaryImage, int startIndex, int length)
    {
        if (length >= RecordLength)
        {
            // Deserialize byte array into TestIsamFileRecord.
            Name = Encoding.ASCII.GetString(binaryImage, startIndex, 20);
            Value = BitConverter.ToDouble(binaryImage, startIndex + 20);
            Description = Encoding.ASCII.GetString(binaryImage, startIndex + 28, 100);
        }
        else
            throw new InvalidOperationException("Invalid record size, not enough data to deserialize record");

        return RecordLength;
    }

    /// <summary>
    /// String representation of the record.
    /// </summary>
    public override string ToString()
    {
        return string.Format("Name: {0}, Value: {1}, Description: {2}", Name, Value, Description);
    }
}
See Also

Reference

GSF.IO Namespace


IsamDataFileBase(T) Constructor

Grid Solutions Framework IsamDataFileBaseT Constructor
Initializes a new instance of the IsamDataFileBaseT class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IsamDataFileBase()
Protected Sub New
new : unit -> IsamDataFileBase
GSF.IO.IsamDataFileBase = function();
protected:
IsamDataFileBase()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T) Fields

Grid Solutions Framework IsamDataFileBaseT Fields

The IsamDataFileBaseT generic type exposes the following members.

Fields
Name | Description
DefaultAutoSaveInterval | Specifies the default value for the AutoSaveInterval property.
DefaultFileAccessMode | Specifies the default value for the FileAccessMode property.
DefaultFileName | Specifies the default value for the FileName property.
DefaultLoadOnOpen | Specifies the default value for the LoadOnOpen property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultReloadOnModify | Specifies the default value for the ReloadOnModify property.
DefaultSaveOnClose | Specifies the default value for the SaveOnClose property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultAutoSaveInterval Field

Grid Solutions Framework IsamDataFileBaseTDefaultAutoSaveInterval Field
Specifies the default value for the AutoSaveInterval property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultAutoSaveInterval
Public Const DefaultAutoSaveInterval As Integer
static val mutable DefaultAutoSaveInterval: int
var GSF.IO.IsamDataFileBase.DefaultAutoSaveInterval
public:
literal int DefaultAutoSaveInterval

Field Value

Type: Int32
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultFileAccessMode Field

Grid Solutions Framework IsamDataFileBaseTDefaultFileAccessMode Field
Specifies the default value for the FileAccessMode property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const FileAccess DefaultFileAccessMode
Public Const DefaultFileAccessMode As FileAccess
static val mutable DefaultFileAccessMode: FileAccess
var GSF.IO.IsamDataFileBase.DefaultFileAccessMode
public:
literal FileAccess DefaultFileAccessMode

Field Value

Type: FileAccess
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultFileName Field

Grid Solutions Framework IsamDataFileBaseTDefaultFileName Field
Specifies the default value for the FileName property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultFileName
Public Const DefaultFileName As String
static val mutable DefaultFileName: string
var GSF.IO.IsamDataFileBase.DefaultFileName
public:
literal String^ DefaultFileName

Field Value

Type: String
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultLoadOnOpen Field

Grid Solutions Framework IsamDataFileBaseTDefaultLoadOnOpen Field
Specifies the default value for the LoadOnOpen property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLoadOnOpen
Public Const DefaultLoadOnOpen As Boolean
static val mutable DefaultLoadOnOpen: bool
var GSF.IO.IsamDataFileBase.DefaultLoadOnOpen
public:
literal bool DefaultLoadOnOpen

Field Value

Type: Boolean
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultPersistSettings Field

Grid Solutions Framework IsamDataFileBaseTDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.IO.IsamDataFileBase.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultReloadOnModify Field

Grid Solutions Framework IsamDataFileBaseTDefaultReloadOnModify Field
Specifies the default value for the ReloadOnModify property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultReloadOnModify
Public Const DefaultReloadOnModify As Boolean
static val mutable DefaultReloadOnModify: bool
var GSF.IO.IsamDataFileBase.DefaultReloadOnModify
public:
literal bool DefaultReloadOnModify

Field Value

Type: Boolean
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultSaveOnClose Field

Grid Solutions Framework IsamDataFileBaseTDefaultSaveOnClose Field
Specifies the default value for the SaveOnClose property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultSaveOnClose
Public Const DefaultSaveOnClose As Boolean
static val mutable DefaultSaveOnClose: bool
var GSF.IO.IsamDataFileBase.DefaultSaveOnClose
public:
literal bool DefaultSaveOnClose

Field Value

Type: Boolean
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DefaultSettingsCategory Field

Grid Solutions Framework IsamDataFileBaseTDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.IO.IsamDataFileBase.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T) Methods

Grid Solutions Framework IsamDataFileBaseT Methods

The IsamDataFileBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the file.
Protected method | CreateNewRecord | When overridden in a derived class, returns a new empty record.
Public method | Dispose | Releases all the resources used by the file.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the file is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetRecordSize | When overridden in a derived class, gets the size of a record (in bytes).
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the file.
Public method | Load | Loads records from disk into memory.
Public method | LoadSettings | Loads saved settings of the file from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnDataLoaded | Raises the DataLoaded event.
Protected method | OnDataLoading | Raises the DataLoading event.
Protected method | OnDataSaved | Raises the DataSaved event.
Protected method | OnDataSaving | Raises the DataSaving event.
Protected method | OnFileModified | Raises the FileModified event.
Public method | Open | Opens the file.
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory.
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory.
Public method | Save | Saves records loaded in memory to disk.
Public method | SaveSettings | Saves settings of the file to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(IEnumerableT) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory.
Public method | Write(Int32, T) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Close Method

Grid Solutions Framework IsamDataFileBaseTClose Method
Closes the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Close()
Public Overridable Sub Close
abstract Close : unit -> unit
override Close : unit -> unit
function Close();
public:
virtual void Close()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).CreateNewRecord Method

Grid Solutions Framework IsamDataFileBaseTCreateNewRecord Method
When overridden in a derived class, returns a new empty record.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract T CreateNewRecord(
    int recordIndex
)
Protected MustOverride Function CreateNewRecord (
    recordIndex As Integer
) As T
abstract CreateNewRecord :
        recordIndex : int -> 'T

function CreateNewRecord(recordIndex);
protected:
virtual T CreateNewRecord(
    int recordIndex
) abstract

Parameters

recordIndex
Type: SystemInt32
1-based index of the new record.

Return Value

Type: T
New empty record.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Dispose Method

Grid Solutions Framework IsamDataFileBaseTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the file.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the file and optionally releases the managed resources.
Top
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Dispose Method

Grid Solutions Framework IsamDataFileBaseTDispose Method
Releases all the resources used by the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

IsamDataFileBaseT Class
Dispose Overload
GSF.IO Namespace


IsamDataFileBase(T).Dispose Method (Boolean)

Grid Solutions Framework IsamDataFileBaseTDispose Method (Boolean)
Releases the unmanaged resources used by the file and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

IsamDataFileBaseT Class
Dispose Overload
GSF.IO Namespace


IsamDataFileBase(T).Finalize Method

Grid Solutions Framework IsamDataFileBaseTFinalize Method
Releases the unmanaged resources before the file is reclaimed by GC.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).GetRecordSize Method

Grid Solutions Framework IsamDataFileBaseTGetRecordSize Method
When overridden in a derived class, gets the size of a record (in bytes).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract int GetRecordSize()
Protected MustOverride Function GetRecordSize As Integer
abstract GetRecordSize : unit -> int

function GetRecordSize();
protected:
virtual int GetRecordSize() abstract

Return Value

Type: Int32
Size of a record in bytes.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Initialize Method

Grid Solutions Framework IsamDataFileBaseTInitialize Method
Initializes the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the file is not consumed through the designer surface of the IDE.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Load Method

Grid Solutions Framework IsamDataFileBaseTLoad Method
Loads records from disk into memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Load()
Public Overridable Sub Load
abstract Load : unit -> unit
override Load : unit -> unit
function Load();
public:
virtual void Load()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).LoadSettings Method

Grid Solutions Framework IsamDataFileBaseTLoadSettings Method
Loads saved settings of the file from the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void LoadSettings()
Public Overridable Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings()

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).OnDataLoaded Method

Grid Solutions Framework IsamDataFileBaseTOnDataLoaded Method
Raises the DataLoaded event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataLoaded()
Protected Overridable Sub OnDataLoaded
abstract OnDataLoaded : unit -> unit
override OnDataLoaded : unit -> unit
function OnDataLoaded();
protected:
virtual void OnDataLoaded()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).OnDataLoading Method

Grid Solutions Framework IsamDataFileBaseTOnDataLoading Method
Raises the DataLoading event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataLoading()
Protected Overridable Sub OnDataLoading
abstract OnDataLoading : unit -> unit
override OnDataLoading : unit -> unit
function OnDataLoading();
protected:
virtual void OnDataLoading()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).OnDataSaved Method

Grid Solutions Framework IsamDataFileBaseTOnDataSaved Method
Raises the DataSaved event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataSaved()
Protected Overridable Sub OnDataSaved
abstract OnDataSaved : unit -> unit
override OnDataSaved : unit -> unit
function OnDataSaved();
protected:
virtual void OnDataSaved()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).OnDataSaving Method

Grid Solutions Framework IsamDataFileBaseTOnDataSaving Method
Raises the DataSaving event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataSaving()
Protected Overridable Sub OnDataSaving
abstract OnDataSaving : unit -> unit
override OnDataSaving : unit -> unit
function OnDataSaving();
protected:
virtual void OnDataSaving()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).OnFileModified Method

Grid Solutions Framework IsamDataFileBaseTOnFileModified Method
Raises the FileModified event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnFileModified()
Protected Overridable Sub OnFileModified
abstract OnFileModified : unit -> unit
override OnFileModified : unit -> unit
function OnFileModified();
protected:
virtual void OnFileModified()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Open Method

Grid Solutions Framework IsamDataFileBaseTOpen Method
Opens the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Open()
Public Overridable Sub Open
abstract Open : unit -> unit
override Open : unit -> unit
function Open();
public:
virtual void Open()
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Read Method

Grid Solutions Framework IsamDataFileBaseTRead Method
Overload List
 | Name | Description
Public method | Read | Reads file records from disk if records were not loaded in memory otherwise returns the records in memory.
Public method | Read(Int32) | Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory.
Top
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Read Method

Grid Solutions Framework IsamDataFileBaseTRead Method
Reads file records from disk if records were not loaded in memory otherwise returns the records in memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IEnumerable<T> Read()
Public Overridable Function Read As IEnumerable(Of T)
abstract Read : unit -> IEnumerable<'T>
override Read : unit -> IEnumerable<'T>
function Read();
public:
virtual IEnumerable<T>^ Read()

Return Value

Type: IEnumerable T
Records of the file.
See Also

Reference

IsamDataFileBaseT Class
Read Overload
GSF.IO Namespace


IsamDataFileBase(T).Read Method (Int32)

Grid Solutions Framework IsamDataFileBaseTRead Method (Int32)
Reads specified file record from disk if records were not loaded in memory otherwise returns the record in memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual T Read(
    int recordIndex
)
Public Overridable Function Read (
    recordIndex As Integer
) As T
abstract Read :
        recordIndex : int -> 'T
override Read :
        recordIndex : int -> 'T
function Read(recordIndex);
public:
virtual T Read(
    int recordIndex
)

Parameters

recordIndex
Type: SystemInt32
1-based index of the record to be read.

Return Value

Type: T
Record with the specified ID if it exists; otherwise null.
See Also

Reference

IsamDataFileBaseT Class
Read Overload
GSF.IO Namespace


IsamDataFileBase(T).Save Method

Grid Solutions Framework IsamDataFileBaseTSave Method
Saves records loaded in memory to disk.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Save()
Public Overridable Sub Save
abstract Save : unit -> unit
override Save : unit -> unit
function Save();
public:
virtual void Save()
Remarks
Save is equivalent to Flush when records are not loaded in memory.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).SaveSettings Method

Grid Solutions Framework IsamDataFileBaseTSaveSettings Method
Saves settings of the file to the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SaveSettings()
Public Overridable Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings()

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Write Method

Grid Solutions Framework IsamDataFileBaseTWrite Method
Overload List
 | Name | Description
Public method | Write(IEnumerableT) | Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory.
Public method | Write(Int32, T) | Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory.
Top
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Write Method (IEnumerable(T))

Grid Solutions Framework IsamDataFileBaseTWrite Method (IEnumerableT)
Writes specified records to disk if records were not loaded in memory otherwise updates the records in memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Write(
    IEnumerable<T> records
)
Public Overridable Sub Write (
    records As IEnumerable(Of T)
)
abstract Write :
        records : IEnumerable<'T> -> unit
override Write :
        records : IEnumerable<'T> -> unit
function Write(records);
public:
virtual void Write(
    IEnumerable<T>^ records
)

Parameters

records
Type: System.Collections.GenericIEnumerable T
Records to be written.
Remarks
This operation will causes existing records to be deleted and replaced with the ones specified.
See Also

Reference

IsamDataFileBaseT Class
Write Overload
GSF.IO Namespace


IsamDataFileBase(T).Write Method (Int32, T)

Grid Solutions Framework IsamDataFileBaseTWrite Method (Int32, T)
Writes specified record to disk if records were not loaded in memory otherwise updates the record in memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Write(
    int recordIndex,
    T record
)
Public Overridable Sub Write (
    recordIndex As Integer,
    record As T
)
abstract Write :
        recordIndex : int *
        record : 'T -> unit
override Write :
        recordIndex : int *
        record : 'T -> unit
function Write(recordIndex, record);
public:
virtual void Write(
    int recordIndex,
    T record
)

Parameters

recordIndex
Type: SystemInt32
1-based index of the record to be written.
record
Type: T
Record to be written.
See Also

Reference

IsamDataFileBaseT Class
Write Overload
GSF.IO Namespace


IsamDataFileBase(T) Properties

Grid Solutions Framework IsamDataFileBaseT Properties

The IsamDataFileBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | AutoSaveInterval | Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk.
Public property | Enabled | Gets or sets a boolean value that indicates whether the file is currently enabled.
Public property | FileAccessMode | Gets or sets the FileAccess value to use when opening the file.
Protected property | FileData | Gets the underlying FileStream of the file.
Protected property | FileDataLock | Gets the locking object for the FileData stream.
Public property | FileName | Gets or sets the name of the file.
Public property | IsCorrupt | Gets a boolean value that indicates whether the file data on disk is corrupt.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsOpen | Gets a boolean value that indicates whether the file is open.
Public property | LoadOnOpen | Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened.
Protected property | LoadWaitHandle | Gets wait handle for loading data.
Public property | MemoryUsage | Gets the approximate memory consumption (in KB) of the file.
Public property | Name | Gets the unique identifier of the file.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file.
Public property | RecordsInMemory | Gets the number of file records loaded in memory.
Public property | RecordsOnDisk | Gets the number of file records on the disk.
Public property | ReloadOnModify | Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk.
Public property | SaveOnClose | Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed.
Protected property | SaveWaitHandle | Gets wait handle for saving data.
Public property | SettingsCategory | Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | Status | Gets the descriptive status of the file.
Top
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).AutoSaveInterval Property

Grid Solutions Framework IsamDataFileBaseTAutoSaveInterval Property
Gets or sets the interval in milliseconds at which the records loaded in memory are to be persisted to disk.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int AutoSaveInterval { get; set; }
Public Property AutoSaveInterval As Integer
    Get
    Set
member AutoSaveInterval : int with get, set

function get_AutoSaveInterval();
function set_AutoSaveInterval(value);
public:
property int AutoSaveInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
AutoSaveInterval will be effective only if records have been loaded in memory either manually by calling the Load method or automatically by settings LoadOnOpen to true.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Enabled Property

Grid Solutions Framework IsamDataFileBaseTEnabled Property
Gets or sets a boolean value that indicates whether the file is currently enabled.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public bool Enabled { get; set; }
<XmlIgnoreAttribute>
Public Property Enabled As Boolean
    Get
    Set
[<XmlIgnoreAttribute>]
abstract Enabled : bool with get, set
[<XmlIgnoreAttribute>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[XmlIgnoreAttribute]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Setting Enabled to true will open the file if it is closed, setting to false will close the file if it is open.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).FileAccessMode Property

Grid Solutions Framework IsamDataFileBaseTFileAccessMode Property
Gets or sets the FileAccess value to use when opening the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileAccess FileAccessMode { get; set; }
Public Property FileAccessMode As FileAccess
    Get
    Set
member FileAccessMode : FileAccess with get, set

function get_FileAccessMode();
function set_FileAccessMode(value);
public:
property FileAccess FileAccessMode {
    FileAccess get ();
    void set (FileAccess value);
}

Property Value

Type: FileAccess
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).FileData Property

Grid Solutions Framework IsamDataFileBaseTFileData Property
Gets the underlying FileStream of the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FileStream FileData { get; }
Protected ReadOnly Property FileData As FileStream
    Get
member FileData : FileStream with get

function get_FileData();

protected:
property FileStream^ FileData {
    FileStream^ get ();
}

Property Value

Type: FileStream
Remarks
Thread-safety Warning: A lock must be obtained on FileData before accessing it.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).FileDataLock Property

Grid Solutions Framework IsamDataFileBaseTFileDataLock Property
Gets the locking object for the FileData stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Object FileDataLock { get; }
Protected ReadOnly Property FileDataLock As Object
    Get
member FileDataLock : Object with get

function get_FileDataLock();

protected:
property Object^ FileDataLock {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).FileName Property

Grid Solutions Framework IsamDataFileBaseTFileName Property
Gets or sets the name of the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string FileName { get; set; }
Public Overridable Property FileName As String
    Get
    Set
abstract FileName : string with get, set
override FileName : string with get, set
function get_FileName();
function set_FileName(value);
public:
virtual property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Changing the FileName when the file is open will cause the file to be re-opened.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).IsCorrupt Property

Grid Solutions Framework IsamDataFileBaseTIsCorrupt Property
Gets a boolean value that indicates whether the file data on disk is corrupt.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool IsCorrupt { get; }
Public Overridable ReadOnly Property IsCorrupt As Boolean
    Get
abstract IsCorrupt : bool with get
override IsCorrupt : bool with get
function get_IsCorrupt();

public:
virtual property bool IsCorrupt {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).IsDisposed Property

Grid Solutions Framework IsamDataFileBaseTIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public bool IsDisposed { get; }
<XmlIgnoreAttribute>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<XmlIgnoreAttribute>]
abstract IsDisposed : bool with get
[<XmlIgnoreAttribute>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[XmlIgnoreAttribute]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).IsOpen Property

Grid Solutions Framework IsamDataFileBaseTIsOpen Property
Gets a boolean value that indicates whether the file is open.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsOpen { get; }
Public ReadOnly Property IsOpen As Boolean
    Get
member IsOpen : bool with get

function get_IsOpen();

public:
property bool IsOpen {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).LoadOnOpen Property

Grid Solutions Framework IsamDataFileBaseTLoadOnOpen Property
Gets or sets a boolean value that indicates whether records are to be loaded automatically in memory when the file is opened.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool LoadOnOpen { get; set; }
Public Property LoadOnOpen As Boolean
    Get
    Set
member LoadOnOpen : bool with get, set

function get_LoadOnOpen();
function set_LoadOnOpen(value);
public:
property bool LoadOnOpen {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).LoadWaitHandle Property

Grid Solutions Framework IsamDataFileBaseTLoadWaitHandle Property
Gets wait handle for loading data.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ManualResetEventSlim LoadWaitHandle { get; }
Protected ReadOnly Property LoadWaitHandle As ManualResetEventSlim
    Get
member LoadWaitHandle : ManualResetEventSlim with get

function get_LoadWaitHandle();

protected:
property ManualResetEventSlim^ LoadWaitHandle {
    ManualResetEventSlim^ get ();
}

Property Value

Type: ManualResetEventSlim
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).MemoryUsage Property

Grid Solutions Framework IsamDataFileBaseTMemoryUsage Property
Gets the approximate memory consumption (in KB) of the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MemoryUsage { get; }
Public ReadOnly Property MemoryUsage As Long
    Get
member MemoryUsage : int64 with get

function get_MemoryUsage();

public:
property long long MemoryUsage {
    long long get ();
}

Property Value

Type: Int64
Remarks
MemoryUsage will be zero (0) unless records are loaded in memory.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Name Property

Grid Solutions Framework IsamDataFileBaseTName Property
Gets the unique identifier of the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).PersistSettings Property

Grid Solutions Framework IsamDataFileBaseTPersistSettings Property
Gets or sets a boolean value that indicates whether the file settings are to be saved to the config file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public bool PersistSettings { get; set; }
<XmlIgnoreAttribute>
Public Property PersistSettings As Boolean
    Get
    Set
[<XmlIgnoreAttribute>]
abstract PersistSettings : bool with get, set
[<XmlIgnoreAttribute>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[XmlIgnoreAttribute]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).RecordsInMemory Property

Grid Solutions Framework IsamDataFileBaseTRecordsInMemory Property
Gets the number of file records loaded in memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int RecordsInMemory { get; }
Public Overridable ReadOnly Property RecordsInMemory As Integer
    Get
abstract RecordsInMemory : int with get
override RecordsInMemory : int with get
function get_RecordsInMemory();

public:
virtual property int RecordsInMemory {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).RecordsOnDisk Property

Grid Solutions Framework IsamDataFileBaseTRecordsOnDisk Property
Gets the number of file records on the disk.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int RecordsOnDisk { get; }
Public Overridable ReadOnly Property RecordsOnDisk As Integer
    Get
abstract RecordsOnDisk : int with get
override RecordsOnDisk : int with get
function get_RecordsOnDisk();

public:
virtual property int RecordsOnDisk {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).ReloadOnModify Property

Grid Solutions Framework IsamDataFileBaseTReloadOnModify Property
Gets or sets a boolean value that indicates whether records loaded in memory are to be re-loaded when the file is modified on disk.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReloadOnModify { get; set; }
Public Property ReloadOnModify As Boolean
    Get
    Set
member ReloadOnModify : bool with get, set

function get_ReloadOnModify();
function set_ReloadOnModify(value);
public:
property bool ReloadOnModify {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
ReloadOnModify will be effective only if records have been loaded in memory either manually by calling the Load method or automatically by settings LoadOnOpen to true.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).SaveOnClose Property

Grid Solutions Framework IsamDataFileBaseTSaveOnClose Property
Gets or sets a boolean value that indicates whether records loaded in memory are to be persisted to disk when the file is closed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SaveOnClose { get; set; }
Public Property SaveOnClose As Boolean
    Get
    Set
member SaveOnClose : bool with get, set

function get_SaveOnClose();
function set_SaveOnClose(value);
public:
property bool SaveOnClose {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
SaveOnClose will be effective only if records have been loaded in memory either manually by calling the Load method or automatically by settings LoadOnOpen to true.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).SaveWaitHandle Property

Grid Solutions Framework IsamDataFileBaseTSaveWaitHandle Property
Gets wait handle for saving data.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ManualResetEventSlim SaveWaitHandle { get; }
Protected ReadOnly Property SaveWaitHandle As ManualResetEventSlim
    Get
member SaveWaitHandle : ManualResetEventSlim with get

function get_SaveWaitHandle();

protected:
property ManualResetEventSlim^ SaveWaitHandle {
    ManualResetEventSlim^ get ();
}

Property Value

Type: ManualResetEventSlim
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).SettingsCategory Property

Grid Solutions Framework IsamDataFileBaseTSettingsCategory Property
Gets or sets the category under which the file settings are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlIgnoreAttribute]
public string SettingsCategory { get; set; }
<XmlIgnoreAttribute>
Public Property SettingsCategory As String
    Get
    Set
[<XmlIgnoreAttribute>]
abstract SettingsCategory : string with get, set
[<XmlIgnoreAttribute>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[XmlIgnoreAttribute]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Status Property

Grid Solutions Framework IsamDataFileBaseTStatus Property
Gets the descriptive status of the file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T) Events

Grid Solutions Framework IsamDataFileBaseT Events

The IsamDataFileBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | DataLoaded | Occurs when data has been read from disk into memory.
Public event | DataLoading | Occurs when data is being read from disk into memory.
Public event | DataSaved | Occurs when data has been saved from memory onto disk.
Public event | DataSaving | Occurs when data is being saved from memory onto disk.
Public event | Disposed | Occurs when the class has been disposed.
Public event | FileModified | Occurs when file data on the disk is modified.
Top
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DataLoaded Event

Grid Solutions Framework IsamDataFileBaseTDataLoaded Event
Occurs when data has been read from disk into memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataLoaded
Public Event DataLoaded As EventHandler
member DataLoaded : IEvent<EventHandler,
    EventArgs>

function add_DataLoaded(value);
function remove_DataLoaded(value);
public:
 event EventHandler^ DataLoaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DataLoading Event

Grid Solutions Framework IsamDataFileBaseTDataLoading Event
Occurs when data is being read from disk into memory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataLoading
Public Event DataLoading As EventHandler
member DataLoading : IEvent<EventHandler,
    EventArgs>

function add_DataLoading(value);
function remove_DataLoading(value);
public:
 event EventHandler^ DataLoading {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DataSaved Event

Grid Solutions Framework IsamDataFileBaseTDataSaved Event
Occurs when data has been saved from memory onto disk.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataSaved
Public Event DataSaved As EventHandler
member DataSaved : IEvent<EventHandler,
    EventArgs>

function add_DataSaved(value);
function remove_DataSaved(value);
public:
 event EventHandler^ DataSaved {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).DataSaving Event

Grid Solutions Framework IsamDataFileBaseTDataSaving Event
Occurs when data is being saved from memory onto disk.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler DataSaving
Public Event DataSaving As EventHandler
member DataSaving : IEvent<EventHandler,
    EventArgs>

function add_DataSaving(value);
function remove_DataSaving(value);
public:
 event EventHandler^ DataSaving {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).Disposed Event

Grid Solutions Framework IsamDataFileBaseTDisposed Event
Occurs when the class has been disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


IsamDataFileBase(T).FileModified Event

Grid Solutions Framework IsamDataFileBaseTFileModified Event
Occurs when file data on the disk is modified.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler FileModified
Public Event FileModified As EventHandler
member FileModified : IEvent<EventHandler,
    EventArgs>

function add_FileModified(value);
function remove_FileModified(value);
public:
 event EventHandler^ FileModified {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IsamDataFileBaseT Class
GSF.IO Namespace


LogFile Class

Grid Solutions Framework LogFile Class
Represents a file that can be used for logging messages in real-time.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.IOLogFile

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(LogFile))]
public class LogFile : Component, ISupportLifecycle,
    IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings
<ToolboxBitmapAttribute(GetType(LogFile))>
Public Class LogFile
    Inherits Component
    Implements ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings
[<ToolboxBitmapAttribute(typeof(LogFile))>]
type LogFile =
    class
        inherit Component
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.IO.LogFile = function();

Type.createClass(
    'GSF.IO.LogFile',
    Component,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(LogFile))]
public ref class LogFile : public Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings

The LogFile type exposes the following members.

Constructors
 | Name | Description
Public method | LogFile | Initializes a new instance of the LogFile class.
Public method | LogFile(IContainer) | Initializes a new instance of the LogFile class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the LogFile object properties are initialized.
Public method | Close | Closes the LogFile if it is open.
Public method | Close(Boolean) | Closes the LogFile if it is open.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LogFile object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the LogFile object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | Flush | Forces queued log entries to be written to the LogFile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the LogFile object.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the LogFile object from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnFileFull | Raises the FileFull event.
Protected method | OnLogException | Raises the LogException event.
Public method | Open | Opens the LogFile for use if it is closed.
Public method | ReadLines | Reads text from the LogFile and returns a list of lines created by separating the text by the "newline" characters if and where present.
Public method | ReadText | Reads and returns the text from the LogFile.
Public method | SaveSettings | Saves settings for the LogFile object to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Write | Queues the text for writing to the LogFile.
Public method | WriteLine | Queues the text for writing to the LogFile.
Public method | WriteTimestampedLine | Queues the text for writing to the log file.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultFileFullOperation | Specifies the default value for the FileFullOperation property.
DefaultFileName | Specifies the default value for the FileName property.
DefaultFileSize | Specifies the default value for the FileSize property.
DefaultFlushTimerInterval | Specifies the default value for the FlushTimerInterval property.
DefaultLogFilesDuration | Specifies the default value for the LogFilesDuration property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
MaxFileSize | Specifies the maximum size for a LogFile.
MinFileSize | Specifies the minimum size for a LogFile.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the LogFile object is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileFullOperation | Gets or sets the type of operation to be performed when the LogFile is full.
Public property | FileName | Gets or sets the name of the LogFile, including the file extension.
Public property | FileSize | Gets or sets the size of the LogFile in MB.
Public property | FlushTimerInterval | Gets or sets the number of seconds of inactivity before the LogFile automatically flushes the file stream.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsOpen | Gets a boolean value that indicates whether the LogFile is open.
Public property | LogFilesDuration | Gets or sets the time duration, in hours, to save the LogFile .
Public property | Name | Gets the unique identifier of the LogFile object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of LogFile object are to be saved to the config file.
Public property | SettingsCategory | Gets or sets the category under which the settings of LogFile object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the LogFile object.
Public property | TextEncoding | Gets or sets the Encoding to be used to encode the messages being logged.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileFull | Occurs when the LogFile is full.
Public event | LogException | Occurs when an Exception is encountered while writing entries to the LogFile.
Top
Examples
This example shows how to use LogFile for logging messages:
Copy
using System;
using GSF.IO;

class Program
{
    static void Main(string[] args)
    {
        LogFile log = new LogFile();
        log.Initialize();                       // Initialize the log file.
        log.Open();                             // Open the log file.
        log.WriteTimestampedLine("Test entry"); // Write message to the log file.
        log.Flush();                            // Flush message to the log file.
        log.Close();                            // Close the log file.

        Console.ReadLine();
    }
}
See Also

Reference

GSF.IO Namespace


LogFile Constructor

Grid Solutions Framework LogFile Constructor
Overload List
 | Name | Description
Public method | LogFile | Initializes a new instance of the LogFile class.
Public method | LogFile(IContainer) | Initializes a new instance of the LogFile class.
Top
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile Constructor

Grid Solutions Framework LogFile Constructor
Initializes a new instance of the LogFile class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogFile()
Public Sub New
new : unit -> LogFile
GSF.IO.LogFile = function();
public:
LogFile()
See Also

Reference

LogFile Class
LogFile Overload
GSF.IO Namespace


LogFile Constructor (IContainer)

Grid Solutions Framework LogFile Constructor (IContainer)
Initializes a new instance of the LogFile class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogFile(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> LogFile
GSF.IO.LogFile = function(container);
public:
LogFile(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the LogFile.
See Also

Reference

LogFile Class
LogFile Overload
GSF.IO Namespace


LogFile Fields

Grid Solutions Framework LogFile Fields

The LogFile type exposes the following members.

Fields
Name | Description
DefaultFileFullOperation | Specifies the default value for the FileFullOperation property.
DefaultFileName | Specifies the default value for the FileName property.
DefaultFileSize | Specifies the default value for the FileSize property.
DefaultFlushTimerInterval | Specifies the default value for the FlushTimerInterval property.
DefaultLogFilesDuration | Specifies the default value for the LogFilesDuration property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
MaxFileSize | Specifies the maximum size for a LogFile.
MinFileSize | Specifies the minimum size for a LogFile.
Top
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.DefaultFileFullOperation Field

Grid Solutions Framework LogFileDefaultFileFullOperation Field
Specifies the default value for the FileFullOperation property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const LogFileFullOperation DefaultFileFullOperation
Public Const DefaultFileFullOperation As LogFileFullOperation
static val mutable DefaultFileFullOperation: LogFileFullOperation
var GSF.IO.LogFile.DefaultFileFullOperation
public:
literal LogFileFullOperation DefaultFileFullOperation

Field Value

Type: LogFileFullOperation
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.DefaultFileName Field

Grid Solutions Framework LogFileDefaultFileName Field
Specifies the default value for the FileName property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultFileName
Public Const DefaultFileName As String
static val mutable DefaultFileName: string
var GSF.IO.LogFile.DefaultFileName
public:
literal String^ DefaultFileName

Field Value

Type: String
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.DefaultFileSize Field

Grid Solutions Framework LogFileDefaultFileSize Field
Specifies the default value for the FileSize property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultFileSize
Public Const DefaultFileSize As Integer
static val mutable DefaultFileSize: int
var GSF.IO.LogFile.DefaultFileSize
public:
literal int DefaultFileSize

Field Value

Type: Int32
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.DefaultFlushTimerInterval Field

Grid Solutions Framework LogFileDefaultFlushTimerInterval Field
Specifies the default value for the FlushTimerInterval property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultFlushTimerInterval
Public Const DefaultFlushTimerInterval As Double
static val mutable DefaultFlushTimerInterval: float
var GSF.IO.LogFile.DefaultFlushTimerInterval
public:
literal double DefaultFlushTimerInterval

Field Value

Type: Double
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.DefaultLogFilesDuration Field

Grid Solutions Framework LogFileDefaultLogFilesDuration Field
Specifies the default value for the LogFilesDuration property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultLogFilesDuration
Public Const DefaultLogFilesDuration As Double
static val mutable DefaultLogFilesDuration: float
var GSF.IO.LogFile.DefaultLogFilesDuration
public:
literal double DefaultLogFilesDuration

Field Value

Type: Double
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.DefaultPersistSettings Field

Grid Solutions Framework LogFileDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.IO.LogFile.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.DefaultSettingsCategory Field

Grid Solutions Framework LogFileDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.IO.LogFile.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.MaxFileSize Field

Grid Solutions Framework LogFileMaxFileSize Field
Specifies the maximum size for a LogFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaxFileSize
Public Const MaxFileSize As Integer
static val mutable MaxFileSize: int
var GSF.IO.LogFile.MaxFileSize
public:
literal int MaxFileSize

Field Value

Type: Int32
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.MinFileSize Field

Grid Solutions Framework LogFileMinFileSize Field
Specifies the minimum size for a LogFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MinFileSize
Public Const MinFileSize As Integer
static val mutable MinFileSize: int
var GSF.IO.LogFile.MinFileSize
public:
literal int MinFileSize

Field Value

Type: Int32
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile Methods

Grid Solutions Framework LogFile Methods

The LogFile type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the LogFile object properties are initialized.
Public method | Close | Closes the LogFile if it is open.
Public method | Close(Boolean) | Closes the LogFile if it is open.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LogFile object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the LogFile object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | Flush | Forces queued log entries to be written to the LogFile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the LogFile object.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the LogFile object from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnFileFull | Raises the FileFull event.
Protected method | OnLogException | Raises the LogException event.
Public method | Open | Opens the LogFile for use if it is closed.
Public method | ReadLines | Reads text from the LogFile and returns a list of lines created by separating the text by the "newline" characters if and where present.
Public method | ReadText | Reads and returns the text from the LogFile.
Public method | SaveSettings | Saves settings for the LogFile object to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Write | Queues the text for writing to the LogFile.
Public method | WriteLine | Queues the text for writing to the LogFile.
Public method | WriteTimestampedLine | Queues the text for writing to the log file.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.BeginInit Method

Grid Solutions Framework LogFileBeginInit Method
Performs necessary operations before the LogFile object properties are initialized.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the LogFile object is consumed through the designer surface of the IDE.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Close Method

Grid Solutions Framework LogFileClose Method
Overload List
 | Name | Description
Public method | Close | Closes the LogFile if it is open.
Public method | Close(Boolean) | Closes the LogFile if it is open.
Top
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Close Method

Grid Solutions Framework LogFileClose Method
Closes the LogFile if it is open.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
Remarks
Forces queued log entries to be flushed to the LogFile.
See Also

Reference

LogFile Class
Close Overload
GSF.IO Namespace


LogFile.Close Method (Boolean)

Grid Solutions Framework LogFileClose Method (Boolean)
Closes the LogFile if it is open.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close(
    bool flushQueuedEntries
)
Public Sub Close (
    flushQueuedEntries As Boolean
)
member Close :
        flushQueuedEntries : bool -> unit

function Close(flushQueuedEntries);
public:
void Close(
    bool flushQueuedEntries
)

Parameters

flushQueuedEntries
Type: SystemBoolean
true, if queued log entries are to be written to the LogFile; otherwise, false.
See Also

Reference

LogFile Class
Close Overload
GSF.IO Namespace


LogFile.Dispose Method

Grid Solutions Framework LogFileDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the LogFile object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Dispose Method (Boolean)

Grid Solutions Framework LogFileDispose Method (Boolean)
Releases the unmanaged resources used by the LogFile object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

LogFile Class
Dispose Overload
GSF.IO Namespace


LogFile.EndInit Method

Grid Solutions Framework LogFileEndInit Method
Performs necessary operations after the LogFile object properties are initialized.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the LogFile object is consumed through the designer surface of the IDE.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Flush Method

Grid Solutions Framework LogFileFlush Method
Forces queued log entries to be written to the LogFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Flush()
Public Sub Flush
member Flush : unit -> unit

function Flush();
public:
void Flush()
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Initialize Method

Grid Solutions Framework LogFileInitialize Method
Initializes the LogFile object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the LogFile object is not consumed through the designer surface of the IDE.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.LoadSettings Method

Grid Solutions Framework LogFileLoadSettings Method
Loads saved settings for the LogFile object from the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.OnFileFull Method

Grid Solutions Framework LogFileOnFileFull Method
Raises the FileFull event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnFileFull()
Protected Overridable Sub OnFileFull
abstract OnFileFull : unit -> unit
override OnFileFull : unit -> unit
function OnFileFull();
protected:
virtual void OnFileFull()
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.OnLogException Method

Grid Solutions Framework LogFileOnLogException Method
Raises the LogException event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnLogException(
    Exception ex
)
Protected Overridable Sub OnLogException (
    ex As Exception
)
abstract OnLogException :
        ex : Exception -> unit
override OnLogException :
        ex : Exception -> unit
function OnLogException(ex);
protected:
virtual void OnLogException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to LogException event.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Open Method

Grid Solutions Framework LogFileOpen Method
Opens the LogFile for use if it is closed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open()
Public Sub Open
member Open : unit -> unit

function Open();
public:
void Open()
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.ReadLines Method

Grid Solutions Framework LogFileReadLines Method
Reads text from the LogFile and returns a list of lines created by separating the text by the "newline" characters if and where present.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<string> ReadLines()
Public Function ReadLines As List(Of String)
member ReadLines : unit -> List<string>

function ReadLines();
public:
List<String^>^ ReadLines()

Return Value

Type: List String
A list of lines from the text read from the LogFile.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.ReadText Method

Grid Solutions Framework LogFileReadText Method
Reads and returns the text from the LogFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ReadText()
Public Function ReadText As String
member ReadText : unit -> string

function ReadText();
public:
String^ ReadText()

Return Value

Type: String
The text read from the LogFile.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.SaveSettings Method

Grid Solutions Framework LogFileSaveSettings Method
Saves settings for the LogFile object to the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Write Method

Grid Solutions Framework LogFileWrite Method
Queues the text for writing to the LogFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Write(
    string text
)
Public Sub Write (
    text As String
)
member Write :
        text : string -> unit

function Write(text);
public:
void Write(
    String^ text
)

Parameters

text
Type: SystemString
The text to be written to the LogFile.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.WriteLine Method

Grid Solutions Framework LogFileWriteLine Method
Queues the text for writing to the LogFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteLine(
    string text
)
Public Sub WriteLine (
    text As String
)
member WriteLine :
        text : string -> unit

function WriteLine(text);
public:
void WriteLine(
    String^ text
)

Parameters

text
Type: SystemString
The text to be written to the log file.
Remarks
In addition to the specified text, a "newline" character will be appended to the text.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.WriteTimestampedLine Method

Grid Solutions Framework LogFileWriteTimestampedLine Method
Queues the text for writing to the log file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteTimestampedLine(
    string text
)
Public Sub WriteTimestampedLine (
    text As String
)
member WriteTimestampedLine :
        text : string -> unit

function WriteTimestampedLine(text);
public:
void WriteTimestampedLine(
    String^ text
)

Parameters

text
Type: SystemString
The text to be written to the log file.
Remarks
In addition to the specified text, a timestamp will be prepended, and a "newline" character will appended to the text.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile Properties

Grid Solutions Framework LogFile Properties

The LogFile type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the LogFile object is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | FileFullOperation | Gets or sets the type of operation to be performed when the LogFile is full.
Public property | FileName | Gets or sets the name of the LogFile, including the file extension.
Public property | FileSize | Gets or sets the size of the LogFile in MB.
Public property | FlushTimerInterval | Gets or sets the number of seconds of inactivity before the LogFile automatically flushes the file stream.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsOpen | Gets a boolean value that indicates whether the LogFile is open.
Public property | LogFilesDuration | Gets or sets the time duration, in hours, to save the LogFile .
Public property | Name | Gets the unique identifier of the LogFile object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of LogFile object are to be saved to the config file.
Public property | SettingsCategory | Gets or sets the category under which the settings of LogFile object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the LogFile object.
Public property | TextEncoding | Gets or sets the Encoding to be used to encode the messages being logged.
Top
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Enabled Property

Grid Solutions Framework LogFileEnabled Property
Gets or sets a boolean value that indicates whether the LogFile object is currently enabled.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public bool Enabled { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Property Enabled As Boolean
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
abstract Enabled : bool with get, set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.FileFullOperation Property

Grid Solutions Framework LogFileFileFullOperation Property
Gets or sets the type of operation to be performed when the LogFile is full.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(LogFileFullOperation.Truncate)]
public LogFileFullOperation FileFullOperation { get; set; }
<DefaultValueAttribute(LogFileFullOperation.Truncate)>
Public Property FileFullOperation As LogFileFullOperation
    Get
    Set
[<DefaultValueAttribute(LogFileFullOperation.Truncate)>]
member FileFullOperation : LogFileFullOperation with get, set

function get_FileFullOperation();
function set_FileFullOperation(value);
public:
[DefaultValueAttribute(LogFileFullOperation::Truncate)]
property LogFileFullOperation FileFullOperation {
    LogFileFullOperation get ();
    void set (LogFileFullOperation value);
}

Property Value

Type: LogFileFullOperation
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.FileName Property

Grid Solutions Framework LogFileFileName Property
Gets or sets the name of the LogFile, including the file extension.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("LogFile.txt")]
public string FileName { get; set; }
<DefaultValueAttribute("LogFile.txt")>
Public Property FileName As String
    Get
    Set
[<DefaultValueAttribute("LogFile.txt")>]
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
[DefaultValueAttribute(L"LogFile.txt")]
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.FileSize Property

Grid Solutions Framework LogFileFileSize Property
Gets or sets the size of the LogFile in MB.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(3)]
public int FileSize { get; set; }
<DefaultValueAttribute(3)>
Public Property FileSize As Integer
    Get
    Set
[<DefaultValueAttribute(3)>]
member FileSize : int with get, set

function get_FileSize();
function set_FileSize(value);
public:
[DefaultValueAttribute(3)]
property int FileSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned outside the MinFileSize and MaxFileSize range.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.FlushTimerInterval Property

Grid Solutions Framework LogFileFlushTimerInterval Property
Gets or sets the number of seconds of inactivity before the LogFile automatically flushes the file stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(10)]
public double FlushTimerInterval { get; set; }
<DefaultValueAttribute(10)>
Public Property FlushTimerInterval As Double
    Get
    Set
[<DefaultValueAttribute(10)>]
member FlushTimerInterval : float with get, set

function get_FlushTimerInterval();
function set_FlushTimerInterval(value);
public:
[DefaultValueAttribute(10)]
property double FlushTimerInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.IsDisposed Property

Grid Solutions Framework LogFileIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool IsDisposed { get; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract IsDisposed : bool with get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.IsOpen Property

Grid Solutions Framework LogFileIsOpen Property
Gets a boolean value that indicates whether the LogFile is open.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public bool IsOpen { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property IsOpen As Boolean
    Get
[<BrowsableAttribute(false)>]
member IsOpen : bool with get

function get_IsOpen();

public:
[BrowsableAttribute(false)]
property bool IsOpen {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.LogFilesDuration Property

Grid Solutions Framework LogFileLogFilesDuration Property
Gets or sets the time duration, in hours, to save the LogFile .

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(0)]
public double LogFilesDuration { get; set; }
<DefaultValueAttribute(0)>
Public Property LogFilesDuration As Double
    Get
    Set
[<DefaultValueAttribute(0)>]
member LogFilesDuration : float with get, set

function get_LogFilesDuration();
function set_LogFilesDuration(value);
public:
[DefaultValueAttribute(0)]
property double LogFilesDuration {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Name Property

Grid Solutions Framework LogFileName Property
Gets the unique identifier of the LogFile object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.PersistSettings Property

Grid Solutions Framework LogFilePersistSettings Property
Gets or sets a boolean value that indicates whether the settings of LogFile object are to be saved to the config file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.SettingsCategory Property

Grid Solutions Framework LogFileSettingsCategory Property
Gets or sets the category under which the settings of LogFile object are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("LogFile")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("LogFile")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("LogFile")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("LogFile")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"LogFile")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.Status Property

Grid Solutions Framework LogFileStatus Property
Gets the descriptive status of the LogFile object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Status { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.TextEncoding Property

Grid Solutions Framework LogFileTextEncoding Property
Gets or sets the Encoding to be used to encode the messages being logged.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
public virtual Encoding TextEncoding { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
Public Overridable Property TextEncoding As Encoding
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
abstract TextEncoding : Encoding with get, set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
override TextEncoding : Encoding with get, set
function get_TextEncoding();
function set_TextEncoding(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
virtual property Encoding^ TextEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile Events

Grid Solutions Framework LogFile Events

The LogFile type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileFull | Occurs when the LogFile is full.
Public event | LogException | Occurs when an Exception is encountered while writing entries to the LogFile.
Top
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.FileFull Event

Grid Solutions Framework LogFileFileFull Event
Occurs when the LogFile is full.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler FileFull
Public Event FileFull As EventHandler
member FileFull : IEvent<EventHandler,
    EventArgs>

function add_FileFull(value);
function remove_FileFull(value);
public:
 event EventHandler^ FileFull {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFile.LogException Event

Grid Solutions Framework LogFileLogException Event
Occurs when an Exception is encountered while writing entries to the LogFile.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> LogException
Public Event LogException As EventHandler(Of EventArgs(Of Exception))
member LogException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_LogException(value);
function remove_LogException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ LogException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception encountered during writing of log entries.
See Also

Reference

LogFile Class
GSF.IO Namespace


LogFileFullOperation Enumeration

Grid Solutions Framework LogFileFullOperation Enumeration
Specifies the operation to be performed on the LogFile when it is full.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum LogFileFullOperation
Public Enumeration LogFileFullOperation
type LogFileFullOperation
GSF.IO.LogFileFullOperation = function();
GSF.IO.LogFileFullOperation.createEnum('GSF.IO.LogFileFullOperation', false);
public enum class LogFileFullOperation
Members
Member name | Value | Description
Truncate | 0 | Truncates the existing entries in the LogFile to make space for new entries.
Rollover | 1 | Rolls over to a new LogFile, and keeps the full LogFile for reference.
See Also

Reference

GSF.IO Namespace


MultipleDestinationExporter Class

Grid Solutions Framework MultipleDestinationExporter Class
Handles the exporting of a file to multiple destinations that are defined in the config file.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.IOMultipleDestinationExporter

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(MultipleDestinationExporter))]
public class MultipleDestinationExporter : Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings
<ToolboxBitmapAttribute(GetType(MultipleDestinationExporter))>
Public Class MultipleDestinationExporter
    Inherits Component
    Implements ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings
[<ToolboxBitmapAttribute(typeof(MultipleDestinationExporter))>]
type MultipleDestinationExporter =
    class
        inherit Component
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.IO.MultipleDestinationExporter = function();

Type.createClass(
    'GSF.IO.MultipleDestinationExporter',
    Component,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(MultipleDestinationExporter))]
public ref class MultipleDestinationExporter : public Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings

The MultipleDestinationExporter type exposes the following members.

Constructors
 | Name | Description
Public method | MultipleDestinationExporter | Initializes a new instance of the MultipleDestinationExporter class.
Public method | MultipleDestinationExporter(IContainer) | Initializes a new instance of the MultipleDestinationExporter class.
Public method | MultipleDestinationExporter(String, Int32) | Initializes a new instance of the MultipleDestinationExporter class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the MultipleDestinationExporter object properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MultipleDestinationExporter object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the MultipleDestinationExporter object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportData(Byte) | Start multiple file export.
Public method | ExportData(String) | Start multiple file export.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.
Public method | Initialize(IEnumerableExportDestination) | Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the MultipleDestinationExporter object from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnInitialized | Raises the Initialized event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage | Raises the StatusMessage event.
Public method | SaveSettings | Saves settings for the MultipleDestinationExporter object to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultExportTimeout | Specifies the default value for the ExportTimeout property.
DefaultMaximumRetryAttempts | Specifies the default value for the MaximumRetryAttempts property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultRetryDelayInterval | Specifies the default value for the RetryDelayInterval property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the MultipleDestinationExporter object is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExportDestinations | Gets a list of currently defined ExportDestination.
Public property | ExportTimeout | Gets or sets the total allowed time in milliseconds for each export to execute.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MaximumRetryAttempts | Gets or sets the maximum number of retries that will be attempted during an export if the export fails.
Public property | Name | Gets the unique identifier of the MultipleDestinationExporter object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of MultipleDestinationExporter object are to be saved to the config file.
Public property | RetryDelayInterval | Gets or sets the interval to wait, in milliseconds, before retrying an export if the export fails.
Public property | SettingsCategory | Gets or sets the category under which the settings of MultipleDestinationExporter object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the MultipleDestinationExporter object.
Public property | TextEncoding | Gets or sets the Encoding to be used to encode text data being exported.
Public property | TotalExports | Gets the total number exports performed successfully.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Initialized | Occurs when the MultipleDestinationExporter object has been initialized.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Occurs when status information for the MultipleDestinationExporter object is being reported.
Top
Remarks
This class is useful for updating the same file on multiple servers (e.g., load balanced web server).
Examples
This example shows the use MultipleDestinationExporter for exporting data to multiple locations:
Copy
using System;
using GSF.IO;

class Program
{
    static MultipleDestinationExporter s_exporter;

    static void Main(string[] args)
    {
        s_exporter = new MultipleDestinationExporter();
        s_exporter.Initialized += s_exporter_Initialized;
        ExportDestination[] defaultDestinations = new ExportDestination[]
        {
            new ExportDestination(@"\\server1\share\exportFile.txt", false, "domain", "user1", "password1"),
            new ExportDestination(@"\\server2\share\exportFile.txt", false, "domain", "user2", "password2")
        };
        // Initialize with the destinations where data is to be exported.
        s_exporter.Initialize(defaultDestinations);

        Console.ReadLine();
    }

    static void s_exporter_Initialized(object sender, EventArgs e)
    {
        // Export data to all defined locations after initialization.
        s_exporter.ExportData("TEST DATA");
    }
}
This example shows the config file entry that can be used to specify the ExportDestination used by the MultipleDestinationExporter when exporting data:
Copy
<exportDestinations>
  <add name="ExportTimeout" value="-1" description="Total allowed time for all exports to execute in milliseconds."
    encrypted="false" />
  <add name="ExportCount" value="2" description="Total number of export files to produce."
    encrypted="false" />
  <add name="ExportDestination1" value="\\server1\share\" description="Root path for export destination. Use UNC path (\\server\share) with no trailing slash for network shares."
    encrypted="false" />
  <add name="ExportDestination1.ConnectToShare" value="True" description="Set to True to attempt authentication to network share."
    encrypted="false" />
  <add name="ExportDestination1.Domain" value="domain" description="Domain used for authentication to network share (computer name for local accounts)."
    encrypted="false" />
  <add name="ExportDestination1.UserName" value="user1" description="User name used for authentication to network share."
    encrypted="false" />
  <add name="ExportDestination1.Password" value="l2qlAwAPihJjoThH+G53BUxzYsIkTE2yNBHLtd1WA3hysDhwDB82ouJb9n35QtG8"
    description="Encrypted password used for authentication to network share."
    encrypted="true" />
  <add name="ExportDestination1.FileName" value="exportFile.txt" description="Path and file name of data export (do not include drive letter or UNC share). Prefix with slash when using UNC paths (\path\filename.txt)."
    encrypted="false" />
  <add name="ExportDestination2" value="\\server2\share\" description="Root path for export destination. Use UNC path (\\server\share) with no trailing slash for network shares."
    encrypted="false" />
  <add name="ExportDestination2.ConnectToShare" value="True" description="Set to True to attempt authentication to network share."
    encrypted="false" />
  <add name="ExportDestination2.Domain" value="domain" description="Domain used for authentication to network share (computer name for local accounts)."
    encrypted="false" />
  <add name="ExportDestination2.UserName" value="user2" description="User name used for authentication to network share."
    encrypted="false" />
  <add name="ExportDestination2.Password" value="l2qlAwAPihJjoThH+G53BYT6BXHQr13D6Asdibl0rDmlrgRXvJmCwcP8uvkFRHr9"
    description="Encrypted password used for authentication to network share."
    encrypted="true" />
  <add name="ExportDestination2.FileName" value="exportFile.txt" description="Path and file name of data export (do not include drive letter or UNC share). Prefix with slash when using UNC paths (\path\filename.txt)."
    encrypted="false" />
</exportDestinations>
See Also

Reference

GSF.IO Namespace
GSF.IOExportDestination


MultipleDestinationExporter Constructor

Grid Solutions Framework MultipleDestinationExporter Constructor
Overload List
 | Name | Description
Public method | MultipleDestinationExporter | Initializes a new instance of the MultipleDestinationExporter class.
Public method | MultipleDestinationExporter(IContainer) | Initializes a new instance of the MultipleDestinationExporter class.
Public method | MultipleDestinationExporter(String, Int32) | Initializes a new instance of the MultipleDestinationExporter class.
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter Constructor

Grid Solutions Framework MultipleDestinationExporter Constructor
Initializes a new instance of the MultipleDestinationExporter class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MultipleDestinationExporter()
Public Sub New
new : unit -> MultipleDestinationExporter
GSF.IO.MultipleDestinationExporter = function();
public:
MultipleDestinationExporter()
See Also

Reference

MultipleDestinationExporter Class
MultipleDestinationExporter Overload
GSF.IO Namespace


MultipleDestinationExporter Constructor (IContainer)

Grid Solutions Framework MultipleDestinationExporter Constructor (IContainer)
Initializes a new instance of the MultipleDestinationExporter class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MultipleDestinationExporter(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> MultipleDestinationExporter
GSF.IO.MultipleDestinationExporter = function(container);
public:
MultipleDestinationExporter(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the MultipleDestinationExporter.
See Also

Reference

MultipleDestinationExporter Class
MultipleDestinationExporter Overload
GSF.IO Namespace


MultipleDestinationExporter Constructor (String, Int32)

Grid Solutions Framework MultipleDestinationExporter Constructor (String, Int32)
Initializes a new instance of the MultipleDestinationExporter class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MultipleDestinationExporter(
    string settingsCategory,
    int exportTimeout
)
Public Sub New (
    settingsCategory As String,
    exportTimeout As Integer
)
new :
        settingsCategory : string *
        exportTimeout : int -> MultipleDestinationExporter
GSF.IO.MultipleDestinationExporter = function(settingsCategory, exportTimeout);
public:
MultipleDestinationExporter(
    String^ settingsCategory,
    int exportTimeout
)

Parameters

settingsCategory
Type: SystemString
The config file settings category under which the export destinations are defined.
exportTimeout
Type: SystemInt32
The total allowed time in milliseconds for each export to execute.
See Also

Reference

MultipleDestinationExporter Class
MultipleDestinationExporter Overload
GSF.IO Namespace


MultipleDestinationExporter Fields

Grid Solutions Framework MultipleDestinationExporter Fields

The MultipleDestinationExporter type exposes the following members.

Fields
Name | Description
DefaultExportTimeout | Specifies the default value for the ExportTimeout property.
DefaultMaximumRetryAttempts | Specifies the default value for the MaximumRetryAttempts property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultRetryDelayInterval | Specifies the default value for the RetryDelayInterval property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.DefaultExportTimeout Field

Grid Solutions Framework MultipleDestinationExporterDefaultExportTimeout Field
Specifies the default value for the ExportTimeout property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultExportTimeout
Public Const DefaultExportTimeout As Integer
static val mutable DefaultExportTimeout: int
var GSF.IO.MultipleDestinationExporter.DefaultExportTimeout
public:
literal int DefaultExportTimeout

Field Value

Type: Int32
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.DefaultMaximumRetryAttempts Field

Grid Solutions Framework MultipleDestinationExporterDefaultMaximumRetryAttempts Field
Specifies the default value for the MaximumRetryAttempts property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaximumRetryAttempts
Public Const DefaultMaximumRetryAttempts As Integer
static val mutable DefaultMaximumRetryAttempts: int
var GSF.IO.MultipleDestinationExporter.DefaultMaximumRetryAttempts
public:
literal int DefaultMaximumRetryAttempts

Field Value

Type: Int32
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.DefaultPersistSettings Field

Grid Solutions Framework MultipleDestinationExporterDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.IO.MultipleDestinationExporter.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.DefaultRetryDelayInterval Field

Grid Solutions Framework MultipleDestinationExporterDefaultRetryDelayInterval Field
Specifies the default value for the RetryDelayInterval property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultRetryDelayInterval
Public Const DefaultRetryDelayInterval As Integer
static val mutable DefaultRetryDelayInterval: int
var GSF.IO.MultipleDestinationExporter.DefaultRetryDelayInterval
public:
literal int DefaultRetryDelayInterval

Field Value

Type: Int32
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.DefaultSettingsCategory Field

Grid Solutions Framework MultipleDestinationExporterDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.IO.MultipleDestinationExporter.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter Methods

Grid Solutions Framework MultipleDestinationExporter Methods

The MultipleDestinationExporter type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the MultipleDestinationExporter object properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MultipleDestinationExporter object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the MultipleDestinationExporter object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExportData(Byte) | Start multiple file export.
Public method | ExportData(String) | Start multiple file export.
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.
Public method | Initialize(IEnumerableExportDestination) | Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the MultipleDestinationExporter object from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnInitialized | Raises the Initialized event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage | Raises the StatusMessage event.
Public method | SaveSettings | Saves settings for the MultipleDestinationExporter object to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.BeginInit Method

Grid Solutions Framework MultipleDestinationExporterBeginInit Method
Performs necessary operations before the MultipleDestinationExporter object properties are initialized.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the MultipleDestinationExporter object is consumed through the designer surface of the IDE.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.Dispose Method

Grid Solutions Framework MultipleDestinationExporterDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the MultipleDestinationExporter object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.Dispose Method (Boolean)

Grid Solutions Framework MultipleDestinationExporterDispose Method (Boolean)
Releases the unmanaged resources used by the MultipleDestinationExporter object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

MultipleDestinationExporter Class
Dispose Overload
GSF.IO Namespace


MultipleDestinationExporter.EndInit Method

Grid Solutions Framework MultipleDestinationExporterEndInit Method
Performs necessary operations after the MultipleDestinationExporter object properties are initialized.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the MultipleDestinationExporter object is consumed through the designer surface of the IDE.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.ExportData Method

Grid Solutions Framework MultipleDestinationExporterExportData Method
Overload List
 | Name | Description
Public method | ExportData(Byte) | Start multiple file export.
Public method | ExportData(String) | Start multiple file export.
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.ExportData Method (Byte[])

Grid Solutions Framework MultipleDestinationExporterExportData Method (Byte)
Start multiple file export.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ExportData(
    byte[] fileData
)
Public Sub ExportData (
    fileData As Byte()
)
member ExportData :
        fileData : byte[] -> unit

function ExportData(fileData);
public:
void ExportData(
    array<unsigned char>^ fileData
)

Parameters

fileData
Type: SystemByte
Binary data to export to each destination.
Remarks
This is assumed to be the full content of the file to export. This class does not queue data since the export is not intended to append to an existing file but rather replace an existing one.
See Also

Reference

MultipleDestinationExporter Class
ExportData Overload
GSF.IO Namespace


MultipleDestinationExporter.ExportData Method (String)

Grid Solutions Framework MultipleDestinationExporterExportData Method (String)
Start multiple file export.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ExportData(
    string fileData
)
Public Sub ExportData (
    fileData As String
)
member ExportData :
        fileData : string -> unit

function ExportData(fileData);
public:
void ExportData(
    String^ fileData
)

Parameters

fileData
Type: SystemString
Text based data to export to each destination.
Remarks
This is assumed to be the full content of the file to export. This class does not queue data since the export is not intended to append to an existing file but rather replace an existing one.
See Also

Reference

MultipleDestinationExporter Class
ExportData Overload
GSF.IO Namespace


MultipleDestinationExporter.Initialize Method

Grid Solutions Framework MultipleDestinationExporterInitialize Method
Overload List
 | Name | Description
Public method | Initialize | Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.
Public method | Initialize(IEnumerableExportDestination) | Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.Initialize Method

Grid Solutions Framework MultipleDestinationExporterInitialize Method
Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
If not being used as a component (i.e., user creates their own instance of this class), this method must be called in order to initialize exports. Event if used as a component this method can be called at anytime to reinitialize the exports with new configuration information.
See Also

Reference

MultipleDestinationExporter Class
Initialize Overload
GSF.IO Namespace


MultipleDestinationExporter.Initialize Method (IEnumerable(ExportDestination))

Grid Solutions Framework MultipleDestinationExporterInitialize Method (IEnumerableExportDestination)
Initializes (or reinitializes) MultipleDestinationExporter from configuration settings.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize(
    IEnumerable<ExportDestination> defaultDestinations
)
Public Sub Initialize (
    defaultDestinations As IEnumerable(Of ExportDestination)
)
member Initialize :
        defaultDestinations : IEnumerable<ExportDestination> -> unit

function Initialize(defaultDestinations);
public:
void Initialize(
    IEnumerable<ExportDestination^>^ defaultDestinations
)

Parameters

defaultDestinations
Type: System.Collections.GenericIEnumerable ExportDestination
Provides a default set of export destinations if none exist in configuration settings.
Remarks
If not being used as a component (i.e., user creates their own instance of this class), this method must be called in order to initialize exports. Even if used as a component this method can be called at anytime to reinitialize the exports with new configuration information.
See Also

Reference

MultipleDestinationExporter Class
Initialize Overload
GSF.IO Namespace


MultipleDestinationExporter.LoadSettings Method

Grid Solutions Framework MultipleDestinationExporterLoadSettings Method
Loads saved settings for the MultipleDestinationExporter object from the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.OnInitialized Method

Grid Solutions Framework MultipleDestinationExporterOnInitialized Method
Raises the Initialized event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnInitialized()
Protected Overridable Sub OnInitialized
abstract OnInitialized : unit -> unit
override OnInitialized : unit -> unit
function OnInitialized();
protected:
virtual void OnInitialized()
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.OnProcessException Method

Grid Solutions Framework MultipleDestinationExporterOnProcessException Method
Raises ProcessException event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.OnStatusMessage Method

Grid Solutions Framework MultipleDestinationExporterOnStatusMessage Method
Raises the StatusMessage event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string status,
    params Object[] args
)
Protected Overridable Sub OnStatusMessage (
    status As String,
    ParamArray args As Object()
)
abstract OnStatusMessage :
        status : string *
        args : Object[] -> unit
override OnStatusMessage :
        status : string *
        args : Object[] -> unit
function OnStatusMessage(status, ... args);
protected:
virtual void OnStatusMessage(
    String^ status,
    ... array<Object^>^ args
)

Parameters

status
Type: SystemString
Status message to report.
args
Type: SystemObject
Format(String, Object) parameters used for status message.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.SaveSettings Method

Grid Solutions Framework MultipleDestinationExporterSaveSettings Method
Saves settings for the MultipleDestinationExporter object to the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter Properties

Grid Solutions Framework MultipleDestinationExporter Properties

The MultipleDestinationExporter type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the MultipleDestinationExporter object is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExportDestinations | Gets a list of currently defined ExportDestination.
Public property | ExportTimeout | Gets or sets the total allowed time in milliseconds for each export to execute.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MaximumRetryAttempts | Gets or sets the maximum number of retries that will be attempted during an export if the export fails.
Public property | Name | Gets the unique identifier of the MultipleDestinationExporter object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of MultipleDestinationExporter object are to be saved to the config file.
Public property | RetryDelayInterval | Gets or sets the interval to wait, in milliseconds, before retrying an export if the export fails.
Public property | SettingsCategory | Gets or sets the category under which the settings of MultipleDestinationExporter object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the MultipleDestinationExporter object.
Public property | TextEncoding | Gets or sets the Encoding to be used to encode text data being exported.
Public property | TotalExports | Gets the total number exports performed successfully.
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.Enabled Property

Grid Solutions Framework MultipleDestinationExporterEnabled Property
Gets or sets a boolean value that indicates whether the MultipleDestinationExporter object is currently enabled.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool Enabled { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Enabled As Boolean
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract Enabled : bool with get, set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.ExportDestinations Property

Grid Solutions Framework MultipleDestinationExporterExportDestinations Property
Gets a list of currently defined ExportDestination.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ReadOnlyCollection<ExportDestination> ExportDestinations { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property ExportDestinations As ReadOnlyCollection(Of ExportDestination)
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>]
member ExportDestinations : ReadOnlyCollection<ExportDestination> with get

function get_ExportDestinations();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
property ReadOnlyCollection<ExportDestination^>^ ExportDestinations {
    ReadOnlyCollection<ExportDestination^>^ get ();
}

Property Value

Type: ReadOnlyCollection ExportDestination
Remarks
Use the Initialize(IEnumerableExportDestination) method to change the export destination collection.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.ExportTimeout Property

Grid Solutions Framework MultipleDestinationExporterExportTimeout Property
Gets or sets the total allowed time in milliseconds for each export to execute.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(-1)]
public int ExportTimeout { get; set; }
<DefaultValueAttribute(-1)>
Public Property ExportTimeout As Integer
    Get
    Set
[<DefaultValueAttribute(-1)>]
member ExportTimeout : int with get, set

function get_ExportTimeout();
function set_ExportTimeout(value);
public:
[DefaultValueAttribute(-1)]
property int ExportTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Set to Timeout.Infinite (-1) for no timeout.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.IsDisposed Property

Grid Solutions Framework MultipleDestinationExporterIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool IsDisposed { get; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract IsDisposed : bool with get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.MaximumRetryAttempts Property

Grid Solutions Framework MultipleDestinationExporterMaximumRetryAttempts Property
Gets or sets the maximum number of retries that will be attempted during an export if the export fails.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(4)]
public int MaximumRetryAttempts { get; set; }
<DefaultValueAttribute(4)>
Public Property MaximumRetryAttempts As Integer
    Get
    Set
[<DefaultValueAttribute(4)>]
member MaximumRetryAttempts : int with get, set

function get_MaximumRetryAttempts();
function set_MaximumRetryAttempts(value);
public:
[DefaultValueAttribute(4)]
property int MaximumRetryAttempts {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Total file export attempts = 1 + MaximumRetryAttempts. Set to zero to only attempt export once.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.Name Property

Grid Solutions Framework MultipleDestinationExporterName Property
Gets the unique identifier of the MultipleDestinationExporter object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.PersistSettings Property

Grid Solutions Framework MultipleDestinationExporterPersistSettings Property
Gets or sets a boolean value that indicates whether the settings of MultipleDestinationExporter object are to be saved to the config file.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(true)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(true)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(true)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.RetryDelayInterval Property

Grid Solutions Framework MultipleDestinationExporterRetryDelayInterval Property
Gets or sets the interval to wait, in milliseconds, before retrying an export if the export fails.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(1000)]
public int RetryDelayInterval { get; set; }
<DefaultValueAttribute(1000)>
Public Property RetryDelayInterval As Integer
    Get
    Set
[<DefaultValueAttribute(1000)>]
member RetryDelayInterval : int with get, set

function get_RetryDelayInterval();
function set_RetryDelayInterval(value);
public:
[DefaultValueAttribute(1000)]
property int RetryDelayInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.SettingsCategory Property

Grid Solutions Framework MultipleDestinationExporterSettingsCategory Property
Gets or sets the category under which the settings of MultipleDestinationExporter object are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("ExportDestinations")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("ExportDestinations")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("ExportDestinations")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("ExportDestinations")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"ExportDestinations")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.Status Property

Grid Solutions Framework MultipleDestinationExporterStatus Property
Gets the descriptive status of the MultipleDestinationExporter object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Status { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.TextEncoding Property

Grid Solutions Framework MultipleDestinationExporterTextEncoding Property
Gets or sets the Encoding to be used to encode text data being exported.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public virtual Encoding TextEncoding { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Overridable Property TextEncoding As Encoding
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract TextEncoding : Encoding with get, set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override TextEncoding : Encoding with get, set
function get_TextEncoding();
function set_TextEncoding(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property Encoding^ TextEncoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.TotalExports Property

Grid Solutions Framework MultipleDestinationExporterTotalExports Property
Gets the total number exports performed successfully.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public long TotalExports { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property TotalExports As Long
    Get
[<BrowsableAttribute(false)>]
member TotalExports : int64 with get

function get_TotalExports();

public:
[BrowsableAttribute(false)]
property long long TotalExports {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter Events

Grid Solutions Framework MultipleDestinationExporter Events

The MultipleDestinationExporter type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | Initialized | Occurs when the MultipleDestinationExporter object has been initialized.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Occurs when status information for the MultipleDestinationExporter object is being reported.
Top
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.Initialized Event

Grid Solutions Framework MultipleDestinationExporterInitialized Event
Occurs when the MultipleDestinationExporter object has been initialized.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Initialized
Public Event Initialized As EventHandler
member Initialized : IEvent<EventHandler,
    EventArgs>

function add_Initialized(value);
function remove_Initialized(value);
public:
 event EventHandler^ Initialized {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.ProcessException Event

Grid Solutions Framework MultipleDestinationExporterProcessException Event
Event is raised when there is an exception encountered while processing.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the exception that was thrown.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


MultipleDestinationExporter.StatusMessage Event

Grid Solutions Framework MultipleDestinationExporterStatusMessage Event
Occurs when status information for the MultipleDestinationExporter object is being reported.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
member StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
 event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is the status message being reported by the MultipleDestinationExporter.
See Also

Reference

MultipleDestinationExporter Class
GSF.IO Namespace


Outage Class

Grid Solutions Framework Outage Class
Represents an outage as a start time and an end time.
Inheritance Hierarchy
SystemObject
GSFRange DateTime
GSF.IOOutage

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Outage : Range<DateTime>
Public Class Outage
    Inherits Range(Of DateTime)
type Outage =
    class
        inherit Range<DateTime>
    end
GSF.IO.Outage = function();

Type.createClass(
    'GSF.IO.Outage',
    GSF.Range`1);
public ref class Outage : public Range<DateTime>

The Outage type exposes the following members.

Constructors
 | Name | Description
Public method | Outage(RangeDateTime) | Creates a new Outage with the same start and end time as the given range.
Public method | Outage(DateTime, DateTime) | Creates a new Outage with the specified start and end time.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge(RangeT) | Merges two ranges into one range that fully encompasses both ranges. (Inherited from RangeT.)
Public method | Merge(RangeT, IComparerT) | Merges two ranges into one range that fully encompasses both ranges. (Inherited from RangeT.)
Public method | Merge(RangeT, ComparisonT) | Merges two ranges into one range that fully encompasses both ranges. (Inherited from RangeT.)
 | MergeOverlapping | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of outages.
Public method | Overlaps(RangeT) | Determines whether the range overlaps with the given range. (Inherited from RangeT.)
Public method | Overlaps(RangeT, IComparerT) | Determines whether the range overlaps with the given range. (Inherited from RangeT.)
Public method | Overlaps(RangeT, ComparisonT) | Determines whether the range overlaps with the given range. (Inherited from RangeT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | End | Gets the end value of the range. (Inherited from RangeT.)
Public property | Start | Gets the start value of the range. (Inherited from RangeT.)
Top
See Also

Reference

GSF.IO Namespace


Outage Constructor

Grid Solutions Framework Outage Constructor
Overload List
 | Name | Description
Public method | Outage(RangeDateTime) | Creates a new Outage with the same start and end time as the given range.
Public method | Outage(DateTime, DateTime) | Creates a new Outage with the specified start and end time.
Top
See Also

Reference

Outage Class
GSF.IO Namespace


Outage Constructor (Range(DateTime))

Grid Solutions Framework Outage Constructor (RangeDateTime)
Creates a new Outage with the same start and end time as the given range.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Outage(
    Range<DateTime> range
)
Public Sub New (
    range As Range(Of DateTime)
)
new :
        range : Range<DateTime> -> Outage
GSF.IO.Outage = function(range);
public:
Outage(
    Range<DateTime>^ range
)

Parameters

range
Type: GSFRange DateTime

[Missing <param name="range"/> documentation for "M:GSF.IO.Outage.#ctor(GSF.Range{System.DateTime})"]

See Also

Reference

Outage Class
Outage Overload
GSF.IO Namespace


Outage Constructor (DateTime, DateTime)

Grid Solutions Framework Outage Constructor (DateTime, DateTime)
Creates a new Outage with the specified start and end time.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Outage(
    DateTime startTime,
    DateTime endTime
)
Public Sub New (
    startTime As DateTime,
    endTime As DateTime
)
new :
        startTime : DateTime *
        endTime : DateTime -> Outage
GSF.IO.Outage = function(startTime, endTime);
public:
Outage(
    DateTime startTime,
    DateTime endTime
)

Parameters

startTime
Type: SystemDateTime
Start time for outage.
endTime
Type: SystemDateTime
End time for outage.
See Also

Reference

Outage Class
Outage Overload
GSF.IO Namespace


Outage Methods

Grid Solutions Framework Outage Methods

The Outage type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Merge(RangeT) | Merges two ranges into one range that fully encompasses both ranges. (Inherited from RangeT.)
Public method | Merge(RangeT, IComparerT) | Merges two ranges into one range that fully encompasses both ranges. (Inherited from RangeT.)
Public method | Merge(RangeT, ComparisonT) | Merges two ranges into one range that fully encompasses both ranges. (Inherited from RangeT.)
 | MergeOverlapping | Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of outages.
Public method | Overlaps(RangeT) | Determines whether the range overlaps with the given range. (Inherited from RangeT.)
Public method | Overlaps(RangeT, IComparerT) | Determines whether the range overlaps with the given range. (Inherited from RangeT.)
Public method | Overlaps(RangeT, ComparisonT) | Determines whether the range overlaps with the given range. (Inherited from RangeT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Outage Class
GSF.IO Namespace


Outage.MergeOverlapping Method

Grid Solutions Framework OutageMergeOverlapping Method
Merges all consecutive groups of overlapping ranges in a collection and returns the resulting collection of outages.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IEnumerable<Outage> MergeOverlapping(
    IEnumerable<Outage> outages
)
Public Shared Function MergeOverlapping (
    outages As IEnumerable(Of Outage)
) As IEnumerable(Of Outage)
static member MergeOverlapping :
        outages : IEnumerable<Outage> -> IEnumerable<Outage>

GSF.IO.Outage.MergeOverlapping = function(outages);
public:
static IEnumerable<Outage^>^ MergeOverlapping(
    IEnumerable<Outage^>^ outages
)

Parameters

outages
Type: System.Collections.GenericIEnumerable Outage
The collection of outages.

Return Value

Type: IEnumerable Outage
The collection of merged outages.
Remarks
This method does not preserve the order of the source collection.
See Also

Reference

Outage Class
GSF.IO Namespace


Outage Properties

Grid Solutions Framework Outage Properties

The Outage type exposes the following members.

Properties
 | Name | Description
Public property | End | Gets the end value of the range. (Inherited from RangeT.)
Public property | Start | Gets the start value of the range. (Inherited from RangeT.)
Top
See Also

Reference

Outage Class
GSF.IO Namespace


OutageLog Class

Grid Solutions Framework OutageLog Class
Represents a persisted log of outages as a list of start and stop times.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection Outage
System.Collections.ObjectModelObservableCollection Outage
GSF.IOOutageLog

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class OutageLog : ObservableCollection<Outage>,
    ISupportLifecycle, IDisposable, IProvideStatus
Public Class OutageLog
    Inherits ObservableCollection(Of Outage)
    Implements ISupportLifecycle, IDisposable, IProvideStatus
type OutageLog =
    class
        inherit ObservableCollection<Outage>
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.IO.OutageLog = function();

Type.createClass(
    'GSF.IO.OutageLog',
    ObservableCollection`1,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class OutageLog : public ObservableCollection<Outage^>,
    ISupportLifecycle, IDisposable, IProvideStatus

The OutageLog type exposes the following members.

Constructors
 | Name | Description
Public method | OutageLog | Creates a new OutageLog.
Top
Methods
 | Name | Description
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection Outage .)
Public method | Add(Ticks, Ticks) | Adds an outage to the OutageLog.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection Outage .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection Outage .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Outage .)
Protected method | ClearItems | Removes all elements from the OutageLog. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection Outage .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Outage .)
Public method | Dispose | Releases all the resources used by the OutageLog object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutageLog object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the OutageLog object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | Flush | Requests that outage log be flushed to disk.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Outage .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Outage .)
Public method | Initialize | Initialize the outage log.
Protected method | InitiateRead | Initiates a log read.
Protected method | InitiateWrite | Initiates a log write.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Outage .)
Protected method | InsertItem | Inserts an element into the OutageLog at the specified index. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection Outage .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the OutageLog. (Overrides ObservableCollectionTMoveItem(Int32, Int32).)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection Outage .)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection Outage .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Outage .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Outage .)
Protected method | RemoveItem | Removes the element at the specified index of the OutageLog. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DateTimeFormat | Date-time format used by OutageLog.
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Outage .)
Public property | Enabled | Gets or sets a boolean value that indicates whether the run-time log is enabled.
Public property | FileName | Gets or sets the file name for the outage log; file name can be set with a relative path.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection Outage .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Outage .)
Protected property | ReadWriteLock | Gets locking object for OutageLog.
Public property | Status | Gets the current status details about OutageLog.
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection Outage .)
Public event | Disposed | Raised after the outage log has been properly disposed.
Public event | ProcessException | Event is raised when there is an exception encountered while processing outage log.
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection Outage .)
Top
Remarks

This class serializes a list of outages (e.g., a connection outage or data loss) where each outage consists of a start and end time. The outages are persisted in a log file so that the log can be operated on even through host application restarts until the outages are processed.

No members in the OutageLog are guaranteed to be thread safe. Make sure any calls are synchronized when simultaneously accessed from different threads.

See Also

Reference

GSF.IO Namespace


OutageLog Constructor

Grid Solutions Framework OutageLog Constructor
Creates a new OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OutageLog()
Public Sub New
new : unit -> OutageLog
GSF.IO.OutageLog = function();
public:
OutageLog()
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog Fields

Grid Solutions Framework OutageLog Fields

The OutageLog type exposes the following members.

Fields
Name | Description
DateTimeFormat | Date-time format used by OutageLog.
Top
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.DateTimeFormat Field

Grid Solutions Framework OutageLogDateTimeFormat Field
Date-time format used by OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DateTimeFormat
Public Const DateTimeFormat As String
static val mutable DateTimeFormat: string
var GSF.IO.OutageLog.DateTimeFormat
public:
literal String^ DateTimeFormat

Field Value

Type: String
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog Methods

Grid Solutions Framework OutageLog Methods

The OutageLog type exposes the following members.

Methods
 | Name | Description
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection Outage .)
Public method | Add(Ticks, Ticks) | Adds an outage to the OutageLog.
Protected method | BlockReentrancy | Disallows reentrant attempts to change this collection. (Inherited from ObservableCollection Outage .)
Protected method | CheckReentrancy | Checks for reentrant attempts to change this collection. (Inherited from ObservableCollection Outage .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection Outage .)
Protected method | ClearItems | Removes all elements from the OutageLog. (Overrides ObservableCollectionTClearItems.)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection Outage .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection Outage .)
Public method | Dispose | Releases all the resources used by the OutageLog object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutageLog object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the OutageLog object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | Flush | Requests that outage log be flushed to disk.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection Outage .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection Outage .)
Public method | Initialize | Initialize the outage log.
Protected method | InitiateRead | Initiates a log read.
Protected method | InitiateWrite | Initiates a log write.
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection Outage .)
Protected method | InsertItem | Inserts an element into the OutageLog at the specified index. (Overrides ObservableCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Move | Moves the item at the specified index to a new location in the collection. (Inherited from ObservableCollection Outage .)
Protected method | MoveItem | Moves the item at the specified index to a new location in the OutageLog. (Overrides ObservableCollectionTMoveItem(Int32, Int32).)
Protected method | OnCollectionChanged | Raises the CollectionChanged event with the provided arguments. (Inherited from ObservableCollection Outage .)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnPropertyChanged | Raises the PropertyChanged event with the provided arguments. (Inherited from ObservableCollection Outage .)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection Outage .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection Outage .)
Protected method | RemoveItem | Removes the element at the specified index of the OutageLog. (Overrides ObservableCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ObservableCollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Add Method

Grid Solutions Framework OutageLogAdd Method
Overload List
 | Name | Description
Public method | Add(T) | Adds an object to the end of the CollectionT. (Inherited from Collection Outage .)
Public method | Add(Ticks, Ticks) | Adds an outage to the OutageLog.
Top
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Add Method (Ticks, Ticks)

Grid Solutions Framework OutageLogAdd Method (Ticks, Ticks)
Adds an outage to the OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    Ticks startTime,
    Ticks endTime
)
Public Sub Add (
    startTime As Ticks,
    endTime As Ticks
)
member Add :
        startTime : Ticks *
        endTime : Ticks -> unit

function Add(startTime, endTime);
public:
void Add(
    Ticks startTime,
    Ticks endTime
)

Parameters

startTime
Type: GSFTicks
Start time of outage.
endTime
Type: GSFTicks
End time of outage.
See Also

Reference

OutageLog Class
Add Overload
GSF.IO Namespace


OutageLog.ClearItems Method

Grid Solutions Framework OutageLogClearItems Method
Removes all elements from the OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
abstract ClearItems : unit -> unit
override ClearItems : unit -> unit
function ClearItems();
protected:
virtual void ClearItems() override
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Dispose Method

Grid Solutions Framework OutageLogDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the OutageLog object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutageLog object and optionally releases the managed resources.
Top
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Dispose Method

Grid Solutions Framework OutageLogDispose Method
Releases all the resources used by the OutageLog object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

OutageLog Class
Dispose Overload
GSF.IO Namespace


OutageLog.Dispose Method (Boolean)

Grid Solutions Framework OutageLogDispose Method (Boolean)
Releases the unmanaged resources used by the OutageLog object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

OutageLog Class
Dispose Overload
GSF.IO Namespace


OutageLog.Finalize Method

Grid Solutions Framework OutageLogFinalize Method
Releases the unmanaged resources before the OutageLog object is reclaimed by GC.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Flush Method

Grid Solutions Framework OutageLogFlush Method
Requests that outage log be flushed to disk.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ManualResetEventSlim Flush()
Public Function Flush As ManualResetEventSlim
member Flush : unit -> ManualResetEventSlim

function Flush();
public:
ManualResetEventSlim^ Flush()

Return Value

Type: ManualResetEventSlim
Wait handle that can block a calling thread until flush completes.
Remarks
Any change in OutageLog contents will automatically queue a log file flush. This function only exists to force a flush and allow consumer to use returned wait handle to block calling thread until flush has completed.
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Initialize Method

Grid Solutions Framework OutageLogInitialize Method
Initialize the outage log.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks

Initialization performs initial outage log read.

It is important to separate initialization from construction such that consumer can attach to events before class is initialized in case initialization causes events to be raised.

See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.InitiateRead Method

Grid Solutions Framework OutageLogInitiateRead Method
Initiates a log read.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void InitiateRead()
Protected Sub InitiateRead
member InitiateRead : unit -> unit

function InitiateRead();
protected:
void InitiateRead()
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.InitiateWrite Method

Grid Solutions Framework OutageLogInitiateWrite Method
Initiates a log write.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void InitiateWrite()
Protected Sub InitiateWrite
member InitiateWrite : unit -> unit

function InitiateWrite();
protected:
void InitiateWrite()
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.InsertItem Method

Grid Solutions Framework OutageLogInsertItem Method
Inserts an element into the OutageLog at the specified index.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InsertItem(
    int index,
    Outage outage
)
Protected Overrides Sub InsertItem (
    index As Integer,
    outage As Outage
)
abstract InsertItem :
        index : int *
        outage : Outage -> unit
override InsertItem :
        index : int *
        outage : Outage -> unit
function InsertItem(index, outage);
protected:
virtual void InsertItem(
    int index,
    Outage^ outage
) override

Parameters

index
Type: SystemInt32
The zero-based index at which outage should be inserted.
outage
Type: GSF.IOOutage
The Outage to insert.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero.-or- index is greater than Count.
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.MoveItem Method

Grid Solutions Framework OutageLogMoveItem Method
Moves the item at the specified index to a new location in the OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void MoveItem(
    int oldIndex,
    int newIndex
)
Protected Overrides Sub MoveItem (
    oldIndex As Integer,
    newIndex As Integer
)
abstract MoveItem :
        oldIndex : int *
        newIndex : int -> unit
override MoveItem :
        oldIndex : int *
        newIndex : int -> unit
function MoveItem(oldIndex, newIndex);
protected:
virtual void MoveItem(
    int oldIndex,
    int newIndex
) override

Parameters

oldIndex
Type: SystemInt32
The zero-based index specifying the location of the Outage to be moved.
newIndex
Type: SystemInt32
The zero-based index specifying the new location of the Outage.
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.OnProcessException Method

Grid Solutions Framework OutageLogOnProcessException Method
Raises ProcessException event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.RemoveItem Method

Grid Solutions Framework OutageLogRemoveItem Method
Removes the element at the specified index of the OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)
abstract RemoveItem :
        index : int -> unit
override RemoveItem :
        index : int -> unit
function RemoveItem(index);
protected:
virtual void RemoveItem(
    int index
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero.-or- index is equal to or greater than Count.
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.SetItem Method

Grid Solutions Framework OutageLogSetItem Method
Replaces the element at the specified index.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SetItem(
    int index,
    Outage outage
)
Protected Overrides Sub SetItem (
    index As Integer,
    outage As Outage
)
abstract SetItem :
        index : int *
        outage : Outage -> unit
override SetItem :
        index : int *
        outage : Outage -> unit
function SetItem(index, outage);
protected:
virtual void SetItem(
    int index,
    Outage^ outage
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
outage
Type: GSF.IOOutage
The new Outage for the element at the specified index.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero.-or- index is greater than Count.
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog Properties

Grid Solutions Framework OutageLog Properties

The OutageLog type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection Outage .)
Public property | Enabled | Gets or sets a boolean value that indicates whether the run-time log is enabled.
Public property | FileName | Gets or sets the file name for the outage log; file name can be set with a relative path.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection Outage .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection Outage .)
Protected property | ReadWriteLock | Gets locking object for OutageLog.
Public property | Status | Gets the current status details about OutageLog.
Top
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Enabled Property

Grid Solutions Framework OutageLogEnabled Property
Gets or sets a boolean value that indicates whether the run-time log is enabled.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Enabled { get; set; }
Public Overridable Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.FileName Property

Grid Solutions Framework OutageLogFileName Property
Gets or sets the file name for the outage log; file name can be set with a relative path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.IsDisposed Property

Grid Solutions Framework OutageLogIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.ReadWriteLock Property

Grid Solutions Framework OutageLogReadWriteLock Property
Gets locking object for OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Object ReadWriteLock { get; }
Protected ReadOnly Property ReadWriteLock As Object
    Get
member ReadWriteLock : Object with get

function get_ReadWriteLock();

protected:
property Object^ ReadWriteLock {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Status Property

Grid Solutions Framework OutageLogStatus Property
Gets the current status details about OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog Events

Grid Solutions Framework OutageLog Events

The OutageLog type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when an item is added, removed, changed, moved, or the entire list is refreshed. (Inherited from ObservableCollection Outage .)
Public event | Disposed | Raised after the outage log has been properly disposed.
Public event | ProcessException | Event is raised when there is an exception encountered while processing outage log.
Protected event | PropertyChanged | Occurs when a property value changes. (Inherited from ObservableCollection Outage .)
Top
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.Disposed Event

Grid Solutions Framework OutageLogDisposed Event
Raised after the outage log has been properly disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLog.ProcessException Event

Grid Solutions Framework OutageLogProcessException Event
Event is raised when there is an exception encountered while processing outage log.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the exception that was thrown.
See Also

Reference

OutageLog Class
GSF.IO Namespace


OutageLogProcessor Class

Grid Solutions Framework OutageLogProcessor Class
Represents a thread-safe OutageLog processor that will operate on each Outage with a consumer provided function on independent threads.
Inheritance Hierarchy
SystemObject
GSF.IOOutageLogProcessor

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class OutageLogProcessor : IDisposable
Public Class OutageLogProcessor
    Implements IDisposable
type OutageLogProcessor =
    class
        interface IDisposable
    end
GSF.IO.OutageLogProcessor = function();

Type.createClass(
    'GSF.IO.OutageLogProcessor',
    null,
    IDisposable);
public ref class OutageLogProcessor : IDisposable

The OutageLogProcessor type exposes the following members.

Constructors
 | Name | Description
Public method | OutageLogProcessor | Creates a OutageLogProcessor using a pre-initialized OutageLog.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the OutageLogProcessor object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutageLogProcessor object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the OutageLogProcessor object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Enabled | Enables or disables the OutageLogProcessor.
Top
See Also

Reference

GSF.IO Namespace


OutageLogProcessor Constructor

Grid Solutions Framework OutageLogProcessor Constructor
Creates a OutageLogProcessor using a pre-initialized OutageLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OutageLogProcessor(
    OutageLog outageLog,
    Action<Outage> processOutageFunction,
    Func<Outage, bool> canProcessOutageFunction,
    Action<Exception> processExceptionHandler,
    int processingInterval
)
Public Sub New (
    outageLog As OutageLog,
    processOutageFunction As Action(Of Outage),
    canProcessOutageFunction As Func(Of Outage, Boolean),
    processExceptionHandler As Action(Of Exception),
    processingInterval As Integer
)
new :
        outageLog : OutageLog *
        processOutageFunction : Action<Outage> *
        canProcessOutageFunction : Func<Outage, bool> *
        processExceptionHandler : Action<Exception> *
        processingInterval : int -> OutageLogProcessor
GSF.IO.OutageLogProcessor = function(outageLog, processOutageFunction, canProcessOutageFunction, processExceptionHandler, processingInterval);
public:
OutageLogProcessor(
    OutageLog^ outageLog,
    Action<Outage^>^ processOutageFunction,
    Func<Outage^, bool>^ canProcessOutageFunction,
    Action<Exception^>^ processExceptionHandler,
    int processingInterval
)

Parameters

outageLog
Type: GSF.IOOutageLog
Pre-initialized OutageLog to process.
processOutageFunction
Type: SystemAction Outage
A delegate that defines a processing function for an Outage.
canProcessOutageFunction
Type: SystemFunc Outage, Boolean
A delegate that determines if an Outage can currently be processed.
processExceptionHandler
Type: SystemAction Exception
Delegate to handle any exceptions encountered while processing as Outage.
processingInterval
Type: SystemInt32
Processing interval, in milliseconds.
See Also

Reference

OutageLogProcessor Class
GSF.IO Namespace


OutageLogProcessor Methods

Grid Solutions Framework OutageLogProcessor Methods

The OutageLogProcessor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the OutageLogProcessor object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutageLogProcessor object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the OutageLogProcessor object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

OutageLogProcessor Class
GSF.IO Namespace


OutageLogProcessor.Dispose Method

Grid Solutions Framework OutageLogProcessorDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the OutageLogProcessor object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutageLogProcessor object and optionally releases the managed resources.
Top
See Also

Reference

OutageLogProcessor Class
GSF.IO Namespace


OutageLogProcessor.Dispose Method

Grid Solutions Framework OutageLogProcessorDispose Method
Releases all the resources used by the OutageLogProcessor object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

OutageLogProcessor Class
Dispose Overload
GSF.IO Namespace


OutageLogProcessor.Dispose Method (Boolean)

Grid Solutions Framework OutageLogProcessorDispose Method (Boolean)
Releases the unmanaged resources used by the OutageLogProcessor object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

OutageLogProcessor Class
Dispose Overload
GSF.IO Namespace


OutageLogProcessor.Finalize Method

Grid Solutions Framework OutageLogProcessorFinalize Method
Releases the unmanaged resources before the OutageLogProcessor object is reclaimed by GC.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

OutageLogProcessor Class
GSF.IO Namespace


OutageLogProcessor Properties

Grid Solutions Framework OutageLogProcessor Properties

The OutageLogProcessor type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Enables or disables the OutageLogProcessor.
Top
See Also

Reference

OutageLogProcessor Class
GSF.IO Namespace


OutageLogProcessor.Enabled Property

Grid Solutions Framework OutageLogProcessorEnabled Property
Enables or disables the OutageLogProcessor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
member Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

OutageLogProcessor Class
GSF.IO Namespace


RunTimeLog Class

Grid Solutions Framework RunTimeLog Class
Represents a persisted run-time log that tracks last start, stop and running times.
Inheritance Hierarchy
SystemObject
GSF.IORunTimeLog

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RunTimeLog : ISupportLifecycle, IDisposable,
    IProvideStatus
Public Class RunTimeLog
    Implements ISupportLifecycle, IDisposable, IProvideStatus
type RunTimeLog =
    class
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.IO.RunTimeLog = function();

Type.createClass(
    'GSF.IO.RunTimeLog',
    null,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class RunTimeLog : ISupportLifecycle,
    IDisposable, IProvideStatus

The RunTimeLog type exposes the following members.

Constructors
 | Name | Description
Public method | RunTimeLog | Creates a new run-time log.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the RunTimeLog object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RunTimeLog object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the RunTimeLog object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize the run-time log.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | ReadLog | Reads the run-time log.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteLog | Writes the run-time log - times are in a human readable format.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DateTimeFormat | Date-time format used by RunTimeLog.
LastRunningTimeKey | Log file key name for last running time used by RunTimeLog.
LastStartTimeKey | Log file key name for last start time used by RunTimeLog.
LastStopTimeKey | Log file key name for last stop time used by RunTimeLog.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the run-time log is enabled.
Public property | FileName | Gets or sets the file name for the run-time log; file name can be set with a relative path.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | RunningTime | Gets last known running-time (10-second resolution).
Public property | StartTime | Gets last known start-time.
Public property | Status | Gets the current status details about RunTimeLog.
Public property | StopTime | Gets last known stop-time.
Top
Events
 | Name | Description
Public event | Disposed | Raised after the run-time log has been properly disposed.
Public event | ProcessException | Event is raised when there is an exception encountered while processing run-time log.
Top
See Also

Reference

GSF.IO Namespace


RunTimeLog Constructor

Grid Solutions Framework RunTimeLog Constructor
Creates a new run-time log.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RunTimeLog()
Public Sub New
new : unit -> RunTimeLog
GSF.IO.RunTimeLog = function();
public:
RunTimeLog()
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog Fields

Grid Solutions Framework RunTimeLog Fields

The RunTimeLog type exposes the following members.

Fields
Name | Description
DateTimeFormat | Date-time format used by RunTimeLog.
LastRunningTimeKey | Log file key name for last running time used by RunTimeLog.
LastStartTimeKey | Log file key name for last start time used by RunTimeLog.
LastStopTimeKey | Log file key name for last stop time used by RunTimeLog.
Top
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.DateTimeFormat Field

Grid Solutions Framework RunTimeLogDateTimeFormat Field
Date-time format used by RunTimeLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DateTimeFormat
Public Const DateTimeFormat As String
static val mutable DateTimeFormat: string
var GSF.IO.RunTimeLog.DateTimeFormat
public:
literal String^ DateTimeFormat

Field Value

Type: String
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.LastRunningTimeKey Field

Grid Solutions Framework RunTimeLogLastRunningTimeKey Field
Log file key name for last running time used by RunTimeLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string LastRunningTimeKey
Public Const LastRunningTimeKey As String
static val mutable LastRunningTimeKey: string
var GSF.IO.RunTimeLog.LastRunningTimeKey
public:
literal String^ LastRunningTimeKey

Field Value

Type: String
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.LastStartTimeKey Field

Grid Solutions Framework RunTimeLogLastStartTimeKey Field
Log file key name for last start time used by RunTimeLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string LastStartTimeKey
Public Const LastStartTimeKey As String
static val mutable LastStartTimeKey: string
var GSF.IO.RunTimeLog.LastStartTimeKey
public:
literal String^ LastStartTimeKey

Field Value

Type: String
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.LastStopTimeKey Field

Grid Solutions Framework RunTimeLogLastStopTimeKey Field
Log file key name for last stop time used by RunTimeLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string LastStopTimeKey
Public Const LastStopTimeKey As String
static val mutable LastStopTimeKey: string
var GSF.IO.RunTimeLog.LastStopTimeKey
public:
literal String^ LastStopTimeKey

Field Value

Type: String
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog Methods

Grid Solutions Framework RunTimeLog Methods

The RunTimeLog type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the RunTimeLog object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RunTimeLog object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the RunTimeLog object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize the run-time log.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | ReadLog | Reads the run-time log.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | WriteLog | Writes the run-time log - times are in a human readable format.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.Dispose Method

Grid Solutions Framework RunTimeLogDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the RunTimeLog object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RunTimeLog object and optionally releases the managed resources.
Top
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.Dispose Method

Grid Solutions Framework RunTimeLogDispose Method
Releases all the resources used by the RunTimeLog object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

RunTimeLog Class
Dispose Overload
GSF.IO Namespace


RunTimeLog.Dispose Method (Boolean)

Grid Solutions Framework RunTimeLogDispose Method (Boolean)
Releases the unmanaged resources used by the RunTimeLog object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

RunTimeLog Class
Dispose Overload
GSF.IO Namespace


RunTimeLog.Finalize Method

Grid Solutions Framework RunTimeLogFinalize Method
Releases the unmanaged resources before the RunTimeLog object is reclaimed by GC.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.Initialize Method

Grid Solutions Framework RunTimeLogInitialize Method
Initialize the run-time log.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize()

Implements

ISupportLifecycleInitialize
Remarks

Initialization performs initial run-time log read, establishes new start time and enables automatic write log timer.

Last logged stop time will be validated against last logged running time. If the last logged running time is later than the last logged stop time, the stop time will be set to the running time with the assumption that the log file was not properly shut down (e.g., due to abnormal host termination).

It is important to separate initialization from construction such that consumer can attach to events before class is initialized in case initialization causes events to be raised.

See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.OnProcessException Method

Grid Solutions Framework RunTimeLogOnProcessException Method
Raises ProcessException event.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.ReadLog Method

Grid Solutions Framework RunTimeLogReadLog Method
Reads the run-time log.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void ReadLog()
Protected Sub ReadLog
member ReadLog : unit -> unit

function ReadLog();
protected:
void ReadLog()
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.WriteLog Method

Grid Solutions Framework RunTimeLogWriteLog Method
Writes the run-time log - times are in a human readable format.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void WriteLog()
Protected Sub WriteLog
member WriteLog : unit -> unit

function WriteLog();
protected:
void WriteLog()
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog Properties

Grid Solutions Framework RunTimeLog Properties

The RunTimeLog type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the run-time log is enabled.
Public property | FileName | Gets or sets the file name for the run-time log; file name can be set with a relative path.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | RunningTime | Gets last known running-time (10-second resolution).
Public property | StartTime | Gets last known start-time.
Public property | Status | Gets the current status details about RunTimeLog.
Public property | StopTime | Gets last known stop-time.
Top
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.Enabled Property

Grid Solutions Framework RunTimeLogEnabled Property
Gets or sets a boolean value that indicates whether the run-time log is enabled.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Enabled { get; set; }
Public Overridable Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
This property controls the automatic write log timer.
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.FileName Property

Grid Solutions Framework RunTimeLogFileName Property
Gets or sets the file name for the run-time log; file name can be set with a relative path.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.IsDisposed Property

Grid Solutions Framework RunTimeLogIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.RunningTime Property

Grid Solutions Framework RunTimeLogRunningTime Property
Gets last known running-time (10-second resolution).

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime RunningTime { get; set; }
Public Property RunningTime As DateTime
    Get
    Set
member RunningTime : DateTime with get, set

function get_RunningTime();
function set_RunningTime(value);
public:
property DateTime RunningTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.StartTime Property

Grid Solutions Framework RunTimeLogStartTime Property
Gets last known start-time.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
member StartTime : DateTime with get, set

function get_StartTime();
function set_StartTime(value);
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.Status Property

Grid Solutions Framework RunTimeLogStatus Property
Gets the current status details about RunTimeLog.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.StopTime Property

Grid Solutions Framework RunTimeLogStopTime Property
Gets last known stop-time.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime StopTime { get; set; }
Public Property StopTime As DateTime
    Get
    Set
member StopTime : DateTime with get, set

function get_StopTime();
function set_StopTime(value);
public:
property DateTime StopTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog Events

Grid Solutions Framework RunTimeLog Events

The RunTimeLog type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the run-time log has been properly disposed.
Public event | ProcessException | Event is raised when there is an exception encountered while processing run-time log.
Top
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.Disposed Event

Grid Solutions Framework RunTimeLogDisposed Event
Raised after the run-time log has been properly disposed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


RunTimeLog.ProcessException Event

Grid Solutions Framework RunTimeLogProcessException Event
Event is raised when there is an exception encountered while processing run-time log.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the exception that was thrown.
See Also

Reference

RunTimeLog Class
GSF.IO Namespace


SafeFileWatcher Class

Grid Solutions Framework SafeFileWatcher Class
Represents a wrapper around the native .NET FileSystemWatcher that avoids problems with dangling references when using a file watcher instance as a class member that never gets disposed.
Inheritance Hierarchy
SystemObject
GSF.IOSafeFileWatcher

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SecurityCriticalAttribute]
public class SafeFileWatcher : IDisposable
<SecurityCriticalAttribute>
Public Class SafeFileWatcher
    Implements IDisposable
[<SecurityCriticalAttribute>]
type SafeFileWatcher =
    class
        interface IDisposable
    end
GSF.IO.SafeFileWatcher = function();

Type.createClass(
    'GSF.IO.SafeFileWatcher',
    null,
    IDisposable);
[SecurityCriticalAttribute]
public ref class SafeFileWatcher : IDisposable

The SafeFileWatcher type exposes the following members.

Constructors
 | Name | Description
Public method | SafeFileWatcher | Initializes a new instance of the SafeFileWatcher class.
Public method | SafeFileWatcher(String) | Initializes a new instance of the SafeFileWatcher class, given the specified directory to monitor.
Public method | SafeFileWatcher(String, String) | Initializes a new instance of the SafeFileWatcher class, given the specified directory and type of files to monitor.
Top
Methods
 | Name | Description
Public method | BeginInit | Begins the initialization of a SafeFileWatcher used on a form or used by another component. The initialization occurs at run time.
Public method | Dispose | Releases all the resources used by the SafeFileWatcher object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SafeFileWatcher object and optionally releases the managed resources.
Public method | EndInit | Ends the initialization of a SafeFileWatcher used on a form or used by another component. The initialization occurs at run time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Terminates SafeFileWatcher instance making sure to release unmanaged resources. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForChanged(WatcherChangeTypes) | A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor.
Public method | WaitForChanged(WatcherChangeTypes, Int32) | A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor and the time (in milliseconds) to wait before timing out.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | EnableRaisingEvents | Gets or sets a value indicating whether the component is enabled.
Public property | Filter | Gets or sets the filter string used to determine what files are monitored in a directory.
Public property | IncludeSubdirectories | Gets or sets a value indicating whether subdirectories within the specified path should be monitored.
Public property | InternalBufferSize | Gets or sets the size of the internal buffer.
Public property | NotifyFilter | Gets or sets the type of changes to watch for.
Public property | Path | Gets or sets the path of the directory to watch.
Public property | Site | Gets or sets an ISite for the SafeFileWatcher.
Public property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued as a result of a directory change.
Top
Events
 | Name | Description
Public event | Changed | Occurs when a file or directory in the specified Path is changed.
Public event | Created | Occurs when a file or directory in the specified Path is created.
Public event | Deleted | Occurs when a file or directory in the specified Path is deleted.
Public event | Error | Occurs when the internal buffer overflows.
Public event | Renamed | Occurs when a file or directory in the specified Path is renamed.
Top
Remarks

The design goal of the SafeFileWatcher is to avoid accidental memory leaks caused by use of .NET's native file system watcher when used as a member of a class that consumers fail to properly dispose. If a class has a reference to a file watcher as a member variable and attaches to the file watcher's events, the file watcher will maintain a reference the parent class so it can call its event handler. If the parent class is not disposed properly, the file watcher will thusly not be disposed and will maintain the reference to the parent class - the garbage collector will never collect the parent because it has a valid reference and no collection means the parent finalizer will never get called and the file system watcher will never get disposed. Creating multiple instances of parent class and not disposing of them will cause a memory leak even with a properly designed disposable pattern. Using the SafeFileWatcher instead of directly using the FileSystemWatcher will resolve this potential issue.

Note that component model implementation is not fully replicated - if you are using a file system watcher on a design surface, this safety wrapper will usually not be needed. This class has benefit when a class will dynamically use a file watcher and needs to make sure any unmanaged resources get properly released even if a consumer neglects to call the dispose function.

See Also

Reference

GSF.IO Namespace


SafeFileWatcher Constructor

Grid Solutions Framework SafeFileWatcher Constructor
Overload List
 | Name | Description
Public method | SafeFileWatcher | Initializes a new instance of the SafeFileWatcher class.
Public method | SafeFileWatcher(String) | Initializes a new instance of the SafeFileWatcher class, given the specified directory to monitor.
Public method | SafeFileWatcher(String, String) | Initializes a new instance of the SafeFileWatcher class, given the specified directory and type of files to monitor.
Top
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher Constructor

Grid Solutions Framework SafeFileWatcher Constructor
Initializes a new instance of the SafeFileWatcher class.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SafeFileWatcher()
Public Sub New
new : unit -> SafeFileWatcher
GSF.IO.SafeFileWatcher = function();
public:
SafeFileWatcher()
See Also

Reference

SafeFileWatcher Class
SafeFileWatcher Overload
GSF.IO Namespace


SafeFileWatcher Constructor (String)

Grid Solutions Framework SafeFileWatcher Constructor (String)
Initializes a new instance of the SafeFileWatcher class, given the specified directory to monitor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SafeFileWatcher(
    string path
)
Public Sub New (
    path As String
)
new :
        path : string -> SafeFileWatcher
GSF.IO.SafeFileWatcher = function(path);
public:
SafeFileWatcher(
    String^ path
)

Parameters

path
Type: SystemString
The directory to monitor, in standard or Universal Naming Convention (UNC) notation.
Exceptions
Exception | Condition
ArgumentNullException | The path parameter is null.
ArgumentException | The path parameter is an empty string (""). -or- The path specified through the path parameter does not exist.
See Also

Reference

SafeFileWatcher Class
SafeFileWatcher Overload
GSF.IO Namespace


SafeFileWatcher Constructor (String, String)

Grid Solutions Framework SafeFileWatcher Constructor (String, String)
Initializes a new instance of the SafeFileWatcher class, given the specified directory and type of files to monitor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SafeFileWatcher(
    string path,
    string filter
)
Public Sub New (
    path As String,
    filter As String
)
new :
        path : string *
        filter : string -> SafeFileWatcher
GSF.IO.SafeFileWatcher = function(path, filter);
public:
SafeFileWatcher(
    String^ path,
    String^ filter
)

Parameters

path
Type: SystemString
The directory to monitor, in standard or Universal Naming Convention (UNC) notation.
filter
Type: SystemString
The type of files to watch. For example, "*.txt" watches for changes to all text files.
Exceptions
Exception | Condition
ArgumentNullException | The path parameter is null. -or- The filter parameter is null.
ArgumentException | The path parameter is an empty string (""). -or- The path specified through the path parameter does not exist.
See Also

Reference

SafeFileWatcher Class
SafeFileWatcher Overload
GSF.IO Namespace


SafeFileWatcher Methods

Grid Solutions Framework SafeFileWatcher Methods

The SafeFileWatcher type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Begins the initialization of a SafeFileWatcher used on a form or used by another component. The initialization occurs at run time.
Public method | Dispose | Releases all the resources used by the SafeFileWatcher object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SafeFileWatcher object and optionally releases the managed resources.
Public method | EndInit | Ends the initialization of a SafeFileWatcher used on a form or used by another component. The initialization occurs at run time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Terminates SafeFileWatcher instance making sure to release unmanaged resources. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForChanged(WatcherChangeTypes) | A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor.
Public method | WaitForChanged(WatcherChangeTypes, Int32) | A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor and the time (in milliseconds) to wait before timing out.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.BeginInit Method

Grid Solutions Framework SafeFileWatcherBeginInit Method
Begins the initialization of a SafeFileWatcher used on a form or used by another component. The initialization occurs at run time.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void BeginInit()
Public Sub BeginInit
member BeginInit : unit -> unit

function BeginInit();
public:
void BeginInit()
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Dispose Method

Grid Solutions Framework SafeFileWatcherDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the SafeFileWatcher object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the SafeFileWatcher object and optionally releases the managed resources.
Top
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Dispose Method

Grid Solutions Framework SafeFileWatcherDispose Method
Releases all the resources used by the SafeFileWatcher object.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

SafeFileWatcher Class
Dispose Overload
GSF.IO Namespace


SafeFileWatcher.Dispose Method (Boolean)

Grid Solutions Framework SafeFileWatcherDispose Method (Boolean)
Releases the unmanaged resources used by the SafeFileWatcher object and optionally releases the managed resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

SafeFileWatcher Class
Dispose Overload
GSF.IO Namespace


SafeFileWatcher.EndInit Method

Grid Solutions Framework SafeFileWatcherEndInit Method
Ends the initialization of a SafeFileWatcher used on a form or used by another component. The initialization occurs at run time.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EndInit()
Public Sub EndInit
member EndInit : unit -> unit

function EndInit();
public:
void EndInit()
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Finalize Method

Grid Solutions Framework SafeFileWatcherFinalize Method
Terminates SafeFileWatcher instance making sure to release unmanaged resources.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.WaitForChanged Method

Grid Solutions Framework SafeFileWatcherWaitForChanged Method
Overload List
 | Name | Description
Public method | WaitForChanged(WatcherChangeTypes) | A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor.
Public method | WaitForChanged(WatcherChangeTypes, Int32) | A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor and the time (in milliseconds) to wait before timing out.
Top
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.WaitForChanged Method (WatcherChangeTypes)

Grid Solutions Framework SafeFileWatcherWaitForChanged Method (WatcherChangeTypes)
A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaitForChangedResult WaitForChanged(
    WatcherChangeTypes changeType
)
Public Function WaitForChanged (
    changeType As WatcherChangeTypes
) As WaitForChangedResult
member WaitForChanged :
        changeType : WatcherChangeTypes -> WaitForChangedResult

function WaitForChanged(changeType);
public:
WaitForChangedResult WaitForChanged(
    WatcherChangeTypes changeType
)

Parameters

changeType
Type: System.IOWatcherChangeTypes
The WatcherChangeTypes to watch for.

Return Value

Type: WaitForChangedResult
A WaitForChangedResult that contains specific information on the change that occurred.
See Also

Reference

SafeFileWatcher Class
WaitForChanged Overload
GSF.IO Namespace


SafeFileWatcher.WaitForChanged Method (WatcherChangeTypes, Int32)

Grid Solutions Framework SafeFileWatcherWaitForChanged Method (WatcherChangeTypes, Int32)
A synchronous method that returns a structure that contains specific information on the change that occurred, given the type of change you want to monitor and the time (in milliseconds) to wait before timing out.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaitForChangedResult WaitForChanged(
    WatcherChangeTypes changeType,
    int timeout
)
Public Function WaitForChanged (
    changeType As WatcherChangeTypes,
    timeout As Integer
) As WaitForChangedResult
member WaitForChanged :
        changeType : WatcherChangeTypes *
        timeout : int -> WaitForChangedResult

function WaitForChanged(changeType, timeout);
public:
WaitForChangedResult WaitForChanged(
    WatcherChangeTypes changeType,
    int timeout
)

Parameters

changeType
Type: System.IOWatcherChangeTypes
The WatcherChangeTypes to watch for.
timeout
Type: SystemInt32
The time (in milliseconds) to wait before timing out.

Return Value

Type: WaitForChangedResult
A WaitForChangedResult that contains specific information on the change that occurred.
See Also

Reference

SafeFileWatcher Class
WaitForChanged Overload
GSF.IO Namespace


SafeFileWatcher Properties

Grid Solutions Framework SafeFileWatcher Properties

The SafeFileWatcher type exposes the following members.

Properties
 | Name | Description
Public property | EnableRaisingEvents | Gets or sets a value indicating whether the component is enabled.
Public property | Filter | Gets or sets the filter string used to determine what files are monitored in a directory.
Public property | IncludeSubdirectories | Gets or sets a value indicating whether subdirectories within the specified path should be monitored.
Public property | InternalBufferSize | Gets or sets the size of the internal buffer.
Public property | NotifyFilter | Gets or sets the type of changes to watch for.
Public property | Path | Gets or sets the path of the directory to watch.
Public property | Site | Gets or sets an ISite for the SafeFileWatcher.
Public property | SynchronizingObject | Gets or sets the object used to marshal the event handler calls issued as a result of a directory change.
Top
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.EnableRaisingEvents Property

Grid Solutions Framework SafeFileWatcherEnableRaisingEvents Property
Gets or sets a value indicating whether the component is enabled.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool EnableRaisingEvents { get; set; }
Public Property EnableRaisingEvents As Boolean
    Get
    Set
member EnableRaisingEvents : bool with get, set

function get_EnableRaisingEvents();
function set_EnableRaisingEvents(value);
public:
property bool EnableRaisingEvents {
    bool get ();
    void set (bool value);
}

Return Value

Type: Boolean
true if the component is enabled; otherwise, false. The default is false. If you are using the component on a designer in Visual Studio 2005, the default is true.
Exceptions
Exception | Condition
ObjectDisposedException | The FileSystemWatcher object has been disposed.
PlatformNotSupportedException | The current operating system is not Microsoft Windows NT or later.
FileNotFoundException | The directory specified in Path could not be found.
ArgumentException | Path has not been set or is invalid.
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Filter Property

Grid Solutions Framework SafeFileWatcherFilter Property
Gets or sets the filter string used to determine what files are monitored in a directory.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Filter { get; set; }
Public Property Filter As String
    Get
    Set
member Filter : string with get, set

function get_Filter();
function set_Filter(value);
public:
property String^ Filter {
    String^ get ();
    void set (String^ value);
}

Return Value

Type: String
The filter string. The default is "*.*" (Watches all files.)
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.IncludeSubdirectories Property

Grid Solutions Framework SafeFileWatcherIncludeSubdirectories Property
Gets or sets a value indicating whether subdirectories within the specified path should be monitored.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IncludeSubdirectories { get; set; }
Public Property IncludeSubdirectories As Boolean
    Get
    Set
member IncludeSubdirectories : bool with get, set

function get_IncludeSubdirectories();
function set_IncludeSubdirectories(value);
public:
property bool IncludeSubdirectories {
    bool get ();
    void set (bool value);
}

Return Value

Type: Boolean
true if you want to monitor subdirectories; otherwise, false. The default is false.
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.InternalBufferSize Property

Grid Solutions Framework SafeFileWatcherInternalBufferSize Property
Gets or sets the size of the internal buffer.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int InternalBufferSize { get; set; }
Public Property InternalBufferSize As Integer
    Get
    Set
member InternalBufferSize : int with get, set

function get_InternalBufferSize();
function set_InternalBufferSize(value);
public:
property int InternalBufferSize {
    int get ();
    void set (int value);
}

Return Value

Type: Int32
The internal buffer size. The default is 8192 (8K).
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.NotifyFilter Property

Grid Solutions Framework SafeFileWatcherNotifyFilter Property
Gets or sets the type of changes to watch for.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NotifyFilters NotifyFilter { get; set; }
Public Property NotifyFilter As NotifyFilters
    Get
    Set
member NotifyFilter : NotifyFilters with get, set

function get_NotifyFilter();
function set_NotifyFilter(value);
public:
property NotifyFilters NotifyFilter {
    NotifyFilters get ();
    void set (NotifyFilters value);
}

Return Value

Type: NotifyFilters
One of the NotifyFilters values. The default is the bitwise OR combination of LastWrite, FileName, and DirectoryName.
Exceptions
Exception | Condition
ArgumentException | The value is not a valid bitwise OR combination of the NotifyFilters values.
InvalidEnumArgumentException | The value that is being set is not valid.
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Path Property

Grid Solutions Framework SafeFileWatcherPath Property
Gets or sets the path of the directory to watch.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Path { get; set; }
Public Property Path As String
    Get
    Set
member Path : string with get, set

function get_Path();
function set_Path(value);
public:
property String^ Path {
    String^ get ();
    void set (String^ value);
}

Return Value

Type: String
The path to monitor. The default is an empty string ("").
Exceptions
Exception | Condition
ArgumentException | The specified path does not exist or could not be found. -or- The specified path contains wildcard characters. -or- The specified path contains invalid path characters.
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Site Property

Grid Solutions Framework SafeFileWatcherSite Property
Gets or sets an ISite for the SafeFileWatcher.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ISite Site { get; set; }
Public Property Site As ISite
    Get
    Set
member Site : ISite with get, set

function get_Site();
function set_Site(value);
public:
property ISite^ Site {
    ISite^ get ();
    void set (ISite^ value);
}

Return Value

Type: ISite
An ISite for the SafeFileWatcher.
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.SynchronizingObject Property

Grid Solutions Framework SafeFileWatcherSynchronizingObject Property
Gets or sets the object used to marshal the event handler calls issued as a result of a directory change.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ISynchronizeInvoke SynchronizingObject { get; set; }
Public Property SynchronizingObject As ISynchronizeInvoke
    Get
    Set
member SynchronizingObject : ISynchronizeInvoke with get, set

function get_SynchronizingObject();
function set_SynchronizingObject(value);
public:
property ISynchronizeInvoke^ SynchronizingObject {
    ISynchronizeInvoke^ get ();
    void set (ISynchronizeInvoke^ value);
}

Return Value

Type: ISynchronizeInvoke
The ISynchronizeInvoke that represents the object used to marshal the event handler calls issued as a result of a directory change. The default is null.
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher Events

Grid Solutions Framework SafeFileWatcher Events

The SafeFileWatcher type exposes the following members.

Events
 | Name | Description
Public event | Changed | Occurs when a file or directory in the specified Path is changed.
Public event | Created | Occurs when a file or directory in the specified Path is created.
Public event | Deleted | Occurs when a file or directory in the specified Path is deleted.
Public event | Error | Occurs when the internal buffer overflows.
Public event | Renamed | Occurs when a file or directory in the specified Path is renamed.
Top
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Changed Event

Grid Solutions Framework SafeFileWatcherChanged Event
Occurs when a file or directory in the specified Path is changed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event FileSystemEventHandler Changed
Public Event Changed As FileSystemEventHandler
member Changed : IEvent<FileSystemEventHandler,
    FileSystemEventArgs>

function add_Changed(value);
function remove_Changed(value);
public:
 event FileSystemEventHandler^ Changed {
    void add (FileSystemEventHandler^ value);
    void remove (FileSystemEventHandler^ value);
}

Value

Type: System.IOFileSystemEventHandler
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Created Event

Grid Solutions Framework SafeFileWatcherCreated Event
Occurs when a file or directory in the specified Path is created.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event FileSystemEventHandler Created
Public Event Created As FileSystemEventHandler
member Created : IEvent<FileSystemEventHandler,
    FileSystemEventArgs>

function add_Created(value);
function remove_Created(value);
public:
 event FileSystemEventHandler^ Created {
    void add (FileSystemEventHandler^ value);
    void remove (FileSystemEventHandler^ value);
}

Value

Type: System.IOFileSystemEventHandler
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Deleted Event

Grid Solutions Framework SafeFileWatcherDeleted Event
Occurs when a file or directory in the specified Path is deleted.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event FileSystemEventHandler Deleted
Public Event Deleted As FileSystemEventHandler
member Deleted : IEvent<FileSystemEventHandler,
    FileSystemEventArgs>

function add_Deleted(value);
function remove_Deleted(value);
public:
 event FileSystemEventHandler^ Deleted {
    void add (FileSystemEventHandler^ value);
    void remove (FileSystemEventHandler^ value);
}

Value

Type: System.IOFileSystemEventHandler
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Error Event

Grid Solutions Framework SafeFileWatcherError Event
Occurs when the internal buffer overflows.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event ErrorEventHandler Error
Public Event Error As ErrorEventHandler
member Error : IEvent<ErrorEventHandler,
    ErrorEventArgs>

function add_Error(value);
function remove_Error(value);
public:
 event ErrorEventHandler^ Error {
    void add (ErrorEventHandler^ value);
    void remove (ErrorEventHandler^ value);
}

Value

Type: System.IOErrorEventHandler
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


SafeFileWatcher.Renamed Event

Grid Solutions Framework SafeFileWatcherRenamed Event
Occurs when a file or directory in the specified Path is renamed.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event RenamedEventHandler Renamed
Public Event Renamed As RenamedEventHandler
member Renamed : IEvent<RenamedEventHandler,
    RenamedEventArgs>

function add_Renamed(value);
function remove_Renamed(value);
public:
 event RenamedEventHandler^ Renamed {
    void add (RenamedEventHandler^ value);
    void remove (RenamedEventHandler^ value);
}

Value

Type: System.IORenamedEventHandler
See Also

Reference

SafeFileWatcher Class
GSF.IO Namespace


StreamExtensions Class

Grid Solutions Framework StreamExtensions Class
Defines extension functions related to Stream manipulation.
Inheritance Hierarchy
SystemObject
GSF.IOStreamExtensions

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class StreamExtensions
<ExtensionAttribute>
Public NotInheritable Class StreamExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type StreamExtensions =  class end
GSF.IO.StreamExtensions = function();

Type.createClass(
    'GSF.IO.StreamExtensions');
[ExtensionAttribute]
public ref class StreamExtensions abstract sealed

The StreamExtensions type exposes the following members.

Methods
Name | Description
CopyStream | Obsolete. Copies input Stream onto output Stream.
ReadStream | Reads entire Stream contents, and returns Byte array of data.
Top
See Also

Reference

GSF.IO Namespace


StreamExtensions Methods

Grid Solutions Framework StreamExtensions Methods

The StreamExtensions type exposes the following members.

Methods
Name | Description
CopyStream | Obsolete. Copies input Stream onto output Stream.
ReadStream | Reads entire Stream contents, and returns Byte array of data.
Top
See Also

Reference

StreamExtensions Class
GSF.IO Namespace


StreamExtensions.CopyStream Method

Grid Solutions Framework StreamExtensionsCopyStream Method

Note: This API is now obsolete.

Copies input Stream onto output Stream.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("Since .NET 4.0, any class inheriting from Stream has a native "CopyTo" function; also, .NET 4.5 has a "CopyToAsync" method.")]
public static void CopyStream(
    this Stream source,
    Stream destination
)
<ObsoleteAttribute("Since .NET 4.0, any class inheriting from Stream has a native "CopyTo" function; also, .NET 4.5 has a "CopyToAsync" method.")>
<ExtensionAttribute>
Public Shared Sub CopyStream (
    source As Stream,
    destination As Stream
)
[<ObsoleteAttribute("Since .NET 4.0, any class inheriting from Stream has a native "CopyTo" function; also, .NET 4.5 has a "CopyToAsync" method.")>]
static member CopyStream :
        source : Stream *
        destination : Stream -> unit

GSF.IO.StreamExtensions.CopyStream = function(source, destination);
public:
[ObsoleteAttribute(L"Since .NET 4.0, any class inheriting from Stream has a native "CopyTo" function; also, .NET 4.5 has a "CopyToAsync" method.")]
[ExtensionAttribute]
static void CopyStream(
    Stream^ source,
    Stream^ destination
)

Parameters

source
Type: System.IOStream
The input Stream.
destination
Type: System.IOStream
The output Stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StreamExtensions Class
GSF.IO Namespace


StreamExtensions.ReadStream Method

Grid Solutions Framework StreamExtensionsReadStream Method
Reads entire Stream contents, and returns Byte array of data.

Namespace: GSF.IO
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] ReadStream(
    this Stream source
)
<ExtensionAttribute>
Public Shared Function ReadStream (
    source As Stream
) As Byte()
static member ReadStream :
        source : Stream -> byte[]

GSF.IO.StreamExtensions.ReadStream = function(source);
public:
[ExtensionAttribute]
static array<unsigned char>^ ReadStream(
    Stream^ source
)

Parameters

source
Type: System.IOStream
The Stream to be converted to Byte array.

Return Value

Type: Byte
An array of Byte.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

StreamExtensions Class
GSF.IO Namespace


GSF.IO.Checksums Namespace

Grid Solutions Framework GSF.IO.Checksums Namespace
Contains classes and extension functions used to calculate standard checksums and CRC’s.
Classes
 | Class | Description
Public class | Adler32 | Generates an Adler-32 checksum calculation.
Public class | ChecksumExtensions | Defines extension functions related to computing checksums.
Public class | Crc16 | Generates a byte-wise 16-bit CRC calculation.
Public class | Crc32 | Generates a byte-wise 32-bit CRC calculation.
Public class | CrcCCITT | Generates a 16-bit CRC-CCITT checksum.
Public class | Xor16 | Calculates word length (16-bit) XOR-based check-sum on specified portion of a buffer.
Public class | Xor32 | Calculates double-word length (32-bit) XOR-based check-sum on specified portion of a buffer.
Public class | Xor64 | Calculates quad-word length (64-bit) XOR-based check-sum on specified portion of a buffer.
Public class | Xor8 | Calculates byte length (8-bit) XOR-based check-sum on specified portion of a buffer.
Enumerations
 | Enumeration | Description
Public enumeration | ChecksumType | Indicates type of CRC-16 calculation performed.


Adler32 Class

Grid Solutions Framework Adler32 Class
Generates an Adler-32 checksum calculation.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsAdler32

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class Adler32
Public NotInheritable Class Adler32
[<SealedAttribute>]
type Adler32 =  class end
GSF.IO.Checksums.Adler32 = function();

Type.createClass(
    'GSF.IO.Checksums.Adler32');
public ref class Adler32 sealed

The Adler32 type exposes the following members.

Constructors
 | Name | Description
Public method | Adler32 | Creates a new instance of the Adler32 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the Adler-32 data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the byte value.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the Adler-32 data checksum computed so far.
Top
See Also

Reference

GSF.IO.Checksums Namespace


Adler32 Constructor

Grid Solutions Framework Adler32 Constructor
Creates a new instance of the Adler32 class.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Adler32()
Public Sub New
new : unit -> Adler32
GSF.IO.Checksums.Adler32 = function();
public:
Adler32()
See Also

Reference

Adler32 Class
GSF.IO.Checksums Namespace


Adler32 Methods

Grid Solutions Framework Adler32 Methods

The Adler32 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the Adler-32 data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the byte value.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Adler32 Class
GSF.IO.Checksums Namespace


Adler32.Reset Method

Grid Solutions Framework Adler32Reset Method
Resets the Adler-32 data checksum as if no update was ever called.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

Adler32 Class
GSF.IO.Checksums Namespace


Adler32.Update Method

Grid Solutions Framework Adler32Update Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with the byte value.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
See Also

Reference

Adler32 Class
GSF.IO.Checksums Namespace


Adler32.Update Method (Byte)

Grid Solutions Framework Adler32Update Method (Byte)
Updates the checksum with the byte value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte value
)
Public Sub Update (
    value As Byte
)
member Update :
        value : byte -> unit

function Update(value);
public:
void Update(
    unsigned char value
)

Parameters

value
Type: SystemByte
The Byte value to use for the update.
See Also

Reference

Adler32 Class
Update Overload
GSF.IO.Checksums Namespace


Adler32.Update Method (Byte[])

Grid Solutions Framework Adler32Update Method (Byte)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
buffer an array of bytes
See Also

Reference

Adler32 Class
Update Overload
GSF.IO.Checksums Namespace


Adler32.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework Adler32Update Method (Byte, Int32, Int32)
Adds the byte array to the data checksum.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
The buffer which contains the data
offset
Type: SystemInt32
The offset in the buffer where the data starts
count
Type: SystemInt32
The number of data bytes to update the checksum with.
See Also

Reference

Adler32 Class
Update Overload
GSF.IO.Checksums Namespace


Adler32 Properties

Grid Solutions Framework Adler32 Properties

The Adler32 type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the Adler-32 data checksum computed so far.
Top
See Also

Reference

Adler32 Class
GSF.IO.Checksums Namespace


Adler32.Value Property

Grid Solutions Framework Adler32Value Property
Returns the Adler-32 data checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Value { get; set; }
Public Property Value As UInteger
    Get
    Set
member Value : uint32 with get, set

function get_Value();
function set_Value(value);
public:
property unsigned int Value {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

Adler32 Class
GSF.IO.Checksums Namespace


ChecksumExtensions Class

Grid Solutions Framework ChecksumExtensions Class
Defines extension functions related to computing checksums.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsChecksumExtensions

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ChecksumExtensions
<ExtensionAttribute>
Public NotInheritable Class ChecksumExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ChecksumExtensions =  class end
GSF.IO.Checksums.ChecksumExtensions = function();

Type.createClass(
    'GSF.IO.Checksums.ChecksumExtensions');
[ExtensionAttribute]
public ref class ChecksumExtensions abstract sealed

The ChecksumExtensions type exposes the following members.

Methods
Name | Description
Adler32Checksum | Calculates the Adler-32 checksum on specified portion of a buffer.
Crc16Checksum | Calculates the CRC16 check-sum on specified portion of a buffer.
Crc32Checksum | Calculates the CRC32 check-sum on specified portion of a buffer.
CrcCCITTChecksum | Calculates the CRC-CCITT check-sum on specified portion of a buffer.
ModBusCrcChecksum | Calculates the CRC-ModBus check-sum on specified portion of a buffer.
Xor16Checksum | Calculates word length (16-bit) XOR-based check-sum on specified portion of a buffer.
Xor32Checksum | Calculates double-word length (32-bit) XOR-based check-sum on specified portion of a buffer.
Xor64Checksum | Calculates quad-word length (64-bit) XOR-based check-sum on specified portion of a buffer.
Xor8Checksum | Calculates byte length (8-bit) XOR-based check-sum on specified portion of a buffer.
Top
See Also

Reference

GSF.IO.Checksums Namespace


ChecksumExtensions Methods

Grid Solutions Framework ChecksumExtensions Methods

The ChecksumExtensions type exposes the following members.

Methods
Name | Description
Adler32Checksum | Calculates the Adler-32 checksum on specified portion of a buffer.
Crc16Checksum | Calculates the CRC16 check-sum on specified portion of a buffer.
Crc32Checksum | Calculates the CRC32 check-sum on specified portion of a buffer.
CrcCCITTChecksum | Calculates the CRC-CCITT check-sum on specified portion of a buffer.
ModBusCrcChecksum | Calculates the CRC-ModBus check-sum on specified portion of a buffer.
Xor16Checksum | Calculates word length (16-bit) XOR-based check-sum on specified portion of a buffer.
Xor32Checksum | Calculates double-word length (32-bit) XOR-based check-sum on specified portion of a buffer.
Xor64Checksum | Calculates quad-word length (64-bit) XOR-based check-sum on specified portion of a buffer.
Xor8Checksum | Calculates byte length (8-bit) XOR-based check-sum on specified portion of a buffer.
Top
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.Adler32Checksum Method

Grid Solutions Framework ChecksumExtensionsAdler32Checksum Method
Calculates the Adler-32 checksum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint Adler32Checksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Adler32Checksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As UInteger
static member Adler32Checksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint32

GSF.IO.Checksums.ChecksumExtensions.Adler32Checksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned int Adler32Checksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform checksum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin checksum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform checksum over.

Return Value

Type: UInt32
Computed Adler-32 checksum over the specified portion of the buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.Crc16Checksum Method

Grid Solutions Framework ChecksumExtensionsCrc16Checksum Method
Calculates the CRC16 check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort Crc16Checksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Crc16Checksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As UShort
static member Crc16Checksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint16

GSF.IO.Checksums.ChecksumExtensions.Crc16Checksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned short Crc16Checksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform check-sum over.

Return Value

Type: UInt16
Computed CRC16 checksum over the specified portion of the buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.Crc32Checksum Method

Grid Solutions Framework ChecksumExtensionsCrc32Checksum Method
Calculates the CRC32 check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint Crc32Checksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Crc32Checksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As UInteger
static member Crc32Checksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint32

GSF.IO.Checksums.ChecksumExtensions.Crc32Checksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned int Crc32Checksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform check-sum over.

Return Value

Type: UInt32
Computed CRC32 checksum over the specified portion of the buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.CrcCCITTChecksum Method

Grid Solutions Framework ChecksumExtensionsCrcCCITTChecksum Method
Calculates the CRC-CCITT check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort CrcCCITTChecksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function CrcCCITTChecksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As UShort
static member CrcCCITTChecksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint16

GSF.IO.Checksums.ChecksumExtensions.CrcCCITTChecksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned short CrcCCITTChecksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform check-sum over.

Return Value

Type: UInt16
Computed CRC-CCITT checksum over the specified portion of the buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
The CRC-CCITT is a table based 16-bit CRC popular for modem protocols defined for use by the Consultative Committee on International Telegraphy and Telephony (CCITT)
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.ModBusCrcChecksum Method

Grid Solutions Framework ChecksumExtensionsModBusCrcChecksum Method
Calculates the CRC-ModBus check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ModBusCrcChecksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function ModBusCrcChecksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As UShort
static member ModBusCrcChecksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint16

GSF.IO.Checksums.ChecksumExtensions.ModBusCrcChecksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned short ModBusCrcChecksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform check-sum over.

Return Value

Type: UInt16
Computed CRC-ModBus checksum over the specified portion of the buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.Xor16Checksum Method

Grid Solutions Framework ChecksumExtensionsXor16Checksum Method
Calculates word length (16-bit) XOR-based check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort Xor16Checksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Xor16Checksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As UShort
static member Xor16Checksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint16

GSF.IO.Checksums.ChecksumExtensions.Xor16Checksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned short Xor16Checksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform XOR check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin XOR check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform XOR check-sum overs

Return Value

Type: UInt16
Word length XOR check-sum.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.Xor32Checksum Method

Grid Solutions Framework ChecksumExtensionsXor32Checksum Method
Calculates double-word length (32-bit) XOR-based check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint Xor32Checksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Xor32Checksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As UInteger
static member Xor32Checksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint32

GSF.IO.Checksums.ChecksumExtensions.Xor32Checksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned int Xor32Checksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform XOR check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin XOR check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform XOR check-sum over.

Return Value

Type: UInt32
Double-word length XOR check-sum.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.Xor64Checksum Method

Grid Solutions Framework ChecksumExtensionsXor64Checksum Method
Calculates quad-word length (64-bit) XOR-based check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong Xor64Checksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Xor64Checksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As ULong
static member Xor64Checksum :
        data : byte[] *
        startIndex : int *
        length : int -> uint64

GSF.IO.Checksums.ChecksumExtensions.Xor64Checksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned long long Xor64Checksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform XOR check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin XOR check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform XOR check-sum over.

Return Value

Type: UInt64
Quad-word length XOR check-sum.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumExtensions.Xor8Checksum Method

Grid Solutions Framework ChecksumExtensionsXor8Checksum Method
Calculates byte length (8-bit) XOR-based check-sum on specified portion of a buffer.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte Xor8Checksum(
    this byte[] data,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Xor8Checksum (
    data As Byte(),
    startIndex As Integer,
    length As Integer
) As Byte
static member Xor8Checksum :
        data : byte[] *
        startIndex : int *
        length : int -> byte

GSF.IO.Checksums.ChecksumExtensions.Xor8Checksum = function(data, startIndex, length);
public:
[ExtensionAttribute]
static unsigned char Xor8Checksum(
    array<unsigned char>^ data,
    int startIndex,
    int length
)

Parameters

data
Type: SystemByte
Data buffer to perform XOR check-sum on.
startIndex
Type: SystemInt32
Starts index in data buffer to begin XOR check-sum.
length
Type: SystemInt32
Total number of bytes from startIndex to perform XOR check-sum over.

Return Value

Type: Byte
Byte length XOR check-sum.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ChecksumExtensions Class
GSF.IO.Checksums Namespace


ChecksumType Enumeration

Grid Solutions Framework ChecksumType Enumeration
Indicates type of CRC-16 calculation performed.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ChecksumType
Public Enumeration ChecksumType
type ChecksumType
GSF.IO.Checksums.ChecksumType = function();
GSF.IO.Checksums.ChecksumType.createEnum('GSF.IO.Checksums.ChecksumType', false);
public enum class ChecksumType
Members
Member name | Value | Description
Crc16 | 0 | Regular CRC-16 calculation.
ModBus | 1 | ModBus CRC-16 calculation.
See Also

Reference

GSF.IO.Checksums Namespace


Crc16 Class

Grid Solutions Framework Crc16 Class
Generates a byte-wise 16-bit CRC calculation.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsCrc16

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class Crc16
Public NotInheritable Class Crc16
[<SealedAttribute>]
type Crc16 =  class end
GSF.IO.Checksums.Crc16 = function();

Type.createClass(
    'GSF.IO.Checksums.Crc16');
public ref class Crc16 sealed

The Crc16 type exposes the following members.

Constructors
 | Name | Description
Public method | Crc16 | Creates a new instance of the Crc16 class. The checksum starts off with a value of 0x0000.
Public method | Crc16(ChecksumType) | Creates a new instance of the Crc16 class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the CRC-16 data checksum as if no update was ever called.
Public method | Reset(ChecksumType) | Resets the CRC-16 data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the byte value.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the CRC-16 data checksum computed so far.
Top
Remarks

2-byte (16-bit) CRC: The generating polynomial is

16 15 2 1

G(X) = X + X + X + X

See Also

Reference

GSF.IO.Checksums Namespace


Crc16 Constructor

Grid Solutions Framework Crc16 Constructor
Overload List
 | Name | Description
Public method | Crc16 | Creates a new instance of the Crc16 class. The checksum starts off with a value of 0x0000.
Public method | Crc16(ChecksumType) | Creates a new instance of the Crc16 class.
Top
See Also

Reference

Crc16 Class
GSF.IO.Checksums Namespace


Crc16 Constructor

Grid Solutions Framework Crc16 Constructor
Creates a new instance of the Crc16 class. The checksum starts off with a value of 0x0000.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Crc16()
Public Sub New
new : unit -> Crc16
GSF.IO.Checksums.Crc16 = function();
public:
Crc16()
See Also

Reference

Crc16 Class
Crc16 Overload
GSF.IO.Checksums Namespace


Crc16 Constructor (ChecksumType)

Grid Solutions Framework Crc16 Constructor (ChecksumType)
Creates a new instance of the Crc16 class.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Crc16(
    ChecksumType checksumType
)
Public Sub New (
    checksumType As ChecksumType
)
new :
        checksumType : ChecksumType -> Crc16
GSF.IO.Checksums.Crc16 = function(checksumType);
public:
Crc16(
    ChecksumType checksumType
)

Parameters

checksumType
Type: GSF.IO.ChecksumsChecksumType
Type of calculation to perform, CRC-16 or ModBus.
See Also

Reference

Crc16 Class
Crc16 Overload
GSF.IO.Checksums Namespace


Crc16 Methods

Grid Solutions Framework Crc16 Methods

The Crc16 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the CRC-16 data checksum as if no update was ever called.
Public method | Reset(ChecksumType) | Resets the CRC-16 data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the byte value.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Crc16 Class
GSF.IO.Checksums Namespace


Crc16.Reset Method

Grid Solutions Framework Crc16Reset Method
Overload List
 | Name | Description
Public method | Reset | Resets the CRC-16 data checksum as if no update was ever called.
Public method | Reset(ChecksumType) | Resets the CRC-16 data checksum as if no update was ever called.
Top
See Also

Reference

Crc16 Class
GSF.IO.Checksums Namespace


Crc16.Reset Method

Grid Solutions Framework Crc16Reset Method
Resets the CRC-16 data checksum as if no update was ever called.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

Crc16 Class
Reset Overload
GSF.IO.Checksums Namespace


Crc16.Reset Method (ChecksumType)

Grid Solutions Framework Crc16Reset Method (ChecksumType)
Resets the CRC-16 data checksum as if no update was ever called.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset(
    ChecksumType checksumType
)
Public Sub Reset (
    checksumType As ChecksumType
)
member Reset :
        checksumType : ChecksumType -> unit

function Reset(checksumType);
public:
void Reset(
    ChecksumType checksumType
)

Parameters

checksumType
Type: GSF.IO.ChecksumsChecksumType
Type of CRC calculation. CRC-16 resets to 0x0000, ModBus resets to 0xFFFF
See Also

Reference

Crc16 Class
Reset Overload
GSF.IO.Checksums Namespace


Crc16.Update Method

Grid Solutions Framework Crc16Update Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with the byte value.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
See Also

Reference

Crc16 Class
GSF.IO.Checksums Namespace


Crc16.Update Method (Byte)

Grid Solutions Framework Crc16Update Method (Byte)
Updates the checksum with the byte value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte value
)
Public Sub Update (
    value As Byte
)
member Update :
        value : byte -> unit

function Update(value);
public:
void Update(
    unsigned char value
)

Parameters

value
Type: SystemByte
The Byte value to use for the update.
See Also

Reference

Crc16 Class
Update Overload
GSF.IO.Checksums Namespace


Crc16.Update Method (Byte[])

Grid Solutions Framework Crc16Update Method (Byte)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
buffer an array of bytes
See Also

Reference

Crc16 Class
Update Overload
GSF.IO.Checksums Namespace


Crc16.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework Crc16Update Method (Byte, Int32, Int32)
Adds the byte array to the data checksum.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
The buffer which contains the data
offset
Type: SystemInt32
The offset in the buffer where the data starts
count
Type: SystemInt32
The number of data bytes to update the CRC with.
See Also

Reference

Crc16 Class
Update Overload
GSF.IO.Checksums Namespace


Crc16 Properties

Grid Solutions Framework Crc16 Properties

The Crc16 type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the CRC-16 data checksum computed so far.
Top
See Also

Reference

Crc16 Class
GSF.IO.Checksums Namespace


Crc16.Value Property

Grid Solutions Framework Crc16Value Property
Returns the CRC-16 data checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Value { get; set; }
Public Property Value As UShort
    Get
    Set
member Value : uint16 with get, set

function get_Value();
function set_Value(value);
public:
property unsigned short Value {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

Crc16 Class
GSF.IO.Checksums Namespace


Crc32 Class

Grid Solutions Framework Crc32 Class
Generates a byte-wise 32-bit CRC calculation.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsCrc32

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class Crc32
Public NotInheritable Class Crc32
[<SealedAttribute>]
type Crc32 =  class end
GSF.IO.Checksums.Crc32 = function();

Type.createClass(
    'GSF.IO.Checksums.Crc32');
public ref class Crc32 sealed

The Crc32 type exposes the following members.

Constructors
 | Name | Description
Public method | Crc32 | Initializes a new instance of the Crc32 class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the CRC-32 data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Int32) | Updates the checksum with the integer value.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the CRC-32 data checksum computed so far.
Top
See Also

Reference

GSF.IO.Checksums Namespace


Crc32 Constructor

Grid Solutions Framework Crc32 Constructor
Initializes a new instance of the Crc32 class

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Crc32()
Public Sub New
new : unit -> Crc32
GSF.IO.Checksums.Crc32 = function();
public:
Crc32()
See Also

Reference

Crc32 Class
GSF.IO.Checksums Namespace


Crc32 Methods

Grid Solutions Framework Crc32 Methods

The Crc32 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the CRC-32 data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Int32) | Updates the checksum with the integer value.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Crc32 Class
GSF.IO.Checksums Namespace


Crc32.Reset Method

Grid Solutions Framework Crc32Reset Method
Resets the CRC-32 data checksum as if no update was ever called.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

Crc32 Class
GSF.IO.Checksums Namespace


Crc32.Update Method

Grid Solutions Framework Crc32Update Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Int32) | Updates the checksum with the integer value.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
See Also

Reference

Crc32 Class
GSF.IO.Checksums Namespace


Crc32.Update Method (Byte[])

Grid Solutions Framework Crc32Update Method (Byte)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
buffer an array of bytes
See Also

Reference

Crc32 Class
Update Overload
GSF.IO.Checksums Namespace


Crc32.Update Method (Int32)

Grid Solutions Framework Crc32Update Method (Int32)
Updates the checksum with the integer value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    int value
)
Public Sub Update (
    value As Integer
)
member Update :
        value : int -> unit

function Update(value);
public:
void Update(
    int value
)

Parameters

value
Type: SystemInt32
The Byte value to use for the update.
See Also

Reference

Crc32 Class
Update Overload
GSF.IO.Checksums Namespace


Crc32.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework Crc32Update Method (Byte, Int32, Int32)
Adds the byte array to the data checksum.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
The buffer which contains the data
offset
Type: SystemInt32
The offset in the buffer where the data starts
count
Type: SystemInt32
The number of data bytes to update the CRC with.
See Also

Reference

Crc32 Class
Update Overload
GSF.IO.Checksums Namespace


Crc32 Properties

Grid Solutions Framework Crc32 Properties

The Crc32 type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the CRC-32 data checksum computed so far.
Top
See Also

Reference

Crc32 Class
GSF.IO.Checksums Namespace


Crc32.Value Property

Grid Solutions Framework Crc32Value Property
Returns the CRC-32 data checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Value { get; set; }
Public Property Value As UInteger
    Get
    Set
member Value : uint32 with get, set

function get_Value();
function set_Value(value);
public:
property unsigned int Value {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

Crc32 Class
GSF.IO.Checksums Namespace


CrcCCITT Class

Grid Solutions Framework CrcCCITT Class
Generates a 16-bit CRC-CCITT checksum.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsCrcCCITT

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class CrcCCITT
Public NotInheritable Class CrcCCITT
[<SealedAttribute>]
type CrcCCITT =  class end
GSF.IO.Checksums.CrcCCITT = function();

Type.createClass(
    'GSF.IO.Checksums.CrcCCITT');
public ref class CrcCCITT sealed

The CrcCCITT type exposes the following members.

Constructors
 | Name | Description
Public method | CrcCCITT | Creates a new instance of the CrcCCITT class. The checksum starts off with a value of 0xFFFF.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the CRC-CCITT data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the int bval.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the CRCCCITT data checksum computed so far.
Top
Remarks
This is a table based 16-bit CRC popular for modem protocols defined for use by the Consultative Committee on International Telegraphy and Telephony (CCITT)
See Also

Reference

GSF.IO.Checksums Namespace


CrcCCITT Constructor

Grid Solutions Framework CrcCCITT Constructor
Creates a new instance of the CrcCCITT class. The checksum starts off with a value of 0xFFFF.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CrcCCITT()
Public Sub New
new : unit -> CrcCCITT
GSF.IO.Checksums.CrcCCITT = function();
public:
CrcCCITT()
See Also

Reference

CrcCCITT Class
GSF.IO.Checksums Namespace


CrcCCITT Methods

Grid Solutions Framework CrcCCITT Methods

The CrcCCITT type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the CRC-CCITT data checksum as if no update was ever called.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with the int bval.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CrcCCITT Class
GSF.IO.Checksums Namespace


CrcCCITT.Reset Method

Grid Solutions Framework CrcCCITTReset Method
Resets the CRC-CCITT data checksum as if no update was ever called.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

CrcCCITT Class
GSF.IO.Checksums Namespace


CrcCCITT.Update Method

Grid Solutions Framework CrcCCITTUpdate Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with the int bval.
Public method | Update(Byte) | Updates the checksum with the bytes taken from the array.
Public method | Update(Byte, Int32, Int32) | Adds the byte array to the data checksum.
Top
See Also

Reference

CrcCCITT Class
GSF.IO.Checksums Namespace


CrcCCITT.Update Method (Byte)

Grid Solutions Framework CrcCCITTUpdate Method (Byte)
Updates the checksum with the int bval.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte value
)
Public Sub Update (
    value As Byte
)
member Update :
        value : byte -> unit

function Update(value);
public:
void Update(
    unsigned char value
)

Parameters

value
Type: SystemByte
The Byte value to use for the update.
See Also

Reference

CrcCCITT Class
Update Overload
GSF.IO.Checksums Namespace


CrcCCITT.Update Method (Byte[])

Grid Solutions Framework CrcCCITTUpdate Method (Byte)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
buffer an array of bytes
See Also

Reference

CrcCCITT Class
Update Overload
GSF.IO.Checksums Namespace


CrcCCITT.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework CrcCCITTUpdate Method (Byte, Int32, Int32)
Adds the byte array to the data checksum.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
The buffer which contains the data
offset
Type: SystemInt32
The offset in the buffer where the data starts
count
Type: SystemInt32
The number of data bytes to update the CRC with.
See Also

Reference

CrcCCITT Class
Update Overload
GSF.IO.Checksums Namespace


CrcCCITT Properties

Grid Solutions Framework CrcCCITT Properties

The CrcCCITT type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the CRCCCITT data checksum computed so far.
Top
See Also

Reference

CrcCCITT Class
GSF.IO.Checksums Namespace


CrcCCITT.Value Property

Grid Solutions Framework CrcCCITTValue Property
Returns the CRCCCITT data checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Value { get; set; }
Public Property Value As UShort
    Get
    Set
member Value : uint16 with get, set

function get_Value();
function set_Value(value);
public:
property unsigned short Value {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CrcCCITT Class
GSF.IO.Checksums Namespace


Xor16 Class

Grid Solutions Framework Xor16 Class
Calculates word length (16-bit) XOR-based check-sum on specified portion of a buffer.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsXor16

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class Xor16
Public NotInheritable Class Xor16
[<SealedAttribute>]
type Xor16 =  class end
GSF.IO.Checksums.Xor16 = function();

Type.createClass(
    'GSF.IO.Checksums.Xor16');
public ref class Xor16 sealed

The Xor16 type exposes the following members.

Constructors
 | Name | Description
Public method | Xor16 | Creates a new instance of the Xor16Bit class. The checksum starts off with a value of 0.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt16) | Updates the checksum with a ushort value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the Xor 16-bit checksum computed so far.
Top
See Also

Reference

GSF.IO.Checksums Namespace


Xor16 Constructor

Grid Solutions Framework Xor16 Constructor
Creates a new instance of the Xor16Bit class. The checksum starts off with a value of 0.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Xor16()
Public Sub New
new : unit -> Xor16
GSF.IO.Checksums.Xor16 = function();
public:
Xor16()
See Also

Reference

Xor16 Class
GSF.IO.Checksums Namespace


Xor16 Methods

Grid Solutions Framework Xor16 Methods

The Xor16 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt16) | Updates the checksum with a ushort value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Xor16 Class
GSF.IO.Checksums Namespace


Xor16.Reset Method

Grid Solutions Framework Xor16Reset Method
Resets the checksum to the initial value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

Xor16 Class
GSF.IO.Checksums Namespace


Xor16.Update Method

Grid Solutions Framework Xor16Update Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt16) | Updates the checksum with a ushort value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
See Also

Reference

Xor16 Class
GSF.IO.Checksums Namespace


Xor16.Update Method (Byte[])

Grid Solutions Framework Xor16Update Method (Byte)
Updates the checksum with an array of bytes.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The source of the data to update with.
See Also

Reference

Xor16 Class
Update Overload
GSF.IO.Checksums Namespace


Xor16.Update Method (UInt16)

Grid Solutions Framework Xor16Update Method (UInt16)
Updates the checksum with a ushort value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    ushort value
)
Public Sub Update (
    value As UShort
)
member Update :
        value : uint16 -> unit

function Update(value);
public:
void Update(
    unsigned short value
)

Parameters

value
Type: SystemUInt16
The UInt16 value to use for the update.
See Also

Reference

Xor16 Class
Update Overload
GSF.IO.Checksums Namespace


Xor16.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework Xor16Update Method (Byte, Int32, Int32)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
an array of bytes
offset
Type: SystemInt32
the start of the data used for this update
count
Type: SystemInt32
the number of bytes to use for this update
See Also

Reference

Xor16 Class
Update Overload
GSF.IO.Checksums Namespace


Xor16 Properties

Grid Solutions Framework Xor16 Properties

The Xor16 type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the Xor 16-bit checksum computed so far.
Top
See Also

Reference

Xor16 Class
GSF.IO.Checksums Namespace


Xor16.Value Property

Grid Solutions Framework Xor16Value Property
Returns the Xor 16-bit checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Value { get; }
Public ReadOnly Property Value As UShort
    Get
member Value : uint16 with get

function get_Value();

public:
property unsigned short Value {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

Xor16 Class
GSF.IO.Checksums Namespace


Xor32 Class

Grid Solutions Framework Xor32 Class
Calculates double-word length (32-bit) XOR-based check-sum on specified portion of a buffer.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsXor32

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class Xor32
Public NotInheritable Class Xor32
[<SealedAttribute>]
type Xor32 =  class end
GSF.IO.Checksums.Xor32 = function();

Type.createClass(
    'GSF.IO.Checksums.Xor32');
public ref class Xor32 sealed

The Xor32 type exposes the following members.

Constructors
 | Name | Description
Public method | Xor32 | Creates a new instance of the Xor32Bit class. The checksum starts off with a value of 0.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt32) | Updates the checksum with a uint value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the Xor 32-bit checksum computed so far.
Top
See Also

Reference

GSF.IO.Checksums Namespace


Xor32 Constructor

Grid Solutions Framework Xor32 Constructor
Creates a new instance of the Xor32Bit class. The checksum starts off with a value of 0.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Xor32()
Public Sub New
new : unit -> Xor32
GSF.IO.Checksums.Xor32 = function();
public:
Xor32()
See Also

Reference

Xor32 Class
GSF.IO.Checksums Namespace


Xor32 Methods

Grid Solutions Framework Xor32 Methods

The Xor32 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt32) | Updates the checksum with a uint value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Xor32 Class
GSF.IO.Checksums Namespace


Xor32.Reset Method

Grid Solutions Framework Xor32Reset Method
Resets the checksum to the initial value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

Xor32 Class
GSF.IO.Checksums Namespace


Xor32.Update Method

Grid Solutions Framework Xor32Update Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt32) | Updates the checksum with a uint value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
See Also

Reference

Xor32 Class
GSF.IO.Checksums Namespace


Xor32.Update Method (Byte[])

Grid Solutions Framework Xor32Update Method (Byte)
Updates the checksum with an array of bytes.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The source of the data to update with.
See Also

Reference

Xor32 Class
Update Overload
GSF.IO.Checksums Namespace


Xor32.Update Method (UInt32)

Grid Solutions Framework Xor32Update Method (UInt32)
Updates the checksum with a uint value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    uint value
)
Public Sub Update (
    value As UInteger
)
member Update :
        value : uint32 -> unit

function Update(value);
public:
void Update(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
The UInt32 value to use for the update.
See Also

Reference

Xor32 Class
Update Overload
GSF.IO.Checksums Namespace


Xor32.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework Xor32Update Method (Byte, Int32, Int32)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
an array of bytes
offset
Type: SystemInt32
the start of the data used for this update
count
Type: SystemInt32
the number of bytes to use for this update
See Also

Reference

Xor32 Class
Update Overload
GSF.IO.Checksums Namespace


Xor32 Properties

Grid Solutions Framework Xor32 Properties

The Xor32 type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the Xor 32-bit checksum computed so far.
Top
See Also

Reference

Xor32 Class
GSF.IO.Checksums Namespace


Xor32.Value Property

Grid Solutions Framework Xor32Value Property
Returns the Xor 32-bit checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Value { get; }
Public ReadOnly Property Value As UInteger
    Get
member Value : uint32 with get

function get_Value();

public:
property unsigned int Value {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

Xor32 Class
GSF.IO.Checksums Namespace


Xor64 Class

Grid Solutions Framework Xor64 Class
Calculates quad-word length (64-bit) XOR-based check-sum on specified portion of a buffer.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsXor64

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class Xor64
Public NotInheritable Class Xor64
[<SealedAttribute>]
type Xor64 =  class end
GSF.IO.Checksums.Xor64 = function();

Type.createClass(
    'GSF.IO.Checksums.Xor64');
public ref class Xor64 sealed

The Xor64 type exposes the following members.

Constructors
 | Name | Description
Public method | Xor64 | Creates a new instance of the Xor64Bit class. The checksum starts off with a value of 0.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt64) | Updates the checksum with a ulong value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the Xor 64-bit checksum computed so far.
Top
See Also

Reference

GSF.IO.Checksums Namespace


Xor64 Constructor

Grid Solutions Framework Xor64 Constructor
Creates a new instance of the Xor64Bit class. The checksum starts off with a value of 0.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Xor64()
Public Sub New
new : unit -> Xor64
GSF.IO.Checksums.Xor64 = function();
public:
Xor64()
See Also

Reference

Xor64 Class
GSF.IO.Checksums Namespace


Xor64 Methods

Grid Solutions Framework Xor64 Methods

The Xor64 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt64) | Updates the checksum with a ulong value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Xor64 Class
GSF.IO.Checksums Namespace


Xor64.Reset Method

Grid Solutions Framework Xor64Reset Method
Resets the checksum to the initial value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

Xor64 Class
GSF.IO.Checksums Namespace


Xor64.Update Method

Grid Solutions Framework Xor64Update Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(UInt64) | Updates the checksum with a ulong value.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
See Also

Reference

Xor64 Class
GSF.IO.Checksums Namespace


Xor64.Update Method (Byte[])

Grid Solutions Framework Xor64Update Method (Byte)
Updates the checksum with an array of bytes.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The source of the data to update with.
See Also

Reference

Xor64 Class
Update Overload
GSF.IO.Checksums Namespace


Xor64.Update Method (UInt64)

Grid Solutions Framework Xor64Update Method (UInt64)
Updates the checksum with a ulong value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    ulong value
)
Public Sub Update (
    value As ULong
)
member Update :
        value : uint64 -> unit

function Update(value);
public:
void Update(
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
The UInt64 value to use for the update.
See Also

Reference

Xor64 Class
Update Overload
GSF.IO.Checksums Namespace


Xor64.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework Xor64Update Method (Byte, Int32, Int32)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
an array of bytes
offset
Type: SystemInt32
the start of the data used for this update
count
Type: SystemInt32
the number of bytes to use for this update
See Also

Reference

Xor64 Class
Update Overload
GSF.IO.Checksums Namespace


Xor64 Properties

Grid Solutions Framework Xor64 Properties

The Xor64 type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the Xor 64-bit checksum computed so far.
Top
See Also

Reference

Xor64 Class
GSF.IO.Checksums Namespace


Xor64.Value Property

Grid Solutions Framework Xor64Value Property
Returns the Xor 64-bit checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong Value { get; }
Public ReadOnly Property Value As ULong
    Get
member Value : uint64 with get

function get_Value();

public:
property unsigned long long Value {
    unsigned long long get ();
}

Property Value

Type: UInt64
See Also

Reference

Xor64 Class
GSF.IO.Checksums Namespace


Xor8 Class

Grid Solutions Framework Xor8 Class
Calculates byte length (8-bit) XOR-based check-sum on specified portion of a buffer.
Inheritance Hierarchy
SystemObject
GSF.IO.ChecksumsXor8

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class Xor8
Public NotInheritable Class Xor8
[<SealedAttribute>]
type Xor8 =  class end
GSF.IO.Checksums.Xor8 = function();

Type.createClass(
    'GSF.IO.Checksums.Xor8');
public ref class Xor8 sealed

The Xor8 type exposes the following members.

Constructors
 | Name | Description
Public method | Xor8 | Creates a new instance of the Xor8Bit class. The checksum starts off with a value of 0.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with a byte value.
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Returns the Xor 8-bit checksum computed so far.
Top
See Also

Reference

GSF.IO.Checksums Namespace


Xor8 Constructor

Grid Solutions Framework Xor8 Constructor
Creates a new instance of the Xor8Bit class. The checksum starts off with a value of 0.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Xor8()
Public Sub New
new : unit -> Xor8
GSF.IO.Checksums.Xor8 = function();
public:
Xor8()
See Also

Reference

Xor8 Class
GSF.IO.Checksums Namespace


Xor8 Methods

Grid Solutions Framework Xor8 Methods

The Xor8 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Reset | Resets the checksum to the initial value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update(Byte) | Updates the checksum with a byte value.
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Xor8 Class
GSF.IO.Checksums Namespace


Xor8.Reset Method

Grid Solutions Framework Xor8Reset Method
Resets the checksum to the initial value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

Xor8 Class
GSF.IO.Checksums Namespace


Xor8.Update Method

Grid Solutions Framework Xor8Update Method
Overload List
 | Name | Description
Public method | Update(Byte) | Updates the checksum with a byte value.
Public method | Update(Byte) | Updates the checksum with an array of bytes.
Public method | Update(Byte, Int32, Int32) | Updates the checksum with the bytes taken from the array.
Top
See Also

Reference

Xor8 Class
GSF.IO.Checksums Namespace


Xor8.Update Method (Byte)

Grid Solutions Framework Xor8Update Method (Byte)
Updates the checksum with a byte value.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte value
)
Public Sub Update (
    value As Byte
)
member Update :
        value : byte -> unit

function Update(value);
public:
void Update(
    unsigned char value
)

Parameters

value
Type: SystemByte
The Byte value to use for the update.
See Also

Reference

Xor8 Class
Update Overload
GSF.IO.Checksums Namespace


Xor8.Update Method (Byte[])

Grid Solutions Framework Xor8Update Method (Byte)
Updates the checksum with an array of bytes.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer
)
Public Sub Update (
    buffer As Byte()
)
member Update :
        buffer : byte[] -> unit

function Update(buffer);
public:
void Update(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The source of the data to update with.
See Also

Reference

Xor8 Class
Update Overload
GSF.IO.Checksums Namespace


Xor8.Update Method (Byte[], Int32, Int32)

Grid Solutions Framework Xor8Update Method (Byte, Int32, Int32)
Updates the checksum with the bytes taken from the array.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Update (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Update :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Update(buffer, offset, count);
public:
void Update(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
an array of bytes
offset
Type: SystemInt32
the start of the data used for this update
count
Type: SystemInt32
the number of bytes to use for this update
See Also

Reference

Xor8 Class
Update Overload
GSF.IO.Checksums Namespace


Xor8 Properties

Grid Solutions Framework Xor8 Properties

The Xor8 type exposes the following members.

Properties
 | Name | Description
Public property | Value | Returns the Xor 8-bit checksum computed so far.
Top
See Also

Reference

Xor8 Class
GSF.IO.Checksums Namespace


Xor8.Value Property

Grid Solutions Framework Xor8Value Property
Returns the Xor 8-bit checksum computed so far.

Namespace: GSF.IO.Checksums
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Value { get; }
Public ReadOnly Property Value As Byte
    Get
member Value : byte with get

function get_Value();

public:
property unsigned char Value {
    unsigned char get ();
}

Property Value

Type: Byte
See Also

Reference

Xor8 Class
GSF.IO.Checksums Namespace


GSF.IO.Compression Namespace

Grid Solutions Framework GSF.IO.Compression Namespace
Contains classes and extension functions used to simplify and standardize using compression in applications.
Classes
 | Class | Description
Public class | CompressionExtensions | Defines extension functions related to compression.
Public class | FileCompressor | Performs basic compression and decompression on a file.
Public class | PatternCompressor | Defines functions used for high-speed pattern compression against native types.
Public class | PatternDecompressor | Defines functions for decompression of data compressed by the PatternCompressor.
Enumerations
 | Enumeration | Description
Public enumeration | CompressionStrength | Level of compression enumeration.


CompressionExtensions Class

Grid Solutions Framework CompressionExtensions Class
Defines extension functions related to compression.
Inheritance Hierarchy
SystemObject
GSF.IO.CompressionCompressionExtensions

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class CompressionExtensions
<ExtensionAttribute>
Public NotInheritable Class CompressionExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CompressionExtensions =  class end
GSF.IO.Compression.CompressionExtensions = function();

Type.createClass(
    'GSF.IO.Compression.CompressionExtensions');
[ExtensionAttribute]
public ref class CompressionExtensions abstract sealed

The CompressionExtensions type exposes the following members.

Methods
Name | Description
Compress(Byte) | Compress a byte array using standard compression method.
Compress(Byte, CompressionStrength) | Compress a byte array using specified compression method.
Compress(Stream, CompressionStrength) | Compress a stream using specified compression strength.
Compress(Byte, Int32, Int32, CompressionStrength) | Compress a byte array using specified compression method.
Compress(Stream, Stream, CompressionStrength, ActionProcessProgressInt64) | Compress a stream onto given output stream using specified compression strength.
Decompress(Byte) | Decompress a byte array.
Decompress(Stream) | Decompress a stream.
Decompress(Byte, Int32, Int32) | Decompress a byte array.
Decompress(Stream, Stream, ActionProcessProgressInt64) | Decompress a stream onto given output stream.
Top
Fields
Name | Description
BufferSize | Default compression buffer size.
CompressionVersion | Needed version of this library to uncompress stream (1.0.0 stored as byte 100).
Top
See Also

Reference

GSF.IO.Compression Namespace


CompressionExtensions Fields

Grid Solutions Framework CompressionExtensions Fields

The CompressionExtensions type exposes the following members.

Fields
Name | Description
BufferSize | Default compression buffer size.
CompressionVersion | Needed version of this library to uncompress stream (1.0.0 stored as byte 100).
Top
See Also

Reference

CompressionExtensions Class
GSF.IO.Compression Namespace


CompressionExtensions.BufferSize Field

Grid Solutions Framework CompressionExtensionsBufferSize Field
Default compression buffer size.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int BufferSize
Public Const BufferSize As Integer
static val mutable BufferSize: int
var GSF.IO.Compression.CompressionExtensions.BufferSize
public:
literal int BufferSize

Field Value

Type: Int32
See Also

Reference

CompressionExtensions Class
GSF.IO.Compression Namespace


CompressionExtensions.CompressionVersion Field

Grid Solutions Framework CompressionExtensionsCompressionVersion Field
Needed version of this library to uncompress stream (1.0.0 stored as byte 100).

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte CompressionVersion
Public Const CompressionVersion As Byte
static val mutable CompressionVersion: byte
var GSF.IO.Compression.CompressionExtensions.CompressionVersion
public:
literal unsigned char CompressionVersion

Field Value

Type: Byte
See Also

Reference

CompressionExtensions Class
GSF.IO.Compression Namespace


CompressionExtensions Methods

Grid Solutions Framework CompressionExtensions Methods
Methods
Name | Description
Compress(Byte) | Compress a byte array using standard compression method.
Compress(Byte, CompressionStrength) | Compress a byte array using specified compression method.
Compress(Stream, CompressionStrength) | Compress a stream using specified compression strength.
Compress(Byte, Int32, Int32, CompressionStrength) | Compress a byte array using specified compression method.
Compress(Stream, Stream, CompressionStrength, ActionProcessProgressInt64) | Compress a stream onto given output stream using specified compression strength.
Decompress(Byte) | Decompress a byte array.
Decompress(Stream) | Decompress a stream.
Decompress(Byte, Int32, Int32) | Decompress a byte array.
Decompress(Stream, Stream, ActionProcessProgressInt64) | Decompress a stream onto given output stream.
Top
See Also

Reference

CompressionExtensions Class
GSF.IO.Compression Namespace


CompressionExtensions.Compress Method

Grid Solutions Framework CompressionExtensionsCompress Method
Overload List
Name | Description
Compress(Byte) | Compress a byte array using standard compression method.
Compress(Byte, CompressionStrength) | Compress a byte array using specified compression method.
Compress(Stream, CompressionStrength) | Compress a stream using specified compression strength.
Compress(Byte, Int32, Int32, CompressionStrength) | Compress a byte array using specified compression method.
Compress(Stream, Stream, CompressionStrength, ActionProcessProgressInt64) | Compress a stream onto given output stream using specified compression strength.
Top
See Also

Reference

CompressionExtensions Class
GSF.IO.Compression Namespace


CompressionExtensions.Compress Method (Byte[])

Grid Solutions Framework CompressionExtensionsCompress Method (Byte)
Compress a byte array using standard compression method.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Compress(
    this byte[] source
)
<ExtensionAttribute>
Public Shared Function Compress (
    source As Byte()
) As Byte()
static member Compress :
        source : byte[] -> byte[]

GSF.IO.Compression.CompressionExtensions.Compress = function(source);
public:
[ExtensionAttribute]
static array<unsigned char>^ Compress(
    array<unsigned char>^ source
)

Parameters

source
Type: SystemByte
The Byte array to compress.

Return Value

Type: Byte
A compressed version of the source Byte array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompressionExtensions Class
Compress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Compress Method (Byte[], CompressionStrength)

Grid Solutions Framework CompressionExtensionsCompress Method (Byte, CompressionStrength)
Compress a byte array using specified compression method.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Compress(
    this byte[] source,
    CompressionStrength strength
)
<ExtensionAttribute>
Public Shared Function Compress (
    source As Byte(),
    strength As CompressionStrength
) As Byte()
static member Compress :
        source : byte[] *
        strength : CompressionStrength -> byte[]

GSF.IO.Compression.CompressionExtensions.Compress = function(source, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Compress(
    array<unsigned char>^ source,
    CompressionStrength strength
)

Parameters

source
Type: SystemByte
The Byte array to compress.
strength
Type: GSF.IO.CompressionCompressionStrength
The specified CompressionStrength.

Return Value

Type: Byte
A compressed version of the source Byte array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompressionExtensions Class
Compress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Compress Method (Stream, CompressionStrength)

Grid Solutions Framework CompressionExtensionsCompress Method (Stream, CompressionStrength)
Compress a stream using specified compression strength.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MemoryStream Compress(
    this Stream source,
    CompressionStrength strength
)
<ExtensionAttribute>
Public Shared Function Compress (
    source As Stream,
    strength As CompressionStrength
) As MemoryStream
static member Compress :
        source : Stream *
        strength : CompressionStrength -> MemoryStream

GSF.IO.Compression.CompressionExtensions.Compress = function(source, strength);
public:
[ExtensionAttribute]
static MemoryStream^ Compress(
    Stream^ source,
    CompressionStrength strength
)

Parameters

source
Type: System.IOStream
The Stream to compress.
strength
Type: GSF.IO.CompressionCompressionStrength
The CompressionStrength of the compression.

Return Value

Type: MemoryStream
Returns a MemoryStream of the compressed Stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This returns a memory stream of the compressed results, if the incoming stream is very large this will consume a large amount memory. In this case use the overload that takes the destination stream as a parameter instead.
See Also

Reference

CompressionExtensions Class
Compress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Compress Method (Byte[], Int32, Int32, CompressionStrength)

Grid Solutions Framework CompressionExtensionsCompress Method (Byte, Int32, Int32, CompressionStrength)
Compress a byte array using specified compression method.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Compress(
    this byte[] source,
    int startIndex,
    int length,
    CompressionStrength strength
)
<ExtensionAttribute>
Public Shared Function Compress (
    source As Byte(),
    startIndex As Integer,
    length As Integer,
    strength As CompressionStrength
) As Byte()
static member Compress :
        source : byte[] *
        startIndex : int *
        length : int *
        strength : CompressionStrength -> byte[]

GSF.IO.Compression.CompressionExtensions.Compress = function(source, startIndex, length, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Compress(
    array<unsigned char>^ source,
    int startIndex,
    int length,
    CompressionStrength strength
)

Parameters

source
Type: SystemByte
The Byte array to compress.
startIndex
Type: SystemInt32
An Int32 representing the start index of the byte array.
length
Type: SystemInt32
The number of bytes to read into the byte array for compression.
strength
Type: GSF.IO.CompressionCompressionStrength
The specified CompressionStrength.

Return Value

Type: Byte
A compressed version of the source Byte array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompressionExtensions Class
Compress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Compress Method (Stream, Stream, CompressionStrength, Action(ProcessProgress(Int64)))

Grid Solutions Framework CompressionExtensionsCompress Method (Stream, Stream, CompressionStrength, ActionProcessProgressInt64)
Compress a stream onto given output stream using specified compression strength.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Compress(
    this Stream source,
    Stream destination,
    CompressionStrength strength,
    Action<ProcessProgress<long>> progressHandler
)
<ExtensionAttribute>
Public Shared Sub Compress (
    source As Stream,
    destination As Stream,
    strength As CompressionStrength,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member Compress :
        source : Stream *
        destination : Stream *
        strength : CompressionStrength *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.IO.Compression.CompressionExtensions.Compress = function(source, destination, strength, progressHandler);
public:
[ExtensionAttribute]
static void Compress(
    Stream^ source,
    Stream^ destination,
    CompressionStrength strength,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

source
Type: System.IOStream
The Stream to compress.
destination
Type: System.IOStream
The Stream destination.
strength
Type: GSF.IO.CompressionCompressionStrength
The CompressionStrength of the compression.
progressHandler
Type: SystemAction ProcessProgress Int64
The progress handler to check progress.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompressionExtensions Class
Compress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Decompress Method

Grid Solutions Framework CompressionExtensionsDecompress Method
Overload List
Name | Description
Decompress(Byte) | Decompress a byte array.
Decompress(Stream) | Decompress a stream.
Decompress(Byte, Int32, Int32) | Decompress a byte array.
Decompress(Stream, Stream, ActionProcessProgressInt64) | Decompress a stream onto given output stream.
Top
See Also

Reference

CompressionExtensions Class
GSF.IO.Compression Namespace


CompressionExtensions.Decompress Method (Byte[])

Grid Solutions Framework CompressionExtensionsDecompress Method (Byte)
Decompress a byte array.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Decompress(
    this byte[] source
)
<ExtensionAttribute>
Public Shared Function Decompress (
    source As Byte()
) As Byte()
static member Decompress :
        source : byte[] -> byte[]

GSF.IO.Compression.CompressionExtensions.Decompress = function(source);
public:
[ExtensionAttribute]
static array<unsigned char>^ Decompress(
    array<unsigned char>^ source
)

Parameters

source
Type: SystemByte
The Byte array to decompress.

Return Value

Type: Byte
A decompressed version of the source Byte array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompressionExtensions Class
Decompress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Decompress Method (Stream)

Grid Solutions Framework CompressionExtensionsDecompress Method (Stream)
Decompress a stream.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MemoryStream Decompress(
    this Stream source
)
<ExtensionAttribute>
Public Shared Function Decompress (
    source As Stream
) As MemoryStream
static member Decompress :
        source : Stream -> MemoryStream

GSF.IO.Compression.CompressionExtensions.Decompress = function(source);
public:
[ExtensionAttribute]
static MemoryStream^ Decompress(
    Stream^ source
)

Parameters

source
Type: System.IOStream
A Stream source to decompress.

Return Value

Type: MemoryStream
A MemoryStream representing the decompressed source.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This returns a memory stream of the uncompressed results, if the incoming stream is very large this will consume a large amount memory. In this case use the overload that takes the destination stream as a parameter instead.
See Also

Reference

CompressionExtensions Class
Decompress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Decompress Method (Byte[], Int32, Int32)

Grid Solutions Framework CompressionExtensionsDecompress Method (Byte, Int32, Int32)
Decompress a byte array.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Decompress(
    this byte[] source,
    int startIndex,
    int length
)
<ExtensionAttribute>
Public Shared Function Decompress (
    source As Byte(),
    startIndex As Integer,
    length As Integer
) As Byte()
static member Decompress :
        source : byte[] *
        startIndex : int *
        length : int -> byte[]

GSF.IO.Compression.CompressionExtensions.Decompress = function(source, startIndex, length);
public:
[ExtensionAttribute]
static array<unsigned char>^ Decompress(
    array<unsigned char>^ source,
    int startIndex,
    int length
)

Parameters

source
Type: SystemByte
The Byte array to decompress.
startIndex
Type: SystemInt32
An Int32 representing the start index of the byte array.
length
Type: SystemInt32
The number of bytes to read into the byte array for compression.

Return Value

Type: Byte
A decompressed Byte array.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompressionExtensions Class
Decompress Overload
GSF.IO.Compression Namespace


CompressionExtensions.Decompress Method (Stream, Stream, Action(ProcessProgress(Int64)))

Grid Solutions Framework CompressionExtensionsDecompress Method (Stream, Stream, ActionProcessProgressInt64)
Decompress a stream onto given output stream.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Decompress(
    this Stream source,
    Stream destination,
    Action<ProcessProgress<long>> progressHandler
)
<ExtensionAttribute>
Public Shared Sub Decompress (
    source As Stream,
    destination As Stream,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member Decompress :
        source : Stream *
        destination : Stream *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.IO.Compression.CompressionExtensions.Decompress = function(source, destination, progressHandler);
public:
[ExtensionAttribute]
static void Decompress(
    Stream^ source,
    Stream^ destination,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

source
Type: System.IOStream
A source Stream to decompress.
destination
Type: System.IOStream
The destination Stream to decompress to.
progressHandler
Type: SystemAction ProcessProgress Int64
A Action handler to monitor the action's progress.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompressionExtensions Class
Decompress Overload
GSF.IO.Compression Namespace


CompressionStrength Enumeration

Grid Solutions Framework CompressionStrength Enumeration
Level of compression enumeration.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum CompressionStrength
Public Enumeration CompressionStrength
type CompressionStrength
GSF.IO.Compression.CompressionStrength = function();
GSF.IO.Compression.CompressionStrength.createEnum('GSF.IO.Compression.CompressionStrength', false);
public enum class CompressionStrength
Members
Member name | Value | Description
NoCompression | 0 | Disables compression.
Standard | 1 | Enables standard compression.
MultiPass | 2 | Enables multi-pass compression to continue recompressing buffer as long as size continues to shrink.
Remarks
Compression strengths represent tradeoffs on speed of compression vs. effectiveness of compression.
See Also

Reference

GSF.IO.Compression Namespace


FileCompressor Class

Grid Solutions Framework FileCompressor Class
Performs basic compression and decompression on a file.
Inheritance Hierarchy
SystemObject
GSF.IO.CompressionFileCompressor

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class FileCompressor
Public NotInheritable Class FileCompressor
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FileCompressor =  class end
GSF.IO.Compression.FileCompressor = function();

Type.createClass(
    'GSF.IO.Compression.FileCompressor');
public ref class FileCompressor abstract sealed
Methods
Name | Description
Compress(String, String) | Compress a file using default compression strength (not PKZip compatible...)
Compress(String, String, CompressionStrength) | Compress a file using specified compression strength (not PKZip compatible...)
Compress(String, String, CompressionStrength, ActionProcessProgressInt64) | Compress a file using specified compression strength (not PKZip compatible...)
Decompress(String, String) | Uncompress a file compressed with CompressFile (not PKZip compatible...)
Decompress(String, String, ActionProcessProgressInt64) | Uncompress a file compressed with CompressFile given progress event handler (not PKZip compatible...)
Top
See Also

Reference

GSF.IO.Compression Namespace


FileCompressor Methods

Grid Solutions Framework FileCompressor Methods
Methods
Name | Description
Compress(String, String) | Compress a file using default compression strength (not PKZip compatible...)
Compress(String, String, CompressionStrength) | Compress a file using specified compression strength (not PKZip compatible...)
Compress(String, String, CompressionStrength, ActionProcessProgressInt64) | Compress a file using specified compression strength (not PKZip compatible...)
Decompress(String, String) | Uncompress a file compressed with CompressFile (not PKZip compatible...)
Decompress(String, String, ActionProcessProgressInt64) | Uncompress a file compressed with CompressFile given progress event handler (not PKZip compatible...)
Top
See Also

Reference

FileCompressor Class
GSF.IO.Compression Namespace


FileCompressor.Compress Method

Grid Solutions Framework FileCompressorCompress Method
Overload List
Name | Description
Compress(String, String) | Compress a file using default compression strength (not PKZip compatible...)
Compress(String, String, CompressionStrength) | Compress a file using specified compression strength (not PKZip compatible...)
Compress(String, String, CompressionStrength, ActionProcessProgressInt64) | Compress a file using specified compression strength (not PKZip compatible...)
Top
See Also

Reference

FileCompressor Class
GSF.IO.Compression Namespace


FileCompressor.Compress Method (String, String)

Grid Solutions Framework FileCompressorCompress Method (String, String)
Compress a file using default compression strength (not PKZip compatible...)

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Compress(
    string sourceFileName,
    string destinationFileName
)
Public Shared Sub Compress (
    sourceFileName As String,
    destinationFileName As String
)
static member Compress :
        sourceFileName : string *
        destinationFileName : string -> unit

GSF.IO.Compression.FileCompressor.Compress = function(sourceFileName, destinationFileName);
public:
static void Compress(
    String^ sourceFileName,
    String^ destinationFileName
)

Parameters

sourceFileName
Type: SystemString
Source file name.
destinationFileName
Type: SystemString
Destination file name.
See Also

Reference

FileCompressor Class
Compress Overload
GSF.IO.Compression Namespace


FileCompressor.Compress Method (String, String, CompressionStrength)

Grid Solutions Framework FileCompressorCompress Method (String, String, CompressionStrength)
Compress a file using specified compression strength (not PKZip compatible...)

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Compress(
    string sourceFileName,
    string destinationFileName,
    CompressionStrength strength
)
Public Shared Sub Compress (
    sourceFileName As String,
    destinationFileName As String,
    strength As CompressionStrength
)
static member Compress :
        sourceFileName : string *
        destinationFileName : string *
        strength : CompressionStrength -> unit

GSF.IO.Compression.FileCompressor.Compress = function(sourceFileName, destinationFileName, strength);
public:
static void Compress(
    String^ sourceFileName,
    String^ destinationFileName,
    CompressionStrength strength
)

Parameters

sourceFileName
Type: SystemString
Source file name.
destinationFileName
Type: SystemString
Destination file name.
strength
Type: GSF.IO.CompressionCompressionStrength
Stength of compression to apply.
See Also

Reference

FileCompressor Class
Compress Overload
GSF.IO.Compression Namespace


FileCompressor.Compress Method (String, String, CompressionStrength, Action(ProcessProgress(Int64)))

Grid Solutions Framework FileCompressorCompress Method (String, String, CompressionStrength, ActionProcessProgressInt64)
Compress a file using specified compression strength (not PKZip compatible...)

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Compress(
    string sourceFileName,
    string destinationFileName,
    CompressionStrength strength,
    Action<ProcessProgress<long>> progressHandler
)
Public Shared Sub Compress (
    sourceFileName As String,
    destinationFileName As String,
    strength As CompressionStrength,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member Compress :
        sourceFileName : string *
        destinationFileName : string *
        strength : CompressionStrength *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.IO.Compression.FileCompressor.Compress = function(sourceFileName, destinationFileName, strength, progressHandler);
public:
static void Compress(
    String^ sourceFileName,
    String^ destinationFileName,
    CompressionStrength strength,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

sourceFileName
Type: SystemString
Source file name.
destinationFileName
Type: SystemString
Destination file name.
strength
Type: GSF.IO.CompressionCompressionStrength
Stength of compression to apply.
progressHandler
Type: SystemAction ProcessProgress Int64
User function to call with compression progress updates.
See Also

Reference

FileCompressor Class
Compress Overload
GSF.IO.Compression Namespace


FileCompressor.Decompress Method

Grid Solutions Framework FileCompressorDecompress Method
Overload List
Name | Description
Decompress(String, String) | Uncompress a file compressed with CompressFile (not PKZip compatible...)
Decompress(String, String, ActionProcessProgressInt64) | Uncompress a file compressed with CompressFile given progress event handler (not PKZip compatible...)
Top
See Also

Reference

FileCompressor Class
GSF.IO.Compression Namespace


FileCompressor.Decompress Method (String, String)

Grid Solutions Framework FileCompressorDecompress Method (String, String)
Uncompress a file compressed with CompressFile (not PKZip compatible...)

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Decompress(
    string sourceFileName,
    string destinationFileName
)
Public Shared Sub Decompress (
    sourceFileName As String,
    destinationFileName As String
)
static member Decompress :
        sourceFileName : string *
        destinationFileName : string -> unit

GSF.IO.Compression.FileCompressor.Decompress = function(sourceFileName, destinationFileName);
public:
static void Decompress(
    String^ sourceFileName,
    String^ destinationFileName
)

Parameters

sourceFileName
Type: SystemString
Source file name.
destinationFileName
Type: SystemString
Destination file name.
See Also

Reference

FileCompressor Class
Decompress Overload
GSF.IO.Compression Namespace


FileCompressor.Decompress Method (String, String, Action(ProcessProgress(Int64)))

Grid Solutions Framework FileCompressorDecompress Method (String, String, ActionProcessProgressInt64)
Uncompress a file compressed with CompressFile given progress event handler (not PKZip compatible...)

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Decompress(
    string sourceFileName,
    string destinationFileName,
    Action<ProcessProgress<long>> progressHandler
)
Public Shared Sub Decompress (
    sourceFileName As String,
    destinationFileName As String,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member Decompress :
        sourceFileName : string *
        destinationFileName : string *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.IO.Compression.FileCompressor.Decompress = function(sourceFileName, destinationFileName, progressHandler);
public:
static void Decompress(
    String^ sourceFileName,
    String^ destinationFileName,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

sourceFileName
Type: SystemString
Source file name.
destinationFileName
Type: SystemString
Destination file name.
progressHandler
Type: SystemAction ProcessProgress Int64
User function to call with decompression progress updates.
See Also

Reference

FileCompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternCompressor Class

Grid Solutions Framework PatternCompressor Class
Defines functions used for high-speed pattern compression against native types.
Inheritance Hierarchy
SystemObject
GSF.IO.CompressionPatternCompressor

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PatternCompressor
Public Class PatternCompressor
type PatternCompressor =  class end
GSF.IO.Compression.PatternCompressor = function();

Type.createClass(
    'GSF.IO.Compression.PatternCompressor');
public ref class PatternCompressor

The PatternCompressor type exposes the following members.

Constructors
 | Name | Description
Public method | PatternCompressor | Creates a new instance of the PatternCompressor with the given compression strength.
Top
Methods
 | Name | Description
Public method | Compress(Byte) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Byte) | Compresses all of the data in the given buffer.
Public method | Compress(Double) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int16) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int32) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int64) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Single) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt16) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt32) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt64) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(ISupportBinaryImage) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Byte, Int32) | Compresses length bytes of data in the given buffer.
Public method | Compress(Byte, Int32, Int32) | Compresses length bytes of data in the given buffer, starting at offset.
 | CompressBuffer | Compress a byte array containing a sequential list of 32-bit structures (e.g., floating point numbers, integers or unsigned integers) using a patterned compression method.
Public method | EmptyCompressedBuffer | Sets CompressedBufferLength to zero and allows the compressor to write over the values in the compressed buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the compressor by flushing the back buffer. Subsequent calls to the Compress methods will not be compressed using previously compressed values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CompressedBuffer | Gets or sets the buffer into which compressed values are written.
Public property | CompressedBufferLength | Gets the amount of compressed data in the compressed buffer.
Public property | CompressionStrength | Gets or sets the compression strength of the PatternCompressor.
Public property | MaxCompressedBufferLength | Gets or sets the maximum compressed buffer length.
Top
See Also

Reference

GSF.IO.Compression Namespace


PatternCompressor Constructor

Grid Solutions Framework PatternCompressor Constructor
Creates a new instance of the PatternCompressor with the given compression strength.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PatternCompressor(
    byte compressionStrength = 5
)
Public Sub New (
    Optional compressionStrength As Byte = 5
)
new :
        ?compressionStrength : byte
(* Defaults:
        let _compressionStrength = defaultArg compressionStrength 5
*)
-> PatternCompressor
GSF.IO.Compression.PatternCompressor = function(compressionStrength);
public:
PatternCompressor(
    unsigned char compressionStrength = 5
)

Parameters

compressionStrength (Optional)
Type: SystemByte
The compression strength of the PatternCompressor.
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor Methods

Grid Solutions Framework PatternCompressor Methods

The PatternCompressor type exposes the following members.

Methods
 | Name | Description
Public method | Compress(Byte) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Byte) | Compresses all of the data in the given buffer.
Public method | Compress(Double) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int16) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int32) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int64) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Single) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt16) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt32) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt64) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(ISupportBinaryImage) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Byte, Int32) | Compresses length bytes of data in the given buffer.
Public method | Compress(Byte, Int32, Int32) | Compresses length bytes of data in the given buffer, starting at offset.
 | CompressBuffer | Compress a byte array containing a sequential list of 32-bit structures (e.g., floating point numbers, integers or unsigned integers) using a patterned compression method.
Public method | EmptyCompressedBuffer | Sets CompressedBufferLength to zero and allows the compressor to write over the values in the compressed buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the compressor by flushing the back buffer. Subsequent calls to the Compress methods will not be compressed using previously compressed values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.Compress Method

Grid Solutions Framework PatternCompressorCompress Method
Overload List
 | Name | Description
Public method | Compress(Byte) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Byte) | Compresses all of the data in the given buffer.
Public method | Compress(Double) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int16) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int32) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Int64) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Single) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt16) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt32) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(UInt64) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(ISupportBinaryImage) | Compresses the given value and places it in the compressed buffer.
Public method | Compress(Byte, Int32) | Compresses length bytes of data in the given buffer.
Public method | Compress(Byte, Int32, Int32) | Compresses length bytes of data in the given buffer, starting at offset.
Top
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Byte)

Grid Solutions Framework PatternCompressorCompress Method (Byte)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    byte value
)
Public Function Compress (
    value As Byte
) As Integer
member Compress :
        value : byte -> int

function Compress(value);
public:
int Compress(
    unsigned char value
)

Parameters

value
Type: SystemByte
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Byte[])

Grid Solutions Framework PatternCompressorCompress Method (Byte)
Compresses all of the data in the given buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    byte[] buffer
)
Public Function Compress (
    buffer As Byte()
) As Integer
member Compress :
        buffer : byte[] -> int

function Compress(buffer);
public:
int Compress(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The buffer to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
Exceptions
Exception | Condition
ArgumentNullException | buffer cannot be null.
ArgumentException | buffer length must be a multiple of four.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Double)

Grid Solutions Framework PatternCompressorCompress Method (Double)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    double value
)
Public Function Compress (
    value As Double
) As Integer
member Compress :
        value : float -> int

function Compress(value);
public:
int Compress(
    double value
)

Parameters

value
Type: SystemDouble
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Int16)

Grid Solutions Framework PatternCompressorCompress Method (Int16)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    short value
)
Public Function Compress (
    value As Short
) As Integer
member Compress :
        value : int16 -> int

function Compress(value);
public:
int Compress(
    short value
)

Parameters

value
Type: SystemInt16
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Int32)

Grid Solutions Framework PatternCompressorCompress Method (Int32)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    int value
)
Public Function Compress (
    value As Integer
) As Integer
member Compress :
        value : int -> int

function Compress(value);
public:
int Compress(
    int value
)

Parameters

value
Type: SystemInt32
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Int64)

Grid Solutions Framework PatternCompressorCompress Method (Int64)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    long value
)
Public Function Compress (
    value As Long
) As Integer
member Compress :
        value : int64 -> int

function Compress(value);
public:
int Compress(
    long long value
)

Parameters

value
Type: SystemInt64
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Single)

Grid Solutions Framework PatternCompressorCompress Method (Single)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    float value
)
Public Function Compress (
    value As Single
) As Integer
member Compress :
        value : float32 -> int

function Compress(value);
public:
int Compress(
    float value
)

Parameters

value
Type: SystemSingle
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (UInt16)

Grid Solutions Framework PatternCompressorCompress Method (UInt16)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    ushort value
)
Public Function Compress (
    value As UShort
) As Integer
member Compress :
        value : uint16 -> int

function Compress(value);
public:
int Compress(
    unsigned short value
)

Parameters

value
Type: SystemUInt16
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (UInt32)

Grid Solutions Framework PatternCompressorCompress Method (UInt32)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    uint value
)
Public Function Compress (
    value As UInteger
) As Integer
member Compress :
        value : uint32 -> int

function Compress(value);
public:
int Compress(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (UInt64)

Grid Solutions Framework PatternCompressorCompress Method (UInt64)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    ulong value
)
Public Function Compress (
    value As ULong
) As Integer
member Compress :
        value : uint64 -> int

function Compress(value);
public:
int Compress(
    unsigned long long value
)

Parameters

value
Type: SystemUInt64
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (ISupportBinaryImage)

Grid Solutions Framework PatternCompressorCompress Method (ISupportBinaryImage)
Compresses the given value and places it in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    ISupportBinaryImage value
)
Public Function Compress (
    value As ISupportBinaryImage
) As Integer
member Compress :
        value : ISupportBinaryImage -> int

function Compress(value);
public:
int Compress(
    ISupportBinaryImage^ value
)

Parameters

value
Type: GSF.ParsingISupportBinaryImage
The value to be compressed.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
Exceptions
Exception | Condition
ArgumentNullException | value cannot be null.
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Byte[], Int32)

Grid Solutions Framework PatternCompressorCompress Method (Byte, Int32)
Compresses length bytes of data in the given buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    byte[] buffer,
    int length
)
Public Function Compress (
    buffer As Byte(),
    length As Integer
) As Integer
member Compress :
        buffer : byte[] *
        length : int -> int

function Compress(buffer, length);
public:
int Compress(
    array<unsigned char>^ buffer,
    int length
)

Parameters

buffer
Type: SystemByte
The buffer to be compressed.
length
Type: SystemInt32
The amount of data to be compressed. Must be a multiple of four.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
Exceptions
Exception | Condition
ArgumentNullException | buffer cannot be null.
ArgumentException | length must be a multiple of four.
ArgumentOutOfRangeException | length must be greater than or equal to zero.
ArgumentOutOfRangeException | length exceeds buffer array boundaries
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.Compress Method (Byte[], Int32, Int32)

Grid Solutions Framework PatternCompressorCompress Method (Byte, Int32, Int32)
Compresses length bytes of data in the given buffer, starting at offset.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Compress(
    byte[] buffer,
    int offset,
    int length
)
Public Function Compress (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As Integer
member Compress :
        buffer : byte[] *
        offset : int *
        length : int -> int

function Compress(buffer, offset, length);
public:
int Compress(
    array<unsigned char>^ buffer,
    int offset,
    int length
)

Parameters

buffer
Type: SystemByte
The buffer to be compressed.
offset
Type: SystemInt32
The amount of data to ignore at the start of the buffer.
length
Type: SystemInt32
The amount of data to be compressed. Must be a multiple of four.

Return Value

Type: Int32
The size, in bytes, of the compressed value.
Exceptions
Exception | Condition
ArgumentNullException | buffer cannot be null.
ArgumentException | length must be a multiple of four.
ArgumentOutOfRangeException | offset must be greater than or equal to zero.
ArgumentOutOfRangeException | length must be greater than or equal to zero.
ArgumentOutOfRangeException | length exceeds buffer array boundaries
See Also

Reference

PatternCompressor Class
Compress Overload
GSF.IO.Compression Namespace


PatternCompressor.CompressBuffer Method

Grid Solutions Framework PatternCompressorCompressBuffer Method
Compress a byte array containing a sequential list of 32-bit structures (e.g., floating point numbers, integers or unsigned integers) using a patterned compression method.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int CompressBuffer(
    byte[] source,
    int startIndex,
    int dataLength,
    int bufferLength,
    byte compressionStrength = 5
)
Public Shared Function CompressBuffer (
    source As Byte(),
    startIndex As Integer,
    dataLength As Integer,
    bufferLength As Integer,
    Optional compressionStrength As Byte = 5
) As Integer
static member CompressBuffer :
        source : byte[] *
        startIndex : int *
        dataLength : int *
        bufferLength : int *
        ?compressionStrength : byte
(* Defaults:
        let _compressionStrength = defaultArg compressionStrength 5
*)
-> int

GSF.IO.Compression.PatternCompressor.CompressBuffer = function(source, startIndex, dataLength, bufferLength, compressionStrength);
public:
static int CompressBuffer(
    array<unsigned char>^ source,
    int startIndex,
    int dataLength,
    int bufferLength,
    unsigned char compressionStrength = 5
)

Parameters

source
Type: SystemByte
The Byte array containing 32-bit values to compress. Compression will happen inline on this buffer.
startIndex
Type: SystemInt32
An Int32 representing the start index of the byte array.
dataLength
Type: SystemInt32
The number of bytes in the buffer that represents actual data.
bufferLength
Type: SystemInt32
The number of bytes available for use in the buffer; actual buffer length must be at least one byte larger than dataLength since it's possible that data cannot be compressed. This extra byte will be used indicate an uncompressed buffer.
compressionStrength (Optional)
Type: SystemByte
Specifies compression strength (0 to 31). Smaller numbers will run faster, larger numbers will yield better compression.

Return Value

Type: Int32
The new length of the buffer after compression.
Exceptions
Exception | Condition
ArgumentNullException | source buffer cannot be null.
ArgumentOutOfRangeException | dataLength must be greater than or equal to zero.
ArgumentException | dataLength must be an even multiple of 4.
ArgumentOutOfRangeException | bufferLength must be at least one byte larger than dataLength in case data cannot be compressed.
ArgumentOutOfRangeException | Actual length of source buffer is less than specified bufferLength.
ArgumentOutOfRangeException | compressionStrength must be 0 to 31.
Remarks
As an optimization this function is using pointers to native structures, as such the endian order decoding and encoding of the values will always be in the native endian order of the operating system.
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.EmptyCompressedBuffer Method

Grid Solutions Framework PatternCompressorEmptyCompressedBuffer Method
Sets CompressedBufferLength to zero and allows the compressor to write over the values in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EmptyCompressedBuffer()
Public Sub EmptyCompressedBuffer
member EmptyCompressedBuffer : unit -> unit

function EmptyCompressedBuffer();
public:
void EmptyCompressedBuffer()
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.Reset Method

Grid Solutions Framework PatternCompressorReset Method
Resets the compressor by flushing the back buffer. Subsequent calls to the Compress methods will not be compressed using previously compressed values.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor Properties

Grid Solutions Framework PatternCompressor Properties

The PatternCompressor type exposes the following members.

Properties
 | Name | Description
Public property | CompressedBuffer | Gets or sets the buffer into which compressed values are written.
Public property | CompressedBufferLength | Gets the amount of compressed data in the compressed buffer.
Public property | CompressionStrength | Gets or sets the compression strength of the PatternCompressor.
Public property | MaxCompressedBufferLength | Gets or sets the maximum compressed buffer length.
Top
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.CompressedBuffer Property

Grid Solutions Framework PatternCompressorCompressedBuffer Property
Gets or sets the buffer into which compressed values are written.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] CompressedBuffer { get; set; }
Public Property CompressedBuffer As Byte()
    Get
    Set
member CompressedBuffer : byte[] with get, set

function get_CompressedBuffer();
function set_CompressedBuffer(value);
public:
property array<unsigned char>^ CompressedBuffer {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Remarks
When setting the compressed buffer, the new buffer is assumed to be empty (CompressedBufferLength is set to zero).
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.CompressedBufferLength Property

Grid Solutions Framework PatternCompressorCompressedBufferLength Property
Gets the amount of compressed data in the compressed buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompressedBufferLength { get; }
Public ReadOnly Property CompressedBufferLength As Integer
    Get
member CompressedBufferLength : int with get

function get_CompressedBufferLength();

public:
property int CompressedBufferLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.CompressionStrength Property

Grid Solutions Framework PatternCompressorCompressionStrength Property
Gets or sets the compression strength of the PatternCompressor.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte CompressionStrength { get; set; }
Public Property CompressionStrength As Byte
    Get
    Set
member CompressionStrength : byte with get, set

function get_CompressionStrength();
function set_CompressionStrength(value);
public:
property unsigned char CompressionStrength {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
Remarks
When setting the compression strength, the PatternCompressor is automatically reset (the back buffer is emptied).
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternCompressor.MaxCompressedBufferLength Property

Grid Solutions Framework PatternCompressorMaxCompressedBufferLength Property
Gets or sets the maximum compressed buffer length.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaxCompressedBufferLength { get; set; }
Public Property MaxCompressedBufferLength As Integer
    Get
    Set
member MaxCompressedBufferLength : int with get, set

function get_MaxCompressedBufferLength();
function set_MaxCompressedBufferLength(value);
public:
property int MaxCompressedBufferLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
The compressor will not write beyond the MaxCompressedBufferLength. Defaults to the full length of the compressed buffer. Set to -1 to return to the default.
See Also

Reference

PatternCompressor Class
GSF.IO.Compression Namespace


PatternDecompressor Class

Grid Solutions Framework PatternDecompressor Class
Defines functions for decompression of data compressed by the PatternCompressor.
Inheritance Hierarchy
SystemObject
GSF.IO.CompressionPatternDecompressor

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PatternDecompressor
Public Class PatternDecompressor
type PatternDecompressor =  class end
GSF.IO.Compression.PatternDecompressor = function();

Type.createClass(
    'GSF.IO.Compression.PatternDecompressor');
public ref class PatternDecompressor

The PatternDecompressor type exposes the following members.

Constructors
 | Name | Description
Public method | PatternDecompressor | Initializes a new instance of the PatternDecompressor class
Top
Methods
 | Name | Description
Public method | AugmentBuffer(Byte) | Inserts the given data into the data buffer for decompression.
Public method | AugmentBuffer(Byte, Int32) | Inserts the given data into the data buffer for decompression.
Public method | AugmentBuffer(Byte, Int32, Int32) | Inserts the given data into the data buffer for decompression.
Public method | Decompress(Byte) | Decompresses four bytes of data and writes the data into an 8-bit integer. The high-order bytes are discarded.
Public method | Decompress(Byte) | Decompresses enough bytes of data to fill up the buffer.
Public method | Decompress(Double) | Decompresses eight bytes of data and writes the data into a 64-bit floating point number.
Public method | Decompress(Int16) | Decompresses four bytes of data and writes the data into a 16-bit signed integer. The high-order bytes are discarded.
Public method | Decompress(Int32) | Decompresses four bytes of data and writes the data into a 32-bit signed integer.
Public method | Decompress(Int64) | Decompresses eight bytes of data and writes the data into a 64-bit signed integer.
Public method | Decompress(Single) | Decompresses four bytes of data and writes the data into a 32-bit floating point number.
Public method | Decompress(UInt16) | Decompresses four bytes of data and writes the data into a 16-bit unsigned integer. The high-order bytes are discarded.
Public method | Decompress(UInt32) | Decompresses four bytes of data and writes the data into a 32-bit unsigned integer.
Public method | Decompress(UInt64) | Decompresses eight bytes of data and writes the data into a 64-bit unsigned integer.
Public method | Decompress(Byte, Int32) | Decompresses length bytes of data and places it in the buffer.
Public method | Decompress(Byte, Int32, Int32) | Decompresses length bytes of data and places it in the buffer starting at offset.
 | DecompressBuffer | Decompress a byte array containing a sequential list of compressed 32-bit structures (e.g., floating point numbers, integers or unsigned integers) using a patterned compression method.
Public method | EmptyBuffer | Clears out the data buffer so that subsequent calls to the Decompress methods do not use the data that was previously in the data buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MaximumSizeDecompressed | Given the size of a compressed buffer, provides the maximum possible size of the decompressed data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the decompressor by flushing the back buffer. Subsequent calls to the Decompress methods will not be decompressed using previously decompressed values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CompressionStrength | Gets the compression strength defined by the compressed stream.
Public property | DataBufferLength | Gets the length of the data left in the buffer.
Top
See Also

Reference

GSF.IO.Compression Namespace


PatternDecompressor Constructor

Grid Solutions Framework PatternDecompressor Constructor
Initializes a new instance of the PatternDecompressor class

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PatternDecompressor()
Public Sub New
new : unit -> PatternDecompressor
GSF.IO.Compression.PatternDecompressor = function();
public:
PatternDecompressor()
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor Methods

Grid Solutions Framework PatternDecompressor Methods

The PatternDecompressor type exposes the following members.

Methods
 | Name | Description
Public method | AugmentBuffer(Byte) | Inserts the given data into the data buffer for decompression.
Public method | AugmentBuffer(Byte, Int32) | Inserts the given data into the data buffer for decompression.
Public method | AugmentBuffer(Byte, Int32, Int32) | Inserts the given data into the data buffer for decompression.
Public method | Decompress(Byte) | Decompresses four bytes of data and writes the data into an 8-bit integer. The high-order bytes are discarded.
Public method | Decompress(Byte) | Decompresses enough bytes of data to fill up the buffer.
Public method | Decompress(Double) | Decompresses eight bytes of data and writes the data into a 64-bit floating point number.
Public method | Decompress(Int16) | Decompresses four bytes of data and writes the data into a 16-bit signed integer. The high-order bytes are discarded.
Public method | Decompress(Int32) | Decompresses four bytes of data and writes the data into a 32-bit signed integer.
Public method | Decompress(Int64) | Decompresses eight bytes of data and writes the data into a 64-bit signed integer.
Public method | Decompress(Single) | Decompresses four bytes of data and writes the data into a 32-bit floating point number.
Public method | Decompress(UInt16) | Decompresses four bytes of data and writes the data into a 16-bit unsigned integer. The high-order bytes are discarded.
Public method | Decompress(UInt32) | Decompresses four bytes of data and writes the data into a 32-bit unsigned integer.
Public method | Decompress(UInt64) | Decompresses eight bytes of data and writes the data into a 64-bit unsigned integer.
Public method | Decompress(Byte, Int32) | Decompresses length bytes of data and places it in the buffer.
Public method | Decompress(Byte, Int32, Int32) | Decompresses length bytes of data and places it in the buffer starting at offset.
 | DecompressBuffer | Decompress a byte array containing a sequential list of compressed 32-bit structures (e.g., floating point numbers, integers or unsigned integers) using a patterned compression method.
Public method | EmptyBuffer | Clears out the data buffer so that subsequent calls to the Decompress methods do not use the data that was previously in the data buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MaximumSizeDecompressed | Given the size of a compressed buffer, provides the maximum possible size of the decompressed data.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the decompressor by flushing the back buffer. Subsequent calls to the Decompress methods will not be decompressed using previously decompressed values.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.AugmentBuffer Method

Grid Solutions Framework PatternDecompressorAugmentBuffer Method
Overload List
 | Name | Description
Public method | AugmentBuffer(Byte) | Inserts the given data into the data buffer for decompression.
Public method | AugmentBuffer(Byte, Int32) | Inserts the given data into the data buffer for decompression.
Public method | AugmentBuffer(Byte, Int32, Int32) | Inserts the given data into the data buffer for decompression.
Top
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.AugmentBuffer Method (Byte[])

Grid Solutions Framework PatternDecompressorAugmentBuffer Method (Byte)
Inserts the given data into the data buffer for decompression.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AugmentBuffer(
    byte[] data
)
Public Sub AugmentBuffer (
    data As Byte()
)
member AugmentBuffer :
        data : byte[] -> unit

function AugmentBuffer(data);
public:
void AugmentBuffer(
    array<unsigned char>^ data
)

Parameters

data
Type: SystemByte
The data to be inserted into the data buffer.
See Also

Reference

PatternDecompressor Class
AugmentBuffer Overload
GSF.IO.Compression Namespace


PatternDecompressor.AugmentBuffer Method (Byte[], Int32)

Grid Solutions Framework PatternDecompressorAugmentBuffer Method (Byte, Int32)
Inserts the given data into the data buffer for decompression.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AugmentBuffer(
    byte[] data,
    int dataLength
)
Public Sub AugmentBuffer (
    data As Byte(),
    dataLength As Integer
)
member AugmentBuffer :
        data : byte[] *
        dataLength : int -> unit

function AugmentBuffer(data, dataLength);
public:
void AugmentBuffer(
    array<unsigned char>^ data,
    int dataLength
)

Parameters

data
Type: SystemByte
The data to be inserted into the data buffer.
dataLength
Type: SystemInt32
The amount of data to be taken from the given buffer and placed in the data buffer.
See Also

Reference

PatternDecompressor Class
AugmentBuffer Overload
GSF.IO.Compression Namespace


PatternDecompressor.AugmentBuffer Method (Byte[], Int32, Int32)

Grid Solutions Framework PatternDecompressorAugmentBuffer Method (Byte, Int32, Int32)
Inserts the given data into the data buffer for decompression.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AugmentBuffer(
    byte[] data,
    int offset,
    int dataLength
)
Public Sub AugmentBuffer (
    data As Byte(),
    offset As Integer,
    dataLength As Integer
)
member AugmentBuffer :
        data : byte[] *
        offset : int *
        dataLength : int -> unit

function AugmentBuffer(data, offset, dataLength);
public:
void AugmentBuffer(
    array<unsigned char>^ data,
    int offset,
    int dataLength
)

Parameters

data
Type: SystemByte
The data to be inserted into the data buffer.
offset
Type: SystemInt32
The amount of data to be ignored at the beginning of the buffer.
dataLength
Type: SystemInt32
The amount of data to be taken from the given buffer and placed in the data buffer.
See Also

Reference

PatternDecompressor Class
AugmentBuffer Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method

Grid Solutions Framework PatternDecompressorDecompress Method
Overload List
 | Name | Description
Public method | Decompress(Byte) | Decompresses four bytes of data and writes the data into an 8-bit integer. The high-order bytes are discarded.
Public method | Decompress(Byte) | Decompresses enough bytes of data to fill up the buffer.
Public method | Decompress(Double) | Decompresses eight bytes of data and writes the data into a 64-bit floating point number.
Public method | Decompress(Int16) | Decompresses four bytes of data and writes the data into a 16-bit signed integer. The high-order bytes are discarded.
Public method | Decompress(Int32) | Decompresses four bytes of data and writes the data into a 32-bit signed integer.
Public method | Decompress(Int64) | Decompresses eight bytes of data and writes the data into a 64-bit signed integer.
Public method | Decompress(Single) | Decompresses four bytes of data and writes the data into a 32-bit floating point number.
Public method | Decompress(UInt16) | Decompresses four bytes of data and writes the data into a 16-bit unsigned integer. The high-order bytes are discarded.
Public method | Decompress(UInt32) | Decompresses four bytes of data and writes the data into a 32-bit unsigned integer.
Public method | Decompress(UInt64) | Decompresses eight bytes of data and writes the data into a 64-bit unsigned integer.
Public method | Decompress(Byte, Int32) | Decompresses length bytes of data and places it in the buffer.
Public method | Decompress(Byte, Int32, Int32) | Decompresses length bytes of data and places it in the buffer starting at offset.
Top
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Byte)

Grid Solutions Framework PatternDecompressorDecompress Method (Byte)
Decompresses four bytes of data and writes the data into an 8-bit integer. The high-order bytes are discarded.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out byte value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As Byte
)
member Decompress :
        value : byte byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] unsigned char% value
)

Parameters

value
Type: SystemByte
The 8-bit integer that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Byte[])

Grid Solutions Framework PatternDecompressorDecompress Method (Byte)
Decompresses enough bytes of data to fill up the buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    byte[] buffer
)
Public Sub Decompress (
    buffer As Byte()
)
member Decompress :
        buffer : byte[] -> unit

function Decompress(buffer);
public:
void Decompress(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The buffer that holds the data.
Exceptions
Exception | Condition
ArgumentNullException | buffer cannot be null.
ArgumentException | buffer length must be a multiple of four.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Double)

Grid Solutions Framework PatternDecompressorDecompress Method (Double)
Decompresses eight bytes of data and writes the data into a 64-bit floating point number.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out double value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As Double
)
member Decompress :
        value : float byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] double% value
)

Parameters

value
Type: SystemDouble
The 64-bit floating point number that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Int16)

Grid Solutions Framework PatternDecompressorDecompress Method (Int16)
Decompresses four bytes of data and writes the data into a 16-bit signed integer. The high-order bytes are discarded.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out short value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As Short
)
member Decompress :
        value : int16 byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] short% value
)

Parameters

value
Type: SystemInt16
The 16-bit integer that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Int32)

Grid Solutions Framework PatternDecompressorDecompress Method (Int32)
Decompresses four bytes of data and writes the data into a 32-bit signed integer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out int value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As Integer
)
member Decompress :
        value : int byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] int% value
)

Parameters

value
Type: SystemInt32
The 32-bit integer that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Int64)

Grid Solutions Framework PatternDecompressorDecompress Method (Int64)
Decompresses eight bytes of data and writes the data into a 64-bit signed integer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out long value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As Long
)
member Decompress :
        value : int64 byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] long long% value
)

Parameters

value
Type: SystemInt64
The 64-bit integer that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Single)

Grid Solutions Framework PatternDecompressorDecompress Method (Single)
Decompresses four bytes of data and writes the data into a 32-bit floating point number.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out float value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As Single
)
member Decompress :
        value : float32 byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] float% value
)

Parameters

value
Type: SystemSingle
The 32-bit floating point number that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (UInt16)

Grid Solutions Framework PatternDecompressorDecompress Method (UInt16)
Decompresses four bytes of data and writes the data into a 16-bit unsigned integer. The high-order bytes are discarded.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out ushort value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As UShort
)
member Decompress :
        value : uint16 byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] unsigned short% value
)

Parameters

value
Type: SystemUInt16
The 16-bit integer that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (UInt32)

Grid Solutions Framework PatternDecompressorDecompress Method (UInt32)
Decompresses four bytes of data and writes the data into a 32-bit unsigned integer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out uint value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As UInteger
)
member Decompress :
        value : uint32 byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] unsigned int% value
)

Parameters

value
Type: SystemUInt32
The 32-bit integer that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (UInt64)

Grid Solutions Framework PatternDecompressorDecompress Method (UInt64)
Decompresses eight bytes of data and writes the data into a 64-bit unsigned integer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    out ulong value
)
Public Sub Decompress (
    <OutAttribute> ByRef value As ULong
)
member Decompress :
        value : uint64 byref -> unit

function Decompress(value);
public:
void Decompress(
    [OutAttribute] unsigned long long% value
)

Parameters

value
Type: SystemUInt64
The 64-bit integer that the data is to be written to.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Byte[], Int32)

Grid Solutions Framework PatternDecompressorDecompress Method (Byte, Int32)
Decompresses length bytes of data and places it in the buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    byte[] buffer,
    int length
)
Public Sub Decompress (
    buffer As Byte(),
    length As Integer
)
member Decompress :
        buffer : byte[] *
        length : int -> unit

function Decompress(buffer, length);
public:
void Decompress(
    array<unsigned char>^ buffer,
    int length
)

Parameters

buffer
Type: SystemByte
The buffer that holds the data.
length
Type: SystemInt32
The amount of data to be decompressed and written to the buffer. The value of this parameter must be a multiple of four.
Exceptions
Exception | Condition
ArgumentNullException | buffer cannot be null.
ArgumentException | length must be a multiple of four.
ArgumentOutOfRangeException | length must be greater than or equal to zero.
ArgumentOutOfRangeException | length exceeds buffer array boundaries.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.Decompress Method (Byte[], Int32, Int32)

Grid Solutions Framework PatternDecompressorDecompress Method (Byte, Int32, Int32)
Decompresses length bytes of data and places it in the buffer starting at offset.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Decompress(
    byte[] buffer,
    int offset,
    int length
)
Public Sub Decompress (
    buffer As Byte(),
    offset As Integer,
    length As Integer
)
member Decompress :
        buffer : byte[] *
        offset : int *
        length : int -> unit

function Decompress(buffer, offset, length);
public:
void Decompress(
    array<unsigned char>^ buffer,
    int offset,
    int length
)

Parameters

buffer
Type: SystemByte
The buffer that holds the data.
offset
Type: SystemInt32
The amount of data at the beginning of the buffer that will not be overwritten.
length
Type: SystemInt32
The amount of data to be decompressed and written to the buffer. The value of this parameter must be a multiple of four.
Exceptions
Exception | Condition
ArgumentNullException | buffer cannot be null.
ArgumentException | length must be a multiple of four.
ArgumentOutOfRangeException | offset must be greater than or equal to zero.
ArgumentOutOfRangeException | length must be greater than or equal to zero.
ArgumentOutOfRangeException | length exceeds buffer array boundaries.
See Also

Reference

PatternDecompressor Class
Decompress Overload
GSF.IO.Compression Namespace


PatternDecompressor.DecompressBuffer Method

Grid Solutions Framework PatternDecompressorDecompressBuffer Method
Decompress a byte array containing a sequential list of compressed 32-bit structures (e.g., floating point numbers, integers or unsigned integers) using a patterned compression method.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int DecompressBuffer(
    byte[] source,
    int startIndex,
    int dataLength,
    int bufferLength
)
Public Shared Function DecompressBuffer (
    source As Byte(),
    startIndex As Integer,
    dataLength As Integer,
    bufferLength As Integer
) As Integer
static member DecompressBuffer :
        source : byte[] *
        startIndex : int *
        dataLength : int *
        bufferLength : int -> int

GSF.IO.Compression.PatternDecompressor.DecompressBuffer = function(source, startIndex, dataLength, bufferLength);
public:
static int DecompressBuffer(
    array<unsigned char>^ source,
    int startIndex,
    int dataLength,
    int bufferLength
)

Parameters

source
Type: SystemByte
The Byte array containing compressed 32-bit values to be decompressed. Decompression will happen inline on this buffer.
startIndex
Type: SystemInt32
An Int32 representing the start index of the byte array.
dataLength
Type: SystemInt32
The number of bytes in the buffer that represents actual data.
bufferLength
Type: SystemInt32
The number of bytes available for use in the buffer; actual buffer length must be at least large enough to fit the maximum size of the decompressed data. See MaximumSizeDecompressed(Int32).

Return Value

Type: Int32
The new length of the buffer after compression, unless the data cannot be compressed. If the data cannot be compressed, the buffer will remain unchanged and zero will be returned.
Exceptions
Exception | Condition
ArgumentNullException | source buffer cannot be null.
ArgumentOutOfRangeException | dataLength must be greater than or equal to one.
ArgumentOutOfRangeException | bufferLength must be at least as large as dataLength.
ArgumentOutOfRangeException | bufferLength must be at least as large as is necessary to fit the maximum possible size of the decompressed data.
ArgumentOutOfRangeException | Actual length of source buffer is less than specified bufferLength.
Remarks

Decompression is performed inline. The source buffer must be large enough to contain the maximum possible size of the decompressed buffer. This maximum size can be obtained by using the MaximumSizeDecompressed(Int32) method.

As an optimization this function is using pointers to native structures, as such the endian order decoding and encoding of the values will always be in the native endian order of the operating system.

See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.EmptyBuffer Method

Grid Solutions Framework PatternDecompressorEmptyBuffer Method
Clears out the data buffer so that subsequent calls to the Decompress methods do not use the data that was previously in the data buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EmptyBuffer()
Public Sub EmptyBuffer
member EmptyBuffer : unit -> unit

function EmptyBuffer();
public:
void EmptyBuffer()
Remarks
This method should not be called during normal operation, as data will be lost and the compressed stream will likely be corrupted. Only call this method if the stream has already been corrupted.
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.MaximumSizeDecompressed Method

Grid Solutions Framework PatternDecompressorMaximumSizeDecompressed Method
Given the size of a compressed buffer, provides the maximum possible size of the decompressed data.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int MaximumSizeDecompressed(
    int compressedLength
)
Public Shared Function MaximumSizeDecompressed (
    compressedLength As Integer
) As Integer
static member MaximumSizeDecompressed :
        compressedLength : int -> int

GSF.IO.Compression.PatternDecompressor.MaximumSizeDecompressed = function(compressedLength);
public:
static int MaximumSizeDecompressed(
    int compressedLength
)

Parameters

compressedLength
Type: SystemInt32
Size of the compressed buffer.

Return Value

Type: Int32
The maximum possible size of the data after decompression.
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.Reset Method

Grid Solutions Framework PatternDecompressorReset Method
Resets the decompressor by flushing the back buffer. Subsequent calls to the Decompress methods will not be decompressed using previously decompressed values.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor Properties

Grid Solutions Framework PatternDecompressor Properties

The PatternDecompressor type exposes the following members.

Properties
 | Name | Description
Public property | CompressionStrength | Gets the compression strength defined by the compressed stream.
Public property | DataBufferLength | Gets the length of the data left in the buffer.
Top
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.CompressionStrength Property

Grid Solutions Framework PatternDecompressorCompressionStrength Property
Gets the compression strength defined by the compressed stream.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte CompressionStrength { get; }
Public ReadOnly Property CompressionStrength As Byte
    Get
member CompressionStrength : byte with get

function get_CompressionStrength();

public:
property unsigned char CompressionStrength {
    unsigned char get ();
}

Property Value

Type: Byte
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


PatternDecompressor.DataBufferLength Property

Grid Solutions Framework PatternDecompressorDataBufferLength Property
Gets the length of the data left in the buffer.

Namespace: GSF.IO.Compression
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DataBufferLength { get; }
Public ReadOnly Property DataBufferLength As Integer
    Get
member DataBufferLength : int with get

function get_DataBufferLength();

public:
property int DataBufferLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PatternDecompressor Class
GSF.IO.Compression Namespace


GSF.Media Namespace

Grid Solutions Framework GSF.Media Namespace
Contains classes used to create and manipulate waveform audio format (WAV) files.
Classes
 | Class | Description
Public class | DataFormatSubType | Common sub-type GUID's for SubFormat property.
Public class | ListInfoChunk | Represents the list info chunk in a WAVE media format file.
Public class | RiffChunk | Represents the type ID and size for a "chunk" in a RIFF media format file.
Public class | RiffHeaderChunk | Represents the header chunk in a RIFF media format file.
Public class | WaveDataChunk | Represents the data chunk in a WAVE media format file.
Public class | WaveDataReader | Represents wave data coming from a stream.
Public class | WaveFile | Represents a waveform audio format file (WAV).
Public class | WaveFormatChunk | Represents the format chunk in a WAVE media format file.
 | WaveFormatExtensible | Represents the "extensible" format structure for a WAVE media format file.
Enumerations
 | Enumeration | Description
Public enumeration | BitsPerSample | Typical bit sizes supported by wave files.
Public enumeration | DataChannels | Typical number of data channels used by wave files.
Public enumeration | SampleRate | Typical samples rates supported by wave files.
Public enumeration | Speakers | Spatial positioning flags for ChannelMask property.
Public enumeration | WaveFormat | Common WAVE audio encoding formats.


BitsPerSample Enumeration

Grid Solutions Framework BitsPerSample Enumeration
Typical bit sizes supported by wave files.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum BitsPerSample
Public Enumeration BitsPerSample
type BitsPerSample
GSF.Media.BitsPerSample = function();
GSF.Media.BitsPerSample.createEnum('GSF.Media.BitsPerSample', false);
public enum class BitsPerSample
Members
Member name | Value | Description
Bits8 | 8 | 8-bits per sample
Bits16 | 16 | 16-bits per sample
Bits24 | 24 | 24-bits per sample
Bits32 | 32 | 32-bits per sample
Remarks
Strictly speaking, “bits-per-sample” describes the total number of bits used to encode the amplitude (or volume) of a sampled signal. The following table describes a few typical bit ranges and their possible resolution:
Bit range | Resolution
8-bits (1 Byte) | 0 to 255
16-bits (2 Bytes) | -32,768 to 32,767
24-bits (3 Bytes) | -8,388,608 to 8,388,607
32-bits (4 Bytes) | -2,147,483,648 to 2,147,483,647
The net result is that more bits you use, the more resolution you can achieve in amplitude; hence “more bits = better sound quality” however you have to compromise for technical constraints because “more bits = more required space”.
See Also

Reference

GSF.Media Namespace


DataChannels Enumeration

Grid Solutions Framework DataChannels Enumeration
Typical number of data channels used by wave files.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DataChannels
Public Enumeration DataChannels
type DataChannels
GSF.Media.DataChannels = function();
GSF.Media.DataChannels.createEnum('GSF.Media.DataChannels', false);
public enum class DataChannels
Members
Member name | Value | Description
Mono | 1 | Defines a single (monaural) data sample channel
Stereo | 2 | Defines two (stereo) data sample channels
DolbySurround | 3 | Defines three data sample channels
DolbyProLogic | 4 | Defines four data sample channels
DolbyDigital | 6 | Defines six data sample channels
Remarks
These are some common number of data channels, but wave files can support any number of data channels.
See Also

Reference

GSF.Media Namespace


DataFormatSubType Class

Grid Solutions Framework DataFormatSubType Class
Common sub-type GUID's for SubFormat property.
Inheritance Hierarchy
SystemObject
GSF.MediaDataFormatSubType

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class DataFormatSubType
Public NotInheritable Class DataFormatSubType
[<AbstractClassAttribute>]
[<SealedAttribute>]
type DataFormatSubType =  class end
GSF.Media.DataFormatSubType = function();

Type.createClass(
    'GSF.Media.DataFormatSubType');
public ref class DataFormatSubType abstract sealed

The DataFormatSubType type exposes the following members.

Fields
Name | Description
ADPCM | Adpative differential pulse-code modulation encoding algorithm
ALaw | A-law encoding algorithm (used in Europe and the rest of the world)
Analog | Analog sub-format.
DRM | Digital Rights Management encoded format (for digital-audio content protected by Microsoft DRM).
IeeeFloat | Floating point PCM encoding algorithm
Mpeg | MPEG Audio is a family of open standards for compressed audio that includes MP2, MP3 and AAC.
MuLaw | μ-law encoding algorithm (used in North America and Japan)
PCM | Standard pulse-code modulation audio format
Top
See Also

Reference

GSF.Media Namespace


DataFormatSubType Fields

Grid Solutions Framework DataFormatSubType Fields

The DataFormatSubType type exposes the following members.

Fields
Name | Description
ADPCM | Adpative differential pulse-code modulation encoding algorithm
ALaw | A-law encoding algorithm (used in Europe and the rest of the world)
Analog | Analog sub-format.
DRM | Digital Rights Management encoded format (for digital-audio content protected by Microsoft DRM).
IeeeFloat | Floating point PCM encoding algorithm
Mpeg | MPEG Audio is a family of open standards for compressed audio that includes MP2, MP3 and AAC.
MuLaw | μ-law encoding algorithm (used in North America and Japan)
PCM | Standard pulse-code modulation audio format
Top
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.ADPCM Field

Grid Solutions Framework DataFormatSubTypeADPCM Field
Adpative differential pulse-code modulation encoding algorithm

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ADPCM
Public Shared ADPCM As Guid
static val mutable ADPCM: Guid
var GSF.Media.DataFormatSubType.ADPCM
public:
static Guid ADPCM

Field Value

Type: Guid
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.ALaw Field

Grid Solutions Framework DataFormatSubTypeALaw Field
A-law encoding algorithm (used in Europe and the rest of the world)

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid ALaw
Public Shared ALaw As Guid
static val mutable ALaw: Guid
var GSF.Media.DataFormatSubType.ALaw
public:
static Guid ALaw

Field Value

Type: Guid
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.Analog Field

Grid Solutions Framework DataFormatSubTypeAnalog Field
Analog sub-format.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid Analog
Public Shared Analog As Guid
static val mutable Analog: Guid
var GSF.Media.DataFormatSubType.Analog
public:
static Guid Analog

Field Value

Type: Guid
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.DRM Field

Grid Solutions Framework DataFormatSubTypeDRM Field
Digital Rights Management encoded format (for digital-audio content protected by Microsoft DRM).

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid DRM
Public Shared DRM As Guid
static val mutable DRM: Guid
var GSF.Media.DataFormatSubType.DRM
public:
static Guid DRM

Field Value

Type: Guid
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.IeeeFloat Field

Grid Solutions Framework DataFormatSubTypeIeeeFloat Field
Floating point PCM encoding algorithm

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid IeeeFloat
Public Shared IeeeFloat As Guid
static val mutable IeeeFloat: Guid
var GSF.Media.DataFormatSubType.IeeeFloat
public:
static Guid IeeeFloat

Field Value

Type: Guid
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.Mpeg Field

Grid Solutions Framework DataFormatSubTypeMpeg Field
MPEG Audio is a family of open standards for compressed audio that includes MP2, MP3 and AAC.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid Mpeg
Public Shared Mpeg As Guid
static val mutable Mpeg: Guid
var GSF.Media.DataFormatSubType.Mpeg
public:
static Guid Mpeg

Field Value

Type: Guid
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.MuLaw Field

Grid Solutions Framework DataFormatSubTypeMuLaw Field
μ-law encoding algorithm (used in North America and Japan)

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid MuLaw
Public Shared MuLaw As Guid
static val mutable MuLaw: Guid
var GSF.Media.DataFormatSubType.MuLaw
public:
static Guid MuLaw

Field Value

Type: Guid
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


DataFormatSubType.PCM Field

Grid Solutions Framework DataFormatSubTypePCM Field
Standard pulse-code modulation audio format

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid PCM
Public Shared PCM As Guid
static val mutable PCM: Guid
var GSF.Media.DataFormatSubType.PCM
public:
static Guid PCM

Field Value

Type: Guid
Remarks
PCM (Pulse Code Modulation) is a common method of storing and transmitting uncompressed digital audio. Since it is a generic format, it can be read by most audio applications—similar to the way a plain text file can be read by any word-processing program. PCM is used by Audio CDs and digital audio tapes (DATs). PCM is also a very common format for AIFF and WAV files.
See Also

Reference

DataFormatSubType Class
GSF.Media Namespace


ListInfoChunk Class

Grid Solutions Framework ListInfoChunk Class
Represents the list info chunk in a WAVE media format file.
Inheritance Hierarchy
SystemObject
GSF.MediaRiffChunk
GSF.MediaListInfoChunk

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ListInfoChunk : RiffChunk
Public Class ListInfoChunk
    Inherits RiffChunk
type ListInfoChunk =
    class
        inherit RiffChunk
    end
GSF.Media.ListInfoChunk = function();

Type.createClass(
    'GSF.Media.ListInfoChunk',
    GSF.Media.RiffChunk);
public ref class ListInfoChunk : public RiffChunk

The ListInfoChunk type exposes the following members.

Constructors
 | Name | Description
Public method | ListInfoChunk | Reads a new WAVE list info section from the specified stream.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of the RiffChunk. (Inherited from RiffChunk.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RiffChunk and copies it into the given buffer. (Inherited from RiffChunk.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
RiffTypeID | Type ID of a WAVE list chunk.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of a RiffChunk consisting of type ID and chunk size (i.e., 8 bytes). (Inherited from RiffChunk.)
Public property | ChunkSize | Size of RiffChunk. (Inherited from RiffChunk.)
Public property | InfoStrings | Gets list of info strings from list info blocks of this ListInfoChunk.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Top
See Also

Reference

GSF.Media Namespace


ListInfoChunk Constructor

Grid Solutions Framework ListInfoChunk Constructor
Reads a new WAVE list info section from the specified stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ListInfoChunk(
    RiffChunk preRead,
    Stream source
)
Public Sub New (
    preRead As RiffChunk,
    source As Stream
)
new :
        preRead : RiffChunk *
        source : Stream -> ListInfoChunk
GSF.Media.ListInfoChunk = function(preRead, source);
public:
ListInfoChunk(
    RiffChunk^ preRead,
    Stream^ source
)

Parameters

preRead
Type: GSF.MediaRiffChunk
Pre-parsed RiffChunk header.
source
Type: System.IOStream
Source stream to read data from.
Exceptions
Exception | Condition
InvalidOperationException | WAVE list info section is too small, wave file corrupted.
See Also

Reference

ListInfoChunk Class
GSF.Media Namespace


ListInfoChunk Fields

Grid Solutions Framework ListInfoChunk Fields

The ListInfoChunk type exposes the following members.

Fields
Name | Description
RiffTypeID | Type ID of a WAVE list chunk.
Top
See Also

Reference

ListInfoChunk Class
GSF.Media Namespace


ListInfoChunk.RiffTypeID Field

Grid Solutions Framework ListInfoChunkRiffTypeID Field
Type ID of a WAVE list chunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string RiffTypeID
Public Const RiffTypeID As String
static val mutable RiffTypeID: string
var GSF.Media.ListInfoChunk.RiffTypeID
public:
literal String^ RiffTypeID

Field Value

Type: String
See Also

Reference

ListInfoChunk Class
GSF.Media Namespace


ListInfoChunk Methods

Grid Solutions Framework ListInfoChunk Methods

The ListInfoChunk type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of the RiffChunk. (Inherited from RiffChunk.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RiffChunk and copies it into the given buffer. (Inherited from RiffChunk.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ListInfoChunk Class
GSF.Media Namespace


ListInfoChunk Properties

Grid Solutions Framework ListInfoChunk Properties

The ListInfoChunk type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of a RiffChunk consisting of type ID and chunk size (i.e., 8 bytes). (Inherited from RiffChunk.)
Public property | ChunkSize | Size of RiffChunk. (Inherited from RiffChunk.)
Public property | InfoStrings | Gets list of info strings from list info blocks of this ListInfoChunk.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Top
See Also

Reference

ListInfoChunk Class
GSF.Media Namespace


ListInfoChunk.InfoStrings Property

Grid Solutions Framework ListInfoChunkInfoStrings Property
Gets list of info strings from list info blocks of this ListInfoChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<string, string> InfoStrings { get; }
Public ReadOnly Property InfoStrings As Dictionary(Of String, String)
    Get
member InfoStrings : Dictionary<string, string> with get

function get_InfoStrings();

public:
property Dictionary<String^, String^>^ InfoStrings {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary String, String
See Also

Reference

ListInfoChunk Class
GSF.Media Namespace


RiffChunk Class

Grid Solutions Framework RiffChunk Class
Represents the type ID and size for a "chunk" in a RIFF media format file.
Inheritance Hierarchy
SystemObject
GSF.MediaRiffChunk
GSF.MediaListInfoChunk
GSF.MediaRiffHeaderChunk
GSF.MediaWaveDataChunk
GSF.MediaWaveFormatChunk

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RiffChunk : ISupportBinaryImage
Public Class RiffChunk
    Implements ISupportBinaryImage
type RiffChunk =
    class
        interface ISupportBinaryImage
    end
GSF.Media.RiffChunk = function();

Type.createClass(
    'GSF.Media.RiffChunk',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class RiffChunk : ISupportBinaryImage

The RiffChunk type exposes the following members.

Constructors
 | Name | Description
Public method | RiffChunk(String) | Constructs a new RiffChunk for the given typeID.
Protected method | RiffChunk(RiffChunk, String) | Constructor for derived classes used to initialize and validate RiffChunk properties.
Top
Methods
 | Name | Description
Public method | Clone | Creates a copy of the RiffChunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RiffChunk and copies it into the given buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadNext | Attempts to read the next RIFF chunk from the source stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | The fixed byte length of a RiffChunk instance.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of a RiffChunk consisting of type ID and chunk size (i.e., 8 bytes).
Public property | ChunkSize | Size of RiffChunk.
Public property | TypeID | Four character text identifer for RIFF chunk.
Top
Remarks

The Resource Interchange File Format (RIFF) is a generic meta-format for storing data in tagged chunks. It was introduced in 1991 by Microsoft and IBM, and was presented by Microsoft as the default format for Windows 3.1 multimedia files. It is based on Electronic Arts's Interchange File Format, introduced in 1985, the only difference being that multi-byte integers are in little-endian format, native to the 80x86 processor series used in IBM PCs, rather than the big-endian format native to the 68k processor series used in Amiga and Apple Macintosh computers, where IFF files were heavily used. (The specification for AIFF, the big-endian analogue of RIFF, was published by Apple Computer in 1988.) The Microsoft implementation is mostly known through file formats like AVI, ANI and WAV, which use the RIFF meta-format as their basis.

Some common RIFF file types:

File extension | Description
WAV | Windows audio file
AVI | Windows audio/video file
ANI | Animated Windows cursors
RMI | Windows RIFF MIDI file
CDR | CorelDRAW vector graphics file

See Also

Reference

GSF.Media Namespace


RiffChunk Constructor

Grid Solutions Framework RiffChunk Constructor
Overload List
 | Name | Description
Public method | RiffChunk(String) | Constructs a new RiffChunk for the given typeID.
Protected method | RiffChunk(RiffChunk, String) | Constructor for derived classes used to initialize and validate RiffChunk properties.
Top
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk Constructor (String)

Grid Solutions Framework RiffChunk Constructor (String)
Constructs a new RiffChunk for the given typeID.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RiffChunk(
    string typeID
)
Public Sub New (
    typeID As String
)
new :
        typeID : string -> RiffChunk
GSF.Media.RiffChunk = function(typeID);
public:
RiffChunk(
    String^ typeID
)

Parameters

typeID
Type: SystemString
Expected type ID.
See Also

Reference

RiffChunk Class
RiffChunk Overload
GSF.Media Namespace


RiffChunk Constructor (RiffChunk, String)

Grid Solutions Framework RiffChunk Constructor (RiffChunk, String)
Constructor for derived classes used to initialize and validate RiffChunk properties.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RiffChunk(
    RiffChunk preRead,
    string typeID
)
Protected Sub New (
    preRead As RiffChunk,
    typeID As String
)
new :
        preRead : RiffChunk *
        typeID : string -> RiffChunk
GSF.Media.RiffChunk = function(preRead, typeID);
protected:
RiffChunk(
    RiffChunk^ preRead,
    String^ typeID
)

Parameters

preRead
Type: GSF.MediaRiffChunk
Pre-parsed RiffChunk header.
typeID
Type: SystemString
Expected type ID.
See Also

Reference

RiffChunk Class
RiffChunk Overload
GSF.Media Namespace


RiffChunk Fields

Grid Solutions Framework RiffChunk Fields

The RiffChunk type exposes the following members.

Fields
Name | Description
FixedLength | The fixed byte length of a RiffChunk instance.
Top
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk.FixedLength Field

Grid Solutions Framework RiffChunkFixedLength Field
The fixed byte length of a RiffChunk instance.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Media.RiffChunk.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk Methods

Grid Solutions Framework RiffChunk Methods

The RiffChunk type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a copy of the RiffChunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this RiffChunk and copies it into the given buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadNext | Attempts to read the next RIFF chunk from the source stream.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk.Clone Method

Grid Solutions Framework RiffChunkClone Method
Creates a copy of the RiffChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RiffChunk Clone()
Public Function Clone As RiffChunk
member Clone : unit -> RiffChunk

function Clone();
public:
RiffChunk^ Clone()

Return Value

Type: RiffChunk
A new copy of the RiffChunk.
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk.GenerateBinaryImage Method

Grid Solutions Framework RiffChunkGenerateBinaryImage Method
Generates a binary representation of this RiffChunk and copies it into the given buffer.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk.ReadNext Method

Grid Solutions Framework RiffChunkReadNext Method
Attempts to read the next RIFF chunk from the source stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static RiffChunk ReadNext(
    Stream source
)
Public Shared Function ReadNext (
    source As Stream
) As RiffChunk
static member ReadNext :
        source : Stream -> RiffChunk

GSF.Media.RiffChunk.ReadNext = function(source);
public:
static RiffChunk^ ReadNext(
    Stream^ source
)

Parameters

source
Type: System.IOStream
Source stream for next RIFF chunk.

Return Value

Type: RiffChunk
Next RIFF chunk read from the source stream.
Exceptions
Exception | Condition
InvalidOperationException | RIFF chunk too small, media file corrupted.
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk Properties

Grid Solutions Framework RiffChunk Properties

The RiffChunk type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of a RiffChunk consisting of type ID and chunk size (i.e., 8 bytes).
Public property | ChunkSize | Size of RiffChunk.
Public property | TypeID | Four character text identifer for RIFF chunk.
Top
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk.BinaryLength Property

Grid Solutions Framework RiffChunkBinaryLength Property
Gets the length of a RiffChunk consisting of type ID and chunk size (i.e., 8 bytes).

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int BinaryLength { get; }
Public Overridable ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get ();
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk.ChunkSize Property

Grid Solutions Framework RiffChunkChunkSize Property
Size of RiffChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ChunkSize { get; set; }
Public Overridable Property ChunkSize As Integer
    Get
    Set
abstract ChunkSize : int with get, set
override ChunkSize : int with get, set
function get_ChunkSize();
function set_ChunkSize(value);
public:
virtual property int ChunkSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffChunk.TypeID Property

Grid Solutions Framework RiffChunkTypeID Property
Four character text identifer for RIFF chunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string TypeID { get; set; }
Public Property TypeID As String
    Get
    Set
member TypeID : string with get, set

function get_TypeID();
function set_TypeID(value);
public:
property String^ TypeID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | TypeID cannot be null.
ArgumentOutOfRangeException | TypeID must be extactly 4 characters in length.
See Also

Reference

RiffChunk Class
GSF.Media Namespace


RiffHeaderChunk Class

Grid Solutions Framework RiffHeaderChunk Class
Represents the header chunk in a RIFF media format file.
Inheritance Hierarchy
SystemObject
GSF.MediaRiffChunk
GSF.MediaRiffHeaderChunk

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RiffHeaderChunk : RiffChunk,
    ISupportBinaryImage
Public Class RiffHeaderChunk
    Inherits RiffChunk
    Implements ISupportBinaryImage
type RiffHeaderChunk =
    class
        inherit RiffChunk
        interface ISupportBinaryImage
    end
GSF.Media.RiffHeaderChunk = function();

Type.createClass(
    'GSF.Media.RiffHeaderChunk',
    GSF.Media.RiffChunk,
    GSF.Parsing.ISupportBinaryImage);
public ref class RiffHeaderChunk : public RiffChunk,
    ISupportBinaryImage

The RiffHeaderChunk type exposes the following members.

Constructors
 | Name | Description
Public method | RiffHeaderChunk(String) | Constructs a new RIFF header chunk for the specified format.
Public method | RiffHeaderChunk(RiffChunk, Stream, String) | Reads a new RIFF header from the specified stream.
Top
Methods
 | Name | Description
Public method | Clone | Returns a cloned instance of this RIFF header chunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer. (Overrides RiffChunkGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | The fixed byte length of a RiffChunk instance.
RiffTypeID | Type ID of a RIFF header chunk.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets length of binary representation of RIFF header chunk.
Public property | ChunkSize | Size of RiffChunk. (Inherited from RiffChunk.)
Public property | Format | Gets or sets format for RIFF header chunk.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Top
See Also

Reference

GSF.Media Namespace


RiffHeaderChunk Constructor

Grid Solutions Framework RiffHeaderChunk Constructor
Overload List
 | Name | Description
Public method | RiffHeaderChunk(String) | Constructs a new RIFF header chunk for the specified format.
Public method | RiffHeaderChunk(RiffChunk, Stream, String) | Reads a new RIFF header from the specified stream.
Top
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk Constructor (String)

Grid Solutions Framework RiffHeaderChunk Constructor (String)
Constructs a new RIFF header chunk for the specified format.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RiffHeaderChunk(
    string format
)
Public Sub New (
    format As String
)
new :
        format : string -> RiffHeaderChunk
GSF.Media.RiffHeaderChunk = function(format);
public:
RiffHeaderChunk(
    String^ format
)

Parameters

format
Type: SystemString
RIFF header chunk header format.
See Also

Reference

RiffHeaderChunk Class
RiffHeaderChunk Overload
GSF.Media Namespace


RiffHeaderChunk Constructor (RiffChunk, Stream, String)

Grid Solutions Framework RiffHeaderChunk Constructor (RiffChunk, Stream, String)
Reads a new RIFF header from the specified stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RiffHeaderChunk(
    RiffChunk preRead,
    Stream source,
    string format
)
Public Sub New (
    preRead As RiffChunk,
    source As Stream,
    format As String
)
new :
        preRead : RiffChunk *
        source : Stream *
        format : string -> RiffHeaderChunk
GSF.Media.RiffHeaderChunk = function(preRead, source, format);
public:
RiffHeaderChunk(
    RiffChunk^ preRead,
    Stream^ source,
    String^ format
)

Parameters

preRead
Type: GSF.MediaRiffChunk
Pre-parsed RiffChunk header.
source
Type: System.IOStream
Source stream to read data from.
format
Type: SystemString
Expected RIFF media format (e.g., "WAVE").
Exceptions
Exception | Condition
ArgumentNullException | format cannot be null.
ArgumentOutOfRangeException | format must be extactly 4 characters in length.
See Also

Reference

RiffHeaderChunk Class
RiffHeaderChunk Overload
GSF.Media Namespace


RiffHeaderChunk Fields

Grid Solutions Framework RiffHeaderChunk Fields

The RiffHeaderChunk type exposes the following members.

Fields
Name | Description
FixedLength | The fixed byte length of a RiffChunk instance.
RiffTypeID | Type ID of a RIFF header chunk.
Top
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk.FixedLength Field

Grid Solutions Framework RiffHeaderChunkFixedLength Field
The fixed byte length of a RiffChunk instance.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Media.RiffHeaderChunk.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk.RiffTypeID Field

Grid Solutions Framework RiffHeaderChunkRiffTypeID Field
Type ID of a RIFF header chunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string RiffTypeID
Public Const RiffTypeID As String
static val mutable RiffTypeID: string
var GSF.Media.RiffHeaderChunk.RiffTypeID
public:
literal String^ RiffTypeID

Field Value

Type: String
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk Methods

Grid Solutions Framework RiffHeaderChunk Methods

The RiffHeaderChunk type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Returns a cloned instance of this RIFF header chunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer. (Overrides RiffChunkGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk.Clone Method

Grid Solutions Framework RiffHeaderChunkClone Method
Returns a cloned instance of this RIFF header chunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RiffHeaderChunk Clone()
Public Function Clone As RiffHeaderChunk
member Clone : unit -> RiffHeaderChunk

function Clone();
public:
RiffHeaderChunk^ Clone()

Return Value

Type: RiffHeaderChunk
A cloned instance of this RIFF header chunk.
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk.GenerateBinaryImage Method

Grid Solutions Framework RiffHeaderChunkGenerateBinaryImage Method
Generates binary image of the object and copies it into the given buffer.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk Properties

Grid Solutions Framework RiffHeaderChunk Properties

The RiffHeaderChunk type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets length of binary representation of RIFF header chunk.
Public property | ChunkSize | Size of RiffChunk. (Inherited from RiffChunk.)
Public property | Format | Gets or sets format for RIFF header chunk.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Top
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk.BinaryLength Property

Grid Solutions Framework RiffHeaderChunkBinaryLength Property
Gets length of binary representation of RIFF header chunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


RiffHeaderChunk.Format Property

Grid Solutions Framework RiffHeaderChunkFormat Property
Gets or sets format for RIFF header chunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Format { get; set; }
Public Property Format As String
    Get
    Set
member Format : string with get, set

function get_Format();
function set_Format(value);
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RiffHeaderChunk Class
GSF.Media Namespace


SampleRate Enumeration

Grid Solutions Framework SampleRate Enumeration
Typical samples rates supported by wave files.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SampleRate
Public Enumeration SampleRate
type SampleRate
GSF.Media.SampleRate = function();
GSF.Media.SampleRate.createEnum('GSF.Media.SampleRate', false);
public enum class SampleRate
Members
Member name | Value | Description
Hz8000 | 8000 | 8000 samples per second
Hz11025 | 11025 | 11025 samples per second
Hz12000 | 12000 | 12000 samples per second
Hz16000 | 16000 | 16000 samples per second
Hz22050 | 22050 | 22050 samples per second
Hz24000 | 24000 | 24000 samples per second
Hz32000 | 32000 | 32000 samples per second
Hz44100 | 44100 | 44100 samples per second
Hz48000 | 48000 | 48000 samples per second
Remarks

Quantization of the analog waveform, or signal, is a real-time process operating over a continuous time-period which produces a “stream” of digital values. In order for the process to work you must define the rate at which new digital values are measured, or sampled, from the analog signal. The rate at which new values are measured is called the “sampling rate” (a.k.a., the sampling frequency).

Audio based Compact Discs use a sampling rate of 44,100 Hz; this means the the Nyquist frequency is 22,050 Hz (i.e., the upper bound on the highest frequency that the digital data can clearly represent without aliasing). This sample rate selection was no accident as the range of hearing for a healthy young person is approximately 20 to 20,000 Hz.

In plain English, higher sampling rates will equate to higher quality sound reproduction but anything above 44,100 Hz will not be perceived as better quality by normal human beings.

See Also

Reference

GSF.Media Namespace


Speakers Enumeration

Grid Solutions Framework Speakers Enumeration
Spatial positioning flags for ChannelMask property.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum Speakers
<FlagsAttribute>
Public Enumeration Speakers
[<FlagsAttribute>]
type Speakers
GSF.Media.Speakers = function();
GSF.Media.Speakers.createEnum('GSF.Media.Speakers', true);
[FlagsAttribute]
public enum class Speakers
Members
Member name | Value | Description
Undefined | 0 | Speaker positions undefined.
FrontLeft | 1 | Front left speaker position.
FrontRight | 2 | Front right speaker position.
FronCenter | 4 | Front center speaker position.
LowFrequency | 8 | Low frequency speaker.
BackLeft | 16 | Back left speaker position.
BackRight | 32 | back right speaker position.
FronLeftOfCenter | 64 | Front left of center speaker position.
FronRightOfCenter | 128 | Front right of center speaker position.
BackCenter | 256 | Back center speaker position.
SideLeft | 512 | Side left speaker position.
SideRight | 1024 | Side right speaker position.
TopCenter | 2048 | Top center speaker position.
TopFrontLeft | 4096 | Top front left speaker position.
TopFrontCenter | 8192 | Top front center speaker position.
TopFrontRight | 16384 | Top front right speaker position.
TopBackLeft | 32768 | Top back left speaker position.
TopBackCenter | 65536 | Top back center speaker position.
TopBackRight | 131072 | Top back right speaker position.
Reserved | 2147221504 | Reserved flags for Speakers enumeration.
All | -2147483648 | All Speaker positions defined.
See Also

Reference

GSF.Media Namespace


WaveDataChunk Class

Grid Solutions Framework WaveDataChunk Class
Represents the data chunk in a WAVE media format file.
Inheritance Hierarchy
SystemObject
GSF.MediaRiffChunk
GSF.MediaWaveDataChunk

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class WaveDataChunk : RiffChunk,
    ISupportBinaryImage
Public Class WaveDataChunk
    Inherits RiffChunk
    Implements ISupportBinaryImage
type WaveDataChunk =
    class
        inherit RiffChunk
        interface ISupportBinaryImage
    end
GSF.Media.WaveDataChunk = function();

Type.createClass(
    'GSF.Media.WaveDataChunk',
    GSF.Media.RiffChunk,
    GSF.Parsing.ISupportBinaryImage);
public ref class WaveDataChunk : public RiffChunk,
    ISupportBinaryImage

The WaveDataChunk type exposes the following members.

Constructors
 | Name | Description
Public method | WaveDataChunk(WaveFormatChunk) | Constructs a new WAVE data chunk for the specified format.
Public method | WaveDataChunk(RiffChunk, Stream, WaveFormatChunk) | Reads a new WAVE format section from the specified stream.
Top
Methods
 | Name | Description
Public method | Clone | Creates a deeply cloned copy of the WaveDataChunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this WaveDataChunk and copies it into the given buffer. (Overrides RiffChunkGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
RiffTypeID | Type ID of a WAVE data chunk.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets length of the binary representation of this WaveDataChunk. (Overrides RiffChunkBinaryLength.)
Public property | ChunkSize | Gets the chunk size of this WaveDataChunk. (Overrides RiffChunkChunkSize.)
Public property | SampleBlocks | Gets list of little-endian formatted sample data blocks of this WaveDataChunk.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Public property | WaveFormat | Gets or sets associated WaveFormatChunk that defines the format of the data in this WaveDataChunk.
Top
See Also

Reference

GSF.Media Namespace


WaveDataChunk Constructor

Grid Solutions Framework WaveDataChunk Constructor
Overload List
 | Name | Description
Public method | WaveDataChunk(WaveFormatChunk) | Constructs a new WAVE data chunk for the specified format.
Public method | WaveDataChunk(RiffChunk, Stream, WaveFormatChunk) | Reads a new WAVE format section from the specified stream.
Top
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk Constructor (WaveFormatChunk)

Grid Solutions Framework WaveDataChunk Constructor (WaveFormatChunk)
Constructs a new WAVE data chunk for the specified format.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveDataChunk(
    WaveFormatChunk waveFormat
)
Public Sub New (
    waveFormat As WaveFormatChunk
)
new :
        waveFormat : WaveFormatChunk -> WaveDataChunk
GSF.Media.WaveDataChunk = function(waveFormat);
public:
WaveDataChunk(
    WaveFormatChunk^ waveFormat
)

Parameters

waveFormat
Type: GSF.MediaWaveFormatChunk
WaveFormatChunk that describes this WaveDataChunk.
See Also

Reference

WaveDataChunk Class
WaveDataChunk Overload
GSF.Media Namespace


WaveDataChunk Constructor (RiffChunk, Stream, WaveFormatChunk)

Grid Solutions Framework WaveDataChunk Constructor (RiffChunk, Stream, WaveFormatChunk)
Reads a new WAVE format section from the specified stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveDataChunk(
    RiffChunk preRead,
    Stream source,
    WaveFormatChunk waveFormat
)
Public Sub New (
    preRead As RiffChunk,
    source As Stream,
    waveFormat As WaveFormatChunk
)
new :
        preRead : RiffChunk *
        source : Stream *
        waveFormat : WaveFormatChunk -> WaveDataChunk
GSF.Media.WaveDataChunk = function(preRead, source, waveFormat);
public:
WaveDataChunk(
    RiffChunk^ preRead,
    Stream^ source,
    WaveFormatChunk^ waveFormat
)

Parameters

preRead
Type: GSF.MediaRiffChunk
Pre-parsed RiffChunk header.
source
Type: System.IOStream
Source stream to read data from.
waveFormat
Type: GSF.MediaWaveFormatChunk
Format of the data section to be parsed.
Exceptions
Exception | Condition
InvalidOperationException | WAVE format or extra parameters section too small, wave file corrupted.
See Also

Reference

WaveDataChunk Class
WaveDataChunk Overload
GSF.Media Namespace


WaveDataChunk Fields

Grid Solutions Framework WaveDataChunk Fields

The WaveDataChunk type exposes the following members.

Fields
Name | Description
RiffTypeID | Type ID of a WAVE data chunk.
Top
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk.RiffTypeID Field

Grid Solutions Framework WaveDataChunkRiffTypeID Field
Type ID of a WAVE data chunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string RiffTypeID
Public Const RiffTypeID As String
static val mutable RiffTypeID: string
var GSF.Media.WaveDataChunk.RiffTypeID
public:
literal String^ RiffTypeID

Field Value

Type: String
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk Methods

Grid Solutions Framework WaveDataChunk Methods

The WaveDataChunk type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a deeply cloned copy of the WaveDataChunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this WaveDataChunk and copies it into the given buffer. (Overrides RiffChunkGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk.Clone Method

Grid Solutions Framework WaveDataChunkClone Method
Creates a deeply cloned copy of the WaveDataChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveDataChunk Clone()
Public Function Clone As WaveDataChunk
member Clone : unit -> WaveDataChunk

function Clone();
public:
WaveDataChunk^ Clone()

Return Value

Type: WaveDataChunk
A deeply cloned copy of the WaveDataChunk.
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk.GenerateBinaryImage Method

Grid Solutions Framework WaveDataChunkGenerateBinaryImage Method
Generates a binary representation of this WaveDataChunk and copies it into the given buffer.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk Properties

Grid Solutions Framework WaveDataChunk Properties

The WaveDataChunk type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets length of the binary representation of this WaveDataChunk. (Overrides RiffChunkBinaryLength.)
Public property | ChunkSize | Gets the chunk size of this WaveDataChunk. (Overrides RiffChunkChunkSize.)
Public property | SampleBlocks | Gets list of little-endian formatted sample data blocks of this WaveDataChunk.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Public property | WaveFormat | Gets or sets associated WaveFormatChunk that defines the format of the data in this WaveDataChunk.
Top
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk.BinaryLength Property

Grid Solutions Framework WaveDataChunkBinaryLength Property
Gets length of the binary representation of this WaveDataChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk.ChunkSize Property

Grid Solutions Framework WaveDataChunkChunkSize Property
Gets the chunk size of this WaveDataChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ChunkSize { get; set; }
Public Overrides Property ChunkSize As Integer
    Get
    Set
abstract ChunkSize : int with get, set
override ChunkSize : int with get, set
function get_ChunkSize();
function set_ChunkSize(value);
public:
virtual property int ChunkSize {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk.SampleBlocks Property

Grid Solutions Framework WaveDataChunkSampleBlocks Property
Gets list of little-endian formatted sample data blocks of this WaveDataChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<LittleBinaryValue[]> SampleBlocks { get; }
Public ReadOnly Property SampleBlocks As List(Of LittleBinaryValue())
    Get
member SampleBlocks : List<LittleBinaryValue[]> with get

function get_SampleBlocks();

public:
property List<array<LittleBinaryValue^>^>^ SampleBlocks {
    List<array<LittleBinaryValue^>^>^ get ();
}

Property Value

Type: List LittleBinaryValue
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataChunk.WaveFormat Property

Grid Solutions Framework WaveDataChunkWaveFormat Property
Gets or sets associated WaveFormatChunk that defines the format of the data in this WaveDataChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatChunk WaveFormat { get; set; }
Public Property WaveFormat As WaveFormatChunk
    Get
    Set
member WaveFormat : WaveFormatChunk with get, set

function get_WaveFormat();
function set_WaveFormat(value);
public:
property WaveFormatChunk^ WaveFormat {
    WaveFormatChunk^ get ();
    void set (WaveFormatChunk^ value);
}

Property Value

Type: WaveFormatChunk
See Also

Reference

WaveDataChunk Class
GSF.Media Namespace


WaveDataReader Class

Grid Solutions Framework WaveDataReader Class
Represents wave data coming from a stream.
Inheritance Hierarchy
SystemObject
GSF.MediaWaveDataReader

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class WaveDataReader : IDisposable
Public Class WaveDataReader
    Implements IDisposable
type WaveDataReader =
    class
        interface IDisposable
    end
GSF.Media.WaveDataReader = function();

Type.createClass(
    'GSF.Media.WaveDataReader',
    null,
    IDisposable);
public ref class WaveDataReader : IDisposable

The WaveDataReader type exposes the following members.

Constructors
 | Name | Description
Public method | WaveDataReader(Stream) | Creates a new instance of the WaveDataReader class.
Public method | WaveDataReader(WaveFormatChunk, Stream) | Creates a new instance of the WaveDataReader class.
Top
Methods
 | Name | Description
Public method | Close | Closes the underlying stream.
Public method | Dispose | Disposes of the underlying stream.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromFile | Creates a WaveDataReader instance created from a WAV file.
 | FromStream | Creates a WaveDataReader instance created from a WAV stream.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextSample | Reads and returns the next sample from the stream.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Format | Gets the format of the wave data.
Public property | WaveStream | Gets the underlying stream providing wave data.
Top
Remarks
This class is meant to be used when loading the entirety of a wave file into memory is not a viable option. With it, samples can be read directly from the data stream in the order that they appear.
See Also

Reference

GSF.Media Namespace


WaveDataReader Constructor

Grid Solutions Framework WaveDataReader Constructor
Overload List
 | Name | Description
Public method | WaveDataReader(Stream) | Creates a new instance of the WaveDataReader class.
Public method | WaveDataReader(WaveFormatChunk, Stream) | Creates a new instance of the WaveDataReader class.
Top
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader Constructor (Stream)

Grid Solutions Framework WaveDataReader Constructor (Stream)
Creates a new instance of the WaveDataReader class.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveDataReader(
    Stream waveStream
)
Public Sub New (
    waveStream As Stream
)
new :
        waveStream : Stream -> WaveDataReader
GSF.Media.WaveDataReader = function(waveStream);
public:
WaveDataReader(
    Stream^ waveStream
)

Parameters

waveStream
Type: System.IOStream
The stream containing wave data.
See Also

Reference

WaveDataReader Class
WaveDataReader Overload
GSF.Media Namespace


WaveDataReader Constructor (WaveFormatChunk, Stream)

Grid Solutions Framework WaveDataReader Constructor (WaveFormatChunk, Stream)
Creates a new instance of the WaveDataReader class.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveDataReader(
    WaveFormatChunk waveFormat,
    Stream waveStream
)
Public Sub New (
    waveFormat As WaveFormatChunk,
    waveStream As Stream
)
new :
        waveFormat : WaveFormatChunk *
        waveStream : Stream -> WaveDataReader
GSF.Media.WaveDataReader = function(waveFormat, waveStream);
public:
WaveDataReader(
    WaveFormatChunk^ waveFormat,
    Stream^ waveStream
)

Parameters

waveFormat
Type: GSF.MediaWaveFormatChunk
The format of the wave stream.
waveStream
Type: System.IOStream
The stream containing wave data.
See Also

Reference

WaveDataReader Class
WaveDataReader Overload
GSF.Media Namespace


WaveDataReader Methods

Grid Solutions Framework WaveDataReader Methods

The WaveDataReader type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the underlying stream.
Public method | Dispose | Disposes of the underlying stream.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | FromFile | Creates a WaveDataReader instance created from a WAV file.
 | FromStream | Creates a WaveDataReader instance created from a WAV stream.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetNextSample | Reads and returns the next sample from the stream.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader.Close Method

Grid Solutions Framework WaveDataReaderClose Method
Closes the underlying stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader.Dispose Method

Grid Solutions Framework WaveDataReaderDispose Method
Disposes of the underlying stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader.FromFile Method

Grid Solutions Framework WaveDataReaderFromFile Method
Creates a WaveDataReader instance created from a WAV file.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WaveDataReader FromFile(
    string fileName
)
Public Shared Function FromFile (
    fileName As String
) As WaveDataReader
static member FromFile :
        fileName : string -> WaveDataReader

GSF.Media.WaveDataReader.FromFile = function(fileName);
public:
static WaveDataReader^ FromFile(
    String^ fileName
)

Parameters

fileName
Type: SystemString
The name of the WAV file.

Return Value

Type: WaveDataReader
The WaveData instance created from a WAV file.
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader.FromStream Method

Grid Solutions Framework WaveDataReaderFromStream Method
Creates a WaveDataReader instance created from a WAV stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WaveDataReader FromStream(
    Stream waveStream
)
Public Shared Function FromStream (
    waveStream As Stream
) As WaveDataReader
static member FromStream :
        waveStream : Stream -> WaveDataReader

GSF.Media.WaveDataReader.FromStream = function(waveStream);
public:
static WaveDataReader^ FromStream(
    Stream^ waveStream
)

Parameters

waveStream
Type: System.IOStream
The WAV stream. The data in the stream must include all headers that would be present in a WAV file.

Return Value

Type: WaveDataReader
The WaveData instance created from a WAV stream.
Remarks
This method is similar to the WaveDataReader(Stream) constructor, however this method will first search the stream for a format chunk in order to set up the WaveData object with proper format info.
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader.GetNextSample Method

Grid Solutions Framework WaveDataReaderGetNextSample Method
Reads and returns the next sample from the stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue[] GetNextSample()
Public Function GetNextSample As LittleBinaryValue()
member GetNextSample : unit -> LittleBinaryValue[]

function GetNextSample();
public:
array<LittleBinaryValue^>^ GetNextSample()

Return Value

Type: LittleBinaryValue
The next sample from the stream. The sample is returned as an array of LittleBinaryValues. Each LittleBinaryValue represents a different channel. A return value of null indicates the end of stream has been reached.
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader Properties

Grid Solutions Framework WaveDataReader Properties

The WaveDataReader type exposes the following members.

Properties
 | Name | Description
Public property | Format | Gets the format of the wave data.
Public property | WaveStream | Gets the underlying stream providing wave data.
Top
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader.Format Property

Grid Solutions Framework WaveDataReaderFormat Property
Gets the format of the wave data.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatChunk Format { get; }
Public ReadOnly Property Format As WaveFormatChunk
    Get
member Format : WaveFormatChunk with get

function get_Format();

public:
property WaveFormatChunk^ Format {
    WaveFormatChunk^ get ();
}

Property Value

Type: WaveFormatChunk
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveDataReader.WaveStream Property

Grid Solutions Framework WaveDataReaderWaveStream Property
Gets the underlying stream providing wave data.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Stream WaveStream { get; }
Public ReadOnly Property WaveStream As Stream
    Get
member WaveStream : Stream with get

function get_WaveStream();

public:
property Stream^ WaveStream {
    Stream^ get ();
}

Property Value

Type: Stream
See Also

Reference

WaveDataReader Class
GSF.Media Namespace


WaveFile Class

Grid Solutions Framework WaveFile Class
Represents a waveform audio format file (WAV).
Inheritance Hierarchy
SystemObject
GSF.MediaWaveFile
GSF.Media.MusicSong

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class WaveFile
Public Class WaveFile
type WaveFile =  class end
GSF.Media.WaveFile = function();

Type.createClass(
    'GSF.Media.WaveFile');
public ref class WaveFile

The WaveFile type exposes the following members.

Constructors
 | Name | Description
Public method | WaveFile | Creates a new empty in-memory wave file using standard CD quality settings.
Public method | WaveFile(Int32, Int16, Int16) | Creates a new empty in-memory wave file in Pulse Code Modulation (PCM) audio format.
Public method | WaveFile(SampleRate, BitsPerSample, DataChannels) | Creates a new empty in-memory wave file in Pulse Code Modulation (PCM) audio format.
Public method | WaveFile(Int32, Int16, Int16, UInt16) | Creates a new empty in-memory wave file in specified audio format.
Public method | WaveFile(RiffHeaderChunk, WaveFormatChunk, WaveDataChunk, ListInfoChunk) | Creates a new empty in-memory wave file using existing constituent chunks.
Public method | WaveFile(SampleRate, BitsPerSample, DataChannels, WaveFormat) | Creates a new empty in-memory wave file in specified audio format.
Top
Methods
 | Name | Description
Public method | AddSample | Add the sample to the wave file.
Public method | AddSampleBlock | Adds a block of samples in native format to the wave file (e.g., if BitsPerSample = 16, parameters need to be Int16 values). Note that LittleBinaryValue parameter type is implicitly castable to common native types, including floating points.
Public method | AddSamples | Adds a series of samples, one per channel, to the wave file.
 | Append | Appends wave files together, one after another, into a single file.
Public method | CastSample | Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat.
Public method | Clone | Creates a deeply cloned copy of the WaveFile.
 | CloneSampleBlock | Performs a deep clone of all the channel samples in a sample block.
 | Combine(WaveFile) | Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.
 | Combine(WaveFile, Double) | Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSampleTypeCode | Determines sample data type code based on defined BitsPerSample and AudioFormat.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load(Stream, Boolean) | Creates a new in-memory wave loaded from an existing wave audio stream.
 | Load(String, Boolean) | Creates a new in-memory wave loaded from an existing wave file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Play | Plays the wave file using SoundPlayer.
Public method | Reverse | Reverses the data samples in the wave file.
Public method | Save(Stream) | Saves wave file to the specified stream.
Public method | Save(String) | Saves wave file to the specified file name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AmplitudeScalar | Returns the amplitude scalar for the given bits per sample of the WaveFile (i.e., maximum value for given BitsPerSample).
Public property | AudioFormat | Gets or sets audio format used by the WaveFile.
Public property | AudioLength | Gets calculated audio length.
Public property | BitsPerSample | Gets or sets number of bits-per-sample in the WaveFile.
Public property | BlockAlignment | Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time).
Public property | ByteRate | Gets or sets the byte rate used for buffer estimation.
Public property | Channels | Gets or sets number of audio channels in the WaveFile.
Public property | DataChunk | Gets or sets the WaveDataChunk of this WaveFile.
Public property | ExtraParameters | Gets or sets any extra parameters defined in the format header of the WaveFile.
Public property | ExtraParametersSize | Gets the size of the ExtraParameters buffer, if defined.
Public property | FormatChunk | Gets or sets the WaveFormatChunk of this WaveFile.
Public property | HeaderChunk | Gets or sets the RiffHeaderChunk of this WaveFile.
Public property | InfoChunk | Gets the ListInfoChunk of this WaveFile.
Public property | InfoStrings | Gets list of info strings available in this WaveFile if any were available during load; otherwise an empty dictionary.
Public property | SampleBlocks | Accesses each individual block of sample data indexed by time.
Public property | SampleRate | Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile.
Top
See Also

Reference

GSF.Media Namespace


WaveFile Constructor

Grid Solutions Framework WaveFile Constructor
Overload List
 | Name | Description
Public method | WaveFile | Creates a new empty in-memory wave file using standard CD quality settings.
Public method | WaveFile(Int32, Int16, Int16) | Creates a new empty in-memory wave file in Pulse Code Modulation (PCM) audio format.
Public method | WaveFile(SampleRate, BitsPerSample, DataChannels) | Creates a new empty in-memory wave file in Pulse Code Modulation (PCM) audio format.
Public method | WaveFile(Int32, Int16, Int16, UInt16) | Creates a new empty in-memory wave file in specified audio format.
Public method | WaveFile(RiffHeaderChunk, WaveFormatChunk, WaveDataChunk, ListInfoChunk) | Creates a new empty in-memory wave file using existing constituent chunks.
Public method | WaveFile(SampleRate, BitsPerSample, DataChannels, WaveFormat) | Creates a new empty in-memory wave file in specified audio format.
Top
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile Constructor

Grid Solutions Framework WaveFile Constructor
Creates a new empty in-memory wave file using standard CD quality settings.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFile()
Public Sub New
new : unit -> WaveFile
GSF.Media.WaveFile = function();
public:
WaveFile()
See Also

Reference

WaveFile Class
WaveFile Overload
GSF.Media Namespace


WaveFile Constructor (Int32, Int16, Int16)

Grid Solutions Framework WaveFile Constructor (Int32, Int16, Int16)
Creates a new empty in-memory wave file in Pulse Code Modulation (PCM) audio format.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFile(
    int sampleRate,
    short bitsPerSample,
    short channels
)
Public Sub New (
    sampleRate As Integer,
    bitsPerSample As Short,
    channels As Short
)
new :
        sampleRate : int *
        bitsPerSample : int16 *
        channels : int16 -> WaveFile
GSF.Media.WaveFile = function(sampleRate, bitsPerSample, channels);
public:
WaveFile(
    int sampleRate,
    short bitsPerSample,
    short channels
)

Parameters

sampleRate
Type: SystemInt32
Desired sample rate (e.g., 44100).
bitsPerSample
Type: SystemInt16
Desired bits-per-sample (e.g., 16).
channels
Type: SystemInt16
Desired data channels (e.g., 2 for stereo).
See Also

Reference

WaveFile Class
WaveFile Overload
GSF.Media Namespace


WaveFile Constructor (SampleRate, BitsPerSample, DataChannels)

Grid Solutions Framework WaveFile Constructor (SampleRate, BitsPerSample, DataChannels)
Creates a new empty in-memory wave file in Pulse Code Modulation (PCM) audio format.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFile(
    SampleRate sampleRate,
    BitsPerSample bitsPerSample,
    DataChannels channels
)
Public Sub New (
    sampleRate As SampleRate,
    bitsPerSample As BitsPerSample,
    channels As DataChannels
)
new :
        sampleRate : SampleRate *
        bitsPerSample : BitsPerSample *
        channels : DataChannels -> WaveFile
GSF.Media.WaveFile = function(sampleRate, bitsPerSample, channels);
public:
WaveFile(
    SampleRate sampleRate,
    BitsPerSample bitsPerSample,
    DataChannels channels
)

Parameters

sampleRate
Type: GSF.MediaSampleRate
Desired sample rate.
bitsPerSample
Type: GSF.MediaBitsPerSample
Desired bits-per-sample.
channels
Type: GSF.MediaDataChannels
Desired data channels.
See Also

Reference

WaveFile Class
WaveFile Overload
GSF.Media Namespace


WaveFile Constructor (Int32, Int16, Int16, UInt16)

Grid Solutions Framework WaveFile Constructor (Int32, Int16, Int16, UInt16)
Creates a new empty in-memory wave file in specified audio format.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFile(
    int sampleRate,
    short bitsPerSample,
    short channels,
    ushort audioFormat
)
Public Sub New (
    sampleRate As Integer,
    bitsPerSample As Short,
    channels As Short,
    audioFormat As UShort
)
new :
        sampleRate : int *
        bitsPerSample : int16 *
        channels : int16 *
        audioFormat : uint16 -> WaveFile
GSF.Media.WaveFile = function(sampleRate, bitsPerSample, channels, audioFormat);
public:
WaveFile(
    int sampleRate,
    short bitsPerSample,
    short channels,
    unsigned short audioFormat
)

Parameters

sampleRate
Type: SystemInt32
Desired sample rate (e.g., 44100).
bitsPerSample
Type: SystemInt16
Desired bits-per-sample (e.g., 16).
channels
Type: SystemInt16
Desired data channels (e.g., 2 for stereo).
audioFormat
Type: SystemUInt16
Desired audio format (e.g., 0x1 for Pulse Code Modulation).
Remarks
Consumer will need to apply appropriate data compression for non-PCM data formats.
See Also

Reference

WaveFile Class
WaveFile Overload
GSF.Media Namespace


WaveFile Constructor (RiffHeaderChunk, WaveFormatChunk, WaveDataChunk, ListInfoChunk)

Grid Solutions Framework WaveFile Constructor (RiffHeaderChunk, WaveFormatChunk, WaveDataChunk, ListInfoChunk)
Creates a new empty in-memory wave file using existing constituent chunks.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public WaveFile(
    RiffHeaderChunk waveHeader,
    WaveFormatChunk waveFormat,
    WaveDataChunk waveData,
    ListInfoChunk listInfo = null
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub New (
    waveHeader As RiffHeaderChunk,
    waveFormat As WaveFormatChunk,
    waveData As WaveDataChunk,
    Optional listInfo As ListInfoChunk = Nothing
)
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
new :
        waveHeader : RiffHeaderChunk *
        waveFormat : WaveFormatChunk *
        waveData : WaveDataChunk *
        ?listInfo : ListInfoChunk
(* Defaults:
        let _listInfo = defaultArg listInfo null
*)
-> WaveFile
GSF.Media.WaveFile = function(waveHeader, waveFormat, waveData, listInfo);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
WaveFile(
    RiffHeaderChunk^ waveHeader,
    WaveFormatChunk^ waveFormat,
    WaveDataChunk^ waveData,
    ListInfoChunk^ listInfo = nullptr
)

Parameters

waveHeader
Type: GSF.MediaRiffHeaderChunk
A WaveDataChunk data object
waveFormat
Type: GSF.MediaWaveFormatChunk
A WaveFormatChunk format object.
waveData
Type: GSF.MediaWaveDataChunk
A RiffHeaderChunk header object.
listInfo (Optional)
Type: GSF.MediaListInfoChunk
Optional ListInfoChunk object.
See Also

Reference

WaveFile Class
WaveFile Overload
GSF.Media Namespace


WaveFile Constructor (SampleRate, BitsPerSample, DataChannels, WaveFormat)

Grid Solutions Framework WaveFile Constructor (SampleRate, BitsPerSample, DataChannels, WaveFormat)
Creates a new empty in-memory wave file in specified audio format.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFile(
    SampleRate sampleRate,
    BitsPerSample bitsPerSample,
    DataChannels channels,
    WaveFormat audioFormat
)
Public Sub New (
    sampleRate As SampleRate,
    bitsPerSample As BitsPerSample,
    channels As DataChannels,
    audioFormat As WaveFormat
)
new :
        sampleRate : SampleRate *
        bitsPerSample : BitsPerSample *
        channels : DataChannels *
        audioFormat : WaveFormat -> WaveFile
GSF.Media.WaveFile = function(sampleRate, bitsPerSample, channels, audioFormat);
public:
WaveFile(
    SampleRate sampleRate,
    BitsPerSample bitsPerSample,
    DataChannels channels,
    WaveFormat audioFormat
)

Parameters

sampleRate
Type: GSF.MediaSampleRate
Desired sample rate.
bitsPerSample
Type: GSF.MediaBitsPerSample
Desired bits-per-sample.
channels
Type: GSF.MediaDataChannels
Desired data channels.
audioFormat
Type: GSF.MediaWaveFormat
Desired audio format.
Remarks
Consumer will need to apply appropriate data compression for non-PCM data formats.
See Also

Reference

WaveFile Class
WaveFile Overload
GSF.Media Namespace


WaveFile Methods

Grid Solutions Framework WaveFile Methods

The WaveFile type exposes the following members.

Methods
 | Name | Description
Public method | AddSample | Add the sample to the wave file.
Public method | AddSampleBlock | Adds a block of samples in native format to the wave file (e.g., if BitsPerSample = 16, parameters need to be Int16 values). Note that LittleBinaryValue parameter type is implicitly castable to common native types, including floating points.
Public method | AddSamples | Adds a series of samples, one per channel, to the wave file.
 | Append | Appends wave files together, one after another, into a single file.
Public method | CastSample | Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat.
Public method | Clone | Creates a deeply cloned copy of the WaveFile.
 | CloneSampleBlock | Performs a deep clone of all the channel samples in a sample block.
 | Combine(WaveFile) | Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.
 | Combine(WaveFile, Double) | Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSampleTypeCode | Determines sample data type code based on defined BitsPerSample and AudioFormat.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Load(Stream, Boolean) | Creates a new in-memory wave loaded from an existing wave audio stream.
 | Load(String, Boolean) | Creates a new in-memory wave loaded from an existing wave file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Play | Plays the wave file using SoundPlayer.
Public method | Reverse | Reverses the data samples in the wave file.
Public method | Save(Stream) | Saves wave file to the specified stream.
Public method | Save(String) | Saves wave file to the specified file name.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.AddSample Method

Grid Solutions Framework WaveFileAddSample Method
Add the sample to the wave file.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddSample(
    double sample
)
Public Sub AddSample (
    sample As Double
)
member AddSample :
        sample : float -> unit

function AddSample(sample);
public:
void AddSample(
    double sample
)

Parameters

sample
Type: SystemDouble
Sample to add to the wave file.
Remarks

Sample is applied to all channels and cast to the appropriate size. Sample should be scaled by AmplitudeScalar for integer based wave file formats to make sure sample will fit into BitsPerSample defined by wave file.

If you have samples to apply to individual channels (e.g., for a stereo format), use the AddSamples(Double) method instead.

See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.AddSampleBlock Method

Grid Solutions Framework WaveFileAddSampleBlock Method
Adds a block of samples in native format to the wave file (e.g., if BitsPerSample = 16, parameters need to be Int16 values). Note that LittleBinaryValue parameter type is implicitly castable to common native types, including floating points.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddSampleBlock(
    params LittleBinaryValue[] samples
)
Public Sub AddSampleBlock (
    ParamArray samples As LittleBinaryValue()
)
member AddSampleBlock :
        samples : LittleBinaryValue[] -> unit

function AddSampleBlock(... samples);
public:
void AddSampleBlock(
    ... array<LittleBinaryValue^>^ samples
)

Parameters

samples
Type: GSFLittleBinaryValue
Samples to add to the wave file.
Remarks

You need to pass in one sample for each defined channel (e.g., if wave is configured for stereo you will need to pass in two parameters).

You should only add values that match the wave file's BitsPerSample (e.g., if wave file is configured for 16-bits only pass in Int16 values, casting if necessary).
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.AddSamples Method

Grid Solutions Framework WaveFileAddSamples Method
Adds a series of samples, one per channel, to the wave file.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddSamples(
    params double[] samples
)
Public Sub AddSamples (
    ParamArray samples As Double()
)
member AddSamples :
        samples : float[] -> unit

function AddSamples(... samples);
public:
void AddSamples(
    ... array<double>^ samples
)

Parameters

samples
Type: SystemDouble
Samples to add to the wave file.
Remarks

You need to pass in one sample for each defined channel (e.g., if wave is configured for stereo you will need to pass in two parameters).

Each sample will be cast to the appropriate size. Samples should be scaled by AmplitudeScalar for integer based wave file formats to make sure samples will fit into BitsPerSample defined by wave file.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Append Method

Grid Solutions Framework WaveFileAppend Method
Appends wave files together, one after another, into a single file.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WaveFile Append(
    params WaveFile[] waveFiles
)
Public Shared Function Append (
    ParamArray waveFiles As WaveFile()
) As WaveFile
static member Append :
        waveFiles : WaveFile[] -> WaveFile

GSF.Media.WaveFile.Append = function(... waveFiles);
public:
static WaveFile^ Append(
    ... array<WaveFile^>^ waveFiles
)

Parameters

waveFiles
Type: GSF.MediaWaveFile
Wave files to append

Return Value

Type: WaveFile
Combined wave files.
Remarks
Each resulting wave file is appending behind the next.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.CastSample Method

Grid Solutions Framework WaveFileCastSample Method
Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue CastSample(
    double sample
)
Public Function CastSample (
    sample As Double
) As LittleBinaryValue
member CastSample :
        sample : float -> LittleBinaryValue

function CastSample(sample);
public:
LittleBinaryValue^ CastSample(
    double sample
)

Parameters

sample
Type: SystemDouble
Sample value.

Return Value

Type: LittleBinaryValue
Sample value cast to its equivalent native type based on defined BitsPerSample and AudioFormat.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Clone Method

Grid Solutions Framework WaveFileClone Method
Creates a deeply cloned copy of the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFile Clone()
Public Function Clone As WaveFile
member Clone : unit -> WaveFile

function Clone();
public:
WaveFile^ Clone()

Return Value

Type: WaveFile
A deeply cloned copy of the WaveFile.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.CloneSampleBlock Method

Grid Solutions Framework WaveFileCloneSampleBlock Method
Performs a deep clone of all the channel samples in a sample block.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static LittleBinaryValue[] CloneSampleBlock(
    LittleBinaryValue[] samples
)
Public Shared Function CloneSampleBlock (
    samples As LittleBinaryValue()
) As LittleBinaryValue()
static member CloneSampleBlock :
        samples : LittleBinaryValue[] -> LittleBinaryValue[]

GSF.Media.WaveFile.CloneSampleBlock = function(samples);
public:
static array<LittleBinaryValue^>^ CloneSampleBlock(
    array<LittleBinaryValue^>^ samples
)

Parameters

samples
Type: GSFLittleBinaryValue
Sample block to clone.

Return Value

Type: LittleBinaryValue
A deep clone of all the channel samples in a sample block.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Combine Method

Grid Solutions Framework WaveFileCombine Method
Overload List
Name | Description
Combine(WaveFile) | Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.
Combine(WaveFile, Double) | Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.
Top
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Combine Method (WaveFile[])

Grid Solutions Framework WaveFileCombine Method (WaveFile)
Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WaveFile Combine(
    params WaveFile[] waveFiles
)
Public Shared Function Combine (
    ParamArray waveFiles As WaveFile()
) As WaveFile
static member Combine :
        waveFiles : WaveFile[] -> WaveFile

GSF.Media.WaveFile.Combine = function(... waveFiles);
public:
static WaveFile^ Combine(
    ... array<WaveFile^>^ waveFiles
)

Parameters

waveFiles
Type: GSF.MediaWaveFile
Wave files to combine

Return Value

Type: WaveFile
Combined wave files.
Remarks

This overload "equalizes" the volume of each source wave file. To specify a desired volume for each combined wave file use the Combine(WaveFile, Double) overload that takes a series of volumes as a parameter.

Resulting sounds will overlap; no truncation is performed. Final wave file length will equal length of longest source file.

Combining sounds files with non-PCM based audio formats will have unexpected results.

See Also

Reference

WaveFile Class
Combine Overload
GSF.Media Namespace


WaveFile.Combine Method (WaveFile[], Double[])

Grid Solutions Framework WaveFileCombine Method (WaveFile, Double)
Combines wave files together, all starting at the same time, into a single file. This has the effect of playing two sound tracks simultaneously.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WaveFile Combine(
    WaveFile[] waveFiles,
    double[] volumes
)
Public Shared Function Combine (
    waveFiles As WaveFile(),
    volumes As Double()
) As WaveFile
static member Combine :
        waveFiles : WaveFile[] *
        volumes : float[] -> WaveFile

GSF.Media.WaveFile.Combine = function(waveFiles, volumes);
public:
static WaveFile^ Combine(
    array<WaveFile^>^ waveFiles,
    array<double>^ volumes
)

Parameters

waveFiles
Type: GSF.MediaWaveFile
Wave files to combine
volumes
Type: SystemDouble
Volume for each wave file (0.0 to 1.0)

Return Value

Type: WaveFile
Combined wave files.
Remarks

Cumulatively, volumes cannot exceed 1.0 - these volumes represent a fractional percentage of volume to be applied to each wave file.

Resulting sounds will overlap; no truncation is performed. Final wave file length will equal length of longest source file.

Combining sounds files with non-PCM based audio formats will have unexpected results.

See Also

Reference

WaveFile Class
Combine Overload
GSF.Media Namespace


WaveFile.GetSampleTypeCode Method

Grid Solutions Framework WaveFileGetSampleTypeCode Method
Determines sample data type code based on defined BitsPerSample and AudioFormat.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetSampleTypeCode()
Public Function GetSampleTypeCode As TypeCode
member GetSampleTypeCode : unit -> TypeCode

function GetSampleTypeCode();
public:
TypeCode GetSampleTypeCode()

Return Value

Type: TypeCode
Sample type code based on defined BitsPerSample and AudioFormat.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Load Method

Grid Solutions Framework WaveFileLoad Method
Overload List
Name | Description
Load(Stream, Boolean) | Creates a new in-memory wave loaded from an existing wave audio stream.
Load(String, Boolean) | Creates a new in-memory wave loaded from an existing wave file.
Top
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Load Method (Stream, Boolean)

Grid Solutions Framework WaveFileLoad Method (Stream, Boolean)
Creates a new in-memory wave loaded from an existing wave audio stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WaveFile Load(
    Stream source,
    bool loadData = true
)
Public Shared Function Load (
    source As Stream,
    Optional loadData As Boolean = true
) As WaveFile
static member Load :
        source : Stream *
        ?loadData : bool
(* Defaults:
        let _loadData = defaultArg loadData true
*)
-> WaveFile

GSF.Media.WaveFile.Load = function(source, loadData);
public:
static WaveFile^ Load(
    Stream^ source,
    bool loadData = true
)

Parameters

source
Type: System.IOStream
Stream of WAV formatted audio data to load.
loadData (Optional)
Type: SystemBoolean
Determines if wave data should be loaded into memory.

Return Value

Type: WaveFile
In-memory representation of wave file.
See Also

Reference

WaveFile Class
Load Overload
GSF.Media Namespace


WaveFile.Load Method (String, Boolean)

Grid Solutions Framework WaveFileLoad Method (String, Boolean)
Creates a new in-memory wave loaded from an existing wave file.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static WaveFile Load(
    string waveFileName,
    bool loadData = true
)
Public Shared Function Load (
    waveFileName As String,
    Optional loadData As Boolean = true
) As WaveFile
static member Load :
        waveFileName : string *
        ?loadData : bool
(* Defaults:
        let _loadData = defaultArg loadData true
*)
-> WaveFile

GSF.Media.WaveFile.Load = function(waveFileName, loadData);
public:
static WaveFile^ Load(
    String^ waveFileName,
    bool loadData = true
)

Parameters

waveFileName
Type: SystemString
File name of WAV file to load.
loadData (Optional)
Type: SystemBoolean
Determines if wave data should be loaded into memory.

Return Value

Type: WaveFile
In-memory representation of wave file.
See Also

Reference

WaveFile Class
Load Overload
GSF.Media Namespace


WaveFile.Play Method

Grid Solutions Framework WaveFilePlay Method
Plays the wave file using SoundPlayer.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Play()
Public Sub Play
member Play : unit -> unit

function Play();
public:
void Play()
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Reverse Method

Grid Solutions Framework WaveFileReverse Method
Reverses the data samples in the wave file.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reverse()
Public Sub Reverse
member Reverse : unit -> unit

function Reverse();
public:
void Reverse()
Remarks
This is just used to reverse the sound in the file for effect.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Save Method

Grid Solutions Framework WaveFileSave Method
Overload List
 | Name | Description
Public method | Save(Stream) | Saves wave file to the specified stream.
Public method | Save(String) | Saves wave file to the specified file name.
Top
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Save Method (Stream)

Grid Solutions Framework WaveFileSave Method (Stream)
Saves wave file to the specified stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Save(
    Stream destination
)
Public Sub Save (
    destination As Stream
)
member Save :
        destination : Stream -> unit

function Save(destination);
public:
void Save(
    Stream^ destination
)

Parameters

destination
Type: System.IOStream
Destination stream for binary wave file data.
See Also

Reference

WaveFile Class
Save Overload
GSF.Media Namespace


WaveFile.Save Method (String)

Grid Solutions Framework WaveFileSave Method (String)
Saves wave file to the specified file name.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Save(
    string waveFileName
)
Public Sub Save (
    waveFileName As String
)
member Save :
        waveFileName : string -> unit

function Save(waveFileName);
public:
void Save(
    String^ waveFileName
)

Parameters

waveFileName
Type: SystemString
Desired destination file name for wave file.
See Also

Reference

WaveFile Class
Save Overload
GSF.Media Namespace


WaveFile Properties

Grid Solutions Framework WaveFile Properties

The WaveFile type exposes the following members.

Properties
 | Name | Description
Public property | AmplitudeScalar | Returns the amplitude scalar for the given bits per sample of the WaveFile (i.e., maximum value for given BitsPerSample).
Public property | AudioFormat | Gets or sets audio format used by the WaveFile.
Public property | AudioLength | Gets calculated audio length.
Public property | BitsPerSample | Gets or sets number of bits-per-sample in the WaveFile.
Public property | BlockAlignment | Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time).
Public property | ByteRate | Gets or sets the byte rate used for buffer estimation.
Public property | Channels | Gets or sets number of audio channels in the WaveFile.
Public property | DataChunk | Gets or sets the WaveDataChunk of this WaveFile.
Public property | ExtraParameters | Gets or sets any extra parameters defined in the format header of the WaveFile.
Public property | ExtraParametersSize | Gets the size of the ExtraParameters buffer, if defined.
Public property | FormatChunk | Gets or sets the WaveFormatChunk of this WaveFile.
Public property | HeaderChunk | Gets or sets the RiffHeaderChunk of this WaveFile.
Public property | InfoChunk | Gets the ListInfoChunk of this WaveFile.
Public property | InfoStrings | Gets list of info strings available in this WaveFile if any were available during load; otherwise an empty dictionary.
Public property | SampleBlocks | Accesses each individual block of sample data indexed by time.
Public property | SampleRate | Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile.
Top
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.AmplitudeScalar Property

Grid Solutions Framework WaveFileAmplitudeScalar Property
Returns the amplitude scalar for the given bits per sample of the WaveFile (i.e., maximum value for given BitsPerSample).

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double AmplitudeScalar { get; }
Public ReadOnly Property AmplitudeScalar As Double
    Get
member AmplitudeScalar : float with get

function get_AmplitudeScalar();

public:
property double AmplitudeScalar {
    double get ();
}

Property Value

Type: Double
Remarks
This defines a scaling factor (essentially a maximum value) used for integer based wave file formats. Floating point wave file formats do not need such scaling.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.AudioFormat Property

Grid Solutions Framework WaveFileAudioFormat Property
Gets or sets audio format used by the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort AudioFormat { get; set; }
Public Property AudioFormat As UShort
    Get
    Set
member AudioFormat : uint16 with get, set

function get_AudioFormat();
function set_AudioFormat(value);
public:
property unsigned short AudioFormat {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
Remarks
PCM = 1 (i.e., linear quantization), values other than 1 typically indicate some form of compression. See WaveFormat enumeration for more details.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.AudioLength Property

Grid Solutions Framework WaveFileAudioLength Property
Gets calculated audio length.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeSpan AudioLength { get; }
Public ReadOnly Property AudioLength As TimeSpan
    Get
member AudioLength : TimeSpan with get

function get_AudioLength();

public:
property TimeSpan AudioLength {
    TimeSpan get ();
}

Property Value

Type: TimeSpan
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.BitsPerSample Property

Grid Solutions Framework WaveFileBitsPerSample Property
Gets or sets number of bits-per-sample in the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short BitsPerSample { get; set; }
Public Property BitsPerSample As Short
    Get
    Set
member BitsPerSample : int16 with get, set

function get_BitsPerSample();
function set_BitsPerSample(value);
public:
property short BitsPerSample {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Remarks
This property defines the number of bits-per-sample (e.g., 8, 16, 24, 32, etc.) used by each sample in a block of samples - effectively the data sample size. See BitsPerSample enumeration for more details.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.BlockAlignment Property

Grid Solutions Framework WaveFileBlockAlignment Property
Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time).

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short BlockAlignment { get; set; }
Public Property BlockAlignment As Short
    Get
    Set
member BlockAlignment : int16 with get, set

function get_BlockAlignment();
function set_BlockAlignment(value);
public:
property short BlockAlignment {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Remarks

This property is not usually changed. It will be automatically calculated for new wave files.

This is typically just the arithmetic result of: Channels * BitsPerSample / 8. However, this value can be changed as needed to accommodate even block-alignment of non-standard BitsPerSample values.

See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.ByteRate Property

Grid Solutions Framework WaveFileByteRate Property
Gets or sets the byte rate used for buffer estimation.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ByteRate { get; set; }
Public Property ByteRate As Integer
    Get
    Set
member ByteRate : int with get, set

function get_ByteRate();
function set_ByteRate(value);
public:
property int ByteRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

This property is not usually changed. It will be automatically calculated for new wave files.

This is typically just the arithmetic result of: SampleRate * Channels * BitsPerSample / 8. However, this value can be changed as needed to accommodate better buffer estimations during data read cycle.

See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.Channels Property

Grid Solutions Framework WaveFileChannels Property
Gets or sets number of audio channels in the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Channels { get; set; }
Public Property Channels As Short
    Get
    Set
member Channels : int16 with get, set

function get_Channels();
function set_Channels(value);
public:
property short Channels {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Remarks
This property defines the number of channels (e.g., mono = 1, stereo = 2, etc.) defined in each sample block. See DataChannels enumeration for more details.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.DataChunk Property

Grid Solutions Framework WaveFileDataChunk Property
Gets or sets the WaveDataChunk of this WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public WaveDataChunk DataChunk { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property DataChunk As WaveDataChunk
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member DataChunk : WaveDataChunk with get

function get_DataChunk();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property WaveDataChunk^ DataChunk {
    WaveDataChunk^ get ();
}

Property Value

Type: WaveDataChunk
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.ExtraParameters Property

Grid Solutions Framework WaveFileExtraParameters Property
Gets or sets any extra parameters defined in the format header of the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ExtraParameters { get; set; }
Public Property ExtraParameters As Byte()
    Get
    Set
member ExtraParameters : byte[] with get, set

function get_ExtraParameters();
function set_ExtraParameters(value);
public:
property array<unsigned char>^ ExtraParameters {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Remarks
See the WaveFormatExtensible class for an example of usage of this property.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.ExtraParametersSize Property

Grid Solutions Framework WaveFileExtraParametersSize Property
Gets the size of the ExtraParameters buffer, if defined.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short ExtraParametersSize { get; }
Public ReadOnly Property ExtraParametersSize As Short
    Get
member ExtraParametersSize : int16 with get

function get_ExtraParametersSize();

public:
property short ExtraParametersSize {
    short get ();
}

Property Value

Type: Int16
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.FormatChunk Property

Grid Solutions Framework WaveFileFormatChunk Property
Gets or sets the WaveFormatChunk of this WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public WaveFormatChunk FormatChunk { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property FormatChunk As WaveFormatChunk
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member FormatChunk : WaveFormatChunk with get

function get_FormatChunk();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property WaveFormatChunk^ FormatChunk {
    WaveFormatChunk^ get ();
}

Property Value

Type: WaveFormatChunk
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.HeaderChunk Property

Grid Solutions Framework WaveFileHeaderChunk Property
Gets or sets the RiffHeaderChunk of this WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public RiffHeaderChunk HeaderChunk { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property HeaderChunk As RiffHeaderChunk
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member HeaderChunk : RiffHeaderChunk with get

function get_HeaderChunk();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property RiffHeaderChunk^ HeaderChunk {
    RiffHeaderChunk^ get ();
}

Property Value

Type: RiffHeaderChunk
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.InfoChunk Property

Grid Solutions Framework WaveFileInfoChunk Property
Gets the ListInfoChunk of this WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ListInfoChunk InfoChunk { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property InfoChunk As ListInfoChunk
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member InfoChunk : ListInfoChunk with get

function get_InfoChunk();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property ListInfoChunk^ InfoChunk {
    ListInfoChunk^ get ();
}

Property Value

Type: ListInfoChunk
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.InfoStrings Property

Grid Solutions Framework WaveFileInfoStrings Property
Gets list of info strings available in this WaveFile if any were available during load; otherwise an empty dictionary.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<string, string> InfoStrings { get; }
Public ReadOnly Property InfoStrings As Dictionary(Of String, String)
    Get
member InfoStrings : Dictionary<string, string> with get

function get_InfoStrings();

public:
property Dictionary<String^, String^>^ InfoStrings {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary String, String
Remarks
The current implementation only allows reading of loaded WaveFile metadata tags, not updating them.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.SampleBlocks Property

Grid Solutions Framework WaveFileSampleBlocks Property
Accesses each individual block of sample data indexed by time.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<LittleBinaryValue[]> SampleBlocks { get; }
Public ReadOnly Property SampleBlocks As List(Of LittleBinaryValue())
    Get
member SampleBlocks : List<LittleBinaryValue[]> with get

function get_SampleBlocks();

public:
property List<array<LittleBinaryValue^>^>^ SampleBlocks {
    List<array<LittleBinaryValue^>^>^ get ();
}

Property Value

Type: List LittleBinaryValue
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFile.SampleRate Property

Grid Solutions Framework WaveFileSampleRate Property
Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SampleRate { get; set; }
Public Property SampleRate As Integer
    Get
    Set
member SampleRate : int with get, set

function get_SampleRate();
function set_SampleRate(value);
public:
property int SampleRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This property defines the number of samples per second defined in each second of data in the WaveFile. See SampleRate enumeration for more details.
See Also

Reference

WaveFile Class
GSF.Media Namespace


WaveFormat Enumeration

Grid Solutions Framework WaveFormat Enumeration
Common WAVE audio encoding formats.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum WaveFormat
Public Enumeration WaveFormat
type WaveFormat
GSF.Media.WaveFormat = function();
GSF.Media.WaveFormat.createEnum('GSF.Media.WaveFormat', false);
public enum class WaveFormat
Members
Member name | Value | Description
Unknown | 0 | Wave format type is undefined.
PCM | 1 | Standard pulse-code modulation audio format
ADPCM | 2 | Adaptive differential pulse-code modulation encoding algorithm
IeeeFloat | 3 | Floating point PCM encoding algorithm
ALaw | 6 | A-law encoding algorithm (used in Europe and the rest of the world)
MuLaw | 7 | μ-law encoding algorithm (used in North America and Japan)
DTS | 8 | Decode Timestamp encoding algorithm (used in MPEG-coded multimedia)
DRM | 9 | Digital Rights Management encoded format (for digital-audio content protected by Microsoft DRM).
Mpeg | 80 | MPEG Audio is a family of open standards for compressed audio that includes MP2, MP3 and AAC.
MpegLayer3 | 85 | ISO MPEG-Layer 3 audio format.
WaveFormatExtensible | 65534 | Use WAVEFORMATEXTENSIBLE structure.
Remarks

Microsoft defines more than 130 different audio encoding formats for WAVE files. Only the more common formats are defined here.

Note that PCM (i.e., Pulse Code Modulation) is a universal audio encoding format. It is a very common method of storing and transmitting uncompressed digital audio. Since it is a generic format, it can be read by most any audio application similar to the way a plain text file can be read by any word-processing program. PCM is used by Audio CDs and digital audio tapes (DATs). PCM is also a very common format for AIFF and WAV files.

See Also

Reference

GSF.Media Namespace


WaveFormatChunk Class

Grid Solutions Framework WaveFormatChunk Class
Represents the format chunk in a WAVE media format file.
Inheritance Hierarchy
SystemObject
GSF.MediaRiffChunk
GSF.MediaWaveFormatChunk

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class WaveFormatChunk : RiffChunk,
    ISupportBinaryImage
Public Class WaveFormatChunk
    Inherits RiffChunk
    Implements ISupportBinaryImage
type WaveFormatChunk =
    class
        inherit RiffChunk
        interface ISupportBinaryImage
    end
GSF.Media.WaveFormatChunk = function();

Type.createClass(
    'GSF.Media.WaveFormatChunk',
    GSF.Media.RiffChunk,
    GSF.Parsing.ISupportBinaryImage);
public ref class WaveFormatChunk : public RiffChunk,
    ISupportBinaryImage

The WaveFormatChunk type exposes the following members.

Constructors
 | Name | Description
Public method | WaveFormatChunk(RiffChunk, Stream) | Reads a new WaveFormatChunk from the specified stream.
Public method | WaveFormatChunk(Int32, Int16, Int16, UInt16) | Constructs a new WaveFormatChunk using the specified audio parameters.
Top
Methods
 | Name | Description
Public method | CastSample | Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat.
Public method | Clone | Creates a copy of the WaveFormatChunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this WaveFormatChunk and copies it into the given buffer. (Overrides RiffChunkGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSampleTypeCode | Determines sample data type code based on defined BitsPerSample and AudioFormat.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses WaveFormatChunk object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
RiffTypeID | RIFF type ID for wave format chunk (i.e., "fmt ").
Top
Properties
 | Name | Description
Public property | AudioFormat | Gets or sets audio format used by the WaveFile.
Public property | BinaryLength | Gets the length of WaveFormatChunk. (Overrides RiffChunkBinaryLength.)
Public property | BitsPerSample | Gets or sets number of bits-per-sample in the WaveFile.
Public property | BlockAlignment | Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time).
Public property | ByteRate | Gets or sets the byte rate used for buffer estimation.
Public property | Channels | Gets or sets number of audio channels in the WaveFile.
Public property | ChunkSize | Size of WaveFormatChunk. (Overrides RiffChunkChunkSize.)
Public property | ExtraParameters | Gets or sets any extra parameters defined in the format header of the WaveFile.
Public property | ExtraParametersSize | Gets the size of the ExtraParameters buffer, if defined.
Public property | SampleRate | Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Top
See Also

Reference

GSF.Media Namespace


WaveFormatChunk Constructor

Grid Solutions Framework WaveFormatChunk Constructor
Overload List
 | Name | Description
Public method | WaveFormatChunk(RiffChunk, Stream) | Reads a new WaveFormatChunk from the specified stream.
Public method | WaveFormatChunk(Int32, Int16, Int16, UInt16) | Constructs a new WaveFormatChunk using the specified audio parameters.
Top
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk Constructor (RiffChunk, Stream)

Grid Solutions Framework WaveFormatChunk Constructor (RiffChunk, Stream)
Reads a new WaveFormatChunk from the specified stream.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatChunk(
    RiffChunk preRead,
    Stream source
)
Public Sub New (
    preRead As RiffChunk,
    source As Stream
)
new :
        preRead : RiffChunk *
        source : Stream -> WaveFormatChunk
GSF.Media.WaveFormatChunk = function(preRead, source);
public:
WaveFormatChunk(
    RiffChunk^ preRead,
    Stream^ source
)

Parameters

preRead
Type: GSF.MediaRiffChunk
Pre-parsed RiffChunk header.
source
Type: System.IOStream
Source stream to read data from.
Exceptions
Exception | Condition
InvalidOperationException | WAVE format or extra parameters section too small, wave file corrupted.
InvalidDataException | Invalid bit rate encountered - wave file bit rates must be a multiple of 8.
See Also

Reference

WaveFormatChunk Class
WaveFormatChunk Overload
GSF.Media Namespace


WaveFormatChunk Constructor (Int32, Int16, Int16, UInt16)

Grid Solutions Framework WaveFormatChunk Constructor (Int32, Int16, Int16, UInt16)
Constructs a new WaveFormatChunk using the specified audio parameters.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatChunk(
    int sampleRate,
    short bitsPerSample,
    short channels,
    ushort audioFormat
)
Public Sub New (
    sampleRate As Integer,
    bitsPerSample As Short,
    channels As Short,
    audioFormat As UShort
)
new :
        sampleRate : int *
        bitsPerSample : int16 *
        channels : int16 *
        audioFormat : uint16 -> WaveFormatChunk
GSF.Media.WaveFormatChunk = function(sampleRate, bitsPerSample, channels, audioFormat);
public:
WaveFormatChunk(
    int sampleRate,
    short bitsPerSample,
    short channels,
    unsigned short audioFormat
)

Parameters

sampleRate
Type: SystemInt32
Sample rate for the WaveFormatChunk.
bitsPerSample
Type: SystemInt16
Bits per sample for the WaveFormatChunk.
channels
Type: SystemInt16
Audio channels for the WaveFormatChunk.
audioFormat
Type: SystemUInt16
Audio format for the WaveFormatChunk.
Exceptions
Exception | Condition
InvalidDataException | Invalid bit rate specified - wave file bit rates must be a multiple of 8.
See Also

Reference

WaveFormatChunk Class
WaveFormatChunk Overload
GSF.Media Namespace


WaveFormatChunk Fields

Grid Solutions Framework WaveFormatChunk Fields

The WaveFormatChunk type exposes the following members.

Fields
Name | Description
RiffTypeID | RIFF type ID for wave format chunk (i.e., "fmt ").
Top
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.RiffTypeID Field

Grid Solutions Framework WaveFormatChunkRiffTypeID Field
RIFF type ID for wave format chunk (i.e., "fmt ").

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string RiffTypeID
Public Const RiffTypeID As String
static val mutable RiffTypeID: string
var GSF.Media.WaveFormatChunk.RiffTypeID
public:
literal String^ RiffTypeID

Field Value

Type: String
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk Methods

Grid Solutions Framework WaveFormatChunk Methods

The WaveFormatChunk type exposes the following members.

Methods
 | Name | Description
Public method | CastSample | Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat.
Public method | Clone | Creates a copy of the WaveFormatChunk.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this WaveFormatChunk and copies it into the given buffer. (Overrides RiffChunkGenerateBinaryImage(Byte, Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSampleTypeCode | Determines sample data type code based on defined BitsPerSample and AudioFormat.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses WaveFormatChunk object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.CastSample Method

Grid Solutions Framework WaveFormatChunkCastSample Method
Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LittleBinaryValue CastSample(
    double sample
)
Public Function CastSample (
    sample As Double
) As LittleBinaryValue
member CastSample :
        sample : float -> LittleBinaryValue

function CastSample(sample);
public:
LittleBinaryValue^ CastSample(
    double sample
)

Parameters

sample
Type: SystemDouble
Sample value.

Return Value

Type: LittleBinaryValue
Sample value cast to its equivalent native type based on defined BitsPerSample and AudioFormat.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.Clone Method

Grid Solutions Framework WaveFormatChunkClone Method
Creates a copy of the WaveFormatChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatChunk Clone()
Public Function Clone As WaveFormatChunk
member Clone : unit -> WaveFormatChunk

function Clone();
public:
WaveFormatChunk^ Clone()

Return Value

Type: WaveFormatChunk
A new copy of the WaveFormatChunk.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.GenerateBinaryImage Method

Grid Solutions Framework WaveFormatChunkGenerateBinaryImage Method
Generates a binary representation of this WaveFormatChunk and copies it into the given buffer.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.GetSampleTypeCode Method

Grid Solutions Framework WaveFormatChunkGetSampleTypeCode Method
Determines sample data type code based on defined BitsPerSample and AudioFormat.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetSampleTypeCode()
Public Function GetSampleTypeCode As TypeCode
member GetSampleTypeCode : unit -> TypeCode

function GetSampleTypeCode();
public:
TypeCode GetSampleTypeCode()

Return Value

Type: TypeCode
Sample type code based on defined BitsPerSample and AudioFormat.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.ParseBinaryImage Method

Grid Solutions Framework WaveFormatChunkParseBinaryImage Method
Parses WaveFormatChunk object by parsing the specified buffer containing a binary image.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | WAVE format section too small, wave file corrupted.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk Properties

Grid Solutions Framework WaveFormatChunk Properties

The WaveFormatChunk type exposes the following members.

Properties
 | Name | Description
Public property | AudioFormat | Gets or sets audio format used by the WaveFile.
Public property | BinaryLength | Gets the length of WaveFormatChunk. (Overrides RiffChunkBinaryLength.)
Public property | BitsPerSample | Gets or sets number of bits-per-sample in the WaveFile.
Public property | BlockAlignment | Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time).
Public property | ByteRate | Gets or sets the byte rate used for buffer estimation.
Public property | Channels | Gets or sets number of audio channels in the WaveFile.
Public property | ChunkSize | Size of WaveFormatChunk. (Overrides RiffChunkChunkSize.)
Public property | ExtraParameters | Gets or sets any extra parameters defined in the format header of the WaveFile.
Public property | ExtraParametersSize | Gets the size of the ExtraParameters buffer, if defined.
Public property | SampleRate | Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile.
Public property | TypeID | Four character text identifer for RIFF chunk. (Inherited from RiffChunk.)
Top
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.AudioFormat Property

Grid Solutions Framework WaveFormatChunkAudioFormat Property
Gets or sets audio format used by the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort AudioFormat { get; set; }
Public Property AudioFormat As UShort
    Get
    Set
member AudioFormat : uint16 with get, set

function get_AudioFormat();
function set_AudioFormat(value);
public:
property unsigned short AudioFormat {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
Remarks
PCM = 1 (i.e., linear quantization), values other than 1 typically indicate some form of compression. See WaveFormat enumeration for more details.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.BinaryLength Property

Grid Solutions Framework WaveFormatChunkBinaryLength Property
Gets the length of WaveFormatChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.BitsPerSample Property

Grid Solutions Framework WaveFormatChunkBitsPerSample Property
Gets or sets number of bits-per-sample in the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short BitsPerSample { get; set; }
Public Property BitsPerSample As Short
    Get
    Set
member BitsPerSample : int16 with get, set

function get_BitsPerSample();
function set_BitsPerSample(value);
public:
property short BitsPerSample {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Remarks
This property defines the number of bits-per-sample (e.g., 8, 16, 24, 32, etc.) used by each sample in a block of samples - effectively the data sample size. See BitsPerSample enumeration for more details.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.BlockAlignment Property

Grid Solutions Framework WaveFormatChunkBlockAlignment Property
Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time).

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short BlockAlignment { get; set; }
Public Property BlockAlignment As Short
    Get
    Set
member BlockAlignment : int16 with get, set

function get_BlockAlignment();
function set_BlockAlignment(value);
public:
property short BlockAlignment {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Remarks

This property is not usually changed. It will be automatically calculated for new wave files.

This is typically just the arithmetic result of: Channels * BitsPerSample / 8. However, this value can be changed as needed to accommodate even block-alignment of non-standard BitsPerSample values.

See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.ByteRate Property

Grid Solutions Framework WaveFormatChunkByteRate Property
Gets or sets the byte rate used for buffer estimation.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ByteRate { get; set; }
Public Property ByteRate As Integer
    Get
    Set
member ByteRate : int with get, set

function get_ByteRate();
function set_ByteRate(value);
public:
property int ByteRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

This property is not usually changed. It will be automatically calculated for new wave files.

This is typically just the arithmetic result of: SampleRate * Channels * BitsPerSample / 8. However, this value can be changed as needed to accommodate better buffer estimations during data read cycle.

See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.Channels Property

Grid Solutions Framework WaveFormatChunkChannels Property
Gets or sets number of audio channels in the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short Channels { get; set; }
Public Property Channels As Short
    Get
    Set
member Channels : int16 with get, set

function get_Channels();
function set_Channels(value);
public:
property short Channels {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
Remarks
This property defines the number of channels (e.g., mono = 1, stereo = 2, etc.) defined in each sample block. See DataChannels enumeration for more details.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.ChunkSize Property

Grid Solutions Framework WaveFormatChunkChunkSize Property
Size of WaveFormatChunk.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ChunkSize { get; set; }
Public Overrides Property ChunkSize As Integer
    Get
    Set
abstract ChunkSize : int with get, set
override ChunkSize : int with get, set
function get_ChunkSize();
function set_ChunkSize(value);
public:
virtual property int ChunkSize {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.ExtraParameters Property

Grid Solutions Framework WaveFormatChunkExtraParameters Property
Gets or sets any extra parameters defined in the format header of the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] ExtraParameters { get; set; }
Public Property ExtraParameters As Byte()
    Get
    Set
member ExtraParameters : byte[] with get, set

function get_ExtraParameters();
function set_ExtraParameters(value);
public:
property array<unsigned char>^ ExtraParameters {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
Remarks
See the WaveFormatExtensible class for an example of usage of this property.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.ExtraParametersSize Property

Grid Solutions Framework WaveFormatChunkExtraParametersSize Property
Gets the size of the ExtraParameters buffer, if defined.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short ExtraParametersSize { get; }
Public ReadOnly Property ExtraParametersSize As Short
    Get
member ExtraParametersSize : int16 with get

function get_ExtraParametersSize();

public:
property short ExtraParametersSize {
    short get ();
}

Property Value

Type: Int16
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatChunk.SampleRate Property

Grid Solutions Framework WaveFormatChunkSampleRate Property
Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SampleRate { get; set; }
Public Property SampleRate As Integer
    Get
    Set
member SampleRate : int with get, set

function get_SampleRate();
function set_SampleRate(value);
public:
property int SampleRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This property defines the number of samples per second defined in each second of data in the WaveFile. See SampleRate enumeration for more details.
See Also

Reference

WaveFormatChunk Class
GSF.Media Namespace


WaveFormatExtensible Class

Grid Solutions Framework WaveFormatExtensible Class
Represents the "extensible" format structure for a WAVE media format file.
Inheritance Hierarchy
SystemObject
GSF.MediaWaveFormatExtensible

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class WaveFormatExtensible : ISupportBinaryImage
Public Class WaveFormatExtensible
    Implements ISupportBinaryImage
type WaveFormatExtensible =
    class
        interface ISupportBinaryImage
    end
GSF.Media.WaveFormatExtensible = function();

Type.createClass(
    'GSF.Media.WaveFormatExtensible',
    null,
    GSF.Parsing.ISupportBinaryImage);
public ref class WaveFormatExtensible : ISupportBinaryImage

The WaveFormatExtensible type exposes the following members.

Constructors
 | Name | Description
Public method | WaveFormatExtensible | Creates a new WaveFormatExtensible.
Public method | WaveFormatExtensible(WaveFormatChunk) | Creates a new WaveFormatExtensible object based on the WaveFormatChunk settings.
Public method | WaveFormatExtensible(UInt16, Speakers, Guid) | Creates a new WaveFormatExtensible object based on the given settings.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this WaveFormatExtensible and copies it into the given buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses WaveFormatExtensible object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
FixedLength | The fixed byte length of a WaveFormatExtensible instance.
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the binary representation of this WaveFormatExtensible instance.
Public property | ChannelMask | Gets or sets flags representing spatial locations of data channels (i.e., speaker locations).
Public property | SampleValue | Gets or sets sample value.
Public property | SubFormat | Gets or sets Guid for sub-format type of extensible WaveFile.
Top
Examples
For some special bit-encodings you may need to use the "WaveFormatExtensible" audio format, here is an example of how to use that format:
Copy
using System;
using GSF.Media;
using GSF.Media.Sound;

static class Program
{
    static void Main()
    {
        // Generate an 8000 Hz, 32 bits per sample, mono channeled WAVE file in "Extensible" format
        WaveFile waveFile = new WaveFile(8000, 32, 1, (ushort)WaveFormat.WaveFormatExtensible);

        // Apply the "WaveFormatExtensible" extra parameters
        WaveFormatExtensible extensible = new WaveFormatExtensible(waveFile.FormatChunk);
        waveFile.ExtraParameters = extensible.BinaryImage;

        // Generate the EBS Alert noise
        DTMF.Generate(waveFile, DTMF.EmergencyBroadcastSystemAlert, 0.25D);

        // Save the generated tone
        waveFile.Save("ExtensibleTest.wav");

        Console.Write("File available to be played from Windows Media Player...");
        Console.ReadKey();
    }
}
See Also

Reference

GSF.Media Namespace


WaveFormatExtensible Constructor

Grid Solutions Framework WaveFormatExtensible Constructor
Overload List
 | Name | Description
Public method | WaveFormatExtensible | Creates a new WaveFormatExtensible.
Public method | WaveFormatExtensible(WaveFormatChunk) | Creates a new WaveFormatExtensible object based on the WaveFormatChunk settings.
Public method | WaveFormatExtensible(UInt16, Speakers, Guid) | Creates a new WaveFormatExtensible object based on the given settings.
Top
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible Constructor

Grid Solutions Framework WaveFormatExtensible Constructor
Creates a new WaveFormatExtensible.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatExtensible()
Public Sub New
new : unit -> WaveFormatExtensible
GSF.Media.WaveFormatExtensible = function();
public:
WaveFormatExtensible()
See Also

Reference

WaveFormatExtensible Class
WaveFormatExtensible Overload
GSF.Media Namespace


WaveFormatExtensible Constructor (WaveFormatChunk)

Grid Solutions Framework WaveFormatExtensible Constructor (WaveFormatChunk)
Creates a new WaveFormatExtensible object based on the WaveFormatChunk settings.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatExtensible(
    WaveFormatChunk waveFormat
)
Public Sub New (
    waveFormat As WaveFormatChunk
)
new :
        waveFormat : WaveFormatChunk -> WaveFormatExtensible
GSF.Media.WaveFormatExtensible = function(waveFormat);
public:
WaveFormatExtensible(
    WaveFormatChunk^ waveFormat
)

Parameters

waveFormat
Type: GSF.MediaWaveFormatChunk
A WaveFormatChunk format.
See Also

Reference

WaveFormatExtensible Class
WaveFormatExtensible Overload
GSF.Media Namespace


WaveFormatExtensible Constructor (UInt16, Speakers, Guid)

Grid Solutions Framework WaveFormatExtensible Constructor (UInt16, Speakers, Guid)
Creates a new WaveFormatExtensible object based on the given settings.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaveFormatExtensible(
    ushort sampleValue,
    Speakers channelMask,
    Guid subFormat
)
Public Sub New (
    sampleValue As UShort,
    channelMask As Speakers,
    subFormat As Guid
)
new :
        sampleValue : uint16 *
        channelMask : Speakers *
        subFormat : Guid -> WaveFormatExtensible
GSF.Media.WaveFormatExtensible = function(sampleValue, channelMask, subFormat);
public:
WaveFormatExtensible(
    unsigned short sampleValue,
    Speakers channelMask,
    Guid subFormat
)

Parameters

sampleValue
Type: SystemUInt16
An UInt16 value representing the sample value.
channelMask
Type: GSF.MediaSpeakers
A Speakers object.
subFormat
Type: SystemGuid
A Guid value.
See Also

Reference

WaveFormatExtensible Class
WaveFormatExtensible Overload
GSF.Media Namespace


WaveFormatExtensible Fields

Grid Solutions Framework WaveFormatExtensible Fields

The WaveFormatExtensible type exposes the following members.

Fields
Name | Description
FixedLength | The fixed byte length of a WaveFormatExtensible instance.
Top
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible.FixedLength Field

Grid Solutions Framework WaveFormatExtensibleFixedLength Field
The fixed byte length of a WaveFormatExtensible instance.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.Media.WaveFormatExtensible.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible Methods

Grid Solutions Framework WaveFormatExtensible Methods

The WaveFormatExtensible type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates a binary representation of this WaveFormatExtensible and copies it into the given buffer.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses WaveFormatExtensible object by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible.GenerateBinaryImage Method

Grid Solutions Framework WaveFormatExtensibleGenerateBinaryImage Method
Generates a binary representation of this WaveFormatExtensible and copies it into the given buffer.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible.ParseBinaryImage Method

Grid Solutions Framework WaveFormatExtensibleParseBinaryImage Method
Parses WaveFormatExtensible object by parsing the specified buffer containing a binary image.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible Properties

Grid Solutions Framework WaveFormatExtensible Properties

The WaveFormatExtensible type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the binary representation of this WaveFormatExtensible instance.
Public property | ChannelMask | Gets or sets flags representing spatial locations of data channels (i.e., speaker locations).
Public property | SampleValue | Gets or sets sample value.
Public property | SubFormat | Gets or sets Guid for sub-format type of extensible WaveFile.
Top
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible.BinaryLength Property

Grid Solutions Framework WaveFormatExtensibleBinaryLength Property
Gets the length of the binary representation of this WaveFormatExtensible instance.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible.ChannelMask Property

Grid Solutions Framework WaveFormatExtensibleChannelMask Property
Gets or sets flags representing spatial locations of data channels (i.e., speaker locations).

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Speakers ChannelMask { get; set; }
Public Property ChannelMask As Speakers
    Get
    Set
member ChannelMask : Speakers with get, set

function get_ChannelMask();
function set_ChannelMask(value);
public:
property Speakers ChannelMask {
    Speakers get ();
    void set (Speakers value);
}

Property Value

Type: Speakers
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible.SampleValue Property

Grid Solutions Framework WaveFormatExtensibleSampleValue Property
Gets or sets sample value.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleValue { get; set; }
Public Property SampleValue As UShort
    Get
    Set
member SampleValue : uint16 with get, set

function get_SampleValue();
function set_SampleValue(value);
public:
property unsigned short SampleValue {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


WaveFormatExtensible.SubFormat Property

Grid Solutions Framework WaveFormatExtensibleSubFormat Property
Gets or sets Guid for sub-format type of extensible WaveFile.

Namespace: GSF.Media
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid SubFormat { get; set; }
Public Property SubFormat As Guid
    Get
    Set
member SubFormat : Guid with get, set

function get_SubFormat();
function set_SubFormat(value);
public:
property Guid SubFormat {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

WaveFormatExtensible Class
GSF.Media Namespace


GSF.Media.Music Namespace

Grid Solutions Framework GSF.Media.Music Namespace

[Missing <summary> documentation for "N:GSF.Media.Music"]

Classes
 | Class | Description
Public class | Damping | Defines a few damping functions.
Public class | MeasureSize | Defines the size of a musical measure as the number of beats per note value.
 | Note | Defines fundamental musical note frequencies and methods to create them.
Public class | NoteValueExtensions | Defines extension functions related to note value enumerations.
Public class | Phrase | Defines a repeatable series of notes that can be added to a song over and over, for example, the phrase of music defining the chorus.
 | Song | Allows creation of a synthesized musical score storing the resultant song in an in-memory wave file for play back or saving music to disk.
Public class | Tempo | Defines the tempo of song as the total number of note values in one minute.
Public class | Timbre | Defines a few timbre functions.
Delegates
 | Delegate | Description
Public delegate | DampingFunction | Provides a function signature for methods that damp an amplitude representing a lowering of the acoustic pressure over time.
Public delegate | TimbreFunction | Provides a function signature for methods that produce an amplitude representing the acoustic pressure of a represented musical timbre for the given time.
Enumerations
 | Enumeration | Description
Public enumeration | Dynamic | Defines the relative intensity (i.e., volume) of a musical line.
Public enumeration | NoteValue | American note value (♪) representing the relative duration of a note.
Public enumeration | NoteValueBritish | British note value (♪) representing the relative duration of a note.
Remarks
This namespace is excluded from the official documentation TOC.


Damping Class

Grid Solutions Framework Damping Class
Defines a few damping functions.
Inheritance Hierarchy
SystemObject
GSF.Media.MusicDamping

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Damping
Public NotInheritable Class Damping
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Damping =  class end
GSF.Media.Music.Damping = function();

Type.createClass(
    'GSF.Media.Music.Damping');
public ref class Damping abstract sealed

The Damping type exposes the following members.

Methods
Name | Description
InverseLogarithmic | Produces an inverse logarithmic damping curve - slowly damping with a sharp end from 1 to 0 over the samplePeriod.
Linear | Produces a linear damping curve - damping with a perfect slope from 1 to 0 over the samplePeriod.
Logarithmic | Produces a logarithmic damping curve - strong at first and damping quickly over time from 1 to 0 over the samplePeriod.
Natural | Produces a natural damping curve very similar to that of a string based instrument - strong at first and damping quickly over time from 1 to 0 over the samplePeriod.
ReverseLinear | Produces a reverse linear damping curve - damping with a perfect slope from 0 to 1 over the samplePeriod.
Sinusoidal | Produces a sinusoidal damping curve oscillating from 1 to 0 to 1 over the samplePeriod.
Zero | Produces a damping signature that represents no damping over time.
Top
See Also

Reference

GSF.Media.Music Namespace


Damping Methods

Grid Solutions Framework Damping Methods

The Damping type exposes the following members.

Methods
Name | Description
InverseLogarithmic | Produces an inverse logarithmic damping curve - slowly damping with a sharp end from 1 to 0 over the samplePeriod.
Linear | Produces a linear damping curve - damping with a perfect slope from 1 to 0 over the samplePeriod.
Logarithmic | Produces a logarithmic damping curve - strong at first and damping quickly over time from 1 to 0 over the samplePeriod.
Natural | Produces a natural damping curve very similar to that of a string based instrument - strong at first and damping quickly over time from 1 to 0 over the samplePeriod.
ReverseLinear | Produces a reverse linear damping curve - damping with a perfect slope from 0 to 1 over the samplePeriod.
Sinusoidal | Produces a sinusoidal damping curve oscillating from 1 to 0 to 1 over the samplePeriod.
Zero | Produces a damping signature that represents no damping over time.
Top
See Also

Reference

Damping Class
GSF.Media.Music Namespace


Damping.InverseLogarithmic Method

Grid Solutions Framework DampingInverseLogarithmic Method
Produces an inverse logarithmic damping curve - slowly damping with a sharp end from 1 to 0 over the samplePeriod.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double InverseLogarithmic(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function InverseLogarithmic (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member InverseLogarithmic :
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Damping.InverseLogarithmic = function(sampleIndex, samplePeriod, sampleRate);
public:
static double InverseLogarithmic(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Scaling factor used to damp an amplitude at the given time.
Remarks
This damping would be similar to that of a note produced on an electronic keyboard or a breath based instrument.
See Also

Reference

Damping Class
GSF.Media.Music Namespace


Damping.Linear Method

Grid Solutions Framework DampingLinear Method
Produces a linear damping curve - damping with a perfect slope from 1 to 0 over the samplePeriod.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Linear(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Linear (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Linear :
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Damping.Linear = function(sampleIndex, samplePeriod, sampleRate);
public:
static double Linear(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Scaling factor used to damp an amplitude at the given time.
See Also

Reference

Damping Class
GSF.Media.Music Namespace


Damping.Logarithmic Method

Grid Solutions Framework DampingLogarithmic Method
Produces a logarithmic damping curve - strong at first and damping quickly over time from 1 to 0 over the samplePeriod.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Logarithmic(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Logarithmic (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Logarithmic :
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Damping.Logarithmic = function(sampleIndex, samplePeriod, sampleRate);
public:
static double Logarithmic(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Scaling factor used to damp an amplitude at the given time.
Remarks
This damping would be similar to that of a note produced by a string based instrument.
See Also

Reference

Damping Class
GSF.Media.Music Namespace


Damping.Natural Method

Grid Solutions Framework DampingNatural Method
Produces a natural damping curve very similar to that of a string based instrument - strong at first and damping quickly over time from 1 to 0 over the samplePeriod.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Natural(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Natural (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Natural :
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Damping.Natural = function(sampleIndex, samplePeriod, sampleRate);
public:
static double Natural(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Scaling factor used to damp an amplitude at the given time.
Remarks
This damping algorithm combines both the logarithmic and linear damping algoriths to produce a very natural damping curve.
See Also

Reference

Damping Class
GSF.Media.Music Namespace


Damping.ReverseLinear Method

Grid Solutions Framework DampingReverseLinear Method
Produces a reverse linear damping curve - damping with a perfect slope from 0 to 1 over the samplePeriod.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ReverseLinear(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function ReverseLinear (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member ReverseLinear :
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Damping.ReverseLinear = function(sampleIndex, samplePeriod, sampleRate);
public:
static double ReverseLinear(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Scaling factor used to damp an amplitude at the given time.
Remarks
This is just used for an interesting note effect.
See Also

Reference

Damping Class
GSF.Media.Music Namespace


Damping.Sinusoidal Method

Grid Solutions Framework DampingSinusoidal Method
Produces a sinusoidal damping curve oscillating from 1 to 0 to 1 over the samplePeriod.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Sinusoidal(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Sinusoidal (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Sinusoidal :
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Damping.Sinusoidal = function(sampleIndex, samplePeriod, sampleRate);
public:
static double Sinusoidal(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Scaling factor used to damp an amplitude at the given time.
Remarks
This is just used for an interesting note effect.
See Also

Reference

Damping Class
GSF.Media.Music Namespace


Damping.Zero Method

Grid Solutions Framework DampingZero Method
Produces a damping signature that represents no damping over time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Zero(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Zero (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Zero :
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Damping.Zero = function(sampleIndex, samplePeriod, sampleRate);
public:
static double Zero(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Returns a scalar of 1.0 regardless to time.
Remarks
Zero damped sounds would be produced by synthetic sources such as an electronic keyboard.
See Also

Reference

Damping Class
GSF.Media.Music Namespace


DampingFunction Delegate

Grid Solutions Framework DampingFunction Delegate
Provides a function signature for methods that damp an amplitude representing a lowering of the acoustic pressure over time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate double DampingFunction(
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Delegate Function DampingFunction (
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
type DampingFunction =
    delegate of
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float
function(sampleIndex, samplePeriod, sampleRate);
public delegate double DampingFunction(
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

sampleIndex
Type: SystemInt64
Sample index (0 to samplePeriod - 1).
samplePeriod
Type: SystemInt64
Total period, in whole samples per second (i.e., seconds of time * sampleRate), over which to perform damping.
sampleRate
Type: SystemInt32
Number of samples per second, if useful for calculation.

Return Value

Type: Double
Scaling factor in the range of zero to one used to damp an amplitude at the given sample index.
See Also

Reference

GSF.Media.Music Namespace


Dynamic Enumeration

Grid Solutions Framework Dynamic Enumeration
Defines the relative intensity (i.e., volume) of a musical line.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum Dynamic
Public Enumeration Dynamic
type Dynamic
GSF.Media.Music.Dynamic = function();
GSF.Media.Music.Dynamic.createEnum('GSF.Media.Music.Dynamic', false);
public enum class Dynamic
Members
Member name | Value | Description
Undefined | -1 | No dynamic is defined.
Pianissimo | 5 | pp - very soft.
Piano | 10 | p - soft.
MezzoPiano | 20 | mp - half soft as Piano.
MezzoForte | 40 | mf - half loud as Forte.
Forte | 80 | f - loud.
Fortissimo | 90 | ff - very loud.
See Also

Reference

GSF.Media.Music Namespace


MeasureSize Class

Grid Solutions Framework MeasureSize Class
Defines the size of a musical measure as the number of beats per note value.
Inheritance Hierarchy
SystemObject
GSF.Media.MusicMeasureSize

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MeasureSize
Public Class MeasureSize
type MeasureSize =  class end
GSF.Media.Music.MeasureSize = function();

Type.createClass(
    'GSF.Media.Music.MeasureSize');
public ref class MeasureSize

The MeasureSize type exposes the following members.

Constructors
 | Name | Description
Public method | MeasureSize(Int32, NoteValue) | Creates a new musical measure defined as the number of beats per note value.
Public method | MeasureSize(Int32, NoteValueBritish) | Creates a new musical measure defined as the number of beats per note value.
Public method | MeasureSize(Int32, Double) | Creates a new musical measure defined as the number of beats per note value.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateNoteValueAtBeat(Double, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Public method | ValidateNoteValueAtBeat(NoteValue, Int32, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Public method | ValidateNoteValueAtBeat(NoteValueBritish, Int32, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Beats | Gets or sets the number of beats per measure.
Public property | NamedNoteValue | Get or sets the note value, expressed in American form, representing the basic pulse of the music.
Public property | NamedNoteValueBritish | Get or sets the note value, expressed in British form, representing the basic pulse of the music.
Public property | NoteValue | Get or sets the relative note value representing the basic pulse of the music.
Top
See Also

Reference

GSF.Media.Music Namespace


MeasureSize Constructor

Grid Solutions Framework MeasureSize Constructor
Overload List
 | Name | Description
Public method | MeasureSize(Int32, NoteValue) | Creates a new musical measure defined as the number of beats per note value.
Public method | MeasureSize(Int32, NoteValueBritish) | Creates a new musical measure defined as the number of beats per note value.
Public method | MeasureSize(Int32, Double) | Creates a new musical measure defined as the number of beats per note value.
Top
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


MeasureSize Constructor (Int32, NoteValue)

Grid Solutions Framework MeasureSize Constructor (Int32, NoteValue)
Creates a new musical measure defined as the number of beats per note value.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MeasureSize(
    int beats,
    NoteValue noteValue
)
Public Sub New (
    beats As Integer,
    noteValue As NoteValue
)
new :
        beats : int *
        noteValue : NoteValue -> MeasureSize
GSF.Media.Music.MeasureSize = function(beats, noteValue);
public:
MeasureSize(
    int beats,
    NoteValue noteValue
)

Parameters

beats
Type: SystemInt32
A Int32 representing the beats.
noteValue
Type: GSF.Media.MusicNoteValue
A NoteValue representing the note value.
See Also

Reference

MeasureSize Class
MeasureSize Overload
GSF.Media.Music Namespace


MeasureSize Constructor (Int32, NoteValueBritish)

Grid Solutions Framework MeasureSize Constructor (Int32, NoteValueBritish)
Creates a new musical measure defined as the number of beats per note value.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MeasureSize(
    int beats,
    NoteValueBritish noteValue
)
Public Sub New (
    beats As Integer,
    noteValue As NoteValueBritish
)
new :
        beats : int *
        noteValue : NoteValueBritish -> MeasureSize
GSF.Media.Music.MeasureSize = function(beats, noteValue);
public:
MeasureSize(
    int beats,
    NoteValueBritish noteValue
)

Parameters

beats
Type: SystemInt32
A Int32 representing the beats.
noteValue
Type: GSF.Media.MusicNoteValueBritish
A NoteValueBritish representing the note value.
See Also

Reference

MeasureSize Class
MeasureSize Overload
GSF.Media.Music Namespace


MeasureSize Constructor (Int32, Double)

Grid Solutions Framework MeasureSize Constructor (Int32, Double)
Creates a new musical measure defined as the number of beats per note value.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MeasureSize(
    int beats,
    double noteValue
)
Public Sub New (
    beats As Integer,
    noteValue As Double
)
new :
        beats : int *
        noteValue : float -> MeasureSize
GSF.Media.Music.MeasureSize = function(beats, noteValue);
public:
MeasureSize(
    int beats,
    double noteValue
)

Parameters

beats
Type: SystemInt32
A Int32 representing the beats.
noteValue
Type: SystemDouble
A Double representing the note value.
See Also

Reference

MeasureSize Class
MeasureSize Overload
GSF.Media.Music Namespace


MeasureSize Methods

Grid Solutions Framework MeasureSize Methods

The MeasureSize type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateNoteValueAtBeat(Double, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Public method | ValidateNoteValueAtBeat(NoteValue, Int32, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Public method | ValidateNoteValueAtBeat(NoteValueBritish, Int32, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


MeasureSize.ValidateNoteValueAtBeat Method

Grid Solutions Framework MeasureSizeValidateNoteValueAtBeat Method
Overload List
 | Name | Description
Public method | ValidateNoteValueAtBeat(Double, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Public method | ValidateNoteValueAtBeat(NoteValue, Int32, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Public method | ValidateNoteValueAtBeat(NoteValueBritish, Int32, Int32) | Validates that given note value will fit within this MeasureSize for specified beat.
Top
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


MeasureSize.ValidateNoteValueAtBeat Method (Double, Int32)

Grid Solutions Framework MeasureSizeValidateNoteValueAtBeat Method (Double, Int32)
Validates that given note value will fit within this MeasureSize for specified beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ValidateNoteValueAtBeat(
    double noteValue,
    int beat
)
Public Sub ValidateNoteValueAtBeat (
    noteValue As Double,
    beat As Integer
)
member ValidateNoteValueAtBeat :
        noteValue : float *
        beat : int -> unit

function ValidateNoteValueAtBeat(noteValue, beat);
public:
void ValidateNoteValueAtBeat(
    double noteValue,
    int beat
)

Parameters

noteValue
Type: SystemDouble
Note value (i.e., length) to validate.
beat
Type: SystemInt32
Beat within in measure where note value is trying to fit.
See Also

Reference

MeasureSize Class
ValidateNoteValueAtBeat Overload
GSF.Media.Music Namespace


MeasureSize.ValidateNoteValueAtBeat Method (NoteValue, Int32, Int32)

Grid Solutions Framework MeasureSizeValidateNoteValueAtBeat Method (NoteValue, Int32, Int32)
Validates that given note value will fit within this MeasureSize for specified beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ValidateNoteValueAtBeat(
    NoteValue noteValue,
    int beat,
    int dots
)
Public Sub ValidateNoteValueAtBeat (
    noteValue As NoteValue,
    beat As Integer,
    dots As Integer
)
member ValidateNoteValueAtBeat :
        noteValue : NoteValue *
        beat : int *
        dots : int -> unit

function ValidateNoteValueAtBeat(noteValue, beat, dots);
public:
void ValidateNoteValueAtBeat(
    NoteValue noteValue,
    int beat,
    int dots
)

Parameters

noteValue
Type: GSF.Media.MusicNoteValue
Named note value to validate.
beat
Type: SystemInt32
Beat within in measure where note value is trying to fit.
dots
Type: SystemInt32
Dot length extensions to apply to named note value.
See Also

Reference

MeasureSize Class
ValidateNoteValueAtBeat Overload
GSF.Media.Music Namespace


MeasureSize.ValidateNoteValueAtBeat Method (NoteValueBritish, Int32, Int32)

Grid Solutions Framework MeasureSizeValidateNoteValueAtBeat Method (NoteValueBritish, Int32, Int32)
Validates that given note value will fit within this MeasureSize for specified beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ValidateNoteValueAtBeat(
    NoteValueBritish noteValue,
    int beat,
    int dots
)
Public Sub ValidateNoteValueAtBeat (
    noteValue As NoteValueBritish,
    beat As Integer,
    dots As Integer
)
member ValidateNoteValueAtBeat :
        noteValue : NoteValueBritish *
        beat : int *
        dots : int -> unit

function ValidateNoteValueAtBeat(noteValue, beat, dots);
public:
void ValidateNoteValueAtBeat(
    NoteValueBritish noteValue,
    int beat,
    int dots
)

Parameters

noteValue
Type: GSF.Media.MusicNoteValueBritish
Named note value to validate.
beat
Type: SystemInt32
Beat within in measure where note value is trying to fit.
dots
Type: SystemInt32
Dot length extensions to apply to named note value.
See Also

Reference

MeasureSize Class
ValidateNoteValueAtBeat Overload
GSF.Media.Music Namespace


MeasureSize Properties

Grid Solutions Framework MeasureSize Properties

The MeasureSize type exposes the following members.

Properties
 | Name | Description
Public property | Beats | Gets or sets the number of beats per measure.
Public property | NamedNoteValue | Get or sets the note value, expressed in American form, representing the basic pulse of the music.
Public property | NamedNoteValueBritish | Get or sets the note value, expressed in British form, representing the basic pulse of the music.
Public property | NoteValue | Get or sets the relative note value representing the basic pulse of the music.
Top
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


MeasureSize.Beats Property

Grid Solutions Framework MeasureSizeBeats Property
Gets or sets the number of beats per measure.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Beats { get; set; }
Public Property Beats As Integer
    Get
    Set
member Beats : int with get, set

function get_Beats();
function set_Beats(value);
public:
property int Beats {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


MeasureSize.NamedNoteValue Property

Grid Solutions Framework MeasureSizeNamedNoteValue Property
Get or sets the note value, expressed in American form, representing the basic pulse of the music.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NoteValue NamedNoteValue { get; set; }
Public Property NamedNoteValue As NoteValue
    Get
    Set
member NamedNoteValue : NoteValue with get, set

function get_NamedNoteValue();
function set_NamedNoteValue(value);
public:
property NoteValue NamedNoteValue {
    NoteValue get ();
    void set (NoteValue value);
}

Property Value

Type: NoteValue
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


MeasureSize.NamedNoteValueBritish Property

Grid Solutions Framework MeasureSizeNamedNoteValueBritish Property
Get or sets the note value, expressed in British form, representing the basic pulse of the music.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NoteValueBritish NamedNoteValueBritish { get; set; }
Public Property NamedNoteValueBritish As NoteValueBritish
    Get
    Set
member NamedNoteValueBritish : NoteValueBritish with get, set

function get_NamedNoteValueBritish();
function set_NamedNoteValueBritish(value);
public:
property NoteValueBritish NamedNoteValueBritish {
    NoteValueBritish get ();
    void set (NoteValueBritish value);
}

Property Value

Type: NoteValueBritish
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


MeasureSize.NoteValue Property

Grid Solutions Framework MeasureSizeNoteValue Property
Get or sets the relative note value representing the basic pulse of the music.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double NoteValue { get; set; }
Public Property NoteValue As Double
    Get
    Set
member NoteValue : float with get, set

function get_NoteValue();
function set_NoteValue(value);
public:
property double NoteValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MeasureSize Class
GSF.Media.Music Namespace


Note Class

Grid Solutions Framework Note Class
Defines fundamental musical note frequencies and methods to create them.
Inheritance Hierarchy
SystemObject
GSF.Media.MusicNote

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Note : IEquatable<Note>, IComparable<Note>,
    IComparable
Public Class Note
    Implements IEquatable(Of Note), IComparable(Of Note),
    IComparable
type Note =
    class
        interface IEquatable<Note>
        interface IComparable<Note>
        interface IComparable
    end
GSF.Media.Music.Note = function();

Type.createClass(
    'GSF.Media.Music.Note',
    null,
    IEquatable`1,
    IComparable`1,
    IComparable);
public ref class Note : IEquatable<Note^>,
    IComparable<Note^>, IComparable

The Note type exposes the following members.

Constructors
Name | Description
Note | Creates a new note of the specified frequency and length.
Top
Methods
 | Name | Description
Public method | CalculateValueTime | Calculates the actual time duration, in seconds, for the specified tempo that the note value will last. For example, if tempo is M.M. 120 quarter-notes per minte, then each quarter-note would last a half-second.
Public method | CompareTo(Object) | Notes are compared by frequency, then by value (i.e., duration).
Public method | CompareTo(Note) | Notes are compared by frequency, then by value (i.e., duration).
Public method | Equals(Object) | Returns True if the frequency and value of this note equals the frequency and value of the specified other note. (Overrides ObjectEquals(Object).)
Public method | Equals(Note) | Returns True if the frequency and value of this note equals the frequency and value of the specified other note.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetFrequency(String) | Gets the specified note frequency.
 | GetFrequency(Char, Int32, Boolean) | Gets the specified note frequency.
Public method | GetHashCode | Serves as a hash function for the current Note. (Overrides ObjectGetHashCode.)
 | GetNextID | Gets the next note ID in sequence after the specified note ID.
 | GetPreviousID | Gets the previous note ID in sequence before the specified note ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamedValueIndex | Returns closest note value index (for NoteValue or NoteValueBritish) given the relative duration of a note.
Public method | ToString | Returns a string representation for the note. (Overrides ObjectToString.)
Top
Operators
Name | Description
Equality | Compares two Note frequencies and values for equality.
GreaterThan | Returns true if left Note timestamp is greater than right Note.
GreaterThanOrEqual | Returns true if left Note timestamp is greater than or equal to right Note.
Inequality | Compares two Note frequencies and values for inequality.
LessThan | Returns true if left Note timestamp is less than right Note.
LessThanOrEqual | Returns true if left Note timestamp is less than or equal to right Note.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
A0 | Fundamental frequency for note A0.
A0S | Fundamental frequency for note A0#.
A1 | Fundamental frequency for note A1.
A1S | Fundamental frequency for note A1#.
A2 | Fundamental frequency for note A2.
A2S | Fundamental frequency for note A2#.
A3 | Fundamental frequency for note A3.
A3S | Fundamental frequency for note A3#.
A4 | Fundamental frequency for note A4.
A4S | Fundamental frequency for note A4#.
A5 | Fundamental frequency for note A5.
A5S | Fundamental frequency for note A5#.
A6 | Fundamental frequency for note A6.
A6S | Fundamental frequency for note A6#.
A7 | Fundamental frequency for note A7.
A7S | Fundamental frequency for note A7#.
B0 | Fundamental frequency for note B0.
B1 | Fundamental frequency for note B1.
B2 | Fundamental frequency for note B2.
B3 | Fundamental frequency for note B3.
B4 | Fundamental frequency for note B4.
B5 | Fundamental frequency for note B5.
B6 | Fundamental frequency for note B6.
B7 | Fundamental frequency for note B7.
C0 | Fundamental frequency for note C0.
C0S | Fundamental frequency for note C0#.
C1 | Fundamental frequency for note C1.
C1S | Fundamental frequency for note C1#.
C2 | Fundamental frequency for note C2.
C2S | Fundamental frequency for note C2#.
C3 | Fundamental frequency for note C3.
C3S | Fundamental frequency for note C3#.
C4 | Fundamental frequency for note C4 - Middle C.
C4S | Fundamental frequency for note C4#.
C5 | Fundamental frequency for note C5.
C5S | Fundamental frequency for note C5#.
C6 | Fundamental frequency for note C6.
C6S | Fundamental frequency for note C6#.
C7 | Fundamental frequency for note C7.
C7S | Fundamental frequency for note C7#.
C8 | Fundamental frequency for note C8.
C8S | Fundamental frequency for note C8#.
D0 | Fundamental frequency for note D0.
D0S | Fundamental frequency for note D0#.
D1 | Fundamental frequency for note D1.
D1S | Fundamental frequency for note D1#.
D2 | Fundamental frequency for note D2.
D2S | Fundamental frequency for note D2#.
D3 | Fundamental frequency for note D3.
D3S | Fundamental frequency for note D3#.
D4 | Fundamental frequency for note D4.
D4S | Fundamental frequency for note D4#.
D5 | Fundamental frequency for note D5.
D5S | Fundamental frequency for note D5#.
D6 | Fundamental frequency for note D6.
D6S | Fundamental frequency for note D6#.
D7 | Fundamental frequency for note D7.
D7S | Fundamental frequency for note D7#.
D8 | Fundamental frequency for note D8.
D8S | Fundamental frequency for note D8#.
E0 | Fundamental frequency for note E0.
E1 | Fundamental frequency for note E1.
E2 | Fundamental frequency for note E2.
E3 | Fundamental frequency for note E3.
E4 | Fundamental frequency for note E4.
E5 | Fundamental frequency for note E5.
E6 | Fundamental frequency for note E6.
E7 | Fundamental frequency for note E7.
F0 | Fundamental frequency for note F0.
F0S | Fundamental frequency for note F0#.
F1 | Fundamental frequency for note F1.
F1S | Fundamental frequency for note F1#.
F2 | Fundamental frequency for note F2.
F2S | Fundamental frequency for note F2#.
F3 | Fundamental frequency for note F3.
F3S | Fundamental frequency for note F3#.
F4 | Fundamental frequency for note F4.
F4S | Fundamental frequency for note F4#.
F5 | Fundamental frequency for note F5.
F5S | Fundamental frequency for note F5#.
F6 | Fundamental frequency for note F6.
F6S | Fundamental frequency for note F6#.
F7 | Fundamental frequency for note F7.
F7S | Fundamental frequency for note F7#.
G0 | Fundamental frequency for note G0.
G0S | Fundamental frequency for note G0#.
G1 | Fundamental frequency for note G1.
G1S | Fundamental frequency for note G1#.
G2 | Fundamental frequency for note G2.
G2S | Fundamental frequency for note G2#.
G3 | Fundamental frequency for note G3.
G3S | Fundamental frequency for note G3#.
G4 | Fundamental frequency for note G4.
G4S | Fundamental frequency for note G4#.
G5 | Fundamental frequency for note G5.
G5S | Fundamental frequency for note G5#.
G6 | Fundamental frequency for note G6.
G6S | Fundamental frequency for note G6#.
G7 | Fundamental frequency for note G7.
G7S | Fundamental frequency for note G7#.
MiddleC | Note ID for "Middle C"
Top
Properties
 | Name | Description
Public property | Damping | Gets or sets the individual damping function used to lower the sound volume for this note over time. If this damping function is not defined, the damping algorithm of the song will be used for the note.
Public property | Dots | Gets or sets the total dotted note length extensions that apply to this note.
Public property | Dynamic | Gets or sets the dynamic (i.e., volume) expressed as percentage in the range of 0 to 1 for this note. If the dynamic is set to -1, the dynamic of the song will be used.
Public property | EndTimeIndex | Gets or sets end time index for this note.
Public property | Frequency | Gets or sets frequency of this note.
Public property | ID | Gets or sets note ID of the note.
Public property | NamedDynamic | Gets or sets the named dynamic (i.e., volume) for this note. If the dynamic is undefined, the dynamic of the song will be used.
Public property | NamedValue | Get or sets the note value, expressed in American form, representing the length of the note.
Public property | NamedValueBritish | Get or sets the note value, expressed in British form, representing the length of the note.
Public property | SamplePeriod | Gets or sets the sample period for this note.
Public property | StartTimeIndex | Gets or sets start time index for this note.
Public property | Timbre | Gets or sets the individual tibre function used to synthesize the sounds for this note (i.e., the instrument). If this timbre function is not defined, the timbre of the song will be used for the note.
Public property | Value | Get or sets the relative note value representing the length of the note.
Public property | ValueTime | Gets the cached note value time, in seconds, calculated from a call to CalculateValueTime(Tempo).
Top
Examples
This example creates an in-memory wave file and adds notes to create a basic musical scale:
Copy
using System;
using GSF.Media;
using GSF.Media.Music;

static class Program
{
    static void Main()
     {
         WaveFile waveFile = new WaveFile();
         long samplePeriod = 6 * waveFile.SampleRate;   // Compute total sample period
         int totalNotes = 15;                           // Total notes to traverse
         string noteID = Note.MiddleC;                  // Start note at middle C
         double frequency = Note.GetFrequency(noteID);  // Get frequency for middle C
         bool reverse = false;                          // Traverse notes in reverse order

         for (int sample = 0; sample < samplePeriod; sample++)
         {
             // Change notes at even intervals within the sample period
             if (sample > 0 && (sample % (samplePeriod / totalNotes)) == 0)
             {
                 if (reverse)
                 {
                     noteID = Note.GetPreviousID(noteID, false);
                     frequency = Note.GetFrequency(noteID);
                 }
                 else
                 {
                     noteID = Note.GetNextID(noteID, false);
                     frequency = Note.GetFrequency(noteID);
                 }

                 // Go back down the scale after C5
                 if (noteID == "C5")
                     reverse = true;
             }

             waveFile.AddSample(Timbre.BasicNote(frequency, sample, samplePeriod, waveFile.SampleRate) * 4500);
         }

         waveFile.Play();
         Console.ReadKey();
     }
}
See Also

Reference

GSF.Media.Music Namespace


Note Constructor

Grid Solutions Framework Note Constructor
Creates a new note of the specified frequency and length.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Note()
Public Sub New
new : unit -> Note
GSF.Media.Music.Note = function();
public:
Note()
Remarks

Default note will be rest (zero frequency), quarter note.

It is expected that Note objects will be constructed using object intializers.

Examples
Copy
// Create a 3/8th length, middle C note
Note note1 = new Note { Frequency = Note.C4, NamedValue = NoteValue.Quarter, Dots = 1 };

// Create a 1/8th length, E above middle C note
Note note2 = new Note { ID = "E4", NamedValueBritish = NoteValueBritish.Quaver };

// Create a whole length, F# above middle C note, "p" soft dynamic
Note note3 = new Note { Frequency = Note.F4S, Value = 1.0, NamedDynamic = Dynamic.Piano };
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note Fields

Grid Solutions Framework Note Fields

The Note type exposes the following members.

Fields
Name | Description
A0 | Fundamental frequency for note A0.
A0S | Fundamental frequency for note A0#.
A1 | Fundamental frequency for note A1.
A1S | Fundamental frequency for note A1#.
A2 | Fundamental frequency for note A2.
A2S | Fundamental frequency for note A2#.
A3 | Fundamental frequency for note A3.
A3S | Fundamental frequency for note A3#.
A4 | Fundamental frequency for note A4.
A4S | Fundamental frequency for note A4#.
A5 | Fundamental frequency for note A5.
A5S | Fundamental frequency for note A5#.
A6 | Fundamental frequency for note A6.
A6S | Fundamental frequency for note A6#.
A7 | Fundamental frequency for note A7.
A7S | Fundamental frequency for note A7#.
B0 | Fundamental frequency for note B0.
B1 | Fundamental frequency for note B1.
B2 | Fundamental frequency for note B2.
B3 | Fundamental frequency for note B3.
B4 | Fundamental frequency for note B4.
B5 | Fundamental frequency for note B5.
B6 | Fundamental frequency for note B6.
B7 | Fundamental frequency for note B7.
C0 | Fundamental frequency for note C0.
C0S | Fundamental frequency for note C0#.
C1 | Fundamental frequency for note C1.
C1S | Fundamental frequency for note C1#.
C2 | Fundamental frequency for note C2.
C2S | Fundamental frequency for note C2#.
C3 | Fundamental frequency for note C3.
C3S | Fundamental frequency for note C3#.
C4 | Fundamental frequency for note C4 - Middle C.
C4S | Fundamental frequency for note C4#.
C5 | Fundamental frequency for note C5.
C5S | Fundamental frequency for note C5#.
C6 | Fundamental frequency for note C6.
C6S | Fundamental frequency for note C6#.
C7 | Fundamental frequency for note C7.
C7S | Fundamental frequency for note C7#.
C8 | Fundamental frequency for note C8.
C8S | Fundamental frequency for note C8#.
D0 | Fundamental frequency for note D0.
D0S | Fundamental frequency for note D0#.
D1 | Fundamental frequency for note D1.
D1S | Fundamental frequency for note D1#.
D2 | Fundamental frequency for note D2.
D2S | Fundamental frequency for note D2#.
D3 | Fundamental frequency for note D3.
D3S | Fundamental frequency for note D3#.
D4 | Fundamental frequency for note D4.
D4S | Fundamental frequency for note D4#.
D5 | Fundamental frequency for note D5.
D5S | Fundamental frequency for note D5#.
D6 | Fundamental frequency for note D6.
D6S | Fundamental frequency for note D6#.
D7 | Fundamental frequency for note D7.
D7S | Fundamental frequency for note D7#.
D8 | Fundamental frequency for note D8.
D8S | Fundamental frequency for note D8#.
E0 | Fundamental frequency for note E0.
E1 | Fundamental frequency for note E1.
E2 | Fundamental frequency for note E2.
E3 | Fundamental frequency for note E3.
E4 | Fundamental frequency for note E4.
E5 | Fundamental frequency for note E5.
E6 | Fundamental frequency for note E6.
E7 | Fundamental frequency for note E7.
F0 | Fundamental frequency for note F0.
F0S | Fundamental frequency for note F0#.
F1 | Fundamental frequency for note F1.
F1S | Fundamental frequency for note F1#.
F2 | Fundamental frequency for note F2.
F2S | Fundamental frequency for note F2#.
F3 | Fundamental frequency for note F3.
F3S | Fundamental frequency for note F3#.
F4 | Fundamental frequency for note F4.
F4S | Fundamental frequency for note F4#.
F5 | Fundamental frequency for note F5.
F5S | Fundamental frequency for note F5#.
F6 | Fundamental frequency for note F6.
F6S | Fundamental frequency for note F6#.
F7 | Fundamental frequency for note F7.
F7S | Fundamental frequency for note F7#.
G0 | Fundamental frequency for note G0.
G0S | Fundamental frequency for note G0#.
G1 | Fundamental frequency for note G1.
G1S | Fundamental frequency for note G1#.
G2 | Fundamental frequency for note G2.
G2S | Fundamental frequency for note G2#.
G3 | Fundamental frequency for note G3.
G3S | Fundamental frequency for note G3#.
G4 | Fundamental frequency for note G4.
G4S | Fundamental frequency for note G4#.
G5 | Fundamental frequency for note G5.
G5S | Fundamental frequency for note G5#.
G6 | Fundamental frequency for note G6.
G6S | Fundamental frequency for note G6#.
G7 | Fundamental frequency for note G7.
G7S | Fundamental frequency for note G7#.
MiddleC | Note ID for "Middle C"
Top
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A0 Field

Grid Solutions Framework NoteA0 Field
Fundamental frequency for note A0.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A0
Public Const A0 As Double
static val mutable A0: float
var GSF.Media.Music.Note.A0
public:
literal double A0

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A0S Field

Grid Solutions Framework NoteA0S Field
Fundamental frequency for note A0#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A0S
Public Const A0S As Double
static val mutable A0S: float
var GSF.Media.Music.Note.A0S
public:
literal double A0S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A1 Field

Grid Solutions Framework NoteA1 Field
Fundamental frequency for note A1.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A1
Public Const A1 As Double
static val mutable A1: float
var GSF.Media.Music.Note.A1
public:
literal double A1

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A1S Field

Grid Solutions Framework NoteA1S Field
Fundamental frequency for note A1#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A1S
Public Const A1S As Double
static val mutable A1S: float
var GSF.Media.Music.Note.A1S
public:
literal double A1S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A2 Field

Grid Solutions Framework NoteA2 Field
Fundamental frequency for note A2.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A2
Public Const A2 As Double
static val mutable A2: float
var GSF.Media.Music.Note.A2
public:
literal double A2

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A2S Field

Grid Solutions Framework NoteA2S Field
Fundamental frequency for note A2#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A2S
Public Const A2S As Double
static val mutable A2S: float
var GSF.Media.Music.Note.A2S
public:
literal double A2S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A3 Field

Grid Solutions Framework NoteA3 Field
Fundamental frequency for note A3.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A3
Public Const A3 As Double
static val mutable A3: float
var GSF.Media.Music.Note.A3
public:
literal double A3

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A3S Field

Grid Solutions Framework NoteA3S Field
Fundamental frequency for note A3#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A3S
Public Const A3S As Double
static val mutable A3S: float
var GSF.Media.Music.Note.A3S
public:
literal double A3S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A4 Field

Grid Solutions Framework NoteA4 Field
Fundamental frequency for note A4.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A4
Public Const A4 As Double
static val mutable A4: float
var GSF.Media.Music.Note.A4
public:
literal double A4

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A4S Field

Grid Solutions Framework NoteA4S Field
Fundamental frequency for note A4#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A4S
Public Const A4S As Double
static val mutable A4S: float
var GSF.Media.Music.Note.A4S
public:
literal double A4S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A5 Field

Grid Solutions Framework NoteA5 Field
Fundamental frequency for note A5.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A5
Public Const A5 As Double
static val mutable A5: float
var GSF.Media.Music.Note.A5
public:
literal double A5

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A5S Field

Grid Solutions Framework NoteA5S Field
Fundamental frequency for note A5#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A5S
Public Const A5S As Double
static val mutable A5S: float
var GSF.Media.Music.Note.A5S
public:
literal double A5S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A6 Field

Grid Solutions Framework NoteA6 Field
Fundamental frequency for note A6.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A6
Public Const A6 As Double
static val mutable A6: float
var GSF.Media.Music.Note.A6
public:
literal double A6

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A6S Field

Grid Solutions Framework NoteA6S Field
Fundamental frequency for note A6#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A6S
Public Const A6S As Double
static val mutable A6S: float
var GSF.Media.Music.Note.A6S
public:
literal double A6S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A7 Field

Grid Solutions Framework NoteA7 Field
Fundamental frequency for note A7.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A7
Public Const A7 As Double
static val mutable A7: float
var GSF.Media.Music.Note.A7
public:
literal double A7

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.A7S Field

Grid Solutions Framework NoteA7S Field
Fundamental frequency for note A7#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double A7S
Public Const A7S As Double
static val mutable A7S: float
var GSF.Media.Music.Note.A7S
public:
literal double A7S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B0 Field

Grid Solutions Framework NoteB0 Field
Fundamental frequency for note B0.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B0
Public Const B0 As Double
static val mutable B0: float
var GSF.Media.Music.Note.B0
public:
literal double B0

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B1 Field

Grid Solutions Framework NoteB1 Field
Fundamental frequency for note B1.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B1
Public Const B1 As Double
static val mutable B1: float
var GSF.Media.Music.Note.B1
public:
literal double B1

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B2 Field

Grid Solutions Framework NoteB2 Field
Fundamental frequency for note B2.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B2
Public Const B2 As Double
static val mutable B2: float
var GSF.Media.Music.Note.B2
public:
literal double B2

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B3 Field

Grid Solutions Framework NoteB3 Field
Fundamental frequency for note B3.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B3
Public Const B3 As Double
static val mutable B3: float
var GSF.Media.Music.Note.B3
public:
literal double B3

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B4 Field

Grid Solutions Framework NoteB4 Field
Fundamental frequency for note B4.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B4
Public Const B4 As Double
static val mutable B4: float
var GSF.Media.Music.Note.B4
public:
literal double B4

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B5 Field

Grid Solutions Framework NoteB5 Field
Fundamental frequency for note B5.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B5
Public Const B5 As Double
static val mutable B5: float
var GSF.Media.Music.Note.B5
public:
literal double B5

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B6 Field

Grid Solutions Framework NoteB6 Field
Fundamental frequency for note B6.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B6
Public Const B6 As Double
static val mutable B6: float
var GSF.Media.Music.Note.B6
public:
literal double B6

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.B7 Field

Grid Solutions Framework NoteB7 Field
Fundamental frequency for note B7.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double B7
Public Const B7 As Double
static val mutable B7: float
var GSF.Media.Music.Note.B7
public:
literal double B7

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C0 Field

Grid Solutions Framework NoteC0 Field
Fundamental frequency for note C0.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C0
Public Const C0 As Double
static val mutable C0: float
var GSF.Media.Music.Note.C0
public:
literal double C0

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C0S Field

Grid Solutions Framework NoteC0S Field
Fundamental frequency for note C0#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C0S
Public Const C0S As Double
static val mutable C0S: float
var GSF.Media.Music.Note.C0S
public:
literal double C0S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C1 Field

Grid Solutions Framework NoteC1 Field
Fundamental frequency for note C1.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C1
Public Const C1 As Double
static val mutable C1: float
var GSF.Media.Music.Note.C1
public:
literal double C1

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C1S Field

Grid Solutions Framework NoteC1S Field
Fundamental frequency for note C1#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C1S
Public Const C1S As Double
static val mutable C1S: float
var GSF.Media.Music.Note.C1S
public:
literal double C1S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C2 Field

Grid Solutions Framework NoteC2 Field
Fundamental frequency for note C2.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C2
Public Const C2 As Double
static val mutable C2: float
var GSF.Media.Music.Note.C2
public:
literal double C2

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C2S Field

Grid Solutions Framework NoteC2S Field
Fundamental frequency for note C2#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C2S
Public Const C2S As Double
static val mutable C2S: float
var GSF.Media.Music.Note.C2S
public:
literal double C2S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C3 Field

Grid Solutions Framework NoteC3 Field
Fundamental frequency for note C3.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C3
Public Const C3 As Double
static val mutable C3: float
var GSF.Media.Music.Note.C3
public:
literal double C3

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C3S Field

Grid Solutions Framework NoteC3S Field
Fundamental frequency for note C3#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C3S
Public Const C3S As Double
static val mutable C3S: float
var GSF.Media.Music.Note.C3S
public:
literal double C3S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C4 Field

Grid Solutions Framework NoteC4 Field
Fundamental frequency for note C4 - Middle C.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C4
Public Const C4 As Double
static val mutable C4: float
var GSF.Media.Music.Note.C4
public:
literal double C4

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C4S Field

Grid Solutions Framework NoteC4S Field
Fundamental frequency for note C4#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C4S
Public Const C4S As Double
static val mutable C4S: float
var GSF.Media.Music.Note.C4S
public:
literal double C4S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C5 Field

Grid Solutions Framework NoteC5 Field
Fundamental frequency for note C5.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C5
Public Const C5 As Double
static val mutable C5: float
var GSF.Media.Music.Note.C5
public:
literal double C5

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C5S Field

Grid Solutions Framework NoteC5S Field
Fundamental frequency for note C5#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C5S
Public Const C5S As Double
static val mutable C5S: float
var GSF.Media.Music.Note.C5S
public:
literal double C5S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C6 Field

Grid Solutions Framework NoteC6 Field
Fundamental frequency for note C6.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C6
Public Const C6 As Double
static val mutable C6: float
var GSF.Media.Music.Note.C6
public:
literal double C6

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C6S Field

Grid Solutions Framework NoteC6S Field
Fundamental frequency for note C6#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C6S
Public Const C6S As Double
static val mutable C6S: float
var GSF.Media.Music.Note.C6S
public:
literal double C6S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C7 Field

Grid Solutions Framework NoteC7 Field
Fundamental frequency for note C7.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C7
Public Const C7 As Double
static val mutable C7: float
var GSF.Media.Music.Note.C7
public:
literal double C7

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C7S Field

Grid Solutions Framework NoteC7S Field
Fundamental frequency for note C7#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C7S
Public Const C7S As Double
static val mutable C7S: float
var GSF.Media.Music.Note.C7S
public:
literal double C7S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C8 Field

Grid Solutions Framework NoteC8 Field
Fundamental frequency for note C8.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C8
Public Const C8 As Double
static val mutable C8: float
var GSF.Media.Music.Note.C8
public:
literal double C8

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.C8S Field

Grid Solutions Framework NoteC8S Field
Fundamental frequency for note C8#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double C8S
Public Const C8S As Double
static val mutable C8S: float
var GSF.Media.Music.Note.C8S
public:
literal double C8S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D0 Field

Grid Solutions Framework NoteD0 Field
Fundamental frequency for note D0.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D0
Public Const D0 As Double
static val mutable D0: float
var GSF.Media.Music.Note.D0
public:
literal double D0

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D0S Field

Grid Solutions Framework NoteD0S Field
Fundamental frequency for note D0#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D0S
Public Const D0S As Double
static val mutable D0S: float
var GSF.Media.Music.Note.D0S
public:
literal double D0S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D1 Field

Grid Solutions Framework NoteD1 Field
Fundamental frequency for note D1.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D1
Public Const D1 As Double
static val mutable D1: float
var GSF.Media.Music.Note.D1
public:
literal double D1

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D1S Field

Grid Solutions Framework NoteD1S Field
Fundamental frequency for note D1#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D1S
Public Const D1S As Double
static val mutable D1S: float
var GSF.Media.Music.Note.D1S
public:
literal double D1S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D2 Field

Grid Solutions Framework NoteD2 Field
Fundamental frequency for note D2.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D2
Public Const D2 As Double
static val mutable D2: float
var GSF.Media.Music.Note.D2
public:
literal double D2

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D2S Field

Grid Solutions Framework NoteD2S Field
Fundamental frequency for note D2#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D2S
Public Const D2S As Double
static val mutable D2S: float
var GSF.Media.Music.Note.D2S
public:
literal double D2S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D3 Field

Grid Solutions Framework NoteD3 Field
Fundamental frequency for note D3.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D3
Public Const D3 As Double
static val mutable D3: float
var GSF.Media.Music.Note.D3
public:
literal double D3

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D3S Field

Grid Solutions Framework NoteD3S Field
Fundamental frequency for note D3#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D3S
Public Const D3S As Double
static val mutable D3S: float
var GSF.Media.Music.Note.D3S
public:
literal double D3S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D4 Field

Grid Solutions Framework NoteD4 Field
Fundamental frequency for note D4.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D4
Public Const D4 As Double
static val mutable D4: float
var GSF.Media.Music.Note.D4
public:
literal double D4

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D4S Field

Grid Solutions Framework NoteD4S Field
Fundamental frequency for note D4#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D4S
Public Const D4S As Double
static val mutable D4S: float
var GSF.Media.Music.Note.D4S
public:
literal double D4S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D5 Field

Grid Solutions Framework NoteD5 Field
Fundamental frequency for note D5.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D5
Public Const D5 As Double
static val mutable D5: float
var GSF.Media.Music.Note.D5
public:
literal double D5

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D5S Field

Grid Solutions Framework NoteD5S Field
Fundamental frequency for note D5#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D5S
Public Const D5S As Double
static val mutable D5S: float
var GSF.Media.Music.Note.D5S
public:
literal double D5S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D6 Field

Grid Solutions Framework NoteD6 Field
Fundamental frequency for note D6.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D6
Public Const D6 As Double
static val mutable D6: float
var GSF.Media.Music.Note.D6
public:
literal double D6

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D6S Field

Grid Solutions Framework NoteD6S Field
Fundamental frequency for note D6#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D6S
Public Const D6S As Double
static val mutable D6S: float
var GSF.Media.Music.Note.D6S
public:
literal double D6S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D7 Field

Grid Solutions Framework NoteD7 Field
Fundamental frequency for note D7.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D7
Public Const D7 As Double
static val mutable D7: float
var GSF.Media.Music.Note.D7
public:
literal double D7

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D7S Field

Grid Solutions Framework NoteD7S Field
Fundamental frequency for note D7#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D7S
Public Const D7S As Double
static val mutable D7S: float
var GSF.Media.Music.Note.D7S
public:
literal double D7S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D8 Field

Grid Solutions Framework NoteD8 Field
Fundamental frequency for note D8.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D8
Public Const D8 As Double
static val mutable D8: float
var GSF.Media.Music.Note.D8
public:
literal double D8

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.D8S Field

Grid Solutions Framework NoteD8S Field
Fundamental frequency for note D8#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double D8S
Public Const D8S As Double
static val mutable D8S: float
var GSF.Media.Music.Note.D8S
public:
literal double D8S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E0 Field

Grid Solutions Framework NoteE0 Field
Fundamental frequency for note E0.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E0
Public Const E0 As Double
static val mutable E0: float
var GSF.Media.Music.Note.E0
public:
literal double E0

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E1 Field

Grid Solutions Framework NoteE1 Field
Fundamental frequency for note E1.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E1
Public Const E1 As Double
static val mutable E1: float
var GSF.Media.Music.Note.E1
public:
literal double E1

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E2 Field

Grid Solutions Framework NoteE2 Field
Fundamental frequency for note E2.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E2
Public Const E2 As Double
static val mutable E2: float
var GSF.Media.Music.Note.E2
public:
literal double E2

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E3 Field

Grid Solutions Framework NoteE3 Field
Fundamental frequency for note E3.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E3
Public Const E3 As Double
static val mutable E3: float
var GSF.Media.Music.Note.E3
public:
literal double E3

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E4 Field

Grid Solutions Framework NoteE4 Field
Fundamental frequency for note E4.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E4
Public Const E4 As Double
static val mutable E4: float
var GSF.Media.Music.Note.E4
public:
literal double E4

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E5 Field

Grid Solutions Framework NoteE5 Field
Fundamental frequency for note E5.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E5
Public Const E5 As Double
static val mutable E5: float
var GSF.Media.Music.Note.E5
public:
literal double E5

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E6 Field

Grid Solutions Framework NoteE6 Field
Fundamental frequency for note E6.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E6
Public Const E6 As Double
static val mutable E6: float
var GSF.Media.Music.Note.E6
public:
literal double E6

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.E7 Field

Grid Solutions Framework NoteE7 Field
Fundamental frequency for note E7.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double E7
Public Const E7 As Double
static val mutable E7: float
var GSF.Media.Music.Note.E7
public:
literal double E7

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F0 Field

Grid Solutions Framework NoteF0 Field
Fundamental frequency for note F0.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F0
Public Const F0 As Double
static val mutable F0: float
var GSF.Media.Music.Note.F0
public:
literal double F0

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F0S Field

Grid Solutions Framework NoteF0S Field
Fundamental frequency for note F0#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F0S
Public Const F0S As Double
static val mutable F0S: float
var GSF.Media.Music.Note.F0S
public:
literal double F0S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F1 Field

Grid Solutions Framework NoteF1 Field
Fundamental frequency for note F1.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F1
Public Const F1 As Double
static val mutable F1: float
var GSF.Media.Music.Note.F1
public:
literal double F1

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F1S Field

Grid Solutions Framework NoteF1S Field
Fundamental frequency for note F1#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F1S
Public Const F1S As Double
static val mutable F1S: float
var GSF.Media.Music.Note.F1S
public:
literal double F1S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F2 Field

Grid Solutions Framework NoteF2 Field
Fundamental frequency for note F2.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F2
Public Const F2 As Double
static val mutable F2: float
var GSF.Media.Music.Note.F2
public:
literal double F2

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F2S Field

Grid Solutions Framework NoteF2S Field
Fundamental frequency for note F2#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F2S
Public Const F2S As Double
static val mutable F2S: float
var GSF.Media.Music.Note.F2S
public:
literal double F2S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F3 Field

Grid Solutions Framework NoteF3 Field
Fundamental frequency for note F3.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F3
Public Const F3 As Double
static val mutable F3: float
var GSF.Media.Music.Note.F3
public:
literal double F3

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F3S Field

Grid Solutions Framework NoteF3S Field
Fundamental frequency for note F3#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F3S
Public Const F3S As Double
static val mutable F3S: float
var GSF.Media.Music.Note.F3S
public:
literal double F3S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F4 Field

Grid Solutions Framework NoteF4 Field
Fundamental frequency for note F4.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F4
Public Const F4 As Double
static val mutable F4: float
var GSF.Media.Music.Note.F4
public:
literal double F4

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F4S Field

Grid Solutions Framework NoteF4S Field
Fundamental frequency for note F4#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F4S
Public Const F4S As Double
static val mutable F4S: float
var GSF.Media.Music.Note.F4S
public:
literal double F4S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F5 Field

Grid Solutions Framework NoteF5 Field
Fundamental frequency for note F5.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F5
Public Const F5 As Double
static val mutable F5: float
var GSF.Media.Music.Note.F5
public:
literal double F5

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F5S Field

Grid Solutions Framework NoteF5S Field
Fundamental frequency for note F5#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F5S
Public Const F5S As Double
static val mutable F5S: float
var GSF.Media.Music.Note.F5S
public:
literal double F5S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F6 Field

Grid Solutions Framework NoteF6 Field
Fundamental frequency for note F6.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F6
Public Const F6 As Double
static val mutable F6: float
var GSF.Media.Music.Note.F6
public:
literal double F6

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F6S Field

Grid Solutions Framework NoteF6S Field
Fundamental frequency for note F6#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F6S
Public Const F6S As Double
static val mutable F6S: float
var GSF.Media.Music.Note.F6S
public:
literal double F6S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F7 Field

Grid Solutions Framework NoteF7 Field
Fundamental frequency for note F7.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F7
Public Const F7 As Double
static val mutable F7: float
var GSF.Media.Music.Note.F7
public:
literal double F7

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.F7S Field

Grid Solutions Framework NoteF7S Field
Fundamental frequency for note F7#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double F7S
Public Const F7S As Double
static val mutable F7S: float
var GSF.Media.Music.Note.F7S
public:
literal double F7S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G0 Field

Grid Solutions Framework NoteG0 Field
Fundamental frequency for note G0.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G0
Public Const G0 As Double
static val mutable G0: float
var GSF.Media.Music.Note.G0
public:
literal double G0

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G0S Field

Grid Solutions Framework NoteG0S Field
Fundamental frequency for note G0#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G0S
Public Const G0S As Double
static val mutable G0S: float
var GSF.Media.Music.Note.G0S
public:
literal double G0S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G1 Field

Grid Solutions Framework NoteG1 Field
Fundamental frequency for note G1.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G1
Public Const G1 As Double
static val mutable G1: float
var GSF.Media.Music.Note.G1
public:
literal double G1

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G1S Field

Grid Solutions Framework NoteG1S Field
Fundamental frequency for note G1#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G1S
Public Const G1S As Double
static val mutable G1S: float
var GSF.Media.Music.Note.G1S
public:
literal double G1S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G2 Field

Grid Solutions Framework NoteG2 Field
Fundamental frequency for note G2.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G2
Public Const G2 As Double
static val mutable G2: float
var GSF.Media.Music.Note.G2
public:
literal double G2

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G2S Field

Grid Solutions Framework NoteG2S Field
Fundamental frequency for note G2#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G2S
Public Const G2S As Double
static val mutable G2S: float
var GSF.Media.Music.Note.G2S
public:
literal double G2S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G3 Field

Grid Solutions Framework NoteG3 Field
Fundamental frequency for note G3.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G3
Public Const G3 As Double
static val mutable G3: float
var GSF.Media.Music.Note.G3
public:
literal double G3

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G3S Field

Grid Solutions Framework NoteG3S Field
Fundamental frequency for note G3#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G3S
Public Const G3S As Double
static val mutable G3S: float
var GSF.Media.Music.Note.G3S
public:
literal double G3S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G4 Field

Grid Solutions Framework NoteG4 Field
Fundamental frequency for note G4.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G4
Public Const G4 As Double
static val mutable G4: float
var GSF.Media.Music.Note.G4
public:
literal double G4

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G4S Field

Grid Solutions Framework NoteG4S Field
Fundamental frequency for note G4#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G4S
Public Const G4S As Double
static val mutable G4S: float
var GSF.Media.Music.Note.G4S
public:
literal double G4S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G5 Field

Grid Solutions Framework NoteG5 Field
Fundamental frequency for note G5.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G5
Public Const G5 As Double
static val mutable G5: float
var GSF.Media.Music.Note.G5
public:
literal double G5

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G5S Field

Grid Solutions Framework NoteG5S Field
Fundamental frequency for note G5#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G5S
Public Const G5S As Double
static val mutable G5S: float
var GSF.Media.Music.Note.G5S
public:
literal double G5S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G6 Field

Grid Solutions Framework NoteG6 Field
Fundamental frequency for note G6.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G6
Public Const G6 As Double
static val mutable G6: float
var GSF.Media.Music.Note.G6
public:
literal double G6

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G6S Field

Grid Solutions Framework NoteG6S Field
Fundamental frequency for note G6#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G6S
Public Const G6S As Double
static val mutable G6S: float
var GSF.Media.Music.Note.G6S
public:
literal double G6S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G7 Field

Grid Solutions Framework NoteG7 Field
Fundamental frequency for note G7.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G7
Public Const G7 As Double
static val mutable G7: float
var GSF.Media.Music.Note.G7
public:
literal double G7

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.G7S Field

Grid Solutions Framework NoteG7S Field
Fundamental frequency for note G7#.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double G7S
Public Const G7S As Double
static val mutable G7S: float
var GSF.Media.Music.Note.G7S
public:
literal double G7S

Field Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.MiddleC Field

Grid Solutions Framework NoteMiddleC Field
Note ID for "Middle C"

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string MiddleC
Public Const MiddleC As String
static val mutable MiddleC: string
var GSF.Media.Music.Note.MiddleC
public:
literal String^ MiddleC

Field Value

Type: String
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note Methods

Grid Solutions Framework Note Methods

The Note type exposes the following members.

Methods
 | Name | Description
Public method | CalculateValueTime | Calculates the actual time duration, in seconds, for the specified tempo that the note value will last. For example, if tempo is M.M. 120 quarter-notes per minte, then each quarter-note would last a half-second.
Public method | CompareTo(Object) | Notes are compared by frequency, then by value (i.e., duration).
Public method | CompareTo(Note) | Notes are compared by frequency, then by value (i.e., duration).
Public method | Equals(Object) | Returns True if the frequency and value of this note equals the frequency and value of the specified other note. (Overrides ObjectEquals(Object).)
Public method | Equals(Note) | Returns True if the frequency and value of this note equals the frequency and value of the specified other note.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | GetFrequency(String) | Gets the specified note frequency.
 | GetFrequency(Char, Int32, Boolean) | Gets the specified note frequency.
Public method | GetHashCode | Serves as a hash function for the current Note. (Overrides ObjectGetHashCode.)
 | GetNextID | Gets the next note ID in sequence after the specified note ID.
 | GetPreviousID | Gets the previous note ID in sequence before the specified note ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NamedValueIndex | Returns closest note value index (for NoteValue or NoteValueBritish) given the relative duration of a note.
Public method | ToString | Returns a string representation for the note. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.CalculateValueTime Method

Grid Solutions Framework NoteCalculateValueTime Method
Calculates the actual time duration, in seconds, for the specified tempo that the note value will last. For example, if tempo is M.M. 120 quarter-notes per minte, then each quarter-note would last a half-second.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculateValueTime(
    Tempo tempo
)
Public Function CalculateValueTime (
    tempo As Tempo
) As Double
member CalculateValueTime :
        tempo : Tempo -> float

function CalculateValueTime(tempo);
public:
double CalculateValueTime(
    Tempo^ tempo
)

Parameters

tempo
Type: GSF.Media.MusicTempo
Tempo used to calculate note value time.

Return Value

Type: Double
Calculated note value time.
Remarks
Calculated value is cached and available from ValueTime property.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.CompareTo Method

Grid Solutions Framework NoteCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Notes are compared by frequency, then by value (i.e., duration).
Public method | CompareTo(Note) | Notes are compared by frequency, then by value (i.e., duration).
Top
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.CompareTo Method (Object)

Grid Solutions Framework NoteCompareTo Method (Object)
Notes are compared by frequency, then by value (i.e., duration).

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: SystemObject
An Object that is compared against.

Return Value

Type: Int32
An Int32 that indicates: this object is greater than if 1, equal to if 0, or less than if -1.

Implements

IComparableCompareTo(Object)
See Also

Reference

Note Class
CompareTo Overload
GSF.Media.Music Namespace


Note.CompareTo Method (Note)

Grid Solutions Framework NoteCompareTo Method (Note)
Notes are compared by frequency, then by value (i.e., duration).

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Note other
)
Public Function CompareTo (
    other As Note
) As Integer
abstract CompareTo :
        other : Note -> int
override CompareTo :
        other : Note -> int
function CompareTo(other);
public:
virtual int CompareTo(
    Note^ other
) sealed

Parameters

other
Type: GSF.Media.MusicNote
A Note that is compared against.

Return Value

Type: Int32
An Int32 that indicates: this object is greater than if 1, equal to if 0, or less than if -1.

Implements

IComparableTCompareTo(T)
See Also

Reference

Note Class
CompareTo Overload
GSF.Media.Music Namespace


Note.Equals Method

Grid Solutions Framework NoteEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Returns True if the frequency and value of this note equals the frequency and value of the specified other note. (Overrides ObjectEquals(Object).)
Public method | Equals(Note) | Returns True if the frequency and value of this note equals the frequency and value of the specified other note.
Top
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Equals Method (Object)

Grid Solutions Framework NoteEquals Method (Object)
Returns True if the frequency and value of this note equals the frequency and value of the specified other note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The other Object to compare against.

Return Value

Type: Boolean
A Boolean indicating the result.
See Also

Reference

Note Class
Equals Overload
GSF.Media.Music Namespace


Note.Equals Method (Note)

Grid Solutions Framework NoteEquals Method (Note)
Returns True if the frequency and value of this note equals the frequency and value of the specified other note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Note other
)
Public Function Equals (
    other As Note
) As Boolean
abstract Equals :
        other : Note -> bool
override Equals :
        other : Note -> bool
function Equals(other);
public:
virtual bool Equals(
    Note^ other
) sealed

Parameters

other
Type: GSF.Media.MusicNote
The other Note to compare against.

Return Value

Type: Boolean
A Boolean indicating the result.

Implements

IEquatableTEquals(T)
See Also

Reference

Note Class
Equals Overload
GSF.Media.Music Namespace


Note.GetFrequency Method

Grid Solutions Framework NoteGetFrequency Method
Overload List
Name | Description
GetFrequency(String) | Gets the specified note frequency.
GetFrequency(Char, Int32, Boolean) | Gets the specified note frequency.
Top
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.GetFrequency Method (String)

Grid Solutions Framework NoteGetFrequency Method (String)
Gets the specified note frequency.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double GetFrequency(
    string noteID
)
Public Shared Function GetFrequency (
    noteID As String
) As Double
static member GetFrequency :
        noteID : string -> float

GSF.Media.Music.Note.GetFrequency = function(noteID);
public:
static double GetFrequency(
    String^ noteID
)

Parameters

noteID
Type: SystemString
ID of the note to retrieve - expected format is "Note + Octave + S?" (e.g., A2 or C5S)

Return Value

Type: Double
The specified note.
Exceptions
Exception | Condition
ArgumentNullException | noteID is null.
ArgumentException | Invalid note ID format - expected "Note + Octave + S?" (e.g., A2 or C5S).
See Also

Reference

Note Class
GetFrequency Overload
GSF.Media.Music Namespace


Note.GetFrequency Method (Char, Int32, Boolean)

Grid Solutions Framework NoteGetFrequency Method (Char, Int32, Boolean)
Gets the specified note frequency.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double GetFrequency(
    char note,
    int octave,
    bool sharp
)
Public Shared Function GetFrequency (
    note As Char,
    octave As Integer,
    sharp As Boolean
) As Double
static member GetFrequency :
        note : char *
        octave : int *
        sharp : bool -> float

GSF.Media.Music.Note.GetFrequency = function(note, octave, sharp);
public:
static double GetFrequency(
    wchar_t note,
    int octave,
    bool sharp
)

Parameters

note
Type: SystemChar
Note (A - G) to retrieve.
octave
Type: SystemInt32
Octave of the the note to retrieve (0 - 8).
sharp
Type: SystemBoolean
Indicates to get the "sharp" version of the note.

Return Value

Type: Double
The specified note.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Notes must be A - G, octaves must be 0 - 8, first note is C0, last note is D8S.
ArgumentException | Sharps are not defined for notes 'B' and 'E'.
See Also

Reference

Note Class
GetFrequency Overload
GSF.Media.Music Namespace


Note.GetHashCode Method

Grid Solutions Framework NoteGetHashCode Method
Serves as a hash function for the current Note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current Note.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.GetNextID Method

Grid Solutions Framework NoteGetNextID Method
Gets the next note ID in sequence after the specified note ID.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetNextID(
    string noteID,
    bool includeSharps
)
Public Shared Function GetNextID (
    noteID As String,
    includeSharps As Boolean
) As String
static member GetNextID :
        noteID : string *
        includeSharps : bool -> string

GSF.Media.Music.Note.GetNextID = function(noteID, includeSharps);
public:
static String^ GetNextID(
    String^ noteID,
    bool includeSharps
)

Parameters

noteID
Type: SystemString
ID of the current note - expected format is "Note + Octave + S?" (e.g., A2 or C5S)
includeSharps
Type: SystemBoolean
Set to True to include sharp notes in the sequence.

Return Value

Type: String
The next note ID that is after the specified note ID.
Exceptions
Exception | Condition
ArgumentNullException | noteID is null.
ArgumentException | Invalid note ID format - expected "Note + Octave + S?" (e.g., A2 or C5S).
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.GetPreviousID Method

Grid Solutions Framework NoteGetPreviousID Method
Gets the previous note ID in sequence before the specified note ID.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetPreviousID(
    string noteID,
    bool includeSharps
)
Public Shared Function GetPreviousID (
    noteID As String,
    includeSharps As Boolean
) As String
static member GetPreviousID :
        noteID : string *
        includeSharps : bool -> string

GSF.Media.Music.Note.GetPreviousID = function(noteID, includeSharps);
public:
static String^ GetPreviousID(
    String^ noteID,
    bool includeSharps
)

Parameters

noteID
Type: SystemString
ID of the current note - expected format is "Note + Octave + S?" (e.g., A2 or C5S)
includeSharps
Type: SystemBoolean
Set to True to include sharp notes in the sequence.

Return Value

Type: String
The previous note ID that is before the specified note ID.
Exceptions
Exception | Condition
ArgumentNullException | noteID is null.
ArgumentException | Invalid note ID format - expected "Note + Octave + S?" (e.g., A2 or C5S).
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.NamedValueIndex Method

Grid Solutions Framework NoteNamedValueIndex Method
Returns closest note value index (for NoteValue or NoteValueBritish) given the relative duration of a note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int NamedValueIndex(
    double value
)
Public Shared Function NamedValueIndex (
    value As Double
) As Integer
static member NamedValueIndex :
        value : float -> int

GSF.Media.Music.Note.NamedValueIndex = function(value);
public:
static int NamedValueIndex(
    double value
)

Parameters

value
Type: SystemDouble
Relative duration of the note.

Return Value

Type: Int32
Closest note value enumeration index given the relative duration of a note.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.ToString Method

Grid Solutions Framework NoteToString Method
Returns a string representation for the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String value representation for the note.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note Operators

Grid Solutions Framework Note Operators

The Note type exposes the following members.

Operators
Name | Description
Equality | Compares two Note frequencies and values for equality.
GreaterThan | Returns true if left Note timestamp is greater than right Note.
GreaterThanOrEqual | Returns true if left Note timestamp is greater than or equal to right Note.
Inequality | Compares two Note frequencies and values for inequality.
LessThan | Returns true if left Note timestamp is less than right Note.
LessThanOrEqual | Returns true if left Note timestamp is less than or equal to right Note.
Top
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Equality Operator

Grid Solutions Framework NoteEquality Operator
Compares two Note frequencies and values for equality.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Note note1,
    Note note2
)
Public Shared Operator = (
    note1 As Note,
    note2 As Note
) As Boolean
static let inline (=)
        note1 : Note *
        note2 : Note  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Note^ note1,
    Note^ note2
)

Parameters

note1
Type: GSF.Media.MusicNote
A Note left hand operand.
note2
Type: GSF.Media.MusicNote
A Note right hand operand.

Return Value

Type: Boolean
A boolean indicating the result of the comparison.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.GreaterThan Operator

Grid Solutions Framework NoteGreaterThan Operator
Returns true if left Note timestamp is greater than right Note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Note note1,
    Note note2
)
Public Shared Operator > (
    note1 As Note,
    note2 As Note
) As Boolean
static let inline (>)
        note1 : Note *
        note2 : Note  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Note^ note1,
    Note^ note2
)

Parameters

note1
Type: GSF.Media.MusicNote
A Note left hand operand.
note2
Type: GSF.Media.MusicNote
A Note right hand operand.

Return Value

Type: Boolean
A boolean indicating the result of the comparison.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.GreaterThanOrEqual Operator

Grid Solutions Framework NoteGreaterThanOrEqual Operator
Returns true if left Note timestamp is greater than or equal to right Note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Note note1,
    Note note2
)
Public Shared Operator >= (
    note1 As Note,
    note2 As Note
) As Boolean
static let inline (>=)
        note1 : Note *
        note2 : Note  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Note^ note1,
    Note^ note2
)

Parameters

note1
Type: GSF.Media.MusicNote
A Note left hand operand.
note2
Type: GSF.Media.MusicNote
A Note right hand operand.

Return Value

Type: Boolean
A boolean indicating the result of the comparison.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Inequality Operator

Grid Solutions Framework NoteInequality Operator
Compares two Note frequencies and values for inequality.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Note note1,
    Note note2
)
Public Shared Operator <> (
    note1 As Note,
    note2 As Note
) As Boolean
static let inline (<>)
        note1 : Note *
        note2 : Note  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Note^ note1,
    Note^ note2
)

Parameters

note1
Type: GSF.Media.MusicNote
A Note left hand operand.
note2
Type: GSF.Media.MusicNote
A Note right hand operand.

Return Value

Type: Boolean
A boolean indicating the result of the comparison.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.LessThan Operator

Grid Solutions Framework NoteLessThan Operator
Returns true if left Note timestamp is less than right Note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Note note1,
    Note note2
)
Public Shared Operator < (
    note1 As Note,
    note2 As Note
) As Boolean
static let inline (<)
        note1 : Note *
        note2 : Note  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Note^ note1,
    Note^ note2
)

Parameters

note1
Type: GSF.Media.MusicNote
A Note left hand operand.
note2
Type: GSF.Media.MusicNote
A Note right hand operand.

Return Value

Type: Boolean
A boolean indicating the result of the comparison.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.LessThanOrEqual Operator

Grid Solutions Framework NoteLessThanOrEqual Operator
Returns true if left Note timestamp is less than or equal to right Note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Note note1,
    Note note2
)
Public Shared Operator <= (
    note1 As Note,
    note2 As Note
) As Boolean
static let inline (<=)
        note1 : Note *
        note2 : Note  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Note^ note1,
    Note^ note2
)

Parameters

note1
Type: GSF.Media.MusicNote
A Note left hand operand.
note2
Type: GSF.Media.MusicNote
A Note right hand operand.

Return Value

Type: Boolean
A boolean indicating the result of the comparison.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note Properties

Grid Solutions Framework Note Properties

The Note type exposes the following members.

Properties
 | Name | Description
Public property | Damping | Gets or sets the individual damping function used to lower the sound volume for this note over time. If this damping function is not defined, the damping algorithm of the song will be used for the note.
Public property | Dots | Gets or sets the total dotted note length extensions that apply to this note.
Public property | Dynamic | Gets or sets the dynamic (i.e., volume) expressed as percentage in the range of 0 to 1 for this note. If the dynamic is set to -1, the dynamic of the song will be used.
Public property | EndTimeIndex | Gets or sets end time index for this note.
Public property | Frequency | Gets or sets frequency of this note.
Public property | ID | Gets or sets note ID of the note.
Public property | NamedDynamic | Gets or sets the named dynamic (i.e., volume) for this note. If the dynamic is undefined, the dynamic of the song will be used.
Public property | NamedValue | Get or sets the note value, expressed in American form, representing the length of the note.
Public property | NamedValueBritish | Get or sets the note value, expressed in British form, representing the length of the note.
Public property | SamplePeriod | Gets or sets the sample period for this note.
Public property | StartTimeIndex | Gets or sets start time index for this note.
Public property | Timbre | Gets or sets the individual tibre function used to synthesize the sounds for this note (i.e., the instrument). If this timbre function is not defined, the timbre of the song will be used for the note.
Public property | Value | Get or sets the relative note value representing the length of the note.
Public property | ValueTime | Gets the cached note value time, in seconds, calculated from a call to CalculateValueTime(Tempo).
Top
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Damping Property

Grid Solutions Framework NoteDamping Property
Gets or sets the individual damping function used to lower the sound volume for this note over time. If this damping function is not defined, the damping algorithm of the song will be used for the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DampingFunction Damping { get; set; }
Public Property Damping As DampingFunction
    Get
    Set
member Damping : DampingFunction with get, set

function get_Damping();
function set_Damping(value);
public:
property DampingFunction^ Damping {
    DampingFunction^ get ();
    void set (DampingFunction^ value);
}

Property Value

Type: DampingFunction
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Dots Property

Grid Solutions Framework NoteDots Property
Gets or sets the total dotted note length extensions that apply to this note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Dots { get; set; }
Public Property Dots As Integer
    Get
    Set
member Dots : int with get, set

function get_Dots();
function set_Dots(value);
public:
property int Dots {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This is only used in conjunction with the named note values.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Dynamic Property

Grid Solutions Framework NoteDynamic Property
Gets or sets the dynamic (i.e., volume) expressed as percentage in the range of 0 to 1 for this note. If the dynamic is set to -1, the dynamic of the song will be used.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Dynamic { get; set; }
Public Property Dynamic As Double
    Get
    Set
member Dynamic : float with get, set

function get_Dynamic();
function set_Dynamic(value);
public:
property double Dynamic {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value must be expressed as a fractional percentage between zero and one.
Remarks
Set this value to -1 to use the current dynamic of the song.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.EndTimeIndex Property

Grid Solutions Framework NoteEndTimeIndex Property
Gets or sets end time index for this note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public long EndTimeIndex { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property EndTimeIndex As Long
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member EndTimeIndex : int64 with get, set

function get_EndTimeIndex();
function set_EndTimeIndex(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property long long EndTimeIndex {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Remarks
This is typically assigned and used by host Song
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Frequency Property

Grid Solutions Framework NoteFrequency Property
Gets or sets frequency of this note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Frequency { get; set; }
Public Property Frequency As Double
    Get
    Set
member Frequency : float with get, set

function get_Frequency();
function set_Frequency(value);
public:
property double Frequency {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.ID Property

Grid Solutions Framework NoteID Property
Gets or sets note ID of the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
member ID : string with get, set

function get_ID();
function set_ID(value);
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | noteID is null.
ArgumentException | Invalid note ID format - expected "Note + Octave + S?" (e.g., A2 or C5S).
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.NamedDynamic Property

Grid Solutions Framework NoteNamedDynamic Property
Gets or sets the named dynamic (i.e., volume) for this note. If the dynamic is undefined, the dynamic of the song will be used.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dynamic NamedDynamic { get; set; }
Public Property NamedDynamic As Dynamic
    Get
    Set
member NamedDynamic : Dynamic with get, set

function get_NamedDynamic();
function set_NamedDynamic(value);
public:
property Dynamic NamedDynamic {
    Dynamic get ();
    void set (Dynamic value);
}

Property Value

Type: Dynamic
Remarks
Set this value to undefined to use the current dynamic of the song.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.NamedValue Property

Grid Solutions Framework NoteNamedValue Property
Get or sets the note value, expressed in American form, representing the length of the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NoteValue NamedValue { get; set; }
Public Property NamedValue As NoteValue
    Get
    Set
member NamedValue : NoteValue with get, set

function get_NamedValue();
function set_NamedValue(value);
public:
property NoteValue NamedValue {
    NoteValue get ();
    void set (NoteValue value);
}

Property Value

Type: NoteValue
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.NamedValueBritish Property

Grid Solutions Framework NoteNamedValueBritish Property
Get or sets the note value, expressed in British form, representing the length of the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NoteValueBritish NamedValueBritish { get; set; }
Public Property NamedValueBritish As NoteValueBritish
    Get
    Set
member NamedValueBritish : NoteValueBritish with get, set

function get_NamedValueBritish();
function set_NamedValueBritish(value);
public:
property NoteValueBritish NamedValueBritish {
    NoteValueBritish get ();
    void set (NoteValueBritish value);
}

Property Value

Type: NoteValueBritish
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.SamplePeriod Property

Grid Solutions Framework NoteSamplePeriod Property
Gets or sets the sample period for this note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public long SamplePeriod { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property SamplePeriod As Long
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member SamplePeriod : int64 with get, set

function get_SamplePeriod();
function set_SamplePeriod(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property long long SamplePeriod {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Remarks
This is typically assigned and used by host Song
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.StartTimeIndex Property

Grid Solutions Framework NoteStartTimeIndex Property
Gets or sets start time index for this note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public long StartTimeIndex { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property StartTimeIndex As Long
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member StartTimeIndex : int64 with get, set

function get_StartTimeIndex();
function set_StartTimeIndex(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property long long StartTimeIndex {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Remarks
This is typically assigned and used by host Song
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Timbre Property

Grid Solutions Framework NoteTimbre Property
Gets or sets the individual tibre function used to synthesize the sounds for this note (i.e., the instrument). If this timbre function is not defined, the timbre of the song will be used for the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimbreFunction Timbre { get; set; }
Public Property Timbre As TimbreFunction
    Get
    Set
member Timbre : TimbreFunction with get, set

function get_Timbre();
function set_Timbre(value);
public:
property TimbreFunction^ Timbre {
    TimbreFunction^ get ();
    void set (TimbreFunction^ value);
}

Property Value

Type: TimbreFunction
Remarks
Set this value to null to use current timbre function of the song.
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.Value Property

Grid Solutions Framework NoteValue Property
Get or sets the relative note value representing the length of the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Value { get; set; }
Public Property Value As Double
    Get
    Set
member Value : float with get, set

function get_Value();
function set_Value(value);
public:
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


Note.ValueTime Property

Grid Solutions Framework NoteValueTime Property
Gets the cached note value time, in seconds, calculated from a call to CalculateValueTime(Tempo).

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ValueTime { get; }
Public ReadOnly Property ValueTime As Double
    Get
member ValueTime : float with get

function get_ValueTime();

public:
property double ValueTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

Note Class
GSF.Media.Music Namespace


NoteValue Enumeration

Grid Solutions Framework NoteValue Enumeration
American note value (♪) representing the relative duration of a note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum NoteValue
Public Enumeration NoteValue
type NoteValue
GSF.Media.Music.NoteValue = function();
GSF.Media.Music.NoteValue.createEnum('GSF.Media.Music.NoteValue', false);
public enum class NoteValue
Members
Member name | Value | Description
Longa | 0 | Quadruple whole note (i.e., 4 times the length of a whole note).
Breve | 1 | Double whole note (i.e., 2 times the length of a whole note).
Whole | 2 | Whole note.
Half | 3 | Half note (i.e., 1/2 the length of a whole note).
Quarter | 4 | Quarter note (i.e., 1/4 the length of a whole note).
Eighth | 5 | Eighth note (i.e., 1/8 the length of a whole note).
Sixteenth | 6 | Sixteenth note (i.e., 1/16 the length of a whole note).
ThirtySecond | 7 | ThirtySecond note (i.e., 1/32 the length of a whole note).
SixtyFourth | 8 | SixtyFourth note (i.e., 1/64 the length of a whole note).
HundredTwentyEighth | 9 | HundredTwentyEighth note (i.e., 1/128 the length of a whole note).
TwoHundredFiftySixth | 10 | TwoHundredFiftySixth note (i.e., 1/256 the length of a whole note).
FiveHundredTwelfth | 11 | FiveHundredTwelfth note (i.e., 1/512 the length of a whole note).
ThousandTwentyFourth | 12 | ThousandTwentyFourth note (i.e., 1/1024 the length of a whole note).
Remarks
Note duration formula accessible via extension function "Duration()" for given note value.
See Also

Reference

GSF.Media.Music Namespace


NoteValueBritish Enumeration

Grid Solutions Framework NoteValueBritish Enumeration
British note value (♪) representing the relative duration of a note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum NoteValueBritish
Public Enumeration NoteValueBritish
type NoteValueBritish
GSF.Media.Music.NoteValueBritish = function();
GSF.Media.Music.NoteValueBritish.createEnum('GSF.Media.Music.NoteValueBritish', false);
public enum class NoteValueBritish
Members
Member name | Value | Description
Longa | 0 | Quadruple whole note (i.e., 4 times the length of a whole note).
Breve | 1 | Double whole note (i.e., 2 times the length of a whole note).
Semibreve | 2 | Whole note.
Minim | 3 | Half note (i.e., 1/2 the length of a whole note).
Crotchet | 4 | Quarter note (i.e., 1/4 the length of a whole note).
Quaver | 5 | Eighth note (i.e., 1/8 the length of a whole note).
Semiquaver | 6 | Sixteenth note (i.e., 1/16 the length of a whole note).
Demisemiquaver | 7 | ThirtySecond note (i.e., 1/32 the length of a whole note).
Hemidemisemiquaver | 8 | SixtyFourth note (i.e., 1/64 the length of a whole note).
Quasihemidemisemiquaver | 9 | HundredTwentyEighth note (i.e., 1/128 the length of a whole note).
TwoHundredFiftySixth | 10 | TwoHundredFiftySixth note (i.e., 1/256 the length of a whole note).
FiveHundredTwelfth | 11 | FiveHundredTwelfth note (i.e., 1/512 the length of a whole note).
ThousandTwentyFourth | 12 | ThousandTwentyFourth note (i.e., 1/1024 the length of a whole note).
Remarks
Note duration formula accessible via extension function "Duration()" for given note value.
See Also

Reference

GSF.Media.Music Namespace


NoteValueExtensions Class

Grid Solutions Framework NoteValueExtensions Class
Defines extension functions related to note value enumerations.
Inheritance Hierarchy
SystemObject
GSF.Media.MusicNoteValueExtensions

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class NoteValueExtensions
<ExtensionAttribute>
Public NotInheritable Class NoteValueExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NoteValueExtensions =  class end
GSF.Media.Music.NoteValueExtensions = function();

Type.createClass(
    'GSF.Media.Music.NoteValueExtensions');
[ExtensionAttribute]
public ref class NoteValueExtensions abstract sealed
Methods
Name | Description
Duration(NoteValue) | Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.
Duration(NoteValueBritish) | Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.
Duration(NoteValue, NoteValue) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValue, Int32) | Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.
Duration(NoteValueBritish, NoteValueBritish) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValueBritish, Int32) | Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.
Duration(NoteValue, NoteValue, Int32) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValueBritish, NoteValueBritish, Int32) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Top
See Also

Reference

GSF.Media.Music Namespace


NoteValueExtensions Methods

Grid Solutions Framework NoteValueExtensions Methods
Methods
Name | Description
Duration(NoteValue) | Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.
Duration(NoteValueBritish) | Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.
Duration(NoteValue, NoteValue) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValue, Int32) | Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.
Duration(NoteValueBritish, NoteValueBritish) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValueBritish, Int32) | Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.
Duration(NoteValue, NoteValue, Int32) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValueBritish, NoteValueBritish, Int32) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Top
See Also

Reference

NoteValueExtensions Class
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method

Grid Solutions Framework NoteValueExtensionsDuration Method
Overload List
Name | Description
Duration(NoteValue) | Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.
Duration(NoteValueBritish) | Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.
Duration(NoteValue, NoteValue) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValue, Int32) | Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.
Duration(NoteValueBritish, NoteValueBritish) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValueBritish, Int32) | Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.
Duration(NoteValue, NoteValue, Int32) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Duration(NoteValueBritish, NoteValueBritish, Int32) | Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.
Top
See Also

Reference

NoteValueExtensions Class
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValue)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValue)
Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValue source
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValue
) As Double
static member Duration :
        source : NoteValue -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source);
public:
[ExtensionAttribute]
static double Duration(
    NoteValue source
)

Parameters

source
Type: GSF.Media.MusicNoteValue
Source note value.

Return Value

Type: Double
Duration of note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValueBritish)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValueBritish)
Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValueBritish source
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValueBritish
) As Double
static member Duration :
        source : NoteValueBritish -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source);
public:
[ExtensionAttribute]
static double Duration(
    NoteValueBritish source
)

Parameters

source
Type: GSF.Media.MusicNoteValueBritish
Source note value.

Return Value

Type: Double
Duration of note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValueBritish. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValue, NoteValue)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValue, NoteValue)
Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValue source,
    NoteValue reference
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValue,
    reference As NoteValue
) As Double
static member Duration :
        source : NoteValue *
        reference : NoteValue -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source, reference);
public:
[ExtensionAttribute]
static double Duration(
    NoteValue source,
    NoteValue reference
)

Parameters

source
Type: GSF.Media.MusicNoteValue
Source note value.
reference
Type: GSF.Media.MusicNoteValue
Reference note value.

Return Value

Type: Double
Duration of note value in terms of specified reference note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValue, Int32)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValue, Int32)
Returns source note value duration. For example, 0.25 will be returned for a quater note, 1.0 will be returned for a whole note, etc.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValue source,
    int dots
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValue,
    dots As Integer
) As Double
static member Duration :
        source : NoteValue *
        dots : int -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source, dots);
public:
[ExtensionAttribute]
static double Duration(
    NoteValue source,
    int dots
)

Parameters

source
Type: GSF.Media.MusicNoteValue
Source note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.

Return Value

Type: Double
Duration of note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValueBritish, NoteValueBritish)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValueBritish, NoteValueBritish)
Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValueBritish source,
    NoteValueBritish reference
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValueBritish,
    reference As NoteValueBritish
) As Double
static member Duration :
        source : NoteValueBritish *
        reference : NoteValueBritish -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source, reference);
public:
[ExtensionAttribute]
static double Duration(
    NoteValueBritish source,
    NoteValueBritish reference
)

Parameters

source
Type: GSF.Media.MusicNoteValueBritish
Source note value.
reference
Type: GSF.Media.MusicNoteValueBritish
Reference note value.

Return Value

Type: Double
Duration of note value in terms of specified reference note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValueBritish. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValueBritish, Int32)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValueBritish, Int32)
Returns source note value duration. For example, 0.25 will be returned for a crotchet note, 1.0 will be returned for a semibreve note, etc.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValueBritish source,
    int dots
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValueBritish,
    dots As Integer
) As Double
static member Duration :
        source : NoteValueBritish *
        dots : int -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source, dots);
public:
[ExtensionAttribute]
static double Duration(
    NoteValueBritish source,
    int dots
)

Parameters

source
Type: GSF.Media.MusicNoteValueBritish
Source note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.

Return Value

Type: Double
Duration of note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValueBritish. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValue, NoteValue, Int32)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValue, NoteValue, Int32)
Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValue source,
    NoteValue reference,
    int dots
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValue,
    reference As NoteValue,
    dots As Integer
) As Double
static member Duration :
        source : NoteValue *
        reference : NoteValue *
        dots : int -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source, reference, dots);
public:
[ExtensionAttribute]
static double Duration(
    NoteValue source,
    NoteValue reference,
    int dots
)

Parameters

source
Type: GSF.Media.MusicNoteValue
Source note value.
reference
Type: GSF.Media.MusicNoteValue
Reference note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.

Return Value

Type: Double
Duration of note value in terms of specified reference note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValue. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


NoteValueExtensions.Duration Method (NoteValueBritish, NoteValueBritish, Int32)

Grid Solutions Framework NoteValueExtensionsDuration Method (NoteValueBritish, NoteValueBritish, Int32)
Returns source note value duration in terms of given reference note value. For example, if measure size is 3/4 then reference is quarter notes and returned value will be equivalent number of quarter notes for given source note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Duration(
    this NoteValueBritish source,
    NoteValueBritish reference,
    int dots
)
<ExtensionAttribute>
Public Shared Function Duration (
    source As NoteValueBritish,
    reference As NoteValueBritish,
    dots As Integer
) As Double
static member Duration :
        source : NoteValueBritish *
        reference : NoteValueBritish *
        dots : int -> float

GSF.Media.Music.NoteValueExtensions.Duration = function(source, reference, dots);
public:
[ExtensionAttribute]
static double Duration(
    NoteValueBritish source,
    NoteValueBritish reference,
    int dots
)

Parameters

source
Type: GSF.Media.MusicNoteValueBritish
Source note value.
reference
Type: GSF.Media.MusicNoteValueBritish
Reference note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.

Return Value

Type: Double
Duration of note value in terms of specified reference note value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type NoteValueBritish. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

NoteValueExtensions Class
Duration Overload
GSF.Media.Music Namespace


Phrase Class

Grid Solutions Framework Phrase Class
Defines a repeatable series of notes that can be added to a song over and over, for example, the phrase of music defining the chorus.
Inheritance Hierarchy
SystemObject
GSF.Media.MusicPhrase

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Phrase
Public Class Phrase
type Phrase =  class end
GSF.Media.Music.Phrase = function();

Type.createClass(
    'GSF.Media.Music.Phrase');
public ref class Phrase

The Phrase type exposes the following members.

Constructors
 | Name | Description
Public method | Phrase | Constructs a new Phrase.
Top
Methods
 | Name | Description
Public method | AddNotes | Add a series of notes to the phrase.
Public method | AddPhrase | Add another predefined phrase of notes to this phrase.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Notes | Series of notes that define the phrase.
Top
See Also

Reference

GSF.Media.Music Namespace


Phrase Constructor

Grid Solutions Framework Phrase Constructor
Constructs a new Phrase.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Phrase()
Public Sub New
new : unit -> Phrase
GSF.Media.Music.Phrase = function();
public:
Phrase()
See Also

Reference

Phrase Class
GSF.Media.Music Namespace


Phrase Methods

Grid Solutions Framework Phrase Methods

The Phrase type exposes the following members.

Methods
 | Name | Description
Public method | AddNotes | Add a series of notes to the phrase.
Public method | AddPhrase | Add another predefined phrase of notes to this phrase.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Phrase Class
GSF.Media.Music Namespace


Phrase.AddNotes Method

Grid Solutions Framework PhraseAddNotes Method
Add a series of notes to the phrase.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddNotes(
    params Note[] notes
)
Public Sub AddNotes (
    ParamArray notes As Note()
)
member AddNotes :
        notes : Note[] -> unit

function AddNotes(... notes);
public:
void AddNotes(
    ... array<Note^>^ notes
)

Parameters

notes
Type: GSF.Media.MusicNote
Notes to add.
See Also

Reference

Phrase Class
GSF.Media.Music Namespace


Phrase.AddPhrase Method

Grid Solutions Framework PhraseAddPhrase Method
Add another predefined phrase of notes to this phrase.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddPhrase(
    Phrase phrase
)
Public Sub AddPhrase (
    phrase As Phrase
)
member AddPhrase :
        phrase : Phrase -> unit

function AddPhrase(phrase);
public:
void AddPhrase(
    Phrase^ phrase
)

Parameters

phrase
Type: GSF.Media.MusicPhrase
Phrase to add.
See Also

Reference

Phrase Class
GSF.Media.Music Namespace


Phrase Properties

Grid Solutions Framework Phrase Properties

The Phrase type exposes the following members.

Properties
 | Name | Description
Public property | Notes | Series of notes that define the phrase.
Top
See Also

Reference

Phrase Class
GSF.Media.Music Namespace


Phrase.Notes Property

Grid Solutions Framework PhraseNotes Property
Series of notes that define the phrase.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<Note[]> Notes { get; }
Public ReadOnly Property Notes As List(Of Note())
    Get
member Notes : List<Note[]> with get

function get_Notes();

public:
property List<array<Note^>^>^ Notes {
    List<array<Note^>^>^ get ();
}

Property Value

Type: List Note
See Also

Reference

Phrase Class
GSF.Media.Music Namespace


Song Class

Grid Solutions Framework Song Class
Allows creation of a synthesized musical score storing the resultant song in an in-memory wave file for play back or saving music to disk.
Inheritance Hierarchy
SystemObject
GSF.MediaWaveFile
GSF.Media.MusicSong

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Song : WaveFile
Public Class Song
    Inherits WaveFile
type Song =
    class
        inherit WaveFile
    end
GSF.Media.Music.Song = function();

Type.createClass(
    'GSF.Media.Music.Song',
    GSF.Media.WaveFile);
public ref class Song : public WaveFile

The Song type exposes the following members.

Constructors
 | Name | Description
Public method | Song | Creates a new song with a 3/4 measure size, a tempo of 240 quarter-notes per minute, mezzo-forte prevailing dynamic level, using a basic note timbre and standard CD-quality settings for the underlying sound file.
Public method | Song(SampleRate, BitsPerSample, DataChannels) | Creates a new song with a 3/4 measure size, a tempo of 240 quarter-notes per minute, mezzo-forte prevailing dynamic level, using a basic note timbre and the specified audio format settings.
Top
Methods
 | Name | Description
Public method | AddNotes | Add a series of notes to the song.
Public method | AddPhrase | Add a predefined phrase of notes to the song.
Public method | AddRest(Double) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValue) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValueBritish) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValue, Int32) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValueBritish, Int32) | Add a rest for the given length for the current beat.
Public method | AddSample | Add the sample to the wave file. (Inherited from WaveFile.)
Public method | AddSampleBlock | Adds a block of samples in native format to the wave file (e.g., if BitsPerSample = 16, parameters need to be Int16 values). Note that LittleBinaryValue parameter type is implicitly castable to common native types, including floating points. (Inherited from WaveFile.)
Public method | AddSamples | Adds a series of samples, one per channel, to the wave file. (Inherited from WaveFile.)
Public method | CastSample | Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat. (Inherited from WaveFile.)
Public method | Clone | Creates a deeply cloned copy of the WaveFile. (Inherited from WaveFile.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Called when there are no more notes to add.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSampleTypeCode | Determines sample data type code based on defined BitsPerSample and AudioFormat. (Inherited from WaveFile.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Play | Plays the wave file using SoundPlayer. (Inherited from WaveFile.)
Public method | Reverse | Reverses the data samples in the wave file. (Inherited from WaveFile.)
Public method | Save(Stream) | Saves wave file to the specified stream. (Inherited from WaveFile.)
Public method | Save(String) | Saves wave file to the specified file name. (Inherited from WaveFile.)
Public method | SetCrescendoDynamic | Starts crescendo dynamic over the range of the specified number of beats.
Public method | SetDiminuendoDynamic | Starts diminuendo dynamic over the range of the specified number of beats.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AmplitudeScalar | Returns the amplitude scalar for the given bits per sample of the WaveFile (i.e., maximum value for given BitsPerSample). (Inherited from WaveFile.)
Public property | AudioFormat | Gets or sets audio format used by the WaveFile. (Inherited from WaveFile.)
Public property | AudioLength | Gets calculated audio length. (Inherited from WaveFile.)
Public property | BeatTime | Returns the time for a single beat.
Public property | BitsPerSample | Gets or sets number of bits-per-sample in the WaveFile. (Inherited from WaveFile.)
Public property | BlockAlignment | Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time). (Inherited from WaveFile.)
Public property | ByteRate | Gets or sets the byte rate used for buffer estimation. (Inherited from WaveFile.)
Public property | Channels | Gets or sets number of audio channels in the WaveFile. (Inherited from WaveFile.)
Public property | Damping | Gets or sets the default damping function used to lower the sound volume of the added notes over time. This damping function will be used if no other function is specified when adding notes.
Public property | DataChunk | Gets or sets the WaveDataChunk of this WaveFile. (Inherited from WaveFile.)
Public property | Dynamic | Gets or sets the prevailing dynamic (i.e., volume) expressed as percentage in the range of 0 to 1 for the song. Individual notes can choose to override this dynamic.
Public property | ExtraParameters | Gets or sets any extra parameters defined in the format header of the WaveFile. (Inherited from WaveFile.)
Public property | ExtraParametersSize | Gets the size of the ExtraParameters buffer, if defined. (Inherited from WaveFile.)
Public property | FormatChunk | Gets or sets the WaveFormatChunk of this WaveFile. (Inherited from WaveFile.)
Public property | HeaderChunk | Gets or sets the RiffHeaderChunk of this WaveFile. (Inherited from WaveFile.)
Public property | InfoChunk | Gets the ListInfoChunk of this WaveFile. (Inherited from WaveFile.)
Public property | InfoStrings | Gets list of info strings available in this WaveFile if any were available during load; otherwise an empty dictionary. (Inherited from WaveFile.)
Public property | InterNoteDelay | Injects specified rest time, in seconds, between notes.
Public property | MeasureSize | Gets current measure size or defines a new measure size for the song.
Public property | NamedDynamic | Gets or sets the prevailing named dynamic (i.e., volume) for the song. Individual notes can choose to override this dynamic.
Public property | SampleBlocks | Accesses each individual block of sample data indexed by time. (Inherited from WaveFile.)
Public property | SampleRate | Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile. (Inherited from WaveFile.)
Public property | Tempo | Gets current tempo or defines a new tempo for the song.
Public property | Timbre | Gets or sets the default tibre function used to synthesize the sounds of the added notes (i.e., the instrument). This timbre function will be used if no other function is specified when adding notes.
Top
Examples
This example generates a multi-instrument chord:
Copy
using System;
using GSF.Media;
using GSF.Media.Music;

static class Program
{
    static void Main()
    {
        Song song = new Song { Damping = Damping.Linear };

        Console.WriteLine("Generating multi-instrument chord...");

        song.AddNotes
        (
            new Note { Frequency = Note.C4, Value = 4, Timbre = Timbre.EvenHarmonicSeries },
            new Note { Frequency = Note.C4, Value = 4, Timbre = Timbre.Clarinet },
            new Note { Frequency = Note.C4, Value = 4, Timbre = Timbre.Organ },
            new Note { Frequency = Note.E4, Value = 4, Timbre = Timbre.EvenHarmonicSeries },
            new Note { Frequency = Note.E4, Value = 4, Timbre = Timbre.Clarinet },
            new Note { Frequency = Note.E4, Value = 4, Timbre = Timbre.Organ },
            new Note { Frequency = Note.G4, Value = 4, Timbre = Timbre.EvenHarmonicSeries },
            new Note { Frequency = Note.G4, Value = 4, Timbre = Timbre.SimulatedClarinet },
            new Note { Frequency = Note.G4, Value = 4, Timbre = Timbre.SimulatedOrgan }
        );

        song.Finish();

        Console.WriteLine("Saving chord to disk...");
        song.Save("MajorTriad.wav");

        Console.WriteLine("Playing chord...");
        song.Play();

        Console.ReadKey();
    }
}
This example generates a familiar tune, plays the song and saves it to disk:
Copy
// Add reference to System.Speech
using System;
using System.IO;
using GSF.Media;
using GSF.Media.Music;
using System.Speech;
using System.Speech.Synthesis;
using System.Speech.AudioFormat;

static class Program
{
    static void Main()
    {
        Console.WriteLine("Synthesizing speech...");
        WaveFile speech = CreateSynthesizedVoiceOver();

        Console.WriteLine("Synthesizing song at tempo for use with speech...");

        // Define all the notes of jingle bells as a single phrase of music
        Phrase score = CreateJingleBellsScore();

        // Create one song at a slower tempo to help with speech synchronization
        Song speechTempSong = new Song { Tempo = new Tempo(160, NoteValue.Quarter) };

        // Make sure audio specifications for song and speech match
        speechTempSong.SampleRate = speech.SampleRate;
        speechTempSong.BitsPerSample = speech.BitsPerSample;
        speechTempSong.Channels = speech.Channels;

        // Add all the notes to the song
        speechTempSong.AddPhrase(score);
        speechTempSong.Finish();

        Console.WriteLine("Synthesizing song by itself at normal tempo...");

        // Create one song at a slower tempo to help with speech synchronization
        Song normalTempoSong = new Song();

        // Add all the notes to the song
        normalTempoSong.AddPhrase(score);
        normalTempoSong.Finish();

        Console.WriteLine("Saving normal tempo song to disk as \"JingleBells.wav\"...");
        normalTempoSong.Save("JingleBells.wav");

        Console.WriteLine("Combining speech with song...");
        WaveFile combined = WaveFile.Combine(speech, speechTempSong);

        Console.WriteLine("Saving combined work to disk as \"SingingComputer.wav\"...");
        combined.Save("SingingComputer.wav");

        Console.WriteLine("Playing combined work...");
        combined.Play();

        Console.ReadKey();
    }

    private static WaveFile CreateSynthesizedVoiceOver()
    {
        SpeechSynthesizer synthesizer = new SpeechSynthesizer();
        MemoryStream speechStream = new MemoryStream();
        PromptBuilder songText = new PromptBuilder();

        synthesizer.SelectVoice("Microsoft Sam");
        synthesizer.Rate = 5; // Range = -10 to +10
        synthesizer.SetOutputToWaveStream(speechStream);

        songText.AppendText("Jin - gull bells!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(3000000));
        songText.AppendText("Jin - gull bells!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(3000000));
        songText.AppendText("Jin - gull - all, theuh - way!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(12000000));
        songText.AppendText("Oh - what - fun!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(1000000));
        songText.AppendText("It - is!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("To - ride!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("a - one - horse!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("Open!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("Sleigh!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(1000000));
        songText.AppendText("A!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(2500000));
        songText.AppendText("Jin - gull bells!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(3000000));
        songText.AppendText("Jin - gull bells!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(3000000));
        songText.AppendText("Jin - gull - all, theuh - way!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(12000000));
        songText.AppendText("Oh - what - fun!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(1000000));
        songText.AppendText("It - is!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("To - ride!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("a - one - horse!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("Open!", PromptEmphasis.Strong);
        songText.AppendBreak(new TimeSpan(500000));
        songText.AppendText("Sleigh.", PromptEmphasis.Reduced);

        synthesizer.Speak(songText);
        speechStream.Position = 0;
        return WaveFile.Load(speechStream);
    }

    private static Phrase CreateJingleBellsScore()
    {
        Phrase score = new Phrase();
        Phrase passage = new Phrase();

        // Define the repeating phrase of the song
        passage.AddNotes
        (
            new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter },
            new Note { Frequency = Note.C3, NamedValue = NoteValue.Whole }
        );
        passage.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Half });

        passage.AddNotes
        (
            new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter },
            new Note { Frequency = Note.G3, NamedValue = NoteValue.Whole }
        );
        passage.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Half });

        passage.AddNotes
        (
            new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter },
            new Note { Frequency = Note.C3, NamedValue = NoteValue.Whole }
        );
        passage.AddNotes(new Note { Frequency = Note.D4, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.G3, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.A3, NamedValue = NoteValue.Quarter });

        passage.AddNotes
        (
            new Note { Frequency = Note.B3, NamedValue = NoteValue.Whole },
            new Note { Frequency = Note.G3, NamedValue = NoteValue.Whole }
        );

        passage.AddNotes
        (
            new Note { Frequency = Note.C4, NamedValue = NoteValue.Quarter },
            new Note { Frequency = Note.D3, NamedValue = NoteValue.Whole }
        );
        passage.AddNotes(new Note { Frequency = Note.C4, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.C4, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.C4, NamedValue = NoteValue.Quarter });

        passage.AddNotes
        (
            new Note { Frequency = Note.C4, NamedValue = NoteValue.Quarter },
            new Note { Frequency = Note.G3, NamedValue = NoteValue.Whole }
        );
        passage.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter });
        passage.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter });

        score.AddPhrase(passage);

        score.AddNotes
        (
            new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter },
            new Note { Frequency = Note.F3S, NamedValue = NoteValue.Whole }
        );
        score.AddNotes(new Note { Frequency = Note.A3, NamedValue = NoteValue.Quarter });
        score.AddNotes(new Note { Frequency = Note.A3, NamedValue = NoteValue.Quarter });
        score.AddNotes(new Note { Frequency = Note.B3, NamedValue = NoteValue.Quarter });

        score.AddNotes
        (
            new Note { Frequency = Note.A3, NamedValue = NoteValue.Half },
            new Note { Frequency = Note.G3, NamedValue = NoteValue.Whole }
        );
        score.AddNotes(new Note { Frequency = Note.D4, NamedValue = NoteValue.Half });

        score.AddPhrase(passage);

        score.AddNotes
        (
            new Note { Frequency = Note.D4, NamedValue = NoteValue.Quarter },
            new Note { Frequency = Note.G3, NamedValue = NoteValue.Whole },
            new Note { Frequency = Note.F3, NamedValue = NoteValue.Whole }
        );
        score.AddNotes(new Note { Frequency = Note.D4, NamedValue = NoteValue.Quarter });
        score.AddNotes(new Note { Frequency = Note.C4, NamedValue = NoteValue.Quarter });
        score.AddNotes(new Note { Frequency = Note.A3, NamedValue = NoteValue.Quarter });

        score.AddNotes
        (
            new Note { Frequency = Note.G3, NamedValue = NoteValue.Whole },
            new Note { Frequency = Note.E3, NamedValue = NoteValue.Whole }
        );

        return score;
    }
}
See Also

Reference

GSF.Media.Music Namespace


Song Constructor

Grid Solutions Framework Song Constructor
Overload List
 | Name | Description
Public method | Song | Creates a new song with a 3/4 measure size, a tempo of 240 quarter-notes per minute, mezzo-forte prevailing dynamic level, using a basic note timbre and standard CD-quality settings for the underlying sound file.
Public method | Song(SampleRate, BitsPerSample, DataChannels) | Creates a new song with a 3/4 measure size, a tempo of 240 quarter-notes per minute, mezzo-forte prevailing dynamic level, using a basic note timbre and the specified audio format settings.
Top
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song Constructor

Grid Solutions Framework Song Constructor
Creates a new song with a 3/4 measure size, a tempo of 240 quarter-notes per minute, mezzo-forte prevailing dynamic level, using a basic note timbre and standard CD-quality settings for the underlying sound file.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Song()
Public Sub New
new : unit -> Song
GSF.Media.Music.Song = function();
public:
Song()
See Also

Reference

Song Class
Song Overload
GSF.Media.Music Namespace


Song Constructor (SampleRate, BitsPerSample, DataChannels)

Grid Solutions Framework Song Constructor (SampleRate, BitsPerSample, DataChannels)
Creates a new song with a 3/4 measure size, a tempo of 240 quarter-notes per minute, mezzo-forte prevailing dynamic level, using a basic note timbre and the specified audio format settings.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Song(
    SampleRate sampleRate,
    BitsPerSample bitsPerSample,
    DataChannels channels
)
Public Sub New (
    sampleRate As SampleRate,
    bitsPerSample As BitsPerSample,
    channels As DataChannels
)
new :
        sampleRate : SampleRate *
        bitsPerSample : BitsPerSample *
        channels : DataChannels -> Song
GSF.Media.Music.Song = function(sampleRate, bitsPerSample, channels);
public:
Song(
    SampleRate sampleRate,
    BitsPerSample bitsPerSample,
    DataChannels channels
)

Parameters

sampleRate
Type: GSF.MediaSampleRate
Desired sample rate
bitsPerSample
Type: GSF.MediaBitsPerSample
Desired bits-per-sample
channels
Type: GSF.MediaDataChannels
Desired data channels
See Also

Reference

Song Class
Song Overload
GSF.Media.Music Namespace


Song Methods

Grid Solutions Framework Song Methods

The Song type exposes the following members.

Methods
 | Name | Description
Public method | AddNotes | Add a series of notes to the song.
Public method | AddPhrase | Add a predefined phrase of notes to the song.
Public method | AddRest(Double) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValue) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValueBritish) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValue, Int32) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValueBritish, Int32) | Add a rest for the given length for the current beat.
Public method | AddSample | Add the sample to the wave file. (Inherited from WaveFile.)
Public method | AddSampleBlock | Adds a block of samples in native format to the wave file (e.g., if BitsPerSample = 16, parameters need to be Int16 values). Note that LittleBinaryValue parameter type is implicitly castable to common native types, including floating points. (Inherited from WaveFile.)
Public method | AddSamples | Adds a series of samples, one per channel, to the wave file. (Inherited from WaveFile.)
Public method | CastSample | Casts sample value to its equivalent native type based on defined BitsPerSample and AudioFormat. (Inherited from WaveFile.)
Public method | Clone | Creates a deeply cloned copy of the WaveFile. (Inherited from WaveFile.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Finish | Called when there are no more notes to add.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSampleTypeCode | Determines sample data type code based on defined BitsPerSample and AudioFormat. (Inherited from WaveFile.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Play | Plays the wave file using SoundPlayer. (Inherited from WaveFile.)
Public method | Reverse | Reverses the data samples in the wave file. (Inherited from WaveFile.)
Public method | Save(Stream) | Saves wave file to the specified stream. (Inherited from WaveFile.)
Public method | Save(String) | Saves wave file to the specified file name. (Inherited from WaveFile.)
Public method | SetCrescendoDynamic | Starts crescendo dynamic over the range of the specified number of beats.
Public method | SetDiminuendoDynamic | Starts diminuendo dynamic over the range of the specified number of beats.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.AddNotes Method

Grid Solutions Framework SongAddNotes Method
Add a series of notes to the song.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddNotes(
    params Note[] notes
)
Public Sub AddNotes (
    ParamArray notes As Note()
)
member AddNotes :
        notes : Note[] -> unit

function AddNotes(... notes);
public:
void AddNotes(
    ... array<Note^>^ notes
)

Parameters

notes
Type: GSF.Media.MusicNote
Notes to add.
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.AddPhrase Method

Grid Solutions Framework SongAddPhrase Method
Add a predefined phrase of notes to the song.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddPhrase(
    Phrase phrase
)
Public Sub AddPhrase (
    phrase As Phrase
)
member AddPhrase :
        phrase : Phrase -> unit

function AddPhrase(phrase);
public:
void AddPhrase(
    Phrase^ phrase
)

Parameters

phrase
Type: GSF.Media.MusicPhrase
Phrase to add.
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.AddRest Method

Grid Solutions Framework SongAddRest Method
Overload List
 | Name | Description
Public method | AddRest(Double) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValue) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValueBritish) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValue, Int32) | Add a rest for the given length for the current beat.
Public method | AddRest(NoteValueBritish, Int32) | Add a rest for the given length for the current beat.
Top
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.AddRest Method (Double)

Grid Solutions Framework SongAddRest Method (Double)
Add a rest for the given length for the current beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddRest(
    double restLength
)
Public Sub AddRest (
    restLength As Double
)
member AddRest :
        restLength : float -> unit

function AddRest(restLength);
public:
void AddRest(
    double restLength
)

Parameters

restLength
Type: SystemDouble
Duration of wait specified as a note value.
See Also

Reference

Song Class
AddRest Overload
GSF.Media.Music Namespace


Song.AddRest Method (NoteValue)

Grid Solutions Framework SongAddRest Method (NoteValue)
Add a rest for the given length for the current beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddRest(
    NoteValue restLength
)
Public Sub AddRest (
    restLength As NoteValue
)
member AddRest :
        restLength : NoteValue -> unit

function AddRest(restLength);
public:
void AddRest(
    NoteValue restLength
)

Parameters

restLength
Type: GSF.Media.MusicNoteValue
Duration of wait specified as a note value.
See Also

Reference

Song Class
AddRest Overload
GSF.Media.Music Namespace


Song.AddRest Method (NoteValueBritish)

Grid Solutions Framework SongAddRest Method (NoteValueBritish)
Add a rest for the given length for the current beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddRest(
    NoteValueBritish restLength
)
Public Sub AddRest (
    restLength As NoteValueBritish
)
member AddRest :
        restLength : NoteValueBritish -> unit

function AddRest(restLength);
public:
void AddRest(
    NoteValueBritish restLength
)

Parameters

restLength
Type: GSF.Media.MusicNoteValueBritish
Duration of wait specified as a note value.
See Also

Reference

Song Class
AddRest Overload
GSF.Media.Music Namespace


Song.AddRest Method (NoteValue, Int32)

Grid Solutions Framework SongAddRest Method (NoteValue, Int32)
Add a rest for the given length for the current beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddRest(
    NoteValue restLength,
    int dots
)
Public Sub AddRest (
    restLength As NoteValue,
    dots As Integer
)
member AddRest :
        restLength : NoteValue *
        dots : int -> unit

function AddRest(restLength, dots);
public:
void AddRest(
    NoteValue restLength,
    int dots
)

Parameters

restLength
Type: GSF.Media.MusicNoteValue
Duration of wait specified as a note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.
See Also

Reference

Song Class
AddRest Overload
GSF.Media.Music Namespace


Song.AddRest Method (NoteValueBritish, Int32)

Grid Solutions Framework SongAddRest Method (NoteValueBritish, Int32)
Add a rest for the given length for the current beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddRest(
    NoteValueBritish restLength,
    int dots
)
Public Sub AddRest (
    restLength As NoteValueBritish,
    dots As Integer
)
member AddRest :
        restLength : NoteValueBritish *
        dots : int -> unit

function AddRest(restLength, dots);
public:
void AddRest(
    NoteValueBritish restLength,
    int dots
)

Parameters

restLength
Type: GSF.Media.MusicNoteValueBritish
Duration of wait specified as a note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.
See Also

Reference

Song Class
AddRest Overload
GSF.Media.Music Namespace


Song.Finish Method

Grid Solutions Framework SongFinish Method
Called when there are no more notes to add.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Finish()
Public Sub Finish
member Finish : unit -> unit

function Finish();
public:
void Finish()
Remarks
This flushes the remaining queued notes into the song allowing them to run their remaining time.
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.SetCrescendoDynamic Method

Grid Solutions Framework SongSetCrescendoDynamic Method
Starts crescendo dynamic over the range of the specified number of beats.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCrescendoDynamic(
    int totalBeats,
    Dynamic endDynamic
)
Public Sub SetCrescendoDynamic (
    totalBeats As Integer,
    endDynamic As Dynamic
)
member SetCrescendoDynamic :
        totalBeats : int *
        endDynamic : Dynamic -> unit

function SetCrescendoDynamic(totalBeats, endDynamic);
public:
void SetCrescendoDynamic(
    int totalBeats,
    Dynamic endDynamic
)

Parameters

totalBeats
Type: SystemInt32
Total number of beats overwhich to gradually increase volume.
endDynamic
Type: GSF.Media.MusicDynamic
Desired volume when crescendo is complete.
Remarks
Current Dynamic is the starting dynamic which should be less than endDynamic.
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.SetDiminuendoDynamic Method

Grid Solutions Framework SongSetDiminuendoDynamic Method
Starts diminuendo dynamic over the range of the specified number of beats.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetDiminuendoDynamic(
    int totalBeats,
    Dynamic endDynamic
)
Public Sub SetDiminuendoDynamic (
    totalBeats As Integer,
    endDynamic As Dynamic
)
member SetDiminuendoDynamic :
        totalBeats : int *
        endDynamic : Dynamic -> unit

function SetDiminuendoDynamic(totalBeats, endDynamic);
public:
void SetDiminuendoDynamic(
    int totalBeats,
    Dynamic endDynamic
)

Parameters

totalBeats
Type: SystemInt32
Total number of beats overwhich to gradually decrease volume.
endDynamic
Type: GSF.Media.MusicDynamic
Desired volume when diminuendo is complete.
Remarks
Current Dynamic is the starting dynamic which should be greater than endDynamic.
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song Properties

Grid Solutions Framework Song Properties

The Song type exposes the following members.

Properties
 | Name | Description
Public property | AmplitudeScalar | Returns the amplitude scalar for the given bits per sample of the WaveFile (i.e., maximum value for given BitsPerSample). (Inherited from WaveFile.)
Public property | AudioFormat | Gets or sets audio format used by the WaveFile. (Inherited from WaveFile.)
Public property | AudioLength | Gets calculated audio length. (Inherited from WaveFile.)
Public property | BeatTime | Returns the time for a single beat.
Public property | BitsPerSample | Gets or sets number of bits-per-sample in the WaveFile. (Inherited from WaveFile.)
Public property | BlockAlignment | Gets or sets the block size of a complete sample of data (i.e., samples for all channels of data at one instant in time). (Inherited from WaveFile.)
Public property | ByteRate | Gets or sets the byte rate used for buffer estimation. (Inherited from WaveFile.)
Public property | Channels | Gets or sets number of audio channels in the WaveFile. (Inherited from WaveFile.)
Public property | Damping | Gets or sets the default damping function used to lower the sound volume of the added notes over time. This damping function will be used if no other function is specified when adding notes.
Public property | DataChunk | Gets or sets the WaveDataChunk of this WaveFile. (Inherited from WaveFile.)
Public property | Dynamic | Gets or sets the prevailing dynamic (i.e., volume) expressed as percentage in the range of 0 to 1 for the song. Individual notes can choose to override this dynamic.
Public property | ExtraParameters | Gets or sets any extra parameters defined in the format header of the WaveFile. (Inherited from WaveFile.)
Public property | ExtraParametersSize | Gets the size of the ExtraParameters buffer, if defined. (Inherited from WaveFile.)
Public property | FormatChunk | Gets or sets the WaveFormatChunk of this WaveFile. (Inherited from WaveFile.)
Public property | HeaderChunk | Gets or sets the RiffHeaderChunk of this WaveFile. (Inherited from WaveFile.)
Public property | InfoChunk | Gets the ListInfoChunk of this WaveFile. (Inherited from WaveFile.)
Public property | InfoStrings | Gets list of info strings available in this WaveFile if any were available during load; otherwise an empty dictionary. (Inherited from WaveFile.)
Public property | InterNoteDelay | Injects specified rest time, in seconds, between notes.
Public property | MeasureSize | Gets current measure size or defines a new measure size for the song.
Public property | NamedDynamic | Gets or sets the prevailing named dynamic (i.e., volume) for the song. Individual notes can choose to override this dynamic.
Public property | SampleBlocks | Accesses each individual block of sample data indexed by time. (Inherited from WaveFile.)
Public property | SampleRate | Gets or sets the sample rate (i.e., the number of samples per second) defined in the WaveFile. (Inherited from WaveFile.)
Public property | Tempo | Gets current tempo or defines a new tempo for the song.
Public property | Timbre | Gets or sets the default tibre function used to synthesize the sounds of the added notes (i.e., the instrument). This timbre function will be used if no other function is specified when adding notes.
Top
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.BeatTime Property

Grid Solutions Framework SongBeatTime Property
Returns the time for a single beat.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double BeatTime { get; }
Public ReadOnly Property BeatTime As Double
    Get
member BeatTime : float with get

function get_BeatTime();

public:
property double BeatTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.Damping Property

Grid Solutions Framework SongDamping Property
Gets or sets the default damping function used to lower the sound volume of the added notes over time. This damping function will be used if no other function is specified when adding notes.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DampingFunction Damping { get; set; }
Public Property Damping As DampingFunction
    Get
    Set
member Damping : DampingFunction with get, set

function get_Damping();
function set_Damping(value);
public:
property DampingFunction^ Damping {
    DampingFunction^ get ();
    void set (DampingFunction^ value);
}

Property Value

Type: DampingFunction
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.Dynamic Property

Grid Solutions Framework SongDynamic Property
Gets or sets the prevailing dynamic (i.e., volume) expressed as percentage in the range of 0 to 1 for the song. Individual notes can choose to override this dynamic.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Dynamic { get; set; }
Public Property Dynamic As Double
    Get
    Set
member Dynamic : float with get, set

function get_Dynamic();
function set_Dynamic(value);
public:
property double Dynamic {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value must be expressed as a fractional percentage between zero and one.
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.InterNoteDelay Property

Grid Solutions Framework SongInterNoteDelay Property
Injects specified rest time, in seconds, between notes.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double InterNoteDelay { get; set; }
Public Property InterNoteDelay As Double
    Get
    Set
member InterNoteDelay : float with get, set

function get_InterNoteDelay();
function set_InterNoteDelay(value);
public:
property double InterNoteDelay {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.MeasureSize Property

Grid Solutions Framework SongMeasureSize Property
Gets current measure size or defines a new measure size for the song.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MeasureSize MeasureSize { get; set; }
Public Property MeasureSize As MeasureSize
    Get
    Set
member MeasureSize : MeasureSize with get, set

function get_MeasureSize();
function set_MeasureSize(value);
public:
property MeasureSize^ MeasureSize {
    MeasureSize^ get ();
    void set (MeasureSize^ value);
}

Property Value

Type: MeasureSize
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.NamedDynamic Property

Grid Solutions Framework SongNamedDynamic Property
Gets or sets the prevailing named dynamic (i.e., volume) for the song. Individual notes can choose to override this dynamic.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dynamic NamedDynamic { get; set; }
Public Property NamedDynamic As Dynamic
    Get
    Set
member NamedDynamic : Dynamic with get, set

function get_NamedDynamic();
function set_NamedDynamic(value);
public:
property Dynamic NamedDynamic {
    Dynamic get ();
    void set (Dynamic value);
}

Property Value

Type: Dynamic
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.Tempo Property

Grid Solutions Framework SongTempo Property
Gets current tempo or defines a new tempo for the song.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Tempo Tempo { get; set; }
Public Property Tempo As Tempo
    Get
    Set
member Tempo : Tempo with get, set

function get_Tempo();
function set_Tempo(value);
public:
property Tempo^ Tempo {
    Tempo^ get ();
    void set (Tempo^ value);
}

Property Value

Type: Tempo
See Also

Reference

Song Class
GSF.Media.Music Namespace


Song.Timbre Property

Grid Solutions Framework SongTimbre Property
Gets or sets the default tibre function used to synthesize the sounds of the added notes (i.e., the instrument). This timbre function will be used if no other function is specified when adding notes.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimbreFunction Timbre { get; set; }
Public Property Timbre As TimbreFunction
    Get
    Set
member Timbre : TimbreFunction with get, set

function get_Timbre();
function set_Timbre(value);
public:
property TimbreFunction^ Timbre {
    TimbreFunction^ get ();
    void set (TimbreFunction^ value);
}

Property Value

Type: TimbreFunction
See Also

Reference

Song Class
GSF.Media.Music Namespace


Tempo Class

Grid Solutions Framework Tempo Class
Defines the tempo of song as the total number of note values in one minute.
Inheritance Hierarchy
SystemObject
GSF.Media.MusicTempo

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Tempo
Public Class Tempo
type Tempo =  class end
GSF.Media.Music.Tempo = function();

Type.createClass(
    'GSF.Media.Music.Tempo');
public ref class Tempo

The Tempo type exposes the following members.

Constructors
 | Name | Description
Public method | Tempo(Int32, NoteValue) | Contructs a new Tempo object.
Public method | Tempo(Int32, NoteValueBritish) | Contructs a new Tempo object.
Public method | Tempo(Int32, Double) | Contructs a new Tempo object.
Top
Methods
 | Name | Description
Public method | CalculateNoteValueTime(Double) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.
Public method | CalculateNoteValueTime(NoteValue, Int32) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.
Public method | CalculateNoteValueTime(NoteValueBritish, Int32) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 crotchets per minute, then each crotchet would last a half-second.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | NamedNoteValue | Get or sets the note value, expressed in American form, representing the length of the note.
Public property | NamedNoteValueBritish | Get or sets the note value, expressed in British form, representing the length of the note.
Public property | NoteValue | Returns relative value for reference note value. For example, if tempo is M.M. 120 quarter-notes per minute, then time is referenced in quarter-notes and this function would return 0.25.
Public property | NoteValueTime | Total time, in seconds, for reference note value. For example, if tempo is M.M. 120 quarter-notes per minute, then time is referenced in quarter-notes and this function would return 0.5 seconds.
Public property | TotalNoteValues | Total number of reference note values that occur in one minute - thus defining the tempo for a score.
Top
Remarks
This defined tempo of the music assigns absolute durations to all the note values within a score.
See Also

Reference

GSF.Media.Music Namespace


Tempo Constructor

Grid Solutions Framework Tempo Constructor
Overload List
 | Name | Description
Public method | Tempo(Int32, NoteValue) | Contructs a new Tempo object.
Public method | Tempo(Int32, NoteValueBritish) | Contructs a new Tempo object.
Public method | Tempo(Int32, Double) | Contructs a new Tempo object.
Top
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo Constructor (Int32, NoteValue)

Grid Solutions Framework Tempo Constructor (Int32, NoteValue)
Contructs a new Tempo object.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Tempo(
    int totalNoteValues,
    NoteValue noteValue
)
Public Sub New (
    totalNoteValues As Integer,
    noteValue As NoteValue
)
new :
        totalNoteValues : int *
        noteValue : NoteValue -> Tempo
GSF.Media.Music.Tempo = function(totalNoteValues, noteValue);
public:
Tempo(
    int totalNoteValues,
    NoteValue noteValue
)

Parameters

totalNoteValues
Type: SystemInt32
Total note values for Tempo.
noteValue
Type: GSF.Media.MusicNoteValue
Named note value used for Tempo.
See Also

Reference

Tempo Class
Tempo Overload
GSF.Media.Music Namespace


Tempo Constructor (Int32, NoteValueBritish)

Grid Solutions Framework Tempo Constructor (Int32, NoteValueBritish)
Contructs a new Tempo object.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Tempo(
    int totalNoteValues,
    NoteValueBritish noteValue
)
Public Sub New (
    totalNoteValues As Integer,
    noteValue As NoteValueBritish
)
new :
        totalNoteValues : int *
        noteValue : NoteValueBritish -> Tempo
GSF.Media.Music.Tempo = function(totalNoteValues, noteValue);
public:
Tempo(
    int totalNoteValues,
    NoteValueBritish noteValue
)

Parameters

totalNoteValues
Type: SystemInt32
A Int32 indicating the total note values.
noteValue
Type: GSF.Media.MusicNoteValueBritish
Named note value used for Tempo.
See Also

Reference

Tempo Class
Tempo Overload
GSF.Media.Music Namespace


Tempo Constructor (Int32, Double)

Grid Solutions Framework Tempo Constructor (Int32, Double)
Contructs a new Tempo object.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Tempo(
    int totalNoteValues,
    double noteValue
)
Public Sub New (
    totalNoteValues As Integer,
    noteValue As Double
)
new :
        totalNoteValues : int *
        noteValue : float -> Tempo
GSF.Media.Music.Tempo = function(totalNoteValues, noteValue);
public:
Tempo(
    int totalNoteValues,
    double noteValue
)

Parameters

totalNoteValues
Type: SystemInt32
Total note values for Tempo.
noteValue
Type: SystemDouble
Note value used for Tempo.
See Also

Reference

Tempo Class
Tempo Overload
GSF.Media.Music Namespace


Tempo Methods

Grid Solutions Framework Tempo Methods

The Tempo type exposes the following members.

Methods
 | Name | Description
Public method | CalculateNoteValueTime(Double) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.
Public method | CalculateNoteValueTime(NoteValue, Int32) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.
Public method | CalculateNoteValueTime(NoteValueBritish, Int32) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 crotchets per minute, then each crotchet would last a half-second.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo.CalculateNoteValueTime Method

Grid Solutions Framework TempoCalculateNoteValueTime Method
Overload List
 | Name | Description
Public method | CalculateNoteValueTime(Double) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.
Public method | CalculateNoteValueTime(NoteValue, Int32) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.
Public method | CalculateNoteValueTime(NoteValueBritish, Int32) | Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 crotchets per minute, then each crotchet would last a half-second.
Top
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo.CalculateNoteValueTime Method (Double)

Grid Solutions Framework TempoCalculateNoteValueTime Method (Double)
Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculateNoteValueTime(
    double value
)
Public Function CalculateNoteValueTime (
    value As Double
) As Double
member CalculateNoteValueTime :
        value : float -> float

function CalculateNoteValueTime(value);
public:
double CalculateNoteValueTime(
    double value
)

Parameters

value
Type: SystemDouble
Relative value of note.

Return Value

Type: Double
Actual duration of note value in seconds.
See Also

Reference

Tempo Class
CalculateNoteValueTime Overload
GSF.Media.Music Namespace


Tempo.CalculateNoteValueTime Method (NoteValue, Int32)

Grid Solutions Framework TempoCalculateNoteValueTime Method (NoteValue, Int32)
Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 quarter-notes per minute, then each quarter-note would last a half-second.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculateNoteValueTime(
    NoteValue source,
    int dots
)
Public Function CalculateNoteValueTime (
    source As NoteValue,
    dots As Integer
) As Double
member CalculateNoteValueTime :
        source : NoteValue *
        dots : int -> float

function CalculateNoteValueTime(source, dots);
public:
double CalculateNoteValueTime(
    NoteValue source,
    int dots
)

Parameters

source
Type: GSF.Media.MusicNoteValue
Source note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.

Return Value

Type: Double
Actual duration of note value in seconds.
See Also

Reference

Tempo Class
CalculateNoteValueTime Overload
GSF.Media.Music Namespace


Tempo.CalculateNoteValueTime Method (NoteValueBritish, Int32)

Grid Solutions Framework TempoCalculateNoteValueTime Method (NoteValueBritish, Int32)
Calculates the actual time duration, in seconds, for the given tempo that the specified source note value will last. For example, if tempo is M.M. 120 crotchets per minute, then each crotchet would last a half-second.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculateNoteValueTime(
    NoteValueBritish source,
    int dots
)
Public Function CalculateNoteValueTime (
    source As NoteValueBritish,
    dots As Integer
) As Double
member CalculateNoteValueTime :
        source : NoteValueBritish *
        dots : int -> float

function CalculateNoteValueTime(source, dots);
public:
double CalculateNoteValueTime(
    NoteValueBritish source,
    int dots
)

Parameters

source
Type: GSF.Media.MusicNoteValueBritish
Source note value.
dots
Type: SystemInt32
Total dotted note length extensions to apply.

Return Value

Type: Double
Actual duration of note value in seconds.
See Also

Reference

Tempo Class
CalculateNoteValueTime Overload
GSF.Media.Music Namespace


Tempo Properties

Grid Solutions Framework Tempo Properties

The Tempo type exposes the following members.

Properties
 | Name | Description
Public property | NamedNoteValue | Get or sets the note value, expressed in American form, representing the length of the note.
Public property | NamedNoteValueBritish | Get or sets the note value, expressed in British form, representing the length of the note.
Public property | NoteValue | Returns relative value for reference note value. For example, if tempo is M.M. 120 quarter-notes per minute, then time is referenced in quarter-notes and this function would return 0.25.
Public property | NoteValueTime | Total time, in seconds, for reference note value. For example, if tempo is M.M. 120 quarter-notes per minute, then time is referenced in quarter-notes and this function would return 0.5 seconds.
Public property | TotalNoteValues | Total number of reference note values that occur in one minute - thus defining the tempo for a score.
Top
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo.NamedNoteValue Property

Grid Solutions Framework TempoNamedNoteValue Property
Get or sets the note value, expressed in American form, representing the length of the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NoteValue NamedNoteValue { get; set; }
Public Property NamedNoteValue As NoteValue
    Get
    Set
member NamedNoteValue : NoteValue with get, set

function get_NamedNoteValue();
function set_NamedNoteValue(value);
public:
property NoteValue NamedNoteValue {
    NoteValue get ();
    void set (NoteValue value);
}

Property Value

Type: NoteValue
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo.NamedNoteValueBritish Property

Grid Solutions Framework TempoNamedNoteValueBritish Property
Get or sets the note value, expressed in British form, representing the length of the note.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NoteValueBritish NamedNoteValueBritish { get; set; }
Public Property NamedNoteValueBritish As NoteValueBritish
    Get
    Set
member NamedNoteValueBritish : NoteValueBritish with get, set

function get_NamedNoteValueBritish();
function set_NamedNoteValueBritish(value);
public:
property NoteValueBritish NamedNoteValueBritish {
    NoteValueBritish get ();
    void set (NoteValueBritish value);
}

Property Value

Type: NoteValueBritish
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo.NoteValue Property

Grid Solutions Framework TempoNoteValue Property
Returns relative value for reference note value. For example, if tempo is M.M. 120 quarter-notes per minute, then time is referenced in quarter-notes and this function would return 0.25.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double NoteValue { get; set; }
Public Property NoteValue As Double
    Get
    Set
member NoteValue : float with get, set

function get_NoteValue();
function set_NoteValue(value);
public:
property double NoteValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo.NoteValueTime Property

Grid Solutions Framework TempoNoteValueTime Property
Total time, in seconds, for reference note value. For example, if tempo is M.M. 120 quarter-notes per minute, then time is referenced in quarter-notes and this function would return 0.5 seconds.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double NoteValueTime { get; }
Public ReadOnly Property NoteValueTime As Double
    Get
member NoteValueTime : float with get

function get_NoteValueTime();

public:
property double NoteValueTime {
    double get ();
}

Property Value

Type: Double
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Tempo.TotalNoteValues Property

Grid Solutions Framework TempoTotalNoteValues Property
Total number of reference note values that occur in one minute - thus defining the tempo for a score.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TotalNoteValues { get; set; }
Public Property TotalNoteValues As Integer
    Get
    Set
member TotalNoteValues : int with get, set

function get_TotalNoteValues();
function set_TotalNoteValues(value);
public:
property int TotalNoteValues {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Tempo Class
GSF.Media.Music Namespace


Timbre Class

Grid Solutions Framework Timbre Class
Defines a few timbre functions.
Inheritance Hierarchy
SystemObject
GSF.Media.MusicTimbre

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Timbre
Public NotInheritable Class Timbre
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Timbre =  class end
GSF.Media.Music.Timbre = function();

Type.createClass(
    'GSF.Media.Music.Timbre');
public ref class Timbre abstract sealed

The Timbre type exposes the following members.

Methods
Name | Description
AcousticGuitar | Generates a simulated acoustic guitar note for the given frequency and time.
AngularFrequency | Computes the angular frequency for the given time.
BasicNote | Generates a basic note for the given frequency and time.
BassGuitar | Generates a simulated bass guitar note for the given frequency and time.
Bell | Generates a simulated bell note for the given frequency and time.
BigBell | Generates a simulated big bell note for the given frequency and time.
ChimeBell | Generates a simulated chime bell note for the given frequency and time.
Clarinet | Generates a simulated clarinet note for the given frequency and time.
ElectricGuitar | Generates a simulated electric guitar note for the given frequency and time.
EvenHarmonicSeries | Generates an even harmonic series for the given frequency and time.
Flute | Generates a simulated flute note for the given frequency and time.
OddHarmonicSeries | Generates an odd harmonic series for the given frequency and time.
Organ | Generates a simulated organ note for the given frequency and time.
Piano | Generates a simulated piano note for the given frequency and time.
PureTone | Generates a pure tone for the given frequency and time.
Xylophone | Generates a simulated xylophone note for the given frequency and time.
Top
See Also

Reference

GSF.Media.Music Namespace


Timbre Methods

Grid Solutions Framework Timbre Methods

The Timbre type exposes the following members.

Methods
Name | Description
AcousticGuitar | Generates a simulated acoustic guitar note for the given frequency and time.
AngularFrequency | Computes the angular frequency for the given time.
BasicNote | Generates a basic note for the given frequency and time.
BassGuitar | Generates a simulated bass guitar note for the given frequency and time.
Bell | Generates a simulated bell note for the given frequency and time.
BigBell | Generates a simulated big bell note for the given frequency and time.
ChimeBell | Generates a simulated chime bell note for the given frequency and time.
Clarinet | Generates a simulated clarinet note for the given frequency and time.
ElectricGuitar | Generates a simulated electric guitar note for the given frequency and time.
EvenHarmonicSeries | Generates an even harmonic series for the given frequency and time.
Flute | Generates a simulated flute note for the given frequency and time.
OddHarmonicSeries | Generates an odd harmonic series for the given frequency and time.
Organ | Generates a simulated organ note for the given frequency and time.
Piano | Generates a simulated piano note for the given frequency and time.
PureTone | Generates a pure tone for the given frequency and time.
Xylophone | Generates a simulated xylophone note for the given frequency and time.
Top
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.AcousticGuitar Method

Grid Solutions Framework TimbreAcousticGuitar Method
Generates a simulated acoustic guitar note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double AcousticGuitar(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function AcousticGuitar (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member AcousticGuitar :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.AcousticGuitar = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double AcousticGuitar(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a acoustic simulated guitar note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated acoustic guitar note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.AngularFrequency Method

Grid Solutions Framework TimbreAngularFrequency Method
Computes the angular frequency for the given time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double AngularFrequency(
    double frequency,
    long sampleIndex,
    double sampleRate
)
Public Shared Function AngularFrequency (
    frequency As Double,
    sampleIndex As Long,
    sampleRate As Double
) As Double
static member AngularFrequency :
        frequency : float *
        sampleIndex : int64 *
        sampleRate : float -> float

GSF.Media.Music.Timbre.AngularFrequency = function(frequency, sampleIndex, sampleRate);
public:
static double AngularFrequency(
    double frequency,
    long long sampleIndex,
    double sampleRate
)

Parameters

frequency
Type: SystemDouble
Frequency in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
sampleRate
Type: SystemDouble
Number of samples per second.

Return Value

Type: Double
The computed angular frequency in radians per second at given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.BasicNote Method

Grid Solutions Framework TimbreBasicNote Method
Generates a basic note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double BasicNote(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function BasicNote (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member BasicNote :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.BasicNote = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double BasicNote(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a basic note at the given time.
Remarks

This method computes an amplitude representing the acoustic pressure of a basic note of the given frequency for the given time.

This timbre algorithm combines the simulated piano and the odd harmonic series algoriths to produce a pleasant sounding note.

See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.BassGuitar Method

Grid Solutions Framework TimbreBassGuitar Method
Generates a simulated bass guitar note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double BassGuitar(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function BassGuitar (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member BassGuitar :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.BassGuitar = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double BassGuitar(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated bass guitar note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated bass guitar note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.Bell Method

Grid Solutions Framework TimbreBell Method
Generates a simulated bell note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Bell(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Bell (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Bell :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.Bell = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double Bell(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated bell note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated bell note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.BigBell Method

Grid Solutions Framework TimbreBigBell Method
Generates a simulated big bell note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double BigBell(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function BigBell (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member BigBell :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.BigBell = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double BigBell(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated big bell note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated big bell note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.ChimeBell Method

Grid Solutions Framework TimbreChimeBell Method
Generates a simulated chime bell note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ChimeBell(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function ChimeBell (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member ChimeBell :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.ChimeBell = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double ChimeBell(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated chime bell note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated chime bell note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.Clarinet Method

Grid Solutions Framework TimbreClarinet Method
Generates a simulated clarinet note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Clarinet(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Clarinet (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Clarinet :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.Clarinet = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double Clarinet(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated clarinet note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated clarinet note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.ElectricGuitar Method

Grid Solutions Framework TimbreElectricGuitar Method
Generates a simulated electric guitar note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ElectricGuitar(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function ElectricGuitar (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member ElectricGuitar :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.ElectricGuitar = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double ElectricGuitar(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated electric guitar note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated electric guitar note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.EvenHarmonicSeries Method

Grid Solutions Framework TimbreEvenHarmonicSeries Method
Generates an even harmonic series for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double EvenHarmonicSeries(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function EvenHarmonicSeries (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member EvenHarmonicSeries :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.EvenHarmonicSeries = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double EvenHarmonicSeries(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated clarinet note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of an even harmonic series of the given frequency for the given time. Algorithm: Sin(2f) + Sin(4f)/3 + Sin(6f)/5, etc.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.Flute Method

Grid Solutions Framework TimbreFlute Method
Generates a simulated flute note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Flute(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Flute (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Flute :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.Flute = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double Flute(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated flute note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated flute note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.OddHarmonicSeries Method

Grid Solutions Framework TimbreOddHarmonicSeries Method
Generates an odd harmonic series for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double OddHarmonicSeries(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function OddHarmonicSeries (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member OddHarmonicSeries :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.OddHarmonicSeries = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double OddHarmonicSeries(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated clarinet note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of an odd harmonic series of the given frequency for the given time. Algorithm: Sin(f) + Sin(3f)/3 + Sin(5f)/5, etc.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.Organ Method

Grid Solutions Framework TimbreOrgan Method
Generates a simulated organ note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Organ(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Organ (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Organ :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.Organ = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double Organ(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated clarinet note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a second-order harmonic series approaching a square wave (i.e., Sin(f) + Sin(3f)/3) of the given frequency for the given time to simulate an organ sound.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.Piano Method

Grid Solutions Framework TimbrePiano Method
Generates a simulated piano note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Piano(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Piano (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Piano :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.Piano = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double Piano(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated piano note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated piano note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.PureTone Method

Grid Solutions Framework TimbrePureTone Method
Generates a pure tone for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double PureTone(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function PureTone (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member PureTone :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.PureTone = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double PureTone(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a pure tone at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a pure tone of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


Timbre.Xylophone Method

Grid Solutions Framework TimbreXylophone Method
Generates a simulated xylophone note for the given frequency and time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Xylophone(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Shared Function Xylophone (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
static member Xylophone :
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float

GSF.Media.Music.Timbre.Xylophone = function(frequency, sampleIndex, samplePeriod, sampleRate);
public:
static double Xylophone(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for a simulated xylophone note at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a simulated xylophone note of the given frequency for the given time.
See Also

Reference

Timbre Class
GSF.Media.Music Namespace


TimbreFunction Delegate

Grid Solutions Framework TimbreFunction Delegate
Provides a function signature for methods that produce an amplitude representing the acoustic pressure of a represented musical timbre for the given time.

Namespace: GSF.Media.Music
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate double TimbreFunction(
    double frequency,
    long sampleIndex,
    long samplePeriod,
    int sampleRate
)
Public Delegate Function TimbreFunction (
    frequency As Double,
    sampleIndex As Long,
    samplePeriod As Long,
    sampleRate As Integer
) As Double
type TimbreFunction =
    delegate of
        frequency : float *
        sampleIndex : int64 *
        samplePeriod : int64 *
        sampleRate : int -> float
function(frequency, sampleIndex, samplePeriod, sampleRate);
public delegate double TimbreFunction(
    double frequency,
    long long sampleIndex,
    long long samplePeriod,
    int sampleRate
)

Parameters

frequency
Type: SystemDouble
Fundamental frequency of the desired note in Hz.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of song).
samplePeriod
Type: SystemInt64
If useful, total period for note in whole samples per second (i.e., seconds of time * sampleRate) over which to compute timbre.
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude of the represented musical timbre (a value between zero and one) at the given time.
See Also

Reference

GSF.Media.Music Namespace


GSF.Media.Sound Namespace

Grid Solutions Framework GSF.Media.Sound Namespace
Contains classes used to create dual tone multi-frequency sounds and standard touch tones.
Classes
Class | Description
DTMF | Dual Tone Multi-Frequency Class.
TouchTone | Touch tone generator.
Enumerations
 | Enumeration | Description
Public enumeration | TouchToneKey | Touch tone key enumeration.


DTMF Class

Grid Solutions Framework DTMF Class
Dual Tone Multi-Frequency Class.
Inheritance Hierarchy
SystemObject
GSF.Media.SoundDTMF
GSF.Media.SoundTouchTone

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DTMF
Public Class DTMF
type DTMF =  class end
GSF.Media.Sound.DTMF = function();

Type.createClass(
    'GSF.Media.Sound.DTMF');
public ref class DTMF

The DTMF type exposes the following members.

Constructors
 | Name | Description
Public method | DTMF | Constructs a new DTMF.
Public method | DTMF(Double, Double, Double) | Constructs a new DTMF using specified parameters.
Top
Methods
 | Name | Description
 | ComputeFrequencies | Computes a dual-tone multi-frequency sound for the given DTMF information and time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Generate(WaveFile, DTMF, Double) | Generates the specified dual-tone multi-frequency storing it in the specified WaveFile.
 | Generate(WaveFile, DTMF, Double) | Generates a single instance of each of the specified dual-tone multi-frequencies storing them in the specified WaveFile.
 | Generate(WaveFile, DTMF, Double, Int32) | Generates the specified dual-tone multi-frequency repeatCount times storing it in the specified WaveFile.
 | Generate(WaveFile, DTMF, Double, Int32) | Generates the specified dual-tone multi-frequencies repeatCount times storing them in the specified WaveFile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Duration | Frequency duration, in seconds, of DTMF.
Public field | HighFrequency | High frequency of DTMF.
Public field | LowFrequency | Low frequency of DTMF.
Top
Properties
Name | Description
BusySignal | Gets the DTMF instances representing a telephone busy signal.
DialTone | Gets the DTMF instance representing a telephone dial tone.
EmergencyBroadcastSystemAlert | Gets the DTMF instance representing the Emergency Broadcast System alert tone.
OffHook | Gets the DTMF instances representing a telephone off-the-hook signal.
Top
Examples
This example generates some familiar dual tone multi-frequency sounds and plays them over the computer's speakers:
Copy
using System;
using GSF.Media;
using GSF.Media.Sound;

static class Program
{
    static void Main()
    {
        WaveFile waveFile = new WaveFile(SampleRate.Hz8000, BitsPerSample.Bits16, DataChannels.Mono);
        double volume = 0.25D;  // Set volume of tones to 25% of maximum
        DTMF tone;

        // Get the dial tone dual-frequencies
        tone = DTMF.DialTone;

        // Change the duration of the dial-tone to 3 seconds
        tone.Duration = 3.0D;

        // Generate a dial tone
        DTMF.Generate(waveFile, tone, volume);

        // Generate a busy-signal tone, repeat four times
        DTMF.Generate(waveFile, DTMF.BusySignal, volume, 4);

        // Generate an off-the-hook tone, repeat eight times
        DTMF.Generate(waveFile, DTMF.OffHook, volume, 8);

        // Get the EBS Alert dual-frequencies
        tone = DTMF.EmergencyBroadcastSystemAlert;

        // The official duration of an EBS Alert is 22.5 seconds, but
        // the noise is rather annoying - so we set it to 4 seconds
        tone.Duration = 4.0D;

        // Generate the EBS Alert noise
        DTMF.Generate(waveFile, tone, volume);

        // Play all the generated tones
        waveFile.Play();

        Console.ReadKey();
    }
}
See Also

Reference

GSF.Media.Sound Namespace


DTMF Constructor

Grid Solutions Framework DTMF Constructor
Overload List
 | Name | Description
Public method | DTMF | Constructs a new DTMF.
Public method | DTMF(Double, Double, Double) | Constructs a new DTMF using specified parameters.
Top
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF Constructor

Grid Solutions Framework DTMF Constructor
Constructs a new DTMF.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DTMF()
Public Sub New
new : unit -> DTMF
GSF.Media.Sound.DTMF = function();
public:
DTMF()
See Also

Reference

DTMF Class
DTMF Overload
GSF.Media.Sound Namespace


DTMF Constructor (Double, Double, Double)

Grid Solutions Framework DTMF Constructor (Double, Double, Double)
Constructs a new DTMF using specified parameters.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DTMF(
    double lowFrequency,
    double highFrequency,
    double duration
)
Public Sub New (
    lowFrequency As Double,
    highFrequency As Double,
    duration As Double
)
new :
        lowFrequency : float *
        highFrequency : float *
        duration : float -> DTMF
GSF.Media.Sound.DTMF = function(lowFrequency, highFrequency, duration);
public:
DTMF(
    double lowFrequency,
    double highFrequency,
    double duration
)

Parameters

lowFrequency
Type: SystemDouble
A Double low frequency value.
highFrequency
Type: SystemDouble
A Double high frequency value.
duration
Type: SystemDouble
A Double duration value.
See Also

Reference

DTMF Class
DTMF Overload
GSF.Media.Sound Namespace


DTMF Fields

Grid Solutions Framework DTMF Fields

The DTMF type exposes the following members.

Fields
 | Name | Description
Public field | Duration | Frequency duration, in seconds, of DTMF.
Public field | HighFrequency | High frequency of DTMF.
Public field | LowFrequency | Low frequency of DTMF.
Top
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.Duration Field

Grid Solutions Framework DTMFDuration Field
Frequency duration, in seconds, of DTMF.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Duration
Public Duration As Double
val mutable Duration: float
var Duration
public:
double Duration

Field Value

Type: Double
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.HighFrequency Field

Grid Solutions Framework DTMFHighFrequency Field
High frequency of DTMF.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double HighFrequency
Public HighFrequency As Double
val mutable HighFrequency: float
var HighFrequency
public:
double HighFrequency

Field Value

Type: Double
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.LowFrequency Field

Grid Solutions Framework DTMFLowFrequency Field
Low frequency of DTMF.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double LowFrequency
Public LowFrequency As Double
val mutable LowFrequency: float
var LowFrequency
public:
double LowFrequency

Field Value

Type: Double
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF Methods

Grid Solutions Framework DTMF Methods

The DTMF type exposes the following members.

Methods
 | Name | Description
 | ComputeFrequencies | Computes a dual-tone multi-frequency sound for the given DTMF information and time.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
 | Generate(WaveFile, DTMF, Double) | Generates the specified dual-tone multi-frequency storing it in the specified WaveFile.
 | Generate(WaveFile, DTMF, Double) | Generates a single instance of each of the specified dual-tone multi-frequencies storing them in the specified WaveFile.
 | Generate(WaveFile, DTMF, Double, Int32) | Generates the specified dual-tone multi-frequency repeatCount times storing it in the specified WaveFile.
 | Generate(WaveFile, DTMF, Double, Int32) | Generates the specified dual-tone multi-frequencies repeatCount times storing them in the specified WaveFile.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.ComputeFrequencies Method

Grid Solutions Framework DTMFComputeFrequencies Method
Computes a dual-tone multi-frequency sound for the given DTMF information and time.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double ComputeFrequencies(
    DTMF tone,
    long sampleIndex,
    int sampleRate
)
Public Shared Function ComputeFrequencies (
    tone As DTMF,
    sampleIndex As Long,
    sampleRate As Integer
) As Double
static member ComputeFrequencies :
        tone : DTMF *
        sampleIndex : int64 *
        sampleRate : int -> float

GSF.Media.Sound.DTMF.ComputeFrequencies = function(tone, sampleIndex, sampleRate);
public:
static double ComputeFrequencies(
    DTMF^ tone,
    long long sampleIndex,
    int sampleRate
)

Parameters

tone
Type: GSF.Media.SoundDTMF
Instance of the DTMF specifying the duration as well as the low and high frequencies of the dual-tone.
sampleIndex
Type: SystemInt64
Sample index (represents time anywhere from zero to full length of tone).
sampleRate
Type: SystemInt32
Number of samples per second.

Return Value

Type: Double
The amplitude for the dual-tone at the given time.
Remarks
This method computes an amplitude representing the acoustic pressure of a DTMF of the given frequency for the given time.
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.Generate Method

Grid Solutions Framework DTMFGenerate Method
Overload List
Name | Description
Generate(WaveFile, DTMF, Double) | Generates the specified dual-tone multi-frequency storing it in the specified WaveFile.
Generate(WaveFile, DTMF, Double) | Generates a single instance of each of the specified dual-tone multi-frequencies storing them in the specified WaveFile.
Generate(WaveFile, DTMF, Double, Int32) | Generates the specified dual-tone multi-frequency repeatCount times storing it in the specified WaveFile.
Generate(WaveFile, DTMF, Double, Int32) | Generates the specified dual-tone multi-frequencies repeatCount times storing them in the specified WaveFile.
Top
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.Generate Method (WaveFile, DTMF, Double)

Grid Solutions Framework DTMFGenerate Method (WaveFile, DTMF, Double)
Generates the specified dual-tone multi-frequency storing it in the specified WaveFile.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Generate(
    WaveFile destination,
    DTMF tone,
    double volume
)
Public Shared Sub Generate (
    destination As WaveFile,
    tone As DTMF,
    volume As Double
)
static member Generate :
        destination : WaveFile *
        tone : DTMF *
        volume : float -> unit

GSF.Media.Sound.DTMF.Generate = function(destination, tone, volume);
public:
static void Generate(
    WaveFile^ destination,
    DTMF^ tone,
    double volume
)

Parameters

destination
Type: GSF.MediaWaveFile
WaveFile used to store generated dual-tone multi-frequencies.
tone
Type: GSF.Media.SoundDTMF
Dual-tone multi-frequency to generate.
volume
Type: SystemDouble
Volume of generated dual-tones as a percentage (0 to 1).
See Also

Reference

DTMF Class
Generate Overload
GSF.Media.Sound Namespace


DTMF.Generate Method (WaveFile, DTMF[], Double)

Grid Solutions Framework DTMFGenerate Method (WaveFile, DTMF, Double)
Generates a single instance of each of the specified dual-tone multi-frequencies storing them in the specified WaveFile.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Generate(
    WaveFile destination,
    DTMF[] tones,
    double volume
)
Public Shared Sub Generate (
    destination As WaveFile,
    tones As DTMF(),
    volume As Double
)
static member Generate :
        destination : WaveFile *
        tones : DTMF[] *
        volume : float -> unit

GSF.Media.Sound.DTMF.Generate = function(destination, tones, volume);
public:
static void Generate(
    WaveFile^ destination,
    array<DTMF^>^ tones,
    double volume
)

Parameters

destination
Type: GSF.MediaWaveFile
WaveFile used to store generated dual-tone multi-frequencies.
tones
Type: GSF.Media.SoundDTMF
Dual-tone multi-frequencies to generate.
volume
Type: SystemDouble
Volume of generated dual-tones as a percentage (0 to 1).
See Also

Reference

DTMF Class
Generate Overload
GSF.Media.Sound Namespace


DTMF.Generate Method (WaveFile, DTMF, Double, Int32)

Grid Solutions Framework DTMFGenerate Method (WaveFile, DTMF, Double, Int32)
Generates the specified dual-tone multi-frequency repeatCount times storing it in the specified WaveFile.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Generate(
    WaveFile destination,
    DTMF tone,
    double volume,
    int repeatCount
)
Public Shared Sub Generate (
    destination As WaveFile,
    tone As DTMF,
    volume As Double,
    repeatCount As Integer
)
static member Generate :
        destination : WaveFile *
        tone : DTMF *
        volume : float *
        repeatCount : int -> unit

GSF.Media.Sound.DTMF.Generate = function(destination, tone, volume, repeatCount);
public:
static void Generate(
    WaveFile^ destination,
    DTMF^ tone,
    double volume,
    int repeatCount
)

Parameters

destination
Type: GSF.MediaWaveFile
WaveFile used to store generated dual-tone multi-frequencies.
tone
Type: GSF.Media.SoundDTMF
Dual-tone multi-frequency to generate.
volume
Type: SystemDouble
Volume of generated dual-tones as a percentage (0 to 1).
repeatCount
Type: SystemInt32
Number of times to repeat the tone.
See Also

Reference

DTMF Class
Generate Overload
GSF.Media.Sound Namespace


DTMF.Generate Method (WaveFile, DTMF[], Double, Int32)

Grid Solutions Framework DTMFGenerate Method (WaveFile, DTMF, Double, Int32)
Generates the specified dual-tone multi-frequencies repeatCount times storing them in the specified WaveFile.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Generate(
    WaveFile destination,
    DTMF[] tones,
    double volume,
    int repeatCount
)
Public Shared Sub Generate (
    destination As WaveFile,
    tones As DTMF(),
    volume As Double,
    repeatCount As Integer
)
static member Generate :
        destination : WaveFile *
        tones : DTMF[] *
        volume : float *
        repeatCount : int -> unit

GSF.Media.Sound.DTMF.Generate = function(destination, tones, volume, repeatCount);
public:
static void Generate(
    WaveFile^ destination,
    array<DTMF^>^ tones,
    double volume,
    int repeatCount
)

Parameters

destination
Type: GSF.MediaWaveFile
WaveFile used to store generated dual-tone multi-frequencies.
tones
Type: GSF.Media.SoundDTMF
Dual-tone multi-frequencies to generate.
volume
Type: SystemDouble
Volume of generated dual-tones as a percentage (0 to 1).
repeatCount
Type: SystemInt32
Number of times to repeat each tone.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value must be expressed as a fractional percentage between zero and one.
InvalidOperationException | DTMF only generated for WaveFile with a sample rate of 8, 16, 24, 32 or 64 bits per sample.
See Also

Reference

DTMF Class
Generate Overload
GSF.Media.Sound Namespace


DTMF Properties

Grid Solutions Framework DTMF Properties

The DTMF type exposes the following members.

Properties
Name | Description
BusySignal | Gets the DTMF instances representing a telephone busy signal.
DialTone | Gets the DTMF instance representing a telephone dial tone.
EmergencyBroadcastSystemAlert | Gets the DTMF instance representing the Emergency Broadcast System alert tone.
OffHook | Gets the DTMF instances representing a telephone off-the-hook signal.
Top
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.BusySignal Property

Grid Solutions Framework DTMFBusySignal Property
Gets the DTMF instances representing a telephone busy signal.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DTMF[] BusySignal { get; }
Public Shared ReadOnly Property BusySignal As DTMF()
    Get
static member BusySignal : DTMF[] with get

GSF.Media.Sound.DTMF.get_BusySignal = function();

public:
static property array<DTMF^>^ BusySignal {
    array<DTMF^>^ get ();
}

Property Value

Type: DTMF
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.DialTone Property

Grid Solutions Framework DTMFDialTone Property
Gets the DTMF instance representing a telephone dial tone.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DTMF DialTone { get; }
Public Shared ReadOnly Property DialTone As DTMF
    Get
static member DialTone : DTMF with get

GSF.Media.Sound.DTMF.get_DialTone = function();

public:
static property DTMF^ DialTone {
    DTMF^ get ();
}

Property Value

Type: DTMF
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.EmergencyBroadcastSystemAlert Property

Grid Solutions Framework DTMFEmergencyBroadcastSystemAlert Property
Gets the DTMF instance representing the Emergency Broadcast System alert tone.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DTMF EmergencyBroadcastSystemAlert { get; }
Public Shared ReadOnly Property EmergencyBroadcastSystemAlert As DTMF
    Get
static member EmergencyBroadcastSystemAlert : DTMF with get

GSF.Media.Sound.DTMF.get_EmergencyBroadcastSystemAlert = function();

public:
static property DTMF^ EmergencyBroadcastSystemAlert {
    DTMF^ get ();
}

Property Value

Type: DTMF
Remarks
The official duration of an EBS Alert is 22.5 seconds.
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


DTMF.OffHook Property

Grid Solutions Framework DTMFOffHook Property
Gets the DTMF instances representing a telephone off-the-hook signal.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DTMF[] OffHook { get; }
Public Shared ReadOnly Property OffHook As DTMF()
    Get
static member OffHook : DTMF[] with get

GSF.Media.Sound.DTMF.get_OffHook = function();

public:
static property array<DTMF^>^ OffHook {
    array<DTMF^>^ get ();
}

Property Value

Type: DTMF
See Also

Reference

DTMF Class
GSF.Media.Sound Namespace


TouchTone Class

Grid Solutions Framework TouchTone Class
Touch tone generator.
Inheritance Hierarchy
SystemObject
GSF.Media.SoundDTMF
GSF.Media.SoundTouchTone

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TouchTone : DTMF
Public Class TouchTone
    Inherits DTMF
type TouchTone =
    class
        inherit DTMF
    end
GSF.Media.Sound.TouchTone = function();

Type.createClass(
    'GSF.Media.Sound.TouchTone',
    GSF.Media.Sound.DTMF);
public ref class TouchTone : public DTMF

The TouchTone type exposes the following members.

Constructors
 | Name | Description
Public method | TouchTone(Char) | Constructs a new TouchTone for specified touch tone key character.
Public method | TouchTone(Int32) | Constructs a new TouchTone for specified touch tone key number.
Public method | TouchTone(TouchToneKey) | Constructs a new TouchTone for specified touch tone key.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTouchTones(String) | Get array of touch tones for given string.
 | GetTouchTones(String, Double, Double) | Get array of touch tones for given string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the character representation of a touch tone key into an instance of the TouchTone class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryParse | Converts the character representation of a touch tone key into an instance of the TouchTone class. A return value indicates whether the conversion succeeded.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
 | DefaultInterKeyPause | Default duration, in seconds, of pause between touch tones.
 | DefaultKeyDuration | Default duration, in seconds, of touch tones.
Public field | Duration | Frequency duration, in seconds, of DTMF. (Inherited from DTMF.)
Public field | HighFrequency | High frequency of DTMF. (Inherited from DTMF.)
Public field | LowFrequency | Low frequency of DTMF. (Inherited from DTMF.)
 | ValidTouchTones | Valid touch tone keys.
Top
Examples
This example will "dial a phone number" over the computer's speakers:
Copy
using System;
using GSF.Media;
using GSF.Media.Sound;

static class Program
{
    static void Main()
    {
        WaveFile waveFile = new WaveFile(SampleRate.Hz8000, BitsPerSample.Bits16, DataChannels.Mono);
        double volume = 0.25D;  // Set volume of TouchTone to 25% of maximum
        string phoneNumber = "9, 1 (535) 217-1631";

        // Generate touch tones for specified phone number
        DTMF.Generate(waveFile, TouchTone.GetTouchTones(phoneNumber), volume);

        Console.WriteLine("Dialing {0}...", phoneNumber);
        waveFile.Play();

        Console.ReadKey();
    }
}
See Also

Reference

GSF.Media.Sound Namespace


TouchTone Constructor

Grid Solutions Framework TouchTone Constructor
Overload List
 | Name | Description
Public method | TouchTone(Char) | Constructs a new TouchTone for specified touch tone key character.
Public method | TouchTone(Int32) | Constructs a new TouchTone for specified touch tone key number.
Public method | TouchTone(TouchToneKey) | Constructs a new TouchTone for specified touch tone key.
Top
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone Constructor (Char)

Grid Solutions Framework TouchTone Constructor (Char)
Constructs a new TouchTone for specified touch tone key character.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TouchTone(
    char key
)
Public Sub New (
    key As Char
)
new :
        key : char -> TouchTone
GSF.Media.Sound.TouchTone = function(key);
public:
TouchTone(
    wchar_t key
)

Parameters

key
Type: SystemChar
Character of touch tone to create.
Exceptions
Exception | Condition
ArgumentException | key is not a valid touch tone character.
See Also

Reference

TouchTone Class
TouchTone Overload
GSF.Media.Sound Namespace


TouchTone Constructor (Int32)

Grid Solutions Framework TouchTone Constructor (Int32)
Constructs a new TouchTone for specified touch tone key number.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TouchTone(
    int key
)
Public Sub New (
    key As Integer
)
new :
        key : int -> TouchTone
GSF.Media.Sound.TouchTone = function(key);
public:
TouchTone(
    int key
)

Parameters

key
Type: SystemInt32
Number of touch tone to create (note that * = 10 and # = 11).
Exceptions
Exception | Condition
ArgumentException | key is not a valid touch tone number.
See Also

Reference

TouchTone Class
TouchTone Overload
GSF.Media.Sound Namespace


TouchTone Constructor (TouchToneKey)

Grid Solutions Framework TouchTone Constructor (TouchToneKey)
Constructs a new TouchTone for specified touch tone key.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TouchTone(
    TouchToneKey key
)
Public Sub New (
    key As TouchToneKey
)
new :
        key : TouchToneKey -> TouchTone
GSF.Media.Sound.TouchTone = function(key);
public:
TouchTone(
    TouchToneKey key
)

Parameters

key
Type: GSF.Media.SoundTouchToneKey
Touch tone to create.
See Also

Reference

TouchTone Class
TouchTone Overload
GSF.Media.Sound Namespace


TouchTone Fields

Grid Solutions Framework TouchTone Fields

The TouchTone type exposes the following members.

Fields
 | Name | Description
 | DefaultInterKeyPause | Default duration, in seconds, of pause between touch tones.
 | DefaultKeyDuration | Default duration, in seconds, of touch tones.
Public field | Duration | Frequency duration, in seconds, of DTMF. (Inherited from DTMF.)
Public field | HighFrequency | High frequency of DTMF. (Inherited from DTMF.)
Public field | LowFrequency | Low frequency of DTMF. (Inherited from DTMF.)
 | ValidTouchTones | Valid touch tone keys.
Top
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone.DefaultInterKeyPause Field

Grid Solutions Framework TouchToneDefaultInterKeyPause Field
Default duration, in seconds, of pause between touch tones.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultInterKeyPause
Public Const DefaultInterKeyPause As Double
static val mutable DefaultInterKeyPause: float
var GSF.Media.Sound.TouchTone.DefaultInterKeyPause
public:
literal double DefaultInterKeyPause

Field Value

Type: Double
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone.DefaultKeyDuration Field

Grid Solutions Framework TouchToneDefaultKeyDuration Field
Default duration, in seconds, of touch tones.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultKeyDuration
Public Const DefaultKeyDuration As Double
static val mutable DefaultKeyDuration: float
var GSF.Media.Sound.TouchTone.DefaultKeyDuration
public:
literal double DefaultKeyDuration

Field Value

Type: Double
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone.ValidTouchTones Field

Grid Solutions Framework TouchToneValidTouchTones Field
Valid touch tone keys.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string ValidTouchTones
Public Const ValidTouchTones As String
static val mutable ValidTouchTones: string
var GSF.Media.Sound.TouchTone.ValidTouchTones
public:
literal String^ ValidTouchTones

Field Value

Type: String
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone Methods

Grid Solutions Framework TouchTone Methods

The TouchTone type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetTouchTones(String) | Get array of touch tones for given string.
 | GetTouchTones(String, Double, Double) | Get array of touch tones for given string.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the character representation of a touch tone key into an instance of the TouchTone class.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | TryParse | Converts the character representation of a touch tone key into an instance of the TouchTone class. A return value indicates whether the conversion succeeded.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone.GetTouchTones Method

Grid Solutions Framework TouchToneGetTouchTones Method
Overload List
Name | Description
GetTouchTones(String) | Get array of touch tones for given string.
GetTouchTones(String, Double, Double) | Get array of touch tones for given string.
Top
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone.GetTouchTones Method (String)

Grid Solutions Framework TouchToneGetTouchTones Method (String)
Get array of touch tones for given string.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DTMF[] GetTouchTones(
    string keys
)
Public Shared Function GetTouchTones (
    keys As String
) As DTMF()
static member GetTouchTones :
        keys : string -> DTMF[]

GSF.Media.Sound.TouchTone.GetTouchTones = function(keys);
public:
static array<DTMF^>^ GetTouchTones(
    String^ keys
)

Parameters

keys
Type: SystemString
String of touch tone characters to convert to touch tones.

Return Value

Type: DTMF
Array of touch tones for given string.
Remarks
Non-touch tone characters are ignored. Commas are interpreted as a one second pause.
See Also

Reference

TouchTone Class
GetTouchTones Overload
GSF.Media.Sound Namespace


TouchTone.GetTouchTones Method (String, Double, Double)

Grid Solutions Framework TouchToneGetTouchTones Method (String, Double, Double)
Get array of touch tones for given string.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DTMF[] GetTouchTones(
    string keys,
    double keyDuration,
    double interKeyPause
)
Public Shared Function GetTouchTones (
    keys As String,
    keyDuration As Double,
    interKeyPause As Double
) As DTMF()
static member GetTouchTones :
        keys : string *
        keyDuration : float *
        interKeyPause : float -> DTMF[]

GSF.Media.Sound.TouchTone.GetTouchTones = function(keys, keyDuration, interKeyPause);
public:
static array<DTMF^>^ GetTouchTones(
    String^ keys,
    double keyDuration,
    double interKeyPause
)

Parameters

keys
Type: SystemString
String of touch tone characters to convert to touch tones.
keyDuration
Type: SystemDouble
Duration of touch tone key press in seconds, typically fractional.
interKeyPause
Type: SystemDouble
Time to wait between key presses in seconds, typically fractional.

Return Value

Type: DTMF
Array of touch tones for given string.
Remarks
Non-touch tone characters are ignored. Commas are interpreted as a one second pause.
See Also

Reference

TouchTone Class
GetTouchTones Overload
GSF.Media.Sound Namespace


TouchTone.Parse Method

Grid Solutions Framework TouchToneParse Method
Converts the character representation of a touch tone key into an instance of the TouchTone class.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static TouchTone Parse(
    char key
)
Public Shared Function Parse (
    key As Char
) As TouchTone
static member Parse :
        key : char -> TouchTone

GSF.Media.Sound.TouchTone.Parse = function(key);
public:
static TouchTone^ Parse(
    wchar_t key
)

Parameters

key
Type: SystemChar
A character containing a touch tone key to convert.

Return Value

Type: TouchTone
An instance of the TouchTone class equivalent to the touch tone chracter contained in key.
Exceptions
Exception | Condition
ArgumentException | key is not a valid touch tone character.
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchTone.TryParse Method

Grid Solutions Framework TouchToneTryParse Method
Converts the character representation of a touch tone key into an instance of the TouchTone class. A return value indicates whether the conversion succeeded.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    char key,
    out TouchTone result
)
Public Shared Function TryParse (
    key As Char,
    <OutAttribute> ByRef result As TouchTone
) As Boolean
static member TryParse :
        key : char *
        result : TouchTone byref -> bool

GSF.Media.Sound.TouchTone.TryParse = function(key, result);
public:
static bool TryParse(
    wchar_t key,
    [OutAttribute] TouchTone^% result
)

Parameters

key
Type: SystemChar
A character containing a touch tone key to convert.
result
Type: GSF.Media.SoundTouchTone
When this method returns, contains an instance of the TouchTone class equivalent to the touch tone key, if the conversion succeeded, or null if the conversion failed. The conversion fails if the key parameter is not a valid touch tone.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

TouchTone Class
GSF.Media.Sound Namespace


TouchToneKey Enumeration

Grid Solutions Framework TouchToneKey Enumeration
Touch tone key enumeration.

Namespace: GSF.Media.Sound
Assembly: GSF.Media (in GSF.Media.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum TouchToneKey
Public Enumeration TouchToneKey
type TouchToneKey
GSF.Media.Sound.TouchToneKey = function();
GSF.Media.Sound.TouchToneKey.createEnum('GSF.Media.Sound.TouchToneKey', false);
public enum class TouchToneKey
Members
Member name | Value | Description
Zero | 0 | Represents the number "0" on a touch tone key pad.
One | 1 | Represents the number "1" on a touch tone key pad.
Two | 2 | Represents the number "2" on a touch tone key pad.
Three | 3 | Represents the number "3" on a touch tone key pad.
Four | 4 | Represents the number "4" on a touch tone key pad.
Five | 5 | Represents the number "5" on a touch tone key pad.
Six | 6 | Represents the number "6" on a touch tone key pad.
Seven | 7 | Represents the number "7" on a touch tone key pad.
Eight | 8 | Represents the number "8" on a touch tone key pad.
Nine | 9 | Represents the number "9" on a touch tone key pad.
Asterisk | 10 | Represents the "*" key on a touch tone key pad.
Pound | 11 | Represents the "#" key on a touch tone key pad.
See Also

Reference

GSF.Media.Sound Namespace


GSF.Net.Ftp Namespace

Grid Solutions Framework GSF.Net.Ftp Namespace
Contains classes used to create client connections to FTP servers for uploading and downloading files.
Classes
 | Class | Description
Public class | FtpAsyncResult | Asynchronous transfer result.
Public class | FtpAuthenticationException | FTP authentication exception.
Public class | FtpClient | Represents a FTP session.
Public class | FtpCommandException | FTP command exception.
Public class | FtpControlChannel | FTP control channel.
Public class | FtpDataStream | FTP data stream.
Public class | FtpDataTransferException | FTP data transfer exception.
Public class | FtpDirectory | Represents a FTP directory.
Public class | FtpExceptionBase | FTP exception base class.
Public class | FtpFile | Represents a FTP file.
Public class | FtpFileNotFoundException | FTP file not found exception.
Public class | FtpFileWatcher | FTP File Watcher
Public class | FtpInputDataStream | Defines a FTP data input stream for remote files.
Public class | FtpInvalidResponseException | Invalid FTP response exception.
Public class | FtpOutputDataStream | Defines a FTP data output stream for remote files.
Public class | FtpResponse | Defines a FTP response.
Public class | FtpResumeNotSupportedException | FTP resume not supported exception.
Public class | FtpServerDownException | FTP server down exception.
Public class | FtpUserAbortException | FTP user abort exception.
Interfaces
 | Interface | Description
Public interface | IFtpFile | Abstract representation of a FTP file or directory.
Enumerations
 | Enumeration | Description
Public enumeration | TransferDirection | FTP file transfer direction enumeration.
Public enumeration | TransferMode | FTP transfer mode enumeration.


FtpAsyncResult Class

Grid Solutions Framework FtpAsyncResult Class
Asynchronous transfer result.
Inheritance Hierarchy
SystemObject
GSF.Net.FtpFtpAsyncResult

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpAsyncResult
Public Class FtpAsyncResult
type FtpAsyncResult =  class end
GSF.Net.Ftp.FtpAsyncResult = function();

Type.createClass(
    'GSF.Net.Ftp.FtpAsyncResult');
public ref class FtpAsyncResult

The FtpAsyncResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Abort | FTP transfer result aborted index.
Complete | FTP transfer result completed index.
Fail | FTP transfer result failed index.
Top
Properties
 | Name | Description
Public property | IsAborted | Returns true if asynchronous transfer was aborted.
Public property | IsFailed | Returns true if asynchronous transfer failed.
Public property | IsSuccess | Returns true if asynchronous transfer completed successfully.
Public property | Message | Gets any message associated with asynchronous transfer.
Public property | ResponseCode | Gets response code from asynchronous transfer.
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpAsyncResult Fields

Grid Solutions Framework FtpAsyncResult Fields

The FtpAsyncResult type exposes the following members.

Fields
Name | Description
Abort | FTP transfer result aborted index.
Complete | FTP transfer result completed index.
Fail | FTP transfer result failed index.
Top
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.Abort Field

Grid Solutions Framework FtpAsyncResultAbort Field
FTP transfer result aborted index.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Abort
Public Const Abort As Integer
static val mutable Abort: int
var GSF.Net.Ftp.FtpAsyncResult.Abort
public:
literal int Abort

Field Value

Type: Int32
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.Complete Field

Grid Solutions Framework FtpAsyncResultComplete Field
FTP transfer result completed index.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Complete
Public Const Complete As Integer
static val mutable Complete: int
var GSF.Net.Ftp.FtpAsyncResult.Complete
public:
literal int Complete

Field Value

Type: Int32
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.Fail Field

Grid Solutions Framework FtpAsyncResultFail Field
FTP transfer result failed index.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int Fail
Public Const Fail As Integer
static val mutable Fail: int
var GSF.Net.Ftp.FtpAsyncResult.Fail
public:
literal int Fail

Field Value

Type: Int32
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult Methods

Grid Solutions Framework FtpAsyncResult Methods

The FtpAsyncResult type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult Properties

Grid Solutions Framework FtpAsyncResult Properties

The FtpAsyncResult type exposes the following members.

Properties
 | Name | Description
Public property | IsAborted | Returns true if asynchronous transfer was aborted.
Public property | IsFailed | Returns true if asynchronous transfer failed.
Public property | IsSuccess | Returns true if asynchronous transfer completed successfully.
Public property | Message | Gets any message associated with asynchronous transfer.
Public property | ResponseCode | Gets response code from asynchronous transfer.
Top
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.IsAborted Property

Grid Solutions Framework FtpAsyncResultIsAborted Property
Returns true if asynchronous transfer was aborted.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsAborted { get; }
Public ReadOnly Property IsAborted As Boolean
    Get
member IsAborted : bool with get

function get_IsAborted();

public:
property bool IsAborted {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.IsFailed Property

Grid Solutions Framework FtpAsyncResultIsFailed Property
Returns true if asynchronous transfer failed.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsFailed { get; }
Public ReadOnly Property IsFailed As Boolean
    Get
member IsFailed : bool with get

function get_IsFailed();

public:
property bool IsFailed {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.IsSuccess Property

Grid Solutions Framework FtpAsyncResultIsSuccess Property
Returns true if asynchronous transfer completed successfully.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSuccess { get; }
Public ReadOnly Property IsSuccess As Boolean
    Get
member IsSuccess : bool with get

function get_IsSuccess();

public:
property bool IsSuccess {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.Message Property

Grid Solutions Framework FtpAsyncResultMessage Property
Gets any message associated with asynchronous transfer.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
member Message : string with get

function get_Message();

public:
property String^ Message {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAsyncResult.ResponseCode Property

Grid Solutions Framework FtpAsyncResultResponseCode Property
Gets response code from asynchronous transfer.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ResponseCode { get; }
Public ReadOnly Property ResponseCode As Integer
    Get
member ResponseCode : int with get

function get_ResponseCode();

public:
property int ResponseCode {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

FtpAsyncResult Class
GSF.Net.Ftp Namespace


FtpAuthenticationException Class

Grid Solutions Framework FtpAuthenticationException Class
FTP authentication exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpAuthenticationException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpAuthenticationException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpAuthenticationException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpAuthenticationException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpAuthenticationException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpAuthenticationException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpAuthenticationException : public FtpExceptionBase

The FtpAuthenticationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpAuthenticationException Methods

Grid Solutions Framework FtpAuthenticationException Methods

The FtpAuthenticationException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpAuthenticationException Class
GSF.Net.Ftp Namespace


FtpAuthenticationException Properties

Grid Solutions Framework FtpAuthenticationException Properties

The FtpAuthenticationException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpAuthenticationException Class
GSF.Net.Ftp Namespace


FtpAuthenticationException Events

Grid Solutions Framework FtpAuthenticationException Events

The FtpAuthenticationException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpAuthenticationException Class
GSF.Net.Ftp Namespace


FtpClient Class

Grid Solutions Framework FtpClient Class
Represents a FTP session.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.Net.FtpFtpClient

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(FtpClient))]
[DefaultEventAttribute("FileTransferProgress")]
[DefaultPropertyAttribute("Server")]
public class FtpClient : Component
<ToolboxBitmapAttribute(GetType(FtpClient))>
<DefaultEventAttribute("FileTransferProgress")>
<DefaultPropertyAttribute("Server")>
Public Class FtpClient
    Inherits Component
[<ToolboxBitmapAttribute(typeof(FtpClient))>]
[<DefaultEventAttribute("FileTransferProgress")>]
[<DefaultPropertyAttribute("Server")>]
type FtpClient =
    class
        inherit Component
    end
GSF.Net.Ftp.FtpClient = function();

Type.createClass(
    'GSF.Net.Ftp.FtpClient',
    Component);
[ToolboxBitmapAttribute(typeof(FtpClient))]
[DefaultEventAttribute(L"FileTransferProgress")]
[DefaultPropertyAttribute(L"Server")]
public ref class FtpClient : public Component

The FtpClient type exposes the following members.

Constructors
 | Name | Description
Public method | FtpClient | Constructs a new FTP session using the default settings.
Public method | FtpClient(Boolean) | Constructs a new FTP session using the specified settings.
Public method | FtpClient(IContainer) | Initializes a new instance of the FtpClient class.
Top
Methods
 | Name | Description
Public method | AbortTransfer | Aborts current file transfer.
Public method | Close | Closes current FTP session.
Public method | Connect | Connects to FTP server using specified credentials.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FtpClient object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | SetCurrentDirectory | Changes the current FTP session directory to the specified path.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CaseInsensitive | Gets or sets FTP case sensitivity of file and directory names.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ControlChannel | Gets the current FTP control channel.
Public property | CurrentDirectory | Gets or sets current FTP session directory.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsBusy | Returns true if FTP session is currently busy.
Public property | IsConnected | Returns true if FTP session is currently connected.
Public property | Port | Gets or sets FTP server port to use, defaults to 21.
Public property | RootDirectory | Gets FTP session root directory entry.
Public property | Server | Gets or sets FTP server name (DNS name or IP).
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | WaitLockTimeout | Gets or sets maximum number of seconds to wait for read lock for files to be uploaded. Defaults to 10 seconds.
Top
Events
 | Name | Description
Public event | BeginFileTransfer | Raised when file transfer begins.
Public event | CommandSent | Raised when FTP command has been sent.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndFileTransfer | Raised when file transfer completes.
Public event | FileTransferNotification | Raised when ansynchronous file transfer process has completed (success or failure).
Public event | FileTransferProgress | Raised as file transfer is progressing.
Public event | ResponseReceived | Raised when FTP response has been received.
Top
Remarks
Creates a client connection to an FTP server for uploading or downloading files.
See Also

Reference

GSF.Net.Ftp Namespace


FtpClient Constructor

Grid Solutions Framework FtpClient Constructor
Overload List
 | Name | Description
Public method | FtpClient | Constructs a new FTP session using the default settings.
Public method | FtpClient(Boolean) | Constructs a new FTP session using the specified settings.
Public method | FtpClient(IContainer) | Initializes a new instance of the FtpClient class.
Top
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient Constructor

Grid Solutions Framework FtpClient Constructor
Constructs a new FTP session using the default settings.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpClient()
Public Sub New
new : unit -> FtpClient
GSF.Net.Ftp.FtpClient = function();
public:
FtpClient()
See Also

Reference

FtpClient Class
FtpClient Overload
GSF.Net.Ftp Namespace


FtpClient Constructor (Boolean)

Grid Solutions Framework FtpClient Constructor (Boolean)
Constructs a new FTP session using the specified settings.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpClient(
    bool caseInsensitive
)
Public Sub New (
    caseInsensitive As Boolean
)
new :
        caseInsensitive : bool -> FtpClient
GSF.Net.Ftp.FtpClient = function(caseInsensitive);
public:
FtpClient(
    bool caseInsensitive
)

Parameters

caseInsensitive
Type: SystemBoolean
Set to true to not be case sensitive with FTP file and directory names.
See Also

Reference

FtpClient Class
FtpClient Overload
GSF.Net.Ftp Namespace


FtpClient Constructor (IContainer)

Grid Solutions Framework FtpClient Constructor (IContainer)
Initializes a new instance of the FtpClient class.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpClient(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> FtpClient
GSF.Net.Ftp.FtpClient = function(container);
public:
FtpClient(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the FtpClient.
See Also

Reference

FtpClient Class
FtpClient Overload
GSF.Net.Ftp Namespace


FtpClient Methods

Grid Solutions Framework FtpClient Methods

The FtpClient type exposes the following members.

Methods
 | Name | Description
Public method | AbortTransfer | Aborts current file transfer.
Public method | Close | Closes current FTP session.
Public method | Connect | Connects to FTP server using specified credentials.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FtpClient object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | SetCurrentDirectory | Changes the current FTP session directory to the specified path.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.AbortTransfer Method

Grid Solutions Framework FtpClientAbortTransfer Method
Aborts current file transfer.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AbortTransfer()
Public Sub AbortTransfer
member AbortTransfer : unit -> unit

function AbortTransfer();
public:
void AbortTransfer()
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.Close Method

Grid Solutions Framework FtpClientClose Method
Closes current FTP session.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.Connect Method

Grid Solutions Framework FtpClientConnect Method
Connects to FTP server using specified credentials.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Connect(
    string userName,
    string password
)
Public Sub Connect (
    userName As String,
    password As String
)
member Connect :
        userName : string *
        password : string -> unit

function Connect(userName, password);
public:
void Connect(
    String^ userName,
    String^ password
)

Parameters

userName
Type: SystemString
User name used to authenticate to FTP server.
password
Type: SystemString
Password used to authenticate to FTP server.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.Dispose Method

Grid Solutions Framework FtpClientDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FtpClient object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.Dispose Method (Boolean)

Grid Solutions Framework FtpClientDispose Method (Boolean)
Releases the unmanaged resources used by the FtpClient object and optionally releases the managed resources.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FtpClient Class
Dispose Overload
GSF.Net.Ftp Namespace


FtpClient.SetCurrentDirectory Method

Grid Solutions Framework FtpClientSetCurrentDirectory Method
Changes the current FTP session directory to the specified path.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCurrentDirectory(
    string directoryPath
)
Public Sub SetCurrentDirectory (
    directoryPath As String
)
member SetCurrentDirectory :
        directoryPath : string -> unit

function SetCurrentDirectory(directoryPath);
public:
void SetCurrentDirectory(
    String^ directoryPath
)

Parameters

directoryPath
Type: SystemString
New directory.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient Properties

Grid Solutions Framework FtpClient Properties

The FtpClient type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CaseInsensitive | Gets or sets FTP case sensitivity of file and directory names.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ControlChannel | Gets the current FTP control channel.
Public property | CurrentDirectory | Gets or sets current FTP session directory.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsBusy | Returns true if FTP session is currently busy.
Public property | IsConnected | Returns true if FTP session is currently connected.
Public property | Port | Gets or sets FTP server port to use, defaults to 21.
Public property | RootDirectory | Gets FTP session root directory entry.
Public property | Server | Gets or sets FTP server name (DNS name or IP).
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | WaitLockTimeout | Gets or sets maximum number of seconds to wait for read lock for files to be uploaded. Defaults to 10 seconds.
Top
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.CaseInsensitive Property

Grid Solutions Framework FtpClientCaseInsensitive Property
Gets or sets FTP case sensitivity of file and directory names.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
[DefaultValueAttribute(false)]
public bool CaseInsensitive { get; set; }
<BrowsableAttribute(true)>
<DefaultValueAttribute(false)>
Public Property CaseInsensitive As Boolean
    Get
    Set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(false)>]
member CaseInsensitive : bool with get, set

function get_CaseInsensitive();
function set_CaseInsensitive(value);
public:
[BrowsableAttribute(true)]
[DefaultValueAttribute(false)]
property bool CaseInsensitive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Set to true to not be case sensitive with FTP file and directory names.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.ControlChannel Property

Grid Solutions Framework FtpClientControlChannel Property
Gets the current FTP control channel.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public FtpControlChannel ControlChannel { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property ControlChannel As FtpControlChannel
    Get
[<BrowsableAttribute(false)>]
member ControlChannel : FtpControlChannel with get

function get_ControlChannel();

public:
[BrowsableAttribute(false)]
property FtpControlChannel^ ControlChannel {
    FtpControlChannel^ get ();
}

Property Value

Type: FtpControlChannel
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.CurrentDirectory Property

Grid Solutions Framework FtpClientCurrentDirectory Property
Gets or sets current FTP session directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public FtpDirectory CurrentDirectory { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property CurrentDirectory As FtpDirectory
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
member CurrentDirectory : FtpDirectory with get, set

function get_CurrentDirectory();
function set_CurrentDirectory(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
property FtpDirectory^ CurrentDirectory {
    FtpDirectory^ get ();
    void set (FtpDirectory^ value);
}

Property Value

Type: FtpDirectory
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.IsBusy Property

Grid Solutions Framework FtpClientIsBusy Property
Returns true if FTP session is currently busy.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public bool IsBusy { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property IsBusy As Boolean
    Get
[<BrowsableAttribute(false)>]
member IsBusy : bool with get

function get_IsBusy();

public:
[BrowsableAttribute(false)]
property bool IsBusy {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.IsConnected Property

Grid Solutions Framework FtpClientIsConnected Property
Returns true if FTP session is currently connected.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public bool IsConnected { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property IsConnected As Boolean
    Get
[<BrowsableAttribute(false)>]
member IsConnected : bool with get

function get_IsConnected();

public:
[BrowsableAttribute(false)]
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.Port Property

Grid Solutions Framework FtpClientPort Property
Gets or sets FTP server port to use, defaults to 21.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(21)]
[BrowsableAttribute(true)]
public int Port { get; set; }
<DefaultValueAttribute(21)>
<BrowsableAttribute(true)>
Public Property Port As Integer
    Get
    Set
[<DefaultValueAttribute(21)>]
[<BrowsableAttribute(true)>]
member Port : int with get, set

function get_Port();
function set_Port(value);
public:
[DefaultValueAttribute(21)]
[BrowsableAttribute(true)]
property int Port {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This only needs to be changed if the FTP server is established on a non-standard port number.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.RootDirectory Property

Grid Solutions Framework FtpClientRootDirectory Property
Gets FTP session root directory entry.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public FtpDirectory RootDirectory { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property RootDirectory As FtpDirectory
    Get
[<BrowsableAttribute(false)>]
member RootDirectory : FtpDirectory with get

function get_RootDirectory();

public:
[BrowsableAttribute(false)]
property FtpDirectory^ RootDirectory {
    FtpDirectory^ get ();
}

Property Value

Type: FtpDirectory
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.Server Property

Grid Solutions Framework FtpClientServer Property
Gets or sets FTP server name (DNS name or IP).

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
public string Server { get; set; }
<BrowsableAttribute(true)>
Public Property Server As String
    Get
    Set
[<BrowsableAttribute(true)>]
member Server : string with get, set

function get_Server();
function set_Server(value);
public:
[BrowsableAttribute(true)]
property String^ Server {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
FTP server name should not be prefixed with FTP://.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.WaitLockTimeout Property

Grid Solutions Framework FtpClientWaitLockTimeout Property
Gets or sets maximum number of seconds to wait for read lock for files to be uploaded. Defaults to 10 seconds.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
[DefaultValueAttribute(10)]
public int WaitLockTimeout { get; set; }
<BrowsableAttribute(true)>
<DefaultValueAttribute(10)>
Public Property WaitLockTimeout As Integer
    Get
    Set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(10)>]
member WaitLockTimeout : int with get, set

function get_WaitLockTimeout();
function set_WaitLockTimeout(value);
public:
[BrowsableAttribute(true)]
[DefaultValueAttribute(10)]
property int WaitLockTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient Events

Grid Solutions Framework FtpClient Events

The FtpClient type exposes the following members.

Events
 | Name | Description
Public event | BeginFileTransfer | Raised when file transfer begins.
Public event | CommandSent | Raised when FTP command has been sent.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | EndFileTransfer | Raised when file transfer completes.
Public event | FileTransferNotification | Raised when ansynchronous file transfer process has completed (success or failure).
Public event | FileTransferProgress | Raised as file transfer is progressing.
Public event | ResponseReceived | Raised when FTP response has been received.
Top
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.BeginFileTransfer Event

Grid Solutions Framework FtpClientBeginFileTransfer Event
Raised when file transfer begins.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string, string, TransferDirection>> BeginFileTransfer
Public Event BeginFileTransfer As EventHandler(Of EventArgs(Of String, String, TransferDirection))
member BeginFileTransfer : IEvent<EventHandler<EventArgs<string, string, TransferDirection>>,
    EventArgs<string, string, TransferDirection>>

function add_BeginFileTransfer(value);
function remove_BeginFileTransfer(value);
public:
 event EventHandler<EventArgs<String^, String^, TransferDirection>^>^ BeginFileTransfer {
    void add (EventHandler<EventArgs<String^, String^, TransferDirection>^>^ value);
    void remove (EventHandler<EventArgs<String^, String^, TransferDirection>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String, String, TransferDirection
Remarks
Argument1 is local filename, Argument2 is remote filename, Argument3 is file transfer direction.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.CommandSent Event

Grid Solutions Framework FtpClientCommandSent Event
Raised when FTP command has been sent.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> CommandSent
Public Event CommandSent As EventHandler(Of EventArgs(Of String))
member CommandSent : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_CommandSent(value);
function remove_CommandSent(value);
public:
 event EventHandler<EventArgs<String^>^>^ CommandSent {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is sent FTP command.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.EndFileTransfer Event

Grid Solutions Framework FtpClientEndFileTransfer Event
Raised when file transfer completes.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string, string, TransferDirection>> EndFileTransfer
Public Event EndFileTransfer As EventHandler(Of EventArgs(Of String, String, TransferDirection))
member EndFileTransfer : IEvent<EventHandler<EventArgs<string, string, TransferDirection>>,
    EventArgs<string, string, TransferDirection>>

function add_EndFileTransfer(value);
function remove_EndFileTransfer(value);
public:
 event EventHandler<EventArgs<String^, String^, TransferDirection>^>^ EndFileTransfer {
    void add (EventHandler<EventArgs<String^, String^, TransferDirection>^>^ value);
    void remove (EventHandler<EventArgs<String^, String^, TransferDirection>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String, String, TransferDirection
Remarks
Argument1 is local filename, Argument2 is remote filename, Argument3 is file transfer direction.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.FileTransferNotification Event

Grid Solutions Framework FtpClientFileTransferNotification Event
Raised when ansynchronous file transfer process has completed (success or failure).

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<FtpAsyncResult>> FileTransferNotification
Public Event FileTransferNotification As EventHandler(Of EventArgs(Of FtpAsyncResult))
member FileTransferNotification : IEvent<EventHandler<EventArgs<FtpAsyncResult>>,
    EventArgs<FtpAsyncResult>>

function add_FileTransferNotification(value);
function remove_FileTransferNotification(value);
public:
 event EventHandler<EventArgs<FtpAsyncResult^>^>^ FileTransferNotification {
    void add (EventHandler<EventArgs<FtpAsyncResult^>^>^ value);
    void remove (EventHandler<EventArgs<FtpAsyncResult^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FtpAsyncResult
Remarks
Argument is result of asynchronous FTP transfer process.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.FileTransferProgress Event

Grid Solutions Framework FtpClientFileTransferProgress Event
Raised as file transfer is progressing.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ProcessProgress<long>, TransferDirection>> FileTransferProgress
Public Event FileTransferProgress As EventHandler(Of EventArgs(Of ProcessProgress(Of Long), TransferDirection))
member FileTransferProgress : IEvent<EventHandler<EventArgs<ProcessProgress<int64>, TransferDirection>>,
    EventArgs<ProcessProgress<int64>, TransferDirection>>

function add_FileTransferProgress(value);
function remove_FileTransferProgress(value);
public:
 event EventHandler<EventArgs<ProcessProgress<long long>^, TransferDirection>^>^ FileTransferProgress {
    void add (EventHandler<EventArgs<ProcessProgress<long long>^, TransferDirection>^>^ value);
    void remove (EventHandler<EventArgs<ProcessProgress<long long>^, TransferDirection>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ProcessProgress Int64 , TransferDirection
Remarks
Argument1 is current file transfer progress, Argument2 is file transfer direction.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpClient.ResponseReceived Event

Grid Solutions Framework FtpClientResponseReceived Event
Raised when FTP response has been received.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> ResponseReceived
Public Event ResponseReceived As EventHandler(Of EventArgs(Of String))
member ResponseReceived : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_ResponseReceived(value);
function remove_ResponseReceived(value);
public:
 event EventHandler<EventArgs<String^>^>^ ResponseReceived {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is received FTP response.
See Also

Reference

FtpClient Class
GSF.Net.Ftp Namespace


FtpCommandException Class

Grid Solutions Framework FtpCommandException Class
FTP command exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpCommandException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpCommandException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpCommandException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpCommandException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpCommandException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpCommandException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpCommandException : public FtpExceptionBase

The FtpCommandException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpCommandException Methods

Grid Solutions Framework FtpCommandException Methods

The FtpCommandException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpCommandException Class
GSF.Net.Ftp Namespace


FtpCommandException Properties

Grid Solutions Framework FtpCommandException Properties

The FtpCommandException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpCommandException Class
GSF.Net.Ftp Namespace


FtpCommandException Events

Grid Solutions Framework FtpCommandException Events

The FtpCommandException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpCommandException Class
GSF.Net.Ftp Namespace


FtpControlChannel Class

Grid Solutions Framework FtpControlChannel Class
FTP control channel.
Inheritance Hierarchy
SystemObject
GSF.Net.FtpFtpControlChannel

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpControlChannel : IDisposable
Public Class FtpControlChannel
    Implements IDisposable
type FtpControlChannel =
    class
        interface IDisposable
    end
GSF.Net.Ftp.FtpControlChannel = function();

Type.createClass(
    'GSF.Net.Ftp.FtpControlChannel',
    null,
    IDisposable);
public ref class FtpControlChannel : IDisposable

The FtpControlChannel type exposes the following members.

Methods
 | Name | Description
Public method | Close | Releases all the resources used by the FtpControlChannel object.
Public method | Command | Send FTP command to control channel.
Public method | Connect | Connects the FtpControlChannel.
Protected method | Dispose | Releases the unmanaged resources used by the FtpControlChannel object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the FtpControlChannel object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResponse | Refresh response from control channel.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | LastResponse | Last response from control channel.
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpControlChannel Methods

Grid Solutions Framework FtpControlChannel Methods

The FtpControlChannel type exposes the following members.

Methods
 | Name | Description
Public method | Close | Releases all the resources used by the FtpControlChannel object.
Public method | Command | Send FTP command to control channel.
Public method | Connect | Connects the FtpControlChannel.
Protected method | Dispose | Releases the unmanaged resources used by the FtpControlChannel object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the FtpControlChannel object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshResponse | Refresh response from control channel.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel.Close Method

Grid Solutions Framework FtpControlChannelClose Method
Releases all the resources used by the FtpControlChannel object.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel.Command Method

Grid Solutions Framework FtpControlChannelCommand Method
Send FTP command to control channel.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Command(
    string cmd
)
Public Sub Command (
    cmd As String
)
member Command :
        cmd : string -> unit

function Command(cmd);
public:
void Command(
    String^ cmd
)

Parameters

cmd
Type: SystemString
A String representing the command to send.
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel.Connect Method

Grid Solutions Framework FtpControlChannelConnect Method
Connects the FtpControlChannel.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Connect()
Public Sub Connect
member Connect : unit -> unit

function Connect();
public:
void Connect()
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel.Dispose Method

Grid Solutions Framework FtpControlChannelDispose Method
Releases the unmanaged resources used by the FtpControlChannel object and optionally releases the managed resources.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel.Finalize Method

Grid Solutions Framework FtpControlChannelFinalize Method
Releases the unmanaged resources before the FtpControlChannel object is reclaimed by GC.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel.RefreshResponse Method

Grid Solutions Framework FtpControlChannelRefreshResponse Method
Refresh response from control channel.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RefreshResponse()
Public Sub RefreshResponse
member RefreshResponse : unit -> unit

function RefreshResponse();
public:
void RefreshResponse()
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel Properties

Grid Solutions Framework FtpControlChannel Properties

The FtpControlChannel type exposes the following members.

Properties
 | Name | Description
Public property | LastResponse | Last response from control channel.
Top
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpControlChannel.LastResponse Property

Grid Solutions Framework FtpControlChannelLastResponse Property
Last response from control channel.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpResponse LastResponse { get; }
Public ReadOnly Property LastResponse As FtpResponse
    Get
member LastResponse : FtpResponse with get

function get_LastResponse();

public:
property FtpResponse^ LastResponse {
    FtpResponse^ get ();
}

Property Value

Type: FtpResponse
See Also

Reference

FtpControlChannel Class
GSF.Net.Ftp Namespace


FtpDataStream Class

Grid Solutions Framework FtpDataStream Class
FTP data stream.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.Net.FtpFtpDataStream
GSF.Net.FtpFtpInputDataStream
GSF.Net.FtpFtpOutputDataStream

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpDataStream : Stream
Public Class FtpDataStream
    Inherits Stream
type FtpDataStream =
    class
        inherit Stream
    end
GSF.Net.Ftp.FtpDataStream = function();

Type.createClass(
    'GSF.Net.Ftp.FtpDataStream',
    Stream);
public ref class FtpDataStream : public Stream

The FtpDataStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the FTP stream and releases any resources associated with the stream. (Overrides StreamClose.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Overrides StreamReadByte.)
Public method | Seek | Sets the position within the current stream. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | Sets the length of the current stream. (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Overrides StreamWriteByte(Byte).)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Overrides StreamCanWrite.)
Public property | Length | Gets the length in bytes of the stream. (Overrides StreamLength.)
Public property | Position | Gets or sets the position within the current stream. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpDataStream Methods

Grid Solutions Framework FtpDataStream Methods

The FtpDataStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the FTP stream and releases any resources associated with the stream. (Overrides StreamClose.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Overrides StreamReadByte.)
Public method | Seek | Sets the position within the current stream. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | Sets the length of the current stream. (Overrides StreamSetLength(Int64).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Overrides StreamWriteByte(Byte).)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.Close Method

Grid Solutions Framework FtpDataStreamClose Method
Closes the FTP stream and releases any resources associated with the stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Close()
Public Overrides Sub Close
abstract Close : unit -> unit
override Close : unit -> unit
function Close();
public:
virtual void Close() override
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.Flush Method

Grid Solutions Framework FtpDataStreamFlush Method
Clears all buffers for this stream and causes any buffered data to be written to the underlying device.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Flush()
Public Overrides Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush() override
Exceptions
Exception | Condition
IOException | An I/O error occurs.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.Read Method

Grid Solutions Framework FtpDataStreamRead Method
Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
function Read(buffer, offset, count);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
Type: SystemInt32
The maximum number of bytes to be read from the current stream.

Return Value

Type: Int32
The total number of bytes read into the buffer. This can be less than the number of bytes requested if that many bytes are not currently available, or zero (0) if the end of the stream has been reached.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.ReadByte Method

Grid Solutions Framework FtpDataStreamReadByte Method
Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ReadByte()
Public Overrides Function ReadByte As Integer
abstract ReadByte : unit -> int
override ReadByte : unit -> int
function ReadByte();
public:
virtual int ReadByte() override

Return Value

Type: Int32
The unsigned byte cast to an Int32, or -1 if at the end of the stream.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.Seek Method

Grid Solutions Framework FtpDataStreamSeek Method
Sets the position within the current stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Seek(
    long offset,
    SeekOrigin origin
)
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
function Seek(offset, origin);
public:
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: SystemInt64
A byte offset relative to the origin parameter.
origin
Type: System.IOSeekOrigin
A value of type SeekOrigin indicating the reference point used to obtain the new position.

Return Value

Type: Int64
The new position within the current stream.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | Stream does not support seeking.
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.SetLength Method

Grid Solutions Framework FtpDataStreamSetLength Method
Sets the length of the current stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SetLength(
    long len
)
Public Overrides Sub SetLength (
    len As Long
)
abstract SetLength :
        len : int64 -> unit
override SetLength :
        len : int64 -> unit
function SetLength(len);
public:
virtual void SetLength(
    long long len
) override

Parameters

len
Type: SystemInt64
The desired length of the current stream in bytes.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.Write Method

Grid Solutions Framework FtpDataStreamWrite Method
When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Write(buffer, offset, count);
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
An array of bytes. When this method returns, the buffer contains the specified byte array with the values between offset and (offset + count - 1) replaced by the bytes read from the current source.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin storing the data read from the current stream.
count
Type: SystemInt32
The maximum number of bytes to be read from the current stream.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.WriteByte Method

Grid Solutions Framework FtpDataStreamWriteByte Method
Writes a byte to the current position in the stream and advances the position within the stream by one byte.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void WriteByte(
    byte b
)
Public Overrides Sub WriteByte (
    b As Byte
)
abstract WriteByte :
        b : byte -> unit
override WriteByte :
        b : byte -> unit
function WriteByte(b);
public:
virtual void WriteByte(
    unsigned char b
) override

Parameters

b
Type: SystemByte
The byte to write to the stream.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream Properties

Grid Solutions Framework FtpDataStream Properties

The FtpDataStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Overrides StreamCanWrite.)
Public property | Length | Gets the length in bytes of the stream. (Overrides StreamLength.)
Public property | Position | Gets or sets the position within the current stream. (Overrides StreamPosition.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.CanRead Property

Grid Solutions Framework FtpDataStreamCanRead Property
Gets a value indicating whether the current stream supports reading.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Return Value

Type: Boolean
true if the stream supports reading; otherwise, false.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.CanSeek Property

Grid Solutions Framework FtpDataStreamCanSeek Property
Gets a value indicating whether the current stream supports seeking.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
abstract CanSeek : bool with get
override CanSeek : bool with get
function get_CanSeek();

public:
virtual property bool CanSeek {
    bool get () override;
}

Return Value

Type: Boolean
true if the stream supports seeking; otherwise, false.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.CanWrite Property

Grid Solutions Framework FtpDataStreamCanWrite Property
Gets a value indicating whether the current stream supports writing.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Return Value

Type: Boolean
true if the stream supports writing; otherwise, false.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.Length Property

Grid Solutions Framework FtpDataStreamLength Property
Gets the length in bytes of the stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Length { get; }
Public Overrides ReadOnly Property Length As Long
    Get
abstract Length : int64 with get
override Length : int64 with get
function get_Length();

public:
virtual property long long Length {
    long long get () override;
}

Return Value

Type: Int64
A long value representing the length of the stream in bytes.
Exceptions
Exception | Condition
NotSupportedException | Stream does not support seeking.
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataStream.Position Property

Grid Solutions Framework FtpDataStreamPosition Property
Gets or sets the position within the current stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long Position { get; set; }
Public Overrides Property Position As Long
    Get
    Set
abstract Position : int64 with get, set
override Position : int64 with get, set
function get_Position();
function set_Position(value);
public:
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Return Value

Type: Int64
The current position within the stream.
Exceptions
Exception | Condition
IOException | An I/O error occurs.
NotSupportedException | Stream does not support seeking.
ObjectDisposedException | Methods were called after the stream was closed.
See Also

Reference

FtpDataStream Class
GSF.Net.Ftp Namespace


FtpDataTransferException Class

Grid Solutions Framework FtpDataTransferException Class
FTP data transfer exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpDataTransferException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpDataTransferException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpDataTransferException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpDataTransferException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpDataTransferException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpDataTransferException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpDataTransferException : public FtpExceptionBase

The FtpDataTransferException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpDataTransferException Methods

Grid Solutions Framework FtpDataTransferException Methods

The FtpDataTransferException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpDataTransferException Class
GSF.Net.Ftp Namespace


FtpDataTransferException Properties

Grid Solutions Framework FtpDataTransferException Properties

The FtpDataTransferException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpDataTransferException Class
GSF.Net.Ftp Namespace


FtpDataTransferException Events

Grid Solutions Framework FtpDataTransferException Events

The FtpDataTransferException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpDataTransferException Class
GSF.Net.Ftp Namespace


FtpDirectory Class

Grid Solutions Framework FtpDirectory Class
Represents a FTP directory.
Inheritance Hierarchy
SystemObject
GSF.Net.FtpFtpDirectory

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpDirectory : IFtpFile,
    IComparable, IComparable<IFtpFile>, IComparable<FtpDirectory>
Public Class FtpDirectory
    Implements IFtpFile, IComparable, IComparable(Of IFtpFile),
    IComparable(Of FtpDirectory)
type FtpDirectory =
    class
        interface IFtpFile
        interface IComparable
        interface IComparable<IFtpFile>
        interface IComparable<FtpDirectory>
    end
GSF.Net.Ftp.FtpDirectory = function();

Type.createClass(
    'GSF.Net.Ftp.FtpDirectory',
    null,
    GSF.Net.Ftp.IFtpFile,
    IComparable,
    IComparable`1,
    IComparable`1);
public ref class FtpDirectory : IFtpFile,
    IComparable, IComparable<IFtpFile^>, IComparable<FtpDirectory^>

The FtpDirectory type exposes the following members.

Methods
 | Name | Description
Public method | BeginGetFile(String) | Starts asynchronous remote file download from directory.
Public method | BeginGetFile(String, String) | Starts asynchronous remote file download from directory using alternate local filename.
Public method | BeginPutFile(String) | Starts asynchrnonous local file upload to directory.
Public method | BeginPutFile(String, String) | Starts asynchrnonous local file upload to directory using alternate name.
Public method | CompareTo | Compares directory or file to another.
Public method | CreateFile | Creates a new zero-length remote file in directory.
Public method | CreateFileStream | Creates a new data stream for remote file in directory.
Public method | Equals | Determines if the two FtpDirectory objects are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFile | Finds matching file name in directory.
Public method | FindSubDirectory | Finds matching subdirectory name in directory.
Public method | GetFile(String) | Downloads remote file from directory.
Public method | GetFile(String, String) | Downloads remote file from directory using alternate local filename.
Public method | GetHashCode | Generates hash code for this FtpDirectory. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutFile(String) | Uploads local file to directory.
Public method | PutFile(String, String) | Uploads local file to directory using alternate name.
Public method | Refresh | Refreshes directory listing.
Public method | RemoveFile | Removes file from directory.
Public method | RemoveSubDir | Removes subdirectory from directory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality | Compares the two values for equality.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CaseInsensitive | Gets or sets FTP case sensitivity of file and directory names.
Public property | Files | Gets files of directory.
Public property | FullPath | Full path of directory.
Public property | IsDirectory | Returns true for directory entries.
Public property | IsFile | Returns false for directory entries.
Public property | Name | Name of directory.
Public property | Parent | Gets parent directory of directory.
Public property | Permission | Gets or sets permission of directory.
Public property | Size | Gets or sets size of directory.
Public property | SubDirectories | Gets sub directories of directory.
Public property | Timestamp | Gets or sets timestamp of directory.
Top
Events
 | Name | Description
Public event | DirectoryListLineScan | Raised when new directory line is scanned.
Public event | DirectoryScanException | Raised when there is an exception scanning a directory.
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpDirectory Methods

Grid Solutions Framework FtpDirectory Methods

The FtpDirectory type exposes the following members.

Methods
 | Name | Description
Public method | BeginGetFile(String) | Starts asynchronous remote file download from directory.
Public method | BeginGetFile(String, String) | Starts asynchronous remote file download from directory using alternate local filename.
Public method | BeginPutFile(String) | Starts asynchrnonous local file upload to directory.
Public method | BeginPutFile(String, String) | Starts asynchrnonous local file upload to directory using alternate name.
Public method | CompareTo | Compares directory or file to another.
Public method | CreateFile | Creates a new zero-length remote file in directory.
Public method | CreateFileStream | Creates a new data stream for remote file in directory.
Public method | Equals | Determines if the two FtpDirectory objects are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindFile | Finds matching file name in directory.
Public method | FindSubDirectory | Finds matching subdirectory name in directory.
Public method | GetFile(String) | Downloads remote file from directory.
Public method | GetFile(String, String) | Downloads remote file from directory using alternate local filename.
Public method | GetHashCode | Generates hash code for this FtpDirectory. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PutFile(String) | Uploads local file to directory.
Public method | PutFile(String, String) | Uploads local file to directory using alternate name.
Public method | Refresh | Refreshes directory listing.
Public method | RemoveFile | Removes file from directory.
Public method | RemoveSubDir | Removes subdirectory from directory.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.BeginGetFile Method

Grid Solutions Framework FtpDirectoryBeginGetFile Method
Overload List
 | Name | Description
Public method | BeginGetFile(String) | Starts asynchronous remote file download from directory.
Public method | BeginGetFile(String, String) | Starts asynchronous remote file download from directory using alternate local filename.
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.BeginGetFile Method (String)

Grid Solutions Framework FtpDirectoryBeginGetFile Method (String)
Starts asynchronous remote file download from directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void BeginGetFile(
    string remoteFile
)
Public Sub BeginGetFile (
    remoteFile As String
)
member BeginGetFile :
        remoteFile : string -> unit

function BeginGetFile(remoteFile);
public:
void BeginGetFile(
    String^ remoteFile
)

Parameters

remoteFile
Type: SystemString
Remote filename to download.
See Also

Reference

FtpDirectory Class
BeginGetFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.BeginGetFile Method (String, String)

Grid Solutions Framework FtpDirectoryBeginGetFile Method (String, String)
Starts asynchronous remote file download from directory using alternate local filename.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void BeginGetFile(
    string localFile,
    string remoteFile
)
Public Sub BeginGetFile (
    localFile As String,
    remoteFile As String
)
member BeginGetFile :
        localFile : string *
        remoteFile : string -> unit

function BeginGetFile(localFile, remoteFile);
public:
void BeginGetFile(
    String^ localFile,
    String^ remoteFile
)

Parameters

localFile
Type: SystemString
Local filename to use for download.
remoteFile
Type: SystemString
Remote filename to download.
See Also

Reference

FtpDirectory Class
BeginGetFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.BeginPutFile Method

Grid Solutions Framework FtpDirectoryBeginPutFile Method
Overload List
 | Name | Description
Public method | BeginPutFile(String) | Starts asynchrnonous local file upload to directory.
Public method | BeginPutFile(String, String) | Starts asynchrnonous local file upload to directory using alternate name.
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.BeginPutFile Method (String)

Grid Solutions Framework FtpDirectoryBeginPutFile Method (String)
Starts asynchrnonous local file upload to directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void BeginPutFile(
    string localFile
)
Public Sub BeginPutFile (
    localFile As String
)
member BeginPutFile :
        localFile : string -> unit

function BeginPutFile(localFile);
public:
void BeginPutFile(
    String^ localFile
)

Parameters

localFile
Type: SystemString
Local file to upload.
See Also

Reference

FtpDirectory Class
BeginPutFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.BeginPutFile Method (String, String)

Grid Solutions Framework FtpDirectoryBeginPutFile Method (String, String)
Starts asynchrnonous local file upload to directory using alternate name.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void BeginPutFile(
    string localFile,
    string remoteFile
)
Public Sub BeginPutFile (
    localFile As String,
    remoteFile As String
)
member BeginPutFile :
        localFile : string *
        remoteFile : string -> unit

function BeginPutFile(localFile, remoteFile);
public:
void BeginPutFile(
    String^ localFile,
    String^ remoteFile
)

Parameters

localFile
Type: SystemString
Local file to upload.
remoteFile
Type: SystemString
Remote filename to use for upload.
See Also

Reference

FtpDirectory Class
BeginPutFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.CompareTo Method

Grid Solutions Framework FtpDirectoryCompareTo Method
Compares directory or file to another.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: SystemObject
An Object to compare against.

Return Value

Type: Int32
An Int32 value representing the result. 1 - obj is greater than, 0 - obj is equal to, -1 - obj is less than.

Implements

IComparableCompareTo(Object)
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.CreateFile Method

Grid Solutions Framework FtpDirectoryCreateFile Method
Creates a new zero-length remote file in directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpFile CreateFile(
    string newFileName
)
Public Function CreateFile (
    newFileName As String
) As FtpFile
member CreateFile :
        newFileName : string -> FtpFile

function CreateFile(newFileName);
public:
FtpFile^ CreateFile(
    String^ newFileName
)

Parameters

newFileName
Type: SystemString
New remote file name.

Return Value

Type: FtpFile
File reference to new zero-length remote file.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.CreateFileStream Method

Grid Solutions Framework FtpDirectoryCreateFileStream Method
Creates a new data stream for remote file in directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpOutputDataStream CreateFileStream(
    string newFileName
)
Public Function CreateFileStream (
    newFileName As String
) As FtpOutputDataStream
member CreateFileStream :
        newFileName : string -> FtpOutputDataStream

function CreateFileStream(newFileName);
public:
FtpOutputDataStream^ CreateFileStream(
    String^ newFileName
)

Parameters

newFileName
Type: SystemString
New remote file name.

Return Value

Type: FtpOutputDataStream
Output data stream for new remote file.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Equals Method

Grid Solutions Framework FtpDirectoryEquals Method
Determines if the two FtpDirectory objects are equal.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Other object to compare.

Return Value

Type: Boolean
true if both objects are equal.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.FindFile Method

Grid Solutions Framework FtpDirectoryFindFile Method
Finds matching file name in directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpFile FindFile(
    string fileName
)
Public Function FindFile (
    fileName As String
) As FtpFile
member FindFile :
        fileName : string -> FtpFile

function FindFile(fileName);
public:
FtpFile^ FindFile(
    String^ fileName
)

Parameters

fileName
Type: SystemString
FileName to find in directory.

Return Value

Type: FtpFile
File reference, if found, otherwise null if file is not found.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.FindSubDirectory Method

Grid Solutions Framework FtpDirectoryFindSubDirectory Method
Finds matching subdirectory name in directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpDirectory FindSubDirectory(
    string dirName
)
Public Function FindSubDirectory (
    dirName As String
) As FtpDirectory
member FindSubDirectory :
        dirName : string -> FtpDirectory

function FindSubDirectory(dirName);
public:
FtpDirectory^ FindSubDirectory(
    String^ dirName
)

Parameters

dirName
Type: SystemString
Subdirectory name to find in directory.

Return Value

Type: FtpDirectory
Subdirectory reference, if found, otherwise null if subdirectory is not found.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.GetFile Method

Grid Solutions Framework FtpDirectoryGetFile Method
Overload List
 | Name | Description
Public method | GetFile(String) | Downloads remote file from directory.
Public method | GetFile(String, String) | Downloads remote file from directory using alternate local filename.
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.GetFile Method (String)

Grid Solutions Framework FtpDirectoryGetFile Method (String)
Downloads remote file from directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetFile(
    string remoteFile
)
Public Sub GetFile (
    remoteFile As String
)
member GetFile :
        remoteFile : string -> unit

function GetFile(remoteFile);
public:
void GetFile(
    String^ remoteFile
)

Parameters

remoteFile
Type: SystemString
Remote filename to download.
See Also

Reference

FtpDirectory Class
GetFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.GetFile Method (String, String)

Grid Solutions Framework FtpDirectoryGetFile Method (String, String)
Downloads remote file from directory using alternate local filename.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetFile(
    string localFile,
    string remoteFile
)
Public Sub GetFile (
    localFile As String,
    remoteFile As String
)
member GetFile :
        localFile : string *
        remoteFile : string -> unit

function GetFile(localFile, remoteFile);
public:
void GetFile(
    String^ localFile,
    String^ remoteFile
)

Parameters

localFile
Type: SystemString
Local filename to use for download.
remoteFile
Type: SystemString
Remote filename to download.
See Also

Reference

FtpDirectory Class
GetFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.GetHashCode Method

Grid Solutions Framework FtpDirectoryGetHashCode Method
Generates hash code for this FtpDirectory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
An Int32 value as the result.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.PutFile Method

Grid Solutions Framework FtpDirectoryPutFile Method
Overload List
 | Name | Description
Public method | PutFile(String) | Uploads local file to directory.
Public method | PutFile(String, String) | Uploads local file to directory using alternate name.
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.PutFile Method (String)

Grid Solutions Framework FtpDirectoryPutFile Method (String)
Uploads local file to directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void PutFile(
    string localFile
)
Public Sub PutFile (
    localFile As String
)
member PutFile :
        localFile : string -> unit

function PutFile(localFile);
public:
void PutFile(
    String^ localFile
)

Parameters

localFile
Type: SystemString
Local file to upload.
See Also

Reference

FtpDirectory Class
PutFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.PutFile Method (String, String)

Grid Solutions Framework FtpDirectoryPutFile Method (String, String)
Uploads local file to directory using alternate name.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void PutFile(
    string localFile,
    string remoteFile
)
Public Sub PutFile (
    localFile As String,
    remoteFile As String
)
member PutFile :
        localFile : string *
        remoteFile : string -> unit

function PutFile(localFile, remoteFile);
public:
void PutFile(
    String^ localFile,
    String^ remoteFile
)

Parameters

localFile
Type: SystemString
Local file to upload.
remoteFile
Type: SystemString
Remote filename to use for upload.
See Also

Reference

FtpDirectory Class
PutFile Overload
GSF.Net.Ftp Namespace


FtpDirectory.Refresh Method

Grid Solutions Framework FtpDirectoryRefresh Method
Refreshes directory listing.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Refresh()
Public Sub Refresh
member Refresh : unit -> unit

function Refresh();
public:
void Refresh()
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.RemoveFile Method

Grid Solutions Framework FtpDirectoryRemoveFile Method
Removes file from directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveFile(
    string fileName
)
Public Sub RemoveFile (
    fileName As String
)
member RemoveFile :
        fileName : string -> unit

function RemoveFile(fileName);
public:
void RemoveFile(
    String^ fileName
)

Parameters

fileName
Type: SystemString
Remote filename to remove.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.RemoveSubDir Method

Grid Solutions Framework FtpDirectoryRemoveSubDir Method
Removes subdirectory from directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveSubDir(
    string dirName
)
Public Sub RemoveSubDir (
    dirName As String
)
member RemoveSubDir :
        dirName : string -> unit

function RemoveSubDir(dirName);
public:
void RemoveSubDir(
    String^ dirName
)

Parameters

dirName
Type: SystemString
Subdirectory name to remove.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory Operators

Grid Solutions Framework FtpDirectory Operators

The FtpDirectory type exposes the following members.

Operators
Name | Description
Equality | Compares the two values for equality.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Equality Operator

Grid Solutions Framework FtpDirectoryEquality Operator
Compares the two values for equality.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    FtpDirectory value1,
    FtpDirectory value2
)
Public Shared Operator = (
    value1 As FtpDirectory,
    value2 As FtpDirectory
) As Boolean
static let inline (=)
        value1 : FtpDirectory *
        value2 : FtpDirectory  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    FtpDirectory^ value1,
    FtpDirectory^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory left hand operand.
value2
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.GreaterThan Operator

Grid Solutions Framework FtpDirectoryGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    FtpDirectory value1,
    FtpDirectory value2
)
Public Shared Operator > (
    value1 As FtpDirectory,
    value2 As FtpDirectory
) As Boolean
static let inline (>)
        value1 : FtpDirectory *
        value2 : FtpDirectory  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    FtpDirectory^ value1,
    FtpDirectory^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory left hand operand.
value2
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.GreaterThanOrEqual Operator

Grid Solutions Framework FtpDirectoryGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    FtpDirectory value1,
    FtpDirectory value2
)
Public Shared Operator >= (
    value1 As FtpDirectory,
    value2 As FtpDirectory
) As Boolean
static let inline (>=)
        value1 : FtpDirectory *
        value2 : FtpDirectory  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    FtpDirectory^ value1,
    FtpDirectory^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory left hand operand.
value2
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Inequality Operator

Grid Solutions Framework FtpDirectoryInequality Operator
Compares the two values for inequality.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    FtpDirectory value1,
    FtpDirectory value2
)
Public Shared Operator <> (
    value1 As FtpDirectory,
    value2 As FtpDirectory
) As Boolean
static let inline (<>)
        value1 : FtpDirectory *
        value2 : FtpDirectory  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    FtpDirectory^ value1,
    FtpDirectory^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory left hand operand.
value2
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.LessThan Operator

Grid Solutions Framework FtpDirectoryLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    FtpDirectory value1,
    FtpDirectory value2
)
Public Shared Operator < (
    value1 As FtpDirectory,
    value2 As FtpDirectory
) As Boolean
static let inline (<)
        value1 : FtpDirectory *
        value2 : FtpDirectory  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    FtpDirectory^ value1,
    FtpDirectory^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory left hand operand.
value2
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.LessThanOrEqual Operator

Grid Solutions Framework FtpDirectoryLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    FtpDirectory value1,
    FtpDirectory value2
)
Public Shared Operator <= (
    value1 As FtpDirectory,
    value2 As FtpDirectory
) As Boolean
static let inline (<=)
        value1 : FtpDirectory *
        value2 : FtpDirectory  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    FtpDirectory^ value1,
    FtpDirectory^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory left hand operand.
value2
Type: GSF.Net.FtpFtpDirectory
A FtpDirectory right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory Properties

Grid Solutions Framework FtpDirectory Properties

The FtpDirectory type exposes the following members.

Properties
 | Name | Description
Public property | CaseInsensitive | Gets or sets FTP case sensitivity of file and directory names.
Public property | Files | Gets files of directory.
Public property | FullPath | Full path of directory.
Public property | IsDirectory | Returns true for directory entries.
Public property | IsFile | Returns false for directory entries.
Public property | Name | Name of directory.
Public property | Parent | Gets parent directory of directory.
Public property | Permission | Gets or sets permission of directory.
Public property | Size | Gets or sets size of directory.
Public property | SubDirectories | Gets sub directories of directory.
Public property | Timestamp | Gets or sets timestamp of directory.
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.CaseInsensitive Property

Grid Solutions Framework FtpDirectoryCaseInsensitive Property
Gets or sets FTP case sensitivity of file and directory names.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CaseInsensitive { get; set; }
Public Property CaseInsensitive As Boolean
    Get
    Set
member CaseInsensitive : bool with get, set

function get_CaseInsensitive();
function set_CaseInsensitive(value);
public:
property bool CaseInsensitive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Set to true to not be case sensitive with FTP file and directory names.
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Files Property

Grid Solutions Framework FtpDirectoryFiles Property
Gets files of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DictionaryTKey, TValueValueCollection Files { get; }
Public ReadOnly Property Files As DictionaryTKey, TValueValueCollection
    Get
member Files : DictionaryTKey, TValueValueCollection with get

function get_Files();

public:
property DictionaryTKey, TValueValueCollection^ Files {
    DictionaryTKey, TValueValueCollection^ get ();
}

Property Value

Type: DictionaryTKey, TValueValueCollection
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.FullPath Property

Grid Solutions Framework FtpDirectoryFullPath Property
Full path of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
abstract FullPath : string with get
override FullPath : string with get
function get_FullPath();

public:
virtual property String^ FullPath {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IFtpFileFullPath
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.IsDirectory Property

Grid Solutions Framework FtpDirectoryIsDirectory Property
Returns true for directory entries.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDirectory { get; }
Public ReadOnly Property IsDirectory As Boolean
    Get
abstract IsDirectory : bool with get
override IsDirectory : bool with get
function get_IsDirectory();

public:
virtual property bool IsDirectory {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IFtpFileIsDirectory
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.IsFile Property

Grid Solutions Framework FtpDirectoryIsFile Property
Returns false for directory entries.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsFile { get; }
Public ReadOnly Property IsFile As Boolean
    Get
abstract IsFile : bool with get
override IsFile : bool with get
function get_IsFile();

public:
virtual property bool IsFile {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IFtpFileIsFile
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Name Property

Grid Solutions Framework FtpDirectoryName Property
Name of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IFtpFileName
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Parent Property

Grid Solutions Framework FtpDirectoryParent Property
Gets parent directory of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpDirectory Parent { get; }
Public ReadOnly Property Parent As FtpDirectory
    Get
abstract Parent : FtpDirectory with get
override Parent : FtpDirectory with get
function get_Parent();

public:
virtual property FtpDirectory^ Parent {
    FtpDirectory^ get () sealed;
}

Property Value

Type: FtpDirectory

Implements

IFtpFileParent
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Permission Property

Grid Solutions Framework FtpDirectoryPermission Property
Gets or sets permission of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Permission { get; set; }
Public Property Permission As String
    Get
    Set
abstract Permission : string with get, set
override Permission : string with get, set
function get_Permission();
function set_Permission(value);
public:
virtual property String^ Permission {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IFtpFilePermission
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Size Property

Grid Solutions Framework FtpDirectorySize Property
Gets or sets size of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Size { get; set; }
Public Property Size As Long
    Get
    Set
abstract Size : int64 with get, set
override Size : int64 with get, set
function get_Size();
function set_Size(value);
public:
virtual property long long Size {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IFtpFileSize
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.SubDirectories Property

Grid Solutions Framework FtpDirectorySubDirectories Property
Gets sub directories of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DictionaryTKey, TValueValueCollection SubDirectories { get; }
Public ReadOnly Property SubDirectories As DictionaryTKey, TValueValueCollection
    Get
member SubDirectories : DictionaryTKey, TValueValueCollection with get

function get_SubDirectories();

public:
property DictionaryTKey, TValueValueCollection^ SubDirectories {
    DictionaryTKey, TValueValueCollection^ get ();
}

Property Value

Type: DictionaryTKey, TValueValueCollection
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.Timestamp Property

Grid Solutions Framework FtpDirectoryTimestamp Property
Gets or sets timestamp of directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
abstract Timestamp : DateTime with get, set
override Timestamp : DateTime with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property DateTime Timestamp {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime

Implements

IFtpFileTimestamp
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory Events

Grid Solutions Framework FtpDirectory Events

The FtpDirectory type exposes the following members.

Events
 | Name | Description
Public event | DirectoryListLineScan | Raised when new directory line is scanned.
Public event | DirectoryScanException | Raised when there is an exception scanning a directory.
Top
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.DirectoryListLineScan Event

Grid Solutions Framework FtpDirectoryDirectoryListLineScan Event
Raised when new directory line is scanned.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event Action<string> DirectoryListLineScan
Public Event DirectoryListLineScan As Action(Of String)
member DirectoryListLineScan : IEvent<Action<string>,
    EventArgs>

function add_DirectoryListLineScan(value);
function remove_DirectoryListLineScan(value);
public:
 event Action<String^>^ DirectoryListLineScan {
    void add (Action<String^>^ value);
    void remove (Action<String^>^ value);
}

Value

Type: SystemAction String
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpDirectory.DirectoryScanException Event

Grid Solutions Framework FtpDirectoryDirectoryScanException Event
Raised when there is an exception scanning a directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event Action<FtpExceptionBase> DirectoryScanException
Public Event DirectoryScanException As Action(Of FtpExceptionBase)
member DirectoryScanException : IEvent<Action<FtpExceptionBase>,
    EventArgs>

function add_DirectoryScanException(value);
function remove_DirectoryScanException(value);
public:
 event Action<FtpExceptionBase^>^ DirectoryScanException {
    void add (Action<FtpExceptionBase^>^ value);
    void remove (Action<FtpExceptionBase^>^ value);
}

Value

Type: SystemAction FtpExceptionBase
See Also

Reference

FtpDirectory Class
GSF.Net.Ftp Namespace


FtpExceptionBase Class

Grid Solutions Framework FtpExceptionBase Class
FTP exception base class.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
More...

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class FtpExceptionBase : Exception
<SerializableAttribute>
Public MustInherit Class FtpExceptionBase
    Inherits Exception
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type FtpExceptionBase =
    class
        inherit Exception
    end
GSF.Net.Ftp.FtpExceptionBase = function();

Type.createClass(
    'GSF.Net.Ftp.FtpExceptionBase',
    Exception);
[SerializableAttribute]
public ref class FtpExceptionBase abstract : public Exception

The FtpExceptionBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpAuthenticationException
GSF.Net.FtpFtpCommandException
GSF.Net.FtpFtpDataTransferException
GSF.Net.FtpFtpFileNotFoundException
GSF.Net.FtpFtpInvalidResponseException
GSF.Net.FtpFtpResumeNotSupportedException
GSF.Net.FtpFtpServerDownException
GSF.Net.FtpFtpUserAbortException


FtpExceptionBase Methods

Grid Solutions Framework FtpExceptionBase Methods

The FtpExceptionBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Overrides ExceptionGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpExceptionBase Class
GSF.Net.Ftp Namespace


FtpExceptionBase.GetObjectData Method

Grid Solutions Framework FtpExceptionBaseGetObjectData Method
Derserializes the FtpExceptionBase.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
_ExceptionGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FtpExceptionBase Class
GSF.Net.Ftp Namespace


FtpExceptionBase Properties

Grid Solutions Framework FtpExceptionBase Properties

The FtpExceptionBase type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any.
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpExceptionBase Class
GSF.Net.Ftp Namespace


FtpExceptionBase.ResponseMessage Property

Grid Solutions Framework FtpExceptionBaseResponseMessage Property
Response message related to exception, if any.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ResponseMessage { get; }
Public ReadOnly Property ResponseMessage As String
    Get
member ResponseMessage : string with get

function get_ResponseMessage();

public:
property String^ ResponseMessage {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

FtpExceptionBase Class
GSF.Net.Ftp Namespace


FtpExceptionBase Events

Grid Solutions Framework FtpExceptionBase Events

The FtpExceptionBase type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpExceptionBase Class
GSF.Net.Ftp Namespace


FtpFile Class

Grid Solutions Framework FtpFile Class
Represents a FTP file.
Inheritance Hierarchy
SystemObject
GSF.Net.FtpFtpFile

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpFile : IFtpFile, IComparable,
    IComparable<IFtpFile>, IComparable<FtpFile>
Public Class FtpFile
    Implements IFtpFile, IComparable, IComparable(Of IFtpFile),
    IComparable(Of FtpFile)
type FtpFile =
    class
        interface IFtpFile
        interface IComparable
        interface IComparable<IFtpFile>
        interface IComparable<FtpFile>
    end
GSF.Net.Ftp.FtpFile = function();

Type.createClass(
    'GSF.Net.Ftp.FtpFile',
    null,
    GSF.Net.Ftp.IFtpFile,
    IComparable,
    IComparable`1,
    IComparable`1);
public ref class FtpFile : IFtpFile,
    IComparable, IComparable<IFtpFile^>, IComparable<FtpFile^>

The FtpFile type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares directory or file to another.
Public method | Equals | Determines if the two FtpFile objects are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Generates hash code for this FtpFile. (Overrides ObjectGetHashCode.)
Public method | GetInputStream | Gets FTP input stream for file.
Public method | GetInputStream(Int64) | Gets FTP input stream for file at given offset.
Public method | GetOutputStream | Gets FTP output stream for file.
Public method | GetOutputStream(Int64) | Gets FTP output stream for file at given offset.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality | Compares the two values for equality.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | FullPath | Full path of file.
Public property | IsDirectory | Returns false for directory entries.
Public property | IsFile | Returns true for file entries.
Public property | Name | Name of file.
Public property | Parent | Gets parent directory of file.
Public property | Permission | Gets or sets permission of file.
Public property | Size | Gets or sets size of file.
Public property | Timestamp | Gets or sets timestamp of file.
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpFile Methods

Grid Solutions Framework FtpFile Methods

The FtpFile type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo | Compares directory or file to another.
Public method | Equals | Determines if the two FtpFile objects are equal. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Generates hash code for this FtpFile. (Overrides ObjectGetHashCode.)
Public method | GetInputStream | Gets FTP input stream for file.
Public method | GetInputStream(Int64) | Gets FTP input stream for file at given offset.
Public method | GetOutputStream | Gets FTP output stream for file.
Public method | GetOutputStream(Int64) | Gets FTP output stream for file at given offset.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.CompareTo Method

Grid Solutions Framework FtpFileCompareTo Method
Compares directory or file to another.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: SystemObject
An Object to compare against.

Return Value

Type: Int32
An Int32 that represents the result of the comparison. 1 - object is greater than, 0 - object is equal to, -1 - object is less than.

Implements

IComparableCompareTo(Object)
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Equals Method

Grid Solutions Framework FtpFileEquals Method
Determines if the two FtpFile objects are equal.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
Other object to compare.

Return Value

Type: Boolean
true if both objects are equal.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.GetHashCode Method

Grid Solutions Framework FtpFileGetHashCode Method
Generates hash code for this FtpFile.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
An Int32 representing the hash code.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.GetInputStream Method

Grid Solutions Framework FtpFileGetInputStream Method
Overload List
 | Name | Description
Public method | GetInputStream | Gets FTP input stream for file.
Public method | GetInputStream(Int64) | Gets FTP input stream for file at given offset.
Top
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.GetInputStream Method

Grid Solutions Framework FtpFileGetInputStream Method
Gets FTP input stream for file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpInputDataStream GetInputStream()
Public Function GetInputStream As FtpInputDataStream
member GetInputStream : unit -> FtpInputDataStream

function GetInputStream();
public:
FtpInputDataStream^ GetInputStream()

Return Value

Type: FtpInputDataStream
FTP input stream for file.
See Also

Reference

FtpFile Class
GetInputStream Overload
GSF.Net.Ftp Namespace


FtpFile.GetInputStream Method (Int64)

Grid Solutions Framework FtpFileGetInputStream Method (Int64)
Gets FTP input stream for file at given offset.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpInputDataStream GetInputStream(
    long offset
)
Public Function GetInputStream (
    offset As Long
) As FtpInputDataStream
member GetInputStream :
        offset : int64 -> FtpInputDataStream

function GetInputStream(offset);
public:
FtpInputDataStream^ GetInputStream(
    long long offset
)

Parameters

offset
Type: SystemInt64
Offset into stream to start.

Return Value

Type: FtpInputDataStream
FTP input stream for file.
See Also

Reference

FtpFile Class
GetInputStream Overload
GSF.Net.Ftp Namespace


FtpFile.GetOutputStream Method

Grid Solutions Framework FtpFileGetOutputStream Method
Overload List
 | Name | Description
Public method | GetOutputStream | Gets FTP output stream for file.
Public method | GetOutputStream(Int64) | Gets FTP output stream for file at given offset.
Top
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.GetOutputStream Method

Grid Solutions Framework FtpFileGetOutputStream Method
Gets FTP output stream for file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpOutputDataStream GetOutputStream()
Public Function GetOutputStream As FtpOutputDataStream
member GetOutputStream : unit -> FtpOutputDataStream

function GetOutputStream();
public:
FtpOutputDataStream^ GetOutputStream()

Return Value

Type: FtpOutputDataStream
FTP output stream for file.
See Also

Reference

FtpFile Class
GetOutputStream Overload
GSF.Net.Ftp Namespace


FtpFile.GetOutputStream Method (Int64)

Grid Solutions Framework FtpFileGetOutputStream Method (Int64)
Gets FTP output stream for file at given offset.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpOutputDataStream GetOutputStream(
    long offset
)
Public Function GetOutputStream (
    offset As Long
) As FtpOutputDataStream
member GetOutputStream :
        offset : int64 -> FtpOutputDataStream

function GetOutputStream(offset);
public:
FtpOutputDataStream^ GetOutputStream(
    long long offset
)

Parameters

offset
Type: SystemInt64
Offset into stream to start.

Return Value

Type: FtpOutputDataStream
FTP output stream for file.
See Also

Reference

FtpFile Class
GetOutputStream Overload
GSF.Net.Ftp Namespace


FtpFile Operators

Grid Solutions Framework FtpFile Operators

The FtpFile type exposes the following members.

Operators
Name | Description
Equality | Compares the two values for equality.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Top
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Equality Operator

Grid Solutions Framework FtpFileEquality Operator
Compares the two values for equality.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    FtpFile value1,
    FtpFile value2
)
Public Shared Operator = (
    value1 As FtpFile,
    value2 As FtpFile
) As Boolean
static let inline (=)
        value1 : FtpFile *
        value2 : FtpFile  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    FtpFile^ value1,
    FtpFile^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpFile
A FtpFile as the left hand operand.
value2
Type: GSF.Net.FtpFtpFile
A FtpFile as the right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result of the comparison.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.GreaterThan Operator

Grid Solutions Framework FtpFileGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    FtpFile value1,
    FtpFile value2
)
Public Shared Operator > (
    value1 As FtpFile,
    value2 As FtpFile
) As Boolean
static let inline (>)
        value1 : FtpFile *
        value2 : FtpFile  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    FtpFile^ value1,
    FtpFile^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpFile
A FtpFile as the left hand operand.
value2
Type: GSF.Net.FtpFtpFile
A FtpFile as the right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result of the comparison.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.GreaterThanOrEqual Operator

Grid Solutions Framework FtpFileGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    FtpFile value1,
    FtpFile value2
)
Public Shared Operator >= (
    value1 As FtpFile,
    value2 As FtpFile
) As Boolean
static let inline (>=)
        value1 : FtpFile *
        value2 : FtpFile  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    FtpFile^ value1,
    FtpFile^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpFile
A FtpFile as the left hand operand.
value2
Type: GSF.Net.FtpFtpFile
A FtpFile as the right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result of the comparison.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Inequality Operator

Grid Solutions Framework FtpFileInequality Operator
Compares the two values for inequality.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    FtpFile value1,
    FtpFile value2
)
Public Shared Operator <> (
    value1 As FtpFile,
    value2 As FtpFile
) As Boolean
static let inline (<>)
        value1 : FtpFile *
        value2 : FtpFile  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    FtpFile^ value1,
    FtpFile^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpFile
A FtpFile as the left hand operand.
value2
Type: GSF.Net.FtpFtpFile
A FtpFile as the right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result of the comparison.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.LessThan Operator

Grid Solutions Framework FtpFileLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    FtpFile value1,
    FtpFile value2
)
Public Shared Operator < (
    value1 As FtpFile,
    value2 As FtpFile
) As Boolean
static let inline (<)
        value1 : FtpFile *
        value2 : FtpFile  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    FtpFile^ value1,
    FtpFile^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpFile
A FtpFile as the left hand operand.
value2
Type: GSF.Net.FtpFtpFile
A FtpFile as the right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result of the comparison.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.LessThanOrEqual Operator

Grid Solutions Framework FtpFileLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    FtpFile value1,
    FtpFile value2
)
Public Shared Operator <= (
    value1 As FtpFile,
    value2 As FtpFile
) As Boolean
static let inline (<=)
        value1 : FtpFile *
        value2 : FtpFile  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    FtpFile^ value1,
    FtpFile^ value2
)

Parameters

value1
Type: GSF.Net.FtpFtpFile
A FtpFile as the left hand operand.
value2
Type: GSF.Net.FtpFtpFile
A FtpFile as the right hand operand.

Return Value

Type: Boolean
A Boolean value indicating the result of the comparison.
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile Properties

Grid Solutions Framework FtpFile Properties

The FtpFile type exposes the following members.

Properties
 | Name | Description
Public property | FullPath | Full path of file.
Public property | IsDirectory | Returns false for directory entries.
Public property | IsFile | Returns true for file entries.
Public property | Name | Name of file.
Public property | Parent | Gets parent directory of file.
Public property | Permission | Gets or sets permission of file.
Public property | Size | Gets or sets size of file.
Public property | Timestamp | Gets or sets timestamp of file.
Top
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.FullPath Property

Grid Solutions Framework FtpFileFullPath Property
Full path of file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FullPath { get; }
Public ReadOnly Property FullPath As String
    Get
abstract FullPath : string with get
override FullPath : string with get
function get_FullPath();

public:
virtual property String^ FullPath {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IFtpFileFullPath
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.IsDirectory Property

Grid Solutions Framework FtpFileIsDirectory Property
Returns false for directory entries.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDirectory { get; }
Public ReadOnly Property IsDirectory As Boolean
    Get
abstract IsDirectory : bool with get
override IsDirectory : bool with get
function get_IsDirectory();

public:
virtual property bool IsDirectory {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IFtpFileIsDirectory
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.IsFile Property

Grid Solutions Framework FtpFileIsFile Property
Returns true for file entries.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsFile { get; }
Public ReadOnly Property IsFile As Boolean
    Get
abstract IsFile : bool with get
override IsFile : bool with get
function get_IsFile();

public:
virtual property bool IsFile {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IFtpFileIsFile
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Name Property

Grid Solutions Framework FtpFileName Property
Name of file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IFtpFileName
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Parent Property

Grid Solutions Framework FtpFileParent Property
Gets parent directory of file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpDirectory Parent { get; }
Public ReadOnly Property Parent As FtpDirectory
    Get
abstract Parent : FtpDirectory with get
override Parent : FtpDirectory with get
function get_Parent();

public:
virtual property FtpDirectory^ Parent {
    FtpDirectory^ get () sealed;
}

Property Value

Type: FtpDirectory

Implements

IFtpFileParent
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Permission Property

Grid Solutions Framework FtpFilePermission Property
Gets or sets permission of file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Permission { get; set; }
Public Property Permission As String
    Get
    Set
abstract Permission : string with get, set
override Permission : string with get, set
function get_Permission();
function set_Permission(value);
public:
virtual property String^ Permission {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IFtpFilePermission
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Size Property

Grid Solutions Framework FtpFileSize Property
Gets or sets size of file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Size { get; set; }
Public Property Size As Long
    Get
    Set
abstract Size : int64 with get, set
override Size : int64 with get, set
function get_Size();
function set_Size(value);
public:
virtual property long long Size {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IFtpFileSize
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFile.Timestamp Property

Grid Solutions Framework FtpFileTimestamp Property
Gets or sets timestamp of file.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Timestamp { get; set; }
Public Property Timestamp As DateTime
    Get
    Set
abstract Timestamp : DateTime with get, set
override Timestamp : DateTime with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property DateTime Timestamp {
    DateTime get () sealed;
    void set (DateTime value) sealed;
}

Property Value

Type: DateTime

Implements

IFtpFileTimestamp
See Also

Reference

FtpFile Class
GSF.Net.Ftp Namespace


FtpFileNotFoundException Class

Grid Solutions Framework FtpFileNotFoundException Class
FTP file not found exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpFileNotFoundException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpFileNotFoundException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpFileNotFoundException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpFileNotFoundException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpFileNotFoundException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpFileNotFoundException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpFileNotFoundException : public FtpExceptionBase

The FtpFileNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpFileNotFoundException Methods

Grid Solutions Framework FtpFileNotFoundException Methods

The FtpFileNotFoundException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpFileNotFoundException Class
GSF.Net.Ftp Namespace


FtpFileNotFoundException Properties

Grid Solutions Framework FtpFileNotFoundException Properties

The FtpFileNotFoundException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpFileNotFoundException Class
GSF.Net.Ftp Namespace


FtpFileNotFoundException Events

Grid Solutions Framework FtpFileNotFoundException Events

The FtpFileNotFoundException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpFileNotFoundException Class
GSF.Net.Ftp Namespace


FtpFileWatcher Class

Grid Solutions Framework FtpFileWatcher Class
FTP File Watcher
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.Net.FtpFtpFileWatcher

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(FtpFileWatcher))]
[DefaultPropertyAttribute("Server")]
[DefaultEventAttribute("FileAdded")]
public class FtpFileWatcher : Component
<ToolboxBitmapAttribute(GetType(FtpFileWatcher))>
<DefaultPropertyAttribute("Server")>
<DefaultEventAttribute("FileAdded")>
Public Class FtpFileWatcher
    Inherits Component
[<ToolboxBitmapAttribute(typeof(FtpFileWatcher))>]
[<DefaultPropertyAttribute("Server")>]
[<DefaultEventAttribute("FileAdded")>]
type FtpFileWatcher =
    class
        inherit Component
    end
GSF.Net.Ftp.FtpFileWatcher = function();

Type.createClass(
    'GSF.Net.Ftp.FtpFileWatcher',
    Component);
[ToolboxBitmapAttribute(typeof(FtpFileWatcher))]
[DefaultPropertyAttribute(L"Server")]
[DefaultEventAttribute(L"FileAdded")]
public ref class FtpFileWatcher : public Component

The FtpFileWatcher type exposes the following members.

Constructors
 | Name | Description
Public method | FtpFileWatcher | Constructs a new FTP file watcher using the default settings.
Public method | FtpFileWatcher(IContainer) | Initializes a new instance of the FtpFileWatcher class.
Public method | FtpFileWatcher(Boolean, Boolean) | Constructs a new FTP file watcher using the specified settings.
Top
Methods
 | Name | Description
Public method | CloneFtpSession | Clones FTP session used by file watcher so it can be used for other purposes.
Public method | Close | Closes FTP session and clears resources used by the FtpFileWatcher.
Public method | Connect | Connects to FTP server and enables file watching if Enabled is true.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FtpFileWatcher object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnCommandSent | Raises CommandSent event.
Protected method | OnFileAdded | Raises FileAdded event.
Protected method | OnFileDeleted | Raises FileDeleted event.
Protected method | OnResponseReceived | Raises ResponseReceived event.
Protected method | OnStatus | Raises Status event.
Public method | Reset | Resets and restarts FTP session used by FTP file watcher.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CaseInsensitive | Gets or sets FTP case sensitivity of file and directory names.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Directory | Gets or sets name of FTP directory name to monitor. Leave blank to monitor initial FTP session directory.
Public property | Enabled | Gets or sets enabled state of the FtpFileWatcher object.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsConnected | Returns true if FTP file watcher session is connected.
Public property | NotifyOnComplete | Sets flag for notification time. Set to true to only notify when a file is finished uploading, set to False to get an immediate notification when a new file is detected.
Public property | Port | Gets or sets FTP server port to use, defaults to 21.
Public property | Server | Gets or sets FTP server name (DNS name or IP) to watch.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | WatchInterval | Gets or sets interval, in seconds, to scan for file changes on monitored FTP directory.
Top
Events
 | Name | Description
Public event | CommandSent | Raised when FTP command has been sent.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileAdded | Raised when new file is added to monitored FTP directory.
Public event | FileDeleted | Raised when file is deleted from monitored FTP directory.
Public event | ResponseReceived | Raised when FTP response has been received.
Public event | Status | Raised when new status messages come from the FTP file watcher.
Top
Remarks
Monitors for file changes over an FTP session.
See Also

Reference

GSF.Net.Ftp Namespace


FtpFileWatcher Constructor

Grid Solutions Framework FtpFileWatcher Constructor
Overload List
 | Name | Description
Public method | FtpFileWatcher | Constructs a new FTP file watcher using the default settings.
Public method | FtpFileWatcher(IContainer) | Initializes a new instance of the FtpFileWatcher class.
Public method | FtpFileWatcher(Boolean, Boolean) | Constructs a new FTP file watcher using the specified settings.
Top
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher Constructor

Grid Solutions Framework FtpFileWatcher Constructor
Constructs a new FTP file watcher using the default settings.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpFileWatcher()
Public Sub New
new : unit -> FtpFileWatcher
GSF.Net.Ftp.FtpFileWatcher = function();
public:
FtpFileWatcher()
See Also

Reference

FtpFileWatcher Class
FtpFileWatcher Overload
GSF.Net.Ftp Namespace


FtpFileWatcher Constructor (IContainer)

Grid Solutions Framework FtpFileWatcher Constructor (IContainer)
Initializes a new instance of the FtpFileWatcher class.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpFileWatcher(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> FtpFileWatcher
GSF.Net.Ftp.FtpFileWatcher = function(container);
public:
FtpFileWatcher(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the FtpFileWatcher.
See Also

Reference

FtpFileWatcher Class
FtpFileWatcher Overload
GSF.Net.Ftp Namespace


FtpFileWatcher Constructor (Boolean, Boolean)

Grid Solutions Framework FtpFileWatcher Constructor (Boolean, Boolean)
Constructs a new FTP file watcher using the specified settings.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FtpFileWatcher(
    bool caseInsensitive,
    bool notifyOnComplete
)
Public Sub New (
    caseInsensitive As Boolean,
    notifyOnComplete As Boolean
)
new :
        caseInsensitive : bool *
        notifyOnComplete : bool -> FtpFileWatcher
GSF.Net.Ftp.FtpFileWatcher = function(caseInsensitive, notifyOnComplete);
public:
FtpFileWatcher(
    bool caseInsensitive,
    bool notifyOnComplete
)

Parameters

caseInsensitive
Type: SystemBoolean
Set to true to not be case sensitive with FTP file and directory names.
notifyOnComplete
Type: SystemBoolean
Set to true to notify after file has completed uploading -or- set to false for immediate notification of new file.
See Also

Reference

FtpFileWatcher Class
FtpFileWatcher Overload
GSF.Net.Ftp Namespace


FtpFileWatcher Methods

Grid Solutions Framework FtpFileWatcher Methods

The FtpFileWatcher type exposes the following members.

Methods
 | Name | Description
Public method | CloneFtpSession | Clones FTP session used by file watcher so it can be used for other purposes.
Public method | Close | Closes FTP session and clears resources used by the FtpFileWatcher.
Public method | Connect | Connects to FTP server and enables file watching if Enabled is true.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FtpFileWatcher object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnCommandSent | Raises CommandSent event.
Protected method | OnFileAdded | Raises FileAdded event.
Protected method | OnFileDeleted | Raises FileDeleted event.
Protected method | OnResponseReceived | Raises ResponseReceived event.
Protected method | OnStatus | Raises Status event.
Public method | Reset | Resets and restarts FTP session used by FTP file watcher.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.CloneFtpSession Method

Grid Solutions Framework FtpFileWatcherCloneFtpSession Method
Clones FTP session used by file watcher so it can be used for other purposes.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FtpClient CloneFtpSession()
Public Overridable Function CloneFtpSession As FtpClient
abstract CloneFtpSession : unit -> FtpClient
override CloneFtpSession : unit -> FtpClient
function CloneFtpSession();
public:
virtual FtpClient^ CloneFtpSession()

Return Value

Type: FtpClient
New connected FTP session matching settings defined for FTP file watcher.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Close Method

Grid Solutions Framework FtpFileWatcherClose Method
Closes FTP session and clears resources used by the FtpFileWatcher.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Close()
Public Overridable Sub Close
abstract Close : unit -> unit
override Close : unit -> unit
function Close();
public:
virtual void Close()
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Connect Method

Grid Solutions Framework FtpFileWatcherConnect Method
Connects to FTP server and enables file watching if Enabled is true.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Connect(
    string userName,
    string password
)
Public Overridable Sub Connect (
    userName As String,
    password As String
)
abstract Connect :
        userName : string *
        password : string -> unit
override Connect :
        userName : string *
        password : string -> unit
function Connect(userName, password);
public:
virtual void Connect(
    String^ userName,
    String^ password
)

Parameters

userName
Type: SystemString
A String value as the username.
password
Type: SystemString
A String value as the password.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Dispose Method

Grid Solutions Framework FtpFileWatcherDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FtpFileWatcher object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Dispose Method (Boolean)

Grid Solutions Framework FtpFileWatcherDispose Method (Boolean)
Releases the unmanaged resources used by the FtpFileWatcher object and optionally releases the managed resources.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FtpFileWatcher Class
Dispose Overload
GSF.Net.Ftp Namespace


FtpFileWatcher.OnCommandSent Method

Grid Solutions Framework FtpFileWatcherOnCommandSent Method
Raises CommandSent event.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnCommandSent(
    string command
)
Protected Sub OnCommandSent (
    command As String
)
member OnCommandSent :
        command : string -> unit

function OnCommandSent(command);
protected:
void OnCommandSent(
    String^ command
)

Parameters

command
Type: SystemString
A String command.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.OnFileAdded Method

Grid Solutions Framework FtpFileWatcherOnFileAdded Method
Raises FileAdded event.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnFileAdded(
    FtpFile file
)
Protected Sub OnFileAdded (
    file As FtpFile
)
member OnFileAdded :
        file : FtpFile -> unit

function OnFileAdded(file);
protected:
void OnFileAdded(
    FtpFile^ file
)

Parameters

file
Type: GSF.Net.FtpFtpFile
A FtpFile file.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.OnFileDeleted Method

Grid Solutions Framework FtpFileWatcherOnFileDeleted Method
Raises FileDeleted event.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnFileDeleted(
    FtpFile file
)
Protected Sub OnFileDeleted (
    file As FtpFile
)
member OnFileDeleted :
        file : FtpFile -> unit

function OnFileDeleted(file);
protected:
void OnFileDeleted(
    FtpFile^ file
)

Parameters

file
Type: GSF.Net.FtpFtpFile
A FtpFile file.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.OnResponseReceived Method

Grid Solutions Framework FtpFileWatcherOnResponseReceived Method
Raises ResponseReceived event.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnResponseReceived(
    string response
)
Protected Sub OnResponseReceived (
    response As String
)
member OnResponseReceived :
        response : string -> unit

function OnResponseReceived(response);
protected:
void OnResponseReceived(
    String^ response
)

Parameters

response
Type: SystemString
A String response.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.OnStatus Method

Grid Solutions Framework FtpFileWatcherOnStatus Method
Raises Status event.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnStatus(
    string status
)
Protected Sub OnStatus (
    status As String
)
member OnStatus :
        status : string -> unit

function OnStatus(status);
protected:
void OnStatus(
    String^ status
)

Parameters

status
Type: SystemString
A String status message.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Reset Method

Grid Solutions Framework FtpFileWatcherReset Method
Resets and restarts FTP session used by FTP file watcher.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Reset()
Public Overridable Sub Reset
abstract Reset : unit -> unit
override Reset : unit -> unit
function Reset();
public:
virtual void Reset()
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher Properties

Grid Solutions Framework FtpFileWatcher Properties

The FtpFileWatcher type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CaseInsensitive | Gets or sets FTP case sensitivity of file and directory names.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Directory | Gets or sets name of FTP directory name to monitor. Leave blank to monitor initial FTP session directory.
Public property | Enabled | Gets or sets enabled state of the FtpFileWatcher object.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsConnected | Returns true if FTP file watcher session is connected.
Public property | NotifyOnComplete | Sets flag for notification time. Set to true to only notify when a file is finished uploading, set to False to get an immediate notification when a new file is detected.
Public property | Port | Gets or sets FTP server port to use, defaults to 21.
Public property | Server | Gets or sets FTP server name (DNS name or IP) to watch.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | WatchInterval | Gets or sets interval, in seconds, to scan for file changes on monitored FTP directory.
Top
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.CaseInsensitive Property

Grid Solutions Framework FtpFileWatcherCaseInsensitive Property
Gets or sets FTP case sensitivity of file and directory names.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
[DefaultValueAttribute(false)]
public bool CaseInsensitive { get; set; }
<BrowsableAttribute(true)>
<DefaultValueAttribute(false)>
Public Property CaseInsensitive As Boolean
    Get
    Set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(false)>]
member CaseInsensitive : bool with get, set

function get_CaseInsensitive();
function set_CaseInsensitive(value);
public:
[BrowsableAttribute(true)]
[DefaultValueAttribute(false)]
property bool CaseInsensitive {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Set to true to not be case sensitive with FTP file and directory names.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Directory Property

Grid Solutions Framework FtpFileWatcherDirectory Property
Gets or sets name of FTP directory name to monitor. Leave blank to monitor initial FTP session directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("")]
[BrowsableAttribute(true)]
public virtual string Directory { get; set; }
<DefaultValueAttribute("")>
<BrowsableAttribute(true)>
Public Overridable Property Directory As String
    Get
    Set
[<DefaultValueAttribute("")>]
[<BrowsableAttribute(true)>]
abstract Directory : string with get, set
[<DefaultValueAttribute("")>]
[<BrowsableAttribute(true)>]
override Directory : string with get, set
function get_Directory();
function set_Directory(value);
public:
[DefaultValueAttribute(L"")]
[BrowsableAttribute(true)]
virtual property String^ Directory {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Enabled Property

Grid Solutions Framework FtpFileWatcherEnabled Property
Gets or sets enabled state of the FtpFileWatcher object.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
[DefaultValueAttribute(true)]
public virtual bool Enabled { get; set; }
<BrowsableAttribute(true)>
<DefaultValueAttribute(true)>
Public Overridable Property Enabled As Boolean
    Get
    Set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(true)>]
abstract Enabled : bool with get, set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(true)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[BrowsableAttribute(true)]
[DefaultValueAttribute(true)]
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.IsConnected Property

Grid Solutions Framework FtpFileWatcherIsConnected Property
Returns true if FTP file watcher session is connected.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual bool IsConnected { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property IsConnected As Boolean
    Get
[<BrowsableAttribute(false)>]
abstract IsConnected : bool with get
[<BrowsableAttribute(false)>]
override IsConnected : bool with get
function get_IsConnected();

public:
[BrowsableAttribute(false)]
virtual property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.NotifyOnComplete Property

Grid Solutions Framework FtpFileWatcherNotifyOnComplete Property
Sets flag for notification time. Set to true to only notify when a file is finished uploading, set to False to get an immediate notification when a new file is detected.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
[DefaultValueAttribute(true)]
public virtual bool NotifyOnComplete { get; set; }
<BrowsableAttribute(true)>
<DefaultValueAttribute(true)>
Public Overridable Property NotifyOnComplete As Boolean
    Get
    Set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(true)>]
abstract NotifyOnComplete : bool with get, set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(true)>]
override NotifyOnComplete : bool with get, set
function get_NotifyOnComplete();
function set_NotifyOnComplete(value);
public:
[BrowsableAttribute(true)]
[DefaultValueAttribute(true)]
virtual property bool NotifyOnComplete {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Port Property

Grid Solutions Framework FtpFileWatcherPort Property
Gets or sets FTP server port to use, defaults to 21.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(21)]
[BrowsableAttribute(true)]
public int Port { get; set; }
<DefaultValueAttribute(21)>
<BrowsableAttribute(true)>
Public Property Port As Integer
    Get
    Set
[<DefaultValueAttribute(21)>]
[<BrowsableAttribute(true)>]
member Port : int with get, set

function get_Port();
function set_Port(value);
public:
[DefaultValueAttribute(21)]
[BrowsableAttribute(true)]
property int Port {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This only needs to be changed if the FTP server is established on a non-standard port number.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Server Property

Grid Solutions Framework FtpFileWatcherServer Property
Gets or sets FTP server name (DNS name or IP) to watch.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
public virtual string Server { get; set; }
<BrowsableAttribute(true)>
Public Overridable Property Server As String
    Get
    Set
[<BrowsableAttribute(true)>]
abstract Server : string with get, set
[<BrowsableAttribute(true)>]
override Server : string with get, set
function get_Server();
function set_Server(value);
public:
[BrowsableAttribute(true)]
virtual property String^ Server {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
FTP server name should not be prefixed with FTP://.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.WatchInterval Property

Grid Solutions Framework FtpFileWatcherWatchInterval Property
Gets or sets interval, in seconds, to scan for file changes on monitored FTP directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(true)]
[DefaultValueAttribute(5)]
public virtual int WatchInterval { get; set; }
<BrowsableAttribute(true)>
<DefaultValueAttribute(5)>
Public Overridable Property WatchInterval As Integer
    Get
    Set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(5)>]
abstract WatchInterval : int with get, set
[<BrowsableAttribute(true)>]
[<DefaultValueAttribute(5)>]
override WatchInterval : int with get, set
function get_WatchInterval();
function set_WatchInterval(value);
public:
[BrowsableAttribute(true)]
[DefaultValueAttribute(5)]
virtual property int WatchInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Specify interval in seconds to poll FTP directory for file changes.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher Events

Grid Solutions Framework FtpFileWatcher Events

The FtpFileWatcher type exposes the following members.

Events
 | Name | Description
Public event | CommandSent | Raised when FTP command has been sent.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | FileAdded | Raised when new file is added to monitored FTP directory.
Public event | FileDeleted | Raised when file is deleted from monitored FTP directory.
Public event | ResponseReceived | Raised when FTP response has been received.
Public event | Status | Raised when new status messages come from the FTP file watcher.
Top
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.CommandSent Event

Grid Solutions Framework FtpFileWatcherCommandSent Event
Raised when FTP command has been sent.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> CommandSent
Public Event CommandSent As EventHandler(Of EventArgs(Of String))
member CommandSent : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_CommandSent(value);
function remove_CommandSent(value);
public:
 event EventHandler<EventArgs<String^>^>^ CommandSent {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is sent FTP command.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.FileAdded Event

Grid Solutions Framework FtpFileWatcherFileAdded Event
Raised when new file is added to monitored FTP directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<FtpFile>> FileAdded
Public Event FileAdded As EventHandler(Of EventArgs(Of FtpFile))
member FileAdded : IEvent<EventHandler<EventArgs<FtpFile>>,
    EventArgs<FtpFile>>

function add_FileAdded(value);
function remove_FileAdded(value);
public:
 event EventHandler<EventArgs<FtpFile^>^>^ FileAdded {
    void add (EventHandler<EventArgs<FtpFile^>^>^ value);
    void remove (EventHandler<EventArgs<FtpFile^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FtpFile
Remarks
Argument is reference to newly added file.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.FileDeleted Event

Grid Solutions Framework FtpFileWatcherFileDeleted Event
Raised when file is deleted from monitored FTP directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<FtpFile>> FileDeleted
Public Event FileDeleted As EventHandler(Of EventArgs(Of FtpFile))
member FileDeleted : IEvent<EventHandler<EventArgs<FtpFile>>,
    EventArgs<FtpFile>>

function add_FileDeleted(value);
function remove_FileDeleted(value);
public:
 event EventHandler<EventArgs<FtpFile^>^>^ FileDeleted {
    void add (EventHandler<EventArgs<FtpFile^>^>^ value);
    void remove (EventHandler<EventArgs<FtpFile^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FtpFile
Remarks
Argument is reference to file that was removed.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.ResponseReceived Event

Grid Solutions Framework FtpFileWatcherResponseReceived Event
Raised when FTP response has been received.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> ResponseReceived
Public Event ResponseReceived As EventHandler(Of EventArgs(Of String))
member ResponseReceived : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_ResponseReceived(value);
function remove_ResponseReceived(value);
public:
 event EventHandler<EventArgs<String^>^>^ ResponseReceived {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is received FTP response.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpFileWatcher.Status Event

Grid Solutions Framework FtpFileWatcherStatus Event
Raised when new status messages come from the FTP file watcher.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> Status
Public Event Status As EventHandler(Of EventArgs(Of String))
member Status : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_Status(value);
function remove_Status(value);
public:
 event EventHandler<EventArgs<String^>^>^ Status {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is status message from FTP file watcher.
See Also

Reference

FtpFileWatcher Class
GSF.Net.Ftp Namespace


FtpInputDataStream Class

Grid Solutions Framework FtpInputDataStream Class
Defines a FTP data input stream for remote files.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.Net.FtpFtpDataStream
GSF.Net.FtpFtpInputDataStream

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpInputDataStream : FtpDataStream
Public Class FtpInputDataStream
    Inherits FtpDataStream
type FtpInputDataStream =
    class
        inherit FtpDataStream
    end
GSF.Net.Ftp.FtpInputDataStream = function();

Type.createClass(
    'GSF.Net.Ftp.FtpInputDataStream',
    GSF.Net.Ftp.FtpDataStream);
public ref class FtpInputDataStream : public FtpDataStream

The FtpInputDataStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the FTP stream and releases any resources associated with the stream. (Inherited from FtpDataStream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from FtpDataStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from FtpDataStream.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from FtpDataStream.)
Public method | Seek | Sets the position within the current stream. (Inherited from FtpDataStream.)
Public method | SetLength | Sets the length of the current stream. (Inherited from FtpDataStream.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Cannot write to input stream, method is not supported. (Overrides FtpDataStreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Cannot write to input stream, method is not supported. (Overrides FtpDataStreamWriteByte(Byte).)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from FtpDataStream.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from FtpDataStream.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Returns false, cannot write to input stream. (Overrides FtpDataStreamCanWrite.)
Public property | Length | Gets the length in bytes of the stream. (Inherited from FtpDataStream.)
Public property | Position | Gets or sets the position within the current stream. (Inherited from FtpDataStream.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpInputDataStream Methods

Grid Solutions Framework FtpInputDataStream Methods

The FtpInputDataStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the FTP stream and releases any resources associated with the stream. (Inherited from FtpDataStream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from FtpDataStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from FtpDataStream.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from FtpDataStream.)
Public method | Seek | Sets the position within the current stream. (Inherited from FtpDataStream.)
Public method | SetLength | Sets the length of the current stream. (Inherited from FtpDataStream.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Cannot write to input stream, method is not supported. (Overrides FtpDataStreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Cannot write to input stream, method is not supported. (Overrides FtpDataStreamWriteByte(Byte).)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FtpInputDataStream Class
GSF.Net.Ftp Namespace


FtpInputDataStream.Write Method

Grid Solutions Framework FtpInputDataStreamWrite Method
Cannot write to input stream, method is not supported.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Write(buffer, offset, count);
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
A Byte array buffer to use.
offset
Type: SystemInt32
An Int32 count of bytes to write.
count
Type: SystemInt32
An Int32 offset into the buffer.
Exceptions
Exception | Condition
NotSupportedException | Cannot write to input stream.
See Also

Reference

FtpInputDataStream Class
GSF.Net.Ftp Namespace


FtpInputDataStream.WriteByte Method

Grid Solutions Framework FtpInputDataStreamWriteByte Method
Cannot write to input stream, method is not supported.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void WriteByte(
    byte b
)
Public Overrides Sub WriteByte (
    b As Byte
)
abstract WriteByte :
        b : byte -> unit
override WriteByte :
        b : byte -> unit
function WriteByte(b);
public:
virtual void WriteByte(
    unsigned char b
) override

Parameters

b
Type: SystemByte
A Byte to write.
Exceptions
Exception | Condition
NotSupportedException | Cannot write to input stream.
See Also

Reference

FtpInputDataStream Class
GSF.Net.Ftp Namespace


FtpInputDataStream Properties

Grid Solutions Framework FtpInputDataStream Properties

The FtpInputDataStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from FtpDataStream.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from FtpDataStream.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Returns false, cannot write to input stream. (Overrides FtpDataStreamCanWrite.)
Public property | Length | Gets the length in bytes of the stream. (Inherited from FtpDataStream.)
Public property | Position | Gets or sets the position within the current stream. (Inherited from FtpDataStream.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FtpInputDataStream Class
GSF.Net.Ftp Namespace


FtpInputDataStream.CanWrite Property

Grid Solutions Framework FtpInputDataStreamCanWrite Property
Returns false, cannot write to input stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FtpInputDataStream Class
GSF.Net.Ftp Namespace


FtpInvalidResponseException Class

Grid Solutions Framework FtpInvalidResponseException Class
Invalid FTP response exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpInvalidResponseException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpInvalidResponseException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpInvalidResponseException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpInvalidResponseException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpInvalidResponseException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpInvalidResponseException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpInvalidResponseException : public FtpExceptionBase

The FtpInvalidResponseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpInvalidResponseException Methods

Grid Solutions Framework FtpInvalidResponseException Methods

The FtpInvalidResponseException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpInvalidResponseException Class
GSF.Net.Ftp Namespace


FtpInvalidResponseException Properties

Grid Solutions Framework FtpInvalidResponseException Properties

The FtpInvalidResponseException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpInvalidResponseException Class
GSF.Net.Ftp Namespace


FtpInvalidResponseException Events

Grid Solutions Framework FtpInvalidResponseException Events

The FtpInvalidResponseException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpInvalidResponseException Class
GSF.Net.Ftp Namespace


FtpOutputDataStream Class

Grid Solutions Framework FtpOutputDataStream Class
Defines a FTP data output stream for remote files.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.Net.FtpFtpDataStream
GSF.Net.FtpFtpOutputDataStream

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpOutputDataStream : FtpDataStream
Public Class FtpOutputDataStream
    Inherits FtpDataStream
type FtpOutputDataStream =
    class
        inherit FtpDataStream
    end
GSF.Net.Ftp.FtpOutputDataStream = function();

Type.createClass(
    'GSF.Net.Ftp.FtpOutputDataStream',
    GSF.Net.Ftp.FtpDataStream);
public ref class FtpOutputDataStream : public FtpDataStream

The FtpOutputDataStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the FTP stream and releases any resources associated with the stream. (Inherited from FtpDataStream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from FtpDataStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Cannot read from output stream, method is not supported. (Overrides FtpDataStreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Cannot read from output stream, method is not supported. (Overrides FtpDataStreamReadByte.)
Public method | Seek | Sets the position within the current stream. (Inherited from FtpDataStream.)
Public method | SetLength | Sets the length of the current stream. (Inherited from FtpDataStream.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from FtpDataStream.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from FtpDataStream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Properties
 | Name | Description
Public property | CanRead | Returns false, cannot read from output stream. (Overrides FtpDataStreamCanRead.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from FtpDataStream.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from FtpDataStream.)
Public property | Length | Gets the length in bytes of the stream. (Inherited from FtpDataStream.)
Public property | Position | Gets or sets the position within the current stream. (Inherited from FtpDataStream.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpOutputDataStream Methods

Grid Solutions Framework FtpOutputDataStream Methods

The FtpOutputDataStream type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the FTP stream and releases any resources associated with the stream. (Inherited from FtpDataStream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | Clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from FtpDataStream.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Public method | Read | Cannot read from output stream, method is not supported. (Overrides FtpDataStreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Cannot read from output stream, method is not supported. (Overrides FtpDataStreamReadByte.)
Public method | Seek | Sets the position within the current stream. (Inherited from FtpDataStream.)
Public method | SetLength | Sets the length of the current stream. (Inherited from FtpDataStream.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | When overridden in a derived class, writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from FtpDataStream.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from FtpDataStream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FtpOutputDataStream Class
GSF.Net.Ftp Namespace


FtpOutputDataStream.Read Method

Grid Solutions Framework FtpOutputDataStreamRead Method
Cannot read from output stream, method is not supported.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
function Read(buffer, offset, count);
public:
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
A Byte array buffer.
offset
Type: SystemInt32
An Int32 number of bytes to read.
count
Type: SystemInt32
An Int32 offset into the stream to read from.

Return Value

Type: Int32
An Int32 number of bytes read.
Exceptions
Exception | Condition
NotSupportedException | Cannot read from output stream.
See Also

Reference

FtpOutputDataStream Class
GSF.Net.Ftp Namespace


FtpOutputDataStream.ReadByte Method

Grid Solutions Framework FtpOutputDataStreamReadByte Method
Cannot read from output stream, method is not supported.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ReadByte()
Public Overrides Function ReadByte As Integer
abstract ReadByte : unit -> int
override ReadByte : unit -> int
function ReadByte();
public:
virtual int ReadByte() override

Return Value

Type: Int32
An Int32 number of bytes read.
Exceptions
Exception | Condition
NotSupportedException | Cannot read from output stream.
See Also

Reference

FtpOutputDataStream Class
GSF.Net.Ftp Namespace


FtpOutputDataStream Properties

Grid Solutions Framework FtpOutputDataStream Properties

The FtpOutputDataStream type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Returns false, cannot read from output stream. (Overrides FtpDataStreamCanRead.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from FtpDataStream.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from FtpDataStream.)
Public property | Length | Gets the length in bytes of the stream. (Inherited from FtpDataStream.)
Public property | Position | Gets or sets the position within the current stream. (Inherited from FtpDataStream.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FtpOutputDataStream Class
GSF.Net.Ftp Namespace


FtpOutputDataStream.CanRead Property

Grid Solutions Framework FtpOutputDataStreamCanRead Property
Returns false, cannot read from output stream.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FtpOutputDataStream Class
GSF.Net.Ftp Namespace


FtpResponse Class

Grid Solutions Framework FtpResponse Class
Defines a FTP response.
Inheritance Hierarchy
SystemObject
GSF.Net.FtpFtpResponse

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FtpResponse
Public Class FtpResponse
type FtpResponse =  class end
GSF.Net.Ftp.FtpResponse = function();

Type.createClass(
    'GSF.Net.Ftp.FtpResponse');
public ref class FtpResponse

The FtpResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ClosingDataChannel | FTP response code for closing data channel.
DataChannelOpenedTransferStart | FTP response code for data channel opened, transfer start.
EnterPassiveMode | FTP response code for enter passive mode.
FileOkBeginOpenDataChannel | FTP response code for file OK, begin open data channel.
InvalidCode | FTP response code for invalid code.
RequestFileActionComplete | FTP response code for request file action complete.
RequestFileActionPending | FTP response code for request file action pending.
ServiceReady | FTP response code for service ready.
ServiceUnavailable | FTP response code for service unavailable.
TransferAborted | FTP response code for transfer aborted.
UserAcceptedWaitingPass | FTP response code for user accepted waiting pass.
UserLoggedIn | FTP response code for user logged in.
Top
Properties
 | Name | Description
Public property | Code | Gets FTP response code.
Public property | Message | Gets FTP response message.
Public property | Respones | Gets FTP response queue.
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpResponse Fields

Grid Solutions Framework FtpResponse Fields

The FtpResponse type exposes the following members.

Fields
Name | Description
ClosingDataChannel | FTP response code for closing data channel.
DataChannelOpenedTransferStart | FTP response code for data channel opened, transfer start.
EnterPassiveMode | FTP response code for enter passive mode.
FileOkBeginOpenDataChannel | FTP response code for file OK, begin open data channel.
InvalidCode | FTP response code for invalid code.
RequestFileActionComplete | FTP response code for request file action complete.
RequestFileActionPending | FTP response code for request file action pending.
ServiceReady | FTP response code for service ready.
ServiceUnavailable | FTP response code for service unavailable.
TransferAborted | FTP response code for transfer aborted.
UserAcceptedWaitingPass | FTP response code for user accepted waiting pass.
UserLoggedIn | FTP response code for user logged in.
Top
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.ClosingDataChannel Field

Grid Solutions Framework FtpResponseClosingDataChannel Field
FTP response code for closing data channel.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ClosingDataChannel
Public Const ClosingDataChannel As Integer
static val mutable ClosingDataChannel: int
var GSF.Net.Ftp.FtpResponse.ClosingDataChannel
public:
literal int ClosingDataChannel

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.DataChannelOpenedTransferStart Field

Grid Solutions Framework FtpResponseDataChannelOpenedTransferStart Field
FTP response code for data channel opened, transfer start.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DataChannelOpenedTransferStart
Public Const DataChannelOpenedTransferStart As Integer
static val mutable DataChannelOpenedTransferStart: int
var GSF.Net.Ftp.FtpResponse.DataChannelOpenedTransferStart
public:
literal int DataChannelOpenedTransferStart

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.EnterPassiveMode Field

Grid Solutions Framework FtpResponseEnterPassiveMode Field
FTP response code for enter passive mode.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int EnterPassiveMode
Public Const EnterPassiveMode As Integer
static val mutable EnterPassiveMode: int
var GSF.Net.Ftp.FtpResponse.EnterPassiveMode
public:
literal int EnterPassiveMode

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.FileOkBeginOpenDataChannel Field

Grid Solutions Framework FtpResponseFileOkBeginOpenDataChannel Field
FTP response code for file OK, begin open data channel.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FileOkBeginOpenDataChannel
Public Const FileOkBeginOpenDataChannel As Integer
static val mutable FileOkBeginOpenDataChannel: int
var GSF.Net.Ftp.FtpResponse.FileOkBeginOpenDataChannel
public:
literal int FileOkBeginOpenDataChannel

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.InvalidCode Field

Grid Solutions Framework FtpResponseInvalidCode Field
FTP response code for invalid code.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int InvalidCode
Public Const InvalidCode As Integer
static val mutable InvalidCode: int
var GSF.Net.Ftp.FtpResponse.InvalidCode
public:
literal int InvalidCode

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.RequestFileActionComplete Field

Grid Solutions Framework FtpResponseRequestFileActionComplete Field
FTP response code for request file action complete.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int RequestFileActionComplete
Public Const RequestFileActionComplete As Integer
static val mutable RequestFileActionComplete: int
var GSF.Net.Ftp.FtpResponse.RequestFileActionComplete
public:
literal int RequestFileActionComplete

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.RequestFileActionPending Field

Grid Solutions Framework FtpResponseRequestFileActionPending Field
FTP response code for request file action pending.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int RequestFileActionPending
Public Const RequestFileActionPending As Integer
static val mutable RequestFileActionPending: int
var GSF.Net.Ftp.FtpResponse.RequestFileActionPending
public:
literal int RequestFileActionPending

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.ServiceReady Field

Grid Solutions Framework FtpResponseServiceReady Field
FTP response code for service ready.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ServiceReady
Public Const ServiceReady As Integer
static val mutable ServiceReady: int
var GSF.Net.Ftp.FtpResponse.ServiceReady
public:
literal int ServiceReady

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.ServiceUnavailable Field

Grid Solutions Framework FtpResponseServiceUnavailable Field
FTP response code for service unavailable.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ServiceUnavailable
Public Const ServiceUnavailable As Integer
static val mutable ServiceUnavailable: int
var GSF.Net.Ftp.FtpResponse.ServiceUnavailable
public:
literal int ServiceUnavailable

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.TransferAborted Field

Grid Solutions Framework FtpResponseTransferAborted Field
FTP response code for transfer aborted.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int TransferAborted
Public Const TransferAborted As Integer
static val mutable TransferAborted: int
var GSF.Net.Ftp.FtpResponse.TransferAborted
public:
literal int TransferAborted

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.UserAcceptedWaitingPass Field

Grid Solutions Framework FtpResponseUserAcceptedWaitingPass Field
FTP response code for user accepted waiting pass.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int UserAcceptedWaitingPass
Public Const UserAcceptedWaitingPass As Integer
static val mutable UserAcceptedWaitingPass: int
var GSF.Net.Ftp.FtpResponse.UserAcceptedWaitingPass
public:
literal int UserAcceptedWaitingPass

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.UserLoggedIn Field

Grid Solutions Framework FtpResponseUserLoggedIn Field
FTP response code for user logged in.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int UserLoggedIn
Public Const UserLoggedIn As Integer
static val mutable UserLoggedIn: int
var GSF.Net.Ftp.FtpResponse.UserLoggedIn
public:
literal int UserLoggedIn

Field Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse Methods

Grid Solutions Framework FtpResponse Methods

The FtpResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse Properties

Grid Solutions Framework FtpResponse Properties

The FtpResponse type exposes the following members.

Properties
 | Name | Description
Public property | Code | Gets FTP response code.
Public property | Message | Gets FTP response message.
Public property | Respones | Gets FTP response queue.
Top
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.Code Property

Grid Solutions Framework FtpResponseCode Property
Gets FTP response code.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Code { get; }
Public ReadOnly Property Code As Integer
    Get
member Code : int with get

function get_Code();

public:
property int Code {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.Message Property

Grid Solutions Framework FtpResponseMessage Property
Gets FTP response message.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Message { get; }
Public ReadOnly Property Message As String
    Get
member Message : string with get

function get_Message();

public:
property String^ Message {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResponse.Respones Property

Grid Solutions Framework FtpResponseRespones Property
Gets FTP response queue.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Queue Respones { get; }
Public ReadOnly Property Respones As Queue
    Get
member Respones : Queue with get

function get_Respones();

public:
property Queue^ Respones {
    Queue^ get ();
}

Property Value

Type: Queue
See Also

Reference

FtpResponse Class
GSF.Net.Ftp Namespace


FtpResumeNotSupportedException Class

Grid Solutions Framework FtpResumeNotSupportedException Class
FTP resume not supported exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpResumeNotSupportedException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpResumeNotSupportedException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpResumeNotSupportedException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpResumeNotSupportedException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpResumeNotSupportedException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpResumeNotSupportedException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpResumeNotSupportedException : public FtpExceptionBase

The FtpResumeNotSupportedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpResumeNotSupportedException Methods

Grid Solutions Framework FtpResumeNotSupportedException Methods

The FtpResumeNotSupportedException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpResumeNotSupportedException Class
GSF.Net.Ftp Namespace


FtpResumeNotSupportedException Properties

Grid Solutions Framework FtpResumeNotSupportedException Properties

The FtpResumeNotSupportedException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpResumeNotSupportedException Class
GSF.Net.Ftp Namespace


FtpResumeNotSupportedException Events

Grid Solutions Framework FtpResumeNotSupportedException Events

The FtpResumeNotSupportedException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpResumeNotSupportedException Class
GSF.Net.Ftp Namespace


FtpServerDownException Class

Grid Solutions Framework FtpServerDownException Class
FTP server down exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpServerDownException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpServerDownException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpServerDownException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpServerDownException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpServerDownException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpServerDownException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpServerDownException : public FtpExceptionBase

The FtpServerDownException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpServerDownException Methods

Grid Solutions Framework FtpServerDownException Methods

The FtpServerDownException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpServerDownException Class
GSF.Net.Ftp Namespace


FtpServerDownException Properties

Grid Solutions Framework FtpServerDownException Properties

The FtpServerDownException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpServerDownException Class
GSF.Net.Ftp Namespace


FtpServerDownException Events

Grid Solutions Framework FtpServerDownException Events

The FtpServerDownException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpServerDownException Class
GSF.Net.Ftp Namespace


FtpUserAbortException Class

Grid Solutions Framework FtpUserAbortException Class
FTP user abort exception.
Inheritance Hierarchy
SystemObject
SystemException
GSF.Net.FtpFtpExceptionBase
GSF.Net.FtpFtpUserAbortException

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FtpUserAbortException : FtpExceptionBase
<SerializableAttribute>
Public Class FtpUserAbortException
    Inherits FtpExceptionBase
[<SerializableAttribute>]
type FtpUserAbortException =
    class
        inherit FtpExceptionBase
    end
GSF.Net.Ftp.FtpUserAbortException = function();

Type.createClass(
    'GSF.Net.Ftp.FtpUserAbortException',
    GSF.Net.Ftp.FtpExceptionBase);
[SerializableAttribute]
public ref class FtpUserAbortException : public FtpExceptionBase

The FtpUserAbortException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.Net.Ftp Namespace


FtpUserAbortException Methods

Grid Solutions Framework FtpUserAbortException Methods

The FtpUserAbortException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Derserializes the FtpExceptionBase. (Inherited from FtpExceptionBase.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FtpUserAbortException Class
GSF.Net.Ftp Namespace


FtpUserAbortException Properties

Grid Solutions Framework FtpUserAbortException Properties

The FtpUserAbortException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | ResponseMessage | Response message related to exception, if any. (Inherited from FtpExceptionBase.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

FtpUserAbortException Class
GSF.Net.Ftp Namespace


FtpUserAbortException Events

Grid Solutions Framework FtpUserAbortException Events

The FtpUserAbortException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

FtpUserAbortException Class
GSF.Net.Ftp Namespace


IFtpFile Interface

Grid Solutions Framework IFtpFile Interface
Abstract representation of a FTP file or directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IFtpFile : IComparable,
    IComparable<IFtpFile>
Public Interface IFtpFile
    Inherits IComparable, IComparable(Of IFtpFile)
type IFtpFile =
    interface
        interface IComparable
        interface IComparable<IFtpFile>
    end
GSF.Net.Ftp.IFtpFile = function();
GSF.Net.Ftp.IFtpFile.createInterface('GSF.Net.Ftp.IFtpFile');
public interface class IFtpFile : IComparable,
    IComparable<IFtpFile^>

The IFtpFile type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFtpFile.)
Top
Properties
 | Name | Description
Public property | FullPath | Gets full path of file or directory.
Public property | IsDirectory | Returns true if IFtpFile represents a directory, otherwise false.
Public property | IsFile | Returns true if IFtpFile represents a file, otherwise false.
Public property | Name | Gets name of file or directory.
Public property | Parent | Gets parent directory of file or directory.
Public property | Permission | Gets or sets permission of file or directory.
Public property | Size | Gets or sets size of file or directory.
Public property | Timestamp | Gets or sets timestamp of file or directory.
Top
See Also

Reference

GSF.Net.Ftp Namespace


IFtpFile Methods

Grid Solutions Framework IFtpFile Methods
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFtpFile .)
Top
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile Properties

Grid Solutions Framework IFtpFile Properties

The IFtpFile type exposes the following members.

Properties
 | Name | Description
Public property | FullPath | Gets full path of file or directory.
Public property | IsDirectory | Returns true if IFtpFile represents a directory, otherwise false.
Public property | IsFile | Returns true if IFtpFile represents a file, otherwise false.
Public property | Name | Gets name of file or directory.
Public property | Parent | Gets parent directory of file or directory.
Public property | Permission | Gets or sets permission of file or directory.
Public property | Size | Gets or sets size of file or directory.
Public property | Timestamp | Gets or sets timestamp of file or directory.
Top
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.FullPath Property

Grid Solutions Framework IFtpFileFullPath Property
Gets full path of file or directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string FullPath { get; }
ReadOnly Property FullPath As String
    Get
abstract FullPath : string with get

function get_FullPath();

property String^ FullPath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.IsDirectory Property

Grid Solutions Framework IFtpFileIsDirectory Property
Returns true if IFtpFile represents a directory, otherwise false.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool IsDirectory { get; }
ReadOnly Property IsDirectory As Boolean
    Get
abstract IsDirectory : bool with get

function get_IsDirectory();

property bool IsDirectory {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.IsFile Property

Grid Solutions Framework IFtpFileIsFile Property
Returns true if IFtpFile represents a file, otherwise false.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool IsFile { get; }
ReadOnly Property IsFile As Boolean
    Get
abstract IsFile : bool with get

function get_IsFile();

property bool IsFile {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.Name Property

Grid Solutions Framework IFtpFileName Property
Gets name of file or directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Name { get; }
ReadOnly Property Name As String
    Get
abstract Name : string with get

function get_Name();

property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.Parent Property

Grid Solutions Framework IFtpFileParent Property
Gets parent directory of file or directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
FtpDirectory Parent { get; }
ReadOnly Property Parent As FtpDirectory
    Get
abstract Parent : FtpDirectory with get

function get_Parent();

property FtpDirectory^ Parent {
    FtpDirectory^ get ();
}

Property Value

Type: FtpDirectory
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.Permission Property

Grid Solutions Framework IFtpFilePermission Property
Gets or sets permission of file or directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Permission { get; set; }
Property Permission As String
    Get
    Set
abstract Permission : string with get, set

function get_Permission();
function set_Permission(value);
property String^ Permission {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.Size Property

Grid Solutions Framework IFtpFileSize Property
Gets or sets size of file or directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
long Size { get; set; }
Property Size As Long
    Get
    Set
abstract Size : int64 with get, set

function get_Size();
function set_Size(value);
property long long Size {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


IFtpFile.Timestamp Property

Grid Solutions Framework IFtpFileTimestamp Property
Gets or sets timestamp of file or directory.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DateTime Timestamp { get; set; }
Property Timestamp As DateTime
    Get
    Set
abstract Timestamp : DateTime with get, set

function get_Timestamp();
function set_Timestamp(value);
property DateTime Timestamp {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

IFtpFile Interface
GSF.Net.Ftp Namespace


TransferDirection Enumeration

Grid Solutions Framework TransferDirection Enumeration
FTP file transfer direction enumeration.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum TransferDirection
Public Enumeration TransferDirection
type TransferDirection
GSF.Net.Ftp.TransferDirection = function();
GSF.Net.Ftp.TransferDirection.createEnum('GSF.Net.Ftp.TransferDirection', false);
public enum class TransferDirection
Members
Member name | Value | Description
Upload | 0 | FTP transfer direction set to upload.
Download | 1 | FTP transfer direction set to download.
See Also

Reference

GSF.Net.Ftp Namespace


TransferMode Enumeration

Grid Solutions Framework TransferMode Enumeration
FTP transfer mode enumeration.

Namespace: GSF.Net.Ftp
Assembly: GSF.Net (in GSF.Net.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum TransferMode
Public Enumeration TransferMode
type TransferMode
GSF.Net.Ftp.TransferMode = function();
GSF.Net.Ftp.TransferMode.createEnum('GSF.Net.Ftp.TransferMode', false);
public enum class TransferMode
Members
Member name | Value | Description
Ascii | 0 | Transfer files in ASCII mode.
Binary | 1 | Transfer files in binary mode.
Unknown | 2 | File transfer mode is undetermined.
See Also

Reference

GSF.Net.Ftp Namespace


GSF.Net.Security Namespace

Grid Solutions Framework GSF.Net.Security Namespace

[Missing <summary> documentation for "N:GSF.Net.Security"]

Classes
 | Class | Description
Public class | CertificateGenerator | The CertificateGenerator searches certificate stores for existing certificates and creates self-signed certificates if no matching certificate exists in any accessible store. It then generates a certificate file at the specified certificate path.
Public class | CertificatePolicy | Represents a set of flags to be checked when validating remote certificates.
Public class | CertificatePolicyChecker | Certificate checker that validates remote certificates based on certificate policies associated with each certificate.
Public class | SimpleCertificateChecker | Simple implementation of ICertificateChecker.
Public class | SimplePolicyChecker | Simple implementation of ICertificateChecker.
Interfaces
 | Interface | Description
Public interface | ICertificateChecker | Defines the interface for a generic X.509 certificate checker.


CertificateGenerator Class

Grid Solutions Framework CertificateGenerator Class
The CertificateGenerator searches certificate stores for existing certificates and creates self-signed certificates if no matching certificate exists in any accessible store. It then generates a certificate file at the specified certificate path.
Inheritance Hierarchy
SystemObject
GSF.Net.SecurityCertificateGenerator

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CertificateGenerator
Public Class CertificateGenerator
type CertificateGenerator =  class end
GSF.Net.Security.CertificateGenerator = function();

Type.createClass(
    'GSF.Net.Security.CertificateGenerator');
public ref class CertificateGenerator

The CertificateGenerator type exposes the following members.

Constructors
 | Name | Description
Public method | CertificateGenerator | Initializes a new instance of the CertificateGenerator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateCertificate | Generates the certificate.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CertificatePath | Gets or sets the path to the certificate file that is generated by this certificate generator.
Public property | Issuer | Gets or sets the name of the entity issuing the certificate.
Public property | SubjectNames | Gets or sets the subject names (common names) of the entity that this certificate identifies.
Top
See Also

Reference

GSF.Net.Security Namespace


CertificateGenerator Constructor

Grid Solutions Framework CertificateGenerator Constructor
Initializes a new instance of the CertificateGenerator class

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CertificateGenerator()
Public Sub New
new : unit -> CertificateGenerator
GSF.Net.Security.CertificateGenerator = function();
public:
CertificateGenerator()
See Also

Reference

CertificateGenerator Class
GSF.Net.Security Namespace


CertificateGenerator Methods

Grid Solutions Framework CertificateGenerator Methods

The CertificateGenerator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateCertificate | Generates the certificate.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CertificateGenerator Class
GSF.Net.Security Namespace


CertificateGenerator.GenerateCertificate Method

Grid Solutions Framework CertificateGeneratorGenerateCertificate Method
Generates the certificate.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public X509Certificate2 GenerateCertificate()
Public Function GenerateCertificate As X509Certificate2
member GenerateCertificate : unit -> X509Certificate2

function GenerateCertificate();
public:
X509Certificate2^ GenerateCertificate()

Return Value

Type: X509Certificate2
The certificate that was generated by this certificate generator.
See Also

Reference

CertificateGenerator Class
GSF.Net.Security Namespace


CertificateGenerator Properties

Grid Solutions Framework CertificateGenerator Properties

The CertificateGenerator type exposes the following members.

Properties
 | Name | Description
Public property | CertificatePath | Gets or sets the path to the certificate file that is generated by this certificate generator.
Public property | Issuer | Gets or sets the name of the entity issuing the certificate.
Public property | SubjectNames | Gets or sets the subject names (common names) of the entity that this certificate identifies.
Top
See Also

Reference

CertificateGenerator Class
GSF.Net.Security Namespace


CertificateGenerator.CertificatePath Property

Grid Solutions Framework CertificateGeneratorCertificatePath Property
Gets or sets the path to the certificate file that is generated by this certificate generator.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CertificatePath { get; set; }
Public Property CertificatePath As String
    Get
    Set
member CertificatePath : string with get, set

function get_CertificatePath();
function set_CertificatePath(value);
public:
property String^ CertificatePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CertificateGenerator Class
GSF.Net.Security Namespace


CertificateGenerator.Issuer Property

Grid Solutions Framework CertificateGeneratorIssuer Property
Gets or sets the name of the entity issuing the certificate.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Issuer { get; set; }
Public Property Issuer As String
    Get
    Set
member Issuer : string with get, set

function get_Issuer();
function set_Issuer(value);
public:
property String^ Issuer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CertificateGenerator Class
GSF.Net.Security Namespace


CertificateGenerator.SubjectNames Property

Grid Solutions Framework CertificateGeneratorSubjectNames Property
Gets or sets the subject names (common names) of the entity that this certificate identifies.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] SubjectNames { get; set; }
Public Property SubjectNames As String()
    Get
    Set
member SubjectNames : string[] with get, set

function get_SubjectNames();
function set_SubjectNames(value);
public:
property array<String^>^ SubjectNames {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
See Also

Reference

CertificateGenerator Class
GSF.Net.Security Namespace


CertificatePolicy Class

Grid Solutions Framework CertificatePolicy Class
Represents a set of flags to be checked when validating remote certificates.
Inheritance Hierarchy
SystemObject
GSF.Net.SecurityCertificatePolicy

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CertificatePolicy
Public Class CertificatePolicy
type CertificatePolicy =  class end
GSF.Net.Security.CertificatePolicy = function();

Type.createClass(
    'GSF.Net.Security.CertificatePolicy');
public ref class CertificatePolicy

The CertificatePolicy type exposes the following members.

Constructors
 | Name | Description
Public method | CertificatePolicy | Creates a new instance of the CertificatePolicy class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ValidChainFlags | Gets or sets the set of valid chain flags used when validating remote certificates using this policy.
Public property | ValidPolicyErrors | Gets or sets the set of valid policy errors used when validating remote certificates using this policy.
Top
See Also

Reference

GSF.Net.Security Namespace


CertificatePolicy Constructor

Grid Solutions Framework CertificatePolicy Constructor
Creates a new instance of the CertificatePolicy class.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CertificatePolicy()
Public Sub New
new : unit -> CertificatePolicy
GSF.Net.Security.CertificatePolicy = function();
public:
CertificatePolicy()
See Also

Reference

CertificatePolicy Class
GSF.Net.Security Namespace


CertificatePolicy Methods

Grid Solutions Framework CertificatePolicy Methods

The CertificatePolicy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CertificatePolicy Class
GSF.Net.Security Namespace


CertificatePolicy Properties

Grid Solutions Framework CertificatePolicy Properties

The CertificatePolicy type exposes the following members.

Properties
 | Name | Description
Public property | ValidChainFlags | Gets or sets the set of valid chain flags used when validating remote certificates using this policy.
Public property | ValidPolicyErrors | Gets or sets the set of valid policy errors used when validating remote certificates using this policy.
Top
See Also

Reference

CertificatePolicy Class
GSF.Net.Security Namespace


CertificatePolicy.ValidChainFlags Property

Grid Solutions Framework CertificatePolicyValidChainFlags Property
Gets or sets the set of valid chain flags used when validating remote certificates using this policy.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public X509ChainStatusFlags ValidChainFlags { get; set; }
Public Property ValidChainFlags As X509ChainStatusFlags
    Get
    Set
member ValidChainFlags : X509ChainStatusFlags with get, set

function get_ValidChainFlags();
function set_ValidChainFlags(value);
public:
property X509ChainStatusFlags ValidChainFlags {
    X509ChainStatusFlags get ();
    void set (X509ChainStatusFlags value);
}

Property Value

Type: X509ChainStatusFlags
See Also

Reference

CertificatePolicy Class
GSF.Net.Security Namespace


CertificatePolicy.ValidPolicyErrors Property

Grid Solutions Framework CertificatePolicyValidPolicyErrors Property
Gets or sets the set of valid policy errors used when validating remote certificates using this policy.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SslPolicyErrors ValidPolicyErrors { get; set; }
Public Property ValidPolicyErrors As SslPolicyErrors
    Get
    Set
member ValidPolicyErrors : SslPolicyErrors with get, set

function get_ValidPolicyErrors();
function set_ValidPolicyErrors(value);
public:
property SslPolicyErrors ValidPolicyErrors {
    SslPolicyErrors get ();
    void set (SslPolicyErrors value);
}

Property Value

Type: SslPolicyErrors
See Also

Reference

CertificatePolicy Class
GSF.Net.Security Namespace


CertificatePolicyChecker Class

Grid Solutions Framework CertificatePolicyChecker Class
Certificate checker that validates remote certificates based on certificate policies associated with each certificate.
Inheritance Hierarchy
SystemObject
GSF.Net.SecurityCertificatePolicyChecker

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CertificatePolicyChecker : ICertificateChecker
Public Class CertificatePolicyChecker
    Implements ICertificateChecker
type CertificatePolicyChecker =
    class
        interface ICertificateChecker
    end
GSF.Net.Security.CertificatePolicyChecker = function();

Type.createClass(
    'GSF.Net.Security.CertificatePolicyChecker',
    null,
    GSF.Net.Security.ICertificateChecker);
public ref class CertificatePolicyChecker : ICertificateChecker

The CertificatePolicyChecker type exposes the following members.

Constructors
 | Name | Description
Public method | CertificatePolicyChecker | Creates a new instance of the CertificatePolicyChecker class.
Top
Methods
 | Name | Description
Public method | Distrust | Removes the given certificate from the list of trusted certificates.
Public method | DistrustAll | Removes all certificates from the list of trusted certificates.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTrustedCertificate | Searches the list of trusted certificates for a certificate that matches the given remote certificate.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Trust(X509Certificate) | Trusts the given certificate, using the default policy for validation.
Public method | Trust(X509Certificate, CertificatePolicy) | Trusts the given certificate, using the given policy for validation.
Public method | ValidateRemoteCertificate | Verifies the remote certificate used for authentication.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | DefaultCertificatePolicy | Gets the default certificate policy used to validate certificates that do not have their own certificate policy.
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Top
See Also

Reference

GSF.Net.Security Namespace


CertificatePolicyChecker Constructor

Grid Solutions Framework CertificatePolicyChecker Constructor
Creates a new instance of the CertificatePolicyChecker class.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CertificatePolicyChecker()
Public Sub New
new : unit -> CertificatePolicyChecker
GSF.Net.Security.CertificatePolicyChecker = function();
public:
CertificatePolicyChecker()
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker Methods

Grid Solutions Framework CertificatePolicyChecker Methods

The CertificatePolicyChecker type exposes the following members.

Methods
 | Name | Description
Public method | Distrust | Removes the given certificate from the list of trusted certificates.
Public method | DistrustAll | Removes all certificates from the list of trusted certificates.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetTrustedCertificate | Searches the list of trusted certificates for a certificate that matches the given remote certificate.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Trust(X509Certificate) | Trusts the given certificate, using the default policy for validation.
Public method | Trust(X509Certificate, CertificatePolicy) | Trusts the given certificate, using the given policy for validation.
Public method | ValidateRemoteCertificate | Verifies the remote certificate used for authentication.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker.Distrust Method

Grid Solutions Framework CertificatePolicyCheckerDistrust Method
Removes the given certificate from the list of trusted certificates.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Distrust(
    X509Certificate certificate
)
Public Sub Distrust (
    certificate As X509Certificate
)
member Distrust :
        certificate : X509Certificate -> unit

function Distrust(certificate);
public:
void Distrust(
    X509Certificate^ certificate
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
The certificate to be distrusted.
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker.DistrustAll Method

Grid Solutions Framework CertificatePolicyCheckerDistrustAll Method
Removes all certificates from the list of trusted certificates.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void DistrustAll()
Public Sub DistrustAll
member DistrustAll : unit -> unit

function DistrustAll();
public:
void DistrustAll()
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker.GetTrustedCertificate Method

Grid Solutions Framework CertificatePolicyCheckerGetTrustedCertificate Method
Searches the list of trusted certificates for a certificate that matches the given remote certificate.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public X509Certificate GetTrustedCertificate(
    X509Certificate remoteCertificate
)
Public Function GetTrustedCertificate (
    remoteCertificate As X509Certificate
) As X509Certificate
member GetTrustedCertificate :
        remoteCertificate : X509Certificate -> X509Certificate

function GetTrustedCertificate(remoteCertificate);
public:
X509Certificate^ GetTrustedCertificate(
    X509Certificate^ remoteCertificate
)

Parameters

remoteCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
Remote certificate to search for.

Return Value

Type: X509Certificate
Trusted X509 certificate, if found; otherwise, null.
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker.Trust Method

Grid Solutions Framework CertificatePolicyCheckerTrust Method
Overload List
 | Name | Description
Public method | Trust(X509Certificate) | Trusts the given certificate, using the default policy for validation.
Public method | Trust(X509Certificate, CertificatePolicy) | Trusts the given certificate, using the given policy for validation.
Top
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker.Trust Method (X509Certificate)

Grid Solutions Framework CertificatePolicyCheckerTrust Method (X509Certificate)
Trusts the given certificate, using the default policy for validation.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Trust(
    X509Certificate certificate
)
Public Sub Trust (
    certificate As X509Certificate
)
member Trust :
        certificate : X509Certificate -> unit

function Trust(certificate);
public:
void Trust(
    X509Certificate^ certificate
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
The certificate to be trusted.
See Also

Reference

CertificatePolicyChecker Class
Trust Overload
GSF.Net.Security Namespace


CertificatePolicyChecker.Trust Method (X509Certificate, CertificatePolicy)

Grid Solutions Framework CertificatePolicyCheckerTrust Method (X509Certificate, CertificatePolicy)
Trusts the given certificate, using the given policy for validation.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Trust(
    X509Certificate certificate,
    CertificatePolicy policy
)
Public Sub Trust (
    certificate As X509Certificate,
    policy As CertificatePolicy
)
member Trust :
        certificate : X509Certificate *
        policy : CertificatePolicy -> unit

function Trust(certificate, policy);
public:
void Trust(
    X509Certificate^ certificate,
    CertificatePolicy^ policy
)

Parameters

certificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
The certificate to be trusted.
policy
Type: GSF.Net.SecurityCertificatePolicy
The policy by which to evaluate the certificate.
See Also

Reference

CertificatePolicyChecker Class
Trust Overload
GSF.Net.Security Namespace


CertificatePolicyChecker.ValidateRemoteCertificate Method

Grid Solutions Framework CertificatePolicyCheckerValidateRemoteCertificate Method
Verifies the remote certificate used for authentication.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValidateRemoteCertificate(
    Object sender,
    X509Certificate remoteCertificate,
    X509Chain chain,
    SslPolicyErrors errors
)
Public Function ValidateRemoteCertificate (
    sender As Object,
    remoteCertificate As X509Certificate,
    chain As X509Chain,
    errors As SslPolicyErrors
) As Boolean
abstract ValidateRemoteCertificate :
        sender : Object *
        remoteCertificate : X509Certificate *
        chain : X509Chain *
        errors : SslPolicyErrors -> bool
override ValidateRemoteCertificate :
        sender : Object *
        remoteCertificate : X509Certificate *
        chain : X509Chain *
        errors : SslPolicyErrors -> bool
function ValidateRemoteCertificate(sender, remoteCertificate, chain, errors);
public:
virtual bool ValidateRemoteCertificate(
    Object^ sender,
    X509Certificate^ remoteCertificate,
    X509Chain^ chain,
    SslPolicyErrors errors
) sealed

Parameters

sender
Type: SystemObject
An object that contains state information for this validation.
remoteCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
The certificate used to authenticate the remote party.
chain
Type: System.Security.Cryptography.X509CertificatesX509Chain
The chain of certificate authorities associated with the remote certificate.
errors
Type: System.Net.SecuritySslPolicyErrors
One or more errors associated with the remote certificate.

Return Value

Type: Boolean
A flag that determines whether the specified certificate is accepted for authentication.

Implements

ICertificateCheckerValidateRemoteCertificate(Object, X509Certificate, X509Chain, SslPolicyErrors)
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker Properties

Grid Solutions Framework CertificatePolicyChecker Properties

The CertificatePolicyChecker type exposes the following members.

Properties
 | Name | Description
Public property | DefaultCertificatePolicy | Gets the default certificate policy used to validate certificates that do not have their own certificate policy.
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Top
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker.DefaultCertificatePolicy Property

Grid Solutions Framework CertificatePolicyCheckerDefaultCertificatePolicy Property
Gets the default certificate policy used to validate certificates that do not have their own certificate policy.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CertificatePolicy DefaultCertificatePolicy { get; }
Public ReadOnly Property DefaultCertificatePolicy As CertificatePolicy
    Get
member DefaultCertificatePolicy : CertificatePolicy with get

function get_DefaultCertificatePolicy();

public:
property CertificatePolicy^ DefaultCertificatePolicy {
    CertificatePolicy^ get ();
}

Property Value

Type: CertificatePolicy
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


CertificatePolicyChecker.ReasonForFailure Property

Grid Solutions Framework CertificatePolicyCheckerReasonForFailure Property
Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ReasonForFailure { get; }
Public ReadOnly Property ReasonForFailure As String
    Get
abstract ReasonForFailure : string with get
override ReasonForFailure : string with get
function get_ReasonForFailure();

public:
virtual property String^ ReasonForFailure {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICertificateCheckerReasonForFailure
See Also

Reference

CertificatePolicyChecker Class
GSF.Net.Security Namespace


ICertificateChecker Interface

Grid Solutions Framework ICertificateChecker Interface
Defines the interface for a generic X.509 certificate checker.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ICertificateChecker
Public Interface ICertificateChecker
type ICertificateChecker =  interface end
GSF.Net.Security.ICertificateChecker = function();
GSF.Net.Security.ICertificateChecker.createInterface('GSF.Net.Security.ICertificateChecker');
public interface class ICertificateChecker

The ICertificateChecker type exposes the following members.

Methods
 | Name | Description
Public method | ValidateRemoteCertificate | Verifies the remote certificate used for authentication.
Top
Properties
 | Name | Description
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Top
See Also

Reference

GSF.Net.Security Namespace


ICertificateChecker Methods

Grid Solutions Framework ICertificateChecker Methods

The ICertificateChecker type exposes the following members.

Methods
 | Name | Description
Public method | ValidateRemoteCertificate | Verifies the remote certificate used for authentication.
Top
See Also

Reference

ICertificateChecker Interface
GSF.Net.Security Namespace


ICertificateChecker.ValidateRemoteCertificate Method

Grid Solutions Framework ICertificateCheckerValidateRemoteCertificate Method
Verifies the remote certificate used for authentication.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool ValidateRemoteCertificate(
    Object sender,
    X509Certificate remoteCertificate,
    X509Chain chain,
    SslPolicyErrors errors
)
Function ValidateRemoteCertificate (
    sender As Object,
    remoteCertificate As X509Certificate,
    chain As X509Chain,
    errors As SslPolicyErrors
) As Boolean
abstract ValidateRemoteCertificate :
        sender : Object *
        remoteCertificate : X509Certificate *
        chain : X509Chain *
        errors : SslPolicyErrors -> bool

function ValidateRemoteCertificate(sender, remoteCertificate, chain, errors);
bool ValidateRemoteCertificate(
    Object^ sender,
    X509Certificate^ remoteCertificate,
    X509Chain^ chain,
    SslPolicyErrors errors
)

Parameters

sender
Type: SystemObject
An object that contains state information for this validation.
remoteCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
The certificate used to authenticate the remote party.
chain
Type: System.Security.Cryptography.X509CertificatesX509Chain
The chain of certificate authorities associated with the remote certificate.
errors
Type: System.Net.SecuritySslPolicyErrors
One or more errors associated with the remote certificate.

Return Value

Type: Boolean
A flag that determines whether the specified certificate is accepted for authentication.
See Also

Reference

ICertificateChecker Interface
GSF.Net.Security Namespace


ICertificateChecker Properties

Grid Solutions Framework ICertificateChecker Properties

The ICertificateChecker type exposes the following members.

Properties
 | Name | Description
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Top
See Also

Reference

ICertificateChecker Interface
GSF.Net.Security Namespace


ICertificateChecker.ReasonForFailure Property

Grid Solutions Framework ICertificateCheckerReasonForFailure Property
Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ReasonForFailure { get; }
ReadOnly Property ReasonForFailure As String
    Get
abstract ReasonForFailure : string with get

function get_ReasonForFailure();

property String^ ReasonForFailure {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ICertificateChecker Interface
GSF.Net.Security Namespace


SimpleCertificateChecker Class

Grid Solutions Framework SimpleCertificateChecker Class
Simple implementation of ICertificateChecker.
Inheritance Hierarchy
SystemObject
GSF.Net.SecuritySimpleCertificateChecker

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SimpleCertificateChecker : ICertificateChecker
Public Class SimpleCertificateChecker
    Implements ICertificateChecker
type SimpleCertificateChecker =
    class
        interface ICertificateChecker
    end
GSF.Net.Security.SimpleCertificateChecker = function();

Type.createClass(
    'GSF.Net.Security.SimpleCertificateChecker',
    null,
    GSF.Net.Security.ICertificateChecker);
public ref class SimpleCertificateChecker : ICertificateChecker

The SimpleCertificateChecker type exposes the following members.

Constructors
 | Name | Description
Public method | SimpleCertificateChecker | Creates a new instance of the SimpleCertificateChecker class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateRemoteCertificate(X509Certificate) | Validates the given remote certificate to determine if the host is trusted.
Public method | ValidateRemoteCertificate(Object, X509Certificate, X509Chain, SslPolicyErrors) | Verifies the remote certificate used for authentication.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Public property | TrustedCertificates | Gets the list of certificates on the system which are considered trusted when validating remote certificates.
Public property | ValidChainFlags | Gets or sets the set of invalid chain flags.
Public property | ValidPolicyErrors | Gets or sets the set of invalid policy errors.
Top
See Also

Reference

GSF.Net.Security Namespace


SimpleCertificateChecker Constructor

Grid Solutions Framework SimpleCertificateChecker Constructor
Creates a new instance of the SimpleCertificateChecker class.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SimpleCertificateChecker()
Public Sub New
new : unit -> SimpleCertificateChecker
GSF.Net.Security.SimpleCertificateChecker = function();
public:
SimpleCertificateChecker()
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimpleCertificateChecker Methods

Grid Solutions Framework SimpleCertificateChecker Methods

The SimpleCertificateChecker type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateRemoteCertificate(X509Certificate) | Validates the given remote certificate to determine if the host is trusted.
Public method | ValidateRemoteCertificate(Object, X509Certificate, X509Chain, SslPolicyErrors) | Verifies the remote certificate used for authentication.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimpleCertificateChecker.ValidateRemoteCertificate Method

Grid Solutions Framework SimpleCertificateCheckerValidateRemoteCertificate Method
Overload List
 | Name | Description
Public method | ValidateRemoteCertificate(X509Certificate) | Validates the given remote certificate to determine if the host is trusted.
Public method | ValidateRemoteCertificate(Object, X509Certificate, X509Chain, SslPolicyErrors) | Verifies the remote certificate used for authentication.
Top
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimpleCertificateChecker.ValidateRemoteCertificate Method (X509Certificate)

Grid Solutions Framework SimpleCertificateCheckerValidateRemoteCertificate Method (X509Certificate)
Validates the given remote certificate to determine if the host is trusted.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValidateRemoteCertificate(
    X509Certificate remoteCertificate
)
Public Function ValidateRemoteCertificate (
    remoteCertificate As X509Certificate
) As Boolean
member ValidateRemoteCertificate :
        remoteCertificate : X509Certificate -> bool

function ValidateRemoteCertificate(remoteCertificate);
public:
bool ValidateRemoteCertificate(
    X509Certificate^ remoteCertificate
)

Parameters

remoteCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
Certificate of the remote host.

Return Value

Type: Boolean
True if the remote certificate is trusted; false otherwise.
See Also

Reference

SimpleCertificateChecker Class
ValidateRemoteCertificate Overload
GSF.Net.Security Namespace


SimpleCertificateChecker.ValidateRemoteCertificate Method (Object, X509Certificate, X509Chain, SslPolicyErrors)

Grid Solutions Framework SimpleCertificateCheckerValidateRemoteCertificate Method (Object, X509Certificate, X509Chain, SslPolicyErrors)
Verifies the remote certificate used for authentication.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValidateRemoteCertificate(
    Object sender,
    X509Certificate remoteCertificate,
    X509Chain chain,
    SslPolicyErrors errors
)
Public Function ValidateRemoteCertificate (
    sender As Object,
    remoteCertificate As X509Certificate,
    chain As X509Chain,
    errors As SslPolicyErrors
) As Boolean
abstract ValidateRemoteCertificate :
        sender : Object *
        remoteCertificate : X509Certificate *
        chain : X509Chain *
        errors : SslPolicyErrors -> bool
override ValidateRemoteCertificate :
        sender : Object *
        remoteCertificate : X509Certificate *
        chain : X509Chain *
        errors : SslPolicyErrors -> bool
function ValidateRemoteCertificate(sender, remoteCertificate, chain, errors);
public:
virtual bool ValidateRemoteCertificate(
    Object^ sender,
    X509Certificate^ remoteCertificate,
    X509Chain^ chain,
    SslPolicyErrors errors
) sealed

Parameters

sender
Type: SystemObject
An object that contains state information for this validation.
remoteCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
The certificate used to authenticate the remote party.
chain
Type: System.Security.Cryptography.X509CertificatesX509Chain
The chain of certificate authorities associated with the remote certificate.
errors
Type: System.Net.SecuritySslPolicyErrors
One or more errors associated with the remote certificate.

Return Value

Type: Boolean
A flag that determines whether the specified certificate is accepted for authentication.

Implements

ICertificateCheckerValidateRemoteCertificate(Object, X509Certificate, X509Chain, SslPolicyErrors)
See Also

Reference

SimpleCertificateChecker Class
ValidateRemoteCertificate Overload
GSF.Net.Security Namespace


SimpleCertificateChecker Properties

Grid Solutions Framework SimpleCertificateChecker Properties

The SimpleCertificateChecker type exposes the following members.

Properties
 | Name | Description
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Public property | TrustedCertificates | Gets the list of certificates on the system which are considered trusted when validating remote certificates.
Public property | ValidChainFlags | Gets or sets the set of invalid chain flags.
Public property | ValidPolicyErrors | Gets or sets the set of invalid policy errors.
Top
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimpleCertificateChecker.ReasonForFailure Property

Grid Solutions Framework SimpleCertificateCheckerReasonForFailure Property
Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ReasonForFailure { get; }
Public ReadOnly Property ReasonForFailure As String
    Get
abstract ReasonForFailure : string with get
override ReasonForFailure : string with get
function get_ReasonForFailure();

public:
virtual property String^ ReasonForFailure {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICertificateCheckerReasonForFailure
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimpleCertificateChecker.TrustedCertificates Property

Grid Solutions Framework SimpleCertificateCheckerTrustedCertificates Property
Gets the list of certificates on the system which are considered trusted when validating remote certificates.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<X509Certificate> TrustedCertificates { get; }
Public ReadOnly Property TrustedCertificates As List(Of X509Certificate)
    Get
member TrustedCertificates : List<X509Certificate> with get

function get_TrustedCertificates();

public:
property List<X509Certificate^>^ TrustedCertificates {
    List<X509Certificate^>^ get ();
}

Property Value

Type: List X509Certificate
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimpleCertificateChecker.ValidChainFlags Property

Grid Solutions Framework SimpleCertificateCheckerValidChainFlags Property
Gets or sets the set of invalid chain flags.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public X509ChainStatusFlags ValidChainFlags { get; set; }
Public Property ValidChainFlags As X509ChainStatusFlags
    Get
    Set
member ValidChainFlags : X509ChainStatusFlags with get, set

function get_ValidChainFlags();
function set_ValidChainFlags(value);
public:
property X509ChainStatusFlags ValidChainFlags {
    X509ChainStatusFlags get ();
    void set (X509ChainStatusFlags value);
}

Property Value

Type: X509ChainStatusFlags
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimpleCertificateChecker.ValidPolicyErrors Property

Grid Solutions Framework SimpleCertificateCheckerValidPolicyErrors Property
Gets or sets the set of invalid policy errors.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SslPolicyErrors ValidPolicyErrors { get; set; }
Public Property ValidPolicyErrors As SslPolicyErrors
    Get
    Set
member ValidPolicyErrors : SslPolicyErrors with get, set

function get_ValidPolicyErrors();
function set_ValidPolicyErrors(value);
public:
property SslPolicyErrors ValidPolicyErrors {
    SslPolicyErrors get ();
    void set (SslPolicyErrors value);
}

Property Value

Type: SslPolicyErrors
See Also

Reference

SimpleCertificateChecker Class
GSF.Net.Security Namespace


SimplePolicyChecker Class

Grid Solutions Framework SimplePolicyChecker Class
Simple implementation of ICertificateChecker.
Inheritance Hierarchy
SystemObject
GSF.Net.SecuritySimplePolicyChecker

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SimplePolicyChecker : ICertificateChecker
Public Class SimplePolicyChecker
    Implements ICertificateChecker
type SimplePolicyChecker =
    class
        interface ICertificateChecker
    end
GSF.Net.Security.SimplePolicyChecker = function();

Type.createClass(
    'GSF.Net.Security.SimplePolicyChecker',
    null,
    GSF.Net.Security.ICertificateChecker);
public ref class SimplePolicyChecker : ICertificateChecker

The SimplePolicyChecker type exposes the following members.

Constructors
 | Name | Description
Public method | SimplePolicyChecker | Creates a new instance of the SimplePolicyChecker class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateRemoteCertificate | Verifies the remote certificate used for authentication.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Public property | ValidChainFlags | Gets or sets the set of invalid chain flags.
Public property | ValidPolicyErrors | Gets or sets the set of invalid policy errors.
Top
See Also

Reference

GSF.Net.Security Namespace


SimplePolicyChecker Constructor

Grid Solutions Framework SimplePolicyChecker Constructor
Creates a new instance of the SimplePolicyChecker class.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SimplePolicyChecker()
Public Sub New
new : unit -> SimplePolicyChecker
GSF.Net.Security.SimplePolicyChecker = function();
public:
SimplePolicyChecker()
See Also

Reference

SimplePolicyChecker Class
GSF.Net.Security Namespace


SimplePolicyChecker Methods

Grid Solutions Framework SimplePolicyChecker Methods

The SimplePolicyChecker type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | ValidateRemoteCertificate | Verifies the remote certificate used for authentication.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SimplePolicyChecker Class
GSF.Net.Security Namespace


SimplePolicyChecker.ValidateRemoteCertificate Method

Grid Solutions Framework SimplePolicyCheckerValidateRemoteCertificate Method
Verifies the remote certificate used for authentication.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ValidateRemoteCertificate(
    Object sender,
    X509Certificate remoteCertificate,
    X509Chain chain,
    SslPolicyErrors errors
)
Public Function ValidateRemoteCertificate (
    sender As Object,
    remoteCertificate As X509Certificate,
    chain As X509Chain,
    errors As SslPolicyErrors
) As Boolean
abstract ValidateRemoteCertificate :
        sender : Object *
        remoteCertificate : X509Certificate *
        chain : X509Chain *
        errors : SslPolicyErrors -> bool
override ValidateRemoteCertificate :
        sender : Object *
        remoteCertificate : X509Certificate *
        chain : X509Chain *
        errors : SslPolicyErrors -> bool
function ValidateRemoteCertificate(sender, remoteCertificate, chain, errors);
public:
virtual bool ValidateRemoteCertificate(
    Object^ sender,
    X509Certificate^ remoteCertificate,
    X509Chain^ chain,
    SslPolicyErrors errors
) sealed

Parameters

sender
Type: SystemObject
An object that contains state information for this validation.
remoteCertificate
Type: System.Security.Cryptography.X509CertificatesX509Certificate
The certificate used to authenticate the remote party.
chain
Type: System.Security.Cryptography.X509CertificatesX509Chain
The chain of certificate authorities associated with the remote certificate.
errors
Type: System.Net.SecuritySslPolicyErrors
One or more errors associated with the remote certificate.

Return Value

Type: Boolean
A flag that determines whether the specified certificate is accepted for authentication.

Implements

ICertificateCheckerValidateRemoteCertificate(Object, X509Certificate, X509Chain, SslPolicyErrors)
See Also

Reference

SimplePolicyChecker Class
GSF.Net.Security Namespace


SimplePolicyChecker Properties

Grid Solutions Framework SimplePolicyChecker Properties

The SimplePolicyChecker type exposes the following members.

Properties
 | Name | Description
Public property | ReasonForFailure | Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.
Public property | ValidChainFlags | Gets or sets the set of invalid chain flags.
Public property | ValidPolicyErrors | Gets or sets the set of invalid policy errors.
Top
See Also

Reference

SimplePolicyChecker Class
GSF.Net.Security Namespace


SimplePolicyChecker.ReasonForFailure Property

Grid Solutions Framework SimplePolicyCheckerReasonForFailure Property
Gets the reason why the remote certificate validation failed, or null if certificate validation did not fail.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ReasonForFailure { get; }
Public ReadOnly Property ReasonForFailure As String
    Get
abstract ReasonForFailure : string with get
override ReasonForFailure : string with get
function get_ReasonForFailure();

public:
virtual property String^ ReasonForFailure {
    String^ get () sealed;
}

Property Value

Type: String

Implements

ICertificateCheckerReasonForFailure
See Also

Reference

SimplePolicyChecker Class
GSF.Net.Security Namespace


SimplePolicyChecker.ValidChainFlags Property

Grid Solutions Framework SimplePolicyCheckerValidChainFlags Property
Gets or sets the set of invalid chain flags.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public X509ChainStatusFlags ValidChainFlags { get; set; }
Public Property ValidChainFlags As X509ChainStatusFlags
    Get
    Set
member ValidChainFlags : X509ChainStatusFlags with get, set

function get_ValidChainFlags();
function set_ValidChainFlags(value);
public:
property X509ChainStatusFlags ValidChainFlags {
    X509ChainStatusFlags get ();
    void set (X509ChainStatusFlags value);
}

Property Value

Type: X509ChainStatusFlags
See Also

Reference

SimplePolicyChecker Class
GSF.Net.Security Namespace


SimplePolicyChecker.ValidPolicyErrors Property

Grid Solutions Framework SimplePolicyCheckerValidPolicyErrors Property
Gets or sets the set of invalid policy errors.

Namespace: GSF.Net.Security
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SslPolicyErrors ValidPolicyErrors { get; set; }
Public Property ValidPolicyErrors As SslPolicyErrors
    Get
    Set
member ValidPolicyErrors : SslPolicyErrors with get, set

function get_ValidPolicyErrors();
function set_ValidPolicyErrors(value);
public:
property SslPolicyErrors ValidPolicyErrors {
    SslPolicyErrors get ();
    void set (SslPolicyErrors value);
}

Property Value

Type: SslPolicyErrors
See Also

Reference

SimplePolicyChecker Class
GSF.Net.Security Namespace


GSF.Net.Smtp Namespace

Grid Solutions Framework GSF.Net.Smtp Namespace
Contains classes used to simplify and standardize operations related to sending e-mail messages.
Classes
Class | Description
Mail | A wrapper class to the MailMessage class that simplifies sending mail messages.


Mail Class

Grid Solutions Framework Mail Class
A wrapper class to the MailMessage class that simplifies sending mail messages.
Inheritance Hierarchy
SystemObject
GSF.Net.SmtpMail

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Mail : IDisposable
Public Class Mail
    Implements IDisposable
type Mail =
    class
        interface IDisposable
    end
GSF.Net.Smtp.Mail = function();

Type.createClass(
    'GSF.Net.Smtp.Mail',
    null,
    IDisposable);
public ref class Mail : IDisposable

The Mail type exposes the following members.

Constructors
 | Name | Description
Public method | Mail(String, String) | Initializes a new instance of the Mail class.
Public method | Mail(String, String, String) | Initializes a new instance of the Mail class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the Mail object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Mail object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Mail object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Send | Send the Mail message with Attachments to the ToRecipients, CcRecipients and BccRecipients using the specified SmtpServer.
 | Send(String, String, String, String, Boolean, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String, SecureString) | Sends a secure Mail message.
 | Send(String, String, String, String, Boolean, String, String, String) | Sends a secure Mail message.
 | Send(String, String, String, String, String, String, Boolean, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String, SecureString, Boolean) | Sends a secure Mail message.
 | Send(String, String, String, String, Boolean, String, String, String, Boolean) | Sends a secure Mail message.
 | Send(String, String, String, String, String, String, Boolean, String, String) | Sends a Mail message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultSmtpServer | Default SmtpServer to be used if one is not specified.
Top
Properties
 | Name | Description
Public property | Attachments | Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message.
Public property | BccRecipients | Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message blank carbon copy (BCC) recipients.
Public property | Body | Gets or sets the body of the Mail message.
Public property | CcRecipients | Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message carbon copy (CC) recipients.
Public property | Client | Gets the SmtpClient object used for sending the Mail message.
Public property | EnableSSL | Gets or sets the flag that determines whether to use SSL when communicating with the SMTP server.
Public property | From | Gets or sets the e-mail address of the Mail message sender.
Public property | IsBodyHtml | Gets or sets a boolean value that indicating whether the Mail message Body is to be formatted as HTML.
Public property | Password | Gets or sets the password used to authenticate to the SMTP server.
Public property | SecurePassword | Gets or sets the password used to authenticate to the SMTP server.
Public property | SmtpServer | Gets or sets the name or IP address of the SMTP server to be used for sending the Mail message.
Public property | Subject | Gets or sets the subject of the Mail message.
Public property | ToRecipients | Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
Public property | Username | Gets or sets the username used to authenticate to the SMTP server.
Top
Examples
This example shows how to send an email message with attachment:
Copy
using System;
using GSF.Net.Smtp;

class Program
{
    static void Main(string[] args)
    {
        Mail email = new Mail("sender@email.com", "recipient@email.com", "smtp.email.com");
        email.Subject = "Test Message";
        email.Body = "This is a test message.";
        email.IsBodyHtml = true;
        email.Attachments = @"c:\attachment.txt";
        email.Send();
        email.Dispose();

        Console.ReadLine();
    }
}
See Also

Reference

GSF.Net.Smtp Namespace


Mail Constructor

Grid Solutions Framework Mail Constructor
Overload List
 | Name | Description
Public method | Mail(String, String) | Initializes a new instance of the Mail class.
Public method | Mail(String, String, String) | Initializes a new instance of the Mail class.
Top
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail Constructor (String, String)

Grid Solutions Framework Mail Constructor (String, String)
Initializes a new instance of the Mail class.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Mail(
    string from,
    string toRecipients
)
Public Sub New (
    from As String,
    toRecipients As String
)
new :
        from : string *
        toRecipients : string -> Mail
GSF.Net.Smtp.Mail = function(from, toRecipients);
public:
Mail(
    String^ from,
    String^ toRecipients
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
See Also

Reference

Mail Class
Mail Overload
GSF.Net.Smtp Namespace


Mail Constructor (String, String, String)

Grid Solutions Framework Mail Constructor (String, String, String)
Initializes a new instance of the Mail class.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Mail(
    string from,
    string toRecipients,
    string smtpServer
)
Public Sub New (
    from As String,
    toRecipients As String,
    smtpServer As String
)
new :
        from : string *
        toRecipients : string *
        smtpServer : string -> Mail
GSF.Net.Smtp.Mail = function(from, toRecipients, smtpServer);
public:
Mail(
    String^ from,
    String^ toRecipients,
    String^ smtpServer
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
See Also

Reference

Mail Class
Mail Overload
GSF.Net.Smtp Namespace


Mail Fields

Grid Solutions Framework Mail Fields

The Mail type exposes the following members.

Fields
Name | Description
DefaultSmtpServer | Default SmtpServer to be used if one is not specified.
Top
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.DefaultSmtpServer Field

Grid Solutions Framework MailDefaultSmtpServer Field
Default SmtpServer to be used if one is not specified.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSmtpServer
Public Const DefaultSmtpServer As String
static val mutable DefaultSmtpServer: string
var GSF.Net.Smtp.Mail.DefaultSmtpServer
public:
literal String^ DefaultSmtpServer

Field Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail Methods

Grid Solutions Framework Mail Methods

The Mail type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the Mail object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Mail object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Mail object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Send | Send the Mail message with Attachments to the ToRecipients, CcRecipients and BccRecipients using the specified SmtpServer.
 | Send(String, String, String, String, Boolean, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String, SecureString) | Sends a secure Mail message.
 | Send(String, String, String, String, Boolean, String, String, String) | Sends a secure Mail message.
 | Send(String, String, String, String, String, String, Boolean, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String, SecureString, Boolean) | Sends a secure Mail message.
 | Send(String, String, String, String, Boolean, String, String, String, Boolean) | Sends a secure Mail message.
 | Send(String, String, String, String, String, String, Boolean, String, String) | Sends a Mail message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Dispose Method

Grid Solutions Framework MailDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Mail object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Mail object and optionally releases the managed resources.
Top
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Dispose Method

Grid Solutions Framework MailDispose Method
Releases all the resources used by the Mail object.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

Mail Class
Dispose Overload
GSF.Net.Smtp Namespace


Mail.Dispose Method (Boolean)

Grid Solutions Framework MailDispose Method (Boolean)
Releases the unmanaged resources used by the Mail object and optionally releases the managed resources.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

Mail Class
Dispose Overload
GSF.Net.Smtp Namespace


Mail.Finalize Method

Grid Solutions Framework MailFinalize Method
Releases the unmanaged resources before the Mail object is reclaimed by GC.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Send Method

Grid Solutions Framework MailSend Method
Overload List
 | Name | Description
Public method | Send | Send the Mail message with Attachments to the ToRecipients, CcRecipients and BccRecipients using the specified SmtpServer.
 | Send(String, String, String, String, Boolean, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String, SecureString) | Sends a secure Mail message.
 | Send(String, String, String, String, Boolean, String, String, String) | Sends a secure Mail message.
 | Send(String, String, String, String, String, String, Boolean, String) | Sends a Mail message.
 | Send(String, String, String, String, Boolean, String, String, SecureString, Boolean) | Sends a secure Mail message.
 | Send(String, String, String, String, Boolean, String, String, String, Boolean) | Sends a secure Mail message.
 | Send(String, String, String, String, String, String, Boolean, String, String) | Sends a Mail message.
Top
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Send Method

Grid Solutions Framework MailSend Method
Send the Mail message with Attachments to the ToRecipients, CcRecipients and BccRecipients using the specified SmtpServer.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Send()
Public Sub Send
member Send : unit -> unit

function Send();
public:
void Send()
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, Boolean, String)

Grid Solutions Framework MailSend Method (String, String, String, String, Boolean, String)
Sends a Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string smtpServer
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    smtpServer As String
)
static member Send :
        from : string *
        toRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        smtpServer : string -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, subject, body, isBodyHtml, smtpServer);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ smtpServer
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, Boolean, String, String)

Grid Solutions Framework MailSend Method (String, String, String, String, Boolean, String, String)
Sends a Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string attachments,
    string smtpServer
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    attachments As String,
    smtpServer As String
)
static member Send :
        from : string *
        toRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        attachments : string *
        smtpServer : string -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, subject, body, isBodyHtml, attachments, smtpServer);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ attachments,
    String^ smtpServer
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
attachments
Type: SystemString
A comma-separated or semicolon-seperated list of file names to be attached to the Mail message.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, Boolean, String, String, SecureString)

Grid Solutions Framework MailSend Method (String, String, String, String, Boolean, String, String, SecureString)
Sends a secure Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string smtpServer,
    string username,
    SecureString password
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    smtpServer As String,
    username As String,
    password As SecureString
)
static member Send :
        from : string *
        toRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        smtpServer : string *
        username : string *
        password : SecureString -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, subject, body, isBodyHtml, smtpServer, username, password);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ smtpServer,
    String^ username,
    SecureString^ password
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
username
Type: SystemString
The username of the account used to authenticate to the SMTP server.
password
Type: System.SecuritySecureString
The password of the account used to authenticate to the SMTP server.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, Boolean, String, String, String)

Grid Solutions Framework MailSend Method (String, String, String, String, Boolean, String, String, String)
Sends a secure Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string smtpServer,
    string username,
    string password
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    smtpServer As String,
    username As String,
    password As String
)
static member Send :
        from : string *
        toRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        smtpServer : string *
        username : string *
        password : string -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, subject, body, isBodyHtml, smtpServer, username, password);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ smtpServer,
    String^ username,
    String^ password
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
username
Type: SystemString
The username of the account used to authenticate to the SMTP server.
password
Type: SystemString
The password of the account used to authenticate to the SMTP server.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, String, String, Boolean, String)

Grid Solutions Framework MailSend Method (String, String, String, String, String, String, Boolean, String)
Sends a Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string ccRecipients,
    string bccRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string smtpServer
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    ccRecipients As String,
    bccRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    smtpServer As String
)
static member Send :
        from : string *
        toRecipients : string *
        ccRecipients : string *
        bccRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        smtpServer : string -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, ccRecipients, bccRecipients, subject, body, isBodyHtml, smtpServer);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ ccRecipients,
    String^ bccRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ smtpServer
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
ccRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message carbon copy (CC) recipients.
bccRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message blank carbon copy (BCC) recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, Boolean, String, String, SecureString, Boolean)

Grid Solutions Framework MailSend Method (String, String, String, String, Boolean, String, String, SecureString, Boolean)
Sends a secure Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string smtpServer,
    string username,
    SecureString password,
    bool enableSSL
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    smtpServer As String,
    username As String,
    password As SecureString,
    enableSSL As Boolean
)
static member Send :
        from : string *
        toRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        smtpServer : string *
        username : string *
        password : SecureString *
        enableSSL : bool -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, subject, body, isBodyHtml, smtpServer, username, password, enableSSL);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ smtpServer,
    String^ username,
    SecureString^ password,
    bool enableSSL
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
username
Type: SystemString
The username of the account used to authenticate to the SMTP server.
password
Type: System.SecuritySecureString
The password of the account used to authenticate to the SMTP server.
enableSSL
Type: SystemBoolean
The flag that determines whether to use SSL when communicating with the SMTP server.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, Boolean, String, String, String, Boolean)

Grid Solutions Framework MailSend Method (String, String, String, String, Boolean, String, String, String, Boolean)
Sends a secure Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string smtpServer,
    string username,
    string password,
    bool enableSSL
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    smtpServer As String,
    username As String,
    password As String,
    enableSSL As Boolean
)
static member Send :
        from : string *
        toRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        smtpServer : string *
        username : string *
        password : string *
        enableSSL : bool -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, subject, body, isBodyHtml, smtpServer, username, password, enableSSL);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ smtpServer,
    String^ username,
    String^ password,
    bool enableSSL
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
username
Type: SystemString
The username of the account used to authenticate to the SMTP server.
password
Type: SystemString
The password of the account used to authenticate to the SMTP server.
enableSSL
Type: SystemBoolean
The flag that determines whether to use SSL when communicating with the SMTP server.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail.Send Method (String, String, String, String, String, String, Boolean, String, String)

Grid Solutions Framework MailSend Method (String, String, String, String, String, String, Boolean, String, String)
Sends a Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Send(
    string from,
    string toRecipients,
    string ccRecipients,
    string bccRecipients,
    string subject,
    string body,
    bool isBodyHtml,
    string attachments,
    string smtpServer
)
Public Shared Sub Send (
    from As String,
    toRecipients As String,
    ccRecipients As String,
    bccRecipients As String,
    subject As String,
    body As String,
    isBodyHtml As Boolean,
    attachments As String,
    smtpServer As String
)
static member Send :
        from : string *
        toRecipients : string *
        ccRecipients : string *
        bccRecipients : string *
        subject : string *
        body : string *
        isBodyHtml : bool *
        attachments : string *
        smtpServer : string -> unit

GSF.Net.Smtp.Mail.Send = function(from, toRecipients, ccRecipients, bccRecipients, subject, body, isBodyHtml, attachments, smtpServer);
public:
static void Send(
    String^ from,
    String^ toRecipients,
    String^ ccRecipients,
    String^ bccRecipients,
    String^ subject,
    String^ body,
    bool isBodyHtml,
    String^ attachments,
    String^ smtpServer
)

Parameters

from
Type: SystemString
The e-mail address of the Mail message sender.
toRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
ccRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message carbon copy (CC) recipients.
bccRecipients
Type: SystemString
A comma-separated or semicolon-seperated e-mail address list of the Mail message blank carbon copy (BCC) recipients.
subject
Type: SystemString
The subject of the Mail message.
body
Type: SystemString
The body of the Mail message.
isBodyHtml
Type: SystemBoolean
true if the Mail message body is to be formated as HTML; otherwise false.
attachments
Type: SystemString
A comma-separated or semicolon-seperated list of file names to be attached to the Mail message.
smtpServer
Type: SystemString
The name or IP address of the SMTP server to be used for sending the Mail message.
See Also

Reference

Mail Class
Send Overload
GSF.Net.Smtp Namespace


Mail Properties

Grid Solutions Framework Mail Properties

The Mail type exposes the following members.

Properties
 | Name | Description
Public property | Attachments | Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message.
Public property | BccRecipients | Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message blank carbon copy (BCC) recipients.
Public property | Body | Gets or sets the body of the Mail message.
Public property | CcRecipients | Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message carbon copy (CC) recipients.
Public property | Client | Gets the SmtpClient object used for sending the Mail message.
Public property | EnableSSL | Gets or sets the flag that determines whether to use SSL when communicating with the SMTP server.
Public property | From | Gets or sets the e-mail address of the Mail message sender.
Public property | IsBodyHtml | Gets or sets a boolean value that indicating whether the Mail message Body is to be formatted as HTML.
Public property | Password | Gets or sets the password used to authenticate to the SMTP server.
Public property | SecurePassword | Gets or sets the password used to authenticate to the SMTP server.
Public property | SmtpServer | Gets or sets the name or IP address of the SMTP server to be used for sending the Mail message.
Public property | Subject | Gets or sets the subject of the Mail message.
Public property | ToRecipients | Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.
Public property | Username | Gets or sets the username used to authenticate to the SMTP server.
Top
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Attachments Property

Grid Solutions Framework MailAttachments Property
Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Attachments { get; set; }
Public Property Attachments As String
    Get
    Set
member Attachments : string with get, set

function get_Attachments();
function set_Attachments(value);
public:
property String^ Attachments {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.BccRecipients Property

Grid Solutions Framework MailBccRecipients Property
Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message blank carbon copy (BCC) recipients.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string BccRecipients { get; set; }
Public Property BccRecipients As String
    Get
    Set
member BccRecipients : string with get, set

function get_BccRecipients();
function set_BccRecipients(value);
public:
property String^ BccRecipients {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Body Property

Grid Solutions Framework MailBody Property
Gets or sets the body of the Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Body { get; set; }
Public Property Body As String
    Get
    Set
member Body : string with get, set

function get_Body();
function set_Body(value);
public:
property String^ Body {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.CcRecipients Property

Grid Solutions Framework MailCcRecipients Property
Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message carbon copy (CC) recipients.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CcRecipients { get; set; }
Public Property CcRecipients As String
    Get
    Set
member CcRecipients : string with get, set

function get_CcRecipients();
function set_CcRecipients(value);
public:
property String^ CcRecipients {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Client Property

Grid Solutions Framework MailClient Property
Gets the SmtpClient object used for sending the Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SmtpClient Client { get; }
Public ReadOnly Property Client As SmtpClient
    Get
member Client : SmtpClient with get

function get_Client();

public:
property SmtpClient^ Client {
    SmtpClient^ get ();
}

Property Value

Type: SmtpClient
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.EnableSSL Property

Grid Solutions Framework MailEnableSSL Property
Gets or sets the flag that determines whether to use SSL when communicating with the SMTP server.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool EnableSSL { get; set; }
Public Property EnableSSL As Boolean
    Get
    Set
member EnableSSL : bool with get, set

function get_EnableSSL();
function set_EnableSSL(value);
public:
property bool EnableSSL {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.From Property

Grid Solutions Framework MailFrom Property
Gets or sets the e-mail address of the Mail message sender.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string From { get; set; }
Public Property From As String
    Get
    Set
member From : string with get, set

function get_From();
function set_From(value);
public:
property String^ From {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Value being assigned is a null or empty string.
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.IsBodyHtml Property

Grid Solutions Framework MailIsBodyHtml Property
Gets or sets a boolean value that indicating whether the Mail message Body is to be formatted as HTML.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsBodyHtml { get; set; }
Public Property IsBodyHtml As Boolean
    Get
    Set
member IsBodyHtml : bool with get, set

function get_IsBodyHtml();
function set_IsBodyHtml(value);
public:
property bool IsBodyHtml {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Password Property

Grid Solutions Framework MailPassword Property
Gets or sets the password used to authenticate to the SMTP server.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
member Password : string with get, set

function get_Password();
function set_Password(value);
public:
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.SecurePassword Property

Grid Solutions Framework MailSecurePassword Property
Gets or sets the password used to authenticate to the SMTP server.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureString SecurePassword { get; set; }
Public Property SecurePassword As SecureString
    Get
    Set
member SecurePassword : SecureString with get, set

function get_SecurePassword();
function set_SecurePassword(value);
public:
property SecureString^ SecurePassword {
    SecureString^ get ();
    void set (SecureString^ value);
}

Property Value

Type: SecureString
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.SmtpServer Property

Grid Solutions Framework MailSmtpServer Property
Gets or sets the name or IP address of the SMTP server to be used for sending the Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SmtpServer { get; set; }
Public Property SmtpServer As String
    Get
    Set
member SmtpServer : string with get, set

function get_SmtpServer();
function set_SmtpServer(value);
public:
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Value being assigned is a null or empty string.
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Subject Property

Grid Solutions Framework MailSubject Property
Gets or sets the subject of the Mail message.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Subject { get; set; }
Public Property Subject As String
    Get
    Set
member Subject : string with get, set

function get_Subject();
function set_Subject(value);
public:
property String^ Subject {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.ToRecipients Property

Grid Solutions Framework MailToRecipients Property
Gets or sets the comma-separated or semicolon-seperated e-mail address list of the Mail message recipients.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToRecipients { get; set; }
Public Property ToRecipients As String
    Get
    Set
member ToRecipients : string with get, set

function get_ToRecipients();
function set_ToRecipients(value);
public:
property String^ ToRecipients {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | Value being assigned is a null or empty string.
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


Mail.Username Property

Grid Solutions Framework MailUsername Property
Gets or sets the username used to authenticate to the SMTP server.

Namespace: GSF.Net.Smtp
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Username { get; set; }
Public Property Username As String
    Get
    Set
member Username : string with get, set

function get_Username();
function set_Username(value);
public:
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Mail Class
GSF.Net.Smtp Namespace


GSF.NumericalAnalysis Namespace

Grid Solutions Framework GSF.NumericalAnalysis Namespace
Contains classes and extension functions used to calculate common numerical operations such as curve fits and standard deviations.
Classes
 | Class | Description
Public class | CurveFit | Linear regression algorithm.
Public class | Euclidean | Contains an implementation of greatest common denominator and least common multiple using the Euclidean algorithm.
Public class | GaussianDistribution | Implements a BoxMuller method for generating statistically normal random numbers.
Public class | NumericalAnalysisExtensions | Defines extension functions related to numerical analysis over a sequence of data.
Public class | RealTimeSlope | Calculates slope for a real-time continuous data stream.
Public class | WaveFit | Linear regression algorithm for sine waves.
Structures
 | Structure | Description
Public structure | SineWave | Represents a sine wave of the form y=A*sin(ω*t+Φ)+δ.


CurveFit Class

Grid Solutions Framework CurveFit Class
Linear regression algorithm.
Inheritance Hierarchy
SystemObject
GSF.NumericalAnalysisCurveFit

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class CurveFit
Public NotInheritable Class CurveFit
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CurveFit =  class end
GSF.NumericalAnalysis.CurveFit = function();

Type.createClass(
    'GSF.NumericalAnalysis.CurveFit');
public ref class CurveFit abstract sealed

The CurveFit type exposes the following members.

Methods
Name | Description
Compute(Int32, IEnumerablePoint) | Computes linear regression over given values.
Compute(Int32, IListDouble, IListDouble) | Computes linear regression over given values.
LeastSquares | Uses least squares linear regression to estimate the coefficients a, b, and c from the given (x,y,z) data points for the equation z = a + bx + cy.
Top
See Also

Reference

GSF.NumericalAnalysis Namespace


CurveFit Methods

Grid Solutions Framework CurveFit Methods

The CurveFit type exposes the following members.

Methods
Name | Description
Compute(Int32, IEnumerablePoint) | Computes linear regression over given values.
Compute(Int32, IListDouble, IListDouble) | Computes linear regression over given values.
LeastSquares | Uses least squares linear regression to estimate the coefficients a, b, and c from the given (x,y,z) data points for the equation z = a + bx + cy.
Top
See Also

Reference

CurveFit Class
GSF.NumericalAnalysis Namespace


CurveFit.Compute Method

Grid Solutions Framework CurveFitCompute Method
Overload List
Name | Description
Compute(Int32, IEnumerablePoint) | Computes linear regression over given values.
Compute(Int32, IListDouble, IListDouble) | Computes linear regression over given values.
Top
See Also

Reference

CurveFit Class
GSF.NumericalAnalysis Namespace


CurveFit.Compute Method (Int32, IEnumerable(Point))

Grid Solutions Framework CurveFitCompute Method (Int32, IEnumerablePoint)
Computes linear regression over given values.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double[] Compute(
    int polynomialOrder,
    IEnumerable<Point> values
)
Public Shared Function Compute (
    polynomialOrder As Integer,
    values As IEnumerable(Of Point)
) As Double()
static member Compute :
        polynomialOrder : int *
        values : IEnumerable<Point> -> float[]

GSF.NumericalAnalysis.CurveFit.Compute = function(polynomialOrder, values);
public:
static array<double>^ Compute(
    int polynomialOrder,
    IEnumerable<Point>^ values
)

Parameters

polynomialOrder
Type: SystemInt32
An Int32 for the polynomial order.
values
Type: System.Collections.GenericIEnumerable Point
A list of values.

Return Value

Type: Double
An array of Double values.
See Also

Reference

CurveFit Class
Compute Overload
GSF.NumericalAnalysis Namespace


CurveFit.Compute Method (Int32, IList(Double), IList(Double))

Grid Solutions Framework CurveFitCompute Method (Int32, IListDouble, IListDouble)
Computes linear regression over given values.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double[] Compute(
    int polynomialOrder,
    IList<double> xValues,
    IList<double> yValues
)
Public Shared Function Compute (
    polynomialOrder As Integer,
    xValues As IList(Of Double),
    yValues As IList(Of Double)
) As Double()
static member Compute :
        polynomialOrder : int *
        xValues : IList<float> *
        yValues : IList<float> -> float[]

GSF.NumericalAnalysis.CurveFit.Compute = function(polynomialOrder, xValues, yValues);
public:
static array<double>^ Compute(
    int polynomialOrder,
    IList<double>^ xValues,
    IList<double>^ yValues
)

Parameters

polynomialOrder
Type: SystemInt32
An Int32 for the polynomial order.
xValues
Type: System.Collections.GenericIList Double
A list of Double x-values.
yValues
Type: System.Collections.GenericIList Double
A list of Double y-values.

Return Value

Type: Double
An array of Double values.
See Also

Reference

CurveFit Class
Compute Overload
GSF.NumericalAnalysis Namespace


CurveFit.LeastSquares Method

Grid Solutions Framework CurveFitLeastSquares Method
Uses least squares linear regression to estimate the coefficients a, b, and c from the given (x,y,z) data points for the equation z = a + bx + cy.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void LeastSquares(
    double[] zValues,
    double[] xValues,
    double[] yValues,
    out double a,
    out double b,
    out double c
)
Public Shared Sub LeastSquares (
    zValues As Double(),
    xValues As Double(),
    yValues As Double(),
    <OutAttribute> ByRef a As Double,
    <OutAttribute> ByRef b As Double,
    <OutAttribute> ByRef c As Double
)
static member LeastSquares :
        zValues : float[] *
        xValues : float[] *
        yValues : float[] *
        a : float byref *
        b : float byref *
        c : float byref -> unit

GSF.NumericalAnalysis.CurveFit.LeastSquares = function(zValues, xValues, yValues, a, b, c);
public:
static void LeastSquares(
    array<double>^ zValues,
    array<double>^ xValues,
    array<double>^ yValues,
    [OutAttribute] double% a,
    [OutAttribute] double% b,
    [OutAttribute] double% c
)

Parameters

zValues
Type: SystemDouble
z-value array
xValues
Type: SystemDouble
x-value array
yValues
Type: SystemDouble
y-value array
a
Type: SystemDouble
the out a coefficient
b
Type: SystemDouble
the out b coefficient
c
Type: SystemDouble
the out c coefficient
See Also

Reference

CurveFit Class
GSF.NumericalAnalysis Namespace


Euclidean Class

Grid Solutions Framework Euclidean Class
Contains an implementation of greatest common denominator and least common multiple using the Euclidean algorithm.
Inheritance Hierarchy
SystemObject
GSF.NumericalAnalysisEuclidean

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Euclidean
<ExtensionAttribute>
Public NotInheritable Class Euclidean
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Euclidean =  class end
GSF.NumericalAnalysis.Euclidean = function();

Type.createClass(
    'GSF.NumericalAnalysis.Euclidean');
[ExtensionAttribute]
public ref class Euclidean abstract sealed

The Euclidean type exposes the following members.

Methods
Name | Description
GreatestCommonDenominator(IEnumerableInt32) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(IEnumerableInt64) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int32) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int64) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int32, Int32) | Gets the greatest common denominator of the given integers.
GreatestCommonDenominator(Int64, Int64) | Gets the greatest common denominator of the given integers.
LeastCommonMultiple(IEnumerableInt32) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(IEnumerableInt64) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int32) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int64) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int32, Int32) | Gets the least common multiple of the given integers.
LeastCommonMultiple(Int64, Int64) | Gets the least common multiple of the given integers.
Mod | Implementation of the modulo operator using Euclidean division.
Wrap | Wraps a value to a range of values defined by the given minimum value and range.
Top
See Also

Reference

GSF.NumericalAnalysis Namespace


Euclidean Methods

Grid Solutions Framework Euclidean Methods

The Euclidean type exposes the following members.

Methods
Name | Description
GreatestCommonDenominator(IEnumerableInt32) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(IEnumerableInt64) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int32) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int64) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int32, Int32) | Gets the greatest common denominator of the given integers.
GreatestCommonDenominator(Int64, Int64) | Gets the greatest common denominator of the given integers.
LeastCommonMultiple(IEnumerableInt32) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(IEnumerableInt64) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int32) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int64) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int32, Int32) | Gets the least common multiple of the given integers.
LeastCommonMultiple(Int64, Int64) | Gets the least common multiple of the given integers.
Mod | Implementation of the modulo operator using Euclidean division.
Wrap | Wraps a value to a range of values defined by the given minimum value and range.
Top
See Also

Reference

Euclidean Class
GSF.NumericalAnalysis Namespace


Euclidean.GreatestCommonDenominator Method

Grid Solutions Framework EuclideanGreatestCommonDenominator Method
Overload List
Name | Description
GreatestCommonDenominator(IEnumerableInt32) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(IEnumerableInt64) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int32) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int64) | Gets the greatest common denominator of all the integers in the source collection.
GreatestCommonDenominator(Int32, Int32) | Gets the greatest common denominator of the given integers.
GreatestCommonDenominator(Int64, Int64) | Gets the greatest common denominator of the given integers.
Top
See Also

Reference

Euclidean Class
GSF.NumericalAnalysis Namespace


Euclidean.GreatestCommonDenominator Method (IEnumerable(Int32))

Grid Solutions Framework EuclideanGreatestCommonDenominator Method (IEnumerableInt32)
Gets the greatest common denominator of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int GreatestCommonDenominator(
    this IEnumerable<int> source
)
<ExtensionAttribute>
Public Shared Function GreatestCommonDenominator (
    source As IEnumerable(Of Integer)
) As Integer
static member GreatestCommonDenominator :
        source : IEnumerable<int> -> int

GSF.NumericalAnalysis.Euclidean.GreatestCommonDenominator = function(source);
public:
[ExtensionAttribute]
static int GreatestCommonDenominator(
    IEnumerable<int>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable Int32
The collection of integers.

Return Value

Type: Int32
The greatest common denominator.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Int32 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Euclidean Class
GreatestCommonDenominator Overload
GSF.NumericalAnalysis Namespace


Euclidean.GreatestCommonDenominator Method (IEnumerable(Int64))

Grid Solutions Framework EuclideanGreatestCommonDenominator Method (IEnumerableInt64)
Gets the greatest common denominator of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GreatestCommonDenominator(
    this IEnumerable<long> source
)
<ExtensionAttribute>
Public Shared Function GreatestCommonDenominator (
    source As IEnumerable(Of Long)
) As Long
static member GreatestCommonDenominator :
        source : IEnumerable<int64> -> int64

GSF.NumericalAnalysis.Euclidean.GreatestCommonDenominator = function(source);
public:
[ExtensionAttribute]
static long long GreatestCommonDenominator(
    IEnumerable<long long>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable Int64
The collection of integers.

Return Value

Type: Int64
The greatest common denominator.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Int64 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Euclidean Class
GreatestCommonDenominator Overload
GSF.NumericalAnalysis Namespace


Euclidean.GreatestCommonDenominator Method (Int32[])

Grid Solutions Framework EuclideanGreatestCommonDenominator Method (Int32)
Gets the greatest common denominator of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int GreatestCommonDenominator(
    params int[] source
)
Public Shared Function GreatestCommonDenominator (
    ParamArray source As Integer()
) As Integer
static member GreatestCommonDenominator :
        source : int[] -> int

GSF.NumericalAnalysis.Euclidean.GreatestCommonDenominator = function(... source);
public:
static int GreatestCommonDenominator(
    ... array<int>^ source
)

Parameters

source
Type: SystemInt32
The collection of integers.

Return Value

Type: Int32
The greatest common denominator.
See Also

Reference

Euclidean Class
GreatestCommonDenominator Overload
GSF.NumericalAnalysis Namespace


Euclidean.GreatestCommonDenominator Method (Int64[])

Grid Solutions Framework EuclideanGreatestCommonDenominator Method (Int64)
Gets the greatest common denominator of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GreatestCommonDenominator(
    params long[] source
)
Public Shared Function GreatestCommonDenominator (
    ParamArray source As Long()
) As Long
static member GreatestCommonDenominator :
        source : int64[] -> int64

GSF.NumericalAnalysis.Euclidean.GreatestCommonDenominator = function(... source);
public:
static long long GreatestCommonDenominator(
    ... array<long long>^ source
)

Parameters

source
Type: SystemInt64
The collection of integers.

Return Value

Type: Int64
The greatest common denominator.
See Also

Reference

Euclidean Class
GreatestCommonDenominator Overload
GSF.NumericalAnalysis Namespace


Euclidean.GreatestCommonDenominator Method (Int32, Int32)

Grid Solutions Framework EuclideanGreatestCommonDenominator Method (Int32, Int32)
Gets the greatest common denominator of the given integers.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int GreatestCommonDenominator(
    int a,
    int b
)
Public Shared Function GreatestCommonDenominator (
    a As Integer,
    b As Integer
) As Integer
static member GreatestCommonDenominator :
        a : int *
        b : int -> int

GSF.NumericalAnalysis.Euclidean.GreatestCommonDenominator = function(a, b);
public:
static int GreatestCommonDenominator(
    int a,
    int b
)

Parameters

a
Type: SystemInt32
The first of the given integers.
b
Type: SystemInt32
The second of the given integers.

Return Value

Type: Int32
The greatest common denominator.
See Also

Reference

Euclidean Class
GreatestCommonDenominator Overload
GSF.NumericalAnalysis Namespace


Euclidean.GreatestCommonDenominator Method (Int64, Int64)

Grid Solutions Framework EuclideanGreatestCommonDenominator Method (Int64, Int64)
Gets the greatest common denominator of the given integers.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long GreatestCommonDenominator(
    long a,
    long b
)
Public Shared Function GreatestCommonDenominator (
    a As Long,
    b As Long
) As Long
static member GreatestCommonDenominator :
        a : int64 *
        b : int64 -> int64

GSF.NumericalAnalysis.Euclidean.GreatestCommonDenominator = function(a, b);
public:
static long long GreatestCommonDenominator(
    long long a,
    long long b
)

Parameters

a
Type: SystemInt64
The first of the given integers.
b
Type: SystemInt64
The second of the given integers.

Return Value

Type: Int64
The greatest common denominator.
See Also

Reference

Euclidean Class
GreatestCommonDenominator Overload
GSF.NumericalAnalysis Namespace


Euclidean.LeastCommonMultiple Method

Grid Solutions Framework EuclideanLeastCommonMultiple Method
Overload List
Name | Description
LeastCommonMultiple(IEnumerableInt32) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(IEnumerableInt64) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int32) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int64) | Gets the least common multiple of all the integers in the source collection.
LeastCommonMultiple(Int32, Int32) | Gets the least common multiple of the given integers.
LeastCommonMultiple(Int64, Int64) | Gets the least common multiple of the given integers.
Top
See Also

Reference

Euclidean Class
GSF.NumericalAnalysis Namespace


Euclidean.LeastCommonMultiple Method (IEnumerable(Int32))

Grid Solutions Framework EuclideanLeastCommonMultiple Method (IEnumerableInt32)
Gets the least common multiple of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int LeastCommonMultiple(
    this IEnumerable<int> source
)
<ExtensionAttribute>
Public Shared Function LeastCommonMultiple (
    source As IEnumerable(Of Integer)
) As Integer
static member LeastCommonMultiple :
        source : IEnumerable<int> -> int

GSF.NumericalAnalysis.Euclidean.LeastCommonMultiple = function(source);
public:
[ExtensionAttribute]
static int LeastCommonMultiple(
    IEnumerable<int>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable Int32
The collection of integers.

Return Value

Type: Int32
The least common multiple.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Int32 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Euclidean Class
LeastCommonMultiple Overload
GSF.NumericalAnalysis Namespace


Euclidean.LeastCommonMultiple Method (IEnumerable(Int64))

Grid Solutions Framework EuclideanLeastCommonMultiple Method (IEnumerableInt64)
Gets the least common multiple of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long LeastCommonMultiple(
    this IEnumerable<long> source
)
<ExtensionAttribute>
Public Shared Function LeastCommonMultiple (
    source As IEnumerable(Of Long)
) As Long
static member LeastCommonMultiple :
        source : IEnumerable<int64> -> int64

GSF.NumericalAnalysis.Euclidean.LeastCommonMultiple = function(source);
public:
[ExtensionAttribute]
static long long LeastCommonMultiple(
    IEnumerable<long long>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable Int64
The collection of integers.

Return Value

Type: Int64
The least common multiple.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Int64 . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Euclidean Class
LeastCommonMultiple Overload
GSF.NumericalAnalysis Namespace


Euclidean.LeastCommonMultiple Method (Int32[])

Grid Solutions Framework EuclideanLeastCommonMultiple Method (Int32)
Gets the least common multiple of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int LeastCommonMultiple(
    params int[] source
)
Public Shared Function LeastCommonMultiple (
    ParamArray source As Integer()
) As Integer
static member LeastCommonMultiple :
        source : int[] -> int

GSF.NumericalAnalysis.Euclidean.LeastCommonMultiple = function(... source);
public:
static int LeastCommonMultiple(
    ... array<int>^ source
)

Parameters

source
Type: SystemInt32
The collection of integers.

Return Value

Type: Int32
The least common multiple.
See Also

Reference

Euclidean Class
LeastCommonMultiple Overload
GSF.NumericalAnalysis Namespace


Euclidean.LeastCommonMultiple Method (Int64[])

Grid Solutions Framework EuclideanLeastCommonMultiple Method (Int64)
Gets the least common multiple of all the integers in the source collection.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long LeastCommonMultiple(
    params long[] source
)
Public Shared Function LeastCommonMultiple (
    ParamArray source As Long()
) As Long
static member LeastCommonMultiple :
        source : int64[] -> int64

GSF.NumericalAnalysis.Euclidean.LeastCommonMultiple = function(... source);
public:
static long long LeastCommonMultiple(
    ... array<long long>^ source
)

Parameters

source
Type: SystemInt64
The collection of integers.

Return Value

Type: Int64
The least common multiple.
See Also

Reference

Euclidean Class
LeastCommonMultiple Overload
GSF.NumericalAnalysis Namespace


Euclidean.LeastCommonMultiple Method (Int32, Int32)

Grid Solutions Framework EuclideanLeastCommonMultiple Method (Int32, Int32)
Gets the least common multiple of the given integers.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int LeastCommonMultiple(
    int a,
    int b
)
Public Shared Function LeastCommonMultiple (
    a As Integer,
    b As Integer
) As Integer
static member LeastCommonMultiple :
        a : int *
        b : int -> int

GSF.NumericalAnalysis.Euclidean.LeastCommonMultiple = function(a, b);
public:
static int LeastCommonMultiple(
    int a,
    int b
)

Parameters

a
Type: SystemInt32
The first of the given integers.
b
Type: SystemInt32
The second of the given integers.

Return Value

Type: Int32
The least common multiple.
See Also

Reference

Euclidean Class
LeastCommonMultiple Overload
GSF.NumericalAnalysis Namespace


Euclidean.LeastCommonMultiple Method (Int64, Int64)

Grid Solutions Framework EuclideanLeastCommonMultiple Method (Int64, Int64)
Gets the least common multiple of the given integers.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long LeastCommonMultiple(
    long a,
    long b
)
Public Shared Function LeastCommonMultiple (
    a As Long,
    b As Long
) As Long
static member LeastCommonMultiple :
        a : int64 *
        b : int64 -> int64

GSF.NumericalAnalysis.Euclidean.LeastCommonMultiple = function(a, b);
public:
static long long LeastCommonMultiple(
    long long a,
    long long b
)

Parameters

a
Type: SystemInt64
The first of the given integers.
b
Type: SystemInt64
The second of the given integers.

Return Value

Type: Int64
The least common multiple.
See Also

Reference

Euclidean Class
LeastCommonMultiple Overload
GSF.NumericalAnalysis Namespace


Euclidean.Mod Method

Grid Solutions Framework EuclideanMod Method
Implementation of the modulo operator using Euclidean division.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Mod(
    double numerator,
    double denominator
)
Public Shared Function Mod (
    numerator As Double,
    denominator As Double
) As Double
static member Mod :
        numerator : float *
        denominator : float -> float

GSF.NumericalAnalysis.Euclidean.Mod = function(numerator, denominator);
public:
static double Mod(
    double numerator,
    double denominator
)

Parameters

numerator
Type: SystemDouble
The number to be divided.
denominator
Type: SystemDouble
The number to divide by.

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.NumericalAnalysis.Euclidean.Mod(System.Double,System.Double)"]

See Also

Reference

Euclidean Class
GSF.NumericalAnalysis Namespace


Euclidean.Wrap Method

Grid Solutions Framework EuclideanWrap Method
Wraps a value to a range of values defined by the given minimum value and range.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Wrap(
    double value,
    double minimum,
    double range
)
Public Shared Function Wrap (
    value As Double,
    minimum As Double,
    range As Double
) As Double
static member Wrap :
        value : float *
        minimum : float *
        range : float -> float

GSF.NumericalAnalysis.Euclidean.Wrap = function(value, minimum, range);
public:
static double Wrap(
    double value,
    double minimum,
    double range
)

Parameters

value
Type: SystemDouble
The value to be wrapped.
minimum
Type: SystemDouble
The minimum value of the range.
range
Type: SystemDouble
The size of the range.

Return Value

Type: Double
The given value wrapped to the given range.
Remarks
This method wraps the given value based on the assumption that for every pair of values x and y where x-y=range, the values are equivalent. This is probably most widely understood in terms of angles, where 0, 360, 720, etc. are all equivalent angles. If you wanted to wrap an angle such that it is between 120 and 480, for instance, you could call Euclidean.Wrap(angle, 120, 360).
See Also

Reference

Euclidean Class
GSF.NumericalAnalysis Namespace


GaussianDistribution Class

Grid Solutions Framework GaussianDistribution Class
Implements a BoxMuller method for generating statistically normal random numbers.
Inheritance Hierarchy
SystemObject
GSF.NumericalAnalysisGaussianDistribution

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class GaussianDistribution
Public Class GaussianDistribution
type GaussianDistribution =  class end
GSF.NumericalAnalysis.GaussianDistribution = function();

Type.createClass(
    'GSF.NumericalAnalysis.GaussianDistribution');
public ref class GaussianDistribution

The GaussianDistribution type exposes the following members.

Constructors
 | Name | Description
Public method | GaussianDistribution | Creates a GaussianDistribution
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Gets the next random value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.NumericalAnalysis Namespace


GaussianDistribution Constructor

Grid Solutions Framework GaussianDistribution Constructor
Creates a GaussianDistribution

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public GaussianDistribution(
    double mean,
    double standardDeviation,
    double min,
    double max
)
Public Sub New (
    mean As Double,
    standardDeviation As Double,
    min As Double,
    max As Double
)
new :
        mean : float *
        standardDeviation : float *
        min : float *
        max : float -> GaussianDistribution
GSF.NumericalAnalysis.GaussianDistribution = function(mean, standardDeviation, min, max);
public:
GaussianDistribution(
    double mean,
    double standardDeviation,
    double min,
    double max
)

Parameters

mean
Type: SystemDouble
the mean of the distribution
standardDeviation
Type: SystemDouble
the standard deviation
min
Type: SystemDouble
a clipping boundary
max
Type: SystemDouble
a clipping boundary
See Also

Reference

GaussianDistribution Class
GSF.NumericalAnalysis Namespace


GaussianDistribution Methods

Grid Solutions Framework GaussianDistribution Methods

The GaussianDistribution type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Next | Gets the next random value.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GaussianDistribution Class
GSF.NumericalAnalysis Namespace


GaussianDistribution.Next Method

Grid Solutions Framework GaussianDistributionNext Method
Gets the next random value.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Next()
Public Function Next As Double
member Next : unit -> float

function Next();
public:
double Next()

Return Value

Type: Double

[Missing <returns> documentation for "M:GSF.NumericalAnalysis.GaussianDistribution.Next"]

See Also

Reference

GaussianDistribution Class
GSF.NumericalAnalysis Namespace


NumericalAnalysisExtensions Class

Grid Solutions Framework NumericalAnalysisExtensions Class
Defines extension functions related to numerical analysis over a sequence of data.
Inheritance Hierarchy
SystemObject
GSF.NumericalAnalysisNumericalAnalysisExtensions

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class NumericalAnalysisExtensions
<ExtensionAttribute>
Public NotInheritable Class NumericalAnalysisExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type NumericalAnalysisExtensions =  class end
GSF.NumericalAnalysis.NumericalAnalysisExtensions = function();

Type.createClass(
    'GSF.NumericalAnalysis.NumericalAnalysisExtensions');
[ExtensionAttribute]
public ref class NumericalAnalysisExtensions abstract sealed
Methods
Name | Description
StandardDeviation(IEnumerableDecimal) | Computes the standard deviation over a sequence of decimal values.
StandardDeviation(IEnumerableDouble) | Computes the standard deviation over a sequence of double values.
StandardDeviation(IEnumerableSingle) | Computes the standard deviation over a sequence of float values.
Top
See Also

Reference

GSF.NumericalAnalysis Namespace


NumericalAnalysisExtensions Methods

Grid Solutions Framework NumericalAnalysisExtensions Methods
Methods
Name | Description
StandardDeviation(IEnumerableDecimal) | Computes the standard deviation over a sequence of decimal values.
StandardDeviation(IEnumerableDouble) | Computes the standard deviation over a sequence of double values.
StandardDeviation(IEnumerableSingle) | Computes the standard deviation over a sequence of float values.
Top
See Also

Reference

NumericalAnalysisExtensions Class
GSF.NumericalAnalysis Namespace


NumericalAnalysisExtensions.StandardDeviation Method

Grid Solutions Framework NumericalAnalysisExtensionsStandardDeviation Method
Overload List
Name | Description
StandardDeviation(IEnumerableDecimal) | Computes the standard deviation over a sequence of decimal values.
StandardDeviation(IEnumerableDouble) | Computes the standard deviation over a sequence of double values.
StandardDeviation(IEnumerableSingle) | Computes the standard deviation over a sequence of float values.
Top
See Also

Reference

NumericalAnalysisExtensions Class
GSF.NumericalAnalysis Namespace


NumericalAnalysisExtensions.StandardDeviation Method (IEnumerable(Decimal))

Grid Solutions Framework NumericalAnalysisExtensionsStandardDeviation Method (IEnumerableDecimal)
Computes the standard deviation over a sequence of decimal values.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static decimal StandardDeviation(
    this IEnumerable<decimal> source
)
<ExtensionAttribute>
Public Shared Function StandardDeviation (
    source As IEnumerable(Of Decimal)
) As Decimal
static member StandardDeviation :
        source : IEnumerable<decimal> -> decimal

GSF.NumericalAnalysis.NumericalAnalysisExtensions.StandardDeviation = function(source);
public:
[ExtensionAttribute]
static Decimal StandardDeviation(
    IEnumerable<Decimal>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable Decimal
Source data sample.

Return Value

Type: Decimal
The standard deviation of the sequence.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Decimal . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | source is null
See Also

Reference

NumericalAnalysisExtensions Class
StandardDeviation Overload
GSF.NumericalAnalysis Namespace


NumericalAnalysisExtensions.StandardDeviation Method (IEnumerable(Double))

Grid Solutions Framework NumericalAnalysisExtensionsStandardDeviation Method (IEnumerableDouble)
Computes the standard deviation over a sequence of double values.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double StandardDeviation(
    this IEnumerable<double> source
)
<ExtensionAttribute>
Public Shared Function StandardDeviation (
    source As IEnumerable(Of Double)
) As Double
static member StandardDeviation :
        source : IEnumerable<float> -> float

GSF.NumericalAnalysis.NumericalAnalysisExtensions.StandardDeviation = function(source);
public:
[ExtensionAttribute]
static double StandardDeviation(
    IEnumerable<double>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable Double
Source data sample.

Return Value

Type: Double
The standard deviation of the sequence.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Double . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | source is null
See Also

Reference

NumericalAnalysisExtensions Class
StandardDeviation Overload
GSF.NumericalAnalysis Namespace


NumericalAnalysisExtensions.StandardDeviation Method (IEnumerable(Single))

Grid Solutions Framework NumericalAnalysisExtensionsStandardDeviation Method (IEnumerableSingle)
Computes the standard deviation over a sequence of float values.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static float StandardDeviation(
    this IEnumerable<float> source
)
<ExtensionAttribute>
Public Shared Function StandardDeviation (
    source As IEnumerable(Of Single)
) As Single
static member StandardDeviation :
        source : IEnumerable<float32> -> float32

GSF.NumericalAnalysis.NumericalAnalysisExtensions.StandardDeviation = function(source);
public:
[ExtensionAttribute]
static float StandardDeviation(
    IEnumerable<float>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable Single
Source data sample.

Return Value

Type: Single
The standard deviation of the sequence.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable Single . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | source is null
See Also

Reference

NumericalAnalysisExtensions Class
StandardDeviation Overload
GSF.NumericalAnalysis Namespace


RealTimeSlope Class

Grid Solutions Framework RealTimeSlope Class
Calculates slope for a real-time continuous data stream.
Inheritance Hierarchy
SystemObject
GSF.NumericalAnalysisRealTimeSlope

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RealTimeSlope
Public Class RealTimeSlope
type RealTimeSlope =  class end
GSF.NumericalAnalysis.RealTimeSlope = function();

Type.createClass(
    'GSF.NumericalAnalysis.RealTimeSlope');
public ref class RealTimeSlope

The RealTimeSlope type exposes the following members.

Constructors
 | Name | Description
Public method | RealTimeSlope | Creates a default instance of the real-time slope calculation class. Must call Initialize before using.
Public method | RealTimeSlope(Int32, Double) | Creates a new instance of the real-time slope calculation class.
Top
Methods
 | Name | Description
Public method | Calculate | Adds a new x, y data pair to continuous data set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes real-time slope calculation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | RunTime | Gets run-time, in seconds, for which slope has maintained a continuous positive or negative trend.
Public property | Slope | Gets current calculated slope for data set.
Top
Events
 | Name | Description
Public event | Recalculated | Raised when new real-time Slope has been calculated and is available.
Public event | Status | Raised when new status messages come from the RealTimeSlope.
Top
See Also

Reference

GSF.NumericalAnalysis Namespace


RealTimeSlope Constructor

Grid Solutions Framework RealTimeSlope Constructor
Overload List
 | Name | Description
Public method | RealTimeSlope | Creates a default instance of the real-time slope calculation class. Must call Initialize before using.
Public method | RealTimeSlope(Int32, Double) | Creates a new instance of the real-time slope calculation class.
Top
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope Constructor

Grid Solutions Framework RealTimeSlope Constructor
Creates a default instance of the real-time slope calculation class. Must call Initialize before using.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RealTimeSlope()
Public Sub New
new : unit -> RealTimeSlope
GSF.NumericalAnalysis.RealTimeSlope = function();
public:
RealTimeSlope()
See Also

Reference

RealTimeSlope Class
RealTimeSlope Overload
GSF.NumericalAnalysis Namespace


RealTimeSlope Constructor (Int32, Double)

Grid Solutions Framework RealTimeSlope Constructor (Int32, Double)
Creates a new instance of the real-time slope calculation class.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RealTimeSlope(
    int regressionInterval,
    double estimatedRefreshInterval
)
Public Sub New (
    regressionInterval As Integer,
    estimatedRefreshInterval As Double
)
new :
        regressionInterval : int *
        estimatedRefreshInterval : float -> RealTimeSlope
GSF.NumericalAnalysis.RealTimeSlope = function(regressionInterval, estimatedRefreshInterval);
public:
RealTimeSlope(
    int regressionInterval,
    double estimatedRefreshInterval
)

Parameters

regressionInterval
Type: SystemInt32
Time span over which to calculate slope.
estimatedRefreshInterval
Type: SystemDouble
Estimated data points per second.
See Also

Reference

RealTimeSlope Class
RealTimeSlope Overload
GSF.NumericalAnalysis Namespace


RealTimeSlope Methods

Grid Solutions Framework RealTimeSlope Methods

The RealTimeSlope type exposes the following members.

Methods
 | Name | Description
Public method | Calculate | Adds a new x, y data pair to continuous data set.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes real-time slope calculation.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope.Calculate Method

Grid Solutions Framework RealTimeSlopeCalculate Method
Adds a new x, y data pair to continuous data set.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Calculate(
    double x,
    double y
)
Public Sub Calculate (
    x As Double,
    y As Double
)
member Calculate :
        x : float *
        y : float -> unit

function Calculate(x, y);
public:
void Calculate(
    double x,
    double y
)

Parameters

x
Type: SystemDouble
New x-axis value.
y
Type: SystemDouble
New y-axis value.
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope.Initialize Method

Grid Solutions Framework RealTimeSlopeInitialize Method
Initializes real-time slope calculation.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize(
    int regressionInterval,
    double estimatedRefreshInterval
)
Public Sub Initialize (
    regressionInterval As Integer,
    estimatedRefreshInterval As Double
)
member Initialize :
        regressionInterval : int *
        estimatedRefreshInterval : float -> unit

function Initialize(regressionInterval, estimatedRefreshInterval);
public:
void Initialize(
    int regressionInterval,
    double estimatedRefreshInterval
)

Parameters

regressionInterval
Type: SystemInt32
Time span over which to calculate slope.
estimatedRefreshInterval
Type: SystemDouble
Estimated data points per second.
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope Properties

Grid Solutions Framework RealTimeSlope Properties

The RealTimeSlope type exposes the following members.

Properties
 | Name | Description
Public property | RunTime | Gets run-time, in seconds, for which slope has maintained a continuous positive or negative trend.
Public property | Slope | Gets current calculated slope for data set.
Top
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope.RunTime Property

Grid Solutions Framework RealTimeSlopeRunTime Property
Gets run-time, in seconds, for which slope has maintained a continuous positive or negative trend.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time RunTime { get; }
Public ReadOnly Property RunTime As Time
    Get
member RunTime : Time with get

function get_RunTime();

public:
property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope.Slope Property

Grid Solutions Framework RealTimeSlopeSlope Property
Gets current calculated slope for data set.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Slope { get; }
Public ReadOnly Property Slope As Double
    Get
member Slope : float with get

function get_Slope();

public:
property double Slope {
    double get ();
}

Property Value

Type: Double
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope Events

Grid Solutions Framework RealTimeSlope Events

The RealTimeSlope type exposes the following members.

Events
 | Name | Description
Public event | Recalculated | Raised when new real-time Slope has been calculated and is available.
Public event | Status | Raised when new status messages come from the RealTimeSlope.
Top
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope.Recalculated Event

Grid Solutions Framework RealTimeSlopeRecalculated Event
Raised when new real-time Slope has been calculated and is available.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Recalculated
Public Event Recalculated As EventHandler
member Recalculated : IEvent<EventHandler,
    EventArgs>

function add_Recalculated(value);
function remove_Recalculated(value);
public:
 event EventHandler^ Recalculated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


RealTimeSlope.Status Event

Grid Solutions Framework RealTimeSlopeStatus Event
Raised when new status messages come from the RealTimeSlope.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> Status
Public Event Status As EventHandler(Of EventArgs(Of String))
member Status : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_Status(value);
function remove_Status(value);
public:
 event EventHandler<EventArgs<String^>^>^ Status {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is status message from the RealTimeSlope.
See Also

Reference

RealTimeSlope Class
GSF.NumericalAnalysis Namespace


SineWave Structure

Grid Solutions Framework SineWave Structure
Represents a sine wave of the form y=A*sin(ω*t+Φ)+δ.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SineWave
Public Structure SineWave
[<SealedAttribute>]
type SineWave =  struct end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SineWave

The SineWave type exposes the following members.

Methods
 | Name | Description
Public method | CalculateY | Calculates the y-value for the given time.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Amplitude | Amplitude (A) of the sine wave.
Public field | Bias | Vertical offset (δ) of the sine wave.
Public field | Frequency | Frequency (ω) of the sine wave, in Hz.
Public field | Phase | Phase (Φ) shift of the sine wave.
 | TwoPi | 2 * pi
Top
See Also

Reference

GSF.NumericalAnalysis Namespace


SineWave Fields

Grid Solutions Framework SineWave Fields

The SineWave type exposes the following members.

Fields
 | Name | Description
Public field | Amplitude | Amplitude (A) of the sine wave.
Public field | Bias | Vertical offset (δ) of the sine wave.
Public field | Frequency | Frequency (ω) of the sine wave, in Hz.
Public field | Phase | Phase (Φ) shift of the sine wave.
 | TwoPi | 2 * pi
Top
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


SineWave.Amplitude Field

Grid Solutions Framework SineWaveAmplitude Field
Amplitude (A) of the sine wave.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Amplitude
Public Amplitude As Double
val mutable Amplitude: float
var Amplitude
public:
double Amplitude

Field Value

Type: Double
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


SineWave.Bias Field

Grid Solutions Framework SineWaveBias Field
Vertical offset (δ) of the sine wave.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Bias
Public Bias As Double
val mutable Bias: float
var Bias
public:
double Bias

Field Value

Type: Double
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


SineWave.Frequency Field

Grid Solutions Framework SineWaveFrequency Field
Frequency (ω) of the sine wave, in Hz.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Frequency
Public Frequency As Double
val mutable Frequency: float
var Frequency
public:
double Frequency

Field Value

Type: Double
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


SineWave.Phase Field

Grid Solutions Framework SineWavePhase Field
Phase (Φ) shift of the sine wave.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Phase
Public Phase As Double
val mutable Phase: float
var Phase
public:
double Phase

Field Value

Type: Double
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


SineWave.TwoPi Field

Grid Solutions Framework SineWaveTwoPi Field
2 * pi

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double TwoPi
Public Const TwoPi As Double
static val mutable TwoPi: float
var GSF.NumericalAnalysis.SineWave.TwoPi
public:
literal double TwoPi

Field Value

Type: Double
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


SineWave Methods

Grid Solutions Framework SineWave Methods

The SineWave type exposes the following members.

Methods
 | Name | Description
Public method | CalculateY | Calculates the y-value for the given time.
Public method | Equals | Indicates whether this instance and a specified object are equal. (Inherited from ValueType.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ValueType.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns the fully qualified type name of this instance. (Inherited from ValueType.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


SineWave.CalculateY Method

Grid Solutions Framework SineWaveCalculateY Method
Calculates the y-value for the given time.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculateY(
    double t
)
Public Function CalculateY (
    t As Double
) As Double
member CalculateY :
        t : float -> float

function CalculateY(t);
public:
double CalculateY(
    double t
)

Parameters

t
Type: SystemDouble
The time, in seconds.

Return Value

Type: Double
A*sin(ω*t+Φ)+δ
See Also

Reference

SineWave Structure
GSF.NumericalAnalysis Namespace


WaveFit Class

Grid Solutions Framework WaveFit Class
Linear regression algorithm for sine waves.
Inheritance Hierarchy
SystemObject
GSF.NumericalAnalysisWaveFit

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class WaveFit
Public NotInheritable Class WaveFit
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WaveFit =  class end
GSF.NumericalAnalysis.WaveFit = function();

Type.createClass(
    'GSF.NumericalAnalysis.WaveFit');
public ref class WaveFit abstract sealed

The WaveFit type exposes the following members.

Methods
Name | Description
SineFit | Uses least squares linear regression to calculate the best fit sine wave for the given data.
Top
See Also

Reference

GSF.NumericalAnalysis Namespace


WaveFit Methods

Grid Solutions Framework WaveFit Methods

The WaveFit type exposes the following members.

Methods
Name | Description
SineFit | Uses least squares linear regression to calculate the best fit sine wave for the given data.
Top
See Also

Reference

WaveFit Class
GSF.NumericalAnalysis Namespace


WaveFit.SineFit Method

Grid Solutions Framework WaveFitSineFit Method
Uses least squares linear regression to calculate the best fit sine wave for the given data.

Namespace: GSF.NumericalAnalysis
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SineWave SineFit(
    double[] yValues,
    double[] tValues,
    double frequency
)
Public Shared Function SineFit (
    yValues As Double(),
    tValues As Double(),
    frequency As Double
) As SineWave
static member SineFit :
        yValues : float[] *
        tValues : float[] *
        frequency : float -> SineWave

GSF.NumericalAnalysis.WaveFit.SineFit = function(yValues, tValues, frequency);
public:
static SineWave SineFit(
    array<double>^ yValues,
    array<double>^ tValues,
    double frequency
)

Parameters

yValues
Type: SystemDouble
The y values of the data points.
tValues
Type: SystemDouble
The time values of the data points, in seconds.
frequency
Type: SystemDouble
The frequency of the sine wave, in Hz.

Return Value

Type: SineWave
A SineWave approximated from the given data points.
See Also

Reference

WaveFit Class
GSF.NumericalAnalysis Namespace


GSF.Parsing Namespace

Grid Solutions Framework GSF.Parsing Namespace
Contains classes used to simplify, standardize and automate any kind of stream based parsing operation.
Classes
 | Class | Description
Public class | BinaryImageBase | Defines a base class that represents binary images for parsing or generation in terms of a header, body and footer.
Public class | BinaryImageParserBase | This class defines the fundamental functionality for parsing any stream of binary data.
Public class | CommonHeaderBaseTTypeIdentifier | Represents the base class for a common binary image header implementation.
Public class | FrameImageParserBaseTTypeIdentifier, TOutputType | This class defines a basic implementation of parsing functionality suitable for automating the parsing of a binary data stream represented as frames with common headers and returning the parsed data via an event.
Public class | ISupportBinaryImageExtensions | Defines extension functions related to ISupportBinaryImage implementations.
Public class | MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType | This class defines a basic implementation of parsing functionality suitable for automating the parsing of multiple binary data streams, each represented as frames with common headers and returning the parsed data via an event.
Public class | MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer | Represents a source identifiable buffer.
Public class | TemplatedExpressionParser | Represents a template based token substitution parser that supports binary and advanced expressions.
Interfaces
 | Interface | Description
Public interface | IBinaryImageParser | This interface represents the protocol independent representation of a streaming data parser.
Public interface | ICommonHeaderTTypeIdentifier | Defines the common header of a frame image for a set of parsed types, consisting at least of a type ID.
Public interface | IFrameImageParserTTypeIdentifier, TOutputType | This interface represents a basic implementation of parsing functionality suitable for automating the parsing of a binary data stream represented as frames with common headers and returning the parsed data via an event.
Public interface | ISupportBinaryImage | Specifies that an object can support production or consumption of a binary image that represents the object.
Public interface | ISupportFrameImageTTypeIdentifier | Specifies that this Type can produce or consume a frame of data represented as a binary image.
Public interface | ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier | Specifies that this Type can produce or consume a frame of data represented as a binary image that can be identified by its data source.


BinaryImageBase Class

Grid Solutions Framework BinaryImageBase Class
Defines a base class that represents binary images for parsing or generation in terms of a header, body and footer.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class BinaryImageBase : ISupportBinaryImage
<SerializableAttribute>
Public MustInherit Class BinaryImageBase
    Implements ISupportBinaryImage
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type BinaryImageBase =
    class
        interface ISupportBinaryImage
    end
GSF.Parsing.BinaryImageBase = function();

Type.createClass(
    'GSF.Parsing.BinaryImageBase',
    null,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class BinaryImageBase abstract : ISupportBinaryImage

The BinaryImageBase type exposes the following members.

Constructors
 | Name | Description
Protected method | BinaryImageBase | Initializes a new instance of the BinaryImageBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes.
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes.
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image.
Protected method | ParseBodyImage | Parses the binary body image.
Protected method | ParseFooterImage | Parses the binary footer image.
Protected method | ParseHeaderImage | Parses the binary header image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the BinaryImageBase object.
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object.
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object.
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object.
Top
See Also

Reference

GSF.Parsing Namespace


BinaryImageBase Constructor

Grid Solutions Framework BinaryImageBase Constructor
Initializes a new instance of the BinaryImageBase class

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected BinaryImageBase()
Protected Sub New
new : unit -> BinaryImageBase
GSF.Parsing.BinaryImageBase = function();
protected:
BinaryImageBase()
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase Methods

Grid Solutions Framework BinaryImageBase Methods

The BinaryImageBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes.
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes.
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image.
Protected method | ParseBodyImage | Parses the binary body image.
Protected method | ParseFooterImage | Parses the binary footer image.
Protected method | ParseHeaderImage | Parses the binary header image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.GenerateBinaryImage Method

Grid Solutions Framework BinaryImageBaseGenerateBinaryImage Method
Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
Remarks
This property is not typically overridden since it is the generates the combination of the header, body and footer images.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.GenerateBodyImage Method

Grid Solutions Framework BinaryImageBaseGenerateBodyImage Method
Generates the binary body image and copies it into the given buffer, for BodyLength bytes.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int GenerateBodyImage(
    byte[] buffer,
    int startIndex
)
Protected Overridable Function GenerateBodyImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBodyImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBodyImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBodyImage(buffer, startIndex);
protected:
virtual int GenerateBodyImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.
Remarks
This method is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.GenerateFooterImage Method

Grid Solutions Framework BinaryImageBaseGenerateFooterImage Method
Generates the binary footer image and copies it into the given buffer, for FooterLength bytes.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int GenerateFooterImage(
    byte[] buffer,
    int startIndex
)
Protected Overridable Function GenerateFooterImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateFooterImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateFooterImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateFooterImage(buffer, startIndex);
protected:
virtual int GenerateFooterImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.
Remarks
This method is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.GenerateHeaderImage Method

Grid Solutions Framework BinaryImageBaseGenerateHeaderImage Method
Generates the binary header image and copies it into the given buffer, for HeaderLength bytes.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int GenerateHeaderImage(
    byte[] buffer,
    int startIndex
)
Protected Overridable Function GenerateHeaderImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateHeaderImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateHeaderImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateHeaderImage(buffer, startIndex);
protected:
virtual int GenerateHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.
Remarks
This method is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.ParseBinaryImage Method

Grid Solutions Framework BinaryImageBaseParseBinaryImage Method
Initializes object by parsing the specified buffer containing a binary image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overridable Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
Remarks
This method is not typically overridden since it is parses the header, body and footer images in sequence.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.ParseBodyImage Method

Grid Solutions Framework BinaryImageBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overridable Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).
Remarks
This method is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.ParseFooterImage Method

Grid Solutions Framework BinaryImageBaseParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overridable Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).
Remarks
This method is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.ParseHeaderImage Method

Grid Solutions Framework BinaryImageBaseParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overridable Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).
Remarks
This method is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase Properties

Grid Solutions Framework BinaryImageBase Properties

The BinaryImageBase type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the BinaryImageBase object.
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object.
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object.
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object.
Top
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.BinaryLength Property

Grid Solutions Framework BinaryImageBaseBinaryLength Property
Gets the length of the BinaryImageBase object.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int BinaryLength { get; }
Public Overridable ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get ();
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
Remarks
This property is not typically overridden since it is the sum of the header, body and footer lengths.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.BodyLength Property

Grid Solutions Framework BinaryImageBaseBodyLength Property
Gets the length of the body portion of the BinaryImageBase object.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int BodyLength { get; }
Protected Overridable ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get ();
}

Property Value

Type: Int32
Remarks
This property is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.FooterLength Property

Grid Solutions Framework BinaryImageBaseFooterLength Property
Gets the length of the footer portion of the BinaryImageBase object.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int FooterLength { get; }
Protected Overridable ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get ();
}

Property Value

Type: Int32
Remarks
This property is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageBase.HeaderLength Property

Grid Solutions Framework BinaryImageBaseHeaderLength Property
Gets the length of the header portion of the BinaryImageBase object.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int HeaderLength { get; }
Protected Overridable ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get ();
}

Property Value

Type: Int32
Remarks
This property is typically overridden by a specific protocol implementation.
See Also

Reference

BinaryImageBase Class
GSF.Parsing Namespace


BinaryImageParserBase Class

Grid Solutions Framework BinaryImageParserBase Class
This class defines the fundamental functionality for parsing any stream of binary data.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBaseTTypeIdentifier, TOutputType

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class BinaryImageParserBase : Stream,
    IBinaryImageParser, IProvideStatus
Public MustInherit Class BinaryImageParserBase
    Inherits Stream
    Implements IBinaryImageParser, IProvideStatus
[<AbstractClassAttribute>]
type BinaryImageParserBase =
    class
        inherit Stream
        interface IBinaryImageParser
        interface IProvideStatus
    end
GSF.Parsing.BinaryImageParserBase = function();

Type.createClass(
    'GSF.Parsing.BinaryImageParserBase',
    Stream,
    GSF.Parsing.IBinaryImageParser,
    GSF.IProvideStatus);
public ref class BinaryImageParserBase abstract : public Stream,
    IBinaryImageParser, IProvideStatus

The BinaryImageParserBase type exposes the following members.

Constructors
 | Name | Description
Protected method | BinaryImageParserBase | Creates a new instance of the BinaryImageParserBase class.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event.
Protected method | OnDataDiscarded | Raises the DataDiscarded event.
Protected method | OnParsingException | Raises the ParsingException event.
Public method | Parse | Parses the object implementing the ISupportBinaryImage interface.
Protected method | ParseFrame | Protocol specific frame parsing algorithm.
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamSetLength(Int64).)
Public method | Start | Start the streaming data parser.
Public method | Stop | Stops the streaming data parser.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes a sequence of bytes onto the stream for parsing. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
 | DefaultProtocolSyncBytes | Specifies the default value for the ProtocolSyncBytes property.
Protected field | StreamInitialized | Tracks if data stream has been initialized.
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any.
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Overrides StreamCanWrite.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled.
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamLength.)
Public property | Name | Gets the name of BinaryImageParserBase.
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamPosition.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used.
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes.
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active.
Public property | Status | Gets current status of BinaryImageParserBase.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far.
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed.
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data.
Top
Remarks
This parser is designed as a write-only stream such that data can come from any source.
See Also

Reference

GSF.Parsing Namespace


BinaryImageParserBase Constructor

Grid Solutions Framework BinaryImageParserBase Constructor
Creates a new instance of the BinaryImageParserBase class.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected BinaryImageParserBase()
Protected Sub New
new : unit -> BinaryImageParserBase
GSF.Parsing.BinaryImageParserBase = function();
protected:
BinaryImageParserBase()
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase Fields

Grid Solutions Framework BinaryImageParserBase Fields

The BinaryImageParserBase type exposes the following members.

Fields
 | Name | Description
 | DefaultProtocolSyncBytes | Specifies the default value for the ProtocolSyncBytes property.
Protected field | StreamInitialized | Tracks if data stream has been initialized.
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any.
Top
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.DefaultProtocolSyncBytes Field

Grid Solutions Framework BinaryImageParserBaseDefaultProtocolSyncBytes Field
Specifies the default value for the ProtocolSyncBytes property.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly byte[] DefaultProtocolSyncBytes
Public Shared ReadOnly DefaultProtocolSyncBytes As Byte()
static val DefaultProtocolSyncBytes: byte[]
var GSF.Parsing.BinaryImageParserBase.DefaultProtocolSyncBytes
public:
static initonly array<unsigned char>^ DefaultProtocolSyncBytes

Field Value

Type: Byte
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.StreamInitialized Field

Grid Solutions Framework BinaryImageParserBaseStreamInitialized Field
Tracks if data stream has been initialized.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool StreamInitialized
Protected StreamInitialized As Boolean
val mutable StreamInitialized: bool
var StreamInitialized
protected:
bool StreamInitialized

Field Value

Type: Boolean
Remarks
Only relevant if ProtocolUsesSyncBytes is true.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.UnparsedBuffer Field

Grid Solutions Framework BinaryImageParserBaseUnparsedBuffer Field
Remaining unparsed buffer from last parsing execution, if any.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected byte[] UnparsedBuffer
Protected UnparsedBuffer As Byte()
val mutable UnparsedBuffer: byte[]
var UnparsedBuffer
protected:
array<unsigned char>^ UnparsedBuffer

Field Value

Type: Byte
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase Methods

Grid Solutions Framework BinaryImageParserBase Methods

The BinaryImageParserBase type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Stream and optionally releases the managed resources. (Inherited from Stream.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Overrides StreamFlush.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event.
Protected method | OnDataDiscarded | Raises the DataDiscarded event.
Protected method | OnParsingException | Raises the ParsingException event.
Public method | Parse | Parses the object implementing the ISupportBinaryImage interface.
Protected method | ParseFrame | Protocol specific frame parsing algorithm.
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamRead(Byte, Int32, Int32).)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamSeek(Int64, SeekOrigin).)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamSetLength(Int64).)
Public method | Start | Start the streaming data parser.
Public method | Stop | Stops the streaming data parser.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes a sequence of bytes onto the stream for parsing. (Overrides StreamWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Flush Method

Grid Solutions Framework BinaryImageParserBaseFlush Method
When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Flush()
Public Overrides Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush() override
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.OnBufferParsed Method

Grid Solutions Framework BinaryImageParserBaseOnBufferParsed Method
Raises the BufferParsed event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnBufferParsed()
Protected Overridable Sub OnBufferParsed
abstract OnBufferParsed : unit -> unit
override OnBufferParsed : unit -> unit
function OnBufferParsed();
protected:
virtual void OnBufferParsed()
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.OnDataDiscarded Method

Grid Solutions Framework BinaryImageParserBaseOnDataDiscarded Method
Raises the DataDiscarded event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataDiscarded(
    byte[] buffer
)
Protected Overridable Sub OnDataDiscarded (
    buffer As Byte()
)
abstract OnDataDiscarded :
        buffer : byte[] -> unit
override OnDataDiscarded :
        buffer : byte[] -> unit
function OnDataDiscarded(buffer);
protected:
virtual void OnDataDiscarded(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
Source buffer that contains output that failed to parse.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.OnParsingException Method

Grid Solutions Framework BinaryImageParserBaseOnParsingException Method
Raises the ParsingException event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnParsingException(
    Exception ex
)
Protected Overridable Sub OnParsingException (
    ex As Exception
)
abstract OnParsingException :
        ex : Exception -> unit
override OnParsingException :
        ex : Exception -> unit
function OnParsingException(ex);
protected:
virtual void OnParsingException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
The Exception that was encountered during parsing.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Parse Method

Grid Solutions Framework BinaryImageParserBaseParse Method
Parses the object implementing the ISupportBinaryImage interface.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Parse(
    ISupportBinaryImage image
)
Public Overridable Sub Parse (
    image As ISupportBinaryImage
)
abstract Parse :
        image : ISupportBinaryImage -> unit
override Parse :
        image : ISupportBinaryImage -> unit
function Parse(image);
public:
virtual void Parse(
    ISupportBinaryImage^ image
)

Parameters

image
Type: GSF.ParsingISupportBinaryImage
Object to be parsed that implements the ISupportBinaryImage interface.
Remarks
This function takes the binary image from ISupportBinaryImage and writes the buffer to the BinaryImageParserBase stream for parsing.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.ParseFrame Method

Grid Solutions Framework BinaryImageParserBaseParseFrame Method
Protocol specific frame parsing algorithm.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract int ParseFrame(
    byte[] buffer,
    int offset,
    int length
)
Protected MustOverride Function ParseFrame (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As Integer
abstract ParseFrame :
        buffer : byte[] *
        offset : int *
        length : int -> int

function ParseFrame(buffer, offset, length);
protected:
virtual int ParseFrame(
    array<unsigned char>^ buffer,
    int offset,
    int length
) abstract

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks

Implementers can choose to focus on parsing a single frame in the buffer even if there are other frames available in the buffer. Base class will continue to move through buffer on behalf of derived class until all the buffer has been processed. Just return the total amount of data was parsed and the remaining unparsed will be prepended to next received buffer.

Derived implementations should return an integer value that represents the length of the data that was parsed, and zero if not enough data was able to be parsed. Note that exceptions are expensive when parsing fast moving streaming data and a good coding practice for implementations of this method will be to not throw an exception when there is not enough data to parse the data, instead check the length property to verify there is enough buffer data to represent the desired image. If there is not enough data to represent the image return zero and base class will prepend buffer onto next incoming set of data.

Because of the expense incurred when an exception is thrown, any exceptions encountered in the derived implementations of this method will cause the current data buffer to be discarded and a ParsingException event to be raised. Doing this prevents exceptions from being thrown repeatedly for the same data. If your code implementation recognizes a malformed image, you can raise a custom event to indicate this instead of throwing as exception and keep moving through the buffer as an optimization.

See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Read Method

Grid Solutions Framework BinaryImageParserBaseRead Method
The parser is designed as a write only stream, so this method is not implemented.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int Read(
    byte[] buffer,
    int offset,
    int count
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function Read (
    buffer As Byte(),
    offset As Integer,
    count As Integer
) As Integer
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Read :
        buffer : byte[] *
        offset : int *
        count : int -> int
function Read(buffer, offset, count);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual int Read(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
Array of Bytes.
offset
Type: SystemInt32
An Int32 value for the count.
count
Type: SystemInt32
An Int32 value for the offset.

Return Value

Type: Int32
An Int32 as the number of bytes read. Well. It would, if implemented.
Exceptions
Exception | Condition
NotImplementedException | Cannot read from WriteOnly stream.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Seek Method

Grid Solutions Framework BinaryImageParserBaseSeek Method
The parser is designed as a write only stream, so this method is not implemented.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override long Seek(
    long offset,
    SeekOrigin origin
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function Seek (
    offset As Long,
    origin As SeekOrigin
) As Long
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Seek :
        offset : int64 *
        origin : SeekOrigin -> int64
function Seek(offset, origin);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual long long Seek(
    long long offset,
    SeekOrigin origin
) override

Parameters

offset
Type: SystemInt64
A Int64 value for the offset.
origin
Type: System.IOSeekOrigin
A SeekOrigin.

Return Value

Type: Int64
Returns a Int64 value indicating the point that was sought.
Exceptions
Exception | Condition
NotImplementedException | WriteOnly stream has no position.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.SetLength Method

Grid Solutions Framework BinaryImageParserBaseSetLength Method
The parser is designed as a write only stream, so this method is not implemented.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override void SetLength(
    long value
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Sub SetLength (
    value As Long
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract SetLength :
        value : int64 -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override SetLength :
        value : int64 -> unit
function SetLength(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void SetLength(
    long long value
) override

Parameters

value
Type: SystemInt64
A Int64 value.
Exceptions
Exception | Condition
NotImplementedException | WriteOnly stream has no length.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Start Method

Grid Solutions Framework BinaryImageParserBaseStart Method
Start the streaming data parser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Start()
Public Overridable Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start()

Implements

IBinaryImageParserStart
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Stop Method

Grid Solutions Framework BinaryImageParserBaseStop Method
Stops the streaming data parser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Stop()
Public Overridable Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop()

Implements

IBinaryImageParserStop
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Write Method

Grid Solutions Framework BinaryImageParserBaseWrite Method
Writes a sequence of bytes onto the stream for parsing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Write(buffer, offset, count);
public:
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: SystemInt32
The number of bytes to be written to the current stream.

Implements

IBinaryImageParserWrite(Byte, Int32, Int32)
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase Properties

Grid Solutions Framework BinaryImageParserBase Properties

The BinaryImageParserBase type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Overrides StreamCanRead.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Overrides StreamCanSeek.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Overrides StreamCanWrite.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled.
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamLength.)
Public property | Name | Gets the name of BinaryImageParserBase.
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Overrides StreamPosition.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used.
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes.
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active.
Public property | Status | Gets current status of BinaryImageParserBase.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far.
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.CanRead Property

Grid Solutions Framework BinaryImageParserBaseCanRead Property
Gets a value indicating whether the current stream supports reading.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanRead { get; }
Public Overrides ReadOnly Property CanRead As Boolean
    Get
abstract CanRead : bool with get
override CanRead : bool with get
function get_CanRead();

public:
virtual property bool CanRead {
    bool get () override;
}

Property Value

Type: Boolean
Remarks
The BinaryImageParserBase is implemented as a WriteOnly stream, so this defaults to false.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.CanSeek Property

Grid Solutions Framework BinaryImageParserBaseCanSeek Property
Gets a value indicating whether the current stream supports seeking.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanSeek { get; }
Public Overrides ReadOnly Property CanSeek As Boolean
    Get
abstract CanSeek : bool with get
override CanSeek : bool with get
function get_CanSeek();

public:
virtual property bool CanSeek {
    bool get () override;
}

Property Value

Type: Boolean
Remarks
The BinaryImageParserBase is implemented as a WriteOnly stream, so this defaults to false.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.CanWrite Property

Grid Solutions Framework BinaryImageParserBaseCanWrite Property
Gets a value indicating whether the current stream supports writing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanWrite { get; }
Public Overrides ReadOnly Property CanWrite As Boolean
    Get
abstract CanWrite : bool with get
override CanWrite : bool with get
function get_CanWrite();

public:
virtual property bool CanWrite {
    bool get () override;
}

Property Value

Type: Boolean
Remarks
The BinaryImageParserBase is implemented as a WriteOnly stream, so this defaults to true.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Enabled Property

Grid Solutions Framework BinaryImageParserBaseEnabled Property
Gets or sets a boolean value that indicates whether the data parser is currently enabled.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Enabled { get; set; }
Public Overridable Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IBinaryImageParserEnabled
Remarks
Setting Enabled to true will start the BinaryImageParserBase if it is not started, setting to false will stop the BinaryImageParserBase if it is started.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Length Property

Grid Solutions Framework BinaryImageParserBaseLength Property
The parser is designed as a write only stream, so this method is not implemented.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override long Length { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides ReadOnly Property Length As Long
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Length : int64 with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Length : int64 with get
function get_Length();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property long long Length {
    long long get () override;
}

Property Value

Type: Int64
Remarks
WriteOnly stream has no length. Returned value will always be -1.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Name Property

Grid Solutions Framework BinaryImageParserBaseName Property
Gets the name of BinaryImageParserBase.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Position Property

Grid Solutions Framework BinaryImageParserBasePosition Property
The parser is designed as a write only stream, so this method is not implemented.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override long Position { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property Position As Long
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Position : int64 with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Position : int64 with get, set
function get_Position();
function set_Position(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property long long Position {
    long long get () override;
    void set (long long value) override;
}

Property Value

Type: Int64
Remarks
WriteOnly stream has no position. Returned value will always be -1 and any assigned value will be ignored.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.ProtocolSyncBytes Property

Grid Solutions Framework BinaryImageParserBaseProtocolSyncBytes Property
Gets or sets synchronization bytes for this parsing implementation, if used.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte[] ProtocolSyncBytes { get; set; }
Public Overridable Property ProtocolSyncBytes As Byte()
    Get
    Set
abstract ProtocolSyncBytes : byte[] with get, set
override ProtocolSyncBytes : byte[] with get, set
function get_ProtocolSyncBytes();
function set_ProtocolSyncBytes(value);
public:
virtual property array<unsigned char>^ ProtocolSyncBytes {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.ProtocolUsesSyncBytes Property

Grid Solutions Framework BinaryImageParserBaseProtocolUsesSyncBytes Property
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool ProtocolUsesSyncBytes { get; }
Public MustOverride ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get

function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () abstract;
}

Property Value

Type: Boolean
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.RunTime Property

Grid Solutions Framework BinaryImageParserBaseRunTime Property
Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time RunTime { get; }
Public ReadOnly Property RunTime As Time
    Get
member RunTime : Time with get

function get_RunTime();

public:
property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.Status Property

Grid Solutions Framework BinaryImageParserBaseStatus Property
Gets current status of BinaryImageParserBase.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.TotalProcessedBuffers Property

Grid Solutions Framework BinaryImageParserBaseTotalProcessedBuffers Property
Gets the total number of buffer images processed so far.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalProcessedBuffers { get; }
Public ReadOnly Property TotalProcessedBuffers As Long
    Get
abstract TotalProcessedBuffers : int64 with get
override TotalProcessedBuffers : int64 with get
function get_TotalProcessedBuffers();

public:
virtual property long long TotalProcessedBuffers {
    long long get () sealed;
}

Return Value

Type: Int64
Total number of buffer images processed so far.

Implements

IBinaryImageParserTotalProcessedBuffers
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase Events

Grid Solutions Framework BinaryImageParserBase Events

The BinaryImageParserBase type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed.
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data.
Top
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.BufferParsed Event

Grid Solutions Framework BinaryImageParserBaseBufferParsed Event
Occurs when buffer parsing has completed.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler BufferParsed
Public Event BufferParsed As EventHandler
member BufferParsed : IEvent<EventHandler,
    EventArgs>

function add_BufferParsed(value);
function remove_BufferParsed(value);
public:
 event EventHandler^ BufferParsed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.DataDiscarded Event

Grid Solutions Framework BinaryImageParserBaseDataDiscarded Event
Occurs when data image fails deserialized due to an exception.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<byte[]>> DataDiscarded
Public Event DataDiscarded As EventHandler(Of EventArgs(Of Byte()))
abstract DataDiscarded : IEvent<EventHandler<EventArgs<byte[]>>,
    EventArgs<byte[]>>
override DataDiscarded : IEvent<EventHandler<EventArgs<byte[]>>,
    EventArgs<byte[]>>
function add_DataDiscarded(value);
function remove_DataDiscarded(value);
public:
virtual  event EventHandler<EventArgs<array<unsigned char>^>^>^ DataDiscarded {
    void add (EventHandler<EventArgs<array<unsigned char>^>^>^ value);
    void remove (EventHandler<EventArgs<array<unsigned char>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Byte

Implements

IBinaryImageParserDataDiscarded
Remarks
Argument is the remaining portion of the binary image that failed to parse.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


BinaryImageParserBase.ParsingException Event

Grid Solutions Framework BinaryImageParserBaseParsingException Event
Occurs when an Exception is encountered while attempting to parse data.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ParsingException
Public Event ParsingException As EventHandler(Of EventArgs(Of Exception))
abstract ParsingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ParsingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ParsingException(value);
function remove_ParsingException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ParsingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IBinaryImageParserParsingException
Remarks
Argument is the Exception encountered while parsing data.
See Also

Reference

BinaryImageParserBase Class
GSF.Parsing Namespace


CommonHeaderBase(TTypeIdentifier) Class

Grid Solutions Framework CommonHeaderBaseTTypeIdentifier Class
Represents the base class for a common binary image header implementation.
Inheritance Hierarchy
SystemObject
GSF.ParsingCommonHeaderBaseTTypeIdentifier
GSF.Historian.PacketsPacketCommonHeader
GSF.PhasorProtocols.FNETCommonFrameHeader
GSF.PhasorProtocols.MacrodyneCommonFrameHeader
GSF.PhasorProtocols.SelFastMessageCommonFrameHeader

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class CommonHeaderBase<TTypeIdentifier> : ICommonHeader<TTypeIdentifier>

Public MustInherit Class CommonHeaderBase(Of TTypeIdentifier)
    Implements ICommonHeader(Of TTypeIdentifier)
[<AbstractClassAttribute>]
type CommonHeaderBase<'TTypeIdentifier> =
    class
        interface ICommonHeader<'TTypeIdentifier>
    end
JavaScript does not support generic types or methods.
generic<typename TTypeIdentifier>
public ref class CommonHeaderBase abstract : ICommonHeader<TTypeIdentifier>

Type Parameters

TTypeIdentifier
Type of identifier used to distinguish output types.

The CommonHeaderBaseTTypeIdentifier type exposes the following members.

Constructors
 | Name | Description
Protected method | CommonHeaderBaseTTypeIdentifier | Initializes a new instance of the CommonHeaderBaseTTypeIdentifier class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | State | Gets or sets any additional state information that might be needed for parsing.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed.
Top
Remarks
Here is an example of a possible derived class constructor that has an integer TypeID as the first 4 bytes in the image:
Copy
public CommonHeader(object state, byte[] binaryImage, int startIndex, int length)
{
    if (length > 3)
    {
        TypeID = LittleEndian.ToInt32(binaryImage, startIndex);
        State = state;
    }
    else
        throw new InvalidOperationException("Malformed image");
}
See Also

Reference

GSF.Parsing Namespace


CommonHeaderBase(TTypeIdentifier) Constructor

Grid Solutions Framework CommonHeaderBaseTTypeIdentifier Constructor
Initializes a new instance of the CommonHeaderBaseTTypeIdentifier class

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommonHeaderBase()
Protected Sub New
new : unit -> CommonHeaderBase
GSF.Parsing.CommonHeaderBase = function();
protected:
CommonHeaderBase()
See Also

Reference

CommonHeaderBaseTTypeIdentifier Class
GSF.Parsing Namespace


CommonHeaderBase(TTypeIdentifier) Methods

Grid Solutions Framework CommonHeaderBaseTTypeIdentifier Methods

The CommonHeaderBaseTTypeIdentifier generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonHeaderBaseTTypeIdentifier Class
GSF.Parsing Namespace


CommonHeaderBase(TTypeIdentifier) Properties

Grid Solutions Framework CommonHeaderBaseTTypeIdentifier Properties

The CommonHeaderBaseTTypeIdentifier generic type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets or sets any additional state information that might be needed for parsing.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed.
Top
See Also

Reference

CommonHeaderBaseTTypeIdentifier Class
GSF.Parsing Namespace


CommonHeaderBase(TTypeIdentifier).State Property

Grid Solutions Framework CommonHeaderBaseTTypeIdentifierState Property
Gets or sets any additional state information that might be needed for parsing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object State { get; set; }
Public Property State As Object
    Get
    Set
abstract State : Object with get, set
override State : Object with get, set
function get_State();
function set_State(value);
public:
virtual property Object^ State {
    Object^ get () sealed;
    void set (Object^ value) sealed;
}

Property Value

Type: Object

Implements

ICommonHeaderTTypeIdentifierState
See Also

Reference

CommonHeaderBaseTTypeIdentifier Class
GSF.Parsing Namespace


CommonHeaderBase(TTypeIdentifier).TypeID Property

Grid Solutions Framework CommonHeaderBaseTTypeIdentifierTypeID Property
Gets or sets the identifier used for identifying the Type to be parsed.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual TTypeIdentifier TypeID { get; set; }
Public Overridable Property TypeID As TTypeIdentifier
    Get
    Set
abstract TypeID : 'TTypeIdentifier with get, set
override TypeID : 'TTypeIdentifier with get, set
function get_TypeID();
function set_TypeID(value);
public:
virtual property TTypeIdentifier TypeID {
    TTypeIdentifier get ();
    void set (TTypeIdentifier value);
}

Property Value

Type: TTypeIdentifier

Implements

ICommonHeaderTTypeIdentifierTypeID
See Also

Reference

CommonHeaderBaseTTypeIdentifier Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType) Class

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputType Class
This class defines a basic implementation of parsing functionality suitable for automating the parsing of a binary data stream represented as frames with common headers and returning the parsed data via an event.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBaseTTypeIdentifier, TOutputType
GSF.ParsingMultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class FrameImageParserBase<TTypeIdentifier, TOutputType> : BinaryImageParserBase,
    IFrameImageParser<TTypeIdentifier, TOutputType>, IBinaryImageParser, IProvideStatus
where TOutputType : Object, ISupportFrameImage<TTypeIdentifier>

Public MustInherit Class FrameImageParserBase(Of TTypeIdentifier, TOutputType As {Object, ISupportFrameImage(Of TTypeIdentifier)})
    Inherits BinaryImageParserBase
    Implements IFrameImageParser(Of TTypeIdentifier, TOutputType),
    IBinaryImageParser, IProvideStatus
[<AbstractClassAttribute>]
type FrameImageParserBase<'TTypeIdentifier, 'TOutputType when 'TOutputType : Object and ISupportFrameImage<'TTypeIdentifier>> =
    class
        inherit BinaryImageParserBase
        interface IFrameImageParser<'TTypeIdentifier, 'TOutputType>
        interface IBinaryImageParser
        interface IProvideStatus
    end
JavaScript does not support generic types or methods.
generic<typename TTypeIdentifier, typename TOutputType>
where TOutputType : Object, ISupportFrameImage<TTypeIdentifier>
public ref class FrameImageParserBase abstract : public BinaryImageParserBase,
    IFrameImageParser<TTypeIdentifier, TOutputType>, IBinaryImageParser, IProvideStatus

Type Parameters

TTypeIdentifier
Type of identifier used to distinguish output types.
TOutputType
Type of the interface or class used to represent outputs.

The FrameImageParserBaseTTypeIdentifier, TOutputType type exposes the following members.

Constructors
 | Name | Description
Protected method | FrameImageParserBaseTTypeIdentifier, TOutputType | Creates a new instance of the FrameImageParserBaseTTypeIdentifier, TOutputType class.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataParsed | Raises the DataParsed event.
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event.
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event.
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Public method | Parse | Parses the object implementing the ISupportBinaryImage interface. (Inherited from BinaryImageParserBase.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Overrides BinaryImageParserBaseParseFrame(Byte, Int32, Int32).)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs.
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides BinaryImageParserBaseStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations.
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes a sequence of bytes onto the stream for parsing. (Inherited from BinaryImageParserBase.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Overrides BinaryImageParserBaseEnabled.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Inherited from BinaryImageParserBase.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any.
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current status of FrameImageParserBaseTTypeIdentifier, TOutputType. (Overrides BinaryImageParserBaseStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents.
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type.
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Top
Remarks

This parser is designed as a write-only stream such that data can come from any source.

This class is more specific than the BinaryImageParserBase in that it can automate the parsing of a particular protocol that is formatted as a series of frames that have a common method of identification. Automation of type creation occurs by loading implementations of common types that implement the ISupportFrameImageTTypeIdentifier interface. The common method of identification is handled by creating a class derived from the ICommonHeaderTTypeIdentifier which primarily includes a TypeID property, but also should include any state information needed to parse a particular frame if necessary. Derived classes simply override the ParseCommonHeader(Byte, Int32, Int32) function in order to parse the ICommonHeaderTTypeIdentifier from a provided binary image.

See Also

Reference

GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType) Constructor

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputType Constructor
Creates a new instance of the FrameImageParserBaseTTypeIdentifier, TOutputType class.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrameImageParserBase()
Protected Sub New
new : unit -> FrameImageParserBase
GSF.Parsing.FrameImageParserBase = function();
protected:
FrameImageParserBase()
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType) Fields

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputType Fields

The FrameImageParserBaseTTypeIdentifier, TOutputType generic type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType) Methods

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputType Methods

The FrameImageParserBaseTTypeIdentifier, TOutputType generic type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataParsed | Raises the DataParsed event.
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event.
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event.
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Public method | Parse | Parses the object implementing the ISupportBinaryImage interface. (Inherited from BinaryImageParserBase.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Overrides BinaryImageParserBaseParseFrame(Byte, Int32, Int32).)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs.
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides BinaryImageParserBaseStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations.
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Writes a sequence of bytes onto the stream for parsing. (Inherited from BinaryImageParserBase.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).Dispose Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources. (Overrides StreamDispose(Boolean).)
Top
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).Dispose Method (Boolean)

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeDispose Method (Boolean)
Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
Dispose Overload
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).OnDataParsed Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeOnDataParsed Method
Raises the DataParsed event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDataParsed(
    TOutputType output
)
Protected Overridable Sub OnDataParsed (
    output As TOutputType
)
abstract OnDataParsed :
        output : 'TOutputType -> unit
override OnDataParsed :
        output : 'TOutputType -> unit
function OnDataParsed(output);
protected:
virtual void OnDataParsed(
    TOutputType output
)

Parameters

output
Type: TOutputType
The object that was deserialized from binary image.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).OnDuplicateTypeHandlerEncountered Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeOnDuplicateTypeHandlerEncountered Method
Raises the DuplicateTypeHandlerEncountered event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDuplicateTypeHandlerEncountered(
    Type duplicateType,
    TTypeIdentifier id
)
Protected Overridable Sub OnDuplicateTypeHandlerEncountered (
    duplicateType As Type,
    id As TTypeIdentifier
)
abstract OnDuplicateTypeHandlerEncountered :
        duplicateType : Type *
        id : 'TTypeIdentifier -> unit
override OnDuplicateTypeHandlerEncountered :
        duplicateType : Type *
        id : 'TTypeIdentifier -> unit
function OnDuplicateTypeHandlerEncountered(duplicateType, id);
protected:
virtual void OnDuplicateTypeHandlerEncountered(
    Type^ duplicateType,
    TTypeIdentifier id
)

Parameters

duplicateType
Type: SystemType
The Type that defines a type ID that has already been defined.
id
Type: TTypeIdentifier
The ID of the output type that was defined more than once.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).OnOutputTypeNotFound Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeOnOutputTypeNotFound Method
Raises the OutputTypeNotFound event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOutputTypeNotFound(
    TTypeIdentifier id
)
Protected Overridable Sub OnOutputTypeNotFound (
    id As TTypeIdentifier
)
abstract OnOutputTypeNotFound :
        id : 'TTypeIdentifier -> unit
override OnOutputTypeNotFound :
        id : 'TTypeIdentifier -> unit
function OnOutputTypeNotFound(id);
protected:
virtual void OnOutputTypeNotFound(
    TTypeIdentifier id
)

Parameters

id
Type: TTypeIdentifier
The ID of the output type that was not found.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).ParseCommonHeader Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract ICommonHeader<TTypeIdentifier> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected MustOverride Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of TTypeIdentifier)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<'TTypeIdentifier>

function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<TTypeIdentifier>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) abstract

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader TTypeIdentifier
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).ParseFrame Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeParseFrame Method
Output type specific frame parsing algorithm.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFrame(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseFrame (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As Integer
abstract ParseFrame :
        buffer : byte[] *
        offset : int *
        length : int -> int
override ParseFrame :
        buffer : byte[] *
        offset : int *
        length : int -> int
function ParseFrame(buffer, offset, length);
protected:
virtual int ParseFrame(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).PublishParsedOutput Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypePublishParsedOutput Method
AsyncQueueT handler used to publish queued outputs.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void PublishParsedOutput(
    EventArgs<TOutputType> outputArgs
)
Protected Overridable Sub PublishParsedOutput (
    outputArgs As EventArgs(Of TOutputType)
)
abstract PublishParsedOutput :
        outputArgs : EventArgs<'TOutputType> -> unit
override PublishParsedOutput :
        outputArgs : EventArgs<'TOutputType> -> unit
function PublishParsedOutput(outputArgs);
protected:
virtual void PublishParsedOutput(
    EventArgs<TOutputType>^ outputArgs
)

Parameters

outputArgs
Type: GSFEventArgs TOutputType
Event args containing new output to publish.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).Start Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides BinaryImageParserBaseStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations.
Top
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).Start Method

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeStart Method
Start the data parser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
Remarks
This overload loads public types from assemblies in the application binaries directory that implement the parser's output type.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
Start Overload
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).Start Method (IEnumerable(Type))

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeStart Method (IEnumerableType)
Starts the data parser given the specified type implementations.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Start(
    IEnumerable<Type> implementations
)
Public Overridable Sub Start (
    implementations As IEnumerable(Of Type)
)
abstract Start :
        implementations : IEnumerable<Type> -> unit
override Start :
        implementations : IEnumerable<Type> -> unit
function Start(implementations);
public:
virtual void Start(
    IEnumerable<Type^>^ implementations
)

Parameters

implementations
Type: System.Collections.GenericIEnumerable Type
Output type implementations to establish for the parser.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
Start Overload
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType) Properties

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputType Properties

The FrameImageParserBaseTTypeIdentifier, TOutputType generic type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Overrides BinaryImageParserBaseEnabled.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Inherited from BinaryImageParserBase.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any.
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current status of FrameImageParserBaseTTypeIdentifier, TOutputType. (Overrides BinaryImageParserBaseStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).Enabled Property

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeEnabled Property
Gets or sets a boolean value that indicates whether the frame image parser is currently enabled.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Enabled { get; set; }
Public Overrides Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IBinaryImageParserEnabled
IBinaryImageParserEnabled
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).QueuedOutputs Property

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeQueuedOutputs Property
Gets the total number of parsed outputs that are currently queued for publication, if any.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int QueuedOutputs { get; }
Public Overridable ReadOnly Property QueuedOutputs As Integer
    Get
abstract QueuedOutputs : int with get
override QueuedOutputs : int with get
function get_QueuedOutputs();

public:
virtual property int QueuedOutputs {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).Status Property

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeStatus Property
Gets current status of FrameImageParserBaseTTypeIdentifier, TOutputType.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override string Status { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType) Events

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputType Events

The FrameImageParserBaseTTypeIdentifier, TOutputType generic type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents.
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type.
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).DataParsed Event

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeDataParsed Event
Occurs when a data image is deserialized successfully to one of the output types that the data image represents.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<TOutputType>> DataParsed
Public Event DataParsed As EventHandler(Of EventArgs(Of TOutputType))
abstract DataParsed : IEvent<EventHandler<EventArgs<'TOutputType>>,
    EventArgs<'TOutputType>>
override DataParsed : IEvent<EventHandler<EventArgs<'TOutputType>>,
    EventArgs<'TOutputType>>
function add_DataParsed(value);
function remove_DataParsed(value);
public:
virtual  event EventHandler<EventArgs<TOutputType>^>^ DataParsed {
    void add (EventHandler<EventArgs<TOutputType>^>^ value);
    void remove (EventHandler<EventArgs<TOutputType>^>^ value);
}

Value

Type: SystemEventHandler EventArgs TOutputType

Implements

IFrameImageParserTTypeIdentifier, TOutputTypeDataParsed
Remarks
Argument is the object that was deserialized from the binary image.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).DuplicateTypeHandlerEncountered Event

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeDuplicateTypeHandlerEncountered Event
Occurs when more than one type has been defined that can deserialize the specified output type.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Type, TTypeIdentifier>> DuplicateTypeHandlerEncountered
Public Event DuplicateTypeHandlerEncountered As EventHandler(Of EventArgs(Of Type, TTypeIdentifier))
member DuplicateTypeHandlerEncountered : IEvent<EventHandler<EventArgs<Type, 'TTypeIdentifier>>,
    EventArgs<Type, 'TTypeIdentifier>>

function add_DuplicateTypeHandlerEncountered(value);
function remove_DuplicateTypeHandlerEncountered(value);
public:
 event EventHandler<EventArgs<Type^, TTypeIdentifier>^>^ DuplicateTypeHandlerEncountered {
    void add (EventHandler<EventArgs<Type^, TTypeIdentifier>^>^ value);
    void remove (EventHandler<EventArgs<Type^, TTypeIdentifier>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Type, TTypeIdentifier
Remarks
Argument1 is the Type that defines a type ID that has already been defined.
Argument2 is the ID of the output type that was defined more than once.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


FrameImageParserBase(TTypeIdentifier, TOutputType).OutputTypeNotFound Event

Grid Solutions Framework FrameImageParserBaseTTypeIdentifier, TOutputTypeOutputTypeNotFound Event
Occurs when matching an output type for deserializing the data image could not be found.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<TTypeIdentifier>> OutputTypeNotFound
Public Event OutputTypeNotFound As EventHandler(Of EventArgs(Of TTypeIdentifier))
abstract OutputTypeNotFound : IEvent<EventHandler<EventArgs<'TTypeIdentifier>>,
    EventArgs<'TTypeIdentifier>>
override OutputTypeNotFound : IEvent<EventHandler<EventArgs<'TTypeIdentifier>>,
    EventArgs<'TTypeIdentifier>>
function add_OutputTypeNotFound(value);
function remove_OutputTypeNotFound(value);
public:
virtual  event EventHandler<EventArgs<TTypeIdentifier>^>^ OutputTypeNotFound {
    void add (EventHandler<EventArgs<TTypeIdentifier>^>^ value);
    void remove (EventHandler<EventArgs<TTypeIdentifier>^>^ value);
}

Value

Type: SystemEventHandler EventArgs TTypeIdentifier

Implements

IFrameImageParserTTypeIdentifier, TOutputTypeOutputTypeNotFound
Remarks
Argument is the ID of the output type that could not be found.
See Also

Reference

FrameImageParserBaseTTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


IBinaryImageParser Interface

Grid Solutions Framework IBinaryImageParser Interface
This interface represents the protocol independent representation of a streaming data parser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IBinaryImageParser : IProvideStatus
Public Interface IBinaryImageParser
    Inherits IProvideStatus
type IBinaryImageParser =
    interface
        interface IProvideStatus
    end
GSF.Parsing.IBinaryImageParser = function();
GSF.Parsing.IBinaryImageParser.createInterface('GSF.Parsing.IBinaryImageParser');
public interface class IBinaryImageParser : IProvideStatus

The IBinaryImageParser type exposes the following members.

Methods
 | Name | Description
Public method | Start | Start the streaming data parser.
Public method | Stop | Stops the streaming data parser.
Public method | Write | Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far.
Top
Events
 | Name | Description
Public event | DataDiscarded | Occurs when data image fails deserialization due to an exception.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data.
Top
See Also

Reference

GSF.Parsing Namespace


IBinaryImageParser Methods

Grid Solutions Framework IBinaryImageParser Methods

The IBinaryImageParser type exposes the following members.

Methods
 | Name | Description
Public method | Start | Start the streaming data parser.
Public method | Stop | Stops the streaming data parser.
Public method | Write | Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.
Top
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser.Start Method

Grid Solutions Framework IBinaryImageParserStart Method
Start the streaming data parser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Start()
Sub Start
abstract Start : unit -> unit

function Start();
void Start()
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser.Stop Method

Grid Solutions Framework IBinaryImageParserStop Method
Stops the streaming data parser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Stop()
Sub Stop
abstract Stop : unit -> unit

function Stop();
void Stop()
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser.Write Method

Grid Solutions Framework IBinaryImageParserWrite Method
Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Write(
    byte[] buffer,
    int offset,
    int count
)
Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Write(buffer, offset, count);
void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: SystemInt32
The number of bytes to be written to the current stream.
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser Properties

Grid Solutions Framework IBinaryImageParser Properties

The IBinaryImageParser type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far.
Top
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser.Enabled Property

Grid Solutions Framework IBinaryImageParserEnabled Property
Gets or sets a boolean value that indicates whether the data parser is currently enabled.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser.TotalProcessedBuffers Property

Grid Solutions Framework IBinaryImageParserTotalProcessedBuffers Property
Gets the total number of buffer images processed so far.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
long TotalProcessedBuffers { get; }
ReadOnly Property TotalProcessedBuffers As Long
    Get
abstract TotalProcessedBuffers : int64 with get

function get_TotalProcessedBuffers();

property long long TotalProcessedBuffers {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser Events

Grid Solutions Framework IBinaryImageParser Events

The IBinaryImageParser type exposes the following members.

Events
 | Name | Description
Public event | DataDiscarded | Occurs when data image fails deserialization due to an exception.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data.
Top
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser.DataDiscarded Event

Grid Solutions Framework IBinaryImageParserDataDiscarded Event
Occurs when data image fails deserialization due to an exception.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<byte[]>> DataDiscarded
Event DataDiscarded As EventHandler(Of EventArgs(Of Byte()))
abstract DataDiscarded : IEvent<EventHandler<EventArgs<byte[]>>,
    EventArgs<byte[]>>

function add_DataDiscarded(value);
function remove_DataDiscarded(value);
 event EventHandler<EventArgs<array<unsigned char>^>^>^ DataDiscarded {
    void add (EventHandler<EventArgs<array<unsigned char>^>^>^ value);
    void remove (EventHandler<EventArgs<array<unsigned char>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Byte
Remarks
Argument is the remaining portion of the binary image that failed to parse.
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


IBinaryImageParser.ParsingException Event

Grid Solutions Framework IBinaryImageParserParsingException Event
Occurs when an Exception is encountered while attempting to parse data.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ParsingException
Event ParsingException As EventHandler(Of EventArgs(Of Exception))
abstract ParsingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ParsingException(value);
function remove_ParsingException(value);
 event EventHandler<EventArgs<Exception^>^>^ ParsingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception encountered while parsing data.
See Also

Reference

IBinaryImageParser Interface
GSF.Parsing Namespace


ICommonHeader(TTypeIdentifier) Interface

Grid Solutions Framework ICommonHeaderTTypeIdentifier Interface
Defines the common header of a frame image for a set of parsed types, consisting at least of a type ID.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ICommonHeader<TTypeIdentifier>

Public Interface ICommonHeader(Of TTypeIdentifier)
type ICommonHeader<'TTypeIdentifier> =  interface end
JavaScript does not support generic types or methods.
generic<typename TTypeIdentifier>
public interface class ICommonHeader

Type Parameters

TTypeIdentifier
Type of identifier used to distinguish output types.

The ICommonHeaderTTypeIdentifier type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets or sets any additional state information that might be needed for parsing.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed.
Top
Remarks
Header implementations can extend this interface as necessary to accomodate protocol specific header images.
See Also

Reference

GSF.Parsing Namespace


ICommonHeader(TTypeIdentifier) Properties

Grid Solutions Framework ICommonHeaderTTypeIdentifier Properties

The ICommonHeaderTTypeIdentifier generic type exposes the following members.

Properties
 | Name | Description
Public property | State | Gets or sets any additional state information that might be needed for parsing.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed.
Top
See Also

Reference

ICommonHeaderTTypeIdentifier Interface
GSF.Parsing Namespace


ICommonHeader(TTypeIdentifier).State Property

Grid Solutions Framework ICommonHeaderTTypeIdentifierState Property
Gets or sets any additional state information that might be needed for parsing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Object State { get; set; }
Property State As Object
    Get
    Set
abstract State : Object with get, set

function get_State();
function set_State(value);
property Object^ State {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ICommonHeaderTTypeIdentifier Interface
GSF.Parsing Namespace


ICommonHeader(TTypeIdentifier).TypeID Property

Grid Solutions Framework ICommonHeaderTTypeIdentifierTypeID Property
Gets or sets the identifier used for identifying the Type to be parsed.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TTypeIdentifier TypeID { get; }
ReadOnly Property TypeID As TTypeIdentifier
    Get
abstract TypeID : 'TTypeIdentifier with get

function get_TypeID();

property TTypeIdentifier TypeID {
    TTypeIdentifier get ();
}

Property Value

Type: TTypeIdentifier
See Also

Reference

ICommonHeaderTTypeIdentifier Interface
GSF.Parsing Namespace


IFrameImageParser(TTypeIdentifier, TOutputType) Interface

Grid Solutions Framework IFrameImageParserTTypeIdentifier, TOutputType Interface
This interface represents a basic implementation of parsing functionality suitable for automating the parsing of a binary data stream represented as frames with common headers and returning the parsed data via an event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IFrameImageParser<TTypeIdentifier, TOutputType> : IBinaryImageParser,
    IProvideStatus
where TOutputType : Object, ISupportFrameImage<TTypeIdentifier>

Public Interface IFrameImageParser(Of TTypeIdentifier, TOutputType As {Object, ISupportFrameImage(Of TTypeIdentifier)})
    Inherits IBinaryImageParser, IProvideStatus
type IFrameImageParser<'TTypeIdentifier, 'TOutputType when 'TOutputType : Object and ISupportFrameImage<'TTypeIdentifier>> =
    interface
        interface IBinaryImageParser
        interface IProvideStatus
    end
JavaScript does not support generic types or methods.
generic<typename TTypeIdentifier, typename TOutputType>
where TOutputType : Object, ISupportFrameImage<TTypeIdentifier>
public interface class IFrameImageParser : IBinaryImageParser,
    IProvideStatus

Type Parameters

TTypeIdentifier
Type of identifier used to distinguish output types.
TOutputType
Type of the interface or class used to represent outputs.

The IFrameImageParserTTypeIdentifier, TOutputType type exposes the following members.

Methods
 | Name | Description
Public method | Start | Start the streaming data parser. (Inherited from IBinaryImageParser.)
Public method | Stop | Stops the streaming data parser. (Inherited from IBinaryImageParser.)
Public method | Write | Writes a sequence of bytes onto the IBinaryImageParser stream for parsing. (Inherited from IBinaryImageParser.)
Top
Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled. (Inherited from IBinaryImageParser.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from IBinaryImageParser.)
Top
Events
 | Name | Description
Public event | DataDiscarded | Occurs when data image fails deserialization due to an exception. (Inherited from IBinaryImageParser.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents.
Public event | OutputTypeNotFound | Occurs when matching a output type for deserializing the data image cound not be found.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from IBinaryImageParser.)
Top
See Also

Reference

GSF.Parsing Namespace


IFrameImageParser(TTypeIdentifier, TOutputType) Methods

Grid Solutions Framework IFrameImageParserTTypeIdentifier, TOutputType Methods

The IFrameImageParserTTypeIdentifier, TOutputType generic type exposes the following members.

Methods
 | Name | Description
Public method | Start | Start the streaming data parser. (Inherited from IBinaryImageParser.)
Public method | Stop | Stops the streaming data parser. (Inherited from IBinaryImageParser.)
Public method | Write | Writes a sequence of bytes onto the IBinaryImageParser stream for parsing. (Inherited from IBinaryImageParser.)
Top
See Also

Reference

IFrameImageParserTTypeIdentifier, TOutputType Interface
GSF.Parsing Namespace


IFrameImageParser(TTypeIdentifier, TOutputType) Properties

Grid Solutions Framework IFrameImageParserTTypeIdentifier, TOutputType Properties

The IFrameImageParserTTypeIdentifier, TOutputType generic type exposes the following members.

Properties
 | Name | Description
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled. (Inherited from IBinaryImageParser.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from IBinaryImageParser.)
Top
See Also

Reference

IFrameImageParserTTypeIdentifier, TOutputType Interface
GSF.Parsing Namespace


IFrameImageParser(TTypeIdentifier, TOutputType) Events

Grid Solutions Framework IFrameImageParserTTypeIdentifier, TOutputType Events

The IFrameImageParserTTypeIdentifier, TOutputType generic type exposes the following members.

Events
 | Name | Description
Public event | DataDiscarded | Occurs when data image fails deserialization due to an exception. (Inherited from IBinaryImageParser.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents.
Public event | OutputTypeNotFound | Occurs when matching a output type for deserializing the data image cound not be found.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from IBinaryImageParser.)
Top
See Also

Reference

IFrameImageParserTTypeIdentifier, TOutputType Interface
GSF.Parsing Namespace


IFrameImageParser(TTypeIdentifier, TOutputType).DataParsed Event

Grid Solutions Framework IFrameImageParserTTypeIdentifier, TOutputTypeDataParsed Event
Occurs when a data image is deserialized successfully to one of the output types that the data image represents.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<TOutputType>> DataParsed
Event DataParsed As EventHandler(Of EventArgs(Of TOutputType))
abstract DataParsed : IEvent<EventHandler<EventArgs<'TOutputType>>,
    EventArgs<'TOutputType>>

function add_DataParsed(value);
function remove_DataParsed(value);
 event EventHandler<EventArgs<TOutputType>^>^ DataParsed {
    void add (EventHandler<EventArgs<TOutputType>^>^ value);
    void remove (EventHandler<EventArgs<TOutputType>^>^ value);
}

Value

Type: SystemEventHandler EventArgs TOutputType
Remarks
Argument is the object that was deserialized from the binary image.
See Also

Reference

IFrameImageParserTTypeIdentifier, TOutputType Interface
GSF.Parsing Namespace


IFrameImageParser(TTypeIdentifier, TOutputType).OutputTypeNotFound Event

Grid Solutions Framework IFrameImageParserTTypeIdentifier, TOutputTypeOutputTypeNotFound Event
Occurs when matching a output type for deserializing the data image cound not be found.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<TTypeIdentifier>> OutputTypeNotFound
Event OutputTypeNotFound As EventHandler(Of EventArgs(Of TTypeIdentifier))
abstract OutputTypeNotFound : IEvent<EventHandler<EventArgs<'TTypeIdentifier>>,
    EventArgs<'TTypeIdentifier>>

function add_OutputTypeNotFound(value);
function remove_OutputTypeNotFound(value);
 event EventHandler<EventArgs<TTypeIdentifier>^>^ OutputTypeNotFound {
    void add (EventHandler<EventArgs<TTypeIdentifier>^>^ value);
    void remove (EventHandler<EventArgs<TTypeIdentifier>^>^ value);
}

Value

Type: SystemEventHandler EventArgs TTypeIdentifier
Remarks
Argument is the ID of the output type that could not be found.
See Also

Reference

IFrameImageParserTTypeIdentifier, TOutputType Interface
GSF.Parsing Namespace


ISupportBinaryImage Interface

Grid Solutions Framework ISupportBinaryImage Interface
Specifies that an object can support production or consumption of a binary image that represents the object.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ISupportBinaryImage
Public Interface ISupportBinaryImage
type ISupportBinaryImage =  interface end
GSF.Parsing.ISupportBinaryImage = function();
GSF.Parsing.ISupportBinaryImage.createInterface('GSF.Parsing.ISupportBinaryImage');
public interface class ISupportBinaryImage

The ISupportBinaryImage type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the binary image.
Top
See Also

Reference

GSF.Parsing Namespace


ISupportBinaryImage Methods

Grid Solutions Framework ISupportBinaryImage Methods

The ISupportBinaryImage type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ISupportBinaryImage Interface
GSF.Parsing Namespace


ISupportBinaryImage.GenerateBinaryImage Method

Grid Solutions Framework ISupportBinaryImageGenerateBinaryImage Method
Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int

function GenerateBinaryImage(buffer, startIndex);
int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.
Remarks
Implementers should validate startIndex and BinaryLength against buffer length. The ValidateParametersT(T, Int32, Int32) method can be used to perform this validation.
See Also

Reference

ISupportBinaryImage Interface
GSF.Parsing Namespace


ISupportBinaryImage.ParseBinaryImage Method

Grid Solutions Framework ISupportBinaryImageParseBinaryImage Method
Initializes object by parsing the specified buffer containing a binary image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int

function ParseBinaryImage(buffer, startIndex, length);
int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer to read from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).
Remarks
Implementers should validate startIndex and length against buffer length. The ValidateParametersT(T, Int32, Int32) method can be used to perform this validation.
See Also

Reference

ISupportBinaryImage Interface
GSF.Parsing Namespace


ISupportBinaryImage Properties

Grid Solutions Framework ISupportBinaryImage Properties

The ISupportBinaryImage type exposes the following members.

Properties
 | Name | Description
Public property | BinaryLength | Gets the length of the binary image.
Top
See Also

Reference

ISupportBinaryImage Interface
GSF.Parsing Namespace


ISupportBinaryImage.BinaryLength Property

Grid Solutions Framework ISupportBinaryImageBinaryLength Property
Gets the length of the binary image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int BinaryLength { get; }
ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get

function get_BinaryLength();

property int BinaryLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ISupportBinaryImage Interface
GSF.Parsing Namespace


ISupportBinaryImageExtensions Class

Grid Solutions Framework ISupportBinaryImageExtensions Class
Defines extension functions related to ISupportBinaryImage implementations.
Inheritance Hierarchy
SystemObject
GSF.ParsingISupportBinaryImageExtensions

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ISupportBinaryImageExtensions
<ExtensionAttribute>
Public NotInheritable Class ISupportBinaryImageExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ISupportBinaryImageExtensions =  class end
GSF.Parsing.ISupportBinaryImageExtensions = function();

Type.createClass(
    'GSF.Parsing.ISupportBinaryImageExtensions');
[ExtensionAttribute]
public ref class ISupportBinaryImageExtensions abstract sealed

The ISupportBinaryImageExtensions type exposes the following members.

Methods
Name | Description
BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage.
CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream.
ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream.
Top
See Also

Reference

GSF.Parsing Namespace


ISupportBinaryImageExtensions Methods

Grid Solutions Framework ISupportBinaryImageExtensions Methods

The ISupportBinaryImageExtensions type exposes the following members.

Methods
Name | Description
BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage.
CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream.
ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream.
Top
See Also

Reference

ISupportBinaryImageExtensions Class
GSF.Parsing Namespace


ISupportBinaryImageExtensions.BinaryImage Method

Grid Solutions Framework ISupportBinaryImageExtensionsBinaryImage Method
Returns a binary image of an object that implements ISupportBinaryImage.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] BinaryImage(
    this ISupportBinaryImage imageSource
)
<ExtensionAttribute>
Public Shared Function BinaryImage (
    imageSource As ISupportBinaryImage
) As Byte()
static member BinaryImage :
        imageSource : ISupportBinaryImage -> byte[]

GSF.Parsing.ISupportBinaryImageExtensions.BinaryImage = function(imageSource);
public:
[ExtensionAttribute]
static array<unsigned char>^ BinaryImage(
    ISupportBinaryImage^ imageSource
)

Parameters

imageSource
Type: GSF.ParsingISupportBinaryImage
ISupportBinaryImage source.

Return Value

Type: Byte
A binary image of an object that implements ISupportBinaryImage.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISupportBinaryImage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | imageSource cannot be null.
Remarks
This is a convenience method. It is often optimal to use GenerateBinaryImage(Byte, Int32) directly using a common buffer instead of always allocating new buffers.
See Also

Reference

ISupportBinaryImageExtensions Class
GSF.Parsing Namespace


ISupportBinaryImageExtensions.CopyBinaryImageToStream Method

Grid Solutions Framework ISupportBinaryImageExtensionsCopyBinaryImageToStream Method
Copies binary image of object that implements ISupportBinaryImage to a Stream.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void CopyBinaryImageToStream(
    this ISupportBinaryImage imageSource,
    Stream stream
)
<ExtensionAttribute>
Public Shared Sub CopyBinaryImageToStream (
    imageSource As ISupportBinaryImage,
    stream As Stream
)
static member CopyBinaryImageToStream :
        imageSource : ISupportBinaryImage *
        stream : Stream -> unit

GSF.Parsing.ISupportBinaryImageExtensions.CopyBinaryImageToStream = function(imageSource, stream);
public:
[ExtensionAttribute]
static void CopyBinaryImageToStream(
    ISupportBinaryImage^ imageSource,
    Stream^ stream
)

Parameters

imageSource
Type: GSF.ParsingISupportBinaryImage
ISupportBinaryImage source.
stream
Type: System.IOStream
Destination Stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISupportBinaryImage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | imageSource cannot be null.
See Also

Reference

ISupportBinaryImageExtensions Class
GSF.Parsing Namespace


ISupportBinaryImageExtensions.ParseBinaryImageFromStream Method

Grid Solutions Framework ISupportBinaryImageExtensionsParseBinaryImageFromStream Method
Parses binary image of object that implements ISupportBinaryImage from a Stream.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ParseBinaryImageFromStream(
    this ISupportBinaryImage imageSource,
    Stream stream
)
<ExtensionAttribute>
Public Shared Function ParseBinaryImageFromStream (
    imageSource As ISupportBinaryImage,
    stream As Stream
) As Integer
static member ParseBinaryImageFromStream :
        imageSource : ISupportBinaryImage *
        stream : Stream -> int

GSF.Parsing.ISupportBinaryImageExtensions.ParseBinaryImageFromStream = function(imageSource, stream);
public:
[ExtensionAttribute]
static int ParseBinaryImageFromStream(
    ISupportBinaryImage^ imageSource,
    Stream^ stream
)

Parameters

imageSource
Type: GSF.ParsingISupportBinaryImage
ISupportBinaryImage source.
stream
Type: System.IOStream
Source Stream.

Return Value

Type: Int32
The number of bytes parsed from the stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISupportBinaryImage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Exceptions
Exception | Condition
ArgumentNullException | imageSource cannot be null.
See Also

Reference

ISupportBinaryImageExtensions Class
GSF.Parsing Namespace


ISupportFrameImage(TTypeIdentifier) Interface

Grid Solutions Framework ISupportFrameImageTTypeIdentifier Interface
Specifies that this Type can produce or consume a frame of data represented as a binary image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ISupportFrameImage<TTypeIdentifier> : ISupportBinaryImage

Public Interface ISupportFrameImage(Of TTypeIdentifier)
    Inherits ISupportBinaryImage
type ISupportFrameImage<'TTypeIdentifier> =
    interface
        interface ISupportBinaryImage
    end
JavaScript does not support generic types or methods.
generic<typename TTypeIdentifier>
public interface class ISupportFrameImage : ISupportBinaryImage

Type Parameters

TTypeIdentifier
Type of the frame identifier.

The ISupportFrameImageTTypeIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately.
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonHeader | Gets or sets current ICommonHeaderTTypeIdentifier.
Public property | TypeID | Gets the identifier that can be used for identifying the Type.
Top
Remarks
Related types of protocol data that occur as frames in a stream can implement this interface for automated parsing via the FrameImageParserBaseTTypeIdentifier, TOutputType class.
See Also

Reference

GSF.Parsing Namespace


ISupportFrameImage(TTypeIdentifier) Methods

Grid Solutions Framework ISupportFrameImageTTypeIdentifier Methods

The ISupportFrameImageTTypeIdentifier generic type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ISupportFrameImageTTypeIdentifier Interface
GSF.Parsing Namespace


ISupportFrameImage(TTypeIdentifier) Properties

Grid Solutions Framework ISupportFrameImageTTypeIdentifier Properties

The ISupportFrameImageTTypeIdentifier generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately.
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonHeader | Gets or sets current ICommonHeaderTTypeIdentifier.
Public property | TypeID | Gets the identifier that can be used for identifying the Type.
Top
See Also

Reference

ISupportFrameImageTTypeIdentifier Interface
GSF.Parsing Namespace


ISupportFrameImage(TTypeIdentifier).AllowQueuedPublication Property

Grid Solutions Framework ISupportFrameImageTTypeIdentifierAllowQueuedPublication Property
Gets flag that determines if frame image can queued for publication or should be processed immediately.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool AllowQueuedPublication { get; }
ReadOnly Property AllowQueuedPublication As Boolean
    Get
abstract AllowQueuedPublication : bool with get

function get_AllowQueuedPublication();

property bool AllowQueuedPublication {
    bool get ();
}

Property Value

Type: Boolean
Remarks
Some frames, e.g., a configuration or key frame, may be critical to processing of other frames. In this case, these types of frames should be published immediately so that subsequent frame parsing can have access to needed critical information.
See Also

Reference

ISupportFrameImageTTypeIdentifier Interface
GSF.Parsing Namespace


ISupportFrameImage(TTypeIdentifier).CommonHeader Property

Grid Solutions Framework ISupportFrameImageTTypeIdentifierCommonHeader Property
Gets or sets current ICommonHeaderTTypeIdentifier.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ICommonHeader<TTypeIdentifier> CommonHeader { get; set; }
Property CommonHeader As ICommonHeader(Of TTypeIdentifier)
    Get
    Set
abstract CommonHeader : ICommonHeader<'TTypeIdentifier> with get, set

function get_CommonHeader();
function set_CommonHeader(value);
property ICommonHeader<TTypeIdentifier>^ CommonHeader {
    ICommonHeader<TTypeIdentifier>^ get ();
    void set (ICommonHeader<TTypeIdentifier>^ value);
}

Property Value

Type: ICommonHeader TTypeIdentifier
Remarks
If used, this will need to be set before call to ParseBinaryImage(Byte, Int32, Int32).
See Also

Reference

ISupportFrameImageTTypeIdentifier Interface
GSF.Parsing Namespace


ISupportFrameImage(TTypeIdentifier).TypeID Property

Grid Solutions Framework ISupportFrameImageTTypeIdentifierTypeID Property
Gets the identifier that can be used for identifying the Type.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TTypeIdentifier TypeID { get; }
ReadOnly Property TypeID As TTypeIdentifier
    Get
abstract TypeID : 'TTypeIdentifier with get

function get_TypeID();

property TTypeIdentifier TypeID {
    TTypeIdentifier get ();
}

Property Value

Type: TTypeIdentifier
Remarks

TypeID must be unique across all siblings implementing a common Type or interface.

Output types implement this class so they have a consistently addressable identification property.

See Also

Reference

ISupportFrameImageTTypeIdentifier Interface
GSF.Parsing Namespace


ISupportSourceIdentifiableFrameImage(TSourceIdentifier, TTypeIdentifier) Interface

Grid Solutions Framework ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier Interface
Specifies that this Type can produce or consume a frame of data represented as a binary image that can be identified by its data source.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ISupportSourceIdentifiableFrameImage<TSourceIdentifier, TTypeIdentifier> : ISupportFrameImage<TTypeIdentifier>,
    ISupportBinaryImage

Public Interface ISupportSourceIdentifiableFrameImage(Of TSourceIdentifier, TTypeIdentifier)
    Inherits ISupportFrameImage(Of TTypeIdentifier), ISupportBinaryImage
type ISupportSourceIdentifiableFrameImage<'TSourceIdentifier, 'TTypeIdentifier> =
    interface
        interface ISupportFrameImage<'TTypeIdentifier>
        interface ISupportBinaryImage
    end
JavaScript does not support generic types or methods.
generic<typename TSourceIdentifier, typename TTypeIdentifier>
public interface class ISupportSourceIdentifiableFrameImage : ISupportFrameImage<TTypeIdentifier>,
    ISupportBinaryImage

Type Parameters

TSourceIdentifier
Type of identifier for the data source.
TTypeIdentifier
Type of the frame identifier.

The ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonHeader | Gets or sets current ICommonHeaderTTypeIdentifier. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | Source | Gets or sets the data source identifier of the frame image.
Public property | TypeID | Gets the identifier that can be used for identifying the Type. (Inherited from ISupportFrameImageTTypeIdentifier.)
Top
Remarks
Related types of protocol data that occur as frames in a stream can implement this interface for automated parsing via the MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType class.
See Also

Reference

GSF.Parsing Namespace


ISupportSourceIdentifiableFrameImage(TSourceIdentifier, TTypeIdentifier) Methods

Grid Solutions Framework ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier Methods

The ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier generic type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier Interface
GSF.Parsing Namespace


ISupportSourceIdentifiableFrameImage(TSourceIdentifier, TTypeIdentifier) Properties

Grid Solutions Framework ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier Properties

The ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can queued for publication or should be processed immediately. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonHeader | Gets or sets current ICommonHeaderTTypeIdentifier. (Inherited from ISupportFrameImageTTypeIdentifier.)
Public property | Source | Gets or sets the data source identifier of the frame image.
Public property | TypeID | Gets the identifier that can be used for identifying the Type. (Inherited from ISupportFrameImageTTypeIdentifier.)
Top
See Also

Reference

ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier Interface
GSF.Parsing Namespace


ISupportSourceIdentifiableFrameImage(TSourceIdentifier, TTypeIdentifier).Source Property

Grid Solutions Framework ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifierSource Property
Gets or sets the data source identifier of the frame image.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
TSourceIdentifier Source { get; set; }
Property Source As TSourceIdentifier
    Get
    Set
abstract Source : 'TSourceIdentifier with get, set

function get_Source();
function set_Source(value);
property TSourceIdentifier Source {
    TSourceIdentifier get ();
    void set (TSourceIdentifier value);
}

Property Value

Type: TSourceIdentifier
See Also

Reference

ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier Interface
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType) Class

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
This class defines a basic implementation of parsing functionality suitable for automating the parsing of multiple binary data streams, each represented as frames with common headers and returning the parsed data via an event.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase TTypeIdentifier, TOutputType
GSF.ParsingMultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType
GSF.Historian.PacketsPacketParser
GSF.PhasorProtocolsFrameParserBaseTFrameIdentifier

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class MultiSourceFrameImageParserBase<TSourceIdentifier, TTypeIdentifier, TOutputType> : FrameImageParserBase<TTypeIdentifier, TOutputType>
where TOutputType : Object, ISupportSourceIdentifiableFrameImage<TSourceIdentifier, TTypeIdentifier>

Public MustInherit Class MultiSourceFrameImageParserBase(Of TSourceIdentifier, TTypeIdentifier, TOutputType As {Object, ISupportSourceIdentifiableFrameImage(Of TSourceIdentifier, TTypeIdentifier)})
    Inherits FrameImageParserBase(Of TTypeIdentifier, TOutputType)
[<AbstractClassAttribute>]
type MultiSourceFrameImageParserBase<'TSourceIdentifier, 'TTypeIdentifier, 'TOutputType when 'TOutputType : Object and ISupportSourceIdentifiableFrameImage<'TSourceIdentifier, 'TTypeIdentifier>> =
    class
        inherit FrameImageParserBase<'TTypeIdentifier, 'TOutputType>
    end
JavaScript does not support generic types or methods.
generic<typename TSourceIdentifier, typename TTypeIdentifier, typename TOutputType>
where TOutputType : Object, ISupportSourceIdentifiableFrameImage<TSourceIdentifier, TTypeIdentifier>
public ref class MultiSourceFrameImageParserBase abstract : public FrameImageParserBase<TTypeIdentifier, TOutputType>

Type Parameters

TSourceIdentifier
Type of identifier for the data source.
TTypeIdentifier
Type of identifier used to distinguish output types.
TOutputType
Type of the interface or class used to represent outputs.

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType type exposes the following members.

Constructors
 | Name | Description
Protected method | MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType | Creates a new instance of the MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType class.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Overrides BinaryImageParserBaseOnDataDiscarded(Byte).)
Protected method | OnDataParsed | Raises the DataParsed event. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeOnDataParsed(TOutputType).)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event.
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Overrides BinaryImageParserBaseParse(ISupportBinaryImage).)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing.
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing.
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing.
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source.
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the streaming data parser. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStart(IEnumerableType).)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Overrides BinaryImageParserBaseWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Inherited from BinaryImageParserBase.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current status of FrameImageParserBaseTTypeIdentifier, TOutputType. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents.
Top
Remarks

This parser is designed as a write-only stream such that data can come from any source.

This class is more specific than the BinaryImageParserBase in that it can automate the parsing of a particular protocol that is formatted as a series of frames that have a common method of identification. Automation of type creation occurs by loading implementations of common types that implement the ISupportSourceIdentifiableFrameImageTSourceIdentifier, TTypeIdentifier interface. The common method of identification is handled by creating a class derived from the ICommonHeaderTTypeIdentifier which primarily includes a TypeID property, but also should include any state information needed to parse a particular frame if necessary. Derived classes override the ParseCommonHeader(Byte, Int32, Int32) method in order to parse the ICommonHeaderTTypeIdentifier from a provided binary image.

See Also

Reference

GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType) Constructor

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Constructor
Creates a new instance of the MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType class.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected MultiSourceFrameImageParserBase()
Protected Sub New
new : unit -> MultiSourceFrameImageParserBase
GSF.Parsing.MultiSourceFrameImageParserBase = function();
protected:
MultiSourceFrameImageParserBase()
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType) Fields

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Fields

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType generic type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType) Methods

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Methods

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType generic type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameImageParserBaseTTypeIdentifier, TOutputType object and optionally releases the managed resources. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Overrides BinaryImageParserBaseOnDataDiscarded(Byte).)
Protected method | OnDataParsed | Raises the DataParsed event. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeOnDataParsed(TOutputType).)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event.
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Overrides BinaryImageParserBaseParse(ISupportBinaryImage).)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing.
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing.
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing.
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source.
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the streaming data parser. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStart(IEnumerableType).)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Overrides BinaryImageParserBaseWrite(Byte, Int32, Int32).)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).OnDataDiscarded Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeOnDataDiscarded Method
Raises the DataDiscarded event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnDataDiscarded(
    byte[] buffer
)
Protected Overrides Sub OnDataDiscarded (
    buffer As Byte()
)
abstract OnDataDiscarded :
        buffer : byte[] -> unit
override OnDataDiscarded :
        buffer : byte[] -> unit
function OnDataDiscarded(buffer);
protected:
virtual void OnDataDiscarded(
    array<unsigned char>^ buffer
) override

Parameters

buffer
Type: SystemByte
Source buffer that contains output that failed to parse.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).OnDataParsed Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeOnDataParsed Method
Raises the DataParsed event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnDataParsed(
    TOutputType output
)
Protected Overrides Sub OnDataParsed (
    output As TOutputType
)
abstract OnDataParsed :
        output : 'TOutputType -> unit
override OnDataParsed :
        output : 'TOutputType -> unit
function OnDataParsed(output);
protected:
virtual void OnDataParsed(
    TOutputType output
) override

Parameters

output
Type: TOutputType
The object that was deserialized from binary image.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).OnSourceDataParsed Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeOnSourceDataParsed Method
Raises the SourceDataParsed event.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSourceDataParsed(
    TSourceIdentifier source,
    IList<TOutputType> output
)
Protected Overridable Sub OnSourceDataParsed (
    source As TSourceIdentifier,
    output As IList(Of TOutputType)
)
abstract OnSourceDataParsed :
        source : 'TSourceIdentifier *
        output : IList<'TOutputType> -> unit
override OnSourceDataParsed :
        source : 'TSourceIdentifier *
        output : IList<'TOutputType> -> unit
function OnSourceDataParsed(source, output);
protected:
virtual void OnSourceDataParsed(
    TSourceIdentifier source,
    IList<TOutputType>^ output
)

Parameters

source
Type: TSourceIdentifier
Identifier for the data source.
output
Type: System.Collections.GenericIList TOutputType
The objects that were deserialized from binary images from the source data stream.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Parse Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse Method
Overload List
 | Name | Description
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Overrides BinaryImageParserBaseParse(ISupportBinaryImage).)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing.
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing.
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing.
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Parse Method (ISupportBinaryImage)

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse Method (ISupportBinaryImage)

Note: This API is now obsolete.

Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override void Parse(
    ISupportBinaryImage image
)
<ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Sub Parse (
    image As ISupportBinaryImage
)
[<ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Parse :
        image : ISupportBinaryImage -> unit
[<ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Parse :
        image : ISupportBinaryImage -> unit
function Parse(image);
public:
[ObsoleteAttribute(L"MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void Parse(
    ISupportBinaryImage^ image
) override

Parameters

image
Type: GSF.ParsingISupportBinaryImage
A ISupportBinaryImage.
Exceptions
Exception | Condition
NotImplementedException | This method should not be called directly.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
Parse Overload
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Parse Method (TSourceIdentifier, ISupportBinaryImage)

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse Method (TSourceIdentifier, ISupportBinaryImage)
Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Parse(
    TSourceIdentifier source,
    ISupportBinaryImage image
)
Public Overridable Sub Parse (
    source As TSourceIdentifier,
    image As ISupportBinaryImage
)
abstract Parse :
        source : 'TSourceIdentifier *
        image : ISupportBinaryImage -> unit
override Parse :
        source : 'TSourceIdentifier *
        image : ISupportBinaryImage -> unit
function Parse(source, image);
public:
virtual void Parse(
    TSourceIdentifier source,
    ISupportBinaryImage^ image
)

Parameters

source
Type: TSourceIdentifier
Identifier of the data source.
image
Type: GSF.ParsingISupportBinaryImage
Object to be parsed that implements the ISupportBinaryImage interface.
Remarks
This method takes the binary image from ISupportBinaryImage and writes the buffer to the BinaryImageParserBase stream for parsing.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
Parse Overload
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Parse Method (TSourceIdentifier, Byte[])

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse Method (TSourceIdentifier, Byte)
Queues a sequence of bytes, from the specified data source, onto the stream for parsing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Parse(
    TSourceIdentifier source,
    byte[] buffer
)
Public Overridable Sub Parse (
    source As TSourceIdentifier,
    buffer As Byte()
)
abstract Parse :
        source : 'TSourceIdentifier *
        buffer : byte[] -> unit
override Parse :
        source : 'TSourceIdentifier *
        buffer : byte[] -> unit
function Parse(source, buffer);
public:
virtual void Parse(
    TSourceIdentifier source,
    array<unsigned char>^ buffer
)

Parameters

source
Type: TSourceIdentifier
Identifier of the data source.
buffer
Type: SystemByte
An array of bytes to queue for parsing
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
Parse Overload
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Parse Method (TSourceIdentifier, Byte[], Int32, Int32)

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse Method (TSourceIdentifier, Byte, Int32, Int32)
Queues a sequence of bytes, from the specified data source, onto the stream for parsing.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Parse(
    TSourceIdentifier source,
    byte[] buffer,
    int offset,
    int count
)
Public Overridable Sub Parse (
    source As TSourceIdentifier,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Parse :
        source : 'TSourceIdentifier *
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Parse :
        source : 'TSourceIdentifier *
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Parse(source, buffer, offset, count);
public:
virtual void Parse(
    TSourceIdentifier source,
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

source
Type: TSourceIdentifier
Identifier of the data source.
buffer
Type: SystemByte
An array of bytes. This method copies count bytes from buffer to the queue.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: SystemInt32
The number of bytes to be written to the current stream.
Remarks
This method associates a buffer with its data source identifier.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
Parse Overload
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).PurgeBuffer Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypePurgeBuffer Method
Clears the internal buffer of unparsed data received from the specified source.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void PurgeBuffer(
    TSourceIdentifier source
)
Public Overridable Sub PurgeBuffer (
    source As TSourceIdentifier
)
abstract PurgeBuffer :
        source : 'TSourceIdentifier -> unit
override PurgeBuffer :
        source : 'TSourceIdentifier -> unit
function PurgeBuffer(source);
public:
virtual void PurgeBuffer(
    TSourceIdentifier source
)

Parameters

source
Type: TSourceIdentifier
Identifier of the data source.
Remarks
This method can be used to ensure that partial data received from the source is not kept in memory indefinitely.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Start Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart Method
Overload List
 | Name | Description
Public method | Start | Start the streaming data parser. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStart(IEnumerableType).)
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Start Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart Method
Start the streaming data parser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
Start Overload
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Start Method (IEnumerable(Type))

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart Method (IEnumerableType)
Starts the data parser given the specified type implementations.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start(
    IEnumerable<Type> implementations
)
Public Overrides Sub Start (
    implementations As IEnumerable(Of Type)
)
abstract Start :
        implementations : IEnumerable<Type> -> unit
override Start :
        implementations : IEnumerable<Type> -> unit
function Start(implementations);
public:
virtual void Start(
    IEnumerable<Type^>^ implementations
) override

Parameters

implementations
Type: System.Collections.GenericIEnumerable Type
Output type implementations to establish for the parser.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
Start Overload
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).Write Method

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeWrite Method

Note: This API is now obsolete.

Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)]
public override void Write(
    byte[] buffer,
    int offset,
    int count
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)>
Public Overrides Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)>]
abstract Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<ObsoleteAttribute("MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)>]
override Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Write(buffer, offset, count);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[ObsoleteAttribute(L"MultiSourceFrameImageParserBase requires consumers call Parse overload that takes data source identifier as an argument",
    true)]
virtual void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

buffer
Type: SystemByte
A Byte array.
offset
Type: SystemInt32
An Int32 for the count.
count
Type: SystemInt32
An Int32 for the offset.

Implements

IBinaryImageParserWrite(Byte, Int32, Int32)
Exceptions
Exception | Condition
NotImplementedException | This method should not be called directly.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType) Properties

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Properties

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType generic type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Inherited from BinaryImageParserBase.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current status of FrameImageParserBaseTTypeIdentifier, TOutputType. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).QueuedBuffers Property

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeQueuedBuffers Property
Gets the total number of buffers that are currently queued for processing, if any.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int QueuedBuffers { get; }
Public Overridable ReadOnly Property QueuedBuffers As Integer
    Get
abstract QueuedBuffers : int with get
override QueuedBuffers : int with get
function get_QueuedBuffers();

public:
virtual property int QueuedBuffers {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType) Events

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Events

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType generic type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents.
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).SourceDataParsed Event

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceDataParsed Event
Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<TSourceIdentifier, IList<TOutputType>>> SourceDataParsed
Public Event SourceDataParsed As EventHandler(Of EventArgs(Of TSourceIdentifier, IList(Of TOutputType)))
member SourceDataParsed : IEvent<EventHandler<EventArgs<'TSourceIdentifier, IList<'TOutputType>>>,
    EventArgs<'TSourceIdentifier, IList<'TOutputType>>>

function add_SourceDataParsed(value);
function remove_SourceDataParsed(value);
public:
 event EventHandler<EventArgs<TSourceIdentifier, IList<TOutputType>^>^>^ SourceDataParsed {
    void add (EventHandler<EventArgs<TSourceIdentifier, IList<TOutputType>^>^>^ value);
    void remove (EventHandler<EventArgs<TSourceIdentifier, IList<TOutputType>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs TSourceIdentifier, IList TOutputType
Remarks
Argument1 is the ID of the source for the data image.
Argument2 is a list of objects deserialized from the data image.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).SourceIdentifiableBuffer Class

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
Represents a source identifiable buffer.
Inheritance Hierarchy
SystemObject
GSF.ParsingMultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SourceIdentifiableBuffer
Public Class SourceIdentifiableBuffer
type SourceIdentifiableBuffer =  class end
GSF.Parsing.SourceIdentifiableBuffer = function();

Type.createClass(
    'GSF.Parsing.SourceIdentifiableBuffer');
public ref class SourceIdentifiableBuffer

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer generic type exposes the following members.

Constructors
 | Name | Description
Public method | MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer | Initializes a new instance of the MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Buffer | Defines the buffer which is identifiable by its associated Source.
Public field | Source | Defines the source identifier of the Buffer.
Top
Properties
 | Name | Description
Public property | Count | Gets or sets valid number of bytes within the Buffer.
Public property | Enabled | Gets or sets enabled state of MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer.
Top
Remarks
This class implements ISupportLifecycle such that it will support automatic object pool handling, e.g., returning object to pool when disposed.
See Also

Reference

GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).SourceIdentifiableBuffer Constructor

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Constructor
Initializes a new instance of the MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer class

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SourceIdentifiableBuffer()
Public Sub New
new : unit -> SourceIdentifiableBuffer
GSF.Parsing.SourceIdentifiableBuffer = function();
public:
SourceIdentifiableBuffer()
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


SourceIdentifiableBuffer Fields

Grid Solutions Framework SourceIdentifiableBuffer Fields

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer type exposes the following members.

Fields
 | Name | Description
Public field | Buffer | Defines the buffer which is identifiable by its associated Source.
Public field | Source | Defines the source identifier of the Buffer.
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).SourceIdentifiableBuffer.Buffer Field

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBufferBuffer Field
Defines the buffer which is identifiable by its associated Source.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Buffer
Public Buffer As Byte()
val mutable Buffer: byte[]
var Buffer
public:
array<unsigned char>^ Buffer

Field Value

Type: Byte
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).SourceIdentifiableBuffer.Source Field

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBufferSource Field
Defines the source identifier of the Buffer.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TSourceIdentifier Source
Public Source As TSourceIdentifier
val mutable Source: 'TSourceIdentifier
var Source
public:
TSourceIdentifier Source

Field Value

Type: TSourceIdentifier
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


SourceIdentifiableBuffer Methods

Grid Solutions Framework SourceIdentifiableBuffer Methods

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


SourceIdentifiableBuffer Properties

Grid Solutions Framework SourceIdentifiableBuffer Properties

The MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets or sets valid number of bytes within the Buffer.
Public property | Enabled | Gets or sets enabled state of MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer.
Top
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).SourceIdentifiableBuffer.Count Property

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBufferCount Property
Gets or sets valid number of bytes within the Buffer.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; set; }
Public Property Count As Integer
    Get
    Set
member Count : int with get, set

function get_Count();
function set_Count(value);
public:
property int Count {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This property will automatically initialize buffer. Set to zero to release buffer.
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


MultiSourceFrameImageParserBase(TSourceIdentifier, TTypeIdentifier, TOutputType).SourceIdentifiableBuffer.Enabled Property

Grid Solutions Framework MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBufferEnabled Property
Gets or sets enabled state of MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
member Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
public:
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeSourceIdentifiableBuffer Class
GSF.Parsing Namespace


TemplatedExpressionParser Class

Grid Solutions Framework TemplatedExpressionParser Class
Represents a template based token substitution parser that supports binary and advanced expressions.
Inheritance Hierarchy
SystemObject
GSF.ParsingTemplatedExpressionParser

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TemplatedExpressionParser
Public Class TemplatedExpressionParser
type TemplatedExpressionParser =  class end
GSF.Parsing.TemplatedExpressionParser = function();

Type.createClass(
    'GSF.Parsing.TemplatedExpressionParser');
public ref class TemplatedExpressionParser

The TemplatedExpressionParser type exposes the following members.

Constructors
 | Name | Description
Public method | TemplatedExpressionParser | Creates a new TemplatedExpressionParser.
Public method | TemplatedExpressionParser(Char, Char, Char, Char) | Creates a new TemplatedExpressionParser with desired delimiters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes replacements using provided substitutions dictionary on the currently defined TemplatedExpression value and optionally evaluates any expressions.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | EndExpressionDelimiter | Gets the character that identifies the end of an expression.
Public property | EndTokenDelimiter | Gets the character that identifies the end of a token.
Public property | ReservedSymbols | Gets the reserved symbols - this includes all delimiters and expression operators.
Public property | StartExpressionDelimiter | Gets the character that identifies the start of an expression.
Public property | StartTokenDelimiter | Gets the character that identifies the beginning of a token.
Public property | TemplatedExpression | Gets or sets the templated expression to use.
Top
Remarks

As an example, this parser can use a templated expression of the form:

Copy
{CompanyAcronym}_{DeviceAcronym}[?{SignalType.Source}=Phasor[-{SignalType.Suffix}{SignalIndex}]]:{Signal.Acronymn}
then replace the tokens with actual values and properly evaluate the expressions. Example results could look like: GPA_SHELBY-PA1:IPHA and GPA_SHELBY:FREQ

Parser also supports more complex C# style expressions using the "eval{}" function, e.g.:

Copy
eval{'{CompanyAcronym}'.Substring(0,3)}_{DeviceAcronym}eval{'[?{SignalType.Source}=Phasor[-{SignalType.Suffix}]]'.Length}

See Also

Reference

GSF.Parsing Namespace


TemplatedExpressionParser Constructor

Grid Solutions Framework TemplatedExpressionParser Constructor
Overload List
 | Name | Description
Public method | TemplatedExpressionParser | Creates a new TemplatedExpressionParser.
Public method | TemplatedExpressionParser(Char, Char, Char, Char) | Creates a new TemplatedExpressionParser with desired delimiters.
Top
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser Constructor

Grid Solutions Framework TemplatedExpressionParser Constructor
Creates a new TemplatedExpressionParser.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TemplatedExpressionParser()
Public Sub New
new : unit -> TemplatedExpressionParser
GSF.Parsing.TemplatedExpressionParser = function();
public:
TemplatedExpressionParser()
See Also

Reference

TemplatedExpressionParser Class
TemplatedExpressionParser Overload
GSF.Parsing Namespace


TemplatedExpressionParser Constructor (Char, Char, Char, Char)

Grid Solutions Framework TemplatedExpressionParser Constructor (Char, Char, Char, Char)
Creates a new TemplatedExpressionParser with desired delimiters.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TemplatedExpressionParser(
    char startTokenDelimiter,
    char endTokenDelimiter,
    char startExpressionDelimiter,
    char endExpressionDelimiter
)
Public Sub New (
    startTokenDelimiter As Char,
    endTokenDelimiter As Char,
    startExpressionDelimiter As Char,
    endExpressionDelimiter As Char
)
new :
        startTokenDelimiter : char *
        endTokenDelimiter : char *
        startExpressionDelimiter : char *
        endExpressionDelimiter : char -> TemplatedExpressionParser
GSF.Parsing.TemplatedExpressionParser = function(startTokenDelimiter, endTokenDelimiter, startExpressionDelimiter, endExpressionDelimiter);
public:
TemplatedExpressionParser(
    wchar_t startTokenDelimiter,
    wchar_t endTokenDelimiter,
    wchar_t startExpressionDelimiter,
    wchar_t endExpressionDelimiter
)

Parameters

startTokenDelimiter
Type: SystemChar
Character that identifies the beginning of a token.
endTokenDelimiter
Type: SystemChar
Character that identifies the end of a token.
startExpressionDelimiter
Type: SystemChar
Character that identifies the beginning of an expression.
endExpressionDelimiter
Type: SystemChar
Character that identifies the beginning of an expression.
See Also

Reference

TemplatedExpressionParser Class
TemplatedExpressionParser Overload
GSF.Parsing Namespace


TemplatedExpressionParser Methods

Grid Solutions Framework TemplatedExpressionParser Methods

The TemplatedExpressionParser type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Execute | Executes replacements using provided substitutions dictionary on the currently defined TemplatedExpression value and optionally evaluates any expressions.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser.Execute Method

Grid Solutions Framework TemplatedExpressionParserExecute Method
Executes replacements using provided substitutions dictionary on the currently defined TemplatedExpression value and optionally evaluates any expressions.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Execute(
    IDictionary<string, string> substitutions,
    bool ignoreCase = true,
    bool evaluateExpressions = true
)
Public Function Execute (
    substitutions As IDictionary(Of String, String),
    Optional ignoreCase As Boolean = true,
    Optional evaluateExpressions As Boolean = true
) As String
member Execute :
        substitutions : IDictionary<string, string> *
        ?ignoreCase : bool *
        ?evaluateExpressions : bool
(* Defaults:
        let _ignoreCase = defaultArg ignoreCase true
        let _evaluateExpressions = defaultArg evaluateExpressions true
*)
-> string

function Execute(substitutions, ignoreCase, evaluateExpressions);
public:
String^ Execute(
    IDictionary<String^, String^>^ substitutions,
    bool ignoreCase = true,
    bool evaluateExpressions = true
)

Parameters

substitutions
Type: System.Collections.GenericIDictionary String, String
Dictionary of substitutions. Dictionary keys are tokens to be replaced by the values.
ignoreCase (Optional)
Type: SystemBoolean
Determines if substitutions should be case insensitive. Defaults to true.
evaluateExpressions (Optional)
Type: SystemBoolean
Determines if expressions should be evaluated. Defaults to true.

Return Value

Type: String
A string that was based on TemplatedExpression with tokens replaced and expressions evaluated.
Remarks

The default token start and end delimiters are { and } but can be overridden in TemplatedExpressionParser constructor. All substitution tokens surrounded by StartTokenDelimiter and EndTokenDelimiter (e.g., {token}) will be immediately replaced with their string equivalents before further expression evaluation. As a result of the expression syntax <, >, =, and ! are reserved expressions symbols; StartTokenDelimiter, EndTokenDelimiter, StartExpressionDelimiter and EndExpressionDelimiter are reserved delimiter symbols. To embed any reserved symbol into the TemplatedExpression so that it appears in the evaluated result, escape the symbol by prefixing it with a backslash, e.g., \{.

The default expression start and end delimiters are [ and ] but can be overridden in TemplatedExpressionParser constructor. Expressions are represented in the form of [?expression[result]] and can be nested, e.g. ([?expression1[?expression2[result]]]). Expressions should not contain extraneous white space for proper evaluation. Only simple boolean comparison operations are allowed in expressions, e.g., A=B (or A==B), A!=B (or A<>B), A>B, A>=B, A<B and A<=B - nothing more. Any expression that fails to evaluate will be evaluated as FALSE. Note that if both left (A) and right (B) operands can be parsed as a numeric value then the expression will be numerically evaluated otherwise expression will be a culture-invariant string comparison. Nested expressions are evaluated as cumulative AND operators. There is no defined nesting limit.

Advanced expressions can be parsed using the eval function, e.g., eval{1 + 2}. Eval function expression is delimited by the currently defined token delimiters, { and } by default. The evaluation engine deals with numbers and strings. The typing of numeric literals follow C# standards, suffixes such as d, f and m may be used to explicitly specify the numeric type. If no numeric suffix is provided, the default type of a numeric literal is assumed to be Int32. String literals should be specified using single quotes instead of double quotes, this includes substitution parameters, e.g., eval{'{DeviceAcronym}'.Length + 1}. Advanced evaluation expressions using the eval function are always parsed after common expressions. Eval functions cannot be nested.

See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser Properties

Grid Solutions Framework TemplatedExpressionParser Properties

The TemplatedExpressionParser type exposes the following members.

Properties
 | Name | Description
Public property | EndExpressionDelimiter | Gets the character that identifies the end of an expression.
Public property | EndTokenDelimiter | Gets the character that identifies the end of a token.
Public property | ReservedSymbols | Gets the reserved symbols - this includes all delimiters and expression operators.
Public property | StartExpressionDelimiter | Gets the character that identifies the start of an expression.
Public property | StartTokenDelimiter | Gets the character that identifies the beginning of a token.
Public property | TemplatedExpression | Gets or sets the templated expression to use.
Top
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser.EndExpressionDelimiter Property

Grid Solutions Framework TemplatedExpressionParserEndExpressionDelimiter Property
Gets the character that identifies the end of an expression.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char EndExpressionDelimiter { get; }
Public ReadOnly Property EndExpressionDelimiter As Char
    Get
member EndExpressionDelimiter : char with get

function get_EndExpressionDelimiter();

public:
property wchar_t EndExpressionDelimiter {
    wchar_t get ();
}

Property Value

Type: Char
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser.EndTokenDelimiter Property

Grid Solutions Framework TemplatedExpressionParserEndTokenDelimiter Property
Gets the character that identifies the end of a token.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char EndTokenDelimiter { get; }
Public ReadOnly Property EndTokenDelimiter As Char
    Get
member EndTokenDelimiter : char with get

function get_EndTokenDelimiter();

public:
property wchar_t EndTokenDelimiter {
    wchar_t get ();
}

Property Value

Type: Char
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser.ReservedSymbols Property

Grid Solutions Framework TemplatedExpressionParserReservedSymbols Property
Gets the reserved symbols - this includes all delimiters and expression operators.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char[] ReservedSymbols { get; }
Public ReadOnly Property ReservedSymbols As Char()
    Get
member ReservedSymbols : char[] with get

function get_ReservedSymbols();

public:
property array<wchar_t>^ ReservedSymbols {
    array<wchar_t>^ get ();
}

Property Value

Type: Char
Remarks
The default reserved symbol list is: \, <, >, =, !, {, }, [ and ]
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser.StartExpressionDelimiter Property

Grid Solutions Framework TemplatedExpressionParserStartExpressionDelimiter Property
Gets the character that identifies the start of an expression.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char StartExpressionDelimiter { get; }
Public ReadOnly Property StartExpressionDelimiter As Char
    Get
member StartExpressionDelimiter : char with get

function get_StartExpressionDelimiter();

public:
property wchar_t StartExpressionDelimiter {
    wchar_t get ();
}

Property Value

Type: Char
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser.StartTokenDelimiter Property

Grid Solutions Framework TemplatedExpressionParserStartTokenDelimiter Property
Gets the character that identifies the beginning of a token.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public char StartTokenDelimiter { get; }
Public ReadOnly Property StartTokenDelimiter As Char
    Get
member StartTokenDelimiter : char with get

function get_StartTokenDelimiter();

public:
property wchar_t StartTokenDelimiter {
    wchar_t get ();
}

Property Value

Type: Char
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


TemplatedExpressionParser.TemplatedExpression Property

Grid Solutions Framework TemplatedExpressionParserTemplatedExpression Property
Gets or sets the templated expression to use.

Namespace: GSF.Parsing
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string TemplatedExpression { get; set; }
Public Property TemplatedExpression As String
    Get
    Set
member TemplatedExpression : string with get, set

function get_TemplatedExpression();
function set_TemplatedExpression(value);
public:
property String^ TemplatedExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

TemplatedExpressionParser Class
GSF.Parsing Namespace


GSF.PhasorProtocols Namespace

Grid Solutions Framework GSF.PhasorProtocols Namespace
Contains fundamental classes and interfaces used by all phasor protocol parsing and generating code.
Classes
 | Class | Description
Public class | AnalogDefinitionBase | Represents the common implementation of the protocol independent definition of an IAnalogValue.
Public class | AnalogDefinitionCollection | Represents a protocol independent collection of IAnalogDefinition objects.
Public class | AnalogValueBase | Represents the common implementation of the protocol independent representation of an analog value.
Public class | AnalogValueCollection | Represents a protocol independent collection of IAnalogValue objects.
Public class | ChannelBase | Represents the common implementation of the protocol independent definition of any kind of data that can be parsed or generated. This is the base class of all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating class hierarchy.
Public class | ChannelCellBase | Represents the common implementation of the protocol independent representation of any kind of data cell.
Public class | ChannelCellCollectionBaseT | Represents a protocol independent collection of IChannelCell objects.
Public class | ChannelCellParsingStateBase | Represents the protocol independent common implementation of the parsing state used by any IChannelCell.
Public class | ChannelCollectionBaseT | Represents a protocol independent collection of IChannel objects. This is the base class of all collection classes in the phasor protocols library; it is the root of the collection class hierarchy.
Public class | ChannelDefinitionBase | Represents the common implementation of the protocol independent definition of any kind of IChannel data.
Public class | ChannelDefinitionCollectionBaseT | Represents a protocol independent collection of IChannelDefinition objects.
Public class | ChannelFrameBaseT | Represents the protocol independent common implementation of any frame of data that can be sent or received.
Public class | ChannelFrameCollectionBaseT | Represents a protocol independent collection of IChannelFrame objects.
Public class | ChannelFrameParsingStateBaseT | Represents the protocol independent common implementation of the parsing state used by any IChannelFrame.
Public class | ChannelParsingStateBase | Represents the common implementation of the protocol independent parsing state class used by any kind of data. This is the base class of all parsing state classes in the phasor protocols library; it is the root of the parsing state class hierarchy.
Public class | ChannelValueBaseT | Represents the common implementation of the protocol independent representation of any kind of data value.
Public class | ChannelValueCollectionBaseTDefinition, TValue | Represents a protocol independent collection of IChannelValueT objects.
Public class | ChannelValueMeasurementT | Represents a IMeasurement implementation for composite values of a given IChannelValueT.
Public class | CommandCell | Represents the protocol independent common implementation of an element of extended data for cells in a ICommandFrame.
Public class | CommandCellCollection | Represents a protocol independent collection of ICommandCell objects.
Public class | CommandFrameBase | Represents the protocol independent common implementation of any ICommandFrame that can be sent or received.
Public class | CommandFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any ICommandFrame.
Public class | Common | Common constants, functions and extensions for phasor classes.
Public class | ConfigurationCellBase | Represents the protocol independent common implementation of all configuration elements for cells in a IConfigurationFrame.
Public class | ConfigurationCellCollection | Represents a protocol independent collection of IConfigurationCell objects.
Public class | ConfigurationCellParsingState | Represents the protocol independent common implementation of the parsing state used by any IConfigurationCell.
Public class | ConfigurationFrameBase | Represents the protocol independent common implementation of any IConfigurationFrame that can be sent or received.
Public class | ConfigurationFrameCollection | Represents a protocol independent collection of IConfigurationFrame.
Public class | ConfigurationFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any IConfigurationFrame.
Public class | ConnectionParametersBase | Represents the common implementation of the protocol independent set of extra connection parameters.
Public class | ConnectionSettings | Represents information defined in a PMU Connection Tester connection file.
Public class | CrcException | The exception that is thrown when an object's CRC check fails.
Public class | DataCellBase | Represents the protocol independent common implementation of all elements for cells in a IDataFrame.
Public class | DataCellCollection | Represents a protocol independent collection of IDataCell objects.
Public class | DataCellParsingState | Represents the protocol independent common implementation of the parsing state used by any IDataCell.
Public class | DataFrameBase | Represents the protocol independent common implementation of any IDataFrame that can be sent or received.
Public class | DataFrameCollection | Represents a protocol independent collection of IDataFrame objects.
Public class | DataFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any IDataFrame.
Public class | DigitalDefinitionBase | Represents the common implementation of the protocol independent definition of a IDigitalValue.
Public class | DigitalDefinitionCollection | Represents a protocol independent collection of IDigitalDefinition objects.
Public class | DigitalValueBase | Represents the common implementation of the protocol independent representation of a digital value.
Public class | DigitalValueCollection | Represents a protocol independent collection of IDigitalValue objects.
Public class | FrameParserBaseTFrameIdentifier | Represents a frame parser that defines the basic functionality for a protocol to parse a binary data stream and return the parsed data via events.
Public class | FrequencyDefinitionBase | Represents the common implementation of the protocol independent definition of a IFrequencyValue.
Public class | FrequencyDefinitionCollection | Represents a protocol independent collection of IFrequencyDefinition objects.
Public class | FrequencyValueBase | Represents the common implementation of the protocol independent representation of a frequency and dF/dt value.
Public class | FrequencyValueCollection | Represents a protocol independent collection of IFrequencyValue objects.
Public class | HeaderCell | Represents the protocol independent common implementation of an element of header data for cells in a IHeaderFrame.
Public class | HeaderCellCollection | Represents a protocol independent collection of IHeaderCell objects.
Public class | HeaderFrameBase | Represents the protocol independent common implementation of any IHeaderFrame that can be sent or received.
Public class | HeaderFrameParsingState | Represents the protocol independent common implementation of the parsing state used by any IHeaderFrame.
Public class | MultiProtocolFrameParser | Protocol independent frame parser.
Public class | PhasorDefinitionBase | Represents the common implementation of the protocol independent definition of a IPhasorValue.
Public class | PhasorDefinitionCollection | Represents a protocol independent collection of IPhasorDefinition objects.
Public class | PhasorValueBase | Represents the common implementation of the protocol independent representation of a phasor value.
Public class | PhasorValueCollection | Represents a protocol independent collection of IPhasorValue objects.
Interfaces
 | Interface | Description
Public interface | IAnalogDefinition | Represents a protocol independent interface representation of a definition of an IAnalogValue.
Public interface | IAnalogValue | Represents a protocol independent interface representation of an analog value.
Public interface | IChannel | Represents a protocol independent interface representation of any data type that can be parsed or generated. This is the base interface implemented by all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating interface hierarchy.
Public interface | IChannelCell | Represents a protocol independent interface representation of any kind of IChannelFrame cell.
Public interface | IChannelCellCollectionT | Represents a protocol independent interface representation of a collection of IChannelCell objects.
Public interface | IChannelCellParsingState | Represents a protocol independent interface representation of the parsing state of any kind of IChannelCell.
Public interface | IChannelCollectionT | Represents a protocol independent interface representation of a collection of any IChannel objects. This is the base interface implemented by all collections classes in the phasor protocols library; it is the root of the collection interface hierarchy.
Public interface | IChannelDefinition | Represents a protocol independent interface representation of a definition of any kind of IChannel data.
Public interface | IChannelFrame | Represents a protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.
Public interface | IChannelFrameT | Represents a strongly-typed protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.
Public interface | IChannelFrameParsingStateT | Represents a protocol independent interface representation of the parsing state of any kind of IChannelFrame.
Public interface | IChannelParsingState | Represents a protocol independent interface representation of the parsing state used by any kind of IChannel data. This is the base interface implemented by all parsing state classes in the phasor protocols library; it is the root of the parsing state interface hierarchy.
Public interface | IChannelValueT | Represents a protocol independent interface representation any kind of IChannel data value.
Public interface | ICommandCell | Represents a protocol independent interface representation of any kind of ICommandFrame cell.
Public interface | ICommandFrame | Represents a protocol independent interface representation of any kind of command frame that contains a collection of ICommandCell objects.
Public interface | ICommandFrameParsingState | Represents a protocol independent interface representation of the parsing state of a ICommandFrame.
Public interface | IConfigurationCell | Represents a protocol independent interface representation of any kind of IConfigurationFrame cell.
Public interface | IConfigurationCellParsingState | Represents a protocol independent interface representation of the parsing state of any kind of IConfigurationCell.
Public interface | IConfigurationFrame | Represents a protocol independent interface representation of any kind of configuration frame that contains a collection of IConfigurationCell objects.
Public interface | IConfigurationFrameParsingState | Represents a protocol independent interface representation of the parsing state of a IConfigurationFrame.
Public interface | IConnectionParameters | Represents a protocol independent interface representation of custom connection parameters.
Public interface | IDataCell | Represents a protocol independent interface representation of any kind of IDataFrame cell.
Public interface | IDataCellParsingState | Represents a protocol independent interface representation of the parsing state of any kind of IDataCell.
Public interface | IDataFrame | Represents a protocol independent interface representation of any kind of data frame that contains a collection of IDataCell objects.
Public interface | IDataFrameParsingState | Represents a protocol independent interface representation of the parsing state of a IDataFrame.
Public interface | IDigitalDefinition | Represents a protocol independent interface representation of a definition of a IDigitalValue.
Public interface | IDigitalValue | Represents a protocol independent interface representation of a digital value.
Public interface | IFrameParser | Represents a protocol independent representation of a frame parser.
Public interface | IFrequencyDefinition | Represents a protocol independent interface representation of a definition of a IFrequencyValue.
Public interface | IFrequencyValue | Represents a protocol independent interface of a frequency value.
Public interface | IHeaderCell | Represents a protocol independent interface representation of any kind of IHeaderFrame cell.
Public interface | IHeaderFrame | Represents a protocol independent interface representation of any kind of header frame that contains a collection of IHeaderCell objects.
Public interface | IHeaderFrameParsingState | Represents a protocol independent interface representation of the parsing state of a IHeaderFrame.
Public interface | IPhasorDefinition | Represents a protocol independent interface representation of a definition of a IPhasorValue.
Public interface | IPhasorValue | Represents a protocol independent interface representation of a phasor value.
Delegates
 | Delegate | Description
Public delegate | CreateNewCellFunctionT | Defines function signature for creating new IChannelCell objects.
Public delegate | CreateNewDefinitionFunctionT | Defines function signature for creating new IChannelDefinition objects.
Public delegate | CreateNewValueFunctionTDefinition, TValue | Defines function signature for creating new IChannelValueT objects.
Enumerations
 | Enumeration | Description
Public enumeration | AnalogType | Analog types enumeration.
Public enumeration | AngleFormat | Angle format enumeration.
Public enumeration | CheckSumValidationFrameTypes | Check-sum validation frame-type flags.
Public enumeration | CommonStatusFlags | Protocol independent common status flags enumeration.
Public enumeration | CompositeFrequencyValue | Composite frequency value indices enumeration.
Public enumeration | CompositePhasorValue | Composite polar value indices enumeration.
Public enumeration | CoordinateFormat | Phasor coordinate formats enumeration.
Public enumeration | DataFormat | Data transmission formats enumeration.
Public enumeration | DataSortingType | Data sorting types enumeration.
Public enumeration | DeviceCommand | Phasor enabled device commands enumeration.
Public enumeration | FundamentalFrameType | Fundamental frame types enumeration.
Public enumeration | PhasorProtocol | Phasor data protocols enumeration.
Public enumeration | SourceChannel | Source channel, e.g., data or command.


AnalogDefinitionBase Class

Grid Solutions Framework AnalogDefinitionBase Class
Represents the common implementation of the protocol independent definition of an IAnalogValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsAnalogDefinitionBase
GSF.PhasorProtocols.AnonymousAnalogDefinition
GSF.PhasorProtocols.BPAPDCstreamAnalogDefinition
GSF.PhasorProtocols.IEC61850_90_5AnalogDefinition
GSF.PhasorProtocols.IEEEC37_118AnalogDefinition

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class AnalogDefinitionBase : ChannelDefinitionBase,
    IAnalogDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute>
Public MustInherit Class AnalogDefinitionBase
    Inherits ChannelDefinitionBase
    Implements IAnalogDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),
    IComparable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type AnalogDefinitionBase =
    class
        inherit ChannelDefinitionBase
        interface IAnalogDefinition
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.AnalogDefinitionBase = function();

Type.createClass(
    'GSF.PhasorProtocols.AnalogDefinitionBase',
    GSF.PhasorProtocols.ChannelDefinitionBase,
    GSF.PhasorProtocols.IAnalogDefinition,
    GSF.PhasorProtocols.IChannelDefinition,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable,
    IEquatable`1,
    IComparable`1,
    IComparable);
[SerializableAttribute]
public ref class AnalogDefinitionBase abstract : public ChannelDefinitionBase,
    IAnalogDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable

The AnalogDefinitionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AnalogDefinitionBase(IConfigurationCell) | Creates a new AnalogDefinitionBase.
Protected method | AnalogDefinitionBase(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionBase from serialization parameters.
Protected method | AnalogDefinitionBase(IConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinitionBase from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


AnalogDefinitionBase Constructor

Grid Solutions Framework AnalogDefinitionBase Constructor
Overload List
 | Name | Description
Protected method | AnalogDefinitionBase(IConfigurationCell) | Creates a new AnalogDefinitionBase.
Protected method | AnalogDefinitionBase(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionBase from serialization parameters.
Protected method | AnalogDefinitionBase(IConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinitionBase from specified parameters.
Top
See Also

Reference

AnalogDefinitionBase Class
GSF.PhasorProtocols Namespace


AnalogDefinitionBase Constructor (IConfigurationCell)

Grid Solutions Framework AnalogDefinitionBase Constructor (IConfigurationCell)
Creates a new AnalogDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> AnalogDefinitionBase
GSF.PhasorProtocols.AnalogDefinitionBase = function(parent);
protected:
AnalogDefinitionBase(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this AnalogDefinitionBase.
See Also

Reference

AnalogDefinitionBase Class
AnalogDefinitionBase Overload
GSF.PhasorProtocols Namespace


AnalogDefinitionBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogDefinitionBase Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogDefinitionBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogDefinitionBase
GSF.PhasorProtocols.AnalogDefinitionBase = function(info, context);
protected:
AnalogDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogDefinitionBase Class
AnalogDefinitionBase Overload
GSF.PhasorProtocols Namespace


AnalogDefinitionBase Constructor (IConfigurationCell, String, UInt32, Double, AnalogType)

Grid Solutions Framework AnalogDefinitionBase Constructor (IConfigurationCell, String, UInt32, Double, AnalogType)
Creates a new AnalogDefinitionBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    AnalogType type
)
Protected Sub New (
    parent As IConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As AnalogType
)
new :
        parent : IConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : AnalogType -> AnalogDefinitionBase
GSF.PhasorProtocols.AnalogDefinitionBase = function(parent, label, scale, offset, type);
protected:
AnalogDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    AnalogType type
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this AnalogDefinitionBase.
label
Type: SystemString
The label of this AnalogDefinitionBase.
scale
Type: SystemUInt32
The integer scaling value of this AnalogDefinitionBase.
offset
Type: SystemDouble
The offset of this AnalogDefinitionBase.
type
Type: GSF.PhasorProtocolsAnalogType
The AnalogType of this AnalogDefinitionBase.
See Also

Reference

AnalogDefinitionBase Class
AnalogDefinitionBase Overload
GSF.PhasorProtocols Namespace


AnalogDefinitionBase Methods

Grid Solutions Framework AnalogDefinitionBase Methods

The AnalogDefinitionBase type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

AnalogDefinitionBase Class
GSF.PhasorProtocols Namespace


AnalogDefinitionBase.GetObjectData Method

Grid Solutions Framework AnalogDefinitionBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AnalogDefinitionBase Class
GSF.PhasorProtocols Namespace


AnalogDefinitionBase Properties

Grid Solutions Framework AnalogDefinitionBase Properties

The AnalogDefinitionBase type exposes the following members.

Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

AnalogDefinitionBase Class
GSF.PhasorProtocols Namespace


AnalogDefinitionBase.AnalogType Property

Grid Solutions Framework AnalogDefinitionBaseAnalogType Property
Gets or sets AnalogType of this AnalogDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AnalogType AnalogType { get; set; }
Public Overridable Property AnalogType As AnalogType
    Get
    Set
abstract AnalogType : AnalogType with get, set
override AnalogType : AnalogType with get, set
function get_AnalogType();
function set_AnalogType(value);
public:
virtual property AnalogType AnalogType {
    AnalogType get ();
    void set (AnalogType value);
}

Property Value

Type: AnalogType

Implements

IAnalogDefinitionAnalogType
See Also

Reference

AnalogDefinitionBase Class
GSF.PhasorProtocols Namespace


AnalogDefinitionBase.Attributes Property

Grid Solutions Framework AnalogDefinitionBaseAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

AnalogDefinitionBase Class
GSF.PhasorProtocols Namespace


AnalogDefinitionBase.DataFormat Property

Grid Solutions Framework AnalogDefinitionBaseDataFormat Property
Gets the DataFormat for the AnalogDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat DataFormat { get; }
Public Overrides ReadOnly Property DataFormat As DataFormat
    Get
abstract DataFormat : DataFormat with get
override DataFormat : DataFormat with get
function get_DataFormat();

public:
virtual property DataFormat DataFormat {
    DataFormat get () override;
}

Property Value

Type: DataFormat

Implements

IChannelDefinitionDataFormat
IChannelDefinitionDataFormat
See Also

Reference

AnalogDefinitionBase Class
GSF.PhasorProtocols Namespace


AnalogDefinitionCollection Class

Grid Solutions Framework AnalogDefinitionCollection Class
Represents a protocol independent collection of IAnalogDefinition objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IAnalogDefinition
GSF.CollectionsListCollection IAnalogDefinition
GSF.PhasorProtocolsChannelCollectionBase IAnalogDefinition
GSF.PhasorProtocolsChannelDefinitionCollectionBase IAnalogDefinition
GSF.PhasorProtocolsAnalogDefinitionCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogDefinitionCollection : ChannelDefinitionCollectionBase<IAnalogDefinition>
<SerializableAttribute>
Public Class AnalogDefinitionCollection
    Inherits ChannelDefinitionCollectionBase(Of IAnalogDefinition)
[<SerializableAttribute>]
type AnalogDefinitionCollection =
    class
        inherit ChannelDefinitionCollectionBase<IAnalogDefinition>
    end
GSF.PhasorProtocols.AnalogDefinitionCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.AnalogDefinitionCollection',
    GSF.PhasorProtocols.ChannelDefinitionCollectionBase`1);
[SerializableAttribute]
public ref class AnalogDefinitionCollection : public ChannelDefinitionCollectionBase<IAnalogDefinition^>

The AnalogDefinitionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogDefinitionCollection(Int32) | Creates a new AnalogDefinitionCollection using specified lastValidIndex.
Protected method | AnalogDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


AnalogDefinitionCollection Constructor

Grid Solutions Framework AnalogDefinitionCollection Constructor
Overload List
 | Name | Description
Public method | AnalogDefinitionCollection(Int32) | Creates a new AnalogDefinitionCollection using specified lastValidIndex.
Protected method | AnalogDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new AnalogDefinitionCollection from serialization parameters.
Top
See Also

Reference

AnalogDefinitionCollection Class
GSF.PhasorProtocols Namespace


AnalogDefinitionCollection Constructor (Int32)

Grid Solutions Framework AnalogDefinitionCollection Constructor (Int32)
Creates a new AnalogDefinitionCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinitionCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> AnalogDefinitionCollection
GSF.PhasorProtocols.AnalogDefinitionCollection = function(lastValidIndex);
public:
AnalogDefinitionCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

AnalogDefinitionCollection Class
AnalogDefinitionCollection Overload
GSF.PhasorProtocols Namespace


AnalogDefinitionCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogDefinitionCollection Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogDefinitionCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogDefinitionCollection
GSF.PhasorProtocols.AnalogDefinitionCollection = function(info, context);
protected:
AnalogDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogDefinitionCollection Class
AnalogDefinitionCollection Overload
GSF.PhasorProtocols Namespace


AnalogDefinitionCollection Methods

Grid Solutions Framework AnalogDefinitionCollection Methods

The AnalogDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogDefinitionCollection Class
GSF.PhasorProtocols Namespace


AnalogDefinitionCollection Properties

Grid Solutions Framework AnalogDefinitionCollection Properties

The AnalogDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

AnalogDefinitionCollection Class
GSF.PhasorProtocols Namespace


AnalogDefinitionCollection Events

Grid Solutions Framework AnalogDefinitionCollection Events

The AnalogDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

AnalogDefinitionCollection Class
GSF.PhasorProtocols Namespace


AnalogType Enumeration

Grid Solutions Framework AnalogType Enumeration
Analog types enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum AnalogType
<SerializableAttribute>
Public Enumeration AnalogType
[<SerializableAttribute>]
type AnalogType
GSF.PhasorProtocols.AnalogType = function();
GSF.PhasorProtocols.AnalogType.createEnum('GSF.PhasorProtocols.AnalogType', false);
[SerializableAttribute]
public enum class AnalogType
Members
Member name | Value | Description
SinglePointOnWave | 0 | Single point-on-wave.
RmsOfAnalogInput | 1 | RMS of analog input.
PeakOfAnalogInput | 2 | Peak of analog input.
See Also

Reference

GSF.PhasorProtocols Namespace


AnalogValueBase Class

Grid Solutions Framework AnalogValueBase Class
Represents the common implementation of the protocol independent representation of an analog value.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IAnalogDefinition
GSF.PhasorProtocolsAnalogValueBase
GSF.PhasorProtocols.BPAPDCstreamAnalogValue
GSF.PhasorProtocols.IEC61850_90_5AnalogValue
GSF.PhasorProtocols.IEEEC37_118AnalogValue

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class AnalogValueBase : ChannelValueBase<IAnalogDefinition>,
    IAnalogValue, IChannelValue<IAnalogDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute>
Public MustInherit Class AnalogValueBase
    Inherits ChannelValueBase(Of IAnalogDefinition)
    Implements IAnalogValue, IChannelValue(Of IAnalogDefinition),
    IChannel, ISupportBinaryImage, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type AnalogValueBase =
    class
        inherit ChannelValueBase<IAnalogDefinition>
        interface IAnalogValue
        interface IChannelValue<IAnalogDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.AnalogValueBase = function();

Type.createClass(
    'GSF.PhasorProtocols.AnalogValueBase',
    GSF.PhasorProtocols.ChannelValueBase`1,
    GSF.PhasorProtocols.IAnalogValue,
    GSF.PhasorProtocols.IChannelValue`1,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class AnalogValueBase abstract : public ChannelValueBase<IAnalogDefinition^>,
    IAnalogValue, IChannelValue<IAnalogDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable

The AnalogValueBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AnalogValueBase(SerializationInfo, StreamingContext) | Creates a new AnalogValueBase from serialization parameters.
Protected method | AnalogValueBase(IDataCell, IAnalogDefinition) | Creates a new AnalogValueBase.
Protected method | AnalogValueBase(IDataCell, IAnalogDefinition, Double) | Creates a new AnalogValueBase from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


AnalogValueBase Constructor

Grid Solutions Framework AnalogValueBase Constructor
Overload List
 | Name | Description
Protected method | AnalogValueBase(SerializationInfo, StreamingContext) | Creates a new AnalogValueBase from serialization parameters.
Protected method | AnalogValueBase(IDataCell, IAnalogDefinition) | Creates a new AnalogValueBase.
Protected method | AnalogValueBase(IDataCell, IAnalogDefinition, Double) | Creates a new AnalogValueBase from specified parameters.
Top
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogValueBase Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogValueBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogValueBase
GSF.PhasorProtocols.AnalogValueBase = function(info, context);
protected:
AnalogValueBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogValueBase Class
AnalogValueBase Overload
GSF.PhasorProtocols Namespace


AnalogValueBase Constructor (IDataCell, IAnalogDefinition)

Grid Solutions Framework AnalogValueBase Constructor (IDataCell, IAnalogDefinition)
Creates a new AnalogValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogValueBase(
    IDataCell parent,
    IAnalogDefinition analogDefinition
)
Protected Sub New (
    parent As IDataCell,
    analogDefinition As IAnalogDefinition
)
new :
        parent : IDataCell *
        analogDefinition : IAnalogDefinition -> AnalogValueBase
GSF.PhasorProtocols.AnalogValueBase = function(parent, analogDefinition);
protected:
AnalogValueBase(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this AnalogValueBase.
analogDefinition
Type: GSF.PhasorProtocolsIAnalogDefinition
The IAnalogDefinition associated with this AnalogValueBase.
See Also

Reference

AnalogValueBase Class
AnalogValueBase Overload
GSF.PhasorProtocols Namespace


AnalogValueBase Constructor (IDataCell, IAnalogDefinition, Double)

Grid Solutions Framework AnalogValueBase Constructor (IDataCell, IAnalogDefinition, Double)
Creates a new AnalogValueBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogValueBase(
    IDataCell parent,
    IAnalogDefinition analogDefinition,
    double value
)
Protected Sub New (
    parent As IDataCell,
    analogDefinition As IAnalogDefinition,
    value As Double
)
new :
        parent : IDataCell *
        analogDefinition : IAnalogDefinition *
        value : float -> AnalogValueBase
GSF.PhasorProtocols.AnalogValueBase = function(parent, analogDefinition, value);
protected:
AnalogValueBase(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition,
    double value
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this AnalogValueBase.
analogDefinition
Type: GSF.PhasorProtocolsIAnalogDefinition
The IAnalogDefinition associated with this AnalogValueBase.
value
Type: SystemDouble
The floating point value that represents this AnalogValueBase.
See Also

Reference

AnalogValueBase Class
AnalogValueBase Overload
GSF.PhasorProtocols Namespace


AnalogValueBase Methods

Grid Solutions Framework AnalogValueBase Methods

The AnalogValueBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.GetCompositeValue Method

Grid Solutions Framework AnalogValueBaseGetCompositeValue Method
Gets the specified composite value of this AnalogValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue (
    index As Integer
) As Double
abstract GetCompositeValue :
        index : int -> float
override GetCompositeValue :
        index : int -> float
function GetCompositeValue(index);
public:
virtual double GetCompositeValue(
    int index
) override

Parameters

index
Type: SystemInt32
Index of composite value to retrieve.

Return Value

Type: Double
A composite value as Double.

Implements

IChannelValueTGetCompositeValue(Int32)
IChannelValueTGetCompositeValue(Int32)
Remarks
Some ChannelValueBaseT implementations can contain more than one value, this method is used to abstractly expose each value.
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.GetObjectData Method

Grid Solutions Framework AnalogValueBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.ParseBodyImage Method

Grid Solutions Framework AnalogValueBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase Properties

Grid Solutions Framework AnalogValueBase Properties

The AnalogValueBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase.
Top
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.Attributes Property

Grid Solutions Framework AnalogValueBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.BodyImage Property

Grid Solutions Framework AnalogValueBaseBodyImage Property
Gets the binary body image of the AnalogValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.BodyLength Property

Grid Solutions Framework AnalogValueBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.CompositeValueCount Property

Grid Solutions Framework AnalogValueBaseCompositeValueCount Property
Gets total number of composite values that this AnalogValueBase provides.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
abstract CompositeValueCount : int with get
override CompositeValueCount : int with get
function get_CompositeValueCount();

public:
virtual property int CompositeValueCount {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelValueTCompositeValueCount
IChannelValueTCompositeValueCount
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.IntegerValue Property

Grid Solutions Framework AnalogValueBaseIntegerValue Property
Gets or sets the integer representation of this AnalogValueBase value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IntegerValue { get; set; }
Public Overridable Property IntegerValue As Integer
    Get
    Set
abstract IntegerValue : int with get, set
override IntegerValue : int with get, set
function get_IntegerValue();
function set_IntegerValue(value);
public:
virtual property int IntegerValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IAnalogValueIntegerValue
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.IsEmpty Property

Grid Solutions Framework AnalogValueBaseIsEmpty Property
Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get
override IsEmpty : bool with get
function get_IsEmpty();

public:
virtual property bool IsEmpty {
    bool get () override;
}

Return Value

Type: Boolean
True, if no composite values have been assigned a value; otherwise, false.

Implements

IChannelValueTIsEmpty
IChannelValueTIsEmpty
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueBase.Value Property

Grid Solutions Framework AnalogValueBaseValue Property
Gets or sets the floating point value that represents this AnalogValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Value { get; set; }
Public Overridable Property Value As Double
    Get
    Set
abstract Value : float with get, set
override Value : float with get, set
function get_Value();
function set_Value(value);
public:
virtual property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IAnalogValueValue
See Also

Reference

AnalogValueBase Class
GSF.PhasorProtocols Namespace


AnalogValueCollection Class

Grid Solutions Framework AnalogValueCollection Class
Represents a protocol independent collection of IAnalogValue objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IAnalogValue
GSF.CollectionsListCollection IAnalogValue
GSF.PhasorProtocolsChannelCollectionBase IAnalogValue
GSF.PhasorProtocolsChannelValueCollectionBase IAnalogDefinition, IAnalogValue
GSF.PhasorProtocolsAnalogValueCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogValueCollection : ChannelValueCollectionBase<IAnalogDefinition, IAnalogValue>
<SerializableAttribute>
Public Class AnalogValueCollection
    Inherits ChannelValueCollectionBase(Of IAnalogDefinition, IAnalogValue)
[<SerializableAttribute>]
type AnalogValueCollection =
    class
        inherit ChannelValueCollectionBase<IAnalogDefinition, IAnalogValue>
    end
GSF.PhasorProtocols.AnalogValueCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.AnalogValueCollection',
    GSF.PhasorProtocols.ChannelValueCollectionBase`2);
[SerializableAttribute]
public ref class AnalogValueCollection : public ChannelValueCollectionBase<IAnalogDefinition^, IAnalogValue^>

The AnalogValueCollection type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogValueCollection(Int32) | Creates a new AnalogValueCollection using specified lastValidIndex.
Protected method | AnalogValueCollection(SerializationInfo, StreamingContext) | Creates a new AnalogValueCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


AnalogValueCollection Constructor

Grid Solutions Framework AnalogValueCollection Constructor
Overload List
 | Name | Description
Public method | AnalogValueCollection(Int32) | Creates a new AnalogValueCollection using specified lastValidIndex.
Protected method | AnalogValueCollection(SerializationInfo, StreamingContext) | Creates a new AnalogValueCollection from serialization parameters.
Top
See Also

Reference

AnalogValueCollection Class
GSF.PhasorProtocols Namespace


AnalogValueCollection Constructor (Int32)

Grid Solutions Framework AnalogValueCollection Constructor (Int32)
Creates a new AnalogValueCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogValueCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> AnalogValueCollection
GSF.PhasorProtocols.AnalogValueCollection = function(lastValidIndex);
public:
AnalogValueCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

AnalogValueCollection Class
AnalogValueCollection Overload
GSF.PhasorProtocols Namespace


AnalogValueCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogValueCollection Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogValueCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogValueCollection
GSF.PhasorProtocols.AnalogValueCollection = function(info, context);
protected:
AnalogValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogValueCollection Class
AnalogValueCollection Overload
GSF.PhasorProtocols Namespace


AnalogValueCollection Methods

Grid Solutions Framework AnalogValueCollection Methods

The AnalogValueCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogValueCollection Class
GSF.PhasorProtocols Namespace


AnalogValueCollection Properties

Grid Solutions Framework AnalogValueCollection Properties

The AnalogValueCollection type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

AnalogValueCollection Class
GSF.PhasorProtocols Namespace


AnalogValueCollection Events

Grid Solutions Framework AnalogValueCollection Events

The AnalogValueCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

AnalogValueCollection Class
GSF.PhasorProtocols Namespace


AngleFormat Enumeration

Grid Solutions Framework AngleFormat Enumeration
Angle format enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum AngleFormat
Public Enumeration AngleFormat
type AngleFormat
GSF.PhasorProtocols.AngleFormat = function();
GSF.PhasorProtocols.AngleFormat.createEnum('GSF.PhasorProtocols.AngleFormat', false);
public enum class AngleFormat
Members
Member name | Value | Description
Degrees | 0 | Serialize angles in degrees.
Radians | 1 | Serialize angles in radians.
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelBase Class

Grid Solutions Framework ChannelBase Class
Represents the common implementation of the protocol independent definition of any kind of data that can be parsed or generated.
This is the base class of all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating class hierarchy.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsChannelFrameBaseT
GSF.PhasorProtocolsChannelValueBaseT

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ChannelBase : BinaryImageBase,
    IChannel, ISupportBinaryImage
Public MustInherit Class ChannelBase
    Inherits BinaryImageBase
    Implements IChannel, ISupportBinaryImage
[<AbstractClassAttribute>]
type ChannelBase =
    class
        inherit BinaryImageBase
        interface IChannel
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.ChannelBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ChannelBase',
    GSF.Parsing.BinaryImageBase,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage);
public ref class ChannelBase abstract : public BinaryImageBase,
    IChannel, ISupportBinaryImage

The ChannelBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelBase | Initializes a new instance of the ChannelBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Overrides BinaryImageBaseGenerateBinaryImage(Byte, Int32).)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from BinaryImageBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelBase object.
Public property | BinaryImage | Gets the binary image of the ChannelBase object.
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelBase object.
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object.
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object.
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object.
Top
Remarks
This base class represents IChannel data images for parsing or generation in terms of a header, body and footer (see BinaryImageBase for details).
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelBase Constructor

Grid Solutions Framework ChannelBase Constructor
Initializes a new instance of the ChannelBase class

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelBase()
Protected Sub New
new : unit -> ChannelBase
GSF.PhasorProtocols.ChannelBase = function();
protected:
ChannelBase()
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase Methods

Grid Solutions Framework ChannelBase Methods

The ChannelBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Overrides BinaryImageBaseGenerateBinaryImage(Byte, Int32).)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from BinaryImageBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.GenerateBinaryImage Method

Grid Solutions Framework ChannelBaseGenerateBinaryImage Method
Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overrides Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase Properties

Grid Solutions Framework ChannelBase Properties

The ChannelBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelBase object.
Public property | BinaryImage | Gets the binary image of the ChannelBase object.
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelBase object.
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object.
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object.
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object.
Top
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.Attributes Property

Grid Solutions Framework ChannelBaseAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this ChannelBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Dictionary<string, string> Attributes { get; }
Public Overridable ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
Remarks
The attributes dictionary is relevant to all channel properties. This dictionary will only be instantiated with a call to the Attributes property which will begin the enumeration of relevant system properties. This is typically used for display purposes. For example, this information is displayed in a tree view on the the PMU Connection Tester to display attributes of data elements that may be protocol specific.
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.BinaryImage Property

Grid Solutions Framework ChannelBaseBinaryImage Property
Gets the binary image of the ChannelBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte[] BinaryImage { get; }
Public Overridable ReadOnly Property BinaryImage As Byte()
    Get
abstract BinaryImage : byte[] with get
override BinaryImage : byte[] with get
function get_BinaryImage();

public:
virtual property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
Remarks
This property is not typically overridden since it is the combination of the header, body and footer images.
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.BodyImage Property

Grid Solutions Framework ChannelBaseBodyImage Property
Gets the binary body image of the ChannelBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual byte[] BodyImage { get; }
Protected Overridable ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
Remarks
This property is typically overridden by a specific protocol implementation.
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.FooterImage Property

Grid Solutions Framework ChannelBaseFooterImage Property
Gets the binary footer image of the BinaryImageBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual byte[] FooterImage { get; }
Protected Overridable ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
Remarks
This property is typically overridden by a specific protocol implementation.
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.HeaderImage Property

Grid Solutions Framework ChannelBaseHeaderImage Property
Gets the binary header image of the ChannelBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual byte[] HeaderImage { get; }
Protected Overridable ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
Remarks
This property is typically overridden by a specific protocol implementation.
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.State Property

Grid Solutions Framework ChannelBaseState Property
Gets or sets the parsing state for this ChannelBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IChannelParsingState State { get; set; }
Public Overridable Property State As IChannelParsingState
    Get
    Set
abstract State : IChannelParsingState with get, set
override State : IChannelParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}

Property Value

Type: IChannelParsingState

Implements

IChannelState
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelBase.Tag Property

Grid Solutions Framework ChannelBaseTag Property
Gets or sets a user definable reference to an object associated with this ChannelBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Object Tag { get; set; }
Public Overridable Property Tag As Object
    Get
    Set
abstract Tag : Object with get, set
override Tag : Object with get, set
function get_Tag();
function set_Tag(value);
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object

Implements

IChannelTag
See Also

Reference

ChannelBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase Class

Grid Solutions Framework ChannelCellBase Class
Represents the common implementation of the protocol independent representation of any kind of data cell.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsCommandCell
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocolsHeaderCell

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelCellBase : ChannelBase,
    IChannelCell, IChannel, ISupportBinaryImage, ISerializable
<SerializableAttribute>
Public MustInherit Class ChannelCellBase
    Inherits ChannelBase
    Implements IChannelCell, IChannel, ISupportBinaryImage, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelCellBase =
    class
        inherit ChannelBase
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.ChannelCellBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ChannelCellBase',
    GSF.PhasorProtocols.ChannelBase,
    GSF.PhasorProtocols.IChannelCell,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class ChannelCellBase abstract : public ChannelBase,
    IChannelCell, IChannel, ISupportBinaryImage, ISerializable

The ChannelCellBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelCellBase(SerializationInfo, StreamingContext) | Creates a new ChannelCellBase from serialization parameters.
Protected method | ChannelCellBase(IChannelFrame, UInt16) | Creates a new ChannelCellBase from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from BinaryImageBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelCellBase object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase.
Public property | Parent | Gets or sets a reference to the parent IChannelFrame for this ChannelCellBase.
Public property | State | Gets or sets the parsing state for the this ChannelCellBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
Remarks
This phasor protocol implementation defines a "cell" as a portion of a frame, i.e., a logical unit of data. For example, a DataCellBase (derived from ChannelCellBase) could be defined as a PMU within a frame of data, a DataFrameBase, that contains multiple PMU's coming from a PDC.
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelCellBase Constructor

Grid Solutions Framework ChannelCellBase Constructor
Overload List
 | Name | Description
Protected method | ChannelCellBase(SerializationInfo, StreamingContext) | Creates a new ChannelCellBase from serialization parameters.
Protected method | ChannelCellBase(IChannelFrame, UInt16) | Creates a new ChannelCellBase from specified parameters.
Top
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelCellBase Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelCellBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCellBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelCellBase
GSF.PhasorProtocols.ChannelCellBase = function(info, context);
protected:
ChannelCellBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelCellBase Class
ChannelCellBase Overload
GSF.PhasorProtocols Namespace


ChannelCellBase Constructor (IChannelFrame, UInt16)

Grid Solutions Framework ChannelCellBase Constructor (IChannelFrame, UInt16)
Creates a new ChannelCellBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCellBase(
    IChannelFrame parent,
    ushort idCode
)
Protected Sub New (
    parent As IChannelFrame,
    idCode As UShort
)
new :
        parent : IChannelFrame *
        idCode : uint16 -> ChannelCellBase
GSF.PhasorProtocols.ChannelCellBase = function(parent, idCode);
protected:
ChannelCellBase(
    IChannelFrame^ parent,
    unsigned short idCode
)

Parameters

parent
Type: GSF.PhasorProtocolsIChannelFrame
A reference to the parent IChannelFrame for this ChannelCellBase.
idCode
Type: SystemUInt16
The numeric ID code for this ChannelCellBase.
See Also

Reference

ChannelCellBase Class
ChannelCellBase Overload
GSF.PhasorProtocols Namespace


ChannelCellBase Methods

Grid Solutions Framework ChannelCellBase Methods

The ChannelCellBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from BinaryImageBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase.GetObjectData Method

Grid Solutions Framework ChannelCellBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase.ToString Method

Grid Solutions Framework ChannelCellBaseToString Method
Gets the string respresentation of this ChannelCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
String respresentation of this ChannelCellBase.
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase Properties

Grid Solutions Framework ChannelCellBase Properties

The ChannelCellBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelCellBase object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase.
Public property | Parent | Gets or sets a reference to the parent IChannelFrame for this ChannelCellBase.
Public property | State | Gets or sets the parsing state for the this ChannelCellBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase.Attributes Property

Grid Solutions Framework ChannelCellBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the ChannelCellBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase.IDCode Property

Grid Solutions Framework ChannelCellBaseIDCode Property
Gets or sets the numeric ID code for this ChannelCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ushort IDCode { get; set; }
Public Overridable Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16

Implements

IChannelCellIDCode
Remarks
Most phasor measurement devices define some kind of numeric identifier (e.g., a hardware identifier coded into the device ROM); this is the abstract representation of this identifier.
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase.Parent Property

Grid Solutions Framework ChannelCellBaseParent Property
Gets or sets a reference to the parent IChannelFrame for this ChannelCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IChannelFrame Parent { get; set; }
Public Overridable Property Parent As IChannelFrame
    Get
    Set
abstract Parent : IChannelFrame with get, set
override Parent : IChannelFrame with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property IChannelFrame^ Parent {
    IChannelFrame^ get ();
    void set (IChannelFrame^ value);
}

Property Value

Type: IChannelFrame

Implements

IChannelCellParent
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellBase.State Property

Grid Solutions Framework ChannelCellBaseState Property
Gets or sets the parsing state for the this ChannelCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IChannelCellParsingState State { get; set; }
Public Overridable Property State As IChannelCellParsingState
    Get
    Set
abstract State : IChannelCellParsingState with get, set
override State : IChannelCellParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IChannelCellParsingState^ State {
    IChannelCellParsingState^ get ();
    void set (IChannelCellParsingState^ value);
}

Property Value

Type: IChannelCellParsingState

Implements

IChannelCellState
See Also

Reference

ChannelCellBase Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T) Class

Grid Solutions Framework ChannelCellCollectionBaseT Class
Represents a protocol independent collection of IChannelCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
GSF.CollectionsListCollection T
GSF.PhasorProtocolsChannelCollectionBase T
GSF.PhasorProtocolsChannelCellCollectionBaseT
GSF.PhasorProtocolsCommandCellCollection
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocolsHeaderCellCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelCellCollectionBase<T> : ChannelCollectionBase<T>,
    IChannelCellCollection<T>, IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, INotifyCollectionChanged, ISerializable
where T : IChannelCell

<SerializableAttribute>
Public MustInherit Class ChannelCellCollectionBase(Of T As IChannelCell)
    Inherits ChannelCollectionBase(Of T)
    Implements IChannelCellCollection(Of T), IChannelCollection(Of T),
    IChannel, ISupportBinaryImage, IList(Of T), ICollection(Of T),
    IEnumerable(Of T), IEnumerable, INotifyCollectionChanged, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelCellCollectionBase<'T when 'T : IChannelCell> =
    class
        inherit ChannelCollectionBase<'T>
        interface IChannelCellCollection<'T>
        interface IChannelCollection<'T>
        interface IChannel
        interface ISupportBinaryImage
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
        interface INotifyCollectionChanged
        interface ISerializable
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
where T : IChannelCell
public ref class ChannelCellCollectionBase abstract : public ChannelCollectionBase<T>,
    IChannelCellCollection<T>, IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>,
    ICollection<T>, IEnumerable<T>, IEnumerable, INotifyCollectionChanged, ISerializable

Type Parameters

T
Specific IChannelCell type that the ChannelCellCollectionBaseT contains.

The ChannelCellCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelCellCollectionBaseT(Int32, Boolean) | Creates a new ChannelCellCollectionBaseT from specified parameters.
Protected method | ChannelCellCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelCellCollectionBaseT from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCollectionBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Overrides ChannelCollectionBaseTAttributes.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Overrides ChannelCollectionBaseTBinaryLength.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T) Constructor

Grid Solutions Framework ChannelCellCollectionBaseT Constructor
Overload List
 | Name | Description
Protected method | ChannelCellCollectionBaseT(Int32, Boolean) | Creates a new ChannelCellCollectionBaseT from specified parameters.
Protected method | ChannelCellCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelCellCollectionBaseT from serialization parameters.
Top
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T) Constructor (Int32, Boolean)

Grid Solutions Framework ChannelCellCollectionBaseT Constructor (Int32, Boolean)
Creates a new ChannelCellCollectionBaseT from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCellCollectionBase(
    int lastValidIndex,
    bool constantCellLength
)
Protected Sub New (
    lastValidIndex As Integer,
    constantCellLength As Boolean
)
new :
        lastValidIndex : int *
        constantCellLength : bool -> ChannelCellCollectionBase
GSF.PhasorProtocols.ChannelCellCollectionBase = function(lastValidIndex, constantCellLength);
protected:
ChannelCellCollectionBase(
    int lastValidIndex,
    bool constantCellLength
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
constantCellLength
Type: SystemBoolean
Sets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant.
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ChannelCellCollectionBaseT Class
ChannelCellCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T) Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelCellCollectionBaseT Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelCellCollectionBaseT from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCellCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelCellCollectionBase
GSF.PhasorProtocols.ChannelCellCollectionBase = function(info, context);
protected:
ChannelCellCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelCellCollectionBaseT Class
ChannelCellCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T) Methods

Grid Solutions Framework ChannelCellCollectionBaseT Methods

The ChannelCellCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCollectionBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T).GetObjectData Method

Grid Solutions Framework ChannelCellCollectionBaseTGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T) Properties

Grid Solutions Framework ChannelCellCollectionBaseT Properties

The ChannelCellCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Overrides ChannelCollectionBaseTAttributes.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Overrides ChannelCollectionBaseTBinaryLength.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T).Attributes Property

Grid Solutions Framework ChannelCellCollectionBaseTAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T).BinaryLength Property

Grid Solutions Framework ChannelCellCollectionBaseTBinaryLength Property
Gets the length of the ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
Remarks
The length of the ChannelCellCollectionBaseT binary image is the combined length of all the items in the collection.
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T).ConstantCellLength Property

Grid Solutions Framework ChannelCellCollectionBaseTConstantCellLength Property
Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ConstantCellLength { get; }
Public ReadOnly Property ConstantCellLength As Boolean
    Get
abstract ConstantCellLength : bool with get
override ConstantCellLength : bool with get
function get_ConstantCellLength();

public:
virtual property bool ConstantCellLength {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IChannelCellCollectionTConstantCellLength
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellCollectionBase(T) Events

Grid Solutions Framework ChannelCellCollectionBaseT Events

The ChannelCellCollectionBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelCellCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCellParsingStateBase Class

Grid Solutions Framework ChannelCellParsingStateBase Class
Represents the protocol independent common implementation of the parsing state used by any IChannelCell.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelCellParsingStateBase
GSF.PhasorProtocolsConfigurationCellParsingState
GSF.PhasorProtocolsDataCellParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ChannelCellParsingStateBase : ChannelParsingStateBase,
    IChannelCellParsingState, IChannelParsingState
Public MustInherit Class ChannelCellParsingStateBase
    Inherits ChannelParsingStateBase
    Implements IChannelCellParsingState, IChannelParsingState
[<AbstractClassAttribute>]
type ChannelCellParsingStateBase =
    class
        inherit ChannelParsingStateBase
        interface IChannelCellParsingState
        interface IChannelParsingState
    end
GSF.PhasorProtocols.ChannelCellParsingStateBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ChannelCellParsingStateBase',
    GSF.PhasorProtocols.ChannelParsingStateBase,
    GSF.PhasorProtocols.IChannelCellParsingState,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class ChannelCellParsingStateBase abstract : public ChannelParsingStateBase,
    IChannelCellParsingState, IChannelParsingState

The ChannelCellParsingStateBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelCellParsingStateBase | Initializes a new instance of the ChannelCellParsingStateBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelCellParsingStateBase Constructor

Grid Solutions Framework ChannelCellParsingStateBase Constructor
Initializes a new instance of the ChannelCellParsingStateBase class

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCellParsingStateBase()
Protected Sub New
new : unit -> ChannelCellParsingStateBase
GSF.PhasorProtocols.ChannelCellParsingStateBase = function();
protected:
ChannelCellParsingStateBase()
See Also

Reference

ChannelCellParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelCellParsingStateBase Methods

Grid Solutions Framework ChannelCellParsingStateBase Methods

The ChannelCellParsingStateBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelCellParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelCellParsingStateBase Properties

Grid Solutions Framework ChannelCellParsingStateBase Properties

The ChannelCellParsingStateBase type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed.
Top
See Also

Reference

ChannelCellParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelCellParsingStateBase.AnalogCount Property

Grid Solutions Framework ChannelCellParsingStateBaseAnalogCount Property
Gets or sets the number of analog elements associated with the IChannelCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int AnalogCount { get; set; }
Public Overridable Property AnalogCount As Integer
    Get
    Set
abstract AnalogCount : int with get, set
override AnalogCount : int with get, set
function get_AnalogCount();
function set_AnalogCount(value);
public:
virtual property int AnalogCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IChannelCellParsingStateAnalogCount
See Also

Reference

ChannelCellParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelCellParsingStateBase.DigitalCount Property

Grid Solutions Framework ChannelCellParsingStateBaseDigitalCount Property
Gets or sets the number of digital elements associated with the IChannelCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int DigitalCount { get; set; }
Public Overridable Property DigitalCount As Integer
    Get
    Set
abstract DigitalCount : int with get, set
override DigitalCount : int with get, set
function get_DigitalCount();
function set_DigitalCount(value);
public:
virtual property int DigitalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IChannelCellParsingStateDigitalCount
See Also

Reference

ChannelCellParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelCellParsingStateBase.PhasorCount Property

Grid Solutions Framework ChannelCellParsingStateBasePhasorCount Property
Gets or sets the number of phasor elements associated with the IChannelCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int PhasorCount { get; set; }
Public Overridable Property PhasorCount As Integer
    Get
    Set
abstract PhasorCount : int with get, set
override PhasorCount : int with get, set
function get_PhasorCount();
function set_PhasorCount(value);
public:
virtual property int PhasorCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IChannelCellParsingStatePhasorCount
See Also

Reference

ChannelCellParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Class

Grid Solutions Framework ChannelCollectionBaseT Class
Represents a protocol independent collection of IChannel objects.
This is the base class of all collection classes in the phasor protocols library; it is the root of the collection class hierarchy.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
GSF.CollectionsListCollection T
GSF.PhasorProtocolsChannelCollectionBaseT
GSF.PhasorProtocolsChannelCellCollectionBaseT
GSF.PhasorProtocolsChannelDefinitionCollectionBaseT
GSF.PhasorProtocolsChannelFrameCollectionBaseT
GSF.PhasorProtocolsChannelValueCollectionBaseTDefinition, TValue

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelCollectionBase<T> : ListCollection<T>,
    IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>, ICollection<T>,
    IEnumerable<T>, IEnumerable, ISerializable, INotifyCollectionChanged
where T : IChannel

<SerializableAttribute>
Public MustInherit Class ChannelCollectionBase(Of T As IChannel)
    Inherits ListCollection(Of T)
    Implements IChannelCollection(Of T), IChannel, ISupportBinaryImage,
    IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable, ISerializable, INotifyCollectionChanged
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelCollectionBase<'T when 'T : IChannel> =
    class
        inherit ListCollection<'T>
        interface IChannelCollection<'T>
        interface IChannel
        interface ISupportBinaryImage
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
        interface ISerializable
        interface INotifyCollectionChanged
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
where T : IChannel
public ref class ChannelCollectionBase abstract : public ListCollection<T>,
    IChannelCollection<T>, IChannel, ISupportBinaryImage, IList<T>, ICollection<T>,
    IEnumerable<T>, IEnumerable, ISerializable, INotifyCollectionChanged

Type Parameters

T
Specific IChannel type that the ChannelCollectionBaseT contains.

The ChannelCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelCollectionBaseT | Creates a new ChannelCollectionBaseT.
Protected method | ChannelCollectionBaseT(Int32) | Creates a new ChannelCollectionBaseT using specified lastValidIndex.
Protected method | ChannelCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelCollectionBaseT from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Overrides ListCollectionTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Overrides ListCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event.
Public method | RefreshBinding | Manually sends a Reset to the collection changed event.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Overrides ListCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ListCollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object.
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT.
Public property | State | Gets or sets the parsing state for this IChannel object.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object.
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.
Top
Remarks
This channel collection implements IChannel (inherited via IChannelCollectionT) for the benefit of providing a cumulative binary image of the entire collection.
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Constructor

Grid Solutions Framework ChannelCollectionBaseT Constructor
Overload List
 | Name | Description
Protected method | ChannelCollectionBaseT | Creates a new ChannelCollectionBaseT.
Protected method | ChannelCollectionBaseT(Int32) | Creates a new ChannelCollectionBaseT using specified lastValidIndex.
Protected method | ChannelCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelCollectionBaseT from serialization parameters.
Top
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Constructor

Grid Solutions Framework ChannelCollectionBaseT Constructor
Creates a new ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCollectionBase()
Protected Sub New
new : unit -> ChannelCollectionBase
GSF.PhasorProtocols.ChannelCollectionBase = function();
protected:
ChannelCollectionBase()
See Also

Reference

ChannelCollectionBaseT Class
ChannelCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Constructor (Int32)

Grid Solutions Framework ChannelCollectionBaseT Constructor (Int32)
Creates a new ChannelCollectionBaseT using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCollectionBase(
    int lastValidIndex
)
Protected Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> ChannelCollectionBase
GSF.PhasorProtocols.ChannelCollectionBase = function(lastValidIndex);
protected:
ChannelCollectionBase(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ChannelCollectionBaseT Class
ChannelCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelCollectionBaseT Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelCollectionBaseT from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelCollectionBase
GSF.PhasorProtocols.ChannelCollectionBase = function(info, context);
protected:
ChannelCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelCollectionBaseT Class
ChannelCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Methods

Grid Solutions Framework ChannelCollectionBaseT Methods

The ChannelCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Overrides ListCollectionTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Overrides ListCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event.
Public method | RefreshBinding | Manually sends a Reset to the collection changed event.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Overrides ListCollectionTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ListCollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).AddRange Method

Grid Solutions Framework ChannelCollectionBaseTAddRange Method
Adds the elements of the specified collection to the end of the ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void AddRange(
    IEnumerable<T> collection
)
Public Overridable Sub AddRange (
    collection As IEnumerable(Of T)
)
abstract AddRange :
        collection : IEnumerable<'T> -> unit
override AddRange :
        collection : IEnumerable<'T> -> unit
function AddRange(collection);
public:
virtual void AddRange(
    IEnumerable<T>^ collection
)

Parameters

collection
Type: System.Collections.GenericIEnumerable T
The collection whose elements should be added to the end of the ChannelCollectionBaseT. The collection itself cannot be null, but it can contain elements that are null, if type T is a reference type.
Exceptions
Exception | Condition
ArgumentNullException | collection is null.
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).ClearItems Method

Grid Solutions Framework ChannelCollectionBaseTClearItems Method
Removes all elements from the ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
abstract ClearItems : unit -> unit
override ClearItems : unit -> unit
function ClearItems();
protected:
virtual void ClearItems() override
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).GenerateBinaryImage Method

Grid Solutions Framework ChannelCollectionBaseTGenerateBinaryImage Method
Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Overridable Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).GetObjectData Method

Grid Solutions Framework ChannelCollectionBaseTGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).InsertItem Method

Grid Solutions Framework ChannelCollectionBaseTInsertItem Method
Inserts an element into the ChannelCollectionBaseT at the specified index.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)
abstract InsertItem :
        index : int *
        item : 'T -> unit
override InsertItem :
        index : int *
        item : 'T -> unit
function InsertItem(index, item);
protected:
virtual void InsertItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert.
Exceptions
Exception | Condition
OverflowException | Maximum collection item limit reached.
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).OnCollectionChanged Method

Grid Solutions Framework ChannelCollectionBaseTOnCollectionChanged Method
Raises the NotifyCollectionChangedEventHandler event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs e
)
Protected Overridable Sub OnCollectionChanged (
    e As NotifyCollectionChangedEventArgs
)
abstract OnCollectionChanged :
        e : NotifyCollectionChangedEventArgs -> unit
override OnCollectionChanged :
        e : NotifyCollectionChangedEventArgs -> unit
function OnCollectionChanged(e);
protected:
virtual void OnCollectionChanged(
    NotifyCollectionChangedEventArgs^ e
)

Parameters

e
Type: System.Collections.SpecializedNotifyCollectionChangedEventArgs
Changed event arguments.
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).RefreshBinding Method

Grid Solutions Framework ChannelCollectionBaseTRefreshBinding Method
Manually sends a Reset to the collection changed event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RefreshBinding()
Public Overridable Sub RefreshBinding
abstract RefreshBinding : unit -> unit
override RefreshBinding : unit -> unit
function RefreshBinding();
public:
virtual void RefreshBinding()
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).RemoveItem Method

Grid Solutions Framework ChannelCollectionBaseTRemoveItem Method
Removes the element at the specified index of the ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)
abstract RemoveItem :
        index : int -> unit
override RemoveItem :
        index : int -> unit
function RemoveItem(index);
protected:
virtual void RemoveItem(
    int index
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).SetItem Method

Grid Solutions Framework ChannelCollectionBaseTSetItem Method
Replaces the element at the specified index.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)
abstract SetItem :
        index : int *
        item : 'T -> unit
override SetItem :
        index : int *
        item : 'T -> unit
function SetItem(index, item);
protected:
virtual void SetItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index. The value can be null for reference types.
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Properties

Grid Solutions Framework ChannelCollectionBaseT Properties

The ChannelCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object.
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT.
Public property | State | Gets or sets the parsing state for this IChannel object.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object.
Top
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).Attributes Property

Grid Solutions Framework ChannelCollectionBaseTAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Dictionary<string, string> Attributes { get; }
Public Overridable ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).BinaryLength Property

Grid Solutions Framework ChannelCollectionBaseTBinaryLength Property
Gets the length of the ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int BinaryLength { get; }
Public Overridable ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get ();
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
Remarks
The length of the ChannelCollectionBaseT binary image is the combined length of all the items in the collection.
The default implementation assumes all IChannel items in the collection have the same length, hence the value returned is the BinaryLength of the first item in the collection times the Count.
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).MaximumCount Property

Grid Solutions Framework ChannelCollectionBaseTMaximumCount Property
Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int MaximumCount { get; set; }
Public Overridable Property MaximumCount As Integer
    Get
    Set
abstract MaximumCount : int with get, set
override MaximumCount : int with get, set
function get_MaximumCount();
function set_MaximumCount(value);
public:
virtual property int MaximumCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).State Property

Grid Solutions Framework ChannelCollectionBaseTState Property
Gets or sets the parsing state for this IChannel object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IChannelParsingState State { get; set; }
Public Overridable Property State As IChannelParsingState
    Get
    Set
abstract State : IChannelParsingState with get, set
override State : IChannelParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}

Property Value

Type: IChannelParsingState

Implements

IChannelState
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).Tag Property

Grid Solutions Framework ChannelCollectionBaseTTag Property
Gets or sets a user definable reference to an object associated with this IChannel object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Object Tag { get; set; }
Public Overridable Property Tag As Object
    Get
    Set
abstract Tag : Object with get, set
override Tag : Object with get, set
function get_Tag();
function set_Tag(value);
public:
virtual property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object

Implements

IChannelTag
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T) Events

Grid Solutions Framework ChannelCollectionBaseT Events

The ChannelCollectionBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.
Top
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelCollectionBase(T).CollectionChanged Event

Grid Solutions Framework ChannelCollectionBaseTCollectionChanged Event
Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event NotifyCollectionChangedEventHandler CollectionChanged
Public Event CollectionChanged As NotifyCollectionChangedEventHandler
abstract CollectionChanged : IEvent<NotifyCollectionChangedEventHandler,
    NotifyCollectionChangedEventArgs>
override CollectionChanged : IEvent<NotifyCollectionChangedEventHandler,
    NotifyCollectionChangedEventArgs>
function add_CollectionChanged(value);
function remove_CollectionChanged(value);
public:
virtual  event NotifyCollectionChangedEventHandler^ CollectionChanged {
    void add (NotifyCollectionChangedEventHandler^ value);
    void remove (NotifyCollectionChangedEventHandler^ value);
}

Value

Type: System.Collections.SpecializedNotifyCollectionChangedEventHandler

Implements

INotifyCollectionChangedCollectionChanged
See Also

Reference

ChannelCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase Class

Grid Solutions Framework ChannelDefinitionBase Class
Represents the common implementation of the protocol independent definition of any kind of IChannel data.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsAnalogDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelDefinitionBase : ChannelBase,
    IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
<SerializableAttribute>
Public MustInherit Class ChannelDefinitionBase
    Inherits ChannelBase
    Implements IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelDefinitionBase =
    class
        inherit ChannelBase
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.ChannelDefinitionBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ChannelDefinitionBase',
    GSF.PhasorProtocols.ChannelBase,
    GSF.PhasorProtocols.IChannelDefinition,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable,
    IEquatable`1,
    IComparable`1,
    IComparable);
[SerializableAttribute]
public ref class ChannelDefinitionBase abstract : public ChannelBase,
    IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable

The ChannelDefinitionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelDefinitionBase(IConfigurationCell) | Creates a new ChannelDefinitionBase.
Protected method | ChannelDefinitionBase(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionBase from serialization parameters.
Protected method | ChannelDefinitionBase(IConfigurationCell, String, UInt32, Double) | Creates a new ChannelDefinitionBase from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ObjectEquals(Object).)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase.
Public property | DataFormat | Gets the DataFormat of this ChannelDefinitionBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase.
Public property | Label | Gets or sets the label of this ChannelDefinitionBase.
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase.
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase.
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase.
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase.
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase.
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelDefinitionBase Constructor

Grid Solutions Framework ChannelDefinitionBase Constructor
Overload List
 | Name | Description
Protected method | ChannelDefinitionBase(IConfigurationCell) | Creates a new ChannelDefinitionBase.
Protected method | ChannelDefinitionBase(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionBase from serialization parameters.
Protected method | ChannelDefinitionBase(IConfigurationCell, String, UInt32, Double) | Creates a new ChannelDefinitionBase from specified parameters.
Top
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase Constructor (IConfigurationCell)

Grid Solutions Framework ChannelDefinitionBase Constructor (IConfigurationCell)
Creates a new ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> ChannelDefinitionBase
GSF.PhasorProtocols.ChannelDefinitionBase = function(parent);
protected:
ChannelDefinitionBase(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this ChannelDefinitionBase.
See Also

Reference

ChannelDefinitionBase Class
ChannelDefinitionBase Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelDefinitionBase Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelDefinitionBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelDefinitionBase
GSF.PhasorProtocols.ChannelDefinitionBase = function(info, context);
protected:
ChannelDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelDefinitionBase Class
ChannelDefinitionBase Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionBase Constructor (IConfigurationCell, String, UInt32, Double)

Grid Solutions Framework ChannelDefinitionBase Constructor (IConfigurationCell, String, UInt32, Double)
Creates a new ChannelDefinitionBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    double offset
)
Protected Sub New (
    parent As IConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double
)
new :
        parent : IConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float -> ChannelDefinitionBase
GSF.PhasorProtocols.ChannelDefinitionBase = function(parent, label, scale, offset);
protected:
ChannelDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this ChannelDefinitionBase.
label
Type: SystemString
The label of this ChannelDefinitionBase.
scale
Type: SystemUInt32
The integer scaling value of this ChannelDefinitionBase.
offset
Type: SystemDouble
The offset of this ChannelDefinitionBase.
See Also

Reference

ChannelDefinitionBase Class
ChannelDefinitionBase Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionBase Methods

Grid Solutions Framework ChannelDefinitionBase Methods

The ChannelDefinitionBase type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ObjectEquals(Object).)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.CompareTo Method

Grid Solutions Framework ChannelDefinitionBaseCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.
Top
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.CompareTo Method (Object)

Grid Solutions Framework ChannelDefinitionBaseCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not an IChannelDefinition.
See Also

Reference

ChannelDefinitionBase Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.CompareTo Method (IChannelDefinition)

Grid Solutions Framework ChannelDefinitionBaseCompareTo Method (IChannelDefinition)
Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    IChannelDefinition other
)
Public Function CompareTo (
    other As IChannelDefinition
) As Integer
abstract CompareTo :
        other : IChannelDefinition -> int
override CompareTo :
        other : IChannelDefinition -> int
function CompareTo(other);
public:
virtual int CompareTo(
    IChannelDefinition^ other
) sealed

Parameters

other
Type: GSF.PhasorProtocolsIChannelDefinition
A IChannelDefinition object to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

ChannelDefinitionBase Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Equals Method

Grid Solutions Framework ChannelDefinitionBaseEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ObjectEquals(Object).)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value.
Top
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Equals Method (Object)

Grid Solutions Framework ChannelDefinitionBaseEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of IChannelDefinition and equals the value of this instance; otherwise, False.
Exceptions
Exception | Condition
ArgumentException | value is not an IChannelDefinition.
See Also

Reference

ChannelDefinitionBase Class
Equals Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Equals Method (IChannelDefinition)

Grid Solutions Framework ChannelDefinitionBaseEquals Method (IChannelDefinition)
Returns a value indicating whether this instance is equal to specified IChannelDefinition value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    IChannelDefinition other
)
Public Function Equals (
    other As IChannelDefinition
) As Boolean
abstract Equals :
        other : IChannelDefinition -> bool
override Equals :
        other : IChannelDefinition -> bool
function Equals(other);
public:
virtual bool Equals(
    IChannelDefinition^ other
) sealed

Parameters

other
Type: GSF.PhasorProtocolsIChannelDefinition
A IChannelDefinition object to compare to this instance.

Return Value

Type: Boolean
True if other has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

ChannelDefinitionBase Class
Equals Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.GetHashCode Method

Grid Solutions Framework ChannelDefinitionBaseGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.GetObjectData Method

Grid Solutions Framework ChannelDefinitionBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.ParseBodyImage Method

Grid Solutions Framework ChannelDefinitionBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The base implementation assumes that all channel definitions begin with a label as this is the general case, override functionality if this is not the case.
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.ToString Method

Grid Solutions Framework ChannelDefinitionBaseToString Method
Gets the string respresentation of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
String respresentation of this ChannelDefinitionBase.
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase Properties

Grid Solutions Framework ChannelDefinitionBase Properties

The ChannelDefinitionBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase.
Public property | DataFormat | Gets the DataFormat of this ChannelDefinitionBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase.
Public property | Label | Gets or sets the label of this ChannelDefinitionBase.
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase.
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase.
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase.
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase.
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase.
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Attributes Property

Grid Solutions Framework ChannelDefinitionBaseAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.BodyImage Property

Grid Solutions Framework ChannelDefinitionBaseBodyImage Property
Gets the binary body image of the ChannelDefinitionBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.BodyLength Property

Grid Solutions Framework ChannelDefinitionBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.ConversionFactor Property

Grid Solutions Framework ChannelDefinitionBaseConversionFactor Property
Gets or sets the conversion factor of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double ConversionFactor { get; set; }
Public Overridable Property ConversionFactor As Double
    Get
    Set
abstract ConversionFactor : float with get, set
override ConversionFactor : float with get, set
function get_ConversionFactor();
function set_ConversionFactor(value);
public:
virtual property double ConversionFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IChannelDefinitionConversionFactor
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.DataFormat Property

Grid Solutions Framework ChannelDefinitionBaseDataFormat Property
Gets the DataFormat of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DataFormat DataFormat { get; }
Public MustOverride ReadOnly Property DataFormat As DataFormat
    Get
abstract DataFormat : DataFormat with get

function get_DataFormat();

public:
virtual property DataFormat DataFormat {
    DataFormat get () abstract;
}

Property Value

Type: DataFormat

Implements

IChannelDefinitionDataFormat
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Index Property

Grid Solutions Framework ChannelDefinitionBaseIndex Property
Gets or sets the index of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int Index { get; set; }
Public Overridable Property Index As Integer
    Get
    Set
abstract Index : int with get, set
override Index : int with get, set
function get_Index();
function set_Index(value);
public:
virtual property int Index {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IChannelDefinitionIndex
Remarks
Index is automatically maintained by ChannelDefinitionCollectionBaseT.
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Label Property

Grid Solutions Framework ChannelDefinitionBaseLabel Property
Gets or sets the label of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Label { get; set; }
Public Overridable Property Label As String
    Get
    Set
abstract Label : string with get, set
override Label : string with get, set
function get_Label();
function set_Label(value);
public:
virtual property String^ Label {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IChannelDefinitionLabel
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.LabelImage Property

Grid Solutions Framework ChannelDefinitionBaseLabelImage Property
Gets the binary image of the Label of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte[] LabelImage { get; }
Public Overridable ReadOnly Property LabelImage As Byte()
    Get
abstract LabelImage : byte[] with get
override LabelImage : byte[] with get
function get_LabelImage();

public:
virtual property array<unsigned char>^ LabelImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte

Implements

IChannelDefinitionLabelImage
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.MaximumLabelLength Property

Grid Solutions Framework ChannelDefinitionBaseMaximumLabelLength Property
Gets the maximum length of the Label of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int MaximumLabelLength { get; }
Public Overridable ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get ();
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.MaximumScalingValue Property

Grid Solutions Framework ChannelDefinitionBaseMaximumScalingValue Property
Gets the maximum value for the ScalingValue of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual uint MaximumScalingValue { get; }
Public Overridable ReadOnly Property MaximumScalingValue As UInteger
    Get
abstract MaximumScalingValue : uint32 with get
override MaximumScalingValue : uint32 with get
function get_MaximumScalingValue();

public:
virtual property unsigned int MaximumScalingValue {
    unsigned int get ();
}

Property Value

Type: UInt32

Implements

IChannelDefinitionMaximumScalingValue
Remarks
The base implementation accomodates maximum scaling factor of 24-bits of space.
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Offset Property

Grid Solutions Framework ChannelDefinitionBaseOffset Property
Gets or sets the offset of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Offset { get; set; }
Public Overridable Property Offset As Double
    Get
    Set
abstract Offset : float with get, set
override Offset : float with get, set
function get_Offset();
function set_Offset(value);
public:
virtual property double Offset {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IChannelDefinitionOffset
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.Parent Property

Grid Solutions Framework ChannelDefinitionBaseParent Property
Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationCell Parent { get; set; }
Public Overridable Property Parent As IConfigurationCell
    Get
    Set
abstract Parent : IConfigurationCell with get, set
override Parent : IConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property IConfigurationCell^ Parent {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}

Property Value

Type: IConfigurationCell

Implements

IChannelDefinitionParent
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.ScalePerBit Property

Grid Solutions Framework ChannelDefinitionBaseScalePerBit Property
Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double ScalePerBit { get; }
Public Overridable ReadOnly Property ScalePerBit As Double
    Get
abstract ScalePerBit : float with get
override ScalePerBit : float with get
function get_ScalePerBit();

public:
virtual property double ScalePerBit {
    double get ();
}

Property Value

Type: Double

Implements

IChannelDefinitionScalePerBit
Remarks
The base implementation assumes scale/bit of 10^-5.
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionBase.ScalingValue Property

Grid Solutions Framework ChannelDefinitionBaseScalingValue Property
Gets or sets the integer scaling value of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual uint ScalingValue { get; set; }
Public Overridable Property ScalingValue As UInteger
    Get
    Set
abstract ScalingValue : uint32 with get, set
override ScalingValue : uint32 with get, set
function get_ScalingValue();
function set_ScalingValue(value);
public:
virtual property unsigned int ScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32

Implements

IChannelDefinitionScalingValue
See Also

Reference

ChannelDefinitionBase Class
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T) Class

Grid Solutions Framework ChannelDefinitionCollectionBaseT Class
Represents a protocol independent collection of IChannelDefinition objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
GSF.CollectionsListCollection T
GSF.PhasorProtocolsChannelCollectionBase T
GSF.PhasorProtocolsChannelDefinitionCollectionBaseT
GSF.PhasorProtocolsAnalogDefinitionCollection
GSF.PhasorProtocolsDigitalDefinitionCollection
GSF.PhasorProtocolsFrequencyDefinitionCollection
GSF.PhasorProtocolsPhasorDefinitionCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelDefinitionCollectionBase<T> : ChannelCollectionBase<T>
where T : IChannelDefinition

<SerializableAttribute>
Public MustInherit Class ChannelDefinitionCollectionBase(Of T As IChannelDefinition)
    Inherits ChannelCollectionBase(Of T)
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelDefinitionCollectionBase<'T when 'T : IChannelDefinition> =
    class
        inherit ChannelCollectionBase<'T>
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
where T : IChannelDefinition
public ref class ChannelDefinitionCollectionBase abstract : public ChannelCollectionBase<T>

Type Parameters

T
Specific IChannelDefinition type that the ChannelDefinitionCollectionBaseT contains.

The ChannelDefinitionCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelDefinitionCollectionBaseT(Int32) | Creates a new ChannelDefinitionCollectionBaseT using specified lastValidIndex.
Protected method | ChannelDefinitionCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionCollectionBaseT from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Overrides ChannelCollectionBaseTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Overrides ChannelCollectionBaseTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ChannelCollectionBaseTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T) Constructor

Grid Solutions Framework ChannelDefinitionCollectionBaseT Constructor
Overload List
 | Name | Description
Protected method | ChannelDefinitionCollectionBaseT(Int32) | Creates a new ChannelDefinitionCollectionBaseT using specified lastValidIndex.
Protected method | ChannelDefinitionCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelDefinitionCollectionBaseT from serialization parameters.
Top
See Also

Reference

ChannelDefinitionCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T) Constructor (Int32)

Grid Solutions Framework ChannelDefinitionCollectionBaseT Constructor (Int32)
Creates a new ChannelDefinitionCollectionBaseT using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelDefinitionCollectionBase(
    int lastValidIndex
)
Protected Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> ChannelDefinitionCollectionBase
GSF.PhasorProtocols.ChannelDefinitionCollectionBase = function(lastValidIndex);
protected:
ChannelDefinitionCollectionBase(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ChannelDefinitionCollectionBaseT Class
ChannelDefinitionCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T) Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelDefinitionCollectionBaseT Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelDefinitionCollectionBaseT from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelDefinitionCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelDefinitionCollectionBase
GSF.PhasorProtocols.ChannelDefinitionCollectionBase = function(info, context);
protected:
ChannelDefinitionCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelDefinitionCollectionBaseT Class
ChannelDefinitionCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T) Methods

Grid Solutions Framework ChannelDefinitionCollectionBaseT Methods

The ChannelDefinitionCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Overrides ChannelCollectionBaseTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Overrides ChannelCollectionBaseTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ChannelCollectionBaseTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelDefinitionCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T).InsertItem Method

Grid Solutions Framework ChannelDefinitionCollectionBaseTInsertItem Method
Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)
abstract InsertItem :
        index : int *
        item : 'T -> unit
override InsertItem :
        index : int *
        item : 'T -> unit
function InsertItem(index, item);
protected:
virtual void InsertItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The object to insert.
See Also

Reference

ChannelDefinitionCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T).RemoveItem Method

Grid Solutions Framework ChannelDefinitionCollectionBaseTRemoveItem Method
Removes the element at the specified index of the ChannelDefinitionCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)
abstract RemoveItem :
        index : int -> unit
override RemoveItem :
        index : int -> unit
function RemoveItem(index);
protected:
virtual void RemoveItem(
    int index
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
See Also

Reference

ChannelDefinitionCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T).SetItem Method

Grid Solutions Framework ChannelDefinitionCollectionBaseTSetItem Method
Replaces the element at the specified index.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)
abstract SetItem :
        index : int *
        item : 'T -> unit
override SetItem :
        index : int *
        item : 'T -> unit
function SetItem(index, item);
protected:
virtual void SetItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: T
The new value for the element at the specified index. The value can be null for reference types.
See Also

Reference

ChannelDefinitionCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T) Properties

Grid Solutions Framework ChannelDefinitionCollectionBaseT Properties

The ChannelDefinitionCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelDefinitionCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelDefinitionCollectionBase(T) Events

Grid Solutions Framework ChannelDefinitionCollectionBaseT Events

The ChannelDefinitionCollectionBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelDefinitionCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T) Class

Grid Solutions Framework ChannelFrameBaseT Class
Represents the protocol independent common implementation of any frame of data that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBaseT
GSF.PhasorProtocolsCommandFrameBase
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocolsHeaderFrameBase

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelFrameBase<T> : ChannelBase,
    IChannelFrame<T>, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
where T : IChannelCell

<SerializableAttribute>
Public MustInherit Class ChannelFrameBase(Of T As IChannelCell)
    Inherits ChannelBase
    Implements IChannelFrame(Of T), IChannelFrame, IChannel,
    ISupportBinaryImage, IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),
    IComparable, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelFrameBase<'T when 'T : IChannelCell> =
    class
        inherit ChannelBase
        interface IChannelFrame<'T>
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
where T : IChannelCell
public ref class ChannelFrameBase abstract : public ChannelBase,
    IChannelFrame<T>, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable

Type Parameters

T
Specific IChannelCell type that the ChannelFrameBaseT contains.

The ChannelFrameBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelFrameBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelFrameBaseT from serialization parameters.
Protected method | ChannelFrameBaseT(UInt16, IChannelCellCollectionT, Ticks) | Creates a new ChannelFrameBaseT from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex.
Protected method | CalculateChecksum | Calculates checksum of given buffer.
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid.
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object.
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Overrides ObjectEquals(Object).)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides BinaryImageBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately.
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Overrides ChannelBaseBinaryImage.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Overrides BinaryImageBaseBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this ChannelFrameBaseT.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ChannelFrameBaseT.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT.
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any.
Public property | Published | Gets or sets published state of this ChannelFrameBaseT.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT.
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT.
Public property | State | Gets or sets the parsing state for the this ChannelFrameBaseT.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT.
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true.
Top
Remarks

This phasor protocol implementation defines a "frame" as a collection of cells (logical units of data). For example, a DataCellBase could be defined as a PMU within a frame of data, a DataFrameBase (derived from ChannelFrameBaseT), that contains multiple PMU's coming from a PDC.

This class implements the IFrame interface so it can be cooperatively integrated into measurement concentration. For more information see the ConcentratorBase class.

See Also

Reference

GSF.PhasorProtocols Namespace


ChannelFrameBase(T) Constructor

Grid Solutions Framework ChannelFrameBaseT Constructor
Overload List
 | Name | Description
Protected method | ChannelFrameBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelFrameBaseT from serialization parameters.
Protected method | ChannelFrameBaseT(UInt16, IChannelCellCollectionT, Ticks) | Creates a new ChannelFrameBaseT from specified parameters.
Top
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T) Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelFrameBaseT Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelFrameBaseT from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelFrameBase
GSF.PhasorProtocols.ChannelFrameBase = function(info, context);
protected:
ChannelFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelFrameBaseT Class
ChannelFrameBaseT Overload
GSF.PhasorProtocols Namespace


ChannelFrameBase(T) Constructor (UInt16, IChannelCellCollection(T), Ticks)

Grid Solutions Framework ChannelFrameBaseT Constructor (UInt16, IChannelCellCollectionT, Ticks)
Creates a new ChannelFrameBaseT from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelFrameBase(
    ushort idCode,
    IChannelCellCollection<T> cells,
    Ticks timestamp
)
Protected Sub New (
    idCode As UShort,
    cells As IChannelCellCollection(Of T),
    timestamp As Ticks
)
new :
        idCode : uint16 *
        cells : IChannelCellCollection<'T> *
        timestamp : Ticks -> ChannelFrameBase
GSF.PhasorProtocols.ChannelFrameBase = function(idCode, cells, timestamp);
protected:
ChannelFrameBase(
    unsigned short idCode,
    IChannelCellCollection<T>^ cells,
    Ticks timestamp
)

Parameters

idCode
Type: SystemUInt16
The ID code of this ChannelFrameBaseT.
cells
Type: GSF.PhasorProtocolsIChannelCellCollection T
The reference to the collection of cells for this ChannelFrameBaseT.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ChannelFrameBaseT.
See Also

Reference

ChannelFrameBaseT Class
ChannelFrameBaseT Overload
GSF.PhasorProtocols Namespace


ChannelFrameBase(T) Methods

Grid Solutions Framework ChannelFrameBaseT Methods

The ChannelFrameBaseT generic type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex.
Protected method | CalculateChecksum | Calculates checksum of given buffer.
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid.
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object.
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Overrides ObjectEquals(Object).)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides BinaryImageBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).AppendChecksum Method

Grid Solutions Framework ChannelFrameBaseTAppendChecksum Method
Appends checksum onto buffer starting at startIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overridable Sub AppendChecksum (
    buffer As Byte(),
    startIndex As Integer
)
abstract AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
override AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
function AppendChecksum(buffer, startIndex);
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer image on which to append checksum.
startIndex
Type: SystemInt32
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accommodate 2-byte checksum representation. Override method if protocol expectations are different.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).CalculateChecksum Method

Grid Solutions Framework ChannelFrameBaseTCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected MustOverride Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16

function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) abstract

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
Remarks
Override with needed checksum calculation for particular protocol.
Examples
This example provides a CRC-CCITT checksum:
Copy
using GSF.IO.Checksums;

protected override ushort CalculateChecksum(byte[] buffer, int offset, int length)
{
    // Return calculated CRC-CCITT over given buffer...
    return buffer.CrcCCITTChecksum(offset, length);
}
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).ChecksumIsValid Method

Grid Solutions Framework ChannelFrameBaseTChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overridable Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. Override method if protocol checksum implementation is different.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).CompareTo Method

Grid Solutions Framework ChannelFrameBaseTCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object.
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame.
Top
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).CompareTo Method (Object)

Grid Solutions Framework ChannelFrameBaseTCompareTo Method (Object)
Compares the ChannelFrameBaseT with the specified Object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
The Object to compare with the current ChannelFrameBaseT.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | Object is not an IFrame.
Remarks
This frame implementation compares itself by timestamp.
See Also

Reference

ChannelFrameBaseT Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).CompareTo Method (IFrame)

Grid Solutions Framework ChannelFrameBaseTCompareTo Method (IFrame)
Compares the ChannelFrameBaseT with an IFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    IFrame other
)
Public Overridable Function CompareTo (
    other As IFrame
) As Integer
abstract CompareTo :
        other : IFrame -> int
override CompareTo :
        other : IFrame -> int
function CompareTo(other);
public:
virtual int CompareTo(
    IFrame^ other
)

Parameters

other
Type: GSF.TimeSeriesIFrame
The IFrame to compare with the current ChannelFrameBaseT.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
Remarks
This frame implementation compares itself by timestamp.
See Also

Reference

ChannelFrameBaseT Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Equals Method

Grid Solutions Framework ChannelFrameBaseTEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Overrides ObjectEquals(Object).)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT.
Top
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Equals Method (Object)

Grid Solutions Framework ChannelFrameBaseTEquals Method (Object)
Determines whether the specified Object is equal to the current ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The Object to compare with the current ChannelFrameBaseT.

Return Value

Type: Boolean
true if the specified Object is equal to the current ChannelFrameBaseT; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | Object is not an IFrame.
See Also

Reference

ChannelFrameBaseT Class
Equals Overload
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Equals Method (IFrame)

Grid Solutions Framework ChannelFrameBaseTEquals Method (IFrame)
Determines whether the specified IFrame is equal to the current ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Equals(
    IFrame other
)
Public Overridable Function Equals (
    other As IFrame
) As Boolean
abstract Equals :
        other : IFrame -> bool
override Equals :
        other : IFrame -> bool
function Equals(other);
public:
virtual bool Equals(
    IFrame^ other
)

Parameters

other
Type: GSF.TimeSeriesIFrame
The IFrame to compare with the current ChannelFrameBaseT.

Return Value

Type: Boolean
true if the specified IFrame is equal to the current ChannelFrameBaseT; otherwise, false.

Implements

IEquatableTEquals(T)
Remarks
This frame implementation compares itself by timestamp.
See Also

Reference

ChannelFrameBaseT Class
Equals Overload
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).GetHashCode Method

Grid Solutions Framework ChannelFrameBaseTGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).GetObjectData Method

Grid Solutions Framework ChannelFrameBaseTGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).ParseBinaryImage Method

Grid Solutions Framework ChannelFrameBaseTParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | Invalid binary image detected - check sum did not match.
Remarks
This method is overridden to validate the checksum in the ChannelFrameBaseT.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).ParseBodyImage Method

Grid Solutions Framework ChannelFrameBaseTParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The body image of the ChannelFrameBaseT is parsed to create a collection of Cells.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T) Properties

Grid Solutions Framework ChannelFrameBaseT Properties

The ChannelFrameBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately.
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Overrides ChannelBaseBinaryImage.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Overrides BinaryImageBaseBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this ChannelFrameBaseT.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ChannelFrameBaseT.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT.
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any.
Public property | Published | Gets or sets published state of this ChannelFrameBaseT.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT.
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT.
Public property | State | Gets or sets the parsing state for the this ChannelFrameBaseT.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT.
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true.
Top
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).AllowQueuedPublication Property

Grid Solutions Framework ChannelFrameBaseTAllowQueuedPublication Property
Gets flag that determines if frame image can be queued for publication or should be processed immediately.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool AllowQueuedPublication { get; }
Public Overridable ReadOnly Property AllowQueuedPublication As Boolean
    Get
abstract AllowQueuedPublication : bool with get
override AllowQueuedPublication : bool with get
function get_AllowQueuedPublication();

public:
virtual property bool AllowQueuedPublication {
    bool get ();
}

Property Value

Type: Boolean
Remarks
Some frames, e.g., a configuration or key frame, may be critical to processing of other frames. In this case, these types of frames should be published immediately so that subsequent frame parsing can have access to needed critical information. All other frames are assumed to be queued by default.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Attributes Property

Grid Solutions Framework ChannelFrameBaseTAttributes Property
DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).BinaryImage Property

Grid Solutions Framework ChannelFrameBaseTBinaryImage Property
Gets the binary image of this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] BinaryImage { get; }
Public Overrides ReadOnly Property BinaryImage As Byte()
    Get
abstract BinaryImage : byte[] with get
override BinaryImage : byte[] with get
function get_BinaryImage();

public:
virtual property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
This property is overridden to include a checksum in the image.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).BinaryLength Property

Grid Solutions Framework ChannelFrameBaseTBinaryLength Property
Gets the length of the BinaryImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
Remarks
This property is overridden so the length can be extended to include a checksum.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).BodyImage Property

Grid Solutions Framework ChannelFrameBaseTBodyImage Property
Gets the binary body image of this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
The body image of the ChannelFrameBaseT is the combined images of all the Cells.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).BodyLength Property

Grid Solutions Framework ChannelFrameBaseTBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
The length of the ChannelFrameBaseT body image is the combined length of all the Cells.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Cells Property

Grid Solutions Framework ChannelFrameBaseTCells Property
Gets the strongly-typed reference to the collection of cells for this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IChannelCellCollection<T> Cells { get; }
Public Overridable ReadOnly Property Cells As IChannelCellCollection(Of T)
    Get
abstract Cells : IChannelCellCollection<'T> with get
override Cells : IChannelCellCollection<'T> with get
function get_Cells();

public:
virtual property IChannelCellCollection<T>^ Cells {
    IChannelCellCollection<T>^ get ();
}

Property Value

Type: IChannelCellCollection T

Implements

IChannelFrameTCells
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).FrameType Property

Grid Solutions Framework ChannelFrameBaseTFrameType Property
Gets the FundamentalFrameType for this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract FundamentalFrameType FrameType { get; }
Public MustOverride ReadOnly Property FrameType As FundamentalFrameType
    Get
abstract FrameType : FundamentalFrameType with get

function get_FrameType();

public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () abstract;
}

Property Value

Type: FundamentalFrameType

Implements

IChannelFrameFrameType
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).IDCode Property

Grid Solutions Framework ChannelFrameBaseTIDCode Property
Gets or sets the ID code of this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ushort IDCode { get; set; }
Public Overridable Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16

Implements

IChannelFrameIDCode
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).LastSortedMeasurement Property

Grid Solutions Framework ChannelFrameBaseTLastSortedMeasurement Property
Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IMeasurement LastSortedMeasurement { get; set; }
Public Property LastSortedMeasurement As IMeasurement
    Get
    Set
abstract LastSortedMeasurement : IMeasurement with get, set
override LastSortedMeasurement : IMeasurement with get, set
function get_LastSortedMeasurement();
function set_LastSortedMeasurement(value);
public:
virtual property IMeasurement^ LastSortedMeasurement {
    IMeasurement^ get () sealed;
    void set (IMeasurement^ value) sealed;
}

Property Value

Type: IMeasurement

Implements

IFrameLastSortedMeasurement
Remarks
This value is used to help monitor slow moving measurements that are being sorted into the ChannelFrameBaseT.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Measurements Property

Grid Solutions Framework ChannelFrameBaseTMeasurements Property
Keyed measurements in this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConcurrentDictionary<MeasurementKey, IMeasurement> Measurements { get; }
Public ReadOnly Property Measurements As ConcurrentDictionary(Of MeasurementKey, IMeasurement)
    Get
abstract Measurements : ConcurrentDictionary<MeasurementKey, IMeasurement> with get
override Measurements : ConcurrentDictionary<MeasurementKey, IMeasurement> with get
function get_Measurements();

public:
virtual property ConcurrentDictionary<MeasurementKey^, IMeasurement^>^ Measurements {
    ConcurrentDictionary<MeasurementKey^, IMeasurement^>^ get () sealed;
}

Property Value

Type: ConcurrentDictionary MeasurementKey, IMeasurement

Implements

IFrameMeasurements
Remarks
Represents a dictionary of measurements, keyed by MeasurementKey.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).ParsedBinaryLength Property

Grid Solutions Framework ChannelFrameBaseTParsedBinaryLength Property
Gets the parsed binary length derived from the parsing state, if any.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected int ParsedBinaryLength { get; }
Protected ReadOnly Property ParsedBinaryLength As Integer
    Get
member ParsedBinaryLength : int with get

function get_ParsedBinaryLength();

protected:
property int ParsedBinaryLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Published Property

Grid Solutions Framework ChannelFrameBaseTPublished Property
Gets or sets published state of this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Published { get; set; }
Public Property Published As Boolean
    Get
    Set
abstract Published : bool with get, set
override Published : bool with get, set
function get_Published();
function set_Published(value);
public:
virtual property bool Published {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IFramePublished
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).PublishedTimestamp Property

Grid Solutions Framework ChannelFrameBaseTPublishedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing).

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks PublishedTimestamp { get; set; }
Public Overridable Property PublishedTimestamp As Ticks
    Get
    Set
abstract PublishedTimestamp : Ticks with get, set
override PublishedTimestamp : Ticks with get, set
function get_PublishedTimestamp();
function set_PublishedTimestamp(value);
public:
virtual property Ticks PublishedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

IFramePublishedTimestamp
Remarks

In the default implementation, setting this property will update all associated PublishedTimestamp.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).ReceivedTimestamp Property

Grid Solutions Framework ChannelFrameBaseTReceivedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created).

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks ReceivedTimestamp { get; set; }
Public Overridable Property ReceivedTimestamp As Ticks
    Get
    Set
abstract ReceivedTimestamp : Ticks with get, set
override ReceivedTimestamp : Ticks with get, set
function get_ReceivedTimestamp();
function set_ReceivedTimestamp(value);
public:
virtual property Ticks ReceivedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

IFrameReceivedTimestamp
Remarks

In the default implementation, this timestamp will simply be the ticks of UtcNow of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).SortedMeasurements Property

Grid Solutions Framework ChannelFrameBaseTSortedMeasurements Property
Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SortedMeasurements { get; set; }
Public Property SortedMeasurements As Integer
    Get
    Set
abstract SortedMeasurements : int with get, set
override SortedMeasurements : int with get, set
function get_SortedMeasurements();
function set_SortedMeasurements(value);
public:
virtual property int SortedMeasurements {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IFrameSortedMeasurements
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Source Property

Grid Solutions Framework ChannelFrameBaseTSource Property
Gets or sets the data source identifier for this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual SourceChannel Source { get; set; }
Public Overridable Property Source As SourceChannel
    Get
    Set
abstract Source : SourceChannel with get, set
override Source : SourceChannel with get, set
function get_Source();
function set_Source(value);
public:
virtual property SourceChannel Source {
    SourceChannel get ();
    void set (SourceChannel value);
}

Property Value

Type: SourceChannel
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).State Property

Grid Solutions Framework ChannelFrameBaseTState Property
Gets or sets the parsing state for the this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IChannelFrameParsingState<T> State { get; set; }
Public Overridable Property State As IChannelFrameParsingState(Of T)
    Get
    Set
abstract State : IChannelFrameParsingState<'T> with get, set
override State : IChannelFrameParsingState<'T> with get, set
function get_State();
function set_State(value);
public:
virtual property IChannelFrameParsingState<T>^ State {
    IChannelFrameParsingState<T>^ get ();
    void set (IChannelFrameParsingState<T>^ value);
}

Property Value

Type: IChannelFrameParsingState T

Implements

IChannelFrameTState
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).Timestamp Property

Grid Solutions Framework ChannelFrameBaseTTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks Timestamp { get; set; }
Public Overridable Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).TimeTag Property

Grid Solutions Framework ChannelFrameBaseTTimeTag Property
Gets UNIX based time representation of the ticks of this ChannelFrameBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual UnixTimeTag TimeTag { get; }
Public Overridable ReadOnly Property TimeTag As UnixTimeTag
    Get
abstract TimeTag : UnixTimeTag with get
override TimeTag : UnixTimeTag with get
function get_TimeTag();

public:
virtual property UnixTimeTag^ TimeTag {
    UnixTimeTag^ get ();
}

Property Value

Type: UnixTimeTag

Implements

IChannelFrameTimeTag
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).TrustHeaderLength Property

Grid Solutions Framework ChannelFrameBaseTTrustHeaderLength Property
Gets or sets flag that determines if header lengths should be trusted over parsed byte count.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TrustHeaderLength { get; set; }
Public Overridable Property TrustHeaderLength As Boolean
    Get
    Set
abstract TrustHeaderLength : bool with get, set
override TrustHeaderLength : bool with get, set
function get_TrustHeaderLength();
function set_TrustHeaderLength(value);
public:
virtual property bool TrustHeaderLength {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameBase(T).ValidateCheckSum Property

Grid Solutions Framework ChannelFrameBaseTValidateCheckSum Property
Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool ValidateCheckSum { get; set; }
Public Overridable Property ValidateCheckSum As Boolean
    Get
    Set
abstract ValidateCheckSum : bool with get, set
override ValidateCheckSum : bool with get, set
function get_ValidateCheckSum();
function set_ValidateCheckSum(value);
public:
virtual property bool ValidateCheckSum {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ChannelFrameBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T) Class

Grid Solutions Framework ChannelFrameCollectionBaseT Class
Represents a protocol independent collection of IChannelFrame objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
GSF.CollectionsListCollection T
GSF.PhasorProtocolsChannelCollectionBase T
GSF.PhasorProtocolsChannelFrameCollectionBaseT
GSF.PhasorProtocolsConfigurationFrameCollection
GSF.PhasorProtocolsDataFrameCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelFrameCollectionBase<T> : ChannelCollectionBase<T>
where T : IChannelFrame

<SerializableAttribute>
Public MustInherit Class ChannelFrameCollectionBase(Of T As IChannelFrame)
    Inherits ChannelCollectionBase(Of T)
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelFrameCollectionBase<'T when 'T : IChannelFrame> =
    class
        inherit ChannelCollectionBase<'T>
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
where T : IChannelFrame
public ref class ChannelFrameCollectionBase abstract : public ChannelCollectionBase<T>

Type Parameters

T
Specific IChannelFrame type that the ChannelFrameCollectionBaseT contains.

The ChannelFrameCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelFrameCollectionBaseT(Int32) | Creates a new ChannelFrameCollectionBaseT using specified lastValidIndex.
Protected method | ChannelFrameCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelFrameCollectionBaseT from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Overrides ChannelCollectionBaseTBinaryLength.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T) Constructor

Grid Solutions Framework ChannelFrameCollectionBaseT Constructor
Overload List
 | Name | Description
Protected method | ChannelFrameCollectionBaseT(Int32) | Creates a new ChannelFrameCollectionBaseT using specified lastValidIndex.
Protected method | ChannelFrameCollectionBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelFrameCollectionBaseT from serialization parameters.
Top
See Also

Reference

ChannelFrameCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T) Constructor (Int32)

Grid Solutions Framework ChannelFrameCollectionBaseT Constructor (Int32)
Creates a new ChannelFrameCollectionBaseT using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelFrameCollectionBase(
    int lastValidIndex
)
Protected Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> ChannelFrameCollectionBase
GSF.PhasorProtocols.ChannelFrameCollectionBase = function(lastValidIndex);
protected:
ChannelFrameCollectionBase(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ChannelFrameCollectionBaseT Class
ChannelFrameCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T) Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelFrameCollectionBaseT Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelFrameCollectionBaseT from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelFrameCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelFrameCollectionBase
GSF.PhasorProtocols.ChannelFrameCollectionBase = function(info, context);
protected:
ChannelFrameCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelFrameCollectionBaseT Class
ChannelFrameCollectionBaseT Overload
GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T) Methods

Grid Solutions Framework ChannelFrameCollectionBaseT Methods

The ChannelFrameCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelFrameCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T) Properties

Grid Solutions Framework ChannelFrameCollectionBaseT Properties

The ChannelFrameCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Overrides ChannelCollectionBaseTBinaryLength.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelFrameCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T).BinaryLength Property

Grid Solutions Framework ChannelFrameCollectionBaseTBinaryLength Property
Gets the length of the ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
Remarks
The length of the ChannelFrameCollectionBaseT binary image is the combined length of all the items in the collection.
See Also

Reference

ChannelFrameCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameCollectionBase(T) Events

Grid Solutions Framework ChannelFrameCollectionBaseT Events

The ChannelFrameCollectionBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelFrameCollectionBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T) Class

Grid Solutions Framework ChannelFrameParsingStateBaseT Class
Represents the protocol independent common implementation of the parsing state used by any IChannelFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBaseT
GSF.PhasorProtocolsCommandFrameParsingState
GSF.PhasorProtocolsConfigurationFrameParsingState
GSF.PhasorProtocolsDataFrameParsingState
GSF.PhasorProtocolsHeaderFrameParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ChannelFrameParsingStateBase<T> : ChannelParsingStateBase,
    IChannelFrameParsingState<T>, IChannelParsingState
where T : IChannelCell

Public MustInherit Class ChannelFrameParsingStateBase(Of T As IChannelCell)
    Inherits ChannelParsingStateBase
    Implements IChannelFrameParsingState(Of T), IChannelParsingState
[<AbstractClassAttribute>]
type ChannelFrameParsingStateBase<'T when 'T : IChannelCell> =
    class
        inherit ChannelParsingStateBase
        interface IChannelFrameParsingState<'T>
        interface IChannelParsingState
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : IChannelCell
public ref class ChannelFrameParsingStateBase abstract : public ChannelParsingStateBase,
    IChannelFrameParsingState<T>, IChannelParsingState

Type Parameters

T
Type of IChannelCell referenced by IChannelFrame being parsed.

The ChannelFrameParsingStateBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelFrameParsingStateBaseT | Creates a new ChannelFrameParsingStateBaseT from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T) Constructor

Grid Solutions Framework ChannelFrameParsingStateBaseT Constructor
Creates a new ChannelFrameParsingStateBaseT from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelFrameParsingStateBase(
    int parsedBinaryLength,
    CreateNewCellFunction<T> createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)
Protected Sub New (
    parsedBinaryLength As Integer,
    createNewCellFunction As CreateNewCellFunction(Of T),
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        createNewCellFunction : CreateNewCellFunction<'T> *
        trustHeaderLength : bool *
        validateCheckSum : bool -> ChannelFrameParsingStateBase
GSF.PhasorProtocols.ChannelFrameParsingStateBase = function(parsedBinaryLength, createNewCellFunction, trustHeaderLength, validateCheckSum);
protected:
ChannelFrameParsingStateBase(
    int parsedBinaryLength,
    CreateNewCellFunction<T>^ createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the IChannelFrame being parsed.
createNewCellFunction
Type: GSF.PhasorProtocolsCreateNewCellFunction T
Reference to delegate to create new IChannelCell instances.
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

ChannelFrameParsingStateBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T) Methods

Grid Solutions Framework ChannelFrameParsingStateBaseT Methods

The ChannelFrameParsingStateBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelFrameParsingStateBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T) Properties

Grid Solutions Framework ChannelFrameParsingStateBaseT Properties

The ChannelFrameParsingStateBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated.
Top
See Also

Reference

ChannelFrameParsingStateBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T).CellCount Property

Grid Solutions Framework ChannelFrameParsingStateBaseTCellCount Property
Gets or sets number of cells that are expected in associated IChannelFrame being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CellCount { get; set; }
Public Overridable Property CellCount As Integer
    Get
    Set
abstract CellCount : int with get, set
override CellCount : int with get, set
function get_CellCount();
function set_CellCount(value);
public:
virtual property int CellCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IChannelFrameParsingStateTCellCount
See Also

Reference

ChannelFrameParsingStateBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T).CreateNewCell Property

Grid Solutions Framework ChannelFrameParsingStateBaseTCreateNewCell Property
Gets reference to delegate used to create a new IChannelCell object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewCellFunction<T> CreateNewCell { get; }
Public Overridable ReadOnly Property CreateNewCell As CreateNewCellFunction(Of T)
    Get
abstract CreateNewCell : CreateNewCellFunction<'T> with get
override CreateNewCell : CreateNewCellFunction<'T> with get
function get_CreateNewCell();

public:
virtual property CreateNewCellFunction<T>^ CreateNewCell {
    CreateNewCellFunction<T>^ get ();
}

Property Value

Type: CreateNewCellFunction T

Implements

IChannelFrameParsingStateTCreateNewCell
See Also

Reference

ChannelFrameParsingStateBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T).TrustHeaderLength Property

Grid Solutions Framework ChannelFrameParsingStateBaseTTrustHeaderLength Property
Gets or sets flag that determines if header lengths should be trusted over parsed byte count.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TrustHeaderLength { get; set; }
Public Overridable Property TrustHeaderLength As Boolean
    Get
    Set
abstract TrustHeaderLength : bool with get, set
override TrustHeaderLength : bool with get, set
function get_TrustHeaderLength();
function set_TrustHeaderLength(value);
public:
virtual property bool TrustHeaderLength {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IChannelFrameParsingStateTTrustHeaderLength
Remarks
It is expected that this will normally be left as true.
See Also

Reference

ChannelFrameParsingStateBaseT Class
GSF.PhasorProtocols Namespace


ChannelFrameParsingStateBase(T).ValidateCheckSum Property

Grid Solutions Framework ChannelFrameParsingStateBaseTValidateCheckSum Property
Gets or sets flag that determines if frame's check-sum should be validated.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool ValidateCheckSum { get; set; }
Public Overridable Property ValidateCheckSum As Boolean
    Get
    Set
abstract ValidateCheckSum : bool with get, set
override ValidateCheckSum : bool with get, set
function get_ValidateCheckSum();
function set_ValidateCheckSum(value);
public:
virtual property bool ValidateCheckSum {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IChannelFrameParsingStateTValidateCheckSum
Remarks
It is expected that this will normally be left as true.
See Also

Reference

ChannelFrameParsingStateBaseT Class
GSF.PhasorProtocols Namespace


ChannelParsingStateBase Class

Grid Solutions Framework ChannelParsingStateBase Class
Represents the common implementation of the protocol independent parsing state class used by any kind of data.
This is the base class of all parsing state classes in the phasor protocols library; it is the root of the parsing state class hierarchy.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelCellParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBaseT

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ChannelParsingStateBase : IChannelParsingState
Public MustInherit Class ChannelParsingStateBase
    Implements IChannelParsingState
[<AbstractClassAttribute>]
type ChannelParsingStateBase =
    class
        interface IChannelParsingState
    end
GSF.PhasorProtocols.ChannelParsingStateBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ChannelParsingStateBase',
    null,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class ChannelParsingStateBase abstract : IChannelParsingState

The ChannelParsingStateBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelParsingStateBase | Initializes a new instance of the ChannelParsingStateBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image.
Top
Remarks
This class is inherited by subsequent classes to provide parsing state information particular to data type needs.
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelParsingStateBase Constructor

Grid Solutions Framework ChannelParsingStateBase Constructor
Initializes a new instance of the ChannelParsingStateBase class

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelParsingStateBase()
Protected Sub New
new : unit -> ChannelParsingStateBase
GSF.PhasorProtocols.ChannelParsingStateBase = function();
protected:
ChannelParsingStateBase()
See Also

Reference

ChannelParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelParsingStateBase Methods

Grid Solutions Framework ChannelParsingStateBase Methods

The ChannelParsingStateBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelParsingStateBase Properties

Grid Solutions Framework ChannelParsingStateBase Properties

The ChannelParsingStateBase type exposes the following members.

Properties
 | Name | Description
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image.
Top
See Also

Reference

ChannelParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelParsingStateBase.ParsedBinaryLength Property

Grid Solutions Framework ChannelParsingStateBaseParsedBinaryLength Property
Gets or sets the length of the associated IChannel object being parsed from the binary image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ParsedBinaryLength { get; set; }
Public Overridable Property ParsedBinaryLength As Integer
    Get
    Set
abstract ParsedBinaryLength : int with get, set
override ParsedBinaryLength : int with get, set
function get_ParsedBinaryLength();
function set_ParsedBinaryLength(value);
public:
virtual property int ParsedBinaryLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IChannelParsingStateParsedBinaryLength
See Also

Reference

ChannelParsingStateBase Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T) Class

Grid Solutions Framework ChannelValueBaseT Class
Represents the common implementation of the protocol independent representation of any kind of data value.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBaseT
GSF.PhasorProtocolsAnalogValueBase
GSF.PhasorProtocolsDigitalValueBase
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocolsPhasorValueBase

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelValueBase<T> : ChannelBase,
    IChannelValue<T>, IChannel, ISupportBinaryImage, ISerializable
where T : IChannelDefinition

<SerializableAttribute>
Public MustInherit Class ChannelValueBase(Of T As IChannelDefinition)
    Inherits ChannelBase
    Implements IChannelValue(Of T), IChannel, ISupportBinaryImage,
    ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelValueBase<'T when 'T : IChannelDefinition> =
    class
        inherit ChannelBase
        interface IChannelValue<'T>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
where T : IChannelDefinition
public ref class ChannelValueBase abstract : public ChannelBase,
    IChannelValue<T>, IChannel, ISupportBinaryImage, ISerializable

Type Parameters

T
Generic type.

The ChannelValueBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelValueBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelValueBaseT from serialization parameters.
Protected method | ChannelValueBaseT(IDataCell, T) | Creates a new ChannelValueBaseT from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this ChannelValueBaseT.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from BinaryImageBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelValueBaseT object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | CompositeValueCount | Gets total number of composite values that this ChannelValueBaseT provides.
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT.
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of ChannelValueBaseT have been assigned a value.
Public property | Label | Gets text based label of this ChannelValueBaseT.
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values.
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelValueBase(T) Constructor

Grid Solutions Framework ChannelValueBaseT Constructor
Overload List
 | Name | Description
Protected method | ChannelValueBaseT(SerializationInfo, StreamingContext) | Creates a new ChannelValueBaseT from serialization parameters.
Protected method | ChannelValueBaseT(IDataCell, T) | Creates a new ChannelValueBaseT from specified parameters.
Top
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T) Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelValueBaseT Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelValueBaseT from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelValueBase
GSF.PhasorProtocols.ChannelValueBase = function(info, context);
protected:
ChannelValueBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelValueBaseT Class
ChannelValueBaseT Overload
GSF.PhasorProtocols Namespace


ChannelValueBase(T) Constructor (IDataCell, T)

Grid Solutions Framework ChannelValueBaseT Constructor (IDataCell, T)
Creates a new ChannelValueBaseT from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelValueBase(
    IDataCell parent,
    T channelDefinition
)
Protected Sub New (
    parent As IDataCell,
    channelDefinition As T
)
new :
        parent : IDataCell *
        channelDefinition : 'T -> ChannelValueBase
GSF.PhasorProtocols.ChannelValueBase = function(parent, channelDefinition);
protected:
ChannelValueBase(
    IDataCell^ parent,
    T channelDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this ChannelValueBaseT.
channelDefinition
Type: T
The IChannelDefinition associated with this ChannelValueBaseT.
See Also

Reference

ChannelValueBaseT Class
ChannelValueBaseT Overload
GSF.PhasorProtocols Namespace


ChannelValueBase(T) Methods

Grid Solutions Framework ChannelValueBaseT Methods

The ChannelValueBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this ChannelValueBaseT.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from BinaryImageBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).GetCompositeValue Method

Grid Solutions Framework ChannelValueBaseTGetCompositeValue Method
Gets the specified composite value of this ChannelValueBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract double GetCompositeValue(
    int index
)
Public MustOverride Function GetCompositeValue (
    index As Integer
) As Double
abstract GetCompositeValue :
        index : int -> float

function GetCompositeValue(index);
public:
virtual double GetCompositeValue(
    int index
) abstract

Parameters

index
Type: SystemInt32
Index of composite value to retrieve.

Return Value

Type: Double
A Double representing the composite value.

Implements

IChannelValueTGetCompositeValue(Int32)
Remarks
Some ChannelValueBaseT implementations can contain more than one value, this method is used to abstractly expose each value.
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).GetMeasurementValueFilterFunction Method

Grid Solutions Framework ChannelValueBaseTGetMeasurementValueFilterFunction Method
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Public Overridable Function GetMeasurementValueFilterFunction (
    index As Integer
) As MeasurementValueFilterFunction
abstract GetMeasurementValueFilterFunction :
        index : int -> MeasurementValueFilterFunction
override GetMeasurementValueFilterFunction :
        index : int -> MeasurementValueFilterFunction
function GetMeasurementValueFilterFunction(index);
public:
virtual MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
)

Parameters

index
Type: SystemInt32
Index of composite value for which to retrieve its filter function.

Return Value

Type: MeasurementValueFilterFunction
Function used to apply a downsampling filter over a sequence of IMeasurement values, if defined; otherwise, null.

Implements

IChannelValueTGetMeasurementValueFilterFunction(Int32)
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).GetObjectData Method

Grid Solutions Framework ChannelValueBaseTGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T) Properties

Grid Solutions Framework ChannelValueBaseT Properties

The ChannelValueBaseT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelValueBaseT object. (Overrides ChannelBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | BodyLength | Gets the length of the body portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | CompositeValueCount | Gets total number of composite values that this ChannelValueBaseT provides.
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT.
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of ChannelValueBaseT have been assigned a value.
Public property | Label | Gets text based label of this ChannelValueBaseT.
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values.
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).Attributes Property

Grid Solutions Framework ChannelValueBaseTAttributes Property
DictionaryTKey, TValue of string based property names and values for the ChannelValueBaseT object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).CompositeValueCount Property

Grid Solutions Framework ChannelValueBaseTCompositeValueCount Property
Gets total number of composite values that this ChannelValueBaseT provides.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract int CompositeValueCount { get; }
Public MustOverride ReadOnly Property CompositeValueCount As Integer
    Get
abstract CompositeValueCount : int with get

function get_CompositeValueCount();

public:
virtual property int CompositeValueCount {
    int get () abstract;
}

Property Value

Type: Int32

Implements

IChannelValueTCompositeValueCount
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).DataFormat Property

Grid Solutions Framework ChannelValueBaseTDataFormat Property
Gets the DataFormat of this ChannelValueBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataFormat DataFormat { get; }
Public Overridable ReadOnly Property DataFormat As DataFormat
    Get
abstract DataFormat : DataFormat with get
override DataFormat : DataFormat with get
function get_DataFormat();

public:
virtual property DataFormat DataFormat {
    DataFormat get ();
}

Property Value

Type: DataFormat

Implements

IChannelValueTDataFormat
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).Definition Property

Grid Solutions Framework ChannelValueBaseTDefinition Property
Gets or sets the IChannelDefinition associated with this ChannelValueBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual T Definition { get; set; }
Public Overridable Property Definition As T
    Get
    Set
abstract Definition : 'T with get, set
override Definition : 'T with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property T Definition {
    T get ();
    void set (T value);
}

Property Value

Type: T

Implements

IChannelValueTDefinition
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).IsEmpty Property

Grid Solutions Framework ChannelValueBaseTIsEmpty Property
Gets boolean value that determines if none of the composite values of ChannelValueBaseT have been assigned a value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool IsEmpty { get; }
Public MustOverride ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get

function get_IsEmpty();

public:
virtual property bool IsEmpty {
    bool get () abstract;
}

Return Value

Type: Boolean
true, if no composite values have been assigned a value; otherwise, false.

Implements

IChannelValueTIsEmpty
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).Label Property

Grid Solutions Framework ChannelValueBaseTLabel Property
Gets text based label of this ChannelValueBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Label { get; }
Public Overridable ReadOnly Property Label As String
    Get
abstract Label : string with get
override Label : string with get
function get_Label();

public:
virtual property String^ Label {
    String^ get ();
}

Property Value

Type: String

Implements

IChannelValueTLabel
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).Measurements Property

Grid Solutions Framework ChannelValueBaseTMeasurements Property
Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IMeasurement[] Measurements { get; }
Public Overridable ReadOnly Property Measurements As IMeasurement()
    Get
abstract Measurements : IMeasurement[] with get
override Measurements : IMeasurement[] with get
function get_Measurements();

public:
virtual property array<IMeasurement^>^ Measurements {
    array<IMeasurement^>^ get ();
}

Property Value

Type: IMeasurement

Implements

IChannelValueTMeasurements
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueBase(T).Parent Property

Grid Solutions Framework ChannelValueBaseTParent Property
Gets or sets the IDataCell parent of this ChannelValueBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IDataCell Parent { get; set; }
Public Overridable Property Parent As IDataCell
    Get
    Set
abstract Parent : IDataCell with get, set
override Parent : IDataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property IDataCell^ Parent {
    IDataCell^ get ();
    void set (IDataCell^ value);
}

Property Value

Type: IDataCell

Implements

IChannelValueTParent
See Also

Reference

ChannelValueBaseT Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue) Class

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValue Class
Represents a protocol independent collection of IChannelValueT objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection TValue
GSF.CollectionsListCollection TValue
GSF.PhasorProtocolsChannelCollectionBase TValue
GSF.PhasorProtocolsChannelValueCollectionBaseTDefinition, TValue
GSF.PhasorProtocolsAnalogValueCollection
GSF.PhasorProtocolsDigitalValueCollection
GSF.PhasorProtocolsFrequencyValueCollection
GSF.PhasorProtocolsPhasorValueCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ChannelValueCollectionBase<TDefinition, TValue> : ChannelCollectionBase<TValue>
where TDefinition : IChannelDefinition
where TValue : Object, IChannelValue<TDefinition>

<SerializableAttribute>
Public MustInherit Class ChannelValueCollectionBase(Of TDefinition As IChannelDefinition, TValue As {Object, IChannelValue(Of TDefinition)})
    Inherits ChannelCollectionBase(Of TValue)
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ChannelValueCollectionBase<'TDefinition, 'TValue when 'TDefinition : IChannelDefinition when 'TValue : Object and IChannelValue<'TDefinition>> =
    class
        inherit ChannelCollectionBase<'TValue>
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename TDefinition, typename TValue>
where TDefinition : IChannelDefinition
where TValue : Object, IChannelValue<TDefinition>
public ref class ChannelValueCollectionBase abstract : public ChannelCollectionBase<TValue>

Type Parameters

TDefinition
Specific IChannelDefinition type that the IChannelValueT references.
TValue
Specific IChannelValueT type that the ChannelValueCollectionBaseTDefinition, TValue contains.

The ChannelValueCollectionBaseTDefinition, TValue type exposes the following members.

Constructors
 | Name | Description
Protected method | ChannelValueCollectionBaseTDefinition, TValue(Int32) | Creates a new ChannelValueCollectionBaseTDefinition, TValue using specified lastValidIndex.
Protected method | ChannelValueCollectionBaseTDefinition, TValue(SerializationInfo, StreamingContext) | Creates a new ChannelValueCollectionBaseTDefinition, TValue from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Overrides ChannelCollectionBaseTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCollectionBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Overrides ChannelCollectionBaseTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Overrides ChannelCollectionBaseTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ChannelCollectionBaseTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Overrides ChannelCollectionBaseTAttributes.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Overrides ChannelCollectionBaseTBinaryLength.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue) Constructor

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValue Constructor
Overload List
 | Name | Description
Protected method | ChannelValueCollectionBaseTDefinition, TValue(Int32) | Creates a new ChannelValueCollectionBaseTDefinition, TValue using specified lastValidIndex.
Protected method | ChannelValueCollectionBaseTDefinition, TValue(SerializationInfo, StreamingContext) | Creates a new ChannelValueCollectionBaseTDefinition, TValue from serialization parameters.
Top
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue) Constructor (Int32)

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValue Constructor (Int32)
Creates a new ChannelValueCollectionBaseTDefinition, TValue using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelValueCollectionBase(
    int lastValidIndex
)
Protected Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> ChannelValueCollectionBase
GSF.PhasorProtocols.ChannelValueCollectionBase = function(lastValidIndex);
protected:
ChannelValueCollectionBase(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
ChannelValueCollectionBaseTDefinition, TValue Overload
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue) Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValue Constructor (SerializationInfo, StreamingContext)
Creates a new ChannelValueCollectionBaseTDefinition, TValue from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ChannelValueCollectionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ChannelValueCollectionBase
GSF.PhasorProtocols.ChannelValueCollectionBase = function(info, context);
protected:
ChannelValueCollectionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
ChannelValueCollectionBaseTDefinition, TValue Overload
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue) Methods

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValue Methods

The ChannelValueCollectionBaseTDefinition, TValue generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Overrides ChannelCollectionBaseTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCollectionBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Overrides ChannelCollectionBaseTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Overrides ChannelCollectionBaseTRemoveItem(Int32).)
Protected method | SetItem | Replaces the element at the specified index. (Overrides ChannelCollectionBaseTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).ClearItems Method

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueClearItems Method
Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
abstract ClearItems : unit -> unit
override ClearItems : unit -> unit
function ClearItems();
protected:
virtual void ClearItems() override
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).GetObjectData Method

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).InsertItem Method

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueInsertItem Method
Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InsertItem(
    int index,
    TValue item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As TValue
)
abstract InsertItem :
        index : int *
        item : 'TValue -> unit
override InsertItem :
        index : int *
        item : 'TValue -> unit
function InsertItem(index, item);
protected:
virtual void InsertItem(
    int index,
    TValue item
) override

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: TValue
The object to insert.
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).RemoveItem Method

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueRemoveItem Method
Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)
abstract RemoveItem :
        index : int -> unit
override RemoveItem :
        index : int -> unit
function RemoveItem(index);
protected:
virtual void RemoveItem(
    int index
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is equal to or greater than Count.
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).SetItem Method

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueSetItem Method
Replaces the element at the specified index.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SetItem(
    int index,
    TValue item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As TValue
)
abstract SetItem :
        index : int *
        item : 'TValue -> unit
override SetItem :
        index : int *
        item : 'TValue -> unit
function SetItem(index, item);
protected:
virtual void SetItem(
    int index,
    TValue item
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: TValue
The new value for the element at the specified index. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue) Properties

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValue Properties

The ChannelValueCollectionBaseTDefinition, TValue generic type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Overrides ChannelCollectionBaseTAttributes.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Overrides ChannelCollectionBaseTBinaryLength.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).AllValuesAssigned Property

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueAllValuesAssigned Property
Gets a boolean value indicating if all of the composite values have been assigned a value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool AllValuesAssigned { get; }
Public Overridable ReadOnly Property AllValuesAssigned As Boolean
    Get
abstract AllValuesAssigned : bool with get
override AllValuesAssigned : bool with get
function get_AllValuesAssigned();

public:
virtual property bool AllValuesAssigned {
    bool get ();
}

Return Value

Type: Boolean
true, if all composite values have been assigned a value; otherwise, false.
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).Attributes Property

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue).BinaryLength Property

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValueBinaryLength Property
Gets the length of the ChannelCollectionBaseT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueCollectionBase(TDefinition, TValue) Events

Grid Solutions Framework ChannelValueCollectionBaseTDefinition, TValue Events

The ChannelValueCollectionBaseTDefinition, TValue generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ChannelValueCollectionBaseTDefinition, TValue Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T) Class

Grid Solutions Framework ChannelValueMeasurementT Class
Represents a IMeasurement implementation for composite values of a given IChannelValueT.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelValueMeasurementT

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public class ChannelValueMeasurement<T> : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>, IComparable<ITimeSeriesValue>,
    IComparable
where T : IChannelDefinition

<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Class ChannelValueMeasurement(Of T As IChannelDefinition)
    Implements IMeasurement, ITimeSeriesValue(Of Double),
    ITimeSeriesValue, IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue),
    IComparable
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
type ChannelValueMeasurement<'T when 'T : IChannelDefinition> =
    class
        interface IMeasurement
        interface ITimeSeriesValue<float>
        interface ITimeSeriesValue
        interface IEquatable<ITimeSeriesValue>
        interface IComparable<ITimeSeriesValue>
        interface IComparable
    end
JavaScript does not support generic types or methods.
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
generic<typename T>
where T : IChannelDefinition
public ref class ChannelValueMeasurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>, IComparable<ITimeSeriesValue^>,
    IComparable

Type Parameters

T
Generic type T.

The ChannelValueMeasurementT type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelValueMeasurementT | Constructs a new ChannelValueMeasurementT given the specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the ChannelValueMeasurementT with the specified Object.
Public method | CompareTo(ITimeSeriesValue) | Compares the ChannelValueMeasurementT with an ITimeSeriesValue.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelValueMeasurementT. (Overrides ObjectEquals(Object).)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current ChannelValueMeasurementT.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Get the hash code for the ChannelValueMeasurementT.MeasurementKey. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current ChannelValueMeasurementT. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0.
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
Public property | ID | Gets or sets the Guid based signal ID of this ChannelValueMeasurementT, if available.
Public property | Key | Gets the primary key (a MeasurementKey, of this ChannelValueMeasurementT.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0.
Public property | Parent | Gets or sets reference to the IChannelValueT that this measurement derives its values from.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurementT was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurementT was received (i.e., created).
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this ChannelValueMeasurementT.
Public property | TagName | Gets or sets the text based tag name of this ChannelValueMeasurementT.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelValueMeasurementT.
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
Public property | ValueIndex | Gets or sets index into the GetCompositeValue(Int32) that this measurement derives its value from.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T) Constructor

Grid Solutions Framework ChannelValueMeasurementT Constructor
Constructs a new ChannelValueMeasurementT given the specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelValueMeasurement(
    IChannelValue<T> parent,
    int valueIndex
)
Public Sub New (
    parent As IChannelValue(Of T),
    valueIndex As Integer
)
new :
        parent : IChannelValue<'T> *
        valueIndex : int -> ChannelValueMeasurement
GSF.PhasorProtocols.ChannelValueMeasurement = function(parent, valueIndex);
public:
ChannelValueMeasurement(
    IChannelValue<T>^ parent,
    int valueIndex
)

Parameters

parent
Type: GSF.PhasorProtocolsIChannelValue T
The reference to the IChannelValueT that this measurement derives its values from.
valueIndex
Type: SystemInt32
The index into the GetCompositeValue(Int32) that this measurement derives its value from.
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T) Methods

Grid Solutions Framework ChannelValueMeasurementT Methods

The ChannelValueMeasurementT generic type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the ChannelValueMeasurementT with the specified Object.
Public method | CompareTo(ITimeSeriesValue) | Compares the ChannelValueMeasurementT with an ITimeSeriesValue.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelValueMeasurementT. (Overrides ObjectEquals(Object).)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current ChannelValueMeasurementT.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Get the hash code for the ChannelValueMeasurementT.MeasurementKey. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current ChannelValueMeasurementT. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).CompareTo Method

Grid Solutions Framework ChannelValueMeasurementTCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the ChannelValueMeasurementT with the specified Object.
Public method | CompareTo(ITimeSeriesValue) | Compares the ChannelValueMeasurementT with an ITimeSeriesValue.
Top
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).CompareTo Method (Object)

Grid Solutions Framework ChannelValueMeasurementTCompareTo Method (Object)
Compares the ChannelValueMeasurementT with the specified Object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: SystemObject
The Object to compare with the current ChannelValueMeasurementT.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | obj is not an IMeasurement.
Remarks
Measurement implementations should compare by hash code.
See Also

Reference

ChannelValueMeasurementT Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).CompareTo Method (ITimeSeriesValue)

Grid Solutions Framework ChannelValueMeasurementTCompareTo Method (ITimeSeriesValue)
Compares the ChannelValueMeasurementT with an ITimeSeriesValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    ITimeSeriesValue other
)
Public Function CompareTo (
    other As ITimeSeriesValue
) As Integer
abstract CompareTo :
        other : ITimeSeriesValue -> int
override CompareTo :
        other : ITimeSeriesValue -> int
function CompareTo(other);
public:
virtual int CompareTo(
    ITimeSeriesValue^ other
) sealed

Parameters

other
Type: GSF.TimeSeriesITimeSeriesValue
The ITimeSeriesValue to compare with the current ChannelValueMeasurementT.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
Remarks
Measurement implementations should compare by hash code.
See Also

Reference

ChannelValueMeasurementT Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Equals Method

Grid Solutions Framework ChannelValueMeasurementTEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelValueMeasurementT. (Overrides ObjectEquals(Object).)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current ChannelValueMeasurementT.
Top
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Equals Method (Object)

Grid Solutions Framework ChannelValueMeasurementTEquals Method (Object)
Determines whether the specified Object is equal to the current ChannelValueMeasurementT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The Object to compare with the current ChannelValueMeasurementT.

Return Value

Type: Boolean
true if the specified Object is equal to the current ChannelValueMeasurementT; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | obj is not an IMeasurement.
See Also

Reference

ChannelValueMeasurementT Class
Equals Overload
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Equals Method (ITimeSeriesValue)

Grid Solutions Framework ChannelValueMeasurementTEquals Method (ITimeSeriesValue)
Determines whether the specified ITimeSeriesValue is equal to the current ChannelValueMeasurementT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    ITimeSeriesValue other
)
Public Function Equals (
    other As ITimeSeriesValue
) As Boolean
abstract Equals :
        other : ITimeSeriesValue -> bool
override Equals :
        other : ITimeSeriesValue -> bool
function Equals(other);
public:
virtual bool Equals(
    ITimeSeriesValue^ other
) sealed

Parameters

other
Type: GSF.TimeSeriesITimeSeriesValue
The ITimeSeriesValue to compare with the current ChannelValueMeasurementT.

Return Value

Type: Boolean
true if the specified ITimeSeriesValue is equal to the current ChannelValueMeasurementT; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

ChannelValueMeasurementT Class
Equals Overload
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).GetHashCode Method

Grid Solutions Framework ChannelValueMeasurementTGetHashCode Method
Get the hash code for the ChannelValueMeasurementT.MeasurementKey.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
Hash code for the ChannelValueMeasurementT.MeasurementKey.

Implements

ITimeSeriesValueGetHashCode
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).ToString Method

Grid Solutions Framework ChannelValueMeasurementTToString Method
Returns a String that represents the current ChannelValueMeasurementT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current ChannelValueMeasurementT.
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T) Properties

Grid Solutions Framework ChannelValueMeasurementT Properties

The ChannelValueMeasurementT generic type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0.
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
Public property | ID | Gets or sets the Guid based signal ID of this ChannelValueMeasurementT, if available.
Public property | Key | Gets the primary key (a MeasurementKey, of this ChannelValueMeasurementT.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0.
Public property | Parent | Gets or sets reference to the IChannelValueT that this measurement derives its values from.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurementT was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurementT was received (i.e., created).
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this ChannelValueMeasurementT.
Public property | TagName | Gets or sets the text based tag name of this ChannelValueMeasurementT.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelValueMeasurementT.
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
Public property | ValueIndex | Gets or sets index into the GetCompositeValue(Int32) that this measurement derives its value from.
Top
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Adder Property

Grid Solutions Framework ChannelValueMeasurementTAdder Property
Gets or sets an offset to add to the measurement value. This defaults to 0.0.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Adder { get; set; }
Public Overridable Property Adder As Double
    Get
    Set
abstract Adder : float with get, set
override Adder : float with get, set
function get_Adder();
function set_Adder(value);
public:
virtual property double Adder {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IMeasurementAdder
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).AdjustedValue Property

Grid Solutions Framework ChannelValueMeasurementTAdjustedValue Property
Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double AdjustedValue { get; }
Public Overridable ReadOnly Property AdjustedValue As Double
    Get
abstract AdjustedValue : float with get
override AdjustedValue : float with get
function get_AdjustedValue();

public:
virtual property double AdjustedValue {
    double get ();
}

Return Value

Type: Double
Value offset by Adder and Multiplier (i.e., Value * Multiplier + Adder).

Implements

IMeasurementAdjustedValue
Remarks
Note that returned value will be offset by Adder and Multiplier.
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).ID Property

Grid Solutions Framework ChannelValueMeasurementTID Property
Gets or sets the Guid based signal ID of this ChannelValueMeasurementT, if available.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid ID { get; }
Public ReadOnly Property ID As Guid
    Get
abstract ID : Guid with get
override ID : Guid with get
function get_ID();

public:
virtual property Guid ID {
    Guid get () sealed;
}

Property Value

Type: Guid

Implements

ITimeSeriesValueID
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Key Property

Grid Solutions Framework ChannelValueMeasurementTKey Property
Gets the primary key (a MeasurementKey, of this ChannelValueMeasurementT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MeasurementKey Key { get; set; }
Public Property Key As MeasurementKey
    Get
    Set
abstract Key : MeasurementKey with get, set
override Key : MeasurementKey with get, set
function get_Key();
function set_Key(value);
public:
virtual property MeasurementKey^ Key {
    MeasurementKey^ get () sealed;
    void set (MeasurementKey^ value) sealed;
}

Property Value

Type: MeasurementKey

Implements

IMeasurementKey
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).MeasurementValueFilter Property

Grid Solutions Framework ChannelValueMeasurementTMeasurementValueFilter Property
Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementValueFilterFunction MeasurementValueFilter { get; set; }
Public Overridable Property MeasurementValueFilter As MeasurementValueFilterFunction
    Get
    Set
abstract MeasurementValueFilter : MeasurementValueFilterFunction with get, set
override MeasurementValueFilter : MeasurementValueFilterFunction with get, set
function get_MeasurementValueFilter();
function set_MeasurementValueFilter(value);
public:
virtual property MeasurementValueFilterFunction^ MeasurementValueFilter {
    MeasurementValueFilterFunction^ get ();
    void set (MeasurementValueFilterFunction^ value);
}

Property Value

Type: MeasurementValueFilterFunction

Implements

IMeasurementMeasurementValueFilter
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Multiplier Property

Grid Solutions Framework ChannelValueMeasurementTMultiplier Property
Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Multiplier { get; set; }
Public Overridable Property Multiplier As Double
    Get
    Set
abstract Multiplier : float with get, set
override Multiplier : float with get, set
function get_Multiplier();
function set_Multiplier(value);
public:
virtual property double Multiplier {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IMeasurementMultiplier
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Parent Property

Grid Solutions Framework ChannelValueMeasurementTParent Property
Gets or sets reference to the IChannelValueT that this measurement derives its values from.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IChannelValue<T> Parent { get; set; }
Public Property Parent As IChannelValue(Of T)
    Get
    Set
member Parent : IChannelValue<'T> with get, set

function get_Parent();
function set_Parent(value);
public:
property IChannelValue<T>^ Parent {
    IChannelValue<T>^ get ();
    void set (IChannelValue<T>^ value);
}

Property Value

Type: IChannelValue T
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).PublishedTimestamp Property

Grid Solutions Framework ChannelValueMeasurementTPublishedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurementT was published (post-processing).

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks PublishedTimestamp { get; set; }
Public Overridable Property PublishedTimestamp As Ticks
    Get
    Set
abstract PublishedTimestamp : Ticks with get, set
override PublishedTimestamp : Ticks with get, set
function get_PublishedTimestamp();
function set_PublishedTimestamp(value);
public:
virtual property Ticks PublishedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

IMeasurementPublishedTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).ReceivedTimestamp Property

Grid Solutions Framework ChannelValueMeasurementTReceivedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this ChannelValueMeasurementT was received (i.e., created).

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks ReceivedTimestamp { get; set; }
Public Overridable Property ReceivedTimestamp As Ticks
    Get
    Set
abstract ReceivedTimestamp : Ticks with get, set
override ReceivedTimestamp : Ticks with get, set
function get_ReceivedTimestamp();
function set_ReceivedTimestamp(value);
public:
virtual property Ticks ReceivedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

IMeasurementReceivedTimestamp
Remarks

In the default implementation, this timestamp will simply be the ticks of UtcNow of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).StateFlags Property

Grid Solutions Framework ChannelValueMeasurementTStateFlags Property
Gets or sets MeasurementStateFlags associated with this ChannelValueMeasurementT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementStateFlags StateFlags { get; set; }
Public Overridable Property StateFlags As MeasurementStateFlags
    Get
    Set
abstract StateFlags : MeasurementStateFlags with get, set
override StateFlags : MeasurementStateFlags with get, set
function get_StateFlags();
function set_StateFlags(value);
public:
virtual property MeasurementStateFlags StateFlags {
    MeasurementStateFlags get ();
    void set (MeasurementStateFlags value);
}

Property Value

Type: MeasurementStateFlags

Implements

IMeasurementStateFlags
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).TagName Property

Grid Solutions Framework ChannelValueMeasurementTTagName Property
Gets or sets the text based tag name of this ChannelValueMeasurementT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string TagName { get; set; }
Public Overridable Property TagName As String
    Get
    Set
abstract TagName : string with get, set
override TagName : string with get, set
function get_TagName();
function set_TagName(value);
public:
virtual property String^ TagName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IMeasurementTagName
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Timestamp Property

Grid Solutions Framework ChannelValueMeasurementTTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this ChannelValueMeasurementT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks Timestamp { get; set; }
Public Overridable Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

ITimeSeriesValueTimestamp
Remarks
This value returns timestamp of parent data frame unless assigned an alternate value.
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).Value Property

Grid Solutions Framework ChannelValueMeasurementTValue Property
Gets or sets the raw measurement value that is not offset by Adder and Multiplier.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Value { get; set; }
Public Overridable Property Value As Double
    Get
    Set
abstract Value : float with get, set
override Value : float with get, set
function get_Value();
function set_Value(value);
public:
virtual property double Value {
    double get ();
    void set (double value);
}

Return Value

Type: Double
Raw value of this ChannelValueMeasurementT (i.e., value that is not offset by Adder and Multiplier).

Implements

ITimeSeriesValueTValue
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


ChannelValueMeasurement(T).ValueIndex Property

Grid Solutions Framework ChannelValueMeasurementTValueIndex Property
Gets or sets index into the GetCompositeValue(Int32) that this measurement derives its value from.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ValueIndex { get; set; }
Public Overridable Property ValueIndex As Integer
    Get
    Set
abstract ValueIndex : int with get, set
override ValueIndex : int with get, set
function get_ValueIndex();
function set_ValueIndex(value);
public:
virtual property int ValueIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ChannelValueMeasurementT Class
GSF.PhasorProtocols Namespace


CheckSumValidationFrameTypes Enumeration

Grid Solutions Framework CheckSumValidationFrameTypes Enumeration
Check-sum validation frame-type flags.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum CheckSumValidationFrameTypes
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration CheckSumValidationFrameTypes
[<SerializableAttribute>]
[<FlagsAttribute>]
type CheckSumValidationFrameTypes
GSF.PhasorProtocols.CheckSumValidationFrameTypes = function();
GSF.PhasorProtocols.CheckSumValidationFrameTypes.createEnum('GSF.PhasorProtocols.CheckSumValidationFrameTypes', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class CheckSumValidationFrameTypes
Members
Member name | Value | Description
NoFrames | 0 | Include no frame types for check-sum validation.
ConfigurationFrame | 1 | Include configuration frame for check-sum validation.
DataFrame | 2 | Include data frame for check-sum validation.
HeaderFrame | 4 | Include header frame for check-sum validation.
CommandFrame | 8 | Include command frame for check-sum validation.
AllFrames | 255 | Include all frame types for check-sum validation.
See Also

Reference

GSF.PhasorProtocols Namespace


CommandCell Class

Grid Solutions Framework CommandCell Class
Represents the protocol independent common implementation of an element of extended data for cells in a ICommandFrame.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsCommandCell

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandCell : ChannelCellBase,
    ICommandCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable
<SerializableAttribute>
Public Class CommandCell
    Inherits ChannelCellBase
    Implements ICommandCell, IChannelCell, IChannel, ISupportBinaryImage,
    ISerializable
[<SerializableAttribute>]
type CommandCell =
    class
        inherit ChannelCellBase
        interface ICommandCell
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.CommandCell = function();

Type.createClass(
    'GSF.PhasorProtocols.CommandCell',
    GSF.PhasorProtocols.ChannelCellBase,
    GSF.PhasorProtocols.ICommandCell,
    GSF.PhasorProtocols.IChannelCell,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class CommandCell : public ChannelCellBase,
    ICommandCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable

The CommandCell type exposes the following members.

Constructors
 | Name | Description
Protected method | CommandCell(SerializationInfo, StreamingContext) | Creates a new CommandCell from serialization parameters.
Public method | CommandCell(ICommandFrame, Byte) | Creates a new CommandCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandCell object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the CommandCell object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | ExtendedDataByte | Gets or sets extended data Byte that represents this CommandCell.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Parent | Gets or sets a reference to the parent ICommandFrame for this CommandCell.
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


CommandCell Constructor

Grid Solutions Framework CommandCell Constructor
Overload List
 | Name | Description
Protected method | CommandCell(SerializationInfo, StreamingContext) | Creates a new CommandCell from serialization parameters.
Public method | CommandCell(ICommandFrame, Byte) | Creates a new CommandCell from specified parameters.
Top
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandCell Constructor (SerializationInfo, StreamingContext)
Creates a new CommandCell from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandCell
GSF.PhasorProtocols.CommandCell = function(info, context);
protected:
CommandCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandCell Class
CommandCell Overload
GSF.PhasorProtocols Namespace


CommandCell Constructor (ICommandFrame, Byte)

Grid Solutions Framework CommandCell Constructor (ICommandFrame, Byte)
Creates a new CommandCell from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandCell(
    ICommandFrame parent,
    byte extendedDataByte
)
Public Sub New (
    parent As ICommandFrame,
    extendedDataByte As Byte
)
new :
        parent : ICommandFrame *
        extendedDataByte : byte -> CommandCell
GSF.PhasorProtocols.CommandCell = function(parent, extendedDataByte);
public:
CommandCell(
    ICommandFrame^ parent,
    unsigned char extendedDataByte
)

Parameters

parent
Type: GSF.PhasorProtocolsICommandFrame
A reference to the parent ICommandFrame for this CommandCell.
extendedDataByte
Type: SystemByte
Extended data Byte that represents this CommandCell.
See Also

Reference

CommandCell Class
CommandCell Overload
GSF.PhasorProtocols Namespace


CommandCell Methods

Grid Solutions Framework CommandCell Methods

The CommandCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell.GetObjectData Method

Grid Solutions Framework CommandCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell.ParseBodyImage Method

Grid Solutions Framework CommandCellParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell Properties

Grid Solutions Framework CommandCell Properties

The CommandCell type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandCell object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the CommandCell object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | ExtendedDataByte | Gets or sets extended data Byte that represents this CommandCell.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Parent | Gets or sets a reference to the parent ICommandFrame for this CommandCell.
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell.Attributes Property

Grid Solutions Framework CommandCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the CommandCell object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell.BodyImage Property

Grid Solutions Framework CommandCellBodyImage Property
Gets the binary body image of the CommandCell object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell.BodyLength Property

Grid Solutions Framework CommandCellBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell.ExtendedDataByte Property

Grid Solutions Framework CommandCellExtendedDataByte Property
Gets or sets extended data Byte that represents this CommandCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte ExtendedDataByte { get; set; }
Public Overridable Property ExtendedDataByte As Byte
    Get
    Set
abstract ExtendedDataByte : byte with get, set
override ExtendedDataByte : byte with get, set
function get_ExtendedDataByte();
function set_ExtendedDataByte(value);
public:
virtual property unsigned char ExtendedDataByte {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte

Implements

ICommandCellExtendedDataByte
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCell.Parent Property

Grid Solutions Framework CommandCellParent Property
Gets or sets a reference to the parent ICommandFrame for this CommandCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ICommandFrame Parent { get; set; }
Public Overridable Property Parent As ICommandFrame
    Get
    Set
abstract Parent : ICommandFrame with get, set
override Parent : ICommandFrame with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ICommandFrame^ Parent {
    ICommandFrame^ get ();
    void set (ICommandFrame^ value);
}

Property Value

Type: ICommandFrame

Implements

ICommandCellParent
See Also

Reference

CommandCell Class
GSF.PhasorProtocols Namespace


CommandCellCollection Class

Grid Solutions Framework CommandCellCollection Class
Represents a protocol independent collection of ICommandCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection ICommandCell
GSF.CollectionsListCollection ICommandCell
GSF.PhasorProtocolsChannelCollectionBase ICommandCell
GSF.PhasorProtocolsChannelCellCollectionBase ICommandCell
GSF.PhasorProtocolsCommandCellCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandCellCollection : ChannelCellCollectionBase<ICommandCell>
<SerializableAttribute>
Public Class CommandCellCollection
    Inherits ChannelCellCollectionBase(Of ICommandCell)
[<SerializableAttribute>]
type CommandCellCollection =
    class
        inherit ChannelCellCollectionBase<ICommandCell>
    end
GSF.PhasorProtocols.CommandCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.CommandCellCollection',
    GSF.PhasorProtocols.ChannelCellCollectionBase`1);
[SerializableAttribute]
public ref class CommandCellCollection : public ChannelCellCollectionBase<ICommandCell^>

The CommandCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | CommandCellCollection(Int32) | Creates a new CommandCellCollection using specified lastValidIndex.
Protected method | CommandCellCollection(SerializationInfo, StreamingContext) | Creates a new CommandCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


CommandCellCollection Constructor

Grid Solutions Framework CommandCellCollection Constructor
Overload List
 | Name | Description
Public method | CommandCellCollection(Int32) | Creates a new CommandCellCollection using specified lastValidIndex.
Protected method | CommandCellCollection(SerializationInfo, StreamingContext) | Creates a new CommandCellCollection from serialization parameters.
Top
See Also

Reference

CommandCellCollection Class
GSF.PhasorProtocols Namespace


CommandCellCollection Constructor (Int32)

Grid Solutions Framework CommandCellCollection Constructor (Int32)
Creates a new CommandCellCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandCellCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> CommandCellCollection
GSF.PhasorProtocols.CommandCellCollection = function(lastValidIndex);
public:
CommandCellCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

CommandCellCollection Class
CommandCellCollection Overload
GSF.PhasorProtocols Namespace


CommandCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new CommandCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandCellCollection
GSF.PhasorProtocols.CommandCellCollection = function(info, context);
protected:
CommandCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandCellCollection Class
CommandCellCollection Overload
GSF.PhasorProtocols Namespace


CommandCellCollection Methods

Grid Solutions Framework CommandCellCollection Methods

The CommandCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandCellCollection Class
GSF.PhasorProtocols Namespace


CommandCellCollection Properties

Grid Solutions Framework CommandCellCollection Properties

The CommandCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

CommandCellCollection Class
GSF.PhasorProtocols Namespace


CommandCellCollection Events

Grid Solutions Framework CommandCellCollection Events

The CommandCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

CommandCellCollection Class
GSF.PhasorProtocols Namespace


CommandFrameBase Class

Grid Solutions Framework CommandFrameBase Class
Represents the protocol independent common implementation of any ICommandFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase ICommandCell
GSF.PhasorProtocolsCommandFrameBase
GSF.PhasorProtocols.IEC61850_90_5CommandFrame
GSF.PhasorProtocols.IEEE1344CommandFrame
GSF.PhasorProtocols.IEEEC37_118CommandFrame
GSF.PhasorProtocols.MacrodyneCommandFrame
GSF.PhasorProtocols.SelFastMessageCommandFrame

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class CommandFrameBase : ChannelFrameBase<ICommandCell>,
    ICommandFrame, IChannelFrame<ICommandCell>, IChannelFrame, IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame>, IComparable<IFrame>,
    IComparable, ISerializable
<SerializableAttribute>
Public MustInherit Class CommandFrameBase
    Inherits ChannelFrameBase(Of ICommandCell)
    Implements ICommandFrame, IChannelFrame(Of ICommandCell),
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable(Of IFrame),
    IComparable(Of IFrame), IComparable, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type CommandFrameBase =
    class
        inherit ChannelFrameBase<ICommandCell>
        interface ICommandFrame
        interface IChannelFrame<ICommandCell>
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.CommandFrameBase = function();

Type.createClass(
    'GSF.PhasorProtocols.CommandFrameBase',
    GSF.PhasorProtocols.ChannelFrameBase`1,
    GSF.PhasorProtocols.ICommandFrame,
    GSF.PhasorProtocols.IChannelFrame`1,
    GSF.PhasorProtocols.IChannelFrame,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    GSF.TimeSeries.IFrame,
    IEquatable`1,
    IComparable`1,
    IComparable,
    ISerializable);
[SerializableAttribute]
public ref class CommandFrameBase abstract : public ChannelFrameBase<ICommandCell^>,
    ICommandFrame, IChannelFrame<ICommandCell^>, IChannelFrame, IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame^>, IComparable<IFrame^>,
    IComparable, ISerializable

The CommandFrameBase type exposes the following members.

Constructors
 | Name | Description
Protected method | CommandFrameBase(SerializationInfo, StreamingContext) | Creates a new CommandFrameBase from serialization parameters.
Protected method | CommandFrameBase(CommandCellCollection, DeviceCommand) | Creates a new CommandFrameBase from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelFrameBaseTParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandFrameBase object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Overrides ChannelFrameBaseTBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelFrameBaseTBodyLength.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase.
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


CommandFrameBase Constructor

Grid Solutions Framework CommandFrameBase Constructor
Overload List
 | Name | Description
Protected method | CommandFrameBase(SerializationInfo, StreamingContext) | Creates a new CommandFrameBase from serialization parameters.
Protected method | CommandFrameBase(CommandCellCollection, DeviceCommand) | Creates a new CommandFrameBase from specified parameters.
Top
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandFrameBase Constructor (SerializationInfo, StreamingContext)
Creates a new CommandFrameBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandFrameBase
GSF.PhasorProtocols.CommandFrameBase = function(info, context);
protected:
CommandFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandFrameBase Class
CommandFrameBase Overload
GSF.PhasorProtocols Namespace


CommandFrameBase Constructor (CommandCellCollection, DeviceCommand)

Grid Solutions Framework CommandFrameBase Constructor (CommandCellCollection, DeviceCommand)
Creates a new CommandFrameBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandFrameBase(
    CommandCellCollection cells,
    DeviceCommand command
)
Protected Sub New (
    cells As CommandCellCollection,
    command As DeviceCommand
)
new :
        cells : CommandCellCollection *
        command : DeviceCommand -> CommandFrameBase
GSF.PhasorProtocols.CommandFrameBase = function(cells, command);
protected:
CommandFrameBase(
    CommandCellCollection^ cells,
    DeviceCommand command
)

Parameters

cells
Type: GSF.PhasorProtocolsCommandCellCollection
The reference to the CommandCellCollection for this CommandFrameBase.
command
Type: GSF.PhasorProtocolsDeviceCommand
The DeviceCommand for this CommandFrameBase.
See Also

Reference

CommandFrameBase Class
CommandFrameBase Overload
GSF.PhasorProtocols Namespace


CommandFrameBase Methods

Grid Solutions Framework CommandFrameBase Methods

The CommandFrameBase type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelFrameBaseTParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.GetObjectData Method

Grid Solutions Framework CommandFrameBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.ParseBodyImage Method

Grid Solutions Framework CommandFrameBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase Properties

Grid Solutions Framework CommandFrameBase Properties

The CommandFrameBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandFrameBase object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Overrides ChannelFrameBaseTBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelFrameBaseTBodyLength.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase.
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.Attributes Property

Grid Solutions Framework CommandFrameBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the CommandFrameBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.BodyImage Property

Grid Solutions Framework CommandFrameBaseBodyImage Property
Gets the binary body image of this CommandFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.BodyLength Property

Grid Solutions Framework CommandFrameBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.Cells Property

Grid Solutions Framework CommandFrameBaseCells Property
Gets reference to the CommandCellCollection for this CommandFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CommandCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As CommandCellCollection
    Get
abstract Cells : CommandCellCollection with get
override Cells : CommandCellCollection with get
function get_Cells();

public:
virtual property CommandCellCollection^ Cells {
    CommandCellCollection^ get ();
}

Property Value

Type: CommandCellCollection

Implements

ICommandFrameCells
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.Command Property

Grid Solutions Framework CommandFrameBaseCommand Property
Gets or sets the DeviceCommand for this CommandFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DeviceCommand Command { get; set; }
Public Overridable Property Command As DeviceCommand
    Get
    Set
abstract Command : DeviceCommand with get, set
override Command : DeviceCommand with get, set
function get_Command();
function set_Command(value);
public:
virtual property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}

Property Value

Type: DeviceCommand

Implements

ICommandFrameCommand
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.ExtendedData Property

Grid Solutions Framework CommandFrameBaseExtendedData Property
Gets or sets extended binary image data for this CommandFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte[] ExtendedData { get; set; }
Public Overridable Property ExtendedData As Byte()
    Get
    Set
abstract ExtendedData : byte[] with get, set
override ExtendedData : byte[] with get, set
function get_ExtendedData();
function set_ExtendedData(value);
public:
virtual property array<unsigned char>^ ExtendedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte

Implements

ICommandFrameExtendedData
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.FrameType Property

Grid Solutions Framework CommandFrameBaseFrameType Property
Gets the FundamentalFrameType for this CommandFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
abstract FrameType : FundamentalFrameType with get
override FrameType : FundamentalFrameType with get
function get_FrameType();

public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}

Property Value

Type: FundamentalFrameType

Implements

IChannelFrameFrameType
IChannelFrameFrameType
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameBase.State Property

Grid Solutions Framework CommandFrameBaseState Property
Gets or sets the parsing state for the this CommandFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ICommandFrameParsingState State { get; set; }
Public Overridable Property State As ICommandFrameParsingState
    Get
    Set
abstract State : ICommandFrameParsingState with get, set
override State : ICommandFrameParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property ICommandFrameParsingState^ State {
    ICommandFrameParsingState^ get ();
    void set (ICommandFrameParsingState^ value);
}

Property Value

Type: ICommandFrameParsingState

Implements

ICommandFrameState
See Also

Reference

CommandFrameBase Class
GSF.PhasorProtocols Namespace


CommandFrameParsingState Class

Grid Solutions Framework CommandFrameParsingState Class
Represents the protocol independent common implementation of the parsing state used by any ICommandFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBase ICommandCell
GSF.PhasorProtocolsCommandFrameParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CommandFrameParsingState : ChannelFrameParsingStateBase<ICommandCell>,
    ICommandFrameParsingState, IChannelFrameParsingState<ICommandCell>, IChannelParsingState
Public Class CommandFrameParsingState
    Inherits ChannelFrameParsingStateBase(Of ICommandCell)
    Implements ICommandFrameParsingState, IChannelFrameParsingState(Of ICommandCell),
    IChannelParsingState
type CommandFrameParsingState =
    class
        inherit ChannelFrameParsingStateBase<ICommandCell>
        interface ICommandFrameParsingState
        interface IChannelFrameParsingState<ICommandCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.CommandFrameParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.CommandFrameParsingState',
    GSF.PhasorProtocols.ChannelFrameParsingStateBase`1,
    GSF.PhasorProtocols.ICommandFrameParsingState,
    GSF.PhasorProtocols.IChannelFrameParsingState`1,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class CommandFrameParsingState : public ChannelFrameParsingStateBase<ICommandCell^>,
    ICommandFrameParsingState, IChannelFrameParsingState<ICommandCell^>, IChannelParsingState

The CommandFrameParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | CommandFrameParsingState | Creates a new CommandFrameParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


CommandFrameParsingState Constructor

Grid Solutions Framework CommandFrameParsingState Constructor
Creates a new CommandFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrameParsingState(
    int parsedBinaryLength,
    int dataLength,
    bool trustHeaderLength,
    bool validateCheckSum
)
Public Sub New (
    parsedBinaryLength As Integer,
    dataLength As Integer,
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        dataLength : int *
        trustHeaderLength : bool *
        validateCheckSum : bool -> CommandFrameParsingState
GSF.PhasorProtocols.CommandFrameParsingState = function(parsedBinaryLength, dataLength, trustHeaderLength, validateCheckSum);
public:
CommandFrameParsingState(
    int parsedBinaryLength,
    int dataLength,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the ICommandFrame being parsed.
dataLength
Type: SystemInt32
Length of data in ICommandFrame being parsed (i.e., number of cells).
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

CommandFrameParsingState Class
GSF.PhasorProtocols Namespace


CommandFrameParsingState Methods

Grid Solutions Framework CommandFrameParsingState Methods

The CommandFrameParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandFrameParsingState Class
GSF.PhasorProtocols Namespace


CommandFrameParsingState Properties

Grid Solutions Framework CommandFrameParsingState Properties

The CommandFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

CommandFrameParsingState Class
GSF.PhasorProtocols Namespace


Common Class

Grid Solutions Framework Common Class
Common constants, functions and extensions for phasor classes.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsCommon

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
<ExtensionAttribute>
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.Common');
[ExtensionAttribute]
public ref class Common abstract sealed

The Common type exposes the following members.

Methods
Name | Description
CopyImage(ISupportBinaryImage, Byte, Int32) | This is a common optimized block copy function for any kind of data.
CopyImage(Byte, Byte, Int32, Int32) | This is a common optimized block copy function for binary data.
DeserializeConfigurationFrame(Stream) | Deserializes a configuration frame from an XML stream.
DeserializeConfigurationFrame(String) | Deserializes a configuration frame from an XML file.
GetFormattedProtocolName | Returns display friendly protocol name.
GetValidLabel | Removes control characters and null from a string.
Top
Fields
Name | Description
SyncByte | Typical data stream synchronization byte.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
SyncByte | Typical data stream synchronization byte.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols Namespace


Common.SyncByte Field

Grid Solutions Framework CommonSyncByte Field
Typical data stream synchronization byte.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte SyncByte
Public Const SyncByte As Byte
static val mutable SyncByte: byte
var GSF.PhasorProtocols.Common.SyncByte
public:
literal unsigned char SyncByte

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols Namespace


Common Methods

Grid Solutions Framework Common Methods

The Common type exposes the following members.

Methods
Name | Description
CopyImage(ISupportBinaryImage, Byte, Int32) | This is a common optimized block copy function for any kind of data.
CopyImage(Byte, Byte, Int32, Int32) | This is a common optimized block copy function for binary data.
DeserializeConfigurationFrame(Stream) | Deserializes a configuration frame from an XML stream.
DeserializeConfigurationFrame(String) | Deserializes a configuration frame from an XML file.
GetFormattedProtocolName | Returns display friendly protocol name.
GetValidLabel | Removes control characters and null from a string.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols Namespace


Common.CopyImage Method

Grid Solutions Framework CommonCopyImage Method
Overload List
Name | Description
CopyImage(ISupportBinaryImage, Byte, Int32) | This is a common optimized block copy function for any kind of data.
CopyImage(Byte, Byte, Int32, Int32) | This is a common optimized block copy function for binary data.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols Namespace


Common.CopyImage Method (ISupportBinaryImage, Byte[], Int32)

Grid Solutions Framework CommonCopyImage Method (ISupportBinaryImage, Byte, Int32)
This is a common optimized block copy function for any kind of data.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void CopyImage(
    this ISupportBinaryImage channel,
    byte[] destination,
    ref int index
)
<ExtensionAttribute>
Public Shared Sub CopyImage (
    channel As ISupportBinaryImage,
    destination As Byte(),
    ByRef index As Integer
)
static member CopyImage :
        channel : ISupportBinaryImage *
        destination : byte[] *
        index : int byref -> unit

GSF.PhasorProtocols.Common.CopyImage = function(channel, destination, index);
public:
[ExtensionAttribute]
static void CopyImage(
    ISupportBinaryImage^ channel,
    array<unsigned char>^ destination,
    int% index
)

Parameters

channel
Type: GSF.ParsingISupportBinaryImage
Source channel with BinaryImage data to copy.
destination
Type: SystemByte
Destination buffer to hold copied buffer data.
index
Type: SystemInt32
Index into destination buffer to begin copy. Index is automatically incremented by BinaryLength.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ISupportBinaryImage. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function automatically advances index for convenience.
See Also

Reference

Common Class
CopyImage Overload
GSF.PhasorProtocols Namespace


Common.CopyImage Method (Byte[], Byte[], Int32, Int32)

Grid Solutions Framework CommonCopyImage Method (Byte, Byte, Int32, Int32)
This is a common optimized block copy function for binary data.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void CopyImage(
    this byte[] source,
    byte[] destination,
    ref int index,
    int length
)
<ExtensionAttribute>
Public Shared Sub CopyImage (
    source As Byte(),
    destination As Byte(),
    ByRef index As Integer,
    length As Integer
)
static member CopyImage :
        source : byte[] *
        destination : byte[] *
        index : int byref *
        length : int -> unit

GSF.PhasorProtocols.Common.CopyImage = function(source, destination, index, length);
public:
[ExtensionAttribute]
static void CopyImage(
    array<unsigned char>^ source,
    array<unsigned char>^ destination,
    int% index,
    int length
)

Parameters

source
Type: SystemByte
Source buffer to copy data from.
destination
Type: SystemByte
Destination buffer to hold copied buffer data.
index
Type: SystemInt32
Index into destination buffer to begin copy. Index is automatically incremented by length.
length
Type: SystemInt32
Number of bytes to copy from source.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Source index is always zero so hence not requested. This function automatically advances index for convenience.
See Also

Reference

Common Class
CopyImage Overload
GSF.PhasorProtocols Namespace


Common.DeserializeConfigurationFrame Method

Grid Solutions Framework CommonDeserializeConfigurationFrame Method
Overload List
Name | Description
DeserializeConfigurationFrame(Stream) | Deserializes a configuration frame from an XML stream.
DeserializeConfigurationFrame(String) | Deserializes a configuration frame from an XML file.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols Namespace


Common.DeserializeConfigurationFrame Method (Stream)

Grid Solutions Framework CommonDeserializeConfigurationFrame Method (Stream)
Deserializes a configuration frame from an XML stream.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IConfigurationFrame DeserializeConfigurationFrame(
    Stream configStream
)
Public Shared Function DeserializeConfigurationFrame (
    configStream As Stream
) As IConfigurationFrame
static member DeserializeConfigurationFrame :
        configStream : Stream -> IConfigurationFrame

GSF.PhasorProtocols.Common.DeserializeConfigurationFrame = function(configStream);
public:
static IConfigurationFrame^ DeserializeConfigurationFrame(
    Stream^ configStream
)

Parameters

configStream
Type: System.IOStream
Stream that contains an XML serialized configuration frame.

Return Value

Type: IConfigurationFrame
Deserialized IConfigurationFrame.
See Also

Reference

Common Class
DeserializeConfigurationFrame Overload
GSF.PhasorProtocols Namespace


Common.DeserializeConfigurationFrame Method (String)

Grid Solutions Framework CommonDeserializeConfigurationFrame Method (String)
Deserializes a configuration frame from an XML file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IConfigurationFrame DeserializeConfigurationFrame(
    string configFileName
)
Public Shared Function DeserializeConfigurationFrame (
    configFileName As String
) As IConfigurationFrame
static member DeserializeConfigurationFrame :
        configFileName : string -> IConfigurationFrame

GSF.PhasorProtocols.Common.DeserializeConfigurationFrame = function(configFileName);
public:
static IConfigurationFrame^ DeserializeConfigurationFrame(
    String^ configFileName
)

Parameters

configFileName
Type: SystemString
Path and file name of XML configuration file.

Return Value

Type: IConfigurationFrame
Deserialized IConfigurationFrame.
See Also

Reference

Common Class
DeserializeConfigurationFrame Overload
GSF.PhasorProtocols Namespace


Common.GetFormattedProtocolName Method

Grid Solutions Framework CommonGetFormattedProtocolName Method
Returns display friendly protocol name.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetFormattedProtocolName(
    this PhasorProtocol protocol
)
<ExtensionAttribute>
Public Shared Function GetFormattedProtocolName (
    protocol As PhasorProtocol
) As String
static member GetFormattedProtocolName :
        protocol : PhasorProtocol -> string

GSF.PhasorProtocols.Common.GetFormattedProtocolName = function(protocol);
public:
[ExtensionAttribute]
static String^ GetFormattedProtocolName(
    PhasorProtocol protocol
)

Parameters

protocol
Type: GSF.PhasorProtocolsPhasorProtocol
PhasorProtocol to return display name for.

Return Value

Type: String
Friendly protocol display name for specified phasor protocol.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PhasorProtocol. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols Namespace


Common.GetValidLabel Method

Grid Solutions Framework CommonGetValidLabel Method
Removes control characters and null from a string.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetValidLabel(
    this string value
)
<ExtensionAttribute>
Public Shared Function GetValidLabel (
    value As String
) As String
static member GetValidLabel :
        value : string -> string

GSF.PhasorProtocols.Common.GetValidLabel = function(value);
public:
[ExtensionAttribute]
static String^ GetValidLabel(
    String^ value
)

Parameters

value
Type: SystemString
Source String to validate.

Return Value

Type: String
value with control characters and nulls removed.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Strings reported from field devices can be full of inconsistencies, this function helps clean-up the strings.
See Also

Reference

Common Class
GSF.PhasorProtocols Namespace


CommonStatusFlags Enumeration

Grid Solutions Framework CommonStatusFlags Enumeration
Protocol independent common status flags enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum CommonStatusFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration CommonStatusFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type CommonStatusFlags
GSF.PhasorProtocols.CommonStatusFlags = function();
GSF.PhasorProtocols.CommonStatusFlags.createEnum('GSF.PhasorProtocols.CommonStatusFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class CommonStatusFlags
Members
Member name | Value | Description
DataDiscarded | 1048576 | Data was discarded from real-time stream due to late arrival (0 when not discarded, 1 when discarded).
DataIsValid | 524288 | Data is valid (0 when device data is valid, 1 when invalid or device is in test mode).
SynchronizationIsValid | 262144 | Synchronization is valid (0 when in device is in sync, 1 when it is not).
DataSortingType | 131072 | Data sorting type, 0 by timestamp, 1 by arrival.
DeviceError | 65536 | Device error (including configuration error), 0 when no error.
ReservedFlags | 4292870144 | Reserved bits for future common flags, presently set to 0.
NoFlags | 0 | No flags.
Remarks

These flags are expected to exist in the high-word of a double-word flag set such that original word flags remain in-tact in low-word of double-word flag set.

Note that value being stored in a historian using a 32-bit single precision floating number value will only have castable conversion accuracy back to an unsigned 32-bit integer up to the 24th bit, so any bits used beyond Bit23 will be lossy.

See Also

Reference

GSF.PhasorProtocols Namespace


CompositeFrequencyValue Enumeration

Grid Solutions Framework CompositeFrequencyValue Enumeration
Composite frequency value indices enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum CompositeFrequencyValue
Public Enumeration CompositeFrequencyValue
type CompositeFrequencyValue
GSF.PhasorProtocols.CompositeFrequencyValue = function();
GSF.PhasorProtocols.CompositeFrequencyValue.createEnum('GSF.PhasorProtocols.CompositeFrequencyValue', false);
public enum class CompositeFrequencyValue
Members
Member name | Value | Description
Frequency | 0 | Composite frequency value index.
DfDt | 1 | Composite dF/dt value index.
See Also

Reference

GSF.PhasorProtocols Namespace


CompositePhasorValue Enumeration

Grid Solutions Framework CompositePhasorValue Enumeration
Composite polar value indices enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum CompositePhasorValue
Public Enumeration CompositePhasorValue
type CompositePhasorValue
GSF.PhasorProtocols.CompositePhasorValue = function();
GSF.PhasorProtocols.CompositePhasorValue.createEnum('GSF.PhasorProtocols.CompositePhasorValue', false);
public enum class CompositePhasorValue
Members
Member name | Value | Description
Angle | 0 | Composite angle value index.
Magnitude | 1 | Composite magnitude value index.
See Also

Reference

GSF.PhasorProtocols Namespace


ConfigurationCellBase Class

Grid Solutions Framework ConfigurationCellBase Class
Represents the protocol independent common implementation of all configuration elements for cells in a IConfigurationFrame.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ConfigurationCellBase : ChannelCellBase,
    IConfigurationCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IConfigurationCell>, IComparable<IConfigurationCell>, IComparable
<SerializableAttribute>
Public MustInherit Class ConfigurationCellBase
    Inherits ChannelCellBase
    Implements IConfigurationCell, IChannelCell, IChannel, ISupportBinaryImage,
    ISerializable, IEquatable(Of IConfigurationCell), IComparable(Of IConfigurationCell),
    IComparable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ConfigurationCellBase =
    class
        inherit ChannelCellBase
        interface IConfigurationCell
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IConfigurationCell>
        interface IComparable<IConfigurationCell>
        interface IComparable
    end
GSF.PhasorProtocols.ConfigurationCellBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ConfigurationCellBase',
    GSF.PhasorProtocols.ChannelCellBase,
    GSF.PhasorProtocols.IConfigurationCell,
    GSF.PhasorProtocols.IChannelCell,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable,
    IEquatable`1,
    IComparable`1,
    IComparable);
[SerializableAttribute]
public ref class ConfigurationCellBase abstract : public ChannelCellBase,
    IConfigurationCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IConfigurationCell^>, IComparable<IConfigurationCell^>, IComparable

The ConfigurationCellBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationCellBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellBase from serialization parameters.
Protected method | ConfigurationCellBase(IConfigurationFrame, UInt16, Int32, Int32, Int32) | Creates a new ConfigurationCellBase from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ObjectEquals(Object).)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Overrides ChannelCellBaseToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCellBase.
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase.
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCellBase object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase.
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCellBase.
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase.
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase.
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase.
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase.
Public property | Parent | Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase.
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase.
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase.
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.AnonymousConfigurationCell
GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
GSF.PhasorProtocols.FNETConfigurationCell
GSF.PhasorProtocols.IEC61850_90_5ConfigurationCell
GSF.PhasorProtocols.IEEE1344ConfigurationCell
GSF.PhasorProtocols.IEEEC37_118ConfigurationCell
GSF.PhasorProtocols.MacrodyneConfigurationCell
GSF.PhasorProtocols.SelFastMessageConfigurationCell


ConfigurationCellBase Constructor

Grid Solutions Framework ConfigurationCellBase Constructor
Overload List
 | Name | Description
Protected method | ConfigurationCellBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellBase from serialization parameters.
Protected method | ConfigurationCellBase(IConfigurationFrame, UInt16, Int32, Int32, Int32) | Creates a new ConfigurationCellBase from specified parameters.
Top
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellBase Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellBase
GSF.PhasorProtocols.ConfigurationCellBase = function(info, context);
protected:
ConfigurationCellBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellBase Class
ConfigurationCellBase Overload
GSF.PhasorProtocols Namespace


ConfigurationCellBase Constructor (IConfigurationFrame, UInt16, Int32, Int32, Int32)

Grid Solutions Framework ConfigurationCellBase Constructor (IConfigurationFrame, UInt16, Int32, Int32, Int32)
Creates a new ConfigurationCellBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellBase(
    IConfigurationFrame parent,
    ushort idCode,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)
Protected Sub New (
    parent As IConfigurationFrame,
    idCode As UShort,
    maximumPhasors As Integer,
    maximumAnalogs As Integer,
    maximumDigitals As Integer
)
new :
        parent : IConfigurationFrame *
        idCode : uint16 *
        maximumPhasors : int *
        maximumAnalogs : int *
        maximumDigitals : int -> ConfigurationCellBase
GSF.PhasorProtocols.ConfigurationCellBase = function(parent, idCode, maximumPhasors, maximumAnalogs, maximumDigitals);
protected:
ConfigurationCellBase(
    IConfigurationFrame^ parent,
    unsigned short idCode,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationFrame
The reference to parent IConfigurationFrame of this ConfigurationCellBase.
idCode
Type: SystemUInt16
The numeric ID code for this ConfigurationCellBase.
maximumPhasors
Type: SystemInt32
Sets the maximum number of phasors for the PhasorDefinitions collection.
maximumAnalogs
Type: SystemInt32
Sets the maximum number of phasors for the AnalogDefinitions collection.
maximumDigitals
Type: SystemInt32
Sets the maximum number of phasors for the DigitalDefinitions collection.
See Also

Reference

ConfigurationCellBase Class
ConfigurationCellBase Overload
GSF.PhasorProtocols Namespace


ConfigurationCellBase Methods

Grid Solutions Framework ConfigurationCellBase Methods

The ConfigurationCellBase type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ObjectEquals(Object).)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ObjectGetHashCode.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Overrides ChannelCellBaseToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.CompareTo Method

Grid Solutions Framework ConfigurationCellBaseCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.
Top
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.CompareTo Method (Object)

Grid Solutions Framework ConfigurationCellBaseCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    Object obj
)
Public Overridable Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not an IConfigurationCell.
See Also

Reference

ConfigurationCellBase Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ConfigurationCellBase.CompareTo Method (IConfigurationCell)

Grid Solutions Framework ConfigurationCellBaseCompareTo Method (IConfigurationCell)
Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int CompareTo(
    IConfigurationCell other
)
Public Overridable Function CompareTo (
    other As IConfigurationCell
) As Integer
abstract CompareTo :
        other : IConfigurationCell -> int
override CompareTo :
        other : IConfigurationCell -> int
function CompareTo(other);
public:
virtual int CompareTo(
    IConfigurationCell^ other
)

Parameters

other
Type: GSF.PhasorProtocolsIConfigurationCell
A IConfigurationCell object to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

ConfigurationCellBase Class
CompareTo Overload
GSF.PhasorProtocols Namespace


ConfigurationCellBase.Equals Method

Grid Solutions Framework ConfigurationCellBaseEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ObjectEquals(Object).)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value.
Top
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.Equals Method (Object)

Grid Solutions Framework ConfigurationCellBaseEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of IConfigurationCell and equals the value of this instance; otherwise, False.
Exceptions
Exception | Condition
ArgumentException | value is not an IConfigurationCell.
See Also

Reference

ConfigurationCellBase Class
Equals Overload
GSF.PhasorProtocols Namespace


ConfigurationCellBase.Equals Method (IConfigurationCell)

Grid Solutions Framework ConfigurationCellBaseEquals Method (IConfigurationCell)
Returns a value indicating whether this instance is equal to specified IConfigurationCell value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    IConfigurationCell other
)
Public Function Equals (
    other As IConfigurationCell
) As Boolean
abstract Equals :
        other : IConfigurationCell -> bool
override Equals :
        other : IConfigurationCell -> bool
function Equals(other);
public:
virtual bool Equals(
    IConfigurationCell^ other
) sealed

Parameters

other
Type: GSF.PhasorProtocolsIConfigurationCell
A IConfigurationCell object to compare to this instance.

Return Value

Type: Boolean
True if other has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

ConfigurationCellBase Class
Equals Overload
GSF.PhasorProtocols Namespace


ConfigurationCellBase.GetHashCode Method

Grid Solutions Framework ConfigurationCellBaseGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.GetObjectData Method

Grid Solutions Framework ConfigurationCellBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.ParseBodyImage Method

Grid Solutions Framework ConfigurationCellBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.ParseFooterImage Method

Grid Solutions Framework ConfigurationCellBaseParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.ParseHeaderImage Method

Grid Solutions Framework ConfigurationCellBaseParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.ToString Method

Grid Solutions Framework ConfigurationCellBaseToString Method
Gets the string respresentation of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
String respresentation of this ConfigurationCellBase.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase Properties

Grid Solutions Framework ConfigurationCellBase Properties

The ConfigurationCellBase type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCellBase.
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase.
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCellBase object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase.
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCellBase.
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase.
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase.
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase.
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase.
Public property | Parent | Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase.
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase.
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase.
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellBaseAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DataFormat AnalogDataFormat { get; set; }
Public MustOverride Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set

function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () abstract;
    void set (DataFormat value) abstract;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.AnalogDefinitions Property

Grid Solutions Framework ConfigurationCellBaseAnalogDefinitions Property
Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AnalogDefinitionCollection AnalogDefinitions { get; }
Public Overridable ReadOnly Property AnalogDefinitions As AnalogDefinitionCollection
    Get
abstract AnalogDefinitions : AnalogDefinitionCollection with get
override AnalogDefinitions : AnalogDefinitionCollection with get
function get_AnalogDefinitions();

public:
virtual property AnalogDefinitionCollection^ AnalogDefinitions {
    AnalogDefinitionCollection^ get ();
}

Property Value

Type: AnalogDefinitionCollection

Implements

IConfigurationCellAnalogDefinitions
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.Attributes Property

Grid Solutions Framework ConfigurationCellBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationCellBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.BodyImage Property

Grid Solutions Framework ConfigurationCellBaseBodyImage Property
Gets the binary body image of the ConfigurationCellBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
Channel names of IEEE protocol configuration frames are common in order and type so these are defined in the base class.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.BodyLength Property

Grid Solutions Framework ConfigurationCellBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
Channel names of IEEE protocol configuration frames are common in order and type so these are defined in the base class.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.DigitalDefinitions Property

Grid Solutions Framework ConfigurationCellBaseDigitalDefinitions Property
Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DigitalDefinitionCollection DigitalDefinitions { get; }
Public Overridable ReadOnly Property DigitalDefinitions As DigitalDefinitionCollection
    Get
abstract DigitalDefinitions : DigitalDefinitionCollection with get
override DigitalDefinitions : DigitalDefinitionCollection with get
function get_DigitalDefinitions();

public:
virtual property DigitalDefinitionCollection^ DigitalDefinitions {
    DigitalDefinitionCollection^ get ();
}

Property Value

Type: DigitalDefinitionCollection

Implements

IConfigurationCellDigitalDefinitions
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.FooterImage Property

Grid Solutions Framework ConfigurationCellBaseFooterImage Property
Gets the binary footer image of the ConfigurationCellBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
Bottom of the IEEE protocol configuration frames contain a nominal frequency definition, so base implementation exposes frequency definition as the footer.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.FooterLength Property

Grid Solutions Framework ConfigurationCellBaseFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
Bottom of the IEEE protocol configuration frames contain a nominal frequency definition, so base implementation exposes frequency definition as the footer.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.FrameRate Property

Grid Solutions Framework ConfigurationCellBaseFrameRate Property
Gets the specified frame rate of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ushort FrameRate { get; }
Public Overridable ReadOnly Property FrameRate As UShort
    Get
abstract FrameRate : uint16 with get
override FrameRate : uint16 with get
function get_FrameRate();

public:
virtual property unsigned short FrameRate {
    unsigned short get ();
}

Property Value

Type: UInt16

Implements

IConfigurationCellFrameRate
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellBaseFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DataFormat FrequencyDataFormat { get; set; }
Public MustOverride Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set

function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () abstract;
    void set (DataFormat value) abstract;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.FrequencyDefinition Property

Grid Solutions Framework ConfigurationCellBaseFrequencyDefinition Property
Gets or sets the IFrequencyDefinition of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IFrequencyDefinition FrequencyDefinition { get; set; }
Public Overridable Property FrequencyDefinition As IFrequencyDefinition
    Get
    Set
abstract FrequencyDefinition : IFrequencyDefinition with get, set
override FrequencyDefinition : IFrequencyDefinition with get, set
function get_FrequencyDefinition();
function set_FrequencyDefinition(value);
public:
virtual property IFrequencyDefinition^ FrequencyDefinition {
    IFrequencyDefinition^ get ();
    void set (IFrequencyDefinition^ value);
}

Property Value

Type: IFrequencyDefinition

Implements

IConfigurationCellFrequencyDefinition
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.HeaderImage Property

Grid Solutions Framework ConfigurationCellBaseHeaderImage Property
Gets the binary header image of the ConfigurationCellBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
Base implementation provides station name image from the header which is common to configuration frame headers in IEEE protocols.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.HeaderLength Property

Grid Solutions Framework ConfigurationCellBaseHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
Base implementation provides station name length from the header which is common to configuration frame headers in IEEE protocols.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.IDLabel Property

Grid Solutions Framework ConfigurationCellBaseIDLabel Property
Gets or sets the ID label of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string IDLabel { get; set; }
Public Overridable Property IDLabel As String
    Get
    Set
abstract IDLabel : string with get, set
override IDLabel : string with get, set
function get_IDLabel();
function set_IDLabel(value);
public:
virtual property String^ IDLabel {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IConfigurationCellIDLabel
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.IDLabelImage Property

Grid Solutions Framework ConfigurationCellBaseIDLabelImage Property
Gets the binary image of the IDLabel of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte[] IDLabelImage { get; }
Public Overridable ReadOnly Property IDLabelImage As Byte()
    Get
abstract IDLabelImage : byte[] with get
override IDLabelImage : byte[] with get
function get_IDLabelImage();

public:
virtual property array<unsigned char>^ IDLabelImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte

Implements

IConfigurationCellIDLabelImage
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.IDLabelLength Property

Grid Solutions Framework ConfigurationCellBaseIDLabelLength Property
Gets the length of the IDLabel of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IDLabelLength { get; }
Public Overridable ReadOnly Property IDLabelLength As Integer
    Get
abstract IDLabelLength : int with get
override IDLabelLength : int with get
function get_IDLabelLength();

public:
virtual property int IDLabelLength {
    int get ();
}

Property Value

Type: Int32

Implements

IConfigurationCellIDLabelLength
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.MaximumStationNameLength Property

Grid Solutions Framework ConfigurationCellBaseMaximumStationNameLength Property
Gets the maximum length of the StationName of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int MaximumStationNameLength { get; }
Public Overridable ReadOnly Property MaximumStationNameLength As Integer
    Get
abstract MaximumStationNameLength : int with get
override MaximumStationNameLength : int with get
function get_MaximumStationNameLength();

public:
virtual property int MaximumStationNameLength {
    int get ();
}

Property Value

Type: Int32

Implements

IConfigurationCellMaximumStationNameLength
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.NominalFrequency Property

Grid Solutions Framework ConfigurationCellBaseNominalFrequency Property
Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual LineFrequency NominalFrequency { get; set; }
Public Overridable Property NominalFrequency As LineFrequency
    Get
    Set
abstract NominalFrequency : LineFrequency with get, set
override NominalFrequency : LineFrequency with get, set
function get_NominalFrequency();
function set_NominalFrequency(value);
public:
virtual property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}

Property Value

Type: LineFrequency

Implements

IConfigurationCellNominalFrequency
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.Parent Property

Grid Solutions Framework ConfigurationCellBaseParent Property
Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationFrame Parent { get; set; }
Public Overridable Property Parent As IConfigurationFrame
    Get
    Set
abstract Parent : IConfigurationFrame with get, set
override Parent : IConfigurationFrame with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property IConfigurationFrame^ Parent {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}

Property Value

Type: IConfigurationFrame

Implements

IConfigurationCellParent
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.PhasorAngleFormat Property

Grid Solutions Framework ConfigurationCellBasePhasorAngleFormat Property
Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AngleFormat PhasorAngleFormat { get; set; }
Public Overridable Property PhasorAngleFormat As AngleFormat
    Get
    Set
abstract PhasorAngleFormat : AngleFormat with get, set
override PhasorAngleFormat : AngleFormat with get, set
function get_PhasorAngleFormat();
function set_PhasorAngleFormat(value);
public:
virtual property AngleFormat PhasorAngleFormat {
    AngleFormat get ();
    void set (AngleFormat value);
}

Property Value

Type: AngleFormat

Implements

IConfigurationCellPhasorAngleFormat
Remarks
Base class defines default angle format since this is rarely not radians.
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellBasePhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract CoordinateFormat PhasorCoordinateFormat { get; set; }
Public MustOverride Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set

function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () abstract;
    void set (CoordinateFormat value) abstract;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellBasePhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DataFormat PhasorDataFormat { get; set; }
Public MustOverride Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set

function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () abstract;
    void set (DataFormat value) abstract;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.PhasorDefinitions Property

Grid Solutions Framework ConfigurationCellBasePhasorDefinitions Property
Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinitionCollection PhasorDefinitions { get; }
Public Overridable ReadOnly Property PhasorDefinitions As PhasorDefinitionCollection
    Get
abstract PhasorDefinitions : PhasorDefinitionCollection with get
override PhasorDefinitions : PhasorDefinitionCollection with get
function get_PhasorDefinitions();

public:
virtual property PhasorDefinitionCollection^ PhasorDefinitions {
    PhasorDefinitionCollection^ get ();
}

Property Value

Type: PhasorDefinitionCollection

Implements

IConfigurationCellPhasorDefinitions
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.RevisionCount Property

Grid Solutions Framework ConfigurationCellBaseRevisionCount Property
Gets or sets the revision count of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ushort RevisionCount { get; set; }
Public Overridable Property RevisionCount As UShort
    Get
    Set
abstract RevisionCount : uint16 with get, set
override RevisionCount : uint16 with get, set
function get_RevisionCount();
function set_RevisionCount(value);
public:
virtual property unsigned short RevisionCount {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16

Implements

IConfigurationCellRevisionCount
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.State Property

Grid Solutions Framework ConfigurationCellBaseState Property
Gets or sets the parsing state for the this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationCellParsingState State { get; set; }
Public Overridable Property State As IConfigurationCellParsingState
    Get
    Set
abstract State : IConfigurationCellParsingState with get, set
override State : IConfigurationCellParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IConfigurationCellParsingState^ State {
    IConfigurationCellParsingState^ get ();
    void set (IConfigurationCellParsingState^ value);
}

Property Value

Type: IConfigurationCellParsingState

Implements

IConfigurationCellState
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.StationName Property

Grid Solutions Framework ConfigurationCellBaseStationName Property
Gets or sets the station name of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string StationName { get; set; }
Public Overridable Property StationName As String
    Get
    Set
abstract StationName : string with get, set
override StationName : string with get, set
function get_StationName();
function set_StationName(value);
public:
virtual property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IConfigurationCellStationName
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellBase.StationNameImage Property

Grid Solutions Framework ConfigurationCellBaseStationNameImage Property
Gets the binary image of the StationName of this ConfigurationCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte[] StationNameImage { get; }
Public Overridable ReadOnly Property StationNameImage As Byte()
    Get
abstract StationNameImage : byte[] with get
override StationNameImage : byte[] with get
function get_StationNameImage();

public:
virtual property array<unsigned char>^ StationNameImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte

Implements

IConfigurationCellStationNameImage
See Also

Reference

ConfigurationCellBase Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a protocol independent collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ChannelCellCollectionBase<IConfigurationCell>
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ChannelCellCollectionBase(Of IConfigurationCell)
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ChannelCellCollectionBase<IConfigurationCell>
    end
GSF.PhasorProtocols.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.ConfigurationCellCollection',
    GSF.PhasorProtocols.ChannelCellCollectionBase`1);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ChannelCellCollectionBase<IConfigurationCell^>

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection(Int32, Boolean) | Creates a new ConfigurationCellCollection from specified parameters.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code.
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label.
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code.
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label.
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.AnonymousConfigurationCellCollection
GSF.PhasorProtocols.BPAPDCstreamConfigurationCellCollection
GSF.PhasorProtocols.FNETConfigurationCellCollection
GSF.PhasorProtocols.IEC61850_90_5ConfigurationCellCollection
GSF.PhasorProtocols.IEEE1344ConfigurationCellCollection
GSF.PhasorProtocols.IEEEC37_118ConfigurationCellCollection
GSF.PhasorProtocols.MacrodyneConfigurationCellCollection
GSF.PhasorProtocols.SelFastMessageConfigurationCellCollection


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection(Int32, Boolean) | Creates a new ConfigurationCellCollection from specified parameters.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection Constructor (Int32, Boolean)

Grid Solutions Framework ConfigurationCellCollection Constructor (Int32, Boolean)
Creates a new ConfigurationCellCollection from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection(
    int lastValidIndex,
    bool constantCellLength
)
Public Sub New (
    lastValidIndex As Integer,
    constantCellLength As Boolean
)
new :
        lastValidIndex : int *
        constantCellLength : bool -> ConfigurationCellCollection
GSF.PhasorProtocols.ConfigurationCellCollection = function(lastValidIndex, constantCellLength);
public:
ConfigurationCellCollection(
    int lastValidIndex,
    bool constantCellLength
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
constantCellLength
Type: SystemBoolean
Sets flag that determines if the lengths of IConfigurationCell elements in this ConfigurationCellCollection are constant.
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code.
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label.
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code.
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label.
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection.IndexOfIDCode Method

Grid Solutions Framework ConfigurationCellCollectionIndexOfIDCode Method
Attempts to find the index of the IConfigurationCell with the specified ID code.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IndexOfIDCode(
    ushort idCode
)
Public Overridable Function IndexOfIDCode (
    idCode As UShort
) As Integer
abstract IndexOfIDCode :
        idCode : uint16 -> int
override IndexOfIDCode :
        idCode : uint16 -> int
function IndexOfIDCode(idCode);
public:
virtual int IndexOfIDCode(
    unsigned short idCode
)

Parameters

idCode
Type: SystemUInt16
The IDCode to find.

Return Value

Type: Int32
Index of the ConfigurationCellCollection that contains the specified idCode; otherwise, -1.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection.IndexOfIDLabel Method

Grid Solutions Framework ConfigurationCellCollectionIndexOfIDLabel Method
Attempts to find the index of the IConfigurationCell with the specified ID label.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IndexOfIDLabel(
    string label
)
Public Overridable Function IndexOfIDLabel (
    label As String
) As Integer
abstract IndexOfIDLabel :
        label : string -> int
override IndexOfIDLabel :
        label : string -> int
function IndexOfIDLabel(label);
public:
virtual int IndexOfIDLabel(
    String^ label
)

Parameters

label
Type: SystemString
The IDLabel to find.

Return Value

Type: Int32
Index of the ConfigurationCellCollection that contains the specified label; otherwise, -1.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection.IndexOfStationName Method

Grid Solutions Framework ConfigurationCellCollectionIndexOfStationName Method
Attempts to find the index of the IConfigurationCell with the specified station name.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int IndexOfStationName(
    string stationName
)
Public Overridable Function IndexOfStationName (
    stationName As String
) As Integer
abstract IndexOfStationName :
        stationName : string -> int
override IndexOfStationName :
        stationName : string -> int
function IndexOfStationName(stationName);
public:
virtual int IndexOfStationName(
    String^ stationName
)

Parameters

stationName
Type: SystemString
The StationName to find.

Return Value

Type: Int32
Index of the ConfigurationCellCollection that contains the specified stationName; otherwise, -1.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection.TryGetByIDCode Method

Grid Solutions Framework ConfigurationCellCollectionTryGetByIDCode Method
Attempts to get IConfigurationCell with the specified ID code.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryGetByIDCode(
    ushort idCode,
    out IConfigurationCell configurationCell
)
Public Overridable Function TryGetByIDCode (
    idCode As UShort,
    <OutAttribute> ByRef configurationCell As IConfigurationCell
) As Boolean
abstract TryGetByIDCode :
        idCode : uint16 *
        configurationCell : IConfigurationCell byref -> bool
override TryGetByIDCode :
        idCode : uint16 *
        configurationCell : IConfigurationCell byref -> bool
function TryGetByIDCode(idCode, configurationCell);
public:
virtual bool TryGetByIDCode(
    unsigned short idCode,
    [OutAttribute] IConfigurationCell^% configurationCell
)

Parameters

idCode
Type: SystemUInt16
The IDCode to find.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
When this method returns, contains the IConfigurationCell with the specified idCode, if found; otherwise, null is returned.

Return Value

Type: Boolean
true if the ConfigurationCellCollection contains an element with the specified idCode; otherwise, false.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection.TryGetByIDLabel Method

Grid Solutions Framework ConfigurationCellCollectionTryGetByIDLabel Method
Attempts to get IConfigurationCell with the specified label.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryGetByIDLabel(
    string label,
    out IConfigurationCell configurationCell
)
Public Overridable Function TryGetByIDLabel (
    label As String,
    <OutAttribute> ByRef configurationCell As IConfigurationCell
) As Boolean
abstract TryGetByIDLabel :
        label : string *
        configurationCell : IConfigurationCell byref -> bool
override TryGetByIDLabel :
        label : string *
        configurationCell : IConfigurationCell byref -> bool
function TryGetByIDLabel(label, configurationCell);
public:
virtual bool TryGetByIDLabel(
    String^ label,
    [OutAttribute] IConfigurationCell^% configurationCell
)

Parameters

label
Type: SystemString
The IDLabel to find.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
When this method returns, contains the IConfigurationCell with the specified label, if found; otherwise, null is returned.

Return Value

Type: Boolean
true if the ConfigurationCellCollection contains an element with the specified label; otherwise, false.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection.TryGetByStationName Method

Grid Solutions Framework ConfigurationCellCollectionTryGetByStationName Method
Attempts to get IConfigurationCell with the specified station name.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryGetByStationName(
    string stationName,
    out IConfigurationCell configurationCell
)
Public Overridable Function TryGetByStationName (
    stationName As String,
    <OutAttribute> ByRef configurationCell As IConfigurationCell
) As Boolean
abstract TryGetByStationName :
        stationName : string *
        configurationCell : IConfigurationCell byref -> bool
override TryGetByStationName :
        stationName : string *
        configurationCell : IConfigurationCell byref -> bool
function TryGetByStationName(stationName, configurationCell);
public:
virtual bool TryGetByStationName(
    String^ stationName,
    [OutAttribute] IConfigurationCell^% configurationCell
)

Parameters

stationName
Type: SystemString
The StationName to find.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
When this method returns, contains the IConfigurationCell with the specified stationName, if found; otherwise, null is returned.

Return Value

Type: Boolean
true if the ConfigurationCellCollection contains an element with the specified stationName; otherwise, false.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols Namespace


ConfigurationCellParsingState Class

Grid Solutions Framework ConfigurationCellParsingState Class
Represents the protocol independent common implementation of the parsing state used by any IConfigurationCell.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelCellParsingStateBase
GSF.PhasorProtocolsConfigurationCellParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConfigurationCellParsingState : ChannelCellParsingStateBase,
    IConfigurationCellParsingState, IChannelCellParsingState, IChannelParsingState
Public Class ConfigurationCellParsingState
    Inherits ChannelCellParsingStateBase
    Implements IConfigurationCellParsingState, IChannelCellParsingState, IChannelParsingState
type ConfigurationCellParsingState =
    class
        inherit ChannelCellParsingStateBase
        interface IConfigurationCellParsingState
        interface IChannelCellParsingState
        interface IChannelParsingState
    end
GSF.PhasorProtocols.ConfigurationCellParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.ConfigurationCellParsingState',
    GSF.PhasorProtocols.ChannelCellParsingStateBase,
    GSF.PhasorProtocols.IConfigurationCellParsingState,
    GSF.PhasorProtocols.IChannelCellParsingState,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class ConfigurationCellParsingState : public ChannelCellParsingStateBase,
    IConfigurationCellParsingState, IChannelCellParsingState, IChannelParsingState

The ConfigurationCellParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellParsingState | Creates a new ConfigurationCellParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | CreateNewAnalogDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IAnalogDefinition objects.
Public property | CreateNewDigitalDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IDigitalDefinition objects.
Public property | CreateNewFrequencyDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IFrequencyDefinition objects.
Public property | CreateNewPhasorDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IPhasorDefinition objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ConfigurationCellParsingState Constructor

Grid Solutions Framework ConfigurationCellParsingState Constructor
Creates a new ConfigurationCellParsingState from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellParsingState(
    CreateNewDefinitionFunction<IPhasorDefinition> createNewPhasorDefinition,
    CreateNewDefinitionFunction<IFrequencyDefinition> createNewFrequencyDefinition,
    CreateNewDefinitionFunction<IAnalogDefinition> createNewAnalogDefinition,
    CreateNewDefinitionFunction<IDigitalDefinition> createNewDigitalDefinition
)
Public Sub New (
    createNewPhasorDefinition As CreateNewDefinitionFunction(Of IPhasorDefinition),
    createNewFrequencyDefinition As CreateNewDefinitionFunction(Of IFrequencyDefinition),
    createNewAnalogDefinition As CreateNewDefinitionFunction(Of IAnalogDefinition),
    createNewDigitalDefinition As CreateNewDefinitionFunction(Of IDigitalDefinition)
)
new :
        createNewPhasorDefinition : CreateNewDefinitionFunction<IPhasorDefinition> *
        createNewFrequencyDefinition : CreateNewDefinitionFunction<IFrequencyDefinition> *
        createNewAnalogDefinition : CreateNewDefinitionFunction<IAnalogDefinition> *
        createNewDigitalDefinition : CreateNewDefinitionFunction<IDigitalDefinition> -> ConfigurationCellParsingState
GSF.PhasorProtocols.ConfigurationCellParsingState = function(createNewPhasorDefinition, createNewFrequencyDefinition, createNewAnalogDefinition, createNewDigitalDefinition);
public:
ConfigurationCellParsingState(
    CreateNewDefinitionFunction<IPhasorDefinition^>^ createNewPhasorDefinition,
    CreateNewDefinitionFunction<IFrequencyDefinition^>^ createNewFrequencyDefinition,
    CreateNewDefinitionFunction<IAnalogDefinition^>^ createNewAnalogDefinition,
    CreateNewDefinitionFunction<IDigitalDefinition^>^ createNewDigitalDefinition
)

Parameters

createNewPhasorDefinition
Type: GSF.PhasorProtocolsCreateNewDefinitionFunction IPhasorDefinition
Reference to delegate to create new IPhasorDefinition instances.
createNewFrequencyDefinition
Type: GSF.PhasorProtocolsCreateNewDefinitionFunction IFrequencyDefinition
Reference to delegate to create new IFrequencyDefinition instances.
createNewAnalogDefinition
Type: GSF.PhasorProtocolsCreateNewDefinitionFunction IAnalogDefinition
Reference to delegate to create new IAnalogDefinition instances.
createNewDigitalDefinition
Type: GSF.PhasorProtocolsCreateNewDefinitionFunction IDigitalDefinition
Reference to delegate to create new IDigitalDefinition instances.
See Also

Reference

ConfigurationCellParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationCellParsingState Methods

Grid Solutions Framework ConfigurationCellParsingState Methods

The ConfigurationCellParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationCellParsingState Properties

Grid Solutions Framework ConfigurationCellParsingState Properties

The ConfigurationCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | CreateNewAnalogDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IAnalogDefinition objects.
Public property | CreateNewDigitalDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IDigitalDefinition objects.
Public property | CreateNewFrequencyDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IFrequencyDefinition objects.
Public property | CreateNewPhasorDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IPhasorDefinition objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Top
See Also

Reference

ConfigurationCellParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationCellParsingState.CreateNewAnalogDefinition Property

Grid Solutions Framework ConfigurationCellParsingStateCreateNewAnalogDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IAnalogDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewDefinitionFunction<IAnalogDefinition> CreateNewAnalogDefinition { get; }
Public Overridable ReadOnly Property CreateNewAnalogDefinition As CreateNewDefinitionFunction(Of IAnalogDefinition)
    Get
abstract CreateNewAnalogDefinition : CreateNewDefinitionFunction<IAnalogDefinition> with get
override CreateNewAnalogDefinition : CreateNewDefinitionFunction<IAnalogDefinition> with get
function get_CreateNewAnalogDefinition();

public:
virtual property CreateNewDefinitionFunction<IAnalogDefinition^>^ CreateNewAnalogDefinition {
    CreateNewDefinitionFunction<IAnalogDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IAnalogDefinition

Implements

IConfigurationCellParsingStateCreateNewAnalogDefinition
See Also

Reference

ConfigurationCellParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationCellParsingState.CreateNewDigitalDefinition Property

Grid Solutions Framework ConfigurationCellParsingStateCreateNewDigitalDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IDigitalDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewDefinitionFunction<IDigitalDefinition> CreateNewDigitalDefinition { get; }
Public Overridable ReadOnly Property CreateNewDigitalDefinition As CreateNewDefinitionFunction(Of IDigitalDefinition)
    Get
abstract CreateNewDigitalDefinition : CreateNewDefinitionFunction<IDigitalDefinition> with get
override CreateNewDigitalDefinition : CreateNewDefinitionFunction<IDigitalDefinition> with get
function get_CreateNewDigitalDefinition();

public:
virtual property CreateNewDefinitionFunction<IDigitalDefinition^>^ CreateNewDigitalDefinition {
    CreateNewDefinitionFunction<IDigitalDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IDigitalDefinition

Implements

IConfigurationCellParsingStateCreateNewDigitalDefinition
See Also

Reference

ConfigurationCellParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationCellParsingState.CreateNewFrequencyDefinition Property

Grid Solutions Framework ConfigurationCellParsingStateCreateNewFrequencyDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IFrequencyDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewDefinitionFunction<IFrequencyDefinition> CreateNewFrequencyDefinition { get; }
Public Overridable ReadOnly Property CreateNewFrequencyDefinition As CreateNewDefinitionFunction(Of IFrequencyDefinition)
    Get
abstract CreateNewFrequencyDefinition : CreateNewDefinitionFunction<IFrequencyDefinition> with get
override CreateNewFrequencyDefinition : CreateNewDefinitionFunction<IFrequencyDefinition> with get
function get_CreateNewFrequencyDefinition();

public:
virtual property CreateNewDefinitionFunction<IFrequencyDefinition^>^ CreateNewFrequencyDefinition {
    CreateNewDefinitionFunction<IFrequencyDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IFrequencyDefinition

Implements

IConfigurationCellParsingStateCreateNewFrequencyDefinition
See Also

Reference

ConfigurationCellParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationCellParsingState.CreateNewPhasorDefinition Property

Grid Solutions Framework ConfigurationCellParsingStateCreateNewPhasorDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IPhasorDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewDefinitionFunction<IPhasorDefinition> CreateNewPhasorDefinition { get; }
Public Overridable ReadOnly Property CreateNewPhasorDefinition As CreateNewDefinitionFunction(Of IPhasorDefinition)
    Get
abstract CreateNewPhasorDefinition : CreateNewDefinitionFunction<IPhasorDefinition> with get
override CreateNewPhasorDefinition : CreateNewDefinitionFunction<IPhasorDefinition> with get
function get_CreateNewPhasorDefinition();

public:
virtual property CreateNewDefinitionFunction<IPhasorDefinition^>^ CreateNewPhasorDefinition {
    CreateNewDefinitionFunction<IPhasorDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IPhasorDefinition

Implements

IConfigurationCellParsingStateCreateNewPhasorDefinition
See Also

Reference

ConfigurationCellParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase Class

Grid Solutions Framework ConfigurationFrameBase Class
Represents the protocol independent common implementation of any IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ConfigurationFrameBase : ChannelFrameBase<IConfigurationCell>,
    IConfigurationFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
<SerializableAttribute>
Public MustInherit Class ConfigurationFrameBase
    Inherits ChannelFrameBase(Of IConfigurationCell)
    Implements IConfigurationFrame, IChannelFrame, IChannel, ISupportBinaryImage,
    IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),
    IComparable, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ConfigurationFrameBase =
    class
        inherit ChannelFrameBase<IConfigurationCell>
        interface IConfigurationFrame
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.ConfigurationFrameBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ConfigurationFrameBase',
    GSF.PhasorProtocols.ChannelFrameBase`1,
    GSF.PhasorProtocols.IConfigurationFrame,
    GSF.PhasorProtocols.IChannelFrame,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    GSF.TimeSeries.IFrame,
    IEquatable`1,
    IComparable`1,
    IComparable,
    ISerializable);
[SerializableAttribute]
public ref class ConfigurationFrameBase abstract : public ChannelFrameBase<IConfigurationCell^>,
    IConfigurationFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable

The ConfigurationFrameBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationFrameBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameBase from serialization parameters.
Protected method | ConfigurationFrameBase(UInt16, ConfigurationCellCollection, Ticks, UInt16) | Creates a new ConfigurationFrameBase from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Overrides ChannelFrameBaseTAllowQueuedPublication.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrameBase object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase.
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.AnonymousConfigurationFrame
GSF.PhasorProtocols.BPAPDCstreamConfigurationFrame
GSF.PhasorProtocols.FNETConfigurationFrame
GSF.PhasorProtocols.IEC61850_90_5ConfigurationFrame
GSF.PhasorProtocols.IEEE1344ConfigurationFrame
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
GSF.PhasorProtocols.MacrodyneConfigurationFrame
GSF.PhasorProtocols.SelFastMessageConfigurationFrame


ConfigurationFrameBase Constructor

Grid Solutions Framework ConfigurationFrameBase Constructor
Overload List
 | Name | Description
Protected method | ConfigurationFrameBase(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameBase from serialization parameters.
Protected method | ConfigurationFrameBase(UInt16, ConfigurationCellCollection, Ticks, UInt16) | Creates a new ConfigurationFrameBase from specified parameters.
Top
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrameBase Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrameBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrameBase
GSF.PhasorProtocols.ConfigurationFrameBase = function(info, context);
protected:
ConfigurationFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrameBase Class
ConfigurationFrameBase Overload
GSF.PhasorProtocols Namespace


ConfigurationFrameBase Constructor (UInt16, ConfigurationCellCollection, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrameBase Constructor (UInt16, ConfigurationCellCollection, Ticks, UInt16)
Creates a new ConfigurationFrameBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrameBase(
    ushort idCode,
    ConfigurationCellCollection cells,
    Ticks timestamp,
    ushort frameRate
)
Protected Sub New (
    idCode As UShort,
    cells As ConfigurationCellCollection,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        idCode : uint16 *
        cells : ConfigurationCellCollection *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrameBase
GSF.PhasorProtocols.ConfigurationFrameBase = function(idCode, cells, timestamp, frameRate);
protected:
ConfigurationFrameBase(
    unsigned short idCode,
    ConfigurationCellCollection^ cells,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

idCode
Type: SystemUInt16
The ID code of this ConfigurationFrameBase.
cells
Type: GSF.PhasorProtocolsConfigurationCellCollection
The reference to the collection of cells for this ConfigurationFrameBase.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrameBase.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrameBase.
See Also

Reference

ConfigurationFrameBase Class
ConfigurationFrameBase Overload
GSF.PhasorProtocols Namespace


ConfigurationFrameBase Methods

Grid Solutions Framework ConfigurationFrameBase Methods

The ConfigurationFrameBase type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.GetObjectData Method

Grid Solutions Framework ConfigurationFrameBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.SetNominalFrequency Method

Grid Solutions Framework ConfigurationFrameBaseSetNominalFrequency Method
Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SetNominalFrequency(
    LineFrequency value
)
Public Overridable Sub SetNominalFrequency (
    value As LineFrequency
)
abstract SetNominalFrequency :
        value : LineFrequency -> unit
override SetNominalFrequency :
        value : LineFrequency -> unit
function SetNominalFrequency(value);
public:
virtual void SetNominalFrequency(
    LineFrequency value
)

Parameters

value
Type: GSF.Units.EELineFrequency
New nominal LineFrequency for IFrequencyDefinition elements.

Implements

IConfigurationFrameSetNominalFrequency(LineFrequency)
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase Properties

Grid Solutions Framework ConfigurationFrameBase Properties

The ConfigurationFrameBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Overrides ChannelFrameBaseTAllowQueuedPublication.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrameBase object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase.
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.AllowQueuedPublication Property

Grid Solutions Framework ConfigurationFrameBaseAllowQueuedPublication Property
Gets flag that determines if frame image can be queued for publication or should be processed immediately.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool AllowQueuedPublication { get; }
Public Overrides ReadOnly Property AllowQueuedPublication As Boolean
    Get
abstract AllowQueuedPublication : bool with get
override AllowQueuedPublication : bool with get
function get_AllowQueuedPublication();

public:
virtual property bool AllowQueuedPublication {
    bool get () override;
}

Property Value

Type: Boolean
Remarks
Configuration frames are not queued for publication by default.
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.Attributes Property

Grid Solutions Framework ConfigurationFrameBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationFrameBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.Cells Property

Grid Solutions Framework ConfigurationFrameBaseCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As ConfigurationCellCollection
    Get
abstract Cells : ConfigurationCellCollection with get
override Cells : ConfigurationCellCollection with get
function get_Cells();

public:
virtual property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection

Implements

IConfigurationFrameCells
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.FrameRate Property

Grid Solutions Framework ConfigurationFrameBaseFrameRate Property
Gets or sets defined frame rate of this ConfigurationFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ushort FrameRate { get; set; }
Public Overridable Property FrameRate As UShort
    Get
    Set
abstract FrameRate : uint16 with get, set
override FrameRate : uint16 with get, set
function get_FrameRate();
function set_FrameRate(value);
public:
virtual property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16

Implements

IConfigurationFrameFrameRate
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.FrameType Property

Grid Solutions Framework ConfigurationFrameBaseFrameType Property
Gets the FundamentalFrameType for this ConfigurationFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
abstract FrameType : FundamentalFrameType with get
override FrameType : FundamentalFrameType with get
function get_FrameType();

public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}

Property Value

Type: FundamentalFrameType

Implements

IChannelFrameFrameType
IChannelFrameFrameType
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.State Property

Grid Solutions Framework ConfigurationFrameBaseState Property
Gets or sets the parsing state for the this ConfigurationFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationFrameParsingState State { get; set; }
Public Overridable Property State As IConfigurationFrameParsingState
    Get
    Set
abstract State : IConfigurationFrameParsingState with get, set
override State : IConfigurationFrameParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IConfigurationFrameParsingState^ State {
    IConfigurationFrameParsingState^ get ();
    void set (IConfigurationFrameParsingState^ value);
}

Property Value

Type: IConfigurationFrameParsingState

Implements

IConfigurationFrameState
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameBase.TicksPerFrame Property

Grid Solutions Framework ConfigurationFrameBaseTicksPerFrame Property
Gets the defined Ticks per frame of this ConfigurationFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual decimal TicksPerFrame { get; }
Public Overridable ReadOnly Property TicksPerFrame As Decimal
    Get
abstract TicksPerFrame : decimal with get
override TicksPerFrame : decimal with get
function get_TicksPerFrame();

public:
virtual property Decimal TicksPerFrame {
    Decimal get ();
}

Property Value

Type: Decimal

Implements

IConfigurationFrameTicksPerFrame
See Also

Reference

ConfigurationFrameBase Class
GSF.PhasorProtocols Namespace


ConfigurationFrameCollection Class

Grid Solutions Framework ConfigurationFrameCollection Class
Represents a protocol independent collection of IConfigurationFrame.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationFrame
GSF.CollectionsListCollection IConfigurationFrame
GSF.PhasorProtocolsChannelCollectionBase IConfigurationFrame
GSF.PhasorProtocolsChannelFrameCollectionBase IConfigurationFrame
GSF.PhasorProtocolsConfigurationFrameCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrameCollection : ChannelFrameCollectionBase<IConfigurationFrame>
<SerializableAttribute>
Public Class ConfigurationFrameCollection
    Inherits ChannelFrameCollectionBase(Of IConfigurationFrame)
[<SerializableAttribute>]
type ConfigurationFrameCollection =
    class
        inherit ChannelFrameCollectionBase<IConfigurationFrame>
    end
GSF.PhasorProtocols.ConfigurationFrameCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.ConfigurationFrameCollection',
    GSF.PhasorProtocols.ChannelFrameCollectionBase`1);
[SerializableAttribute]
public ref class ConfigurationFrameCollection : public ChannelFrameCollectionBase<IConfigurationFrame^>

The ConfigurationFrameCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrameCollection(Int32) | Creates a new ConfigurationFrameCollection using specified lastValidIndex.
Protected method | ConfigurationFrameCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelFrameCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ConfigurationFrameCollection Constructor

Grid Solutions Framework ConfigurationFrameCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrameCollection(Int32) | Creates a new ConfigurationFrameCollection using specified lastValidIndex.
Protected method | ConfigurationFrameCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrameCollection from serialization parameters.
Top
See Also

Reference

ConfigurationFrameCollection Class
GSF.PhasorProtocols Namespace


ConfigurationFrameCollection Constructor (Int32)

Grid Solutions Framework ConfigurationFrameCollection Constructor (Int32)
Creates a new ConfigurationFrameCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrameCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> ConfigurationFrameCollection
GSF.PhasorProtocols.ConfigurationFrameCollection = function(lastValidIndex);
public:
ConfigurationFrameCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ConfigurationFrameCollection Class
ConfigurationFrameCollection Overload
GSF.PhasorProtocols Namespace


ConfigurationFrameCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrameCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrameCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrameCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrameCollection
GSF.PhasorProtocols.ConfigurationFrameCollection = function(info, context);
protected:
ConfigurationFrameCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrameCollection Class
ConfigurationFrameCollection Overload
GSF.PhasorProtocols Namespace


ConfigurationFrameCollection Methods

Grid Solutions Framework ConfigurationFrameCollection Methods

The ConfigurationFrameCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrameCollection Class
GSF.PhasorProtocols Namespace


ConfigurationFrameCollection Properties

Grid Solutions Framework ConfigurationFrameCollection Properties

The ConfigurationFrameCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelFrameCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationFrameCollection Class
GSF.PhasorProtocols Namespace


ConfigurationFrameCollection Events

Grid Solutions Framework ConfigurationFrameCollection Events

The ConfigurationFrameCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationFrameCollection Class
GSF.PhasorProtocols Namespace


ConfigurationFrameParsingState Class

Grid Solutions Framework ConfigurationFrameParsingState Class
Represents the protocol independent common implementation of the parsing state used by any IConfigurationFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameParsingState
GSF.PhasorProtocols.BPAPDCstreamConfigurationFrameParsingState
GSF.PhasorProtocols.MacrodyneConfigurationFrameParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConfigurationFrameParsingState : ChannelFrameParsingStateBase<IConfigurationCell>,
    IConfigurationFrameParsingState, IChannelFrameParsingState<IConfigurationCell>, IChannelParsingState
Public Class ConfigurationFrameParsingState
    Inherits ChannelFrameParsingStateBase(Of IConfigurationCell)
    Implements IConfigurationFrameParsingState, IChannelFrameParsingState(Of IConfigurationCell),
    IChannelParsingState
type ConfigurationFrameParsingState =
    class
        inherit ChannelFrameParsingStateBase<IConfigurationCell>
        interface IConfigurationFrameParsingState
        interface IChannelFrameParsingState<IConfigurationCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.ConfigurationFrameParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.ConfigurationFrameParsingState',
    GSF.PhasorProtocols.ChannelFrameParsingStateBase`1,
    GSF.PhasorProtocols.IConfigurationFrameParsingState,
    GSF.PhasorProtocols.IChannelFrameParsingState`1,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class ConfigurationFrameParsingState : public ChannelFrameParsingStateBase<IConfigurationCell^>,
    IConfigurationFrameParsingState, IChannelFrameParsingState<IConfigurationCell^>, IChannelParsingState

The ConfigurationFrameParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrameParsingState(Int32, CreateNewCellFunctionIConfigurationCell, Boolean, Boolean) | Creates a new ConfigurationFrameParsingState from specified parameters.
Public method | ConfigurationFrameParsingState(Int32, CreateNewCellFunctionIConfigurationCell, Boolean, Boolean, Int32) | Creates a new ConfigurationFrameParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ConfigurationFrameParsingState Constructor

Grid Solutions Framework ConfigurationFrameParsingState Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrameParsingState(Int32, CreateNewCellFunctionIConfigurationCell, Boolean, Boolean) | Creates a new ConfigurationFrameParsingState from specified parameters.
Public method | ConfigurationFrameParsingState(Int32, CreateNewCellFunctionIConfigurationCell, Boolean, Boolean, Int32) | Creates a new ConfigurationFrameParsingState from specified parameters.
Top
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationFrameParsingState Constructor (Int32, CreateNewCellFunction(IConfigurationCell), Boolean, Boolean)

Grid Solutions Framework ConfigurationFrameParsingState Constructor (Int32, CreateNewCellFunctionIConfigurationCell, Boolean, Boolean)
Creates a new ConfigurationFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)
Public Sub New (
    parsedBinaryLength As Integer,
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell),
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        createNewCellFunction : CreateNewCellFunction<IConfigurationCell> *
        trustHeaderLength : bool *
        validateCheckSum : bool -> ConfigurationFrameParsingState
GSF.PhasorProtocols.ConfigurationFrameParsingState = function(parsedBinaryLength, createNewCellFunction, trustHeaderLength, validateCheckSum);
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the IConfigurationFrame being parsed.
createNewCellFunction
Type: GSF.PhasorProtocolsCreateNewCellFunction IConfigurationCell
Reference to delegate to create new IConfigurationCell instances.
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

ConfigurationFrameParsingState Class
ConfigurationFrameParsingState Overload
GSF.PhasorProtocols Namespace


ConfigurationFrameParsingState Constructor (Int32, CreateNewCellFunction(IConfigurationCell), Boolean, Boolean, Int32)

Grid Solutions Framework ConfigurationFrameParsingState Constructor (Int32, CreateNewCellFunctionIConfigurationCell, Boolean, Boolean, Int32)
Creates a new ConfigurationFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum,
    int cellCount
)
Public Sub New (
    parsedBinaryLength As Integer,
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell),
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean,
    cellCount As Integer
)
new :
        parsedBinaryLength : int *
        createNewCellFunction : CreateNewCellFunction<IConfigurationCell> *
        trustHeaderLength : bool *
        validateCheckSum : bool *
        cellCount : int -> ConfigurationFrameParsingState
GSF.PhasorProtocols.ConfigurationFrameParsingState = function(parsedBinaryLength, createNewCellFunction, trustHeaderLength, validateCheckSum, cellCount);
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum,
    int cellCount
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the IConfigurationFrame being parsed.
createNewCellFunction
Type: GSF.PhasorProtocolsCreateNewCellFunction IConfigurationCell
Reference to delegate to create new IConfigurationCell instances.
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
cellCount
Type: SystemInt32
Number of cells that exist in the frame to be parsed.
See Also

Reference

ConfigurationFrameParsingState Class
ConfigurationFrameParsingState Overload
GSF.PhasorProtocols Namespace


ConfigurationFrameParsingState Methods

Grid Solutions Framework ConfigurationFrameParsingState Methods

The ConfigurationFrameParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols Namespace


ConfigurationFrameParsingState Properties

Grid Solutions Framework ConfigurationFrameParsingState Properties

The ConfigurationFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols Namespace


ConnectionParametersBase Class

Grid Solutions Framework ConnectionParametersBase Class
Represents the common implementation of the protocol independent set of extra connection parameters.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsConnectionParametersBase
GSF.PhasorProtocols.BPAPDCstreamConnectionParameters
GSF.PhasorProtocols.FNETConnectionParameters
GSF.PhasorProtocols.IEC61850_90_5ConnectionParameters
GSF.PhasorProtocols.MacrodyneConnectionParameters
GSF.PhasorProtocols.SelFastMessageConnectionParameters

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class ConnectionParametersBase : IConnectionParameters,
    ISerializable
<SerializableAttribute>
Public MustInherit Class ConnectionParametersBase
    Implements IConnectionParameters, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type ConnectionParametersBase =
    class
        interface IConnectionParameters
        interface ISerializable
    end
GSF.PhasorProtocols.ConnectionParametersBase = function();

Type.createClass(
    'GSF.PhasorProtocols.ConnectionParametersBase',
    null,
    GSF.PhasorProtocols.IConnectionParameters,
    ISerializable);
[SerializableAttribute]
public ref class ConnectionParametersBase abstract : IConnectionParameters,
    ISerializable

The ConnectionParametersBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ConnectionParametersBase | Initializes a new instance of the ConnectionParametersBase class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ValuesAreValid | Determines if custom connection parameters are valid.
Top
Remarks

This class is inherited by subsequent classes to provide protocol specific connection parameters that may be needed to make a connection.

Derived implementations of this class are designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters.

See Also

Reference

GSF.PhasorProtocols Namespace


ConnectionParametersBase Constructor

Grid Solutions Framework ConnectionParametersBase Constructor
Initializes a new instance of the ConnectionParametersBase class

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConnectionParametersBase()
Protected Sub New
new : unit -> ConnectionParametersBase
GSF.PhasorProtocols.ConnectionParametersBase = function();
protected:
ConnectionParametersBase()
See Also

Reference

ConnectionParametersBase Class
GSF.PhasorProtocols Namespace


ConnectionParametersBase Methods

Grid Solutions Framework ConnectionParametersBase Methods

The ConnectionParametersBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionParametersBase Class
GSF.PhasorProtocols Namespace


ConnectionParametersBase.GetObjectData Method

Grid Solutions Framework ConnectionParametersBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public MustOverride Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit

function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) abstract

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConnectionParametersBase Class
GSF.PhasorProtocols Namespace


ConnectionParametersBase Properties

Grid Solutions Framework ConnectionParametersBase Properties

The ConnectionParametersBase type exposes the following members.

Properties
 | Name | Description
Public property | ValuesAreValid | Determines if custom connection parameters are valid.
Top
See Also

Reference

ConnectionParametersBase Class
GSF.PhasorProtocols Namespace


ConnectionParametersBase.ValuesAreValid Property

Grid Solutions Framework ConnectionParametersBaseValuesAreValid Property
Determines if custom connection parameters are valid.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public virtual bool ValuesAreValid { get; }
<BrowsableAttribute(false)>
Public Overridable ReadOnly Property ValuesAreValid As Boolean
    Get
[<BrowsableAttribute(false)>]
abstract ValuesAreValid : bool with get
[<BrowsableAttribute(false)>]
override ValuesAreValid : bool with get
function get_ValuesAreValid();

public:
[BrowsableAttribute(false)]
virtual property bool ValuesAreValid {
    bool get ();
}

Property Value

Type: Boolean

Implements

IConnectionParametersValuesAreValid
See Also

Reference

ConnectionParametersBase Class
GSF.PhasorProtocols Namespace


ConnectionSettings Class

Grid Solutions Framework ConnectionSettings Class
Represents information defined in a PMU Connection Tester connection file.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsConnectionSettings

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConnectionSettings : ISerializable
<SerializableAttribute>
Public Class ConnectionSettings
    Implements ISerializable
[<SerializableAttribute>]
type ConnectionSettings =
    class
        interface ISerializable
    end
GSF.PhasorProtocols.ConnectionSettings = function();

Type.createClass(
    'GSF.PhasorProtocols.ConnectionSettings',
    null,
    ISerializable);
[SerializableAttribute]
public ref class ConnectionSettings : ISerializable

The ConnectionSettings type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionSettings | Creates a new ConnectionSettings instance.
Protected method | ConnectionSettings(SerializationInfo, StreamingContext) | Creates a new ConnectionSettings instance from serialization parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | AutoRepeatPlayback | Defines boolean flag if data needs to be repeated again and again.
Public field | ByteEncodingDisplayFormat | Defines byte encoding format from PmuConnection file.
Public field | ConnectionParameters | Defines additional connection information such as alternate command channel from PmuConnection file.
Public field | ConnectionString | Defines connection string from PmuConnection file.
Public field | FrameRate | Defines frame rate from PmuConnection file.
Public field | PhasorProtocol | Defines PhasorProtocol from PmuConnection file.
Public field | PmuID | Defines ID of the source from PmuConnection file.
Public field | TransportProtocol | Defines TransportProtocol from PmuConnection file.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ConnectionSettings Constructor

Grid Solutions Framework ConnectionSettings Constructor
Overload List
 | Name | Description
Public method | ConnectionSettings | Creates a new ConnectionSettings instance.
Protected method | ConnectionSettings(SerializationInfo, StreamingContext) | Creates a new ConnectionSettings instance from serialization parameters.
Top
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings Constructor

Grid Solutions Framework ConnectionSettings Constructor
Creates a new ConnectionSettings instance.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionSettings()
Public Sub New
new : unit -> ConnectionSettings
GSF.PhasorProtocols.ConnectionSettings = function();
public:
ConnectionSettings()
See Also

Reference

ConnectionSettings Class
ConnectionSettings Overload
GSF.PhasorProtocols Namespace


ConnectionSettings Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConnectionSettings Constructor (SerializationInfo, StreamingContext)
Creates a new ConnectionSettings instance from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConnectionSettings(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConnectionSettings
GSF.PhasorProtocols.ConnectionSettings = function(info, context);
protected:
ConnectionSettings(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConnectionSettings Class
ConnectionSettings Overload
GSF.PhasorProtocols Namespace


ConnectionSettings Fields

Grid Solutions Framework ConnectionSettings Fields

The ConnectionSettings type exposes the following members.

Fields
 | Name | Description
Public field | AutoRepeatPlayback | Defines boolean flag if data needs to be repeated again and again.
Public field | ByteEncodingDisplayFormat | Defines byte encoding format from PmuConnection file.
Public field | ConnectionParameters | Defines additional connection information such as alternate command channel from PmuConnection file.
Public field | ConnectionString | Defines connection string from PmuConnection file.
Public field | FrameRate | Defines frame rate from PmuConnection file.
Public field | PhasorProtocol | Defines PhasorProtocol from PmuConnection file.
Public field | PmuID | Defines ID of the source from PmuConnection file.
Public field | TransportProtocol | Defines TransportProtocol from PmuConnection file.
Top
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.AutoRepeatPlayback Field

Grid Solutions Framework ConnectionSettingsAutoRepeatPlayback Field
Defines boolean flag if data needs to be repeated again and again.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AutoRepeatPlayback
Public AutoRepeatPlayback As Boolean
val mutable AutoRepeatPlayback: bool
var AutoRepeatPlayback
public:
bool AutoRepeatPlayback

Field Value

Type: Boolean
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.ByteEncodingDisplayFormat Field

Grid Solutions Framework ConnectionSettingsByteEncodingDisplayFormat Field
Defines byte encoding format from PmuConnection file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ByteEncodingDisplayFormat
Public ByteEncodingDisplayFormat As Integer
val mutable ByteEncodingDisplayFormat: int
var ByteEncodingDisplayFormat
public:
int ByteEncodingDisplayFormat

Field Value

Type: Int32
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.ConnectionParameters Field

Grid Solutions Framework ConnectionSettingsConnectionParameters Field
Defines additional connection information such as alternate command channel from PmuConnection file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IConnectionParameters ConnectionParameters
Public ConnectionParameters As IConnectionParameters
val mutable ConnectionParameters: IConnectionParameters
var ConnectionParameters
public:
IConnectionParameters^ ConnectionParameters

Field Value

Type: IConnectionParameters
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.ConnectionString Field

Grid Solutions Framework ConnectionSettingsConnectionString Field
Defines connection string from PmuConnection file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString
Public ConnectionString As String
val mutable ConnectionString: string
var ConnectionString
public:
String^ ConnectionString

Field Value

Type: String
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.FrameRate Field

Grid Solutions Framework ConnectionSettingsFrameRate Field
Defines frame rate from PmuConnection file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int FrameRate
Public FrameRate As Integer
val mutable FrameRate: int
var FrameRate
public:
int FrameRate

Field Value

Type: Int32
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.PhasorProtocol Field

Grid Solutions Framework ConnectionSettingsPhasorProtocol Field
Defines PhasorProtocol from PmuConnection file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorProtocol PhasorProtocol
Public PhasorProtocol As PhasorProtocol
val mutable PhasorProtocol: PhasorProtocol
var PhasorProtocol
public:
PhasorProtocol PhasorProtocol

Field Value

Type: PhasorProtocol
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.PmuID Field

Grid Solutions Framework ConnectionSettingsPmuID Field
Defines ID of the source from PmuConnection file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int PmuID
Public PmuID As Integer
val mutable PmuID: int
var PmuID
public:
int PmuID

Field Value

Type: Int32
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.TransportProtocol Field

Grid Solutions Framework ConnectionSettingsTransportProtocol Field
Defines TransportProtocol from PmuConnection file.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TransportProtocol TransportProtocol
Public TransportProtocol As TransportProtocol
val mutable TransportProtocol: TransportProtocol
var TransportProtocol
public:
TransportProtocol TransportProtocol

Field Value

Type: TransportProtocol
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings Methods

Grid Solutions Framework ConnectionSettings Methods

The ConnectionSettings type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


ConnectionSettings.GetObjectData Method

Grid Solutions Framework ConnectionSettingsGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConnectionSettings Class
GSF.PhasorProtocols Namespace


CoordinateFormat Enumeration

Grid Solutions Framework CoordinateFormat Enumeration
Phasor coordinate formats enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum CoordinateFormat
<SerializableAttribute>
Public Enumeration CoordinateFormat
[<SerializableAttribute>]
type CoordinateFormat
GSF.PhasorProtocols.CoordinateFormat = function();
GSF.PhasorProtocols.CoordinateFormat.createEnum('GSF.PhasorProtocols.CoordinateFormat', false);
[SerializableAttribute]
public enum class CoordinateFormat
Members
Member name | Value | Description
Rectangular | 0 | Rectangular coordinate format.
Polar | 1 | Polar coordinate format.
See Also

Reference

GSF.PhasorProtocols Namespace


CrcException Class

Grid Solutions Framework CrcException Class
The exception that is thrown when an object's CRC check fails.
Inheritance Hierarchy
SystemObject
SystemException
GSF.PhasorProtocolsCrcException

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CrcException : Exception
<SerializableAttribute>
Public Class CrcException
    Inherits Exception
[<SerializableAttribute>]
type CrcException =
    class
        inherit Exception
    end
GSF.PhasorProtocols.CrcException = function();

Type.createClass(
    'GSF.PhasorProtocols.CrcException',
    Exception);
[SerializableAttribute]
public ref class CrcException : public Exception

The CrcException type exposes the following members.

Constructors
 | Name | Description
Public method | CrcException | Initializes a new instance of the CrcException class.
Public method | CrcException(String) | Initializes a new instance of the CrcException class.
Protected method | CrcException(SerializationInfo, StreamingContext) | Creates a new CrcException from serialization parameters.
Public method | CrcException(String, Exception) | Initializes a new instance of the CrcException class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


CrcException Constructor

Grid Solutions Framework CrcException Constructor
Overload List
 | Name | Description
Public method | CrcException | Initializes a new instance of the CrcException class.
Public method | CrcException(String) | Initializes a new instance of the CrcException class.
Protected method | CrcException(SerializationInfo, StreamingContext) | Creates a new CrcException from serialization parameters.
Public method | CrcException(String, Exception) | Initializes a new instance of the CrcException class.
Top
See Also

Reference

CrcException Class
GSF.PhasorProtocols Namespace


CrcException Constructor

Grid Solutions Framework CrcException Constructor
Initializes a new instance of the CrcException class.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CrcException()
Public Sub New
new : unit -> CrcException
GSF.PhasorProtocols.CrcException = function();
public:
CrcException()
See Also

Reference

CrcException Class
CrcException Overload
GSF.PhasorProtocols Namespace


CrcException Constructor (String)

Grid Solutions Framework CrcException Constructor (String)
Initializes a new instance of the CrcException class.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CrcException(
    string message
)
Public Sub New (
    message As String
)
new :
        message : string -> CrcException
GSF.PhasorProtocols.CrcException = function(message);
public:
CrcException(
    String^ message
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

CrcException Class
CrcException Overload
GSF.PhasorProtocols Namespace


CrcException Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CrcException Constructor (SerializationInfo, StreamingContext)
Creates a new CrcException from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CrcException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CrcException
GSF.PhasorProtocols.CrcException = function(info, context);
protected:
CrcException(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CrcException Class
CrcException Overload
GSF.PhasorProtocols Namespace


CrcException Constructor (String, Exception)

Grid Solutions Framework CrcException Constructor (String, Exception)
Initializes a new instance of the CrcException class.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CrcException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
new :
        message : string *
        innerException : Exception -> CrcException
GSF.PhasorProtocols.CrcException = function(message, innerException);
public:
CrcException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: SystemString
The message that describes the error.
innerException
Type: SystemException
The exception that is the cause of the current exception.
See Also

Reference

CrcException Class
CrcException Overload
GSF.PhasorProtocols Namespace


CrcException Methods

Grid Solutions Framework CrcException Methods

The CrcException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CrcException Class
GSF.PhasorProtocols Namespace


CrcException Properties

Grid Solutions Framework CrcException Properties

The CrcException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

CrcException Class
GSF.PhasorProtocols Namespace


CrcException Events

Grid Solutions Framework CrcException Events

The CrcException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

CrcException Class
GSF.PhasorProtocols Namespace


CreateNewCellFunction(T) Delegate

Grid Solutions Framework CreateNewCellFunctionT Delegate
Defines function signature for creating new IChannelCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate T CreateNewCellFunction<T>(
    IChannelFrame parent,
    IChannelFrameParsingState<T> state,
    int index,
    byte[] buffer,
    int startIndex,
    out int parsedLength
)
where T : IChannelCell

Public Delegate Function CreateNewCellFunction(Of T As IChannelCell) (
    parent As IChannelFrame,
    state As IChannelFrameParsingState(Of T),
    index As Integer,
    buffer As Byte(),
    startIndex As Integer,
    <OutAttribute> ByRef parsedLength As Integer
) As T
type CreateNewCellFunction =
    delegate of
        parent : IChannelFrame *
        state : IChannelFrameParsingState<'T> *
        index : int *
        buffer : byte[] *
        startIndex : int *
        parsedLength : int byref -> 'T
function(parent, state, index, buffer, startIndex, parsedLength);
generic<typename T>
where T : IChannelCell
public delegate T CreateNewCellFunction(
    IChannelFrame^ parent,
    IChannelFrameParsingState<T>^ state,
    int index,
    array<unsigned char>^ buffer,
    int startIndex,
    [OutAttribute] int% parsedLength
)

Parameters

parent
Type: GSF.PhasorProtocolsIChannelFrame
Reference to parent IChannelFrame.
state
Type: GSF.PhasorProtocolsIChannelFrameParsingState T
Current parsing state of associated IChannelFrame.
index
Type: SystemInt32
Index of cell within its collection.
buffer
Type: SystemByte
Binary image to parse IChannelCell from.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
parsedLength
Type: SystemInt32
Returns the total number of bytes parsed from buffer.

Type Parameters

T
Specific IChannelCell type of object that gets created by referenced function.

Return Value

Type: T
New IChannelCell object.
See Also

Reference

GSF.PhasorProtocols Namespace


CreateNewDefinitionFunction(T) Delegate

Grid Solutions Framework CreateNewDefinitionFunctionT Delegate
Defines function signature for creating new IChannelDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate T CreateNewDefinitionFunction<T>(
    IConfigurationCell parent,
    byte[] buffer,
    int startIndex,
    out int parsedLength
)
where T : IChannelDefinition

Public Delegate Function CreateNewDefinitionFunction(Of T As IChannelDefinition) (
    parent As IConfigurationCell,
    buffer As Byte(),
    startIndex As Integer,
    <OutAttribute> ByRef parsedLength As Integer
) As T
type CreateNewDefinitionFunction =
    delegate of
        parent : IConfigurationCell *
        buffer : byte[] *
        startIndex : int *
        parsedLength : int byref -> 'T
function(parent, buffer, startIndex, parsedLength);
generic<typename T>
where T : IChannelDefinition
public delegate T CreateNewDefinitionFunction(
    IConfigurationCell^ parent,
    array<unsigned char>^ buffer,
    int startIndex,
    [OutAttribute] int% parsedLength
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
Reference to parent IConfigurationCell.
buffer
Type: SystemByte
Binary image to parse IChannelDefinition from.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
parsedLength
Type: SystemInt32
Returns the total number of bytes parsed from buffer.

Type Parameters

T
Specific IChannelDefinition type of object that the CreateNewDefinitionFunctionT creates.

Return Value

Type: T
New IChannelDefinition object.
See Also

Reference

GSF.PhasorProtocols Namespace


CreateNewValueFunction(TDefinition, TValue) Delegate

Grid Solutions Framework CreateNewValueFunctionTDefinition, TValue Delegate
Defines function signature for creating new IChannelValueT objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate TValue CreateNewValueFunction<TDefinition, TValue>(
    IDataCell parent,
    TDefinition definition,
    byte[] buffer,
    int startIndex,
    out int parsedLength
)
where TDefinition : IChannelDefinition
where TValue : Object, IChannelValue<TDefinition>

Public Delegate Function CreateNewValueFunction(Of TDefinition As IChannelDefinition, TValue As {Object, IChannelValue(Of TDefinition)}) (
    parent As IDataCell,
    definition As TDefinition,
    buffer As Byte(),
    startIndex As Integer,
    <OutAttribute> ByRef parsedLength As Integer
) As TValue
type CreateNewValueFunction =
    delegate of
        parent : IDataCell *
        definition : 'TDefinition *
        buffer : byte[] *
        startIndex : int *
        parsedLength : int byref -> 'TValue
function(parent, definition, buffer, startIndex, parsedLength);
generic<typename TDefinition, typename TValue>
where TDefinition : IChannelDefinition
where TValue : Object, IChannelValue<TDefinition>
public delegate TValue CreateNewValueFunction(
    IDataCell^ parent,
    TDefinition definition,
    array<unsigned char>^ buffer,
    int startIndex,
    [OutAttribute] int% parsedLength
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
Reference to parent IDataCell.
definition
Type: TDefinition
Refrence to associated IChannelDefinition object.
buffer
Type: SystemByte
Binary image to parse IChannelValueT from.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
parsedLength
Type: SystemInt32
Returns the total number of bytes parsed from buffer.

Type Parameters

TDefinition
Specific IChannelDefinition type that the IChannelValueT references.
TValue
Specific IChannelValueT type that the CreateNewValueFunctionTDefinition, TValue creates.

Return Value

Type: TValue
New IChannelValueT object.
See Also

Reference

GSF.PhasorProtocols Namespace


DataCellBase Class

Grid Solutions Framework DataCellBase Class
Represents the protocol independent common implementation of all elements for cells in a IDataFrame.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class DataCellBase : ChannelCellBase,
    IDataCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable
<SerializableAttribute>
Public MustInherit Class DataCellBase
    Inherits ChannelCellBase
    Implements IDataCell, IChannelCell, IChannel, ISupportBinaryImage,
    ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DataCellBase =
    class
        inherit ChannelCellBase
        interface IDataCell
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.DataCellBase = function();

Type.createClass(
    'GSF.PhasorProtocols.DataCellBase',
    GSF.PhasorProtocols.ChannelCellBase,
    GSF.PhasorProtocols.IDataCell,
    GSF.PhasorProtocols.IChannelCell,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class DataCellBase abstract : public ChannelCellBase,
    IDataCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable

The DataCellBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCellBase(SerializationInfo, StreamingContext) | Creates a new DataCellBase from serialization parameters.
Protected method | DataCellBase(IDataFrame, IConfigurationCell, UInt16, Int32, Int32, Int32) | Creates a new DataCellBase from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned.
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase.
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCellBase object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase.
Public property | ConfigurationCell | Gets or sets the IConfigurationCell associated with this DataCellBase.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCellBase is valid.
Public property | DataSortingType | Gets or sets DataSortingType of this DataCellBase.
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCellBase is reporting an error.
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets ID label of this DataCellBase.
Public property | Parent | Gets or sets the reference to parent IDataFrame of this DataCellBase.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase.
Public property | State | Gets or sets the parsing state for the this DataCellBase.
Public property | StationName | Gets station name of this DataCellBase.
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCellBase is valid based on GPS lock.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.BPAPDCstreamDataCell
GSF.PhasorProtocols.FNETDataCell
GSF.PhasorProtocols.IEC61850_90_5DataCell
GSF.PhasorProtocols.IEEE1344DataCell
GSF.PhasorProtocols.IEEEC37_118DataCell
GSF.PhasorProtocols.MacrodyneDataCell
GSF.PhasorProtocols.SelFastMessageDataCell


DataCellBase Constructor

Grid Solutions Framework DataCellBase Constructor
Overload List
 | Name | Description
Protected method | DataCellBase(SerializationInfo, StreamingContext) | Creates a new DataCellBase from serialization parameters.
Protected method | DataCellBase(IDataFrame, IConfigurationCell, UInt16, Int32, Int32, Int32) | Creates a new DataCellBase from specified parameters.
Top
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellBase Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellBase
GSF.PhasorProtocols.DataCellBase = function(info, context);
protected:
DataCellBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellBase Class
DataCellBase Overload
GSF.PhasorProtocols Namespace


DataCellBase Constructor (IDataFrame, IConfigurationCell, UInt16, Int32, Int32, Int32)

Grid Solutions Framework DataCellBase Constructor (IDataFrame, IConfigurationCell, UInt16, Int32, Int32, Int32)
Creates a new DataCellBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellBase(
    IDataFrame parent,
    IConfigurationCell configurationCell,
    ushort statusFlags,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)
Protected Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell,
    statusFlags As UShort,
    maximumPhasors As Integer,
    maximumAnalogs As Integer,
    maximumDigitals As Integer
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell *
        statusFlags : uint16 *
        maximumPhasors : int *
        maximumAnalogs : int *
        maximumDigitals : int -> DataCellBase
GSF.PhasorProtocols.DataCellBase = function(parent, configurationCell, statusFlags, maximumPhasors, maximumAnalogs, maximumDigitals);
protected:
DataCellBase(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell,
    unsigned short statusFlags,
    int maximumPhasors,
    int maximumAnalogs,
    int maximumDigitals
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCellBase.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCellBase.
statusFlags
Type: SystemUInt16
The default status flags to apply to this DataCellBase.
maximumPhasors
Type: SystemInt32
Sets the maximum number of phasors for the PhasorValues collection.
maximumAnalogs
Type: SystemInt32
Sets the maximum number of phasors for the AnalogValues collection.
maximumDigitals
Type: SystemInt32
Sets the maximum number of phasors for the DigitalValues collection.
See Also

Reference

DataCellBase Class
DataCellBase Overload
GSF.PhasorProtocols Namespace


DataCellBase Methods

Grid Solutions Framework DataCellBase Methods

The DataCellBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.GetObjectData Method

Grid Solutions Framework DataCellBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.ParseBodyImage Method

Grid Solutions Framework DataCellBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase Properties

Grid Solutions Framework DataCellBase Properties

The DataCellBase type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned.
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase.
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCellBase object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase.
Public property | ConfigurationCell | Gets or sets the IConfigurationCell associated with this DataCellBase.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCellBase is valid.
Public property | DataSortingType | Gets or sets DataSortingType of this DataCellBase.
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCellBase is reporting an error.
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets ID label of this DataCellBase.
Public property | Parent | Gets or sets the reference to parent IDataFrame of this DataCellBase.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase.
Public property | State | Gets or sets the parsing state for the this DataCellBase.
Public property | StationName | Gets station name of this DataCellBase.
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCellBase is valid based on GPS lock.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.AllValuesAssigned Property

Grid Solutions Framework DataCellBaseAllValuesAssigned Property
Gets flag that determines if all values of this DataCellBase have been assigned.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool AllValuesAssigned { get; }
Public Overridable ReadOnly Property AllValuesAssigned As Boolean
    Get
abstract AllValuesAssigned : bool with get
override AllValuesAssigned : bool with get
function get_AllValuesAssigned();

public:
virtual property bool AllValuesAssigned {
    bool get ();
}

Property Value

Type: Boolean

Implements

IDataCellAllValuesAssigned
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.AnalogValues Property

Grid Solutions Framework DataCellBaseAnalogValues Property
Gets AnalogValueCollectionof this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AnalogValueCollection AnalogValues { get; }
Public Overridable ReadOnly Property AnalogValues As AnalogValueCollection
    Get
abstract AnalogValues : AnalogValueCollection with get
override AnalogValues : AnalogValueCollection with get
function get_AnalogValues();

public:
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get ();
}

Property Value

Type: AnalogValueCollection

Implements

IDataCellAnalogValues
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.Attributes Property

Grid Solutions Framework DataCellBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataCellBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.BodyImage Property

Grid Solutions Framework DataCellBaseBodyImage Property
Gets the binary body image of the DataCellBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.BodyLength Property

Grid Solutions Framework DataCellBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.CommonStatusFlags Property

Grid Solutions Framework DataCellBaseCommonStatusFlags Property
Gets or sets common status flags of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint CommonStatusFlags { get; set; }
Public Property CommonStatusFlags As UInteger
    Get
    Set
abstract CommonStatusFlags : uint32 with get, set
override CommonStatusFlags : uint32 with get, set
function get_CommonStatusFlags();
function set_CommonStatusFlags(value);
public:
virtual property unsigned int CommonStatusFlags {
    unsigned int get () sealed;
    void set (unsigned int value) sealed;
}

Property Value

Type: UInt32

Implements

IDataCellCommonStatusFlags
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.ConfigurationCell Property

Grid Solutions Framework DataCellBaseConfigurationCell Property
Gets or sets the IConfigurationCell associated with this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationCell ConfigurationCell { get; set; }
Public Overridable Property ConfigurationCell As IConfigurationCell
    Get
    Set
abstract ConfigurationCell : IConfigurationCell with get, set
override ConfigurationCell : IConfigurationCell with get, set
function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
virtual property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}

Property Value

Type: IConfigurationCell

Implements

IDataCellConfigurationCell
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.DataIsValid Property

Grid Solutions Framework DataCellBaseDataIsValid Property
Gets or sets flag that determines if data of this DataCellBase is valid.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool DataIsValid { get; set; }
Public MustOverride Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set

function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () abstract;
    void set (bool value) abstract;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.DataSortingType Property

Grid Solutions Framework DataCellBaseDataSortingType Property
Gets or sets DataSortingType of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract DataSortingType DataSortingType { get; set; }
Public MustOverride Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set

function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () abstract;
    void set (DataSortingType value) abstract;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.DeviceError Property

Grid Solutions Framework DataCellBaseDeviceError Property
Gets or sets flag that determines if source device of this DataCellBase is reporting an error.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool DeviceError { get; set; }
Public MustOverride Property DeviceError As Boolean
    Get
    Set
abstract DeviceError : bool with get, set

function get_DeviceError();
function set_DeviceError(value);
public:
virtual property bool DeviceError {
    bool get () abstract;
    void set (bool value) abstract;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.DigitalValues Property

Grid Solutions Framework DataCellBaseDigitalValues Property
Gets DigitalValueCollectionof this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DigitalValueCollection DigitalValues { get; }
Public Overridable ReadOnly Property DigitalValues As DigitalValueCollection
    Get
abstract DigitalValues : DigitalValueCollection with get
override DigitalValues : DigitalValueCollection with get
function get_DigitalValues();

public:
virtual property DigitalValueCollection^ DigitalValues {
    DigitalValueCollection^ get ();
}

Property Value

Type: DigitalValueCollection

Implements

IDataCellDigitalValues
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.FrequencyValue Property

Grid Solutions Framework DataCellBaseFrequencyValue Property
Gets IFrequencyValue of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IFrequencyValue FrequencyValue { get; set; }
Public Overridable Property FrequencyValue As IFrequencyValue
    Get
    Set
abstract FrequencyValue : IFrequencyValue with get, set
override FrequencyValue : IFrequencyValue with get, set
function get_FrequencyValue();
function set_FrequencyValue(value);
public:
virtual property IFrequencyValue^ FrequencyValue {
    IFrequencyValue^ get ();
    void set (IFrequencyValue^ value);
}

Property Value

Type: IFrequencyValue

Implements

IDataCellFrequencyValue
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.IDCode Property

Grid Solutions Framework DataCellBaseIDCode Property
Gets the numeric ID code for this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}

Property Value

Type: UInt16

Implements

IChannelCellIDCode
IChannelCellIDCode
Exceptions
Exception | Condition
NotSupportedException | IDCode of a data cell is read-only, change IDCode is associated configuration cell instead.
Remarks
This value is read-only for DataCellBase; assigning a value will throw an exception. Value returned is the IDCode of the associated ConfigurationCell.
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.IDLabel Property

Grid Solutions Framework DataCellBaseIDLabel Property
Gets ID label of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string IDLabel { get; }
Public Overridable ReadOnly Property IDLabel As String
    Get
abstract IDLabel : string with get
override IDLabel : string with get
function get_IDLabel();

public:
virtual property String^ IDLabel {
    String^ get ();
}

Property Value

Type: String

Implements

IDataCellIDLabel
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.Parent Property

Grid Solutions Framework DataCellBaseParent Property
Gets or sets the reference to parent IDataFrame of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IDataFrame Parent { get; set; }
Public Overridable Property Parent As IDataFrame
    Get
    Set
abstract Parent : IDataFrame with get, set
override Parent : IDataFrame with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property IDataFrame^ Parent {
    IDataFrame^ get ();
    void set (IDataFrame^ value);
}

Property Value

Type: IDataFrame

Implements

IDataCellParent
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.PhasorValues Property

Grid Solutions Framework DataCellBasePhasorValues Property
Gets PhasorValueCollection of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorValueCollection PhasorValues { get; }
Public Overridable ReadOnly Property PhasorValues As PhasorValueCollection
    Get
abstract PhasorValues : PhasorValueCollection with get
override PhasorValues : PhasorValueCollection with get
function get_PhasorValues();

public:
virtual property PhasorValueCollection^ PhasorValues {
    PhasorValueCollection^ get ();
}

Property Value

Type: PhasorValueCollection

Implements

IDataCellPhasorValues
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.State Property

Grid Solutions Framework DataCellBaseState Property
Gets or sets the parsing state for the this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IDataCellParsingState State { get; set; }
Public Overridable Property State As IDataCellParsingState
    Get
    Set
abstract State : IDataCellParsingState with get, set
override State : IDataCellParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IDataCellParsingState^ State {
    IDataCellParsingState^ get ();
    void set (IDataCellParsingState^ value);
}

Property Value

Type: IDataCellParsingState

Implements

IDataCellState
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.StationName Property

Grid Solutions Framework DataCellBaseStationName Property
Gets station name of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string StationName { get; }
Public Overridable ReadOnly Property StationName As String
    Get
abstract StationName : string with get
override StationName : string with get
function get_StationName();

public:
virtual property String^ StationName {
    String^ get ();
}

Property Value

Type: String

Implements

IDataCellStationName
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.StatusFlags Property

Grid Solutions Framework DataCellBaseStatusFlags Property
Gets or sets 16-bit status flags of this DataCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ushort StatusFlags { get; set; }
Public Overridable Property StatusFlags As UShort
    Get
    Set
abstract StatusFlags : uint16 with get, set
override StatusFlags : uint16 with get, set
function get_StatusFlags();
function set_StatusFlags(value);
public:
virtual property unsigned short StatusFlags {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16

Implements

IDataCellStatusFlags
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellBase.SynchronizationIsValid Property

Grid Solutions Framework DataCellBaseSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCellBase is valid based on GPS lock.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool SynchronizationIsValid { get; set; }
Public MustOverride Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set

function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () abstract;
    void set (bool value) abstract;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
Remarks
This value is used to abstractly assign the protocol independent set of CommonStatusFlags.
See Also

Reference

DataCellBase Class
GSF.PhasorProtocols Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a protocol independent collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : ChannelCellCollectionBase<IDataCell>
<SerializableAttribute>
Public Class DataCellCollection
    Inherits ChannelCellCollectionBase(Of IDataCell)
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit ChannelCellCollectionBase<IDataCell>
    end
GSF.PhasorProtocols.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.DataCellCollection',
    GSF.PhasorProtocols.ChannelCellCollectionBase`1);
[SerializableAttribute]
public ref class DataCellCollection : public ChannelCellCollectionBase<IDataCell^>

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection(Int32, Boolean) | Creates a new DataCellCollection from specified parameters.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.BPAPDCstreamDataCellCollection
GSF.PhasorProtocols.FNETDataCellCollection
GSF.PhasorProtocols.IEC61850_90_5DataCellCollection
GSF.PhasorProtocols.IEEE1344DataCellCollection
GSF.PhasorProtocols.IEEEC37_118DataCellCollection
GSF.PhasorProtocols.MacrodyneDataCellCollection
GSF.PhasorProtocols.SelFastMessageDataCellCollection


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection(Int32, Boolean) | Creates a new DataCellCollection from specified parameters.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols Namespace


DataCellCollection Constructor (Int32, Boolean)

Grid Solutions Framework DataCellCollection Constructor (Int32, Boolean)
Creates a new DataCellCollection from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection(
    int lastValidIndex,
    bool constantCellLength
)
Public Sub New (
    lastValidIndex As Integer,
    constantCellLength As Boolean
)
new :
        lastValidIndex : int *
        constantCellLength : bool -> DataCellCollection
GSF.PhasorProtocols.DataCellCollection = function(lastValidIndex, constantCellLength);
public:
DataCellCollection(
    int lastValidIndex,
    bool constantCellLength
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
constantCellLength
Type: SystemBoolean
Sets flag that determines if the lengths of IDataCell elements in this DataCellCollection are constant.
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols Namespace


DataCellParsingState Class

Grid Solutions Framework DataCellParsingState Class
Represents the protocol independent common implementation of the parsing state used by any IDataCell.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelCellParsingStateBase
GSF.PhasorProtocolsDataCellParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataCellParsingState : ChannelCellParsingStateBase,
    IDataCellParsingState, IChannelCellParsingState, IChannelParsingState
Public Class DataCellParsingState
    Inherits ChannelCellParsingStateBase
    Implements IDataCellParsingState, IChannelCellParsingState, IChannelParsingState
type DataCellParsingState =
    class
        inherit ChannelCellParsingStateBase
        interface IDataCellParsingState
        interface IChannelCellParsingState
        interface IChannelParsingState
    end
GSF.PhasorProtocols.DataCellParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.DataCellParsingState',
    GSF.PhasorProtocols.ChannelCellParsingStateBase,
    GSF.PhasorProtocols.IDataCellParsingState,
    GSF.PhasorProtocols.IChannelCellParsingState,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class DataCellParsingState : public ChannelCellParsingStateBase,
    IDataCellParsingState, IChannelCellParsingState, IChannelParsingState

The DataCellParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellParsingState | Creates a new DataCellParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | ConfigurationCell | Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
Public property | CreateNewAnalogValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IAnalogValue objects.
Public property | CreateNewDigitalValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IDigitalValue objects.
Public property | CreateNewFrequencyValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IFrequencyValue objects.
Public property | CreateNewPhasorValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IPhasorValue objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


DataCellParsingState Constructor

Grid Solutions Framework DataCellParsingState Constructor
Creates a new DataCellParsingState from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellParsingState(
    IConfigurationCell configurationCell,
    CreateNewValueFunction<IPhasorDefinition, IPhasorValue> createNewPhasorValue,
    CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> createNewFrequencyValue,
    CreateNewValueFunction<IAnalogDefinition, IAnalogValue> createNewAnalogValue,
    CreateNewValueFunction<IDigitalDefinition, IDigitalValue> createNewDigitalValue
)
Public Sub New (
    configurationCell As IConfigurationCell,
    createNewPhasorValue As CreateNewValueFunction(Of IPhasorDefinition, IPhasorValue),
    createNewFrequencyValue As CreateNewValueFunction(Of IFrequencyDefinition, IFrequencyValue),
    createNewAnalogValue As CreateNewValueFunction(Of IAnalogDefinition, IAnalogValue),
    createNewDigitalValue As CreateNewValueFunction(Of IDigitalDefinition, IDigitalValue)
)
new :
        configurationCell : IConfigurationCell *
        createNewPhasorValue : CreateNewValueFunction<IPhasorDefinition, IPhasorValue> *
        createNewFrequencyValue : CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> *
        createNewAnalogValue : CreateNewValueFunction<IAnalogDefinition, IAnalogValue> *
        createNewDigitalValue : CreateNewValueFunction<IDigitalDefinition, IDigitalValue> -> DataCellParsingState
GSF.PhasorProtocols.DataCellParsingState = function(configurationCell, createNewPhasorValue, createNewFrequencyValue, createNewAnalogValue, createNewDigitalValue);
public:
DataCellParsingState(
    IConfigurationCell^ configurationCell,
    CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ createNewPhasorValue,
    CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ createNewFrequencyValue,
    CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ createNewAnalogValue,
    CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ createNewDigitalValue
)

Parameters

configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
Reference to the IConfigurationCell associated with the IDataCell being parsed.
createNewPhasorValue
Type: GSF.PhasorProtocolsCreateNewValueFunction IPhasorDefinition, IPhasorValue
Reference to delegate to create new IPhasorValue instances.
createNewFrequencyValue
Type: GSF.PhasorProtocolsCreateNewValueFunction IFrequencyDefinition, IFrequencyValue
Reference to delegate to create new IFrequencyValue instances.
createNewAnalogValue
Type: GSF.PhasorProtocolsCreateNewValueFunction IAnalogDefinition, IAnalogValue
Reference to delegate to create new IAnalogValue instances.
createNewDigitalValue
Type: GSF.PhasorProtocolsCreateNewValueFunction IDigitalDefinition, IDigitalValue
Reference to delegate to create new IDigitalValue instances.
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataCellParsingState Methods

Grid Solutions Framework DataCellParsingState Methods

The DataCellParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataCellParsingState Properties

Grid Solutions Framework DataCellParsingState Properties

The DataCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | ConfigurationCell | Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
Public property | CreateNewAnalogValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IAnalogValue objects.
Public property | CreateNewDigitalValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IDigitalValue objects.
Public property | CreateNewFrequencyValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IFrequencyValue objects.
Public property | CreateNewPhasorValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IPhasorValue objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from ChannelCellParsingStateBase.)
Top
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataCellParsingState.ConfigurationCell Property

Grid Solutions Framework DataCellParsingStateConfigurationCell Property
Gets reference to the IConfigurationCell associated with the IDataCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationCell ConfigurationCell { get; }
Public Overridable ReadOnly Property ConfigurationCell As IConfigurationCell
    Get
abstract ConfigurationCell : IConfigurationCell with get
override ConfigurationCell : IConfigurationCell with get
function get_ConfigurationCell();

public:
virtual property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
}

Property Value

Type: IConfigurationCell

Implements

IDataCellParsingStateConfigurationCell
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataCellParsingState.CreateNewAnalogValue Property

Grid Solutions Framework DataCellParsingStateCreateNewAnalogValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IAnalogValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewValueFunction<IAnalogDefinition, IAnalogValue> CreateNewAnalogValue { get; }
Public Overridable ReadOnly Property CreateNewAnalogValue As CreateNewValueFunction(Of IAnalogDefinition, IAnalogValue)
    Get
abstract CreateNewAnalogValue : CreateNewValueFunction<IAnalogDefinition, IAnalogValue> with get
override CreateNewAnalogValue : CreateNewValueFunction<IAnalogDefinition, IAnalogValue> with get
function get_CreateNewAnalogValue();

public:
virtual property CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ CreateNewAnalogValue {
    CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IAnalogDefinition, IAnalogValue

Implements

IDataCellParsingStateCreateNewAnalogValue
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataCellParsingState.CreateNewDigitalValue Property

Grid Solutions Framework DataCellParsingStateCreateNewDigitalValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IDigitalValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewValueFunction<IDigitalDefinition, IDigitalValue> CreateNewDigitalValue { get; }
Public Overridable ReadOnly Property CreateNewDigitalValue As CreateNewValueFunction(Of IDigitalDefinition, IDigitalValue)
    Get
abstract CreateNewDigitalValue : CreateNewValueFunction<IDigitalDefinition, IDigitalValue> with get
override CreateNewDigitalValue : CreateNewValueFunction<IDigitalDefinition, IDigitalValue> with get
function get_CreateNewDigitalValue();

public:
virtual property CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ CreateNewDigitalValue {
    CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IDigitalDefinition, IDigitalValue

Implements

IDataCellParsingStateCreateNewDigitalValue
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataCellParsingState.CreateNewFrequencyValue Property

Grid Solutions Framework DataCellParsingStateCreateNewFrequencyValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IFrequencyValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> CreateNewFrequencyValue { get; }
Public Overridable ReadOnly Property CreateNewFrequencyValue As CreateNewValueFunction(Of IFrequencyDefinition, IFrequencyValue)
    Get
abstract CreateNewFrequencyValue : CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> with get
override CreateNewFrequencyValue : CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> with get
function get_CreateNewFrequencyValue();

public:
virtual property CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ CreateNewFrequencyValue {
    CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IFrequencyDefinition, IFrequencyValue

Implements

IDataCellParsingStateCreateNewFrequencyValue
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataCellParsingState.CreateNewPhasorValue Property

Grid Solutions Framework DataCellParsingStateCreateNewPhasorValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IPhasorValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CreateNewValueFunction<IPhasorDefinition, IPhasorValue> CreateNewPhasorValue { get; }
Public Overridable ReadOnly Property CreateNewPhasorValue As CreateNewValueFunction(Of IPhasorDefinition, IPhasorValue)
    Get
abstract CreateNewPhasorValue : CreateNewValueFunction<IPhasorDefinition, IPhasorValue> with get
override CreateNewPhasorValue : CreateNewValueFunction<IPhasorDefinition, IPhasorValue> with get
function get_CreateNewPhasorValue();

public:
virtual property CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ CreateNewPhasorValue {
    CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IPhasorDefinition, IPhasorValue

Implements

IDataCellParsingStateCreateNewPhasorValue
See Also

Reference

DataCellParsingState Class
GSF.PhasorProtocols Namespace


DataFormat Enumeration

Grid Solutions Framework DataFormat Enumeration
Data transmission formats enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DataFormat
<SerializableAttribute>
Public Enumeration DataFormat
[<SerializableAttribute>]
type DataFormat
GSF.PhasorProtocols.DataFormat = function();
GSF.PhasorProtocols.DataFormat.createEnum('GSF.PhasorProtocols.DataFormat', false);
[SerializableAttribute]
public enum class DataFormat
Members
Member name | Value | Description
FixedInteger | 0 | Fixed integer data transmission format.
FloatingPoint | 1 | Floating point data transmission format.
See Also

Reference

GSF.PhasorProtocols Namespace


DataFrameBase Class

Grid Solutions Framework DataFrameBase Class
Represents the protocol independent common implementation of any IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class DataFrameBase : ChannelFrameBase<IDataCell>,
    IDataFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
<SerializableAttribute>
Public MustInherit Class DataFrameBase
    Inherits ChannelFrameBase(Of IDataCell)
    Implements IDataFrame, IChannelFrame, IChannel, ISupportBinaryImage,
    IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),
    IComparable, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DataFrameBase =
    class
        inherit ChannelFrameBase<IDataCell>
        interface IDataFrame
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.DataFrameBase = function();

Type.createClass(
    'GSF.PhasorProtocols.DataFrameBase',
    GSF.PhasorProtocols.ChannelFrameBase`1,
    GSF.PhasorProtocols.IDataFrame,
    GSF.PhasorProtocols.IChannelFrame,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    GSF.TimeSeries.IFrame,
    IEquatable`1,
    IComparable`1,
    IComparable,
    ISerializable);
[SerializableAttribute]
public ref class DataFrameBase abstract : public ChannelFrameBase<IDataCell^>,
    IDataFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable

The DataFrameBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DataFrameBase(SerializationInfo, StreamingContext) | Creates a new DataFrameBase from serialization parameters.
Protected method | DataFrameBase(DataCellCollection, Ticks, IConfigurationFrame) | Creates a new DataFrameBase from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Inherited from ChannelFrameBaseT.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrameBase.
Public property | ConfigurationFrame | Gets or sets IConfigurationFrame associated with this DataFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Overrides ChannelFrameBaseTIDCode.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase.
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.BPAPDCstreamDataFrame
GSF.PhasorProtocols.FNETDataFrame
GSF.PhasorProtocols.IEC61850_90_5DataFrame
GSF.PhasorProtocols.IEEE1344DataFrame
GSF.PhasorProtocols.IEEEC37_118DataFrame
GSF.PhasorProtocols.MacrodyneDataFrame
GSF.PhasorProtocols.SelFastMessageDataFrame


DataFrameBase Constructor

Grid Solutions Framework DataFrameBase Constructor
Overload List
 | Name | Description
Protected method | DataFrameBase(SerializationInfo, StreamingContext) | Creates a new DataFrameBase from serialization parameters.
Protected method | DataFrameBase(DataCellCollection, Ticks, IConfigurationFrame) | Creates a new DataFrameBase from specified parameters.
Top
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrameBase Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrameBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrameBase
GSF.PhasorProtocols.DataFrameBase = function(info, context);
protected:
DataFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrameBase Class
DataFrameBase Overload
GSF.PhasorProtocols Namespace


DataFrameBase Constructor (DataCellCollection, Ticks, IConfigurationFrame)

Grid Solutions Framework DataFrameBase Constructor (DataCellCollection, Ticks, IConfigurationFrame)
Creates a new DataFrameBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrameBase(
    DataCellCollection cells,
    Ticks timestamp,
    IConfigurationFrame configurationFrame
)
Protected Sub New (
    cells As DataCellCollection,
    timestamp As Ticks,
    configurationFrame As IConfigurationFrame
)
new :
        cells : DataCellCollection *
        timestamp : Ticks *
        configurationFrame : IConfigurationFrame -> DataFrameBase
GSF.PhasorProtocols.DataFrameBase = function(cells, timestamp, configurationFrame);
protected:
DataFrameBase(
    DataCellCollection^ cells,
    Ticks timestamp,
    IConfigurationFrame^ configurationFrame
)

Parameters

cells
Type: GSF.PhasorProtocolsDataCellCollection
The reference to the collection of cells for this DataFrameBase.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrameBase.
configurationFrame
Type: GSF.PhasorProtocolsIConfigurationFrame
The IConfigurationFrame associated with this DataFrameBase.
See Also

Reference

DataFrameBase Class
DataFrameBase Overload
GSF.PhasorProtocols Namespace


DataFrameBase Methods

Grid Solutions Framework DataFrameBase Methods

The DataFrameBase type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.GetObjectData Method

Grid Solutions Framework DataFrameBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.ParseBinaryImage Method

Grid Solutions Framework DataFrameBaseParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
This method is overridden to ensure assignment of configuration frame.
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase Properties

Grid Solutions Framework DataFrameBase Properties

The DataFrameBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Inherited from ChannelFrameBaseT.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrameBase.
Public property | ConfigurationFrame | Gets or sets IConfigurationFrame associated with this DataFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Overrides ChannelFrameBaseTIDCode.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase.
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.Cells Property

Grid Solutions Framework DataFrameBaseCells Property
Gets reference to the DataCellCollection for this DataFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As DataCellCollection
    Get
abstract Cells : DataCellCollection with get
override Cells : DataCellCollection with get
function get_Cells();

public:
virtual property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection

Implements

IDataFrameCells
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.ConfigurationFrame Property

Grid Solutions Framework DataFrameBaseConfigurationFrame Property
Gets or sets IConfigurationFrame associated with this DataFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationFrame ConfigurationFrame { get; set; }
Public Overridable Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}

Property Value

Type: IConfigurationFrame

Implements

IDataFrameConfigurationFrame
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.FrameType Property

Grid Solutions Framework DataFrameBaseFrameType Property
Gets the FundamentalFrameType for this DataFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
abstract FrameType : FundamentalFrameType with get
override FrameType : FundamentalFrameType with get
function get_FrameType();

public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}

Property Value

Type: FundamentalFrameType

Implements

IChannelFrameFrameType
IChannelFrameFrameType
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.IDCode Property

Grid Solutions Framework DataFrameBaseIDCode Property
Gets the numeric ID code for this DataFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}

Property Value

Type: UInt16

Implements

IChannelFrameIDCode
IChannelFrameIDCode
Exceptions
Exception | Condition
NotSupportedException | IDCode of a data frame is read-only, change IDCode is associated configuration frame instead.
Remarks
This value is read-only for DataFrameBase; assigning a value will throw an exception. Value returned is the IDCode of the associated ConfigurationFrame.
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.QualityFlags Property

Grid Solutions Framework DataFrameBaseQualityFlags Property
Gets or sets protocol specific quality flags for this DataFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual uint QualityFlags { get; set; }
Public Overridable Property QualityFlags As UInteger
    Get
    Set
abstract QualityFlags : uint32 with get, set
override QualityFlags : uint32 with get, set
function get_QualityFlags();
function set_QualityFlags(value);
public:
virtual property unsigned int QualityFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32

Implements

IDataFrameQualityFlags
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameBase.State Property

Grid Solutions Framework DataFrameBaseState Property
Gets or sets the parsing state for the this DataFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IDataFrameParsingState State { get; set; }
Public Overridable Property State As IDataFrameParsingState
    Get
    Set
abstract State : IDataFrameParsingState with get, set
override State : IDataFrameParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IDataFrameParsingState^ State {
    IDataFrameParsingState^ get ();
    void set (IDataFrameParsingState^ value);
}

Property Value

Type: IDataFrameParsingState

Implements

IDataFrameState
See Also

Reference

DataFrameBase Class
GSF.PhasorProtocols Namespace


DataFrameCollection Class

Grid Solutions Framework DataFrameCollection Class
Represents a protocol independent collection of IDataFrame objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataFrame
GSF.CollectionsListCollection IDataFrame
GSF.PhasorProtocolsChannelCollectionBase IDataFrame
GSF.PhasorProtocolsChannelFrameCollectionBase IDataFrame
GSF.PhasorProtocolsDataFrameCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrameCollection : ChannelFrameCollectionBase<IDataFrame>
<SerializableAttribute>
Public Class DataFrameCollection
    Inherits ChannelFrameCollectionBase(Of IDataFrame)
[<SerializableAttribute>]
type DataFrameCollection =
    class
        inherit ChannelFrameCollectionBase<IDataFrame>
    end
GSF.PhasorProtocols.DataFrameCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.DataFrameCollection',
    GSF.PhasorProtocols.ChannelFrameCollectionBase`1);
[SerializableAttribute]
public ref class DataFrameCollection : public ChannelFrameCollectionBase<IDataFrame^>

The DataFrameCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrameCollection(Int32) | Creates a new DataFrameCollection using specified lastValidIndex.
Protected method | DataFrameCollection(SerializationInfo, StreamingContext) | Creates a new DataFrameCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelFrameCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


DataFrameCollection Constructor

Grid Solutions Framework DataFrameCollection Constructor
Overload List
 | Name | Description
Public method | DataFrameCollection(Int32) | Creates a new DataFrameCollection using specified lastValidIndex.
Protected method | DataFrameCollection(SerializationInfo, StreamingContext) | Creates a new DataFrameCollection from serialization parameters.
Top
See Also

Reference

DataFrameCollection Class
GSF.PhasorProtocols Namespace


DataFrameCollection Constructor (Int32)

Grid Solutions Framework DataFrameCollection Constructor (Int32)
Creates a new DataFrameCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrameCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> DataFrameCollection
GSF.PhasorProtocols.DataFrameCollection = function(lastValidIndex);
public:
DataFrameCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

DataFrameCollection Class
DataFrameCollection Overload
GSF.PhasorProtocols Namespace


DataFrameCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrameCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrameCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrameCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrameCollection
GSF.PhasorProtocols.DataFrameCollection = function(info, context);
protected:
DataFrameCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrameCollection Class
DataFrameCollection Overload
GSF.PhasorProtocols Namespace


DataFrameCollection Methods

Grid Solutions Framework DataFrameCollection Methods

The DataFrameCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataFrameCollection Class
GSF.PhasorProtocols Namespace


DataFrameCollection Properties

Grid Solutions Framework DataFrameCollection Properties

The DataFrameCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelFrameCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataFrameCollection Class
GSF.PhasorProtocols Namespace


DataFrameCollection Events

Grid Solutions Framework DataFrameCollection Events

The DataFrameCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataFrameCollection Class
GSF.PhasorProtocols Namespace


DataFrameParsingState Class

Grid Solutions Framework DataFrameParsingState Class
Represents the protocol independent common implementation of the parsing state used by any IDataFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBase IDataCell
GSF.PhasorProtocolsDataFrameParsingState
GSF.PhasorProtocols.BPAPDCstreamDataFrameParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataFrameParsingState : ChannelFrameParsingStateBase<IDataCell>,
    IDataFrameParsingState, IChannelFrameParsingState<IDataCell>, IChannelParsingState
Public Class DataFrameParsingState
    Inherits ChannelFrameParsingStateBase(Of IDataCell)
    Implements IDataFrameParsingState, IChannelFrameParsingState(Of IDataCell),
    IChannelParsingState
type DataFrameParsingState =
    class
        inherit ChannelFrameParsingStateBase<IDataCell>
        interface IDataFrameParsingState
        interface IChannelFrameParsingState<IDataCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.DataFrameParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.DataFrameParsingState',
    GSF.PhasorProtocols.ChannelFrameParsingStateBase`1,
    GSF.PhasorProtocols.IDataFrameParsingState,
    GSF.PhasorProtocols.IChannelFrameParsingState`1,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class DataFrameParsingState : public ChannelFrameParsingStateBase<IDataCell^>,
    IDataFrameParsingState, IChannelFrameParsingState<IDataCell^>, IChannelParsingState

The DataFrameParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrameParsingState | Creates a new DataFrameParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ConfigurationFrame | Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


DataFrameParsingState Constructor

Grid Solutions Framework DataFrameParsingState Constructor
Creates a new DataFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame configurationFrame,
    CreateNewCellFunction<IDataCell> createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)
Public Sub New (
    parsedBinaryLength As Integer,
    configurationFrame As IConfigurationFrame,
    createNewCellFunction As CreateNewCellFunction(Of IDataCell),
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        configurationFrame : IConfigurationFrame *
        createNewCellFunction : CreateNewCellFunction<IDataCell> *
        trustHeaderLength : bool *
        validateCheckSum : bool -> DataFrameParsingState
GSF.PhasorProtocols.DataFrameParsingState = function(parsedBinaryLength, configurationFrame, createNewCellFunction, trustHeaderLength, validateCheckSum);
public:
DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame^ configurationFrame,
    CreateNewCellFunction<IDataCell^>^ createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the IDataFrame being parsed.
configurationFrame
Type: GSF.PhasorProtocolsIConfigurationFrame
Reference to the IConfigurationFrame associated with the IDataFrame being parsed.
createNewCellFunction
Type: GSF.PhasorProtocolsCreateNewCellFunction IDataCell
Reference to delegate to create new IDataCell instances.
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols Namespace


DataFrameParsingState Methods

Grid Solutions Framework DataFrameParsingState Methods

The DataFrameParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols Namespace


DataFrameParsingState Properties

Grid Solutions Framework DataFrameParsingState Properties

The DataFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ConfigurationFrame | Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols Namespace


DataFrameParsingState.ConfigurationFrame Property

Grid Solutions Framework DataFrameParsingStateConfigurationFrame Property
Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConfigurationFrame ConfigurationFrame { get; }
Public Overridable ReadOnly Property ConfigurationFrame As IConfigurationFrame
    Get
abstract ConfigurationFrame : IConfigurationFrame with get
override ConfigurationFrame : IConfigurationFrame with get
function get_ConfigurationFrame();

public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
}

Property Value

Type: IConfigurationFrame

Implements

IDataFrameParsingStateConfigurationFrame
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols Namespace


DataSortingType Enumeration

Grid Solutions Framework DataSortingType Enumeration
Data sorting types enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DataSortingType
<SerializableAttribute>
Public Enumeration DataSortingType
[<SerializableAttribute>]
type DataSortingType
GSF.PhasorProtocols.DataSortingType = function();
GSF.PhasorProtocols.DataSortingType.createEnum('GSF.PhasorProtocols.DataSortingType', false);
[SerializableAttribute]
public enum class DataSortingType
Members
Member name | Value | Description
ByTimestamp | 0 | Data sorted by timestamp (typical situation).
ByArrival | 1 | Data sorted by arrival (bad timestamp).
See Also

Reference

GSF.PhasorProtocols Namespace


DeviceCommand Enumeration

Grid Solutions Framework DeviceCommand Enumeration
Phasor enabled device commands enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DeviceCommand
<SerializableAttribute>
Public Enumeration DeviceCommand
[<SerializableAttribute>]
type DeviceCommand
GSF.PhasorProtocols.DeviceCommand = function();
GSF.PhasorProtocols.DeviceCommand.createEnum('GSF.PhasorProtocols.DeviceCommand', false);
[SerializableAttribute]
public enum class DeviceCommand
Members
Member name | Value | Description
DisableRealTimeData | 1 | 0001 Turn off transmission of data frames.
EnableRealTimeData | 2 | 0010 Turn on transmission of data frames.
SendHeaderFrame | 3 | 0011 Send header file.
SendConfigurationFrame1 | 4 | 0100 Send configuration file 1.
SendConfigurationFrame2 | 5 | 0101 Send configuration file 2.
ReceiveExtendedFrame | 8 | 1000 Receive extended frame for IEEE C37.118 / receive reference phasor for IEEE 1344.
ReservedBits | 65520 | Reserved bits.
See Also

Reference

GSF.PhasorProtocols Namespace


DigitalDefinitionBase Class

Grid Solutions Framework DigitalDefinitionBase Class
Represents the common implementation of the protocol independent definition of a IDigitalValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class DigitalDefinitionBase : ChannelDefinitionBase,
    IDigitalDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute>
Public MustInherit Class DigitalDefinitionBase
    Inherits ChannelDefinitionBase
    Implements IDigitalDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),
    IComparable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DigitalDefinitionBase =
    class
        inherit ChannelDefinitionBase
        interface IDigitalDefinition
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.DigitalDefinitionBase = function();

Type.createClass(
    'GSF.PhasorProtocols.DigitalDefinitionBase',
    GSF.PhasorProtocols.ChannelDefinitionBase,
    GSF.PhasorProtocols.IDigitalDefinition,
    GSF.PhasorProtocols.IChannelDefinition,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable,
    IEquatable`1,
    IComparable`1,
    IComparable);
[SerializableAttribute]
public ref class DigitalDefinitionBase abstract : public ChannelDefinitionBase,
    IDigitalDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable

The DigitalDefinitionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalDefinitionBase(IConfigurationCell) | Creates a new DigitalDefinitionBase.
Protected method | DigitalDefinitionBase(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionBase from serialization parameters.
Protected method | DigitalDefinitionBase(IConfigurationCell, String) | Creates a new DigitalDefinitionBase from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseOffset.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseScalePerBit.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseScalingValue.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocols.AnonymousDigitalDefinition
GSF.PhasorProtocols.BPAPDCstreamDigitalDefinition
GSF.PhasorProtocols.IEC61850_90_5DigitalDefinition
GSF.PhasorProtocols.IEEE1344DigitalDefinition
GSF.PhasorProtocols.IEEEC37_118DigitalDefinition
GSF.PhasorProtocols.MacrodyneDigitalDefinition


DigitalDefinitionBase Constructor

Grid Solutions Framework DigitalDefinitionBase Constructor
Overload List
 | Name | Description
Protected method | DigitalDefinitionBase(IConfigurationCell) | Creates a new DigitalDefinitionBase.
Protected method | DigitalDefinitionBase(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionBase from serialization parameters.
Protected method | DigitalDefinitionBase(IConfigurationCell, String) | Creates a new DigitalDefinitionBase from specified parameters.
Top
See Also

Reference

DigitalDefinitionBase Class
GSF.PhasorProtocols Namespace


DigitalDefinitionBase Constructor (IConfigurationCell)

Grid Solutions Framework DigitalDefinitionBase Constructor (IConfigurationCell)
Creates a new DigitalDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> DigitalDefinitionBase
GSF.PhasorProtocols.DigitalDefinitionBase = function(parent);
protected:
DigitalDefinitionBase(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this DigitalDefinitionBase.
See Also

Reference

DigitalDefinitionBase Class
DigitalDefinitionBase Overload
GSF.PhasorProtocols Namespace


DigitalDefinitionBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinitionBase Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinitionBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinitionBase
GSF.PhasorProtocols.DigitalDefinitionBase = function(info, context);
protected:
DigitalDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinitionBase Class
DigitalDefinitionBase Overload
GSF.PhasorProtocols Namespace


DigitalDefinitionBase Constructor (IConfigurationCell, String)

Grid Solutions Framework DigitalDefinitionBase Constructor (IConfigurationCell, String)
Creates a new DigitalDefinitionBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinitionBase(
    IConfigurationCell parent,
    string label
)
Protected Sub New (
    parent As IConfigurationCell,
    label As String
)
new :
        parent : IConfigurationCell *
        label : string -> DigitalDefinitionBase
GSF.PhasorProtocols.DigitalDefinitionBase = function(parent, label);
protected:
DigitalDefinitionBase(
    IConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this DigitalDefinitionBase.
label
Type: SystemString
The label of this DigitalDefinitionBase.
See Also

Reference

DigitalDefinitionBase Class
DigitalDefinitionBase Overload
GSF.PhasorProtocols Namespace


DigitalDefinitionBase Methods

Grid Solutions Framework DigitalDefinitionBase Methods

The DigitalDefinitionBase type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DigitalDefinitionBase Class
GSF.PhasorProtocols Namespace


DigitalDefinitionBase Properties

Grid Solutions Framework DigitalDefinitionBase Properties

The DigitalDefinitionBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseOffset.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseScalePerBit.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Overrides ChannelDefinitionBaseScalingValue.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

DigitalDefinitionBase Class
GSF.PhasorProtocols Namespace


DigitalDefinitionBase.DataFormat Property

Grid Solutions Framework DigitalDefinitionBaseDataFormat Property
Gets the DataFormat of this DigitalDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed DataFormat DataFormat { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides NotOverridable ReadOnly Property DataFormat As DataFormat
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract DataFormat : DataFormat with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override DataFormat : DataFormat with get
function get_DataFormat();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property DataFormat DataFormat {
    DataFormat get () override sealed;
}

Property Value

Type: DataFormat

Implements

IChannelDefinitionDataFormat
IChannelDefinitionDataFormat
Remarks
Data format for digital values will always be FixedInteger.
See Also

Reference

DigitalDefinitionBase Class
GSF.PhasorProtocols Namespace


DigitalDefinitionBase.Offset Property

Grid Solutions Framework DigitalDefinitionBaseOffset Property
Gets or sets the offset of this DigitalDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed double Offset { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides NotOverridable Property Offset As Double
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Offset : float with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Offset : float with get, set
function get_Offset();
function set_Offset(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property double Offset {
    double get () override sealed;
    void set (double value) override sealed;
}

Property Value

Type: Double

Implements

IChannelDefinitionOffset
IChannelDefinitionOffset
Exceptions
Exception | Condition
NotImplementedException | Digital values represent bit flags and thus do not support an offset.
Remarks
Offset for digital values will always be 0; assigning a value other than 0 will thrown an exception.
See Also

Reference

DigitalDefinitionBase Class
GSF.PhasorProtocols Namespace


DigitalDefinitionBase.ScalePerBit Property

Grid Solutions Framework DigitalDefinitionBaseScalePerBit Property
Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed double ScalePerBit { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides NotOverridable ReadOnly Property ScalePerBit As Double
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ScalePerBit : float with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ScalePerBit : float with get
function get_ScalePerBit();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property double ScalePerBit {
    double get () override sealed;
}

Property Value

Type: Double

Implements

IChannelDefinitionScalePerBit
IChannelDefinitionScalePerBit
Remarks
Scale/bit for digital values will always be 1.0.
See Also

Reference

DigitalDefinitionBase Class
GSF.PhasorProtocols Namespace


DigitalDefinitionBase.ScalingValue Property

Grid Solutions Framework DigitalDefinitionBaseScalingValue Property
Gets or sets the integer scaling value of this DigitalDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override sealed uint ScalingValue { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides NotOverridable Property ScalingValue As UInteger
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ScalingValue : uint32 with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ScalingValue : uint32 with get, set
function get_ScalingValue();
function set_ScalingValue(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property unsigned int ScalingValue {
    unsigned int get () override sealed;
    void set (unsigned int value) override sealed;
}

Property Value

Type: UInt32

Implements

IChannelDefinitionScalingValue
IChannelDefinitionScalingValue
Exceptions
Exception | Condition
NotImplementedException | Digital values represent bit flags and thus are not scaled.
Remarks
Scaling value for digital values will always be 1; assigning a value other than 1 will thrown an exception.
See Also

Reference

DigitalDefinitionBase Class
GSF.PhasorProtocols Namespace


DigitalDefinitionCollection Class

Grid Solutions Framework DigitalDefinitionCollection Class
Represents a protocol independent collection of IDigitalDefinition objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDigitalDefinition
GSF.CollectionsListCollection IDigitalDefinition
GSF.PhasorProtocolsChannelCollectionBase IDigitalDefinition
GSF.PhasorProtocolsChannelDefinitionCollectionBase IDigitalDefinition
GSF.PhasorProtocolsDigitalDefinitionCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalDefinitionCollection : ChannelDefinitionCollectionBase<IDigitalDefinition>
<SerializableAttribute>
Public Class DigitalDefinitionCollection
    Inherits ChannelDefinitionCollectionBase(Of IDigitalDefinition)
[<SerializableAttribute>]
type DigitalDefinitionCollection =
    class
        inherit ChannelDefinitionCollectionBase<IDigitalDefinition>
    end
GSF.PhasorProtocols.DigitalDefinitionCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.DigitalDefinitionCollection',
    GSF.PhasorProtocols.ChannelDefinitionCollectionBase`1);
[SerializableAttribute]
public ref class DigitalDefinitionCollection : public ChannelDefinitionCollectionBase<IDigitalDefinition^>

The DigitalDefinitionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalDefinitionCollection(Int32) | Creates a new DigitalDefinitionCollection using specified lastValidIndex.
Protected method | DigitalDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


DigitalDefinitionCollection Constructor

Grid Solutions Framework DigitalDefinitionCollection Constructor
Overload List
 | Name | Description
Public method | DigitalDefinitionCollection(Int32) | Creates a new DigitalDefinitionCollection using specified lastValidIndex.
Protected method | DigitalDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new DigitalDefinitionCollection from serialization parameters.
Top
See Also

Reference

DigitalDefinitionCollection Class
GSF.PhasorProtocols Namespace


DigitalDefinitionCollection Constructor (Int32)

Grid Solutions Framework DigitalDefinitionCollection Constructor (Int32)
Creates a new DigitalDefinitionCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinitionCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> DigitalDefinitionCollection
GSF.PhasorProtocols.DigitalDefinitionCollection = function(lastValidIndex);
public:
DigitalDefinitionCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

DigitalDefinitionCollection Class
DigitalDefinitionCollection Overload
GSF.PhasorProtocols Namespace


DigitalDefinitionCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinitionCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinitionCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinitionCollection
GSF.PhasorProtocols.DigitalDefinitionCollection = function(info, context);
protected:
DigitalDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinitionCollection Class
DigitalDefinitionCollection Overload
GSF.PhasorProtocols Namespace


DigitalDefinitionCollection Methods

Grid Solutions Framework DigitalDefinitionCollection Methods

The DigitalDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalDefinitionCollection Class
GSF.PhasorProtocols Namespace


DigitalDefinitionCollection Properties

Grid Solutions Framework DigitalDefinitionCollection Properties

The DigitalDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DigitalDefinitionCollection Class
GSF.PhasorProtocols Namespace


DigitalDefinitionCollection Events

Grid Solutions Framework DigitalDefinitionCollection Events

The DigitalDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DigitalDefinitionCollection Class
GSF.PhasorProtocols Namespace


DigitalValueBase Class

Grid Solutions Framework DigitalValueBase Class
Represents the common implementation of the protocol independent representation of a digital value.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IDigitalDefinition
GSF.PhasorProtocolsDigitalValueBase
GSF.PhasorProtocols.BPAPDCstreamDigitalValue
GSF.PhasorProtocols.IEC61850_90_5DigitalValue
GSF.PhasorProtocols.IEEE1344DigitalValue
GSF.PhasorProtocols.IEEEC37_118DigitalValue
GSF.PhasorProtocols.MacrodyneDigitalValue

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class DigitalValueBase : ChannelValueBase<IDigitalDefinition>,
    IDigitalValue, IChannelValue<IDigitalDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute>
Public MustInherit Class DigitalValueBase
    Inherits ChannelValueBase(Of IDigitalDefinition)
    Implements IDigitalValue, IChannelValue(Of IDigitalDefinition),
    IChannel, ISupportBinaryImage, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type DigitalValueBase =
    class
        inherit ChannelValueBase<IDigitalDefinition>
        interface IDigitalValue
        interface IChannelValue<IDigitalDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.DigitalValueBase = function();

Type.createClass(
    'GSF.PhasorProtocols.DigitalValueBase',
    GSF.PhasorProtocols.ChannelValueBase`1,
    GSF.PhasorProtocols.IDigitalValue,
    GSF.PhasorProtocols.IChannelValue`1,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class DigitalValueBase abstract : public ChannelValueBase<IDigitalDefinition^>,
    IDigitalValue, IChannelValue<IDigitalDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable

The DigitalValueBase type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalValueBase(SerializationInfo, StreamingContext) | Creates a new DigitalValueBase from serialization parameters.
Protected method | DigitalValueBase(IDataCell, IDigitalDefinition) | Creates a new DigitalValueBase.
Protected method | DigitalValueBase(IDataCell, IDigitalDefinition, UInt16) | Creates a new DigitalValueBase from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Overrides ChannelValueBaseTGetMeasurementValueFilterFunction(Int32).)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


DigitalValueBase Constructor

Grid Solutions Framework DigitalValueBase Constructor
Overload List
 | Name | Description
Protected method | DigitalValueBase(SerializationInfo, StreamingContext) | Creates a new DigitalValueBase from serialization parameters.
Protected method | DigitalValueBase(IDataCell, IDigitalDefinition) | Creates a new DigitalValueBase.
Protected method | DigitalValueBase(IDataCell, IDigitalDefinition, UInt16) | Creates a new DigitalValueBase from specified parameters.
Top
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalValueBase Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalValueBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalValueBase
GSF.PhasorProtocols.DigitalValueBase = function(info, context);
protected:
DigitalValueBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalValueBase Class
DigitalValueBase Overload
GSF.PhasorProtocols Namespace


DigitalValueBase Constructor (IDataCell, IDigitalDefinition)

Grid Solutions Framework DigitalValueBase Constructor (IDataCell, IDigitalDefinition)
Creates a new DigitalValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValueBase(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Protected Sub New (
    parent As IDataCell,
    digitalDefinition As IDigitalDefinition
)
new :
        parent : IDataCell *
        digitalDefinition : IDigitalDefinition -> DigitalValueBase
GSF.PhasorProtocols.DigitalValueBase = function(parent, digitalDefinition);
protected:
DigitalValueBase(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this DigitalValueBase.
digitalDefinition
Type: GSF.PhasorProtocolsIDigitalDefinition
The IDigitalDefinition associated with this DigitalValueBase.
See Also

Reference

DigitalValueBase Class
DigitalValueBase Overload
GSF.PhasorProtocols Namespace


DigitalValueBase Constructor (IDataCell, IDigitalDefinition, UInt16)

Grid Solutions Framework DigitalValueBase Constructor (IDataCell, IDigitalDefinition, UInt16)
Creates a new DigitalValueBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValueBase(
    IDataCell parent,
    IDigitalDefinition digitalDefinition,
    ushort value
)
Protected Sub New (
    parent As IDataCell,
    digitalDefinition As IDigitalDefinition,
    value As UShort
)
new :
        parent : IDataCell *
        digitalDefinition : IDigitalDefinition *
        value : uint16 -> DigitalValueBase
GSF.PhasorProtocols.DigitalValueBase = function(parent, digitalDefinition, value);
protected:
DigitalValueBase(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition,
    unsigned short value
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this DigitalValueBase.
digitalDefinition
Type: GSF.PhasorProtocolsIDigitalDefinition
The IDigitalDefinition associated with this DigitalValueBase.
value
Type: SystemUInt16
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase.
See Also

Reference

DigitalValueBase Class
DigitalValueBase Overload
GSF.PhasorProtocols Namespace


DigitalValueBase Methods

Grid Solutions Framework DigitalValueBase Methods

The DigitalValueBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Overrides ChannelValueBaseTGetMeasurementValueFilterFunction(Int32).)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.GetCompositeValue Method

Grid Solutions Framework DigitalValueBaseGetCompositeValue Method
Gets the specified composite value of this DigitalValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue (
    index As Integer
) As Double
abstract GetCompositeValue :
        index : int -> float
override GetCompositeValue :
        index : int -> float
function GetCompositeValue(index);
public:
virtual double GetCompositeValue(
    int index
) override

Parameters

index
Type: SystemInt32
Index of composite value to retrieve.

Return Value

Type: Double
A Double representing the composite value.

Implements

IChannelValueTGetCompositeValue(Int32)
IChannelValueTGetCompositeValue(Int32)
Remarks
Some ChannelValueBaseT implementations can contain more than one value, this method is used to abstractly expose each value.
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.GetMeasurementValueFilterFunction Method

Grid Solutions Framework DigitalValueBaseGetMeasurementValueFilterFunction Method
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Public Overrides Function GetMeasurementValueFilterFunction (
    index As Integer
) As MeasurementValueFilterFunction
abstract GetMeasurementValueFilterFunction :
        index : int -> MeasurementValueFilterFunction
override GetMeasurementValueFilterFunction :
        index : int -> MeasurementValueFilterFunction
function GetMeasurementValueFilterFunction(index);
public:
virtual MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
) override

Parameters

index
Type: SystemInt32
Index of composite value for which to retrieve its filter function.

Return Value

Type: MeasurementValueFilterFunction
Majority value filter function since all values are digital in nature.

Implements

IChannelValueTGetMeasurementValueFilterFunction(Int32)
IChannelValueTGetMeasurementValueFilterFunction(Int32)
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.GetObjectData Method

Grid Solutions Framework DigitalValueBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.ParseBodyImage Method

Grid Solutions Framework DigitalValueBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase Properties

Grid Solutions Framework DigitalValueBase Properties

The DigitalValueBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase.
Top
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.Attributes Property

Grid Solutions Framework DigitalValueBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.BodyImage Property

Grid Solutions Framework DigitalValueBaseBodyImage Property
Gets the binary body image of the DigitalValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.BodyLength Property

Grid Solutions Framework DigitalValueBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.CompositeValueCount Property

Grid Solutions Framework DigitalValueBaseCompositeValueCount Property
Gets total number of composite values that this DigitalValueBase provides.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
abstract CompositeValueCount : int with get
override CompositeValueCount : int with get
function get_CompositeValueCount();

public:
virtual property int CompositeValueCount {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelValueTCompositeValueCount
IChannelValueTCompositeValueCount
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.IsEmpty Property

Grid Solutions Framework DigitalValueBaseIsEmpty Property
Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get
override IsEmpty : bool with get
function get_IsEmpty();

public:
virtual property bool IsEmpty {
    bool get () override;
}

Return Value

Type: Boolean
True, if no composite values have been assigned a value; otherwise, false.

Implements

IChannelValueTIsEmpty
IChannelValueTIsEmpty
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueBase.Value Property

Grid Solutions Framework DigitalValueBaseValue Property
Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ushort Value { get; set; }
Public Overridable Property Value As UShort
    Get
    Set
abstract Value : uint16 with get, set
override Value : uint16 with get, set
function get_Value();
function set_Value(value);
public:
virtual property unsigned short Value {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16

Implements

IDigitalValueValue
See Also

Reference

DigitalValueBase Class
GSF.PhasorProtocols Namespace


DigitalValueCollection Class

Grid Solutions Framework DigitalValueCollection Class
Represents a protocol independent collection of IDigitalValue objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDigitalValue
GSF.CollectionsListCollection IDigitalValue
GSF.PhasorProtocolsChannelCollectionBase IDigitalValue
GSF.PhasorProtocolsChannelValueCollectionBase IDigitalDefinition, IDigitalValue
GSF.PhasorProtocolsDigitalValueCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalValueCollection : ChannelValueCollectionBase<IDigitalDefinition, IDigitalValue>
<SerializableAttribute>
Public Class DigitalValueCollection
    Inherits ChannelValueCollectionBase(Of IDigitalDefinition, IDigitalValue)
[<SerializableAttribute>]
type DigitalValueCollection =
    class
        inherit ChannelValueCollectionBase<IDigitalDefinition, IDigitalValue>
    end
GSF.PhasorProtocols.DigitalValueCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.DigitalValueCollection',
    GSF.PhasorProtocols.ChannelValueCollectionBase`2);
[SerializableAttribute]
public ref class DigitalValueCollection : public ChannelValueCollectionBase<IDigitalDefinition^, IDigitalValue^>

The DigitalValueCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalValueCollection(Int32) | Creates a new DigitalValueCollection using specified lastValidIndex.
Protected method | DigitalValueCollection(SerializationInfo, StreamingContext) | Creates a new DigitalValueCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


DigitalValueCollection Constructor

Grid Solutions Framework DigitalValueCollection Constructor
Overload List
 | Name | Description
Public method | DigitalValueCollection(Int32) | Creates a new DigitalValueCollection using specified lastValidIndex.
Protected method | DigitalValueCollection(SerializationInfo, StreamingContext) | Creates a new DigitalValueCollection from serialization parameters.
Top
See Also

Reference

DigitalValueCollection Class
GSF.PhasorProtocols Namespace


DigitalValueCollection Constructor (Int32)

Grid Solutions Framework DigitalValueCollection Constructor (Int32)
Creates a new DigitalValueCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValueCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> DigitalValueCollection
GSF.PhasorProtocols.DigitalValueCollection = function(lastValidIndex);
public:
DigitalValueCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

DigitalValueCollection Class
DigitalValueCollection Overload
GSF.PhasorProtocols Namespace


DigitalValueCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalValueCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalValueCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalValueCollection
GSF.PhasorProtocols.DigitalValueCollection = function(info, context);
protected:
DigitalValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalValueCollection Class
DigitalValueCollection Overload
GSF.PhasorProtocols Namespace


DigitalValueCollection Methods

Grid Solutions Framework DigitalValueCollection Methods

The DigitalValueCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalValueCollection Class
GSF.PhasorProtocols Namespace


DigitalValueCollection Properties

Grid Solutions Framework DigitalValueCollection Properties

The DigitalValueCollection type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DigitalValueCollection Class
GSF.PhasorProtocols Namespace


DigitalValueCollection Events

Grid Solutions Framework DigitalValueCollection Events

The DigitalValueCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DigitalValueCollection Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier) Class

Grid Solutions Framework FrameParserBaseTFrameIdentifier Class
Represents a frame parser that defines the basic functionality for a protocol to parse a binary data stream and return the parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase TFrameIdentifier, ISupportSourceIdentifiableFrameImage SourceChannel, TFrameIdentifier
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, TFrameIdentifier, ISupportSourceIdentifiableFrameImage SourceChannel, TFrameIdentifier
GSF.PhasorProtocolsFrameParserBaseTFrameIdentifier
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class FrameParserBase<TFrameIdentifier> : MultiSourceFrameImageParserBase<SourceChannel, TFrameIdentifier, ISupportSourceIdentifiableFrameImage<SourceChannel, TFrameIdentifier>>,
    IFrameParser, IProvideStatus, IDisposable

Public MustInherit Class FrameParserBase(Of TFrameIdentifier)
    Inherits MultiSourceFrameImageParserBase(Of SourceChannel, TFrameIdentifier, ISupportSourceIdentifiableFrameImage(Of SourceChannel, TFrameIdentifier))
    Implements IFrameParser, IProvideStatus, IDisposable
[<AbstractClassAttribute>]
type FrameParserBase<'TFrameIdentifier> =
    class
        inherit MultiSourceFrameImageParserBase<SourceChannel, 'TFrameIdentifier, ISupportSourceIdentifiableFrameImage<SourceChannel, 'TFrameIdentifier>>
        interface IFrameParser
        interface IProvideStatus
        interface IDisposable
    end
JavaScript does not support generic types or methods.
generic<typename TFrameIdentifier>
public ref class FrameParserBase abstract : public MultiSourceFrameImageParserBase<SourceChannel, TFrameIdentifier, ISupportSourceIdentifiableFrameImage<SourceChannel, TFrameIdentifier>^>,
    IFrameParser, IProvideStatus, IDisposable

Type Parameters

TFrameIdentifier
Frame type identifier used to distinguish frames.

The FrameParserBaseTFrameIdentifier type exposes the following members.

Constructors
 | Name | Description
Protected method | FrameParserBaseTFrameIdentifier | Creates a new FrameParserBaseTFrameIdentifier.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event.
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., IDataFrame, IConfigurationFrame, ICommandFrame or IHeaderFrame).
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event.
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event.
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event.
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event.
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event.
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event.
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types.
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the streaming data parser. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Inherited from BinaryImageParserBase.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet.
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParserBaseTFrameIdentifier. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation.
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation.
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation.
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation.
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a IDataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer.
Public event | ReceivedFrameImage | Occurs when a frame image has been received.
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parsers are implemented as a write-only streams so that data can come from any source.
See MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType for more detail. Note that using the multi-source frame image parser base allows buffers to come in from different channels and still be parsed correctly.
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase TFrameIdentifier, ISupportSourceIdentifiableFrameImage SourceChannel, TFrameIdentifier
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, TFrameIdentifier, ISupportSourceIdentifiableFrameImage SourceChannel, TFrameIdentifier
GSF.PhasorProtocolsFrameParserBaseTFrameIdentifier
GSF.PhasorProtocols.BPAPDCstreamFrameParser
GSF.PhasorProtocols.FNETFrameParser
GSF.PhasorProtocols.IEC61850_90_5FrameParser
GSF.PhasorProtocols.IEEE1344FrameParser
GSF.PhasorProtocols.IEEEC37_118FrameParser
GSF.PhasorProtocols.MacrodyneFrameParser
GSF.PhasorProtocols.SelFastMessageFrameParser


FrameParserBase(TFrameIdentifier) Constructor

Grid Solutions Framework FrameParserBaseTFrameIdentifier Constructor
Creates a new FrameParserBaseTFrameIdentifier.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrameParserBase(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes,
    bool trustHeaderLength
)
Protected Sub New (
    checkSumValidationFrameTypes As CheckSumValidationFrameTypes,
    trustHeaderLength As Boolean
)
new :
        checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        trustHeaderLength : bool -> FrameParserBase
GSF.PhasorProtocols.FrameParserBase = function(checkSumValidationFrameTypes, trustHeaderLength);
protected:
FrameParserBase(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes,
    bool trustHeaderLength
)

Parameters

checkSumValidationFrameTypes
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier) Fields

Grid Solutions Framework FrameParserBaseTFrameIdentifier Fields

The FrameParserBaseTFrameIdentifier generic type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier) Methods

Grid Solutions Framework FrameParserBaseTFrameIdentifier Methods

The FrameParserBaseTFrameIdentifier generic type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event.
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., IDataFrame, IConfigurationFrame, ICommandFrame or IHeaderFrame).
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event.
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event.
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event.
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event.
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event.
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event.
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types.
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the streaming data parser. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).Dispose Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeDispose(Boolean).)
Top
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).Dispose Method (Boolean)

Grid Solutions Framework FrameParserBaseTFrameIdentifierDispose Method (Boolean)
Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
Dispose Overload
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnConfigurationChanged Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnConfigurationChanged Method
Raises the ConfigurationChanged event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConfigurationChanged()
Protected Overridable Sub OnConfigurationChanged
abstract OnConfigurationChanged : unit -> unit
override OnConfigurationChanged : unit -> unit
function OnConfigurationChanged();
protected:
virtual void OnConfigurationChanged()
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., IDataFrame, IConfigurationFrame, ICommandFrame or IHeaderFrame).

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overridable Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
)

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnReceivedCommandFrame Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnReceivedCommandFrame Method
Raises the ReceivedCommandFrame event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedCommandFrame(
    ICommandFrame frame
)
Protected Overridable Sub OnReceivedCommandFrame (
    frame As ICommandFrame
)
abstract OnReceivedCommandFrame :
        frame : ICommandFrame -> unit
override OnReceivedCommandFrame :
        frame : ICommandFrame -> unit
function OnReceivedCommandFrame(frame);
protected:
virtual void OnReceivedCommandFrame(
    ICommandFrame^ frame
)

Parameters

frame
Type: GSF.PhasorProtocolsICommandFrame
ICommandFrame to send to ReceivedCommandFrame event.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnReceivedConfigurationFrame Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame Method
Raises the ReceivedConfigurationFrame event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overridable Sub OnReceivedConfigurationFrame (
    frame As IConfigurationFrame
)
abstract OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
override OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
function OnReceivedConfigurationFrame(frame);
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
)

Parameters

frame
Type: GSF.PhasorProtocolsIConfigurationFrame
IConfigurationFrame to send to ReceivedConfigurationFrame event.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnReceivedDataFrame Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnReceivedDataFrame Method
Raises the ReceivedDataFrame event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedDataFrame(
    IDataFrame frame
)
Protected Overridable Sub OnReceivedDataFrame (
    frame As IDataFrame
)
abstract OnReceivedDataFrame :
        frame : IDataFrame -> unit
override OnReceivedDataFrame :
        frame : IDataFrame -> unit
function OnReceivedDataFrame(frame);
protected:
virtual void OnReceivedDataFrame(
    IDataFrame^ frame
)

Parameters

frame
Type: GSF.PhasorProtocolsIDataFrame
IDataFrame to send to ReceivedDataFrame event.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnReceivedFrameBufferImage Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnReceivedFrameBufferImage Method
Raises the ReceivedFrameImage and ReceivedFrameBufferImage event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedFrameBufferImage(
    FundamentalFrameType frameType,
    byte[] buffer,
    int offset,
    int length
)
Protected Overridable Sub OnReceivedFrameBufferImage (
    frameType As FundamentalFrameType,
    buffer As Byte(),
    offset As Integer,
    length As Integer
)
abstract OnReceivedFrameBufferImage :
        frameType : FundamentalFrameType *
        buffer : byte[] *
        offset : int *
        length : int -> unit
override OnReceivedFrameBufferImage :
        frameType : FundamentalFrameType *
        buffer : byte[] *
        offset : int *
        length : int -> unit
function OnReceivedFrameBufferImage(frameType, buffer, offset, length);
protected:
virtual void OnReceivedFrameBufferImage(
    FundamentalFrameType frameType,
    array<unsigned char>^ buffer,
    int offset,
    int length
)

Parameters

frameType
Type: GSF.PhasorProtocolsFundamentalFrameType
FundamentalFrameType to send to ReceivedFrameBufferImage event.
buffer
Type: SystemByte
Frame buffer image to send to ReceivedFrameBufferImage event.
offset
Type: SystemInt32
Offset into frame buffer image to send to ReceivedFrameBufferImage event.
length
Type: SystemInt32
Length of data in frame buffer image to send to ReceivedFrameBufferImage event.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnReceivedHeaderFrame Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnReceivedHeaderFrame Method
Raises the ReceivedHeaderFrame event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedHeaderFrame(
    IHeaderFrame frame
)
Protected Overridable Sub OnReceivedHeaderFrame (
    frame As IHeaderFrame
)
abstract OnReceivedHeaderFrame :
        frame : IHeaderFrame -> unit
override OnReceivedHeaderFrame :
        frame : IHeaderFrame -> unit
function OnReceivedHeaderFrame(frame);
protected:
virtual void OnReceivedHeaderFrame(
    IHeaderFrame^ frame
)

Parameters

frame
Type: GSF.PhasorProtocolsIHeaderFrame
IHeaderFrame to send to ReceivedHeaderFrame event.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnReceivedUndeterminedFrame Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnReceivedUndeterminedFrame Method
Raises the ReceivedUndeterminedFrame event.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedUndeterminedFrame(
    IChannelFrame frame
)
Protected Overridable Sub OnReceivedUndeterminedFrame (
    frame As IChannelFrame
)
abstract OnReceivedUndeterminedFrame :
        frame : IChannelFrame -> unit
override OnReceivedUndeterminedFrame :
        frame : IChannelFrame -> unit
function OnReceivedUndeterminedFrame(frame);
protected:
virtual void OnReceivedUndeterminedFrame(
    IChannelFrame^ frame
)

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame to send to ReceivedUndeterminedFrame event.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).OnUnknownFrameTypeEncountered Method

Grid Solutions Framework FrameParserBaseTFrameIdentifierOnUnknownFrameTypeEncountered Method
Handles unknown frame types.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnknownFrameTypeEncountered(
    TFrameIdentifier frameType
)
Protected Overridable Sub OnUnknownFrameTypeEncountered (
    frameType As TFrameIdentifier
)
abstract OnUnknownFrameTypeEncountered :
        frameType : 'TFrameIdentifier -> unit
override OnUnknownFrameTypeEncountered :
        frameType : 'TFrameIdentifier -> unit
function OnUnknownFrameTypeEncountered(frameType);
protected:
virtual void OnUnknownFrameTypeEncountered(
    TFrameIdentifier frameType
)

Parameters

frameType
Type: TFrameIdentifier
Unknown frame ID.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier) Properties

Grid Solutions Framework FrameParserBaseTFrameIdentifier Properties

The FrameParserBaseTFrameIdentifier generic type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Inherited from BinaryImageParserBase.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet.
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParserBaseTFrameIdentifier. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation.
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation.
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation.
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation.
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).CheckSumValidationFrameTypes Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierCheckSumValidationFrameTypes Property
Gets or sets flags that determine if check-sums for specified frames should be validated.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CheckSumValidationFrameTypes CheckSumValidationFrameTypes { get; set; }
Public Property CheckSumValidationFrameTypes As CheckSumValidationFrameTypes
    Get
    Set
abstract CheckSumValidationFrameTypes : CheckSumValidationFrameTypes with get, set
override CheckSumValidationFrameTypes : CheckSumValidationFrameTypes with get, set
function get_CheckSumValidationFrameTypes();
function set_CheckSumValidationFrameTypes(value);
public:
virtual property CheckSumValidationFrameTypes CheckSumValidationFrameTypes {
    CheckSumValidationFrameTypes get () sealed;
    void set (CheckSumValidationFrameTypes value) sealed;
}

Property Value

Type: CheckSumValidationFrameTypes

Implements

IFrameParserCheckSumValidationFrameTypes
Remarks
It is expected that this will normally be set to AllFrames.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ConfigurationFrame Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract IConfigurationFrame ConfigurationFrame { get; set; }
Public MustOverride Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () abstract;
    void set (IConfigurationFrame^ value) abstract;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ConnectionParameters Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IConnectionParameters ConnectionParameters { get; set; }
Public Overridable Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set
override ConnectionParameters : IConnectionParameters with get, set
function get_ConnectionParameters();
function set_ConnectionParameters(value);
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get ();
    void set (IConnectionParameters^ value);
}

Property Value

Type: IConnectionParameters

Implements

IFrameParserConnectionParameters
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).RedundantFramesPerPacket Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierRedundantFramesPerPacket Property
Gets the number of redundant frames in each packet.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int RedundantFramesPerPacket { get; }
Public Overridable ReadOnly Property RedundantFramesPerPacket As Integer
    Get
abstract RedundantFramesPerPacket : int with get
override RedundantFramesPerPacket : int with get
function get_RedundantFramesPerPacket();

public:
virtual property int RedundantFramesPerPacket {
    int get ();
}

Property Value

Type: Int32

Implements

IFrameParserRedundantFramesPerPacket
Remarks

This value is used when calculating statistics. It is assumed that for each frame that is received, that frame will be included in the next n packets, where n is the number of redundant frames per packet.

This base class returns 0, as most protocols do not support redundant frames.

See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).Status Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierStatus Property
Gets current descriptive status of the FrameParserBaseTFrameIdentifier.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).TrustHeaderLength Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierTrustHeaderLength Property
Gets or sets flag that determines if header lengths should be trusted over parsed byte count.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TrustHeaderLength { get; set; }
Public Property TrustHeaderLength As Boolean
    Get
    Set
abstract TrustHeaderLength : bool with get, set
override TrustHeaderLength : bool with get, set
function get_TrustHeaderLength();
function set_TrustHeaderLength(value);
public:
virtual property bool TrustHeaderLength {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IFrameParserTrustHeaderLength
Remarks
It is expected that this will normally be left as true
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ValidateCommandFrameCheckSum Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierValidateCommandFrameCheckSum Property
Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool ValidateCommandFrameCheckSum { get; }
Protected ReadOnly Property ValidateCommandFrameCheckSum As Boolean
    Get
member ValidateCommandFrameCheckSum : bool with get

function get_ValidateCommandFrameCheckSum();

protected:
property bool ValidateCommandFrameCheckSum {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ValidateConfigurationFrameCheckSum Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierValidateConfigurationFrameCheckSum Property
Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool ValidateConfigurationFrameCheckSum { get; }
Protected ReadOnly Property ValidateConfigurationFrameCheckSum As Boolean
    Get
member ValidateConfigurationFrameCheckSum : bool with get

function get_ValidateConfigurationFrameCheckSum();

protected:
property bool ValidateConfigurationFrameCheckSum {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ValidateDataFrameCheckSum Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierValidateDataFrameCheckSum Property
Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool ValidateDataFrameCheckSum { get; }
Protected ReadOnly Property ValidateDataFrameCheckSum As Boolean
    Get
member ValidateDataFrameCheckSum : bool with get

function get_ValidateDataFrameCheckSum();

protected:
property bool ValidateDataFrameCheckSum {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ValidateHeaderFrameCheckSum Property

Grid Solutions Framework FrameParserBaseTFrameIdentifierValidateHeaderFrameCheckSum Property
Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool ValidateHeaderFrameCheckSum { get; }
Protected ReadOnly Property ValidateHeaderFrameCheckSum As Boolean
    Get
member ValidateHeaderFrameCheckSum : bool with get

function get_ValidateHeaderFrameCheckSum();

protected:
property bool ValidateHeaderFrameCheckSum {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier) Events

Grid Solutions Framework FrameParserBaseTFrameIdentifier Events

The FrameParserBaseTFrameIdentifier generic type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a IDataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer.
Public event | ReceivedFrameImage | Occurs when a frame image has been received.
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ConfigurationChanged Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierConfigurationChanged Event
Occurs when a device sends a notification that its configuration has changed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
override ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
public:
virtual  event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IFrameParserConfigurationChanged
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ReceivedCommandFrame Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierReceivedCommandFrame Event
Occurs when a ICommandFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
abstract ReceivedCommandFrame : IEvent<EventHandler<EventArgs<ICommandFrame>>,
    EventArgs<ICommandFrame>>
override ReceivedCommandFrame : IEvent<EventHandler<EventArgs<ICommandFrame>>,
    EventArgs<ICommandFrame>>
function add_ReceivedCommandFrame(value);
function remove_ReceivedCommandFrame(value);
public:
virtual  event EventHandler<EventArgs<ICommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICommandFrame

Implements

IFrameParserReceivedCommandFrame
Remarks
Argument is the ICommandFrame that was received.

Command frames are normally sent, not received, but there is nothing that prevents this.

See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ReceivedConfigurationFrame Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierReceivedConfigurationFrame Event
Occurs when a IConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of IConfigurationFrame))
abstract ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<IConfigurationFrame>>,
    EventArgs<IConfigurationFrame>>
override ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<IConfigurationFrame>>,
    EventArgs<IConfigurationFrame>>
function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
virtual  event EventHandler<EventArgs<IConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IConfigurationFrame

Implements

IFrameParserReceivedConfigurationFrame
Remarks
Argument is the IConfigurationFrame that was received.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ReceivedDataFrame Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierReceivedDataFrame Event
Occurs when a IDataFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IDataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of IDataFrame))
abstract ReceivedDataFrame : IEvent<EventHandler<EventArgs<IDataFrame>>,
    EventArgs<IDataFrame>>
override ReceivedDataFrame : IEvent<EventHandler<EventArgs<IDataFrame>>,
    EventArgs<IDataFrame>>
function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
virtual  event EventHandler<EventArgs<IDataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<IDataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IDataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IDataFrame

Implements

IFrameParserReceivedDataFrame
Remarks
Argument is the IDataFrame that was received.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ReceivedFrameBufferImage Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierReceivedFrameBufferImage Event
Occurs when a frame image has been received, event includes buffer.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>> ReceivedFrameBufferImage
Public Event ReceivedFrameBufferImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Byte(), Integer, Integer))
abstract ReceivedFrameBufferImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>>,
    EventArgs<FundamentalFrameType, byte[], int, int>>
override ReceivedFrameBufferImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>>,
    EventArgs<FundamentalFrameType, byte[], int, int>>
function add_ReceivedFrameBufferImage(value);
function remove_ReceivedFrameBufferImage(value);
public:
virtual  event EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ ReceivedFrameBufferImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FundamentalFrameType, Byte , Int32, Int32

Implements

IFrameParserReceivedFrameBufferImage
Remarks

Argument1 is the FundamentalFrameType of the frame buffer image that was received.
Argument2 is the buffer that contains the frame image that was received.
Argument3 is the offset into the buffer that contains the frame image that was received.
Argument4 is the length of data in the buffer that contains the frame image that was received.

Consumers should use the more efficient ReceivedFrameImage event if the buffer is not needed.

See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ReceivedFrameImage Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierReceivedFrameImage Event
Occurs when a frame image has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<FundamentalFrameType, int>> ReceivedFrameImage
Public Event ReceivedFrameImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Integer))
abstract ReceivedFrameImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, int>>,
    EventArgs<FundamentalFrameType, int>>
override ReceivedFrameImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, int>>,
    EventArgs<FundamentalFrameType, int>>
function add_ReceivedFrameImage(value);
function remove_ReceivedFrameImage(value);
public:
virtual  event EventHandler<EventArgs<FundamentalFrameType, int>^>^ ReceivedFrameImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FundamentalFrameType, Int32

Implements

IFrameParserReceivedFrameImage
Remarks
Argument1 is the FundamentalFrameType of the frame buffer image that was received.
Argument2 is the length of the frame image that was received.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ReceivedHeaderFrame Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierReceivedHeaderFrame Event
Occurs when a IHeaderFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IHeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of IHeaderFrame))
abstract ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<IHeaderFrame>>,
    EventArgs<IHeaderFrame>>
override ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<IHeaderFrame>>,
    EventArgs<IHeaderFrame>>
function add_ReceivedHeaderFrame(value);
function remove_ReceivedHeaderFrame(value);
public:
virtual  event EventHandler<EventArgs<IHeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IHeaderFrame

Implements

IFrameParserReceivedHeaderFrame
Remarks
Argument is the IHeaderFrame that was received.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrameParserBase(TFrameIdentifier).ReceivedUndeterminedFrame Event

Grid Solutions Framework FrameParserBaseTFrameIdentifierReceivedUndeterminedFrame Event
Occurs when an undetermined IChannelFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IChannelFrame>> ReceivedUndeterminedFrame
Public Event ReceivedUndeterminedFrame As EventHandler(Of EventArgs(Of IChannelFrame))
abstract ReceivedUndeterminedFrame : IEvent<EventHandler<EventArgs<IChannelFrame>>,
    EventArgs<IChannelFrame>>
override ReceivedUndeterminedFrame : IEvent<EventHandler<EventArgs<IChannelFrame>>,
    EventArgs<IChannelFrame>>
function add_ReceivedUndeterminedFrame(value);
function remove_ReceivedUndeterminedFrame(value);
public:
virtual  event EventHandler<EventArgs<IChannelFrame^>^>^ ReceivedUndeterminedFrame {
    void add (EventHandler<EventArgs<IChannelFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IChannelFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IChannelFrame

Implements

IFrameParserReceivedUndeterminedFrame
Remarks
Argument is the undetermined IChannelFrame that was received.
See Also

Reference

FrameParserBaseTFrameIdentifier Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase Class

Grid Solutions Framework FrequencyDefinitionBase Class
Represents the common implementation of the protocol independent definition of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class FrequencyDefinitionBase : ChannelDefinitionBase,
    IFrequencyDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute>
Public MustInherit Class FrequencyDefinitionBase
    Inherits ChannelDefinitionBase
    Implements IFrequencyDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),
    IComparable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type FrequencyDefinitionBase =
    class
        inherit ChannelDefinitionBase
        interface IFrequencyDefinition
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.FrequencyDefinitionBase = function();

Type.createClass(
    'GSF.PhasorProtocols.FrequencyDefinitionBase',
    GSF.PhasorProtocols.ChannelDefinitionBase,
    GSF.PhasorProtocols.IFrequencyDefinition,
    GSF.PhasorProtocols.IChannelDefinition,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable,
    IEquatable`1,
    IComparable`1,
    IComparable);
[SerializableAttribute]
public ref class FrequencyDefinitionBase abstract : public ChannelDefinitionBase,
    IFrequencyDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable

The FrequencyDefinitionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyDefinitionBase(IConfigurationCell) | Creates a new FrequencyDefinitionBase.
Protected method | FrequencyDefinitionBase(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionBase from serialization parameters.
Protected method | FrequencyDefinitionBase(IConfigurationCell, String, UInt32, UInt32, Double) | Creates a new FrequencyDefinitionBase from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase.
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBaseIndex.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase.
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBaseOffset.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.AnonymousFrequencyDefinition
GSF.PhasorProtocols.BPAPDCstreamFrequencyDefinition
GSF.PhasorProtocols.FNETFrequencyDefinition
GSF.PhasorProtocols.IEC61850_90_5FrequencyDefinition
GSF.PhasorProtocols.IEEE1344FrequencyDefinition
GSF.PhasorProtocols.IEEEC37_118FrequencyDefinition
GSF.PhasorProtocols.MacrodyneFrequencyDefinition
GSF.PhasorProtocols.SelFastMessageFrequencyDefinition


FrequencyDefinitionBase Constructor

Grid Solutions Framework FrequencyDefinitionBase Constructor
Overload List
 | Name | Description
Protected method | FrequencyDefinitionBase(IConfigurationCell) | Creates a new FrequencyDefinitionBase.
Protected method | FrequencyDefinitionBase(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionBase from serialization parameters.
Protected method | FrequencyDefinitionBase(IConfigurationCell, String, UInt32, UInt32, Double) | Creates a new FrequencyDefinitionBase from specified parameters.
Top
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinitionBase Constructor (IConfigurationCell)
Creates a new FrequencyDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinitionBase
GSF.PhasorProtocols.FrequencyDefinitionBase = function(parent);
protected:
FrequencyDefinitionBase(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinitionBase.
See Also

Reference

FrequencyDefinitionBase Class
FrequencyDefinitionBase Overload
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinitionBase Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinitionBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinitionBase
GSF.PhasorProtocols.FrequencyDefinitionBase = function(info, context);
protected:
FrequencyDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinitionBase Class
FrequencyDefinitionBase Overload
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase Constructor (IConfigurationCell, String, UInt32, UInt32, Double)

Grid Solutions Framework FrequencyDefinitionBase Constructor (IConfigurationCell, String, UInt32, UInt32, Double)
Creates a new FrequencyDefinitionBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    uint dfdtScale,
    double dfdtOffset
)
Protected Sub New (
    parent As IConfigurationCell,
    label As String,
    scale As UInteger,
    dfdtScale As UInteger,
    dfdtOffset As Double
)
new :
        parent : IConfigurationCell *
        label : string *
        scale : uint32 *
        dfdtScale : uint32 *
        dfdtOffset : float -> FrequencyDefinitionBase
GSF.PhasorProtocols.FrequencyDefinitionBase = function(parent, label, scale, dfdtScale, dfdtOffset);
protected:
FrequencyDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    unsigned int dfdtScale,
    double dfdtOffset
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinitionBase.
label
Type: SystemString
The label of this FrequencyDefinitionBase.
scale
Type: SystemUInt32
The integer scaling value of this FrequencyDefinitionBase.
dfdtScale
Type: SystemUInt32
The df/dt scaling value of this FrequencyDefinitionBase.
dfdtOffset
Type: SystemDouble
The df/dt offset of this FrequencyDefinitionBase.
See Also

Reference

FrequencyDefinitionBase Class
FrequencyDefinitionBase Overload
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase Methods

Grid Solutions Framework FrequencyDefinitionBase Methods

The FrequencyDefinitionBase type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.GetObjectData Method

Grid Solutions Framework FrequencyDefinitionBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase Properties

Grid Solutions Framework FrequencyDefinitionBase Properties

The FrequencyDefinitionBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase.
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBaseIndex.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase.
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Overrides ChannelDefinitionBaseOffset.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.Attributes Property

Grid Solutions Framework FrequencyDefinitionBaseAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.DataFormat Property

Grid Solutions Framework FrequencyDefinitionBaseDataFormat Property
Gets the DataFormat of this FrequencyDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat DataFormat { get; }
Public Overrides ReadOnly Property DataFormat As DataFormat
    Get
abstract DataFormat : DataFormat with get
override DataFormat : DataFormat with get
function get_DataFormat();

public:
virtual property DataFormat DataFormat {
    DataFormat get () override;
}

Property Value

Type: DataFormat

Implements

IChannelDefinitionDataFormat
IChannelDefinitionDataFormat
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.DfDtOffset Property

Grid Solutions Framework FrequencyDefinitionBaseDfDtOffset Property
Gets or sets the df/dt offset of this FrequencyDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double DfDtOffset { get; set; }
Public Overridable Property DfDtOffset As Double
    Get
    Set
abstract DfDtOffset : float with get, set
override DfDtOffset : float with get, set
function get_DfDtOffset();
function set_DfDtOffset(value);
public:
virtual property double DfDtOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IFrequencyDefinitionDfDtOffset
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.DfDtScalingValue Property

Grid Solutions Framework FrequencyDefinitionBaseDfDtScalingValue Property
Gets or sets the df/dt scaling value of this FrequencyDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual uint DfDtScalingValue { get; set; }
Public Overridable Property DfDtScalingValue As UInteger
    Get
    Set
abstract DfDtScalingValue : uint32 with get, set
override DfDtScalingValue : uint32 with get, set
function get_DfDtScalingValue();
function set_DfDtScalingValue(value);
public:
virtual property unsigned int DfDtScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32

Implements

IFrequencyDefinitionDfDtScalingValue
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.Index Property

Grid Solutions Framework FrequencyDefinitionBaseIndex Property
Gets or sets the index of this FrequencyDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override int Index { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property Index As Integer
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Index : int with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Index : int with get, set
function get_Index();
function set_Index(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property int Index {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionIndex
IChannelDefinitionIndex
Remarks
Phasor protocols only define one frequency measurement per device.
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.NominalFrequency Property

Grid Solutions Framework FrequencyDefinitionBaseNominalFrequency Property
Gets the nominal LineFrequency of this FrequencyDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual LineFrequency NominalFrequency { get; }
Public Overridable ReadOnly Property NominalFrequency As LineFrequency
    Get
abstract NominalFrequency : LineFrequency with get
override NominalFrequency : LineFrequency with get
function get_NominalFrequency();

public:
virtual property LineFrequency NominalFrequency {
    LineFrequency get ();
}

Property Value

Type: LineFrequency

Implements

IFrequencyDefinitionNominalFrequency
Remarks
Value returned is the NominalFrequency and is exposed here just for convenience.
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionBase.Offset Property

Grid Solutions Framework FrequencyDefinitionBaseOffset Property
Gets or sets the offset of this FrequencyDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double Offset { get; set; }
Public Overrides Property Offset As Double
    Get
    Set
abstract Offset : float with get, set
override Offset : float with get, set
function get_Offset();
function set_Offset(value);
public:
virtual property double Offset {
    double get () override;
    void set (double value) override;
}

Property Value

Type: Double

Implements

IChannelDefinitionOffset
IChannelDefinitionOffset
Exceptions
Exception | Condition
NotSupportedException | Frequency offset is read-only; value is determined by nominal frequency specified in containing configuration cell.
Remarks
Offset for frequency values will always be the nominal frequency as defined in parent configuration cell; assigning a value is not supported.
See Also

Reference

FrequencyDefinitionBase Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionCollection Class

Grid Solutions Framework FrequencyDefinitionCollection Class
Represents a protocol independent collection of IFrequencyDefinition objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IFrequencyDefinition
GSF.CollectionsListCollection IFrequencyDefinition
GSF.PhasorProtocolsChannelCollectionBase IFrequencyDefinition
GSF.PhasorProtocolsChannelDefinitionCollectionBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyDefinitionCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinitionCollection : ChannelDefinitionCollectionBase<IFrequencyDefinition>
<SerializableAttribute>
Public Class FrequencyDefinitionCollection
    Inherits ChannelDefinitionCollectionBase(Of IFrequencyDefinition)
[<SerializableAttribute>]
type FrequencyDefinitionCollection =
    class
        inherit ChannelDefinitionCollectionBase<IFrequencyDefinition>
    end
GSF.PhasorProtocols.FrequencyDefinitionCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.FrequencyDefinitionCollection',
    GSF.PhasorProtocols.ChannelDefinitionCollectionBase`1);
[SerializableAttribute]
public ref class FrequencyDefinitionCollection : public ChannelDefinitionCollectionBase<IFrequencyDefinition^>

The FrequencyDefinitionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinitionCollection(Int32) | Creates a new FrequencyDefinitionCollection using specified lastValidIndex.
Protected method | FrequencyDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
Remarks
None of the phasor protocols currently define multiple frequency elements per transmission, but if a future protocol does this collection can be used.
See Also

Reference

GSF.PhasorProtocols Namespace


FrequencyDefinitionCollection Constructor

Grid Solutions Framework FrequencyDefinitionCollection Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinitionCollection(Int32) | Creates a new FrequencyDefinitionCollection using specified lastValidIndex.
Protected method | FrequencyDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinitionCollection from serialization parameters.
Top
See Also

Reference

FrequencyDefinitionCollection Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionCollection Constructor (Int32)

Grid Solutions Framework FrequencyDefinitionCollection Constructor (Int32)
Creates a new FrequencyDefinitionCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinitionCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> FrequencyDefinitionCollection
GSF.PhasorProtocols.FrequencyDefinitionCollection = function(lastValidIndex);
public:
FrequencyDefinitionCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

FrequencyDefinitionCollection Class
FrequencyDefinitionCollection Overload
GSF.PhasorProtocols Namespace


FrequencyDefinitionCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinitionCollection Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinitionCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinitionCollection
GSF.PhasorProtocols.FrequencyDefinitionCollection = function(info, context);
protected:
FrequencyDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinitionCollection Class
FrequencyDefinitionCollection Overload
GSF.PhasorProtocols Namespace


FrequencyDefinitionCollection Methods

Grid Solutions Framework FrequencyDefinitionCollection Methods

The FrequencyDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinitionCollection Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionCollection Properties

Grid Solutions Framework FrequencyDefinitionCollection Properties

The FrequencyDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

FrequencyDefinitionCollection Class
GSF.PhasorProtocols Namespace


FrequencyDefinitionCollection Events

Grid Solutions Framework FrequencyDefinitionCollection Events

The FrequencyDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

FrequencyDefinitionCollection Class
GSF.PhasorProtocols Namespace


FrequencyValueBase Class

Grid Solutions Framework FrequencyValueBase Class
Represents the common implementation of the protocol independent representation of a frequency and dF/dt value.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class FrequencyValueBase : ChannelValueBase<IFrequencyDefinition>,
    IFrequencyValue, IChannelValue<IFrequencyDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute>
Public MustInherit Class FrequencyValueBase
    Inherits ChannelValueBase(Of IFrequencyDefinition)
    Implements IFrequencyValue, IChannelValue(Of IFrequencyDefinition),
    IChannel, ISupportBinaryImage, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type FrequencyValueBase =
    class
        inherit ChannelValueBase<IFrequencyDefinition>
        interface IFrequencyValue
        interface IChannelValue<IFrequencyDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.FrequencyValueBase = function();

Type.createClass(
    'GSF.PhasorProtocols.FrequencyValueBase',
    GSF.PhasorProtocols.ChannelValueBase`1,
    GSF.PhasorProtocols.IFrequencyValue,
    GSF.PhasorProtocols.IChannelValue`1,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class FrequencyValueBase abstract : public ChannelValueBase<IFrequencyDefinition^>,
    IFrequencyValue, IChannelValue<IFrequencyDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable

The FrequencyValueBase type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValueBase(SerializationInfo, StreamingContext) | Creates a new FrequencyValueBase from serialization parameters.
Protected method | FrequencyValueBase(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValueBase.
Protected method | FrequencyValueBase(IDataCell, IFrequencyDefinition, Double, Double) | Creates a new FrequencyValueBase from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time.
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase.
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.BPAPDCstreamFrequencyValue
GSF.PhasorProtocols.FNETFrequencyValue
GSF.PhasorProtocols.IEC61850_90_5FrequencyValue
GSF.PhasorProtocols.IEEE1344FrequencyValue
GSF.PhasorProtocols.IEEEC37_118FrequencyValue
GSF.PhasorProtocols.MacrodyneFrequencyValue
GSF.PhasorProtocols.SelFastMessageFrequencyValue


FrequencyValueBase Constructor

Grid Solutions Framework FrequencyValueBase Constructor
Overload List
 | Name | Description
Protected method | FrequencyValueBase(SerializationInfo, StreamingContext) | Creates a new FrequencyValueBase from serialization parameters.
Protected method | FrequencyValueBase(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValueBase.
Protected method | FrequencyValueBase(IDataCell, IFrequencyDefinition, Double, Double) | Creates a new FrequencyValueBase from specified parameters.
Top
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValueBase Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValueBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValueBase
GSF.PhasorProtocols.FrequencyValueBase = function(info, context);
protected:
FrequencyValueBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValueBase Class
FrequencyValueBase Overload
GSF.PhasorProtocols Namespace


FrequencyValueBase Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValueBase Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValueBase(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Protected Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValueBase
GSF.PhasorProtocols.FrequencyValueBase = function(parent, frequencyDefinition);
protected:
FrequencyValueBase(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValueBase.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValueBase.
See Also

Reference

FrequencyValueBase Class
FrequencyValueBase Overload
GSF.PhasorProtocols Namespace


FrequencyValueBase Constructor (IDataCell, IFrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValueBase Constructor (IDataCell, IFrequencyDefinition, Double, Double)
Creates a new FrequencyValueBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValueBase(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Protected Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValueBase
GSF.PhasorProtocols.FrequencyValueBase = function(parent, frequencyDefinition, frequency, dfdt);
protected:
FrequencyValueBase(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValueBase.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValueBase.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValueBase.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValueBase over time.
See Also

Reference

FrequencyValueBase Class
FrequencyValueBase Overload
GSF.PhasorProtocols Namespace


FrequencyValueBase Methods

Grid Solutions Framework FrequencyValueBase Methods

The FrequencyValueBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.GetCompositeValue Method

Grid Solutions Framework FrequencyValueBaseGetCompositeValue Method
Gets the specified composite value of this FrequencyValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue (
    index As Integer
) As Double
abstract GetCompositeValue :
        index : int -> float
override GetCompositeValue :
        index : int -> float
function GetCompositeValue(index);
public:
virtual double GetCompositeValue(
    int index
) override

Parameters

index
Type: SystemInt32
Index of composite value to retrieve.

Return Value

Type: Double
A Double representing the composite value.

Implements

IChannelValueTGetCompositeValue(Int32)
IChannelValueTGetCompositeValue(Int32)
Remarks
Some ChannelValueBaseT implementations can contain more than one value, this method is used to abstractly expose each value.
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.GetObjectData Method

Grid Solutions Framework FrequencyValueBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.ParseBodyImage Method

Grid Solutions Framework FrequencyValueBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase Properties

Grid Solutions Framework FrequencyValueBase Properties

The FrequencyValueBase type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time.
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase.
Top
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.Attributes Property

Grid Solutions Framework FrequencyValueBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.BodyImage Property

Grid Solutions Framework FrequencyValueBaseBodyImage Property
Gets the binary body image of the FrequencyValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.BodyLength Property

Grid Solutions Framework FrequencyValueBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.CompositeValueCount Property

Grid Solutions Framework FrequencyValueBaseCompositeValueCount Property
Gets total number of composite values that this FrequencyValueBase provides.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
abstract CompositeValueCount : int with get
override CompositeValueCount : int with get
function get_CompositeValueCount();

public:
virtual property int CompositeValueCount {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelValueTCompositeValueCount
IChannelValueTCompositeValueCount
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.DfDt Property

Grid Solutions Framework FrequencyValueBaseDfDt Property
Gets or sets the floating point value that represents the change in this FrequencyValueBase over time.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double DfDt { get; set; }
Public Overridable Property DfDt As Double
    Get
    Set
abstract DfDt : float with get, set
override DfDt : float with get, set
function get_DfDt();
function set_DfDt(value);
public:
virtual property double DfDt {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IFrequencyValueDfDt
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.Frequency Property

Grid Solutions Framework FrequencyValueBaseFrequency Property
Gets or sets the floating point value that represents this FrequencyValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Frequency { get; set; }
Public Overridable Property Frequency As Double
    Get
    Set
abstract Frequency : float with get, set
override Frequency : float with get, set
function get_Frequency();
function set_Frequency(value);
public:
virtual property double Frequency {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IFrequencyValueFrequency
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.IsEmpty Property

Grid Solutions Framework FrequencyValueBaseIsEmpty Property
Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get
override IsEmpty : bool with get
function get_IsEmpty();

public:
virtual property bool IsEmpty {
    bool get () override;
}

Return Value

Type: Boolean
True, if no composite values have been assigned a value; otherwise, false.

Implements

IChannelValueTIsEmpty
IChannelValueTIsEmpty
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.UnscaledDfDt Property

Grid Solutions Framework FrequencyValueBaseUnscaledDfDt Property
Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int UnscaledDfDt { get; set; }
Public Overridable Property UnscaledDfDt As Integer
    Get
    Set
abstract UnscaledDfDt : int with get, set
override UnscaledDfDt : int with get, set
function get_UnscaledDfDt();
function set_UnscaledDfDt(value);
public:
virtual property int UnscaledDfDt {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IFrequencyValueUnscaledDfDt
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueBase.UnscaledFrequency Property

Grid Solutions Framework FrequencyValueBaseUnscaledFrequency Property
Gets or sets the unscaled integer representation of this FrequencyValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int UnscaledFrequency { get; set; }
Public Overridable Property UnscaledFrequency As Integer
    Get
    Set
abstract UnscaledFrequency : int with get, set
override UnscaledFrequency : int with get, set
function get_UnscaledFrequency();
function set_UnscaledFrequency(value);
public:
virtual property int UnscaledFrequency {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IFrequencyValueUnscaledFrequency
See Also

Reference

FrequencyValueBase Class
GSF.PhasorProtocols Namespace


FrequencyValueCollection Class

Grid Solutions Framework FrequencyValueCollection Class
Represents a protocol independent collection of IFrequencyValue objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IFrequencyValue
GSF.CollectionsListCollection IFrequencyValue
GSF.PhasorProtocolsChannelCollectionBase IFrequencyValue
GSF.PhasorProtocolsChannelValueCollectionBase IFrequencyDefinition, IFrequencyValue
GSF.PhasorProtocolsFrequencyValueCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValueCollection : ChannelValueCollectionBase<IFrequencyDefinition, IFrequencyValue>
<SerializableAttribute>
Public Class FrequencyValueCollection
    Inherits ChannelValueCollectionBase(Of IFrequencyDefinition, IFrequencyValue)
[<SerializableAttribute>]
type FrequencyValueCollection =
    class
        inherit ChannelValueCollectionBase<IFrequencyDefinition, IFrequencyValue>
    end
GSF.PhasorProtocols.FrequencyValueCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.FrequencyValueCollection',
    GSF.PhasorProtocols.ChannelValueCollectionBase`2);
[SerializableAttribute]
public ref class FrequencyValueCollection : public ChannelValueCollectionBase<IFrequencyDefinition^, IFrequencyValue^>

The FrequencyValueCollection type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyValueCollection(Int32) | Creates a new FrequencyValueCollection using specified lastValidIndex.
Protected method | FrequencyValueCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyValueCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
Remarks
None of the phasor protocols currently define multiple frequency elements per transmission, but if a future protocol does this collection can be used.
See Also

Reference

GSF.PhasorProtocols Namespace


FrequencyValueCollection Constructor

Grid Solutions Framework FrequencyValueCollection Constructor
Overload List
 | Name | Description
Public method | FrequencyValueCollection(Int32) | Creates a new FrequencyValueCollection using specified lastValidIndex.
Protected method | FrequencyValueCollection(SerializationInfo, StreamingContext) | Creates a new FrequencyValueCollection from serialization parameters.
Top
See Also

Reference

FrequencyValueCollection Class
GSF.PhasorProtocols Namespace


FrequencyValueCollection Constructor (Int32)

Grid Solutions Framework FrequencyValueCollection Constructor (Int32)
Creates a new FrequencyValueCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValueCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> FrequencyValueCollection
GSF.PhasorProtocols.FrequencyValueCollection = function(lastValidIndex);
public:
FrequencyValueCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

FrequencyValueCollection Class
FrequencyValueCollection Overload
GSF.PhasorProtocols Namespace


FrequencyValueCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValueCollection Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValueCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValueCollection
GSF.PhasorProtocols.FrequencyValueCollection = function(info, context);
protected:
FrequencyValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValueCollection Class
FrequencyValueCollection Overload
GSF.PhasorProtocols Namespace


FrequencyValueCollection Methods

Grid Solutions Framework FrequencyValueCollection Methods

The FrequencyValueCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValueCollection Class
GSF.PhasorProtocols Namespace


FrequencyValueCollection Properties

Grid Solutions Framework FrequencyValueCollection Properties

The FrequencyValueCollection type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

FrequencyValueCollection Class
GSF.PhasorProtocols Namespace


FrequencyValueCollection Events

Grid Solutions Framework FrequencyValueCollection Events

The FrequencyValueCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

FrequencyValueCollection Class
GSF.PhasorProtocols Namespace


FundamentalFrameType Enumeration

Grid Solutions Framework FundamentalFrameType Enumeration
Fundamental frame types enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FundamentalFrameType
<SerializableAttribute>
Public Enumeration FundamentalFrameType
[<SerializableAttribute>]
type FundamentalFrameType
GSF.PhasorProtocols.FundamentalFrameType = function();
GSF.PhasorProtocols.FundamentalFrameType.createEnum('GSF.PhasorProtocols.FundamentalFrameType', false);
[SerializableAttribute]
public enum class FundamentalFrameType
Members
Member name | Value | Description
ConfigurationFrame | 0 | Configuration frame.
DataFrame | 1 | Data frame.
HeaderFrame | 2 | Header frame.
CommandFrame | 3 | Command frame.
Undetermined | 4 | Undetermined frame type.
See Also

Reference

GSF.PhasorProtocols Namespace


HeaderCell Class

Grid Solutions Framework HeaderCell Class
Represents the protocol independent common implementation of an element of header data for cells in a IHeaderFrame.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsHeaderCell

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class HeaderCell : ChannelCellBase, IHeaderCell,
    IChannelCell, IChannel, ISupportBinaryImage, ISerializable
<SerializableAttribute>
Public Class HeaderCell
    Inherits ChannelCellBase
    Implements IHeaderCell, IChannelCell, IChannel, ISupportBinaryImage,
    ISerializable
[<SerializableAttribute>]
type HeaderCell =
    class
        inherit ChannelCellBase
        interface IHeaderCell
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.HeaderCell = function();

Type.createClass(
    'GSF.PhasorProtocols.HeaderCell',
    GSF.PhasorProtocols.ChannelCellBase,
    GSF.PhasorProtocols.IHeaderCell,
    GSF.PhasorProtocols.IChannelCell,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class HeaderCell : public ChannelCellBase,
    IHeaderCell, IChannelCell, IChannel, ISupportBinaryImage, ISerializable

The HeaderCell type exposes the following members.

Constructors
 | Name | Description
Protected method | HeaderCell(SerializationInfo, StreamingContext) | Creates a new HeaderCell from serialization parameters.
Public method | HeaderCell(IHeaderFrame, Byte) | Creates a new HeaderCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderCell object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the HeaderCell object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | Character | Gets or sets ASCII character as a Byte that represents this HeaderCell.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Parent | Gets or sets a reference to the parent ICommandFrame for this HeaderCell.
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


HeaderCell Constructor

Grid Solutions Framework HeaderCell Constructor
Overload List
 | Name | Description
Protected method | HeaderCell(SerializationInfo, StreamingContext) | Creates a new HeaderCell from serialization parameters.
Public method | HeaderCell(IHeaderFrame, Byte) | Creates a new HeaderCell from specified parameters.
Top
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework HeaderCell Constructor (SerializationInfo, StreamingContext)
Creates a new HeaderCell from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HeaderCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HeaderCell
GSF.PhasorProtocols.HeaderCell = function(info, context);
protected:
HeaderCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

HeaderCell Class
HeaderCell Overload
GSF.PhasorProtocols Namespace


HeaderCell Constructor (IHeaderFrame, Byte)

Grid Solutions Framework HeaderCell Constructor (IHeaderFrame, Byte)
Creates a new HeaderCell from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderCell(
    IHeaderFrame parent,
    byte character
)
Public Sub New (
    parent As IHeaderFrame,
    character As Byte
)
new :
        parent : IHeaderFrame *
        character : byte -> HeaderCell
GSF.PhasorProtocols.HeaderCell = function(parent, character);
public:
HeaderCell(
    IHeaderFrame^ parent,
    unsigned char character
)

Parameters

parent
Type: GSF.PhasorProtocolsIHeaderFrame
A reference to the parent ICommandFrame for this HeaderCell.
character
Type: SystemByte
ASCII character as a Byte that represents this HeaderCell.
See Also

Reference

HeaderCell Class
HeaderCell Overload
GSF.PhasorProtocols Namespace


HeaderCell Methods

Grid Solutions Framework HeaderCell Methods

The HeaderCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell.GetObjectData Method

Grid Solutions Framework HeaderCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell.ParseBodyImage Method

Grid Solutions Framework HeaderCellParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell Properties

Grid Solutions Framework HeaderCell Properties

The HeaderCell type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderCell object. (Overrides ChannelCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the HeaderCell object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | Character | Gets or sets ASCII character as a Byte that represents this HeaderCell.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Parent | Gets or sets a reference to the parent ICommandFrame for this HeaderCell.
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell.Attributes Property

Grid Solutions Framework HeaderCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the HeaderCell object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell.BodyImage Property

Grid Solutions Framework HeaderCellBodyImage Property
Gets the binary body image of the HeaderCell object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell.BodyLength Property

Grid Solutions Framework HeaderCellBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell.Character Property

Grid Solutions Framework HeaderCellCharacter Property
Gets or sets ASCII character as a Byte that represents this HeaderCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual byte Character { get; set; }
Public Overridable Property Character As Byte
    Get
    Set
abstract Character : byte with get, set
override Character : byte with get, set
function get_Character();
function set_Character(value);
public:
virtual property unsigned char Character {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte

Implements

IHeaderCellCharacter
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCell.Parent Property

Grid Solutions Framework HeaderCellParent Property
Gets or sets a reference to the parent ICommandFrame for this HeaderCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IHeaderFrame Parent { get; set; }
Public Overridable Property Parent As IHeaderFrame
    Get
    Set
abstract Parent : IHeaderFrame with get, set
override Parent : IHeaderFrame with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property IHeaderFrame^ Parent {
    IHeaderFrame^ get ();
    void set (IHeaderFrame^ value);
}

Property Value

Type: IHeaderFrame

Implements

IHeaderCellParent
See Also

Reference

HeaderCell Class
GSF.PhasorProtocols Namespace


HeaderCellCollection Class

Grid Solutions Framework HeaderCellCollection Class
Represents a protocol independent collection of IHeaderCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IHeaderCell
GSF.CollectionsListCollection IHeaderCell
GSF.PhasorProtocolsChannelCollectionBase IHeaderCell
GSF.PhasorProtocolsChannelCellCollectionBase IHeaderCell
GSF.PhasorProtocolsHeaderCellCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class HeaderCellCollection : ChannelCellCollectionBase<IHeaderCell>
<SerializableAttribute>
Public Class HeaderCellCollection
    Inherits ChannelCellCollectionBase(Of IHeaderCell)
[<SerializableAttribute>]
type HeaderCellCollection =
    class
        inherit ChannelCellCollectionBase<IHeaderCell>
    end
GSF.PhasorProtocols.HeaderCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.HeaderCellCollection',
    GSF.PhasorProtocols.ChannelCellCollectionBase`1);
[SerializableAttribute]
public ref class HeaderCellCollection : public ChannelCellCollectionBase<IHeaderCell^>

The HeaderCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderCellCollection(Int32) | Creates a new HeaderCellCollection using specified lastValidIndex.
Protected method | HeaderCellCollection(SerializationInfo, StreamingContext) | Creates a new HeaderCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


HeaderCellCollection Constructor

Grid Solutions Framework HeaderCellCollection Constructor
Overload List
 | Name | Description
Public method | HeaderCellCollection(Int32) | Creates a new HeaderCellCollection using specified lastValidIndex.
Protected method | HeaderCellCollection(SerializationInfo, StreamingContext) | Creates a new HeaderCellCollection from serialization parameters.
Top
See Also

Reference

HeaderCellCollection Class
GSF.PhasorProtocols Namespace


HeaderCellCollection Constructor (Int32)

Grid Solutions Framework HeaderCellCollection Constructor (Int32)
Creates a new HeaderCellCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderCellCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> HeaderCellCollection
GSF.PhasorProtocols.HeaderCellCollection = function(lastValidIndex);
public:
HeaderCellCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

HeaderCellCollection Class
HeaderCellCollection Overload
GSF.PhasorProtocols Namespace


HeaderCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework HeaderCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new HeaderCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HeaderCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HeaderCellCollection
GSF.PhasorProtocols.HeaderCellCollection = function(info, context);
protected:
HeaderCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

HeaderCellCollection Class
HeaderCellCollection Overload
GSF.PhasorProtocols Namespace


HeaderCellCollection Methods

Grid Solutions Framework HeaderCellCollection Methods

The HeaderCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

HeaderCellCollection Class
GSF.PhasorProtocols Namespace


HeaderCellCollection Properties

Grid Solutions Framework HeaderCellCollection Properties

The HeaderCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

HeaderCellCollection Class
GSF.PhasorProtocols Namespace


HeaderCellCollection Events

Grid Solutions Framework HeaderCellCollection Events

The HeaderCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

HeaderCellCollection Class
GSF.PhasorProtocols Namespace


HeaderFrameBase Class

Grid Solutions Framework HeaderFrameBase Class
Represents the protocol independent common implementation of any IHeaderFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IHeaderCell
GSF.PhasorProtocolsHeaderFrameBase
GSF.PhasorProtocols.IEEE1344HeaderFrame
GSF.PhasorProtocols.IEEEC37_118HeaderFrame
GSF.PhasorProtocols.MacrodyneHeaderFrame

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class HeaderFrameBase : ChannelFrameBase<IHeaderCell>,
    IHeaderFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame>, IComparable<IFrame>, IComparable,
    ISerializable
<SerializableAttribute>
Public MustInherit Class HeaderFrameBase
    Inherits ChannelFrameBase(Of IHeaderCell)
    Implements IHeaderFrame, IChannelFrame, IChannel, ISupportBinaryImage,
    IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),
    IComparable, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type HeaderFrameBase =
    class
        inherit ChannelFrameBase<IHeaderCell>
        interface IHeaderFrame
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.HeaderFrameBase = function();

Type.createClass(
    'GSF.PhasorProtocols.HeaderFrameBase',
    GSF.PhasorProtocols.ChannelFrameBase`1,
    GSF.PhasorProtocols.IHeaderFrame,
    GSF.PhasorProtocols.IChannelFrame,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    GSF.TimeSeries.IFrame,
    IEquatable`1,
    IComparable`1,
    IComparable,
    ISerializable);
[SerializableAttribute]
public ref class HeaderFrameBase abstract : public ChannelFrameBase<IHeaderCell^>,
    IHeaderFrame, IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable<IFrame^>, IComparable<IFrame^>, IComparable,
    ISerializable

The HeaderFrameBase type exposes the following members.

Constructors
 | Name | Description
Protected method | HeaderFrameBase(HeaderCellCollection) | Creates a new HeaderFrameBase.
Protected method | HeaderFrameBase(SerializationInfo, StreamingContext) | Creates a new HeaderFrameBase from serialization parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelFrameBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrameBase object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


HeaderFrameBase Constructor

Grid Solutions Framework HeaderFrameBase Constructor
Overload List
 | Name | Description
Protected method | HeaderFrameBase(HeaderCellCollection) | Creates a new HeaderFrameBase.
Protected method | HeaderFrameBase(SerializationInfo, StreamingContext) | Creates a new HeaderFrameBase from serialization parameters.
Top
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameBase Constructor (HeaderCellCollection)

Grid Solutions Framework HeaderFrameBase Constructor (HeaderCellCollection)
Creates a new HeaderFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HeaderFrameBase(
    HeaderCellCollection cells
)
Protected Sub New (
    cells As HeaderCellCollection
)
new :
        cells : HeaderCellCollection -> HeaderFrameBase
GSF.PhasorProtocols.HeaderFrameBase = function(cells);
protected:
HeaderFrameBase(
    HeaderCellCollection^ cells
)

Parameters

cells
Type: GSF.PhasorProtocolsHeaderCellCollection
The reference to the HeaderCellCollection for this HeaderFrameBase.
See Also

Reference

HeaderFrameBase Class
HeaderFrameBase Overload
GSF.PhasorProtocols Namespace


HeaderFrameBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework HeaderFrameBase Constructor (SerializationInfo, StreamingContext)
Creates a new HeaderFrameBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HeaderFrameBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HeaderFrameBase
GSF.PhasorProtocols.HeaderFrameBase = function(info, context);
protected:
HeaderFrameBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

HeaderFrameBase Class
HeaderFrameBase Overload
GSF.PhasorProtocols Namespace


HeaderFrameBase Methods

Grid Solutions Framework HeaderFrameBase Methods

The HeaderFrameBase type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ChannelFrameBaseT.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelFrameBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameBase Properties

Grid Solutions Framework HeaderFrameBase Properties

The HeaderFrameBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrameBase object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Overrides ChannelFrameBaseTFrameType.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameBase.Attributes Property

Grid Solutions Framework HeaderFrameBaseAttributes Property
DictionaryTKey, TValue of string based property names and values for the HeaderFrameBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameBase.Cells Property

Grid Solutions Framework HeaderFrameBaseCells Property
Gets reference to the HeaderCellCollection for this HeaderFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual HeaderCellCollection Cells { get; }
Public Overridable ReadOnly Property Cells As HeaderCellCollection
    Get
abstract Cells : HeaderCellCollection with get
override Cells : HeaderCellCollection with get
function get_Cells();

public:
virtual property HeaderCellCollection^ Cells {
    HeaderCellCollection^ get ();
}

Property Value

Type: HeaderCellCollection

Implements

IHeaderFrameCells
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameBase.FrameType Property

Grid Solutions Framework HeaderFrameBaseFrameType Property
Gets the FundamentalFrameType for this HeaderFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override FundamentalFrameType FrameType { get; }
Public Overrides ReadOnly Property FrameType As FundamentalFrameType
    Get
abstract FrameType : FundamentalFrameType with get
override FrameType : FundamentalFrameType with get
function get_FrameType();

public:
virtual property FundamentalFrameType FrameType {
    FundamentalFrameType get () override;
}

Property Value

Type: FundamentalFrameType

Implements

IChannelFrameFrameType
IChannelFrameFrameType
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameBase.HeaderData Property

Grid Solutions Framework HeaderFrameBaseHeaderData Property
Gets or sets header data for this HeaderFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string HeaderData { get; set; }
Public Overridable Property HeaderData As String
    Get
    Set
abstract HeaderData : string with get, set
override HeaderData : string with get, set
function get_HeaderData();
function set_HeaderData(value);
public:
virtual property String^ HeaderData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IHeaderFrameHeaderData
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameBase.State Property

Grid Solutions Framework HeaderFrameBaseState Property
Gets or sets the parsing state for the this HeaderFrameBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IHeaderFrameParsingState State { get; set; }
Public Overridable Property State As IHeaderFrameParsingState
    Get
    Set
abstract State : IHeaderFrameParsingState with get, set
override State : IHeaderFrameParsingState with get, set
function get_State();
function set_State(value);
public:
virtual property IHeaderFrameParsingState^ State {
    IHeaderFrameParsingState^ get ();
    void set (IHeaderFrameParsingState^ value);
}

Property Value

Type: IHeaderFrameParsingState

Implements

IHeaderFrameState
See Also

Reference

HeaderFrameBase Class
GSF.PhasorProtocols Namespace


HeaderFrameParsingState Class

Grid Solutions Framework HeaderFrameParsingState Class
Represents the protocol independent common implementation of the parsing state used by any IHeaderFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBase IHeaderCell
GSF.PhasorProtocolsHeaderFrameParsingState

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class HeaderFrameParsingState : ChannelFrameParsingStateBase<IHeaderCell>,
    IHeaderFrameParsingState, IChannelFrameParsingState<IHeaderCell>, IChannelParsingState
Public Class HeaderFrameParsingState
    Inherits ChannelFrameParsingStateBase(Of IHeaderCell)
    Implements IHeaderFrameParsingState, IChannelFrameParsingState(Of IHeaderCell),
    IChannelParsingState
type HeaderFrameParsingState =
    class
        inherit ChannelFrameParsingStateBase<IHeaderCell>
        interface IHeaderFrameParsingState
        interface IChannelFrameParsingState<IHeaderCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.HeaderFrameParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.HeaderFrameParsingState',
    GSF.PhasorProtocols.ChannelFrameParsingStateBase`1,
    GSF.PhasorProtocols.IHeaderFrameParsingState,
    GSF.PhasorProtocols.IChannelFrameParsingState`1,
    GSF.PhasorProtocols.IChannelParsingState);
public ref class HeaderFrameParsingState : public ChannelFrameParsingStateBase<IHeaderCell^>,
    IHeaderFrameParsingState, IChannelFrameParsingState<IHeaderCell^>, IChannelParsingState

The HeaderFrameParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderFrameParsingState | Creates a new HeaderFrameParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


HeaderFrameParsingState Constructor

Grid Solutions Framework HeaderFrameParsingState Constructor
Creates a new HeaderFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderFrameParsingState(
    int parsedBinaryLength,
    int dataLength,
    bool trustHeaderLength,
    bool validateCheckSum
)
Public Sub New (
    parsedBinaryLength As Integer,
    dataLength As Integer,
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        dataLength : int *
        trustHeaderLength : bool *
        validateCheckSum : bool -> HeaderFrameParsingState
GSF.PhasorProtocols.HeaderFrameParsingState = function(parsedBinaryLength, dataLength, trustHeaderLength, validateCheckSum);
public:
HeaderFrameParsingState(
    int parsedBinaryLength,
    int dataLength,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the IHeaderFrame being parsed.
dataLength
Type: SystemInt32
Length of data in IHeaderFrame being parsed (i.e., number of cells).
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

HeaderFrameParsingState Class
GSF.PhasorProtocols Namespace


HeaderFrameParsingState Methods

Grid Solutions Framework HeaderFrameParsingState Methods

The HeaderFrameParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

HeaderFrameParsingState Class
GSF.PhasorProtocols Namespace


HeaderFrameParsingState Properties

Grid Solutions Framework HeaderFrameParsingState Properties

The HeaderFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

HeaderFrameParsingState Class
GSF.PhasorProtocols Namespace


IAnalogDefinition Interface

Grid Solutions Framework IAnalogDefinition Interface
Represents a protocol independent interface representation of a definition of an IAnalogValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IAnalogDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IAnalogDefinition
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
type IAnalogDefinition =
    interface
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.IAnalogDefinition = function();
GSF.PhasorProtocols.IAnalogDefinition.createInterface('GSF.PhasorProtocols.IAnalogDefinition');
public interface class IAnalogDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable

The IAnalogDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this IAnalogDefinition.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IAnalogDefinition Methods

Grid Solutions Framework IAnalogDefinition Methods

The IAnalogDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IAnalogDefinition Interface
GSF.PhasorProtocols Namespace


IAnalogDefinition Properties

Grid Solutions Framework IAnalogDefinition Properties

The IAnalogDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this IAnalogDefinition.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IAnalogDefinition Interface
GSF.PhasorProtocols Namespace


IAnalogDefinition.AnalogType Property

Grid Solutions Framework IAnalogDefinitionAnalogType Property
Gets or sets AnalogType of this IAnalogDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
AnalogType AnalogType { get; set; }
Property AnalogType As AnalogType
    Get
    Set
abstract AnalogType : AnalogType with get, set

function get_AnalogType();
function set_AnalogType(value);
property AnalogType AnalogType {
    AnalogType get ();
    void set (AnalogType value);
}

Property Value

Type: AnalogType
See Also

Reference

IAnalogDefinition Interface
GSF.PhasorProtocols Namespace


IAnalogValue Interface

Grid Solutions Framework IAnalogValue Interface
Represents a protocol independent interface representation of an analog value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IAnalogValue : IChannelValue<IAnalogDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IAnalogValue
    Inherits IChannelValue(Of IAnalogDefinition), IChannel, ISupportBinaryImage,
    ISerializable
type IAnalogValue =
    interface
        interface IChannelValue<IAnalogDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.IAnalogValue = function();
GSF.PhasorProtocols.IAnalogValue.createInterface('GSF.PhasorProtocols.IAnalogValue');
public interface class IAnalogValue : IChannelValue<IAnalogDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable

The IAnalogValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | IntegerValue | Gets or sets the integer representation of this IAnalogValue value.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Value | Gets or sets the floating point value that represents this IAnalogValue.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IAnalogValue Methods

Grid Solutions Framework IAnalogValue Methods

The IAnalogValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IAnalogValue Interface
GSF.PhasorProtocols Namespace


IAnalogValue Properties

Grid Solutions Framework IAnalogValue Properties

The IAnalogValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | IntegerValue | Gets or sets the integer representation of this IAnalogValue value.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Value | Gets or sets the floating point value that represents this IAnalogValue.
Top
See Also

Reference

IAnalogValue Interface
GSF.PhasorProtocols Namespace


IAnalogValue.IntegerValue Property

Grid Solutions Framework IAnalogValueIntegerValue Property
Gets or sets the integer representation of this IAnalogValue value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int IntegerValue { get; set; }
Property IntegerValue As Integer
    Get
    Set
abstract IntegerValue : int with get, set

function get_IntegerValue();
function set_IntegerValue(value);
property int IntegerValue {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IAnalogValue Interface
GSF.PhasorProtocols Namespace


IAnalogValue.Value Property

Grid Solutions Framework IAnalogValueValue Property
Gets or sets the floating point value that represents this IAnalogValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Value { get; set; }
Property Value As Double
    Get
    Set
abstract Value : float with get, set

function get_Value();
function set_Value(value);
property double Value {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IAnalogValue Interface
GSF.PhasorProtocols Namespace


IChannel Interface

Grid Solutions Framework IChannel Interface
Represents a protocol independent interface representation of any data type that can be parsed or generated.
This is the base interface implemented by all parsing/generating classes in the phasor protocols library; it is the root of the parsing/generating interface hierarchy.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannel : ISupportBinaryImage
Public Interface IChannel
    Inherits ISupportBinaryImage
type IChannel =
    interface
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IChannel = function();
GSF.PhasorProtocols.IChannel.createInterface('GSF.PhasorProtocols.IChannel');
public interface class IChannel : ISupportBinaryImage

The IChannel type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object.
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | State | Gets or sets the parsing state for this IChannel object.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IChannel Methods

Grid Solutions Framework IChannel Methods

The IChannel type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IChannel Interface
GSF.PhasorProtocols Namespace


IChannel Properties

Grid Solutions Framework IChannel Properties

The IChannel type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object.
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | State | Gets or sets the parsing state for this IChannel object.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object.
Top
See Also

Reference

IChannel Interface
GSF.PhasorProtocols Namespace


IChannel.Attributes Property

Grid Solutions Framework IChannelAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
Dictionary<string, string> Attributes { get; }
ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get

function get_Attributes();

property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary String, String
See Also

Reference

IChannel Interface
GSF.PhasorProtocols Namespace


IChannel.State Property

Grid Solutions Framework IChannelState Property
Gets or sets the parsing state for this IChannel object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IChannelParsingState State { get; set; }
Property State As IChannelParsingState
    Get
    Set
abstract State : IChannelParsingState with get, set

function get_State();
function set_State(value);
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}

Property Value

Type: IChannelParsingState
See Also

Reference

IChannel Interface
GSF.PhasorProtocols Namespace


IChannel.Tag Property

Grid Solutions Framework IChannelTag Property
Gets or sets a user definable reference to an object associated with this IChannel object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
Object Tag { get; set; }
Property Tag As Object
    Get
    Set
abstract Tag : Object with get, set

function get_Tag();
function set_Tag(value);
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
Remarks
Classes implementing IChannel should only track this value.
See Also

Reference

IChannel Interface
GSF.PhasorProtocols Namespace


IChannelCell Interface

Grid Solutions Framework IChannelCell Interface
Represents a protocol independent interface representation of any kind of IChannelFrame cell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelCell : IChannel,
    ISupportBinaryImage, ISerializable
Public Interface IChannelCell
    Inherits IChannel, ISupportBinaryImage, ISerializable
type IChannelCell =
    interface
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.IChannelCell = function();
GSF.PhasorProtocols.IChannelCell.createInterface('GSF.PhasorProtocols.IChannelCell');
public interface class IChannelCell : IChannel,
    ISupportBinaryImage, ISerializable

The IChannelCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | IDCode | Gets the numeric ID code for this IChannelCell.
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
Remarks
This phasor protocol implementation defines a "cell" as a portion of a "frame", i.e., a logical unit of data. For example, a IDataCell (derived from IChannelCell) could be defined as a PMU within a frame of data, a IDataFrame, that contains multiple PMU's coming from a PDC.
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelCell Methods

Grid Solutions Framework IChannelCell Methods

The IChannelCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IChannelCell Interface
GSF.PhasorProtocols Namespace


IChannelCell Properties

Grid Solutions Framework IChannelCell Properties

The IChannelCell type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | IDCode | Gets the numeric ID code for this IChannelCell.
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IChannelCell Interface
GSF.PhasorProtocols Namespace


IChannelCell.IDCode Property

Grid Solutions Framework IChannelCellIDCode Property
Gets the numeric ID code for this IChannelCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ushort IDCode { get; set; }
Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set

function get_IDCode();
function set_IDCode(value);
property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
Remarks
Most phasor measurement devices define some kind of numeric identifier (e.g., a hardware identifier coded into the device ROM); this is the abstract representation of this identifier.
See Also

Reference

IChannelCell Interface
GSF.PhasorProtocols Namespace


IChannelCell.Parent Property

Grid Solutions Framework IChannelCellParent Property
Gets a reference to the parent IChannelFrame for this IChannelCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IChannelFrame Parent { get; set; }
Property Parent As IChannelFrame
    Get
    Set
abstract Parent : IChannelFrame with get, set

function get_Parent();
function set_Parent(value);
property IChannelFrame^ Parent {
    IChannelFrame^ get ();
    void set (IChannelFrame^ value);
}

Property Value

Type: IChannelFrame
See Also

Reference

IChannelCell Interface
GSF.PhasorProtocols Namespace


IChannelCell.State Property

Grid Solutions Framework IChannelCellState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase.
Top
See Also

Reference

IChannelCell Interface
GSF.PhasorProtocols Namespace


IChannelCell.State Property

Grid Solutions Framework IChannelCellState Property
Gets or sets the parsing state for the this ChannelCellBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IChannelCellParsingState State { get; set; }
Property State As IChannelCellParsingState
    Get
    Set
abstract State : IChannelCellParsingState with get, set

function get_State();
function set_State(value);
property IChannelCellParsingState^ State {
    IChannelCellParsingState^ get ();
    void set (IChannelCellParsingState^ value);
}

Property Value

Type: IChannelCellParsingState
See Also

Reference

IChannelCell Interface
State Overload
GSF.PhasorProtocols Namespace


IChannelCellCollection(T) Interface

Grid Solutions Framework IChannelCellCollectionT Interface
Represents a protocol independent interface representation of a collection of IChannelCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelCellCollection<T> : IChannelCollection<T>,
    IChannel, ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>,
    IEnumerable, INotifyCollectionChanged, ISerializable
where T : IChannelCell

Public Interface IChannelCellCollection(Of T As IChannelCell)
    Inherits IChannelCollection(Of T), IChannel, ISupportBinaryImage,
    IList(Of T), ICollection(Of T), IEnumerable(Of T),
    IEnumerable, INotifyCollectionChanged, ISerializable
type IChannelCellCollection<'T when 'T : IChannelCell> =
    interface
        interface IChannelCollection<'T>
        interface IChannel
        interface ISupportBinaryImage
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
        interface INotifyCollectionChanged
        interface ISerializable
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : IChannelCell
public interface class IChannelCellCollection : IChannelCollection<T>,
    IChannel, ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>,
    IEnumerable, INotifyCollectionChanged, ISerializable

Type Parameters

T
Generic type used.

The IChannelCellCollectionT type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this IChannelCellCollectionT are constant.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelCellCollection(T) Methods

Grid Solutions Framework IChannelCellCollectionT Methods

The IChannelCellCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T .)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

IChannelCellCollectionT Interface
GSF.PhasorProtocols Namespace


IChannelCellCollection(T) Properties

Grid Solutions Framework IChannelCellCollectionT Properties

The IChannelCellCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this IChannelCellCollectionT are constant.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T .)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IChannelCellCollectionT Interface
GSF.PhasorProtocols Namespace


IChannelCellCollection(T).ConstantCellLength Property

Grid Solutions Framework IChannelCellCollectionTConstantCellLength Property
Gets flag that determines if the lengths of IChannelCell elements in this IChannelCellCollectionT are constant.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool ConstantCellLength { get; }
ReadOnly Property ConstantCellLength As Boolean
    Get
abstract ConstantCellLength : bool with get

function get_ConstantCellLength();

property bool ConstantCellLength {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IChannelCellCollectionT Interface
GSF.PhasorProtocols Namespace


IChannelCellCollection(T) Events

Grid Solutions Framework IChannelCellCollectionT Events

The IChannelCellCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Top
See Also

Reference

IChannelCellCollectionT Interface
GSF.PhasorProtocols Namespace


IChannelCellParsingState Interface

Grid Solutions Framework IChannelCellParsingState Interface
Represents a protocol independent interface representation of the parsing state of any kind of IChannelCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelCellParsingState : IChannelParsingState
Public Interface IChannelCellParsingState
    Inherits IChannelParsingState
type IChannelCellParsingState =
    interface
        interface IChannelParsingState
    end
GSF.PhasorProtocols.IChannelCellParsingState = function();
GSF.PhasorProtocols.IChannelCellParsingState.createInterface('GSF.PhasorProtocols.IChannelCellParsingState');
public interface class IChannelCellParsingState : IChannelParsingState

The IChannelCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelCellParsingState Properties

Grid Solutions Framework IChannelCellParsingState Properties

The IChannelCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed.
Top
See Also

Reference

IChannelCellParsingState Interface
GSF.PhasorProtocols Namespace


IChannelCellParsingState.AnalogCount Property

Grid Solutions Framework IChannelCellParsingStateAnalogCount Property
Gets or sets the number of analog elements associated with the IChannelCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int AnalogCount { get; set; }
Property AnalogCount As Integer
    Get
    Set
abstract AnalogCount : int with get, set

function get_AnalogCount();
function set_AnalogCount(value);
property int AnalogCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IChannelCellParsingState Interface
GSF.PhasorProtocols Namespace


IChannelCellParsingState.DigitalCount Property

Grid Solutions Framework IChannelCellParsingStateDigitalCount Property
Gets or sets the number of digital elements associated with the IChannelCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int DigitalCount { get; set; }
Property DigitalCount As Integer
    Get
    Set
abstract DigitalCount : int with get, set

function get_DigitalCount();
function set_DigitalCount(value);
property int DigitalCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IChannelCellParsingState Interface
GSF.PhasorProtocols Namespace


IChannelCellParsingState.PhasorCount Property

Grid Solutions Framework IChannelCellParsingStatePhasorCount Property
Gets or sets the number of phasor elements associated with the IChannelCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int PhasorCount { get; set; }
Property PhasorCount As Integer
    Get
    Set
abstract PhasorCount : int with get, set

function get_PhasorCount();
function set_PhasorCount(value);
property int PhasorCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IChannelCellParsingState Interface
GSF.PhasorProtocols Namespace


IChannelCollection(T) Interface

Grid Solutions Framework IChannelCollectionT Interface
Represents a protocol independent interface representation of a collection of any IChannel objects.
This is the base interface implemented by all collections classes in the phasor protocols library; it is the root of the collection interface hierarchy.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelCollection<T> : IChannel,
    ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable,
    INotifyCollectionChanged, ISerializable
where T : IChannel

Public Interface IChannelCollection(Of T As IChannel)
    Inherits IChannel, ISupportBinaryImage, IList(Of T),
    ICollection(Of T), IEnumerable(Of T), IEnumerable, INotifyCollectionChanged,
    ISerializable
type IChannelCollection<'T when 'T : IChannel> =
    interface
        interface IChannel
        interface ISupportBinaryImage
        interface IList<'T>
        interface ICollection<'T>
        interface IEnumerable<'T>
        interface IEnumerable
        interface INotifyCollectionChanged
        interface ISerializable
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : IChannel
public interface class IChannelCollection : IChannel,
    ISupportBinaryImage, IList<T>, ICollection<T>, IEnumerable<T>, IEnumerable,
    INotifyCollectionChanged, ISerializable

Type Parameters

T
Specific IChannel type that the IChannelCollectionT contains.

The IChannelCollectionT type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T.)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T.)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T.)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelCollection(T) Methods

Grid Solutions Framework IChannelCollectionT Methods

The IChannelCollectionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection T .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection T .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection T .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection T .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable T .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList T .)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList T .)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection T .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList T .)
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeT | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | DistinctByT, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetRangeT | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfT | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, Char, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringT(String, String, FuncString, T) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityT(T) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(FuncT, T, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxT(IComparerT) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByT, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(FuncT, T, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinT(IComparerT) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByT, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityT(T) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | ScrambleT | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleT(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringT(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleT | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeT | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

IChannelCollectionT Interface
GSF.PhasorProtocols Namespace


IChannelCollection(T) Properties

Grid Solutions Framework IChannelCollectionT Properties

The IChannelCollectionT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection T .)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection T .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList T .)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IChannelCollectionT Interface
GSF.PhasorProtocols Namespace


IChannelCollection(T) Events

Grid Solutions Framework IChannelCollectionT Events

The IChannelCollectionT generic type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Occurs when the collection changes. (Inherited from INotifyCollectionChanged.)
Top
See Also

Reference

IChannelCollectionT Interface
GSF.PhasorProtocols Namespace


IChannelDefinition Interface

Grid Solutions Framework IChannelDefinition Interface
Represents a protocol independent interface representation of a definition of any kind of IChannel data.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelDefinition : IChannel,
    ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>,
    IComparable
Public Interface IChannelDefinition
    Inherits IChannel, ISupportBinaryImage, ISerializable, IEquatable(Of IChannelDefinition),
    IComparable(Of IChannelDefinition), IComparable
type IChannelDefinition =
    interface
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.IChannelDefinition = function();
GSF.PhasorProtocols.IChannelDefinition.createInterface('GSF.PhasorProtocols.IChannelDefinition');
public interface class IChannelDefinition : IChannel,
    ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>,
    IComparable

The IChannelDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition.
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition.
Public property | Index | Gets or sets the index of this IChannelDefinition.
Public property | Label | Gets or sets the label of this IChannelDefinition.
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition.
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition.
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition.
Public property | Offset | Gets or sets the offset of this IChannelDefinition.
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition.
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition.
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
Remarks
Each instance of IChannelDefinition will have a more specific derived implementation (e.g., IAnalogDefinition and IFrequencyDefinition), these specific implementations of IChannelDefinition will be referenced children of a IConfigurationCell.
The IChannelDefinition defines the properties of an associated IChannelValueT.
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelDefinition Methods

Grid Solutions Framework IChannelDefinition Methods

The IChannelDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition Properties

Grid Solutions Framework IChannelDefinition Properties

The IChannelDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition.
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition.
Public property | Index | Gets or sets the index of this IChannelDefinition.
Public property | Label | Gets or sets the label of this IChannelDefinition.
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition.
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition.
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition.
Public property | Offset | Gets or sets the offset of this IChannelDefinition.
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition.
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition.
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.ConversionFactor Property

Grid Solutions Framework IChannelDefinitionConversionFactor Property
Gets or sets the conversion factor of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double ConversionFactor { get; set; }
Property ConversionFactor As Double
    Get
    Set
abstract ConversionFactor : float with get, set

function get_ConversionFactor();
function set_ConversionFactor(value);
property double ConversionFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.DataFormat Property

Grid Solutions Framework IChannelDefinitionDataFormat Property
Gets the DataFormat of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataFormat DataFormat { get; }
ReadOnly Property DataFormat As DataFormat
    Get
abstract DataFormat : DataFormat with get

function get_DataFormat();

property DataFormat DataFormat {
    DataFormat get ();
}

Property Value

Type: DataFormat
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.Index Property

Grid Solutions Framework IChannelDefinitionIndex Property
Gets or sets the index of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int Index { get; set; }
Property Index As Integer
    Get
    Set
abstract Index : int with get, set

function get_Index();
function set_Index(value);
property int Index {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.Label Property

Grid Solutions Framework IChannelDefinitionLabel Property
Gets or sets the label of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Label { get; set; }
Property Label As String
    Get
    Set
abstract Label : string with get, set

function get_Label();
function set_Label(value);
property String^ Label {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.LabelImage Property

Grid Solutions Framework IChannelDefinitionLabelImage Property
Gets the binary image of the Label of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] LabelImage { get; }
ReadOnly Property LabelImage As Byte()
    Get
abstract LabelImage : byte[] with get

function get_LabelImage();

property array<unsigned char>^ LabelImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.MaximumLabelLength Property

Grid Solutions Framework IChannelDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int MaximumLabelLength { get; }
ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get

function get_MaximumLabelLength();

property int MaximumLabelLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.MaximumScalingValue Property

Grid Solutions Framework IChannelDefinitionMaximumScalingValue Property
Gets the maximum value for the ScalingValue of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
uint MaximumScalingValue { get; }
ReadOnly Property MaximumScalingValue As UInteger
    Get
abstract MaximumScalingValue : uint32 with get

function get_MaximumScalingValue();

property unsigned int MaximumScalingValue {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.Offset Property

Grid Solutions Framework IChannelDefinitionOffset Property
Gets or sets the offset of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Offset { get; set; }
Property Offset As Double
    Get
    Set
abstract Offset : float with get, set

function get_Offset();
function set_Offset(value);
property double Offset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.Parent Property

Grid Solutions Framework IChannelDefinitionParent Property
Gets the IConfigurationCell parent of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationCell Parent { get; set; }
Property Parent As IConfigurationCell
    Get
    Set
abstract Parent : IConfigurationCell with get, set

function get_Parent();
function set_Parent(value);
property IConfigurationCell^ Parent {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}

Property Value

Type: IConfigurationCell
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.ScalePerBit Property

Grid Solutions Framework IChannelDefinitionScalePerBit Property
Gets the scale/bit value of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double ScalePerBit { get; }
ReadOnly Property ScalePerBit As Double
    Get
abstract ScalePerBit : float with get

function get_ScalePerBit();

property double ScalePerBit {
    double get ();
}

Property Value

Type: Double
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelDefinition.ScalingValue Property

Grid Solutions Framework IChannelDefinitionScalingValue Property
Gets or sets the integer scaling value of this IChannelDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
uint ScalingValue { get; set; }
Property ScalingValue As UInteger
    Get
    Set
abstract ScalingValue : uint32 with get, set

function get_ScalingValue();
function set_ScalingValue(value);
property unsigned int ScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

IChannelDefinition Interface
GSF.PhasorProtocols Namespace


IChannelFrame Interface

Grid Solutions Framework IChannelFrame Interface
Represents a protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelFrame : IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame>, IComparable<IFrame>,
    IComparable, ISerializable
Public Interface IChannelFrame
    Inherits IChannel, ISupportBinaryImage, IFrame, IEquatable(Of IFrame),
    IComparable(Of IFrame), IComparable, ISerializable
type IChannelFrame =
    interface
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.IChannelFrame = function();
GSF.PhasorProtocols.IChannelFrame.createInterface('GSF.PhasorProtocols.IChannelFrame');
public interface class IChannelFrame : IChannel,
    ISupportBinaryImage, IFrame, IEquatable<IFrame^>, IComparable<IFrame^>,
    IComparable, ISerializable

The IChannelFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame.
Public property | IDCode | Gets or sets the ID code of this IChannelFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame.
Top
Remarks

The phasor protocols library defines a "frame" as a collection of cells (logical units of data). For example, a IDataCell would be defined as a PMU within a frame of data, a IDataFrame (derived from IChannelFrame), that contains multiple PMU's coming from a PDC.

This interface inherits IFrame so that classes implementing this interface can be cooperatively integrated into measurement concentration (see ConcentratorBase).

See Also

Reference

GSF.PhasorProtocols Namespace


IChannelFrame Methods

Grid Solutions Framework IChannelFrame Methods

The IChannelFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IChannelFrame Interface
GSF.PhasorProtocols Namespace


IChannelFrame Properties

Grid Solutions Framework IChannelFrame Properties

The IChannelFrame type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame.
Public property | IDCode | Gets or sets the ID code of this IChannelFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame.
Top
See Also

Reference

IChannelFrame Interface
GSF.PhasorProtocols Namespace


IChannelFrame.Cells Property

Grid Solutions Framework IChannelFrameCells Property
Gets the simple reference to the collection of cells for this IChannelFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
Object Cells { get; }
ReadOnly Property Cells As Object
    Get
abstract Cells : Object with get

function get_Cells();

property Object^ Cells {
    Object^ get ();
}

Property Value

Type: Object
See Also

Reference

IChannelFrame Interface
GSF.PhasorProtocols Namespace


IChannelFrame.FrameType Property

Grid Solutions Framework IChannelFrameFrameType Property
Gets the FundamentalFrameType for this IChannelFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
FundamentalFrameType FrameType { get; }
ReadOnly Property FrameType As FundamentalFrameType
    Get
abstract FrameType : FundamentalFrameType with get

function get_FrameType();

property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}

Property Value

Type: FundamentalFrameType
See Also

Reference

IChannelFrame Interface
GSF.PhasorProtocols Namespace


IChannelFrame.IDCode Property

Grid Solutions Framework IChannelFrameIDCode Property
Gets or sets the ID code of this IChannelFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ushort IDCode { get; set; }
Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set

function get_IDCode();
function set_IDCode(value);
property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

IChannelFrame Interface
GSF.PhasorProtocols Namespace


IChannelFrame.TimeTag Property

Grid Solutions Framework IChannelFrameTimeTag Property
Gets UNIX based time representation of the ticks of this IChannelFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
UnixTimeTag TimeTag { get; }
ReadOnly Property TimeTag As UnixTimeTag
    Get
abstract TimeTag : UnixTimeTag with get

function get_TimeTag();

property UnixTimeTag^ TimeTag {
    UnixTimeTag^ get ();
}

Property Value

Type: UnixTimeTag
See Also

Reference

IChannelFrame Interface
GSF.PhasorProtocols Namespace


IChannelFrame(T) Interface

Grid Solutions Framework IChannelFrameT Interface
Represents a strongly-typed protocol independent interface representation of any kind of frame of data that contains a collection of IChannelCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelFrame<T> : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
where T : IChannelCell

Public Interface IChannelFrame(Of T As IChannelCell)
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,
    ISerializable
type IChannelFrame<'T when 'T : IChannelCell> =
    interface
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : IChannelCell
public interface class IChannelFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable

Type Parameters

T
Specific IChannelCell type that the IChannelFrameT contains.

The IChannelFrameT type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrameT.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IChannelFrameT.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
Remarks
This interface inherits IFrame so that classes implementing this interface can be cooperatively integrated into measurement concentration (see ConcentratorBase).
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelFrame(T) Methods

Grid Solutions Framework IChannelFrameT Methods

The IChannelFrameT generic type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IChannelFrameT Interface
GSF.PhasorProtocols Namespace


IChannelFrame(T) Properties

Grid Solutions Framework IChannelFrameT Properties

The IChannelFrameT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrameT.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IChannelFrameT.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

IChannelFrameT Interface
GSF.PhasorProtocols Namespace


IChannelFrame(T).Cells Property

Grid Solutions Framework IChannelFrameTCells Property
Overload List
 | Name | Description
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrameT.
Top
See Also

Reference

IChannelFrameT Interface
GSF.PhasorProtocols Namespace


IChannelFrame(T).Cells Property

Grid Solutions Framework IChannelFrameTCells Property
Gets the strongly-typed reference to the collection of cells for this IChannelFrameT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IChannelCellCollection<T> Cells { get; }
ReadOnly Property Cells As IChannelCellCollection(Of T)
    Get
abstract Cells : IChannelCellCollection<'T> with get

function get_Cells();

property IChannelCellCollection<T>^ Cells {
    IChannelCellCollection<T>^ get ();
}

Property Value

Type: IChannelCellCollection T
See Also

Reference

IChannelFrameT Interface
Cells Overload
GSF.PhasorProtocols Namespace


IChannelFrame(T).State Property

Grid Solutions Framework IChannelFrameTState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IChannelFrameT.
Top
See Also

Reference

IChannelFrameT Interface
GSF.PhasorProtocols Namespace


IChannelFrame(T).State Property

Grid Solutions Framework IChannelFrameTState Property
Gets or sets the parsing state for this IChannelFrameT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IChannelFrameParsingState<T> State { get; set; }
Property State As IChannelFrameParsingState(Of T)
    Get
    Set
abstract State : IChannelFrameParsingState<'T> with get, set

function get_State();
function set_State(value);
property IChannelFrameParsingState<T>^ State {
    IChannelFrameParsingState<T>^ get ();
    void set (IChannelFrameParsingState<T>^ value);
}

Property Value

Type: IChannelFrameParsingState T
See Also

Reference

IChannelFrameT Interface
State Overload
GSF.PhasorProtocols Namespace


IChannelFrameParsingState(T) Interface

Grid Solutions Framework IChannelFrameParsingStateT Interface
Represents a protocol independent interface representation of the parsing state of any kind of IChannelFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelFrameParsingState<T> : IChannelParsingState
where T : IChannelCell

Public Interface IChannelFrameParsingState(Of T As IChannelCell)
    Inherits IChannelParsingState
type IChannelFrameParsingState<'T when 'T : IChannelCell> =
    interface
        interface IChannelParsingState
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : IChannelCell
public interface class IChannelFrameParsingState : IChannelParsingState

Type Parameters

T
Specific IChannelCell type that the IChannelFrameParsingStateT references.

The IChannelFrameParsingStateT type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelFrameParsingState(T) Properties

Grid Solutions Framework IChannelFrameParsingStateT Properties

The IChannelFrameParsingStateT generic type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated.
Top
See Also

Reference

IChannelFrameParsingStateT Interface
GSF.PhasorProtocols Namespace


IChannelFrameParsingState(T).CellCount Property

Grid Solutions Framework IChannelFrameParsingStateTCellCount Property
Gets or sets number of cells that are expected in associated IChannelFrame being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int CellCount { get; set; }
Property CellCount As Integer
    Get
    Set
abstract CellCount : int with get, set

function get_CellCount();
function set_CellCount(value);
property int CellCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IChannelFrameParsingStateT Interface
GSF.PhasorProtocols Namespace


IChannelFrameParsingState(T).CreateNewCell Property

Grid Solutions Framework IChannelFrameParsingStateTCreateNewCell Property
Gets reference to delegate used to create a new IChannelCell object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewCellFunction<T> CreateNewCell { get; }
ReadOnly Property CreateNewCell As CreateNewCellFunction(Of T)
    Get
abstract CreateNewCell : CreateNewCellFunction<'T> with get

function get_CreateNewCell();

property CreateNewCellFunction<T>^ CreateNewCell {
    CreateNewCellFunction<T>^ get ();
}

Property Value

Type: CreateNewCellFunction T
See Also

Reference

IChannelFrameParsingStateT Interface
GSF.PhasorProtocols Namespace


IChannelFrameParsingState(T).TrustHeaderLength Property

Grid Solutions Framework IChannelFrameParsingStateTTrustHeaderLength Property
Gets or sets flag that determines if header lengths should be trusted over parsed byte count.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool TrustHeaderLength { get; set; }
Property TrustHeaderLength As Boolean
    Get
    Set
abstract TrustHeaderLength : bool with get, set

function get_TrustHeaderLength();
function set_TrustHeaderLength(value);
property bool TrustHeaderLength {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
It is expected that this will normally be left as true.
See Also

Reference

IChannelFrameParsingStateT Interface
GSF.PhasorProtocols Namespace


IChannelFrameParsingState(T).ValidateCheckSum Property

Grid Solutions Framework IChannelFrameParsingStateTValidateCheckSum Property
Gets or sets flag that determines if frame's check-sum should be validated.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool ValidateCheckSum { get; set; }
Property ValidateCheckSum As Boolean
    Get
    Set
abstract ValidateCheckSum : bool with get, set

function get_ValidateCheckSum();
function set_ValidateCheckSum(value);
property bool ValidateCheckSum {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
It is expected that this will normally be left as true.
See Also

Reference

IChannelFrameParsingStateT Interface
GSF.PhasorProtocols Namespace


IChannelParsingState Interface

Grid Solutions Framework IChannelParsingState Interface
Represents a protocol independent interface representation of the parsing state used by any kind of IChannel data.
This is the base interface implemented by all parsing state classes in the phasor protocols library; it is the root of the parsing state interface hierarchy.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelParsingState
Public Interface IChannelParsingState
type IChannelParsingState =  interface end
GSF.PhasorProtocols.IChannelParsingState = function();
GSF.PhasorProtocols.IChannelParsingState.createInterface('GSF.PhasorProtocols.IChannelParsingState');
public interface class IChannelParsingState

The IChannelParsingState type exposes the following members.

Properties
 | Name | Description
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image.
Top
Remarks
Data parsing is very format specific, classes implementing this interface create a common form for parsing state information particular to a data type.
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelParsingState Properties

Grid Solutions Framework IChannelParsingState Properties

The IChannelParsingState type exposes the following members.

Properties
 | Name | Description
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image.
Top
See Also

Reference

IChannelParsingState Interface
GSF.PhasorProtocols Namespace


IChannelParsingState.ParsedBinaryLength Property

Grid Solutions Framework IChannelParsingStateParsedBinaryLength Property
Gets or sets the length of the associated IChannel object being parsed from the binary image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int ParsedBinaryLength { get; set; }
Property ParsedBinaryLength As Integer
    Get
    Set
abstract ParsedBinaryLength : int with get, set

function get_ParsedBinaryLength();
function set_ParsedBinaryLength(value);
property int ParsedBinaryLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IChannelParsingState Interface
GSF.PhasorProtocols Namespace


IChannelValue(T) Interface

Grid Solutions Framework IChannelValueT Interface
Represents a protocol independent interface representation any kind of IChannel data value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IChannelValue<T> : IChannel,
    ISupportBinaryImage, ISerializable
where T : IChannelDefinition

Public Interface IChannelValue(Of T As IChannelDefinition)
    Inherits IChannel, ISupportBinaryImage, ISerializable
type IChannelValue<'T when 'T : IChannelDefinition> =
    interface
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
JavaScript does not support generic types or methods.
generic<typename T>
where T : IChannelDefinition
public interface class IChannelValue : IChannel,
    ISupportBinaryImage, ISerializable

Type Parameters

T
Specific IChannelDefinition type that represents the IChannelValueT definition.

The IChannelValueT type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT.
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides.
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat.
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value.
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label.
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values.
Public property | Parent | Gets the IDataCell parent of this IChannelValueT.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
Remarks
Each instance of IChannelValueT will have a more specific derived implementation (e.g., IDigitalValue and IPhasorValue), these specific implementations of IChannelValueT will be referenced children of a IDataCell.
The IChannelValueT uses the specified IChannelDefinition type to define its properties.
See Also

Reference

GSF.PhasorProtocols Namespace


IChannelValue(T) Methods

Grid Solutions Framework IChannelValueT Methods

The IChannelValueT generic type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT.
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).GetCompositeValue Method

Grid Solutions Framework IChannelValueTGetCompositeValue Method
Gets the specified composite value of this IChannelValueT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double GetCompositeValue(
    int index
)
Function GetCompositeValue (
    index As Integer
) As Double
abstract GetCompositeValue :
        index : int -> float

function GetCompositeValue(index);
double GetCompositeValue(
    int index
)

Parameters

index
Type: SystemInt32
Index of composite value to retrieve.

Return Value

Type: Double
A Double representing the composite value.
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).GetMeasurementValueFilterFunction Method

Grid Solutions Framework IChannelValueTGetMeasurementValueFilterFunction Method
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Function GetMeasurementValueFilterFunction (
    index As Integer
) As MeasurementValueFilterFunction
abstract GetMeasurementValueFilterFunction :
        index : int -> MeasurementValueFilterFunction

function GetMeasurementValueFilterFunction(index);
MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
)

Parameters

index
Type: SystemInt32
Index of composite value for which to retrieve its filter function.

Return Value

Type: MeasurementValueFilterFunction
Function used to apply a downsampling filter over a sequence of IMeasurement values, if defined; otherwise, null.
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T) Properties

Grid Solutions Framework IChannelValueT Properties

The IChannelValueT generic type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides.
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat.
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value.
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label.
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values.
Public property | Parent | Gets the IDataCell parent of this IChannelValueT.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).CompositeValueCount Property

Grid Solutions Framework IChannelValueTCompositeValueCount Property
Gets total number of composite values that this IChannelValueT provides.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int CompositeValueCount { get; }
ReadOnly Property CompositeValueCount As Integer
    Get
abstract CompositeValueCount : int with get

function get_CompositeValueCount();

property int CompositeValueCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).DataFormat Property

Grid Solutions Framework IChannelValueTDataFormat Property
Gets the DataFormat of this IChannelValueT typically derived from DataFormat.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataFormat DataFormat { get; }
ReadOnly Property DataFormat As DataFormat
    Get
abstract DataFormat : DataFormat with get

function get_DataFormat();

property DataFormat DataFormat {
    DataFormat get ();
}

Property Value

Type: DataFormat
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).Definition Property

Grid Solutions Framework IChannelValueTDefinition Property
Gets the IChannelDefinition associated with this IChannelValueT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
T Definition { get; set; }
Property Definition As T
    Get
    Set
abstract Definition : 'T with get, set

function get_Definition();
function set_Definition(value);
property T Definition {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).IsEmpty Property

Grid Solutions Framework IChannelValueTIsEmpty Property
Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool IsEmpty { get; }
ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get

function get_IsEmpty();

property bool IsEmpty {
    bool get ();
}

Return Value

Type: Boolean
True, if no composite values have been assigned a value; otherwise, false.
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).Label Property

Grid Solutions Framework IChannelValueTLabel Property
Gets text based label of this IChannelValueT typically derived from Label.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Label { get; }
ReadOnly Property Label As String
    Get
abstract Label : string with get

function get_Label();

property String^ Label {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).Measurements Property

Grid Solutions Framework IChannelValueTMeasurements Property
Gets the composite values of this IChannelValueT as an array of IMeasurement values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IMeasurement[] Measurements { get; }
ReadOnly Property Measurements As IMeasurement()
    Get
abstract Measurements : IMeasurement[] with get

function get_Measurements();

property array<IMeasurement^>^ Measurements {
    array<IMeasurement^>^ get ();
}

Property Value

Type: IMeasurement
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


IChannelValue(T).Parent Property

Grid Solutions Framework IChannelValueTParent Property
Gets the IDataCell parent of this IChannelValueT.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IDataCell Parent { get; set; }
Property Parent As IDataCell
    Get
    Set
abstract Parent : IDataCell with get, set

function get_Parent();
function set_Parent(value);
property IDataCell^ Parent {
    IDataCell^ get ();
    void set (IDataCell^ value);
}

Property Value

Type: IDataCell
See Also

Reference

IChannelValueT Interface
GSF.PhasorProtocols Namespace


ICommandCell Interface

Grid Solutions Framework ICommandCell Interface
Represents a protocol independent interface representation of any kind of ICommandFrame cell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ICommandCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface ICommandCell
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable
type ICommandCell =
    interface
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.ICommandCell = function();
GSF.PhasorProtocols.ICommandCell.createInterface('GSF.PhasorProtocols.ICommandCell');
public interface class ICommandCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable

The ICommandCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ExtendedDataByte | Gets or sets extended data Byte that represents this ICommandCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent ICommandFrame for this ICommandCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ICommandCell Methods

Grid Solutions Framework ICommandCell Methods

The ICommandCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ICommandCell Interface
GSF.PhasorProtocols Namespace


ICommandCell Properties

Grid Solutions Framework ICommandCell Properties

The ICommandCell type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ExtendedDataByte | Gets or sets extended data Byte that represents this ICommandCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent ICommandFrame for this ICommandCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

ICommandCell Interface
GSF.PhasorProtocols Namespace


ICommandCell.ExtendedDataByte Property

Grid Solutions Framework ICommandCellExtendedDataByte Property
Gets or sets extended data Byte that represents this ICommandCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte ExtendedDataByte { get; set; }
Property ExtendedDataByte As Byte
    Get
    Set
abstract ExtendedDataByte : byte with get, set

function get_ExtendedDataByte();
function set_ExtendedDataByte(value);
property unsigned char ExtendedDataByte {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

ICommandCell Interface
GSF.PhasorProtocols Namespace


ICommandCell.Parent Property

Grid Solutions Framework ICommandCellParent Property
Overload List
 | Name | Description
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent ICommandFrame for this ICommandCell.
Top
See Also

Reference

ICommandCell Interface
GSF.PhasorProtocols Namespace


ICommandCell.Parent Property

Grid Solutions Framework ICommandCellParent Property
Gets a reference to the parent ICommandFrame for this ICommandCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ICommandFrame Parent { get; set; }
Property Parent As ICommandFrame
    Get
    Set
abstract Parent : ICommandFrame with get, set

function get_Parent();
function set_Parent(value);
property ICommandFrame^ Parent {
    ICommandFrame^ get ();
    void set (ICommandFrame^ value);
}

Property Value

Type: ICommandFrame
See Also

Reference

ICommandCell Interface
Parent Overload
GSF.PhasorProtocols Namespace


ICommandFrame Interface

Grid Solutions Framework ICommandFrame Interface
Represents a protocol independent interface representation of any kind of command frame that contains a collection of ICommandCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ICommandFrame : IChannelFrame<ICommandCell>,
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface ICommandFrame
    Inherits IChannelFrame(Of ICommandCell), IChannelFrame, IChannel,
    ISupportBinaryImage, IFrame, IEquatable(Of IFrame), IComparable(Of IFrame),
    IComparable, ISerializable
type ICommandFrame =
    interface
        interface IChannelFrame<ICommandCell>
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.ICommandFrame = function();
GSF.PhasorProtocols.ICommandFrame.createInterface('GSF.PhasorProtocols.ICommandFrame');
public interface class ICommandFrame : IChannelFrame<ICommandCell^>,
    IChannelFrame, IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable

The ICommandFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrameT. (Inherited from IChannelFrameT.)
Public property | Cells | Gets reference to the CommandCellCollection for this ICommandFrame.
Public property | Command | Gets or sets DeviceCommand for this ICommandFrame.
Public property | ExtendedData | Gets or sets extended binary image data for this ICommandFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IChannelFrameT. (Inherited from IChannelFrameT.)
Public property | State | Gets or sets the parsing state for the this ICommandFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ICommandFrame Methods

Grid Solutions Framework ICommandFrame Methods

The ICommandFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ICommandFrame Interface
GSF.PhasorProtocols Namespace


ICommandFrame Properties

Grid Solutions Framework ICommandFrame Properties

The ICommandFrame type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrameT. (Inherited from IChannelFrameT.)
Public property | Cells | Gets reference to the CommandCellCollection for this ICommandFrame.
Public property | Command | Gets or sets DeviceCommand for this ICommandFrame.
Public property | ExtendedData | Gets or sets extended binary image data for this ICommandFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IChannelFrameT. (Inherited from IChannelFrameT.)
Public property | State | Gets or sets the parsing state for the this ICommandFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

ICommandFrame Interface
GSF.PhasorProtocols Namespace


ICommandFrame.Cells Property

Grid Solutions Framework ICommandFrameCells Property
Overload List
 | Name | Description
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets the strongly-typed reference to the collection of cells for this IChannelFrameT. (Inherited from IChannelFrameT.)
Public property | Cells | Gets reference to the CommandCellCollection for this ICommandFrame.
Top
See Also

Reference

ICommandFrame Interface
GSF.PhasorProtocols Namespace


ICommandFrame.Cells Property

Grid Solutions Framework ICommandFrameCells Property
Gets reference to the CommandCellCollection for this ICommandFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CommandCellCollection Cells { get; }
ReadOnly Property Cells As CommandCellCollection
    Get
abstract Cells : CommandCellCollection with get

function get_Cells();

property CommandCellCollection^ Cells {
    CommandCellCollection^ get ();
}

Property Value

Type: CommandCellCollection
See Also

Reference

ICommandFrame Interface
Cells Overload
GSF.PhasorProtocols Namespace


ICommandFrame.Command Property

Grid Solutions Framework ICommandFrameCommand Property
Gets or sets DeviceCommand for this ICommandFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DeviceCommand Command { get; set; }
Property Command As DeviceCommand
    Get
    Set
abstract Command : DeviceCommand with get, set

function get_Command();
function set_Command(value);
property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}

Property Value

Type: DeviceCommand
See Also

Reference

ICommandFrame Interface
GSF.PhasorProtocols Namespace


ICommandFrame.ExtendedData Property

Grid Solutions Framework ICommandFrameExtendedData Property
Gets or sets extended binary image data for this ICommandFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] ExtendedData { get; set; }
Property ExtendedData As Byte()
    Get
    Set
abstract ExtendedData : byte[] with get, set

function get_ExtendedData();
function set_ExtendedData(value);
property array<unsigned char>^ ExtendedData {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
See Also

Reference

ICommandFrame Interface
GSF.PhasorProtocols Namespace


ICommandFrame.State Property

Grid Solutions Framework ICommandFrameState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IChannelFrameT. (Inherited from IChannelFrameT.)
Public property | State | Gets or sets the parsing state for the this ICommandFrame.
Top
See Also

Reference

ICommandFrame Interface
GSF.PhasorProtocols Namespace


ICommandFrame.State Property

Grid Solutions Framework ICommandFrameState Property
Gets or sets the parsing state for the this ICommandFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ICommandFrameParsingState State { get; set; }
Property State As ICommandFrameParsingState
    Get
    Set
abstract State : ICommandFrameParsingState with get, set

function get_State();
function set_State(value);
property ICommandFrameParsingState^ State {
    ICommandFrameParsingState^ get ();
    void set (ICommandFrameParsingState^ value);
}

Property Value

Type: ICommandFrameParsingState
See Also

Reference

ICommandFrame Interface
State Overload
GSF.PhasorProtocols Namespace


ICommandFrameParsingState Interface

Grid Solutions Framework ICommandFrameParsingState Interface
Represents a protocol independent interface representation of the parsing state of a ICommandFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ICommandFrameParsingState : IChannelFrameParsingState<ICommandCell>,
    IChannelParsingState
Public Interface ICommandFrameParsingState
    Inherits IChannelFrameParsingState(Of ICommandCell), IChannelParsingState
type ICommandFrameParsingState =
    interface
        interface IChannelFrameParsingState<ICommandCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.ICommandFrameParsingState = function();
GSF.PhasorProtocols.ICommandFrameParsingState.createInterface('GSF.PhasorProtocols.ICommandFrameParsingState');
public interface class ICommandFrameParsingState : IChannelFrameParsingState<ICommandCell^>,
    IChannelParsingState

The ICommandFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


ICommandFrameParsingState Properties

Grid Solutions Framework ICommandFrameParsingState Properties

The ICommandFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

ICommandFrameParsingState Interface
GSF.PhasorProtocols Namespace


IConfigurationCell Interface

Grid Solutions Framework IConfigurationCell Interface
Represents a protocol independent interface representation of any kind of IConfigurationFrame cell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IConfigurationCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IConfigurationCell>,
    IComparable<IConfigurationCell>, IComparable
Public Interface IConfigurationCell
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable(Of IConfigurationCell), IComparable(Of IConfigurationCell), IComparable
type IConfigurationCell =
    interface
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IConfigurationCell>
        interface IComparable<IConfigurationCell>
        interface IComparable
    end
GSF.PhasorProtocols.IConfigurationCell = function();
GSF.PhasorProtocols.IConfigurationCell.createInterface('GSF.PhasorProtocols.IConfigurationCell');
public interface class IConfigurationCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IConfigurationCell^>,
    IComparable<IConfigurationCell^>, IComparable

The IConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IConfigurationCell.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IConfigurationCell.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this IConfigurationCell.
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this IConfigurationCell.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this IConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this IConfigurationCell.
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this IConfigurationCell.
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this IConfigurationCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | IDLabel | Gets or sets the ID label of this IConfigurationCell.
Public property | IDLabelImage | Gets the binary image of the IDLabel of this IConfigurationCell.
Public property | IDLabelLength | Gets the length of the IDLabel of this IConfigurationCell.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this IConfigurationCell.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this IConfigurationCell.
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IConfigurationFrame for this IConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this IConfigurationCell.
Public property | RevisionCount | Gets or sets the revision count of this IConfigurationCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | State | Gets or sets the parsing state for the this IConfigurationCell.
Public property | StationName | Gets or sets the station name of this IConfigurationCell.
Public property | StationNameImage | Gets the binary image of the StationName of this IConfigurationCell.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IConfigurationCell Methods

Grid Solutions Framework IConfigurationCell Methods

The IConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IConfigurationCell .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IConfigurationCell .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell Properties

Grid Solutions Framework IConfigurationCell Properties

The IConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this IConfigurationCell.
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this IConfigurationCell.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this IConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this IConfigurationCell.
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this IConfigurationCell.
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this IConfigurationCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | IDLabel | Gets or sets the ID label of this IConfigurationCell.
Public property | IDLabelImage | Gets the binary image of the IDLabel of this IConfigurationCell.
Public property | IDLabelLength | Gets the length of the IDLabel of this IConfigurationCell.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this IConfigurationCell.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this IConfigurationCell.
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IConfigurationFrame for this IConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this IConfigurationCell.
Public property | RevisionCount | Gets or sets the revision count of this IConfigurationCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | State | Gets or sets the parsing state for the this IConfigurationCell.
Public property | StationName | Gets or sets the station name of this IConfigurationCell.
Public property | StationNameImage | Gets the binary image of the StationName of this IConfigurationCell.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework IConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataFormat AnalogDataFormat { get; set; }
Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set

function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
property DataFormat AnalogDataFormat {
    DataFormat get ();
    void set (DataFormat value);
}

Property Value

Type: DataFormat
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.AnalogDefinitions Property

Grid Solutions Framework IConfigurationCellAnalogDefinitions Property
Gets a reference to the AnalogDefinitionCollection of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
AnalogDefinitionCollection AnalogDefinitions { get; }
ReadOnly Property AnalogDefinitions As AnalogDefinitionCollection
    Get
abstract AnalogDefinitions : AnalogDefinitionCollection with get

function get_AnalogDefinitions();

property AnalogDefinitionCollection^ AnalogDefinitions {
    AnalogDefinitionCollection^ get ();
}

Property Value

Type: AnalogDefinitionCollection
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.DigitalDefinitions Property

Grid Solutions Framework IConfigurationCellDigitalDefinitions Property
Gets a reference to the DigitalDefinitionCollection of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DigitalDefinitionCollection DigitalDefinitions { get; }
ReadOnly Property DigitalDefinitions As DigitalDefinitionCollection
    Get
abstract DigitalDefinitions : DigitalDefinitionCollection with get

function get_DigitalDefinitions();

property DigitalDefinitionCollection^ DigitalDefinitions {
    DigitalDefinitionCollection^ get ();
}

Property Value

Type: DigitalDefinitionCollection
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.FrameRate Property

Grid Solutions Framework IConfigurationCellFrameRate Property
Gets the specified frame rate of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ushort FrameRate { get; }
ReadOnly Property FrameRate As UShort
    Get
abstract FrameRate : uint16 with get

function get_FrameRate();

property unsigned short FrameRate {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework IConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataFormat FrequencyDataFormat { get; set; }
Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set

function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
property DataFormat FrequencyDataFormat {
    DataFormat get ();
    void set (DataFormat value);
}

Property Value

Type: DataFormat
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.FrequencyDefinition Property

Grid Solutions Framework IConfigurationCellFrequencyDefinition Property
Gets or sets the IFrequencyDefinition of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IFrequencyDefinition FrequencyDefinition { get; set; }
Property FrequencyDefinition As IFrequencyDefinition
    Get
    Set
abstract FrequencyDefinition : IFrequencyDefinition with get, set

function get_FrequencyDefinition();
function set_FrequencyDefinition(value);
property IFrequencyDefinition^ FrequencyDefinition {
    IFrequencyDefinition^ get ();
    void set (IFrequencyDefinition^ value);
}

Property Value

Type: IFrequencyDefinition
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.IDLabel Property

Grid Solutions Framework IConfigurationCellIDLabel Property
Gets or sets the ID label of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string IDLabel { get; set; }
Property IDLabel As String
    Get
    Set
abstract IDLabel : string with get, set

function get_IDLabel();
function set_IDLabel(value);
property String^ IDLabel {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.IDLabelImage Property

Grid Solutions Framework IConfigurationCellIDLabelImage Property
Gets the binary image of the IDLabel of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] IDLabelImage { get; }
ReadOnly Property IDLabelImage As Byte()
    Get
abstract IDLabelImage : byte[] with get

function get_IDLabelImage();

property array<unsigned char>^ IDLabelImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.IDLabelLength Property

Grid Solutions Framework IConfigurationCellIDLabelLength Property
Gets the length of the IDLabel of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int IDLabelLength { get; }
ReadOnly Property IDLabelLength As Integer
    Get
abstract IDLabelLength : int with get

function get_IDLabelLength();

property int IDLabelLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.MaximumStationNameLength Property

Grid Solutions Framework IConfigurationCellMaximumStationNameLength Property
Gets the maximum length of the StationName of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int MaximumStationNameLength { get; }
ReadOnly Property MaximumStationNameLength As Integer
    Get
abstract MaximumStationNameLength : int with get

function get_MaximumStationNameLength();

property int MaximumStationNameLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.NominalFrequency Property

Grid Solutions Framework IConfigurationCellNominalFrequency Property
Gets or sets the nominal LineFrequency of the FrequencyDefinition of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
LineFrequency NominalFrequency { get; set; }
Property NominalFrequency As LineFrequency
    Get
    Set
abstract NominalFrequency : LineFrequency with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}

Property Value

Type: LineFrequency
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.Parent Property

Grid Solutions Framework IConfigurationCellParent Property
Overload List
 | Name | Description
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IConfigurationFrame for this IConfigurationCell.
Top
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.Parent Property

Grid Solutions Framework IConfigurationCellParent Property
Gets a reference to the parent IConfigurationFrame for this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationFrame Parent { get; set; }
Property Parent As IConfigurationFrame
    Get
    Set
abstract Parent : IConfigurationFrame with get, set

function get_Parent();
function set_Parent(value);
property IConfigurationFrame^ Parent {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}

Property Value

Type: IConfigurationFrame
See Also

Reference

IConfigurationCell Interface
Parent Overload
GSF.PhasorProtocols Namespace


IConfigurationCell.PhasorAngleFormat Property

Grid Solutions Framework IConfigurationCellPhasorAngleFormat Property
Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
AngleFormat PhasorAngleFormat { get; set; }
Property PhasorAngleFormat As AngleFormat
    Get
    Set
abstract PhasorAngleFormat : AngleFormat with get, set

function get_PhasorAngleFormat();
function set_PhasorAngleFormat(value);
property AngleFormat PhasorAngleFormat {
    AngleFormat get ();
    void set (AngleFormat value);
}

Property Value

Type: AngleFormat
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework IConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CoordinateFormat PhasorCoordinateFormat { get; set; }
Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set

function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get ();
    void set (CoordinateFormat value);
}

Property Value

Type: CoordinateFormat
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework IConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataFormat PhasorDataFormat { get; set; }
Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set

function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
property DataFormat PhasorDataFormat {
    DataFormat get ();
    void set (DataFormat value);
}

Property Value

Type: DataFormat
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.PhasorDefinitions Property

Grid Solutions Framework IConfigurationCellPhasorDefinitions Property
Gets a reference to the PhasorDefinitionCollection of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
PhasorDefinitionCollection PhasorDefinitions { get; }
ReadOnly Property PhasorDefinitions As PhasorDefinitionCollection
    Get
abstract PhasorDefinitions : PhasorDefinitionCollection with get

function get_PhasorDefinitions();

property PhasorDefinitionCollection^ PhasorDefinitions {
    PhasorDefinitionCollection^ get ();
}

Property Value

Type: PhasorDefinitionCollection
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.RevisionCount Property

Grid Solutions Framework IConfigurationCellRevisionCount Property
Gets or sets the revision count of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ushort RevisionCount { get; set; }
Property RevisionCount As UShort
    Get
    Set
abstract RevisionCount : uint16 with get, set

function get_RevisionCount();
function set_RevisionCount(value);
property unsigned short RevisionCount {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.State Property

Grid Solutions Framework IConfigurationCellState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | State | Gets or sets the parsing state for the this IConfigurationCell.
Top
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.State Property

Grid Solutions Framework IConfigurationCellState Property
Gets or sets the parsing state for the this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationCellParsingState State { get; set; }
Property State As IConfigurationCellParsingState
    Get
    Set
abstract State : IConfigurationCellParsingState with get, set

function get_State();
function set_State(value);
property IConfigurationCellParsingState^ State {
    IConfigurationCellParsingState^ get ();
    void set (IConfigurationCellParsingState^ value);
}

Property Value

Type: IConfigurationCellParsingState
See Also

Reference

IConfigurationCell Interface
State Overload
GSF.PhasorProtocols Namespace


IConfigurationCell.StationName Property

Grid Solutions Framework IConfigurationCellStationName Property
Gets or sets the station name of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string StationName { get; set; }
Property StationName As String
    Get
    Set
abstract StationName : string with get, set

function get_StationName();
function set_StationName(value);
property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCell.StationNameImage Property

Grid Solutions Framework IConfigurationCellStationNameImage Property
Gets the binary image of the StationName of this IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte[] StationNameImage { get; }
ReadOnly Property StationNameImage As Byte()
    Get
abstract StationNameImage : byte[] with get

function get_StationNameImage();

property array<unsigned char>^ StationNameImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

IConfigurationCell Interface
GSF.PhasorProtocols Namespace


IConfigurationCellParsingState Interface

Grid Solutions Framework IConfigurationCellParsingState Interface
Represents a protocol independent interface representation of the parsing state of any kind of IConfigurationCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IConfigurationCellParsingState : IChannelCellParsingState,
    IChannelParsingState
Public Interface IConfigurationCellParsingState
    Inherits IChannelCellParsingState, IChannelParsingState
type IConfigurationCellParsingState =
    interface
        interface IChannelCellParsingState
        interface IChannelParsingState
    end
GSF.PhasorProtocols.IConfigurationCellParsingState = function();
GSF.PhasorProtocols.IConfigurationCellParsingState.createInterface('GSF.PhasorProtocols.IConfigurationCellParsingState');
public interface class IConfigurationCellParsingState : IChannelCellParsingState,
    IChannelParsingState

The IConfigurationCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | CreateNewAnalogDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IAnalogDefinition objects.
Public property | CreateNewDigitalDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IDigitalDefinition objects.
Public property | CreateNewFrequencyDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IFrequencyDefinition objects.
Public property | CreateNewPhasorDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IPhasorDefinition objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IConfigurationCellParsingState Properties

Grid Solutions Framework IConfigurationCellParsingState Properties

The IConfigurationCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | CreateNewAnalogDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IAnalogDefinition objects.
Public property | CreateNewDigitalDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IDigitalDefinition objects.
Public property | CreateNewFrequencyDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IFrequencyDefinition objects.
Public property | CreateNewPhasorDefinition | Gets reference to CreateNewDefinitionFunctionT delegate used to create new IPhasorDefinition objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Top
See Also

Reference

IConfigurationCellParsingState Interface
GSF.PhasorProtocols Namespace


IConfigurationCellParsingState.CreateNewAnalogDefinition Property

Grid Solutions Framework IConfigurationCellParsingStateCreateNewAnalogDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IAnalogDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewDefinitionFunction<IAnalogDefinition> CreateNewAnalogDefinition { get; }
ReadOnly Property CreateNewAnalogDefinition As CreateNewDefinitionFunction(Of IAnalogDefinition)
    Get
abstract CreateNewAnalogDefinition : CreateNewDefinitionFunction<IAnalogDefinition> with get

function get_CreateNewAnalogDefinition();

property CreateNewDefinitionFunction<IAnalogDefinition^>^ CreateNewAnalogDefinition {
    CreateNewDefinitionFunction<IAnalogDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IAnalogDefinition
See Also

Reference

IConfigurationCellParsingState Interface
GSF.PhasorProtocols Namespace


IConfigurationCellParsingState.CreateNewDigitalDefinition Property

Grid Solutions Framework IConfigurationCellParsingStateCreateNewDigitalDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IDigitalDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewDefinitionFunction<IDigitalDefinition> CreateNewDigitalDefinition { get; }
ReadOnly Property CreateNewDigitalDefinition As CreateNewDefinitionFunction(Of IDigitalDefinition)
    Get
abstract CreateNewDigitalDefinition : CreateNewDefinitionFunction<IDigitalDefinition> with get

function get_CreateNewDigitalDefinition();

property CreateNewDefinitionFunction<IDigitalDefinition^>^ CreateNewDigitalDefinition {
    CreateNewDefinitionFunction<IDigitalDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IDigitalDefinition
See Also

Reference

IConfigurationCellParsingState Interface
GSF.PhasorProtocols Namespace


IConfigurationCellParsingState.CreateNewFrequencyDefinition Property

Grid Solutions Framework IConfigurationCellParsingStateCreateNewFrequencyDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IFrequencyDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewDefinitionFunction<IFrequencyDefinition> CreateNewFrequencyDefinition { get; }
ReadOnly Property CreateNewFrequencyDefinition As CreateNewDefinitionFunction(Of IFrequencyDefinition)
    Get
abstract CreateNewFrequencyDefinition : CreateNewDefinitionFunction<IFrequencyDefinition> with get

function get_CreateNewFrequencyDefinition();

property CreateNewDefinitionFunction<IFrequencyDefinition^>^ CreateNewFrequencyDefinition {
    CreateNewDefinitionFunction<IFrequencyDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IFrequencyDefinition
See Also

Reference

IConfigurationCellParsingState Interface
GSF.PhasorProtocols Namespace


IConfigurationCellParsingState.CreateNewPhasorDefinition Property

Grid Solutions Framework IConfigurationCellParsingStateCreateNewPhasorDefinition Property
Gets reference to CreateNewDefinitionFunctionT delegate used to create new IPhasorDefinition objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewDefinitionFunction<IPhasorDefinition> CreateNewPhasorDefinition { get; }
ReadOnly Property CreateNewPhasorDefinition As CreateNewDefinitionFunction(Of IPhasorDefinition)
    Get
abstract CreateNewPhasorDefinition : CreateNewDefinitionFunction<IPhasorDefinition> with get

function get_CreateNewPhasorDefinition();

property CreateNewDefinitionFunction<IPhasorDefinition^>^ CreateNewPhasorDefinition {
    CreateNewDefinitionFunction<IPhasorDefinition^>^ get ();
}

Property Value

Type: CreateNewDefinitionFunction IPhasorDefinition
See Also

Reference

IConfigurationCellParsingState Interface
GSF.PhasorProtocols Namespace


IConfigurationFrame Interface

Grid Solutions Framework IConfigurationFrame Interface
Represents a protocol independent interface representation of any kind of configuration frame that contains a collection of IConfigurationCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IConfigurationFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface IConfigurationFrame
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,
    ISerializable
type IConfigurationFrame =
    interface
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.IConfigurationFrame = function();
GSF.PhasorProtocols.IConfigurationFrame.createInterface('GSF.PhasorProtocols.IConfigurationFrame');
public interface class IConfigurationFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable

The IConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this IConfigurationFrame.
Public property | FrameRate | Gets or sets defined frame rate of this IConfigurationFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this IConfigurationFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this IConfigurationFrame.
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IConfigurationFrame Methods

Grid Solutions Framework IConfigurationFrame Methods

The IConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IConfigurationFrame Interface
GSF.PhasorProtocols Namespace


IConfigurationFrame.SetNominalFrequency Method

Grid Solutions Framework IConfigurationFrameSetNominalFrequency Method
Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
void SetNominalFrequency(
    LineFrequency value
)
Sub SetNominalFrequency (
    value As LineFrequency
)
abstract SetNominalFrequency :
        value : LineFrequency -> unit

function SetNominalFrequency(value);
void SetNominalFrequency(
    LineFrequency value
)

Parameters

value
Type: GSF.Units.EELineFrequency
New nominal LineFrequency for IFrequencyDefinition elements.
See Also

Reference

IConfigurationFrame Interface
GSF.PhasorProtocols Namespace


IConfigurationFrame Properties

Grid Solutions Framework IConfigurationFrame Properties

The IConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this IConfigurationFrame.
Public property | FrameRate | Gets or sets defined frame rate of this IConfigurationFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this IConfigurationFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this IConfigurationFrame.
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

IConfigurationFrame Interface
GSF.PhasorProtocols Namespace


IConfigurationFrame.Cells Property

Grid Solutions Framework IConfigurationFrameCells Property
Overload List
 | Name | Description
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this IConfigurationFrame.
Top
See Also

Reference

IConfigurationFrame Interface
GSF.PhasorProtocols Namespace


IConfigurationFrame.Cells Property

Grid Solutions Framework IConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this IConfigurationFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ConfigurationCellCollection Cells { get; }
ReadOnly Property Cells As ConfigurationCellCollection
    Get
abstract Cells : ConfigurationCellCollection with get

function get_Cells();

property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

IConfigurationFrame Interface
Cells Overload
GSF.PhasorProtocols Namespace


IConfigurationFrame.FrameRate Property

Grid Solutions Framework IConfigurationFrameFrameRate Property
Gets or sets defined frame rate of this IConfigurationFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ushort FrameRate { get; set; }
Property FrameRate As UShort
    Get
    Set
abstract FrameRate : uint16 with get, set

function get_FrameRate();
function set_FrameRate(value);
property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

IConfigurationFrame Interface
GSF.PhasorProtocols Namespace


IConfigurationFrame.State Property

Grid Solutions Framework IConfigurationFrameState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this IConfigurationFrame.
Top
See Also

Reference

IConfigurationFrame Interface
GSF.PhasorProtocols Namespace


IConfigurationFrame.State Property

Grid Solutions Framework IConfigurationFrameState Property
Gets or sets the parsing state for the this IConfigurationFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationFrameParsingState State { get; set; }
Property State As IConfigurationFrameParsingState
    Get
    Set
abstract State : IConfigurationFrameParsingState with get, set

function get_State();
function set_State(value);
property IConfigurationFrameParsingState^ State {
    IConfigurationFrameParsingState^ get ();
    void set (IConfigurationFrameParsingState^ value);
}

Property Value

Type: IConfigurationFrameParsingState
See Also

Reference

IConfigurationFrame Interface
State Overload
GSF.PhasorProtocols Namespace


IConfigurationFrame.TicksPerFrame Property

Grid Solutions Framework IConfigurationFrameTicksPerFrame Property
Gets the defined Ticks per frame of this IConfigurationFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
decimal TicksPerFrame { get; }
ReadOnly Property TicksPerFrame As Decimal
    Get
abstract TicksPerFrame : decimal with get

function get_TicksPerFrame();

property Decimal TicksPerFrame {
    Decimal get ();
}

Property Value

Type: Decimal
See Also

Reference

IConfigurationFrame Interface
GSF.PhasorProtocols Namespace


IConfigurationFrameParsingState Interface

Grid Solutions Framework IConfigurationFrameParsingState Interface
Represents a protocol independent interface representation of the parsing state of a IConfigurationFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IConfigurationFrameParsingState : IChannelFrameParsingState<IConfigurationCell>,
    IChannelParsingState
Public Interface IConfigurationFrameParsingState
    Inherits IChannelFrameParsingState(Of IConfigurationCell), IChannelParsingState
type IConfigurationFrameParsingState =
    interface
        interface IChannelFrameParsingState<IConfigurationCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.IConfigurationFrameParsingState = function();
GSF.PhasorProtocols.IConfigurationFrameParsingState.createInterface('GSF.PhasorProtocols.IConfigurationFrameParsingState');
public interface class IConfigurationFrameParsingState : IChannelFrameParsingState<IConfigurationCell^>,
    IChannelParsingState

The IConfigurationFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IConfigurationFrameParsingState Properties

Grid Solutions Framework IConfigurationFrameParsingState Properties

The IConfigurationFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

IConfigurationFrameParsingState Interface
GSF.PhasorProtocols Namespace


IConnectionParameters Interface

Grid Solutions Framework IConnectionParameters Interface
Represents a protocol independent interface representation of custom connection parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IConnectionParameters : ISerializable
Public Interface IConnectionParameters
    Inherits ISerializable
type IConnectionParameters =
    interface
        interface ISerializable
    end
GSF.PhasorProtocols.IConnectionParameters = function();
GSF.PhasorProtocols.IConnectionParameters.createInterface('GSF.PhasorProtocols.IConnectionParameters');
public interface class IConnectionParameters : ISerializable

The IConnectionParameters type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
Properties
 | Name | Description
Public property | ValuesAreValid | Determines if custom connection parameters are valid.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IConnectionParameters Methods

Grid Solutions Framework IConnectionParameters Methods

The IConnectionParameters type exposes the following members.

Methods
 | Name | Description
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Top
See Also

Reference

IConnectionParameters Interface
GSF.PhasorProtocols Namespace


IConnectionParameters Properties

Grid Solutions Framework IConnectionParameters Properties

The IConnectionParameters type exposes the following members.

Properties
 | Name | Description
Public property | ValuesAreValid | Determines if custom connection parameters are valid.
Top
See Also

Reference

IConnectionParameters Interface
GSF.PhasorProtocols Namespace


IConnectionParameters.ValuesAreValid Property

Grid Solutions Framework IConnectionParametersValuesAreValid Property
Determines if custom connection parameters are valid.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool ValuesAreValid { get; }
ReadOnly Property ValuesAreValid As Boolean
    Get
abstract ValuesAreValid : bool with get

function get_ValuesAreValid();

property bool ValuesAreValid {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IConnectionParameters Interface
GSF.PhasorProtocols Namespace


IDataCell Interface

Grid Solutions Framework IDataCell Interface
Represents a protocol independent interface representation of any kind of IDataFrame cell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDataCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IDataCell
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable
type IDataCell =
    interface
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.IDataCell = function();
GSF.PhasorProtocols.IDataCell.createInterface('GSF.PhasorProtocols.IDataCell');
public interface class IDataCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable

The IDataCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | GetStatusFlagsMeasurement | Gets the status flags of the IDataCell as a measurement value.
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this IDataCell have been assigned.
Public property | AnalogValues | Gets AnalogValueCollectionof this IDataCell.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonStatusFlags | Gets or sets command status flags of this IDataCell.
Public property | ConfigurationCell | Gets or sets IConfigurationCell associated with this IDataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this IDataCell is valid.
Public property | DataSortingType | Gets or sets DataSortingType of this IDataCell.
Public property | DeviceError | Gets or sets flag that determines if source device of this IDataCell is reporting an error.
Public property | DigitalValues | Gets DigitalValueCollectionof this IDataCell.
Public property | FrequencyValue | Gets IFrequencyValue of this IDataCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | IDLabel | Gets ID label of this IDataCell.
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets reference to parent IDataFrame of this IDataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this IDataCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | State | Gets or sets the parsing state for the this IDataCell.
Public property | StationName | Gets station name of this IDataCell.
Public property | StatusFlags | Gets or sets 16-bit status flags of this IDataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this IDataCell is valid based on GPS lock.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
Remarks
This phasor protocol implementation defines a "cell" as a portion of a "frame", i.e., a logical unit of data. For example, a IDataCell could be defined as a PMU within a IDataFrame that contains multiple PMU's coming from a PDC.
See Also

Reference

GSF.PhasorProtocols Namespace


IDataCell Methods

Grid Solutions Framework IDataCell Methods

The IDataCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | GetStatusFlagsMeasurement | Gets the status flags of the IDataCell as a measurement value.
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.GetStatusFlagsMeasurement Method

Grid Solutions Framework IDataCellGetStatusFlagsMeasurement Method
Gets the status flags of the IDataCell as a measurement value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IMeasurement GetStatusFlagsMeasurement()
Function GetStatusFlagsMeasurement As IMeasurement
abstract GetStatusFlagsMeasurement : unit -> IMeasurement

function GetStatusFlagsMeasurement();
IMeasurement^ GetStatusFlagsMeasurement()

Return Value

Type: IMeasurement
Status flags of the IDataCell as a measurement value.
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell Properties

Grid Solutions Framework IDataCell Properties

The IDataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this IDataCell have been assigned.
Public property | AnalogValues | Gets AnalogValueCollectionof this IDataCell.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CommonStatusFlags | Gets or sets command status flags of this IDataCell.
Public property | ConfigurationCell | Gets or sets IConfigurationCell associated with this IDataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this IDataCell is valid.
Public property | DataSortingType | Gets or sets DataSortingType of this IDataCell.
Public property | DeviceError | Gets or sets flag that determines if source device of this IDataCell is reporting an error.
Public property | DigitalValues | Gets DigitalValueCollectionof this IDataCell.
Public property | FrequencyValue | Gets IFrequencyValue of this IDataCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | IDLabel | Gets ID label of this IDataCell.
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets reference to parent IDataFrame of this IDataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this IDataCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | State | Gets or sets the parsing state for the this IDataCell.
Public property | StationName | Gets station name of this IDataCell.
Public property | StatusFlags | Gets or sets 16-bit status flags of this IDataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this IDataCell is valid based on GPS lock.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.AllValuesAssigned Property

Grid Solutions Framework IDataCellAllValuesAssigned Property
Gets flag that determines if all values of this IDataCell have been assigned.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool AllValuesAssigned { get; }
ReadOnly Property AllValuesAssigned As Boolean
    Get
abstract AllValuesAssigned : bool with get

function get_AllValuesAssigned();

property bool AllValuesAssigned {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.AnalogValues Property

Grid Solutions Framework IDataCellAnalogValues Property
Gets AnalogValueCollectionof this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
AnalogValueCollection AnalogValues { get; }
ReadOnly Property AnalogValues As AnalogValueCollection
    Get
abstract AnalogValues : AnalogValueCollection with get

function get_AnalogValues();

property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get ();
}

Property Value

Type: AnalogValueCollection
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.CommonStatusFlags Property

Grid Solutions Framework IDataCellCommonStatusFlags Property
Gets or sets command status flags of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
uint CommonStatusFlags { get; set; }
Property CommonStatusFlags As UInteger
    Get
    Set
abstract CommonStatusFlags : uint32 with get, set

function get_CommonStatusFlags();
function set_CommonStatusFlags(value);
property unsigned int CommonStatusFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.ConfigurationCell Property

Grid Solutions Framework IDataCellConfigurationCell Property
Gets or sets IConfigurationCell associated with this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationCell ConfigurationCell { get; set; }
Property ConfigurationCell As IConfigurationCell
    Get
    Set
abstract ConfigurationCell : IConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
    void set (IConfigurationCell^ value);
}

Property Value

Type: IConfigurationCell
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.DataIsValid Property

Grid Solutions Framework IDataCellDataIsValid Property
Gets or sets flag that determines if data of this IDataCell is valid.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool DataIsValid { get; set; }
Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set

function get_DataIsValid();
function set_DataIsValid(value);
property bool DataIsValid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.DataSortingType Property

Grid Solutions Framework IDataCellDataSortingType Property
Gets or sets DataSortingType of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataSortingType DataSortingType { get; set; }
Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set

function get_DataSortingType();
function set_DataSortingType(value);
property DataSortingType DataSortingType {
    DataSortingType get ();
    void set (DataSortingType value);
}

Property Value

Type: DataSortingType
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.DeviceError Property

Grid Solutions Framework IDataCellDeviceError Property
Gets or sets flag that determines if source device of this IDataCell is reporting an error.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool DeviceError { get; set; }
Property DeviceError As Boolean
    Get
    Set
abstract DeviceError : bool with get, set

function get_DeviceError();
function set_DeviceError(value);
property bool DeviceError {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.DigitalValues Property

Grid Solutions Framework IDataCellDigitalValues Property
Gets DigitalValueCollectionof this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DigitalValueCollection DigitalValues { get; }
ReadOnly Property DigitalValues As DigitalValueCollection
    Get
abstract DigitalValues : DigitalValueCollection with get

function get_DigitalValues();

property DigitalValueCollection^ DigitalValues {
    DigitalValueCollection^ get ();
}

Property Value

Type: DigitalValueCollection
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.FrequencyValue Property

Grid Solutions Framework IDataCellFrequencyValue Property
Gets IFrequencyValue of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IFrequencyValue FrequencyValue { get; set; }
Property FrequencyValue As IFrequencyValue
    Get
    Set
abstract FrequencyValue : IFrequencyValue with get, set

function get_FrequencyValue();
function set_FrequencyValue(value);
property IFrequencyValue^ FrequencyValue {
    IFrequencyValue^ get ();
    void set (IFrequencyValue^ value);
}

Property Value

Type: IFrequencyValue
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.IDLabel Property

Grid Solutions Framework IDataCellIDLabel Property
Gets ID label of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string IDLabel { get; }
ReadOnly Property IDLabel As String
    Get
abstract IDLabel : string with get

function get_IDLabel();

property String^ IDLabel {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.Parent Property

Grid Solutions Framework IDataCellParent Property
Overload List
 | Name | Description
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets reference to parent IDataFrame of this IDataCell.
Top
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.Parent Property

Grid Solutions Framework IDataCellParent Property
Gets reference to parent IDataFrame of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IDataFrame Parent { get; set; }
Property Parent As IDataFrame
    Get
    Set
abstract Parent : IDataFrame with get, set

function get_Parent();
function set_Parent(value);
property IDataFrame^ Parent {
    IDataFrame^ get ();
    void set (IDataFrame^ value);
}

Property Value

Type: IDataFrame
See Also

Reference

IDataCell Interface
Parent Overload
GSF.PhasorProtocols Namespace


IDataCell.PhasorValues Property

Grid Solutions Framework IDataCellPhasorValues Property
Gets PhasorValueCollection of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
PhasorValueCollection PhasorValues { get; }
ReadOnly Property PhasorValues As PhasorValueCollection
    Get
abstract PhasorValues : PhasorValueCollection with get

function get_PhasorValues();

property PhasorValueCollection^ PhasorValues {
    PhasorValueCollection^ get ();
}

Property Value

Type: PhasorValueCollection
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.State Property

Grid Solutions Framework IDataCellState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | State | Gets or sets the parsing state for the this IDataCell.
Top
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.State Property

Grid Solutions Framework IDataCellState Property
Gets or sets the parsing state for the this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IDataCellParsingState State { get; set; }
Property State As IDataCellParsingState
    Get
    Set
abstract State : IDataCellParsingState with get, set

function get_State();
function set_State(value);
property IDataCellParsingState^ State {
    IDataCellParsingState^ get ();
    void set (IDataCellParsingState^ value);
}

Property Value

Type: IDataCellParsingState
See Also

Reference

IDataCell Interface
State Overload
GSF.PhasorProtocols Namespace


IDataCell.StationName Property

Grid Solutions Framework IDataCellStationName Property
Gets station name of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string StationName { get; }
ReadOnly Property StationName As String
    Get
abstract StationName : string with get

function get_StationName();

property String^ StationName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.StatusFlags Property

Grid Solutions Framework IDataCellStatusFlags Property
Gets or sets 16-bit status flags of this IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ushort StatusFlags { get; set; }
Property StatusFlags As UShort
    Get
    Set
abstract StatusFlags : uint16 with get, set

function get_StatusFlags();
function set_StatusFlags(value);
property unsigned short StatusFlags {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCell.SynchronizationIsValid Property

Grid Solutions Framework IDataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this IDataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool SynchronizationIsValid { get; set; }
Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set

function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
property bool SynchronizationIsValid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IDataCell Interface
GSF.PhasorProtocols Namespace


IDataCellParsingState Interface

Grid Solutions Framework IDataCellParsingState Interface
Represents a protocol independent interface representation of the parsing state of any kind of IDataCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDataCellParsingState : IChannelCellParsingState,
    IChannelParsingState
Public Interface IDataCellParsingState
    Inherits IChannelCellParsingState, IChannelParsingState
type IDataCellParsingState =
    interface
        interface IChannelCellParsingState
        interface IChannelParsingState
    end
GSF.PhasorProtocols.IDataCellParsingState = function();
GSF.PhasorProtocols.IDataCellParsingState.createInterface('GSF.PhasorProtocols.IDataCellParsingState');
public interface class IDataCellParsingState : IChannelCellParsingState,
    IChannelParsingState

The IDataCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | ConfigurationCell | Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
Public property | CreateNewAnalogValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IAnalogValue objects.
Public property | CreateNewDigitalValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IDigitalValue objects.
Public property | CreateNewFrequencyValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IFrequencyValue objects.
Public property | CreateNewPhasorValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IPhasorValue objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IDataCellParsingState Properties

Grid Solutions Framework IDataCellParsingState Properties

The IDataCellParsingState type exposes the following members.

Properties
 | Name | Description
Public property | AnalogCount | Gets or sets the number of analog elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | ConfigurationCell | Gets reference to the IConfigurationCell associated with the IDataCell being parsed.
Public property | CreateNewAnalogValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IAnalogValue objects.
Public property | CreateNewDigitalValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IDigitalValue objects.
Public property | CreateNewFrequencyValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IFrequencyValue objects.
Public property | CreateNewPhasorValue | Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IPhasorValue objects.
Public property | DigitalCount | Gets or sets the number of digital elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | PhasorCount | Gets or sets the number of phasor elements associated with the IChannelCell being parsed. (Inherited from IChannelCellParsingState.)
Top
See Also

Reference

IDataCellParsingState Interface
GSF.PhasorProtocols Namespace


IDataCellParsingState.ConfigurationCell Property

Grid Solutions Framework IDataCellParsingStateConfigurationCell Property
Gets reference to the IConfigurationCell associated with the IDataCell being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationCell ConfigurationCell { get; }
ReadOnly Property ConfigurationCell As IConfigurationCell
    Get
abstract ConfigurationCell : IConfigurationCell with get

function get_ConfigurationCell();

property IConfigurationCell^ ConfigurationCell {
    IConfigurationCell^ get ();
}

Property Value

Type: IConfigurationCell
See Also

Reference

IDataCellParsingState Interface
GSF.PhasorProtocols Namespace


IDataCellParsingState.CreateNewAnalogValue Property

Grid Solutions Framework IDataCellParsingStateCreateNewAnalogValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IAnalogValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewValueFunction<IAnalogDefinition, IAnalogValue> CreateNewAnalogValue { get; }
ReadOnly Property CreateNewAnalogValue As CreateNewValueFunction(Of IAnalogDefinition, IAnalogValue)
    Get
abstract CreateNewAnalogValue : CreateNewValueFunction<IAnalogDefinition, IAnalogValue> with get

function get_CreateNewAnalogValue();

property CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ CreateNewAnalogValue {
    CreateNewValueFunction<IAnalogDefinition^, IAnalogValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IAnalogDefinition, IAnalogValue
See Also

Reference

IDataCellParsingState Interface
GSF.PhasorProtocols Namespace


IDataCellParsingState.CreateNewDigitalValue Property

Grid Solutions Framework IDataCellParsingStateCreateNewDigitalValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IDigitalValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewValueFunction<IDigitalDefinition, IDigitalValue> CreateNewDigitalValue { get; }
ReadOnly Property CreateNewDigitalValue As CreateNewValueFunction(Of IDigitalDefinition, IDigitalValue)
    Get
abstract CreateNewDigitalValue : CreateNewValueFunction<IDigitalDefinition, IDigitalValue> with get

function get_CreateNewDigitalValue();

property CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ CreateNewDigitalValue {
    CreateNewValueFunction<IDigitalDefinition^, IDigitalValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IDigitalDefinition, IDigitalValue
See Also

Reference

IDataCellParsingState Interface
GSF.PhasorProtocols Namespace


IDataCellParsingState.CreateNewFrequencyValue Property

Grid Solutions Framework IDataCellParsingStateCreateNewFrequencyValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IFrequencyValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> CreateNewFrequencyValue { get; }
ReadOnly Property CreateNewFrequencyValue As CreateNewValueFunction(Of IFrequencyDefinition, IFrequencyValue)
    Get
abstract CreateNewFrequencyValue : CreateNewValueFunction<IFrequencyDefinition, IFrequencyValue> with get

function get_CreateNewFrequencyValue();

property CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ CreateNewFrequencyValue {
    CreateNewValueFunction<IFrequencyDefinition^, IFrequencyValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IFrequencyDefinition, IFrequencyValue
See Also

Reference

IDataCellParsingState Interface
GSF.PhasorProtocols Namespace


IDataCellParsingState.CreateNewPhasorValue Property

Grid Solutions Framework IDataCellParsingStateCreateNewPhasorValue Property
Gets reference to CreateNewValueFunctionTDefinition, TValue delegate used to create new IPhasorValue objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CreateNewValueFunction<IPhasorDefinition, IPhasorValue> CreateNewPhasorValue { get; }
ReadOnly Property CreateNewPhasorValue As CreateNewValueFunction(Of IPhasorDefinition, IPhasorValue)
    Get
abstract CreateNewPhasorValue : CreateNewValueFunction<IPhasorDefinition, IPhasorValue> with get

function get_CreateNewPhasorValue();

property CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ CreateNewPhasorValue {
    CreateNewValueFunction<IPhasorDefinition^, IPhasorValue^>^ get ();
}

Property Value

Type: CreateNewValueFunction IPhasorDefinition, IPhasorValue
See Also

Reference

IDataCellParsingState Interface
GSF.PhasorProtocols Namespace


IDataFrame Interface

Grid Solutions Framework IDataFrame Interface
Represents a protocol independent interface representation of any kind of data frame that contains a collection of IDataCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDataFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface IDataFrame
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,
    ISerializable
type IDataFrame =
    interface
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.IDataFrame = function();
GSF.PhasorProtocols.IDataFrame.createInterface('GSF.PhasorProtocols.IDataFrame');
public interface class IDataFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable

The IDataFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | GetQualityFlagsMeasurement | Gets the quality flags of the IDataFrame as a measurement value.
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the DataCellCollection for this IDataFrame.
Public property | ConfigurationFrame | Gets or sets IConfigurationFrame associated with this IDataFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this IDataFrame.
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IDataFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IDataFrame Methods

Grid Solutions Framework IDataFrame Methods

The IDataFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | GetQualityFlagsMeasurement | Gets the quality flags of the IDataFrame as a measurement value.
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IDataFrame Interface
GSF.PhasorProtocols Namespace


IDataFrame.GetQualityFlagsMeasurement Method

Grid Solutions Framework IDataFrameGetQualityFlagsMeasurement Method
Gets the quality flags of the IDataFrame as a measurement value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IMeasurement GetQualityFlagsMeasurement()
Function GetQualityFlagsMeasurement As IMeasurement
abstract GetQualityFlagsMeasurement : unit -> IMeasurement

function GetQualityFlagsMeasurement();
IMeasurement^ GetQualityFlagsMeasurement()

Return Value

Type: IMeasurement
Quality flags of the IDataFrame as a measurement value.
See Also

Reference

IDataFrame Interface
GSF.PhasorProtocols Namespace


IDataFrame Properties

Grid Solutions Framework IDataFrame Properties

The IDataFrame type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the DataCellCollection for this IDataFrame.
Public property | ConfigurationFrame | Gets or sets IConfigurationFrame associated with this IDataFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this IDataFrame.
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IDataFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

IDataFrame Interface
GSF.PhasorProtocols Namespace


IDataFrame.Cells Property

Grid Solutions Framework IDataFrameCells Property
Overload List
 | Name | Description
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the DataCellCollection for this IDataFrame.
Top
See Also

Reference

IDataFrame Interface
GSF.PhasorProtocols Namespace


IDataFrame.Cells Property

Grid Solutions Framework IDataFrameCells Property
Gets reference to the DataCellCollection for this IDataFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataCellCollection Cells { get; }
ReadOnly Property Cells As DataCellCollection
    Get
abstract Cells : DataCellCollection with get

function get_Cells();

property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

IDataFrame Interface
Cells Overload
GSF.PhasorProtocols Namespace


IDataFrame.ConfigurationFrame Property

Grid Solutions Framework IDataFrameConfigurationFrame Property
Gets or sets IConfigurationFrame associated with this IDataFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationFrame ConfigurationFrame { get; set; }
Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}

Property Value

Type: IConfigurationFrame
See Also

Reference

IDataFrame Interface
GSF.PhasorProtocols Namespace


IDataFrame.QualityFlags Property

Grid Solutions Framework IDataFrameQualityFlags Property
Gets or sets protocol specific quality flags for this IDataFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
uint QualityFlags { get; set; }
Property QualityFlags As UInteger
    Get
    Set
abstract QualityFlags : uint32 with get, set

function get_QualityFlags();
function set_QualityFlags(value);
property unsigned int QualityFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

IDataFrame Interface
GSF.PhasorProtocols Namespace


IDataFrame.State Property

Grid Solutions Framework IDataFrameState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for this IDataFrame.
Top
See Also

Reference

IDataFrame Interface
GSF.PhasorProtocols Namespace


IDataFrame.State Property

Grid Solutions Framework IDataFrameState Property
Gets or sets the parsing state for this IDataFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IDataFrameParsingState State { get; set; }
Property State As IDataFrameParsingState
    Get
    Set
abstract State : IDataFrameParsingState with get, set

function get_State();
function set_State(value);
property IDataFrameParsingState^ State {
    IDataFrameParsingState^ get ();
    void set (IDataFrameParsingState^ value);
}

Property Value

Type: IDataFrameParsingState
See Also

Reference

IDataFrame Interface
State Overload
GSF.PhasorProtocols Namespace


IDataFrameParsingState Interface

Grid Solutions Framework IDataFrameParsingState Interface
Represents a protocol independent interface representation of the parsing state of a IDataFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDataFrameParsingState : IChannelFrameParsingState<IDataCell>,
    IChannelParsingState
Public Interface IDataFrameParsingState
    Inherits IChannelFrameParsingState(Of IDataCell), IChannelParsingState
type IDataFrameParsingState =
    interface
        interface IChannelFrameParsingState<IDataCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.IDataFrameParsingState = function();
GSF.PhasorProtocols.IDataFrameParsingState.createInterface('GSF.PhasorProtocols.IDataFrameParsingState');
public interface class IDataFrameParsingState : IChannelFrameParsingState<IDataCell^>,
    IChannelParsingState

The IDataFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | ConfigurationFrame | Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IDataFrameParsingState Properties

Grid Solutions Framework IDataFrameParsingState Properties

The IDataFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | ConfigurationFrame | Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

IDataFrameParsingState Interface
GSF.PhasorProtocols Namespace


IDataFrameParsingState.ConfigurationFrame Property

Grid Solutions Framework IDataFrameParsingStateConfigurationFrame Property
Gets reference to the IConfigurationFrame associated with the IDataFrame being parsed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationFrame ConfigurationFrame { get; }
ReadOnly Property ConfigurationFrame As IConfigurationFrame
    Get
abstract ConfigurationFrame : IConfigurationFrame with get

function get_ConfigurationFrame();

property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
}

Property Value

Type: IConfigurationFrame
See Also

Reference

IDataFrameParsingState Interface
GSF.PhasorProtocols Namespace


IDigitalDefinition Interface

Grid Solutions Framework IDigitalDefinition Interface
Represents a protocol independent interface representation of a definition of a IDigitalValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDigitalDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IDigitalDefinition
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
type IDigitalDefinition =
    interface
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.IDigitalDefinition = function();
GSF.PhasorProtocols.IDigitalDefinition.createInterface('GSF.PhasorProtocols.IDigitalDefinition');
public interface class IDigitalDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable

The IDigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IDigitalDefinition Methods

Grid Solutions Framework IDigitalDefinition Methods

The IDigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IDigitalDefinition Interface
GSF.PhasorProtocols Namespace


IDigitalDefinition Properties

Grid Solutions Framework IDigitalDefinition Properties

The IDigitalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IDigitalDefinition Interface
GSF.PhasorProtocols Namespace


IDigitalValue Interface

Grid Solutions Framework IDigitalValue Interface
Represents a protocol independent interface representation of a digital value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDigitalValue : IChannelValue<IDigitalDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IDigitalValue
    Inherits IChannelValue(Of IDigitalDefinition), IChannel, ISupportBinaryImage,
    ISerializable
type IDigitalValue =
    interface
        interface IChannelValue<IDigitalDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.IDigitalValue = function();
GSF.PhasorProtocols.IDigitalValue.createInterface('GSF.PhasorProtocols.IDigitalValue');
public interface class IDigitalValue : IChannelValue<IDigitalDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable

The IDigitalValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Value | Gets or sets the 16-bit integer value (composed of digital bits) that represents this IDigitalValue.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IDigitalValue Methods

Grid Solutions Framework IDigitalValue Methods

The IDigitalValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IDigitalValue Interface
GSF.PhasorProtocols Namespace


IDigitalValue Properties

Grid Solutions Framework IDigitalValue Properties

The IDigitalValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Value | Gets or sets the 16-bit integer value (composed of digital bits) that represents this IDigitalValue.
Top
See Also

Reference

IDigitalValue Interface
GSF.PhasorProtocols Namespace


IDigitalValue.Value Property

Grid Solutions Framework IDigitalValueValue Property
Gets or sets the 16-bit integer value (composed of digital bits) that represents this IDigitalValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
ushort Value { get; set; }
Property Value As UShort
    Get
    Set
abstract Value : uint16 with get, set

function get_Value();
function set_Value(value);
property unsigned short Value {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

IDigitalValue Interface
GSF.PhasorProtocols Namespace


IFrameParser Interface

Grid Solutions Framework IFrameParser Interface
Represents a protocol independent representation of a frame parser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IFrameParser : IProvideStatus,
    IDisposable
Public Interface IFrameParser
    Inherits IProvideStatus, IDisposable
type IFrameParser =
    interface
        interface IProvideStatus
        interface IDisposable
    end
GSF.PhasorProtocols.IFrameParser = function();
GSF.PhasorProtocols.IFrameParser.createInterface('GSF.PhasorProtocols.IFrameParser');
public interface class IFrameParser : IProvideStatus,
    IDisposable

The IFrameParser type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Parse | Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.
Public method | Start | Start the streaming data parser.
Public method | Stop | Stops the streaming data parser.
Top
Properties
 | Name | Description
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
Public property | QueuedOutputs | Gets the total number of frames that are currently queued for publication, if any.
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed.
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data.
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a IDataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received.
Public event | ReceivedFrameImage | Occurs when a frame image has been received.
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
Top
Remarks
This interface allows protocol specific frame parsers to be handled abstractly by the MultiProtocolFrameParser.
See Also

Reference

GSF.PhasorProtocols Namespace


IFrameParser Methods

Grid Solutions Framework IFrameParser Methods

The IFrameParser type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Parse | Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.
Public method | Start | Start the streaming data parser.
Public method | Stop | Stops the streaming data parser.
Top
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.Parse Method

Grid Solutions Framework IFrameParserParse Method
Writes a sequence of bytes onto the IBinaryImageParser stream for parsing.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Parse(
    SourceChannel source,
    byte[] buffer,
    int offset,
    int count
)
Sub Parse (
    source As SourceChannel,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Parse :
        source : SourceChannel *
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Parse(source, buffer, offset, count);
void Parse(
    SourceChannel source,
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

source
Type: GSF.PhasorProtocolsSourceChannel
Defines the source channel for the data.
buffer
Type: SystemByte
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: SystemInt32
The number of bytes to be written to the current stream.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.Start Method

Grid Solutions Framework IFrameParserStart Method
Start the streaming data parser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Start()
Sub Start
abstract Start : unit -> unit

function Start();
void Start()
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.Stop Method

Grid Solutions Framework IFrameParserStop Method
Stops the streaming data parser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Stop()
Sub Stop
abstract Stop : unit -> unit

function Stop();
void Stop()
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser Properties

Grid Solutions Framework IFrameParser Properties

The IFrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing.
Public property | Enabled | Gets or sets a boolean value that indicates whether the data parser is currently enabled.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
Public property | QueuedOutputs | Gets the total number of frames that are currently queued for publication, if any.
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Top
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.CheckSumValidationFrameTypes Property

Grid Solutions Framework IFrameParserCheckSumValidationFrameTypes Property
Gets or sets flags that determine if check-sums for specified frames should be validated.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CheckSumValidationFrameTypes CheckSumValidationFrameTypes { get; set; }
Property CheckSumValidationFrameTypes As CheckSumValidationFrameTypes
    Get
    Set
abstract CheckSumValidationFrameTypes : CheckSumValidationFrameTypes with get, set

function get_CheckSumValidationFrameTypes();
function set_CheckSumValidationFrameTypes(value);
property CheckSumValidationFrameTypes CheckSumValidationFrameTypes {
    CheckSumValidationFrameTypes get ();
    void set (CheckSumValidationFrameTypes value);
}

Property Value

Type: CheckSumValidationFrameTypes
Remarks
It is expected that this will normally be set to AllFrames.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ConfigurationFrame Property

Grid Solutions Framework IFrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConfigurationFrame ConfigurationFrame { get; set; }
Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get ();
    void set (IConfigurationFrame^ value);
}

Property Value

Type: IConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ConnectionParameters Property

Grid Solutions Framework IFrameParserConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IConnectionParameters ConnectionParameters { get; set; }
Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set

function get_ConnectionParameters();
function set_ConnectionParameters(value);
property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get ();
    void set (IConnectionParameters^ value);
}

Property Value

Type: IConnectionParameters
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.Enabled Property

Grid Solutions Framework IFrameParserEnabled Property
Gets or sets a boolean value that indicates whether the data parser is currently enabled.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Enabled { get; set; }
Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set

function get_Enabled();
function set_Enabled(value);
property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.QueuedBuffers Property

Grid Solutions Framework IFrameParserQueuedBuffers Property
Gets the total number of buffers that are currently queued for processing, if any.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int QueuedBuffers { get; }
ReadOnly Property QueuedBuffers As Integer
    Get
abstract QueuedBuffers : int with get

function get_QueuedBuffers();

property int QueuedBuffers {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.QueuedOutputs Property

Grid Solutions Framework IFrameParserQueuedOutputs Property
Gets the total number of frames that are currently queued for publication, if any.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int QueuedOutputs { get; }
ReadOnly Property QueuedOutputs As Integer
    Get
abstract QueuedOutputs : int with get

function get_QueuedOutputs();

property int QueuedOutputs {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.RedundantFramesPerPacket Property

Grid Solutions Framework IFrameParserRedundantFramesPerPacket Property
Gets the number of redundant frames in each packet.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int RedundantFramesPerPacket { get; }
ReadOnly Property RedundantFramesPerPacket As Integer
    Get
abstract RedundantFramesPerPacket : int with get

function get_RedundantFramesPerPacket();

property int RedundantFramesPerPacket {
    int get ();
}

Property Value

Type: Int32
Remarks
This value is used when calculating statistics. It is assumed that for each frame that is received, that frame will be included in the next n packets, where n is the number of redundant frames per packet.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.TrustHeaderLength Property

Grid Solutions Framework IFrameParserTrustHeaderLength Property
Gets or sets flag that determines if header lengths should be trusted over parsed byte count.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool TrustHeaderLength { get; set; }
Property TrustHeaderLength As Boolean
    Get
    Set
abstract TrustHeaderLength : bool with get, set

function get_TrustHeaderLength();
function set_TrustHeaderLength(value);
property bool TrustHeaderLength {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
It is expected that this will normally be left as true.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser Events

Grid Solutions Framework IFrameParser Events

The IFrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed.
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data.
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a IDataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received.
Public event | ReceivedFrameImage | Occurs when a frame image has been received.
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
Top
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.BufferParsed Event

Grid Solutions Framework IFrameParserBufferParsed Event
Occurs when buffer parsing has completed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler BufferParsed
Event BufferParsed As EventHandler
abstract BufferParsed : IEvent<EventHandler,
    EventArgs>

function add_BufferParsed(value);
function remove_BufferParsed(value);
 event EventHandler^ BufferParsed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ConfigurationChanged Event

Grid Solutions Framework IFrameParserConfigurationChanged Event
Occurs when a device sends a notification that its configuration has changed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ConfigurationChanged
Event ConfigurationChanged As EventHandler
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>

function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
 event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ParsingException Event

Grid Solutions Framework IFrameParserParsingException Event
Occurs when an Exception is encountered while attempting to parse data.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ParsingException
Event ParsingException As EventHandler(Of EventArgs(Of Exception))
abstract ParsingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ParsingException(value);
function remove_ParsingException(value);
 event EventHandler<EventArgs<Exception^>^>^ ParsingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the Exception encountered while parsing data.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ReceivedCommandFrame Event

Grid Solutions Framework IFrameParserReceivedCommandFrame Event
Occurs when a ICommandFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<ICommandFrame>> ReceivedCommandFrame
Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
abstract ReceivedCommandFrame : IEvent<EventHandler<EventArgs<ICommandFrame>>,
    EventArgs<ICommandFrame>>

function add_ReceivedCommandFrame(value);
function remove_ReceivedCommandFrame(value);
 event EventHandler<EventArgs<ICommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICommandFrame
Remarks
Argument is the ICommandFrame that was received.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework IFrameParserReceivedConfigurationFrame Event
Occurs when a IConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<IConfigurationFrame>> ReceivedConfigurationFrame
Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of IConfigurationFrame))
abstract ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<IConfigurationFrame>>,
    EventArgs<IConfigurationFrame>>

function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
 event EventHandler<EventArgs<IConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IConfigurationFrame
Remarks
Argument is the IConfigurationFrame that was received.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ReceivedDataFrame Event

Grid Solutions Framework IFrameParserReceivedDataFrame Event
Occurs when a IDataFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<IDataFrame>> ReceivedDataFrame
Event ReceivedDataFrame As EventHandler(Of EventArgs(Of IDataFrame))
abstract ReceivedDataFrame : IEvent<EventHandler<EventArgs<IDataFrame>>,
    EventArgs<IDataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
 event EventHandler<EventArgs<IDataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<IDataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IDataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IDataFrame
Remarks
Argument is the IDataFrame that was received.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ReceivedFrameBufferImage Event

Grid Solutions Framework IFrameParserReceivedFrameBufferImage Event
Occurs when a frame buffer image has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>> ReceivedFrameBufferImage
Event ReceivedFrameBufferImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Byte(), Integer, Integer))
abstract ReceivedFrameBufferImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>>,
    EventArgs<FundamentalFrameType, byte[], int, int>>

function add_ReceivedFrameBufferImage(value);
function remove_ReceivedFrameBufferImage(value);
 event EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ ReceivedFrameBufferImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FundamentalFrameType, Byte , Int32, Int32
Remarks

Argument1 is the FundamentalFrameType of the frame buffer image that was received.
Argument2 is the buffer that contains the frame image that was received.
Argument3 is the offset into the buffer that contains the frame image that was received.
Argument4 is the length of data in the buffer that contains the frame image that was received.

Consumers should use the more efficient ReceivedFrameImage event if the buffer is not needed.

See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ReceivedFrameImage Event

Grid Solutions Framework IFrameParserReceivedFrameImage Event
Occurs when a frame image has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<FundamentalFrameType, int>> ReceivedFrameImage
Event ReceivedFrameImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Integer))
abstract ReceivedFrameImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, int>>,
    EventArgs<FundamentalFrameType, int>>

function add_ReceivedFrameImage(value);
function remove_ReceivedFrameImage(value);
 event EventHandler<EventArgs<FundamentalFrameType, int>^>^ ReceivedFrameImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FundamentalFrameType, Int32
Remarks
Argument1 is the FundamentalFrameType of the frame buffer image that was received.
Argument2 is the length of the frame image that was received.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ReceivedHeaderFrame Event

Grid Solutions Framework IFrameParserReceivedHeaderFrame Event
Occurs when a IHeaderFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<IHeaderFrame>> ReceivedHeaderFrame
Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of IHeaderFrame))
abstract ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<IHeaderFrame>>,
    EventArgs<IHeaderFrame>>

function add_ReceivedHeaderFrame(value);
function remove_ReceivedHeaderFrame(value);
 event EventHandler<EventArgs<IHeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IHeaderFrame
Remarks
Argument is the IHeaderFrame that was received.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrameParser.ReceivedUndeterminedFrame Event

Grid Solutions Framework IFrameParserReceivedUndeterminedFrame Event
Occurs when an undetermined IChannelFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<IChannelFrame>> ReceivedUndeterminedFrame
Event ReceivedUndeterminedFrame As EventHandler(Of EventArgs(Of IChannelFrame))
abstract ReceivedUndeterminedFrame : IEvent<EventHandler<EventArgs<IChannelFrame>>,
    EventArgs<IChannelFrame>>

function add_ReceivedUndeterminedFrame(value);
function remove_ReceivedUndeterminedFrame(value);
 event EventHandler<EventArgs<IChannelFrame^>^>^ ReceivedUndeterminedFrame {
    void add (EventHandler<EventArgs<IChannelFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IChannelFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IChannelFrame
Remarks
Argument is the undetermined IChannelFrame that was received.
See Also

Reference

IFrameParser Interface
GSF.PhasorProtocols Namespace


IFrequencyDefinition Interface

Grid Solutions Framework IFrequencyDefinition Interface
Represents a protocol independent interface representation of a definition of a IFrequencyValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IFrequencyDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IFrequencyDefinition
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
type IFrequencyDefinition =
    interface
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.IFrequencyDefinition = function();
GSF.PhasorProtocols.IFrequencyDefinition.createInterface('GSF.PhasorProtocols.IFrequencyDefinition');
public interface class IFrequencyDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable

The IFrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this IFrequencyDefinition.
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this IFrequencyDefinition.
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this IFrequencyDefinition.
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IFrequencyDefinition Methods

Grid Solutions Framework IFrequencyDefinition Methods

The IFrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IFrequencyDefinition Interface
GSF.PhasorProtocols Namespace


IFrequencyDefinition Properties

Grid Solutions Framework IFrequencyDefinition Properties

The IFrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this IFrequencyDefinition.
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this IFrequencyDefinition.
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this IFrequencyDefinition.
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IFrequencyDefinition Interface
GSF.PhasorProtocols Namespace


IFrequencyDefinition.DfDtOffset Property

Grid Solutions Framework IFrequencyDefinitionDfDtOffset Property
Gets or sets the df/dt offset of this IFrequencyDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double DfDtOffset { get; set; }
Property DfDtOffset As Double
    Get
    Set
abstract DfDtOffset : float with get, set

function get_DfDtOffset();
function set_DfDtOffset(value);
property double DfDtOffset {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFrequencyDefinition Interface
GSF.PhasorProtocols Namespace


IFrequencyDefinition.DfDtScalingValue Property

Grid Solutions Framework IFrequencyDefinitionDfDtScalingValue Property
Gets or sets the df/dt scaling value of this IFrequencyDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
uint DfDtScalingValue { get; set; }
Property DfDtScalingValue As UInteger
    Get
    Set
abstract DfDtScalingValue : uint32 with get, set

function get_DfDtScalingValue();
function set_DfDtScalingValue(value);
property unsigned int DfDtScalingValue {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

IFrequencyDefinition Interface
GSF.PhasorProtocols Namespace


IFrequencyDefinition.NominalFrequency Property

Grid Solutions Framework IFrequencyDefinitionNominalFrequency Property
Gets the nominal LineFrequency of this IFrequencyDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
LineFrequency NominalFrequency { get; }
ReadOnly Property NominalFrequency As LineFrequency
    Get
abstract NominalFrequency : LineFrequency with get

function get_NominalFrequency();

property LineFrequency NominalFrequency {
    LineFrequency get ();
}

Property Value

Type: LineFrequency
See Also

Reference

IFrequencyDefinition Interface
GSF.PhasorProtocols Namespace


IFrequencyValue Interface

Grid Solutions Framework IFrequencyValue Interface
Represents a protocol independent interface of a frequency value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IFrequencyValue : IChannelValue<IFrequencyDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IFrequencyValue
    Inherits IChannelValue(Of IFrequencyDefinition), IChannel, ISupportBinaryImage,
    ISerializable
type IFrequencyValue =
    interface
        interface IChannelValue<IFrequencyDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.IFrequencyValue = function();
GSF.PhasorProtocols.IFrequencyValue.createInterface('GSF.PhasorProtocols.IFrequencyValue');
public interface class IFrequencyValue : IChannelValue<IFrequencyDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable

The IFrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | DfDt | Gets or sets the floating point value that represents the change in this IFrequencyValue over time.
Public property | Frequency | Gets or sets the floating point value that represents this IFrequencyValue.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this IFrequencyValue over time.
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this IFrequencyValue.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IFrequencyValue Methods

Grid Solutions Framework IFrequencyValue Methods

The IFrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IFrequencyValue Interface
GSF.PhasorProtocols Namespace


IFrequencyValue Properties

Grid Solutions Framework IFrequencyValue Properties

The IFrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | DfDt | Gets or sets the floating point value that represents the change in this IFrequencyValue over time.
Public property | Frequency | Gets or sets the floating point value that represents this IFrequencyValue.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this IFrequencyValue over time.
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this IFrequencyValue.
Top
See Also

Reference

IFrequencyValue Interface
GSF.PhasorProtocols Namespace


IFrequencyValue.DfDt Property

Grid Solutions Framework IFrequencyValueDfDt Property
Gets or sets the floating point value that represents the change in this IFrequencyValue over time.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double DfDt { get; set; }
Property DfDt As Double
    Get
    Set
abstract DfDt : float with get, set

function get_DfDt();
function set_DfDt(value);
property double DfDt {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFrequencyValue Interface
GSF.PhasorProtocols Namespace


IFrequencyValue.Frequency Property

Grid Solutions Framework IFrequencyValueFrequency Property
Gets or sets the floating point value that represents this IFrequencyValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Frequency { get; set; }
Property Frequency As Double
    Get
    Set
abstract Frequency : float with get, set

function get_Frequency();
function set_Frequency(value);
property double Frequency {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IFrequencyValue Interface
GSF.PhasorProtocols Namespace


IFrequencyValue.UnscaledDfDt Property

Grid Solutions Framework IFrequencyValueUnscaledDfDt Property
Gets or sets the unscaled integer representation of the change in this IFrequencyValue over time.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int UnscaledDfDt { get; set; }
Property UnscaledDfDt As Integer
    Get
    Set
abstract UnscaledDfDt : int with get, set

function get_UnscaledDfDt();
function set_UnscaledDfDt(value);
property int UnscaledDfDt {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IFrequencyValue Interface
GSF.PhasorProtocols Namespace


IFrequencyValue.UnscaledFrequency Property

Grid Solutions Framework IFrequencyValueUnscaledFrequency Property
Gets or sets the unscaled integer representation of this IFrequencyValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int UnscaledFrequency { get; set; }
Property UnscaledFrequency As Integer
    Get
    Set
abstract UnscaledFrequency : int with get, set

function get_UnscaledFrequency();
function set_UnscaledFrequency(value);
property int UnscaledFrequency {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IFrequencyValue Interface
GSF.PhasorProtocols Namespace


IHeaderCell Interface

Grid Solutions Framework IHeaderCell Interface
Represents a protocol independent interface representation of any kind of IHeaderFrame cell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IHeaderCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IHeaderCell
    Inherits IChannelCell, IChannel, ISupportBinaryImage, ISerializable
type IHeaderCell =
    interface
        interface IChannelCell
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.IHeaderCell = function();
GSF.PhasorProtocols.IHeaderCell.createInterface('GSF.PhasorProtocols.IHeaderCell');
public interface class IHeaderCell : IChannelCell,
    IChannel, ISupportBinaryImage, ISerializable

The IHeaderCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Character | Gets or sets ASCII character as a Byte that represents this IHeaderCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IHeaderFrame for this IHeaderCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IHeaderCell Methods

Grid Solutions Framework IHeaderCell Methods

The IHeaderCell type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IHeaderCell Interface
GSF.PhasorProtocols Namespace


IHeaderCell Properties

Grid Solutions Framework IHeaderCell Properties

The IHeaderCell type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Character | Gets or sets ASCII character as a Byte that represents this IHeaderCell.
Public property | IDCode | Gets the numeric ID code for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IHeaderFrame for this IHeaderCell.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this ChannelCellBase. (Inherited from IChannelCell.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Top
See Also

Reference

IHeaderCell Interface
GSF.PhasorProtocols Namespace


IHeaderCell.Character Property

Grid Solutions Framework IHeaderCellCharacter Property
Gets or sets ASCII character as a Byte that represents this IHeaderCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
byte Character { get; set; }
Property Character As Byte
    Get
    Set
abstract Character : byte with get, set

function get_Character();
function set_Character(value);
property unsigned char Character {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

IHeaderCell Interface
GSF.PhasorProtocols Namespace


IHeaderCell.Parent Property

Grid Solutions Framework IHeaderCellParent Property
Overload List
 | Name | Description
Public property | Parent | Gets a reference to the parent IChannelFrame for this IChannelCell. (Inherited from IChannelCell.)
Public property | Parent | Gets a reference to the parent IHeaderFrame for this IHeaderCell.
Top
See Also

Reference

IHeaderCell Interface
GSF.PhasorProtocols Namespace


IHeaderCell.Parent Property

Grid Solutions Framework IHeaderCellParent Property
Gets a reference to the parent IHeaderFrame for this IHeaderCell.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IHeaderFrame Parent { get; set; }
Property Parent As IHeaderFrame
    Get
    Set
abstract Parent : IHeaderFrame with get, set

function get_Parent();
function set_Parent(value);
property IHeaderFrame^ Parent {
    IHeaderFrame^ get ();
    void set (IHeaderFrame^ value);
}

Property Value

Type: IHeaderFrame
See Also

Reference

IHeaderCell Interface
Parent Overload
GSF.PhasorProtocols Namespace


IHeaderFrame Interface

Grid Solutions Framework IHeaderFrame Interface
Represents a protocol independent interface representation of any kind of header frame that contains a collection of IHeaderCell objects.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IHeaderFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable, ISerializable
Public Interface IHeaderFrame
    Inherits IChannelFrame, IChannel, ISupportBinaryImage, IFrame,
    IEquatable(Of IFrame), IComparable(Of IFrame), IComparable,
    ISerializable
type IHeaderFrame =
    interface
        interface IChannelFrame
        interface IChannel
        interface ISupportBinaryImage
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
        interface ISerializable
    end
GSF.PhasorProtocols.IHeaderFrame = function();
GSF.PhasorProtocols.IHeaderFrame.createInterface('GSF.PhasorProtocols.IHeaderFrame');
public interface class IHeaderFrame : IChannelFrame,
    IChannel, ISupportBinaryImage, IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable, ISerializable

The IHeaderFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the HeaderCellCollection for this IHeaderFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | HeaderData | Gets or sets header data for this IHeaderFrame.
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this IHeaderFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IHeaderFrame Methods

Grid Solutions Framework IHeaderFrame Methods

The IHeaderFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IHeaderFrame Interface
GSF.PhasorProtocols Namespace


IHeaderFrame Properties

Grid Solutions Framework IHeaderFrame Properties

The IHeaderFrame type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the HeaderCellCollection for this IHeaderFrame.
Public property | FrameType | Gets the FundamentalFrameType for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | HeaderData | Gets or sets header data for this IHeaderFrame.
Public property | IDCode | Gets or sets the ID code of this IChannelFrame. (Inherited from IChannelFrame.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame. (Inherited from IFrame.)
Public property | Measurements | Keyed measurements in this IFrame. (Inherited from IFrame.)
Public property | Published | Gets or sets published state of this IFrame (pre-processing). (Inherited from IFrame.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IFrame.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IFrame.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame. (Inherited from IFrame.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this IHeaderFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame. (Inherited from IFrame.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this IChannelFrame. (Inherited from IChannelFrame.)
Top
See Also

Reference

IHeaderFrame Interface
GSF.PhasorProtocols Namespace


IHeaderFrame.Cells Property

Grid Solutions Framework IHeaderFrameCells Property
Overload List
 | Name | Description
Public property | Cells | Gets the simple reference to the collection of cells for this IChannelFrame. (Inherited from IChannelFrame.)
Public property | Cells | Gets reference to the HeaderCellCollection for this IHeaderFrame.
Top
See Also

Reference

IHeaderFrame Interface
GSF.PhasorProtocols Namespace


IHeaderFrame.Cells Property

Grid Solutions Framework IHeaderFrameCells Property
Gets reference to the HeaderCellCollection for this IHeaderFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
HeaderCellCollection Cells { get; }
ReadOnly Property Cells As HeaderCellCollection
    Get
abstract Cells : HeaderCellCollection with get

function get_Cells();

property HeaderCellCollection^ Cells {
    HeaderCellCollection^ get ();
}

Property Value

Type: HeaderCellCollection
See Also

Reference

IHeaderFrame Interface
Cells Overload
GSF.PhasorProtocols Namespace


IHeaderFrame.HeaderData Property

Grid Solutions Framework IHeaderFrameHeaderData Property
Gets or sets header data for this IHeaderFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
string HeaderData { get; set; }
Property HeaderData As String
    Get
    Set
abstract HeaderData : string with get, set

function get_HeaderData();
function set_HeaderData(value);
property String^ HeaderData {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IHeaderFrame Interface
GSF.PhasorProtocols Namespace


IHeaderFrame.State Property

Grid Solutions Framework IHeaderFrameState Property
Overload List
 | Name | Description
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | State | Gets or sets the parsing state for the this IHeaderFrame.
Top
See Also

Reference

IHeaderFrame Interface
GSF.PhasorProtocols Namespace


IHeaderFrame.State Property

Grid Solutions Framework IHeaderFrameState Property
Gets or sets the parsing state for the this IHeaderFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IHeaderFrameParsingState State { get; set; }
Property State As IHeaderFrameParsingState
    Get
    Set
abstract State : IHeaderFrameParsingState with get, set

function get_State();
function set_State(value);
property IHeaderFrameParsingState^ State {
    IHeaderFrameParsingState^ get ();
    void set (IHeaderFrameParsingState^ value);
}

Property Value

Type: IHeaderFrameParsingState
See Also

Reference

IHeaderFrame Interface
State Overload
GSF.PhasorProtocols Namespace


IHeaderFrameParsingState Interface

Grid Solutions Framework IHeaderFrameParsingState Interface
Represents a protocol independent interface representation of the parsing state of a IHeaderFrame.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IHeaderFrameParsingState : IChannelFrameParsingState<IHeaderCell>,
    IChannelParsingState
Public Interface IHeaderFrameParsingState
    Inherits IChannelFrameParsingState(Of IHeaderCell), IChannelParsingState
type IHeaderFrameParsingState =
    interface
        interface IChannelFrameParsingState<IHeaderCell>
        interface IChannelParsingState
    end
GSF.PhasorProtocols.IHeaderFrameParsingState = function();
GSF.PhasorProtocols.IHeaderFrameParsingState.createInterface('GSF.PhasorProtocols.IHeaderFrameParsingState');
public interface class IHeaderFrameParsingState : IChannelFrameParsingState<IHeaderCell^>,
    IChannelParsingState

The IHeaderFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IHeaderFrameParsingState Properties

Grid Solutions Framework IHeaderFrameParsingState Properties

The IHeaderFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from IChannelFrameParsingStateT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from IChannelFrameParsingStateT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from IChannelParsingState.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from IChannelFrameParsingStateT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from IChannelFrameParsingStateT.)
Top
See Also

Reference

IHeaderFrameParsingState Interface
GSF.PhasorProtocols Namespace


IPhasorDefinition Interface

Grid Solutions Framework IPhasorDefinition Interface
Represents a protocol independent interface representation of a definition of a IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IPhasorDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition>,
    IComparable<IChannelDefinition>, IComparable
Public Interface IPhasorDefinition
    Inherits IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition), IComparable
type IPhasorDefinition =
    interface
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.IPhasorDefinition = function();
GSF.PhasorProtocols.IPhasorDefinition.createInterface('GSF.PhasorProtocols.IPhasorDefinition');
public interface class IPhasorDefinition : IChannelDefinition,
    IChannel, ISupportBinaryImage, ISerializable, IEquatable<IChannelDefinition^>,
    IComparable<IChannelDefinition^>, IComparable

The IPhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this IPhasorDefinition.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this IPhasorDefinition.
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | PhasorType | Gets or sets the PhasorType of this IPhasorDefinition.
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IPhasorDefinition Methods

Grid Solutions Framework IPhasorDefinition Methods

The IPhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IChannelDefinition .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IChannelDefinition .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IPhasorDefinition Interface
GSF.PhasorProtocols Namespace


IPhasorDefinition Properties

Grid Solutions Framework IPhasorDefinition Properties

The IPhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this IPhasorDefinition.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ConversionFactor | Gets or sets the conversion factor of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this IPhasorDefinition.
Public property | DataFormat | Gets the DataFormat of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Index | Gets or sets the index of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Label | Gets or sets the label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | LabelImage | Gets the binary image of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Offset | Gets or sets the offset of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | Parent | Gets the IConfigurationCell parent of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | PhasorType | Gets or sets the PhasorType of this IPhasorDefinition.
Public property | ScalePerBit | Gets the scale/bit value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | ScalingValue | Gets or sets the integer scaling value of this IChannelDefinition. (Inherited from IChannelDefinition.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).
Top
See Also

Reference

IPhasorDefinition Interface
GSF.PhasorProtocols Namespace


IPhasorDefinition.AngleFormat Property

Grid Solutions Framework IPhasorDefinitionAngleFormat Property
Gets or sets the AngleFormat of this IPhasorDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
AngleFormat AngleFormat { get; }
ReadOnly Property AngleFormat As AngleFormat
    Get
abstract AngleFormat : AngleFormat with get

function get_AngleFormat();

property AngleFormat AngleFormat {
    AngleFormat get ();
}

Property Value

Type: AngleFormat
See Also

Reference

IPhasorDefinition Interface
GSF.PhasorProtocols Namespace


IPhasorDefinition.CoordinateFormat Property

Grid Solutions Framework IPhasorDefinitionCoordinateFormat Property
Gets or sets the CoordinateFormat of this IPhasorDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CoordinateFormat CoordinateFormat { get; }
ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
abstract CoordinateFormat : CoordinateFormat with get

function get_CoordinateFormat();

property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}

Property Value

Type: CoordinateFormat
See Also

Reference

IPhasorDefinition Interface
GSF.PhasorProtocols Namespace


IPhasorDefinition.PhasorType Property

Grid Solutions Framework IPhasorDefinitionPhasorType Property
Gets or sets the PhasorType of this IPhasorDefinition.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
PhasorType PhasorType { get; set; }
Property PhasorType As PhasorType
    Get
    Set
abstract PhasorType : PhasorType with get, set

function get_PhasorType();
function set_PhasorType(value);
property PhasorType PhasorType {
    PhasorType get ();
    void set (PhasorType value);
}

Property Value

Type: PhasorType
See Also

Reference

IPhasorDefinition Interface
GSF.PhasorProtocols Namespace


IPhasorDefinition.VoltageReference Property

Grid Solutions Framework IPhasorDefinitionVoltageReference Property
Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
IPhasorDefinition VoltageReference { get; set; }
Property VoltageReference As IPhasorDefinition
    Get
    Set
abstract VoltageReference : IPhasorDefinition with get, set

function get_VoltageReference();
function set_VoltageReference(value);
property IPhasorDefinition^ VoltageReference {
    IPhasorDefinition^ get ();
    void set (IPhasorDefinition^ value);
}

Property Value

Type: IPhasorDefinition
Remarks
This only applies to current phasors.
See Also

Reference

IPhasorDefinition Interface
GSF.PhasorProtocols Namespace


IPhasorValue Interface

Grid Solutions Framework IPhasorValue Interface
Represents a protocol independent interface representation of a phasor value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IPhasorValue : IChannelValue<IPhasorDefinition>,
    IChannel, ISupportBinaryImage, ISerializable
Public Interface IPhasorValue
    Inherits IChannelValue(Of IPhasorDefinition), IChannel, ISupportBinaryImage,
    ISerializable
type IPhasorValue =
    interface
        interface IChannelValue<IPhasorDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.IPhasorValue = function();
GSF.PhasorProtocols.IPhasorValue.createInterface('GSF.PhasorProtocols.IPhasorValue');
public interface class IPhasorValue : IChannelValue<IPhasorDefinition^>,
    IChannel, ISupportBinaryImage, ISerializable

The IPhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this IPhasorValue, in radians.
Public property | AngleFormat | Gets the AngleFormat of this IPhasorValue.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this IPhasorValue.
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | Imaginary | Gets or sets the imaginary floating point value of this IPhasorValue.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this IPhasorValue.
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | Real | Gets or sets the real floating point value of this IPhasorValue.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Type | Gets the PhasorType of this IPhasorValue.
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this IPhasorValue.
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this IPhasorValue.
Top
See Also

Reference

GSF.PhasorProtocols Namespace


IPhasorValue Methods

Grid Solutions Framework IPhasorValue Methods

The IPhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetCompositeValue | Gets the specified composite value of this IChannelValueT. (Inherited from IChannelValueT.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from IChannelValueT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ISerializable.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue Properties

Grid Solutions Framework IPhasorValue Properties

The IPhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this IPhasorValue, in radians.
Public property | AngleFormat | Gets the AngleFormat of this IPhasorValue.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from IChannel.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | CompositeValueCount | Gets total number of composite values that this IChannelValueT provides. (Inherited from IChannelValueT.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this IPhasorValue.
Public property | DataFormat | Gets the DataFormat of this IChannelValueT typically derived from DataFormat. (Inherited from IChannelValueT.)
Public property | Definition | Gets the IChannelDefinition associated with this IChannelValueT. (Inherited from IChannelValueT.)
Public property | Imaginary | Gets or sets the imaginary floating point value of this IPhasorValue.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of IChannelValueT have been assigned a value. (Inherited from IChannelValueT.)
Public property | Label | Gets text based label of this IChannelValueT typically derived from Label. (Inherited from IChannelValueT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this IPhasorValue.
Public property | Measurements | Gets the composite values of this IChannelValueT as an array of IMeasurement values. (Inherited from IChannelValueT.)
Public property | Parent | Gets the IDataCell parent of this IChannelValueT. (Inherited from IChannelValueT.)
Public property | Real | Gets or sets the real floating point value of this IPhasorValue.
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from IChannel.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from IChannel.)
Public property | Type | Gets the PhasorType of this IPhasorValue.
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this IPhasorValue.
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this IPhasorValue.
Top
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.Angle Property

Grid Solutions Framework IPhasorValueAngle Property
Gets or sets the Angle value (a.k.a., the argument) of this IPhasorValue, in radians.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
Angle Angle { get; set; }
Property Angle As Angle
    Get
    Set
abstract Angle : Angle with get, set

function get_Angle();
function set_Angle(value);
property Angle Angle {
    Angle get ();
    void set (Angle value);
}

Property Value

Type: Angle
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.AngleFormat Property

Grid Solutions Framework IPhasorValueAngleFormat Property
Gets the AngleFormat of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
AngleFormat AngleFormat { get; }
ReadOnly Property AngleFormat As AngleFormat
    Get
abstract AngleFormat : AngleFormat with get

function get_AngleFormat();

property AngleFormat AngleFormat {
    AngleFormat get ();
}

Property Value

Type: AngleFormat
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.CoordinateFormat Property

Grid Solutions Framework IPhasorValueCoordinateFormat Property
Gets the CoordinateFormat of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
CoordinateFormat CoordinateFormat { get; }
ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
abstract CoordinateFormat : CoordinateFormat with get

function get_CoordinateFormat();

property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}

Property Value

Type: CoordinateFormat
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.Imaginary Property

Grid Solutions Framework IPhasorValueImaginary Property
Gets or sets the imaginary floating point value of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Imaginary { get; set; }
Property Imaginary As Double
    Get
    Set
abstract Imaginary : float with get, set

function get_Imaginary();
function set_Imaginary(value);
property double Imaginary {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.Magnitude Property

Grid Solutions Framework IPhasorValueMagnitude Property
Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Magnitude { get; set; }
Property Magnitude As Double
    Get
    Set
abstract Magnitude : float with get, set

function get_Magnitude();
function set_Magnitude(value);
property double Magnitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.Real Property

Grid Solutions Framework IPhasorValueReal Property
Gets or sets the real floating point value of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Real { get; set; }
Property Real As Double
    Get
    Set
abstract Real : float with get, set

function get_Real();
function set_Real(value);
property double Real {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.Type Property

Grid Solutions Framework IPhasorValueType Property
Gets the PhasorType of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
PhasorType Type { get; }
ReadOnly Property Type As PhasorType
    Get
abstract Type : PhasorType with get

function get_Type();

property PhasorType Type {
    PhasorType get ();
}

Property Value

Type: PhasorType
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.UnscaledImaginary Property

Grid Solutions Framework IPhasorValueUnscaledImaginary Property
Gets or sets the unscaled integer representation of the imaginary value of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int UnscaledImaginary { get; set; }
Property UnscaledImaginary As Integer
    Get
    Set
abstract UnscaledImaginary : int with get, set

function get_UnscaledImaginary();
function set_UnscaledImaginary(value);
property int UnscaledImaginary {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


IPhasorValue.UnscaledReal Property

Grid Solutions Framework IPhasorValueUnscaledReal Property
Gets or sets the unscaled integer representation of the real value of this IPhasorValue.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
int UnscaledReal { get; set; }
Property UnscaledReal As Integer
    Get
    Set
abstract UnscaledReal : int with get, set

function get_UnscaledReal();
function set_UnscaledReal(value);
property int UnscaledReal {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IPhasorValue Interface
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser Class

Grid Solutions Framework MultiProtocolFrameParser Class
Protocol independent frame parser.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsMultiProtocolFrameParser

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class MultiProtocolFrameParser : IFrameParser,
    IProvideStatus, IDisposable
Public NotInheritable Class MultiProtocolFrameParser
    Implements IFrameParser, IProvideStatus, IDisposable
[<SealedAttribute>]
type MultiProtocolFrameParser =
    class
        interface IFrameParser
        interface IProvideStatus
        interface IDisposable
    end
GSF.PhasorProtocols.MultiProtocolFrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.MultiProtocolFrameParser',
    null,
    GSF.PhasorProtocols.IFrameParser,
    GSF.IProvideStatus,
    IDisposable);
public ref class MultiProtocolFrameParser sealed : IFrameParser,
    IProvideStatus, IDisposable

The MultiProtocolFrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | MultiProtocolFrameParser | Creates a new MultiProtocolFrameParser using the default settings.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the MultiProtocolFrameParser object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetTotalBytesReceived | Resets the value for the TotalBytesReceived statistic.
Public method | SendDeviceCommand | Sends the specified DeviceCommand to the remote device.
Public method | Start | Starts the MultiProtocolFrameParser.
Public method | Stop | Stops the MultiProtocolFrameParser.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryInitializeFrameParser | Attempts to initialize the protocol specific frame parser.
Public method | Write | Writes data directly to the frame parsing engine buffer.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultAllowedParsingExceptions | Specifies the default value for the AllowedParsingExceptions property.
DefaultAutoStartDataParsingSequence | Specifies the default value for the AutoStartDataParsingSequence property.
DefaultBufferSize | Specifies the default value for the BufferSize property.
DefaultDefinedFrameRate | Specifies the default value for the DefinedFrameRate property.
DefaultMaximumConnectionAttempts | Specifies the default value for the MaximumConnectionAttempts property.
DefaultParsingExceptionWindow | Specifies the default value for the ParsingExceptionWindow property.
Top
Properties
 | Name | Description
Public property | AllowedParsingExceptions | Gets or sets number of parsing exceptions allowed during ParsingExceptionWindow before connection is reset.
Public property | AutoRepeatCapturedPlayback | Gets or sets a flag that determines if a file used for replaying data should be restarted at the beginning once it has been completed.
Public property | AutoStartDataParsingSequence | Gets or sets flag to automatically send the ConfigFrame2 and EnableRealTimeData command frames used to start a typical data parsing sequence.
Public property | BitRate | Gets the calculated bit rate (i.e., bits per second (bps)) based on data received from device connection.
Public property | BufferSize | Gets or sets the size of the buffer used by the MultiProtocolFrameParser for sending and receiving data from a device.
Public property | ByteRate | Gets the calculated byte rate (i.e., bytes per second) based on data received from device connection.
Public property | CalculatedFrameRate | Gets the calculated frame rate (i.e., frames per second) based on data received from device connection.
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Public property | ConfiguredFrameRate | Gets the configured frame rate as reported by the connected device.
Public property | ConnectionIsListener | Gets flag that determines if the connection type is a TCP server.
Public property | ConnectionIsMulticast | Gets flag that determines if the connection type is multicast.
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be applicable for the current PhasorProtocol.
Public property | ConnectionString | Gets or sets the key/value pair based connection information required by the MultiProtocolFrameParser to connect to a device.
Public property | ConnectionTime | Gets total time connection has been active.
Public property | ConnectionType | Gets the connection type (Active, Passive or Hybrid) based on defined channels and transport selections.
Public property | DataChannelIsServerBased | Gets a boolean value that determines if data channel is defined as a server based connection.
Public property | DefinedFrameRate | Gets or sets desired frame rate to use for maintaining captured frame replay timing.
Public property | DeviceID | Gets or sets the device identification code often needed to establish a connection.
Public property | DeviceSupportsCommands | Gets or sets flag that determines if a device supports commands.
Public property | Enabled | Gets or sets a boolean value that indicates whether the MultiProtocolFrameParser is currently enabled.
Public property | InjectSimulatedTimestamp | Gets or sets flag indicating whether or not to inject local system time into parsed data frames.
Public property | IsConnected | Gets a flag that determines if the currently selected TransportProtocol is connected.
Public property | IsIEEEProtocol | Gets a flag that determines if the currently selected PhasorProtocol is an IEEE standard protocol.
Public property | KeepCommandChannelOpen | Gets or sets flag that determines whether to keep the command channel open after the initial startup sequence.
Public property | MaximumConnectionAttempts | Gets or sets the maximum number of times the MultiProtocolFrameParser will attempt to connect to a device.
Public property | MegaBitRate | Gets the calculated megabits per second (Mbps) rate based on data received from device connection.
Public property | Name | Gets a descriptive name for a device connection that includes SourceName, if provided.
Public property | ParsingExceptionWindow | Gets or sets time duration, in Ticks, to monitor parsing exceptions.
Public property | PhasorProtocol | Gets or sets PhasorProtocol to use with this MultiProtocolFrameParser.
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
Public property | QueuedOutputs | Gets the total number of frames that are currently queued for publication, if any.
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet.
Public property | SkipDisableRealTimeData | Gets or sets flag to skip automatic disabling of the real-time data stream on shutdown or startup.
Public property | SourceName | Gets or sets a descriptive name for a device connection.
Public property | Status | Gets current descriptive status of the MultiProtocolFrameParser.
Public property | TotalBytesReceived | Gets total number of bytes that have been received from a device so far.
Public property | TotalCrcExceptions | Gets total number of CRC exceptions encountered from device so far.
Public property | TotalFramesReceived | Gets total number of frames that have been received from a device so far.
Public property | TotalMissingFrames | Gets total number of frames that were missing from device so far.
Public property | TransportProtocol | Gets or sets TransportProtocol to use with this MultiProtocolFrameParser.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | UseHighResolutionInputTimer | Gets or sets flag that determines if a high-resolution precision timer should be used for file based input.
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed.
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
Public event | ConnectionAttempt | Occurs when MultiProtocolFrameParser is attempting connection to a device.
Public event | ConnectionEstablished | Occurs when MultiProtocolFrameParser has established a connection to a device.
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to a device.
Public event | ConnectionTerminated | Occurs when device connection has been terminated.
Public event | ExceededParsingExceptionThreshold | Occurs when number of parsing exceptions exceed AllowedParsingExceptions during ParsingExceptionWindow.
Public event | ParsingException | Occurs when an Exception is encountered while parsing the data stream.
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a IDataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received.
Public event | ReceivedFrameImage | Occurs when a frame image has been received.
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
Public event | SentCommandFrame | Occurs when a ICommandFrame is sent to a device.
Public event | ServerStarted | Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been started.
Public event | ServerStopped | Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been stopped.
Top
Remarks
This class takes all protocol frame parsing implementations and reduces them to a single simple-to-use class exposing all data through abstract interfaces (e.g., IConfigurationFrame, IDataFrame, etc.) - this way new protocol implementations can be added without adversely affecting consuming code. Additionally, this class implements a variety of transport options (e.g., TCP, UDP, Serial, etc.) and hides the complexities of this connectivity and internally pushes all data received from the selected transport protocol to the selected phasor parsing protocol.
See Also

Reference

GSF.PhasorProtocols Namespace


MultiProtocolFrameParser Constructor

Grid Solutions Framework MultiProtocolFrameParser Constructor
Creates a new MultiProtocolFrameParser using the default settings.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MultiProtocolFrameParser()
Public Sub New
new : unit -> MultiProtocolFrameParser
GSF.PhasorProtocols.MultiProtocolFrameParser = function();
public:
MultiProtocolFrameParser()
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser Fields

Grid Solutions Framework MultiProtocolFrameParser Fields

The MultiProtocolFrameParser type exposes the following members.

Fields
Name | Description
DefaultAllowedParsingExceptions | Specifies the default value for the AllowedParsingExceptions property.
DefaultAutoStartDataParsingSequence | Specifies the default value for the AutoStartDataParsingSequence property.
DefaultBufferSize | Specifies the default value for the BufferSize property.
DefaultDefinedFrameRate | Specifies the default value for the DefinedFrameRate property.
DefaultMaximumConnectionAttempts | Specifies the default value for the MaximumConnectionAttempts property.
DefaultParsingExceptionWindow | Specifies the default value for the ParsingExceptionWindow property.
Top
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DefaultAllowedParsingExceptions Field

Grid Solutions Framework MultiProtocolFrameParserDefaultAllowedParsingExceptions Field
Specifies the default value for the AllowedParsingExceptions property.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultAllowedParsingExceptions
Public Const DefaultAllowedParsingExceptions As Integer
static val mutable DefaultAllowedParsingExceptions: int
var GSF.PhasorProtocols.MultiProtocolFrameParser.DefaultAllowedParsingExceptions
public:
literal int DefaultAllowedParsingExceptions

Field Value

Type: Int32
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DefaultAutoStartDataParsingSequence Field

Grid Solutions Framework MultiProtocolFrameParserDefaultAutoStartDataParsingSequence Field
Specifies the default value for the AutoStartDataParsingSequence property.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAutoStartDataParsingSequence
Public Const DefaultAutoStartDataParsingSequence As Boolean
static val mutable DefaultAutoStartDataParsingSequence: bool
var GSF.PhasorProtocols.MultiProtocolFrameParser.DefaultAutoStartDataParsingSequence
public:
literal bool DefaultAutoStartDataParsingSequence

Field Value

Type: Boolean
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DefaultBufferSize Field

Grid Solutions Framework MultiProtocolFrameParserDefaultBufferSize Field
Specifies the default value for the BufferSize property.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultBufferSize
Public Const DefaultBufferSize As Integer
static val mutable DefaultBufferSize: int
var GSF.PhasorProtocols.MultiProtocolFrameParser.DefaultBufferSize
public:
literal int DefaultBufferSize

Field Value

Type: Int32
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DefaultDefinedFrameRate Field

Grid Solutions Framework MultiProtocolFrameParserDefaultDefinedFrameRate Field
Specifies the default value for the DefinedFrameRate property.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultDefinedFrameRate
Public Const DefaultDefinedFrameRate As Integer
static val mutable DefaultDefinedFrameRate: int
var GSF.PhasorProtocols.MultiProtocolFrameParser.DefaultDefinedFrameRate
public:
literal int DefaultDefinedFrameRate

Field Value

Type: Int32
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DefaultMaximumConnectionAttempts Field

Grid Solutions Framework MultiProtocolFrameParserDefaultMaximumConnectionAttempts Field
Specifies the default value for the MaximumConnectionAttempts property.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaximumConnectionAttempts
Public Const DefaultMaximumConnectionAttempts As Integer
static val mutable DefaultMaximumConnectionAttempts: int
var GSF.PhasorProtocols.MultiProtocolFrameParser.DefaultMaximumConnectionAttempts
public:
literal int DefaultMaximumConnectionAttempts

Field Value

Type: Int32
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DefaultParsingExceptionWindow Field

Grid Solutions Framework MultiProtocolFrameParserDefaultParsingExceptionWindow Field
Specifies the default value for the ParsingExceptionWindow property.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long DefaultParsingExceptionWindow
Public Const DefaultParsingExceptionWindow As Long
static val mutable DefaultParsingExceptionWindow: int64
var GSF.PhasorProtocols.MultiProtocolFrameParser.DefaultParsingExceptionWindow
public:
literal long long DefaultParsingExceptionWindow

Field Value

Type: Int64
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser Methods

Grid Solutions Framework MultiProtocolFrameParser Methods

The MultiProtocolFrameParser type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the MultiProtocolFrameParser object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ResetTotalBytesReceived | Resets the value for the TotalBytesReceived statistic.
Public method | SendDeviceCommand | Sends the specified DeviceCommand to the remote device.
Public method | Start | Starts the MultiProtocolFrameParser.
Public method | Stop | Stops the MultiProtocolFrameParser.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryInitializeFrameParser | Attempts to initialize the protocol specific frame parser.
Public method | Write | Writes data directly to the frame parsing engine buffer.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.Dispose Method

Grid Solutions Framework MultiProtocolFrameParserDispose Method
Releases all the resources used by the MultiProtocolFrameParser object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ResetTotalBytesReceived Method

Grid Solutions Framework MultiProtocolFrameParserResetTotalBytesReceived Method
Resets the value for the TotalBytesReceived statistic.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ResetTotalBytesReceived()
Public Sub ResetTotalBytesReceived
member ResetTotalBytesReceived : unit -> unit

function ResetTotalBytesReceived();
public:
void ResetTotalBytesReceived()
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.SendDeviceCommand Method

Grid Solutions Framework MultiProtocolFrameParserSendDeviceCommand Method
Sends the specified DeviceCommand to the remote device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WaitHandle SendDeviceCommand(
    DeviceCommand command
)
Public Function SendDeviceCommand (
    command As DeviceCommand
) As WaitHandle
member SendDeviceCommand :
        command : DeviceCommand -> WaitHandle

function SendDeviceCommand(command);
public:
WaitHandle^ SendDeviceCommand(
    DeviceCommand command
)

Parameters

command
Type: GSF.PhasorProtocolsDeviceCommand
DeviceCommand to send to the remote device.

Return Value

Type: WaitHandle
A WaitHandle.
Remarks
Command will only be sent if DeviceSupportsCommands is true and MultiProtocolFrameParser.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.Start Method

Grid Solutions Framework MultiProtocolFrameParserStart Method
Starts the MultiProtocolFrameParser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start()
Public Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() sealed

Implements

IFrameParserStart
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.Stop Method

Grid Solutions Framework MultiProtocolFrameParserStop Method
Stops the MultiProtocolFrameParser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Stop()
Public Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() sealed

Implements

IFrameParserStop
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.TryInitializeFrameParser Method

Grid Solutions Framework MultiProtocolFrameParserTryInitializeFrameParser Method
Attempts to initialize the protocol specific frame parser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryInitializeFrameParser()
Public Function TryInitializeFrameParser As Boolean
member TryInitializeFrameParser : unit -> bool

function TryInitializeFrameParser();
public:
bool TryInitializeFrameParser()

Return Value

Type: Boolean
true if frame parser was successfully initialized; otherwise false.
Remarks
Starting the multi-protocol frame parser will automatically initialize the frame parsers so calling this method then will be unnecessary, however, if you are using this class just to edit custom connection parameters then initializing the will be necessary.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.Write Method

Grid Solutions Framework MultiProtocolFrameParserWrite Method
Writes data directly to the frame parsing engine buffer.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Write(
    byte[] buffer,
    int offset,
    int count
)
Public Sub Write (
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
member Write :
        buffer : byte[] *
        offset : int *
        count : int -> unit

function Write(buffer, offset, count);
public:
void Write(
    array<unsigned char>^ buffer,
    int offset,
    int count
)

Parameters

buffer
Type: SystemByte
Buffer containing data to be parsed.
offset
Type: SystemInt32
Offset into buffer where data begins.
count
Type: SystemInt32
Length of data in buffer to be parsed.
Remarks
This method is public to allow consumer to "manually send extra data" to the parsing engine to be parsed, if desired.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser Properties

Grid Solutions Framework MultiProtocolFrameParser Properties

The MultiProtocolFrameParser type exposes the following members.

Properties
 | Name | Description
Public property | AllowedParsingExceptions | Gets or sets number of parsing exceptions allowed during ParsingExceptionWindow before connection is reset.
Public property | AutoRepeatCapturedPlayback | Gets or sets a flag that determines if a file used for replaying data should be restarted at the beginning once it has been completed.
Public property | AutoStartDataParsingSequence | Gets or sets flag to automatically send the ConfigFrame2 and EnableRealTimeData command frames used to start a typical data parsing sequence.
Public property | BitRate | Gets the calculated bit rate (i.e., bits per second (bps)) based on data received from device connection.
Public property | BufferSize | Gets or sets the size of the buffer used by the MultiProtocolFrameParser for sending and receiving data from a device.
Public property | ByteRate | Gets the calculated byte rate (i.e., bytes per second) based on data received from device connection.
Public property | CalculatedFrameRate | Gets the calculated frame rate (i.e., frames per second) based on data received from device connection.
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.
Public property | ConfiguredFrameRate | Gets the configured frame rate as reported by the connected device.
Public property | ConnectionIsListener | Gets flag that determines if the connection type is a TCP server.
Public property | ConnectionIsMulticast | Gets flag that determines if the connection type is multicast.
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be applicable for the current PhasorProtocol.
Public property | ConnectionString | Gets or sets the key/value pair based connection information required by the MultiProtocolFrameParser to connect to a device.
Public property | ConnectionTime | Gets total time connection has been active.
Public property | ConnectionType | Gets the connection type (Active, Passive or Hybrid) based on defined channels and transport selections.
Public property | DataChannelIsServerBased | Gets a boolean value that determines if data channel is defined as a server based connection.
Public property | DefinedFrameRate | Gets or sets desired frame rate to use for maintaining captured frame replay timing.
Public property | DeviceID | Gets or sets the device identification code often needed to establish a connection.
Public property | DeviceSupportsCommands | Gets or sets flag that determines if a device supports commands.
Public property | Enabled | Gets or sets a boolean value that indicates whether the MultiProtocolFrameParser is currently enabled.
Public property | InjectSimulatedTimestamp | Gets or sets flag indicating whether or not to inject local system time into parsed data frames.
Public property | IsConnected | Gets a flag that determines if the currently selected TransportProtocol is connected.
Public property | IsIEEEProtocol | Gets a flag that determines if the currently selected PhasorProtocol is an IEEE standard protocol.
Public property | KeepCommandChannelOpen | Gets or sets flag that determines whether to keep the command channel open after the initial startup sequence.
Public property | MaximumConnectionAttempts | Gets or sets the maximum number of times the MultiProtocolFrameParser will attempt to connect to a device.
Public property | MegaBitRate | Gets the calculated megabits per second (Mbps) rate based on data received from device connection.
Public property | Name | Gets a descriptive name for a device connection that includes SourceName, if provided.
Public property | ParsingExceptionWindow | Gets or sets time duration, in Ticks, to monitor parsing exceptions.
Public property | PhasorProtocol | Gets or sets PhasorProtocol to use with this MultiProtocolFrameParser.
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any.
Public property | QueuedOutputs | Gets the total number of frames that are currently queued for publication, if any.
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet.
Public property | SkipDisableRealTimeData | Gets or sets flag to skip automatic disabling of the real-time data stream on shutdown or startup.
Public property | SourceName | Gets or sets a descriptive name for a device connection.
Public property | Status | Gets current descriptive status of the MultiProtocolFrameParser.
Public property | TotalBytesReceived | Gets total number of bytes that have been received from a device so far.
Public property | TotalCrcExceptions | Gets total number of CRC exceptions encountered from device so far.
Public property | TotalFramesReceived | Gets total number of frames that have been received from a device so far.
Public property | TotalMissingFrames | Gets total number of frames that were missing from device so far.
Public property | TransportProtocol | Gets or sets TransportProtocol to use with this MultiProtocolFrameParser.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count.
Public property | UseHighResolutionInputTimer | Gets or sets flag that determines if a high-resolution precision timer should be used for file based input.
Top
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.AllowedParsingExceptions Property

Grid Solutions Framework MultiProtocolFrameParserAllowedParsingExceptions Property
Gets or sets number of parsing exceptions allowed during ParsingExceptionWindow before connection is reset.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int AllowedParsingExceptions { get; set; }
Public Property AllowedParsingExceptions As Integer
    Get
    Set
member AllowedParsingExceptions : int with get, set

function get_AllowedParsingExceptions();
function set_AllowedParsingExceptions(value);
public:
property int AllowedParsingExceptions {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.AutoRepeatCapturedPlayback Property

Grid Solutions Framework MultiProtocolFrameParserAutoRepeatCapturedPlayback Property
Gets or sets a flag that determines if a file used for replaying data should be restarted at the beginning once it has been completed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AutoRepeatCapturedPlayback { get; set; }
Public Property AutoRepeatCapturedPlayback As Boolean
    Get
    Set
member AutoRepeatCapturedPlayback : bool with get, set

function get_AutoRepeatCapturedPlayback();
function set_AutoRepeatCapturedPlayback(value);
public:
property bool AutoRepeatCapturedPlayback {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This is only applicable when connection is made to a file for replay purposes.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.AutoStartDataParsingSequence Property

Grid Solutions Framework MultiProtocolFrameParserAutoStartDataParsingSequence Property
Gets or sets flag to automatically send the ConfigFrame2 and EnableRealTimeData command frames used to start a typical data parsing sequence.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AutoStartDataParsingSequence { get; set; }
Public Property AutoStartDataParsingSequence As Boolean
    Get
    Set
member AutoStartDataParsingSequence : bool with get, set

function get_AutoStartDataParsingSequence();
function set_AutoStartDataParsingSequence(value);
public:
property bool AutoStartDataParsingSequence {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
For devices that support IEEE commands, setting this property to true will automatically start the data parsing sequence.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.BitRate Property

Grid Solutions Framework MultiProtocolFrameParserBitRate Property
Gets the calculated bit rate (i.e., bits per second (bps)) based on data received from device connection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double BitRate { get; }
Public ReadOnly Property BitRate As Double
    Get
member BitRate : float with get

function get_BitRate();

public:
property double BitRate {
    double get ();
}

Property Value

Type: Double
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.BufferSize Property

Grid Solutions Framework MultiProtocolFrameParserBufferSize Property
Gets or sets the size of the buffer used by the MultiProtocolFrameParser for sending and receiving data from a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BufferSize { get; set; }
Public Property BufferSize As Integer
    Get
    Set
member BufferSize : int with get, set

function get_BufferSize();
function set_BufferSize(value);
public:
property int BufferSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value specified is either zero or negative.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ByteRate Property

Grid Solutions Framework MultiProtocolFrameParserByteRate Property
Gets the calculated byte rate (i.e., bytes per second) based on data received from device connection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ByteRate { get; }
Public ReadOnly Property ByteRate As Double
    Get
member ByteRate : float with get

function get_ByteRate();

public:
property double ByteRate {
    double get ();
}

Property Value

Type: Double
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.CalculatedFrameRate Property

Grid Solutions Framework MultiProtocolFrameParserCalculatedFrameRate Property
Gets the calculated frame rate (i.e., frames per second) based on data received from device connection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculatedFrameRate { get; }
Public ReadOnly Property CalculatedFrameRate As Double
    Get
member CalculatedFrameRate : float with get

function get_CalculatedFrameRate();

public:
property double CalculatedFrameRate {
    double get ();
}

Property Value

Type: Double
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.CheckSumValidationFrameTypes Property

Grid Solutions Framework MultiProtocolFrameParserCheckSumValidationFrameTypes Property
Gets or sets flags that determine if check-sums for specified frames should be validated.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CheckSumValidationFrameTypes CheckSumValidationFrameTypes { get; set; }
Public Property CheckSumValidationFrameTypes As CheckSumValidationFrameTypes
    Get
    Set
abstract CheckSumValidationFrameTypes : CheckSumValidationFrameTypes with get, set
override CheckSumValidationFrameTypes : CheckSumValidationFrameTypes with get, set
function get_CheckSumValidationFrameTypes();
function set_CheckSumValidationFrameTypes(value);
public:
virtual property CheckSumValidationFrameTypes CheckSumValidationFrameTypes {
    CheckSumValidationFrameTypes get () sealed;
    void set (CheckSumValidationFrameTypes value) sealed;
}

Property Value

Type: CheckSumValidationFrameTypes

Implements

IFrameParserCheckSumValidationFrameTypes
Remarks
It is expected that this will normally be set to AllFrames.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConfigurationFrame Property

Grid Solutions Framework MultiProtocolFrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () sealed;
    void set (IConfigurationFrame^ value) sealed;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConfiguredFrameRate Property

Grid Solutions Framework MultiProtocolFrameParserConfiguredFrameRate Property
Gets the configured frame rate as reported by the connected device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ConfiguredFrameRate { get; }
Public ReadOnly Property ConfiguredFrameRate As Integer
    Get
member ConfiguredFrameRate : int with get

function get_ConfiguredFrameRate();

public:
property int ConfiguredFrameRate {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionIsListener Property

Grid Solutions Framework MultiProtocolFrameParserConnectionIsListener Property
Gets flag that determines if the connection type is a TCP server.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ConnectionIsListener { get; }
Public ReadOnly Property ConnectionIsListener As Boolean
    Get
member ConnectionIsListener : bool with get

function get_ConnectionIsListener();

public:
property bool ConnectionIsListener {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionIsMulticast Property

Grid Solutions Framework MultiProtocolFrameParserConnectionIsMulticast Property
Gets flag that determines if the connection type is multicast.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ConnectionIsMulticast { get; }
Public ReadOnly Property ConnectionIsMulticast As Boolean
    Get
member ConnectionIsMulticast : bool with get

function get_ConnectionIsMulticast();

public:
property bool ConnectionIsMulticast {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionParameters Property

Grid Solutions Framework MultiProtocolFrameParserConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be applicable for the current PhasorProtocol.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IConnectionParameters ConnectionParameters { get; set; }
Public Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set
override ConnectionParameters : IConnectionParameters with get, set
function get_ConnectionParameters();
function set_ConnectionParameters(value);
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () sealed;
    void set (IConnectionParameters^ value) sealed;
}

Property Value

Type: IConnectionParameters

Implements

IFrameParserConnectionParameters
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionString Property

Grid Solutions Framework MultiProtocolFrameParserConnectionString Property
Gets or sets the key/value pair based connection information required by the MultiProtocolFrameParser to connect to a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
member ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionTime Property

Grid Solutions Framework MultiProtocolFrameParserConnectionTime Property
Gets total time connection has been active.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time ConnectionTime { get; }
Public ReadOnly Property ConnectionTime As Time
    Get
member ConnectionTime : Time with get

function get_ConnectionTime();

public:
property Time ConnectionTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionType Property

Grid Solutions Framework MultiProtocolFrameParserConnectionType Property
Gets the connection type (Active, Passive or Hybrid) based on defined channels and transport selections.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionType { get; }
Public ReadOnly Property ConnectionType As String
    Get
member ConnectionType : string with get

function get_ConnectionType();

public:
property String^ ConnectionType {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DataChannelIsServerBased Property

Grid Solutions Framework MultiProtocolFrameParserDataChannelIsServerBased Property
Gets a boolean value that determines if data channel is defined as a server based connection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DataChannelIsServerBased { get; }
Public ReadOnly Property DataChannelIsServerBased As Boolean
    Get
member DataChannelIsServerBased : bool with get

function get_DataChannelIsServerBased();

public:
property bool DataChannelIsServerBased {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DefinedFrameRate Property

Grid Solutions Framework MultiProtocolFrameParserDefinedFrameRate Property
Gets or sets desired frame rate to use for maintaining captured frame replay timing.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int DefinedFrameRate { get; set; }
Public Property DefinedFrameRate As Integer
    Get
    Set
member DefinedFrameRate : int with get, set

function get_DefinedFrameRate();
function set_DefinedFrameRate(value);
public:
property int DefinedFrameRate {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This is only applicable when connection is made to a file for replay purposes.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DeviceID Property

Grid Solutions Framework MultiProtocolFrameParserDeviceID Property
Gets or sets the device identification code often needed to establish a connection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DeviceID { get; set; }
Public Property DeviceID As UShort
    Get
    Set
member DeviceID : uint16 with get, set

function get_DeviceID();
function set_DeviceID(value);
public:
property unsigned short DeviceID {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
Remarks
Most devices validate this ID when sending commands, so it must be correct in order to start parsing sequence.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.DeviceSupportsCommands Property

Grid Solutions Framework MultiProtocolFrameParserDeviceSupportsCommands Property
Gets or sets flag that determines if a device supports commands.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DeviceSupportsCommands { get; set; }
Public Property DeviceSupportsCommands As Boolean
    Get
    Set
member DeviceSupportsCommands : bool with get, set

function get_DeviceSupportsCommands();
function set_DeviceSupportsCommands(value);
public:
property bool DeviceSupportsCommands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This property is automatically derived based on the selected PhasorProtocol, TransportProtocol and ConnectionString, but can be overridden if the consumer already knows that a device supports commands.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.Enabled Property

Grid Solutions Framework MultiProtocolFrameParserEnabled Property
Gets or sets a boolean value that indicates whether the MultiProtocolFrameParser is currently enabled.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IFrameParserEnabled
Remarks
Setting Enabled to true will start the MultiProtocolFrameParser if it is not started, setting to false will stop the MultiProtocolFrameParser if it is started.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.InjectSimulatedTimestamp Property

Grid Solutions Framework MultiProtocolFrameParserInjectSimulatedTimestamp Property
Gets or sets flag indicating whether or not to inject local system time into parsed data frames.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool InjectSimulatedTimestamp { get; set; }
Public Property InjectSimulatedTimestamp As Boolean
    Get
    Set
member InjectSimulatedTimestamp : bool with get, set

function get_InjectSimulatedTimestamp();
function set_InjectSimulatedTimestamp(value);
public:
property bool InjectSimulatedTimestamp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
When connection is made to a file for replay purposes or consumer doesn't trust remote clock source, this flag can be set to true replace all frame timestamps with a UTC timestamp derived from the local system clock.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.IsConnected Property

Grid Solutions Framework MultiProtocolFrameParserIsConnected Property
Gets a flag that determines if the currently selected TransportProtocol is connected.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
member IsConnected : bool with get

function get_IsConnected();

public:
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.IsIEEEProtocol Property

Grid Solutions Framework MultiProtocolFrameParserIsIEEEProtocol Property
Gets a flag that determines if the currently selected PhasorProtocol is an IEEE standard protocol.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsIEEEProtocol { get; }
Public ReadOnly Property IsIEEEProtocol As Boolean
    Get
member IsIEEEProtocol : bool with get

function get_IsIEEEProtocol();

public:
property bool IsIEEEProtocol {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.KeepCommandChannelOpen Property

Grid Solutions Framework MultiProtocolFrameParserKeepCommandChannelOpen Property
Gets or sets flag that determines whether to keep the command channel open after the initial startup sequence.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool KeepCommandChannelOpen { get; set; }
Public Property KeepCommandChannelOpen As Boolean
    Get
    Set
member KeepCommandChannelOpen : bool with get, set

function get_KeepCommandChannelOpen();
function set_KeepCommandChannelOpen(value);
public:
property bool KeepCommandChannelOpen {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.MaximumConnectionAttempts Property

Grid Solutions Framework MultiProtocolFrameParserMaximumConnectionAttempts Property
Gets or sets the maximum number of times the MultiProtocolFrameParser will attempt to connect to a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaximumConnectionAttempts { get; set; }
Public Property MaximumConnectionAttempts As Integer
    Get
    Set
member MaximumConnectionAttempts : int with get, set

function get_MaximumConnectionAttempts();
function set_MaximumConnectionAttempts(value);
public:
property int MaximumConnectionAttempts {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Set to -1 for infinite connection attempts.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.MegaBitRate Property

Grid Solutions Framework MultiProtocolFrameParserMegaBitRate Property
Gets the calculated megabits per second (Mbps) rate based on data received from device connection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double MegaBitRate { get; }
Public ReadOnly Property MegaBitRate As Double
    Get
member MegaBitRate : float with get

function get_MegaBitRate();

public:
property double MegaBitRate {
    double get ();
}

Property Value

Type: Double
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.Name Property

Grid Solutions Framework MultiProtocolFrameParserName Property
Gets a descriptive name for a device connection that includes SourceName, if provided.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ParsingExceptionWindow Property

Grid Solutions Framework MultiProtocolFrameParserParsingExceptionWindow Property
Gets or sets time duration, in Ticks, to monitor parsing exceptions.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks ParsingExceptionWindow { get; set; }
Public Property ParsingExceptionWindow As Ticks
    Get
    Set
member ParsingExceptionWindow : Ticks with get, set

function get_ParsingExceptionWindow();
function set_ParsingExceptionWindow(value);
public:
property Ticks ParsingExceptionWindow {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.PhasorProtocol Property

Grid Solutions Framework MultiProtocolFrameParserPhasorProtocol Property
Gets or sets PhasorProtocol to use with this MultiProtocolFrameParser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorProtocol PhasorProtocol { get; set; }
Public Property PhasorProtocol As PhasorProtocol
    Get
    Set
member PhasorProtocol : PhasorProtocol with get, set

function get_PhasorProtocol();
function set_PhasorProtocol(value);
public:
property PhasorProtocol PhasorProtocol {
    PhasorProtocol get ();
    void set (PhasorProtocol value);
}

Property Value

Type: PhasorProtocol
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.QueuedBuffers Property

Grid Solutions Framework MultiProtocolFrameParserQueuedBuffers Property
Gets the total number of buffers that are currently queued for processing, if any.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int QueuedBuffers { get; }
Public ReadOnly Property QueuedBuffers As Integer
    Get
abstract QueuedBuffers : int with get
override QueuedBuffers : int with get
function get_QueuedBuffers();

public:
virtual property int QueuedBuffers {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IFrameParserQueuedBuffers
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.QueuedOutputs Property

Grid Solutions Framework MultiProtocolFrameParserQueuedOutputs Property
Gets the total number of frames that are currently queued for publication, if any.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int QueuedOutputs { get; }
Public ReadOnly Property QueuedOutputs As Integer
    Get
abstract QueuedOutputs : int with get
override QueuedOutputs : int with get
function get_QueuedOutputs();

public:
virtual property int QueuedOutputs {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IFrameParserQueuedOutputs
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.RedundantFramesPerPacket Property

Grid Solutions Framework MultiProtocolFrameParserRedundantFramesPerPacket Property
Gets the number of redundant frames in each packet.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int RedundantFramesPerPacket { get; }
Public ReadOnly Property RedundantFramesPerPacket As Integer
    Get
abstract RedundantFramesPerPacket : int with get
override RedundantFramesPerPacket : int with get
function get_RedundantFramesPerPacket();

public:
virtual property int RedundantFramesPerPacket {
    int get () sealed;
}

Property Value

Type: Int32

Implements

IFrameParserRedundantFramesPerPacket
Remarks
This value is used when calculating statistics. It is assumed that for each frame that is received, that frame will be included in the next n packets, where n is the number of redundant frames per packet.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.SkipDisableRealTimeData Property

Grid Solutions Framework MultiProtocolFrameParserSkipDisableRealTimeData Property
Gets or sets flag to skip automatic disabling of the real-time data stream on shutdown or startup.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SkipDisableRealTimeData { get; set; }
Public Property SkipDisableRealTimeData As Boolean
    Get
    Set
member SkipDisableRealTimeData : bool with get, set

function get_SkipDisableRealTimeData();
function set_SkipDisableRealTimeData(value);
public:
property bool SkipDisableRealTimeData {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This flag may important when using UDP multicast with several subscribed clients.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.SourceName Property

Grid Solutions Framework MultiProtocolFrameParserSourceName Property
Gets or sets a descriptive name for a device connection.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SourceName { get; set; }
Public Property SourceName As String
    Get
    Set
member SourceName : string with get, set

function get_SourceName();
function set_SourceName(value);
public:
property String^ SourceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.Status Property

Grid Solutions Framework MultiProtocolFrameParserStatus Property
Gets current descriptive status of the MultiProtocolFrameParser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.TotalBytesReceived Property

Grid Solutions Framework MultiProtocolFrameParserTotalBytesReceived Property
Gets total number of bytes that have been received from a device so far.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalBytesReceived { get; }
Public ReadOnly Property TotalBytesReceived As Long
    Get
member TotalBytesReceived : int64 with get

function get_TotalBytesReceived();

public:
property long long TotalBytesReceived {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.TotalCrcExceptions Property

Grid Solutions Framework MultiProtocolFrameParserTotalCrcExceptions Property
Gets total number of CRC exceptions encountered from device so far.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalCrcExceptions { get; }
Public ReadOnly Property TotalCrcExceptions As Long
    Get
member TotalCrcExceptions : int64 with get

function get_TotalCrcExceptions();

public:
property long long TotalCrcExceptions {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.TotalFramesReceived Property

Grid Solutions Framework MultiProtocolFrameParserTotalFramesReceived Property
Gets total number of frames that have been received from a device so far.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalFramesReceived { get; }
Public ReadOnly Property TotalFramesReceived As Long
    Get
member TotalFramesReceived : int64 with get

function get_TotalFramesReceived();

public:
property long long TotalFramesReceived {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.TotalMissingFrames Property

Grid Solutions Framework MultiProtocolFrameParserTotalMissingFrames Property
Gets total number of frames that were missing from device so far.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalMissingFrames { get; }
Public ReadOnly Property TotalMissingFrames As Long
    Get
member TotalMissingFrames : int64 with get

function get_TotalMissingFrames();

public:
property long long TotalMissingFrames {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.TransportProtocol Property

Grid Solutions Framework MultiProtocolFrameParserTransportProtocol Property
Gets or sets TransportProtocol to use with this MultiProtocolFrameParser.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TransportProtocol TransportProtocol { get; set; }
Public Property TransportProtocol As TransportProtocol
    Get
    Set
member TransportProtocol : TransportProtocol with get, set

function get_TransportProtocol();
function set_TransportProtocol(value);
public:
property TransportProtocol TransportProtocol {
    TransportProtocol get ();
    void set (TransportProtocol value);
}

Property Value

Type: TransportProtocol
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.TrustHeaderLength Property

Grid Solutions Framework MultiProtocolFrameParserTrustHeaderLength Property
Gets or sets flag that determines if header lengths should be trusted over parsed byte count.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TrustHeaderLength { get; set; }
Public Property TrustHeaderLength As Boolean
    Get
    Set
abstract TrustHeaderLength : bool with get, set
override TrustHeaderLength : bool with get, set
function get_TrustHeaderLength();
function set_TrustHeaderLength(value);
public:
virtual property bool TrustHeaderLength {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IFrameParserTrustHeaderLength
Remarks
It is expected that this will normally be left as true.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.UseHighResolutionInputTimer Property

Grid Solutions Framework MultiProtocolFrameParserUseHighResolutionInputTimer Property
Gets or sets flag that determines if a high-resolution precision timer should be used for file based input.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseHighResolutionInputTimer { get; set; }
Public Property UseHighResolutionInputTimer As Boolean
    Get
    Set
member UseHighResolutionInputTimer : bool with get, set

function get_UseHighResolutionInputTimer();
function set_UseHighResolutionInputTimer(value);
public:
property bool UseHighResolutionInputTimer {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Useful when input frames need be accurately time-aligned to the local clock to better simulate an input device and calculate downstream latencies.
This is only applicable when connection is made to a file for replay purposes.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser Events

Grid Solutions Framework MultiProtocolFrameParser Events

The MultiProtocolFrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed.
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed.
Public event | ConnectionAttempt | Occurs when MultiProtocolFrameParser is attempting connection to a device.
Public event | ConnectionEstablished | Occurs when MultiProtocolFrameParser has established a connection to a device.
Public event | ConnectionException | Occurs when an Exception is encountered during connection attempt to a device.
Public event | ConnectionTerminated | Occurs when device connection has been terminated.
Public event | ExceededParsingExceptionThreshold | Occurs when number of parsing exceptions exceed AllowedParsingExceptions during ParsingExceptionWindow.
Public event | ParsingException | Occurs when an Exception is encountered while parsing the data stream.
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a IDataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame buffer image has been received.
Public event | ReceivedFrameImage | Occurs when a frame image has been received.
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received.
Public event | SentCommandFrame | Occurs when a ICommandFrame is sent to a device.
Public event | ServerStarted | Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been started.
Public event | ServerStopped | Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been stopped.
Top
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.BufferParsed Event

Grid Solutions Framework MultiProtocolFrameParserBufferParsed Event
Occurs when buffer parsing has completed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler BufferParsed
Public Event BufferParsed As EventHandler
abstract BufferParsed : IEvent<EventHandler,
    EventArgs>
override BufferParsed : IEvent<EventHandler,
    EventArgs>
function add_BufferParsed(value);
function remove_BufferParsed(value);
public:
virtual  event EventHandler^ BufferParsed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IFrameParserBufferParsed
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConfigurationChanged Event

Grid Solutions Framework MultiProtocolFrameParserConfigurationChanged Event
Occurs when a device sends a notification that its configuration has changed.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
override ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
public:
virtual  event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IFrameParserConfigurationChanged
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionAttempt Event

Grid Solutions Framework MultiProtocolFrameParserConnectionAttempt Event
Occurs when MultiProtocolFrameParser is attempting connection to a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionAttempt
Public Event ConnectionAttempt As EventHandler
member ConnectionAttempt : IEvent<EventHandler,
    EventArgs>

function add_ConnectionAttempt(value);
function remove_ConnectionAttempt(value);
public:
 event EventHandler^ ConnectionAttempt {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionEstablished Event

Grid Solutions Framework MultiProtocolFrameParserConnectionEstablished Event
Occurs when MultiProtocolFrameParser has established a connection to a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionEstablished
Public Event ConnectionEstablished As EventHandler
member ConnectionEstablished : IEvent<EventHandler,
    EventArgs>

function add_ConnectionEstablished(value);
function remove_ConnectionEstablished(value);
public:
 event EventHandler^ ConnectionEstablished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionException Event

Grid Solutions Framework MultiProtocolFrameParserConnectionException Event
Occurs when an Exception is encountered during connection attempt to a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception, int>> ConnectionException
Public Event ConnectionException As EventHandler(Of EventArgs(Of Exception, Integer))
member ConnectionException : IEvent<EventHandler<EventArgs<Exception, int>>,
    EventArgs<Exception, int>>

function add_ConnectionException(value);
function remove_ConnectionException(value);
public:
 event EventHandler<EventArgs<Exception^, int>^>^ ConnectionException {
    void add (EventHandler<EventArgs<Exception^, int>^>^ value);
    void remove (EventHandler<EventArgs<Exception^, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception, Int32
Remarks
Argument1 is the exception that occurred during the connection attempt.
Argument2 is the number of connections attempted so far.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ConnectionTerminated Event

Grid Solutions Framework MultiProtocolFrameParserConnectionTerminated Event
Occurs when device connection has been terminated.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionTerminated
Public Event ConnectionTerminated As EventHandler
member ConnectionTerminated : IEvent<EventHandler,
    EventArgs>

function add_ConnectionTerminated(value);
function remove_ConnectionTerminated(value);
public:
 event EventHandler^ ConnectionTerminated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ExceededParsingExceptionThreshold Event

Grid Solutions Framework MultiProtocolFrameParserExceededParsingExceptionThreshold Event
Occurs when number of parsing exceptions exceed AllowedParsingExceptions during ParsingExceptionWindow.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ExceededParsingExceptionThreshold
Public Event ExceededParsingExceptionThreshold As EventHandler
member ExceededParsingExceptionThreshold : IEvent<EventHandler,
    EventArgs>

function add_ExceededParsingExceptionThreshold(value);
function remove_ExceededParsingExceptionThreshold(value);
public:
 event EventHandler^ ExceededParsingExceptionThreshold {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ParsingException Event

Grid Solutions Framework MultiProtocolFrameParserParsingException Event
Occurs when an Exception is encountered while parsing the data stream.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ParsingException
Public Event ParsingException As EventHandler(Of EventArgs(Of Exception))
abstract ParsingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ParsingException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ParsingException(value);
function remove_ParsingException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ParsingException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IFrameParserParsingException
Remarks
Argument is the Exception encountered while parsing the data stream.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ReceivedCommandFrame Event

Grid Solutions Framework MultiProtocolFrameParserReceivedCommandFrame Event
Occurs when a ICommandFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
abstract ReceivedCommandFrame : IEvent<EventHandler<EventArgs<ICommandFrame>>,
    EventArgs<ICommandFrame>>
override ReceivedCommandFrame : IEvent<EventHandler<EventArgs<ICommandFrame>>,
    EventArgs<ICommandFrame>>
function add_ReceivedCommandFrame(value);
function remove_ReceivedCommandFrame(value);
public:
virtual  event EventHandler<EventArgs<ICommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICommandFrame

Implements

IFrameParserReceivedCommandFrame
Remarks
Argument is the ICommandFrame that was received.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework MultiProtocolFrameParserReceivedConfigurationFrame Event
Occurs when a IConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of IConfigurationFrame))
abstract ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<IConfigurationFrame>>,
    EventArgs<IConfigurationFrame>>
override ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<IConfigurationFrame>>,
    EventArgs<IConfigurationFrame>>
function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
virtual  event EventHandler<EventArgs<IConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IConfigurationFrame

Implements

IFrameParserReceivedConfigurationFrame
Remarks
Argument is the IConfigurationFrame that was received.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ReceivedDataFrame Event

Grid Solutions Framework MultiProtocolFrameParserReceivedDataFrame Event
Occurs when a IDataFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IDataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of IDataFrame))
abstract ReceivedDataFrame : IEvent<EventHandler<EventArgs<IDataFrame>>,
    EventArgs<IDataFrame>>
override ReceivedDataFrame : IEvent<EventHandler<EventArgs<IDataFrame>>,
    EventArgs<IDataFrame>>
function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
virtual  event EventHandler<EventArgs<IDataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<IDataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IDataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IDataFrame

Implements

IFrameParserReceivedDataFrame
Remarks
Argument is the IDataFrame that was received.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ReceivedFrameBufferImage Event

Grid Solutions Framework MultiProtocolFrameParserReceivedFrameBufferImage Event
Occurs when a frame buffer image has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>> ReceivedFrameBufferImage
Public Event ReceivedFrameBufferImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Byte(), Integer, Integer))
abstract ReceivedFrameBufferImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>>,
    EventArgs<FundamentalFrameType, byte[], int, int>>
override ReceivedFrameBufferImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, byte[], int, int>>,
    EventArgs<FundamentalFrameType, byte[], int, int>>
function add_ReceivedFrameBufferImage(value);
function remove_ReceivedFrameBufferImage(value);
public:
virtual  event EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ ReceivedFrameBufferImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, array<unsigned char>^, int, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FundamentalFrameType, Byte , Int32, Int32

Implements

IFrameParserReceivedFrameBufferImage
Remarks

Argument1 is the FundamentalFrameType of the frame buffer image that was received.
Argument2 is the buffer that contains the frame image that was received.
Argument3 is the offset into the buffer that contains the frame image that was received.
Argument4 is the length of data in the buffer that contains the frame image that was received.

Consumers should use the more efficient ReceivedFrameImage event if the buffer is not needed.

See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ReceivedFrameImage Event

Grid Solutions Framework MultiProtocolFrameParserReceivedFrameImage Event
Occurs when a frame image has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<FundamentalFrameType, int>> ReceivedFrameImage
Public Event ReceivedFrameImage As EventHandler(Of EventArgs(Of FundamentalFrameType, Integer))
abstract ReceivedFrameImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, int>>,
    EventArgs<FundamentalFrameType, int>>
override ReceivedFrameImage : IEvent<EventHandler<EventArgs<FundamentalFrameType, int>>,
    EventArgs<FundamentalFrameType, int>>
function add_ReceivedFrameImage(value);
function remove_ReceivedFrameImage(value);
public:
virtual  event EventHandler<EventArgs<FundamentalFrameType, int>^>^ ReceivedFrameImage {
    void add (EventHandler<EventArgs<FundamentalFrameType, int>^>^ value);
    void remove (EventHandler<EventArgs<FundamentalFrameType, int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs FundamentalFrameType, Int32

Implements

IFrameParserReceivedFrameImage
Remarks
Argument1 is the FundamentalFrameType of the frame buffer image that was received.
Argument2 is the length of the frame image that was received.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ReceivedHeaderFrame Event

Grid Solutions Framework MultiProtocolFrameParserReceivedHeaderFrame Event
Occurs when a IHeaderFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IHeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of IHeaderFrame))
abstract ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<IHeaderFrame>>,
    EventArgs<IHeaderFrame>>
override ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<IHeaderFrame>>,
    EventArgs<IHeaderFrame>>
function add_ReceivedHeaderFrame(value);
function remove_ReceivedHeaderFrame(value);
public:
virtual  event EventHandler<EventArgs<IHeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IHeaderFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IHeaderFrame

Implements

IFrameParserReceivedHeaderFrame
Remarks
Argument is the IHeaderFrame that was received.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ReceivedUndeterminedFrame Event

Grid Solutions Framework MultiProtocolFrameParserReceivedUndeterminedFrame Event
Occurs when an undetermined IChannelFrame has been received.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IChannelFrame>> ReceivedUndeterminedFrame
Public Event ReceivedUndeterminedFrame As EventHandler(Of EventArgs(Of IChannelFrame))
abstract ReceivedUndeterminedFrame : IEvent<EventHandler<EventArgs<IChannelFrame>>,
    EventArgs<IChannelFrame>>
override ReceivedUndeterminedFrame : IEvent<EventHandler<EventArgs<IChannelFrame>>,
    EventArgs<IChannelFrame>>
function add_ReceivedUndeterminedFrame(value);
function remove_ReceivedUndeterminedFrame(value);
public:
virtual  event EventHandler<EventArgs<IChannelFrame^>^>^ ReceivedUndeterminedFrame {
    void add (EventHandler<EventArgs<IChannelFrame^>^>^ value);
    void remove (EventHandler<EventArgs<IChannelFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IChannelFrame

Implements

IFrameParserReceivedUndeterminedFrame
Remarks
Argument is the undetermined IChannelFrame that was received.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.SentCommandFrame Event

Grid Solutions Framework MultiProtocolFrameParserSentCommandFrame Event
Occurs when a ICommandFrame is sent to a device.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICommandFrame>> SentCommandFrame
Public Event SentCommandFrame As EventHandler(Of EventArgs(Of ICommandFrame))
member SentCommandFrame : IEvent<EventHandler<EventArgs<ICommandFrame>>,
    EventArgs<ICommandFrame>>

function add_SentCommandFrame(value);
function remove_SentCommandFrame(value);
public:
 event EventHandler<EventArgs<ICommandFrame^>^>^ SentCommandFrame {
    void add (EventHandler<EventArgs<ICommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ICommandFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICommandFrame
Remarks
Argument is a reference to the ICommandFrame that was sent to the device.
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ServerStarted Event

Grid Solutions Framework MultiProtocolFrameParserServerStarted Event
Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been started.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServerStarted
Public Event ServerStarted As EventHandler
member ServerStarted : IEvent<EventHandler,
    EventArgs>

function add_ServerStarted(value);
function remove_ServerStarted(value);
public:
 event EventHandler^ ServerStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


MultiProtocolFrameParser.ServerStopped Event

Grid Solutions Framework MultiProtocolFrameParserServerStopped Event
Occurs when the MultiProtocolFrameParser is setup as a listening connection and server connection has been stopped.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServerStopped
Public Event ServerStopped As EventHandler
member ServerStopped : IEvent<EventHandler,
    EventArgs>

function add_ServerStopped(value);
function remove_ServerStopped(value);
public:
 event EventHandler^ ServerStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

MultiProtocolFrameParser Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase Class

Grid Solutions Framework PhasorDefinitionBase Class
Represents the common implementation of the protocol independent definition of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class PhasorDefinitionBase : ChannelDefinitionBase,
    IPhasorDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition>, IComparable<IChannelDefinition>, IComparable
<SerializableAttribute>
Public MustInherit Class PhasorDefinitionBase
    Inherits ChannelDefinitionBase
    Implements IPhasorDefinition, IChannelDefinition, IChannel, ISupportBinaryImage,
    ISerializable, IEquatable(Of IChannelDefinition), IComparable(Of IChannelDefinition),
    IComparable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type PhasorDefinitionBase =
    class
        inherit ChannelDefinitionBase
        interface IPhasorDefinition
        interface IChannelDefinition
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
        interface IEquatable<IChannelDefinition>
        interface IComparable<IChannelDefinition>
        interface IComparable
    end
GSF.PhasorProtocols.PhasorDefinitionBase = function();

Type.createClass(
    'GSF.PhasorProtocols.PhasorDefinitionBase',
    GSF.PhasorProtocols.ChannelDefinitionBase,
    GSF.PhasorProtocols.IPhasorDefinition,
    GSF.PhasorProtocols.IChannelDefinition,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable,
    IEquatable`1,
    IComparable`1,
    IComparable);
[SerializableAttribute]
public ref class PhasorDefinitionBase abstract : public ChannelDefinitionBase,
    IPhasorDefinition, IChannelDefinition, IChannel, ISupportBinaryImage, ISerializable,
    IEquatable<IChannelDefinition^>, IComparable<IChannelDefinition^>, IComparable

The PhasorDefinitionBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorDefinitionBase(IConfigurationCell) | Creates a new PhasorDefinitionBase.
Protected method | PhasorDefinitionBase(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionBase from serialization parameters.
Protected method | PhasorDefinitionBase(IConfigurationCell, String, UInt32, Double, PhasorType, IPhasorDefinition) | Creates a new PhasorDefinitionBase from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Overrides ChannelDefinitionBaseToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase.
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.AnonymousPhasorDefinition
GSF.PhasorProtocols.BPAPDCstreamPhasorDefinition
GSF.PhasorProtocols.FNETPhasorDefinition
GSF.PhasorProtocols.IEC61850_90_5PhasorDefinition
GSF.PhasorProtocols.IEEE1344PhasorDefinition
GSF.PhasorProtocols.IEEEC37_118PhasorDefinition
GSF.PhasorProtocols.MacrodynePhasorDefinition
GSF.PhasorProtocols.SelFastMessagePhasorDefinition


PhasorDefinitionBase Constructor

Grid Solutions Framework PhasorDefinitionBase Constructor
Overload List
 | Name | Description
Protected method | PhasorDefinitionBase(IConfigurationCell) | Creates a new PhasorDefinitionBase.
Protected method | PhasorDefinitionBase(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionBase from serialization parameters.
Protected method | PhasorDefinitionBase(IConfigurationCell, String, UInt32, Double, PhasorType, IPhasorDefinition) | Creates a new PhasorDefinitionBase from specified parameters.
Top
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinitionBase Constructor (IConfigurationCell)
Creates a new PhasorDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinitionBase(
    IConfigurationCell parent
)
Protected Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinitionBase
GSF.PhasorProtocols.PhasorDefinitionBase = function(parent);
protected:
PhasorDefinitionBase(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinitionBase.
See Also

Reference

PhasorDefinitionBase Class
PhasorDefinitionBase Overload
GSF.PhasorProtocols Namespace


PhasorDefinitionBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinitionBase Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinitionBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinitionBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinitionBase
GSF.PhasorProtocols.PhasorDefinitionBase = function(info, context);
protected:
PhasorDefinitionBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinitionBase Class
PhasorDefinitionBase Overload
GSF.PhasorProtocols Namespace


PhasorDefinitionBase Constructor (IConfigurationCell, String, UInt32, Double, PhasorType, IPhasorDefinition)

Grid Solutions Framework PhasorDefinitionBase Constructor (IConfigurationCell, String, UInt32, Double, PhasorType, IPhasorDefinition)
Creates a new PhasorDefinitionBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinitionBase(
    IConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    IPhasorDefinition voltageReference
)
Protected Sub New (
    parent As IConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As PhasorType,
    voltageReference As IPhasorDefinition
)
new :
        parent : IConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : PhasorType *
        voltageReference : IPhasorDefinition -> PhasorDefinitionBase
GSF.PhasorProtocols.PhasorDefinitionBase = function(parent, label, scale, offset, type, voltageReference);
protected:
PhasorDefinitionBase(
    IConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    IPhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinitionBase.
label
Type: SystemString
The label of this PhasorDefinitionBase.
scale
Type: SystemUInt32
The integer scaling value of this PhasorDefinitionBase.
offset
Type: SystemDouble
The offset of this PhasorDefinitionBase.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinitionBase.
voltageReference
Type: GSF.PhasorProtocolsIPhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinitionBase Class
PhasorDefinitionBase Overload
GSF.PhasorProtocols Namespace


PhasorDefinitionBase Methods

Grid Solutions Framework PhasorDefinitionBase Methods

The PhasorDefinitionBase type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Overrides ChannelDefinitionBaseToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.GetObjectData Method

Grid Solutions Framework PhasorDefinitionBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.ToString Method

Grid Solutions Framework PhasorDefinitionBaseToString Method
Gets the string respresentation of this PhasorDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
String respresentation of this PhasorDefinitionBase.
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase Properties

Grid Solutions Framework PhasorDefinitionBase Properties

The PhasorDefinitionBase type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase.
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Overrides ChannelDefinitionBaseDataFormat.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the IConfigurationCell parent of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).
Top
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.AngleFormat Property

Grid Solutions Framework PhasorDefinitionBaseAngleFormat Property
Gets or sets the AngleFormat of this PhasorDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AngleFormat AngleFormat { get; }
Public Overridable ReadOnly Property AngleFormat As AngleFormat
    Get
abstract AngleFormat : AngleFormat with get
override AngleFormat : AngleFormat with get
function get_AngleFormat();

public:
virtual property AngleFormat AngleFormat {
    AngleFormat get ();
}

Property Value

Type: AngleFormat

Implements

IPhasorDefinitionAngleFormat
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.Attributes Property

Grid Solutions Framework PhasorDefinitionBaseAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.CoordinateFormat Property

Grid Solutions Framework PhasorDefinitionBaseCoordinateFormat Property
Gets or sets the CoordinateFormat of this PhasorDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CoordinateFormat CoordinateFormat { get; }
Public Overridable ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
abstract CoordinateFormat : CoordinateFormat with get
override CoordinateFormat : CoordinateFormat with get
function get_CoordinateFormat();

public:
virtual property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}

Property Value

Type: CoordinateFormat

Implements

IPhasorDefinitionCoordinateFormat
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.DataFormat Property

Grid Solutions Framework PhasorDefinitionBaseDataFormat Property
Gets the DataFormat of this PhasorDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat DataFormat { get; }
Public Overrides ReadOnly Property DataFormat As DataFormat
    Get
abstract DataFormat : DataFormat with get
override DataFormat : DataFormat with get
function get_DataFormat();

public:
virtual property DataFormat DataFormat {
    DataFormat get () override;
}

Property Value

Type: DataFormat

Implements

IChannelDefinitionDataFormat
IChannelDefinitionDataFormat
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.PhasorType Property

Grid Solutions Framework PhasorDefinitionBasePhasorType Property
Gets or sets the PhasorType of this PhasorDefinitionBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorType PhasorType { get; set; }
Public Overridable Property PhasorType As PhasorType
    Get
    Set
abstract PhasorType : PhasorType with get, set
override PhasorType : PhasorType with get, set
function get_PhasorType();
function set_PhasorType(value);
public:
virtual property PhasorType PhasorType {
    PhasorType get ();
    void set (PhasorType value);
}

Property Value

Type: PhasorType

Implements

IPhasorDefinitionPhasorType
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionBase.VoltageReference Property

Grid Solutions Framework PhasorDefinitionBaseVoltageReference Property
Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any).

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IPhasorDefinition VoltageReference { get; set; }
Public Overridable Property VoltageReference As IPhasorDefinition
    Get
    Set
abstract VoltageReference : IPhasorDefinition with get, set
override VoltageReference : IPhasorDefinition with get, set
function get_VoltageReference();
function set_VoltageReference(value);
public:
virtual property IPhasorDefinition^ VoltageReference {
    IPhasorDefinition^ get ();
    void set (IPhasorDefinition^ value);
}

Property Value

Type: IPhasorDefinition

Implements

IPhasorDefinitionVoltageReference
Remarks
This only applies to current phasors.
See Also

Reference

PhasorDefinitionBase Class
GSF.PhasorProtocols Namespace


PhasorDefinitionCollection Class

Grid Solutions Framework PhasorDefinitionCollection Class
Represents a protocol independent collection of IPhasorDefinition objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IPhasorDefinition
GSF.CollectionsListCollection IPhasorDefinition
GSF.PhasorProtocolsChannelCollectionBase IPhasorDefinition
GSF.PhasorProtocolsChannelDefinitionCollectionBase IPhasorDefinition
GSF.PhasorProtocolsPhasorDefinitionCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinitionCollection : ChannelDefinitionCollectionBase<IPhasorDefinition>
<SerializableAttribute>
Public Class PhasorDefinitionCollection
    Inherits ChannelDefinitionCollectionBase(Of IPhasorDefinition)
[<SerializableAttribute>]
type PhasorDefinitionCollection =
    class
        inherit ChannelDefinitionCollectionBase<IPhasorDefinition>
    end
GSF.PhasorProtocols.PhasorDefinitionCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.PhasorDefinitionCollection',
    GSF.PhasorProtocols.ChannelDefinitionCollectionBase`1);
[SerializableAttribute]
public ref class PhasorDefinitionCollection : public ChannelDefinitionCollectionBase<IPhasorDefinition^>

The PhasorDefinitionCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinitionCollection(Int32) | Creates a new PhasorDefinitionCollection using specified lastValidIndex.
Protected method | PhasorDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


PhasorDefinitionCollection Constructor

Grid Solutions Framework PhasorDefinitionCollection Constructor
Overload List
 | Name | Description
Public method | PhasorDefinitionCollection(Int32) | Creates a new PhasorDefinitionCollection using specified lastValidIndex.
Protected method | PhasorDefinitionCollection(SerializationInfo, StreamingContext) | Creates a new PhasorDefinitionCollection from serialization parameters.
Top
See Also

Reference

PhasorDefinitionCollection Class
GSF.PhasorProtocols Namespace


PhasorDefinitionCollection Constructor (Int32)

Grid Solutions Framework PhasorDefinitionCollection Constructor (Int32)
Creates a new PhasorDefinitionCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinitionCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> PhasorDefinitionCollection
GSF.PhasorProtocols.PhasorDefinitionCollection = function(lastValidIndex);
public:
PhasorDefinitionCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

PhasorDefinitionCollection Class
PhasorDefinitionCollection Overload
GSF.PhasorProtocols Namespace


PhasorDefinitionCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinitionCollection Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinitionCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinitionCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinitionCollection
GSF.PhasorProtocols.PhasorDefinitionCollection = function(info, context);
protected:
PhasorDefinitionCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinitionCollection Class
PhasorDefinitionCollection Overload
GSF.PhasorProtocols Namespace


PhasorDefinitionCollection Methods

Grid Solutions Framework PhasorDefinitionCollection Methods

The PhasorDefinitionCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelDefinitionCollectionBaseT at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelDefinitionCollectionBaseT. (Inherited from ChannelDefinitionCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelDefinitionCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinitionCollection Class
GSF.PhasorProtocols Namespace


PhasorDefinitionCollection Properties

Grid Solutions Framework PhasorDefinitionCollection Properties

The PhasorDefinitionCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

PhasorDefinitionCollection Class
GSF.PhasorProtocols Namespace


PhasorDefinitionCollection Events

Grid Solutions Framework PhasorDefinitionCollection Events

The PhasorDefinitionCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

PhasorDefinitionCollection Class
GSF.PhasorProtocols Namespace


PhasorProtocol Enumeration

Grid Solutions Framework PhasorProtocol Enumeration
Phasor data protocols enumeration.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum PhasorProtocol
<SerializableAttribute>
Public Enumeration PhasorProtocol
[<SerializableAttribute>]
type PhasorProtocol
GSF.PhasorProtocols.PhasorProtocol = function();
GSF.PhasorProtocols.PhasorProtocol.createEnum('GSF.PhasorProtocols.PhasorProtocol', false);
[SerializableAttribute]
public enum class PhasorProtocol
Members
Member name | Value | Description
IEEEC37_118V2 | 0 | IEEE C37.118.2-2011 protocol.
IEEEC37_118V1 | 1 | IEEE C37.118-2005 protocol.
IEEEC37_118D6 | 2 | IEEE C37.118, draft 6 protocol.
IEEE1344 | 3 | IEEE 1344-1995 protocol.
BPAPDCstream | 4 | BPA PDCstream protocol.
FNET | 5 | UTK F-NET protocol.
SelFastMessage | 6 | SEL Fast Message protocol.
Macrodyne | 7 | Macrodyne protocol.
IEC61850_90_5 | 8 | IEC 61850-90-5 protocol.
See Also

Reference

GSF.PhasorProtocols Namespace


PhasorValueBase Class

Grid Solutions Framework PhasorValueBase Class
Represents the common implementation of the protocol independent representation of a phasor value.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
More...

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public abstract class PhasorValueBase : ChannelValueBase<IPhasorDefinition>,
    IPhasorValue, IChannelValue<IPhasorDefinition>, IChannel, ISupportBinaryImage,
    ISerializable
<SerializableAttribute>
Public MustInherit Class PhasorValueBase
    Inherits ChannelValueBase(Of IPhasorDefinition)
    Implements IPhasorValue, IChannelValue(Of IPhasorDefinition),
    IChannel, ISupportBinaryImage, ISerializable
[<AbstractClassAttribute>]
[<SerializableAttribute>]
type PhasorValueBase =
    class
        inherit ChannelValueBase<IPhasorDefinition>
        interface IPhasorValue
        interface IChannelValue<IPhasorDefinition>
        interface IChannel
        interface ISupportBinaryImage
        interface ISerializable
    end
GSF.PhasorProtocols.PhasorValueBase = function();

Type.createClass(
    'GSF.PhasorProtocols.PhasorValueBase',
    GSF.PhasorProtocols.ChannelValueBase`1,
    GSF.PhasorProtocols.IPhasorValue,
    GSF.PhasorProtocols.IChannelValue`1,
    GSF.PhasorProtocols.IChannel,
    GSF.Parsing.ISupportBinaryImage,
    ISerializable);
[SerializableAttribute]
public ref class PhasorValueBase abstract : public ChannelValueBase<IPhasorDefinition^>,
    IPhasorValue, IChannelValue<IPhasorDefinition^>, IChannel, ISupportBinaryImage,
    ISerializable

The PhasorValueBase type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValueBase(SerializationInfo, StreamingContext) | Creates a new PhasorValueBase from serialization parameters.
Protected method | PhasorValueBase(IDataCell, IPhasorDefinition) | Creates a new PhasorValueBase.
Protected method | PhasorValueBase(IDataCell, IPhasorDefinition, Angle, Double) | Creates a new PhasorValueBase from specified parameters.
Protected method | PhasorValueBase(IDataCell, IPhasorDefinition, Double, Double) | Creates a new PhasorValueBase from specified parameters.
Top
Methods
 | Name | Description
 | AverageAngleValueFilter | Calculates an average of the specified sequence of IMeasurement phase angle values.
 | CalculatePower | Calculates watts from imaginary and real components of a voltage and current phasor.
 | CalculateVars | Calculates vars (total volt-amperes of reactive power) from imaginary and real components of a voltage and current phasor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Overrides ChannelValueBaseTGetMeasurementValueFilterFunction(Int32).)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians.
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase.
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase.
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Real | Gets or sets the real value of this PhasorValueBase.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase.
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase.
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase.
Top
See Also

Reference

GSF.PhasorProtocols Namespace
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.BPAPDCstreamPhasorValue
GSF.PhasorProtocols.FNETPhasorValue
GSF.PhasorProtocols.IEC61850_90_5PhasorValue
GSF.PhasorProtocols.IEEE1344PhasorValue
GSF.PhasorProtocols.IEEEC37_118PhasorValue
GSF.PhasorProtocols.MacrodynePhasorValue
GSF.PhasorProtocols.SelFastMessagePhasorValue


PhasorValueBase Constructor

Grid Solutions Framework PhasorValueBase Constructor
Overload List
 | Name | Description
Protected method | PhasorValueBase(SerializationInfo, StreamingContext) | Creates a new PhasorValueBase from serialization parameters.
Protected method | PhasorValueBase(IDataCell, IPhasorDefinition) | Creates a new PhasorValueBase.
Protected method | PhasorValueBase(IDataCell, IPhasorDefinition, Angle, Double) | Creates a new PhasorValueBase from specified parameters.
Protected method | PhasorValueBase(IDataCell, IPhasorDefinition, Double, Double) | Creates a new PhasorValueBase from specified parameters.
Top
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValueBase Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValueBase from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValueBase(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValueBase
GSF.PhasorProtocols.PhasorValueBase = function(info, context);
protected:
PhasorValueBase(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValueBase Class
PhasorValueBase Overload
GSF.PhasorProtocols Namespace


PhasorValueBase Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValueBase Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValueBase(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Protected Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValueBase
GSF.PhasorProtocols.PhasorValueBase = function(parent, phasorDefinition);
protected:
PhasorValueBase(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValueBase.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValueBase.
See Also

Reference

PhasorValueBase Class
PhasorValueBase Overload
GSF.PhasorProtocols Namespace


PhasorValueBase Constructor (IDataCell, IPhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValueBase Constructor (IDataCell, IPhasorDefinition, Angle, Double)
Creates a new PhasorValueBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValueBase(
    IDataCell parent,
    IPhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Protected Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValueBase
GSF.PhasorProtocols.PhasorValueBase = function(parent, phasorDefinition, angle, magnitude);
protected:
PhasorValueBase(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValueBase.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValueBase.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValueBase, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase.
See Also

Reference

PhasorValueBase Class
PhasorValueBase Overload
GSF.PhasorProtocols Namespace


PhasorValueBase Constructor (IDataCell, IPhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValueBase Constructor (IDataCell, IPhasorDefinition, Double, Double)
Creates a new PhasorValueBase from specified parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValueBase(
    IDataCell parent,
    IPhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Protected Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition *
        real : float *
        imaginary : float -> PhasorValueBase
GSF.PhasorProtocols.PhasorValueBase = function(parent, phasorDefinition, real, imaginary);
protected:
PhasorValueBase(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValueBase.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValueBase.
real
Type: SystemDouble
The real value of this PhasorValueBase.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValueBase.
See Also

Reference

PhasorValueBase Class
PhasorValueBase Overload
GSF.PhasorProtocols Namespace


PhasorValueBase Methods

Grid Solutions Framework PhasorValueBase Methods

The PhasorValueBase type exposes the following members.

Methods
 | Name | Description
 | AverageAngleValueFilter | Calculates an average of the specified sequence of IMeasurement phase angle values.
 | CalculatePower | Calculates watts from imaginary and real components of a voltage and current phasor.
 | CalculateVars | Calculates vars (total volt-amperes of reactive power) from imaginary and real components of a voltage and current phasor.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Overrides ChannelValueBaseTGetCompositeValue(Int32).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Overrides ChannelValueBaseTGetMeasurementValueFilterFunction(Int32).)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelValueBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides BinaryImageBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.AverageAngleValueFilter Method

Grid Solutions Framework PhasorValueBaseAverageAngleValueFilter Method
Calculates an average of the specified sequence of IMeasurement phase angle values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double AverageAngleValueFilter(
    IEnumerable<IMeasurement> source
)
Public Shared Function AverageAngleValueFilter (
    source As IEnumerable(Of IMeasurement)
) As Double
static member AverageAngleValueFilter :
        source : IEnumerable<IMeasurement> -> float

GSF.PhasorProtocols.PhasorValueBase.AverageAngleValueFilter = function(source);
public:
static double AverageAngleValueFilter(
    IEnumerable<IMeasurement^>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable IMeasurement
Sequence of IMeasurement values over which to run calculation.

Return Value

Type: Double
Average of the specified sequence of IMeasurement phase angle values.
Remarks
Phase angles wrap, so this algorithm takes the wrapping into account when calculating the average.
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.CalculatePower Method

Grid Solutions Framework PhasorValueBaseCalculatePower Method
Calculates watts from imaginary and real components of a voltage and current phasor.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power CalculatePower(
    IPhasorValue voltage,
    IPhasorValue current
)
Public Shared Function CalculatePower (
    voltage As IPhasorValue,
    current As IPhasorValue
) As Power
static member CalculatePower :
        voltage : IPhasorValue *
        current : IPhasorValue -> Power

GSF.PhasorProtocols.PhasorValueBase.CalculatePower = function(voltage, current);
public:
static Power CalculatePower(
    IPhasorValue^ voltage,
    IPhasorValue^ current
)

Parameters

voltage
Type: GSF.PhasorProtocolsIPhasorValue
Voltage phasor.
current
Type: GSF.PhasorProtocolsIPhasorValue
Current phasor.

Return Value

Type: Power
Calculated watts from imaginary and real components of specified voltage and current phasors.
Exceptions
Exception | Condition
ArgumentNullException | voltage and current must not be null.
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.CalculateVars Method

Grid Solutions Framework PhasorValueBaseCalculateVars Method
Calculates vars (total volt-amperes of reactive power) from imaginary and real components of a voltage and current phasor.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power CalculateVars(
    IPhasorValue voltage,
    IPhasorValue current
)
Public Shared Function CalculateVars (
    voltage As IPhasorValue,
    current As IPhasorValue
) As Power
static member CalculateVars :
        voltage : IPhasorValue *
        current : IPhasorValue -> Power

GSF.PhasorProtocols.PhasorValueBase.CalculateVars = function(voltage, current);
public:
static Power CalculateVars(
    IPhasorValue^ voltage,
    IPhasorValue^ current
)

Parameters

voltage
Type: GSF.PhasorProtocolsIPhasorValue
Voltage phasor.
current
Type: GSF.PhasorProtocolsIPhasorValue
Current phasor.

Return Value

Type: Power
Calculated vars (total volt-amperes of reactive power) from imaginary and real components of specified voltage and current phasors.
Exceptions
Exception | Condition
ArgumentNullException | voltage and current must not be null.
Remarks
Although the Power units class technically represents watts (i.e., real power) and vars (i.e., imaginary power) are properly expressed in volt-amperes reactive (VAr), the calculated result is still a representation of power and therefore the Power units class is used to express the return value leaving the consumer to properly apply the needed engineering units for display purposes.
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.GetCompositeValue Method

Grid Solutions Framework PhasorValueBaseGetCompositeValue Method
Gets the specified composite value of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double GetCompositeValue(
    int index
)
Public Overrides Function GetCompositeValue (
    index As Integer
) As Double
abstract GetCompositeValue :
        index : int -> float
override GetCompositeValue :
        index : int -> float
function GetCompositeValue(index);
public:
virtual double GetCompositeValue(
    int index
) override

Parameters

index
Type: SystemInt32
Index of composite value to retrieve.

Return Value

Type: Double
A Double representing the composite value.

Implements

IChannelValueTGetCompositeValue(Int32)
IChannelValueTGetCompositeValue(Int32)
Remarks
Some ChannelValueBaseT implementations can contain more than one value, this method is used to abstractly expose each value.
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.GetMeasurementValueFilterFunction Method

Grid Solutions Framework PhasorValueBaseGetMeasurementValueFilterFunction Method
Gets function used to apply a downsampling filter over a sequence of IMeasurement values.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override MeasurementValueFilterFunction GetMeasurementValueFilterFunction(
    int index
)
Public Overrides Function GetMeasurementValueFilterFunction (
    index As Integer
) As MeasurementValueFilterFunction
abstract GetMeasurementValueFilterFunction :
        index : int -> MeasurementValueFilterFunction
override GetMeasurementValueFilterFunction :
        index : int -> MeasurementValueFilterFunction
function GetMeasurementValueFilterFunction(index);
public:
virtual MeasurementValueFilterFunction^ GetMeasurementValueFilterFunction(
    int index
) override

Parameters

index
Type: SystemInt32
Index of composite value for which to retrieve its filter function.

Return Value

Type: MeasurementValueFilterFunction
Function used to apply a downsampling filter over a sequence of IMeasurement values.

Implements

IChannelValueTGetMeasurementValueFilterFunction(Int32)
IChannelValueTGetMeasurementValueFilterFunction(Int32)
Remarks
Phase angles averaging filter takes angle wrapping into account, magnitudes apply a standard average filter.
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.GetObjectData Method

Grid Solutions Framework PhasorValueBaseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.ParseBodyImage Method

Grid Solutions Framework PhasorValueBaseParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase Properties

Grid Solutions Framework PhasorValueBase Properties

The PhasorValueBase type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians.
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase.
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Overrides ChannelValueBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Overrides ChannelBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides BinaryImageBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Overrides ChannelValueBaseTCompositeValueCount.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase.
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the IChannelDefinition associated with this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase.
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Overrides ChannelValueBaseTIsEmpty.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase.
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the IDataCell parent of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Real | Gets or sets the real value of this PhasorValueBase.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase.
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase.
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase.
Top
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.Angle Property

Grid Solutions Framework PhasorValueBaseAngle Property
Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Angle Angle { get; set; }
Public Overridable Property Angle As Angle
    Get
    Set
abstract Angle : Angle with get, set
override Angle : Angle with get, set
function get_Angle();
function set_Angle(value);
public:
virtual property Angle Angle {
    Angle get ();
    void set (Angle value);
}

Property Value

Type: Angle

Implements

IPhasorValueAngle
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.AngleFormat Property

Grid Solutions Framework PhasorValueBaseAngleFormat Property
Gets the AngleFormat of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AngleFormat AngleFormat { get; }
Public Overridable ReadOnly Property AngleFormat As AngleFormat
    Get
abstract AngleFormat : AngleFormat with get
override AngleFormat : AngleFormat with get
function get_AngleFormat();

public:
virtual property AngleFormat AngleFormat {
    AngleFormat get ();
}

Property Value

Type: AngleFormat

Implements

IPhasorValueAngleFormat
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.Attributes Property

Grid Solutions Framework PhasorValueBaseAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.BodyImage Property

Grid Solutions Framework PhasorValueBaseBodyImage Property
Gets the binary body image of the PhasorValueBase object.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.BodyLength Property

Grid Solutions Framework PhasorValueBaseBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.CompositeValueCount Property

Grid Solutions Framework PhasorValueBaseCompositeValueCount Property
Gets total number of composite values that this PhasorValueBase provides.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int CompositeValueCount { get; }
Public Overrides ReadOnly Property CompositeValueCount As Integer
    Get
abstract CompositeValueCount : int with get
override CompositeValueCount : int with get
function get_CompositeValueCount();

public:
virtual property int CompositeValueCount {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelValueTCompositeValueCount
IChannelValueTCompositeValueCount
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.CoordinateFormat Property

Grid Solutions Framework PhasorValueBaseCoordinateFormat Property
Gets the CoordinateFormat of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual CoordinateFormat CoordinateFormat { get; }
Public Overridable ReadOnly Property CoordinateFormat As CoordinateFormat
    Get
abstract CoordinateFormat : CoordinateFormat with get
override CoordinateFormat : CoordinateFormat with get
function get_CoordinateFormat();

public:
virtual property CoordinateFormat CoordinateFormat {
    CoordinateFormat get ();
}

Property Value

Type: CoordinateFormat

Implements

IPhasorValueCoordinateFormat
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.Imaginary Property

Grid Solutions Framework PhasorValueBaseImaginary Property
Gets or sets the imaginary value of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Imaginary { get; set; }
Public Overridable Property Imaginary As Double
    Get
    Set
abstract Imaginary : float with get, set
override Imaginary : float with get, set
function get_Imaginary();
function set_Imaginary(value);
public:
virtual property double Imaginary {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IPhasorValueImaginary
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.IsEmpty Property

Grid Solutions Framework PhasorValueBaseIsEmpty Property
Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool IsEmpty { get; }
Public Overrides ReadOnly Property IsEmpty As Boolean
    Get
abstract IsEmpty : bool with get
override IsEmpty : bool with get
function get_IsEmpty();

public:
virtual property bool IsEmpty {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IChannelValueTIsEmpty
IChannelValueTIsEmpty
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.Magnitude Property

Grid Solutions Framework PhasorValueBaseMagnitude Property
Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Magnitude { get; set; }
Public Overridable Property Magnitude As Double
    Get
    Set
abstract Magnitude : float with get, set
override Magnitude : float with get, set
function get_Magnitude();
function set_Magnitude(value);
public:
virtual property double Magnitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IPhasorValueMagnitude
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.Real Property

Grid Solutions Framework PhasorValueBaseReal Property
Gets or sets the real value of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Real { get; set; }
Public Overridable Property Real As Double
    Get
    Set
abstract Real : float with get, set
override Real : float with get, set
function get_Real();
function set_Real(value);
public:
virtual property double Real {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IPhasorValueReal
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.Type Property

Grid Solutions Framework PhasorValueBaseType Property
Gets the PhasorType of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorType Type { get; }
Public Overridable ReadOnly Property Type As PhasorType
    Get
abstract Type : PhasorType with get
override Type : PhasorType with get
function get_Type();

public:
virtual property PhasorType Type {
    PhasorType get ();
}

Property Value

Type: PhasorType

Implements

IPhasorValueType
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.UnscaledImaginary Property

Grid Solutions Framework PhasorValueBaseUnscaledImaginary Property
Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int UnscaledImaginary { get; set; }
Public Overridable Property UnscaledImaginary As Integer
    Get
    Set
abstract UnscaledImaginary : int with get, set
override UnscaledImaginary : int with get, set
function get_UnscaledImaginary();
function set_UnscaledImaginary(value);
public:
virtual property int UnscaledImaginary {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IPhasorValueUnscaledImaginary
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueBase.UnscaledReal Property

Grid Solutions Framework PhasorValueBaseUnscaledReal Property
Gets or sets the unscaled integer representation of the real value of this PhasorValueBase.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int UnscaledReal { get; set; }
Public Overridable Property UnscaledReal As Integer
    Get
    Set
abstract UnscaledReal : int with get, set
override UnscaledReal : int with get, set
function get_UnscaledReal();
function set_UnscaledReal(value);
public:
virtual property int UnscaledReal {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IPhasorValueUnscaledReal
See Also

Reference

PhasorValueBase Class
GSF.PhasorProtocols Namespace


PhasorValueCollection Class

Grid Solutions Framework PhasorValueCollection Class
Represents a protocol independent collection of IPhasorValue objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IPhasorValue
GSF.CollectionsListCollection IPhasorValue
GSF.PhasorProtocolsChannelCollectionBase IPhasorValue
GSF.PhasorProtocolsChannelValueCollectionBase IPhasorDefinition, IPhasorValue
GSF.PhasorProtocolsPhasorValueCollection

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValueCollection : ChannelValueCollectionBase<IPhasorDefinition, IPhasorValue>
<SerializableAttribute>
Public Class PhasorValueCollection
    Inherits ChannelValueCollectionBase(Of IPhasorDefinition, IPhasorValue)
[<SerializableAttribute>]
type PhasorValueCollection =
    class
        inherit ChannelValueCollectionBase<IPhasorDefinition, IPhasorValue>
    end
GSF.PhasorProtocols.PhasorValueCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.PhasorValueCollection',
    GSF.PhasorProtocols.ChannelValueCollectionBase`2);
[SerializableAttribute]
public ref class PhasorValueCollection : public ChannelValueCollectionBase<IPhasorDefinition^, IPhasorValue^>

The PhasorValueCollection type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorValueCollection(Int32) | Creates a new PhasorValueCollection using specified lastValidIndex.
Protected method | PhasorValueCollection(SerializationInfo, StreamingContext) | Creates a new PhasorValueCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols Namespace


PhasorValueCollection Constructor

Grid Solutions Framework PhasorValueCollection Constructor
Overload List
 | Name | Description
Public method | PhasorValueCollection(Int32) | Creates a new PhasorValueCollection using specified lastValidIndex.
Protected method | PhasorValueCollection(SerializationInfo, StreamingContext) | Creates a new PhasorValueCollection from serialization parameters.
Top
See Also

Reference

PhasorValueCollection Class
GSF.PhasorProtocols Namespace


PhasorValueCollection Constructor (Int32)

Grid Solutions Framework PhasorValueCollection Constructor (Int32)
Creates a new PhasorValueCollection using specified lastValidIndex.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValueCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> PhasorValueCollection
GSF.PhasorProtocols.PhasorValueCollection = function(lastValidIndex);
public:
PhasorValueCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

PhasorValueCollection Class
PhasorValueCollection Overload
GSF.PhasorProtocols Namespace


PhasorValueCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValueCollection Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValueCollection from serialization parameters.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValueCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValueCollection
GSF.PhasorProtocols.PhasorValueCollection = function(info, context);
protected:
PhasorValueCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValueCollection Class
PhasorValueCollection Overload
GSF.PhasorProtocols Namespace


PhasorValueCollection Methods

Grid Solutions Framework PhasorValueCollection Methods

The PhasorValueCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelValueCollectionBaseTDefinition, TValue at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelValueCollectionBaseTDefinition, TValue. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValueCollection Class
GSF.PhasorProtocols Namespace


PhasorValueCollection Properties

Grid Solutions Framework PhasorValueCollection Properties

The PhasorValueCollection type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets a boolean value indicating if all of the composite values have been assigned a value. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelValueCollectionBaseTDefinition, TValue object. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelValueCollectionBaseTDefinition, TValue.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

PhasorValueCollection Class
GSF.PhasorProtocols Namespace


PhasorValueCollection Events

Grid Solutions Framework PhasorValueCollection Events

The PhasorValueCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

PhasorValueCollection Class
GSF.PhasorProtocols Namespace


SourceChannel Enumeration

Grid Solutions Framework SourceChannel Enumeration
Source channel, e.g., data or command.

Namespace: GSF.PhasorProtocols
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum SourceChannel
<SerializableAttribute>
Public Enumeration SourceChannel
[<SerializableAttribute>]
type SourceChannel
GSF.PhasorProtocols.SourceChannel = function();
GSF.PhasorProtocols.SourceChannel.createEnum('GSF.PhasorProtocols.SourceChannel', false);
[SerializableAttribute]
public enum class SourceChannel
Members
Member name | Value | Description
Command | 0 | Source channel is command (e.g., TCP).
Data | 1 | Source channel is data (e.g., UDP).
Other | 2 | Source channel is other.
See Also

Reference

GSF.PhasorProtocols Namespace


GSF.PhasorProtocols.Anonymous Namespace

Grid Solutions Framework GSF.PhasorProtocols.Anonymous Namespace
Contains a generic implementation of phasor classes used to represent phasor data that isn’t associated with any particular protocol.
Classes
 | Class | Description
Public class | AnalogDefinition | Represents a protocol independent implementation of an IAnalogDefinition.
Public class | ConfigurationCell | Represents a protocol independent implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a protocol independent implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame | Represents a protocol independent implementation of a IConfigurationFrame that can be sent or received.
Public class | DigitalDefinition | Represents a protocol independent implementation of an IDigitalDefinition.
Public class | FrequencyDefinition | Represents a protocol independent implementation of a IFrequencyDefinition.
Public class | PhasorDefinition | Represents a protocol independent implementation of a IPhasorDefinition.


AnalogDefinition Class

Grid Solutions Framework AnalogDefinition Class
Represents a protocol independent implementation of an IAnalogDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsAnalogDefinitionBase
GSF.PhasorProtocols.AnonymousAnalogDefinition

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogDefinition : AnalogDefinitionBase
<SerializableAttribute>
Public Class AnalogDefinition
    Inherits AnalogDefinitionBase
[<SerializableAttribute>]
type AnalogDefinition =
    class
        inherit AnalogDefinitionBase
    end
GSF.PhasorProtocols.Anonymous.AnalogDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.Anonymous.AnalogDefinition',
    GSF.PhasorProtocols.AnalogDefinitionBase);
[SerializableAttribute]
public ref class AnalogDefinition : public AnalogDefinitionBase

The AnalogDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Anonymous Namespace


AnalogDefinition Constructor

Grid Solutions Framework AnalogDefinition Constructor
Overload List
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


AnalogDefinition Constructor (IConfigurationCell)

Grid Solutions Framework AnalogDefinition Constructor (IConfigurationCell)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> AnalogDefinition
GSF.PhasorProtocols.Anonymous.AnalogDefinition = function(parent);
public:
AnalogDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


AnalogDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogDefinition
GSF.PhasorProtocols.Anonymous.AnalogDefinition = function(info, context);
protected:
AnalogDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


AnalogDefinition Constructor (ConfigurationCell, String, UInt32, AnalogType)

Grid Solutions Framework AnalogDefinition Constructor (ConfigurationCell, String, UInt32, AnalogType)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    AnalogType type
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    type As AnalogType
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        type : AnalogType -> AnalogDefinition
GSF.PhasorProtocols.Anonymous.AnalogDefinition = function(parent, label, scale, type);
public:
AnalogDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    AnalogType type
)

Parameters

parent
Type: GSF.PhasorProtocols.AnonymousConfigurationCell
The ConfigurationCell parent of this AnalogDefinition.
label
Type: SystemString
The label of this AnalogDefinition.
scale
Type: SystemUInt32
The integer scaling value of this AnalogDefinitionBase.
type
Type: GSF.PhasorProtocolsAnalogType
The AnalogType of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


AnalogDefinition Methods

Grid Solutions Framework AnalogDefinition Methods

The AnalogDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


AnalogDefinition Properties

Grid Solutions Framework AnalogDefinition Properties

The AnalogDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


AnalogDefinition.Parent Property

Grid Solutions Framework AnalogDefinitionParent Property
Gets or sets the ConfigurationCell parent of this AnalogDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents a protocol independent implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.AnonymousConfigurationCell

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase,
    IDevice
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
    Implements IDevice
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
        interface IDevice
    end
GSF.PhasorProtocols.Anonymous.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.Anonymous.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase,
    GSF.TimeSeries.IDevice);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase,
    IDevice

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCell(UInt16) | Creates a new ConfigurationCell from specified parameters.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt16) | Creates a new ConfigurationCell from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
Public method | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DataQualityErrors | Gets or sets total data quality errors of this ConfigurationCell.
Public property | DeviceErrors | Gets or sets total device errors of this ConfigurationCell.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | LastReportTime | Gets or sets last report time of this ConfigurationCell.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MeasurementsExpected | Gets or sets total measurements expected to have been received for this ConfigurationCell.
Public property | MeasurementsReceived | Gets or sets total measurements received for this ConfigurationCell.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Source | Gets or sets the reference to the source of this ConfigurationCell.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeQualityErrors | Gets or sets total time quality errors of this ConfigurationCell.
Public property | TotalFrames | Gets or sets total frames of this ConfigurationCell.
Top
See Also

Reference

GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Overload List
 | Name | Description
Public method | ConfigurationCell(UInt16) | Creates a new ConfigurationCell from specified parameters.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt16) | Creates a new ConfigurationCell from specified parameters.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell Constructor (UInt16)

Grid Solutions Framework ConfigurationCell Constructor (UInt16)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ushort idCode
)
Public Sub New (
    idCode As UShort
)
new :
        idCode : uint16 -> ConfigurationCell
GSF.PhasorProtocols.Anonymous.ConfigurationCell = function(idCode);
public:
ConfigurationCell(
    unsigned short idCode
)

Parameters

idCode
Type: SystemUInt16
The numeric ID code for this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCell Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.Anonymous.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell Constructor (ConfigurationFrame, UInt16)

Grid Solutions Framework ConfigurationCell Constructor (ConfigurationFrame, UInt16)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ConfigurationFrame parent,
    ushort idCode
)
Public Sub New (
    parent As ConfigurationFrame,
    idCode As UShort
)
new :
        parent : ConfigurationFrame *
        idCode : uint16 -> ConfigurationCell
GSF.PhasorProtocols.Anonymous.ConfigurationCell = function(parent, idCode);
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    unsigned short idCode
)

Parameters

parent
Type: GSF.PhasorProtocols.AnonymousConfigurationFrame
The reference to parent ConfigurationFrame of this ConfigurationCell.
idCode
Type: SystemUInt16
The numeric ID code for this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
Public method | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.GetObjectData Method

Grid Solutions Framework ConfigurationCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.GetSignalReference Method

Grid Solutions Framework ConfigurationCellGetSignalReference Method
Overload List
 | Name | Description
Public method | GetSignalReference(SignalKind) | Get signal reference for specified SignalKind.
Public method | GetSignalReference(SignalKind, Int32, Int32) | Get signal reference for specified SignalKind and index.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.GetSignalReference Method (SignalKind)

Grid Solutions Framework ConfigurationCellGetSignalReference Method (SignalKind)
Get signal reference for specified SignalKind.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetSignalReference(
    SignalKind type
)
Public Function GetSignalReference (
    type As SignalKind
) As String
member GetSignalReference :
        type : SignalKind -> string

function GetSignalReference(type);
public:
String^ GetSignalReference(
    SignalKind type
)

Parameters

type
Type: GSF.Units.EESignalKind
SignalKind to request signal reference for.

Return Value

Type: String
Signal reference of given SignalKind.
See Also

Reference

ConfigurationCell Class
GetSignalReference Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.GetSignalReference Method (SignalKind, Int32, Int32)

Grid Solutions Framework ConfigurationCellGetSignalReference Method (SignalKind, Int32, Int32)
Get signal reference for specified SignalKind and index.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetSignalReference(
    SignalKind type,
    int index,
    int count
)
Public Function GetSignalReference (
    type As SignalKind,
    index As Integer,
    count As Integer
) As String
member GetSignalReference :
        type : SignalKind *
        index : int *
        count : int -> string

function GetSignalReference(type, index, count);
public:
String^ GetSignalReference(
    SignalKind type,
    int index,
    int count
)

Parameters

type
Type: GSF.Units.EESignalKind
SignalKind to request signal reference for.
index
Type: SystemInt32
Index SignalKind to request signal reference for.
count
Type: SystemInt32
Number of signals defined for this SignalKind.

Return Value

Type: String
Signal reference of given SignalKind and index.
See Also

Reference

ConfigurationCell Class
GetSignalReference Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DataQualityErrors | Gets or sets total data quality errors of this ConfigurationCell.
Public property | DeviceErrors | Gets or sets total device errors of this ConfigurationCell.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | LastReportTime | Gets or sets last report time of this ConfigurationCell.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MeasurementsExpected | Gets or sets total measurements expected to have been received for this ConfigurationCell.
Public property | MeasurementsReceived | Gets or sets total measurements received for this ConfigurationCell.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets or sets a reference to the parent IConfigurationFrame for this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Source | Gets or sets the reference to the source of this ConfigurationCell.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeQualityErrors | Gets or sets total time quality errors of this ConfigurationCell.
Public property | TotalFrames | Gets or sets total frames of this ConfigurationCell.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.DataQualityErrors Property

Grid Solutions Framework ConfigurationCellDataQualityErrors Property
Gets or sets total data quality errors of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long DataQualityErrors { get; set; }
Public Property DataQualityErrors As Long
    Get
    Set
abstract DataQualityErrors : int64 with get, set
override DataQualityErrors : int64 with get, set
function get_DataQualityErrors();
function set_DataQualityErrors(value);
public:
virtual property long long DataQualityErrors {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceDataQualityErrors
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.DeviceErrors Property

Grid Solutions Framework ConfigurationCellDeviceErrors Property
Gets or sets total device errors of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long DeviceErrors { get; set; }
Public Property DeviceErrors As Long
    Get
    Set
abstract DeviceErrors : int64 with get, set
override DeviceErrors : int64 with get, set
function get_DeviceErrors();
function set_DeviceErrors(value);
public:
virtual property long long DeviceErrors {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceDeviceErrors
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.LastReportTime Property

Grid Solutions Framework ConfigurationCellLastReportTime Property
Gets or sets last report time of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks LastReportTime { get; set; }
Public Property LastReportTime As Ticks
    Get
    Set
member LastReportTime : Ticks with get, set

function get_LastReportTime();
function set_LastReportTime(value);
public:
property Ticks LastReportTime {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.MeasurementsExpected Property

Grid Solutions Framework ConfigurationCellMeasurementsExpected Property
Gets or sets total measurements expected to have been received for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MeasurementsExpected { get; set; }
Public Property MeasurementsExpected As Long
    Get
    Set
abstract MeasurementsExpected : int64 with get, set
override MeasurementsExpected : int64 with get, set
function get_MeasurementsExpected();
function set_MeasurementsExpected(value);
public:
virtual property long long MeasurementsExpected {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceMeasurementsExpected
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.MeasurementsReceived Property

Grid Solutions Framework ConfigurationCellMeasurementsReceived Property
Gets or sets total measurements received for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MeasurementsReceived { get; set; }
Public Property MeasurementsReceived As Long
    Get
    Set
abstract MeasurementsReceived : int64 with get, set
override MeasurementsReceived : int64 with get, set
function get_MeasurementsReceived();
function set_MeasurementsReceived(value);
public:
virtual property long long MeasurementsReceived {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceMeasurementsReceived
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.Source Property

Grid Solutions Framework ConfigurationCellSource Property
Gets or sets the reference to the source of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object Source { get; set; }
Public Property Source As Object
    Get
    Set
member Source : Object with get, set

function get_Source();
function set_Source(value);
public:
property Object^ Source {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.TimeQualityErrors Property

Grid Solutions Framework ConfigurationCellTimeQualityErrors Property
Gets or sets total time quality errors of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TimeQualityErrors { get; set; }
Public Property TimeQualityErrors As Long
    Get
    Set
abstract TimeQualityErrors : int64 with get, set
override TimeQualityErrors : int64 with get, set
function get_TimeQualityErrors();
function set_TimeQualityErrors(value);
public:
virtual property long long TimeQualityErrors {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceTimeQualityErrors
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCell.TotalFrames Property

Grid Solutions Framework ConfigurationCellTotalFrames Property
Gets or sets total frames of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalFrames { get; set; }
Public Property TotalFrames As Long
    Get
    Set
member TotalFrames : int64 with get, set

function get_TotalFrames();
function set_TotalFrames(value);
public:
property long long TotalFrames {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a protocol independent implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.AnonymousConfigurationCellCollection

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.Anonymous.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.Anonymous.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.Anonymous.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.Anonymous.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame Class

Grid Solutions Framework ConfigurationFrame Class
Represents a protocol independent implementation of a IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.AnonymousConfigurationFrame

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase
<SerializableAttribute>
Public Class ConfigurationFrame
    Inherits ConfigurationFrameBase
[<SerializableAttribute>]
type ConfigurationFrame =
    class
        inherit ConfigurationFrameBase
    end
GSF.PhasorProtocols.Anonymous.ConfigurationFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.Anonymous.ConfigurationFrame',
    GSF.PhasorProtocols.ConfigurationFrameBase);
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase

The ConfigurationFrame type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
 | Cache | Serializes configuration frame to cache folder on an independent thread for later use (if needed).
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
 | DeleteCachedConfiguration | Deletes the cached configuration, if defined.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
 | GetCachedConfiguration | Deserializes cached configuration, if available.
 | GetConfigurationCacheFileName | Gets the file name with path of the specified configurationName.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrameBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrameBase object. (Inherited from ConfigurationFrameBase.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ConfigurationBackups | Gets total number of configuration backups to keep when storing serialized phasor protocol configurations.
 | ConfigurationCachePath | Gets the path for storing serialized phasor protocol configurations.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Overload List
 | Name | Description
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame
GSF.PhasorProtocols.Anonymous.ConfigurationFrame = function(info, context);
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame Constructor (UInt16, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame Constructor (UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame(
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame
GSF.PhasorProtocols.Anonymous.ConfigurationFrame = function(idCode, timestamp, frameRate);
public:
ConfigurationFrame(
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame Methods

Grid Solutions Framework ConfigurationFrame Methods

The ConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
 | Cache | Serializes configuration frame to cache folder on an independent thread for later use (if needed).
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
 | DeleteCachedConfiguration | Deletes the cached configuration, if defined.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
 | GetCachedConfiguration | Deserializes cached configuration, if available.
 | GetConfigurationCacheFileName | Gets the file name with path of the specified configurationName.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrameBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.Cache Method

Grid Solutions Framework ConfigurationFrameCache Method
Serializes configuration frame to cache folder on an independent thread for later use (if needed).

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Cache(
    IConfigurationFrame configurationFrame,
    Action<Exception> exceptionHandler,
    string configurationName
)
Public Shared Sub Cache (
    configurationFrame As IConfigurationFrame,
    exceptionHandler As Action(Of Exception),
    configurationName As String
)
static member Cache :
        configurationFrame : IConfigurationFrame *
        exceptionHandler : Action<Exception> *
        configurationName : string -> unit

GSF.PhasorProtocols.Anonymous.ConfigurationFrame.Cache = function(configurationFrame, exceptionHandler, configurationName);
public:
static void Cache(
    IConfigurationFrame^ configurationFrame,
    Action<Exception^>^ exceptionHandler,
    String^ configurationName
)

Parameters

configurationFrame
Type: GSF.PhasorProtocolsIConfigurationFrame
Reference to IConfigurationFrame.
exceptionHandler
Type: SystemAction Exception
ActionT delegate to handle process exceptions.
configurationName
Type: SystemString
String representing the configuration name.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.DeleteCachedConfiguration Method

Grid Solutions Framework ConfigurationFrameDeleteCachedConfiguration Method
Deletes the cached configuration, if defined.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DeleteCachedConfiguration(
    string configurationName
)
Public Shared Sub DeleteCachedConfiguration (
    configurationName As String
)
static member DeleteCachedConfiguration :
        configurationName : string -> unit

GSF.PhasorProtocols.Anonymous.ConfigurationFrame.DeleteCachedConfiguration = function(configurationName);
public:
static void DeleteCachedConfiguration(
    String^ configurationName
)

Parameters

configurationName
Type: SystemString
Name of the configuration to delete.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.GetCachedConfiguration Method

Grid Solutions Framework ConfigurationFrameGetCachedConfiguration Method
Deserializes cached configuration, if available.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IConfigurationFrame GetCachedConfiguration(
    string configurationName,
    bool fromCache
)
Public Shared Function GetCachedConfiguration (
    configurationName As String,
    fromCache As Boolean
) As IConfigurationFrame
static member GetCachedConfiguration :
        configurationName : string *
        fromCache : bool -> IConfigurationFrame

GSF.PhasorProtocols.Anonymous.ConfigurationFrame.GetCachedConfiguration = function(configurationName, fromCache);
public:
static IConfigurationFrame^ GetCachedConfiguration(
    String^ configurationName,
    bool fromCache
)

Parameters

configurationName
Type: SystemString
Name of the configuration to get file name for.
fromCache
Type: SystemBoolean
Set to True retrieve from cache, False to retrieve from specified file name in configurationName

Return Value

Type: IConfigurationFrame
Cached configuration frame, or null if not available.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.GetConfigurationCacheFileName Method

Grid Solutions Framework ConfigurationFrameGetConfigurationCacheFileName Method
Gets the file name with path of the specified configurationName.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetConfigurationCacheFileName(
    string configurationName
)
Public Shared Function GetConfigurationCacheFileName (
    configurationName As String
) As String
static member GetConfigurationCacheFileName :
        configurationName : string -> string

GSF.PhasorProtocols.Anonymous.ConfigurationFrame.GetConfigurationCacheFileName = function(configurationName);
public:
static String^ GetConfigurationCacheFileName(
    String^ configurationName
)

Parameters

configurationName
Type: SystemString
Name of the configuration to get file name for.

Return Value

Type: String
File name with path of the specified configurationName.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame Properties

Grid Solutions Framework ConfigurationFrame Properties

The ConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrameBase object. (Inherited from ConfigurationFrameBase.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
 | ConfigurationBackups | Gets total number of configuration backups to keep when storing serialized phasor protocol configurations.
 | ConfigurationCachePath | Gets the path for storing serialized phasor protocol configurations.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.Cells Property

Grid Solutions Framework ConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.ConfigurationBackups Property

Grid Solutions Framework ConfigurationFrameConfigurationBackups Property
Gets total number of configuration backups to keep when storing serialized phasor protocol configurations.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ConfigurationBackups { get; }
Public Shared ReadOnly Property ConfigurationBackups As Integer
    Get
static member ConfigurationBackups : int with get

GSF.PhasorProtocols.Anonymous.ConfigurationFrame.get_ConfigurationBackups = function();

public:
static property int ConfigurationBackups {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


ConfigurationFrame.ConfigurationCachePath Property

Grid Solutions Framework ConfigurationFrameConfigurationCachePath Property
Gets the path for storing serialized phasor protocol configurations.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ConfigurationCachePath { get; }
Public Shared ReadOnly Property ConfigurationCachePath As String
    Get
static member ConfigurationCachePath : string with get

GSF.PhasorProtocols.Anonymous.ConfigurationFrame.get_ConfigurationCachePath = function();

public:
static property String^ ConfigurationCachePath {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition Class

Grid Solutions Framework DigitalDefinition Class
Represents a protocol independent implementation of an IDigitalDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocols.AnonymousDigitalDefinition

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute>
Public Class DigitalDefinition
    Inherits DigitalDefinitionBase
[<SerializableAttribute>]
type DigitalDefinition =
    class
        inherit DigitalDefinitionBase
    end
GSF.PhasorProtocols.Anonymous.DigitalDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.Anonymous.DigitalDefinition',
    GSF.PhasorProtocols.DigitalDefinitionBase);
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase

The DigitalDefinition type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String, UInt32) | Creates a new DigitalDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this DigitalDefinition. (Overrides ChannelDefinitionBaseLabel.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaskValue | Gets or sets the digital mask value of this DigitalDefinition made available in configuration frames.
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition Constructor

Grid Solutions Framework DigitalDefinition Constructor
Overload List
 | Name | Description
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String, UInt32) | Creates a new DigitalDefinition from specified parameters.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinition
GSF.PhasorProtocols.Anonymous.DigitalDefinition = function(info, context);
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition Constructor (ConfigurationCell, String, UInt32)

Grid Solutions Framework DigitalDefinition Constructor (ConfigurationCell, String, UInt32)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    ConfigurationCell parent,
    string label,
    uint maskValue
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    maskValue As UInteger
)
new :
        parent : ConfigurationCell *
        label : string *
        maskValue : uint32 -> DigitalDefinition
GSF.PhasorProtocols.Anonymous.DigitalDefinition = function(parent, label, maskValue);
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int maskValue
)

Parameters

parent
Type: GSF.PhasorProtocols.AnonymousConfigurationCell
The ConfigurationCell parent of this DigitalDefinition.
label
Type: SystemString
The label of this DigitalDefinition.
maskValue
Type: SystemUInt32
The value of the digital mask made available in configuration frames.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition Methods

Grid Solutions Framework DigitalDefinition Methods

The DigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition.GetObjectData Method

Grid Solutions Framework DigitalDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition Properties

Grid Solutions Framework DigitalDefinition Properties

The DigitalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this DigitalDefinition. (Overrides ChannelDefinitionBaseLabel.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaskValue | Gets or sets the digital mask value of this DigitalDefinition made available in configuration frames.
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition.Label Property

Grid Solutions Framework DigitalDefinitionLabel Property
Gets or sets the label of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Label { get; set; }
Public Overrides Property Label As String
    Get
    Set
abstract Label : string with get, set
override Label : string with get, set
function get_Label();
function set_Label(value);
public:
virtual property String^ Label {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String

Implements

IChannelDefinitionLabel
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition.MaskValue Property

Grid Solutions Framework DigitalDefinitionMaskValue Property
Gets or sets the digital mask value of this DigitalDefinition made available in configuration frames.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint MaskValue { get; set; }
Public Property MaskValue As UInteger
    Get
    Set
member MaskValue : uint32 with get, set

function get_MaskValue();
function set_MaskValue(value);
public:
property unsigned int MaskValue {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition.MaximumLabelLength Property

Grid Solutions Framework DigitalDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
Remarks
This length is not restricted for anonymous protocol definitions.
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


DigitalDefinition.Parent Property

Grid Solutions Framework DigitalDefinitionParent Property
Gets or sets the ConfigurationCell parent of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents a protocol independent implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.AnonymousFrequencyDefinition

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.Anonymous.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.Anonymous.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this FrequencyDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.Anonymous.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> FrequencyDefinition
GSF.PhasorProtocols.Anonymous.FrequencyDefinition = function(parent, label);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.AnonymousConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
label
Type: SystemString
The label of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this FrequencyDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition.MaximumLabelLength Property

Grid Solutions Framework FrequencyDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
Remarks
This length is not restricted for anonymous protocol definitions.
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents a protocol independent implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.AnonymousPhasorDefinition

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.Anonymous.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.Anonymous.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this PhasorDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.Anonymous.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition Constructor (ConfigurationCell, String, UInt32, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, UInt32, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.Anonymous.PhasorDefinition = function(parent, label, scale, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.AnonymousConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
scale
Type: SystemUInt32
The integer scaling value of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.AnonymousPhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this PhasorDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition.MaximumLabelLength Property

Grid Solutions Framework PhasorDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
Remarks
This length is not restricted for anonymous protocol definitions.
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Anonymous
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Anonymous Namespace


GSF.PhasorProtocols.BPAPDCstream Namespace

Grid Solutions Framework GSF.PhasorProtocols.BPAPDCstream Namespace
Contains an implementation of the phasor classes used to parse or generate a stream of data in the BPA PDCstream format.
Classes
 | Class | Description
Public class | AnalogDefinition | Represents the BPA PDCstream implementation of an IAnalogDefinition.
Public class | AnalogValue | Represents the BPA PDCstream implementation of an IAnalogValue.
Public class | Common | Common BPA PDCstream declarations and functions.
Public class | CommonFrameHeader | Represents the common header for all BPA PDCstream frames of data.
Public class | ConfigurationCell | Represents the BPA PDCstream implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a BPA PDCstream implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame | Represents the BPA PDCstream implementation of a IConfigurationFrame that can be sent or received.
Public class | ConfigurationFrameParsingState | Represents the BPA PDCstream implementation of the parsing state used by a ConfigurationFrame.
Public class | ConnectionParameters | Represents the extra connection parameters required for a connection to a BPA PDCstream.
Public class | DataCell | Represents the BPA PDCstream implementation of a IDataCell that can be sent or received.
Public class | DataCellCollection | Represents a BPA PDCstream implementation of a collection of IDataCell objects.
Public class | DataFrame | Represents the BPA PDCstream implementation of a IDataFrame that can be sent or received.
Public class | DataFrameParsingState | Represents the BPA PDCstream protocol implementation of the parsing state used by a DataFrame.
Public class | DigitalDefinition | Represents the BPA PDCstream implementation of an IDigitalDefinition.
Public class | DigitalValue | Represents the BPA PDCstream implementation of an IDigitalValue.
Public class | FrameParser | Represents a frame parser for a BPA PDCstream binary data stream and returns parsed data via events.
Public class | FrequencyDefinition | Represents the BPA PDCstream implementation of a IFrequencyDefinition.
Public class | FrequencyValue | Represents the BPA PDCstream implementation of a IFrequencyValue.
Public class | IniFileNameEditor | INI file name browser used with BPA PDCstream ConnectionParameters.
Public class | PhasorDefinition | Represents the BPA PDCstream implementation of a IPhasorDefinition.
Public class | PhasorValue | Represents the BPA PDCstream implementation of a IPhasorValue.
Enumerations
 | Enumeration | Description
Public enumeration | ChannelFlags | Channel flags enumeration.
Public enumeration | FileType | File type enueration.
Public enumeration | FileVersion |
Public enumeration | FormatFlags | Format flags enumeration.
Public enumeration | FrameType | Frame type enumeration.
Public enumeration | PMUStatusFlags | PMU status flags enumeration.
Public enumeration | ReservedFlags | Reserved flags enumeration.
Public enumeration | RevisionNumber | Stream revision number enumeration.
Public enumeration | StreamType | Stream type enueration.


AnalogDefinition Class

Grid Solutions Framework AnalogDefinition Class
Represents the BPA PDCstream implementation of an IAnalogDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsAnalogDefinitionBase
GSF.PhasorProtocols.BPAPDCstreamAnalogDefinition

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogDefinition : AnalogDefinitionBase
<SerializableAttribute>
Public Class AnalogDefinition
    Inherits AnalogDefinitionBase
[<SerializableAttribute>]
type AnalogDefinition =
    class
        inherit AnalogDefinitionBase
    end
GSF.PhasorProtocols.BPAPDCstream.AnalogDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.AnalogDefinition',
    GSF.PhasorProtocols.AnalogDefinitionBase);
[SerializableAttribute]
public ref class AnalogDefinition : public AnalogDefinitionBase

The AnalogDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this AnalogDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition Constructor

Grid Solutions Framework AnalogDefinition Constructor
Overload List
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition Constructor (IConfigurationCell)

Grid Solutions Framework AnalogDefinition Constructor (IConfigurationCell)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> AnalogDefinition
GSF.PhasorProtocols.BPAPDCstream.AnalogDefinition = function(parent);
public:
AnalogDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogDefinition
GSF.PhasorProtocols.BPAPDCstream.AnalogDefinition = function(info, context);
protected:
AnalogDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition Constructor (ConfigurationCell, String, UInt32, Double, AnalogType)

Grid Solutions Framework AnalogDefinition Constructor (ConfigurationCell, String, UInt32, Double, AnalogType)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    AnalogType type
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As AnalogType
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : AnalogType -> AnalogDefinition
GSF.PhasorProtocols.BPAPDCstream.AnalogDefinition = function(parent, label, scale, offset, type);
public:
AnalogDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    AnalogType type
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
The ConfigurationCell parent of this AnalogDefinition.
label
Type: SystemString
The label of this AnalogDefinition.
scale
Type: SystemUInt32
The integer scaling value of this AnalogDefinition.
offset
Type: SystemDouble
The offset of this AnalogDefinition.
type
Type: GSF.PhasorProtocolsAnalogType
The AnalogType of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition Methods

Grid Solutions Framework AnalogDefinition Methods

The AnalogDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition Properties

Grid Solutions Framework AnalogDefinition Properties

The AnalogDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this AnalogDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition.BodyImage Property

Grid Solutions Framework AnalogDefinitionBodyImage Property
Gets the binary body image of the AnalogDefinition object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
BPA PDCstream does not include analog definition in descriptor packet. Only a count of available values is defined in the data frame.
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition.BodyLength Property

Grid Solutions Framework AnalogDefinitionBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition.MaximumLabelLength Property

Grid Solutions Framework AnalogDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this AnalogDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogDefinition.Parent Property

Grid Solutions Framework AnalogDefinitionParent Property
Gets or sets the ConfigurationCell parent of this AnalogDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue Class

Grid Solutions Framework AnalogValue Class
Represents the BPA PDCstream implementation of an IAnalogValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IAnalogDefinition
GSF.PhasorProtocolsAnalogValueBase
GSF.PhasorProtocols.BPAPDCstreamAnalogValue

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogValue : AnalogValueBase
<SerializableAttribute>
Public Class AnalogValue
    Inherits AnalogValueBase
[<SerializableAttribute>]
type AnalogValue =
    class
        inherit AnalogValueBase
    end
GSF.PhasorProtocols.BPAPDCstream.AnalogValue = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.AnalogValue',
    GSF.PhasorProtocols.AnalogValueBase);
[SerializableAttribute]
public ref class AnalogValue : public AnalogValueBase

The AnalogValue type exposes the following members.

Constructors
 | Name | Description
Protected method | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
Public method | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
Public method | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from AnalogValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this AnalogValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue Constructor

Grid Solutions Framework AnalogValue Constructor
Overload List
 | Name | Description
Protected method | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
Public method | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
Public method | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogValue Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogValue from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogValue
GSF.PhasorProtocols.BPAPDCstream.AnalogValue = function(info, context);
protected:
AnalogValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue Constructor (IDataCell, IAnalogDefinition)

Grid Solutions Framework AnalogValue Constructor (IDataCell, IAnalogDefinition)
Creates a new AnalogValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogValue(
    IDataCell parent,
    IAnalogDefinition analogDefinition
)
Public Sub New (
    parent As IDataCell,
    analogDefinition As IAnalogDefinition
)
new :
        parent : IDataCell *
        analogDefinition : IAnalogDefinition -> AnalogValue
GSF.PhasorProtocols.BPAPDCstream.AnalogValue = function(parent, analogDefinition);
public:
AnalogValue(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this AnalogValue.
analogDefinition
Type: GSF.PhasorProtocolsIAnalogDefinition
The IAnalogDefinition associated with this AnalogValue.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue Constructor (DataCell, AnalogDefinition, Double)

Grid Solutions Framework AnalogValue Constructor (DataCell, AnalogDefinition, Double)
Creates a new AnalogValue from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogValue(
    DataCell parent,
    AnalogDefinition analogDefinition,
    double value
)
Public Sub New (
    parent As DataCell,
    analogDefinition As AnalogDefinition,
    value As Double
)
new :
        parent : DataCell *
        analogDefinition : AnalogDefinition *
        value : float -> AnalogValue
GSF.PhasorProtocols.BPAPDCstream.AnalogValue = function(parent, analogDefinition, value);
public:
AnalogValue(
    DataCell^ parent,
    AnalogDefinition^ analogDefinition,
    double value
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamDataCell
The DataCell parent of this AnalogValue.
analogDefinition
Type: GSF.PhasorProtocols.BPAPDCstreamAnalogDefinition
The AnalogDefinition associated with this AnalogValue.
value
Type: SystemDouble
The floating point value that represents this AnalogValue.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue Methods

Grid Solutions Framework AnalogValue Methods

The AnalogValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from AnalogValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue Properties

Grid Solutions Framework AnalogValue Properties

The AnalogValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this AnalogValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue.Definition Property

Grid Solutions Framework AnalogValueDefinition Property
Gets or sets the AnalogDefinition associated with this AnalogValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AnalogDefinition Definition { get; set; }
Public Overridable Property Definition As AnalogDefinition
    Get
    Set
abstract Definition : AnalogDefinition with get, set
override Definition : AnalogDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property AnalogDefinition^ Definition {
    AnalogDefinition^ get ();
    void set (AnalogDefinition^ value);
}

Property Value

Type: AnalogDefinition
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


AnalogValue.Parent Property

Grid Solutions Framework AnalogValueParent Property
Gets or sets the DataCell parent of this AnalogValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ChannelFlags Enumeration

Grid Solutions Framework ChannelFlags Enumeration
Channel flags enumeration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum ChannelFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration ChannelFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type ChannelFlags
GSF.PhasorProtocols.BPAPDCstream.ChannelFlags = function();
GSF.PhasorProtocols.BPAPDCstream.ChannelFlags.createEnum('GSF.PhasorProtocols.BPAPDCstream.ChannelFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class ChannelFlags
Members
Member name | Value | Description
DataIsValid | 128 | Valid if not set (yes = 0).
TransmissionErrors | 64 | Errors if set (yes = 1).
PmuSynchronized | 32 | Not sync'd if set (yes = 0).
DataSortedByArrival | 16 | Data out of sync if set (yes = 1).
DataSortedByTimestamp | 8 | Sorted by timestamp if not set (yes = 0).
PdcExchangeFormat | 4 | PDC format if set (yes = 1).
MacrodyneFormat | 2 | Macrodyne or IEEE format (Macrodyne = 1).
TimestampIncluded | 1 | Timestamp included if not set (yes = 0).
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


Common Class

Grid Solutions Framework Common Class
Common BPA PDCstream declarations and functions.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.BPAPDCstreamCommon

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.BPAPDCstream.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.Common');
public ref class Common abstract sealed

The Common type exposes the following members.

Fields
Name | Description
DescriptorPacketFlag | Descriptor packet flag.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
PhasorFileFormatFlag | Phasor file format flag.
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
DescriptorPacketFlag | Descriptor packet flag.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
PhasorFileFormatFlag | Phasor file format flag.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.BPAPDCstream Namespace


Common.DescriptorPacketFlag Field

Grid Solutions Framework CommonDescriptorPacketFlag Field
Descriptor packet flag.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte DescriptorPacketFlag
Public Const DescriptorPacketFlag As Byte
static val mutable DescriptorPacketFlag: byte
var GSF.PhasorProtocols.BPAPDCstream.Common.DescriptorPacketFlag
public:
literal unsigned char DescriptorPacketFlag

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.BPAPDCstream Namespace


Common.MaximumAnalogValues Field

Grid Solutions Framework CommonMaximumAnalogValues Field
Absolute maximum number of possible analog values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
static val mutable MaximumAnalogValues: uint16
var GSF.PhasorProtocols.BPAPDCstream.Common.MaximumAnalogValues
public:
literal unsigned short MaximumAnalogValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.BPAPDCstream Namespace


Common.MaximumDataLength Field

Grid Solutions Framework CommonMaximumDataLength Field
Absolute maximum data length (in bytes) that could fit into any frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
static val mutable MaximumDataLength: uint16
var GSF.PhasorProtocols.BPAPDCstream.Common.MaximumDataLength
public:
literal unsigned short MaximumDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.BPAPDCstream Namespace


Common.MaximumDigitalValues Field

Grid Solutions Framework CommonMaximumDigitalValues Field
Absolute maximum number of possible digital values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
static val mutable MaximumDigitalValues: uint16
var GSF.PhasorProtocols.BPAPDCstream.Common.MaximumDigitalValues
public:
literal unsigned short MaximumDigitalValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.BPAPDCstream Namespace


Common.MaximumPhasorValues Field

Grid Solutions Framework CommonMaximumPhasorValues Field
Absolute maximum number of possible phasor values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
static val mutable MaximumPhasorValues: uint16
var GSF.PhasorProtocols.BPAPDCstream.Common.MaximumPhasorValues
public:
literal unsigned short MaximumPhasorValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.BPAPDCstream Namespace


Common.PhasorFileFormatFlag Field

Grid Solutions Framework CommonPhasorFileFormatFlag Field
Phasor file format flag.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte PhasorFileFormatFlag
Public Const PhasorFileFormatFlag As Byte
static val mutable PhasorFileFormatFlag: byte
var GSF.PhasorProtocols.BPAPDCstream.Common.PhasorFileFormatFlag
public:
literal unsigned char PhasorFileFormatFlag

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Class

Grid Solutions Framework CommonFrameHeader Class
Represents the common header for all BPA PDCstream frames of data.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.BPAPDCstreamCommonFrameHeader

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
<SerializableAttribute>
Public Class CommonFrameHeader
    Implements ICommonHeader(Of FrameType), ISerializable
[<SerializableAttribute>]
type CommonFrameHeader =
    class
        interface ICommonHeader<FrameType>
        interface ISerializable
    end
GSF.PhasorProtocols.BPAPDCstream.CommonFrameHeader = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.CommonFrameHeader',
    null,
    GSF.Parsing.ICommonHeader`1,
    ISerializable);
[SerializableAttribute]
public ref class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable

The CommonFrameHeader type exposes the following members.

Constructors
 | Name | Description
Public method | CommonFrameHeader(Byte) | Creates a new CommonFrameHeader from specified parameters.
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(Boolean, Boolean, ConfigurationFrame, Byte, Int32, Int32) | Creates a new CommonFrameHeader from given buffer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DstHeaderFixedLength | Total fixed length of CommonFrameHeader for header in phasor file format data.
FixedLength | Total fixed length of CommonFrameHeader, streaming data or data row in phasor file format data.
Top
Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | DataLength | Gets or sets the length of the data in the BPA PDCstream frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FileType | Gets or sets file type for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
Public property | FileVersion | Gets or sets file version for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
Public property | FrameLength | Gets or sets the BPA PDCstream frame length of this frame.
Public property | FrameRate | Gets frame rate based on sample rate and sample interval for the CommonFrameHeader object.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | PacketNumber | Gets or sets the BPA PDCstream packet number of this frame - set to 00 for configuration frame
Public property | PmuCount | Gets or sets PMU count (i.e., number of cells) for the CommonFrameHeader object when use phasor file format is true.
Public property | PreTriggerRows | Gets or sets pre-trigger rows for the CommonFrameHeader object when use phasor file format is true.
Public property | RoughTimestamp | Gets rough timestamp, accuarate to the second, that can be used until configuration frame arrives.
Public property | RowFlags | Gets or sets row flags for this CommonFrameHeader when frame is a data frame and use phasor file format is true.
Public property | RowLength | Gets or sets row length for the CommonFrameHeader object when use phasor file format is true.
Public property | SampleInterval | Gets or sets sample interval for the CommonFrameHeader object.
Public property | SampleRate | Gets or sets sample rate for the CommonFrameHeader object.
Public property | SourceID | Gets or sets source ID for the CommonFrameHeader object.
Public property | StartSample | Gets or sets start sample for the CommonFrameHeader object.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | TotalRows | Gets or sets total number of data rows for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerPMU | Gets or sets trigger PMU number for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerSample | Gets or sets trigger sample for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerTime | Gets or sets trigger time for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerType | Gets or sets trigger type for the CommonFrameHeader object when use phasor file format is true.
Public property | TypeID | Gets or sets the BPA PDCstream specific frame type of this frame.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | UserInformation | Gets or sets free-form user information that can be added to the CommonFrameHeader object when use phasor file format is true.
Public property | WordCount | Gets or sets the BPA PDcstream word count.
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Overload List
 | Name | Description
Public method | CommonFrameHeader(Byte) | Creates a new CommonFrameHeader from specified parameters.
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(Boolean, Boolean, ConfigurationFrame, Byte, Int32, Int32) | Creates a new CommonFrameHeader from given buffer.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Constructor (Byte)

Grid Solutions Framework CommonFrameHeader Constructor (Byte)
Creates a new CommonFrameHeader from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    byte packetNumber
)
Public Sub New (
    packetNumber As Byte
)
new :
        packetNumber : byte -> CommonFrameHeader
GSF.PhasorProtocols.BPAPDCstream.CommonFrameHeader = function(packetNumber);
public:
CommonFrameHeader(
    unsigned char packetNumber
)

Parameters

packetNumber
Type: SystemByte
The BPA PDCstream packet number, configuration frame is packet zero.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommonFrameHeader Constructor (SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommonFrameHeader
GSF.PhasorProtocols.BPAPDCstream.CommonFrameHeader = function(info, context);
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Constructor (Boolean, Boolean, ConfigurationFrame, Byte[], Int32, Int32)

Grid Solutions Framework CommonFrameHeader Constructor (Boolean, Boolean, ConfigurationFrame, Byte, Int32, Int32)
Creates a new CommonFrameHeader from given buffer.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    bool parseWordCountFromByte,
    bool usePhasorDataFileFormat,
    ConfigurationFrame configFrame,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    parseWordCountFromByte As Boolean,
    usePhasorDataFileFormat As Boolean,
    configFrame As ConfigurationFrame,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        parseWordCountFromByte : bool *
        usePhasorDataFileFormat : bool *
        configFrame : ConfigurationFrame *
        buffer : byte[] *
        startIndex : int *
        length : int -> CommonFrameHeader
GSF.PhasorProtocols.BPAPDCstream.CommonFrameHeader = function(parseWordCountFromByte, usePhasorDataFileFormat, configFrame, buffer, startIndex, length);
public:
CommonFrameHeader(
    bool parseWordCountFromByte,
    bool usePhasorDataFileFormat,
    ConfigurationFrame^ configFrame,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

parseWordCountFromByte
Type: SystemBoolean
Defines flag that interprets word count in packet header from a byte instead of a word.
usePhasorDataFileFormat
Type: SystemBoolean
Defines flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
configFrame
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationFrame
Previously parsed configuration frame, if available.
buffer
Type: SystemByte
Buffer that contains data to parse.
startIndex
Type: SystemInt32
Start index into buffer where valid data begins.
length
Type: SystemInt32
Maximum length of valid data from start index.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Fields

Grid Solutions Framework CommonFrameHeader Fields

The CommonFrameHeader type exposes the following members.

Fields
Name | Description
DstHeaderFixedLength | Total fixed length of CommonFrameHeader for header in phasor file format data.
FixedLength | Total fixed length of CommonFrameHeader, streaming data or data row in phasor file format data.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.DstHeaderFixedLength Field

Grid Solutions Framework CommonFrameHeaderDstHeaderFixedLength Field
Total fixed length of CommonFrameHeader for header in phasor file format data.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort DstHeaderFixedLength
Public Const DstHeaderFixedLength As UShort
static val mutable DstHeaderFixedLength: uint16
var GSF.PhasorProtocols.BPAPDCstream.CommonFrameHeader.DstHeaderFixedLength
public:
literal unsigned short DstHeaderFixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.FixedLength Field

Grid Solutions Framework CommonFrameHeaderFixedLength Field
Total fixed length of CommonFrameHeader, streaming data or data row in phasor file format data.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FixedLength
Public Const FixedLength As UShort
static val mutable FixedLength: uint16
var GSF.PhasorProtocols.BPAPDCstream.CommonFrameHeader.FixedLength
public:
literal unsigned short FixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Methods

Grid Solutions Framework CommonFrameHeader Methods

The CommonFrameHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.GetObjectData Method

Grid Solutions Framework CommonFrameHeaderGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader Properties

Grid Solutions Framework CommonFrameHeader Properties

The CommonFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | DataLength | Gets or sets the length of the data in the BPA PDCstream frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FileType | Gets or sets file type for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
Public property | FileVersion | Gets or sets file version for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.
Public property | FrameLength | Gets or sets the BPA PDCstream frame length of this frame.
Public property | FrameRate | Gets frame rate based on sample rate and sample interval for the CommonFrameHeader object.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | PacketNumber | Gets or sets the BPA PDCstream packet number of this frame - set to 00 for configuration frame
Public property | PmuCount | Gets or sets PMU count (i.e., number of cells) for the CommonFrameHeader object when use phasor file format is true.
Public property | PreTriggerRows | Gets or sets pre-trigger rows for the CommonFrameHeader object when use phasor file format is true.
Public property | RoughTimestamp | Gets rough timestamp, accuarate to the second, that can be used until configuration frame arrives.
Public property | RowFlags | Gets or sets row flags for this CommonFrameHeader when frame is a data frame and use phasor file format is true.
Public property | RowLength | Gets or sets row length for the CommonFrameHeader object when use phasor file format is true.
Public property | SampleInterval | Gets or sets sample interval for the CommonFrameHeader object.
Public property | SampleRate | Gets or sets sample rate for the CommonFrameHeader object.
Public property | SourceID | Gets or sets source ID for the CommonFrameHeader object.
Public property | StartSample | Gets or sets start sample for the CommonFrameHeader object.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | TotalRows | Gets or sets total number of data rows for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerPMU | Gets or sets trigger PMU number for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerSample | Gets or sets trigger sample for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerTime | Gets or sets trigger time for the CommonFrameHeader object when use phasor file format is true.
Public property | TriggerType | Gets or sets trigger type for the CommonFrameHeader object when use phasor file format is true.
Public property | TypeID | Gets or sets the BPA PDCstream specific frame type of this frame.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | UserInformation | Gets or sets free-form user information that can be added to the CommonFrameHeader object when use phasor file format is true.
Public property | WordCount | Gets or sets the BPA PDcstream word count.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.BinaryImage Property

Grid Solutions Framework CommonFrameHeaderBinaryImage Property
Gets the binary image of the common header portion of this frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
member BinaryImage : byte[] with get

function get_BinaryImage();

public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.DataLength Property

Grid Solutions Framework CommonFrameHeaderDataLength Property
Gets or sets the length of the data in the BPA PDCstream frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DataLength { get; set; }
Public Property DataLength As UShort
    Get
    Set
member DataLength : uint16 with get, set

function get_DataLength();
function set_DataLength(value);
public:
property unsigned short DataLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.FileType Property

Grid Solutions Framework CommonFrameHeaderFileType Property
Gets or sets file type for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileType FileType { get; set; }
Public Property FileType As FileType
    Get
    Set
member FileType : FileType with get, set

function get_FileType();
function set_FileType(value);
public:
property FileType FileType {
    FileType get ();
    void set (FileType value);
}

Property Value

Type: FileType
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.FileVersion Property

Grid Solutions Framework CommonFrameHeaderFileVersion Property
Gets or sets file version for this CommonFrameHeader used when frame is configuration frame and use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FileVersion FileVersion { get; set; }
Public Property FileVersion As FileVersion
    Get
    Set
member FileVersion : FileVersion with get, set

function get_FileVersion();
function set_FileVersion(value);
public:
property FileVersion FileVersion {
    FileVersion get ();
    void set (FileVersion value);
}

Property Value

Type: FileVersion
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.FrameLength Property

Grid Solutions Framework CommonFrameHeaderFrameLength Property
Gets or sets the BPA PDCstream frame length of this frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort FrameLength { get; set; }
Public Property FrameLength As UShort
    Get
    Set
member FrameLength : uint16 with get, set

function get_FrameLength();
function set_FrameLength(value);
public:
property unsigned short FrameLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.FrameRate Property

Grid Solutions Framework CommonFrameHeaderFrameRate Property
Gets frame rate based on sample rate and sample interval for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double FrameRate { get; }
Public ReadOnly Property FrameRate As Double
    Get
member FrameRate : float with get

function get_FrameRate();

public:
property double FrameRate {
    double get ();
}

Property Value

Type: Double
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.FrameType Property

Grid Solutions Framework CommonFrameHeaderFrameType Property
Gets the fundamental frame type of this frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
member FrameType : FundamentalFrameType with get

function get_FrameType();

public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}

Property Value

Type: FundamentalFrameType
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.PacketNumber Property

Grid Solutions Framework CommonFrameHeaderPacketNumber Property
Gets or sets the BPA PDCstream packet number of this frame - set to 00 for configuration frame

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte PacketNumber { get; set; }
Public Property PacketNumber As Byte
    Get
    Set
member PacketNumber : byte with get, set

function get_PacketNumber();
function set_PacketNumber(value);
public:
property unsigned char PacketNumber {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.PmuCount Property

Grid Solutions Framework CommonFrameHeaderPmuCount Property
Gets or sets PMU count (i.e., number of cells) for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint PmuCount { get; set; }
Public Property PmuCount As UInteger
    Get
    Set
member PmuCount : uint32 with get, set

function get_PmuCount();
function set_PmuCount(value);
public:
property unsigned int PmuCount {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.PreTriggerRows Property

Grid Solutions Framework CommonFrameHeaderPreTriggerRows Property
Gets or sets pre-trigger rows for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint PreTriggerRows { get; set; }
Public Property PreTriggerRows As UInteger
    Get
    Set
member PreTriggerRows : uint32 with get, set

function get_PreTriggerRows();
function set_PreTriggerRows(value);
public:
property unsigned int PreTriggerRows {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.RoughTimestamp Property

Grid Solutions Framework CommonFrameHeaderRoughTimestamp Property
Gets rough timestamp, accuarate to the second, that can be used until configuration frame arrives.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks RoughTimestamp { get; }
Public ReadOnly Property RoughTimestamp As Ticks
    Get
member RoughTimestamp : Ticks with get

function get_RoughTimestamp();

public:
property Ticks RoughTimestamp {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.RowFlags Property

Grid Solutions Framework CommonFrameHeaderRowFlags Property
Gets or sets row flags for this CommonFrameHeader when frame is a data frame and use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint RowFlags { get; set; }
Public Property RowFlags As UInteger
    Get
    Set
member RowFlags : uint32 with get, set

function get_RowFlags();
function set_RowFlags(value);
public:
property unsigned int RowFlags {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.RowLength Property

Grid Solutions Framework CommonFrameHeaderRowLength Property
Gets or sets row length for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint RowLength { get; set; }
Public Property RowLength As UInteger
    Get
    Set
member RowLength : uint32 with get, set

function get_RowLength();
function set_RowLength(value);
public:
property unsigned int RowLength {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.SampleInterval Property

Grid Solutions Framework CommonFrameHeaderSampleInterval Property
Gets or sets sample interval for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleInterval { get; set; }
Public Property SampleInterval As UShort
    Get
    Set
member SampleInterval : uint16 with get, set

function get_SampleInterval();
function set_SampleInterval(value);
public:
property unsigned short SampleInterval {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.SampleRate Property

Grid Solutions Framework CommonFrameHeaderSampleRate Property
Gets or sets sample rate for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleRate { get; set; }
Public Property SampleRate As UShort
    Get
    Set
member SampleRate : uint16 with get, set

function get_SampleRate();
function set_SampleRate(value);
public:
property unsigned short SampleRate {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.SourceID Property

Grid Solutions Framework CommonFrameHeaderSourceID Property
Gets or sets source ID for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SourceID { get; set; }
Public Property SourceID As String
    Get
    Set
member SourceID : string with get, set

function get_SourceID();
function set_SourceID(value);
public:
property String^ SourceID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.StartSample Property

Grid Solutions Framework CommonFrameHeaderStartSample Property
Gets or sets start sample for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint StartSample { get; set; }
Public Property StartSample As UInteger
    Get
    Set
member StartSample : uint32 with get, set

function get_StartSample();
function set_StartSample(value);
public:
property unsigned int StartSample {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.State Property

Grid Solutions Framework CommonFrameHeaderState Property
Gets or sets the parsing state for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IChannelParsingState State { get; set; }
Public Property State As IChannelParsingState
    Get
    Set
member State : IChannelParsingState with get, set

function get_State();
function set_State(value);
public:
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}

Property Value

Type: IChannelParsingState
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.TotalRows Property

Grid Solutions Framework CommonFrameHeaderTotalRows Property
Gets or sets total number of data rows for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint TotalRows { get; set; }
Public Property TotalRows As UInteger
    Get
    Set
member TotalRows : uint32 with get, set

function get_TotalRows();
function set_TotalRows(value);
public:
property unsigned int TotalRows {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.TriggerPMU Property

Grid Solutions Framework CommonFrameHeaderTriggerPMU Property
Gets or sets trigger PMU number for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort TriggerPMU { get; set; }
Public Property TriggerPMU As UShort
    Get
    Set
member TriggerPMU : uint16 with get, set

function get_TriggerPMU();
function set_TriggerPMU(value);
public:
property unsigned short TriggerPMU {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.TriggerSample Property

Grid Solutions Framework CommonFrameHeaderTriggerSample Property
Gets or sets trigger sample for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint TriggerSample { get; set; }
Public Property TriggerSample As UInteger
    Get
    Set
member TriggerSample : uint32 with get, set

function get_TriggerSample();
function set_TriggerSample(value);
public:
property unsigned int TriggerSample {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.TriggerTime Property

Grid Solutions Framework CommonFrameHeaderTriggerTime Property
Gets or sets trigger time for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks TriggerTime { get; set; }
Public Property TriggerTime As Ticks
    Get
    Set
member TriggerTime : Ticks with get, set

function get_TriggerTime();
function set_TriggerTime(value);
public:
property Ticks TriggerTime {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.TriggerType Property

Grid Solutions Framework CommonFrameHeaderTriggerType Property
Gets or sets trigger type for the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort TriggerType { get; set; }
Public Property TriggerType As UShort
    Get
    Set
member TriggerType : uint16 with get, set

function get_TriggerType();
function set_TriggerType(value);
public:
property unsigned short TriggerType {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.TypeID Property

Grid Solutions Framework CommonFrameHeaderTypeID Property
Gets or sets the BPA PDCstream specific frame type of this frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ICommonHeaderTTypeIdentifierTypeID
Remarks

This returns the protocol specific frame classification which uniquely identifies the frame type.

This is the TypeID implementation.

See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.UsePhasorDataFileFormat Property

Grid Solutions Framework CommonFrameHeaderUsePhasorDataFileFormat Property
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsePhasorDataFileFormat { get; set; }
Public Property UsePhasorDataFileFormat As Boolean
    Get
    Set
member UsePhasorDataFileFormat : bool with get, set

function get_UsePhasorDataFileFormat();
function set_UsePhasorDataFileFormat(value);
public:
property bool UsePhasorDataFileFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.UserInformation Property

Grid Solutions Framework CommonFrameHeaderUserInformation Property
Gets or sets free-form user information that can be added to the CommonFrameHeader object when use phasor file format is true.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string UserInformation { get; set; }
Public Property UserInformation As String
    Get
    Set
member UserInformation : string with get, set

function get_UserInformation();
function set_UserInformation(value);
public:
property String^ UserInformation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


CommonFrameHeader.WordCount Property

Grid Solutions Framework CommonFrameHeaderWordCount Property
Gets or sets the BPA PDcstream word count.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort WordCount { get; set; }
Public Property WordCount As UShort
    Get
    Set
member WordCount : uint16 with get, set

function get_WordCount();
function set_WordCount(value);
public:
property unsigned short WordCount {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents the BPA PDCstream implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.BPAPDCstreamConfigurationCell

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
    end
GSF.PhasorProtocols.BPAPDCstream.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ConfigurationCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCell object. (Overrides ConfigurationCellBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ConfigurationCellBaseBodyLength.)
Public property | ConfigurationFileCell | Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FormatFlags | Gets or sets format flags of this ConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDefinition.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ConfigurationCell. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCell. (Overrides ConfigurationCellBaseIDLabelLength.)
Public property | IsPdcBlockSection | Gets flag that determines if current SectionEntry defines a PDC block section.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseNominalFrequency.)
Public property | Offset | Gets or sets BPA PDCstream descriptor offset of this ConfigurationCell in its data packet.
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDefinitions.)
Public property | Reserved | Gets or sets reserved word of this ConfigurationCell.
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | SectionEntry | Gets or sets section entry in INI based configuration file for this ConfigurationCell.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCell. (Overrides ConfigurationCellBaseStationName.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UsePhasorDataFileFormat | Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Overload List
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell Constructor (IConfigurationFrame)

Grid Solutions Framework ConfigurationCell Constructor (IConfigurationFrame)
Creates a new ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    IConfigurationFrame parent
)
Public Sub New (
    parent As IConfigurationFrame
)
new :
        parent : IConfigurationFrame -> ConfigurationCell
GSF.PhasorProtocols.BPAPDCstream.ConfigurationCell = function(parent);
public:
ConfigurationCell(
    IConfigurationFrame^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationFrame
The reference to parent IConfigurationFrame of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCell Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.BPAPDCstream.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell Constructor (ConfigurationFrame, UInt16, LineFrequency)

Grid Solutions Framework ConfigurationCell Constructor (ConfigurationFrame, UInt16, LineFrequency)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ConfigurationFrame parent,
    ushort idCode,
    LineFrequency nominalFrequency = LineFrequency.Hz60
)
Public Sub New (
    parent As ConfigurationFrame,
    idCode As UShort,
    Optional nominalFrequency As LineFrequency = LineFrequency.Hz60
)
new :
        parent : ConfigurationFrame *
        idCode : uint16 *
        ?nominalFrequency : LineFrequency
(* Defaults:
        let _nominalFrequency = defaultArg nominalFrequency LineFrequency.Hz60
*)
-> ConfigurationCell
GSF.PhasorProtocols.BPAPDCstream.ConfigurationCell = function(parent, idCode, nominalFrequency);
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    unsigned short idCode,
    LineFrequency nominalFrequency = LineFrequency::Hz60
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationFrame
The reference to parent ConfigurationFrame of this ConfigurationCell.
idCode
Type: SystemUInt16
The numeric ID code for this ConfigurationCell.
nominalFrequency (Optional)
Type: GSF.Units.EELineFrequency
The nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ConfigurationCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.GetObjectData Method

Grid Solutions Framework ConfigurationCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.ParseBodyImage Method

Grid Solutions Framework ConfigurationCellParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.ParseFooterImage Method

Grid Solutions Framework ConfigurationCellParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.ParseHeaderImage Method

Grid Solutions Framework ConfigurationCellParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCell object. (Overrides ConfigurationCellBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ConfigurationCellBaseBodyLength.)
Public property | ConfigurationFileCell | Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FormatFlags | Gets or sets format flags of this ConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDefinition.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ConfigurationCell. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCell. (Overrides ConfigurationCellBaseIDLabelLength.)
Public property | IsPdcBlockSection | Gets flag that determines if current SectionEntry defines a PDC block section.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseNominalFrequency.)
Public property | Offset | Gets or sets BPA PDCstream descriptor offset of this ConfigurationCell in its data packet.
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDefinitions.)
Public property | Reserved | Gets or sets reserved word of this ConfigurationCell.
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | SectionEntry | Gets or sets section entry in INI based configuration file for this ConfigurationCell.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCell. (Overrides ConfigurationCellBaseStationName.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UsePhasorDataFileFormat | Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.Attributes Property

Grid Solutions Framework ConfigurationCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.BodyImage Property

Grid Solutions Framework ConfigurationCellBodyImage Property
Gets the binary body image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.BodyLength Property

Grid Solutions Framework ConfigurationCellBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.ConfigurationFileCell Property

Grid Solutions Framework ConfigurationCellConfigurationFileCell Property
Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationFileCell { get; set; }
Public Property ConfigurationFileCell As ConfigurationCell
    Get
    Set
member ConfigurationFileCell : ConfigurationCell with get, set

function get_ConfigurationFileCell();
function set_ConfigurationFileCell(value);
public:
property ConfigurationCell^ ConfigurationFileCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.FooterImage Property

Grid Solutions Framework ConfigurationCellFooterImage Property
Gets the binary footer image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.FooterLength Property

Grid Solutions Framework ConfigurationCellFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.FormatFlags Property

Grid Solutions Framework ConfigurationCellFormatFlags Property
Gets or sets format flags of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public FormatFlags FormatFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property FormatFlags As FormatFlags
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member FormatFlags : FormatFlags with get, set

function get_FormatFlags();
function set_FormatFlags(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property FormatFlags FormatFlags {
    FormatFlags get ();
    void set (FormatFlags value);
}

Property Value

Type: FormatFlags
Remarks
These are bit flags, use properties to change basic values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.FrequencyDefinition Property

Grid Solutions Framework ConfigurationCellFrequencyDefinition Property
Gets or sets the IFrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IFrequencyDefinition FrequencyDefinition { get; set; }
Public Overrides Property FrequencyDefinition As IFrequencyDefinition
    Get
    Set
abstract FrequencyDefinition : IFrequencyDefinition with get, set
override FrequencyDefinition : IFrequencyDefinition with get, set
function get_FrequencyDefinition();
function set_FrequencyDefinition(value);
public:
virtual property IFrequencyDefinition^ FrequencyDefinition {
    IFrequencyDefinition^ get () override;
    void set (IFrequencyDefinition^ value) override;
}

Property Value

Type: IFrequencyDefinition

Implements

IConfigurationCellFrequencyDefinition
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.HeaderImage Property

Grid Solutions Framework ConfigurationCellHeaderImage Property
Gets the binary header image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.HeaderLength Property

Grid Solutions Framework ConfigurationCellHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.IDCode Property

Grid Solutions Framework ConfigurationCellIDCode Property
Gets or sets the numeric ID code for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}

Property Value

Type: UInt16

Implements

IChannelCellIDCode
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.IDLabelLength Property

Grid Solutions Framework ConfigurationCellIDLabelLength Property
Gets the length of the IDLabel of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int IDLabelLength { get; }
Public Overrides ReadOnly Property IDLabelLength As Integer
    Get
abstract IDLabelLength : int with get
override IDLabelLength : int with get
function get_IDLabelLength();

public:
virtual property int IDLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IConfigurationCellIDLabelLength
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.IsPdcBlockSection Property

Grid Solutions Framework ConfigurationCellIsPdcBlockSection Property
Gets flag that determines if current SectionEntry defines a PDC block section.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsPdcBlockSection { get; }
Public ReadOnly Property IsPdcBlockSection As Boolean
    Get
member IsPdcBlockSection : bool with get

function get_IsPdcBlockSection();

public:
property bool IsPdcBlockSection {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.MaximumStationNameLength Property

Grid Solutions Framework ConfigurationCellMaximumStationNameLength Property
Gets the maximum length of the StationName of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
abstract MaximumStationNameLength : int with get
override MaximumStationNameLength : int with get
function get_MaximumStationNameLength();

public:
virtual property int MaximumStationNameLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IConfigurationCellMaximumStationNameLength
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.NominalFrequency Property

Grid Solutions Framework ConfigurationCellNominalFrequency Property
Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override LineFrequency NominalFrequency { get; set; }
Public Overrides Property NominalFrequency As LineFrequency
    Get
    Set
abstract NominalFrequency : LineFrequency with get, set
override NominalFrequency : LineFrequency with get, set
function get_NominalFrequency();
function set_NominalFrequency(value);
public:
virtual property LineFrequency NominalFrequency {
    LineFrequency get () override;
    void set (LineFrequency value) override;
}

Property Value

Type: LineFrequency

Implements

IConfigurationCellNominalFrequency
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.Offset Property

Grid Solutions Framework ConfigurationCellOffset Property
Gets or sets BPA PDCstream descriptor offset of this ConfigurationCell in its data packet.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Offset { get; set; }
Public Property Offset As UShort
    Get
    Set
member Offset : uint16 with get, set

function get_Offset();
function set_Offset(value);
public:
property unsigned short Offset {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.Parent Property

Grid Solutions Framework ConfigurationCellParent Property
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
member Parent : ConfigurationFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.PhasorDefinitions Property

Grid Solutions Framework ConfigurationCellPhasorDefinitions Property
Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override PhasorDefinitionCollection PhasorDefinitions { get; }
Public Overrides ReadOnly Property PhasorDefinitions As PhasorDefinitionCollection
    Get
abstract PhasorDefinitions : PhasorDefinitionCollection with get
override PhasorDefinitions : PhasorDefinitionCollection with get
function get_PhasorDefinitions();

public:
virtual property PhasorDefinitionCollection^ PhasorDefinitions {
    PhasorDefinitionCollection^ get () override;
}

Property Value

Type: PhasorDefinitionCollection

Implements

IConfigurationCellPhasorDefinitions
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.Reserved Property

Grid Solutions Framework ConfigurationCellReserved Property
Gets or sets reserved word of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Reserved { get; set; }
Public Property Reserved As UShort
    Get
    Set
member Reserved : uint16 with get, set

function get_Reserved();
function set_Reserved(value);
public:
property unsigned short Reserved {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.SectionEntry Property

Grid Solutions Framework ConfigurationCellSectionEntry Property
Gets or sets section entry in INI based configuration file for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SectionEntry { get; set; }
Public Property SectionEntry As String
    Get
    Set
member SectionEntry : string with get, set

function get_SectionEntry();
function set_SectionEntry(value);
public:
property String^ SectionEntry {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.StationName Property

Grid Solutions Framework ConfigurationCellStationName Property
Gets or sets the station name of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string StationName { get; set; }
Public Overrides Property StationName As String
    Get
    Set
abstract StationName : string with get, set
override StationName : string with get, set
function get_StationName();
function set_StationName(value);
public:
virtual property String^ StationName {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String

Implements

IConfigurationCellStationName
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCell.UsePhasorDataFileFormat Property

Grid Solutions Framework ConfigurationCellUsePhasorDataFileFormat Property
Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
member UsePhasorDataFileFormat : bool with get

function get_UsePhasorDataFileFormat();

public:
property bool UsePhasorDataFileFormat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a BPA PDCstream implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.BPAPDCstreamConfigurationCellCollection

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.BPAPDCstream.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetBySectionEntry | Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.BPAPDCstream.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.BPAPDCstream.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetBySectionEntry | Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection.TryGetBySectionEntry Method

Grid Solutions Framework ConfigurationCellCollectionTryGetBySectionEntry Method
Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetBySectionEntry(
    string sectionEntry,
    ref ConfigurationCell configurationCell
)
Public Function TryGetBySectionEntry (
    sectionEntry As String,
    ByRef configurationCell As ConfigurationCell
) As Boolean
member TryGetBySectionEntry :
        sectionEntry : string *
        configurationCell : ConfigurationCell byref -> bool

function TryGetBySectionEntry(sectionEntry, configurationCell);
public:
bool TryGetBySectionEntry(
    String^ sectionEntry,
    ConfigurationCell^% configurationCell
)

Parameters

sectionEntry
Type: SystemString
SectionEntry value to try to find.
configurationCell
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
ConfigurationCell with the specified sectionEntry if found; otherwise null.

Return Value

Type: Boolean
true if ConfigurationCell with the specified sectionEntry is found; otherwise false.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Class

Grid Solutions Framework ConfigurationFrame Class
Represents the BPA PDCstream implementation of a IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.BPAPDCstreamConfigurationFrame

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class ConfigurationFrame
    Inherits ConfigurationFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type ConfigurationFrame =
    class
        inherit ConfigurationFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame',
    GSF.PhasorProtocols.ConfigurationFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The ConfigurationFrame type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(Ticks, String, UInt16, RevisionNumber, StreamType) | Creates a new ConfigurationFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
 | GetIniFileImage | Gets a generated INI configuration file image.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | Refresh | Reload BPA PDcstream INI based configuration file.
Public method | Refresh(Boolean) | Reload BPA PDcstream INI based configuration file specifying if the refresh was caused by a frame parse.
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
DefaultCurrentPhasorEntry | Default current phasor INI based configuration entry.
DefaultFrequencyEntry | Default frequency INI based configuration entry.
DefaultVoltagePhasorEntry | Default voltage phasor INI based configuration entry.
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFileCells | Gets reference to the ConfigurationCellCollection loaded from the configuration file of this ConfigurationFrame.
Public property | ConfigurationFileName | Gets the INI based configuration file name of this ConfigurationFrame.
Public property | DefaultFrequency | Gets the default frequency definition.
Public property | DefaultPhasorI | Gets the default current phasor definition.
Public property | DefaultPhasorV | Gets the default voltage phasor definition.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PacketsPerSample | Gets or sets the number of packets per sample of this ConfigurationFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | RevisionNumber | Gets or sets the RevisionNumber of this ConfigurationFrame.
Public property | SampleIndex | Gets or sets current sample index used to calculate row time stamp when source data is in the Phasor Data File Format (i.e., a DST file).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | StreamType | Gets or sets the BPA PDCstream protocol StreamType, i.e., legacy or compact, of this ConfigurationFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
Events
 | Name | Description
Public event | ConfigurationFileReloaded | Occurs when the BPA PDCstream INI based configuration file has been reloaded.
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(Ticks, String, UInt16, RevisionNumber, StreamType) | Creates a new ConfigurationFrame from specified parameters.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Creates a new ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame
GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse a BPA PDCstream configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame
GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame = function(info, context);
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Constructor (Ticks, String, UInt16, RevisionNumber, StreamType)

Grid Solutions Framework ConfigurationFrame Constructor (Ticks, String, UInt16, RevisionNumber, StreamType)
Creates a new ConfigurationFrame from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame(
    Ticks timestamp,
    string configurationFileName,
    ushort packetsPerSample,
    RevisionNumber revisionNumber,
    StreamType streamType
)
Public Sub New (
    timestamp As Ticks,
    configurationFileName As String,
    packetsPerSample As UShort,
    revisionNumber As RevisionNumber,
    streamType As StreamType
)
new :
        timestamp : Ticks *
        configurationFileName : string *
        packetsPerSample : uint16 *
        revisionNumber : RevisionNumber *
        streamType : StreamType -> ConfigurationFrame
GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame = function(timestamp, configurationFileName, packetsPerSample, revisionNumber, streamType);
public:
ConfigurationFrame(
    Ticks timestamp,
    String^ configurationFileName,
    unsigned short packetsPerSample,
    RevisionNumber revisionNumber,
    StreamType streamType
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
configurationFileName
Type: SystemString
The required external BPA PDCstream INI based configuration file.
packetsPerSample
Type: SystemUInt16
Number of packets per sample.
revisionNumber
Type: GSF.PhasorProtocols.BPAPDCstreamRevisionNumber
Defines the RevisionNumber for this BPA PDCstream configuration frame.
streamType
Type: GSF.PhasorProtocols.BPAPDCstreamStreamType
Defines the StreamType for this BPA PDCstream configuration frame.
Remarks

This constructor is used by a consumer to generate a BPA PDCstream configuration frame.

If you are going to create multiple data packets set packetsPerSample to a number greater than one. This will only start becoming necessary if you start hitting data size limits imposed by the nature of the transport protocol.

See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Fields

Grid Solutions Framework ConfigurationFrame Fields

The ConfigurationFrame type exposes the following members.

Fields
Name | Description
DefaultCurrentPhasorEntry | Default current phasor INI based configuration entry.
DefaultFrequencyEntry | Default frequency INI based configuration entry.
DefaultVoltagePhasorEntry | Default voltage phasor INI based configuration entry.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.DefaultCurrentPhasorEntry Field

Grid Solutions Framework ConfigurationFrameDefaultCurrentPhasorEntry Field
Default current phasor INI based configuration entry.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultCurrentPhasorEntry
Public Const DefaultCurrentPhasorEntry As String
static val mutable DefaultCurrentPhasorEntry: string
var GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame.DefaultCurrentPhasorEntry
public:
literal String^ DefaultCurrentPhasorEntry

Field Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.DefaultFrequencyEntry Field

Grid Solutions Framework ConfigurationFrameDefaultFrequencyEntry Field
Default frequency INI based configuration entry.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultFrequencyEntry
Public Const DefaultFrequencyEntry As String
static val mutable DefaultFrequencyEntry: string
var GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame.DefaultFrequencyEntry
public:
literal String^ DefaultFrequencyEntry

Field Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.DefaultVoltagePhasorEntry Field

Grid Solutions Framework ConfigurationFrameDefaultVoltagePhasorEntry Field
Default voltage phasor INI based configuration entry.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultVoltagePhasorEntry
Public Const DefaultVoltagePhasorEntry As String
static val mutable DefaultVoltagePhasorEntry: string
var GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame.DefaultVoltagePhasorEntry
public:
literal String^ DefaultVoltagePhasorEntry

Field Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Methods

Grid Solutions Framework ConfigurationFrame Methods

The ConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
 | GetIniFileImage | Gets a generated INI configuration file image.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | Refresh | Reload BPA PDcstream INI based configuration file.
Public method | Refresh(Boolean) | Reload BPA PDcstream INI based configuration file specifying if the refresh was caused by a frame parse.
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.AppendChecksum Method

Grid Solutions Framework ConfigurationFrameAppendChecksum Method
Appends checksum onto buffer starting at startIndex.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum (
    buffer As Byte(),
    startIndex As Integer
)
abstract AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
override AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
function AppendChecksum(buffer, startIndex);
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image on which to append checksum.
startIndex
Type: SystemInt32
Index into buffer where checksum should be appended.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.ChecksumIsValid Method

Grid Solutions Framework ConfigurationFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.GetIniFileImage Method

Grid Solutions Framework ConfigurationFrameGetIniFileImage Method
Gets a generated INI configuration file image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetIniFileImage(
    IConfigurationFrame configFrame
)
Public Shared Function GetIniFileImage (
    configFrame As IConfigurationFrame
) As String
static member GetIniFileImage :
        configFrame : IConfigurationFrame -> string

GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame.GetIniFileImage = function(configFrame);
public:
static String^ GetIniFileImage(
    IConfigurationFrame^ configFrame
)

Parameters

configFrame
Type: GSF.PhasorProtocolsIConfigurationFrame

[Missing <param name="configFrame"/> documentation for "M:GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame.GetIniFileImage(GSF.PhasorProtocols.IConfigurationFrame)"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrame.GetIniFileImage(GSF.PhasorProtocols.IConfigurationFrame)"]

See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.GetObjectData Method

Grid Solutions Framework ConfigurationFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.ParseBinaryImage Method

Grid Solutions Framework ConfigurationFrameParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
This method is overridden so INI file can be loaded after binary image has been parsed.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.ParseHeaderImage Method

Grid Solutions Framework ConfigurationFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.Refresh Method

Grid Solutions Framework ConfigurationFrameRefresh Method
Overload List
 | Name | Description
Public method | Refresh | Reload BPA PDcstream INI based configuration file.
Public method | Refresh(Boolean) | Reload BPA PDcstream INI based configuration file specifying if the refresh was caused by a frame parse.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.Refresh Method

Grid Solutions Framework ConfigurationFrameRefresh Method
Reload BPA PDcstream INI based configuration file.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Refresh()
Public Sub Refresh
member Refresh : unit -> unit

function Refresh();
public:
void Refresh()
See Also

Reference

ConfigurationFrame Class
Refresh Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.Refresh Method (Boolean)

Grid Solutions Framework ConfigurationFrameRefresh Method (Boolean)
Reload BPA PDcstream INI based configuration file specifying if the refresh was caused by a frame parse.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void Refresh(
    bool refreshCausedByFrameParse
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub Refresh (
    refreshCausedByFrameParse As Boolean
)
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member Refresh :
        refreshCausedByFrameParse : bool -> unit

function Refresh(refreshCausedByFrameParse);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void Refresh(
    bool refreshCausedByFrameParse
)

Parameters

refreshCausedByFrameParse
Type: SystemBoolean
Flag that specifies if the refresh was caused by a frame parse.
See Also

Reference

ConfigurationFrame Class
Refresh Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Properties

Grid Solutions Framework ConfigurationFrame Properties

The ConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFileCells | Gets reference to the ConfigurationCellCollection loaded from the configuration file of this ConfigurationFrame.
Public property | ConfigurationFileName | Gets the INI based configuration file name of this ConfigurationFrame.
Public property | DefaultFrequency | Gets the default frequency definition.
Public property | DefaultPhasorI | Gets the default current phasor definition.
Public property | DefaultPhasorV | Gets the default voltage phasor definition.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PacketsPerSample | Gets or sets the number of packets per sample of this ConfigurationFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | RevisionNumber | Gets or sets the RevisionNumber of this ConfigurationFrame.
Public property | SampleIndex | Gets or sets current sample index used to calculate row time stamp when source data is in the Phasor Data File Format (i.e., a DST file).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | StreamType | Gets or sets the BPA PDCstream protocol StreamType, i.e., legacy or compact, of this ConfigurationFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.Attributes Property

Grid Solutions Framework ConfigurationFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.Cells Property

Grid Solutions Framework ConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.CommonHeader Property

Grid Solutions Framework ConfigurationFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.ConfigurationFileCells Property

Grid Solutions Framework ConfigurationFrameConfigurationFileCells Property
Gets reference to the ConfigurationCellCollection loaded from the configuration file of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection ConfigurationFileCells { get; }
Public ReadOnly Property ConfigurationFileCells As ConfigurationCellCollection
    Get
member ConfigurationFileCells : ConfigurationCellCollection with get

function get_ConfigurationFileCells();

public:
property ConfigurationCellCollection^ ConfigurationFileCells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.ConfigurationFileName Property

Grid Solutions Framework ConfigurationFrameConfigurationFileName Property
Gets the INI based configuration file name of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConfigurationFileName { get; }
Public ReadOnly Property ConfigurationFileName As String
    Get
member ConfigurationFileName : string with get

function get_ConfigurationFileName();

public:
property String^ ConfigurationFileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.DefaultFrequency Property

Grid Solutions Framework ConfigurationFrameDefaultFrequency Property
Gets the default frequency definition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition DefaultFrequency { get; }
Public ReadOnly Property DefaultFrequency As FrequencyDefinition
    Get
member DefaultFrequency : FrequencyDefinition with get

function get_DefaultFrequency();

public:
property FrequencyDefinition^ DefaultFrequency {
    FrequencyDefinition^ get ();
}

Property Value

Type: FrequencyDefinition
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.DefaultPhasorI Property

Grid Solutions Framework ConfigurationFrameDefaultPhasorI Property
Gets the default current phasor definition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition DefaultPhasorI { get; }
Public ReadOnly Property DefaultPhasorI As PhasorDefinition
    Get
member DefaultPhasorI : PhasorDefinition with get

function get_DefaultPhasorI();

public:
property PhasorDefinition^ DefaultPhasorI {
    PhasorDefinition^ get ();
}

Property Value

Type: PhasorDefinition
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.DefaultPhasorV Property

Grid Solutions Framework ConfigurationFrameDefaultPhasorV Property
Gets the default voltage phasor definition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition DefaultPhasorV { get; }
Public ReadOnly Property DefaultPhasorV As PhasorDefinition
    Get
member DefaultPhasorV : PhasorDefinition with get

function get_DefaultPhasorV();

public:
property PhasorDefinition^ DefaultPhasorV {
    PhasorDefinition^ get ();
}

Property Value

Type: PhasorDefinition
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.HeaderImage Property

Grid Solutions Framework ConfigurationFrameHeaderImage Property
Gets the binary header image of the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.HeaderLength Property

Grid Solutions Framework ConfigurationFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.PacketsPerSample Property

Grid Solutions Framework ConfigurationFramePacketsPerSample Property
Gets or sets the number of packets per sample of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort PacketsPerSample { get; set; }
Public Property PacketsPerSample As UShort
    Get
    Set
member PacketsPerSample : uint16 with get, set

function get_PacketsPerSample();
function set_PacketsPerSample(value);
public:
property unsigned short PacketsPerSample {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.RevisionNumber Property

Grid Solutions Framework ConfigurationFrameRevisionNumber Property
Gets or sets the RevisionNumber of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RevisionNumber RevisionNumber { get; set; }
Public Property RevisionNumber As RevisionNumber
    Get
    Set
member RevisionNumber : RevisionNumber with get, set

function get_RevisionNumber();
function set_RevisionNumber(value);
public:
property RevisionNumber RevisionNumber {
    RevisionNumber get ();
    void set (RevisionNumber value);
}

Property Value

Type: RevisionNumber
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.SampleIndex Property

Grid Solutions Framework ConfigurationFrameSampleIndex Property
Gets or sets current sample index used to calculate row time stamp when source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint SampleIndex { get; set; }
Public Property SampleIndex As UInteger
    Get
    Set
member SampleIndex : uint32 with get, set

function get_SampleIndex();
function set_SampleIndex(value);
public:
property unsigned int SampleIndex {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.StreamType Property

Grid Solutions Framework ConfigurationFrameStreamType Property
Gets or sets the BPA PDCstream protocol StreamType, i.e., legacy or compact, of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StreamType StreamType { get; set; }
Public Property StreamType As StreamType
    Get
    Set
member StreamType : StreamType with get, set

function get_StreamType();
function set_StreamType(value);
public:
property StreamType StreamType {
    StreamType get ();
    void set (StreamType value);
}

Property Value

Type: StreamType
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.TypeID Property

Grid Solutions Framework ConfigurationFrameTypeID Property
Gets the FrameType of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.UsePhasorDataFileFormat Property

Grid Solutions Framework ConfigurationFrameUsePhasorDataFileFormat Property
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
member UsePhasorDataFileFormat : bool with get

function get_UsePhasorDataFileFormat();

public:
property bool UsePhasorDataFileFormat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame Events

Grid Solutions Framework ConfigurationFrame Events

The ConfigurationFrame type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationFileReloaded | Occurs when the BPA PDCstream INI based configuration file has been reloaded.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrame.ConfigurationFileReloaded Event

Grid Solutions Framework ConfigurationFrameConfigurationFileReloaded Event
Occurs when the BPA PDCstream INI based configuration file has been reloaded.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationFileReloaded
Public Event ConfigurationFileReloaded As EventHandler
member ConfigurationFileReloaded : IEvent<EventHandler,
    EventArgs>

function add_ConfigurationFileReloaded(value);
function remove_ConfigurationFileReloaded(value);
public:
 event EventHandler^ ConfigurationFileReloaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrameParsingState Class

Grid Solutions Framework ConfigurationFrameParsingState Class
Represents the BPA PDCstream implementation of the parsing state used by a ConfigurationFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameParsingState
GSF.PhasorProtocols.BPAPDCstreamConfigurationFrameParsingState

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConfigurationFrameParsingState : ConfigurationFrameParsingState
Public Class ConfigurationFrameParsingState
    Inherits ConfigurationFrameParsingState
type ConfigurationFrameParsingState =
    class
        inherit ConfigurationFrameParsingState
    end
GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrameParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrameParsingState',
    GSF.PhasorProtocols.ConfigurationFrameParsingState);
public ref class ConfigurationFrameParsingState : public ConfigurationFrameParsingState

The ConfigurationFrameParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrameParsingState | Creates a new ConfigurationFrameParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrameParsingState Constructor

Grid Solutions Framework ConfigurationFrameParsingState Constructor
Creates a new ConfigurationFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    string configurationFileName,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)
Public Sub New (
    parsedBinaryLength As Integer,
    configurationFileName As String,
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell),
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        configurationFileName : string *
        createNewCellFunction : CreateNewCellFunction<IConfigurationCell> *
        trustHeaderLength : bool *
        validateCheckSum : bool -> ConfigurationFrameParsingState
GSF.PhasorProtocols.BPAPDCstream.ConfigurationFrameParsingState = function(parsedBinaryLength, configurationFileName, createNewCellFunction, trustHeaderLength, validateCheckSum);
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    String^ configurationFileName,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the ConfigurationFrame being parsed.
configurationFileName
Type: SystemString
The required external BPA PDCstream INI based configuration file.
createNewCellFunction
Type: GSF.PhasorProtocolsCreateNewCellFunction IConfigurationCell
Reference to delegate to create new ConfigurationCell instances.
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrameParsingState Methods

Grid Solutions Framework ConfigurationFrameParsingState Methods

The ConfigurationFrameParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrameParsingState Properties

Grid Solutions Framework ConfigurationFrameParsingState Properties

The ConfigurationFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConfigurationFrameParsingState.ConfigurationFileName Property

Grid Solutions Framework ConfigurationFrameParsingStateConfigurationFileName Property
Gets or sets required external BPA PDCstream INI based configuration file.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConfigurationFileName { get; set; }
Public Property ConfigurationFileName As String
    Get
    Set
member ConfigurationFileName : string with get, set

function get_ConfigurationFileName();
function set_ConfigurationFileName(value);
public:
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters Class

Grid Solutions Framework ConnectionParameters Class
Represents the extra connection parameters required for a connection to a BPA PDCstream.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsConnectionParametersBase
GSF.PhasorProtocols.BPAPDCstreamConnectionParameters

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute>
Public Class ConnectionParameters
    Inherits ConnectionParametersBase
[<SerializableAttribute>]
type ConnectionParameters =
    class
        inherit ConnectionParametersBase
    end
GSF.PhasorProtocols.BPAPDCstream.ConnectionParameters = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.ConnectionParameters',
    GSF.PhasorProtocols.ConnectionParametersBase);
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase

The ConnectionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
Public property | ParseWordCountFromByte | Gets or sets flag that interprets word count in packet header from a byte instead of a word.
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | ValuesAreValid | Determines if selected BPA PDCstream configuration file exists. (Overrides ConnectionParametersBaseValuesAreValid.)
Top
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Overload List
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Creates a new ConnectionParameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionParameters()
Public Sub New
new : unit -> ConnectionParameters
GSF.PhasorProtocols.BPAPDCstream.ConnectionParameters = function();
public:
ConnectionParameters()
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConnectionParameters Constructor (SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConnectionParameters
GSF.PhasorProtocols.BPAPDCstream.ConnectionParameters = function(info, context);
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters Methods

Grid Solutions Framework ConnectionParameters Methods

The ConnectionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters.GetObjectData Method

Grid Solutions Framework ConnectionParametersGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters Properties

Grid Solutions Framework ConnectionParameters Properties

The ConnectionParameters type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
Public property | ParseWordCountFromByte | Gets or sets flag that interprets word count in packet header from a byte instead of a word.
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | ValuesAreValid | Determines if selected BPA PDCstream configuration file exists. (Overrides ConnectionParametersBaseValuesAreValid.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters.ConfigurationFileName Property

Grid Solutions Framework ConnectionParametersConfigurationFileName Property
Gets or sets required external BPA PDCstream INI based configuration file.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))]
public string ConfigurationFileName { get; set; }
<EditorAttribute(GetType(IniFileNameEditor), GetType(UITypeEditor))>
Public Property ConfigurationFileName As String
    Get
    Set
[<EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))>]
member ConfigurationFileName : string with get, set

function get_ConfigurationFileName();
function set_ConfigurationFileName(value);
public:
[EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))]
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters.ParseWordCountFromByte Property

Grid Solutions Framework ConnectionParametersParseWordCountFromByte Property
Gets or sets flag that interprets word count in packet header from a byte instead of a word.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool ParseWordCountFromByte { get; set; }
<DefaultValueAttribute(false)>
Public Property ParseWordCountFromByte As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member ParseWordCountFromByte : bool with get, set

function get_ParseWordCountFromByte();
function set_ParseWordCountFromByte(value);
public:
[DefaultValueAttribute(false)]
property bool ParseWordCountFromByte {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters.RefreshConfigurationFileOnChange Property

Grid Solutions Framework ConnectionParametersRefreshConfigurationFileOnChange Property
Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool RefreshConfigurationFileOnChange { get; set; }
<DefaultValueAttribute(true)>
Public Property RefreshConfigurationFileOnChange As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member RefreshConfigurationFileOnChange : bool with get, set

function get_RefreshConfigurationFileOnChange();
function set_RefreshConfigurationFileOnChange(value);
public:
[DefaultValueAttribute(true)]
property bool RefreshConfigurationFileOnChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters.UsePhasorDataFileFormat Property

Grid Solutions Framework ConnectionParametersUsePhasorDataFileFormat Property
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool UsePhasorDataFileFormat { get; set; }
<DefaultValueAttribute(false)>
Public Property UsePhasorDataFileFormat As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member UsePhasorDataFileFormat : bool with get, set

function get_UsePhasorDataFileFormat();
function set_UsePhasorDataFileFormat(value);
public:
[DefaultValueAttribute(false)]
property bool UsePhasorDataFileFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


ConnectionParameters.ValuesAreValid Property

Grid Solutions Framework ConnectionParametersValuesAreValid Property
Determines if selected BPA PDCstream configuration file exists.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override bool ValuesAreValid { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ValuesAreValid As Boolean
    Get
[<BrowsableAttribute(false)>]
abstract ValuesAreValid : bool with get
[<BrowsableAttribute(false)>]
override ValuesAreValid : bool with get
function get_ValuesAreValid();

public:
[BrowsableAttribute(false)]
virtual property bool ValuesAreValid {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IConnectionParametersValuesAreValid
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell Class

Grid Solutions Framework DataCell Class
Represents the BPA PDCstream implementation of a IDataCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.BPAPDCstreamDataCell

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute>
Public Class DataCell
    Inherits DataCellBase
[<SerializableAttribute>]
type DataCell =
    class
        inherit DataCellBase
    end
GSF.PhasorProtocols.BPAPDCstream.DataCell = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.DataCell',
    GSF.PhasorProtocols.DataCellBase);
[SerializableAttribute]
public ref class DataCell : public DataCellBase

The DataCell type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides BinaryImageBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the DataCell. (Overrides BinaryImageBaseBinaryLength.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | ChannelFlags | Gets or sets channel flags for this DataCell.
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataBuffer | Gets or sets data buffer long word that prefixes each cell when source data is in the Phasor Data File Format (i.e., a DST file).
Public property | DataIsSortedByTimestamp | Obsolete. Gets or sets flag that determines if this DataCell data is sorted by timestamp.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataRate | Gets or sets data rate of this DataCell.
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FormatFlags | Gets or sets FormatFlags from ConfigurationCell associated with this DataCell.
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the DataCell object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | ReservedFlag0IsSet | Gets or sets flag that determines if reserved flag zero is set.
Public property | ReservedFlag1IsSet | Gets or sets flag that determines if reserved flag one is set.
Public property | ReservedFlags | Gets or sets reserved flags for this DataCell.
Public property | SampleNumber | Gets or sets sample number associated with this DataCell.
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimestampIsIncluded | Obsolete. Gets or sets flag that determines if timestamp is included with this DataCell.
Public property | UsePhasorDataFileFormat | Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | UsingIeeeFormat | Gets or sets flag that determines if this DataCell is using IEEE format.
Public property | UsingMacrodyneFormat | Gets or sets flag that determines if this DataCell is using Macrodyne format.
Public property | UsingPdcExchangeFormat | Gets or sets flag that determines if this DataCell is using the PDC exchange format.
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell Constructor

Grid Solutions Framework DataCell Constructor
Overload List
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCell Constructor (SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCell
GSF.PhasorProtocols.BPAPDCstream.DataCell = function(info, context);
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell Constructor (IDataFrame, IConfigurationCell)

Grid Solutions Framework DataCell Constructor (IDataFrame, IConfigurationCell)
Creates a new DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell -> DataCell
GSF.PhasorProtocols.BPAPDCstream.DataCell = function(parent, configurationCell);
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCell.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell Constructor (DataFrame, ConfigurationCell, Boolean)

Grid Solutions Framework DataCell Constructor (DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New (
    parent As DataFrame,
    configurationCell As ConfigurationCell,
    addEmptyValues As Boolean
)
new :
        parent : DataFrame *
        configurationCell : ConfigurationCell *
        addEmptyValues : bool -> DataCell
GSF.PhasorProtocols.BPAPDCstream.DataCell = function(parent, configurationCell, addEmptyValues);
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamDataFrame
The reference to parent DataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
The ConfigurationCell associated with this DataCell.
addEmptyValues
Type: SystemBoolean
If true, adds empty values for each defined configuration cell definition.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell Methods

Grid Solutions Framework DataCell Methods

The DataCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides BinaryImageBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.GetObjectData Method

Grid Solutions Framework DataCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.ParseBinaryImage Method

Grid Solutions Framework DataCellParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
This property is overridden to extend parsed length evenly at 4-byte intervals.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.ParseHeaderImage Method

Grid Solutions Framework DataCellParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell Properties

Grid Solutions Framework DataCell Properties

The DataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the DataCell. (Overrides BinaryImageBaseBinaryLength.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | ChannelFlags | Gets or sets channel flags for this DataCell.
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataBuffer | Gets or sets data buffer long word that prefixes each cell when source data is in the Phasor Data File Format (i.e., a DST file).
Public property | DataIsSortedByTimestamp | Obsolete. Gets or sets flag that determines if this DataCell data is sorted by timestamp.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataRate | Gets or sets data rate of this DataCell.
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FormatFlags | Gets or sets FormatFlags from ConfigurationCell associated with this DataCell.
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the DataCell object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | ReservedFlag0IsSet | Gets or sets flag that determines if reserved flag zero is set.
Public property | ReservedFlag1IsSet | Gets or sets flag that determines if reserved flag one is set.
Public property | ReservedFlags | Gets or sets reserved flags for this DataCell.
Public property | SampleNumber | Gets or sets sample number associated with this DataCell.
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimestampIsIncluded | Obsolete. Gets or sets flag that determines if timestamp is included with this DataCell.
Public property | UsePhasorDataFileFormat | Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | UsingIeeeFormat | Gets or sets flag that determines if this DataCell is using IEEE format.
Public property | UsingMacrodyneFormat | Gets or sets flag that determines if this DataCell is using Macrodyne format.
Public property | UsingPdcExchangeFormat | Gets or sets flag that determines if this DataCell is using the PDC exchange format.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.Attributes Property

Grid Solutions Framework DataCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataCell object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.BinaryLength Property

Grid Solutions Framework DataCellBinaryLength Property
Gets the length of the DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
Remarks
This property is overridden to extend length evenly at 4-byte intervals.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.ChannelFlags Property

Grid Solutions Framework DataCellChannelFlags Property
Gets or sets channel flags for this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ChannelFlags ChannelFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property ChannelFlags As ChannelFlags
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member ChannelFlags : ChannelFlags with get, set

function get_ChannelFlags();
function set_ChannelFlags(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property ChannelFlags ChannelFlags {
    ChannelFlags get ();
    void set (ChannelFlags value);
}

Property Value

Type: ChannelFlags
Remarks
These are bit flags, use properties to change basic values.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.ConfigurationCell Property

Grid Solutions Framework DataCellConfigurationCell Property
Gets or sets the ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
member ConfigurationCell : ConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.DataBuffer Property

Grid Solutions Framework DataCellDataBuffer Property
Gets or sets data buffer long word that prefixes each cell when source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint DataBuffer { get; set; }
Public Property DataBuffer As UInteger
    Get
    Set
member DataBuffer : uint32 with get, set

function get_DataBuffer();
function set_DataBuffer(value);
public:
property unsigned int DataBuffer {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.DataIsSortedByTimestamp Property

Grid Solutions Framework DataCellDataIsSortedByTimestamp Property

Note: This API is now obsolete.

Gets or sets flag that determines if this DataCell data is sorted by timestamp.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)]
public bool DataIsSortedByTimestamp { get; set; }
<ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)>
Public Property DataIsSortedByTimestamp As Boolean
    Get
    Set
[<ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)>]
member DataIsSortedByTimestamp : bool with get, set

function get_DataIsSortedByTimestamp();
function set_DataIsSortedByTimestamp(value);
public:
[ObsoleteAttribute(L"This bit definition is for obsolete uses that is no longer needed.",
    false)]
property bool DataIsSortedByTimestamp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.DataIsValid Property

Grid Solutions Framework DataCellDataIsValid Property
Gets or sets flag that determines if data of this DataCell is valid.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set
override DataIsValid : bool with get, set
function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.DataRate Property

Grid Solutions Framework DataCellDataRate Property
Gets or sets data rate of this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte DataRate { get; set; }
Public Property DataRate As Byte
    Get
    Set
member DataRate : byte with get, set

function get_DataRate();
function set_DataRate(value);
public:
property unsigned char DataRate {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.DataSortingType Property

Grid Solutions Framework DataCellDataSortingType Property
Gets or sets DataSortingType of this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set
override DataSortingType : DataSortingType with get, set
function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.DeviceError Property

Grid Solutions Framework DataCellDeviceError Property
Gets or sets flag that determines if source device of this DataCell is reporting an error.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DeviceError { get; set; }
Public Overrides Property DeviceError As Boolean
    Get
    Set
abstract DeviceError : bool with get, set
override DeviceError : bool with get, set
function get_DeviceError();
function set_DeviceError(value);
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.FormatFlags Property

Grid Solutions Framework DataCellFormatFlags Property
Gets or sets FormatFlags from ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FormatFlags FormatFlags { get; set; }
Public Property FormatFlags As FormatFlags
    Get
    Set
member FormatFlags : FormatFlags with get, set

function get_FormatFlags();
function set_FormatFlags(value);
public:
property FormatFlags FormatFlags {
    FormatFlags get ();
    void set (FormatFlags value);
}

Property Value

Type: FormatFlags
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.HeaderImage Property

Grid Solutions Framework DataCellHeaderImage Property
Gets the binary header image of the DataCell object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
Although this BPA PDCstream implementation DataCell will correctly parse a PDCxchng style stream, one will not be produced. Only a fully formatted stream will ever be produced.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.HeaderLength Property

Grid Solutions Framework DataCellHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.Parent Property

Grid Solutions Framework DataCellParent Property
Gets or sets the reference to parent DataFrame of this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
member Parent : DataFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}

Property Value

Type: DataFrame
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.ReservedFlag0IsSet Property

Grid Solutions Framework DataCellReservedFlag0IsSet Property
Gets or sets flag that determines if reserved flag zero is set.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReservedFlag0IsSet { get; set; }
Public Property ReservedFlag0IsSet As Boolean
    Get
    Set
member ReservedFlag0IsSet : bool with get, set

function get_ReservedFlag0IsSet();
function set_ReservedFlag0IsSet(value);
public:
property bool ReservedFlag0IsSet {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.ReservedFlag1IsSet Property

Grid Solutions Framework DataCellReservedFlag1IsSet Property
Gets or sets flag that determines if reserved flag one is set.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReservedFlag1IsSet { get; set; }
Public Property ReservedFlag1IsSet As Boolean
    Get
    Set
member ReservedFlag1IsSet : bool with get, set

function get_ReservedFlag1IsSet();
function set_ReservedFlag1IsSet(value);
public:
property bool ReservedFlag1IsSet {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.ReservedFlags Property

Grid Solutions Framework DataCellReservedFlags Property
Gets or sets reserved flags for this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ReservedFlags ReservedFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property ReservedFlags As ReservedFlags
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member ReservedFlags : ReservedFlags with get, set

function get_ReservedFlags();
function set_ReservedFlags(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property ReservedFlags ReservedFlags {
    ReservedFlags get ();
    void set (ReservedFlags value);
}

Property Value

Type: ReservedFlags
Remarks
These are bit flags, use properties to change basic values.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.SampleNumber Property

Grid Solutions Framework DataCellSampleNumber Property
Gets or sets sample number associated with this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleNumber { get; set; }
Public Property SampleNumber As UShort
    Get
    Set
member SampleNumber : uint16 with get, set

function get_SampleNumber();
function set_SampleNumber(value);
public:
property unsigned short SampleNumber {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.SynchronizationIsValid Property

Grid Solutions Framework DataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set
override SynchronizationIsValid : bool with get, set
function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.TimestampIsIncluded Property

Grid Solutions Framework DataCellTimestampIsIncluded Property

Note: This API is now obsolete.

Gets or sets flag that determines if timestamp is included with this DataCell.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)]
public bool TimestampIsIncluded { get; set; }
<ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)>
Public Property TimestampIsIncluded As Boolean
    Get
    Set
[<ObsoleteAttribute("This bit definition is for obsolete uses that is no longer needed.",
    false)>]
member TimestampIsIncluded : bool with get, set

function get_TimestampIsIncluded();
function set_TimestampIsIncluded(value);
public:
[ObsoleteAttribute(L"This bit definition is for obsolete uses that is no longer needed.",
    false)]
property bool TimestampIsIncluded {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.UsePhasorDataFileFormat Property

Grid Solutions Framework DataCellUsePhasorDataFileFormat Property
Gets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
member UsePhasorDataFileFormat : bool with get

function get_UsePhasorDataFileFormat();

public:
property bool UsePhasorDataFileFormat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.UsingIeeeFormat Property

Grid Solutions Framework DataCellUsingIeeeFormat Property
Gets or sets flag that determines if this DataCell is using IEEE format.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsingIeeeFormat { get; set; }
Public Property UsingIeeeFormat As Boolean
    Get
    Set
member UsingIeeeFormat : bool with get, set

function get_UsingIeeeFormat();
function set_UsingIeeeFormat(value);
public:
property bool UsingIeeeFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.UsingMacrodyneFormat Property

Grid Solutions Framework DataCellUsingMacrodyneFormat Property
Gets or sets flag that determines if this DataCell is using Macrodyne format.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsingMacrodyneFormat { get; set; }
Public Property UsingMacrodyneFormat As Boolean
    Get
    Set
member UsingMacrodyneFormat : bool with get, set

function get_UsingMacrodyneFormat();
function set_UsingMacrodyneFormat(value);
public:
property bool UsingMacrodyneFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCell.UsingPdcExchangeFormat Property

Grid Solutions Framework DataCellUsingPdcExchangeFormat Property
Gets or sets flag that determines if this DataCell is using the PDC exchange format.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsingPdcExchangeFormat { get; set; }
Public Property UsingPdcExchangeFormat As Boolean
    Get
    Set
member UsingPdcExchangeFormat : bool with get, set

function get_UsingPdcExchangeFormat();
function set_UsingPdcExchangeFormat(value);
public:
property bool UsingPdcExchangeFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a BPA PDCstream implementation of a collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.BPAPDCstreamDataCellCollection

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute>
Public Class DataCellCollection
    Inherits DataCellCollection
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit DataCellCollection
    end
GSF.PhasorProtocols.BPAPDCstream.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.DataCellCollection',
    GSF.PhasorProtocols.DataCellCollection);
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Creates a new DataCellCollection.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection()
Public Sub New
new : unit -> DataCellCollection
GSF.PhasorProtocols.BPAPDCstream.DataCellCollection = function();
public:
DataCellCollection()
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.BPAPDCstream.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection.Item Property

Grid Solutions Framework DataCellCollectionItem Property
Gets or sets DataCell at specified index.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As DataCell
    Get
    Set
member Item : DataCell with get, set

function get_Item(index);
function set_Item(value);
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: DataCell
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame Class

Grid Solutions Framework DataFrame Class
Represents the BPA PDCstream implementation of a IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.BPAPDCstreamDataFrame

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute>
Public Class DataFrame
    Inherits DataFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type DataFrame =
    class
        inherit DataFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.BPAPDCstream.DataFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.DataFrame',
    GSF.PhasorProtocols.DataFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The DataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame, Byte, UInt16) | Creates a new DataFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides DataFrameBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LegacyLabels | Gets the legacy labels parsed from the DataFrame, if any.
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | NtpTimeTag | Gets the timestamp of this DataFrame formatted as NTP.
Public property | PacketNumber | Gets or sets the packet number of this DataFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SampleNumber | Gets or sets the sample number of this DataFrame.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Overload List
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame, Byte, UInt16) | Creates a new DataFrame from specified parameters.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Creates a new DataFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> DataFrame
GSF.PhasorProtocols.BPAPDCstream.DataFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
DataFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse a BPA PDCstream data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrame Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrame
GSF.PhasorProtocols.BPAPDCstream.DataFrame = function(info, context);
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame Constructor (Ticks, ConfigurationFrame, Byte, UInt16)

Grid Solutions Framework DataFrame Constructor (Ticks, ConfigurationFrame, Byte, UInt16)
Creates a new DataFrame from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame configurationFrame,
    byte packetNumber,
    ushort sampleNumber
)
Public Sub New (
    timestamp As Ticks,
    configurationFrame As ConfigurationFrame,
    packetNumber As Byte,
    sampleNumber As UShort
)
new :
        timestamp : Ticks *
        configurationFrame : ConfigurationFrame *
        packetNumber : byte *
        sampleNumber : uint16 -> DataFrame
GSF.PhasorProtocols.BPAPDCstream.DataFrame = function(timestamp, configurationFrame, packetNumber, sampleNumber);
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame^ configurationFrame,
    unsigned char packetNumber,
    unsigned short sampleNumber
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationFrame
The ConfigurationFrame associated with this DataFrame.
packetNumber
Type: SystemByte
Packet number for this DataFrame.
sampleNumber
Type: SystemUInt16
Sample number for this DataFrame.
Remarks
This constructor is used by a consumer to generate a BPA PDCstream data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame Methods

Grid Solutions Framework DataFrame Methods

The DataFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides DataFrameBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.AppendChecksum Method

Grid Solutions Framework DataFrameAppendChecksum Method
Appends checksum onto buffer starting at startIndex.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum (
    buffer As Byte(),
    startIndex As Integer
)
abstract AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
override AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
function AppendChecksum(buffer, startIndex);
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image on which to append checksum.
startIndex
Type: SystemInt32
Index into buffer where checksum should be appended.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.CalculateChecksum Method

Grid Solutions Framework DataFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.ChecksumIsValid Method

Grid Solutions Framework DataFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
We override default implementation since BPA PDCstream implements check sum for frames in little-endian.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.GetObjectData Method

Grid Solutions Framework DataFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.ParseBinaryImage Method

Grid Solutions Framework DataFrameParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
This method is overridden to compensate for lack of CRC in DST files.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.ParseHeaderImage Method

Grid Solutions Framework DataFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame Properties

Grid Solutions Framework DataFrame Properties

The DataFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LegacyLabels | Gets the legacy labels parsed from the DataFrame, if any.
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | NtpTimeTag | Gets the timestamp of this DataFrame formatted as NTP.
Public property | PacketNumber | Gets or sets the packet number of this DataFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SampleNumber | Gets or sets the sample number of this DataFrame.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrame.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.Attributes Property

Grid Solutions Framework DataFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.Cells Property

Grid Solutions Framework DataFrameCells Property
Gets reference to the DataCellCollection for this DataFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
member Cells : DataCellCollection with get

function get_Cells();

public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.CommonHeader Property

Grid Solutions Framework DataFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.ConfigurationFrame Property

Grid Solutions Framework DataFrameConfigurationFrame Property
Gets or sets ConfigurationFrame associated with this DataFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
member ConfigurationFrame : ConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.HeaderImage Property

Grid Solutions Framework DataFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.HeaderLength Property

Grid Solutions Framework DataFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.LegacyLabels Property

Grid Solutions Framework DataFrameLegacyLabels Property
Gets the legacy labels parsed from the DataFrame, if any.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] LegacyLabels { get; }
Public ReadOnly Property LegacyLabels As String()
    Get
member LegacyLabels : string[] with get

function get_LegacyLabels();

public:
property array<String^>^ LegacyLabels {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.NtpTimeTag Property

Grid Solutions Framework DataFrameNtpTimeTag Property
Gets the timestamp of this DataFrame formatted as NTP.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag NtpTimeTag { get; }
Public ReadOnly Property NtpTimeTag As NtpTimeTag
    Get
member NtpTimeTag : NtpTimeTag with get

function get_NtpTimeTag();

public:
property NtpTimeTag^ NtpTimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.PacketNumber Property

Grid Solutions Framework DataFramePacketNumber Property
Gets or sets the packet number of this DataFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte PacketNumber { get; set; }
Public Property PacketNumber As Byte
    Get
    Set
member PacketNumber : byte with get, set

function get_PacketNumber();
function set_PacketNumber(value);
public:
property unsigned char PacketNumber {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.SampleNumber Property

Grid Solutions Framework DataFrameSampleNumber Property
Gets or sets the sample number of this DataFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleNumber { get; set; }
Public Property SampleNumber As UShort
    Get
    Set
member SampleNumber : uint16 with get, set

function get_SampleNumber();
function set_SampleNumber(value);
public:
property unsigned short SampleNumber {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.State Property

Grid Solutions Framework DataFrameState Property
Gets or sets the parsing state for the this DataFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrameParsingState State { get; set; }
Public Property State As DataFrameParsingState
    Get
    Set
member State : DataFrameParsingState with get, set

function get_State();
function set_State(value);
public:
property DataFrameParsingState^ State {
    DataFrameParsingState^ get ();
    void set (DataFrameParsingState^ value);
}

Property Value

Type: DataFrameParsingState
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.TypeID Property

Grid Solutions Framework DataFrameTypeID Property
Gets the identifier that is used to identify the IEEE C37.118 frame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrame.UsePhasorDataFileFormat Property

Grid Solutions Framework DataFrameUsePhasorDataFileFormat Property
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsePhasorDataFileFormat { get; }
Public ReadOnly Property UsePhasorDataFileFormat As Boolean
    Get
member UsePhasorDataFileFormat : bool with get

function get_UsePhasorDataFileFormat();

public:
property bool UsePhasorDataFileFormat {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrameParsingState Class

Grid Solutions Framework DataFrameParsingState Class
Represents the BPA PDCstream protocol implementation of the parsing state used by a DataFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBase IDataCell
GSF.PhasorProtocolsDataFrameParsingState
GSF.PhasorProtocols.BPAPDCstreamDataFrameParsingState

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataFrameParsingState : DataFrameParsingState
Public Class DataFrameParsingState
    Inherits DataFrameParsingState
type DataFrameParsingState =
    class
        inherit DataFrameParsingState
    end
GSF.PhasorProtocols.BPAPDCstream.DataFrameParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.DataFrameParsingState',
    GSF.PhasorProtocols.DataFrameParsingState);
public ref class DataFrameParsingState : public DataFrameParsingState

The DataFrameParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrameParsingState | Creates a new DataFrameParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ConfigurationFrame | Gets reference to the ConfigurationFrame associated with the DataFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | RemainingPdcBlockPmus | Gets or sets the remaining number of PMU's the PDC block to be parsed.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrameParsingState Constructor

Grid Solutions Framework DataFrameParsingState Constructor
Creates a new DataFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame configurationFrame,
    CreateNewCellFunction<IDataCell> createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)
Public Sub New (
    parsedBinaryLength As Integer,
    configurationFrame As IConfigurationFrame,
    createNewCellFunction As CreateNewCellFunction(Of IDataCell),
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        configurationFrame : IConfigurationFrame *
        createNewCellFunction : CreateNewCellFunction<IDataCell> *
        trustHeaderLength : bool *
        validateCheckSum : bool -> DataFrameParsingState
GSF.PhasorProtocols.BPAPDCstream.DataFrameParsingState = function(parsedBinaryLength, configurationFrame, createNewCellFunction, trustHeaderLength, validateCheckSum);
public:
DataFrameParsingState(
    int parsedBinaryLength,
    IConfigurationFrame^ configurationFrame,
    CreateNewCellFunction<IDataCell^>^ createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the IDataFrame being parsed.
configurationFrame
Type: GSF.PhasorProtocolsIConfigurationFrame
Reference to the IConfigurationFrame associated with the IDataFrame being parsed.
createNewCellFunction
Type: GSF.PhasorProtocolsCreateNewCellFunction IDataCell
Reference to delegate to create new IDataCell instances.
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrameParsingState Methods

Grid Solutions Framework DataFrameParsingState Methods

The DataFrameParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrameParsingState Properties

Grid Solutions Framework DataFrameParsingState Properties

The DataFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ConfigurationFrame | Gets reference to the ConfigurationFrame associated with the DataFrame being parsed.
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | RemainingPdcBlockPmus | Gets or sets the remaining number of PMU's the PDC block to be parsed.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrameParsingState.ConfigurationFrame Property

Grid Solutions Framework DataFrameParsingStateConfigurationFrame Property
Gets reference to the ConfigurationFrame associated with the DataFrame being parsed.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; }
Public ReadOnly Property ConfigurationFrame As ConfigurationFrame
    Get
member ConfigurationFrame : ConfigurationFrame with get

function get_ConfigurationFrame();

public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
}

Property Value

Type: ConfigurationFrame
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DataFrameParsingState.RemainingPdcBlockPmus Property

Grid Solutions Framework DataFrameParsingStateRemainingPdcBlockPmus Property
Gets or sets the remaining number of PMU's the PDC block to be parsed.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int RemainingPdcBlockPmus { get; set; }
Public Property RemainingPdcBlockPmus As Integer
    Get
    Set
member RemainingPdcBlockPmus : int with get, set

function get_RemainingPdcBlockPmus();
function set_RemainingPdcBlockPmus(value);
public:
property int RemainingPdcBlockPmus {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DataFrameParsingState Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition Class

Grid Solutions Framework DigitalDefinition Class
Represents the BPA PDCstream implementation of an IDigitalDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocols.BPAPDCstreamDigitalDefinition

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute>
Public Class DigitalDefinition
    Inherits DigitalDefinitionBase
[<SerializableAttribute>]
type DigitalDefinition =
    class
        inherit DigitalDefinitionBase
    end
GSF.PhasorProtocols.BPAPDCstream.DigitalDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.DigitalDefinition',
    GSF.PhasorProtocols.DigitalDefinitionBase);
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase

The DigitalDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition Constructor

Grid Solutions Framework DigitalDefinition Constructor
Overload List
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition Constructor (IConfigurationCell)

Grid Solutions Framework DigitalDefinition Constructor (IConfigurationCell)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> DigitalDefinition
GSF.PhasorProtocols.BPAPDCstream.DigitalDefinition = function(parent);
public:
DigitalDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinition
GSF.PhasorProtocols.BPAPDCstream.DigitalDefinition = function(info, context);
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework DigitalDefinition Constructor (ConfigurationCell, String)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> DigitalDefinition
GSF.PhasorProtocols.BPAPDCstream.DigitalDefinition = function(parent, label);
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
The ConfigurationCell parent of this DigitalDefinition.
label
Type: SystemString
The label of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition Methods

Grid Solutions Framework DigitalDefinition Methods

The DigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition Properties

Grid Solutions Framework DigitalDefinition Properties

The DigitalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition.BodyImage Property

Grid Solutions Framework DigitalDefinitionBodyImage Property
Gets the binary body image of the DigitalDefinition object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
BPA PDCstream does not include digital definition in descriptor packet. Only a count of available values is defined in the data frame.
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition.BodyLength Property

Grid Solutions Framework DigitalDefinitionBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition.MaximumLabelLength Property

Grid Solutions Framework DigitalDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalDefinition.Parent Property

Grid Solutions Framework DigitalDefinitionParent Property
Gets or sets the ConfigurationCell parent of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue Class

Grid Solutions Framework DigitalValue Class
Represents the BPA PDCstream implementation of an IDigitalValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IDigitalDefinition
GSF.PhasorProtocolsDigitalValueBase
GSF.PhasorProtocols.BPAPDCstreamDigitalValue

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute>
Public Class DigitalValue
    Inherits DigitalValueBase
[<SerializableAttribute>]
type DigitalValue =
    class
        inherit DigitalValueBase
    end
GSF.PhasorProtocols.BPAPDCstream.DigitalValue = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.DigitalValue',
    GSF.PhasorProtocols.DigitalValueBase);
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase

The DigitalValue type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue Constructor

Grid Solutions Framework DigitalValue Constructor
Overload List
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalValue Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalValue
GSF.PhasorProtocols.BPAPDCstream.DigitalValue = function(info, context);
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue Constructor (IDataCell, IDigitalDefinition)

Grid Solutions Framework DigitalValue Constructor (IDataCell, IDigitalDefinition)
Creates a new DigitalValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New (
    parent As IDataCell,
    digitalDefinition As IDigitalDefinition
)
new :
        parent : IDataCell *
        digitalDefinition : IDigitalDefinition -> DigitalValue
GSF.PhasorProtocols.BPAPDCstream.DigitalValue = function(parent, digitalDefinition);
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocolsIDigitalDefinition
The IDigitalDefinition associated with this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)

Grid Solutions Framework DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New (
    parent As DataCell,
    digitalDefinition As DigitalDefinition,
    value As UShort
)
new :
        parent : DataCell *
        digitalDefinition : DigitalDefinition *
        value : uint16 -> DigitalValue
GSF.PhasorProtocols.BPAPDCstream.DigitalValue = function(parent, digitalDefinition, value);
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamDataCell
The DataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocols.BPAPDCstreamDigitalDefinition
The DigitalDefinition associated with this DigitalValue.
value
Type: SystemUInt16
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue Methods

Grid Solutions Framework DigitalValue Methods

The DigitalValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue Properties

Grid Solutions Framework DigitalValue Properties

The DigitalValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue.Definition Property

Grid Solutions Framework DigitalValueDefinition Property
Gets or sets the DigitalDefinition associated with this DigitalValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
abstract Definition : DigitalDefinition with get, set
override Definition : DigitalDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}

Property Value

Type: DigitalDefinition
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


DigitalValue.Parent Property

Grid Solutions Framework DigitalValueParent Property
Gets or sets the DataCell parent of this DigitalValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FileType Enumeration

Grid Solutions Framework FileType Enumeration
File type enueration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FileType
<SerializableAttribute>
Public Enumeration FileType
[<SerializableAttribute>]
type FileType
GSF.PhasorProtocols.BPAPDCstream.FileType = function();
GSF.PhasorProtocols.BPAPDCstream.FileType.createEnum('GSF.PhasorProtocols.BPAPDCstream.FileType', false);
[SerializableAttribute]
public enum class FileType
Members
Member name | Value | Description
PdcNtp | 1 | PDC phasor data recording, NTP time stamp (SOC starts 1900).
PdcUnix | 2 | PDC phasor data recording, UNIX time stamp (SOC starts 1970).
Ppsm | 4 | PPSM sample data recording.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


FileVersion Enumeration

Grid Solutions Framework FileVersion Enumeration

[Missing <summary> documentation for "T:GSF.PhasorProtocols.BPAPDCstream.FileVersion"]

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FileVersion
<SerializableAttribute>
Public Enumeration FileVersion
[<SerializableAttribute>]
type FileVersion
GSF.PhasorProtocols.BPAPDCstream.FileVersion = function();
GSF.PhasorProtocols.BPAPDCstream.FileVersion.createEnum('GSF.PhasorProtocols.BPAPDCstream.FileVersion', false);
[SerializableAttribute]
public enum class FileVersion
Members
Member name | Value | Description
PdcWithDbuf | 1 | PDC phasor data recording, including Dbuf flag.
PdcWithoutDbuf | 2 | PDC phasor data recording, excluding Dbuf flag.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


FormatFlags Enumeration

Grid Solutions Framework FormatFlags Enumeration
Format flags enumeration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum FormatFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration FormatFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type FormatFlags
GSF.PhasorProtocols.BPAPDCstream.FormatFlags = function();
GSF.PhasorProtocols.BPAPDCstream.FormatFlags.createEnum('GSF.PhasorProtocols.BPAPDCstream.FormatFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class FormatFlags
Members
Member name | Value | Description
Frequency | 128 | Frequency data format: Set = float, Clear = integer.
Analog | 64 | Analog data format: Set = float, Clear = integer.
Phasors | 32 | Phasor data format: Set = float, Clear = integer.
Coordinates | 16 | Phasor coordinate format: Set = polar, Clear = rectangular.
DigitalWordsMask | 15 | Digital words mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser Class

Grid Solutions Framework FrameParser Class
Represents a frame parser for a BPA PDCstream binary data stream and returns parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.PhasorProtocolsFrameParserBase FrameType
GSF.PhasorProtocols.BPAPDCstreamFrameParser

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser
    Inherits FrameParserBase(Of FrameType)
type FrameParser =
    class
        inherit FrameParserBase<FrameType>
    end
GSF.PhasorProtocols.BPAPDCstream.FrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.FrameParser',
    GSF.PhasorProtocols.FrameParserBase`1);
public ref class FrameParser : public FrameParserBase<FrameType>

The FrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | FrameParser | Creates a new FrameParser.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBaseTFrameIdentifierDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame. (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | ParseWordCountFromByte | Gets or sets flag that interprets word count in packet header from a byte instead of a word.
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a BPA PDCstream ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a BPA PDCstream DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser Constructor

Grid Solutions Framework FrameParser Constructor
Creates a new FrameParser.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    bool trustHeaderLength = true,
    string configurationFileName = null
)
Public Sub New (
    Optional checkSumValidationFrameTypes As CheckSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    Optional trustHeaderLength As Boolean = true,
    Optional configurationFileName As String = Nothing
)
new :
        ?checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        ?trustHeaderLength : bool *
        ?configurationFileName : string
(* Defaults:
        let _checkSumValidationFrameTypes = defaultArg checkSumValidationFrameTypes CheckSumValidationFrameTypes.AllFrames
        let _trustHeaderLength = defaultArg trustHeaderLength true
        let _configurationFileName = defaultArg configurationFileName null
*)
-> FrameParser
GSF.PhasorProtocols.BPAPDCstream.FrameParser = function(checkSumValidationFrameTypes, trustHeaderLength, configurationFileName);
public:
FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes::AllFrames,
    bool trustHeaderLength = true,
    String^ configurationFileName = nullptr
)

Parameters

checkSumValidationFrameTypes (Optional)
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength (Optional)
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
configurationFileName (Optional)
Type: SystemString
The required external BPA PDCstream INI based configuration file.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser Fields

Grid Solutions Framework FrameParser Fields

The FrameParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser Methods

Grid Solutions Framework FrameParser Methods

The FrameParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBaseTFrameIdentifierDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame. (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.Dispose Method

Grid Solutions Framework FrameParserDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBaseTFrameIdentifierDispose(Boolean).)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.Dispose Method (Boolean)

Grid Solutions Framework FrameParserDispose Method (Boolean)
Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FrameParser Class
Dispose Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.OnReceivedConfigurationFrame Method

Grid Solutions Framework FrameParserOnReceivedConfigurationFrame Method
Raises the ReceivedConfigurationFrame event.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame (
    frame As IConfigurationFrame
)
abstract OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
override OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
function OnReceivedConfigurationFrame(frame);
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIConfigurationFrame
IConfigurationFrame to send to ReceivedConfigurationFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ParseCommonHeader Method

Grid Solutions Framework FrameParserParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of FrameType)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader FrameType
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Start the data parser.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

FrameParser Class
Start Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser Properties

Grid Solutions Framework FrameParser Properties

The FrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFileName | Gets or sets required external BPA PDCstream INI based configuration file.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | ParseWordCountFromByte | Gets or sets flag that interprets word count in packet header from a byte instead of a word.
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | UsePhasorDataFileFormat | Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ConfigurationFileName Property

Grid Solutions Framework FrameParserConfigurationFileName Property
Gets or sets required external BPA PDCstream INI based configuration file.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConfigurationFileName { get; set; }
Public Property ConfigurationFileName As String
    Get
    Set
member ConfigurationFileName : string with get, set

function get_ConfigurationFileName();
function set_ConfigurationFileName(value);
public:
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ConfigurationFrame Property

Grid Solutions Framework FrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ConnectionParameters Property

Grid Solutions Framework FrameParserConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set
override ConnectionParameters : IConnectionParameters with get, set
function get_ConnectionParameters();
function set_ConnectionParameters(value);
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}

Property Value

Type: IConnectionParameters

Implements

IFrameParserConnectionParameters
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ParseWordCountFromByte Property

Grid Solutions Framework FrameParserParseWordCountFromByte Property
Gets or sets flag that interprets word count in packet header from a byte instead of a word.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ParseWordCountFromByte { get; set; }
Public Property ParseWordCountFromByte As Boolean
    Get
    Set
member ParseWordCountFromByte : bool with get, set

function get_ParseWordCountFromByte();
function set_ParseWordCountFromByte(value);
public:
property bool ParseWordCountFromByte {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Set to true to interpret word count in packet header from a byte instead of a word - if the sync byte (0xAA) is at position one, then the word count would be interpreted from byte four. Some older BPA PDC stream implementations have a 0x01 in byte three where there should be a 0x00 and this throws off the frame length, setting this property to true will correctly interpret the word count.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework FrameParserProtocolUsesSyncBytes Property
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.RefreshConfigurationFileOnChange Property

Grid Solutions Framework FrameParserRefreshConfigurationFileOnChange Property
Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RefreshConfigurationFileOnChange { get; set; }
Public Property RefreshConfigurationFileOnChange As Boolean
    Get
    Set
member RefreshConfigurationFileOnChange : bool with get, set

function get_RefreshConfigurationFileOnChange();
function set_RefreshConfigurationFileOnChange(value);
public:
property bool RefreshConfigurationFileOnChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.Status Property

Grid Solutions Framework FrameParserStatus Property
Gets current descriptive status of the FrameParser.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.UsePhasorDataFileFormat Property

Grid Solutions Framework FrameParserUsePhasorDataFileFormat Property
Gets or sets flag that determines if source data is in the Phasor Data File Format (i.e., a DST file).

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsePhasorDataFileFormat { get; set; }
Public Property UsePhasorDataFileFormat As Boolean
    Get
    Set
member UsePhasorDataFileFormat : bool with get, set

function get_UsePhasorDataFileFormat();
function set_UsePhasorDataFileFormat(value);
public:
property bool UsePhasorDataFileFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser Events

Grid Solutions Framework FrameParser Events

The FrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a BPA PDCstream ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a BPA PDCstream DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame Event
Occurs when a BPA PDCstream ConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
member ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<ConfigurationFrame>>,
    EventArgs<ConfigurationFrame>>

function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame
Remarks
Argument is the ConfigurationFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameParser.ReceivedDataFrame Event

Grid Solutions Framework FrameParserReceivedDataFrame Event
Occurs when a BPA PDCstream DataFrame has been received.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
member ReceivedDataFrame : IEvent<EventHandler<EventArgs<DataFrame>>,
    EventArgs<DataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataFrame
Remarks
Argument is the DataFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrameType Enumeration

Grid Solutions Framework FrameType Enumeration
Frame type enumeration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FrameType
<SerializableAttribute>
Public Enumeration FrameType
[<SerializableAttribute>]
type FrameType
GSF.PhasorProtocols.BPAPDCstream.FrameType = function();
GSF.PhasorProtocols.BPAPDCstream.FrameType.createEnum('GSF.PhasorProtocols.BPAPDCstream.FrameType', false);
[SerializableAttribute]
public enum class FrameType
Members
Member name | Value | Description
ConfigurationFrame | 0 | Configuration frame.
DataFrame | 1 | Data frame.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents the BPA PDCstream implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.BPAPDCstreamFrequencyDefinition

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.BPAPDCstream.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from the specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides FrequencyDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this FrequencyDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinition. (Overrides FrequencyDefinitionBaseOffset.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from the specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinition Constructor (IConfigurationCell)
Creates a new FrequencyDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinition
GSF.PhasorProtocols.BPAPDCstream.FrequencyDefinition = function(parent);
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.BPAPDCstream.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from the specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string entryValue
)
Public Sub New (
    parent As ConfigurationCell,
    entryValue As String
)
new :
        parent : ConfigurationCell *
        entryValue : string -> FrequencyDefinition
GSF.PhasorProtocols.BPAPDCstream.FrequencyDefinition = function(parent, entryValue);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ entryValue
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
entryValue
Type: SystemString
The entry value from the INI based configuration file.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides FrequencyDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition.GetObjectData Method

Grid Solutions Framework FrequencyDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this FrequencyDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinition. (Overrides FrequencyDefinitionBaseOffset.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition.BodyImage Property

Grid Solutions Framework FrequencyDefinitionBodyImage Property
Gets the binary body image of the FrequencyDefinition object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
BPA PDCstream does not include frequency definition in descriptor packet.
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition.BodyLength Property

Grid Solutions Framework FrequencyDefinitionBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition.MaximumLabelLength Property

Grid Solutions Framework FrequencyDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition.Offset Property

Grid Solutions Framework FrequencyDefinitionOffset Property
Gets or sets the offset of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double Offset { get; set; }
Public Overrides Property Offset As Double
    Get
    Set
abstract Offset : float with get, set
override Offset : float with get, set
function get_Offset();
function set_Offset(value);
public:
virtual property double Offset {
    double get () override;
    void set (double value) override;
}

Property Value

Type: Double

Implements

IChannelDefinitionOffset
IChannelDefinitionOffset
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue Class

Grid Solutions Framework FrequencyValue Class
Represents the BPA PDCstream implementation of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.BPAPDCstreamFrequencyValue

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute>
Public Class FrequencyValue
    Inherits FrequencyValueBase
[<SerializableAttribute>]
type FrequencyValue =
    class
        inherit FrequencyValueBase
    end
GSF.PhasorProtocols.BPAPDCstream.FrequencyValue = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.FrequencyValue',
    GSF.PhasorProtocols.FrequencyValueBase);
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase

The FrequencyValue type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue Constructor

Grid Solutions Framework FrequencyValue Constructor
Overload List
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValue Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValue
GSF.PhasorProtocols.BPAPDCstream.FrequencyValue = function(info, context);
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValue Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValue
GSF.PhasorProtocols.BPAPDCstream.FrequencyValue = function(parent, frequencyDefinition);
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValue.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New (
    parent As DataCell,
    frequencyDefinition As FrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : DataCell *
        frequencyDefinition : FrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValue
GSF.PhasorProtocols.BPAPDCstream.FrequencyValue = function(parent, frequencyDefinition, frequency, dfdt);
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamDataCell
The DataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocols.BPAPDCstreamFrequencyDefinition
The FrequencyDefinition associated with this FrequencyValue.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValue.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValue over time.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue Methods

Grid Solutions Framework FrequencyValue Methods

The FrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue.ParseBodyImage Method

Grid Solutions Framework FrequencyValueParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue Properties

Grid Solutions Framework FrequencyValue Properties

The FrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue.BodyImage Property

Grid Solutions Framework FrequencyValueBodyImage Property
Gets the binary body image of the FrequencyValue object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue.BodyLength Property

Grid Solutions Framework FrequencyValueBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
The base implementation assumes fixed integer values are represented as 16-bit signed integers and floating point values are represented as 32-bit single-precision floating-point values (i.e., short and float data types respectively).
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue.Definition Property

Grid Solutions Framework FrequencyValueDefinition Property
Gets or sets the FrequencyDefinition associated with this FrequencyValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
abstract Definition : FrequencyDefinition with get, set
override Definition : FrequencyDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}

Property Value

Type: FrequencyDefinition
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


FrequencyValue.Parent Property

Grid Solutions Framework FrequencyValueParent Property
Gets or sets the DataCell parent of this FrequencyValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


IniFileNameEditor Class

Grid Solutions Framework IniFileNameEditor Class
INI file name browser used with BPA PDCstream ConnectionParameters.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
System.Windows.Forms.DesignFileNameEditor
GSF.PhasorProtocols.BPAPDCstreamIniFileNameEditor

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IniFileNameEditor : FileNameEditor
Public Class IniFileNameEditor
    Inherits FileNameEditor
type IniFileNameEditor =
    class
        inherit FileNameEditor
    end
GSF.PhasorProtocols.BPAPDCstream.IniFileNameEditor = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.IniFileNameEditor',
    FileNameEditor);
public ref class IniFileNameEditor : public FileNameEditor

The IniFileNameEditor type exposes the following members.

Constructors
 | Name | Description
Public method | IniFileNameEditor | Initializes a new instance of the IniFileNameEditor class
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object using the editor style provided by the GetEditStyle(ITypeDescriptorContext) method. (Inherited from FileNameEditor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editing style used by the EditValue(ITypeDescriptorContext, IServiceProvider, Object) method. (Inherited from FileNameEditor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeDialog | Initializes the open file dialog when it is created. (Overrides FileNameEditorInitializeDialog(OpenFileDialog).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


IniFileNameEditor Constructor

Grid Solutions Framework IniFileNameEditor Constructor
Initializes a new instance of the IniFileNameEditor class

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IniFileNameEditor()
Public Sub New
new : unit -> IniFileNameEditor
GSF.PhasorProtocols.BPAPDCstream.IniFileNameEditor = function();
public:
IniFileNameEditor()
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.BPAPDCstream Namespace


IniFileNameEditor Methods

Grid Solutions Framework IniFileNameEditor Methods

The IniFileNameEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object using the editor style provided by the GetEditStyle(ITypeDescriptorContext) method. (Inherited from FileNameEditor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editing style used by the EditValue(ITypeDescriptorContext, IServiceProvider, Object) method. (Inherited from FileNameEditor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeDialog | Initializes the open file dialog when it is created. (Overrides FileNameEditorInitializeDialog(OpenFileDialog).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.BPAPDCstream Namespace


IniFileNameEditor.InitializeDialog Method

Grid Solutions Framework IniFileNameEditorInitializeDialog Method
Initializes the open file dialog when it is created.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InitializeDialog(
    OpenFileDialog openFileDialog
)
Protected Overrides Sub InitializeDialog (
    openFileDialog As OpenFileDialog
)
abstract InitializeDialog :
        openFileDialog : OpenFileDialog -> unit
override InitializeDialog :
        openFileDialog : OpenFileDialog -> unit
function InitializeDialog(openFileDialog);
protected:
virtual void InitializeDialog(
    OpenFileDialog^ openFileDialog
) override

Parameters

openFileDialog
Type: System.Windows.FormsOpenFileDialog
The OpenFileDialog to use to select a file name.
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.BPAPDCstream Namespace


IniFileNameEditor Properties

Grid Solutions Framework IniFileNameEditor Properties

The IniFileNameEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents the BPA PDCstream implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.BPAPDCstreamPhasorDefinition

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.BPAPDCstream.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, Int32, String) | Creates a new PhasorDefinition from specified parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhasorDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinition object. (Overrides PhasorDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | CalFactor | Gets or sets calibration factor of this PhasorDefinition.
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Overrides ChannelDefinitionBaseConversionFactor.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this PhasorDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Ratio | Gets or sets ratio of this PhasorDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Shunt | Gets or sets shunt value of this PhasorDefinition.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Public property | VoltageReferenceIndex | Gets or sets voltage reference index of this PhasorDefinition.
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, Int32, String) | Creates a new PhasorDefinition from specified parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinition Constructor (IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinition
GSF.PhasorProtocols.BPAPDCstream.PhasorDefinition = function(parent);
public:
PhasorDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinition.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.BPAPDCstream.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Constructor (ConfigurationCell, Int32, String)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, Int32, String)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    int index,
    string entryValue
)
Public Sub New (
    parent As ConfigurationCell,
    index As Integer,
    entryValue As String
)
new :
        parent : ConfigurationCell *
        index : int *
        entryValue : string -> PhasorDefinition
GSF.PhasorProtocols.BPAPDCstream.PhasorDefinition = function(parent, index, entryValue);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    int index,
    String^ entryValue
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
index
Type: SystemInt32
Index of phasor within INI based configuration file.
entryValue
Type: SystemString
The entry value from the INI based configuration file.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.BPAPDCstream.PhasorDefinition = function(parent, label, scale, offset, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
scale
Type: SystemUInt32
The integer scaling value of this PhasorDefinition.
offset
Type: SystemDouble
The offset of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.BPAPDCstreamPhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhasorDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.GetObjectData Method

Grid Solutions Framework PhasorDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinition object. (Overrides PhasorDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | CalFactor | Gets or sets calibration factor of this PhasorDefinition.
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Overrides ChannelDefinitionBaseConversionFactor.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this PhasorDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Ratio | Gets or sets ratio of this PhasorDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Shunt | Gets or sets shunt value of this PhasorDefinition.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Public property | VoltageReferenceIndex | Gets or sets voltage reference index of this PhasorDefinition.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.Attributes Property

Grid Solutions Framework PhasorDefinitionAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinition object.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.CalFactor Property

Grid Solutions Framework PhasorDefinitionCalFactor Property
Gets or sets calibration factor of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalFactor { get; set; }
Public Property CalFactor As Double
    Get
    Set
member CalFactor : float with get, set

function get_CalFactor();
function set_CalFactor(value);
public:
property double CalFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.ConversionFactor Property

Grid Solutions Framework PhasorDefinitionConversionFactor Property
Gets or sets the conversion factor of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override double ConversionFactor { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property ConversionFactor As Double
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ConversionFactor : float with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ConversionFactor : float with get, set
function get_ConversionFactor();
function set_ConversionFactor(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property double ConversionFactor {
    double get () override;
    void set (double value) override;
}

Property Value

Type: Double

Implements

IChannelDefinitionConversionFactor
Remarks
This method is hidden from the consumer since BPA PDCstream uses a custom conversion factor. Property always returns 1.0, updates are ignored.
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.MaximumLabelLength Property

Grid Solutions Framework PhasorDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.Ratio Property

Grid Solutions Framework PhasorDefinitionRatio Property
Gets or sets ratio of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Ratio { get; set; }
Public Property Ratio As Double
    Get
    Set
member Ratio : float with get, set

function get_Ratio();
function set_Ratio(value);
public:
property double Ratio {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.Shunt Property

Grid Solutions Framework PhasorDefinitionShunt Property
Gets or sets shunt value of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Shunt { get; set; }
Public Property Shunt As Double
    Get
    Set
member Shunt : float with get, set

function get_Shunt();
function set_Shunt(value);
public:
property double Shunt {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorDefinition.VoltageReferenceIndex Property

Grid Solutions Framework PhasorDefinitionVoltageReferenceIndex Property
Gets or sets voltage reference index of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int VoltageReferenceIndex { get; set; }
Public Property VoltageReferenceIndex As Integer
    Get
    Set
member VoltageReferenceIndex : int with get, set

function get_VoltageReferenceIndex();
function set_VoltageReferenceIndex(value);
public:
property int VoltageReferenceIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Class

Grid Solutions Framework PhasorValue Class
Represents the BPA PDCstream implementation of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.BPAPDCstreamPhasorValue

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute>
Public Class PhasorValue
    Inherits PhasorValueBase
[<SerializableAttribute>]
type PhasorValue =
    class
        inherit PhasorValueBase
    end
GSF.PhasorProtocols.BPAPDCstream.PhasorValue = function();

Type.createClass(
    'GSF.PhasorProtocols.BPAPDCstream.PhasorValue',
    GSF.PhasorProtocols.PhasorValueBase);
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase

The PhasorValue type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValue, in radians. (Overrides PhasorValueBaseAngle.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue. (Overrides PhasorValueBaseMagnitude.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Constructor

Grid Solutions Framework PhasorValue Constructor
Overload List
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValue Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValue
GSF.PhasorProtocols.BPAPDCstream.PhasorValue = function(info, context);
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValue Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValue
GSF.PhasorProtocols.BPAPDCstream.PhasorValue = function(parent, phasorDefinition);
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValue
GSF.PhasorProtocols.BPAPDCstream.PhasorValue = function(parent, phasorDefinition, angle, magnitude);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.BPAPDCstreamPhasorDefinition
The PhasorDefinition associated with this PhasorValue.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        real : float *
        imaginary : float -> PhasorValue
GSF.PhasorProtocols.BPAPDCstream.PhasorValue = function(parent, phasorDefinition, real, imaginary);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocols.BPAPDCstreamDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.BPAPDCstreamPhasorDefinition
The PhasorDefinition associated with this PhasorValue.
real
Type: SystemDouble
The real value of this PhasorValue.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Methods

Grid Solutions Framework PhasorValue Methods

The PhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue Properties

Grid Solutions Framework PhasorValue Properties

The PhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValue, in radians. (Overrides PhasorValueBaseAngle.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue. (Overrides PhasorValueBaseMagnitude.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue.Angle Property

Grid Solutions Framework PhasorValueAngle Property
Gets or sets the Angle value (a.k.a., the argument) of this PhasorValue, in radians.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Angle Angle { get; set; }
Public Overrides Property Angle As Angle
    Get
    Set
abstract Angle : Angle with get, set
override Angle : Angle with get, set
function get_Angle();
function set_Angle(value);
public:
virtual property Angle Angle {
    Angle get () override;
    void set (Angle value) override;
}

Property Value

Type: Angle

Implements

IPhasorValueAngle
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue.Definition Property

Grid Solutions Framework PhasorValueDefinition Property
Gets or sets the PhasorDefinition associated with this PhasorValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
abstract Definition : PhasorDefinition with get, set
override Definition : PhasorDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}

Property Value

Type: PhasorDefinition
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue.Magnitude Property

Grid Solutions Framework PhasorValueMagnitude Property
Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double Magnitude { get; set; }
Public Overrides Property Magnitude As Double
    Get
    Set
abstract Magnitude : float with get, set
override Magnitude : float with get, set
function get_Magnitude();
function set_Magnitude(value);
public:
virtual property double Magnitude {
    double get () override;
    void set (double value) override;
}

Property Value

Type: Double

Implements

IPhasorValueMagnitude
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PhasorValue.Parent Property

Grid Solutions Framework PhasorValueParent Property
Gets or sets the DataCell parent of this PhasorValue.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.BPAPDCstream Namespace


PMUStatusFlags Enumeration

Grid Solutions Framework PMUStatusFlags Enumeration
PMU status flags enumeration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum PMUStatusFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration PMUStatusFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type PMUStatusFlags
GSF.PhasorProtocols.BPAPDCstream.PMUStatusFlags = function();
GSF.PhasorProtocols.BPAPDCstream.PMUStatusFlags.createEnum('GSF.PhasorProtocols.BPAPDCstream.PMUStatusFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class PMUStatusFlags
Members
Member name | Value | Description
SyncInvalid | 1 | Synchonization is invalid.
DataInvalid | 2 | Data is invalid.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


ReservedFlags Enumeration

Grid Solutions Framework ReservedFlags Enumeration
Reserved flags enumeration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum ReservedFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration ReservedFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type ReservedFlags
GSF.PhasorProtocols.BPAPDCstream.ReservedFlags = function();
GSF.PhasorProtocols.BPAPDCstream.ReservedFlags.createEnum('GSF.PhasorProtocols.BPAPDCstream.ReservedFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class ReservedFlags
Members
Member name | Value | Description
Reserved0 | 128 | Reserved bit 7.
Reserved1 | 64 | Reserved bit 6.
AnalogWordsMask | 63 | Analog words mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


RevisionNumber Enumeration

Grid Solutions Framework RevisionNumber Enumeration
Stream revision number enumeration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum RevisionNumber
<SerializableAttribute>
Public Enumeration RevisionNumber
[<SerializableAttribute>]
type RevisionNumber
GSF.PhasorProtocols.BPAPDCstream.RevisionNumber = function();
GSF.PhasorProtocols.BPAPDCstream.RevisionNumber.createEnum('GSF.PhasorProtocols.BPAPDCstream.RevisionNumber', false);
[SerializableAttribute]
public enum class RevisionNumber
Members
Member name | Value | Description
Revision0 | 0 | Original revision for all to June 2002, use NTP timetag (start count 1900).
Revision1 | 1 | July 2002 revision for std. 37.118, use UNIX timetag (start count 1970).
Revision2 | 2 | May 2005 revision for std. 37.118, change ChanFlag for added data types.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


StreamType Enumeration

Grid Solutions Framework StreamType Enumeration
Stream type enueration.

Namespace: GSF.PhasorProtocols.BPAPDCstream
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum StreamType
<SerializableAttribute>
Public Enumeration StreamType
[<SerializableAttribute>]
type StreamType
GSF.PhasorProtocols.BPAPDCstream.StreamType = function();
GSF.PhasorProtocols.BPAPDCstream.StreamType.createEnum('GSF.PhasorProtocols.BPAPDCstream.StreamType', false);
[SerializableAttribute]
public enum class StreamType
Members
Member name | Value | Description
Legacy | 0 | Standard full data stream.
Compact | 1 | Full data stream with PMU ID's and offsets removed from data packet.
See Also

Reference

GSF.PhasorProtocols.BPAPDCstream Namespace


GSF.PhasorProtocols.FNET Namespace

Grid Solutions Framework GSF.PhasorProtocols.FNET Namespace
Contains an implementation of the phasor classes used to parse or generate a stream of data in the F-NET device format.
Classes
 | Class | Description
Public class | Common | Common F-NET declarations and functions.
Public class | CommonFrameHeader | Represents the common header for a F-NET frame of data.
Public class | ConfigurationCell | Represents the F-NET implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a F-NET implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame | Represents the F-NET implementation of a IConfigurationFrame that can be sent or received.
Public class | ConnectionParameters | Represents the extra connection parameters required for a connection to a F-NET device.
Public class | DataCell | Represents the F-NET implementation of a IDataCell that can be sent or received.
Public class | DataCellCollection | Represents a F-NET implementation of a collection of IDataCell objects.
Public class | DataFrame | Represents the F-NET implementation of a IDataFrame that can be sent or received.
Public class | FrameParser | Represents a frame parser for a F-NET text based data stream that returns parsed data via events.
Public class | FrequencyDefinition | Represents the F-NET implementation of a IFrequencyDefinition.
Public class | FrequencyValue | Represents the F-NET implementation of a IFrequencyValue.
Public class | PhasorDefinition | Represents the F-NET implementation of a IPhasorDefinition.
Public class | PhasorValue | Represents the F-NET implementation of a IPhasorValue.


Common Class

Grid Solutions Framework Common Class
Common F-NET declarations and functions.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.FNETCommon

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.FNET.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.Common');
public ref class Common abstract sealed

The Common type exposes the following members.

Fields
Name | Description
DefaultFrameRate | Default frame rate for F-NET devices is 10 frames per second.
DefaultNominalFrequency | Default nominal frequency for F-NET devices is 60Hz.
DefaultStationName | Default F-NET station name.
DefaultTimeOffset | Default real-time ticks offset for F-NET.
EndByte | F-NET data frame start byte.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
MaximumPracticalFrameSize | The maximum practical limit for an F-NET data frame.
StartByte | F-NET data frame start byte.
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
DefaultFrameRate | Default frame rate for F-NET devices is 10 frames per second.
DefaultNominalFrequency | Default nominal frequency for F-NET devices is 60Hz.
DefaultStationName | Default F-NET station name.
DefaultTimeOffset | Default real-time ticks offset for F-NET.
EndByte | F-NET data frame start byte.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
MaximumPracticalFrameSize | The maximum practical limit for an F-NET data frame.
StartByte | F-NET data frame start byte.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.DefaultFrameRate Field

Grid Solutions Framework CommonDefaultFrameRate Field
Default frame rate for F-NET devices is 10 frames per second.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort DefaultFrameRate
Public Const DefaultFrameRate As UShort
static val mutable DefaultFrameRate: uint16
var GSF.PhasorProtocols.FNET.Common.DefaultFrameRate
public:
literal unsigned short DefaultFrameRate

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.DefaultNominalFrequency Field

Grid Solutions Framework CommonDefaultNominalFrequency Field
Default nominal frequency for F-NET devices is 60Hz.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const LineFrequency DefaultNominalFrequency
Public Const DefaultNominalFrequency As LineFrequency
static val mutable DefaultNominalFrequency: LineFrequency
var GSF.PhasorProtocols.FNET.Common.DefaultNominalFrequency
public:
literal LineFrequency DefaultNominalFrequency

Field Value

Type: LineFrequency
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.DefaultStationName Field

Grid Solutions Framework CommonDefaultStationName Field
Default F-NET station name.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultStationName
Public Const DefaultStationName As String
static val mutable DefaultStationName: string
var GSF.PhasorProtocols.FNET.Common.DefaultStationName
public:
literal String^ DefaultStationName

Field Value

Type: String
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.DefaultTimeOffset Field

Grid Solutions Framework CommonDefaultTimeOffset Field
Default real-time ticks offset for F-NET.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long DefaultTimeOffset
Public Const DefaultTimeOffset As Long
static val mutable DefaultTimeOffset: int64
var GSF.PhasorProtocols.FNET.Common.DefaultTimeOffset
public:
literal long long DefaultTimeOffset

Field Value

Type: Int64
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.EndByte Field

Grid Solutions Framework CommonEndByte Field
F-NET data frame start byte.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte EndByte
Public Const EndByte As Byte
static val mutable EndByte: byte
var GSF.PhasorProtocols.FNET.Common.EndByte
public:
literal unsigned char EndByte

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.MaximumAnalogValues Field

Grid Solutions Framework CommonMaximumAnalogValues Field
Absolute maximum number of possible analog values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaximumAnalogValues
Public Const MaximumAnalogValues As Integer
static val mutable MaximumAnalogValues: int
var GSF.PhasorProtocols.FNET.Common.MaximumAnalogValues
public:
literal int MaximumAnalogValues

Field Value

Type: Int32
Remarks
F-NET doesn't support analog values.
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.MaximumDigitalValues Field

Grid Solutions Framework CommonMaximumDigitalValues Field
Absolute maximum number of possible digital values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaximumDigitalValues
Public Const MaximumDigitalValues As Integer
static val mutable MaximumDigitalValues: int
var GSF.PhasorProtocols.FNET.Common.MaximumDigitalValues
public:
literal int MaximumDigitalValues

Field Value

Type: Int32
Remarks
F-NET doesn't support digital values.
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.MaximumPhasorValues Field

Grid Solutions Framework CommonMaximumPhasorValues Field
Absolute maximum number of possible phasor values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaximumPhasorValues
Public Const MaximumPhasorValues As Integer
static val mutable MaximumPhasorValues: int
var GSF.PhasorProtocols.FNET.Common.MaximumPhasorValues
public:
literal int MaximumPhasorValues

Field Value

Type: Int32
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.MaximumPracticalFrameSize Field

Grid Solutions Framework CommonMaximumPracticalFrameSize Field
The maximum practical limit for an F-NET data frame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaximumPracticalFrameSize
Public Const MaximumPracticalFrameSize As Integer
static val mutable MaximumPracticalFrameSize: int
var GSF.PhasorProtocols.FNET.Common.MaximumPracticalFrameSize
public:
literal int MaximumPracticalFrameSize

Field Value

Type: Int32
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


Common.StartByte Field

Grid Solutions Framework CommonStartByte Field
F-NET data frame start byte.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte StartByte
Public Const StartByte As Byte
static val mutable StartByte: byte
var GSF.PhasorProtocols.FNET.Common.StartByte
public:
literal unsigned char StartByte

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.FNET Namespace


CommonFrameHeader Class

Grid Solutions Framework CommonFrameHeader Class
Represents the common header for a F-NET frame of data.
Inheritance Hierarchy
SystemObject
GSF.ParsingCommonHeaderBase Int32
GSF.PhasorProtocols.FNETCommonFrameHeader

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CommonFrameHeader : CommonHeaderBase<int>
Public Class CommonFrameHeader
    Inherits CommonHeaderBase(Of Integer)
type CommonFrameHeader =
    class
        inherit CommonHeaderBase<int>
    end
GSF.PhasorProtocols.FNET.CommonFrameHeader = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.CommonFrameHeader',
    GSF.Parsing.CommonHeaderBase`1);
public ref class CommonFrameHeader : public CommonHeaderBase<int>

The CommonFrameHeader type exposes the following members.

Constructors
 | Name | Description
Public method | CommonFrameHeader | Creates a new CommonFrameHeader from given buffer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | DataElements | Gets F-NET data elements parsed during construction.
Public property | ParsedLength | Gets length of data parsed during construction.
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
Remarks
Because of its simplicity, all F-NET parsing is handled in the constructor of this class. Subsequently all parsed data is available as an array of strings where needed.
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Creates a new CommonFrameHeader from given buffer.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> CommonFrameHeader
GSF.PhasorProtocols.FNET.CommonFrameHeader = function(buffer, startIndex, length);
public:
CommonFrameHeader(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Buffer that contains data to parse.
startIndex
Type: SystemInt32
Start index into buffer where valid data begins.
length
Type: SystemInt32
Length of valid data in buffer.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.FNET Namespace


CommonFrameHeader Methods

Grid Solutions Framework CommonFrameHeader Methods

The CommonFrameHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.FNET Namespace


CommonFrameHeader Properties

Grid Solutions Framework CommonFrameHeader Properties

The CommonFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | DataElements | Gets F-NET data elements parsed during construction.
Public property | ParsedLength | Gets length of data parsed during construction.
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.FNET Namespace


CommonFrameHeader.DataElements Property

Grid Solutions Framework CommonFrameHeaderDataElements Property
Gets F-NET data elements parsed during construction.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] DataElements { get; }
Public ReadOnly Property DataElements As String()
    Get
member DataElements : string[] with get

function get_DataElements();

public:
property array<String^>^ DataElements {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.FNET Namespace


CommonFrameHeader.ParsedLength Property

Grid Solutions Framework CommonFrameHeaderParsedLength Property
Gets length of data parsed during construction.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParsedLength { get; }
Public ReadOnly Property ParsedLength As Integer
    Get
member ParsedLength : int with get

function get_ParsedLength();

public:
property int ParsedLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents the F-NET implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.FNETConfigurationCell

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
    end
GSF.PhasorProtocols.FNET.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationCell | Creates a new ConfigurationCell from serialization parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationCell. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Latitude | Gets or sets the latitude (i.e., North/South geospatial position) of the device defined by this ConfigurationCell.
Public property | Longitude | Gets or sets the longitude (i.e., East/West geospatial position) of the device defined by this ConfigurationCell.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NumberOfSatellites | Gets or sets the number of satellites visible to the GPS timing source of the device defined by this ConfigurationCell.
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeOffset | Gets or sets time offset of F-NET device in Ticks.
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.FNET.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.GetObjectData Method

Grid Solutions Framework ConfigurationCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationCell. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Latitude | Gets or sets the latitude (i.e., North/South geospatial position) of the device defined by this ConfigurationCell.
Public property | Longitude | Gets or sets the longitude (i.e., East/West geospatial position) of the device defined by this ConfigurationCell.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NumberOfSatellites | Gets or sets the number of satellites visible to the GPS timing source of the device defined by this ConfigurationCell.
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeOffset | Gets or sets time offset of F-NET device in Ticks.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports floating-point data.
Remarks
This property only supports floating-point data; F-NET doesn't transport scaled values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.Attributes Property

Grid Solutions Framework ConfigurationCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports floating-point data.
Remarks
This property only supports floating-point data; F-NET doesn't transport scaled values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.IDCode Property

Grid Solutions Framework ConfigurationCellIDCode Property
Gets or sets the ID code of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}

Property Value

Type: UInt16

Implements

IChannelCellIDCode
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.Latitude Property

Grid Solutions Framework ConfigurationCellLatitude Property
Gets or sets the latitude (i.e., North/South geospatial position) of the device defined by this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
member Latitude : float with get, set

function get_Latitude();
function set_Latitude(value);
public:
property double Latitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.Longitude Property

Grid Solutions Framework ConfigurationCellLongitude Property
Gets or sets the longitude (i.e., East/West geospatial position) of the device defined by this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
member Longitude : float with get, set

function get_Longitude();
function set_Longitude(value);
public:
property double Longitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.MaximumStationNameLength Property

Grid Solutions Framework ConfigurationCellMaximumStationNameLength Property
Gets the maximum length of the StationName of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
abstract MaximumStationNameLength : int with get
override MaximumStationNameLength : int with get
function get_MaximumStationNameLength();

public:
virtual property int MaximumStationNameLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IConfigurationCellMaximumStationNameLength
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.NumberOfSatellites Property

Grid Solutions Framework ConfigurationCellNumberOfSatellites Property
Gets or sets the number of satellites visible to the GPS timing source of the device defined by this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int NumberOfSatellites { get; set; }
Public Property NumberOfSatellites As Integer
    Get
    Set
member NumberOfSatellites : int with get, set

function get_NumberOfSatellites();
function set_NumberOfSatellites(value);
public:
property int NumberOfSatellites {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.Parent Property

Grid Solutions Framework ConfigurationCellParent Property
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
member Parent : ConfigurationFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports polar phasor data.
Remarks
This property only supports polar phasor data; F-NET doesn't transport rectangular phasor values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
Exceptions
Exception | Condition
NotSupportedException | F-NET only supports floating-point data.
Remarks
This property only supports floating-point data; F-NET doesn't transport scaled values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCell.TimeOffset Property

Grid Solutions Framework ConfigurationCellTimeOffset Property
Gets or sets time offset of F-NET device in Ticks.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks TimeOffset { get; set; }
Public Property TimeOffset As Ticks
    Get
    Set
member TimeOffset : Ticks with get, set

function get_TimeOffset();
function set_TimeOffset(value);
public:
property Ticks TimeOffset {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10,000,000 ticks.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a F-NET implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.FNETConfigurationCellCollection

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.FNET.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.FNET.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.FNET.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame Class

Grid Solutions Framework ConfigurationFrame Class
Represents the F-NET implementation of a IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.FNETConfigurationFrame

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase
<SerializableAttribute>
Public Class ConfigurationFrame
    Inherits ConfigurationFrameBase
[<SerializableAttribute>]
type ConfigurationFrame =
    class
        inherit ConfigurationFrameBase
    end
GSF.PhasorProtocols.FNET.ConfigurationFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.ConfigurationFrame',
    GSF.PhasorProtocols.ConfigurationFrameBase);
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase

The ConfigurationFrame type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt16, Ticks, UInt16, LineFrequency, Ticks, String) | Creates a new ConfigurationFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Method is not implemented. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrameBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrameBase object. (Inherited from ConfigurationFrameBase.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Latitude | Gets or sets the latitude (i.e., North/South geospatial position) of the device.
Public property | Longitude | Gets or sets the longitude (i.e., East/West geospatial position) of the device.
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of this ConfigurationFrame.
Public property | NumberOfSatellites | Gets or sets the number of satellites visible to the GPS timing source of the device.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | TimeOffset | Gets or sets the time offset of F-NET device in Ticks.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Overload List
 | Name | Description
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt16, Ticks, UInt16, LineFrequency, Ticks, String) | Creates a new ConfigurationFrame from specified parameters.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame
GSF.PhasorProtocols.FNET.ConfigurationFrame = function(info, context);
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame Constructor (UInt16, Ticks, UInt16, LineFrequency, Ticks, String)

Grid Solutions Framework ConfigurationFrame Constructor (UInt16, Ticks, UInt16, LineFrequency, Ticks, String)
Creates a new ConfigurationFrame from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame(
    ushort idCode,
    Ticks timestamp,
    ushort frameRate,
    LineFrequency nominalFrequency,
    Ticks timeOffset,
    string stationName
)
Public Sub New (
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort,
    nominalFrequency As LineFrequency,
    timeOffset As Ticks,
    stationName As String
)
new :
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 *
        nominalFrequency : LineFrequency *
        timeOffset : Ticks *
        stationName : string -> ConfigurationFrame
GSF.PhasorProtocols.FNET.ConfigurationFrame = function(idCode, timestamp, frameRate, nominalFrequency, timeOffset, stationName);
public:
ConfigurationFrame(
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate,
    LineFrequency nominalFrequency,
    Ticks timeOffset,
    String^ stationName
)

Parameters

idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame.
nominalFrequency
Type: GSF.Units.EELineFrequency
The nominal LineFrequency of this ConfigurationFrame.
timeOffset
Type: GSFTicks
The time offset of F-NET device in Ticks.
stationName
Type: SystemString
The station name of the F-NET device.
Remarks
This constructor is used by a consumer to generate an F-NET configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame Methods

Grid Solutions Framework ConfigurationFrame Methods

The ConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Method is not implemented. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrameBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrameCalculateChecksum Method
Method is not implemented.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
A Byte array.
offset
Type: SystemInt32
An Int32 for the length.
length
Type: SystemInt32
An Int32 for the offset.

Return Value

Type: UInt16
An UInt16.
Exceptions
Exception | Condition
NotImplementedException | F-NET doesn't use checksums.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.ChecksumIsValid Method

Grid Solutions Framework ConfigurationFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
F-NET doesn't use checksums - this always returns true.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame Properties

Grid Solutions Framework ConfigurationFrame Properties

The ConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrameBase object. (Inherited from ConfigurationFrameBase.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Latitude | Gets or sets the latitude (i.e., North/South geospatial position) of the device.
Public property | Longitude | Gets or sets the longitude (i.e., East/West geospatial position) of the device.
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of this ConfigurationFrame.
Public property | NumberOfSatellites | Gets or sets the number of satellites visible to the GPS timing source of the device.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | TimeOffset | Gets or sets the time offset of F-NET device in Ticks.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.Cells Property

Grid Solutions Framework ConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.Latitude Property

Grid Solutions Framework ConfigurationFrameLatitude Property
Gets or sets the latitude (i.e., North/South geospatial position) of the device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Latitude { get; set; }
Public Property Latitude As Double
    Get
    Set
member Latitude : float with get, set

function get_Latitude();
function set_Latitude(value);
public:
property double Latitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.Longitude Property

Grid Solutions Framework ConfigurationFrameLongitude Property
Gets or sets the longitude (i.e., East/West geospatial position) of the device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Longitude { get; set; }
Public Property Longitude As Double
    Get
    Set
member Longitude : float with get, set

function get_Longitude();
function set_Longitude(value);
public:
property double Longitude {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.NominalFrequency Property

Grid Solutions Framework ConfigurationFrameNominalFrequency Property
Gets or sets the nominal LineFrequency of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LineFrequency NominalFrequency { get; set; }
Public Property NominalFrequency As LineFrequency
    Get
    Set
member NominalFrequency : LineFrequency with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}

Property Value

Type: LineFrequency
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.NumberOfSatellites Property

Grid Solutions Framework ConfigurationFrameNumberOfSatellites Property
Gets or sets the number of satellites visible to the GPS timing source of the device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int NumberOfSatellites { get; set; }
Public Property NumberOfSatellites As Integer
    Get
    Set
member NumberOfSatellites : int with get, set

function get_NumberOfSatellites();
function set_NumberOfSatellites(value);
public:
property int NumberOfSatellites {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConfigurationFrame.TimeOffset Property

Grid Solutions Framework ConfigurationFrameTimeOffset Property
Gets or sets the time offset of F-NET device in Ticks.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks TimeOffset { get; set; }
Public Property TimeOffset As Ticks
    Get
    Set
member TimeOffset : Ticks with get, set

function get_TimeOffset();
function set_TimeOffset(value);
public:
property Ticks TimeOffset {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10,000,000 ticks.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters Class

Grid Solutions Framework ConnectionParameters Class
Represents the extra connection parameters required for a connection to a F-NET device.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsConnectionParametersBase
GSF.PhasorProtocols.FNETConnectionParameters

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute>
Public Class ConnectionParameters
    Inherits ConnectionParametersBase
[<SerializableAttribute>]
type ConnectionParameters =
    class
        inherit ConnectionParametersBase
    end
GSF.PhasorProtocols.FNET.ConnectionParameters = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.ConnectionParameters',
    GSF.PhasorProtocols.ConnectionParametersBase);
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase

The ConnectionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | FrameRate | Gets or sets the configured frame rate for the F-NET device.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of this F-NET device.
Public property | StationName | Gets or sets the station name for the F-NET device.
Public property | TimeOffset | Gets or sets time offset of the F-NET device in Ticks.
Public property | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Top
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Overload List
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Creates a new ConnectionParameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionParameters()
Public Sub New
new : unit -> ConnectionParameters
GSF.PhasorProtocols.FNET.ConnectionParameters = function();
public:
ConnectionParameters()
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConnectionParameters Constructor (SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConnectionParameters
GSF.PhasorProtocols.FNET.ConnectionParameters = function(info, context);
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters Methods

Grid Solutions Framework ConnectionParameters Methods

The ConnectionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters.GetObjectData Method

Grid Solutions Framework ConnectionParametersGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters Properties

Grid Solutions Framework ConnectionParameters Properties

The ConnectionParameters type exposes the following members.

Properties
 | Name | Description
Public property | FrameRate | Gets or sets the configured frame rate for the F-NET device.
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of this F-NET device.
Public property | StationName | Gets or sets the station name for the F-NET device.
Public property | TimeOffset | Gets or sets time offset of the F-NET device in Ticks.
Public property | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters.FrameRate Property

Grid Solutions Framework ConnectionParametersFrameRate Property
Gets or sets the configured frame rate for the F-NET device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(10)]
public ushort FrameRate { get; set; }
<DefaultValueAttribute(10)>
Public Property FrameRate As UShort
    Get
    Set
[<DefaultValueAttribute(10)>]
member FrameRate : uint16 with get, set

function get_FrameRate();
function set_FrameRate(value);
public:
[DefaultValueAttribute(10)]
property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
Remarks
This is typically set to 10 frames per second.
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters.NominalFrequency Property

Grid Solutions Framework ConnectionParametersNominalFrequency Property
Gets or sets the nominal LineFrequency of this F-NET device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(typeof(LineFrequency), "Hz60")]
public LineFrequency NominalFrequency { get; set; }
<DefaultValueAttribute(GetType(LineFrequency), "Hz60")>
Public Property NominalFrequency As LineFrequency
    Get
    Set
[<DefaultValueAttribute(typeof(LineFrequency), "Hz60")>]
member NominalFrequency : LineFrequency with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
public:
[DefaultValueAttribute(typeof(LineFrequency), L"Hz60")]
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}

Property Value

Type: LineFrequency
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters.StationName Property

Grid Solutions Framework ConnectionParametersStationName Property
Gets or sets the station name for the F-NET device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("F-NET Unit")]
public string StationName { get; set; }
<DefaultValueAttribute("F-NET Unit")>
Public Property StationName As String
    Get
    Set
[<DefaultValueAttribute("F-NET Unit")>]
member StationName : string with get, set

function get_StationName();
function set_StationName(value);
public:
[DefaultValueAttribute(L"F-NET Unit")]
property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


ConnectionParameters.TimeOffset Property

Grid Solutions Framework ConnectionParametersTimeOffset Property
Gets or sets time offset of the F-NET device in Ticks.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(110000000)]
public long TimeOffset { get; set; }
<DefaultValueAttribute(110000000)>
Public Property TimeOffset As Long
    Get
    Set
[<DefaultValueAttribute(110000000)>]
member TimeOffset : int64 with get, set

function get_TimeOffset();
function set_TimeOffset(value);
public:
[DefaultValueAttribute(110000000)]
property long long TimeOffset {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10,000,000 ticks.
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.FNET Namespace


DataCell Class

Grid Solutions Framework DataCell Class
Represents the F-NET implementation of a IDataCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.FNETDataCell

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute>
Public Class DataCell
    Inherits DataCellBase
[<SerializableAttribute>]
type DataCell =
    class
        inherit DataCellBase
    end
GSF.PhasorProtocols.FNET.DataCell = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.DataCell',
    GSF.PhasorProtocols.DataCellBase);
[SerializableAttribute]
public ref class DataCell : public DataCellBase

The DataCell type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides DataCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValue | Gets or sets analog value for F-NET data row.
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCell object. (Overrides DataCellBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides DataCellBaseBodyLength.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | FNetDataRow | Gets image of this DataCell as a F-NET formatted data row.
Public property | FNetDate | Gets date in F-NET format.
Public property | FNetTime | Gets time in F-NET format.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


DataCell Constructor

Grid Solutions Framework DataCell Constructor
Overload List
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCell Constructor (SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCell
GSF.PhasorProtocols.FNET.DataCell = function(info, context);
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.FNET Namespace


DataCell Constructor (IDataFrame, IConfigurationCell)

Grid Solutions Framework DataCell Constructor (IDataFrame, IConfigurationCell)
Creates a new DataCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell -> DataCell
GSF.PhasorProtocols.FNET.DataCell = function(parent, configurationCell);
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCell.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.FNET Namespace


DataCell Methods

Grid Solutions Framework DataCell Methods

The DataCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides DataCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.GetObjectData Method

Grid Solutions Framework DataCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.ParseBodyImage Method

Grid Solutions Framework DataCellParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The longitude, latitude and number of satellites arrive at the top of minute in F-NET data as the analog data in a single row, each on their own row, as sample 1, 2, and 3 respectively.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell Properties

Grid Solutions Framework DataCell Properties

The DataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValue | Gets or sets analog value for F-NET data row.
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCell object. (Overrides DataCellBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides DataCellBaseBodyLength.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | FNetDataRow | Gets image of this DataCell as a F-NET formatted data row.
Public property | FNetDate | Gets date in F-NET format.
Public property | FNetTime | Gets time in F-NET format.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.AnalogValue Property

Grid Solutions Framework DataCellAnalogValue Property
Gets or sets analog value for F-NET data row.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double AnalogValue { get; set; }
Public Property AnalogValue As Double
    Get
    Set
member AnalogValue : float with get, set

function get_AnalogValue();
function set_AnalogValue(value);
public:
property double AnalogValue {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.Attributes Property

Grid Solutions Framework DataCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataCell object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.BodyImage Property

Grid Solutions Framework DataCellBodyImage Property
Gets the binary body image of the DataCell object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.BodyLength Property

Grid Solutions Framework DataCellBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.ConfigurationCell Property

Grid Solutions Framework DataCellConfigurationCell Property
Gets or sets the ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
member ConfigurationCell : ConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.DataIsValid Property

Grid Solutions Framework DataCellDataIsValid Property
Gets or sets flag that determines if data of this DataCell is valid.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set
override DataIsValid : bool with get, set
function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.DataSortingType Property

Grid Solutions Framework DataCellDataSortingType Property
Gets or sets DataSortingType of this DataCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set
override DataSortingType : DataSortingType with get, set
function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.DeviceError Property

Grid Solutions Framework DataCellDeviceError Property
Gets or sets flag that determines if source device of this DataCell is reporting an error.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property DeviceError As Boolean
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract DeviceError : bool with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override DeviceError : bool with get, set
function get_DeviceError();
function set_DeviceError(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
Remarks
F-NET doesn't define any flags for device errors.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.FNetDataRow Property

Grid Solutions Framework DataCellFNetDataRow Property
Gets image of this DataCell as a F-NET formatted data row.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FNetDataRow { get; }
Public ReadOnly Property FNetDataRow As String
    Get
member FNetDataRow : string with get

function get_FNetDataRow();

public:
property String^ FNetDataRow {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.FNetDate Property

Grid Solutions Framework DataCellFNetDate Property
Gets date in F-NET format.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FNetDate { get; }
Public ReadOnly Property FNetDate As String
    Get
member FNetDate : string with get

function get_FNetDate();

public:
property String^ FNetDate {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.FNetTime Property

Grid Solutions Framework DataCellFNetTime Property
Gets time in F-NET format.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FNetTime { get; }
Public ReadOnly Property FNetTime As String
    Get
member FNetTime : string with get

function get_FNetTime();

public:
property String^ FNetTime {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.Parent Property

Grid Solutions Framework DataCellParent Property
Gets or sets the reference to parent DataFrame of this DataCell.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
member Parent : DataFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}

Property Value

Type: DataFrame
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCell.SynchronizationIsValid Property

Grid Solutions Framework DataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set
override SynchronizationIsValid : bool with get, set
function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
Remarks
F-NET defines synchronization validity as a derived value based on the number of available satellites, i.e., synchronization is valid if number of visible sattellites is greater than zero.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.FNET Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a F-NET implementation of a collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.FNETDataCellCollection

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute>
Public Class DataCellCollection
    Inherits DataCellCollection
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit DataCellCollection
    end
GSF.PhasorProtocols.FNET.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.DataCellCollection',
    GSF.PhasorProtocols.DataCellCollection);
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.FNET Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Creates a new DataCellCollection.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection()
Public Sub New
new : unit -> DataCellCollection
GSF.PhasorProtocols.FNET.DataCellCollection = function();
public:
DataCellCollection()
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.FNET Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.FNET.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.FNET Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.FNET Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.FNET Namespace


DataCellCollection.Item Property

Grid Solutions Framework DataCellCollectionItem Property
Gets or sets DataCell at specified index.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As DataCell
    Get
    Set
member Item : DataCell with get, set

function get_Item(index);
function set_Item(value);
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: DataCell
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.FNET Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.FNET Namespace


DataFrame Class

Grid Solutions Framework DataFrame Class
Represents the F-NET implementation of a IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.FNETDataFrame

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportSourceIdentifiableFrameImage<SourceChannel, int>,
    ISupportFrameImage<int>, ISupportBinaryImage
<SerializableAttribute>
Public Class DataFrame
    Inherits DataFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, Integer), ISupportFrameImage(Of Integer),
    ISupportBinaryImage
[<SerializableAttribute>]
type DataFrame =
    class
        inherit DataFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, int>
        interface ISupportFrameImage<int>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.FNET.DataFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.DataFrame',
    GSF.PhasorProtocols.DataFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, int>, ISupportFrameImage<int>, ISupportBinaryImage

The DataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame, UInt32) | Creates a new DataFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Method is not implemented. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SampleIndex | Gets or sets the sample index of this DataFrame.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the F-NET frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Overload List
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame, UInt32) | Creates a new DataFrame from specified parameters.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Creates a new DataFrame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> DataFrame
GSF.PhasorProtocols.FNET.DataFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
DataFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an F-NET data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.FNET Namespace


DataFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrame Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrame
GSF.PhasorProtocols.FNET.DataFrame = function(info, context);
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.FNET Namespace


DataFrame Constructor (Ticks, ConfigurationFrame, UInt32)

Grid Solutions Framework DataFrame Constructor (Ticks, ConfigurationFrame, UInt32)
Creates a new DataFrame from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame configurationFrame,
    uint sampleIndex
)
Public Sub New (
    timestamp As Ticks,
    configurationFrame As ConfigurationFrame,
    sampleIndex As UInteger
)
new :
        timestamp : Ticks *
        configurationFrame : ConfigurationFrame *
        sampleIndex : uint32 -> DataFrame
GSF.PhasorProtocols.FNET.DataFrame = function(timestamp, configurationFrame, sampleIndex);
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame^ configurationFrame,
    unsigned int sampleIndex
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame
Type: GSF.PhasorProtocols.FNETConfigurationFrame
The ConfigurationFrame associated with this DataFrame.
sampleIndex
Type: SystemUInt32
The sample index of this DataFrame.
Remarks
This constructor is used by a consumer to generate a F-NET data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.FNET Namespace


DataFrame Methods

Grid Solutions Framework DataFrame Methods

The DataFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Method is not implemented. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.CalculateChecksum Method

Grid Solutions Framework DataFrameCalculateChecksum Method
Method is not implemented.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Array of Bytes.
offset
Type: SystemInt32
An Int32 value for offset to read from.
length
Type: SystemInt32
An Int32 value for the bytes to read.

Return Value

Type: UInt16
An UInt16 as the checksum.
Exceptions
Exception | Condition
NotImplementedException | F-NET doesn't use checksums.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.ChecksumIsValid Method

Grid Solutions Framework DataFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
F-NET doesn't use checksums - this always returns true.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.GetObjectData Method

Grid Solutions Framework DataFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame Properties

Grid Solutions Framework DataFrame Properties

The DataFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SampleIndex | Gets or sets the sample index of this DataFrame.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the F-NET frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.Attributes Property

Grid Solutions Framework DataFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.Cells Property

Grid Solutions Framework DataFrameCells Property
Gets reference to the DataCellCollection for this DataFrame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
member Cells : DataCellCollection with get

function get_Cells();

public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.CommonHeader Property

Grid Solutions Framework DataFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.ConfigurationFrame Property

Grid Solutions Framework DataFrameConfigurationFrame Property
Gets or sets ConfigurationFrame associated with this DataFrame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
member ConfigurationFrame : ConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.SampleIndex Property

Grid Solutions Framework DataFrameSampleIndex Property
Gets or sets the sample index of this DataFrame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint SampleIndex { get; set; }
Public Property SampleIndex As UInteger
    Get
    Set
member SampleIndex : uint32 with get, set

function get_SampleIndex();
function set_SampleIndex(value);
public:
property unsigned int SampleIndex {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


DataFrame.TypeID Property

Grid Solutions Framework DataFrameTypeID Property
Gets the identifier that is used to identify the F-NET frame.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TypeID { get; }
Public ReadOnly Property TypeID As Integer
    Get
abstract TypeID : int with get
override TypeID : int with get
function get_TypeID();

public:
virtual property int TypeID {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.FNET Namespace


FrameParser Class

Grid Solutions Framework FrameParser Class
Represents a frame parser for a F-NET text based data stream that returns parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase Int32, ISupportSourceIdentifiableFrameImage SourceChannel, Int32
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, Int32, ISupportSourceIdentifiableFrameImage SourceChannel, Int32
GSF.PhasorProtocolsFrameParserBase Int32
GSF.PhasorProtocols.FNETFrameParser

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameParser : FrameParserBase<int>
Public Class FrameParser
    Inherits FrameParserBase(Of Integer)
type FrameParser =
    class
        inherit FrameParserBase<int>
    end
GSF.PhasorProtocols.FNET.FrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.FrameParser',
    GSF.PhasorProtocols.FrameParserBase`1);
public ref class FrameParser : public FrameParserBase<int>

The FrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | FrameParser | Creates a new FrameParser.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | FrameRate | Gets or sets the configured frame rate for the F-NET device.
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the F-NET device.
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if F-NET protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | StationName | Gets or sets the station name for the F-NET device.
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TimeOffset | Gets or sets time offset of F-NET device in Ticks.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a F-NET ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a F-NET DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


FrameParser Constructor

Grid Solutions Framework FrameParser Constructor
Creates a new FrameParser.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    bool trustHeaderLength = true,
    ushort frameRate = 10,
    LineFrequency nominalFrequency = LineFrequency.Hz60,
    long timeOffset = 110000000,
    string stationName = "F-NET Unit"
)
Public Sub New (
    Optional checkSumValidationFrameTypes As CheckSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    Optional trustHeaderLength As Boolean = true,
    Optional frameRate As UShort = 10,
    Optional nominalFrequency As LineFrequency = LineFrequency.Hz60,
    Optional timeOffset As Long = 110000000,
    Optional stationName As String = "F-NET Unit"
)
new :
        ?checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        ?trustHeaderLength : bool *
        ?frameRate : uint16 *
        ?nominalFrequency : LineFrequency *
        ?timeOffset : int64 *
        ?stationName : string
(* Defaults:
        let _checkSumValidationFrameTypes = defaultArg checkSumValidationFrameTypes CheckSumValidationFrameTypes.AllFrames
        let _trustHeaderLength = defaultArg trustHeaderLength true
        let _frameRate = defaultArg frameRate 10
        let _nominalFrequency = defaultArg nominalFrequency LineFrequency.Hz60
        let _timeOffset = defaultArg timeOffset 110000000
        let _stationName = defaultArg stationName "F-NET Unit"
*)
-> FrameParser
GSF.PhasorProtocols.FNET.FrameParser = function(checkSumValidationFrameTypes, trustHeaderLength, frameRate, nominalFrequency, timeOffset, stationName);
public:
FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes::AllFrames,
    bool trustHeaderLength = true,
    unsigned short frameRate = 10,
    LineFrequency nominalFrequency = LineFrequency::Hz60,
    long long timeOffset = 110000000,
    String^ stationName = L"F-NET Unit"
)

Parameters

checkSumValidationFrameTypes (Optional)
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength (Optional)
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
frameRate (Optional)
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame.
nominalFrequency (Optional)
Type: GSF.Units.EELineFrequency
The nominal LineFrequency of this ConfigurationFrame.
timeOffset (Optional)
Type: SystemInt64
The time offset of F-NET device in Ticks.
stationName (Optional)
Type: SystemString
The station name of the F-NET device.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser Fields

Grid Solutions Framework FrameParser Fields

The FrameParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser Methods

Grid Solutions Framework FrameParser Methods

The FrameParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame).

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.ParseCommonHeader Method

Grid Solutions Framework FrameParserParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<int> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of Integer)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<int>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<int>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<int>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader Int32
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Start the data parser.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

FrameParser Class
Start Overload
GSF.PhasorProtocols.FNET Namespace


FrameParser Properties

Grid Solutions Framework FrameParser Properties

The FrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | FrameRate | Gets or sets the configured frame rate for the F-NET device.
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the F-NET device.
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if F-NET protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | StationName | Gets or sets the station name for the F-NET device.
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TimeOffset | Gets or sets time offset of F-NET device in Ticks.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.ConfigurationFrame Property

Grid Solutions Framework FrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.ConnectionParameters Property

Grid Solutions Framework FrameParserConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set
override ConnectionParameters : IConnectionParameters with get, set
function get_ConnectionParameters();
function set_ConnectionParameters(value);
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}

Property Value

Type: IConnectionParameters

Implements

IFrameParserConnectionParameters
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.FrameRate Property

Grid Solutions Framework FrameParserFrameRate Property
Gets or sets the configured frame rate for the F-NET device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort FrameRate { get; set; }
Public Property FrameRate As UShort
    Get
    Set
member FrameRate : uint16 with get, set

function get_FrameRate();
function set_FrameRate(value);
public:
property unsigned short FrameRate {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
Remarks
This is typically set to 10 frames per second.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.NominalFrequency Property

Grid Solutions Framework FrameParserNominalFrequency Property
Gets or sets the nominal LineFrequency of the F-NET device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LineFrequency NominalFrequency { get; set; }
Public Property NominalFrequency As LineFrequency
    Get
    Set
member NominalFrequency : LineFrequency with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}

Property Value

Type: LineFrequency
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework FrameParserProtocolUsesSyncBytes Property
Gets flag that determines if F-NET protocol parsing implementation uses synchronization bytes.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.StationName Property

Grid Solutions Framework FrameParserStationName Property
Gets or sets the station name for the F-NET device.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StationName { get; set; }
Public Property StationName As String
    Get
    Set
member StationName : string with get, set

function get_StationName();
function set_StationName(value);
public:
property String^ StationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.Status Property

Grid Solutions Framework FrameParserStatus Property
Gets current descriptive status of the FrameParser.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.TimeOffset Property

Grid Solutions Framework FrameParserTimeOffset Property
Gets or sets time offset of F-NET device in Ticks.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks TimeOffset { get; set; }
Public Property TimeOffset As Ticks
    Get
    Set
member TimeOffset : Ticks with get, set

function get_TimeOffset();
function set_TimeOffset(value);
public:
property Ticks TimeOffset {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks
F-NET devices normally report time in 11 seconds past real-time, this property defines the offset for this this artificial delay. Note that the parameter value is in ticks to allow a very high-resolution offset; 1 second = 10000000 ticks.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser Events

Grid Solutions Framework FrameParser Events

The FrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a F-NET ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a F-NET DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame Event
Occurs when a F-NET ConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
member ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<ConfigurationFrame>>,
    EventArgs<ConfigurationFrame>>

function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame
Remarks
Argument is the ConfigurationFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrameParser.ReceivedDataFrame Event

Grid Solutions Framework FrameParserReceivedDataFrame Event
Occurs when a F-NET DataFrame has been received.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
member ReceivedDataFrame : IEvent<EventHandler<EventArgs<DataFrame>>,
    EventArgs<DataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataFrame
Remarks
Argument is the DataFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents the F-NET implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.FNETFrequencyDefinition

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.FNET.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinition Constructor (IConfigurationCell)
Creates a new FrequencyDefinition.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinition
GSF.PhasorProtocols.FNET.FrequencyDefinition = function(parent);
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.FNET.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> FrequencyDefinition
GSF.PhasorProtocols.FNET.FrequencyDefinition = function(parent, label);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.FNETConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
label
Type: SystemString
The label of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.FNET Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.FNET Namespace


FrequencyValue Class

Grid Solutions Framework FrequencyValue Class
Represents the F-NET implementation of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.FNETFrequencyValue

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute>
Public Class FrequencyValue
    Inherits FrequencyValueBase
[<SerializableAttribute>]
type FrequencyValue =
    class
        inherit FrequencyValueBase
    end
GSF.PhasorProtocols.FNET.FrequencyValue = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.FrequencyValue',
    GSF.PhasorProtocols.FrequencyValueBase);
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase

The FrequencyValue type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from FrequencyValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


FrequencyValue Constructor

Grid Solutions Framework FrequencyValue Constructor
Overload List
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.FNET Namespace


FrequencyValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValue Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValue
GSF.PhasorProtocols.FNET.FrequencyValue = function(info, context);
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.FNET Namespace


FrequencyValue Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValue Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValue
GSF.PhasorProtocols.FNET.FrequencyValue = function(parent, frequencyDefinition);
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValue.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.FNET Namespace


FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New (
    parent As DataCell,
    frequencyDefinition As FrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : DataCell *
        frequencyDefinition : FrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValue
GSF.PhasorProtocols.FNET.FrequencyValue = function(parent, frequencyDefinition, frequency, dfdt);
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocols.FNETDataCell
The DataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocols.FNETFrequencyDefinition
The FrequencyDefinition associated with this FrequencyValue.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValue.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValue over time.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.FNET Namespace


FrequencyValue Methods

Grid Solutions Framework FrequencyValue Methods

The FrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from FrequencyValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.FNET Namespace


FrequencyValue Properties

Grid Solutions Framework FrequencyValue Properties

The FrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.FNET Namespace


FrequencyValue.Definition Property

Grid Solutions Framework FrequencyValueDefinition Property
Gets or sets the FrequencyDefinition associated with this FrequencyValue.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
abstract Definition : FrequencyDefinition with get, set
override Definition : FrequencyDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}

Property Value

Type: FrequencyDefinition
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.FNET Namespace


FrequencyValue.Parent Property

Grid Solutions Framework FrequencyValueParent Property
Gets or sets the DataCell parent of this FrequencyValue.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.FNET Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents the F-NET implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.FNETPhasorDefinition

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.FNET.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.FNET Namespace


PhasorDefinition Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinition Constructor (IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinition
GSF.PhasorProtocols.FNET.PhasorDefinition = function(parent);
public:
PhasorDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinition.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.FNET Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.FNET.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.FNET Namespace


PhasorDefinition Constructor (ConfigurationCell, String, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.FNET.PhasorDefinition = function(parent, label, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.FNETConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.FNETPhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.FNET Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.FNET Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.FNET Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.FNET Namespace


PhasorValue Class

Grid Solutions Framework PhasorValue Class
Represents the F-NET implementation of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.FNETPhasorValue

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute>
Public Class PhasorValue
    Inherits PhasorValueBase
[<SerializableAttribute>]
type PhasorValue =
    class
        inherit PhasorValueBase
    end
GSF.PhasorProtocols.FNET.PhasorValue = function();

Type.createClass(
    'GSF.PhasorProtocols.FNET.PhasorValue',
    GSF.PhasorProtocols.PhasorValueBase);
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase

The PhasorValue type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.FNET Namespace


PhasorValue Constructor

Grid Solutions Framework PhasorValue Constructor
Overload List
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.FNET Namespace


PhasorValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValue Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValue
GSF.PhasorProtocols.FNET.PhasorValue = function(info, context);
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.FNET Namespace


PhasorValue Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValue Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValue.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValue
GSF.PhasorProtocols.FNET.PhasorValue = function(parent, phasorDefinition);
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.FNET Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValue
GSF.PhasorProtocols.FNET.PhasorValue = function(parent, phasorDefinition, angle, magnitude);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocols.FNETDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.FNETPhasorDefinition
The PhasorDefinition associated with this PhasorValue.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.FNET Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        real : float *
        imaginary : float -> PhasorValue
GSF.PhasorProtocols.FNET.PhasorValue = function(parent, phasorDefinition, real, imaginary);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocols.FNETDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.FNETPhasorDefinition
The PhasorDefinition associated with this PhasorValue.
real
Type: SystemDouble
The real value of this PhasorValue.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.FNET Namespace


PhasorValue Methods

Grid Solutions Framework PhasorValue Methods

The PhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.FNET Namespace


PhasorValue Properties

Grid Solutions Framework PhasorValue Properties

The PhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.FNET Namespace


PhasorValue.Definition Property

Grid Solutions Framework PhasorValueDefinition Property
Gets or sets the PhasorDefinition associated with this PhasorValue.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
abstract Definition : PhasorDefinition with get, set
override Definition : PhasorDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}

Property Value

Type: PhasorDefinition
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.FNET Namespace


PhasorValue.Parent Property

Grid Solutions Framework PhasorValueParent Property
Gets or sets the DataCell parent of this PhasorValue.

Namespace: GSF.PhasorProtocols.FNET
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.FNET Namespace


GSF.PhasorProtocols.IEC61850_90_5 Namespace

Grid Solutions Framework GSF.PhasorProtocols.IEC61850_90_5 Namespace
Contains an implementation of the phasor classes used to parse or generate a stream of data in the IEC 61850-90-5-2005 standard format.
Classes
 | Class | Description
Public class | AnalogDefinition | Represents the IEC 61850-90-5 implementation of an IAnalogDefinition.
Public class | AnalogValue | Represents the IEC 61850-90-5 implementation of an IAnalogValue.
Public class | CommandFrame | Represents the IEC 61850-90-5 implementation of a ICommandFrame that can be sent or received.
Public class | Common | Common IEC 61850-90-5 declarations and functions.
Public class | CommonFrameHeader | Represents the common header for all IEC 61850-90-5 frames of data.
Public class | ConfigurationCell | Represents the IEC 61850-90-5 implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a IEC 61850-90-5 implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame | Represents the IEC 61850-90-5 implementation of a IConfigurationFrame that can be sent or received.
Public class | ConnectionParameters | Represents the extra connection parameters available for a connection to an IEC 61850-90-5 stream.
Public class | DataCell | Represents the IEC 61850-90-5 implementation of a IDataCell that can be sent or received.
Public class | DataCellCollection | Represents a IEC 61850-90-5 implementation of a collection of IDataCell objects.
Public class | DataFrame | Represents the IEC 61850-90-5 implementation of a IDataFrame that can be sent or received.
Public class | DigitalDefinition | Represents the IEC 61850-90-5 implementation of a IDigitalDefinition.
Public class | DigitalValue | Represents the IEC 61850-90-5 implementation of a IDigitalValue.
Public class | FrameParser | Represents a frame parser for an IEC 61850-90-5 binary data stream and returns parsed data via events.
Public class | FrequencyDefinition | Represents the IEC 61850-90-5 implementation of a IFrequencyDefinition.
Public class | FrequencyValue | Represents the IEC 61850-90-5 implementation of a IFrequencyValue.
Public class | PhasorDefinition | Represents the IEC 61850-90-5 implementation of a IPhasorDefinition.
Public class | PhasorValue | Represents the IEC 61850-90-5 implementation of a IPhasorValue.
Enumerations
 | Enumeration | Description
Public enumeration | DraftRevision | Protocol draft revision numbers enumeration.
Public enumeration | FormatFlags | Data format flags enumeration.
Public enumeration | FrameType | IEC 61850-90-5 frame types enumeration.
Public enumeration | SampledValueTag | Sampled value tags.
Public enumeration | SecurityAlgorithm | IEC 61850-90-5 security algorithm.
Public enumeration | SessionType | IEC 61850-90-5 session types.
Public enumeration | SignatureAlgorithm | IEC 61850-90-5 signature algorithm.
Public enumeration | StatusFlags | Status flags enumeration.
Public enumeration | TimeQualityFlags | Time quality flags enumeration.
Public enumeration | TimeQualityIndicatorCode | Time quality indicator code enumeration.
Public enumeration | TriggerReason | Trigger reason enumeration.
Public enumeration | UnlockedTime | Unlocked time enumeration.


AnalogDefinition Class

Grid Solutions Framework AnalogDefinition Class
Represents the IEC 61850-90-5 implementation of an IAnalogDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsAnalogDefinitionBase
GSF.PhasorProtocols.IEC61850_90_5AnalogDefinition

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogDefinition : AnalogDefinitionBase
<SerializableAttribute>
Public Class AnalogDefinition
    Inherits AnalogDefinitionBase
[<SerializableAttribute>]
type AnalogDefinition =
    class
        inherit AnalogDefinitionBase
    end
GSF.PhasorProtocols.IEC61850_90_5.AnalogDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.AnalogDefinition',
    GSF.PhasorProtocols.AnalogDefinitionBase);
[SerializableAttribute]
public ref class AnalogDefinition : public AnalogDefinitionBase

The AnalogDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogDefinition Constructor

Grid Solutions Framework AnalogDefinition Constructor
Overload List
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogDefinition Constructor (IConfigurationCell)

Grid Solutions Framework AnalogDefinition Constructor (IConfigurationCell)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> AnalogDefinition
GSF.PhasorProtocols.IEC61850_90_5.AnalogDefinition = function(parent);
public:
AnalogDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogDefinition
GSF.PhasorProtocols.IEC61850_90_5.AnalogDefinition = function(info, context);
protected:
AnalogDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogDefinition Constructor (ConfigurationCell, String, UInt32, Double, AnalogType)

Grid Solutions Framework AnalogDefinition Constructor (ConfigurationCell, String, UInt32, Double, AnalogType)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    AnalogType type
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As AnalogType
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : AnalogType -> AnalogDefinition
GSF.PhasorProtocols.IEC61850_90_5.AnalogDefinition = function(parent, label, scale, offset, type);
public:
AnalogDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    AnalogType type
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationCell
The ConfigurationCell parent of this AnalogDefinition.
label
Type: SystemString
The label of this AnalogDefinition.
scale
Type: SystemUInt32
The integer scaling value of this AnalogDefinition.
offset
Type: SystemDouble
The offset of this AnalogDefinition.
type
Type: GSF.PhasorProtocolsAnalogType
The AnalogType of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogDefinition Methods

Grid Solutions Framework AnalogDefinition Methods

The AnalogDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogDefinition Properties

Grid Solutions Framework AnalogDefinition Properties

The AnalogDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogDefinition.Parent Property

Grid Solutions Framework AnalogDefinitionParent Property
Gets or sets the ConfigurationCell parent of this AnalogDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue Class

Grid Solutions Framework AnalogValue Class
Represents the IEC 61850-90-5 implementation of an IAnalogValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IAnalogDefinition
GSF.PhasorProtocolsAnalogValueBase
GSF.PhasorProtocols.IEC61850_90_5AnalogValue

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogValue : AnalogValueBase
<SerializableAttribute>
Public Class AnalogValue
    Inherits AnalogValueBase
[<SerializableAttribute>]
type AnalogValue =
    class
        inherit AnalogValueBase
    end
GSF.PhasorProtocols.IEC61850_90_5.AnalogValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.AnalogValue',
    GSF.PhasorProtocols.AnalogValueBase);
[SerializableAttribute]
public ref class AnalogValue : public AnalogValueBase

The AnalogValue type exposes the following members.

Constructors
 | Name | Description
Protected method | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
Public method | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
Public method | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from AnalogValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this AnalogValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue Constructor

Grid Solutions Framework AnalogValue Constructor
Overload List
 | Name | Description
Protected method | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
Public method | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
Public method | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogValue Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogValue
GSF.PhasorProtocols.IEC61850_90_5.AnalogValue = function(info, context);
protected:
AnalogValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue Constructor (IDataCell, IAnalogDefinition)

Grid Solutions Framework AnalogValue Constructor (IDataCell, IAnalogDefinition)
Creates a new AnalogValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogValue(
    IDataCell parent,
    IAnalogDefinition analogDefinition
)
Public Sub New (
    parent As IDataCell,
    analogDefinition As IAnalogDefinition
)
new :
        parent : IDataCell *
        analogDefinition : IAnalogDefinition -> AnalogValue
GSF.PhasorProtocols.IEC61850_90_5.AnalogValue = function(parent, analogDefinition);
public:
AnalogValue(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this AnalogValue.
analogDefinition
Type: GSF.PhasorProtocolsIAnalogDefinition
The IAnalogDefinition associated with this AnalogValue.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue Constructor (DataCell, AnalogDefinition, Double)

Grid Solutions Framework AnalogValue Constructor (DataCell, AnalogDefinition, Double)
Creates a new AnalogValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogValue(
    DataCell parent,
    AnalogDefinition analogDefinition,
    double value
)
Public Sub New (
    parent As DataCell,
    analogDefinition As AnalogDefinition,
    value As Double
)
new :
        parent : DataCell *
        analogDefinition : AnalogDefinition *
        value : float -> AnalogValue
GSF.PhasorProtocols.IEC61850_90_5.AnalogValue = function(parent, analogDefinition, value);
public:
AnalogValue(
    DataCell^ parent,
    AnalogDefinition^ analogDefinition,
    double value
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5DataCell
The DataCell parent of this AnalogValue.
analogDefinition
Type: GSF.PhasorProtocols.IEC61850_90_5AnalogDefinition
The AnalogDefinition associated with this AnalogValue.
value
Type: SystemDouble
The floating point value that represents this AnalogValue.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue Methods

Grid Solutions Framework AnalogValue Methods

The AnalogValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from AnalogValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue Properties

Grid Solutions Framework AnalogValue Properties

The AnalogValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this AnalogValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue.Definition Property

Grid Solutions Framework AnalogValueDefinition Property
Gets or sets the AnalogDefinition associated with this AnalogValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AnalogDefinition Definition { get; set; }
Public Overridable Property Definition As AnalogDefinition
    Get
    Set
abstract Definition : AnalogDefinition with get, set
override Definition : AnalogDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property AnalogDefinition^ Definition {
    AnalogDefinition^ get ();
    void set (AnalogDefinition^ value);
}

Property Value

Type: AnalogDefinition
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


AnalogValue.Parent Property

Grid Solutions Framework AnalogValueParent Property
Gets or sets the DataCell parent of this AnalogValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame Class

Grid Solutions Framework CommandFrame Class
Represents the IEC 61850-90-5 implementation of a ICommandFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase ICommandCell
GSF.PhasorProtocolsCommandFrameBase
GSF.PhasorProtocols.IEC61850_90_5CommandFrame

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute>
Public Class CommandFrame
    Inherits CommandFrameBase
[<SerializableAttribute>]
type CommandFrame =
    class
        inherit CommandFrameBase
    end
GSF.PhasorProtocols.IEC61850_90_5.CommandFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.CommandFrame',
    GSF.PhasorProtocols.CommandFrameBase);
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase

The CommandFrame type exposes the following members.

Constructors
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Public method | CommandFrame(UInt16, DeviceCommand, Byte) | Creates a new CommandFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEC 61850-90-5 protocol version of this CommandFrame.
Top
Remarks
IEC 61850-90-5 command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImageTTypeIdentifier for automated frame parsing. This class exposes a constructor that accepts a binary image in order to manually parse a command frame.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame Constructor

Grid Solutions Framework CommandFrame Constructor
Overload List
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Public method | CommandFrame(UInt16, DeviceCommand, Byte) | Creates a new CommandFrame from specified parameters.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandFrame Constructor (SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandFrame
GSF.PhasorProtocols.IEC61850_90_5.CommandFrame = function(info, context);
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame Constructor (Byte[], Int32, Int32)

Grid Solutions Framework CommandFrame Constructor (Byte, Int32, Int32)
Creates a new CommandFrame from the given buffer.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> CommandFrame
GSF.PhasorProtocols.IEC61850_90_5.CommandFrame = function(buffer, startIndex, length);
public:
CommandFrame(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | length is not large enough to parse frame.
Remarks
This constructor is used by a consumer to parse a received IEC 61850-90-5 command frame. Typically command frames are sent to a device. This constructor would used if this code was being used inside of a phasor measurement device.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame Constructor (UInt16, DeviceCommand, Byte)

Grid Solutions Framework CommandFrame Constructor (UInt16, DeviceCommand, Byte)
Creates a new CommandFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    ushort idCode,
    DeviceCommand command,
    byte version
)
Public Sub New (
    idCode As UShort,
    command As DeviceCommand,
    version As Byte
)
new :
        idCode : uint16 *
        command : DeviceCommand *
        version : byte -> CommandFrame
GSF.PhasorProtocols.IEC61850_90_5.CommandFrame = function(idCode, command, version);
public:
CommandFrame(
    unsigned short idCode,
    DeviceCommand command,
    unsigned char version
)

Parameters

idCode
Type: SystemUInt16
The ID code of this CommandFrame.
command
Type: GSF.PhasorProtocolsDeviceCommand
The DeviceCommand for this CommandFrame.
version
Type: SystemByte
IEC 61850-90-5 revision number.
Remarks
This constructor is used by a consumer to generate an IEC 61850-90-5 command frame.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame Methods

Grid Solutions Framework CommandFrame Methods

The CommandFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.CalculateChecksum Method

Grid Solutions Framework CommandFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.GetObjectData Method

Grid Solutions Framework CommandFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.ParseHeaderImage Method

Grid Solutions Framework CommandFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame Properties

Grid Solutions Framework CommandFrame Properties

The CommandFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEC 61850-90-5 protocol version of this CommandFrame.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.Attributes Property

Grid Solutions Framework CommandFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.CommonHeader Property

Grid Solutions Framework CommandFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.HeaderImage Property

Grid Solutions Framework CommandFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.HeaderLength Property

Grid Solutions Framework CommandFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.Timestamp Property

Grid Solutions Framework CommandFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommandFrame.Version Property

Grid Solutions Framework CommandFrameVersion Property
Gets the IEC 61850-90-5 protocol version of this CommandFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
member Version : byte with get, set

function get_Version();
function set_Version(value);
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common Class

Grid Solutions Framework Common Class
Common IEC 61850-90-5 declarations and functions.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEC61850_90_5Common

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
<ExtensionAttribute>
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.IEC61850_90_5.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.Common');
[ExtensionAttribute]
public ref class Common abstract sealed

The Common type exposes the following members.

Methods
Name | Description
EncodeTagLength(UInt16, Byte, Int32) | Encodes sample value tag length (currently limited to 16-bits).
EncodeTagLength(UInt16, SampledValueTag, Byte, Int32) | Encodes sampled value tag with only a 16-bit length.
EncodeTagValue(Byte, SampledValueTag, Byte, Int32) | Encodes byte based sampled value tag.
EncodeTagValue(String, SampledValueTag, Byte, Int32) | Encodes string based sampled value tag.
EncodeTagValueT(T, SampledValueTag, Byte, Int32) | Encodes primitive type sampled value tag.
ParseByteTag | Validates and parses byte length sample value tag.
ParseStringTag | Validates and parses string sample value tag.
ParseTagLength | Gets decoded sample value tag length (currently limited to 16-bits).
ParseUInt16Tag | Validates and parses 2-byte length sample value tag.
ParseUInt24Tag | Validates and parses 3-byte length sample value tag.
ParseUInt32Tag | Validates and parses 4-byte length sample value tag.
ParseUInt64Tag | Validates and parses 8-byte length sample value tag.
ValidateTag | Validates sample value tag exists and skips past it.
Top
Fields
Name | Description
CltpTag | Marker for a connectionless transport protocol tag in IEC 61850-90-5 data frames.
DummyKey | Temporary key used by IEC 61850-90-5 draft implementations.
KeySize | Size of keys.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
SessionHeaderSize | Common session header size.
Timebase | Timebase used by IEC 61850-90-5 protocol implementation.
TimeQualityFlagsMask | Time quality flags mask.
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
CltpTag | Marker for a connectionless transport protocol tag in IEC 61850-90-5 data frames.
DummyKey | Temporary key used by IEC 61850-90-5 draft implementations.
KeySize | Size of keys.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
SessionHeaderSize | Common session header size.
Timebase | Timebase used by IEC 61850-90-5 protocol implementation.
TimeQualityFlagsMask | Time quality flags mask.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.CltpTag Field

Grid Solutions Framework CommonCltpTag Field
Marker for a connectionless transport protocol tag in IEC 61850-90-5 data frames.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte CltpTag
Public Const CltpTag As Byte
static val mutable CltpTag: byte
var GSF.PhasorProtocols.IEC61850_90_5.Common.CltpTag
public:
literal unsigned char CltpTag

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.DummyKey Field

Grid Solutions Framework CommonDummyKey Field
Temporary key used by IEC 61850-90-5 draft implementations.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] DummyKey
Public Shared DummyKey As Byte()
static val mutable DummyKey: byte[]
var GSF.PhasorProtocols.IEC61850_90_5.Common.DummyKey
public:
static array<unsigned char>^ DummyKey

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.KeySize Field

Grid Solutions Framework CommonKeySize Field
Size of keys.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int KeySize
Public Const KeySize As Integer
static val mutable KeySize: int
var GSF.PhasorProtocols.IEC61850_90_5.Common.KeySize
public:
literal int KeySize

Field Value

Type: Int32
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.MaximumAnalogValues Field

Grid Solutions Framework CommonMaximumAnalogValues Field
Absolute maximum number of possible analog values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
static val mutable MaximumAnalogValues: uint16
var GSF.PhasorProtocols.IEC61850_90_5.Common.MaximumAnalogValues
public:
literal unsigned short MaximumAnalogValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.MaximumDataLength Field

Grid Solutions Framework CommonMaximumDataLength Field
Absolute maximum data length (in bytes) that could fit into any frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
static val mutable MaximumDataLength: uint16
var GSF.PhasorProtocols.IEC61850_90_5.Common.MaximumDataLength
public:
literal unsigned short MaximumDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.MaximumDigitalValues Field

Grid Solutions Framework CommonMaximumDigitalValues Field
Absolute maximum number of possible digital values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
static val mutable MaximumDigitalValues: uint16
var GSF.PhasorProtocols.IEC61850_90_5.Common.MaximumDigitalValues
public:
literal unsigned short MaximumDigitalValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.MaximumExtendedDataLength Field

Grid Solutions Framework CommonMaximumExtendedDataLength Field
Absolute maximum number of bytes of extended data that could fit into a command frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumExtendedDataLength
Public Const MaximumExtendedDataLength As UShort
static val mutable MaximumExtendedDataLength: uint16
var GSF.PhasorProtocols.IEC61850_90_5.Common.MaximumExtendedDataLength
public:
literal unsigned short MaximumExtendedDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.MaximumPhasorValues Field

Grid Solutions Framework CommonMaximumPhasorValues Field
Absolute maximum number of possible phasor values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
static val mutable MaximumPhasorValues: uint16
var GSF.PhasorProtocols.IEC61850_90_5.Common.MaximumPhasorValues
public:
literal unsigned short MaximumPhasorValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.SessionHeaderSize Field

Grid Solutions Framework CommonSessionHeaderSize Field
Common session header size.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte SessionHeaderSize
Public Const SessionHeaderSize As Byte
static val mutable SessionHeaderSize: byte
var GSF.PhasorProtocols.IEC61850_90_5.Common.SessionHeaderSize
public:
literal unsigned char SessionHeaderSize

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.Timebase Field

Grid Solutions Framework CommonTimebase Field
Timebase used by IEC 61850-90-5 protocol implementation.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint Timebase
Public Const Timebase As UInteger
static val mutable Timebase: uint32
var GSF.PhasorProtocols.IEC61850_90_5.Common.Timebase
public:
literal unsigned int Timebase

Field Value

Type: UInt32
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.TimeQualityFlagsMask Field

Grid Solutions Framework CommonTimeQualityFlagsMask Field
Time quality flags mask.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TimeQualityFlagsMask
Public Const TimeQualityFlagsMask As UInteger
static val mutable TimeQualityFlagsMask: uint32
var GSF.PhasorProtocols.IEC61850_90_5.Common.TimeQualityFlagsMask
public:
literal unsigned int TimeQualityFlagsMask

Field Value

Type: UInt32
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common Methods

Grid Solutions Framework Common Methods

The Common type exposes the following members.

Methods
Name | Description
EncodeTagLength(UInt16, Byte, Int32) | Encodes sample value tag length (currently limited to 16-bits).
EncodeTagLength(UInt16, SampledValueTag, Byte, Int32) | Encodes sampled value tag with only a 16-bit length.
EncodeTagValue(Byte, SampledValueTag, Byte, Int32) | Encodes byte based sampled value tag.
EncodeTagValue(String, SampledValueTag, Byte, Int32) | Encodes string based sampled value tag.
EncodeTagValueT(T, SampledValueTag, Byte, Int32) | Encodes primitive type sampled value tag.
ParseByteTag | Validates and parses byte length sample value tag.
ParseStringTag | Validates and parses string sample value tag.
ParseTagLength | Gets decoded sample value tag length (currently limited to 16-bits).
ParseUInt16Tag | Validates and parses 2-byte length sample value tag.
ParseUInt24Tag | Validates and parses 3-byte length sample value tag.
ParseUInt32Tag | Validates and parses 4-byte length sample value tag.
ParseUInt64Tag | Validates and parses 8-byte length sample value tag.
ValidateTag | Validates sample value tag exists and skips past it.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.EncodeTagLength Method

Grid Solutions Framework CommonEncodeTagLength Method
Overload List
Name | Description
EncodeTagLength(UInt16, Byte, Int32) | Encodes sample value tag length (currently limited to 16-bits).
EncodeTagLength(UInt16, SampledValueTag, Byte, Int32) | Encodes sampled value tag with only a 16-bit length.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.EncodeTagLength Method (UInt16, Byte[], Int32)

Grid Solutions Framework CommonEncodeTagLength Method (UInt16, Byte, Int32)
Encodes sample value tag length (currently limited to 16-bits).

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EncodeTagLength(
    this ushort length,
    byte[] buffer,
    ref int index
)
<ExtensionAttribute>
Public Shared Sub EncodeTagLength (
    length As UShort,
    buffer As Byte(),
    ByRef index As Integer
)
static member EncodeTagLength :
        length : uint16 *
        buffer : byte[] *
        index : int byref -> unit

GSF.PhasorProtocols.IEC61850_90_5.Common.EncodeTagLength = function(length, buffer, index);
public:
[ExtensionAttribute]
static void EncodeTagLength(
    unsigned short length,
    array<unsigned char>^ buffer,
    int% index
)

Parameters

length
Type: SystemUInt16
Sample value tag length.
buffer
Type: SystemByte
Buffer to hold encoded sampled value tag length.
index
Type: SystemInt32
Start index of buffer where tag length encoding begins - will be auto-incremented.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
EncodeTagLength Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.EncodeTagLength Method (UInt16, SampledValueTag, Byte[], Int32)

Grid Solutions Framework CommonEncodeTagLength Method (UInt16, SampledValueTag, Byte, Int32)
Encodes sampled value tag with only a 16-bit length.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EncodeTagLength(
    this ushort length,
    SampledValueTag tag,
    byte[] buffer,
    ref int index
)
<ExtensionAttribute>
Public Shared Sub EncodeTagLength (
    length As UShort,
    tag As SampledValueTag,
    buffer As Byte(),
    ByRef index As Integer
)
static member EncodeTagLength :
        length : uint16 *
        tag : SampledValueTag *
        buffer : byte[] *
        index : int byref -> unit

GSF.PhasorProtocols.IEC61850_90_5.Common.EncodeTagLength = function(length, tag, buffer, index);
public:
[ExtensionAttribute]
static void EncodeTagLength(
    unsigned short length,
    SampledValueTag tag,
    array<unsigned char>^ buffer,
    int% index
)

Parameters

length
Type: SystemUInt16
Value to encode.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to encode.
buffer
Type: SystemByte
Buffer to hold encoded sampled value.
index
Type: SystemInt32
Start index of buffer where tag will begin - will be auto-incremented.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type UInt16. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
EncodeTagLength Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.EncodeTagValue Method

Grid Solutions Framework CommonEncodeTagValue Method
Overload List
Name | Description
EncodeTagValue(Byte, SampledValueTag, Byte, Int32) | Encodes byte based sampled value tag.
EncodeTagValue(String, SampledValueTag, Byte, Int32) | Encodes string based sampled value tag.
EncodeTagValueT(T, SampledValueTag, Byte, Int32) | Encodes primitive type sampled value tag.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.EncodeTagValue Method (Byte, SampledValueTag, Byte[], Int32)

Grid Solutions Framework CommonEncodeTagValue Method (Byte, SampledValueTag, Byte, Int32)
Encodes byte based sampled value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EncodeTagValue(
    this byte value,
    SampledValueTag tag,
    byte[] buffer,
    ref int index
)
<ExtensionAttribute>
Public Shared Sub EncodeTagValue (
    value As Byte,
    tag As SampledValueTag,
    buffer As Byte(),
    ByRef index As Integer
)
static member EncodeTagValue :
        value : byte *
        tag : SampledValueTag *
        buffer : byte[] *
        index : int byref -> unit

GSF.PhasorProtocols.IEC61850_90_5.Common.EncodeTagValue = function(value, tag, buffer, index);
public:
[ExtensionAttribute]
static void EncodeTagValue(
    unsigned char value,
    SampledValueTag tag,
    array<unsigned char>^ buffer,
    int% index
)

Parameters

value
Type: SystemByte
Value to encode.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to encode.
buffer
Type: SystemByte
Buffer to hold encoded sampled value.
index
Type: SystemInt32
Start index of buffer where tag will begin - will be auto-incremented.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Byte. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
EncodeTagValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.EncodeTagValue Method (String, SampledValueTag, Byte[], Int32)

Grid Solutions Framework CommonEncodeTagValue Method (String, SampledValueTag, Byte, Int32)
Encodes string based sampled value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EncodeTagValue(
    this string value,
    SampledValueTag tag,
    byte[] buffer,
    ref int index
)
<ExtensionAttribute>
Public Shared Sub EncodeTagValue (
    value As String,
    tag As SampledValueTag,
    buffer As Byte(),
    ByRef index As Integer
)
static member EncodeTagValue :
        value : string *
        tag : SampledValueTag *
        buffer : byte[] *
        index : int byref -> unit

GSF.PhasorProtocols.IEC61850_90_5.Common.EncodeTagValue = function(value, tag, buffer, index);
public:
[ExtensionAttribute]
static void EncodeTagValue(
    String^ value,
    SampledValueTag tag,
    array<unsigned char>^ buffer,
    int% index
)

Parameters

value
Type: SystemString
String to encode - null string will be encoded as empty string.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to encode.
buffer
Type: SystemByte
Buffer to hold encoded sampled value.
index
Type: SystemInt32
Start index of buffer where tag will begin - will be auto-incremented.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
EncodeTagValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.EncodeTagValue(T) Method (T, SampledValueTag, Byte[], Int32)

Grid Solutions Framework CommonEncodeTagValueT Method (T, SampledValueTag, Byte, Int32)
Encodes primitive type sampled value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EncodeTagValue<T>(
    this T value,
    SampledValueTag tag,
    byte[] buffer,
    ref int index
)
where T : struct, new(), IConvertible

<ExtensionAttribute>
Public Shared Sub EncodeTagValue(Of T As {Structure, New, IConvertible}) (
    value As T,
    tag As SampledValueTag,
    buffer As Byte(),
    ByRef index As Integer
)
static member EncodeTagValue :
        value : 'T *
        tag : SampledValueTag *
        buffer : byte[] *
        index : int byref -> unit  when 'T : struct, new() and IConvertible

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : value class, gcnew(), IConvertible
static void EncodeTagValue(
    T value,
    SampledValueTag tag,
    array<unsigned char>^ buffer,
    int% index
)

Parameters

value
Type: T
Value to encode.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to encode.
buffer
Type: SystemByte
Buffer to hold encoded sampled value.
index
Type: SystemInt32
Start index of buffer where tag will begin - will be auto-incremented.

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.EncodeTagValue``1(``0,GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Byte[],System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
EncodeTagValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ParseByteTag Method

Grid Solutions Framework CommonParseByteTag Method
Validates and parses byte length sample value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte ParseByteTag(
    this byte[] buffer,
    SampledValueTag tag,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ParseByteTag (
    buffer As Byte(),
    tag As SampledValueTag,
    ByRef index As Integer
) As Byte
static member ParseByteTag :
        buffer : byte[] *
        tag : SampledValueTag *
        index : int byref -> byte

GSF.PhasorProtocols.IEC61850_90_5.Common.ParseByteTag = function(buffer, tag, index);
public:
[ExtensionAttribute]
static unsigned char ParseByteTag(
    array<unsigned char>^ buffer,
    SampledValueTag tag,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to parse.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: Byte

[Missing <returns> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.ParseByteTag(System.Byte[],GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ParseStringTag Method

Grid Solutions Framework CommonParseStringTag Method
Validates and parses string sample value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ParseStringTag(
    this byte[] buffer,
    SampledValueTag tag,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ParseStringTag (
    buffer As Byte(),
    tag As SampledValueTag,
    ByRef index As Integer
) As String
static member ParseStringTag :
        buffer : byte[] *
        tag : SampledValueTag *
        index : int byref -> string

GSF.PhasorProtocols.IEC61850_90_5.Common.ParseStringTag = function(buffer, tag, index);
public:
[ExtensionAttribute]
static String^ ParseStringTag(
    array<unsigned char>^ buffer,
    SampledValueTag tag,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to parse.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.ParseStringTag(System.Byte[],GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ParseTagLength Method

Grid Solutions Framework CommonParseTagLength Method
Gets decoded sample value tag length (currently limited to 16-bits).

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ParseTagLength(
    this byte[] buffer,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ParseTagLength (
    buffer As Byte(),
    ByRef index As Integer
) As Integer
static member ParseTagLength :
        buffer : byte[] *
        index : int byref -> int

GSF.PhasorProtocols.IEC61850_90_5.Common.ParseTagLength = function(buffer, index);
public:
[ExtensionAttribute]
static int ParseTagLength(
    array<unsigned char>^ buffer,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value tag length.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: Int32
Decoded sample value tag length.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ParseUInt16Tag Method

Grid Solutions Framework CommonParseUInt16Tag Method
Validates and parses 2-byte length sample value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort ParseUInt16Tag(
    this byte[] buffer,
    SampledValueTag tag,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ParseUInt16Tag (
    buffer As Byte(),
    tag As SampledValueTag,
    ByRef index As Integer
) As UShort
static member ParseUInt16Tag :
        buffer : byte[] *
        tag : SampledValueTag *
        index : int byref -> uint16

GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt16Tag = function(buffer, tag, index);
public:
[ExtensionAttribute]
static unsigned short ParseUInt16Tag(
    array<unsigned char>^ buffer,
    SampledValueTag tag,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to parse.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: UInt16

[Missing <returns> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt16Tag(System.Byte[],GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ParseUInt24Tag Method

Grid Solutions Framework CommonParseUInt24Tag Method
Validates and parses 3-byte length sample value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 ParseUInt24Tag(
    this byte[] buffer,
    SampledValueTag tag,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ParseUInt24Tag (
    buffer As Byte(),
    tag As SampledValueTag,
    ByRef index As Integer
) As UInt24
static member ParseUInt24Tag :
        buffer : byte[] *
        tag : SampledValueTag *
        index : int byref -> UInt24

GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt24Tag = function(buffer, tag, index);
public:
[ExtensionAttribute]
static UInt24 ParseUInt24Tag(
    array<unsigned char>^ buffer,
    SampledValueTag tag,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to parse.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: UInt24

[Missing <returns> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt24Tag(System.Byte[],GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ParseUInt32Tag Method

Grid Solutions Framework CommonParseUInt32Tag Method
Validates and parses 4-byte length sample value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint ParseUInt32Tag(
    this byte[] buffer,
    SampledValueTag tag,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ParseUInt32Tag (
    buffer As Byte(),
    tag As SampledValueTag,
    ByRef index As Integer
) As UInteger
static member ParseUInt32Tag :
        buffer : byte[] *
        tag : SampledValueTag *
        index : int byref -> uint32

GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt32Tag = function(buffer, tag, index);
public:
[ExtensionAttribute]
static unsigned int ParseUInt32Tag(
    array<unsigned char>^ buffer,
    SampledValueTag tag,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to parse.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: UInt32

[Missing <returns> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt32Tag(System.Byte[],GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ParseUInt64Tag Method

Grid Solutions Framework CommonParseUInt64Tag Method
Validates and parses 8-byte length sample value tag.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong ParseUInt64Tag(
    this byte[] buffer,
    SampledValueTag tag,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ParseUInt64Tag (
    buffer As Byte(),
    tag As SampledValueTag,
    ByRef index As Integer
) As ULong
static member ParseUInt64Tag :
        buffer : byte[] *
        tag : SampledValueTag *
        index : int byref -> uint64

GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt64Tag = function(buffer, tag, index);
public:
[ExtensionAttribute]
static unsigned long long ParseUInt64Tag(
    array<unsigned char>^ buffer,
    SampledValueTag tag,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to parse.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: UInt64

[Missing <returns> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.ParseUInt64Tag(System.Byte[],GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


Common.ValidateTag Method

Grid Solutions Framework CommonValidateTag Method
Validates sample value tag exists and skips past it.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int ValidateTag(
    this byte[] buffer,
    SampledValueTag tag,
    ref int index
)
<ExtensionAttribute>
Public Shared Function ValidateTag (
    buffer As Byte(),
    tag As SampledValueTag,
    ByRef index As Integer
) As Integer
static member ValidateTag :
        buffer : byte[] *
        tag : SampledValueTag *
        index : int byref -> int

GSF.PhasorProtocols.IEC61850_90_5.Common.ValidateTag = function(buffer, tag, index);
public:
[ExtensionAttribute]
static int ValidateTag(
    array<unsigned char>^ buffer,
    SampledValueTag tag,
    int% index
)

Parameters

buffer
Type: SystemByte
Buffer containing sampled value tag length.
tag
Type: GSF.PhasorProtocols.IEC61850_90_5SampledValueTag
Sampled value tag to validate.
index
Type: SystemInt32
Start index of buffer where tag length begins - will be auto-incremented.

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.PhasorProtocols.IEC61850_90_5.Common.ValidateTag(System.Byte[],GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag,System.Int32@)"]

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Common Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Class

Grid Solutions Framework CommonFrameHeader Class
Represents the common header for all IEC 61850-90-5 frames of data.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEC61850_90_5CommonFrameHeader

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
<SerializableAttribute>
Public Class CommonFrameHeader
    Implements ICommonHeader(Of FrameType), ISerializable
[<SerializableAttribute>]
type CommonFrameHeader =
    class
        interface ICommonHeader<FrameType>
        interface ISerializable
    end
GSF.PhasorProtocols.IEC61850_90_5.CommonFrameHeader = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.CommonFrameHeader',
    null,
    GSF.Parsing.ICommonHeader`1,
    ISerializable);
[SerializableAttribute]
public ref class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable

The CommonFrameHeader type exposes the following members.

Constructors
 | Name | Description
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(ConfigurationFrame, FrameType, UInt16, Ticks, String, Int32, UInt32) | Creates a new CommonFrameHeader from specified parameters.
Public method | CommonFrameHeader(ConfigurationFrame, Boolean, Boolean, Boolean, Boolean, Boolean, AngleFormat, Byte, Int32, Int32) | Creates a new CommonFrameHeader from given buffer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader for IEEE C37.118 frames.
IECFixedLength | Total fixed length of CommonFrameHeader for IEC 61850-90-5 data frames.
Top
Properties
 | Name | Description
Public property | AsduCount | Gets or sets number of ASDUs in this frame.
Public property | AsduLength | Gets or sets ASDU length in this frame.
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | ConfigurationFrame | Gets or sets current configuration frame.
Public property | ConfigurationRevision | Gets or sets configuration revision;
Public property | DataLength | Gets or sets the length of the data in the IEC 61850-90-5 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FractionOfSecond | Gets the IEC 61850-90-5 fraction of second.
Public property | FrameLength | Gets or sets the IEC 61850-90-5 frame length of this frame.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | GuessConfiguration | Gets or sets flag that determines if system should try to guess at a possible configuration given payload size.
Public property | IDCode | Gets or sets the IEC 61850-90-5 ID code of this frame.
Public property | IgnoreSampleSizeValidationFailures | Gets or sets flag that determines if system should ignore sample size validation errors.
Public property | IgnoreSignatureValidationFailures | Gets or sets flag that determines if system should ignore checksum signature validation errors.
Public property | KeyID | Gets or sets key ID - lookup into table of current keys.
Public property | Length | Gets the IEC 61850-90-5 frame header length.
Public property | MsvID | Gets or sets the MSVID to be used by IEC 61850-90-5 data frames.
Public property | PacketNumber | Gets or sets packet number of this frame.
Public property | ParseRedundantASDUs | Gets or sets flag that determines if system should expose redundantly parsed ASDUs.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects.
Public property | PublishFrame | Gets or sets delegate to method used to publish new frames.
Public property | SecondOfCentury | Gets the IEC 61850-90-5 second of century.
Public property | SecurityAlgorithm | Gets or sets security algorithm used by IEC61850-90-5 data frames.
Public property | SignatureAlgorithm | Gets or sets signature algorithm used by IEC61850-90-5 data frames.
Public property | SpduLength | Gets SPDU length.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | Timebase | Gets or sets the IEC 61850-90-5 resolution of fractional time stamps.
Public property | TimeQualityFlags | Gets or sets the IEC 61850-90-5 TimeQualityFlags.
Public property | TimeQualityIndicatorCode | Gets or sets the IEC 61850-90-5 TimeQualityIndicatorCode.
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets time as a UnixTimeTag representing seconds of current Timestamp.
Public property | TypeID | Gets or sets the IEC 61850-90-5 specific frame type of this frame.
Public property | UseETRConfiguration | Gets or sets flag that determines if system should find associated ETR file using MSVID with same name for configuration.
Public property | Version | Gets or sets the IEC 61850-90-5 version of this frame.
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Overload List
 | Name | Description
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(ConfigurationFrame, FrameType, UInt16, Ticks, String, Int32, UInt32) | Creates a new CommonFrameHeader from specified parameters.
Public method | CommonFrameHeader(ConfigurationFrame, Boolean, Boolean, Boolean, Boolean, Boolean, AngleFormat, Byte, Int32, Int32) | Creates a new CommonFrameHeader from given buffer.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommonFrameHeader Constructor (SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommonFrameHeader
GSF.PhasorProtocols.IEC61850_90_5.CommonFrameHeader = function(info, context);
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Constructor (ConfigurationFrame, FrameType, UInt16, Ticks, String, Int32, UInt32)

Grid Solutions Framework CommonFrameHeader Constructor (ConfigurationFrame, FrameType, UInt16, Ticks, String, Int32, UInt32)
Creates a new CommonFrameHeader from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    ConfigurationFrame configurationFrame,
    FrameType typeID,
    ushort idCode,
    Ticks timestamp,
    string msvID = null,
    int asduCount = 1,
    uint configurationRevision = 1
)
Public Sub New (
    configurationFrame As ConfigurationFrame,
    typeID As FrameType,
    idCode As UShort,
    timestamp As Ticks,
    Optional msvID As String = Nothing,
    Optional asduCount As Integer = 1,
    Optional configurationRevision As UInteger = 1
)
new :
        configurationFrame : ConfigurationFrame *
        typeID : FrameType *
        idCode : uint16 *
        timestamp : Ticks *
        ?msvID : string *
        ?asduCount : int *
        ?configurationRevision : uint32
(* Defaults:
        let _msvID = defaultArg msvID null
        let _asduCount = defaultArg asduCount 1
        let _configurationRevision = defaultArg configurationRevision 1
*)
-> CommonFrameHeader
GSF.PhasorProtocols.IEC61850_90_5.CommonFrameHeader = function(configurationFrame, typeID, idCode, timestamp, msvID, asduCount, configurationRevision);
public:
CommonFrameHeader(
    ConfigurationFrame^ configurationFrame,
    FrameType typeID,
    unsigned short idCode,
    Ticks timestamp,
    String^ msvID = nullptr,
    int asduCount = 1,
    unsigned int configurationRevision = 1
)

Parameters

configurationFrame
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationFrame
IEC 61850-90-5 ConfigurationFrame if available.
typeID
Type: GSF.PhasorProtocols.IEC61850_90_5FrameType
The IEC 61850-90-5 specific frame type of this frame.
idCode
Type: SystemUInt16
The ID code of this frame.
timestamp
Type: GSFTicks
The timestamp of this frame.
msvID (Optional)
Type: SystemString
MSVID to use for this frame, if any.
asduCount (Optional)
Type: SystemInt32
ASDU count.
configurationRevision (Optional)
Type: SystemUInt32
Configuration revision.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Constructor (ConfigurationFrame, Boolean, Boolean, Boolean, Boolean, Boolean, AngleFormat, Byte[], Int32, Int32)

Grid Solutions Framework CommonFrameHeader Constructor (ConfigurationFrame, Boolean, Boolean, Boolean, Boolean, Boolean, AngleFormat, Byte, Int32, Int32)
Creates a new CommonFrameHeader from given buffer.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    ConfigurationFrame configurationFrame,
    bool useETRConfiguration,
    bool guessConfiguration,
    bool parseRedundantASDUs,
    bool ignoreSignatureValidationFailures,
    bool ignoreSampleSizeValidationFailures,
    AngleFormat angleFormat,
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    configurationFrame As ConfigurationFrame,
    useETRConfiguration As Boolean,
    guessConfiguration As Boolean,
    parseRedundantASDUs As Boolean,
    ignoreSignatureValidationFailures As Boolean,
    ignoreSampleSizeValidationFailures As Boolean,
    angleFormat As AngleFormat,
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        configurationFrame : ConfigurationFrame *
        useETRConfiguration : bool *
        guessConfiguration : bool *
        parseRedundantASDUs : bool *
        ignoreSignatureValidationFailures : bool *
        ignoreSampleSizeValidationFailures : bool *
        angleFormat : AngleFormat *
        buffer : byte[] *
        startIndex : int *
        length : int -> CommonFrameHeader
GSF.PhasorProtocols.IEC61850_90_5.CommonFrameHeader = function(configurationFrame, useETRConfiguration, guessConfiguration, parseRedundantASDUs, ignoreSignatureValidationFailures, ignoreSampleSizeValidationFailures, angleFormat, buffer, startIndex, length);
public:
CommonFrameHeader(
    ConfigurationFrame^ configurationFrame,
    bool useETRConfiguration,
    bool guessConfiguration,
    bool parseRedundantASDUs,
    bool ignoreSignatureValidationFailures,
    bool ignoreSampleSizeValidationFailures,
    AngleFormat angleFormat,
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

configurationFrame
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationFrame
IEC 61850-90-5 ConfigurationFrame if already parsed.
useETRConfiguration
Type: SystemBoolean
Determines if system should find associated ETR file using MSVID with same name for configuration.
guessConfiguration
Type: SystemBoolean
Determines if system should try to guess at a possible configuration given payload size.
parseRedundantASDUs
Type: SystemBoolean
Determines if system should expose redundantly parsed ASDUs.
ignoreSignatureValidationFailures
Type: SystemBoolean
Determines if system should ignore checksum signature validation errors.
ignoreSampleSizeValidationFailures
Type: SystemBoolean
Determines if system should ignore sample size validation errors.
angleFormat
Type: GSF.PhasorProtocolsAngleFormat
Allows customization of the angle parsing format.
buffer
Type: SystemByte
Buffer that contains data to parse.
startIndex
Type: SystemInt32
Start index into buffer where valid data begins.
length
Type: SystemInt32
Maximum length of valid data from offset.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Fields

Grid Solutions Framework CommonFrameHeader Fields

The CommonFrameHeader type exposes the following members.

Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader for IEEE C37.118 frames.
IECFixedLength | Total fixed length of CommonFrameHeader for IEC 61850-90-5 data frames.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.FixedLength Field

Grid Solutions Framework CommonFrameHeaderFixedLength Field
Total fixed length of CommonFrameHeader for IEEE C37.118 frames.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FixedLength
Public Const FixedLength As UShort
static val mutable FixedLength: uint16
var GSF.PhasorProtocols.IEC61850_90_5.CommonFrameHeader.FixedLength
public:
literal unsigned short FixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.IECFixedLength Field

Grid Solutions Framework CommonFrameHeaderIECFixedLength Field
Total fixed length of CommonFrameHeader for IEC 61850-90-5 data frames.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort IECFixedLength
Public Const IECFixedLength As UShort
static val mutable IECFixedLength: uint16
var GSF.PhasorProtocols.IEC61850_90_5.CommonFrameHeader.IECFixedLength
public:
literal unsigned short IECFixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Methods

Grid Solutions Framework CommonFrameHeader Methods

The CommonFrameHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.GetObjectData Method

Grid Solutions Framework CommonFrameHeaderGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader Properties

Grid Solutions Framework CommonFrameHeader Properties

The CommonFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | AsduCount | Gets or sets number of ASDUs in this frame.
Public property | AsduLength | Gets or sets ASDU length in this frame.
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | ConfigurationFrame | Gets or sets current configuration frame.
Public property | ConfigurationRevision | Gets or sets configuration revision;
Public property | DataLength | Gets or sets the length of the data in the IEC 61850-90-5 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FractionOfSecond | Gets the IEC 61850-90-5 fraction of second.
Public property | FrameLength | Gets or sets the IEC 61850-90-5 frame length of this frame.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | GuessConfiguration | Gets or sets flag that determines if system should try to guess at a possible configuration given payload size.
Public property | IDCode | Gets or sets the IEC 61850-90-5 ID code of this frame.
Public property | IgnoreSampleSizeValidationFailures | Gets or sets flag that determines if system should ignore sample size validation errors.
Public property | IgnoreSignatureValidationFailures | Gets or sets flag that determines if system should ignore checksum signature validation errors.
Public property | KeyID | Gets or sets key ID - lookup into table of current keys.
Public property | Length | Gets the IEC 61850-90-5 frame header length.
Public property | MsvID | Gets or sets the MSVID to be used by IEC 61850-90-5 data frames.
Public property | PacketNumber | Gets or sets packet number of this frame.
Public property | ParseRedundantASDUs | Gets or sets flag that determines if system should expose redundantly parsed ASDUs.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects.
Public property | PublishFrame | Gets or sets delegate to method used to publish new frames.
Public property | SecondOfCentury | Gets the IEC 61850-90-5 second of century.
Public property | SecurityAlgorithm | Gets or sets security algorithm used by IEC61850-90-5 data frames.
Public property | SignatureAlgorithm | Gets or sets signature algorithm used by IEC61850-90-5 data frames.
Public property | SpduLength | Gets SPDU length.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | Timebase | Gets or sets the IEC 61850-90-5 resolution of fractional time stamps.
Public property | TimeQualityFlags | Gets or sets the IEC 61850-90-5 TimeQualityFlags.
Public property | TimeQualityIndicatorCode | Gets or sets the IEC 61850-90-5 TimeQualityIndicatorCode.
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets time as a UnixTimeTag representing seconds of current Timestamp.
Public property | TypeID | Gets or sets the IEC 61850-90-5 specific frame type of this frame.
Public property | UseETRConfiguration | Gets or sets flag that determines if system should find associated ETR file using MSVID with same name for configuration.
Public property | Version | Gets or sets the IEC 61850-90-5 version of this frame.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.AsduCount Property

Grid Solutions Framework CommonFrameHeaderAsduCount Property
Gets or sets number of ASDUs in this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int AsduCount { get; set; }
Public Property AsduCount As Integer
    Get
    Set
member AsduCount : int with get, set

function get_AsduCount();
function set_AsduCount(value);
public:
property int AsduCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.AsduLength Property

Grid Solutions Framework CommonFrameHeaderAsduLength Property
Gets or sets ASDU length in this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort AsduLength { get; set; }
Public Property AsduLength As UShort
    Get
    Set
member AsduLength : uint16 with get, set

function get_AsduLength();
function set_AsduLength(value);
public:
property unsigned short AsduLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.BinaryImage Property

Grid Solutions Framework CommonFrameHeaderBinaryImage Property
Gets the binary image of the common header portion of this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
member BinaryImage : byte[] with get

function get_BinaryImage();

public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.ConfigurationFrame Property

Grid Solutions Framework CommonFrameHeaderConfigurationFrame Property
Gets or sets current configuration frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
member ConfigurationFrame : ConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.ConfigurationRevision Property

Grid Solutions Framework CommonFrameHeaderConfigurationRevision Property
Gets or sets configuration revision;

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ConfigurationRevision { get; set; }
Public Property ConfigurationRevision As UInteger
    Get
    Set
member ConfigurationRevision : uint32 with get, set

function get_ConfigurationRevision();
function set_ConfigurationRevision(value);
public:
property unsigned int ConfigurationRevision {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.DataLength Property

Grid Solutions Framework CommonFrameHeaderDataLength Property
Gets or sets the length of the data in the IEC 61850-90-5 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DataLength { get; set; }
Public Property DataLength As UShort
    Get
    Set
member DataLength : uint16 with get, set

function get_DataLength();
function set_DataLength(value);
public:
property unsigned short DataLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.FractionOfSecond Property

Grid Solutions Framework CommonFrameHeaderFractionOfSecond Property
Gets the IEC 61850-90-5 fraction of second.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UInt24 FractionOfSecond { get; }
Public ReadOnly Property FractionOfSecond As UInt24
    Get
member FractionOfSecond : UInt24 with get

function get_FractionOfSecond();

public:
property UInt24 FractionOfSecond {
    UInt24 get ();
}

Property Value

Type: UInt24
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.FrameLength Property

Grid Solutions Framework CommonFrameHeaderFrameLength Property
Gets or sets the IEC 61850-90-5 frame length of this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort FrameLength { get; set; }
Public Property FrameLength As UShort
    Get
    Set
member FrameLength : uint16 with get, set

function get_FrameLength();
function set_FrameLength(value);
public:
property unsigned short FrameLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.FrameType Property

Grid Solutions Framework CommonFrameHeaderFrameType Property
Gets the fundamental frame type of this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
member FrameType : FundamentalFrameType with get

function get_FrameType();

public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}

Property Value

Type: FundamentalFrameType
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.GuessConfiguration Property

Grid Solutions Framework CommonFrameHeaderGuessConfiguration Property
Gets or sets flag that determines if system should try to guess at a possible configuration given payload size.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool GuessConfiguration { get; set; }
Public Property GuessConfiguration As Boolean
    Get
    Set
member GuessConfiguration : bool with get, set

function get_GuessConfiguration();
function set_GuessConfiguration(value);
public:
property bool GuessConfiguration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.IDCode Property

Grid Solutions Framework CommonFrameHeaderIDCode Property
Gets or sets the IEC 61850-90-5 ID code of this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort IDCode { get; set; }
Public Property IDCode As UShort
    Get
    Set
member IDCode : uint16 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.IgnoreSampleSizeValidationFailures Property

Grid Solutions Framework CommonFrameHeaderIgnoreSampleSizeValidationFailures Property
Gets or sets flag that determines if system should ignore sample size validation errors.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IgnoreSampleSizeValidationFailures { get; set; }
Public Property IgnoreSampleSizeValidationFailures As Boolean
    Get
    Set
member IgnoreSampleSizeValidationFailures : bool with get, set

function get_IgnoreSampleSizeValidationFailures();
function set_IgnoreSampleSizeValidationFailures(value);
public:
property bool IgnoreSampleSizeValidationFailures {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.IgnoreSignatureValidationFailures Property

Grid Solutions Framework CommonFrameHeaderIgnoreSignatureValidationFailures Property
Gets or sets flag that determines if system should ignore checksum signature validation errors.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IgnoreSignatureValidationFailures { get; set; }
Public Property IgnoreSignatureValidationFailures As Boolean
    Get
    Set
member IgnoreSignatureValidationFailures : bool with get, set

function get_IgnoreSignatureValidationFailures();
function set_IgnoreSignatureValidationFailures(value);
public:
property bool IgnoreSignatureValidationFailures {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.KeyID Property

Grid Solutions Framework CommonFrameHeaderKeyID Property
Gets or sets key ID - lookup into table of current keys.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint KeyID { get; set; }
Public Property KeyID As UInteger
    Get
    Set
member KeyID : uint32 with get, set

function get_KeyID();
function set_KeyID(value);
public:
property unsigned int KeyID {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.Length Property

Grid Solutions Framework CommonFrameHeaderLength Property
Gets the IEC 61850-90-5 frame header length.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Length { get; }
Public ReadOnly Property Length As UShort
    Get
member Length : uint16 with get

function get_Length();

public:
property unsigned short Length {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.MsvID Property

Grid Solutions Framework CommonFrameHeaderMsvID Property
Gets or sets the MSVID to be used by IEC 61850-90-5 data frames.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string MsvID { get; set; }
Public Property MsvID As String
    Get
    Set
member MsvID : string with get, set

function get_MsvID();
function set_MsvID(value);
public:
property String^ MsvID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.PacketNumber Property

Grid Solutions Framework CommonFrameHeaderPacketNumber Property
Gets or sets packet number of this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint PacketNumber { get; set; }
Public Property PacketNumber As UInteger
    Get
    Set
member PacketNumber : uint32 with get, set

function get_PacketNumber();
function set_PacketNumber(value);
public:
property unsigned int PacketNumber {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.ParseRedundantASDUs Property

Grid Solutions Framework CommonFrameHeaderParseRedundantASDUs Property
Gets or sets flag that determines if system should expose redundantly parsed ASDUs.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ParseRedundantASDUs { get; set; }
Public Property ParseRedundantASDUs As Boolean
    Get
    Set
member ParseRedundantASDUs : bool with get, set

function get_ParseRedundantASDUs();
function set_ParseRedundantASDUs(value);
public:
property bool ParseRedundantASDUs {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.PhasorAngleFormat Property

Grid Solutions Framework CommonFrameHeaderPhasorAngleFormat Property
Gets or sets the AngleFormat for the IPhasorDefinition objects.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AngleFormat PhasorAngleFormat { get; set; }
Public Overridable Property PhasorAngleFormat As AngleFormat
    Get
    Set
abstract PhasorAngleFormat : AngleFormat with get, set
override PhasorAngleFormat : AngleFormat with get, set
function get_PhasorAngleFormat();
function set_PhasorAngleFormat(value);
public:
virtual property AngleFormat PhasorAngleFormat {
    AngleFormat get ();
    void set (AngleFormat value);
}

Property Value

Type: AngleFormat
Remarks
Base class defines default angle format since this is rarely not radians.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.PublishFrame Property

Grid Solutions Framework CommonFrameHeaderPublishFrame Property
Gets or sets delegate to method used to publish new frames.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<IChannelFrame> PublishFrame { get; set; }
Public Property PublishFrame As Action(Of IChannelFrame)
    Get
    Set
member PublishFrame : Action<IChannelFrame> with get, set

function get_PublishFrame();
function set_PublishFrame(value);
public:
property Action<IChannelFrame^>^ PublishFrame {
    Action<IChannelFrame^>^ get ();
    void set (Action<IChannelFrame^>^ value);
}

Property Value

Type: Action IChannelFrame
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.SecondOfCentury Property

Grid Solutions Framework CommonFrameHeaderSecondOfCentury Property
Gets the IEC 61850-90-5 second of century.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint SecondOfCentury { get; }
Public ReadOnly Property SecondOfCentury As UInteger
    Get
member SecondOfCentury : uint32 with get

function get_SecondOfCentury();

public:
property unsigned int SecondOfCentury {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.SecurityAlgorithm Property

Grid Solutions Framework CommonFrameHeaderSecurityAlgorithm Property
Gets or sets security algorithm used by IEC61850-90-5 data frames.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityAlgorithm SecurityAlgorithm { get; set; }
Public Property SecurityAlgorithm As SecurityAlgorithm
    Get
    Set
member SecurityAlgorithm : SecurityAlgorithm with get, set

function get_SecurityAlgorithm();
function set_SecurityAlgorithm(value);
public:
property SecurityAlgorithm SecurityAlgorithm {
    SecurityAlgorithm get ();
    void set (SecurityAlgorithm value);
}

Property Value

Type: SecurityAlgorithm
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.SignatureAlgorithm Property

Grid Solutions Framework CommonFrameHeaderSignatureAlgorithm Property
Gets or sets signature algorithm used by IEC61850-90-5 data frames.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SignatureAlgorithm SignatureAlgorithm { get; set; }
Public Property SignatureAlgorithm As SignatureAlgorithm
    Get
    Set
member SignatureAlgorithm : SignatureAlgorithm with get, set

function get_SignatureAlgorithm();
function set_SignatureAlgorithm(value);
public:
property SignatureAlgorithm SignatureAlgorithm {
    SignatureAlgorithm get ();
    void set (SignatureAlgorithm value);
}

Property Value

Type: SignatureAlgorithm
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.SpduLength Property

Grid Solutions Framework CommonFrameHeaderSpduLength Property
Gets SPDU length.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint SpduLength { get; }
Public ReadOnly Property SpduLength As UInteger
    Get
member SpduLength : uint32 with get

function get_SpduLength();

public:
property unsigned int SpduLength {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.State Property

Grid Solutions Framework CommonFrameHeaderState Property
Gets or sets the parsing state for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IChannelParsingState State { get; set; }
Public Property State As IChannelParsingState
    Get
    Set
member State : IChannelParsingState with get, set

function get_State();
function set_State(value);
public:
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}

Property Value

Type: IChannelParsingState
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.Timebase Property

Grid Solutions Framework CommonFrameHeaderTimebase Property
Gets or sets the IEC 61850-90-5 resolution of fractional time stamps.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Timebase { get; set; }
Public Property Timebase As UInteger
    Get
    Set
member Timebase : uint32 with get, set

function get_Timebase();
function set_Timebase(value);
public:
property unsigned int Timebase {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.TimeQualityFlags Property

Grid Solutions Framework CommonFrameHeaderTimeQualityFlags Property
Gets or sets the IEC 61850-90-5 TimeQualityFlags.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
member TimeQualityFlags : TimeQualityFlags with get, set

function get_TimeQualityFlags();
function set_TimeQualityFlags(value);
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}

Property Value

Type: TimeQualityFlags
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.TimeQualityIndicatorCode Property

Grid Solutions Framework CommonFrameHeaderTimeQualityIndicatorCode Property
Gets or sets the IEC 61850-90-5 TimeQualityIndicatorCode.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
member TimeQualityIndicatorCode : TimeQualityIndicatorCode with get, set

function get_TimeQualityIndicatorCode();
function set_TimeQualityIndicatorCode(value);
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}

Property Value

Type: TimeQualityIndicatorCode
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.Timestamp Property

Grid Solutions Framework CommonFrameHeaderTimestamp Property
Gets or sets timestamp of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
member Timestamp : Ticks with get, set

function get_Timestamp();
function set_Timestamp(value);
public:
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.TimeTag Property

Grid Solutions Framework CommonFrameHeaderTimeTag Property
Gets time as a UnixTimeTag representing seconds of current Timestamp.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnixTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As UnixTimeTag
    Get
member TimeTag : UnixTimeTag with get

function get_TimeTag();

public:
property UnixTimeTag^ TimeTag {
    UnixTimeTag^ get ();
}

Property Value

Type: UnixTimeTag
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.TypeID Property

Grid Solutions Framework CommonFrameHeaderTypeID Property
Gets or sets the IEC 61850-90-5 specific frame type of this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; set; }
Public Property TypeID As FrameType
    Get
    Set
abstract TypeID : FrameType with get, set
override TypeID : FrameType with get, set
function get_TypeID();
function set_TypeID(value);
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
    void set (FrameType value) sealed;
}

Property Value

Type: FrameType

Implements

ICommonHeaderTTypeIdentifierTypeID
Remarks

This returns the protocol specific frame classification which uniquely identifies the frame type.

This is the TypeID implementation.

See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.UseETRConfiguration Property

Grid Solutions Framework CommonFrameHeaderUseETRConfiguration Property
Gets or sets flag that determines if system should find associated ETR file using MSVID with same name for configuration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseETRConfiguration { get; set; }
Public Property UseETRConfiguration As Boolean
    Get
    Set
member UseETRConfiguration : bool with get, set

function get_UseETRConfiguration();
function set_UseETRConfiguration(value);
public:
property bool UseETRConfiguration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


CommonFrameHeader.Version Property

Grid Solutions Framework CommonFrameHeaderVersion Property
Gets or sets the IEC 61850-90-5 version of this frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
member Version : byte with get, set

function get_Version();
function set_Version(value);
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents the IEC 61850-90-5 implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.IEC61850_90_5ConfigurationCell

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
    end
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FormatFlags | Gets or sets format flags of this ConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorAngleFormat.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Overload List
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell Constructor (IConfigurationFrame)

Grid Solutions Framework ConfigurationCell Constructor (IConfigurationFrame)
Creates a new ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    IConfigurationFrame parent
)
Public Sub New (
    parent As IConfigurationFrame
)
new :
        parent : IConfigurationFrame -> ConfigurationCell
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCell = function(parent);
public:
ConfigurationCell(
    IConfigurationFrame^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationFrame
The reference to parent IConfigurationFrame of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCell Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell Constructor (ConfigurationFrame, UInt16, LineFrequency)

Grid Solutions Framework ConfigurationCell Constructor (ConfigurationFrame, UInt16, LineFrequency)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ConfigurationFrame parent,
    ushort idCode,
    LineFrequency nominalFrequency
)
Public Sub New (
    parent As ConfigurationFrame,
    idCode As UShort,
    nominalFrequency As LineFrequency
)
new :
        parent : ConfigurationFrame *
        idCode : uint16 *
        nominalFrequency : LineFrequency -> ConfigurationCell
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCell = function(parent, idCode, nominalFrequency);
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    unsigned short idCode,
    LineFrequency nominalFrequency
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationFrame
The reference to parent ConfigurationFrame of this ConfigurationCell.
idCode
Type: SystemUInt16
The numeric ID code for this ConfigurationCell.
nominalFrequency
Type: GSF.Units.EELineFrequency
The nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.GetObjectData Method

Grid Solutions Framework ConfigurationCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.ParseFooterImage Method

Grid Solutions Framework ConfigurationCellParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.ParseHeaderImage Method

Grid Solutions Framework ConfigurationCellParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FormatFlags | Gets or sets format flags of this ConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorAngleFormat.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.Attributes Property

Grid Solutions Framework ConfigurationCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.FooterImage Property

Grid Solutions Framework ConfigurationCellFooterImage Property
Gets the binary footer image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.FooterLength Property

Grid Solutions Framework ConfigurationCellFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.FormatFlags Property

Grid Solutions Framework ConfigurationCellFormatFlags Property
Gets or sets format flags of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public FormatFlags FormatFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property FormatFlags As FormatFlags
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member FormatFlags : FormatFlags with get, set

function get_FormatFlags();
function set_FormatFlags(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property FormatFlags FormatFlags {
    FormatFlags get ();
    void set (FormatFlags value);
}

Property Value

Type: FormatFlags
Remarks
These are bit flags, use properties to change basic values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.HeaderImage Property

Grid Solutions Framework ConfigurationCellHeaderImage Property
Gets the binary header image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.HeaderLength Property

Grid Solutions Framework ConfigurationCellHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.Parent Property

Grid Solutions Framework ConfigurationCellParent Property
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
member Parent : ConfigurationFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.PhasorAngleFormat Property

Grid Solutions Framework ConfigurationCellPhasorAngleFormat Property
Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override AngleFormat PhasorAngleFormat { get; set; }
Public Overrides Property PhasorAngleFormat As AngleFormat
    Get
    Set
abstract PhasorAngleFormat : AngleFormat with get, set
override PhasorAngleFormat : AngleFormat with get, set
function get_PhasorAngleFormat();
function set_PhasorAngleFormat(value);
public:
virtual property AngleFormat PhasorAngleFormat {
    AngleFormat get () override;
    void set (AngleFormat value) override;
}

Property Value

Type: AngleFormat

Implements

IConfigurationCellPhasorAngleFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a IEC 61850-90-5 implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.IEC61850_90_5ConfigurationCellCollection

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame Class

Grid Solutions Framework ConfigurationFrame Class
Represents the IEC 61850-90-5 implementation of a IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.IEC61850_90_5ConfigurationFrame

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class ConfigurationFrame
    Inherits ConfigurationFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type ConfigurationFrame =
    class
        inherit ConfigurationFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.ConfigurationFrame',
    GSF.PhasorProtocols.ConfigurationFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The ConfigurationFrame type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCalculatedSampleLength | Gets calculated length of data samples based on known configuration.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEC 61850-90-5 resolution of fractional time stamps of this ConfigurationFrame.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEC 61850-90-5 protocol version of this ConfigurationFrame.
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Creates a new ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEC 61850-90-5 configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationFrame = function(info, context);
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame Constructor (UInt32, UInt16, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame Constructor (UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    timebase As UInteger,
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        timebase : uint32 *
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame
GSF.PhasorProtocols.IEC61850_90_5.ConfigurationFrame = function(timebase, idCode, timestamp, frameRate);
public:
ConfigurationFrame(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

timebase
Type: SystemUInt32
Timebase to use for fraction second resolution.
idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame.
Remarks
This constructor is used by a consumer to generate an IEC 61850-90-5 configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame Methods

Grid Solutions Framework ConfigurationFrame Methods

The ConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCalculatedSampleLength | Gets calculated length of data samples based on known configuration.
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.GetCalculatedSampleLength Method

Grid Solutions Framework ConfigurationFrameGetCalculatedSampleLength Method
Gets calculated length of data samples based on known configuration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GetCalculatedSampleLength()
Public Function GetCalculatedSampleLength As Integer
member GetCalculatedSampleLength : unit -> int

function GetCalculatedSampleLength();
public:
int GetCalculatedSampleLength()

Return Value

Type: Int32
Calculated length of data samples.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.GetObjectData Method

Grid Solutions Framework ConfigurationFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.ParseFooterImage Method

Grid Solutions Framework ConfigurationFrameParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.ParseHeaderImage Method

Grid Solutions Framework ConfigurationFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame Properties

Grid Solutions Framework ConfigurationFrame Properties

The ConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEC 61850-90-5 resolution of fractional time stamps of this ConfigurationFrame.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEC 61850-90-5 protocol version of this ConfigurationFrame.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.Attributes Property

Grid Solutions Framework ConfigurationFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.Cells Property

Grid Solutions Framework ConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.CommonHeader Property

Grid Solutions Framework ConfigurationFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.DraftRevision Property

Grid Solutions Framework ConfigurationFrameDraftRevision Property
Gets the DraftRevision of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DraftRevision DraftRevision { get; }
Public Overridable ReadOnly Property DraftRevision As DraftRevision
    Get
abstract DraftRevision : DraftRevision with get
override DraftRevision : DraftRevision with get
function get_DraftRevision();

public:
virtual property DraftRevision DraftRevision {
    DraftRevision get ();
}

Property Value

Type: DraftRevision
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.FooterImage Property

Grid Solutions Framework ConfigurationFrameFooterImage Property
Gets the binary footer image of the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.FooterLength Property

Grid Solutions Framework ConfigurationFrameFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.HeaderImage Property

Grid Solutions Framework ConfigurationFrameHeaderImage Property
Gets the binary header image of the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.HeaderLength Property

Grid Solutions Framework ConfigurationFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.Timebase Property

Grid Solutions Framework ConfigurationFrameTimebase Property
Gets or sets the IEC 61850-90-5 resolution of fractional time stamps of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Timebase { get; set; }
Public Property Timebase As UInteger
    Get
    Set
member Timebase : uint32 with get, set

function get_Timebase();
function set_Timebase(value);
public:
property unsigned int Timebase {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.TimeQualityFlags Property

Grid Solutions Framework ConfigurationFrameTimeQualityFlags Property
Gets or sets the TimeQualityFlags of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
member TimeQualityFlags : TimeQualityFlags with get, set

function get_TimeQualityFlags();
function set_TimeQualityFlags(value);
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}

Property Value

Type: TimeQualityFlags
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.TimeQualityIndicatorCode Property

Grid Solutions Framework ConfigurationFrameTimeQualityIndicatorCode Property
Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
member TimeQualityIndicatorCode : TimeQualityIndicatorCode with get, set

function get_TimeQualityIndicatorCode();
function set_TimeQualityIndicatorCode(value);
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}

Property Value

Type: TimeQualityIndicatorCode
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.Timestamp Property

Grid Solutions Framework ConfigurationFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.TypeID Property

Grid Solutions Framework ConfigurationFrameTypeID Property
Gets the FrameType of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrameType TypeID { get; }
Public Overridable ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get ();
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConfigurationFrame.Version Property

Grid Solutions Framework ConfigurationFrameVersion Property
Gets or sets the IEC 61850-90-5 protocol version of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
member Version : byte with get, set

function get_Version();
function set_Version(value);
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters Class

Grid Solutions Framework ConnectionParameters Class
Represents the extra connection parameters available for a connection to an IEC 61850-90-5 stream.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsConnectionParametersBase
GSF.PhasorProtocols.IEC61850_90_5ConnectionParameters

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute>
Public Class ConnectionParameters
    Inherits ConnectionParametersBase
[<SerializableAttribute>]
type ConnectionParameters =
    class
        inherit ConnectionParametersBase
    end
GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters',
    GSF.PhasorProtocols.ConnectionParametersBase);
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase

The ConnectionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultGuessConfiguration | Default value for GuessConfiguration property.
DefaultIgnoreSampleSizeValidationFailures | Default value for IgnoreSampleSizeValidationFailures property.
DefaultIgnoreSignatureValidationFailures | Default value for IgnoreSignatureValidationFailures property.
DefaultParseRedundantASDUs | Default value for ParseRedundantASDUs property.
DefaultPhasorAngleFormat | Default value for PhasorAngleFormat property.
DefaultUseETRConfiguration | Default value for UseETRConfiguration property.
Top
Properties
 | Name | Description
Public property | GuessConfiguration | Gets or sets flag that determines if system should try to guess at a possible configuration given payload size.
Public property | IgnoreSampleSizeValidationFailures | Gets or sets flag that determines if system should ignore sample size validation errors.
Public property | IgnoreSignatureValidationFailures | Gets or sets flag that determines if system should ignore checksum signature validation errors.
Public property | ParseRedundantASDUs | Gets or sets flag that determines if system should expose redundantly parsed ASDUs.
Public property | PhasorAngleFormat | Gets or sets flag that determines the phasor angle parsing format.
Public property | UseETRConfiguration | Gets or sets flag that determines if system should find associated ETR file using MSVID with same name for configuration.
Public property | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Top
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Overload List
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Creates a new ConnectionParameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionParameters()
Public Sub New
new : unit -> ConnectionParameters
GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters = function();
public:
ConnectionParameters()
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConnectionParameters Constructor (SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConnectionParameters
GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters = function(info, context);
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters Fields

Grid Solutions Framework ConnectionParameters Fields

The ConnectionParameters type exposes the following members.

Fields
Name | Description
DefaultGuessConfiguration | Default value for GuessConfiguration property.
DefaultIgnoreSampleSizeValidationFailures | Default value for IgnoreSampleSizeValidationFailures property.
DefaultIgnoreSignatureValidationFailures | Default value for IgnoreSignatureValidationFailures property.
DefaultParseRedundantASDUs | Default value for ParseRedundantASDUs property.
DefaultPhasorAngleFormat | Default value for PhasorAngleFormat property.
DefaultUseETRConfiguration | Default value for UseETRConfiguration property.
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.DefaultGuessConfiguration Field

Grid Solutions Framework ConnectionParametersDefaultGuessConfiguration Field
Default value for GuessConfiguration property.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultGuessConfiguration
Public Const DefaultGuessConfiguration As Boolean
static val mutable DefaultGuessConfiguration: bool
var GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters.DefaultGuessConfiguration
public:
literal bool DefaultGuessConfiguration

Field Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.DefaultIgnoreSampleSizeValidationFailures Field

Grid Solutions Framework ConnectionParametersDefaultIgnoreSampleSizeValidationFailures Field
Default value for IgnoreSampleSizeValidationFailures property.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIgnoreSampleSizeValidationFailures
Public Const DefaultIgnoreSampleSizeValidationFailures As Boolean
static val mutable DefaultIgnoreSampleSizeValidationFailures: bool
var GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters.DefaultIgnoreSampleSizeValidationFailures
public:
literal bool DefaultIgnoreSampleSizeValidationFailures

Field Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.DefaultIgnoreSignatureValidationFailures Field

Grid Solutions Framework ConnectionParametersDefaultIgnoreSignatureValidationFailures Field
Default value for IgnoreSignatureValidationFailures property.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultIgnoreSignatureValidationFailures
Public Const DefaultIgnoreSignatureValidationFailures As Boolean
static val mutable DefaultIgnoreSignatureValidationFailures: bool
var GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters.DefaultIgnoreSignatureValidationFailures
public:
literal bool DefaultIgnoreSignatureValidationFailures

Field Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.DefaultParseRedundantASDUs Field

Grid Solutions Framework ConnectionParametersDefaultParseRedundantASDUs Field
Default value for ParseRedundantASDUs property.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultParseRedundantASDUs
Public Const DefaultParseRedundantASDUs As Boolean
static val mutable DefaultParseRedundantASDUs: bool
var GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters.DefaultParseRedundantASDUs
public:
literal bool DefaultParseRedundantASDUs

Field Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.DefaultPhasorAngleFormat Field

Grid Solutions Framework ConnectionParametersDefaultPhasorAngleFormat Field
Default value for PhasorAngleFormat property.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultPhasorAngleFormat
Public Const DefaultPhasorAngleFormat As String
static val mutable DefaultPhasorAngleFormat: string
var GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters.DefaultPhasorAngleFormat
public:
literal String^ DefaultPhasorAngleFormat

Field Value

Type: String
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.DefaultUseETRConfiguration Field

Grid Solutions Framework ConnectionParametersDefaultUseETRConfiguration Field
Default value for UseETRConfiguration property.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultUseETRConfiguration
Public Const DefaultUseETRConfiguration As Boolean
static val mutable DefaultUseETRConfiguration: bool
var GSF.PhasorProtocols.IEC61850_90_5.ConnectionParameters.DefaultUseETRConfiguration
public:
literal bool DefaultUseETRConfiguration

Field Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters Methods

Grid Solutions Framework ConnectionParameters Methods

The ConnectionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.GetObjectData Method

Grid Solutions Framework ConnectionParametersGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters Properties

Grid Solutions Framework ConnectionParameters Properties

The ConnectionParameters type exposes the following members.

Properties
 | Name | Description
Public property | GuessConfiguration | Gets or sets flag that determines if system should try to guess at a possible configuration given payload size.
Public property | IgnoreSampleSizeValidationFailures | Gets or sets flag that determines if system should ignore sample size validation errors.
Public property | IgnoreSignatureValidationFailures | Gets or sets flag that determines if system should ignore checksum signature validation errors.
Public property | ParseRedundantASDUs | Gets or sets flag that determines if system should expose redundantly parsed ASDUs.
Public property | PhasorAngleFormat | Gets or sets flag that determines the phasor angle parsing format.
Public property | UseETRConfiguration | Gets or sets flag that determines if system should find associated ETR file using MSVID with same name for configuration.
Public property | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.GuessConfiguration Property

Grid Solutions Framework ConnectionParametersGuessConfiguration Property
Gets or sets flag that determines if system should try to guess at a possible configuration given payload size.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool GuessConfiguration { get; set; }
<DefaultValueAttribute(false)>
Public Property GuessConfiguration As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member GuessConfiguration : bool with get, set

function get_GuessConfiguration();
function set_GuessConfiguration(value);
public:
[DefaultValueAttribute(false)]
property bool GuessConfiguration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.IgnoreSampleSizeValidationFailures Property

Grid Solutions Framework ConnectionParametersIgnoreSampleSizeValidationFailures Property
Gets or sets flag that determines if system should ignore sample size validation errors.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool IgnoreSampleSizeValidationFailures { get; set; }
<DefaultValueAttribute(false)>
Public Property IgnoreSampleSizeValidationFailures As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member IgnoreSampleSizeValidationFailures : bool with get, set

function get_IgnoreSampleSizeValidationFailures();
function set_IgnoreSampleSizeValidationFailures(value);
public:
[DefaultValueAttribute(false)]
property bool IgnoreSampleSizeValidationFailures {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.IgnoreSignatureValidationFailures Property

Grid Solutions Framework ConnectionParametersIgnoreSignatureValidationFailures Property
Gets or sets flag that determines if system should ignore checksum signature validation errors.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool IgnoreSignatureValidationFailures { get; set; }
<DefaultValueAttribute(true)>
Public Property IgnoreSignatureValidationFailures As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member IgnoreSignatureValidationFailures : bool with get, set

function get_IgnoreSignatureValidationFailures();
function set_IgnoreSignatureValidationFailures(value);
public:
[DefaultValueAttribute(true)]
property bool IgnoreSignatureValidationFailures {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.ParseRedundantASDUs Property

Grid Solutions Framework ConnectionParametersParseRedundantASDUs Property
Gets or sets flag that determines if system should expose redundantly parsed ASDUs.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool ParseRedundantASDUs { get; set; }
<DefaultValueAttribute(false)>
Public Property ParseRedundantASDUs As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member ParseRedundantASDUs : bool with get, set

function get_ParseRedundantASDUs();
function set_ParseRedundantASDUs(value);
public:
[DefaultValueAttribute(false)]
property bool ParseRedundantASDUs {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.PhasorAngleFormat Property

Grid Solutions Framework ConnectionParametersPhasorAngleFormat Property
Gets or sets flag that determines the phasor angle parsing format.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(typeof(AngleFormat), "Degrees")]
public AngleFormat PhasorAngleFormat { get; set; }
<DefaultValueAttribute(GetType(AngleFormat), "Degrees")>
Public Property PhasorAngleFormat As AngleFormat
    Get
    Set
[<DefaultValueAttribute(typeof(AngleFormat), "Degrees")>]
member PhasorAngleFormat : AngleFormat with get, set

function get_PhasorAngleFormat();
function set_PhasorAngleFormat(value);
public:
[DefaultValueAttribute(typeof(AngleFormat), L"Degrees")]
property AngleFormat PhasorAngleFormat {
    AngleFormat get ();
    void set (AngleFormat value);
}

Property Value

Type: AngleFormat
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


ConnectionParameters.UseETRConfiguration Property

Grid Solutions Framework ConnectionParametersUseETRConfiguration Property
Gets or sets flag that determines if system should find associated ETR file using MSVID with same name for configuration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool UseETRConfiguration { get; set; }
<DefaultValueAttribute(false)>
Public Property UseETRConfiguration As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member UseETRConfiguration : bool with get, set

function get_UseETRConfiguration();
function set_UseETRConfiguration(value);
public:
[DefaultValueAttribute(false)]
property bool UseETRConfiguration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell Class

Grid Solutions Framework DataCell Class
Represents the IEC 61850-90-5 implementation of a IDataCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.IEC61850_90_5DataCell

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute>
Public Class DataCell
    Inherits DataCellBase
[<SerializableAttribute>]
type DataCell =
    class
        inherit DataCellBase
    end
GSF.PhasorProtocols.IEC61850_90_5.DataCell = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.DataCell',
    GSF.PhasorProtocols.DataCellBase);
[SerializableAttribute]
public ref class DataCell : public DataCellBase

The DataCell type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | ConfigurationChangeDetected | Gets or sets flag that determines if configuration change was detected for this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DeviceTriggerDetected | Gets or sets flag that determines if device trigger is detected for this DataCell.
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets status flags for this DataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerReason | Gets or sets trigger reason of this DataCell.
Public property | UnlockedTime | Gets or sets unlocked time of this DataCell.
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell Constructor

Grid Solutions Framework DataCell Constructor
Overload List
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCell Constructor (SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCell
GSF.PhasorProtocols.IEC61850_90_5.DataCell = function(info, context);
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell Constructor (IDataFrame, IConfigurationCell)

Grid Solutions Framework DataCell Constructor (IDataFrame, IConfigurationCell)
Creates a new DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell -> DataCell
GSF.PhasorProtocols.IEC61850_90_5.DataCell = function(parent, configurationCell);
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCell.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell Constructor (DataFrame, ConfigurationCell, Boolean)

Grid Solutions Framework DataCell Constructor (DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New (
    parent As DataFrame,
    configurationCell As ConfigurationCell,
    addEmptyValues As Boolean
)
new :
        parent : DataFrame *
        configurationCell : ConfigurationCell *
        addEmptyValues : bool -> DataCell
GSF.PhasorProtocols.IEC61850_90_5.DataCell = function(parent, configurationCell, addEmptyValues);
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5DataFrame
The reference to parent DataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationCell
The ConfigurationCell associated with this DataCell.
addEmptyValues
Type: SystemBoolean
If true, adds empty values for each defined configuration cell definition.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell Methods

Grid Solutions Framework DataCell Methods

The DataCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell Properties

Grid Solutions Framework DataCell Properties

The DataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | ConfigurationChangeDetected | Gets or sets flag that determines if configuration change was detected for this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DeviceTriggerDetected | Gets or sets flag that determines if device trigger is detected for this DataCell.
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets status flags for this DataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerReason | Gets or sets trigger reason of this DataCell.
Public property | UnlockedTime | Gets or sets unlocked time of this DataCell.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.Attributes Property

Grid Solutions Framework DataCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.ConfigurationCell Property

Grid Solutions Framework DataCellConfigurationCell Property
Gets or sets the ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
member ConfigurationCell : ConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.ConfigurationChangeDetected Property

Grid Solutions Framework DataCellConfigurationChangeDetected Property
Gets or sets flag that determines if configuration change was detected for this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ConfigurationChangeDetected { get; set; }
Public Property ConfigurationChangeDetected As Boolean
    Get
    Set
member ConfigurationChangeDetected : bool with get, set

function get_ConfigurationChangeDetected();
function set_ConfigurationChangeDetected(value);
public:
property bool ConfigurationChangeDetected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.DataIsValid Property

Grid Solutions Framework DataCellDataIsValid Property
Gets or sets flag that determines if data of this DataCell is valid.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set
override DataIsValid : bool with get, set
function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.DataSortingType Property

Grid Solutions Framework DataCellDataSortingType Property
Gets or sets DataSortingType of this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set
override DataSortingType : DataSortingType with get, set
function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.DeviceError Property

Grid Solutions Framework DataCellDeviceError Property
Gets or sets flag that determines if source device of this DataCell is reporting an error.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DeviceError { get; set; }
Public Overrides Property DeviceError As Boolean
    Get
    Set
abstract DeviceError : bool with get, set
override DeviceError : bool with get, set
function get_DeviceError();
function set_DeviceError(value);
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.DeviceTriggerDetected Property

Grid Solutions Framework DataCellDeviceTriggerDetected Property
Gets or sets flag that determines if device trigger is detected for this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DeviceTriggerDetected { get; set; }
Public Property DeviceTriggerDetected As Boolean
    Get
    Set
member DeviceTriggerDetected : bool with get, set

function get_DeviceTriggerDetected();
function set_DeviceTriggerDetected(value);
public:
property bool DeviceTriggerDetected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.Parent Property

Grid Solutions Framework DataCellParent Property
Gets or sets the reference to parent DataFrame of this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
member Parent : DataFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}

Property Value

Type: DataFrame
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.StatusFlags Property

Grid Solutions Framework DataCellStatusFlags Property
Gets or sets status flags for this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatusFlags StatusFlags { get; set; }
Public Property StatusFlags As StatusFlags
    Get
    Set
member StatusFlags : StatusFlags with get, set

function get_StatusFlags();
function set_StatusFlags(value);
public:
property StatusFlags StatusFlags {
    StatusFlags get ();
    void set (StatusFlags value);
}

Property Value

Type: StatusFlags
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.SynchronizationIsValid Property

Grid Solutions Framework DataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set
override SynchronizationIsValid : bool with get, set
function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.TriggerReason Property

Grid Solutions Framework DataCellTriggerReason Property
Gets or sets trigger reason of this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TriggerReason TriggerReason { get; set; }
Public Property TriggerReason As TriggerReason
    Get
    Set
member TriggerReason : TriggerReason with get, set

function get_TriggerReason();
function set_TriggerReason(value);
public:
property TriggerReason TriggerReason {
    TriggerReason get ();
    void set (TriggerReason value);
}

Property Value

Type: TriggerReason
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCell.UnlockedTime Property

Grid Solutions Framework DataCellUnlockedTime Property
Gets or sets unlocked time of this DataCell.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnlockedTime UnlockedTime { get; set; }
Public Property UnlockedTime As UnlockedTime
    Get
    Set
member UnlockedTime : UnlockedTime with get, set

function get_UnlockedTime();
function set_UnlockedTime(value);
public:
property UnlockedTime UnlockedTime {
    UnlockedTime get ();
    void set (UnlockedTime value);
}

Property Value

Type: UnlockedTime
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a IEC 61850-90-5 implementation of a collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.IEC61850_90_5DataCellCollection

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute>
Public Class DataCellCollection
    Inherits DataCellCollection
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit DataCellCollection
    end
GSF.PhasorProtocols.IEC61850_90_5.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.DataCellCollection',
    GSF.PhasorProtocols.DataCellCollection);
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Creates a new DataCellCollection.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection()
Public Sub New
new : unit -> DataCellCollection
GSF.PhasorProtocols.IEC61850_90_5.DataCellCollection = function();
public:
DataCellCollection()
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.IEC61850_90_5.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection.Item Property

Grid Solutions Framework DataCellCollectionItem Property
Gets or sets DataCell at specified index.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As DataCell
    Get
    Set
member Item : DataCell with get, set

function get_Item(index);
function set_Item(value);
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: DataCell
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame Class

Grid Solutions Framework DataFrame Class
Represents the IEC 61850-90-5 implementation of a IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.IEC61850_90_5DataFrame

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute>
Public Class DataFrame
    Inherits DataFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type DataFrame =
    class
        inherit DataFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEC61850_90_5.DataFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.DataFrame',
    GSF.PhasorProtocols.DataFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The DataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame, String, Int32, Byte, UInt32) | Creates a new DataFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides DataFrameBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this DataFrame object. (Overrides ChannelFrameBaseTBinaryImage.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the DataFrame object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the header image. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrame. (Overrides DataFrameBaseQualityFlags.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SampleCount | Gets or sets sample count for the DataFrame.
Public property | SampleSynchronization | Gets or sets IEC 61850-90-5 sample synchronization state.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this DataFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEC 61850-90-5 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Overload List
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame, String, Int32, Byte, UInt32) | Creates a new DataFrame from specified parameters.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Creates a new DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> DataFrame
GSF.PhasorProtocols.IEC61850_90_5.DataFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
DataFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEC 61850-90-5 data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrame Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrame
GSF.PhasorProtocols.IEC61850_90_5.DataFrame = function(info, context);
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame Constructor (Ticks, ConfigurationFrame, String, Int32, Byte[][], UInt32)

Grid Solutions Framework DataFrame Constructor (Ticks, ConfigurationFrame, String, Int32, Byte, UInt32)
Creates a new DataFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame configurationFrame,
    string msvID,
    int asduCount,
    byte[][] asduImages,
    uint configurationRevision
)
Public Sub New (
    timestamp As Ticks,
    configurationFrame As ConfigurationFrame,
    msvID As String,
    asduCount As Integer,
    asduImages As Byte()(),
    configurationRevision As UInteger
)
new :
        timestamp : Ticks *
        configurationFrame : ConfigurationFrame *
        msvID : string *
        asduCount : int *
        asduImages : byte[][] *
        configurationRevision : uint32 -> DataFrame
GSF.PhasorProtocols.IEC61850_90_5.DataFrame = function(timestamp, configurationFrame, msvID, asduCount, asduImages, configurationRevision);
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame^ configurationFrame,
    String^ msvID,
    int asduCount,
    array<array<unsigned char>^>^ asduImages,
    unsigned int configurationRevision
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationFrame
The ConfigurationFrame associated with this DataFrame.
msvID
Type: SystemString
MSVID to use for DataFrame.
asduCount
Type: SystemInt32
ASDU count.
asduImages
Type: SystemByte
Concentrator's ASDU image cache.
configurationRevision
Type: SystemUInt32
Configuration revision.
Remarks
This constructor is used by a consumer to generate an IEC 61850-90-5 data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame Methods

Grid Solutions Framework DataFrame Methods

The DataFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides DataFrameBaseParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.CalculateChecksum Method

Grid Solutions Framework DataFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.ChecksumIsValid Method

Grid Solutions Framework DataFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.GetObjectData Method

Grid Solutions Framework DataFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.ParseBinaryImage Method

Grid Solutions Framework DataFrameParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame Properties

Grid Solutions Framework DataFrame Properties

The DataFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this DataFrame object. (Overrides ChannelFrameBaseTBinaryImage.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the DataFrame object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the header image. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrame. (Overrides DataFrameBaseQualityFlags.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SampleCount | Gets or sets sample count for the DataFrame.
Public property | SampleSynchronization | Gets or sets IEC 61850-90-5 sample synchronization state.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this DataFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEC 61850-90-5 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.Attributes Property

Grid Solutions Framework DataFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.BinaryImage Property

Grid Solutions Framework DataFrameBinaryImage Property
Gets the binary image of this DataFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] BinaryImage { get; }
Public Overrides ReadOnly Property BinaryImage As Byte()
    Get
abstract BinaryImage : byte[] with get
override BinaryImage : byte[] with get
function get_BinaryImage();

public:
virtual property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.BinaryLength Property

Grid Solutions Framework DataFrameBinaryLength Property
Gets the length of the BinaryImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.Cells Property

Grid Solutions Framework DataFrameCells Property
Gets reference to the DataCellCollection for this DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
member Cells : DataCellCollection with get

function get_Cells();

public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.CommonHeader Property

Grid Solutions Framework DataFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.ConfigurationFrame Property

Grid Solutions Framework DataFrameConfigurationFrame Property
Gets or sets ConfigurationFrame associated with this DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
member ConfigurationFrame : ConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.FooterImage Property

Grid Solutions Framework DataFrameFooterImage Property
Gets the binary footer image of the DataFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.FooterLength Property

Grid Solutions Framework DataFrameFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.HeaderImage Property

Grid Solutions Framework DataFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.HeaderLength Property

Grid Solutions Framework DataFrameHeaderLength Property
Gets the length of the header image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.QualityFlags Property

Grid Solutions Framework DataFrameQualityFlags Property
Gets or sets protocol specific quality flags for this DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override uint QualityFlags { get; set; }
Public Overrides Property QualityFlags As UInteger
    Get
    Set
abstract QualityFlags : uint32 with get, set
override QualityFlags : uint32 with get, set
function get_QualityFlags();
function set_QualityFlags(value);
public:
virtual property unsigned int QualityFlags {
    unsigned int get () override;
    void set (unsigned int value) override;
}

Property Value

Type: UInt32

Implements

IDataFrameQualityFlags
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.SampleCount Property

Grid Solutions Framework DataFrameSampleCount Property
Gets or sets sample count for the DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleCount { get; set; }
Public Property SampleCount As UShort
    Get
    Set
member SampleCount : uint16 with get, set

function get_SampleCount();
function set_SampleCount(value);
public:
property unsigned short SampleCount {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.SampleSynchronization Property

Grid Solutions Framework DataFrameSampleSynchronization Property
Gets or sets IEC 61850-90-5 sample synchronization state.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte SampleSynchronization { get; set; }
Public Property SampleSynchronization As Byte
    Get
    Set
member SampleSynchronization : byte with get, set

function get_SampleSynchronization();
function set_SampleSynchronization(value);
public:
property unsigned char SampleSynchronization {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.TimeQualityFlags Property

Grid Solutions Framework DataFrameTimeQualityFlags Property
Gets or sets the TimeQualityFlags associated with this DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
member TimeQualityFlags : TimeQualityFlags with get, set

function get_TimeQualityFlags();
function set_TimeQualityFlags(value);
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}

Property Value

Type: TimeQualityFlags
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.TimeQualityIndicatorCode Property

Grid Solutions Framework DataFrameTimeQualityIndicatorCode Property
Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
member TimeQualityIndicatorCode : TimeQualityIndicatorCode with get, set

function get_TimeQualityIndicatorCode();
function set_TimeQualityIndicatorCode(value);
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}

Property Value

Type: TimeQualityIndicatorCode
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.Timestamp Property

Grid Solutions Framework DataFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DataFrame.TypeID Property

Grid Solutions Framework DataFrameTypeID Property
Gets the identifier that is used to identify the IEC 61850-90-5 frame.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition Class

Grid Solutions Framework DigitalDefinition Class
Represents the IEC 61850-90-5 implementation of a IDigitalDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocols.IEC61850_90_5DigitalDefinition

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute>
Public Class DigitalDefinition
    Inherits DigitalDefinitionBase
[<SerializableAttribute>]
type DigitalDefinition =
    class
        inherit DigitalDefinitionBase
    end
GSF.PhasorProtocols.IEC61850_90_5.DigitalDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.DigitalDefinition',
    GSF.PhasorProtocols.DigitalDefinitionBase);
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase

The DigitalDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String, UInt16, UInt16) | Creates a new DigitalDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetLabel | Gets the individual labels for specified bit in this DigitalDefinition.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetLabel | Sets the individual labels for specified bit in this DigitalDefinition.
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | DraftRevision | Gets the DraftRevision of this DigitalDefinition.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the combined set of label images of this DigitalDefinition. (Overrides ChannelDefinitionBaseLabel.)
Public property | LabelCount | Gets the number of labels defined in this DigitalDefinition.
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NormalStatus | Gets or sets normal status for this DigitalDefinition.
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition Constructor

Grid Solutions Framework DigitalDefinition Constructor
Overload List
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String, UInt16, UInt16) | Creates a new DigitalDefinition from specified parameters.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition Constructor (IConfigurationCell)

Grid Solutions Framework DigitalDefinition Constructor (IConfigurationCell)
Creates a new DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> DigitalDefinition
GSF.PhasorProtocols.IEC61850_90_5.DigitalDefinition = function(parent);
public:
DigitalDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinition
GSF.PhasorProtocols.IEC61850_90_5.DigitalDefinition = function(info, context);
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition Constructor (ConfigurationCell, String, UInt16, UInt16)

Grid Solutions Framework DigitalDefinition Constructor (ConfigurationCell, String, UInt16, UInt16)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    ConfigurationCell parent,
    string label,
    ushort normalStatus,
    ushort validInputs
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    normalStatus As UShort,
    validInputs As UShort
)
new :
        parent : ConfigurationCell *
        label : string *
        normalStatus : uint16 *
        validInputs : uint16 -> DigitalDefinition
GSF.PhasorProtocols.IEC61850_90_5.DigitalDefinition = function(parent, label, normalStatus, validInputs);
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned short normalStatus,
    unsigned short validInputs
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationCell
The ConfigurationCell parent of this DigitalDefinition.
label
Type: SystemString
The label of this DigitalDefinition.
normalStatus
Type: SystemUInt16
The normal status for this DigitalDefinition.
validInputs
Type: SystemUInt16
The valid input for this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition Methods

Grid Solutions Framework DigitalDefinition Methods

The DigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetLabel | Gets the individual labels for specified bit in this DigitalDefinition.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetLabel | Sets the individual labels for specified bit in this DigitalDefinition.
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.GetLabel Method

Grid Solutions Framework DigitalDefinitionGetLabel Method
Gets the individual labels for specified bit in this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetLabel(
    int index
)
Public Function GetLabel (
    index As Integer
) As String
member GetLabel :
        index : int -> string

function GetLabel(index);
public:
String^ GetLabel(
    int index
)

Parameters

index
Type: SystemInt32
Index of desired bit label to access.

Return Value

Type: String
A String value of the label corresponding to the parameter.
Remarks

In the final version of the protocol each digital bit can be labeled, but we read them out as one big string in the "Label" property so this property allows individual access to each label.

Note that the draft 6 implementation of the protocol supports one label for all 16-bits, however draft 7 (i.e., version 1) supports a label for each of the 16 bits.

See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.GetObjectData Method

Grid Solutions Framework DigitalDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.ParseBodyImage Method

Grid Solutions Framework DigitalDefinitionParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.SetLabel Method

Grid Solutions Framework DigitalDefinitionSetLabel Method
Sets the individual labels for specified bit in this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetLabel(
    int index,
    string value
)
Public Sub SetLabel (
    index As Integer,
    value As String
)
member SetLabel :
        index : int *
        value : string -> unit

function SetLabel(index, value);
public:
void SetLabel(
    int index,
    String^ value
)

Parameters

index
Type: SystemInt32
Index of desired bit label to access.
value
Type: SystemString
Value of the bit label to assign.
Remarks

In the final version of the protocol each digital bit can be labeled, but we read them out as one big string in the "Label" property so this property allows individual access to each label.

Note that the draft 6 implementation of the protocol supports one label for all 16-bits, however draft 7 (i.e., version 1) supports a label for each of the 16 bits.

See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition Properties

Grid Solutions Framework DigitalDefinition Properties

The DigitalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | DraftRevision | Gets the DraftRevision of this DigitalDefinition.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the combined set of label images of this DigitalDefinition. (Overrides ChannelDefinitionBaseLabel.)
Public property | LabelCount | Gets the number of labels defined in this DigitalDefinition.
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NormalStatus | Gets or sets normal status for this DigitalDefinition.
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.Attributes Property

Grid Solutions Framework DigitalDefinitionAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.DraftRevision Property

Grid Solutions Framework DigitalDefinitionDraftRevision Property
Gets the DraftRevision of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DraftRevision DraftRevision { get; }
Public ReadOnly Property DraftRevision As DraftRevision
    Get
member DraftRevision : DraftRevision with get

function get_DraftRevision();

public:
property DraftRevision DraftRevision {
    DraftRevision get ();
}

Property Value

Type: DraftRevision
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.Label Property

Grid Solutions Framework DigitalDefinitionLabel Property
Gets or sets the combined set of label images of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override string Label { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property Label As String
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Label : string with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Label : string with get, set
function get_Label();
function set_Label(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property String^ Label {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String

Implements

IChannelDefinitionLabel
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.LabelCount Property

Grid Solutions Framework DigitalDefinitionLabelCount Property
Gets the number of labels defined in this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LabelCount { get; }
Public ReadOnly Property LabelCount As Integer
    Get
member LabelCount : int with get

function get_LabelCount();

public:
property int LabelCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.MaximumLabelLength Property

Grid Solutions Framework DigitalDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.NormalStatus Property

Grid Solutions Framework DigitalDefinitionNormalStatus Property
Gets or sets normal status for this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort NormalStatus { get; set; }
Public Property NormalStatus As UShort
    Get
    Set
member NormalStatus : uint16 with get, set

function get_NormalStatus();
function set_NormalStatus(value);
public:
property unsigned short NormalStatus {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.Parent Property

Grid Solutions Framework DigitalDefinitionParent Property
Gets or sets the ConfigurationCell parent of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalDefinition.ValidInputs Property

Grid Solutions Framework DigitalDefinitionValidInputs Property
Gets or sets valid input for this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ValidInputs { get; set; }
Public Property ValidInputs As UShort
    Get
    Set
member ValidInputs : uint16 with get, set

function get_ValidInputs();
function set_ValidInputs(value);
public:
property unsigned short ValidInputs {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue Class

Grid Solutions Framework DigitalValue Class
Represents the IEC 61850-90-5 implementation of a IDigitalValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IDigitalDefinition
GSF.PhasorProtocolsDigitalValueBase
GSF.PhasorProtocols.IEC61850_90_5DigitalValue

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute>
Public Class DigitalValue
    Inherits DigitalValueBase
[<SerializableAttribute>]
type DigitalValue =
    class
        inherit DigitalValueBase
    end
GSF.PhasorProtocols.IEC61850_90_5.DigitalValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.DigitalValue',
    GSF.PhasorProtocols.DigitalValueBase);
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase

The DigitalValue type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue Constructor

Grid Solutions Framework DigitalValue Constructor
Overload List
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalValue Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalValue
GSF.PhasorProtocols.IEC61850_90_5.DigitalValue = function(info, context);
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue Constructor (IDataCell, IDigitalDefinition)

Grid Solutions Framework DigitalValue Constructor (IDataCell, IDigitalDefinition)
Creates a new DigitalValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New (
    parent As IDataCell,
    digitalDefinition As IDigitalDefinition
)
new :
        parent : IDataCell *
        digitalDefinition : IDigitalDefinition -> DigitalValue
GSF.PhasorProtocols.IEC61850_90_5.DigitalValue = function(parent, digitalDefinition);
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocolsIDigitalDefinition
The IDigitalDefinition associated with this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)

Grid Solutions Framework DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New (
    parent As DataCell,
    digitalDefinition As DigitalDefinition,
    value As UShort
)
new :
        parent : DataCell *
        digitalDefinition : DigitalDefinition *
        value : uint16 -> DigitalValue
GSF.PhasorProtocols.IEC61850_90_5.DigitalValue = function(parent, digitalDefinition, value);
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5DataCell
The DataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocols.IEC61850_90_5DigitalDefinition
The DigitalDefinition associated with this DigitalValue.
value
Type: SystemUInt16
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue Methods

Grid Solutions Framework DigitalValue Methods

The DigitalValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue Properties

Grid Solutions Framework DigitalValue Properties

The DigitalValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue.Definition Property

Grid Solutions Framework DigitalValueDefinition Property
Gets or sets the DigitalDefinition associated with this DigitalValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
abstract Definition : DigitalDefinition with get, set
override Definition : DigitalDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}

Property Value

Type: DigitalDefinition
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DigitalValue.Parent Property

Grid Solutions Framework DigitalValueParent Property
Gets or sets the DataCell parent of this DigitalValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


DraftRevision Enumeration

Grid Solutions Framework DraftRevision Enumeration
Protocol draft revision numbers enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DraftRevision
<SerializableAttribute>
Public Enumeration DraftRevision
[<SerializableAttribute>]
type DraftRevision
GSF.PhasorProtocols.IEC61850_90_5.DraftRevision = function();
GSF.PhasorProtocols.IEC61850_90_5.DraftRevision.createEnum('GSF.PhasorProtocols.IEC61850_90_5.DraftRevision', false);
[SerializableAttribute]
public enum class DraftRevision
Members
Member name | Value | Description
Draft6 | 0 | Draft 6.0.
Draft7 | 1 | Draft 7.0 (Version 1.0).
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


FormatFlags Enumeration

Grid Solutions Framework FormatFlags Enumeration
Data format flags enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum FormatFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration FormatFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type FormatFlags
GSF.PhasorProtocols.IEC61850_90_5.FormatFlags = function();
GSF.PhasorProtocols.IEC61850_90_5.FormatFlags.createEnum('GSF.PhasorProtocols.IEC61850_90_5.FormatFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class FormatFlags
Members
Member name | Value | Description
Frequency | 8 | Frequency value format (Set = float, Clear = integer).
Analog | 4 | Analog value format (Set = float, Clear = integer).
Phasors | 2 | Phasor value format (Set = float, Clear = integer).
Coordinates | 1 | Phasor coordinate format (Set = polar, Clear = rectangular).
UnusedMask | 65520 | Unsed format bits mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser Class

Grid Solutions Framework FrameParser Class
Represents a frame parser for an IEC 61850-90-5 binary data stream and returns parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.PhasorProtocolsFrameParserBase FrameType
GSF.PhasorProtocols.IEC61850_90_5FrameParser

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser
    Inherits FrameParserBase(Of FrameType)
type FrameParser =
    class
        inherit FrameParserBase<FrameType>
    end
GSF.PhasorProtocols.IEC61850_90_5.FrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.FrameParser',
    GSF.PhasorProtocols.FrameParserBase`1);
public ref class FrameParser : public FrameParserBase<FrameType>

The FrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | FrameParser | Creates a new FrameParser.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame or CommandFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedDataFrame(IDataFrame).)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Overrides FrameParserBaseTFrameIdentifierOnUnknownFrameTypeEncountered(TFrameIdentifier).)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Overrides FrameParserBaseTFrameIdentifierRedundantFramesPerPacket.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | Timebase | Gets the IEC 61850-90-5 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when an IEC 61850-90-5 CommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when an IEC 61850-90-5 ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when an IEC 61850-90-5 DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser Constructor

Grid Solutions Framework FrameParser Constructor
Creates a new FrameParser.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    bool trustHeaderLength = true
)
Public Sub New (
    Optional checkSumValidationFrameTypes As CheckSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    Optional trustHeaderLength As Boolean = true
)
new :
        ?checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        ?trustHeaderLength : bool
(* Defaults:
        let _checkSumValidationFrameTypes = defaultArg checkSumValidationFrameTypes CheckSumValidationFrameTypes.AllFrames
        let _trustHeaderLength = defaultArg trustHeaderLength true
*)
-> FrameParser
GSF.PhasorProtocols.IEC61850_90_5.FrameParser = function(checkSumValidationFrameTypes, trustHeaderLength);
public:
FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes::AllFrames,
    bool trustHeaderLength = true
)

Parameters

checkSumValidationFrameTypes (Optional)
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength (Optional)
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser Fields

Grid Solutions Framework FrameParser Fields

The FrameParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser Methods

Grid Solutions Framework FrameParser Methods

The FrameParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame or CommandFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedDataFrame(IDataFrame).)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Overrides FrameParserBaseTFrameIdentifierOnUnknownFrameTypeEncountered(TFrameIdentifier).)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame or CommandFrame).

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.OnReceivedConfigurationFrame Method

Grid Solutions Framework FrameParserOnReceivedConfigurationFrame Method
Raises the ReceivedConfigurationFrame event.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame (
    frame As IConfigurationFrame
)
abstract OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
override OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
function OnReceivedConfigurationFrame(frame);
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIConfigurationFrame
IConfigurationFrame to send to ReceivedConfigurationFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.OnReceivedDataFrame Method

Grid Solutions Framework FrameParserOnReceivedDataFrame Method
Raises the ReceivedDataFrame event.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedDataFrame(
    IDataFrame frame
)
Protected Overrides Sub OnReceivedDataFrame (
    frame As IDataFrame
)
abstract OnReceivedDataFrame :
        frame : IDataFrame -> unit
override OnReceivedDataFrame :
        frame : IDataFrame -> unit
function OnReceivedDataFrame(frame);
protected:
virtual void OnReceivedDataFrame(
    IDataFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIDataFrame
IDataFrame to send to ReceivedDataFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.OnUnknownFrameTypeEncountered Method

Grid Solutions Framework FrameParserOnUnknownFrameTypeEncountered Method
Handles unknown frame types.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnUnknownFrameTypeEncountered(
    FrameType frameType
)
Protected Overrides Sub OnUnknownFrameTypeEncountered (
    frameType As FrameType
)
abstract OnUnknownFrameTypeEncountered :
        frameType : FrameType -> unit
override OnUnknownFrameTypeEncountered :
        frameType : FrameType -> unit
function OnUnknownFrameTypeEncountered(frameType);
protected:
virtual void OnUnknownFrameTypeEncountered(
    FrameType frameType
) override

Parameters

frameType
Type: GSF.PhasorProtocols.IEC61850_90_5FrameType
Unknown frame ID.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.ParseCommonHeader Method

Grid Solutions Framework FrameParserParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of FrameType)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader FrameType
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Start the data parser.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

FrameParser Class
Start Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser Properties

Grid Solutions Framework FrameParser Properties

The FrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Overrides FrameParserBaseTFrameIdentifierRedundantFramesPerPacket.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | Timebase | Gets the IEC 61850-90-5 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.ConfigurationFrame Property

Grid Solutions Framework FrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.ConnectionParameters Property

Grid Solutions Framework FrameParserConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set
override ConnectionParameters : IConnectionParameters with get, set
function get_ConnectionParameters();
function set_ConnectionParameters(value);
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}

Property Value

Type: IConnectionParameters

Implements

IFrameParserConnectionParameters
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework FrameParserProtocolUsesSyncBytes Property
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.RedundantFramesPerPacket Property

Grid Solutions Framework FrameParserRedundantFramesPerPacket Property
Gets the number of redundant frames in each packet.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int RedundantFramesPerPacket { get; }
Public Overrides ReadOnly Property RedundantFramesPerPacket As Integer
    Get
abstract RedundantFramesPerPacket : int with get
override RedundantFramesPerPacket : int with get
function get_RedundantFramesPerPacket();

public:
virtual property int RedundantFramesPerPacket {
    int get () override;
}

Property Value

Type: Int32

Implements

IFrameParserRedundantFramesPerPacket
Remarks
This value is used when calculating statistics. It is assumed that for each frame that is received, that frame will be included in the next n packets, where n is the number of redundant frames per packet.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.Status Property

Grid Solutions Framework FrameParserStatus Property
Gets current descriptive status of the FrameParser.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.Timebase Property

Grid Solutions Framework FrameParserTimebase Property
Gets the IEC 61850-90-5 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Timebase { get; }
Public ReadOnly Property Timebase As UInteger
    Get
member Timebase : uint32 with get

function get_Timebase();

public:
property unsigned int Timebase {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser Events

Grid Solutions Framework FrameParser Events

The FrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when an IEC 61850-90-5 CommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when an IEC 61850-90-5 ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when an IEC 61850-90-5 DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.ReceivedCommandFrame Event

Grid Solutions Framework FrameParserReceivedCommandFrame Event
Occurs when an IEC 61850-90-5 CommandFrame has been received.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<CommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of CommandFrame))
member ReceivedCommandFrame : IEvent<EventHandler<EventArgs<CommandFrame>>,
    EventArgs<CommandFrame>>

function add_ReceivedCommandFrame(value);
function remove_ReceivedCommandFrame(value);
public:
 event EventHandler<EventArgs<CommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<CommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<CommandFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs CommandFrame
Remarks
Argument is the CommandFrame that was received.

Command frames are normally sent, not received, but there is nothing that prevents this.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame Event
Occurs when an IEC 61850-90-5 ConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
member ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<ConfigurationFrame>>,
    EventArgs<ConfigurationFrame>>

function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame
Remarks
Argument is the ConfigurationFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameParser.ReceivedDataFrame Event

Grid Solutions Framework FrameParserReceivedDataFrame Event
Occurs when an IEC 61850-90-5 DataFrame has been received.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
member ReceivedDataFrame : IEvent<EventHandler<EventArgs<DataFrame>>,
    EventArgs<DataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataFrame
Remarks
Argument is the DataFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrameType Enumeration

Grid Solutions Framework FrameType Enumeration
IEC 61850-90-5 frame types enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FrameType
<SerializableAttribute>
Public Enumeration FrameType
[<SerializableAttribute>]
type FrameType
GSF.PhasorProtocols.IEC61850_90_5.FrameType = function();
GSF.PhasorProtocols.IEC61850_90_5.FrameType.createEnum('GSF.PhasorProtocols.IEC61850_90_5.FrameType', false);
[SerializableAttribute]
public enum class FrameType
Members
Member name | Value | Description
DataFrame | 0 | 000 Data frame.
ConfigurationFrame | 48 | 011 Configuration frame.
CommandFrame | 64 | 100 Command frame.
VersionNumberMask | 15 | Version number mask.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents the IEC 61850-90-5 implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.IEC61850_90_5FrequencyDefinition

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.IEC61850_90_5.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinition Constructor (IConfigurationCell)
Creates a new FrequencyDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinition
GSF.PhasorProtocols.IEC61850_90_5.FrequencyDefinition = function(parent);
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.IEC61850_90_5.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> FrequencyDefinition
GSF.PhasorProtocols.IEC61850_90_5.FrequencyDefinition = function(parent, label);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
label
Type: SystemString
The label of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition.ParseBodyImage Method

Grid Solutions Framework FrequencyDefinitionParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The base implementation assumes that all channel definitions begin with a label as this is the general case, override functionality if this is not the case.
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition.BodyImage Property

Grid Solutions Framework FrequencyDefinitionBodyImage Property
Gets the binary body image of the FrequencyDefinition object.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition.BodyLength Property

Grid Solutions Framework FrequencyDefinitionBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue Class

Grid Solutions Framework FrequencyValue Class
Represents the IEC 61850-90-5 implementation of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.IEC61850_90_5FrequencyValue

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute>
Public Class FrequencyValue
    Inherits FrequencyValueBase
[<SerializableAttribute>]
type FrequencyValue =
    class
        inherit FrequencyValueBase
    end
GSF.PhasorProtocols.IEC61850_90_5.FrequencyValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.FrequencyValue',
    GSF.PhasorProtocols.FrequencyValueBase);
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase

The FrequencyValue type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from FrequencyValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue Constructor

Grid Solutions Framework FrequencyValue Constructor
Overload List
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValue Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValue
GSF.PhasorProtocols.IEC61850_90_5.FrequencyValue = function(info, context);
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValue Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValue
GSF.PhasorProtocols.IEC61850_90_5.FrequencyValue = function(parent, frequencyDefinition);
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValue.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New (
    parent As DataCell,
    frequencyDefinition As FrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : DataCell *
        frequencyDefinition : FrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValue
GSF.PhasorProtocols.IEC61850_90_5.FrequencyValue = function(parent, frequencyDefinition, frequency, dfdt);
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5DataCell
The DataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocols.IEC61850_90_5FrequencyDefinition
The FrequencyDefinition associated with this FrequencyValue.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValue.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValue over time.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue Methods

Grid Solutions Framework FrequencyValue Methods

The FrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from FrequencyValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue Properties

Grid Solutions Framework FrequencyValue Properties

The FrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue.Definition Property

Grid Solutions Framework FrequencyValueDefinition Property
Gets or sets the FrequencyDefinition associated with this FrequencyValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
abstract Definition : FrequencyDefinition with get, set
override Definition : FrequencyDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}

Property Value

Type: FrequencyDefinition
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


FrequencyValue.Parent Property

Grid Solutions Framework FrequencyValueParent Property
Gets or sets the DataCell parent of this FrequencyValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents the IEC 61850-90-5 implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.IEC61850_90_5PhasorDefinition

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.IEC61850_90_5.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinition Constructor (IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinition
GSF.PhasorProtocols.IEC61850_90_5.PhasorDefinition = function(parent);
public:
PhasorDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinition.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.IEC61850_90_5.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.IEC61850_90_5.PhasorDefinition = function(parent, label, scale, offset, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5ConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
scale
Type: SystemUInt32
The integer scaling value of this PhasorDefinition.
offset
Type: SystemDouble
The offset of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.IEC61850_90_5PhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Class

Grid Solutions Framework PhasorValue Class
Represents the IEC 61850-90-5 implementation of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.IEC61850_90_5PhasorValue

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute>
Public Class PhasorValue
    Inherits PhasorValueBase
[<SerializableAttribute>]
type PhasorValue =
    class
        inherit PhasorValueBase
    end
GSF.PhasorProtocols.IEC61850_90_5.PhasorValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEC61850_90_5.PhasorValue',
    GSF.PhasorProtocols.PhasorValueBase);
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase

The PhasorValue type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Constructor

Grid Solutions Framework PhasorValue Constructor
Overload List
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValue Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValue
GSF.PhasorProtocols.IEC61850_90_5.PhasorValue = function(info, context);
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValue Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValue
GSF.PhasorProtocols.IEC61850_90_5.PhasorValue = function(parent, phasorDefinition);
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValue
GSF.PhasorProtocols.IEC61850_90_5.PhasorValue = function(parent, phasorDefinition, angle, magnitude);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5DataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.IEC61850_90_5PhasorDefinition
The PhasorDefinition associated with this PhasorValue.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        real : float *
        imaginary : float -> PhasorValue
GSF.PhasorProtocols.IEC61850_90_5.PhasorValue = function(parent, phasorDefinition, real, imaginary);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocols.IEC61850_90_5DataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.IEC61850_90_5PhasorDefinition
The PhasorDefinition associated with this PhasorValue.
real
Type: SystemDouble
The real value of this PhasorValue.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Methods

Grid Solutions Framework PhasorValue Methods

The PhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue Properties

Grid Solutions Framework PhasorValue Properties

The PhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue.Definition Property

Grid Solutions Framework PhasorValueDefinition Property
Gets or sets the PhasorDefinition associated with this PhasorValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
abstract Definition : PhasorDefinition with get, set
override Definition : PhasorDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}

Property Value

Type: PhasorDefinition
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


PhasorValue.Parent Property

Grid Solutions Framework PhasorValueParent Property
Gets or sets the DataCell parent of this PhasorValue.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEC61850_90_5 Namespace


SampledValueTag Enumeration

Grid Solutions Framework SampledValueTag Enumeration
Sampled value tags.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SampledValueTag
Public Enumeration SampledValueTag
type SampledValueTag
GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag = function();
GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag.createEnum('GSF.PhasorProtocols.IEC61850_90_5.SampledValueTag', false);
public enum class SampledValueTag
Members
Member name | Value | Description
SvPdu | 96 | Sampled value protocol data unit.
AsduCount | 128 | Number of ASDUs.
SequenceOfAsdu | 162 | Sequence of ASDU.
AsduSequence | 48 | ASDU sequence number.
MsvID | 128 | Multicast sampled value identifier.
Dataset | 129 | Data set.
SmpCnt | 130 | Sample Count
ConfRev | 131 | Configuration revision.
RefrTm | 132 | Local refresh time.
SmpSynch | 133 | Samples are synchronized.
SmpRate | 134 | Sample rate.
Samples | 135 | Data samples.
SmpMod | 136 | Sample mod.
UtcTimestamp | 137 | UTC Timestamp.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


SecurityAlgorithm Enumeration

Grid Solutions Framework SecurityAlgorithm Enumeration
IEC 61850-90-5 security algorithm.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SecurityAlgorithm
Public Enumeration SecurityAlgorithm
type SecurityAlgorithm
GSF.PhasorProtocols.IEC61850_90_5.SecurityAlgorithm = function();
GSF.PhasorProtocols.IEC61850_90_5.SecurityAlgorithm.createEnum('GSF.PhasorProtocols.IEC61850_90_5.SecurityAlgorithm', false);
public enum class SecurityAlgorithm
Members
Member name | Value | Description
None | 0 | No algorithm used
Aes128 | 1 | AES 128
Aes256 | 2 | AES 256
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


SessionType Enumeration

Grid Solutions Framework SessionType Enumeration
IEC 61850-90-5 session types.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SessionType
Public Enumeration SessionType
type SessionType
GSF.PhasorProtocols.IEC61850_90_5.SessionType = function();
GSF.PhasorProtocols.IEC61850_90_5.SessionType.createEnum('GSF.PhasorProtocols.IEC61850_90_5.SessionType', false);
public enum class SessionType
Members
Member name | Value | Description
Tunnelled | 160 | Tunnelled values.
Goose | 161 | Goose values.
SampledValues | 162 | Sampled values.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


SignatureAlgorithm Enumeration

Grid Solutions Framework SignatureAlgorithm Enumeration
IEC 61850-90-5 signature algorithm.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SignatureAlgorithm
Public Enumeration SignatureAlgorithm
type SignatureAlgorithm
GSF.PhasorProtocols.IEC61850_90_5.SignatureAlgorithm = function();
GSF.PhasorProtocols.IEC61850_90_5.SignatureAlgorithm.createEnum('GSF.PhasorProtocols.IEC61850_90_5.SignatureAlgorithm', false);
public enum class SignatureAlgorithm
Members
Member name | Value | Description
None | 0 | No algorithm used
Sha80 | 1 | SHA 256/80
Sha128 | 2 | SHA 256/128
Sha256 | 3 | SHA 256/256
Aes64 | 4 | AES GMAC 64
Aes128 | 5 | AES GMAC 128
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


StatusFlags Enumeration

Grid Solutions Framework StatusFlags Enumeration
Status flags enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum StatusFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration StatusFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type StatusFlags
GSF.PhasorProtocols.IEC61850_90_5.StatusFlags = function();
GSF.PhasorProtocols.IEC61850_90_5.StatusFlags.createEnum('GSF.PhasorProtocols.IEC61850_90_5.StatusFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class StatusFlags
Members
Member name | Value | Description
DataIsValid | 32768 | Data is valid (0 when device data is valid, 1 when invalid or device is in test mode).
DeviceError | 16384 | Device error including configuration error, 0 when no error.
DeviceSynchronizationError | 8192 | Device synchronization error, 0 when in sync.
DataSortingType | 4096 | Data sorting type, 0 by timestamp, 1 by arrival.
DeviceTriggerDetected | 2048 | Device trigger detected, 0 when no trigger.
ConfigurationChanged | 1024 | Configuration changed, set to 1 for one minute when configuration changed.
ReservedFlags | 960 | Reserved bits for security, presently set to 0.
UnlockedTimeMask | 48 | Unlocked time mask.
TriggerReasonMask | 15 | Trigger reason mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


TimeQualityFlags Enumeration

Grid Solutions Framework TimeQualityFlags Enumeration
Time quality flags enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum TimeQualityFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration TimeQualityFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type TimeQualityFlags
GSF.PhasorProtocols.IEC61850_90_5.TimeQualityFlags = function();
GSF.PhasorProtocols.IEC61850_90_5.TimeQualityFlags.createEnum('GSF.PhasorProtocols.IEC61850_90_5.TimeQualityFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class TimeQualityFlags
Members
Member name | Value | Description
Reserved | 2147483648 | Reserved bit.
LeapSecondDirection | 1073741824 | Leap second direction – 0 for add, 1 for delete.
LeapSecondOccurred | 536870912 | Leap second occurred – set in the first second after the leap second occurs and remains set for 24 hours.
LeapSecondPending | 268435456 | Leap second pending – set before a leap second occurs and cleared in the second after the leap second occurs.
TimeQualityIndicatorCodeMask | 251658240 | Time quality indicator code mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


TimeQualityIndicatorCode Enumeration

Grid Solutions Framework TimeQualityIndicatorCode Enumeration
Time quality indicator code enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum TimeQualityIndicatorCode
<SerializableAttribute>
Public Enumeration TimeQualityIndicatorCode
[<SerializableAttribute>]
type TimeQualityIndicatorCode
GSF.PhasorProtocols.IEC61850_90_5.TimeQualityIndicatorCode = function();
GSF.PhasorProtocols.IEC61850_90_5.TimeQualityIndicatorCode.createEnum('GSF.PhasorProtocols.IEC61850_90_5.TimeQualityIndicatorCode', false);
[SerializableAttribute]
public enum class TimeQualityIndicatorCode
Members
Member name | Value | Description
Failure | 251658240 | 1111 - 0xF: Fault--clock failure, time not reliable.
UnlockedWithin10Seconds | 184549376 | 1011 - 0xB: Clock unlocked, time within 10^1 s.
UnlockedWithin1Second | 167772160 | 1010 - 0xA: Clock unlocked, time within 10^0 s.
UnlockedWithinPoint1Seconds | 150994944 | 1001 - 0x9: Clock unlocked, time within 10^-1 s.
UnlockedWithinPoint01Seconds | 134217728 | 1000 - 0x8: Clock unlocked, time within 10^-2 s.
UnlockedWithinPoint001Seconds | 117440512 | 0111 - 0x7: Clock unlocked, time within 10^-3 s.
UnlockedWithinPoint0001Seconds | 100663296 | 0110 - 0x6: Clock unlocked, time within 10^-4 s.
UnlockedWithinPoint00001Seconds | 83886080 | 0101 - 0x5: Clock unlocked, time within 10^-5 s.
UnlockedWithinPoint000001Seconds | 67108864 | 0100 - 0x4: Clock unlocked, time within 10^-6 s.
UnlockedWithinPoint0000001Seconds | 50331648 | 0011 - 0x3: Clock unlocked, time within 10^-7 s.
UnlockedWithinPoint00000001Seconds | 33554432 | 0010 - 0x2: Clock unlocked, time within 10^-8 s.
UnlockedWithinPoint000000001Seconds | 16777216 | 0001 - 0x1: Clock unlocked, time within 10^-9 s.
Locked | 0 | 0000 - 0x0: Normal operation, clock locked.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


TriggerReason Enumeration

Grid Solutions Framework TriggerReason Enumeration
Trigger reason enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum TriggerReason
<SerializableAttribute>
Public Enumeration TriggerReason
[<SerializableAttribute>]
type TriggerReason
GSF.PhasorProtocols.IEC61850_90_5.TriggerReason = function();
GSF.PhasorProtocols.IEC61850_90_5.TriggerReason.createEnum('GSF.PhasorProtocols.IEC61850_90_5.TriggerReason', false);
[SerializableAttribute]
public enum class TriggerReason
Members
Member name | Value | Description
VendorDefinedTrigger8 | 15 | 1111 Vendor defined trigger 8.
VendorDefinedTrigger7 | 14 | 1110 Vendor defined trigger 7.
VendorDefinedTrigger6 | 13 | 1101 Vendor defined trigger 6.
VendorDefinedTrigger5 | 12 | 1100 Vendor defined trigger 5.
VendorDefinedTrigger4 | 11 | 1011 Vendor defined trigger 4.
VendorDefinedTrigger3 | 10 | 1010 Vendor defined trigger 3.
VendorDefinedTrigger2 | 9 | 1001 Vendor defined trigger 2.
VendorDefinedTrigger1 | 8 | 1000 Vendor defined trigger 1.
Digital | 7 | 0111 Digital.
DfDtHigh | 5 | 0101 df/dt high.
PhaseAngleDifference | 3 | 0011 Phase angle difference.
MagnitudeLow | 1 | 0001 Magnitude low.
Reserved | 6 | 0110 Reserved.
FrequencyHighOrLow | 4 | 0100 Frequency high/low.
MagnitudeHigh | 2 | 0010 Magnitude high.
Manual | 0 | 0000 Manual.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


UnlockedTime Enumeration

Grid Solutions Framework UnlockedTime Enumeration
Unlocked time enumeration.

Namespace: GSF.PhasorProtocols.IEC61850_90_5
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum UnlockedTime
<SerializableAttribute>
Public Enumeration UnlockedTime
[<SerializableAttribute>]
type UnlockedTime
GSF.PhasorProtocols.IEC61850_90_5.UnlockedTime = function();
GSF.PhasorProtocols.IEC61850_90_5.UnlockedTime.createEnum('GSF.PhasorProtocols.IEC61850_90_5.UnlockedTime', false);
[SerializableAttribute]
public enum class UnlockedTime
Members
Member name | Value | Description
SyncLocked | 0 | Sync locked, best quality.
UnlockedFor10Seconds | 16 | Unlocked for 10 seconds.
UnlockedFor100Seconds | 32 | Unlocked for 100 seconds.
UnlockedForOver1000Seconds | 48 | Unlocked for over 1000 seconds.
See Also

Reference

GSF.PhasorProtocols.IEC61850_90_5 Namespace


GSF.PhasorProtocols.IEEE1344 Namespace

Grid Solutions Framework GSF.PhasorProtocols.IEEE1344 Namespace
Contains an implementation of the phasor classes used to parse or generate a stream of data in the IEEE 1344-1995 standard format.
Classes
 | Class | Description
Public class | CommandFrame | Represents the IEEE 1344 implementation of a ICommandFrame that can be sent or received.
Public class | Common | Common IEEE 1344 declarations and functions.
Public class | CommonFrameHeader | Represents the common header for all IEEE 1344 frames of data.
Public class | ConfigurationCell | Represents the IEEE 1344 implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a IEEE 1344 implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame | Represents the IEEE 1344 implementation of a IConfigurationFrame that can be sent or received.
Public class | DataCell | Represents the IEEE 1344 implementation of a IDataCell that can be sent or received.
Public class | DataCellCollection | Represents a IEEE 1344 implementation of a collection of IDataCell objects.
Public class | DataFrame | Represents the IEEE 1344 implementation of a IDataFrame that can be sent or received.
Public class | DigitalDefinition | Represents the IEEE 1344 implementation of a IDigitalDefinition.
Public class | DigitalValue | Represents the IEEE 1344 implementation of a IDigitalValue.
Public class | FrameImageCollector | Collects frame images until a full IEEE 1344 frame has been received.
Public class | FrameParser | Represents a frame parser for an IEEE 1344 binary data stream that returns parsed data via events.
Public class | FrequencyDefinition | Represents the IEEE 1344 implementation of a IFrequencyDefinition.
Public class | FrequencyValue | Represents the IEEE 1344 implementation of a IFrequencyValue.
Public class | HeaderFrame | Represents the IEEE 1344 implementation of a IHeaderFrame that can be sent or received.
Public class | PhasorDefinition | Represents the IEEE 1344 implementation of a IPhasorDefinition.
Public class | PhasorValue | Represents the IEEE 1344 implementation of a IPhasorValue.
Enumerations
 | Enumeration | Description
Public enumeration | FrameType | IEEE 1344 frame types enumeration.
Public enumeration | TriggerStatus | IEEE 1344 trigger status enumeration.


CommandFrame Class

Grid Solutions Framework CommandFrame Class
Represents the IEEE 1344 implementation of a ICommandFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase ICommandCell
GSF.PhasorProtocolsCommandFrameBase
GSF.PhasorProtocols.IEEE1344CommandFrame

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute>
Public Class CommandFrame
    Inherits CommandFrameBase
[<SerializableAttribute>]
type CommandFrame =
    class
        inherit CommandFrameBase
    end
GSF.PhasorProtocols.IEEE1344.CommandFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.CommandFrame',
    GSF.PhasorProtocols.CommandFrameBase);
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase

The CommandFrame type exposes the following members.

Constructors
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(UInt64, DeviceCommand) | Creates a new CommandFrame from specified parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FrameLength | Total frame length of a IEEE 1344 CommandFrame.
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrame. (Overrides CommandFrameBaseCells.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrame. (Overrides CommandFrameBaseExtendedData.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the CommandFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this CommandFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets NTP based time representation of the ticks of this CommandFrame.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
Remarks
IEEE 1344 command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImageTTypeIdentifier for automated frame parsing. This class exposes a constructor that accepts a binary image in order to manually parse a command frame.
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame Constructor

Grid Solutions Framework CommandFrame Constructor
Overload List
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(UInt64, DeviceCommand) | Creates a new CommandFrame from specified parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandFrame Constructor (SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandFrame
GSF.PhasorProtocols.IEEE1344.CommandFrame = function(info, context);
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame Constructor (UInt64, DeviceCommand)

Grid Solutions Framework CommandFrame Constructor (UInt64, DeviceCommand)
Creates a new CommandFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    ulong idCode,
    DeviceCommand command
)
Public Sub New (
    idCode As ULong,
    command As DeviceCommand
)
new :
        idCode : uint64 *
        command : DeviceCommand -> CommandFrame
GSF.PhasorProtocols.IEEE1344.CommandFrame = function(idCode, command);
public:
CommandFrame(
    unsigned long long idCode,
    DeviceCommand command
)

Parameters

idCode
Type: SystemUInt64
The ID code of this CommandFrame.
command
Type: GSF.PhasorProtocolsDeviceCommand
The DeviceCommand for this CommandFrame.
Remarks
This constructor is used by a consumer to generate an IEEE 1344 command frame.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame Constructor (Byte[], Int32, Int32)

Grid Solutions Framework CommandFrame Constructor (Byte, Int32, Int32)
Creates a new CommandFrame from the given buffer.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> CommandFrame
GSF.PhasorProtocols.IEEE1344.CommandFrame = function(buffer, startIndex, length);
public:
CommandFrame(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | length must be at least 16.
Remarks
This constructor is used by a consumer to parse a received IEEE 1344 command frame. Typically command frames are sent to a device. This constructor would used if this code was being used inside of a phasor measurement device.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame Fields

Grid Solutions Framework CommandFrame Fields

The CommandFrame type exposes the following members.

Fields
Name | Description
FrameLength | Total frame length of a IEEE 1344 CommandFrame.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.FrameLength Field

Grid Solutions Framework CommandFrameFrameLength Field
Total frame length of a IEEE 1344 CommandFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FrameLength
Public Const FrameLength As UShort
static val mutable FrameLength: uint16
var GSF.PhasorProtocols.IEEE1344.CommandFrame.FrameLength
public:
literal unsigned short FrameLength

Field Value

Type: UInt16
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame Methods

Grid Solutions Framework CommandFrame Methods

The CommandFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.CalculateChecksum Method

Grid Solutions Framework CommandFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.GetObjectData Method

Grid Solutions Framework CommandFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.ParseHeaderImage Method

Grid Solutions Framework CommandFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame Properties

Grid Solutions Framework CommandFrame Properties

The CommandFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrame. (Overrides CommandFrameBaseCells.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrame. (Overrides CommandFrameBaseExtendedData.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the CommandFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this CommandFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets NTP based time representation of the ticks of this CommandFrame.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.Attributes Property

Grid Solutions Framework CommandFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the CommandFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.Cells Property

Grid Solutions Framework CommandFrameCells Property
Gets reference to the CommandCellCollection for this CommandFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override CommandCellCollection Cells { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides ReadOnly Property Cells As CommandCellCollection
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Cells : CommandCellCollection with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Cells : CommandCellCollection with get
function get_Cells();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property CommandCellCollection^ Cells {
    CommandCellCollection^ get () override;
}

Property Value

Type: CommandCellCollection

Implements

ICommandFrameCells
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.ExtendedData Property

Grid Solutions Framework CommandFrameExtendedData Property
Gets or sets extended binary image data for this CommandFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override byte[] ExtendedData { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property ExtendedData As Byte()
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ExtendedData : byte[] with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ExtendedData : byte[] with get, set
function get_ExtendedData();
function set_ExtendedData(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property array<unsigned char>^ ExtendedData {
    array<unsigned char>^ get () override;
    void set (array<unsigned char>^ value) override;
}

Property Value

Type: Byte

Implements

ICommandFrameExtendedData
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.HeaderImage Property

Grid Solutions Framework CommandFrameHeaderImage Property
Gets the binary header image of the CommandFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.HeaderLength Property

Grid Solutions Framework CommandFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.IDCode Property

Grid Solutions Framework CommandFrameIDCode Property
Gets or sets the ID code of this CommandFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
member IDCode : uint64 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommandFrame.TimeTag Property

Grid Solutions Framework CommandFrameTimeTag Property
Gets NTP based time representation of the ticks of this CommandFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
member TimeTag : NtpTimeTag with get

function get_TimeTag();

public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common Class

Grid Solutions Framework Common Class
Common IEEE 1344 declarations and functions.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEEE1344Common

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.IEEE1344.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.Common');
public ref class Common abstract sealed

The Common type exposes the following members.

Fields
Name | Description
FrameCountMask | Frame count mask (for multi-framed files) constant.
FrameLengthMask | Frame length mask constant.
FrameTypeMask | Frame type mask constant.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame constant.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame constant.
MaximumFrameCount | Maximum frame count (for multi-framed files) constant.
MaximumFrameLength | Absolute maximum frame length constant.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame constant.
MaximumSampleCount | Absolute maximum number of samples constant.
TriggerMask | Trigger mask constant.
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
FrameCountMask | Frame count mask (for multi-framed files) constant.
FrameLengthMask | Frame length mask constant.
FrameTypeMask | Frame type mask constant.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame constant.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame constant.
MaximumFrameCount | Maximum frame count (for multi-framed files) constant.
MaximumFrameLength | Absolute maximum frame length constant.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame constant.
MaximumSampleCount | Absolute maximum number of samples constant.
TriggerMask | Trigger mask constant.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.FrameCountMask Field

Grid Solutions Framework CommonFrameCountMask Field
Frame count mask (for multi-framed files) constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FrameCountMask
Public Const FrameCountMask As UShort
static val mutable FrameCountMask: uint16
var GSF.PhasorProtocols.IEEE1344.Common.FrameCountMask
public:
literal unsigned short FrameCountMask

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.FrameLengthMask Field

Grid Solutions Framework CommonFrameLengthMask Field
Frame length mask constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FrameLengthMask
Public Const FrameLengthMask As UShort
static val mutable FrameLengthMask: uint16
var GSF.PhasorProtocols.IEEE1344.Common.FrameLengthMask
public:
literal unsigned short FrameLengthMask

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.FrameTypeMask Field

Grid Solutions Framework CommonFrameTypeMask Field
Frame type mask constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FrameTypeMask
Public Const FrameTypeMask As UShort
static val mutable FrameTypeMask: uint16
var GSF.PhasorProtocols.IEEE1344.Common.FrameTypeMask
public:
literal unsigned short FrameTypeMask

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.MaximumAnalogValues Field

Grid Solutions Framework CommonMaximumAnalogValues Field
Absolute maximum number of possible analog values that could fit into a data frame constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaximumAnalogValues
Public Const MaximumAnalogValues As Integer
static val mutable MaximumAnalogValues: int
var GSF.PhasorProtocols.IEEE1344.Common.MaximumAnalogValues
public:
literal int MaximumAnalogValues

Field Value

Type: Int32
Remarks
IEEE 1344 doesn't support analog values
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.MaximumDataLength Field

Grid Solutions Framework CommonMaximumDataLength Field
Absolute maximum data length (in bytes) that could fit into any frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
static val mutable MaximumDataLength: uint16
var GSF.PhasorProtocols.IEEE1344.Common.MaximumDataLength
public:
literal unsigned short MaximumDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.MaximumDigitalValues Field

Grid Solutions Framework CommonMaximumDigitalValues Field
Absolute maximum number of possible digital values that could fit into a data frame constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaximumDigitalValues
Public Const MaximumDigitalValues As Integer
static val mutable MaximumDigitalValues: int
var GSF.PhasorProtocols.IEEE1344.Common.MaximumDigitalValues
public:
literal int MaximumDigitalValues

Field Value

Type: Int32
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.MaximumFrameCount Field

Grid Solutions Framework CommonMaximumFrameCount Field
Maximum frame count (for multi-framed files) constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumFrameCount
Public Const MaximumFrameCount As UShort
static val mutable MaximumFrameCount: uint16
var GSF.PhasorProtocols.IEEE1344.Common.MaximumFrameCount
public:
literal unsigned short MaximumFrameCount

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.MaximumFrameLength Field

Grid Solutions Framework CommonMaximumFrameLength Field
Absolute maximum frame length constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumFrameLength
Public Const MaximumFrameLength As UShort
static val mutable MaximumFrameLength: uint16
var GSF.PhasorProtocols.IEEE1344.Common.MaximumFrameLength
public:
literal unsigned short MaximumFrameLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.MaximumPhasorValues Field

Grid Solutions Framework CommonMaximumPhasorValues Field
Absolute maximum number of possible phasor values that could fit into a data frame constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaximumPhasorValues
Public Const MaximumPhasorValues As Integer
static val mutable MaximumPhasorValues: int
var GSF.PhasorProtocols.IEEE1344.Common.MaximumPhasorValues
public:
literal int MaximumPhasorValues

Field Value

Type: Int32
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.MaximumSampleCount Field

Grid Solutions Framework CommonMaximumSampleCount Field
Absolute maximum number of samples constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumSampleCount
Public Const MaximumSampleCount As UShort
static val mutable MaximumSampleCount: uint16
var GSF.PhasorProtocols.IEEE1344.Common.MaximumSampleCount
public:
literal unsigned short MaximumSampleCount

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


Common.TriggerMask Field

Grid Solutions Framework CommonTriggerMask Field
Trigger mask constant.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort TriggerMask
Public Const TriggerMask As UShort
static val mutable TriggerMask: uint16
var GSF.PhasorProtocols.IEEE1344.Common.TriggerMask
public:
literal unsigned short TriggerMask

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Class

Grid Solutions Framework CommonFrameHeader Class
Represents the common header for all IEEE 1344 frames of data.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEEE1344CommonFrameHeader

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
<SerializableAttribute>
Public Class CommonFrameHeader
    Implements ICommonHeader(Of FrameType), ISerializable
[<SerializableAttribute>]
type CommonFrameHeader =
    class
        interface ICommonHeader<FrameType>
        interface ISerializable
    end
GSF.PhasorProtocols.IEEE1344.CommonFrameHeader = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.CommonFrameHeader',
    null,
    GSF.Parsing.ICommonHeader`1,
    ISerializable);
[SerializableAttribute]
public ref class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable

The CommonFrameHeader type exposes the following members.

Constructors
 | Name | Description
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(FrameType, Ticks) | Creates a new CommonFrameHeader from specified parameters.
Public method | CommonFrameHeader(ConfigurationFrame, Byte, Int32) | Creates a new CommonFrameHeader from given buffer.
Top
Methods
 | Name | Description
 | ChecksumIsValid | Validates the CRC-CCITT for the specified IEEE 1344 buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
Top
Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | DataLength | Gets or sets the length of the data in the IEEE 1344 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FrameCount | Gets or sets the total frame count.
Public property | FrameImages | Gets or sets reference to a FrameImageCollector associated the IEEE 1344 frame, if any.
Public property | FrameLength | Gets or sets the entire length of the IEEE 1344 frame.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | IsFirstFrame | Gets or sets flag from that determines if this is the first frame image in a series of images representing an entire frame.
Public property | IsLastFrame | Gets or sets flag that determines if this is the last frame image in a series of images representing an entire frame.
Public property | SampleCount | Gets or sets the sample number (i.e., frame count) of this frame.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TypeID | Gets or sets the IEEE 1344 specific frame type of this frame.
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Overload List
 | Name | Description
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(FrameType, Ticks) | Creates a new CommonFrameHeader from specified parameters.
Public method | CommonFrameHeader(ConfigurationFrame, Byte, Int32) | Creates a new CommonFrameHeader from given buffer.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommonFrameHeader Constructor (SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommonFrameHeader
GSF.PhasorProtocols.IEEE1344.CommonFrameHeader = function(info, context);
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Constructor (FrameType, Ticks)

Grid Solutions Framework CommonFrameHeader Constructor (FrameType, Ticks)
Creates a new CommonFrameHeader from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    FrameType typeID,
    Ticks timestamp
)
Public Sub New (
    typeID As FrameType,
    timestamp As Ticks
)
new :
        typeID : FrameType *
        timestamp : Ticks -> CommonFrameHeader
GSF.PhasorProtocols.IEEE1344.CommonFrameHeader = function(typeID, timestamp);
public:
CommonFrameHeader(
    FrameType typeID,
    Ticks timestamp
)

Parameters

typeID
Type: GSF.PhasorProtocols.IEEE1344FrameType
The IEEE 1344 specific frame type of this frame.
timestamp
Type: GSFTicks
The timestamp of this frame.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Constructor (ConfigurationFrame, Byte[], Int32)

Grid Solutions Framework CommonFrameHeader Constructor (ConfigurationFrame, Byte, Int32)
Creates a new CommonFrameHeader from given buffer.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    ConfigurationFrame configurationFrame,
    byte[] buffer,
    int startIndex
)
Public Sub New (
    configurationFrame As ConfigurationFrame,
    buffer As Byte(),
    startIndex As Integer
)
new :
        configurationFrame : ConfigurationFrame *
        buffer : byte[] *
        startIndex : int -> CommonFrameHeader
GSF.PhasorProtocols.IEEE1344.CommonFrameHeader = function(configurationFrame, buffer, startIndex);
public:
CommonFrameHeader(
    ConfigurationFrame^ configurationFrame,
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

configurationFrame
Type: GSF.PhasorProtocols.IEEE1344ConfigurationFrame
IEEE 1344 ConfigurationFrame if already parsed.
buffer
Type: SystemByte
Buffer that contains data to parse.
startIndex
Type: SystemInt32
Start index into buffer where valid data begins.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Fields

Grid Solutions Framework CommonFrameHeader Fields

The CommonFrameHeader type exposes the following members.

Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.FixedLength Field

Grid Solutions Framework CommonFrameHeaderFixedLength Field
Total fixed length of CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FixedLength
Public Const FixedLength As UShort
static val mutable FixedLength: uint16
var GSF.PhasorProtocols.IEEE1344.CommonFrameHeader.FixedLength
public:
literal unsigned short FixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Methods

Grid Solutions Framework CommonFrameHeader Methods

The CommonFrameHeader type exposes the following members.

Methods
 | Name | Description
 | ChecksumIsValid | Validates the CRC-CCITT for the specified IEEE 1344 buffer.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.ChecksumIsValid Method

Grid Solutions Framework CommonFrameHeaderChecksumIsValid Method
Validates the CRC-CCITT for the specified IEEE 1344 buffer.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ChecksumIsValid(
    byte[] buffer,
    int startIndex,
    int length
)
Public Shared Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Boolean
static member ChecksumIsValid :
        buffer : byte[] *
        startIndex : int *
        length : int -> bool

GSF.PhasorProtocols.IEEE1344.CommonFrameHeader.ChecksumIsValid = function(buffer, startIndex, length);
public:
static bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
A Byte array buffer.
startIndex
Type: SystemInt32
An Int32 value as the start index into being reading the value at.
length
Type: SystemInt32
An Int32 value as the number of bytes to read for the checksum.

Return Value

Type: Boolean
A Boolean indicating whether the checksum is valid.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.GetObjectData Method

Grid Solutions Framework CommonFrameHeaderGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader Properties

Grid Solutions Framework CommonFrameHeader Properties

The CommonFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | DataLength | Gets or sets the length of the data in the IEEE 1344 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FrameCount | Gets or sets the total frame count.
Public property | FrameImages | Gets or sets reference to a FrameImageCollector associated the IEEE 1344 frame, if any.
Public property | FrameLength | Gets or sets the entire length of the IEEE 1344 frame.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | IsFirstFrame | Gets or sets flag from that determines if this is the first frame image in a series of images representing an entire frame.
Public property | IsLastFrame | Gets or sets flag that determines if this is the last frame image in a series of images representing an entire frame.
Public property | SampleCount | Gets or sets the sample number (i.e., frame count) of this frame.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TypeID | Gets or sets the IEEE 1344 specific frame type of this frame.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.BinaryImage Property

Grid Solutions Framework CommonFrameHeaderBinaryImage Property
Gets the binary image of the common header portion of this frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
member BinaryImage : byte[] with get

function get_BinaryImage();

public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.DataLength Property

Grid Solutions Framework CommonFrameHeaderDataLength Property
Gets or sets the length of the data in the IEEE 1344 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DataLength { get; set; }
Public Property DataLength As UShort
    Get
    Set
member DataLength : uint16 with get, set

function get_DataLength();
function set_DataLength(value);
public:
property unsigned short DataLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.FrameCount Property

Grid Solutions Framework CommonFrameHeaderFrameCount Property
Gets or sets the total frame count.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort FrameCount { get; set; }
Public Property FrameCount As UShort
    Get
    Set
member FrameCount : uint16 with get, set

function get_FrameCount();
function set_FrameCount(value);
public:
property unsigned short FrameCount {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.FrameImages Property

Grid Solutions Framework CommonFrameHeaderFrameImages Property
Gets or sets reference to a FrameImageCollector associated the IEEE 1344 frame, if any.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameImageCollector FrameImages { get; set; }
Public Property FrameImages As FrameImageCollector
    Get
    Set
member FrameImages : FrameImageCollector with get, set

function get_FrameImages();
function set_FrameImages(value);
public:
property FrameImageCollector^ FrameImages {
    FrameImageCollector^ get ();
    void set (FrameImageCollector^ value);
}

Property Value

Type: FrameImageCollector
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.FrameLength Property

Grid Solutions Framework CommonFrameHeaderFrameLength Property
Gets or sets the entire length of the IEEE 1344 frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort FrameLength { get; set; }
Public Property FrameLength As UShort
    Get
    Set
member FrameLength : uint16 with get, set

function get_FrameLength();
function set_FrameLength(value);
public:
property unsigned short FrameLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.FrameType Property

Grid Solutions Framework CommonFrameHeaderFrameType Property
Gets the fundamental frame type of this frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
member FrameType : FundamentalFrameType with get

function get_FrameType();

public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}

Property Value

Type: FundamentalFrameType
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.IsFirstFrame Property

Grid Solutions Framework CommonFrameHeaderIsFirstFrame Property
Gets or sets flag from that determines if this is the first frame image in a series of images representing an entire frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsFirstFrame { get; set; }
Public Property IsFirstFrame As Boolean
    Get
    Set
member IsFirstFrame : bool with get, set

function get_IsFirstFrame();
function set_IsFirstFrame(value);
public:
property bool IsFirstFrame {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.IsLastFrame Property

Grid Solutions Framework CommonFrameHeaderIsLastFrame Property
Gets or sets flag that determines if this is the last frame image in a series of images representing an entire frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsLastFrame { get; set; }
Public Property IsLastFrame As Boolean
    Get
    Set
member IsLastFrame : bool with get, set

function get_IsLastFrame();
function set_IsLastFrame(value);
public:
property bool IsLastFrame {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.SampleCount Property

Grid Solutions Framework CommonFrameHeaderSampleCount Property
Gets or sets the sample number (i.e., frame count) of this frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleCount { get; set; }
Public Property SampleCount As UShort
    Get
    Set
member SampleCount : uint16 with get, set

function get_SampleCount();
function set_SampleCount(value);
public:
property unsigned short SampleCount {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.State Property

Grid Solutions Framework CommonFrameHeaderState Property
Gets or sets the parsing state for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IChannelParsingState State { get; set; }
Public Property State As IChannelParsingState
    Get
    Set
member State : IChannelParsingState with get, set

function get_State();
function set_State(value);
public:
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}

Property Value

Type: IChannelParsingState
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.Timestamp Property

Grid Solutions Framework CommonFrameHeaderTimestamp Property
Gets or sets timestamp of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
member Timestamp : Ticks with get, set

function get_Timestamp();
function set_Timestamp(value);
public:
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.TimeTag Property

Grid Solutions Framework CommonFrameHeaderTimeTag Property
Gets the timestamp of this frame in NTP format.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
member TimeTag : NtpTimeTag with get

function get_TimeTag();

public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


CommonFrameHeader.TypeID Property

Grid Solutions Framework CommonFrameHeaderTypeID Property
Gets or sets the IEEE 1344 specific frame type of this frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; set; }
Public Property TypeID As FrameType
    Get
    Set
abstract TypeID : FrameType with get, set
override TypeID : FrameType with get, set
function get_TypeID();
function set_TypeID(value);
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
    void set (FrameType value) sealed;
}

Property Value

Type: FrameType

Implements

ICommonHeaderTTypeIdentifierTypeID
Remarks

This returns the protocol specific frame classification which uniquely identifies the frame type.

This is the TypeID implementation.

See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents the IEEE 1344 implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.IEEE1344ConfigurationCell

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
    end
GSF.PhasorProtocols.IEEE1344.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt64, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DataIsValid | Gets or sets flag that determines if data of this ConfigurationCell is valid.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationCell.
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StatusFlags | Gets or sets status flags of this ConfigurationCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this ConfigurationCell is valid based on GPS lock.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerStatus | Gets or sets trigger status of this ConfigurationCell.
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Overload List
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, UInt64, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell Constructor (IConfigurationFrame)

Grid Solutions Framework ConfigurationCell Constructor (IConfigurationFrame)
Creates a new ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    IConfigurationFrame parent
)
Public Sub New (
    parent As IConfigurationFrame
)
new :
        parent : IConfigurationFrame -> ConfigurationCell
GSF.PhasorProtocols.IEEE1344.ConfigurationCell = function(parent);
public:
ConfigurationCell(
    IConfigurationFrame^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationFrame
The reference to parent IConfigurationFrame of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCell Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.IEEE1344.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell Constructor (ConfigurationFrame, UInt64, LineFrequency)

Grid Solutions Framework ConfigurationCell Constructor (ConfigurationFrame, UInt64, LineFrequency)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ConfigurationFrame parent,
    ulong idCode,
    LineFrequency nominalFrequency
)
Public Sub New (
    parent As ConfigurationFrame,
    idCode As ULong,
    nominalFrequency As LineFrequency
)
new :
        parent : ConfigurationFrame *
        idCode : uint64 *
        nominalFrequency : LineFrequency -> ConfigurationCell
GSF.PhasorProtocols.IEEE1344.ConfigurationCell = function(parent, idCode, nominalFrequency);
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    unsigned long long idCode,
    LineFrequency nominalFrequency
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344ConfigurationFrame
The reference to parent ConfigurationFrame of this ConfigurationCell.
idCode
Type: SystemUInt64
The numeric ID code for this ConfigurationCell.
nominalFrequency
Type: GSF.Units.EELineFrequency
The nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.GetObjectData Method

Grid Solutions Framework ConfigurationCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.ParseFooterImage Method

Grid Solutions Framework ConfigurationCellParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.ParseHeaderImage Method

Grid Solutions Framework ConfigurationCellParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DataIsValid | Gets or sets flag that determines if data of this ConfigurationCell is valid.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationCell.
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StatusFlags | Gets or sets status flags of this ConfigurationCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this ConfigurationCell is valid based on GPS lock.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerStatus | Gets or sets trigger status of this ConfigurationCell.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override DataFormat AnalogDataFormat { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract AnalogDataFormat : DataFormat with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
Exceptions
Exception | Condition
NotSupportedException | IEEE 1344 only supports scaled data.
Remarks

IEEE 1344 doesn't define any analog values.

This property only supports scaled data; IEEE 1344 doesn't transport floating point values.

See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.Attributes Property

Grid Solutions Framework ConfigurationCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.DataIsValid Property

Grid Solutions Framework ConfigurationCellDataIsValid Property
Gets or sets flag that determines if data of this ConfigurationCell is valid.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DataIsValid { get; set; }
Public Property DataIsValid As Boolean
    Get
    Set
member DataIsValid : bool with get, set

function get_DataIsValid();
function set_DataIsValid(value);
public:
property bool DataIsValid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.FooterImage Property

Grid Solutions Framework ConfigurationCellFooterImage Property
Gets the binary footer image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.FooterLength Property

Grid Solutions Framework ConfigurationCellFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
Exceptions
Exception | Condition
NotSupportedException | IEEE 1344 only supports scaled data.
Remarks
This property only supports scaled data; IEEE 1344 doesn't transport floating point values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.HeaderImage Property

Grid Solutions Framework ConfigurationCellHeaderImage Property
Gets the binary header image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.HeaderLength Property

Grid Solutions Framework ConfigurationCellHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.IDCode Property

Grid Solutions Framework ConfigurationCellIDCode Property
Gets or sets the ID code of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
member IDCode : uint64 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.Parent Property

Grid Solutions Framework ConfigurationCellParent Property
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
member Parent : ConfigurationFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
Exceptions
Exception | Condition
NotSupportedException | IEEE 1344 only supports scaled data.
Remarks
This property only supports scaled data; IEEE 1344 doesn't transport floating point values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.StatusFlags Property

Grid Solutions Framework ConfigurationCellStatusFlags Property
Gets or sets status flags of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public ushort StatusFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property StatusFlags As UShort
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member StatusFlags : uint16 with get, set

function get_StatusFlags();
function set_StatusFlags(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property unsigned short StatusFlags {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
Remarks
These are bit flags, use properties to change basic values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.SynchronizationIsValid Property

Grid Solutions Framework ConfigurationCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this ConfigurationCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SynchronizationIsValid { get; set; }
Public Property SynchronizationIsValid As Boolean
    Get
    Set
member SynchronizationIsValid : bool with get, set

function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
property bool SynchronizationIsValid {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCell.TriggerStatus Property

Grid Solutions Framework ConfigurationCellTriggerStatus Property
Gets or sets trigger status of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TriggerStatus TriggerStatus { get; set; }
Public Property TriggerStatus As TriggerStatus
    Get
    Set
member TriggerStatus : TriggerStatus with get, set

function get_TriggerStatus();
function set_TriggerStatus(value);
public:
property TriggerStatus TriggerStatus {
    TriggerStatus get ();
    void set (TriggerStatus value);
}

Property Value

Type: TriggerStatus
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a IEEE 1344 implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.IEEE1344ConfigurationCellCollection

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.IEEE1344.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.IEEE1344.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.IEEE1344.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame Class

Grid Solutions Framework ConfigurationFrame Class
Represents the IEEE 1344 implementation of a IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.IEEE1344ConfigurationFrame

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class ConfigurationFrame
    Inherits ConfigurationFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type ConfigurationFrame =
    class
        inherit ConfigurationFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEEE1344.ConfigurationFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.ConfigurationFrame',
    GSF.PhasorProtocols.ConfigurationFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The ConfigurationFrame type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt64, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of this ConfigurationFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Period | Gets or sets the IEEE 1344 period value.
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(UInt64, Ticks, UInt16) | Creates a new ConfigurationFrame from specified parameters.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Creates a new ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame
GSF.PhasorProtocols.IEEE1344.ConfigurationFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE 1344 configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame
GSF.PhasorProtocols.IEEE1344.ConfigurationFrame = function(info, context);
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame Constructor (UInt64, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame Constructor (UInt64, Ticks, UInt16)
Creates a new ConfigurationFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame(
    ulong idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    idCode As ULong,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        idCode : uint64 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame
GSF.PhasorProtocols.IEEE1344.ConfigurationFrame = function(idCode, timestamp, frameRate);
public:
ConfigurationFrame(
    unsigned long long idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

idCode
Type: SystemUInt64
The ID code of this ConfigurationFrame.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame.
Remarks
This constructor is used by a consumer to generate an IEEE 1344 configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame Methods

Grid Solutions Framework ConfigurationFrame Methods

The ConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.GetObjectData Method

Grid Solutions Framework ConfigurationFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.ParseBinaryImage Method

Grid Solutions Framework ConfigurationFrameParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
This method is overridden to parse from cumulated frame images.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.ParseFooterImage Method

Grid Solutions Framework ConfigurationFrameParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.ParseHeaderImage Method

Grid Solutions Framework ConfigurationFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame Properties

Grid Solutions Framework ConfigurationFrame Properties

The ConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of this ConfigurationFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Period | Gets or sets the IEEE 1344 period value.
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.Attributes Property

Grid Solutions Framework ConfigurationFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.Cells Property

Grid Solutions Framework ConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.CommonHeader Property

Grid Solutions Framework ConfigurationFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.FooterImage Property

Grid Solutions Framework ConfigurationFrameFooterImage Property
Gets the binary footer image of the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.FooterLength Property

Grid Solutions Framework ConfigurationFrameFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.HeaderImage Property

Grid Solutions Framework ConfigurationFrameHeaderImage Property
Gets the binary header image of the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.HeaderLength Property

Grid Solutions Framework ConfigurationFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.IDCode Property

Grid Solutions Framework ConfigurationFrameIDCode Property
Gets or sets the ID code of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
member IDCode : uint64 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.NominalFrequency Property

Grid Solutions Framework ConfigurationFrameNominalFrequency Property
Gets or sets the nominal LineFrequency of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LineFrequency NominalFrequency { get; set; }
Public Property NominalFrequency As LineFrequency
    Get
    Set
member NominalFrequency : LineFrequency with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
public:
property LineFrequency NominalFrequency {
    LineFrequency get ();
    void set (LineFrequency value);
}

Property Value

Type: LineFrequency
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.Period Property

Grid Solutions Framework ConfigurationFramePeriod Property
Gets or sets the IEEE 1344 period value.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort Period { get; set; }
Public Property Period As UShort
    Get
    Set
member Period : uint16 with get, set

function get_Period();
function set_Period(value);
public:
property unsigned short Period {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.Timestamp Property

Grid Solutions Framework ConfigurationFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.TimeTag Property

Grid Solutions Framework ConfigurationFrameTimeTag Property
Gets the timestamp of this frame in NTP format.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
member TimeTag : NtpTimeTag with get

function get_TimeTag();

public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


ConfigurationFrame.TypeID Property

Grid Solutions Framework ConfigurationFrameTypeID Property
Gets the identifier that is used to identify the IEEE 1344 frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell Class

Grid Solutions Framework DataCell Class
Represents the IEEE 1344 implementation of a IDataCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.IEEE1344DataCell

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute>
Public Class DataCell
    Inherits DataCellBase
[<SerializableAttribute>]
type DataCell =
    class
        inherit DataCellBase
    end
GSF.PhasorProtocols.IEEE1344.DataCell = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.DataCell',
    GSF.PhasorProtocols.DataCellBase);
[SerializableAttribute]
public ref class DataCell : public DataCellBase

The DataCell type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBaseAnalogValues.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCell.
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerStatus | Gets or sets trigger status of this DataCell.
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


DataCell Constructor

Grid Solutions Framework DataCell Constructor
Overload List
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCell Constructor (SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCell
GSF.PhasorProtocols.IEEE1344.DataCell = function(info, context);
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell Constructor (IDataFrame, IConfigurationCell)

Grid Solutions Framework DataCell Constructor (IDataFrame, IConfigurationCell)
Creates a new DataCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell -> DataCell
GSF.PhasorProtocols.IEEE1344.DataCell = function(parent, configurationCell);
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCell.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell Constructor (DataFrame, ConfigurationCell, Boolean)

Grid Solutions Framework DataCell Constructor (DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New (
    parent As DataFrame,
    configurationCell As ConfigurationCell,
    addEmptyValues As Boolean
)
new :
        parent : DataFrame *
        configurationCell : ConfigurationCell *
        addEmptyValues : bool -> DataCell
GSF.PhasorProtocols.IEEE1344.DataCell = function(parent, configurationCell, addEmptyValues);
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344DataFrame
The reference to parent DataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocols.IEEE1344ConfigurationCell
The ConfigurationCell associated with this DataCell.
addEmptyValues
Type: SystemBoolean
If true, adds empty values for each defined configuration cell definition.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell Methods

Grid Solutions Framework DataCell Methods

The DataCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell Properties

Grid Solutions Framework DataCell Properties

The DataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBaseAnalogValues.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCell.
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerStatus | Gets or sets trigger status of this DataCell.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.AnalogValues Property

Grid Solutions Framework DataCellAnalogValues Property
Gets AnalogValueCollection of this DataCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override AnalogValueCollection AnalogValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides ReadOnly Property AnalogValues As AnalogValueCollection
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract AnalogValues : AnalogValueCollection with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override AnalogValues : AnalogValueCollection with get
function get_AnalogValues();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get () override;
}

Property Value

Type: AnalogValueCollection

Implements

IDataCellAnalogValues
Remarks
IEEE 1344 doesn't define any analog values.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.Attributes Property

Grid Solutions Framework DataCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataCell object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.ConfigurationCell Property

Grid Solutions Framework DataCellConfigurationCell Property
Gets or sets the ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
member ConfigurationCell : ConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.DataIsValid Property

Grid Solutions Framework DataCellDataIsValid Property
Gets or sets flag that determines if data of this DataCell is valid.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set
override DataIsValid : bool with get, set
function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.DataSortingType Property

Grid Solutions Framework DataCellDataSortingType Property
Gets or sets DataSortingType of this DataCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set
override DataSortingType : DataSortingType with get, set
function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.DeviceError Property

Grid Solutions Framework DataCellDeviceError Property
Gets or sets flag that determines if source device of this DataCell is reporting an error.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property DeviceError As Boolean
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract DeviceError : bool with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override DeviceError : bool with get, set
function get_DeviceError();
function set_DeviceError(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
Remarks
IEEE 1344 doesn't define bits for device error.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.IDCode Property

Grid Solutions Framework DataCellIDCode Property
Gets the numeric ID code for this DataCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong IDCode { get; }
Public ReadOnly Property IDCode As ULong
    Get
member IDCode : uint64 with get

function get_IDCode();

public:
property unsigned long long IDCode {
    unsigned long long get ();
}

Property Value

Type: UInt64
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.Parent Property

Grid Solutions Framework DataCellParent Property
Gets or sets the reference to parent DataFrame of this DataCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
member Parent : DataFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}

Property Value

Type: DataFrame
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.SynchronizationIsValid Property

Grid Solutions Framework DataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set
override SynchronizationIsValid : bool with get, set
function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCell.TriggerStatus Property

Grid Solutions Framework DataCellTriggerStatus Property
Gets or sets trigger status of this DataCell.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TriggerStatus TriggerStatus { get; set; }
Public Property TriggerStatus As TriggerStatus
    Get
    Set
member TriggerStatus : TriggerStatus with get, set

function get_TriggerStatus();
function set_TriggerStatus(value);
public:
property TriggerStatus TriggerStatus {
    TriggerStatus get ();
    void set (TriggerStatus value);
}

Property Value

Type: TriggerStatus
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a IEEE 1344 implementation of a collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.IEEE1344DataCellCollection

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute>
Public Class DataCellCollection
    Inherits DataCellCollection
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit DataCellCollection
    end
GSF.PhasorProtocols.IEEE1344.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.DataCellCollection',
    GSF.PhasorProtocols.DataCellCollection);
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Creates a new DataCellCollection.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection()
Public Sub New
new : unit -> DataCellCollection
GSF.PhasorProtocols.IEEE1344.DataCellCollection = function();
public:
DataCellCollection()
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.IEEE1344.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection.Item Property

Grid Solutions Framework DataCellCollectionItem Property
Gets or sets DataCell at specified index.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As DataCell
    Get
    Set
member Item : DataCell with get, set

function get_Item(index);
function set_Item(value);
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: DataCell
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame Class

Grid Solutions Framework DataFrame Class
Represents the IEEE 1344 implementation of a IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.IEEE1344DataFrame

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute>
Public Class DataFrame
    Inherits DataFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type DataFrame =
    class
        inherit DataFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEEE1344.DataFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.DataFrame',
    GSF.PhasorProtocols.DataFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The DataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame) | Creates a new DataFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Overload List
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame) | Creates a new DataFrame from specified parameters.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Creates a new DataFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> DataFrame
GSF.PhasorProtocols.IEEE1344.DataFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
DataFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE 1344 data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrame Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrame
GSF.PhasorProtocols.IEEE1344.DataFrame = function(info, context);
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame Constructor (Ticks, ConfigurationFrame)

Grid Solutions Framework DataFrame Constructor (Ticks, ConfigurationFrame)
Creates a new DataFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame configurationFrame
)
Public Sub New (
    timestamp As Ticks,
    configurationFrame As ConfigurationFrame
)
new :
        timestamp : Ticks *
        configurationFrame : ConfigurationFrame -> DataFrame
GSF.PhasorProtocols.IEEE1344.DataFrame = function(timestamp, configurationFrame);
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame^ configurationFrame
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame
Type: GSF.PhasorProtocols.IEEE1344ConfigurationFrame
The ConfigurationFrame associated with this DataFrame.
Remarks
This constructor is used by a consumer to generate an IEEE 1344 data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame Methods

Grid Solutions Framework DataFrame Methods

The DataFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.CalculateChecksum Method

Grid Solutions Framework DataFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.GetObjectData Method

Grid Solutions Framework DataFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.ParseHeaderImage Method

Grid Solutions Framework DataFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame Properties

Grid Solutions Framework DataFrame Properties

The DataFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.Attributes Property

Grid Solutions Framework DataFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.Cells Property

Grid Solutions Framework DataFrameCells Property
Gets reference to the DataCellCollection for this DataFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
member Cells : DataCellCollection with get

function get_Cells();

public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.CommonHeader Property

Grid Solutions Framework DataFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.ConfigurationFrame Property

Grid Solutions Framework DataFrameConfigurationFrame Property
Gets or sets ConfigurationFrame associated with this DataFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
member ConfigurationFrame : ConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.HeaderImage Property

Grid Solutions Framework DataFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.HeaderLength Property

Grid Solutions Framework DataFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.IDCode Property

Grid Solutions Framework DataFrameIDCode Property
Gets the numeric ID code for this DataFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong IDCode { get; }
Public ReadOnly Property IDCode As ULong
    Get
member IDCode : uint64 with get

function get_IDCode();

public:
property unsigned long long IDCode {
    unsigned long long get ();
}

Property Value

Type: UInt64
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.Timestamp Property

Grid Solutions Framework DataFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.TimeTag Property

Grid Solutions Framework DataFrameTimeTag Property
Gets the timestamp of this frame in NTP format.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
member TimeTag : NtpTimeTag with get

function get_TimeTag();

public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DataFrame.TypeID Property

Grid Solutions Framework DataFrameTypeID Property
Gets the identifier that is used to identify the IEEE 1344 frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition Class

Grid Solutions Framework DigitalDefinition Class
Represents the IEEE 1344 implementation of a IDigitalDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocols.IEEE1344DigitalDefinition

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute>
Public Class DigitalDefinition
    Inherits DigitalDefinitionBase
[<SerializableAttribute>]
type DigitalDefinition =
    class
        inherit DigitalDefinitionBase
    end
GSF.PhasorProtocols.IEEE1344.DigitalDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.DigitalDefinition',
    GSF.PhasorProtocols.DigitalDefinitionBase);
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase

The DigitalDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NormalStatus | Gets or sets normal status for this DigitalDefinition.
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition Constructor

Grid Solutions Framework DigitalDefinition Constructor
Overload List
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition Constructor (IConfigurationCell)

Grid Solutions Framework DigitalDefinition Constructor (IConfigurationCell)
Creates a new DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> DigitalDefinition
GSF.PhasorProtocols.IEEE1344.DigitalDefinition = function(parent);
public:
DigitalDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinition
GSF.PhasorProtocols.IEEE1344.DigitalDefinition = function(info, context);
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework DigitalDefinition Constructor (ConfigurationCell, String)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> DigitalDefinition
GSF.PhasorProtocols.IEEE1344.DigitalDefinition = function(parent, label);
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344ConfigurationCell
The ConfigurationCell parent of this DigitalDefinition.
label
Type: SystemString
The label of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition Methods

Grid Solutions Framework DigitalDefinition Methods

The DigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition.GetObjectData Method

Grid Solutions Framework DigitalDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition Properties

Grid Solutions Framework DigitalDefinition Properties

The DigitalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NormalStatus | Gets or sets normal status for this DigitalDefinition.
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition.Attributes Property

Grid Solutions Framework DigitalDefinitionAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition.NormalStatus Property

Grid Solutions Framework DigitalDefinitionNormalStatus Property
Gets or sets normal status for this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort NormalStatus { get; set; }
Public Property NormalStatus As UShort
    Get
    Set
member NormalStatus : uint16 with get, set

function get_NormalStatus();
function set_NormalStatus(value);
public:
property unsigned short NormalStatus {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition.Parent Property

Grid Solutions Framework DigitalDefinitionParent Property
Gets or sets the ConfigurationCell parent of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalDefinition.ValidInputs Property

Grid Solutions Framework DigitalDefinitionValidInputs Property
Gets or sets valid input for this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ValidInputs { get; set; }
Public Property ValidInputs As UShort
    Get
    Set
member ValidInputs : uint16 with get, set

function get_ValidInputs();
function set_ValidInputs(value);
public:
property unsigned short ValidInputs {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue Class

Grid Solutions Framework DigitalValue Class
Represents the IEEE 1344 implementation of a IDigitalValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IDigitalDefinition
GSF.PhasorProtocolsDigitalValueBase
GSF.PhasorProtocols.IEEE1344DigitalValue

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute>
Public Class DigitalValue
    Inherits DigitalValueBase
[<SerializableAttribute>]
type DigitalValue =
    class
        inherit DigitalValueBase
    end
GSF.PhasorProtocols.IEEE1344.DigitalValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.DigitalValue',
    GSF.PhasorProtocols.DigitalValueBase);
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase

The DigitalValue type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue Constructor

Grid Solutions Framework DigitalValue Constructor
Overload List
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalValue Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalValue
GSF.PhasorProtocols.IEEE1344.DigitalValue = function(info, context);
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue Constructor (IDataCell, IDigitalDefinition)

Grid Solutions Framework DigitalValue Constructor (IDataCell, IDigitalDefinition)
Creates a new DigitalValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New (
    parent As IDataCell,
    digitalDefinition As IDigitalDefinition
)
new :
        parent : IDataCell *
        digitalDefinition : IDigitalDefinition -> DigitalValue
GSF.PhasorProtocols.IEEE1344.DigitalValue = function(parent, digitalDefinition);
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocolsIDigitalDefinition
The IDigitalDefinition associated with this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)

Grid Solutions Framework DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New (
    parent As DataCell,
    digitalDefinition As DigitalDefinition,
    value As UShort
)
new :
        parent : DataCell *
        digitalDefinition : DigitalDefinition *
        value : uint16 -> DigitalValue
GSF.PhasorProtocols.IEEE1344.DigitalValue = function(parent, digitalDefinition, value);
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344DataCell
The DataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocols.IEEE1344DigitalDefinition
The DigitalDefinition associated with this DigitalValue.
value
Type: SystemUInt16
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue Methods

Grid Solutions Framework DigitalValue Methods

The DigitalValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue Properties

Grid Solutions Framework DigitalValue Properties

The DigitalValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue.Definition Property

Grid Solutions Framework DigitalValueDefinition Property
Gets or sets the DigitalDefinition associated with this DigitalValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
abstract Definition : DigitalDefinition with get, set
override Definition : DigitalDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}

Property Value

Type: DigitalDefinition
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


DigitalValue.Parent Property

Grid Solutions Framework DigitalValueParent Property
Gets or sets the DataCell parent of this DigitalValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector Class

Grid Solutions Framework FrameImageCollector Class
Collects frame images until a full IEEE 1344 frame has been received.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEEE1344FrameImageCollector

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameImageCollector
Public Class FrameImageCollector
type FrameImageCollector =  class end
GSF.PhasorProtocols.IEEE1344.FrameImageCollector = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.FrameImageCollector');
public ref class FrameImageCollector

The FrameImageCollector type exposes the following members.

Constructors
 | Name | Description
Public method | FrameImageCollector | Creates a new FrameImageCollector.
Top
Methods
 | Name | Description
Public method | AppendFrameImage | Appends the current frame image to the frame image collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | BinaryImage | Gets the combined binary image of all the collected frame images.
Public property | BinaryLength | Gets the length of the combined binary image of all the collected frame images.
Public property | Count | Gets the total number frames appended to FrameImageCollector.
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector Constructor

Grid Solutions Framework FrameImageCollector Constructor
Creates a new FrameImageCollector.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameImageCollector()
Public Sub New
new : unit -> FrameImageCollector
GSF.PhasorProtocols.IEEE1344.FrameImageCollector = function();
public:
FrameImageCollector()
See Also

Reference

FrameImageCollector Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector Methods

Grid Solutions Framework FrameImageCollector Methods

The FrameImageCollector type exposes the following members.

Methods
 | Name | Description
Public method | AppendFrameImage | Appends the current frame image to the frame image collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrameImageCollector Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector.AppendFrameImage Method

Grid Solutions Framework FrameImageCollectorAppendFrameImage Method
Appends the current frame image to the frame image collection.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AppendFrameImage(
    byte[] buffer,
    int offset,
    int length
)
Public Sub AppendFrameImage (
    buffer As Byte(),
    offset As Integer,
    length As Integer
)
member AppendFrameImage :
        buffer : byte[] *
        offset : int *
        length : int -> unit

function AppendFrameImage(buffer, offset, length);
public:
void AppendFrameImage(
    array<unsigned char>^ buffer,
    int offset,
    int length
)

Parameters

buffer
Type: SystemByte
A Byte array to append to the collection.
offset
Type: SystemInt32
An Int32 value indicating the offset to read from.
length
Type: SystemInt32
An Int32 value indicating the number of bytes to read from the buffer.
See Also

Reference

FrameImageCollector Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector Properties

Grid Solutions Framework FrameImageCollector Properties

The FrameImageCollector type exposes the following members.

Properties
 | Name | Description
Public property | BinaryImage | Gets the combined binary image of all the collected frame images.
Public property | BinaryLength | Gets the length of the combined binary image of all the collected frame images.
Public property | Count | Gets the total number frames appended to FrameImageCollector.
Top
See Also

Reference

FrameImageCollector Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector.BinaryImage Property

Grid Solutions Framework FrameImageCollectorBinaryImage Property
Gets the combined binary image of all the collected frame images.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
member BinaryImage : byte[] with get

function get_BinaryImage();

public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

FrameImageCollector Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector.BinaryLength Property

Grid Solutions Framework FrameImageCollectorBinaryLength Property
Gets the length of the combined binary image of all the collected frame images.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
member BinaryLength : int with get

function get_BinaryLength();

public:
property int BinaryLength {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

FrameImageCollector Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameImageCollector.Count Property

Grid Solutions Framework FrameImageCollectorCount Property
Gets the total number frames appended to FrameImageCollector.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Count { get; }
Public ReadOnly Property Count As Integer
    Get
member Count : int with get

function get_Count();

public:
property int Count {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

FrameImageCollector Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser Class

Grid Solutions Framework FrameParser Class
Represents a frame parser for an IEEE 1344 binary data stream that returns parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.PhasorProtocolsFrameParserBase FrameType
GSF.PhasorProtocols.IEEE1344FrameParser

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser
    Inherits FrameParserBase(Of FrameType)
type FrameParser =
    class
        inherit FrameParserBase<FrameType>
    end
GSF.PhasorProtocols.IEEE1344.FrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.FrameParser',
    GSF.PhasorProtocols.FrameParserBase`1);
public ref class FrameParser : public FrameParserBase<FrameType>

The FrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | FrameParser | Creates a new FrameParser.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedHeaderFrame(IHeaderFrame).)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParserBaseTFrameIdentifier. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when an IEEE 1344 CommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when an IEEE 1344 ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when an IEEE 1344 DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when an IEEE 1344 HeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser Constructor

Grid Solutions Framework FrameParser Constructor
Creates a new FrameParser.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    bool trustHeaderLength = true
)
Public Sub New (
    Optional checkSumValidationFrameTypes As CheckSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    Optional trustHeaderLength As Boolean = true
)
new :
        ?checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        ?trustHeaderLength : bool
(* Defaults:
        let _checkSumValidationFrameTypes = defaultArg checkSumValidationFrameTypes CheckSumValidationFrameTypes.AllFrames
        let _trustHeaderLength = defaultArg trustHeaderLength true
*)
-> FrameParser
GSF.PhasorProtocols.IEEE1344.FrameParser = function(checkSumValidationFrameTypes, trustHeaderLength);
public:
FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes::AllFrames,
    bool trustHeaderLength = true
)

Parameters

checkSumValidationFrameTypes (Optional)
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength (Optional)
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser Fields

Grid Solutions Framework FrameParser Fields

The FrameParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser Methods

Grid Solutions Framework FrameParser Methods

The FrameParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedHeaderFrame(IHeaderFrame).)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame).

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.OnReceivedConfigurationFrame Method

Grid Solutions Framework FrameParserOnReceivedConfigurationFrame Method
Raises the ReceivedConfigurationFrame event.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame (
    frame As IConfigurationFrame
)
abstract OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
override OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
function OnReceivedConfigurationFrame(frame);
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIConfigurationFrame
IConfigurationFrame to send to ReceivedConfigurationFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.OnReceivedHeaderFrame Method

Grid Solutions Framework FrameParserOnReceivedHeaderFrame Method
Raises the ReceivedHeaderFrame event.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedHeaderFrame(
    IHeaderFrame frame
)
Protected Overrides Sub OnReceivedHeaderFrame (
    frame As IHeaderFrame
)
abstract OnReceivedHeaderFrame :
        frame : IHeaderFrame -> unit
override OnReceivedHeaderFrame :
        frame : IHeaderFrame -> unit
function OnReceivedHeaderFrame(frame);
protected:
virtual void OnReceivedHeaderFrame(
    IHeaderFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIHeaderFrame
IHeaderFrame to send to ReceivedHeaderFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.ParseCommonHeader Method

Grid Solutions Framework FrameParserParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of FrameType)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader FrameType
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Start the data parser.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

FrameParser Class
Start Overload
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser Properties

Grid Solutions Framework FrameParser Properties

The FrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParserBaseTFrameIdentifier. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.ConfigurationFrame Property

Grid Solutions Framework FrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework FrameParserProtocolUsesSyncBytes Property
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
Remarks
The IEEE 1344 protocol does not use synchronization bytes, as a result this property returns false.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser Events

Grid Solutions Framework FrameParser Events

The FrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when an IEEE 1344 CommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when an IEEE 1344 ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when an IEEE 1344 DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when an IEEE 1344 HeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.ReceivedCommandFrame Event

Grid Solutions Framework FrameParserReceivedCommandFrame Event
Occurs when an IEEE 1344 CommandFrame has been received.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<CommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of CommandFrame))
member ReceivedCommandFrame : IEvent<EventHandler<EventArgs<CommandFrame>>,
    EventArgs<CommandFrame>>

function add_ReceivedCommandFrame(value);
function remove_ReceivedCommandFrame(value);
public:
 event EventHandler<EventArgs<CommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<CommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<CommandFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs CommandFrame
Remarks
Argument is the CommandFrame that was received.

Command frames are normally sent, not received, but there is nothing that prevents this.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame Event
Occurs when an IEEE 1344 ConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
member ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<ConfigurationFrame>>,
    EventArgs<ConfigurationFrame>>

function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame
Remarks
Argument is the ConfigurationFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.ReceivedDataFrame Event

Grid Solutions Framework FrameParserReceivedDataFrame Event
Occurs when an IEEE 1344 DataFrame has been received.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
member ReceivedDataFrame : IEvent<EventHandler<EventArgs<DataFrame>>,
    EventArgs<DataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataFrame
Remarks
Argument is the DataFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameParser.ReceivedHeaderFrame Event

Grid Solutions Framework FrameParserReceivedHeaderFrame Event
Occurs when an IEEE 1344 HeaderFrame has been received.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<HeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of HeaderFrame))
member ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<HeaderFrame>>,
    EventArgs<HeaderFrame>>

function add_ReceivedHeaderFrame(value);
function remove_ReceivedHeaderFrame(value);
public:
 event EventHandler<EventArgs<HeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<HeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<HeaderFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs HeaderFrame
Remarks
Argument is the HeaderFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrameType Enumeration

Grid Solutions Framework FrameType Enumeration
IEEE 1344 frame types enumeration.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FrameType
<SerializableAttribute>
Public Enumeration FrameType
[<SerializableAttribute>]
type FrameType
GSF.PhasorProtocols.IEEE1344.FrameType = function();
GSF.PhasorProtocols.IEEE1344.FrameType.createEnum('GSF.PhasorProtocols.IEEE1344.FrameType', false);
[SerializableAttribute]
public enum class FrameType
Members
Member name | Value | Description
DataFrame | 0 | 000 Data frame.
HeaderFrame | 8192 | 001 Header frame.
ConfigurationFrame | 16384 | 010 Configuration frame.
Reserved0 | 24576 | 011 Reserved flags 0.
Reserved1 | 49152 | 110 Reserved flags 1.
Reserved2 | 32768 | 100 Reserved flags 2.
UserDefined0 | 40960 | 101 User defined flags 0.
UserDefined1 | 57344 | 111 User defined flags 1.
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents the IEEE 1344 implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.IEEE1344FrequencyDefinition

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.IEEE1344.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides FrequencyDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinition object. (Overrides FrequencyDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtIsAvailable | Gets or sets flag that determines if df/dt measurement is available in FrequencyValue.
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyIsAvailable | Gets or sets flag that determines if frequency measurement is available in FrequencyValue.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinition Constructor (IConfigurationCell)
Creates a new FrequencyDefinition.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinition
GSF.PhasorProtocols.IEEE1344.FrequencyDefinition = function(parent);
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.IEEE1344.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> FrequencyDefinition
GSF.PhasorProtocols.IEEE1344.FrequencyDefinition = function(parent, label);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344ConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
label
Type: SystemString
The label of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides FrequencyDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.GetObjectData Method

Grid Solutions Framework FrequencyDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.ParseBodyImage Method

Grid Solutions Framework FrequencyDefinitionParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The base implementation assumes that all channel definitions begin with a label as this is the general case, override functionality if this is not the case.
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinition object. (Overrides FrequencyDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtIsAvailable | Gets or sets flag that determines if df/dt measurement is available in FrequencyValue.
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyIsAvailable | Gets or sets flag that determines if frequency measurement is available in FrequencyValue.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.Attributes Property

Grid Solutions Framework FrequencyDefinitionAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinition object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.BodyImage Property

Grid Solutions Framework FrequencyDefinitionBodyImage Property
Gets the binary body image of the FrequencyDefinition object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.BodyLength Property

Grid Solutions Framework FrequencyDefinitionBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.DfDtIsAvailable Property

Grid Solutions Framework FrequencyDefinitionDfDtIsAvailable Property
Gets or sets flag that determines if df/dt measurement is available in FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DfDtIsAvailable { get; set; }
Public Property DfDtIsAvailable As Boolean
    Get
    Set
member DfDtIsAvailable : bool with get, set

function get_DfDtIsAvailable();
function set_DfDtIsAvailable(value);
public:
property bool DfDtIsAvailable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.FrequencyIsAvailable Property

Grid Solutions Framework FrequencyDefinitionFrequencyIsAvailable Property
Gets or sets flag that determines if frequency measurement is available in FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool FrequencyIsAvailable { get; set; }
Public Property FrequencyIsAvailable As Boolean
    Get
    Set
member FrequencyIsAvailable : bool with get, set

function get_FrequencyIsAvailable();
function set_FrequencyIsAvailable(value);
public:
property bool FrequencyIsAvailable {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue Class

Grid Solutions Framework FrequencyValue Class
Represents the IEEE 1344 implementation of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.IEEE1344FrequencyValue

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute>
Public Class FrequencyValue
    Inherits FrequencyValueBase
[<SerializableAttribute>]
type FrequencyValue =
    class
        inherit FrequencyValueBase
    end
GSF.PhasorProtocols.IEEE1344.FrequencyValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.FrequencyValue',
    GSF.PhasorProtocols.FrequencyValueBase);
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase

The FrequencyValue type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue Constructor

Grid Solutions Framework FrequencyValue Constructor
Overload List
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValue Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValue
GSF.PhasorProtocols.IEEE1344.FrequencyValue = function(info, context);
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValue Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValue
GSF.PhasorProtocols.IEEE1344.FrequencyValue = function(parent, frequencyDefinition);
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValue.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New (
    parent As DataCell,
    frequencyDefinition As FrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : DataCell *
        frequencyDefinition : FrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValue
GSF.PhasorProtocols.IEEE1344.FrequencyValue = function(parent, frequencyDefinition, frequency, dfdt);
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344DataCell
The DataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocols.IEEE1344FrequencyDefinition
The FrequencyDefinition associated with this FrequencyValue.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValue.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValue over time.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue Methods

Grid Solutions Framework FrequencyValue Methods

The FrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue.ParseBodyImage Method

Grid Solutions Framework FrequencyValueParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The IEEE 1344 protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue Properties

Grid Solutions Framework FrequencyValue Properties

The FrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue.BodyImage Property

Grid Solutions Framework FrequencyValueBodyImage Property
Gets the binary body image of the FrequencyValue object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
Remarks
The IEEE 1344 protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue.BodyLength Property

Grid Solutions Framework FrequencyValueBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
The IEEE 1344 protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue.Definition Property

Grid Solutions Framework FrequencyValueDefinition Property
Gets or sets the FrequencyDefinition associated with this FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
abstract Definition : FrequencyDefinition with get, set
override Definition : FrequencyDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}

Property Value

Type: FrequencyDefinition
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


FrequencyValue.Parent Property

Grid Solutions Framework FrequencyValueParent Property
Gets or sets the DataCell parent of this FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame Class

Grid Solutions Framework HeaderFrame Class
Represents the IEEE 1344 implementation of a IHeaderFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IHeaderCell
GSF.PhasorProtocolsHeaderFrameBase
GSF.PhasorProtocols.IEEE1344HeaderFrame

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class HeaderFrame : HeaderFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class HeaderFrame
    Inherits HeaderFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type HeaderFrame =
    class
        inherit HeaderFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEEE1344.HeaderFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.HeaderFrame',
    GSF.PhasorProtocols.HeaderFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class HeaderFrame : public HeaderFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The HeaderFrame type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderFrame | Creates a new HeaderFrame.
Protected method | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrame object. (Overrides HeaderFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the HeaderFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this HeaderFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame Constructor

Grid Solutions Framework HeaderFrame Constructor
Overload List
 | Name | Description
Public method | HeaderFrame | Creates a new HeaderFrame.
Protected method | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame Constructor

Grid Solutions Framework HeaderFrame Constructor
Creates a new HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public HeaderFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> HeaderFrame
GSF.PhasorProtocols.IEEE1344.HeaderFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
HeaderFrame()
Remarks
This constructor is used by a consumer to generate an IEEE 1344 configuration frame and by the FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE 1344 configuration frame.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework HeaderFrame Constructor (SerializationInfo, StreamingContext)
Creates a new HeaderFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HeaderFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HeaderFrame
GSF.PhasorProtocols.IEEE1344.HeaderFrame = function(info, context);
protected:
HeaderFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame Methods

Grid Solutions Framework HeaderFrame Methods

The HeaderFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.CalculateChecksum Method

Grid Solutions Framework HeaderFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.GetObjectData Method

Grid Solutions Framework HeaderFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.ParseBinaryImage Method

Grid Solutions Framework HeaderFrameParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
This method is overridden to parse from cumulated frame images.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.ParseHeaderImage Method

Grid Solutions Framework HeaderFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame Properties

Grid Solutions Framework HeaderFrame Properties

The HeaderFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrame object. (Overrides HeaderFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the HeaderFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this HeaderFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE 1344 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.Attributes Property

Grid Solutions Framework HeaderFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the HeaderFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.CommonHeader Property

Grid Solutions Framework HeaderFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.HeaderImage Property

Grid Solutions Framework HeaderFrameHeaderImage Property
Gets the binary header image of the HeaderFrame object.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.HeaderLength Property

Grid Solutions Framework HeaderFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.IDCode Property

Grid Solutions Framework HeaderFrameIDCode Property
Gets or sets the ID code of this HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ulong IDCode { get; set; }
Public Property IDCode As ULong
    Get
    Set
member IDCode : uint64 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned long long IDCode {
    unsigned long long get ();
    void set (unsigned long long value);
}

Property Value

Type: UInt64
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.Timestamp Property

Grid Solutions Framework HeaderFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.TimeTag Property

Grid Solutions Framework HeaderFrameTimeTag Property
Gets the timestamp of this frame in NTP format.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
member TimeTag : NtpTimeTag with get

function get_TimeTag();

public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


HeaderFrame.TypeID Property

Grid Solutions Framework HeaderFrameTypeID Property
Gets the identifier that is used to identify the IEEE 1344 frame.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents the IEEE 1344 implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.IEEE1344PhasorDefinition

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.IEEE1344.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinition Constructor (IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinition
GSF.PhasorProtocols.IEEE1344.PhasorDefinition = function(parent);
public:
PhasorDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinition.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.IEEE1344.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.IEEE1344.PhasorDefinition = function(parent, label, scale, offset, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344ConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
scale
Type: SystemUInt32
The integer scaling value of this PhasorDefinition.
offset
Type: SystemDouble
The offset of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.IEEE1344PhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Class

Grid Solutions Framework PhasorValue Class
Represents the IEEE 1344 implementation of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.IEEE1344PhasorValue

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute>
Public Class PhasorValue
    Inherits PhasorValueBase
[<SerializableAttribute>]
type PhasorValue =
    class
        inherit PhasorValueBase
    end
GSF.PhasorProtocols.IEEE1344.PhasorValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEE1344.PhasorValue',
    GSF.PhasorProtocols.PhasorValueBase);
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase

The PhasorValue type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Constructor

Grid Solutions Framework PhasorValue Constructor
Overload List
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValue Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValue
GSF.PhasorProtocols.IEEE1344.PhasorValue = function(info, context);
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValue Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValue
GSF.PhasorProtocols.IEEE1344.PhasorValue = function(parent, phasorDefinition);
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValue
GSF.PhasorProtocols.IEEE1344.PhasorValue = function(parent, phasorDefinition, angle, magnitude);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344DataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.IEEE1344PhasorDefinition
The PhasorDefinition associated with this PhasorValue.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        real : float *
        imaginary : float -> PhasorValue
GSF.PhasorProtocols.IEEE1344.PhasorValue = function(parent, phasorDefinition, real, imaginary);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEE1344DataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.IEEE1344PhasorDefinition
The PhasorDefinition associated with this PhasorValue.
real
Type: SystemDouble
The real value of this PhasorValue.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Methods

Grid Solutions Framework PhasorValue Methods

The PhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue Properties

Grid Solutions Framework PhasorValue Properties

The PhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue.Definition Property

Grid Solutions Framework PhasorValueDefinition Property
Gets or sets the PhasorDefinition associated with this PhasorValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
abstract Definition : PhasorDefinition with get, set
override Definition : PhasorDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}

Property Value

Type: PhasorDefinition
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


PhasorValue.Parent Property

Grid Solutions Framework PhasorValueParent Property
Gets or sets the DataCell parent of this PhasorValue.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEE1344 Namespace


TriggerStatus Enumeration

Grid Solutions Framework TriggerStatus Enumeration
IEEE 1344 trigger status enumeration.

Namespace: GSF.PhasorProtocols.IEEE1344
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum TriggerStatus
<SerializableAttribute>
Public Enumeration TriggerStatus
[<SerializableAttribute>]
type TriggerStatus
GSF.PhasorProtocols.IEEE1344.TriggerStatus = function();
GSF.PhasorProtocols.IEEE1344.TriggerStatus.createEnum('GSF.PhasorProtocols.IEEE1344.TriggerStatus', false);
[SerializableAttribute]
public enum class TriggerStatus
Members
Member name | Value | Description
FrequencyTrigger | 14336 | 111 Frequency trigger.
DfDtTrigger | 12288 | 110 df/dt trigger.
AngleTrigger | 10240 | 101 Angle trigger.
OverCurrentTrigger | 8192 | 100 Overcurrent trigger.
UnderVoltageTrigger | 6144 | 011 Undervoltage trigger.
RateTrigger | 4096 | 010 Rate trigger.
UserDefined | 2048 | 001 User defined.
Unused | 0 | 000 Unused.
See Also

Reference

GSF.PhasorProtocols.IEEE1344 Namespace


GSF.PhasorProtocols.IEEEC37_118 Namespace

Grid Solutions Framework GSF.PhasorProtocols.IEEEC37_118 Namespace
Contains an implementation of the phasor classes used to parse or generate a stream of data in the IEEE C37.118-2005 standard format.
Classes
 | Class | Description
Public class | AnalogDefinition | Represents the IEEE C37.118 implementation of an IAnalogDefinition.
Public class | AnalogValue | Represents the IEEE C37.118 implementation of an IAnalogValue.
Public class | CommandFrame | Represents the IEEE C37.118 implementation of a ICommandFrame that can be sent or received.
Public class | Common | Common IEEE C37.118 declarations and functions.
Public class | CommonFrameHeader | Represents the common header for all IEEE C37.118 frames of data.
Public class | ConfigurationCell | Represents the IEEE C37.118 implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCell3 | Represents the IEEE C37.118 implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a IEEE C37.118 implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame1 | Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 1, that can be sent or received.
Public class | ConfigurationFrame1Draft6 | Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 1, that can be sent or received.
Public class | ConfigurationFrame2 | Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 2, that can be sent or received.
Public class | ConfigurationFrame2Draft6 | Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 2, that can be sent or received.
Public class | ConfigurationFrame3 | Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 3, that can be sent or received.
Public class | DataCell | Represents the IEEE C37.118 implementation of a IDataCell that can be sent or received.
Public class | DataCellCollection | Represents a IEEE C37.118 implementation of a collection of IDataCell objects.
Public class | DataFrame | Represents the IEEE C37.118 implementation of a IDataFrame that can be sent or received.
Public class | DigitalDefinition | Represents the IEEE C37.118 implementation of a IDigitalDefinition.
Public class | DigitalValue | Represents the IEEE C37.118 implementation of a IDigitalValue.
Public class | FrameParser | Represents a frame parser for an IEEE C37.118 binary data stream and returns parsed data via events.
Public class | FrequencyDefinition | Represents the IEEE C37.118 implementation of a IFrequencyDefinition.
Public class | FrequencyValue | Represents the IEEE C37.118 implementation of a IFrequencyValue.
Public class | HeaderFrame | Represents the IEEE C37.118 implementation of a IHeaderFrame that can be sent or received.
Public class | PhasorDefinition | Represents the IEEE C37.118 implementation of a IPhasorDefinition.
Public class | PhasorValue | Represents the IEEE C37.118 implementation of a IPhasorValue.
Enumerations
 | Enumeration | Description
Public enumeration | DraftRevision | Protocol draft revision numbers enumeration.
Public enumeration | FormatFlags | Data format flags enumeration.
Public enumeration | FrameType | IEEE C37.118 frame types enumeration.
Public enumeration | StatusFlags | Status flags enumeration.
Public enumeration | TimeQualityFlags | Time quality flags enumeration.
Public enumeration | TimeQualityIndicatorCode | Time quality indicator code enumeration.
Public enumeration | TriggerReason | Trigger reason enumeration.
Public enumeration | UnlockedTime | Unlocked time enumeration.


AnalogDefinition Class

Grid Solutions Framework AnalogDefinition Class
Represents the IEEE C37.118 implementation of an IAnalogDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsAnalogDefinitionBase
GSF.PhasorProtocols.IEEEC37_118AnalogDefinition

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogDefinition : AnalogDefinitionBase
<SerializableAttribute>
Public Class AnalogDefinition
    Inherits AnalogDefinitionBase
[<SerializableAttribute>]
type AnalogDefinition =
    class
        inherit AnalogDefinitionBase
    end
GSF.PhasorProtocols.IEEEC37_118.AnalogDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.AnalogDefinition',
    GSF.PhasorProtocols.AnalogDefinitionBase);
[SerializableAttribute]
public ref class AnalogDefinition : public AnalogDefinitionBase

The AnalogDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogDefinition Constructor

Grid Solutions Framework AnalogDefinition Constructor
Overload List
 | Name | Description
Public method | AnalogDefinition(IConfigurationCell) | Creates a new AnalogDefinition from specified parameters.
Protected method | AnalogDefinition(SerializationInfo, StreamingContext) | Creates a new AnalogDefinition from serialization parameters.
Public method | AnalogDefinition(ConfigurationCell, String, UInt32, Double, AnalogType) | Creates a new AnalogDefinition from specified parameters.
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogDefinition Constructor (IConfigurationCell)

Grid Solutions Framework AnalogDefinition Constructor (IConfigurationCell)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> AnalogDefinition
GSF.PhasorProtocols.IEEEC37_118.AnalogDefinition = function(parent);
public:
AnalogDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogDefinition
GSF.PhasorProtocols.IEEEC37_118.AnalogDefinition = function(info, context);
protected:
AnalogDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogDefinition Constructor (ConfigurationCell, String, UInt32, Double, AnalogType)

Grid Solutions Framework AnalogDefinition Constructor (ConfigurationCell, String, UInt32, Double, AnalogType)
Creates a new AnalogDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    AnalogType type
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As AnalogType
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : AnalogType -> AnalogDefinition
GSF.PhasorProtocols.IEEEC37_118.AnalogDefinition = function(parent, label, scale, offset, type);
public:
AnalogDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    AnalogType type
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationCell
The ConfigurationCell parent of this AnalogDefinition.
label
Type: SystemString
The label of this AnalogDefinition.
scale
Type: SystemUInt32
The integer scaling value of this AnalogDefinition.
offset
Type: SystemDouble
The offset of this AnalogDefinition.
type
Type: GSF.PhasorProtocolsAnalogType
The AnalogType of this AnalogDefinition.
See Also

Reference

AnalogDefinition Class
AnalogDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogDefinition Methods

Grid Solutions Framework AnalogDefinition Methods

The AnalogDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogDefinition Properties

Grid Solutions Framework AnalogDefinition Properties

The AnalogDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AnalogType | Gets or sets AnalogType of this AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this AnalogDefinitionBase object. (Inherited from AnalogDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat for the AnalogDefinitionBase. (Inherited from AnalogDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this AnalogDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogDefinition.Parent Property

Grid Solutions Framework AnalogDefinitionParent Property
Gets or sets the ConfigurationCell parent of this AnalogDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

AnalogDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue Class

Grid Solutions Framework AnalogValue Class
Represents the IEEE C37.118 implementation of an IAnalogValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IAnalogDefinition
GSF.PhasorProtocolsAnalogValueBase
GSF.PhasorProtocols.IEEEC37_118AnalogValue

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class AnalogValue : AnalogValueBase
<SerializableAttribute>
Public Class AnalogValue
    Inherits AnalogValueBase
[<SerializableAttribute>]
type AnalogValue =
    class
        inherit AnalogValueBase
    end
GSF.PhasorProtocols.IEEEC37_118.AnalogValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.AnalogValue',
    GSF.PhasorProtocols.AnalogValueBase);
[SerializableAttribute]
public ref class AnalogValue : public AnalogValueBase

The AnalogValue type exposes the following members.

Constructors
 | Name | Description
Protected method | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
Public method | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
Public method | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from AnalogValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this AnalogValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue Constructor

Grid Solutions Framework AnalogValue Constructor
Overload List
 | Name | Description
Protected method | AnalogValue(SerializationInfo, StreamingContext) | Creates a new AnalogValue from serialization parameters.
Public method | AnalogValue(IDataCell, IAnalogDefinition) | Creates a new AnalogValue.
Public method | AnalogValue(DataCell, AnalogDefinition, Double) | Creates a new AnalogValue from specified parameters.
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework AnalogValue Constructor (SerializationInfo, StreamingContext)
Creates a new AnalogValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AnalogValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> AnalogValue
GSF.PhasorProtocols.IEEEC37_118.AnalogValue = function(info, context);
protected:
AnalogValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue Constructor (IDataCell, IAnalogDefinition)

Grid Solutions Framework AnalogValue Constructor (IDataCell, IAnalogDefinition)
Creates a new AnalogValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogValue(
    IDataCell parent,
    IAnalogDefinition analogDefinition
)
Public Sub New (
    parent As IDataCell,
    analogDefinition As IAnalogDefinition
)
new :
        parent : IDataCell *
        analogDefinition : IAnalogDefinition -> AnalogValue
GSF.PhasorProtocols.IEEEC37_118.AnalogValue = function(parent, analogDefinition);
public:
AnalogValue(
    IDataCell^ parent,
    IAnalogDefinition^ analogDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this AnalogValue.
analogDefinition
Type: GSF.PhasorProtocolsIAnalogDefinition
The IAnalogDefinition associated with this AnalogValue.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue Constructor (DataCell, AnalogDefinition, Double)

Grid Solutions Framework AnalogValue Constructor (DataCell, AnalogDefinition, Double)
Creates a new AnalogValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogValue(
    DataCell parent,
    AnalogDefinition analogDefinition,
    double value
)
Public Sub New (
    parent As DataCell,
    analogDefinition As AnalogDefinition,
    value As Double
)
new :
        parent : DataCell *
        analogDefinition : AnalogDefinition *
        value : float -> AnalogValue
GSF.PhasorProtocols.IEEEC37_118.AnalogValue = function(parent, analogDefinition, value);
public:
AnalogValue(
    DataCell^ parent,
    AnalogDefinition^ analogDefinition,
    double value
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118DataCell
The DataCell parent of this AnalogValue.
analogDefinition
Type: GSF.PhasorProtocols.IEEEC37_118AnalogDefinition
The AnalogDefinition associated with this AnalogValue.
value
Type: SystemDouble
The floating point value that represents this AnalogValue.
See Also

Reference

AnalogValue Class
AnalogValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue Methods

Grid Solutions Framework AnalogValue Methods

The AnalogValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this AnalogValueBase. (Inherited from AnalogValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from AnalogValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from AnalogValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue Properties

Grid Solutions Framework AnalogValue Properties

The AnalogValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the AnalogValueBase object. (Inherited from AnalogValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the AnalogValueBase object. (Inherited from AnalogValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from AnalogValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this AnalogValueBase provides. (Inherited from AnalogValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the AnalogDefinition associated with this AnalogValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IntegerValue | Gets or sets the integer representation of this AnalogValueBase value. (Inherited from AnalogValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of AnalogValueBase have been assigned a value. (Inherited from AnalogValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this AnalogValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the floating point value that represents this AnalogValueBase. (Inherited from AnalogValueBase.)
Top
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue.Definition Property

Grid Solutions Framework AnalogValueDefinition Property
Gets or sets the AnalogDefinition associated with this AnalogValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AnalogDefinition Definition { get; set; }
Public Overridable Property Definition As AnalogDefinition
    Get
    Set
abstract Definition : AnalogDefinition with get, set
override Definition : AnalogDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property AnalogDefinition^ Definition {
    AnalogDefinition^ get ();
    void set (AnalogDefinition^ value);
}

Property Value

Type: AnalogDefinition
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


AnalogValue.Parent Property

Grid Solutions Framework AnalogValueParent Property
Gets or sets the DataCell parent of this AnalogValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

AnalogValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame Class

Grid Solutions Framework CommandFrame Class
Represents the IEEE C37.118 implementation of a ICommandFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase ICommandCell
GSF.PhasorProtocolsCommandFrameBase
GSF.PhasorProtocols.IEEEC37_118CommandFrame

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute>
Public Class CommandFrame
    Inherits CommandFrameBase
[<SerializableAttribute>]
type CommandFrame =
    class
        inherit CommandFrameBase
    end
GSF.PhasorProtocols.IEEEC37_118.CommandFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.CommandFrame',
    GSF.PhasorProtocols.CommandFrameBase);
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase

The CommandFrame type exposes the following members.

Constructors
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Public method | CommandFrame(UInt16, DeviceCommand, Byte) | Creates a new CommandFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEEE C37.118 protocol version of this CommandFrame.
Top
Remarks
IEEE C37.118 command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImageTTypeIdentifier for automated frame parsing. This class exposes a constructor that accepts a binary image in order to manually parse a command frame.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame Constructor

Grid Solutions Framework CommandFrame Constructor
Overload List
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Public method | CommandFrame(UInt16, DeviceCommand, Byte) | Creates a new CommandFrame from specified parameters.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandFrame Constructor (SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandFrame
GSF.PhasorProtocols.IEEEC37_118.CommandFrame = function(info, context);
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame Constructor (Byte[], Int32, Int32)

Grid Solutions Framework CommandFrame Constructor (Byte, Int32, Int32)
Creates a new CommandFrame from the given buffer.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> CommandFrame
GSF.PhasorProtocols.IEEEC37_118.CommandFrame = function(buffer, startIndex, length);
public:
CommandFrame(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | length is not large enough to parse frame.
Remarks
This constructor is used by a consumer to parse a received IEEE C37.118 command frame. Typically command frames are sent to a device. This constructor would used if this code was being used inside of a phasor measurement device.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame Constructor (UInt16, DeviceCommand, Byte)

Grid Solutions Framework CommandFrame Constructor (UInt16, DeviceCommand, Byte)
Creates a new CommandFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    ushort idCode,
    DeviceCommand command,
    byte version
)
Public Sub New (
    idCode As UShort,
    command As DeviceCommand,
    version As Byte
)
new :
        idCode : uint16 *
        command : DeviceCommand *
        version : byte -> CommandFrame
GSF.PhasorProtocols.IEEEC37_118.CommandFrame = function(idCode, command, version);
public:
CommandFrame(
    unsigned short idCode,
    DeviceCommand command,
    unsigned char version
)

Parameters

idCode
Type: SystemUInt16
The ID code of this CommandFrame.
command
Type: GSF.PhasorProtocolsDeviceCommand
The DeviceCommand for this CommandFrame.
version
Type: SystemByte
IEEE C37.118 revision number.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 command frame.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame Methods

Grid Solutions Framework CommandFrame Methods

The CommandFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.CalculateChecksum Method

Grid Solutions Framework CommandFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.GetObjectData Method

Grid Solutions Framework CommandFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.ParseHeaderImage Method

Grid Solutions Framework CommandFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame Properties

Grid Solutions Framework CommandFrame Properties

The CommandFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEEE C37.118 protocol version of this CommandFrame.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.Attributes Property

Grid Solutions Framework CommandFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.CommonHeader Property

Grid Solutions Framework CommandFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.HeaderImage Property

Grid Solutions Framework CommandFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.HeaderLength Property

Grid Solutions Framework CommandFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.Timestamp Property

Grid Solutions Framework CommandFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommandFrame.Version Property

Grid Solutions Framework CommandFrameVersion Property
Gets the IEEE C37.118 protocol version of this CommandFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
member Version : byte with get, set

function get_Version();
function set_Version(value);
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


Common Class

Grid Solutions Framework Common Class
Common IEEE C37.118 declarations and functions.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEEEC37_118Common

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.IEEEC37_118.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.Common');
public ref class Common abstract sealed

The Common type exposes the following members.

Fields
Name | Description
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
TimeQualityFlagsMask | Time quality flags mask.
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
TimeQualityFlagsMask | Time quality flags mask.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


Common.MaximumAnalogValues Field

Grid Solutions Framework CommonMaximumAnalogValues Field
Absolute maximum number of possible analog values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
static val mutable MaximumAnalogValues: uint16
var GSF.PhasorProtocols.IEEEC37_118.Common.MaximumAnalogValues
public:
literal unsigned short MaximumAnalogValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


Common.MaximumDataLength Field

Grid Solutions Framework CommonMaximumDataLength Field
Absolute maximum data length (in bytes) that could fit into any frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
static val mutable MaximumDataLength: uint16
var GSF.PhasorProtocols.IEEEC37_118.Common.MaximumDataLength
public:
literal unsigned short MaximumDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


Common.MaximumDigitalValues Field

Grid Solutions Framework CommonMaximumDigitalValues Field
Absolute maximum number of possible digital values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
static val mutable MaximumDigitalValues: uint16
var GSF.PhasorProtocols.IEEEC37_118.Common.MaximumDigitalValues
public:
literal unsigned short MaximumDigitalValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


Common.MaximumExtendedDataLength Field

Grid Solutions Framework CommonMaximumExtendedDataLength Field
Absolute maximum number of bytes of extended data that could fit into a command frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumExtendedDataLength
Public Const MaximumExtendedDataLength As UShort
static val mutable MaximumExtendedDataLength: uint16
var GSF.PhasorProtocols.IEEEC37_118.Common.MaximumExtendedDataLength
public:
literal unsigned short MaximumExtendedDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


Common.MaximumPhasorValues Field

Grid Solutions Framework CommonMaximumPhasorValues Field
Absolute maximum number of possible phasor values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
static val mutable MaximumPhasorValues: uint16
var GSF.PhasorProtocols.IEEEC37_118.Common.MaximumPhasorValues
public:
literal unsigned short MaximumPhasorValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


Common.TimeQualityFlagsMask Field

Grid Solutions Framework CommonTimeQualityFlagsMask Field
Time quality flags mask.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const uint TimeQualityFlagsMask
Public Const TimeQualityFlagsMask As UInteger
static val mutable TimeQualityFlagsMask: uint32
var GSF.PhasorProtocols.IEEEC37_118.Common.TimeQualityFlagsMask
public:
literal unsigned int TimeQualityFlagsMask

Field Value

Type: UInt32
See Also

Reference

Common Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Class

Grid Solutions Framework CommonFrameHeader Class
Represents the common header for all IEEE C37.118 frames of data.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEEEC37_118CommonFrameHeader

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable
<SerializableAttribute>
Public Class CommonFrameHeader
    Implements ICommonHeader(Of FrameType), ISerializable
[<SerializableAttribute>]
type CommonFrameHeader =
    class
        interface ICommonHeader<FrameType>
        interface ISerializable
    end
GSF.PhasorProtocols.IEEEC37_118.CommonFrameHeader = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.CommonFrameHeader',
    null,
    GSF.Parsing.ICommonHeader`1,
    ISerializable);
[SerializableAttribute]
public ref class CommonFrameHeader : ICommonHeader<FrameType>,
    ISerializable

The CommonFrameHeader type exposes the following members.

Constructors
 | Name | Description
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(ConfigurationFrame1, Byte, Int32) | Creates a new CommonFrameHeader from given buffer.
Public method | CommonFrameHeader(ConfigurationFrame1, FrameType, UInt16, Ticks) | Creates a new CommonFrameHeader from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
Top
Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | DataLength | Gets or sets the length of the data in the IEEE C37.118 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FractionOfSecond | Gets the IEEE C37.118 fraction of second.
Public property | FrameLength | Gets or sets the IEEE C37.118 frame length of this frame.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | IDCode | Gets or sets the IEEE C37.118 ID code of this frame.
Public property | SecondOfCentury | Gets the IEEE C37.118 second of century.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps.
Public property | TimeQualityFlags | Gets or sets the IEEE C37.118 TimeQualityFlags.
Public property | TimeQualityIndicatorCode | Gets or sets the IEEE C37.118 TimeQualityIndicatorCode.
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets time as a UnixTimeTag representing seconds of current Timestamp.
Public property | TypeID | Gets or sets the IEEE C37.118 specific frame type of this frame.
Public property | Version | Gets or sets the IEEE C37.118 version of this frame.
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Overload List
 | Name | Description
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(ConfigurationFrame1, Byte, Int32) | Creates a new CommonFrameHeader from given buffer.
Public method | CommonFrameHeader(ConfigurationFrame1, FrameType, UInt16, Ticks) | Creates a new CommonFrameHeader from specified parameters.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommonFrameHeader Constructor (SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommonFrameHeader
GSF.PhasorProtocols.IEEEC37_118.CommonFrameHeader = function(info, context);
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Constructor (ConfigurationFrame1, Byte[], Int32)

Grid Solutions Framework CommonFrameHeader Constructor (ConfigurationFrame1, Byte, Int32)
Creates a new CommonFrameHeader from given buffer.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    ConfigurationFrame1 configurationFrame,
    byte[] buffer,
    int startIndex
)
Public Sub New (
    configurationFrame As ConfigurationFrame1,
    buffer As Byte(),
    startIndex As Integer
)
new :
        configurationFrame : ConfigurationFrame1 *
        buffer : byte[] *
        startIndex : int -> CommonFrameHeader
GSF.PhasorProtocols.IEEEC37_118.CommonFrameHeader = function(configurationFrame, buffer, startIndex);
public:
CommonFrameHeader(
    ConfigurationFrame1^ configurationFrame,
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

configurationFrame
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
IEEE C37.118 ConfigurationFrame1 if already parsed.
buffer
Type: SystemByte
Buffer that contains data to parse.
startIndex
Type: SystemInt32
Start index into buffer where valid data begins.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Constructor (ConfigurationFrame1, FrameType, UInt16, Ticks)

Grid Solutions Framework CommonFrameHeader Constructor (ConfigurationFrame1, FrameType, UInt16, Ticks)
Creates a new CommonFrameHeader from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    ConfigurationFrame1 configurationFrame,
    FrameType typeID,
    ushort idCode,
    Ticks timestamp
)
Public Sub New (
    configurationFrame As ConfigurationFrame1,
    typeID As FrameType,
    idCode As UShort,
    timestamp As Ticks
)
new :
        configurationFrame : ConfigurationFrame1 *
        typeID : FrameType *
        idCode : uint16 *
        timestamp : Ticks -> CommonFrameHeader
GSF.PhasorProtocols.IEEEC37_118.CommonFrameHeader = function(configurationFrame, typeID, idCode, timestamp);
public:
CommonFrameHeader(
    ConfigurationFrame1^ configurationFrame,
    FrameType typeID,
    unsigned short idCode,
    Ticks timestamp
)

Parameters

configurationFrame
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
IEEE C37.118 ConfigurationFrame1 if available.
typeID
Type: GSF.PhasorProtocols.IEEEC37_118FrameType
The IEEE C37.118 specific frame type of this frame.
idCode
Type: SystemUInt16
The ID code of this frame.
timestamp
Type: GSFTicks
The timestamp of this frame.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Fields

Grid Solutions Framework CommonFrameHeader Fields

The CommonFrameHeader type exposes the following members.

Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.FixedLength Field

Grid Solutions Framework CommonFrameHeaderFixedLength Field
Total fixed length of CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FixedLength
Public Const FixedLength As UShort
static val mutable FixedLength: uint16
var GSF.PhasorProtocols.IEEEC37_118.CommonFrameHeader.FixedLength
public:
literal unsigned short FixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Methods

Grid Solutions Framework CommonFrameHeader Methods

The CommonFrameHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.GetObjectData Method

Grid Solutions Framework CommonFrameHeaderGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader Properties

Grid Solutions Framework CommonFrameHeader Properties

The CommonFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this frame.
Public property | DataLength | Gets or sets the length of the data in the IEEE C37.118 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).
Public property | FractionOfSecond | Gets the IEEE C37.118 fraction of second.
Public property | FrameLength | Gets or sets the IEEE C37.118 frame length of this frame.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | IDCode | Gets or sets the IEEE C37.118 ID code of this frame.
Public property | SecondOfCentury | Gets the IEEE C37.118 second of century.
Public property | State | Gets or sets the parsing state for the CommonFrameHeader object.
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps.
Public property | TimeQualityFlags | Gets or sets the IEEE C37.118 TimeQualityFlags.
Public property | TimeQualityIndicatorCode | Gets or sets the IEEE C37.118 TimeQualityIndicatorCode.
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets time as a UnixTimeTag representing seconds of current Timestamp.
Public property | TypeID | Gets or sets the IEEE C37.118 specific frame type of this frame.
Public property | Version | Gets or sets the IEEE C37.118 version of this frame.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.BinaryImage Property

Grid Solutions Framework CommonFrameHeaderBinaryImage Property
Gets the binary image of the common header portion of this frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
member BinaryImage : byte[] with get

function get_BinaryImage();

public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.DataLength Property

Grid Solutions Framework CommonFrameHeaderDataLength Property
Gets or sets the length of the data in the IEEE C37.118 frame (i.e., the FrameLength minus the header length and checksum: FrameLength - 8).

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DataLength { get; set; }
Public Property DataLength As UShort
    Get
    Set
member DataLength : uint16 with get, set

function get_DataLength();
function set_DataLength(value);
public:
property unsigned short DataLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.FractionOfSecond Property

Grid Solutions Framework CommonFrameHeaderFractionOfSecond Property
Gets the IEEE C37.118 fraction of second.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UInt24 FractionOfSecond { get; }
Public ReadOnly Property FractionOfSecond As UInt24
    Get
member FractionOfSecond : UInt24 with get

function get_FractionOfSecond();

public:
property UInt24 FractionOfSecond {
    UInt24 get ();
}

Property Value

Type: UInt24
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.FrameLength Property

Grid Solutions Framework CommonFrameHeaderFrameLength Property
Gets or sets the IEEE C37.118 frame length of this frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort FrameLength { get; set; }
Public Property FrameLength As UShort
    Get
    Set
member FrameLength : uint16 with get, set

function get_FrameLength();
function set_FrameLength(value);
public:
property unsigned short FrameLength {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.FrameType Property

Grid Solutions Framework CommonFrameHeaderFrameType Property
Gets the fundamental frame type of this frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
member FrameType : FundamentalFrameType with get

function get_FrameType();

public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}

Property Value

Type: FundamentalFrameType
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.IDCode Property

Grid Solutions Framework CommonFrameHeaderIDCode Property
Gets or sets the IEEE C37.118 ID code of this frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort IDCode { get; set; }
Public Property IDCode As UShort
    Get
    Set
member IDCode : uint16 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned short IDCode {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.SecondOfCentury Property

Grid Solutions Framework CommonFrameHeaderSecondOfCentury Property
Gets the IEEE C37.118 second of century.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint SecondOfCentury { get; }
Public ReadOnly Property SecondOfCentury As UInteger
    Get
member SecondOfCentury : uint32 with get

function get_SecondOfCentury();

public:
property unsigned int SecondOfCentury {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.State Property

Grid Solutions Framework CommonFrameHeaderState Property
Gets or sets the parsing state for the CommonFrameHeader object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IChannelParsingState State { get; set; }
Public Property State As IChannelParsingState
    Get
    Set
member State : IChannelParsingState with get, set

function get_State();
function set_State(value);
public:
property IChannelParsingState^ State {
    IChannelParsingState^ get ();
    void set (IChannelParsingState^ value);
}

Property Value

Type: IChannelParsingState
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.Timebase Property

Grid Solutions Framework CommonFrameHeaderTimebase Property
Gets or sets the IEEE C37.118 resolution of fractional time stamps.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Timebase { get; set; }
Public Property Timebase As UInteger
    Get
    Set
member Timebase : uint32 with get, set

function get_Timebase();
function set_Timebase(value);
public:
property unsigned int Timebase {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.TimeQualityFlags Property

Grid Solutions Framework CommonFrameHeaderTimeQualityFlags Property
Gets or sets the IEEE C37.118 TimeQualityFlags.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
member TimeQualityFlags : TimeQualityFlags with get, set

function get_TimeQualityFlags();
function set_TimeQualityFlags(value);
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}

Property Value

Type: TimeQualityFlags
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.TimeQualityIndicatorCode Property

Grid Solutions Framework CommonFrameHeaderTimeQualityIndicatorCode Property
Gets or sets the IEEE C37.118 TimeQualityIndicatorCode.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
member TimeQualityIndicatorCode : TimeQualityIndicatorCode with get, set

function get_TimeQualityIndicatorCode();
function set_TimeQualityIndicatorCode(value);
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}

Property Value

Type: TimeQualityIndicatorCode
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.Timestamp Property

Grid Solutions Framework CommonFrameHeaderTimestamp Property
Gets or sets timestamp of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
member Timestamp : Ticks with get, set

function get_Timestamp();
function set_Timestamp(value);
public:
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.TimeTag Property

Grid Solutions Framework CommonFrameHeaderTimeTag Property
Gets time as a UnixTimeTag representing seconds of current Timestamp.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnixTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As UnixTimeTag
    Get
member TimeTag : UnixTimeTag with get

function get_TimeTag();

public:
property UnixTimeTag^ TimeTag {
    UnixTimeTag^ get ();
}

Property Value

Type: UnixTimeTag
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.TypeID Property

Grid Solutions Framework CommonFrameHeaderTypeID Property
Gets or sets the IEEE C37.118 specific frame type of this frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; set; }
Public Property TypeID As FrameType
    Get
    Set
abstract TypeID : FrameType with get, set
override TypeID : FrameType with get, set
function get_TypeID();
function set_TypeID(value);
public:
virtual property FrameType TypeID {
    FrameType get () sealed;
    void set (FrameType value) sealed;
}

Property Value

Type: FrameType

Implements

ICommonHeaderTTypeIdentifierTypeID
Remarks

This returns the protocol specific frame classification which uniquely identifies the frame type.

This is the TypeID implementation.

See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


CommonFrameHeader.Version Property

Grid Solutions Framework CommonFrameHeaderVersion Property
Gets or sets the IEEE C37.118 version of this frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
member Version : byte with get, set

function get_Version();
function set_Version(value);
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents the IEEE C37.118 implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.IEEEC37_118ConfigurationCell

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
    end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame1, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FormatFlags | Gets or sets format flags of this ConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame1 for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Overload List
 | Name | Description
Public method | ConfigurationCell(IConfigurationFrame) | Creates a new ConfigurationCell.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame1, UInt16, LineFrequency) | Creates a new ConfigurationCell from specified parameters.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell Constructor (IConfigurationFrame)

Grid Solutions Framework ConfigurationCell Constructor (IConfigurationFrame)
Creates a new ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    IConfigurationFrame parent
)
Public Sub New (
    parent As IConfigurationFrame
)
new :
        parent : IConfigurationFrame -> ConfigurationCell
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell = function(parent);
public:
ConfigurationCell(
    IConfigurationFrame^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationFrame
The reference to parent IConfigurationFrame of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCell Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell Constructor (ConfigurationFrame1, UInt16, LineFrequency)

Grid Solutions Framework ConfigurationCell Constructor (ConfigurationFrame1, UInt16, LineFrequency)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ConfigurationFrame1 parent,
    ushort idCode,
    LineFrequency nominalFrequency
)
Public Sub New (
    parent As ConfigurationFrame1,
    idCode As UShort,
    nominalFrequency As LineFrequency
)
new :
        parent : ConfigurationFrame1 *
        idCode : uint16 *
        nominalFrequency : LineFrequency -> ConfigurationCell
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell = function(parent, idCode, nominalFrequency);
public:
ConfigurationCell(
    ConfigurationFrame1^ parent,
    unsigned short idCode,
    LineFrequency nominalFrequency
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
The reference to parent ConfigurationFrame1 of this ConfigurationCell.
idCode
Type: SystemUInt16
The numeric ID code for this ConfigurationCell.
nominalFrequency
Type: GSF.Units.EELineFrequency
The nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides ConfigurationCellBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides ConfigurationCellBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.GetObjectData Method

Grid Solutions Framework ConfigurationCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.ParseFooterImage Method

Grid Solutions Framework ConfigurationCellParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.ParseHeaderImage Method

Grid Solutions Framework ConfigurationCellParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCell object. (Overrides ConfigurationCellBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides ConfigurationCellBaseFooterLength.)
Public property | FormatFlags | Gets or sets format flags of this ConfigurationCell.
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCell object. (Overrides ConfigurationCellBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides ConfigurationCellBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ChannelCellBase. (Inherited from ChannelCellBase.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame1 for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.Attributes Property

Grid Solutions Framework ConfigurationCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.FooterImage Property

Grid Solutions Framework ConfigurationCellFooterImage Property
Gets the binary footer image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.FooterLength Property

Grid Solutions Framework ConfigurationCellFooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.FormatFlags Property

Grid Solutions Framework ConfigurationCellFormatFlags Property
Gets or sets format flags of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public FormatFlags FormatFlags { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Property FormatFlags As FormatFlags
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member FormatFlags : FormatFlags with get, set

function get_FormatFlags();
function set_FormatFlags(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property FormatFlags FormatFlags {
    FormatFlags get ();
    void set (FormatFlags value);
}

Property Value

Type: FormatFlags
Remarks
These are bit flags, use properties to change basic values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.HeaderImage Property

Grid Solutions Framework ConfigurationCellHeaderImage Property
Gets the binary header image of the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.HeaderLength Property

Grid Solutions Framework ConfigurationCellHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.Parent Property

Grid Solutions Framework ConfigurationCellParent Property
Gets a reference to the parent ConfigurationFrame1 for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame1 Parent { get; set; }
Public Property Parent As ConfigurationFrame1
    Get
    Set
member Parent : ConfigurationFrame1 with get, set

function get_Parent();
function set_Parent(value);
public:
property ConfigurationFrame1^ Parent {
    ConfigurationFrame1^ get ();
    void set (ConfigurationFrame1^ value);
}

Property Value

Type: ConfigurationFrame1
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell3 Class

Grid Solutions Framework ConfigurationCell3 Class
Represents the IEEE C37.118 implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.IEEEC37_118ConfigurationCell3

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell3
<SerializableAttribute>
Public Class ConfigurationCell3
[<SerializableAttribute>]
type ConfigurationCell3 =  class end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell3 = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell3');
[SerializableAttribute]
public ref class ConfigurationCell3

The ConfigurationCell3 type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCell3 | Initializes a new instance of the ConfigurationCell3 class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell3 Constructor

Grid Solutions Framework ConfigurationCell3 Constructor
Initializes a new instance of the ConfigurationCell3 class

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell3()
Public Sub New
new : unit -> ConfigurationCell3
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCell3 = function();
public:
ConfigurationCell3()
See Also

Reference

ConfigurationCell3 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCell3 Methods

Grid Solutions Framework ConfigurationCell3 Methods

The ConfigurationCell3 type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell3 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a IEEE C37.118 implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.IEEEC37_118ConfigurationCellCollection

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.IEEEC37_118.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1 Class

Grid Solutions Framework ConfigurationFrame1 Class
Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 1, that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1Draft6
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame2
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame3

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame1 : ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class ConfigurationFrame1
    Inherits ConfigurationFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type ConfigurationFrame1 =
    class
        inherit ConfigurationFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1 = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1',
    GSF.PhasorProtocols.ConfigurationFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class ConfigurationFrame1 : public ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The ConfigurationFrame1 type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame1 | Creates a new ConfigurationFrame1.
Protected method | ConfigurationFrame1(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1 from serialization parameters.
Public method | ConfigurationFrame1(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1 from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame1.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1.
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1 Constructor

Grid Solutions Framework ConfigurationFrame1 Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame1 | Creates a new ConfigurationFrame1.
Protected method | ConfigurationFrame1(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1 from serialization parameters.
Public method | ConfigurationFrame1(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1 from specified parameters.
Top
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1 Constructor

Grid Solutions Framework ConfigurationFrame1 Constructor
Creates a new ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame1()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1 = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame1()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE C37.118 configuration frame.
See Also

Reference

ConfigurationFrame1 Class
ConfigurationFrame1 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1 Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame1 Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame1 from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame1(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1 = function(info, context);
protected:
ConfigurationFrame1(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame1 Class
ConfigurationFrame1 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1 Constructor (UInt32, UInt16, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame1 Constructor (UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame1 from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame1(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    timebase As UInteger,
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        timebase : uint32 *
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1 = function(timebase, idCode, timestamp, frameRate);
public:
ConfigurationFrame1(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

timebase
Type: SystemUInt32
Timebase to use for fraction second resolution.
idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame1.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame1.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame1.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 configuration frame.
See Also

Reference

ConfigurationFrame1 Class
ConfigurationFrame1 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1 Methods

Grid Solutions Framework ConfigurationFrame1 Methods

The ConfigurationFrame1 type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Overrides BinaryImageBaseParseFooterImage(Byte, Int32, Int32).)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrame1CalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.GetObjectData Method

Grid Solutions Framework ConfigurationFrame1GetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.ParseFooterImage Method

Grid Solutions Framework ConfigurationFrame1ParseFooterImage Method
Parses the binary footer image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseFooterImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseFooterImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseFooterImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseFooterImage(buffer, startIndex, length);
protected:
virtual int ParseFooterImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.ParseHeaderImage Method

Grid Solutions Framework ConfigurationFrame1ParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1 Properties

Grid Solutions Framework ConfigurationFrame1 Properties

The ConfigurationFrame1 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1.
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Overrides ChannelBaseFooterImage.)
Protected property | FooterLength | Gets the length of the FooterImage. (Overrides BinaryImageBaseFooterLength.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame1.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1.
Top
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.Attributes Property

Grid Solutions Framework ConfigurationFrame1Attributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.Cells Property

Grid Solutions Framework ConfigurationFrame1Cells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.CommonHeader Property

Grid Solutions Framework ConfigurationFrame1CommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.DraftRevision Property

Grid Solutions Framework ConfigurationFrame1DraftRevision Property
Gets the DraftRevision of this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DraftRevision DraftRevision { get; }
Public Overridable ReadOnly Property DraftRevision As DraftRevision
    Get
abstract DraftRevision : DraftRevision with get
override DraftRevision : DraftRevision with get
function get_DraftRevision();

public:
virtual property DraftRevision DraftRevision {
    DraftRevision get ();
}

Property Value

Type: DraftRevision
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.FooterImage Property

Grid Solutions Framework ConfigurationFrame1FooterImage Property
Gets the binary footer image of the ConfigurationFrame1 object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] FooterImage { get; }
Protected Overrides ReadOnly Property FooterImage As Byte()
    Get
abstract FooterImage : byte[] with get
override FooterImage : byte[] with get
function get_FooterImage();

protected:
virtual property array<unsigned char>^ FooterImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.FooterLength Property

Grid Solutions Framework ConfigurationFrame1FooterLength Property
Gets the length of the FooterImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int FooterLength { get; }
Protected Overrides ReadOnly Property FooterLength As Integer
    Get
abstract FooterLength : int with get
override FooterLength : int with get
function get_FooterLength();

protected:
virtual property int FooterLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.HeaderImage Property

Grid Solutions Framework ConfigurationFrame1HeaderImage Property
Gets the binary header image of the ConfigurationFrame1 object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.HeaderLength Property

Grid Solutions Framework ConfigurationFrame1HeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.Timebase Property

Grid Solutions Framework ConfigurationFrame1Timebase Property
Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Timebase { get; set; }
Public Property Timebase As UInteger
    Get
    Set
member Timebase : uint32 with get, set

function get_Timebase();
function set_Timebase(value);
public:
property unsigned int Timebase {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.TimeQualityFlags Property

Grid Solutions Framework ConfigurationFrame1TimeQualityFlags Property
Gets or sets the TimeQualityFlags of this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
member TimeQualityFlags : TimeQualityFlags with get, set

function get_TimeQualityFlags();
function set_TimeQualityFlags(value);
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}

Property Value

Type: TimeQualityFlags
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.TimeQualityIndicatorCode Property

Grid Solutions Framework ConfigurationFrame1TimeQualityIndicatorCode Property
Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
member TimeQualityIndicatorCode : TimeQualityIndicatorCode with get, set

function get_TimeQualityIndicatorCode();
function set_TimeQualityIndicatorCode(value);
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}

Property Value

Type: TimeQualityIndicatorCode
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.Timestamp Property

Grid Solutions Framework ConfigurationFrame1Timestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.TypeID Property

Grid Solutions Framework ConfigurationFrame1TypeID Property
Gets the FrameType of this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrameType TypeID { get; }
Public Overridable ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get ();
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1.Version Property

Grid Solutions Framework ConfigurationFrame1Version Property
Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; set; }
Public Property Version As Byte
    Get
    Set
member Version : byte with get, set

function get_Version();
function set_Version(value);
public:
property unsigned char Version {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame1 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6 Class

Grid Solutions Framework ConfigurationFrame1Draft6 Class
Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 1, that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1Draft6

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame1Draft6 : ConfigurationFrame1
<SerializableAttribute>
Public Class ConfigurationFrame1Draft6
    Inherits ConfigurationFrame1
[<SerializableAttribute>]
type ConfigurationFrame1Draft6 =
    class
        inherit ConfigurationFrame1
    end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1Draft6 = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1Draft6',
    GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1);
[SerializableAttribute]
public ref class ConfigurationFrame1Draft6 : public ConfigurationFrame1

The ConfigurationFrame1Draft6 type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame1Draft6 | Creates a new ConfigurationFrame1Draft6.
Protected method | ConfigurationFrame1Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1Draft6 from serialization parameters.
Public method | ConfigurationFrame1Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1Draft6 from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1Draft6. (Overrides ConfigurationFrame1DraftRevision.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6 Constructor

Grid Solutions Framework ConfigurationFrame1Draft6 Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame1Draft6 | Creates a new ConfigurationFrame1Draft6.
Protected method | ConfigurationFrame1Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame1Draft6 from serialization parameters.
Public method | ConfigurationFrame1Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame1Draft6 from specified parameters.
Top
See Also

Reference

ConfigurationFrame1Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6 Constructor

Grid Solutions Framework ConfigurationFrame1Draft6 Constructor
Creates a new ConfigurationFrame1Draft6.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame1Draft6()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame1Draft6
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1Draft6 = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame1Draft6()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE C37.118 draft 6 configuration frame.
See Also

Reference

ConfigurationFrame1Draft6 Class
ConfigurationFrame1Draft6 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6 Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame1Draft6 Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame1Draft6 from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame1Draft6(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame1Draft6
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1Draft6 = function(info, context);
protected:
ConfigurationFrame1Draft6(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame1Draft6 Class
ConfigurationFrame1Draft6 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6 Constructor (UInt32, UInt16, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame1Draft6 Constructor (UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame1Draft6 from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame1Draft6(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    timebase As UInteger,
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        timebase : uint32 *
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame1Draft6
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1Draft6 = function(timebase, idCode, timestamp, frameRate);
public:
ConfigurationFrame1Draft6(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

timebase
Type: SystemUInt32
Timebase to use for fraction second resolution.
idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame1Draft6.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame1Draft6.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame1Draft6.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 draft 6 configuration frame.
See Also

Reference

ConfigurationFrame1Draft6 Class
ConfigurationFrame1Draft6 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6 Methods

Grid Solutions Framework ConfigurationFrame1Draft6 Methods

The ConfigurationFrame1Draft6 type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrame1Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6 Properties

Grid Solutions Framework ConfigurationFrame1Draft6 Properties

The ConfigurationFrame1Draft6 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1Draft6. (Overrides ConfigurationFrame1DraftRevision.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

ConfigurationFrame1Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame1Draft6.DraftRevision Property

Grid Solutions Framework ConfigurationFrame1Draft6DraftRevision Property
Gets the DraftRevision of this ConfigurationFrame1Draft6.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DraftRevision DraftRevision { get; }
Public Overrides ReadOnly Property DraftRevision As DraftRevision
    Get
abstract DraftRevision : DraftRevision with get
override DraftRevision : DraftRevision with get
function get_DraftRevision();

public:
virtual property DraftRevision DraftRevision {
    DraftRevision get () override;
}

Property Value

Type: DraftRevision
See Also

Reference

ConfigurationFrame1Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2 Class

Grid Solutions Framework ConfigurationFrame2 Class
Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 2, that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame2
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame2Draft6

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame2 : ConfigurationFrame1
<SerializableAttribute>
Public Class ConfigurationFrame2
    Inherits ConfigurationFrame1
[<SerializableAttribute>]
type ConfigurationFrame2 =
    class
        inherit ConfigurationFrame1
    end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2 = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2',
    GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1);
[SerializableAttribute]
public ref class ConfigurationFrame2 : public ConfigurationFrame1

The ConfigurationFrame2 type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame2 | Creates a new ConfigurationFrame2.
Protected method | ConfigurationFrame2(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2 from serialization parameters.
Public method | ConfigurationFrame2(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2 from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame2. (Overrides ConfigurationFrame1TypeID.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2 Constructor

Grid Solutions Framework ConfigurationFrame2 Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame2 | Creates a new ConfigurationFrame2.
Protected method | ConfigurationFrame2(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2 from serialization parameters.
Public method | ConfigurationFrame2(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2 from specified parameters.
Top
See Also

Reference

ConfigurationFrame2 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2 Constructor

Grid Solutions Framework ConfigurationFrame2 Constructor
Creates a new ConfigurationFrame2.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame2()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame2
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2 = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame2()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE C37.118 configuration frame, type 2.
See Also

Reference

ConfigurationFrame2 Class
ConfigurationFrame2 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2 Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame2 Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame2 from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame2(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame2
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2 = function(info, context);
protected:
ConfigurationFrame2(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame2 Class
ConfigurationFrame2 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2 Constructor (UInt32, UInt16, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame2 Constructor (UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame2 from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame2(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    timebase As UInteger,
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        timebase : uint32 *
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame2
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2 = function(timebase, idCode, timestamp, frameRate);
public:
ConfigurationFrame2(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

timebase
Type: SystemUInt32
Timebase to use for fraction second resolution.
idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame2.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame2.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame2.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 configuration frame, type 2.
See Also

Reference

ConfigurationFrame2 Class
ConfigurationFrame2 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2 Methods

Grid Solutions Framework ConfigurationFrame2 Methods

The ConfigurationFrame2 type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrame2 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2 Properties

Grid Solutions Framework ConfigurationFrame2 Properties

The ConfigurationFrame2 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame2. (Overrides ConfigurationFrame1TypeID.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

ConfigurationFrame2 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2.TypeID Property

Grid Solutions Framework ConfigurationFrame2TypeID Property
Gets the FrameType of this ConfigurationFrame2.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override FrameType TypeID { get; }
Public Overrides ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () override;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

ConfigurationFrame2 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6 Class

Grid Solutions Framework ConfigurationFrame2Draft6 Class
Represents the IEEE C37.118 draft 6 implementation of a IConfigurationFrame, type 2, that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame2
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame2Draft6

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame2Draft6 : ConfigurationFrame2
<SerializableAttribute>
Public Class ConfigurationFrame2Draft6
    Inherits ConfigurationFrame2
[<SerializableAttribute>]
type ConfigurationFrame2Draft6 =
    class
        inherit ConfigurationFrame2
    end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2Draft6 = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2Draft6',
    GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2);
[SerializableAttribute]
public ref class ConfigurationFrame2Draft6 : public ConfigurationFrame2

The ConfigurationFrame2Draft6 type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame2Draft6 | Creates a new ConfigurationFrame2Draft6.
Protected method | ConfigurationFrame2Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2Draft6 from serialization parameters.
Public method | ConfigurationFrame2Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2Draft6 from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame2Draft6. (Overrides ConfigurationFrame1DraftRevision.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame2. (Inherited from ConfigurationFrame2.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6 Constructor

Grid Solutions Framework ConfigurationFrame2Draft6 Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame2Draft6 | Creates a new ConfigurationFrame2Draft6.
Protected method | ConfigurationFrame2Draft6(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame2Draft6 from serialization parameters.
Public method | ConfigurationFrame2Draft6(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame2Draft6 from specified parameters.
Top
See Also

Reference

ConfigurationFrame2Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6 Constructor

Grid Solutions Framework ConfigurationFrame2Draft6 Constructor
Creates a new ConfigurationFrame2Draft6.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame2Draft6()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame2Draft6
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2Draft6 = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame2Draft6()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE C37.118 draft 6 configuration frame, type 2.
See Also

Reference

ConfigurationFrame2Draft6 Class
ConfigurationFrame2Draft6 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6 Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame2Draft6 Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame2Draft6 from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame2Draft6(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame2Draft6
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2Draft6 = function(info, context);
protected:
ConfigurationFrame2Draft6(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame2Draft6 Class
ConfigurationFrame2Draft6 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6 Constructor (UInt32, UInt16, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame2Draft6 Constructor (UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame2Draft6 from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame2Draft6(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    timebase As UInteger,
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        timebase : uint32 *
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame2Draft6
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame2Draft6 = function(timebase, idCode, timestamp, frameRate);
public:
ConfigurationFrame2Draft6(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

timebase
Type: SystemUInt32
Timebase to use for fraction second resolution.
idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame2Draft6.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame2Draft6.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame2Draft6.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 draft 6 configuration frame, type 2.
See Also

Reference

ConfigurationFrame2Draft6 Class
ConfigurationFrame2Draft6 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6 Methods

Grid Solutions Framework ConfigurationFrame2Draft6 Methods

The ConfigurationFrame2Draft6 type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrame2Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6 Properties

Grid Solutions Framework ConfigurationFrame2Draft6 Properties

The ConfigurationFrame2Draft6 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame2Draft6. (Overrides ConfigurationFrame1DraftRevision.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame2. (Inherited from ConfigurationFrame2.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

ConfigurationFrame2Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame2Draft6.DraftRevision Property

Grid Solutions Framework ConfigurationFrame2Draft6DraftRevision Property
Gets the DraftRevision of this ConfigurationFrame2Draft6.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DraftRevision DraftRevision { get; }
Public Overrides ReadOnly Property DraftRevision As DraftRevision
    Get
abstract DraftRevision : DraftRevision with get
override DraftRevision : DraftRevision with get
function get_DraftRevision();

public:
virtual property DraftRevision DraftRevision {
    DraftRevision get () override;
}

Property Value

Type: DraftRevision
See Also

Reference

ConfigurationFrame2Draft6 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3 Class

Grid Solutions Framework ConfigurationFrame3 Class
Represents the IEEE C37.118 implementation of a IConfigurationFrame, type 3, that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame3

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame3 : ConfigurationFrame1
<SerializableAttribute>
Public Class ConfigurationFrame3
    Inherits ConfigurationFrame1
[<SerializableAttribute>]
type ConfigurationFrame3 =
    class
        inherit ConfigurationFrame1
    end
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame3 = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame3',
    GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame1);
[SerializableAttribute]
public ref class ConfigurationFrame3 : public ConfigurationFrame1

The ConfigurationFrame3 type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame3 | Creates a new ConfigurationFrame3.
Protected method | ConfigurationFrame3(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame3 from serialization parameters.
Public method | ConfigurationFrame3(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame3 from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame3. (Overrides ConfigurationFrame1TypeID.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3 Constructor

Grid Solutions Framework ConfigurationFrame3 Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame3 | Creates a new ConfigurationFrame3.
Protected method | ConfigurationFrame3(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame3 from serialization parameters.
Public method | ConfigurationFrame3(UInt32, UInt16, Ticks, UInt16) | Creates a new ConfigurationFrame3 from specified parameters.
Top
See Also

Reference

ConfigurationFrame3 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3 Constructor

Grid Solutions Framework ConfigurationFrame3 Constructor
Creates a new ConfigurationFrame3.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame3()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame3
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame3 = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame3()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE C37.118 configuration frame, type 3.
See Also

Reference

ConfigurationFrame3 Class
ConfigurationFrame3 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3 Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame3 Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame3 from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame3(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame3
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame3 = function(info, context);
protected:
ConfigurationFrame3(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame3 Class
ConfigurationFrame3 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3 Constructor (UInt32, UInt16, Ticks, UInt16)

Grid Solutions Framework ConfigurationFrame3 Constructor (UInt32, UInt16, Ticks, UInt16)
Creates a new ConfigurationFrame3 from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame3(
    uint timebase,
    ushort idCode,
    Ticks timestamp,
    ushort frameRate
)
Public Sub New (
    timebase As UInteger,
    idCode As UShort,
    timestamp As Ticks,
    frameRate As UShort
)
new :
        timebase : uint32 *
        idCode : uint16 *
        timestamp : Ticks *
        frameRate : uint16 -> ConfigurationFrame3
GSF.PhasorProtocols.IEEEC37_118.ConfigurationFrame3 = function(timebase, idCode, timestamp, frameRate);
public:
ConfigurationFrame3(
    unsigned int timebase,
    unsigned short idCode,
    Ticks timestamp,
    unsigned short frameRate
)

Parameters

timebase
Type: SystemUInt32
Timebase to use for fraction second resolution.
idCode
Type: SystemUInt16
The ID code of this ConfigurationFrame3.
timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this ConfigurationFrame3.
frameRate
Type: SystemUInt16
The defined frame rate of this ConfigurationFrame3.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 configuration frame, type 3.
See Also

Reference

ConfigurationFrame3 Class
ConfigurationFrame3 Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3 Methods

Grid Solutions Framework ConfigurationFrame3 Methods

The ConfigurationFrame3 type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Inherited from ConfigurationFrame1.)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationFrame1.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationFrame1.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationFrame1.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrame3 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3 Properties

Grid Solutions Framework ConfigurationFrame3 Properties

The ConfigurationFrame3 type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader. (Inherited from ConfigurationFrame1.)
Public property | DraftRevision | Gets the DraftRevision of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationFrame1.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationFrame1 object. (Inherited from ConfigurationFrame1.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationFrame1.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timebase | Gets or sets the IEEE C37.118 resolution of fractional time stamps of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the FrameType of this ConfigurationFrame3. (Overrides ConfigurationFrame1TypeID.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets or sets the IEEE C37.118 protocol version of this ConfigurationFrame1. (Inherited from ConfigurationFrame1.)
Top
See Also

Reference

ConfigurationFrame3 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


ConfigurationFrame3.TypeID Property

Grid Solutions Framework ConfigurationFrame3TypeID Property
Gets the FrameType of this ConfigurationFrame3.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override FrameType TypeID { get; }
Public Overrides ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () override;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

ConfigurationFrame3 Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell Class

Grid Solutions Framework DataCell Class
Represents the IEEE C37.118 implementation of a IDataCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.IEEEC37_118DataCell

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute>
Public Class DataCell
    Inherits DataCellBase
[<SerializableAttribute>]
type DataCell =
    class
        inherit DataCellBase
    end
GSF.PhasorProtocols.IEEEC37_118.DataCell = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.DataCell',
    GSF.PhasorProtocols.DataCellBase);
[SerializableAttribute]
public ref class DataCell : public DataCellBase

The DataCell type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | ConfigurationChangeDetected | Gets or sets flag that determines if configuration change was detected for this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DeviceTriggerDetected | Gets or sets flag that determines if device trigger is detected for this DataCell.
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets status flags for this DataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerReason | Gets or sets trigger reason of this DataCell.
Public property | UnlockedTime | Gets or sets unlocked time of this DataCell.
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell Constructor

Grid Solutions Framework DataCell Constructor
Overload List
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCell Constructor (SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCell
GSF.PhasorProtocols.IEEEC37_118.DataCell = function(info, context);
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell Constructor (IDataFrame, IConfigurationCell)

Grid Solutions Framework DataCell Constructor (IDataFrame, IConfigurationCell)
Creates a new DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell -> DataCell
GSF.PhasorProtocols.IEEEC37_118.DataCell = function(parent, configurationCell);
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCell.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell Constructor (DataFrame, ConfigurationCell, Boolean)

Grid Solutions Framework DataCell Constructor (DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New (
    parent As DataFrame,
    configurationCell As ConfigurationCell,
    addEmptyValues As Boolean
)
new :
        parent : DataFrame *
        configurationCell : ConfigurationCell *
        addEmptyValues : bool -> DataCell
GSF.PhasorProtocols.IEEEC37_118.DataCell = function(parent, configurationCell, addEmptyValues);
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118DataFrame
The reference to parent DataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationCell
The ConfigurationCell associated with this DataCell.
addEmptyValues
Type: SystemBoolean
If true, adds empty values for each defined configuration cell definition.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell Methods

Grid Solutions Framework DataCell Methods

The DataCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DataCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell Properties

Grid Solutions Framework DataCell Properties

The DataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | ConfigurationChangeDetected | Gets or sets flag that determines if configuration change was detected for this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DeviceTriggerDetected | Gets or sets flag that determines if device trigger is detected for this DataCell.
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCellBase. (Inherited from DataCellBase.)
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets status flags for this DataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerReason | Gets or sets trigger reason of this DataCell.
Public property | UnlockedTime | Gets or sets unlocked time of this DataCell.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.Attributes Property

Grid Solutions Framework DataCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataCell object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.ConfigurationCell Property

Grid Solutions Framework DataCellConfigurationCell Property
Gets or sets the ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
member ConfigurationCell : ConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.ConfigurationChangeDetected Property

Grid Solutions Framework DataCellConfigurationChangeDetected Property
Gets or sets flag that determines if configuration change was detected for this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ConfigurationChangeDetected { get; set; }
Public Property ConfigurationChangeDetected As Boolean
    Get
    Set
member ConfigurationChangeDetected : bool with get, set

function get_ConfigurationChangeDetected();
function set_ConfigurationChangeDetected(value);
public:
property bool ConfigurationChangeDetected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.DataIsValid Property

Grid Solutions Framework DataCellDataIsValid Property
Gets or sets flag that determines if data of this DataCell is valid.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set
override DataIsValid : bool with get, set
function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.DataSortingType Property

Grid Solutions Framework DataCellDataSortingType Property
Gets or sets DataSortingType of this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set
override DataSortingType : DataSortingType with get, set
function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.DeviceError Property

Grid Solutions Framework DataCellDeviceError Property
Gets or sets flag that determines if source device of this DataCell is reporting an error.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DeviceError { get; set; }
Public Overrides Property DeviceError As Boolean
    Get
    Set
abstract DeviceError : bool with get, set
override DeviceError : bool with get, set
function get_DeviceError();
function set_DeviceError(value);
public:
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.DeviceTriggerDetected Property

Grid Solutions Framework DataCellDeviceTriggerDetected Property
Gets or sets flag that determines if device trigger is detected for this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DeviceTriggerDetected { get; set; }
Public Property DeviceTriggerDetected As Boolean
    Get
    Set
member DeviceTriggerDetected : bool with get, set

function get_DeviceTriggerDetected();
function set_DeviceTriggerDetected(value);
public:
property bool DeviceTriggerDetected {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.Parent Property

Grid Solutions Framework DataCellParent Property
Gets or sets the reference to parent DataFrame of this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
member Parent : DataFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}

Property Value

Type: DataFrame
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.StatusFlags Property

Grid Solutions Framework DataCellStatusFlags Property
Gets or sets status flags for this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatusFlags StatusFlags { get; set; }
Public Property StatusFlags As StatusFlags
    Get
    Set
member StatusFlags : StatusFlags with get, set

function get_StatusFlags();
function set_StatusFlags(value);
public:
property StatusFlags StatusFlags {
    StatusFlags get ();
    void set (StatusFlags value);
}

Property Value

Type: StatusFlags
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.SynchronizationIsValid Property

Grid Solutions Framework DataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set
override SynchronizationIsValid : bool with get, set
function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.TriggerReason Property

Grid Solutions Framework DataCellTriggerReason Property
Gets or sets trigger reason of this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TriggerReason TriggerReason { get; set; }
Public Property TriggerReason As TriggerReason
    Get
    Set
member TriggerReason : TriggerReason with get, set

function get_TriggerReason();
function set_TriggerReason(value);
public:
property TriggerReason TriggerReason {
    TriggerReason get ();
    void set (TriggerReason value);
}

Property Value

Type: TriggerReason
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCell.UnlockedTime Property

Grid Solutions Framework DataCellUnlockedTime Property
Gets or sets unlocked time of this DataCell.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnlockedTime UnlockedTime { get; set; }
Public Property UnlockedTime As UnlockedTime
    Get
    Set
member UnlockedTime : UnlockedTime with get, set

function get_UnlockedTime();
function set_UnlockedTime(value);
public:
property UnlockedTime UnlockedTime {
    UnlockedTime get ();
    void set (UnlockedTime value);
}

Property Value

Type: UnlockedTime
See Also

Reference

DataCell Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a IEEE C37.118 implementation of a collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.IEEEC37_118DataCellCollection

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute>
Public Class DataCellCollection
    Inherits DataCellCollection
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit DataCellCollection
    end
GSF.PhasorProtocols.IEEEC37_118.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.DataCellCollection',
    GSF.PhasorProtocols.DataCellCollection);
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Creates a new DataCellCollection.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection()
Public Sub New
new : unit -> DataCellCollection
GSF.PhasorProtocols.IEEEC37_118.DataCellCollection = function();
public:
DataCellCollection()
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.IEEEC37_118.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection.Item Property

Grid Solutions Framework DataCellCollectionItem Property
Gets or sets DataCell at specified index.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As DataCell
    Get
    Set
member Item : DataCell with get, set

function get_Item(index);
function set_Item(value);
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: DataCell
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame Class

Grid Solutions Framework DataFrame Class
Represents the IEEE C37.118 implementation of a IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.IEEEC37_118DataFrame

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute>
Public Class DataFrame
    Inherits DataFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type DataFrame =
    class
        inherit DataFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEEEC37_118.DataFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.DataFrame',
    GSF.PhasorProtocols.DataFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The DataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame1) | Creates a new DataFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame1 associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrame. (Overrides DataFrameBaseQualityFlags.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeBase | Gets the IEEE C37.118 timebase of this DataFrame as specified by the associated ConfigurationFrame.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this DataFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEEE C37.118 protocol version of this DataFrame as specified by the associated ConfigurationFrame.
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Overload List
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, ConfigurationFrame1) | Creates a new DataFrame from specified parameters.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Creates a new DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> DataFrame
GSF.PhasorProtocols.IEEEC37_118.DataFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
DataFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse an IEEE C37.118 data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrame Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrame
GSF.PhasorProtocols.IEEEC37_118.DataFrame = function(info, context);
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame Constructor (Ticks, ConfigurationFrame1)

Grid Solutions Framework DataFrame Constructor (Ticks, ConfigurationFrame1)
Creates a new DataFrame from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame(
    Ticks timestamp,
    ConfigurationFrame1 configurationFrame
)
Public Sub New (
    timestamp As Ticks,
    configurationFrame As ConfigurationFrame1
)
new :
        timestamp : Ticks *
        configurationFrame : ConfigurationFrame1 -> DataFrame
GSF.PhasorProtocols.IEEEC37_118.DataFrame = function(timestamp, configurationFrame);
public:
DataFrame(
    Ticks timestamp,
    ConfigurationFrame1^ configurationFrame
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrame.
configurationFrame
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationFrame1
The ConfigurationFrame associated with this DataFrame.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame Methods

Grid Solutions Framework DataFrame Methods

The DataFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.CalculateChecksum Method

Grid Solutions Framework DataFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.GetObjectData Method

Grid Solutions Framework DataFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.ParseHeaderImage Method

Grid Solutions Framework DataFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame Properties

Grid Solutions Framework DataFrame Properties

The DataFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame1 associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrame. (Overrides DataFrameBaseQualityFlags.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeBase | Gets the IEEE C37.118 timebase of this DataFrame as specified by the associated ConfigurationFrame.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this DataFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEEE C37.118 protocol version of this DataFrame as specified by the associated ConfigurationFrame.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.Attributes Property

Grid Solutions Framework DataFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.Cells Property

Grid Solutions Framework DataFrameCells Property
Gets reference to the DataCellCollection for this DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
member Cells : DataCellCollection with get

function get_Cells();

public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.CommonHeader Property

Grid Solutions Framework DataFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.ConfigurationFrame Property

Grid Solutions Framework DataFrameConfigurationFrame Property
Gets or sets ConfigurationFrame1 associated with this DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame1 ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame1
    Get
    Set
member ConfigurationFrame : ConfigurationFrame1 with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame1^ ConfigurationFrame {
    ConfigurationFrame1^ get ();
    void set (ConfigurationFrame1^ value);
}

Property Value

Type: ConfigurationFrame1
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.HeaderImage Property

Grid Solutions Framework DataFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.HeaderLength Property

Grid Solutions Framework DataFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.QualityFlags Property

Grid Solutions Framework DataFrameQualityFlags Property
Gets or sets protocol specific quality flags for this DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override uint QualityFlags { get; set; }
Public Overrides Property QualityFlags As UInteger
    Get
    Set
abstract QualityFlags : uint32 with get, set
override QualityFlags : uint32 with get, set
function get_QualityFlags();
function set_QualityFlags(value);
public:
virtual property unsigned int QualityFlags {
    unsigned int get () override;
    void set (unsigned int value) override;
}

Property Value

Type: UInt32

Implements

IDataFrameQualityFlags
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.TimeBase Property

Grid Solutions Framework DataFrameTimeBase Property
Gets the IEEE C37.118 timebase of this DataFrame as specified by the associated ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint TimeBase { get; }
Public ReadOnly Property TimeBase As UInteger
    Get
member TimeBase : uint32 with get

function get_TimeBase();

public:
property unsigned int TimeBase {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.TimeQualityFlags Property

Grid Solutions Framework DataFrameTimeQualityFlags Property
Gets or sets the TimeQualityFlags associated with this DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
member TimeQualityFlags : TimeQualityFlags with get, set

function get_TimeQualityFlags();
function set_TimeQualityFlags(value);
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}

Property Value

Type: TimeQualityFlags
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.TimeQualityIndicatorCode Property

Grid Solutions Framework DataFrameTimeQualityIndicatorCode Property
Gets or sets the TimeQualityIndicatorCode associated with this DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
member TimeQualityIndicatorCode : TimeQualityIndicatorCode with get, set

function get_TimeQualityIndicatorCode();
function set_TimeQualityIndicatorCode(value);
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}

Property Value

Type: TimeQualityIndicatorCode
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.Timestamp Property

Grid Solutions Framework DataFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.TypeID Property

Grid Solutions Framework DataFrameTypeID Property
Gets the identifier that is used to identify the IEEE C37.118 frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DataFrame.Version Property

Grid Solutions Framework DataFrameVersion Property
Gets the IEEE C37.118 protocol version of this DataFrame as specified by the associated ConfigurationFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
member Version : byte with get

function get_Version();

public:
property unsigned char Version {
    unsigned char get ();
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition Class

Grid Solutions Framework DigitalDefinition Class
Represents the IEEE C37.118 implementation of a IDigitalDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocols.IEEEC37_118DigitalDefinition

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute>
Public Class DigitalDefinition
    Inherits DigitalDefinitionBase
[<SerializableAttribute>]
type DigitalDefinition =
    class
        inherit DigitalDefinitionBase
    end
GSF.PhasorProtocols.IEEEC37_118.DigitalDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.DigitalDefinition',
    GSF.PhasorProtocols.DigitalDefinitionBase);
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase

The DigitalDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String, UInt16, UInt16) | Creates a new DigitalDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetLabel | Gets the individual labels for specified bit in this DigitalDefinition.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetLabel | Sets the individual labels for specified bit in this DigitalDefinition.
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | DraftRevision | Gets the DraftRevision of this DigitalDefinition.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the combined set of label images of this DigitalDefinition. (Overrides ChannelDefinitionBaseLabel.)
Public property | LabelCount | Gets the number of labels defined in this DigitalDefinition.
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NormalStatus | Gets or sets normal status for this DigitalDefinition.
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition Constructor

Grid Solutions Framework DigitalDefinition Constructor
Overload List
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String, UInt16, UInt16) | Creates a new DigitalDefinition from specified parameters.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition Constructor (IConfigurationCell)

Grid Solutions Framework DigitalDefinition Constructor (IConfigurationCell)
Creates a new DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> DigitalDefinition
GSF.PhasorProtocols.IEEEC37_118.DigitalDefinition = function(parent);
public:
DigitalDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinition
GSF.PhasorProtocols.IEEEC37_118.DigitalDefinition = function(info, context);
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition Constructor (ConfigurationCell, String, UInt16, UInt16)

Grid Solutions Framework DigitalDefinition Constructor (ConfigurationCell, String, UInt16, UInt16)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    ConfigurationCell parent,
    string label,
    ushort normalStatus,
    ushort validInputs
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    normalStatus As UShort,
    validInputs As UShort
)
new :
        parent : ConfigurationCell *
        label : string *
        normalStatus : uint16 *
        validInputs : uint16 -> DigitalDefinition
GSF.PhasorProtocols.IEEEC37_118.DigitalDefinition = function(parent, label, normalStatus, validInputs);
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned short normalStatus,
    unsigned short validInputs
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationCell
The ConfigurationCell parent of this DigitalDefinition.
label
Type: SystemString
The label of this DigitalDefinition.
normalStatus
Type: SystemUInt16
The normal status for this DigitalDefinition.
validInputs
Type: SystemUInt16
The valid input for this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition Methods

Grid Solutions Framework DigitalDefinition Methods

The DigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetLabel | Gets the individual labels for specified bit in this DigitalDefinition.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetLabel | Sets the individual labels for specified bit in this DigitalDefinition.
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.GetLabel Method

Grid Solutions Framework DigitalDefinitionGetLabel Method
Gets the individual labels for specified bit in this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetLabel(
    int index
)
Public Function GetLabel (
    index As Integer
) As String
member GetLabel :
        index : int -> string

function GetLabel(index);
public:
String^ GetLabel(
    int index
)

Parameters

index
Type: SystemInt32
Index of desired bit label to access.

Return Value

Type: String
A String value of the label corresponding to the parameter.
Remarks

In the final version of the protocol each digital bit can be labeled, but we read them out as one big string in the "Label" property so this property allows individual access to each label.

Note that the draft 6 implementation of the protocol supports one label for all 16-bits, however draft 7 (i.e., version 1) supports a label for each of the 16 bits.

See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.GetObjectData Method

Grid Solutions Framework DigitalDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.ParseBodyImage Method

Grid Solutions Framework DigitalDefinitionParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.SetLabel Method

Grid Solutions Framework DigitalDefinitionSetLabel Method
Sets the individual labels for specified bit in this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetLabel(
    int index,
    string value
)
Public Sub SetLabel (
    index As Integer,
    value As String
)
member SetLabel :
        index : int *
        value : string -> unit

function SetLabel(index, value);
public:
void SetLabel(
    int index,
    String^ value
)

Parameters

index
Type: SystemInt32
Index of desired bit label to access.
value
Type: SystemString
Value of the bit label to assign.
Remarks

In the final version of the protocol each digital bit can be labeled, but we read them out as one big string in the "Label" property so this property allows individual access to each label.

Note that the draft 6 implementation of the protocol supports one label for all 16-bits, however draft 7 (i.e., version 1) supports a label for each of the 16 bits.

See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition Properties

Grid Solutions Framework DigitalDefinition Properties

The DigitalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object. (Overrides ChannelDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | DraftRevision | Gets the DraftRevision of this DigitalDefinition.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the combined set of label images of this DigitalDefinition. (Overrides ChannelDefinitionBaseLabel.)
Public property | LabelCount | Gets the number of labels defined in this DigitalDefinition.
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this DigitalDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NormalStatus | Gets or sets normal status for this DigitalDefinition.
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | ValidInputs | Gets or sets valid input for this DigitalDefinition.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.Attributes Property

Grid Solutions Framework DigitalDefinitionAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this DigitalDefinition object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.DraftRevision Property

Grid Solutions Framework DigitalDefinitionDraftRevision Property
Gets the DraftRevision of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DraftRevision DraftRevision { get; }
Public ReadOnly Property DraftRevision As DraftRevision
    Get
member DraftRevision : DraftRevision with get

function get_DraftRevision();

public:
property DraftRevision DraftRevision {
    DraftRevision get ();
}

Property Value

Type: DraftRevision
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.Label Property

Grid Solutions Framework DigitalDefinitionLabel Property
Gets or sets the combined set of label images of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override string Label { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property Label As String
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Label : string with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Label : string with get, set
function get_Label();
function set_Label(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property String^ Label {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String

Implements

IChannelDefinitionLabel
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.LabelCount Property

Grid Solutions Framework DigitalDefinitionLabelCount Property
Gets the number of labels defined in this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LabelCount { get; }
Public ReadOnly Property LabelCount As Integer
    Get
member LabelCount : int with get

function get_LabelCount();

public:
property int LabelCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.MaximumLabelLength Property

Grid Solutions Framework DigitalDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.NormalStatus Property

Grid Solutions Framework DigitalDefinitionNormalStatus Property
Gets or sets normal status for this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort NormalStatus { get; set; }
Public Property NormalStatus As UShort
    Get
    Set
member NormalStatus : uint16 with get, set

function get_NormalStatus();
function set_NormalStatus(value);
public:
property unsigned short NormalStatus {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.Parent Property

Grid Solutions Framework DigitalDefinitionParent Property
Gets or sets the ConfigurationCell parent of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalDefinition.ValidInputs Property

Grid Solutions Framework DigitalDefinitionValidInputs Property
Gets or sets valid input for this DigitalDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ValidInputs { get; set; }
Public Property ValidInputs As UShort
    Get
    Set
member ValidInputs : uint16 with get, set

function get_ValidInputs();
function set_ValidInputs(value);
public:
property unsigned short ValidInputs {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue Class

Grid Solutions Framework DigitalValue Class
Represents the IEEE C37.118 implementation of a IDigitalValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IDigitalDefinition
GSF.PhasorProtocolsDigitalValueBase
GSF.PhasorProtocols.IEEEC37_118DigitalValue

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute>
Public Class DigitalValue
    Inherits DigitalValueBase
[<SerializableAttribute>]
type DigitalValue =
    class
        inherit DigitalValueBase
    end
GSF.PhasorProtocols.IEEEC37_118.DigitalValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.DigitalValue',
    GSF.PhasorProtocols.DigitalValueBase);
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase

The DigitalValue type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue Constructor

Grid Solutions Framework DigitalValue Constructor
Overload List
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalValue Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalValue
GSF.PhasorProtocols.IEEEC37_118.DigitalValue = function(info, context);
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue Constructor (IDataCell, IDigitalDefinition)

Grid Solutions Framework DigitalValue Constructor (IDataCell, IDigitalDefinition)
Creates a new DigitalValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New (
    parent As IDataCell,
    digitalDefinition As IDigitalDefinition
)
new :
        parent : IDataCell *
        digitalDefinition : IDigitalDefinition -> DigitalValue
GSF.PhasorProtocols.IEEEC37_118.DigitalValue = function(parent, digitalDefinition);
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocolsIDigitalDefinition
The IDigitalDefinition associated with this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)

Grid Solutions Framework DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New (
    parent As DataCell,
    digitalDefinition As DigitalDefinition,
    value As UShort
)
new :
        parent : DataCell *
        digitalDefinition : DigitalDefinition *
        value : uint16 -> DigitalValue
GSF.PhasorProtocols.IEEEC37_118.DigitalValue = function(parent, digitalDefinition, value);
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118DataCell
The DataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocols.IEEEC37_118DigitalDefinition
The DigitalDefinition associated with this DigitalValue.
value
Type: SystemUInt16
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue Methods

Grid Solutions Framework DigitalValue Methods

The DigitalValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue Properties

Grid Solutions Framework DigitalValue Properties

The DigitalValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue.Definition Property

Grid Solutions Framework DigitalValueDefinition Property
Gets or sets the DigitalDefinition associated with this DigitalValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
abstract Definition : DigitalDefinition with get, set
override Definition : DigitalDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}

Property Value

Type: DigitalDefinition
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DigitalValue.Parent Property

Grid Solutions Framework DigitalValueParent Property
Gets or sets the DataCell parent of this DigitalValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


DraftRevision Enumeration

Grid Solutions Framework DraftRevision Enumeration
Protocol draft revision numbers enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DraftRevision
<SerializableAttribute>
Public Enumeration DraftRevision
[<SerializableAttribute>]
type DraftRevision
GSF.PhasorProtocols.IEEEC37_118.DraftRevision = function();
GSF.PhasorProtocols.IEEEC37_118.DraftRevision.createEnum('GSF.PhasorProtocols.IEEEC37_118.DraftRevision', false);
[SerializableAttribute]
public enum class DraftRevision
Members
Member name | Value | Description
Draft6 | 0 | Draft 6.0.
Draft7 | 1 | Draft 7.0 (Version 1.0).
Draft8 | 2 | Draft 8.0 (Version 8.0).
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


FormatFlags Enumeration

Grid Solutions Framework FormatFlags Enumeration
Data format flags enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum FormatFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration FormatFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type FormatFlags
GSF.PhasorProtocols.IEEEC37_118.FormatFlags = function();
GSF.PhasorProtocols.IEEEC37_118.FormatFlags.createEnum('GSF.PhasorProtocols.IEEEC37_118.FormatFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class FormatFlags
Members
Member name | Value | Description
Frequency | 8 | Frequency value format (Set = float, Clear = integer).
Analog | 4 | Analog value format (Set = float, Clear = integer).
Phasors | 2 | Phasor value format (Set = float, Clear = integer).
Coordinates | 1 | Phasor coordinate format (Set = polar, Clear = rectangular).
UnusedMask | 65520 | Unsed format bits mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser Class

Grid Solutions Framework FrameParser Class
Represents a frame parser for an IEEE C37.118 binary data stream and returns parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.PhasorProtocolsFrameParserBase FrameType
GSF.PhasorProtocols.IEEEC37_118FrameParser

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser
    Inherits FrameParserBase(Of FrameType)
type FrameParser =
    class
        inherit FrameParserBase<FrameType>
    end
GSF.PhasorProtocols.IEEEC37_118.FrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.FrameParser',
    GSF.PhasorProtocols.FrameParserBase`1);
public ref class FrameParser : public FrameParserBase<FrameType>

The FrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | FrameParser | Creates a new FrameParser.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedDataFrame(IDataFrame).)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Overrides FrameParserBaseTFrameIdentifierOnUnknownFrameTypeEncountered(TFrameIdentifier).)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | DraftRevision | Gets or sets the DraftRevision of this FrameParser.
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | Timebase | Gets the IEEE C37.118 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when an IEEE C37.118 CommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame1 | Occurs when an IEEE C37.118 ConfigurationFrame1 has been received.
Public event | ReceivedConfigurationFrame2 | Occurs when an IEEE C37.118 ConfigurationFrame2 has been received.
Public event | ReceivedDataFrame | Occurs when an IEEE C37.118 DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when an IEEE C37.118 HeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser Constructor

Grid Solutions Framework FrameParser Constructor
Creates a new FrameParser.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    bool trustHeaderLength = true,
    DraftRevision draftRevision = DraftRevision.Draft7
)
Public Sub New (
    Optional checkSumValidationFrameTypes As CheckSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    Optional trustHeaderLength As Boolean = true,
    Optional draftRevision As DraftRevision = DraftRevision.Draft7
)
new :
        ?checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        ?trustHeaderLength : bool *
        ?draftRevision : DraftRevision
(* Defaults:
        let _checkSumValidationFrameTypes = defaultArg checkSumValidationFrameTypes CheckSumValidationFrameTypes.AllFrames
        let _trustHeaderLength = defaultArg trustHeaderLength true
        let _draftRevision = defaultArg draftRevision DraftRevision.Draft7
*)
-> FrameParser
GSF.PhasorProtocols.IEEEC37_118.FrameParser = function(checkSumValidationFrameTypes, trustHeaderLength, draftRevision);
public:
FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes::AllFrames,
    bool trustHeaderLength = true,
    DraftRevision draftRevision = DraftRevision::Draft7
)

Parameters

checkSumValidationFrameTypes (Optional)
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength (Optional)
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
draftRevision (Optional)
Type: GSF.PhasorProtocols.IEEEC37_118DraftRevision
The DraftRevision of this FrameParser.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser Fields

Grid Solutions Framework FrameParser Fields

The FrameParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser Methods

Grid Solutions Framework FrameParser Methods

The FrameParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedDataFrame(IDataFrame).)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Overrides FrameParserBaseTFrameIdentifierOnUnknownFrameTypeEncountered(TFrameIdentifier).)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame, ConfigurationFrame, CommandFrame or HeaderFrame).

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.OnReceivedConfigurationFrame Method

Grid Solutions Framework FrameParserOnReceivedConfigurationFrame Method
Raises the ReceivedConfigurationFrame event.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame (
    frame As IConfigurationFrame
)
abstract OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
override OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
function OnReceivedConfigurationFrame(frame);
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIConfigurationFrame
IConfigurationFrame to send to ReceivedConfigurationFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.OnReceivedDataFrame Method

Grid Solutions Framework FrameParserOnReceivedDataFrame Method
Raises the ReceivedDataFrame event.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedDataFrame(
    IDataFrame frame
)
Protected Overrides Sub OnReceivedDataFrame (
    frame As IDataFrame
)
abstract OnReceivedDataFrame :
        frame : IDataFrame -> unit
override OnReceivedDataFrame :
        frame : IDataFrame -> unit
function OnReceivedDataFrame(frame);
protected:
virtual void OnReceivedDataFrame(
    IDataFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIDataFrame
IDataFrame to send to ReceivedDataFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.OnUnknownFrameTypeEncountered Method

Grid Solutions Framework FrameParserOnUnknownFrameTypeEncountered Method
Handles unknown frame types.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnUnknownFrameTypeEncountered(
    FrameType frameType
)
Protected Overrides Sub OnUnknownFrameTypeEncountered (
    frameType As FrameType
)
abstract OnUnknownFrameTypeEncountered :
        frameType : FrameType -> unit
override OnUnknownFrameTypeEncountered :
        frameType : FrameType -> unit
function OnUnknownFrameTypeEncountered(frameType);
protected:
virtual void OnUnknownFrameTypeEncountered(
    FrameType frameType
) override

Parameters

frameType
Type: GSF.PhasorProtocols.IEEEC37_118FrameType
Unknown frame ID.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ParseCommonHeader Method

Grid Solutions Framework FrameParserParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of FrameType)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader FrameType
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Start the data parser.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

FrameParser Class
Start Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser Properties

Grid Solutions Framework FrameParser Properties

The FrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | DraftRevision | Gets or sets the DraftRevision of this FrameParser.
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if this protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | Timebase | Gets the IEEE C37.118 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ConfigurationFrame Property

Grid Solutions Framework FrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.DraftRevision Property

Grid Solutions Framework FrameParserDraftRevision Property
Gets or sets the DraftRevision of this FrameParser.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DraftRevision DraftRevision { get; set; }
Public Property DraftRevision As DraftRevision
    Get
    Set
member DraftRevision : DraftRevision with get, set

function get_DraftRevision();
function set_DraftRevision(value);
public:
property DraftRevision DraftRevision {
    DraftRevision get ();
    void set (DraftRevision value);
}

Property Value

Type: DraftRevision
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework FrameParserProtocolUsesSyncBytes Property
Gets flag that determines if this protocol parsing implementation uses synchronization bytes.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.Status Property

Grid Solutions Framework FrameParserStatus Property
Gets current descriptive status of the FrameParser.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.Timebase Property

Grid Solutions Framework FrameParserTimebase Property
Gets the IEEE C37.118 resolution of fractional timestamps of the current ConfigurationFrame, if one has been parsed.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Timebase { get; }
Public ReadOnly Property Timebase As UInteger
    Get
member Timebase : uint32 with get

function get_Timebase();

public:
property unsigned int Timebase {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser Events

Grid Solutions Framework FrameParser Events

The FrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when an IEEE C37.118 CommandFrame has been received.
Public event | ReceivedConfigurationFrame | Occurs when a IConfigurationFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame1 | Occurs when an IEEE C37.118 ConfigurationFrame1 has been received.
Public event | ReceivedConfigurationFrame2 | Occurs when an IEEE C37.118 ConfigurationFrame2 has been received.
Public event | ReceivedDataFrame | Occurs when an IEEE C37.118 DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when an IEEE C37.118 HeaderFrame has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ReceivedCommandFrame Event

Grid Solutions Framework FrameParserReceivedCommandFrame Event
Occurs when an IEEE C37.118 CommandFrame has been received.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<CommandFrame>> ReceivedCommandFrame
Public Event ReceivedCommandFrame As EventHandler(Of EventArgs(Of CommandFrame))
member ReceivedCommandFrame : IEvent<EventHandler<EventArgs<CommandFrame>>,
    EventArgs<CommandFrame>>

function add_ReceivedCommandFrame(value);
function remove_ReceivedCommandFrame(value);
public:
 event EventHandler<EventArgs<CommandFrame^>^>^ ReceivedCommandFrame {
    void add (EventHandler<EventArgs<CommandFrame^>^>^ value);
    void remove (EventHandler<EventArgs<CommandFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs CommandFrame
Remarks
Argument is the CommandFrame that was received.

Command frames are normally sent, not received, but there is nothing that prevents this.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ReceivedConfigurationFrame1 Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame1 Event
Occurs when an IEEE C37.118 ConfigurationFrame1 has been received.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame1>> ReceivedConfigurationFrame1
Public Event ReceivedConfigurationFrame1 As EventHandler(Of EventArgs(Of ConfigurationFrame1))
member ReceivedConfigurationFrame1 : IEvent<EventHandler<EventArgs<ConfigurationFrame1>>,
    EventArgs<ConfigurationFrame1>>

function add_ReceivedConfigurationFrame1(value);
function remove_ReceivedConfigurationFrame1(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame1^>^>^ ReceivedConfigurationFrame1 {
    void add (EventHandler<EventArgs<ConfigurationFrame1^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame1^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame1
Remarks
Argument is the ConfigurationFrame1 that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ReceivedConfigurationFrame2 Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame2 Event
Occurs when an IEEE C37.118 ConfigurationFrame2 has been received.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame2>> ReceivedConfigurationFrame2
Public Event ReceivedConfigurationFrame2 As EventHandler(Of EventArgs(Of ConfigurationFrame2))
member ReceivedConfigurationFrame2 : IEvent<EventHandler<EventArgs<ConfigurationFrame2>>,
    EventArgs<ConfigurationFrame2>>

function add_ReceivedConfigurationFrame2(value);
function remove_ReceivedConfigurationFrame2(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame2^>^>^ ReceivedConfigurationFrame2 {
    void add (EventHandler<EventArgs<ConfigurationFrame2^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame2^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame2
Remarks
Argument is the ConfigurationFrame2 that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ReceivedDataFrame Event

Grid Solutions Framework FrameParserReceivedDataFrame Event
Occurs when an IEEE C37.118 DataFrame has been received.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
member ReceivedDataFrame : IEvent<EventHandler<EventArgs<DataFrame>>,
    EventArgs<DataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataFrame
Remarks
Argument is the DataFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameParser.ReceivedHeaderFrame Event

Grid Solutions Framework FrameParserReceivedHeaderFrame Event
Occurs when an IEEE C37.118 HeaderFrame has been received.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<HeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of HeaderFrame))
member ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<HeaderFrame>>,
    EventArgs<HeaderFrame>>

function add_ReceivedHeaderFrame(value);
function remove_ReceivedHeaderFrame(value);
public:
 event EventHandler<EventArgs<HeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<HeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<HeaderFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs HeaderFrame
Remarks
Argument is the HeaderFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrameType Enumeration

Grid Solutions Framework FrameType Enumeration
IEEE C37.118 frame types enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FrameType
<SerializableAttribute>
Public Enumeration FrameType
[<SerializableAttribute>]
type FrameType
GSF.PhasorProtocols.IEEEC37_118.FrameType = function();
GSF.PhasorProtocols.IEEEC37_118.FrameType.createEnum('GSF.PhasorProtocols.IEEEC37_118.FrameType', false);
[SerializableAttribute]
public enum class FrameType
Members
Member name | Value | Description
DataFrame | 0 | 000 Data frame.
HeaderFrame | 16 | 001 Header frame.
ConfigurationFrame1 | 32 | 010 Configuration frame 1.
ConfigurationFrame2 | 48 | 011 Configuration frame 2.
ConfigurationFrame3 | 80 | 101 Configuration frame 3.
CommandFrame | 64 | 100 Command frame.
Reserved | 128 | . Reserved bit.
VersionNumberMask | 15 | Version number mask.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents the IEEE C37.118 implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.IEEEC37_118FrequencyDefinition

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.IEEEC37_118.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinition Constructor (IConfigurationCell)
Creates a new FrequencyDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinition
GSF.PhasorProtocols.IEEEC37_118.FrequencyDefinition = function(parent);
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.IEEEC37_118.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> FrequencyDefinition
GSF.PhasorProtocols.IEEEC37_118.FrequencyDefinition = function(parent, label);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
label
Type: SystemString
The label of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides ChannelDefinitionBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition.ParseBodyImage Method

Grid Solutions Framework FrequencyDefinitionParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
Remarks
The base implementation assumes that all channel definitions begin with a label as this is the general case, override functionality if this is not the case.
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyDefinition object. (Overrides ChannelDefinitionBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides ChannelDefinitionBaseBodyLength.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition.BodyImage Property

Grid Solutions Framework FrequencyDefinitionBodyImage Property
Gets the binary body image of the FrequencyDefinition object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition.BodyLength Property

Grid Solutions Framework FrequencyDefinitionBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue Class

Grid Solutions Framework FrequencyValue Class
Represents the IEEE C37.118 implementation of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.IEEEC37_118FrequencyValue

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute>
Public Class FrequencyValue
    Inherits FrequencyValueBase
[<SerializableAttribute>]
type FrequencyValue =
    class
        inherit FrequencyValueBase
    end
GSF.PhasorProtocols.IEEEC37_118.FrequencyValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.FrequencyValue',
    GSF.PhasorProtocols.FrequencyValueBase);
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase

The FrequencyValue type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from FrequencyValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue Constructor

Grid Solutions Framework FrequencyValue Constructor
Overload List
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValue Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValue
GSF.PhasorProtocols.IEEEC37_118.FrequencyValue = function(info, context);
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValue Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValue
GSF.PhasorProtocols.IEEEC37_118.FrequencyValue = function(parent, frequencyDefinition);
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValue.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New (
    parent As DataCell,
    frequencyDefinition As FrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : DataCell *
        frequencyDefinition : FrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValue
GSF.PhasorProtocols.IEEEC37_118.FrequencyValue = function(parent, frequencyDefinition, frequency, dfdt);
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118DataCell
The DataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocols.IEEEC37_118FrequencyDefinition
The FrequencyDefinition associated with this FrequencyValue.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValue.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValue over time.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue Methods

Grid Solutions Framework FrequencyValue Methods

The FrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from FrequencyValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue Properties

Grid Solutions Framework FrequencyValue Properties

The FrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue.Definition Property

Grid Solutions Framework FrequencyValueDefinition Property
Gets or sets the FrequencyDefinition associated with this FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
abstract Definition : FrequencyDefinition with get, set
override Definition : FrequencyDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}

Property Value

Type: FrequencyDefinition
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


FrequencyValue.Parent Property

Grid Solutions Framework FrequencyValueParent Property
Gets or sets the DataCell parent of this FrequencyValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame Class

Grid Solutions Framework HeaderFrame Class
Represents the IEEE C37.118 implementation of a IHeaderFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IHeaderCell
GSF.PhasorProtocolsHeaderFrameBase
GSF.PhasorProtocols.IEEEC37_118HeaderFrame

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class HeaderFrame : HeaderFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class HeaderFrame
    Inherits HeaderFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type HeaderFrame =
    class
        inherit HeaderFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.IEEEC37_118.HeaderFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.HeaderFrame',
    GSF.PhasorProtocols.HeaderFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class HeaderFrame : public HeaderFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The HeaderFrame type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderFrame | Creates a new HeaderFrame.
Public method | HeaderFrame(String) | Creates a new HeaderFrame.
Protected method | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrame object. (Overrides HeaderFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the HeaderFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeBase | Gets the IEEE C37.118 timebase of this HeaderFrame.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this HeaderFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this HeaderFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEEE C37.118 protocol version of this HeaderFrame.
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame Constructor

Grid Solutions Framework HeaderFrame Constructor
Overload List
 | Name | Description
Public method | HeaderFrame | Creates a new HeaderFrame.
Public method | HeaderFrame(String) | Creates a new HeaderFrame.
Protected method | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame Constructor

Grid Solutions Framework HeaderFrame Constructor
Creates a new HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderFrame()
Public Sub New
new : unit -> HeaderFrame
GSF.PhasorProtocols.IEEEC37_118.HeaderFrame = function();
public:
HeaderFrame()
Remarks
This constructor is used by a consumer or by FrameImageParserBaseTTypeIdentifier, TOutputType to generate or parse an IEEE C37.118 header frame.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame Constructor (String)

Grid Solutions Framework HeaderFrame Constructor (String)
Creates a new HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderFrame(
    string headerData
)
Public Sub New (
    headerData As String
)
new :
        headerData : string -> HeaderFrame
GSF.PhasorProtocols.IEEEC37_118.HeaderFrame = function(headerData);
public:
HeaderFrame(
    String^ headerData
)

Parameters

headerData
Type: SystemString
String based data to include in this HeaderFrame.
Remarks
This constructor is used by a consumer to generate an IEEE C37.118 header frame.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework HeaderFrame Constructor (SerializationInfo, StreamingContext)
Creates a new HeaderFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HeaderFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HeaderFrame
GSF.PhasorProtocols.IEEEC37_118.HeaderFrame = function(info, context);
protected:
HeaderFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame Methods

Grid Solutions Framework HeaderFrame Methods

The HeaderFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ChannelFrameBaseTGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.CalculateChecksum Method

Grid Solutions Framework HeaderFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.GetObjectData Method

Grid Solutions Framework HeaderFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.ParseHeaderImage Method

Grid Solutions Framework HeaderFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame Properties

Grid Solutions Framework HeaderFrame Properties

The HeaderFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrame object. (Overrides HeaderFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the HeaderFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TimeBase | Gets the IEEE C37.118 timebase of this HeaderFrame.
Public property | TimeQualityFlags | Gets or sets the TimeQualityFlags associated with this HeaderFrame.
Public property | TimeQualityIndicatorCode | Gets or sets the TimeQualityIndicatorCode associated with this HeaderFrame.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the IEEE C37.118 frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Public property | Version | Gets the IEEE C37.118 protocol version of this HeaderFrame.
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.Attributes Property

Grid Solutions Framework HeaderFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the HeaderFrame object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.CommonHeader Property

Grid Solutions Framework HeaderFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.HeaderImage Property

Grid Solutions Framework HeaderFrameHeaderImage Property
Gets the binary header image of the HeaderFrame object.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.HeaderLength Property

Grid Solutions Framework HeaderFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.TimeBase Property

Grid Solutions Framework HeaderFrameTimeBase Property
Gets the IEEE C37.118 timebase of this HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint TimeBase { get; }
Public ReadOnly Property TimeBase As UInteger
    Get
member TimeBase : uint32 with get

function get_TimeBase();

public:
property unsigned int TimeBase {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.TimeQualityFlags Property

Grid Solutions Framework HeaderFrameTimeQualityFlags Property
Gets or sets the TimeQualityFlags associated with this HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityFlags TimeQualityFlags { get; set; }
Public Property TimeQualityFlags As TimeQualityFlags
    Get
    Set
member TimeQualityFlags : TimeQualityFlags with get, set

function get_TimeQualityFlags();
function set_TimeQualityFlags(value);
public:
property TimeQualityFlags TimeQualityFlags {
    TimeQualityFlags get ();
    void set (TimeQualityFlags value);
}

Property Value

Type: TimeQualityFlags
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.TimeQualityIndicatorCode Property

Grid Solutions Framework HeaderFrameTimeQualityIndicatorCode Property
Gets or sets the TimeQualityIndicatorCode associated with this HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeQualityIndicatorCode TimeQualityIndicatorCode { get; set; }
Public Property TimeQualityIndicatorCode As TimeQualityIndicatorCode
    Get
    Set
member TimeQualityIndicatorCode : TimeQualityIndicatorCode with get, set

function get_TimeQualityIndicatorCode();
function set_TimeQualityIndicatorCode(value);
public:
property TimeQualityIndicatorCode TimeQualityIndicatorCode {
    TimeQualityIndicatorCode get ();
    void set (TimeQualityIndicatorCode value);
}

Property Value

Type: TimeQualityIndicatorCode
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.Timestamp Property

Grid Solutions Framework HeaderFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.TypeID Property

Grid Solutions Framework HeaderFrameTypeID Property
Gets the identifier that is used to identify the IEEE C37.118 frame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


HeaderFrame.Version Property

Grid Solutions Framework HeaderFrameVersion Property
Gets the IEEE C37.118 protocol version of this HeaderFrame.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Version { get; }
Public ReadOnly Property Version As Byte
    Get
member Version : byte with get

function get_Version();

public:
property unsigned char Version {
    unsigned char get ();
}

Property Value

Type: Byte
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents the IEEE C37.118 implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.IEEEC37_118PhasorDefinition

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.IEEEC37_118.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinition Constructor (IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinition
GSF.PhasorProtocols.IEEEC37_118.PhasorDefinition = function(parent);
public:
PhasorDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinition.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.IEEEC37_118.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, UInt32, Double, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    uint scale,
    double offset,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    scale As UInteger,
    offset As Double,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        scale : uint32 *
        offset : float *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.IEEEC37_118.PhasorDefinition = function(parent, label, scale, offset, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    unsigned int scale,
    double offset,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118ConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
scale
Type: SystemUInt32
The integer scaling value of this PhasorDefinition.
offset
Type: SystemDouble
The offset of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.IEEEC37_118PhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Class

Grid Solutions Framework PhasorValue Class
Represents the IEEE C37.118 implementation of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.IEEEC37_118PhasorValue

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute>
Public Class PhasorValue
    Inherits PhasorValueBase
[<SerializableAttribute>]
type PhasorValue =
    class
        inherit PhasorValueBase
    end
GSF.PhasorProtocols.IEEEC37_118.PhasorValue = function();

Type.createClass(
    'GSF.PhasorProtocols.IEEEC37_118.PhasorValue',
    GSF.PhasorProtocols.PhasorValueBase);
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase

The PhasorValue type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Constructor

Grid Solutions Framework PhasorValue Constructor
Overload List
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValue Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValue
GSF.PhasorProtocols.IEEEC37_118.PhasorValue = function(info, context);
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValue Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValue
GSF.PhasorProtocols.IEEEC37_118.PhasorValue = function(parent, phasorDefinition);
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValue
GSF.PhasorProtocols.IEEEC37_118.PhasorValue = function(parent, phasorDefinition, angle, magnitude);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118DataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.IEEEC37_118PhasorDefinition
The PhasorDefinition associated with this PhasorValue.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        real : float *
        imaginary : float -> PhasorValue
GSF.PhasorProtocols.IEEEC37_118.PhasorValue = function(parent, phasorDefinition, real, imaginary);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocols.IEEEC37_118DataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.IEEEC37_118PhasorDefinition
The PhasorDefinition associated with this PhasorValue.
real
Type: SystemDouble
The real value of this PhasorValue.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Methods

Grid Solutions Framework PhasorValue Methods

The PhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue Properties

Grid Solutions Framework PhasorValue Properties

The PhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue.Definition Property

Grid Solutions Framework PhasorValueDefinition Property
Gets or sets the PhasorDefinition associated with this PhasorValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
abstract Definition : PhasorDefinition with get, set
override Definition : PhasorDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}

Property Value

Type: PhasorDefinition
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


PhasorValue.Parent Property

Grid Solutions Framework PhasorValueParent Property
Gets or sets the DataCell parent of this PhasorValue.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.IEEEC37_118 Namespace


StatusFlags Enumeration

Grid Solutions Framework StatusFlags Enumeration
Status flags enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum StatusFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration StatusFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type StatusFlags
GSF.PhasorProtocols.IEEEC37_118.StatusFlags = function();
GSF.PhasorProtocols.IEEEC37_118.StatusFlags.createEnum('GSF.PhasorProtocols.IEEEC37_118.StatusFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class StatusFlags
Members
Member name | Value | Description
DataIsValid | 32768 | Data is valid (0 when device data is valid, 1 when invalid or device is in test mode).
DeviceError | 16384 | Device error including configuration error, 0 when no error.
DeviceSynchronizationError | 8192 | Device synchronization error, 0 when in sync.
DataSortingType | 4096 | Data sorting type, 0 by timestamp, 1 by arrival.
DeviceTriggerDetected | 2048 | Device trigger detected, 0 when no trigger.
ConfigurationChanged | 1024 | Configuration changed, set to 1 for one minute when configuration changed.
ReservedFlags | 960 | Reserved bits for security, presently set to 0.
UnlockedTimeMask | 48 | Unlocked time mask.
TriggerReasonMask | 15 | Trigger reason mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


TimeQualityFlags Enumeration

Grid Solutions Framework TimeQualityFlags Enumeration
Time quality flags enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum TimeQualityFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration TimeQualityFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type TimeQualityFlags
GSF.PhasorProtocols.IEEEC37_118.TimeQualityFlags = function();
GSF.PhasorProtocols.IEEEC37_118.TimeQualityFlags.createEnum('GSF.PhasorProtocols.IEEEC37_118.TimeQualityFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class TimeQualityFlags
Members
Member name | Value | Description
Reserved | 2147483648 | Reserved bit.
LeapSecondDirection | 1073741824 | Leap second direction – 0 for add, 1 for delete.
LeapSecondOccurred | 536870912 | Leap second occurred – set in the first second after the leap second occurs and remains set for 24 hours.
LeapSecondPending | 268435456 | Leap second pending – set before a leap second occurs and cleared in the second after the leap second occurs.
TimeQualityIndicatorCodeMask | 251658240 | Time quality indicator code mask.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


TimeQualityIndicatorCode Enumeration

Grid Solutions Framework TimeQualityIndicatorCode Enumeration
Time quality indicator code enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum TimeQualityIndicatorCode
<SerializableAttribute>
Public Enumeration TimeQualityIndicatorCode
[<SerializableAttribute>]
type TimeQualityIndicatorCode
GSF.PhasorProtocols.IEEEC37_118.TimeQualityIndicatorCode = function();
GSF.PhasorProtocols.IEEEC37_118.TimeQualityIndicatorCode.createEnum('GSF.PhasorProtocols.IEEEC37_118.TimeQualityIndicatorCode', false);
[SerializableAttribute]
public enum class TimeQualityIndicatorCode
Members
Member name | Value | Description
Failure | 251658240 | 1111 - 0xF: Fault--clock failure, time not reliable.
UnlockedWithin10Seconds | 184549376 | 1011 - 0xB: Clock unlocked, time within 10^1 s.
UnlockedWithin1Second | 167772160 | 1010 - 0xA: Clock unlocked, time within 10^0 s.
UnlockedWithinPoint1Seconds | 150994944 | 1001 - 0x9: Clock unlocked, time within 10^-1 s.
UnlockedWithinPoint01Seconds | 134217728 | 1000 - 0x8: Clock unlocked, time within 10^-2 s.
UnlockedWithinPoint001Seconds | 117440512 | 0111 - 0x7: Clock unlocked, time within 10^-3 s.
UnlockedWithinPoint0001Seconds | 100663296 | 0110 - 0x6: Clock unlocked, time within 10^-4 s.
UnlockedWithinPoint00001Seconds | 83886080 | 0101 - 0x5: Clock unlocked, time within 10^-5 s.
UnlockedWithinPoint000001Seconds | 67108864 | 0100 - 0x4: Clock unlocked, time within 10^-6 s.
UnlockedWithinPoint0000001Seconds | 50331648 | 0011 - 0x3: Clock unlocked, time within 10^-7 s.
UnlockedWithinPoint00000001Seconds | 33554432 | 0010 - 0x2: Clock unlocked, time within 10^-8 s.
UnlockedWithinPoint000000001Seconds | 16777216 | 0001 - 0x1: Clock unlocked, time within 10^-9 s.
Locked | 0 | 0000 - 0x0: Normal operation, clock locked.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


TriggerReason Enumeration

Grid Solutions Framework TriggerReason Enumeration
Trigger reason enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum TriggerReason
<SerializableAttribute>
Public Enumeration TriggerReason
[<SerializableAttribute>]
type TriggerReason
GSF.PhasorProtocols.IEEEC37_118.TriggerReason = function();
GSF.PhasorProtocols.IEEEC37_118.TriggerReason.createEnum('GSF.PhasorProtocols.IEEEC37_118.TriggerReason', false);
[SerializableAttribute]
public enum class TriggerReason
Members
Member name | Value | Description
VendorDefinedTrigger8 | 15 | 1111 Vendor defined trigger 8.
VendorDefinedTrigger7 | 14 | 1110 Vendor defined trigger 7.
VendorDefinedTrigger6 | 13 | 1101 Vendor defined trigger 6.
VendorDefinedTrigger5 | 12 | 1100 Vendor defined trigger 5.
VendorDefinedTrigger4 | 11 | 1011 Vendor defined trigger 4.
VendorDefinedTrigger3 | 10 | 1010 Vendor defined trigger 3.
VendorDefinedTrigger2 | 9 | 1001 Vendor defined trigger 2.
VendorDefinedTrigger1 | 8 | 1000 Vendor defined trigger 1.
Digital | 7 | 0111 Digital.
DfDtHigh | 5 | 0101 df/dt high.
PhaseAngleDifference | 3 | 0011 Phase angle difference.
MagnitudeLow | 1 | 0001 Magnitude low.
Reserved | 6 | 0110 Reserved.
FrequencyHighOrLow | 4 | 0100 Frequency high/low.
MagnitudeHigh | 2 | 0010 Magnitude high.
Manual | 0 | 0000 Manual.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


UnlockedTime Enumeration

Grid Solutions Framework UnlockedTime Enumeration
Unlocked time enumeration.

Namespace: GSF.PhasorProtocols.IEEEC37_118
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum UnlockedTime
<SerializableAttribute>
Public Enumeration UnlockedTime
[<SerializableAttribute>]
type UnlockedTime
GSF.PhasorProtocols.IEEEC37_118.UnlockedTime = function();
GSF.PhasorProtocols.IEEEC37_118.UnlockedTime.createEnum('GSF.PhasorProtocols.IEEEC37_118.UnlockedTime', false);
[SerializableAttribute]
public enum class UnlockedTime
Members
Member name | Value | Description
SyncLocked | 0 | Sync locked, best quality.
UnlockedFor10Seconds | 16 | Unlocked for 10 seconds.
UnlockedFor100Seconds | 32 | Unlocked for 100 seconds.
UnlockedForOver1000Seconds | 48 | Unlocked for over 1000 seconds.
See Also

Reference

GSF.PhasorProtocols.IEEEC37_118 Namespace


GSF.PhasorProtocols.Macrodyne Namespace

Grid Solutions Framework GSF.PhasorProtocols.Macrodyne Namespace
Contains an implementation of the phasor classes used to parse or generate a stream of data in the Macrodyne PMU device format.
Classes
 | Class | Description
Public class | CommandFrame | Represents the Macrodyne implementation of a ICommandFrame that can be sent or received.
Public class | Common | Common Macrodyne declarations and functions.
Public class | CommonFrameHeader | Represents the common header for all Macrodyne frames of data.
Public class | ConfigurationCell | Represents the Macrodyne implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a Macrodyne implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame | Represents the Macrodyne implementation of a IConfigurationFrame that can be sent or received.
Public class | ConfigurationFrameParsingState | Represents the Macrodyne implementation of the parsing state used by a ConfigurationFrame.
Public class | ConnectionParameters | Represents the extra connection parameters required for a connection to a Macrodyne.
Public class | DataCell | Represents the Macrodyne implementation of a IDataCell that can be sent or received.
Public class | DataCellCollection | Represents a Macrodyne implementation of a collection of IDataCell objects.
Public class | DataFrame | Represents the Macrodyne implementation of a IDataFrame that can be sent or received.
Public class | DigitalDefinition | Represents the Macrodyne implementation of an IDigitalDefinition.
Public class | DigitalValue | Represents the Macrodyne implementation of an IDigitalValue.
Public class | FrameParser | Represents a frame parser for a Macrodyne binary data stream that returns parsed data via events.
Public class | FrequencyDefinition | Represents the Macrodyne implementation of a IFrequencyDefinition.
Public class | FrequencyValue | Represents the Macrodyne implementation of a IFrequencyValue.
Public class | HeaderFrame | Represents the Macrodyne implementation of a IHeaderFrame that can be sent or received.
Public class | IniFileNameEditor | INI file name browser used with Macrodyne ConnectionParameters.
Public class | PhasorDefinition | Represents the Macrodyne implementation of a IPhasorDefinition.
Public class | PhasorValue | Represents the Macrodyne implementation of a IPhasorValue.
Enumerations
 | Enumeration | Description
Public enumeration | ClockStatusFlags | Macrodyne clock status flags enumeration (from byte 1 in time string).
Public enumeration | DataInputCommand | Macrodyne data input commands enumeration.
Public enumeration | DeviceCommand | Macrodyne set and request commands enumeration.
Public enumeration | DevicePort | Macrodyne device ports enumeration.
Public enumeration | FrameType | Macrodyne frame types enumeration.
Public enumeration | GpsStatus | Macrodyne GPS status enumeration (from Status 2 byte, bits 3-4).
Public enumeration | OnlineDataFormatFlags | Macrodyne ON-LINE data format flags enumeration (from RequestOnlineDataFormat 2 byte response).
Public enumeration | OperationalLimitFlags | Macrodyne operational limit reached flags enumeration (from RequestOperationalLimitFlags first byte of 3 byte response).
Public enumeration | ProtocolVersion | Macrodyne protocol versions enumeration.
Public enumeration | StatusFlags | Macrodyne status flags enumeration (from Status 1 byte).
Public enumeration | TriggerReason | Macrodyne trigger reason enumeration (from Status 2 byte, bits 0-2).


ClockStatusFlags Enumeration

Grid Solutions Framework ClockStatusFlags Enumeration
Macrodyne clock status flags enumeration (from byte 1 in time string).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum ClockStatusFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration ClockStatusFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type ClockStatusFlags
GSF.PhasorProtocols.Macrodyne.ClockStatusFlags = function();
GSF.PhasorProtocols.Macrodyne.ClockStatusFlags.createEnum('GSF.PhasorProtocols.Macrodyne.ClockStatusFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class ClockStatusFlags
Members
Member name | Value | Description
DacBeyondLimits | 1 | Set when DAC811 adjustment on the GPS board is beyond limits.
GpsComIssue | 2 | Set when the time output is that from the internal buffer (in GPS board processor) incremented by one second.
GpsUnlocked | 4 | Set when the internal oscillator is not disciplined (the GPS clock is not locked).
GpsTimeInvalid | 8 | Set when the last GPS receiver time tag was invalid.
ResynchronizationPending | 16 | Set when the system is about to be resynchronized to the GPS receiver.
ErrorCondition | 32 | Set when an error condition exists.
UsingLocalTime | 64 | Set for local time mode, cleared for UTC mode.
ClockAndReceiverOutOfSync | 128 | Set when the GPS clock 1 PPS and the GPS receiver 1 PPS differ by more than 5 microseconds.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame Class

Grid Solutions Framework CommandFrame Class
Represents the Macrodyne implementation of a ICommandFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase ICommandCell
GSF.PhasorProtocolsCommandFrameBase
GSF.PhasorProtocols.MacrodyneCommandFrame

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute>
Public Class CommandFrame
    Inherits CommandFrameBase
[<SerializableAttribute>]
type CommandFrame =
    class
        inherit CommandFrameBase
    end
GSF.PhasorProtocols.Macrodyne.CommandFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.CommandFrame',
    GSF.PhasorProtocols.CommandFrameBase);
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase

The CommandFrame type exposes the following members.

Constructors
 | Name | Description
Public method | CommandFrame(DeviceCommand) | Creates a new CommandFrame from specified parameters.
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from CommandFrameBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandFrameBase object. (Inherited from CommandFrameBase.)
Public property | BinaryImage | Gets the binary body image of this CommandFrame. (Overrides ChannelFrameBaseTBinaryImage.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrame.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
Remarks
Macrodyne command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImageTTypeIdentifier for automated frame parsing.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame Constructor

Grid Solutions Framework CommandFrame Constructor
Overload List
 | Name | Description
Public method | CommandFrame(DeviceCommand) | Creates a new CommandFrame from specified parameters.
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame Constructor (DeviceCommand)

Grid Solutions Framework CommandFrame Constructor (DeviceCommand)
Creates a new CommandFrame from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    DeviceCommand command
)
Public Sub New (
    command As DeviceCommand
)
new :
        command : DeviceCommand -> CommandFrame
GSF.PhasorProtocols.Macrodyne.CommandFrame = function(command);
public:
CommandFrame(
    DeviceCommand command
)

Parameters

command
Type: GSF.PhasorProtocolsDeviceCommand
The DeviceCommand for this CommandFrame.
Remarks
This constructor is used by a consumer to generate an Macrodyne command frame.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandFrame Constructor (SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandFrame
GSF.PhasorProtocols.Macrodyne.CommandFrame = function(info, context);
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame Methods

Grid Solutions Framework CommandFrame Methods

The CommandFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from CommandFrameBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame.CalculateChecksum Method

Grid Solutions Framework CommandFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
Remarks
The Macrodyne does not use checksums for sending commands.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame Properties

Grid Solutions Framework CommandFrame Properties

The CommandFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the CommandFrameBase object. (Inherited from CommandFrameBase.)
Public property | BinaryImage | Gets the binary body image of this CommandFrame. (Overrides ChannelFrameBaseTBinaryImage.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from CommandFrameBase.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrame.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame.BinaryImage Property

Grid Solutions Framework CommandFrameBinaryImage Property
Gets the binary body image of this CommandFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override byte[] BinaryImage { get; }
Public Overrides ReadOnly Property BinaryImage As Byte()
    Get
abstract BinaryImage : byte[] with get
override BinaryImage : byte[] with get
function get_BinaryImage();

public:
virtual property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame.BinaryLength Property

Grid Solutions Framework CommandFrameBinaryLength Property
Gets the length of the BinaryImage.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


CommandFrame.Command Property

Grid Solutions Framework CommandFrameCommand Property
Gets or sets the DeviceCommand for this CommandFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DeviceCommand Command { get; set; }
Public Property Command As DeviceCommand
    Get
    Set
member Command : DeviceCommand with get, set

function get_Command();
function set_Command(value);
public:
property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}

Property Value

Type: DeviceCommand
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


Common Class

Grid Solutions Framework Common Class
Common Macrodyne declarations and functions.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.MacrodyneCommon

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.Macrodyne.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.Common');
public ref class Common abstract sealed

The Common type exposes the following members.

Methods
Name | Description
GetFormatFlagsFromPhasorCount | Gets set of ONLINE data format flags based on the specified number of phasors.
Top
Fields
Name | Description
GpsStatusMask | Macrodyne GPS status mask (from Status 2 byte, bits 3-4).
GpsSynchronizationBit | GPS synchronization bit (from Status 2 byte, bits 7): set = last time mark was true / tracking, not set = last time mark was false / not tracking.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
ReferenceInputPortBit | Reference input port bit (from Status 2 byte, bits 5): set = port 3, not set = port 4.
ReferenceOutputPortBit | Reference output port bit (from Status 2 byte, bits 6): set = port 2, not set = port 1.
TriggerReasonMask | Macrodyne trigger reason mask (from Status 2 byte, bits 0-2).
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
GpsStatusMask | Macrodyne GPS status mask (from Status 2 byte, bits 3-4).
GpsSynchronizationBit | GPS synchronization bit (from Status 2 byte, bits 7): set = last time mark was true / tracking, not set = last time mark was false / not tracking.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
ReferenceInputPortBit | Reference input port bit (from Status 2 byte, bits 5): set = port 3, not set = port 4.
ReferenceOutputPortBit | Reference output port bit (from Status 2 byte, bits 6): set = port 2, not set = port 1.
TriggerReasonMask | Macrodyne trigger reason mask (from Status 2 byte, bits 0-2).
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.GpsStatusMask Field

Grid Solutions Framework CommonGpsStatusMask Field
Macrodyne GPS status mask (from Status 2 byte, bits 3-4).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte GpsStatusMask
Public Const GpsStatusMask As Byte
static val mutable GpsStatusMask: byte
var GSF.PhasorProtocols.Macrodyne.Common.GpsStatusMask
public:
literal unsigned char GpsStatusMask

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.GpsSynchronizationBit Field

Grid Solutions Framework CommonGpsSynchronizationBit Field
GPS synchronization bit (from Status 2 byte, bits 7): set = last time mark was true / tracking, not set = last time mark was false / not tracking.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte GpsSynchronizationBit
Public Const GpsSynchronizationBit As Byte
static val mutable GpsSynchronizationBit: byte
var GSF.PhasorProtocols.Macrodyne.Common.GpsSynchronizationBit
public:
literal unsigned char GpsSynchronizationBit

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.MaximumAnalogValues Field

Grid Solutions Framework CommonMaximumAnalogValues Field
Absolute maximum number of possible analog values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
static val mutable MaximumAnalogValues: uint16
var GSF.PhasorProtocols.Macrodyne.Common.MaximumAnalogValues
public:
literal unsigned short MaximumAnalogValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.MaximumDataLength Field

Grid Solutions Framework CommonMaximumDataLength Field
Absolute maximum data length (in bytes) that could fit into any frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
static val mutable MaximumDataLength: uint16
var GSF.PhasorProtocols.Macrodyne.Common.MaximumDataLength
public:
literal unsigned short MaximumDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.MaximumDigitalValues Field

Grid Solutions Framework CommonMaximumDigitalValues Field
Absolute maximum number of possible digital values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
static val mutable MaximumDigitalValues: uint16
var GSF.PhasorProtocols.Macrodyne.Common.MaximumDigitalValues
public:
literal unsigned short MaximumDigitalValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.MaximumExtendedDataLength Field

Grid Solutions Framework CommonMaximumExtendedDataLength Field
Absolute maximum number of bytes of extended data that could fit into a command frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumExtendedDataLength
Public Const MaximumExtendedDataLength As UShort
static val mutable MaximumExtendedDataLength: uint16
var GSF.PhasorProtocols.Macrodyne.Common.MaximumExtendedDataLength
public:
literal unsigned short MaximumExtendedDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.MaximumPhasorValues Field

Grid Solutions Framework CommonMaximumPhasorValues Field
Absolute maximum number of possible phasor values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
static val mutable MaximumPhasorValues: uint16
var GSF.PhasorProtocols.Macrodyne.Common.MaximumPhasorValues
public:
literal unsigned short MaximumPhasorValues

Field Value

Type: UInt16
Remarks
Technically 1690M will have a maximum of 10 and 1690G will have a maximum of 40 (not counting reference).
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.ReferenceInputPortBit Field

Grid Solutions Framework CommonReferenceInputPortBit Field
Reference input port bit (from Status 2 byte, bits 5): set = port 3, not set = port 4.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte ReferenceInputPortBit
Public Const ReferenceInputPortBit As Byte
static val mutable ReferenceInputPortBit: byte
var GSF.PhasorProtocols.Macrodyne.Common.ReferenceInputPortBit
public:
literal unsigned char ReferenceInputPortBit

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.ReferenceOutputPortBit Field

Grid Solutions Framework CommonReferenceOutputPortBit Field
Reference output port bit (from Status 2 byte, bits 6): set = port 2, not set = port 1.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte ReferenceOutputPortBit
Public Const ReferenceOutputPortBit As Byte
static val mutable ReferenceOutputPortBit: byte
var GSF.PhasorProtocols.Macrodyne.Common.ReferenceOutputPortBit
public:
literal unsigned char ReferenceOutputPortBit

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.TriggerReasonMask Field

Grid Solutions Framework CommonTriggerReasonMask Field
Macrodyne trigger reason mask (from Status 2 byte, bits 0-2).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte TriggerReasonMask
Public Const TriggerReasonMask As Byte
static val mutable TriggerReasonMask: byte
var GSF.PhasorProtocols.Macrodyne.Common.TriggerReasonMask
public:
literal unsigned char TriggerReasonMask

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common Methods

Grid Solutions Framework Common Methods

The Common type exposes the following members.

Methods
Name | Description
GetFormatFlagsFromPhasorCount | Gets set of ONLINE data format flags based on the specified number of phasors.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


Common.GetFormatFlagsFromPhasorCount Method

Grid Solutions Framework CommonGetFormatFlagsFromPhasorCount Method
Gets set of ONLINE data format flags based on the specified number of phasors.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static OnlineDataFormatFlags GetFormatFlagsFromPhasorCount(
    int count
)
Public Shared Function GetFormatFlagsFromPhasorCount (
    count As Integer
) As OnlineDataFormatFlags
static member GetFormatFlagsFromPhasorCount :
        count : int -> OnlineDataFormatFlags

GSF.PhasorProtocols.Macrodyne.Common.GetFormatFlagsFromPhasorCount = function(count);
public:
static OnlineDataFormatFlags GetFormatFlagsFromPhasorCount(
    int count
)

Parameters

count
Type: SystemInt32
Total number phasors.

Return Value

Type: OnlineDataFormatFlags
ONLINE data format flags based on the specified number of phasors.
Remarks
This function always includes TimestampEnabled as part of the format flags.
See Also

Reference

Common Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Class

Grid Solutions Framework CommonFrameHeader Class
Represents the common header for all Macrodyne frames of data.
Inheritance Hierarchy
SystemObject
GSF.ParsingCommonHeaderBase FrameType
GSF.PhasorProtocols.MacrodyneCommonFrameHeader

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommonFrameHeader : CommonHeaderBase<FrameType>,
    ISerializable
<SerializableAttribute>
Public Class CommonFrameHeader
    Inherits CommonHeaderBase(Of FrameType)
    Implements ISerializable
[<SerializableAttribute>]
type CommonFrameHeader =
    class
        inherit CommonHeaderBase<FrameType>
        interface ISerializable
    end
GSF.PhasorProtocols.Macrodyne.CommonFrameHeader = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.CommonFrameHeader',
    GSF.Parsing.CommonHeaderBase`1,
    ISerializable);
[SerializableAttribute]
public ref class CommonFrameHeader : public CommonHeaderBase<FrameType>,
    ISerializable

The CommonFrameHeader type exposes the following members.

Constructors
 | Name | Description
Public method | CommonFrameHeader | Creates a new CommonFrameHeader.
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(ProtocolVersion, FrameType) | Creates a new CommonFrameHeader.
Public method | CommonFrameHeader(Byte, Int32, ProtocolVersion, ConfigurationFrame) | Creates a new CommonFrameHeader from given buffer.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
Top
Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this CommonFrameHeader.
Public property | DataLength | Gets the Macrodyne data length.
Public property | FrameLength | Gets the Macrodyne frame length.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | ProtocolVersion | Gets or sets flag that determines the Macrodyne protocol version.
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | StatusFlags | Gets or sets the StatusFlags of this CommonFrameHeader.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Overload List
 | Name | Description
Public method | CommonFrameHeader | Creates a new CommonFrameHeader.
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(ProtocolVersion, FrameType) | Creates a new CommonFrameHeader.
Public method | CommonFrameHeader(Byte, Int32, ProtocolVersion, ConfigurationFrame) | Creates a new CommonFrameHeader from given buffer.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Creates a new CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader()
Public Sub New
new : unit -> CommonFrameHeader
GSF.PhasorProtocols.Macrodyne.CommonFrameHeader = function();
public:
CommonFrameHeader()
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommonFrameHeader Constructor (SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommonFrameHeader
GSF.PhasorProtocols.Macrodyne.CommonFrameHeader = function(info, context);
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Constructor (ProtocolVersion, FrameType)

Grid Solutions Framework CommonFrameHeader Constructor (ProtocolVersion, FrameType)
Creates a new CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    ProtocolVersion protocolVersion,
    FrameType typeID
)
Public Sub New (
    protocolVersion As ProtocolVersion,
    typeID As FrameType
)
new :
        protocolVersion : ProtocolVersion *
        typeID : FrameType -> CommonFrameHeader
GSF.PhasorProtocols.Macrodyne.CommonFrameHeader = function(protocolVersion, typeID);
public:
CommonFrameHeader(
    ProtocolVersion protocolVersion,
    FrameType typeID
)

Parameters

protocolVersion
Type: GSF.PhasorProtocols.MacrodyneProtocolVersion
Macrodyne protocol to use for parsing.
typeID
Type: GSF.PhasorProtocols.MacrodyneFrameType
Frame type common header represents.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Constructor (Byte[], Int32, ProtocolVersion, ConfigurationFrame)

Grid Solutions Framework CommonFrameHeader Constructor (Byte, Int32, ProtocolVersion, ConfigurationFrame)
Creates a new CommonFrameHeader from given buffer.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    byte[] buffer,
    int startIndex,
    ProtocolVersion protocolVersion,
    ConfigurationFrame configurationFrame
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    protocolVersion As ProtocolVersion,
    configurationFrame As ConfigurationFrame
)
new :
        buffer : byte[] *
        startIndex : int *
        protocolVersion : ProtocolVersion *
        configurationFrame : ConfigurationFrame -> CommonFrameHeader
GSF.PhasorProtocols.Macrodyne.CommonFrameHeader = function(buffer, startIndex, protocolVersion, configurationFrame);
public:
CommonFrameHeader(
    array<unsigned char>^ buffer,
    int startIndex,
    ProtocolVersion protocolVersion,
    ConfigurationFrame^ configurationFrame
)

Parameters

buffer
Type: SystemByte
Buffer that contains data to parse.
startIndex
Type: SystemInt32
Start index into buffer where valid data begins.
protocolVersion
Type: GSF.PhasorProtocols.MacrodyneProtocolVersion
Macrodyne protocol to use for parsing.
configurationFrame
Type: GSF.PhasorProtocols.MacrodyneConfigurationFrame
Configuration frame, if available.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Fields

Grid Solutions Framework CommonFrameHeader Fields

The CommonFrameHeader type exposes the following members.

Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.FixedLength Field

Grid Solutions Framework CommonFrameHeaderFixedLength Field
Total fixed length of CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FixedLength
Public Const FixedLength As UShort
static val mutable FixedLength: uint16
var GSF.PhasorProtocols.Macrodyne.CommonFrameHeader.FixedLength
public:
literal unsigned short FixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Methods

Grid Solutions Framework CommonFrameHeader Methods

The CommonFrameHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.GetObjectData Method

Grid Solutions Framework CommonFrameHeaderGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader Properties

Grid Solutions Framework CommonFrameHeader Properties

The CommonFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this CommonFrameHeader.
Public property | DataLength | Gets the Macrodyne data length.
Public property | FrameLength | Gets the Macrodyne frame length.
Public property | FrameType | Gets the fundamental frame type of this frame.
Public property | ProtocolVersion | Gets or sets flag that determines the Macrodyne protocol version.
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | StatusFlags | Gets or sets the StatusFlags of this CommonFrameHeader.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.BinaryImage Property

Grid Solutions Framework CommonFrameHeaderBinaryImage Property
Gets the binary image of the common header portion of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
member BinaryImage : byte[] with get

function get_BinaryImage();

public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.DataLength Property

Grid Solutions Framework CommonFrameHeaderDataLength Property
Gets the Macrodyne data length.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DataLength { get; }
Public ReadOnly Property DataLength As UShort
    Get
member DataLength : uint16 with get

function get_DataLength();

public:
property unsigned short DataLength {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.FrameLength Property

Grid Solutions Framework CommonFrameHeaderFrameLength Property
Gets the Macrodyne frame length.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort FrameLength { get; }
Public ReadOnly Property FrameLength As UShort
    Get
member FrameLength : uint16 with get

function get_FrameLength();

public:
property unsigned short FrameLength {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.FrameType Property

Grid Solutions Framework CommonFrameHeaderFrameType Property
Gets the fundamental frame type of this frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FundamentalFrameType FrameType { get; }
Public ReadOnly Property FrameType As FundamentalFrameType
    Get
member FrameType : FundamentalFrameType with get

function get_FrameType();

public:
property FundamentalFrameType FrameType {
    FundamentalFrameType get ();
}

Property Value

Type: FundamentalFrameType
Remarks
Frames are generally classified as data, configuration or header frames. This returns the general frame classification.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.ProtocolVersion Property

Grid Solutions Framework CommonFrameHeaderProtocolVersion Property
Gets or sets flag that determines the Macrodyne protocol version.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ProtocolVersion ProtocolVersion { get; set; }
Public Property ProtocolVersion As ProtocolVersion
    Get
    Set
member ProtocolVersion : ProtocolVersion with get, set

function get_ProtocolVersion();
function set_ProtocolVersion(value);
public:
property ProtocolVersion ProtocolVersion {
    ProtocolVersion get ();
    void set (ProtocolVersion value);
}

Property Value

Type: ProtocolVersion
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


CommonFrameHeader.StatusFlags Property

Grid Solutions Framework CommonFrameHeaderStatusFlags Property
Gets or sets the StatusFlags of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatusFlags StatusFlags { get; set; }
Public Property StatusFlags As StatusFlags
    Get
    Set
member StatusFlags : StatusFlags with get, set

function get_StatusFlags();
function set_StatusFlags(value);
public:
property StatusFlags StatusFlags {
    StatusFlags get ();
    void set (StatusFlags value);
}

Property Value

Type: StatusFlags
Remarks
Status flags are only relevant for 1690M implementations and are not provided for 1690G implementations.
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents the Macrodyne implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.MacrodyneConfigurationCell

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
    end
GSF.PhasorProtocols.Macrodyne.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, String) | Creates a new ConfigurationCell from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | ConfigurationFileCell | Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDefinition.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ConfigurationCell. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IsPdcBlockSection | Gets flag that determines if current SectionEntry defines a PDC block section.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseNominalFrequency.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDefinitions.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | SectionEntry | Gets or sets section entry in INI based configuration file for this ConfigurationCell.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCell. (Overrides ConfigurationCellBaseStationName.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Overload List
 | Name | Description
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Public method | ConfigurationCell(ConfigurationFrame, String) | Creates a new ConfigurationCell from specified parameters.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCell Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.Macrodyne.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell Constructor (ConfigurationFrame, String)

Grid Solutions Framework ConfigurationCell Constructor (ConfigurationFrame, String)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ConfigurationFrame parent,
    string deviceLabel = null
)
Public Sub New (
    parent As ConfigurationFrame,
    Optional deviceLabel As String = Nothing
)
new :
        parent : ConfigurationFrame *
        ?deviceLabel : string
(* Defaults:
        let _deviceLabel = defaultArg deviceLabel null
*)
-> ConfigurationCell
GSF.PhasorProtocols.Macrodyne.ConfigurationCell = function(parent, deviceLabel);
public:
ConfigurationCell(
    ConfigurationFrame^ parent,
    String^ deviceLabel = nullptr
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneConfigurationFrame
The parent ConfigurationFrame reference to use.
deviceLabel (Optional)
Type: SystemString
INI section device label to use.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.GetObjectData Method

Grid Solutions Framework ConfigurationCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object. (Overrides ConfigurationCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | ConfigurationFileCell | Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDefinition.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the numeric ID code for this ConfigurationCell. (Overrides ChannelCellBaseIDCode.)
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IsPdcBlockSection | Gets flag that determines if current SectionEntry defines a PDC block section.
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseNominalFrequency.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDefinitions.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | SectionEntry | Gets or sets section entry in INI based configuration file for this ConfigurationCell.
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCell. (Overrides ConfigurationCellBaseStationName.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override DataFormat AnalogDataFormat { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract AnalogDataFormat : DataFormat with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports scaled data.
Remarks

Macrodyne doesn't define any analog values.

This property only supports scaled data; Macrodyne doesn't transport floating point values.

See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.Attributes Property

Grid Solutions Framework ConfigurationCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationCell object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.ConfigurationFileCell Property

Grid Solutions Framework ConfigurationCellConfigurationFileCell Property
Gets or sets reference to the ConfigurationCell loaded from the configuration file associated this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationFileCell { get; set; }
Public Property ConfigurationFileCell As ConfigurationCell
    Get
    Set
member ConfigurationFileCell : ConfigurationCell with get, set

function get_ConfigurationFileCell();
function set_ConfigurationFileCell(value);
public:
property ConfigurationCell^ ConfigurationFileCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports scaled data.
Remarks
This property only supports scaled data; Macrodyne doesn't transport floating-point values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.FrequencyDefinition Property

Grid Solutions Framework ConfigurationCellFrequencyDefinition Property
Gets or sets the IFrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IFrequencyDefinition FrequencyDefinition { get; set; }
Public Overrides Property FrequencyDefinition As IFrequencyDefinition
    Get
    Set
abstract FrequencyDefinition : IFrequencyDefinition with get, set
override FrequencyDefinition : IFrequencyDefinition with get, set
function get_FrequencyDefinition();
function set_FrequencyDefinition(value);
public:
virtual property IFrequencyDefinition^ FrequencyDefinition {
    IFrequencyDefinition^ get () override;
    void set (IFrequencyDefinition^ value) override;
}

Property Value

Type: IFrequencyDefinition

Implements

IConfigurationCellFrequencyDefinition
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.IDCode Property

Grid Solutions Framework ConfigurationCellIDCode Property
Gets or sets the numeric ID code for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}

Property Value

Type: UInt16

Implements

IChannelCellIDCode
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.IsPdcBlockSection Property

Grid Solutions Framework ConfigurationCellIsPdcBlockSection Property
Gets flag that determines if current SectionEntry defines a PDC block section.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsPdcBlockSection { get; }
Public ReadOnly Property IsPdcBlockSection As Boolean
    Get
member IsPdcBlockSection : bool with get

function get_IsPdcBlockSection();

public:
property bool IsPdcBlockSection {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.MaximumStationNameLength Property

Grid Solutions Framework ConfigurationCellMaximumStationNameLength Property
Gets the maximum length of the StationName of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
abstract MaximumStationNameLength : int with get
override MaximumStationNameLength : int with get
function get_MaximumStationNameLength();

public:
virtual property int MaximumStationNameLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IConfigurationCellMaximumStationNameLength
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.NominalFrequency Property

Grid Solutions Framework ConfigurationCellNominalFrequency Property
Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override LineFrequency NominalFrequency { get; set; }
Public Overrides Property NominalFrequency As LineFrequency
    Get
    Set
abstract NominalFrequency : LineFrequency with get, set
override NominalFrequency : LineFrequency with get, set
function get_NominalFrequency();
function set_NominalFrequency(value);
public:
virtual property LineFrequency NominalFrequency {
    LineFrequency get () override;
    void set (LineFrequency value) override;
}

Property Value

Type: LineFrequency

Implements

IConfigurationCellNominalFrequency
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.Parent Property

Grid Solutions Framework ConfigurationCellParent Property
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
member Parent : ConfigurationFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports rectangular phasor data.
Remarks
This property only supports rectangular phasor data; Macrodyne doesn't transport polar phasor values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
Exceptions
Exception | Condition
NotSupportedException | Macrodyne only supports scaled data.
Remarks
This property only supports scaled data; Macrodyne doesn't transport floating-point values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.PhasorDefinitions Property

Grid Solutions Framework ConfigurationCellPhasorDefinitions Property
Gets a reference to the PhasorDefinitionCollection of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override PhasorDefinitionCollection PhasorDefinitions { get; }
Public Overrides ReadOnly Property PhasorDefinitions As PhasorDefinitionCollection
    Get
abstract PhasorDefinitions : PhasorDefinitionCollection with get
override PhasorDefinitions : PhasorDefinitionCollection with get
function get_PhasorDefinitions();

public:
virtual property PhasorDefinitionCollection^ PhasorDefinitions {
    PhasorDefinitionCollection^ get () override;
}

Property Value

Type: PhasorDefinitionCollection

Implements

IConfigurationCellPhasorDefinitions
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.SectionEntry Property

Grid Solutions Framework ConfigurationCellSectionEntry Property
Gets or sets section entry in INI based configuration file for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SectionEntry { get; set; }
Public Property SectionEntry As String
    Get
    Set
member SectionEntry : string with get, set

function get_SectionEntry();
function set_SectionEntry(value);
public:
property String^ SectionEntry {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCell.StationName Property

Grid Solutions Framework ConfigurationCellStationName Property
Gets or sets the station name of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string StationName { get; set; }
Public Overrides Property StationName As String
    Get
    Set
abstract StationName : string with get, set
override StationName : string with get, set
function get_StationName();
function set_StationName(value);
public:
virtual property String^ StationName {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String

Implements

IConfigurationCellStationName
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a Macrodyne implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.MacrodyneConfigurationCellCollection

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.Macrodyne.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Public method | ConfigurationCellCollection(Int32) | Creates a new ConfigurationCellCollection with alternate maximum cell count.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetBySectionEntry | Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Public method | ConfigurationCellCollection(Int32) | Creates a new ConfigurationCellCollection with alternate maximum cell count.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.Macrodyne.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Constructor (Int32)

Grid Solutions Framework ConfigurationCellCollection Constructor (Int32)
Creates a new ConfigurationCellCollection with alternate maximum cell count.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection(
    int lastValidIndex
)
Public Sub New (
    lastValidIndex As Integer
)
new :
        lastValidIndex : int -> ConfigurationCellCollection
GSF.PhasorProtocols.Macrodyne.ConfigurationCellCollection = function(lastValidIndex);
public:
ConfigurationCellCollection(
    int lastValidIndex
)

Parameters

lastValidIndex
Type: SystemInt32
Last valid index for the collection (i.e., maximum count - 1).
Remarks
lastValidIndex is used instead of maximum count so that maximum type values may be specified as needed. For example, if the protocol specifies a collection with a signed 16-bit maximum length you can specify MaxValue (i.e., 32,767) as the last valid index for the collection since total number of items supported would be 32,768.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.Macrodyne.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetBySectionEntry | Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection.TryGetBySectionEntry Method

Grid Solutions Framework ConfigurationCellCollectionTryGetBySectionEntry Method
Attempts to retrieve a ConfigurationCell from this ConfigurationCellCollection with the specified sectionEntry.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetBySectionEntry(
    string sectionEntry,
    ref ConfigurationCell configurationCell
)
Public Function TryGetBySectionEntry (
    sectionEntry As String,
    ByRef configurationCell As ConfigurationCell
) As Boolean
member TryGetBySectionEntry :
        sectionEntry : string *
        configurationCell : ConfigurationCell byref -> bool

function TryGetBySectionEntry(sectionEntry, configurationCell);
public:
bool TryGetBySectionEntry(
    String^ sectionEntry,
    ConfigurationCell^% configurationCell
)

Parameters

sectionEntry
Type: SystemString
SectionEntry value to try to find.
configurationCell
Type: GSF.PhasorProtocols.MacrodyneConfigurationCell
ConfigurationCell with the specified sectionEntry if found; otherwise null.

Return Value

Type: Boolean
true if ConfigurationCell with the specified sectionEntry is found; otherwise false.
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Class

Grid Solutions Framework ConfigurationFrame Class
Represents the Macrodyne implementation of a IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.MacrodyneConfigurationFrame

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class ConfigurationFrame
    Inherits ConfigurationFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type ConfigurationFrame =
    class
        inherit ConfigurationFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.Macrodyne.ConfigurationFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.ConfigurationFrame',
    GSF.PhasorProtocols.ConfigurationFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The ConfigurationFrame type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(OnlineDataFormatFlags, String, String, String) | Creates a new ConfigurationFrame.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
 | GetIniFileImage | Gets a generated INI configuration file image.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | Refresh | Reload Macrodyne INI based configuration file.
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Fields
Name | Description
DefaultCurrentPhasorEntry | Default current phasor INI based configuration entry.
DefaultFrequencyEntry | Default frequency INI based configuration entry.
DefaultVoltagePhasorEntry | Default voltage phasor INI based configuration entry.
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the ConfigurationFrame. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFileName | Gets the INI based configuration file name of this ConfigurationFrame.
Public property | DataFrameLength | Gets length of data frame based on enabled streaming data.
Public property | DefaultFrequency | Gets the default frequency definition.
Public property | DefaultPhasorI | Gets the default current phasor definition.
Public property | DefaultPhasorV | Gets the default voltage phasor definition.
Public property | Digital1Included | Gets flag that determines if Digital 1 is included in ON-LINE data.
Public property | Digital2Included | Gets flag that determines if Digital 2 is included in ON-LINE data.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ConfigurationCell. (Overrides ChannelFrameBaseTIDCode.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | OnlineDataFormatFlags | Gets or sets the Macrodyne OnlineDataFormatFlags of this ConfigurationFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | PhasorCount | Gets phasor count derived from OnlineDataFormatFlags of this ConfigurationFrame.
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | ReferenceIncluded | Gets flag that determines if reference phasor is included in ON-LINE data.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | StationName | Gets station name retrieved from header frame.
Public property | Status2Included | Gets flag that determines if status 2 flags are included in ON-LINE data.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimestampIncluded | Gets flag that determines if timestamp is included in ON-LINE data.
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
Events
 | Name | Description
Public event | ConfigurationFileReloaded | Occurs when the Macrodyne INI based configuration file has been reloaded.
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Overload List
 | Name | Description
Public method | ConfigurationFrame | Creates a new ConfigurationFrame.
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(OnlineDataFormatFlags, String, String, String) | Creates a new ConfigurationFrame.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Creates a new ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public ConfigurationFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> ConfigurationFrame
GSF.PhasorProtocols.Macrodyne.ConfigurationFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
ConfigurationFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse a Macrodyne configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame
GSF.PhasorProtocols.Macrodyne.ConfigurationFrame = function(info, context);
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Constructor (OnlineDataFormatFlags, String, String, String)

Grid Solutions Framework ConfigurationFrame Constructor (OnlineDataFormatFlags, String, String, String)
Creates a new ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame(
    OnlineDataFormatFlags onlineDataFormatFlags,
    string unitID,
    string configurationFileName = null,
    string deviceLabel = null
)
Public Sub New (
    onlineDataFormatFlags As OnlineDataFormatFlags,
    unitID As String,
    Optional configurationFileName As String = Nothing,
    Optional deviceLabel As String = Nothing
)
new :
        onlineDataFormatFlags : OnlineDataFormatFlags *
        unitID : string *
        ?configurationFileName : string *
        ?deviceLabel : string
(* Defaults:
        let _configurationFileName = defaultArg configurationFileName null
        let _deviceLabel = defaultArg deviceLabel null
*)
-> ConfigurationFrame
GSF.PhasorProtocols.Macrodyne.ConfigurationFrame = function(onlineDataFormatFlags, unitID, configurationFileName, deviceLabel);
public:
ConfigurationFrame(
    OnlineDataFormatFlags onlineDataFormatFlags,
    String^ unitID,
    String^ configurationFileName = nullptr,
    String^ deviceLabel = nullptr
)

Parameters

onlineDataFormatFlags
Type: GSF.PhasorProtocols.MacrodyneOnlineDataFormatFlags
Online data format flags to use in this Macrodyne ConfigurationFrame.
unitID
Type: SystemString
8 character unit ID to use in this Macrodyne ConfigurationFrame.
configurationFileName (Optional)
Type: SystemString
INI configuration file name, if specified.
deviceLabel (Optional)
Type: SystemString
INI section name.
Remarks
This constructor is used by a consumer to generate a Macrodyne configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Fields

Grid Solutions Framework ConfigurationFrame Fields

The ConfigurationFrame type exposes the following members.

Fields
Name | Description
DefaultCurrentPhasorEntry | Default current phasor INI based configuration entry.
DefaultFrequencyEntry | Default frequency INI based configuration entry.
DefaultVoltagePhasorEntry | Default voltage phasor INI based configuration entry.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.DefaultCurrentPhasorEntry Field

Grid Solutions Framework ConfigurationFrameDefaultCurrentPhasorEntry Field
Default current phasor INI based configuration entry.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultCurrentPhasorEntry
Public Const DefaultCurrentPhasorEntry As String
static val mutable DefaultCurrentPhasorEntry: string
var GSF.PhasorProtocols.Macrodyne.ConfigurationFrame.DefaultCurrentPhasorEntry
public:
literal String^ DefaultCurrentPhasorEntry

Field Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.DefaultFrequencyEntry Field

Grid Solutions Framework ConfigurationFrameDefaultFrequencyEntry Field
Default frequency INI based configuration entry.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultFrequencyEntry
Public Const DefaultFrequencyEntry As String
static val mutable DefaultFrequencyEntry: string
var GSF.PhasorProtocols.Macrodyne.ConfigurationFrame.DefaultFrequencyEntry
public:
literal String^ DefaultFrequencyEntry

Field Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.DefaultVoltagePhasorEntry Field

Grid Solutions Framework ConfigurationFrameDefaultVoltagePhasorEntry Field
Default voltage phasor INI based configuration entry.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultVoltagePhasorEntry
Public Const DefaultVoltagePhasorEntry As String
static val mutable DefaultVoltagePhasorEntry: string
var GSF.PhasorProtocols.Macrodyne.ConfigurationFrame.DefaultVoltagePhasorEntry
public:
literal String^ DefaultVoltagePhasorEntry

Field Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Methods

Grid Solutions Framework ConfigurationFrame Methods

The ConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
 | GetIniFileImage | Gets a generated INI configuration file image.
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Overrides ChannelFrameBaseTParseBinaryImage(Byte, Int32, Int32).)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | Refresh | Reload Macrodyne INI based configuration file.
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.AppendChecksum Method

Grid Solutions Framework ConfigurationFrameAppendChecksum Method
Appends checksum onto buffer starting at startIndex.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum (
    buffer As Byte(),
    startIndex As Integer
)
abstract AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
override AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
function AppendChecksum(buffer, startIndex);
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image on which to append checksum.
startIndex
Type: SystemInt32
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accomodate 2-byte checksum representation. We override this method since checksum in Macrodyne is a single byte.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.ChecksumIsValid Method

Grid Solutions Framework ConfigurationFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. So we override method since checksum in Macrodyne is a single byte.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.GetIniFileImage Method

Grid Solutions Framework ConfigurationFrameGetIniFileImage Method
Gets a generated INI configuration file image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetIniFileImage(
    IConfigurationFrame configFrame
)
Public Shared Function GetIniFileImage (
    configFrame As IConfigurationFrame
) As String
static member GetIniFileImage :
        configFrame : IConfigurationFrame -> string

GSF.PhasorProtocols.Macrodyne.ConfigurationFrame.GetIniFileImage = function(configFrame);
public:
static String^ GetIniFileImage(
    IConfigurationFrame^ configFrame
)

Parameters

configFrame
Type: GSF.PhasorProtocolsIConfigurationFrame

[Missing <param name="configFrame"/> documentation for "M:GSF.PhasorProtocols.Macrodyne.ConfigurationFrame.GetIniFileImage(GSF.PhasorProtocols.IConfigurationFrame)"]

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.PhasorProtocols.Macrodyne.ConfigurationFrame.GetIniFileImage(GSF.PhasorProtocols.IConfigurationFrame)"]

See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.GetObjectData Method

Grid Solutions Framework ConfigurationFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.ParseBinaryImage Method

Grid Solutions Framework ConfigurationFrameParseBinaryImage Method
Parses the binary image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Overrides Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Remarks
This method is overridden so INI file can be loaded after binary image has been parsed as well as adjusting CRC length.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.ParseHeaderImage Method

Grid Solutions Framework ConfigurationFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.Refresh Method

Grid Solutions Framework ConfigurationFrameRefresh Method
Reload Macrodyne INI based configuration file.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Refresh()
Public Sub Refresh
member Refresh : unit -> unit

function Refresh();
public:
void Refresh()
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Properties

Grid Solutions Framework ConfigurationFrame Properties

The ConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the ConfigurationFrame. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFileName | Gets the INI based configuration file name of this ConfigurationFrame.
Public property | DataFrameLength | Gets length of data frame based on enabled streaming data.
Public property | DefaultFrequency | Gets the default frequency definition.
Public property | DefaultPhasorI | Gets the default current phasor definition.
Public property | DefaultPhasorV | Gets the default voltage phasor definition.
Public property | Digital1Included | Gets flag that determines if Digital 1 is included in ON-LINE data.
Public property | Digital2Included | Gets flag that determines if Digital 2 is included in ON-LINE data.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the numeric ID code for this ConfigurationCell. (Overrides ChannelFrameBaseTIDCode.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | OnlineDataFormatFlags | Gets or sets the Macrodyne OnlineDataFormatFlags of this ConfigurationFrame.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | PhasorCount | Gets phasor count derived from OnlineDataFormatFlags of this ConfigurationFrame.
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | ReferenceIncluded | Gets flag that determines if reference phasor is included in ON-LINE data.
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | StationName | Gets station name retrieved from header frame.
Public property | Status2Included | Gets flag that determines if status 2 flags are included in ON-LINE data.
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimestampIncluded | Gets flag that determines if timestamp is included in ON-LINE data.
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.Attributes Property

Grid Solutions Framework ConfigurationFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.BinaryLength Property

Grid Solutions Framework ConfigurationFrameBinaryLength Property
Gets the length of the ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
Remarks
This property is overridden so the length can be extended to include a 1-byte checksum.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.Cells Property

Grid Solutions Framework ConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.CommonHeader Property

Grid Solutions Framework ConfigurationFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.ConfigurationFileName Property

Grid Solutions Framework ConfigurationFrameConfigurationFileName Property
Gets the INI based configuration file name of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConfigurationFileName { get; }
Public ReadOnly Property ConfigurationFileName As String
    Get
member ConfigurationFileName : string with get

function get_ConfigurationFileName();

public:
property String^ ConfigurationFileName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.DataFrameLength Property

Grid Solutions Framework ConfigurationFrameDataFrameLength Property
Gets length of data frame based on enabled streaming data.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DataFrameLength { get; }
Public ReadOnly Property DataFrameLength As UShort
    Get
member DataFrameLength : uint16 with get

function get_DataFrameLength();

public:
property unsigned short DataFrameLength {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.DefaultFrequency Property

Grid Solutions Framework ConfigurationFrameDefaultFrequency Property
Gets the default frequency definition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition DefaultFrequency { get; }
Public ReadOnly Property DefaultFrequency As FrequencyDefinition
    Get
member DefaultFrequency : FrequencyDefinition with get

function get_DefaultFrequency();

public:
property FrequencyDefinition^ DefaultFrequency {
    FrequencyDefinition^ get ();
}

Property Value

Type: FrequencyDefinition
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.DefaultPhasorI Property

Grid Solutions Framework ConfigurationFrameDefaultPhasorI Property
Gets the default current phasor definition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition DefaultPhasorI { get; }
Public ReadOnly Property DefaultPhasorI As PhasorDefinition
    Get
member DefaultPhasorI : PhasorDefinition with get

function get_DefaultPhasorI();

public:
property PhasorDefinition^ DefaultPhasorI {
    PhasorDefinition^ get ();
}

Property Value

Type: PhasorDefinition
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.DefaultPhasorV Property

Grid Solutions Framework ConfigurationFrameDefaultPhasorV Property
Gets the default voltage phasor definition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition DefaultPhasorV { get; }
Public ReadOnly Property DefaultPhasorV As PhasorDefinition
    Get
member DefaultPhasorV : PhasorDefinition with get

function get_DefaultPhasorV();

public:
property PhasorDefinition^ DefaultPhasorV {
    PhasorDefinition^ get ();
}

Property Value

Type: PhasorDefinition
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.Digital1Included Property

Grid Solutions Framework ConfigurationFrameDigital1Included Property
Gets flag that determines if Digital 1 is included in ON-LINE data.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Digital1Included { get; }
Public ReadOnly Property Digital1Included As Boolean
    Get
member Digital1Included : bool with get

function get_Digital1Included();

public:
property bool Digital1Included {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.Digital2Included Property

Grid Solutions Framework ConfigurationFrameDigital2Included Property
Gets flag that determines if Digital 2 is included in ON-LINE data.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Digital2Included { get; }
Public ReadOnly Property Digital2Included As Boolean
    Get
member Digital2Included : bool with get

function get_Digital2Included();

public:
property bool Digital2Included {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.HeaderImage Property

Grid Solutions Framework ConfigurationFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.HeaderLength Property

Grid Solutions Framework ConfigurationFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.IDCode Property

Grid Solutions Framework ConfigurationFrameIDCode Property
Gets or sets the numeric ID code for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ushort IDCode { get; set; }
Public Overrides Property IDCode As UShort
    Get
    Set
abstract IDCode : uint16 with get, set
override IDCode : uint16 with get, set
function get_IDCode();
function set_IDCode(value);
public:
virtual property unsigned short IDCode {
    unsigned short get () override;
    void set (unsigned short value) override;
}

Property Value

Type: UInt16

Implements

IChannelFrameIDCode
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.OnlineDataFormatFlags Property

Grid Solutions Framework ConfigurationFrameOnlineDataFormatFlags Property
Gets or sets the Macrodyne OnlineDataFormatFlags of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OnlineDataFormatFlags OnlineDataFormatFlags { get; set; }
Public Property OnlineDataFormatFlags As OnlineDataFormatFlags
    Get
    Set
member OnlineDataFormatFlags : OnlineDataFormatFlags with get, set

function get_OnlineDataFormatFlags();
function set_OnlineDataFormatFlags(value);
public:
property OnlineDataFormatFlags OnlineDataFormatFlags {
    OnlineDataFormatFlags get ();
    void set (OnlineDataFormatFlags value);
}

Property Value

Type: OnlineDataFormatFlags
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.PhasorCount Property

Grid Solutions Framework ConfigurationFramePhasorCount Property
Gets phasor count derived from OnlineDataFormatFlags of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int PhasorCount { get; }
Public ReadOnly Property PhasorCount As Integer
    Get
member PhasorCount : int with get

function get_PhasorCount();

public:
property int PhasorCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.ReferenceIncluded Property

Grid Solutions Framework ConfigurationFrameReferenceIncluded Property
Gets flag that determines if reference phasor is included in ON-LINE data.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReferenceIncluded { get; }
Public ReadOnly Property ReferenceIncluded As Boolean
    Get
member ReferenceIncluded : bool with get

function get_ReferenceIncluded();

public:
property bool ReferenceIncluded {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.StationName Property

Grid Solutions Framework ConfigurationFrameStationName Property
Gets station name retrieved from header frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StationName { get; }
Public ReadOnly Property StationName As String
    Get
member StationName : string with get

function get_StationName();

public:
property String^ StationName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.Status2Included Property

Grid Solutions Framework ConfigurationFrameStatus2Included Property
Gets flag that determines if status 2 flags are included in ON-LINE data.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Status2Included { get; }
Public ReadOnly Property Status2Included As Boolean
    Get
member Status2Included : bool with get

function get_Status2Included();

public:
property bool Status2Included {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.TimestampIncluded Property

Grid Solutions Framework ConfigurationFrameTimestampIncluded Property
Gets flag that determines if timestamp is included in ON-LINE data.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TimestampIncluded { get; }
Public ReadOnly Property TimestampIncluded As Boolean
    Get
member TimestampIncluded : bool with get

function get_TimestampIncluded();

public:
property bool TimestampIncluded {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.TypeID Property

Grid Solutions Framework ConfigurationFrameTypeID Property
Gets the identifier that is used to identify the Macrodyne frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame Events

Grid Solutions Framework ConfigurationFrame Events

The ConfigurationFrame type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationFileReloaded | Occurs when the Macrodyne INI based configuration file has been reloaded.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrame.ConfigurationFileReloaded Event

Grid Solutions Framework ConfigurationFrameConfigurationFileReloaded Event
Occurs when the Macrodyne INI based configuration file has been reloaded.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationFileReloaded
Public Event ConfigurationFileReloaded As EventHandler
member ConfigurationFileReloaded : IEvent<EventHandler,
    EventArgs>

function add_ConfigurationFileReloaded(value);
function remove_ConfigurationFileReloaded(value);
public:
 event EventHandler^ ConfigurationFileReloaded {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrameParsingState Class

Grid Solutions Framework ConfigurationFrameParsingState Class
Represents the Macrodyne implementation of the parsing state used by a ConfigurationFrame.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsChannelParsingStateBase
GSF.PhasorProtocolsChannelFrameParsingStateBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameParsingState
GSF.PhasorProtocols.MacrodyneConfigurationFrameParsingState

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConfigurationFrameParsingState : ConfigurationFrameParsingState
Public Class ConfigurationFrameParsingState
    Inherits ConfigurationFrameParsingState
type ConfigurationFrameParsingState =
    class
        inherit ConfigurationFrameParsingState
    end
GSF.PhasorProtocols.Macrodyne.ConfigurationFrameParsingState = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.ConfigurationFrameParsingState',
    GSF.PhasorProtocols.ConfigurationFrameParsingState);
public ref class ConfigurationFrameParsingState : public ConfigurationFrameParsingState

The ConfigurationFrameParsingState type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationFrameParsingState | Creates a new ConfigurationFrameParsingState from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | HeaderFrame | Gets or sets the header frame, which contains the unit ID (i.e., station name), of the device.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrameParsingState Constructor

Grid Solutions Framework ConfigurationFrameParsingState Constructor
Creates a new ConfigurationFrameParsingState from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrameParsingState(
    int parsedBinaryLength,
    HeaderFrame headerFrame,
    CreateNewCellFunction<IConfigurationCell> createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)
Public Sub New (
    parsedBinaryLength As Integer,
    headerFrame As HeaderFrame,
    createNewCellFunction As CreateNewCellFunction(Of IConfigurationCell),
    trustHeaderLength As Boolean,
    validateCheckSum As Boolean
)
new :
        parsedBinaryLength : int *
        headerFrame : HeaderFrame *
        createNewCellFunction : CreateNewCellFunction<IConfigurationCell> *
        trustHeaderLength : bool *
        validateCheckSum : bool -> ConfigurationFrameParsingState
GSF.PhasorProtocols.Macrodyne.ConfigurationFrameParsingState = function(parsedBinaryLength, headerFrame, createNewCellFunction, trustHeaderLength, validateCheckSum);
public:
ConfigurationFrameParsingState(
    int parsedBinaryLength,
    HeaderFrame^ headerFrame,
    CreateNewCellFunction<IConfigurationCell^>^ createNewCellFunction,
    bool trustHeaderLength,
    bool validateCheckSum
)

Parameters

parsedBinaryLength
Type: SystemInt32
Binary length of the ConfigurationFrame being parsed.
headerFrame
Type: GSF.PhasorProtocols.MacrodyneHeaderFrame
Previously parsed header frame that contains needed station name.
createNewCellFunction
Type: GSF.PhasorProtocolsCreateNewCellFunction IConfigurationCell
Reference to delegate to create new ConfigurationCell instances.
trustHeaderLength
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
validateCheckSum
Type: SystemBoolean
Determines if frame's check-sum should be validated.
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrameParsingState Methods

Grid Solutions Framework ConfigurationFrameParsingState Methods

The ConfigurationFrameParsingState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrameParsingState Properties

Grid Solutions Framework ConfigurationFrameParsingState Properties

The ConfigurationFrameParsingState type exposes the following members.

Properties
 | Name | Description
Public property | CellCount | Gets or sets number of cells that are expected in associated IChannelFrame being parsed. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | CreateNewCell | Gets reference to delegate used to create a new IChannelCell object. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | HeaderFrame | Gets or sets the header frame, which contains the unit ID (i.e., station name), of the device.
Public property | ParsedBinaryLength | Gets or sets the length of the associated IChannel object being parsed from the binary image. (Inherited from ChannelParsingStateBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameParsingStateBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated. (Inherited from ChannelFrameParsingStateBaseT.)
Top
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.Macrodyne Namespace


ConfigurationFrameParsingState.HeaderFrame Property

Grid Solutions Framework ConfigurationFrameParsingStateHeaderFrame Property
Gets or sets the header frame, which contains the unit ID (i.e., station name), of the device.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderFrame HeaderFrame { get; set; }
Public Property HeaderFrame As HeaderFrame
    Get
    Set
member HeaderFrame : HeaderFrame with get, set

function get_HeaderFrame();
function set_HeaderFrame(value);
public:
property HeaderFrame^ HeaderFrame {
    HeaderFrame^ get ();
    void set (HeaderFrame^ value);
}

Property Value

Type: HeaderFrame
See Also

Reference

ConfigurationFrameParsingState Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters Class

Grid Solutions Framework ConnectionParameters Class
Represents the extra connection parameters required for a connection to a Macrodyne.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsConnectionParametersBase
GSF.PhasorProtocols.MacrodyneConnectionParameters

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute>
Public Class ConnectionParameters
    Inherits ConnectionParametersBase
[<SerializableAttribute>]
type ConnectionParameters =
    class
        inherit ConnectionParametersBase
    end
GSF.PhasorProtocols.Macrodyne.ConnectionParameters = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.ConnectionParameters',
    GSF.PhasorProtocols.ConnectionParametersBase);
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase

The ConnectionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConfigurationFileName | Gets or sets the optional Macrodyne configuration source based on a BPA PDCstream style INI file.
Public property | DeviceLabel | Gets or sets device section label, as defined in associated INI file.
Public property | ProtocolVersion | Gets or sets flag that determines the Macrodyne protocol version.
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | ValuesAreValid | Determines if selected Macrodyne configuration file exists when needed. (Overrides ConnectionParametersBaseValuesAreValid.)
Top
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Overload List
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Creates a new ConnectionParameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionParameters()
Public Sub New
new : unit -> ConnectionParameters
GSF.PhasorProtocols.Macrodyne.ConnectionParameters = function();
public:
ConnectionParameters()
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConnectionParameters Constructor (SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConnectionParameters
GSF.PhasorProtocols.Macrodyne.ConnectionParameters = function(info, context);
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters Methods

Grid Solutions Framework ConnectionParameters Methods

The ConnectionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters.GetObjectData Method

Grid Solutions Framework ConnectionParametersGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters Properties

Grid Solutions Framework ConnectionParameters Properties

The ConnectionParameters type exposes the following members.

Properties
 | Name | Description
Public property | ConfigurationFileName | Gets or sets the optional Macrodyne configuration source based on a BPA PDCstream style INI file.
Public property | DeviceLabel | Gets or sets device section label, as defined in associated INI file.
Public property | ProtocolVersion | Gets or sets flag that determines the Macrodyne protocol version.
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | ValuesAreValid | Determines if selected Macrodyne configuration file exists when needed. (Overrides ConnectionParametersBaseValuesAreValid.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters.ConfigurationFileName Property

Grid Solutions Framework ConnectionParametersConfigurationFileName Property
Gets or sets the optional Macrodyne configuration source based on a BPA PDCstream style INI file.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))]
public string ConfigurationFileName { get; set; }
<EditorAttribute(GetType(IniFileNameEditor), GetType(UITypeEditor))>
Public Property ConfigurationFileName As String
    Get
    Set
[<EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))>]
member ConfigurationFileName : string with get, set

function get_ConfigurationFileName();
function set_ConfigurationFileName(value);
public:
[EditorAttribute(typeof(IniFileNameEditor), typeof(UITypeEditor))]
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters.DeviceLabel Property

Grid Solutions Framework ConnectionParametersDeviceLabel Property
Gets or sets device section label, as defined in associated INI file.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DeviceLabel { get; set; }
Public Property DeviceLabel As String
    Get
    Set
member DeviceLabel : string with get, set

function get_DeviceLabel();
function set_DeviceLabel(value);
public:
property String^ DeviceLabel {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters.ProtocolVersion Property

Grid Solutions Framework ConnectionParametersProtocolVersion Property
Gets or sets flag that determines the Macrodyne protocol version.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(typeof(ProtocolVersion), "M")]
public ProtocolVersion ProtocolVersion { get; set; }
<DefaultValueAttribute(GetType(ProtocolVersion), "M")>
Public Property ProtocolVersion As ProtocolVersion
    Get
    Set
[<DefaultValueAttribute(typeof(ProtocolVersion), "M")>]
member ProtocolVersion : ProtocolVersion with get, set

function get_ProtocolVersion();
function set_ProtocolVersion(value);
public:
[DefaultValueAttribute(typeof(ProtocolVersion), L"M")]
property ProtocolVersion ProtocolVersion {
    ProtocolVersion get ();
    void set (ProtocolVersion value);
}

Property Value

Type: ProtocolVersion
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters.RefreshConfigurationFileOnChange Property

Grid Solutions Framework ConnectionParametersRefreshConfigurationFileOnChange Property
Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool RefreshConfigurationFileOnChange { get; set; }
<DefaultValueAttribute(true)>
Public Property RefreshConfigurationFileOnChange As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member RefreshConfigurationFileOnChange : bool with get, set

function get_RefreshConfigurationFileOnChange();
function set_RefreshConfigurationFileOnChange(value);
public:
[DefaultValueAttribute(true)]
property bool RefreshConfigurationFileOnChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


ConnectionParameters.ValuesAreValid Property

Grid Solutions Framework ConnectionParametersValuesAreValid Property
Determines if selected Macrodyne configuration file exists when needed.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public override bool ValuesAreValid { get; }
<BrowsableAttribute(false)>
Public Overrides ReadOnly Property ValuesAreValid As Boolean
    Get
[<BrowsableAttribute(false)>]
abstract ValuesAreValid : bool with get
[<BrowsableAttribute(false)>]
override ValuesAreValid : bool with get
function get_ValuesAreValid();

public:
[BrowsableAttribute(false)]
virtual property bool ValuesAreValid {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IConnectionParametersValuesAreValid
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell Class

Grid Solutions Framework DataCell Class
Represents the Macrodyne implementation of a IDataCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.MacrodyneDataCell

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute>
Public Class DataCell
    Inherits DataCellBase
[<SerializableAttribute>]
type DataCell =
    class
        inherit DataCellBase
    end
GSF.PhasorProtocols.Macrodyne.DataCell = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.DataCell',
    GSF.PhasorProtocols.DataCellBase);
[SerializableAttribute]
public ref class DataCell : public DataCellBase

The DataCell type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides DataCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBaseAnalogValues.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | ClockStatusFlags | Gets or sets ClockStatusFlags for this DataCell.
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Public property | GpsStatus | Gets or sets GpsStatus for this DataCell.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCell.
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | ReferencePhasor | Gets or sets reference phasor value.
Public property | ReferenceSampleNumber | Gets or sets reference phasor sample number.
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | Status1Flags | Gets or sets status 1 flags for this DataCell.
Public property | Status2Flags | Gets or sets status 2 flags for this DataCell.
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerReason | Gets or sets TriggerReason for this DataCell.
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DataCell Constructor

Grid Solutions Framework DataCell Constructor
Overload List
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCell Constructor (SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCell
GSF.PhasorProtocols.Macrodyne.DataCell = function(info, context);
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataCell Constructor (IDataFrame, IConfigurationCell)

Grid Solutions Framework DataCell Constructor (IDataFrame, IConfigurationCell)
Creates a new DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell -> DataCell
GSF.PhasorProtocols.Macrodyne.DataCell = function(parent, configurationCell);
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCell.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataCell Constructor (DataFrame, ConfigurationCell, Boolean)

Grid Solutions Framework DataCell Constructor (DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New (
    parent As DataFrame,
    configurationCell As ConfigurationCell,
    addEmptyValues As Boolean
)
new :
        parent : DataFrame *
        configurationCell : ConfigurationCell *
        addEmptyValues : bool -> DataCell
GSF.PhasorProtocols.Macrodyne.DataCell = function(parent, configurationCell, addEmptyValues);
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneDataFrame
The reference to parent DataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocols.MacrodyneConfigurationCell
The ConfigurationCell associated with this DataCell.
addEmptyValues
Type: SystemBoolean
If true, adds empty values for each defined configuration cell definition.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataCell Methods

Grid Solutions Framework DataCell Methods

The DataCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataCellBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides DataCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.GetObjectData Method

Grid Solutions Framework DataCellGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.ParseBodyImage Method

Grid Solutions Framework DataCellParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell Properties

Grid Solutions Framework DataCell Properties

The DataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBaseAnalogValues.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | ClockStatusFlags | Gets or sets ClockStatusFlags for this DataCell.
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollectionof this DataCellBase. (Inherited from DataCellBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Public property | GpsStatus | Gets or sets GpsStatus for this DataCell.
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCell.
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | ReferencePhasor | Gets or sets reference phasor value.
Public property | ReferenceSampleNumber | Gets or sets reference phasor sample number.
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | Status1Flags | Gets or sets status 1 flags for this DataCell.
Public property | Status2Flags | Gets or sets status 2 flags for this DataCell.
Public property | StatusFlags | Gets or sets 16-bit status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TriggerReason | Gets or sets TriggerReason for this DataCell.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.AnalogValues Property

Grid Solutions Framework DataCellAnalogValues Property
Gets AnalogValueCollection of this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override AnalogValueCollection AnalogValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides ReadOnly Property AnalogValues As AnalogValueCollection
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract AnalogValues : AnalogValueCollection with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override AnalogValues : AnalogValueCollection with get
function get_AnalogValues();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get () override;
}

Property Value

Type: AnalogValueCollection

Implements

IDataCellAnalogValues
Remarks
Macrodyne doesn't define any analog values.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.Attributes Property

Grid Solutions Framework DataCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataCell object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.ClockStatusFlags Property

Grid Solutions Framework DataCellClockStatusFlags Property
Gets or sets ClockStatusFlags for this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClockStatusFlags ClockStatusFlags { get; set; }
Public Property ClockStatusFlags As ClockStatusFlags
    Get
    Set
member ClockStatusFlags : ClockStatusFlags with get, set

function get_ClockStatusFlags();
function set_ClockStatusFlags(value);
public:
property ClockStatusFlags ClockStatusFlags {
    ClockStatusFlags get ();
    void set (ClockStatusFlags value);
}

Property Value

Type: ClockStatusFlags
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.ConfigurationCell Property

Grid Solutions Framework DataCellConfigurationCell Property
Gets or sets the ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
member ConfigurationCell : ConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.DataIsValid Property

Grid Solutions Framework DataCellDataIsValid Property
Gets or sets flag that determines if data of this DataCell is valid.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set
override DataIsValid : bool with get, set
function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.DataSortingType Property

Grid Solutions Framework DataCellDataSortingType Property
Gets or sets DataSortingType of this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set
override DataSortingType : DataSortingType with get, set
function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.DeviceError Property

Grid Solutions Framework DataCellDeviceError Property
Gets or sets flag that determines if source device of this DataCell is reporting an error.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property DeviceError As Boolean
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract DeviceError : bool with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override DeviceError : bool with get, set
function get_DeviceError();
function set_DeviceError(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
Remarks
Macrodyne doesn't define bits for device error.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.GpsStatus Property

Grid Solutions Framework DataCellGpsStatus Property
Gets or sets GpsStatus for this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public GpsStatus GpsStatus { get; set; }
Public Property GpsStatus As GpsStatus
    Get
    Set
member GpsStatus : GpsStatus with get, set

function get_GpsStatus();
function set_GpsStatus(value);
public:
property GpsStatus GpsStatus {
    GpsStatus get ();
    void set (GpsStatus value);
}

Property Value

Type: GpsStatus
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.IDCode Property

Grid Solutions Framework DataCellIDCode Property
Gets the numeric ID code for this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint IDCode { get; }
Public ReadOnly Property IDCode As UInteger
    Get
member IDCode : uint32 with get

function get_IDCode();

public:
property unsigned int IDCode {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.Parent Property

Grid Solutions Framework DataCellParent Property
Gets or sets the reference to parent DataFrame of this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
member Parent : DataFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}

Property Value

Type: DataFrame
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.ReferencePhasor Property

Grid Solutions Framework DataCellReferencePhasor Property
Gets or sets reference phasor value.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue ReferencePhasor { get; set; }
Public Property ReferencePhasor As PhasorValue
    Get
    Set
member ReferencePhasor : PhasorValue with get, set

function get_ReferencePhasor();
function set_ReferencePhasor(value);
public:
property PhasorValue^ ReferencePhasor {
    PhasorValue^ get ();
    void set (PhasorValue^ value);
}

Property Value

Type: PhasorValue
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.ReferenceSampleNumber Property

Grid Solutions Framework DataCellReferenceSampleNumber Property
Gets or sets reference phasor sample number.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort ReferenceSampleNumber { get; set; }
Public Property ReferenceSampleNumber As UShort
    Get
    Set
member ReferenceSampleNumber : uint16 with get, set

function get_ReferenceSampleNumber();
function set_ReferenceSampleNumber(value);
public:
property unsigned short ReferenceSampleNumber {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.Status1Flags Property

Grid Solutions Framework DataCellStatus1Flags Property
Gets or sets status 1 flags for this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatusFlags Status1Flags { get; set; }
Public Property Status1Flags As StatusFlags
    Get
    Set
member Status1Flags : StatusFlags with get, set

function get_Status1Flags();
function set_Status1Flags(value);
public:
property StatusFlags Status1Flags {
    StatusFlags get ();
    void set (StatusFlags value);
}

Property Value

Type: StatusFlags
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.Status2Flags Property

Grid Solutions Framework DataCellStatus2Flags Property
Gets or sets status 2 flags for this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte Status2Flags { get; set; }
Public Property Status2Flags As Byte
    Get
    Set
member Status2Flags : byte with get, set

function get_Status2Flags();
function set_Status2Flags(value);
public:
property unsigned char Status2Flags {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.SynchronizationIsValid Property

Grid Solutions Framework DataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set
override SynchronizationIsValid : bool with get, set
function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCell.TriggerReason Property

Grid Solutions Framework DataCellTriggerReason Property
Gets or sets TriggerReason for this DataCell.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TriggerReason TriggerReason { get; set; }
Public Property TriggerReason As TriggerReason
    Get
    Set
member TriggerReason : TriggerReason with get, set

function get_TriggerReason();
function set_TriggerReason(value);
public:
property TriggerReason TriggerReason {
    TriggerReason get ();
    void set (TriggerReason value);
}

Property Value

Type: TriggerReason
See Also

Reference

DataCell Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a Macrodyne implementation of a collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.MacrodyneDataCellCollection

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute>
Public Class DataCellCollection
    Inherits DataCellCollection
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit DataCellCollection
    end
GSF.PhasorProtocols.Macrodyne.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.DataCellCollection',
    GSF.PhasorProtocols.DataCellCollection);
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Creates a new DataCellCollection.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection()
Public Sub New
new : unit -> DataCellCollection
GSF.PhasorProtocols.Macrodyne.DataCellCollection = function();
public:
DataCellCollection()
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.Macrodyne.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection.Item Property

Grid Solutions Framework DataCellCollectionItem Property
Gets or sets DataCell at specified index.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As DataCell
    Get
    Set
member Item : DataCell with get, set

function get_Item(index);
function set_Item(value);
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: DataCell
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame Class

Grid Solutions Framework DataFrame Class
Represents the Macrodyne implementation of a IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.MacrodyneDataFrame

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>,
    ISupportFrameImage<FrameType>, ISupportBinaryImage
<SerializableAttribute>
Public Class DataFrame
    Inherits DataFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type DataFrame =
    class
        inherit DataFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.Macrodyne.DataFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.DataFrame',
    GSF.PhasorProtocols.DataFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The DataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Public method | DataFrame(Ticks) | Creates a new DataFrame from specified parameters.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Inherited from ChannelFrameBaseT.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the DataFrame. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Overload List
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Public method | DataFrame(Ticks) | Creates a new DataFrame from specified parameters.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Creates a new DataFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> DataFrame
GSF.PhasorProtocols.Macrodyne.DataFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
DataFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse a Macrodyne data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame Constructor (Ticks)

Grid Solutions Framework DataFrame Constructor (Ticks)
Creates a new DataFrame from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame(
    Ticks timestamp
)
Public Sub New (
    timestamp As Ticks
)
new :
        timestamp : Ticks -> DataFrame
GSF.PhasorProtocols.Macrodyne.DataFrame = function(timestamp);
public:
DataFrame(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrame.
Remarks
This constructor is used by a consumer to generate a Macrodyne data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrame Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrame
GSF.PhasorProtocols.Macrodyne.DataFrame = function(info, context);
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame Methods

Grid Solutions Framework DataFrame Methods

The DataFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.AppendChecksum Method

Grid Solutions Framework DataFrameAppendChecksum Method
Appends checksum onto buffer starting at startIndex.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum (
    buffer As Byte(),
    startIndex As Integer
)
abstract AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
override AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
function AppendChecksum(buffer, startIndex);
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image on which to append checksum.
startIndex
Type: SystemInt32
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accomodate 2-byte checksum representation. We override this method since checksum in Macrodyne is a single byte.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.CalculateChecksum Method

Grid Solutions Framework DataFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.ChecksumIsValid Method

Grid Solutions Framework DataFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. So we override method since checksum in Macrodyne is a single byte.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.GetObjectData Method

Grid Solutions Framework DataFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.ParseHeaderImage Method

Grid Solutions Framework DataFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame Properties

Grid Solutions Framework DataFrame Properties

The DataFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ChannelFrameBaseT object. (Inherited from ChannelFrameBaseT.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the DataFrame. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets the numeric ID code for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.BinaryLength Property

Grid Solutions Framework DataFrameBinaryLength Property
Gets the length of the DataFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
Remarks
This property is overridden so the length can be adjusted for 1-byte checksum.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.Cells Property

Grid Solutions Framework DataFrameCells Property
Gets reference to the DataCellCollection for this DataFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
member Cells : DataCellCollection with get

function get_Cells();

public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.CommonHeader Property

Grid Solutions Framework DataFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.ConfigurationFrame Property

Grid Solutions Framework DataFrameConfigurationFrame Property
Gets or sets ConfigurationFrame associated with this DataFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
member ConfigurationFrame : ConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.HeaderImage Property

Grid Solutions Framework DataFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.HeaderLength Property

Grid Solutions Framework DataFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataFrame.TypeID Property

Grid Solutions Framework DataFrameTypeID Property
Gets the identifier that is used to identify the Macrodyne frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


DataInputCommand Enumeration

Grid Solutions Framework DataInputCommand Enumeration
Macrodyne data input commands enumeration.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DataInputCommand
<SerializableAttribute>
Public Enumeration DataInputCommand
[<SerializableAttribute>]
type DataInputCommand
GSF.PhasorProtocols.Macrodyne.DataInputCommand = function();
GSF.PhasorProtocols.Macrodyne.DataInputCommand.createEnum('GSF.PhasorProtocols.Macrodyne.DataInputCommand', false);
[SerializableAttribute]
public enum class DataInputCommand
Members
Member name | Value | Description
SendReferencePhasor | 160 | Send reference phasor.
SendWordData | 162 | Send word data.
SendUnitIDData | 164 | Send unit ID data.
SendByteData | 166 | Send byte data.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DeviceCommand Enumeration

Grid Solutions Framework DeviceCommand Enumeration
Macrodyne set and request commands enumeration.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DeviceCommand
<SerializableAttribute>
Public Enumeration DeviceCommand
[<SerializableAttribute>]
type DeviceCommand
GSF.PhasorProtocols.Macrodyne.DeviceCommand = function();
GSF.PhasorProtocols.Macrodyne.DeviceCommand.createEnum('GSF.PhasorProtocols.Macrodyne.DeviceCommand', false);
[SerializableAttribute]
public enum class DeviceCommand
Members
Member name | Value | Description
SelectEvent1 | 52256 | Select Event 1.
SelectEvent2 | 52257 | Select Event 2.
SelectEvent3 | 52258 | Select Event 3.
SelectEvent4 | 52259 | Select Event 4.
SelectEvent5 | 52260 | Select Event 5.
SelectEvent6 | 52261 | Select Event 6.
SelectEvent7 | 52262 | Select Event 7.
SelectEvent8 | 52263 | Select Event 8.
SelectEvent9 | 52264 | Select Event 9.
SelectEvent10 | 52265 | Select Event 10.
SelectEvent11 | 52266 | Select Event 11.
SelectEvent12 | 52267 | Select Event 12.
SelectEvent13 | 52268 | Select Event 13.
SelectEvent14 | 52269 | Select Event 14.
SelectEvent15 | 52270 | Select Event 15.
SelectEvent16 | 52271 | Select Event 16.
EraseSelectedEvent | 52272 | Erase selected event.
ForceEvent | 52274 | Force an event.
SetOneSecondPreTriggerValue | 52276 | Set the 1 second table pre-trigger to the value in the word buffer.
SetExtendedPreTriggerValue | 52278 | Set the extended table pre-trigger to the value in the word buffer.
SetUnitID | 52280 | Set the unit ID (8 ASCII bytes) to the values in the 8 byte buffer (set using SendUnitIDData.
StartOnlineData | 52282 | Start sending ON-LINE data down this port (the port the command was received on).
StopOnlineData | 52284 | Stop sending ON-LINE data or reference data down this port.
StartSendingReferencePort1 | 52286 | Start sending the reference down port1.
StartSendingReferencePort2 | 52288 | Start sending the reference down port2.
StopSendingReference | 52290 | Stop sending the reference down either port.
EnableReferenceReception | 52292 | Enable the reference reception in any port.
DisableReferenceReception | 52294 | Disable the reference reception in any port.
RebootUnit | 52296 | Re-boot the PMU code from the EEPROM and re-start the unit.
ResetUnitAndFlags | 52298 | Reset the unit and reset the flags.
Set2CycleOutputRate | 52300 | Set the output rate to 2 cycles (i.e. 30 times/sec).
Set5CycleOutputRate | 52302 | Set the output rate to 5 cycles (i.e. 12 times/sec).
Set10CycleOutputRate | 52304 | Set the output rate to 10 cycles (i.e. 6 times/sec).
Use5Phasors | 52306 | Set the PMU for 5 phasors.
Use4Phasors | 52308 | Set the PMU for 4 phasors.
Use3Phasors | 52310 | Set the PMU for 3 phasors.
Use2Phasors | 52312 | Set the PMU for 2 phasors.
Use1Phasor | 52314 | Set the PMU for 1 phasor.
SetMScaleValue | 52316 | Set mscale to the value in the word buffer.
EnableAllTriggers | 52318 | Enable all triggers.
DisableAllTriggers | 52320 | Disable all triggers.
SetVMinTrigger | 52322 | Set the VMIN trigger to the value in the word buffer.
SetVMaxTrigger | 52324 | Set the VMAX trigger to the value in the word buffer.
SetAngdTrigger | 52326 | Set the ANGD trigger to the value in the word buffer.
SetFreqTrigger | 52328 | Set the FREQ trigger to the value in the word buffer.
SetDfDtTrigger | 52330 | Set the DFDT trigger to the value in the word buffer.
SetLncmTrigger | 52332 | Set the LNCM trigger to the value in the word buffer.
SetVCoefValue | 52334 | Set the VCOEF value to the value in the word buffer.
SetFCoefValue | 52336 | Set the FCOEF value to the value in the word buffer.
SetDCoefValue | 52338 | Set the DCOEF value to the value in the word buffer.
SetNrmDigState | 52340 | Set the NRM_DIG (normal state of digital channel) to the value in the word buffer.
SetDigEnbTrigger | 52342 | Set the DIG_ENB (digital channel trigger enable) to the value in the word buffer.
ResetOnlineDataFormat | 52344 | Reset the ON-LINE data format to the default setting.
AddSecondStatus | 52346 | Add the second status byte to the ON-LINE data.
AddTimeStamp | 52348 | Add the time stamp to the ON-LINE data.
AddSecondPhasor | 52350 | Add the second phasor to the ON-LINE data.
AddThirdPhasor | 52352 | Add the third phasor to the ON-LINE data.
AddForthPhasor | 52354 | Add the fourth phasor to the ON-LINE data.
AddFifthPhasor | 52356 | Add the fifth phasor to the ON-LINE data.
AddReferencePhasor | 52358 | Add the reference phasor to the ON-LINE data.
SetVMinOperationalLimit | 52360 | Set the VMIN operational limit to the value in the byte buffer.
SetVMaxOperationalLimit | 52362 | Set the VMAX operational limit to the value in the byte buffer.
SetAngdOperationalLimit | 52364 | Set the ANGD operational limit to the value in the byte buffer.
SetFreqOperationalLimit | 52366 | Set the FREQ operational limit to the value in the byte buffer.
SetDfDtOperationalLimit | 52368 | Set the DFDT operational limit to the value in the byte buffer.
SetLncmOperationalLimit | 52370 | Set the LNCM operational limit to the value in the byte buffer.
SetDigitalOperationalLimit | 52372 | Set the digital channels operational limit to the value in the byte buffer.
ResetOperationalLimitCounters | 52374 | Reset all operational limit counters (ANALOG AND DIGITAL) to 0.
AddDigitals | 52376 | Add digital channels to the ON-LINE data.
SetPhasorType | 52378 | Set the first set of analog channels to the value in the word buffer which designates what each channel will be, VOLTAGE or CURRENT.
SetGpsTransparentMode | 52380 | Obsolete. Set GPS to transparent mode (host port A only).
SendCommandToSecondBoard | 52382 | Send this command when the following command refers to the second board.
SetDigitalsTo16 | 52384 | Set the number of Digital Channels to 16.
SetDigitalsTo32 | 52386 | Set the number of Digital Channels to 32.
SetRawPreTriggerValue | 52388 | Set Raw data pretrigger to the value in the word buffer.
StartDebugMode | 52390 | Start Debug Mode. Stops PMU program and enters the debugger.
RequestStatus1Flags | 47904 | Request STATU1 flag (1 response byte).
RequestStatus2Flags | 47906 | Request STATU2 flag (1 response byte).
RequestOnlineDataFormat | 47908 | Request ON-LINE data format (2 response bytes).
RequestOperationalLimitFlags | 47910 | Request operational limit reached flags (3 response bytes).
RequestWordBufferValue | 47912 | Request value in word buffer (2 response bytes).
RequestByteBufferValue | 47914 | Request value in byte buffer (1 response byte).
RequestTimeTagValue | 47916 | Request current time tag string (6 response bytes).
RequestUnitStatus | 47918 | Request unit status.
RequestAnalogTriggerValues | 47920 | Request analog trigger values (18 response bytes).
RequestVMinTriggerValue | 47922 | Request VMIN trigger value (2 response bytes).
RequestVMaxTriggerValue | 47924 | Request VMAX trigger value (2 response bytes).
RequestAngdTriggerValue | 47926 | Request ANGD trigger value (2 response bytes).
RequestFreqTriggerValue | 47928 | Request FREQ trigger value (2 response bytes).
RequestDfDtTriggerValue | 47930 | Request DFDT trigger value (2 response bytes).
RequestLncmTriggerValue | 47932 | Request LNCM trigger value (2 response bytes).
RequestVCoefTriggerValue | 47934 | Request VCOEF trigger value (2 response bytes).
RequestFCoefTriggerValue | 47936 | Request FCOEF trigger value (2 response bytes).
RequestDCoefTriggerValue | 47938 | Request DCOEF trigger value (2 response bytes).
RequestDigitalsNormalState | 47940 | Request normal state of digital channels (2 response bytes).
RequestDigitalsTriggerEnabledState | 47942 | Request trigger enabled state of digital channels (1 response byte).
RequestUnitIDBufferValue | 47944 | Request value in unit ID buffer (8 ASCII response bytes).
RequestPhasorType | 47946 | Request the value which determines what each analog channel is, bit # = channel #, 1 = VOLTAGE, 0 = CURRENT.
RequestOneSecondTableLine | 47948 | Request table line from 1 second table.
RequestExtendedTableLine | 47950 | Request table line from extended table.
RequestPreviousTableLine | 47952 | Request previous table line/block.
RequestTableTimeInformation | 47954 | Request time information for selected table.
RequestTableTriggerInformation | 47956 | Request trigger information for selected table.
RequestTableWithFreezeReason | 47958 | Request table with freeze reason (16 response bytes).
RequestTimeOfFreezeTableSize | 47960 | Request number of bytes in time of freeze tables (1 response byte).
RequestTimeOfFreezeTables | 47962 | Request time of freeze tables.
RequestOperationalLimitsValue | 47964 | Request value of operational limits (7 response bytes).
RequestOperationalCountersValue | 47966 | Request value of operational counters (6 response bytes).
RequestOperationalDigitalCountsValue | 47968 | Request value of operational counts of digital channels (16 response bytes).
RequestRawTableLine | 47970 | Request raw table line.
RequestRawTableInformation | 47972 | Request raw table information (18 response bytes).
RequestCurrentRawTablePreTrigger | 47974 | Request current raw table pretrigger (22 response bytes).
Undefined | 0 | Undefined command.
Remarks
These commands should be transmitted in big-endian to make sure high word and low word are in the expected order.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DevicePort Enumeration

Grid Solutions Framework DevicePort Enumeration
Macrodyne device ports enumeration.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DevicePort
<SerializableAttribute>
Public Enumeration DevicePort
[<SerializableAttribute>]
type DevicePort
GSF.PhasorProtocols.Macrodyne.DevicePort = function();
GSF.PhasorProtocols.Macrodyne.DevicePort.createEnum('GSF.PhasorProtocols.Macrodyne.DevicePort', false);
[SerializableAttribute]
public enum class DevicePort
Members
Member name | Value | Description
Port1 | 0 | Serial port 1.
Port2 | 1 | Serial port 2.
Port3 | 2 | Serial port 3.
Port4 | 3 | Serial port 4.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition Class

Grid Solutions Framework DigitalDefinition Class
Represents the Macrodyne implementation of an IDigitalDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsDigitalDefinitionBase
GSF.PhasorProtocols.MacrodyneDigitalDefinition

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalDefinition : DigitalDefinitionBase
<SerializableAttribute>
Public Class DigitalDefinition
    Inherits DigitalDefinitionBase
[<SerializableAttribute>]
type DigitalDefinition =
    class
        inherit DigitalDefinitionBase
    end
GSF.PhasorProtocols.Macrodyne.DigitalDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.DigitalDefinition',
    GSF.PhasorProtocols.DigitalDefinitionBase);
[SerializableAttribute]
public ref class DigitalDefinition : public DigitalDefinitionBase

The DigitalDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition Constructor

Grid Solutions Framework DigitalDefinition Constructor
Overload List
 | Name | Description
Public method | DigitalDefinition(IConfigurationCell) | Creates a new DigitalDefinition from specified parameters.
Protected method | DigitalDefinition(SerializationInfo, StreamingContext) | Creates a new DigitalDefinition from serialization parameters.
Public method | DigitalDefinition(ConfigurationCell, String) | Creates a new DigitalDefinition from specified parameters.
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition Constructor (IConfigurationCell)

Grid Solutions Framework DigitalDefinition Constructor (IConfigurationCell)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> DigitalDefinition
GSF.PhasorProtocols.Macrodyne.DigitalDefinition = function(parent);
public:
DigitalDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalDefinition
GSF.PhasorProtocols.Macrodyne.DigitalDefinition = function(info, context);
protected:
DigitalDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework DigitalDefinition Constructor (ConfigurationCell, String)
Creates a new DigitalDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> DigitalDefinition
GSF.PhasorProtocols.Macrodyne.DigitalDefinition = function(parent, label);
public:
DigitalDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneConfigurationCell
The ConfigurationCell parent of this DigitalDefinition.
label
Type: SystemString
The label of this DigitalDefinition.
See Also

Reference

DigitalDefinition Class
DigitalDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition Methods

Grid Solutions Framework DigitalDefinition Methods

The DigitalDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition Properties

Grid Solutions Framework DigitalDefinition Properties

The DigitalDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this DigitalDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this DigitalDefinitionBase. (Inherited from DigitalDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalDefinition.Parent Property

Grid Solutions Framework DigitalDefinitionParent Property
Gets or sets the ConfigurationCell parent of this DigitalDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DigitalDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue Class

Grid Solutions Framework DigitalValue Class
Represents the Macrodyne implementation of an IDigitalValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IDigitalDefinition
GSF.PhasorProtocolsDigitalValueBase
GSF.PhasorProtocols.MacrodyneDigitalValue

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DigitalValue : DigitalValueBase
<SerializableAttribute>
Public Class DigitalValue
    Inherits DigitalValueBase
[<SerializableAttribute>]
type DigitalValue =
    class
        inherit DigitalValueBase
    end
GSF.PhasorProtocols.Macrodyne.DigitalValue = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.DigitalValue',
    GSF.PhasorProtocols.DigitalValueBase);
[SerializableAttribute]
public ref class DigitalValue : public DigitalValueBase

The DigitalValue type exposes the following members.

Constructors
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue Constructor

Grid Solutions Framework DigitalValue Constructor
Overload List
 | Name | Description
Protected method | DigitalValue(SerializationInfo, StreamingContext) | Creates a new DigitalValue from serialization parameters.
Public method | DigitalValue(IDataCell, IDigitalDefinition) | Creates a new DigitalValue.
Public method | DigitalValue(DataCell, DigitalDefinition, UInt16) | Creates a new DigitalValue from specified parameters.
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DigitalValue Constructor (SerializationInfo, StreamingContext)
Creates a new DigitalValue from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DigitalValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DigitalValue
GSF.PhasorProtocols.Macrodyne.DigitalValue = function(info, context);
protected:
DigitalValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue Constructor (IDataCell, IDigitalDefinition)

Grid Solutions Framework DigitalValue Constructor (IDataCell, IDigitalDefinition)
Creates a new DigitalValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    IDataCell parent,
    IDigitalDefinition digitalDefinition
)
Public Sub New (
    parent As IDataCell,
    digitalDefinition As IDigitalDefinition
)
new :
        parent : IDataCell *
        digitalDefinition : IDigitalDefinition -> DigitalValue
GSF.PhasorProtocols.Macrodyne.DigitalValue = function(parent, digitalDefinition);
public:
DigitalValue(
    IDataCell^ parent,
    IDigitalDefinition^ digitalDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocolsIDigitalDefinition
The IDigitalDefinition associated with this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)

Grid Solutions Framework DigitalValue Constructor (DataCell, DigitalDefinition, UInt16)
Creates a new DigitalValue from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DigitalValue(
    DataCell parent,
    DigitalDefinition digitalDefinition,
    ushort value
)
Public Sub New (
    parent As DataCell,
    digitalDefinition As DigitalDefinition,
    value As UShort
)
new :
        parent : DataCell *
        digitalDefinition : DigitalDefinition *
        value : uint16 -> DigitalValue
GSF.PhasorProtocols.Macrodyne.DigitalValue = function(parent, digitalDefinition, value);
public:
DigitalValue(
    DataCell^ parent,
    DigitalDefinition^ digitalDefinition,
    unsigned short value
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneDataCell
The DataCell parent of this DigitalValue.
digitalDefinition
Type: GSF.PhasorProtocols.MacrodyneDigitalDefinition
The DigitalDefinition associated with this DigitalValue.
value
Type: SystemUInt16
The unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValue.
See Also

Reference

DigitalValue Class
DigitalValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue Methods

Grid Solutions Framework DigitalValue Methods

The DigitalValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this DigitalValueBase. (Inherited from DigitalValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from DigitalValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DigitalValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from DigitalValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue Properties

Grid Solutions Framework DigitalValue Properties

The DigitalValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DigitalValueBase object. (Inherited from DigitalValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DigitalValueBase object. (Inherited from DigitalValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DigitalValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this DigitalValueBase provides. (Inherited from DigitalValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the DigitalDefinition associated with this DigitalValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of DigitalValueBase have been assigned a value. (Inherited from DigitalValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this DigitalValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Value | Gets or sets the unsigned 16-bit integer value (composed of digital bits) that represents this DigitalValueBase. (Inherited from DigitalValueBase.)
Top
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue.Definition Property

Grid Solutions Framework DigitalValueDefinition Property
Gets or sets the DigitalDefinition associated with this DigitalValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DigitalDefinition Definition { get; set; }
Public Overridable Property Definition As DigitalDefinition
    Get
    Set
abstract Definition : DigitalDefinition with get, set
override Definition : DigitalDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property DigitalDefinition^ Definition {
    DigitalDefinition^ get ();
    void set (DigitalDefinition^ value);
}

Property Value

Type: DigitalDefinition
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.Macrodyne Namespace


DigitalValue.Parent Property

Grid Solutions Framework DigitalValueParent Property
Gets or sets the DataCell parent of this DigitalValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

DigitalValue Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser Class

Grid Solutions Framework FrameParser Class
Represents a frame parser for a Macrodyne binary data stream that returns parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, FrameType, ISupportSourceIdentifiableFrameImage SourceChannel, FrameType
GSF.PhasorProtocolsFrameParserBase FrameType
GSF.PhasorProtocols.MacrodyneFrameParser

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameParser : FrameParserBase<FrameType>
Public Class FrameParser
    Inherits FrameParserBase(Of FrameType)
type FrameParser =
    class
        inherit FrameParserBase<FrameType>
    end
GSF.PhasorProtocols.Macrodyne.FrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.FrameParser',
    GSF.PhasorProtocols.FrameParserBase`1);
public ref class FrameParser : public FrameParserBase<FrameType>

The FrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | FrameParser | Creates a new FrameParser from specified parameters.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBaseTFrameIdentifierDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Overrides BinaryImageParserBaseOnParsingException(Exception).)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedHeaderFrame(IHeaderFrame).)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(SourceChannel, Byte, Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse(TSourceIdentifier, Byte, Int32, Int32).)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFileName | Gets or sets external Macrodyne based configuration file.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | DeviceLabel | Gets or sets device section label, as defined in associated INI file.
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if Macrodyne protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a Macrodyne ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a Macrodyne DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a Macrodyne HeaderFrame that contains the UnitID (i.e., station name) has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


FrameParser Constructor

Grid Solutions Framework FrameParser Constructor
Creates a new FrameParser from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    bool trustHeaderLength = true,
    ProtocolVersion protocolVersion = ProtocolVersion.M,
    string configurationFileName = null,
    string deviceLabel = null
)
Public Sub New (
    Optional checkSumValidationFrameTypes As CheckSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    Optional trustHeaderLength As Boolean = true,
    Optional protocolVersion As ProtocolVersion = ProtocolVersion.M,
    Optional configurationFileName As String = Nothing,
    Optional deviceLabel As String = Nothing
)
new :
        ?checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        ?trustHeaderLength : bool *
        ?protocolVersion : ProtocolVersion *
        ?configurationFileName : string *
        ?deviceLabel : string
(* Defaults:
        let _checkSumValidationFrameTypes = defaultArg checkSumValidationFrameTypes CheckSumValidationFrameTypes.AllFrames
        let _trustHeaderLength = defaultArg trustHeaderLength true
        let _protocolVersion = defaultArg protocolVersion ProtocolVersion.M
        let _configurationFileName = defaultArg configurationFileName null
        let _deviceLabel = defaultArg deviceLabel null
*)
-> FrameParser
GSF.PhasorProtocols.Macrodyne.FrameParser = function(checkSumValidationFrameTypes, trustHeaderLength, protocolVersion, configurationFileName, deviceLabel);
public:
FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes::AllFrames,
    bool trustHeaderLength = true,
    ProtocolVersion protocolVersion = ProtocolVersion::M,
    String^ configurationFileName = nullptr,
    String^ deviceLabel = nullptr
)

Parameters

checkSumValidationFrameTypes (Optional)
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength (Optional)
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
protocolVersion (Optional)
Type: GSF.PhasorProtocols.MacrodyneProtocolVersion
The protocol version that the parser should use.
configurationFileName (Optional)
Type: SystemString
The optional external Macrodyne configuration in BPA PDCstream INI file based format.
deviceLabel (Optional)
Type: SystemString
The INI section device label to use.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser Fields

Grid Solutions Framework FrameParser Fields

The FrameParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser Methods

Grid Solutions Framework FrameParser Methods

The FrameParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBaseTFrameIdentifierDispose(Boolean).)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Overrides BinaryImageParserBaseOnParsingException(Exception).)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedConfigurationFrame(IConfigurationFrame).)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Overrides FrameParserBaseTFrameIdentifierOnReceivedHeaderFrame(IHeaderFrame).)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(SourceChannel, Byte, Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse(TSourceIdentifier, Byte, Int32, Int32).)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.Dispose Method

Grid Solutions Framework FrameParserDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources. (Overrides FrameParserBaseTFrameIdentifierDispose(Boolean).)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.Dispose Method (Boolean)

Grid Solutions Framework FrameParserDispose Method (Boolean)
Releases the unmanaged resources used by the FrameParser object and optionally releases the managed resources.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

FrameParser Class
Dispose Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.OnParsingException Method

Grid Solutions Framework FrameParserOnParsingException Method
Raises the ParsingException event.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnParsingException(
    Exception ex
)
Protected Overrides Sub OnParsingException (
    ex As Exception
)
abstract OnParsingException :
        ex : Exception -> unit
override OnParsingException :
        ex : Exception -> unit
function OnParsingException(ex);
protected:
virtual void OnParsingException(
    Exception^ ex
) override

Parameters

ex
Type: SystemException
The Exception that was encountered during parsing.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.OnReceivedConfigurationFrame Method

Grid Solutions Framework FrameParserOnReceivedConfigurationFrame Method
Raises the ReceivedConfigurationFrame event.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedConfigurationFrame(
    IConfigurationFrame frame
)
Protected Overrides Sub OnReceivedConfigurationFrame (
    frame As IConfigurationFrame
)
abstract OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
override OnReceivedConfigurationFrame :
        frame : IConfigurationFrame -> unit
function OnReceivedConfigurationFrame(frame);
protected:
virtual void OnReceivedConfigurationFrame(
    IConfigurationFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIConfigurationFrame
IConfigurationFrame to send to ReceivedConfigurationFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.OnReceivedHeaderFrame Method

Grid Solutions Framework FrameParserOnReceivedHeaderFrame Method
Raises the ReceivedHeaderFrame event.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedHeaderFrame(
    IHeaderFrame frame
)
Protected Overrides Sub OnReceivedHeaderFrame (
    frame As IHeaderFrame
)
abstract OnReceivedHeaderFrame :
        frame : IHeaderFrame -> unit
override OnReceivedHeaderFrame :
        frame : IHeaderFrame -> unit
function OnReceivedHeaderFrame(frame);
protected:
virtual void OnReceivedHeaderFrame(
    IHeaderFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIHeaderFrame
IHeaderFrame to send to ReceivedHeaderFrame event.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.Parse Method

Grid Solutions Framework FrameParserParse Method
Overload List
 | Name | Description
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(SourceChannel, Byte, Int32, Int32) | Writes a sequence of bytes onto the stream for parsing. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse(TSourceIdentifier, Byte, Int32, Int32).)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.Parse Method (SourceChannel, Byte[], Int32, Int32)

Grid Solutions Framework FrameParserParse Method (SourceChannel, Byte, Int32, Int32)
Writes a sequence of bytes onto the stream for parsing.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Parse(
    SourceChannel source,
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Parse (
    source As SourceChannel,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Parse :
        source : SourceChannel *
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Parse :
        source : SourceChannel *
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Parse(source, buffer, offset, count);
public:
virtual void Parse(
    SourceChannel source,
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

source
Type: GSF.PhasorProtocolsSourceChannel
Defines the source channel for the data.
buffer
Type: SystemByte
An array of bytes. This method copies count bytes from buffer to the current stream.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: SystemInt32
The number of bytes to be written to the current stream.
See Also

Reference

FrameParser Class
Parse Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ParseCommonHeader Method

Grid Solutions Framework FrameParserParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<FrameType> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of FrameType)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<FrameType>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<FrameType>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader FrameType
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Start the data parser.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

FrameParser Class
Start Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser Properties

Grid Solutions Framework FrameParser Properties

The FrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFileName | Gets or sets external Macrodyne based configuration file.
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | DeviceLabel | Gets or sets device section label, as defined in associated INI file.
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if Macrodyne protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RefreshConfigurationFileOnChange | Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ConfigurationFileName Property

Grid Solutions Framework FrameParserConfigurationFileName Property
Gets or sets external Macrodyne based configuration file.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConfigurationFileName { get; set; }
Public Property ConfigurationFileName As String
    Get
    Set
member ConfigurationFileName : string with get, set

function get_ConfigurationFileName();
function set_ConfigurationFileName(value);
public:
property String^ ConfigurationFileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ConfigurationFrame Property

Grid Solutions Framework FrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ConnectionParameters Property

Grid Solutions Framework FrameParserConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set
override ConnectionParameters : IConnectionParameters with get, set
function get_ConnectionParameters();
function set_ConnectionParameters(value);
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}

Property Value

Type: IConnectionParameters

Implements

IFrameParserConnectionParameters
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.DeviceLabel Property

Grid Solutions Framework FrameParserDeviceLabel Property
Gets or sets device section label, as defined in associated INI file.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DeviceLabel { get; set; }
Public Property DeviceLabel As String
    Get
    Set
member DeviceLabel : string with get, set

function get_DeviceLabel();
function set_DeviceLabel(value);
public:
property String^ DeviceLabel {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework FrameParserProtocolUsesSyncBytes Property
Gets flag that determines if Macrodyne protocol parsing implementation uses synchronization bytes.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.RefreshConfigurationFileOnChange Property

Grid Solutions Framework FrameParserRefreshConfigurationFileOnChange Property
Gets or sets flag that determines if configuration file is automatically reloaded when it has changed on disk.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RefreshConfigurationFileOnChange { get; set; }
Public Property RefreshConfigurationFileOnChange As Boolean
    Get
    Set
member RefreshConfigurationFileOnChange : bool with get, set

function get_RefreshConfigurationFileOnChange();
function set_RefreshConfigurationFileOnChange(value);
public:
property bool RefreshConfigurationFileOnChange {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.Status Property

Grid Solutions Framework FrameParserStatus Property
Gets current descriptive status of the FrameParser.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser Events

Grid Solutions Framework FrameParser Events

The FrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a Macrodyne ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a Macrodyne DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a Macrodyne HeaderFrame that contains the UnitID (i.e., station name) has been received.
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame Event
Occurs when a Macrodyne ConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
member ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<ConfigurationFrame>>,
    EventArgs<ConfigurationFrame>>

function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame
Remarks
Argument is the ConfigurationFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ReceivedDataFrame Event

Grid Solutions Framework FrameParserReceivedDataFrame Event
Occurs when a Macrodyne DataFrame has been received.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
member ReceivedDataFrame : IEvent<EventHandler<EventArgs<DataFrame>>,
    EventArgs<DataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataFrame
Remarks
Argument is the DataFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameParser.ReceivedHeaderFrame Event

Grid Solutions Framework FrameParserReceivedHeaderFrame Event
Occurs when a Macrodyne HeaderFrame that contains the UnitID (i.e., station name) has been received.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<HeaderFrame>> ReceivedHeaderFrame
Public Event ReceivedHeaderFrame As EventHandler(Of EventArgs(Of HeaderFrame))
member ReceivedHeaderFrame : IEvent<EventHandler<EventArgs<HeaderFrame>>,
    EventArgs<HeaderFrame>>

function add_ReceivedHeaderFrame(value);
function remove_ReceivedHeaderFrame(value);
public:
 event EventHandler<EventArgs<HeaderFrame^>^>^ ReceivedHeaderFrame {
    void add (EventHandler<EventArgs<HeaderFrame^>^>^ value);
    void remove (EventHandler<EventArgs<HeaderFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs HeaderFrame
Remarks
Argument is the HeaderFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.Macrodyne Namespace


FrameType Enumeration

Grid Solutions Framework FrameType Enumeration
Macrodyne frame types enumeration.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FrameType
<SerializableAttribute>
Public Enumeration FrameType
[<SerializableAttribute>]
type FrameType
GSF.PhasorProtocols.Macrodyne.FrameType = function();
GSF.PhasorProtocols.Macrodyne.FrameType.createEnum('GSF.PhasorProtocols.Macrodyne.FrameType', false);
[SerializableAttribute]
public enum class FrameType
Members
Member name | Value | Description
DataFrame | 0 | Data frame.
ConfigurationFrame | 1 | Configuration frame.
HeaderFrame | 2 | Header frame.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents the Macrodyne implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.MacrodyneFrequencyDefinition

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.Macrodyne.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from the specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this FrequencyDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinition. (Overrides FrequencyDefinitionBaseOffset.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from the specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinition Constructor (IConfigurationCell)
Creates a new FrequencyDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinition
GSF.PhasorProtocols.Macrodyne.FrequencyDefinition = function(parent);
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.Macrodyne.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from the specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string entryValue
)
Public Sub New (
    parent As ConfigurationCell,
    entryValue As String
)
new :
        parent : ConfigurationCell *
        entryValue : string -> FrequencyDefinition
GSF.PhasorProtocols.Macrodyne.FrequencyDefinition = function(parent, entryValue);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ entryValue
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
entryValue
Type: SystemString
The entry value from the INI based configuration file.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this FrequencyDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinition. (Overrides FrequencyDefinitionBaseOffset.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition.MaximumLabelLength Property

Grid Solutions Framework FrequencyDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition.Offset Property

Grid Solutions Framework FrequencyDefinitionOffset Property
Gets or sets the offset of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override double Offset { get; set; }
Public Overrides Property Offset As Double
    Get
    Set
abstract Offset : float with get, set
override Offset : float with get, set
function get_Offset();
function set_Offset(value);
public:
virtual property double Offset {
    double get () override;
    void set (double value) override;
}

Property Value

Type: Double

Implements

IChannelDefinitionOffset
IChannelDefinitionOffset
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue Class

Grid Solutions Framework FrequencyValue Class
Represents the Macrodyne implementation of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.MacrodyneFrequencyValue

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute>
Public Class FrequencyValue
    Inherits FrequencyValueBase
[<SerializableAttribute>]
type FrequencyValue =
    class
        inherit FrequencyValueBase
    end
GSF.PhasorProtocols.Macrodyne.FrequencyValue = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.FrequencyValue',
    GSF.PhasorProtocols.FrequencyValueBase);
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase

The FrequencyValue type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue Constructor

Grid Solutions Framework FrequencyValue Constructor
Overload List
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValue Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValue
GSF.PhasorProtocols.Macrodyne.FrequencyValue = function(info, context);
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValue Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValue
GSF.PhasorProtocols.Macrodyne.FrequencyValue = function(parent, frequencyDefinition);
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValue.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New (
    parent As DataCell,
    frequencyDefinition As FrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : DataCell *
        frequencyDefinition : FrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValue
GSF.PhasorProtocols.Macrodyne.FrequencyValue = function(parent, frequencyDefinition, frequency, dfdt);
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneDataCell
The DataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocols.MacrodyneFrequencyDefinition
The FrequencyDefinition associated with this FrequencyValue.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValue.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValue over time.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue Methods

Grid Solutions Framework FrequencyValue Methods

The FrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue.ParseBodyImage Method

Grid Solutions Framework FrequencyValueParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue Properties

Grid Solutions Framework FrequencyValue Properties

The FrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from FrequencyValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue.Definition Property

Grid Solutions Framework FrequencyValueDefinition Property
Gets or sets the FrequencyDefinition associated with this FrequencyValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
abstract Definition : FrequencyDefinition with get, set
override Definition : FrequencyDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}

Property Value

Type: FrequencyDefinition
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.Macrodyne Namespace


FrequencyValue.Parent Property

Grid Solutions Framework FrequencyValueParent Property
Gets or sets the DataCell parent of this FrequencyValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.Macrodyne Namespace


GpsStatus Enumeration

Grid Solutions Framework GpsStatus Enumeration
Macrodyne GPS status enumeration (from Status 2 byte, bits 3-4).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum GpsStatus
<SerializableAttribute>
Public Enumeration GpsStatus
[<SerializableAttribute>]
type GpsStatus
GSF.PhasorProtocols.Macrodyne.GpsStatus = function();
GSF.PhasorProtocols.Macrodyne.GpsStatus.createEnum('GSF.PhasorProtocols.Macrodyne.GpsStatus', false);
[SerializableAttribute]
public enum class GpsStatus
Members
Member name | Value | Description
StatusIsGood | 0 | 00 - GPS clock status is good.
NoStatus1 | 8 | 01 - None (undefined state 1).
NoStatus2 | 16 | 10 - None (undefined state 2).
StatusIsBad | 24 | 11 - GPS clock status is bad.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame Class

Grid Solutions Framework HeaderFrame Class
Represents the Macrodyne implementation of a IHeaderFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IHeaderCell
GSF.PhasorProtocolsHeaderFrameBase
GSF.PhasorProtocols.MacrodyneHeaderFrame

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class HeaderFrame : HeaderFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage
<SerializableAttribute>
Public Class HeaderFrame
    Inherits HeaderFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, FrameType),
    ISupportFrameImage(Of FrameType), ISupportBinaryImage
[<SerializableAttribute>]
type HeaderFrame =
    class
        inherit HeaderFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>
        interface ISupportFrameImage<FrameType>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.Macrodyne.HeaderFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.HeaderFrame',
    GSF.PhasorProtocols.HeaderFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class HeaderFrame : public HeaderFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, FrameType>, ISupportFrameImage<FrameType>,
    ISupportBinaryImage

The HeaderFrame type exposes the following members.

Constructors
 | Name | Description
Public method | HeaderFrame | Creates a new HeaderFrame.
Public method | HeaderFrame(String) | Creates a new HeaderFrame.
Protected method | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelFrameBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrameBase object. (Inherited from HeaderFrameBase.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the HeaderFrame. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame Constructor

Grid Solutions Framework HeaderFrame Constructor
Overload List
 | Name | Description
Public method | HeaderFrame | Creates a new HeaderFrame.
Public method | HeaderFrame(String) | Creates a new HeaderFrame.
Protected method | HeaderFrame(SerializationInfo, StreamingContext) | Creates a new HeaderFrame from serialization parameters.
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame Constructor

Grid Solutions Framework HeaderFrame Constructor
Creates a new HeaderFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderFrame()
Public Sub New
new : unit -> HeaderFrame
GSF.PhasorProtocols.Macrodyne.HeaderFrame = function();
public:
HeaderFrame()
Remarks
This constructor is used by a consumer or by FrameImageParserBaseTTypeIdentifier, TOutputType to generate or parse a Macrodyne header frame.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame Constructor (String)

Grid Solutions Framework HeaderFrame Constructor (String)
Creates a new HeaderFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public HeaderFrame(
    string headerData
)
Public Sub New (
    headerData As String
)
new :
        headerData : string -> HeaderFrame
GSF.PhasorProtocols.Macrodyne.HeaderFrame = function(headerData);
public:
HeaderFrame(
    String^ headerData
)

Parameters

headerData
Type: SystemString
String based data to include in this HeaderFrame.
Remarks
This constructor is used by a consumer to generate a Macrodyne header frame.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework HeaderFrame Constructor (SerializationInfo, StreamingContext)
Creates a new HeaderFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HeaderFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> HeaderFrame
GSF.PhasorProtocols.Macrodyne.HeaderFrame = function(info, context);
protected:
HeaderFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

HeaderFrame Class
HeaderFrame Overload
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame Methods

Grid Solutions Framework HeaderFrame Methods

The HeaderFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Overrides ChannelFrameBaseTAppendChecksum(Byte, Int32).)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelFrameBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.AppendChecksum Method

Grid Solutions Framework HeaderFrameAppendChecksum Method
Appends checksum onto buffer starting at startIndex.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void AppendChecksum(
    byte[] buffer,
    int startIndex
)
Protected Overrides Sub AppendChecksum (
    buffer As Byte(),
    startIndex As Integer
)
abstract AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
override AppendChecksum :
        buffer : byte[] *
        startIndex : int -> unit
function AppendChecksum(buffer, startIndex);
protected:
virtual void AppendChecksum(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image on which to append checksum.
startIndex
Type: SystemInt32
Index into buffer where checksum should be appended.
Remarks
Default implementation encodes checksum in big-endian order and expects buffer size large enough to accomodate 2-byte checksum representation. We override this method since checksum in Macrodyne is a single byte.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.CalculateChecksum Method

Grid Solutions Framework HeaderFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.ChecksumIsValid Method

Grid Solutions Framework HeaderFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
Default implementation expects 2-byte big-endian ordered checksum. So we override method since checksum in Macrodyne is a single byte.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.ParseHeaderImage Method

Grid Solutions Framework HeaderFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame Properties

Grid Solutions Framework HeaderFrame Properties

The HeaderFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the HeaderFrameBase object. (Inherited from HeaderFrameBase.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the HeaderFrame. (Overrides ChannelFrameBaseTBinaryLength.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the HeaderCellCollection for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameType | Gets the FundamentalFrameType for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | HeaderData | Gets or sets header data for this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this HeaderFrameBase. (Inherited from HeaderFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the Macrodyne frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.BinaryLength Property

Grid Solutions Framework HeaderFrameBinaryLength Property
Gets the length of the HeaderFrame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int BinaryLength { get; }
Public Overrides ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () override;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
ISupportBinaryImageBinaryLength
Remarks
This property is overridden so the length can be extended to include a 1-byte checksum.
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.CommonHeader Property

Grid Solutions Framework HeaderFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.HeaderImage Property

Grid Solutions Framework HeaderFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.HeaderLength Property

Grid Solutions Framework HeaderFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


HeaderFrame.TypeID Property

Grid Solutions Framework HeaderFrameTypeID Property
Gets the identifier that is used to identify the Macrodyne frame.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameType TypeID { get; }
Public ReadOnly Property TypeID As FrameType
    Get
abstract TypeID : FrameType with get
override TypeID : FrameType with get
function get_TypeID();

public:
virtual property FrameType TypeID {
    FrameType get () sealed;
}

Property Value

Type: FrameType

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

HeaderFrame Class
GSF.PhasorProtocols.Macrodyne Namespace


IniFileNameEditor Class

Grid Solutions Framework IniFileNameEditor Class
INI file name browser used with Macrodyne ConnectionParameters.
Inheritance Hierarchy
SystemObject
System.Drawing.DesignUITypeEditor
System.Windows.Forms.DesignFileNameEditor
GSF.PhasorProtocols.MacrodyneIniFileNameEditor

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IniFileNameEditor : FileNameEditor
Public Class IniFileNameEditor
    Inherits FileNameEditor
type IniFileNameEditor =
    class
        inherit FileNameEditor
    end
GSF.PhasorProtocols.Macrodyne.IniFileNameEditor = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.IniFileNameEditor',
    FileNameEditor);
public ref class IniFileNameEditor : public FileNameEditor

The IniFileNameEditor type exposes the following members.

Constructors
 | Name | Description
Public method | IniFileNameEditor | Initializes a new instance of the IniFileNameEditor class
Top
Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object using the editor style provided by the GetEditStyle(ITypeDescriptorContext) method. (Inherited from FileNameEditor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editing style used by the EditValue(ITypeDescriptorContext, IServiceProvider, Object) method. (Inherited from FileNameEditor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeDialog | Initializes the open file dialog when it is created. (Overrides FileNameEditorInitializeDialog(OpenFileDialog).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


IniFileNameEditor Constructor

Grid Solutions Framework IniFileNameEditor Constructor
Initializes a new instance of the IniFileNameEditor class

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IniFileNameEditor()
Public Sub New
new : unit -> IniFileNameEditor
GSF.PhasorProtocols.Macrodyne.IniFileNameEditor = function();
public:
IniFileNameEditor()
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.Macrodyne Namespace


IniFileNameEditor Methods

Grid Solutions Framework IniFileNameEditor Methods

The IniFileNameEditor type exposes the following members.

Methods
 | Name | Description
Public method | EditValue(IServiceProvider, Object) | Edits the value of the specified object using the editor style indicated by the GetEditStyle method. (Inherited from UITypeEditor.)
Public method | EditValue(ITypeDescriptorContext, IServiceProvider, Object) | Edits the specified object using the editor style provided by the GetEditStyle(ITypeDescriptorContext) method. (Inherited from FileNameEditor.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEditStyle | Gets the editor style used by the EditValue(IServiceProvider, Object) method. (Inherited from UITypeEditor.)
Public method | GetEditStyle(ITypeDescriptorContext) | Gets the editing style used by the EditValue(ITypeDescriptorContext, IServiceProvider, Object) method. (Inherited from FileNameEditor.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPaintValueSupported | Indicates whether this editor supports painting a representation of an object's value. (Inherited from UITypeEditor.)
Public method | GetPaintValueSupported(ITypeDescriptorContext) | Indicates whether the specified context supports painting a representation of an object's value within the specified context. (Inherited from UITypeEditor.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | InitializeDialog | Initializes the open file dialog when it is created. (Overrides FileNameEditorInitializeDialog(OpenFileDialog).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | PaintValue(PaintValueEventArgs) | Paints a representation of the value of an object using the specified PaintValueEventArgs. (Inherited from UITypeEditor.)
Public method | PaintValue(Object, Graphics, Rectangle) | Paints a representation of the value of the specified object to the specified canvas. (Inherited from UITypeEditor.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.Macrodyne Namespace


IniFileNameEditor.InitializeDialog Method

Grid Solutions Framework IniFileNameEditorInitializeDialog Method
Initializes the open file dialog when it is created.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InitializeDialog(
    OpenFileDialog openFileDialog
)
Protected Overrides Sub InitializeDialog (
    openFileDialog As OpenFileDialog
)
abstract InitializeDialog :
        openFileDialog : OpenFileDialog -> unit
override InitializeDialog :
        openFileDialog : OpenFileDialog -> unit
function InitializeDialog(openFileDialog);
protected:
virtual void InitializeDialog(
    OpenFileDialog^ openFileDialog
) override

Parameters

openFileDialog
Type: System.Windows.FormsOpenFileDialog
The OpenFileDialog to use to select a file name.
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.Macrodyne Namespace


IniFileNameEditor Properties

Grid Solutions Framework IniFileNameEditor Properties

The IniFileNameEditor type exposes the following members.

Properties
 | Name | Description
Public property | IsDropDownResizable | Gets a value indicating whether drop-down editors should be resizable by the user. (Inherited from UITypeEditor.)
Top
See Also

Reference

IniFileNameEditor Class
GSF.PhasorProtocols.Macrodyne Namespace


OnlineDataFormatFlags Enumeration

Grid Solutions Framework OnlineDataFormatFlags Enumeration
Macrodyne ON-LINE data format flags enumeration (from RequestOnlineDataFormat 2 byte response).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum OnlineDataFormatFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration OnlineDataFormatFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type OnlineDataFormatFlags
GSF.PhasorProtocols.Macrodyne.OnlineDataFormatFlags = function();
GSF.PhasorProtocols.Macrodyne.OnlineDataFormatFlags.createEnum('GSF.PhasorProtocols.Macrodyne.OnlineDataFormatFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class OnlineDataFormatFlags
Members
Member name | Value | Description
Status2ByteEnabled | 1 | Status 2 enabled.
TimestampEnabled | 2 | Timestamp enabled.
Phasor2Enabled | 4 | Phasor 2 enabled.
Phasor3Enabled | 8 | Phasor 3 enabled.
Phasor4Enabled | 16 | Phasor 4 enabled.
Phasor5Enabled | 32 | Phasor 5 enabled.
ReferenceEnabled | 64 | Reference enabled.
Digital1Enabled | 128 | Digital channel 1 enabled.
Phasor6Enabled | 256 | Phasor 6 enabled.
Phasor7Enabled | 512 | Phasor 7 enabled.
Phasor8Enabled | 1024 | Phasor 8 enabled.
Phasor9Enabled | 2048 | Phasor 9 enabled.
Phasor10Enabled | 4096 | Phasor 10 enabled.
Digital2Enabled | 8192 | Digital channel 2 enabled.
NotUsed1 | 16384 | Bit not used (undefined bit 1).
NotUsed2 | 32768 | Bit not used (undefined bit 2).
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


OperationalLimitFlags Enumeration

Grid Solutions Framework OperationalLimitFlags Enumeration
Macrodyne operational limit reached flags enumeration (from RequestOperationalLimitFlags first byte of 3 byte response).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum OperationalLimitFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration OperationalLimitFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type OperationalLimitFlags
GSF.PhasorProtocols.Macrodyne.OperationalLimitFlags = function();
GSF.PhasorProtocols.Macrodyne.OperationalLimitFlags.createEnum('GSF.PhasorProtocols.Macrodyne.OperationalLimitFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class OperationalLimitFlags
Members
Member name | Value | Description
VMinLimitReached | 1 | VMIN operations limit reached.
VMaxLimitReached | 2 | VMAX operations limit reached.
AngdLimitReached | 4 | ANGD operations limit reached.
FreqLimitReached | 8 | FREQ operations limit reached.
DtDtLimitReached | 16 | DFDT operations limit reached.
LncmLimitReached | 32 | LNCM operations limit reached.
NotUsed1 | 64 | Bit not used (undefined bit 1).
NotUsed2 | 128 | Bit not used (undefined bit 2).
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents the Macrodyne implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.MacrodynePhasorDefinition

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.Macrodyne.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, Int32, String) | Creates a new PhasorDefinition from specified parameters.
Public method | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhasorDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinition object. (Overrides PhasorDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | CalFactor | Gets or sets calibration factor of this PhasorDefinition.
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Overrides ChannelDefinitionBaseConversionFactor.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this PhasorDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Ratio | Gets or sets ratio of this PhasorDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Shunt | Gets or sets shunt value of this PhasorDefinition.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Public property | VoltageReferenceIndex | Gets or sets voltage reference index of this PhasorDefinition.
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, Int32, String) | Creates a new PhasorDefinition from specified parameters.
Public method | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinition Constructor (IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinition
GSF.PhasorProtocols.Macrodyne.PhasorDefinition = function(parent);
public:
PhasorDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinition.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.Macrodyne.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Constructor (ConfigurationCell, Int32, String)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, Int32, String)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    int index,
    string entryValue
)
Public Sub New (
    parent As ConfigurationCell,
    index As Integer,
    entryValue As String
)
new :
        parent : ConfigurationCell *
        index : int *
        entryValue : string -> PhasorDefinition
GSF.PhasorProtocols.Macrodyne.PhasorDefinition = function(parent, index, entryValue);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    int index,
    String^ entryValue
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
index
Type: SystemInt32
Index of phasor within INI based configuration file.
entryValue
Type: SystemString
The entry value from the INI based configuration file.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Constructor (ConfigurationCell, String, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.Macrodyne.PhasorDefinition = function(parent, label, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.MacrodynePhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides PhasorDefinitionBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.GetObjectData Method

Grid Solutions Framework PhasorDefinitionGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinition object. (Overrides PhasorDefinitionBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | CalFactor | Gets or sets calibration factor of this PhasorDefinition.
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Overrides ChannelDefinitionBaseConversionFactor.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this PhasorDefinition. (Overrides ChannelDefinitionBaseMaximumLabelLength.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Ratio | Gets or sets ratio of this PhasorDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Shunt | Gets or sets shunt value of this PhasorDefinition.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Public property | VoltageReferenceIndex | Gets or sets voltage reference index of this PhasorDefinition.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.Attributes Property

Grid Solutions Framework PhasorDefinitionAttributes Property
Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinition object.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.CalFactor Property

Grid Solutions Framework PhasorDefinitionCalFactor Property
Gets or sets calibration factor of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalFactor { get; set; }
Public Property CalFactor As Double
    Get
    Set
member CalFactor : float with get, set

function get_CalFactor();
function set_CalFactor(value);
public:
property double CalFactor {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.ConversionFactor Property

Grid Solutions Framework PhasorDefinitionConversionFactor Property
Gets or sets the conversion factor of this ChannelDefinitionBase.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override double ConversionFactor { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property ConversionFactor As Double
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract ConversionFactor : float with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override ConversionFactor : float with get, set
function get_ConversionFactor();
function set_ConversionFactor(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property double ConversionFactor {
    double get () override;
    void set (double value) override;
}

Property Value

Type: Double

Implements

IChannelDefinitionConversionFactor
Remarks
This method is hidden from the consumer since Macrodyne uses a custom conversion factor. Property always returns 1.0, updates are ignored.
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.MaximumLabelLength Property

Grid Solutions Framework PhasorDefinitionMaximumLabelLength Property
Gets the maximum length of the Label of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumLabelLength { get; }
Public Overrides ReadOnly Property MaximumLabelLength As Integer
    Get
abstract MaximumLabelLength : int with get
override MaximumLabelLength : int with get
function get_MaximumLabelLength();

public:
virtual property int MaximumLabelLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IChannelDefinitionMaximumLabelLength
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.Ratio Property

Grid Solutions Framework PhasorDefinitionRatio Property
Gets or sets ratio of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Ratio { get; set; }
Public Property Ratio As Double
    Get
    Set
member Ratio : float with get, set

function get_Ratio();
function set_Ratio(value);
public:
property double Ratio {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.Shunt Property

Grid Solutions Framework PhasorDefinitionShunt Property
Gets or sets shunt value of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Shunt { get; set; }
Public Property Shunt As Double
    Get
    Set
member Shunt : float with get, set

function get_Shunt();
function set_Shunt(value);
public:
property double Shunt {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorDefinition.VoltageReferenceIndex Property

Grid Solutions Framework PhasorDefinitionVoltageReferenceIndex Property
Gets or sets voltage reference index of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int VoltageReferenceIndex { get; set; }
Public Property VoltageReferenceIndex As Integer
    Get
    Set
member VoltageReferenceIndex : int with get, set

function get_VoltageReferenceIndex();
function set_VoltageReferenceIndex(value);
public:
property int VoltageReferenceIndex {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Class

Grid Solutions Framework PhasorValue Class
Represents the Macrodyne implementation of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.MacrodynePhasorValue

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute>
Public Class PhasorValue
    Inherits PhasorValueBase
[<SerializableAttribute>]
type PhasorValue =
    class
        inherit PhasorValueBase
    end
GSF.PhasorProtocols.Macrodyne.PhasorValue = function();

Type.createClass(
    'GSF.PhasorProtocols.Macrodyne.PhasorValue',
    GSF.PhasorProtocols.PhasorValueBase);
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase

The PhasorValue type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Constructor

Grid Solutions Framework PhasorValue Constructor
Overload List
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValue Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValue
GSF.PhasorProtocols.Macrodyne.PhasorValue = function(info, context);
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValue Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValue
GSF.PhasorProtocols.Macrodyne.PhasorValue = function(parent, phasorDefinition);
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValue
GSF.PhasorProtocols.Macrodyne.PhasorValue = function(parent, phasorDefinition, angle, magnitude);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.MacrodynePhasorDefinition
The PhasorDefinition associated with this PhasorValue.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        real : float *
        imaginary : float -> PhasorValue
GSF.PhasorProtocols.Macrodyne.PhasorValue = function(parent, phasorDefinition, real, imaginary);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocols.MacrodyneDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.MacrodynePhasorDefinition
The PhasorDefinition associated with this PhasorValue.
real
Type: SystemDouble
The real value of this PhasorValue.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Methods

Grid Solutions Framework PhasorValue Methods

The PhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from PhasorValueBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue Properties

Grid Solutions Framework PhasorValue Properties

The PhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Inherited from PhasorValueBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from PhasorValueBase.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue.Definition Property

Grid Solutions Framework PhasorValueDefinition Property
Gets or sets the PhasorDefinition associated with this PhasorValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
abstract Definition : PhasorDefinition with get, set
override Definition : PhasorDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}

Property Value

Type: PhasorDefinition
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.Macrodyne Namespace


PhasorValue.Parent Property

Grid Solutions Framework PhasorValueParent Property
Gets or sets the DataCell parent of this PhasorValue.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.Macrodyne Namespace


ProtocolVersion Enumeration

Grid Solutions Framework ProtocolVersion Enumeration
Macrodyne protocol versions enumeration.

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum ProtocolVersion
<SerializableAttribute>
Public Enumeration ProtocolVersion
[<SerializableAttribute>]
type ProtocolVersion
GSF.PhasorProtocols.Macrodyne.ProtocolVersion = function();
GSF.PhasorProtocols.Macrodyne.ProtocolVersion.createEnum('GSF.PhasorProtocols.Macrodyne.ProtocolVersion', false);
[SerializableAttribute]
public enum class ProtocolVersion
Members
Member name | Value | Description
M | 0 | Macrodyne 1690M Protocol.
G | 1 | Macrodyne 1690G Protocol.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


StatusFlags Enumeration

Grid Solutions Framework StatusFlags Enumeration
Macrodyne status flags enumeration (from Status 1 byte).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum StatusFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration StatusFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type StatusFlags
GSF.PhasorProtocols.Macrodyne.StatusFlags = function();
GSF.PhasorProtocols.Macrodyne.StatusFlags.createEnum('GSF.PhasorProtocols.Macrodyne.StatusFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class StatusFlags
Members
Member name | Value | Description
TriggerDetected | 1 | TRG = 1 - Trigger detected, table being collected.
OperationalLimitReached | 2 | OP = 1 - Operational limit reached.
ResetOccurred | 4 | UR = 1 - Reset occurred.
TimeError | 8 | TTE = 1 - Error in GPS time or time tag.
ReferenceLost | 16 | RL = 1 - Reference expected but not received.
InputReferenceEnabled | 32 | RI = 1 - Unit enabled to receive reference.
OuputReferenceEnabled | 64 | RO = 1 - Unit set to output reference.
TriggerDetectedMemoryFull | 128 | Trigger detected, but memory full.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


TriggerReason Enumeration

Grid Solutions Framework TriggerReason Enumeration
Macrodyne trigger reason enumeration (from Status 2 byte, bits 0-2).

Namespace: GSF.PhasorProtocols.Macrodyne
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum TriggerReason
<SerializableAttribute>
Public Enumeration TriggerReason
[<SerializableAttribute>]
type TriggerReason
GSF.PhasorProtocols.Macrodyne.TriggerReason = function();
GSF.PhasorProtocols.Macrodyne.TriggerReason.createEnum('GSF.PhasorProtocols.Macrodyne.TriggerReason', false);
[SerializableAttribute]
public enum class TriggerReason
Members
Member name | Value | Description
DigitalChannelTrigger | 7 | 111 DCHN - Digital channel.
LinearCombinationTrigger | 6 | 110 LNCM - Linear combination.
DfDtTrigger | 5 | 101 DFDT - Change in frequency over time.
FrequencyTrigger | 4 | 100 FREQ - Maximum allowed offset from 60 Hz.
AngleDifferenceTrigger | 3 | 011 ANGD - Angle difference from reference.
MaximumMagnitudeTrigger | 2 | 010 VMAX - Maximum magnitude.
MinimumMagnitudeTrigger | 1 | 001 VMIN - Minimum magnitude.
UserDefined | 0 | 000 USER - Manual trigger.
See Also

Reference

GSF.PhasorProtocols.Macrodyne Namespace


GSF.PhasorProtocols.SelFastMessage Namespace

Grid Solutions Framework GSF.PhasorProtocols.SelFastMessage Namespace
Contains an implementation of the phasor classes used to parse or generate a stream of data in the SEL Fast Message format used by a variety of SEL devices.
Classes
 | Class | Description
Public class | CommandFrame | Represents the SEL Fast Message implementation of a ICommandFrame that can be sent or received.
Public class | Common | Common SEL Fast Message declarations and functions.
Public class | CommonFrameHeader | Represents the common header for all SEL Fast Message frames of data.
Public class | ConfigurationCell | Represents the SEL Fast Message implementation of a IConfigurationCell that can be sent or received.
Public class | ConfigurationCellCollection | Represents a SEL Fast Message implementation of a collection of IConfigurationCell objects.
Public class | ConfigurationFrame | Represents the SEL Fast Message implementation of a IConfigurationFrame that can be sent or received.
Public class | ConnectionParameters | Represents the extra connection parameters required for a connection to a SEL device.
Public class | DataCell | Represents the SEL Fast Message implementation of a IDataCell that can be sent or received.
Public class | DataCellCollection | Represents a SEL Fast Message implementation of a collection of IDataCell objects.
Public class | DataFrame | Represents the SEL Fast Message implementation of a IDataFrame that can be sent or received.
Public class | FrameParser | Represents a frame parser for a SEL Fast Message binary data stream that returns parsed data via events.
Public class | FrequencyDefinition | Represents the SEL Fast Message implementation of a IFrequencyDefinition.
Public class | FrequencyValue | Represents the SEL Fast Message implementation of a IFrequencyValue.
Public class | PhasorDefinition | Represents the SEL Fast Message implementation of a IPhasorDefinition.
Public class | PhasorValue | Represents the SEL Fast Message implementation of a IPhasorValue.
Enumerations
 | Enumeration | Description
Public enumeration | DeviceCommand | SEL Fast Message device commands enumeration.
Public enumeration | FrameSize | SEL Fast Message PMDATA setting frame size enumeration.
Public enumeration | MessagePeriod | SEL Fast Message frame rate enumeration.
Public enumeration | StatusFlags | SEL Fast Message status word flags enumeration.


CommandFrame Class

Grid Solutions Framework CommandFrame Class
Represents the SEL Fast Message implementation of a ICommandFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase ICommandCell
GSF.PhasorProtocolsCommandFrameBase
GSF.PhasorProtocols.SelFastMessageCommandFrame

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommandFrame : CommandFrameBase
<SerializableAttribute>
Public Class CommandFrame
    Inherits CommandFrameBase
[<SerializableAttribute>]
type CommandFrame =
    class
        inherit CommandFrameBase
    end
GSF.PhasorProtocols.SelFastMessage.CommandFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.CommandFrame',
    GSF.PhasorProtocols.CommandFrameBase);
[SerializableAttribute]
public ref class CommandFrame : public CommandFrameBase

The CommandFrame type exposes the following members.

Constructors
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(DeviceCommand, MessagePeriod) | Creates a new CommandFrame from specified parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrame. (Overrides CommandFrameBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides CommandFrameBaseBodyLength.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrame.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameSize | Gets frame size based on Command.
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | MessagePeriod | Gets or sets the desired message period for the SEL device.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
Remarks
SEL Fast Message command frames are designed only to be sent to a device, not received from a device. As a result this frame does not implement ISupportFrameImageTTypeIdentifier for automated frame parsing. This class exposes a constructor that accepts a binary image in order to manually parse a command frame.
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame Constructor

Grid Solutions Framework CommandFrame Constructor
Overload List
 | Name | Description
Protected method | CommandFrame(SerializationInfo, StreamingContext) | Creates a new CommandFrame from serialization parameters.
Public method | CommandFrame(DeviceCommand, MessagePeriod) | Creates a new CommandFrame from specified parameters.
Public method | CommandFrame(Byte, Int32, Int32) | Creates a new CommandFrame from the given buffer.
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommandFrame Constructor (SerializationInfo, StreamingContext)
Creates a new CommandFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommandFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommandFrame
GSF.PhasorProtocols.SelFastMessage.CommandFrame = function(info, context);
protected:
CommandFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame Constructor (DeviceCommand, MessagePeriod)

Grid Solutions Framework CommandFrame Constructor (DeviceCommand, MessagePeriod)
Creates a new CommandFrame from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    DeviceCommand command,
    MessagePeriod messagePeriod
)
Public Sub New (
    command As DeviceCommand,
    messagePeriod As MessagePeriod
)
new :
        command : DeviceCommand *
        messagePeriod : MessagePeriod -> CommandFrame
GSF.PhasorProtocols.SelFastMessage.CommandFrame = function(command, messagePeriod);
public:
CommandFrame(
    DeviceCommand command,
    MessagePeriod messagePeriod
)

Parameters

command
Type: GSF.PhasorProtocolsDeviceCommand
The DeviceCommand for this CommandFrame.
messagePeriod
Type: GSF.PhasorProtocols.SelFastMessageMessagePeriod
The desired MessagePeriod for SEL device connection.
Remarks
This constructor is used by a consumer to generate an SEL Fast Message command frame.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame Constructor (Byte[], Int32, Int32)

Grid Solutions Framework CommandFrame Constructor (Byte, Int32, Int32)
Creates a new CommandFrame from the given buffer.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommandFrame(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> CommandFrame
GSF.PhasorProtocols.SelFastMessage.CommandFrame = function(buffer, startIndex, length);
public:
CommandFrame(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | length is not large enough to parse frame.
Remarks
This constructor is used by a consumer to parse a received SEL Fast Message command frame. Typically command frames are sent to a device. This constructor would used if this code was being used inside of a phasor measurement device.
See Also

Reference

CommandFrame Class
CommandFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame Methods

Grid Solutions Framework CommandFrame Methods

The CommandFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides CommandFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from CommandFrameBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.CalculateChecksum Method

Grid Solutions Framework CommandFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.GetObjectData Method

Grid Solutions Framework CommandFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame Properties

Grid Solutions Framework CommandFrame Properties

The CommandFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides CommandFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this CommandFrame. (Overrides CommandFrameBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides CommandFrameBaseBodyLength.)
Public property | Cells | Gets reference to the CommandCellCollection for this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Command | Gets or sets the DeviceCommand for this CommandFrame.
Public property | ExtendedData | Gets or sets extended binary image data for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameSize | Gets frame size based on Command.
Public property | FrameType | Gets the FundamentalFrameType for this CommandFrameBase. (Inherited from CommandFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the ID code of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | MessagePeriod | Gets or sets the desired message period for the SEL device.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this CommandFrameBase. (Inherited from CommandFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.Attributes Property

Grid Solutions Framework CommandFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.BodyImage Property

Grid Solutions Framework CommandFrameBodyImage Property
Gets the binary body image of this CommandFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.BodyLength Property

Grid Solutions Framework CommandFrameBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.Command Property

Grid Solutions Framework CommandFrameCommand Property
Gets or sets the DeviceCommand for this CommandFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DeviceCommand Command { get; set; }
Public Property Command As DeviceCommand
    Get
    Set
member Command : DeviceCommand with get, set

function get_Command();
function set_Command(value);
public:
property DeviceCommand Command {
    DeviceCommand get ();
    void set (DeviceCommand value);
}

Property Value

Type: DeviceCommand
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.FrameSize Property

Grid Solutions Framework CommandFrameFrameSize Property
Gets frame size based on Command.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte FrameSize { get; }
Public ReadOnly Property FrameSize As Byte
    Get
member FrameSize : byte with get

function get_FrameSize();

public:
property unsigned char FrameSize {
    unsigned char get ();
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.HeaderImage Property

Grid Solutions Framework CommandFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.HeaderLength Property

Grid Solutions Framework CommandFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommandFrame.MessagePeriod Property

Grid Solutions Framework CommandFrameMessagePeriod Property
Gets or sets the desired message period for the SEL device.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MessagePeriod MessagePeriod { get; set; }
Public Property MessagePeriod As MessagePeriod
    Get
    Set
member MessagePeriod : MessagePeriod with get, set

function get_MessagePeriod();
function set_MessagePeriod(value);
public:
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
    void set (MessagePeriod value);
}

Property Value

Type: MessagePeriod
See Also

Reference

CommandFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common Class

Grid Solutions Framework Common Class
Common SEL Fast Message declarations and functions.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocols.SelFastMessageCommon

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.PhasorProtocols.SelFastMessage.Common = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.Common');
public ref class Common abstract sealed

The Common type exposes the following members.

Fields
Name | Description
HeaderByte1 | SEL Fast message data frame header byte 1.
HeaderByte2 | SEL Fast message data frame header byte 2.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


Common Fields

Grid Solutions Framework Common Fields

The Common type exposes the following members.

Fields
Name | Description
HeaderByte1 | SEL Fast message data frame header byte 1.
HeaderByte2 | SEL Fast message data frame header byte 2.
MaximumAnalogValues | Absolute maximum number of possible analog values that could fit into a data frame.
MaximumDataLength | Absolute maximum data length (in bytes) that could fit into any frame.
MaximumDigitalValues | Absolute maximum number of possible digital values that could fit into a data frame.
MaximumExtendedDataLength | Absolute maximum number of bytes of extended data that could fit into a command frame.
MaximumPhasorValues | Absolute maximum number of possible phasor values that could fit into a data frame.
Top
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common.HeaderByte1 Field

Grid Solutions Framework CommonHeaderByte1 Field
SEL Fast message data frame header byte 1.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte HeaderByte1
Public Const HeaderByte1 As Byte
static val mutable HeaderByte1: byte
var GSF.PhasorProtocols.SelFastMessage.Common.HeaderByte1
public:
literal unsigned char HeaderByte1

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common.HeaderByte2 Field

Grid Solutions Framework CommonHeaderByte2 Field
SEL Fast message data frame header byte 2.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const byte HeaderByte2
Public Const HeaderByte2 As Byte
static val mutable HeaderByte2: byte
var GSF.PhasorProtocols.SelFastMessage.Common.HeaderByte2
public:
literal unsigned char HeaderByte2

Field Value

Type: Byte
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common.MaximumAnalogValues Field

Grid Solutions Framework CommonMaximumAnalogValues Field
Absolute maximum number of possible analog values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumAnalogValues
Public Const MaximumAnalogValues As UShort
static val mutable MaximumAnalogValues: uint16
var GSF.PhasorProtocols.SelFastMessage.Common.MaximumAnalogValues
public:
literal unsigned short MaximumAnalogValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common.MaximumDataLength Field

Grid Solutions Framework CommonMaximumDataLength Field
Absolute maximum data length (in bytes) that could fit into any frame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDataLength
Public Const MaximumDataLength As UShort
static val mutable MaximumDataLength: uint16
var GSF.PhasorProtocols.SelFastMessage.Common.MaximumDataLength
public:
literal unsigned short MaximumDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common.MaximumDigitalValues Field

Grid Solutions Framework CommonMaximumDigitalValues Field
Absolute maximum number of possible digital values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumDigitalValues
Public Const MaximumDigitalValues As UShort
static val mutable MaximumDigitalValues: uint16
var GSF.PhasorProtocols.SelFastMessage.Common.MaximumDigitalValues
public:
literal unsigned short MaximumDigitalValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common.MaximumExtendedDataLength Field

Grid Solutions Framework CommonMaximumExtendedDataLength Field
Absolute maximum number of bytes of extended data that could fit into a command frame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumExtendedDataLength
Public Const MaximumExtendedDataLength As UShort
static val mutable MaximumExtendedDataLength: uint16
var GSF.PhasorProtocols.SelFastMessage.Common.MaximumExtendedDataLength
public:
literal unsigned short MaximumExtendedDataLength

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


Common.MaximumPhasorValues Field

Grid Solutions Framework CommonMaximumPhasorValues Field
Absolute maximum number of possible phasor values that could fit into a data frame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort MaximumPhasorValues
Public Const MaximumPhasorValues As UShort
static val mutable MaximumPhasorValues: uint16
var GSF.PhasorProtocols.SelFastMessage.Common.MaximumPhasorValues
public:
literal unsigned short MaximumPhasorValues

Field Value

Type: UInt16
See Also

Reference

Common Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Class

Grid Solutions Framework CommonFrameHeader Class
Represents the common header for all SEL Fast Message frames of data.
Inheritance Hierarchy
SystemObject
GSF.ParsingCommonHeaderBase Int32
GSF.PhasorProtocols.SelFastMessageCommonFrameHeader

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class CommonFrameHeader : CommonHeaderBase<int>,
    ISerializable
<SerializableAttribute>
Public Class CommonFrameHeader
    Inherits CommonHeaderBase(Of Integer)
    Implements ISerializable
[<SerializableAttribute>]
type CommonFrameHeader =
    class
        inherit CommonHeaderBase<int>
        interface ISerializable
    end
GSF.PhasorProtocols.SelFastMessage.CommonFrameHeader = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.CommonFrameHeader',
    GSF.Parsing.CommonHeaderBase`1,
    ISerializable);
[SerializableAttribute]
public ref class CommonFrameHeader : public CommonHeaderBase<int>,
    ISerializable

The CommonFrameHeader type exposes the following members.

Constructors
 | Name | Description
Public method | CommonFrameHeader(Byte, Int32) | Creates a new CommonFrameHeader from given buffer.
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(FrameSize, Ticks) | Creates a new CommonFrameHeader from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
HeaderLength | Total header length of CommonFrameHeader.
Top
Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this CommonFrameHeader.
Public property | DataLength | Gets the length of the data in the SEL Fast Message frame (i.e., the FrameSize minus the HeaderLength and checksum) of this CommonFrameHeader.
Public property | FrameSize | Gets or sets the SEL Fast Message frame size of this CommonFrameHeader.
Public property | IDCode | Gets or sets the SEL Fast Message destination address (PMADDR setting) of this CommonFrameHeader.
Public property | RegisterCount | Gets the SEL Fast Message register count of this CommonFrameHeader.
Public property | SampleNumber | Gets the SEL Fast Message sample number of this CommonFrameHeader.
Public property | SecondOfCentury | Gets the SEL Fast Message second of century of this CommonFrameHeader.
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Constructor

Grid Solutions Framework CommonFrameHeader Constructor
Overload List
 | Name | Description
Public method | CommonFrameHeader(Byte, Int32) | Creates a new CommonFrameHeader from given buffer.
Protected method | CommonFrameHeader(SerializationInfo, StreamingContext) | Creates a new CommonFrameHeader from serialization parameters.
Public method | CommonFrameHeader(FrameSize, Ticks) | Creates a new CommonFrameHeader from specified parameters.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Constructor (Byte[], Int32)

Grid Solutions Framework CommonFrameHeader Constructor (Byte, Int32)
Creates a new CommonFrameHeader from given buffer.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    byte[] buffer,
    int startIndex
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer
)
new :
        buffer : byte[] *
        startIndex : int -> CommonFrameHeader
GSF.PhasorProtocols.SelFastMessage.CommonFrameHeader = function(buffer, startIndex);
public:
CommonFrameHeader(
    array<unsigned char>^ buffer,
    int startIndex
)

Parameters

buffer
Type: SystemByte
Buffer that contains data to parse.
startIndex
Type: SystemInt32
Start index into buffer where valid data begins.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework CommonFrameHeader Constructor (SerializationInfo, StreamingContext)
Creates a new CommonFrameHeader from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CommonFrameHeader(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> CommonFrameHeader
GSF.PhasorProtocols.SelFastMessage.CommonFrameHeader = function(info, context);
protected:
CommonFrameHeader(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Constructor (FrameSize, Ticks)

Grid Solutions Framework CommonFrameHeader Constructor (FrameSize, Ticks)
Creates a new CommonFrameHeader from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader(
    FrameSize frameSize,
    Ticks timestamp
)
Public Sub New (
    frameSize As FrameSize,
    timestamp As Ticks
)
new :
        frameSize : FrameSize *
        timestamp : Ticks -> CommonFrameHeader
GSF.PhasorProtocols.SelFastMessage.CommonFrameHeader = function(frameSize, timestamp);
public:
CommonFrameHeader(
    FrameSize frameSize,
    Ticks timestamp
)

Parameters

frameSize
Type: GSF.PhasorProtocols.SelFastMessageFrameSize
The FrameSize of this frame.
timestamp
Type: GSFTicks
The timestamp of this frame.
See Also

Reference

CommonFrameHeader Class
CommonFrameHeader Overload
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Fields

Grid Solutions Framework CommonFrameHeader Fields

The CommonFrameHeader type exposes the following members.

Fields
Name | Description
FixedLength | Total fixed length of CommonFrameHeader.
HeaderLength | Total header length of CommonFrameHeader.
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.FixedLength Field

Grid Solutions Framework CommonFrameHeaderFixedLength Field
Total fixed length of CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort FixedLength
Public Const FixedLength As UShort
static val mutable FixedLength: uint16
var GSF.PhasorProtocols.SelFastMessage.CommonFrameHeader.FixedLength
public:
literal unsigned short FixedLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.HeaderLength Field

Grid Solutions Framework CommonFrameHeaderHeaderLength Field
Total header length of CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const ushort HeaderLength
Public Const HeaderLength As UShort
static val mutable HeaderLength: uint16
var GSF.PhasorProtocols.SelFastMessage.CommonFrameHeader.HeaderLength
public:
literal unsigned short HeaderLength

Field Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Methods

Grid Solutions Framework CommonFrameHeader Methods

The CommonFrameHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.GetObjectData Method

Grid Solutions Framework CommonFrameHeaderGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overridable Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader Properties

Grid Solutions Framework CommonFrameHeader Properties

The CommonFrameHeader type exposes the following members.

Properties
 | Name | Description
Public property | BinaryImage | Gets the binary image of the common header portion of this CommonFrameHeader.
Public property | DataLength | Gets the length of the data in the SEL Fast Message frame (i.e., the FrameSize minus the HeaderLength and checksum) of this CommonFrameHeader.
Public property | FrameSize | Gets or sets the SEL Fast Message frame size of this CommonFrameHeader.
Public property | IDCode | Gets or sets the SEL Fast Message destination address (PMADDR setting) of this CommonFrameHeader.
Public property | RegisterCount | Gets the SEL Fast Message register count of this CommonFrameHeader.
Public property | SampleNumber | Gets the SEL Fast Message sample number of this CommonFrameHeader.
Public property | SecondOfCentury | Gets the SEL Fast Message second of century of this CommonFrameHeader.
Public property | State | Gets or sets any additional state information that might be needed for parsing. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Public property | Timestamp | Gets or sets timestamp of this CommonFrameHeader.
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TypeID | Gets or sets the identifier used for identifying the Type to be parsed. (Inherited from CommonHeaderBaseTTypeIdentifier.)
Top
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.BinaryImage Property

Grid Solutions Framework CommonFrameHeaderBinaryImage Property
Gets the binary image of the common header portion of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] BinaryImage { get; }
Public ReadOnly Property BinaryImage As Byte()
    Get
member BinaryImage : byte[] with get

function get_BinaryImage();

public:
property array<unsigned char>^ BinaryImage {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.DataLength Property

Grid Solutions Framework CommonFrameHeaderDataLength Property
Gets the length of the data in the SEL Fast Message frame (i.e., the FrameSize minus the HeaderLength and checksum) of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort DataLength { get; }
Public ReadOnly Property DataLength As UShort
    Get
member DataLength : uint16 with get

function get_DataLength();

public:
property unsigned short DataLength {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.FrameSize Property

Grid Solutions Framework CommonFrameHeaderFrameSize Property
Gets or sets the SEL Fast Message frame size of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameSize FrameSize { get; set; }
Public Property FrameSize As FrameSize
    Get
    Set
member FrameSize : FrameSize with get, set

function get_FrameSize();
function set_FrameSize(value);
public:
property FrameSize FrameSize {
    FrameSize get ();
    void set (FrameSize value);
}

Property Value

Type: FrameSize
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.IDCode Property

Grid Solutions Framework CommonFrameHeaderIDCode Property
Gets or sets the SEL Fast Message destination address (PMADDR setting) of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
member IDCode : uint32 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.RegisterCount Property

Grid Solutions Framework CommonFrameHeaderRegisterCount Property
Gets the SEL Fast Message register count of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort RegisterCount { get; }
Public ReadOnly Property RegisterCount As UShort
    Get
member RegisterCount : uint16 with get

function get_RegisterCount();

public:
property unsigned short RegisterCount {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.SampleNumber Property

Grid Solutions Framework CommonFrameHeaderSampleNumber Property
Gets the SEL Fast Message sample number of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort SampleNumber { get; }
Public ReadOnly Property SampleNumber As UShort
    Get
member SampleNumber : uint16 with get

function get_SampleNumber();

public:
property unsigned short SampleNumber {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.SecondOfCentury Property

Grid Solutions Framework CommonFrameHeaderSecondOfCentury Property
Gets the SEL Fast Message second of century of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint SecondOfCentury { get; }
Public ReadOnly Property SecondOfCentury As UInteger
    Get
member SecondOfCentury : uint32 with get

function get_SecondOfCentury();

public:
property unsigned int SecondOfCentury {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.Timestamp Property

Grid Solutions Framework CommonFrameHeaderTimestamp Property
Gets or sets timestamp of this CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks Timestamp { get; set; }
Public Property Timestamp As Ticks
    Get
    Set
member Timestamp : Ticks with get, set

function get_Timestamp();
function set_Timestamp(value);
public:
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


CommonFrameHeader.TimeTag Property

Grid Solutions Framework CommonFrameHeaderTimeTag Property
Gets the timestamp of this frame in NTP format.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
member TimeTag : NtpTimeTag with get

function get_TimeTag();

public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

CommonFrameHeader Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell Class

Grid Solutions Framework ConfigurationCell Class
Represents the SEL Fast Message implementation of a IConfigurationCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsConfigurationCellBase
GSF.PhasorProtocols.SelFastMessageConfigurationCell

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCell : ConfigurationCellBase
<SerializableAttribute>
Public Class ConfigurationCell
    Inherits ConfigurationCellBase
[<SerializableAttribute>]
type ConfigurationCell =
    class
        inherit ConfigurationCellBase
    end
GSF.PhasorProtocols.SelFastMessage.ConfigurationCell = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.ConfigurationCell',
    GSF.PhasorProtocols.ConfigurationCellBase);
[SerializableAttribute]
public ref class ConfigurationCell : public ConfigurationCellBase

The ConfigurationCell type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCell(ConfigurationFrame) | Creates a new ConfigurationCell from specified parameters.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationCell.
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell Constructor

Grid Solutions Framework ConfigurationCell Constructor
Overload List
 | Name | Description
Public method | ConfigurationCell(ConfigurationFrame) | Creates a new ConfigurationCell from specified parameters.
Protected method | ConfigurationCell(SerializationInfo, StreamingContext) | Creates a new ConfigurationCell from serialization parameters.
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell Constructor (ConfigurationFrame)

Grid Solutions Framework ConfigurationCell Constructor (ConfigurationFrame)
Creates a new ConfigurationCell from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell(
    ConfigurationFrame parent
)
Public Sub New (
    parent As ConfigurationFrame
)
new :
        parent : ConfigurationFrame -> ConfigurationCell
GSF.PhasorProtocols.SelFastMessage.ConfigurationCell = function(parent);
public:
ConfigurationCell(
    ConfigurationFrame^ parent
)

Parameters

parent
Type: GSF.PhasorProtocols.SelFastMessageConfigurationFrame
The parent ConfigurationFrame.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCell Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCell from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCell
GSF.PhasorProtocols.SelFastMessage.ConfigurationCell = function(info, context);
protected:
ConfigurationCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCell Class
ConfigurationCell Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell Methods

Grid Solutions Framework ConfigurationCell Methods

The ConfigurationCell type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | CompareTo(IConfigurationCell) | Compares this instance to a specified IConfigurationCell object and returns an indication of their relative values. (Inherited from ConfigurationCellBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ConfigurationCellBase.)
Public method | Equals(IConfigurationCell) | Returns a value indicating whether this instance is equal to specified IConfigurationCell value. (Inherited from ConfigurationCellBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ConfigurationCellBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ConfigurationCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ConfigurationCellBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from ConfigurationCellBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from ConfigurationCellBase.)
Public method | ToString | Gets the string respresentation of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell Properties

Grid Solutions Framework ConfigurationCell Properties

The ConfigurationCell type exposes the following members.

Properties
 | Name | Description
Public property | AnalogDataFormat | Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBaseAnalogDataFormat.)
Public property | AnalogDefinitions | Gets a reference to the AnalogDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ConfigurationCellBase.)
Public property | DigitalDefinitions | Gets a reference to the DigitalDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | FooterImage | Gets the binary footer image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | FooterLength | Gets the length of the FooterImage. (Inherited from ConfigurationCellBase.)
Public property | FrameRate | Gets the specified frame rate of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | FrequencyDataFormat | Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell. (Overrides ConfigurationCellBaseFrequencyDataFormat.)
Public property | FrequencyDefinition | Gets or sets the IFrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ConfigurationCellBase object. (Inherited from ConfigurationCellBase.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Inherited from ConfigurationCellBase.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationCell.
Public property | IDLabel | Gets or sets the ID label of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelImage | Gets the binary image of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | IDLabelLength | Gets the length of the IDLabel of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | MaximumStationNameLength | Gets the maximum length of the StationName of this ConfigurationCell. (Overrides ConfigurationCellBaseMaximumStationNameLength.)
Public property | NominalFrequency | Gets or sets the nominal LineFrequency of the FrequencyDefinition of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Parent | Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.
Public property | PhasorAngleFormat | Gets or sets the AngleFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | PhasorCoordinateFormat | Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorCoordinateFormat.)
Public property | PhasorDataFormat | Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell. (Overrides ConfigurationCellBasePhasorDataFormat.)
Public property | PhasorDefinitions | Gets a reference to the PhasorDefinitionCollection of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | RevisionCount | Gets or sets the revision count of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | State | Gets or sets the parsing state for the this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationName | Gets or sets the station name of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | StationNameImage | Gets the binary image of the StationName of this ConfigurationCellBase. (Inherited from ConfigurationCellBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell.AnalogDataFormat Property

Grid Solutions Framework ConfigurationCellAnalogDataFormat Property
Gets or sets the DataFormat for the IAnalogDefinition objects in the AnalogDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat AnalogDataFormat { get; set; }
Public Overrides Property AnalogDataFormat As DataFormat
    Get
    Set
abstract AnalogDataFormat : DataFormat with get, set
override AnalogDataFormat : DataFormat with get, set
function get_AnalogDataFormat();
function set_AnalogDataFormat(value);
public:
virtual property DataFormat AnalogDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellAnalogDataFormat
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports floating-point data.
Remarks
This property only supports floating-point data; SEL Fast Message doesn't transport scaled values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell.FrequencyDataFormat Property

Grid Solutions Framework ConfigurationCellFrequencyDataFormat Property
Gets or sets the DataFormat of the FrequencyDefinition of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat FrequencyDataFormat { get; set; }
Public Overrides Property FrequencyDataFormat As DataFormat
    Get
    Set
abstract FrequencyDataFormat : DataFormat with get, set
override FrequencyDataFormat : DataFormat with get, set
function get_FrequencyDataFormat();
function set_FrequencyDataFormat(value);
public:
virtual property DataFormat FrequencyDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellFrequencyDataFormat
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports floating-point data.
Remarks
This property only supports floating-point data; SEL Fast Message doesn't transport scaled values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell.IDCode Property

Grid Solutions Framework ConfigurationCellIDCode Property
Gets or sets the ID code of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
member IDCode : uint32 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell.MaximumStationNameLength Property

Grid Solutions Framework ConfigurationCellMaximumStationNameLength Property
Gets the maximum length of the StationName of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int MaximumStationNameLength { get; }
Public Overrides ReadOnly Property MaximumStationNameLength As Integer
    Get
abstract MaximumStationNameLength : int with get
override MaximumStationNameLength : int with get
function get_MaximumStationNameLength();

public:
virtual property int MaximumStationNameLength {
    int get () override;
}

Property Value

Type: Int32

Implements

IConfigurationCellMaximumStationNameLength
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell.Parent Property

Grid Solutions Framework ConfigurationCellParent Property
Gets a reference to the parent ConfigurationFrame for this ConfigurationCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame Parent { get; set; }
Public Property Parent As ConfigurationFrame
    Get
    Set
member Parent : ConfigurationFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property ConfigurationFrame^ Parent {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell.PhasorCoordinateFormat Property

Grid Solutions Framework ConfigurationCellPhasorCoordinateFormat Property
Gets or sets the CoordinateFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CoordinateFormat PhasorCoordinateFormat { get; set; }
Public Overrides Property PhasorCoordinateFormat As CoordinateFormat
    Get
    Set
abstract PhasorCoordinateFormat : CoordinateFormat with get, set
override PhasorCoordinateFormat : CoordinateFormat with get, set
function get_PhasorCoordinateFormat();
function set_PhasorCoordinateFormat(value);
public:
virtual property CoordinateFormat PhasorCoordinateFormat {
    CoordinateFormat get () override;
    void set (CoordinateFormat value) override;
}

Property Value

Type: CoordinateFormat

Implements

IConfigurationCellPhasorCoordinateFormat
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports polar phasor data.
Remarks
This property only supports polar phasor data; SEL Fast Message doesn't transport rectangular phasor values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCell.PhasorDataFormat Property

Grid Solutions Framework ConfigurationCellPhasorDataFormat Property
Gets or sets the DataFormat for the IPhasorDefinition objects in the PhasorDefinitions of this ConfigurationCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataFormat PhasorDataFormat { get; set; }
Public Overrides Property PhasorDataFormat As DataFormat
    Get
    Set
abstract PhasorDataFormat : DataFormat with get, set
override PhasorDataFormat : DataFormat with get, set
function get_PhasorDataFormat();
function set_PhasorDataFormat(value);
public:
virtual property DataFormat PhasorDataFormat {
    DataFormat get () override;
    void set (DataFormat value) override;
}

Property Value

Type: DataFormat

Implements

IConfigurationCellPhasorDataFormat
Exceptions
Exception | Condition
NotSupportedException | SEL Fast Message only supports floating-point data.
Remarks
This property only supports floating-point data; SEL Fast Message doesn't transport scaled values.
See Also

Reference

ConfigurationCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection Class

Grid Solutions Framework ConfigurationCellCollection Class
Represents a SEL Fast Message implementation of a collection of IConfigurationCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IConfigurationCell
GSF.CollectionsListCollection IConfigurationCell
GSF.PhasorProtocolsChannelCollectionBase IConfigurationCell
GSF.PhasorProtocolsChannelCellCollectionBase IConfigurationCell
GSF.PhasorProtocolsConfigurationCellCollection
GSF.PhasorProtocols.SelFastMessageConfigurationCellCollection

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationCellCollection : ConfigurationCellCollection
<SerializableAttribute>
Public Class ConfigurationCellCollection
    Inherits ConfigurationCellCollection
[<SerializableAttribute>]
type ConfigurationCellCollection =
    class
        inherit ConfigurationCellCollection
    end
GSF.PhasorProtocols.SelFastMessage.ConfigurationCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.ConfigurationCellCollection',
    GSF.PhasorProtocols.ConfigurationCellCollection);
[SerializableAttribute]
public ref class ConfigurationCellCollection : public ConfigurationCellCollection

The ConfigurationCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Overload List
 | Name | Description
Public method | ConfigurationCellCollection | Creates a new ConfigurationCellCollection.
Protected method | ConfigurationCellCollection(SerializationInfo, StreamingContext) | Creates a new ConfigurationCellCollection from serialization parameters.
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection Constructor

Grid Solutions Framework ConfigurationCellCollection Constructor
Creates a new ConfigurationCellCollection.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection()
Public Sub New
new : unit -> ConfigurationCellCollection
GSF.PhasorProtocols.SelFastMessage.ConfigurationCellCollection = function();
public:
ConfigurationCellCollection()
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationCellCollection
GSF.PhasorProtocols.SelFastMessage.ConfigurationCellCollection = function(info, context);
protected:
ConfigurationCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationCellCollection Class
ConfigurationCellCollection Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection Methods

Grid Solutions Framework ConfigurationCellCollection Methods

The ConfigurationCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | IndexOfIDCode | Attempts to find the index of the IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfIDLabel | Attempts to find the index of the IConfigurationCell with the specified ID label. (Inherited from ConfigurationCellCollection.)
Public method | IndexOfStationName | Attempts to find the index of the IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetByIDCode | Attempts to get IConfigurationCell with the specified ID code. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByIDLabel | Attempts to get IConfigurationCell with the specified label. (Inherited from ConfigurationCellCollection.)
Public method | TryGetByStationName | Attempts to get IConfigurationCell with the specified station name. (Inherited from ConfigurationCellCollection.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection Properties

Grid Solutions Framework ConfigurationCellCollection Properties

The ConfigurationCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets ConfigurationCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection.Item Property

Grid Solutions Framework ConfigurationCellCollectionItem Property
Gets or sets ConfigurationCell at specified index.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As ConfigurationCell
    Get
    Set
member Item : ConfigurationCell with get, set

function get_Item(index);
function set_Item(value);
public:
property ConfigurationCell^ default[int index] {
    ConfigurationCell^ get (int index);
    void set (int index, ConfigurationCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: ConfigurationCell
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationCellCollection Events

Grid Solutions Framework ConfigurationCellCollection Events

The ConfigurationCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

ConfigurationCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame Class

Grid Solutions Framework ConfigurationFrame Class
Represents the SEL Fast Message implementation of a IConfigurationFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IConfigurationCell
GSF.PhasorProtocolsConfigurationFrameBase
GSF.PhasorProtocols.SelFastMessageConfigurationFrame

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConfigurationFrame : ConfigurationFrameBase
<SerializableAttribute>
Public Class ConfigurationFrame
    Inherits ConfigurationFrameBase
[<SerializableAttribute>]
type ConfigurationFrame =
    class
        inherit ConfigurationFrameBase
    end
GSF.PhasorProtocols.SelFastMessage.ConfigurationFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.ConfigurationFrame',
    GSF.PhasorProtocols.ConfigurationFrameBase);
[SerializableAttribute]
public ref class ConfigurationFrame : public ConfigurationFrameBase

The ConfigurationFrame type exposes the following members.

Constructors
 | Name | Description
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(FrameSize, MessagePeriod, UInt32) | Creates a new ConfigurationFrame.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Method is not implemented. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameSize | Gets the SEL Fast Message frame size of this ConfigurationFrame.
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | MessagePeriod | Gets defined MessagePeriod for SEL device.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame Constructor

Grid Solutions Framework ConfigurationFrame Constructor
Overload List
 | Name | Description
Protected method | ConfigurationFrame(SerializationInfo, StreamingContext) | Creates a new ConfigurationFrame from serialization parameters.
Public method | ConfigurationFrame(FrameSize, MessagePeriod, UInt32) | Creates a new ConfigurationFrame.
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConfigurationFrame Constructor (SerializationInfo, StreamingContext)
Creates a new ConfigurationFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConfigurationFrame
GSF.PhasorProtocols.SelFastMessage.ConfigurationFrame = function(info, context);
protected:
ConfigurationFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame Constructor (FrameSize, MessagePeriod, UInt32)

Grid Solutions Framework ConfigurationFrame Constructor (FrameSize, MessagePeriod, UInt32)
Creates a new ConfigurationFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame(
    FrameSize frameSize,
    MessagePeriod messagePeriod,
    uint idCode
)
Public Sub New (
    frameSize As FrameSize,
    messagePeriod As MessagePeriod,
    idCode As UInteger
)
new :
        frameSize : FrameSize *
        messagePeriod : MessagePeriod *
        idCode : uint32 -> ConfigurationFrame
GSF.PhasorProtocols.SelFastMessage.ConfigurationFrame = function(frameSize, messagePeriod, idCode);
public:
ConfigurationFrame(
    FrameSize frameSize,
    MessagePeriod messagePeriod,
    unsigned int idCode
)

Parameters

frameSize
Type: GSF.PhasorProtocols.SelFastMessageFrameSize
A FrameSize object.
messagePeriod
Type: GSF.PhasorProtocols.SelFastMessageMessagePeriod
A MessagePeriod object.
idCode
Type: SystemUInt32
An UInt32 as the id code.
Remarks
This constructor is used by a consumer to generate a SEL Fast Message configuration frame.
See Also

Reference

ConfigurationFrame Class
ConfigurationFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame Methods

Grid Solutions Framework ConfigurationFrame Methods

The ConfigurationFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Method is not implemented. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Overrides ChannelFrameBaseTChecksumIsValid(Byte, Int32).)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConfigurationFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | SetNominalFrequency | Sets a new nominal LineFrequency for all IFrequencyDefinition elements of each IConfigurationCell in the Cells collection. (Inherited from ConfigurationFrameBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.CalculateChecksum Method

Grid Solutions Framework ConfigurationFrameCalculateChecksum Method
Method is not implemented.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
A Byte buffer to read data from.
offset
Type: SystemInt32
An Int32 offset to read from.
length
Type: SystemInt32
An Int32 number of bytes to read.

Return Value

Type: UInt16
An UInt16 value for the checksum.
Exceptions
Exception | Condition
NotImplementedException | SEL Fast Message doesn't define a binary configuration frame - so no checksum is defined.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.ChecksumIsValid Method

Grid Solutions Framework ConfigurationFrameChecksumIsValid Method
Determines if checksum in the buffer is valid.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool ChecksumIsValid(
    byte[] buffer,
    int startIndex
)
Protected Overrides Function ChecksumIsValid (
    buffer As Byte(),
    startIndex As Integer
) As Boolean
abstract ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
override ChecksumIsValid :
        buffer : byte[] *
        startIndex : int -> bool
function ChecksumIsValid(buffer, startIndex);
protected:
virtual bool ChecksumIsValid(
    array<unsigned char>^ buffer,
    int startIndex
) override

Parameters

buffer
Type: SystemByte
Buffer image to validate.
startIndex
Type: SystemInt32
Start index into buffer to perform checksum.

Return Value

Type: Boolean
Flag that determines if checksum over buffer is valid.
Remarks
SEL Fast Message doesn't define a binary configuration frame - so no checksum is defined - this always returns true.
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.GetObjectData Method

Grid Solutions Framework ConfigurationFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame Properties

Grid Solutions Framework ConfigurationFrame Properties

The ConfigurationFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ConfigurationFrameBase.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object. (Overrides ConfigurationFrameBaseAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameRate | Gets or sets defined frame rate of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | FrameSize | Gets the SEL Fast Message frame size of this ConfigurationFrame.
Public property | FrameType | Gets the FundamentalFrameType for this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets or sets the ID code of this ConfigurationFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | MessagePeriod | Gets defined MessagePeriod for SEL device.
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | TicksPerFrame | Gets the defined Ticks per frame of this ConfigurationFrameBase. (Inherited from ConfigurationFrameBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TimeTag | Gets UNIX based time representation of the ticks of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.Attributes Property

Grid Solutions Framework ConfigurationFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the ConfigurationFrame object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.Cells Property

Grid Solutions Framework ConfigurationFrameCells Property
Gets reference to the ConfigurationCellCollection for this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCellCollection Cells { get; }
Public ReadOnly Property Cells As ConfigurationCellCollection
    Get
member Cells : ConfigurationCellCollection with get

function get_Cells();

public:
property ConfigurationCellCollection^ Cells {
    ConfigurationCellCollection^ get ();
}

Property Value

Type: ConfigurationCellCollection
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.FrameSize Property

Grid Solutions Framework ConfigurationFrameFrameSize Property
Gets the SEL Fast Message frame size of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameSize FrameSize { get; }
Public ReadOnly Property FrameSize As FrameSize
    Get
member FrameSize : FrameSize with get

function get_FrameSize();

public:
property FrameSize FrameSize {
    FrameSize get ();
}

Property Value

Type: FrameSize
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.IDCode Property

Grid Solutions Framework ConfigurationFrameIDCode Property
Gets or sets the ID code of this ConfigurationFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
member IDCode : uint32 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConfigurationFrame.MessagePeriod Property

Grid Solutions Framework ConfigurationFrameMessagePeriod Property
Gets defined MessagePeriod for SEL device.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MessagePeriod MessagePeriod { get; }
Public ReadOnly Property MessagePeriod As MessagePeriod
    Get
member MessagePeriod : MessagePeriod with get

function get_MessagePeriod();

public:
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
}

Property Value

Type: MessagePeriod
See Also

Reference

ConfigurationFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters Class

Grid Solutions Framework ConnectionParameters Class
Represents the extra connection parameters required for a connection to a SEL device.
Inheritance Hierarchy
SystemObject
GSF.PhasorProtocolsConnectionParametersBase
GSF.PhasorProtocols.SelFastMessageConnectionParameters

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ConnectionParameters : ConnectionParametersBase
<SerializableAttribute>
Public Class ConnectionParameters
    Inherits ConnectionParametersBase
[<SerializableAttribute>]
type ConnectionParameters =
    class
        inherit ConnectionParametersBase
    end
GSF.PhasorProtocols.SelFastMessage.ConnectionParameters = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.ConnectionParameters',
    GSF.PhasorProtocols.ConnectionParametersBase);
[SerializableAttribute]
public ref class ConnectionParameters : public ConnectionParametersBase

The ConnectionParameters type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | MessagePeriod | Gets or sets desired MessagePeriod for SEL device.
Public property | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Top
Remarks
This class is designed to be exposed by a "PropertyGrid" so a UI can request protocol specific connection parameters. As a result the CategoryAttribute and DescriptionAttribute elements should be defined for each of the exposed properties.
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Overload List
 | Name | Description
Public method | ConnectionParameters | Creates a new ConnectionParameters.
Protected method | ConnectionParameters(SerializationInfo, StreamingContext) | Creates a new ConnectionParameters from serialization parameters.
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters Constructor

Grid Solutions Framework ConnectionParameters Constructor
Creates a new ConnectionParameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionParameters()
Public Sub New
new : unit -> ConnectionParameters
GSF.PhasorProtocols.SelFastMessage.ConnectionParameters = function();
public:
ConnectionParameters()
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ConnectionParameters Constructor (SerializationInfo, StreamingContext)
Creates a new ConnectionParameters from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConnectionParameters(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ConnectionParameters
GSF.PhasorProtocols.SelFastMessage.ConnectionParameters = function(info, context);
protected:
ConnectionParameters(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ConnectionParameters Class
ConnectionParameters Overload
GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters Methods

Grid Solutions Framework ConnectionParameters Methods

The ConnectionParameters type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides ConnectionParametersBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters.GetObjectData Method

Grid Solutions Framework ConnectionParametersGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters Properties

Grid Solutions Framework ConnectionParameters Properties

The ConnectionParameters type exposes the following members.

Properties
 | Name | Description
Public property | MessagePeriod | Gets or sets desired MessagePeriod for SEL device.
Public property | ValuesAreValid | Determines if custom connection parameters are valid. (Inherited from ConnectionParametersBase.)
Top
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.SelFastMessage Namespace


ConnectionParameters.MessagePeriod Property

Grid Solutions Framework ConnectionParametersMessagePeriod Property
Gets or sets desired MessagePeriod for SEL device.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(typeof(MessagePeriod), "DefaultRate")]
public MessagePeriod MessagePeriod { get; set; }
<DefaultValueAttribute(GetType(MessagePeriod), "DefaultRate")>
Public Property MessagePeriod As MessagePeriod
    Get
    Set
[<DefaultValueAttribute(typeof(MessagePeriod), "DefaultRate")>]
member MessagePeriod : MessagePeriod with get, set

function get_MessagePeriod();
function set_MessagePeriod(value);
public:
[DefaultValueAttribute(typeof(MessagePeriod), L"DefaultRate")]
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
    void set (MessagePeriod value);
}

Property Value

Type: MessagePeriod
See Also

Reference

ConnectionParameters Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell Class

Grid Solutions Framework DataCell Class
Represents the SEL Fast Message implementation of a IDataCell that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelCellBase
GSF.PhasorProtocolsDataCellBase
GSF.PhasorProtocols.SelFastMessageDataCell

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCell : DataCellBase
<SerializableAttribute>
Public Class DataCell
    Inherits DataCellBase
[<SerializableAttribute>]
type DataCell =
    class
        inherit DataCellBase
    end
GSF.PhasorProtocols.SelFastMessage.DataCell = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.DataCell',
    GSF.PhasorProtocols.DataCellBase);
[SerializableAttribute]
public ref class DataCell : public DataCellBase

The DataCell type exposes the following members.

Constructors
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides DataCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBaseAnalogValues.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollection of this DataCell. (Overrides DataCellBaseDigitalValues.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCell.
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets status flags for this DataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


DataCell Constructor

Grid Solutions Framework DataCell Constructor
Overload List
 | Name | Description
Protected method | DataCell(SerializationInfo, StreamingContext) | Creates a new DataCell from serialization parameters.
Public method | DataCell(IDataFrame, IConfigurationCell) | Creates a new DataCell.
Public method | DataCell(DataFrame, ConfigurationCell, Boolean) | Creates a new DataCell from specified parameters.
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCell Constructor (SerializationInfo, StreamingContext)
Creates a new DataCell from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCell(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCell
GSF.PhasorProtocols.SelFastMessage.DataCell = function(info, context);
protected:
DataCell(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell Constructor (IDataFrame, IConfigurationCell)

Grid Solutions Framework DataCell Constructor (IDataFrame, IConfigurationCell)
Creates a new DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    IDataFrame parent,
    IConfigurationCell configurationCell
)
Public Sub New (
    parent As IDataFrame,
    configurationCell As IConfigurationCell
)
new :
        parent : IDataFrame *
        configurationCell : IConfigurationCell -> DataCell
GSF.PhasorProtocols.SelFastMessage.DataCell = function(parent, configurationCell);
public:
DataCell(
    IDataFrame^ parent,
    IConfigurationCell^ configurationCell
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataFrame
The reference to parent IDataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell associated with this DataCell.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell Constructor (DataFrame, ConfigurationCell, Boolean)

Grid Solutions Framework DataCell Constructor (DataFrame, ConfigurationCell, Boolean)
Creates a new DataCell from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell(
    DataFrame parent,
    ConfigurationCell configurationCell,
    bool addEmptyValues
)
Public Sub New (
    parent As DataFrame,
    configurationCell As ConfigurationCell,
    addEmptyValues As Boolean
)
new :
        parent : DataFrame *
        configurationCell : ConfigurationCell *
        addEmptyValues : bool -> DataCell
GSF.PhasorProtocols.SelFastMessage.DataCell = function(parent, configurationCell, addEmptyValues);
public:
DataCell(
    DataFrame^ parent,
    ConfigurationCell^ configurationCell,
    bool addEmptyValues
)

Parameters

parent
Type: GSF.PhasorProtocols.SelFastMessageDataFrame
The reference to parent DataFrame of this DataCell.
configurationCell
Type: GSF.PhasorProtocols.SelFastMessageConfigurationCell
The ConfigurationCell associated with this DataCell.
addEmptyValues
Type: SystemBoolean
If true, adds empty values for each defined configuration cell definition.
See Also

Reference

DataCell Class
DataCell Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell Methods

Grid Solutions Framework DataCell Methods

The DataCell type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from DataCellBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides DataCellBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelCellBase. (Inherited from ChannelCellBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.ParseBodyImage Method

Grid Solutions Framework DataCellParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell Properties

Grid Solutions Framework DataCell Properties

The DataCell type exposes the following members.

Properties
 | Name | Description
Public property | AllValuesAssigned | Gets flag that determines if all values of this DataCellBase have been assigned. (Inherited from DataCellBase.)
Public property | AnalogValues | Gets AnalogValueCollection of this DataCell. (Overrides DataCellBaseAnalogValues.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataCell object. (Overrides DataCellBaseAttributes.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the DataCellBase object. (Inherited from DataCellBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from DataCellBase.)
Public property | CommonStatusFlags | Gets or sets common status flags of this DataCellBase. (Inherited from DataCellBase.)
Public property | ConfigurationCell | Gets or sets the ConfigurationCell associated with this DataCell.
Public property | DataIsValid | Gets or sets flag that determines if data of this DataCell is valid. (Overrides DataCellBaseDataIsValid.)
Public property | DataSortingType | Gets or sets DataSortingType of this DataCell. (Overrides DataCellBaseDataSortingType.)
Public property | DeviceError | Gets or sets flag that determines if source device of this DataCell is reporting an error. (Overrides DataCellBaseDeviceError.)
Public property | DigitalValues | Gets DigitalValueCollection of this DataCell. (Overrides DataCellBaseDigitalValues.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrequencyValue | Gets IFrequencyValue of this DataCellBase. (Inherited from DataCellBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IDCode | Gets the numeric ID code for this DataCell.
Public property | IDLabel | Gets ID label of this DataCellBase. (Inherited from DataCellBase.)
Public property | Parent | Gets or sets the reference to parent DataFrame of this DataCell.
Public property | PhasorValues | Gets PhasorValueCollection of this DataCellBase. (Inherited from DataCellBase.)
Public property | State | Gets or sets the parsing state for the this DataCellBase. (Inherited from DataCellBase.)
Public property | StationName | Gets station name of this DataCellBase. (Inherited from DataCellBase.)
Public property | StatusFlags | Gets or sets status flags for this DataCell.
Public property | SynchronizationIsValid | Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock. (Overrides DataCellBaseSynchronizationIsValid.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.AnalogValues Property

Grid Solutions Framework DataCellAnalogValues Property
Gets AnalogValueCollection of this DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override AnalogValueCollection AnalogValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides ReadOnly Property AnalogValues As AnalogValueCollection
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract AnalogValues : AnalogValueCollection with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override AnalogValues : AnalogValueCollection with get
function get_AnalogValues();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property AnalogValueCollection^ AnalogValues {
    AnalogValueCollection^ get () override;
}

Property Value

Type: AnalogValueCollection

Implements

IDataCellAnalogValues
Remarks
SEL Fast Message doesn't define any analog values.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.Attributes Property

Grid Solutions Framework DataCellAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataCell object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
IChannelAttributes
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.ConfigurationCell Property

Grid Solutions Framework DataCellConfigurationCell Property
Gets or sets the ConfigurationCell associated with this DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationCell ConfigurationCell { get; set; }
Public Property ConfigurationCell As ConfigurationCell
    Get
    Set
member ConfigurationCell : ConfigurationCell with get, set

function get_ConfigurationCell();
function set_ConfigurationCell(value);
public:
property ConfigurationCell^ ConfigurationCell {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.DataIsValid Property

Grid Solutions Framework DataCellDataIsValid Property
Gets or sets flag that determines if data of this DataCell is valid.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool DataIsValid { get; set; }
Public Overrides Property DataIsValid As Boolean
    Get
    Set
abstract DataIsValid : bool with get, set
override DataIsValid : bool with get, set
function get_DataIsValid();
function set_DataIsValid(value);
public:
virtual property bool DataIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDataIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.DataSortingType Property

Grid Solutions Framework DataCellDataSortingType Property
Gets or sets DataSortingType of this DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSortingType DataSortingType { get; set; }
Public Overrides Property DataSortingType As DataSortingType
    Get
    Set
abstract DataSortingType : DataSortingType with get, set
override DataSortingType : DataSortingType with get, set
function get_DataSortingType();
function set_DataSortingType(value);
public:
virtual property DataSortingType DataSortingType {
    DataSortingType get () override;
    void set (DataSortingType value) override;
}

Property Value

Type: DataSortingType

Implements

IDataCellDataSortingType
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.DeviceError Property

Grid Solutions Framework DataCellDeviceError Property
Gets or sets flag that determines if source device of this DataCell is reporting an error.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool DeviceError { get; set; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Property DeviceError As Boolean
    Get
    Set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract DeviceError : bool with get, set
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override DeviceError : bool with get, set
function get_DeviceError();
function set_DeviceError(value);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool DeviceError {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellDeviceError
Remarks
SEL Fast Message doesn't define bits for device error.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.DigitalValues Property

Grid Solutions Framework DataCellDigitalValues Property
Gets DigitalValueCollection of this DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override DigitalValueCollection DigitalValues { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides ReadOnly Property DigitalValues As DigitalValueCollection
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract DigitalValues : DigitalValueCollection with get
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override DigitalValues : DigitalValueCollection with get
function get_DigitalValues();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property DigitalValueCollection^ DigitalValues {
    DigitalValueCollection^ get () override;
}

Property Value

Type: DigitalValueCollection

Implements

IDataCellDigitalValues
Remarks
SEL Fast Message doesn't define any digital values.
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.IDCode Property

Grid Solutions Framework DataCellIDCode Property
Gets the numeric ID code for this DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint IDCode { get; }
Public ReadOnly Property IDCode As UInteger
    Get
member IDCode : uint32 with get

function get_IDCode();

public:
property unsigned int IDCode {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.Parent Property

Grid Solutions Framework DataCellParent Property
Gets or sets the reference to parent DataFrame of this DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame Parent { get; set; }
Public Property Parent As DataFrame
    Get
    Set
member Parent : DataFrame with get, set

function get_Parent();
function set_Parent(value);
public:
property DataFrame^ Parent {
    DataFrame^ get ();
    void set (DataFrame^ value);
}

Property Value

Type: DataFrame
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.StatusFlags Property

Grid Solutions Framework DataCellStatusFlags Property
Gets or sets status flags for this DataCell.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatusFlags StatusFlags { get; set; }
Public Property StatusFlags As StatusFlags
    Get
    Set
member StatusFlags : StatusFlags with get, set

function get_StatusFlags();
function set_StatusFlags(value);
public:
property StatusFlags StatusFlags {
    StatusFlags get ();
    void set (StatusFlags value);
}

Property Value

Type: StatusFlags
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCell.SynchronizationIsValid Property

Grid Solutions Framework DataCellSynchronizationIsValid Property
Gets or sets flag that determines if timestamp of this DataCell is valid based on GPS lock.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SynchronizationIsValid { get; set; }
Public Overrides Property SynchronizationIsValid As Boolean
    Get
    Set
abstract SynchronizationIsValid : bool with get, set
override SynchronizationIsValid : bool with get, set
function get_SynchronizationIsValid();
function set_SynchronizationIsValid(value);
public:
virtual property bool SynchronizationIsValid {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

IDataCellSynchronizationIsValid
See Also

Reference

DataCell Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection Class

Grid Solutions Framework DataCellCollection Class
Represents a SEL Fast Message implementation of a collection of IDataCell objects.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IDataCell
GSF.CollectionsListCollection IDataCell
GSF.PhasorProtocolsChannelCollectionBase IDataCell
GSF.PhasorProtocolsChannelCellCollectionBase IDataCell
GSF.PhasorProtocolsDataCellCollection
GSF.PhasorProtocols.SelFastMessageDataCellCollection

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataCellCollection : DataCellCollection
<SerializableAttribute>
Public Class DataCellCollection
    Inherits DataCellCollection
[<SerializableAttribute>]
type DataCellCollection =
    class
        inherit DataCellCollection
    end
GSF.PhasorProtocols.SelFastMessage.DataCellCollection = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.DataCellCollection',
    GSF.PhasorProtocols.DataCellCollection);
[SerializableAttribute]
public ref class DataCellCollection : public DataCellCollection

The DataCellCollection type exposes the following members.

Constructors
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Overload List
 | Name | Description
Public method | DataCellCollection | Creates a new DataCellCollection.
Protected method | DataCellCollection(SerializationInfo, StreamingContext) | Creates a new DataCellCollection from serialization parameters.
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection Constructor

Grid Solutions Framework DataCellCollection Constructor
Creates a new DataCellCollection.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection()
Public Sub New
new : unit -> DataCellCollection
GSF.PhasorProtocols.SelFastMessage.DataCellCollection = function();
public:
DataCellCollection()
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataCellCollection Constructor (SerializationInfo, StreamingContext)
Creates a new DataCellCollection from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataCellCollection(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataCellCollection
GSF.PhasorProtocols.SelFastMessage.DataCellCollection = function(info, context);
protected:
DataCellCollection(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataCellCollection Class
DataCellCollection Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection Methods

Grid Solutions Framework DataCellCollection Methods

The DataCellCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | AddRange | Adds the elements of the specified collection to the end of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from ChannelCellCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the ChannelCollectionBaseT at the specified index. (Inherited from ChannelCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnCollectionChanged | Raises the NotifyCollectionChangedEventHandler event. (Inherited from ChannelCollectionBaseT.)
Public method | RefreshBinding | Manually sends a Reset to the collection changed event. (Inherited from ChannelCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Protected method | SetItem | Replaces the element at the specified index. (Inherited from ChannelCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection Properties

Grid Solutions Framework DataCellCollection Properties

The DataCellCollection type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this ChannelCellCollectionBaseT object. (Inherited from ChannelCellCollectionBaseT.)
Public property | BinaryLength | Gets the length of the ChannelCollectionBaseT. (Inherited from ChannelCellCollectionBaseT.)
Public property | ConstantCellLength | Gets flag that determines if the lengths of IChannelCell elements in this ChannelCellCollectionBaseT are constant. (Inherited from ChannelCellCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | Item | Gets or sets DataCell at specified index.
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | MaximumCount | Gets or sets the maximum allowed number of items for this ChannelCollectionBaseT. (Inherited from ChannelCollectionBaseT.)
Public property | State | Gets or sets the parsing state for this IChannel object. (Inherited from ChannelCollectionBaseT.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this IChannel object. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection.Item Property

Grid Solutions Framework DataCellCollectionItem Property
Gets or sets DataCell at specified index.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCell this[
    int index
] { get; set; }
Public Default Property Item (
    index As Integer
) As DataCell
    Get
    Set
member Item : DataCell with get, set

function get_Item(index);
function set_Item(value);
public:
property DataCell^ default[int index] {
    DataCell^ get (int index);
    void set (int index, DataCell^ value);
}

Parameters

index
Type: SystemInt32
Index of value to get or set.

Property Value

Type: DataCell
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataCellCollection Events

Grid Solutions Framework DataCellCollection Events

The DataCellCollection type exposes the following members.

Events
 | Name | Description
Public event | CollectionChanged | Notifies listeners of dynamic changes, such as when items get added and removed or the whole list is refreshed. (Inherited from ChannelCollectionBaseT.)
Top
See Also

Reference

DataCellCollection Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame Class

Grid Solutions Framework DataFrame Class
Represents the SEL Fast Message implementation of a IDataFrame that can be sent or received.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelFrameBase IDataCell
GSF.PhasorProtocolsDataFrameBase
GSF.PhasorProtocols.SelFastMessageDataFrame

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class DataFrame : DataFrameBase, ISupportSourceIdentifiableFrameImage<SourceChannel, int>,
    ISupportFrameImage<int>, ISupportBinaryImage
<SerializableAttribute>
Public Class DataFrame
    Inherits DataFrameBase
    Implements ISupportSourceIdentifiableFrameImage(Of SourceChannel, Integer), ISupportFrameImage(Of Integer),
    ISupportBinaryImage
[<SerializableAttribute>]
type DataFrame =
    class
        inherit DataFrameBase
        interface ISupportSourceIdentifiableFrameImage<SourceChannel, int>
        interface ISupportFrameImage<int>
        interface ISupportBinaryImage
    end
GSF.PhasorProtocols.SelFastMessage.DataFrame = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.DataFrame',
    GSF.PhasorProtocols.DataFrameBase,
    GSF.Parsing.ISupportSourceIdentifiableFrameImage`2,
    GSF.Parsing.ISupportFrameImage`1,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class DataFrame : public DataFrameBase,
    ISupportSourceIdentifiableFrameImage<SourceChannel, int>, ISupportFrameImage<int>, ISupportBinaryImage

The DataFrame type exposes the following members.

Constructors
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, FrameSize, UInt32) | Creates a new DataFrame from specified parameters.
Top
Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameSize | Gets or sets the SEL Fast Message frame size of this DataFrame.
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the SEL Fast Message destination address (PMADDR setting) for this DataFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the SEL Fast Message frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Overload List
 | Name | Description
Public method | DataFrame | Creates a new DataFrame.
Protected method | DataFrame(SerializationInfo, StreamingContext) | Creates a new DataFrame from serialization parameters.
Public method | DataFrame(Ticks, FrameSize, UInt32) | Creates a new DataFrame from specified parameters.
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame Constructor

Grid Solutions Framework DataFrame Constructor
Creates a new DataFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public DataFrame()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub New
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
new : unit -> DataFrame
GSF.PhasorProtocols.SelFastMessage.DataFrame = function();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
DataFrame()
Remarks
This constructor is used by FrameImageParserBaseTTypeIdentifier, TOutputType to parse a SEL Fast Message data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework DataFrame Constructor (SerializationInfo, StreamingContext)
Creates a new DataFrame from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataFrame(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> DataFrame
GSF.PhasorProtocols.SelFastMessage.DataFrame = function(info, context);
protected:
DataFrame(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame Constructor (Ticks, FrameSize, UInt32)

Grid Solutions Framework DataFrame Constructor (Ticks, FrameSize, UInt32)
Creates a new DataFrame from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataFrame(
    Ticks timestamp,
    FrameSize frameSize,
    uint idCode
)
Public Sub New (
    timestamp As Ticks,
    frameSize As FrameSize,
    idCode As UInteger
)
new :
        timestamp : Ticks *
        frameSize : FrameSize *
        idCode : uint32 -> DataFrame
GSF.PhasorProtocols.SelFastMessage.DataFrame = function(timestamp, frameSize, idCode);
public:
DataFrame(
    Ticks timestamp,
    FrameSize frameSize,
    unsigned int idCode
)

Parameters

timestamp
Type: GSFTicks
The exact timestamp, in Ticks, of the data represented by this DataFrame.
frameSize
Type: GSF.PhasorProtocols.SelFastMessageFrameSize
The SEL Fast Message frame size of this DataFrame.
idCode
Type: SystemUInt32
The SEL Fast Message destination address (PMADDR setting) for this DataFrame
Remarks
This constructor is used by a consumer to generate a SEL Fast Message data frame.
See Also

Reference

DataFrame Class
DataFrame Overload
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame Methods

Grid Solutions Framework DataFrame Methods

The DataFrame type exposes the following members.

Methods
 | Name | Description
Protected method | AppendChecksum | Appends checksum onto buffer starting at startIndex. (Inherited from ChannelFrameBaseT.)
Protected method | CalculateChecksum | Calculates checksum of given buffer. (Overrides ChannelFrameBaseTCalculateChecksum(Byte, Int32, Int32).)
Protected method | ChecksumIsValid | Determines if checksum in the buffer is valid. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(Object) | Compares the ChannelFrameBaseT with the specified Object. (Inherited from ChannelFrameBaseT.)
Public method | CompareTo(IFrame) | Compares the ChannelFrameBaseT with an IFrame. (Inherited from ChannelFrameBaseT.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelFrameBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Overrides DataFrameBaseGetObjectData(SerializationInfo, StreamingContext).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Parses the binary image. (Inherited from DataFrameBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelFrameBaseT.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Overrides BinaryImageBaseParseHeaderImage(Byte, Int32, Int32).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.CalculateChecksum Method

Grid Solutions Framework DataFrameCalculateChecksum Method
Calculates checksum of given buffer.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ushort CalculateChecksum(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function CalculateChecksum (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As UShort
abstract CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
override CalculateChecksum :
        buffer : byte[] *
        offset : int *
        length : int -> uint16
function CalculateChecksum(buffer, offset, length);
protected:
virtual unsigned short CalculateChecksum(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer image over which to calculate checksum.
offset
Type: SystemInt32
Start index into buffer to calculate checksum.
length
Type: SystemInt32
Length of data within buffer to calculate checksum.

Return Value

Type: UInt16
Checksum over specified portion of buffer.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.GetObjectData Method

Grid Solutions Framework DataFrameGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination StreamingContext for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
ISerializableGetObjectData(SerializationInfo, StreamingContext)
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.ParseHeaderImage Method

Grid Solutions Framework DataFrameParseHeaderImage Method
Parses the binary header image.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseHeaderImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseHeaderImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseHeaderImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseHeaderImage(buffer, startIndex, length);
protected:
virtual int ParseHeaderImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame Properties

Grid Solutions Framework DataFrame Properties

The DataFrame type exposes the following members.

Properties
 | Name | Description
Public property | AllowQueuedPublication | Gets flag that determines if frame image can be queued for publication or should be processed immediately. (Inherited from ChannelFrameBaseT.)
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the DataFrame object. (Overrides ChannelFrameBaseTAttributes.)
Public property | BinaryImage | Gets the binary image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | BinaryLength | Gets the length of the BinaryImage. (Inherited from ChannelFrameBaseT.)
Protected property | BodyImage | Gets the binary body image of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelFrameBaseT.)
Public property | Cells | Gets reference to the DataCellCollection for this DataFrame.
Public property | CommonHeader | Gets or sets current CommonFrameHeader.
Public property | ConfigurationFrame | Gets or sets ConfigurationFrame associated with this DataFrame.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | FrameSize | Gets or sets the SEL Fast Message frame size of this DataFrame.
Public property | FrameType | Gets the FundamentalFrameType for this DataFrameBase. (Inherited from DataFrameBase.)
Protected property | HeaderImage | Gets the binary header image of the DataFrame object. (Overrides ChannelBaseHeaderImage.)
Protected property | HeaderLength | Gets the length of the HeaderImage. (Overrides BinaryImageBaseHeaderLength.)
Public property | IDCode | Gets or sets the SEL Fast Message destination address (PMADDR setting) for this DataFrame.
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Measurements | Keyed measurements in this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Protected property | ParsedBinaryLength | Gets the parsed binary length derived from the parsing state, if any. (Inherited from ChannelFrameBaseT.)
Public property | Published | Gets or sets published state of this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was published (post-processing). (Inherited from ChannelFrameBaseT.)
Public property | QualityFlags | Gets or sets protocol specific quality flags for this DataFrameBase. (Inherited from DataFrameBase.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this ChannelFrameBaseT was received (i.e., created). (Inherited from ChannelFrameBaseT.)
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | Source | Gets or sets the data source identifier for this ChannelFrameBaseT. (Inherited from ChannelFrameBaseT.)
Public property | State | Gets or sets the parsing state for the this DataFrameBase. (Inherited from DataFrameBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame. (Overrides ChannelFrameBaseTTimestamp.)
Public property | TimeTag | Gets the timestamp of this frame in NTP format.
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from ChannelFrameBaseT.)
Public property | TypeID | Gets the identifier that is used to identify the SEL Fast Message frame.
Public property | ValidateCheckSum | Gets or sets flag that determines if frame's check-sum should be validated - this should normally be left as true. (Inherited from ChannelFrameBaseT.)
Top
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.Attributes Property

Grid Solutions Framework DataFrameAttributes Property
DictionaryTKey, TValue of string based property names and values for the DataFrame object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Dictionary<string, string> Attributes { get; }
Public Overrides ReadOnly Property Attributes As Dictionary(Of String, String)
    Get
abstract Attributes : Dictionary<string, string> with get
override Attributes : Dictionary<string, string> with get
function get_Attributes();

public:
virtual property Dictionary<String^, String^>^ Attributes {
    Dictionary<String^, String^>^ get () override;
}

Property Value

Type: Dictionary String, String

Implements

IChannelAttributes
IChannelAttributes
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.Cells Property

Grid Solutions Framework DataFrameCells Property
Gets reference to the DataCellCollection for this DataFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataCellCollection Cells { get; }
Public ReadOnly Property Cells As DataCellCollection
    Get
member Cells : DataCellCollection with get

function get_Cells();

public:
property DataCellCollection^ Cells {
    DataCellCollection^ get ();
}

Property Value

Type: DataCellCollection
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.CommonHeader Property

Grid Solutions Framework DataFrameCommonHeader Property
Gets or sets current CommonFrameHeader.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CommonFrameHeader CommonHeader { get; set; }
Public Property CommonHeader As CommonFrameHeader
    Get
    Set
member CommonHeader : CommonFrameHeader with get, set

function get_CommonHeader();
function set_CommonHeader(value);
public:
property CommonFrameHeader^ CommonHeader {
    CommonFrameHeader^ get ();
    void set (CommonFrameHeader^ value);
}

Property Value

Type: CommonFrameHeader
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.ConfigurationFrame Property

Grid Solutions Framework DataFrameConfigurationFrame Property
Gets or sets ConfigurationFrame associated with this DataFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConfigurationFrame ConfigurationFrame { get; set; }
Public Property ConfigurationFrame As ConfigurationFrame
    Get
    Set
member ConfigurationFrame : ConfigurationFrame with get, set

function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
property ConfigurationFrame^ ConfigurationFrame {
    ConfigurationFrame^ get ();
    void set (ConfigurationFrame^ value);
}

Property Value

Type: ConfigurationFrame
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.FrameSize Property

Grid Solutions Framework DataFrameFrameSize Property
Gets or sets the SEL Fast Message frame size of this DataFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameSize FrameSize { get; set; }
Public Property FrameSize As FrameSize
    Get
    Set
member FrameSize : FrameSize with get, set

function get_FrameSize();
function set_FrameSize(value);
public:
property FrameSize FrameSize {
    FrameSize get ();
    void set (FrameSize value);
}

Property Value

Type: FrameSize
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.HeaderImage Property

Grid Solutions Framework DataFrameHeaderImage Property
Gets the binary header image of the DataFrame object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] HeaderImage { get; }
Protected Overrides ReadOnly Property HeaderImage As Byte()
    Get
abstract HeaderImage : byte[] with get
override HeaderImage : byte[] with get
function get_HeaderImage();

protected:
virtual property array<unsigned char>^ HeaderImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.HeaderLength Property

Grid Solutions Framework DataFrameHeaderLength Property
Gets the length of the HeaderImage.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int HeaderLength { get; }
Protected Overrides ReadOnly Property HeaderLength As Integer
    Get
abstract HeaderLength : int with get
override HeaderLength : int with get
function get_HeaderLength();

protected:
virtual property int HeaderLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.IDCode Property

Grid Solutions Framework DataFrameIDCode Property
Gets or sets the SEL Fast Message destination address (PMADDR setting) for this DataFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint IDCode { get; set; }
Public Property IDCode As UInteger
    Get
    Set
member IDCode : uint32 with get, set

function get_IDCode();
function set_IDCode(value);
public:
property unsigned int IDCode {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.Timestamp Property

Grid Solutions Framework DataFrameTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this DataFrame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Ticks Timestamp { get; set; }
Public Overrides Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get () override;
    void set (Ticks value) override;
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.TimeTag Property

Grid Solutions Framework DataFrameTimeTag Property
Gets the timestamp of this frame in NTP format.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NtpTimeTag TimeTag { get; }
Public ReadOnly Property TimeTag As NtpTimeTag
    Get
member TimeTag : NtpTimeTag with get

function get_TimeTag();

public:
property NtpTimeTag^ TimeTag {
    NtpTimeTag^ get ();
}

Property Value

Type: NtpTimeTag
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DataFrame.TypeID Property

Grid Solutions Framework DataFrameTypeID Property
Gets the identifier that is used to identify the SEL Fast Message frame.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int TypeID { get; }
Public ReadOnly Property TypeID As Integer
    Get
abstract TypeID : int with get
override TypeID : int with get
function get_TypeID();

public:
virtual property int TypeID {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportFrameImageTTypeIdentifierTypeID
See Also

Reference

DataFrame Class
GSF.PhasorProtocols.SelFastMessage Namespace


DeviceCommand Enumeration

Grid Solutions Framework DeviceCommand Enumeration
SEL Fast Message device commands enumeration.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum DeviceCommand
<SerializableAttribute>
Public Enumeration DeviceCommand
[<SerializableAttribute>]
type DeviceCommand
GSF.PhasorProtocols.SelFastMessage.DeviceCommand = function();
GSF.PhasorProtocols.SelFastMessage.DeviceCommand.createEnum('GSF.PhasorProtocols.SelFastMessage.DeviceCommand', false);
[SerializableAttribute]
public enum class DeviceCommand
Members
Member name | Value | Description
EnableUnsolicitedMessages | 1 | Enable unsolicited write messages.
DisableUnsolicitedMessages | 2 | Disable unsolicited write messages.
Undefined | 255 | Undefined command.
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser Class

Grid Solutions Framework FrameParser Class
Represents a frame parser for a SEL Fast Message binary data stream that returns parsed data via events.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.IOStream
GSF.ParsingBinaryImageParserBase
GSF.ParsingFrameImageParserBase Int32, ISupportSourceIdentifiableFrameImage SourceChannel, Int32
GSF.ParsingMultiSourceFrameImageParserBase SourceChannel, Int32, ISupportSourceIdentifiableFrameImage SourceChannel, Int32
GSF.PhasorProtocolsFrameParserBase Int32
GSF.PhasorProtocols.SelFastMessageFrameParser

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FrameParser : FrameParserBase<int>
Public Class FrameParser
    Inherits FrameParserBase(Of Integer)
type FrameParser =
    class
        inherit FrameParserBase<int>
    end
GSF.PhasorProtocols.SelFastMessage.FrameParser = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.FrameParser',
    GSF.PhasorProtocols.FrameParserBase`1);
public ref class FrameParser : public FrameParserBase<int>

The FrameParser type exposes the following members.

Constructors
 | Name | Description
Public method | FrameParser | Creates a new FrameParser from specified parameters.
Top
Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(SourceChannel, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse(TSourceIdentifier, Byte, Int32, Int32).)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | MessagePeriod | Gets or sets the desired message period for the SEL device.
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if SEL Fast Message protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a SEL Fast Message ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a SEL Fast Message DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
Remarks
Frame parser is implemented as a write-only stream - this way data can come from any source.
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser Constructor

Grid Solutions Framework FrameParser Constructor
Creates a new FrameParser from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    bool trustHeaderLength = true,
    MessagePeriod messagePeriod = MessagePeriod.DefaultRate
)
Public Sub New (
    Optional checkSumValidationFrameTypes As CheckSumValidationFrameTypes = CheckSumValidationFrameTypes.AllFrames,
    Optional trustHeaderLength As Boolean = true,
    Optional messagePeriod As MessagePeriod = MessagePeriod.DefaultRate
)
new :
        ?checkSumValidationFrameTypes : CheckSumValidationFrameTypes *
        ?trustHeaderLength : bool *
        ?messagePeriod : MessagePeriod
(* Defaults:
        let _checkSumValidationFrameTypes = defaultArg checkSumValidationFrameTypes CheckSumValidationFrameTypes.AllFrames
        let _trustHeaderLength = defaultArg trustHeaderLength true
        let _messagePeriod = defaultArg messagePeriod MessagePeriod.DefaultRate
*)
-> FrameParser
GSF.PhasorProtocols.SelFastMessage.FrameParser = function(checkSumValidationFrameTypes, trustHeaderLength, messagePeriod);
public:
FrameParser(
    CheckSumValidationFrameTypes checkSumValidationFrameTypes = CheckSumValidationFrameTypes::AllFrames,
    bool trustHeaderLength = true,
    MessagePeriod messagePeriod = MessagePeriod::DefaultRate
)

Parameters

checkSumValidationFrameTypes (Optional)
Type: GSF.PhasorProtocolsCheckSumValidationFrameTypes
Frame types that should perform check-sum validation; default to AllFrames
trustHeaderLength (Optional)
Type: SystemBoolean
Determines if header lengths should be trusted over parsed byte count.
messagePeriod (Optional)
Type: GSF.PhasorProtocols.SelFastMessageMessagePeriod
The desired MessagePeriod for SEL device connection.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser Fields

Grid Solutions Framework FrameParser Fields

The FrameParser type exposes the following members.

Fields
 | Name | Description
Protected field | StreamInitialized | Tracks if data stream has been initialized. (Inherited from BinaryImageParserBase.)
Protected field | UnparsedBuffer | Remaining unparsed buffer from last parsing execution, if any. (Inherited from BinaryImageParserBase.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser Methods

Grid Solutions Framework FrameParser Methods

The FrameParser type exposes the following members.

Methods
 | Name | Description
Public method | BeginRead | Begins an asynchronous read operation. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | BeginWrite | Begins an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Close | Closes the current stream and releases any resources (such as sockets and file handles) associated with the current stream. Instead of calling this method, ensure that the stream is properly disposed. (Inherited from Stream.)
Public method | CopyTo(Stream) | Reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyTo(Stream, Int32) | Reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream) | Asynchronously reads the bytes from the current stream and writes them to another stream. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size. (Inherited from Stream.)
Public method | CopyToAsync(Stream, Int32, CancellationToken) | Asynchronously reads the bytes from the current stream and writes them to another stream, using a specified buffer size and cancellation token. (Inherited from Stream.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | CreateWaitHandle | Obsolete. Allocates a WaitHandle object. (Inherited from Stream.)
Public method | Dispose | Releases all resources used by the Stream. (Inherited from Stream.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the FrameParserBaseTFrameIdentifier object and optionally releases the managed resources. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | EndRead | Waits for the pending asynchronous read to complete. (Consider using ReadAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | EndWrite | Ends an asynchronous write operation. (Consider using WriteAsync(Byte, Int32, Int32) instead; see the Remarks section.) (Inherited from Stream.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Flush | When overridden in a derived class, clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from BinaryImageParserBase.)
Public method | FlushAsync | Asynchronously clears all buffers for this stream and causes any buffered data to be written to the underlying device. (Inherited from Stream.)
Public method | FlushAsync(CancellationToken) | Asynchronously clears all buffers for this stream, causes any buffered data to be written to the underlying device, and monitors cancellation requests. (Inherited from Stream.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ObjectInvariant | Obsolete. Provides support for a Contract. (Inherited from Stream.)
Protected method | OnBufferParsed | Raises the BufferParsed event. (Inherited from BinaryImageParserBase.)
Protected method | OnConfigurationChanged | Raises the ConfigurationChanged event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnDataDiscarded | Raises the DataDiscarded event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDataParsed | Raises the DataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnDuplicateTypeHandlerEncountered | Raises the DuplicateTypeHandlerEncountered event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnOutputTypeNotFound | Raises the OutputTypeNotFound event. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | OnParsingException | Raises the ParsingException event. (Inherited from BinaryImageParserBase.)
Protected method | OnReceivedChannelFrame | Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame). (Overrides FrameParserBaseTFrameIdentifierOnReceivedChannelFrame(IChannelFrame).)
Protected method | OnReceivedCommandFrame | Raises the ReceivedCommandFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedConfigurationFrame | Raises the ReceivedConfigurationFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedDataFrame | Raises the ReceivedDataFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedFrameBufferImage | Raises the ReceivedFrameImage and ReceivedFrameBufferImage event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedHeaderFrame | Raises the ReceivedHeaderFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnReceivedUndeterminedFrame | Raises the ReceivedUndeterminedFrame event. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected method | OnSourceDataParsed | Raises the SourceDataParsed event. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Protected method | OnUnknownFrameTypeEncountered | Handles unknown frame types. (Inherited from FrameParserBaseTFrameIdentifier.)
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(SourceChannel, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse(TSourceIdentifier, Byte, Int32, Int32).)
Protected method | ParseCommonHeader | Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image. (Overrides FrameImageParserBaseTTypeIdentifier, TOutputTypeParseCommonHeader(Byte, Int32, Int32).)
Protected method | ParseFrame | Output type specific frame parsing algorithm. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Protected method | PublishParsedOutput | AsyncQueueT handler used to publish queued outputs. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public method | PurgeBuffer | Clears the internal buffer of unparsed data received from the specified source. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Read | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | ReadAsync(Byte, Int32, Int32) | Asynchronously reads a sequence of bytes from the current stream and advances the position within the stream by the number of bytes read. (Inherited from Stream.)
Public method | ReadAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously reads a sequence of bytes from the current stream, advances the position within the stream by the number of bytes read, and monitors cancellation requests. (Inherited from Stream.)
Public method | ReadByte | Reads a byte from the stream and advances the position within the stream by one byte, or returns -1 if at the end of the stream. (Inherited from Stream.)
Public method | Seek | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | SetLength | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Stop | Stops the streaming data parser. (Inherited from BinaryImageParserBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, Byte, Int32, Int32) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | WriteAsync(Byte, Int32, Int32) | Asynchronously writes a sequence of bytes to the current stream and advances the current position within this stream by the number of bytes written. (Inherited from Stream.)
Public method | WriteAsync(Byte, Int32, Int32, CancellationToken) | Asynchronously writes a sequence of bytes to the current stream, advances the current position within this stream by the number of bytes written, and monitors cancellation requests. (Inherited from Stream.)
Public method | WriteByte | Writes a byte to the current position in the stream and advances the position within the stream by one byte. (Inherited from Stream.)
Top
Extension Methods
 | Name | Description
Public Extension Method | Compress(CompressionStrength) | Overloaded. Compress a stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | Compress(Stream, CompressionStrength, ActionProcessProgressInt64) | Overloaded. Compress a stream onto given output stream using specified compression strength. (Defined by CompressionExtensions.)
Public Extension Method | CopyStream | Copies input Stream onto output Stream. (Defined by StreamExtensions.)
Public Extension Method | Decompress | Overloaded. Decompress a stream. (Defined by CompressionExtensions.)
Public Extension Method | Decompress(Stream, ActionProcessProgressInt64) | Overloaded. Decompress a stream onto given output stream. (Defined by CompressionExtensions.)
Public Extension Method | Decrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of decrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Decrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Decrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | DeserializeToDataSet | Deserializes a DataSet from a Stream. (Defined by DataSetExtensions.)
Public Extension Method | Encrypt(Byte, Byte, CipherStrength) | Overloaded. Returns a stream of encrypted data for the given parameters. (Defined by Cipher.)
Public Extension Method | Encrypt(Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Overloaded. Encrypts input stream onto output stream for the given parameters. (Defined by Cipher.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ReadStream | Reads entire Stream contents, and returns Byte array of data. (Defined by StreamExtensions.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.OnReceivedChannelFrame Method

Grid Solutions Framework FrameParserOnReceivedChannelFrame Method
Casts the parsed IChannelFrame to its specific implementation (i.e., DataFrame or ConfigurationFrame).

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnReceivedChannelFrame(
    IChannelFrame frame
)
Protected Overrides Sub OnReceivedChannelFrame (
    frame As IChannelFrame
)
abstract OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
override OnReceivedChannelFrame :
        frame : IChannelFrame -> unit
function OnReceivedChannelFrame(frame);
protected:
virtual void OnReceivedChannelFrame(
    IChannelFrame^ frame
) override

Parameters

frame
Type: GSF.PhasorProtocolsIChannelFrame
IChannelFrame that was parsed by FrameImageParserBaseTTypeIdentifier, TOutputType that implements protocol specific common frame header interface.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.Parse Method

Grid Solutions Framework FrameParserParse Method
Overload List
 | Name | Description
Public method | Parse(ISupportBinaryImage) | Obsolete. Not implemented. Consumers should call the Parse(TSourceIdentifier, ISupportBinaryImage) method instead to make sure data source source ID gets tracked with data buffer. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, ISupportBinaryImage) | Queues the object implementing the ISupportBinaryImage interface, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(TSourceIdentifier, Byte) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public method | Parse(SourceChannel, Byte, Int32, Int32) | Queues a sequence of bytes, from the specified data source, onto the stream for parsing. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeParse(TSourceIdentifier, Byte, Int32, Int32).)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.Parse Method (SourceChannel, Byte[], Int32, Int32)

Grid Solutions Framework FrameParserParse Method (SourceChannel, Byte, Int32, Int32)
Queues a sequence of bytes, from the specified data source, onto the stream for parsing.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Parse(
    SourceChannel source,
    byte[] buffer,
    int offset,
    int count
)
Public Overrides Sub Parse (
    source As SourceChannel,
    buffer As Byte(),
    offset As Integer,
    count As Integer
)
abstract Parse :
        source : SourceChannel *
        buffer : byte[] *
        offset : int *
        count : int -> unit
override Parse :
        source : SourceChannel *
        buffer : byte[] *
        offset : int *
        count : int -> unit
function Parse(source, buffer, offset, count);
public:
virtual void Parse(
    SourceChannel source,
    array<unsigned char>^ buffer,
    int offset,
    int count
) override

Parameters

source
Type: GSF.PhasorProtocolsSourceChannel
Identifier of the data source.
buffer
Type: SystemByte
An array of bytes. This method copies count bytes from buffer to the queue.
offset
Type: SystemInt32
The zero-based byte offset in buffer at which to begin copying bytes to the current stream.
count
Type: SystemInt32
The number of bytes to be written to the current stream.
See Also

Reference

FrameParser Class
Parse Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.ParseCommonHeader Method

Grid Solutions Framework FrameParserParseCommonHeader Method
Parses a common header instance that implements ICommonHeaderTTypeIdentifier for the output type represented in the binary image.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ICommonHeader<int> ParseCommonHeader(
    byte[] buffer,
    int offset,
    int length
)
Protected Overrides Function ParseCommonHeader (
    buffer As Byte(),
    offset As Integer,
    length As Integer
) As ICommonHeader(Of Integer)
abstract ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<int>
override ParseCommonHeader :
        buffer : byte[] *
        offset : int *
        length : int -> ICommonHeader<int>
function ParseCommonHeader(buffer, offset, length);
protected:
virtual ICommonHeader<int>^ ParseCommonHeader(
    array<unsigned char>^ buffer,
    int offset,
    int length
) override

Parameters

buffer
Type: SystemByte
Buffer containing data to parse.
offset
Type: SystemInt32
Offset index into buffer that represents where to start parsing.
length
Type: SystemInt32
Maximum length of valid data from offset.

Return Value

Type: ICommonHeader Int32
The ICommonHeaderTTypeIdentifier which includes a type ID for the Type to be parsed.
Remarks

Derived classes need to provide a common header instance (i.e., class that implements ICommonHeaderTTypeIdentifier) for the output types; this will primarily include an ID of the Type that the data image represents. This parsing is only for common header information, actual parsing will be handled by output type via its ParseBinaryImage(Byte, Int32, Int32) method. This header image should also be used to add needed complex state information about the output type being parsed if needed.

If there is not enough buffer available to parse common header (as determined by length), return null. Also, if the protocol allows frame length to be determined at the time common header is being parsed and there is not enough buffer to parse the entire frame, it will be optimal to prevent further parsing by returning null.

See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Overload List
 | Name | Description
Public method | Start | Start the data parser. (Overrides MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputTypeStart.)
Public method | Start(IEnumerableType) | Starts the data parser given the specified type implementations. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.Start Method

Grid Solutions Framework FrameParserStart Method
Start the data parser.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IBinaryImageParserStart
IBinaryImageParserStart
See Also

Reference

FrameParser Class
Start Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser Properties

Grid Solutions Framework FrameParser Properties

The FrameParser type exposes the following members.

Properties
 | Name | Description
Public property | CanRead | Gets a value indicating whether the current stream supports reading. (Inherited from BinaryImageParserBase.)
Public property | CanSeek | Gets a value indicating whether the current stream supports seeking. (Inherited from BinaryImageParserBase.)
Public property | CanTimeout | Gets a value that determines whether the current stream can time out. (Inherited from Stream.)
Public property | CanWrite | Gets a value indicating whether the current stream supports writing. (Inherited from BinaryImageParserBase.)
Public property | CheckSumValidationFrameTypes | Gets or sets flags that determine if check-sums for specified frames should be validated. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | ConfigurationFrame | Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device. (Overrides FrameParserBaseTFrameIdentifierConfigurationFrame.)
Public property | ConnectionParameters | Gets or sets any connection specific IConnectionParameters that may be needed for parsing. (Overrides FrameParserBaseTFrameIdentifierConnectionParameters.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the frame image parser is currently enabled. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | Length | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | MessagePeriod | Gets or sets the desired message period for the SEL device.
Public property | Name | Gets the name of BinaryImageParserBase. (Inherited from BinaryImageParserBase.)
Public property | Position | The parser is designed as a write only stream, so this method is not implemented. (Inherited from BinaryImageParserBase.)
Public property | ProtocolSyncBytes | Gets or sets synchronization bytes for this parsing implementation, if used. (Inherited from BinaryImageParserBase.)
Public property | ProtocolUsesSyncBytes | Gets flag that determines if SEL Fast Message protocol parsing implementation uses synchronization bytes. (Overrides BinaryImageParserBaseProtocolUsesSyncBytes.)
Public property | QueuedBuffers | Gets the total number of buffers that are currently queued for processing, if any. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Public property | QueuedOutputs | Gets the total number of parsed outputs that are currently queued for publication, if any. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public property | ReadTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to read before timing out. (Inherited from Stream.)
Public property | RedundantFramesPerPacket | Gets the number of redundant frames in each packet. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | RunTime | Gets the total amount of time, in seconds, that the BinaryImageParserBase has been active. (Inherited from BinaryImageParserBase.)
Public property | Status | Gets current descriptive status of the FrameParser. (Overrides FrameParserBaseTFrameIdentifierStatus.)
Public property | TotalProcessedBuffers | Gets the total number of buffer images processed so far. (Inherited from BinaryImageParserBase.)
Public property | TrustHeaderLength | Gets or sets flag that determines if header lengths should be trusted over parsed byte count. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateCommandFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if command frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateConfigurationFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if configuration frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateDataFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if data frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Protected property | ValidateHeaderFrameCheckSum | Gets flag based on CheckSumValidationFrameTypes property that determines if header frames are selected for check-sum validation. (Inherited from FrameParserBaseTFrameIdentifier.)
Public property | WriteTimeout | Gets or sets a value, in miliseconds, that determines how long the stream will attempt to write before timing out. (Inherited from Stream.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.ConfigurationFrame Property

Grid Solutions Framework FrameParserConfigurationFrame Property
Gets or sets current IConfigurationFrame used for parsing IDataFrame's encountered in the data stream from a device.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConfigurationFrame ConfigurationFrame { get; set; }
Public Overrides Property ConfigurationFrame As IConfigurationFrame
    Get
    Set
abstract ConfigurationFrame : IConfigurationFrame with get, set
override ConfigurationFrame : IConfigurationFrame with get, set
function get_ConfigurationFrame();
function set_ConfigurationFrame(value);
public:
virtual property IConfigurationFrame^ ConfigurationFrame {
    IConfigurationFrame^ get () override;
    void set (IConfigurationFrame^ value) override;
}

Property Value

Type: IConfigurationFrame

Implements

IFrameParserConfigurationFrame
Remarks
If a IConfigurationFrame has been parsed, this will return a reference to the parsed frame. Consumer can manually assign a IConfigurationFrame to start parsing data if one has not been encountered in the stream.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.ConnectionParameters Property

Grid Solutions Framework FrameParserConnectionParameters Property
Gets or sets any connection specific IConnectionParameters that may be needed for parsing.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override IConnectionParameters ConnectionParameters { get; set; }
Public Overrides Property ConnectionParameters As IConnectionParameters
    Get
    Set
abstract ConnectionParameters : IConnectionParameters with get, set
override ConnectionParameters : IConnectionParameters with get, set
function get_ConnectionParameters();
function set_ConnectionParameters(value);
public:
virtual property IConnectionParameters^ ConnectionParameters {
    IConnectionParameters^ get () override;
    void set (IConnectionParameters^ value) override;
}

Property Value

Type: IConnectionParameters

Implements

IFrameParserConnectionParameters
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.MessagePeriod Property

Grid Solutions Framework FrameParserMessagePeriod Property
Gets or sets the desired message period for the SEL device.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MessagePeriod MessagePeriod { get; set; }
Public Property MessagePeriod As MessagePeriod
    Get
    Set
member MessagePeriod : MessagePeriod with get, set

function get_MessagePeriod();
function set_MessagePeriod(value);
public:
property MessagePeriod MessagePeriod {
    MessagePeriod get ();
    void set (MessagePeriod value);
}

Property Value

Type: MessagePeriod
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.ProtocolUsesSyncBytes Property

Grid Solutions Framework FrameParserProtocolUsesSyncBytes Property
Gets flag that determines if SEL Fast Message protocol parsing implementation uses synchronization bytes.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ProtocolUsesSyncBytes { get; }
Public Overrides ReadOnly Property ProtocolUsesSyncBytes As Boolean
    Get
abstract ProtocolUsesSyncBytes : bool with get
override ProtocolUsesSyncBytes : bool with get
function get_ProtocolUsesSyncBytes();

public:
virtual property bool ProtocolUsesSyncBytes {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.Status Property

Grid Solutions Framework FrameParserStatus Property
Gets current descriptive status of the FrameParser.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser Events

Grid Solutions Framework FrameParser Events

The FrameParser type exposes the following members.

Events
 | Name | Description
Public event | BufferParsed | Occurs when buffer parsing has completed. (Inherited from BinaryImageParserBase.)
Public event | ConfigurationChanged | Occurs when a device sends a notification that its configuration has changed. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | DataDiscarded | Occurs when data image fails deserialized due to an exception. (Inherited from BinaryImageParserBase.)
Public event | DataParsed | Occurs when a data image is deserialized successfully to one of the output types that the data image represents. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | DuplicateTypeHandlerEncountered | Occurs when more than one type has been defined that can deserialize the specified output type. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | OutputTypeNotFound | Occurs when matching an output type for deserializing the data image could not be found. (Inherited from FrameImageParserBaseTTypeIdentifier, TOutputType.)
Public event | ParsingException | Occurs when an Exception is encountered while attempting to parse data. (Inherited from BinaryImageParserBase.)
Public event | ReceivedCommandFrame | Occurs when a ICommandFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedConfigurationFrame | Occurs when a SEL Fast Message ConfigurationFrame has been received.
Public event | ReceivedDataFrame | Occurs when a SEL Fast Message DataFrame has been received.
Public event | ReceivedFrameBufferImage | Occurs when a frame image has been received, event includes buffer. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedFrameImage | Occurs when a frame image has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedHeaderFrame | Occurs when a IHeaderFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | ReceivedUndeterminedFrame | Occurs when an undetermined IChannelFrame has been received. (Inherited from FrameParserBaseTFrameIdentifier.)
Public event | SourceDataParsed | Occurs when a data image is deserialized successfully to one or more of the output types that the data image represents. (Inherited from MultiSourceFrameImageParserBaseTSourceIdentifier, TTypeIdentifier, TOutputType.)
Top
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.ReceivedConfigurationFrame Event

Grid Solutions Framework FrameParserReceivedConfigurationFrame Event
Occurs when a SEL Fast Message ConfigurationFrame has been received.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ConfigurationFrame>> ReceivedConfigurationFrame
Public Event ReceivedConfigurationFrame As EventHandler(Of EventArgs(Of ConfigurationFrame))
member ReceivedConfigurationFrame : IEvent<EventHandler<EventArgs<ConfigurationFrame>>,
    EventArgs<ConfigurationFrame>>

function add_ReceivedConfigurationFrame(value);
function remove_ReceivedConfigurationFrame(value);
public:
 event EventHandler<EventArgs<ConfigurationFrame^>^>^ ReceivedConfigurationFrame {
    void add (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
    void remove (EventHandler<EventArgs<ConfigurationFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ConfigurationFrame
Remarks
Argument is the ConfigurationFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameParser.ReceivedDataFrame Event

Grid Solutions Framework FrameParserReceivedDataFrame Event
Occurs when a SEL Fast Message DataFrame has been received.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataFrame>> ReceivedDataFrame
Public Event ReceivedDataFrame As EventHandler(Of EventArgs(Of DataFrame))
member ReceivedDataFrame : IEvent<EventHandler<EventArgs<DataFrame>>,
    EventArgs<DataFrame>>

function add_ReceivedDataFrame(value);
function remove_ReceivedDataFrame(value);
public:
 event EventHandler<EventArgs<DataFrame^>^>^ ReceivedDataFrame {
    void add (EventHandler<EventArgs<DataFrame^>^>^ value);
    void remove (EventHandler<EventArgs<DataFrame^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataFrame
Remarks
Argument is the DataFrame that was received.
See Also

Reference

FrameParser Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrameSize Enumeration

Grid Solutions Framework FrameSize Enumeration
SEL Fast Message PMDATA setting frame size enumeration.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum FrameSize
<SerializableAttribute>
Public Enumeration FrameSize
[<SerializableAttribute>]
type FrameSize
GSF.PhasorProtocols.SelFastMessage.FrameSize = function();
GSF.PhasorProtocols.SelFastMessage.FrameSize.createEnum('GSF.PhasorProtocols.SelFastMessage.FrameSize', false);
[SerializableAttribute]
public enum class FrameSize
Members
Member name | Value | Description
V1 | 40 | Positive sequence voltage phasor.
V | 64 | Three-phase and positive sequence voltage phasors.
A | 96 | Three-phase and positive sequence voltage and current phasors.
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition Class

Grid Solutions Framework FrequencyDefinition Class
Represents the SEL Fast Message implementation of a IFrequencyDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsFrequencyDefinitionBase
GSF.PhasorProtocols.SelFastMessageFrequencyDefinition

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyDefinition : FrequencyDefinitionBase
<SerializableAttribute>
Public Class FrequencyDefinition
    Inherits FrequencyDefinitionBase
[<SerializableAttribute>]
type FrequencyDefinition =
    class
        inherit FrequencyDefinitionBase
    end
GSF.PhasorProtocols.SelFastMessage.FrequencyDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.FrequencyDefinition',
    GSF.PhasorProtocols.FrequencyDefinitionBase);
[SerializableAttribute]
public ref class FrequencyDefinition : public FrequencyDefinitionBase

The FrequencyDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition Constructor

Grid Solutions Framework FrequencyDefinition Constructor
Overload List
 | Name | Description
Public method | FrequencyDefinition(IConfigurationCell) | Creates a new FrequencyDefinition.
Protected method | FrequencyDefinition(SerializationInfo, StreamingContext) | Creates a new FrequencyDefinition from serialization parameters.
Public method | FrequencyDefinition(ConfigurationCell, String) | Creates a new FrequencyDefinition from specified parameters.
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition Constructor (IConfigurationCell)

Grid Solutions Framework FrequencyDefinition Constructor (IConfigurationCell)
Creates a new FrequencyDefinition.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> FrequencyDefinition
GSF.PhasorProtocols.SelFastMessage.FrequencyDefinition = function(parent);
public:
FrequencyDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyDefinition
GSF.PhasorProtocols.SelFastMessage.FrequencyDefinition = function(info, context);
protected:
FrequencyDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition Constructor (ConfigurationCell, String)

Grid Solutions Framework FrequencyDefinition Constructor (ConfigurationCell, String)
Creates a new FrequencyDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyDefinition(
    ConfigurationCell parent,
    string label
)
Public Sub New (
    parent As ConfigurationCell,
    label As String
)
new :
        parent : ConfigurationCell *
        label : string -> FrequencyDefinition
GSF.PhasorProtocols.SelFastMessage.FrequencyDefinition = function(parent, label);
public:
FrequencyDefinition(
    ConfigurationCell^ parent,
    String^ label
)

Parameters

parent
Type: GSF.PhasorProtocols.SelFastMessageConfigurationCell
The ConfigurationCell parent of this FrequencyDefinition.
label
Type: SystemString
The label of this FrequencyDefinition.
See Also

Reference

FrequencyDefinition Class
FrequencyDefinition Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition Methods

Grid Solutions Framework FrequencyDefinition Methods

The FrequencyDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition Properties

Grid Solutions Framework FrequencyDefinition Properties

The FrequencyDefinition type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this FrequencyDefinitionBase object. (Inherited from FrequencyDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtOffset | Gets or sets the df/dt offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | DfDtScalingValue | Gets or sets the df/dt scaling value of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | NominalFrequency | Gets the nominal LineFrequency of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Offset | Gets or sets the offset of this FrequencyDefinitionBase. (Inherited from FrequencyDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this FrequencyDefinition.
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Top
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyDefinition.Parent Property

Grid Solutions Framework FrequencyDefinitionParent Property
Gets or sets the ConfigurationCell parent of this FrequencyDefinition.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

FrequencyDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue Class

Grid Solutions Framework FrequencyValue Class
Represents the SEL Fast Message implementation of a IFrequencyValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IFrequencyDefinition
GSF.PhasorProtocolsFrequencyValueBase
GSF.PhasorProtocols.SelFastMessageFrequencyValue

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class FrequencyValue : FrequencyValueBase
<SerializableAttribute>
Public Class FrequencyValue
    Inherits FrequencyValueBase
[<SerializableAttribute>]
type FrequencyValue =
    class
        inherit FrequencyValueBase
    end
GSF.PhasorProtocols.SelFastMessage.FrequencyValue = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.FrequencyValue',
    GSF.PhasorProtocols.FrequencyValueBase);
[SerializableAttribute]
public ref class FrequencyValue : public FrequencyValueBase

The FrequencyValue type exposes the following members.

Constructors
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue Constructor

Grid Solutions Framework FrequencyValue Constructor
Overload List
 | Name | Description
Protected method | FrequencyValue(SerializationInfo, StreamingContext) | Creates a new FrequencyValue from serialization parameters.
Public method | FrequencyValue(IDataCell, IFrequencyDefinition) | Creates a new FrequencyValue.
Public method | FrequencyValue(DataCell, FrequencyDefinition, Double, Double) | Creates a new FrequencyValue from specified parameters.
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework FrequencyValue Constructor (SerializationInfo, StreamingContext)
Creates a new FrequencyValue from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FrequencyValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> FrequencyValue
GSF.PhasorProtocols.SelFastMessage.FrequencyValue = function(info, context);
protected:
FrequencyValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue Constructor (IDataCell, IFrequencyDefinition)

Grid Solutions Framework FrequencyValue Constructor (IDataCell, IFrequencyDefinition)
Creates a new FrequencyValue.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    IDataCell parent,
    IFrequencyDefinition frequencyDefinition
)
Public Sub New (
    parent As IDataCell,
    frequencyDefinition As IFrequencyDefinition
)
new :
        parent : IDataCell *
        frequencyDefinition : IFrequencyDefinition -> FrequencyValue
GSF.PhasorProtocols.SelFastMessage.FrequencyValue = function(parent, frequencyDefinition);
public:
FrequencyValue(
    IDataCell^ parent,
    IFrequencyDefinition^ frequencyDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocolsIFrequencyDefinition
The IFrequencyDefinition associated with this FrequencyValue.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)

Grid Solutions Framework FrequencyValue Constructor (DataCell, FrequencyDefinition, Double, Double)
Creates a new FrequencyValue from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FrequencyValue(
    DataCell parent,
    FrequencyDefinition frequencyDefinition,
    double frequency,
    double dfdt
)
Public Sub New (
    parent As DataCell,
    frequencyDefinition As FrequencyDefinition,
    frequency As Double,
    dfdt As Double
)
new :
        parent : DataCell *
        frequencyDefinition : FrequencyDefinition *
        frequency : float *
        dfdt : float -> FrequencyValue
GSF.PhasorProtocols.SelFastMessage.FrequencyValue = function(parent, frequencyDefinition, frequency, dfdt);
public:
FrequencyValue(
    DataCell^ parent,
    FrequencyDefinition^ frequencyDefinition,
    double frequency,
    double dfdt
)

Parameters

parent
Type: GSF.PhasorProtocols.SelFastMessageDataCell
The DataCell parent of this FrequencyValue.
frequencyDefinition
Type: GSF.PhasorProtocols.SelFastMessageFrequencyDefinition
The FrequencyDefinition associated with this FrequencyValue.
frequency
Type: SystemDouble
The floating point value that represents this FrequencyValue.
dfdt
Type: SystemDouble
The floating point value that represents the change in this FrequencyValue over time.
See Also

Reference

FrequencyValue Class
FrequencyValue Overload
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue Methods

Grid Solutions Framework FrequencyValue Methods

The FrequencyValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from FrequencyValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides FrequencyValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue.ParseBodyImage Method

Grid Solutions Framework FrequencyValueParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue Properties

Grid Solutions Framework FrequencyValue Properties

The FrequencyValue type exposes the following members.

Properties
 | Name | Description
Public property | Attributes | DictionaryTKey, TValue of string based property names and values for the FrequencyValueBase object. (Inherited from FrequencyValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the FrequencyValue object. (Overrides FrequencyValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides FrequencyValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this FrequencyValueBase provides. (Inherited from FrequencyValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the FrequencyDefinition associated with this FrequencyValue.
Public property | DfDt | Gets or sets the floating point value that represents the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Frequency | Gets or sets the floating point value that represents this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of FrequencyValueBase have been assigned a value. (Inherited from FrequencyValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this FrequencyValue.
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | UnscaledDfDt | Gets or sets the unscaled integer representation of the change in this FrequencyValueBase over time. (Inherited from FrequencyValueBase.)
Public property | UnscaledFrequency | Gets or sets the unscaled integer representation of this FrequencyValueBase. (Inherited from FrequencyValueBase.)
Top
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue.BodyImage Property

Grid Solutions Framework FrequencyValueBodyImage Property
Gets the binary body image of the FrequencyValue object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue.BodyLength Property

Grid Solutions Framework FrequencyValueBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
Remarks
The SEL Fast Message protocol provides frequency and df/dt as optional data measurements, so we override the default behavior to account for this change in operation.
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue.Definition Property

Grid Solutions Framework FrequencyValueDefinition Property
Gets or sets the FrequencyDefinition associated with this FrequencyValue.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual FrequencyDefinition Definition { get; set; }
Public Overridable Property Definition As FrequencyDefinition
    Get
    Set
abstract Definition : FrequencyDefinition with get, set
override Definition : FrequencyDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property FrequencyDefinition^ Definition {
    FrequencyDefinition^ get ();
    void set (FrequencyDefinition^ value);
}

Property Value

Type: FrequencyDefinition
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


FrequencyValue.Parent Property

Grid Solutions Framework FrequencyValueParent Property
Gets or sets the DataCell parent of this FrequencyValue.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

FrequencyValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


MessagePeriod Enumeration

Grid Solutions Framework MessagePeriod Enumeration
SEL Fast Message frame rate enumeration.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum MessagePeriod
<SerializableAttribute>
Public Enumeration MessagePeriod
[<SerializableAttribute>]
type MessagePeriod
GSF.PhasorProtocols.SelFastMessage.MessagePeriod = function();
GSF.PhasorProtocols.SelFastMessage.MessagePeriod.createEnum('GSF.PhasorProtocols.SelFastMessage.MessagePeriod', false);
[SerializableAttribute]
public enum class MessagePeriod
Members
Member name | Value | Description
DefaultRate | 0 | Default message rate, 20 messages per second.
TwentyPerSecond | 5 | 20 messages per second.
TenPerSecond | 10 | 10 messages per second.
FivePerSecond | 22 | 5 messages per second.
FourPerSecond | 25 | 4 messages per second.
TwoPerSecond | 50 | 2 messages per second.
OnePerSecond | 100 | 1 packet per second, or 60 messages per minute.
ThirtyPerMinute | 200 | 30 messages per minute, or 1/2 packet per second.
TwentyPerMinute | 300 | 20 messages per minute.
FifteenPerMinute | 400 | 15 messages per minute.
TwelvePerMinute | 500 | 12 messages per minute.
TenPerMinute | 600 | 10 messages per minute.
SixPerMinute | 1000 | 6 messages per minute.
FourPerMinute | 1500 | 4 messages per minute.
ThreePerMinute | 2000 | 3 messages per minute.
TwoPerMinute | 3000 | 2 messages per minute.
OnePerMinute | 6000 | 1 message per minute.
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition Class

Grid Solutions Framework PhasorDefinition Class
Represents the SEL Fast Message implementation of a IPhasorDefinition.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelDefinitionBase
GSF.PhasorProtocolsPhasorDefinitionBase
GSF.PhasorProtocols.SelFastMessagePhasorDefinition

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorDefinition : PhasorDefinitionBase
<SerializableAttribute>
Public Class PhasorDefinition
    Inherits PhasorDefinitionBase
[<SerializableAttribute>]
type PhasorDefinition =
    class
        inherit PhasorDefinitionBase
    end
GSF.PhasorProtocols.SelFastMessage.PhasorDefinition = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.PhasorDefinition',
    GSF.PhasorProtocols.PhasorDefinitionBase);
[SerializableAttribute]
public ref class PhasorDefinition : public PhasorDefinitionBase

The PhasorDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition Constructor

Grid Solutions Framework PhasorDefinition Constructor
Overload List
 | Name | Description
Public method | PhasorDefinition(IConfigurationCell) | Creates a new PhasorDefinition from specified parameters.
Protected method | PhasorDefinition(SerializationInfo, StreamingContext) | Creates a new PhasorDefinition from serialization parameters.
Public method | PhasorDefinition(ConfigurationCell, String, PhasorType, PhasorDefinition) | Creates a new PhasorDefinition from specified parameters.
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition Constructor (IConfigurationCell)

Grid Solutions Framework PhasorDefinition Constructor (IConfigurationCell)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    IConfigurationCell parent
)
Public Sub New (
    parent As IConfigurationCell
)
new :
        parent : IConfigurationCell -> PhasorDefinition
GSF.PhasorProtocols.SelFastMessage.PhasorDefinition = function(parent);
public:
PhasorDefinition(
    IConfigurationCell^ parent
)

Parameters

parent
Type: GSF.PhasorProtocolsIConfigurationCell
The IConfigurationCell parent of this PhasorDefinition.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorDefinition Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorDefinition from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorDefinition(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorDefinition
GSF.PhasorProtocols.SelFastMessage.PhasorDefinition = function(info, context);
protected:
PhasorDefinition(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition Constructor (ConfigurationCell, String, PhasorType, PhasorDefinition)

Grid Solutions Framework PhasorDefinition Constructor (ConfigurationCell, String, PhasorType, PhasorDefinition)
Creates a new PhasorDefinition from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorDefinition(
    ConfigurationCell parent,
    string label,
    PhasorType type,
    PhasorDefinition voltageReference
)
Public Sub New (
    parent As ConfigurationCell,
    label As String,
    type As PhasorType,
    voltageReference As PhasorDefinition
)
new :
        parent : ConfigurationCell *
        label : string *
        type : PhasorType *
        voltageReference : PhasorDefinition -> PhasorDefinition
GSF.PhasorProtocols.SelFastMessage.PhasorDefinition = function(parent, label, type, voltageReference);
public:
PhasorDefinition(
    ConfigurationCell^ parent,
    String^ label,
    PhasorType type,
    PhasorDefinition^ voltageReference
)

Parameters

parent
Type: GSF.PhasorProtocols.SelFastMessageConfigurationCell
The ConfigurationCell parent of this PhasorDefinition.
label
Type: SystemString
The label of this PhasorDefinition.
type
Type: GSF.Units.EEPhasorType
The PhasorType of this PhasorDefinition.
voltageReference
Type: GSF.PhasorProtocols.SelFastMessagePhasorDefinition
The associated IPhasorDefinition that represents the voltage reference (if any).
See Also

Reference

PhasorDefinition Class
PhasorDefinition Overload
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition Methods

Grid Solutions Framework PhasorDefinition Methods

The PhasorDefinition type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | CompareTo(IChannelDefinition) | Compares this instance to a specified IChannelDefinition object and returns an indication of their relative values. (Inherited from ChannelDefinitionBase.)
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Inherited from ChannelDefinitionBase.)
Public method | Equals(IChannelDefinition) | Returns a value indicating whether this instance is equal to specified IChannelDefinition value. (Inherited from ChannelDefinitionBase.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from ChannelDefinitionBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorDefinitionBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Inherited from ChannelDefinitionBase.)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Gets the string respresentation of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition Properties

Grid Solutions Framework PhasorDefinition Properties

The PhasorDefinition type exposes the following members.

Properties
 | Name | Description
Public property | AngleFormat | Gets or sets the AngleFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorDefinitionBase object. (Inherited from PhasorDefinitionBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the ChannelDefinitionBase object. (Inherited from ChannelDefinitionBase.)
Protected property | BodyLength | Gets the length of the BodyImage. (Inherited from ChannelDefinitionBase.)
Public property | ConversionFactor | Gets or sets the conversion factor of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | CoordinateFormat | Gets or sets the CoordinateFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | DataFormat | Gets the DataFormat of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Index | Gets or sets the index of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Label | Gets or sets the label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | LabelImage | Gets the binary image of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumLabelLength | Gets the maximum length of the Label of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | MaximumScalingValue | Gets the maximum value for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Offset | Gets or sets the offset of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | Parent | Gets or sets the ConfigurationCell parent of this PhasorDefinition.
Public property | PhasorType | Gets or sets the PhasorType of this PhasorDefinitionBase. (Inherited from PhasorDefinitionBase.)
Public property | ScalePerBit | Gets the scale/bit for the ScalingValue of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | ScalingValue | Gets or sets the integer scaling value of this ChannelDefinitionBase. (Inherited from ChannelDefinitionBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | VoltageReference | Gets or sets the associated IPhasorDefinition that represents the voltage reference (if any). (Inherited from PhasorDefinitionBase.)
Top
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorDefinition.Parent Property

Grid Solutions Framework PhasorDefinitionParent Property
Gets or sets the ConfigurationCell parent of this PhasorDefinition.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ConfigurationCell Parent { get; set; }
Public Overridable Property Parent As ConfigurationCell
    Get
    Set
abstract Parent : ConfigurationCell with get, set
override Parent : ConfigurationCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property ConfigurationCell^ Parent {
    ConfigurationCell^ get ();
    void set (ConfigurationCell^ value);
}

Property Value

Type: ConfigurationCell
See Also

Reference

PhasorDefinition Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Class

Grid Solutions Framework PhasorValue Class
Represents the SEL Fast Message implementation of a IPhasorValue.
Inheritance Hierarchy
SystemObject
GSF.ParsingBinaryImageBase
GSF.PhasorProtocolsChannelBase
GSF.PhasorProtocolsChannelValueBase IPhasorDefinition
GSF.PhasorProtocolsPhasorValueBase
GSF.PhasorProtocols.SelFastMessagePhasorValue

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class PhasorValue : PhasorValueBase
<SerializableAttribute>
Public Class PhasorValue
    Inherits PhasorValueBase
[<SerializableAttribute>]
type PhasorValue =
    class
        inherit PhasorValueBase
    end
GSF.PhasorProtocols.SelFastMessage.PhasorValue = function();

Type.createClass(
    'GSF.PhasorProtocols.SelFastMessage.PhasorValue',
    GSF.PhasorProtocols.PhasorValueBase);
[SerializableAttribute]
public ref class PhasorValue : public PhasorValueBase

The PhasorValue type exposes the following members.

Constructors
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides PhasorValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Overrides PhasorValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides PhasorValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Constructor

Grid Solutions Framework PhasorValue Constructor
Overload List
 | Name | Description
Protected method | PhasorValue(SerializationInfo, StreamingContext) | Creates a new PhasorValue from serialization parameters.
Public method | PhasorValue(IDataCell, IPhasorDefinition) | Creates a new PhasorValue.
Public method | PhasorValue(DataCell, PhasorDefinition, Angle, Double) | Creates a new PhasorValue from specified parameters.
Public method | PhasorValue(DataCell, PhasorDefinition, Double, Double) | Creates a new PhasorValue from specified parameters.
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework PhasorValue Constructor (SerializationInfo, StreamingContext)
Creates a new PhasorValue from serialization parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PhasorValue(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> PhasorValue
GSF.PhasorProtocols.SelFastMessage.PhasorValue = function(info, context);
protected:
PhasorValue(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Constructor (IDataCell, IPhasorDefinition)

Grid Solutions Framework PhasorValue Constructor (IDataCell, IPhasorDefinition)
Creates a new PhasorValue.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    IDataCell parent,
    IPhasorDefinition phasorDefinition
)
Public Sub New (
    parent As IDataCell,
    phasorDefinition As IPhasorDefinition
)
new :
        parent : IDataCell *
        phasorDefinition : IPhasorDefinition -> PhasorValue
GSF.PhasorProtocols.SelFastMessage.PhasorValue = function(parent, phasorDefinition);
public:
PhasorValue(
    IDataCell^ parent,
    IPhasorDefinition^ phasorDefinition
)

Parameters

parent
Type: GSF.PhasorProtocolsIDataCell
The IDataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocolsIPhasorDefinition
The IPhasorDefinition associated with this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Angle, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    Angle angle,
    double magnitude
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    angle As Angle,
    magnitude As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        angle : Angle *
        magnitude : float -> PhasorValue
GSF.PhasorProtocols.SelFastMessage.PhasorValue = function(parent, phasorDefinition, angle, magnitude);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    Angle angle,
    double magnitude
)

Parameters

parent
Type: GSF.PhasorProtocols.SelFastMessageDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.SelFastMessagePhasorDefinition
The PhasorDefinition associated with this PhasorValue.
angle
Type: GSF.UnitsAngle
The Angle value (a.k.a., the argument) of this PhasorValue, in radians.
magnitude
Type: SystemDouble
The magnitude value (a.k.a., the absolute value or modulus) of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)

Grid Solutions Framework PhasorValue Constructor (DataCell, PhasorDefinition, Double, Double)
Creates a new PhasorValue from specified parameters.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorValue(
    DataCell parent,
    PhasorDefinition phasorDefinition,
    double real,
    double imaginary
)
Public Sub New (
    parent As DataCell,
    phasorDefinition As PhasorDefinition,
    real As Double,
    imaginary As Double
)
new :
        parent : DataCell *
        phasorDefinition : PhasorDefinition *
        real : float *
        imaginary : float -> PhasorValue
GSF.PhasorProtocols.SelFastMessage.PhasorValue = function(parent, phasorDefinition, real, imaginary);
public:
PhasorValue(
    DataCell^ parent,
    PhasorDefinition^ phasorDefinition,
    double real,
    double imaginary
)

Parameters

parent
Type: GSF.PhasorProtocols.SelFastMessageDataCell
The DataCell parent of this PhasorValue.
phasorDefinition
Type: GSF.PhasorProtocols.SelFastMessagePhasorDefinition
The PhasorDefinition associated with this PhasorValue.
real
Type: SystemDouble
The real value of this PhasorValue.
imaginary
Type: SystemDouble
The imaginary value of this PhasorValue.
See Also

Reference

PhasorValue Class
PhasorValue Overload
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Methods

Grid Solutions Framework PhasorValue Methods

The PhasorValue type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ChannelBase.)
Protected method | GenerateBodyImage | Generates the binary body image and copies it into the given buffer, for BodyLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateFooterImage | Generates the binary footer image and copies it into the given buffer, for FooterLength bytes. (Inherited from BinaryImageBase.)
Protected method | GenerateHeaderImage | Generates the binary header image and copies it into the given buffer, for HeaderLength bytes. (Inherited from BinaryImageBase.)
Public method | GetCompositeValue | Gets the specified composite value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetMeasurementValueFilterFunction | Gets function used to apply a downsampling filter over a sequence of IMeasurement values. (Inherited from PhasorValueBase.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object. (Inherited from PhasorValueBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from BinaryImageBase.)
Protected method | ParseBodyImage | Parses the binary body image. (Overrides PhasorValueBaseParseBodyImage(Byte, Int32, Int32).)
Protected method | ParseFooterImage | Parses the binary footer image. (Inherited from BinaryImageBase.)
Protected method | ParseHeaderImage | Parses the binary header image. (Inherited from BinaryImageBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue.ParseBodyImage Method

Grid Solutions Framework PhasorValueParseBodyImage Method
Parses the binary body image.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int ParseBodyImage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Overrides Function ParseBodyImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBodyImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBodyImage(buffer, startIndex, length);
protected:
virtual int ParseBodyImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) override

Parameters

buffer
Type: SystemByte
Binary image to parse.
startIndex
Type: SystemInt32
Start index into buffer to begin parsing.
length
Type: SystemInt32
Length of valid data within buffer.

Return Value

Type: Int32
The length of the data that was parsed.
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue Properties

Grid Solutions Framework PhasorValue Properties

The PhasorValue type exposes the following members.

Properties
 | Name | Description
Public property | Angle | Gets or sets the Angle value (a.k.a., the argument) of this PhasorValueBase, in radians. (Inherited from PhasorValueBase.)
Public property | AngleFormat | Gets the AngleFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Attributes | Gets a DictionaryTKey, TValue of string based property names and values for this PhasorValueBase object. (Inherited from PhasorValueBase.)
Public property | BinaryImage | Gets the binary image of the ChannelBase object. (Inherited from ChannelBase.)
Public property | BinaryLength | Gets the length of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | BodyImage | Gets the binary body image of the PhasorValueBase object. (Overrides PhasorValueBaseBodyImage.)
Protected property | BodyLength | Gets the length of the BodyImage. (Overrides PhasorValueBaseBodyLength.)
Public property | CompositeValueCount | Gets total number of composite values that this PhasorValueBase provides. (Inherited from PhasorValueBase.)
Public property | CoordinateFormat | Gets the CoordinateFormat of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | DataFormat | Gets the DataFormat of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Definition | Gets or sets the PhasorDefinition associated with this PhasorValue.
Protected property | FooterImage | Gets the binary footer image of the BinaryImageBase object. (Inherited from ChannelBase.)
Protected property | FooterLength | Gets the length of the footer portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Protected property | HeaderImage | Gets the binary header image of the ChannelBase object. (Inherited from ChannelBase.)
Protected property | HeaderLength | Gets the length of the header portion of the BinaryImageBase object. (Inherited from BinaryImageBase.)
Public property | Imaginary | Gets or sets the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | IsEmpty | Gets boolean value that determines if none of the composite values of PhasorValueBase have been assigned a value. (Inherited from PhasorValueBase.)
Public property | Label | Gets text based label of this ChannelValueBaseT. (Inherited from ChannelValueBaseT.)
Public property | Magnitude | Gets or sets the magnitude value (a.k.a., the absolute value or modulus) of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | Measurements | Gets the composite values of this ChannelValueBaseT as an array of IMeasurement values. (Inherited from ChannelValueBaseT.)
Public property | Parent | Gets or sets the DataCell parent of this PhasorValue.
Public property | Real | Gets or sets the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | State | Gets or sets the parsing state for this ChannelBase object. (Inherited from ChannelBase.)
Public property | Tag | Gets or sets a user definable reference to an object associated with this ChannelBase object. (Inherited from ChannelBase.)
Public property | Type | Gets the PhasorType of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledImaginary | Gets or sets the unscaled integer representation of the imaginary value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Public property | UnscaledReal | Gets or sets the unscaled integer representation of the real value of this PhasorValueBase. (Inherited from PhasorValueBase.)
Top
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue.BodyImage Property

Grid Solutions Framework PhasorValueBodyImage Property
Gets the binary body image of the PhasorValueBase object.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] BodyImage { get; }
Protected Overrides ReadOnly Property BodyImage As Byte()
    Get
abstract BodyImage : byte[] with get
override BodyImage : byte[] with get
function get_BodyImage();

protected:
virtual property array<unsigned char>^ BodyImage {
    array<unsigned char>^ get () override;
}

Property Value

Type: Byte
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue.BodyLength Property

Grid Solutions Framework PhasorValueBodyLength Property
Gets the length of the BodyImage.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override int BodyLength { get; }
Protected Overrides ReadOnly Property BodyLength As Integer
    Get
abstract BodyLength : int with get
override BodyLength : int with get
function get_BodyLength();

protected:
virtual property int BodyLength {
    int get () override;
}

Property Value

Type: Int32
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue.Definition Property

Grid Solutions Framework PhasorValueDefinition Property
Gets or sets the PhasorDefinition associated with this PhasorValue.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhasorDefinition Definition { get; set; }
Public Overridable Property Definition As PhasorDefinition
    Get
    Set
abstract Definition : PhasorDefinition with get, set
override Definition : PhasorDefinition with get, set
function get_Definition();
function set_Definition(value);
public:
virtual property PhasorDefinition^ Definition {
    PhasorDefinition^ get ();
    void set (PhasorDefinition^ value);
}

Property Value

Type: PhasorDefinition
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


PhasorValue.Parent Property

Grid Solutions Framework PhasorValueParent Property
Gets or sets the DataCell parent of this PhasorValue.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataCell Parent { get; set; }
Public Overridable Property Parent As DataCell
    Get
    Set
abstract Parent : DataCell with get, set
override Parent : DataCell with get, set
function get_Parent();
function set_Parent(value);
public:
virtual property DataCell^ Parent {
    DataCell^ get ();
    void set (DataCell^ value);
}

Property Value

Type: DataCell
See Also

Reference

PhasorValue Class
GSF.PhasorProtocols.SelFastMessage Namespace


StatusFlags Enumeration

Grid Solutions Framework StatusFlags Enumeration
SEL Fast Message status word flags enumeration.

Namespace: GSF.PhasorProtocols.SelFastMessage
Assembly: GSF.PhasorProtocols (in GSF.PhasorProtocols.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[FlagsAttribute]
public enum StatusFlags
<SerializableAttribute>
<FlagsAttribute>
Public Enumeration StatusFlags
[<SerializableAttribute>]
[<FlagsAttribute>]
type StatusFlags
GSF.PhasorProtocols.SelFastMessage.StatusFlags = function();
GSF.PhasorProtocols.SelFastMessage.StatusFlags.createEnum('GSF.PhasorProtocols.SelFastMessage.StatusFlags', true);
[SerializableAttribute]
[FlagsAttribute]
public enum class StatusFlags
Members
Member name | Value | Description
TSOK | 1 | Time synchronization OK, 1 when OK.
PMDOK | 2 | Phasor measurement data OK, 1 when OK.
PSV51 | 4 | User programmable bit 1.
PSV52 | 8 | User programmable bit 2.
PSV53 | 16 | User programmable bit 3.
PSV54 | 32 | User programmable bit 4.
PSV55 | 64 | User programmable bit 5.
PSV56 | 128 | User programmable bit 6.
PSV57 | 256 | User programmable bit 7.
PSV58 | 512 | User programmable bit 8.
PSV59 | 1024 | User programmable bit 9.
PSV60 | 2048 | User programmable bit 10.
PSV61 | 4096 | User programmable bit 11.
PSV62 | 8192 | User programmable bit 12.
PSV63 | 16384 | User programmable bit 13.
PSV64 | 32768 | User programmable bit 14.
NoFlags | 0 | No flags.
See Also

Reference

GSF.PhasorProtocols.SelFastMessage Namespace


GSF.PQDIF.Logical Namespace

Grid Solutions Framework GSF.PQDIF.Logical Namespace

[Missing <summary> documentation for "N:GSF.PQDIF.Logical"]

Classes
 | Class | Description
Public class | ChannelDefinition | Represents a channel definition in a PQDIF file. The channel definition resides within a DataSourceRecord and defines a ChannelInstance.
Public class | ChannelInstance | Represents a channel instance in a PQDIF file. A channel instance resides in an ObservationRecord, and is defined by a ChannelDefinition inside the observation record's DataSourceRecord.
Public class | ChannelSetting | Represents a channel setting in a PQDIF file. A channel setting resides in an MonitorSettingsRecord, and is defined by a ChannelDefinition inside the observation record's DataSourceRecord.
Public class | ContainerRecord | Represents the container record in a PQDIF file. There can be only one container record in a PQDIF file, and it is the first physical Record.
Public class | DataSourceRecord | Represents a data source record in a PQDIF file. The data source record contains information about the source of the data in an ObservationRecord.
Public class | Equipment | Power quality equipment and software.
Public class | LogicalParser | Represents a parser which parses the logical structure of a PQDIF file.
Public class | LogicalWriter | Represents a writer used to create files using the PQDIF file format.
Public class | MissingTag | Represents an exception
Public class | MonitorSettingsRecord | Represents a monitor settings record in a PQDIF file.
Public class | ObservationRecord | Represents an observation record in a PQDIF file.
Public class | QuantityCharacteristic | Specifies additional detail about the meaning of the series data.
Public class | QuantityType | The high-level description of the type of quantity which is being captured by a channel.
Public class | SeriesDefinition | Definition of a SeriesInstance.
Public class | SeriesInstance | Represents an instance of a series in a PQDIF file. A series instance resides in a ChannelInstance and is defined by a SeriesDefinition.
Public class | SeriesValueType | Defines tags used to identify different series value types.
Public class | Vendor | Vendors for power quality hardware.
Enumerations
 | Enumeration | Description
Public enumeration | Phase | Phase types.
Public enumeration | QuantityMeasured | Physical quantity under measurement.
Public enumeration | QuantityUnits | Units of data defined in a PQDIF file.
Public enumeration | StorageMethods | Defines flags that determine the how the data is stored in a series instance.


ChannelDefinition Class

Grid Solutions Framework ChannelDefinition Class
Represents a channel definition in a PQDIF file. The channel definition resides within a DataSourceRecord and defines a ChannelInstance.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalChannelDefinition

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ChannelDefinition : IEquatable<ChannelDefinition>
Public Class ChannelDefinition
    Implements IEquatable(Of ChannelDefinition)
type ChannelDefinition =
    class
        interface IEquatable<ChannelDefinition>
    end
GSF.PQDIF.Logical.ChannelDefinition = function();

Type.createClass(
    'GSF.PQDIF.Logical.ChannelDefinition',
    null,
    IEquatable`1);
public ref class ChannelDefinition : IEquatable<ChannelDefinition^>

The ChannelDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelDefinition | Creates a new instance of the ChannelDefinition class.
Top
Methods
 | Name | Description
Public method | AddNewSeriesDefinition | Adds a new series definition to the collection of series definitions in this channel definition.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelDefinition. (Overrides ObjectEquals(Object).)
Public method | Equals(ChannelDefinition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given series definition from the collection of series definitions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ChannelDefinitionIndexTag | Tag that identifies the channel definition index.
ChannelNameTag | Tag that identifies the channel name.
OneSeriesDefinitionTag | Tag that identifies a single series definition within the collection.
PhaseIDTag | Tag that identifies the phase ID.
QuantityMeasuredIDTag | Tag that identifies the quantity measured ID.
QuantityNameTag | Tag that identifies the quantity name.
QuantityTypeIDTag | Tag that identifies the quantity type.
SeriesDefinitionsTag | Tag that identifies the series definitions collection.
Top
Properties
 | Name | Description
Public property | ChannelName | Gets a string identifier for the channel definition.
Public property | DataSource | Gets the data source record in which the channel definition resides.
Public property | Phase | Gets the phase measured by the device.
Public property | PhysicalStructure | Gets the physical structure of the channel definition.
Public property | QuantityMeasured | Gets the physical quantity under measurement (Voltage, Current Power, etc).
Public property | QuantityName | Gets the name of the quantity.
Public property | QuantityTypeID | Gets the quantity type ID, which specifies how the data inside instances of this definition should be interpreted.
Public property | SeriesDefinitions | Gets the series definitions defined in this channel definition.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


ChannelDefinition Constructor

Grid Solutions Framework ChannelDefinition Constructor
Creates a new instance of the ChannelDefinition class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelDefinition(
    CollectionElement physicalStructure,
    DataSourceRecord dataSource
)
Public Sub New (
    physicalStructure As CollectionElement,
    dataSource As DataSourceRecord
)
new :
        physicalStructure : CollectionElement *
        dataSource : DataSourceRecord -> ChannelDefinition
GSF.PQDIF.Logical.ChannelDefinition = function(physicalStructure, dataSource);
public:
ChannelDefinition(
    CollectionElement^ physicalStructure,
    DataSourceRecord^ dataSource
)

Parameters

physicalStructure
Type: GSF.PQDIF.PhysicalCollectionElement
The collection element which is the physical structure of the channel definition.
dataSource
Type: GSF.PQDIF.LogicalDataSourceRecord
The data source in which the channel definition resides.
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition Fields

Grid Solutions Framework ChannelDefinition Fields

The ChannelDefinition type exposes the following members.

Fields
Name | Description
ChannelDefinitionIndexTag | Tag that identifies the channel definition index.
ChannelNameTag | Tag that identifies the channel name.
OneSeriesDefinitionTag | Tag that identifies a single series definition within the collection.
PhaseIDTag | Tag that identifies the phase ID.
QuantityMeasuredIDTag | Tag that identifies the quantity measured ID.
QuantityNameTag | Tag that identifies the quantity name.
QuantityTypeIDTag | Tag that identifies the quantity type.
SeriesDefinitionsTag | Tag that identifies the series definitions collection.
Top
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.ChannelDefinitionIndexTag Field

Grid Solutions Framework ChannelDefinitionChannelDefinitionIndexTag Field
Tag that identifies the channel definition index.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ChannelDefinitionIndexTag
Public Shared ReadOnly ChannelDefinitionIndexTag As Guid
static val ChannelDefinitionIndexTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.ChannelDefinitionIndexTag
public:
static initonly Guid ChannelDefinitionIndexTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.ChannelNameTag Field

Grid Solutions Framework ChannelDefinitionChannelNameTag Field
Tag that identifies the channel name.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ChannelNameTag
Public Shared ReadOnly ChannelNameTag As Guid
static val ChannelNameTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.ChannelNameTag
public:
static initonly Guid ChannelNameTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.OneSeriesDefinitionTag Field

Grid Solutions Framework ChannelDefinitionOneSeriesDefinitionTag Field
Tag that identifies a single series definition within the collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid OneSeriesDefinitionTag
Public Shared ReadOnly OneSeriesDefinitionTag As Guid
static val OneSeriesDefinitionTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.OneSeriesDefinitionTag
public:
static initonly Guid OneSeriesDefinitionTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.PhaseIDTag Field

Grid Solutions Framework ChannelDefinitionPhaseIDTag Field
Tag that identifies the phase ID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PhaseIDTag
Public Shared ReadOnly PhaseIDTag As Guid
static val PhaseIDTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.PhaseIDTag
public:
static initonly Guid PhaseIDTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.QuantityMeasuredIDTag Field

Grid Solutions Framework ChannelDefinitionQuantityMeasuredIDTag Field
Tag that identifies the quantity measured ID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QuantityMeasuredIDTag
Public Shared ReadOnly QuantityMeasuredIDTag As Guid
static val QuantityMeasuredIDTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.QuantityMeasuredIDTag
public:
static initonly Guid QuantityMeasuredIDTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.QuantityNameTag Field

Grid Solutions Framework ChannelDefinitionQuantityNameTag Field
Tag that identifies the quantity name.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QuantityNameTag
Public Shared ReadOnly QuantityNameTag As Guid
static val QuantityNameTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.QuantityNameTag
public:
static initonly Guid QuantityNameTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.QuantityTypeIDTag Field

Grid Solutions Framework ChannelDefinitionQuantityTypeIDTag Field
Tag that identifies the quantity type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QuantityTypeIDTag
Public Shared ReadOnly QuantityTypeIDTag As Guid
static val QuantityTypeIDTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.QuantityTypeIDTag
public:
static initonly Guid QuantityTypeIDTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.SeriesDefinitionsTag Field

Grid Solutions Framework ChannelDefinitionSeriesDefinitionsTag Field
Tag that identifies the series definitions collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesDefinitionsTag
Public Shared ReadOnly SeriesDefinitionsTag As Guid
static val SeriesDefinitionsTag: Guid
var GSF.PQDIF.Logical.ChannelDefinition.SeriesDefinitionsTag
public:
static initonly Guid SeriesDefinitionsTag

Field Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition Methods

Grid Solutions Framework ChannelDefinition Methods

The ChannelDefinition type exposes the following members.

Methods
 | Name | Description
Public method | AddNewSeriesDefinition | Adds a new series definition to the collection of series definitions in this channel definition.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelDefinition. (Overrides ObjectEquals(Object).)
Public method | Equals(ChannelDefinition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given series definition from the collection of series definitions.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.AddNewSeriesDefinition Method

Grid Solutions Framework ChannelDefinitionAddNewSeriesDefinition Method
Adds a new series definition to the collection of series definitions in this channel definition.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SeriesDefinition AddNewSeriesDefinition()
Public Function AddNewSeriesDefinition As SeriesDefinition
member AddNewSeriesDefinition : unit -> SeriesDefinition

function AddNewSeriesDefinition();
public:
SeriesDefinition^ AddNewSeriesDefinition()

Return Value

Type: SeriesDefinition

[Missing <returns> documentation for "M:GSF.PQDIF.Logical.ChannelDefinition.AddNewSeriesDefinition"]

See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.Equals Method

Grid Solutions Framework ChannelDefinitionEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current ChannelDefinition. (Overrides ObjectEquals(Object).)
Public method | Equals(ChannelDefinition) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.Equals Method (Object)

Grid Solutions Framework ChannelDefinitionEquals Method (Object)
Determines whether the specified Object is equal to the current ChannelDefinition.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

ChannelDefinition Class
Equals Overload
GSF.PQDIF.Logical Namespace


ChannelDefinition.Equals Method (ChannelDefinition)

Grid Solutions Framework ChannelDefinitionEquals Method (ChannelDefinition)
Indicates whether the current object is equal to another object of the same type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    ChannelDefinition other
)
Public Function Equals (
    other As ChannelDefinition
) As Boolean
abstract Equals :
        other : ChannelDefinition -> bool
override Equals :
        other : ChannelDefinition -> bool
function Equals(other);
public:
virtual bool Equals(
    ChannelDefinition^ other
) sealed

Parameters

other
Type: GSF.PQDIF.LogicalChannelDefinition
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

ChannelDefinition Class
Equals Overload
GSF.PQDIF.Logical Namespace


ChannelDefinition.GetHashCode Method

Grid Solutions Framework ChannelDefinitionGetHashCode Method
Serves as a hash function for a particular type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current ChannelDefinition.
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.Remove Method

Grid Solutions Framework ChannelDefinitionRemove Method
Removes the given series definition from the collection of series definitions.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    SeriesDefinition seriesDefinition
)
Public Sub Remove (
    seriesDefinition As SeriesDefinition
)
member Remove :
        seriesDefinition : SeriesDefinition -> unit

function Remove(seriesDefinition);
public:
void Remove(
    SeriesDefinition^ seriesDefinition
)

Parameters

seriesDefinition
Type: GSF.PQDIF.LogicalSeriesDefinition
The series definition to be removed.
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition Properties

Grid Solutions Framework ChannelDefinition Properties

The ChannelDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ChannelName | Gets a string identifier for the channel definition.
Public property | DataSource | Gets the data source record in which the channel definition resides.
Public property | Phase | Gets the phase measured by the device.
Public property | PhysicalStructure | Gets the physical structure of the channel definition.
Public property | QuantityMeasured | Gets the physical quantity under measurement (Voltage, Current Power, etc).
Public property | QuantityName | Gets the name of the quantity.
Public property | QuantityTypeID | Gets the quantity type ID, which specifies how the data inside instances of this definition should be interpreted.
Public property | SeriesDefinitions | Gets the series definitions defined in this channel definition.
Top
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.ChannelName Property

Grid Solutions Framework ChannelDefinitionChannelName Property
Gets a string identifier for the channel definition.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ChannelName { get; set; }
Public Property ChannelName As String
    Get
    Set
member ChannelName : string with get, set

function get_ChannelName();
function set_ChannelName(value);
public:
property String^ ChannelName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.DataSource Property

Grid Solutions Framework ChannelDefinitionDataSource Property
Gets the data source record in which the channel definition resides.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSourceRecord DataSource { get; }
Public ReadOnly Property DataSource As DataSourceRecord
    Get
member DataSource : DataSourceRecord with get

function get_DataSource();

public:
property DataSourceRecord^ DataSource {
    DataSourceRecord^ get ();
}

Property Value

Type: DataSourceRecord
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.Phase Property

Grid Solutions Framework ChannelDefinitionPhase Property
Gets the phase measured by the device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Phase Phase { get; set; }
Public Property Phase As Phase
    Get
    Set
member Phase : Phase with get, set

function get_Phase();
function set_Phase(value);
public:
property Phase Phase {
    Phase get ();
    void set (Phase value);
}

Property Value

Type: Phase
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.PhysicalStructure Property

Grid Solutions Framework ChannelDefinitionPhysicalStructure Property
Gets the physical structure of the channel definition.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement PhysicalStructure { get; }
Public ReadOnly Property PhysicalStructure As CollectionElement
    Get
member PhysicalStructure : CollectionElement with get

function get_PhysicalStructure();

public:
property CollectionElement^ PhysicalStructure {
    CollectionElement^ get ();
}

Property Value

Type: CollectionElement
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.QuantityMeasured Property

Grid Solutions Framework ChannelDefinitionQuantityMeasured Property
Gets the physical quantity under measurement (Voltage, Current Power, etc).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public QuantityMeasured QuantityMeasured { get; set; }
Public Property QuantityMeasured As QuantityMeasured
    Get
    Set
member QuantityMeasured : QuantityMeasured with get, set

function get_QuantityMeasured();
function set_QuantityMeasured(value);
public:
property QuantityMeasured QuantityMeasured {
    QuantityMeasured get ();
    void set (QuantityMeasured value);
}

Property Value

Type: QuantityMeasured
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.QuantityName Property

Grid Solutions Framework ChannelDefinitionQuantityName Property
Gets the name of the quantity.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string QuantityName { get; set; }
Public Property QuantityName As String
    Get
    Set
member QuantityName : string with get, set

function get_QuantityName();
function set_QuantityName(value);
public:
property String^ QuantityName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.QuantityTypeID Property

Grid Solutions Framework ChannelDefinitionQuantityTypeID Property
Gets the quantity type ID, which specifies how the data inside instances of this definition should be interpreted.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid QuantityTypeID { get; set; }
Public Property QuantityTypeID As Guid
    Get
    Set
member QuantityTypeID : Guid with get, set

function get_QuantityTypeID();
function set_QuantityTypeID(value);
public:
property Guid QuantityTypeID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelDefinition.SeriesDefinitions Property

Grid Solutions Framework ChannelDefinitionSeriesDefinitions Property
Gets the series definitions defined in this channel definition.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<SeriesDefinition> SeriesDefinitions { get; }
Public ReadOnly Property SeriesDefinitions As IList(Of SeriesDefinition)
    Get
member SeriesDefinitions : IList<SeriesDefinition> with get

function get_SeriesDefinitions();

public:
property IList<SeriesDefinition^>^ SeriesDefinitions {
    IList<SeriesDefinition^>^ get ();
}

Property Value

Type: IList SeriesDefinition
See Also

Reference

ChannelDefinition Class
GSF.PQDIF.Logical Namespace


ChannelInstance Class

Grid Solutions Framework ChannelInstance Class
Represents a channel instance in a PQDIF file. A channel instance resides in an ObservationRecord, and is defined by a ChannelDefinition inside the observation record's DataSourceRecord.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalChannelInstance

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ChannelInstance : IEquatable<ChannelInstance>
Public Class ChannelInstance
    Implements IEquatable(Of ChannelInstance)
type ChannelInstance =
    class
        interface IEquatable<ChannelInstance>
    end
GSF.PQDIF.Logical.ChannelInstance = function();

Type.createClass(
    'GSF.PQDIF.Logical.ChannelInstance',
    null,
    IEquatable`1);
public ref class ChannelInstance : IEquatable<ChannelInstance^>

The ChannelInstance type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelInstance | Creates a new instance of the ChannelInstance class.
Top
Methods
 | Name | Description
Public method | AddNewSeriesInstance | Adds a new series instance to the collection of series instances in this channel instance.
Public method | Equals(Object) | Determines whether the specified ChannelInstance is equal to the current ChannelInstance. (Overrides ObjectEquals(Object).)
Public method | Equals(ChannelInstance) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given series instance from the collection of series instances.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ChannelGroupIDTag | Tag that identifies the channel group ID.
ChannelTriggerModuleNameTag | Tag that identifies the channel trigger module name.
CrossTriggerDeviceNameTag | Tag that identifies the cross trigger device name.
OneSeriesInstanceTag | Tag that identifies a single series instance in the collection.
SeriesInstancesTag | Tag that identifies the series instances collection.
Top
Properties
 | Name | Description
Public property | ChannelDefinitionIndex | Gets the index of the ChannelDefinition which defines the channel instance.
Public property | ChannelGroupID | Gets the identifier for the harmonic or interharmonic group represented by this channel.
Public property | CrossTriggerDeviceName | Gets the name of the device involved in an external cross trigger scenario.
Public property | Definition | Gets the channel definition which defines the channel instance.
Public property | ObservationRecord | Gets the observation record in which the channel instance resides.
Public property | PhysicalStructure | Gets the physical structure of the channel instance.
Public property | SeriesInstances | Gets the series instances contained in this channel.
Public property | Setting | Gets the channel setting which defines the instrument settings for the channel.
Public property | TriggerModuleName | Gets the name of the of a device specific code or hardware module, algorithm, or rule not necessarily channel based that cause this channel to be recorded.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


ChannelInstance Constructor

Grid Solutions Framework ChannelInstance Constructor
Creates a new instance of the ChannelInstance class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelInstance(
    CollectionElement physicalStructure,
    ObservationRecord observationRecord
)
Public Sub New (
    physicalStructure As CollectionElement,
    observationRecord As ObservationRecord
)
new :
        physicalStructure : CollectionElement *
        observationRecord : ObservationRecord -> ChannelInstance
GSF.PQDIF.Logical.ChannelInstance = function(physicalStructure, observationRecord);
public:
ChannelInstance(
    CollectionElement^ physicalStructure,
    ObservationRecord^ observationRecord
)

Parameters

physicalStructure
Type: GSF.PQDIF.PhysicalCollectionElement
The collection element which is the physical structure of the channel instance.
observationRecord
Type: GSF.PQDIF.LogicalObservationRecord
The observation record in which the channel instance resides.
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance Fields

Grid Solutions Framework ChannelInstance Fields

The ChannelInstance type exposes the following members.

Fields
Name | Description
ChannelGroupIDTag | Tag that identifies the channel group ID.
ChannelTriggerModuleNameTag | Tag that identifies the channel trigger module name.
CrossTriggerDeviceNameTag | Tag that identifies the cross trigger device name.
OneSeriesInstanceTag | Tag that identifies a single series instance in the collection.
SeriesInstancesTag | Tag that identifies the series instances collection.
Top
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.ChannelGroupIDTag Field

Grid Solutions Framework ChannelInstanceChannelGroupIDTag Field
Tag that identifies the channel group ID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ChannelGroupIDTag
Public Shared ReadOnly ChannelGroupIDTag As Guid
static val ChannelGroupIDTag: Guid
var GSF.PQDIF.Logical.ChannelInstance.ChannelGroupIDTag
public:
static initonly Guid ChannelGroupIDTag

Field Value

Type: Guid
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.ChannelTriggerModuleNameTag Field

Grid Solutions Framework ChannelInstanceChannelTriggerModuleNameTag Field
Tag that identifies the channel trigger module name.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ChannelTriggerModuleNameTag
Public Shared ReadOnly ChannelTriggerModuleNameTag As Guid
static val ChannelTriggerModuleNameTag: Guid
var GSF.PQDIF.Logical.ChannelInstance.ChannelTriggerModuleNameTag
public:
static initonly Guid ChannelTriggerModuleNameTag

Field Value

Type: Guid
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.CrossTriggerDeviceNameTag Field

Grid Solutions Framework ChannelInstanceCrossTriggerDeviceNameTag Field
Tag that identifies the cross trigger device name.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CrossTriggerDeviceNameTag
Public Shared ReadOnly CrossTriggerDeviceNameTag As Guid
static val CrossTriggerDeviceNameTag: Guid
var GSF.PQDIF.Logical.ChannelInstance.CrossTriggerDeviceNameTag
public:
static initonly Guid CrossTriggerDeviceNameTag

Field Value

Type: Guid
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.OneSeriesInstanceTag Field

Grid Solutions Framework ChannelInstanceOneSeriesInstanceTag Field
Tag that identifies a single series instance in the collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid OneSeriesInstanceTag
Public Shared ReadOnly OneSeriesInstanceTag As Guid
static val OneSeriesInstanceTag: Guid
var GSF.PQDIF.Logical.ChannelInstance.OneSeriesInstanceTag
public:
static initonly Guid OneSeriesInstanceTag

Field Value

Type: Guid
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.SeriesInstancesTag Field

Grid Solutions Framework ChannelInstanceSeriesInstancesTag Field
Tag that identifies the series instances collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesInstancesTag
Public Shared ReadOnly SeriesInstancesTag As Guid
static val SeriesInstancesTag: Guid
var GSF.PQDIF.Logical.ChannelInstance.SeriesInstancesTag
public:
static initonly Guid SeriesInstancesTag

Field Value

Type: Guid
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance Methods

Grid Solutions Framework ChannelInstance Methods

The ChannelInstance type exposes the following members.

Methods
 | Name | Description
Public method | AddNewSeriesInstance | Adds a new series instance to the collection of series instances in this channel instance.
Public method | Equals(Object) | Determines whether the specified ChannelInstance is equal to the current ChannelInstance. (Overrides ObjectEquals(Object).)
Public method | Equals(ChannelInstance) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given series instance from the collection of series instances.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.AddNewSeriesInstance Method

Grid Solutions Framework ChannelInstanceAddNewSeriesInstance Method
Adds a new series instance to the collection of series instances in this channel instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SeriesInstance AddNewSeriesInstance()
Public Function AddNewSeriesInstance As SeriesInstance
member AddNewSeriesInstance : unit -> SeriesInstance

function AddNewSeriesInstance();
public:
SeriesInstance^ AddNewSeriesInstance()

Return Value

Type: SeriesInstance

[Missing <returns> documentation for "M:GSF.PQDIF.Logical.ChannelInstance.AddNewSeriesInstance"]

See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.Equals Method

Grid Solutions Framework ChannelInstanceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified ChannelInstance is equal to the current ChannelInstance. (Overrides ObjectEquals(Object).)
Public method | Equals(ChannelInstance) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.Equals Method (Object)

Grid Solutions Framework ChannelInstanceEquals Method (Object)
Determines whether the specified ChannelInstance is equal to the current ChannelInstance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

ChannelInstance Class
Equals Overload
GSF.PQDIF.Logical Namespace


ChannelInstance.Equals Method (ChannelInstance)

Grid Solutions Framework ChannelInstanceEquals Method (ChannelInstance)
Indicates whether the current object is equal to another object of the same type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    ChannelInstance other
)
Public Function Equals (
    other As ChannelInstance
) As Boolean
abstract Equals :
        other : ChannelInstance -> bool
override Equals :
        other : ChannelInstance -> bool
function Equals(other);
public:
virtual bool Equals(
    ChannelInstance^ other
) sealed

Parameters

other
Type: GSF.PQDIF.LogicalChannelInstance
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

ChannelInstance Class
Equals Overload
GSF.PQDIF.Logical Namespace


ChannelInstance.GetHashCode Method

Grid Solutions Framework ChannelInstanceGetHashCode Method
Serves as a hash function for a particular type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current ChannelInstance.
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.Remove Method

Grid Solutions Framework ChannelInstanceRemove Method
Removes the given series instance from the collection of series instances.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    SeriesInstance seriesInstance
)
Public Sub Remove (
    seriesInstance As SeriesInstance
)
member Remove :
        seriesInstance : SeriesInstance -> unit

function Remove(seriesInstance);
public:
void Remove(
    SeriesInstance^ seriesInstance
)

Parameters

seriesInstance
Type: GSF.PQDIF.LogicalSeriesInstance
The series instance to be removed.
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance Properties

Grid Solutions Framework ChannelInstance Properties

The ChannelInstance type exposes the following members.

Properties
 | Name | Description
Public property | ChannelDefinitionIndex | Gets the index of the ChannelDefinition which defines the channel instance.
Public property | ChannelGroupID | Gets the identifier for the harmonic or interharmonic group represented by this channel.
Public property | CrossTriggerDeviceName | Gets the name of the device involved in an external cross trigger scenario.
Public property | Definition | Gets the channel definition which defines the channel instance.
Public property | ObservationRecord | Gets the observation record in which the channel instance resides.
Public property | PhysicalStructure | Gets the physical structure of the channel instance.
Public property | SeriesInstances | Gets the series instances contained in this channel.
Public property | Setting | Gets the channel setting which defines the instrument settings for the channel.
Public property | TriggerModuleName | Gets the name of the of a device specific code or hardware module, algorithm, or rule not necessarily channel based that cause this channel to be recorded.
Top
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.ChannelDefinitionIndex Property

Grid Solutions Framework ChannelInstanceChannelDefinitionIndex Property
Gets the index of the ChannelDefinition which defines the channel instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ChannelDefinitionIndex { get; set; }
Public Property ChannelDefinitionIndex As UInteger
    Get
    Set
member ChannelDefinitionIndex : uint32 with get, set

function get_ChannelDefinitionIndex();
function set_ChannelDefinitionIndex(value);
public:
property unsigned int ChannelDefinitionIndex {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.ChannelGroupID Property

Grid Solutions Framework ChannelInstanceChannelGroupID Property
Gets the identifier for the harmonic or interharmonic group represented by this channel.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short ChannelGroupID { get; set; }
Public Property ChannelGroupID As Short
    Get
    Set
member ChannelGroupID : int16 with get, set

function get_ChannelGroupID();
function set_ChannelGroupID(value);
public:
property short ChannelGroupID {
    short get ();
    void set (short value);
}

Property Value

Type: Int16
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.CrossTriggerDeviceName Property

Grid Solutions Framework ChannelInstanceCrossTriggerDeviceName Property
Gets the name of the device involved in an external cross trigger scenario.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CrossTriggerDeviceName { get; set; }
Public Property CrossTriggerDeviceName As String
    Get
    Set
member CrossTriggerDeviceName : string with get, set

function get_CrossTriggerDeviceName();
function set_CrossTriggerDeviceName(value);
public:
property String^ CrossTriggerDeviceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.Definition Property

Grid Solutions Framework ChannelInstanceDefinition Property
Gets the channel definition which defines the channel instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelDefinition Definition { get; }
Public ReadOnly Property Definition As ChannelDefinition
    Get
member Definition : ChannelDefinition with get

function get_Definition();

public:
property ChannelDefinition^ Definition {
    ChannelDefinition^ get ();
}

Property Value

Type: ChannelDefinition
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.ObservationRecord Property

Grid Solutions Framework ChannelInstanceObservationRecord Property
Gets the observation record in which the channel instance resides.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ObservationRecord ObservationRecord { get; }
Public ReadOnly Property ObservationRecord As ObservationRecord
    Get
member ObservationRecord : ObservationRecord with get

function get_ObservationRecord();

public:
property ObservationRecord^ ObservationRecord {
    ObservationRecord^ get ();
}

Property Value

Type: ObservationRecord
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.PhysicalStructure Property

Grid Solutions Framework ChannelInstancePhysicalStructure Property
Gets the physical structure of the channel instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement PhysicalStructure { get; }
Public ReadOnly Property PhysicalStructure As CollectionElement
    Get
member PhysicalStructure : CollectionElement with get

function get_PhysicalStructure();

public:
property CollectionElement^ PhysicalStructure {
    CollectionElement^ get ();
}

Property Value

Type: CollectionElement
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.SeriesInstances Property

Grid Solutions Framework ChannelInstanceSeriesInstances Property
Gets the series instances contained in this channel.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<SeriesInstance> SeriesInstances { get; }
Public ReadOnly Property SeriesInstances As IList(Of SeriesInstance)
    Get
member SeriesInstances : IList<SeriesInstance> with get

function get_SeriesInstances();

public:
property IList<SeriesInstance^>^ SeriesInstances {
    IList<SeriesInstance^>^ get ();
}

Property Value

Type: IList SeriesInstance
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.Setting Property

Grid Solutions Framework ChannelInstanceSetting Property
Gets the channel setting which defines the instrument settings for the channel.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelSetting Setting { get; }
Public ReadOnly Property Setting As ChannelSetting
    Get
member Setting : ChannelSetting with get

function get_Setting();

public:
property ChannelSetting^ Setting {
    ChannelSetting^ get ();
}

Property Value

Type: ChannelSetting
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelInstance.TriggerModuleName Property

Grid Solutions Framework ChannelInstanceTriggerModuleName Property
Gets the name of the of a device specific code or hardware module, algorithm, or rule not necessarily channel based that cause this channel to be recorded.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string TriggerModuleName { get; set; }
Public Property TriggerModuleName As String
    Get
    Set
member TriggerModuleName : string with get, set

function get_TriggerModuleName();
function set_TriggerModuleName(value);
public:
property String^ TriggerModuleName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChannelInstance Class
GSF.PQDIF.Logical Namespace


ChannelSetting Class

Grid Solutions Framework ChannelSetting Class
Represents a channel setting in a PQDIF file. A channel setting resides in an MonitorSettingsRecord, and is defined by a ChannelDefinition inside the observation record's DataSourceRecord.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalChannelSetting

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ChannelSetting
Public Class ChannelSetting
type ChannelSetting =  class end
GSF.PQDIF.Logical.ChannelSetting = function();

Type.createClass(
    'GSF.PQDIF.Logical.ChannelSetting');
public ref class ChannelSetting

The ChannelSetting type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelSetting | Creates a new instance of the ChannelSetting class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasElement | Determines whether an element identified by the given tag exists in this object's physical structure.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
XDMonitorSideRatioTag | Tag that identifies the monitor side ratio.
XDSystemSideRatioTag | Tag that identifies the system side ratio.
Top
Properties
 | Name | Description
Public property | ChannelDefinitionIndex | Gets the index of the ChannelDefinition which defines the channel instance.
Public property | MonitorSettingsRecord | Gets the monitor settings record in which the channel setting resides.
Public property | PhysicalStructure | Gets the physical structure of the channel setting.
Public property | XDMonitorSideRatio | Gets the monitor-side part of the transducer ratio.
Public property | XDSystemSideRatio | Gets the system-side part of the transducer ratio.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


ChannelSetting Constructor

Grid Solutions Framework ChannelSetting Constructor
Creates a new instance of the ChannelSetting class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelSetting(
    CollectionElement physicalStructure,
    MonitorSettingsRecord monitorSettingsRecord
)
Public Sub New (
    physicalStructure As CollectionElement,
    monitorSettingsRecord As MonitorSettingsRecord
)
new :
        physicalStructure : CollectionElement *
        monitorSettingsRecord : MonitorSettingsRecord -> ChannelSetting
GSF.PQDIF.Logical.ChannelSetting = function(physicalStructure, monitorSettingsRecord);
public:
ChannelSetting(
    CollectionElement^ physicalStructure,
    MonitorSettingsRecord^ monitorSettingsRecord
)

Parameters

physicalStructure
Type: GSF.PQDIF.PhysicalCollectionElement
The collection element which is the physical structure of the channel setting.
monitorSettingsRecord
Type: GSF.PQDIF.LogicalMonitorSettingsRecord
The monitor settings record in which the channel setting resides.
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting Fields

Grid Solutions Framework ChannelSetting Fields

The ChannelSetting type exposes the following members.

Fields
Name | Description
XDMonitorSideRatioTag | Tag that identifies the monitor side ratio.
XDSystemSideRatioTag | Tag that identifies the system side ratio.
Top
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.XDMonitorSideRatioTag Field

Grid Solutions Framework ChannelSettingXDMonitorSideRatioTag Field
Tag that identifies the monitor side ratio.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid XDMonitorSideRatioTag
Public Shared ReadOnly XDMonitorSideRatioTag As Guid
static val XDMonitorSideRatioTag: Guid
var GSF.PQDIF.Logical.ChannelSetting.XDMonitorSideRatioTag
public:
static initonly Guid XDMonitorSideRatioTag

Field Value

Type: Guid
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.XDSystemSideRatioTag Field

Grid Solutions Framework ChannelSettingXDSystemSideRatioTag Field
Tag that identifies the system side ratio.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid XDSystemSideRatioTag
Public Shared ReadOnly XDSystemSideRatioTag As Guid
static val XDSystemSideRatioTag: Guid
var GSF.PQDIF.Logical.ChannelSetting.XDSystemSideRatioTag
public:
static initonly Guid XDSystemSideRatioTag

Field Value

Type: Guid
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting Methods

Grid Solutions Framework ChannelSetting Methods

The ChannelSetting type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasElement | Determines whether an element identified by the given tag exists in this object's physical structure.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.HasElement Method

Grid Solutions Framework ChannelSettingHasElement Method
Determines whether an element identified by the given tag exists in this object's physical structure.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasElement(
    Guid tag
)
Public Function HasElement (
    tag As Guid
) As Boolean
member HasElement :
        tag : Guid -> bool

function HasElement(tag);
public:
bool HasElement(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag of the element to search for.

Return Value

Type: Boolean
True if the element exists; false otherwise.
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting Properties

Grid Solutions Framework ChannelSetting Properties

The ChannelSetting type exposes the following members.

Properties
 | Name | Description
Public property | ChannelDefinitionIndex | Gets the index of the ChannelDefinition which defines the channel instance.
Public property | MonitorSettingsRecord | Gets the monitor settings record in which the channel setting resides.
Public property | PhysicalStructure | Gets the physical structure of the channel setting.
Public property | XDMonitorSideRatio | Gets the monitor-side part of the transducer ratio.
Public property | XDSystemSideRatio | Gets the system-side part of the transducer ratio.
Top
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.ChannelDefinitionIndex Property

Grid Solutions Framework ChannelSettingChannelDefinitionIndex Property
Gets the index of the ChannelDefinition which defines the channel instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ChannelDefinitionIndex { get; set; }
Public Property ChannelDefinitionIndex As UInteger
    Get
    Set
member ChannelDefinitionIndex : uint32 with get, set

function get_ChannelDefinitionIndex();
function set_ChannelDefinitionIndex(value);
public:
property unsigned int ChannelDefinitionIndex {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.MonitorSettingsRecord Property

Grid Solutions Framework ChannelSettingMonitorSettingsRecord Property
Gets the monitor settings record in which the channel setting resides.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MonitorSettingsRecord MonitorSettingsRecord { get; }
Public ReadOnly Property MonitorSettingsRecord As MonitorSettingsRecord
    Get
member MonitorSettingsRecord : MonitorSettingsRecord with get

function get_MonitorSettingsRecord();

public:
property MonitorSettingsRecord^ MonitorSettingsRecord {
    MonitorSettingsRecord^ get ();
}

Property Value

Type: MonitorSettingsRecord
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.PhysicalStructure Property

Grid Solutions Framework ChannelSettingPhysicalStructure Property
Gets the physical structure of the channel setting.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement PhysicalStructure { get; }
Public ReadOnly Property PhysicalStructure As CollectionElement
    Get
member PhysicalStructure : CollectionElement with get

function get_PhysicalStructure();

public:
property CollectionElement^ PhysicalStructure {
    CollectionElement^ get ();
}

Property Value

Type: CollectionElement
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.XDMonitorSideRatio Property

Grid Solutions Framework ChannelSettingXDMonitorSideRatio Property
Gets the monitor-side part of the transducer ratio.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double XDMonitorSideRatio { get; set; }
Public Property XDMonitorSideRatio As Double
    Get
    Set
member XDMonitorSideRatio : float with get, set

function get_XDMonitorSideRatio();
function set_XDMonitorSideRatio(value);
public:
property double XDMonitorSideRatio {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ChannelSetting.XDSystemSideRatio Property

Grid Solutions Framework ChannelSettingXDSystemSideRatio Property
Gets the system-side part of the transducer ratio.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double XDSystemSideRatio { get; set; }
Public Property XDSystemSideRatio As Double
    Get
    Set
member XDSystemSideRatio : float with get, set

function get_XDSystemSideRatio();
function set_XDSystemSideRatio(value);
public:
property double XDSystemSideRatio {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ChannelSetting Class
GSF.PQDIF.Logical Namespace


ContainerRecord Class

Grid Solutions Framework ContainerRecord Class
Represents the container record in a PQDIF file. There can be only one container record in a PQDIF file, and it is the first physical Record.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalContainerRecord

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ContainerRecord
Public Class ContainerRecord
type ContainerRecord =  class end
GSF.PQDIF.Logical.ContainerRecord = function();

Type.createClass(
    'GSF.PQDIF.Logical.ContainerRecord');
public ref class ContainerRecord

The ContainerRecord type exposes the following members.

Methods
 | Name | Description
 | CreateContainerRecord | Creates a new container record from the given physical record if the physical record is of type container. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveElement | Removes the element identified by the given tag from the record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
CompressionAlgorithmTag | Tag that identifies the compression algorithm used when writing the PQDIF file.
CompressionStyleTag | Tag that identifies the compression style of the PQDIF file.
CreationTag | Tag that identifies the date and time of creation.
FileNameTag | Tag that identifies the file name.
NotesTag | Tag that identifies the notes stored in the PQDIF file.
VersionInfoTag | Tag that identifies the version info.
Top
Properties
 | Name | Description
Public property | CompatibleMajorVersion | Gets the compatible major version that the file can be read as.
Public property | CompatibleMinorVersion | Gets the compatible minor version that the file can be read as.
Public property | CompressionAlgorithm | Gets the compression algorithm used to compress the PQDIF file.
Public property | CompressionStyle | Gets the style of compression used to compress the PQDIF file.
Public property | Creation | Gets the date and time of file creation.
Public property | FileName | Gets the name of the file at the time the file was written.
Public property | Notes | Gets the notes stored in the file.
Public property | PhysicalRecord | Gets the physical structure of the container record.
Public property | WriterMajorVersion | Gets the major version number of the PQDIF file writer.
Public property | WriterMinorVersion | Gets the minor version number of the PQDIF file writer.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


ContainerRecord Fields

Grid Solutions Framework ContainerRecord Fields

The ContainerRecord type exposes the following members.

Fields
Name | Description
CompressionAlgorithmTag | Tag that identifies the compression algorithm used when writing the PQDIF file.
CompressionStyleTag | Tag that identifies the compression style of the PQDIF file.
CreationTag | Tag that identifies the date and time of creation.
FileNameTag | Tag that identifies the file name.
NotesTag | Tag that identifies the notes stored in the PQDIF file.
VersionInfoTag | Tag that identifies the version info.
Top
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CompressionAlgorithmTag Field

Grid Solutions Framework ContainerRecordCompressionAlgorithmTag Field
Tag that identifies the compression algorithm used when writing the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CompressionAlgorithmTag
Public Shared ReadOnly CompressionAlgorithmTag As Guid
static val CompressionAlgorithmTag: Guid
var GSF.PQDIF.Logical.ContainerRecord.CompressionAlgorithmTag
public:
static initonly Guid CompressionAlgorithmTag

Field Value

Type: Guid
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CompressionStyleTag Field

Grid Solutions Framework ContainerRecordCompressionStyleTag Field
Tag that identifies the compression style of the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CompressionStyleTag
Public Shared ReadOnly CompressionStyleTag As Guid
static val CompressionStyleTag: Guid
var GSF.PQDIF.Logical.ContainerRecord.CompressionStyleTag
public:
static initonly Guid CompressionStyleTag

Field Value

Type: Guid
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CreationTag Field

Grid Solutions Framework ContainerRecordCreationTag Field
Tag that identifies the date and time of creation.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CreationTag
Public Shared ReadOnly CreationTag As Guid
static val CreationTag: Guid
var GSF.PQDIF.Logical.ContainerRecord.CreationTag
public:
static initonly Guid CreationTag

Field Value

Type: Guid
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.FileNameTag Field

Grid Solutions Framework ContainerRecordFileNameTag Field
Tag that identifies the file name.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FileNameTag
Public Shared ReadOnly FileNameTag As Guid
static val FileNameTag: Guid
var GSF.PQDIF.Logical.ContainerRecord.FileNameTag
public:
static initonly Guid FileNameTag

Field Value

Type: Guid
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.NotesTag Field

Grid Solutions Framework ContainerRecordNotesTag Field
Tag that identifies the notes stored in the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid NotesTag
Public Shared ReadOnly NotesTag As Guid
static val NotesTag: Guid
var GSF.PQDIF.Logical.ContainerRecord.NotesTag
public:
static initonly Guid NotesTag

Field Value

Type: Guid
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.VersionInfoTag Field

Grid Solutions Framework ContainerRecordVersionInfoTag Field
Tag that identifies the version info.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid VersionInfoTag
Public Shared ReadOnly VersionInfoTag As Guid
static val VersionInfoTag: Guid
var GSF.PQDIF.Logical.ContainerRecord.VersionInfoTag
public:
static initonly Guid VersionInfoTag

Field Value

Type: Guid
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord Methods

Grid Solutions Framework ContainerRecord Methods

The ContainerRecord type exposes the following members.

Methods
 | Name | Description
 | CreateContainerRecord | Creates a new container record from the given physical record if the physical record is of type container. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveElement | Removes the element identified by the given tag from the record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CreateContainerRecord Method

Grid Solutions Framework ContainerRecordCreateContainerRecord Method
Creates a new container record from the given physical record if the physical record is of type container. Returns null if it is not.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ContainerRecord CreateContainerRecord(
    Record physicalRecord
)
Public Shared Function CreateContainerRecord (
    physicalRecord As Record
) As ContainerRecord
static member CreateContainerRecord :
        physicalRecord : Record -> ContainerRecord

GSF.PQDIF.Logical.ContainerRecord.CreateContainerRecord = function(physicalRecord);
public:
static ContainerRecord^ CreateContainerRecord(
    Record^ physicalRecord
)

Parameters

physicalRecord
Type: GSF.PQDIF.PhysicalRecord
The physical record used to create the container record.

Return Value

Type: ContainerRecord
The new container record, or null if the physical record does not define a container record.
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.RemoveElement Method

Grid Solutions Framework ContainerRecordRemoveElement Method
Removes the element identified by the given tag from the record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveElement(
    Guid tag
)
Public Sub RemoveElement (
    tag As Guid
)
member RemoveElement :
        tag : Guid -> unit

function RemoveElement(tag);
public:
void RemoveElement(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag of the element to be removed.
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord Properties

Grid Solutions Framework ContainerRecord Properties

The ContainerRecord type exposes the following members.

Properties
 | Name | Description
Public property | CompatibleMajorVersion | Gets the compatible major version that the file can be read as.
Public property | CompatibleMinorVersion | Gets the compatible minor version that the file can be read as.
Public property | CompressionAlgorithm | Gets the compression algorithm used to compress the PQDIF file.
Public property | CompressionStyle | Gets the style of compression used to compress the PQDIF file.
Public property | Creation | Gets the date and time of file creation.
Public property | FileName | Gets the name of the file at the time the file was written.
Public property | Notes | Gets the notes stored in the file.
Public property | PhysicalRecord | Gets the physical structure of the container record.
Public property | WriterMajorVersion | Gets the major version number of the PQDIF file writer.
Public property | WriterMinorVersion | Gets the minor version number of the PQDIF file writer.
Top
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CompatibleMajorVersion Property

Grid Solutions Framework ContainerRecordCompatibleMajorVersion Property
Gets the compatible major version that the file can be read as.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint CompatibleMajorVersion { get; set; }
Public Property CompatibleMajorVersion As UInteger
    Get
    Set
member CompatibleMajorVersion : uint32 with get, set

function get_CompatibleMajorVersion();
function set_CompatibleMajorVersion(value);
public:
property unsigned int CompatibleMajorVersion {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CompatibleMinorVersion Property

Grid Solutions Framework ContainerRecordCompatibleMinorVersion Property
Gets the compatible minor version that the file can be read as.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint CompatibleMinorVersion { get; set; }
Public Property CompatibleMinorVersion As UInteger
    Get
    Set
member CompatibleMinorVersion : uint32 with get, set

function get_CompatibleMinorVersion();
function set_CompatibleMinorVersion(value);
public:
property unsigned int CompatibleMinorVersion {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CompressionAlgorithm Property

Grid Solutions Framework ContainerRecordCompressionAlgorithm Property
Gets the compression algorithm used to compress the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompressionAlgorithm CompressionAlgorithm { get; set; }
Public Property CompressionAlgorithm As CompressionAlgorithm
    Get
    Set
member CompressionAlgorithm : CompressionAlgorithm with get, set

function get_CompressionAlgorithm();
function set_CompressionAlgorithm(value);
public:
property CompressionAlgorithm CompressionAlgorithm {
    CompressionAlgorithm get ();
    void set (CompressionAlgorithm value);
}

Property Value

Type: CompressionAlgorithm
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.CompressionStyle Property

Grid Solutions Framework ContainerRecordCompressionStyle Property
Gets the style of compression used to compress the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompressionStyle CompressionStyle { get; set; }
Public Property CompressionStyle As CompressionStyle
    Get
    Set
member CompressionStyle : CompressionStyle with get, set

function get_CompressionStyle();
function set_CompressionStyle(value);
public:
property CompressionStyle CompressionStyle {
    CompressionStyle get ();
    void set (CompressionStyle value);
}

Property Value

Type: CompressionStyle
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.Creation Property

Grid Solutions Framework ContainerRecordCreation Property
Gets the date and time of file creation.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Creation { get; set; }
Public Property Creation As DateTime
    Get
    Set
member Creation : DateTime with get, set

function get_Creation();
function set_Creation(value);
public:
property DateTime Creation {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.FileName Property

Grid Solutions Framework ContainerRecordFileName Property
Gets the name of the file at the time the file was written.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.Notes Property

Grid Solutions Framework ContainerRecordNotes Property
Gets the notes stored in the file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Notes { get; set; }
Public Property Notes As String
    Get
    Set
member Notes : string with get, set

function get_Notes();
function set_Notes(value);
public:
property String^ Notes {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.PhysicalRecord Property

Grid Solutions Framework ContainerRecordPhysicalRecord Property
Gets the physical structure of the container record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Record PhysicalRecord { get; }
Public ReadOnly Property PhysicalRecord As Record
    Get
member PhysicalRecord : Record with get

function get_PhysicalRecord();

public:
property Record^ PhysicalRecord {
    Record^ get ();
}

Property Value

Type: Record
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.WriterMajorVersion Property

Grid Solutions Framework ContainerRecordWriterMajorVersion Property
Gets the major version number of the PQDIF file writer.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint WriterMajorVersion { get; set; }
Public Property WriterMajorVersion As UInteger
    Get
    Set
member WriterMajorVersion : uint32 with get, set

function get_WriterMajorVersion();
function set_WriterMajorVersion(value);
public:
property unsigned int WriterMajorVersion {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


ContainerRecord.WriterMinorVersion Property

Grid Solutions Framework ContainerRecordWriterMinorVersion Property
Gets the minor version number of the PQDIF file writer.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint WriterMinorVersion { get; set; }
Public Property WriterMinorVersion As UInteger
    Get
    Set
member WriterMinorVersion : uint32 with get, set

function get_WriterMinorVersion();
function set_WriterMinorVersion(value);
public:
property unsigned int WriterMinorVersion {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

ContainerRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord Class

Grid Solutions Framework DataSourceRecord Class
Represents a data source record in a PQDIF file. The data source record contains information about the source of the data in an ObservationRecord.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalDataSourceRecord

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataSourceRecord
Public Class DataSourceRecord
type DataSourceRecord =  class end
GSF.PQDIF.Logical.DataSourceRecord = function();

Type.createClass(
    'GSF.PQDIF.Logical.DataSourceRecord');
public ref class DataSourceRecord

The DataSourceRecord type exposes the following members.

Methods
 | Name | Description
Public method | AddNewChannelDefinition | Adds a new channel definition to the collection of channel definitions in this data source record.
 | CreateDataSourceRecord | Creates a new data source record from the given physical record if the physical record is of type data source. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given channel definition from the collection of channel definitions.
Public method | RemoveElement | Removes the element identified by the given tag from the record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ChannelDefinitionsTag | Tag that identifies the channel definitions collection.
DataSourceCoordinatesTag | Tag that identifies the physical location of the data source.
DataSourceNameTag | Tag that identifies the data source name.
DataSourceTypeTag | Tag that identifies the data source type.
EffectiveTag | Tag that identifies the time that the data source record becomes effective.
EquipmentIDTag | Tag that identifies the equipment ID.
OneChannelDefinitionTag | Tag that identifies the a single channel definition in the collection.
VendorIDTag | Tag that identifies the vendor ID.
Top
Properties
 | Name | Description
Public property | ChannelDefinitions | Gets the definitions for the channels defined in the data source.
Public property | DataSourceName | Gets the name of the data source.
Public property | EquipmentID | Gets the ID of the equipment.
Public property | Latitude | Gets the latitude at which the device is located.
Public property | Longitude | Gets the longitude at which the data source is located.
Public property | PhysicalRecord | Gets the physical structure of the data source record.
Public property | VendorID | Gets the ID of the vendor of the data source.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


DataSourceRecord Fields

Grid Solutions Framework DataSourceRecord Fields

The DataSourceRecord type exposes the following members.

Fields
Name | Description
ChannelDefinitionsTag | Tag that identifies the channel definitions collection.
DataSourceCoordinatesTag | Tag that identifies the physical location of the data source.
DataSourceNameTag | Tag that identifies the data source name.
DataSourceTypeTag | Tag that identifies the data source type.
EffectiveTag | Tag that identifies the time that the data source record becomes effective.
EquipmentIDTag | Tag that identifies the equipment ID.
OneChannelDefinitionTag | Tag that identifies the a single channel definition in the collection.
VendorIDTag | Tag that identifies the vendor ID.
Top
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.ChannelDefinitionsTag Field

Grid Solutions Framework DataSourceRecordChannelDefinitionsTag Field
Tag that identifies the channel definitions collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ChannelDefinitionsTag
Public Shared ReadOnly ChannelDefinitionsTag As Guid
static val ChannelDefinitionsTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.ChannelDefinitionsTag
public:
static initonly Guid ChannelDefinitionsTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.DataSourceCoordinatesTag Field

Grid Solutions Framework DataSourceRecordDataSourceCoordinatesTag Field
Tag that identifies the physical location of the data source.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DataSourceCoordinatesTag
Public Shared ReadOnly DataSourceCoordinatesTag As Guid
static val DataSourceCoordinatesTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.DataSourceCoordinatesTag
public:
static initonly Guid DataSourceCoordinatesTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.DataSourceNameTag Field

Grid Solutions Framework DataSourceRecordDataSourceNameTag Field
Tag that identifies the data source name.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DataSourceNameTag
Public Shared ReadOnly DataSourceNameTag As Guid
static val DataSourceNameTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.DataSourceNameTag
public:
static initonly Guid DataSourceNameTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.DataSourceTypeTag Field

Grid Solutions Framework DataSourceRecordDataSourceTypeTag Field
Tag that identifies the data source type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DataSourceTypeTag
Public Shared ReadOnly DataSourceTypeTag As Guid
static val DataSourceTypeTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.DataSourceTypeTag
public:
static initonly Guid DataSourceTypeTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.EffectiveTag Field

Grid Solutions Framework DataSourceRecordEffectiveTag Field
Tag that identifies the time that the data source record becomes effective.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EffectiveTag
Public Shared ReadOnly EffectiveTag As Guid
static val EffectiveTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.EffectiveTag
public:
static initonly Guid EffectiveTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.EquipmentIDTag Field

Grid Solutions Framework DataSourceRecordEquipmentIDTag Field
Tag that identifies the equipment ID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EquipmentIDTag
Public Shared ReadOnly EquipmentIDTag As Guid
static val EquipmentIDTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.EquipmentIDTag
public:
static initonly Guid EquipmentIDTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.OneChannelDefinitionTag Field

Grid Solutions Framework DataSourceRecordOneChannelDefinitionTag Field
Tag that identifies the a single channel definition in the collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid OneChannelDefinitionTag
Public Shared ReadOnly OneChannelDefinitionTag As Guid
static val OneChannelDefinitionTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.OneChannelDefinitionTag
public:
static initonly Guid OneChannelDefinitionTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.VendorIDTag Field

Grid Solutions Framework DataSourceRecordVendorIDTag Field
Tag that identifies the vendor ID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid VendorIDTag
Public Shared ReadOnly VendorIDTag As Guid
static val VendorIDTag: Guid
var GSF.PQDIF.Logical.DataSourceRecord.VendorIDTag
public:
static initonly Guid VendorIDTag

Field Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord Methods

Grid Solutions Framework DataSourceRecord Methods

The DataSourceRecord type exposes the following members.

Methods
 | Name | Description
Public method | AddNewChannelDefinition | Adds a new channel definition to the collection of channel definitions in this data source record.
 | CreateDataSourceRecord | Creates a new data source record from the given physical record if the physical record is of type data source. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given channel definition from the collection of channel definitions.
Public method | RemoveElement | Removes the element identified by the given tag from the record.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.AddNewChannelDefinition Method

Grid Solutions Framework DataSourceRecordAddNewChannelDefinition Method
Adds a new channel definition to the collection of channel definitions in this data source record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelDefinition AddNewChannelDefinition()
Public Function AddNewChannelDefinition As ChannelDefinition
member AddNewChannelDefinition : unit -> ChannelDefinition

function AddNewChannelDefinition();
public:
ChannelDefinition^ AddNewChannelDefinition()

Return Value

Type: ChannelDefinition

[Missing <returns> documentation for "M:GSF.PQDIF.Logical.DataSourceRecord.AddNewChannelDefinition"]

See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.CreateDataSourceRecord Method

Grid Solutions Framework DataSourceRecordCreateDataSourceRecord Method
Creates a new data source record from the given physical record if the physical record is of type data source. Returns null if it is not.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSourceRecord CreateDataSourceRecord(
    Record physicalRecord
)
Public Shared Function CreateDataSourceRecord (
    physicalRecord As Record
) As DataSourceRecord
static member CreateDataSourceRecord :
        physicalRecord : Record -> DataSourceRecord

GSF.PQDIF.Logical.DataSourceRecord.CreateDataSourceRecord = function(physicalRecord);
public:
static DataSourceRecord^ CreateDataSourceRecord(
    Record^ physicalRecord
)

Parameters

physicalRecord
Type: GSF.PQDIF.PhysicalRecord
The physical record used to create the data source record.

Return Value

Type: DataSourceRecord
The new data source record, or null if the physical record does not define a data source record.
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.Remove Method

Grid Solutions Framework DataSourceRecordRemove Method
Removes the given channel definition from the collection of channel definitions.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    ChannelDefinition channelDefinition
)
Public Sub Remove (
    channelDefinition As ChannelDefinition
)
member Remove :
        channelDefinition : ChannelDefinition -> unit

function Remove(channelDefinition);
public:
void Remove(
    ChannelDefinition^ channelDefinition
)

Parameters

channelDefinition
Type: GSF.PQDIF.LogicalChannelDefinition
The channel definition to be removed.
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.RemoveElement Method

Grid Solutions Framework DataSourceRecordRemoveElement Method
Removes the element identified by the given tag from the record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveElement(
    Guid tag
)
Public Sub RemoveElement (
    tag As Guid
)
member RemoveElement :
        tag : Guid -> unit

function RemoveElement(tag);
public:
void RemoveElement(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag of the element to be removed.
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord Properties

Grid Solutions Framework DataSourceRecord Properties

The DataSourceRecord type exposes the following members.

Properties
 | Name | Description
Public property | ChannelDefinitions | Gets the definitions for the channels defined in the data source.
Public property | DataSourceName | Gets the name of the data source.
Public property | EquipmentID | Gets the ID of the equipment.
Public property | Latitude | Gets the latitude at which the device is located.
Public property | Longitude | Gets the longitude at which the data source is located.
Public property | PhysicalRecord | Gets the physical structure of the data source record.
Public property | VendorID | Gets the ID of the vendor of the data source.
Top
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.ChannelDefinitions Property

Grid Solutions Framework DataSourceRecordChannelDefinitions Property
Gets the definitions for the channels defined in the data source.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<ChannelDefinition> ChannelDefinitions { get; }
Public ReadOnly Property ChannelDefinitions As IList(Of ChannelDefinition)
    Get
member ChannelDefinitions : IList<ChannelDefinition> with get

function get_ChannelDefinitions();

public:
property IList<ChannelDefinition^>^ ChannelDefinitions {
    IList<ChannelDefinition^>^ get ();
}

Property Value

Type: IList ChannelDefinition
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.DataSourceName Property

Grid Solutions Framework DataSourceRecordDataSourceName Property
Gets the name of the data source.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DataSourceName { get; set; }
Public Property DataSourceName As String
    Get
    Set
member DataSourceName : string with get, set

function get_DataSourceName();
function set_DataSourceName(value);
public:
property String^ DataSourceName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.EquipmentID Property

Grid Solutions Framework DataSourceRecordEquipmentID Property
Gets the ID of the equipment.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid EquipmentID { get; set; }
Public Property EquipmentID As Guid
    Get
    Set
member EquipmentID : Guid with get, set

function get_EquipmentID();
function set_EquipmentID(value);
public:
property Guid EquipmentID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.Latitude Property

Grid Solutions Framework DataSourceRecordLatitude Property
Gets the latitude at which the device is located.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Latitude { get; set; }
Public Property Latitude As UInteger
    Get
    Set
member Latitude : uint32 with get, set

function get_Latitude();
function set_Latitude(value);
public:
property unsigned int Latitude {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.Longitude Property

Grid Solutions Framework DataSourceRecordLongitude Property
Gets the longitude at which the data source is located.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Longitude { get; set; }
Public Property Longitude As UInteger
    Get
    Set
member Longitude : uint32 with get, set

function get_Longitude();
function set_Longitude(value);
public:
property unsigned int Longitude {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.PhysicalRecord Property

Grid Solutions Framework DataSourceRecordPhysicalRecord Property
Gets the physical structure of the data source record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Record PhysicalRecord { get; }
Public ReadOnly Property PhysicalRecord As Record
    Get
member PhysicalRecord : Record with get

function get_PhysicalRecord();

public:
property Record^ PhysicalRecord {
    Record^ get ();
}

Property Value

Type: Record
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


DataSourceRecord.VendorID Property

Grid Solutions Framework DataSourceRecordVendorID Property
Gets the ID of the vendor of the data source.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid VendorID { get; set; }
Public Property VendorID As Guid
    Get
    Set
member VendorID : Guid with get, set

function get_VendorID();
function set_VendorID(value);
public:
property Guid VendorID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

DataSourceRecord Class
GSF.PQDIF.Logical Namespace


Equipment Class

Grid Solutions Framework Equipment Class
Power quality equipment and software.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalEquipment

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Equipment
Public NotInheritable Class Equipment
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Equipment =  class end
GSF.PQDIF.Logical.Equipment = function();

Type.createClass(
    'GSF.PQDIF.Logical.Equipment');
public ref class Equipment abstract sealed

The Equipment type exposes the following members.

Methods
Name | Description
ToString | Converts the given equpiment ID to a string containing the name of the equipment.
Top
Fields
Name | Description
AcumentricsControl | The ID of the Acumentrics Control device.
AdvanTechADAM4017 | The ID of the AdvanTech ADAM 4017 device.
AdvanTechADAM4018 | The ID of the AdvanTech ADAM 4018 device.
AdvanTechADAM4018M | The ID of the AdvanTech ADAM 4018M device.
AdvanTechADAM4050 | The ID of the AdvanTech ADAM 4050 device.
AdvanTechADAM4052 | The ID of the AdvanTech ADAM 4052 device.
AdvanTechADAM4053 | The ID of the AdvanTech ADAM 4053 device.
AdvanTechADAM4080 | The ID of the AdvanTech ADAM 4080 device.
AdvanTechADAM5017 | The ID of the AdvanTech ADAM 5017 device.
AdvanTechADAM5018 | The ID of the AdvanTech ADAM 5018 device.
AdvanTechADAM5050 | The ID of the AdvanTech ADAM 5050 device.
AdvanTechADAM5051 | The ID of the AdvanTech ADAM 5051 device.
AdvanTechADAM5052 | The ID of the AdvanTech ADAM 5052 device.
AdvanTechADAM5080 | The ID of the AdvanTech ADAM 5080 device.
BMI3100 | The ID of the BMI 3100 device.
BMI7100 | The ID of the BMI 7100 device.
BMI8010 | The ID of the BMI 7100 device.
BMI8020 | The ID of the BMI 7100 device.
BMI8800 | The ID of the BMI 8800 device.
BMI9010 | The ID of the BMI 7100 device.
CooperVFlicker | The ID of the Cooper V-Flicker device.
CooperVHarm | The ID of the Cooper V-Harm device.
DCGEMTP | The ID of the DCG EMTP device.
Dranetz656 | The ID of the Dranetz 656 device.
Dranetz658 | The ID of the Dranetz 658 device.
Dranetz8000 | The ID of the Dranetz 8000 device.
ELCOMBK550 | The ID of the ELCOM BK 550 device.
ETKDSS | The ID of ETK DSS.
ETKHarmoni | The ID of Electrotek Harmoni.
ETKNodeCenter | The ID of Electrotek Node Center.
ETKPASS | The ID of Electrotek PASS.
ETKPQDIFEditor | The ID of the Electrotek PQDIF editor.
ETKPQView | The ID of Electrotek PQView.
ETKPQWeb | The ID of Electrotek PQWeb.
ETKSuperHarm | The ID of Electrotek Super-Harm.
ETKSuperTran | The ID of Electrotek Super-Tran.
ETKTestProgram | The ID of the Electrotek test program.
ETKTextPQDIF | The ID of Electrotek Text PQDIF.
ETKTOP | The ID of Electrotek TOP.
EWON4000 | The ID of the EWON 4000 device.
FlukeCUR | The ID of the Fluke CUR device.
FlukeF41 | The ID of the Fluke F41 device.
GEKV | The ID of the GE kV Energy Meter.
GEKV2 | The ID of the GE kV2 Energy Meter.
IEEECOMTRADE | The ID of IEEE COMTRADE.
LEMAnalyst1Q | The ID of the LEM Analyst 1Q device.
LEMAnalyst2050 | The ID of the LEM Analyst 2050 device.
LEMAnalyst2060 | The ID of the LEM Analyst 2060 device.
LEMAnalyst3Q | The ID of the LEM Analyst 3Q device.
LEMBEN5000 | The ID of the LEM BEN 5000 device.
LEMBEN6000 | The ID of the LEM BEN 6000 device.
LEMEWave | The ID of the LEM EWave device.
LEMEWON4000 | The ID of the LEM EWON 4000 device.
LEMMBX300 | The ID of the LEM MBX 300 device.
LEMMBX601 | The ID of the LEM MBX 601 device.
LEMMBX602 | The ID of the LEM MBX 602 device.
LEMMBX603 | The ID of the LEM MBX 603 device.
LEMMBX686 | The ID of the LEM MBX 686 device.
LEMMBX800 | The ID of the LEM MBX 800 device.
LEMMidget200 | The ID of the LEM Midget 200 device.
LEMPerma701 | The ID of the LEM Perma 701 device.
LEMPerma702 | The ID of the LEM Perma 702 device.
LEMPerma705 | The ID of the LEM Perma 705 device.
LEMPerma706 | The ID of the LEM Perma 706 device.
LEMQWaveLight | The ID of the LEM QWave Light device.
LEMQWaveMicro | The ID of the LEM QWave Micro device.
LEMQWaveNomad | The ID of the LEM QWave Nomad device.
LEMQWavePowerDistribution | The ID of the LEM QWave Power Distribution device.
LEMQWavePowerTransport | The ID of the LEM QWave Power Transport device.
LEMQWavePremium | The ID of the LEM QWave Premium device.
LEMQWaveTWin | The ID of the LEM QWave TWin device.
LEMTOPAS1000 | The ID of the LEM TOPAS 1000 device.
LEMTOPAS1019 | The ID of the LEM TOPAS 1019 device.
LEMTOPAS1020 | The ID of the LEM TOPAS 1020 device.
LEMTOPAS1040 | The ID of the LEM TOPAS 1040 device.
LEMTOPASLT | The ID of the LEM TOPAS LT device.
Medcal | The ID of the Medcal device.
MetOneELT15 | The ID of the Met One ELT15 device.
MetrosonicM1 | The ID of the Metrosonic M1 device.
PMIScanner | The ID of the PMI scanner.
PML3710 | The ID of the PML 3710 device.
PML3720 | The ID of the PML 3720 device.
PML3800 | The ID of the PML 3800 device.
PML7300 | The ID of the PML 7300 device.
PML7700 | The ID of the PML 7700 device.
PMLLogServer | The ID of the PML Log Server.
PMLVIP | The ID of the PML VIP device.
PublicATP | The ID of public ATP.
Qualimetre | The ID of the Qualimetre device.
QWaveLight | The ID of the QWave Light device.
QWaveMicro | The ID of the QWave Micro device.
QWaveNomad | The ID of the QWave Nomad device.
QWavePowerDistribution | The ID of the QWave Power Distribution device.
QWavePowerTransmission | The ID of the QWave Power Transmission device.
QWavePremium | The ID of the QWave Premium device.
QWaveTWin | The ID of the QWave TWin device.
SQDSMS | The ID of the Square D PowerLogic SMS device.
TelogM1 | The ID of the Telog M1 device.
TrinergiPQM | The ID of the Trinergi Power Quality Meter.
WPT5510 | The ID of the LEM WPT 5510 device.
WPT5520 | The ID of the LEM WPT 5520 device.
WPT5530 | The ID of the WPT 5530 device.
WPT5530T | The ID of the LEM WPT 5530T device.
WPT5540 | The ID of the WPT 5540 device.
WPT5560 | The ID of the LEM WPT 5560 device.
WPT5590 | The ID of the LEM WPT 5590 device.
WPTDranView | The ID of WPT Dran View.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


Equipment Fields

Grid Solutions Framework Equipment Fields

The Equipment type exposes the following members.

Fields
Name | Description
AcumentricsControl | The ID of the Acumentrics Control device.
AdvanTechADAM4017 | The ID of the AdvanTech ADAM 4017 device.
AdvanTechADAM4018 | The ID of the AdvanTech ADAM 4018 device.
AdvanTechADAM4018M | The ID of the AdvanTech ADAM 4018M device.
AdvanTechADAM4050 | The ID of the AdvanTech ADAM 4050 device.
AdvanTechADAM4052 | The ID of the AdvanTech ADAM 4052 device.
AdvanTechADAM4053 | The ID of the AdvanTech ADAM 4053 device.
AdvanTechADAM4080 | The ID of the AdvanTech ADAM 4080 device.
AdvanTechADAM5017 | The ID of the AdvanTech ADAM 5017 device.
AdvanTechADAM5018 | The ID of the AdvanTech ADAM 5018 device.
AdvanTechADAM5050 | The ID of the AdvanTech ADAM 5050 device.
AdvanTechADAM5051 | The ID of the AdvanTech ADAM 5051 device.
AdvanTechADAM5052 | The ID of the AdvanTech ADAM 5052 device.
AdvanTechADAM5080 | The ID of the AdvanTech ADAM 5080 device.
BMI3100 | The ID of the BMI 3100 device.
BMI7100 | The ID of the BMI 7100 device.
BMI8010 | The ID of the BMI 7100 device.
BMI8020 | The ID of the BMI 7100 device.
BMI8800 | The ID of the BMI 8800 device.
BMI9010 | The ID of the BMI 7100 device.
CooperVFlicker | The ID of the Cooper V-Flicker device.
CooperVHarm | The ID of the Cooper V-Harm device.
DCGEMTP | The ID of the DCG EMTP device.
Dranetz656 | The ID of the Dranetz 656 device.
Dranetz658 | The ID of the Dranetz 658 device.
Dranetz8000 | The ID of the Dranetz 8000 device.
ELCOMBK550 | The ID of the ELCOM BK 550 device.
ETKDSS | The ID of ETK DSS.
ETKHarmoni | The ID of Electrotek Harmoni.
ETKNodeCenter | The ID of Electrotek Node Center.
ETKPASS | The ID of Electrotek PASS.
ETKPQDIFEditor | The ID of the Electrotek PQDIF editor.
ETKPQView | The ID of Electrotek PQView.
ETKPQWeb | The ID of Electrotek PQWeb.
ETKSuperHarm | The ID of Electrotek Super-Harm.
ETKSuperTran | The ID of Electrotek Super-Tran.
ETKTestProgram | The ID of the Electrotek test program.
ETKTextPQDIF | The ID of Electrotek Text PQDIF.
ETKTOP | The ID of Electrotek TOP.
EWON4000 | The ID of the EWON 4000 device.
FlukeCUR | The ID of the Fluke CUR device.
FlukeF41 | The ID of the Fluke F41 device.
GEKV | The ID of the GE kV Energy Meter.
GEKV2 | The ID of the GE kV2 Energy Meter.
IEEECOMTRADE | The ID of IEEE COMTRADE.
LEMAnalyst1Q | The ID of the LEM Analyst 1Q device.
LEMAnalyst2050 | The ID of the LEM Analyst 2050 device.
LEMAnalyst2060 | The ID of the LEM Analyst 2060 device.
LEMAnalyst3Q | The ID of the LEM Analyst 3Q device.
LEMBEN5000 | The ID of the LEM BEN 5000 device.
LEMBEN6000 | The ID of the LEM BEN 6000 device.
LEMEWave | The ID of the LEM EWave device.
LEMEWON4000 | The ID of the LEM EWON 4000 device.
LEMMBX300 | The ID of the LEM MBX 300 device.
LEMMBX601 | The ID of the LEM MBX 601 device.
LEMMBX602 | The ID of the LEM MBX 602 device.
LEMMBX603 | The ID of the LEM MBX 603 device.
LEMMBX686 | The ID of the LEM MBX 686 device.
LEMMBX800 | The ID of the LEM MBX 800 device.
LEMMidget200 | The ID of the LEM Midget 200 device.
LEMPerma701 | The ID of the LEM Perma 701 device.
LEMPerma702 | The ID of the LEM Perma 702 device.
LEMPerma705 | The ID of the LEM Perma 705 device.
LEMPerma706 | The ID of the LEM Perma 706 device.
LEMQWaveLight | The ID of the LEM QWave Light device.
LEMQWaveMicro | The ID of the LEM QWave Micro device.
LEMQWaveNomad | The ID of the LEM QWave Nomad device.
LEMQWavePowerDistribution | The ID of the LEM QWave Power Distribution device.
LEMQWavePowerTransport | The ID of the LEM QWave Power Transport device.
LEMQWavePremium | The ID of the LEM QWave Premium device.
LEMQWaveTWin | The ID of the LEM QWave TWin device.
LEMTOPAS1000 | The ID of the LEM TOPAS 1000 device.
LEMTOPAS1019 | The ID of the LEM TOPAS 1019 device.
LEMTOPAS1020 | The ID of the LEM TOPAS 1020 device.
LEMTOPAS1040 | The ID of the LEM TOPAS 1040 device.
LEMTOPASLT | The ID of the LEM TOPAS LT device.
Medcal | The ID of the Medcal device.
MetOneELT15 | The ID of the Met One ELT15 device.
MetrosonicM1 | The ID of the Metrosonic M1 device.
PMIScanner | The ID of the PMI scanner.
PML3710 | The ID of the PML 3710 device.
PML3720 | The ID of the PML 3720 device.
PML3800 | The ID of the PML 3800 device.
PML7300 | The ID of the PML 7300 device.
PML7700 | The ID of the PML 7700 device.
PMLLogServer | The ID of the PML Log Server.
PMLVIP | The ID of the PML VIP device.
PublicATP | The ID of public ATP.
Qualimetre | The ID of the Qualimetre device.
QWaveLight | The ID of the QWave Light device.
QWaveMicro | The ID of the QWave Micro device.
QWaveNomad | The ID of the QWave Nomad device.
QWavePowerDistribution | The ID of the QWave Power Distribution device.
QWavePowerTransmission | The ID of the QWave Power Transmission device.
QWavePremium | The ID of the QWave Premium device.
QWaveTWin | The ID of the QWave TWin device.
SQDSMS | The ID of the Square D PowerLogic SMS device.
TelogM1 | The ID of the Telog M1 device.
TrinergiPQM | The ID of the Trinergi Power Quality Meter.
WPT5510 | The ID of the LEM WPT 5510 device.
WPT5520 | The ID of the LEM WPT 5520 device.
WPT5530 | The ID of the WPT 5530 device.
WPT5530T | The ID of the LEM WPT 5530T device.
WPT5540 | The ID of the WPT 5540 device.
WPT5560 | The ID of the LEM WPT 5560 device.
WPT5590 | The ID of the LEM WPT 5590 device.
WPTDranView | The ID of WPT Dran View.
Top
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AcumentricsControl Field

Grid Solutions Framework EquipmentAcumentricsControl Field
The ID of the Acumentrics Control device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AcumentricsControl
Public Shared ReadOnly AcumentricsControl As Guid
static val AcumentricsControl: Guid
var GSF.PQDIF.Logical.Equipment.AcumentricsControl
public:
static initonly Guid AcumentricsControl

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM4017 Field

Grid Solutions Framework EquipmentAdvanTechADAM4017 Field
The ID of the AdvanTech ADAM 4017 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM4017
Public Shared ReadOnly AdvanTechADAM4017 As Guid
static val AdvanTechADAM4017: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM4017
public:
static initonly Guid AdvanTechADAM4017

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM4018 Field

Grid Solutions Framework EquipmentAdvanTechADAM4018 Field
The ID of the AdvanTech ADAM 4018 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM4018
Public Shared ReadOnly AdvanTechADAM4018 As Guid
static val AdvanTechADAM4018: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM4018
public:
static initonly Guid AdvanTechADAM4018

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM4018M Field

Grid Solutions Framework EquipmentAdvanTechADAM4018M Field
The ID of the AdvanTech ADAM 4018M device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM4018M
Public Shared ReadOnly AdvanTechADAM4018M As Guid
static val AdvanTechADAM4018M: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM4018M
public:
static initonly Guid AdvanTechADAM4018M

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM4050 Field

Grid Solutions Framework EquipmentAdvanTechADAM4050 Field
The ID of the AdvanTech ADAM 4050 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM4050
Public Shared ReadOnly AdvanTechADAM4050 As Guid
static val AdvanTechADAM4050: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM4050
public:
static initonly Guid AdvanTechADAM4050

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM4052 Field

Grid Solutions Framework EquipmentAdvanTechADAM4052 Field
The ID of the AdvanTech ADAM 4052 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM4052
Public Shared ReadOnly AdvanTechADAM4052 As Guid
static val AdvanTechADAM4052: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM4052
public:
static initonly Guid AdvanTechADAM4052

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM4053 Field

Grid Solutions Framework EquipmentAdvanTechADAM4053 Field
The ID of the AdvanTech ADAM 4053 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM4053
Public Shared ReadOnly AdvanTechADAM4053 As Guid
static val AdvanTechADAM4053: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM4053
public:
static initonly Guid AdvanTechADAM4053

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM4080 Field

Grid Solutions Framework EquipmentAdvanTechADAM4080 Field
The ID of the AdvanTech ADAM 4080 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM4080
Public Shared ReadOnly AdvanTechADAM4080 As Guid
static val AdvanTechADAM4080: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM4080
public:
static initonly Guid AdvanTechADAM4080

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM5017 Field

Grid Solutions Framework EquipmentAdvanTechADAM5017 Field
The ID of the AdvanTech ADAM 5017 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM5017
Public Shared ReadOnly AdvanTechADAM5017 As Guid
static val AdvanTechADAM5017: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM5017
public:
static initonly Guid AdvanTechADAM5017

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM5018 Field

Grid Solutions Framework EquipmentAdvanTechADAM5018 Field
The ID of the AdvanTech ADAM 5018 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM5018
Public Shared ReadOnly AdvanTechADAM5018 As Guid
static val AdvanTechADAM5018: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM5018
public:
static initonly Guid AdvanTechADAM5018

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM5050 Field

Grid Solutions Framework EquipmentAdvanTechADAM5050 Field
The ID of the AdvanTech ADAM 5050 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM5050
Public Shared ReadOnly AdvanTechADAM5050 As Guid
static val AdvanTechADAM5050: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM5050
public:
static initonly Guid AdvanTechADAM5050

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM5051 Field

Grid Solutions Framework EquipmentAdvanTechADAM5051 Field
The ID of the AdvanTech ADAM 5051 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM5051
Public Shared ReadOnly AdvanTechADAM5051 As Guid
static val AdvanTechADAM5051: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM5051
public:
static initonly Guid AdvanTechADAM5051

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM5052 Field

Grid Solutions Framework EquipmentAdvanTechADAM5052 Field
The ID of the AdvanTech ADAM 5052 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM5052
Public Shared ReadOnly AdvanTechADAM5052 As Guid
static val AdvanTechADAM5052: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM5052
public:
static initonly Guid AdvanTechADAM5052

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.AdvanTechADAM5080 Field

Grid Solutions Framework EquipmentAdvanTechADAM5080 Field
The ID of the AdvanTech ADAM 5080 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTechADAM5080
Public Shared ReadOnly AdvanTechADAM5080 As Guid
static val AdvanTechADAM5080: Guid
var GSF.PQDIF.Logical.Equipment.AdvanTechADAM5080
public:
static initonly Guid AdvanTechADAM5080

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.BMI3100 Field

Grid Solutions Framework EquipmentBMI3100 Field
The ID of the BMI 3100 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BMI3100
Public Shared ReadOnly BMI3100 As Guid
static val BMI3100: Guid
var GSF.PQDIF.Logical.Equipment.BMI3100
public:
static initonly Guid BMI3100

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.BMI7100 Field

Grid Solutions Framework EquipmentBMI7100 Field
The ID of the BMI 7100 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BMI7100
Public Shared ReadOnly BMI7100 As Guid
static val BMI7100: Guid
var GSF.PQDIF.Logical.Equipment.BMI7100
public:
static initonly Guid BMI7100

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.BMI8010 Field

Grid Solutions Framework EquipmentBMI8010 Field
The ID of the BMI 7100 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BMI8010
Public Shared ReadOnly BMI8010 As Guid
static val BMI8010: Guid
var GSF.PQDIF.Logical.Equipment.BMI8010
public:
static initonly Guid BMI8010

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.BMI8020 Field

Grid Solutions Framework EquipmentBMI8020 Field
The ID of the BMI 7100 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BMI8020
Public Shared ReadOnly BMI8020 As Guid
static val BMI8020: Guid
var GSF.PQDIF.Logical.Equipment.BMI8020
public:
static initonly Guid BMI8020

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.BMI8800 Field

Grid Solutions Framework EquipmentBMI8800 Field
The ID of the BMI 8800 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BMI8800
Public Shared ReadOnly BMI8800 As Guid
static val BMI8800: Guid
var GSF.PQDIF.Logical.Equipment.BMI8800
public:
static initonly Guid BMI8800

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.BMI9010 Field

Grid Solutions Framework EquipmentBMI9010 Field
The ID of the BMI 7100 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BMI9010
Public Shared ReadOnly BMI9010 As Guid
static val BMI9010: Guid
var GSF.PQDIF.Logical.Equipment.BMI9010
public:
static initonly Guid BMI9010

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.CooperVFlicker Field

Grid Solutions Framework EquipmentCooperVFlicker Field
The ID of the Cooper V-Flicker device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CooperVFlicker
Public Shared ReadOnly CooperVFlicker As Guid
static val CooperVFlicker: Guid
var GSF.PQDIF.Logical.Equipment.CooperVFlicker
public:
static initonly Guid CooperVFlicker

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.CooperVHarm Field

Grid Solutions Framework EquipmentCooperVHarm Field
The ID of the Cooper V-Harm device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CooperVHarm
Public Shared ReadOnly CooperVHarm As Guid
static val CooperVHarm: Guid
var GSF.PQDIF.Logical.Equipment.CooperVHarm
public:
static initonly Guid CooperVHarm

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.DCGEMTP Field

Grid Solutions Framework EquipmentDCGEMTP Field
The ID of the DCG EMTP device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DCGEMTP
Public Shared ReadOnly DCGEMTP As Guid
static val DCGEMTP: Guid
var GSF.PQDIF.Logical.Equipment.DCGEMTP
public:
static initonly Guid DCGEMTP

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.Dranetz656 Field

Grid Solutions Framework EquipmentDranetz656 Field
The ID of the Dranetz 656 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Dranetz656
Public Shared ReadOnly Dranetz656 As Guid
static val Dranetz656: Guid
var GSF.PQDIF.Logical.Equipment.Dranetz656
public:
static initonly Guid Dranetz656

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.Dranetz658 Field

Grid Solutions Framework EquipmentDranetz658 Field
The ID of the Dranetz 658 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Dranetz658
Public Shared ReadOnly Dranetz658 As Guid
static val Dranetz658: Guid
var GSF.PQDIF.Logical.Equipment.Dranetz658
public:
static initonly Guid Dranetz658

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.Dranetz8000 Field

Grid Solutions Framework EquipmentDranetz8000 Field
The ID of the Dranetz 8000 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Dranetz8000
Public Shared ReadOnly Dranetz8000 As Guid
static val Dranetz8000: Guid
var GSF.PQDIF.Logical.Equipment.Dranetz8000
public:
static initonly Guid Dranetz8000

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ELCOMBK550 Field

Grid Solutions Framework EquipmentELCOMBK550 Field
The ID of the ELCOM BK 550 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ELCOMBK550
Public Shared ReadOnly ELCOMBK550 As Guid
static val ELCOMBK550: Guid
var GSF.PQDIF.Logical.Equipment.ELCOMBK550
public:
static initonly Guid ELCOMBK550

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKDSS Field

Grid Solutions Framework EquipmentETKDSS Field
The ID of ETK DSS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKDSS
Public Shared ReadOnly ETKDSS As Guid
static val ETKDSS: Guid
var GSF.PQDIF.Logical.Equipment.ETKDSS
public:
static initonly Guid ETKDSS

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKHarmoni Field

Grid Solutions Framework EquipmentETKHarmoni Field
The ID of Electrotek Harmoni.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKHarmoni
Public Shared ReadOnly ETKHarmoni As Guid
static val ETKHarmoni: Guid
var GSF.PQDIF.Logical.Equipment.ETKHarmoni
public:
static initonly Guid ETKHarmoni

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKNodeCenter Field

Grid Solutions Framework EquipmentETKNodeCenter Field
The ID of Electrotek Node Center.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKNodeCenter
Public Shared ReadOnly ETKNodeCenter As Guid
static val ETKNodeCenter: Guid
var GSF.PQDIF.Logical.Equipment.ETKNodeCenter
public:
static initonly Guid ETKNodeCenter

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKPASS Field

Grid Solutions Framework EquipmentETKPASS Field
The ID of Electrotek PASS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKPASS
Public Shared ReadOnly ETKPASS As Guid
static val ETKPASS: Guid
var GSF.PQDIF.Logical.Equipment.ETKPASS
public:
static initonly Guid ETKPASS

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKPQDIFEditor Field

Grid Solutions Framework EquipmentETKPQDIFEditor Field
The ID of the Electrotek PQDIF editor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKPQDIFEditor
Public Shared ReadOnly ETKPQDIFEditor As Guid
static val ETKPQDIFEditor: Guid
var GSF.PQDIF.Logical.Equipment.ETKPQDIFEditor
public:
static initonly Guid ETKPQDIFEditor

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKPQView Field

Grid Solutions Framework EquipmentETKPQView Field
The ID of Electrotek PQView.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKPQView
Public Shared ReadOnly ETKPQView As Guid
static val ETKPQView: Guid
var GSF.PQDIF.Logical.Equipment.ETKPQView
public:
static initonly Guid ETKPQView

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKPQWeb Field

Grid Solutions Framework EquipmentETKPQWeb Field
The ID of Electrotek PQWeb.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKPQWeb
Public Shared ReadOnly ETKPQWeb As Guid
static val ETKPQWeb: Guid
var GSF.PQDIF.Logical.Equipment.ETKPQWeb
public:
static initonly Guid ETKPQWeb

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKSuperHarm Field

Grid Solutions Framework EquipmentETKSuperHarm Field
The ID of Electrotek Super-Harm.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKSuperHarm
Public Shared ReadOnly ETKSuperHarm As Guid
static val ETKSuperHarm: Guid
var GSF.PQDIF.Logical.Equipment.ETKSuperHarm
public:
static initonly Guid ETKSuperHarm

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKSuperTran Field

Grid Solutions Framework EquipmentETKSuperTran Field
The ID of Electrotek Super-Tran.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKSuperTran
Public Shared ReadOnly ETKSuperTran As Guid
static val ETKSuperTran: Guid
var GSF.PQDIF.Logical.Equipment.ETKSuperTran
public:
static initonly Guid ETKSuperTran

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKTestProgram Field

Grid Solutions Framework EquipmentETKTestProgram Field
The ID of the Electrotek test program.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKTestProgram
Public Shared ReadOnly ETKTestProgram As Guid
static val ETKTestProgram: Guid
var GSF.PQDIF.Logical.Equipment.ETKTestProgram
public:
static initonly Guid ETKTestProgram

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKTextPQDIF Field

Grid Solutions Framework EquipmentETKTextPQDIF Field
The ID of Electrotek Text PQDIF.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKTextPQDIF
Public Shared ReadOnly ETKTextPQDIF As Guid
static val ETKTextPQDIF: Guid
var GSF.PQDIF.Logical.Equipment.ETKTextPQDIF
public:
static initonly Guid ETKTextPQDIF

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ETKTOP Field

Grid Solutions Framework EquipmentETKTOP Field
The ID of Electrotek TOP.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ETKTOP
Public Shared ReadOnly ETKTOP As Guid
static val ETKTOP: Guid
var GSF.PQDIF.Logical.Equipment.ETKTOP
public:
static initonly Guid ETKTOP

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.EWON4000 Field

Grid Solutions Framework EquipmentEWON4000 Field
The ID of the EWON 4000 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EWON4000
Public Shared ReadOnly EWON4000 As Guid
static val EWON4000: Guid
var GSF.PQDIF.Logical.Equipment.EWON4000
public:
static initonly Guid EWON4000

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.FlukeCUR Field

Grid Solutions Framework EquipmentFlukeCUR Field
The ID of the Fluke CUR device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlukeCUR
Public Shared ReadOnly FlukeCUR As Guid
static val FlukeCUR: Guid
var GSF.PQDIF.Logical.Equipment.FlukeCUR
public:
static initonly Guid FlukeCUR

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.FlukeF41 Field

Grid Solutions Framework EquipmentFlukeF41 Field
The ID of the Fluke F41 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlukeF41
Public Shared ReadOnly FlukeF41 As Guid
static val FlukeF41: Guid
var GSF.PQDIF.Logical.Equipment.FlukeF41
public:
static initonly Guid FlukeF41

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.GEKV Field

Grid Solutions Framework EquipmentGEKV Field
The ID of the GE kV Energy Meter.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid GEKV
Public Shared ReadOnly GEKV As Guid
static val GEKV: Guid
var GSF.PQDIF.Logical.Equipment.GEKV
public:
static initonly Guid GEKV

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.GEKV2 Field

Grid Solutions Framework EquipmentGEKV2 Field
The ID of the GE kV2 Energy Meter.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid GEKV2
Public Shared ReadOnly GEKV2 As Guid
static val GEKV2: Guid
var GSF.PQDIF.Logical.Equipment.GEKV2
public:
static initonly Guid GEKV2

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.IEEECOMTRADE Field

Grid Solutions Framework EquipmentIEEECOMTRADE Field
The ID of IEEE COMTRADE.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid IEEECOMTRADE
Public Shared ReadOnly IEEECOMTRADE As Guid
static val IEEECOMTRADE: Guid
var GSF.PQDIF.Logical.Equipment.IEEECOMTRADE
public:
static initonly Guid IEEECOMTRADE

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMAnalyst1Q Field

Grid Solutions Framework EquipmentLEMAnalyst1Q Field
The ID of the LEM Analyst 1Q device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMAnalyst1Q
Public Shared ReadOnly LEMAnalyst1Q As Guid
static val LEMAnalyst1Q: Guid
var GSF.PQDIF.Logical.Equipment.LEMAnalyst1Q
public:
static initonly Guid LEMAnalyst1Q

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMAnalyst2050 Field

Grid Solutions Framework EquipmentLEMAnalyst2050 Field
The ID of the LEM Analyst 2050 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMAnalyst2050
Public Shared ReadOnly LEMAnalyst2050 As Guid
static val LEMAnalyst2050: Guid
var GSF.PQDIF.Logical.Equipment.LEMAnalyst2050
public:
static initonly Guid LEMAnalyst2050

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMAnalyst2060 Field

Grid Solutions Framework EquipmentLEMAnalyst2060 Field
The ID of the LEM Analyst 2060 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMAnalyst2060
Public Shared ReadOnly LEMAnalyst2060 As Guid
static val LEMAnalyst2060: Guid
var GSF.PQDIF.Logical.Equipment.LEMAnalyst2060
public:
static initonly Guid LEMAnalyst2060

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMAnalyst3Q Field

Grid Solutions Framework EquipmentLEMAnalyst3Q Field
The ID of the LEM Analyst 3Q device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMAnalyst3Q
Public Shared ReadOnly LEMAnalyst3Q As Guid
static val LEMAnalyst3Q: Guid
var GSF.PQDIF.Logical.Equipment.LEMAnalyst3Q
public:
static initonly Guid LEMAnalyst3Q

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMBEN5000 Field

Grid Solutions Framework EquipmentLEMBEN5000 Field
The ID of the LEM BEN 5000 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMBEN5000
Public Shared ReadOnly LEMBEN5000 As Guid
static val LEMBEN5000: Guid
var GSF.PQDIF.Logical.Equipment.LEMBEN5000
public:
static initonly Guid LEMBEN5000

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMBEN6000 Field

Grid Solutions Framework EquipmentLEMBEN6000 Field
The ID of the LEM BEN 6000 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMBEN6000
Public Shared ReadOnly LEMBEN6000 As Guid
static val LEMBEN6000: Guid
var GSF.PQDIF.Logical.Equipment.LEMBEN6000
public:
static initonly Guid LEMBEN6000

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMEWave Field

Grid Solutions Framework EquipmentLEMEWave Field
The ID of the LEM EWave device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMEWave
Public Shared ReadOnly LEMEWave As Guid
static val LEMEWave: Guid
var GSF.PQDIF.Logical.Equipment.LEMEWave
public:
static initonly Guid LEMEWave

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMEWON4000 Field

Grid Solutions Framework EquipmentLEMEWON4000 Field
The ID of the LEM EWON 4000 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMEWON4000
Public Shared ReadOnly LEMEWON4000 As Guid
static val LEMEWON4000: Guid
var GSF.PQDIF.Logical.Equipment.LEMEWON4000
public:
static initonly Guid LEMEWON4000

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMMBX300 Field

Grid Solutions Framework EquipmentLEMMBX300 Field
The ID of the LEM MBX 300 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMMBX300
Public Shared ReadOnly LEMMBX300 As Guid
static val LEMMBX300: Guid
var GSF.PQDIF.Logical.Equipment.LEMMBX300
public:
static initonly Guid LEMMBX300

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMMBX601 Field

Grid Solutions Framework EquipmentLEMMBX601 Field
The ID of the LEM MBX 601 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMMBX601
Public Shared ReadOnly LEMMBX601 As Guid
static val LEMMBX601: Guid
var GSF.PQDIF.Logical.Equipment.LEMMBX601
public:
static initonly Guid LEMMBX601

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMMBX602 Field

Grid Solutions Framework EquipmentLEMMBX602 Field
The ID of the LEM MBX 602 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMMBX602
Public Shared ReadOnly LEMMBX602 As Guid
static val LEMMBX602: Guid
var GSF.PQDIF.Logical.Equipment.LEMMBX602
public:
static initonly Guid LEMMBX602

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMMBX603 Field

Grid Solutions Framework EquipmentLEMMBX603 Field
The ID of the LEM MBX 603 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMMBX603
Public Shared ReadOnly LEMMBX603 As Guid
static val LEMMBX603: Guid
var GSF.PQDIF.Logical.Equipment.LEMMBX603
public:
static initonly Guid LEMMBX603

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMMBX686 Field

Grid Solutions Framework EquipmentLEMMBX686 Field
The ID of the LEM MBX 686 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMMBX686
Public Shared ReadOnly LEMMBX686 As Guid
static val LEMMBX686: Guid
var GSF.PQDIF.Logical.Equipment.LEMMBX686
public:
static initonly Guid LEMMBX686

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMMBX800 Field

Grid Solutions Framework EquipmentLEMMBX800 Field
The ID of the LEM MBX 800 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMMBX800
Public Shared ReadOnly LEMMBX800 As Guid
static val LEMMBX800: Guid
var GSF.PQDIF.Logical.Equipment.LEMMBX800
public:
static initonly Guid LEMMBX800

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMMidget200 Field

Grid Solutions Framework EquipmentLEMMidget200 Field
The ID of the LEM Midget 200 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMMidget200
Public Shared ReadOnly LEMMidget200 As Guid
static val LEMMidget200: Guid
var GSF.PQDIF.Logical.Equipment.LEMMidget200
public:
static initonly Guid LEMMidget200

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMPerma701 Field

Grid Solutions Framework EquipmentLEMPerma701 Field
The ID of the LEM Perma 701 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMPerma701
Public Shared ReadOnly LEMPerma701 As Guid
static val LEMPerma701: Guid
var GSF.PQDIF.Logical.Equipment.LEMPerma701
public:
static initonly Guid LEMPerma701

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMPerma702 Field

Grid Solutions Framework EquipmentLEMPerma702 Field
The ID of the LEM Perma 702 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMPerma702
Public Shared ReadOnly LEMPerma702 As Guid
static val LEMPerma702: Guid
var GSF.PQDIF.Logical.Equipment.LEMPerma702
public:
static initonly Guid LEMPerma702

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMPerma705 Field

Grid Solutions Framework EquipmentLEMPerma705 Field
The ID of the LEM Perma 705 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMPerma705
Public Shared ReadOnly LEMPerma705 As Guid
static val LEMPerma705: Guid
var GSF.PQDIF.Logical.Equipment.LEMPerma705
public:
static initonly Guid LEMPerma705

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMPerma706 Field

Grid Solutions Framework EquipmentLEMPerma706 Field
The ID of the LEM Perma 706 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMPerma706
Public Shared ReadOnly LEMPerma706 As Guid
static val LEMPerma706: Guid
var GSF.PQDIF.Logical.Equipment.LEMPerma706
public:
static initonly Guid LEMPerma706

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMQWaveLight Field

Grid Solutions Framework EquipmentLEMQWaveLight Field
The ID of the LEM QWave Light device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMQWaveLight
Public Shared ReadOnly LEMQWaveLight As Guid
static val LEMQWaveLight: Guid
var GSF.PQDIF.Logical.Equipment.LEMQWaveLight
public:
static initonly Guid LEMQWaveLight

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMQWaveMicro Field

Grid Solutions Framework EquipmentLEMQWaveMicro Field
The ID of the LEM QWave Micro device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMQWaveMicro
Public Shared ReadOnly LEMQWaveMicro As Guid
static val LEMQWaveMicro: Guid
var GSF.PQDIF.Logical.Equipment.LEMQWaveMicro
public:
static initonly Guid LEMQWaveMicro

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMQWaveNomad Field

Grid Solutions Framework EquipmentLEMQWaveNomad Field
The ID of the LEM QWave Nomad device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMQWaveNomad
Public Shared ReadOnly LEMQWaveNomad As Guid
static val LEMQWaveNomad: Guid
var GSF.PQDIF.Logical.Equipment.LEMQWaveNomad
public:
static initonly Guid LEMQWaveNomad

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMQWavePowerDistribution Field

Grid Solutions Framework EquipmentLEMQWavePowerDistribution Field
The ID of the LEM QWave Power Distribution device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMQWavePowerDistribution
Public Shared ReadOnly LEMQWavePowerDistribution As Guid
static val LEMQWavePowerDistribution: Guid
var GSF.PQDIF.Logical.Equipment.LEMQWavePowerDistribution
public:
static initonly Guid LEMQWavePowerDistribution

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMQWavePowerTransport Field

Grid Solutions Framework EquipmentLEMQWavePowerTransport Field
The ID of the LEM QWave Power Transport device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMQWavePowerTransport
Public Shared ReadOnly LEMQWavePowerTransport As Guid
static val LEMQWavePowerTransport: Guid
var GSF.PQDIF.Logical.Equipment.LEMQWavePowerTransport
public:
static initonly Guid LEMQWavePowerTransport

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMQWavePremium Field

Grid Solutions Framework EquipmentLEMQWavePremium Field
The ID of the LEM QWave Premium device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMQWavePremium
Public Shared ReadOnly LEMQWavePremium As Guid
static val LEMQWavePremium: Guid
var GSF.PQDIF.Logical.Equipment.LEMQWavePremium
public:
static initonly Guid LEMQWavePremium

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMQWaveTWin Field

Grid Solutions Framework EquipmentLEMQWaveTWin Field
The ID of the LEM QWave TWin device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMQWaveTWin
Public Shared ReadOnly LEMQWaveTWin As Guid
static val LEMQWaveTWin: Guid
var GSF.PQDIF.Logical.Equipment.LEMQWaveTWin
public:
static initonly Guid LEMQWaveTWin

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMTOPAS1000 Field

Grid Solutions Framework EquipmentLEMTOPAS1000 Field
The ID of the LEM TOPAS 1000 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMTOPAS1000
Public Shared ReadOnly LEMTOPAS1000 As Guid
static val LEMTOPAS1000: Guid
var GSF.PQDIF.Logical.Equipment.LEMTOPAS1000
public:
static initonly Guid LEMTOPAS1000

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMTOPAS1019 Field

Grid Solutions Framework EquipmentLEMTOPAS1019 Field
The ID of the LEM TOPAS 1019 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMTOPAS1019
Public Shared ReadOnly LEMTOPAS1019 As Guid
static val LEMTOPAS1019: Guid
var GSF.PQDIF.Logical.Equipment.LEMTOPAS1019
public:
static initonly Guid LEMTOPAS1019

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMTOPAS1020 Field

Grid Solutions Framework EquipmentLEMTOPAS1020 Field
The ID of the LEM TOPAS 1020 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMTOPAS1020
Public Shared ReadOnly LEMTOPAS1020 As Guid
static val LEMTOPAS1020: Guid
var GSF.PQDIF.Logical.Equipment.LEMTOPAS1020
public:
static initonly Guid LEMTOPAS1020

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMTOPAS1040 Field

Grid Solutions Framework EquipmentLEMTOPAS1040 Field
The ID of the LEM TOPAS 1040 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMTOPAS1040
Public Shared ReadOnly LEMTOPAS1040 As Guid
static val LEMTOPAS1040: Guid
var GSF.PQDIF.Logical.Equipment.LEMTOPAS1040
public:
static initonly Guid LEMTOPAS1040

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.LEMTOPASLT Field

Grid Solutions Framework EquipmentLEMTOPASLT Field
The ID of the LEM TOPAS LT device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEMTOPASLT
Public Shared ReadOnly LEMTOPASLT As Guid
static val LEMTOPASLT: Guid
var GSF.PQDIF.Logical.Equipment.LEMTOPASLT
public:
static initonly Guid LEMTOPASLT

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.Medcal Field

Grid Solutions Framework EquipmentMedcal Field
The ID of the Medcal device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Medcal
Public Shared ReadOnly Medcal As Guid
static val Medcal: Guid
var GSF.PQDIF.Logical.Equipment.Medcal
public:
static initonly Guid Medcal

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.MetOneELT15 Field

Grid Solutions Framework EquipmentMetOneELT15 Field
The ID of the Met One ELT15 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid MetOneELT15
Public Shared ReadOnly MetOneELT15 As Guid
static val MetOneELT15: Guid
var GSF.PQDIF.Logical.Equipment.MetOneELT15
public:
static initonly Guid MetOneELT15

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.MetrosonicM1 Field

Grid Solutions Framework EquipmentMetrosonicM1 Field
The ID of the Metrosonic M1 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid MetrosonicM1
Public Shared ReadOnly MetrosonicM1 As Guid
static val MetrosonicM1: Guid
var GSF.PQDIF.Logical.Equipment.MetrosonicM1
public:
static initonly Guid MetrosonicM1

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PMIScanner Field

Grid Solutions Framework EquipmentPMIScanner Field
The ID of the PMI scanner.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PMIScanner
Public Shared ReadOnly PMIScanner As Guid
static val PMIScanner: Guid
var GSF.PQDIF.Logical.Equipment.PMIScanner
public:
static initonly Guid PMIScanner

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PML3710 Field

Grid Solutions Framework EquipmentPML3710 Field
The ID of the PML 3710 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PML3710
Public Shared ReadOnly PML3710 As Guid
static val PML3710: Guid
var GSF.PQDIF.Logical.Equipment.PML3710
public:
static initonly Guid PML3710

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PML3720 Field

Grid Solutions Framework EquipmentPML3720 Field
The ID of the PML 3720 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PML3720
Public Shared ReadOnly PML3720 As Guid
static val PML3720: Guid
var GSF.PQDIF.Logical.Equipment.PML3720
public:
static initonly Guid PML3720

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PML3800 Field

Grid Solutions Framework EquipmentPML3800 Field
The ID of the PML 3800 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PML3800
Public Shared ReadOnly PML3800 As Guid
static val PML3800: Guid
var GSF.PQDIF.Logical.Equipment.PML3800
public:
static initonly Guid PML3800

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PML7300 Field

Grid Solutions Framework EquipmentPML7300 Field
The ID of the PML 7300 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PML7300
Public Shared ReadOnly PML7300 As Guid
static val PML7300: Guid
var GSF.PQDIF.Logical.Equipment.PML7300
public:
static initonly Guid PML7300

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PML7700 Field

Grid Solutions Framework EquipmentPML7700 Field
The ID of the PML 7700 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PML7700
Public Shared ReadOnly PML7700 As Guid
static val PML7700: Guid
var GSF.PQDIF.Logical.Equipment.PML7700
public:
static initonly Guid PML7700

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PMLLogServer Field

Grid Solutions Framework EquipmentPMLLogServer Field
The ID of the PML Log Server.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PMLLogServer
Public Shared ReadOnly PMLLogServer As Guid
static val PMLLogServer: Guid
var GSF.PQDIF.Logical.Equipment.PMLLogServer
public:
static initonly Guid PMLLogServer

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PMLVIP Field

Grid Solutions Framework EquipmentPMLVIP Field
The ID of the PML VIP device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PMLVIP
Public Shared ReadOnly PMLVIP As Guid
static val PMLVIP: Guid
var GSF.PQDIF.Logical.Equipment.PMLVIP
public:
static initonly Guid PMLVIP

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.PublicATP Field

Grid Solutions Framework EquipmentPublicATP Field
The ID of public ATP.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PublicATP
Public Shared ReadOnly PublicATP As Guid
static val PublicATP: Guid
var GSF.PQDIF.Logical.Equipment.PublicATP
public:
static initonly Guid PublicATP

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.Qualimetre Field

Grid Solutions Framework EquipmentQualimetre Field
The ID of the Qualimetre device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Qualimetre
Public Shared ReadOnly Qualimetre As Guid
static val Qualimetre: Guid
var GSF.PQDIF.Logical.Equipment.Qualimetre
public:
static initonly Guid Qualimetre

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.QWaveLight Field

Grid Solutions Framework EquipmentQWaveLight Field
The ID of the QWave Light device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QWaveLight
Public Shared ReadOnly QWaveLight As Guid
static val QWaveLight: Guid
var GSF.PQDIF.Logical.Equipment.QWaveLight
public:
static initonly Guid QWaveLight

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.QWaveMicro Field

Grid Solutions Framework EquipmentQWaveMicro Field
The ID of the QWave Micro device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QWaveMicro
Public Shared ReadOnly QWaveMicro As Guid
static val QWaveMicro: Guid
var GSF.PQDIF.Logical.Equipment.QWaveMicro
public:
static initonly Guid QWaveMicro

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.QWaveNomad Field

Grid Solutions Framework EquipmentQWaveNomad Field
The ID of the QWave Nomad device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QWaveNomad
Public Shared ReadOnly QWaveNomad As Guid
static val QWaveNomad: Guid
var GSF.PQDIF.Logical.Equipment.QWaveNomad
public:
static initonly Guid QWaveNomad

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.QWavePowerDistribution Field

Grid Solutions Framework EquipmentQWavePowerDistribution Field
The ID of the QWave Power Distribution device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QWavePowerDistribution
Public Shared ReadOnly QWavePowerDistribution As Guid
static val QWavePowerDistribution: Guid
var GSF.PQDIF.Logical.Equipment.QWavePowerDistribution
public:
static initonly Guid QWavePowerDistribution

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.QWavePowerTransmission Field

Grid Solutions Framework EquipmentQWavePowerTransmission Field
The ID of the QWave Power Transmission device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QWavePowerTransmission
Public Shared ReadOnly QWavePowerTransmission As Guid
static val QWavePowerTransmission: Guid
var GSF.PQDIF.Logical.Equipment.QWavePowerTransmission
public:
static initonly Guid QWavePowerTransmission

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.QWavePremium Field

Grid Solutions Framework EquipmentQWavePremium Field
The ID of the QWave Premium device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QWavePremium
Public Shared ReadOnly QWavePremium As Guid
static val QWavePremium: Guid
var GSF.PQDIF.Logical.Equipment.QWavePremium
public:
static initonly Guid QWavePremium

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.QWaveTWin Field

Grid Solutions Framework EquipmentQWaveTWin Field
The ID of the QWave TWin device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QWaveTWin
Public Shared ReadOnly QWaveTWin As Guid
static val QWaveTWin: Guid
var GSF.PQDIF.Logical.Equipment.QWaveTWin
public:
static initonly Guid QWaveTWin

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.SQDSMS Field

Grid Solutions Framework EquipmentSQDSMS Field
The ID of the Square D PowerLogic SMS device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SQDSMS
Public Shared ReadOnly SQDSMS As Guid
static val SQDSMS: Guid
var GSF.PQDIF.Logical.Equipment.SQDSMS
public:
static initonly Guid SQDSMS

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.TelogM1 Field

Grid Solutions Framework EquipmentTelogM1 Field
The ID of the Telog M1 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TelogM1
Public Shared ReadOnly TelogM1 As Guid
static val TelogM1: Guid
var GSF.PQDIF.Logical.Equipment.TelogM1
public:
static initonly Guid TelogM1

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.TrinergiPQM Field

Grid Solutions Framework EquipmentTrinergiPQM Field
The ID of the Trinergi Power Quality Meter.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TrinergiPQM
Public Shared ReadOnly TrinergiPQM As Guid
static val TrinergiPQM: Guid
var GSF.PQDIF.Logical.Equipment.TrinergiPQM
public:
static initonly Guid TrinergiPQM

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPT5510 Field

Grid Solutions Framework EquipmentWPT5510 Field
The ID of the LEM WPT 5510 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT5510
Public Shared ReadOnly WPT5510 As Guid
static val WPT5510: Guid
var GSF.PQDIF.Logical.Equipment.WPT5510
public:
static initonly Guid WPT5510

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPT5520 Field

Grid Solutions Framework EquipmentWPT5520 Field
The ID of the LEM WPT 5520 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT5520
Public Shared ReadOnly WPT5520 As Guid
static val WPT5520: Guid
var GSF.PQDIF.Logical.Equipment.WPT5520
public:
static initonly Guid WPT5520

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPT5530 Field

Grid Solutions Framework EquipmentWPT5530 Field
The ID of the WPT 5530 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT5530
Public Shared ReadOnly WPT5530 As Guid
static val WPT5530: Guid
var GSF.PQDIF.Logical.Equipment.WPT5530
public:
static initonly Guid WPT5530

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPT5530T Field

Grid Solutions Framework EquipmentWPT5530T Field
The ID of the LEM WPT 5530T device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT5530T
Public Shared ReadOnly WPT5530T As Guid
static val WPT5530T: Guid
var GSF.PQDIF.Logical.Equipment.WPT5530T
public:
static initonly Guid WPT5530T

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPT5540 Field

Grid Solutions Framework EquipmentWPT5540 Field
The ID of the WPT 5540 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT5540
Public Shared ReadOnly WPT5540 As Guid
static val WPT5540: Guid
var GSF.PQDIF.Logical.Equipment.WPT5540
public:
static initonly Guid WPT5540

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPT5560 Field

Grid Solutions Framework EquipmentWPT5560 Field
The ID of the LEM WPT 5560 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT5560
Public Shared ReadOnly WPT5560 As Guid
static val WPT5560: Guid
var GSF.PQDIF.Logical.Equipment.WPT5560
public:
static initonly Guid WPT5560

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPT5590 Field

Grid Solutions Framework EquipmentWPT5590 Field
The ID of the LEM WPT 5590 device.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT5590
Public Shared ReadOnly WPT5590 As Guid
static val WPT5590: Guid
var GSF.PQDIF.Logical.Equipment.WPT5590
public:
static initonly Guid WPT5590

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.WPTDranView Field

Grid Solutions Framework EquipmentWPTDranView Field
The ID of WPT Dran View.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPTDranView
Public Shared ReadOnly WPTDranView As Guid
static val WPTDranView: Guid
var GSF.PQDIF.Logical.Equipment.WPTDranView
public:
static initonly Guid WPTDranView

Field Value

Type: Guid
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment Methods

Grid Solutions Framework Equipment Methods

The Equipment type exposes the following members.

Methods
Name | Description
ToString | Converts the given equpiment ID to a string containing the name of the equipment.
Top
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


Equipment.ToString Method

Grid Solutions Framework EquipmentToString Method
Converts the given equpiment ID to a string containing the name of the equipment.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    Guid equipmentID
)
Public Shared Function ToString (
    equipmentID As Guid
) As String
static member ToString :
        equipmentID : Guid -> string

GSF.PQDIF.Logical.Equipment.ToString = function(equipmentID);
public:
static String^ ToString(
    Guid equipmentID
)

Parameters

equipmentID
Type: SystemGuid
The ID of the equipment to be converted to a string.

Return Value

Type: String
A string containing the name of the equipment with the given ID.
See Also

Reference

Equipment Class
GSF.PQDIF.Logical Namespace


LogicalParser Class

Grid Solutions Framework LogicalParser Class
Represents a parser which parses the logical structure of a PQDIF file.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalLogicalParser

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LogicalParser : IDisposable
Public Class LogicalParser
    Implements IDisposable
type LogicalParser =
    class
        interface IDisposable
    end
GSF.PQDIF.Logical.LogicalParser = function();

Type.createClass(
    'GSF.PQDIF.Logical.LogicalParser',
    null,
    IDisposable);
public ref class LogicalParser : IDisposable

The LogicalParser type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalParser | Creates a new instance of the LogicalParser class.
Top
Methods
 | Name | Description
Public method | Close | Closes the PQDIF file.
Public method | Dispose | Releases resources held by the parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNextObservationRecord | Determines whether there are any more ObservationRecords to be read from the PQDIF file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextObservationRecord | Gets the next observation record from the PQDIF file.
Public method | Open | Opens the parser and parses the ContainerRecord.
Public method | Reset | Resets the parser to the beginning of the PQDIF file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ContainerRecord | Gets the container record from the PQDIF file. This is parsed as soon as the parser is Opened.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


LogicalParser Constructor

Grid Solutions Framework LogicalParser Constructor
Creates a new instance of the LogicalParser class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalParser(
    string fileName
)
Public Sub New (
    fileName As String
)
new :
        fileName : string -> LogicalParser
GSF.PQDIF.Logical.LogicalParser = function(fileName);
public:
LogicalParser(
    String^ fileName
)

Parameters

fileName
Type: SystemString
Name of the PQDIF file to be parsed.
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser Methods

Grid Solutions Framework LogicalParser Methods

The LogicalParser type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the PQDIF file.
Public method | Dispose | Releases resources held by the parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNextObservationRecord | Determines whether there are any more ObservationRecords to be read from the PQDIF file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextObservationRecord | Gets the next observation record from the PQDIF file.
Public method | Open | Opens the parser and parses the ContainerRecord.
Public method | Reset | Resets the parser to the beginning of the PQDIF file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser.Close Method

Grid Solutions Framework LogicalParserClose Method
Closes the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser.Dispose Method

Grid Solutions Framework LogicalParserDispose Method
Releases resources held by the parser.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser.HasNextObservationRecord Method

Grid Solutions Framework LogicalParserHasNextObservationRecord Method
Determines whether there are any more ObservationRecords to be read from the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasNextObservationRecord()
Public Function HasNextObservationRecord As Boolean
member HasNextObservationRecord : unit -> bool

function HasNextObservationRecord();
public:
bool HasNextObservationRecord()

Return Value

Type: Boolean
true if there is another observation record to be read from PQDIF file; false otherwise
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser.NextObservationRecord Method

Grid Solutions Framework LogicalParserNextObservationRecord Method
Gets the next observation record from the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ObservationRecord NextObservationRecord()
Public Function NextObservationRecord As ObservationRecord
member NextObservationRecord : unit -> ObservationRecord

function NextObservationRecord();
public:
ObservationRecord^ NextObservationRecord()

Return Value

Type: ObservationRecord
The next observation record.
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser.Open Method

Grid Solutions Framework LogicalParserOpen Method
Opens the parser and parses the ContainerRecord.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open()
Public Sub Open
member Open : unit -> unit

function Open();
public:
void Open()
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser.Reset Method

Grid Solutions Framework LogicalParserReset Method
Resets the parser to the beginning of the PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser Properties

Grid Solutions Framework LogicalParser Properties

The LogicalParser type exposes the following members.

Properties
 | Name | Description
Public property | ContainerRecord | Gets the container record from the PQDIF file. This is parsed as soon as the parser is Opened.
Top
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalParser.ContainerRecord Property

Grid Solutions Framework LogicalParserContainerRecord Property
Gets the container record from the PQDIF file. This is parsed as soon as the parser is Opened.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ContainerRecord ContainerRecord { get; }
Public ReadOnly Property ContainerRecord As ContainerRecord
    Get
member ContainerRecord : ContainerRecord with get

function get_ContainerRecord();

public:
property ContainerRecord^ ContainerRecord {
    ContainerRecord^ get ();
}

Property Value

Type: ContainerRecord
See Also

Reference

LogicalParser Class
GSF.PQDIF.Logical Namespace


LogicalWriter Class

Grid Solutions Framework LogicalWriter Class
Represents a writer used to create files using the PQDIF file format.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalLogicalWriter

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class LogicalWriter : IDisposable
Public NotInheritable Class LogicalWriter
    Implements IDisposable
[<SealedAttribute>]
type LogicalWriter =
    class
        interface IDisposable
    end
GSF.PQDIF.Logical.LogicalWriter = function();

Type.createClass(
    'GSF.PQDIF.Logical.LogicalWriter',
    null,
    IDisposable);
public ref class LogicalWriter sealed : IDisposable

The LogicalWriter type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalWriter(String) | Creates a new instance of the LogicalWriter class.
Public method | LogicalWriter(Stream, Boolean) | Creates a new instance of the LogicalWriter class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases the unmanaged resources used by the LogicalWriter object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(ContainerRecord) | Writes the given container record to the file stream.
Public method | Write(ObservationRecord, Boolean) | Writes the given observation record, as well as its data source and monitor settings records if necessary, to the file stream.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | MissingTags | Gets a collection of required tags identified as missing from the records written to this PQDIF file.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


LogicalWriter Constructor

Grid Solutions Framework LogicalWriter Constructor
Overload List
 | Name | Description
Public method | LogicalWriter(String) | Creates a new instance of the LogicalWriter class.
Public method | LogicalWriter(Stream, Boolean) | Creates a new instance of the LogicalWriter class.
Top
See Also

Reference

LogicalWriter Class
GSF.PQDIF.Logical Namespace


LogicalWriter Constructor (String)

Grid Solutions Framework LogicalWriter Constructor (String)
Creates a new instance of the LogicalWriter class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalWriter(
    string filePath
)
Public Sub New (
    filePath As String
)
new :
        filePath : string -> LogicalWriter
GSF.PQDIF.Logical.LogicalWriter = function(filePath);
public:
LogicalWriter(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The path to the file where the PQDIF data is to be written.
See Also

Reference

LogicalWriter Class
LogicalWriter Overload
GSF.PQDIF.Logical Namespace


LogicalWriter Constructor (Stream, Boolean)

Grid Solutions Framework LogicalWriter Constructor (Stream, Boolean)
Creates a new instance of the LogicalWriter class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalWriter(
    Stream stream,
    bool leaveOpen = false
)
Public Sub New (
    stream As Stream,
    Optional leaveOpen As Boolean = false
)
new :
        stream : Stream *
        ?leaveOpen : bool
(* Defaults:
        let _leaveOpen = defaultArg leaveOpen false
*)
-> LogicalWriter
GSF.PQDIF.Logical.LogicalWriter = function(stream, leaveOpen);
public:
LogicalWriter(
    Stream^ stream,
    bool leaveOpen = false
)

Parameters

stream
Type: System.IOStream
The stream to write the PQDIF data to.
leaveOpen (Optional)
Type: SystemBoolean
Indicates whether to leave the stream open when disposing of the writer.
See Also

Reference

LogicalWriter Class
LogicalWriter Overload
GSF.PQDIF.Logical Namespace


LogicalWriter Methods

Grid Solutions Framework LogicalWriter Methods

The LogicalWriter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases the unmanaged resources used by the LogicalWriter object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Write(ContainerRecord) | Writes the given container record to the file stream.
Public method | Write(ObservationRecord, Boolean) | Writes the given observation record, as well as its data source and monitor settings records if necessary, to the file stream.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogicalWriter Class
GSF.PQDIF.Logical Namespace


LogicalWriter.Dispose Method

Grid Solutions Framework LogicalWriterDispose Method
Releases the unmanaged resources used by the LogicalWriter object and optionally releases the managed resources.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

LogicalWriter Class
GSF.PQDIF.Logical Namespace


LogicalWriter.Write Method

Grid Solutions Framework LogicalWriterWrite Method
Overload List
 | Name | Description
Public method | Write(ContainerRecord) | Writes the given container record to the file stream.
Public method | Write(ObservationRecord, Boolean) | Writes the given observation record, as well as its data source and monitor settings records if necessary, to the file stream.
Top
See Also

Reference

LogicalWriter Class
GSF.PQDIF.Logical Namespace


LogicalWriter.Write Method (ContainerRecord)

Grid Solutions Framework LogicalWriterWrite Method (ContainerRecord)
Writes the given container record to the file stream.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Write(
    ContainerRecord containerRecord
)
Public Sub Write (
    containerRecord As ContainerRecord
)
member Write :
        containerRecord : ContainerRecord -> unit

function Write(containerRecord);
public:
void Write(
    ContainerRecord^ containerRecord
)

Parameters

containerRecord
Type: GSF.PQDIF.LogicalContainerRecord
The container record to be written to the PQDIF file.
See Also

Reference

LogicalWriter Class
Write Overload
GSF.PQDIF.Logical Namespace


LogicalWriter.Write Method (ObservationRecord, Boolean)

Grid Solutions Framework LogicalWriterWrite Method (ObservationRecord, Boolean)
Writes the given observation record, as well as its data source and monitor settings records if necessary, to the file stream.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Write(
    ObservationRecord observationRecord,
    bool lastRecord = false
)
Public Sub Write (
    observationRecord As ObservationRecord,
    Optional lastRecord As Boolean = false
)
member Write :
        observationRecord : ObservationRecord *
        ?lastRecord : bool
(* Defaults:
        let _lastRecord = defaultArg lastRecord false
*)
-> unit

function Write(observationRecord, lastRecord);
public:
void Write(
    ObservationRecord^ observationRecord,
    bool lastRecord = false
)

Parameters

observationRecord
Type: GSF.PQDIF.LogicalObservationRecord
The observation record to be written to the PQDIF file.
lastRecord (Optional)
Type: SystemBoolean
Indicates whether this observation record is the last record in the file.
See Also

Reference

LogicalWriter Class
Write Overload
GSF.PQDIF.Logical Namespace


LogicalWriter Properties

Grid Solutions Framework LogicalWriter Properties

The LogicalWriter type exposes the following members.

Properties
 | Name | Description
Public property | MissingTags | Gets a collection of required tags identified as missing from the records written to this PQDIF file.
Top
See Also

Reference

LogicalWriter Class
GSF.PQDIF.Logical Namespace


LogicalWriter.MissingTags Property

Grid Solutions Framework LogicalWriterMissingTags Property
Gets a collection of required tags identified as missing from the records written to this PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IReadOnlyCollection<MissingTag> MissingTags { get; }
Public ReadOnly Property MissingTags As IReadOnlyCollection(Of MissingTag)
    Get
member MissingTags : IReadOnlyCollection<MissingTag> with get

function get_MissingTags();

public:
property IReadOnlyCollection<MissingTag^>^ MissingTags {
    IReadOnlyCollection<MissingTag^>^ get ();
}

Property Value

Type: IReadOnlyCollection MissingTag
See Also

Reference

LogicalWriter Class
GSF.PQDIF.Logical Namespace


MissingTag Class

Grid Solutions Framework MissingTag Class
Represents an exception
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalMissingTag

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class MissingTag
Public NotInheritable Class MissingTag
[<SealedAttribute>]
type MissingTag =  class end
GSF.PQDIF.Logical.MissingTag = function();

Type.createClass(
    'GSF.PQDIF.Logical.MissingTag');
public ref class MissingTag sealed

The MissingTag type exposes the following members.

Constructors
 | Name | Description
Public method | MissingTag | Creates a new instance of the MissingTag class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | RecordType | Gets the type of the record in which the tag was identified as missing.
Public property | Tag | Gets the globally unique identifier for the given tag.
Public property | TagName | Gets the name of the missing tag.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


MissingTag Constructor

Grid Solutions Framework MissingTag Constructor
Creates a new instance of the MissingTag class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MissingTag(
    RecordType recordType,
    string tagName,
    Guid tag
)
Public Sub New (
    recordType As RecordType,
    tagName As String,
    tag As Guid
)
new :
        recordType : RecordType *
        tagName : string *
        tag : Guid -> MissingTag
GSF.PQDIF.Logical.MissingTag = function(recordType, tagName, tag);
public:
MissingTag(
    RecordType recordType,
    String^ tagName,
    Guid tag
)

Parameters

recordType
Type: GSF.PQDIF.PhysicalRecordType
The type of record the tag is missing from.
tagName
Type: SystemString
The name of the tag.
tag
Type: SystemGuid
The globally unique identifier for the tag.
See Also

Reference

MissingTag Class
GSF.PQDIF.Logical Namespace


MissingTag Methods

Grid Solutions Framework MissingTag Methods

The MissingTag type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MissingTag Class
GSF.PQDIF.Logical Namespace


MissingTag Properties

Grid Solutions Framework MissingTag Properties

The MissingTag type exposes the following members.

Properties
 | Name | Description
Public property | RecordType | Gets the type of the record in which the tag was identified as missing.
Public property | Tag | Gets the globally unique identifier for the given tag.
Public property | TagName | Gets the name of the missing tag.
Top
See Also

Reference

MissingTag Class
GSF.PQDIF.Logical Namespace


MissingTag.RecordType Property

Grid Solutions Framework MissingTagRecordType Property
Gets the type of the record in which the tag was identified as missing.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RecordType RecordType { get; }
Public ReadOnly Property RecordType As RecordType
    Get
member RecordType : RecordType with get

function get_RecordType();

public:
property RecordType RecordType {
    RecordType get ();
}

Property Value

Type: RecordType
See Also

Reference

MissingTag Class
GSF.PQDIF.Logical Namespace


MissingTag.Tag Property

Grid Solutions Framework MissingTagTag Property
Gets the globally unique identifier for the given tag.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid Tag { get; }
Public ReadOnly Property Tag As Guid
    Get
member Tag : Guid with get

function get_Tag();

public:
property Guid Tag {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

MissingTag Class
GSF.PQDIF.Logical Namespace


MissingTag.TagName Property

Grid Solutions Framework MissingTagTagName Property
Gets the name of the missing tag.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string TagName { get; }
Public ReadOnly Property TagName As String
    Get
member TagName : string with get

function get_TagName();

public:
property String^ TagName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

MissingTag Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord Class

Grid Solutions Framework MonitorSettingsRecord Class
Represents a monitor settings record in a PQDIF file.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalMonitorSettingsRecord

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MonitorSettingsRecord
Public Class MonitorSettingsRecord
type MonitorSettingsRecord =  class end
GSF.PQDIF.Logical.MonitorSettingsRecord = function();

Type.createClass(
    'GSF.PQDIF.Logical.MonitorSettingsRecord');
public ref class MonitorSettingsRecord

The MonitorSettingsRecord type exposes the following members.

Methods
 | Name | Description
Public method | AddNewChannelSetting | Adds a new channel setting to the collection of channel settings in this monitor settings record.
 | CreateMonitorSettingsRecord | Creates a new monitor settings record from the given physical record if the physical record is of type monitor settings. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given channel setting from the collection of channel settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ChannelSettingsArrayTag | Tag that identifies the collection of channel settings.
EffectiveTag | Tag that identifies the time that these settings become effective.
NominalFrequencyTag | Tag that identifies the nominal frequency.
OneChannelSettingTag | Tag that identifies one channel setting in the collection.
TimeInstalledTag | Tag that identifies the install time.
UseCalibrationTag | Tag that identifies the flag which determines whether to apply calibration to the series.
UseTransducerTag | Tag that identifies the flag which determines whether to apply transducer adjustments to the series.
Top
Properties
 | Name | Description
Public property | ChannelSettings | Gets or sets the settings for the channels defined in the data source.
Public property | Effective | Gets or sets the date time at which these settings become effective.
Public property | NominalFrequency | Gets or sets nominal frequency.
Public property | PhysicalRecord | Gets the physical record of the monitor settings record.
Public property | TimeInstalled | Gets or sets the time at which the settings were installed.
Public property | UseCalibration | Gets or sets the flag that determines whether the calibration settings need to be applied before using the values recorded by this monitor.
Public property | UseTransducer | Gets or sets the flag that determines whether the transducer ratio needs to be applied before using the values recorded by this monitor.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


MonitorSettingsRecord Fields

Grid Solutions Framework MonitorSettingsRecord Fields

The MonitorSettingsRecord type exposes the following members.

Fields
Name | Description
ChannelSettingsArrayTag | Tag that identifies the collection of channel settings.
EffectiveTag | Tag that identifies the time that these settings become effective.
NominalFrequencyTag | Tag that identifies the nominal frequency.
OneChannelSettingTag | Tag that identifies one channel setting in the collection.
TimeInstalledTag | Tag that identifies the install time.
UseCalibrationTag | Tag that identifies the flag which determines whether to apply calibration to the series.
UseTransducerTag | Tag that identifies the flag which determines whether to apply transducer adjustments to the series.
Top
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.ChannelSettingsArrayTag Field

Grid Solutions Framework MonitorSettingsRecordChannelSettingsArrayTag Field
Tag that identifies the collection of channel settings.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ChannelSettingsArrayTag
Public Shared ReadOnly ChannelSettingsArrayTag As Guid
static val ChannelSettingsArrayTag: Guid
var GSF.PQDIF.Logical.MonitorSettingsRecord.ChannelSettingsArrayTag
public:
static initonly Guid ChannelSettingsArrayTag

Field Value

Type: Guid
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.EffectiveTag Field

Grid Solutions Framework MonitorSettingsRecordEffectiveTag Field
Tag that identifies the time that these settings become effective.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EffectiveTag
Public Shared ReadOnly EffectiveTag As Guid
static val EffectiveTag: Guid
var GSF.PQDIF.Logical.MonitorSettingsRecord.EffectiveTag
public:
static initonly Guid EffectiveTag

Field Value

Type: Guid
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.NominalFrequencyTag Field

Grid Solutions Framework MonitorSettingsRecordNominalFrequencyTag Field
Tag that identifies the nominal frequency.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid NominalFrequencyTag
Public Shared ReadOnly NominalFrequencyTag As Guid
static val NominalFrequencyTag: Guid
var GSF.PQDIF.Logical.MonitorSettingsRecord.NominalFrequencyTag
public:
static initonly Guid NominalFrequencyTag

Field Value

Type: Guid
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.OneChannelSettingTag Field

Grid Solutions Framework MonitorSettingsRecordOneChannelSettingTag Field
Tag that identifies one channel setting in the collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid OneChannelSettingTag
Public Shared ReadOnly OneChannelSettingTag As Guid
static val OneChannelSettingTag: Guid
var GSF.PQDIF.Logical.MonitorSettingsRecord.OneChannelSettingTag
public:
static initonly Guid OneChannelSettingTag

Field Value

Type: Guid
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.TimeInstalledTag Field

Grid Solutions Framework MonitorSettingsRecordTimeInstalledTag Field
Tag that identifies the install time.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TimeInstalledTag
Public Shared ReadOnly TimeInstalledTag As Guid
static val TimeInstalledTag: Guid
var GSF.PQDIF.Logical.MonitorSettingsRecord.TimeInstalledTag
public:
static initonly Guid TimeInstalledTag

Field Value

Type: Guid
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.UseCalibrationTag Field

Grid Solutions Framework MonitorSettingsRecordUseCalibrationTag Field
Tag that identifies the flag which determines whether to apply calibration to the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid UseCalibrationTag
Public Shared ReadOnly UseCalibrationTag As Guid
static val UseCalibrationTag: Guid
var GSF.PQDIF.Logical.MonitorSettingsRecord.UseCalibrationTag
public:
static initonly Guid UseCalibrationTag

Field Value

Type: Guid
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.UseTransducerTag Field

Grid Solutions Framework MonitorSettingsRecordUseTransducerTag Field
Tag that identifies the flag which determines whether to apply transducer adjustments to the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid UseTransducerTag
Public Shared ReadOnly UseTransducerTag As Guid
static val UseTransducerTag: Guid
var GSF.PQDIF.Logical.MonitorSettingsRecord.UseTransducerTag
public:
static initonly Guid UseTransducerTag

Field Value

Type: Guid
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord Methods

Grid Solutions Framework MonitorSettingsRecord Methods

The MonitorSettingsRecord type exposes the following members.

Methods
 | Name | Description
Public method | AddNewChannelSetting | Adds a new channel setting to the collection of channel settings in this monitor settings record.
 | CreateMonitorSettingsRecord | Creates a new monitor settings record from the given physical record if the physical record is of type monitor settings. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given channel setting from the collection of channel settings.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.AddNewChannelSetting Method

Grid Solutions Framework MonitorSettingsRecordAddNewChannelSetting Method
Adds a new channel setting to the collection of channel settings in this monitor settings record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelSetting AddNewChannelSetting()
Public Function AddNewChannelSetting As ChannelSetting
member AddNewChannelSetting : unit -> ChannelSetting

function AddNewChannelSetting();
public:
ChannelSetting^ AddNewChannelSetting()

Return Value

Type: ChannelSetting

[Missing <returns> documentation for "M:GSF.PQDIF.Logical.MonitorSettingsRecord.AddNewChannelSetting"]

See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.CreateMonitorSettingsRecord Method

Grid Solutions Framework MonitorSettingsRecordCreateMonitorSettingsRecord Method
Creates a new monitor settings record from the given physical record if the physical record is of type monitor settings. Returns null if it is not.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MonitorSettingsRecord CreateMonitorSettingsRecord(
    Record physicalRecord
)
Public Shared Function CreateMonitorSettingsRecord (
    physicalRecord As Record
) As MonitorSettingsRecord
static member CreateMonitorSettingsRecord :
        physicalRecord : Record -> MonitorSettingsRecord

GSF.PQDIF.Logical.MonitorSettingsRecord.CreateMonitorSettingsRecord = function(physicalRecord);
public:
static MonitorSettingsRecord^ CreateMonitorSettingsRecord(
    Record^ physicalRecord
)

Parameters

physicalRecord
Type: GSF.PQDIF.PhysicalRecord
The physical record used to create the monitor settings record.

Return Value

Type: MonitorSettingsRecord
The new monitor settings record, or null if the physical record does not define a monitor settings record.
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.Remove Method

Grid Solutions Framework MonitorSettingsRecordRemove Method
Removes the given channel setting from the collection of channel settings.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    ChannelSetting channelSetting
)
Public Sub Remove (
    channelSetting As ChannelSetting
)
member Remove :
        channelSetting : ChannelSetting -> unit

function Remove(channelSetting);
public:
void Remove(
    ChannelSetting^ channelSetting
)

Parameters

channelSetting
Type: GSF.PQDIF.LogicalChannelSetting
The channel setting to be removed.
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord Properties

Grid Solutions Framework MonitorSettingsRecord Properties

The MonitorSettingsRecord type exposes the following members.

Properties
 | Name | Description
Public property | ChannelSettings | Gets or sets the settings for the channels defined in the data source.
Public property | Effective | Gets or sets the date time at which these settings become effective.
Public property | NominalFrequency | Gets or sets nominal frequency.
Public property | PhysicalRecord | Gets the physical record of the monitor settings record.
Public property | TimeInstalled | Gets or sets the time at which the settings were installed.
Public property | UseCalibration | Gets or sets the flag that determines whether the calibration settings need to be applied before using the values recorded by this monitor.
Public property | UseTransducer | Gets or sets the flag that determines whether the transducer ratio needs to be applied before using the values recorded by this monitor.
Top
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.ChannelSettings Property

Grid Solutions Framework MonitorSettingsRecordChannelSettings Property
Gets or sets the settings for the channels defined in the data source.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<ChannelSetting> ChannelSettings { get; }
Public ReadOnly Property ChannelSettings As IList(Of ChannelSetting)
    Get
member ChannelSettings : IList<ChannelSetting> with get

function get_ChannelSettings();

public:
property IList<ChannelSetting^>^ ChannelSettings {
    IList<ChannelSetting^>^ get ();
}

Property Value

Type: IList ChannelSetting
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.Effective Property

Grid Solutions Framework MonitorSettingsRecordEffective Property
Gets or sets the date time at which these settings become effective.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Effective { get; set; }
Public Property Effective As DateTime
    Get
    Set
member Effective : DateTime with get, set

function get_Effective();
function set_Effective(value);
public:
property DateTime Effective {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.NominalFrequency Property

Grid Solutions Framework MonitorSettingsRecordNominalFrequency Property
Gets or sets nominal frequency.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double NominalFrequency { get; set; }
Public Property NominalFrequency As Double
    Get
    Set
member NominalFrequency : float with get, set

function get_NominalFrequency();
function set_NominalFrequency(value);
public:
property double NominalFrequency {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.PhysicalRecord Property

Grid Solutions Framework MonitorSettingsRecordPhysicalRecord Property
Gets the physical record of the monitor settings record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Record PhysicalRecord { get; }
Public ReadOnly Property PhysicalRecord As Record
    Get
member PhysicalRecord : Record with get

function get_PhysicalRecord();

public:
property Record^ PhysicalRecord {
    Record^ get ();
}

Property Value

Type: Record
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.TimeInstalled Property

Grid Solutions Framework MonitorSettingsRecordTimeInstalled Property
Gets or sets the time at which the settings were installed.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime TimeInstalled { get; set; }
Public Property TimeInstalled As DateTime
    Get
    Set
member TimeInstalled : DateTime with get, set

function get_TimeInstalled();
function set_TimeInstalled(value);
public:
property DateTime TimeInstalled {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.UseCalibration Property

Grid Solutions Framework MonitorSettingsRecordUseCalibration Property
Gets or sets the flag that determines whether the calibration settings need to be applied before using the values recorded by this monitor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseCalibration { get; set; }
Public Property UseCalibration As Boolean
    Get
    Set
member UseCalibration : bool with get, set

function get_UseCalibration();
function set_UseCalibration(value);
public:
property bool UseCalibration {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


MonitorSettingsRecord.UseTransducer Property

Grid Solutions Framework MonitorSettingsRecordUseTransducer Property
Gets or sets the flag that determines whether the transducer ratio needs to be applied before using the values recorded by this monitor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseTransducer { get; set; }
Public Property UseTransducer As Boolean
    Get
    Set
member UseTransducer : bool with get, set

function get_UseTransducer();
function set_UseTransducer(value);
public:
property bool UseTransducer {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

MonitorSettingsRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord Class

Grid Solutions Framework ObservationRecord Class
Represents an observation record in a PQDIF file.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalObservationRecord

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ObservationRecord
Public Class ObservationRecord
type ObservationRecord =  class end
GSF.PQDIF.Logical.ObservationRecord = function();

Type.createClass(
    'GSF.PQDIF.Logical.ObservationRecord');
public ref class ObservationRecord

The ObservationRecord type exposes the following members.

Methods
 | Name | Description
Public method | AddNewChannelInstance | Adds a new channel instance to the collection of channel instances in this observation record.
 | CreateObservationRecord | Creates a new observation record from the given physical record if the physical record is of type observation. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given channel instance from the collection of channel instances.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ChannelInstancesTag | Tag that identifies the channel instances collection.
ObservationNameTag | Tag that identifies the name of the observation record.
OneChannelInstanceTag | Tag that identifies a single channel instance in the collection.
TimeCreateTag | Tag that identifies the time that the observation record was created.
TimeStartTag | Tag that identifies the start time of the data in the observation record.
TriggerMethodTag | Tag that identifies the type of trigger that caused the observation.
Top
Properties
 | Name | Description
Public property | ChannelInstances | Gets the channel instances in this observation record.
Public property | DataSource | Gets the data source record that defines the channels in this observation record.
Public property | Name | Gets the name of the observation record.
Public property | PhysicalRecord | Gets the physical structure of the observation record.
Public property | Settings | Gets the monitor settings record that defines the settings to be applied to this observation record.
Public property | StartTime | Gets the starting time of the data in the observation record.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


ObservationRecord Fields

Grid Solutions Framework ObservationRecord Fields

The ObservationRecord type exposes the following members.

Fields
Name | Description
ChannelInstancesTag | Tag that identifies the channel instances collection.
ObservationNameTag | Tag that identifies the name of the observation record.
OneChannelInstanceTag | Tag that identifies a single channel instance in the collection.
TimeCreateTag | Tag that identifies the time that the observation record was created.
TimeStartTag | Tag that identifies the start time of the data in the observation record.
TriggerMethodTag | Tag that identifies the type of trigger that caused the observation.
Top
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.ChannelInstancesTag Field

Grid Solutions Framework ObservationRecordChannelInstancesTag Field
Tag that identifies the channel instances collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ChannelInstancesTag
Public Shared ReadOnly ChannelInstancesTag As Guid
static val ChannelInstancesTag: Guid
var GSF.PQDIF.Logical.ObservationRecord.ChannelInstancesTag
public:
static initonly Guid ChannelInstancesTag

Field Value

Type: Guid
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.ObservationNameTag Field

Grid Solutions Framework ObservationRecordObservationNameTag Field
Tag that identifies the name of the observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ObservationNameTag
Public Shared ReadOnly ObservationNameTag As Guid
static val ObservationNameTag: Guid
var GSF.PQDIF.Logical.ObservationRecord.ObservationNameTag
public:
static initonly Guid ObservationNameTag

Field Value

Type: Guid
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.OneChannelInstanceTag Field

Grid Solutions Framework ObservationRecordOneChannelInstanceTag Field
Tag that identifies a single channel instance in the collection.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid OneChannelInstanceTag
Public Shared ReadOnly OneChannelInstanceTag As Guid
static val OneChannelInstanceTag: Guid
var GSF.PQDIF.Logical.ObservationRecord.OneChannelInstanceTag
public:
static initonly Guid OneChannelInstanceTag

Field Value

Type: Guid
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.TimeCreateTag Field

Grid Solutions Framework ObservationRecordTimeCreateTag Field
Tag that identifies the time that the observation record was created.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TimeCreateTag
Public Shared ReadOnly TimeCreateTag As Guid
static val TimeCreateTag: Guid
var GSF.PQDIF.Logical.ObservationRecord.TimeCreateTag
public:
static initonly Guid TimeCreateTag

Field Value

Type: Guid
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.TimeStartTag Field

Grid Solutions Framework ObservationRecordTimeStartTag Field
Tag that identifies the start time of the data in the observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TimeStartTag
Public Shared ReadOnly TimeStartTag As Guid
static val TimeStartTag: Guid
var GSF.PQDIF.Logical.ObservationRecord.TimeStartTag
public:
static initonly Guid TimeStartTag

Field Value

Type: Guid
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.TriggerMethodTag Field

Grid Solutions Framework ObservationRecordTriggerMethodTag Field
Tag that identifies the type of trigger that caused the observation.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TriggerMethodTag
Public Shared ReadOnly TriggerMethodTag As Guid
static val TriggerMethodTag: Guid
var GSF.PQDIF.Logical.ObservationRecord.TriggerMethodTag
public:
static initonly Guid TriggerMethodTag

Field Value

Type: Guid
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord Methods

Grid Solutions Framework ObservationRecord Methods

The ObservationRecord type exposes the following members.

Methods
 | Name | Description
Public method | AddNewChannelInstance | Adds a new channel instance to the collection of channel instances in this observation record.
 | CreateObservationRecord | Creates a new observation record from the given physical record if the physical record is of type observation. Returns null if it is not.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the given channel instance from the collection of channel instances.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.AddNewChannelInstance Method

Grid Solutions Framework ObservationRecordAddNewChannelInstance Method
Adds a new channel instance to the collection of channel instances in this observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelInstance AddNewChannelInstance()
Public Function AddNewChannelInstance As ChannelInstance
member AddNewChannelInstance : unit -> ChannelInstance

function AddNewChannelInstance();
public:
ChannelInstance^ AddNewChannelInstance()

Return Value

Type: ChannelInstance

[Missing <returns> documentation for "M:GSF.PQDIF.Logical.ObservationRecord.AddNewChannelInstance"]

See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.CreateObservationRecord Method

Grid Solutions Framework ObservationRecordCreateObservationRecord Method
Creates a new observation record from the given physical record if the physical record is of type observation. Returns null if it is not.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ObservationRecord CreateObservationRecord(
    Record physicalRecord,
    DataSourceRecord dataSource,
    MonitorSettingsRecord settings
)
Public Shared Function CreateObservationRecord (
    physicalRecord As Record,
    dataSource As DataSourceRecord,
    settings As MonitorSettingsRecord
) As ObservationRecord
static member CreateObservationRecord :
        physicalRecord : Record *
        dataSource : DataSourceRecord *
        settings : MonitorSettingsRecord -> ObservationRecord

GSF.PQDIF.Logical.ObservationRecord.CreateObservationRecord = function(physicalRecord, dataSource, settings);
public:
static ObservationRecord^ CreateObservationRecord(
    Record^ physicalRecord,
    DataSourceRecord^ dataSource,
    MonitorSettingsRecord^ settings
)

Parameters

physicalRecord
Type: GSF.PQDIF.PhysicalRecord
The physical record used to create the observation record.
dataSource
Type: GSF.PQDIF.LogicalDataSourceRecord
The data source record that defines the channels in this observation record.
settings
Type: GSF.PQDIF.LogicalMonitorSettingsRecord
The monitor settings to be applied to this observation record.

Return Value

Type: ObservationRecord
The new observation record, or null if the physical record does not define a observation record.
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.Remove Method

Grid Solutions Framework ObservationRecordRemove Method
Removes the given channel instance from the collection of channel instances.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Remove(
    ChannelInstance channelInstance
)
Public Sub Remove (
    channelInstance As ChannelInstance
)
member Remove :
        channelInstance : ChannelInstance -> unit

function Remove(channelInstance);
public:
void Remove(
    ChannelInstance^ channelInstance
)

Parameters

channelInstance
Type: GSF.PQDIF.LogicalChannelInstance
The channel instance to be removed.
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord Properties

Grid Solutions Framework ObservationRecord Properties

The ObservationRecord type exposes the following members.

Properties
 | Name | Description
Public property | ChannelInstances | Gets the channel instances in this observation record.
Public property | DataSource | Gets the data source record that defines the channels in this observation record.
Public property | Name | Gets the name of the observation record.
Public property | PhysicalRecord | Gets the physical structure of the observation record.
Public property | Settings | Gets the monitor settings record that defines the settings to be applied to this observation record.
Public property | StartTime | Gets the starting time of the data in the observation record.
Top
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.ChannelInstances Property

Grid Solutions Framework ObservationRecordChannelInstances Property
Gets the channel instances in this observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<ChannelInstance> ChannelInstances { get; }
Public ReadOnly Property ChannelInstances As IList(Of ChannelInstance)
    Get
member ChannelInstances : IList<ChannelInstance> with get

function get_ChannelInstances();

public:
property IList<ChannelInstance^>^ ChannelInstances {
    IList<ChannelInstance^>^ get ();
}

Property Value

Type: IList ChannelInstance
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.DataSource Property

Grid Solutions Framework ObservationRecordDataSource Property
Gets the data source record that defines the channels in this observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSourceRecord DataSource { get; }
Public ReadOnly Property DataSource As DataSourceRecord
    Get
member DataSource : DataSourceRecord with get

function get_DataSource();

public:
property DataSourceRecord^ DataSource {
    DataSourceRecord^ get ();
}

Property Value

Type: DataSourceRecord
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.Name Property

Grid Solutions Framework ObservationRecordName Property
Gets the name of the observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.PhysicalRecord Property

Grid Solutions Framework ObservationRecordPhysicalRecord Property
Gets the physical structure of the observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Record PhysicalRecord { get; }
Public ReadOnly Property PhysicalRecord As Record
    Get
member PhysicalRecord : Record with get

function get_PhysicalRecord();

public:
property Record^ PhysicalRecord {
    Record^ get ();
}

Property Value

Type: Record
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.Settings Property

Grid Solutions Framework ObservationRecordSettings Property
Gets the monitor settings record that defines the settings to be applied to this observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MonitorSettingsRecord Settings { get; }
Public ReadOnly Property Settings As MonitorSettingsRecord
    Get
member Settings : MonitorSettingsRecord with get

function get_Settings();

public:
property MonitorSettingsRecord^ Settings {
    MonitorSettingsRecord^ get ();
}

Property Value

Type: MonitorSettingsRecord
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


ObservationRecord.StartTime Property

Grid Solutions Framework ObservationRecordStartTime Property
Gets the starting time of the data in the observation record.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime StartTime { get; set; }
Public Property StartTime As DateTime
    Get
    Set
member StartTime : DateTime with get, set

function get_StartTime();
function set_StartTime(value);
public:
property DateTime StartTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

ObservationRecord Class
GSF.PQDIF.Logical Namespace


Phase Enumeration

Grid Solutions Framework Phase Enumeration
Phase types.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum Phase
Public Enumeration Phase
type Phase
GSF.PQDIF.Logical.Phase = function();
GSF.PQDIF.Logical.Phase.createEnum('GSF.PQDIF.Logical.Phase', false);
public enum class Phase
Members
Member name | Value | Description
None | 0 | Phase is not applicable.
AN | 1 | A-to-neutral.
BN | 2 | B-to-neutral.
CN | 3 | C-to-neutral.
NG | 4 | Neutral-to-ground.
AB | 5 | A-to-B.
BC | 6 | B-to-C.
CA | 7 | C-to-A.
Residual | 8 | Residual - the vector or point-on-wave sum of Phases A, B, and C. Should be zero in a perfectly balanced system.
Net | 9 | Net - the vector or point-on-wave sum of Phases A, B, C and the Neutral phase. Should be zero in a 4-wire system with no earth return path.
PositiveSequence | 10 | Positive sequence.
NegativeSequence | 11 | Negative sequence.
ZeroSequence | 12 | Zero sequence.
Total | 13 | The value representing a total or other summarizing value in a multi-phase system.
LineToNeutralAverage | 14 | The value representing average of 3 line-neutral values.
LineToLineAverage | 15 | The value representing average of 3 line-line values.
Worst | 16 | The value representing the "worst" of the 3 phases.
Plus | 17 | DC Positive.
Minus | 18 | DC Negative.
General1 | 19 | Generic Phase 1.
General2 | 20 | Generic Phase 2.
General3 | 21 | Generic Phase 3.
General4 | 22 | Generic Phase 4.
General5 | 23 | Generic Phase 5.
General6 | 24 | Generic Phase 6.
General7 | 25 | Generic Phase 7.
General8 | 26 | Generic Phase 8.
General9 | 27 | Generic Phase 9.
General10 | 28 | Generic Phase 10.
General11 | 29 | Generic Phase 11.
General12 | 30 | Generic Phase 12.
General13 | 31 | Generic Phase 13.
General14 | 32 | Generic Phase 14.
General15 | 33 | Generic Phase 15.
General16 | 34 | Generic Phase 16.
See Also

Reference

GSF.PQDIF.Logical Namespace


QuantityCharacteristic Class

Grid Solutions Framework QuantityCharacteristic Class
Specifies additional detail about the meaning of the series data.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalQuantityCharacteristic

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class QuantityCharacteristic
Public NotInheritable Class QuantityCharacteristic
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QuantityCharacteristic =  class end
GSF.PQDIF.Logical.QuantityCharacteristic = function();

Type.createClass(
    'GSF.PQDIF.Logical.QuantityCharacteristic');
public ref class QuantityCharacteristic abstract sealed

The QuantityCharacteristic type exposes the following members.

Methods
Name | Description
ToName | Returns the name of the given quantity characteristic.
ToString | Returns a string representation of the given quantity characteristic.
Top
Fields
Name | Description
AngleFund | Value of the power angle at fundamental frequency.
ANSITDF | Transformer derating factor.
ArithSum | Arithmetic sum.
AvgImbal | Imbalance by max deviation from average.
CrestFactor | Crest factor.
DAxis | D axis components.
DAxisField | D axis components.
DF | Displacement factor - Cosine of the phase angle between fundamental frequency voltage and current phasors.
DFArith | Displacement factor - IEEE arithmetic calculations.
DFCoSDemand | Value of displacement power factor coincident with apparent power demand.
DFDemand | Value of displacement power factor for a demand interval.
DFVector | Displacement factor - IEEE vector calculations.
EvenTHD | Even harmonic distortion (%).
EvenTHDRMS | Even THD normalized to RMS.
FlkrFreqMax | Frequence of maximum flicker harmonic.
FlkrMagAvg | Flicker average RMS value.
FlkrMagMax | Magnitude of maximum flicker harmonic.
FlkrMaxDVV | dV/V base.
FlkrPiLPF | Pi LPF.
FlkrPiMax | Pi max.
FlkrPiRoot | Pi root.
FlkrPiRootLPF | Pi root LPF.
FlkrPLT | Long term flicker.
FlkrPLTSlide | Sliding PLT.
FlkrPST | Short term flicker.
FlkrSpectrum | Flicker spectrum VRMS(F).
FlkrWgtAvg | Spectrum weighted average.
FormFactor | Form factor.
Frequency | Frequency.
HRMS | Harmonic RMS.
IHRMS | Interharmonic RMS.
Instantaneous | Instantaneous f(t).
IT | IT.
KFactor | Transformer K factor.
Linear | Linear position.
None | No quantity characteristic.
OddTHD | Odd harmonic distortion (%).
OddTHDRMS | Odd THD normalized to RMS.
P | Real power (watts).
PCoQDemand | Value of active power coincident with reactive power demand.
PCoSDemand | Value of active power coincident with apparent power demand.
PDemand | Value of active power for a demand interval.
Peak | Peak value.
PF | True power factor - (Vrms * Irms) / P.
PFArith | True power factor - IEEE arithmetic calculations.
PFCoPDemand | Value of true power factor coincident with active power demand.
PFCoQDemand | Value of true power factor coincident with reactive power demand.
PFCoSDemand | Value of true power factor coincident with apparent power demand.
PFDemand | Value of true power factor for a demand interval.
PFund | Value of fundamental frequency real power.
PFVector | True power factor - IEEE vector calculations.
PHarmonic | Net harmonic active power.
PHarmonicUnsigned | Arithmetic sum harmonic active power.
PIntg | Value of active power integrated over time (Energy - watt-hours).
PIntgNeg | Value of active power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIntgNegFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIntgPos | Value of active power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PIntgPosFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PIVLIntg | Value of active power integrated over time (Energy - watt-hours).
PIVLIntgNeg | Value of active power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIVLIntgNegFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIVLIntgPos | Value of active power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PIVLIntgPosFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PPeakDemand | Peak active power demand.
PPredDemand | Predicted value of active power for current demand interval.
Q | Reactive power (VAR).
QAxis | Q axis components.
QCoPDemand | Value of reactive power coincident with active power demand.
QCoSDemand | Value of reactive power coincident with apparent power demand.
QDemand | Value of reactive power for a demand interval.
QFund | Value of the reactive power at fundamental frequency.
QIntg | Value of reactive power integrated over time (var-hours).
QIntgNeg | Value of reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIntgNegFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIntgPos | Value of reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QIntgPosFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QIVLIntg | Value of reactive power integrated over time (var-hours).
QIVLIntgNeg | Value of reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIVLIntgNegFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIVLIntgPos | Value of reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QIVLIntgPosFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QPeakDemand | Peak reactive power demand.
QPredDemand | Predicted value of reactive power for current demand interval.
RMS | RMS value.
RMSDemand | RMS value of current for a demand interval.
RMSPeakDemand | Peak demand current.
Rotational | Rotational position.
S | Apparent power (VA).
S0S1 | Zero sequence component unbalance (%).
S2S1 | Negative sequence component unbalance (%).
SArith | Value of apparent power - IEEE arithmetic calculations.
SArithFund | Value of fundamental frequency apparent power - IEEE arithmetic calculations.
SCoPDemand | Apparent power coincident with active power demand.
SCoQDemand | Apparent power coincident with reactive power demand.
SDemand | Value of apparent power for a demand interval.
SFund | Value of fundamental frequency apparent power.
SIntg | Value of apparent power integrated over time (VA-hours).
SIntgFund | Value of fundamental frequency apparent power integrated over time (VA-hours).
SIVLIntg | Value of apparent power integrated over time (VA-hours).
SIVLIntgFund | Value of fundamental frequency apparent power integrated over time (VA-hours).
SNeg | Negative sequence component.
SPeakDemand | Peak apparent power demand.
Spectra | Spectra F(F).
SpectraHGroup | Spectra by harmonic group index.
SpectraIGroup | Spectra by interharmonic group index.
SPos | Positive sequence component.
SPredDemand | Predicted value of apparent power for current demand interval.
Status | Status data.
SVector | Value of apparent power - IEEE vector calculations.
SVectorFund | Value of fundamental frequency apparent power - IEEE vector calculations.
SZero | Zero sequence component.
TDD | Total demand distortion.
TID | Total interharmonic distortion.
TIDRMS | Total interharmonic distortion normalized to RMS.
TIF | TIF.
TIFRMS | TIF normalized to RMS.
TotalTHD | Total harmonic distortion (%).
TotalTHDRMS | Total THD normalized to RMS.
TransferFunc | Transfer function.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


QuantityCharacteristic Fields

Grid Solutions Framework QuantityCharacteristic Fields

The QuantityCharacteristic type exposes the following members.

Fields
Name | Description
AngleFund | Value of the power angle at fundamental frequency.
ANSITDF | Transformer derating factor.
ArithSum | Arithmetic sum.
AvgImbal | Imbalance by max deviation from average.
CrestFactor | Crest factor.
DAxis | D axis components.
DAxisField | D axis components.
DF | Displacement factor - Cosine of the phase angle between fundamental frequency voltage and current phasors.
DFArith | Displacement factor - IEEE arithmetic calculations.
DFCoSDemand | Value of displacement power factor coincident with apparent power demand.
DFDemand | Value of displacement power factor for a demand interval.
DFVector | Displacement factor - IEEE vector calculations.
EvenTHD | Even harmonic distortion (%).
EvenTHDRMS | Even THD normalized to RMS.
FlkrFreqMax | Frequence of maximum flicker harmonic.
FlkrMagAvg | Flicker average RMS value.
FlkrMagMax | Magnitude of maximum flicker harmonic.
FlkrMaxDVV | dV/V base.
FlkrPiLPF | Pi LPF.
FlkrPiMax | Pi max.
FlkrPiRoot | Pi root.
FlkrPiRootLPF | Pi root LPF.
FlkrPLT | Long term flicker.
FlkrPLTSlide | Sliding PLT.
FlkrPST | Short term flicker.
FlkrSpectrum | Flicker spectrum VRMS(F).
FlkrWgtAvg | Spectrum weighted average.
FormFactor | Form factor.
Frequency | Frequency.
HRMS | Harmonic RMS.
IHRMS | Interharmonic RMS.
Instantaneous | Instantaneous f(t).
IT | IT.
KFactor | Transformer K factor.
Linear | Linear position.
None | No quantity characteristic.
OddTHD | Odd harmonic distortion (%).
OddTHDRMS | Odd THD normalized to RMS.
P | Real power (watts).
PCoQDemand | Value of active power coincident with reactive power demand.
PCoSDemand | Value of active power coincident with apparent power demand.
PDemand | Value of active power for a demand interval.
Peak | Peak value.
PF | True power factor - (Vrms * Irms) / P.
PFArith | True power factor - IEEE arithmetic calculations.
PFCoPDemand | Value of true power factor coincident with active power demand.
PFCoQDemand | Value of true power factor coincident with reactive power demand.
PFCoSDemand | Value of true power factor coincident with apparent power demand.
PFDemand | Value of true power factor for a demand interval.
PFund | Value of fundamental frequency real power.
PFVector | True power factor - IEEE vector calculations.
PHarmonic | Net harmonic active power.
PHarmonicUnsigned | Arithmetic sum harmonic active power.
PIntg | Value of active power integrated over time (Energy - watt-hours).
PIntgNeg | Value of active power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIntgNegFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIntgPos | Value of active power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PIntgPosFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PIVLIntg | Value of active power integrated over time (Energy - watt-hours).
PIVLIntgNeg | Value of active power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIVLIntgNegFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the negative direction (away from load).
PIVLIntgPos | Value of active power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PIVLIntgPosFund | Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the positive direction (toward load).
PPeakDemand | Peak active power demand.
PPredDemand | Predicted value of active power for current demand interval.
Q | Reactive power (VAR).
QAxis | Q axis components.
QCoPDemand | Value of reactive power coincident with active power demand.
QCoSDemand | Value of reactive power coincident with apparent power demand.
QDemand | Value of reactive power for a demand interval.
QFund | Value of the reactive power at fundamental frequency.
QIntg | Value of reactive power integrated over time (var-hours).
QIntgNeg | Value of reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIntgNegFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIntgPos | Value of reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QIntgPosFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QIVLIntg | Value of reactive power integrated over time (var-hours).
QIVLIntgNeg | Value of reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIVLIntgNegFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).
QIVLIntgPos | Value of reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QIVLIntgPosFund | Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).
QPeakDemand | Peak reactive power demand.
QPredDemand | Predicted value of reactive power for current demand interval.
RMS | RMS value.
RMSDemand | RMS value of current for a demand interval.
RMSPeakDemand | Peak demand current.
Rotational | Rotational position.
S | Apparent power (VA).
S0S1 | Zero sequence component unbalance (%).
S2S1 | Negative sequence component unbalance (%).
SArith | Value of apparent power - IEEE arithmetic calculations.
SArithFund | Value of fundamental frequency apparent power - IEEE arithmetic calculations.
SCoPDemand | Apparent power coincident with active power demand.
SCoQDemand | Apparent power coincident with reactive power demand.
SDemand | Value of apparent power for a demand interval.
SFund | Value of fundamental frequency apparent power.
SIntg | Value of apparent power integrated over time (VA-hours).
SIntgFund | Value of fundamental frequency apparent power integrated over time (VA-hours).
SIVLIntg | Value of apparent power integrated over time (VA-hours).
SIVLIntgFund | Value of fundamental frequency apparent power integrated over time (VA-hours).
SNeg | Negative sequence component.
SPeakDemand | Peak apparent power demand.
Spectra | Spectra F(F).
SpectraHGroup | Spectra by harmonic group index.
SpectraIGroup | Spectra by interharmonic group index.
SPos | Positive sequence component.
SPredDemand | Predicted value of apparent power for current demand interval.
Status | Status data.
SVector | Value of apparent power - IEEE vector calculations.
SVectorFund | Value of fundamental frequency apparent power - IEEE vector calculations.
SZero | Zero sequence component.
TDD | Total demand distortion.
TID | Total interharmonic distortion.
TIDRMS | Total interharmonic distortion normalized to RMS.
TIF | TIF.
TIFRMS | TIF normalized to RMS.
TotalTHD | Total harmonic distortion (%).
TotalTHDRMS | Total THD normalized to RMS.
TransferFunc | Transfer function.
Top
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.AngleFund Field

Grid Solutions Framework QuantityCharacteristicAngleFund Field
Value of the power angle at fundamental frequency.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AngleFund
Public Shared ReadOnly AngleFund As Guid
static val AngleFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.AngleFund
public:
static initonly Guid AngleFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.ANSITDF Field

Grid Solutions Framework QuantityCharacteristicANSITDF Field
Transformer derating factor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ANSITDF
Public Shared ReadOnly ANSITDF As Guid
static val ANSITDF: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.ANSITDF
public:
static initonly Guid ANSITDF

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.ArithSum Field

Grid Solutions Framework QuantityCharacteristicArithSum Field
Arithmetic sum.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ArithSum
Public Shared ReadOnly ArithSum As Guid
static val ArithSum: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.ArithSum
public:
static initonly Guid ArithSum

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.AvgImbal Field

Grid Solutions Framework QuantityCharacteristicAvgImbal Field
Imbalance by max deviation from average.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AvgImbal
Public Shared ReadOnly AvgImbal As Guid
static val AvgImbal: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.AvgImbal
public:
static initonly Guid AvgImbal

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.CrestFactor Field

Grid Solutions Framework QuantityCharacteristicCrestFactor Field
Crest factor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CrestFactor
Public Shared ReadOnly CrestFactor As Guid
static val CrestFactor: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.CrestFactor
public:
static initonly Guid CrestFactor

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.DAxis Field

Grid Solutions Framework QuantityCharacteristicDAxis Field
D axis components.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DAxis
Public Shared ReadOnly DAxis As Guid
static val DAxis: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.DAxis
public:
static initonly Guid DAxis

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.DAxisField Field

Grid Solutions Framework QuantityCharacteristicDAxisField Field
D axis components.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DAxisField
Public Shared ReadOnly DAxisField As Guid
static val DAxisField: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.DAxisField
public:
static initonly Guid DAxisField

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.DF Field

Grid Solutions Framework QuantityCharacteristicDF Field
Displacement factor - Cosine of the phase angle between fundamental frequency voltage and current phasors.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DF
Public Shared ReadOnly DF As Guid
static val DF: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.DF
public:
static initonly Guid DF

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.DFArith Field

Grid Solutions Framework QuantityCharacteristicDFArith Field
Displacement factor - IEEE arithmetic calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DFArith
Public Shared ReadOnly DFArith As Guid
static val DFArith: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.DFArith
public:
static initonly Guid DFArith

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.DFCoSDemand Field

Grid Solutions Framework QuantityCharacteristicDFCoSDemand Field
Value of displacement power factor coincident with apparent power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DFCoSDemand
Public Shared ReadOnly DFCoSDemand As Guid
static val DFCoSDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.DFCoSDemand
public:
static initonly Guid DFCoSDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.DFDemand Field

Grid Solutions Framework QuantityCharacteristicDFDemand Field
Value of displacement power factor for a demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DFDemand
Public Shared ReadOnly DFDemand As Guid
static val DFDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.DFDemand
public:
static initonly Guid DFDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.DFVector Field

Grid Solutions Framework QuantityCharacteristicDFVector Field
Displacement factor - IEEE vector calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DFVector
Public Shared ReadOnly DFVector As Guid
static val DFVector: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.DFVector
public:
static initonly Guid DFVector

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.EvenTHD Field

Grid Solutions Framework QuantityCharacteristicEvenTHD Field
Even harmonic distortion (%).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EvenTHD
Public Shared ReadOnly EvenTHD As Guid
static val EvenTHD: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.EvenTHD
public:
static initonly Guid EvenTHD

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.EvenTHDRMS Field

Grid Solutions Framework QuantityCharacteristicEvenTHDRMS Field
Even THD normalized to RMS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EvenTHDRMS
Public Shared ReadOnly EvenTHDRMS As Guid
static val EvenTHDRMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.EvenTHDRMS
public:
static initonly Guid EvenTHDRMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrFreqMax Field

Grid Solutions Framework QuantityCharacteristicFlkrFreqMax Field
Frequence of maximum flicker harmonic.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrFreqMax
Public Shared ReadOnly FlkrFreqMax As Guid
static val FlkrFreqMax: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrFreqMax
public:
static initonly Guid FlkrFreqMax

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrMagAvg Field

Grid Solutions Framework QuantityCharacteristicFlkrMagAvg Field
Flicker average RMS value.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrMagAvg
Public Shared ReadOnly FlkrMagAvg As Guid
static val FlkrMagAvg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrMagAvg
public:
static initonly Guid FlkrMagAvg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrMagMax Field

Grid Solutions Framework QuantityCharacteristicFlkrMagMax Field
Magnitude of maximum flicker harmonic.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrMagMax
Public Shared ReadOnly FlkrMagMax As Guid
static val FlkrMagMax: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrMagMax
public:
static initonly Guid FlkrMagMax

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrMaxDVV Field

Grid Solutions Framework QuantityCharacteristicFlkrMaxDVV Field
dV/V base.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrMaxDVV
Public Shared ReadOnly FlkrMaxDVV As Guid
static val FlkrMaxDVV: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrMaxDVV
public:
static initonly Guid FlkrMaxDVV

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrPiLPF Field

Grid Solutions Framework QuantityCharacteristicFlkrPiLPF Field
Pi LPF.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrPiLPF
Public Shared ReadOnly FlkrPiLPF As Guid
static val FlkrPiLPF: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrPiLPF
public:
static initonly Guid FlkrPiLPF

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrPiMax Field

Grid Solutions Framework QuantityCharacteristicFlkrPiMax Field
Pi max.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrPiMax
Public Shared ReadOnly FlkrPiMax As Guid
static val FlkrPiMax: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrPiMax
public:
static initonly Guid FlkrPiMax

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrPiRoot Field

Grid Solutions Framework QuantityCharacteristicFlkrPiRoot Field
Pi root.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrPiRoot
Public Shared ReadOnly FlkrPiRoot As Guid
static val FlkrPiRoot: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrPiRoot
public:
static initonly Guid FlkrPiRoot

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrPiRootLPF Field

Grid Solutions Framework QuantityCharacteristicFlkrPiRootLPF Field
Pi root LPF.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrPiRootLPF
Public Shared ReadOnly FlkrPiRootLPF As Guid
static val FlkrPiRootLPF: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrPiRootLPF
public:
static initonly Guid FlkrPiRootLPF

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrPLT Field

Grid Solutions Framework QuantityCharacteristicFlkrPLT Field
Long term flicker.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrPLT
Public Shared ReadOnly FlkrPLT As Guid
static val FlkrPLT: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrPLT
public:
static initonly Guid FlkrPLT

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrPLTSlide Field

Grid Solutions Framework QuantityCharacteristicFlkrPLTSlide Field
Sliding PLT.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrPLTSlide
Public Shared ReadOnly FlkrPLTSlide As Guid
static val FlkrPLTSlide: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrPLTSlide
public:
static initonly Guid FlkrPLTSlide

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrPST Field

Grid Solutions Framework QuantityCharacteristicFlkrPST Field
Short term flicker.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrPST
Public Shared ReadOnly FlkrPST As Guid
static val FlkrPST: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrPST
public:
static initonly Guid FlkrPST

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrSpectrum Field

Grid Solutions Framework QuantityCharacteristicFlkrSpectrum Field
Flicker spectrum VRMS(F).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrSpectrum
Public Shared ReadOnly FlkrSpectrum As Guid
static val FlkrSpectrum: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrSpectrum
public:
static initonly Guid FlkrSpectrum

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FlkrWgtAvg Field

Grid Solutions Framework QuantityCharacteristicFlkrWgtAvg Field
Spectrum weighted average.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FlkrWgtAvg
Public Shared ReadOnly FlkrWgtAvg As Guid
static val FlkrWgtAvg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FlkrWgtAvg
public:
static initonly Guid FlkrWgtAvg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.FormFactor Field

Grid Solutions Framework QuantityCharacteristicFormFactor Field
Form factor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid FormFactor
Public Shared ReadOnly FormFactor As Guid
static val FormFactor: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.FormFactor
public:
static initonly Guid FormFactor

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Frequency Field

Grid Solutions Framework QuantityCharacteristicFrequency Field
Frequency.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Frequency
Public Shared ReadOnly Frequency As Guid
static val Frequency: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Frequency
public:
static initonly Guid Frequency

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.HRMS Field

Grid Solutions Framework QuantityCharacteristicHRMS Field
Harmonic RMS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid HRMS
Public Shared ReadOnly HRMS As Guid
static val HRMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.HRMS
public:
static initonly Guid HRMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.IHRMS Field

Grid Solutions Framework QuantityCharacteristicIHRMS Field
Interharmonic RMS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid IHRMS
Public Shared ReadOnly IHRMS As Guid
static val IHRMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.IHRMS
public:
static initonly Guid IHRMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Instantaneous Field

Grid Solutions Framework QuantityCharacteristicInstantaneous Field
Instantaneous f(t).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Instantaneous
Public Shared ReadOnly Instantaneous As Guid
static val Instantaneous: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Instantaneous
public:
static initonly Guid Instantaneous

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.IT Field

Grid Solutions Framework QuantityCharacteristicIT Field
IT.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid IT
Public Shared ReadOnly IT As Guid
static val IT: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.IT
public:
static initonly Guid IT

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.KFactor Field

Grid Solutions Framework QuantityCharacteristicKFactor Field
Transformer K factor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid KFactor
Public Shared ReadOnly KFactor As Guid
static val KFactor: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.KFactor
public:
static initonly Guid KFactor

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Linear Field

Grid Solutions Framework QuantityCharacteristicLinear Field
Linear position.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Linear
Public Shared ReadOnly Linear As Guid
static val Linear: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Linear
public:
static initonly Guid Linear

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.None Field

Grid Solutions Framework QuantityCharacteristicNone Field
No quantity characteristic.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid None
Public Shared ReadOnly None As Guid
static val None: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.None
public:
static initonly Guid None

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.OddTHD Field

Grid Solutions Framework QuantityCharacteristicOddTHD Field
Odd harmonic distortion (%).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid OddTHD
Public Shared ReadOnly OddTHD As Guid
static val OddTHD: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.OddTHD
public:
static initonly Guid OddTHD

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.OddTHDRMS Field

Grid Solutions Framework QuantityCharacteristicOddTHDRMS Field
Odd THD normalized to RMS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid OddTHDRMS
Public Shared ReadOnly OddTHDRMS As Guid
static val OddTHDRMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.OddTHDRMS
public:
static initonly Guid OddTHDRMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.P Field

Grid Solutions Framework QuantityCharacteristicP Field
Real power (watts).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid P
Public Shared ReadOnly P As Guid
static val P: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.P
public:
static initonly Guid P

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PCoQDemand Field

Grid Solutions Framework QuantityCharacteristicPCoQDemand Field
Value of active power coincident with reactive power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PCoQDemand
Public Shared ReadOnly PCoQDemand As Guid
static val PCoQDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PCoQDemand
public:
static initonly Guid PCoQDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PCoSDemand Field

Grid Solutions Framework QuantityCharacteristicPCoSDemand Field
Value of active power coincident with apparent power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PCoSDemand
Public Shared ReadOnly PCoSDemand As Guid
static val PCoSDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PCoSDemand
public:
static initonly Guid PCoSDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PDemand Field

Grid Solutions Framework QuantityCharacteristicPDemand Field
Value of active power for a demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PDemand
Public Shared ReadOnly PDemand As Guid
static val PDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PDemand
public:
static initonly Guid PDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Peak Field

Grid Solutions Framework QuantityCharacteristicPeak Field
Peak value.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Peak
Public Shared ReadOnly Peak As Guid
static val Peak: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Peak
public:
static initonly Guid Peak

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PF Field

Grid Solutions Framework QuantityCharacteristicPF Field
True power factor - (Vrms * Irms) / P.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PF
Public Shared ReadOnly PF As Guid
static val PF: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PF
public:
static initonly Guid PF

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PFArith Field

Grid Solutions Framework QuantityCharacteristicPFArith Field
True power factor - IEEE arithmetic calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PFArith
Public Shared ReadOnly PFArith As Guid
static val PFArith: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PFArith
public:
static initonly Guid PFArith

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PFCoPDemand Field

Grid Solutions Framework QuantityCharacteristicPFCoPDemand Field
Value of true power factor coincident with active power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PFCoPDemand
Public Shared ReadOnly PFCoPDemand As Guid
static val PFCoPDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PFCoPDemand
public:
static initonly Guid PFCoPDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PFCoQDemand Field

Grid Solutions Framework QuantityCharacteristicPFCoQDemand Field
Value of true power factor coincident with reactive power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PFCoQDemand
Public Shared ReadOnly PFCoQDemand As Guid
static val PFCoQDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PFCoQDemand
public:
static initonly Guid PFCoQDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PFCoSDemand Field

Grid Solutions Framework QuantityCharacteristicPFCoSDemand Field
Value of true power factor coincident with apparent power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PFCoSDemand
Public Shared ReadOnly PFCoSDemand As Guid
static val PFCoSDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PFCoSDemand
public:
static initonly Guid PFCoSDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PFDemand Field

Grid Solutions Framework QuantityCharacteristicPFDemand Field
Value of true power factor for a demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PFDemand
Public Shared ReadOnly PFDemand As Guid
static val PFDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PFDemand
public:
static initonly Guid PFDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PFund Field

Grid Solutions Framework QuantityCharacteristicPFund Field
Value of fundamental frequency real power.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PFund
Public Shared ReadOnly PFund As Guid
static val PFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PFund
public:
static initonly Guid PFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PFVector Field

Grid Solutions Framework QuantityCharacteristicPFVector Field
True power factor - IEEE vector calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PFVector
Public Shared ReadOnly PFVector As Guid
static val PFVector: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PFVector
public:
static initonly Guid PFVector

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PHarmonic Field

Grid Solutions Framework QuantityCharacteristicPHarmonic Field
Net harmonic active power.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PHarmonic
Public Shared ReadOnly PHarmonic As Guid
static val PHarmonic: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PHarmonic
public:
static initonly Guid PHarmonic

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PHarmonicUnsigned Field

Grid Solutions Framework QuantityCharacteristicPHarmonicUnsigned Field
Arithmetic sum harmonic active power.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PHarmonicUnsigned
Public Shared ReadOnly PHarmonicUnsigned As Guid
static val PHarmonicUnsigned: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PHarmonicUnsigned
public:
static initonly Guid PHarmonicUnsigned

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIntg Field

Grid Solutions Framework QuantityCharacteristicPIntg Field
Value of active power integrated over time (Energy - watt-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIntg
Public Shared ReadOnly PIntg As Guid
static val PIntg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIntg
public:
static initonly Guid PIntg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIntgNeg Field

Grid Solutions Framework QuantityCharacteristicPIntgNeg Field
Value of active power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIntgNeg
Public Shared ReadOnly PIntgNeg As Guid
static val PIntgNeg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIntgNeg
public:
static initonly Guid PIntgNeg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIntgNegFund Field

Grid Solutions Framework QuantityCharacteristicPIntgNegFund Field
Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIntgNegFund
Public Shared ReadOnly PIntgNegFund As Guid
static val PIntgNegFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIntgNegFund
public:
static initonly Guid PIntgNegFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIntgPos Field

Grid Solutions Framework QuantityCharacteristicPIntgPos Field
Value of active power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIntgPos
Public Shared ReadOnly PIntgPos As Guid
static val PIntgPos: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIntgPos
public:
static initonly Guid PIntgPos

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIntgPosFund Field

Grid Solutions Framework QuantityCharacteristicPIntgPosFund Field
Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIntgPosFund
Public Shared ReadOnly PIntgPosFund As Guid
static val PIntgPosFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIntgPosFund
public:
static initonly Guid PIntgPosFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIVLIntg Field

Grid Solutions Framework QuantityCharacteristicPIVLIntg Field
Value of active power integrated over time (Energy - watt-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIVLIntg
Public Shared ReadOnly PIVLIntg As Guid
static val PIVLIntg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIVLIntg
public:
static initonly Guid PIVLIntg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIVLIntgNeg Field

Grid Solutions Framework QuantityCharacteristicPIVLIntgNeg Field
Value of active power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIVLIntgNeg
Public Shared ReadOnly PIVLIntgNeg As Guid
static val PIVLIntgNeg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIVLIntgNeg
public:
static initonly Guid PIVLIntgNeg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIVLIntgNegFund Field

Grid Solutions Framework QuantityCharacteristicPIVLIntgNegFund Field
Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIVLIntgNegFund
Public Shared ReadOnly PIVLIntgNegFund As Guid
static val PIVLIntgNegFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIVLIntgNegFund
public:
static initonly Guid PIVLIntgNegFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIVLIntgPos Field

Grid Solutions Framework QuantityCharacteristicPIVLIntgPos Field
Value of active power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIVLIntgPos
Public Shared ReadOnly PIVLIntgPos As Guid
static val PIVLIntgPos: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIVLIntgPos
public:
static initonly Guid PIVLIntgPos

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PIVLIntgPosFund Field

Grid Solutions Framework QuantityCharacteristicPIVLIntgPosFund Field
Value of active fundamental frequency power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PIVLIntgPosFund
Public Shared ReadOnly PIVLIntgPosFund As Guid
static val PIVLIntgPosFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PIVLIntgPosFund
public:
static initonly Guid PIVLIntgPosFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PPeakDemand Field

Grid Solutions Framework QuantityCharacteristicPPeakDemand Field
Peak active power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PPeakDemand
Public Shared ReadOnly PPeakDemand As Guid
static val PPeakDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PPeakDemand
public:
static initonly Guid PPeakDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.PPredDemand Field

Grid Solutions Framework QuantityCharacteristicPPredDemand Field
Predicted value of active power for current demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PPredDemand
Public Shared ReadOnly PPredDemand As Guid
static val PPredDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.PPredDemand
public:
static initonly Guid PPredDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Q Field

Grid Solutions Framework QuantityCharacteristicQ Field
Reactive power (VAR).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Q
Public Shared ReadOnly Q As Guid
static val Q: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Q
public:
static initonly Guid Q

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QAxis Field

Grid Solutions Framework QuantityCharacteristicQAxis Field
Q axis components.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QAxis
Public Shared ReadOnly QAxis As Guid
static val QAxis: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QAxis
public:
static initonly Guid QAxis

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QCoPDemand Field

Grid Solutions Framework QuantityCharacteristicQCoPDemand Field
Value of reactive power coincident with active power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QCoPDemand
Public Shared ReadOnly QCoPDemand As Guid
static val QCoPDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QCoPDemand
public:
static initonly Guid QCoPDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QCoSDemand Field

Grid Solutions Framework QuantityCharacteristicQCoSDemand Field
Value of reactive power coincident with apparent power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QCoSDemand
Public Shared ReadOnly QCoSDemand As Guid
static val QCoSDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QCoSDemand
public:
static initonly Guid QCoSDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QDemand Field

Grid Solutions Framework QuantityCharacteristicQDemand Field
Value of reactive power for a demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QDemand
Public Shared ReadOnly QDemand As Guid
static val QDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QDemand
public:
static initonly Guid QDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QFund Field

Grid Solutions Framework QuantityCharacteristicQFund Field
Value of the reactive power at fundamental frequency.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QFund
Public Shared ReadOnly QFund As Guid
static val QFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QFund
public:
static initonly Guid QFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIntg Field

Grid Solutions Framework QuantityCharacteristicQIntg Field
Value of reactive power integrated over time (var-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIntg
Public Shared ReadOnly QIntg As Guid
static val QIntg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIntg
public:
static initonly Guid QIntg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIntgNeg Field

Grid Solutions Framework QuantityCharacteristicQIntgNeg Field
Value of reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIntgNeg
Public Shared ReadOnly QIntgNeg As Guid
static val QIntgNeg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIntgNeg
public:
static initonly Guid QIntgNeg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIntgNegFund Field

Grid Solutions Framework QuantityCharacteristicQIntgNegFund Field
Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIntgNegFund
Public Shared ReadOnly QIntgNegFund As Guid
static val QIntgNegFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIntgNegFund
public:
static initonly Guid QIntgNegFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIntgPos Field

Grid Solutions Framework QuantityCharacteristicQIntgPos Field
Value of reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIntgPos
Public Shared ReadOnly QIntgPos As Guid
static val QIntgPos: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIntgPos
public:
static initonly Guid QIntgPos

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIntgPosFund Field

Grid Solutions Framework QuantityCharacteristicQIntgPosFund Field
Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIntgPosFund
Public Shared ReadOnly QIntgPosFund As Guid
static val QIntgPosFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIntgPosFund
public:
static initonly Guid QIntgPosFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIVLIntg Field

Grid Solutions Framework QuantityCharacteristicQIVLIntg Field
Value of reactive power integrated over time (var-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIVLIntg
Public Shared ReadOnly QIVLIntg As Guid
static val QIVLIntg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIVLIntg
public:
static initonly Guid QIVLIntg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIVLIntgNeg Field

Grid Solutions Framework QuantityCharacteristicQIVLIntgNeg Field
Value of reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIVLIntgNeg
Public Shared ReadOnly QIVLIntgNeg As Guid
static val QIVLIntgNeg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIVLIntgNeg
public:
static initonly Guid QIVLIntgNeg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIVLIntgNegFund Field

Grid Solutions Framework QuantityCharacteristicQIVLIntgNegFund Field
Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the negative direction (away from load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIVLIntgNegFund
Public Shared ReadOnly QIVLIntgNegFund As Guid
static val QIVLIntgNegFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIVLIntgNegFund
public:
static initonly Guid QIVLIntgNegFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIVLIntgPos Field

Grid Solutions Framework QuantityCharacteristicQIVLIntgPos Field
Value of reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIVLIntgPos
Public Shared ReadOnly QIVLIntgPos As Guid
static val QIVLIntgPos: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIVLIntgPos
public:
static initonly Guid QIVLIntgPos

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QIVLIntgPosFund Field

Grid Solutions Framework QuantityCharacteristicQIVLIntgPosFund Field
Value of fundamental frequency reactive power integrated over time (Energy - watt-hours) in the positive direction (toward load).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QIVLIntgPosFund
Public Shared ReadOnly QIVLIntgPosFund As Guid
static val QIVLIntgPosFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QIVLIntgPosFund
public:
static initonly Guid QIVLIntgPosFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QPeakDemand Field

Grid Solutions Framework QuantityCharacteristicQPeakDemand Field
Peak reactive power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QPeakDemand
Public Shared ReadOnly QPeakDemand As Guid
static val QPeakDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QPeakDemand
public:
static initonly Guid QPeakDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.QPredDemand Field

Grid Solutions Framework QuantityCharacteristicQPredDemand Field
Predicted value of reactive power for current demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QPredDemand
Public Shared ReadOnly QPredDemand As Guid
static val QPredDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.QPredDemand
public:
static initonly Guid QPredDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.RMS Field

Grid Solutions Framework QuantityCharacteristicRMS Field
RMS value.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid RMS
Public Shared ReadOnly RMS As Guid
static val RMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.RMS
public:
static initonly Guid RMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.RMSDemand Field

Grid Solutions Framework QuantityCharacteristicRMSDemand Field
RMS value of current for a demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid RMSDemand
Public Shared ReadOnly RMSDemand As Guid
static val RMSDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.RMSDemand
public:
static initonly Guid RMSDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.RMSPeakDemand Field

Grid Solutions Framework QuantityCharacteristicRMSPeakDemand Field
Peak demand current.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid RMSPeakDemand
Public Shared ReadOnly RMSPeakDemand As Guid
static val RMSPeakDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.RMSPeakDemand
public:
static initonly Guid RMSPeakDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Rotational Field

Grid Solutions Framework QuantityCharacteristicRotational Field
Rotational position.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Rotational
Public Shared ReadOnly Rotational As Guid
static val Rotational: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Rotational
public:
static initonly Guid Rotational

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.S Field

Grid Solutions Framework QuantityCharacteristicS Field
Apparent power (VA).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid S
Public Shared ReadOnly S As Guid
static val S: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.S
public:
static initonly Guid S

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.S0S1 Field

Grid Solutions Framework QuantityCharacteristicS0S1 Field
Zero sequence component unbalance (%).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid S0S1
Public Shared ReadOnly S0S1 As Guid
static val S0S1: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.S0S1
public:
static initonly Guid S0S1

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.S2S1 Field

Grid Solutions Framework QuantityCharacteristicS2S1 Field
Negative sequence component unbalance (%).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid S2S1
Public Shared ReadOnly S2S1 As Guid
static val S2S1: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.S2S1
public:
static initonly Guid S2S1

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SArith Field

Grid Solutions Framework QuantityCharacteristicSArith Field
Value of apparent power - IEEE arithmetic calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SArith
Public Shared ReadOnly SArith As Guid
static val SArith: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SArith
public:
static initonly Guid SArith

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SArithFund Field

Grid Solutions Framework QuantityCharacteristicSArithFund Field
Value of fundamental frequency apparent power - IEEE arithmetic calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SArithFund
Public Shared ReadOnly SArithFund As Guid
static val SArithFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SArithFund
public:
static initonly Guid SArithFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SCoPDemand Field

Grid Solutions Framework QuantityCharacteristicSCoPDemand Field
Apparent power coincident with active power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SCoPDemand
Public Shared ReadOnly SCoPDemand As Guid
static val SCoPDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SCoPDemand
public:
static initonly Guid SCoPDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SCoQDemand Field

Grid Solutions Framework QuantityCharacteristicSCoQDemand Field
Apparent power coincident with reactive power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SCoQDemand
Public Shared ReadOnly SCoQDemand As Guid
static val SCoQDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SCoQDemand
public:
static initonly Guid SCoQDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SDemand Field

Grid Solutions Framework QuantityCharacteristicSDemand Field
Value of apparent power for a demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SDemand
Public Shared ReadOnly SDemand As Guid
static val SDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SDemand
public:
static initonly Guid SDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SFund Field

Grid Solutions Framework QuantityCharacteristicSFund Field
Value of fundamental frequency apparent power.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SFund
Public Shared ReadOnly SFund As Guid
static val SFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SFund
public:
static initonly Guid SFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SIntg Field

Grid Solutions Framework QuantityCharacteristicSIntg Field
Value of apparent power integrated over time (VA-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SIntg
Public Shared ReadOnly SIntg As Guid
static val SIntg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SIntg
public:
static initonly Guid SIntg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SIntgFund Field

Grid Solutions Framework QuantityCharacteristicSIntgFund Field
Value of fundamental frequency apparent power integrated over time (VA-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SIntgFund
Public Shared ReadOnly SIntgFund As Guid
static val SIntgFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SIntgFund
public:
static initonly Guid SIntgFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SIVLIntg Field

Grid Solutions Framework QuantityCharacteristicSIVLIntg Field
Value of apparent power integrated over time (VA-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SIVLIntg
Public Shared ReadOnly SIVLIntg As Guid
static val SIVLIntg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SIVLIntg
public:
static initonly Guid SIVLIntg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SIVLIntgFund Field

Grid Solutions Framework QuantityCharacteristicSIVLIntgFund Field
Value of fundamental frequency apparent power integrated over time (VA-hours).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SIVLIntgFund
Public Shared ReadOnly SIVLIntgFund As Guid
static val SIVLIntgFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SIVLIntgFund
public:
static initonly Guid SIVLIntgFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SNeg Field

Grid Solutions Framework QuantityCharacteristicSNeg Field
Negative sequence component.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SNeg
Public Shared ReadOnly SNeg As Guid
static val SNeg: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SNeg
public:
static initonly Guid SNeg

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SPeakDemand Field

Grid Solutions Framework QuantityCharacteristicSPeakDemand Field
Peak apparent power demand.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SPeakDemand
Public Shared ReadOnly SPeakDemand As Guid
static val SPeakDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SPeakDemand
public:
static initonly Guid SPeakDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Spectra Field

Grid Solutions Framework QuantityCharacteristicSpectra Field
Spectra F(F).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Spectra
Public Shared ReadOnly Spectra As Guid
static val Spectra: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Spectra
public:
static initonly Guid Spectra

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SpectraHGroup Field

Grid Solutions Framework QuantityCharacteristicSpectraHGroup Field
Spectra by harmonic group index.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SpectraHGroup
Public Shared ReadOnly SpectraHGroup As Guid
static val SpectraHGroup: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SpectraHGroup
public:
static initonly Guid SpectraHGroup

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SpectraIGroup Field

Grid Solutions Framework QuantityCharacteristicSpectraIGroup Field
Spectra by interharmonic group index.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SpectraIGroup
Public Shared ReadOnly SpectraIGroup As Guid
static val SpectraIGroup: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SpectraIGroup
public:
static initonly Guid SpectraIGroup

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SPos Field

Grid Solutions Framework QuantityCharacteristicSPos Field
Positive sequence component.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SPos
Public Shared ReadOnly SPos As Guid
static val SPos: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SPos
public:
static initonly Guid SPos

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SPredDemand Field

Grid Solutions Framework QuantityCharacteristicSPredDemand Field
Predicted value of apparent power for current demand interval.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SPredDemand
Public Shared ReadOnly SPredDemand As Guid
static val SPredDemand: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SPredDemand
public:
static initonly Guid SPredDemand

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.Status Field

Grid Solutions Framework QuantityCharacteristicStatus Field
Status data.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Status
Public Shared ReadOnly Status As Guid
static val Status: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.Status
public:
static initonly Guid Status

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SVector Field

Grid Solutions Framework QuantityCharacteristicSVector Field
Value of apparent power - IEEE vector calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SVector
Public Shared ReadOnly SVector As Guid
static val SVector: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SVector
public:
static initonly Guid SVector

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SVectorFund Field

Grid Solutions Framework QuantityCharacteristicSVectorFund Field
Value of fundamental frequency apparent power - IEEE vector calculations.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SVectorFund
Public Shared ReadOnly SVectorFund As Guid
static val SVectorFund: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SVectorFund
public:
static initonly Guid SVectorFund

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.SZero Field

Grid Solutions Framework QuantityCharacteristicSZero Field
Zero sequence component.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SZero
Public Shared ReadOnly SZero As Guid
static val SZero: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.SZero
public:
static initonly Guid SZero

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TDD Field

Grid Solutions Framework QuantityCharacteristicTDD Field
Total demand distortion.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TDD
Public Shared ReadOnly TDD As Guid
static val TDD: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TDD
public:
static initonly Guid TDD

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TID Field

Grid Solutions Framework QuantityCharacteristicTID Field
Total interharmonic distortion.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TID
Public Shared ReadOnly TID As Guid
static val TID: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TID
public:
static initonly Guid TID

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TIDRMS Field

Grid Solutions Framework QuantityCharacteristicTIDRMS Field
Total interharmonic distortion normalized to RMS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TIDRMS
Public Shared ReadOnly TIDRMS As Guid
static val TIDRMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TIDRMS
public:
static initonly Guid TIDRMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TIF Field

Grid Solutions Framework QuantityCharacteristicTIF Field
TIF.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TIF
Public Shared ReadOnly TIF As Guid
static val TIF: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TIF
public:
static initonly Guid TIF

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TIFRMS Field

Grid Solutions Framework QuantityCharacteristicTIFRMS Field
TIF normalized to RMS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TIFRMS
Public Shared ReadOnly TIFRMS As Guid
static val TIFRMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TIFRMS
public:
static initonly Guid TIFRMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TotalTHD Field

Grid Solutions Framework QuantityCharacteristicTotalTHD Field
Total harmonic distortion (%).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TotalTHD
Public Shared ReadOnly TotalTHD As Guid
static val TotalTHD: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TotalTHD
public:
static initonly Guid TotalTHD

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TotalTHDRMS Field

Grid Solutions Framework QuantityCharacteristicTotalTHDRMS Field
Total THD normalized to RMS.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TotalTHDRMS
Public Shared ReadOnly TotalTHDRMS As Guid
static val TotalTHDRMS: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TotalTHDRMS
public:
static initonly Guid TotalTHDRMS

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.TransferFunc Field

Grid Solutions Framework QuantityCharacteristicTransferFunc Field
Transfer function.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid TransferFunc
Public Shared ReadOnly TransferFunc As Guid
static val TransferFunc: Guid
var GSF.PQDIF.Logical.QuantityCharacteristic.TransferFunc
public:
static initonly Guid TransferFunc

Field Value

Type: Guid
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic Methods

Grid Solutions Framework QuantityCharacteristic Methods

The QuantityCharacteristic type exposes the following members.

Methods
Name | Description
ToName | Returns the name of the given quantity characteristic.
ToString | Returns a string representation of the given quantity characteristic.
Top
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.ToName Method

Grid Solutions Framework QuantityCharacteristicToName Method
Returns the name of the given quantity characteristic.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToName(
    Guid quantityCharacteristic
)
Public Shared Function ToName (
    quantityCharacteristic As Guid
) As String
static member ToName :
        quantityCharacteristic : Guid -> string

GSF.PQDIF.Logical.QuantityCharacteristic.ToName = function(quantityCharacteristic);
public:
static String^ ToName(
    Guid quantityCharacteristic
)

Parameters

quantityCharacteristic
Type: SystemGuid
The GUID tag which identifies the quantity characteristic.

Return Value

Type: String
The name of the given quantity characteristic.
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityCharacteristic.ToString Method

Grid Solutions Framework QuantityCharacteristicToString Method
Returns a string representation of the given quantity characteristic.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    Guid quantityCharacteristic
)
Public Shared Function ToString (
    quantityCharacteristic As Guid
) As String
static member ToString :
        quantityCharacteristic : Guid -> string

GSF.PQDIF.Logical.QuantityCharacteristic.ToString = function(quantityCharacteristic);
public:
static String^ ToString(
    Guid quantityCharacteristic
)

Parameters

quantityCharacteristic
Type: SystemGuid
The GUID tag which identifies the quantity characteristic.

Return Value

Type: String
The name of the given quantity characteristic.
See Also

Reference

QuantityCharacteristic Class
GSF.PQDIF.Logical Namespace


QuantityMeasured Enumeration

Grid Solutions Framework QuantityMeasured Enumeration
Physical quantity under measurement.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum QuantityMeasured
Public Enumeration QuantityMeasured
type QuantityMeasured
GSF.PQDIF.Logical.QuantityMeasured = function();
GSF.PQDIF.Logical.QuantityMeasured.createEnum('GSF.PQDIF.Logical.QuantityMeasured', false);
public enum class QuantityMeasured
Members
Member name | Value | Description
None | 0 | None or not applicable.
Voltage | 1 | Voltage.
Current | 2 | Current.
Power | 3 | Power - includes all data for a quantity or characteristic derived from multiplying voltage and current components.
Energy | 4 | Energy - includes all data from an integration of a quantity or characteristic derived from multiplying voltage and current components together.
Temperature | 5 | Temperature.
Pressure | 6 | Pressure.
Charge | 7 | Charge.
ElectricalField | 8 | Electrical field.
MagneticField | 9 | Magnetic field.
Velocity | 10 | Velocity.
Bearing | 11 | Compass bearing.
Force | 12 | Applied force, electrical, mechanical etc.
Torque | 13 | Torque.
Position | 14 | Spatial position.
FluxLinkage | 15 | Flux linkage Weber Turns.
FluxDensity | 16 | Magnetic field density.
Status | 17 | Status data.
See Also

Reference

GSF.PQDIF.Logical Namespace


QuantityType Class

Grid Solutions Framework QuantityType Class
The high-level description of the type of quantity which is being captured by a channel.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalQuantityType

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class QuantityType
Public NotInheritable Class QuantityType
[<AbstractClassAttribute>]
[<SealedAttribute>]
type QuantityType =  class end
GSF.PQDIF.Logical.QuantityType = function();

Type.createClass(
    'GSF.PQDIF.Logical.QuantityType');
public ref class QuantityType abstract sealed

The QuantityType type exposes the following members.

Methods
Name | Description
IsQuantityTypeID | Determines whether the given ID is a quantity type ID.
ToString | Gets the name of the quantity type with the given ID.
Top
Fields
Name | Description
CPF | Probability, value.
Flash | Time, latitude, longitude, value, polarity, ellipse.
Histogram | BinLow, BinHigh, BinID, count.
Histogram3D | XBinLow, XBinHigh, YBinLow, YBinHigh, BinID, count.
MagDur | Magnitude and duration.
MagDurCount | Time, magnitude, duration, and count.
MagDurTime | Time, magnitude, and duration.
Phasor | Time-domain measurements including magnitudes and (optionally) phase angle.
Response | Frequency-domain measurements including magnitude and (optionally) phase angle.
ValueLog | Time-based logged entries.
WaveForm | Point-on-wave measurements.
XY | X-values and y-values.
XYZ | X-values, y-values, and z-values.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


QuantityType Fields

Grid Solutions Framework QuantityType Fields

The QuantityType type exposes the following members.

Fields
Name | Description
CPF | Probability, value.
Flash | Time, latitude, longitude, value, polarity, ellipse.
Histogram | BinLow, BinHigh, BinID, count.
Histogram3D | XBinLow, XBinHigh, YBinLow, YBinHigh, BinID, count.
MagDur | Magnitude and duration.
MagDurCount | Time, magnitude, duration, and count.
MagDurTime | Time, magnitude, and duration.
Phasor | Time-domain measurements including magnitudes and (optionally) phase angle.
Response | Frequency-domain measurements including magnitude and (optionally) phase angle.
ValueLog | Time-based logged entries.
WaveForm | Point-on-wave measurements.
XY | X-values and y-values.
XYZ | X-values, y-values, and z-values.
Top
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.CPF Field

Grid Solutions Framework QuantityTypeCPF Field
Probability, value.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CPF
Public Shared ReadOnly CPF As Guid
static val CPF: Guid
var GSF.PQDIF.Logical.QuantityType.CPF
public:
static initonly Guid CPF

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.Flash Field

Grid Solutions Framework QuantityTypeFlash Field
Time, latitude, longitude, value, polarity, ellipse.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Flash
Public Shared ReadOnly Flash As Guid
static val Flash: Guid
var GSF.PQDIF.Logical.QuantityType.Flash
public:
static initonly Guid Flash

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.Histogram Field

Grid Solutions Framework QuantityTypeHistogram Field
BinLow, BinHigh, BinID, count.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Histogram
Public Shared ReadOnly Histogram As Guid
static val Histogram: Guid
var GSF.PQDIF.Logical.QuantityType.Histogram
public:
static initonly Guid Histogram

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.Histogram3D Field

Grid Solutions Framework QuantityTypeHistogram3D Field
XBinLow, XBinHigh, YBinLow, YBinHigh, BinID, count.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Histogram3D
Public Shared ReadOnly Histogram3D As Guid
static val Histogram3D: Guid
var GSF.PQDIF.Logical.QuantityType.Histogram3D
public:
static initonly Guid Histogram3D

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.MagDur Field

Grid Solutions Framework QuantityTypeMagDur Field
Magnitude and duration.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid MagDur
Public Shared ReadOnly MagDur As Guid
static val MagDur: Guid
var GSF.PQDIF.Logical.QuantityType.MagDur
public:
static initonly Guid MagDur

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.MagDurCount Field

Grid Solutions Framework QuantityTypeMagDurCount Field
Time, magnitude, duration, and count.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid MagDurCount
Public Shared ReadOnly MagDurCount As Guid
static val MagDurCount: Guid
var GSF.PQDIF.Logical.QuantityType.MagDurCount
public:
static initonly Guid MagDurCount

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.MagDurTime Field

Grid Solutions Framework QuantityTypeMagDurTime Field
Time, magnitude, and duration.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid MagDurTime
Public Shared ReadOnly MagDurTime As Guid
static val MagDurTime: Guid
var GSF.PQDIF.Logical.QuantityType.MagDurTime
public:
static initonly Guid MagDurTime

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.Phasor Field

Grid Solutions Framework QuantityTypePhasor Field
Time-domain measurements including magnitudes and (optionally) phase angle.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Phasor
Public Shared ReadOnly Phasor As Guid
static val Phasor: Guid
var GSF.PQDIF.Logical.QuantityType.Phasor
public:
static initonly Guid Phasor

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.Response Field

Grid Solutions Framework QuantityTypeResponse Field
Frequency-domain measurements including magnitude and (optionally) phase angle.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Response
Public Shared ReadOnly Response As Guid
static val Response: Guid
var GSF.PQDIF.Logical.QuantityType.Response
public:
static initonly Guid Response

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.ValueLog Field

Grid Solutions Framework QuantityTypeValueLog Field
Time-based logged entries.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ValueLog
Public Shared ReadOnly ValueLog As Guid
static val ValueLog: Guid
var GSF.PQDIF.Logical.QuantityType.ValueLog
public:
static initonly Guid ValueLog

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.WaveForm Field

Grid Solutions Framework QuantityTypeWaveForm Field
Point-on-wave measurements.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WaveForm
Public Shared ReadOnly WaveForm As Guid
static val WaveForm: Guid
var GSF.PQDIF.Logical.QuantityType.WaveForm
public:
static initonly Guid WaveForm

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.XY Field

Grid Solutions Framework QuantityTypeXY Field
X-values and y-values.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid XY
Public Shared ReadOnly XY As Guid
static val XY: Guid
var GSF.PQDIF.Logical.QuantityType.XY
public:
static initonly Guid XY

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.XYZ Field

Grid Solutions Framework QuantityTypeXYZ Field
X-values, y-values, and z-values.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid XYZ
Public Shared ReadOnly XYZ As Guid
static val XYZ: Guid
var GSF.PQDIF.Logical.QuantityType.XYZ
public:
static initonly Guid XYZ

Field Value

Type: Guid
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType Methods

Grid Solutions Framework QuantityType Methods

The QuantityType type exposes the following members.

Methods
Name | Description
IsQuantityTypeID | Determines whether the given ID is a quantity type ID.
ToString | Gets the name of the quantity type with the given ID.
Top
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.IsQuantityTypeID Method

Grid Solutions Framework QuantityTypeIsQuantityTypeID Method
Determines whether the given ID is a quantity type ID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsQuantityTypeID(
    Guid id
)
Public Shared Function IsQuantityTypeID (
    id As Guid
) As Boolean
static member IsQuantityTypeID :
        id : Guid -> bool

GSF.PQDIF.Logical.QuantityType.IsQuantityTypeID = function(id);
public:
static bool IsQuantityTypeID(
    Guid id
)

Parameters

id
Type: SystemGuid
The ID to be tested.

Return Value

Type: Boolean
True if the given ID is a quantity type ID; false otherwise.
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityType.ToString Method

Grid Solutions Framework QuantityTypeToString Method
Gets the name of the quantity type with the given ID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    Guid quantityTypeID
)
Public Shared Function ToString (
    quantityTypeID As Guid
) As String
static member ToString :
        quantityTypeID : Guid -> string

GSF.PQDIF.Logical.QuantityType.ToString = function(quantityTypeID);
public:
static String^ ToString(
    Guid quantityTypeID
)

Parameters

quantityTypeID
Type: SystemGuid
The ID of the quantity type.

Return Value

Type: String
The name of the quantity type with the given ID.
See Also

Reference

QuantityType Class
GSF.PQDIF.Logical Namespace


QuantityUnits Enumeration

Grid Solutions Framework QuantityUnits Enumeration
Units of data defined in a PQDIF file.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum QuantityUnits
Public Enumeration QuantityUnits
type QuantityUnits
GSF.PQDIF.Logical.QuantityUnits = function();
GSF.PQDIF.Logical.QuantityUnits.createEnum('GSF.PQDIF.Logical.QuantityUnits', false);
public enum class QuantityUnits
Members
Member name | Value | Description
None | 0 | Unitless.
Timestamp | 1 | Absolute time. Each timestamp in the series must be in absolute time using the Timestamp type.
Seconds | 2 | Seconds relative to the start time of an observation.
Cycles | 3 | Cycles relative to the start time of an observation.
Volts | 6 | Volts.
Amps | 7 | Amperes.
VoltAmps | 8 | Volt-amperes.
Watts | 9 | Watts.
Vars | 10 | Volt-amperes reactive.
Ohms | 11 | Ohms.
Siemens | 12 | Siemens.
VoltsPerAmp | 13 | Volts per ampere.
Joules | 14 | Joules.
Hertz | 15 | Hertz.
Celcius | 16 | Celcius.
Degrees | 17 | Degrees of arc.
Decibels | 18 | Decibels.
Percent | 19 | Percent.
PerUnit | 20 | Per-unit.
Samples | 21 | Number of counts or samples.
VarHours | 22 | Energy in var-hours.
WattHours | 23 | Energy in watt-hours.
VoltAmpHours | 24 | Energy in VA-hours.
MetersPerSecond | 25 | Meters/second.
MilesPerHour | 26 | Miles/hour.
Bars | 27 | Pressure in bars.
Pascals | 28 | Pressure in pascals.
Newtons | 29 | Force in newtons.
NewtonMeters | 30 | Torque in newton-meters.
RevolutionsPerMinute | 31 | Revolutions/minute.
RadiansPerSecond | 32 | Radians/second.
Meters | 33 | Meters.
WeberTurns | 34 | Flux linkage in Weber Turns.
Teslas | 35 | Flux density in teslas.
Webers | 36 | Magnetic field in webers.
VoltsPerVolt | 37 | Volts/volt transfer function.
AmpsPerAmp | 38 | Amps/amp transfer function.
AmpsPerVolt | 39 | Impedance transfer function.
See Also

Reference

GSF.PQDIF.Logical Namespace


SeriesDefinition Class

Grid Solutions Framework SeriesDefinition Class
Definition of a SeriesInstance.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalSeriesDefinition

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SeriesDefinition : IEquatable<SeriesDefinition>
Public Class SeriesDefinition
    Implements IEquatable(Of SeriesDefinition)
type SeriesDefinition =
    class
        interface IEquatable<SeriesDefinition>
    end
GSF.PQDIF.Logical.SeriesDefinition = function();

Type.createClass(
    'GSF.PQDIF.Logical.SeriesDefinition',
    null,
    IEquatable`1);
public ref class SeriesDefinition : IEquatable<SeriesDefinition^>

The SeriesDefinition type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesDefinition | Creates a new instance of the SeriesDefinition class.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | Equals(SeriesDefinition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasElement | Determines whether an element identified by the given tag exists in this object's physical structure.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
QuantityCharacteristicIDTag | Tag that identifies the characteristic ID of the series.
QuantityUnitsIDTag | Tag that identifies the quantity units ID of the series.
SeriesNominalQuantityTag | Tag that identifies the nominal quantity of the series.
StorageMethodIDTag | Tag that identifies the storage method ID of the series.
ValueTypeIDTag | Tag that identifies the value type ID of the series.
ValueTypeNameTag | Tag that identifies the value type name of the series.
Top
Properties
 | Name | Description
Public property | ChannelDefinition | Gets the channel definition in which the series definition resides.
Public property | PhysicalStructure | Gets the physical structure of the series definition.
Public property | QuantityCharacteristicID | Gets additional detail about the meaning of the series data.
Public property | QuantityUnits | Gets the units of the data in the series.
Public property | SeriesNominalQuantity | Gets the nominal quantity of the series.
Public property | StorageMethodID | Gets the storage method ID, which can be used with StorageMethods to determine how the data is stored.
Public property | ValueTypeID | Gets the value type ID of the series.
Public property | ValueTypeName | Gets the value type name of the series.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


SeriesDefinition Constructor

Grid Solutions Framework SeriesDefinition Constructor
Creates a new instance of the SeriesDefinition class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SeriesDefinition(
    CollectionElement physicalStructure,
    ChannelDefinition channelDefinition
)
Public Sub New (
    physicalStructure As CollectionElement,
    channelDefinition As ChannelDefinition
)
new :
        physicalStructure : CollectionElement *
        channelDefinition : ChannelDefinition -> SeriesDefinition
GSF.PQDIF.Logical.SeriesDefinition = function(physicalStructure, channelDefinition);
public:
SeriesDefinition(
    CollectionElement^ physicalStructure,
    ChannelDefinition^ channelDefinition
)

Parameters

physicalStructure
Type: GSF.PQDIF.PhysicalCollectionElement
The collection that is the physical structure of the series definition.
channelDefinition
Type: GSF.PQDIF.LogicalChannelDefinition
The channel definition in which the series definition resides.
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition Fields

Grid Solutions Framework SeriesDefinition Fields

The SeriesDefinition type exposes the following members.

Fields
Name | Description
QuantityCharacteristicIDTag | Tag that identifies the characteristic ID of the series.
QuantityUnitsIDTag | Tag that identifies the quantity units ID of the series.
SeriesNominalQuantityTag | Tag that identifies the nominal quantity of the series.
StorageMethodIDTag | Tag that identifies the storage method ID of the series.
ValueTypeIDTag | Tag that identifies the value type ID of the series.
ValueTypeNameTag | Tag that identifies the value type name of the series.
Top
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.QuantityCharacteristicIDTag Field

Grid Solutions Framework SeriesDefinitionQuantityCharacteristicIDTag Field
Tag that identifies the characteristic ID of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QuantityCharacteristicIDTag
Public Shared ReadOnly QuantityCharacteristicIDTag As Guid
static val QuantityCharacteristicIDTag: Guid
var GSF.PQDIF.Logical.SeriesDefinition.QuantityCharacteristicIDTag
public:
static initonly Guid QuantityCharacteristicIDTag

Field Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.QuantityUnitsIDTag Field

Grid Solutions Framework SeriesDefinitionQuantityUnitsIDTag Field
Tag that identifies the quantity units ID of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid QuantityUnitsIDTag
Public Shared ReadOnly QuantityUnitsIDTag As Guid
static val QuantityUnitsIDTag: Guid
var GSF.PQDIF.Logical.SeriesDefinition.QuantityUnitsIDTag
public:
static initonly Guid QuantityUnitsIDTag

Field Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.SeriesNominalQuantityTag Field

Grid Solutions Framework SeriesDefinitionSeriesNominalQuantityTag Field
Tag that identifies the nominal quantity of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesNominalQuantityTag
Public Shared ReadOnly SeriesNominalQuantityTag As Guid
static val SeriesNominalQuantityTag: Guid
var GSF.PQDIF.Logical.SeriesDefinition.SeriesNominalQuantityTag
public:
static initonly Guid SeriesNominalQuantityTag

Field Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.StorageMethodIDTag Field

Grid Solutions Framework SeriesDefinitionStorageMethodIDTag Field
Tag that identifies the storage method ID of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid StorageMethodIDTag
Public Shared ReadOnly StorageMethodIDTag As Guid
static val StorageMethodIDTag: Guid
var GSF.PQDIF.Logical.SeriesDefinition.StorageMethodIDTag
public:
static initonly Guid StorageMethodIDTag

Field Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.ValueTypeIDTag Field

Grid Solutions Framework SeriesDefinitionValueTypeIDTag Field
Tag that identifies the value type ID of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ValueTypeIDTag
Public Shared ReadOnly ValueTypeIDTag As Guid
static val ValueTypeIDTag: Guid
var GSF.PQDIF.Logical.SeriesDefinition.ValueTypeIDTag
public:
static initonly Guid ValueTypeIDTag

Field Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.ValueTypeNameTag Field

Grid Solutions Framework SeriesDefinitionValueTypeNameTag Field
Tag that identifies the value type name of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ValueTypeNameTag
Public Shared ReadOnly ValueTypeNameTag As Guid
static val ValueTypeNameTag: Guid
var GSF.PQDIF.Logical.SeriesDefinition.ValueTypeNameTag
public:
static initonly Guid ValueTypeNameTag

Field Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition Methods

Grid Solutions Framework SeriesDefinition Methods

The SeriesDefinition type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | Equals(SeriesDefinition) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasElement | Determines whether an element identified by the given tag exists in this object's physical structure.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.Equals Method

Grid Solutions Framework SeriesDefinitionEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Overrides ObjectEquals(Object).)
Public method | Equals(SeriesDefinition) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.Equals Method (Object)

Grid Solutions Framework SeriesDefinitionEquals Method (Object)
Determines whether the specified Object is equal to the current Object.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

SeriesDefinition Class
Equals Overload
GSF.PQDIF.Logical Namespace


SeriesDefinition.Equals Method (SeriesDefinition)

Grid Solutions Framework SeriesDefinitionEquals Method (SeriesDefinition)
Indicates whether the current object is equal to another object of the same type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    SeriesDefinition other
)
Public Function Equals (
    other As SeriesDefinition
) As Boolean
abstract Equals :
        other : SeriesDefinition -> bool
override Equals :
        other : SeriesDefinition -> bool
function Equals(other);
public:
virtual bool Equals(
    SeriesDefinition^ other
) sealed

Parameters

other
Type: GSF.PQDIF.LogicalSeriesDefinition
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

SeriesDefinition Class
Equals Overload
GSF.PQDIF.Logical Namespace


SeriesDefinition.GetHashCode Method

Grid Solutions Framework SeriesDefinitionGetHashCode Method
Serves as a hash function for a particular type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current Object.
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.HasElement Method

Grid Solutions Framework SeriesDefinitionHasElement Method
Determines whether an element identified by the given tag exists in this object's physical structure.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasElement(
    Guid tag
)
Public Function HasElement (
    tag As Guid
) As Boolean
member HasElement :
        tag : Guid -> bool

function HasElement(tag);
public:
bool HasElement(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag of the element to search for.

Return Value

Type: Boolean
True if the element exists; false otherwise.
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition Properties

Grid Solutions Framework SeriesDefinition Properties

The SeriesDefinition type exposes the following members.

Properties
 | Name | Description
Public property | ChannelDefinition | Gets the channel definition in which the series definition resides.
Public property | PhysicalStructure | Gets the physical structure of the series definition.
Public property | QuantityCharacteristicID | Gets additional detail about the meaning of the series data.
Public property | QuantityUnits | Gets the units of the data in the series.
Public property | SeriesNominalQuantity | Gets the nominal quantity of the series.
Public property | StorageMethodID | Gets the storage method ID, which can be used with StorageMethods to determine how the data is stored.
Public property | ValueTypeID | Gets the value type ID of the series.
Public property | ValueTypeName | Gets the value type name of the series.
Top
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.ChannelDefinition Property

Grid Solutions Framework SeriesDefinitionChannelDefinition Property
Gets the channel definition in which the series definition resides.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelDefinition ChannelDefinition { get; }
Public ReadOnly Property ChannelDefinition As ChannelDefinition
    Get
member ChannelDefinition : ChannelDefinition with get

function get_ChannelDefinition();

public:
property ChannelDefinition^ ChannelDefinition {
    ChannelDefinition^ get ();
}

Property Value

Type: ChannelDefinition
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.PhysicalStructure Property

Grid Solutions Framework SeriesDefinitionPhysicalStructure Property
Gets the physical structure of the series definition.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement PhysicalStructure { get; }
Public ReadOnly Property PhysicalStructure As CollectionElement
    Get
member PhysicalStructure : CollectionElement with get

function get_PhysicalStructure();

public:
property CollectionElement^ PhysicalStructure {
    CollectionElement^ get ();
}

Property Value

Type: CollectionElement
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.QuantityCharacteristicID Property

Grid Solutions Framework SeriesDefinitionQuantityCharacteristicID Property
Gets additional detail about the meaning of the series data.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid QuantityCharacteristicID { get; set; }
Public Property QuantityCharacteristicID As Guid
    Get
    Set
member QuantityCharacteristicID : Guid with get, set

function get_QuantityCharacteristicID();
function set_QuantityCharacteristicID(value);
public:
property Guid QuantityCharacteristicID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.QuantityUnits Property

Grid Solutions Framework SeriesDefinitionQuantityUnits Property
Gets the units of the data in the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public QuantityUnits QuantityUnits { get; set; }
Public Property QuantityUnits As QuantityUnits
    Get
    Set
member QuantityUnits : QuantityUnits with get, set

function get_QuantityUnits();
function set_QuantityUnits(value);
public:
property QuantityUnits QuantityUnits {
    QuantityUnits get ();
    void set (QuantityUnits value);
}

Property Value

Type: QuantityUnits
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.SeriesNominalQuantity Property

Grid Solutions Framework SeriesDefinitionSeriesNominalQuantity Property
Gets the nominal quantity of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double SeriesNominalQuantity { get; set; }
Public Property SeriesNominalQuantity As Double
    Get
    Set
member SeriesNominalQuantity : float with get, set

function get_SeriesNominalQuantity();
function set_SeriesNominalQuantity(value);
public:
property double SeriesNominalQuantity {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.StorageMethodID Property

Grid Solutions Framework SeriesDefinitionStorageMethodID Property
Gets the storage method ID, which can be used with StorageMethods to determine how the data is stored.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StorageMethods StorageMethodID { get; set; }
Public Property StorageMethodID As StorageMethods
    Get
    Set
member StorageMethodID : StorageMethods with get, set

function get_StorageMethodID();
function set_StorageMethodID(value);
public:
property StorageMethods StorageMethodID {
    StorageMethods get ();
    void set (StorageMethods value);
}

Property Value

Type: StorageMethods
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesDefinition.ValueTypeID Property

Grid Solutions Framework SeriesDefinitionValueTypeID Property
Gets the value type ID of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid ValueTypeID { get; set; }
Public Property ValueTypeID As Guid
    Get
    Set
member ValueTypeID : Guid with get, set

function get_ValueTypeID();
function set_ValueTypeID(value);
public:
property Guid ValueTypeID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace
GSF.PQDIF.LogicalSeriesValueType


SeriesDefinition.ValueTypeName Property

Grid Solutions Framework SeriesDefinitionValueTypeName Property
Gets the value type name of the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ValueTypeName { get; set; }
Public Property ValueTypeName As String
    Get
    Set
member ValueTypeName : string with get, set

function get_ValueTypeName();
function set_ValueTypeName(value);
public:
property String^ ValueTypeName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SeriesDefinition Class
GSF.PQDIF.Logical Namespace


SeriesInstance Class

Grid Solutions Framework SeriesInstance Class
Represents an instance of a series in a PQDIF file. A series instance resides in a ChannelInstance and is defined by a SeriesDefinition.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalSeriesInstance

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SeriesInstance : IEquatable<SeriesInstance>
Public Class SeriesInstance
    Implements IEquatable(Of SeriesInstance)
type SeriesInstance =
    class
        interface IEquatable<SeriesInstance>
    end
GSF.PQDIF.Logical.SeriesInstance = function();

Type.createClass(
    'GSF.PQDIF.Logical.SeriesInstance',
    null,
    IEquatable`1);
public ref class SeriesInstance : IEquatable<SeriesInstance^>

The SeriesInstance type exposes the following members.

Constructors
 | Name | Description
Public method | SeriesInstance | Creates a new instance of the SeriesInstance class.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified SeriesInstance is equal to the current SeriesInstance. (Overrides ObjectEquals(Object).)
Public method | Equals(SeriesInstance) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValues(IListObject) | Sets the raw values to be written to the PQDIF file as the SeriesValues.
Public method | SetValues(Object, Object, Object) | Sets the values to be written to the PQDIF file for the increment storage method.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
SeriesOffsetTag | Tag that identifies the offset value to apply to the series.
SeriesScaleTag | Tag that identifies the scale value to apply to the series.
SeriesShareChannelIndexTag | Tag that identifies the index of the channel that owns the series to be shared.
SeriesShareSeriesIndexTag | Tag that identifies the index of the series to be shared.
SeriesValuesTag | Tag that identifies the values contained in the series.
Top
Properties
 | Name | Description
Public property | Channel | Gets the channel instance in which the series instance resides.
Public property | Definition | Gets the series definition that defines the series.
Public property | OriginalValues | Gets the original data values, after expanding sequences and scale and offset modifications.
Public property | PhysicalStructure | Gets the physical structure of the series instance.
Public property | SeriesOffset | Gets the value added to the values in order to restore the original data values.
Public property | SeriesScale | Gets the value by which to scale the values in order to restore the original data values.
Public property | SeriesShareChannel | Gets the channel that owns the series to be shared.
Public property | SeriesShareChannelIndex | Gets the index of the channel that owns the series to be shared.
Public property | SeriesShareSeries | Gets the series to be shared.
Public property | SeriesShareSeriesIndex | Gets the index of the series to be shared.
Public property | SeriesValues | Gets the values contained in this series instance.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


SeriesInstance Constructor

Grid Solutions Framework SeriesInstance Constructor
Creates a new instance of the SeriesInstance class.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SeriesInstance(
    CollectionElement physicalStructure,
    ChannelInstance channel,
    SeriesDefinition definition
)
Public Sub New (
    physicalStructure As CollectionElement,
    channel As ChannelInstance,
    definition As SeriesDefinition
)
new :
        physicalStructure : CollectionElement *
        channel : ChannelInstance *
        definition : SeriesDefinition -> SeriesInstance
GSF.PQDIF.Logical.SeriesInstance = function(physicalStructure, channel, definition);
public:
SeriesInstance(
    CollectionElement^ physicalStructure,
    ChannelInstance^ channel,
    SeriesDefinition^ definition
)

Parameters

physicalStructure
Type: GSF.PQDIF.PhysicalCollectionElement
The physical structure of the series instance.
channel
Type: GSF.PQDIF.LogicalChannelInstance
The channel instance that this series instance resides in.
definition
Type: GSF.PQDIF.LogicalSeriesDefinition
The series definition that defines this series instance.
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance Fields

Grid Solutions Framework SeriesInstance Fields

The SeriesInstance type exposes the following members.

Fields
Name | Description
SeriesOffsetTag | Tag that identifies the offset value to apply to the series.
SeriesScaleTag | Tag that identifies the scale value to apply to the series.
SeriesShareChannelIndexTag | Tag that identifies the index of the channel that owns the series to be shared.
SeriesShareSeriesIndexTag | Tag that identifies the index of the series to be shared.
SeriesValuesTag | Tag that identifies the values contained in the series.
Top
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesOffsetTag Field

Grid Solutions Framework SeriesInstanceSeriesOffsetTag Field
Tag that identifies the offset value to apply to the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesOffsetTag
Public Shared ReadOnly SeriesOffsetTag As Guid
static val SeriesOffsetTag: Guid
var GSF.PQDIF.Logical.SeriesInstance.SeriesOffsetTag
public:
static initonly Guid SeriesOffsetTag

Field Value

Type: Guid
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesScaleTag Field

Grid Solutions Framework SeriesInstanceSeriesScaleTag Field
Tag that identifies the scale value to apply to the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesScaleTag
Public Shared ReadOnly SeriesScaleTag As Guid
static val SeriesScaleTag: Guid
var GSF.PQDIF.Logical.SeriesInstance.SeriesScaleTag
public:
static initonly Guid SeriesScaleTag

Field Value

Type: Guid
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesShareChannelIndexTag Field

Grid Solutions Framework SeriesInstanceSeriesShareChannelIndexTag Field
Tag that identifies the index of the channel that owns the series to be shared.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesShareChannelIndexTag
Public Shared ReadOnly SeriesShareChannelIndexTag As Guid
static val SeriesShareChannelIndexTag: Guid
var GSF.PQDIF.Logical.SeriesInstance.SeriesShareChannelIndexTag
public:
static initonly Guid SeriesShareChannelIndexTag

Field Value

Type: Guid
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesShareSeriesIndexTag Field

Grid Solutions Framework SeriesInstanceSeriesShareSeriesIndexTag Field
Tag that identifies the index of the series to be shared.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesShareSeriesIndexTag
Public Shared ReadOnly SeriesShareSeriesIndexTag As Guid
static val SeriesShareSeriesIndexTag: Guid
var GSF.PQDIF.Logical.SeriesInstance.SeriesShareSeriesIndexTag
public:
static initonly Guid SeriesShareSeriesIndexTag

Field Value

Type: Guid
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesValuesTag Field

Grid Solutions Framework SeriesInstanceSeriesValuesTag Field
Tag that identifies the values contained in the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SeriesValuesTag
Public Shared ReadOnly SeriesValuesTag As Guid
static val SeriesValuesTag: Guid
var GSF.PQDIF.Logical.SeriesInstance.SeriesValuesTag
public:
static initonly Guid SeriesValuesTag

Field Value

Type: Guid
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance Methods

Grid Solutions Framework SeriesInstance Methods

The SeriesInstance type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Determines whether the specified SeriesInstance is equal to the current SeriesInstance. (Overrides ObjectEquals(Object).)
Public method | Equals(SeriesInstance) | Indicates whether the current object is equal to another object of the same type.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValues(IListObject) | Sets the raw values to be written to the PQDIF file as the SeriesValues.
Public method | SetValues(Object, Object, Object) | Sets the values to be written to the PQDIF file for the increment storage method.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.Equals Method

Grid Solutions Framework SeriesInstanceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified SeriesInstance is equal to the current SeriesInstance. (Overrides ObjectEquals(Object).)
Public method | Equals(SeriesInstance) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.Equals Method (Object)

Grid Solutions Framework SeriesInstanceEquals Method (Object)
Determines whether the specified SeriesInstance is equal to the current SeriesInstance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The object to compare with the current object.

Return Value

Type: Boolean
true if the specified object is equal to the current object; otherwise, false.
See Also

Reference

SeriesInstance Class
Equals Overload
GSF.PQDIF.Logical Namespace


SeriesInstance.Equals Method (SeriesInstance)

Grid Solutions Framework SeriesInstanceEquals Method (SeriesInstance)
Indicates whether the current object is equal to another object of the same type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    SeriesInstance other
)
Public Function Equals (
    other As SeriesInstance
) As Boolean
abstract Equals :
        other : SeriesInstance -> bool
override Equals :
        other : SeriesInstance -> bool
function Equals(other);
public:
virtual bool Equals(
    SeriesInstance^ other
) sealed

Parameters

other
Type: GSF.PQDIF.LogicalSeriesInstance
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

SeriesInstance Class
Equals Overload
GSF.PQDIF.Logical Namespace


SeriesInstance.GetHashCode Method

Grid Solutions Framework SeriesInstanceGetHashCode Method
Serves as a hash function for a particular type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current SeriesInstance.
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SetValues Method

Grid Solutions Framework SeriesInstanceSetValues Method
Overload List
 | Name | Description
Public method | SetValues(IListObject) | Sets the raw values to be written to the PQDIF file as the SeriesValues.
Public method | SetValues(Object, Object, Object) | Sets the values to be written to the PQDIF file for the increment storage method.
Top
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SetValues Method (IList(Object))

Grid Solutions Framework SeriesInstanceSetValues Method (IListObject)
Sets the raw values to be written to the PQDIF file as the SeriesValues.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetValues(
    IList<Object> values
)
Public Sub SetValues (
    values As IList(Of Object)
)
member SetValues :
        values : IList<Object> -> unit

function SetValues(values);
public:
void SetValues(
    IList<Object^>^ values
)

Parameters

values
Type: System.Collections.GenericIList Object
The values to be written to the PQDIF file.
See Also

Reference

SeriesInstance Class
SetValues Overload
GSF.PQDIF.Logical Namespace


SeriesInstance.SetValues Method (Object, Object, Object)

Grid Solutions Framework SeriesInstanceSetValues Method (Object, Object, Object)
Sets the values to be written to the PQDIF file for the increment storage method.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetValues(
    Object start,
    Object count,
    Object increment
)
Public Sub SetValues (
    start As Object,
    count As Object,
    increment As Object
)
member SetValues :
        start : Object *
        count : Object *
        increment : Object -> unit

function SetValues(start, count, increment);
public:
void SetValues(
    Object^ start,
    Object^ count,
    Object^ increment
)

Parameters

start
Type: SystemObject
The start of the increment.
count
Type: SystemObject
The number of values in the series.
increment
Type: SystemObject
The amount by which to increment each value in the series.
See Also

Reference

SeriesInstance Class
SetValues Overload
GSF.PQDIF.Logical Namespace


SeriesInstance Properties

Grid Solutions Framework SeriesInstance Properties

The SeriesInstance type exposes the following members.

Properties
 | Name | Description
Public property | Channel | Gets the channel instance in which the series instance resides.
Public property | Definition | Gets the series definition that defines the series.
Public property | OriginalValues | Gets the original data values, after expanding sequences and scale and offset modifications.
Public property | PhysicalStructure | Gets the physical structure of the series instance.
Public property | SeriesOffset | Gets the value added to the values in order to restore the original data values.
Public property | SeriesScale | Gets the value by which to scale the values in order to restore the original data values.
Public property | SeriesShareChannel | Gets the channel that owns the series to be shared.
Public property | SeriesShareChannelIndex | Gets the index of the channel that owns the series to be shared.
Public property | SeriesShareSeries | Gets the series to be shared.
Public property | SeriesShareSeriesIndex | Gets the index of the series to be shared.
Public property | SeriesValues | Gets the values contained in this series instance.
Top
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.Channel Property

Grid Solutions Framework SeriesInstanceChannel Property
Gets the channel instance in which the series instance resides.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelInstance Channel { get; }
Public ReadOnly Property Channel As ChannelInstance
    Get
member Channel : ChannelInstance with get

function get_Channel();

public:
property ChannelInstance^ Channel {
    ChannelInstance^ get ();
}

Property Value

Type: ChannelInstance
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.Definition Property

Grid Solutions Framework SeriesInstanceDefinition Property
Gets the series definition that defines the series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SeriesDefinition Definition { get; }
Public ReadOnly Property Definition As SeriesDefinition
    Get
member Definition : SeriesDefinition with get

function get_Definition();

public:
property SeriesDefinition^ Definition {
    SeriesDefinition^ get ();
}

Property Value

Type: SeriesDefinition
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.OriginalValues Property

Grid Solutions Framework SeriesInstanceOriginalValues Property
Gets the original data values, after expanding sequences and scale and offset modifications.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<Object> OriginalValues { get; }
Public ReadOnly Property OriginalValues As IList(Of Object)
    Get
member OriginalValues : IList<Object> with get

function get_OriginalValues();

public:
property IList<Object^>^ OriginalValues {
    IList<Object^>^ get ();
}

Property Value

Type: IList Object
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.PhysicalStructure Property

Grid Solutions Framework SeriesInstancePhysicalStructure Property
Gets the physical structure of the series instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement PhysicalStructure { get; }
Public ReadOnly Property PhysicalStructure As CollectionElement
    Get
member PhysicalStructure : CollectionElement with get

function get_PhysicalStructure();

public:
property CollectionElement^ PhysicalStructure {
    CollectionElement^ get ();
}

Property Value

Type: CollectionElement
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesOffset Property

Grid Solutions Framework SeriesInstanceSeriesOffset Property
Gets the value added to the values in order to restore the original data values.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ScalarElement SeriesOffset { get; set; }
Public Property SeriesOffset As ScalarElement
    Get
    Set
member SeriesOffset : ScalarElement with get, set

function get_SeriesOffset();
function set_SeriesOffset(value);
public:
property ScalarElement^ SeriesOffset {
    ScalarElement^ get ();
    void set (ScalarElement^ value);
}

Property Value

Type: ScalarElement
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesScale Property

Grid Solutions Framework SeriesInstanceSeriesScale Property
Gets the value by which to scale the values in order to restore the original data values.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ScalarElement SeriesScale { get; set; }
Public Property SeriesScale As ScalarElement
    Get
    Set
member SeriesScale : ScalarElement with get, set

function get_SeriesScale();
function set_SeriesScale(value);
public:
property ScalarElement^ SeriesScale {
    ScalarElement^ get ();
    void set (ScalarElement^ value);
}

Property Value

Type: ScalarElement
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesShareChannel Property

Grid Solutions Framework SeriesInstanceSeriesShareChannel Property
Gets the channel that owns the series to be shared.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ChannelInstance SeriesShareChannel { get; }
Public ReadOnly Property SeriesShareChannel As ChannelInstance
    Get
member SeriesShareChannel : ChannelInstance with get

function get_SeriesShareChannel();

public:
property ChannelInstance^ SeriesShareChannel {
    ChannelInstance^ get ();
}

Property Value

Type: ChannelInstance
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesShareChannelIndex Property

Grid Solutions Framework SeriesInstanceSeriesShareChannelIndex Property
Gets the index of the channel that owns the series to be shared.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Nullable<uint> SeriesShareChannelIndex { get; set; }
Public Property SeriesShareChannelIndex As Nullable(Of UInteger)
    Get
    Set
member SeriesShareChannelIndex : Nullable<uint32> with get, set

function get_SeriesShareChannelIndex();
function set_SeriesShareChannelIndex(value);
public:
property Nullable<unsigned int> SeriesShareChannelIndex {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Property Value

Type: Nullable UInt32
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesShareSeries Property

Grid Solutions Framework SeriesInstanceSeriesShareSeries Property
Gets the series to be shared.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SeriesInstance SeriesShareSeries { get; }
Public ReadOnly Property SeriesShareSeries As SeriesInstance
    Get
member SeriesShareSeries : SeriesInstance with get

function get_SeriesShareSeries();

public:
property SeriesInstance^ SeriesShareSeries {
    SeriesInstance^ get ();
}

Property Value

Type: SeriesInstance
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesShareSeriesIndex Property

Grid Solutions Framework SeriesInstanceSeriesShareSeriesIndex Property
Gets the index of the series to be shared.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Nullable<uint> SeriesShareSeriesIndex { get; set; }
Public Property SeriesShareSeriesIndex As Nullable(Of UInteger)
    Get
    Set
member SeriesShareSeriesIndex : Nullable<uint32> with get, set

function get_SeriesShareSeriesIndex();
function set_SeriesShareSeriesIndex(value);
public:
property Nullable<unsigned int> SeriesShareSeriesIndex {
    Nullable<unsigned int> get ();
    void set (Nullable<unsigned int> value);
}

Property Value

Type: Nullable UInt32
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesInstance.SeriesValues Property

Grid Solutions Framework SeriesInstanceSeriesValues Property
Gets the values contained in this series instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public VectorElement SeriesValues { get; set; }
Public Property SeriesValues As VectorElement
    Get
    Set
member SeriesValues : VectorElement with get, set

function get_SeriesValues();
function set_SeriesValues(value);
public:
property VectorElement^ SeriesValues {
    VectorElement^ get ();
    void set (VectorElement^ value);
}

Property Value

Type: VectorElement
See Also

Reference

SeriesInstance Class
GSF.PQDIF.Logical Namespace


SeriesValueType Class

Grid Solutions Framework SeriesValueType Class
Defines tags used to identify different series value types.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalSeriesValueType

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SeriesValueType
Public NotInheritable Class SeriesValueType
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SeriesValueType =  class end
GSF.PQDIF.Logical.SeriesValueType = function();

Type.createClass(
    'GSF.PQDIF.Logical.SeriesValueType');
public ref class SeriesValueType abstract sealed

The SeriesValueType type exposes the following members.

Methods
Name | Description
ToString | Returns the name of the given series value type.
Top
Fields
Name | Description
Area | Area under the signal, usually an rms voltage, current, or other quantity.
Avg | Average.
BinHigh | BinHigh.
BinID | BinID.
BinLow | BinLow.
Count | Count.
Duration | Duration.
Ellipse | Ellipse (for lightning flash density).
Frequency | Frequency.
Inst | Instantaneous.
Interval | Interval data.
Latitude | Latitude.
Longitude | Longitude.
Max | Maximum.
Min | Minimum.
P1 | Probability: 1%.
P10 | Probability: 10%.
P5 | Probability: 5%.
P90 | Probability: 90%.
P95 | Probability: 95%.
P99 | Probability: 99%.
PhaseAngle | Phase angle.
PhaseAngleAvg | Phase angle which corresponds to an Avg series.
PhaseAngleMax | Phase angle which corresponds to a Max series.
PhaseAngleMin | Phase angle which corresponds to a Min series.
Polarity | Polarity.
Prob | Cumulative probability in percent.
Status | Status data.
Time | Time.
Transition | Transition event code series.
Val | Value type for a measurement.
XBinHigh | XBinHigh.
XBinLow | XBinLow.
YBinHigh | YBinHigh.
YBinLow | YBinLow.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


SeriesValueType Fields

Grid Solutions Framework SeriesValueType Fields

The SeriesValueType type exposes the following members.

Fields
Name | Description
Area | Area under the signal, usually an rms voltage, current, or other quantity.
Avg | Average.
BinHigh | BinHigh.
BinID | BinID.
BinLow | BinLow.
Count | Count.
Duration | Duration.
Ellipse | Ellipse (for lightning flash density).
Frequency | Frequency.
Inst | Instantaneous.
Interval | Interval data.
Latitude | Latitude.
Longitude | Longitude.
Max | Maximum.
Min | Minimum.
P1 | Probability: 1%.
P10 | Probability: 10%.
P5 | Probability: 5%.
P90 | Probability: 90%.
P95 | Probability: 95%.
P99 | Probability: 99%.
PhaseAngle | Phase angle.
PhaseAngleAvg | Phase angle which corresponds to an Avg series.
PhaseAngleMax | Phase angle which corresponds to a Max series.
PhaseAngleMin | Phase angle which corresponds to a Min series.
Polarity | Polarity.
Prob | Cumulative probability in percent.
Status | Status data.
Time | Time.
Transition | Transition event code series.
Val | Value type for a measurement.
XBinHigh | XBinHigh.
XBinLow | XBinLow.
YBinHigh | YBinHigh.
YBinLow | YBinLow.
Top
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Area Field

Grid Solutions Framework SeriesValueTypeArea Field
Area under the signal, usually an rms voltage, current, or other quantity.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Area
Public Shared ReadOnly Area As Guid
static val Area: Guid
var GSF.PQDIF.Logical.SeriesValueType.Area
public:
static initonly Guid Area

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Avg Field

Grid Solutions Framework SeriesValueTypeAvg Field
Average.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Avg
Public Shared ReadOnly Avg As Guid
static val Avg: Guid
var GSF.PQDIF.Logical.SeriesValueType.Avg
public:
static initonly Guid Avg

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.BinHigh Field

Grid Solutions Framework SeriesValueTypeBinHigh Field
BinHigh.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BinHigh
Public Shared ReadOnly BinHigh As Guid
static val BinHigh: Guid
var GSF.PQDIF.Logical.SeriesValueType.BinHigh
public:
static initonly Guid BinHigh

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.BinID Field

Grid Solutions Framework SeriesValueTypeBinID Field
BinID.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BinID
Public Shared ReadOnly BinID As Guid
static val BinID: Guid
var GSF.PQDIF.Logical.SeriesValueType.BinID
public:
static initonly Guid BinID

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.BinLow Field

Grid Solutions Framework SeriesValueTypeBinLow Field
BinLow.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BinLow
Public Shared ReadOnly BinLow As Guid
static val BinLow: Guid
var GSF.PQDIF.Logical.SeriesValueType.BinLow
public:
static initonly Guid BinLow

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Count Field

Grid Solutions Framework SeriesValueTypeCount Field
Count.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Count
Public Shared ReadOnly Count As Guid
static val Count: Guid
var GSF.PQDIF.Logical.SeriesValueType.Count
public:
static initonly Guid Count

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Duration Field

Grid Solutions Framework SeriesValueTypeDuration Field
Duration.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Duration
Public Shared ReadOnly Duration As Guid
static val Duration: Guid
var GSF.PQDIF.Logical.SeriesValueType.Duration
public:
static initonly Guid Duration

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Ellipse Field

Grid Solutions Framework SeriesValueTypeEllipse Field
Ellipse (for lightning flash density).

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Ellipse
Public Shared ReadOnly Ellipse As Guid
static val Ellipse: Guid
var GSF.PQDIF.Logical.SeriesValueType.Ellipse
public:
static initonly Guid Ellipse

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Frequency Field

Grid Solutions Framework SeriesValueTypeFrequency Field
Frequency.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Frequency
Public Shared ReadOnly Frequency As Guid
static val Frequency: Guid
var GSF.PQDIF.Logical.SeriesValueType.Frequency
public:
static initonly Guid Frequency

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Inst Field

Grid Solutions Framework SeriesValueTypeInst Field
Instantaneous.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Inst
Public Shared ReadOnly Inst As Guid
static val Inst: Guid
var GSF.PQDIF.Logical.SeriesValueType.Inst
public:
static initonly Guid Inst

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Interval Field

Grid Solutions Framework SeriesValueTypeInterval Field
Interval data.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Interval
Public Shared ReadOnly Interval As Guid
static val Interval: Guid
var GSF.PQDIF.Logical.SeriesValueType.Interval
public:
static initonly Guid Interval

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Latitude Field

Grid Solutions Framework SeriesValueTypeLatitude Field
Latitude.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Latitude
Public Shared ReadOnly Latitude As Guid
static val Latitude: Guid
var GSF.PQDIF.Logical.SeriesValueType.Latitude
public:
static initonly Guid Latitude

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Longitude Field

Grid Solutions Framework SeriesValueTypeLongitude Field
Longitude.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Longitude
Public Shared ReadOnly Longitude As Guid
static val Longitude: Guid
var GSF.PQDIF.Logical.SeriesValueType.Longitude
public:
static initonly Guid Longitude

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Max Field

Grid Solutions Framework SeriesValueTypeMax Field
Maximum.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Max
Public Shared ReadOnly Max As Guid
static val Max: Guid
var GSF.PQDIF.Logical.SeriesValueType.Max
public:
static initonly Guid Max

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Min Field

Grid Solutions Framework SeriesValueTypeMin Field
Minimum.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Min
Public Shared ReadOnly Min As Guid
static val Min: Guid
var GSF.PQDIF.Logical.SeriesValueType.Min
public:
static initonly Guid Min

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.P1 Field

Grid Solutions Framework SeriesValueTypeP1 Field
Probability: 1%.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid P1
Public Shared ReadOnly P1 As Guid
static val P1: Guid
var GSF.PQDIF.Logical.SeriesValueType.P1
public:
static initonly Guid P1

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.P10 Field

Grid Solutions Framework SeriesValueTypeP10 Field
Probability: 10%.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid P10
Public Shared ReadOnly P10 As Guid
static val P10: Guid
var GSF.PQDIF.Logical.SeriesValueType.P10
public:
static initonly Guid P10

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.P5 Field

Grid Solutions Framework SeriesValueTypeP5 Field
Probability: 5%.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid P5
Public Shared ReadOnly P5 As Guid
static val P5: Guid
var GSF.PQDIF.Logical.SeriesValueType.P5
public:
static initonly Guid P5

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.P90 Field

Grid Solutions Framework SeriesValueTypeP90 Field
Probability: 90%.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid P90
Public Shared ReadOnly P90 As Guid
static val P90: Guid
var GSF.PQDIF.Logical.SeriesValueType.P90
public:
static initonly Guid P90

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.P95 Field

Grid Solutions Framework SeriesValueTypeP95 Field
Probability: 95%.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid P95
Public Shared ReadOnly P95 As Guid
static val P95: Guid
var GSF.PQDIF.Logical.SeriesValueType.P95
public:
static initonly Guid P95

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.P99 Field

Grid Solutions Framework SeriesValueTypeP99 Field
Probability: 99%.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid P99
Public Shared ReadOnly P99 As Guid
static val P99: Guid
var GSF.PQDIF.Logical.SeriesValueType.P99
public:
static initonly Guid P99

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.PhaseAngle Field

Grid Solutions Framework SeriesValueTypePhaseAngle Field
Phase angle.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PhaseAngle
Public Shared ReadOnly PhaseAngle As Guid
static val PhaseAngle: Guid
var GSF.PQDIF.Logical.SeriesValueType.PhaseAngle
public:
static initonly Guid PhaseAngle

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.PhaseAngleAvg Field

Grid Solutions Framework SeriesValueTypePhaseAngleAvg Field
Phase angle which corresponds to an Avg series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PhaseAngleAvg
Public Shared ReadOnly PhaseAngleAvg As Guid
static val PhaseAngleAvg: Guid
var GSF.PQDIF.Logical.SeriesValueType.PhaseAngleAvg
public:
static initonly Guid PhaseAngleAvg

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.PhaseAngleMax Field

Grid Solutions Framework SeriesValueTypePhaseAngleMax Field
Phase angle which corresponds to a Max series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PhaseAngleMax
Public Shared ReadOnly PhaseAngleMax As Guid
static val PhaseAngleMax: Guid
var GSF.PQDIF.Logical.SeriesValueType.PhaseAngleMax
public:
static initonly Guid PhaseAngleMax

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.PhaseAngleMin Field

Grid Solutions Framework SeriesValueTypePhaseAngleMin Field
Phase angle which corresponds to a Min series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PhaseAngleMin
Public Shared ReadOnly PhaseAngleMin As Guid
static val PhaseAngleMin: Guid
var GSF.PQDIF.Logical.SeriesValueType.PhaseAngleMin
public:
static initonly Guid PhaseAngleMin

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Polarity Field

Grid Solutions Framework SeriesValueTypePolarity Field
Polarity.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Polarity
Public Shared ReadOnly Polarity As Guid
static val Polarity: Guid
var GSF.PQDIF.Logical.SeriesValueType.Polarity
public:
static initonly Guid Polarity

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Prob Field

Grid Solutions Framework SeriesValueTypeProb Field
Cumulative probability in percent.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Prob
Public Shared ReadOnly Prob As Guid
static val Prob: Guid
var GSF.PQDIF.Logical.SeriesValueType.Prob
public:
static initonly Guid Prob

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Status Field

Grid Solutions Framework SeriesValueTypeStatus Field
Status data.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Status
Public Shared ReadOnly Status As Guid
static val Status: Guid
var GSF.PQDIF.Logical.SeriesValueType.Status
public:
static initonly Guid Status

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Time Field

Grid Solutions Framework SeriesValueTypeTime Field
Time.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Time
Public Shared ReadOnly Time As Guid
static val Time: Guid
var GSF.PQDIF.Logical.SeriesValueType.Time
public:
static initonly Guid Time

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Transition Field

Grid Solutions Framework SeriesValueTypeTransition Field
Transition event code series.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Transition
Public Shared ReadOnly Transition As Guid
static val Transition: Guid
var GSF.PQDIF.Logical.SeriesValueType.Transition
public:
static initonly Guid Transition

Field Value

Type: Guid
Remarks
This series contains codes corresponding to values in a value series that indicates what kind of transition caused the event to be recorded. Used only with VALUELOG data.
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.Val Field

Grid Solutions Framework SeriesValueTypeVal Field
Value type for a measurement.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Val
Public Shared ReadOnly Val As Guid
static val Val: Guid
var GSF.PQDIF.Logical.SeriesValueType.Val
public:
static initonly Guid Val

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.XBinHigh Field

Grid Solutions Framework SeriesValueTypeXBinHigh Field
XBinHigh.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid XBinHigh
Public Shared ReadOnly XBinHigh As Guid
static val XBinHigh: Guid
var GSF.PQDIF.Logical.SeriesValueType.XBinHigh
public:
static initonly Guid XBinHigh

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.XBinLow Field

Grid Solutions Framework SeriesValueTypeXBinLow Field
XBinLow.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid XBinLow
Public Shared ReadOnly XBinLow As Guid
static val XBinLow: Guid
var GSF.PQDIF.Logical.SeriesValueType.XBinLow
public:
static initonly Guid XBinLow

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.YBinHigh Field

Grid Solutions Framework SeriesValueTypeYBinHigh Field
YBinHigh.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid YBinHigh
Public Shared ReadOnly YBinHigh As Guid
static val YBinHigh: Guid
var GSF.PQDIF.Logical.SeriesValueType.YBinHigh
public:
static initonly Guid YBinHigh

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.YBinLow Field

Grid Solutions Framework SeriesValueTypeYBinLow Field
YBinLow.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid YBinLow
Public Shared ReadOnly YBinLow As Guid
static val YBinLow: Guid
var GSF.PQDIF.Logical.SeriesValueType.YBinLow
public:
static initonly Guid YBinLow

Field Value

Type: Guid
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType Methods

Grid Solutions Framework SeriesValueType Methods

The SeriesValueType type exposes the following members.

Methods
Name | Description
ToString | Returns the name of the given series value type.
Top
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


SeriesValueType.ToString Method

Grid Solutions Framework SeriesValueTypeToString Method
Returns the name of the given series value type.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    Guid seriesValueType
)
Public Shared Function ToString (
    seriesValueType As Guid
) As String
static member ToString :
        seriesValueType : Guid -> string

GSF.PQDIF.Logical.SeriesValueType.ToString = function(seriesValueType);
public:
static String^ ToString(
    Guid seriesValueType
)

Parameters

seriesValueType
Type: SystemGuid
The GUID tag which identifies the series value type.

Return Value

Type: String
The name of the given series value type.
See Also

Reference

SeriesValueType Class
GSF.PQDIF.Logical Namespace


StorageMethods Enumeration

Grid Solutions Framework StorageMethods Enumeration
Defines flags that determine the how the data is stored in a series instance.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum StorageMethods
<FlagsAttribute>
Public Enumeration StorageMethods
[<FlagsAttribute>]
type StorageMethods
GSF.PQDIF.Logical.StorageMethods = function();
GSF.PQDIF.Logical.StorageMethods.createEnum('GSF.PQDIF.Logical.StorageMethods', true);
[FlagsAttribute]
public enum class StorageMethods
Members
Member name | Value | Description
Values | 1 | Straight array of data points.
Scaled | 2 | Data values are scaled.
Increment | 4 | Start, count, and increment are stored and the series is recreated from those values.
See Also

Reference

GSF.PQDIF.Logical Namespace


Vendor Class

Grid Solutions Framework Vendor Class
Vendors for power quality hardware.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.LogicalVendor

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Vendor
Public NotInheritable Class Vendor
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Vendor =  class end
GSF.PQDIF.Logical.Vendor = function();

Type.createClass(
    'GSF.PQDIF.Logical.Vendor');
public ref class Vendor abstract sealed

The Vendor type exposes the following members.

Methods
Name | Description
ToString | Converts the given vendor ID to a string containing the name of the vendor.
Top
Fields
Name | Description
ACTL | The ID for vendor ACTL.
AdvanTech | The ID for vendor AdvanTech.
BMI | The ID for vendor BMI.
BPA | The ID for vendor BPA.
CESI | The ID for vendor CESI.
Cooper | The ID for vendor Cooper.
DCG | The ID for vendor DCG.
Dranetz | The ID for vendor Dranetz.
EDF | The ID for vendor EDF.
ELCOM | The ID for vendor ELCOM.
Electrotek | The ID for vendor Electrotek.
EPRI | The ID for vendor Electric Power Research Institute.
Fluke | The ID for vendor Fluke.
GE | The ID for vendor General Electric.
HydroQuebec | The ID for vendor Hydro-Quebec.
IEEE | The ID for vendor IEEE.
KreissJohnson | The ID for vendor Kreiss Johnson.
LEM | The ID for vendor LEM.
MetOne | The ID for vendor Met One.
Metrosonic | The ID for vendor Metrosonic.
None | The ID representing no vendor.
PMI | The ID for vendor PMI.
PML | The ID for vendor PML.
PSI | The ID for vendor PSI.
PTI | The ID for vendor PTI.
PublicDomain | The ID for public domain hardware.
RPM | The ID for vendor RPM.
SATEC | The ID for vendor SATEC.
SquareDPowerLogic | The ID for vendor Square D PowerLogic.
Telog | The ID for vendor Telog.
Trinergi | The ID for vendor Trinergi.
WPT | The ID for vendor WPT.
Top
See Also

Reference

GSF.PQDIF.Logical Namespace


Vendor Fields

Grid Solutions Framework Vendor Fields

The Vendor type exposes the following members.

Fields
Name | Description
ACTL | The ID for vendor ACTL.
AdvanTech | The ID for vendor AdvanTech.
BMI | The ID for vendor BMI.
BPA | The ID for vendor BPA.
CESI | The ID for vendor CESI.
Cooper | The ID for vendor Cooper.
DCG | The ID for vendor DCG.
Dranetz | The ID for vendor Dranetz.
EDF | The ID for vendor EDF.
ELCOM | The ID for vendor ELCOM.
Electrotek | The ID for vendor Electrotek.
EPRI | The ID for vendor Electric Power Research Institute.
Fluke | The ID for vendor Fluke.
GE | The ID for vendor General Electric.
HydroQuebec | The ID for vendor Hydro-Quebec.
IEEE | The ID for vendor IEEE.
KreissJohnson | The ID for vendor Kreiss Johnson.
LEM | The ID for vendor LEM.
MetOne | The ID for vendor Met One.
Metrosonic | The ID for vendor Metrosonic.
None | The ID representing no vendor.
PMI | The ID for vendor PMI.
PML | The ID for vendor PML.
PSI | The ID for vendor PSI.
PTI | The ID for vendor PTI.
PublicDomain | The ID for public domain hardware.
RPM | The ID for vendor RPM.
SATEC | The ID for vendor SATEC.
SquareDPowerLogic | The ID for vendor Square D PowerLogic.
Telog | The ID for vendor Telog.
Trinergi | The ID for vendor Trinergi.
WPT | The ID for vendor WPT.
Top
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.ACTL Field

Grid Solutions Framework VendorACTL Field
The ID for vendor ACTL.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ACTL
Public Shared ReadOnly ACTL As Guid
static val ACTL: Guid
var GSF.PQDIF.Logical.Vendor.ACTL
public:
static initonly Guid ACTL

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.AdvanTech Field

Grid Solutions Framework VendorAdvanTech Field
The ID for vendor AdvanTech.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid AdvanTech
Public Shared ReadOnly AdvanTech As Guid
static val AdvanTech: Guid
var GSF.PQDIF.Logical.Vendor.AdvanTech
public:
static initonly Guid AdvanTech

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.BMI Field

Grid Solutions Framework VendorBMI Field
The ID for vendor BMI.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BMI
Public Shared ReadOnly BMI As Guid
static val BMI: Guid
var GSF.PQDIF.Logical.Vendor.BMI
public:
static initonly Guid BMI

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.BPA Field

Grid Solutions Framework VendorBPA Field
The ID for vendor BPA.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid BPA
Public Shared ReadOnly BPA As Guid
static val BPA: Guid
var GSF.PQDIF.Logical.Vendor.BPA
public:
static initonly Guid BPA

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.CESI Field

Grid Solutions Framework VendorCESI Field
The ID for vendor CESI.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid CESI
Public Shared ReadOnly CESI As Guid
static val CESI: Guid
var GSF.PQDIF.Logical.Vendor.CESI
public:
static initonly Guid CESI

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.Cooper Field

Grid Solutions Framework VendorCooper Field
The ID for vendor Cooper.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Cooper
Public Shared ReadOnly Cooper As Guid
static val Cooper: Guid
var GSF.PQDIF.Logical.Vendor.Cooper
public:
static initonly Guid Cooper

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.DCG Field

Grid Solutions Framework VendorDCG Field
The ID for vendor DCG.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid DCG
Public Shared ReadOnly DCG As Guid
static val DCG: Guid
var GSF.PQDIF.Logical.Vendor.DCG
public:
static initonly Guid DCG

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.Dranetz Field

Grid Solutions Framework VendorDranetz Field
The ID for vendor Dranetz.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Dranetz
Public Shared ReadOnly Dranetz As Guid
static val Dranetz: Guid
var GSF.PQDIF.Logical.Vendor.Dranetz
public:
static initonly Guid Dranetz

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.EDF Field

Grid Solutions Framework VendorEDF Field
The ID for vendor EDF.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EDF
Public Shared ReadOnly EDF As Guid
static val EDF: Guid
var GSF.PQDIF.Logical.Vendor.EDF
public:
static initonly Guid EDF

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.ELCOM Field

Grid Solutions Framework VendorELCOM Field
The ID for vendor ELCOM.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid ELCOM
Public Shared ReadOnly ELCOM As Guid
static val ELCOM: Guid
var GSF.PQDIF.Logical.Vendor.ELCOM
public:
static initonly Guid ELCOM

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.Electrotek Field

Grid Solutions Framework VendorElectrotek Field
The ID for vendor Electrotek.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Electrotek
Public Shared ReadOnly Electrotek As Guid
static val Electrotek: Guid
var GSF.PQDIF.Logical.Vendor.Electrotek
public:
static initonly Guid Electrotek

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.EPRI Field

Grid Solutions Framework VendorEPRI Field
The ID for vendor Electric Power Research Institute.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid EPRI
Public Shared ReadOnly EPRI As Guid
static val EPRI: Guid
var GSF.PQDIF.Logical.Vendor.EPRI
public:
static initonly Guid EPRI

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.Fluke Field

Grid Solutions Framework VendorFluke Field
The ID for vendor Fluke.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Fluke
Public Shared ReadOnly Fluke As Guid
static val Fluke: Guid
var GSF.PQDIF.Logical.Vendor.Fluke
public:
static initonly Guid Fluke

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.GE Field

Grid Solutions Framework VendorGE Field
The ID for vendor General Electric.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid GE
Public Shared ReadOnly GE As Guid
static val GE: Guid
var GSF.PQDIF.Logical.Vendor.GE
public:
static initonly Guid GE

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.HydroQuebec Field

Grid Solutions Framework VendorHydroQuebec Field
The ID for vendor Hydro-Quebec.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid HydroQuebec
Public Shared ReadOnly HydroQuebec As Guid
static val HydroQuebec: Guid
var GSF.PQDIF.Logical.Vendor.HydroQuebec
public:
static initonly Guid HydroQuebec

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.IEEE Field

Grid Solutions Framework VendorIEEE Field
The ID for vendor IEEE.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid IEEE
Public Shared ReadOnly IEEE As Guid
static val IEEE: Guid
var GSF.PQDIF.Logical.Vendor.IEEE
public:
static initonly Guid IEEE

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.KreissJohnson Field

Grid Solutions Framework VendorKreissJohnson Field
The ID for vendor Kreiss Johnson.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid KreissJohnson
Public Shared ReadOnly KreissJohnson As Guid
static val KreissJohnson: Guid
var GSF.PQDIF.Logical.Vendor.KreissJohnson
public:
static initonly Guid KreissJohnson

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.LEM Field

Grid Solutions Framework VendorLEM Field
The ID for vendor LEM.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid LEM
Public Shared ReadOnly LEM As Guid
static val LEM: Guid
var GSF.PQDIF.Logical.Vendor.LEM
public:
static initonly Guid LEM

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.MetOne Field

Grid Solutions Framework VendorMetOne Field
The ID for vendor Met One.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid MetOne
Public Shared ReadOnly MetOne As Guid
static val MetOne: Guid
var GSF.PQDIF.Logical.Vendor.MetOne
public:
static initonly Guid MetOne

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.Metrosonic Field

Grid Solutions Framework VendorMetrosonic Field
The ID for vendor Metrosonic.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Metrosonic
Public Shared ReadOnly Metrosonic As Guid
static val Metrosonic: Guid
var GSF.PQDIF.Logical.Vendor.Metrosonic
public:
static initonly Guid Metrosonic

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.None Field

Grid Solutions Framework VendorNone Field
The ID representing no vendor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid None
Public Shared ReadOnly None As Guid
static val None: Guid
var GSF.PQDIF.Logical.Vendor.None
public:
static initonly Guid None

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.PMI Field

Grid Solutions Framework VendorPMI Field
The ID for vendor PMI.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PMI
Public Shared ReadOnly PMI As Guid
static val PMI: Guid
var GSF.PQDIF.Logical.Vendor.PMI
public:
static initonly Guid PMI

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.PML Field

Grid Solutions Framework VendorPML Field
The ID for vendor PML.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PML
Public Shared ReadOnly PML As Guid
static val PML: Guid
var GSF.PQDIF.Logical.Vendor.PML
public:
static initonly Guid PML

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.PSI Field

Grid Solutions Framework VendorPSI Field
The ID for vendor PSI.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PSI
Public Shared ReadOnly PSI As Guid
static val PSI: Guid
var GSF.PQDIF.Logical.Vendor.PSI
public:
static initonly Guid PSI

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.PTI Field

Grid Solutions Framework VendorPTI Field
The ID for vendor PTI.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PTI
Public Shared ReadOnly PTI As Guid
static val PTI: Guid
var GSF.PQDIF.Logical.Vendor.PTI
public:
static initonly Guid PTI

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.PublicDomain Field

Grid Solutions Framework VendorPublicDomain Field
The ID for public domain hardware.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid PublicDomain
Public Shared ReadOnly PublicDomain As Guid
static val PublicDomain: Guid
var GSF.PQDIF.Logical.Vendor.PublicDomain
public:
static initonly Guid PublicDomain

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.RPM Field

Grid Solutions Framework VendorRPM Field
The ID for vendor RPM.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid RPM
Public Shared ReadOnly RPM As Guid
static val RPM: Guid
var GSF.PQDIF.Logical.Vendor.RPM
public:
static initonly Guid RPM

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.SATEC Field

Grid Solutions Framework VendorSATEC Field
The ID for vendor SATEC.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SATEC
Public Shared ReadOnly SATEC As Guid
static val SATEC: Guid
var GSF.PQDIF.Logical.Vendor.SATEC
public:
static initonly Guid SATEC

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.SquareDPowerLogic Field

Grid Solutions Framework VendorSquareDPowerLogic Field
The ID for vendor Square D PowerLogic.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid SquareDPowerLogic
Public Shared ReadOnly SquareDPowerLogic As Guid
static val SquareDPowerLogic: Guid
var GSF.PQDIF.Logical.Vendor.SquareDPowerLogic
public:
static initonly Guid SquareDPowerLogic

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.Telog Field

Grid Solutions Framework VendorTelog Field
The ID for vendor Telog.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Telog
Public Shared ReadOnly Telog As Guid
static val Telog: Guid
var GSF.PQDIF.Logical.Vendor.Telog
public:
static initonly Guid Telog

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.Trinergi Field

Grid Solutions Framework VendorTrinergi Field
The ID for vendor Trinergi.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid Trinergi
Public Shared ReadOnly Trinergi As Guid
static val Trinergi: Guid
var GSF.PQDIF.Logical.Vendor.Trinergi
public:
static initonly Guid Trinergi

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.WPT Field

Grid Solutions Framework VendorWPT Field
The ID for vendor WPT.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Guid WPT
Public Shared ReadOnly WPT As Guid
static val WPT: Guid
var GSF.PQDIF.Logical.Vendor.WPT
public:
static initonly Guid WPT

Field Value

Type: Guid
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor Methods

Grid Solutions Framework Vendor Methods

The Vendor type exposes the following members.

Methods
Name | Description
ToString | Converts the given vendor ID to a string containing the name of the vendor.
Top
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


Vendor.ToString Method

Grid Solutions Framework VendorToString Method
Converts the given vendor ID to a string containing the name of the vendor.

Namespace: GSF.PQDIF.Logical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    Guid vendorID
)
Public Shared Function ToString (
    vendorID As Guid
) As String
static member ToString :
        vendorID : Guid -> string

GSF.PQDIF.Logical.Vendor.ToString = function(vendorID);
public:
static String^ ToString(
    Guid vendorID
)

Parameters

vendorID
Type: SystemGuid
The ID of the vendor to be converted to a string.

Return Value

Type: String
A string containing the name of the vendor with the given ID.
See Also

Reference

Vendor Class
GSF.PQDIF.Logical Namespace


GSF.PQDIF.Physical Namespace

Grid Solutions Framework GSF.PQDIF.Physical Namespace

[Missing <summary> documentation for "N:GSF.PQDIF.Physical"]

Classes
 | Class | Description
Public class | CollectionElement | Represents an Element which is a collection of other elements. Collection elements are part of the physical structure of a PQDIF file. They exist within the body of a Record.
Public class | Element | Base class for elements. Elements are part of the physical structure of a PQDIF file. They exist within the body of a Record.
Public class | PhysicalParser | Represents a parser which parses the physical structure of a PQDIF file.
Public class | PhysicalTypeExtensions | Defines extension methods for PhysicalType.
Public class | PhysicalWriter | Represents a writer used to write the physical structure of a PQDIF file to a byte stream.
Public class | Record | Represents a record in a PQDIF file. This class exposes the physical structure of the record.
Public class | RecordBody | The body of a PQDIF Record. The body is part of the physical structure of a PQDIF file. It laid out as a hierarchy of Elements, starting with a CollectionElement that contains other elements.
Public class | RecordHeader | The header of a PQDIF Record. The header is part of the physical structure of a PQDIF file, and contains information on how to parse the RecordBody as well as how to find the next record.
Public class | ScalarElement | Represents an Element which is a single value in a PQDIF file. Scalar elements are part of the physical structure of a PQDIF file. They exist within the body of a Record (contained by a CollectionElement).
Public class | VectorElement | Represents an Element which is a collection of values in a PQDIF file. Vector elements are part of the physical structure of a PQDIF file. They exist within the body of a Record (contained by a CollectionElement).
Enumerations
 | Enumeration | Description
Public enumeration | CompressionAlgorithm | Enumeration which defines the algorithms used to compress PQDIF files.
Public enumeration | CompressionStyle | Enumeration which defines the types of compression used in PQDIF files.
Public enumeration | ElementType | Enumeration that defines the types of elements found in the body of a record.
Public enumeration | PhysicalType | Enumeration that defines the types of values stored in ScalarElements and VectorElements.
Public enumeration | RecordType | Enumeration that defines type of record as per header definition.


CollectionElement Class

Grid Solutions Framework CollectionElement Class
Represents an Element which is a collection of other elements. Collection elements are part of the physical structure of a PQDIF file. They exist within the body of a Record.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalElement
GSF.PQDIF.PhysicalCollectionElement

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CollectionElement : Element
Public Class CollectionElement
    Inherits Element
type CollectionElement =
    class
        inherit Element
    end
GSF.PQDIF.Physical.CollectionElement = function();

Type.createClass(
    'GSF.PQDIF.Physical.CollectionElement',
    GSF.PQDIF.Physical.Element);
public ref class CollectionElement : public Element

The CollectionElement type exposes the following members.

Constructors
 | Name | Description
Public method | CollectionElement | Creates a new instance of the CollectionElement class.
Top
Methods
 | Name | Description
Public method | AddElement | Adds the given element to the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCollectionByTag | Gets the element whose tag matches the one given as a parameter, type cast to CollectionElement.
Public method | GetElementsByTag | Gets the elements whose tag matches the one given as a parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetScalarByTag | Gets the element whose tag matches the one given as a parameter, type cast to ScalarElement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVectorByTag | Gets the element whose tag matches the one given as a parameter, type cast to VectorElement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveElement | Removes the given element from the collection.
Public method | RemoveElementsByTag | Removes all elements identified by the given tag from the collection.
Public method | ToString | Returns a string that represents the collection. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Elements | Gets a list of the element in this collection.
Public property | Size | Gets or sets the number of elements in the collection.
Public property | TagOfElement | Gets or sets the tag which identifies the element. (Inherited from Element.)
Public property | TypeOfElement | Gets the type of the element. Returns Collection. (Overrides ElementTypeOfElement.)
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element. (Inherited from Element.)
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


CollectionElement Constructor

Grid Solutions Framework CollectionElement Constructor
Creates a new instance of the CollectionElement class.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement()
Public Sub New
new : unit -> CollectionElement
GSF.PQDIF.Physical.CollectionElement = function();
public:
CollectionElement()
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement Methods

Grid Solutions Framework CollectionElement Methods

The CollectionElement type exposes the following members.

Methods
 | Name | Description
Public method | AddElement | Adds the given element to the collection.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCollectionByTag | Gets the element whose tag matches the one given as a parameter, type cast to CollectionElement.
Public method | GetElementsByTag | Gets the elements whose tag matches the one given as a parameter.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetScalarByTag | Gets the element whose tag matches the one given as a parameter, type cast to ScalarElement.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetVectorByTag | Gets the element whose tag matches the one given as a parameter, type cast to VectorElement.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RemoveElement | Removes the given element from the collection.
Public method | RemoveElementsByTag | Removes all elements identified by the given tag from the collection.
Public method | ToString | Returns a string that represents the collection. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.AddElement Method

Grid Solutions Framework CollectionElementAddElement Method
Adds the given element to the collection.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddElement(
    Element element
)
Public Sub AddElement (
    element As Element
)
member AddElement :
        element : Element -> unit

function AddElement(element);
public:
void AddElement(
    Element^ element
)

Parameters

element
Type: GSF.PQDIF.PhysicalElement
The element to be added.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.GetCollectionByTag Method

Grid Solutions Framework CollectionElementGetCollectionByTag Method
Gets the element whose tag matches the one given as a parameter, type cast to CollectionElement.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement GetCollectionByTag(
    Guid tag
)
Public Function GetCollectionByTag (
    tag As Guid
) As CollectionElement
member GetCollectionByTag :
        tag : Guid -> CollectionElement

function GetCollectionByTag(tag);
public:
CollectionElement^ GetCollectionByTag(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag to search by.

Return Value

Type: CollectionElement
The element whose tag matches the one given, or null if no matching collection element exists.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.GetElementsByTag Method

Grid Solutions Framework CollectionElementGetElementsByTag Method
Gets the elements whose tag matches the one given as a parameter.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IEnumerable<Element> GetElementsByTag(
    Guid tag
)
Public Function GetElementsByTag (
    tag As Guid
) As IEnumerable(Of Element)
member GetElementsByTag :
        tag : Guid -> IEnumerable<Element>

function GetElementsByTag(tag);
public:
IEnumerable<Element^>^ GetElementsByTag(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag of the elements to be retrieved.

Return Value

Type: IEnumerable Element
An IEnumerableT of Elements identified by the given tag.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.GetScalarByTag Method

Grid Solutions Framework CollectionElementGetScalarByTag Method
Gets the element whose tag matches the one given as a parameter, type cast to ScalarElement.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ScalarElement GetScalarByTag(
    Guid tag
)
Public Function GetScalarByTag (
    tag As Guid
) As ScalarElement
member GetScalarByTag :
        tag : Guid -> ScalarElement

function GetScalarByTag(tag);
public:
ScalarElement^ GetScalarByTag(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag to search by.

Return Value

Type: ScalarElement
The element whose tag matches the one given, or null if no matching scalar element exists.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.GetVectorByTag Method

Grid Solutions Framework CollectionElementGetVectorByTag Method
Gets the element whose tag matches the one given as a parameter, type cast to VectorElement.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public VectorElement GetVectorByTag(
    Guid tag
)
Public Function GetVectorByTag (
    tag As Guid
) As VectorElement
member GetVectorByTag :
        tag : Guid -> VectorElement

function GetVectorByTag(tag);
public:
VectorElement^ GetVectorByTag(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag to search by.

Return Value

Type: VectorElement
The element whose tag matches the one given, or null if no matching vector element exists.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.RemoveElement Method

Grid Solutions Framework CollectionElementRemoveElement Method
Removes the given element from the collection.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveElement(
    Element element
)
Public Sub RemoveElement (
    element As Element
)
member RemoveElement :
        element : Element -> unit

function RemoveElement(element);
public:
void RemoveElement(
    Element^ element
)

Parameters

element
Type: GSF.PQDIF.PhysicalElement
The element to be removed.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.RemoveElementsByTag Method

Grid Solutions Framework CollectionElementRemoveElementsByTag Method
Removes all elements identified by the given tag from the collection.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveElementsByTag(
    Guid tag
)
Public Sub RemoveElementsByTag (
    tag As Guid
)
member RemoveElementsByTag :
        tag : Guid -> unit

function RemoveElementsByTag(tag);
public:
void RemoveElementsByTag(
    Guid tag
)

Parameters

tag
Type: SystemGuid
The tag of the elements to be removed.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.ToString Method

Grid Solutions Framework CollectionElementToString Method
Returns a string that represents the collection.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A string that represents the collection.
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement Properties

Grid Solutions Framework CollectionElement Properties

The CollectionElement type exposes the following members.

Properties
 | Name | Description
Public property | Elements | Gets a list of the element in this collection.
Public property | Size | Gets or sets the number of elements in the collection.
Public property | TagOfElement | Gets or sets the tag which identifies the element. (Inherited from Element.)
Public property | TypeOfElement | Gets the type of the element. Returns Collection. (Overrides ElementTypeOfElement.)
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element. (Inherited from Element.)
Top
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.Elements Property

Grid Solutions Framework CollectionElementElements Property
Gets a list of the element in this collection.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IList<Element> Elements { get; }
Public ReadOnly Property Elements As IList(Of Element)
    Get
member Elements : IList<Element> with get

function get_Elements();

public:
property IList<Element^>^ Elements {
    IList<Element^>^ get ();
}

Property Value

Type: IList Element
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.Size Property

Grid Solutions Framework CollectionElementSize Property
Gets or sets the number of elements in the collection.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Size { get; }
Public ReadOnly Property Size As Integer
    Get
member Size : int with get

function get_Size();

public:
property int Size {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CollectionElement.TypeOfElement Property

Grid Solutions Framework CollectionElementTypeOfElement Property
Gets the type of the element. Returns Collection.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ElementType TypeOfElement { get; }
Public Overrides ReadOnly Property TypeOfElement As ElementType
    Get
abstract TypeOfElement : ElementType with get
override TypeOfElement : ElementType with get
function get_TypeOfElement();

public:
virtual property ElementType TypeOfElement {
    ElementType get () override;
}

Property Value

Type: ElementType
See Also

Reference

CollectionElement Class
GSF.PQDIF.Physical Namespace


CompressionAlgorithm Enumeration

Grid Solutions Framework CompressionAlgorithm Enumeration
Enumeration which defines the algorithms used to compress PQDIF files.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum CompressionAlgorithm
Public Enumeration CompressionAlgorithm
type CompressionAlgorithm
GSF.PQDIF.Physical.CompressionAlgorithm = function();
GSF.PQDIF.Physical.CompressionAlgorithm.createEnum('GSF.PQDIF.Physical.CompressionAlgorithm', false);
public enum class CompressionAlgorithm
Members
Member name | Value | Description
None | 0 | No compression.
Zlib | 1 | Zlib compression. http://www.zlib.net/
PKZIP | 64 | PKZIP compression. This compression algorithm is deprecated and is currently not supported by this PQDIF library.
See Also

Reference

GSF.PQDIF.Physical Namespace


CompressionStyle Enumeration

Grid Solutions Framework CompressionStyle Enumeration
Enumeration which defines the types of compression used in PQDIF files.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum CompressionStyle
Public Enumeration CompressionStyle
type CompressionStyle
GSF.PQDIF.Physical.CompressionStyle = function();
GSF.PQDIF.Physical.CompressionStyle.createEnum('GSF.PQDIF.Physical.CompressionStyle', false);
public enum class CompressionStyle
Members
Member name | Value | Description
None | 0 | No compression.
TotalFile | 1 | Compress the entire file after the container record. This compression style is deprecated and is currently not supported by this PQDIF library.
RecordLevel | 2 | Compress the body of each record.
See Also

Reference

GSF.PQDIF.Physical Namespace


Element Class

Grid Solutions Framework Element Class
Base class for elements. Elements are part of the physical structure of a PQDIF file. They exist within the body of a Record.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalElement
GSF.PQDIF.PhysicalCollectionElement
GSF.PQDIF.PhysicalScalarElement
GSF.PQDIF.PhysicalVectorElement

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class Element
Public MustInherit Class Element
[<AbstractClassAttribute>]
type Element =  class end
GSF.PQDIF.Physical.Element = function();

Type.createClass(
    'GSF.PQDIF.Physical.Element');
public ref class Element abstract

The Element type exposes the following members.

Constructors
 | Name | Description
Protected method | Element | Initializes a new instance of the Element class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | TagOfElement | Gets or sets the tag which identifies the element.
Public property | TypeOfElement | Gets the type of the element. The element can be a ScalarElement, a VectorElement, or a CollectionElement.
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element.
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


Element Constructor

Grid Solutions Framework Element Constructor
Initializes a new instance of the Element class

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Element()
Protected Sub New
new : unit -> Element
GSF.PQDIF.Physical.Element = function();
protected:
Element()
See Also

Reference

Element Class
GSF.PQDIF.Physical Namespace


Element Methods

Grid Solutions Framework Element Methods

The Element type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Element Class
GSF.PQDIF.Physical Namespace


Element Properties

Grid Solutions Framework Element Properties

The Element type exposes the following members.

Properties
 | Name | Description
Public property | TagOfElement | Gets or sets the tag which identifies the element.
Public property | TypeOfElement | Gets the type of the element. The element can be a ScalarElement, a VectorElement, or a CollectionElement.
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element.
Top
See Also

Reference

Element Class
GSF.PQDIF.Physical Namespace


Element.TagOfElement Property

Grid Solutions Framework ElementTagOfElement Property
Gets or sets the tag which identifies the element.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Guid TagOfElement { get; set; }
Public Overridable Property TagOfElement As Guid
    Get
    Set
abstract TagOfElement : Guid with get, set
override TagOfElement : Guid with get, set
function get_TagOfElement();
function set_TagOfElement(value);
public:
virtual property Guid TagOfElement {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

Element Class
GSF.PQDIF.Physical Namespace


Element.TypeOfElement Property

Grid Solutions Framework ElementTypeOfElement Property
Gets the type of the element. The element can be a ScalarElement, a VectorElement, or a CollectionElement.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract ElementType TypeOfElement { get; }
Public MustOverride ReadOnly Property TypeOfElement As ElementType
    Get
abstract TypeOfElement : ElementType with get

function get_TypeOfElement();

public:
virtual property ElementType TypeOfElement {
    ElementType get () abstract;
}

Property Value

Type: ElementType
See Also

Reference

Element Class
GSF.PQDIF.Physical Namespace


Element.TypeOfValue Property

Grid Solutions Framework ElementTypeOfValue Property
Gets or sets the physical type of the value or values contained by the element.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual PhysicalType TypeOfValue { get; set; }
Public Overridable Property TypeOfValue As PhysicalType
    Get
    Set
abstract TypeOfValue : PhysicalType with get, set
override TypeOfValue : PhysicalType with get, set
function get_TypeOfValue();
function set_TypeOfValue(value);
public:
virtual property PhysicalType TypeOfValue {
    PhysicalType get ();
    void set (PhysicalType value);
}

Property Value

Type: PhysicalType
Remarks
This determines the data type and size of the value or values. The value of this property is only relevant when TypeOfElement is either Scalar or Vector.
See Also

Reference

Element Class
GSF.PQDIF.Physical Namespace


ElementType Enumeration

Grid Solutions Framework ElementType Enumeration
Enumeration that defines the types of elements found in the body of a record.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ElementType
Public Enumeration ElementType
type ElementType
GSF.PQDIF.Physical.ElementType = function();
GSF.PQDIF.Physical.ElementType.createEnum('GSF.PQDIF.Physical.ElementType', false);
public enum class ElementType
Members
Member name | Value | Description
Collection | 1 | Collection element. Represents a collection of elements.
Scalar | 2 | Scalar element. Represents a single value.
Vector | 3 | Vector element. Represents a collection of values.
See Also

Reference

GSF.PQDIF.Physical Namespace


PhysicalParser Class

Grid Solutions Framework PhysicalParser Class
Represents a parser which parses the physical structure of a PQDIF file.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalPhysicalParser

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PhysicalParser : IDisposable
Public Class PhysicalParser
    Implements IDisposable
type PhysicalParser =
    class
        interface IDisposable
    end
GSF.PQDIF.Physical.PhysicalParser = function();

Type.createClass(
    'GSF.PQDIF.Physical.PhysicalParser',
    null,
    IDisposable);
public ref class PhysicalParser : IDisposable

The PhysicalParser type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalParser | Creates a new instance of the PhysicalParser class.
Top
Methods
 | Name | Description
Public method | Close | Closes the PQDIF file.
Public method | Dispose | Releases all resources held by this parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNextRecord | Returns true if this parser has not reached the end of the PQDIF file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextRecord | Reads the next record from the PQDIF file.
Public method | Open | Opens the PQDIF file.
Public method | Reset | Sets the parser back to the beginning of the file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CompressionAlgorithm | Gets or sets the compression algorithm used by the PQDIF file.
Public property | CompressionStyle | Gets or sets the compression style used by the PQDIF file.
Public property | FileName | Gets or sets the file name of the PQDIF file to be parsed.
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


PhysicalParser Constructor

Grid Solutions Framework PhysicalParser Constructor
Creates a new instance of the PhysicalParser class.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhysicalParser(
    string fileName
)
Public Sub New (
    fileName As String
)
new :
        fileName : string -> PhysicalParser
GSF.PQDIF.Physical.PhysicalParser = function(fileName);
public:
PhysicalParser(
    String^ fileName
)

Parameters

fileName
Type: SystemString
Name of the PQDIF file to be parsed.
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser Methods

Grid Solutions Framework PhysicalParser Methods

The PhysicalParser type exposes the following members.

Methods
 | Name | Description
Public method | Close | Closes the PQDIF file.
Public method | Dispose | Releases all resources held by this parser.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HasNextRecord | Returns true if this parser has not reached the end of the PQDIF file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | NextRecord | Reads the next record from the PQDIF file.
Public method | Open | Opens the PQDIF file.
Public method | Reset | Sets the parser back to the beginning of the file.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.Close Method

Grid Solutions Framework PhysicalParserClose Method
Closes the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.Dispose Method

Grid Solutions Framework PhysicalParserDispose Method
Releases all resources held by this parser.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.HasNextRecord Method

Grid Solutions Framework PhysicalParserHasNextRecord Method
Returns true if this parser has not reached the end of the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasNextRecord()
Public Function HasNextRecord As Boolean
member HasNextRecord : unit -> bool

function HasNextRecord();
public:
bool HasNextRecord()

Return Value

Type: Boolean
false if the end of the file has been reached; true otherwise
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.NextRecord Method

Grid Solutions Framework PhysicalParserNextRecord Method
Reads the next record from the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Record NextRecord()
Public Function NextRecord As Record
member NextRecord : unit -> Record

function NextRecord();
public:
Record^ NextRecord()

Return Value

Type: Record
The next record to be parsed from the PQDIF file.
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.Open Method

Grid Solutions Framework PhysicalParserOpen Method
Opens the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open()
Public Sub Open
member Open : unit -> unit

function Open();
public:
void Open()
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.Reset Method

Grid Solutions Framework PhysicalParserReset Method
Sets the parser back to the beginning of the file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser Properties

Grid Solutions Framework PhysicalParser Properties

The PhysicalParser type exposes the following members.

Properties
 | Name | Description
Public property | CompressionAlgorithm | Gets or sets the compression algorithm used by the PQDIF file.
Public property | CompressionStyle | Gets or sets the compression style used by the PQDIF file.
Public property | FileName | Gets or sets the file name of the PQDIF file to be parsed.
Top
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.CompressionAlgorithm Property

Grid Solutions Framework PhysicalParserCompressionAlgorithm Property
Gets or sets the compression algorithm used by the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompressionAlgorithm CompressionAlgorithm { get; set; }
Public Property CompressionAlgorithm As CompressionAlgorithm
    Get
    Set
member CompressionAlgorithm : CompressionAlgorithm with get, set

function get_CompressionAlgorithm();
function set_CompressionAlgorithm(value);
public:
property CompressionAlgorithm CompressionAlgorithm {
    CompressionAlgorithm get ();
    void set (CompressionAlgorithm value);
}

Property Value

Type: CompressionAlgorithm
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.CompressionStyle Property

Grid Solutions Framework PhysicalParserCompressionStyle Property
Gets or sets the compression style used by the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompressionStyle CompressionStyle { get; set; }
Public Property CompressionStyle As CompressionStyle
    Get
    Set
member CompressionStyle : CompressionStyle with get, set

function get_CompressionStyle();
function set_CompressionStyle(value);
public:
property CompressionStyle CompressionStyle {
    CompressionStyle get ();
    void set (CompressionStyle value);
}

Property Value

Type: CompressionStyle
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalParser.FileName Property

Grid Solutions Framework PhysicalParserFileName Property
Gets or sets the file name of the PQDIF file to be parsed.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FileName { get; set; }
Public Property FileName As String
    Get
    Set
member FileName : string with get, set

function get_FileName();
function set_FileName(value);
public:
property String^ FileName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

PhysicalParser Class
GSF.PQDIF.Physical Namespace


PhysicalType Enumeration

Grid Solutions Framework PhysicalType Enumeration
Enumeration that defines the types of values stored in ScalarElements and VectorElements.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum PhysicalType
Public Enumeration PhysicalType
type PhysicalType
GSF.PQDIF.Physical.PhysicalType = function();
GSF.PQDIF.Physical.PhysicalType.createEnum('GSF.PQDIF.Physical.PhysicalType', false);
public enum class PhysicalType
Members
Member name | Value | Description
Boolean1 | 1 | 1-byte boolean
Boolean2 | 2 | 2-byte boolean
Boolean4 | 3 | 4-byte boolean
Char1 | 10 | 1-byte character (ASCII)
Char2 | 11 | 2-byte character (UTF-16)
Integer1 | 20 | 8-bit signed integer
Integer2 | 21 | 16-bit signed integer
Integer4 | 22 | 32-bit signed integer
UnsignedInteger1 | 30 | 8-bit unsigned integer
UnsignedInteger2 | 31 | 16-bit unsigned integer
UnsignedInteger4 | 32 | 32-bit unsigned integer
Real4 | 40 | 32-bit floating point number
Real8 | 41 | 64-bit floating point number
Complex8 | 42 | 8-byte complex number
Complex16 | 43 | 16-byte complex number
Timestamp | 50 | 12-byte timestamp
Guid | 60 | 128-bit globally unique identifier
See Also

Reference

GSF.PQDIF.Physical Namespace


PhysicalTypeExtensions Class

Grid Solutions Framework PhysicalTypeExtensions Class
Defines extension methods for PhysicalType.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalPhysicalTypeExtensions

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class PhysicalTypeExtensions
<ExtensionAttribute>
Public NotInheritable Class PhysicalTypeExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PhysicalTypeExtensions =  class end
GSF.PQDIF.Physical.PhysicalTypeExtensions = function();

Type.createClass(
    'GSF.PQDIF.Physical.PhysicalTypeExtensions');
[ExtensionAttribute]
public ref class PhysicalTypeExtensions abstract sealed

The PhysicalTypeExtensions type exposes the following members.

Methods
Name | Description
GetByteSize | Gets the size of the physical type, in bytes.
GetPhysicalType | Gets the physical type that most closely maps to the given type.
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


PhysicalTypeExtensions Methods

Grid Solutions Framework PhysicalTypeExtensions Methods

The PhysicalTypeExtensions type exposes the following members.

Methods
Name | Description
GetByteSize | Gets the size of the physical type, in bytes.
GetPhysicalType | Gets the physical type that most closely maps to the given type.
Top
See Also

Reference

PhysicalTypeExtensions Class
GSF.PQDIF.Physical Namespace


PhysicalTypeExtensions.GetByteSize Method

Grid Solutions Framework PhysicalTypeExtensionsGetByteSize Method
Gets the size of the physical type, in bytes.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int GetByteSize(
    this PhysicalType type
)
<ExtensionAttribute>
Public Shared Function GetByteSize (
    type As PhysicalType
) As Integer
static member GetByteSize :
        type : PhysicalType -> int

GSF.PQDIF.Physical.PhysicalTypeExtensions.GetByteSize = function(type);
public:
[ExtensionAttribute]
static int GetByteSize(
    PhysicalType type
)

Parameters

type
Type: GSF.PQDIF.PhysicalPhysicalType
The physical type.

Return Value

Type: Int32
The size of the physical type, in bytes.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PhysicalType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

PhysicalTypeExtensions Class
GSF.PQDIF.Physical Namespace


PhysicalTypeExtensions.GetPhysicalType Method

Grid Solutions Framework PhysicalTypeExtensionsGetPhysicalType Method
Gets the physical type that most closely maps to the given type.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static PhysicalType GetPhysicalType(
    Type type
)
Public Shared Function GetPhysicalType (
    type As Type
) As PhysicalType
static member GetPhysicalType :
        type : Type -> PhysicalType

GSF.PQDIF.Physical.PhysicalTypeExtensions.GetPhysicalType = function(type);
public:
static PhysicalType GetPhysicalType(
    Type^ type
)

Parameters

type
Type: SystemType
The type to be converted to a PQDIF physical type.

Return Value

Type: PhysicalType
The physical type that most closely maps to the given type.
See Also

Reference

PhysicalTypeExtensions Class
GSF.PQDIF.Physical Namespace


PhysicalWriter Class

Grid Solutions Framework PhysicalWriter Class
Represents a writer used to write the physical structure of a PQDIF file to a byte stream.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalPhysicalWriter

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class PhysicalWriter : IDisposable
Public Class PhysicalWriter
    Implements IDisposable
type PhysicalWriter =
    class
        interface IDisposable
    end
GSF.PQDIF.Physical.PhysicalWriter = function();

Type.createClass(
    'GSF.PQDIF.Physical.PhysicalWriter',
    null,
    IDisposable);
public ref class PhysicalWriter : IDisposable

The PhysicalWriter type exposes the following members.

Constructors
 | Name | Description
Public method | PhysicalWriter(String) | Creates a new instance of the PhysicalWriter class.
Public method | PhysicalWriter(Stream, Boolean) | Creates a new instance of the PhysicalWriter class.
Top
Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteRecord | Writes the given record to the PQDIF file.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CompressionAlgorithm | Gets or sets the compression algorithm used by the PQDIF file.
Public property | CompressionStyle | Gets or sets the compression style used by the PQDIF file.
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


PhysicalWriter Constructor

Grid Solutions Framework PhysicalWriter Constructor
Overload List
 | Name | Description
Public method | PhysicalWriter(String) | Creates a new instance of the PhysicalWriter class.
Public method | PhysicalWriter(Stream, Boolean) | Creates a new instance of the PhysicalWriter class.
Top
See Also

Reference

PhysicalWriter Class
GSF.PQDIF.Physical Namespace


PhysicalWriter Constructor (String)

Grid Solutions Framework PhysicalWriter Constructor (String)
Creates a new instance of the PhysicalWriter class.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhysicalWriter(
    string filePath
)
Public Sub New (
    filePath As String
)
new :
        filePath : string -> PhysicalWriter
GSF.PQDIF.Physical.PhysicalWriter = function(filePath);
public:
PhysicalWriter(
    String^ filePath
)

Parameters

filePath
Type: SystemString
The path to the file where the PQDIF data is to be written.
See Also

Reference

PhysicalWriter Class
PhysicalWriter Overload
GSF.PQDIF.Physical Namespace


PhysicalWriter Constructor (Stream, Boolean)

Grid Solutions Framework PhysicalWriter Constructor (Stream, Boolean)
Creates a new instance of the PhysicalWriter class.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhysicalWriter(
    Stream stream,
    bool leaveOpen = false
)
Public Sub New (
    stream As Stream,
    Optional leaveOpen As Boolean = false
)
new :
        stream : Stream *
        ?leaveOpen : bool
(* Defaults:
        let _leaveOpen = defaultArg leaveOpen false
*)
-> PhysicalWriter
GSF.PQDIF.Physical.PhysicalWriter = function(stream, leaveOpen);
public:
PhysicalWriter(
    Stream^ stream,
    bool leaveOpen = false
)

Parameters

stream
Type: System.IOStream
The stream to write the PQDIF data to.
leaveOpen (Optional)
Type: SystemBoolean
Indicates whether to leave the stream open when disposing of the writer.
See Also

Reference

PhysicalWriter Class
PhysicalWriter Overload
GSF.PQDIF.Physical Namespace


PhysicalWriter Methods

Grid Solutions Framework PhysicalWriter Methods

The PhysicalWriter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WriteRecord | Writes the given record to the PQDIF file.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PhysicalWriter Class
GSF.PQDIF.Physical Namespace


PhysicalWriter.Dispose Method

Grid Solutions Framework PhysicalWriterDispose Method
Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PhysicalWriter Class
GSF.PQDIF.Physical Namespace


PhysicalWriter.WriteRecord Method

Grid Solutions Framework PhysicalWriterWriteRecord Method
Writes the given record to the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void WriteRecord(
    Record record,
    bool lastRecord = false
)
Public Sub WriteRecord (
    record As Record,
    Optional lastRecord As Boolean = false
)
member WriteRecord :
        record : Record *
        ?lastRecord : bool
(* Defaults:
        let _lastRecord = defaultArg lastRecord false
*)
-> unit

function WriteRecord(record, lastRecord);
public:
void WriteRecord(
    Record^ record,
    bool lastRecord = false
)

Parameters

record
Type: GSF.PQDIF.PhysicalRecord
The record to be written to the file.
lastRecord (Optional)
Type: SystemBoolean
Indicates whether this record is the last record in the file.
See Also

Reference

PhysicalWriter Class
GSF.PQDIF.Physical Namespace


PhysicalWriter Properties

Grid Solutions Framework PhysicalWriter Properties

The PhysicalWriter type exposes the following members.

Properties
 | Name | Description
Public property | CompressionAlgorithm | Gets or sets the compression algorithm used by the PQDIF file.
Public property | CompressionStyle | Gets or sets the compression style used by the PQDIF file.
Top
See Also

Reference

PhysicalWriter Class
GSF.PQDIF.Physical Namespace


PhysicalWriter.CompressionAlgorithm Property

Grid Solutions Framework PhysicalWriterCompressionAlgorithm Property
Gets or sets the compression algorithm used by the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompressionAlgorithm CompressionAlgorithm { get; set; }
Public Property CompressionAlgorithm As CompressionAlgorithm
    Get
    Set
member CompressionAlgorithm : CompressionAlgorithm with get, set

function get_CompressionAlgorithm();
function set_CompressionAlgorithm(value);
public:
property CompressionAlgorithm CompressionAlgorithm {
    CompressionAlgorithm get ();
    void set (CompressionAlgorithm value);
}

Property Value

Type: CompressionAlgorithm
See Also

Reference

PhysicalWriter Class
GSF.PQDIF.Physical Namespace


PhysicalWriter.CompressionStyle Property

Grid Solutions Framework PhysicalWriterCompressionStyle Property
Gets or sets the compression style used by the PQDIF file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompressionStyle CompressionStyle { get; set; }
Public Property CompressionStyle As CompressionStyle
    Get
    Set
member CompressionStyle : CompressionStyle with get, set

function get_CompressionStyle();
function set_CompressionStyle(value);
public:
property CompressionStyle CompressionStyle {
    CompressionStyle get ();
    void set (CompressionStyle value);
}

Property Value

Type: CompressionStyle
See Also

Reference

PhysicalWriter Class
GSF.PQDIF.Physical Namespace


Record Class

Grid Solutions Framework Record Class
Represents a record in a PQDIF file. This class exposes the physical structure of the record.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalRecord

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Record
Public Class Record
type Record =  class end
GSF.PQDIF.Physical.Record = function();

Type.createClass(
    'GSF.PQDIF.Physical.Record');
public ref class Record

The Record type exposes the following members.

Constructors
 | Name | Description
Public method | Record | Creates an instance of Record.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRecordType | Gets the RecordType identified by the given tag.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeAsTag | Gets the globally unique identifier used to identify the given record type.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the record. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Body | Gets or sets the record body.
Public property | Header | Gets or sets the record header.
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


Record Constructor

Grid Solutions Framework Record Constructor
Creates an instance of Record.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Record(
    RecordHeader header,
    RecordBody body
)
Public Sub New (
    header As RecordHeader,
    body As RecordBody
)
new :
        header : RecordHeader *
        body : RecordBody -> Record
GSF.PQDIF.Physical.Record = function(header, body);
public:
Record(
    RecordHeader^ header,
    RecordBody^ body
)

Parameters

header
Type: GSF.PQDIF.PhysicalRecordHeader
The record header.
body
Type: GSF.PQDIF.PhysicalRecordBody
The record body.
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


Record Methods

Grid Solutions Framework Record Methods

The Record type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetRecordType | Gets the RecordType identified by the given tag.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | GetTypeAsTag | Gets the globally unique identifier used to identify the given record type.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the record. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


Record.GetRecordType Method

Grid Solutions Framework RecordGetRecordType Method
Gets the RecordType identified by the given tag.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static RecordType GetRecordType(
    Guid recordTypeTag
)
Public Shared Function GetRecordType (
    recordTypeTag As Guid
) As RecordType
static member GetRecordType :
        recordTypeTag : Guid -> RecordType

GSF.PQDIF.Physical.Record.GetRecordType = function(recordTypeTag);
public:
static RecordType GetRecordType(
    Guid recordTypeTag
)

Parameters

recordTypeTag
Type: SystemGuid
The tag of the RecordType.

Return Value

Type: RecordType
The RecordType identified by the given tag.
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


Record.GetTypeAsTag Method

Grid Solutions Framework RecordGetTypeAsTag Method
Gets the globally unique identifier used to identify the given record type.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid GetTypeAsTag(
    RecordType recordType
)
Public Shared Function GetTypeAsTag (
    recordType As RecordType
) As Guid
static member GetTypeAsTag :
        recordType : RecordType -> Guid

GSF.PQDIF.Physical.Record.GetTypeAsTag = function(recordType);
public:
static Guid GetTypeAsTag(
    RecordType recordType
)

Parameters

recordType
Type: GSF.PQDIF.PhysicalRecordType
The record type to search for.

Return Value

Type: Guid
The globally unique identifier used to identify the given record type.
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


Record.ToString Method

Grid Solutions Framework RecordToString Method
Returns a string representation of the record.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A string representation of the record.
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


Record Properties

Grid Solutions Framework Record Properties

The Record type exposes the following members.

Properties
 | Name | Description
Public property | Body | Gets or sets the record body.
Public property | Header | Gets or sets the record header.
Top
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


Record.Body Property

Grid Solutions Framework RecordBody Property
Gets or sets the record body.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RecordBody Body { get; set; }
Public Property Body As RecordBody
    Get
    Set
member Body : RecordBody with get, set

function get_Body();
function set_Body(value);
public:
property RecordBody^ Body {
    RecordBody^ get ();
    void set (RecordBody^ value);
}

Property Value

Type: RecordBody
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


Record.Header Property

Grid Solutions Framework RecordHeader Property
Gets or sets the record header.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RecordHeader Header { get; set; }
Public Property Header As RecordHeader
    Get
    Set
member Header : RecordHeader with get, set

function get_Header();
function set_Header(value);
public:
property RecordHeader^ Header {
    RecordHeader^ get ();
    void set (RecordHeader^ value);
}

Property Value

Type: RecordHeader
See Also

Reference

Record Class
GSF.PQDIF.Physical Namespace


RecordBody Class

Grid Solutions Framework RecordBody Class
The body of a PQDIF Record. The body is part of the physical structure of a PQDIF file. It laid out as a hierarchy of Elements, starting with a CollectionElement that contains other elements.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalRecordBody

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RecordBody
Public Class RecordBody
type RecordBody =  class end
GSF.PQDIF.Physical.RecordBody = function();

Type.createClass(
    'GSF.PQDIF.Physical.RecordBody');
public ref class RecordBody

The RecordBody type exposes the following members.

Constructors
 | Name | Description
Public method | RecordBody | Initializes a new instance of the RecordBody class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the record body. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Collection | Gets or sets the CollectionElement at the top of the hierarchy. This can be used to traverse the hierarchy.
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


RecordBody Constructor

Grid Solutions Framework RecordBody Constructor
Initializes a new instance of the RecordBody class

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RecordBody()
Public Sub New
new : unit -> RecordBody
GSF.PQDIF.Physical.RecordBody = function();
public:
RecordBody()
See Also

Reference

RecordBody Class
GSF.PQDIF.Physical Namespace


RecordBody Methods

Grid Solutions Framework RecordBody Methods

The RecordBody type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the record body. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RecordBody Class
GSF.PQDIF.Physical Namespace


RecordBody.ToString Method

Grid Solutions Framework RecordBodyToString Method
Returns a string representation of the record body.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A string representation of the record body.
See Also

Reference

RecordBody Class
GSF.PQDIF.Physical Namespace


RecordBody Properties

Grid Solutions Framework RecordBody Properties

The RecordBody type exposes the following members.

Properties
 | Name | Description
Public property | Collection | Gets or sets the CollectionElement at the top of the hierarchy. This can be used to traverse the hierarchy.
Top
See Also

Reference

RecordBody Class
GSF.PQDIF.Physical Namespace


RecordBody.Collection Property

Grid Solutions Framework RecordBodyCollection Property
Gets or sets the CollectionElement at the top of the hierarchy. This can be used to traverse the hierarchy.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CollectionElement Collection { get; set; }
Public Property Collection As CollectionElement
    Get
    Set
member Collection : CollectionElement with get, set

function get_Collection();
function set_Collection(value);
public:
property CollectionElement^ Collection {
    CollectionElement^ get ();
    void set (CollectionElement^ value);
}

Property Value

Type: CollectionElement
See Also

Reference

RecordBody Class
GSF.PQDIF.Physical Namespace


RecordHeader Class

Grid Solutions Framework RecordHeader Class
The header of a PQDIF Record. The header is part of the physical structure of a PQDIF file, and contains information on how to parse the RecordBody as well as how to find the next record.
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalRecordHeader

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RecordHeader
Public Class RecordHeader
type RecordHeader =  class end
GSF.PQDIF.Physical.RecordHeader = function();

Type.createClass(
    'GSF.PQDIF.Physical.RecordHeader');
public ref class RecordHeader

The RecordHeader type exposes the following members.

Constructors
 | Name | Description
Public method | RecordHeader | Initializes a new instance of the RecordHeader class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the record header. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | BodySize | Gets or sets the size of the body, in bytes.
Public property | Checksum | Optional checksum (such as a 32-bit CRC) of the record body to verify decompression.
Public property | HeaderSize | Gets or sets the size of the header, in bytes.
Public property | NextRecordPosition | Gets or sets the position of the next record in the PQDIF file. This value is a byte offset relative to the beginning of the file.
Public property | RecordSignature | Gets or sets the record's globally unique identifier.
Public property | RecordTypeTag | Gets or sets the tag which identifies the type of the record.
Public property | Reserved | Reserved to fill structure to 64 bytes. Should be filled with 0.
Public property | TypeOfRecord | Gets or sets the type of the record which determines the logical structure of the record.
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


RecordHeader Constructor

Grid Solutions Framework RecordHeader Constructor
Initializes a new instance of the RecordHeader class

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RecordHeader()
Public Sub New
new : unit -> RecordHeader
GSF.PQDIF.Physical.RecordHeader = function();
public:
RecordHeader()
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader Methods

Grid Solutions Framework RecordHeader Methods

The RecordHeader type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string representation of the record header. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.ToString Method

Grid Solutions Framework RecordHeaderToString Method
Returns a string representation of the record header.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A string representation of the record header.
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader Properties

Grid Solutions Framework RecordHeader Properties

The RecordHeader type exposes the following members.

Properties
 | Name | Description
Public property | BodySize | Gets or sets the size of the body, in bytes.
Public property | Checksum | Optional checksum (such as a 32-bit CRC) of the record body to verify decompression.
Public property | HeaderSize | Gets or sets the size of the header, in bytes.
Public property | NextRecordPosition | Gets or sets the position of the next record in the PQDIF file. This value is a byte offset relative to the beginning of the file.
Public property | RecordSignature | Gets or sets the record's globally unique identifier.
Public property | RecordTypeTag | Gets or sets the tag which identifies the type of the record.
Public property | Reserved | Reserved to fill structure to 64 bytes. Should be filled with 0.
Public property | TypeOfRecord | Gets or sets the type of the record which determines the logical structure of the record.
Top
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.BodySize Property

Grid Solutions Framework RecordHeaderBodySize Property
Gets or sets the size of the body, in bytes.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BodySize { get; set; }
Public Property BodySize As Integer
    Get
    Set
member BodySize : int with get, set

function get_BodySize();
function set_BodySize(value);
public:
property int BodySize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.Checksum Property

Grid Solutions Framework RecordHeaderChecksum Property
Optional checksum (such as a 32-bit CRC) of the record body to verify decompression.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint Checksum { get; set; }
Public Property Checksum As UInteger
    Get
    Set
member Checksum : uint32 with get, set

function get_Checksum();
function set_Checksum(value);
public:
property unsigned int Checksum {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.HeaderSize Property

Grid Solutions Framework RecordHeaderHeaderSize Property
Gets or sets the size of the header, in bytes.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int HeaderSize { get; set; }
Public Property HeaderSize As Integer
    Get
    Set
member HeaderSize : int with get, set

function get_HeaderSize();
function set_HeaderSize(value);
public:
property int HeaderSize {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.NextRecordPosition Property

Grid Solutions Framework RecordHeaderNextRecordPosition Property
Gets or sets the position of the next record in the PQDIF file. This value is a byte offset relative to the beginning of the file.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int NextRecordPosition { get; set; }
Public Property NextRecordPosition As Integer
    Get
    Set
member NextRecordPosition : int with get, set

function get_NextRecordPosition();
function set_NextRecordPosition(value);
public:
property int NextRecordPosition {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.RecordSignature Property

Grid Solutions Framework RecordHeaderRecordSignature Property
Gets or sets the record's globally unique identifier.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid RecordSignature { get; set; }
Public Property RecordSignature As Guid
    Get
    Set
member RecordSignature : Guid with get, set

function get_RecordSignature();
function set_RecordSignature(value);
public:
property Guid RecordSignature {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.RecordTypeTag Property

Grid Solutions Framework RecordHeaderRecordTypeTag Property
Gets or sets the tag which identifies the type of the record.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid RecordTypeTag { get; set; }
Public Property RecordTypeTag As Guid
    Get
    Set
member RecordTypeTag : Guid with get, set

function get_RecordTypeTag();
function set_RecordTypeTag(value);
public:
property Guid RecordTypeTag {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.Reserved Property

Grid Solutions Framework RecordHeaderReserved Property
Reserved to fill structure to 64 bytes. Should be filled with 0.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Reserved { get; set; }
Public Property Reserved As Byte()
    Get
    Set
member Reserved : byte[] with get, set

function get_Reserved();
function set_Reserved(value);
public:
property array<unsigned char>^ Reserved {
    array<unsigned char>^ get ();
    void set (array<unsigned char>^ value);
}

Property Value

Type: Byte
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordHeader.TypeOfRecord Property

Grid Solutions Framework RecordHeaderTypeOfRecord Property
Gets or sets the type of the record which determines the logical structure of the record.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RecordType TypeOfRecord { get; }
Public ReadOnly Property TypeOfRecord As RecordType
    Get
member TypeOfRecord : RecordType with get

function get_TypeOfRecord();

public:
property RecordType TypeOfRecord {
    RecordType get ();
}

Property Value

Type: RecordType
See Also

Reference

RecordHeader Class
GSF.PQDIF.Physical Namespace


RecordType Enumeration

Grid Solutions Framework RecordType Enumeration
Enumeration that defines type of record as per header definition.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum RecordType
Public Enumeration RecordType
type RecordType
GSF.PQDIF.Physical.RecordType = function();
GSF.PQDIF.Physical.RecordType.createEnum('GSF.PQDIF.Physical.RecordType', false);
public enum class RecordType
Members
Member name | Value | Description
Container | 0 | Represents a record level tag which identifies the container record. Always the first one in the file, and only one per file.
DataSource | 1 | Represents a record level tag which identifies the data source record. Instrument level information.
MonitorSettings | 2 | Represents an optional record level tag which identifies configuration parameters. Used to capture configuration changes on the data source.
Observation | 3 | Represents a record-level tag which identifies an observation. Used to capture an event, measurements etc.
Unknown | 4 | Represents a record-level tag which is unknown to this library.
See Also

Reference

GSF.PQDIF.Physical Namespace


ScalarElement Class

Grid Solutions Framework ScalarElement Class
Represents an Element which is a single value in a PQDIF file. Scalar elements are part of the physical structure of a PQDIF file. They exist within the body of a Record (contained by a CollectionElement).
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalElement
GSF.PQDIF.PhysicalScalarElement

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ScalarElement : Element
Public Class ScalarElement
    Inherits Element
type ScalarElement =
    class
        inherit Element
    end
GSF.PQDIF.Physical.ScalarElement = function();

Type.createClass(
    'GSF.PQDIF.Physical.ScalarElement',
    GSF.PQDIF.Physical.Element);
public ref class ScalarElement : public Element

The ScalarElement type exposes the following members.

Constructors
 | Name | Description
Public method | ScalarElement | Creates a new instance of the ScalarElement class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the value of the scalar as the physical type defined by TypeOfValue and returns it as a generic Object.
Public method | GetBool4 | Gets the value of this scalar as a 4-byte boolean.
Public method | GetComplex16 | Gets the value of this scalar as a 16-byte complex number.
Public method | GetComplex8 | Gets the value of this scalar as an 8-byte complex number.
Public method | GetGuid | Gets the value of this scalar as a globally unique identifier.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt1 | Gets the value of this scalar as an 8-bit signed integer.
Public method | GetInt2 | Gets the value of this scalar as a 16-bit signed integer.
Public method | GetInt4 | Gets the value of this scalar as a 32-bit signed integer.
Public method | GetReal4 | Gets the value of this scalar as a 32-bit floating point number.
Public method | GetReal8 | Gets the value of this scalar as a 64-bit floating point number.
Public method | GetTimestamp | Gets the value of this scalar as DateTime.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUInt1 | Gets the value of this scalar as an 8-bit unsigned integer.
Public method | GetUInt2 | Gets the value of this scalar as a 16-bit unsigned integer.
Public method | GetUInt4 | Gets the value of this scalar as a 32-bit unsigned integer.
Public method | GetValue | Gets the raw bytes of the value that this scalar represents.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | Sets the value at the given index as the physical type defined by [!:TypeOfValue].
Public method | SetBool4 | Sets the value of this scalar as a 4-byte boolean.
Public method | SetComplex16 | Sets the value of this scalar as a 16-byte complex number.
Public method | SetComplex8 | Sets the value of this scalar as an 8-byte complex number.
Public method | SetGuid | Sets the value of this scalar as a globally unique identifier.
Public method | SetInt1 | Sets the value of this scalar as an 8-bit signed integer.
Public method | SetInt2 | Sets the value of this scalar as a 16-bit signed integer.
Public method | SetInt4 | Sets the value of this scalar as a 32-bit signed integer.
Public method | SetReal4 | Sets the value of this scalar as a 32-bit floating point number.
Public method | SetReal8 | Sets the value of this scalar as a 64-bit floating point number.
Public method | SetTimestamp | Sets the value of this scalar as a DateTime.
Public method | SetUInt1 | Sets the value of this scalar as an 8-bit unsigned integer.
Public method | SetUInt2 | Sets the value of this scalar as a 16-bit unsigned integer.
Public method | SetUInt4 | Sets the value of this scalar as a 32-bit unsigned integer.
Public method | SetValue | Sets the raw bytes of the value that this scalar represents.
Public method | ToString | Returns a string representation of the scalar. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | TagOfElement | Gets or sets the tag which identifies the element. (Inherited from Element.)
Public property | TypeOfElement | Gets the type of the element. Returns Scalar. (Overrides ElementTypeOfElement.)
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element. (Inherited from Element.)
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


ScalarElement Constructor

Grid Solutions Framework ScalarElement Constructor
Creates a new instance of the ScalarElement class.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ScalarElement()
Public Sub New
new : unit -> ScalarElement
GSF.PQDIF.Physical.ScalarElement = function();
public:
ScalarElement()
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement Methods

Grid Solutions Framework ScalarElement Methods

The ScalarElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the value of the scalar as the physical type defined by TypeOfValue and returns it as a generic Object.
Public method | GetBool4 | Gets the value of this scalar as a 4-byte boolean.
Public method | GetComplex16 | Gets the value of this scalar as a 16-byte complex number.
Public method | GetComplex8 | Gets the value of this scalar as an 8-byte complex number.
Public method | GetGuid | Gets the value of this scalar as a globally unique identifier.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt1 | Gets the value of this scalar as an 8-bit signed integer.
Public method | GetInt2 | Gets the value of this scalar as a 16-bit signed integer.
Public method | GetInt4 | Gets the value of this scalar as a 32-bit signed integer.
Public method | GetReal4 | Gets the value of this scalar as a 32-bit floating point number.
Public method | GetReal8 | Gets the value of this scalar as a 64-bit floating point number.
Public method | GetTimestamp | Gets the value of this scalar as DateTime.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUInt1 | Gets the value of this scalar as an 8-bit unsigned integer.
Public method | GetUInt2 | Gets the value of this scalar as a 16-bit unsigned integer.
Public method | GetUInt4 | Gets the value of this scalar as a 32-bit unsigned integer.
Public method | GetValue | Gets the raw bytes of the value that this scalar represents.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | Sets the value at the given index as the physical type defined by [!:TypeOfValue].
Public method | SetBool4 | Sets the value of this scalar as a 4-byte boolean.
Public method | SetComplex16 | Sets the value of this scalar as a 16-byte complex number.
Public method | SetComplex8 | Sets the value of this scalar as an 8-byte complex number.
Public method | SetGuid | Sets the value of this scalar as a globally unique identifier.
Public method | SetInt1 | Sets the value of this scalar as an 8-bit signed integer.
Public method | SetInt2 | Sets the value of this scalar as a 16-bit signed integer.
Public method | SetInt4 | Sets the value of this scalar as a 32-bit signed integer.
Public method | SetReal4 | Sets the value of this scalar as a 32-bit floating point number.
Public method | SetReal8 | Sets the value of this scalar as a 64-bit floating point number.
Public method | SetTimestamp | Sets the value of this scalar as a DateTime.
Public method | SetUInt1 | Sets the value of this scalar as an 8-bit unsigned integer.
Public method | SetUInt2 | Sets the value of this scalar as a 16-bit unsigned integer.
Public method | SetUInt4 | Sets the value of this scalar as a 32-bit unsigned integer.
Public method | SetValue | Sets the raw bytes of the value that this scalar represents.
Public method | ToString | Returns a string representation of the scalar. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.Get Method

Grid Solutions Framework ScalarElementGet Method
Gets the value of the scalar as the physical type defined by TypeOfValue and returns it as a generic Object.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object Get()
Public Function Get As Object
member Get : unit -> Object

function Get();
public:
Object^ Get()

Return Value

Type: Object
The value of the scalar.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetBool4 Method

Grid Solutions Framework ScalarElementGetBool4 Method
Gets the value of this scalar as a 4-byte boolean.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool GetBool4()
Public Function GetBool4 As Boolean
member GetBool4 : unit -> bool

function GetBool4();
public:
bool GetBool4()

Return Value

Type: Boolean
The value as a 4-byte boolean.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetComplex16 Method

Grid Solutions Framework ScalarElementGetComplex16 Method
Gets the value of this scalar as a 16-byte complex number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ComplexNumber GetComplex16()
Public Function GetComplex16 As ComplexNumber
member GetComplex16 : unit -> ComplexNumber

function GetComplex16();
public:
ComplexNumber GetComplex16()

Return Value

Type: ComplexNumber
The value as a 16-byte complex number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetComplex8 Method

Grid Solutions Framework ScalarElementGetComplex8 Method
Gets the value of this scalar as an 8-byte complex number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ComplexNumber GetComplex8()
Public Function GetComplex8 As ComplexNumber
member GetComplex8 : unit -> ComplexNumber

function GetComplex8();
public:
ComplexNumber GetComplex8()

Return Value

Type: ComplexNumber
The value as an 8-byte complex number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetGuid Method

Grid Solutions Framework ScalarElementGetGuid Method
Gets the value of this scalar as a globally unique identifier.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid GetGuid()
Public Function GetGuid As Guid
member GetGuid : unit -> Guid

function GetGuid();
public:
Guid GetGuid()

Return Value

Type: Guid
The value as a globally unique identifier.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetInt1 Method

Grid Solutions Framework ScalarElementGetInt1 Method
Gets the value of this scalar as an 8-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short GetInt1()
Public Function GetInt1 As Short
member GetInt1 : unit -> int16

function GetInt1();
public:
short GetInt1()

Return Value

Type: Int16
The value as an 8-bit signed integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetInt2 Method

Grid Solutions Framework ScalarElementGetInt2 Method
Gets the value of this scalar as a 16-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short GetInt2()
Public Function GetInt2 As Short
member GetInt2 : unit -> int16

function GetInt2();
public:
short GetInt2()

Return Value

Type: Int16
The value as a 16-bit signed integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetInt4 Method

Grid Solutions Framework ScalarElementGetInt4 Method
Gets the value of this scalar as a 32-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GetInt4()
Public Function GetInt4 As Integer
member GetInt4 : unit -> int

function GetInt4();
public:
int GetInt4()

Return Value

Type: Int32
The value as a 32-bit signed integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetReal4 Method

Grid Solutions Framework ScalarElementGetReal4 Method
Gets the value of this scalar as a 32-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float GetReal4()
Public Function GetReal4 As Single
member GetReal4 : unit -> float32

function GetReal4();
public:
float GetReal4()

Return Value

Type: Single
The value as a 32-bit floating point number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetReal8 Method

Grid Solutions Framework ScalarElementGetReal8 Method
Gets the value of this scalar as a 64-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double GetReal8()
Public Function GetReal8 As Double
member GetReal8 : unit -> float

function GetReal8();
public:
double GetReal8()

Return Value

Type: Double
The value as a 64-bit floating point number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetTimestamp Method

Grid Solutions Framework ScalarElementGetTimestamp Method
Gets the value of this scalar as DateTime.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime GetTimestamp()
Public Function GetTimestamp As DateTime
member GetTimestamp : unit -> DateTime

function GetTimestamp();
public:
DateTime GetTimestamp()

Return Value

Type: DateTime
The value of this scalar as a DateTime.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetUInt1 Method

Grid Solutions Framework ScalarElementGetUInt1 Method
Gets the value of this scalar as an 8-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort GetUInt1()
Public Function GetUInt1 As UShort
member GetUInt1 : unit -> uint16

function GetUInt1();
public:
unsigned short GetUInt1()

Return Value

Type: UInt16
The value as an 8-bit unsigned integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetUInt2 Method

Grid Solutions Framework ScalarElementGetUInt2 Method
Gets the value of this scalar as a 16-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort GetUInt2()
Public Function GetUInt2 As UShort
member GetUInt2 : unit -> uint16

function GetUInt2();
public:
unsigned short GetUInt2()

Return Value

Type: UInt16
The value as a 16-bit unsigned integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetUInt4 Method

Grid Solutions Framework ScalarElementGetUInt4 Method
Gets the value of this scalar as a 32-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint GetUInt4()
Public Function GetUInt4 As UInteger
member GetUInt4 : unit -> uint32

function GetUInt4();
public:
unsigned int GetUInt4()

Return Value

Type: UInt32
The value as a 32-bit unsigned integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.GetValue Method

Grid Solutions Framework ScalarElementGetValue Method
Gets the raw bytes of the value that this scalar represents.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetValue()
Public Function GetValue As Byte()
member GetValue : unit -> byte[]

function GetValue();
public:
array<unsigned char>^ GetValue()

Return Value

Type: Byte
The value in bytes.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.Set Method

Grid Solutions Framework ScalarElementSet Method
Sets the value at the given index as the physical type defined by [!:TypeOfValue].

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Set(
    int index,
    Object value
)
Public Sub Set (
    index As Integer,
    value As Object
)
member Set :
        index : int *
        value : Object -> unit

function Set(index, value);
public:
void Set(
    int index,
    Object^ value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemObject
The new value to be stored.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetBool4 Method

Grid Solutions Framework ScalarElementSetBool4 Method
Sets the value of this scalar as a 4-byte boolean.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetBool4(
    bool value
)
Public Sub SetBool4 (
    value As Boolean
)
member SetBool4 :
        value : bool -> unit

function SetBool4(value);
public:
void SetBool4(
    bool value
)

Parameters

value
Type: SystemBoolean
The new value as a 4-byte boolean.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetComplex16 Method

Grid Solutions Framework ScalarElementSetComplex16 Method
Sets the value of this scalar as a 16-byte complex number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetComplex16(
    ComplexNumber value
)
Public Sub SetComplex16 (
    value As ComplexNumber
)
member SetComplex16 :
        value : ComplexNumber -> unit

function SetComplex16(value);
public:
void SetComplex16(
    ComplexNumber value
)

Parameters

value
Type: GSFComplexNumber
The new value as a 16-byte complex number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetComplex8 Method

Grid Solutions Framework ScalarElementSetComplex8 Method
Sets the value of this scalar as an 8-byte complex number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetComplex8(
    ComplexNumber value
)
Public Sub SetComplex8 (
    value As ComplexNumber
)
member SetComplex8 :
        value : ComplexNumber -> unit

function SetComplex8(value);
public:
void SetComplex8(
    ComplexNumber value
)

Parameters

value
Type: GSFComplexNumber
The new value as an 8-byte complex number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetGuid Method

Grid Solutions Framework ScalarElementSetGuid Method
Sets the value of this scalar as a globally unique identifier.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetGuid(
    Guid value
)
Public Sub SetGuid (
    value As Guid
)
member SetGuid :
        value : Guid -> unit

function SetGuid(value);
public:
void SetGuid(
    Guid value
)

Parameters

value
Type: SystemGuid
The new value as a globally unique identifier.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetInt1 Method

Grid Solutions Framework ScalarElementSetInt1 Method
Sets the value of this scalar as an 8-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetInt1(
    sbyte value
)
Public Sub SetInt1 (
    value As SByte
)
member SetInt1 :
        value : sbyte -> unit

function SetInt1(value);
public:
void SetInt1(
    signed char value
)

Parameters

value
Type: SystemSByte
The new value as an 8-bit signed integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetInt2 Method

Grid Solutions Framework ScalarElementSetInt2 Method
Sets the value of this scalar as a 16-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetInt2(
    short value
)
Public Sub SetInt2 (
    value As Short
)
member SetInt2 :
        value : int16 -> unit

function SetInt2(value);
public:
void SetInt2(
    short value
)

Parameters

value
Type: SystemInt16
The new value as a 16-bit signed integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetInt4 Method

Grid Solutions Framework ScalarElementSetInt4 Method
Sets the value of this scalar as a 32-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetInt4(
    int value
)
Public Sub SetInt4 (
    value As Integer
)
member SetInt4 :
        value : int -> unit

function SetInt4(value);
public:
void SetInt4(
    int value
)

Parameters

value
Type: SystemInt32
The new value as a 32-bit signed integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetReal4 Method

Grid Solutions Framework ScalarElementSetReal4 Method
Sets the value of this scalar as a 32-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetReal4(
    float value
)
Public Sub SetReal4 (
    value As Single
)
member SetReal4 :
        value : float32 -> unit

function SetReal4(value);
public:
void SetReal4(
    float value
)

Parameters

value
Type: SystemSingle
The new value as a 32-bit floating point number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetReal8 Method

Grid Solutions Framework ScalarElementSetReal8 Method
Sets the value of this scalar as a 64-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetReal8(
    double value
)
Public Sub SetReal8 (
    value As Double
)
member SetReal8 :
        value : float -> unit

function SetReal8(value);
public:
void SetReal8(
    double value
)

Parameters

value
Type: SystemDouble
The new value as a 64-bit floating point number.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetTimestamp Method

Grid Solutions Framework ScalarElementSetTimestamp Method
Sets the value of this scalar as a DateTime.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetTimestamp(
    DateTime value
)
Public Sub SetTimestamp (
    value As DateTime
)
member SetTimestamp :
        value : DateTime -> unit

function SetTimestamp(value);
public:
void SetTimestamp(
    DateTime value
)

Parameters

value
Type: SystemDateTime
The new value of this scalar as a DateTime.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetUInt1 Method

Grid Solutions Framework ScalarElementSetUInt1 Method
Sets the value of this scalar as an 8-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetUInt1(
    byte value
)
Public Sub SetUInt1 (
    value As Byte
)
member SetUInt1 :
        value : byte -> unit

function SetUInt1(value);
public:
void SetUInt1(
    unsigned char value
)

Parameters

value
Type: SystemByte
The new value as an 8-bit unsigned integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetUInt2 Method

Grid Solutions Framework ScalarElementSetUInt2 Method
Sets the value of this scalar as a 16-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetUInt2(
    ushort value
)
Public Sub SetUInt2 (
    value As UShort
)
member SetUInt2 :
        value : uint16 -> unit

function SetUInt2(value);
public:
void SetUInt2(
    unsigned short value
)

Parameters

value
Type: SystemUInt16
The new value as a 16-bit unsigned integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetUInt4 Method

Grid Solutions Framework ScalarElementSetUInt4 Method
Sets the value of this scalar as a 32-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetUInt4(
    uint value
)
Public Sub SetUInt4 (
    value As UInteger
)
member SetUInt4 :
        value : uint32 -> unit

function SetUInt4(value);
public:
void SetUInt4(
    unsigned int value
)

Parameters

value
Type: SystemUInt32
The new value as a 32-bit unsigned integer.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.SetValue Method

Grid Solutions Framework ScalarElementSetValue Method
Sets the raw bytes of the value that this scalar represents.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetValue(
    byte[] value,
    int offset
)
Public Sub SetValue (
    value As Byte(),
    offset As Integer
)
member SetValue :
        value : byte[] *
        offset : int -> unit

function SetValue(value, offset);
public:
void SetValue(
    array<unsigned char>^ value,
    int offset
)

Parameters

value
Type: SystemByte
The array containing the bytes.
offset
Type: SystemInt32
The offset into the array at which the value starts.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.ToString Method

Grid Solutions Framework ScalarElementToString Method
Returns a string representation of the scalar.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A string representation of the scalar.
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement Properties

Grid Solutions Framework ScalarElement Properties

The ScalarElement type exposes the following members.

Properties
 | Name | Description
Public property | TagOfElement | Gets or sets the tag which identifies the element. (Inherited from Element.)
Public property | TypeOfElement | Gets the type of the element. Returns Scalar. (Overrides ElementTypeOfElement.)
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element. (Inherited from Element.)
Top
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


ScalarElement.TypeOfElement Property

Grid Solutions Framework ScalarElementTypeOfElement Property
Gets the type of the element. Returns Scalar.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ElementType TypeOfElement { get; }
Public Overrides ReadOnly Property TypeOfElement As ElementType
    Get
abstract TypeOfElement : ElementType with get
override TypeOfElement : ElementType with get
function get_TypeOfElement();

public:
virtual property ElementType TypeOfElement {
    ElementType get () override;
}

Property Value

Type: ElementType
See Also

Reference

ScalarElement Class
GSF.PQDIF.Physical Namespace


VectorElement Class

Grid Solutions Framework VectorElement Class
Represents an Element which is a collection of values in a PQDIF file. Vector elements are part of the physical structure of a PQDIF file. They exist within the body of a Record (contained by a CollectionElement).
Inheritance Hierarchy
SystemObject
GSF.PQDIF.PhysicalElement
GSF.PQDIF.PhysicalVectorElement

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class VectorElement : Element
Public Class VectorElement
    Inherits Element
type VectorElement =
    class
        inherit Element
    end
GSF.PQDIF.Physical.VectorElement = function();

Type.createClass(
    'GSF.PQDIF.Physical.VectorElement',
    GSF.PQDIF.Physical.Element);
public ref class VectorElement : public Element

The VectorElement type exposes the following members.

Constructors
 | Name | Description
Public method | VectorElement | Initializes a new instance of the VectorElement class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the value at the given index as the physical type defined by TypeOfValue and returns it as a generic Object.
Public method | GetGuid | Gets the value in this vector as a globally unique identifier.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt1 | Gets a value in this vector as an 8-bit signed integer.
Public method | GetInt2 | Gets a value in this vector as a 16-bit signed integer.
Public method | GetInt4 | Gets a value in this vector as a 32-bit signed integer.
Public method | GetReal4 | Gets a value in this vector as a 32-bit floating point number.
Public method | GetReal8 | Gets a value in this vector as a 64-bit floating point number.
Public method | GetTimestamp | Gets a value in this vector as a DateTime.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUInt1 | Gets a value in this vector as an 8-bit unsigned integer.
Public method | GetUInt2 | Gets a value in this vector as a 16-bit unsigned integer.
Public method | GetUInt4 | Gets a value in this vector as a 32-bit unsigned integer.
Public method | GetValues | Gets the raw bytes of the values contained by this vector.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | Sets the value at the given index as the physical type defined by TypeOfValue.
Public method | SetGuid | Sets the value in this vector as a globally unique identifier.
Public method | SetInt1 | Sets a value in this vector as an 8-bit signed integer.
Public method | SetInt2 | Sets a value in this vector as a 16-bit signed integer.
Public method | SetInt4 | Sets a value in this vector as a 32-bit signed integer.
Public method | SetReal4 | Sets a value in this vector as a 32-bit floating point number.
Public method | SetReal8 | Sets a value in this vector as a 64-bit floating point number.
Public method | SetTimestamp | Sets a value in this vector as a DateTime.
Public method | SetUInt1 | Sets a value in this vector as an 8-bit unsigned integer.
Public method | SetUInt2 | Sets a value in this vector as a 16-bit unsigned integer.
Public method | SetUInt4 | Sets a value in this vector as a 32-bit unsigned integer.
Public method | SetValues | Sets the raw bytes of the values contained by this vector.
Public method | ToString | Returns a string representation of this vector. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Size | Gets or sets the number of values in the vector.
Public property | TagOfElement | Gets or sets the tag which identifies the element. (Inherited from Element.)
Public property | TypeOfElement | Gets the type of the element. Returns Vector. (Overrides ElementTypeOfElement.)
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element. (Overrides ElementTypeOfValue.)
Top
See Also

Reference

GSF.PQDIF.Physical Namespace


VectorElement Constructor

Grid Solutions Framework VectorElement Constructor
Initializes a new instance of the VectorElement class

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public VectorElement()
Public Sub New
new : unit -> VectorElement
GSF.PQDIF.Physical.VectorElement = function();
public:
VectorElement()
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement Methods

Grid Solutions Framework VectorElement Methods

The VectorElement type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | Get | Gets the value at the given index as the physical type defined by TypeOfValue and returns it as a generic Object.
Public method | GetGuid | Gets the value in this vector as a globally unique identifier.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetInt1 | Gets a value in this vector as an 8-bit signed integer.
Public method | GetInt2 | Gets a value in this vector as a 16-bit signed integer.
Public method | GetInt4 | Gets a value in this vector as a 32-bit signed integer.
Public method | GetReal4 | Gets a value in this vector as a 32-bit floating point number.
Public method | GetReal8 | Gets a value in this vector as a 64-bit floating point number.
Public method | GetTimestamp | Gets a value in this vector as a DateTime.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUInt1 | Gets a value in this vector as an 8-bit unsigned integer.
Public method | GetUInt2 | Gets a value in this vector as a 16-bit unsigned integer.
Public method | GetUInt4 | Gets a value in this vector as a 32-bit unsigned integer.
Public method | GetValues | Gets the raw bytes of the values contained by this vector.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Set | Sets the value at the given index as the physical type defined by TypeOfValue.
Public method | SetGuid | Sets the value in this vector as a globally unique identifier.
Public method | SetInt1 | Sets a value in this vector as an 8-bit signed integer.
Public method | SetInt2 | Sets a value in this vector as a 16-bit signed integer.
Public method | SetInt4 | Sets a value in this vector as a 32-bit signed integer.
Public method | SetReal4 | Sets a value in this vector as a 32-bit floating point number.
Public method | SetReal8 | Sets a value in this vector as a 64-bit floating point number.
Public method | SetTimestamp | Sets a value in this vector as a DateTime.
Public method | SetUInt1 | Sets a value in this vector as an 8-bit unsigned integer.
Public method | SetUInt2 | Sets a value in this vector as a 16-bit unsigned integer.
Public method | SetUInt4 | Sets a value in this vector as a 32-bit unsigned integer.
Public method | SetValues | Sets the raw bytes of the values contained by this vector.
Public method | ToString | Returns a string representation of this vector. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.Get Method

Grid Solutions Framework VectorElementGet Method
Gets the value at the given index as the physical type defined by TypeOfValue and returns it as a generic Object.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object Get(
    int index
)
Public Function Get (
    index As Integer
) As Object
member Get :
        index : int -> Object

function Get(index);
public:
Object^ Get(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value to be retrieved.

Return Value

Type: Object
The value that was retrieved from the vector.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetGuid Method

Grid Solutions Framework VectorElementGetGuid Method
Gets the value in this vector as a globally unique identifier.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid GetGuid(
    int index
)
Public Function GetGuid (
    index As Integer
) As Guid
member GetGuid :
        index : int -> Guid

function GetGuid(index);
public:
Guid GetGuid(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: Guid
The value as a globally unique identifier.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetInt1 Method

Grid Solutions Framework VectorElementGetInt1 Method
Gets a value in this vector as an 8-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sbyte GetInt1(
    int index
)
Public Function GetInt1 (
    index As Integer
) As SByte
member GetInt1 :
        index : int -> sbyte

function GetInt1(index);
public:
signed char GetInt1(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: SByte
The value as an 8-bit signed integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetInt2 Method

Grid Solutions Framework VectorElementGetInt2 Method
Gets a value in this vector as a 16-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public short GetInt2(
    int index
)
Public Function GetInt2 (
    index As Integer
) As Short
member GetInt2 :
        index : int -> int16

function GetInt2(index);
public:
short GetInt2(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: Int16
The value as a 16-bit signed integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetInt4 Method

Grid Solutions Framework VectorElementGetInt4 Method
Gets a value in this vector as a 32-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GetInt4(
    int index
)
Public Function GetInt4 (
    index As Integer
) As Integer
member GetInt4 :
        index : int -> int

function GetInt4(index);
public:
int GetInt4(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: Int32
The value as a 32-bit signed integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetReal4 Method

Grid Solutions Framework VectorElementGetReal4 Method
Gets a value in this vector as a 32-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public float GetReal4(
    int index
)
Public Function GetReal4 (
    index As Integer
) As Single
member GetReal4 :
        index : int -> float32

function GetReal4(index);
public:
float GetReal4(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: Single
The value as a 32-bit floating point number.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetReal8 Method

Grid Solutions Framework VectorElementGetReal8 Method
Gets a value in this vector as a 64-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double GetReal8(
    int index
)
Public Function GetReal8 (
    index As Integer
) As Double
member GetReal8 :
        index : int -> float

function GetReal8(index);
public:
double GetReal8(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: Double
The value as a 64-bit floating point number.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetTimestamp Method

Grid Solutions Framework VectorElementGetTimestamp Method
Gets a value in this vector as a DateTime.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime GetTimestamp(
    int index
)
Public Function GetTimestamp (
    index As Integer
) As DateTime
member GetTimestamp :
        index : int -> DateTime

function GetTimestamp(index);
public:
DateTime GetTimestamp(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: DateTime
The value as a DateTime.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetUInt1 Method

Grid Solutions Framework VectorElementGetUInt1 Method
Gets a value in this vector as an 8-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte GetUInt1(
    int index
)
Public Function GetUInt1 (
    index As Integer
) As Byte
member GetUInt1 :
        index : int -> byte

function GetUInt1(index);
public:
unsigned char GetUInt1(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: Byte
The value as an 8-bit unsigned integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetUInt2 Method

Grid Solutions Framework VectorElementGetUInt2 Method
Gets a value in this vector as a 16-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort GetUInt2(
    int index
)
Public Function GetUInt2 (
    index As Integer
) As UShort
member GetUInt2 :
        index : int -> uint16

function GetUInt2(index);
public:
unsigned short GetUInt2(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: UInt16
The value as a 16-bit unsigned integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetUInt4 Method

Grid Solutions Framework VectorElementGetUInt4 Method
Gets a value in this vector as a 32-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint GetUInt4(
    int index
)
Public Function GetUInt4 (
    index As Integer
) As UInteger
member GetUInt4 :
        index : int -> uint32

function GetUInt4(index);
public:
unsigned int GetUInt4(
    int index
)

Parameters

index
Type: SystemInt32
The index of the value.

Return Value

Type: UInt32
The value as a 32-bit unsigned integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.GetValues Method

Grid Solutions Framework VectorElementGetValues Method
Gets the raw bytes of the values contained by this vector.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] GetValues()
Public Function GetValues As Byte()
member GetValues : unit -> byte[]

function GetValues();
public:
array<unsigned char>^ GetValues()

Return Value

Type: Byte
The raw bytes of the values contained by this vector.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.Set Method

Grid Solutions Framework VectorElementSet Method
Sets the value at the given index as the physical type defined by TypeOfValue.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Set(
    int index,
    Object value
)
Public Sub Set (
    index As Integer,
    value As Object
)
member Set :
        index : int *
        value : Object -> unit

function Set(index, value);
public:
void Set(
    int index,
    Object^ value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemObject
The new value to be stored.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetGuid Method

Grid Solutions Framework VectorElementSetGuid Method
Sets the value in this vector as a globally unique identifier.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetGuid(
    int index,
    Guid value
)
Public Sub SetGuid (
    index As Integer,
    value As Guid
)
member SetGuid :
        index : int *
        value : Guid -> unit

function SetGuid(index, value);
public:
void SetGuid(
    int index,
    Guid value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemGuid
The new value as a globally unique identifier.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetInt1 Method

Grid Solutions Framework VectorElementSetInt1 Method
Sets a value in this vector as an 8-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetInt1(
    int index,
    sbyte value
)
Public Sub SetInt1 (
    index As Integer,
    value As SByte
)
member SetInt1 :
        index : int *
        value : sbyte -> unit

function SetInt1(index, value);
public:
void SetInt1(
    int index,
    signed char value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemSByte
The new value of an 8-bit signed integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetInt2 Method

Grid Solutions Framework VectorElementSetInt2 Method
Sets a value in this vector as a 16-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetInt2(
    int index,
    short value
)
Public Sub SetInt2 (
    index As Integer,
    value As Short
)
member SetInt2 :
        index : int *
        value : int16 -> unit

function SetInt2(index, value);
public:
void SetInt2(
    int index,
    short value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemInt16
The new value of a 16-bit signed integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetInt4 Method

Grid Solutions Framework VectorElementSetInt4 Method
Sets a value in this vector as a 32-bit signed integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetInt4(
    int index,
    int value
)
Public Sub SetInt4 (
    index As Integer,
    value As Integer
)
member SetInt4 :
        index : int *
        value : int -> unit

function SetInt4(index, value);
public:
void SetInt4(
    int index,
    int value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemInt32
The new value of a 32-bit signed integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetReal4 Method

Grid Solutions Framework VectorElementSetReal4 Method
Sets a value in this vector as a 32-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetReal4(
    int index,
    float value
)
Public Sub SetReal4 (
    index As Integer,
    value As Single
)
member SetReal4 :
        index : int *
        value : float32 -> unit

function SetReal4(index, value);
public:
void SetReal4(
    int index,
    float value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemSingle
The new value of a 32-bit floating point number.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetReal8 Method

Grid Solutions Framework VectorElementSetReal8 Method
Sets a value in this vector as a 64-bit floating point number.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetReal8(
    int index,
    double value
)
Public Sub SetReal8 (
    index As Integer,
    value As Double
)
member SetReal8 :
        index : int *
        value : float -> unit

function SetReal8(index, value);
public:
void SetReal8(
    int index,
    double value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemDouble
The new value of a 64-bit floating point number.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetTimestamp Method

Grid Solutions Framework VectorElementSetTimestamp Method
Sets a value in this vector as a DateTime.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetTimestamp(
    int index,
    DateTime value
)
Public Sub SetTimestamp (
    index As Integer,
    value As DateTime
)
member SetTimestamp :
        index : int *
        value : DateTime -> unit

function SetTimestamp(index, value);
public:
void SetTimestamp(
    int index,
    DateTime value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemDateTime
The new value of a DateTime.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetUInt1 Method

Grid Solutions Framework VectorElementSetUInt1 Method
Sets a value in this vector as an 8-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetUInt1(
    int index,
    byte value
)
Public Sub SetUInt1 (
    index As Integer,
    value As Byte
)
member SetUInt1 :
        index : int *
        value : byte -> unit

function SetUInt1(index, value);
public:
void SetUInt1(
    int index,
    unsigned char value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemByte
The new value of an 8-bit unsigned integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetUInt2 Method

Grid Solutions Framework VectorElementSetUInt2 Method
Sets a value in this vector as a 16-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetUInt2(
    int index,
    ushort value
)
Public Sub SetUInt2 (
    index As Integer,
    value As UShort
)
member SetUInt2 :
        index : int *
        value : uint16 -> unit

function SetUInt2(index, value);
public:
void SetUInt2(
    int index,
    unsigned short value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemUInt16
The new value of a 16-bit unsigned integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetUInt4 Method

Grid Solutions Framework VectorElementSetUInt4 Method
Sets a value in this vector as a 32-bit unsigned integer.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetUInt4(
    int index,
    uint value
)
Public Sub SetUInt4 (
    index As Integer,
    value As UInteger
)
member SetUInt4 :
        index : int *
        value : uint32 -> unit

function SetUInt4(index, value);
public:
void SetUInt4(
    int index,
    unsigned int value
)

Parameters

index
Type: SystemInt32
The index of the value.
value
Type: SystemUInt32
The new value of a 32-bit unsigned integer.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.SetValues Method

Grid Solutions Framework VectorElementSetValues Method
Sets the raw bytes of the values contained by this vector.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetValues(
    byte[] values,
    int offset
)
Public Sub SetValues (
    values As Byte(),
    offset As Integer
)
member SetValues :
        values : byte[] *
        offset : int -> unit

function SetValues(values, offset);
public:
void SetValues(
    array<unsigned char>^ values,
    int offset
)

Parameters

values
Type: SystemByte
The array that contains the raw bytes.
offset
Type: SystemInt32
The offset into the array at which the values start.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.ToString Method

Grid Solutions Framework VectorElementToString Method
Returns a string representation of this vector.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A string representation of this vector.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement Properties

Grid Solutions Framework VectorElement Properties

The VectorElement type exposes the following members.

Properties
 | Name | Description
Public property | Size | Gets or sets the number of values in the vector.
Public property | TagOfElement | Gets or sets the tag which identifies the element. (Inherited from Element.)
Public property | TypeOfElement | Gets the type of the element. Returns Vector. (Overrides ElementTypeOfElement.)
Public property | TypeOfValue | Gets or sets the physical type of the value or values contained by the element. (Overrides ElementTypeOfValue.)
Top
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.Size Property

Grid Solutions Framework VectorElementSize Property
Gets or sets the number of values in the vector.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Size { get; set; }
Public Property Size As Integer
    Get
    Set
member Size : int with get, set

function get_Size();
function set_Size(value);
public:
property int Size {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.TypeOfElement Property

Grid Solutions Framework VectorElementTypeOfElement Property
Gets the type of the element. Returns Vector.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override ElementType TypeOfElement { get; }
Public Overrides ReadOnly Property TypeOfElement As ElementType
    Get
abstract TypeOfElement : ElementType with get
override TypeOfElement : ElementType with get
function get_TypeOfElement();

public:
virtual property ElementType TypeOfElement {
    ElementType get () override;
}

Property Value

Type: ElementType
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


VectorElement.TypeOfValue Property

Grid Solutions Framework VectorElementTypeOfValue Property
Gets or sets the physical type of the value or values contained by the element.

Namespace: GSF.PQDIF.Physical
Assembly: GSF.PQDIF (in GSF.PQDIF.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override PhysicalType TypeOfValue { get; set; }
Public Overrides Property TypeOfValue As PhysicalType
    Get
    Set
abstract TypeOfValue : PhysicalType with get, set
override TypeOfValue : PhysicalType with get, set
function get_TypeOfValue();
function set_TypeOfValue(value);
public:
virtual property PhysicalType TypeOfValue {
    PhysicalType get () override;
    void set (PhysicalType value) override;
}

Property Value

Type: PhysicalType
Remarks
This determines the data type and size of the value or values. The value of this property is only relevant when TypeOfElement is either Scalar or Vector.
See Also

Reference

VectorElement Class
GSF.PQDIF.Physical Namespace


GSF.Reflection Namespace

Grid Solutions Framework GSF.Reflection Namespace
Contains classes and extension functions used to simplify and standardize access to assembly information and attributes in applications.
Classes
 | Class | Description
Public class | AssemblyExtensions | Defines extension functions related to Assemblies.
Public class | AssemblyInfo | Represents a common information provider for an assembly.
Public class | MemberInfoExtensions | Defines extensions methods related to MemberInfo objects and derived types (e.g., FieldInfo, PropertyInfo, MethodInfo, etc.)


AssemblyExtensions Class

Grid Solutions Framework AssemblyExtensions Class
Defines extension functions related to Assemblies.
Inheritance Hierarchy
SystemObject
GSF.ReflectionAssemblyExtensions

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class AssemblyExtensions
<ExtensionAttribute>
Public NotInheritable Class AssemblyExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type AssemblyExtensions =  class end
GSF.Reflection.AssemblyExtensions = function();

Type.createClass(
    'GSF.Reflection.AssemblyExtensions');
[ExtensionAttribute]
public ref class AssemblyExtensions abstract sealed

The AssemblyExtensions type exposes the following members.

Methods
Name | Description
BuildDate | Gets the date and time when the assembly was last built.
CLSCompliant | Gets a boolean value indicating whether the indicated program element is CLS-compliant.
ComCompatibleVersion | Gets the string representing the assembly version used to indicate to a COM client that all classes in the current version of the assembly are compatible with classes in an earlier version of the assembly.
Company | Gets the company name information of the assembly.
ComVisible | Gets a boolean value indicating if the assembly is exposed to COM.
Configuration | Gets the configuration information of the assembly.
Copyright | Gets the copyright information of the assembly.
CultureName | Gets the culture name of the assembly.
DelaySign | Gets a boolean value indicating if the assembly has been built as delay-signed.
Description | Gets the description information of the assembly.
GetAttributes | Gets a name/value collection of assembly attributes exposed by the assembly.
GetEmbeddedResource | Gets the specified embedded resource from the assembly.
Guid | Gets the assembly GUID that is used as an ID if the assembly is exposed to COM.
InformationalVersion | Gets the version information of the assembly.
KeyFile | Gets the name of the file containing the key pair used to generate a strong name for the attributed assembly.
Product | Gets the product name information of the assembly.
RootNamespace | Gets the root namespace of the assembly.
SatelliteContractVersion | Gets the assembly version used to instruct the System.Resources.ResourceManager to ask for a particular version of a satellite assembly to simplify updates of the main assembly of an application.
ShortName | Returns only assembly name and version from full assembly name.
Title | Gets the title information of the assembly.
Trademark | Gets the trademark information of the assembly.
TryLoadAllReferences | Recursively attempts to load all assemblies referenced from the given assembly.
TypeLibVersion | Gets the string representing the assembly version number in MajorVersion.MinorVersion format.
Top
See Also

Reference

GSF.Reflection Namespace


AssemblyExtensions Methods

Grid Solutions Framework AssemblyExtensions Methods

The AssemblyExtensions type exposes the following members.

Methods
Name | Description
BuildDate | Gets the date and time when the assembly was last built.
CLSCompliant | Gets a boolean value indicating whether the indicated program element is CLS-compliant.
ComCompatibleVersion | Gets the string representing the assembly version used to indicate to a COM client that all classes in the current version of the assembly are compatible with classes in an earlier version of the assembly.
Company | Gets the company name information of the assembly.
ComVisible | Gets a boolean value indicating if the assembly is exposed to COM.
Configuration | Gets the configuration information of the assembly.
Copyright | Gets the copyright information of the assembly.
CultureName | Gets the culture name of the assembly.
DelaySign | Gets a boolean value indicating if the assembly has been built as delay-signed.
Description | Gets the description information of the assembly.
GetAttributes | Gets a name/value collection of assembly attributes exposed by the assembly.
GetEmbeddedResource | Gets the specified embedded resource from the assembly.
Guid | Gets the assembly GUID that is used as an ID if the assembly is exposed to COM.
InformationalVersion | Gets the version information of the assembly.
KeyFile | Gets the name of the file containing the key pair used to generate a strong name for the attributed assembly.
Product | Gets the product name information of the assembly.
RootNamespace | Gets the root namespace of the assembly.
SatelliteContractVersion | Gets the assembly version used to instruct the System.Resources.ResourceManager to ask for a particular version of a satellite assembly to simplify updates of the main assembly of an application.
ShortName | Returns only assembly name and version from full assembly name.
Title | Gets the title information of the assembly.
Trademark | Gets the trademark information of the assembly.
TryLoadAllReferences | Recursively attempts to load all assemblies referenced from the given assembly.
TypeLibVersion | Gets the string representing the assembly version number in MajorVersion.MinorVersion format.
Top
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.BuildDate Method

Grid Solutions Framework AssemblyExtensionsBuildDate Method
Gets the date and time when the assembly was last built.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime BuildDate(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function BuildDate (
    assemblyInstance As Assembly
) As DateTime
static member BuildDate :
        assemblyInstance : Assembly -> DateTime

GSF.Reflection.AssemblyExtensions.BuildDate = function(assemblyInstance);
public:
[ExtensionAttribute]
static DateTime BuildDate(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: DateTime
The date and time when the assembly was last built.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.CLSCompliant Method

Grid Solutions Framework AssemblyExtensionsCLSCompliant Method
Gets a boolean value indicating whether the indicated program element is CLS-compliant.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CLSCompliant(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function CLSCompliant (
    assemblyInstance As Assembly
) As Boolean
static member CLSCompliant :
        assemblyInstance : Assembly -> bool

GSF.Reflection.AssemblyExtensions.CLSCompliant = function(assemblyInstance);
public:
[ExtensionAttribute]
static bool CLSCompliant(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: Boolean
True, if the program element is CLS-compliant; otherwise, False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.ComCompatibleVersion Method

Grid Solutions Framework AssemblyExtensionsComCompatibleVersion Method
Gets the string representing the assembly version used to indicate to a COM client that all classes in the current version of the assembly are compatible with classes in an earlier version of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ComCompatibleVersion(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function ComCompatibleVersion (
    assemblyInstance As Assembly
) As String
static member ComCompatibleVersion :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.ComCompatibleVersion = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ ComCompatibleVersion(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The string representing the assembly version in MajorVersion.MinorVersion.RevisionNumber.BuildNumber format.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Company Method

Grid Solutions Framework AssemblyExtensionsCompany Method
Gets the company name information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Company(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Company (
    assemblyInstance As Assembly
) As String
static member Company :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Company = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Company(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The company name information of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.ComVisible Method

Grid Solutions Framework AssemblyExtensionsComVisible Method
Gets a boolean value indicating if the assembly is exposed to COM.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ComVisible(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function ComVisible (
    assemblyInstance As Assembly
) As Boolean
static member ComVisible :
        assemblyInstance : Assembly -> bool

GSF.Reflection.AssemblyExtensions.ComVisible = function(assemblyInstance);
public:
[ExtensionAttribute]
static bool ComVisible(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: Boolean
True, if the assembly is exposed to COM; otherwise, False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Configuration Method

Grid Solutions Framework AssemblyExtensionsConfiguration Method
Gets the configuration information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Configuration(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Configuration (
    assemblyInstance As Assembly
) As String
static member Configuration :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Configuration = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Configuration(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The configuration information of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Copyright Method

Grid Solutions Framework AssemblyExtensionsCopyright Method
Gets the copyright information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Copyright(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Copyright (
    assemblyInstance As Assembly
) As String
static member Copyright :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Copyright = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Copyright(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The copyright information of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.CultureName Method

Grid Solutions Framework AssemblyExtensionsCultureName Method
Gets the culture name of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string CultureName(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function CultureName (
    assemblyInstance As Assembly
) As String
static member CultureName :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.CultureName = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ CultureName(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The culture name of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.DelaySign Method

Grid Solutions Framework AssemblyExtensionsDelaySign Method
Gets a boolean value indicating if the assembly has been built as delay-signed.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool DelaySign(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function DelaySign (
    assemblyInstance As Assembly
) As Boolean
static member DelaySign :
        assemblyInstance : Assembly -> bool

GSF.Reflection.AssemblyExtensions.DelaySign = function(assemblyInstance);
public:
[ExtensionAttribute]
static bool DelaySign(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: Boolean
True, if the assembly has been built as delay-signed; otherwise, False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Description Method

Grid Solutions Framework AssemblyExtensionsDescription Method
Gets the description information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Description(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Description (
    assemblyInstance As Assembly
) As String
static member Description :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Description = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Description(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The description information of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.GetAttributes Method

Grid Solutions Framework AssemblyExtensionsGetAttributes Method
Gets a name/value collection of assembly attributes exposed by the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static NameValueCollection GetAttributes(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function GetAttributes (
    assemblyInstance As Assembly
) As NameValueCollection
static member GetAttributes :
        assemblyInstance : Assembly -> NameValueCollection

GSF.Reflection.AssemblyExtensions.GetAttributes = function(assemblyInstance);
public:
[ExtensionAttribute]
static NameValueCollection^ GetAttributes(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: NameValueCollection
A NameValueCollection of assembly attributes.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.GetEmbeddedResource Method

Grid Solutions Framework AssemblyExtensionsGetEmbeddedResource Method
Gets the specified embedded resource from the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Stream GetEmbeddedResource(
    this Assembly assemblyInstance,
    string resourceName
)
<ExtensionAttribute>
Public Shared Function GetEmbeddedResource (
    assemblyInstance As Assembly,
    resourceName As String
) As Stream
static member GetEmbeddedResource :
        assemblyInstance : Assembly *
        resourceName : string -> Stream

GSF.Reflection.AssemblyExtensions.GetEmbeddedResource = function(assemblyInstance, resourceName);
public:
[ExtensionAttribute]
static Stream^ GetEmbeddedResource(
    Assembly^ assemblyInstance,
    String^ resourceName
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.
resourceName
Type: SystemString
The full name (including the namespace) of the embedded resource to get.

Return Value

Type: Stream
The embedded resource.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Guid Method

Grid Solutions Framework AssemblyExtensionsGuid Method
Gets the assembly GUID that is used as an ID if the assembly is exposed to COM.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Guid(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Guid (
    assemblyInstance As Assembly
) As String
static member Guid :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Guid = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Guid(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The assembly GUID that is used as an ID if the assembly is exposed to COM.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.InformationalVersion Method

Grid Solutions Framework AssemblyExtensionsInformationalVersion Method
Gets the version information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string InformationalVersion(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function InformationalVersion (
    assemblyInstance As Assembly
) As String
static member InformationalVersion :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.InformationalVersion = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ InformationalVersion(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The version information of the assembly

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.KeyFile Method

Grid Solutions Framework AssemblyExtensionsKeyFile Method
Gets the name of the file containing the key pair used to generate a strong name for the attributed assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string KeyFile(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function KeyFile (
    assemblyInstance As Assembly
) As String
static member KeyFile :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.KeyFile = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ KeyFile(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
A string containing the name of the file that contains the key pair.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Product Method

Grid Solutions Framework AssemblyExtensionsProduct Method
Gets the product name information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Product(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Product (
    assemblyInstance As Assembly
) As String
static member Product :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Product = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Product(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The product name information of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.RootNamespace Method

Grid Solutions Framework AssemblyExtensionsRootNamespace Method
Gets the root namespace of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string RootNamespace(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function RootNamespace (
    assemblyInstance As Assembly
) As String
static member RootNamespace :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.RootNamespace = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ RootNamespace(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The root namespace of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.SatelliteContractVersion Method

Grid Solutions Framework AssemblyExtensionsSatelliteContractVersion Method
Gets the assembly version used to instruct the System.Resources.ResourceManager to ask for a particular version of a satellite assembly to simplify updates of the main assembly of an application.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string SatelliteContractVersion(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function SatelliteContractVersion (
    assemblyInstance As Assembly
) As String
static member SatelliteContractVersion :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.SatelliteContractVersion = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ SatelliteContractVersion(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The satellite contract version of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.ShortName Method

Grid Solutions Framework AssemblyExtensionsShortName Method
Returns only assembly name and version from full assembly name.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ShortName(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function ShortName (
    assemblyInstance As Assembly
) As String
static member ShortName :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.ShortName = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ ShortName(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
An Assembly to get the short name of.

Return Value

Type: String
The assembly name and version from the full assembly name.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Title Method

Grid Solutions Framework AssemblyExtensionsTitle Method
Gets the title information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Title(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Title (
    assemblyInstance As Assembly
) As String
static member Title :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Title = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Title(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The title information of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.Trademark Method

Grid Solutions Framework AssemblyExtensionsTrademark Method
Gets the trademark information of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Trademark(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function Trademark (
    assemblyInstance As Assembly
) As String
static member Trademark :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.Trademark = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ Trademark(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The trademark information of the assembly.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.TryLoadAllReferences Method

Grid Solutions Framework AssemblyExtensionsTryLoadAllReferences Method
Recursively attempts to load all assemblies referenced from the given assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryLoadAllReferences(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function TryLoadAllReferences (
    assemblyInstance As Assembly
) As Boolean
static member TryLoadAllReferences :
        assemblyInstance : Assembly -> bool

GSF.Reflection.AssemblyExtensions.TryLoadAllReferences = function(assemblyInstance);
public:
[ExtensionAttribute]
static bool TryLoadAllReferences(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
The assembly whose references are to be loaded.

Return Value

Type: Boolean
True if the references were successfully loaded; false otherwise.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If an object is created from a type that is loaded from an assembly, and if that assembly's references fail to load during instantiation, an exception may be thrown from both the constructor and the finalizer of the object that was instantiated. This method allows us to ensure that all referenced assemblies can be loaded before attempting to instantiate a type from that assembly.
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyExtensions.TypeLibVersion Method

Grid Solutions Framework AssemblyExtensionsTypeLibVersion Method
Gets the string representing the assembly version number in MajorVersion.MinorVersion format.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string TypeLibVersion(
    this Assembly assemblyInstance
)
<ExtensionAttribute>
Public Shared Function TypeLibVersion (
    assemblyInstance As Assembly
) As String
static member TypeLibVersion :
        assemblyInstance : Assembly -> string

GSF.Reflection.AssemblyExtensions.TypeLibVersion = function(assemblyInstance);
public:
[ExtensionAttribute]
static String^ TypeLibVersion(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
Source assembly.

Return Value

Type: String
The string representing the assembly version number in MajorVersion.MinorVersion format.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Assembly. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

AssemblyExtensions Class
GSF.Reflection Namespace


AssemblyInfo Class

Grid Solutions Framework AssemblyInfo Class
Represents a common information provider for an assembly.
Inheritance Hierarchy
SystemObject
GSF.ReflectionAssemblyInfo

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AssemblyInfo
Public Class AssemblyInfo
type AssemblyInfo =  class end
GSF.Reflection.AssemblyInfo = function();

Type.createClass(
    'GSF.Reflection.AssemblyInfo');
public ref class AssemblyInfo

The AssemblyInfo type exposes the following members.

Constructors
 | Name | Description
Public method | AssemblyInfo | Initializes a new instance of the AssemblyInfo class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | Gets a collection of assembly attributes exposed by the assembly.
Public method | GetCustomAttribute | Gets the specified assembly attribute if it is exposed by the assembly.
Public method | GetEmbeddedResource | Gets the specified embedded resource from the assembly.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAssemblyFromResource | Loads the specified assembly that is embedded as a resource in the assembly.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Assembly | Gets the underlying Assembly being represented by this AssemblyInfo object.
Public property | BuildDate | Gets the date and time when the Assembly was built.
 | CallingAssembly | Gets the AssemblyInfo object of the assembly that invoked the currently executing method.
Public property | CLSCompliant | Gets a boolean value indicating whether the Assembly is CLS-compliant.
Public property | CodeBase | Gets the location of the Assembly as specified originally.
Public property | ComCompatibleVersion | Gets the string representing the assembly version used to indicate to a COM client that all classes in the current version of the assembly are compatible with classes in an earlier version of the assembly.
Public property | Company | Gets the company name information of the Assembly.
Public property | ComVisible | Gets a boolean value indicating if the Assembly is exposed to COM.
Public property | Configuration | Gets the configuration information of the Assembly.
Public property | Copyright | Gets the copyright information of the Assembly.
Public property | CultureName | Gets the culture name of the Assembly.
Public property | DelaySign | Gets a boolean value indicating if the Assembly has been built as delay-signed.
Public property | Description | Gets the description information of the Assembly.
 | EntryAssembly | Gets the AssemblyInfo object of the process executable in the default application domain.
 | ExecutingAssembly | Gets the AssemblyInfo object of the assembly that contains the code that is currently executing.
Public property | FullName | Gets the display name of the Assembly.
Public property | GACLoaded | Gets a boolean value indicating whether the Assembly was loaded from the global assembly cache.
Public property | Guid | Gets the GUID that is used as an ID if the Assembly is exposed to COM.
Public property | ImageRuntimeVersion | Gets the string representing the version of the common language runtime (CLR) saved in the file containing the manifest.
Public property | InformationalVersion | Gets the version information of the Assembly.
Public property | KeyFile | Gets the name of the file containing the key pair used to generate a strong name for the attributed Assembly.
Public property | Location | Gets the path or UNC location of the loaded file that contains the manifest.
Public property | Name | Gets the simple, unencrypted name of the Assembly.
Public property | Product | Gets the product name information of the Assembly.
Public property | RootNamespace | Gets the root namespace of the Assembly.
Public property | SatelliteContractVersion | Gets the assembly version used to instruct the System.Resources.ResourceManager to ask for a particular version of a satellite assembly to simplify updates of the main assembly of an application.
Public property | Title | Gets the title information of the Assembly.
Public property | Trademark | Gets the trademark information of the Assembly.
Public property | TypeLibVersion | Gets the string representing the Assembly version number in MajorVersion.MinorVersion format.
Public property | Version | Gets the major, minor, revision, and build numbers of the Assembly.
Top
See Also

Reference

GSF.Reflection Namespace


AssemblyInfo Constructor

Grid Solutions Framework AssemblyInfo Constructor
Initializes a new instance of the AssemblyInfo class.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AssemblyInfo(
    Assembly assemblyInstance
)
Public Sub New (
    assemblyInstance As Assembly
)
new :
        assemblyInstance : Assembly -> AssemblyInfo
GSF.Reflection.AssemblyInfo = function(assemblyInstance);
public:
AssemblyInfo(
    Assembly^ assemblyInstance
)

Parameters

assemblyInstance
Type: System.ReflectionAssembly
An Assembly object.
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo Methods

Grid Solutions Framework AssemblyInfo Methods

The AssemblyInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAttributes | Gets a collection of assembly attributes exposed by the assembly.
Public method | GetCustomAttribute | Gets the specified assembly attribute if it is exposed by the assembly.
Public method | GetEmbeddedResource | Gets the specified embedded resource from the assembly.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LoadAssemblyFromResource | Loads the specified assembly that is embedded as a resource in the assembly.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.GetAttributes Method

Grid Solutions Framework AssemblyInfoGetAttributes Method
Gets a collection of assembly attributes exposed by the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NameValueCollection GetAttributes()
Public Function GetAttributes As NameValueCollection
member GetAttributes : unit -> NameValueCollection

function GetAttributes();
public:
NameValueCollection^ GetAttributes()

Return Value

Type: NameValueCollection
A System.Specialized.KeyValueCollection of assembly attributes.
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.GetCustomAttribute Method

Grid Solutions Framework AssemblyInfoGetCustomAttribute Method
Gets the specified assembly attribute if it is exposed by the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CustomAttributeData GetCustomAttribute(
    Type attributeType
)
Public Function GetCustomAttribute (
    attributeType As Type
) As CustomAttributeData
member GetCustomAttribute :
        attributeType : Type -> CustomAttributeData

function GetCustomAttribute(attributeType);
public:
CustomAttributeData^ GetCustomAttribute(
    Type^ attributeType
)

Parameters

attributeType
Type: SystemType
Type of the attribute to get.

Return Value

Type: CustomAttributeData
The requested assembly attribute if it exists; otherwise null.
Remarks
This method always returns null under Mono deployments.
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.GetEmbeddedResource Method

Grid Solutions Framework AssemblyInfoGetEmbeddedResource Method
Gets the specified embedded resource from the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Stream GetEmbeddedResource(
    string resourceName
)
Public Function GetEmbeddedResource (
    resourceName As String
) As Stream
member GetEmbeddedResource :
        resourceName : string -> Stream

function GetEmbeddedResource(resourceName);
public:
Stream^ GetEmbeddedResource(
    String^ resourceName
)

Parameters

resourceName
Type: SystemString
The full name (including the namespace) of the embedded resource to get.

Return Value

Type: Stream
The embedded resource.
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.LoadAssemblyFromResource Method

Grid Solutions Framework AssemblyInfoLoadAssemblyFromResource Method
Loads the specified assembly that is embedded as a resource in the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SecurityCriticalAttribute]
public static void LoadAssemblyFromResource(
    string assemblyName
)
<SecurityCriticalAttribute>
Public Shared Sub LoadAssemblyFromResource (
    assemblyName As String
)
[<SecurityCriticalAttribute>]
static member LoadAssemblyFromResource :
        assemblyName : string -> unit

GSF.Reflection.AssemblyInfo.LoadAssemblyFromResource = function(assemblyName);
public:
[SecurityCriticalAttribute]
static void LoadAssemblyFromResource(
    String^ assemblyName
)

Parameters

assemblyName
Type: SystemString
Name of the assembly to load.
Remarks
This cannot be used to load GSF.Core itself.
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo Properties

Grid Solutions Framework AssemblyInfo Properties

The AssemblyInfo type exposes the following members.

Properties
 | Name | Description
Public property | Assembly | Gets the underlying Assembly being represented by this AssemblyInfo object.
Public property | BuildDate | Gets the date and time when the Assembly was built.
 | CallingAssembly | Gets the AssemblyInfo object of the assembly that invoked the currently executing method.
Public property | CLSCompliant | Gets a boolean value indicating whether the Assembly is CLS-compliant.
Public property | CodeBase | Gets the location of the Assembly as specified originally.
Public property | ComCompatibleVersion | Gets the string representing the assembly version used to indicate to a COM client that all classes in the current version of the assembly are compatible with classes in an earlier version of the assembly.
Public property | Company | Gets the company name information of the Assembly.
Public property | ComVisible | Gets a boolean value indicating if the Assembly is exposed to COM.
Public property | Configuration | Gets the configuration information of the Assembly.
Public property | Copyright | Gets the copyright information of the Assembly.
Public property | CultureName | Gets the culture name of the Assembly.
Public property | DelaySign | Gets a boolean value indicating if the Assembly has been built as delay-signed.
Public property | Description | Gets the description information of the Assembly.
 | EntryAssembly | Gets the AssemblyInfo object of the process executable in the default application domain.
 | ExecutingAssembly | Gets the AssemblyInfo object of the assembly that contains the code that is currently executing.
Public property | FullName | Gets the display name of the Assembly.
Public property | GACLoaded | Gets a boolean value indicating whether the Assembly was loaded from the global assembly cache.
Public property | Guid | Gets the GUID that is used as an ID if the Assembly is exposed to COM.
Public property | ImageRuntimeVersion | Gets the string representing the version of the common language runtime (CLR) saved in the file containing the manifest.
Public property | InformationalVersion | Gets the version information of the Assembly.
Public property | KeyFile | Gets the name of the file containing the key pair used to generate a strong name for the attributed Assembly.
Public property | Location | Gets the path or UNC location of the loaded file that contains the manifest.
Public property | Name | Gets the simple, unencrypted name of the Assembly.
Public property | Product | Gets the product name information of the Assembly.
Public property | RootNamespace | Gets the root namespace of the Assembly.
Public property | SatelliteContractVersion | Gets the assembly version used to instruct the System.Resources.ResourceManager to ask for a particular version of a satellite assembly to simplify updates of the main assembly of an application.
Public property | Title | Gets the title information of the Assembly.
Public property | Trademark | Gets the trademark information of the Assembly.
Public property | TypeLibVersion | Gets the string representing the Assembly version number in MajorVersion.MinorVersion format.
Public property | Version | Gets the major, minor, revision, and build numbers of the Assembly.
Top
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Assembly Property

Grid Solutions Framework AssemblyInfoAssembly Property
Gets the underlying Assembly being represented by this AssemblyInfo object.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Assembly Assembly { get; }
Public ReadOnly Property Assembly As Assembly
    Get
member Assembly : Assembly with get

function get_Assembly();

public:
property Assembly^ Assembly {
    Assembly^ get ();
}

Property Value

Type: Assembly
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.BuildDate Property

Grid Solutions Framework AssemblyInfoBuildDate Property
Gets the date and time when the Assembly was built.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime BuildDate { get; }
Public ReadOnly Property BuildDate As DateTime
    Get
member BuildDate : DateTime with get

function get_BuildDate();

public:
property DateTime BuildDate {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.CallingAssembly Property

Grid Solutions Framework AssemblyInfoCallingAssembly Property
Gets the AssemblyInfo object of the assembly that invoked the currently executing method.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static AssemblyInfo CallingAssembly { get; }
Public Shared ReadOnly Property CallingAssembly As AssemblyInfo
    Get
static member CallingAssembly : AssemblyInfo with get

GSF.Reflection.AssemblyInfo.get_CallingAssembly = function();

public:
static property AssemblyInfo^ CallingAssembly {
    AssemblyInfo^ get ();
}

Property Value

Type: AssemblyInfo
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.CLSCompliant Property

Grid Solutions Framework AssemblyInfoCLSCompliant Property
Gets a boolean value indicating whether the Assembly is CLS-compliant.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CLSCompliant { get; }
Public ReadOnly Property CLSCompliant As Boolean
    Get
member CLSCompliant : bool with get

function get_CLSCompliant();

public:
property bool CLSCompliant {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.CodeBase Property

Grid Solutions Framework AssemblyInfoCodeBase Property
Gets the location of the Assembly as specified originally.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CodeBase { get; }
Public ReadOnly Property CodeBase As String
    Get
member CodeBase : string with get

function get_CodeBase();

public:
property String^ CodeBase {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.ComCompatibleVersion Property

Grid Solutions Framework AssemblyInfoComCompatibleVersion Property
Gets the string representing the assembly version used to indicate to a COM client that all classes in the current version of the assembly are compatible with classes in an earlier version of the assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ComCompatibleVersion { get; }
Public ReadOnly Property ComCompatibleVersion As String
    Get
member ComCompatibleVersion : string with get

function get_ComCompatibleVersion();

public:
property String^ ComCompatibleVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Company Property

Grid Solutions Framework AssemblyInfoCompany Property
Gets the company name information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Company { get; }
Public ReadOnly Property Company As String
    Get
member Company : string with get

function get_Company();

public:
property String^ Company {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.ComVisible Property

Grid Solutions Framework AssemblyInfoComVisible Property
Gets a boolean value indicating if the Assembly is exposed to COM.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ComVisible { get; }
Public ReadOnly Property ComVisible As Boolean
    Get
member ComVisible : bool with get

function get_ComVisible();

public:
property bool ComVisible {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Configuration Property

Grid Solutions Framework AssemblyInfoConfiguration Property
Gets the configuration information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Configuration { get; }
Public ReadOnly Property Configuration As String
    Get
member Configuration : string with get

function get_Configuration();

public:
property String^ Configuration {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Copyright Property

Grid Solutions Framework AssemblyInfoCopyright Property
Gets the copyright information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Copyright { get; }
Public ReadOnly Property Copyright As String
    Get
member Copyright : string with get

function get_Copyright();

public:
property String^ Copyright {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.CultureName Property

Grid Solutions Framework AssemblyInfoCultureName Property
Gets the culture name of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CultureName { get; }
Public ReadOnly Property CultureName As String
    Get
member CultureName : string with get

function get_CultureName();

public:
property String^ CultureName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.DelaySign Property

Grid Solutions Framework AssemblyInfoDelaySign Property
Gets a boolean value indicating if the Assembly has been built as delay-signed.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DelaySign { get; }
Public ReadOnly Property DelaySign As Boolean
    Get
member DelaySign : bool with get

function get_DelaySign();

public:
property bool DelaySign {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Description Property

Grid Solutions Framework AssemblyInfoDescription Property
Gets the description information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
member Description : string with get

function get_Description();

public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.EntryAssembly Property

Grid Solutions Framework AssemblyInfoEntryAssembly Property
Gets the AssemblyInfo object of the process executable in the default application domain.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static AssemblyInfo EntryAssembly { get; }
Public Shared ReadOnly Property EntryAssembly As AssemblyInfo
    Get
static member EntryAssembly : AssemblyInfo with get

GSF.Reflection.AssemblyInfo.get_EntryAssembly = function();

public:
static property AssemblyInfo^ EntryAssembly {
    AssemblyInfo^ get ();
}

Property Value

Type: AssemblyInfo
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.ExecutingAssembly Property

Grid Solutions Framework AssemblyInfoExecutingAssembly Property
Gets the AssemblyInfo object of the assembly that contains the code that is currently executing.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static AssemblyInfo ExecutingAssembly { get; }
Public Shared ReadOnly Property ExecutingAssembly As AssemblyInfo
    Get
static member ExecutingAssembly : AssemblyInfo with get

GSF.Reflection.AssemblyInfo.get_ExecutingAssembly = function();

public:
static property AssemblyInfo^ ExecutingAssembly {
    AssemblyInfo^ get ();
}

Property Value

Type: AssemblyInfo
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.FullName Property

Grid Solutions Framework AssemblyInfoFullName Property
Gets the display name of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FullName { get; }
Public ReadOnly Property FullName As String
    Get
member FullName : string with get

function get_FullName();

public:
property String^ FullName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.GACLoaded Property

Grid Solutions Framework AssemblyInfoGACLoaded Property
Gets a boolean value indicating whether the Assembly was loaded from the global assembly cache.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool GACLoaded { get; }
Public ReadOnly Property GACLoaded As Boolean
    Get
member GACLoaded : bool with get

function get_GACLoaded();

public:
property bool GACLoaded {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Guid Property

Grid Solutions Framework AssemblyInfoGuid Property
Gets the GUID that is used as an ID if the Assembly is exposed to COM.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Guid { get; }
Public ReadOnly Property Guid As String
    Get
member Guid : string with get

function get_Guid();

public:
property String^ Guid {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.ImageRuntimeVersion Property

Grid Solutions Framework AssemblyInfoImageRuntimeVersion Property
Gets the string representing the version of the common language runtime (CLR) saved in the file containing the manifest.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ImageRuntimeVersion { get; }
Public ReadOnly Property ImageRuntimeVersion As String
    Get
member ImageRuntimeVersion : string with get

function get_ImageRuntimeVersion();

public:
property String^ ImageRuntimeVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.InformationalVersion Property

Grid Solutions Framework AssemblyInfoInformationalVersion Property
Gets the version information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string InformationalVersion { get; }
Public ReadOnly Property InformationalVersion As String
    Get
member InformationalVersion : string with get

function get_InformationalVersion();

public:
property String^ InformationalVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.KeyFile Property

Grid Solutions Framework AssemblyInfoKeyFile Property
Gets the name of the file containing the key pair used to generate a strong name for the attributed Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string KeyFile { get; }
Public ReadOnly Property KeyFile As String
    Get
member KeyFile : string with get

function get_KeyFile();

public:
property String^ KeyFile {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Location Property

Grid Solutions Framework AssemblyInfoLocation Property
Gets the path or UNC location of the loaded file that contains the manifest.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Location { get; }
Public ReadOnly Property Location As String
    Get
member Location : string with get

function get_Location();

public:
property String^ Location {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Name Property

Grid Solutions Framework AssemblyInfoName Property
Gets the simple, unencrypted name of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
member Name : string with get

function get_Name();

public:
property String^ Name {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Product Property

Grid Solutions Framework AssemblyInfoProduct Property
Gets the product name information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Product { get; }
Public ReadOnly Property Product As String
    Get
member Product : string with get

function get_Product();

public:
property String^ Product {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.RootNamespace Property

Grid Solutions Framework AssemblyInfoRootNamespace Property
Gets the root namespace of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string RootNamespace { get; }
Public ReadOnly Property RootNamespace As String
    Get
member RootNamespace : string with get

function get_RootNamespace();

public:
property String^ RootNamespace {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.SatelliteContractVersion Property

Grid Solutions Framework AssemblyInfoSatelliteContractVersion Property
Gets the assembly version used to instruct the System.Resources.ResourceManager to ask for a particular version of a satellite assembly to simplify updates of the main assembly of an application.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SatelliteContractVersion { get; }
Public ReadOnly Property SatelliteContractVersion As String
    Get
member SatelliteContractVersion : string with get

function get_SatelliteContractVersion();

public:
property String^ SatelliteContractVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Title Property

Grid Solutions Framework AssemblyInfoTitle Property
Gets the title information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Title { get; }
Public ReadOnly Property Title As String
    Get
member Title : string with get

function get_Title();

public:
property String^ Title {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Trademark Property

Grid Solutions Framework AssemblyInfoTrademark Property
Gets the trademark information of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Trademark { get; }
Public ReadOnly Property Trademark As String
    Get
member Trademark : string with get

function get_Trademark();

public:
property String^ Trademark {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.TypeLibVersion Property

Grid Solutions Framework AssemblyInfoTypeLibVersion Property
Gets the string representing the Assembly version number in MajorVersion.MinorVersion format.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string TypeLibVersion { get; }
Public ReadOnly Property TypeLibVersion As String
    Get
member TypeLibVersion : string with get

function get_TypeLibVersion();

public:
property String^ TypeLibVersion {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


AssemblyInfo.Version Property

Grid Solutions Framework AssemblyInfoVersion Property
Gets the major, minor, revision, and build numbers of the Assembly.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Version Version { get; }
Public ReadOnly Property Version As Version
    Get
member Version : Version with get

function get_Version();

public:
property Version^ Version {
    Version^ get ();
}

Property Value

Type: Version
See Also

Reference

AssemblyInfo Class
GSF.Reflection Namespace


MemberInfoExtensions Class

Grid Solutions Framework MemberInfoExtensions Class
Defines extensions methods related to MemberInfo objects and derived types (e.g., FieldInfo, PropertyInfo, MethodInfo, etc.)
Inheritance Hierarchy
SystemObject
GSF.ReflectionMemberInfoExtensions

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class MemberInfoExtensions
<ExtensionAttribute>
Public NotInheritable Class MemberInfoExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type MemberInfoExtensions =  class end
GSF.Reflection.MemberInfoExtensions = function();

Type.createClass(
    'GSF.Reflection.MemberInfoExtensions');
[ExtensionAttribute]
public ref class MemberInfoExtensions abstract sealed
Methods
Name | Description
TryGetAttributeTMemberInfo(TMemberInfo, Type, Attribute) | Attempts to get the specified attribute from a MemberInfo object, returning true if it does.
TryGetAttributeTMemberInfo, TAttribute(TMemberInfo, TAttribute) | Attempts to get the specified attribute from a MemberInfo object, returning true if it does.
TryGetAttributesTMemberInfo(TMemberInfo, Type, Attribute) | Attempts to get the specified attributes from a MemberInfo object, returning true if it does.
TryGetAttributesTMemberInfo, TAttribute(TMemberInfo, TAttribute) | Attempts to get the specified attributes from a MemberInfo object, returning true if it does.
Top
See Also

Reference

GSF.Reflection Namespace


MemberInfoExtensions Methods

Grid Solutions Framework MemberInfoExtensions Methods
Methods
Name | Description
TryGetAttributeTMemberInfo(TMemberInfo, Type, Attribute) | Attempts to get the specified attribute from a MemberInfo object, returning true if it does.
TryGetAttributeTMemberInfo, TAttribute(TMemberInfo, TAttribute) | Attempts to get the specified attribute from a MemberInfo object, returning true if it does.
TryGetAttributesTMemberInfo(TMemberInfo, Type, Attribute) | Attempts to get the specified attributes from a MemberInfo object, returning true if it does.
TryGetAttributesTMemberInfo, TAttribute(TMemberInfo, TAttribute) | Attempts to get the specified attributes from a MemberInfo object, returning true if it does.
Top
See Also

Reference

MemberInfoExtensions Class
GSF.Reflection Namespace


MemberInfoExtensions.TryGetAttribute Method

Grid Solutions Framework MemberInfoExtensionsTryGetAttribute Method
Overload List
Name | Description
TryGetAttributeTMemberInfo, TAttribute(TMemberInfo, TAttribute) | Attempts to get the specified attribute from a MemberInfo object, returning true if it does.
TryGetAttributeTMemberInfo(TMemberInfo, Type, Attribute) | Attempts to get the specified attribute from a MemberInfo object, returning true if it does.
Top
See Also

Reference

MemberInfoExtensions Class
GSF.Reflection Namespace


MemberInfoExtensions.TryGetAttribute(TMemberInfo, TAttribute) Method (TMemberInfo, TAttribute)

Grid Solutions Framework MemberInfoExtensionsTryGetAttributeTMemberInfo, TAttribute Method (TMemberInfo, TAttribute)
Attempts to get the specified attribute from a MemberInfo object, returning true if it does.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetAttribute<TMemberInfo, TAttribute>(
    this TMemberInfo member,
    out TAttribute attribute
)
where TMemberInfo : MemberInfo
where TAttribute : Attribute

<ExtensionAttribute>
Public Shared Function TryGetAttribute(Of TMemberInfo As MemberInfo, TAttribute As Attribute) (
    member As TMemberInfo,
    <OutAttribute> ByRef attribute As TAttribute
) As Boolean
static member TryGetAttribute :
        member : 'TMemberInfo *
        attribute : 'TAttribute byref -> bool  when 'TMemberInfo : MemberInfo when 'TAttribute : Attribute

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TMemberInfo, typename TAttribute>
where TMemberInfo : MemberInfo
where TAttribute : Attribute
static bool TryGetAttribute(
    TMemberInfo member,
    [OutAttribute] TAttribute% attribute
)

Parameters

member
Type: TMemberInfo
The MemberInfo object over which to search attributes.
attribute
Type: TAttribute
The Attribute that was found, if any.

Type Parameters

TMemberInfo
MemberInfo or derived type to get Attribute from.
TAttribute
Type of Attribute to attempt to retrieve.

Return Value

Type: Boolean
true if attribute was found; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If more than of the same type of attribute exists on the member, only the first one is returned.
See Also

Reference

MemberInfoExtensions Class
TryGetAttribute Overload
GSF.Reflection Namespace


MemberInfoExtensions.TryGetAttribute(TMemberInfo) Method (TMemberInfo, Type, Attribute)

Grid Solutions Framework MemberInfoExtensionsTryGetAttributeTMemberInfo Method (TMemberInfo, Type, Attribute)
Attempts to get the specified attribute from a MemberInfo object, returning true if it does.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetAttribute<TMemberInfo>(
    this TMemberInfo member,
    Type attributeType,
    out Attribute attribute
)
where TMemberInfo : MemberInfo

<ExtensionAttribute>
Public Shared Function TryGetAttribute(Of TMemberInfo As MemberInfo) (
    member As TMemberInfo,
    attributeType As Type,
    <OutAttribute> ByRef attribute As Attribute
) As Boolean
static member TryGetAttribute :
        member : 'TMemberInfo *
        attributeType : Type *
        attribute : Attribute byref -> bool  when 'TMemberInfo : MemberInfo

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TMemberInfo>
where TMemberInfo : MemberInfo
static bool TryGetAttribute(
    TMemberInfo member,
    Type^ attributeType,
    [OutAttribute] Attribute^% attribute
)

Parameters

member
Type: TMemberInfo
The MemberInfo object over which to search attributes.
attributeType
Type: SystemType
The actual type of the Attribute to look for.
attribute
Type: SystemAttribute
The Attribute that was found, if any.

Type Parameters

TMemberInfo
MemberInfo or derived type to get Attribute from.

Return Value

Type: Boolean
true if attribute was found; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If more than of the same type of attribute exists on the member, only the first one is returned.
See Also

Reference

MemberInfoExtensions Class
TryGetAttribute Overload
GSF.Reflection Namespace


MemberInfoExtensions.TryGetAttributes Method

Grid Solutions Framework MemberInfoExtensionsTryGetAttributes Method
Overload List
Name | Description
TryGetAttributesTMemberInfo, TAttribute(TMemberInfo, TAttribute) | Attempts to get the specified attributes from a MemberInfo object, returning true if it does.
TryGetAttributesTMemberInfo(TMemberInfo, Type, Attribute) | Attempts to get the specified attributes from a MemberInfo object, returning true if it does.
Top
See Also

Reference

MemberInfoExtensions Class
GSF.Reflection Namespace


MemberInfoExtensions.TryGetAttributes(TMemberInfo, TAttribute) Method (TMemberInfo, TAttribute[])

Grid Solutions Framework MemberInfoExtensionsTryGetAttributesTMemberInfo, TAttribute Method (TMemberInfo, TAttribute)
Attempts to get the specified attributes from a MemberInfo object, returning true if it does.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetAttributes<TMemberInfo, TAttribute>(
    this TMemberInfo member,
    out TAttribute[] attributes
)
where TMemberInfo : MemberInfo
where TAttribute : Attribute

<ExtensionAttribute>
Public Shared Function TryGetAttributes(Of TMemberInfo As MemberInfo, TAttribute As Attribute) (
    member As TMemberInfo,
    <OutAttribute> ByRef attributes As TAttribute()
) As Boolean
static member TryGetAttributes :
        member : 'TMemberInfo *
        attributes : 'TAttribute[] byref -> bool  when 'TMemberInfo : MemberInfo when 'TAttribute : Attribute

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TMemberInfo, typename TAttribute>
where TMemberInfo : MemberInfo
where TAttribute : Attribute
static bool TryGetAttributes(
    TMemberInfo member,
    [OutAttribute] array<TAttribute>^% attributes
)

Parameters

member
Type: TMemberInfo
The MemberInfo object over which to search attributes.
attributes
Type: TAttribute
The array of Attribute objects that were found, if any.

Type Parameters

TMemberInfo
MemberInfo or derived type to get Attribute from.
TAttribute
Type of Attribute to attempt to retrieve.

Return Value

Type: Boolean
true if attributes was found; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberInfoExtensions Class
TryGetAttributes Overload
GSF.Reflection Namespace


MemberInfoExtensions.TryGetAttributes(TMemberInfo) Method (TMemberInfo, Type, Attribute[])

Grid Solutions Framework MemberInfoExtensionsTryGetAttributesTMemberInfo Method (TMemberInfo, Type, Attribute)
Attempts to get the specified attributes from a MemberInfo object, returning true if it does.

Namespace: GSF.Reflection
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetAttributes<TMemberInfo>(
    this TMemberInfo member,
    Type attributeType,
    out Attribute[] attributes
)
where TMemberInfo : MemberInfo

<ExtensionAttribute>
Public Shared Function TryGetAttributes(Of TMemberInfo As MemberInfo) (
    member As TMemberInfo,
    attributeType As Type,
    <OutAttribute> ByRef attributes As Attribute()
) As Boolean
static member TryGetAttributes :
        member : 'TMemberInfo *
        attributeType : Type *
        attributes : Attribute[] byref -> bool  when 'TMemberInfo : MemberInfo

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename TMemberInfo>
where TMemberInfo : MemberInfo
static bool TryGetAttributes(
    TMemberInfo member,
    Type^ attributeType,
    [OutAttribute] array<Attribute^>^% attributes
)

Parameters

member
Type: TMemberInfo
The MemberInfo object over which to search attributes.
attributeType
Type: SystemType
The actual type of the Attribute objects to look for.
attributes
Type: SystemAttribute
The array of Attribute objects that were found, if any.

Type Parameters

TMemberInfo
MemberInfo or derived type to get Attribute from.

Return Value

Type: Boolean
true if attributes was found; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

MemberInfoExtensions Class
TryGetAttributes Overload
GSF.Reflection Namespace


GSF.Scheduling Namespace

Grid Solutions Framework GSF.Scheduling Namespace
Contains classes used to schedule operations using standard UNIX crontab syntax.
Classes
 | Class | Description
Public class | Schedule | Represents a schedule defined using UNIX crontab syntax.
 | ScheduleManager | Monitors multiple Schedule at an interval of one minute to check if they are due.
Public class | SchedulePart | Represents a part of the Schedule.
Enumerations
 | Enumeration | Description
Public enumeration | DateTimePart | Indicates the date/time element that a SchedulePart represents.
Public enumeration | SchedulePartTextSyntax | Indicates the syntax used in a SchedulePart for specifying its values.


DateTimePart Enumeration

Grid Solutions Framework DateTimePart Enumeration
Indicates the date/time element that a SchedulePart represents.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DateTimePart
Public Enumeration DateTimePart
type DateTimePart
GSF.Scheduling.DateTimePart = function();
GSF.Scheduling.DateTimePart.createEnum('GSF.Scheduling.DateTimePart', false);
public enum class DateTimePart
Members
Member name | Value | Description
Minute | 0 | SchedulePart represents minutes. Legal values are 0 through 59.
Hour | 1 | SchedulePart represents hours. Legal values are 0 through 23.
Day | 2 | SchedulePart represents day of month. Legal values are 1 through 31.
Month | 3 | SchedulePart represents months. Legal values are 1 through 12.
DayOfWeek | 4 | SchedulePart represents day of week. Legal values are 0 through 7 where 0 is Sunday.
Remarks
This enumeration specifically corresponds to the UNIX crontab date/time elements.
See Also

Reference

GSF.Scheduling Namespace


Schedule Class

Grid Solutions Framework Schedule Class
Represents a schedule defined using UNIX crontab syntax.
Inheritance Hierarchy
SystemObject
GSF.SchedulingSchedule

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Schedule
Public Class Schedule
type Schedule =  class end
GSF.Scheduling.Schedule = function();

Type.createClass(
    'GSF.Scheduling.Schedule');
public ref class Schedule

The Schedule type exposes the following members.

Constructors
 | Name | Description
Public method | Schedule | Initializes a new instance of the Schedule class.
Public method | Schedule(String) | Initializes a new instance of the Schedule class.
Public method | Schedule(String, String) | Initializes a new instance of the Schedule class.
Public method | Schedule(String, String, String) | Initializes a new instance of the Schedule class.
Public method | Schedule(String, String, String, Boolean) | Initializes a new instance of the Schedule class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Schedule is equal to the current Schedule. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for the Schedule. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDue | Checks whether the Schedule is due at the present system time.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of Schedule. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | DayPart | Gets the SchedulePart of the Schedule that represents day of month DateTimePart.
Public property | DaysOfWeekPart | Gets the SchedulePart of the Schedule that represents day of week DateTimePart.
Public property | Description | Gets or sets a description of the Schedule.
Public property | HourPart | Gets the SchedulePart of the Schedule that represents hour DateTimePart.
Public property | LastDueAt | Gets the DateTime when the Schedule was last due.
Public property | MinutePart | Gets the SchedulePart of the Schedule that represents minute DateTimePart.
Public property | MonthPart | Gets the SchedulePart of the Schedule that represents month DateTimePart.
Public property | Name | Gets or sets the name of the Schedule.
Public property | Rule | Gets or sets the rule of the Schedule defined in UNIX crontab syntax.
Public property | Status | Gets the current status of the Schedule.
Public property | UseLocalTime | Gets or sets a flag that determines whether the scheduler uses local time or UTC time for scheduling.
Top
Remarks

Operators:

There are several ways of specifying multiple date/time values in a field:

  • The comma (',') operator specifies a list of values, for example: "1,3,4,7,8"
  • The dash ('-') operator specifies a range of values, for example: "1-6", which is equivalent to "1,2,3,4,5,6"
  • The asterisk ('*') operator specifies all possible values for a field. For example, an asterisk in the hour time field would be equivalent to 'every hour' (subject to matching other specified fields).
  • The slash ('/') operator (called "step"), which can be used to skip a given number of values. For example, "*/3" in the hour time field is equivalent to "0,3,6,9,12,15,18,21". So "*" specifies 'every hour' but the "*/3" means only those hours divisible by 3.

Fields:

Copy
+---------------- minute (0 - 59)
|  +------------- hour (0 - 23)
|  |  +---------- day of month (1 - 31)
|  |  |  +------- month (1 - 12)
|  |  |  |  +---- day of week (0 - 7) (Sunday=0 or 7)
|  |  |  |  |
*  *  *  *  *

Each of the patterns from the first five fields may be either * (an asterisk), which matches all legal values, or a list of elements separated by commas.

See http://en.wikipedia.org/wiki/Cron for more information.

See Also

Reference

GSF.Scheduling Namespace
GSF.SchedulingSchedulePart
GSF.SchedulingScheduleManager


Schedule Constructor

Grid Solutions Framework Schedule Constructor
Overload List
 | Name | Description
Public method | Schedule | Initializes a new instance of the Schedule class.
Public method | Schedule(String) | Initializes a new instance of the Schedule class.
Public method | Schedule(String, String) | Initializes a new instance of the Schedule class.
Public method | Schedule(String, String, String) | Initializes a new instance of the Schedule class.
Public method | Schedule(String, String, String, Boolean) | Initializes a new instance of the Schedule class.
Top
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule Constructor

Grid Solutions Framework Schedule Constructor
Initializes a new instance of the Schedule class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schedule()
Public Sub New
new : unit -> Schedule
GSF.Scheduling.Schedule = function();
public:
Schedule()
See Also

Reference

Schedule Class
Schedule Overload
GSF.Scheduling Namespace


Schedule Constructor (String)

Grid Solutions Framework Schedule Constructor (String)
Initializes a new instance of the Schedule class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schedule(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> Schedule
GSF.Scheduling.Schedule = function(name);
public:
Schedule(
    String^ name
)

Parameters

name
Type: SystemString
Name of the schedule.
Remarks
Default Rule of '* * * * *' is used.
See Also

Reference

Schedule Class
Schedule Overload
GSF.Scheduling Namespace


Schedule Constructor (String, String)

Grid Solutions Framework Schedule Constructor (String, String)
Initializes a new instance of the Schedule class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schedule(
    string name,
    string rule
)
Public Sub New (
    name As String,
    rule As String
)
new :
        name : string *
        rule : string -> Schedule
GSF.Scheduling.Schedule = function(name, rule);
public:
Schedule(
    String^ name,
    String^ rule
)

Parameters

name
Type: SystemString
Name of the schedule.
rule
Type: SystemString
Rule formated in UNIX crontab syntax.
See Also

Reference

Schedule Class
Schedule Overload
GSF.Scheduling Namespace


Schedule Constructor (String, String, String)

Grid Solutions Framework Schedule Constructor (String, String, String)
Initializes a new instance of the Schedule class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schedule(
    string name,
    string rule,
    string description
)
Public Sub New (
    name As String,
    rule As String,
    description As String
)
new :
        name : string *
        rule : string *
        description : string -> Schedule
GSF.Scheduling.Schedule = function(name, rule, description);
public:
Schedule(
    String^ name,
    String^ rule,
    String^ description
)

Parameters

name
Type: SystemString
Name of the schedule.
rule
Type: SystemString
Rule formated in UNIX crontab syntax.
description
Type: SystemString
Description of defined schedule.
See Also

Reference

Schedule Class
Schedule Overload
GSF.Scheduling Namespace


Schedule Constructor (String, String, String, Boolean)

Grid Solutions Framework Schedule Constructor (String, String, String, Boolean)
Initializes a new instance of the Schedule class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schedule(
    string name,
    string rule,
    string description,
    bool useLocalTime
)
Public Sub New (
    name As String,
    rule As String,
    description As String,
    useLocalTime As Boolean
)
new :
        name : string *
        rule : string *
        description : string *
        useLocalTime : bool -> Schedule
GSF.Scheduling.Schedule = function(name, rule, description, useLocalTime);
public:
Schedule(
    String^ name,
    String^ rule,
    String^ description,
    bool useLocalTime
)

Parameters

name
Type: SystemString
Name of the schedule.
rule
Type: SystemString
Rule formated in UNIX crontab syntax.
description
Type: SystemString
Description of defined schedule.
useLocalTime
Type: SystemBoolean
Flag that determines whether to use local time for schedule.
See Also

Reference

Schedule Class
Schedule Overload
GSF.Scheduling Namespace


Schedule Methods

Grid Solutions Framework Schedule Methods

The Schedule type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Schedule is equal to the current Schedule. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash code for the Schedule. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDue | Checks whether the Schedule is due at the present system time.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Gets the string representation of Schedule. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.Equals Method

Grid Solutions Framework ScheduleEquals Method
Determines whether the specified Schedule is equal to the current Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The Schedule to compare with the current Schedule.

Return Value

Type: Boolean
true if the specified Schedule is equal to the current Schedule; otherwise false
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.GetHashCode Method

Grid Solutions Framework ScheduleGetHashCode Method
Gets a hash code for the Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
An Int32 based hashcode.
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.IsDue Method

Grid Solutions Framework ScheduleIsDue Method
Checks whether the Schedule is due at the present system time.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDue()
Public Function IsDue As Boolean
member IsDue : unit -> bool

function IsDue();
public:
bool IsDue()

Return Value

Type: Boolean
true if the Schedule is due at the present system time; otherwise false.
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.ToString Method

Grid Solutions Framework ScheduleToString Method
Gets the string representation of Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
String representation of Schedule.
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule Properties

Grid Solutions Framework Schedule Properties

The Schedule type exposes the following members.

Properties
 | Name | Description
Public property | DayPart | Gets the SchedulePart of the Schedule that represents day of month DateTimePart.
Public property | DaysOfWeekPart | Gets the SchedulePart of the Schedule that represents day of week DateTimePart.
Public property | Description | Gets or sets a description of the Schedule.
Public property | HourPart | Gets the SchedulePart of the Schedule that represents hour DateTimePart.
Public property | LastDueAt | Gets the DateTime when the Schedule was last due.
Public property | MinutePart | Gets the SchedulePart of the Schedule that represents minute DateTimePart.
Public property | MonthPart | Gets the SchedulePart of the Schedule that represents month DateTimePart.
Public property | Name | Gets or sets the name of the Schedule.
Public property | Rule | Gets or sets the rule of the Schedule defined in UNIX crontab syntax.
Public property | Status | Gets the current status of the Schedule.
Public property | UseLocalTime | Gets or sets a flag that determines whether the scheduler uses local time or UTC time for scheduling.
Top
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.DayPart Property

Grid Solutions Framework ScheduleDayPart Property
Gets the SchedulePart of the Schedule that represents day of month DateTimePart.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public SchedulePart DayPart { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property DayPart As SchedulePart
    Get
[<BrowsableAttribute(false)>]
member DayPart : SchedulePart with get

function get_DayPart();

public:
[BrowsableAttribute(false)]
property SchedulePart^ DayPart {
    SchedulePart^ get ();
}

Property Value

Type: SchedulePart
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.DaysOfWeekPart Property

Grid Solutions Framework ScheduleDaysOfWeekPart Property
Gets the SchedulePart of the Schedule that represents day of week DateTimePart.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public SchedulePart DaysOfWeekPart { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property DaysOfWeekPart As SchedulePart
    Get
[<BrowsableAttribute(false)>]
member DaysOfWeekPart : SchedulePart with get

function get_DaysOfWeekPart();

public:
[BrowsableAttribute(false)]
property SchedulePart^ DaysOfWeekPart {
    SchedulePart^ get ();
}

Property Value

Type: SchedulePart
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.Description Property

Grid Solutions Framework ScheduleDescription Property
Gets or sets a description of the Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
member Description : string with get, set

function get_Description();
function set_Description(value);
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
A default description is created automatically when the Rule is set.
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.HourPart Property

Grid Solutions Framework ScheduleHourPart Property
Gets the SchedulePart of the Schedule that represents hour DateTimePart.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public SchedulePart HourPart { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property HourPart As SchedulePart
    Get
[<BrowsableAttribute(false)>]
member HourPart : SchedulePart with get

function get_HourPart();

public:
[BrowsableAttribute(false)]
property SchedulePart^ HourPart {
    SchedulePart^ get ();
}

Property Value

Type: SchedulePart
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.LastDueAt Property

Grid Solutions Framework ScheduleLastDueAt Property
Gets the DateTime when the Schedule was last due.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public DateTime LastDueAt { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property LastDueAt As DateTime
    Get
[<BrowsableAttribute(false)>]
member LastDueAt : DateTime with get

function get_LastDueAt();

public:
[BrowsableAttribute(false)]
property DateTime LastDueAt {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.MinutePart Property

Grid Solutions Framework ScheduleMinutePart Property
Gets the SchedulePart of the Schedule that represents minute DateTimePart.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public SchedulePart MinutePart { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property MinutePart As SchedulePart
    Get
[<BrowsableAttribute(false)>]
member MinutePart : SchedulePart with get

function get_MinutePart();

public:
[BrowsableAttribute(false)]
property SchedulePart^ MinutePart {
    SchedulePart^ get ();
}

Property Value

Type: SchedulePart
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.MonthPart Property

Grid Solutions Framework ScheduleMonthPart Property
Gets the SchedulePart of the Schedule that represents month DateTimePart.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public SchedulePart MonthPart { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property MonthPart As SchedulePart
    Get
[<BrowsableAttribute(false)>]
member MonthPart : SchedulePart with get

function get_MonthPart();

public:
[BrowsableAttribute(false)]
property SchedulePart^ MonthPart {
    SchedulePart^ get ();
}

Property Value

Type: SchedulePart
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.Name Property

Grid Solutions Framework ScheduleName Property
Gets or sets the name of the Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.Rule Property

Grid Solutions Framework ScheduleRule Property
Gets or sets the rule of the Schedule defined in UNIX crontab syntax.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Rule { get; set; }
Public Property Rule As String
    Get
    Set
member Rule : string with get, set

function get_Rule();
function set_Rule(value);
public:
property String^ Rule {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
ArgumentException | The number of SchedulePart in the rule is not exactly 5.
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.Status Property

Grid Solutions Framework ScheduleStatus Property
Gets the current status of the Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Status { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
member Status : string with get

function get_Status();

public:
[BrowsableAttribute(false)]
property String^ Status {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


Schedule.UseLocalTime Property

Grid Solutions Framework ScheduleUseLocalTime Property
Gets or sets a flag that determines whether the scheduler uses local time or UTC time for scheduling.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseLocalTime { get; set; }
Public Property UseLocalTime As Boolean
    Get
    Set
member UseLocalTime : bool with get, set

function get_UseLocalTime();
function set_UseLocalTime(value);
public:
property bool UseLocalTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

Schedule Class
GSF.Scheduling Namespace


ScheduleManager Class

Grid Solutions Framework ScheduleManager Class
Monitors multiple Schedule at an interval of one minute to check if they are due.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.SchedulingScheduleManager

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ScheduleManager))]
public class ScheduleManager : Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings
<ToolboxBitmapAttribute(GetType(ScheduleManager))>
Public Class ScheduleManager
    Inherits Component
    Implements ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings
[<ToolboxBitmapAttribute(typeof(ScheduleManager))>]
type ScheduleManager =
    class
        inherit Component
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Scheduling.ScheduleManager = function();

Type.createClass(
    'GSF.Scheduling.ScheduleManager',
    Component,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(ScheduleManager))]
public ref class ScheduleManager : public Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings

The ScheduleManager type exposes the following members.

Constructors
 | Name | Description
Public method | ScheduleManager | Initializes a new instance of the ScheduleManager class.
Public method | ScheduleManager(IContainer) | Initializes a new instance of the ScheduleManager class.
Top
Methods
 | Name | Description
Public method | AddSchedule(String, String) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, Boolean) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, String) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, String, Boolean) | Attempts to add a new Schedule.
Public method | BeginInit | Performs necessary operations before the ScheduleManager object properties are initialized.
Public method | CheckAllSchedules | Checks all of the Schedules to determine if they are due.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ScheduleManager object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ScheduleManager object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindSchedule | Searches for the Schedule with the specified name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ScheduleManager object.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ScheduleManager object from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnScheduleDue | Raises the ScheduleDue event.
Protected method | OnScheduleDueCheck | Raises the ScheduleDueCheck event.
Protected method | OnStarted | Raises the Started event.
Protected method | OnStarting | Raises the Starting event.
Public method | RemoveSchedule | Attempts to remove a Schedule with the specified name if one exists.
Public method | SaveSettings | Saves settings for the ScheduleManager object to the config file if the PersistSettings property is set to true.
Public method | Start | Starts the ScheduleManager asynchronously if not running.
Public method | Stop | Stops the ScheduleManager if running.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ScheduleManager object is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsRunning | Gets a boolean value that indicates whether the ScheduleManager is running.
Public property | Name | Gets the unique identifier of the ScheduleManager object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ScheduleManager object are to be saved to the config file.
Public property | Schedules | Gets a list of all Schedule monitored by the ScheduleManager object.
Public property | SettingsCategory | Gets or sets the category under which the settings of ScheduleManager object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the ScheduleManager object.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ScheduleDue | Occurs asynchronously when a Schedule is due according to the rule specified for it.
Public event | ScheduleDueCheck | Occurs when the a particular Schedule is being checked to see if it is due.
Public event | Started | Occurs when the ScheduleManager has started at the top of the minute.
Public event | Starting | Occurs while the ScheduleManager is waiting to start at the top of the minute.
Top
Examples
This example shows how to use the ScheduleManager component:
Copy
using System;
using GSF;
using GSF.Scheduling;

class Program
{
    static void Main(string[] args)
    {
        ScheduleManager scheduler = new ScheduleManager();
        scheduler.Initialize();
        // Add event handlers.
        scheduler.Starting += scheduler_Starting;
        scheduler.Started += scheduler_Started;
        scheduler.ScheduleDue += scheduler_ScheduleDue;
        // Add test schedules.
        scheduler.AddSchedule("Run.Notepad", "* * * * *");
        scheduler.AddSchedule("Run.Explorer", "* * * * *");
        // Start the scheduler.
        scheduler.Start();

        Console.ReadLine();
    }

    static void scheduler_Started(object sender, EventArgs e)
    {
        Console.WriteLine("Scheduler has started successfully.");
    }

    static void scheduler_Starting(object sender, EventArgs e)
    {
        Console.WriteLine("Scheduler is waiting to be started.");
    }

    static void scheduler_ScheduleDue(object sender, EventArgs<Schedule> e)
    {
        Console.WriteLine(string.Format("{0} schedule is due for processing.", e.Argument.Name));
    }
}
See Also

Reference

GSF.Scheduling Namespace
GSF.SchedulingSchedule


ScheduleManager Constructor

Grid Solutions Framework ScheduleManager Constructor
Overload List
 | Name | Description
Public method | ScheduleManager | Initializes a new instance of the ScheduleManager class.
Public method | ScheduleManager(IContainer) | Initializes a new instance of the ScheduleManager class.
Top
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager Constructor

Grid Solutions Framework ScheduleManager Constructor
Initializes a new instance of the ScheduleManager class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ScheduleManager()
Public Sub New
new : unit -> ScheduleManager
GSF.Scheduling.ScheduleManager = function();
public:
ScheduleManager()
See Also

Reference

ScheduleManager Class
ScheduleManager Overload
GSF.Scheduling Namespace


ScheduleManager Constructor (IContainer)

Grid Solutions Framework ScheduleManager Constructor (IContainer)
Initializes a new instance of the ScheduleManager class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ScheduleManager(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ScheduleManager
GSF.Scheduling.ScheduleManager = function(container);
public:
ScheduleManager(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the ScheduleManager.
See Also

Reference

ScheduleManager Class
ScheduleManager Overload
GSF.Scheduling Namespace


ScheduleManager Fields

Grid Solutions Framework ScheduleManager Fields

The ScheduleManager type exposes the following members.

Fields
Name | Description
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.DefaultPersistSettings Field

Grid Solutions Framework ScheduleManagerDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.Scheduling.ScheduleManager.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.DefaultSettingsCategory Field

Grid Solutions Framework ScheduleManagerDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.Scheduling.ScheduleManager.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager Methods

Grid Solutions Framework ScheduleManager Methods

The ScheduleManager type exposes the following members.

Methods
 | Name | Description
Public method | AddSchedule(String, String) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, Boolean) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, String) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, String, Boolean) | Attempts to add a new Schedule.
Public method | BeginInit | Performs necessary operations before the ScheduleManager object properties are initialized.
Public method | CheckAllSchedules | Checks all of the Schedules to determine if they are due.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ScheduleManager object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ScheduleManager object properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindSchedule | Searches for the Schedule with the specified name.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ScheduleManager object.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ScheduleManager object from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnScheduleDue | Raises the ScheduleDue event.
Protected method | OnScheduleDueCheck | Raises the ScheduleDueCheck event.
Protected method | OnStarted | Raises the Started event.
Protected method | OnStarting | Raises the Starting event.
Public method | RemoveSchedule | Attempts to remove a Schedule with the specified name if one exists.
Public method | SaveSettings | Saves settings for the ScheduleManager object to the config file if the PersistSettings property is set to true.
Public method | Start | Starts the ScheduleManager asynchronously if not running.
Public method | Stop | Stops the ScheduleManager if running.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.AddSchedule Method

Grid Solutions Framework ScheduleManagerAddSchedule Method
Overload List
 | Name | Description
Public method | AddSchedule(String, String) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, Boolean) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, String) | Attempts to add a new Schedule.
Public method | AddSchedule(String, String, String, Boolean) | Attempts to add a new Schedule.
Top
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.AddSchedule Method (String, String)

Grid Solutions Framework ScheduleManagerAddSchedule Method (String, String)
Attempts to add a new Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddSchedule(
    string scheduleName,
    string scheduleRule
)
Public Function AddSchedule (
    scheduleName As String,
    scheduleRule As String
) As Boolean
member AddSchedule :
        scheduleName : string *
        scheduleRule : string -> bool

function AddSchedule(scheduleName, scheduleRule);
public:
bool AddSchedule(
    String^ scheduleName,
    String^ scheduleRule
)

Parameters

scheduleName
Type: SystemString
Name of the new Schedule.
scheduleRule
Type: SystemString
Rule of the new Schedule.

Return Value

Type: Boolean
true if a new Schedule was added or an existing one was updated; otherwise false.
See Also

Reference

ScheduleManager Class
AddSchedule Overload
GSF.Scheduling Namespace


ScheduleManager.AddSchedule Method (String, String, Boolean)

Grid Solutions Framework ScheduleManagerAddSchedule Method (String, String, Boolean)
Attempts to add a new Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddSchedule(
    string scheduleName,
    string scheduleRule,
    bool updateExisting
)
Public Function AddSchedule (
    scheduleName As String,
    scheduleRule As String,
    updateExisting As Boolean
) As Boolean
member AddSchedule :
        scheduleName : string *
        scheduleRule : string *
        updateExisting : bool -> bool

function AddSchedule(scheduleName, scheduleRule, updateExisting);
public:
bool AddSchedule(
    String^ scheduleName,
    String^ scheduleRule,
    bool updateExisting
)

Parameters

scheduleName
Type: SystemString
Name of the new Schedule.
scheduleRule
Type: SystemString
Rule of the new Schedule.
updateExisting
Type: SystemBoolean
true to update existing Schedule with the specified scheduleName; otherwise false.

Return Value

Type: Boolean
true if a new Schedule was added or an existing one was updated; otherwise false.
See Also

Reference

ScheduleManager Class
AddSchedule Overload
GSF.Scheduling Namespace


ScheduleManager.AddSchedule Method (String, String, String)

Grid Solutions Framework ScheduleManagerAddSchedule Method (String, String, String)
Attempts to add a new Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddSchedule(
    string scheduleName,
    string scheduleRule,
    string scheduleDescription
)
Public Function AddSchedule (
    scheduleName As String,
    scheduleRule As String,
    scheduleDescription As String
) As Boolean
member AddSchedule :
        scheduleName : string *
        scheduleRule : string *
        scheduleDescription : string -> bool

function AddSchedule(scheduleName, scheduleRule, scheduleDescription);
public:
bool AddSchedule(
    String^ scheduleName,
    String^ scheduleRule,
    String^ scheduleDescription
)

Parameters

scheduleName
Type: SystemString
Name of the new Schedule.
scheduleRule
Type: SystemString
Rule of the new Schedule.
scheduleDescription
Type: SystemString
Description of the new Schedule.

Return Value

Type: Boolean
true if a new Schedule was added; otherwise false.
See Also

Reference

ScheduleManager Class
AddSchedule Overload
GSF.Scheduling Namespace


ScheduleManager.AddSchedule Method (String, String, String, Boolean)

Grid Solutions Framework ScheduleManagerAddSchedule Method (String, String, String, Boolean)
Attempts to add a new Schedule.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddSchedule(
    string scheduleName,
    string scheduleRule,
    string scheduleDescription,
    bool updateExisting
)
Public Function AddSchedule (
    scheduleName As String,
    scheduleRule As String,
    scheduleDescription As String,
    updateExisting As Boolean
) As Boolean
member AddSchedule :
        scheduleName : string *
        scheduleRule : string *
        scheduleDescription : string *
        updateExisting : bool -> bool

function AddSchedule(scheduleName, scheduleRule, scheduleDescription, updateExisting);
public:
bool AddSchedule(
    String^ scheduleName,
    String^ scheduleRule,
    String^ scheduleDescription,
    bool updateExisting
)

Parameters

scheduleName
Type: SystemString
Name of the new Schedule.
scheduleRule
Type: SystemString
Rule of the new Schedule.
scheduleDescription
Type: SystemString
Description of the new Schedule.
updateExisting
Type: SystemBoolean
true to update existing Schedule with the specified scheduleName; otherwise false.

Return Value

Type: Boolean
true if a new Schedule was added or an existing one was updated; otherwise false.
See Also

Reference

ScheduleManager Class
AddSchedule Overload
GSF.Scheduling Namespace


ScheduleManager.BeginInit Method

Grid Solutions Framework ScheduleManagerBeginInit Method
Performs necessary operations before the ScheduleManager object properties are initialized.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the ScheduleManager object is consumed through the designer surface of the IDE.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.CheckAllSchedules Method

Grid Solutions Framework ScheduleManagerCheckAllSchedules Method
Checks all of the Schedules to determine if they are due.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CheckAllSchedules()
Public Sub CheckAllSchedules
member CheckAllSchedules : unit -> unit

function CheckAllSchedules();
public:
void CheckAllSchedules()
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Dispose Method

Grid Solutions Framework ScheduleManagerDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ScheduleManager object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Dispose Method (Boolean)

Grid Solutions Framework ScheduleManagerDispose Method (Boolean)
Releases the unmanaged resources used by the ScheduleManager object and optionally releases the managed resources.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ScheduleManager Class
Dispose Overload
GSF.Scheduling Namespace


ScheduleManager.EndInit Method

Grid Solutions Framework ScheduleManagerEndInit Method
Performs necessary operations after the ScheduleManager object properties are initialized.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the ScheduleManager object is consumed through the designer surface of the IDE.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.FindSchedule Method

Grid Solutions Framework ScheduleManagerFindSchedule Method
Searches for the Schedule with the specified name.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Schedule FindSchedule(
    string scheduleName
)
Public Function FindSchedule (
    scheduleName As String
) As Schedule
member FindSchedule :
        scheduleName : string -> Schedule

function FindSchedule(scheduleName);
public:
Schedule^ FindSchedule(
    String^ scheduleName
)

Parameters

scheduleName
Type: SystemString
Name of the Schedule to be obtained.

Return Value

Type: Schedule
Schedule object if a match is found; otherwise null.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Initialize Method

Grid Solutions Framework ScheduleManagerInitialize Method
Initializes the ScheduleManager object.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the ScheduleManager object is not consumed through the designer surface of the IDE.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.LoadSettings Method

Grid Solutions Framework ScheduleManagerLoadSettings Method
Loads saved settings for the ScheduleManager object from the config file if the PersistSettings property is set to true.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.OnScheduleDue Method

Grid Solutions Framework ScheduleManagerOnScheduleDue Method
Raises the ScheduleDue event.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnScheduleDue(
    Schedule schedule
)
Protected Overridable Sub OnScheduleDue (
    schedule As Schedule
)
abstract OnScheduleDue :
        schedule : Schedule -> unit
override OnScheduleDue :
        schedule : Schedule -> unit
function OnScheduleDue(schedule);
protected:
virtual void OnScheduleDue(
    Schedule^ schedule
)

Parameters

schedule
Type: GSF.SchedulingSchedule
Schedule to send to ScheduleDue event.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.OnScheduleDueCheck Method

Grid Solutions Framework ScheduleManagerOnScheduleDueCheck Method
Raises the ScheduleDueCheck event.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnScheduleDueCheck(
    EventArgs<Schedule> e
)
Protected Overridable Sub OnScheduleDueCheck (
    e As EventArgs(Of Schedule)
)
abstract OnScheduleDueCheck :
        e : EventArgs<Schedule> -> unit
override OnScheduleDueCheck :
        e : EventArgs<Schedule> -> unit
function OnScheduleDueCheck(e);
protected:
virtual void OnScheduleDueCheck(
    EventArgs<Schedule^>^ e
)

Parameters

e
Type: GSFEventArgs Schedule
Event data.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.OnStarted Method

Grid Solutions Framework ScheduleManagerOnStarted Method
Raises the Started event.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStarted()
Protected Overridable Sub OnStarted
abstract OnStarted : unit -> unit
override OnStarted : unit -> unit
function OnStarted();
protected:
virtual void OnStarted()
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.OnStarting Method

Grid Solutions Framework ScheduleManagerOnStarting Method
Raises the Starting event.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStarting()
Protected Overridable Sub OnStarting
abstract OnStarting : unit -> unit
override OnStarting : unit -> unit
function OnStarting();
protected:
virtual void OnStarting()
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.RemoveSchedule Method

Grid Solutions Framework ScheduleManagerRemoveSchedule Method
Attempts to remove a Schedule with the specified name if one exists.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RemoveSchedule(
    string scheduleName
)
Public Function RemoveSchedule (
    scheduleName As String
) As Boolean
member RemoveSchedule :
        scheduleName : string -> bool

function RemoveSchedule(scheduleName);
public:
bool RemoveSchedule(
    String^ scheduleName
)

Parameters

scheduleName
Type: SystemString
Name of the Schedule to be removed.

Return Value

Type: Boolean
true if the Schedule was removed; otherwise false.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.SaveSettings Method

Grid Solutions Framework ScheduleManagerSaveSettings Method
Saves settings for the ScheduleManager object to the config file if the PersistSettings property is set to true.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Start Method

Grid Solutions Framework ScheduleManagerStart Method
Starts the ScheduleManager asynchronously if not running.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start()
Public Sub Start
member Start : unit -> unit

function Start();
public:
void Start()
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Stop Method

Grid Solutions Framework ScheduleManagerStop Method
Stops the ScheduleManager if running.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Stop()
Public Sub Stop
member Stop : unit -> unit

function Stop();
public:
void Stop()
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager Properties

Grid Solutions Framework ScheduleManager Properties

The ScheduleManager type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ScheduleManager object is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsRunning | Gets a boolean value that indicates whether the ScheduleManager is running.
Public property | Name | Gets the unique identifier of the ScheduleManager object.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ScheduleManager object are to be saved to the config file.
Public property | Schedules | Gets a list of all Schedule monitored by the ScheduleManager object.
Public property | SettingsCategory | Gets or sets the category under which the settings of ScheduleManager object are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the ScheduleManager object.
Top
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Enabled Property

Grid Solutions Framework ScheduleManagerEnabled Property
Gets or sets a boolean value that indicates whether the ScheduleManager object is currently enabled.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool Enabled { get; set; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Property Enabled As Boolean
    Get
    Set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Enabled : bool with get, set
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Enabled property is not be set by user-code directly.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.IsDisposed Property

Grid Solutions Framework ScheduleManagerIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool IsDisposed { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract IsDisposed : bool with get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.IsRunning Property

Grid Solutions Framework ScheduleManagerIsRunning Property
Gets a boolean value that indicates whether the ScheduleManager is running.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public bool IsRunning { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property IsRunning As Boolean
    Get
[<BrowsableAttribute(false)>]
member IsRunning : bool with get

function get_IsRunning();

public:
[BrowsableAttribute(false)]
property bool IsRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Name Property

Grid Solutions Framework ScheduleManagerName Property
Gets the unique identifier of the ScheduleManager object.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.PersistSettings Property

Grid Solutions Framework ScheduleManagerPersistSettings Property
Gets or sets a boolean value that indicates whether the settings of ScheduleManager object are to be saved to the config file.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Schedules Property

Grid Solutions Framework ScheduleManagerSchedules Property
Gets a list of all Schedule monitored by the ScheduleManager object.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public List<Schedule> Schedules { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property Schedules As List(Of Schedule)
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>]
member Schedules : List<Schedule> with get

function get_Schedules();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
property List<Schedule^>^ Schedules {
    List<Schedule^>^ get ();
}

Property Value

Type: List Schedule
Remarks
Thread-safety Warning: Due to the asynchronous nature of ScheduleManager, a lock must be obtained on Schedules before accessing it.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.SettingsCategory Property

Grid Solutions Framework ScheduleManagerSettingsCategory Property
Gets or sets the category under which the settings of ScheduleManager object are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("ScheduleManager")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("ScheduleManager")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("ScheduleManager")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("ScheduleManager")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"ScheduleManager")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is null or empty string.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Status Property

Grid Solutions Framework ScheduleManagerStatus Property
Gets the descriptive status of the ScheduleManager object.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Status { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager Events

Grid Solutions Framework ScheduleManager Events

The ScheduleManager type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ScheduleDue | Occurs asynchronously when a Schedule is due according to the rule specified for it.
Public event | ScheduleDueCheck | Occurs when the a particular Schedule is being checked to see if it is due.
Public event | Started | Occurs when the ScheduleManager has started at the top of the minute.
Public event | Starting | Occurs while the ScheduleManager is waiting to start at the top of the minute.
Top
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.ScheduleDue Event

Grid Solutions Framework ScheduleManagerScheduleDue Event
Occurs asynchronously when a Schedule is due according to the rule specified for it.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Schedule>> ScheduleDue
Public Event ScheduleDue As EventHandler(Of EventArgs(Of Schedule))
member ScheduleDue : IEvent<EventHandler<EventArgs<Schedule>>,
    EventArgs<Schedule>>

function add_ScheduleDue(value);
function remove_ScheduleDue(value);
public:
 event EventHandler<EventArgs<Schedule^>^>^ ScheduleDue {
    void add (EventHandler<EventArgs<Schedule^>^>^ value);
    void remove (EventHandler<EventArgs<Schedule^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Schedule
Remarks
Argument is the Schedule that is due.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.ScheduleDueCheck Event

Grid Solutions Framework ScheduleManagerScheduleDueCheck Event
Occurs when the a particular Schedule is being checked to see if it is due.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Schedule>> ScheduleDueCheck
Public Event ScheduleDueCheck As EventHandler(Of EventArgs(Of Schedule))
member ScheduleDueCheck : IEvent<EventHandler<EventArgs<Schedule>>,
    EventArgs<Schedule>>

function add_ScheduleDueCheck(value);
function remove_ScheduleDueCheck(value);
public:
 event EventHandler<EventArgs<Schedule^>^>^ ScheduleDueCheck {
    void add (EventHandler<EventArgs<Schedule^>^>^ value);
    void remove (EventHandler<EventArgs<Schedule^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Schedule
Remarks
Argument is the Schedule that is being checked to see if it is due.
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Started Event

Grid Solutions Framework ScheduleManagerStarted Event
Occurs when the ScheduleManager has started at the top of the minute.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Started
Public Event Started As EventHandler
member Started : IEvent<EventHandler,
    EventArgs>

function add_Started(value);
function remove_Started(value);
public:
 event EventHandler^ Started {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


ScheduleManager.Starting Event

Grid Solutions Framework ScheduleManagerStarting Event
Occurs while the ScheduleManager is waiting to start at the top of the minute.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Starting
Public Event Starting As EventHandler
member Starting : IEvent<EventHandler,
    EventArgs>

function add_Starting(value);
function remove_Starting(value);
public:
 event EventHandler^ Starting {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScheduleManager Class
GSF.Scheduling Namespace


SchedulePart Class

Grid Solutions Framework SchedulePart Class
Represents a part of the Schedule.
Inheritance Hierarchy
SystemObject
GSF.SchedulingSchedulePart

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SchedulePart
Public Class SchedulePart
type SchedulePart =  class end
GSF.Scheduling.SchedulePart = function();

Type.createClass(
    'GSF.Scheduling.SchedulePart');
public ref class SchedulePart

The SchedulePart type exposes the following members.

Constructors
 | Name | Description
Public method | SchedulePart | Initializes a new instance of the SchedulePart class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Determines if the Values for the DateTimePart that the SchedulePart object represents matches the specified dateTime.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | DateTimePart | Gets the DateTimePart that the SchedulePart object represents.
Public property | Description | Gets a meaningful description of the SchedulePart object.
Public property | Values | Gets the list of values for the SchedulePart object specified using ValueText.
Public property | ValueText | Gets the text used to specify the values for the SchedulePart object.
Public property | ValueTextSyntax | Gets the SchedulePartTextSyntax used in the ValueText for specifying the values of the SchedulePart object.
Top
See Also

Reference

GSF.Scheduling Namespace
GSF.SchedulingSchedule


SchedulePart Constructor

Grid Solutions Framework SchedulePart Constructor
Initializes a new instance of the SchedulePart class.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SchedulePart(
    string valueText,
    DateTimePart dateTimePart
)
Public Sub New (
    valueText As String,
    dateTimePart As DateTimePart
)
new :
        valueText : string *
        dateTimePart : DateTimePart -> SchedulePart
GSF.Scheduling.SchedulePart = function(valueText, dateTimePart);
public:
SchedulePart(
    String^ valueText,
    DateTimePart dateTimePart
)

Parameters

valueText
Type: SystemString
The text that specifies the values for the SchedulePart object.
dateTimePart
Type: GSF.SchedulingDateTimePart
The DateTimePart that the SchedulePart object represents.
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart Methods

Grid Solutions Framework SchedulePart Methods

The SchedulePart type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Matches | Determines if the Values for the DateTimePart that the SchedulePart object represents matches the specified dateTime.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart.Matches Method

Grid Solutions Framework SchedulePartMatches Method
Determines if the Values for the DateTimePart that the SchedulePart object represents matches the specified dateTime.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Matches(
    DateTime dateTime
)
Public Function Matches (
    dateTime As DateTime
) As Boolean
member Matches :
        dateTime : DateTime -> bool

function Matches(dateTime);
public:
bool Matches(
    DateTime dateTime
)

Parameters

dateTime
Type: SystemDateTime
The DateTime against which the Values are to be matches.

Return Value

Type: Boolean
true if one of the Values matches the dateTime; otherwise false.
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart Properties

Grid Solutions Framework SchedulePart Properties

The SchedulePart type exposes the following members.

Properties
 | Name | Description
Public property | DateTimePart | Gets the DateTimePart that the SchedulePart object represents.
Public property | Description | Gets a meaningful description of the SchedulePart object.
Public property | Values | Gets the list of values for the SchedulePart object specified using ValueText.
Public property | ValueText | Gets the text used to specify the values for the SchedulePart object.
Public property | ValueTextSyntax | Gets the SchedulePartTextSyntax used in the ValueText for specifying the values of the SchedulePart object.
Top
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart.DateTimePart Property

Grid Solutions Framework SchedulePartDateTimePart Property
Gets the DateTimePart that the SchedulePart object represents.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTimePart DateTimePart { get; }
Public ReadOnly Property DateTimePart As DateTimePart
    Get
member DateTimePart : DateTimePart with get

function get_DateTimePart();

public:
property DateTimePart DateTimePart {
    DateTimePart get ();
}

Property Value

Type: DateTimePart
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart.Description Property

Grid Solutions Framework SchedulePartDescription Property
Gets a meaningful description of the SchedulePart object.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
member Description : string with get

function get_Description();

public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart.Values Property

Grid Solutions Framework SchedulePartValues Property
Gets the list of values for the SchedulePart object specified using ValueText.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<int> Values { get; }
Public ReadOnly Property Values As List(Of Integer)
    Get
member Values : List<int> with get

function get_Values();

public:
property List<int>^ Values {
    List<int>^ get ();
}

Property Value

Type: List Int32
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart.ValueText Property

Grid Solutions Framework SchedulePartValueText Property
Gets the text used to specify the values for the SchedulePart object.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ValueText { get; }
Public ReadOnly Property ValueText As String
    Get
member ValueText : string with get

function get_ValueText();

public:
property String^ ValueText {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePart.ValueTextSyntax Property

Grid Solutions Framework SchedulePartValueTextSyntax Property
Gets the SchedulePartTextSyntax used in the ValueText for specifying the values of the SchedulePart object.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SchedulePartTextSyntax ValueTextSyntax { get; }
Public ReadOnly Property ValueTextSyntax As SchedulePartTextSyntax
    Get
member ValueTextSyntax : SchedulePartTextSyntax with get

function get_ValueTextSyntax();

public:
property SchedulePartTextSyntax ValueTextSyntax {
    SchedulePartTextSyntax get ();
}

Property Value

Type: SchedulePartTextSyntax
See Also

Reference

SchedulePart Class
GSF.Scheduling Namespace


SchedulePartTextSyntax Enumeration

Grid Solutions Framework SchedulePartTextSyntax Enumeration
Indicates the syntax used in a SchedulePart for specifying its values.

Namespace: GSF.Scheduling
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SchedulePartTextSyntax
Public Enumeration SchedulePartTextSyntax
type SchedulePartTextSyntax
GSF.Scheduling.SchedulePartTextSyntax = function();
GSF.Scheduling.SchedulePartTextSyntax.createEnum('GSF.Scheduling.SchedulePartTextSyntax', false);
public enum class SchedulePartTextSyntax
Members
Member name | Value | Description
Any | 0 | Values for the SchedulePart were specified using the '*' text syntax. Included values are all legal values for the DateTimePart that the SchedulePart represents.
EveryN | 1 | Values for the SchedulePart were specified using the '*/n' text syntax. Included values are legal values for the DateTimePart that the SchedulePart represents that are divisible by 'n'.
Range | 2 | Values for the SchedulePart were specified using the 'n1-nn' text syntax. Included values are legal values for the DateTimePart that the SchedulePart represents that are within the specified range.
Specific | 3 | Values for the SchedulePart were specified using the 'n1,n2,nn' text syntax. Included values are specific legal values for the DateTimePart that the SchedulePart represents.
See Also

Reference

GSF.Scheduling Namespace


GSF.Searching Namespace

Grid Solutions Framework GSF.Searching Namespace

[Missing <summary> documentation for "N:GSF.Searching"]

Classes
 | Class | Description
Public class | AsyncSearcherTSearch | Uses reflection to search a collection of items for a given search string.


AsyncSearcher(TSearch) Class

Grid Solutions Framework AsyncSearcherTSearch Class
Uses reflection to search a collection of items for a given search string.
Inheritance Hierarchy
SystemObject
GSF.SearchingAsyncSearcherTSearch

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AsyncSearcher<TSearch>

Public Class AsyncSearcher(Of TSearch)
type AsyncSearcher<'TSearch> =  class end
JavaScript does not support generic types or methods.
generic<typename TSearch>
public ref class AsyncSearcher

Type Parameters

TSearch
The type of the objects to be searched.

The AsyncSearcherTSearch type exposes the following members.

Constructors
 | Name | Description
Public method | AsyncSearcherTSearch | Creates a new instance of the AsyncSearcherTSearch class.
Top
Methods
 | Name | Description
Public method | Add | Adds a collection of items to the search.
Public method | Cancel | Cancels currently running searches.
Public method | Clear | Clears the queue of items to search.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IgnoreCase | Gets or sets the flag that determines whether to ignore case when running the search.
Public property | SearchCategories | Gets the names of the properties to which the search string will be applied.
Public property | Searching | Gets the flag that indicates whether the AsyncSearcherTSearch is in the middle of a search operation.
Public property | SearchText | Gets or sets the text to be searched for.
Public property | UseRegex | Gets or sets the flag that determines whether to process the search tokens as regular expressions.
Public property | UseWildcards | Gets or sets the flag that determines whether to process *, ?, and - characters as wildcards.
Top
Events
 | Name | Description
Public event | MatchesFound | Event triggered when the searcher finds a match.
Public event | SearchComplete | Event triggered when the searcher has finished searching all the items in its queue.
Top
See Also

Reference

GSF.Searching Namespace


AsyncSearcher(TSearch) Constructor

Grid Solutions Framework AsyncSearcherTSearch Constructor
Creates a new instance of the AsyncSearcherTSearch class.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AsyncSearcher()
Public Sub New
new : unit -> AsyncSearcher
GSF.Searching.AsyncSearcher = function();
public:
AsyncSearcher()
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch) Methods

Grid Solutions Framework AsyncSearcherTSearch Methods

The AsyncSearcherTSearch generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds a collection of items to the search.
Public method | Cancel | Cancels currently running searches.
Public method | Clear | Clears the queue of items to search.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).Add Method

Grid Solutions Framework AsyncSearcherTSearchAdd Method
Adds a collection of items to the search.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    IEnumerable<TSearch> itemsToSearch
)
Public Sub Add (
    itemsToSearch As IEnumerable(Of TSearch)
)
member Add :
        itemsToSearch : IEnumerable<'TSearch> -> unit

function Add(itemsToSearch);
public:
void Add(
    IEnumerable<TSearch>^ itemsToSearch
)

Parameters

itemsToSearch
Type: System.Collections.GenericIEnumerable TSearch
The items to be searched.
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).Cancel Method

Grid Solutions Framework AsyncSearcherTSearchCancel Method
Cancels currently running searches.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Cancel()
Public Sub Cancel
member Cancel : unit -> unit

function Cancel();
public:
void Cancel()
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).Clear Method

Grid Solutions Framework AsyncSearcherTSearchClear Method
Clears the queue of items to search.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
Remarks
After a search is cancelled, there may still be items lingering in the queue. This method allows the user to clear them out.
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch) Properties

Grid Solutions Framework AsyncSearcherTSearch Properties

The AsyncSearcherTSearch generic type exposes the following members.

Properties
 | Name | Description
Public property | IgnoreCase | Gets or sets the flag that determines whether to ignore case when running the search.
Public property | SearchCategories | Gets the names of the properties to which the search string will be applied.
Public property | Searching | Gets the flag that indicates whether the AsyncSearcherTSearch is in the middle of a search operation.
Public property | SearchText | Gets or sets the text to be searched for.
Public property | UseRegex | Gets or sets the flag that determines whether to process the search tokens as regular expressions.
Public property | UseWildcards | Gets or sets the flag that determines whether to process *, ?, and - characters as wildcards.
Top
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).IgnoreCase Property

Grid Solutions Framework AsyncSearcherTSearchIgnoreCase Property
Gets or sets the flag that determines whether to ignore case when running the search.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IgnoreCase { get; set; }
Public Property IgnoreCase As Boolean
    Get
    Set
member IgnoreCase : bool with get, set

function get_IgnoreCase();
function set_IgnoreCase(value);
public:
property bool IgnoreCase {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).SearchCategories Property

Grid Solutions Framework AsyncSearcherTSearchSearchCategories Property
Gets the names of the properties to which the search string will be applied.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<string> SearchCategories { get; }
Public ReadOnly Property SearchCategories As ICollection(Of String)
    Get
member SearchCategories : ICollection<string> with get

function get_SearchCategories();

public:
property ICollection<String^>^ SearchCategories {
    ICollection<String^>^ get ();
}

Property Value

Type: ICollection String
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).Searching Property

Grid Solutions Framework AsyncSearcherTSearchSearching Property
Gets the flag that indicates whether the AsyncSearcherTSearch is in the middle of a search operation.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Searching { get; }
Public ReadOnly Property Searching As Boolean
    Get
member Searching : bool with get

function get_Searching();

public:
property bool Searching {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).SearchText Property

Grid Solutions Framework AsyncSearcherTSearchSearchText Property
Gets or sets the text to be searched for.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SearchText { get; set; }
Public Property SearchText As String
    Get
    Set
member SearchText : string with get, set

function get_SearchText();
function set_SearchText(value);
public:
property String^ SearchText {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).UseRegex Property

Grid Solutions Framework AsyncSearcherTSearchUseRegex Property
Gets or sets the flag that determines whether to process the search tokens as regular expressions.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseRegex { get; set; }
Public Property UseRegex As Boolean
    Get
    Set
member UseRegex : bool with get, set

function get_UseRegex();
function set_UseRegex(value);
public:
property bool UseRegex {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This property supercedes the UseWildcards property. In order to use wildcards, this property must be set to false.
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).UseWildcards Property

Grid Solutions Framework AsyncSearcherTSearchUseWildcards Property
Gets or sets the flag that determines whether to process *, ?, and - characters as wildcards.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseWildcards { get; set; }
Public Property UseWildcards As Boolean
    Get
    Set
member UseWildcards : bool with get, set

function get_UseWildcards();
function set_UseWildcards(value);
public:
property bool UseWildcards {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
The UseRegex property supercedes this property. In order to use wildcards, UseRegex must be set to false.
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch) Events

Grid Solutions Framework AsyncSearcherTSearch Events

The AsyncSearcherTSearch generic type exposes the following members.

Events
 | Name | Description
Public event | MatchesFound | Event triggered when the searcher finds a match.
Public event | SearchComplete | Event triggered when the searcher has finished searching all the items in its queue.
Top
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).MatchesFound Event

Grid Solutions Framework AsyncSearcherTSearchMatchesFound Event
Event triggered when the searcher finds a match.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IEnumerable<TSearch>>> MatchesFound
Public Event MatchesFound As EventHandler(Of EventArgs(Of IEnumerable(Of TSearch)))
member MatchesFound : IEvent<EventHandler<EventArgs<IEnumerable<'TSearch>>>,
    EventArgs<IEnumerable<'TSearch>>>

function add_MatchesFound(value);
function remove_MatchesFound(value);
public:
 event EventHandler<EventArgs<IEnumerable<TSearch>^>^>^ MatchesFound {
    void add (EventHandler<EventArgs<IEnumerable<TSearch>^>^>^ value);
    void remove (EventHandler<EventArgs<IEnumerable<TSearch>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IEnumerable TSearch
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


AsyncSearcher(TSearch).SearchComplete Event

Grid Solutions Framework AsyncSearcherTSearchSearchComplete Event
Event triggered when the searcher has finished searching all the items in its queue.

Namespace: GSF.Searching
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler SearchComplete
Public Event SearchComplete As EventHandler
member SearchComplete : IEvent<EventHandler,
    EventArgs>

function add_SearchComplete(value);
function remove_SearchComplete(value);
public:
 event EventHandler^ SearchComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

AsyncSearcherTSearch Class
GSF.Searching Namespace


GSF.Security Namespace

Grid Solutions Framework GSF.Security Namespace
Contains fundamental classes that define the security framework for role-based security.
Classes
 | Class | Description
Public class | AdoSecurityCache | Represents a secured inter-process cache for the security context needed by the AdoSecurityProvider.
 | AdoSecurityProvider | Represents an ISecurityProvider that uses ADO.NET data source (SQL Server, MySQL, Oracle, etc.) for its backend data store and authenticates internal users against Active Directory and external users against the database.
 | LdapSecurityProvider | Represents an ISecurityProvider that uses Active Directory for its backend data store and credential authentication.
Public class | RestrictAccessAttribute | Represents an Attribute that can be used restrict access to a class when using role-based security.
Public class | SecurityIdentity | A class that implements IIdentity interface to facilitate custom role-based security.
Public class | SecurityPrincipal | A class that implements IPrincipal interface to facilitate custom role-based security.
 | SecurityProviderBase | Base class for a provider of role-based security in applications.
Public class | SecurityProviderCache | A helper class that manages the caching of ISecurityProviders.
Public class | SecurityProviderUtility | A helper class containing methods used in the implementation of role-based security.
Public class | UserData | A serializable class that contains information about a user defined in the security data store.
Public class | UserDataCache | Represents a secured inter-process cache for a DictionaryTKey, TValue of serialized UserData.
Public class | UserRoleCache | Represents a secured inter-process cache for a DictionaryTKey, TValue of serialized user role information.
Interfaces
 | Interface | Description
Public interface | ISecurityProvider | Defines a provider of role-based security in applications.
Delegates
 | Delegate | Description
Public delegate | LogEventFunctionSignature | Defines the function signature delegate used for logging events from the ISecurityProvider.


AdoSecurityCache Class

Grid Solutions Framework AdoSecurityCache Class
Represents a secured inter-process cache for the security context needed by the AdoSecurityProvider.
Inheritance Hierarchy
SystemObject
GSF.IOInterprocessCache
GSF.SecurityAdoSecurityCache

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AdoSecurityCache : InterprocessCache
Public Class AdoSecurityCache
    Inherits InterprocessCache
type AdoSecurityCache =
    class
        inherit InterprocessCache
    end
GSF.Security.AdoSecurityCache = function();

Type.createClass(
    'GSF.Security.AdoSecurityCache',
    GSF.IO.InterprocessCache);
public ref class AdoSecurityCache : public InterprocessCache

The AdoSecurityCache type exposes the following members.

Constructors
 | Name | Description
Public method | AdoSecurityCache | Creates a new instance of the AdoSecurityCache with the specified number of maximumConcurrentLocks.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object. (Inherited from InterprocessCache.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources. (Inherited from InterprocessCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Inherited from InterprocessCache.)
 | GetCurrentCache | Loads the AdoSecurityCache for the current local user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Initiates inter-process synchronized cache file load. (Inherited from InterprocessCache.)
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge). (Overrides InterprocessCacheLoadFileData(FileStream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Initiates inter-process synchronized save of DataSet. (Overrides InterprocessCacheSave.)
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge). (Overrides InterprocessCacheSaveFileData(FileStream, Byte).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete. (Inherited from InterprocessCache.)
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete. (Inherited from InterprocessCache.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated. (Inherited from InterprocessCache.)
Public property | DataSet | Gets or sets the internal DataSet; returned value will be a copy of the internal.
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded. (Inherited from InterprocessCache.)
Public property | FileName | Path and file name for the cache needing inter-process synchronization. (Inherited from InterprocessCache.)
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed. (Inherited from InterprocessCache.)
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data. (Inherited from InterprocessCache.)
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData. (Inherited from InterprocessCache.)
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data. (Inherited from InterprocessCache.)
Top
Remarks
This is a system cache that contains the last known security information loaded from the database related to users, roles and groups. This cache allows the AdoSecurityProvider to start-up without database access using latest cached security context. Even though this cache contains role information for all users, it does not overlap information in the UserRoleCache since the user role cache contains role assignments for a user at last login and is used for auditing.
See Also

Reference

GSF.Security Namespace


AdoSecurityCache Constructor

Grid Solutions Framework AdoSecurityCache Constructor
Creates a new instance of the AdoSecurityCache with the specified number of maximumConcurrentLocks.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdoSecurityCache(
    int maximumConcurrentLocks = 10
)
Public Sub New (
    Optional maximumConcurrentLocks As Integer = 10
)
new :
        ?maximumConcurrentLocks : int
(* Defaults:
        let _maximumConcurrentLocks = defaultArg maximumConcurrentLocks 10
*)
-> AdoSecurityCache
GSF.Security.AdoSecurityCache = function(maximumConcurrentLocks);
public:
AdoSecurityCache(
    int maximumConcurrentLocks = 10
)

Parameters

maximumConcurrentLocks (Optional)
Type: SystemInt32
Maximum concurrent reader locks to allow.
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityCache Methods

Grid Solutions Framework AdoSecurityCache Methods

The AdoSecurityCache type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object. (Inherited from InterprocessCache.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources. (Inherited from InterprocessCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Inherited from InterprocessCache.)
 | GetCurrentCache | Loads the AdoSecurityCache for the current local user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Initiates inter-process synchronized cache file load. (Inherited from InterprocessCache.)
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge). (Overrides InterprocessCacheLoadFileData(FileStream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Initiates inter-process synchronized save of DataSet. (Overrides InterprocessCacheSave.)
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge). (Overrides InterprocessCacheSaveFileData(FileStream, Byte).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete. (Inherited from InterprocessCache.)
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete. (Inherited from InterprocessCache.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityCache.GetCurrentCache Method

Grid Solutions Framework AdoSecurityCacheGetCurrentCache Method
Loads the AdoSecurityCache for the current local user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static AdoSecurityCache GetCurrentCache()
Public Shared Function GetCurrentCache As AdoSecurityCache
static member GetCurrentCache : unit -> AdoSecurityCache

GSF.Security.AdoSecurityCache.GetCurrentCache = function();
public:
static AdoSecurityCache^ GetCurrentCache()

Return Value

Type: AdoSecurityCache
Loaded instance of the AdoSecurityCache.
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityCache.LoadFileData Method

Grid Solutions Framework AdoSecurityCacheLoadFileData Method
Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge).

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] LoadFileData(
    FileStream fileStream
)
Protected Overrides Function LoadFileData (
    fileStream As FileStream
) As Byte()
abstract LoadFileData :
        fileStream : FileStream -> byte[]
override LoadFileData :
        fileStream : FileStream -> byte[]
function LoadFileData(fileStream);
protected:
virtual array<unsigned char>^ LoadFileData(
    FileStream^ fileStream
) override

Parameters

fileStream
Type: System.IOFileStream
FileStream used to deserialize data.

Return Value

Type: Byte
Deserialized file data.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityCache.Save Method

Grid Solutions Framework AdoSecurityCacheSave Method
Initiates inter-process synchronized save of DataSet.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Save()
Public Overrides Sub Save
abstract Save : unit -> unit
override Save : unit -> unit
function Save();
public:
virtual void Save() override
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityCache.SaveFileData Method

Grid Solutions Framework AdoSecurityCacheSaveFileData Method
Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge).

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SaveFileData(
    FileStream fileStream,
    byte[] fileData
)
Protected Overrides Sub SaveFileData (
    fileStream As FileStream,
    fileData As Byte()
)
abstract SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
override SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
function SaveFileData(fileStream, fileData);
protected:
virtual void SaveFileData(
    FileStream^ fileStream,
    array<unsigned char>^ fileData
) override

Parameters

fileStream
Type: System.IOFileStream
FileStream used to serialize data.
fileData
Type: SystemByte
File data to be serialized.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityCache Properties

Grid Solutions Framework AdoSecurityCache Properties

The AdoSecurityCache type exposes the following members.

Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated. (Inherited from InterprocessCache.)
Public property | DataSet | Gets or sets the internal DataSet; returned value will be a copy of the internal.
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded. (Inherited from InterprocessCache.)
Public property | FileName | Path and file name for the cache needing inter-process synchronization. (Inherited from InterprocessCache.)
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed. (Inherited from InterprocessCache.)
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data. (Inherited from InterprocessCache.)
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData. (Inherited from InterprocessCache.)
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data. (Inherited from InterprocessCache.)
Top
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityCache.DataSet Property

Grid Solutions Framework AdoSecurityCacheDataSet Property
Gets or sets the internal DataSet; returned value will be a copy of the internal.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet DataSet { get; set; }
Public Property DataSet As DataSet
    Get
    Set
member DataSet : DataSet with get, set

function get_DataSet();
function set_DataSet(value);
public:
property DataSet^ DataSet {
    DataSet^ get ();
    void set (DataSet^ value);
}

Property Value

Type: DataSet
See Also

Reference

AdoSecurityCache Class
GSF.Security Namespace


AdoSecurityProvider Class

Grid Solutions Framework AdoSecurityProvider Class
Represents an ISecurityProvider that uses ADO.NET data source (SQL Server, MySQL, Oracle, etc.) for its backend data store and authenticates internal users against Active Directory and external users against the database.
Inheritance Hierarchy
SystemObject
GSF.SecuritySecurityProviderBase
GSF.SecurityLdapSecurityProvider
GSF.SecurityAdoSecurityProvider

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AdoSecurityProvider : LdapSecurityProvider
Public Class AdoSecurityProvider
    Inherits LdapSecurityProvider
type AdoSecurityProvider =
    class
        inherit LdapSecurityProvider
    end
GSF.Security.AdoSecurityProvider = function();

Type.createClass(
    'GSF.Security.AdoSecurityProvider',
    GSF.Security.LdapSecurityProvider);
public ref class AdoSecurityProvider : public LdapSecurityProvider

The AdoSecurityProvider type exposes the following members.

Constructors
 | Name | Description
Public method | AdoSecurityProvider(String) | Initializes a new instance of the AdoSecurityProvider class.
Protected method | AdoSecurityProvider(String, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the AdoSecurityProvider class.
Top
Methods
 | Name | Description
Public method | Authenticate | Authenticates the user. (Overrides LdapSecurityProviderAuthenticate(String).)
Public method | ChangePassword | Changes user password in the backend data store. (Overrides LdapSecurityProviderChangePassword(String, String).)
Public method | Dispose | Releases all the resources used by the security provider. (Inherited from SecurityProviderBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the security provider and optionally releases the managed resources. (Inherited from SecurityProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractSecurityContext | Extracts the current security context from the database.
Protected method | Finalize | Releases the unmanaged resources before the security provider is reclaimed by GC. (Inherited from SecurityProviderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLdapPath | Gets the LDAP path. (Overrides LdapSecurityProviderGetLdapPath.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the security provider. (Inherited from SecurityProviderBase.)
Public method | LoadSettings | Loads saved security provider settings from the config file if the PersistSettings property is set to true. (Overrides LdapSecurityProviderLoadSettings.)
Protected method | LogAuthenticationAttempt | Logs user authentication attempt.
Protected method | LogError | Logs information about an encountered exception to the backend data store.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshData | Refreshes the UserData. (Overrides LdapSecurityProviderRefreshData.)
Protected method | RefreshData(ListString, Int32) | Refreshes the UserData from the backend data store loading user groups into desired collection. (Inherited from LdapSecurityProvider.)
Public method | ResetPassword | Resets user password in the backend data store. (Inherited from LdapSecurityProvider.)
Public method | SaveSettings | Saves LdapSecurityProvider settings to the config file if the PersistSettings property is set to true. (Inherited from LdapSecurityProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateRole | Performs a translation of the specified user role. (Inherited from LdapSecurityProvider.)
Public method | UpdateData | Updates the UserData in the backend data store. (Inherited from LdapSecurityProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultPasswordRequirementsError | Default error message displayed when databases users fail regular expression test.
DefaultPasswordRequirementsRegex | Default regular expression used to validate new database user passwords.
ProviderID | Defines the provider ID for the AdoSecurityProvider.
Top
Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | AuthenticationFailureReason | Gets or allows derived classes to set an authentication failure reason. (Inherited from SecurityProviderBase.)
Public property | CacheMaximumRetryAttempts | Gets or sets the maximum retry attempts allowed for loading offline user data cache. (Inherited from LdapSecurityProvider.)
Public property | CacheRetryDelayInterval | Gets or sets the wait interval (in milliseconds) before retrying load of offline user data cache. (Inherited from LdapSecurityProvider.)
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanUpdateData | Gets a boolean value that indicates whether UpdateData operation is supported. (Overrides SecurityProviderBaseCanUpdateData.)
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the security provider is currently enabled. (Inherited from SecurityProviderBase.)
Public property | EnableOfflineCaching | Gets or sets a boolean value that indicates whether user information is to be cached for offline authentication. (Inherited from LdapSecurityProvider.)
Protected property | Initialized | Gets current intialization state. (Inherited from SecurityProviderBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from SecurityProviderBase.)
Public property | LastException | Gets last exception reported by the AdoSecurityProvider.
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation. (Inherited from SecurityProviderBase.)
Public property | Password | Gets or sets SecurePassword as clear text password. (Inherited from SecurityProviderBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether security provider settings are to be saved to the config file. (Inherited from SecurityProviderBase.)
Public property | SecurePassword | Gets or sets the password as a SecureString. (Inherited from SecurityProviderBase.)
Public property | SettingsCategory | Gets or sets the category under which security provider settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from SecurityProviderBase.)
Public property | UserData | Gets the UserData object containing information about the user. (Inherited from SecurityProviderBase.)
Public property | WindowsPrincipal | Gets the original WindowsPrincipal of the user if the user exists in Active Directory. (Inherited from LdapSecurityProvider.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed. (Inherited from SecurityProviderBase.)
Top
Remarks
Minimum expected table schema for ADO Security Provider:
Copy
CREATE TABLE UserAccount
(
    ID UNIQUEINDENTIFIER NOT NULL DEFAULT NEWID(),
    Name VARCHAR(200) NOT NULL,
    Password VARCHAR(200) DEFAULT NULL,
    FirstName VARCHAR(200) DEFAULT NULL,
    LastName VARCHAR(200) DEFAULT NULL,
    Phone VARCHAR(200) DEFAULT NULL,
    Email VARCHAR(200) DEFAULT NULL,
    LockedOut TINYINT NOT NULL DEFAULT 0,
    UseADAuthentication TINYINT NOT NULL DEFAULT 1,
    ChangePasswordOn DATETIME DEFAULT NULL,
    CONSTRAINT PK_UserAccount PRIMARY KEY (ID ASC),
    CONSTRAINT IX_UserAccount UNIQUE KEY (Name)
);

CREATE TABLE SecurityGroup
(
    ID UNIQUEINDENTIFIER NOT NULL DEFAULT NEWID(),
    Name VARCHAR(200) NOT NULL,
    CONSTRAINT PK_SecurityGroup PRIMARY KEY (ID ASC),
    CONSTRAINT IX_SecurityGroup UNIQUE KEY (Name)
);

CREATE TABLE SecurityGroupUserAccount
(
    SecurityGroupID UNIQUEINDENTIFIER NOT NULL,
    UserAccountID UNIQUEINDENTIFIER NOT NULL
);

CREATE TABLE ApplicationRole
(
    ID UNIQUEINDENTIFIER NOT NULL DEFAULT NEWID(),
    Name VARCHAR(200) NOT NULL,
    NodeID UNIQUEINDENTIFIER NOT NULL,
    CONSTRAINT PK_ApplicationRole PRIMARY KEY (ID ASC),
    CONSTRAINT IX_ApplicationRole UNIQUE KEY (NodeID, Name)
);

CREATE TABLE ApplicationRoleUserAccount
(
    ApplicationRoleID UNIQUEINDENTIFIER NOT NULL,
    UserAccountID UNIQUEINDENTIFIER NOT NULL
);

CREATE TABLE ApplicationRoleSecurityGroup
(
    ApplicationRoleID UNIQUEINDENTIFIER NOT NULL,
    SecurityGroupID UNIQUEINDENTIFIER NOT NULL
);
Examples
Required config file entries (automatically added):
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ProviderType" value="GSF.Security.AdoSecurityProvider, GSF.Security" description="The type to be used for enforcing security."
        encrypted="false" />
      <add name="UserCacheTimeout" value="5" description="Defines the timeout, in whole minutes, for a user's provider cache. Any value less than 1 will cause cache reset every minute."
        encrypted="false" />
      <add name="ConnectionString" value="Eval(systemSettings.ConnectionString)" description="Configuration database connection string"
        encrypted="false"/>
      <add name="DataProviderString" value="Eval(systemSettings.DataProviderString)" description="Configuration database ADO.NET data provider assembly type creation string"
        encrypted="false"/>
      <add name="LdapPath" value="" description="Specifies the LDAP path used to initialize the security provider."
        encrypted="false" />
      <add name="ApplicationName" value="SEC_APP" description="Name of the application being secured."
        encrypted="false" />
      <add name="IncludedResources" value="*=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="" description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
      <add name="CacheRetryDelayInterval" value="200" description="Wait interval, in milliseconds, before retrying load of user data cache."
        encrypted="false"/>
      <add name="CacheMaximumRetryAttempts" value="10" description="Maximum retry attempts allowed for loading user data cache."
        encrypted="false"/>
      <add name="EnableOfflineCaching" value="True" description="True to enable caching of user information for authentication in offline state, otherwise False."
        encrypted="false"/>
      <add name="PasswordRequirementsRegex" value="^.*(?=.{8,})(?=.*\d)(?=.*[a-z])(?=.*[A-Z]).*$" description="Regular expression used to validate new passwords for database users."
        encrypted="false" />
      <add name="PasswordRequirementsError" value="Invalid Password: Password must be at least 8 characters; must contain at least 1 number, 1 upper case letter, and 1 lower case letter" description="Error message to be displayed when new database user password fails regular expression test."
        encrypted="false" />
    </securityProvider>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.Security Namespace


AdoSecurityProvider Constructor

Grid Solutions Framework AdoSecurityProvider Constructor
Overload List
 | Name | Description
Public method | AdoSecurityProvider(String) | Initializes a new instance of the AdoSecurityProvider class.
Protected method | AdoSecurityProvider(String, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the AdoSecurityProvider class.
Top
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider Constructor (String)

Grid Solutions Framework AdoSecurityProvider Constructor (String)
Initializes a new instance of the AdoSecurityProvider class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdoSecurityProvider(
    string username
)
Public Sub New (
    username As String
)
new :
        username : string -> AdoSecurityProvider
GSF.Security.AdoSecurityProvider = function(username);
public:
AdoSecurityProvider(
    String^ username
)

Parameters

username
Type: SystemString
Name that uniquely identifies the user.
See Also

Reference

AdoSecurityProvider Class
AdoSecurityProvider Overload
GSF.Security Namespace


AdoSecurityProvider Constructor (String, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework AdoSecurityProvider Constructor (String, Boolean, Boolean, Boolean, Boolean)
Initializes a new instance of the AdoSecurityProvider class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AdoSecurityProvider(
    string username,
    bool canRefreshData,
    bool canUpdateData,
    bool canResetPassword,
    bool canChangePassword
)
Protected Sub New (
    username As String,
    canRefreshData As Boolean,
    canUpdateData As Boolean,
    canResetPassword As Boolean,
    canChangePassword As Boolean
)
new :
        username : string *
        canRefreshData : bool *
        canUpdateData : bool *
        canResetPassword : bool *
        canChangePassword : bool -> AdoSecurityProvider
GSF.Security.AdoSecurityProvider = function(username, canRefreshData, canUpdateData, canResetPassword, canChangePassword);
protected:
AdoSecurityProvider(
    String^ username,
    bool canRefreshData,
    bool canUpdateData,
    bool canResetPassword,
    bool canChangePassword
)

Parameters

username
Type: SystemString
Name that uniquely identifies the user.
canRefreshData
Type: SystemBoolean
true if the security provider can refresh UserData from the backend data store, otherwise false.
canUpdateData
Type: SystemBoolean
true if the security provider can update UserData in the backend data store, otherwise false.
canResetPassword
Type: SystemBoolean
true if the security provider can reset user password, otherwise false.
canChangePassword
Type: SystemBoolean
true if the security provider can change user password, otherwise false.
See Also

Reference

AdoSecurityProvider Class
AdoSecurityProvider Overload
GSF.Security Namespace


AdoSecurityProvider Fields

Grid Solutions Framework AdoSecurityProvider Fields

The AdoSecurityProvider type exposes the following members.

Fields
Name | Description
DefaultPasswordRequirementsError | Default error message displayed when databases users fail regular expression test.
DefaultPasswordRequirementsRegex | Default regular expression used to validate new database user passwords.
ProviderID | Defines the provider ID for the AdoSecurityProvider.
Top
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.DefaultPasswordRequirementsError Field

Grid Solutions Framework AdoSecurityProviderDefaultPasswordRequirementsError Field
Default error message displayed when databases users fail regular expression test.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultPasswordRequirementsError
Public Const DefaultPasswordRequirementsError As String
static val mutable DefaultPasswordRequirementsError: string
var GSF.Security.AdoSecurityProvider.DefaultPasswordRequirementsError
public:
literal String^ DefaultPasswordRequirementsError

Field Value

Type: String
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.DefaultPasswordRequirementsRegex Field

Grid Solutions Framework AdoSecurityProviderDefaultPasswordRequirementsRegex Field
Default regular expression used to validate new database user passwords.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultPasswordRequirementsRegex
Public Const DefaultPasswordRequirementsRegex As String
static val mutable DefaultPasswordRequirementsRegex: string
var GSF.Security.AdoSecurityProvider.DefaultPasswordRequirementsRegex
public:
literal String^ DefaultPasswordRequirementsRegex

Field Value

Type: String
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.ProviderID Field

Grid Solutions Framework AdoSecurityProviderProviderID Field
Defines the provider ID for the AdoSecurityProvider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ProviderID
Public Const ProviderID As Integer
static val mutable ProviderID: int
var GSF.Security.AdoSecurityProvider.ProviderID
public:
literal int ProviderID

Field Value

Type: Int32
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider Methods

Grid Solutions Framework AdoSecurityProvider Methods

The AdoSecurityProvider type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Authenticates the user. (Overrides LdapSecurityProviderAuthenticate(String).)
Public method | ChangePassword | Changes user password in the backend data store. (Overrides LdapSecurityProviderChangePassword(String, String).)
Public method | Dispose | Releases all the resources used by the security provider. (Inherited from SecurityProviderBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the security provider and optionally releases the managed resources. (Inherited from SecurityProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractSecurityContext | Extracts the current security context from the database.
Protected method | Finalize | Releases the unmanaged resources before the security provider is reclaimed by GC. (Inherited from SecurityProviderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLdapPath | Gets the LDAP path. (Overrides LdapSecurityProviderGetLdapPath.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the security provider. (Inherited from SecurityProviderBase.)
Public method | LoadSettings | Loads saved security provider settings from the config file if the PersistSettings property is set to true. (Overrides LdapSecurityProviderLoadSettings.)
Protected method | LogAuthenticationAttempt | Logs user authentication attempt.
Protected method | LogError | Logs information about an encountered exception to the backend data store.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshData | Refreshes the UserData. (Overrides LdapSecurityProviderRefreshData.)
Protected method | RefreshData(ListString, Int32) | Refreshes the UserData from the backend data store loading user groups into desired collection. (Inherited from LdapSecurityProvider.)
Public method | ResetPassword | Resets user password in the backend data store. (Inherited from LdapSecurityProvider.)
Public method | SaveSettings | Saves LdapSecurityProvider settings to the config file if the PersistSettings property is set to true. (Inherited from LdapSecurityProvider.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateRole | Performs a translation of the specified user role. (Inherited from LdapSecurityProvider.)
Public method | UpdateData | Updates the UserData in the backend data store. (Inherited from LdapSecurityProvider.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.Authenticate Method

Grid Solutions Framework AdoSecurityProviderAuthenticate Method
Authenticates the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Authenticate(
    string password
)
Public Overrides Function Authenticate (
    password As String
) As Boolean
abstract Authenticate :
        password : string -> bool
override Authenticate :
        password : string -> bool
function Authenticate(password);
public:
virtual bool Authenticate(
    String^ password
) override

Parameters

password
Type: SystemString
Password to be used for authentication.

Return Value

Type: Boolean
true if the user is authenticated, otherwise false.

Implements

ISecurityProviderAuthenticate(String)
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.ChangePassword Method

Grid Solutions Framework AdoSecurityProviderChangePassword Method
Changes user password in the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ChangePassword(
    string oldPassword,
    string newPassword
)
Public Overrides Function ChangePassword (
    oldPassword As String,
    newPassword As String
) As Boolean
abstract ChangePassword :
        oldPassword : string *
        newPassword : string -> bool
override ChangePassword :
        oldPassword : string *
        newPassword : string -> bool
function ChangePassword(oldPassword, newPassword);
public:
virtual bool ChangePassword(
    String^ oldPassword,
    String^ newPassword
) override

Parameters

oldPassword
Type: SystemString
User's current password.
newPassword
Type: SystemString
User's new password.

Return Value

Type: Boolean
true if the password is changed, otherwise false.

Implements

ISecurityProviderChangePassword(String, String)
Exceptions
Exception | Condition
SecurityException | newPassword does not meet password requirements.
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.ExtractSecurityContext Method

Grid Solutions Framework AdoSecurityProviderExtractSecurityContext Method
Extracts the current security context from the database.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet ExtractSecurityContext(
    IDbConnection connection,
    Action<Exception> exceptionHandler
)
Public Shared Function ExtractSecurityContext (
    connection As IDbConnection,
    exceptionHandler As Action(Of Exception)
) As DataSet
static member ExtractSecurityContext :
        connection : IDbConnection *
        exceptionHandler : Action<Exception> -> DataSet

GSF.Security.AdoSecurityProvider.ExtractSecurityContext = function(connection, exceptionHandler);
public:
static DataSet^ ExtractSecurityContext(
    IDbConnection^ connection,
    Action<Exception^>^ exceptionHandler
)

Parameters

connection
Type: System.DataIDbConnection
Existing database connection used to extract security context.
exceptionHandler
Type: SystemAction Exception
Exception handler to use for any exceptions encountered while updating security cache.

Return Value

Type: DataSet
A new DataSet containing the latest security context.
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.GetLdapPath Method

Grid Solutions Framework AdoSecurityProviderGetLdapPath Method
Gets the LDAP path.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override string GetLdapPath()
Protected Overrides Function GetLdapPath As String
abstract GetLdapPath : unit -> string
override GetLdapPath : unit -> string
function GetLdapPath();
protected:
virtual String^ GetLdapPath() override

Return Value

Type: String
The LDAP path.
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.LoadSettings Method

Grid Solutions Framework AdoSecurityProviderLoadSettings Method
Loads saved security provider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.LogAuthenticationAttempt Method

Grid Solutions Framework AdoSecurityProviderLogAuthenticationAttempt Method
Logs user authentication attempt.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool LogAuthenticationAttempt(
    bool loginSuccess
)
Protected Overridable Function LogAuthenticationAttempt (
    loginSuccess As Boolean
) As Boolean
abstract LogAuthenticationAttempt :
        loginSuccess : bool -> bool
override LogAuthenticationAttempt :
        loginSuccess : bool -> bool
function LogAuthenticationAttempt(loginSuccess);
protected:
virtual bool LogAuthenticationAttempt(
    bool loginSuccess
)

Parameters

loginSuccess
Type: SystemBoolean
true if user authentication was successful, otherwise false.

Return Value

Type: Boolean
true if logging was successful, otherwise false.
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.LogError Method

Grid Solutions Framework AdoSecurityProviderLogError Method
Logs information about an encountered exception to the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool LogError(
    string source,
    string message
)
Protected Overridable Function LogError (
    source As String,
    message As String
) As Boolean
abstract LogError :
        source : string *
        message : string -> bool
override LogError :
        source : string *
        message : string -> bool
function LogError(source, message);
protected:
virtual bool LogError(
    String^ source,
    String^ message
)

Parameters

source
Type: SystemString
Source of the exception.
message
Type: SystemString
Detailed description of the exception.

Return Value

Type: Boolean
true if logging was successful, otherwise false.
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.RefreshData Method

Grid Solutions Framework AdoSecurityProviderRefreshData Method
Overload List
 | Name | Description
Public method | RefreshData | Refreshes the UserData. (Overrides LdapSecurityProviderRefreshData.)
Protected method | RefreshData(ListString, Int32) | Refreshes the UserData from the backend data store loading user groups into desired collection. (Inherited from LdapSecurityProvider.)
Top
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.RefreshData Method

Grid Solutions Framework AdoSecurityProviderRefreshData Method
Refreshes the UserData.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool RefreshData()
Public Overrides Function RefreshData As Boolean
abstract RefreshData : unit -> bool
override RefreshData : unit -> bool
function RefreshData();
public:
virtual bool RefreshData() override

Return Value

Type: Boolean
true if UserData is refreshed, otherwise false.

Implements

ISecurityProviderRefreshData
See Also

Reference

AdoSecurityProvider Class
RefreshData Overload
GSF.Security Namespace


AdoSecurityProvider Properties

Grid Solutions Framework AdoSecurityProvider Properties

The AdoSecurityProvider type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | AuthenticationFailureReason | Gets or allows derived classes to set an authentication failure reason. (Inherited from SecurityProviderBase.)
Public property | CacheMaximumRetryAttempts | Gets or sets the maximum retry attempts allowed for loading offline user data cache. (Inherited from LdapSecurityProvider.)
Public property | CacheRetryDelayInterval | Gets or sets the wait interval (in milliseconds) before retrying load of offline user data cache. (Inherited from LdapSecurityProvider.)
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanUpdateData | Gets a boolean value that indicates whether UpdateData operation is supported. (Overrides SecurityProviderBaseCanUpdateData.)
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the security provider is currently enabled. (Inherited from SecurityProviderBase.)
Public property | EnableOfflineCaching | Gets or sets a boolean value that indicates whether user information is to be cached for offline authentication. (Inherited from LdapSecurityProvider.)
Protected property | Initialized | Gets current intialization state. (Inherited from SecurityProviderBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from SecurityProviderBase.)
Public property | LastException | Gets last exception reported by the AdoSecurityProvider.
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation. (Inherited from SecurityProviderBase.)
Public property | Password | Gets or sets SecurePassword as clear text password. (Inherited from SecurityProviderBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether security provider settings are to be saved to the config file. (Inherited from SecurityProviderBase.)
Public property | SecurePassword | Gets or sets the password as a SecureString. (Inherited from SecurityProviderBase.)
Public property | SettingsCategory | Gets or sets the category under which security provider settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from SecurityProviderBase.)
Public property | UserData | Gets the UserData object containing information about the user. (Inherited from SecurityProviderBase.)
Public property | WindowsPrincipal | Gets the original WindowsPrincipal of the user if the user exists in Active Directory. (Inherited from LdapSecurityProvider.)
Top
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.CanUpdateData Property

Grid Solutions Framework AdoSecurityProviderCanUpdateData Property
Gets a boolean value that indicates whether UpdateData operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool CanUpdateData { get; }
Public Overrides ReadOnly Property CanUpdateData As Boolean
    Get
abstract CanUpdateData : bool with get
override CanUpdateData : bool with get
function get_CanUpdateData();

public:
virtual property bool CanUpdateData {
    bool get () override;
}

Property Value

Type: Boolean

Implements

ISecurityProviderCanUpdateData
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider.LastException Property

Grid Solutions Framework AdoSecurityProviderLastException Property
Gets last exception reported by the AdoSecurityProvider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Exception LastException { get; set; }
Public Property LastException As Exception
    Get
    Set
member LastException : Exception with get, set

function get_LastException();
function set_LastException(value);
public:
property Exception^ LastException {
    Exception^ get ();
    void set (Exception^ value);
}

Property Value

Type: Exception
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


AdoSecurityProvider Events

Grid Solutions Framework AdoSecurityProvider Events

The AdoSecurityProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed. (Inherited from SecurityProviderBase.)
Top
See Also

Reference

AdoSecurityProvider Class
GSF.Security Namespace


ISecurityProvider Interface

Grid Solutions Framework ISecurityProvider Interface
Defines a provider of role-based security in applications.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ISecurityProvider : ISupportLifecycle,
    IDisposable, IPersistSettings
Public Interface ISecurityProvider
    Inherits ISupportLifecycle, IDisposable, IPersistSettings
type ISecurityProvider =
    interface
        interface ISupportLifecycle
        interface IDisposable
        interface IPersistSettings
    end
GSF.Security.ISecurityProvider = function();
GSF.Security.ISecurityProvider.createInterface('GSF.Security.ISecurityProvider');
public interface class ISecurityProvider : ISupportLifecycle,
    IDisposable, IPersistSettings

The ISecurityProvider type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Authenticates the user.
Public method | ChangePassword | Changes user password in the backend data store.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | RefreshData | Refreshes the UserData from the backend data store.
Public method | ResetPassword | Resets user password in the backend data store.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Public method | TranslateRole | Performs a translation of the specified user role.
Public method | UpdateData | Updates the UserData in the backend data store.
Top
Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security data store.
Public property | AuthenticationFailureReason | Gets an authentication failure reason, if set by the provider when authentication fails.
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported.
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported.
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported.
Public property | CanUpdateData | Gets a boolean value that indicates whether UpdateData operation is supported.
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security data store.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation.
Public property | Password | Gets or sets SecurePassword as clear text password.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | SecurePassword | Gets or sets the password as a SecureString.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | UserData | Gets the UserData object containing information about the user.
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Top
See Also

Reference

GSF.Security Namespace


ISecurityProvider Methods

Grid Solutions Framework ISecurityProvider Methods

The ISecurityProvider type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Authenticates the user.
Public method | ChangePassword | Changes user password in the backend data store.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | RefreshData | Refreshes the UserData from the backend data store.
Public method | ResetPassword | Resets user password in the backend data store.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Public method | TranslateRole | Performs a translation of the specified user role.
Public method | UpdateData | Updates the UserData in the backend data store.
Top
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.Authenticate Method

Grid Solutions Framework ISecurityProviderAuthenticate Method
Authenticates the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Authenticate(
    string password
)
Function Authenticate (
    password As String
) As Boolean
abstract Authenticate :
        password : string -> bool

function Authenticate(password);
bool Authenticate(
    String^ password
)

Parameters

password
Type: SystemString
Password to be used for authentication.

Return Value

Type: Boolean
true if the user is authenticated, otherwise false.
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.ChangePassword Method

Grid Solutions Framework ISecurityProviderChangePassword Method
Changes user password in the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool ChangePassword(
    string oldPassword,
    string newPassword
)
Function ChangePassword (
    oldPassword As String,
    newPassword As String
) As Boolean
abstract ChangePassword :
        oldPassword : string *
        newPassword : string -> bool

function ChangePassword(oldPassword, newPassword);
bool ChangePassword(
    String^ oldPassword,
    String^ newPassword
)

Parameters

oldPassword
Type: SystemString
User's current password.
newPassword
Type: SystemString
User's new password.

Return Value

Type: Boolean
true if the password is changed, otherwise false.
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.RefreshData Method

Grid Solutions Framework ISecurityProviderRefreshData Method
Refreshes the UserData from the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool RefreshData()
Function RefreshData As Boolean
abstract RefreshData : unit -> bool

function RefreshData();
bool RefreshData()

Return Value

Type: Boolean
true if UserData is refreshed, otherwise false.
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.ResetPassword Method

Grid Solutions Framework ISecurityProviderResetPassword Method
Resets user password in the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool ResetPassword(
    string securityAnswer
)
Function ResetPassword (
    securityAnswer As String
) As Boolean
abstract ResetPassword :
        securityAnswer : string -> bool

function ResetPassword(securityAnswer);
bool ResetPassword(
    String^ securityAnswer
)

Parameters

securityAnswer
Type: SystemString
Answer to the user's security question.

Return Value

Type: Boolean
true if the password is reset, otherwise false.
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.TranslateRole Method

Grid Solutions Framework ISecurityProviderTranslateRole Method
Performs a translation of the specified user role.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string TranslateRole(
    string role
)
Function TranslateRole (
    role As String
) As String
abstract TranslateRole :
        role : string -> string

function TranslateRole(role);
String^ TranslateRole(
    String^ role
)

Parameters

role
Type: SystemString
The user role to be translated.

Return Value

Type: String
The user role that the specified user role translates to.
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.UpdateData Method

Grid Solutions Framework ISecurityProviderUpdateData Method
Updates the UserData in the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool UpdateData()
Function UpdateData As Boolean
abstract UpdateData : unit -> bool

function UpdateData();
bool UpdateData()

Return Value

Type: Boolean
true if UserData is updated, otherwise false.
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider Properties

Grid Solutions Framework ISecurityProvider Properties

The ISecurityProvider type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security data store.
Public property | AuthenticationFailureReason | Gets an authentication failure reason, if set by the provider when authentication fails.
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported.
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported.
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported.
Public property | CanUpdateData | Gets a boolean value that indicates whether UpdateData operation is supported.
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security data store.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation.
Public property | Password | Gets or sets SecurePassword as clear text password.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | SecurePassword | Gets or sets the password as a SecureString.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | UserData | Gets the UserData object containing information about the user.
Top
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.ApplicationName Property

Grid Solutions Framework ISecurityProviderApplicationName Property
Gets or sets the name of the application being secured as defined in the backend security data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ApplicationName { get; set; }
Property ApplicationName As String
    Get
    Set
abstract ApplicationName : string with get, set

function get_ApplicationName();
function set_ApplicationName(value);
property String^ ApplicationName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.AuthenticationFailureReason Property

Grid Solutions Framework ISecurityProviderAuthenticationFailureReason Property
Gets an authentication failure reason, if set by the provider when authentication fails.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string AuthenticationFailureReason { get; }
ReadOnly Property AuthenticationFailureReason As String
    Get
abstract AuthenticationFailureReason : string with get

function get_AuthenticationFailureReason();

property String^ AuthenticationFailureReason {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.CanChangePassword Property

Grid Solutions Framework ISecurityProviderCanChangePassword Property
Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool CanChangePassword { get; }
ReadOnly Property CanChangePassword As Boolean
    Get
abstract CanChangePassword : bool with get

function get_CanChangePassword();

property bool CanChangePassword {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.CanRefreshData Property

Grid Solutions Framework ISecurityProviderCanRefreshData Property
Gets a boolean value that indicates whether RefreshData operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool CanRefreshData { get; }
ReadOnly Property CanRefreshData As Boolean
    Get
abstract CanRefreshData : bool with get

function get_CanRefreshData();

property bool CanRefreshData {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.CanResetPassword Property

Grid Solutions Framework ISecurityProviderCanResetPassword Property
Gets a boolean value that indicates whether ResetPassword(String) operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool CanResetPassword { get; }
ReadOnly Property CanResetPassword As Boolean
    Get
abstract CanResetPassword : bool with get

function get_CanResetPassword();

property bool CanResetPassword {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.CanUpdateData Property

Grid Solutions Framework ISecurityProviderCanUpdateData Property
Gets a boolean value that indicates whether UpdateData operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool CanUpdateData { get; }
ReadOnly Property CanUpdateData As Boolean
    Get
abstract CanUpdateData : bool with get

function get_CanUpdateData();

property bool CanUpdateData {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.ConnectionString Property

Grid Solutions Framework ISecurityProviderConnectionString Property
Gets or sets the connection string to be used for connection to the backend security data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ConnectionString { get; set; }
Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.LogEvent Property

Grid Solutions Framework ISecurityProviderLogEvent Property
Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
LogEventFunctionSignature LogEvent { get; set; }
Property LogEvent As LogEventFunctionSignature
    Get
    Set
abstract LogEvent : LogEventFunctionSignature with get, set

function get_LogEvent();
function set_LogEvent(value);
property LogEventFunctionSignature^ LogEvent {
    LogEventFunctionSignature^ get ();
    void set (LogEventFunctionSignature^ value);
}

Property Value

Type: LogEventFunctionSignature
Remarks
Set LogEvent to null to use default handler, i.e., WriteEntry(String, String, EventLogEntryType, Int32).
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.Password Property

Grid Solutions Framework ISecurityProviderPassword Property
Gets or sets SecurePassword as clear text password.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Password { get; set; }
Property Password As String
    Get
    Set
abstract Password : string with get, set

function get_Password();
function set_Password(value);
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.SecurePassword Property

Grid Solutions Framework ISecurityProviderSecurePassword Property
Gets or sets the password as a SecureString.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
SecureString SecurePassword { get; set; }
Property SecurePassword As SecureString
    Get
    Set
abstract SecurePassword : SecureString with get, set

function get_SecurePassword();
function set_SecurePassword(value);
property SecureString^ SecurePassword {
    SecureString^ get ();
    void set (SecureString^ value);
}

Property Value

Type: SecureString
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider.UserData Property

Grid Solutions Framework ISecurityProviderUserData Property
Gets the UserData object containing information about the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
UserData UserData { get; }
ReadOnly Property UserData As UserData
    Get
abstract UserData : UserData with get

function get_UserData();

property UserData^ UserData {
    UserData^ get ();
}

Property Value

Type: UserData
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


ISecurityProvider Events

Grid Solutions Framework ISecurityProvider Events

The ISecurityProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Top
See Also

Reference

ISecurityProvider Interface
GSF.Security Namespace


LdapSecurityProvider Class

Grid Solutions Framework LdapSecurityProvider Class
Represents an ISecurityProvider that uses Active Directory for its backend data store and credential authentication.
Inheritance Hierarchy
SystemObject
GSF.SecuritySecurityProviderBase
GSF.SecurityLdapSecurityProvider
GSF.SecurityAdoSecurityProvider

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LdapSecurityProvider : SecurityProviderBase
Public Class LdapSecurityProvider
    Inherits SecurityProviderBase
type LdapSecurityProvider =
    class
        inherit SecurityProviderBase
    end
GSF.Security.LdapSecurityProvider = function();

Type.createClass(
    'GSF.Security.LdapSecurityProvider',
    GSF.Security.SecurityProviderBase);
public ref class LdapSecurityProvider : public SecurityProviderBase

The LdapSecurityProvider type exposes the following members.

Constructors
 | Name | Description
Public method | LdapSecurityProvider(String) | Initializes a new instance of the LdapSecurityProvider class.
Protected method | LdapSecurityProvider(String, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the LdapSecurityProvider class.
Top
Methods
 | Name | Description
Public method | Authenticate | Authenticates the user. (Overrides SecurityProviderBaseAuthenticate(String).)
Public method | ChangePassword | Changes user password in the backend data store. (Overrides SecurityProviderBaseChangePassword(String, String).)
Public method | Dispose | Releases all the resources used by the security provider. (Inherited from SecurityProviderBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the security provider and optionally releases the managed resources. (Inherited from SecurityProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the security provider is reclaimed by GC. (Inherited from SecurityProviderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLdapPath | Gets the LDAP path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the security provider. (Inherited from SecurityProviderBase.)
Public method | LoadSettings | Loads saved LdapSecurityProvider settings from the config file if the PersistSettings property is set to true. (Overrides SecurityProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshData | Refreshes the UserData from the backend data store. (Overrides SecurityProviderBaseRefreshData.)
Protected method | RefreshData(ListString, Int32) | Refreshes the UserData from the backend data store loading user groups into desired collection.
Public method | ResetPassword | Resets user password in the backend data store. (Overrides SecurityProviderBaseResetPassword(String).)
Public method | SaveSettings | Saves LdapSecurityProvider settings to the config file if the PersistSettings property is set to true. (Overrides SecurityProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateRole | Performs a translation of the specified user role. (Overrides SecurityProviderBaseTranslateRole(String).)
Public method | UpdateData | Updates the UserData in the backend data store. (Overrides SecurityProviderBaseUpdateData.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultCacheMaximumRetryAttempts | Specifies the default value for the CacheMaximumRetryAttempts property.
DefaultCacheRetryDelayInterval | Specifies the default value for the CacheRetryDelayInterval property.
DefaultEnableOfflineCaching | Specifies the default value for the EnableOfflineCaching property.
ProviderID | Defines the provider ID for the LdapSecurityProvider.
Top
Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | AuthenticationFailureReason | Gets or allows derived classes to set an authentication failure reason. (Inherited from SecurityProviderBase.)
Public property | CacheMaximumRetryAttempts | Gets or sets the maximum retry attempts allowed for loading offline user data cache.
Public property | CacheRetryDelayInterval | Gets or sets the wait interval (in milliseconds) before retrying load of offline user data cache.
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanUpdateData | Geta a boolean value that indicates whether UpdateData operation is supported. (Inherited from SecurityProviderBase.)
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the security provider is currently enabled. (Inherited from SecurityProviderBase.)
Public property | EnableOfflineCaching | Gets or sets a boolean value that indicates whether user information is to be cached for offline authentication.
Protected property | Initialized | Gets current intialization state. (Inherited from SecurityProviderBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from SecurityProviderBase.)
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation. (Inherited from SecurityProviderBase.)
Public property | Password | Gets or sets SecurePassword as clear text password. (Inherited from SecurityProviderBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether security provider settings are to be saved to the config file. (Inherited from SecurityProviderBase.)
Public property | SecurePassword | Gets or sets the password as a SecureString. (Inherited from SecurityProviderBase.)
Public property | SettingsCategory | Gets or sets the category under which security provider settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from SecurityProviderBase.)
Public property | UserData | Gets the UserData object containing information about the user. (Inherited from SecurityProviderBase.)
Public property | WindowsPrincipal | Gets the original WindowsPrincipal of the user if the user exists in Active Directory.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed. (Inherited from SecurityProviderBase.)
Top
Remarks
A Security Identifier can also be specified in IncludedResources instead of a role name in the format of 'SID:<Security Identifier>' (Example: SID:S-1-5-21-19610888-1443184010-1631745340-269783).
Examples
Required config file entries:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ApplicationName" value="" description="Name of the application being secured as defined in the backend security datastore."
        encrypted="false" />
      <add name="ConnectionString" value="LDAP://DC=COMPANY,DC=COM" description="Connection string to be used for connection to the backend security data store."
        encrypted="false" />
      <add name="ProviderType" value="GSF.Security.LdapSecurityProvider, GSF.Security" description="The type to be used for enforcing security."
        encrypted="false" />
      <add name="UserCacheTimeout" value="5" description="Defines the timeout, in whole minutes, for a user's provider cache. Any value less than 1 will cause cache reset every minute."
        encrypted="false" />
      <add name="IncludedResources" value="*=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="" description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
      <add name="EnableOfflineCaching" value="True" description="True to enable caching of user information for authentication in offline state, otherwise False."
        encrypted="false" />
      <add name="CacheRetryDelayInterval" value="200" description="Wait interval, in milliseconds, before retrying load of user data cache."
        encrypted="false" />
      <add name="CacheMaximumRetryAttempts" value="10" description="Maximum retry attempts allowed for loading user data cache."
        encrypted="false" />
    </securityProvider>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.Security Namespace


LdapSecurityProvider Constructor

Grid Solutions Framework LdapSecurityProvider Constructor
Overload List
 | Name | Description
Public method | LdapSecurityProvider(String) | Initializes a new instance of the LdapSecurityProvider class.
Protected method | LdapSecurityProvider(String, Boolean, Boolean, Boolean, Boolean) | Initializes a new instance of the LdapSecurityProvider class.
Top
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider Constructor (String)

Grid Solutions Framework LdapSecurityProvider Constructor (String)
Initializes a new instance of the LdapSecurityProvider class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LdapSecurityProvider(
    string username
)
Public Sub New (
    username As String
)
new :
        username : string -> LdapSecurityProvider
GSF.Security.LdapSecurityProvider = function(username);
public:
LdapSecurityProvider(
    String^ username
)

Parameters

username
Type: SystemString
Name that uniquely identifies the user.
See Also

Reference

LdapSecurityProvider Class
LdapSecurityProvider Overload
GSF.Security Namespace


LdapSecurityProvider Constructor (String, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework LdapSecurityProvider Constructor (String, Boolean, Boolean, Boolean, Boolean)
Initializes a new instance of the LdapSecurityProvider class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected LdapSecurityProvider(
    string username,
    bool canRefreshData,
    bool canUpdateData,
    bool canResetPassword,
    bool canChangePassword
)
Protected Sub New (
    username As String,
    canRefreshData As Boolean,
    canUpdateData As Boolean,
    canResetPassword As Boolean,
    canChangePassword As Boolean
)
new :
        username : string *
        canRefreshData : bool *
        canUpdateData : bool *
        canResetPassword : bool *
        canChangePassword : bool -> LdapSecurityProvider
GSF.Security.LdapSecurityProvider = function(username, canRefreshData, canUpdateData, canResetPassword, canChangePassword);
protected:
LdapSecurityProvider(
    String^ username,
    bool canRefreshData,
    bool canUpdateData,
    bool canResetPassword,
    bool canChangePassword
)

Parameters

username
Type: SystemString
Name that uniquely identifies the user.
canRefreshData
Type: SystemBoolean
true if the security provider can refresh UserData from the backend data store, otherwise false.
canUpdateData
Type: SystemBoolean
true if the security provider can update UserData in the backend data store, otherwise false.
canResetPassword
Type: SystemBoolean
true if the security provider can reset user password, otherwise false.
canChangePassword
Type: SystemBoolean
true if the security provider can change user password, otherwise false.
See Also

Reference

LdapSecurityProvider Class
LdapSecurityProvider Overload
GSF.Security Namespace


LdapSecurityProvider Fields

Grid Solutions Framework LdapSecurityProvider Fields

The LdapSecurityProvider type exposes the following members.

Fields
Name | Description
DefaultCacheMaximumRetryAttempts | Specifies the default value for the CacheMaximumRetryAttempts property.
DefaultCacheRetryDelayInterval | Specifies the default value for the CacheRetryDelayInterval property.
DefaultEnableOfflineCaching | Specifies the default value for the EnableOfflineCaching property.
ProviderID | Defines the provider ID for the LdapSecurityProvider.
Top
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.DefaultCacheMaximumRetryAttempts Field

Grid Solutions Framework LdapSecurityProviderDefaultCacheMaximumRetryAttempts Field
Specifies the default value for the CacheMaximumRetryAttempts property.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultCacheMaximumRetryAttempts
Public Const DefaultCacheMaximumRetryAttempts As Integer
static val mutable DefaultCacheMaximumRetryAttempts: int
var GSF.Security.LdapSecurityProvider.DefaultCacheMaximumRetryAttempts
public:
literal int DefaultCacheMaximumRetryAttempts

Field Value

Type: Int32
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.DefaultCacheRetryDelayInterval Field

Grid Solutions Framework LdapSecurityProviderDefaultCacheRetryDelayInterval Field
Specifies the default value for the CacheRetryDelayInterval property.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultCacheRetryDelayInterval
Public Const DefaultCacheRetryDelayInterval As Double
static val mutable DefaultCacheRetryDelayInterval: float
var GSF.Security.LdapSecurityProvider.DefaultCacheRetryDelayInterval
public:
literal double DefaultCacheRetryDelayInterval

Field Value

Type: Double
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.DefaultEnableOfflineCaching Field

Grid Solutions Framework LdapSecurityProviderDefaultEnableOfflineCaching Field
Specifies the default value for the EnableOfflineCaching property.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultEnableOfflineCaching
Public Const DefaultEnableOfflineCaching As Boolean
static val mutable DefaultEnableOfflineCaching: bool
var GSF.Security.LdapSecurityProvider.DefaultEnableOfflineCaching
public:
literal bool DefaultEnableOfflineCaching

Field Value

Type: Boolean
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.ProviderID Field

Grid Solutions Framework LdapSecurityProviderProviderID Field
Defines the provider ID for the LdapSecurityProvider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ProviderID
Public Const ProviderID As Integer
static val mutable ProviderID: int
var GSF.Security.LdapSecurityProvider.ProviderID
public:
literal int ProviderID

Field Value

Type: Int32
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider Methods

Grid Solutions Framework LdapSecurityProvider Methods

The LdapSecurityProvider type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Authenticates the user. (Overrides SecurityProviderBaseAuthenticate(String).)
Public method | ChangePassword | Changes user password in the backend data store. (Overrides SecurityProviderBaseChangePassword(String, String).)
Public method | Dispose | Releases all the resources used by the security provider. (Inherited from SecurityProviderBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the security provider and optionally releases the managed resources. (Inherited from SecurityProviderBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the security provider is reclaimed by GC. (Inherited from SecurityProviderBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLdapPath | Gets the LDAP path.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the security provider. (Inherited from SecurityProviderBase.)
Public method | LoadSettings | Loads saved LdapSecurityProvider settings from the config file if the PersistSettings property is set to true. (Overrides SecurityProviderBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshData | Refreshes the UserData from the backend data store. (Overrides SecurityProviderBaseRefreshData.)
Protected method | RefreshData(ListString, Int32) | Refreshes the UserData from the backend data store loading user groups into desired collection.
Public method | ResetPassword | Resets user password in the backend data store. (Overrides SecurityProviderBaseResetPassword(String).)
Public method | SaveSettings | Saves LdapSecurityProvider settings to the config file if the PersistSettings property is set to true. (Overrides SecurityProviderBaseSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateRole | Performs a translation of the specified user role. (Overrides SecurityProviderBaseTranslateRole(String).)
Public method | UpdateData | Updates the UserData in the backend data store. (Overrides SecurityProviderBaseUpdateData.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.Authenticate Method

Grid Solutions Framework LdapSecurityProviderAuthenticate Method
Authenticates the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Authenticate(
    string password
)
Public Overrides Function Authenticate (
    password As String
) As Boolean
abstract Authenticate :
        password : string -> bool
override Authenticate :
        password : string -> bool
function Authenticate(password);
public:
virtual bool Authenticate(
    String^ password
) override

Parameters

password
Type: SystemString
Password to be used for authentication.

Return Value

Type: Boolean
true if the user is authenticated, otherwise false.

Implements

ISecurityProviderAuthenticate(String)
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.ChangePassword Method

Grid Solutions Framework LdapSecurityProviderChangePassword Method
Changes user password in the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ChangePassword(
    string oldPassword,
    string newPassword
)
Public Overrides Function ChangePassword (
    oldPassword As String,
    newPassword As String
) As Boolean
abstract ChangePassword :
        oldPassword : string *
        newPassword : string -> bool
override ChangePassword :
        oldPassword : string *
        newPassword : string -> bool
function ChangePassword(oldPassword, newPassword);
public:
virtual bool ChangePassword(
    String^ oldPassword,
    String^ newPassword
) override

Parameters

oldPassword
Type: SystemString
User's current password.
newPassword
Type: SystemString
User's new password.

Return Value

Type: Boolean
true if the password is changed, otherwise false.

Implements

ISecurityProviderChangePassword(String, String)
Remarks
This method always returns false under Mono deployments.
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.GetLdapPath Method

Grid Solutions Framework LdapSecurityProviderGetLdapPath Method
Gets the LDAP path.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetLdapPath()
Protected Overridable Function GetLdapPath As String
abstract GetLdapPath : unit -> string
override GetLdapPath : unit -> string
function GetLdapPath();
protected:
virtual String^ GetLdapPath()

Return Value

Type: String
The LDAP path.
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.LoadSettings Method

Grid Solutions Framework LdapSecurityProviderLoadSettings Method
Loads saved LdapSecurityProvider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.RefreshData Method

Grid Solutions Framework LdapSecurityProviderRefreshData Method
Overload List
 | Name | Description
Public method | RefreshData | Refreshes the UserData from the backend data store. (Overrides SecurityProviderBaseRefreshData.)
Protected method | RefreshData(ListString, Int32) | Refreshes the UserData from the backend data store loading user groups into desired collection.
Top
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.RefreshData Method

Grid Solutions Framework LdapSecurityProviderRefreshData Method
Refreshes the UserData from the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool RefreshData()
Public Overrides Function RefreshData As Boolean
abstract RefreshData : unit -> bool
override RefreshData : unit -> bool
function RefreshData();
public:
virtual bool RefreshData() override

Return Value

Type: Boolean
true if UserData is refreshed, otherwise false.

Implements

ISecurityProviderRefreshData
See Also

Reference

LdapSecurityProvider Class
RefreshData Overload
GSF.Security Namespace


LdapSecurityProvider.RefreshData Method (List(String), Int32)

Grid Solutions Framework LdapSecurityProviderRefreshData Method (ListString, Int32)
Refreshes the UserData from the backend data store loading user groups into desired collection.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool RefreshData(
    List<string> groupCollection,
    int providerID
)
Protected Overridable Function RefreshData (
    groupCollection As List(Of String),
    providerID As Integer
) As Boolean
abstract RefreshData :
        groupCollection : List<string> *
        providerID : int -> bool
override RefreshData :
        groupCollection : List<string> *
        providerID : int -> bool
function RefreshData(groupCollection, providerID);
protected:
virtual bool RefreshData(
    List<String^>^ groupCollection,
    int providerID
)

Parameters

groupCollection
Type: System.Collections.GenericList String
Target collection for user groups.
providerID
Type: SystemInt32
Unique provider ID used to distinguish cached user data that may be different based on provider.

Return Value

Type: Boolean
true if UserData is refreshed, otherwise false.
See Also

Reference

LdapSecurityProvider Class
RefreshData Overload
GSF.Security Namespace


LdapSecurityProvider.ResetPassword Method

Grid Solutions Framework LdapSecurityProviderResetPassword Method
Resets user password in the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool ResetPassword(
    string securityAnswer
)
Public Overrides Function ResetPassword (
    securityAnswer As String
) As Boolean
abstract ResetPassword :
        securityAnswer : string -> bool
override ResetPassword :
        securityAnswer : string -> bool
function ResetPassword(securityAnswer);
public:
virtual bool ResetPassword(
    String^ securityAnswer
) override

Parameters

securityAnswer
Type: SystemString
Answer to the user's security question.

Return Value

Type: Boolean
true if the password is reset, otherwise false.

Implements

ISecurityProviderResetPassword(String)
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.SaveSettings Method

Grid Solutions Framework LdapSecurityProviderSaveSettings Method
Saves LdapSecurityProvider settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.TranslateRole Method

Grid Solutions Framework LdapSecurityProviderTranslateRole Method
Performs a translation of the specified user role.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string TranslateRole(
    string role
)
Public Overrides Function TranslateRole (
    role As String
) As String
abstract TranslateRole :
        role : string -> string
override TranslateRole :
        role : string -> string
function TranslateRole(role);
public:
virtual String^ TranslateRole(
    String^ role
) override

Parameters

role
Type: SystemString
The user role to be translated.

Return Value

Type: String
The user role that the specified user role translates to.

Implements

ISecurityProviderTranslateRole(String)
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.UpdateData Method

Grid Solutions Framework LdapSecurityProviderUpdateData Method
Updates the UserData in the backend data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool UpdateData()
Public Overrides Function UpdateData As Boolean
abstract UpdateData : unit -> bool
override UpdateData : unit -> bool
function UpdateData();
public:
virtual bool UpdateData() override

Return Value

Type: Boolean
true if UserData is updated, otherwise false.

Implements

ISecurityProviderUpdateData
Exceptions
Exception | Condition
NotSupportedException | Always
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider Properties

Grid Solutions Framework LdapSecurityProvider Properties

The LdapSecurityProvider type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | AuthenticationFailureReason | Gets or allows derived classes to set an authentication failure reason. (Inherited from SecurityProviderBase.)
Public property | CacheMaximumRetryAttempts | Gets or sets the maximum retry attempts allowed for loading offline user data cache.
Public property | CacheRetryDelayInterval | Gets or sets the wait interval (in milliseconds) before retrying load of offline user data cache.
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported. (Inherited from SecurityProviderBase.)
Public property | CanUpdateData | Geta a boolean value that indicates whether UpdateData operation is supported. (Inherited from SecurityProviderBase.)
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security datastore. (Inherited from SecurityProviderBase.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the security provider is currently enabled. (Inherited from SecurityProviderBase.)
Public property | EnableOfflineCaching | Gets or sets a boolean value that indicates whether user information is to be cached for offline authentication.
Protected property | Initialized | Gets current intialization state. (Inherited from SecurityProviderBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from SecurityProviderBase.)
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation. (Inherited from SecurityProviderBase.)
Public property | Password | Gets or sets SecurePassword as clear text password. (Inherited from SecurityProviderBase.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether security provider settings are to be saved to the config file. (Inherited from SecurityProviderBase.)
Public property | SecurePassword | Gets or sets the password as a SecureString. (Inherited from SecurityProviderBase.)
Public property | SettingsCategory | Gets or sets the category under which security provider settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from SecurityProviderBase.)
Public property | UserData | Gets the UserData object containing information about the user. (Inherited from SecurityProviderBase.)
Public property | WindowsPrincipal | Gets the original WindowsPrincipal of the user if the user exists in Active Directory.
Top
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.CacheMaximumRetryAttempts Property

Grid Solutions Framework LdapSecurityProviderCacheMaximumRetryAttempts Property
Gets or sets the maximum retry attempts allowed for loading offline user data cache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CacheMaximumRetryAttempts { get; set; }
Public Property CacheMaximumRetryAttempts As Integer
    Get
    Set
member CacheMaximumRetryAttempts : int with get, set

function get_CacheMaximumRetryAttempts();
function set_CacheMaximumRetryAttempts(value);
public:
property int CacheMaximumRetryAttempts {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.CacheRetryDelayInterval Property

Grid Solutions Framework LdapSecurityProviderCacheRetryDelayInterval Property
Gets or sets the wait interval (in milliseconds) before retrying load of offline user data cache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CacheRetryDelayInterval { get; set; }
Public Property CacheRetryDelayInterval As Double
    Get
    Set
member CacheRetryDelayInterval : float with get, set

function get_CacheRetryDelayInterval();
function set_CacheRetryDelayInterval(value);
public:
property double CacheRetryDelayInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.EnableOfflineCaching Property

Grid Solutions Framework LdapSecurityProviderEnableOfflineCaching Property
Gets or sets a boolean value that indicates whether user information is to be cached for offline authentication.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool EnableOfflineCaching { get; set; }
Public Property EnableOfflineCaching As Boolean
    Get
    Set
member EnableOfflineCaching : bool with get, set

function get_EnableOfflineCaching();
function set_EnableOfflineCaching(value);
public:
property bool EnableOfflineCaching {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider.WindowsPrincipal Property

Grid Solutions Framework LdapSecurityProviderWindowsPrincipal Property
Gets the original WindowsPrincipal of the user if the user exists in Active Directory.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WindowsPrincipal WindowsPrincipal { get; protected set; }
Public Property WindowsPrincipal As WindowsPrincipal
    Get
    Protected Set
member WindowsPrincipal : WindowsPrincipal with get, set

function get_WindowsPrincipal();
function set_WindowsPrincipal(value);
public:
property WindowsPrincipal^ WindowsPrincipal {
    WindowsPrincipal^ get ();
    protected: void set (WindowsPrincipal^ value);
}

Property Value

Type: WindowsPrincipal
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LdapSecurityProvider Events

Grid Solutions Framework LdapSecurityProvider Events

The LdapSecurityProvider type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed. (Inherited from SecurityProviderBase.)
Top
See Also

Reference

LdapSecurityProvider Class
GSF.Security Namespace


LogEventFunctionSignature Delegate

Grid Solutions Framework LogEventFunctionSignature Delegate
Defines the function signature delegate used for logging events from the ISecurityProvider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate void LogEventFunctionSignature(
    string source,
    string message,
    EventLogEntryType type,
    int eventID
)
Public Delegate Sub LogEventFunctionSignature (
    source As String,
    message As String,
    type As EventLogEntryType,
    eventID As Integer
)
type LogEventFunctionSignature =
    delegate of
        source : string *
        message : string *
        type : EventLogEntryType *
        eventID : int -> unit
function(source, message, type, eventID);
public delegate void LogEventFunctionSignature(
    String^ source,
    String^ message,
    EventLogEntryType type,
    int eventID
)

Parameters

source
Type: SystemString
The source by which the application is registered on the specified computer.
message
Type: SystemString
The string to write to the event log.
type
Type: System.DiagnosticsEventLogEntryType
One of the EventLogEntryType values.
eventID
Type: SystemInt32
The application-specific identifier for the event.
See Also

Reference

GSF.Security Namespace


RestrictAccessAttribute Class

Grid Solutions Framework RestrictAccessAttribute Class
Represents an Attribute that can be used restrict access to a class when using role-based security.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.SecurityRestrictAccessAttribute

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)]
public class RestrictAccessAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple := false)>
Public Class RestrictAccessAttribute
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class, AllowMultiple = false)>]
type RestrictAccessAttribute =
    class
        inherit Attribute
    end
GSF.Security.RestrictAccessAttribute = function();

Type.createClass(
    'GSF.Security.RestrictAccessAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class, AllowMultiple = false)]
public ref class RestrictAccessAttribute : public Attribute

The RestrictAccessAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | RestrictAccessAttribute | Initializes a new instance of the RestrictAccessAttribute class.
Public method | RestrictAccessAttribute(String) | Initializes a new instance of the RestrictAccessAttribute class.
Top
Methods
 | Name | Description
Public method | CheckAccess | Checks if the current thread principal has at least one of the Roles in order to have access.
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Roles | Gets or sets the list of either roles the current thread principal must have in order to have access.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.Security Namespace


RestrictAccessAttribute Constructor

Grid Solutions Framework RestrictAccessAttribute Constructor
Overload List
 | Name | Description
Public method | RestrictAccessAttribute | Initializes a new instance of the RestrictAccessAttribute class.
Public method | RestrictAccessAttribute(String) | Initializes a new instance of the RestrictAccessAttribute class.
Top
See Also

Reference

RestrictAccessAttribute Class
GSF.Security Namespace


RestrictAccessAttribute Constructor

Grid Solutions Framework RestrictAccessAttribute Constructor
Initializes a new instance of the RestrictAccessAttribute class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RestrictAccessAttribute()
Public Sub New
new : unit -> RestrictAccessAttribute
GSF.Security.RestrictAccessAttribute = function();
public:
RestrictAccessAttribute()
See Also

Reference

RestrictAccessAttribute Class
RestrictAccessAttribute Overload
GSF.Security Namespace


RestrictAccessAttribute Constructor (String[])

Grid Solutions Framework RestrictAccessAttribute Constructor (String)
Initializes a new instance of the RestrictAccessAttribute class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RestrictAccessAttribute(
    params string[] roles
)
Public Sub New (
    ParamArray roles As String()
)
new :
        roles : string[] -> RestrictAccessAttribute
GSF.Security.RestrictAccessAttribute = function(... roles);
public:
RestrictAccessAttribute(
    ... array<String^>^ roles
)

Parameters

roles
Type: SystemString
List of either roles the current thread principal must have in order to have access.
See Also

Reference

RestrictAccessAttribute Class
RestrictAccessAttribute Overload
GSF.Security Namespace


RestrictAccessAttribute Methods

Grid Solutions Framework RestrictAccessAttribute Methods

The RestrictAccessAttribute type exposes the following members.

Methods
 | Name | Description
Public method | CheckAccess | Checks if the current thread principal has at least one of the Roles in order to have access.
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RestrictAccessAttribute Class
GSF.Security Namespace


RestrictAccessAttribute.CheckAccess Method

Grid Solutions Framework RestrictAccessAttributeCheckAccess Method
Checks if the current thread principal has at least one of the Roles in order to have access.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CheckAccess()
Public Function CheckAccess As Boolean
member CheckAccess : unit -> bool

function CheckAccess();
public:
bool CheckAccess()

Return Value

Type: Boolean
true if the current thread principal has access, otherwise false.
See Also

Reference

RestrictAccessAttribute Class
GSF.Security Namespace


RestrictAccessAttribute Properties

Grid Solutions Framework RestrictAccessAttribute Properties

The RestrictAccessAttribute type exposes the following members.

Properties
 | Name | Description
Public property | Roles | Gets or sets the list of either roles the current thread principal must have in order to have access.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

RestrictAccessAttribute Class
GSF.Security Namespace


RestrictAccessAttribute.Roles Property

Grid Solutions Framework RestrictAccessAttributeRoles Property
Gets or sets the list of either roles the current thread principal must have in order to have access.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] Roles { get; set; }
Public Property Roles As String()
    Get
    Set
member Roles : string[] with get, set

function get_Roles();
function set_Roles(value);
public:
property array<String^>^ Roles {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
See Also

Reference

RestrictAccessAttribute Class
GSF.Security Namespace


SecurityIdentity Class

Grid Solutions Framework SecurityIdentity Class
A class that implements IIdentity interface to facilitate custom role-based security.
Inheritance Hierarchy
SystemObject
GSF.SecuritySecurityIdentity

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecurityIdentity : IIdentity
Public Class SecurityIdentity
    Implements IIdentity
type SecurityIdentity =
    class
        interface IIdentity
    end
GSF.Security.SecurityIdentity = function();

Type.createClass(
    'GSF.Security.SecurityIdentity',
    null,
    IIdentity);
public ref class SecurityIdentity : IIdentity

The SecurityIdentity type exposes the following members.

Constructors
 | Name | Description
Public method | SecurityIdentity | Initializes a new instance of the SecurityIdentity class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AuthenticationType | Gets the type of authentication used to identify the user.
Public property | IsAuthenticated | Gets a boolean value that indicates whether the user has been authenticated.
Public property | Name | Gets the user's login name.
Public property | Provider | Gets the ISecurityProvider of the user.
Top
See Also

Reference

GSF.Security Namespace
GSF.SecuritySecurityPrincipal
GSF.SecurityISecurityProvider


SecurityIdentity Constructor

Grid Solutions Framework SecurityIdentity Constructor
Initializes a new instance of the SecurityIdentity class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityIdentity(
    ISecurityProvider provider
)
Public Sub New (
    provider As ISecurityProvider
)
new :
        provider : ISecurityProvider -> SecurityIdentity
GSF.Security.SecurityIdentity = function(provider);
public:
SecurityIdentity(
    ISecurityProvider^ provider
)

Parameters

provider
Type: GSF.SecurityISecurityProvider
An ISecurityProvider of the user.
Exceptions
Exception | Condition
ArgumentNullException | Value specified for provider is null.
See Also

Reference

SecurityIdentity Class
GSF.Security Namespace


SecurityIdentity Methods

Grid Solutions Framework SecurityIdentity Methods

The SecurityIdentity type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecurityIdentity Class
GSF.Security Namespace


SecurityIdentity Properties

Grid Solutions Framework SecurityIdentity Properties

The SecurityIdentity type exposes the following members.

Properties
 | Name | Description
Public property | AuthenticationType | Gets the type of authentication used to identify the user.
Public property | IsAuthenticated | Gets a boolean value that indicates whether the user has been authenticated.
Public property | Name | Gets the user's login name.
Public property | Provider | Gets the ISecurityProvider of the user.
Top
See Also

Reference

SecurityIdentity Class
GSF.Security Namespace


SecurityIdentity.AuthenticationType Property

Grid Solutions Framework SecurityIdentityAuthenticationType Property
Gets the type of authentication used to identify the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AuthenticationType { get; }
Public ReadOnly Property AuthenticationType As String
    Get
abstract AuthenticationType : string with get
override AuthenticationType : string with get
function get_AuthenticationType();

public:
virtual property String^ AuthenticationType {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IIdentityAuthenticationType
See Also

Reference

SecurityIdentity Class
GSF.Security Namespace


SecurityIdentity.IsAuthenticated Property

Grid Solutions Framework SecurityIdentityIsAuthenticated Property
Gets a boolean value that indicates whether the user has been authenticated.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsAuthenticated { get; }
Public ReadOnly Property IsAuthenticated As Boolean
    Get
abstract IsAuthenticated : bool with get
override IsAuthenticated : bool with get
function get_IsAuthenticated();

public:
virtual property bool IsAuthenticated {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IIdentityIsAuthenticated
See Also

Reference

SecurityIdentity Class
GSF.Security Namespace


SecurityIdentity.Name Property

Grid Solutions Framework SecurityIdentityName Property
Gets the user's login name.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IIdentityName
See Also

Reference

SecurityIdentity Class
GSF.Security Namespace


SecurityIdentity.Provider Property

Grid Solutions Framework SecurityIdentityProvider Property
Gets the ISecurityProvider of the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ISecurityProvider Provider { get; }
Public ReadOnly Property Provider As ISecurityProvider
    Get
member Provider : ISecurityProvider with get

function get_Provider();

public:
property ISecurityProvider^ Provider {
    ISecurityProvider^ get ();
}

Property Value

Type: ISecurityProvider
See Also

Reference

SecurityIdentity Class
GSF.Security Namespace


SecurityPrincipal Class

Grid Solutions Framework SecurityPrincipal Class
A class that implements IPrincipal interface to facilitate custom role-based security.
Inheritance Hierarchy
SystemObject
GSF.SecuritySecurityPrincipal

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecurityPrincipal : IPrincipal
Public Class SecurityPrincipal
    Implements IPrincipal
type SecurityPrincipal =
    class
        interface IPrincipal
    end
GSF.Security.SecurityPrincipal = function();

Type.createClass(
    'GSF.Security.SecurityPrincipal',
    null,
    IPrincipal);
public ref class SecurityPrincipal : IPrincipal

The SecurityPrincipal type exposes the following members.

Constructors
 | Name | Description
Public method | SecurityPrincipal | Initializes a new instance of the SecurityPrincipal class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInRole | Determines whether the user is a member of either of the specified roles.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Identity | Gets the SecurityIdentity object of the user.
Top
See Also

Reference

GSF.Security Namespace
GSF.SecuritySecurityIdentity
GSF.SecurityISecurityProvider


SecurityPrincipal Constructor

Grid Solutions Framework SecurityPrincipal Constructor
Initializes a new instance of the SecurityPrincipal class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityPrincipal(
    SecurityIdentity identity
)
Public Sub New (
    identity As SecurityIdentity
)
new :
        identity : SecurityIdentity -> SecurityPrincipal
GSF.Security.SecurityPrincipal = function(identity);
public:
SecurityPrincipal(
    SecurityIdentity^ identity
)

Parameters

identity
Type: GSF.SecuritySecurityIdentity
An SecurityIdentity object.
Exceptions
Exception | Condition
ArgumentNullException | Value specified for identity is null.
See Also

Reference

SecurityPrincipal Class
GSF.Security Namespace


SecurityPrincipal Methods

Grid Solutions Framework SecurityPrincipal Methods

The SecurityPrincipal type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsInRole | Determines whether the user is a member of either of the specified roles.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecurityPrincipal Class
GSF.Security Namespace


SecurityPrincipal.IsInRole Method

Grid Solutions Framework SecurityPrincipalIsInRole Method
Determines whether the user is a member of either of the specified roles.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsInRole(
    string roles
)
Public Function IsInRole (
    roles As String
) As Boolean
abstract IsInRole :
        roles : string -> bool
override IsInRole :
        roles : string -> bool
function IsInRole(roles);
public:
virtual bool IsInRole(
    String^ roles
) sealed

Parameters

roles
Type: SystemString
Comma separated list of roles to check.

Return Value

Type: Boolean
true if the user is a member of either of the specified roles, otherwise false.

Implements

IPrincipalIsInRole(String)
See Also

Reference

SecurityPrincipal Class
GSF.Security Namespace


SecurityPrincipal Properties

Grid Solutions Framework SecurityPrincipal Properties

The SecurityPrincipal type exposes the following members.

Properties
 | Name | Description
Public property | Identity | Gets the SecurityIdentity object of the user.
Top
See Also

Reference

SecurityPrincipal Class
GSF.Security Namespace


SecurityPrincipal.Identity Property

Grid Solutions Framework SecurityPrincipalIdentity Property
Gets the SecurityIdentity object of the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IIdentity Identity { get; }
Public ReadOnly Property Identity As IIdentity
    Get
abstract Identity : IIdentity with get
override Identity : IIdentity with get
function get_Identity();

public:
virtual property IIdentity^ Identity {
    IIdentity^ get () sealed;
}

Property Value

Type: IIdentity

Implements

IPrincipalIdentity
See Also

Reference

SecurityPrincipal Class
GSF.Security Namespace


SecurityProviderBase Class

Grid Solutions Framework SecurityProviderBase Class
Base class for a provider of role-based security in applications.
Inheritance Hierarchy
SystemObject
GSF.SecuritySecurityProviderBase
GSF.SecurityLdapSecurityProvider

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class SecurityProviderBase : ISecurityProvider,
    ISupportLifecycle, IDisposable, IPersistSettings
Public MustInherit Class SecurityProviderBase
    Implements ISecurityProvider, ISupportLifecycle, IDisposable, IPersistSettings
[<AbstractClassAttribute>]
type SecurityProviderBase =
    class
        interface ISecurityProvider
        interface ISupportLifecycle
        interface IDisposable
        interface IPersistSettings
    end
GSF.Security.SecurityProviderBase = function();

Type.createClass(
    'GSF.Security.SecurityProviderBase',
    null,
    GSF.Security.ISecurityProvider,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.Configuration.IPersistSettings);
public ref class SecurityProviderBase abstract : ISecurityProvider,
    ISupportLifecycle, IDisposable, IPersistSettings

The SecurityProviderBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SecurityProviderBase | Initializes a new instance of the security provider.
Top
Methods
 | Name | Description
Public method | Authenticate | When overridden in a derived class, authenticates the user.
Public method | ChangePassword | When overridden in a derived class, changes user password in the backend datastore.
Public method | Dispose | Releases all the resources used by the security provider.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the security provider and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the security provider is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the security provider.
Public method | LoadSettings | Loads saved security provider settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshData | When overridden in a derived class, refreshes the UserData from the backend datastore.
Public method | ResetPassword | When overridden in a derived class, resets user password in the backend datastore.
Public method | SaveSettings | Saves security provider settings to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateRole | Performs a translation of the specified user role.
Public method | UpdateData | When overridden in a derived class, updates the UserData in the backend datastore.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultApplicationName | Specifies the default value for the ApplicationName property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security datastore.
Public property | AuthenticationFailureReason | Gets or allows derived classes to set an authentication failure reason.
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported.
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported.
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported.
Public property | CanUpdateData | Geta a boolean value that indicates whether UpdateData operation is supported.
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security datastore.
Public property | Enabled | Gets or sets a boolean value that indicates whether the security provider is currently enabled.
Protected property | Initialized | Gets current intialization state.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation.
Public property | Password | Gets or sets SecurePassword as clear text password.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether security provider settings are to be saved to the config file.
Public property | SecurePassword | Gets or sets the password as a SecureString.
Public property | SettingsCategory | Gets or sets the category under which security provider settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | UserData | Gets the UserData object containing information about the user.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed.
Top
Examples
This examples shows how to extend SecurityProviderBase to use a flat-file for the security data store:
Copy
using System.Data;
using System.IO;
using GSF;
using GSF.Data;
using GSF.IO;
using GSF.Security;

namespace CustomSecurity
{
    public class FlatFileSecurityProvider : SecurityProviderBase
    {
        private const int LeastPrivilegedLevel = 5;

        public FlatFileSecurityProvider(string username)
            : base(username)
        {
        }

        public override bool RefreshData()
        {
            // Check for a valid username.
            if (string.IsNullOrEmpty(UserData.Username))
                return false;

            // Check if a file name is specified.
            if (string.IsNullOrEmpty(ConnectionString))
                return false;

            // Check if file exist on file system.
            string file = FilePath.GetAbsolutePath(ConnectionString);
            if (!File.Exists(file))
                return false;

            // Read the data from the specified file.
            DataTable data = File.ReadAllText(file).ToDataTable(",", true);
            DataRow[] user = data.Select(string.Format("Username = '{0}'", UserData.Username));
            if (user.Length > 0)
            {
                // User exists in the specified file.
                UserData.IsDefined = true;
                UserData.Password = user[0]["Password"].ToNonNullString();

                for (int i = LeastPrivilegedLevel; i >= int.Parse(user[0]["Level"].ToNonNullString()); i--)
                {
                    UserData.Roles.Add(i.ToString());
                }
            }

            return true;
        }

        public override bool Authenticate(string password)
        {
            // Compare password hashes to authenticate.
            return (UserData.Password == SecurityProviderUtility.EncryptPassword(password));
        }
    }
}
Config file entries that go along with the above example:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ApplicationName" value="SEC_APP" description="Name of the application being secured as defined in the backend security datastore."
        encrypted="false" />
      <add name="ConnectionString" value="Security.csv" description="Connection string to be used for connection to the backend security datastore."
        encrypted="false" />
      <add name="ProviderType" value="CustomSecurity.FlatFileSecurityProvider, CustomSecurity"
        description="The type to be used for enforcing security." encrypted="false" />
      <add name="IncludedResources" value="*=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="" description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
    </securityProvider>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.Security Namespace
GSF.SecuritySecurityIdentity
GSF.SecuritySecurityPrincipal


SecurityProviderBase Constructor

Grid Solutions Framework SecurityProviderBase Constructor
Initializes a new instance of the security provider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected SecurityProviderBase(
    string username,
    bool canRefreshData,
    bool canUpdateData,
    bool canResetPassword,
    bool canChangePassword
)
Protected Sub New (
    username As String,
    canRefreshData As Boolean,
    canUpdateData As Boolean,
    canResetPassword As Boolean,
    canChangePassword As Boolean
)
new :
        username : string *
        canRefreshData : bool *
        canUpdateData : bool *
        canResetPassword : bool *
        canChangePassword : bool -> SecurityProviderBase
GSF.Security.SecurityProviderBase = function(username, canRefreshData, canUpdateData, canResetPassword, canChangePassword);
protected:
SecurityProviderBase(
    String^ username,
    bool canRefreshData,
    bool canUpdateData,
    bool canResetPassword,
    bool canChangePassword
)

Parameters

username
Type: SystemString
Name that uniquely identifies the user.
canRefreshData
Type: SystemBoolean
true if the security provider can refresh UserData from the backend data store, otherwise false.
canUpdateData
Type: SystemBoolean
true if the security provider can update UserData in the backend data store, otherwise false.
canResetPassword
Type: SystemBoolean
true if the security provider can reset user password, otherwise false.
canChangePassword
Type: SystemBoolean
true if the security provider can change user password, otherwise false.
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase Fields

Grid Solutions Framework SecurityProviderBase Fields

The SecurityProviderBase type exposes the following members.

Fields
Name | Description
DefaultApplicationName | Specifies the default value for the ApplicationName property.
DefaultConnectionString | Specifies the default value for the ConnectionString property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
Top
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.DefaultApplicationName Field

Grid Solutions Framework SecurityProviderBaseDefaultApplicationName Field
Specifies the default value for the ApplicationName property.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultApplicationName
Public Const DefaultApplicationName As String
static val mutable DefaultApplicationName: string
var GSF.Security.SecurityProviderBase.DefaultApplicationName
public:
literal String^ DefaultApplicationName

Field Value

Type: String
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.DefaultConnectionString Field

Grid Solutions Framework SecurityProviderBaseDefaultConnectionString Field
Specifies the default value for the ConnectionString property.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultConnectionString
Public Const DefaultConnectionString As String
static val mutable DefaultConnectionString: string
var GSF.Security.SecurityProviderBase.DefaultConnectionString
public:
literal String^ DefaultConnectionString

Field Value

Type: String
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.DefaultPersistSettings Field

Grid Solutions Framework SecurityProviderBaseDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.Security.SecurityProviderBase.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.DefaultSettingsCategory Field

Grid Solutions Framework SecurityProviderBaseDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.Security.SecurityProviderBase.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase Methods

Grid Solutions Framework SecurityProviderBase Methods

The SecurityProviderBase type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | When overridden in a derived class, authenticates the user.
Public method | ChangePassword | When overridden in a derived class, changes user password in the backend datastore.
Public method | Dispose | Releases all the resources used by the security provider.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the security provider and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the security provider is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the security provider.
Public method | LoadSettings | Loads saved security provider settings from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RefreshData | When overridden in a derived class, refreshes the UserData from the backend datastore.
Public method | ResetPassword | When overridden in a derived class, resets user password in the backend datastore.
Public method | SaveSettings | Saves security provider settings to the config file if the PersistSettings property is set to true.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TranslateRole | Performs a translation of the specified user role.
Public method | UpdateData | When overridden in a derived class, updates the UserData in the backend datastore.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Authenticate Method

Grid Solutions Framework SecurityProviderBaseAuthenticate Method
When overridden in a derived class, authenticates the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool Authenticate(
    string password
)
Public MustOverride Function Authenticate (
    password As String
) As Boolean
abstract Authenticate :
        password : string -> bool

function Authenticate(password);
public:
virtual bool Authenticate(
    String^ password
) abstract

Parameters

password
Type: SystemString
Password to be used for authentication.

Return Value

Type: Boolean
true if the user is authenticated, otherwise false.

Implements

ISecurityProviderAuthenticate(String)
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.ChangePassword Method

Grid Solutions Framework SecurityProviderBaseChangePassword Method
When overridden in a derived class, changes user password in the backend datastore.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool ChangePassword(
    string oldPassword,
    string newPassword
)
Public MustOverride Function ChangePassword (
    oldPassword As String,
    newPassword As String
) As Boolean
abstract ChangePassword :
        oldPassword : string *
        newPassword : string -> bool

function ChangePassword(oldPassword, newPassword);
public:
virtual bool ChangePassword(
    String^ oldPassword,
    String^ newPassword
) abstract

Parameters

oldPassword
Type: SystemString
User's current password.
newPassword
Type: SystemString
User's new password.

Return Value

Type: Boolean
true if the password is changed, otherwise false.

Implements

ISecurityProviderChangePassword(String, String)
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Dispose Method

Grid Solutions Framework SecurityProviderBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the security provider.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the security provider and optionally releases the managed resources.
Top
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Dispose Method

Grid Solutions Framework SecurityProviderBaseDispose Method
Releases all the resources used by the security provider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

SecurityProviderBase Class
Dispose Overload
GSF.Security Namespace


SecurityProviderBase.Dispose Method (Boolean)

Grid Solutions Framework SecurityProviderBaseDispose Method (Boolean)
Releases the unmanaged resources used by the security provider and optionally releases the managed resources.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

SecurityProviderBase Class
Dispose Overload
GSF.Security Namespace


SecurityProviderBase.Finalize Method

Grid Solutions Framework SecurityProviderBaseFinalize Method
Releases the unmanaged resources before the security provider is reclaimed by GC.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Initialize Method

Grid Solutions Framework SecurityProviderBaseInitialize Method
Initializes the security provider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize()

Implements

ISupportLifecycleInitialize
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.LoadSettings Method

Grid Solutions Framework SecurityProviderBaseLoadSettings Method
Loads saved security provider settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void LoadSettings()
Public Overridable Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings()

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.RefreshData Method

Grid Solutions Framework SecurityProviderBaseRefreshData Method
When overridden in a derived class, refreshes the UserData from the backend datastore.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool RefreshData()
Public MustOverride Function RefreshData As Boolean
abstract RefreshData : unit -> bool

function RefreshData();
public:
virtual bool RefreshData() abstract

Return Value

Type: Boolean
true if UserData is refreshed, otherwise false.

Implements

ISecurityProviderRefreshData
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.ResetPassword Method

Grid Solutions Framework SecurityProviderBaseResetPassword Method
When overridden in a derived class, resets user password in the backend datastore.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool ResetPassword(
    string securityAnswer
)
Public MustOverride Function ResetPassword (
    securityAnswer As String
) As Boolean
abstract ResetPassword :
        securityAnswer : string -> bool

function ResetPassword(securityAnswer);
public:
virtual bool ResetPassword(
    String^ securityAnswer
) abstract

Parameters

securityAnswer
Type: SystemString
Answer to the user's security question.

Return Value

Type: Boolean
true if the password is reset, otherwise false.

Implements

ISecurityProviderResetPassword(String)
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.SaveSettings Method

Grid Solutions Framework SecurityProviderBaseSaveSettings Method
Saves security provider settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SaveSettings()
Public Overridable Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings()

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.TranslateRole Method

Grid Solutions Framework SecurityProviderBaseTranslateRole Method
Performs a translation of the specified user role.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string TranslateRole(
    string role
)
Public Overridable Function TranslateRole (
    role As String
) As String
abstract TranslateRole :
        role : string -> string
override TranslateRole :
        role : string -> string
function TranslateRole(role);
public:
virtual String^ TranslateRole(
    String^ role
)

Parameters

role
Type: SystemString
The user role to be translated.

Return Value

Type: String
The user role that the specified user role translates to.

Implements

ISecurityProviderTranslateRole(String)
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.UpdateData Method

Grid Solutions Framework SecurityProviderBaseUpdateData Method
When overridden in a derived class, updates the UserData in the backend datastore.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool UpdateData()
Public MustOverride Function UpdateData As Boolean
abstract UpdateData : unit -> bool

function UpdateData();
public:
virtual bool UpdateData() abstract

Return Value

Type: Boolean
true if UserData is updated, otherwise false.

Implements

ISecurityProviderUpdateData
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase Properties

Grid Solutions Framework SecurityProviderBase Properties

The SecurityProviderBase type exposes the following members.

Properties
 | Name | Description
Public property | ApplicationName | Gets or sets the name of the application being secured as defined in the backend security datastore.
Public property | AuthenticationFailureReason | Gets or allows derived classes to set an authentication failure reason.
Public property | CanChangePassword | Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported.
Public property | CanRefreshData | Gets a boolean value that indicates whether RefreshData operation is supported.
Public property | CanResetPassword | Gets a boolean value that indicates whether ResetPassword(String) operation is supported.
Public property | CanUpdateData | Geta a boolean value that indicates whether UpdateData operation is supported.
Public property | ConnectionString | Gets or sets the connection string to be used for connection to the backend security datastore.
Public property | Enabled | Gets or sets a boolean value that indicates whether the security provider is currently enabled.
Protected property | Initialized | Gets current intialization state.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LogEvent | Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation.
Public property | Password | Gets or sets SecurePassword as clear text password.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether security provider settings are to be saved to the config file.
Public property | SecurePassword | Gets or sets the password as a SecureString.
Public property | SettingsCategory | Gets or sets the category under which security provider settings are to be saved to the config file if the PersistSettings property is set to true.
Public property | UserData | Gets the UserData object containing information about the user.
Top
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.ApplicationName Property

Grid Solutions Framework SecurityProviderBaseApplicationName Property
Gets or sets the name of the application being secured as defined in the backend security datastore.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ApplicationName { get; set; }
Public Property ApplicationName As String
    Get
    Set
abstract ApplicationName : string with get, set
override ApplicationName : string with get, set
function get_ApplicationName();
function set_ApplicationName(value);
public:
virtual property String^ ApplicationName {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISecurityProviderApplicationName
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.AuthenticationFailureReason Property

Grid Solutions Framework SecurityProviderBaseAuthenticationFailureReason Property
Gets or allows derived classes to set an authentication failure reason.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string AuthenticationFailureReason { get; protected set; }
Public Overridable Property AuthenticationFailureReason As String
    Get
    Protected Set
abstract AuthenticationFailureReason : string with get, set
override AuthenticationFailureReason : string with get, set
function get_AuthenticationFailureReason();
function set_AuthenticationFailureReason(value);
public:
virtual property String^ AuthenticationFailureReason {
    String^ get ();
    protected: void set (String^ value);
}

Property Value

Type: String

Implements

ISecurityProviderAuthenticationFailureReason
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.CanChangePassword Property

Grid Solutions Framework SecurityProviderBaseCanChangePassword Property
Gets a boolean value that indicates whether ChangePassword(String, String) operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool CanChangePassword { get; }
Public Overridable ReadOnly Property CanChangePassword As Boolean
    Get
abstract CanChangePassword : bool with get
override CanChangePassword : bool with get
function get_CanChangePassword();

public:
virtual property bool CanChangePassword {
    bool get ();
}

Property Value

Type: Boolean

Implements

ISecurityProviderCanChangePassword
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.CanRefreshData Property

Grid Solutions Framework SecurityProviderBaseCanRefreshData Property
Gets a boolean value that indicates whether RefreshData operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool CanRefreshData { get; }
Public Overridable ReadOnly Property CanRefreshData As Boolean
    Get
abstract CanRefreshData : bool with get
override CanRefreshData : bool with get
function get_CanRefreshData();

public:
virtual property bool CanRefreshData {
    bool get ();
}

Property Value

Type: Boolean

Implements

ISecurityProviderCanRefreshData
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.CanResetPassword Property

Grid Solutions Framework SecurityProviderBaseCanResetPassword Property
Gets a boolean value that indicates whether ResetPassword(String) operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool CanResetPassword { get; }
Public Overridable ReadOnly Property CanResetPassword As Boolean
    Get
abstract CanResetPassword : bool with get
override CanResetPassword : bool with get
function get_CanResetPassword();

public:
virtual property bool CanResetPassword {
    bool get ();
}

Property Value

Type: Boolean

Implements

ISecurityProviderCanResetPassword
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.CanUpdateData Property

Grid Solutions Framework SecurityProviderBaseCanUpdateData Property
Geta a boolean value that indicates whether UpdateData operation is supported.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool CanUpdateData { get; }
Public Overridable ReadOnly Property CanUpdateData As Boolean
    Get
abstract CanUpdateData : bool with get
override CanUpdateData : bool with get
function get_CanUpdateData();

public:
virtual property bool CanUpdateData {
    bool get ();
}

Property Value

Type: Boolean

Implements

ISecurityProviderCanUpdateData
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.ConnectionString Property

Grid Solutions Framework SecurityProviderBaseConnectionString Property
Gets or sets the connection string to be used for connection to the backend security datastore.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set
override ConnectionString : string with get, set
function get_ConnectionString();
function set_ConnectionString(value);
public:
virtual property String^ ConnectionString {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISecurityProviderConnectionString
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Enabled Property

Grid Solutions Framework SecurityProviderBaseEnabled Property
Gets or sets a boolean value that indicates whether the security provider is currently enabled.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Initialized Property

Grid Solutions Framework SecurityProviderBaseInitialized Property
Gets current intialization state.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool Initialized { get; }
Protected ReadOnly Property Initialized As Boolean
    Get
member Initialized : bool with get

function get_Initialized();

protected:
property bool Initialized {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.IsDisposed Property

Grid Solutions Framework SecurityProviderBaseIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.LogEvent Property

Grid Solutions Framework SecurityProviderBaseLogEvent Property
Gets or sets the LogEventFunctionSignature to use for logging security events for the SecurityProviderBase implementation.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual LogEventFunctionSignature LogEvent { get; set; }
Public Overridable Property LogEvent As LogEventFunctionSignature
    Get
    Set
abstract LogEvent : LogEventFunctionSignature with get, set
override LogEvent : LogEventFunctionSignature with get, set
function get_LogEvent();
function set_LogEvent(value);
public:
virtual property LogEventFunctionSignature^ LogEvent {
    LogEventFunctionSignature^ get ();
    void set (LogEventFunctionSignature^ value);
}

Property Value

Type: LogEventFunctionSignature

Implements

ISecurityProviderLogEvent
Remarks
Set LogEvent to null to use default handler, i.e., WriteEntry(String, String, EventLogEntryType, Int32).
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Password Property

Grid Solutions Framework SecurityProviderBasePassword Property
Gets or sets SecurePassword as clear text password.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Password { get; set; }
Public Property Password As String
    Get
    Set
abstract Password : string with get, set
override Password : string with get, set
function get_Password();
function set_Password(value);
public:
virtual property String^ Password {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISecurityProviderPassword
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.PersistSettings Property

Grid Solutions Framework SecurityProviderBasePersistSettings Property
Gets or sets a boolean value that indicates whether security provider settings are to be saved to the config file.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PersistSettings { get; set; }
Public Property PersistSettings As Boolean
    Get
    Set
abstract PersistSettings : bool with get, set
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.SecurePassword Property

Grid Solutions Framework SecurityProviderBaseSecurePassword Property
Gets or sets the password as a SecureString.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual SecureString SecurePassword { get; set; }
Public Overridable Property SecurePassword As SecureString
    Get
    Set
abstract SecurePassword : SecureString with get, set
override SecurePassword : SecureString with get, set
function get_SecurePassword();
function set_SecurePassword(value);
public:
virtual property SecureString^ SecurePassword {
    SecureString^ get ();
    void set (SecureString^ value);
}

Property Value

Type: SecureString

Implements

ISecurityProviderSecurePassword
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.SettingsCategory Property

Grid Solutions Framework SecurityProviderBaseSettingsCategory Property
Gets or sets the category under which security provider settings are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SettingsCategory { get; set; }
Public Property SettingsCategory As String
    Get
    Set
abstract SettingsCategory : string with get, set
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.UserData Property

Grid Solutions Framework SecurityProviderBaseUserData Property
Gets the UserData object containing information about the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual UserData UserData { get; }
Public Overridable ReadOnly Property UserData As UserData
    Get
abstract UserData : UserData with get
override UserData : UserData with get
function get_UserData();

public:
virtual property UserData^ UserData {
    UserData^ get ();
}

Property Value

Type: UserData

Implements

ISecurityProviderUserData
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase Events

Grid Solutions Framework SecurityProviderBase Events

The SecurityProviderBase type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the class has been disposed.
Top
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderBase.Disposed Event

Grid Solutions Framework SecurityProviderBaseDisposed Event
Occurs when the class has been disposed.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

SecurityProviderBase Class
GSF.Security Namespace


SecurityProviderCache Class

Grid Solutions Framework SecurityProviderCache Class
A helper class that manages the caching of ISecurityProviders.
Inheritance Hierarchy
SystemObject
GSF.SecuritySecurityProviderCache

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SecurityProviderCache
Public NotInheritable Class SecurityProviderCache
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SecurityProviderCache =  class end
GSF.Security.SecurityProviderCache = function();

Type.createClass(
    'GSF.Security.SecurityProviderCache');
public ref class SecurityProviderCache abstract sealed

The SecurityProviderCache type exposes the following members.

Methods
Name | Description
ReauthenticateCurrentPrincipal | Attempts to reauthenticate the current thread principal after their provider has been removed from the cache.
TryGetCachedProvider | Attempts to get cached ISecurityProvider for the given username.
Top
Properties
Name | Description
CurrentProvider | Gets or sets the ISecurityProvider of the current user.
Top
See Also

Reference

GSF.Security Namespace


SecurityProviderCache Methods

Grid Solutions Framework SecurityProviderCache Methods

The SecurityProviderCache type exposes the following members.

Methods
Name | Description
ReauthenticateCurrentPrincipal | Attempts to reauthenticate the current thread principal after their provider has been removed from the cache.
TryGetCachedProvider | Attempts to get cached ISecurityProvider for the given username.
Top
See Also

Reference

SecurityProviderCache Class
GSF.Security Namespace


SecurityProviderCache.ReauthenticateCurrentPrincipal Method

Grid Solutions Framework SecurityProviderCacheReauthenticateCurrentPrincipal Method
Attempts to reauthenticate the current thread principal after their provider has been removed from the cache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ReauthenticateCurrentPrincipal()
Public Shared Function ReauthenticateCurrentPrincipal As Boolean
static member ReauthenticateCurrentPrincipal : unit -> bool

GSF.Security.SecurityProviderCache.ReauthenticateCurrentPrincipal = function();
public:
static bool ReauthenticateCurrentPrincipal()

Return Value

Type: Boolean
True if the user successfully reauthenticated; false otherwise.
See Also

Reference

SecurityProviderCache Class
GSF.Security Namespace


SecurityProviderCache.TryGetCachedProvider Method

Grid Solutions Framework SecurityProviderCacheTryGetCachedProvider Method
Attempts to get cached ISecurityProvider for the given username.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryGetCachedProvider(
    string username,
    out ISecurityProvider provider
)
Public Shared Function TryGetCachedProvider (
    username As String,
    <OutAttribute> ByRef provider As ISecurityProvider
) As Boolean
static member TryGetCachedProvider :
        username : string *
        provider : ISecurityProvider byref -> bool

GSF.Security.SecurityProviderCache.TryGetCachedProvider = function(username, provider);
public:
static bool TryGetCachedProvider(
    String^ username,
    [OutAttribute] ISecurityProvider^% provider
)

Parameters

username
Type: SystemString
Name of the user.
provider
Type: GSF.SecurityISecurityProvider
Security provider to return.

Return Value

Type: Boolean
True if provider is cached; false otherwise.
See Also

Reference

SecurityProviderCache Class
GSF.Security Namespace


SecurityProviderCache Properties

Grid Solutions Framework SecurityProviderCache Properties

The SecurityProviderCache type exposes the following members.

Properties
Name | Description
CurrentProvider | Gets or sets the ISecurityProvider of the current user.
Top
See Also

Reference

SecurityProviderCache Class
GSF.Security Namespace


SecurityProviderCache.CurrentProvider Property

Grid Solutions Framework SecurityProviderCacheCurrentProvider Property
Gets or sets the ISecurityProvider of the current user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ISecurityProvider CurrentProvider { get; set; }
Public Shared Property CurrentProvider As ISecurityProvider
    Get
    Set
static member CurrentProvider : ISecurityProvider with get, set

GSF.Security.SecurityProviderCache.get_CurrentProvider = function();
GSF.Security.SecurityProviderCache.set_CurrentProvider = function(value);
public:
static property ISecurityProvider^ CurrentProvider {
    ISecurityProvider^ get ();
    void set (ISecurityProvider^ value);
}

Property Value

Type: ISecurityProvider
See Also

Reference

SecurityProviderCache Class
GSF.Security Namespace


SecurityProviderUtility Class

Grid Solutions Framework SecurityProviderUtility Class
A helper class containing methods used in the implementation of role-based security.
Inheritance Hierarchy
SystemObject
GSF.SecuritySecurityProviderUtility

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SecurityProviderUtility
Public NotInheritable Class SecurityProviderUtility
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SecurityProviderUtility =  class end
GSF.Security.SecurityProviderUtility = function();

Type.createClass(
    'GSF.Security.SecurityProviderUtility');
public ref class SecurityProviderUtility abstract sealed

The SecurityProviderUtility type exposes the following members.

Methods
Name | Description
CreateProvider | Creates a new ISecurityProvider based on the settings in the config file.
EncryptPassword | Encrypts the password to a one-way hash using the SHA1 hash algorithm.
GeneratePassword | Generates a random password of the specified length with at least one uppercase letter, one lowercase letter, one special character and one digit.
IsRegexMatch | Determines if the specified target matches the specified spec.
IsResourceAccessible | Determines if the current user, as defined by the CurrentPrincipal, has permission to access the specified resource based on settings in the config file.
IsResourceSecurable | Determines if the specified resource is to be secured based on settings in the config file.
SendNotification | Sends email notification message to the specified recipient using settings specified in the config file.
Top
See Also

Reference

GSF.Security Namespace


SecurityProviderUtility Methods

Grid Solutions Framework SecurityProviderUtility Methods

The SecurityProviderUtility type exposes the following members.

Methods
Name | Description
CreateProvider | Creates a new ISecurityProvider based on the settings in the config file.
EncryptPassword | Encrypts the password to a one-way hash using the SHA1 hash algorithm.
GeneratePassword | Generates a random password of the specified length with at least one uppercase letter, one lowercase letter, one special character and one digit.
IsRegexMatch | Determines if the specified target matches the specified spec.
IsResourceAccessible | Determines if the current user, as defined by the CurrentPrincipal, has permission to access the specified resource based on settings in the config file.
IsResourceSecurable | Determines if the specified resource is to be secured based on settings in the config file.
SendNotification | Sends email notification message to the specified recipient using settings specified in the config file.
Top
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


SecurityProviderUtility.CreateProvider Method

Grid Solutions Framework SecurityProviderUtilityCreateProvider Method
Creates a new ISecurityProvider based on the settings in the config file.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ISecurityProvider CreateProvider(
    string username
)
Public Shared Function CreateProvider (
    username As String
) As ISecurityProvider
static member CreateProvider :
        username : string -> ISecurityProvider

GSF.Security.SecurityProviderUtility.CreateProvider = function(username);
public:
static ISecurityProvider^ CreateProvider(
    String^ username
)

Parameters

username
Type: SystemString
Username of the user for whom the ISecurityProvider is to be created.

Return Value

Type: ISecurityProvider
An object that implements ISecurityProvider.
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


SecurityProviderUtility.EncryptPassword Method

Grid Solutions Framework SecurityProviderUtilityEncryptPassword Method
Encrypts the password to a one-way hash using the SHA1 hash algorithm.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string EncryptPassword(
    string password
)
Public Shared Function EncryptPassword (
    password As String
) As String
static member EncryptPassword :
        password : string -> string

GSF.Security.SecurityProviderUtility.EncryptPassword = function(password);
public:
static String^ EncryptPassword(
    String^ password
)

Parameters

password
Type: SystemString
Password to be encrypted.

Return Value

Type: String
Encrypted password.
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


SecurityProviderUtility.GeneratePassword Method

Grid Solutions Framework SecurityProviderUtilityGeneratePassword Method
Generates a random password of the specified length with at least one uppercase letter, one lowercase letter, one special character and one digit.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GeneratePassword(
    int length
)
Public Shared Function GeneratePassword (
    length As Integer
) As String
static member GeneratePassword :
        length : int -> string

GSF.Security.SecurityProviderUtility.GeneratePassword = function(length);
public:
static String^ GeneratePassword(
    int length
)

Parameters

length
Type: SystemInt32
Length of the password to generate.

Return Value

Type: String
Randomly generated password of the specified length.
Exceptions
Exception | Condition
ArgumentException | A value of less than 8 is specified for the length.
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


SecurityProviderUtility.IsRegexMatch Method

Grid Solutions Framework SecurityProviderUtilityIsRegexMatch Method
Determines if the specified target matches the specified spec.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsRegexMatch(
    string spec,
    string target
)
Public Shared Function IsRegexMatch (
    spec As String,
    target As String
) As Boolean
static member IsRegexMatch :
        spec : string *
        target : string -> bool

GSF.Security.SecurityProviderUtility.IsRegexMatch = function(spec, target);
public:
static bool IsRegexMatch(
    String^ spec,
    String^ target
)

Parameters

spec
Type: SystemString
Spec string that can include wildcards ('*'). For example, *.txt
target
Type: SystemString
Target string to be compared with the spec.

Return Value

Type: Boolean
true if the target matches the spec, otherwise false.
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


SecurityProviderUtility.IsResourceAccessible Method

Grid Solutions Framework SecurityProviderUtilityIsResourceAccessible Method
Determines if the current user, as defined by the CurrentPrincipal, has permission to access the specified resource based on settings in the config file.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsResourceAccessible(
    string resource
)
Public Shared Function IsResourceAccessible (
    resource As String
) As Boolean
static member IsResourceAccessible :
        resource : string -> bool

GSF.Security.SecurityProviderUtility.IsResourceAccessible = function(resource);
public:
static bool IsResourceAccessible(
    String^ resource
)

Parameters

resource
Type: SystemString
Name of the resource to be checked.

Return Value

Type: Boolean
true if the current user has permission to access the resource; otherwise false.
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


SecurityProviderUtility.IsResourceSecurable Method

Grid Solutions Framework SecurityProviderUtilityIsResourceSecurable Method
Determines if the specified resource is to be secured based on settings in the config file.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsResourceSecurable(
    string resource
)
Public Shared Function IsResourceSecurable (
    resource As String
) As Boolean
static member IsResourceSecurable :
        resource : string -> bool

GSF.Security.SecurityProviderUtility.IsResourceSecurable = function(resource);
public:
static bool IsResourceSecurable(
    String^ resource
)

Parameters

resource
Type: SystemString
Name of the resource to be checked.

Return Value

Type: Boolean
true if the resource is to be secured; otherwise false/
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


SecurityProviderUtility.SendNotification Method

Grid Solutions Framework SecurityProviderUtilitySendNotification Method
Sends email notification message to the specified recipient using settings specified in the config file.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SendNotification(
    string recipient,
    string subject,
    string body
)
Public Shared Sub SendNotification (
    recipient As String,
    subject As String,
    body As String
)
static member SendNotification :
        recipient : string *
        subject : string *
        body : string -> unit

GSF.Security.SecurityProviderUtility.SendNotification = function(recipient, subject, body);
public:
static void SendNotification(
    String^ recipient,
    String^ subject,
    String^ body
)

Parameters

recipient
Type: SystemString
Email address of the notification recipient.
subject
Type: SystemString
Subject of the notification.
body
Type: SystemString
Content of the notification.
See Also

Reference

SecurityProviderUtility Class
GSF.Security Namespace


UserData Class

Grid Solutions Framework UserData Class
A serializable class that contains information about a user defined in the security data store.
Inheritance Hierarchy
SystemObject
GSF.SecurityUserData

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
[DataContractAttribute(Namespace = "")]
[XmlTypeAttribute(Namespace = "")]
public class UserData
<SerializableAttribute>
<DataContractAttribute(Namespace := "")>
<XmlTypeAttribute(Namespace := "")>
Public Class UserData
[<SerializableAttribute>]
[<DataContractAttribute(Namespace = "")>]
[<XmlTypeAttribute(Namespace = "")>]
type UserData =  class end
GSF.Security.UserData = function();

Type.createClass(
    'GSF.Security.UserData');
[SerializableAttribute]
[DataContractAttribute(Namespace = L"")]
[XmlTypeAttribute(Namespace = L"")]
public ref class UserData

The UserData type exposes the following members.

Constructors
 | Name | Description
Public method | UserData | Initializes a new instance of the UserData class.
Public method | UserData(String) | Initializes a new instance of the UserData class.
Public method | UserData(UserData) | Initializes a new instance of the UserData class by copying an existing instance.
Top
Methods
 | Name | Description
Public method | Clone | Copies a new instance of the UserData class by copying an existing instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this UserData object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AccountCreatedDateTime | Gets the UTC date and time when user account was created.
Public property | CompanyName | Gets the user's company name.
Public property | EmailAddress | Gets the user's email address.
Public property | FirstName | Gets the user's first name.
Public property | Groups | Gets a read-only list of all the groups the user belongs to.
Public property | IsAuthenticated | Gets a boolean value indicating whether or not the user has been authenticated.
Public property | IsDefined | Gets a boolean value that indicates whether the user is defined in the backend security data store.
Public property | IsDisabled | Gets a boolean value that indicates whether the user account has been disabled.
Public property | IsExternal | Gets a boolean value that indicates whether the user is defined as an external user in the backend security data store.
Public property | IsLockedOut | Gets a boolean value that indicates whether the user account has been locked due to numerous unsuccessful login attempts.
Public property | LastName | Gets the user's last name.
Public property | LoginID | Gets the user's login ID.
Public property | Password | Gets the user's password.
Public property | PasswordChangeDateTime | Gets the UTC date and time when user must change the password.
Public property | PhoneNumber | Gets the user's phone number.
Public property | Roles | Gets a read-only list of all the roles assigned to the user.
Public property | SecurityAnswer | Gets the user's security answer.
Public property | SecurityQuestion | Gets the user's security question.
Public property | Username | Gets the user's login name.
Top
See Also

Reference

GSF.Security Namespace


UserData Constructor

Grid Solutions Framework UserData Constructor
Overload List
 | Name | Description
Public method | UserData | Initializes a new instance of the UserData class.
Public method | UserData(String) | Initializes a new instance of the UserData class.
Public method | UserData(UserData) | Initializes a new instance of the UserData class by copying an existing instance.
Top
See Also

Reference

UserData Class
GSF.Security Namespace


UserData Constructor

Grid Solutions Framework UserData Constructor
Initializes a new instance of the UserData class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserData()
Public Sub New
new : unit -> UserData
GSF.Security.UserData = function();
public:
UserData()
See Also

Reference

UserData Class
UserData Overload
GSF.Security Namespace


UserData Constructor (String)

Grid Solutions Framework UserData Constructor (String)
Initializes a new instance of the UserData class.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserData(
    string username
)
Public Sub New (
    username As String
)
new :
        username : string -> UserData
GSF.Security.UserData = function(username);
public:
UserData(
    String^ username
)

Parameters

username
Type: SystemString
User's logon name.
See Also

Reference

UserData Class
UserData Overload
GSF.Security Namespace


UserData Constructor (UserData)

Grid Solutions Framework UserData Constructor (UserData)
Initializes a new instance of the UserData class by copying an existing instance.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserData(
    UserData userData
)
Public Sub New (
    userData As UserData
)
new :
        userData : UserData -> UserData
GSF.Security.UserData = function(userData);
public:
UserData(
    UserData^ userData
)

Parameters

userData
Type: GSF.SecurityUserData
The existing instance of the UserData class.
See Also

Reference

UserData Class
UserData Overload
GSF.Security Namespace


UserData Methods

Grid Solutions Framework UserData Methods

The UserData type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Copies a new instance of the UserData class by copying an existing instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes this UserData object.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.Clone Method

Grid Solutions Framework UserDataClone Method
Copies a new instance of the UserData class by copying an existing instance.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clone(
    UserData userData
)
Public Sub Clone (
    userData As UserData
)
member Clone :
        userData : UserData -> unit

function Clone(userData);
public:
void Clone(
    UserData^ userData
)

Parameters

userData
Type: GSF.SecurityUserData
The existing instance of the UserData class.
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.Initialize Method

Grid Solutions Framework UserDataInitialize Method
Initializes this UserData object.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
member Initialize : unit -> unit

function Initialize();
public:
void Initialize()
See Also

Reference

UserData Class
GSF.Security Namespace


UserData Properties

Grid Solutions Framework UserData Properties

The UserData type exposes the following members.

Properties
 | Name | Description
Public property | AccountCreatedDateTime | Gets the UTC date and time when user account was created.
Public property | CompanyName | Gets the user's company name.
Public property | EmailAddress | Gets the user's email address.
Public property | FirstName | Gets the user's first name.
Public property | Groups | Gets a read-only list of all the groups the user belongs to.
Public property | IsAuthenticated | Gets a boolean value indicating whether or not the user has been authenticated.
Public property | IsDefined | Gets a boolean value that indicates whether the user is defined in the backend security data store.
Public property | IsDisabled | Gets a boolean value that indicates whether the user account has been disabled.
Public property | IsExternal | Gets a boolean value that indicates whether the user is defined as an external user in the backend security data store.
Public property | IsLockedOut | Gets a boolean value that indicates whether the user account has been locked due to numerous unsuccessful login attempts.
Public property | LastName | Gets the user's last name.
Public property | LoginID | Gets the user's login ID.
Public property | Password | Gets the user's password.
Public property | PasswordChangeDateTime | Gets the UTC date and time when user must change the password.
Public property | PhoneNumber | Gets the user's phone number.
Public property | Roles | Gets a read-only list of all the roles assigned to the user.
Public property | SecurityAnswer | Gets the user's security answer.
Public property | SecurityQuestion | Gets the user's security question.
Public property | Username | Gets the user's login name.
Top
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.AccountCreatedDateTime Property

Grid Solutions Framework UserDataAccountCreatedDateTime Property
Gets the UTC date and time when user account was created.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 10)]
[XmlElementAttribute]
public DateTime AccountCreatedDateTime { get; set; }
<DataMemberAttribute(Order := 10)>
<XmlElementAttribute>
Public Property AccountCreatedDateTime As DateTime
    Get
    Set
[<DataMemberAttribute(Order = 10)>]
[<XmlElementAttribute>]
member AccountCreatedDateTime : DateTime with get, set

function get_AccountCreatedDateTime();
function set_AccountCreatedDateTime(value);
public:
[DataMemberAttribute(Order = 10)]
[XmlElementAttribute]
property DateTime AccountCreatedDateTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.CompanyName Property

Grid Solutions Framework UserDataCompanyName Property
Gets the user's company name.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlElementAttribute]
[DataMemberAttribute(Order = 4)]
public string CompanyName { get; set; }
<XmlElementAttribute>
<DataMemberAttribute(Order := 4)>
Public Property CompanyName As String
    Get
    Set
[<XmlElementAttribute>]
[<DataMemberAttribute(Order = 4)>]
member CompanyName : string with get, set

function get_CompanyName();
function set_CompanyName(value);
public:
[XmlElementAttribute]
[DataMemberAttribute(Order = 4)]
property String^ CompanyName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.EmailAddress Property

Grid Solutions Framework UserDataEmailAddress Property
Gets the user's email address.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 6)]
[XmlElementAttribute]
public string EmailAddress { get; set; }
<DataMemberAttribute(Order := 6)>
<XmlElementAttribute>
Public Property EmailAddress As String
    Get
    Set
[<DataMemberAttribute(Order = 6)>]
[<XmlElementAttribute>]
member EmailAddress : string with get, set

function get_EmailAddress();
function set_EmailAddress(value);
public:
[DataMemberAttribute(Order = 6)]
[XmlElementAttribute]
property String^ EmailAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.FirstName Property

Grid Solutions Framework UserDataFirstName Property
Gets the user's first name.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlElementAttribute]
[DataMemberAttribute(Order = 2)]
public string FirstName { get; set; }
<XmlElementAttribute>
<DataMemberAttribute(Order := 2)>
Public Property FirstName As String
    Get
    Set
[<XmlElementAttribute>]
[<DataMemberAttribute(Order = 2)>]
member FirstName : string with get, set

function get_FirstName();
function set_FirstName(value);
public:
[XmlElementAttribute]
[DataMemberAttribute(Order = 2)]
property String^ FirstName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.Groups Property

Grid Solutions Framework UserDataGroups Property
Gets a read-only list of all the groups the user belongs to.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlArrayAttribute]
[DataMemberAttribute(Order = 16)]
[XmlArrayItemAttribute("Group")]
public List<string> Groups { get; set; }
<XmlArrayAttribute>
<DataMemberAttribute(Order := 16)>
<XmlArrayItemAttribute("Group")>
Public Property Groups As List(Of String)
    Get
    Set
[<XmlArrayAttribute>]
[<DataMemberAttribute(Order = 16)>]
[<XmlArrayItemAttribute("Group")>]
member Groups : List<string> with get, set

function get_Groups();
function set_Groups(value);
public:
[XmlArrayAttribute]
[DataMemberAttribute(Order = 16)]
[XmlArrayItemAttribute(L"Group")]
property List<String^>^ Groups {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.IsAuthenticated Property

Grid Solutions Framework UserDataIsAuthenticated Property
Gets a boolean value indicating whether or not the user has been authenticated.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 15)]
[XmlElementAttribute]
public bool IsAuthenticated { get; set; }
<DataMemberAttribute(Order := 15)>
<XmlElementAttribute>
Public Property IsAuthenticated As Boolean
    Get
    Set
[<DataMemberAttribute(Order = 15)>]
[<XmlElementAttribute>]
member IsAuthenticated : bool with get, set

function get_IsAuthenticated();
function set_IsAuthenticated(value);
public:
[DataMemberAttribute(Order = 15)]
[XmlElementAttribute]
property bool IsAuthenticated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.IsDefined Property

Grid Solutions Framework UserDataIsDefined Property
Gets a boolean value that indicates whether the user is defined in the backend security data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 11)]
[XmlElementAttribute]
public bool IsDefined { get; set; }
<DataMemberAttribute(Order := 11)>
<XmlElementAttribute>
Public Property IsDefined As Boolean
    Get
    Set
[<DataMemberAttribute(Order = 11)>]
[<XmlElementAttribute>]
member IsDefined : bool with get, set

function get_IsDefined();
function set_IsDefined(value);
public:
[DataMemberAttribute(Order = 11)]
[XmlElementAttribute]
property bool IsDefined {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.IsDisabled Property

Grid Solutions Framework UserDataIsDisabled Property
Gets a boolean value that indicates whether the user account has been disabled.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlElementAttribute]
[DataMemberAttribute(Order = 13)]
public bool IsDisabled { get; set; }
<XmlElementAttribute>
<DataMemberAttribute(Order := 13)>
Public Property IsDisabled As Boolean
    Get
    Set
[<XmlElementAttribute>]
[<DataMemberAttribute(Order = 13)>]
member IsDisabled : bool with get, set

function get_IsDisabled();
function set_IsDisabled(value);
public:
[XmlElementAttribute]
[DataMemberAttribute(Order = 13)]
property bool IsDisabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.IsExternal Property

Grid Solutions Framework UserDataIsExternal Property
Gets a boolean value that indicates whether the user is defined as an external user in the backend security data store.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 12)]
[XmlElementAttribute]
public bool IsExternal { get; set; }
<DataMemberAttribute(Order := 12)>
<XmlElementAttribute>
Public Property IsExternal As Boolean
    Get
    Set
[<DataMemberAttribute(Order = 12)>]
[<XmlElementAttribute>]
member IsExternal : bool with get, set

function get_IsExternal();
function set_IsExternal(value);
public:
[DataMemberAttribute(Order = 12)]
[XmlElementAttribute]
property bool IsExternal {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.IsLockedOut Property

Grid Solutions Framework UserDataIsLockedOut Property
Gets a boolean value that indicates whether the user account has been locked due to numerous unsuccessful login attempts.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlElementAttribute]
[DataMemberAttribute(Order = 14)]
public bool IsLockedOut { get; set; }
<XmlElementAttribute>
<DataMemberAttribute(Order := 14)>
Public Property IsLockedOut As Boolean
    Get
    Set
[<XmlElementAttribute>]
[<DataMemberAttribute(Order = 14)>]
member IsLockedOut : bool with get, set

function get_IsLockedOut();
function set_IsLockedOut(value);
public:
[XmlElementAttribute]
[DataMemberAttribute(Order = 14)]
property bool IsLockedOut {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.LastName Property

Grid Solutions Framework UserDataLastName Property
Gets the user's last name.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 3)]
[XmlElementAttribute]
public string LastName { get; set; }
<DataMemberAttribute(Order := 3)>
<XmlElementAttribute>
Public Property LastName As String
    Get
    Set
[<DataMemberAttribute(Order = 3)>]
[<XmlElementAttribute>]
member LastName : string with get, set

function get_LastName();
function set_LastName(value);
public:
[DataMemberAttribute(Order = 3)]
[XmlElementAttribute]
property String^ LastName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.LoginID Property

Grid Solutions Framework UserDataLoginID Property
Gets the user's login ID.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LoginID { get; set; }
Public Property LoginID As String
    Get
    Set
member LoginID : string with get, set

function get_LoginID();
function set_LoginID(value);
public:
property String^ LoginID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.Password Property

Grid Solutions Framework UserDataPassword Property
Gets the user's password.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 1)]
[XmlElementAttribute]
public string Password { get; set; }
<DataMemberAttribute(Order := 1)>
<XmlElementAttribute>
Public Property Password As String
    Get
    Set
[<DataMemberAttribute(Order = 1)>]
[<XmlElementAttribute>]
member Password : string with get, set

function get_Password();
function set_Password(value);
public:
[DataMemberAttribute(Order = 1)]
[XmlElementAttribute]
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
This field is only used to store hashed user passwords which are stored in the database.
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.PasswordChangeDateTime Property

Grid Solutions Framework UserDataPasswordChangeDateTime Property
Gets the UTC date and time when user must change the password.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 9)]
[XmlElementAttribute]
public DateTime PasswordChangeDateTime { get; set; }
<DataMemberAttribute(Order := 9)>
<XmlElementAttribute>
Public Property PasswordChangeDateTime As DateTime
    Get
    Set
[<DataMemberAttribute(Order = 9)>]
[<XmlElementAttribute>]
member PasswordChangeDateTime : DateTime with get, set

function get_PasswordChangeDateTime();
function set_PasswordChangeDateTime(value);
public:
[DataMemberAttribute(Order = 9)]
[XmlElementAttribute]
property DateTime PasswordChangeDateTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.PhoneNumber Property

Grid Solutions Framework UserDataPhoneNumber Property
Gets the user's phone number.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 5)]
[XmlElementAttribute]
public string PhoneNumber { get; set; }
<DataMemberAttribute(Order := 5)>
<XmlElementAttribute>
Public Property PhoneNumber As String
    Get
    Set
[<DataMemberAttribute(Order = 5)>]
[<XmlElementAttribute>]
member PhoneNumber : string with get, set

function get_PhoneNumber();
function set_PhoneNumber(value);
public:
[DataMemberAttribute(Order = 5)]
[XmlElementAttribute]
property String^ PhoneNumber {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.Roles Property

Grid Solutions Framework UserDataRoles Property
Gets a read-only list of all the roles assigned to the user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlArrayItemAttribute("Role")]
[DataMemberAttribute(Order = 17)]
[XmlArrayAttribute]
public List<string> Roles { get; set; }
<XmlArrayItemAttribute("Role")>
<DataMemberAttribute(Order := 17)>
<XmlArrayAttribute>
Public Property Roles As List(Of String)
    Get
    Set
[<XmlArrayItemAttribute("Role")>]
[<DataMemberAttribute(Order = 17)>]
[<XmlArrayAttribute>]
member Roles : List<string> with get, set

function get_Roles();
function set_Roles(value);
public:
[XmlArrayItemAttribute(L"Role")]
[DataMemberAttribute(Order = 17)]
[XmlArrayAttribute]
property List<String^>^ Roles {
    List<String^>^ get ();
    void set (List<String^>^ value);
}

Property Value

Type: List String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.SecurityAnswer Property

Grid Solutions Framework UserDataSecurityAnswer Property
Gets the user's security answer.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlElementAttribute]
[DataMemberAttribute(Order = 8)]
public string SecurityAnswer { get; set; }
<XmlElementAttribute>
<DataMemberAttribute(Order := 8)>
Public Property SecurityAnswer As String
    Get
    Set
[<XmlElementAttribute>]
[<DataMemberAttribute(Order = 8)>]
member SecurityAnswer : string with get, set

function get_SecurityAnswer();
function set_SecurityAnswer(value);
public:
[XmlElementAttribute]
[DataMemberAttribute(Order = 8)]
property String^ SecurityAnswer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.SecurityQuestion Property

Grid Solutions Framework UserDataSecurityQuestion Property
Gets the user's security question.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[XmlElementAttribute]
[DataMemberAttribute(Order = 7)]
public string SecurityQuestion { get; set; }
<XmlElementAttribute>
<DataMemberAttribute(Order := 7)>
Public Property SecurityQuestion As String
    Get
    Set
[<XmlElementAttribute>]
[<DataMemberAttribute(Order = 7)>]
member SecurityQuestion : string with get, set

function get_SecurityQuestion();
function set_SecurityQuestion(value);
public:
[XmlElementAttribute]
[DataMemberAttribute(Order = 7)]
property String^ SecurityQuestion {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserData.Username Property

Grid Solutions Framework UserDataUsername Property
Gets the user's login name.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute(Order = 0)]
[XmlElementAttribute]
public string Username { get; set; }
<DataMemberAttribute(Order := 0)>
<XmlElementAttribute>
Public Property Username As String
    Get
    Set
[<DataMemberAttribute(Order = 0)>]
[<XmlElementAttribute>]
member Username : string with get, set

function get_Username();
function set_Username(value);
public:
[DataMemberAttribute(Order = 0)]
[XmlElementAttribute]
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

UserData Class
GSF.Security Namespace


UserDataCache Class

Grid Solutions Framework UserDataCache Class
Represents a secured inter-process cache for a DictionaryTKey, TValue of serialized UserData.
Inheritance Hierarchy
SystemObject
GSF.IOInterprocessCache
GSF.SecurityUserDataCache

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class UserDataCache : InterprocessCache
Public Class UserDataCache
    Inherits InterprocessCache
type UserDataCache =
    class
        inherit InterprocessCache
    end
GSF.Security.UserDataCache = function();

Type.createClass(
    'GSF.Security.UserDataCache',
    GSF.IO.InterprocessCache);
public ref class UserDataCache : public InterprocessCache

The UserDataCache type exposes the following members.

Constructors
 | Name | Description
Public method | UserDataCache(Int32) | Creates a new instance of the UserDataCache.
Public method | UserDataCache(Int32, Int32) | Creates a new instance of the UserDataCache with the specified number of maximumConcurrentLocks.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object. (Inherited from InterprocessCache.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources. (Inherited from InterprocessCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Inherited from InterprocessCache.)
 | GetCurrentCache | Loads the UserDataCache for the current local user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HashLoginID | Calculates the hash of the loginID used as the key for the user data cache.
Public method | Load | Initiates inter-process synchronized cache file load. (Inherited from InterprocessCache.)
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge). (Overrides InterprocessCacheLoadFileData(FileStream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Initiates inter-process synchronized save of user data cache. (Overrides InterprocessCacheSave.)
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge). (Overrides InterprocessCacheSaveFileData(FileStream, Byte).)
Public method | SaveUserData | Serializes the userData for the given loginID into the UserDataCache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetUserData | Attempts to retrieve UserData for given loginID.
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete. (Inherited from InterprocessCache.)
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete. (Inherited from InterprocessCache.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated. (Inherited from InterprocessCache.)
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded. (Inherited from InterprocessCache.)
Public property | FileName | Path and file name for the cache needing inter-process synchronization. (Inherited from InterprocessCache.)
Public property | Item | Gets or sets UserData for given loginID.
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed. (Inherited from InterprocessCache.)
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data. (Inherited from InterprocessCache.)
Public property | ProviderID | Gets or sets unique provider ID used to distinguish cached user data that may be different based on provider.
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData. (Inherited from InterprocessCache.)
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data. (Inherited from InterprocessCache.)
Top
Remarks
This is a personal user data cache that only contains basic LDAP information for the user. It is used to load the local and Active Directory groups a user is associated with when the user no longer has access to its domain server. This can happen when a laptop that is normally connected to the Active Directory domain gets shutdown then restarted without access to the domain, for example, on an airplane - in this mode the user can successfully still login to the laptop to their using domain account cached by Windows but the groups the user is in will no longer be accessible. If role based security happens to be based on Active Directory groups, this cache will make sure the user can still have needed role based access even when the domain is unavailable. This cache is maintained as a separate user cache from the system level AdoSecurityCache since the user data cache only contains group information and is used by the LdapSecurityProvider which can be used independently of the AdoSecurityProvider.
See Also

Reference

GSF.Security Namespace


UserDataCache Constructor

Grid Solutions Framework UserDataCache Constructor
Overload List
 | Name | Description
Public method | UserDataCache(Int32) | Creates a new instance of the UserDataCache.
Public method | UserDataCache(Int32, Int32) | Creates a new instance of the UserDataCache with the specified number of maximumConcurrentLocks.
Top
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache Constructor (Int32)

Grid Solutions Framework UserDataCache Constructor (Int32)
Creates a new instance of the UserDataCache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserDataCache(
    int providerID = 0
)
Public Sub New (
    Optional providerID As Integer = 0
)
new :
        ?providerID : int
(* Defaults:
        let _providerID = defaultArg providerID 0
*)
-> UserDataCache
GSF.Security.UserDataCache = function(providerID);
public:
UserDataCache(
    int providerID = 0
)

Parameters

providerID (Optional)
Type: SystemInt32
Unique provider ID used to distinguish cached user data that may be different based on provider.
See Also

Reference

UserDataCache Class
UserDataCache Overload
GSF.Security Namespace


UserDataCache Constructor (Int32, Int32)

Grid Solutions Framework UserDataCache Constructor (Int32, Int32)
Creates a new instance of the UserDataCache with the specified number of maximumConcurrentLocks.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserDataCache(
    int providerID,
    int maximumConcurrentLocks
)
Public Sub New (
    providerID As Integer,
    maximumConcurrentLocks As Integer
)
new :
        providerID : int *
        maximumConcurrentLocks : int -> UserDataCache
GSF.Security.UserDataCache = function(providerID, maximumConcurrentLocks);
public:
UserDataCache(
    int providerID,
    int maximumConcurrentLocks
)

Parameters

providerID
Type: SystemInt32
Unique provider ID used to distinguish cached user data that may be different based on provider.
maximumConcurrentLocks
Type: SystemInt32
Maximum concurrent reader locks to allow.
See Also

Reference

UserDataCache Class
UserDataCache Overload
GSF.Security Namespace


UserDataCache Methods

Grid Solutions Framework UserDataCache Methods

The UserDataCache type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object. (Inherited from InterprocessCache.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources. (Inherited from InterprocessCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Inherited from InterprocessCache.)
 | GetCurrentCache | Loads the UserDataCache for the current local user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HashLoginID | Calculates the hash of the loginID used as the key for the user data cache.
Public method | Load | Initiates inter-process synchronized cache file load. (Inherited from InterprocessCache.)
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge). (Overrides InterprocessCacheLoadFileData(FileStream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Save | Initiates inter-process synchronized save of user data cache. (Overrides InterprocessCacheSave.)
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge). (Overrides InterprocessCacheSaveFileData(FileStream, Byte).)
Public method | SaveUserData | Serializes the userData for the given loginID into the UserDataCache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetUserData | Attempts to retrieve UserData for given loginID.
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete. (Inherited from InterprocessCache.)
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete. (Inherited from InterprocessCache.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.GetCurrentCache Method

Grid Solutions Framework UserDataCacheGetCurrentCache Method
Loads the UserDataCache for the current local user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UserDataCache GetCurrentCache(
    int providerID
)
Public Shared Function GetCurrentCache (
    providerID As Integer
) As UserDataCache
static member GetCurrentCache :
        providerID : int -> UserDataCache

GSF.Security.UserDataCache.GetCurrentCache = function(providerID);
public:
static UserDataCache^ GetCurrentCache(
    int providerID
)

Parameters

providerID
Type: SystemInt32
Unique security provider ID used to distinguish cached user data that may be different based on provider.

Return Value

Type: UserDataCache
Loaded instance of the UserDataCache.
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.HashLoginID Method

Grid Solutions Framework UserDataCacheHashLoginID Method
Calculates the hash of the loginID used as the key for the user data cache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected string HashLoginID(
    string loginID
)
Protected Function HashLoginID (
    loginID As String
) As String
member HashLoginID :
        loginID : string -> string

function HashLoginID(loginID);
protected:
String^ HashLoginID(
    String^ loginID
)

Parameters

loginID
Type: SystemString
Login ID to hash.

Return Value

Type: String
The Base64 encoded calculated SHA-2 hash of the loginID used as the key for the user data cache.
Remarks
For added security, a hash of the loginID is used as the key for UserData in the user data cache instead of the actual loginID. This method allows the consumer to properly calculate this hash when directly using the user data cache.
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.LoadFileData Method

Grid Solutions Framework UserDataCacheLoadFileData Method
Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge).

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] LoadFileData(
    FileStream fileStream
)
Protected Overrides Function LoadFileData (
    fileStream As FileStream
) As Byte()
abstract LoadFileData :
        fileStream : FileStream -> byte[]
override LoadFileData :
        fileStream : FileStream -> byte[]
function LoadFileData(fileStream);
protected:
virtual array<unsigned char>^ LoadFileData(
    FileStream^ fileStream
) override

Parameters

fileStream
Type: System.IOFileStream
FileStream used to deserialize data.

Return Value

Type: Byte
Deserialized file data.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.Save Method

Grid Solutions Framework UserDataCacheSave Method
Initiates inter-process synchronized save of user data cache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Save()
Public Overrides Sub Save
abstract Save : unit -> unit
override Save : unit -> unit
function Save();
public:
virtual void Save() override
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.SaveFileData Method

Grid Solutions Framework UserDataCacheSaveFileData Method
Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge).

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SaveFileData(
    FileStream fileStream,
    byte[] fileData
)
Protected Overrides Sub SaveFileData (
    fileStream As FileStream,
    fileData As Byte()
)
abstract SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
override SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
function SaveFileData(fileStream, fileData);
protected:
virtual void SaveFileData(
    FileStream^ fileStream,
    array<unsigned char>^ fileData
) override

Parameters

fileStream
Type: System.IOFileStream
FileStream used to serialize data.
fileData
Type: SystemByte
File data to be serialized.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.SaveUserData Method

Grid Solutions Framework UserDataCacheSaveUserData Method
Serializes the userData for the given loginID into the UserDataCache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveUserData(
    string loginID,
    UserData userData
)
Public Sub SaveUserData (
    loginID As String,
    userData As UserData
)
member SaveUserData :
        loginID : string *
        userData : UserData -> unit

function SaveUserData(loginID, userData);
public:
void SaveUserData(
    String^ loginID,
    UserData^ userData
)

Parameters

loginID
Type: SystemString
Login ID of associated UserData to retrieve.
userData
Type: GSF.SecurityUserData
Reference to UserData object to serialize into UserDataCache.
Remarks

This will add an entry into the user data cache for loginID if it doesn't exist; otherwise existing entry will be updated.

Updates are automatically queued up for serialization so user does not need to call Save.

See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.TryGetUserData Method

Grid Solutions Framework UserDataCacheTryGetUserData Method
Attempts to retrieve UserData for given loginID.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetUserData(
    string loginID,
    out UserData userData
)
Public Function TryGetUserData (
    loginID As String,
    <OutAttribute> ByRef userData As UserData
) As Boolean
member TryGetUserData :
        loginID : string *
        userData : UserData byref -> bool

function TryGetUserData(loginID, userData);
public:
bool TryGetUserData(
    String^ loginID,
    [OutAttribute] UserData^% userData
)

Parameters

loginID
Type: SystemString
Login ID of associated UserData to retrieve.
userData
Type: GSF.SecurityUserData
Reference to UserData object to populate if found.

Return Value

Type: Boolean
true if UserData for given loginID was retrieved; otherwise false.
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache Properties

Grid Solutions Framework UserDataCache Properties

The UserDataCache type exposes the following members.

Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated. (Inherited from InterprocessCache.)
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded. (Inherited from InterprocessCache.)
Public property | FileName | Path and file name for the cache needing inter-process synchronization. (Inherited from InterprocessCache.)
Public property | Item | Gets or sets UserData for given loginID.
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed. (Inherited from InterprocessCache.)
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data. (Inherited from InterprocessCache.)
Public property | ProviderID | Gets or sets unique provider ID used to distinguish cached user data that may be different based on provider.
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData. (Inherited from InterprocessCache.)
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data. (Inherited from InterprocessCache.)
Top
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.Item Property

Grid Solutions Framework UserDataCacheItem Property
Gets or sets UserData for given loginID.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserData this[
    string loginID
] { get; set; }
Public Default Property Item (
    loginID As String
) As UserData
    Get
    Set
member Item : UserData with get, set

function get_Item(loginID);
function set_Item(value);
public:
property UserData^ default[String^ loginID] {
    UserData^ get (String^ loginID);
    void set (String^ loginID, UserData^ value);
}

Parameters

loginID
Type: SystemString
Login ID of associated UserData to load or save.

Return Value

Type: UserData
Reference to UserData for given loginID if found; otherwise null.
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserDataCache.ProviderID Property

Grid Solutions Framework UserDataCacheProviderID Property
Gets or sets unique provider ID used to distinguish cached user data that may be different based on provider.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ProviderID { get; set; }
Public Property ProviderID As Integer
    Get
    Set
member ProviderID : int with get, set

function get_ProviderID();
function set_ProviderID(value);
public:
property int ProviderID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

UserDataCache Class
GSF.Security Namespace


UserRoleCache Class

Grid Solutions Framework UserRoleCache Class
Represents a secured inter-process cache for a DictionaryTKey, TValue of serialized user role information.
Inheritance Hierarchy
SystemObject
GSF.IOInterprocessCache
GSF.SecurityUserRoleCache

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class UserRoleCache : InterprocessCache
Public Class UserRoleCache
    Inherits InterprocessCache
type UserRoleCache =
    class
        inherit InterprocessCache
    end
GSF.Security.UserRoleCache = function();

Type.createClass(
    'GSF.Security.UserRoleCache',
    GSF.IO.InterprocessCache);
public ref class UserRoleCache : public InterprocessCache

The UserRoleCache type exposes the following members.

Constructors
 | Name | Description
Public method | UserRoleCache | Creates a new instance of the UserRoleCache with the specified number of maximumConcurrentLocks.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object. (Inherited from InterprocessCache.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources. (Inherited from InterprocessCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Inherited from InterprocessCache.)
 | GetCurrentCache | Loads the UserRoleCache for the current local user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HashLoginID | Calculates the hash of the userName used as the key for the user roles dictionary.
Public method | Load | Initiates inter-process synchronized cache file load. (Inherited from InterprocessCache.)
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge). (Overrides InterprocessCacheLoadFileData(FileStream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeLeft | Merge user roles from another UserRoleCache, local cache taking precedence.
Public method | MergeRight | Merge user roles from another UserRoleCache, other cache taking precedence.
Public method | Save | Initiates inter-process synchronized save of user role cache. (Overrides InterprocessCacheSave.)
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge). (Overrides InterprocessCacheSaveFileData(FileStream, Byte).)
Public method | SaveUserRole | Serializes the roles for the given userName into the UserRoleCache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetUserRole | Attempts to retrieve access role for given userName.
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete. (Inherited from InterprocessCache.)
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete. (Inherited from InterprocessCache.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated. (Inherited from InterprocessCache.)
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded. (Inherited from InterprocessCache.)
Public property | FileName | Path and file name for the cache needing inter-process synchronization. (Inherited from InterprocessCache.)
Public property | Item | Gets or sets access roles for given userName.
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed. (Inherited from InterprocessCache.)
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data. (Inherited from InterprocessCache.)
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData. (Inherited from InterprocessCache.)
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data. (Inherited from InterprocessCache.)
Public property | UserRoles | Gets a copy of the internal user role dictionary.
Top
Remarks
This is a system cache that contains the role assignments for each user that has logged in successfully. This cache is used to check for changes in role assignments for a user - that is, a role change in the database that may now be different than what is in the current cache. Any kind of role changes are logged as security events in the Windows event log for auditing. Note that this is kept as a separate cache from the AdoSecurityCache since the user role cache is used for auditing and contains information relative to a user's roles at last login.
See Also

Reference

GSF.Security Namespace


UserRoleCache Constructor

Grid Solutions Framework UserRoleCache Constructor
Creates a new instance of the UserRoleCache with the specified number of maximumConcurrentLocks.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserRoleCache(
    int maximumConcurrentLocks = 10
)
Public Sub New (
    Optional maximumConcurrentLocks As Integer = 10
)
new :
        ?maximumConcurrentLocks : int
(* Defaults:
        let _maximumConcurrentLocks = defaultArg maximumConcurrentLocks 10
*)
-> UserRoleCache
GSF.Security.UserRoleCache = function(maximumConcurrentLocks);
public:
UserRoleCache(
    int maximumConcurrentLocks = 10
)

Parameters

maximumConcurrentLocks (Optional)
Type: SystemInt32
Maximum concurrent reader locks to allow.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache Methods

Grid Solutions Framework UserRoleCache Methods

The UserRoleCache type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessCache object. (Inherited from InterprocessCache.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessCache object and optionally releases the managed resources. (Inherited from InterprocessCache.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the InterprocessCache object is reclaimed by GC. (Inherited from InterprocessCache.)
 | GetCurrentCache | Loads the UserRoleCache for the current local user.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HashLoginID | Calculates the hash of the userName used as the key for the user roles dictionary.
Public method | Load | Initiates inter-process synchronized cache file load. (Inherited from InterprocessCache.)
Protected method | LoadFileData | Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge). (Overrides InterprocessCacheLoadFileData(FileStream).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MergeLeft | Merge user roles from another UserRoleCache, local cache taking precedence.
Public method | MergeRight | Merge user roles from another UserRoleCache, other cache taking precedence.
Public method | Save | Initiates inter-process synchronized save of user role cache. (Overrides InterprocessCacheSave.)
Protected method | SaveFileData | Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge). (Overrides InterprocessCacheSaveFileData(FileStream, Byte).)
Public method | SaveUserRole | Serializes the roles for the given userName into the UserRoleCache.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryGetUserRole | Attempts to retrieve access role for given userName.
Public method | WaitForLoad | Blocks current thread and waits for any pending load to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForLoad(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending load to complete. (Inherited from InterprocessCache.)
Public method | WaitForSave | Blocks current thread and waits for any pending save to complete; wait time is RetryDelayInterval * MaximumRetryAttempts. (Inherited from InterprocessCache.)
Public method | WaitForSave(Int32) | Blocks current thread and waits for specified millisecondsTimeout for any pending save to complete. (Inherited from InterprocessCache.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.GetCurrentCache Method

Grid Solutions Framework UserRoleCacheGetCurrentCache Method
Loads the UserRoleCache for the current local user.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UserRoleCache GetCurrentCache()
Public Shared Function GetCurrentCache As UserRoleCache
static member GetCurrentCache : unit -> UserRoleCache

GSF.Security.UserRoleCache.GetCurrentCache = function();
public:
static UserRoleCache^ GetCurrentCache()

Return Value

Type: UserRoleCache
Loaded instance of the UserRoleCache.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.HashLoginID Method

Grid Solutions Framework UserRoleCacheHashLoginID Method
Calculates the hash of the userName used as the key for the user roles dictionary.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected string HashLoginID(
    string userName
)
Protected Function HashLoginID (
    userName As String
) As String
member HashLoginID :
        userName : string -> string

function HashLoginID(userName);
protected:
String^ HashLoginID(
    String^ userName
)

Parameters

userName
Type: SystemString
User name to hash.

Return Value

Type: String
The Base64 encoded calculated SHA-2 hash of the userName used as the key for the user roles dictionary.
Remarks
For added security, a hash of the userName is used as the key for accessing roles in the user roles cache instead of the actual userName. This method allows the consumer to properly calculate this hash when directly using the user data cache.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.LoadFileData Method

Grid Solutions Framework UserRoleCacheLoadFileData Method
Handles deserialization of file from disk; virtual method allows customization (e.g., pre-load decryption and/or data merge).

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override byte[] LoadFileData(
    FileStream fileStream
)
Protected Overrides Function LoadFileData (
    fileStream As FileStream
) As Byte()
abstract LoadFileData :
        fileStream : FileStream -> byte[]
override LoadFileData :
        fileStream : FileStream -> byte[]
function LoadFileData(fileStream);
protected:
virtual array<unsigned char>^ LoadFileData(
    FileStream^ fileStream
) override

Parameters

fileStream
Type: System.IOFileStream
FileStream used to deserialize data.

Return Value

Type: Byte
Deserialized file data.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.MergeLeft Method

Grid Solutions Framework UserRoleCacheMergeLeft Method
Merge user roles from another UserRoleCache, local cache taking precedence.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void MergeLeft(
    UserRoleCache other
)
Public Sub MergeLeft (
    other As UserRoleCache
)
member MergeLeft :
        other : UserRoleCache -> unit

function MergeLeft(other);
public:
void MergeLeft(
    UserRoleCache^ other
)

Parameters

other
Type: GSF.SecurityUserRoleCache
Other UserRoleCache to merge with.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.MergeRight Method

Grid Solutions Framework UserRoleCacheMergeRight Method
Merge user roles from another UserRoleCache, other cache taking precedence.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void MergeRight(
    UserRoleCache other
)
Public Sub MergeRight (
    other As UserRoleCache
)
member MergeRight :
        other : UserRoleCache -> unit

function MergeRight(other);
public:
void MergeRight(
    UserRoleCache^ other
)

Parameters

other
Type: GSF.SecurityUserRoleCache
Other UserRoleCache to merge with.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.Save Method

Grid Solutions Framework UserRoleCacheSave Method
Initiates inter-process synchronized save of user role cache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Save()
Public Overrides Sub Save
abstract Save : unit -> unit
override Save : unit -> unit
function Save();
public:
virtual void Save() override
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.SaveFileData Method

Grid Solutions Framework UserRoleCacheSaveFileData Method
Handles serialization of file to disk; virtual method allows customization (e.g., pre-save encryption and/or data merge).

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SaveFileData(
    FileStream fileStream,
    byte[] fileData
)
Protected Overrides Sub SaveFileData (
    fileStream As FileStream,
    fileData As Byte()
)
abstract SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
override SaveFileData :
        fileStream : FileStream *
        fileData : byte[] -> unit
function SaveFileData(fileStream, fileData);
protected:
virtual void SaveFileData(
    FileStream^ fileStream,
    array<unsigned char>^ fileData
) override

Parameters

fileStream
Type: System.IOFileStream
FileStream used to serialize data.
fileData
Type: SystemByte
File data to be serialized.
Remarks
Consumers overriding this method should not directly call FileData property to avoid potential dead-locks.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.SaveUserRole Method

Grid Solutions Framework UserRoleCacheSaveUserRole Method
Serializes the roles for the given userName into the UserRoleCache.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveUserRole(
    string userName,
    string[] roles
)
Public Sub SaveUserRole (
    userName As String,
    roles As String()
)
member SaveUserRole :
        userName : string *
        roles : string[] -> unit

function SaveUserRole(userName, roles);
public:
void SaveUserRole(
    String^ userName,
    array<String^>^ roles
)

Parameters

userName
Type: SystemString
User name associated with access role to retrieve.
roles
Type: SystemString
Access roles to update or populate.
Remarks

This will add an entry into the user roles cache for userName if it doesn't exist; otherwise existing entry will be updated.

Updates are automatically queued up for serialization so user does not need to call Save.

See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.TryGetUserRole Method

Grid Solutions Framework UserRoleCacheTryGetUserRole Method
Attempts to retrieve access role for given userName.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetUserRole(
    string userName,
    out string[] roles
)
Public Function TryGetUserRole (
    userName As String,
    <OutAttribute> ByRef roles As String()
) As Boolean
member TryGetUserRole :
        userName : string *
        roles : string[] byref -> bool

function TryGetUserRole(userName, roles);
public:
bool TryGetUserRole(
    String^ userName,
    [OutAttribute] array<String^>^% roles
)

Parameters

userName
Type: SystemString
User name associated with access role to retrieve.
roles
Type: SystemString
Access roles to populate if found.

Return Value

Type: Boolean
true if access roles for given userName were retrieved; otherwise false.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache Properties

Grid Solutions Framework UserRoleCache Properties

The UserRoleCache type exposes the following members.

Properties
 | Name | Description
Public property | AutoSave | Gets or sets flag that determines if InterprocessCache should automatically initiate a save when FileData has been updated. (Inherited from InterprocessCache.)
Public property | FileData | Gets or sets file data for the cache to be saved or that has been loaded. (Inherited from InterprocessCache.)
Public property | FileName | Path and file name for the cache needing inter-process synchronization. (Inherited from InterprocessCache.)
Public property | Item | Gets or sets access roles for given userName.
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed. (Inherited from InterprocessCache.)
Public property | MaximumRetryAttempts | Maximum retry attempts allowed for loading or saving cache file data. (Inherited from InterprocessCache.)
Public property | ReloadOnChange | Gets or sets flag that enables system to monitor for changes in FileName and automatically reload FileData. (Inherited from InterprocessCache.)
Public property | RetryDelayInterval | Wait interval, in milliseconds, before retrying load or save of cache file data. (Inherited from InterprocessCache.)
Public property | UserRoles | Gets a copy of the internal user role dictionary.
Top
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.Item Property

Grid Solutions Framework UserRoleCacheItem Property
Gets or sets access roles for given userName.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] this[
    string userName
] { get; set; }
Public Default Property Item (
    userName As String
) As String()
    Get
    Set
member Item : string[] with get, set

function get_Item(userName);
function set_Item(value);
public:
property array<String^>^ default[String^ userName] {
    array<String^>^ get (String^ userName);
    void set (String^ userName, array<String^>^ value);
}

Parameters

userName
Type: SystemString
User name for associated access role to load or save.

Return Value

Type: String
Access roles for given userName if found; otherwise null.
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


UserRoleCache.UserRoles Property

Grid Solutions Framework UserRoleCacheUserRoles Property
Gets a copy of the internal user role dictionary.

Namespace: GSF.Security
Assembly: GSF.Security (in GSF.Security.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<string, string[]> UserRoles { get; }
Public ReadOnly Property UserRoles As Dictionary(Of String, String())
    Get
member UserRoles : Dictionary<string, string[]> with get

function get_UserRoles();

public:
property Dictionary<String^, array<String^>^>^ UserRoles {
    Dictionary<String^, array<String^>^>^ get ();
}

Property Value

Type: Dictionary String, String
See Also

Reference

UserRoleCache Class
GSF.Security Namespace


GSF.Security.Cryptography Namespace

Grid Solutions Framework GSF.Security.Cryptography Namespace
Contains classes and extension functions used to simplify and standardize usage of basic cryptography using a combination of standard and proprietary encryption algorithms to produce decent obfuscations of strings, buffers and streams of data.
Classes
 | Class | Description
Public class | Cipher | Provides general use cryptographic functions.
Public class | Random | Generates cryptographically strong random numbers.
Public class | SymmetricAlgorithmExtensions | Defines extension functions related to cryptographic SymmetricAlgorithm objects.
Enumerations
 | Enumeration | Description
Public enumeration | CipherStrength | Cryptographic strength enumeration.


Cipher Class

Grid Solutions Framework Cipher Class
Provides general use cryptographic functions.
Inheritance Hierarchy
SystemObject
GSF.Security.CryptographyCipher

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Cipher
<ExtensionAttribute>
Public NotInheritable Class Cipher
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Cipher =  class end
GSF.Security.Cryptography.Cipher = function();

Type.createClass(
    'GSF.Security.Cryptography.Cipher');
[ExtensionAttribute]
public ref class Cipher abstract sealed

The Cipher type exposes the following members.

Methods
Name | Description
Decrypt(Byte, String, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(String, String, CipherStrength) | Returns a decrypted string from a Base64 encoded string of binary encrypted data from the given parameters.
Decrypt(Byte, Byte, Byte, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Stream, Byte, Byte, CipherStrength) | Returns a stream of decrypted data for the given parameters.
Decrypt(Byte, Int32, Int32, String, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Byte, Int32, Int32, Byte, Byte, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Decrypts input stream onto output stream for the given parameters.
DecryptFile | Creates a decrypted file from source file data.
Encrypt(Byte, String, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(String, String, CipherStrength) | Returns a Base64 encoded string of the returned binary array of the encrypted data, generated with the given parameters.
Encrypt(Byte, Byte, Byte, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Stream, Byte, Byte, CipherStrength) | Returns a stream of encrypted data for the given parameters.
Encrypt(Byte, Int32, Int32, String, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Byte, Int32, Int32, Byte, Byte, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Encrypts input stream onto output stream for the given parameters.
EncryptFile | Creates an encrypted file from source file data.
ExportKeyIV | Exports a key and initialization vector from the local system key cache.
FlushCache | Blocks current thread and waits for any pending save of local system key cache to complete.
GetPasswordHash | Gets the Base64 encoded SHA-256 hash of given user password.
ImportKeyIV | Imports a key and initialization vector into the local system key cache.
KeyIVExists | Determines if a key and initialization vector exists for the given password in the local system key cache.
ReloadCache | Manually loads keys into the local system key cache.
Top
Remarks
This class exists to simplify usage of basic cryptography functionality.
See Also

Reference

GSF.Security.Cryptography Namespace


Cipher Methods

Grid Solutions Framework Cipher Methods

The Cipher type exposes the following members.

Methods
Name | Description
Decrypt(Byte, String, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(String, String, CipherStrength) | Returns a decrypted string from a Base64 encoded string of binary encrypted data from the given parameters.
Decrypt(Byte, Byte, Byte, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Stream, Byte, Byte, CipherStrength) | Returns a stream of decrypted data for the given parameters.
Decrypt(Byte, Int32, Int32, String, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Byte, Int32, Int32, Byte, Byte, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Decrypts input stream onto output stream for the given parameters.
DecryptFile | Creates a decrypted file from source file data.
Encrypt(Byte, String, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(String, String, CipherStrength) | Returns a Base64 encoded string of the returned binary array of the encrypted data, generated with the given parameters.
Encrypt(Byte, Byte, Byte, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Stream, Byte, Byte, CipherStrength) | Returns a stream of encrypted data for the given parameters.
Encrypt(Byte, Int32, Int32, String, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Byte, Int32, Int32, Byte, Byte, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Encrypts input stream onto output stream for the given parameters.
EncryptFile | Creates an encrypted file from source file data.
ExportKeyIV | Exports a key and initialization vector from the local system key cache.
FlushCache | Blocks current thread and waits for any pending save of local system key cache to complete.
GetPasswordHash | Gets the Base64 encoded SHA-256 hash of given user password.
ImportKeyIV | Imports a key and initialization vector into the local system key cache.
KeyIVExists | Determines if a key and initialization vector exists for the given password in the local system key cache.
ReloadCache | Manually loads keys into the local system key cache.
Top
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method

Grid Solutions Framework CipherDecrypt Method
Overload List
Name | Description
Decrypt(Byte, String, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(String, String, CipherStrength) | Returns a decrypted string from a Base64 encoded string of binary encrypted data from the given parameters.
Decrypt(Byte, Byte, Byte, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Stream, Byte, Byte, CipherStrength) | Returns a stream of decrypted data for the given parameters.
Decrypt(Byte, Int32, Int32, String, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Byte, Int32, Int32, Byte, Byte, CipherStrength) | Returns a binary array of decrypted data for the given parameters.
Decrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Decrypts input stream onto output stream for the given parameters.
Top
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method (Byte[], String, CipherStrength)

Grid Solutions Framework CipherDecrypt Method (Byte, String, CipherStrength)
Returns a binary array of decrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Decrypt(
    this byte[] source,
    string password,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Decrypt (
    source As Byte(),
    password As String,
    strength As CipherStrength
) As Byte()
static member Decrypt :
        source : byte[] *
        password : string *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Decrypt = function(source, password, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Decrypt(
    array<unsigned char>^ source,
    String^ password,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to decrypt.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting data.

Return Value

Type: Byte
A decrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Decrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method (String, String, CipherStrength)

Grid Solutions Framework CipherDecrypt Method (String, String, CipherStrength)
Returns a decrypted string from a Base64 encoded string of binary encrypted data from the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Decrypt(
    this string source,
    string password,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Decrypt (
    source As String,
    password As String,
    strength As CipherStrength
) As String
static member Decrypt :
        source : string *
        password : string *
        strength : CipherStrength -> string

GSF.Security.Cryptography.Cipher.Decrypt = function(source, password, strength);
public:
[ExtensionAttribute]
static String^ Decrypt(
    String^ source,
    String^ password,
    CipherStrength strength
)

Parameters

source
Type: SystemString
Source string to decrypt.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting string.

Return Value

Type: String
A decrypted version of the source string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Decrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method (Byte[], Byte[], Byte[], CipherStrength)

Grid Solutions Framework CipherDecrypt Method (Byte, Byte, Byte, CipherStrength)
Returns a binary array of decrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Decrypt(
    this byte[] source,
    byte[] key,
    byte[] iv,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Decrypt (
    source As Byte(),
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength
) As Byte()
static member Decrypt :
        source : byte[] *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Decrypt = function(source, key, iv, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Decrypt(
    array<unsigned char>^ source,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to decrypt.
key
Type: SystemByte
Encryption key to use to decrypt data.
iv
Type: SystemByte
Initialization vector to use to decrypt data.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting data.

Return Value

Type: Byte
A decrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Decrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method (Stream, Byte[], Byte[], CipherStrength)

Grid Solutions Framework CipherDecrypt Method (Stream, Byte, Byte, CipherStrength)
Returns a stream of decrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MemoryStream Decrypt(
    this Stream source,
    byte[] key,
    byte[] iv,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Decrypt (
    source As Stream,
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength
) As MemoryStream
static member Decrypt :
        source : Stream *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength -> MemoryStream

GSF.Security.Cryptography.Cipher.Decrypt = function(source, key, iv, strength);
public:
[ExtensionAttribute]
static MemoryStream^ Decrypt(
    Stream^ source,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength
)

Parameters

source
Type: System.IOStream
Source stream that contains data to decrypt.
key
Type: SystemByte
Encryption key to use to decrypt stream.
iv
Type: SystemByte
Initialization vector to use to decrypt stream.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting stream.

Return Value

Type: MemoryStream
A decrypted version of the source stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This returns a memory stream of the decrypted results, if the incoming stream is very large this will consume a large amount of memory. In this case use the overload that takes the destination stream as a parameter instead.
See Also

Reference

Cipher Class
Decrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method (Byte[], Int32, Int32, String, CipherStrength)

Grid Solutions Framework CipherDecrypt Method (Byte, Int32, Int32, String, CipherStrength)
Returns a binary array of decrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Decrypt(
    this byte[] source,
    int startIndex,
    int length,
    string password,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Decrypt (
    source As Byte(),
    startIndex As Integer,
    length As Integer,
    password As String,
    strength As CipherStrength
) As Byte()
static member Decrypt :
        source : byte[] *
        startIndex : int *
        length : int *
        password : string *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Decrypt = function(source, startIndex, length, password, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Decrypt(
    array<unsigned char>^ source,
    int startIndex,
    int length,
    String^ password,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to decrypt.
startIndex
Type: SystemInt32
Offset into source buffer.
length
Type: SystemInt32
Number of bytes in source buffer to decrypt starting from startIndex offset.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting data.

Return Value

Type: Byte
A decrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Decrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method (Byte[], Int32, Int32, Byte[], Byte[], CipherStrength)

Grid Solutions Framework CipherDecrypt Method (Byte, Int32, Int32, Byte, Byte, CipherStrength)
Returns a binary array of decrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Decrypt(
    this byte[] source,
    int startIndex,
    int length,
    byte[] key,
    byte[] iv,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Decrypt (
    source As Byte(),
    startIndex As Integer,
    length As Integer,
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength
) As Byte()
static member Decrypt :
        source : byte[] *
        startIndex : int *
        length : int *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Decrypt = function(source, startIndex, length, key, iv, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Decrypt(
    array<unsigned char>^ source,
    int startIndex,
    int length,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to decrypt.
startIndex
Type: SystemInt32
Offset into source buffer.
length
Type: SystemInt32
Number of bytes in source buffer to decrypt starting from startIndex offset.
key
Type: SystemByte
Encryption key to use to decrypt data.
iv
Type: SystemByte
Initialization vector to use to decrypt data.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting data.

Return Value

Type: Byte
A decrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Decrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Decrypt Method (Stream, Stream, Byte[], Byte[], CipherStrength, Action(ProcessProgress(Int64)))

Grid Solutions Framework CipherDecrypt Method (Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64)
Decrypts input stream onto output stream for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Decrypt(
    this Stream source,
    Stream destination,
    byte[] key,
    byte[] iv,
    CipherStrength strength,
    Action<ProcessProgress<long>> progressHandler
)
<ExtensionAttribute>
Public Shared Sub Decrypt (
    source As Stream,
    destination As Stream,
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member Decrypt :
        source : Stream *
        destination : Stream *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.Security.Cryptography.Cipher.Decrypt = function(source, destination, key, iv, strength, progressHandler);
public:
[ExtensionAttribute]
static void Decrypt(
    Stream^ source,
    Stream^ destination,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

source
Type: System.IOStream
Source stream that contains data to decrypt.
destination
Type: System.IOStream
Destination stream used to hold decrypted data.
key
Type: SystemByte
Encryption key to use to decrypt stream.
iv
Type: SystemByte
Initialization vector to use to decrypt stream.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting stream.
progressHandler
Type: SystemAction ProcessProgress Int64
Optional delegate to handle progress updates for decrypting large streams.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Decrypt Overload
GSF.Security.Cryptography Namespace


Cipher.DecryptFile Method

Grid Solutions Framework CipherDecryptFile Method
Creates a decrypted file from source file data.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DecryptFile(
    string sourceFileName,
    string destinationFileName,
    string password,
    CipherStrength strength,
    Action<ProcessProgress<long>> progressHandler
)
Public Shared Sub DecryptFile (
    sourceFileName As String,
    destinationFileName As String,
    password As String,
    strength As CipherStrength,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member DecryptFile :
        sourceFileName : string *
        destinationFileName : string *
        password : string *
        strength : CipherStrength *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.Security.Cryptography.Cipher.DecryptFile = function(sourceFileName, destinationFileName, password, strength, progressHandler);
public:
static void DecryptFile(
    String^ sourceFileName,
    String^ destinationFileName,
    String^ password,
    CipherStrength strength,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

sourceFileName
Type: SystemString
Source file name.
destinationFileName
Type: SystemString
Destination file name.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when decrypting file.
progressHandler
Type: SystemAction ProcessProgress Int64
Optional delegate to handle progress updates for decrypting large files.
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method

Grid Solutions Framework CipherEncrypt Method
Overload List
Name | Description
Encrypt(Byte, String, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(String, String, CipherStrength) | Returns a Base64 encoded string of the returned binary array of the encrypted data, generated with the given parameters.
Encrypt(Byte, Byte, Byte, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Stream, Byte, Byte, CipherStrength) | Returns a stream of encrypted data for the given parameters.
Encrypt(Byte, Int32, Int32, String, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Byte, Int32, Int32, Byte, Byte, CipherStrength) | Returns a binary array of encrypted data for the given parameters.
Encrypt(Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64) | Encrypts input stream onto output stream for the given parameters.
Top
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method (Byte[], String, CipherStrength)

Grid Solutions Framework CipherEncrypt Method (Byte, String, CipherStrength)
Returns a binary array of encrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Encrypt(
    this byte[] source,
    string password,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Encrypt (
    source As Byte(),
    password As String,
    strength As CipherStrength
) As Byte()
static member Encrypt :
        source : byte[] *
        password : string *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Encrypt = function(source, password, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Encrypt(
    array<unsigned char>^ source,
    String^ password,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to encrypt.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting data.

Return Value

Type: Byte
An encrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Encrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method (String, String, CipherStrength)

Grid Solutions Framework CipherEncrypt Method (String, String, CipherStrength)
Returns a Base64 encoded string of the returned binary array of the encrypted data, generated with the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string Encrypt(
    this string source,
    string password,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Encrypt (
    source As String,
    password As String,
    strength As CipherStrength
) As String
static member Encrypt :
        source : string *
        password : string *
        strength : CipherStrength -> string

GSF.Security.Cryptography.Cipher.Encrypt = function(source, password, strength);
public:
[ExtensionAttribute]
static String^ Encrypt(
    String^ source,
    String^ password,
    CipherStrength strength
)

Parameters

source
Type: SystemString
Source string to encrypt.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting string.

Return Value

Type: String
An encrypted version of the source string.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Encrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method (Byte[], Byte[], Byte[], CipherStrength)

Grid Solutions Framework CipherEncrypt Method (Byte, Byte, Byte, CipherStrength)
Returns a binary array of encrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Encrypt(
    this byte[] source,
    byte[] key,
    byte[] iv,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Encrypt (
    source As Byte(),
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength
) As Byte()
static member Encrypt :
        source : byte[] *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Encrypt = function(source, key, iv, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Encrypt(
    array<unsigned char>^ source,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to encrypt.
key
Type: SystemByte
Encryption key to use to encrypt data.
iv
Type: SystemByte
Initialization vector to use to encrypt data.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting data.

Return Value

Type: Byte
An encrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Encrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method (Stream, Byte[], Byte[], CipherStrength)

Grid Solutions Framework CipherEncrypt Method (Stream, Byte, Byte, CipherStrength)
Returns a stream of encrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MemoryStream Encrypt(
    this Stream source,
    byte[] key,
    byte[] iv,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Encrypt (
    source As Stream,
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength
) As MemoryStream
static member Encrypt :
        source : Stream *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength -> MemoryStream

GSF.Security.Cryptography.Cipher.Encrypt = function(source, key, iv, strength);
public:
[ExtensionAttribute]
static MemoryStream^ Encrypt(
    Stream^ source,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength
)

Parameters

source
Type: System.IOStream
Source stream that contains data to encrypt.
key
Type: SystemByte
Encryption key to use to encrypt stream.
iv
Type: SystemByte
Initialization vector to use to encrypt stream.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting stream.

Return Value

Type: MemoryStream
An encrypted version of the source stream.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This returns a memory stream of the encrypted results, if the incoming stream is very large this will consume a large amount of memory. In this case use the overload that takes the destination stream as a parameter instead.
See Also

Reference

Cipher Class
Encrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method (Byte[], Int32, Int32, String, CipherStrength)

Grid Solutions Framework CipherEncrypt Method (Byte, Int32, Int32, String, CipherStrength)
Returns a binary array of encrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Encrypt(
    this byte[] source,
    int startIndex,
    int length,
    string password,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Encrypt (
    source As Byte(),
    startIndex As Integer,
    length As Integer,
    password As String,
    strength As CipherStrength
) As Byte()
static member Encrypt :
        source : byte[] *
        startIndex : int *
        length : int *
        password : string *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Encrypt = function(source, startIndex, length, password, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Encrypt(
    array<unsigned char>^ source,
    int startIndex,
    int length,
    String^ password,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to encrypt.
startIndex
Type: SystemInt32
Offset into source buffer.
length
Type: SystemInt32
Number of bytes in source buffer to encrypt starting from startIndex offset.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting data.

Return Value

Type: Byte
An encrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Encrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method (Byte[], Int32, Int32, Byte[], Byte[], CipherStrength)

Grid Solutions Framework CipherEncrypt Method (Byte, Int32, Int32, Byte, Byte, CipherStrength)
Returns a binary array of encrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Encrypt(
    this byte[] source,
    int startIndex,
    int length,
    byte[] key,
    byte[] iv,
    CipherStrength strength
)
<ExtensionAttribute>
Public Shared Function Encrypt (
    source As Byte(),
    startIndex As Integer,
    length As Integer,
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength
) As Byte()
static member Encrypt :
        source : byte[] *
        startIndex : int *
        length : int *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength -> byte[]

GSF.Security.Cryptography.Cipher.Encrypt = function(source, startIndex, length, key, iv, strength);
public:
[ExtensionAttribute]
static array<unsigned char>^ Encrypt(
    array<unsigned char>^ source,
    int startIndex,
    int length,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength
)

Parameters

source
Type: SystemByte
Binary array of data to encrypt.
startIndex
Type: SystemInt32
Offset into source buffer.
length
Type: SystemInt32
Number of bytes in source buffer to encrypt starting from startIndex offset.
key
Type: SystemByte
Encryption key to use to encrypt data.
iv
Type: SystemByte
Initialization vector to use to encrypt data.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting data.

Return Value

Type: Byte
An encrypted version of the source data.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Encrypt Overload
GSF.Security.Cryptography Namespace


Cipher.Encrypt Method (Stream, Stream, Byte[], Byte[], CipherStrength, Action(ProcessProgress(Int64)))

Grid Solutions Framework CipherEncrypt Method (Stream, Stream, Byte, Byte, CipherStrength, ActionProcessProgressInt64)
Encrypts input stream onto output stream for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Encrypt(
    this Stream source,
    Stream destination,
    byte[] key,
    byte[] iv,
    CipherStrength strength,
    Action<ProcessProgress<long>> progressHandler
)
<ExtensionAttribute>
Public Shared Sub Encrypt (
    source As Stream,
    destination As Stream,
    key As Byte(),
    iv As Byte(),
    strength As CipherStrength,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member Encrypt :
        source : Stream *
        destination : Stream *
        key : byte[] *
        iv : byte[] *
        strength : CipherStrength *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.Security.Cryptography.Cipher.Encrypt = function(source, destination, key, iv, strength, progressHandler);
public:
[ExtensionAttribute]
static void Encrypt(
    Stream^ source,
    Stream^ destination,
    array<unsigned char>^ key,
    array<unsigned char>^ iv,
    CipherStrength strength,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

source
Type: System.IOStream
Source stream that contains data to encrypt.
destination
Type: System.IOStream
Destination stream used to hold encrypted data.
key
Type: SystemByte
Encryption key to use to encrypt stream.
iv
Type: SystemByte
Initialization vector to use to encrypt stream.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting stream.
progressHandler
Type: SystemAction ProcessProgress Int64
Optional delegate to handle progress updates for encrypting large streams.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Stream. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

Cipher Class
Encrypt Overload
GSF.Security.Cryptography Namespace


Cipher.EncryptFile Method

Grid Solutions Framework CipherEncryptFile Method
Creates an encrypted file from source file data.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EncryptFile(
    string sourceFileName,
    string destinationFileName,
    string password,
    CipherStrength strength,
    Action<ProcessProgress<long>> progressHandler
)
Public Shared Sub EncryptFile (
    sourceFileName As String,
    destinationFileName As String,
    password As String,
    strength As CipherStrength,
    progressHandler As Action(Of ProcessProgress(Of Long))
)
static member EncryptFile :
        sourceFileName : string *
        destinationFileName : string *
        password : string *
        strength : CipherStrength *
        progressHandler : Action<ProcessProgress<int64>> -> unit

GSF.Security.Cryptography.Cipher.EncryptFile = function(sourceFileName, destinationFileName, password, strength, progressHandler);
public:
static void EncryptFile(
    String^ sourceFileName,
    String^ destinationFileName,
    String^ password,
    CipherStrength strength,
    Action<ProcessProgress<long long>^>^ progressHandler
)

Parameters

sourceFileName
Type: SystemString
Source file name.
destinationFileName
Type: SystemString
Destination file name.
password
Type: SystemString
User password used for key lookup.
strength
Type: GSF.Security.CryptographyCipherStrength
Cryptographic strength to use when encrypting file.
progressHandler
Type: SystemAction ProcessProgress Int64
Optional delegate to handle progress updates for encrypting large files.
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.ExportKeyIV Method

Grid Solutions Framework CipherExportKeyIV Method
Exports a key and initialization vector from the local system key cache.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ExportKeyIV(
    string password,
    int keySize
)
Public Shared Function ExportKeyIV (
    password As String,
    keySize As Integer
) As String
static member ExportKeyIV :
        password : string *
        keySize : int -> string

GSF.Security.Cryptography.Cipher.ExportKeyIV = function(password, keySize);
public:
static String^ ExportKeyIV(
    String^ password,
    int keySize
)

Parameters

password
Type: SystemString
User password used for key lookup.
keySize
Type: SystemInt32
Specifies the desired key size.

Return Value

Type: String
Text based key and initialization vector exported from local key cache.
Remarks
This method is used to manually export a key to be installed on another computer.
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.FlushCache Method

Grid Solutions Framework CipherFlushCache Method
Blocks current thread and waits for any pending save of local system key cache to complete.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void FlushCache(
    int millisecondsTimeout = -1
)
Public Shared Sub FlushCache (
    Optional millisecondsTimeout As Integer = -1
)
static member FlushCache :
        ?millisecondsTimeout : int
(* Defaults:
        let _millisecondsTimeout = defaultArg millisecondsTimeout -1
*)
-> unit

GSF.Security.Cryptography.Cipher.FlushCache = function(millisecondsTimeout);
public:
static void FlushCache(
    int millisecondsTimeout = -1
)

Parameters

millisecondsTimeout (Optional)
Type: SystemInt32
The number of milliseconds to wait, or Infinite(-1) to wait indefinitely.
Remarks

This method only needs to be used if crypto cache changes could be pending during application shutdown (i.e., executing ciphers with new keys that have not been saved, using existing keys does not queue crypto cache updates) to ensure keys are flushed before exit.

For most applications it is expected that this method would be rarely needed. However, possible usage scenarios would include:

  • Writing an application that establishes crypto keys where application lifetime would be very short (i.e., run, create keys, exit).
  • Creating new crypto keys during application shutdown (i.e., performing ciphers with non-existing keys at shutdown).

See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.GetPasswordHash Method

Grid Solutions Framework CipherGetPasswordHash Method
Gets the Base64 encoded SHA-256 hash of given user password.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetPasswordHash(
    string password,
    int categoryID = 0
)
Public Shared Function GetPasswordHash (
    password As String,
    Optional categoryID As Integer = 0
) As String
static member GetPasswordHash :
        password : string *
        ?categoryID : int
(* Defaults:
        let _categoryID = defaultArg categoryID 0
*)
-> string

GSF.Security.Cryptography.Cipher.GetPasswordHash = function(password, categoryID);
public:
static String^ GetPasswordHash(
    String^ password,
    int categoryID = 0
)

Parameters

password
Type: SystemString
User password to get hash for.
categoryID (Optional)
Type: SystemInt32
Specifies the desired category ID.

Return Value

Type: String
Base64 encoded SHA-256 hash of user password.
Remarks
The optional categoryID will be appended to the password to allow the same password to be used in different contexts and return different results, when useful.
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.ImportKeyIV Method

Grid Solutions Framework CipherImportKeyIV Method
Imports a key and initialization vector into the local system key cache.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ImportKeyIV(
    string password,
    int keySize,
    string keyIVText
)
Public Shared Sub ImportKeyIV (
    password As String,
    keySize As Integer,
    keyIVText As String
)
static member ImportKeyIV :
        password : string *
        keySize : int *
        keyIVText : string -> unit

GSF.Security.Cryptography.Cipher.ImportKeyIV = function(password, keySize, keyIVText);
public:
static void ImportKeyIV(
    String^ password,
    int keySize,
    String^ keyIVText
)

Parameters

password
Type: SystemString
User password used for key lookups.
keySize
Type: SystemInt32
Specifies the desired key size.
keyIVText
Type: SystemString
Text based key and initialization vector to import into local key cache.
Remarks
This method is used to manually import a key created on another computer.
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.KeyIVExists Method

Grid Solutions Framework CipherKeyIVExists Method
Determines if a key and initialization vector exists for the given password in the local system key cache.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool KeyIVExists(
    string password,
    int keySize
)
Public Shared Function KeyIVExists (
    password As String,
    keySize As Integer
) As Boolean
static member KeyIVExists :
        password : string *
        keySize : int -> bool

GSF.Security.Cryptography.Cipher.KeyIVExists = function(password, keySize);
public:
static bool KeyIVExists(
    String^ password,
    int keySize
)

Parameters

password
Type: SystemString
User password used for key lookups.
keySize
Type: SystemInt32
Specifies the desired key size.

Return Value

Type: Boolean
true if a key and initialization vector exists for the given password; otherwise false.
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


Cipher.ReloadCache Method

Grid Solutions Framework CipherReloadCache Method
Manually loads keys into the local system key cache.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ReloadCache()
Public Shared Sub ReloadCache
static member ReloadCache : unit -> unit

GSF.Security.Cryptography.Cipher.ReloadCache = function();
public:
static void ReloadCache()
See Also

Reference

Cipher Class
GSF.Security.Cryptography Namespace


CipherStrength Enumeration

Grid Solutions Framework CipherStrength Enumeration
Cryptographic strength enumeration.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum CipherStrength
Public Enumeration CipherStrength
type CipherStrength
GSF.Security.Cryptography.CipherStrength = function();
GSF.Security.Cryptography.CipherStrength.createEnum('GSF.Security.Cryptography.CipherStrength', false);
public enum class CipherStrength
Members
Member name | Value | Description
None | 0 | Uses no encryption.
Aes128 | 128 | Uses AES 128-bit encryption.
Aes256 | 256 | Uses AES 256-bit encryption.
See Also

Reference

GSF.Security.Cryptography Namespace


Random Class

Grid Solutions Framework Random Class
Generates cryptographically strong random numbers.
Inheritance Hierarchy
SystemObject
GSF.Security.CryptographyRandom

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Random
Public NotInheritable Class Random
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Random =  class end
GSF.Security.Cryptography.Random = function();

Type.createClass(
    'GSF.Security.Cryptography.Random');
public ref class Random abstract sealed

The Random type exposes the following members.

Methods
Name | Description
Between | Generates a cryptographically strong random integer between specified values.
ByteBetween | Generates a cryptographically strong 8-bit random integer between specified values.
GetBytes | Fills an array of bytes with a cryptographically strong sequence of random values.
Int16Between | Generates a cryptographically strong 16-bit random integer between specified values.
Int24Between(Int24, Int24) | Generates a cryptographically strong 24-bit random integer between specified values.
Int24Between(UInt24, UInt24) | Generates a cryptographically strong unsigned 24-bit random integer between specified values.
Int32Between | Generates a cryptographically strong 32-bit random integer between specified values.
Int64Between | Generates a cryptographically strong 64-bit random integer between specified values.
UInt16Between | Generates a cryptographically strong unsigned 16-bit random integer between specified values.
UInt32Between | Generates a cryptographically strong unsigned 32-bit random integer between specified values.
UInt64Between | Generates a cryptographically strong unsigned 64-bit random integer between specified values.
Top
Properties
Name | Description
Boolean | Generates a cryptographically strong random boolean (i.e., a coin toss).
Byte | Generates a cryptographically strong 8-bit random integer.
Decimal | Generates a cryptographically strong random decimal between zero and one.
Int16 | Generates a cryptographically strong 16-bit random integer.
Int24 | Generates a cryptographically strong 24-bit random integer.
Int32 | Generates a cryptographically strong 32-bit random integer.
Int64 | Generates a cryptographically strong 64-bit random integer.
Number | Generates a cryptographically strong double-precision floating-point random number between zero and one.
UInt16 | Generates a cryptographically strong unsigned 16-bit random integer.
UInt24 | Generates a cryptographically strong unsigned 24-bit random integer.
UInt32 | Generates a cryptographically strong unsigned 32-bit random integer.
UInt64 | Generates a cryptographically strong unsigned 64-bit random integer.
Top
See Also

Reference

GSF.Security.Cryptography Namespace


Random Methods

Grid Solutions Framework Random Methods

The Random type exposes the following members.

Methods
Name | Description
Between | Generates a cryptographically strong random integer between specified values.
ByteBetween | Generates a cryptographically strong 8-bit random integer between specified values.
GetBytes | Fills an array of bytes with a cryptographically strong sequence of random values.
Int16Between | Generates a cryptographically strong 16-bit random integer between specified values.
Int24Between(Int24, Int24) | Generates a cryptographically strong 24-bit random integer between specified values.
Int24Between(UInt24, UInt24) | Generates a cryptographically strong unsigned 24-bit random integer between specified values.
Int32Between | Generates a cryptographically strong 32-bit random integer between specified values.
Int64Between | Generates a cryptographically strong 64-bit random integer between specified values.
UInt16Between | Generates a cryptographically strong unsigned 16-bit random integer between specified values.
UInt32Between | Generates a cryptographically strong unsigned 32-bit random integer between specified values.
UInt64Between | Generates a cryptographically strong unsigned 64-bit random integer between specified values.
Top
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Between Method

Grid Solutions Framework RandomBetween Method
Generates a cryptographically strong random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Between(
    double startNumber,
    double stopNumber
)
Public Shared Function Between (
    startNumber As Double,
    stopNumber As Double
) As Double
static member Between :
        startNumber : float *
        stopNumber : float -> float

GSF.Security.Cryptography.Random.Between = function(startNumber, stopNumber);
public:
static double Between(
    double startNumber,
    double stopNumber
)

Parameters

startNumber
Type: SystemDouble
A Double that is the low end of our range.
stopNumber
Type: SystemDouble
A Double that is the high end of our range.

Return Value

Type: Double
A Double that is generated between the startNumber and the stopNumber, or an excception.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.ByteBetween Method

Grid Solutions Framework RandomByteBetween Method
Generates a cryptographically strong 8-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte ByteBetween(
    byte startNumber,
    byte stopNumber
)
Public Shared Function ByteBetween (
    startNumber As Byte,
    stopNumber As Byte
) As Byte
static member ByteBetween :
        startNumber : byte *
        stopNumber : byte -> byte

GSF.Security.Cryptography.Random.ByteBetween = function(startNumber, stopNumber);
public:
static unsigned char ByteBetween(
    unsigned char startNumber,
    unsigned char stopNumber
)

Parameters

startNumber
Type: SystemByte
A Byte that is the low end of our range.
stopNumber
Type: SystemByte
A Byte that is the high end of our range.

Return Value

Type: Byte
A Byte that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.GetBytes Method

Grid Solutions Framework RandomGetBytes Method
Fills an array of bytes with a cryptographically strong sequence of random values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void GetBytes(
    byte[] buffer
)
Public Shared Sub GetBytes (
    buffer As Byte()
)
static member GetBytes :
        buffer : byte[] -> unit

GSF.Security.Cryptography.Random.GetBytes = function(buffer);
public:
static void GetBytes(
    array<unsigned char>^ buffer
)

Parameters

buffer
Type: SystemByte
The array to fill with a cryptographically strong sequence of random values.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
ArgumentNullException | buffer is null.
Remarks

The length of the byte array determines how many cryptographically strong random bytes are produced.

This method is thread safe.

See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int16Between Method

Grid Solutions Framework RandomInt16Between Method
Generates a cryptographically strong 16-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short Int16Between(
    short startNumber,
    short stopNumber
)
Public Shared Function Int16Between (
    startNumber As Short,
    stopNumber As Short
) As Short
static member Int16Between :
        startNumber : int16 *
        stopNumber : int16 -> int16

GSF.Security.Cryptography.Random.Int16Between = function(startNumber, stopNumber);
public:
static short Int16Between(
    short startNumber,
    short stopNumber
)

Parameters

startNumber
Type: SystemInt16
A Int16 that is the low end of our range.
stopNumber
Type: SystemInt16
A Int16 that is the high end of our range.

Return Value

Type: Int16
A Int16 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int24Between Method

Grid Solutions Framework RandomInt24Between Method
Overload List
Name | Description
Int24Between(Int24, Int24) | Generates a cryptographically strong 24-bit random integer between specified values.
Int24Between(UInt24, UInt24) | Generates a cryptographically strong unsigned 24-bit random integer between specified values.
Top
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int24Between Method (Int24, Int24)

Grid Solutions Framework RandomInt24Between Method (Int24, Int24)
Generates a cryptographically strong 24-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 Int24Between(
    Int24 startNumber,
    Int24 stopNumber
)
Public Shared Function Int24Between (
    startNumber As Int24,
    stopNumber As Int24
) As Int24
static member Int24Between :
        startNumber : Int24 *
        stopNumber : Int24 -> Int24

GSF.Security.Cryptography.Random.Int24Between = function(startNumber, stopNumber);
public:
static Int24 Int24Between(
    Int24 startNumber,
    Int24 stopNumber
)

Parameters

startNumber
Type: GSFInt24
A Int24 that is the low end of our range.
stopNumber
Type: GSFInt24
A Int24 that is the high end of our range.

Return Value

Type: Int24
A Int24 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
Int24Between Overload
GSF.Security.Cryptography Namespace


Random.Int24Between Method (UInt24, UInt24)

Grid Solutions Framework RandomInt24Between Method (UInt24, UInt24)
Generates a cryptographically strong unsigned 24-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 Int24Between(
    UInt24 startNumber,
    UInt24 stopNumber
)
Public Shared Function Int24Between (
    startNumber As UInt24,
    stopNumber As UInt24
) As UInt24
static member Int24Between :
        startNumber : UInt24 *
        stopNumber : UInt24 -> UInt24

GSF.Security.Cryptography.Random.Int24Between = function(startNumber, stopNumber);
public:
static UInt24 Int24Between(
    UInt24 startNumber,
    UInt24 stopNumber
)

Parameters

startNumber
Type: GSFUInt24
A UInt24 that is the low end of our range.
stopNumber
Type: GSFUInt24
A UInt24 that is the high end of our range.

Return Value

Type: UInt24
A UInt24 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
Int24Between Overload
GSF.Security.Cryptography Namespace


Random.Int32Between Method

Grid Solutions Framework RandomInt32Between Method
Generates a cryptographically strong 32-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int Int32Between(
    int startNumber,
    int stopNumber
)
Public Shared Function Int32Between (
    startNumber As Integer,
    stopNumber As Integer
) As Integer
static member Int32Between :
        startNumber : int *
        stopNumber : int -> int

GSF.Security.Cryptography.Random.Int32Between = function(startNumber, stopNumber);
public:
static int Int32Between(
    int startNumber,
    int stopNumber
)

Parameters

startNumber
Type: SystemInt32
A Int32 that is the low end of our range.
stopNumber
Type: SystemInt32
A Int32 that is the high end of our range.

Return Value

Type: Int32
A Int32 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int64Between Method

Grid Solutions Framework RandomInt64Between Method
Generates a cryptographically strong 64-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long Int64Between(
    long startNumber,
    long stopNumber
)
Public Shared Function Int64Between (
    startNumber As Long,
    stopNumber As Long
) As Long
static member Int64Between :
        startNumber : int64 *
        stopNumber : int64 -> int64

GSF.Security.Cryptography.Random.Int64Between = function(startNumber, stopNumber);
public:
static long long Int64Between(
    long long startNumber,
    long long stopNumber
)

Parameters

startNumber
Type: SystemInt64
A Int64 that is the low end of our range.
stopNumber
Type: SystemInt64
A Int64 that is the high end of our range.

Return Value

Type: Int64
A Int64 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.UInt16Between Method

Grid Solutions Framework RandomUInt16Between Method
Generates a cryptographically strong unsigned 16-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort UInt16Between(
    ushort startNumber,
    ushort stopNumber
)
Public Shared Function UInt16Between (
    startNumber As UShort,
    stopNumber As UShort
) As UShort
static member UInt16Between :
        startNumber : uint16 *
        stopNumber : uint16 -> uint16

GSF.Security.Cryptography.Random.UInt16Between = function(startNumber, stopNumber);
public:
static unsigned short UInt16Between(
    unsigned short startNumber,
    unsigned short stopNumber
)

Parameters

startNumber
Type: SystemUInt16
A UInt16 that is the low end of our range.
stopNumber
Type: SystemUInt16
A UInt16 that is the high end of our range.

Return Value

Type: UInt16
A UInt16 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.UInt32Between Method

Grid Solutions Framework RandomUInt32Between Method
Generates a cryptographically strong unsigned 32-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint UInt32Between(
    uint startNumber,
    uint stopNumber
)
Public Shared Function UInt32Between (
    startNumber As UInteger,
    stopNumber As UInteger
) As UInteger
static member UInt32Between :
        startNumber : uint32 *
        stopNumber : uint32 -> uint32

GSF.Security.Cryptography.Random.UInt32Between = function(startNumber, stopNumber);
public:
static unsigned int UInt32Between(
    unsigned int startNumber,
    unsigned int stopNumber
)

Parameters

startNumber
Type: SystemUInt32
A UInt32 that is the low end of our range.
stopNumber
Type: SystemUInt32
A UInt32 that is the high end of our range.

Return Value

Type: UInt32
A UInt32 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.UInt64Between Method

Grid Solutions Framework RandomUInt64Between Method
Generates a cryptographically strong unsigned 64-bit random integer between specified values.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong UInt64Between(
    ulong startNumber,
    ulong stopNumber
)
Public Shared Function UInt64Between (
    startNumber As ULong,
    stopNumber As ULong
) As ULong
static member UInt64Between :
        startNumber : uint64 *
        stopNumber : uint64 -> uint64

GSF.Security.Cryptography.Random.UInt64Between = function(startNumber, stopNumber);
public:
static unsigned long long UInt64Between(
    unsigned long long startNumber,
    unsigned long long stopNumber
)

Parameters

startNumber
Type: SystemUInt64
A UInt64 that is the low end of our range.
stopNumber
Type: SystemUInt64
A UInt64 that is the high end of our range.

Return Value

Type: UInt64
A UInt64 that is generated between the startNumber and the stopNumber.
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random Properties

Grid Solutions Framework Random Properties

The Random type exposes the following members.

Properties
Name | Description
Boolean | Generates a cryptographically strong random boolean (i.e., a coin toss).
Byte | Generates a cryptographically strong 8-bit random integer.
Decimal | Generates a cryptographically strong random decimal between zero and one.
Int16 | Generates a cryptographically strong 16-bit random integer.
Int24 | Generates a cryptographically strong 24-bit random integer.
Int32 | Generates a cryptographically strong 32-bit random integer.
Int64 | Generates a cryptographically strong 64-bit random integer.
Number | Generates a cryptographically strong double-precision floating-point random number between zero and one.
UInt16 | Generates a cryptographically strong unsigned 16-bit random integer.
UInt24 | Generates a cryptographically strong unsigned 24-bit random integer.
UInt32 | Generates a cryptographically strong unsigned 32-bit random integer.
UInt64 | Generates a cryptographically strong unsigned 64-bit random integer.
Top
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Boolean Property

Grid Solutions Framework RandomBoolean Property
Generates a cryptographically strong random boolean (i.e., a coin toss).

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool Boolean { get; }
Public Shared ReadOnly Property Boolean As Boolean
    Get
static member Boolean : bool with get

GSF.Security.Cryptography.Random.get_Boolean = function();

public:
static property bool Boolean {
    bool get ();
}

Property Value

Type: Boolean
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Byte Property

Grid Solutions Framework RandomByte Property
Generates a cryptographically strong 8-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte Byte { get; }
Public Shared ReadOnly Property Byte As Byte
    Get
static member Byte : byte with get

GSF.Security.Cryptography.Random.get_Byte = function();

public:
static property unsigned char Byte {
    unsigned char get ();
}

Property Value

Type: Byte
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Decimal Property

Grid Solutions Framework RandomDecimal Property
Generates a cryptographically strong random decimal between zero and one.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static decimal Decimal { get; }
Public Shared ReadOnly Property Decimal As Decimal
    Get
static member Decimal : decimal with get

GSF.Security.Cryptography.Random.get_Decimal = function();

public:
static property Decimal Decimal {
    Decimal get ();
}

Property Value

Type: Decimal
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int16 Property

Grid Solutions Framework RandomInt16 Property
Generates a cryptographically strong 16-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static short Int16 { get; }
Public Shared ReadOnly Property Int16 As Short
    Get
static member Int16 : int16 with get

GSF.Security.Cryptography.Random.get_Int16 = function();

public:
static property short Int16 {
    short get ();
}

Property Value

Type: Int16
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int24 Property

Grid Solutions Framework RandomInt24 Property
Generates a cryptographically strong 24-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Int24 Int24 { get; }
Public Shared ReadOnly Property Int24 As Int24
    Get
static member Int24 : Int24 with get

GSF.Security.Cryptography.Random.get_Int24 = function();

public:
static property Int24 Int24 {
    Int24 get ();
}

Property Value

Type: Int24
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int32 Property

Grid Solutions Framework RandomInt32 Property
Generates a cryptographically strong 32-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int Int32 { get; }
Public Shared ReadOnly Property Int32 As Integer
    Get
static member Int32 : int with get

GSF.Security.Cryptography.Random.get_Int32 = function();

public:
static property int Int32 {
    int get ();
}

Property Value

Type: Int32
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Int64 Property

Grid Solutions Framework RandomInt64 Property
Generates a cryptographically strong 64-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long Int64 { get; }
Public Shared ReadOnly Property Int64 As Long
    Get
static member Int64 : int64 with get

GSF.Security.Cryptography.Random.get_Int64 = function();

public:
static property long long Int64 {
    long long get ();
}

Property Value

Type: Int64
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.Number Property

Grid Solutions Framework RandomNumber Property
Generates a cryptographically strong double-precision floating-point random number between zero and one.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double Number { get; }
Public Shared ReadOnly Property Number As Double
    Get
static member Number : float with get

GSF.Security.Cryptography.Random.get_Number = function();

public:
static property double Number {
    double get ();
}

Property Value

Type: Double
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.UInt16 Property

Grid Solutions Framework RandomUInt16 Property
Generates a cryptographically strong unsigned 16-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ushort UInt16 { get; }
Public Shared ReadOnly Property UInt16 As UShort
    Get
static member UInt16 : uint16 with get

GSF.Security.Cryptography.Random.get_UInt16 = function();

public:
static property unsigned short UInt16 {
    unsigned short get ();
}

Property Value

Type: UInt16
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.UInt24 Property

Grid Solutions Framework RandomUInt24 Property
Generates a cryptographically strong unsigned 24-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static UInt24 UInt24 { get; }
Public Shared ReadOnly Property UInt24 As UInt24
    Get
static member UInt24 : UInt24 with get

GSF.Security.Cryptography.Random.get_UInt24 = function();

public:
static property UInt24 UInt24 {
    UInt24 get ();
}

Property Value

Type: UInt24
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.UInt32 Property

Grid Solutions Framework RandomUInt32 Property
Generates a cryptographically strong unsigned 32-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static uint UInt32 { get; }
Public Shared ReadOnly Property UInt32 As UInteger
    Get
static member UInt32 : uint32 with get

GSF.Security.Cryptography.Random.get_UInt32 = function();

public:
static property unsigned int UInt32 {
    unsigned int get ();
}

Property Value

Type: UInt32
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


Random.UInt64 Property

Grid Solutions Framework RandomUInt64 Property
Generates a cryptographically strong unsigned 64-bit random integer.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ulong UInt64 { get; }
Public Shared ReadOnly Property UInt64 As ULong
    Get
static member UInt64 : uint64 with get

GSF.Security.Cryptography.Random.get_UInt64 = function();

public:
static property unsigned long long UInt64 {
    unsigned long long get ();
}

Property Value

Type: UInt64
Exceptions
Exception | Condition
CryptographicException | The cryptographic service provider (CSP) cannot be acquired.
See Also

Reference

Random Class
GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions Class

Grid Solutions Framework SymmetricAlgorithmExtensions Class
Defines extension functions related to cryptographic SymmetricAlgorithm objects.
Inheritance Hierarchy
SystemObject
GSF.Security.CryptographySymmetricAlgorithmExtensions

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SymmetricAlgorithmExtensions
<ExtensionAttribute>
Public NotInheritable Class SymmetricAlgorithmExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SymmetricAlgorithmExtensions =  class end
GSF.Security.Cryptography.SymmetricAlgorithmExtensions = function();

Type.createClass(
    'GSF.Security.Cryptography.SymmetricAlgorithmExtensions');
[ExtensionAttribute]
public ref class SymmetricAlgorithmExtensions abstract sealed
Methods
Name | Description
Decrypt(SymmetricAlgorithm, Stream, Stream, Byte, Byte) | Decrypts input stream onto output stream for the given parameters.
Decrypt(SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte) | Returns a binary array of decrypted data for the given parameters.
Encrypt(SymmetricAlgorithm, Stream, Stream, Byte, Byte) | Encrypts input stream onto output stream for the given parameters.
Encrypt(SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte) | Returns a binary array of encrypted data for the given parameters.
Top
See Also

Reference

GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions Methods

Grid Solutions Framework SymmetricAlgorithmExtensions Methods
Methods
Name | Description
Decrypt(SymmetricAlgorithm, Stream, Stream, Byte, Byte) | Decrypts input stream onto output stream for the given parameters.
Decrypt(SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte) | Returns a binary array of decrypted data for the given parameters.
Encrypt(SymmetricAlgorithm, Stream, Stream, Byte, Byte) | Encrypts input stream onto output stream for the given parameters.
Encrypt(SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte) | Returns a binary array of encrypted data for the given parameters.
Top
See Also

Reference

SymmetricAlgorithmExtensions Class
GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions.Decrypt Method

Grid Solutions Framework SymmetricAlgorithmExtensionsDecrypt Method
Overload List
Name | Description
Decrypt(SymmetricAlgorithm, Stream, Stream, Byte, Byte) | Decrypts input stream onto output stream for the given parameters.
Decrypt(SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte) | Returns a binary array of decrypted data for the given parameters.
Top
See Also

Reference

SymmetricAlgorithmExtensions Class
GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions.Decrypt Method (SymmetricAlgorithm, Stream, Stream, Byte[], Byte[])

Grid Solutions Framework SymmetricAlgorithmExtensionsDecrypt Method (SymmetricAlgorithm, Stream, Stream, Byte, Byte)
Decrypts input stream onto output stream for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Decrypt(
    this SymmetricAlgorithm algorithm,
    Stream source,
    Stream destination,
    byte[] key,
    byte[] iv
)
<ExtensionAttribute>
Public Shared Sub Decrypt (
    algorithm As SymmetricAlgorithm,
    source As Stream,
    destination As Stream,
    key As Byte(),
    iv As Byte()
)
static member Decrypt :
        algorithm : SymmetricAlgorithm *
        source : Stream *
        destination : Stream *
        key : byte[] *
        iv : byte[] -> unit

GSF.Security.Cryptography.SymmetricAlgorithmExtensions.Decrypt = function(algorithm, source, destination, key, iv);
public:
[ExtensionAttribute]
static void Decrypt(
    SymmetricAlgorithm^ algorithm,
    Stream^ source,
    Stream^ destination,
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

algorithm
Type: System.Security.CryptographySymmetricAlgorithm
SymmetricAlgorithm to use for decryption.
source
Type: System.IOStream
Source stream that contains data to decrypt.
destination
Type: System.IOStream
Destination stream used to hold decrypted data.
key
Type: SystemByte
The secret key to use for the symmetric algorithm.
iv
Type: SystemByte
The initialization vector to use for the symmetric algorithm.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SymmetricAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SymmetricAlgorithmExtensions Class
Decrypt Overload
GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions.Decrypt Method (SymmetricAlgorithm, Byte[], Int32, Int32, Byte[], Byte[])

Grid Solutions Framework SymmetricAlgorithmExtensionsDecrypt Method (SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte)
Returns a binary array of decrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Decrypt(
    this SymmetricAlgorithm algorithm,
    byte[] data,
    int startIndex,
    int length,
    byte[] key,
    byte[] iv
)
<ExtensionAttribute>
Public Shared Function Decrypt (
    algorithm As SymmetricAlgorithm,
    data As Byte(),
    startIndex As Integer,
    length As Integer,
    key As Byte(),
    iv As Byte()
) As Byte()
static member Decrypt :
        algorithm : SymmetricAlgorithm *
        data : byte[] *
        startIndex : int *
        length : int *
        key : byte[] *
        iv : byte[] -> byte[]

GSF.Security.Cryptography.SymmetricAlgorithmExtensions.Decrypt = function(algorithm, data, startIndex, length, key, iv);
public:
[ExtensionAttribute]
static array<unsigned char>^ Decrypt(
    SymmetricAlgorithm^ algorithm,
    array<unsigned char>^ data,
    int startIndex,
    int length,
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

algorithm
Type: System.Security.CryptographySymmetricAlgorithm
SymmetricAlgorithm to use for decryption.
data
Type: SystemByte
Source buffer containing data to decrypt.
startIndex
Type: SystemInt32
Offset into data buffer.
length
Type: SystemInt32
Number of bytes in data buffer to decrypt starting from startIndex offset.
key
Type: SystemByte
The secret key to use for the symmetric algorithm.
iv
Type: SystemByte
The initialization vector to use for the symmetric algorithm.

Return Value

Type: Byte
Decrypted version of data buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SymmetricAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SymmetricAlgorithmExtensions Class
Decrypt Overload
GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions.Encrypt Method

Grid Solutions Framework SymmetricAlgorithmExtensionsEncrypt Method
Overload List
Name | Description
Encrypt(SymmetricAlgorithm, Stream, Stream, Byte, Byte) | Encrypts input stream onto output stream for the given parameters.
Encrypt(SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte) | Returns a binary array of encrypted data for the given parameters.
Top
See Also

Reference

SymmetricAlgorithmExtensions Class
GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions.Encrypt Method (SymmetricAlgorithm, Stream, Stream, Byte[], Byte[])

Grid Solutions Framework SymmetricAlgorithmExtensionsEncrypt Method (SymmetricAlgorithm, Stream, Stream, Byte, Byte)
Encrypts input stream onto output stream for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Encrypt(
    this SymmetricAlgorithm algorithm,
    Stream source,
    Stream destination,
    byte[] key,
    byte[] iv
)
<ExtensionAttribute>
Public Shared Sub Encrypt (
    algorithm As SymmetricAlgorithm,
    source As Stream,
    destination As Stream,
    key As Byte(),
    iv As Byte()
)
static member Encrypt :
        algorithm : SymmetricAlgorithm *
        source : Stream *
        destination : Stream *
        key : byte[] *
        iv : byte[] -> unit

GSF.Security.Cryptography.SymmetricAlgorithmExtensions.Encrypt = function(algorithm, source, destination, key, iv);
public:
[ExtensionAttribute]
static void Encrypt(
    SymmetricAlgorithm^ algorithm,
    Stream^ source,
    Stream^ destination,
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

algorithm
Type: System.Security.CryptographySymmetricAlgorithm
SymmetricAlgorithm to use for encryption.
source
Type: System.IOStream
Source stream that contains data to encrypt.
destination
Type: System.IOStream
Destination stream used to hold encrypted data.
key
Type: SystemByte
The secret key to use for the symmetric algorithm.
iv
Type: SystemByte
The initialization vector to use for the symmetric algorithm.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SymmetricAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SymmetricAlgorithmExtensions Class
Encrypt Overload
GSF.Security.Cryptography Namespace


SymmetricAlgorithmExtensions.Encrypt Method (SymmetricAlgorithm, Byte[], Int32, Int32, Byte[], Byte[])

Grid Solutions Framework SymmetricAlgorithmExtensionsEncrypt Method (SymmetricAlgorithm, Byte, Int32, Int32, Byte, Byte)
Returns a binary array of encrypted data for the given parameters.

Namespace: GSF.Security.Cryptography
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static byte[] Encrypt(
    this SymmetricAlgorithm algorithm,
    byte[] data,
    int startIndex,
    int length,
    byte[] key,
    byte[] iv
)
<ExtensionAttribute>
Public Shared Function Encrypt (
    algorithm As SymmetricAlgorithm,
    data As Byte(),
    startIndex As Integer,
    length As Integer,
    key As Byte(),
    iv As Byte()
) As Byte()
static member Encrypt :
        algorithm : SymmetricAlgorithm *
        data : byte[] *
        startIndex : int *
        length : int *
        key : byte[] *
        iv : byte[] -> byte[]

GSF.Security.Cryptography.SymmetricAlgorithmExtensions.Encrypt = function(algorithm, data, startIndex, length, key, iv);
public:
[ExtensionAttribute]
static array<unsigned char>^ Encrypt(
    SymmetricAlgorithm^ algorithm,
    array<unsigned char>^ data,
    int startIndex,
    int length,
    array<unsigned char>^ key,
    array<unsigned char>^ iv
)

Parameters

algorithm
Type: System.Security.CryptographySymmetricAlgorithm
SymmetricAlgorithm to use for encryption.
data
Type: SystemByte
Source buffer containing data to encrypt.
startIndex
Type: SystemInt32
Offset into data buffer.
length
Type: SystemInt32
Number of bytes in data buffer to encrypt starting from startIndex offset.
key
Type: SystemByte
The secret key to use for the symmetric algorithm.
iv
Type: SystemByte
The initialization vector to use for the symmetric algorithm.

Return Value

Type: Byte
Encrypted version of data buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SymmetricAlgorithm. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SymmetricAlgorithmExtensions Class
Encrypt Overload
GSF.Security.Cryptography Namespace


GSF.SELEventParser Namespace

Grid Solutions Framework GSF.SELEventParser Namespace

[Missing <summary> documentation for "N:GSF.SELEventParser"]

Classes
 | Class | Description
Public class | AnalogSection |
Public class | ChannelT |
Public class | CycleT |
Public class | EventFile |
Public class | EventHistory |
Public class | EventHistoryRecord |
Public class | EventReport |
Public class | Firmware |
Public class | Header |


AnalogSection Class

Grid Solutions Framework AnalogSection Class

[Missing <summary> documentation for "T:GSF.SELEventParser.AnalogSection"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserAnalogSection

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AnalogSection
Public Class AnalogSection
type AnalogSection =  class end
GSF.SELEventParser.AnalogSection = function();

Type.createClass(
    'GSF.SELEventParser.AnalogSection');
public ref class AnalogSection

The AnalogSection type exposes the following members.

Constructors
 | Name | Description
Public method | AnalogSection | Initializes a new instance of the AnalogSection class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnalogChannel |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogChannels |
Public property | TimeChannel |
Top
See Also

Reference

GSF.SELEventParser Namespace


AnalogSection Constructor

Grid Solutions Framework AnalogSection Constructor
Initializes a new instance of the AnalogSection class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogSection()
Public Sub New
new : unit -> AnalogSection
GSF.SELEventParser.AnalogSection = function();
public:
AnalogSection()
See Also

Reference

AnalogSection Class
GSF.SELEventParser Namespace


AnalogSection Methods

Grid Solutions Framework AnalogSection Methods

The AnalogSection type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAnalogChannel |
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AnalogSection Class
GSF.SELEventParser Namespace


AnalogSection.GetAnalogChannel Method

Grid Solutions Framework AnalogSectionGetAnalogChannel Method

[Missing <summary> documentation for "M:GSF.SELEventParser.AnalogSection.GetAnalogChannel(System.String)"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Channel<double> GetAnalogChannel(
    string name
)
Public Function GetAnalogChannel (
    name As String
) As Channel(Of Double)
member GetAnalogChannel :
        name : string -> Channel<float>

function GetAnalogChannel(name);
public:
Channel<double>^ GetAnalogChannel(
    String^ name
)

Parameters

name
Type: SystemString

[Missing <param name="name"/> documentation for "M:GSF.SELEventParser.AnalogSection.GetAnalogChannel(System.String)"]

Return Value

Type: Channel Double

[Missing <returns> documentation for "M:GSF.SELEventParser.AnalogSection.GetAnalogChannel(System.String)"]

See Also

Reference

AnalogSection Class
GSF.SELEventParser Namespace


AnalogSection Properties

Grid Solutions Framework AnalogSection Properties

The AnalogSection type exposes the following members.

Properties
 | Name | Description
Public property | AnalogChannels |
Public property | TimeChannel |
Top
See Also

Reference

AnalogSection Class
GSF.SELEventParser Namespace


AnalogSection.AnalogChannels Property

Grid Solutions Framework AnalogSectionAnalogChannels Property

[Missing <summary> documentation for "P:GSF.SELEventParser.AnalogSection.AnalogChannels"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<Channel<double>> AnalogChannels { get; set; }
Public Property AnalogChannels As List(Of Channel(Of Double))
    Get
    Set
member AnalogChannels : List<Channel<float>> with get, set

function get_AnalogChannels();
function set_AnalogChannels(value);
public:
property List<Channel<double>^>^ AnalogChannels {
    List<Channel<double>^>^ get ();
    void set (List<Channel<double>^>^ value);
}

Property Value

Type: List Channel Double
See Also

Reference

AnalogSection Class
GSF.SELEventParser Namespace


AnalogSection.TimeChannel Property

Grid Solutions Framework AnalogSectionTimeChannel Property

[Missing <summary> documentation for "P:GSF.SELEventParser.AnalogSection.TimeChannel"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Channel<DateTime> TimeChannel { get; set; }
Public Property TimeChannel As Channel(Of DateTime)
    Get
    Set
member TimeChannel : Channel<DateTime> with get, set

function get_TimeChannel();
function set_TimeChannel(value);
public:
property Channel<DateTime>^ TimeChannel {
    Channel<DateTime>^ get ();
    void set (Channel<DateTime>^ value);
}

Property Value

Type: Channel DateTime
See Also

Reference

AnalogSection Class
GSF.SELEventParser Namespace


Channel(T) Class

Grid Solutions Framework ChannelT Class

[Missing <summary> documentation for "T:GSF.SELEventParser.Channel`1"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserChannelT

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Channel<T>

Public Class Channel(Of T)
type Channel<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class Channel

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GSF.SELEventParser.Channel`1"]

The ChannelT type exposes the following members.

Constructors
 | Name | Description
Public method | ChannelT | Initializes a new instance of the ChannelT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Cycles |
Public property | Name |
Public property | Samples |
Top
See Also

Reference

GSF.SELEventParser Namespace


Channel(T) Constructor

Grid Solutions Framework ChannelT Constructor
Initializes a new instance of the ChannelT class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Channel()
Public Sub New
new : unit -> Channel
GSF.SELEventParser.Channel = function();
public:
Channel()
See Also

Reference

ChannelT Class
GSF.SELEventParser Namespace


Channel(T) Methods

Grid Solutions Framework ChannelT Methods

The ChannelT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ChannelT Class
GSF.SELEventParser Namespace


Channel(T) Properties

Grid Solutions Framework ChannelT Properties

The ChannelT generic type exposes the following members.

Properties
 | Name | Description
Public property | Cycles |
Public property | Name |
Public property | Samples |
Top
See Also

Reference

ChannelT Class
GSF.SELEventParser Namespace


Channel(T).Cycles Property

Grid Solutions Framework ChannelTCycles Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Channel`1.Cycles"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<Cycle<T>> Cycles { get; set; }
Public Property Cycles As List(Of Cycle(Of T))
    Get
    Set
member Cycles : List<Cycle<'T>> with get, set

function get_Cycles();
function set_Cycles(value);
public:
property List<Cycle<T>^>^ Cycles {
    List<Cycle<T>^>^ get ();
    void set (List<Cycle<T>^>^ value);
}

Property Value

Type: List Cycle T
See Also

Reference

ChannelT Class
GSF.SELEventParser Namespace


Channel(T).Name Property

Grid Solutions Framework ChannelTName Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Channel`1.Name"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ChannelT Class
GSF.SELEventParser Namespace


Channel(T).Samples Property

Grid Solutions Framework ChannelTSamples Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Channel`1.Samples"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<T> Samples { get; }
Public ReadOnly Property Samples As List(Of T)
    Get
member Samples : List<'T> with get

function get_Samples();

public:
property List<T>^ Samples {
    List<T>^ get ();
}

Property Value

Type: List T
See Also

Reference

ChannelT Class
GSF.SELEventParser Namespace


Cycle(T) Class

Grid Solutions Framework CycleT Class

[Missing <summary> documentation for "T:GSF.SELEventParser.Cycle`1"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserCycleT

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Cycle<T>

Public Class Cycle(Of T)
type Cycle<'T> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class Cycle

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GSF.SELEventParser.Cycle`1"]

The CycleT type exposes the following members.

Constructors
 | Name | Description
Public method | CycleT | Initializes a new instance of the CycleT class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Samples |
Top
See Also

Reference

GSF.SELEventParser Namespace


Cycle(T) Constructor

Grid Solutions Framework CycleT Constructor
Initializes a new instance of the CycleT class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Cycle()
Public Sub New
new : unit -> Cycle
GSF.SELEventParser.Cycle = function();
public:
Cycle()
See Also

Reference

CycleT Class
GSF.SELEventParser Namespace


Cycle(T) Methods

Grid Solutions Framework CycleT Methods

The CycleT generic type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CycleT Class
GSF.SELEventParser Namespace


Cycle(T) Properties

Grid Solutions Framework CycleT Properties

The CycleT generic type exposes the following members.

Properties
 | Name | Description
Public property | Samples |
Top
See Also

Reference

CycleT Class
GSF.SELEventParser Namespace


Cycle(T).Samples Property

Grid Solutions Framework CycleTSamples Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Cycle`1.Samples"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<T> Samples { get; set; }
Public Property Samples As List(Of T)
    Get
    Set
member Samples : List<'T> with get, set

function get_Samples();
function set_Samples(value);
public:
property List<T>^ Samples {
    List<T>^ get ();
    void set (List<T>^ value);
}

Property Value

Type: List T
See Also

Reference

CycleT Class
GSF.SELEventParser Namespace


EventFile Class

Grid Solutions Framework EventFile Class

[Missing <summary> documentation for "T:GSF.SELEventParser.EventFile"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserEventFile

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EventFile
Public Class EventFile
type EventFile =  class end
GSF.SELEventParser.EventFile = function();

Type.createClass(
    'GSF.SELEventParser.EventFile');
public ref class EventFile

The EventFile type exposes the following members.

Constructors
 | Name | Description
Public method | EventFile | Initializes a new instance of the EventFile class
Top
Methods
 | Name | Description
Public method | Add(EventHistory) |
Public method | Add(EventReport) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | Remove(EventHistory) |
Public method | Remove(EventReport) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | EventHistories |
Public property | EventReports |
Top
See Also

Reference

GSF.SELEventParser Namespace


EventFile Constructor

Grid Solutions Framework EventFile Constructor
Initializes a new instance of the EventFile class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventFile()
Public Sub New
new : unit -> EventFile
GSF.SELEventParser.EventFile = function();
public:
EventFile()
See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventFile Methods

Grid Solutions Framework EventFile Methods

The EventFile type exposes the following members.

Methods
 | Name | Description
Public method | Add(EventHistory) |
Public method | Add(EventReport) |
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse |
Public method | Remove(EventHistory) |
Public method | Remove(EventReport) |
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventFile.Add Method

Grid Solutions Framework EventFileAdd Method
Overload List
 | Name | Description
Public method | Add(EventHistory) |
Public method | Add(EventReport) |
Top
See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventFile.Add Method (EventHistory)

Grid Solutions Framework EventFileAdd Method (EventHistory)

[Missing <summary> documentation for "M:GSF.SELEventParser.EventFile.Add(GSF.SELEventParser.EventHistory)"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    EventHistory eventHistory
)
Public Sub Add (
    eventHistory As EventHistory
)
member Add :
        eventHistory : EventHistory -> unit

function Add(eventHistory);
public:
void Add(
    EventHistory^ eventHistory
)

Parameters

eventHistory
Type: GSF.SELEventParserEventHistory

[Missing <param name="eventHistory"/> documentation for "M:GSF.SELEventParser.EventFile.Add(GSF.SELEventParser.EventHistory)"]

See Also

Reference

EventFile Class
Add Overload
GSF.SELEventParser Namespace


EventFile.Add Method (EventReport)

Grid Solutions Framework EventFileAdd Method (EventReport)

[Missing <summary> documentation for "M:GSF.SELEventParser.EventFile.Add(GSF.SELEventParser.EventReport)"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Add(
    EventReport eventReport
)
Public Sub Add (
    eventReport As EventReport
)
member Add :
        eventReport : EventReport -> unit

function Add(eventReport);
public:
void Add(
    EventReport^ eventReport
)

Parameters

eventReport
Type: GSF.SELEventParserEventReport

[Missing <param name="eventReport"/> documentation for "M:GSF.SELEventParser.EventFile.Add(GSF.SELEventParser.EventReport)"]

See Also

Reference

EventFile Class
Add Overload
GSF.SELEventParser Namespace


EventFile.Parse Method

Grid Solutions Framework EventFileParse Method

[Missing <summary> documentation for "M:GSF.SELEventParser.EventFile.Parse(System.String)"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static EventFile Parse(
    string filename
)
Public Shared Function Parse (
    filename As String
) As EventFile
static member Parse :
        filename : string -> EventFile

GSF.SELEventParser.EventFile.Parse = function(filename);
public:
static EventFile^ Parse(
    String^ filename
)

Parameters

filename
Type: SystemString

[Missing <param name="filename"/> documentation for "M:GSF.SELEventParser.EventFile.Parse(System.String)"]

Return Value

Type: EventFile

[Missing <returns> documentation for "M:GSF.SELEventParser.EventFile.Parse(System.String)"]

See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventFile.Remove Method

Grid Solutions Framework EventFileRemove Method
Overload List
 | Name | Description
Public method | Remove(EventHistory) |
Public method | Remove(EventReport) |
Top
See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventFile.Remove Method (EventHistory)

Grid Solutions Framework EventFileRemove Method (EventHistory)

[Missing <summary> documentation for "M:GSF.SELEventParser.EventFile.Remove(GSF.SELEventParser.EventHistory)"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    EventHistory eventHistory
)
Public Function Remove (
    eventHistory As EventHistory
) As Boolean
member Remove :
        eventHistory : EventHistory -> bool

function Remove(eventHistory);
public:
bool Remove(
    EventHistory^ eventHistory
)

Parameters

eventHistory
Type: GSF.SELEventParserEventHistory

[Missing <param name="eventHistory"/> documentation for "M:GSF.SELEventParser.EventFile.Remove(GSF.SELEventParser.EventHistory)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.SELEventParser.EventFile.Remove(GSF.SELEventParser.EventHistory)"]

See Also

Reference

EventFile Class
Remove Overload
GSF.SELEventParser Namespace


EventFile.Remove Method (EventReport)

Grid Solutions Framework EventFileRemove Method (EventReport)

[Missing <summary> documentation for "M:GSF.SELEventParser.EventFile.Remove(GSF.SELEventParser.EventReport)"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Remove(
    EventReport eventReport
)
Public Function Remove (
    eventReport As EventReport
) As Boolean
member Remove :
        eventReport : EventReport -> bool

function Remove(eventReport);
public:
bool Remove(
    EventReport^ eventReport
)

Parameters

eventReport
Type: GSF.SELEventParserEventReport

[Missing <param name="eventReport"/> documentation for "M:GSF.SELEventParser.EventFile.Remove(GSF.SELEventParser.EventReport)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.SELEventParser.EventFile.Remove(GSF.SELEventParser.EventReport)"]

See Also

Reference

EventFile Class
Remove Overload
GSF.SELEventParser Namespace


EventFile Properties

Grid Solutions Framework EventFile Properties

The EventFile type exposes the following members.

Properties
 | Name | Description
Public property | EventHistories |
Public property | EventReports |
Top
See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventFile.EventHistories Property

Grid Solutions Framework EventFileEventHistories Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventFile.EventHistories"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<EventHistory> EventHistories { get; }
Public ReadOnly Property EventHistories As List(Of EventHistory)
    Get
member EventHistories : List<EventHistory> with get

function get_EventHistories();

public:
property List<EventHistory^>^ EventHistories {
    List<EventHistory^>^ get ();
}

Property Value

Type: List EventHistory
See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventFile.EventReports Property

Grid Solutions Framework EventFileEventReports Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventFile.EventReports"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<EventReport> EventReports { get; }
Public ReadOnly Property EventReports As List(Of EventReport)
    Get
member EventReports : List<EventReport> with get

function get_EventReports();

public:
property List<EventReport^>^ EventReports {
    List<EventReport^>^ get ();
}

Property Value

Type: List EventReport
See Also

Reference

EventFile Class
GSF.SELEventParser Namespace


EventHistory Class

Grid Solutions Framework EventHistory Class

[Missing <summary> documentation for "T:GSF.SELEventParser.EventHistory"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserEventHistory

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EventHistory
Public Class EventHistory
type EventHistory =  class end
GSF.SELEventParser.EventHistory = function();

Type.createClass(
    'GSF.SELEventParser.EventHistory');
public ref class EventHistory

The EventHistory type exposes the following members.

Constructors
 | Name | Description
Public method | EventHistory | Initializes a new instance of the EventHistory class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Command |
Public property | Header |
Public property | Histories |
Top
See Also

Reference

GSF.SELEventParser Namespace


EventHistory Constructor

Grid Solutions Framework EventHistory Constructor
Initializes a new instance of the EventHistory class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventHistory()
Public Sub New
new : unit -> EventHistory
GSF.SELEventParser.EventHistory = function();
public:
EventHistory()
See Also

Reference

EventHistory Class
GSF.SELEventParser Namespace


EventHistory Methods

Grid Solutions Framework EventHistory Methods

The EventHistory type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventHistory Class
GSF.SELEventParser Namespace


EventHistory Properties

Grid Solutions Framework EventHistory Properties

The EventHistory type exposes the following members.

Properties
 | Name | Description
Public property | Command |
Public property | Header |
Public property | Histories |
Top
See Also

Reference

EventHistory Class
GSF.SELEventParser Namespace


EventHistory.Command Property

Grid Solutions Framework EventHistoryCommand Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistory.Command"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Command { get; set; }
Public Property Command As String
    Get
    Set
member Command : string with get, set

function get_Command();
function set_Command(value);
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EventHistory Class
GSF.SELEventParser Namespace


EventHistory.Header Property

Grid Solutions Framework EventHistoryHeader Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistory.Header"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Header Header { get; set; }
Public Property Header As Header
    Get
    Set
member Header : Header with get, set

function get_Header();
function set_Header(value);
public:
property Header^ Header {
    Header^ get ();
    void set (Header^ value);
}

Property Value

Type: Header
See Also

Reference

EventHistory Class
GSF.SELEventParser Namespace


EventHistory.Histories Property

Grid Solutions Framework EventHistoryHistories Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistory.Histories"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<EventHistoryRecord> Histories { get; set; }
Public Property Histories As List(Of EventHistoryRecord)
    Get
    Set
member Histories : List<EventHistoryRecord> with get, set

function get_Histories();
function set_Histories(value);
public:
property List<EventHistoryRecord^>^ Histories {
    List<EventHistoryRecord^>^ get ();
    void set (List<EventHistoryRecord^>^ value);
}

Property Value

Type: List EventHistoryRecord
See Also

Reference

EventHistory Class
GSF.SELEventParser Namespace


EventHistoryRecord Class

Grid Solutions Framework EventHistoryRecord Class

[Missing <summary> documentation for "T:GSF.SELEventParser.EventHistoryRecord"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserEventHistoryRecord

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EventHistoryRecord
Public Class EventHistoryRecord
type EventHistoryRecord =  class end
GSF.SELEventParser.EventHistoryRecord = function();

Type.createClass(
    'GSF.SELEventParser.EventHistoryRecord');
public ref class EventHistoryRecord

The EventHistoryRecord type exposes the following members.

Constructors
 | Name | Description
Public method | EventHistoryRecord | Initializes a new instance of the EventHistoryRecord class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Current |
Public property | EventNumber |
Public property | EventType |
Public property | FaultLocation |
Public property | Frequency |
Public property | Group |
Public property | Shot |
Public property | Targets |
Public property | Time |
Top
See Also

Reference

GSF.SELEventParser Namespace


EventHistoryRecord Constructor

Grid Solutions Framework EventHistoryRecord Constructor
Initializes a new instance of the EventHistoryRecord class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventHistoryRecord()
Public Sub New
new : unit -> EventHistoryRecord
GSF.SELEventParser.EventHistoryRecord = function();
public:
EventHistoryRecord()
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord Methods

Grid Solutions Framework EventHistoryRecord Methods

The EventHistoryRecord type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord Properties

Grid Solutions Framework EventHistoryRecord Properties

The EventHistoryRecord type exposes the following members.

Properties
 | Name | Description
Public property | Current |
Public property | EventNumber |
Public property | EventType |
Public property | FaultLocation |
Public property | Frequency |
Public property | Group |
Public property | Shot |
Public property | Targets |
Public property | Time |
Top
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.Current Property

Grid Solutions Framework EventHistoryRecordCurrent Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.Current"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Current { get; set; }
Public Property Current As Double
    Get
    Set
member Current : float with get, set

function get_Current();
function set_Current(value);
public:
property double Current {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.EventNumber Property

Grid Solutions Framework EventHistoryRecordEventNumber Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.EventNumber"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int EventNumber { get; set; }
Public Property EventNumber As Integer
    Get
    Set
member EventNumber : int with get, set

function get_EventNumber();
function set_EventNumber(value);
public:
property int EventNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.EventType Property

Grid Solutions Framework EventHistoryRecordEventType Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.EventType"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string EventType { get; set; }
Public Property EventType As String
    Get
    Set
member EventType : string with get, set

function get_EventType();
function set_EventType(value);
public:
property String^ EventType {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.FaultLocation Property

Grid Solutions Framework EventHistoryRecordFaultLocation Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.FaultLocation"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double FaultLocation { get; set; }
Public Property FaultLocation As Double
    Get
    Set
member FaultLocation : float with get, set

function get_FaultLocation();
function set_FaultLocation(value);
public:
property double FaultLocation {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.Frequency Property

Grid Solutions Framework EventHistoryRecordFrequency Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.Frequency"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Frequency { get; set; }
Public Property Frequency As Double
    Get
    Set
member Frequency : float with get, set

function get_Frequency();
function set_Frequency(value);
public:
property double Frequency {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.Group Property

Grid Solutions Framework EventHistoryRecordGroup Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.Group"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Group { get; set; }
Public Property Group As Integer
    Get
    Set
member Group : int with get, set

function get_Group();
function set_Group(value);
public:
property int Group {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.Shot Property

Grid Solutions Framework EventHistoryRecordShot Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.Shot"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Shot { get; set; }
Public Property Shot As Integer
    Get
    Set
member Shot : int with get, set

function get_Shot();
function set_Shot(value);
public:
property int Shot {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.Targets Property

Grid Solutions Framework EventHistoryRecordTargets Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.Targets"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Targets { get; set; }
Public Property Targets As String
    Get
    Set
member Targets : string with get, set

function get_Targets();
function set_Targets(value);
public:
property String^ Targets {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventHistoryRecord.Time Property

Grid Solutions Framework EventHistoryRecordTime Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventHistoryRecord.Time"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Time { get; set; }
Public Property Time As DateTime
    Get
    Set
member Time : DateTime with get, set

function get_Time();
function set_Time(value);
public:
property DateTime Time {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

EventHistoryRecord Class
GSF.SELEventParser Namespace


EventReport Class

Grid Solutions Framework EventReport Class

[Missing <summary> documentation for "T:GSF.SELEventParser.EventReport"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserEventReport

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EventReport
Public Class EventReport
type EventReport =  class end
GSF.SELEventParser.EventReport = function();

Type.createClass(
    'GSF.SELEventParser.EventReport');
public ref class EventReport

The EventReport type exposes the following members.

Constructors
 | Name | Description
Public method | EventReport | Initializes a new instance of the EventReport class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AnalogSection |
Public property | Command |
Public property | EventNumber |
Public property | Firmware |
Public property | Header |
Top
See Also

Reference

GSF.SELEventParser Namespace


EventReport Constructor

Grid Solutions Framework EventReport Constructor
Initializes a new instance of the EventReport class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EventReport()
Public Sub New
new : unit -> EventReport
GSF.SELEventParser.EventReport = function();
public:
EventReport()
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


EventReport Methods

Grid Solutions Framework EventReport Methods

The EventReport type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


EventReport Properties

Grid Solutions Framework EventReport Properties

The EventReport type exposes the following members.

Properties
 | Name | Description
Public property | AnalogSection |
Public property | Command |
Public property | EventNumber |
Public property | Firmware |
Public property | Header |
Top
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


EventReport.AnalogSection Property

Grid Solutions Framework EventReportAnalogSection Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventReport.AnalogSection"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AnalogSection AnalogSection { get; set; }
Public Property AnalogSection As AnalogSection
    Get
    Set
member AnalogSection : AnalogSection with get, set

function get_AnalogSection();
function set_AnalogSection(value);
public:
property AnalogSection^ AnalogSection {
    AnalogSection^ get ();
    void set (AnalogSection^ value);
}

Property Value

Type: AnalogSection
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


EventReport.Command Property

Grid Solutions Framework EventReportCommand Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventReport.Command"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Command { get; set; }
Public Property Command As String
    Get
    Set
member Command : string with get, set

function get_Command();
function set_Command(value);
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


EventReport.EventNumber Property

Grid Solutions Framework EventReportEventNumber Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventReport.EventNumber"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int EventNumber { get; set; }
Public Property EventNumber As Integer
    Get
    Set
member EventNumber : int with get, set

function get_EventNumber();
function set_EventNumber(value);
public:
property int EventNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


EventReport.Firmware Property

Grid Solutions Framework EventReportFirmware Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventReport.Firmware"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Firmware Firmware { get; set; }
Public Property Firmware As Firmware
    Get
    Set
member Firmware : Firmware with get, set

function get_Firmware();
function set_Firmware(value);
public:
property Firmware^ Firmware {
    Firmware^ get ();
    void set (Firmware^ value);
}

Property Value

Type: Firmware
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


EventReport.Header Property

Grid Solutions Framework EventReportHeader Property

[Missing <summary> documentation for "P:GSF.SELEventParser.EventReport.Header"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Header Header { get; set; }
Public Property Header As Header
    Get
    Set
member Header : Header with get, set

function get_Header();
function set_Header(value);
public:
property Header^ Header {
    Header^ get ();
    void set (Header^ value);
}

Property Value

Type: Header
See Also

Reference

EventReport Class
GSF.SELEventParser Namespace


Firmware Class

Grid Solutions Framework Firmware Class

[Missing <summary> documentation for "T:GSF.SELEventParser.Firmware"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserFirmware

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Firmware
Public Class Firmware
type Firmware =  class end
GSF.SELEventParser.Firmware = function();

Type.createClass(
    'GSF.SELEventParser.Firmware');
public ref class Firmware

The Firmware type exposes the following members.

Constructors
 | Name | Description
Public method | Firmware | Initializes a new instance of the Firmware class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Checksum |
Public property | ID |
Top
See Also

Reference

GSF.SELEventParser Namespace


Firmware Constructor

Grid Solutions Framework Firmware Constructor
Initializes a new instance of the Firmware class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Firmware()
Public Sub New
new : unit -> Firmware
GSF.SELEventParser.Firmware = function();
public:
Firmware()
See Also

Reference

Firmware Class
GSF.SELEventParser Namespace


Firmware Methods

Grid Solutions Framework Firmware Methods

The Firmware type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Firmware Class
GSF.SELEventParser Namespace


Firmware Properties

Grid Solutions Framework Firmware Properties

The Firmware type exposes the following members.

Properties
 | Name | Description
Public property | Checksum |
Public property | ID |
Top
See Also

Reference

Firmware Class
GSF.SELEventParser Namespace


Firmware.Checksum Property

Grid Solutions Framework FirmwareChecksum Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Firmware.Checksum"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Checksum { get; set; }
Public Property Checksum As Integer
    Get
    Set
member Checksum : int with get, set

function get_Checksum();
function set_Checksum(value);
public:
property int Checksum {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Firmware Class
GSF.SELEventParser Namespace


Firmware.ID Property

Grid Solutions Framework FirmwareID Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Firmware.ID"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ID { get; set; }
Public Property ID As String
    Get
    Set
member ID : string with get, set

function get_ID();
function set_ID(value);
public:
property String^ ID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Firmware Class
GSF.SELEventParser Namespace


Header Class

Grid Solutions Framework Header Class

[Missing <summary> documentation for "T:GSF.SELEventParser.Header"]

Inheritance Hierarchy
SystemObject
GSF.SELEventParserHeader

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Header
Public Class Header
type Header =  class end
GSF.SELEventParser.Header = function();

Type.createClass(
    'GSF.SELEventParser.Header');
public ref class Header

The Header type exposes the following members.

Constructors
 | Name | Description
Public method | Header | Initializes a new instance of the Header class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | EventTime |
Public property | RelayID |
Public property | SerialNumber |
Public property | StationID |
Top
See Also

Reference

GSF.SELEventParser Namespace


Header Constructor

Grid Solutions Framework Header Constructor
Initializes a new instance of the Header class

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Header()
Public Sub New
new : unit -> Header
GSF.SELEventParser.Header = function();
public:
Header()
See Also

Reference

Header Class
GSF.SELEventParser Namespace


Header Methods

Grid Solutions Framework Header Methods

The Header type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Header Class
GSF.SELEventParser Namespace


Header Properties

Grid Solutions Framework Header Properties

The Header type exposes the following members.

Properties
 | Name | Description
Public property | EventTime |
Public property | RelayID |
Public property | SerialNumber |
Public property | StationID |
Top
See Also

Reference

Header Class
GSF.SELEventParser Namespace


Header.EventTime Property

Grid Solutions Framework HeaderEventTime Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Header.EventTime"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime EventTime { get; set; }
Public Property EventTime As DateTime
    Get
    Set
member EventTime : DateTime with get, set

function get_EventTime();
function set_EventTime(value);
public:
property DateTime EventTime {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

Header Class
GSF.SELEventParser Namespace


Header.RelayID Property

Grid Solutions Framework HeaderRelayID Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Header.RelayID"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string RelayID { get; set; }
Public Property RelayID As String
    Get
    Set
member RelayID : string with get, set

function get_RelayID();
function set_RelayID(value);
public:
property String^ RelayID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Header Class
GSF.SELEventParser Namespace


Header.SerialNumber Property

Grid Solutions Framework HeaderSerialNumber Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Header.SerialNumber"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SerialNumber { get; set; }
Public Property SerialNumber As Integer
    Get
    Set
member SerialNumber : int with get, set

function get_SerialNumber();
function set_SerialNumber(value);
public:
property int SerialNumber {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Header Class
GSF.SELEventParser Namespace


Header.StationID Property

Grid Solutions Framework HeaderStationID Property

[Missing <summary> documentation for "P:GSF.SELEventParser.Header.StationID"]

Namespace: GSF.SELEventParser
Assembly: GSF.SELEventParser (in GSF.SELEventParser.dll) Version: 2.1.122.0 (2.1.122.0)
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string StationID { get; set; }
Public Property StationID As String
    Get
    Set
member StationID : string with get, set

function get_StationID();
function set_StationID(value);
public:
property String^ StationID {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Header Class
GSF.SELEventParser Namespace


GSF.ServiceBus Namespace

Grid Solutions Framework GSF.ServiceBus Namespace
Contains WCF web services that facilitate secure inter-process messaging.
Classes
 | Class | Description
Public class | ClientInfo | Represents information about a client connected to the ServiceBusService to produce/consume Messages.
Public class | Message | Represents a message that can be used to exchange information between processes using ServiceBusService.
Public class | RegistrationInfo | Represents information about a registration with the ServiceBusService to produce/consume Messages.
Public class | RegistrationRequest | Represents a request to register with the ServiceBusService to produce or consume Messages.
 | ServiceBusSecurityPolicy | Represents an authorization policy that can be used for enabling role-based security on ServiceBusService.
 | ServiceBusService | A service bus for event-based messaging between disjoint systems.
Interfaces
 | Interface | Description
Public interface | IServiceBusService | Defines a service bus for event-based messaging between disjoint systems.
Public interface | IServiceBusServiceCallback | Defines a callback contract that must be implemented by clients of ServiceBusService for receiving Messages.
Enumerations
 | Enumeration | Description
Public enumeration | MessageProcessingMode | Indicates how the distribution of Messages is processed by the ServiceBusService.
Public enumeration | MessageType | Indicates how a Message is distributed by the ServiceBusService.
Public enumeration | RegistrationType | Indicates the intent of the RegistrationRequest.


ClientInfo Class

Grid Solutions Framework ClientInfo Class
Represents information about a client connected to the ServiceBusService to produce/consume Messages.
Inheritance Hierarchy
SystemObject
GSF.ServiceBusClientInfo

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataContractAttribute]
public class ClientInfo
<DataContractAttribute>
Public Class ClientInfo
[<DataContractAttribute>]
type ClientInfo =  class end
GSF.ServiceBus.ClientInfo = function();

Type.createClass(
    'GSF.ServiceBus.ClientInfo');
[DataContractAttribute]
public ref class ClientInfo

The ClientInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if the specified Object is equal to the current ClientInfo object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash value for the current ClientInfo object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | ConnectedAt | Gets or sets the UTC DateTime when the client connected to the ServiceBusService.
Public field | MessagesConsumed | Gets or sets the total number of Messages consumed by the client.
Public field | MessagesProduced | Gets or sets the total number of Messages produced by the client.
Public field | OperationContext | Gets or sets the OperationContext object of the client.
Public field | SessionId | Gets or sets the session identifier of the client.
Top
See Also

Reference

GSF.ServiceBus Namespace


ClientInfo Fields

Grid Solutions Framework ClientInfo Fields

The ClientInfo type exposes the following members.

Fields
 | Name | Description
Public field | ConnectedAt | Gets or sets the UTC DateTime when the client connected to the ServiceBusService.
Public field | MessagesConsumed | Gets or sets the total number of Messages consumed by the client.
Public field | MessagesProduced | Gets or sets the total number of Messages produced by the client.
Public field | OperationContext | Gets or sets the OperationContext object of the client.
Public field | SessionId | Gets or sets the session identifier of the client.
Top
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo.ConnectedAt Field

Grid Solutions Framework ClientInfoConnectedAt Field
Gets or sets the UTC DateTime when the client connected to the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public DateTime ConnectedAt
<DataMemberAttribute>
Public ConnectedAt As DateTime
[<DataMemberAttribute>]
val mutable ConnectedAt: DateTime
var ConnectedAt
public:
[DataMemberAttribute]
DateTime ConnectedAt

Field Value

Type: DateTime
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo.MessagesConsumed Field

Grid Solutions Framework ClientInfoMessagesConsumed Field
Gets or sets the total number of Messages consumed by the client.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public long MessagesConsumed
<DataMemberAttribute>
Public MessagesConsumed As Long
[<DataMemberAttribute>]
val mutable MessagesConsumed: int64
var MessagesConsumed
public:
[DataMemberAttribute]
long long MessagesConsumed

Field Value

Type: Int64
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo.MessagesProduced Field

Grid Solutions Framework ClientInfoMessagesProduced Field
Gets or sets the total number of Messages produced by the client.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public long MessagesProduced
<DataMemberAttribute>
Public MessagesProduced As Long
[<DataMemberAttribute>]
val mutable MessagesProduced: int64
var MessagesProduced
public:
[DataMemberAttribute]
long long MessagesProduced

Field Value

Type: Int64
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo.OperationContext Field

Grid Solutions Framework ClientInfoOperationContext Field
Gets or sets the OperationContext object of the client.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OperationContext OperationContext
Public OperationContext As OperationContext
val mutable OperationContext: OperationContext
var OperationContext
public:
OperationContext^ OperationContext

Field Value

Type: OperationContext
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo.SessionId Field

Grid Solutions Framework ClientInfoSessionId Field
Gets or sets the session identifier of the client.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public string SessionId
<DataMemberAttribute>
Public SessionId As String
[<DataMemberAttribute>]
val mutable SessionId: string
var SessionId
public:
[DataMemberAttribute]
String^ SessionId

Field Value

Type: String
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo Methods

Grid Solutions Framework ClientInfo Methods

The ClientInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines if the specified Object is equal to the current ClientInfo object. (Overrides ObjectEquals(Object).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Gets a hash value for the current ClientInfo object. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo.Equals Method

Grid Solutions Framework ClientInfoEquals Method
Determines if the specified Object is equal to the current ClientInfo object.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The Object to compare with the current ClientInfo object.

Return Value

Type: Boolean
true if both Objects are equal; otherwise false.
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


ClientInfo.GetHashCode Method

Grid Solutions Framework ClientInfoGetHashCode Method
Gets a hash value for the current ClientInfo object.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
An Int32 value.
See Also

Reference

ClientInfo Class
GSF.ServiceBus Namespace


IServiceBusService Interface

Grid Solutions Framework IServiceBusService Interface
Defines a service bus for event-based messaging between disjoint systems.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceContractAttribute(SessionMode = SessionMode.Allowed, CallbackContract = typeof(IServiceBusServiceCallback))]
public interface IServiceBusService : ISelfHostingService,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
<ServiceContractAttribute(SessionMode := SessionMode.Allowed, CallbackContract := GetType(IServiceBusServiceCallback))>
Public Interface IServiceBusService
    Inherits ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
[<ServiceContractAttribute(SessionMode = SessionMode.Allowed, CallbackContract = typeof(IServiceBusServiceCallback))>]
type IServiceBusService =
    interface
        interface ISelfHostingService
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.ServiceBus.IServiceBusService = function();
GSF.ServiceBus.IServiceBusService.createInterface('GSF.ServiceBus.IServiceBusService');
[ServiceContractAttribute(SessionMode = SessionMode::Allowed, CallbackContract = typeof(IServiceBusServiceCallback))]
public interface class IServiceBusService : ISelfHostingService,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The IServiceBusService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetClients | Gets a list of all clients connected to the ServiceBusService.
Public method | GetLatestMessage | Gets the latest Message distributed to the subscribers of the specified topic.
Public method | GetQueues | Gets a list of all Queues registered on the ServiceBusService.
Public method | GetTopics | Gets a list of all Topics registered on the ServiceBusService.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Publish | Sends the message to the ServiceBusService for distribution amongst its registered consumers.
Public method | Register | Registers with the ServiceBusService to produce or consume Messages.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Public method | Unregister | Unregisters a previous registration with the ServiceBusService to produce or consume Messages
Top
Properties
 | Name | Description
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from ISelfHostingService.)
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from ISelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | ServiceHost | Gets the ServiceHost hosting the web service. (Inherited from ISelfHostingService.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from ISelfHostingService.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from ISelfHostingService.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.ServiceBus Namespace


IServiceBusService Methods

Grid Solutions Framework IServiceBusService Methods

The IServiceBusService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetClients | Gets a list of all clients connected to the ServiceBusService.
Public method | GetLatestMessage | Gets the latest Message distributed to the subscribers of the specified topic.
Public method | GetQueues | Gets a list of all Queues registered on the ServiceBusService.
Public method | GetTopics | Gets a list of all Topics registered on the ServiceBusService.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | Publish | Sends the message to the ServiceBusService for distribution amongst its registered consumers.
Public method | Register | Registers with the ServiceBusService to produce or consume Messages.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Public method | Unregister | Unregisters a previous registration with the ServiceBusService to produce or consume Messages
Top
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService.GetClients Method

Grid Solutions Framework IServiceBusServiceGetClients Method
Gets a list of all clients connected to the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
ICollection<ClientInfo> GetClients()
<OperationContractAttribute>
Function GetClients As ICollection(Of ClientInfo)
[<OperationContractAttribute>]
abstract GetClients : unit -> ICollection<ClientInfo>

function GetClients();
[OperationContractAttribute]
ICollection<ClientInfo^>^ GetClients()

Return Value

Type: ICollection ClientInfo
An ICollectionT of ClientInfo objects.
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService.GetLatestMessage Method

Grid Solutions Framework IServiceBusServiceGetLatestMessage Method
Gets the latest Message distributed to the subscribers of the specified topic.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
Message GetLatestMessage(
    RegistrationRequest topic
)
<OperationContractAttribute>
Function GetLatestMessage (
    topic As RegistrationRequest
) As Message
[<OperationContractAttribute>]
abstract GetLatestMessage :
        topic : RegistrationRequest -> Message

function GetLatestMessage(topic);
[OperationContractAttribute]
Message^ GetLatestMessage(
    RegistrationRequest^ topic
)

Parameters

topic
Type: GSF.ServiceBusRegistrationRequest
The topic RegistrationRequest used when registering.

Return Value

Type: Message
The latest Message distributed to the topic subscribers.
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService.GetQueues Method

Grid Solutions Framework IServiceBusServiceGetQueues Method
Gets a list of all Queues registered on the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
ICollection<RegistrationInfo> GetQueues()
<OperationContractAttribute>
Function GetQueues As ICollection(Of RegistrationInfo)
[<OperationContractAttribute>]
abstract GetQueues : unit -> ICollection<RegistrationInfo>

function GetQueues();
[OperationContractAttribute]
ICollection<RegistrationInfo^>^ GetQueues()

Return Value

Type: ICollection RegistrationInfo
An ICollectionT of RegistrationInfo objects.
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService.GetTopics Method

Grid Solutions Framework IServiceBusServiceGetTopics Method
Gets a list of all Topics registered on the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
ICollection<RegistrationInfo> GetTopics()
<OperationContractAttribute>
Function GetTopics As ICollection(Of RegistrationInfo)
[<OperationContractAttribute>]
abstract GetTopics : unit -> ICollection<RegistrationInfo>

function GetTopics();
[OperationContractAttribute]
ICollection<RegistrationInfo^>^ GetTopics()

Return Value

Type: ICollection RegistrationInfo
An ICollectionT of RegistrationInfo objects.
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService.Publish Method

Grid Solutions Framework IServiceBusServicePublish Method
Sends the message to the ServiceBusService for distribution amongst its registered consumers.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
void Publish(
    Message message
)
<OperationContractAttribute>
Sub Publish (
    message As Message
)
[<OperationContractAttribute>]
abstract Publish :
        message : Message -> unit

function Publish(message);
[OperationContractAttribute]
void Publish(
    Message^ message
)

Parameters

message
Type: GSF.ServiceBusMessage
The Message that is to be distributed.
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService.Register Method

Grid Solutions Framework IServiceBusServiceRegister Method
Registers with the ServiceBusService to produce or consume Messages.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
void Register(
    RegistrationRequest request
)
<OperationContractAttribute>
Sub Register (
    request As RegistrationRequest
)
[<OperationContractAttribute>]
abstract Register :
        request : RegistrationRequest -> unit

function Register(request);
[OperationContractAttribute]
void Register(
    RegistrationRequest^ request
)

Parameters

request
Type: GSF.ServiceBusRegistrationRequest
An RegistrationRequest containing registration data.
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService.Unregister Method

Grid Solutions Framework IServiceBusServiceUnregister Method
Unregisters a previous registration with the ServiceBusService to produce or consume Messages

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute]
void Unregister(
    RegistrationRequest request
)
<OperationContractAttribute>
Sub Unregister (
    request As RegistrationRequest
)
[<OperationContractAttribute>]
abstract Unregister :
        request : RegistrationRequest -> unit

function Unregister(request);
[OperationContractAttribute]
void Unregister(
    RegistrationRequest^ request
)

Parameters

request
Type: GSF.ServiceBusRegistrationRequest
The RegistrationRequest used when registering.
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService Properties

Grid Solutions Framework IServiceBusService Properties

The IServiceBusService type exposes the following members.

Properties
 | Name | Description
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from ISelfHostingService.)
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from ISelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | ServiceHost | Gets the ServiceHost hosting the web service. (Inherited from ISelfHostingService.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from ISelfHostingService.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusService Events

Grid Solutions Framework IServiceBusService Events

The IServiceBusService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from ISelfHostingService.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

IServiceBusService Interface
GSF.ServiceBus Namespace


IServiceBusServiceCallback Interface

Grid Solutions Framework IServiceBusServiceCallback Interface
Defines a callback contract that must be implemented by clients of ServiceBusService for receiving Messages.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IServiceBusServiceCallback
Public Interface IServiceBusServiceCallback
type IServiceBusServiceCallback =  interface end
GSF.ServiceBus.IServiceBusServiceCallback = function();
GSF.ServiceBus.IServiceBusServiceCallback.createInterface('GSF.ServiceBus.IServiceBusServiceCallback');
public interface class IServiceBusServiceCallback

The IServiceBusServiceCallback type exposes the following members.

Methods
 | Name | Description
Public method | ProcessMessage | Invoked when a new Message is received from the ServiceBusService.
Top
See Also

Reference

GSF.ServiceBus Namespace


IServiceBusServiceCallback Methods

Grid Solutions Framework IServiceBusServiceCallback Methods

The IServiceBusServiceCallback type exposes the following members.

Methods
 | Name | Description
Public method | ProcessMessage | Invoked when a new Message is received from the ServiceBusService.
Top
See Also

Reference

IServiceBusServiceCallback Interface
GSF.ServiceBus Namespace


IServiceBusServiceCallback.ProcessMessage Method

Grid Solutions Framework IServiceBusServiceCallbackProcessMessage Method
Invoked when a new Message is received from the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[OperationContractAttribute(IsOneWay = true)]
void ProcessMessage(
    Message message
)
<OperationContractAttribute(IsOneWay := true)>
Sub ProcessMessage (
    message As Message
)
[<OperationContractAttribute(IsOneWay = true)>]
abstract ProcessMessage :
        message : Message -> unit

function ProcessMessage(message);
[OperationContractAttribute(IsOneWay = true)]
void ProcessMessage(
    Message^ message
)

Parameters

message
Type: GSF.ServiceBusMessage
Message received from the ServiceBusService.
See Also

Reference

IServiceBusServiceCallback Interface
GSF.ServiceBus Namespace


Message Class

Grid Solutions Framework Message Class
Represents a message that can be used to exchange information between processes using ServiceBusService.
Inheritance Hierarchy
SystemObject
GSF.ServiceBusMessage

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class Message
<SerializableAttribute>
Public Class Message
[<SerializableAttribute>]
type Message =  class end
GSF.ServiceBus.Message = function();

Type.createClass(
    'GSF.ServiceBus.Message');
[SerializableAttribute]
public ref class Message

The Message type exposes the following members.

Constructors
 | Name | Description
Public method | Message | Initializes a new instance of the Message class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Content | Gets or sets the actual payload of this Message.
Public field | Format | Gets or sets the format of the Content in this Message.
Public field | Name | Gets or sets the identifier of this Message.
Public field | Time | Gets or sets the DateTime when this Message was created.
Public field | Type | Gets or sets the Type of this Message.
Top
See Also

Reference

GSF.ServiceBus Namespace


Message Constructor

Grid Solutions Framework Message Constructor
Initializes a new instance of the Message class

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Message()
Public Sub New
new : unit -> Message
GSF.ServiceBus.Message = function();
public:
Message()
See Also

Reference

Message Class
GSF.ServiceBus Namespace


Message Fields

Grid Solutions Framework Message Fields

The Message type exposes the following members.

Fields
 | Name | Description
Public field | Content | Gets or sets the actual payload of this Message.
Public field | Format | Gets or sets the format of the Content in this Message.
Public field | Name | Gets or sets the identifier of this Message.
Public field | Time | Gets or sets the DateTime when this Message was created.
Public field | Type | Gets or sets the Type of this Message.
Top
See Also

Reference

Message Class
GSF.ServiceBus Namespace


Message.Content Field

Grid Solutions Framework MessageContent Field
Gets or sets the actual payload of this Message.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Content
Public Content As Byte()
val mutable Content: byte[]
var Content
public:
array<unsigned char>^ Content

Field Value

Type: Byte
See Also

Reference

Message Class
GSF.ServiceBus Namespace


Message.Format Field

Grid Solutions Framework MessageFormat Field
Gets or sets the format of the Content in this Message.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Format
Public Format As String
val mutable Format: string
var Format
public:
String^ Format

Field Value

Type: String
See Also

Reference

Message Class
GSF.ServiceBus Namespace


Message.Name Field

Grid Solutions Framework MessageName Field
Gets or sets the identifier of this Message.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name
Public Name As String
val mutable Name: string
var Name
public:
String^ Name

Field Value

Type: String
See Also

Reference

Message Class
GSF.ServiceBus Namespace


Message.Time Field

Grid Solutions Framework MessageTime Field
Gets or sets the DateTime when this Message was created.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime Time
Public Time As DateTime
val mutable Time: DateTime
var Time
public:
DateTime Time

Field Value

Type: DateTime
See Also

Reference

Message Class
GSF.ServiceBus Namespace


Message.Type Field

Grid Solutions Framework MessageType Field
Gets or sets the Type of this Message.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MessageType Type
Public Type As MessageType
val mutable Type: MessageType
var Type
public:
MessageType Type

Field Value

Type: MessageType
See Also

Reference

Message Class
GSF.ServiceBus Namespace


Message Methods

Grid Solutions Framework Message Methods

The Message type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Message Class
GSF.ServiceBus Namespace


MessageProcessingMode Enumeration

Grid Solutions Framework MessageProcessingMode Enumeration
Indicates how the distribution of Messages is processed by the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum MessageProcessingMode
Public Enumeration MessageProcessingMode
type MessageProcessingMode
GSF.ServiceBus.MessageProcessingMode = function();
GSF.ServiceBus.MessageProcessingMode.createEnum('GSF.ServiceBus.MessageProcessingMode', false);
public enum class MessageProcessingMode
Members
Member name | Value | Description
Parallel | 0 | Message distribution is processed in parallel for increased distribution performance.
Sequential | 1 | Message distribution is processed sequentially to preserve Message ordering.
See Also

Reference

GSF.ServiceBus Namespace


MessageType Enumeration

Grid Solutions Framework MessageType Enumeration
Indicates how a Message is distributed by the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum MessageType
Public Enumeration MessageType
type MessageType
GSF.ServiceBus.MessageType = function();
GSF.ServiceBus.MessageType.createEnum('GSF.ServiceBus.MessageType', false);
public enum class MessageType
Members
Member name | Value | Description
Topic | 0 | Message is distributed to all of its registered consumers.
Queue | 1 | Message is distributed to the first of all its registered consumers.
See Also

Reference

GSF.ServiceBus Namespace


RegistrationInfo Class

Grid Solutions Framework RegistrationInfo Class
Represents information about a registration with the ServiceBusService to produce/consume Messages.
Inheritance Hierarchy
SystemObject
GSF.ServiceBusRegistrationInfo

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataContractAttribute]
public class RegistrationInfo : IDisposable
<DataContractAttribute>
Public Class RegistrationInfo
    Implements IDisposable
[<DataContractAttribute>]
type RegistrationInfo =
    class
        interface IDisposable
    end
GSF.ServiceBus.RegistrationInfo = function();

Type.createClass(
    'GSF.ServiceBus.RegistrationInfo',
    null,
    IDisposable);
[DataContractAttribute]
public ref class RegistrationInfo : IDisposable

The RegistrationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the RegistrationInfo object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RegistrationInfo object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the RegistrationInfo object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Consumers | Gets or sets the list of clients consuming the Messages.
Public field | ConsumersLock | Gets the ReaderWriterLockSlim to be used for synchronized access to Consumers.
Public field | LatestMessage | Gets or sets the latest Message distributed to the subscribers.
Public field | MessageName | Gets or sets the name for Messages being produced/consumed.
Public field | MessagesProcessed | Gets or sets the total number of Messages distributed.
Public field | MessagesReceived | Gets or sets the total number of Messages received.
Public field | MessageType | Gets or sets the type for Messages being produced/consumed.
Public field | Producers | Gets or sets the list of clients producing the Messages.
Public field | ProducersLock | Gets the ReaderWriterLockSlim to be used for synchronized access to Producers.
Top
See Also

Reference

GSF.ServiceBus Namespace


RegistrationInfo Fields

Grid Solutions Framework RegistrationInfo Fields

The RegistrationInfo type exposes the following members.

Fields
 | Name | Description
Public field | Consumers | Gets or sets the list of clients consuming the Messages.
Public field | ConsumersLock | Gets the ReaderWriterLockSlim to be used for synchronized access to Consumers.
Public field | LatestMessage | Gets or sets the latest Message distributed to the subscribers.
Public field | MessageName | Gets or sets the name for Messages being produced/consumed.
Public field | MessagesProcessed | Gets or sets the total number of Messages distributed.
Public field | MessagesReceived | Gets or sets the total number of Messages received.
Public field | MessageType | Gets or sets the type for Messages being produced/consumed.
Public field | Producers | Gets or sets the list of clients producing the Messages.
Public field | ProducersLock | Gets the ReaderWriterLockSlim to be used for synchronized access to Producers.
Top
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.Consumers Field

Grid Solutions Framework RegistrationInfoConsumers Field
Gets or sets the list of clients consuming the Messages.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public List<ClientInfo> Consumers
<DataMemberAttribute>
Public Consumers As List(Of ClientInfo)
[<DataMemberAttribute>]
val mutable Consumers: List<ClientInfo>
var Consumers
public:
[DataMemberAttribute]
List<ClientInfo^>^ Consumers

Field Value

Type: List ClientInfo
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.ConsumersLock Field

Grid Solutions Framework RegistrationInfoConsumersLock Field
Gets the ReaderWriterLockSlim to be used for synchronized access to Consumers.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public readonly ReaderWriterLockSlim ConsumersLock
Public ReadOnly ConsumersLock As ReaderWriterLockSlim
val ConsumersLock: ReaderWriterLockSlim
var ConsumersLock
public:
initonly ReaderWriterLockSlim^ ConsumersLock

Field Value

Type: ReaderWriterLockSlim
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.LatestMessage Field

Grid Solutions Framework RegistrationInfoLatestMessage Field
Gets or sets the latest Message distributed to the subscribers.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Message LatestMessage
Public LatestMessage As Message
val mutable LatestMessage: Message
var LatestMessage
public:
Message^ LatestMessage

Field Value

Type: Message
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.MessageName Field

Grid Solutions Framework RegistrationInfoMessageName Field
Gets or sets the name for Messages being produced/consumed.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public string MessageName
<DataMemberAttribute>
Public MessageName As String
[<DataMemberAttribute>]
val mutable MessageName: string
var MessageName
public:
[DataMemberAttribute]
String^ MessageName

Field Value

Type: String
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.MessagesProcessed Field

Grid Solutions Framework RegistrationInfoMessagesProcessed Field
Gets or sets the total number of Messages distributed.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public long MessagesProcessed
<DataMemberAttribute>
Public MessagesProcessed As Long
[<DataMemberAttribute>]
val mutable MessagesProcessed: int64
var MessagesProcessed
public:
[DataMemberAttribute]
long long MessagesProcessed

Field Value

Type: Int64
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.MessagesReceived Field

Grid Solutions Framework RegistrationInfoMessagesReceived Field
Gets or sets the total number of Messages received.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public long MessagesReceived
<DataMemberAttribute>
Public MessagesReceived As Long
[<DataMemberAttribute>]
val mutable MessagesReceived: int64
var MessagesReceived
public:
[DataMemberAttribute]
long long MessagesReceived

Field Value

Type: Int64
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.MessageType Field

Grid Solutions Framework RegistrationInfoMessageType Field
Gets or sets the type for Messages being produced/consumed.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public MessageType MessageType
<DataMemberAttribute>
Public MessageType As MessageType
[<DataMemberAttribute>]
val mutable MessageType: MessageType
var MessageType
public:
[DataMemberAttribute]
MessageType MessageType

Field Value

Type: MessageType
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.Producers Field

Grid Solutions Framework RegistrationInfoProducers Field
Gets or sets the list of clients producing the Messages.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DataMemberAttribute]
public List<ClientInfo> Producers
<DataMemberAttribute>
Public Producers As List(Of ClientInfo)
[<DataMemberAttribute>]
val mutable Producers: List<ClientInfo>
var Producers
public:
[DataMemberAttribute]
List<ClientInfo^>^ Producers

Field Value

Type: List ClientInfo
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.ProducersLock Field

Grid Solutions Framework RegistrationInfoProducersLock Field
Gets the ReaderWriterLockSlim to be used for synchronized access to Producers.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public readonly ReaderWriterLockSlim ProducersLock
Public ReadOnly ProducersLock As ReaderWriterLockSlim
val ProducersLock: ReaderWriterLockSlim
var ProducersLock
public:
initonly ReaderWriterLockSlim^ ProducersLock

Field Value

Type: ReaderWriterLockSlim
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo Methods

Grid Solutions Framework RegistrationInfo Methods

The RegistrationInfo type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the RegistrationInfo object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RegistrationInfo object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the RegistrationInfo object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.Dispose Method

Grid Solutions Framework RegistrationInfoDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the RegistrationInfo object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RegistrationInfo object and optionally releases the managed resources.
Top
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationInfo.Dispose Method

Grid Solutions Framework RegistrationInfoDispose Method
Releases all the resources used by the RegistrationInfo object.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

RegistrationInfo Class
Dispose Overload
GSF.ServiceBus Namespace


RegistrationInfo.Dispose Method (Boolean)

Grid Solutions Framework RegistrationInfoDispose Method (Boolean)
Releases the unmanaged resources used by the RegistrationInfo object and optionally releases the managed resources.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

RegistrationInfo Class
Dispose Overload
GSF.ServiceBus Namespace


RegistrationInfo.Finalize Method

Grid Solutions Framework RegistrationInfoFinalize Method
Releases the unmanaged resources before the RegistrationInfo object is reclaimed by GC.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

RegistrationInfo Class
GSF.ServiceBus Namespace


RegistrationRequest Class

Grid Solutions Framework RegistrationRequest Class
Represents a request to register with the ServiceBusService to produce or consume Messages.
Inheritance Hierarchy
SystemObject
GSF.ServiceBusRegistrationRequest

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RegistrationRequest
Public Class RegistrationRequest
type RegistrationRequest =  class end
GSF.ServiceBus.RegistrationRequest = function();

Type.createClass(
    'GSF.ServiceBus.RegistrationRequest');
public ref class RegistrationRequest

The RegistrationRequest type exposes the following members.

Constructors
 | Name | Description
Public method | RegistrationRequest | Initializes a new instance of the RegistrationRequest class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | MessageName | Gets or sets the Name of the Message this RegistrationRequest is for.
Public property | MessageType | Gets or sets the Type of the Message this RegistrationRequest is for.
Public property | RegistrationType | Gets or sets the type of this RegistrationRequest.
Top
See Also

Reference

GSF.ServiceBus Namespace


RegistrationRequest Constructor

Grid Solutions Framework RegistrationRequest Constructor
Initializes a new instance of the RegistrationRequest class

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RegistrationRequest()
Public Sub New
new : unit -> RegistrationRequest
GSF.ServiceBus.RegistrationRequest = function();
public:
RegistrationRequest()
See Also

Reference

RegistrationRequest Class
GSF.ServiceBus Namespace


RegistrationRequest Methods

Grid Solutions Framework RegistrationRequest Methods

The RegistrationRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RegistrationRequest Class
GSF.ServiceBus Namespace


RegistrationRequest Properties

Grid Solutions Framework RegistrationRequest Properties

The RegistrationRequest type exposes the following members.

Properties
 | Name | Description
Public property | MessageName | Gets or sets the Name of the Message this RegistrationRequest is for.
Public property | MessageType | Gets or sets the Type of the Message this RegistrationRequest is for.
Public property | RegistrationType | Gets or sets the type of this RegistrationRequest.
Top
See Also

Reference

RegistrationRequest Class
GSF.ServiceBus Namespace


RegistrationRequest.MessageName Property

Grid Solutions Framework RegistrationRequestMessageName Property
Gets or sets the Name of the Message this RegistrationRequest is for.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string MessageName { get; set; }
Public Property MessageName As String
    Get
    Set
member MessageName : string with get, set

function get_MessageName();
function set_MessageName(value);
public:
property String^ MessageName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

RegistrationRequest Class
GSF.ServiceBus Namespace


RegistrationRequest.MessageType Property

Grid Solutions Framework RegistrationRequestMessageType Property
Gets or sets the Type of the Message this RegistrationRequest is for.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MessageType MessageType { get; set; }
Public Property MessageType As MessageType
    Get
    Set
member MessageType : MessageType with get, set

function get_MessageType();
function set_MessageType(value);
public:
property MessageType MessageType {
    MessageType get ();
    void set (MessageType value);
}

Property Value

Type: MessageType
See Also

Reference

RegistrationRequest Class
GSF.ServiceBus Namespace


RegistrationRequest.RegistrationType Property

Grid Solutions Framework RegistrationRequestRegistrationType Property
Gets or sets the type of this RegistrationRequest.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RegistrationType RegistrationType { get; set; }
Public Property RegistrationType As RegistrationType
    Get
    Set
member RegistrationType : RegistrationType with get, set

function get_RegistrationType();
function set_RegistrationType(value);
public:
property RegistrationType RegistrationType {
    RegistrationType get ();
    void set (RegistrationType value);
}

Property Value

Type: RegistrationType
See Also

Reference

RegistrationRequest Class
GSF.ServiceBus Namespace


RegistrationType Enumeration

Grid Solutions Framework RegistrationType Enumeration
Indicates the intent of the RegistrationRequest.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum RegistrationType
Public Enumeration RegistrationType
type RegistrationType
GSF.ServiceBus.RegistrationType = function();
GSF.ServiceBus.RegistrationType.createEnum('GSF.ServiceBus.RegistrationType', false);
public enum class RegistrationType
Members
Member name | Value | Description
Produce | 0 | Register to produce Messages.
Consume | 1 | Register to consume Messages.
See Also

Reference

GSF.ServiceBus Namespace


ServiceBusSecurityPolicy Class

Grid Solutions Framework ServiceBusSecurityPolicy Class
Represents an authorization policy that can be used for enabling role-based security on ServiceBusService.
Inheritance Hierarchy
SystemObject
GSF.ServiceModelSecurityPolicy
GSF.ServiceBusServiceBusSecurityPolicy

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ServiceBusSecurityPolicy : SecurityPolicy
Public Class ServiceBusSecurityPolicy
    Inherits SecurityPolicy
type ServiceBusSecurityPolicy =
    class
        inherit SecurityPolicy
    end
GSF.ServiceBus.ServiceBusSecurityPolicy = function();

Type.createClass(
    'GSF.ServiceBus.ServiceBusSecurityPolicy',
    GSF.ServiceModel.SecurityPolicy);
public ref class ServiceBusSecurityPolicy : public SecurityPolicy

The ServiceBusSecurityPolicy type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceBusSecurityPolicy | Initializes a new instance of the ServiceBusSecurityPolicy class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the evaluationContext and initializes security. (Inherited from SecurityPolicy.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed. (Overrides SecurityPolicyGetResourceName.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Id | Gets the identifier of this SecurityPolicy instance. (Inherited from SecurityPolicy.)
Public property | Issuer | Gets a claim set that represents the issuer of this SecurityPolicy. (Inherited from SecurityPolicy.)
Top
Examples
This example shows the required config file entries when securing ServiceBusService:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ApplicationName" value="" description="Name of the application being secured as defined in the backend security datastore."
        encrypted="false" />
      <add name="ConnectionString" value="" description="Connection string to be used for connection to the backend security datastore."
        encrypted="false" />
      <add name="ProviderType" value="GSF.Security.LdapSecurityProvider, GSF.Security"
        description="The type to be used for enforcing security." encrypted="false" />
      <add name="IncludedResources" value="Topic.Name=*;Queue.Name=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="*/mex;*/Publish;*/GetClients;*/GetQueues;*/GetTopics;*/SecurityService.svc/*"
        description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
    </securityProvider>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.ServiceBus Namespace
GSF.ServiceBusServiceBusService


ServiceBusSecurityPolicy Constructor

Grid Solutions Framework ServiceBusSecurityPolicy Constructor
Initializes a new instance of the ServiceBusSecurityPolicy class

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceBusSecurityPolicy()
Public Sub New
new : unit -> ServiceBusSecurityPolicy
GSF.ServiceBus.ServiceBusSecurityPolicy = function();
public:
ServiceBusSecurityPolicy()
See Also

Reference

ServiceBusSecurityPolicy Class
GSF.ServiceBus Namespace


ServiceBusSecurityPolicy Methods

Grid Solutions Framework ServiceBusSecurityPolicy Methods

The ServiceBusSecurityPolicy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the evaluationContext and initializes security. (Inherited from SecurityPolicy.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed. (Overrides SecurityPolicyGetResourceName.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceBusSecurityPolicy Class
GSF.ServiceBus Namespace


ServiceBusSecurityPolicy.GetResourceName Method

Grid Solutions Framework ServiceBusSecurityPolicyGetResourceName Method
Gets the name of resource being accessed.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override string GetResourceName()
Protected Overrides Function GetResourceName As String
abstract GetResourceName : unit -> string
override GetResourceName : unit -> string
function GetResourceName();
protected:
virtual String^ GetResourceName() override

Return Value

Type: String
Message.Name property value for Publish(Message) operations, otherwise Action property value for all other operations.
See Also

Reference

ServiceBusSecurityPolicy Class
GSF.ServiceBus Namespace


ServiceBusSecurityPolicy Properties

Grid Solutions Framework ServiceBusSecurityPolicy Properties

The ServiceBusSecurityPolicy type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the identifier of this SecurityPolicy instance. (Inherited from SecurityPolicy.)
Public property | Issuer | Gets a claim set that represents the issuer of this SecurityPolicy. (Inherited from SecurityPolicy.)
Top
See Also

Reference

ServiceBusSecurityPolicy Class
GSF.ServiceBus Namespace


ServiceBusService Class

Grid Solutions Framework ServiceBusService Class
A service bus for event-based messaging between disjoint systems.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.ServiceModelSelfHostingService
GSF.ServiceBusServiceBusService

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, UseSynchronizationContext = false)]
public class ServiceBusService : SelfHostingService,
    IServiceBusService, ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
<ServiceBehaviorAttribute(InstanceContextMode := InstanceContextMode.Single, UseSynchronizationContext := false)>
Public Class ServiceBusService
    Inherits SelfHostingService
    Implements IServiceBusService, ISelfHostingService, IAdapter, ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings
[<ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode.Single, UseSynchronizationContext = false)>]
type ServiceBusService =
    class
        inherit SelfHostingService
        interface IServiceBusService
        interface ISelfHostingService
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.ServiceBus.ServiceBusService = function();

Type.createClass(
    'GSF.ServiceBus.ServiceBusService',
    GSF.ServiceModel.SelfHostingService,
    GSF.ServiceBus.IServiceBusService,
    GSF.ServiceModel.ISelfHostingService,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ServiceBehaviorAttribute(InstanceContextMode = InstanceContextMode::Single, UseSynchronizationContext = false)]
public ref class ServiceBusService : public SelfHostingService,
    IServiceBusService, ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings

The ServiceBusService type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceBusService | Initializes a new instance of the ServiceBusService class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceBusService object and optionally releases the managed resources. (Overrides SelfHostingServiceDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetClients | Gets a list of all clients connected to the ServiceBusService.
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLatestMessage | Gets the latest Message distributed to the subscribers of the specified topic.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetQueues | Gets a list of all Queues registered on the ServiceBusService.
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetTopics | Gets a list of all Topics registered on the ServiceBusService.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the ServiceBusService. (Overrides SelfHostingServiceInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved ServiceBusService settings from the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Overrides SelfHostingServiceOnServiceHostCreated.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Publish | Sends the message to the ServiceBusService for distribution amongst its registered consumers.
Public method | Register | Registers with the ServiceBusService to produce or consume Messages.
Public method | SaveSettings | Saves ServiceBusService settings to the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unregister | Unregisters a previous registration with the ServiceBusService to produce or consume Messages
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultBufferThreshold | Specifies the default value for the BufferThreshold property.
DefaultProcessingMode | Specifies the default value for the ProcessingMode property.
Top
Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | BufferThreshold | Gets or sets the maximum number of Messages that can be buffered for distribution by the ServiceBusService before the the oldest buffered Messages are discarded to keep memory consumption in check by avoiding Message flooding.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ServiceBusService is currently enabled. (Overrides SelfHostingServiceEnabled.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessingMode | Gets or sets the MessageProcessingMode used by the ServiceBusService for processing Message distribution.
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the ServiceBusService. (Overrides AdapterStatus.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
Examples
This example shows how to host ServiceBusService inside a console application:
Copy
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.Threading;
using GSF;
using GSF.ServiceBus;

class Program
{
    static void Main(string[] args)
    {
        // Prompt for security option.
        Console.Write("Enable security (Y/N): ");
        bool enableSecurity = Console.ReadLine().ParseBoolean();

        // Initialize service bus.
        ServiceBusService service = new ServiceBusService();
        service.Singleton = true;
        service.PublishMetadata = true;
        service.PersistSettings = false;
        service.Endpoints = "http.duplex://localhost:4501; net.tcp://locahost:4502";
        if (enableSecurity)
            service.SecurityPolicy = typeof(ServiceBusSecurityPolicy).FullName;
        service.Initialize();

        // Show service bus status.
        if (service.ServiceHost.State == CommunicationState.Opened)
        {
            Console.WriteLine("\r\n{0} is running:", service.GetType().Name);
            foreach (ServiceEndpoint endpoint in service.ServiceHost.Description.Endpoints)
            {
                Console.WriteLine("- {0} ({1})", endpoint.Address, endpoint.Binding.GetType().Name);
            }

            new Thread(delegate()
                {
                    while (service.ServiceHost.State == CommunicationState.Opened)
                    {
                        Console.WriteLine();
                        Console.WriteLine();
                        Console.WriteLine("Status of {0}:", service.Name);
                        Console.WriteLine(service.Status);
                        Console.Write("Press Enter key to stop...");

                        Thread.Sleep(5000);
                    }
                }).Start();
        }
        else
        {
            Console.WriteLine("\r\n{0} could not be started", service.GetType().Name);
        }

        // Shutdown.
        Console.ReadLine();
        service.Dispose();
    }
}
This example shows how to host ServiceBusService inside a web application:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <serviceBusService>
      <add name="Endpoints" value="" description="Semicolon delimited list of URIs where the web service can be accessed."
        encrypted="false" />
      <add name="Contract" value="GSF.ServiceBus.IServiceBusService, GSF.ServiceBus"
        description="Assembly qualified name of the contract interface implemented by the web service."
        encrypted="false" />
      <add name="Singleton" value="True" description="True if the web service is singleton; otherwise False."
        encrypted="false" />
      <add name="SecurityPolicy" value="" description="Assembly qualified name of the authorization policy to be used for securing the web service."
        encrypted="false" />
      <add name="PublishMetadata" value="True" description="True if the web service metadata is to be published at all the endpoints; otherwise False."
        encrypted="false" />
      <add name="BufferThreshold" value="-1" description="Maximum number of messages that can be queued for distribution before the oldest ones are discarded."
        encrypted="false" />
      <add name="ProcessingMode" value="Sequential" description="Processing mode (Parallel; Sequential) to be used for the distribution of messages."
        encrypted="false" />
    </serviceBusService>
  </categorizedSettings>
  <system.serviceModel>
    <services>
      <service name="GSF.ServiceBus.ServiceBusService">
        <endpoint address="" contract="GSF.ServiceBus.IServiceBusService" binding="wsDualHttpBinding" />
      </service>
    </services>
    <behaviors>
      <serviceBehaviors>
        <behavior>
          <serviceMetadata httpGetEnabled="true" />
          <serviceDebug includeExceptionDetailInFaults="false" />
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <serviceHostingEnvironment multipleSiteBindingsEnabled="true">
      <serviceActivations>
        <add relativeAddress="ServiceBusService.svc" service="GSF.ServiceBus.ServiceBusService, GSF.ServiceBus" />
      </serviceActivations>
    </serviceHostingEnvironment>
  </system.serviceModel>
</configuration>
This example shows how to publish Messages to ServiceBusService:
Copy
using System;
using System.ServiceModel;
using System.Threading;

class Program : IServiceBusServiceCallback
{
    static void Main(string[] args)
    {
        // NOTE: Service reference to the service bus service must be added to generate the service proxy.

        // Initialize auto-generated service bus service proxy.
        InstanceContext callbackContext = new InstanceContext(new Program());
        ServiceBusServiceClient serviceBusService = new ServiceBusServiceClient(callbackContext, "NetTcpBinding_IServiceBusService");

        // Create registration request for publishing messages.
        RegistrationRequest registration = new RegistrationRequest();
        registration.MessageType = MessageType.Topic;
        registration.MessageName = "Topic.Frequency";
        registration.RegistrationType = RegistrationType.Produce;
        serviceBusService.Register(registration);

        // Start publishing messages to the bus asynchronously.
        new Thread(delegate()
            {
                Message message = new Message();
                message.Type = registration.MessageType;
                message.Name = registration.MessageName;
                message.Format = "application/octet-stream";

                Random random = new Random(59);
                while (serviceBusService.State == CommunicationState.Opened)
                {
                    message.Time = DateTime.UtcNow;
                    message.Content = BitConverter.GetBytes(random.Next(61));
                    serviceBusService.Publish(message);

                    Thread.Sleep(5000);
                }
            }).Start();

        // Shutdown.
        Console.Write("Press Enter key to stop...");
        Console.ReadLine();
        serviceBusService.Close();
    }

    public void ProcessMessage(Message message)
    {
        // This method will not be invoked since we are not consuming messages.
        throw new NotSupportedException();
    }
}
This example shows how to subscribe to ServiceBusService for receiving Messages:
Copy
using System;
using System.ServiceModel;

class Program : IServiceBusServiceCallback
{
    static void Main(string[] args)
    {
        // NOTE: Service reference to the service bus service must be added to generate the service proxy.

        // Initialize auto-generated service bus service proxy.
        InstanceContext callbackContext = new InstanceContext(new Program());
        ServiceBusServiceClient serviceBusService = new ServiceBusServiceClient(callbackContext, "NetTcpBinding_IServiceBusService");

        // Subscribe with service bus service to receive messages.
        RegistrationRequest registration = new RegistrationRequest();
        registration.MessageType = MessageType.Topic;
        registration.MessageName = "Topic.Frequency";
        registration.RegistrationType = RegistrationType.Consume;
        serviceBusService.Register(registration);

        // Shutdown.
        Console.WriteLine("Press Enter key to stop...");
        Console.WriteLine();
        Console.ReadLine();
        serviceBusService.Close();
    }

    public void ProcessMessage(Message message)
    {
        if (message.Format != "application/octet-stream")
            Console.WriteLine("Message format '{0}' is not supported", message.Format);
        else
            Console.WriteLine("Message received: {0} Hz", BitConverter.ToInt32(message.Content, 0));
    }
}
This example shows how to monitor ServiceBusService remotely:
Copy
using System;
using System.ServiceModel;
using System.Threading;
using GSF;

class Program : IServiceBusServiceCallback
{
    static void Main(string[] args)
    {
        // NOTE: Service reference to the service bus service must be added to generate the service proxy.

        // Initialize auto-generated service bus service proxy.
        InstanceContext callbackContext = new InstanceContext(new Program());
        ServiceBusServiceClient serviceBusService = new ServiceBusServiceClient(callbackContext, "NetTcpBinding_IServiceBusService");
        serviceBusService.ChannelFactory.Open();

        // Start querying service bus service status asynchronously.
        new Thread(delegate()
        {
            while (serviceBusService.State == CommunicationState.Opened)
            {
                Console.Clear();
                Console.WriteLine(new string('-', 79));
                Console.WriteLine("|" + "Service Bus Status".CenterText(77) + "|");
                Console.WriteLine(new string('-', 79));
                Console.WriteLine();

                // Show clients.
                Console.Write("Client ID".PadRight(25));
                Console.Write(" ");
                Console.Write("Connected".PadRight(21));
                Console.Write(" ");
                Console.Write("Msg. Produced".PadRight(15));
                Console.Write(" ");
                Console.Write("Msg. Consumed".PadRight(15));
                Console.WriteLine();
                Console.Write(new string('-', 25));
                Console.Write(" ");
                Console.Write(new string('-', 21));
                Console.Write(" ");
                Console.Write(new string('-', 15));
                Console.Write(" ");
                Console.Write(new string('-', 15));
                Console.WriteLine();
                foreach (ClientInfo client in serviceBusService.GetClients())
                {
                    Console.Write(client.SessionId.TruncateRight(25).PadRight(25));
                    Console.Write(" ");
                    Console.Write(client.ConnectedAt.ToString("MM/dd/yy hh:mm:ss tt").PadRight(21));
                    Console.Write(" ");
                    Console.Write(client.MessagesProduced.ToString().PadRight(15));
                    Console.Write(" ");
                    Console.Write(client.MessagesConsumed.ToString().PadRight(15));
                    Console.WriteLine();
                }
                Console.WriteLine();

                // Show queues.
                Console.Write("Queue Name".PadRight(25));
                Console.Write(" ");
                Console.Write("Producers".PadRight(10));
                Console.Write(" ");
                Console.Write("Consumers".PadRight(10));
                Console.Write(" ");
                Console.Write("Msg. Received".PadRight(15));
                Console.Write(" ");
                Console.Write("Msg. Processed".PadRight(15));
                Console.WriteLine();
                Console.Write(new string('-', 25));
                Console.Write(" ");
                Console.Write(new string('-', 10));
                Console.Write(" ");
                Console.Write(new string('-', 10));
                Console.Write(" ");
                Console.Write(new string('-', 15));
                Console.Write(" ");
                Console.Write(new string('-', 15));
                Console.WriteLine();
                foreach (RegistrationInfo queue in serviceBusService.GetQueues())
                {
                    Console.Write(queue.MessageName.PadRight(25));
                    Console.Write(" ");
                    Console.Write(queue.Producers.Length.ToString().PadRight(15));
                    Console.Write(" ");
                    Console.Write(queue.Consumers.Length.ToString().PadRight(15));
                    Console.Write(" ");
                    Console.Write(queue.MessagesReceived.ToString().PadRight(15));
                    Console.Write(" ");
                    Console.Write(queue.MessagesProcessed.ToString().PadRight(15));
                    Console.WriteLine();
                }
                Console.WriteLine();

                // Show topics.
                Console.Write("Topic Name".PadRight(25));
                Console.Write(" ");
                Console.Write("Producers".PadRight(10));
                Console.Write(" ");
                Console.Write("Consumers".PadRight(10));
                Console.Write(" ");
                Console.Write("Msg. Received".PadRight(15));
                Console.Write(" ");
                Console.Write("Msg. Processed".PadRight(15));
                Console.WriteLine();
                Console.Write(new string('-', 25));
                Console.Write(" ");
                Console.Write(new string('-', 10));
                Console.Write(" ");
                Console.Write(new string('-', 10));
                Console.Write(" ");
                Console.Write(new string('-', 15));
                Console.Write(" ");
                Console.Write(new string('-', 15));
                Console.WriteLine();
                foreach (RegistrationInfo topic in serviceBusService.GetTopics())
                {
                    Console.Write(topic.MessageName.PadRight(25));
                    Console.Write(" ");
                    Console.Write(topic.Producers.Length.ToString().PadRight(15));
                    Console.Write(" ");
                    Console.Write(topic.Consumers.Length.ToString().PadRight(15));
                    Console.Write(" ");
                    Console.Write(topic.MessagesReceived.ToString().PadRight(15));
                    Console.Write(" ");
                    Console.Write(topic.MessagesProcessed.ToString().PadRight(15));
                    Console.WriteLine();
                }
                Console.WriteLine();
                Console.Write("Press Enter key to stop...");

                Thread.Sleep(5000);
            }
        }).Start();

        // Shutdown.
        Console.ReadLine();
        serviceBusService.Close();
    }

    public void ProcessMessage(Message message)
    {
        // This method will not be invoked since we are not consuming messages.
        throw new NotSupportedException();
    }
}
See Also

Reference

GSF.ServiceBus Namespace
GSF.ServiceBusMessage
GSF.ServiceBusClientInfo
GSF.ServiceBusRegistrationInfo
GSF.ServiceBusRegistrationRequest
GSF.ServiceBusServiceBusSecurityPolicy


ServiceBusService Constructor

Grid Solutions Framework ServiceBusService Constructor
Initializes a new instance of the ServiceBusService class.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceBusService()
Public Sub New
new : unit -> ServiceBusService
GSF.ServiceBus.ServiceBusService = function();
public:
ServiceBusService()
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService Fields

Grid Solutions Framework ServiceBusService Fields

The ServiceBusService type exposes the following members.

Fields
Name | Description
DefaultBufferThreshold | Specifies the default value for the BufferThreshold property.
DefaultProcessingMode | Specifies the default value for the ProcessingMode property.
Top
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.DefaultBufferThreshold Field

Grid Solutions Framework ServiceBusServiceDefaultBufferThreshold Field
Specifies the default value for the BufferThreshold property.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultBufferThreshold
Public Const DefaultBufferThreshold As Integer
static val mutable DefaultBufferThreshold: int
var GSF.ServiceBus.ServiceBusService.DefaultBufferThreshold
public:
literal int DefaultBufferThreshold

Field Value

Type: Int32
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.DefaultProcessingMode Field

Grid Solutions Framework ServiceBusServiceDefaultProcessingMode Field
Specifies the default value for the ProcessingMode property.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const MessageProcessingMode DefaultProcessingMode
Public Const DefaultProcessingMode As MessageProcessingMode
static val mutable DefaultProcessingMode: MessageProcessingMode
var GSF.ServiceBus.ServiceBusService.DefaultProcessingMode
public:
literal MessageProcessingMode DefaultProcessingMode

Field Value

Type: MessageProcessingMode
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService Methods

Grid Solutions Framework ServiceBusService Methods

The ServiceBusService type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceBusService object and optionally releases the managed resources. (Overrides SelfHostingServiceDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetClients | Gets a list of all clients connected to the ServiceBusService.
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLatestMessage | Gets the latest Message distributed to the subscribers of the specified topic.
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetQueues | Gets a list of all Queues registered on the ServiceBusService.
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetTopics | Gets a list of all Topics registered on the ServiceBusService.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | Initialize | Initializes the ServiceBusService. (Overrides SelfHostingServiceInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved ServiceBusService settings from the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Overrides SelfHostingServiceOnServiceHostCreated.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | Publish | Sends the message to the ServiceBusService for distribution amongst its registered consumers.
Public method | Register | Registers with the ServiceBusService to produce or consume Messages.
Public method | SaveSettings | Saves ServiceBusService settings to the config file if the PersistSettings property is set to true. (Overrides SelfHostingServiceSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unregister | Unregisters a previous registration with the ServiceBusService to produce or consume Messages
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Dispose Method

Grid Solutions Framework ServiceBusServiceDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceBusService object and optionally releases the managed resources. (Overrides SelfHostingServiceDispose(Boolean).)
Top
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Dispose Method (Boolean)

Grid Solutions Framework ServiceBusServiceDispose Method (Boolean)
Releases the unmanaged resources used by the ServiceBusService object and optionally releases the managed resources.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ServiceBusService Class
Dispose Overload
GSF.ServiceBus Namespace


ServiceBusService.GetClients Method

Grid Solutions Framework ServiceBusServiceGetClients Method
Gets a list of all clients connected to the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ICollection<ClientInfo> GetClients()
Public Overridable Function GetClients As ICollection(Of ClientInfo)
abstract GetClients : unit -> ICollection<ClientInfo>
override GetClients : unit -> ICollection<ClientInfo>
function GetClients();
public:
virtual ICollection<ClientInfo^>^ GetClients()

Return Value

Type: ICollection ClientInfo
An ICollectionT of ClientInfo objects.

Implements

IServiceBusServiceGetClients
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.GetLatestMessage Method

Grid Solutions Framework ServiceBusServiceGetLatestMessage Method
Gets the latest Message distributed to the subscribers of the specified topic.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Message GetLatestMessage(
    RegistrationRequest topic
)
Public Overridable Function GetLatestMessage (
    topic As RegistrationRequest
) As Message
abstract GetLatestMessage :
        topic : RegistrationRequest -> Message
override GetLatestMessage :
        topic : RegistrationRequest -> Message
function GetLatestMessage(topic);
public:
virtual Message^ GetLatestMessage(
    RegistrationRequest^ topic
)

Parameters

topic
Type: GSF.ServiceBusRegistrationRequest
The topic RegistrationRequest used when registering.

Return Value

Type: Message
The latest Message distributed to the topic subscribers.

Implements

IServiceBusServiceGetLatestMessage(RegistrationRequest)
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.GetQueues Method

Grid Solutions Framework ServiceBusServiceGetQueues Method
Gets a list of all Queues registered on the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ICollection<RegistrationInfo> GetQueues()
Public Overridable Function GetQueues As ICollection(Of RegistrationInfo)
abstract GetQueues : unit -> ICollection<RegistrationInfo>
override GetQueues : unit -> ICollection<RegistrationInfo>
function GetQueues();
public:
virtual ICollection<RegistrationInfo^>^ GetQueues()

Return Value

Type: ICollection RegistrationInfo
An ICollectionT of RegistrationInfo objects.

Implements

IServiceBusServiceGetQueues
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.GetTopics Method

Grid Solutions Framework ServiceBusServiceGetTopics Method
Gets a list of all Topics registered on the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ICollection<RegistrationInfo> GetTopics()
Public Overridable Function GetTopics As ICollection(Of RegistrationInfo)
abstract GetTopics : unit -> ICollection<RegistrationInfo>
override GetTopics : unit -> ICollection<RegistrationInfo>
function GetTopics();
public:
virtual ICollection<RegistrationInfo^>^ GetTopics()

Return Value

Type: ICollection RegistrationInfo
An ICollectionT of RegistrationInfo objects.

Implements

IServiceBusServiceGetTopics
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Initialize Method

Grid Solutions Framework ServiceBusServiceInitialize Method
Initializes the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
ISupportLifecycleInitialize
Exceptions
Exception | Condition
NotSupportedException | The specified ProcessingMode is not supported.
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.LoadSettings Method

Grid Solutions Framework ServiceBusServiceLoadSettings Method
Loads saved ServiceBusService settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.OnServiceHostCreated Method

Grid Solutions Framework ServiceBusServiceOnServiceHostCreated Method
Raises the ServiceHostCreated event.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnServiceHostCreated()
Protected Overrides Sub OnServiceHostCreated
abstract OnServiceHostCreated : unit -> unit
override OnServiceHostCreated : unit -> unit
function OnServiceHostCreated();
protected:
virtual void OnServiceHostCreated() override
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Publish Method

Grid Solutions Framework ServiceBusServicePublish Method
Sends the message to the ServiceBusService for distribution amongst its registered consumers.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Publish(
    Message message
)
Public Overridable Sub Publish (
    message As Message
)
abstract Publish :
        message : Message -> unit
override Publish :
        message : Message -> unit
function Publish(message);
public:
virtual void Publish(
    Message^ message
)

Parameters

message
Type: GSF.ServiceBusMessage
The Message that is to be distributed.

Implements

IServiceBusServicePublish(Message)
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Register Method

Grid Solutions Framework ServiceBusServiceRegister Method
Registers with the ServiceBusService to produce or consume Messages.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Register(
    RegistrationRequest request
)
Public Overridable Sub Register (
    request As RegistrationRequest
)
abstract Register :
        request : RegistrationRequest -> unit
override Register :
        request : RegistrationRequest -> unit
function Register(request);
public:
virtual void Register(
    RegistrationRequest^ request
)

Parameters

request
Type: GSF.ServiceBusRegistrationRequest
An RegistrationRequest containing registration data.

Implements

IServiceBusServiceRegister(RegistrationRequest)
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.SaveSettings Method

Grid Solutions Framework ServiceBusServiceSaveSettings Method
Saves ServiceBusService settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Unregister Method

Grid Solutions Framework ServiceBusServiceUnregister Method
Unregisters a previous registration with the ServiceBusService to produce or consume Messages

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Unregister(
    RegistrationRequest request
)
Public Overridable Sub Unregister (
    request As RegistrationRequest
)
abstract Unregister :
        request : RegistrationRequest -> unit
override Unregister :
        request : RegistrationRequest -> unit
function Unregister(request);
public:
virtual void Unregister(
    RegistrationRequest^ request
)

Parameters

request
Type: GSF.ServiceBusRegistrationRequest
The RegistrationRequest used when registering.

Implements

IServiceBusServiceUnregister(RegistrationRequest)
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService Properties

Grid Solutions Framework ServiceBusService Properties

The ServiceBusService type exposes the following members.

Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | BufferThreshold | Gets or sets the maximum number of Messages that can be buffered for distribution by the ServiceBusService before the the oldest buffered Messages are discarded to keep memory consumption in check by avoiding Message flooding.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ServiceBusService is currently enabled. (Overrides SelfHostingServiceEnabled.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessingMode | Gets or sets the MessageProcessingMode used by the ServiceBusService for processing Message distribution.
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the ServiceBusService. (Overrides AdapterStatus.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.BufferThreshold Property

Grid Solutions Framework ServiceBusServiceBufferThreshold Property
Gets or sets the maximum number of Messages that can be buffered for distribution by the ServiceBusService before the the oldest buffered Messages are discarded to keep memory consumption in check by avoiding Message flooding.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BufferThreshold { get; set; }
Public Property BufferThreshold As Integer
    Get
    Set
member BufferThreshold : int with get, set

function get_BufferThreshold();
function set_BufferThreshold(value);
public:
property int BufferThreshold {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Set BufferThreshold to -1 to disable discarding of Messages.
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Enabled Property

Grid Solutions Framework ServiceBusServiceEnabled Property
Gets or sets a boolean value that indicates whether the ServiceBusService is currently enabled.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Enabled { get; set; }
Public Overrides Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
ISupportLifecycleEnabled
ISupportLifecycleEnabled
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.ProcessingMode Property

Grid Solutions Framework ServiceBusServiceProcessingMode Property
Gets or sets the MessageProcessingMode used by the ServiceBusService for processing Message distribution.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MessageProcessingMode ProcessingMode { get; set; }
Public Property ProcessingMode As MessageProcessingMode
    Get
    Set
member ProcessingMode : MessageProcessingMode with get, set

function get_ProcessingMode();
function set_ProcessingMode(value);
public:
property MessageProcessingMode ProcessingMode {
    MessageProcessingMode get ();
    void set (MessageProcessingMode value);
}

Property Value

Type: MessageProcessingMode
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService.Status Property

Grid Solutions Framework ServiceBusServiceStatus Property
Gets the descriptive status of the ServiceBusService.

Namespace: GSF.ServiceBus
Assembly: GSF.ServiceBus (in GSF.ServiceBus.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


ServiceBusService Events

Grid Solutions Framework ServiceBusService Events

The ServiceBusService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

ServiceBusService Class
GSF.ServiceBus Namespace


GSF.ServiceModel Namespace

Grid Solutions Framework GSF.ServiceModel Namespace
Contains classes and interfaces that provide the basic infrastructure for writting web services.
Classes
 | Class | Description
 | SecurityPolicy | Represents an authorization policy that can be used by WCF services for enabling role-based security.
 | SelfHostingService | A base class for web service that can send and receive data over REST (Representational State Transfer) interface.
Public class | Service | Defines helper methods related to WCF-based web services.
Interfaces
 | Interface | Description
Public interface | IPolicyRetriever | Defines a web service interface to allow policy retrieval for cross-domain access from Silverlight and Flash browser controls.
Public interface | ISelfHostingService | Defines a web service that can send and receive data over REST (Representational State Transfer) interface.


IPolicyRetriever Interface

Grid Solutions Framework IPolicyRetriever Interface
Defines a web service interface to allow policy retrieval for cross-domain access from Silverlight and Flash browser controls.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceContractAttribute]
public interface IPolicyRetriever
<ServiceContractAttribute>
Public Interface IPolicyRetriever
[<ServiceContractAttribute>]
type IPolicyRetriever =  interface end
GSF.ServiceModel.IPolicyRetriever = function();
GSF.ServiceModel.IPolicyRetriever.createInterface('GSF.ServiceModel.IPolicyRetriever');
[ServiceContractAttribute]
public interface class IPolicyRetriever

The IPolicyRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetFlashPolicy | Gets policy stream for Flash applications.
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications.
Top
See Also

Reference

GSF.ServiceModel Namespace


IPolicyRetriever Methods

Grid Solutions Framework IPolicyRetriever Methods

The IPolicyRetriever type exposes the following members.

Methods
 | Name | Description
Public method | GetFlashPolicy | Gets policy stream for Flash applications.
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications.
Top
See Also

Reference

IPolicyRetriever Interface
GSF.ServiceModel Namespace


IPolicyRetriever.GetFlashPolicy Method

Grid Solutions Framework IPolicyRetrieverGetFlashPolicy Method
Gets policy stream for Flash applications.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(UriTemplate = "/crossdomain.xml")]
[OperationContractAttribute]
Stream GetFlashPolicy()
<WebGetAttribute(UriTemplate := "/crossdomain.xml")>
<OperationContractAttribute>
Function GetFlashPolicy As Stream
[<WebGetAttribute(UriTemplate = "/crossdomain.xml")>]
[<OperationContractAttribute>]
abstract GetFlashPolicy : unit -> Stream

function GetFlashPolicy();
[WebGetAttribute(UriTemplate = L"/crossdomain.xml")]
[OperationContractAttribute]
Stream^ GetFlashPolicy()

Return Value

Type: Stream
Stream containing crossdomain.xml.
See Also

Reference

IPolicyRetriever Interface
GSF.ServiceModel Namespace


IPolicyRetriever.GetSilverlightPolicy Method

Grid Solutions Framework IPolicyRetrieverGetSilverlightPolicy Method
Gets policy stream for Silverlight applications.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(UriTemplate = "/clientaccesspolicy.xml")]
[OperationContractAttribute]
Stream GetSilverlightPolicy()
<WebGetAttribute(UriTemplate := "/clientaccesspolicy.xml")>
<OperationContractAttribute>
Function GetSilverlightPolicy As Stream
[<WebGetAttribute(UriTemplate = "/clientaccesspolicy.xml")>]
[<OperationContractAttribute>]
abstract GetSilverlightPolicy : unit -> Stream

function GetSilverlightPolicy();
[WebGetAttribute(UriTemplate = L"/clientaccesspolicy.xml")]
[OperationContractAttribute]
Stream^ GetSilverlightPolicy()

Return Value

Type: Stream
Stream containing clientaccesspolicy.xml.
See Also

Reference

IPolicyRetriever Interface
GSF.ServiceModel Namespace


ISelfHostingService Interface

Grid Solutions Framework ISelfHostingService Interface
Defines a web service that can send and receive data over REST (Representational State Transfer) interface.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceContractAttribute]
public interface ISelfHostingService : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
<ServiceContractAttribute>
Public Interface ISelfHostingService
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
[<ServiceContractAttribute>]
type ISelfHostingService =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.ServiceModel.ISelfHostingService = function();
GSF.ServiceModel.ISelfHostingService.createInterface('GSF.ServiceModel.ISelfHostingService');
[ServiceContractAttribute]
public interface class ISelfHostingService : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The ISelfHostingService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service.
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed.
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints.
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints.
Public property | ServiceHost | Gets the ServiceHost hosting the web service.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints.
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints.
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.ServiceModel Namespace


ISelfHostingService Methods

Grid Solutions Framework ISelfHostingService Methods

The ISelfHostingService type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService Properties

Grid Solutions Framework ISelfHostingService Properties

The ISelfHostingService type exposes the following members.

Properties
 | Name | Description
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service.
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed.
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints.
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints.
Public property | ServiceHost | Gets the ServiceHost hosting the web service.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.ContractInterface Property

Grid Solutions Framework ISelfHostingServiceContractInterface Property
Gets or sets the FullName of the contract interface implemented by the web service.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ContractInterface { get; set; }
Property ContractInterface As String
    Get
    Set
abstract ContractInterface : string with get, set

function get_ContractInterface();
function set_ContractInterface(value);
property String^ ContractInterface {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.Endpoints Property

Grid Solutions Framework ISelfHostingServiceEndpoints Property
Gets or sets a semicolon delimited list of URIs where the web service can be accessed.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Endpoints { get; set; }
Property Endpoints As String
    Get
    Set
abstract Endpoints : string with get, set

function get_Endpoints();
function set_Endpoints(value);
property String^ Endpoints {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.PublishMetadata Property

Grid Solutions Framework ISelfHostingServicePublishMetadata Property
Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool PublishMetadata { get; set; }
Property PublishMetadata As Boolean
    Get
    Set
abstract PublishMetadata : bool with get, set

function get_PublishMetadata();
function set_PublishMetadata(value);
property bool PublishMetadata {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.SecurityPolicy Property

Grid Solutions Framework ISelfHostingServiceSecurityPolicy Property
Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string SecurityPolicy { get; set; }
Property SecurityPolicy As String
    Get
    Set
abstract SecurityPolicy : string with get, set

function get_SecurityPolicy();
function set_SecurityPolicy(value);
property String^ SecurityPolicy {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.ServiceHost Property

Grid Solutions Framework ISelfHostingServiceServiceHost Property
Gets the ServiceHost hosting the web service.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ServiceHost ServiceHost { get; }
ReadOnly Property ServiceHost As ServiceHost
    Get
abstract ServiceHost : ServiceHost with get

function get_ServiceHost();

property ServiceHost^ ServiceHost {
    ServiceHost^ get ();
}

Property Value

Type: ServiceHost
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.Singleton Property

Grid Solutions Framework ISelfHostingServiceSingleton Property
Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Singleton { get; set; }
Property Singleton As Boolean
    Get
    Set
abstract Singleton : bool with get, set

function get_Singleton();
function set_Singleton(value);
property bool Singleton {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService Events

Grid Solutions Framework ISelfHostingService Events

The ISelfHostingService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints.
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints.
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request.
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.ServiceHostCreated Event

Grid Solutions Framework ISelfHostingServiceServiceHostCreated Event
Occurs when the ServiceHost has been created with the specified Endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ServiceHostCreated
Event ServiceHostCreated As EventHandler
abstract ServiceHostCreated : IEvent<EventHandler,
    EventArgs>

function add_ServiceHostCreated(value);
function remove_ServiceHostCreated(value);
 event EventHandler^ ServiceHostCreated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.ServiceHostStarted Event

Grid Solutions Framework ISelfHostingServiceServiceHostStarted Event
Occurs when the ServiceHost can process requests via all of its endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ServiceHostStarted
Event ServiceHostStarted As EventHandler
abstract ServiceHostStarted : IEvent<EventHandler,
    EventArgs>

function add_ServiceHostStarted(value);
function remove_ServiceHostStarted(value);
 event EventHandler^ ServiceHostStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


ISelfHostingService.ServiceProcessException Event

Grid Solutions Framework ISelfHostingServiceServiceProcessException Event
Occurs when an Exception is encountered when processing a request.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ServiceProcessException
Event ServiceProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ServiceProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ServiceProcessException(value);
function remove_ServiceProcessException(value);
 event EventHandler<EventArgs<Exception^>^>^ ServiceProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ISelfHostingService Interface
GSF.ServiceModel Namespace


SecurityPolicy Class

Grid Solutions Framework SecurityPolicy Class
Represents an authorization policy that can be used by WCF services for enabling role-based security.
Inheritance Hierarchy
SystemObject
GSF.ServiceModelSecurityPolicy
GSF.ServiceBusServiceBusSecurityPolicy

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecurityPolicy : IAuthorizationPolicy,
    IAuthorizationComponent
Public Class SecurityPolicy
    Implements IAuthorizationPolicy, IAuthorizationComponent
type SecurityPolicy =
    class
        interface IAuthorizationPolicy
        interface IAuthorizationComponent
    end
GSF.ServiceModel.SecurityPolicy = function();

Type.createClass(
    'GSF.ServiceModel.SecurityPolicy',
    null,
    IAuthorizationPolicy,
    IAuthorizationComponent);
public ref class SecurityPolicy : IAuthorizationPolicy,
    IAuthorizationComponent

The SecurityPolicy type exposes the following members.

Constructors
 | Name | Description
Public method | SecurityPolicy | Initializes a new instance of the SecurityPolicy class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the evaluationContext and initializes security.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Id | Gets the identifier of this SecurityPolicy instance.
Public property | Issuer | Gets a claim set that represents the issuer of this SecurityPolicy.
Top
Examples
Common config file entries:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ApplicationName" value="" description="Name of the application being secured as defined in the backend security datastore."
        encrypted="false" />
      <add name="ConnectionString" value="" description="Connection string to be used for connection to the backend security datastore."
        encrypted="false" />
      <add name="ProviderType" value="GSF.Security.LdapSecurityProvider, GSF.Security"
        description="The type to be used for enforcing security." encrypted="false" />
      <add name="IncludedResources" value="*/*.*=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="*/SecurityService.svc*"
        description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
    </securityProvider>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
</configuration>
Internal WCF service configuration:
Copy
<?xml version="1.0"?>
<configuration>
  <system.serviceModel>
    <services>
      <service name="WcfService1.Service1" behaviorConfiguration="serviceBehavior">
        <endpoint address="" contract="WcfService1.IService1" binding="webHttpBinding"
                  bindingConfiguration="endpointBinding" behaviorConfiguration="endpointBehavior" />
      </service>
    </services>
    <behaviors>
      <endpointBehaviors>
        <behavior name="endpointBehavior">
          <webHttp/>
        </behavior>
      </endpointBehaviors>
      <serviceBehaviors>
        <behavior name="serviceBehavior">
          <serviceAuthorization principalPermissionMode="Custom">
            <authorizationPolicies>
              <add policyType="GSF.ServiceModel.SecurityPolicy, GSF.ServiceModel" />
            </authorizationPolicies>
          </serviceAuthorization>
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <bindings>
      <webHttpBinding>
        <binding name="endpointBinding">
          <security mode="TransportCredentialOnly">
            <transport clientCredentialType="Windows"/>
          </security>
        </binding>
      </webHttpBinding>
    </bindings>
    <serviceHostingEnvironment aspNetCompatibilityEnabled="false" />
  </system.serviceModel>
</configuration>
External WCF service configuration:
Copy
<?xml version="1.0"?>
<configuration>
  <system.web>
    <httpModules>
      <add name="SecurityModule" type="GSF.ServiceModel.SecurityModule, GSF.ServiceModel" />
    </httpModules>
  </system.web>
  <system.serviceModel>
    <services>
      <service name="WcfService1.Service1" behaviorConfiguration="serviceBehavior">
        <endpoint address="" contract="WcfService1.IService1" binding="webHttpBinding"
                  bindingConfiguration="endpointBinding" behaviorConfiguration="endpointBehavior"/>
      </service>
    </services>
    <behaviors>
      <endpointBehaviors>
        <behavior name="endpointBehavior">
          <webHttp/>
        </behavior>
      </endpointBehaviors>
      <serviceBehaviors>
        <behavior name="serviceBehavior">
          <serviceAuthorization principalPermissionMode="Custom">
            <authorizationPolicies>
              <add policyType="GSF.ServiceModel.SecurityPolicy, GSF.ServiceModel" />
            </authorizationPolicies>
          </serviceAuthorization>
        </behavior>
      </serviceBehaviors>
    </behaviors>
    <bindings>
      <webHttpBinding>
        <binding name="endpointBinding">
          <security mode="None" />
        </binding>
      </webHttpBinding>
    </bindings>
    <serviceHostingEnvironment aspNetCompatibilityEnabled="true" />
  </system.serviceModel>
</configuration>
See Also

Reference

GSF.ServiceModel Namespace
GSF.SecurityISecurityProvider


SecurityPolicy Constructor

Grid Solutions Framework SecurityPolicy Constructor
Initializes a new instance of the SecurityPolicy class.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityPolicy()
Public Sub New
new : unit -> SecurityPolicy
GSF.ServiceModel.SecurityPolicy = function();
public:
SecurityPolicy()
See Also

Reference

SecurityPolicy Class
GSF.ServiceModel Namespace


SecurityPolicy Methods

Grid Solutions Framework SecurityPolicy Methods

The SecurityPolicy type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | Evaluate | Evaluates the evaluationContext and initializes security.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecurityPolicy Class
GSF.ServiceModel Namespace


SecurityPolicy.Evaluate Method

Grid Solutions Framework SecurityPolicyEvaluate Method
Evaluates the evaluationContext and initializes security.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Evaluate(
    EvaluationContext evaluationContext,
    ref Object state
)
Public Overridable Function Evaluate (
    evaluationContext As EvaluationContext,
    ByRef state As Object
) As Boolean
abstract Evaluate :
        evaluationContext : EvaluationContext *
        state : Object byref -> bool
override Evaluate :
        evaluationContext : EvaluationContext *
        state : Object byref -> bool
function Evaluate(evaluationContext, state);
public:
virtual bool Evaluate(
    EvaluationContext^ evaluationContext,
    Object^% state
)

Parameters

evaluationContext
Type: System.IdentityModel.PolicyEvaluationContext
An EvaluationContext object.
state
Type: SystemObject
Custom state of the SecurityPolicy.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.ServiceModel.SecurityPolicy.Evaluate(System.IdentityModel.Policy.EvaluationContext,System.Object@)"]

Implements

IAuthorizationPolicyEvaluate(EvaluationContext, Object)
See Also

Reference

SecurityPolicy Class
GSF.ServiceModel Namespace


SecurityPolicy.GetResourceName Method

Grid Solutions Framework SecurityPolicyGetResourceName Method
Gets the name of resource being accessed.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetResourceName()
Protected Overridable Function GetResourceName As String
abstract GetResourceName : unit -> string
override GetResourceName : unit -> string
function GetResourceName();
protected:
virtual String^ GetResourceName()

Return Value

Type: String
IncomingMessageHeaders.To.PathAndQuery property value.
See Also

Reference

SecurityPolicy Class
GSF.ServiceModel Namespace


SecurityPolicy Properties

Grid Solutions Framework SecurityPolicy Properties

The SecurityPolicy type exposes the following members.

Properties
 | Name | Description
Public property | Id | Gets the identifier of this SecurityPolicy instance.
Public property | Issuer | Gets a claim set that represents the issuer of this SecurityPolicy.
Top
See Also

Reference

SecurityPolicy Class
GSF.ServiceModel Namespace


SecurityPolicy.Id Property

Grid Solutions Framework SecurityPolicyId Property
Gets the identifier of this SecurityPolicy instance.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Id { get; }
Public ReadOnly Property Id As String
    Get
abstract Id : string with get
override Id : string with get
function get_Id();

public:
virtual property String^ Id {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IAuthorizationComponentId
See Also

Reference

SecurityPolicy Class
GSF.ServiceModel Namespace


SecurityPolicy.Issuer Property

Grid Solutions Framework SecurityPolicyIssuer Property
Gets a claim set that represents the issuer of this SecurityPolicy.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClaimSet Issuer { get; }
Public ReadOnly Property Issuer As ClaimSet
    Get
abstract Issuer : ClaimSet with get
override Issuer : ClaimSet with get
function get_Issuer();

public:
virtual property ClaimSet^ Issuer {
    ClaimSet^ get () sealed;
}

Property Value

Type: ClaimSet

Implements

IAuthorizationPolicyIssuer
See Also

Reference

SecurityPolicy Class
GSF.ServiceModel Namespace


SelfHostingService Class

Grid Solutions Framework SelfHostingService Class
A base class for web service that can send and receive data over REST (Representational State Transfer) interface.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.ServiceModelSelfHostingService
GSF.Historian.DataServicesDataService
GSF.ServiceBusServiceBusService
GSF.Web.EmbeddedSecurityService

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SelfHostingService : Adapter,
    ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings, IPolicyRetriever
Public Class SelfHostingService
    Inherits Adapter
    Implements ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings, IPolicyRetriever
type SelfHostingService =
    class
        inherit Adapter
        interface ISelfHostingService
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
        interface IPolicyRetriever
    end
GSF.ServiceModel.SelfHostingService = function();

Type.createClass(
    'GSF.ServiceModel.SelfHostingService',
    GSF.Adapters.Adapter,
    GSF.ServiceModel.ISelfHostingService,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings,
    GSF.ServiceModel.IPolicyRetriever);
public ref class SelfHostingService : public Adapter,
    ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings, IPolicyRetriever

The SelfHostingService type exposes the following members.

Constructors
 | Name | Description
Protected method | SelfHostingService | Initializes a new instance of the web service.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Overrides AdapterFinalize.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service.
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number.
Public method | Initialize | Initializes the web service. (Overrides AdapterInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost.
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event.
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event.
Protected method | OnServiceProcessException | Raises the ServiceProcessException event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications.
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Overrides AdapterEnabled.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed.
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints.
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints.
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup.
Public property | ServiceHost | Gets the WebServiceHost hosting the web service.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute.
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints.
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints.
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
Examples
This example shows how to create a WCF service derived from SelfHostingService that is capable of hosting itself:
Copy
using System.ServiceModel;
using System.ServiceModel.Web;
using GSF.ServiceModel;

namespace Services
{
    [ServiceContract()]
    public interface IService : ISelfHostingService
    {
        [OperationContract(), WebGet(UriTemplate = "/hello/{name}")]
        string Hello(string name);
    }

    public class Service : SelfHostingService, IService
    {
        public string Hello(string name)
        {
            return string.Format("Hello {0}!", name);
        }
    }
}
This example shows how to activate a WCF service derived from SelfHostingService that is capable of hosting itself:
Copy
using System;
using System.ServiceModel;
using System.ServiceModel.Description;
using System.ServiceModel.Web;
using Services;
using GSF.ServiceModel;

class Program
{
    static void Main(string[] args)
    {
        // Initialize web service.
        Service service = new Service();
        service.PublishMetadata = true;
        service.Endpoints = "http.soap11://localhost:4500/soap; http.rest://localhost:4500/rest";
        service.Initialize();

        // Show web service status.
        if (service.ServiceHost.State == CommunicationState.Opened)
        {
            Console.WriteLine("\r\n{0} is running:", service.GetType().Name);
            foreach (ServiceEndpoint endpoint in service.ServiceHost.Description.Endpoints)
            {
                Console.WriteLine("- {0} ({1})", endpoint.Address, endpoint.Binding.GetType().Name);
            }
            Console.Write("\r\nPress Enter key to stop...");
        }
        else
        {
            Console.WriteLine("\r\n{0} could not be started", service.GetType().Name);
        }

        // Shutdown.
        Console.ReadLine();
        service.Dispose();
    }
}
This example shows how to host a WCF service derived from SelfHostingService inside ASP.NET:
Copy
<?xml version="1.0"?>
<configuration>
  <system.serviceModel>
    <services>
      <service name="Services.Service">
        <endpoint address="soap" contract="Services.IService" binding="basicHttpBinding"/>
        <endpoint address="rest" contract="Services.IService" binding="webHttpBinding" behaviorConfiguration="restBehavior"/>
      </service>
    </services>
    <behaviors>
      <serviceBehaviors>
        <behavior>
          <serviceMetadata httpGetEnabled="true"/>
        </behavior>
      </serviceBehaviors>
      <endpointBehaviors>
        <behavior name="restBehavior">
          <webHttp helpEnabled="true"/>
        </behavior>
      </endpointBehaviors>
    </behaviors>
    <serviceHostingEnvironment multipleSiteBindingsEnabled="true">
      <serviceActivations>
        <add relativeAddress="Service.svc" service="Services.Service, Services"/>
      </serviceActivations>
    </serviceHostingEnvironment>
  </system.serviceModel>
</configuration>
See Also

Reference

GSF.ServiceModel Namespace


SelfHostingService Constructor

Grid Solutions Framework SelfHostingService Constructor
Initializes a new instance of the web service.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected SelfHostingService()
Protected Sub New
new : unit -> SelfHostingService
GSF.ServiceModel.SelfHostingService = function();
protected:
SelfHostingService()
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService Methods

Grid Solutions Framework SelfHostingService Methods

The SelfHostingService type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Overrides AdapterFinalize.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service.
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number.
Public method | Initialize | Initializes the web service. (Overrides AdapterInitialize.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost.
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event.
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event.
Protected method | OnServiceProcessException | Raises the ServiceProcessException event.
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.Dispose Method

Grid Solutions Framework SelfHostingServiceDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Overrides AdapterDispose(Boolean).)
Top
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.Dispose Method (Boolean)

Grid Solutions Framework SelfHostingServiceDispose Method (Boolean)
Releases the unmanaged resources used by the web service and optionally releases the managed resources.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

SelfHostingService Class
Dispose Overload
GSF.ServiceModel Namespace


SelfHostingService.Finalize Method

Grid Solutions Framework SelfHostingServiceFinalize Method
Releases the unmanaged resources before the web service is reclaimed by GC.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.GetFlashPolicy Method

Grid Solutions Framework SelfHostingServiceGetFlashPolicy Method
Gets policy stream for Flash applications.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Stream GetFlashPolicy()
Public Function GetFlashPolicy As Stream
abstract GetFlashPolicy : unit -> Stream
override GetFlashPolicy : unit -> Stream
function GetFlashPolicy();
public:
virtual Stream^ GetFlashPolicy() sealed

Return Value

Type: Stream
Stream containing crossdomain.xml.

Implements

IPolicyRetrieverGetFlashPolicy
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.GetServiceAddress Method

Grid Solutions Framework SelfHostingServiceGetServiceAddress Method
Gets an address where the ServiceHost will host the service.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetServiceAddress()
Protected Overridable Function GetServiceAddress As String
abstract GetServiceAddress : unit -> string
override GetServiceAddress : unit -> string
function GetServiceAddress();
protected:
virtual String^ GetServiceAddress()

Return Value

Type: String
A String value.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.GetSilverlightPolicy Method

Grid Solutions Framework SelfHostingServiceGetSilverlightPolicy Method
Gets policy stream for Silverlight applications.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Stream GetSilverlightPolicy()
Public Function GetSilverlightPolicy As Stream
abstract GetSilverlightPolicy : unit -> Stream
override GetSilverlightPolicy : unit -> Stream
function GetSilverlightPolicy();
public:
virtual Stream^ GetSilverlightPolicy() sealed

Return Value

Type: Stream
Stream containing clientaccesspolicy.xml.

Implements

IPolicyRetrieverGetSilverlightPolicy
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.GetUnusedPort Method

Grid Solutions Framework SelfHostingServiceGetUnusedPort Method
Get an unused port number.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual int GetUnusedPort()
Protected Overridable Function GetUnusedPort As Integer
abstract GetUnusedPort : unit -> int
override GetUnusedPort : unit -> int
function GetUnusedPort();
protected:
virtual int GetUnusedPort()

Return Value

Type: Int32
An Int32 value.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.Initialize Method

Grid Solutions Framework SelfHostingServiceInitialize Method
Initializes the web service.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.InitializeServiceHost Method

Grid Solutions Framework SelfHostingServiceInitializeServiceHost Method
Initializes the ServiceHost.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void InitializeServiceHost()
Protected Overridable Sub InitializeServiceHost
abstract InitializeServiceHost : unit -> unit
override InitializeServiceHost : unit -> unit
function InitializeServiceHost();
protected:
virtual void InitializeServiceHost()
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.LoadSettings Method

Grid Solutions Framework SelfHostingServiceLoadSettings Method
Loads saved web service settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.OnServiceHostCreated Method

Grid Solutions Framework SelfHostingServiceOnServiceHostCreated Method
Raises the ServiceHostCreated event.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceHostCreated()
Protected Overridable Sub OnServiceHostCreated
abstract OnServiceHostCreated : unit -> unit
override OnServiceHostCreated : unit -> unit
function OnServiceHostCreated();
protected:
virtual void OnServiceHostCreated()
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.OnServiceHostStarted Method

Grid Solutions Framework SelfHostingServiceOnServiceHostStarted Method
Raises the ServiceHostStarted event.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceHostStarted()
Protected Overridable Sub OnServiceHostStarted
abstract OnServiceHostStarted : unit -> unit
override OnServiceHostStarted : unit -> unit
function OnServiceHostStarted();
protected:
virtual void OnServiceHostStarted()
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.OnServiceProcessException Method

Grid Solutions Framework SelfHostingServiceOnServiceProcessException Method
Raises the ServiceProcessException event.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceProcessException(
    Exception exception
)
Protected Overridable Sub OnServiceProcessException (
    exception As Exception
)
abstract OnServiceProcessException :
        exception : Exception -> unit
override OnServiceProcessException :
        exception : Exception -> unit
function OnServiceProcessException(exception);
protected:
virtual void OnServiceProcessException(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception to sent to ServiceProcessException event.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.SaveSettings Method

Grid Solutions Framework SelfHostingServiceSaveSettings Method
Saves web service settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService Properties

Grid Solutions Framework SelfHostingService Properties

The SelfHostingService type exposes the following members.

Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications.
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com.
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service.
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Overrides AdapterEnabled.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed.
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints.
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints.
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup.
Public property | ServiceHost | Gets the WebServiceHost hosting the web service.
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute.
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled.
Top
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.AllowCrossDomainAccess Property

Grid Solutions Framework SelfHostingServiceAllowCrossDomainAccess Property
Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllowCrossDomainAccess { get; set; }
Public Property AllowCrossDomainAccess As Boolean
    Get
    Set
member AllowCrossDomainAccess : bool with get, set

function get_AllowCrossDomainAccess();
function set_AllowCrossDomainAccess(value);
public:
property bool AllowCrossDomainAccess {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.AllowedDomainList Property

Grid Solutions Framework SelfHostingServiceAllowedDomainList Property
Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string AllowedDomainList { get; set; }
Public Property AllowedDomainList As String
    Get
    Set
member AllowedDomainList : string with get, set

function get_AllowedDomainList();
function set_AllowedDomainList(value);
public:
property String^ AllowedDomainList {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
To allow all domains just set this property to "*".
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.ContractInterface Property

Grid Solutions Framework SelfHostingServiceContractInterface Property
Gets or sets the FullName of the contract interface implemented by the web service.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ContractInterface { get; set; }
Public Property ContractInterface As String
    Get
    Set
abstract ContractInterface : string with get, set
override ContractInterface : string with get, set
function get_ContractInterface();
function set_ContractInterface(value);
public:
virtual property String^ ContractInterface {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISelfHostingServiceContractInterface
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.Enabled Property

Grid Solutions Framework SelfHostingServiceEnabled Property
Gets or sets a boolean value that indicates whether the web service is currently enabled.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Enabled { get; set; }
Public Overrides Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () override;
    void set (bool value) override;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
ISupportLifecycleEnabled
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.Endpoints Property

Grid Solutions Framework SelfHostingServiceEndpoints Property
Gets or sets a semicolon delimited list of URIs where the web service can be accessed.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Endpoints { get; set; }
Public Property Endpoints As String
    Get
    Set
abstract Endpoints : string with get, set
override Endpoints : string with get, set
function get_Endpoints();
function set_Endpoints(value);
public:
virtual property String^ Endpoints {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISelfHostingServiceEndpoints
Remarks
Set Endpoints to a null or empty string to disable web service hosting. Refer to CreateServiceBinding(String, Boolean) for a list of supported URI formats.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.PublishMetadata Property

Grid Solutions Framework SelfHostingServicePublishMetadata Property
Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PublishMetadata { get; set; }
Public Property PublishMetadata As Boolean
    Get
    Set
abstract PublishMetadata : bool with get, set
override PublishMetadata : bool with get, set
function get_PublishMetadata();
function set_PublishMetadata(value);
public:
virtual property bool PublishMetadata {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISelfHostingServicePublishMetadata
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.SecurityPolicy Property

Grid Solutions Framework SelfHostingServiceSecurityPolicy Property
Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SecurityPolicy { get; set; }
Public Property SecurityPolicy As String
    Get
    Set
abstract SecurityPolicy : string with get, set
override SecurityPolicy : string with get, set
function get_SecurityPolicy();
function set_SecurityPolicy(value);
public:
virtual property String^ SecurityPolicy {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

ISelfHostingServiceSecurityPolicy
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.ServiceEnabled Property

Grid Solutions Framework SelfHostingServiceServiceEnabled Property
Gets or sets a boolean value that indicates whether the web service is to be enabled at startup.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ServiceEnabled { get; set; }
Public Property ServiceEnabled As Boolean
    Get
    Set
member ServiceEnabled : bool with get, set

function get_ServiceEnabled();
function set_ServiceEnabled(value);
public:
property bool ServiceEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.ServiceHost Property

Grid Solutions Framework SelfHostingServiceServiceHost Property
Gets the WebServiceHost hosting the web service.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceHost ServiceHost { get; }
Public ReadOnly Property ServiceHost As ServiceHost
    Get
abstract ServiceHost : ServiceHost with get
override ServiceHost : ServiceHost with get
function get_ServiceHost();

public:
virtual property ServiceHost^ ServiceHost {
    ServiceHost^ get () sealed;
}

Property Value

Type: ServiceHost

Implements

ISelfHostingServiceServiceHost
Remarks
By default, the ServiceHost only has WebHttpBinding endpoint at the Endpoints. Additional endpoints can be added to the ServiceHost when ServiceHostCreated event is fired.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.Singleton Property

Grid Solutions Framework SelfHostingServiceSingleton Property
Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Singleton { get; set; }
Public Property Singleton As Boolean
    Get
    Set
abstract Singleton : bool with get, set
override Singleton : bool with get, set
function get_Singleton();
function set_Singleton(value);
public:
virtual property bool Singleton {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISelfHostingServiceSingleton
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.WindowsAuthentication Property

Grid Solutions Framework SelfHostingServiceWindowsAuthentication Property
Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool WindowsAuthentication { get; set; }
Public Property WindowsAuthentication As Boolean
    Get
    Set
member WindowsAuthentication : bool with get, set

function get_WindowsAuthentication();
function set_WindowsAuthentication(value);
public:
property bool WindowsAuthentication {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService Events

Grid Solutions Framework SelfHostingService Events

The SelfHostingService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints.
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints.
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request.
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.ServiceHostCreated Event

Grid Solutions Framework SelfHostingServiceServiceHostCreated Event
Occurs when the ServiceHost has been created with the specified Endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServiceHostCreated
Public Event ServiceHostCreated As EventHandler
abstract ServiceHostCreated : IEvent<EventHandler,
    EventArgs>
override ServiceHostCreated : IEvent<EventHandler,
    EventArgs>
function add_ServiceHostCreated(value);
function remove_ServiceHostCreated(value);
public:
virtual  event EventHandler^ ServiceHostCreated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISelfHostingServiceServiceHostCreated
Remarks
When ServiceHostCreated event is fired, changes like adding new endpoints can be made to the ServiceHost.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.ServiceHostStarted Event

Grid Solutions Framework SelfHostingServiceServiceHostStarted Event
Occurs when the ServiceHost has can process requests via all of its endpoints.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServiceHostStarted
Public Event ServiceHostStarted As EventHandler
abstract ServiceHostStarted : IEvent<EventHandler,
    EventArgs>
override ServiceHostStarted : IEvent<EventHandler,
    EventArgs>
function add_ServiceHostStarted(value);
function remove_ServiceHostStarted(value);
public:
virtual  event EventHandler^ ServiceHostStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISelfHostingServiceServiceHostStarted
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


SelfHostingService.ServiceProcessException Event

Grid Solutions Framework SelfHostingServiceServiceProcessException Event
Occurs when an Exception is encountered when processing a request.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ServiceProcessException
Public Event ServiceProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ServiceProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ServiceProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ServiceProcessException(value);
function remove_ServiceProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ServiceProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

ISelfHostingServiceServiceProcessException
Remarks
Argument is the exception encountered when processing a request.
See Also

Reference

SelfHostingService Class
GSF.ServiceModel Namespace


Service Class

Grid Solutions Framework Service Class
Defines helper methods related to WCF-based web services.
Inheritance Hierarchy
SystemObject
GSF.ServiceModelService

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Service
Public NotInheritable Class Service
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Service =  class end
GSF.ServiceModel.Service = function();

Type.createClass(
    'GSF.ServiceModel.Service');
public ref class Service abstract sealed

The Service type exposes the following members.

Methods
Name | Description
CreateServiceBinding | Creates a Binding based on the specified address.
GetAuthenticationSchemes | Gets the security setting of the hosting environment (For example: IIS web site or virtual directory).
GetServiceContract | Gets the contract that the service implements.
Top
See Also

Reference

GSF.ServiceModel Namespace


Service Methods

Grid Solutions Framework Service Methods

The Service type exposes the following members.

Methods
Name | Description
CreateServiceBinding | Creates a Binding based on the specified address.
GetAuthenticationSchemes | Gets the security setting of the hosting environment (For example: IIS web site or virtual directory).
GetServiceContract | Gets the contract that the service implements.
Top
See Also

Reference

Service Class
GSF.ServiceModel Namespace


Service.CreateServiceBinding Method

Grid Solutions Framework ServiceCreateServiceBinding Method
Creates a Binding based on the specified address.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Binding CreateServiceBinding(
    ref string address,
    bool enableSecurity
)
Public Shared Function CreateServiceBinding (
    ByRef address As String,
    enableSecurity As Boolean
) As Binding
static member CreateServiceBinding :
        address : string byref *
        enableSecurity : bool -> Binding

GSF.ServiceModel.Service.CreateServiceBinding = function(address, enableSecurity);
public:
static Binding^ CreateServiceBinding(
    String^% address,
    bool enableSecurity
)

Parameters

address
Type: SystemString
The URI that is used to determine the type of Binding to be created.
enableSecurity
Type: SystemBoolean
A boolean value that indicated whether security is to be enabled on the Binding.

Return Value

Type: Binding
An Binding object if a valid address is specified; otherwise null.
Remarks
This list shows all valid address schemes that can be specified in the address:
Address Scheme | Usage
http:// or http.soap11:// | An address of http.soap11://localhost:2929 will create an BasicHttpBinding and update the address to http://localhost:2929.
http.soap12:// | An address of http.soap12://localhost:2929 will create an WSHttpBinding and update the address to http://localhost:2929.
http.duplex:// | An address of http.duplex://localhost:2929 will create an WSDualHttpBinding and update the address to http://localhost:2929.
http.rest:// | An address of http.rest://localhost:2929 will create an WebHttpBinding and update the address to http://localhost:2929.
net.tcp:// | An address of net.tcp://localhost:2929 will create an NetTcpBinding and leave the address unchanged.
net.p2p:// | An address of net.p2p://localhost:2929 will create an NetPeerTcpBinding and leave the address unchanged.
net.pipe:// | An address of net.pipe://localhost:2929 will create an NetNamedPipeBinding and leave the address unchanged.
net.msmq:// | An address of net.msmq://localhost:2929 will create an NetMsmqBinding and leave the address unchanged.

The enableSecurity parameter value is ignored Mono deployments since security bindings are not implemented.

See Also

Reference

Service Class
GSF.ServiceModel Namespace


Service.GetAuthenticationSchemes Method

Grid Solutions Framework ServiceGetAuthenticationSchemes Method
Gets the security setting of the hosting environment (For example: IIS web site or virtual directory).

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static AuthenticationSchemes GetAuthenticationSchemes(
    Uri baseAddress
)
Public Shared Function GetAuthenticationSchemes (
    baseAddress As Uri
) As AuthenticationSchemes
static member GetAuthenticationSchemes :
        baseAddress : Uri -> AuthenticationSchemes

GSF.ServiceModel.Service.GetAuthenticationSchemes = function(baseAddress);
public:
static AuthenticationSchemes GetAuthenticationSchemes(
    Uri^ baseAddress
)

Parameters

baseAddress
Type: SystemUri

[Missing <param name="baseAddress"/> documentation for "M:GSF.ServiceModel.Service.GetAuthenticationSchemes(System.Uri)"]

Return Value

Type: AuthenticationSchemes

[Missing <returns> documentation for "M:GSF.ServiceModel.Service.GetAuthenticationSchemes(System.Uri)"]

See Also

Reference

Service Class
GSF.ServiceModel Namespace


Service.GetServiceContract Method

Grid Solutions Framework ServiceGetServiceContract Method
Gets the contract that the service implements.

Namespace: GSF.ServiceModel
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Type GetServiceContract(
    Type serviceType
)
Public Shared Function GetServiceContract (
    serviceType As Type
) As Type
static member GetServiceContract :
        serviceType : Type -> Type

GSF.ServiceModel.Service.GetServiceContract = function(serviceType);
public:
static Type^ GetServiceContract(
    Type^ serviceType
)

Parameters

serviceType
Type: SystemType
Type of the service.

Return Value

Type: Type
Type of the service contract if found, otherwise null.
See Also

Reference

Service Class
GSF.ServiceModel Namespace


GSF.ServiceModel.Activation Namespace

Grid Solutions Framework GSF.ServiceModel.Activation Namespace

[Missing <summary> documentation for "N:GSF.ServiceModel.Activation"]

Classes
 | Class | Description
Public class | FormatSpecificationBehavior | WCF Endpoint behavior intended to be attached to REST endpoints. Attaches FormatSpecificationInspector to inspect requests and alter their formats as required.
Public class | FormatSpecificationInspector | Message inspector intended to be attached to WCF REST endpoints. Examines incoming requests for "application/json" in the "Accept" header, and sets the response format to Json when present.
Public class | SecureDataServiceHostFactory | A service host factory for WCF Data Services that enables role-based security using IAuthorizationPolicy.
Public class | SecureServiceHostFactory | A service host factory for WCF Services that enables role-based security using IAuthorizationPolicy.


FormatSpecificationBehavior Class

Grid Solutions Framework FormatSpecificationBehavior Class
WCF Endpoint behavior intended to be attached to REST endpoints. Attaches FormatSpecificationInspector to inspect requests and alter their formats as required.
Inheritance Hierarchy
SystemObject
GSF.ServiceModel.ActivationFormatSpecificationBehavior

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FormatSpecificationBehavior : IEndpointBehavior
Public Class FormatSpecificationBehavior
    Implements IEndpointBehavior
type FormatSpecificationBehavior =
    class
        interface IEndpointBehavior
    end
GSF.ServiceModel.Activation.FormatSpecificationBehavior = function();

Type.createClass(
    'GSF.ServiceModel.Activation.FormatSpecificationBehavior',
    null,
    IEndpointBehavior);
public ref class FormatSpecificationBehavior : IEndpointBehavior

The FormatSpecificationBehavior type exposes the following members.

Constructors
 | Name | Description
Public method | FormatSpecificationBehavior | Initializes a new instance of the FormatSpecificationBehavior class
Top
Methods
 | Name | Description
Public method | AddBindingParameters | Implement to pass data at runtime to bindings to support custom behavior.
Public method | ApplyClientBehavior | Implements a modification or extension of the client across an endpoint.
Public method | ApplyDispatchBehavior | Implements a modification or extension of the service across an endpoint.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Implement to confirm that the endpoint meets some intended criteria.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ServiceModel.Activation Namespace


FormatSpecificationBehavior Constructor

Grid Solutions Framework FormatSpecificationBehavior Constructor
Initializes a new instance of the FormatSpecificationBehavior class

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FormatSpecificationBehavior()
Public Sub New
new : unit -> FormatSpecificationBehavior
GSF.ServiceModel.Activation.FormatSpecificationBehavior = function();
public:
FormatSpecificationBehavior()
See Also

Reference

FormatSpecificationBehavior Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationBehavior Methods

Grid Solutions Framework FormatSpecificationBehavior Methods

The FormatSpecificationBehavior type exposes the following members.

Methods
 | Name | Description
Public method | AddBindingParameters | Implement to pass data at runtime to bindings to support custom behavior.
Public method | ApplyClientBehavior | Implements a modification or extension of the client across an endpoint.
Public method | ApplyDispatchBehavior | Implements a modification or extension of the service across an endpoint.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Implement to confirm that the endpoint meets some intended criteria.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FormatSpecificationBehavior Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationBehavior.AddBindingParameters Method

Grid Solutions Framework FormatSpecificationBehaviorAddBindingParameters Method
Implement to pass data at runtime to bindings to support custom behavior.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddBindingParameters(
    ServiceEndpoint endpoint,
    BindingParameterCollection bindingParameters
)
Public Sub AddBindingParameters (
    endpoint As ServiceEndpoint,
    bindingParameters As BindingParameterCollection
)
abstract AddBindingParameters :
        endpoint : ServiceEndpoint *
        bindingParameters : BindingParameterCollection -> unit
override AddBindingParameters :
        endpoint : ServiceEndpoint *
        bindingParameters : BindingParameterCollection -> unit
function AddBindingParameters(endpoint, bindingParameters);
public:
virtual void AddBindingParameters(
    ServiceEndpoint^ endpoint,
    BindingParameterCollection^ bindingParameters
) sealed

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
The endpoint to modify.
bindingParameters
Type: System.ServiceModel.ChannelsBindingParameterCollection
The objects that binding elements require to support the behavior.

Implements

IEndpointBehaviorAddBindingParameters(ServiceEndpoint, BindingParameterCollection)
See Also

Reference

FormatSpecificationBehavior Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationBehavior.ApplyClientBehavior Method

Grid Solutions Framework FormatSpecificationBehaviorApplyClientBehavior Method
Implements a modification or extension of the client across an endpoint.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ApplyClientBehavior(
    ServiceEndpoint endpoint,
    ClientRuntime clientRuntime
)
Public Sub ApplyClientBehavior (
    endpoint As ServiceEndpoint,
    clientRuntime As ClientRuntime
)
abstract ApplyClientBehavior :
        endpoint : ServiceEndpoint *
        clientRuntime : ClientRuntime -> unit
override ApplyClientBehavior :
        endpoint : ServiceEndpoint *
        clientRuntime : ClientRuntime -> unit
function ApplyClientBehavior(endpoint, clientRuntime);
public:
virtual void ApplyClientBehavior(
    ServiceEndpoint^ endpoint,
    ClientRuntime^ clientRuntime
) sealed

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
The endpoint that is to be customized.
clientRuntime
Type: System.ServiceModel.DispatcherClientRuntime
The client runtime to be customized.

Implements

IEndpointBehaviorApplyClientBehavior(ServiceEndpoint, ClientRuntime)
See Also

Reference

FormatSpecificationBehavior Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationBehavior.ApplyDispatchBehavior Method

Grid Solutions Framework FormatSpecificationBehaviorApplyDispatchBehavior Method
Implements a modification or extension of the service across an endpoint.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ApplyDispatchBehavior(
    ServiceEndpoint endpoint,
    EndpointDispatcher endpointDispatcher
)
Public Sub ApplyDispatchBehavior (
    endpoint As ServiceEndpoint,
    endpointDispatcher As EndpointDispatcher
)
abstract ApplyDispatchBehavior :
        endpoint : ServiceEndpoint *
        endpointDispatcher : EndpointDispatcher -> unit
override ApplyDispatchBehavior :
        endpoint : ServiceEndpoint *
        endpointDispatcher : EndpointDispatcher -> unit
function ApplyDispatchBehavior(endpoint, endpointDispatcher);
public:
virtual void ApplyDispatchBehavior(
    ServiceEndpoint^ endpoint,
    EndpointDispatcher^ endpointDispatcher
) sealed

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
The endpoint that exposes the contract.
endpointDispatcher
Type: System.ServiceModel.DispatcherEndpointDispatcher
The endpoint dispatcher to be modified or extended.

Implements

IEndpointBehaviorApplyDispatchBehavior(ServiceEndpoint, EndpointDispatcher)
See Also

Reference

FormatSpecificationBehavior Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationBehavior.Validate Method

Grid Solutions Framework FormatSpecificationBehaviorValidate Method
Implement to confirm that the endpoint meets some intended criteria.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Validate(
    ServiceEndpoint endpoint
)
Public Sub Validate (
    endpoint As ServiceEndpoint
)
abstract Validate :
        endpoint : ServiceEndpoint -> unit
override Validate :
        endpoint : ServiceEndpoint -> unit
function Validate(endpoint);
public:
virtual void Validate(
    ServiceEndpoint^ endpoint
) sealed

Parameters

endpoint
Type: System.ServiceModel.DescriptionServiceEndpoint
The endpoint to validate.

Implements

IEndpointBehaviorValidate(ServiceEndpoint)
See Also

Reference

FormatSpecificationBehavior Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationInspector Class

Grid Solutions Framework FormatSpecificationInspector Class
Message inspector intended to be attached to WCF REST endpoints. Examines incoming requests for "application/json" in the "Accept" header, and sets the response format to Json when present.
Inheritance Hierarchy
SystemObject
GSF.ServiceModel.ActivationFormatSpecificationInspector

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class FormatSpecificationInspector : IDispatchMessageInspector
Public Class FormatSpecificationInspector
    Implements IDispatchMessageInspector
type FormatSpecificationInspector =
    class
        interface IDispatchMessageInspector
    end
GSF.ServiceModel.Activation.FormatSpecificationInspector = function();

Type.createClass(
    'GSF.ServiceModel.Activation.FormatSpecificationInspector',
    null,
    IDispatchMessageInspector);
public ref class FormatSpecificationInspector : IDispatchMessageInspector

The FormatSpecificationInspector type exposes the following members.

Constructors
 | Name | Description
Public method | FormatSpecificationInspector | Initializes a new instance of the FormatSpecificationInspector class
Top
Methods
 | Name | Description
Public method | AfterReceiveRequest | Called after an inbound message has been received but before the message is dispatched to the intended operation.
Public method | BeforeSendReply | Called after the operation has returned but before the reply message is sent.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.ServiceModel.Activation Namespace


FormatSpecificationInspector Constructor

Grid Solutions Framework FormatSpecificationInspector Constructor
Initializes a new instance of the FormatSpecificationInspector class

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public FormatSpecificationInspector()
Public Sub New
new : unit -> FormatSpecificationInspector
GSF.ServiceModel.Activation.FormatSpecificationInspector = function();
public:
FormatSpecificationInspector()
See Also

Reference

FormatSpecificationInspector Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationInspector Methods

Grid Solutions Framework FormatSpecificationInspector Methods

The FormatSpecificationInspector type exposes the following members.

Methods
 | Name | Description
Public method | AfterReceiveRequest | Called after an inbound message has been received but before the message is dispatched to the intended operation.
Public method | BeforeSendReply | Called after the operation has returned but before the reply message is sent.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

FormatSpecificationInspector Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationInspector.AfterReceiveRequest Method

Grid Solutions Framework FormatSpecificationInspectorAfterReceiveRequest Method
Called after an inbound message has been received but before the message is dispatched to the intended operation.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object AfterReceiveRequest(
    ref Message request,
    IClientChannel channel,
    InstanceContext instanceContext
)
Public Function AfterReceiveRequest (
    ByRef request As Message,
    channel As IClientChannel,
    instanceContext As InstanceContext
) As Object
abstract AfterReceiveRequest :
        request : Message byref *
        channel : IClientChannel *
        instanceContext : InstanceContext -> Object
override AfterReceiveRequest :
        request : Message byref *
        channel : IClientChannel *
        instanceContext : InstanceContext -> Object
function AfterReceiveRequest(request, channel, instanceContext);
public:
virtual Object^ AfterReceiveRequest(
    Message^% request,
    IClientChannel^ channel,
    InstanceContext^ instanceContext
) sealed

Parameters

request
Type: System.ServiceModel.ChannelsMessage
The request message.
channel
Type: System.ServiceModelIClientChannel
The incoming channel.
instanceContext
Type: System.ServiceModelInstanceContext
The current service instance.

Return Value

Type: Object
The object used to correlate state. This object is passed back in the BeforeSendReply(Message, Object) method.

Implements

IDispatchMessageInspectorAfterReceiveRequest(Message, IClientChannel, InstanceContext)
See Also

Reference

FormatSpecificationInspector Class
GSF.ServiceModel.Activation Namespace


FormatSpecificationInspector.BeforeSendReply Method

Grid Solutions Framework FormatSpecificationInspectorBeforeSendReply Method
Called after the operation has returned but before the reply message is sent.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void BeforeSendReply(
    ref Message reply,
    Object correlationState
)
Public Sub BeforeSendReply (
    ByRef reply As Message,
    correlationState As Object
)
abstract BeforeSendReply :
        reply : Message byref *
        correlationState : Object -> unit
override BeforeSendReply :
        reply : Message byref *
        correlationState : Object -> unit
function BeforeSendReply(reply, correlationState);
public:
virtual void BeforeSendReply(
    Message^% reply,
    Object^ correlationState
) sealed

Parameters

reply
Type: System.ServiceModel.ChannelsMessage
The reply message. This value is null if the operation is one way.
correlationState
Type: SystemObject
The correlation object returned from the AfterReceiveRequest(Message, IClientChannel, InstanceContext) method.

Implements

IDispatchMessageInspectorBeforeSendReply(Message, Object)
See Also

Reference

FormatSpecificationInspector Class
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Class

Grid Solutions Framework SecureDataServiceHostFactory Class
A service host factory for WCF Data Services that enables role-based security using IAuthorizationPolicy.
Inheritance Hierarchy
SystemObject
System.ServiceModel.ActivationServiceHostFactoryBase
System.ServiceModel.ActivationServiceHostFactory
System.Data.ServicesDataServiceHostFactory
GSF.ServiceModel.ActivationSecureDataServiceHostFactory

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecureDataServiceHostFactory : DataServiceHostFactory
Public Class SecureDataServiceHostFactory
    Inherits DataServiceHostFactory
type SecureDataServiceHostFactory =
    class
        inherit DataServiceHostFactory
    end
GSF.ServiceModel.Activation.SecureDataServiceHostFactory = function();

Type.createClass(
    'GSF.ServiceModel.Activation.SecureDataServiceHostFactory',
    DataServiceHostFactory);
public ref class SecureDataServiceHostFactory : public DataServiceHostFactory

The SecureDataServiceHostFactory type exposes the following members.

Constructors
 | Name | Description
Public method | SecureDataServiceHostFactory | Initializes a new instance of the SecureDataServiceHostFactory class.
Public method | SecureDataServiceHostFactory(ListIEndpointBehavior) | Initializes a new instance of the SecureDataServiceHostFactory class.
Public method | SecureDataServiceHostFactory(ListIServiceBehavior) | Initializes a new instance of the SecureDataServiceHostFactory class.
Public method | SecureDataServiceHostFactory(ListIServiceBehavior, ListIEndpointBehavior) | Initializes a new instance of the SecureDataServiceHostFactory class.
Top
Methods
 | Name | Description
Public method | CreateServiceHost(String, Uri) | Creates a ServiceHost with specific base addresses and initializes it with specified data. (Inherited from ServiceHostFactory.)
Protected method | CreateServiceHost(Type, Uri) | Creates a new DataServiceHost from the URI. (Overrides DataServiceHostFactoryCreateServiceHost(Type, Uri).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AuthorizationPolicy | Gets or sets the IAuthorizationPolicy used for securing the service.
Public property | EndpointBehaviors | Gets or sets the list of endpoint behaviors applied to endpoints created for the service.
Public property | ServiceBehaviors | Gets or sets the list of IServiceBehavior applied to the service.
Top
See Also

Reference

GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Constructor

Grid Solutions Framework SecureDataServiceHostFactory Constructor
Overload List
 | Name | Description
Public method | SecureDataServiceHostFactory | Initializes a new instance of the SecureDataServiceHostFactory class.
Public method | SecureDataServiceHostFactory(ListIEndpointBehavior) | Initializes a new instance of the SecureDataServiceHostFactory class.
Public method | SecureDataServiceHostFactory(ListIServiceBehavior) | Initializes a new instance of the SecureDataServiceHostFactory class.
Public method | SecureDataServiceHostFactory(ListIServiceBehavior, ListIEndpointBehavior) | Initializes a new instance of the SecureDataServiceHostFactory class.
Top
See Also

Reference

SecureDataServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Constructor

Grid Solutions Framework SecureDataServiceHostFactory Constructor
Initializes a new instance of the SecureDataServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureDataServiceHostFactory()
Public Sub New
new : unit -> SecureDataServiceHostFactory
GSF.ServiceModel.Activation.SecureDataServiceHostFactory = function();
public:
SecureDataServiceHostFactory()
See Also

Reference

SecureDataServiceHostFactory Class
SecureDataServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Constructor (List(IEndpointBehavior))

Grid Solutions Framework SecureDataServiceHostFactory Constructor (ListIEndpointBehavior)
Initializes a new instance of the SecureDataServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureDataServiceHostFactory(
    List<IEndpointBehavior> behaviors
)
Public Sub New (
    behaviors As List(Of IEndpointBehavior)
)
new :
        behaviors : List<IEndpointBehavior> -> SecureDataServiceHostFactory
GSF.ServiceModel.Activation.SecureDataServiceHostFactory = function(behaviors);
public:
SecureDataServiceHostFactory(
    List<IEndpointBehavior^>^ behaviors
)

Parameters

behaviors
Type: System.Collections.GenericList IEndpointBehavior
A collection of endpoint behaviors that will be applied to newly created endpoints.
See Also

Reference

SecureDataServiceHostFactory Class
SecureDataServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Constructor (List(IServiceBehavior))

Grid Solutions Framework SecureDataServiceHostFactory Constructor (ListIServiceBehavior)
Initializes a new instance of the SecureDataServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureDataServiceHostFactory(
    List<IServiceBehavior> behaviors
)
Public Sub New (
    behaviors As List(Of IServiceBehavior)
)
new :
        behaviors : List<IServiceBehavior> -> SecureDataServiceHostFactory
GSF.ServiceModel.Activation.SecureDataServiceHostFactory = function(behaviors);
public:
SecureDataServiceHostFactory(
    List<IServiceBehavior^>^ behaviors
)

Parameters

behaviors
Type: System.Collections.GenericList IServiceBehavior
A collection of service behaviors that will be applied to newly created services.
See Also

Reference

SecureDataServiceHostFactory Class
SecureDataServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Constructor (List(IServiceBehavior), List(IEndpointBehavior))

Grid Solutions Framework SecureDataServiceHostFactory Constructor (ListIServiceBehavior, ListIEndpointBehavior)
Initializes a new instance of the SecureDataServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureDataServiceHostFactory(
    List<IServiceBehavior> serviceBehaviors,
    List<IEndpointBehavior> endpointBehaviors
)
Public Sub New (
    serviceBehaviors As List(Of IServiceBehavior),
    endpointBehaviors As List(Of IEndpointBehavior)
)
new :
        serviceBehaviors : List<IServiceBehavior> *
        endpointBehaviors : List<IEndpointBehavior> -> SecureDataServiceHostFactory
GSF.ServiceModel.Activation.SecureDataServiceHostFactory = function(serviceBehaviors, endpointBehaviors);
public:
SecureDataServiceHostFactory(
    List<IServiceBehavior^>^ serviceBehaviors,
    List<IEndpointBehavior^>^ endpointBehaviors
)

Parameters

serviceBehaviors
Type: System.Collections.GenericList IServiceBehavior
A collection of service behaviors that will be applied to newly created services.
endpointBehaviors
Type: System.Collections.GenericList IEndpointBehavior
A collection of endpoint behaviors that will be applied to newly created endpoints.
See Also

Reference

SecureDataServiceHostFactory Class
SecureDataServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Methods

Grid Solutions Framework SecureDataServiceHostFactory Methods

The SecureDataServiceHostFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateServiceHost(String, Uri) | Creates a ServiceHost with specific base addresses and initializes it with specified data. (Inherited from ServiceHostFactory.)
Protected method | CreateServiceHost(Type, Uri) | Creates a new DataServiceHost from the URI. (Overrides DataServiceHostFactoryCreateServiceHost(Type, Uri).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecureDataServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory.CreateServiceHost Method

Grid Solutions Framework SecureDataServiceHostFactoryCreateServiceHost Method
Overload List
 | Name | Description
Public method | CreateServiceHost(String, Uri) | Creates a ServiceHost with specific base addresses and initializes it with specified data. (Inherited from ServiceHostFactory.)
Protected method | CreateServiceHost(Type, Uri) | Creates a new DataServiceHost from the URI. (Overrides DataServiceHostFactoryCreateServiceHost(Type, Uri).)
Top
See Also

Reference

SecureDataServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory.CreateServiceHost Method (Type, Uri[])

Grid Solutions Framework SecureDataServiceHostFactoryCreateServiceHost Method (Type, Uri)
Creates a new DataServiceHost from the URI.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ServiceHost CreateServiceHost(
    Type serviceType,
    Uri[] baseAddresses
)
Protected Overrides Function CreateServiceHost (
    serviceType As Type,
    baseAddresses As Uri()
) As ServiceHost
abstract CreateServiceHost :
        serviceType : Type *
        baseAddresses : Uri[] -> ServiceHost
override CreateServiceHost :
        serviceType : Type *
        baseAddresses : Uri[] -> ServiceHost
function CreateServiceHost(serviceType, baseAddresses);
protected:
virtual ServiceHost^ CreateServiceHost(
    Type^ serviceType,
    array<Uri^>^ baseAddresses
) override

Parameters

serviceType
Type: SystemType
Specifies the type of WCF service to host.
baseAddresses
Type: SystemUri
An array of base addresses for the service.

Return Value

Type: ServiceHost
New DataServiceHost.
See Also

Reference

SecureDataServiceHostFactory Class
CreateServiceHost Overload
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory Properties

Grid Solutions Framework SecureDataServiceHostFactory Properties

The SecureDataServiceHostFactory type exposes the following members.

Properties
 | Name | Description
Public property | AuthorizationPolicy | Gets or sets the IAuthorizationPolicy used for securing the service.
Public property | EndpointBehaviors | Gets or sets the list of endpoint behaviors applied to endpoints created for the service.
Public property | ServiceBehaviors | Gets or sets the list of IServiceBehavior applied to the service.
Top
See Also

Reference

SecureDataServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory.AuthorizationPolicy Property

Grid Solutions Framework SecureDataServiceHostFactoryAuthorizationPolicy Property
Gets or sets the IAuthorizationPolicy used for securing the service.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Type AuthorizationPolicy { get; set; }
Public Property AuthorizationPolicy As Type
    Get
    Set
member AuthorizationPolicy : Type with get, set

function get_AuthorizationPolicy();
function set_AuthorizationPolicy(value);
public:
property Type^ AuthorizationPolicy {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

SecureDataServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory.EndpointBehaviors Property

Grid Solutions Framework SecureDataServiceHostFactoryEndpointBehaviors Property
Gets or sets the list of endpoint behaviors applied to endpoints created for the service.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<IEndpointBehavior> EndpointBehaviors { get; set; }
Public Property EndpointBehaviors As List(Of IEndpointBehavior)
    Get
    Set
member EndpointBehaviors : List<IEndpointBehavior> with get, set

function get_EndpointBehaviors();
function set_EndpointBehaviors(value);
public:
property List<IEndpointBehavior^>^ EndpointBehaviors {
    List<IEndpointBehavior^>^ get ();
    void set (List<IEndpointBehavior^>^ value);
}

Property Value

Type: List IEndpointBehavior
See Also

Reference

SecureDataServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureDataServiceHostFactory.ServiceBehaviors Property

Grid Solutions Framework SecureDataServiceHostFactoryServiceBehaviors Property
Gets or sets the list of IServiceBehavior applied to the service.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<IServiceBehavior> ServiceBehaviors { get; set; }
Public Property ServiceBehaviors As List(Of IServiceBehavior)
    Get
    Set
member ServiceBehaviors : List<IServiceBehavior> with get, set

function get_ServiceBehaviors();
function set_ServiceBehaviors(value);
public:
property List<IServiceBehavior^>^ ServiceBehaviors {
    List<IServiceBehavior^>^ get ();
    void set (List<IServiceBehavior^>^ value);
}

Property Value

Type: List IServiceBehavior
Exceptions
Exception | Condition
ArgumentNullException | Assigned value cannot be null
See Also

Reference

SecureDataServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Class

Grid Solutions Framework SecureServiceHostFactory Class
A service host factory for WCF Services that enables role-based security using IAuthorizationPolicy.
Inheritance Hierarchy
SystemObject
System.ServiceModel.ActivationServiceHostFactoryBase
System.ServiceModel.ActivationServiceHostFactory
GSF.ServiceModel.ActivationSecureServiceHostFactory

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecureServiceHostFactory : ServiceHostFactory
Public Class SecureServiceHostFactory
    Inherits ServiceHostFactory
type SecureServiceHostFactory =
    class
        inherit ServiceHostFactory
    end
GSF.ServiceModel.Activation.SecureServiceHostFactory = function();

Type.createClass(
    'GSF.ServiceModel.Activation.SecureServiceHostFactory',
    ServiceHostFactory);
public ref class SecureServiceHostFactory : public ServiceHostFactory

The SecureServiceHostFactory type exposes the following members.

Constructors
 | Name | Description
Public method | SecureServiceHostFactory | Initializes a new instance of the SecureServiceHostFactory class.
Public method | SecureServiceHostFactory(String) | Initializes a new instance of the SecureServiceHostFactory class.
Public method | SecureServiceHostFactory(String, String) | Initializes a new instance of the SecureServiceHostFactory class.
Public method | SecureServiceHostFactory(String, String, ListIEndpointBehavior, ListIServiceBehavior) | Initializes a new instance of the SecureServiceHostFactory class.
Top
Methods
 | Name | Description
Public method | CreateServiceHost(String, Uri) | Creates a ServiceHost with specific base addresses and initializes it with specified data. (Inherited from ServiceHostFactory.)
Protected method | CreateServiceHost(Type, Uri) | Creates a new ServiceHost from the URI. (Overrides ServiceHostFactoryCreateServiceHost(Type, Uri).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AuthorizationPolicy | Gets or sets the IAuthorizationPolicy used for securing the service.
Public property | DisableSecurity | Gets or sets a boolean value that indicates whether security on the service is to be disabled.
Public property | EndpointBehaviors | Gets or sets the list of endpoint behaviors added to the services created
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether service meta-data is to be published.
Public property | ServiceBehaviors | Gets or sets the list of service behaviors added to the services created
Top
See Also

Reference

GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Constructor

Grid Solutions Framework SecureServiceHostFactory Constructor
Overload List
 | Name | Description
Public method | SecureServiceHostFactory | Initializes a new instance of the SecureServiceHostFactory class.
Public method | SecureServiceHostFactory(String) | Initializes a new instance of the SecureServiceHostFactory class.
Public method | SecureServiceHostFactory(String, String) | Initializes a new instance of the SecureServiceHostFactory class.
Public method | SecureServiceHostFactory(String, String, ListIEndpointBehavior, ListIServiceBehavior) | Initializes a new instance of the SecureServiceHostFactory class.
Top
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Constructor

Grid Solutions Framework SecureServiceHostFactory Constructor
Initializes a new instance of the SecureServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureServiceHostFactory()
Public Sub New
new : unit -> SecureServiceHostFactory
GSF.ServiceModel.Activation.SecureServiceHostFactory = function();
public:
SecureServiceHostFactory()
See Also

Reference

SecureServiceHostFactory Class
SecureServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Constructor (String)

Grid Solutions Framework SecureServiceHostFactory Constructor (String)
Initializes a new instance of the SecureServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureServiceHostFactory(
    string protocol
)
Public Sub New (
    protocol As String
)
new :
        protocol : string -> SecureServiceHostFactory
GSF.ServiceModel.Activation.SecureServiceHostFactory = function(protocol);
public:
SecureServiceHostFactory(
    String^ protocol
)

Parameters

protocol
Type: SystemString
Protocol used by the service.
See Also

Reference

SecureServiceHostFactory Class
SecureServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Constructor (String, String)

Grid Solutions Framework SecureServiceHostFactory Constructor (String, String)
Initializes a new instance of the SecureServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureServiceHostFactory(
    string protocol,
    string address
)
Public Sub New (
    protocol As String,
    address As String
)
new :
        protocol : string *
        address : string -> SecureServiceHostFactory
GSF.ServiceModel.Activation.SecureServiceHostFactory = function(protocol, address);
public:
SecureServiceHostFactory(
    String^ protocol,
    String^ address
)

Parameters

protocol
Type: SystemString
Protocol used by the service.
address
Type: SystemString
Address of the service.
See Also

Reference

SecureServiceHostFactory Class
SecureServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Constructor (String, String, List(IEndpointBehavior), List(IServiceBehavior))

Grid Solutions Framework SecureServiceHostFactory Constructor (String, String, ListIEndpointBehavior, ListIServiceBehavior)
Initializes a new instance of the SecureServiceHostFactory class.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureServiceHostFactory(
    string protocol,
    string address,
    List<IEndpointBehavior> endpointBehaviors,
    List<IServiceBehavior> serviceBehaviors
)
Public Sub New (
    protocol As String,
    address As String,
    endpointBehaviors As List(Of IEndpointBehavior),
    serviceBehaviors As List(Of IServiceBehavior)
)
new :
        protocol : string *
        address : string *
        endpointBehaviors : List<IEndpointBehavior> *
        serviceBehaviors : List<IServiceBehavior> -> SecureServiceHostFactory
GSF.ServiceModel.Activation.SecureServiceHostFactory = function(protocol, address, endpointBehaviors, serviceBehaviors);
public:
SecureServiceHostFactory(
    String^ protocol,
    String^ address,
    List<IEndpointBehavior^>^ endpointBehaviors,
    List<IServiceBehavior^>^ serviceBehaviors
)

Parameters

protocol
Type: SystemString
Protocol used by the service.
address
Type: SystemString
Address of the service.
endpointBehaviors
Type: System.Collections.GenericList IEndpointBehavior
Endpoint behaviors to be added to the created service.
serviceBehaviors
Type: System.Collections.GenericList IServiceBehavior
Service behaviors to be added to the created service.
See Also

Reference

SecureServiceHostFactory Class
SecureServiceHostFactory Overload
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Methods

Grid Solutions Framework SecureServiceHostFactory Methods

The SecureServiceHostFactory type exposes the following members.

Methods
 | Name | Description
Public method | CreateServiceHost(String, Uri) | Creates a ServiceHost with specific base addresses and initializes it with specified data. (Inherited from ServiceHostFactory.)
Protected method | CreateServiceHost(Type, Uri) | Creates a new ServiceHost from the URI. (Overrides ServiceHostFactoryCreateServiceHost(Type, Uri).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory.CreateServiceHost Method

Grid Solutions Framework SecureServiceHostFactoryCreateServiceHost Method
Overload List
 | Name | Description
Public method | CreateServiceHost(String, Uri) | Creates a ServiceHost with specific base addresses and initializes it with specified data. (Inherited from ServiceHostFactory.)
Protected method | CreateServiceHost(Type, Uri) | Creates a new ServiceHost from the URI. (Overrides ServiceHostFactoryCreateServiceHost(Type, Uri).)
Top
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory.CreateServiceHost Method (Type, Uri[])

Grid Solutions Framework SecureServiceHostFactoryCreateServiceHost Method (Type, Uri)
Creates a new ServiceHost from the URI.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override ServiceHost CreateServiceHost(
    Type serviceType,
    Uri[] baseAddresses
)
Protected Overrides Function CreateServiceHost (
    serviceType As Type,
    baseAddresses As Uri()
) As ServiceHost
abstract CreateServiceHost :
        serviceType : Type *
        baseAddresses : Uri[] -> ServiceHost
override CreateServiceHost :
        serviceType : Type *
        baseAddresses : Uri[] -> ServiceHost
function CreateServiceHost(serviceType, baseAddresses);
protected:
virtual ServiceHost^ CreateServiceHost(
    Type^ serviceType,
    array<Uri^>^ baseAddresses
) override

Parameters

serviceType
Type: SystemType
Specifies the type of WCF service to host.
baseAddresses
Type: SystemUri
An array of base addresses for the service.

Return Value

Type: ServiceHost
New ServiceHost.
See Also

Reference

SecureServiceHostFactory Class
CreateServiceHost Overload
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory Properties

Grid Solutions Framework SecureServiceHostFactory Properties

The SecureServiceHostFactory type exposes the following members.

Properties
 | Name | Description
Public property | AuthorizationPolicy | Gets or sets the IAuthorizationPolicy used for securing the service.
Public property | DisableSecurity | Gets or sets a boolean value that indicates whether security on the service is to be disabled.
Public property | EndpointBehaviors | Gets or sets the list of endpoint behaviors added to the services created
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether service meta-data is to be published.
Public property | ServiceBehaviors | Gets or sets the list of service behaviors added to the services created
Top
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory.AuthorizationPolicy Property

Grid Solutions Framework SecureServiceHostFactoryAuthorizationPolicy Property
Gets or sets the IAuthorizationPolicy used for securing the service.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Type AuthorizationPolicy { get; set; }
Public Property AuthorizationPolicy As Type
    Get
    Set
member AuthorizationPolicy : Type with get, set

function get_AuthorizationPolicy();
function set_AuthorizationPolicy(value);
public:
property Type^ AuthorizationPolicy {
    Type^ get ();
    void set (Type^ value);
}

Property Value

Type: Type
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory.DisableSecurity Property

Grid Solutions Framework SecureServiceHostFactoryDisableSecurity Property
Gets or sets a boolean value that indicates whether security on the service is to be disabled.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool DisableSecurity { get; set; }
Public Property DisableSecurity As Boolean
    Get
    Set
member DisableSecurity : bool with get, set

function get_DisableSecurity();
function set_DisableSecurity(value);
public:
property bool DisableSecurity {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory.EndpointBehaviors Property

Grid Solutions Framework SecureServiceHostFactoryEndpointBehaviors Property
Gets or sets the list of endpoint behaviors added to the services created

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<IEndpointBehavior> EndpointBehaviors { get; set; }
Public Property EndpointBehaviors As List(Of IEndpointBehavior)
    Get
    Set
member EndpointBehaviors : List<IEndpointBehavior> with get, set

function get_EndpointBehaviors();
function set_EndpointBehaviors(value);
public:
property List<IEndpointBehavior^>^ EndpointBehaviors {
    List<IEndpointBehavior^>^ get ();
    void set (List<IEndpointBehavior^>^ value);
}

Property Value

Type: List IEndpointBehavior
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory.PublishMetadata Property

Grid Solutions Framework SecureServiceHostFactoryPublishMetadata Property
Gets or sets a boolean value that indicates whether service meta-data is to be published.

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PublishMetadata { get; set; }
Public Property PublishMetadata As Boolean
    Get
    Set
member PublishMetadata : bool with get, set

function get_PublishMetadata();
function set_PublishMetadata(value);
public:
property bool PublishMetadata {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


SecureServiceHostFactory.ServiceBehaviors Property

Grid Solutions Framework SecureServiceHostFactoryServiceBehaviors Property
Gets or sets the list of service behaviors added to the services created

Namespace: GSF.ServiceModel.Activation
Assembly: GSF.ServiceModel (in GSF.ServiceModel.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<IServiceBehavior> ServiceBehaviors { get; set; }
Public Property ServiceBehaviors As List(Of IServiceBehavior)
    Get
    Set
member ServiceBehaviors : List<IServiceBehavior> with get, set

function get_ServiceBehaviors();
function set_ServiceBehaviors(value);
public:
property List<IServiceBehavior^>^ ServiceBehaviors {
    List<IServiceBehavior^>^ get ();
    void set (List<IServiceBehavior^>^ value);
}

Property Value

Type: List IServiceBehavior
See Also

Reference

SecureServiceHostFactory Class
GSF.ServiceModel.Activation Namespace


GSF.ServiceProcess Namespace

Grid Solutions Framework GSF.ServiceProcess Namespace
Contains classes used to simplify and standardize development and operation of Windows services that are remotely manageable.
Classes
 | Class | Description
Public class | ClientHelper | Component that provides client-side functionality to ServiceHelper.
Public class | ClientInfo | Represents information about a client using ClientHelper for connecting to a Windows Service that uses ServiceHelper.
Public class | ClientRequest | Represents a request sent by ClientHelper to ServiceHelper.
Public class | ClientRequestHandler | Represents a handler for ClientRequests sent by ClientHelper.
Public class | ClientRequestInfo | Represents information about a ClientRequest sent by ClientHelper.
Public class | ErrorHandlerException | A special exception thrown by error handlers.
Public class | ServiceHelper | Component that provides added functionality to a Windows Service.
Public class | ServiceInstallerEx | Defines an extended service installer class that can define service failure actions at install time.
Public class | ServiceMonitorBase | Base class for service monitors.
Public class | ServiceMonitors | Adapter loader that loads implementations of IServiceMonitor and delegates messages to the enabled monitors.
Public class | ServiceProcess | Represents a process that executes asynchronously inside a ServiceHelper.
Public class | ServiceResponse | Represents a response sent by the ServiceHelper to a ClientRequest from the ClientHelper.
Interfaces
 | Interface | Description
Public interface | IServiceMonitor | Interface for an adapter that monitors the health of a service.
Enumerations
 | Enumeration | Description
Public enumeration | RecoverAction | Defines the recover action to be performed upon service failure.
Public enumeration | ServiceProcessState | Indicates the current state of ServiceProcess.
Public enumeration | ServiceState | Indicates the state of a Windows Service.


ClientHelper Class

Grid Solutions Framework ClientHelper Class
Component that provides client-side functionality to ServiceHelper.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.ServiceProcessClientHelper

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ClientHelper))]
public class ClientHelper : Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IPersistSettings
<ToolboxBitmapAttribute(GetType(ClientHelper))>
Public Class ClientHelper
    Inherits Component
    Implements ISupportLifecycle, IDisposable, ISupportInitialize, IPersistSettings
[<ToolboxBitmapAttribute(typeof(ClientHelper))>]
type ClientHelper =
    class
        inherit Component
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IPersistSettings
    end
GSF.ServiceProcess.ClientHelper = function();

Type.createClass(
    'GSF.ServiceProcess.ClientHelper',
    Component,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(ClientHelper))]
public ref class ClientHelper : public Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IPersistSettings

The ClientHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ClientHelper | Initializes a new instance of the ClientHelper class.
Public method | ClientHelper(IContainer) | Initializes a new instance of the ClientHelper class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ClientHelper properties are initialized.
Public method | Connect | Connects RemotingClient to RemotingServer and wait until authentication is complete.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects RemotingClient from RemotingServer.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ClientHelper object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ClientHelper properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ClientHelper.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ClientHelper from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAuthenticationFailure | Raises the AuthenticationFailure event.
Protected method | OnAuthenticationSuccess | Raises the AuthenticationSuccess event.
Protected method | OnProcessStateChanged | Raises the ProcessStateChanged event.
Protected method | OnReceivedServiceResponse | Raises the ReceivedServiceResponse event.
Protected method | OnReceivedServiceUpdate | Raises the ReceivedServiceUpdate event.
Protected method | OnServiceStateChanged | Raises the ServiceStateChanged event.
Protected method | OnTelnetSessionEstablished | Raises the TelnetSessionEstablished event.
Protected method | OnTelnetSessionTerminated | Raises the TelnetSessionTerminated event.
 | PretendRequest | Returns an ClientRequestInfo object for the specified requestCommand that can be used to invoke ClientRequestHandlers manually as if the request was sent by a ClientHelper remotely.
Public method | SaveSettings | Saves settings for the ClientHelper to the config file if the PersistSettings property is set to true.
Public method | SendRequest(String) | Sends a request to the ServiceHelper using RemotingClient.
Public method | SendRequest(ClientRequest) | Sends a request to the ServiceHelper using RemotingClient.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TryParseActionableResponse | Attempts to parse an actionable response sent from the service.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultPassword | Specifies the default value for the Password property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
DefaultUsername | Specifies the default value for the Username property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ClientHelper is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | Password | Gets or sets the password of the ClientHelper's user to be used for authenticating with the ServiceHelper.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ClientHelper are to be saved to the config file.
Public property | RemotingClient | Gets or sets the ClientBase object used for communicating with the ServiceHelper.
Public property | SerializationFormat | Gets or sets a value that indicates the desired message SerializationFormat for interaction with ServiceHelper.
Public property | SettingsCategory | Gets or sets the category under which the settings of ClientHelper are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Username | Gets or sets the username of the ClientHelper's user to be used for authenticating with the ServiceHelper.
Top
Events
 | Name | Description
Public event | AuthenticationFailure | Occurs when the ServiceHelper fails to authenticate the ClientHelper.
Public event | AuthenticationSuccess | Occurs when the ServiceHelper successfully authenticates the ClientHelper.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ProcessStateChanged | Occurs when the state of a ServiceProcess is changed.
Public event | ReceivedServiceResponse | Occurs when a custom ServiceResponse is received from the ServiceHelper.
Public event | ReceivedServiceUpdate | Occurs when a status update is received from the ServiceHelper.
Public event | ServiceStateChanged | Occurs when the state of the ServiceHelper is changed.
Public event | TelnetSessionEstablished | Occurs when a telnet session has been established.
Public event | TelnetSessionTerminated | Occurs when a telnet session has been terminated.
Top
See Also

Reference

GSF.ServiceProcess Namespace


ClientHelper Constructor

Grid Solutions Framework ClientHelper Constructor
Overload List
 | Name | Description
Public method | ClientHelper | Initializes a new instance of the ClientHelper class.
Public method | ClientHelper(IContainer) | Initializes a new instance of the ClientHelper class.
Top
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper Constructor

Grid Solutions Framework ClientHelper Constructor
Initializes a new instance of the ClientHelper class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientHelper()
Public Sub New
new : unit -> ClientHelper
GSF.ServiceProcess.ClientHelper = function();
public:
ClientHelper()
See Also

Reference

ClientHelper Class
ClientHelper Overload
GSF.ServiceProcess Namespace


ClientHelper Constructor (IContainer)

Grid Solutions Framework ClientHelper Constructor (IContainer)
Initializes a new instance of the ClientHelper class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientHelper(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ClientHelper
GSF.ServiceProcess.ClientHelper = function(container);
public:
ClientHelper(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the ClientHelper.
See Also

Reference

ClientHelper Class
ClientHelper Overload
GSF.ServiceProcess Namespace


ClientHelper Fields

Grid Solutions Framework ClientHelper Fields

The ClientHelper type exposes the following members.

Fields
Name | Description
DefaultPassword | Specifies the default value for the Password property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
DefaultUsername | Specifies the default value for the Username property.
Top
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.DefaultPassword Field

Grid Solutions Framework ClientHelperDefaultPassword Field
Specifies the default value for the Password property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultPassword
Public Const DefaultPassword As String
static val mutable DefaultPassword: string
var GSF.ServiceProcess.ClientHelper.DefaultPassword
public:
literal String^ DefaultPassword

Field Value

Type: String
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.DefaultPersistSettings Field

Grid Solutions Framework ClientHelperDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.ServiceProcess.ClientHelper.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.DefaultSettingsCategory Field

Grid Solutions Framework ClientHelperDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.ServiceProcess.ClientHelper.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.DefaultUsername Field

Grid Solutions Framework ClientHelperDefaultUsername Field
Specifies the default value for the Username property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultUsername
Public Const DefaultUsername As String
static val mutable DefaultUsername: string
var GSF.ServiceProcess.ClientHelper.DefaultUsername
public:
literal String^ DefaultUsername

Field Value

Type: String
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper Methods

Grid Solutions Framework ClientHelper Methods

The ClientHelper type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ClientHelper properties are initialized.
Public method | Connect | Connects RemotingClient to RemotingServer and wait until authentication is complete.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Disconnect | Disconnects RemotingClient from RemotingServer.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ClientHelper object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ClientHelper properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ClientHelper.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ClientHelper from the config file if the PersistSettings property is set to true.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAuthenticationFailure | Raises the AuthenticationFailure event.
Protected method | OnAuthenticationSuccess | Raises the AuthenticationSuccess event.
Protected method | OnProcessStateChanged | Raises the ProcessStateChanged event.
Protected method | OnReceivedServiceResponse | Raises the ReceivedServiceResponse event.
Protected method | OnReceivedServiceUpdate | Raises the ReceivedServiceUpdate event.
Protected method | OnServiceStateChanged | Raises the ServiceStateChanged event.
Protected method | OnTelnetSessionEstablished | Raises the TelnetSessionEstablished event.
Protected method | OnTelnetSessionTerminated | Raises the TelnetSessionTerminated event.
 | PretendRequest | Returns an ClientRequestInfo object for the specified requestCommand that can be used to invoke ClientRequestHandlers manually as if the request was sent by a ClientHelper remotely.
Public method | SaveSettings | Saves settings for the ClientHelper to the config file if the PersistSettings property is set to true.
Public method | SendRequest(String) | Sends a request to the ServiceHelper using RemotingClient.
Public method | SendRequest(ClientRequest) | Sends a request to the ServiceHelper using RemotingClient.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
 | TryParseActionableResponse | Attempts to parse an actionable response sent from the service.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.BeginInit Method

Grid Solutions Framework ClientHelperBeginInit Method
Performs necessary operations before the ClientHelper properties are initialized.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the ClientHelper is consumed through the designer surface of the IDE.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Connect Method

Grid Solutions Framework ClientHelperConnect Method
Connects RemotingClient to RemotingServer and wait until authentication is complete.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Connect()
Public Sub Connect
member Connect : unit -> unit

function Connect();
public:
void Connect()
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Disconnect Method

Grid Solutions Framework ClientHelperDisconnect Method
Disconnects RemotingClient from RemotingServer.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Disconnect()
Public Sub Disconnect
member Disconnect : unit -> unit

function Disconnect();
public:
void Disconnect()
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Dispose Method

Grid Solutions Framework ClientHelperDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ClientHelper object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Dispose Method (Boolean)

Grid Solutions Framework ClientHelperDispose Method (Boolean)
Releases the unmanaged resources used by the ClientHelper object and optionally releases the managed resources.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ClientHelper Class
Dispose Overload
GSF.ServiceProcess Namespace


ClientHelper.EndInit Method

Grid Solutions Framework ClientHelperEndInit Method
Performs necessary operations after the ClientHelper properties are initialized.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the ClientHelper is consumed through the designer surface of the IDE.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Initialize Method

Grid Solutions Framework ClientHelperInitialize Method
Initializes the ClientHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the ClientHelper is not consumed through the designer surface of the IDE.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.LoadSettings Method

Grid Solutions Framework ClientHelperLoadSettings Method
Loads saved settings for the ClientHelper from the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnAuthenticationFailure Method

Grid Solutions Framework ClientHelperOnAuthenticationFailure Method
Raises the AuthenticationFailure event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnAuthenticationFailure()
Protected Overridable Sub OnAuthenticationFailure
abstract OnAuthenticationFailure : unit -> unit
override OnAuthenticationFailure : unit -> unit
function OnAuthenticationFailure();
protected:
virtual void OnAuthenticationFailure()
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnAuthenticationSuccess Method

Grid Solutions Framework ClientHelperOnAuthenticationSuccess Method
Raises the AuthenticationSuccess event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnAuthenticationSuccess()
Protected Overridable Sub OnAuthenticationSuccess
abstract OnAuthenticationSuccess : unit -> unit
override OnAuthenticationSuccess : unit -> unit
function OnAuthenticationSuccess();
protected:
virtual void OnAuthenticationSuccess()
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnProcessStateChanged Method

Grid Solutions Framework ClientHelperOnProcessStateChanged Method
Raises the ProcessStateChanged event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessStateChanged(
    ObjectState<ServiceProcessState> state
)
Protected Overridable Sub OnProcessStateChanged (
    state As ObjectState(Of ServiceProcessState)
)
abstract OnProcessStateChanged :
        state : ObjectState<ServiceProcessState> -> unit
override OnProcessStateChanged :
        state : ObjectState<ServiceProcessState> -> unit
function OnProcessStateChanged(state);
protected:
virtual void OnProcessStateChanged(
    ObjectState<ServiceProcessState>^ state
)

Parameters

state
Type: GSFObjectState ServiceProcessState
New ServiceProcessState.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnReceivedServiceResponse Method

Grid Solutions Framework ClientHelperOnReceivedServiceResponse Method
Raises the ReceivedServiceResponse event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedServiceResponse(
    ServiceResponse response
)
Protected Overridable Sub OnReceivedServiceResponse (
    response As ServiceResponse
)
abstract OnReceivedServiceResponse :
        response : ServiceResponse -> unit
override OnReceivedServiceResponse :
        response : ServiceResponse -> unit
function OnReceivedServiceResponse(response);
protected:
virtual void OnReceivedServiceResponse(
    ServiceResponse^ response
)

Parameters

response
Type: GSF.ServiceProcessServiceResponse
ServiceResponse received.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnReceivedServiceUpdate Method

Grid Solutions Framework ClientHelperOnReceivedServiceUpdate Method
Raises the ReceivedServiceUpdate event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedServiceUpdate(
    UpdateType type,
    string update
)
Protected Overridable Sub OnReceivedServiceUpdate (
    type As UpdateType,
    update As String
)
abstract OnReceivedServiceUpdate :
        type : UpdateType *
        update : string -> unit
override OnReceivedServiceUpdate :
        type : UpdateType *
        update : string -> unit
function OnReceivedServiceUpdate(type, update);
protected:
virtual void OnReceivedServiceUpdate(
    UpdateType type,
    String^ update
)

Parameters

type
Type: GSFUpdateType
One of the UpdateType values.
update
Type: SystemString
Update message received.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnServiceStateChanged Method

Grid Solutions Framework ClientHelperOnServiceStateChanged Method
Raises the ServiceStateChanged event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceStateChanged(
    ObjectState<ServiceState> state
)
Protected Overridable Sub OnServiceStateChanged (
    state As ObjectState(Of ServiceState)
)
abstract OnServiceStateChanged :
        state : ObjectState<ServiceState> -> unit
override OnServiceStateChanged :
        state : ObjectState<ServiceState> -> unit
function OnServiceStateChanged(state);
protected:
virtual void OnServiceStateChanged(
    ObjectState<ServiceState>^ state
)

Parameters

state
Type: GSFObjectState ServiceState
New ServiceState.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnTelnetSessionEstablished Method

Grid Solutions Framework ClientHelperOnTelnetSessionEstablished Method
Raises the TelnetSessionEstablished event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnTelnetSessionEstablished()
Protected Overridable Sub OnTelnetSessionEstablished
abstract OnTelnetSessionEstablished : unit -> unit
override OnTelnetSessionEstablished : unit -> unit
function OnTelnetSessionEstablished();
protected:
virtual void OnTelnetSessionEstablished()
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.OnTelnetSessionTerminated Method

Grid Solutions Framework ClientHelperOnTelnetSessionTerminated Method
Raises the TelnetSessionTerminated event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnTelnetSessionTerminated()
Protected Overridable Sub OnTelnetSessionTerminated
abstract OnTelnetSessionTerminated : unit -> unit
override OnTelnetSessionTerminated : unit -> unit
function OnTelnetSessionTerminated();
protected:
virtual void OnTelnetSessionTerminated()
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.PretendRequest Method

Grid Solutions Framework ClientHelperPretendRequest Method
Returns an ClientRequestInfo object for the specified requestCommand that can be used to invoke ClientRequestHandlers manually as if the request was sent by a ClientHelper remotely.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ClientRequestInfo PretendRequest(
    string requestCommand
)
Public Shared Function PretendRequest (
    requestCommand As String
) As ClientRequestInfo
static member PretendRequest :
        requestCommand : string -> ClientRequestInfo

GSF.ServiceProcess.ClientHelper.PretendRequest = function(requestCommand);
public:
static ClientRequestInfo^ PretendRequest(
    String^ requestCommand
)

Parameters

requestCommand
Type: SystemString
Command for which an ClientRequestInfo object is to be created.

Return Value

Type: ClientRequestInfo
An ClientRequestInfo object.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.SaveSettings Method

Grid Solutions Framework ClientHelperSaveSettings Method
Saves settings for the ClientHelper to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.SendRequest Method

Grid Solutions Framework ClientHelperSendRequest Method
Overload List
 | Name | Description
Public method | SendRequest(String) | Sends a request to the ServiceHelper using RemotingClient.
Public method | SendRequest(ClientRequest) | Sends a request to the ServiceHelper using RemotingClient.
Top
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.SendRequest Method (String)

Grid Solutions Framework ClientHelperSendRequest Method (String)
Sends a request to the ServiceHelper using RemotingClient.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendRequest(
    string request
)
Public Sub SendRequest (
    request As String
)
member SendRequest :
        request : string -> unit

function SendRequest(request);
public:
void SendRequest(
    String^ request
)

Parameters

request
Type: SystemString
Request text to be sent.
See Also

Reference

ClientHelper Class
SendRequest Overload
GSF.ServiceProcess Namespace


ClientHelper.SendRequest Method (ClientRequest)

Grid Solutions Framework ClientHelperSendRequest Method (ClientRequest)
Sends a request to the ServiceHelper using RemotingClient.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendRequest(
    ClientRequest request
)
Public Sub SendRequest (
    request As ClientRequest
)
member SendRequest :
        request : ClientRequest -> unit

function SendRequest(request);
public:
void SendRequest(
    ClientRequest^ request
)

Parameters

request
Type: GSF.ServiceProcessClientRequest
ClientRequest object to be sent.
See Also

Reference

ClientHelper Class
SendRequest Overload
GSF.ServiceProcess Namespace


ClientHelper.TryParseActionableResponse Method

Grid Solutions Framework ClientHelperTryParseActionableResponse Method
Attempts to parse an actionable response sent from the service.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParseActionableResponse(
    ServiceResponse serviceResponse,
    out string sourceCommand,
    out bool responseSuccess
)
Public Shared Function TryParseActionableResponse (
    serviceResponse As ServiceResponse,
    <OutAttribute> ByRef sourceCommand As String,
    <OutAttribute> ByRef responseSuccess As Boolean
) As Boolean
static member TryParseActionableResponse :
        serviceResponse : ServiceResponse *
        sourceCommand : string byref *
        responseSuccess : bool byref -> bool

GSF.ServiceProcess.ClientHelper.TryParseActionableResponse = function(serviceResponse, sourceCommand, responseSuccess);
public:
static bool TryParseActionableResponse(
    ServiceResponse^ serviceResponse,
    [OutAttribute] String^% sourceCommand,
    [OutAttribute] bool% responseSuccess
)

Parameters

serviceResponse
Type: GSF.ServiceProcessServiceResponse
ServiceResponse to test for actionable response.
sourceCommand
Type: SystemString
Command that invoked serviceResponse.
responseSuccess
Type: SystemBoolean
Boolean success state of serviceResponse.

Return Value

Type: Boolean
true if actionable response was able to be parsed successfully; otherwise false.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper Properties

Grid Solutions Framework ClientHelper Properties

The ClientHelper type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ClientHelper is currently enabled.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | Password | Gets or sets the password of the ClientHelper's user to be used for authenticating with the ServiceHelper.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ClientHelper are to be saved to the config file.
Public property | RemotingClient | Gets or sets the ClientBase object used for communicating with the ServiceHelper.
Public property | SerializationFormat | Gets or sets a value that indicates the desired message SerializationFormat for interaction with ServiceHelper.
Public property | SettingsCategory | Gets or sets the category under which the settings of ClientHelper are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Username | Gets or sets the username of the ClientHelper's user to be used for authenticating with the ServiceHelper.
Top
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Enabled Property

Grid Solutions Framework ClientHelperEnabled Property
Gets or sets a boolean value that indicates whether the ClientHelper is currently enabled.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool Enabled { get; set; }
<BrowsableAttribute(false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public Property Enabled As Boolean
    Get
    Set
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract Enabled : bool with get, set
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Enabled property is not be set by user-code directly.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.IsDisposed Property

Grid Solutions Framework ClientHelperIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
public bool IsDisposed { get; }
<BrowsableAttribute(false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
abstract IsDisposed : bool with get
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Password Property

Grid Solutions Framework ClientHelperPassword Property
Gets or sets the password of the ClientHelper's user to be used for authenticating with the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("")]
public string Password { get; set; }
<DefaultValueAttribute("")>
Public Property Password As String
    Get
    Set
[<DefaultValueAttribute("")>]
member Password : string with get, set

function get_Password();
function set_Password(value);
public:
[DefaultValueAttribute(L"")]
property String^ Password {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being specified is a null string.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.PersistSettings Property

Grid Solutions Framework ClientHelperPersistSettings Property
Gets or sets a boolean value that indicates whether the settings of ClientHelper are to be saved to the config file.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.RemotingClient Property

Grid Solutions Framework ClientHelperRemotingClient Property
Gets or sets the ClientBase object used for communicating with the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientBase RemotingClient { get; set; }
Public Property RemotingClient As ClientBase
    Get
    Set
member RemotingClient : ClientBase with get, set

function get_RemotingClient();
function set_RemotingClient(value);
public:
property ClientBase^ RemotingClient {
    ClientBase^ get ();
    void set (ClientBase^ value);
}

Property Value

Type: ClientBase
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.SerializationFormat Property

Grid Solutions Framework ClientHelperSerializationFormat Property
Gets or sets a value that indicates the desired message SerializationFormat for interaction with ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(SerializationFormat.Binary)]
public SerializationFormat SerializationFormat { get; set; }
<DefaultValueAttribute(SerializationFormat.Binary)>
Public Property SerializationFormat As SerializationFormat
    Get
    Set
[<DefaultValueAttribute(SerializationFormat.Binary)>]
member SerializationFormat : SerializationFormat with get, set

function get_SerializationFormat();
function set_SerializationFormat(value);
public:
[DefaultValueAttribute(SerializationFormat::Binary)]
property SerializationFormat SerializationFormat {
    SerializationFormat get ();
    void set (SerializationFormat value);
}

Property Value

Type: SerializationFormat
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.SettingsCategory Property

Grid Solutions Framework ClientHelperSettingsCategory Property
Gets or sets the category under which the settings of ClientHelper are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("ClientHelper")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("ClientHelper")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("ClientHelper")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("ClientHelper")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"ClientHelper")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.Username Property

Grid Solutions Framework ClientHelperUsername Property
Gets or sets the username of the ClientHelper's user to be used for authenticating with the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("")]
public string Username { get; set; }
<DefaultValueAttribute("")>
Public Property Username As String
    Get
    Set
[<DefaultValueAttribute("")>]
member Username : string with get, set

function get_Username();
function set_Username(value);
public:
[DefaultValueAttribute(L"")]
property String^ Username {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being specified is a null string.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper Events

Grid Solutions Framework ClientHelper Events

The ClientHelper type exposes the following members.

Events
 | Name | Description
Public event | AuthenticationFailure | Occurs when the ServiceHelper fails to authenticate the ClientHelper.
Public event | AuthenticationSuccess | Occurs when the ServiceHelper successfully authenticates the ClientHelper.
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | ProcessStateChanged | Occurs when the state of a ServiceProcess is changed.
Public event | ReceivedServiceResponse | Occurs when a custom ServiceResponse is received from the ServiceHelper.
Public event | ReceivedServiceUpdate | Occurs when a status update is received from the ServiceHelper.
Public event | ServiceStateChanged | Occurs when the state of the ServiceHelper is changed.
Public event | TelnetSessionEstablished | Occurs when a telnet session has been established.
Public event | TelnetSessionTerminated | Occurs when a telnet session has been terminated.
Top
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.AuthenticationFailure Event

Grid Solutions Framework ClientHelperAuthenticationFailure Event
Occurs when the ServiceHelper fails to authenticate the ClientHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<CancelEventArgs> AuthenticationFailure
Public Event AuthenticationFailure As EventHandler(Of CancelEventArgs)
member AuthenticationFailure : IEvent<EventHandler<CancelEventArgs>,
    CancelEventArgs>

function add_AuthenticationFailure(value);
function remove_AuthenticationFailure(value);
public:
 event EventHandler<CancelEventArgs^>^ AuthenticationFailure {
    void add (EventHandler<CancelEventArgs^>^ value);
    void remove (EventHandler<CancelEventArgs^>^ value);
}

Value

Type: SystemEventHandler CancelEventArgs
Remarks
Set Cancel to true to continue with connection attempts even after authentication fails. This can be useful for re-authenticating the ClientHelper using different Username and Password.
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.AuthenticationSuccess Event

Grid Solutions Framework ClientHelperAuthenticationSuccess Event
Occurs when the ServiceHelper successfully authenticates the ClientHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler AuthenticationSuccess
Public Event AuthenticationSuccess As EventHandler
member AuthenticationSuccess : IEvent<EventHandler,
    EventArgs>

function add_AuthenticationSuccess(value);
function remove_AuthenticationSuccess(value);
public:
 event EventHandler^ AuthenticationSuccess {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.ProcessStateChanged Event

Grid Solutions Framework ClientHelperProcessStateChanged Event
Occurs when the state of a ServiceProcess is changed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ObjectState<ServiceProcessState>>> ProcessStateChanged
Public Event ProcessStateChanged As EventHandler(Of EventArgs(Of ObjectState(Of ServiceProcessState)))
member ProcessStateChanged : IEvent<EventHandler<EventArgs<ObjectState<ServiceProcessState>>>,
    EventArgs<ObjectState<ServiceProcessState>>>

function add_ProcessStateChanged(value);
function remove_ProcessStateChanged(value);
public:
 event EventHandler<EventArgs<ObjectState<ServiceProcessState>^>^>^ ProcessStateChanged {
    void add (EventHandler<EventArgs<ObjectState<ServiceProcessState>^>^>^ value);
    void remove (EventHandler<EventArgs<ObjectState<ServiceProcessState>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ObjectState ServiceProcessState
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.ReceivedServiceResponse Event

Grid Solutions Framework ClientHelperReceivedServiceResponse Event
Occurs when a custom ServiceResponse is received from the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ServiceResponse>> ReceivedServiceResponse
Public Event ReceivedServiceResponse As EventHandler(Of EventArgs(Of ServiceResponse))
member ReceivedServiceResponse : IEvent<EventHandler<EventArgs<ServiceResponse>>,
    EventArgs<ServiceResponse>>

function add_ReceivedServiceResponse(value);
function remove_ReceivedServiceResponse(value);
public:
 event EventHandler<EventArgs<ServiceResponse^>^>^ ReceivedServiceResponse {
    void add (EventHandler<EventArgs<ServiceResponse^>^>^ value);
    void remove (EventHandler<EventArgs<ServiceResponse^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ServiceResponse
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.ReceivedServiceUpdate Event

Grid Solutions Framework ClientHelperReceivedServiceUpdate Event
Occurs when a status update is received from the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<UpdateType, string>> ReceivedServiceUpdate
Public Event ReceivedServiceUpdate As EventHandler(Of EventArgs(Of UpdateType, String))
member ReceivedServiceUpdate : IEvent<EventHandler<EventArgs<UpdateType, string>>,
    EventArgs<UpdateType, string>>

function add_ReceivedServiceUpdate(value);
function remove_ReceivedServiceUpdate(value);
public:
 event EventHandler<EventArgs<UpdateType, String^>^>^ ReceivedServiceUpdate {
    void add (EventHandler<EventArgs<UpdateType, String^>^>^ value);
    void remove (EventHandler<EventArgs<UpdateType, String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs UpdateType, String
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.ServiceStateChanged Event

Grid Solutions Framework ClientHelperServiceStateChanged Event
Occurs when the state of the ServiceHelper is changed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ObjectState<ServiceState>>> ServiceStateChanged
Public Event ServiceStateChanged As EventHandler(Of EventArgs(Of ObjectState(Of ServiceState)))
member ServiceStateChanged : IEvent<EventHandler<EventArgs<ObjectState<ServiceState>>>,
    EventArgs<ObjectState<ServiceState>>>

function add_ServiceStateChanged(value);
function remove_ServiceStateChanged(value);
public:
 event EventHandler<EventArgs<ObjectState<ServiceState>^>^>^ ServiceStateChanged {
    void add (EventHandler<EventArgs<ObjectState<ServiceState>^>^>^ value);
    void remove (EventHandler<EventArgs<ObjectState<ServiceState>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ObjectState ServiceState
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.TelnetSessionEstablished Event

Grid Solutions Framework ClientHelperTelnetSessionEstablished Event
Occurs when a telnet session has been established.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler TelnetSessionEstablished
Public Event TelnetSessionEstablished As EventHandler
member TelnetSessionEstablished : IEvent<EventHandler,
    EventArgs>

function add_TelnetSessionEstablished(value);
function remove_TelnetSessionEstablished(value);
public:
 event EventHandler^ TelnetSessionEstablished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientHelper.TelnetSessionTerminated Event

Grid Solutions Framework ClientHelperTelnetSessionTerminated Event
Occurs when a telnet session has been terminated.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler TelnetSessionTerminated
Public Event TelnetSessionTerminated As EventHandler
member TelnetSessionTerminated : IEvent<EventHandler,
    EventArgs>

function add_TelnetSessionTerminated(value);
function remove_TelnetSessionTerminated(value);
public:
 event EventHandler^ TelnetSessionTerminated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ClientHelper Class
GSF.ServiceProcess Namespace


ClientInfo Class

Grid Solutions Framework ClientInfo Class
Represents information about a client using ClientHelper for connecting to a Windows Service that uses ServiceHelper.
Inheritance Hierarchy
SystemObject
GSF.ServiceProcessClientInfo

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ClientInfo : ISerializable
<SerializableAttribute>
Public Class ClientInfo
    Implements ISerializable
[<SerializableAttribute>]
type ClientInfo =
    class
        interface ISerializable
    end
GSF.ServiceProcess.ClientInfo = function();

Type.createClass(
    'GSF.ServiceProcess.ClientInfo',
    null,
    ISerializable);
[SerializableAttribute]
public ref class ClientInfo : ISerializable

The ClientInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ClientInfo | Initializes a new instance of the ClientInfo class.
Public method | ClientInfo(ClientHelper) | Initializes a new instance of the ClientInfo class.
Protected method | ClientInfo(SerializationInfo, StreamingContext) | Creates a new ClientInfo from serialization parameters.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ClientID | Gets the identifier of the remote client application.
Public property | ClientName | Gets the friendly name of the remote client application.
Public property | ClientType | Gets the ApplicationType of the remote client application.
Public property | ClientUser | Gets the IPrincipal of the remote client application's user.
Public property | ClientUserCredentials | Gets the credentials in 'username:password' format for authenticating the remote client application's user if a valid ClientUser is not available.
Public property | ConnectedAt | Gets or sets the DateTime when the remote client application connected to the ServiceHelper.
Public property | MachineName | Gets the name of the machine running the remote client application.
Top
Remarks
ClientInfo can be serialized and deserialized using BinaryFormatter only.
See Also

Reference

GSF.ServiceProcess Namespace
GSF.ServiceProcessClientHelper
GSF.ServiceProcessServiceHelper


ClientInfo Constructor

Grid Solutions Framework ClientInfo Constructor
Overload List
 | Name | Description
Public method | ClientInfo | Initializes a new instance of the ClientInfo class.
Public method | ClientInfo(ClientHelper) | Initializes a new instance of the ClientInfo class.
Protected method | ClientInfo(SerializationInfo, StreamingContext) | Creates a new ClientInfo from serialization parameters.
Top
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo Constructor

Grid Solutions Framework ClientInfo Constructor
Initializes a new instance of the ClientInfo class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientInfo()
Public Sub New
new : unit -> ClientInfo
GSF.ServiceProcess.ClientInfo = function();
public:
ClientInfo()
See Also

Reference

ClientInfo Class
ClientInfo Overload
GSF.ServiceProcess Namespace


ClientInfo Constructor (ClientHelper)

Grid Solutions Framework ClientInfo Constructor (ClientHelper)
Initializes a new instance of the ClientInfo class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientInfo(
    ClientHelper parent
)
Public Sub New (
    parent As ClientHelper
)
new :
        parent : ClientHelper -> ClientInfo
GSF.ServiceProcess.ClientInfo = function(parent);
public:
ClientInfo(
    ClientHelper^ parent
)

Parameters

parent
Type: GSF.ServiceProcessClientHelper
An ClientHelper object.
See Also

Reference

ClientInfo Class
ClientInfo Overload
GSF.ServiceProcess Namespace


ClientInfo Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ClientInfo Constructor (SerializationInfo, StreamingContext)
Creates a new ClientInfo from serialization parameters.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ClientInfo(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ClientInfo
GSF.ServiceProcess.ClientInfo = function(info, context);
protected:
ClientInfo(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ClientInfo Class
ClientInfo Overload
GSF.ServiceProcess Namespace


ClientInfo Methods

Grid Solutions Framework ClientInfo Methods

The ClientInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.GetObjectData Method

Grid Solutions Framework ClientInfoGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo Properties

Grid Solutions Framework ClientInfo Properties

The ClientInfo type exposes the following members.

Properties
 | Name | Description
Public property | ClientID | Gets the identifier of the remote client application.
Public property | ClientName | Gets the friendly name of the remote client application.
Public property | ClientType | Gets the ApplicationType of the remote client application.
Public property | ClientUser | Gets the IPrincipal of the remote client application's user.
Public property | ClientUserCredentials | Gets the credentials in 'username:password' format for authenticating the remote client application's user if a valid ClientUser is not available.
Public property | ConnectedAt | Gets or sets the DateTime when the remote client application connected to the ServiceHelper.
Public property | MachineName | Gets the name of the machine running the remote client application.
Top
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.ClientID Property

Grid Solutions Framework ClientInfoClientID Property
Gets the identifier of the remote client application.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid ClientID { get; set; }
Public Property ClientID As Guid
    Get
    Set
member ClientID : Guid with get, set

function get_ClientID();
function set_ClientID(value);
public:
property Guid ClientID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.ClientName Property

Grid Solutions Framework ClientInfoClientName Property
Gets the friendly name of the remote client application.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ClientName { get; }
Public ReadOnly Property ClientName As String
    Get
member ClientName : string with get

function get_ClientName();

public:
property String^ ClientName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.ClientType Property

Grid Solutions Framework ClientInfoClientType Property
Gets the ApplicationType of the remote client application.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ApplicationType ClientType { get; }
Public ReadOnly Property ClientType As ApplicationType
    Get
member ClientType : ApplicationType with get

function get_ClientType();

public:
property ApplicationType ClientType {
    ApplicationType get ();
}

Property Value

Type: ApplicationType
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.ClientUser Property

Grid Solutions Framework ClientInfoClientUser Property
Gets the IPrincipal of the remote client application's user.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IPrincipal ClientUser { get; }
Public ReadOnly Property ClientUser As IPrincipal
    Get
member ClientUser : IPrincipal with get

function get_ClientUser();

public:
property IPrincipal^ ClientUser {
    IPrincipal^ get ();
}

Property Value

Type: IPrincipal
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.ClientUserCredentials Property

Grid Solutions Framework ClientInfoClientUserCredentials Property
Gets the credentials in 'username:password' format for authenticating the remote client application's user if a valid ClientUser is not available.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ClientUserCredentials { get; }
Public ReadOnly Property ClientUserCredentials As String
    Get
member ClientUserCredentials : string with get

function get_ClientUserCredentials();

public:
property String^ ClientUserCredentials {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.ConnectedAt Property

Grid Solutions Framework ClientInfoConnectedAt Property
Gets or sets the DateTime when the remote client application connected to the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ConnectedAt { get; set; }
Public Property ConnectedAt As DateTime
    Get
    Set
member ConnectedAt : DateTime with get, set

function get_ConnectedAt();
function set_ConnectedAt(value);
public:
property DateTime ConnectedAt {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientInfo.MachineName Property

Grid Solutions Framework ClientInfoMachineName Property
Gets the name of the machine running the remote client application.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string MachineName { get; }
Public ReadOnly Property MachineName As String
    Get
member MachineName : string with get

function get_MachineName();

public:
property String^ MachineName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ClientInfo Class
GSF.ServiceProcess Namespace


ClientRequest Class

Grid Solutions Framework ClientRequest Class
Represents a request sent by ClientHelper to ServiceHelper.
Inheritance Hierarchy
SystemObject
GSF.ServiceProcessClientRequest

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ClientRequest : ISerializable
<SerializableAttribute>
Public Class ClientRequest
    Implements ISerializable
[<SerializableAttribute>]
type ClientRequest =
    class
        interface ISerializable
    end
GSF.ServiceProcess.ClientRequest = function();

Type.createClass(
    'GSF.ServiceProcess.ClientRequest',
    null,
    ISerializable);
[SerializableAttribute]
public ref class ClientRequest : ISerializable

The ClientRequest type exposes the following members.

Constructors
 | Name | Description
Public method | ClientRequest | Initializes a new instance of the ClientRequest class.
Public method | ClientRequest(String) | Initializes a new instance of the ClientRequest class.
Protected method | ClientRequest(SerializationInfo, StreamingContext) | Creates a new ClientRequest from serialization parameters.
Public method | ClientRequest(String, Arguments) | Initializes a new instance of the ClientRequest class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts String to a ClientRequest.
Public method | ToString | Returns the String that represents the ClientRequest. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the Arguments for the Command.
Public property | Attachments | Gets a list of attachments for the ClientRequest.
Public property | Command | Gets or sets the command text for the ClientRequest.
Top
See Also

Reference

GSF.ServiceProcess Namespace
GSF.ServiceProcessClientHelper
GSF.ServiceProcessServiceHelper


ClientRequest Constructor

Grid Solutions Framework ClientRequest Constructor
Overload List
 | Name | Description
Public method | ClientRequest | Initializes a new instance of the ClientRequest class.
Public method | ClientRequest(String) | Initializes a new instance of the ClientRequest class.
Protected method | ClientRequest(SerializationInfo, StreamingContext) | Creates a new ClientRequest from serialization parameters.
Public method | ClientRequest(String, Arguments) | Initializes a new instance of the ClientRequest class.
Top
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest Constructor

Grid Solutions Framework ClientRequest Constructor
Initializes a new instance of the ClientRequest class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequest()
Public Sub New
new : unit -> ClientRequest
GSF.ServiceProcess.ClientRequest = function();
public:
ClientRequest()
See Also

Reference

ClientRequest Class
ClientRequest Overload
GSF.ServiceProcess Namespace


ClientRequest Constructor (String)

Grid Solutions Framework ClientRequest Constructor (String)
Initializes a new instance of the ClientRequest class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequest(
    string command
)
Public Sub New (
    command As String
)
new :
        command : string -> ClientRequest
GSF.ServiceProcess.ClientRequest = function(command);
public:
ClientRequest(
    String^ command
)

Parameters

command
Type: SystemString
Command text for the ClientRequest.
See Also

Reference

ClientRequest Class
ClientRequest Overload
GSF.ServiceProcess Namespace


ClientRequest Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ClientRequest Constructor (SerializationInfo, StreamingContext)
Creates a new ClientRequest from serialization parameters.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ClientRequest(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ClientRequest
GSF.ServiceProcess.ClientRequest = function(info, context);
protected:
ClientRequest(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ClientRequest Class
ClientRequest Overload
GSF.ServiceProcess Namespace


ClientRequest Constructor (String, Arguments)

Grid Solutions Framework ClientRequest Constructor (String, Arguments)
Initializes a new instance of the ClientRequest class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequest(
    string command,
    Arguments arguments
)
Public Sub New (
    command As String,
    arguments As Arguments
)
new :
        command : string *
        arguments : Arguments -> ClientRequest
GSF.ServiceProcess.ClientRequest = function(command, arguments);
public:
ClientRequest(
    String^ command,
    Arguments^ arguments
)

Parameters

command
Type: SystemString
Command text for the ClientRequest.
arguments
Type: GSF.ConsoleArguments
Arguments for the command.
See Also

Reference

ClientRequest Class
ClientRequest Overload
GSF.ServiceProcess Namespace


ClientRequest Methods

Grid Solutions Framework ClientRequest Methods

The ClientRequest type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts String to a ClientRequest.
Public method | ToString | Returns the String that represents the ClientRequest. (Overrides ObjectToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest.GetObjectData Method

Grid Solutions Framework ClientRequestGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest.Parse Method

Grid Solutions Framework ClientRequestParse Method
Converts String to a ClientRequest.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ClientRequest Parse(
    string text
)
Public Shared Function Parse (
    text As String
) As ClientRequest
static member Parse :
        text : string -> ClientRequest

GSF.ServiceProcess.ClientRequest.Parse = function(text);
public:
static ClientRequest^ Parse(
    String^ text
)

Parameters

text
Type: SystemString
Text to be converted to a ClientRequest.

Return Value

Type: ClientRequest
ClientRequest object if parsing is successful; otherwise null.
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest.ToString Method

Grid Solutions Framework ClientRequestToString Method
Returns the String that represents the ClientRequest.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the ClientRequest.
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest Properties

Grid Solutions Framework ClientRequest Properties

The ClientRequest type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the Arguments for the Command.
Public property | Attachments | Gets a list of attachments for the ClientRequest.
Public property | Command | Gets or sets the command text for the ClientRequest.
Top
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest.Arguments Property

Grid Solutions Framework ClientRequestArguments Property
Gets or sets the Arguments for the Command.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Arguments Arguments { get; set; }
Public Property Arguments As Arguments
    Get
    Set
member Arguments : Arguments with get, set

function get_Arguments();
function set_Arguments(value);
public:
property Arguments^ Arguments {
    Arguments^ get ();
    void set (Arguments^ value);
}

Property Value

Type: Arguments
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest.Attachments Property

Grid Solutions Framework ClientRequestAttachments Property
Gets a list of attachments for the ClientRequest.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<Object> Attachments { get; }
Public ReadOnly Property Attachments As List(Of Object)
    Get
member Attachments : List<Object> with get

function get_Attachments();

public:
property List<Object^>^ Attachments {
    List<Object^>^ get ();
}

Property Value

Type: List Object
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequest.Command Property

Grid Solutions Framework ClientRequestCommand Property
Gets or sets the command text for the ClientRequest.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Command { get; set; }
Public Property Command As String
    Get
    Set
member Command : string with get, set

function get_Command();
function set_Command(value);
public:
property String^ Command {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is either a null or empty string.
See Also

Reference

ClientRequest Class
GSF.ServiceProcess Namespace


ClientRequestHandler Class

Grid Solutions Framework ClientRequestHandler Class
Represents a handler for ClientRequests sent by ClientHelper.
Inheritance Hierarchy
SystemObject
GSF.ServiceProcessClientRequestHandler

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ClientRequestHandler
Public Class ClientRequestHandler
type ClientRequestHandler =  class end
GSF.ServiceProcess.ClientRequestHandler = function();

Type.createClass(
    'GSF.ServiceProcess.ClientRequestHandler');
public ref class ClientRequestHandler

The ClientRequestHandler type exposes the following members.

Constructors
 | Name | Description
Public method | ClientRequestHandler(String, String, ActionClientRequestInfo, String) | Initializes a new instance of the ClientRequestHandler class.
Public method | ClientRequestHandler(String, String, ActionClientRequestInfo, Boolean, String) | Initializes a new instance of the ClientRequestHandler class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Aliases | Gets any aliases for the command.
Public property | Command | Gets the command text that the ClientRequestHandler will process.
Public property | CommandDescription | Gets the description of the ClientRequestHandler.
Public property | HandlerMethod | Gets the Delegate method that gets invoked for processing the Command.
Public property | IsAdvertised | Gets a boolean value that indicates whether the ClientRequestHandler will be published by the ServiceHelper.
Top
See Also

Reference

GSF.ServiceProcess Namespace
GSF.ServiceProcessClientHelper
GSF.ServiceProcessClientRequest
GSF.ServiceProcessServiceHelper


ClientRequestHandler Constructor

Grid Solutions Framework ClientRequestHandler Constructor
Overload List
 | Name | Description
Public method | ClientRequestHandler(String, String, ActionClientRequestInfo, String) | Initializes a new instance of the ClientRequestHandler class.
Public method | ClientRequestHandler(String, String, ActionClientRequestInfo, Boolean, String) | Initializes a new instance of the ClientRequestHandler class.
Top
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestHandler Constructor (String, String, Action(ClientRequestInfo), String[])

Grid Solutions Framework ClientRequestHandler Constructor (String, String, ActionClientRequestInfo, String)
Initializes a new instance of the ClientRequestHandler class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequestHandler(
    string requestCommand,
    string requestDescription,
    Action<ClientRequestInfo> handlerMethod,
    string[] aliases = null
)
Public Sub New (
    requestCommand As String,
    requestDescription As String,
    handlerMethod As Action(Of ClientRequestInfo),
    Optional aliases As String() = Nothing
)
new :
        requestCommand : string *
        requestDescription : string *
        handlerMethod : Action<ClientRequestInfo> *
        ?aliases : string[]
(* Defaults:
        let _aliases = defaultArg aliases null
*)
-> ClientRequestHandler
GSF.ServiceProcess.ClientRequestHandler = function(requestCommand, requestDescription, handlerMethod, aliases);
public:
ClientRequestHandler(
    String^ requestCommand,
    String^ requestDescription,
    Action<ClientRequestInfo^>^ handlerMethod,
    array<String^>^ aliases = nullptr
)

Parameters

requestCommand
Type: SystemString
Command text that the ClientRequestHandler will process.
requestDescription
Type: SystemString
Description of the ClientRequestHandler.
handlerMethod
Type: SystemAction ClientRequestInfo
Delegate method that will be invoked for processing the requestCommand.
aliases (Optional)
Type: SystemString
Optional alias names to command.
See Also

Reference

ClientRequestHandler Class
ClientRequestHandler Overload
GSF.ServiceProcess Namespace


ClientRequestHandler Constructor (String, String, Action(ClientRequestInfo), Boolean, String[])

Grid Solutions Framework ClientRequestHandler Constructor (String, String, ActionClientRequestInfo, Boolean, String)
Initializes a new instance of the ClientRequestHandler class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequestHandler(
    string requestCommand,
    string requestDescription,
    Action<ClientRequestInfo> handlerMethod,
    bool isAdvertised,
    string[] aliases = null
)
Public Sub New (
    requestCommand As String,
    requestDescription As String,
    handlerMethod As Action(Of ClientRequestInfo),
    isAdvertised As Boolean,
    Optional aliases As String() = Nothing
)
new :
        requestCommand : string *
        requestDescription : string *
        handlerMethod : Action<ClientRequestInfo> *
        isAdvertised : bool *
        ?aliases : string[]
(* Defaults:
        let _aliases = defaultArg aliases null
*)
-> ClientRequestHandler
GSF.ServiceProcess.ClientRequestHandler = function(requestCommand, requestDescription, handlerMethod, isAdvertised, aliases);
public:
ClientRequestHandler(
    String^ requestCommand,
    String^ requestDescription,
    Action<ClientRequestInfo^>^ handlerMethod,
    bool isAdvertised,
    array<String^>^ aliases = nullptr
)

Parameters

requestCommand
Type: SystemString
Command text that the ClientRequestHandler will process.
requestDescription
Type: SystemString
Description of the ClientRequestHandler.
handlerMethod
Type: SystemAction ClientRequestInfo
Delegate method that will be invoked for processing the requestCommand.
isAdvertised
Type: SystemBoolean
true if the ClientRequestHandler is to be published by the ServiceHelper; otherwise false.
aliases (Optional)
Type: SystemString
Optional alias names to command.
See Also

Reference

ClientRequestHandler Class
ClientRequestHandler Overload
GSF.ServiceProcess Namespace


ClientRequestHandler Methods

Grid Solutions Framework ClientRequestHandler Methods

The ClientRequestHandler type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestHandler Properties

Grid Solutions Framework ClientRequestHandler Properties

The ClientRequestHandler type exposes the following members.

Properties
 | Name | Description
Public property | Aliases | Gets any aliases for the command.
Public property | Command | Gets the command text that the ClientRequestHandler will process.
Public property | CommandDescription | Gets the description of the ClientRequestHandler.
Public property | HandlerMethod | Gets the Delegate method that gets invoked for processing the Command.
Public property | IsAdvertised | Gets a boolean value that indicates whether the ClientRequestHandler will be published by the ServiceHelper.
Top
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestHandler.Aliases Property

Grid Solutions Framework ClientRequestHandlerAliases Property
Gets any aliases for the command.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] Aliases { get; }
Public ReadOnly Property Aliases As String()
    Get
member Aliases : string[] with get

function get_Aliases();

public:
property array<String^>^ Aliases {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestHandler.Command Property

Grid Solutions Framework ClientRequestHandlerCommand Property
Gets the command text that the ClientRequestHandler will process.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Command { get; }
Public ReadOnly Property Command As String
    Get
member Command : string with get

function get_Command();

public:
property String^ Command {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestHandler.CommandDescription Property

Grid Solutions Framework ClientRequestHandlerCommandDescription Property
Gets the description of the ClientRequestHandler.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string CommandDescription { get; }
Public ReadOnly Property CommandDescription As String
    Get
member CommandDescription : string with get

function get_CommandDescription();

public:
property String^ CommandDescription {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestHandler.HandlerMethod Property

Grid Solutions Framework ClientRequestHandlerHandlerMethod Property
Gets the Delegate method that gets invoked for processing the Command.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<ClientRequestInfo> HandlerMethod { get; }
Public ReadOnly Property HandlerMethod As Action(Of ClientRequestInfo)
    Get
member HandlerMethod : Action<ClientRequestInfo> with get

function get_HandlerMethod();

public:
property Action<ClientRequestInfo^>^ HandlerMethod {
    Action<ClientRequestInfo^>^ get ();
}

Property Value

Type: Action ClientRequestInfo
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestHandler.IsAdvertised Property

Grid Solutions Framework ClientRequestHandlerIsAdvertised Property
Gets a boolean value that indicates whether the ClientRequestHandler will be published by the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsAdvertised { get; }
Public ReadOnly Property IsAdvertised As Boolean
    Get
member IsAdvertised : bool with get

function get_IsAdvertised();

public:
property bool IsAdvertised {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ClientRequestHandler Class
GSF.ServiceProcess Namespace


ClientRequestInfo Class

Grid Solutions Framework ClientRequestInfo Class
Represents information about a ClientRequest sent by ClientHelper.
Inheritance Hierarchy
SystemObject
GSF.ServiceProcessClientRequestInfo

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ClientRequestInfo
Public Class ClientRequestInfo
type ClientRequestInfo =  class end
GSF.ServiceProcess.ClientRequestInfo = function();

Type.createClass(
    'GSF.ServiceProcess.ClientRequestInfo');
public ref class ClientRequestInfo

The ClientRequestInfo type exposes the following members.

Constructors
 | Name | Description
Public method | ClientRequestInfo | Initializes a new instance of the ClientRequestInfo class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ReceivedAt | Gets or sets the DateTime when the Request was received from the Sender.
Public property | Request | Gets or sets the ClientRequest object sent by the Sender.
Public property | Sender | Gets or sets the ClientInfo object of the Request sender.
Top
See Also

Reference

GSF.ServiceProcess Namespace
GSF.ServiceProcessClientInfo
GSF.ServiceProcessClientRequest


ClientRequestInfo Constructor

Grid Solutions Framework ClientRequestInfo Constructor
Initializes a new instance of the ClientRequestInfo class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequestInfo(
    ClientInfo sender,
    ClientRequest request
)
Public Sub New (
    sender As ClientInfo,
    request As ClientRequest
)
new :
        sender : ClientInfo *
        request : ClientRequest -> ClientRequestInfo
GSF.ServiceProcess.ClientRequestInfo = function(sender, request);
public:
ClientRequestInfo(
    ClientInfo^ sender,
    ClientRequest^ request
)

Parameters

sender
Type: GSF.ServiceProcessClientInfo
ClientInfo object of the request sender.
request
Type: GSF.ServiceProcessClientRequest
ClientRequest object sent by the sender.
See Also

Reference

ClientRequestInfo Class
GSF.ServiceProcess Namespace


ClientRequestInfo Methods

Grid Solutions Framework ClientRequestInfo Methods

The ClientRequestInfo type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientRequestInfo Class
GSF.ServiceProcess Namespace


ClientRequestInfo Properties

Grid Solutions Framework ClientRequestInfo Properties

The ClientRequestInfo type exposes the following members.

Properties
 | Name | Description
Public property | ReceivedAt | Gets or sets the DateTime when the Request was received from the Sender.
Public property | Request | Gets or sets the ClientRequest object sent by the Sender.
Public property | Sender | Gets or sets the ClientInfo object of the Request sender.
Top
See Also

Reference

ClientRequestInfo Class
GSF.ServiceProcess Namespace


ClientRequestInfo.ReceivedAt Property

Grid Solutions Framework ClientRequestInfoReceivedAt Property
Gets or sets the DateTime when the Request was received from the Sender.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ReceivedAt { get; set; }
Public Property ReceivedAt As DateTime
    Get
    Set
member ReceivedAt : DateTime with get, set

function get_ReceivedAt();
function set_ReceivedAt(value);
public:
property DateTime ReceivedAt {
    DateTime get ();
    void set (DateTime value);
}

Property Value

Type: DateTime
See Also

Reference

ClientRequestInfo Class
GSF.ServiceProcess Namespace


ClientRequestInfo.Request Property

Grid Solutions Framework ClientRequestInfoRequest Property
Gets or sets the ClientRequest object sent by the Sender.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequest Request { get; set; }
Public Property Request As ClientRequest
    Get
    Set
member Request : ClientRequest with get, set

function get_Request();
function set_Request(value);
public:
property ClientRequest^ Request {
    ClientRequest^ get ();
    void set (ClientRequest^ value);
}

Property Value

Type: ClientRequest
See Also

Reference

ClientRequestInfo Class
GSF.ServiceProcess Namespace


ClientRequestInfo.Sender Property

Grid Solutions Framework ClientRequestInfoSender Property
Gets or sets the ClientInfo object of the Request sender.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientInfo Sender { get; set; }
Public Property Sender As ClientInfo
    Get
    Set
member Sender : ClientInfo with get, set

function get_Sender();
function set_Sender(value);
public:
property ClientInfo^ Sender {
    ClientInfo^ get ();
    void set (ClientInfo^ value);
}

Property Value

Type: ClientInfo
See Also

Reference

ClientRequestInfo Class
GSF.ServiceProcess Namespace


ErrorHandlerException Class

Grid Solutions Framework ErrorHandlerException Class
A special exception thrown by error handlers.
Inheritance Hierarchy
SystemObject
SystemException
GSF.ServiceProcessErrorHandlerException

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ErrorHandlerException : Exception
Public Class ErrorHandlerException
    Inherits Exception
type ErrorHandlerException =
    class
        inherit Exception
    end
GSF.ServiceProcess.ErrorHandlerException = function();

Type.createClass(
    'GSF.ServiceProcess.ErrorHandlerException',
    Exception);
public ref class ErrorHandlerException : public Exception

The ErrorHandlerException type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorHandlerException | Creates a new instance of the ErrorHandlerException class.
Public method | ErrorHandlerException(String) | Creates a new instance of the ErrorHandlerException class.
Public method | ErrorHandlerException(String, Exception) | Creates a new instance of the ErrorHandlerException class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

GSF.ServiceProcess Namespace


ErrorHandlerException Constructor

Grid Solutions Framework ErrorHandlerException Constructor
Overload List
 | Name | Description
Public method | ErrorHandlerException | Creates a new instance of the ErrorHandlerException class.
Public method | ErrorHandlerException(String) | Creates a new instance of the ErrorHandlerException class.
Public method | ErrorHandlerException(String, Exception) | Creates a new instance of the ErrorHandlerException class.
Top
See Also

Reference

ErrorHandlerException Class
GSF.ServiceProcess Namespace


ErrorHandlerException Constructor

Grid Solutions Framework ErrorHandlerException Constructor
Creates a new instance of the ErrorHandlerException class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorHandlerException()
Public Sub New
new : unit -> ErrorHandlerException
GSF.ServiceProcess.ErrorHandlerException = function();
public:
ErrorHandlerException()
See Also

Reference

ErrorHandlerException Class
ErrorHandlerException Overload
GSF.ServiceProcess Namespace


ErrorHandlerException Constructor (String)

Grid Solutions Framework ErrorHandlerException Constructor (String)
Creates a new instance of the ErrorHandlerException class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorHandlerException(
    string message
)
Public Sub New (
    message As String
)
new :
        message : string -> ErrorHandlerException
GSF.ServiceProcess.ErrorHandlerException = function(message);
public:
ErrorHandlerException(
    String^ message
)

Parameters

message
Type: SystemString
The message that describes the error.
See Also

Reference

ErrorHandlerException Class
ErrorHandlerException Overload
GSF.ServiceProcess Namespace


ErrorHandlerException Constructor (String, Exception)

Grid Solutions Framework ErrorHandlerException Constructor (String, Exception)
Creates a new instance of the ErrorHandlerException class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorHandlerException(
    string message,
    Exception innerException
)
Public Sub New (
    message As String,
    innerException As Exception
)
new :
        message : string *
        innerException : Exception -> ErrorHandlerException
GSF.ServiceProcess.ErrorHandlerException = function(message, innerException);
public:
ErrorHandlerException(
    String^ message,
    Exception^ innerException
)

Parameters

message
Type: SystemString
The message that describes the error.
innerException
Type: SystemException
The exception that is the cause of the current exception, or a null reference if no inner exception is specified.
See Also

Reference

ErrorHandlerException Class
ErrorHandlerException Overload
GSF.ServiceProcess Namespace


ErrorHandlerException Methods

Grid Solutions Framework ErrorHandlerException Methods

The ErrorHandlerException type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetBaseException | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
Public method | GetType | Gets the runtime type of the current instance. (Inherited from Exception.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ErrorHandlerException Class
GSF.ServiceProcess Namespace


ErrorHandlerException Properties

Grid Solutions Framework ErrorHandlerException Properties

The ErrorHandlerException type exposes the following members.

Properties
 | Name | Description
Public property | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
Public property | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
Public property | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
Public property | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
Public property | Message | Gets a message that describes the current exception. (Inherited from Exception.)
Public property | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
Public property | StackTrace | Gets a string representation of the immediate frames on the call stack. (Inherited from Exception.)
Public property | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
Top
See Also

Reference

ErrorHandlerException Class
GSF.ServiceProcess Namespace


ErrorHandlerException Events

Grid Solutions Framework ErrorHandlerException Events

The ErrorHandlerException type exposes the following members.

Events
 | Name | Description
Protected event | SerializeObjectState | Occurs when an exception is serialized to create an exception state object that contains serialized data about the exception. (Inherited from Exception.)
Top
See Also

Reference

ErrorHandlerException Class
GSF.ServiceProcess Namespace


IServiceMonitor Interface

Grid Solutions Framework IServiceMonitor Interface
Interface for an adapter that monitors the health of a service.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IServiceMonitor : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
Public Interface IServiceMonitor
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
type IServiceMonitor =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.ServiceProcess.IServiceMonitor = function();
GSF.ServiceProcess.IServiceMonitor.createInterface('GSF.ServiceProcess.IServiceMonitor');
public interface class IServiceMonitor : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The IServiceMonitor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | HandleClientMessage | Handles messages sent by a client.
Public method | HandleServiceError | Handles messages received by the service whenever the service encounters an error.
Public method | HandleServiceHeartbeat | Handles notifications from the service that occur on an interval to indicate that the service is still running.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.ServiceProcess Namespace


IServiceMonitor Methods

Grid Solutions Framework IServiceMonitor Methods

The IServiceMonitor type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | HandleClientMessage | Handles messages sent by a client.
Public method | HandleServiceError | Handles messages received by the service whenever the service encounters an error.
Public method | HandleServiceHeartbeat | Handles notifications from the service that occur on an interval to indicate that the service is still running.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

IServiceMonitor Interface
GSF.ServiceProcess Namespace


IServiceMonitor.HandleClientMessage Method

Grid Solutions Framework IServiceMonitorHandleClientMessage Method
Handles messages sent by a client.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void HandleClientMessage(
    string[] args
)
Sub HandleClientMessage (
    args As String()
)
abstract HandleClientMessage :
        args : string[] -> unit

function HandleClientMessage(args);
void HandleClientMessage(
    array<String^>^ args
)

Parameters

args
Type: SystemString
Arguments provided by the client.
See Also

Reference

IServiceMonitor Interface
GSF.ServiceProcess Namespace


IServiceMonitor.HandleServiceError Method

Grid Solutions Framework IServiceMonitorHandleServiceError Method
Handles messages received by the service whenever the service encounters an error.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void HandleServiceError(
    Exception ex
)
Sub HandleServiceError (
    ex As Exception
)
abstract HandleServiceError :
        ex : Exception -> unit

function HandleServiceError(ex);
void HandleServiceError(
    Exception^ ex
)

Parameters

ex
Type: SystemException
The exception received from the service.
See Also

Reference

IServiceMonitor Interface
GSF.ServiceProcess Namespace


IServiceMonitor.HandleServiceHeartbeat Method

Grid Solutions Framework IServiceMonitorHandleServiceHeartbeat Method
Handles notifications from the service that occur on an interval to indicate that the service is still running.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void HandleServiceHeartbeat()
Sub HandleServiceHeartbeat
abstract HandleServiceHeartbeat : unit -> unit

function HandleServiceHeartbeat();
void HandleServiceHeartbeat()
See Also

Reference

IServiceMonitor Interface
GSF.ServiceProcess Namespace


IServiceMonitor Properties

Grid Solutions Framework IServiceMonitor Properties

The IServiceMonitor type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

IServiceMonitor Interface
GSF.ServiceProcess Namespace


IServiceMonitor Events

Grid Solutions Framework IServiceMonitor Events

The IServiceMonitor type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

IServiceMonitor Interface
GSF.ServiceProcess Namespace


RecoverAction Enumeration

Grid Solutions Framework RecoverAction Enumeration
Defines the recover action to be performed upon service failure.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum RecoverAction
Public Enumeration RecoverAction
type RecoverAction
GSF.ServiceProcess.RecoverAction = function();
GSF.ServiceProcess.RecoverAction.createEnum('GSF.ServiceProcess.RecoverAction', false);
public enum class RecoverAction
Members
Member name | Value | Description
None | 0 | No action.
Restart | 1 | Restart the service.
Reboot | 2 | Reboot the computer.
RunCommand | 3 | Run a command.
Remarks
Enum values correspond to Win32 equivalents.
See Also

Reference

GSF.ServiceProcess Namespace


ServiceHelper Class

Grid Solutions Framework ServiceHelper Class
Component that provides added functionality to a Windows Service.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.ServiceProcessServiceHelper

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ServiceHelper))]
public class ServiceHelper : Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings
<ToolboxBitmapAttribute(GetType(ServiceHelper))>
Public Class ServiceHelper
    Inherits Component
    Implements ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus,
    IPersistSettings
[<ToolboxBitmapAttribute(typeof(ServiceHelper))>]
type ServiceHelper =
    class
        inherit Component
        interface ISupportLifecycle
        interface IDisposable
        interface ISupportInitialize
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.ServiceProcess.ServiceHelper = function();

Type.createClass(
    'GSF.ServiceProcess.ServiceHelper',
    Component,
    GSF.ISupportLifecycle,
    IDisposable,
    ISupportInitialize,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[ToolboxBitmapAttribute(typeof(ServiceHelper))]
public ref class ServiceHelper : public Component,
    ISupportLifecycle, IDisposable, ISupportInitialize, IProvideStatus, IPersistSettings

The ServiceHelper type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceHelper | Initializes a new instance of the ServiceHelper class.
Public method | ServiceHelper(IContainer) | Initializes a new instance of the ServiceHelper class.
Top
Methods
 | Name | Description
Public method | AddProcess(ActionString, Object, String) | Adds a new ServiceProcess to the ServiceHelper.
Public method | AddProcess(ActionString, Object, String, Object) | Adds a new ServiceProcess to the ServiceHelper.
Public method | AddScheduledProcess(ActionString, Object, String, String) | Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.
Public method | AddScheduledProcess(ActionString, Object, String, Object, String) | Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.
Public method | BeginInit | Performs necessary operations before the ServiceHelper properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceHelper object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ServiceHelper properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindClientRequestHandler | Returns the ClientRequestHandler object for the specified handlerCommand.
Public method | FindConnectedClient | Returns the ClientInfo object for the specified clientID.
Public method | FindProcess | Returns the ServiceProcess for the specified processName.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ServiceHelper.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.
Public method | LoadSettings(Boolean) | Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.
Public method | LogException | Log exception to ErrorLogger.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnLoggedException | Raises LoggedException event with logged exception.
Public method | OnPause | To be called from the OnPause method of ParentService.
Protected method | OnProcessStateChanged | Raises the ProcessStateChanged event.
Protected method | OnReceivedClientRequest | Raises the ReceivedClientRequest event.
Public method | OnResume | To be called from the OnContinue method of ParentService.
Protected method | OnServicePaused | Raises the ServicePaused event.
Protected method | OnServicePausing | Raises the ServicePausing event.
Protected method | OnServiceResumed | Raises the ServiceResumed event.
Protected method | OnServiceResuming | Raises the ServiceResuming event.
Protected method | OnServiceStarted | Raises the ServiceStarted event.
Protected method | OnServiceStarting | Raises the ServiceStarting event.
Protected method | OnServiceStopped | Raises the ServiceStopped event.
Protected method | OnServiceStopping | Raises the ServiceStopping event.
Public method | OnShutdown | To be called from the OnShutdown method of ParentService.
Public method | OnStart | To be called from the OnStart(String) method of ParentService.
Public method | OnStop | To be called from the OnStop method of ParentService.
Protected method | OnSystemShutdown | Raises the SystemShutdown event.
Protected method | OnUpdatedStatus | Raises the UpdatedStatus event with the updated status message.
Public method | RemoveProcess | Removes an existing ServiceProcess from the ServiceHelper.
Public method | RemoveScheduledProcess | Removes an existing ServiceProcess from the ServiceHelper that is scheduled for automatic execution.
Public method | SaveSettings | Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.
Public method | SaveSettings(Boolean) | Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.
Public method | ScheduleProcess(String, String) | Schedules an existing ServiceProcess for automatic execution.
Public method | ScheduleProcess(String, String, Boolean) | Schedules an existing ServiceProcess for automatic execution.
Public method | SendActionableResponse | Sends an actionable response to client along with an optional formatted message and attachment.
Public method | SendResponse(ServiceResponse) | Sends the specified response to all RemoteClients.
Public method | SendResponse(Guid, ServiceResponse) | Sends the specified response to the specified client only.
Public method | SendResponse(Guid, ServiceResponse, Boolean) | Sends the specified response to the specified client only.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnscheduleProcess | Unschedules an existing ServiceProcess scheduled for automatic execution.
Public method | UpdateStatus(UpdateType, String, Object) | Provides a status update to all RemoteClients.
Public method | UpdateStatus(Guid, UpdateType, String, Object) | Provides a status update to the specified client.
Public method | UpdateStatusAppendLine(UpdateType, String, Object) | Provides a line terminated status update to all RemoteClients.
Public method | UpdateStatusAppendLine(Guid, UpdateType, String, Object) | Provides a line terminated status update to the specified client.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultHealthMonitorInterval | Specifies the default value for the HealthMonitorInterval property.
DefaultLogStatusUpdates | Specifies the default value for the LogStatusUpdates property.
DefaultMaxStatusUpdatesFrequency | Specifies the default value for the MaxStatusUpdatesFrequency property.
DefaultMaxStatusUpdatesLength | Specifies the default value for the MaxStatusUpdatesLength property.
DefaultMonitorServiceHealth | Specifies the default value for the MonitorServiceHealth property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultRequestHistoryLimit | Specifies the default value for the RequestHistoryLimit property.
DefaultSecureRemoteInteractions | Specifies the default value for the SecureRemoteInteractions property.
DefaultSerializationFormat | Specifies the default value for the SerializationFormat property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
DefaultSupportSystemCommands | Specifies the default value for the SupportSystemCommands property.
DefaultSupportTelnetSessions | Specifies the default value for the SupportTelnetSessions property.
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientRequestHandlers | Gets a list of ClientRequestHandler registered for handling requests from RemoteClients.
Public property | ClientRequestHistory | Gets a list of ClientRequestInfo for requests made by RemoteClients.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ServiceHelper is currently enabled.
Public property | ErrorLogger | Gets the ErrorLogger component used for logging errors encountered in the ParentService.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | HealthMonitorInterval | Gets or sets the interval, in seconds, over which to sample the performance monitor for health statistics.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LogStatusUpdates | Gets or sets a boolean value that indicates whether messages sent using UpdateStatus(UpdateType, String, Object) or UpdateStatus(Guid, UpdateType, String, Object) are to be logged to the StatusLog.
Public property | MaxStatusUpdatesFrequency | Gets or sets the maximum number of status update messages that can be issued in a second without getting suppressed from being displayed.
Public property | MaxStatusUpdatesLength | Gets or sets the maximum numbers of characters allowed in update status messages without getting suppressed from being displayed.
Public property | MonitorServiceHealth | Gets or sets a boolean value that indicates whether the health of the ParentService is to be monitored.
Public property | Name | Gets the unique identifier of the ServiceHelper.
Public property | ParentService | Gets or sets the ServiceBase to which the ServiceHelper will provided added functionality.
Public property | PerformanceMonitor | Gets the PerformanceMonitor object used for monitoring the health of the ParentService.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ServiceHelper are to be saved to the config file.
Public property | Processes | Gets a list of ServiceProcess defined in the ServiceHelper.
Public property | ProcessScheduler | Gets the ScheduleManager component used for scheduling defined ServiceProcess.
Public property | RemoteClients | Gets a list of ClientInfo for remote clients connected to the RemotingServer.
Public property | RemotingServer | Gets or sets the ServerBase component used for communicating with RemoteClients.
Public property | RequestHistoryLimit | Gets or sets the maximum number of ClientRequest entries to be maintained in the ClientRequestHistory.
Public property | SecureRemoteInteractions | Gets or sets a boolean value that indicates whether ServiceHelper will secure remote interactions from ClientHelper.
Public property | SerializationFormat | Gets or sets a value that indicates the desired message SerializationFormat for interaction with ClientHelper.
Public property | ServiceComponents | Gets a list of components that implement the ISupportLifecycle interface used by the ParentService.
Public property | SettingsCategory | Gets or sets the category under which the settings of ServiceHelper are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the ServiceHelper.
Public property | StatusLog | Gets the LogFile component used for logging status messages to a text file.
Public property | SupportSystemCommands | Gets or sets a boolean value that indicates whether ServiceHelper commands will have support for system-level access (-system switch).
Public property | SupportTelnetSessions | Gets or sets a boolean value that indicates whether the ServiceHelper will have support for remote telnet-like sessions.
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | LoggedException | Provides notification of when there is an exception logged.
Public event | ProcessStateChanged | Occurs when the state of a defined ServiceProcess changes.
Public event | ReceivedClientRequest | Occurs when a request is received from one of the RemoteClients.
Public event | ServicePaused | Occurs when the ParentService has paused.
Public event | ServicePausing | Occurs when the ParentService is pausing.
Public event | ServiceResumed | Occurs when the ParentService has resumed.
Public event | ServiceResuming | Occurs when the ParentService is resuming.
Public event | ServiceStarted | Occurs when the ParentService has started.
Public event | ServiceStarting | Occurs when the ParentService is starting.
Public event | ServiceStopped | Occurs when the ParentService has stopped.
Public event | ServiceStopping | Occurs when the ParentService is stopping.
Public event | SystemShutdown | Occurs when the system is being shutdown.
Public event | UpdatedStatus | Provides notification of when status messages were sent to consumer(s).
Top
See Also

Reference

GSF.ServiceProcess Namespace
GSF.ServiceProcessServiceProcess
GSF.ServiceProcessServiceResponse
GSF.ServiceProcessClientInfo
GSF.ServiceProcessClientRequest
GSF.ServiceProcessClientRequestHandler


ServiceHelper Constructor

Grid Solutions Framework ServiceHelper Constructor
Overload List
 | Name | Description
Public method | ServiceHelper | Initializes a new instance of the ServiceHelper class.
Public method | ServiceHelper(IContainer) | Initializes a new instance of the ServiceHelper class.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper Constructor

Grid Solutions Framework ServiceHelper Constructor
Initializes a new instance of the ServiceHelper class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceHelper()
Public Sub New
new : unit -> ServiceHelper
GSF.ServiceProcess.ServiceHelper = function();
public:
ServiceHelper()
See Also

Reference

ServiceHelper Class
ServiceHelper Overload
GSF.ServiceProcess Namespace


ServiceHelper Constructor (IContainer)

Grid Solutions Framework ServiceHelper Constructor (IContainer)
Initializes a new instance of the ServiceHelper class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceHelper(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ServiceHelper
GSF.ServiceProcess.ServiceHelper = function(container);
public:
ServiceHelper(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
IContainer object that contains the ServiceHelper.
See Also

Reference

ServiceHelper Class
ServiceHelper Overload
GSF.ServiceProcess Namespace


ServiceHelper Fields

Grid Solutions Framework ServiceHelper Fields

The ServiceHelper type exposes the following members.

Fields
Name | Description
DefaultHealthMonitorInterval | Specifies the default value for the HealthMonitorInterval property.
DefaultLogStatusUpdates | Specifies the default value for the LogStatusUpdates property.
DefaultMaxStatusUpdatesFrequency | Specifies the default value for the MaxStatusUpdatesFrequency property.
DefaultMaxStatusUpdatesLength | Specifies the default value for the MaxStatusUpdatesLength property.
DefaultMonitorServiceHealth | Specifies the default value for the MonitorServiceHealth property.
DefaultPersistSettings | Specifies the default value for the PersistSettings property.
DefaultRequestHistoryLimit | Specifies the default value for the RequestHistoryLimit property.
DefaultSecureRemoteInteractions | Specifies the default value for the SecureRemoteInteractions property.
DefaultSerializationFormat | Specifies the default value for the SerializationFormat property.
DefaultSettingsCategory | Specifies the default value for the SettingsCategory property.
DefaultSupportSystemCommands | Specifies the default value for the SupportSystemCommands property.
DefaultSupportTelnetSessions | Specifies the default value for the SupportTelnetSessions property.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultHealthMonitorInterval Field

Grid Solutions Framework ServiceHelperDefaultHealthMonitorInterval Field
Specifies the default value for the HealthMonitorInterval property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultHealthMonitorInterval
Public Const DefaultHealthMonitorInterval As Double
static val mutable DefaultHealthMonitorInterval: float
var GSF.ServiceProcess.ServiceHelper.DefaultHealthMonitorInterval
public:
literal double DefaultHealthMonitorInterval

Field Value

Type: Double
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultLogStatusUpdates Field

Grid Solutions Framework ServiceHelperDefaultLogStatusUpdates Field
Specifies the default value for the LogStatusUpdates property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogStatusUpdates
Public Const DefaultLogStatusUpdates As Boolean
static val mutable DefaultLogStatusUpdates: bool
var GSF.ServiceProcess.ServiceHelper.DefaultLogStatusUpdates
public:
literal bool DefaultLogStatusUpdates

Field Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultMaxStatusUpdatesFrequency Field

Grid Solutions Framework ServiceHelperDefaultMaxStatusUpdatesFrequency Field
Specifies the default value for the MaxStatusUpdatesFrequency property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxStatusUpdatesFrequency
Public Const DefaultMaxStatusUpdatesFrequency As Integer
static val mutable DefaultMaxStatusUpdatesFrequency: int
var GSF.ServiceProcess.ServiceHelper.DefaultMaxStatusUpdatesFrequency
public:
literal int DefaultMaxStatusUpdatesFrequency

Field Value

Type: Int32
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultMaxStatusUpdatesLength Field

Grid Solutions Framework ServiceHelperDefaultMaxStatusUpdatesLength Field
Specifies the default value for the MaxStatusUpdatesLength property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaxStatusUpdatesLength
Public Const DefaultMaxStatusUpdatesLength As Integer
static val mutable DefaultMaxStatusUpdatesLength: int
var GSF.ServiceProcess.ServiceHelper.DefaultMaxStatusUpdatesLength
public:
literal int DefaultMaxStatusUpdatesLength

Field Value

Type: Int32
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultMonitorServiceHealth Field

Grid Solutions Framework ServiceHelperDefaultMonitorServiceHealth Field
Specifies the default value for the MonitorServiceHealth property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultMonitorServiceHealth
Public Const DefaultMonitorServiceHealth As Boolean
static val mutable DefaultMonitorServiceHealth: bool
var GSF.ServiceProcess.ServiceHelper.DefaultMonitorServiceHealth
public:
literal bool DefaultMonitorServiceHealth

Field Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultPersistSettings Field

Grid Solutions Framework ServiceHelperDefaultPersistSettings Field
Specifies the default value for the PersistSettings property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultPersistSettings
Public Const DefaultPersistSettings As Boolean
static val mutable DefaultPersistSettings: bool
var GSF.ServiceProcess.ServiceHelper.DefaultPersistSettings
public:
literal bool DefaultPersistSettings

Field Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultRequestHistoryLimit Field

Grid Solutions Framework ServiceHelperDefaultRequestHistoryLimit Field
Specifies the default value for the RequestHistoryLimit property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultRequestHistoryLimit
Public Const DefaultRequestHistoryLimit As Integer
static val mutable DefaultRequestHistoryLimit: int
var GSF.ServiceProcess.ServiceHelper.DefaultRequestHistoryLimit
public:
literal int DefaultRequestHistoryLimit

Field Value

Type: Int32
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultSecureRemoteInteractions Field

Grid Solutions Framework ServiceHelperDefaultSecureRemoteInteractions Field
Specifies the default value for the SecureRemoteInteractions property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultSecureRemoteInteractions
Public Const DefaultSecureRemoteInteractions As Boolean
static val mutable DefaultSecureRemoteInteractions: bool
var GSF.ServiceProcess.ServiceHelper.DefaultSecureRemoteInteractions
public:
literal bool DefaultSecureRemoteInteractions

Field Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultSerializationFormat Field

Grid Solutions Framework ServiceHelperDefaultSerializationFormat Field
Specifies the default value for the SerializationFormat property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const SerializationFormat DefaultSerializationFormat
Public Const DefaultSerializationFormat As SerializationFormat
static val mutable DefaultSerializationFormat: SerializationFormat
var GSF.ServiceProcess.ServiceHelper.DefaultSerializationFormat
public:
literal SerializationFormat DefaultSerializationFormat

Field Value

Type: SerializationFormat
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultSettingsCategory Field

Grid Solutions Framework ServiceHelperDefaultSettingsCategory Field
Specifies the default value for the SettingsCategory property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultSettingsCategory
Public Const DefaultSettingsCategory As String
static val mutable DefaultSettingsCategory: string
var GSF.ServiceProcess.ServiceHelper.DefaultSettingsCategory
public:
literal String^ DefaultSettingsCategory

Field Value

Type: String
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultSupportSystemCommands Field

Grid Solutions Framework ServiceHelperDefaultSupportSystemCommands Field
Specifies the default value for the SupportSystemCommands property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultSupportSystemCommands
Public Const DefaultSupportSystemCommands As Boolean
static val mutable DefaultSupportSystemCommands: bool
var GSF.ServiceProcess.ServiceHelper.DefaultSupportSystemCommands
public:
literal bool DefaultSupportSystemCommands

Field Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.DefaultSupportTelnetSessions Field

Grid Solutions Framework ServiceHelperDefaultSupportTelnetSessions Field
Specifies the default value for the SupportTelnetSessions property.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultSupportTelnetSessions
Public Const DefaultSupportTelnetSessions As Boolean
static val mutable DefaultSupportTelnetSessions: bool
var GSF.ServiceProcess.ServiceHelper.DefaultSupportTelnetSessions
public:
literal bool DefaultSupportTelnetSessions

Field Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper Methods

Grid Solutions Framework ServiceHelper Methods

The ServiceHelper type exposes the following members.

Methods
 | Name | Description
Public method | AddProcess(ActionString, Object, String) | Adds a new ServiceProcess to the ServiceHelper.
Public method | AddProcess(ActionString, Object, String, Object) | Adds a new ServiceProcess to the ServiceHelper.
Public method | AddScheduledProcess(ActionString, Object, String, String) | Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.
Public method | AddScheduledProcess(ActionString, Object, String, Object, String) | Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.
Public method | BeginInit | Performs necessary operations before the ServiceHelper properties are initialized.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceHelper object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Public method | EndInit | Performs necessary operations after the ServiceHelper properties are initialized.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindClientRequestHandler | Returns the ClientRequestHandler object for the specified handlerCommand.
Public method | FindConnectedClient | Returns the ClientInfo object for the specified clientID.
Public method | FindProcess | Returns the ServiceProcess for the specified processName.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ServiceHelper.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.
Public method | LoadSettings(Boolean) | Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.
Public method | LogException | Log exception to ErrorLogger.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnLoggedException | Raises LoggedException event with logged exception.
Public method | OnPause | To be called from the OnPause method of ParentService.
Protected method | OnProcessStateChanged | Raises the ProcessStateChanged event.
Protected method | OnReceivedClientRequest | Raises the ReceivedClientRequest event.
Public method | OnResume | To be called from the OnContinue method of ParentService.
Protected method | OnServicePaused | Raises the ServicePaused event.
Protected method | OnServicePausing | Raises the ServicePausing event.
Protected method | OnServiceResumed | Raises the ServiceResumed event.
Protected method | OnServiceResuming | Raises the ServiceResuming event.
Protected method | OnServiceStarted | Raises the ServiceStarted event.
Protected method | OnServiceStarting | Raises the ServiceStarting event.
Protected method | OnServiceStopped | Raises the ServiceStopped event.
Protected method | OnServiceStopping | Raises the ServiceStopping event.
Public method | OnShutdown | To be called from the OnShutdown method of ParentService.
Public method | OnStart | To be called from the OnStart(String) method of ParentService.
Public method | OnStop | To be called from the OnStop method of ParentService.
Protected method | OnSystemShutdown | Raises the SystemShutdown event.
Protected method | OnUpdatedStatus | Raises the UpdatedStatus event with the updated status message.
Public method | RemoveProcess | Removes an existing ServiceProcess from the ServiceHelper.
Public method | RemoveScheduledProcess | Removes an existing ServiceProcess from the ServiceHelper that is scheduled for automatic execution.
Public method | SaveSettings | Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.
Public method | SaveSettings(Boolean) | Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.
Public method | ScheduleProcess(String, String) | Schedules an existing ServiceProcess for automatic execution.
Public method | ScheduleProcess(String, String, Boolean) | Schedules an existing ServiceProcess for automatic execution.
Public method | SendActionableResponse | Sends an actionable response to client along with an optional formatted message and attachment.
Public method | SendResponse(ServiceResponse) | Sends the specified response to all RemoteClients.
Public method | SendResponse(Guid, ServiceResponse) | Sends the specified response to the specified client only.
Public method | SendResponse(Guid, ServiceResponse, Boolean) | Sends the specified response to the specified client only.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | UnscheduleProcess | Unschedules an existing ServiceProcess scheduled for automatic execution.
Public method | UpdateStatus(UpdateType, String, Object) | Provides a status update to all RemoteClients.
Public method | UpdateStatus(Guid, UpdateType, String, Object) | Provides a status update to the specified client.
Public method | UpdateStatusAppendLine(UpdateType, String, Object) | Provides a line terminated status update to all RemoteClients.
Public method | UpdateStatusAppendLine(Guid, UpdateType, String, Object) | Provides a line terminated status update to the specified client.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.AddProcess Method

Grid Solutions Framework ServiceHelperAddProcess Method
Overload List
 | Name | Description
Public method | AddProcess(ActionString, Object, String) | Adds a new ServiceProcess to the ServiceHelper.
Public method | AddProcess(ActionString, Object, String, Object) | Adds a new ServiceProcess to the ServiceHelper.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.AddProcess Method (Action(String, Object[]), String)

Grid Solutions Framework ServiceHelperAddProcess Method (ActionString, Object, String)
Adds a new ServiceProcess to the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddProcess(
    Action<string, Object[]> processExecutionMethod,
    string processName
)
Public Function AddProcess (
    processExecutionMethod As Action(Of String, Object()),
    processName As String
) As Boolean
member AddProcess :
        processExecutionMethod : Action<string, Object[]> *
        processName : string -> bool

function AddProcess(processExecutionMethod, processName);
public:
bool AddProcess(
    Action<String^, array<Object^>^>^ processExecutionMethod,
    String^ processName
)

Parameters

processExecutionMethod
Type: SystemAction String, Object
The Delegate to be invoked the ServiceProcess is started.
processName
Type: SystemString
Name of the ServiceProcess being added.

Return Value

Type: Boolean
true if the ServiceProcess does not already exist and is added, otherwise false.
See Also

Reference

ServiceHelper Class
AddProcess Overload
GSF.ServiceProcess Namespace


ServiceHelper.AddProcess Method (Action(String, Object[]), String, Object[])

Grid Solutions Framework ServiceHelperAddProcess Method (ActionString, Object, String, Object)
Adds a new ServiceProcess to the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddProcess(
    Action<string, Object[]> processExecutionMethod,
    string processName,
    Object[] processArguments
)
Public Function AddProcess (
    processExecutionMethod As Action(Of String, Object()),
    processName As String,
    processArguments As Object()
) As Boolean
member AddProcess :
        processExecutionMethod : Action<string, Object[]> *
        processName : string *
        processArguments : Object[] -> bool

function AddProcess(processExecutionMethod, processName, processArguments);
public:
bool AddProcess(
    Action<String^, array<Object^>^>^ processExecutionMethod,
    String^ processName,
    array<Object^>^ processArguments
)

Parameters

processExecutionMethod
Type: SystemAction String, Object
The Delegate to be invoked the ServiceProcess is started.
processName
Type: SystemString
Name of the ServiceProcess being added.
processArguments
Type: SystemObject
Arguments to be passed in to the processExecutionMethod during execution.

Return Value

Type: Boolean
true if the ServiceProcess does not already exist and is added, otherwise false.
See Also

Reference

ServiceHelper Class
AddProcess Overload
GSF.ServiceProcess Namespace


ServiceHelper.AddScheduledProcess Method

Grid Solutions Framework ServiceHelperAddScheduledProcess Method
Overload List
 | Name | Description
Public method | AddScheduledProcess(ActionString, Object, String, String) | Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.
Public method | AddScheduledProcess(ActionString, Object, String, Object, String) | Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.AddScheduledProcess Method (Action(String, Object[]), String, String)

Grid Solutions Framework ServiceHelperAddScheduledProcess Method (ActionString, Object, String, String)
Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddScheduledProcess(
    Action<string, Object[]> processExecutionMethod,
    string processName,
    string processSchedule
)
Public Function AddScheduledProcess (
    processExecutionMethod As Action(Of String, Object()),
    processName As String,
    processSchedule As String
) As Boolean
member AddScheduledProcess :
        processExecutionMethod : Action<string, Object[]> *
        processName : string *
        processSchedule : string -> bool

function AddScheduledProcess(processExecutionMethod, processName, processSchedule);
public:
bool AddScheduledProcess(
    Action<String^, array<Object^>^>^ processExecutionMethod,
    String^ processName,
    String^ processSchedule
)

Parameters

processExecutionMethod
Type: SystemAction String, Object
The Delegate to be invoked the ServiceProcess is started.
processName
Type: SystemString
Name of the ServiceProcess being added.
processSchedule
Type: SystemString
Schedule for the execution of the ServiceProcess.

Return Value

Type: Boolean
true if the ServiceProcess does not exist already and is added and scheduled, otherwise false.
See Also

Reference

ServiceHelper Class
AddScheduledProcess Overload
GSF.ServiceProcess Namespace


ServiceHelper.AddScheduledProcess Method (Action(String, Object[]), String, Object[], String)

Grid Solutions Framework ServiceHelperAddScheduledProcess Method (ActionString, Object, String, Object, String)
Adds a new ServiceProcess to the ServiceHelper that executes on a schedule.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AddScheduledProcess(
    Action<string, Object[]> processExecutionMethod,
    string processName,
    Object[] processArguments,
    string processSchedule
)
Public Function AddScheduledProcess (
    processExecutionMethod As Action(Of String, Object()),
    processName As String,
    processArguments As Object(),
    processSchedule As String
) As Boolean
member AddScheduledProcess :
        processExecutionMethod : Action<string, Object[]> *
        processName : string *
        processArguments : Object[] *
        processSchedule : string -> bool

function AddScheduledProcess(processExecutionMethod, processName, processArguments, processSchedule);
public:
bool AddScheduledProcess(
    Action<String^, array<Object^>^>^ processExecutionMethod,
    String^ processName,
    array<Object^>^ processArguments,
    String^ processSchedule
)

Parameters

processExecutionMethod
Type: SystemAction String, Object
The Delegate to be invoked the ServiceProcess is started.
processName
Type: SystemString
Name of the ServiceProcess being added.
processArguments
Type: SystemObject
Arguments to be passed in to the processExecutionMethod during execution.
processSchedule
Type: SystemString
Schedule for the execution of the ServiceProcess.

Return Value

Type: Boolean
true if the ServiceProcess does not exist already and is added and scheduled, otherwise false.
See Also

Reference

ServiceHelper Class
AddScheduledProcess Overload
GSF.ServiceProcess Namespace


ServiceHelper.BeginInit Method

Grid Solutions Framework ServiceHelperBeginInit Method
Performs necessary operations before the ServiceHelper properties are initialized.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void BeginInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub BeginInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract BeginInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override BeginInit : unit -> unit
function BeginInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void BeginInit() sealed

Implements

ISupportInitializeBeginInit
Remarks
BeginInit should never be called by user-code directly. This method exists solely for use by the designer if the ServiceHelper is consumed through the designer surface of the IDE.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.Dispose Method

Grid Solutions Framework ServiceHelperDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceHelper object and optionally releases the managed resources. (Overrides ComponentDispose(Boolean).)
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.Dispose Method (Boolean)

Grid Solutions Framework ServiceHelperDispose Method (Boolean)
Releases the unmanaged resources used by the ServiceHelper object and optionally releases the managed resources.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ServiceHelper Class
Dispose Overload
GSF.ServiceProcess Namespace


ServiceHelper.EndInit Method

Grid Solutions Framework ServiceHelperEndInit Method
Performs necessary operations after the ServiceHelper properties are initialized.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public void EndInit()
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Sub EndInit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract EndInit : unit -> unit
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override EndInit : unit -> unit
function EndInit();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual void EndInit() sealed

Implements

ISupportInitializeEndInit
Remarks
EndInit should never be called by user-code directly. This method exists solely for use by the designer if the ServiceHelper is consumed through the designer surface of the IDE.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.FindClientRequestHandler Method

Grid Solutions Framework ServiceHelperFindClientRequestHandler Method
Returns the ClientRequestHandler object for the specified handlerCommand.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientRequestHandler FindClientRequestHandler(
    string handlerCommand
)
Public Function FindClientRequestHandler (
    handlerCommand As String
) As ClientRequestHandler
member FindClientRequestHandler :
        handlerCommand : string -> ClientRequestHandler

function FindClientRequestHandler(handlerCommand);
public:
ClientRequestHandler^ FindClientRequestHandler(
    String^ handlerCommand
)

Parameters

handlerCommand
Type: SystemString
Request type whose ClientRequestHandler object is to be retrieved.

Return Value

Type: ClientRequestHandler
ClientRequestHandler object if found; otherwise null.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.FindConnectedClient Method

Grid Solutions Framework ServiceHelperFindConnectedClient Method
Returns the ClientInfo object for the specified clientID.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientInfo FindConnectedClient(
    Guid clientID
)
Public Function FindConnectedClient (
    clientID As Guid
) As ClientInfo
member FindConnectedClient :
        clientID : Guid -> ClientInfo

function FindConnectedClient(clientID);
public:
ClientInfo^ FindConnectedClient(
    Guid clientID
)

Parameters

clientID
Type: SystemGuid
ID of the client whose ClientInfo object is to be retrieved.

Return Value

Type: ClientInfo
ClientInfo object if found; otherwise null.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.FindProcess Method

Grid Solutions Framework ServiceHelperFindProcess Method
Returns the ServiceProcess for the specified processName.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceProcess FindProcess(
    string processName
)
Public Function FindProcess (
    processName As String
) As ServiceProcess
member FindProcess :
        processName : string -> ServiceProcess

function FindProcess(processName);
public:
ServiceProcess^ FindProcess(
    String^ processName
)

Parameters

processName
Type: SystemString
Name of the ServiceProcess to be retrieved.

Return Value

Type: ServiceProcess
ServiceProcess object if found; otherwise null.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.Initialize Method

Grid Solutions Framework ServiceHelperInitialize Method
Initializes the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
Remarks
Initialize is to be called by user-code directly only if the ServiceHelper object is not consumed through the designer surface of the IDE.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.LoadSettings Method

Grid Solutions Framework ServiceHelperLoadSettings Method
Overload List
 | Name | Description
Public method | LoadSettings | Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.
Public method | LoadSettings(Boolean) | Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.LoadSettings Method

Grid Solutions Framework ServiceHelperLoadSettings Method
Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings()
Public Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() sealed

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ServiceHelper Class
LoadSettings Overload
GSF.ServiceProcess Namespace


ServiceHelper.LoadSettings Method (Boolean)

Grid Solutions Framework ServiceHelperLoadSettings Method (Boolean)
Loads saved settings of the ServiceHelper from the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LoadSettings(
    bool includeServiceComponents
)
Public Sub LoadSettings (
    includeServiceComponents As Boolean
)
member LoadSettings :
        includeServiceComponents : bool -> unit

function LoadSettings(includeServiceComponents);
public:
void LoadSettings(
    bool includeServiceComponents
)

Parameters

includeServiceComponents
Type: SystemBoolean
A boolean value that indicates whether the settings of ServiceComponents are to be loaded.
See Also

Reference

ServiceHelper Class
LoadSettings Overload
GSF.ServiceProcess Namespace


ServiceHelper.LogException Method

Grid Solutions Framework ServiceHelperLogException Method
Log exception to ErrorLogger.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void LogException(
    Exception ex
)
Public Sub LogException (
    ex As Exception
)
member LogException :
        ex : Exception -> unit

function LogException(ex);
public:
void LogException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to log.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnLoggedException Method

Grid Solutions Framework ServiceHelperOnLoggedException Method
Raises LoggedException event with logged exception.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnLoggedException(
    Exception ex
)
Protected Overridable Sub OnLoggedException (
    ex As Exception
)
abstract OnLoggedException :
        ex : Exception -> unit
override OnLoggedException :
        ex : Exception -> unit
function OnLoggedException(ex);
protected:
virtual void OnLoggedException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Logged Exception.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnPause Method

Grid Solutions Framework ServiceHelperOnPause Method
To be called from the OnPause method of ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void OnPause()
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub OnPause
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member OnPause : unit -> unit

function OnPause();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void OnPause()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnProcessStateChanged Method

Grid Solutions Framework ServiceHelperOnProcessStateChanged Method
Raises the ProcessStateChanged event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessStateChanged(
    string processName,
    ServiceProcessState processState
)
Protected Overridable Sub OnProcessStateChanged (
    processName As String,
    processState As ServiceProcessState
)
abstract OnProcessStateChanged :
        processName : string *
        processState : ServiceProcessState -> unit
override OnProcessStateChanged :
        processName : string *
        processState : ServiceProcessState -> unit
function OnProcessStateChanged(processName, processState);
protected:
virtual void OnProcessStateChanged(
    String^ processName,
    ServiceProcessState processState
)

Parameters

processName
Type: SystemString
Name of the ServiceProcess whose state changed.
processState
Type: GSF.ServiceProcessServiceProcessState
New ServiceProcessState of the ServiceProcess.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnReceivedClientRequest Method

Grid Solutions Framework ServiceHelperOnReceivedClientRequest Method
Raises the ReceivedClientRequest event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnReceivedClientRequest(
    ClientRequest request,
    ClientInfo requestSender
)
Protected Overridable Sub OnReceivedClientRequest (
    request As ClientRequest,
    requestSender As ClientInfo
)
abstract OnReceivedClientRequest :
        request : ClientRequest *
        requestSender : ClientInfo -> unit
override OnReceivedClientRequest :
        request : ClientRequest *
        requestSender : ClientInfo -> unit
function OnReceivedClientRequest(request, requestSender);
protected:
virtual void OnReceivedClientRequest(
    ClientRequest^ request,
    ClientInfo^ requestSender
)

Parameters

request
Type: GSF.ServiceProcessClientRequest
The ClientRequest that was received.
requestSender
Type: GSF.ServiceProcessClientInfo
The ClientInfo object of the request sender.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnResume Method

Grid Solutions Framework ServiceHelperOnResume Method
To be called from the OnContinue method of ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void OnResume()
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub OnResume
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member OnResume : unit -> unit

function OnResume();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void OnResume()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServicePaused Method

Grid Solutions Framework ServiceHelperOnServicePaused Method
Raises the ServicePaused event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServicePaused()
Protected Overridable Sub OnServicePaused
abstract OnServicePaused : unit -> unit
override OnServicePaused : unit -> unit
function OnServicePaused();
protected:
virtual void OnServicePaused()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServicePausing Method

Grid Solutions Framework ServiceHelperOnServicePausing Method
Raises the ServicePausing event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServicePausing()
Protected Overridable Sub OnServicePausing
abstract OnServicePausing : unit -> unit
override OnServicePausing : unit -> unit
function OnServicePausing();
protected:
virtual void OnServicePausing()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServiceResumed Method

Grid Solutions Framework ServiceHelperOnServiceResumed Method
Raises the ServiceResumed event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceResumed()
Protected Overridable Sub OnServiceResumed
abstract OnServiceResumed : unit -> unit
override OnServiceResumed : unit -> unit
function OnServiceResumed();
protected:
virtual void OnServiceResumed()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServiceResuming Method

Grid Solutions Framework ServiceHelperOnServiceResuming Method
Raises the ServiceResuming event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceResuming()
Protected Overridable Sub OnServiceResuming
abstract OnServiceResuming : unit -> unit
override OnServiceResuming : unit -> unit
function OnServiceResuming();
protected:
virtual void OnServiceResuming()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServiceStarted Method

Grid Solutions Framework ServiceHelperOnServiceStarted Method
Raises the ServiceStarted event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceStarted()
Protected Overridable Sub OnServiceStarted
abstract OnServiceStarted : unit -> unit
override OnServiceStarted : unit -> unit
function OnServiceStarted();
protected:
virtual void OnServiceStarted()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServiceStarting Method

Grid Solutions Framework ServiceHelperOnServiceStarting Method
Raises the ServiceStarting event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceStarting(
    string[] args
)
Protected Overridable Sub OnServiceStarting (
    args As String()
)
abstract OnServiceStarting :
        args : string[] -> unit
override OnServiceStarting :
        args : string[] -> unit
function OnServiceStarting(args);
protected:
virtual void OnServiceStarting(
    array<String^>^ args
)

Parameters

args
Type: SystemString
Arguments to be sent to ServiceStarting event.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServiceStopped Method

Grid Solutions Framework ServiceHelperOnServiceStopped Method
Raises the ServiceStopped event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceStopped()
Protected Overridable Sub OnServiceStopped
abstract OnServiceStopped : unit -> unit
override OnServiceStopped : unit -> unit
function OnServiceStopped();
protected:
virtual void OnServiceStopped()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnServiceStopping Method

Grid Solutions Framework ServiceHelperOnServiceStopping Method
Raises the ServiceStopping event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnServiceStopping()
Protected Overridable Sub OnServiceStopping
abstract OnServiceStopping : unit -> unit
override OnServiceStopping : unit -> unit
function OnServiceStopping();
protected:
virtual void OnServiceStopping()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnShutdown Method

Grid Solutions Framework ServiceHelperOnShutdown Method
To be called from the OnShutdown method of ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void OnShutdown()
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub OnShutdown
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member OnShutdown : unit -> unit

function OnShutdown();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void OnShutdown()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnStart Method

Grid Solutions Framework ServiceHelperOnStart Method
To be called from the OnStart(String) method of ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void OnStart(
    string[] args
)
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub OnStart (
    args As String()
)
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member OnStart :
        args : string[] -> unit

function OnStart(args);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void OnStart(
    array<String^>^ args
)

Parameters

args
Type: SystemString
Array of type String.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnStop Method

Grid Solutions Framework ServiceHelperOnStop Method
To be called from the OnStop method of ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public void OnStop()
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Sub OnStop
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member OnStop : unit -> unit

function OnStop();
public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
void OnStop()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnSystemShutdown Method

Grid Solutions Framework ServiceHelperOnSystemShutdown Method
Raises the SystemShutdown event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSystemShutdown()
Protected Overridable Sub OnSystemShutdown
abstract OnSystemShutdown : unit -> unit
override OnSystemShutdown : unit -> unit
function OnSystemShutdown();
protected:
virtual void OnSystemShutdown()
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.OnUpdatedStatus Method

Grid Solutions Framework ServiceHelperOnUpdatedStatus Method
Raises the UpdatedStatus event with the updated status message.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUpdatedStatus(
    string status,
    UpdateType type
)
Protected Overridable Sub OnUpdatedStatus (
    status As String,
    type As UpdateType
)
abstract OnUpdatedStatus :
        status : string *
        type : UpdateType -> unit
override OnUpdatedStatus :
        status : string *
        type : UpdateType -> unit
function OnUpdatedStatus(status, type);
protected:
virtual void OnUpdatedStatus(
    String^ status,
    UpdateType type
)

Parameters

status
Type: SystemString
Updated status message.
type
Type: GSFUpdateType
UpdateType of status message.
Remarks
This overload combines string.Format and SendStatusMessage for convenience.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.RemoveProcess Method

Grid Solutions Framework ServiceHelperRemoveProcess Method
Removes an existing ServiceProcess from the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RemoveProcess(
    string processName
)
Public Function RemoveProcess (
    processName As String
) As Boolean
member RemoveProcess :
        processName : string -> bool

function RemoveProcess(processName);
public:
bool RemoveProcess(
    String^ processName
)

Parameters

processName
Type: SystemString
Name of the ServiceProcess to be removed.

Return Value

Type: Boolean
true if the ServiceProcess exists and is removed, otherwise false.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.RemoveScheduledProcess Method

Grid Solutions Framework ServiceHelperRemoveScheduledProcess Method
Removes an existing ServiceProcess from the ServiceHelper that is scheduled for automatic execution.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RemoveScheduledProcess(
    string processName
)
Public Function RemoveScheduledProcess (
    processName As String
) As Boolean
member RemoveScheduledProcess :
        processName : string -> bool

function RemoveScheduledProcess(processName);
public:
bool RemoveScheduledProcess(
    String^ processName
)

Parameters

processName
Type: SystemString
Name of the scheduled ServiceProcess to be removed.

Return Value

Type: Boolean
true is the scheduled ServiceProcess is removed, otherwise false.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SaveSettings Method

Grid Solutions Framework ServiceHelperSaveSettings Method
Overload List
 | Name | Description
Public method | SaveSettings | Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.
Public method | SaveSettings(Boolean) | Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SaveSettings Method

Grid Solutions Framework ServiceHelperSaveSettings Method
Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings()
Public Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() sealed

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ServiceHelper Class
SaveSettings Overload
GSF.ServiceProcess Namespace


ServiceHelper.SaveSettings Method (Boolean)

Grid Solutions Framework ServiceHelperSaveSettings Method (Boolean)
Saves settings of the ServiceHelper to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SaveSettings(
    bool includeServiceComponents
)
Public Sub SaveSettings (
    includeServiceComponents As Boolean
)
member SaveSettings :
        includeServiceComponents : bool -> unit

function SaveSettings(includeServiceComponents);
public:
void SaveSettings(
    bool includeServiceComponents
)

Parameters

includeServiceComponents
Type: SystemBoolean
A boolean value that indicates whether the settings of ServiceComponents are to be saved.
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ServiceHelper Class
SaveSettings Overload
GSF.ServiceProcess Namespace


ServiceHelper.ScheduleProcess Method

Grid Solutions Framework ServiceHelperScheduleProcess Method
Overload List
 | Name | Description
Public method | ScheduleProcess(String, String) | Schedules an existing ServiceProcess for automatic execution.
Public method | ScheduleProcess(String, String, Boolean) | Schedules an existing ServiceProcess for automatic execution.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ScheduleProcess Method (String, String)

Grid Solutions Framework ServiceHelperScheduleProcess Method (String, String)
Schedules an existing ServiceProcess for automatic execution.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ScheduleProcess(
    string processName,
    string scheduleRule
)
Public Function ScheduleProcess (
    processName As String,
    scheduleRule As String
) As Boolean
member ScheduleProcess :
        processName : string *
        scheduleRule : string -> bool

function ScheduleProcess(processName, scheduleRule);
public:
bool ScheduleProcess(
    String^ processName,
    String^ scheduleRule
)

Parameters

processName
Type: SystemString
Name of the ServiceProcess to be scheduled.
scheduleRule
Type: SystemString
Rule that defines the execution pattern of the ServiceProcess.

Return Value

Type: Boolean
true if the ServiceProcess exists and is scheduled, otherwise false.
See Also

Reference

ServiceHelper Class
ScheduleProcess Overload
GSF.ServiceProcess Namespace


ServiceHelper.ScheduleProcess Method (String, String, Boolean)

Grid Solutions Framework ServiceHelperScheduleProcess Method (String, String, Boolean)
Schedules an existing ServiceProcess for automatic execution.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ScheduleProcess(
    string processName,
    string scheduleRule,
    bool updateExistingSchedule
)
Public Function ScheduleProcess (
    processName As String,
    scheduleRule As String,
    updateExistingSchedule As Boolean
) As Boolean
member ScheduleProcess :
        processName : string *
        scheduleRule : string *
        updateExistingSchedule : bool -> bool

function ScheduleProcess(processName, scheduleRule, updateExistingSchedule);
public:
bool ScheduleProcess(
    String^ processName,
    String^ scheduleRule,
    bool updateExistingSchedule
)

Parameters

processName
Type: SystemString
Name of the ServiceProcess to be scheduled.
scheduleRule
Type: SystemString
Rule that defines the execution pattern of the ServiceProcess.
updateExistingSchedule
Type: SystemBoolean
true if the ServiceProcess is to be re-scheduled; otherwise false.

Return Value

Type: Boolean
true if the ServiceProcess exists and is scheduled or re-scheduled, otherwise false.
See Also

Reference

ServiceHelper Class
ScheduleProcess Overload
GSF.ServiceProcess Namespace


ServiceHelper.SendActionableResponse Method

Grid Solutions Framework ServiceHelperSendActionableResponse Method
Sends an actionable response to client along with an optional formatted message and attachment.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendActionableResponse(
    ClientRequestInfo requestInfo,
    bool success,
    Object attachment = null,
    string status = null,
    params Object[] args
)
Public Sub SendActionableResponse (
    requestInfo As ClientRequestInfo,
    success As Boolean,
    Optional attachment As Object = Nothing,
    Optional status As String = Nothing,
    ParamArray args As Object()
)
member SendActionableResponse :
        requestInfo : ClientRequestInfo *
        success : bool *
        ?attachment : Object *
        ?status : string *
        args : Object[]
(* Defaults:
        let _attachment = defaultArg attachment null
        let _status = defaultArg status null
*)
-> unit

function SendActionableResponse(requestInfo, success, attachment, status, ... args);
public:
void SendActionableResponse(
    ClientRequestInfo^ requestInfo,
    bool success,
    Object^ attachment = nullptr,
    String^ status = nullptr,
    ... array<Object^>^ args
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
success
Type: SystemBoolean
Flag that determines if this response to client request was a success.
attachment (Optional)
Type: SystemObject
Attachment to send with response.
status (Optional)
Type: SystemString
Formatted status message to send with response.
args
Type: SystemObject
Arguments of the formatted status message.
Remarks
This method is used to send an actionable client response that can be used for responding to an event after a command has been issued.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SendResponse Method

Grid Solutions Framework ServiceHelperSendResponse Method
Overload List
 | Name | Description
Public method | SendResponse(ServiceResponse) | Sends the specified response to all RemoteClients.
Public method | SendResponse(Guid, ServiceResponse) | Sends the specified response to the specified client only.
Public method | SendResponse(Guid, ServiceResponse, Boolean) | Sends the specified response to the specified client only.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SendResponse Method (ServiceResponse)

Grid Solutions Framework ServiceHelperSendResponse Method (ServiceResponse)
Sends the specified response to all RemoteClients.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendResponse(
    ServiceResponse response
)
Public Sub SendResponse (
    response As ServiceResponse
)
member SendResponse :
        response : ServiceResponse -> unit

function SendResponse(response);
public:
void SendResponse(
    ServiceResponse^ response
)

Parameters

response
Type: GSF.ServiceProcessServiceResponse
The ServiceResponse to be sent to all RemoteClients.
See Also

Reference

ServiceHelper Class
SendResponse Overload
GSF.ServiceProcess Namespace


ServiceHelper.SendResponse Method (Guid, ServiceResponse)

Grid Solutions Framework ServiceHelperSendResponse Method (Guid, ServiceResponse)
Sends the specified response to the specified client only.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendResponse(
    Guid client,
    ServiceResponse response
)
Public Sub SendResponse (
    client As Guid,
    response As ServiceResponse
)
member SendResponse :
        client : Guid *
        response : ServiceResponse -> unit

function SendResponse(client, response);
public:
void SendResponse(
    Guid client,
    ServiceResponse^ response
)

Parameters

client
Type: SystemGuid
ID of the client to whom the response is to be sent.
response
Type: GSF.ServiceProcessServiceResponse
The ServiceResponse to be sent to the client.
See Also

Reference

ServiceHelper Class
SendResponse Overload
GSF.ServiceProcess Namespace


ServiceHelper.SendResponse Method (Guid, ServiceResponse, Boolean)

Grid Solutions Framework ServiceHelperSendResponse Method (Guid, ServiceResponse, Boolean)
Sends the specified response to the specified client only.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SendResponse(
    Guid client,
    ServiceResponse response,
    bool async
)
Public Sub SendResponse (
    client As Guid,
    response As ServiceResponse,
    async As Boolean
)
member SendResponse :
        client : Guid *
        response : ServiceResponse *
        async : bool -> unit

function SendResponse(client, response, async);
public:
void SendResponse(
    Guid client,
    ServiceResponse^ response,
    bool async
)

Parameters

client
Type: SystemGuid
ID of the client to whom the response is to be sent.
response
Type: GSF.ServiceProcessServiceResponse
The ServiceResponse to be sent to the client.
async
Type: SystemBoolean
Flag to determine whether to wait for the send operations to complete.
See Also

Reference

ServiceHelper Class
SendResponse Overload
GSF.ServiceProcess Namespace


ServiceHelper.UnscheduleProcess Method

Grid Solutions Framework ServiceHelperUnscheduleProcess Method
Unschedules an existing ServiceProcess scheduled for automatic execution.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UnscheduleProcess(
    string processName
)
Public Function UnscheduleProcess (
    processName As String
) As Boolean
member UnscheduleProcess :
        processName : string -> bool

function UnscheduleProcess(processName);
public:
bool UnscheduleProcess(
    String^ processName
)

Parameters

processName
Type: SystemString
Name of the ServiceProcess to be unscheduled.

Return Value

Type: Boolean
true if the scheduled ServiceProcess is unscheduled, otherwise false.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.UpdateStatus Method

Grid Solutions Framework ServiceHelperUpdateStatus Method
Overload List
 | Name | Description
Public method | UpdateStatus(UpdateType, String, Object) | Provides a status update to all RemoteClients.
Public method | UpdateStatus(Guid, UpdateType, String, Object) | Provides a status update to the specified client.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.UpdateStatus Method (UpdateType, String, Object[])

Grid Solutions Framework ServiceHelperUpdateStatus Method (UpdateType, String, Object)
Provides a status update to all RemoteClients.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateStatus(
    UpdateType type,
    string message,
    params Object[] args
)
Public Sub UpdateStatus (
    type As UpdateType,
    message As String,
    ParamArray args As Object()
)
member UpdateStatus :
        type : UpdateType *
        message : string *
        args : Object[] -> unit

function UpdateStatus(type, message, ... args);
public:
void UpdateStatus(
    UpdateType type,
    String^ message,
    ... array<Object^>^ args
)

Parameters

type
Type: GSFUpdateType
One of the UpdateType values.
message
Type: SystemString
Text message to be transmitted to all RemoteClients.
args
Type: SystemObject
Arguments to be used for formatting the message.
See Also

Reference

ServiceHelper Class
UpdateStatus Overload
GSF.ServiceProcess Namespace


ServiceHelper.UpdateStatus Method (Guid, UpdateType, String, Object[])

Grid Solutions Framework ServiceHelperUpdateStatus Method (Guid, UpdateType, String, Object)
Provides a status update to the specified client.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateStatus(
    Guid client,
    UpdateType type,
    string message,
    params Object[] args
)
Public Sub UpdateStatus (
    client As Guid,
    type As UpdateType,
    message As String,
    ParamArray args As Object()
)
member UpdateStatus :
        client : Guid *
        type : UpdateType *
        message : string *
        args : Object[] -> unit

function UpdateStatus(client, type, message, ... args);
public:
void UpdateStatus(
    Guid client,
    UpdateType type,
    String^ message,
    ... array<Object^>^ args
)

Parameters

client
Type: SystemGuid
ID of the client to whom the message is to be sent.
type
Type: GSFUpdateType
One of the UpdateType values.
message
Type: SystemString
Text message to be transmitted to the client.
args
Type: SystemObject
Arguments to be used for formatting the message.
See Also

Reference

ServiceHelper Class
UpdateStatus Overload
GSF.ServiceProcess Namespace


ServiceHelper.UpdateStatusAppendLine Method

Grid Solutions Framework ServiceHelperUpdateStatusAppendLine Method
Overload List
 | Name | Description
Public method | UpdateStatusAppendLine(UpdateType, String, Object) | Provides a line terminated status update to all RemoteClients.
Public method | UpdateStatusAppendLine(Guid, UpdateType, String, Object) | Provides a line terminated status update to the specified client.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.UpdateStatusAppendLine Method (UpdateType, String, Object[])

Grid Solutions Framework ServiceHelperUpdateStatusAppendLine Method (UpdateType, String, Object)
Provides a line terminated status update to all RemoteClients.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateStatusAppendLine(
    UpdateType type,
    string message,
    params Object[] args
)
Public Sub UpdateStatusAppendLine (
    type As UpdateType,
    message As String,
    ParamArray args As Object()
)
member UpdateStatusAppendLine :
        type : UpdateType *
        message : string *
        args : Object[] -> unit

function UpdateStatusAppendLine(type, message, ... args);
public:
void UpdateStatusAppendLine(
    UpdateType type,
    String^ message,
    ... array<Object^>^ args
)

Parameters

type
Type: GSFUpdateType
One of the UpdateType values.
message
Type: SystemString
Text message to be transmitted to all RemoteClients.
args
Type: SystemObject
Arguments to be used for formatting the message.
See Also

Reference

ServiceHelper Class
UpdateStatusAppendLine Overload
GSF.ServiceProcess Namespace


ServiceHelper.UpdateStatusAppendLine Method (Guid, UpdateType, String, Object[])

Grid Solutions Framework ServiceHelperUpdateStatusAppendLine Method (Guid, UpdateType, String, Object)
Provides a line terminated status update to the specified client.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateStatusAppendLine(
    Guid client,
    UpdateType type,
    string message,
    params Object[] args
)
Public Sub UpdateStatusAppendLine (
    client As Guid,
    type As UpdateType,
    message As String,
    ParamArray args As Object()
)
member UpdateStatusAppendLine :
        client : Guid *
        type : UpdateType *
        message : string *
        args : Object[] -> unit

function UpdateStatusAppendLine(client, type, message, ... args);
public:
void UpdateStatusAppendLine(
    Guid client,
    UpdateType type,
    String^ message,
    ... array<Object^>^ args
)

Parameters

client
Type: SystemGuid
ID of the client to whom the message is to be sent.
type
Type: GSFUpdateType
One of the UpdateType values.
message
Type: SystemString
Text message to be transmitted to the client.
args
Type: SystemObject
Arguments to be used for formatting the message.
See Also

Reference

ServiceHelper Class
UpdateStatusAppendLine Overload
GSF.ServiceProcess Namespace


ServiceHelper Properties

Grid Solutions Framework ServiceHelper Properties

The ServiceHelper type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ClientRequestHandlers | Gets a list of ClientRequestHandler registered for handling requests from RemoteClients.
Public property | ClientRequestHistory | Gets a list of ClientRequestInfo for requests made by RemoteClients.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ServiceHelper is currently enabled.
Public property | ErrorLogger | Gets the ErrorLogger component used for logging errors encountered in the ParentService.
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | HealthMonitorInterval | Gets or sets the interval, in seconds, over which to sample the performance monitor for health statistics.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LogStatusUpdates | Gets or sets a boolean value that indicates whether messages sent using UpdateStatus(UpdateType, String, Object) or UpdateStatus(Guid, UpdateType, String, Object) are to be logged to the StatusLog.
Public property | MaxStatusUpdatesFrequency | Gets or sets the maximum number of status update messages that can be issued in a second without getting suppressed from being displayed.
Public property | MaxStatusUpdatesLength | Gets or sets the maximum numbers of characters allowed in update status messages without getting suppressed from being displayed.
Public property | MonitorServiceHealth | Gets or sets a boolean value that indicates whether the health of the ParentService is to be monitored.
Public property | Name | Gets the unique identifier of the ServiceHelper.
Public property | ParentService | Gets or sets the ServiceBase to which the ServiceHelper will provided added functionality.
Public property | PerformanceMonitor | Gets the PerformanceMonitor object used for monitoring the health of the ParentService.
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ServiceHelper are to be saved to the config file.
Public property | Processes | Gets a list of ServiceProcess defined in the ServiceHelper.
Public property | ProcessScheduler | Gets the ScheduleManager component used for scheduling defined ServiceProcess.
Public property | RemoteClients | Gets a list of ClientInfo for remote clients connected to the RemotingServer.
Public property | RemotingServer | Gets or sets the ServerBase component used for communicating with RemoteClients.
Public property | RequestHistoryLimit | Gets or sets the maximum number of ClientRequest entries to be maintained in the ClientRequestHistory.
Public property | SecureRemoteInteractions | Gets or sets a boolean value that indicates whether ServiceHelper will secure remote interactions from ClientHelper.
Public property | SerializationFormat | Gets or sets a value that indicates the desired message SerializationFormat for interaction with ClientHelper.
Public property | ServiceComponents | Gets a list of components that implement the ISupportLifecycle interface used by the ParentService.
Public property | SettingsCategory | Gets or sets the category under which the settings of ServiceHelper are to be saved to the config file if the PersistSettings property is set to true.
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | Status | Gets the descriptive status of the ServiceHelper.
Public property | StatusLog | Gets the LogFile component used for logging status messages to a text file.
Public property | SupportSystemCommands | Gets or sets a boolean value that indicates whether ServiceHelper commands will have support for system-level access (-system switch).
Public property | SupportTelnetSessions | Gets or sets a boolean value that indicates whether the ServiceHelper will have support for remote telnet-like sessions.
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ClientRequestHandlers Property

Grid Solutions Framework ServiceHelperClientRequestHandlers Property
Gets a list of ClientRequestHandler registered for handling requests from RemoteClients.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public IList<ClientRequestHandler> ClientRequestHandlers { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(false)>
Public ReadOnly Property ClientRequestHandlers As IList(Of ClientRequestHandler)
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
[<BrowsableAttribute(false)>]
member ClientRequestHandlers : IList<ClientRequestHandler> with get

function get_ClientRequestHandlers();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
[BrowsableAttribute(false)]
property IList<ClientRequestHandler^>^ ClientRequestHandlers {
    IList<ClientRequestHandler^>^ get ();
}

Property Value

Type: IList ClientRequestHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ClientRequestHistory Property

Grid Solutions Framework ServiceHelperClientRequestHistory Property
Gets a list of ClientRequestInfo for requests made by RemoteClients.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public IList<ClientRequestInfo> ClientRequestHistory { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(false)>
Public ReadOnly Property ClientRequestHistory As IList(Of ClientRequestInfo)
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
[<BrowsableAttribute(false)>]
member ClientRequestHistory : IList<ClientRequestInfo> with get

function get_ClientRequestHistory();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
[BrowsableAttribute(false)]
property IList<ClientRequestInfo^>^ ClientRequestHistory {
    IList<ClientRequestInfo^>^ get ();
}

Property Value

Type: IList ClientRequestInfo
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.Enabled Property

Grid Solutions Framework ServiceHelperEnabled Property
Gets or sets a boolean value that indicates whether the ServiceHelper is currently enabled.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool Enabled { get; set; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<BrowsableAttribute(false)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Property Enabled As Boolean
    Get
    Set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract Enabled : bool with get, set
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Enabled property is not be set by user-code directly.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ErrorLogger Property

Grid Solutions Framework ServiceHelperErrorLogger Property
Gets the ErrorLogger component used for logging errors encountered in the ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ErrorLogger ErrorLogger { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property ErrorLogger As ErrorLogger
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>]
member ErrorLogger : ErrorLogger with get

function get_ErrorLogger();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
property ErrorLogger^ ErrorLogger {
    ErrorLogger^ get ();
}

Property Value

Type: ErrorLogger
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.HealthMonitorInterval Property

Grid Solutions Framework ServiceHelperHealthMonitorInterval Property
Gets or sets the interval, in seconds, over which to sample the performance monitor for health statistics.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(5)]
public double HealthMonitorInterval { get; set; }
<DefaultValueAttribute(5)>
Public Property HealthMonitorInterval As Double
    Get
    Set
[<DefaultValueAttribute(5)>]
member HealthMonitorInterval : float with get, set

function get_HealthMonitorInterval();
function set_HealthMonitorInterval(value);
public:
[DefaultValueAttribute(5)]
property double HealthMonitorInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.IsDisposed Property

Grid Solutions Framework ServiceHelperIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public bool IsDisposed { get; }
<BrowsableAttribute(false)>
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public ReadOnly Property IsDisposed As Boolean
    Get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract IsDisposed : bool with get
[<BrowsableAttribute(false)>]
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Hidden)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override IsDisposed : bool with get
function get_IsDisposed();

public:
[BrowsableAttribute(false)]
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Hidden)]
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.LogStatusUpdates Property

Grid Solutions Framework ServiceHelperLogStatusUpdates Property
Gets or sets a boolean value that indicates whether messages sent using UpdateStatus(UpdateType, String, Object) or UpdateStatus(Guid, UpdateType, String, Object) are to be logged to the StatusLog.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
public bool LogStatusUpdates { get; set; }
<DefaultValueAttribute(true)>
Public Property LogStatusUpdates As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
member LogStatusUpdates : bool with get, set

function get_LogStatusUpdates();
function set_LogStatusUpdates(value);
public:
[DefaultValueAttribute(true)]
property bool LogStatusUpdates {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.MaxStatusUpdatesFrequency Property

Grid Solutions Framework ServiceHelperMaxStatusUpdatesFrequency Property
Gets or sets the maximum number of status update messages that can be issued in a second without getting suppressed from being displayed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(30)]
public int MaxStatusUpdatesFrequency { get; set; }
<DefaultValueAttribute(30)>
Public Property MaxStatusUpdatesFrequency As Integer
    Get
    Set
[<DefaultValueAttribute(30)>]
member MaxStatusUpdatesFrequency : int with get, set

function get_MaxStatusUpdatesFrequency();
function set_MaxStatusUpdatesFrequency(value);
public:
[DefaultValueAttribute(30)]
property int MaxStatusUpdatesFrequency {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is negative or zero.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.MaxStatusUpdatesLength Property

Grid Solutions Framework ServiceHelperMaxStatusUpdatesLength Property
Gets or sets the maximum numbers of characters allowed in update status messages without getting suppressed from being displayed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(8192)]
public int MaxStatusUpdatesLength { get; set; }
<DefaultValueAttribute(8192)>
Public Property MaxStatusUpdatesLength As Integer
    Get
    Set
[<DefaultValueAttribute(8192)>]
member MaxStatusUpdatesLength : int with get, set

function get_MaxStatusUpdatesLength();
function set_MaxStatusUpdatesLength(value);
public:
[DefaultValueAttribute(8192)]
property int MaxStatusUpdatesLength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentException | The value being assigned is negative or zero.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.MonitorServiceHealth Property

Grid Solutions Framework ServiceHelperMonitorServiceHealth Property
Gets or sets a boolean value that indicates whether the health of the ParentService is to be monitored.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool MonitorServiceHealth { get; set; }
<DefaultValueAttribute(false)>
Public Property MonitorServiceHealth As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member MonitorServiceHealth : bool with get, set

function get_MonitorServiceHealth();
function set_MonitorServiceHealth(value);
public:
[DefaultValueAttribute(false)]
property bool MonitorServiceHealth {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.Name Property

Grid Solutions Framework ServiceHelperName Property
Gets the unique identifier of the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Name { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Name As String
    Get
[<BrowsableAttribute(false)>]
abstract Name : string with get
[<BrowsableAttribute(false)>]
override Name : string with get
function get_Name();

public:
[BrowsableAttribute(false)]
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ParentService Property

Grid Solutions Framework ServiceHelperParentService Property
Gets or sets the ServiceBase to which the ServiceHelper will provided added functionality.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceBase ParentService { get; set; }
Public Property ParentService As ServiceBase
    Get
    Set
member ParentService : ServiceBase with get, set

function get_ParentService();
function set_ParentService(value);
public:
property ServiceBase^ ParentService {
    ServiceBase^ get ();
    void set (ServiceBase^ value);
}

Property Value

Type: ServiceBase
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.PerformanceMonitor Property

Grid Solutions Framework ServiceHelperPerformanceMonitor Property
Gets the PerformanceMonitor object used for monitoring the health of the ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public PerformanceMonitor PerformanceMonitor { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(false)>
Public ReadOnly Property PerformanceMonitor As PerformanceMonitor
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
[<BrowsableAttribute(false)>]
member PerformanceMonitor : PerformanceMonitor with get

function get_PerformanceMonitor();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
[BrowsableAttribute(false)]
property PerformanceMonitor^ PerformanceMonitor {
    PerformanceMonitor^ get ();
}

Property Value

Type: PerformanceMonitor
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.PersistSettings Property

Grid Solutions Framework ServiceHelperPersistSettings Property
Gets or sets a boolean value that indicates whether the settings of ServiceHelper are to be saved to the config file.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool PersistSettings { get; set; }
<DefaultValueAttribute(false)>
Public Property PersistSettings As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
abstract PersistSettings : bool with get, set
[<DefaultValueAttribute(false)>]
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
[DefaultValueAttribute(false)]
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.Processes Property

Grid Solutions Framework ServiceHelperProcesses Property
Gets a list of ServiceProcess defined in the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public IList<ServiceProcess> Processes { get; }
<BrowsableAttribute(false)>
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public ReadOnly Property Processes As IList(Of ServiceProcess)
    Get
[<BrowsableAttribute(false)>]
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
member Processes : IList<ServiceProcess> with get

function get_Processes();

public:
[BrowsableAttribute(false)]
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
property IList<ServiceProcess^>^ Processes {
    IList<ServiceProcess^>^ get ();
}

Property Value

Type: IList ServiceProcess
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ProcessScheduler Property

Grid Solutions Framework ServiceHelperProcessScheduler Property
Gets the ScheduleManager component used for scheduling defined ServiceProcess.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public ScheduleManager ProcessScheduler { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property ProcessScheduler As ScheduleManager
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>]
member ProcessScheduler : ScheduleManager with get

function get_ProcessScheduler();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
property ScheduleManager^ ProcessScheduler {
    ScheduleManager^ get ();
}

Property Value

Type: ScheduleManager
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.RemoteClients Property

Grid Solutions Framework ServiceHelperRemoteClients Property
Gets a list of ClientInfo for remote clients connected to the RemotingServer.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public IList<ClientInfo> RemoteClients { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(false)>
Public ReadOnly Property RemoteClients As IList(Of ClientInfo)
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
[<BrowsableAttribute(false)>]
member RemoteClients : IList<ClientInfo> with get

function get_RemoteClients();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
[BrowsableAttribute(false)]
property IList<ClientInfo^>^ RemoteClients {
    IList<ClientInfo^>^ get ();
}

Property Value

Type: IList ClientInfo
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.RemotingServer Property

Grid Solutions Framework ServiceHelperRemotingServer Property
Gets or sets the ServerBase component used for communicating with RemoteClients.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServerBase RemotingServer { get; set; }
Public Property RemotingServer As ServerBase
    Get
    Set
member RemotingServer : ServerBase with get, set

function get_RemotingServer();
function set_RemotingServer(value);
public:
property ServerBase^ RemotingServer {
    ServerBase^ get ();
    void set (ServerBase^ value);
}

Property Value

Type: ServerBase
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.RequestHistoryLimit Property

Grid Solutions Framework ServiceHelperRequestHistoryLimit Property
Gets or sets the maximum number of ClientRequest entries to be maintained in the ClientRequestHistory.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(50)]
public int RequestHistoryLimit { get; set; }
<DefaultValueAttribute(50)>
Public Property RequestHistoryLimit As Integer
    Get
    Set
[<DefaultValueAttribute(50)>]
member RequestHistoryLimit : int with get, set

function get_RequestHistoryLimit();
function set_RequestHistoryLimit(value);
public:
[DefaultValueAttribute(50)]
property int RequestHistoryLimit {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Exceptions
Exception | Condition
ArgumentOutOfRangeException | The value being assigned is zero or negative.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SecureRemoteInteractions Property

Grid Solutions Framework ServiceHelperSecureRemoteInteractions Property
Gets or sets a boolean value that indicates whether ServiceHelper will secure remote interactions from ClientHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool SecureRemoteInteractions { get; set; }
<DefaultValueAttribute(false)>
Public Property SecureRemoteInteractions As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member SecureRemoteInteractions : bool with get, set

function get_SecureRemoteInteractions();
function set_SecureRemoteInteractions(value);
public:
[DefaultValueAttribute(false)]
property bool SecureRemoteInteractions {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SerializationFormat Property

Grid Solutions Framework ServiceHelperSerializationFormat Property
Gets or sets a value that indicates the desired message SerializationFormat for interaction with ClientHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(SerializationFormat.Binary)]
public SerializationFormat SerializationFormat { get; set; }
<DefaultValueAttribute(SerializationFormat.Binary)>
Public Property SerializationFormat As SerializationFormat
    Get
    Set
[<DefaultValueAttribute(SerializationFormat.Binary)>]
member SerializationFormat : SerializationFormat with get, set

function get_SerializationFormat();
function set_SerializationFormat(value);
public:
[DefaultValueAttribute(SerializationFormat::Binary)]
property SerializationFormat SerializationFormat {
    SerializationFormat get ();
    void set (SerializationFormat value);
}

Property Value

Type: SerializationFormat
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServiceComponents Property

Grid Solutions Framework ServiceHelperServiceComponents Property
Gets a list of components that implement the ISupportLifecycle interface used by the ParentService.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
[BrowsableAttribute(false)]
public IList<Object> ServiceComponents { get; }
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
<BrowsableAttribute(false)>
Public ReadOnly Property ServiceComponents As IList(Of Object)
    Get
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
[<BrowsableAttribute(false)>]
member ServiceComponents : IList<Object> with get

function get_ServiceComponents();

public:
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
[BrowsableAttribute(false)]
property IList<Object^>^ ServiceComponents {
    IList<Object^>^ get ();
}

Property Value

Type: IList Object
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SettingsCategory Property

Grid Solutions Framework ServiceHelperSettingsCategory Property
Gets or sets the category under which the settings of ServiceHelper are to be saved to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute("ServiceHelper")]
public string SettingsCategory { get; set; }
<DefaultValueAttribute("ServiceHelper")>
Public Property SettingsCategory As String
    Get
    Set
[<DefaultValueAttribute("ServiceHelper")>]
abstract SettingsCategory : string with get, set
[<DefaultValueAttribute("ServiceHelper")>]
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
[DefaultValueAttribute(L"ServiceHelper")]
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.Status Property

Grid Solutions Framework ServiceHelperStatus Property
Gets the descriptive status of the ServiceHelper.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[BrowsableAttribute(false)]
public string Status { get; }
<BrowsableAttribute(false)>
Public ReadOnly Property Status As String
    Get
[<BrowsableAttribute(false)>]
abstract Status : string with get
[<BrowsableAttribute(false)>]
override Status : string with get
function get_Status();

public:
[BrowsableAttribute(false)]
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.StatusLog Property

Grid Solutions Framework ServiceHelperStatusLog Property
Gets the LogFile component used for logging status messages to a text file.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)]
public LogFile StatusLog { get; }
<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>
Public ReadOnly Property StatusLog As LogFile
    Get
[<DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility.Content)>]
member StatusLog : LogFile with get

function get_StatusLog();

public:
[DesignerSerializationVisibilityAttribute(DesignerSerializationVisibility::Content)]
property LogFile^ StatusLog {
    LogFile^ get ();
}

Property Value

Type: LogFile
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SupportSystemCommands Property

Grid Solutions Framework ServiceHelperSupportSystemCommands Property
Gets or sets a boolean value that indicates whether ServiceHelper commands will have support for system-level access (-system switch).

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool SupportSystemCommands { get; set; }
<DefaultValueAttribute(false)>
Public Property SupportSystemCommands As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member SupportSystemCommands : bool with get, set

function get_SupportSystemCommands();
function set_SupportSystemCommands(value);
public:
[DefaultValueAttribute(false)]
property bool SupportSystemCommands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SupportTelnetSessions Property

Grid Solutions Framework ServiceHelperSupportTelnetSessions Property
Gets or sets a boolean value that indicates whether the ServiceHelper will have support for remote telnet-like sessions.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool SupportTelnetSessions { get; set; }
<DefaultValueAttribute(false)>
Public Property SupportTelnetSessions As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member SupportTelnetSessions : bool with get, set

function get_SupportTelnetSessions();
function set_SupportTelnetSessions(value);
public:
[DefaultValueAttribute(false)]
property bool SupportTelnetSessions {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper Events

Grid Solutions Framework ServiceHelper Events

The ServiceHelper type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | LoggedException | Provides notification of when there is an exception logged.
Public event | ProcessStateChanged | Occurs when the state of a defined ServiceProcess changes.
Public event | ReceivedClientRequest | Occurs when a request is received from one of the RemoteClients.
Public event | ServicePaused | Occurs when the ParentService has paused.
Public event | ServicePausing | Occurs when the ParentService is pausing.
Public event | ServiceResumed | Occurs when the ParentService has resumed.
Public event | ServiceResuming | Occurs when the ParentService is resuming.
Public event | ServiceStarted | Occurs when the ParentService has started.
Public event | ServiceStarting | Occurs when the ParentService is starting.
Public event | ServiceStopped | Occurs when the ParentService has stopped.
Public event | ServiceStopping | Occurs when the ParentService is stopping.
Public event | SystemShutdown | Occurs when the system is being shutdown.
Public event | UpdatedStatus | Provides notification of when status messages were sent to consumer(s).
Top
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.LoggedException Event

Grid Solutions Framework ServiceHelperLoggedException Event
Provides notification of when there is an exception logged.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> LoggedException
Public Event LoggedException As EventHandler(Of EventArgs(Of Exception))
member LoggedException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_LoggedException(value);
function remove_LoggedException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ LoggedException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the exception that was logged.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ProcessStateChanged Event

Grid Solutions Framework ServiceHelperProcessStateChanged Event
Occurs when the state of a defined ServiceProcess changes.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string, ServiceProcessState>> ProcessStateChanged
Public Event ProcessStateChanged As EventHandler(Of EventArgs(Of String, ServiceProcessState))
member ProcessStateChanged : IEvent<EventHandler<EventArgs<string, ServiceProcessState>>,
    EventArgs<string, ServiceProcessState>>

function add_ProcessStateChanged(value);
function remove_ProcessStateChanged(value);
public:
 event EventHandler<EventArgs<String^, ServiceProcessState>^>^ ProcessStateChanged {
    void add (EventHandler<EventArgs<String^, ServiceProcessState>^>^ value);
    void remove (EventHandler<EventArgs<String^, ServiceProcessState>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String, ServiceProcessState
Remarks
Argument1 is the Name.
Argument2 is the CurrentState
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ReceivedClientRequest Event

Grid Solutions Framework ServiceHelperReceivedClientRequest Event
Occurs when a request is received from one of the RemoteClients.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid, ClientRequest>> ReceivedClientRequest
Public Event ReceivedClientRequest As EventHandler(Of EventArgs(Of Guid, ClientRequest))
member ReceivedClientRequest : IEvent<EventHandler<EventArgs<Guid, ClientRequest>>,
    EventArgs<Guid, ClientRequest>>

function add_ReceivedClientRequest(value);
function remove_ReceivedClientRequest(value);
public:
 event EventHandler<EventArgs<Guid, ClientRequest^>^>^ ReceivedClientRequest {
    void add (EventHandler<EventArgs<Guid, ClientRequest^>^>^ value);
    void remove (EventHandler<EventArgs<Guid, ClientRequest^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, ClientRequest
Remarks
Argument1 is the ID of the remote client that sent the request.
Argument2 is the ClientRequest sent by the remote client.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServicePaused Event

Grid Solutions Framework ServiceHelperServicePaused Event
Occurs when the ParentService has paused.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServicePaused
Public Event ServicePaused As EventHandler
member ServicePaused : IEvent<EventHandler,
    EventArgs>

function add_ServicePaused(value);
function remove_ServicePaused(value);
public:
 event EventHandler^ ServicePaused {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServicePausing Event

Grid Solutions Framework ServiceHelperServicePausing Event
Occurs when the ParentService is pausing.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServicePausing
Public Event ServicePausing As EventHandler
member ServicePausing : IEvent<EventHandler,
    EventArgs>

function add_ServicePausing(value);
function remove_ServicePausing(value);
public:
 event EventHandler^ ServicePausing {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServiceResumed Event

Grid Solutions Framework ServiceHelperServiceResumed Event
Occurs when the ParentService has resumed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServiceResumed
Public Event ServiceResumed As EventHandler
member ServiceResumed : IEvent<EventHandler,
    EventArgs>

function add_ServiceResumed(value);
function remove_ServiceResumed(value);
public:
 event EventHandler^ ServiceResumed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServiceResuming Event

Grid Solutions Framework ServiceHelperServiceResuming Event
Occurs when the ParentService is resuming.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServiceResuming
Public Event ServiceResuming As EventHandler
member ServiceResuming : IEvent<EventHandler,
    EventArgs>

function add_ServiceResuming(value);
function remove_ServiceResuming(value);
public:
 event EventHandler^ ServiceResuming {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServiceStarted Event

Grid Solutions Framework ServiceHelperServiceStarted Event
Occurs when the ParentService has started.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServiceStarted
Public Event ServiceStarted As EventHandler
member ServiceStarted : IEvent<EventHandler,
    EventArgs>

function add_ServiceStarted(value);
function remove_ServiceStarted(value);
public:
 event EventHandler^ ServiceStarted {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServiceStarting Event

Grid Solutions Framework ServiceHelperServiceStarting Event
Occurs when the ParentService is starting.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string[]>> ServiceStarting
Public Event ServiceStarting As EventHandler(Of EventArgs(Of String()))
member ServiceStarting : IEvent<EventHandler<EventArgs<string[]>>,
    EventArgs<string[]>>

function add_ServiceStarting(value);
function remove_ServiceStarting(value);
public:
 event EventHandler<EventArgs<array<String^>^>^>^ ServiceStarting {
    void add (EventHandler<EventArgs<array<String^>^>^>^ value);
    void remove (EventHandler<EventArgs<array<String^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServiceStopped Event

Grid Solutions Framework ServiceHelperServiceStopped Event
Occurs when the ParentService has stopped.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServiceStopped
Public Event ServiceStopped As EventHandler
member ServiceStopped : IEvent<EventHandler,
    EventArgs>

function add_ServiceStopped(value);
function remove_ServiceStopped(value);
public:
 event EventHandler^ ServiceStopped {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.ServiceStopping Event

Grid Solutions Framework ServiceHelperServiceStopping Event
Occurs when the ParentService is stopping.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServiceStopping
Public Event ServiceStopping As EventHandler
member ServiceStopping : IEvent<EventHandler,
    EventArgs>

function add_ServiceStopping(value);
function remove_ServiceStopping(value);
public:
 event EventHandler^ ServiceStopping {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.SystemShutdown Event

Grid Solutions Framework ServiceHelperSystemShutdown Event
Occurs when the system is being shutdown.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler SystemShutdown
Public Event SystemShutdown As EventHandler
member SystemShutdown : IEvent<EventHandler,
    EventArgs>

function add_SystemShutdown(value);
function remove_SystemShutdown(value);
public:
 event EventHandler^ SystemShutdown {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceHelper.UpdatedStatus Event

Grid Solutions Framework ServiceHelperUpdatedStatus Event
Provides notification of when status messages were sent to consumer(s).

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string, UpdateType>> UpdatedStatus
Public Event UpdatedStatus As EventHandler(Of EventArgs(Of String, UpdateType))
member UpdatedStatus : IEvent<EventHandler<EventArgs<string, UpdateType>>,
    EventArgs<string, UpdateType>>

function add_UpdatedStatus(value);
function remove_UpdatedStatus(value);
public:
 event EventHandler<EventArgs<String^, UpdateType>^>^ UpdatedStatus {
    void add (EventHandler<EventArgs<String^, UpdateType>^>^ value);
    void remove (EventHandler<EventArgs<String^, UpdateType>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String, UpdateType
Remarks
Argument1 is the status message sent to consumer(s).
Argument2 is the message UpdateType.
See Also

Reference

ServiceHelper Class
GSF.ServiceProcess Namespace


ServiceInstallerEx Class

Grid Solutions Framework ServiceInstallerEx Class
Defines an extended service installer class that can define service failure actions at install time.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Configuration.InstallInstaller
System.Configuration.InstallComponentInstaller
System.ServiceProcessServiceInstaller
GSF.ServiceProcessServiceInstallerEx

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ServiceInstallerEx : ServiceInstaller
Public Class ServiceInstallerEx
    Inherits ServiceInstaller
type ServiceInstallerEx =
    class
        inherit ServiceInstaller
    end
GSF.ServiceProcess.ServiceInstallerEx = function();

Type.createClass(
    'GSF.ServiceProcess.ServiceInstallerEx',
    ServiceInstaller);
public ref class ServiceInstallerEx : public ServiceInstaller

The ServiceInstallerEx type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceInstallerEx | Creates a new ServiceInstallerEx.
Top
Methods
 | Name | Description
Public method | Commit | When overridden in a derived class, completes the install transaction. (Inherited from Installer.)
Public method | CopyFromComponent | Copies properties from an instance of ServiceBase to this installer. (Inherited from ServiceInstaller.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DefineRecoverAction | Defines a new recover action to be performed upon service failure.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Install | Installs the service by writing service application information to the registry. This method is meant to be used by installation tools, which process the appropriate methods automatically. (Inherited from ServiceInstaller.)
Public method | IsEquivalentInstaller | Indicates whether two installers would install the same service. (Inherited from ServiceInstaller.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterInstall | Raises the AfterInstall event. (Inherited from Installer.)
Protected method | OnAfterRollback | Raises the AfterRollback event. (Inherited from Installer.)
Protected method | OnAfterUninstall | Raises the AfterUninstall event. (Inherited from Installer.)
Protected method | OnBeforeInstall | Raises the BeforeInstall event. (Inherited from Installer.)
Protected method | OnBeforeRollback | Raises the BeforeRollback event. (Inherited from Installer.)
Protected method | OnBeforeUninstall | Raises the BeforeUninstall event. (Inherited from Installer.)
Protected method | OnCommitted | Raises the Committed event. (Inherited from Installer.)
Protected method | OnCommitting | Raises the Committing event. (Inherited from Installer.)
Public method | Rollback | Rolls back service application information written to the registry by the installation procedure. This method is meant to be used by installation tools, which process the appropriate methods automatically. (Inherited from ServiceInstaller.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Uninstall | Uninstalls the service by removing information about it from the registry. (Inherited from ServiceInstaller.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Context | Gets or sets information about the current installation. (Inherited from Installer.)
Public property | DelayedAutoStart | Gets or sets a value that indicates whether the service should be delayed from starting until other automatically started services are running. (Inherited from ServiceInstaller.)
Public property | Description | Gets or sets the description for the service. (Inherited from ServiceInstaller.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayName | Indicates the friendly name that identifies the service to the user. (Inherited from ServiceInstaller.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExecuteActionsOnNonCrashErrors | Sets flag that determines when failure actions are to be executed.
Public property | FailRebootMessage | Sets the service fail reboot message.
Public property | FailResetPeriod | Sets the time after which to reset the failure count to zero if there are no failures, in seconds. Specify Infinite to indicate that this value should never be reset.
Public property | FailRunCommand | Sets the service fail run command.
Public property | HelpText | Gets the help text for all the installers in the installer collection. (Inherited from Installer.)
Public property | Installers | Gets the collection of installers that this installer contains. (Inherited from Installer.)
Public property | Parent | Gets or sets the installer containing the collection that this installer belongs to. (Inherited from Installer.)
Public property | ServiceName | Indicates the name used by the system to identify this service. This property must be identical to the ServiceName of the service you want to install. (Inherited from ServiceInstaller.)
Public property | ServicesDependedOn | Indicates the services that must be running for this service to run. (Inherited from ServiceInstaller.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | StartOnInstall | Sets the boolean value to configure the service to start after it is installed.
Public property | StartTimeout | Sets the service start timeout in milliseconds.
Public property | StartType | Indicates how and when this service is started. (Inherited from ServiceInstaller.)
Top
Events
 | Name | Description
Public event | AfterInstall | Occurs after the Install(IDictionary) methods of all the installers in the Installers property have run. (Inherited from Installer.)
Public event | AfterRollback | Occurs after the installations of all the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | AfterUninstall | Occurs after all the installers in the Installers property perform their uninstallation operations. (Inherited from Installer.)
Public event | BeforeInstall | Occurs before the Install(IDictionary) method of each installer in the installer collection has run. (Inherited from Installer.)
Public event | BeforeRollback | Occurs before the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | BeforeUninstall | Occurs before the installers in the Installers property perform their uninstall operations. (Inherited from Installer.)
Public event | Committed | Occurs after all the installers in the Installers property have committed their installations. (Inherited from Installer.)
Public event | Committing | Occurs before the installers in the Installers property committ their installations. (Inherited from Installer.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
See Also

Reference

GSF.ServiceProcess Namespace


ServiceInstallerEx Constructor

Grid Solutions Framework ServiceInstallerEx Constructor
Creates a new ServiceInstallerEx.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceInstallerEx()
Public Sub New
new : unit -> ServiceInstallerEx
GSF.ServiceProcess.ServiceInstallerEx = function();
public:
ServiceInstallerEx()
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx Methods

Grid Solutions Framework ServiceInstallerEx Methods

The ServiceInstallerEx type exposes the following members.

Methods
 | Name | Description
Public method | Commit | When overridden in a derived class, completes the install transaction. (Inherited from Installer.)
Public method | CopyFromComponent | Copies properties from an instance of ServiceBase to this installer. (Inherited from ServiceInstaller.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DefineRecoverAction | Defines a new recover action to be performed upon service failure.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Install | Installs the service by writing service application information to the registry. This method is meant to be used by installation tools, which process the appropriate methods automatically. (Inherited from ServiceInstaller.)
Public method | IsEquivalentInstaller | Indicates whether two installers would install the same service. (Inherited from ServiceInstaller.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterInstall | Raises the AfterInstall event. (Inherited from Installer.)
Protected method | OnAfterRollback | Raises the AfterRollback event. (Inherited from Installer.)
Protected method | OnAfterUninstall | Raises the AfterUninstall event. (Inherited from Installer.)
Protected method | OnBeforeInstall | Raises the BeforeInstall event. (Inherited from Installer.)
Protected method | OnBeforeRollback | Raises the BeforeRollback event. (Inherited from Installer.)
Protected method | OnBeforeUninstall | Raises the BeforeUninstall event. (Inherited from Installer.)
Protected method | OnCommitted | Raises the Committed event. (Inherited from Installer.)
Protected method | OnCommitting | Raises the Committing event. (Inherited from Installer.)
Public method | Rollback | Rolls back service application information written to the registry by the installation procedure. This method is meant to be used by installation tools, which process the appropriate methods automatically. (Inherited from ServiceInstaller.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Uninstall | Uninstalls the service by removing information about it from the registry. (Inherited from ServiceInstaller.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx.DefineRecoverAction Method

Grid Solutions Framework ServiceInstallerExDefineRecoverAction Method
Defines a new recover action to be performed upon service failure.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void DefineRecoverAction(
    RecoverAction recoverAction,
    int delay
)
Public Sub DefineRecoverAction (
    recoverAction As RecoverAction,
    delay As Integer
)
member DefineRecoverAction :
        recoverAction : RecoverAction *
        delay : int -> unit

function DefineRecoverAction(recoverAction, delay);
public:
void DefineRecoverAction(
    RecoverAction recoverAction,
    int delay
)

Parameters

recoverAction
Type: GSF.ServiceProcessRecoverAction
RecoverAction to execute upon service failure.
delay
Type: SystemInt32
The time to wait before performing the specified recoverAction, in milliseconds.
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx Properties

Grid Solutions Framework ServiceInstallerEx Properties

The ServiceInstallerEx type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Context | Gets or sets information about the current installation. (Inherited from Installer.)
Public property | DelayedAutoStart | Gets or sets a value that indicates whether the service should be delayed from starting until other automatically started services are running. (Inherited from ServiceInstaller.)
Public property | Description | Gets or sets the description for the service. (Inherited from ServiceInstaller.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DisplayName | Indicates the friendly name that identifies the service to the user. (Inherited from ServiceInstaller.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExecuteActionsOnNonCrashErrors | Sets flag that determines when failure actions are to be executed.
Public property | FailRebootMessage | Sets the service fail reboot message.
Public property | FailResetPeriod | Sets the time after which to reset the failure count to zero if there are no failures, in seconds. Specify Infinite to indicate that this value should never be reset.
Public property | FailRunCommand | Sets the service fail run command.
Public property | HelpText | Gets the help text for all the installers in the installer collection. (Inherited from Installer.)
Public property | Installers | Gets the collection of installers that this installer contains. (Inherited from Installer.)
Public property | Parent | Gets or sets the installer containing the collection that this installer belongs to. (Inherited from Installer.)
Public property | ServiceName | Indicates the name used by the system to identify this service. This property must be identical to the ServiceName of the service you want to install. (Inherited from ServiceInstaller.)
Public property | ServicesDependedOn | Indicates the services that must be running for this service to run. (Inherited from ServiceInstaller.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | StartOnInstall | Sets the boolean value to configure the service to start after it is installed.
Public property | StartTimeout | Sets the service start timeout in milliseconds.
Public property | StartType | Indicates how and when this service is started. (Inherited from ServiceInstaller.)
Top
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx.ExecuteActionsOnNonCrashErrors Property

Grid Solutions Framework ServiceInstallerExExecuteActionsOnNonCrashErrors Property
Sets flag that determines when failure actions are to be executed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ExecuteActionsOnNonCrashErrors { set; }
Public WriteOnly Property ExecuteActionsOnNonCrashErrors As Boolean
    Set
member ExecuteActionsOnNonCrashErrors : bool with set

function set_ExecuteActionsOnNonCrashErrors(value);
public:
property bool ExecuteActionsOnNonCrashErrors {
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

If this member is true and the service has configured failure actions, the failure actions are queued if the service process terminates without reporting a status of SERVICE_STOPPED or if it enters the SERVICE_STOPPED state but the exit code returned in the SERVICE_STATUS structure is not ERROR_SUCCESS (0).

If this member is false and the service has configured failure actions, the failure actions are queued only if the service terminates without reporting a status of SERVICE_STOPPED.

This setting is ignored unless the service has configured failure actions.

See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx.FailRebootMessage Property

Grid Solutions Framework ServiceInstallerExFailRebootMessage Property
Sets the service fail reboot message.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FailRebootMessage { set; }
Public WriteOnly Property FailRebootMessage As String
    Set
member FailRebootMessage : string with set

function set_FailRebootMessage(value);
public:
property String^ FailRebootMessage {
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx.FailResetPeriod Property

Grid Solutions Framework ServiceInstallerExFailResetPeriod Property
Sets the time after which to reset the failure count to zero if there are no failures, in seconds. Specify Infinite to indicate that this value should never be reset.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int FailResetPeriod { set; }
Public WriteOnly Property FailResetPeriod As Integer
    Set
member FailResetPeriod : int with set

function set_FailResetPeriod(value);
public:
property int FailResetPeriod {
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx.FailRunCommand Property

Grid Solutions Framework ServiceInstallerExFailRunCommand Property
Sets the service fail run command.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FailRunCommand { set; }
Public WriteOnly Property FailRunCommand As String
    Set
member FailRunCommand : string with set

function set_FailRunCommand(value);
public:
property String^ FailRunCommand {
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx.StartOnInstall Property

Grid Solutions Framework ServiceInstallerExStartOnInstall Property
Sets the boolean value to configure the service to start after it is installed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool StartOnInstall { set; }
Public WriteOnly Property StartOnInstall As Boolean
    Set
member StartOnInstall : bool with set

function set_StartOnInstall(value);
public:
property bool StartOnInstall {
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx.StartTimeout Property

Grid Solutions Framework ServiceInstallerExStartTimeout Property
Sets the service start timeout in milliseconds.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int StartTimeout { set; }
Public WriteOnly Property StartTimeout As Integer
    Set
member StartTimeout : int with set

function set_StartTimeout(value);
public:
property int StartTimeout {
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceInstallerEx Events

Grid Solutions Framework ServiceInstallerEx Events

The ServiceInstallerEx type exposes the following members.

Events
 | Name | Description
Public event | AfterInstall | Occurs after the Install(IDictionary) methods of all the installers in the Installers property have run. (Inherited from Installer.)
Public event | AfterRollback | Occurs after the installations of all the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | AfterUninstall | Occurs after all the installers in the Installers property perform their uninstallation operations. (Inherited from Installer.)
Public event | BeforeInstall | Occurs before the Install(IDictionary) method of each installer in the installer collection has run. (Inherited from Installer.)
Public event | BeforeRollback | Occurs before the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | BeforeUninstall | Occurs before the installers in the Installers property perform their uninstall operations. (Inherited from Installer.)
Public event | Committed | Occurs after all the installers in the Installers property have committed their installations. (Inherited from Installer.)
Public event | Committing | Occurs before the installers in the Installers property committ their installations. (Inherited from Installer.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
See Also

Reference

ServiceInstallerEx Class
GSF.ServiceProcess Namespace


ServiceMonitorBase Class

Grid Solutions Framework ServiceMonitorBase Class
Base class for service monitors.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.ServiceProcessServiceMonitorBase

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ServiceMonitorBase : Adapter,
    IServiceMonitor, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings
Public MustInherit Class ServiceMonitorBase
    Inherits Adapter
    Implements IServiceMonitor, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
[<AbstractClassAttribute>]
type ServiceMonitorBase =
    class
        inherit Adapter
        interface IServiceMonitor
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.ServiceProcess.ServiceMonitorBase = function();

Type.createClass(
    'GSF.ServiceProcess.ServiceMonitorBase',
    GSF.Adapters.Adapter,
    GSF.ServiceProcess.IServiceMonitor,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
public ref class ServiceMonitorBase abstract : public Adapter,
    IServiceMonitor, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IPersistSettings

The ServiceMonitorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ServiceMonitorBase | Initializes a new instance of the ServiceMonitorBase class
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Adapter and optionally releases the managed resources. (Inherited from Adapter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleClientMessage | Handles messages sent by a client.
Public method | HandleServiceError | Handles messages received by the service whenever the service encounters an error.
Public method | HandleServiceHeartbeat | Handles notifications from the service that occur on an interval to indicate that the service is still running.
Public method | Initialize | Initializes the Adapter. (Inherited from Adapter.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved ServiceMonitorBase settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves ServiceMonitorBase settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

GSF.ServiceProcess Namespace


ServiceMonitorBase Constructor

Grid Solutions Framework ServiceMonitorBase Constructor
Initializes a new instance of the ServiceMonitorBase class

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ServiceMonitorBase()
Protected Sub New
new : unit -> ServiceMonitorBase
GSF.ServiceProcess.ServiceMonitorBase = function();
protected:
ServiceMonitorBase()
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase Methods

Grid Solutions Framework ServiceMonitorBase Methods

The ServiceMonitorBase type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Adapter and optionally releases the managed resources. (Inherited from Adapter.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the Adapter is reclaimed by GC. (Inherited from Adapter.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleClientMessage | Handles messages sent by a client.
Public method | HandleServiceError | Handles messages received by the service whenever the service encounters an error.
Public method | HandleServiceHeartbeat | Handles notifications from the service that occur on an interval to indicate that the service is still running.
Public method | Initialize | Initializes the Adapter. (Inherited from Adapter.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved ServiceMonitorBase settings from the config file if the PersistSettings property is set to true. (Overrides AdapterLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | SaveSettings | Saves ServiceMonitorBase settings to the config file if the PersistSettings property is set to true. (Overrides AdapterSaveSettings.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase.HandleClientMessage Method

Grid Solutions Framework ServiceMonitorBaseHandleClientMessage Method
Handles messages sent by a client.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void HandleClientMessage(
    string[] args
)
Public Overridable Sub HandleClientMessage (
    args As String()
)
abstract HandleClientMessage :
        args : string[] -> unit
override HandleClientMessage :
        args : string[] -> unit
function HandleClientMessage(args);
public:
virtual void HandleClientMessage(
    array<String^>^ args
)

Parameters

args
Type: SystemString
Arguments provided by the client.

Implements

IServiceMonitorHandleClientMessage(String)
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase.HandleServiceError Method

Grid Solutions Framework ServiceMonitorBaseHandleServiceError Method
Handles messages received by the service whenever the service encounters an error.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void HandleServiceError(
    Exception ex
)
Public Overridable Sub HandleServiceError (
    ex As Exception
)
abstract HandleServiceError :
        ex : Exception -> unit
override HandleServiceError :
        ex : Exception -> unit
function HandleServiceError(ex);
public:
virtual void HandleServiceError(
    Exception^ ex
)

Parameters

ex
Type: SystemException
The error received from the service.

Implements

IServiceMonitorHandleServiceError(Exception)
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase.HandleServiceHeartbeat Method

Grid Solutions Framework ServiceMonitorBaseHandleServiceHeartbeat Method
Handles notifications from the service that occur on an interval to indicate that the service is still running.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void HandleServiceHeartbeat()
Public Overridable Sub HandleServiceHeartbeat
abstract HandleServiceHeartbeat : unit -> unit
override HandleServiceHeartbeat : unit -> unit
function HandleServiceHeartbeat();
public:
virtual void HandleServiceHeartbeat()

Implements

IServiceMonitorHandleServiceHeartbeat
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase.LoadSettings Method

Grid Solutions Framework ServiceMonitorBaseLoadSettings Method
Loads saved ServiceMonitorBase settings from the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase.SaveSettings Method

Grid Solutions Framework ServiceMonitorBaseSaveSettings Method
Saves ServiceMonitorBase settings to the config file if the PersistSettings property is set to true.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase Properties

Grid Solutions Framework ServiceMonitorBase Properties

The ServiceMonitorBase type exposes the following members.

Properties
 | Name | Description
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the Adapter is currently enabled. (Inherited from Adapter.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Top
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitorBase Events

Grid Solutions Framework ServiceMonitorBase Events

The ServiceMonitorBase type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

ServiceMonitorBase Class
GSF.ServiceProcess Namespace


ServiceMonitors Class

Grid Solutions Framework ServiceMonitors Class
Adapter loader that loads implementations of IServiceMonitor and delegates messages to the enabled monitors.
Inheritance Hierarchy
SystemObject
GSF.AdaptersAdapterLoader IServiceMonitor
GSF.ServiceProcessServiceMonitors

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ServiceMonitors : AdapterLoader<IServiceMonitor>
Public Class ServiceMonitors
    Inherits AdapterLoader(Of IServiceMonitor)
type ServiceMonitors =
    class
        inherit AdapterLoader<IServiceMonitor>
    end
GSF.ServiceProcess.ServiceMonitors = function();

Type.createClass(
    'GSF.ServiceProcess.ServiceMonitors',
    GSF.Adapters.AdapterLoader`1);
public ref class ServiceMonitors : public AdapterLoader<IServiceMonitor^>

The ServiceMonitors type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceMonitors | Initializes a new instance of the ServiceMonitors class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data. (Overrides AdapterLoaderTExecuteAdapterOperation(T, Object).)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleClientMessage | Handles messages sent by a client.
Public method | HandleServiceError | Handles messages received by the service whenever the service encounters an error.
Public method | HandleServiceHeartbeat | Handles notifications from the service that occur on an interval to indicate that the service is still running.
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

GSF.ServiceProcess Namespace


ServiceMonitors Constructor

Grid Solutions Framework ServiceMonitors Constructor
Initializes a new instance of the ServiceMonitors class

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceMonitors()
Public Sub New
new : unit -> ServiceMonitors
GSF.ServiceProcess.ServiceMonitors = function();
public:
ServiceMonitors()
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceMonitors Methods

Grid Solutions Framework ServiceMonitors Methods

The ServiceMonitors type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterLoaderT and optionally releases the managed resources. (Inherited from AdapterLoaderT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAdapterOperation | Executes an operation on the adapter with the given data. (Overrides AdapterLoaderTExecuteAdapterOperation(T, Object).)
Protected method | Finalize | Releases the unmanaged resources before the AdapterLoaderT is reclaimed by GC. (Inherited from AdapterLoaderT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetMemoryUsage | Gets the memory usage in bytes of the specified process. (Inherited from AdapterLoaderT.)
Protected method | GetProcessorUsage | Gets the % processor usage of the specified process. (Inherited from AdapterLoaderT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | HandleClientMessage | Handles messages sent by a client.
Public method | HandleServiceError | Handles messages received by the service whenever the service encounters an error.
Public method | HandleServiceHeartbeat | Handles notifications from the service that occur on an interval to indicate that the service is still running.
Public method | Initialize | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | Initialize(IEnumerableType) | Initializes the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public method | LoadSettings | Loads saved AdapterLoaderT settings from the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MonitorAdapterResources | Monitors the resource utilization of Adapters. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterCreated | Raises the AdapterCreated event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoaded | Raises the AdapterLoaded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterLoadException | Raises the AdapterLoadException event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterResourceUsageExceeded | Raises the AdapterResourceUsageExceeded event. (Inherited from AdapterLoaderT.)
Protected method | OnAdapterUnloaded | Raises the AdapterUnloaded event. (Inherited from AdapterLoaderT.)
Protected method | OnOperationExecutionException | Raises the OperationExecutionException event. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(String) | Processes the adapterFile by deserializing it. (Inherited from AdapterLoaderT.)
Protected method | ProcessAdapter(Type) | Processes the adapterType by instantiating it. (Inherited from AdapterLoaderT.)
Public method | SaveSettings | Saves AdapterLoaderT settings to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceMonitors.ExecuteAdapterOperation Method

Grid Solutions Framework ServiceMonitorsExecuteAdapterOperation Method
Executes an operation on the adapter with the given data.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExecuteAdapterOperation(
    IServiceMonitor adapter,
    Object data
)
Protected Overrides Sub ExecuteAdapterOperation (
    adapter As IServiceMonitor,
    data As Object
)
abstract ExecuteAdapterOperation :
        adapter : IServiceMonitor *
        data : Object -> unit
override ExecuteAdapterOperation :
        adapter : IServiceMonitor *
        data : Object -> unit
function ExecuteAdapterOperation(adapter, data);
protected:
virtual void ExecuteAdapterOperation(
    IServiceMonitor^ adapter,
    Object^ data
) override

Parameters

adapter
Type: GSF.ServiceProcessIServiceMonitor
Adapter on which an operation is to be executed.
data
Type: SystemObject
The operation to be executed.
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceMonitors.HandleClientMessage Method

Grid Solutions Framework ServiceMonitorsHandleClientMessage Method
Handles messages sent by a client.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void HandleClientMessage(
    string[] args
)
Public Sub HandleClientMessage (
    args As String()
)
member HandleClientMessage :
        args : string[] -> unit

function HandleClientMessage(args);
public:
void HandleClientMessage(
    array<String^>^ args
)

Parameters

args
Type: SystemString
Arguments provided by the client.
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceMonitors.HandleServiceError Method

Grid Solutions Framework ServiceMonitorsHandleServiceError Method
Handles messages received by the service whenever the service encounters an error.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void HandleServiceError(
    Exception ex
)
Public Sub HandleServiceError (
    ex As Exception
)
member HandleServiceError :
        ex : Exception -> unit

function HandleServiceError(ex);
public:
void HandleServiceError(
    Exception^ ex
)

Parameters

ex
Type: SystemException
The exception received from the service.
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceMonitors.HandleServiceHeartbeat Method

Grid Solutions Framework ServiceMonitorsHandleServiceHeartbeat Method
Handles notifications from the service that occur on an interval to indicate that the service is still running.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void HandleServiceHeartbeat()
Public Sub HandleServiceHeartbeat
member HandleServiceHeartbeat : unit -> unit

function HandleServiceHeartbeat();
public:
void HandleServiceHeartbeat()
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceMonitors Properties

Grid Solutions Framework ServiceMonitors Properties

The ServiceMonitors type exposes the following members.

Properties
 | Name | Description
Public property | AdapterDirectory | Gets or sets the directory where Adapters are located. (Inherited from AdapterLoaderT.)
Public property | AdapterFileExtension | Gets or sets the file extension of the Adapters. (Inherited from AdapterLoaderT.)
Public property | AdapterFileFormat | Gets or sets the file format of the Adapters. (Inherited from AdapterLoaderT.)
Public property | Adapters | Gets a list of adapters loaded from the AdapterDirectory. (Inherited from AdapterLoaderT.)
Protected property | AdapterWatcher | Gets the FileSystemWatcher object watching for new adapter assemblies added at runtime. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterMemoryUsage | Gets or sets the memory in megabytes the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableAdapterProcessorUsage | Gets or sets the processor time in % the Adapters are allowed to use before being flagged as offending by the internal monitoring process. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessMemoryUsage | Gets or sets the memory in megabytes the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | AllowableProcessProcessorUsage | Gets or sets the processor time in % the current process is allowed to use before the internal monitoring process starts looking for offending Adapters. (Inherited from AdapterLoaderT.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the AdapterLoaderT is currently enabled. (Inherited from AdapterLoaderT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterLoaderT.)
Public property | IsolateAdapters | Gets or sets a boolean value that indicates whether Adapters are loaded in separate AppDomain for isolated execution. (Inherited from AdapterLoaderT.)
Public property | MonitorAdapters | Gets or sets a boolean value that indicates whether resource utilization of Adapters executing in isolation is to be monitored. (Inherited from AdapterLoaderT.)
Public property | Name | Gets the unique identifier of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Protected property | OperationQueue | Gets the ProcessQueueT object to be used for queuing operations to be executed on Adapters. (Inherited from AdapterLoaderT.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether AdapterLoaderT settings are to be saved to the config file. (Inherited from AdapterLoaderT.)
Public property | SettingsCategory | Gets or sets the category under which AdapterLoaderT settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from AdapterLoaderT.)
Public property | Status | Gets the descriptive status of the AdapterLoaderT. (Inherited from AdapterLoaderT.)
Public property | WatchForAdapters | Gets or sets a boolean value that indicates whether the AdapterDirectory is to be monitored for new Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceMonitors Events

Grid Solutions Framework ServiceMonitors Events

The ServiceMonitors type exposes the following members.

Events
 | Name | Description
Public event | AdapterCreated | Occurs when a new adapter is found and instantiated. (Inherited from AdapterLoaderT.)
Public event | AdapterLoaded | Occurs when a new adapter is loaded to the Adapters list. (Inherited from AdapterLoaderT.)
Public event | AdapterLoadException | Occurs when an Exception is encountered when loading an adapter. (Inherited from AdapterLoaderT.)
Public event | AdapterResourceUsageExceeded | Occurs when an adapter has exceeded either the AllowableAdapterMemoryUsage or AllowableAdapterProcessorUsage. (Inherited from AdapterLoaderT.)
Public event | AdapterUnloaded | Occurs when an existing adapter is unloaded from the Adapters list. (Inherited from AdapterLoaderT.)
Public event | Disposed | Occurs when the class has been disposed. (Inherited from AdapterLoaderT.)
Public event | OperationExecutionException | Occurs when an Exception is encountered while executing a queued operation on one the Adapters. (Inherited from AdapterLoaderT.)
Top
See Also

Reference

ServiceMonitors Class
GSF.ServiceProcess Namespace


ServiceProcess Class

Grid Solutions Framework ServiceProcess Class
Represents a process that executes asynchronously inside a ServiceHelper.
Inheritance Hierarchy
SystemObject
GSF.ServiceProcessServiceProcess

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ServiceProcess : IDisposable,
    IProvideStatus
Public Class ServiceProcess
    Implements IDisposable, IProvideStatus
type ServiceProcess =
    class
        interface IDisposable
        interface IProvideStatus
    end
GSF.ServiceProcess.ServiceProcess = function();

Type.createClass(
    'GSF.ServiceProcess.ServiceProcess',
    null,
    IDisposable,
    GSF.IProvideStatus);
public ref class ServiceProcess : IDisposable,
    IProvideStatus

The ServiceProcess type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceProcess | Initializes a new instance of the ServiceProcess class.
Top
Methods
 | Name | Description
Public method | Abort | Stops the execution of ServiceProcess if it executing.
Public method | Dispose | Releases all the resources used by the ServiceProcess object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceProcess and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ServiceProcess object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnStateChanged | Raises the StateChanged event.
Public method | Start | Starts the execution of ServiceProcess.
Public method | Start(Object) | Starts the execution of ServiceProcess.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to be passed in to the ExecutionMethod.
Public property | CurrentState | Gets the current ServiceProcessState.
Public property | ExecutionMethod | Gets or sets the Delegate that gets invoked when Start is called.
Public property | ExecutionStartTime | Gets the DateTime when execution of ServiceProcess last started.
Public property | ExecutionStopTime | Gets the DateTime when execution of ServiceProcess last completed.
Public property | LastExecutionTime | Gets the Time taken by the ServiceProcess during the last execution.
Public property | Name | Gets or sets the name of the ServiceProcess.
Public property | Status | Gets the descriptive status of the ServiceProcess.
Top
Events
 | Name | Description
Public event | StateChanged | Occurs when the CurrentState of the ServiceProcess changes.
Top
See Also

Reference

GSF.ServiceProcess Namespace
GSF.ServiceProcessServiceHelper


ServiceProcess Constructor

Grid Solutions Framework ServiceProcess Constructor
Initializes a new instance of the ServiceProcess class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceProcess(
    Action<string, Object[]> executionMethod,
    string name,
    params Object[] arguments
)
Public Sub New (
    executionMethod As Action(Of String, Object()),
    name As String,
    ParamArray arguments As Object()
)
new :
        executionMethod : Action<string, Object[]> *
        name : string *
        arguments : Object[] -> ServiceProcess
GSF.ServiceProcess.ServiceProcess = function(executionMethod, name, ... arguments);
public:
ServiceProcess(
    Action<String^, array<Object^>^>^ executionMethod,
    String^ name,
    ... array<Object^>^ arguments
)

Parameters

executionMethod
Type: SystemAction String, Object
Delegate that gets invoked when Start is called.
name
Type: SystemString
Name of the ServiceProcess.
arguments
Type: SystemObject
Arguments to be passed in to the executionMethod.
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess Methods

Grid Solutions Framework ServiceProcess Methods

The ServiceProcess type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Stops the execution of ServiceProcess if it executing.
Public method | Dispose | Releases all the resources used by the ServiceProcess object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceProcess and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ServiceProcess object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnStateChanged | Raises the StateChanged event.
Public method | Start | Starts the execution of ServiceProcess.
Public method | Start(Object) | Starts the execution of ServiceProcess.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Abort Method

Grid Solutions Framework ServiceProcessAbort Method
Stops the execution of ServiceProcess if it executing.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Abort()
Public Sub Abort
member Abort : unit -> unit

function Abort();
public:
void Abort()
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Dispose Method

Grid Solutions Framework ServiceProcessDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ServiceProcess object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceProcess and optionally releases the managed resources.
Top
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Dispose Method

Grid Solutions Framework ServiceProcessDispose Method
Releases all the resources used by the ServiceProcess object.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ServiceProcess Class
Dispose Overload
GSF.ServiceProcess Namespace


ServiceProcess.Dispose Method (Boolean)

Grid Solutions Framework ServiceProcessDispose Method (Boolean)
Releases the unmanaged resources used by the ServiceProcess and optionally releases the managed resources.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ServiceProcess Class
Dispose Overload
GSF.ServiceProcess Namespace


ServiceProcess.Finalize Method

Grid Solutions Framework ServiceProcessFinalize Method
Releases the unmanaged resources before the ServiceProcess object is reclaimed by GC.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.OnStateChanged Method

Grid Solutions Framework ServiceProcessOnStateChanged Method
Raises the StateChanged event.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStateChanged()
Protected Overridable Sub OnStateChanged
abstract OnStateChanged : unit -> unit
override OnStateChanged : unit -> unit
function OnStateChanged();
protected:
virtual void OnStateChanged()
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Start Method

Grid Solutions Framework ServiceProcessStart Method
Overload List
 | Name | Description
Public method | Start | Starts the execution of ServiceProcess.
Public method | Start(Object) | Starts the execution of ServiceProcess.
Top
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Start Method

Grid Solutions Framework ServiceProcessStart Method
Starts the execution of ServiceProcess.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start()
Public Sub Start
member Start : unit -> unit

function Start();
public:
void Start()
See Also

Reference

ServiceProcess Class
Start Overload
GSF.ServiceProcess Namespace


ServiceProcess.Start Method (Object[])

Grid Solutions Framework ServiceProcessStart Method (Object)
Starts the execution of ServiceProcess.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start(
    Object[] arguments
)
Public Sub Start (
    arguments As Object()
)
member Start :
        arguments : Object[] -> unit

function Start(arguments);
public:
void Start(
    array<Object^>^ arguments
)

Parameters

arguments
Type: SystemObject
Arguments to be passed in to the ExecutionMethod.
See Also

Reference

ServiceProcess Class
Start Overload
GSF.ServiceProcess Namespace


ServiceProcess Properties

Grid Solutions Framework ServiceProcess Properties

The ServiceProcess type exposes the following members.

Properties
 | Name | Description
Public property | Arguments | Gets or sets the arguments to be passed in to the ExecutionMethod.
Public property | CurrentState | Gets the current ServiceProcessState.
Public property | ExecutionMethod | Gets or sets the Delegate that gets invoked when Start is called.
Public property | ExecutionStartTime | Gets the DateTime when execution of ServiceProcess last started.
Public property | ExecutionStopTime | Gets the DateTime when execution of ServiceProcess last completed.
Public property | LastExecutionTime | Gets the Time taken by the ServiceProcess during the last execution.
Public property | Name | Gets or sets the name of the ServiceProcess.
Public property | Status | Gets the descriptive status of the ServiceProcess.
Top
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Arguments Property

Grid Solutions Framework ServiceProcessArguments Property
Gets or sets the arguments to be passed in to the ExecutionMethod.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object[] Arguments { get; set; }
Public Property Arguments As Object()
    Get
    Set
member Arguments : Object[] with get, set

function get_Arguments();
function set_Arguments(value);
public:
property array<Object^>^ Arguments {
    array<Object^>^ get ();
    void set (array<Object^>^ value);
}

Property Value

Type: Object
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.CurrentState Property

Grid Solutions Framework ServiceProcessCurrentState Property
Gets the current ServiceProcessState.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceProcessState CurrentState { get; }
Public ReadOnly Property CurrentState As ServiceProcessState
    Get
member CurrentState : ServiceProcessState with get

function get_CurrentState();

public:
property ServiceProcessState CurrentState {
    ServiceProcessState get ();
}

Property Value

Type: ServiceProcessState
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.ExecutionMethod Property

Grid Solutions Framework ServiceProcessExecutionMethod Property
Gets or sets the Delegate that gets invoked when Start is called.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<string, Object[]> ExecutionMethod { get; set; }
Public Property ExecutionMethod As Action(Of String, Object())
    Get
    Set
member ExecutionMethod : Action<string, Object[]> with get, set

function get_ExecutionMethod();
function set_ExecutionMethod(value);
public:
property Action<String^, array<Object^>^>^ ExecutionMethod {
    Action<String^, array<Object^>^>^ get ();
    void set (Action<String^, array<Object^>^>^ value);
}

Property Value

Type: Action String, Object
Remarks
Argument1 gets the Name of the ServiceProcess.
Argument2 gets the Arguments of the ServiceProcess.
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.ExecutionStartTime Property

Grid Solutions Framework ServiceProcessExecutionStartTime Property
Gets the DateTime when execution of ServiceProcess last started.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ExecutionStartTime { get; }
Public ReadOnly Property ExecutionStartTime As DateTime
    Get
member ExecutionStartTime : DateTime with get

function get_ExecutionStartTime();

public:
property DateTime ExecutionStartTime {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.ExecutionStopTime Property

Grid Solutions Framework ServiceProcessExecutionStopTime Property
Gets the DateTime when execution of ServiceProcess last completed.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DateTime ExecutionStopTime { get; }
Public ReadOnly Property ExecutionStopTime As DateTime
    Get
member ExecutionStopTime : DateTime with get

function get_ExecutionStopTime();

public:
property DateTime ExecutionStopTime {
    DateTime get ();
}

Property Value

Type: DateTime
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.LastExecutionTime Property

Grid Solutions Framework ServiceProcessLastExecutionTime Property
Gets the Time taken by the ServiceProcess during the last execution.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time LastExecutionTime { get; }
Public ReadOnly Property LastExecutionTime As Time
    Get
member LastExecutionTime : Time with get

function get_LastExecutionTime();

public:
property Time LastExecutionTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Name Property

Grid Solutions Framework ServiceProcessName Property
Gets or sets the name of the ServiceProcess.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is a null or empty string.
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.Status Property

Grid Solutions Framework ServiceProcessStatus Property
Gets the descriptive status of the ServiceProcess.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess Events

Grid Solutions Framework ServiceProcess Events

The ServiceProcess type exposes the following members.

Events
 | Name | Description
Public event | StateChanged | Occurs when the CurrentState of the ServiceProcess changes.
Top
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcess.StateChanged Event

Grid Solutions Framework ServiceProcessStateChanged Event
Occurs when the CurrentState of the ServiceProcess changes.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler StateChanged
Public Event StateChanged As EventHandler
member StateChanged : IEvent<EventHandler,
    EventArgs>

function add_StateChanged(value);
function remove_StateChanged(value);
public:
 event EventHandler^ StateChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ServiceProcess Class
GSF.ServiceProcess Namespace


ServiceProcessState Enumeration

Grid Solutions Framework ServiceProcessState Enumeration
Indicates the current state of ServiceProcess.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ServiceProcessState
Public Enumeration ServiceProcessState
type ServiceProcessState
GSF.ServiceProcess.ServiceProcessState = function();
GSF.ServiceProcess.ServiceProcessState.createEnum('GSF.ServiceProcess.ServiceProcessState', false);
public enum class ServiceProcessState
Members
Member name | Value | Description
Unprocessed | 0 | ServiceProcess has not been started.
Processing | 1 | ServiceProcess is currently executing.
Processed | 2 | ServiceProcess has completed processing.
Aborted | 3 | ServiceProcess was aborted.
Exception | 4 | ServiceProcess stopped due to exception.
See Also

Reference

GSF.ServiceProcess Namespace


ServiceResponse Class

Grid Solutions Framework ServiceResponse Class
Represents a response sent by the ServiceHelper to a ClientRequest from the ClientHelper.
Inheritance Hierarchy
SystemObject
GSF.ServiceProcessServiceResponse

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class ServiceResponse : ISerializable
<SerializableAttribute>
Public Class ServiceResponse
    Implements ISerializable
[<SerializableAttribute>]
type ServiceResponse =
    class
        interface ISerializable
    end
GSF.ServiceProcess.ServiceResponse = function();

Type.createClass(
    'GSF.ServiceProcess.ServiceResponse',
    null,
    ISerializable);
[SerializableAttribute]
public ref class ServiceResponse : ISerializable

The ServiceResponse type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceResponse | Initializes a new instance of the ServiceResponse class.
Public method | ServiceResponse(String) | Initializes a new instance of the ServiceResponse class.
Protected method | ServiceResponse(SerializationInfo, StreamingContext) | Creates a new ClientRequest from serialization parameters.
Public method | ServiceResponse(String, String) | Initializes a new instance of the ServiceResponse class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Attachments | Gets a list of serializable attachments of the ServiceResponse.
Public property | Message | Gets or sets the plain-text message associated with the ServiceResponse.
Public property | Type | Gets or sets the plain-text type of the ServiceResponse.
Top
See Also

Reference

GSF.ServiceProcess Namespace
GSF.ServiceProcessServiceHelper
GSF.ServiceProcessClientHelper
GSF.ServiceProcessClientRequest


ServiceResponse Constructor

Grid Solutions Framework ServiceResponse Constructor
Overload List
 | Name | Description
Public method | ServiceResponse | Initializes a new instance of the ServiceResponse class.
Public method | ServiceResponse(String) | Initializes a new instance of the ServiceResponse class.
Protected method | ServiceResponse(SerializationInfo, StreamingContext) | Creates a new ClientRequest from serialization parameters.
Public method | ServiceResponse(String, String) | Initializes a new instance of the ServiceResponse class.
Top
See Also

Reference

ServiceResponse Class
GSF.ServiceProcess Namespace


ServiceResponse Constructor

Grid Solutions Framework ServiceResponse Constructor
Initializes a new instance of the ServiceResponse class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceResponse()
Public Sub New
new : unit -> ServiceResponse
GSF.ServiceProcess.ServiceResponse = function();
public:
ServiceResponse()
See Also

Reference

ServiceResponse Class
ServiceResponse Overload
GSF.ServiceProcess Namespace


ServiceResponse Constructor (String)

Grid Solutions Framework ServiceResponse Constructor (String)
Initializes a new instance of the ServiceResponse class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceResponse(
    string type
)
Public Sub New (
    type As String
)
new :
        type : string -> ServiceResponse
GSF.ServiceProcess.ServiceResponse = function(type);
public:
ServiceResponse(
    String^ type
)

Parameters

type
Type: SystemString
Type of the ServiceResponse in plain text.
See Also

Reference

ServiceResponse Class
ServiceResponse Overload
GSF.ServiceProcess Namespace


ServiceResponse Constructor (SerializationInfo, StreamingContext)

Grid Solutions Framework ServiceResponse Constructor (SerializationInfo, StreamingContext)
Creates a new ClientRequest from serialization parameters.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ServiceResponse(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New (
    info As SerializationInfo,
    context As StreamingContext
)
new :
        info : SerializationInfo *
        context : StreamingContext -> ServiceResponse
GSF.ServiceProcess.ServiceResponse = function(info, context);
protected:
ServiceResponse(
    SerializationInfo^ info,
    StreamingContext context
)

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo with populated with data.
context
Type: System.Runtime.SerializationStreamingContext
The source StreamingContext for this deserialization.
See Also

Reference

ServiceResponse Class
ServiceResponse Overload
GSF.ServiceProcess Namespace


ServiceResponse Constructor (String, String)

Grid Solutions Framework ServiceResponse Constructor (String, String)
Initializes a new instance of the ServiceResponse class.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceResponse(
    string type,
    string message
)
Public Sub New (
    type As String,
    message As String
)
new :
        type : string *
        message : string -> ServiceResponse
GSF.ServiceProcess.ServiceResponse = function(type, message);
public:
ServiceResponse(
    String^ type,
    String^ message
)

Parameters

type
Type: SystemString
Type of the ServiceResponse in plain-text.
message
Type: SystemString
Message associated with the ServiceResponse.
See Also

Reference

ServiceResponse Class
ServiceResponse Overload
GSF.ServiceProcess Namespace


ServiceResponse Methods

Grid Solutions Framework ServiceResponse Methods

The ServiceResponse type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo with the data needed to serialize the target object.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceResponse Class
GSF.ServiceProcess Namespace


ServiceResponse.GetObjectData Method

Grid Solutions Framework ServiceResponseGetObjectData Method
Populates a SerializationInfo with the data needed to serialize the target object.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Sub GetObjectData (
    info As SerializationInfo,
    context As StreamingContext
)
abstract GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
override GetObjectData :
        info : SerializationInfo *
        context : StreamingContext -> unit
function GetObjectData(info, context);
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) sealed

Parameters

info
Type: System.Runtime.SerializationSerializationInfo
The SerializationInfo to populate with data.
context
Type: System.Runtime.SerializationStreamingContext
The destination (see StreamingContext) for this serialization.

Implements

ISerializableGetObjectData(SerializationInfo, StreamingContext)
Exceptions
Exception | Condition
SecurityException | The caller does not have the required permission.
See Also

Reference

ServiceResponse Class
GSF.ServiceProcess Namespace


ServiceResponse Properties

Grid Solutions Framework ServiceResponse Properties

The ServiceResponse type exposes the following members.

Properties
 | Name | Description
Public property | Attachments | Gets a list of serializable attachments of the ServiceResponse.
Public property | Message | Gets or sets the plain-text message associated with the ServiceResponse.
Public property | Type | Gets or sets the plain-text type of the ServiceResponse.
Top
See Also

Reference

ServiceResponse Class
GSF.ServiceProcess Namespace


ServiceResponse.Attachments Property

Grid Solutions Framework ServiceResponseAttachments Property
Gets a list of serializable attachments of the ServiceResponse.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<Object> Attachments { get; }
Public ReadOnly Property Attachments As List(Of Object)
    Get
member Attachments : List<Object> with get

function get_Attachments();

public:
property List<Object^>^ Attachments {
    List<Object^>^ get ();
}

Property Value

Type: List Object
See Also

Reference

ServiceResponse Class
GSF.ServiceProcess Namespace


ServiceResponse.Message Property

Grid Solutions Framework ServiceResponseMessage Property
Gets or sets the plain-text message associated with the ServiceResponse.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Message { get; set; }
Public Property Message As String
    Get
    Set
member Message : string with get, set

function get_Message();
function set_Message(value);
public:
property String^ Message {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ServiceResponse Class
GSF.ServiceProcess Namespace


ServiceResponse.Type Property

Grid Solutions Framework ServiceResponseType Property
Gets or sets the plain-text type of the ServiceResponse.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Type { get; set; }
Public Property Type As String
    Get
    Set
member Type : string with get, set

function get_Type();
function set_Type(value);
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentNullException | The value being assigned is either a null or empty string.
See Also

Reference

ServiceResponse Class
GSF.ServiceProcess Namespace


ServiceState Enumeration

Grid Solutions Framework ServiceState Enumeration
Indicates the state of a Windows Service.

Namespace: GSF.ServiceProcess
Assembly: GSF.ServiceProcess (in GSF.ServiceProcess.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ServiceState
Public Enumeration ServiceState
type ServiceState
GSF.ServiceProcess.ServiceState = function();
GSF.ServiceProcess.ServiceState.createEnum('GSF.ServiceProcess.ServiceState', false);
public enum class ServiceState
Members
Member name | Value | Description
Started | 0 | Service has started.
Stopped | 1 | Service has stopped.
Paused | 2 | Service has paused.
Resumed | 3 | Service has resumed.
Shutdown | 4 | Service has shutdown.
See Also

Reference

GSF.ServiceProcess Namespace


GSF.Threading Namespace

Grid Solutions Framework GSF.Threading Namespace
Contains classes used to define managed threads that can be used for debugging threads by providing automatic tracking, total thread runtime and the ability to run threads in alternate execution contexts.
Classes
 | Class | Description
Public class | InterprocessLock | Defines helper methods related to inter-process locking.
Public class | InterprocessReaderWriterLock | Represents an inter-process reader/writer lock using Semaphore and Mutex native locking mechanisms.
Public class | LogicalThread | Represents a thread of execution to which actions can be dispatched from other threads.
Public class | LogicalThreadLocalT | Represents a slot in the thread local memory space of each logical thread.
Public class | LogicalThreadOperation | Synchronized operation that executes on a logical thread.
Public class | LogicalThreadScheduler | Manages synchronization of actions by dispatching actions to logical threads to be processed synchronously.
Public class | LogicalThreadStatistics | Represents a set of statistics gathered about the execution time of actions on a logical thread.
Public class | LongSynchronizedOperation | Represents a long-running synchronized operation that cannot run while it is already in progress.
Public class | ManagedThread | Defines a managed thread
Public class | ManagedThreadPool | Defines a managed thread pool
Public class | ManagedThreads | Maintains a reference to all managed threads
Public class | MixedSynchronizedOperation | Represents an operation that cannot run while it is already in progress.
Public class | ReaderWriterSpinLock | Represents a fast, lightweight reader/writer lock that uses spinning to perform locking. No recursive acquires or upgradable locks are allowed (i.e., all entered locks must be exited before entering another lock).
Public class | ScheduledTask | Represents a way to schedule a task to be executed on a separate thread immediately or after a given time delay.
Public class | ShortSynchronizedOperation | Represents a short-running synchronized operation that cannot run while it is already in progress.
Public class | SynchronizedOperationBase | Base class for operations that cannot run while they is already in progress.
Public class | WeakAction | Provides a weak referenced action delegate.
Public class | WeakActionT | Provides a weak referenced action delegate.
Interfaces
 | Interface | Description
Public interface | ISynchronizedOperation | Represents an operation that cannot run while it is already in progress.
Enumerations
 | Enumeration | Description
Public enumeration | AsynchronousExecutionMode | Indicates modes of execution for the MixedSynchronizedOperation.
Public enumeration | ScheduledTaskRunningReason | Metadata about why this worker was called.
Public enumeration | SynchronizedOperationType | Represents the available types of synchronized operations.
Public enumeration | ThreadingMode | Specifies the threading mode to use for the ScheduledTask
Public enumeration | ThreadStatus | Managed Thread States
Public enumeration | ThreadType | Managed Thread Types


AsynchronousExecutionMode Enumeration

Grid Solutions Framework AsynchronousExecutionMode Enumeration
Indicates modes of execution for the MixedSynchronizedOperation.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum AsynchronousExecutionMode
Public Enumeration AsynchronousExecutionMode
type AsynchronousExecutionMode
GSF.Threading.AsynchronousExecutionMode = function();
GSF.Threading.AsynchronousExecutionMode.createEnum('GSF.Threading.AsynchronousExecutionMode', false);
public enum class AsynchronousExecutionMode
Members
Member name | Value | Description
Short | 0 | Executes asynchronous operations on the thread pool (same as ShortSynchronizedOperation).
Long | 1 | Executes asynchronous operations on a dedicated background thread (same as LongSynchronizedOperation).
See Also

Reference

GSF.Threading Namespace


InterprocessLock Class

Grid Solutions Framework InterprocessLock Class
Defines helper methods related to inter-process locking.
Inheritance Hierarchy
SystemObject
GSF.ThreadingInterprocessLock

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class InterprocessLock
Public NotInheritable Class InterprocessLock
[<AbstractClassAttribute>]
[<SealedAttribute>]
type InterprocessLock =  class end
GSF.Threading.InterprocessLock = function();

Type.createClass(
    'GSF.Threading.InterprocessLock');
public ref class InterprocessLock abstract sealed

The InterprocessLock type exposes the following members.

Methods
Name | Description
GetNamedMutex | Gets a uniquely named inter-process Mutex associated with the specified name that identifies a source object needing concurrency locking.
GetNamedSemaphore | Gets a uniquely named inter-process Semaphore associated with the specified name that identifies a source object needing concurrency locking.
Top
See Also

Reference

GSF.Threading Namespace


InterprocessLock Methods

Grid Solutions Framework InterprocessLock Methods

The InterprocessLock type exposes the following members.

Methods
Name | Description
GetNamedMutex | Gets a uniquely named inter-process Mutex associated with the specified name that identifies a source object needing concurrency locking.
GetNamedSemaphore | Gets a uniquely named inter-process Semaphore associated with the specified name that identifies a source object needing concurrency locking.
Top
See Also

Reference

InterprocessLock Class
GSF.Threading Namespace


InterprocessLock.GetNamedMutex Method

Grid Solutions Framework InterprocessLockGetNamedMutex Method
Gets a uniquely named inter-process Mutex associated with the specified name that identifies a source object needing concurrency locking.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mutex GetNamedMutex(
    string name
)
Public Shared Function GetNamedMutex (
    name As String
) As Mutex
static member GetNamedMutex :
        name : string -> Mutex

GSF.Threading.InterprocessLock.GetNamedMutex = function(name);
public:
static Mutex^ GetNamedMutex(
    String^ name
)

Parameters

name
Type: SystemString
Identifying name of source object needing concurrency locking (e.g., a path and file name).

Return Value

Type: Mutex
A uniquely named inter-process Mutex specific to name; Mutex is created if it does not exist.
Exceptions
Exception | Condition
ArgumentNullException | Argument name cannot be empty, null or white space.
UnauthorizedAccessException | The named mutex exists, but the user does not have the minimum needed security access rights to use it.
Remarks

This function uses a hash of the name when creating the Mutex, not the actual name - this way restrictions on the name length do not need to be a user concern. All processes needing an inter-process Mutex need to use this same function to ensure access to the same Mutex.

The name can be a string of any length (must not be empty, null or white space) and is not case-sensitive. All hashes of the name used to create the global Mutex are first converted to lower case.

The Mutex created is "Global" meaning that it will be accessible to all active application sessions including terminal service sessions. This is accomplished internally by prefixing the Mutex name with "Global\"; it is not necessary for the user to be concerned with the length or contents of the name in this method as long as the same name is used for each application. Do not use this helper function if you need to create a specifically named or non-global Mutex, such as when you need to interact with another application using a Mutex that does not use this function.

See Also

Reference

InterprocessLock Class
GSF.Threading Namespace


InterprocessLock.GetNamedSemaphore Method

Grid Solutions Framework InterprocessLockGetNamedSemaphore Method
Gets a uniquely named inter-process Semaphore associated with the specified name that identifies a source object needing concurrency locking.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Semaphore GetNamedSemaphore(
    string name,
    int maximumCount = 10,
    int initialCount = -1
)
Public Shared Function GetNamedSemaphore (
    name As String,
    Optional maximumCount As Integer = 10,
    Optional initialCount As Integer = -1
) As Semaphore
static member GetNamedSemaphore :
        name : string *
        ?maximumCount : int *
        ?initialCount : int
(* Defaults:
        let _maximumCount = defaultArg maximumCount 10
        let _initialCount = defaultArg initialCount -1
*)
-> Semaphore

GSF.Threading.InterprocessLock.GetNamedSemaphore = function(name, maximumCount, initialCount);
public:
static Semaphore^ GetNamedSemaphore(
    String^ name,
    int maximumCount = 10,
    int initialCount = -1
)

Parameters

name
Type: SystemString
Identifying name of source object needing concurrency locking (e.g., a path and file name).
maximumCount (Optional)
Type: SystemInt32
The maximum number of requests for the semaphore that can be granted concurrently.
initialCount (Optional)
Type: SystemInt32
The initial number of requests for the semaphore that can be granted concurrently, or -1 to default to maximumCount.

Return Value

Type: Semaphore
A uniquely named inter-process Semaphore specific to name; Semaphore is created if it does not exist.
Exceptions
Exception | Condition
ArgumentNullException | Argument name cannot be empty, null or white space.
UnauthorizedAccessException | The named semaphore exists, but the user does not have the minimum needed security access rights to use it.
Remarks

This function uses a hash of the name when creating the Semaphore, not the actual name - this way restrictions on the name length do not need to be a user concern. All processes needing an inter-process Semaphore need to use this same function to ensure access to the same Semaphore.

The name can be a string of any length (must not be empty, null or white space) and is not case-sensitive. All hashes of the name used to create the global Semaphore are first converted to lower case.

The Semaphore created is "Global" meaning that it will be accessible to all active application sessions including terminal service sessions. This is accomplished internally by prefixing the Semaphore name with "Global\"; it is not necessary for the user to be concerned with the length or contents of the name in this method as long as the same name is used for each application. Do not use this helper function if you need to create a specifically named or non-global Semaphore, such as when you need to interact with another application using a Semaphore that does not use this function.

See Also

Reference

InterprocessLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock Class

Grid Solutions Framework InterprocessReaderWriterLock Class
Represents an inter-process reader/writer lock using Semaphore and Mutex native locking mechanisms.
Inheritance Hierarchy
SystemObject
GSF.ThreadingInterprocessReaderWriterLock

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class InterprocessReaderWriterLock : IDisposable
Public Class InterprocessReaderWriterLock
    Implements IDisposable
type InterprocessReaderWriterLock =
    class
        interface IDisposable
    end
GSF.Threading.InterprocessReaderWriterLock = function();

Type.createClass(
    'GSF.Threading.InterprocessReaderWriterLock',
    null,
    IDisposable);
public ref class InterprocessReaderWriterLock : IDisposable

The InterprocessReaderWriterLock type exposes the following members.

Constructors
 | Name | Description
Public method | InterprocessReaderWriterLock(String) | Creates a new instance of the InterprocessReaderWriterLock associated with the specified name that identifies a source object needing concurrency locking.
Public method | InterprocessReaderWriterLock(String, Int32) | Creates a new instance of the InterprocessReaderWriterLock associated with the specified name that identifies a source object needing concurrency locking.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessReaderWriterLock object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessReaderWriterLock object and optionally releases the managed resources.
Public method | EnterReadLock | Tries to enter the lock in read mode.
Public method | EnterWriteLock | Tries to enter the lock in write mode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExitReadLock | Exits read mode and returns the prior read lock count.
Public method | ExitWriteLock | Exits write mode.
Protected method | Finalize | Releases the unmanaged resources before the InterprocessReaderWriterLock object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryEnterReadLock | Tries to enter the lock in read mode, with an optional time-out.
Public method | TryEnterWriteLock | Tries to enter the lock in write mode, with an optional time-out.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultMaximumConcurrentLocks | Default maximum concurrent locks allowed for InterprocessReaderWriterLock.
Top
Properties
 | Name | Description
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed.
Top
See Also

Reference

GSF.Threading Namespace


InterprocessReaderWriterLock Constructor

Grid Solutions Framework InterprocessReaderWriterLock Constructor
Overload List
 | Name | Description
Public method | InterprocessReaderWriterLock(String) | Creates a new instance of the InterprocessReaderWriterLock associated with the specified name that identifies a source object needing concurrency locking.
Public method | InterprocessReaderWriterLock(String, Int32) | Creates a new instance of the InterprocessReaderWriterLock associated with the specified name that identifies a source object needing concurrency locking.
Top
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock Constructor (String)

Grid Solutions Framework InterprocessReaderWriterLock Constructor (String)
Creates a new instance of the InterprocessReaderWriterLock associated with the specified name that identifies a source object needing concurrency locking.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InterprocessReaderWriterLock(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> InterprocessReaderWriterLock
GSF.Threading.InterprocessReaderWriterLock = function(name);
public:
InterprocessReaderWriterLock(
    String^ name
)

Parameters

name
Type: SystemString
Identifying name of source object needing concurrency locking (e.g., a path and file name).
See Also

Reference

InterprocessReaderWriterLock Class
InterprocessReaderWriterLock Overload
GSF.Threading Namespace


InterprocessReaderWriterLock Constructor (String, Int32)

Grid Solutions Framework InterprocessReaderWriterLock Constructor (String, Int32)
Creates a new instance of the InterprocessReaderWriterLock associated with the specified name that identifies a source object needing concurrency locking.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InterprocessReaderWriterLock(
    string name,
    int maximumConcurrentLocks
)
Public Sub New (
    name As String,
    maximumConcurrentLocks As Integer
)
new :
        name : string *
        maximumConcurrentLocks : int -> InterprocessReaderWriterLock
GSF.Threading.InterprocessReaderWriterLock = function(name, maximumConcurrentLocks);
public:
InterprocessReaderWriterLock(
    String^ name,
    int maximumConcurrentLocks
)

Parameters

name
Type: SystemString
Identifying name of source object needing concurrency locking (e.g., a path and file name).
maximumConcurrentLocks
Type: SystemInt32
Maximum concurrent reader locks to allow.
Remarks
If more reader locks are requested than the maximumConcurrentLocks, excess reader locks will simply wait until a lock is available (i.e., one of the existing reads completes).
See Also

Reference

InterprocessReaderWriterLock Class
InterprocessReaderWriterLock Overload
GSF.Threading Namespace


InterprocessReaderWriterLock Fields

Grid Solutions Framework InterprocessReaderWriterLock Fields

The InterprocessReaderWriterLock type exposes the following members.

Fields
Name | Description
DefaultMaximumConcurrentLocks | Default maximum concurrent locks allowed for InterprocessReaderWriterLock.
Top
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.DefaultMaximumConcurrentLocks Field

Grid Solutions Framework InterprocessReaderWriterLockDefaultMaximumConcurrentLocks Field
Default maximum concurrent locks allowed for InterprocessReaderWriterLock.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMaximumConcurrentLocks
Public Const DefaultMaximumConcurrentLocks As Integer
static val mutable DefaultMaximumConcurrentLocks: int
var GSF.Threading.InterprocessReaderWriterLock.DefaultMaximumConcurrentLocks
public:
literal int DefaultMaximumConcurrentLocks

Field Value

Type: Int32
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock Methods

Grid Solutions Framework InterprocessReaderWriterLock Methods

The InterprocessReaderWriterLock type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessReaderWriterLock object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessReaderWriterLock object and optionally releases the managed resources.
Public method | EnterReadLock | Tries to enter the lock in read mode.
Public method | EnterWriteLock | Tries to enter the lock in write mode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExitReadLock | Exits read mode and returns the prior read lock count.
Public method | ExitWriteLock | Exits write mode.
Protected method | Finalize | Releases the unmanaged resources before the InterprocessReaderWriterLock object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryEnterReadLock | Tries to enter the lock in read mode, with an optional time-out.
Public method | TryEnterWriteLock | Tries to enter the lock in write mode, with an optional time-out.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.Dispose Method

Grid Solutions Framework InterprocessReaderWriterLockDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the InterprocessReaderWriterLock object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InterprocessReaderWriterLock object and optionally releases the managed resources.
Top
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.Dispose Method

Grid Solutions Framework InterprocessReaderWriterLockDispose Method
Releases all the resources used by the InterprocessReaderWriterLock object.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

InterprocessReaderWriterLock Class
Dispose Overload
GSF.Threading Namespace


InterprocessReaderWriterLock.Dispose Method (Boolean)

Grid Solutions Framework InterprocessReaderWriterLockDispose Method (Boolean)
Releases the unmanaged resources used by the InterprocessReaderWriterLock object and optionally releases the managed resources.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

InterprocessReaderWriterLock Class
Dispose Overload
GSF.Threading Namespace


InterprocessReaderWriterLock.EnterReadLock Method

Grid Solutions Framework InterprocessReaderWriterLockEnterReadLock Method
Tries to enter the lock in read mode.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EnterReadLock()
Public Sub EnterReadLock
member EnterReadLock : unit -> unit

function EnterReadLock();
public:
void EnterReadLock()
Remarks
Upon successful acquisition of a read lock, use the finally block of a try/finally statement to call ExitReadLock. One ExitReadLock should be called for each EnterReadLock or TryEnterReadLock(Int32).
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.EnterWriteLock Method

Grid Solutions Framework InterprocessReaderWriterLockEnterWriteLock Method
Tries to enter the lock in write mode.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EnterWriteLock()
Public Sub EnterWriteLock
member EnterWriteLock : unit -> unit

function EnterWriteLock();
public:
void EnterWriteLock()
Remarks
Upon successful acquisition of a write lock, use the finally block of a try/finally statement to call ExitWriteLock. One ExitWriteLock should be called for each EnterWriteLock or TryEnterWriteLock(Int32).
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.ExitReadLock Method

Grid Solutions Framework InterprocessReaderWriterLockExitReadLock Method
Exits read mode and returns the prior read lock count.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ExitReadLock()
Public Function ExitReadLock As Integer
member ExitReadLock : unit -> int

function ExitReadLock();
public:
int ExitReadLock()

Return Value

Type: Int32

[Missing <returns> documentation for "M:GSF.Threading.InterprocessReaderWriterLock.ExitReadLock"]

Remarks
Upon successful acquisition of a read lock, use the finally block of a try/finally statement to call ExitReadLock. One ExitReadLock should be called for each EnterReadLock or TryEnterReadLock(Int32).
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.ExitWriteLock Method

Grid Solutions Framework InterprocessReaderWriterLockExitWriteLock Method
Exits write mode.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ExitWriteLock()
Public Sub ExitWriteLock
member ExitWriteLock : unit -> unit

function ExitWriteLock();
public:
void ExitWriteLock()
Remarks
Upon successful acquisition of a write lock, use the finally block of a try/finally statement to call ExitWriteLock. One ExitWriteLock should be called for each EnterWriteLock or TryEnterWriteLock(Int32).
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.Finalize Method

Grid Solutions Framework InterprocessReaderWriterLockFinalize Method
Releases the unmanaged resources before the InterprocessReaderWriterLock object is reclaimed by GC.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.TryEnterReadLock Method

Grid Solutions Framework InterprocessReaderWriterLockTryEnterReadLock Method
Tries to enter the lock in read mode, with an optional time-out.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryEnterReadLock(
    int millisecondsTimeout
)
Public Function TryEnterReadLock (
    millisecondsTimeout As Integer
) As Boolean
member TryEnterReadLock :
        millisecondsTimeout : int -> bool

function TryEnterReadLock(millisecondsTimeout);
public:
bool TryEnterReadLock(
    int millisecondsTimeout
)

Parameters

millisecondsTimeout
Type: SystemInt32
The number of milliseconds to wait, or -1 (Infinite) to wait indefinitely.

Return Value

Type: Boolean
true if the calling thread entered read mode, otherwise, false.
Remarks

Upon successful acquisition of a read lock, use the finally block of a try/finally statement to call ExitReadLock. One ExitReadLock should be called for each EnterReadLock or TryEnterReadLock(Int32).

Note that this function may wait as long as 2 * millisecondsTimeout since the function first waits for synchronous access to the semaphore, then waits again on an available semaphore slot.

See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.TryEnterWriteLock Method

Grid Solutions Framework InterprocessReaderWriterLockTryEnterWriteLock Method
Tries to enter the lock in write mode, with an optional time-out.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryEnterWriteLock(
    int millisecondsTimeout
)
Public Function TryEnterWriteLock (
    millisecondsTimeout As Integer
) As Boolean
member TryEnterWriteLock :
        millisecondsTimeout : int -> bool

function TryEnterWriteLock(millisecondsTimeout);
public:
bool TryEnterWriteLock(
    int millisecondsTimeout
)

Parameters

millisecondsTimeout
Type: SystemInt32
The number of milliseconds to wait, or -1 (Infinite) to wait indefinitely.

Return Value

Type: Boolean
true if the calling thread entered write mode, otherwise, false.
Remarks

Upon successful acquisition of a write lock, use the finally block of a try/finally statement to call ExitWriteLock. One ExitWriteLock should be called for each EnterWriteLock or TryEnterWriteLock(Int32).

Note that this function may wait as long as 2 * millisecondsTimeout since the function first waits for synchronous access to the semaphore, then waits again on an available semaphore slot.

See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock Properties

Grid Solutions Framework InterprocessReaderWriterLock Properties

The InterprocessReaderWriterLock type exposes the following members.

Properties
 | Name | Description
Public property | MaximumConcurrentLocks | Gets the maximum concurrent reader locks allowed.
Top
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


InterprocessReaderWriterLock.MaximumConcurrentLocks Property

Grid Solutions Framework InterprocessReaderWriterLockMaximumConcurrentLocks Property
Gets the maximum concurrent reader locks allowed.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaximumConcurrentLocks { get; }
Public ReadOnly Property MaximumConcurrentLocks As Integer
    Get
member MaximumConcurrentLocks : int with get

function get_MaximumConcurrentLocks();

public:
property int MaximumConcurrentLocks {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

InterprocessReaderWriterLock Class
GSF.Threading Namespace


ISynchronizedOperation Interface

Grid Solutions Framework ISynchronizedOperation Interface
Represents an operation that cannot run while it is already in progress.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ISynchronizedOperation
Public Interface ISynchronizedOperation
type ISynchronizedOperation =  interface end
GSF.Threading.ISynchronizedOperation = function();
GSF.Threading.ISynchronizedOperation.createInterface('GSF.Threading.ISynchronizedOperation');
public interface class ISynchronizedOperation

The ISynchronizedOperation type exposes the following members.

Methods
 | Name | Description
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running.
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running.
Top
Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed.
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action.
Top
See Also

Reference

GSF.Threading Namespace


ISynchronizedOperation Methods

Grid Solutions Framework ISynchronizedOperation Methods

The ISynchronizedOperation type exposes the following members.

Methods
 | Name | Description
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running.
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running.
Top
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.Run Method

Grid Solutions Framework ISynchronizedOperationRun Method
Executes the action on this thread or marks the operation as pending if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Run()
Sub Run
abstract Run : unit -> unit

function Run();
void Run()
Remarks

When the operation is marked as pending, it will run again after the operation that is currently running has completed. This is useful if an update has invalidated the operation that is currently running and will therefore need to be run again.

This method does not guarantee that control will be returned to the thread that called it. If other threads continuously mark the operation as pending, this thread will continue to run the operation indefinitely.

See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.RunOnce Method

Grid Solutions Framework ISynchronizedOperationRunOnce Method
Executes the action on this thread or marks the operation as pending if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void RunOnce()
Sub RunOnce
abstract RunOnce : unit -> unit

function RunOnce();
void RunOnce()
Remarks
When the operation is marked as pending, it will run again after the operation that is currently running has completed. This is useful if an update has invalidated the operation that is currently running and will therefore need to be run again.
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.RunOnceAsync Method

Grid Solutions Framework ISynchronizedOperationRunOnceAsync Method
Executes the action on another thread or marks the operation as pending if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void RunOnceAsync()
Sub RunOnceAsync
abstract RunOnceAsync : unit -> unit

function RunOnceAsync();
void RunOnceAsync()
Remarks
When the operation is marked as pending, it will run again after the operation that is currently running has completed. This is useful if an update has invalidated the operation that is currently running and will therefore need to be run again.
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.TryRun Method

Grid Solutions Framework ISynchronizedOperationTryRun Method
Attempts to execute the action on this thread. Does nothing if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void TryRun()
Sub TryRun
abstract TryRun : unit -> unit

function TryRun();
void TryRun()
Remarks
This method does not guarantee that control will be returned to the thread that called it. If other threads continuously mark the operation as pending, this thread will continue to run the operation indefinitely.
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.TryRunOnce Method

Grid Solutions Framework ISynchronizedOperationTryRunOnce Method
Attempts to execute the action on this thread. Does nothing if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void TryRunOnce()
Sub TryRunOnce
abstract TryRunOnce : unit -> unit

function TryRunOnce();
void TryRunOnce()
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.TryRunOnceAsync Method

Grid Solutions Framework ISynchronizedOperationTryRunOnceAsync Method
Attempts to execute the action on another thread. Does nothing if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void TryRunOnceAsync()
Sub TryRunOnceAsync
abstract TryRunOnceAsync : unit -> unit

function TryRunOnceAsync();
void TryRunOnceAsync()
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation Properties

Grid Solutions Framework ISynchronizedOperation Properties

The ISynchronizedOperation type exposes the following members.

Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed.
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action.
Top
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.IsPending Property

Grid Solutions Framework ISynchronizedOperationIsPending Property
Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool IsPending { get; }
ReadOnly Property IsPending As Boolean
    Get
abstract IsPending : bool with get

function get_IsPending();

property bool IsPending {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


ISynchronizedOperation.IsRunning Property

Grid Solutions Framework ISynchronizedOperationIsRunning Property
Gets a value to indicate whether the synchronized operation is currently executing its action.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool IsRunning { get; }
ReadOnly Property IsRunning As Boolean
    Get
abstract IsRunning : bool with get

function get_IsRunning();

property bool IsRunning {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ISynchronizedOperation Interface
GSF.Threading Namespace


LogicalThread Class

Grid Solutions Framework LogicalThread Class
Represents a thread of execution to which actions can be dispatched from other threads.
Inheritance Hierarchy
SystemObject
GSF.ThreadingLogicalThread

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LogicalThread
Public Class LogicalThread
type LogicalThread =  class end
GSF.Threading.LogicalThread = function();

Type.createClass(
    'GSF.Threading.LogicalThread');
public ref class LogicalThread

The LogicalThread type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalThread | Creates a new instance of the LogicalThread class.
Top
Methods
 | Name | Description
Public method | Clear | Clears all actions from the logical thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push | Pushes an action to the logical thread.
Public method | SampleStatistics | Samples the statistics, providing current statistic values and resetting statistic counters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
 | CurrentThread | Gets the logical thread that is currently executing.
Public property | HasAction | Gets a flag that indicates whether the logical thread has any unprocessed actions left in its queue.
Top
Events
 | Name | Description
Public event | UnhandledException | Handler for unhandled exceptions on the thread.
Top
Remarks

This class provides a simple alternative to synchronization primitives such as wait handles and locks. Actions dispatched to a logical thread will be processed synchronously as though it was executed as consecutive method calls. All such actions can be dispatched from any thread in the system so method calls coming from multiple threads can be easily synchronized without locks, loops, wait handles, or timeouts.

Note that the LogicalThreadScheduler implements its own thread pool to execute tasks pushed to logical threads. Executing long-running processes or using synchronization primitives with high contention or long timeouts can hinder the logical thread scheduler's ability to schedule the actions of other logical threads. Like other thread pool implementations, you can mitigate this by increasing the maximum thread count of the logical thread scheduler, however it is recommended to avoid using synchronization primitives and instead synchronize those operations by running them as separate actions on the same logical thread.

See Also

Reference

GSF.Threading Namespace


LogicalThread Constructor

Grid Solutions Framework LogicalThread Constructor
Creates a new instance of the LogicalThread class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThread()
Public Sub New
new : unit -> LogicalThread
GSF.Threading.LogicalThread = function();
public:
LogicalThread()
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread Methods

Grid Solutions Framework LogicalThread Methods

The LogicalThread type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears all actions from the logical thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Push | Pushes an action to the logical thread.
Public method | SampleStatistics | Samples the statistics, providing current statistic values and resetting statistic counters.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread.Clear Method

Grid Solutions Framework LogicalThreadClear Method
Clears all actions from the logical thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread.Push Method

Grid Solutions Framework LogicalThreadPush Method
Pushes an action to the logical thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Push(
    Action action
)
Public Sub Push (
    action As Action
)
member Push :
        action : Action -> unit

function Push(action);
public:
void Push(
    Action^ action
)

Parameters

action
Type: SystemAction
The action to be executed on this thread.
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread.SampleStatistics Method

Grid Solutions Framework LogicalThreadSampleStatistics Method
Samples the statistics, providing current statistic values and resetting statistic counters.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThreadStatistics SampleStatistics()
Public Function SampleStatistics As LogicalThreadStatistics
member SampleStatistics : unit -> LogicalThreadStatistics

function SampleStatistics();
public:
LogicalThreadStatistics^ SampleStatistics()

Return Value

Type: LogicalThreadStatistics
The current statistic values.
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread Properties

Grid Solutions Framework LogicalThread Properties

The LogicalThread type exposes the following members.

Properties
 | Name | Description
 | CurrentThread | Gets the logical thread that is currently executing.
Public property | HasAction | Gets a flag that indicates whether the logical thread has any unprocessed actions left in its queue.
Top
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread.CurrentThread Property

Grid Solutions Framework LogicalThreadCurrentThread Property
Gets the logical thread that is currently executing.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static LogicalThread CurrentThread { get; }
Public Shared ReadOnly Property CurrentThread As LogicalThread
    Get
static member CurrentThread : LogicalThread with get

GSF.Threading.LogicalThread.get_CurrentThread = function();

public:
static property LogicalThread^ CurrentThread {
    LogicalThread^ get ();
}

Property Value

Type: LogicalThread
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread.HasAction Property

Grid Solutions Framework LogicalThreadHasAction Property
Gets a flag that indicates whether the logical thread has any unprocessed actions left in its queue.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool HasAction { get; }
Public ReadOnly Property HasAction As Boolean
    Get
member HasAction : bool with get

function get_HasAction();

public:
property bool HasAction {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread Events

Grid Solutions Framework LogicalThread Events

The LogicalThread type exposes the following members.

Events
 | Name | Description
Public event | UnhandledException | Handler for unhandled exceptions on the thread.
Top
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThread.UnhandledException Event

Grid Solutions Framework LogicalThreadUnhandledException Event
Handler for unhandled exceptions on the thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> UnhandledException
Public Event UnhandledException As EventHandler(Of EventArgs(Of Exception))
member UnhandledException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_UnhandledException(value);
function remove_UnhandledException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ UnhandledException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

LogicalThread Class
GSF.Threading Namespace


LogicalThreadLocal(T) Class

Grid Solutions Framework LogicalThreadLocalT Class
Represents a slot in the thread local memory space of each logical thread.
Inheritance Hierarchy
SystemObject
GSF.ThreadingLogicalThreadLocalT

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class LogicalThreadLocal<T> : IDisposable

Public NotInheritable Class LogicalThreadLocal(Of T)
    Implements IDisposable
[<SealedAttribute>]
type LogicalThreadLocal<'T> =
    class
        interface IDisposable
    end
JavaScript does not support generic types or methods.
generic<typename T>
public ref class LogicalThreadLocal sealed : IDisposable

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GSF.Threading.LogicalThreadLocal`1"]

The LogicalThreadLocalT type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalThreadLocalT | Creates a new instance of the LogicalThreadLocalT class.
Public method | LogicalThreadLocalT(FuncT) | Creates a new instance of the LogicalThreadLocalT class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the LogicalThreadLocalT object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Value | Gets or sets the thread local object associated with the current logical thread.
Top
See Also

Reference

GSF.Threading Namespace


LogicalThreadLocal(T) Constructor

Grid Solutions Framework LogicalThreadLocalT Constructor
Overload List
 | Name | Description
Public method | LogicalThreadLocalT | Creates a new instance of the LogicalThreadLocalT class.
Public method | LogicalThreadLocalT(FuncT) | Creates a new instance of the LogicalThreadLocalT class.
Top
See Also

Reference

LogicalThreadLocalT Class
GSF.Threading Namespace


LogicalThreadLocal(T) Constructor

Grid Solutions Framework LogicalThreadLocalT Constructor
Creates a new instance of the LogicalThreadLocalT class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThreadLocal()
Public Sub New
new : unit -> LogicalThreadLocal
GSF.Threading.LogicalThreadLocal = function();
public:
LogicalThreadLocal()
See Also

Reference

LogicalThreadLocalT Class
LogicalThreadLocalT Overload
GSF.Threading Namespace


LogicalThreadLocal(T) Constructor (Func(T))

Grid Solutions Framework LogicalThreadLocalT Constructor (FuncT)
Creates a new instance of the LogicalThreadLocalT class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThreadLocal(
    Func<T> newObjectFactory
)
Public Sub New (
    newObjectFactory As Func(Of T)
)
new :
        newObjectFactory : Func<'T> -> LogicalThreadLocal
GSF.Threading.LogicalThreadLocal = function(newObjectFactory);
public:
LogicalThreadLocal(
    Func<T>^ newObjectFactory
)

Parameters

newObjectFactory
Type: SystemFunc T
Factory to produce the initial value when accessing uninitialized values.
See Also

Reference

LogicalThreadLocalT Class
LogicalThreadLocalT Overload
GSF.Threading Namespace


LogicalThreadLocal(T) Methods

Grid Solutions Framework LogicalThreadLocalT Methods

The LogicalThreadLocalT generic type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the LogicalThreadLocalT object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogicalThreadLocalT Class
GSF.Threading Namespace


LogicalThreadLocal(T).Dispose Method

Grid Solutions Framework LogicalThreadLocalTDispose Method
Releases all the resources used by the LogicalThreadLocalT object.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

LogicalThreadLocalT Class
GSF.Threading Namespace


LogicalThreadLocal(T) Properties

Grid Solutions Framework LogicalThreadLocalT Properties

The LogicalThreadLocalT generic type exposes the following members.

Properties
 | Name | Description
Public property | Value | Gets or sets the thread local object associated with the current logical thread.
Top
See Also

Reference

LogicalThreadLocalT Class
GSF.Threading Namespace


LogicalThreadLocal(T).Value Property

Grid Solutions Framework LogicalThreadLocalTValue Property
Gets or sets the thread local object associated with the current logical thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Value { get; set; }
Public Property Value As T
    Get
    Set
member Value : 'T with get, set

function get_Value();
function set_Value(value);
public:
property T Value {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

LogicalThreadLocalT Class
GSF.Threading Namespace


LogicalThreadOperation Class

Grid Solutions Framework LogicalThreadOperation Class
Synchronized operation that executes on a logical thread.
Inheritance Hierarchy
SystemObject
GSF.ThreadingSynchronizedOperationBase
GSF.ThreadingLogicalThreadOperation

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LogicalThreadOperation : SynchronizedOperationBase
Public Class LogicalThreadOperation
    Inherits SynchronizedOperationBase
type LogicalThreadOperation =
    class
        inherit SynchronizedOperationBase
    end
GSF.Threading.LogicalThreadOperation = function();

Type.createClass(
    'GSF.Threading.LogicalThreadOperation',
    GSF.Threading.SynchronizedOperationBase);
public ref class LogicalThreadOperation : public SynchronizedOperationBase

The LogicalThreadOperation type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalThreadOperation(LogicalThread, Action) | Creates a new instance of the LogicalThreadOperation class.
Public method | LogicalThreadOperation(LogicalThread, Action, ActionException) | Creates a new instance of the LogicalThreadOperation class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action on a separate thread. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
See Also

Reference

GSF.Threading Namespace


LogicalThreadOperation Constructor

Grid Solutions Framework LogicalThreadOperation Constructor
Overload List
 | Name | Description
Public method | LogicalThreadOperation(LogicalThread, Action) | Creates a new instance of the LogicalThreadOperation class.
Public method | LogicalThreadOperation(LogicalThread, Action, ActionException) | Creates a new instance of the LogicalThreadOperation class.
Top
See Also

Reference

LogicalThreadOperation Class
GSF.Threading Namespace


LogicalThreadOperation Constructor (LogicalThread, Action)

Grid Solutions Framework LogicalThreadOperation Constructor (LogicalThread, Action)
Creates a new instance of the LogicalThreadOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThreadOperation(
    LogicalThread thread,
    Action action
)
Public Sub New (
    thread As LogicalThread,
    action As Action
)
new :
        thread : LogicalThread *
        action : Action -> LogicalThreadOperation
GSF.Threading.LogicalThreadOperation = function(thread, action);
public:
LogicalThreadOperation(
    LogicalThread^ thread,
    Action^ action
)

Parameters

thread
Type: GSF.ThreadingLogicalThread
The thread on which to execute the operation's action.
action
Type: SystemAction
The action to be executed.
See Also

Reference

LogicalThreadOperation Class
LogicalThreadOperation Overload
GSF.Threading Namespace


LogicalThreadOperation Constructor (LogicalThread, Action, Action(Exception))

Grid Solutions Framework LogicalThreadOperation Constructor (LogicalThread, Action, ActionException)
Creates a new instance of the LogicalThreadOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThreadOperation(
    LogicalThread thread,
    Action action,
    Action<Exception> exceptionAction
)
Public Sub New (
    thread As LogicalThread,
    action As Action,
    exceptionAction As Action(Of Exception)
)
new :
        thread : LogicalThread *
        action : Action *
        exceptionAction : Action<Exception> -> LogicalThreadOperation
GSF.Threading.LogicalThreadOperation = function(thread, action, exceptionAction);
public:
LogicalThreadOperation(
    LogicalThread^ thread,
    Action^ action,
    Action<Exception^>^ exceptionAction
)

Parameters

thread
Type: GSF.ThreadingLogicalThread
The thread on which to execute the operation's action.
action
Type: SystemAction
The action to be executed.
exceptionAction
Type: SystemAction Exception
The action to be executed to process unhandled exceptions.
See Also

Reference

LogicalThreadOperation Class
LogicalThreadOperation Overload
GSF.Threading Namespace


LogicalThreadOperation Methods

Grid Solutions Framework LogicalThreadOperation Methods

The LogicalThreadOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action on a separate thread. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogicalThreadOperation Class
GSF.Threading Namespace


LogicalThreadOperation.ExecuteActionAsync Method

Grid Solutions Framework LogicalThreadOperationExecuteActionAsync Method
Executes the action on a separate thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExecuteActionAsync()
Protected Overrides Sub ExecuteActionAsync
abstract ExecuteActionAsync : unit -> unit
override ExecuteActionAsync : unit -> unit
function ExecuteActionAsync();
protected:
virtual void ExecuteActionAsync() override
See Also

Reference

LogicalThreadOperation Class
GSF.Threading Namespace


LogicalThreadOperation Properties

Grid Solutions Framework LogicalThreadOperation Properties

The LogicalThreadOperation type exposes the following members.

Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
See Also

Reference

LogicalThreadOperation Class
GSF.Threading Namespace


LogicalThreadScheduler Class

Grid Solutions Framework LogicalThreadScheduler Class
Manages synchronization of actions by dispatching actions to logical threads to be processed synchronously.
Inheritance Hierarchy
SystemObject
GSF.ThreadingLogicalThreadScheduler

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LogicalThreadScheduler
Public Class LogicalThreadScheduler
type LogicalThreadScheduler =  class end
GSF.Threading.LogicalThreadScheduler = function();

Type.createClass(
    'GSF.Threading.LogicalThreadScheduler');
public ref class LogicalThreadScheduler

The LogicalThreadScheduler type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalThreadScheduler | Creates a new instance of the LogicalThreadScheduler class.
Top
Methods
 | Name | Description
Public method | CreateThread | Creates a new logical thread whose execution is managed by this scheduler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | MaxThreadCount | Gets or sets the target for the maximum number of physical threads managed by this synchronization manager at any given time.
Public property | UseBackgroundThreads | Gets or sets the flag that determines whether the threads in the scheduler's thread pool should be background threads.
Top
Events
 | Name | Description
Public event | UnhandledException | Triggered when an action managed by this synchronization manager throws an exception.
Top
See Also

Reference

GSF.Threading Namespace


LogicalThreadScheduler Constructor

Grid Solutions Framework LogicalThreadScheduler Constructor
Creates a new instance of the LogicalThreadScheduler class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThreadScheduler()
Public Sub New
new : unit -> LogicalThreadScheduler
GSF.Threading.LogicalThreadScheduler = function();
public:
LogicalThreadScheduler()
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadScheduler Methods

Grid Solutions Framework LogicalThreadScheduler Methods

The LogicalThreadScheduler type exposes the following members.

Methods
 | Name | Description
Public method | CreateThread | Creates a new logical thread whose execution is managed by this scheduler.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadScheduler.CreateThread Method

Grid Solutions Framework LogicalThreadSchedulerCreateThread Method
Creates a new logical thread whose execution is managed by this scheduler.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThread CreateThread()
Public Function CreateThread As LogicalThread
member CreateThread : unit -> LogicalThread

function CreateThread();
public:
LogicalThread^ CreateThread()

Return Value

Type: LogicalThread
A new logical thread managed by this scheduler.
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadScheduler Properties

Grid Solutions Framework LogicalThreadScheduler Properties

The LogicalThreadScheduler type exposes the following members.

Properties
 | Name | Description
Public property | MaxThreadCount | Gets or sets the target for the maximum number of physical threads managed by this synchronization manager at any given time.
Public property | UseBackgroundThreads | Gets or sets the flag that determines whether the threads in the scheduler's thread pool should be background threads.
Top
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadScheduler.MaxThreadCount Property

Grid Solutions Framework LogicalThreadSchedulerMaxThreadCount Property
Gets or sets the target for the maximum number of physical threads managed by this synchronization manager at any given time.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaxThreadCount { get; set; }
Public Property MaxThreadCount As Integer
    Get
    Set
member MaxThreadCount : int with get, set

function get_MaxThreadCount();
function set_MaxThreadCount(value);
public:
property int MaxThreadCount {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadScheduler.UseBackgroundThreads Property

Grid Solutions Framework LogicalThreadSchedulerUseBackgroundThreads Property
Gets or sets the flag that determines whether the threads in the scheduler's thread pool should be background threads.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseBackgroundThreads { get; set; }
Public Property UseBackgroundThreads As Boolean
    Get
    Set
member UseBackgroundThreads : bool with get, set

function get_UseBackgroundThreads();
function set_UseBackgroundThreads(value);
public:
property bool UseBackgroundThreads {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadScheduler Events

Grid Solutions Framework LogicalThreadScheduler Events

The LogicalThreadScheduler type exposes the following members.

Events
 | Name | Description
Public event | UnhandledException | Triggered when an action managed by this synchronization manager throws an exception.
Top
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadScheduler.UnhandledException Event

Grid Solutions Framework LogicalThreadSchedulerUnhandledException Event
Triggered when an action managed by this synchronization manager throws an exception.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> UnhandledException
Public Event UnhandledException As EventHandler(Of EventArgs(Of Exception))
member UnhandledException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_UnhandledException(value);
function remove_UnhandledException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ UnhandledException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

LogicalThreadScheduler Class
GSF.Threading Namespace


LogicalThreadStatistics Class

Grid Solutions Framework LogicalThreadStatistics Class
Represents a set of statistics gathered about the execution time of actions on a logical thread.
Inheritance Hierarchy
SystemObject
GSF.ThreadingLogicalThreadStatistics

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LogicalThreadStatistics
Public Class LogicalThreadStatistics
type LogicalThreadStatistics =  class end
GSF.Threading.LogicalThreadStatistics = function();

Type.createClass(
    'GSF.Threading.LogicalThreadStatistics');
public ref class LogicalThreadStatistics

The LogicalThreadStatistics type exposes the following members.

Constructors
 | Name | Description
Public method | LogicalThreadStatistics | Initializes a new instance of the LogicalThreadStatistics class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ExecutionCount | Gets the total number of actions executed on the logical thread.
Public property | MaxExecutionTime | Gets the execution time of the longest running action.
Public property | MinExecutionTime | Gets the execution time of the shortest running action.
Public property | TotalExecutionTime | Gets the total execution time of all actions executed on the logical thread.
Top
See Also

Reference

GSF.Threading Namespace


LogicalThreadStatistics Constructor

Grid Solutions Framework LogicalThreadStatistics Constructor
Initializes a new instance of the LogicalThreadStatistics class

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LogicalThreadStatistics()
Public Sub New
new : unit -> LogicalThreadStatistics
GSF.Threading.LogicalThreadStatistics = function();
public:
LogicalThreadStatistics()
See Also

Reference

LogicalThreadStatistics Class
GSF.Threading Namespace


LogicalThreadStatistics Methods

Grid Solutions Framework LogicalThreadStatistics Methods

The LogicalThreadStatistics type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LogicalThreadStatistics Class
GSF.Threading Namespace


LogicalThreadStatistics Properties

Grid Solutions Framework LogicalThreadStatistics Properties

The LogicalThreadStatistics type exposes the following members.

Properties
 | Name | Description
Public property | ExecutionCount | Gets the total number of actions executed on the logical thread.
Public property | MaxExecutionTime | Gets the execution time of the longest running action.
Public property | MinExecutionTime | Gets the execution time of the shortest running action.
Public property | TotalExecutionTime | Gets the total execution time of all actions executed on the logical thread.
Top
See Also

Reference

LogicalThreadStatistics Class
GSF.Threading Namespace


LogicalThreadStatistics.ExecutionCount Property

Grid Solutions Framework LogicalThreadStatisticsExecutionCount Property
Gets the total number of actions executed on the logical thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ExecutionCount { get; }
Public ReadOnly Property ExecutionCount As Long
    Get
member ExecutionCount : int64 with get

function get_ExecutionCount();

public:
property long long ExecutionCount {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

LogicalThreadStatistics Class
GSF.Threading Namespace


LogicalThreadStatistics.MaxExecutionTime Property

Grid Solutions Framework LogicalThreadStatisticsMaxExecutionTime Property
Gets the execution time of the longest running action.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeSpan MaxExecutionTime { get; }
Public ReadOnly Property MaxExecutionTime As TimeSpan
    Get
member MaxExecutionTime : TimeSpan with get

function get_MaxExecutionTime();

public:
property TimeSpan MaxExecutionTime {
    TimeSpan get ();
}

Property Value

Type: TimeSpan
See Also

Reference

LogicalThreadStatistics Class
GSF.Threading Namespace


LogicalThreadStatistics.MinExecutionTime Property

Grid Solutions Framework LogicalThreadStatisticsMinExecutionTime Property
Gets the execution time of the shortest running action.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeSpan MinExecutionTime { get; }
Public ReadOnly Property MinExecutionTime As TimeSpan
    Get
member MinExecutionTime : TimeSpan with get

function get_MinExecutionTime();

public:
property TimeSpan MinExecutionTime {
    TimeSpan get ();
}

Property Value

Type: TimeSpan
See Also

Reference

LogicalThreadStatistics Class
GSF.Threading Namespace


LogicalThreadStatistics.TotalExecutionTime Property

Grid Solutions Framework LogicalThreadStatisticsTotalExecutionTime Property
Gets the total execution time of all actions executed on the logical thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TimeSpan TotalExecutionTime { get; }
Public ReadOnly Property TotalExecutionTime As TimeSpan
    Get
member TotalExecutionTime : TimeSpan with get

function get_TotalExecutionTime();

public:
property TimeSpan TotalExecutionTime {
    TimeSpan get ();
}

Property Value

Type: TimeSpan
See Also

Reference

LogicalThreadStatistics Class
GSF.Threading Namespace


LongSynchronizedOperation Class

Grid Solutions Framework LongSynchronizedOperation Class
Represents a long-running synchronized operation that cannot run while it is already in progress.
Inheritance Hierarchy
SystemObject
GSF.ThreadingSynchronizedOperationBase
GSF.ThreadingLongSynchronizedOperation

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class LongSynchronizedOperation : SynchronizedOperationBase
Public Class LongSynchronizedOperation
    Inherits SynchronizedOperationBase
type LongSynchronizedOperation =
    class
        inherit SynchronizedOperationBase
    end
GSF.Threading.LongSynchronizedOperation = function();

Type.createClass(
    'GSF.Threading.LongSynchronizedOperation',
    GSF.Threading.SynchronizedOperationBase);
public ref class LongSynchronizedOperation : public SynchronizedOperationBase

The LongSynchronizedOperation type exposes the following members.

Constructors
 | Name | Description
Public method | LongSynchronizedOperation(Action) | Creates a new instance of the LongSynchronizedOperation class.
Public method | LongSynchronizedOperation(Action, ActionException) | Creates a new instance of the LongSynchronizedOperation class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action on a separate thread. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsBackground | Gets or sets whether or not the thread executing the action is a background thread.
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
Remarks
The action performed by the LongSynchronizedOperation is executed on its own dedicated thread when running the operation asynchronously. When running on its own thread, the action is executed in a tight loop until all pending operations have been completed. This type of synchronized operation should be preferred if operations may take a long time, block the thread, or put it to sleep. It is also recommended to prefer this type of operation if the speed of the operation is not critical or if completion of the operation is critical, such as when saving data to a file.
See Also

Reference

GSF.Threading Namespace


LongSynchronizedOperation Constructor

Grid Solutions Framework LongSynchronizedOperation Constructor
Overload List
 | Name | Description
Public method | LongSynchronizedOperation(Action) | Creates a new instance of the LongSynchronizedOperation class.
Public method | LongSynchronizedOperation(Action, ActionException) | Creates a new instance of the LongSynchronizedOperation class.
Top
See Also

Reference

LongSynchronizedOperation Class
GSF.Threading Namespace


LongSynchronizedOperation Constructor (Action)

Grid Solutions Framework LongSynchronizedOperation Constructor (Action)
Creates a new instance of the LongSynchronizedOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LongSynchronizedOperation(
    Action action
)
Public Sub New (
    action As Action
)
new :
        action : Action -> LongSynchronizedOperation
GSF.Threading.LongSynchronizedOperation = function(action);
public:
LongSynchronizedOperation(
    Action^ action
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
See Also

Reference

LongSynchronizedOperation Class
LongSynchronizedOperation Overload
GSF.Threading Namespace


LongSynchronizedOperation Constructor (Action, Action(Exception))

Grid Solutions Framework LongSynchronizedOperation Constructor (Action, ActionException)
Creates a new instance of the LongSynchronizedOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public LongSynchronizedOperation(
    Action action,
    Action<Exception> exceptionAction
)
Public Sub New (
    action As Action,
    exceptionAction As Action(Of Exception)
)
new :
        action : Action *
        exceptionAction : Action<Exception> -> LongSynchronizedOperation
GSF.Threading.LongSynchronizedOperation = function(action, exceptionAction);
public:
LongSynchronizedOperation(
    Action^ action,
    Action<Exception^>^ exceptionAction
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
exceptionAction
Type: SystemAction Exception
The action to be performed if an exception is thrown from the action.
See Also

Reference

LongSynchronizedOperation Class
LongSynchronizedOperation Overload
GSF.Threading Namespace


LongSynchronizedOperation Methods

Grid Solutions Framework LongSynchronizedOperation Methods

The LongSynchronizedOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action on a separate thread. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

LongSynchronizedOperation Class
GSF.Threading Namespace


LongSynchronizedOperation.ExecuteActionAsync Method

Grid Solutions Framework LongSynchronizedOperationExecuteActionAsync Method
Executes the action on a separate thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExecuteActionAsync()
Protected Overrides Sub ExecuteActionAsync
abstract ExecuteActionAsync : unit -> unit
override ExecuteActionAsync : unit -> unit
function ExecuteActionAsync();
protected:
virtual void ExecuteActionAsync() override
See Also

Reference

LongSynchronizedOperation Class
GSF.Threading Namespace


LongSynchronizedOperation Properties

Grid Solutions Framework LongSynchronizedOperation Properties

The LongSynchronizedOperation type exposes the following members.

Properties
 | Name | Description
Public property | IsBackground | Gets or sets whether or not the thread executing the action is a background thread.
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
See Also

Reference

LongSynchronizedOperation Class
GSF.Threading Namespace


LongSynchronizedOperation.IsBackground Property

Grid Solutions Framework LongSynchronizedOperationIsBackground Property
Gets or sets whether or not the thread executing the action is a background thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsBackground { get; set; }
Public Property IsBackground As Boolean
    Get
    Set
member IsBackground : bool with get, set

function get_IsBackground();
function set_IsBackground(value);
public:
property bool IsBackground {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

LongSynchronizedOperation Class
GSF.Threading Namespace


ManagedThread Class

Grid Solutions Framework ManagedThread Class
Defines a managed thread
Inheritance Hierarchy
SystemObject
GSF.ThreadingManagedThread

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class ManagedThread
Public NotInheritable Class ManagedThread
[<SealedAttribute>]
type ManagedThread =  class end
GSF.Threading.ManagedThread = function();

Type.createClass(
    'GSF.Threading.ManagedThread');
public ref class ManagedThread sealed

The ManagedThread type exposes the following members.

Constructors
 | Name | Description
Public method | ManagedThread(ParameterizedThreadStart) | Initializes a new instance of the ManagedThread class, specifying a delegate that allows an object to be passed to the thread when the thread is started.
Public method | ManagedThread(ThreadStart) | Initializes a new instance of the ManagedThread class.
Public method | ManagedThread(ContextCallback, ExecutionContext) | Initializes a new instance of the ManagedThread class, specifying a delegate that allows an object to be passed to the thread when the thread is started and allowing the user to specify an alternate execution context for the thread.
Top
Methods
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Join | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Join(Int32) | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Join(TimeSpan) | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Start | Causes a thread to be scheduled for execution.
Public method | Start(Object) | Causes a thread to be scheduled for execution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsAlive | Gets a value indicating the execution status of the current thread.
Public property | Name | Gets or sets the name of the thread.
Public property | Priority | Gets or sets a value indicating the scheduling priority of a thread.
Public property | RunTime | Gets the total amount of time, in seconds, that the managed thread has been active.
Public property | StartTime | Get the time, in ticks, that the thread started executing
Public property | State | An object containing data to be used by the thread's execution method.
Public property | Status | Gets a value containing the curretn status of the current thread.
Public property | StopTime | Get the time, in ticks, that the thread finished executing
Public property | Tag | An object that allows additional user defined information to be tracked along with this thread.
Public property | Type | Returns the managed thread type (either StandardThread or QueuedThread)
Top
Remarks
This class works like any normal thread but provides the benefit of automatic tracking through the ManagedThreads collection, total thread runtime and the ability to run the thread in an alternate execution context
See Also

Reference

GSF.Threading Namespace


ManagedThread Constructor

Grid Solutions Framework ManagedThread Constructor
Overload List
 | Name | Description
Public method | ManagedThread(ParameterizedThreadStart) | Initializes a new instance of the ManagedThread class, specifying a delegate that allows an object to be passed to the thread when the thread is started.
Public method | ManagedThread(ThreadStart) | Initializes a new instance of the ManagedThread class.
Public method | ManagedThread(ContextCallback, ExecutionContext) | Initializes a new instance of the ManagedThread class, specifying a delegate that allows an object to be passed to the thread when the thread is started and allowing the user to specify an alternate execution context for the thread.
Top
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread Constructor (ParameterizedThreadStart)

Grid Solutions Framework ManagedThread Constructor (ParameterizedThreadStart)
Initializes a new instance of the ManagedThread class, specifying a delegate that allows an object to be passed to the thread when the thread is started.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ManagedThread(
    ParameterizedThreadStart callback
)
Public Sub New (
    callback As ParameterizedThreadStart
)
new :
        callback : ParameterizedThreadStart -> ManagedThread
GSF.Threading.ManagedThread = function(callback);
public:
ManagedThread(
    ParameterizedThreadStart^ callback
)

Parameters

callback
Type: System.ThreadingParameterizedThreadStart
A ParameterizedThreadStart object.
See Also

Reference

ManagedThread Class
ManagedThread Overload
GSF.Threading Namespace


ManagedThread Constructor (ThreadStart)

Grid Solutions Framework ManagedThread Constructor (ThreadStart)
Initializes a new instance of the ManagedThread class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ManagedThread(
    ThreadStart callback
)
Public Sub New (
    callback As ThreadStart
)
new :
        callback : ThreadStart -> ManagedThread
GSF.Threading.ManagedThread = function(callback);
public:
ManagedThread(
    ThreadStart^ callback
)

Parameters

callback
Type: System.ThreadingThreadStart
A ThreadStart object.
See Also

Reference

ManagedThread Class
ManagedThread Overload
GSF.Threading Namespace


ManagedThread Constructor (ContextCallback, ExecutionContext)

Grid Solutions Framework ManagedThread Constructor (ContextCallback, ExecutionContext)
Initializes a new instance of the ManagedThread class, specifying a delegate that allows an object to be passed to the thread when the thread is started and allowing the user to specify an alternate execution context for the thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ManagedThread(
    ContextCallback callback,
    ExecutionContext ctx
)
Public Sub New (
    callback As ContextCallback,
    ctx As ExecutionContext
)
new :
        callback : ContextCallback *
        ctx : ExecutionContext -> ManagedThread
GSF.Threading.ManagedThread = function(callback, ctx);
public:
ManagedThread(
    ContextCallback^ callback,
    ExecutionContext^ ctx
)

Parameters

callback
Type: System.ThreadingContextCallback
A ContextCallback delgate to execute.
ctx
Type: System.ThreadingExecutionContext
An ExecutionContext.
See Also

Reference

ManagedThread Class
ManagedThread Overload
GSF.Threading Namespace


ManagedThread Methods

Grid Solutions Framework ManagedThread Methods

The ManagedThread type exposes the following members.

Methods
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Join | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Join(Int32) | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Join(TimeSpan) | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Start | Causes a thread to be scheduled for execution.
Public method | Start(Object) | Causes a thread to be scheduled for execution.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Abort Method

Grid Solutions Framework ManagedThreadAbort Method
Overload List
 | Name | Description
Public method | Abort | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.
Public method | Abort(Object) | Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.
Top
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Abort Method

Grid Solutions Framework ManagedThreadAbort Method
Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Abort()
Public Sub Abort
member Abort : unit -> unit

function Abort();
public:
void Abort()
See Also

Reference

ManagedThread Class
Abort Overload
GSF.Threading Namespace


ManagedThread.Abort Method (Object)

Grid Solutions Framework ManagedThreadAbort Method (Object)
Raises a ThreadAbortException in the thread on which it is invoked, to begin the process of terminating the thread. Calling this method usually terminates the thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Abort(
    Object stateInfo
)
Public Sub Abort (
    stateInfo As Object
)
member Abort :
        stateInfo : Object -> unit

function Abort(stateInfo);
public:
void Abort(
    Object^ stateInfo
)

Parameters

stateInfo
Type: SystemObject
An object that contains application-specific information, such as state, which can be used by the thread being aborted.
See Also

Reference

ManagedThread Class
Abort Overload
GSF.Threading Namespace


ManagedThread.Join Method

Grid Solutions Framework ManagedThreadJoin Method
Overload List
 | Name | Description
Public method | Join | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Join(Int32) | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Public method | Join(TimeSpan) | Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.
Top
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Join Method

Grid Solutions Framework ManagedThreadJoin Method
Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Join()
Public Sub Join
member Join : unit -> unit

function Join();
public:
void Join()
Remarks
This is only available for standard threads - queued threads don't have an associated thread until they are executing.
See Also

Reference

ManagedThread Class
Join Overload
GSF.Threading Namespace


ManagedThread.Join Method (Int32)

Grid Solutions Framework ManagedThreadJoin Method (Int32)
Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Join(
    int millisecondsTimeout
)
Public Function Join (
    millisecondsTimeout As Integer
) As Boolean
member Join :
        millisecondsTimeout : int -> bool

function Join(millisecondsTimeout);
public:
bool Join(
    int millisecondsTimeout
)

Parameters

millisecondsTimeout
Type: SystemInt32
The number of milliseconds to wait for the thread to terminate.

Return Value

Type: Boolean
true if the thread has terminated; false if the thread has not terminated after the amount of time specified by the millisecondsTimeout parameter has elapsed.
Remarks
This is only available for standard threads - queued threads don't have an associated thread until they are executing.
See Also

Reference

ManagedThread Class
Join Overload
GSF.Threading Namespace


ManagedThread.Join Method (TimeSpan)

Grid Solutions Framework ManagedThreadJoin Method (TimeSpan)
Blocks the calling thread until a thread terminates or the specified time elapses, while continuing to perform standard COM and SendMessage pumping.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Join(
    TimeSpan timeout
)
Public Function Join (
    timeout As TimeSpan
) As Boolean
member Join :
        timeout : TimeSpan -> bool

function Join(timeout);
public:
bool Join(
    TimeSpan timeout
)

Parameters

timeout
Type: SystemTimeSpan
A TimeSpan set to the amount of time to wait for the thread to terminate.

Return Value

Type: Boolean
true if the thread terminated; false if the thread has not terminated after the amount of time specified by the timeout parameter has elapsed.
Remarks
This is only available for standard threads - queued threads don't have an associated thread until they are executing.
See Also

Reference

ManagedThread Class
Join Overload
GSF.Threading Namespace


ManagedThread.Start Method

Grid Solutions Framework ManagedThreadStart Method
Overload List
 | Name | Description
Public method | Start | Causes a thread to be scheduled for execution.
Public method | Start(Object) | Causes a thread to be scheduled for execution.
Top
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Start Method

Grid Solutions Framework ManagedThreadStart Method
Causes a thread to be scheduled for execution.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start()
Public Sub Start
member Start : unit -> unit

function Start();
public:
void Start()
See Also

Reference

ManagedThread Class
Start Overload
GSF.Threading Namespace


ManagedThread.Start Method (Object)

Grid Solutions Framework ManagedThreadStart Method (Object)
Causes a thread to be scheduled for execution.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start(
    Object parameter
)
Public Sub Start (
    parameter As Object
)
member Start :
        parameter : Object -> unit

function Start(parameter);
public:
void Start(
    Object^ parameter
)

Parameters

parameter
Type: SystemObject
An object that contains data to be used by the method the thread executes.
See Also

Reference

ManagedThread Class
Start Overload
GSF.Threading Namespace


ManagedThread Properties

Grid Solutions Framework ManagedThread Properties

The ManagedThread type exposes the following members.

Properties
 | Name | Description
Public property | IsAlive | Gets a value indicating the execution status of the current thread.
Public property | Name | Gets or sets the name of the thread.
Public property | Priority | Gets or sets a value indicating the scheduling priority of a thread.
Public property | RunTime | Gets the total amount of time, in seconds, that the managed thread has been active.
Public property | StartTime | Get the time, in ticks, that the thread started executing
Public property | State | An object containing data to be used by the thread's execution method.
Public property | Status | Gets a value containing the curretn status of the current thread.
Public property | StopTime | Get the time, in ticks, that the thread finished executing
Public property | Tag | An object that allows additional user defined information to be tracked along with this thread.
Public property | Type | Returns the managed thread type (either StandardThread or QueuedThread)
Top
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.IsAlive Property

Grid Solutions Framework ManagedThreadIsAlive Property
Gets a value indicating the execution status of the current thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsAlive { get; }
Public ReadOnly Property IsAlive As Boolean
    Get
member IsAlive : bool with get

function get_IsAlive();

public:
property bool IsAlive {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Name Property

Grid Solutions Framework ManagedThreadName Property
Gets or sets the name of the thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; set; }
Public Property Name As String
    Get
    Set
member Name : string with get, set

function get_Name();
function set_Name(value);
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Priority Property

Grid Solutions Framework ManagedThreadPriority Property
Gets or sets a value indicating the scheduling priority of a thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ThreadPriority Priority { get; set; }
Public Property Priority As ThreadPriority
    Get
    Set
member Priority : ThreadPriority with get, set

function get_Priority();
function set_Priority(value);
public:
property ThreadPriority Priority {
    ThreadPriority get ();
    void set (ThreadPriority value);
}

Return Value

Type: ThreadPriority
One of the ThreadPriority values. The default value is Normal.
Remarks
Changing of this value is only available to standard threads - you can't change the priorty of queued threads since they are already allocated and owned by the .NET thread pool.
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.RunTime Property

Grid Solutions Framework ManagedThreadRunTime Property
Gets the total amount of time, in seconds, that the managed thread has been active.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time RunTime { get; }
Public ReadOnly Property RunTime As Time
    Get
member RunTime : Time with get

function get_RunTime();

public:
property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.StartTime Property

Grid Solutions Framework ManagedThreadStartTime Property
Get the time, in ticks, that the thread started executing

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks StartTime { get; }
Public ReadOnly Property StartTime As Ticks
    Get
member StartTime : Ticks with get

function get_StartTime();

public:
property Ticks StartTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.State Property

Grid Solutions Framework ManagedThreadState Property
An object containing data to be used by the thread's execution method.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object State { get; set; }
Public Property State As Object
    Get
    Set
member State : Object with get, set

function get_State();
function set_State(value);
public:
property Object^ State {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Status Property

Grid Solutions Framework ManagedThreadStatus Property
Gets a value containing the curretn status of the current thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ThreadStatus Status { get; }
Public ReadOnly Property Status As ThreadStatus
    Get
member Status : ThreadStatus with get

function get_Status();

public:
property ThreadStatus Status {
    ThreadStatus get ();
}

Property Value

Type: ThreadStatus
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.StopTime Property

Grid Solutions Framework ManagedThreadStopTime Property
Get the time, in ticks, that the thread finished executing

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks StopTime { get; }
Public ReadOnly Property StopTime As Ticks
    Get
member StopTime : Ticks with get

function get_StopTime();

public:
property Ticks StopTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Tag Property

Grid Solutions Framework ManagedThreadTag Property
An object that allows additional user defined information to be tracked along with this thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Object Tag { get; set; }
Public Property Tag As Object
    Get
    Set
member Tag : Object with get, set

function get_Tag();
function set_Tag(value);
public:
property Object^ Tag {
    Object^ get ();
    void set (Object^ value);
}

Property Value

Type: Object
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThread.Type Property

Grid Solutions Framework ManagedThreadType Property
Returns the managed thread type (either StandardThread or QueuedThread)

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ThreadType Type { get; }
Public ReadOnly Property Type As ThreadType
    Get
member Type : ThreadType with get

function get_Type();

public:
property ThreadType Type {
    ThreadType get ();
}

Property Value

Type: ThreadType
See Also

Reference

ManagedThread Class
GSF.Threading Namespace


ManagedThreadPool Class

Grid Solutions Framework ManagedThreadPool Class
Defines a managed thread pool
Inheritance Hierarchy
SystemObject
GSF.ThreadingManagedThreadPool

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ManagedThreadPool
Public NotInheritable Class ManagedThreadPool
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ManagedThreadPool =  class end
GSF.Threading.ManagedThreadPool = function();

Type.createClass(
    'GSF.Threading.ManagedThreadPool');
public ref class ManagedThreadPool abstract sealed
Methods
Name | Description
QueueUserWorkItem(ParameterizedThreadStart) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ThreadStart) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ContextCallback, ExecutionContext) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ParameterizedThreadStart, Object) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ContextCallback, Object, ExecutionContext) | Queues a work item for processing on the managed thread pool
Top
Remarks
This class works like the normal thread pool but provides the benefit of automatic tracking of queued threads through the ManagedThreads collection, returns a reference to the queued thread with the ability to dequeue and/or abort, total thread runtime and the ability to run the queued thread in an alternate execution context
See Also

Reference

GSF.Threading Namespace


ManagedThreadPool Methods

Grid Solutions Framework ManagedThreadPool Methods
Methods
Name | Description
QueueUserWorkItem(ParameterizedThreadStart) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ThreadStart) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ContextCallback, ExecutionContext) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ParameterizedThreadStart, Object) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ContextCallback, Object, ExecutionContext) | Queues a work item for processing on the managed thread pool
Top
See Also

Reference

ManagedThreadPool Class
GSF.Threading Namespace


ManagedThreadPool.QueueUserWorkItem Method

Grid Solutions Framework ManagedThreadPoolQueueUserWorkItem Method
Overload List
Name | Description
QueueUserWorkItem(ParameterizedThreadStart) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ThreadStart) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ContextCallback, ExecutionContext) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ParameterizedThreadStart, Object) | Queues a work item for processing on the managed thread pool
QueueUserWorkItem(ContextCallback, Object, ExecutionContext) | Queues a work item for processing on the managed thread pool
Top
See Also

Reference

ManagedThreadPool Class
GSF.Threading Namespace


ManagedThreadPool.QueueUserWorkItem Method (ParameterizedThreadStart)

Grid Solutions Framework ManagedThreadPoolQueueUserWorkItem Method (ParameterizedThreadStart)
Queues a work item for processing on the managed thread pool

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ManagedThread QueueUserWorkItem(
    ParameterizedThreadStart callback
)
Public Shared Function QueueUserWorkItem (
    callback As ParameterizedThreadStart
) As ManagedThread
static member QueueUserWorkItem :
        callback : ParameterizedThreadStart -> ManagedThread

GSF.Threading.ManagedThreadPool.QueueUserWorkItem = function(callback);
public:
static ManagedThread^ QueueUserWorkItem(
    ParameterizedThreadStart^ callback
)

Parameters

callback
Type: System.ThreadingParameterizedThreadStart
A WaitCallback representing the method to execute.

Return Value

Type: ManagedThread
Reference to queued thread
Remarks
This differs from the normal thread pool QueueUserWorkItem function in that it does not return a success value determing if item was queued, but rather a reference to to the managed thread that was actually placed on the queue.
See Also

Reference

ManagedThreadPool Class
QueueUserWorkItem Overload
GSF.Threading Namespace


ManagedThreadPool.QueueUserWorkItem Method (ThreadStart)

Grid Solutions Framework ManagedThreadPoolQueueUserWorkItem Method (ThreadStart)
Queues a work item for processing on the managed thread pool

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ManagedThread QueueUserWorkItem(
    ThreadStart callback
)
Public Shared Function QueueUserWorkItem (
    callback As ThreadStart
) As ManagedThread
static member QueueUserWorkItem :
        callback : ThreadStart -> ManagedThread

GSF.Threading.ManagedThreadPool.QueueUserWorkItem = function(callback);
public:
static ManagedThread^ QueueUserWorkItem(
    ThreadStart^ callback
)

Parameters

callback
Type: System.ThreadingThreadStart
A WaitCallback representing the method to execute.

Return Value

Type: ManagedThread
Reference to queued thread
Remarks
This differs from the normal thread pool QueueUserWorkItem function in that it does not return a success value determing if item was queued, but rather a reference to to the managed thread that was actually placed on the queue.
See Also

Reference

ManagedThreadPool Class
QueueUserWorkItem Overload
GSF.Threading Namespace


ManagedThreadPool.QueueUserWorkItem Method (ContextCallback, ExecutionContext)

Grid Solutions Framework ManagedThreadPoolQueueUserWorkItem Method (ContextCallback, ExecutionContext)
Queues a work item for processing on the managed thread pool

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ManagedThread QueueUserWorkItem(
    ContextCallback callback,
    ExecutionContext ctx
)
Public Shared Function QueueUserWorkItem (
    callback As ContextCallback,
    ctx As ExecutionContext
) As ManagedThread
static member QueueUserWorkItem :
        callback : ContextCallback *
        ctx : ExecutionContext -> ManagedThread

GSF.Threading.ManagedThreadPool.QueueUserWorkItem = function(callback, ctx);
public:
static ManagedThread^ QueueUserWorkItem(
    ContextCallback^ callback,
    ExecutionContext^ ctx
)

Parameters

callback
Type: System.ThreadingContextCallback
A WaitCallback representing the method to execute.
ctx
Type: System.ThreadingExecutionContext
Alternate execution context in which to run the thread.

Return Value

Type: ManagedThread
Reference to queued thread
Remarks
This differs from the normal thread pool QueueUserWorkItem function in that it does not return a success value determing if item was queued, but rather a reference to to the managed thread that was actually placed on the queue.
See Also

Reference

ManagedThreadPool Class
QueueUserWorkItem Overload
GSF.Threading Namespace


ManagedThreadPool.QueueUserWorkItem Method (ParameterizedThreadStart, Object)

Grid Solutions Framework ManagedThreadPoolQueueUserWorkItem Method (ParameterizedThreadStart, Object)
Queues a work item for processing on the managed thread pool

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ManagedThread QueueUserWorkItem(
    ParameterizedThreadStart callback,
    Object state
)
Public Shared Function QueueUserWorkItem (
    callback As ParameterizedThreadStart,
    state As Object
) As ManagedThread
static member QueueUserWorkItem :
        callback : ParameterizedThreadStart *
        state : Object -> ManagedThread

GSF.Threading.ManagedThreadPool.QueueUserWorkItem = function(callback, state);
public:
static ManagedThread^ QueueUserWorkItem(
    ParameterizedThreadStart^ callback,
    Object^ state
)

Parameters

callback
Type: System.ThreadingParameterizedThreadStart
A WaitCallback representing the method to execute.
state
Type: SystemObject
An object containing data to be used by the method.

Return Value

Type: ManagedThread
Reference to queued thread
Remarks
This differs from the normal thread pool QueueUserWorkItem function in that it does not return a success value determing if item was queued, but rather a reference to to the managed thread that was actually placed on the queue.
See Also

Reference

ManagedThreadPool Class
QueueUserWorkItem Overload
GSF.Threading Namespace


ManagedThreadPool.QueueUserWorkItem Method (ContextCallback, Object, ExecutionContext)

Grid Solutions Framework ManagedThreadPoolQueueUserWorkItem Method (ContextCallback, Object, ExecutionContext)
Queues a work item for processing on the managed thread pool

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ManagedThread QueueUserWorkItem(
    ContextCallback callback,
    Object state,
    ExecutionContext ctx
)
Public Shared Function QueueUserWorkItem (
    callback As ContextCallback,
    state As Object,
    ctx As ExecutionContext
) As ManagedThread
static member QueueUserWorkItem :
        callback : ContextCallback *
        state : Object *
        ctx : ExecutionContext -> ManagedThread

GSF.Threading.ManagedThreadPool.QueueUserWorkItem = function(callback, state, ctx);
public:
static ManagedThread^ QueueUserWorkItem(
    ContextCallback^ callback,
    Object^ state,
    ExecutionContext^ ctx
)

Parameters

callback
Type: System.ThreadingContextCallback
A WaitCallback representing the method to execute.
state
Type: SystemObject
An object containing data to be used by the method.
ctx
Type: System.ThreadingExecutionContext
Alternate execution context in which to run the thread.

Return Value

Type: ManagedThread
Reference to queued thread
Remarks
This differs from the normal thread pool QueueUserWorkItem function in that it does not return a success value determing if item was queued, but rather a reference to to the managed thread that was actually placed on the queue.
See Also

Reference

ManagedThreadPool Class
QueueUserWorkItem Overload
GSF.Threading Namespace


ManagedThreads Class

Grid Solutions Framework ManagedThreads Class
Maintains a reference to all managed threads
Inheritance Hierarchy
SystemObject
GSF.ThreadingManagedThreads

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ManagedThreads
Public NotInheritable Class ManagedThreads
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ManagedThreads =  class end
GSF.Threading.ManagedThreads = function();

Type.createClass(
    'GSF.Threading.ManagedThreads');
public ref class ManagedThreads abstract sealed

The ManagedThreads type exposes the following members.

Methods
Name | Description
Cancel | Removes a queued thread from thread pool if still queued, if allowAbort is True aborts the thread if executing (standard or queued)
Top
Properties
Name | Description
ActiveThreadStatus | Returns a descriptive status of all queued and active mananged threads
QueuedThreads | Returns a copy of the currently queued and active threads
Top
See Also

Reference

GSF.Threading Namespace


ManagedThreads Methods

Grid Solutions Framework ManagedThreads Methods

The ManagedThreads type exposes the following members.

Methods
Name | Description
Cancel | Removes a queued thread from thread pool if still queued, if allowAbort is True aborts the thread if executing (standard or queued)
Top
See Also

Reference

ManagedThreads Class
GSF.Threading Namespace


ManagedThreads.Cancel Method

Grid Solutions Framework ManagedThreadsCancel Method
Removes a queued thread from thread pool if still queued, if allowAbort is True aborts the thread if executing (standard or queued)

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Cancel(
    ManagedThread item,
    bool allowAbort,
    Object stateInfo
)
Public Shared Sub Cancel (
    item As ManagedThread,
    allowAbort As Boolean,
    stateInfo As Object
)
static member Cancel :
        item : ManagedThread *
        allowAbort : bool *
        stateInfo : Object -> unit

GSF.Threading.ManagedThreads.Cancel = function(item, allowAbort, stateInfo);
public:
static void Cancel(
    ManagedThread^ item,
    bool allowAbort,
    Object^ stateInfo
)

Parameters

item
Type: GSF.ThreadingManagedThread
Thread to cancel
allowAbort
Type: SystemBoolean
Set to True to abort thread if executing
stateInfo
Type: SystemObject
An object that contains application-specific information, such as state, which can be used by the thread being aborted.
See Also

Reference

ManagedThreads Class
GSF.Threading Namespace


ManagedThreads Properties

Grid Solutions Framework ManagedThreads Properties

The ManagedThreads type exposes the following members.

Properties
Name | Description
ActiveThreadStatus | Returns a descriptive status of all queued and active mananged threads
QueuedThreads | Returns a copy of the currently queued and active threads
Top
See Also

Reference

ManagedThreads Class
GSF.Threading Namespace


ManagedThreads.ActiveThreadStatus Property

Grid Solutions Framework ManagedThreadsActiveThreadStatus Property
Returns a descriptive status of all queued and active mananged threads

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ActiveThreadStatus { get; }
Public Shared ReadOnly Property ActiveThreadStatus As String
    Get
static member ActiveThreadStatus : string with get

GSF.Threading.ManagedThreads.get_ActiveThreadStatus = function();

public:
static property String^ ActiveThreadStatus {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ManagedThreads Class
GSF.Threading Namespace


ManagedThreads.QueuedThreads Property

Grid Solutions Framework ManagedThreadsQueuedThreads Property
Returns a copy of the currently queued and active threads

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ManagedThread[] QueuedThreads { get; }
Public Shared ReadOnly Property QueuedThreads As ManagedThread()
    Get
static member QueuedThreads : ManagedThread[] with get

GSF.Threading.ManagedThreads.get_QueuedThreads = function();

public:
static property array<ManagedThread^>^ QueuedThreads {
    array<ManagedThread^>^ get ();
}

Property Value

Type: ManagedThread
See Also

Reference

ManagedThreads Class
GSF.Threading Namespace


MixedSynchronizedOperation Class

Grid Solutions Framework MixedSynchronizedOperation Class
Represents an operation that cannot run while it is already in progress.
Inheritance Hierarchy
SystemObject
GSF.ThreadingSynchronizedOperationBase
GSF.ThreadingMixedSynchronizedOperation

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class MixedSynchronizedOperation : SynchronizedOperationBase
Public Class MixedSynchronizedOperation
    Inherits SynchronizedOperationBase
type MixedSynchronizedOperation =
    class
        inherit SynchronizedOperationBase
    end
GSF.Threading.MixedSynchronizedOperation = function();

Type.createClass(
    'GSF.Threading.MixedSynchronizedOperation',
    GSF.Threading.SynchronizedOperationBase);
public ref class MixedSynchronizedOperation : public SynchronizedOperationBase

The MixedSynchronizedOperation type exposes the following members.

Constructors
 | Name | Description
Public method | MixedSynchronizedOperation(Action) | Creates a new instance of the MixedSynchronizedOperation class.
Public method | MixedSynchronizedOperation(Action, ActionException) | Creates a new instance of the MixedSynchronizedOperation class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action on a separate thread. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AsynchronousExecutionMode | Gets or sets the mode of execution used to execute the action asynchronously.
Public property | CurrentExecutionMode | Gets the execution mode of the currently executing action.
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
Remarks
The behavior of asynchronous executions will depend on the value of the AsynchronousExecutionMode property. When using the short asynchronous execution mode, refer to the ShortSynchronizedOperation class for a description of the behavior of this class. When using the long asynchronous execution mode, refer to the LongSynchronizedOperation class. Actions executed by this class will always be executed on a background thread, even when using the long asynchronous execution mode.
See Also

Reference

GSF.Threading Namespace


MixedSynchronizedOperation Constructor

Grid Solutions Framework MixedSynchronizedOperation Constructor
Overload List
 | Name | Description
Public method | MixedSynchronizedOperation(Action) | Creates a new instance of the MixedSynchronizedOperation class.
Public method | MixedSynchronizedOperation(Action, ActionException) | Creates a new instance of the MixedSynchronizedOperation class.
Top
See Also

Reference

MixedSynchronizedOperation Class
GSF.Threading Namespace


MixedSynchronizedOperation Constructor (Action)

Grid Solutions Framework MixedSynchronizedOperation Constructor (Action)
Creates a new instance of the MixedSynchronizedOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MixedSynchronizedOperation(
    Action action
)
Public Sub New (
    action As Action
)
new :
        action : Action -> MixedSynchronizedOperation
GSF.Threading.MixedSynchronizedOperation = function(action);
public:
MixedSynchronizedOperation(
    Action^ action
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
See Also

Reference

MixedSynchronizedOperation Class
MixedSynchronizedOperation Overload
GSF.Threading Namespace


MixedSynchronizedOperation Constructor (Action, Action(Exception))

Grid Solutions Framework MixedSynchronizedOperation Constructor (Action, ActionException)
Creates a new instance of the MixedSynchronizedOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MixedSynchronizedOperation(
    Action action,
    Action<Exception> exceptionAction
)
Public Sub New (
    action As Action,
    exceptionAction As Action(Of Exception)
)
new :
        action : Action *
        exceptionAction : Action<Exception> -> MixedSynchronizedOperation
GSF.Threading.MixedSynchronizedOperation = function(action, exceptionAction);
public:
MixedSynchronizedOperation(
    Action^ action,
    Action<Exception^>^ exceptionAction
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
exceptionAction
Type: SystemAction Exception
The action to be performed if an exception is thrown from the action.
See Also

Reference

MixedSynchronizedOperation Class
MixedSynchronizedOperation Overload
GSF.Threading Namespace


MixedSynchronizedOperation Methods

Grid Solutions Framework MixedSynchronizedOperation Methods

The MixedSynchronizedOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action on a separate thread. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MixedSynchronizedOperation Class
GSF.Threading Namespace


MixedSynchronizedOperation.ExecuteActionAsync Method

Grid Solutions Framework MixedSynchronizedOperationExecuteActionAsync Method
Executes the action on a separate thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExecuteActionAsync()
Protected Overrides Sub ExecuteActionAsync
abstract ExecuteActionAsync : unit -> unit
override ExecuteActionAsync : unit -> unit
function ExecuteActionAsync();
protected:
virtual void ExecuteActionAsync() override
See Also

Reference

MixedSynchronizedOperation Class
GSF.Threading Namespace


MixedSynchronizedOperation Properties

Grid Solutions Framework MixedSynchronizedOperation Properties

The MixedSynchronizedOperation type exposes the following members.

Properties
 | Name | Description
Public property | AsynchronousExecutionMode | Gets or sets the mode of execution used to execute the action asynchronously.
Public property | CurrentExecutionMode | Gets the execution mode of the currently executing action.
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
See Also

Reference

MixedSynchronizedOperation Class
GSF.Threading Namespace


MixedSynchronizedOperation.AsynchronousExecutionMode Property

Grid Solutions Framework MixedSynchronizedOperationAsynchronousExecutionMode Property
Gets or sets the mode of execution used to execute the action asynchronously.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AsynchronousExecutionMode AsynchronousExecutionMode { get; set; }
Public Property AsynchronousExecutionMode As AsynchronousExecutionMode
    Get
    Set
member AsynchronousExecutionMode : AsynchronousExecutionMode with get, set

function get_AsynchronousExecutionMode();
function set_AsynchronousExecutionMode(value);
public:
property AsynchronousExecutionMode AsynchronousExecutionMode {
    AsynchronousExecutionMode get ();
    void set (AsynchronousExecutionMode value);
}

Property Value

Type: AsynchronousExecutionMode
See Also

Reference

MixedSynchronizedOperation Class
GSF.Threading Namespace


MixedSynchronizedOperation.CurrentExecutionMode Property

Grid Solutions Framework MixedSynchronizedOperationCurrentExecutionMode Property
Gets the execution mode of the currently executing action.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AsynchronousExecutionMode CurrentExecutionMode { get; }
Public ReadOnly Property CurrentExecutionMode As AsynchronousExecutionMode
    Get
member CurrentExecutionMode : AsynchronousExecutionMode with get

function get_CurrentExecutionMode();

public:
property AsynchronousExecutionMode CurrentExecutionMode {
    AsynchronousExecutionMode get ();
}

Property Value

Type: AsynchronousExecutionMode
See Also

Reference

MixedSynchronizedOperation Class
GSF.Threading Namespace


ReaderWriterSpinLock Class

Grid Solutions Framework ReaderWriterSpinLock Class
Represents a fast, lightweight reader/writer lock that uses spinning to perform locking. No recursive acquires or upgradable locks are allowed (i.e., all entered locks must be exited before entering another lock).
Inheritance Hierarchy
SystemObject
GSF.ThreadingReaderWriterSpinLock

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ReaderWriterSpinLock
Public Class ReaderWriterSpinLock
type ReaderWriterSpinLock =  class end
GSF.Threading.ReaderWriterSpinLock = function();

Type.createClass(
    'GSF.Threading.ReaderWriterSpinLock');
public ref class ReaderWriterSpinLock

The ReaderWriterSpinLock type exposes the following members.

Constructors
 | Name | Description
Public method | ReaderWriterSpinLock | Initializes a new instance of the ReaderWriterSpinLock class
Top
Methods
 | Name | Description
Public method | EnterReadLock | Enters the lock in read mode.
Public method | EnterWriteLock | Enters the lock in write mode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExitReadLock | Exits read mode.
Public method | ExitWriteLock | Exits write mode.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Remarks
This reader/writer lock uses SpinWait to spin the CPU instead of engaging event based locking. As a result it should only be used in cases where lock times are expected to be very small, reads are very frequent and writes are rare. If hold times for write locks can be lengthy, it will be better to use ReaderWriterLockSlim instead to avoid unnecessary CPU utilization due to spinning incurred by waiting reads.
See Also

Reference

GSF.Threading Namespace


ReaderWriterSpinLock Constructor

Grid Solutions Framework ReaderWriterSpinLock Constructor
Initializes a new instance of the ReaderWriterSpinLock class

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ReaderWriterSpinLock()
Public Sub New
new : unit -> ReaderWriterSpinLock
GSF.Threading.ReaderWriterSpinLock = function();
public:
ReaderWriterSpinLock()
See Also

Reference

ReaderWriterSpinLock Class
GSF.Threading Namespace


ReaderWriterSpinLock Methods

Grid Solutions Framework ReaderWriterSpinLock Methods

The ReaderWriterSpinLock type exposes the following members.

Methods
 | Name | Description
Public method | EnterReadLock | Enters the lock in read mode.
Public method | EnterWriteLock | Enters the lock in write mode.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExitReadLock | Exits read mode.
Public method | ExitWriteLock | Exits write mode.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ReaderWriterSpinLock Class
GSF.Threading Namespace


ReaderWriterSpinLock.EnterReadLock Method

Grid Solutions Framework ReaderWriterSpinLockEnterReadLock Method
Enters the lock in read mode.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EnterReadLock()
Public Sub EnterReadLock
member EnterReadLock : unit -> unit

function EnterReadLock();
public:
void EnterReadLock()
Remarks
Upon successful acquisition of a read lock, use the finally block of a try/finally statement to call ExitReadLock. One ExitReadLock should be called for each EnterReadLock.
See Also

Reference

ReaderWriterSpinLock Class
GSF.Threading Namespace


ReaderWriterSpinLock.EnterWriteLock Method

Grid Solutions Framework ReaderWriterSpinLockEnterWriteLock Method
Enters the lock in write mode.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void EnterWriteLock()
Public Sub EnterWriteLock
member EnterWriteLock : unit -> unit

function EnterWriteLock();
public:
void EnterWriteLock()
Remarks
Upon successful acquisition of a write lock, use the finally block of a try/finally statement to call ExitWriteLock. One ExitWriteLock should be called for each EnterWriteLock.
See Also

Reference

ReaderWriterSpinLock Class
GSF.Threading Namespace


ReaderWriterSpinLock.ExitReadLock Method

Grid Solutions Framework ReaderWriterSpinLockExitReadLock Method
Exits read mode.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ExitReadLock()
Public Sub ExitReadLock
member ExitReadLock : unit -> unit

function ExitReadLock();
public:
void ExitReadLock()
Exceptions
Exception | Condition
InvalidOperationException | Cannot exit read lock when there are no readers.
See Also

Reference

ReaderWriterSpinLock Class
GSF.Threading Namespace


ReaderWriterSpinLock.ExitWriteLock Method

Grid Solutions Framework ReaderWriterSpinLockExitWriteLock Method
Exits write mode.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ExitWriteLock()
Public Sub ExitWriteLock
member ExitWriteLock : unit -> unit

function ExitWriteLock();
public:
void ExitWriteLock()
See Also

Reference

ReaderWriterSpinLock Class
GSF.Threading Namespace


ScheduledTask Class

Grid Solutions Framework ScheduledTask Class
Represents a way to schedule a task to be executed on a separate thread immediately or after a given time delay.
Inheritance Hierarchy
SystemObject
GSF.ThreadingScheduledTask

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ScheduledTask : IDisposable
Public Class ScheduledTask
    Implements IDisposable
type ScheduledTask =
    class
        interface IDisposable
    end
GSF.Threading.ScheduledTask = function();

Type.createClass(
    'GSF.Threading.ScheduledTask',
    null,
    IDisposable);
public ref class ScheduledTask : IDisposable

The ScheduledTask type exposes the following members.

Constructors
 | Name | Description
Public method | ScheduledTask | Creates a ScheduledTask.
Top
Methods
 | Name | Description
Public method | Dispose | Starts the disposing process of exiting the worker thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Cleans up the ThreadContainerBase thread since that class likely will never be garbage collected. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts the task immediately, or if one was scheduled, starts the scheduled task immediately
Public method | Start(Int32) | Starts a timer to run the task after a provided interval.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Events
 | Name | Description
Public event | Disposing | Occurs right before this task is disposed.
Public event | Running | Occurs every time the task should run.
Public event | UnhandledException | Occurs when Running or Disposing event throws an exception.
Top
See Also

Reference

GSF.Threading Namespace


ScheduledTask Constructor

Grid Solutions Framework ScheduledTask Constructor
Creates a ScheduledTask.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ScheduledTask(
    ThreadingMode threadMode = ThreadingMode.ThreadPool,
    ThreadPriority priority = ThreadPriority.Normal
)
Public Sub New (
    Optional threadMode As ThreadingMode = ThreadingMode.ThreadPool,
    Optional priority As ThreadPriority = ThreadPriority.Normal
)
new :
        ?threadMode : ThreadingMode *
        ?priority : ThreadPriority
(* Defaults:
        let _threadMode = defaultArg threadMode ThreadingMode.ThreadPool
        let _priority = defaultArg priority ThreadPriority.Normal
*)
-> ScheduledTask
GSF.Threading.ScheduledTask = function(threadMode, priority);
public:
ScheduledTask(
    ThreadingMode threadMode = ThreadingMode::ThreadPool,
    ThreadPriority priority = ThreadPriority::Normal
)

Parameters

threadMode (Optional)
Type: GSF.ThreadingThreadingMode
The manner in which the scheduled task executes.
priority (Optional)
Type: System.ThreadingThreadPriority
The thread priority to assign if a dedicated thread is used. This is ignored if using the thread-pool.
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask Methods

Grid Solutions Framework ScheduledTask Methods

The ScheduledTask type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Starts the disposing process of exiting the worker thread.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Cleans up the ThreadContainerBase thread since that class likely will never be garbage collected. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Starts the task immediately, or if one was scheduled, starts the scheduled task immediately
Public method | Start(Int32) | Starts a timer to run the task after a provided interval.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask.Dispose Method

Grid Solutions Framework ScheduledTaskDispose Method
Starts the disposing process of exiting the worker thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
Remarks

Callback will be invoked one more time. Duplicate calls are ignored.

Unless called from the worker thread, this method will block until the dispose has successfully completed.

See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask.Finalize Method

Grid Solutions Framework ScheduledTaskFinalize Method
Cleans up the ThreadContainerBase thread since that class likely will never be garbage collected.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask.Start Method

Grid Solutions Framework ScheduledTaskStart Method
Overload List
 | Name | Description
Public method | Start | Starts the task immediately, or if one was scheduled, starts the scheduled task immediately
Public method | Start(Int32) | Starts a timer to run the task after a provided interval.
Top
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask.Start Method

Grid Solutions Framework ScheduledTaskStart Method
Starts the task immediately, or if one was scheduled, starts the scheduled task immediately

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start()
Public Sub Start
member Start : unit -> unit

function Start();
public:
void Start()
Remarks

If this is called after a Start(Int32) the timer will be canceled and the process will still start immediately.

This method is safe to call from any thread, including the worker thread. If disposed, this method will no nothing.

See Also

Reference

ScheduledTask Class
Start Overload
GSF.Threading Namespace


ScheduledTask.Start Method (Int32)

Grid Solutions Framework ScheduledTaskStart Method (Int32)
Starts a timer to run the task after a provided interval.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Start(
    int delay
)
Public Sub Start (
    delay As Integer
)
member Start :
        delay : int -> unit

function Start(delay);
public:
void Start(
    int delay
)

Parameters

delay
Type: SystemInt32
the delay in milliseconds before the task should run
Remarks

If a timer is currently pending, this function will do nothing. Do not use this function to reset or restart an existing timer.

If called while working, a subsequent timer will be scheduled, but delay will not start until after the worker has completed.

This method is safe to call from any thread, including the worker thread. If disposed, this method will no nothing.

See Also

Reference

ScheduledTask Class
Start Overload
GSF.Threading Namespace


ScheduledTask Events

Grid Solutions Framework ScheduledTask Events

The ScheduledTask type exposes the following members.

Events
 | Name | Description
Public event | Disposing | Occurs right before this task is disposed.
Public event | Running | Occurs every time the task should run.
Public event | UnhandledException | Occurs when Running or Disposing event throws an exception.
Top
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask.Disposing Event

Grid Solutions Framework ScheduledTaskDisposing Event
Occurs right before this task is disposed.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposing
Public Event Disposing As EventHandler
member Disposing : IEvent<EventHandler,
    EventArgs>

function add_Disposing(value);
function remove_Disposing(value);
public:
 event EventHandler^ Disposing {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask.Running Event

Grid Solutions Framework ScheduledTaskRunning Event
Occurs every time the task should run.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ScheduledTaskRunningReason>> Running
Public Event Running As EventHandler(Of EventArgs(Of ScheduledTaskRunningReason))
member Running : IEvent<EventHandler<EventArgs<ScheduledTaskRunningReason>>,
    EventArgs<ScheduledTaskRunningReason>>

function add_Running(value);
function remove_Running(value);
public:
 event EventHandler<EventArgs<ScheduledTaskRunningReason>^>^ Running {
    void add (EventHandler<EventArgs<ScheduledTaskRunningReason>^>^ value);
    void remove (EventHandler<EventArgs<ScheduledTaskRunningReason>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ScheduledTaskRunningReason
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTask.UnhandledException Event

Grid Solutions Framework ScheduledTaskUnhandledException Event
Occurs when Running or Disposing event throws an exception.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> UnhandledException
Public Event UnhandledException As EventHandler(Of EventArgs(Of Exception))
member UnhandledException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_UnhandledException(value);
function remove_UnhandledException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ UnhandledException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

ScheduledTask Class
GSF.Threading Namespace


ScheduledTaskRunningReason Enumeration

Grid Solutions Framework ScheduledTaskRunningReason Enumeration
Metadata about why this worker was called.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ScheduledTaskRunningReason
Public Enumeration ScheduledTaskRunningReason
type ScheduledTaskRunningReason
GSF.Threading.ScheduledTaskRunningReason = function();
GSF.Threading.ScheduledTaskRunningReason.createEnum('GSF.Threading.ScheduledTaskRunningReason', false);
public enum class ScheduledTaskRunningReason
Members
Member name | Value | Description
Running | 0 | A normal run was scheduled.
Disposing | 1 | Dispose was called and execution will terminate after this function call.
See Also

Reference

GSF.Threading Namespace


ShortSynchronizedOperation Class

Grid Solutions Framework ShortSynchronizedOperation Class
Represents a short-running synchronized operation that cannot run while it is already in progress.
Inheritance Hierarchy
SystemObject
GSF.ThreadingSynchronizedOperationBase
GSF.ThreadingShortSynchronizedOperation

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ShortSynchronizedOperation : SynchronizedOperationBase
Public Class ShortSynchronizedOperation
    Inherits SynchronizedOperationBase
type ShortSynchronizedOperation =
    class
        inherit SynchronizedOperationBase
    end
GSF.Threading.ShortSynchronizedOperation = function();

Type.createClass(
    'GSF.Threading.ShortSynchronizedOperation',
    GSF.Threading.SynchronizedOperationBase);
public ref class ShortSynchronizedOperation : public SynchronizedOperationBase

The ShortSynchronizedOperation type exposes the following members.

Constructors
 | Name | Description
Public method | ShortSynchronizedOperation(Action) | Creates a new instance of the ShortSynchronizedOperation class.
Public method | ShortSynchronizedOperation(Action, ActionException) | Creates a new instance of the ShortSynchronizedOperation class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action in an asynchronous loop on the thread pool, as long as the operation is pending. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
Remarks
The action performed by the ShortSynchronizedOperation is executed on the ThreadPool when running the operation asynchronously. When the operation is set to pending, the action is executed in an asynchronous loop on the thread pool until all pending operations have been completed. Since the action is executed on the thread pool, it is best if it can be executed quickly, without blocking the thread or putting it to sleep. If completion of the operation is critical, such as when saving data to a file, this type of operation should not be used since thread pool threads are background threads and will not prevent the program from ending before the operation is complete.
See Also

Reference

GSF.Threading Namespace


ShortSynchronizedOperation Constructor

Grid Solutions Framework ShortSynchronizedOperation Constructor
Overload List
 | Name | Description
Public method | ShortSynchronizedOperation(Action) | Creates a new instance of the ShortSynchronizedOperation class.
Public method | ShortSynchronizedOperation(Action, ActionException) | Creates a new instance of the ShortSynchronizedOperation class.
Top
See Also

Reference

ShortSynchronizedOperation Class
GSF.Threading Namespace


ShortSynchronizedOperation Constructor (Action)

Grid Solutions Framework ShortSynchronizedOperation Constructor (Action)
Creates a new instance of the ShortSynchronizedOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ShortSynchronizedOperation(
    Action action
)
Public Sub New (
    action As Action
)
new :
        action : Action -> ShortSynchronizedOperation
GSF.Threading.ShortSynchronizedOperation = function(action);
public:
ShortSynchronizedOperation(
    Action^ action
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
See Also

Reference

ShortSynchronizedOperation Class
ShortSynchronizedOperation Overload
GSF.Threading Namespace


ShortSynchronizedOperation Constructor (Action, Action(Exception))

Grid Solutions Framework ShortSynchronizedOperation Constructor (Action, ActionException)
Creates a new instance of the ShortSynchronizedOperation class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ShortSynchronizedOperation(
    Action action,
    Action<Exception> exceptionAction
)
Public Sub New (
    action As Action,
    exceptionAction As Action(Of Exception)
)
new :
        action : Action *
        exceptionAction : Action<Exception> -> ShortSynchronizedOperation
GSF.Threading.ShortSynchronizedOperation = function(action, exceptionAction);
public:
ShortSynchronizedOperation(
    Action^ action,
    Action<Exception^>^ exceptionAction
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
exceptionAction
Type: SystemAction Exception
The action to be performed if an exception is thrown from the action.
See Also

Reference

ShortSynchronizedOperation Class
ShortSynchronizedOperation Overload
GSF.Threading Namespace


ShortSynchronizedOperation Methods

Grid Solutions Framework ShortSynchronizedOperation Methods

The ShortSynchronizedOperation type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread. (Inherited from SynchronizedOperationBase.)
Protected method | ExecuteActionAsync | Executes the action in an asynchronous loop on the thread pool, as long as the operation is pending. (Overrides SynchronizedOperationBaseExecuteActionAsync.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running. (Inherited from SynchronizedOperationBase.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ShortSynchronizedOperation Class
GSF.Threading Namespace


ShortSynchronizedOperation.ExecuteActionAsync Method

Grid Solutions Framework ShortSynchronizedOperationExecuteActionAsync Method
Executes the action in an asynchronous loop on the thread pool, as long as the operation is pending.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExecuteActionAsync()
Protected Overrides Sub ExecuteActionAsync
abstract ExecuteActionAsync : unit -> unit
override ExecuteActionAsync : unit -> unit
function ExecuteActionAsync();
protected:
virtual void ExecuteActionAsync() override
See Also

Reference

ShortSynchronizedOperation Class
GSF.Threading Namespace


ShortSynchronizedOperation Properties

Grid Solutions Framework ShortSynchronizedOperation Properties

The ShortSynchronizedOperation type exposes the following members.

Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed. (Inherited from SynchronizedOperationBase.)
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action. (Inherited from SynchronizedOperationBase.)
Top
See Also

Reference

ShortSynchronizedOperation Class
GSF.Threading Namespace


SynchronizedOperationBase Class

Grid Solutions Framework SynchronizedOperationBase Class
Base class for operations that cannot run while they is already in progress.
Inheritance Hierarchy
SystemObject
GSF.ThreadingSynchronizedOperationBase
GSF.ThreadingLogicalThreadOperation
GSF.ThreadingLongSynchronizedOperation
GSF.ThreadingMixedSynchronizedOperation
GSF.ThreadingShortSynchronizedOperation

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class SynchronizedOperationBase : ISynchronizedOperation
Public MustInherit Class SynchronizedOperationBase
    Implements ISynchronizedOperation
[<AbstractClassAttribute>]
type SynchronizedOperationBase =
    class
        interface ISynchronizedOperation
    end
GSF.Threading.SynchronizedOperationBase = function();

Type.createClass(
    'GSF.Threading.SynchronizedOperationBase',
    null,
    GSF.Threading.ISynchronizedOperation);
public ref class SynchronizedOperationBase abstract : ISynchronizedOperation

The SynchronizedOperationBase type exposes the following members.

Constructors
 | Name | Description
Protected method | SynchronizedOperationBase(Action) | Creates a new instance of the SynchronizedOperationBase class.
Protected method | SynchronizedOperationBase(Action, ActionException) | Creates a new instance of the SynchronizedOperationBase class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread.
Protected method | ExecuteActionAsync | Executes the action on a separate thread.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed.
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action.
Top
Remarks
This class handles the synchronization between the methods defined in the ISynchronizedOperation interface. Implementers should only need to implement the ExecuteActionAsync method to provide a mechanism for executing the action on a separate thread.
See Also

Reference

GSF.Threading Namespace


SynchronizedOperationBase Constructor

Grid Solutions Framework SynchronizedOperationBase Constructor
Overload List
 | Name | Description
Protected method | SynchronizedOperationBase(Action) | Creates a new instance of the SynchronizedOperationBase class.
Protected method | SynchronizedOperationBase(Action, ActionException) | Creates a new instance of the SynchronizedOperationBase class.
Top
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase Constructor (Action)

Grid Solutions Framework SynchronizedOperationBase Constructor (Action)
Creates a new instance of the SynchronizedOperationBase class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected SynchronizedOperationBase(
    Action action
)
Protected Sub New (
    action As Action
)
new :
        action : Action -> SynchronizedOperationBase
GSF.Threading.SynchronizedOperationBase = function(action);
protected:
SynchronizedOperationBase(
    Action^ action
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
See Also

Reference

SynchronizedOperationBase Class
SynchronizedOperationBase Overload
GSF.Threading Namespace


SynchronizedOperationBase Constructor (Action, Action(Exception))

Grid Solutions Framework SynchronizedOperationBase Constructor (Action, ActionException)
Creates a new instance of the SynchronizedOperationBase class.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected SynchronizedOperationBase(
    Action action,
    Action<Exception> exceptionAction
)
Protected Sub New (
    action As Action,
    exceptionAction As Action(Of Exception)
)
new :
        action : Action *
        exceptionAction : Action<Exception> -> SynchronizedOperationBase
GSF.Threading.SynchronizedOperationBase = function(action, exceptionAction);
protected:
SynchronizedOperationBase(
    Action^ action,
    Action<Exception^>^ exceptionAction
)

Parameters

action
Type: SystemAction
The action to be performed during this operation.
exceptionAction
Type: SystemAction Exception
The action to be performed if an exception is thrown from the action.
See Also

Reference

SynchronizedOperationBase Class
SynchronizedOperationBase Overload
GSF.Threading Namespace


SynchronizedOperationBase Methods

Grid Solutions Framework SynchronizedOperationBase Methods

The SynchronizedOperationBase type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteAction | Executes the action once on the current thread.
Protected method | ExecuteActionAsync | Executes the action on a separate thread.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnce | Executes the action on this thread or marks the operation as pending if the operation is already running.
Public method | RunOnceAsync | Executes the action on another thread or marks the operation as pending if the operation is already running.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryRun | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnce | Attempts to execute the action on this thread. Does nothing if the operation is already running.
Public method | TryRunOnceAsync | Attempts to execute the action on another thread. Does nothing if the operation is already running.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.ExecuteAction Method

Grid Solutions Framework SynchronizedOperationBaseExecuteAction Method
Executes the action once on the current thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool ExecuteAction()
Protected Function ExecuteAction As Boolean
member ExecuteAction : unit -> bool

function ExecuteAction();
protected:
bool ExecuteAction()

Return Value

Type: Boolean
True if the action was pending and needs to run again; false otherwise.
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.ExecuteActionAsync Method

Grid Solutions Framework SynchronizedOperationBaseExecuteActionAsync Method
Executes the action on a separate thread.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void ExecuteActionAsync()
Protected MustOverride Sub ExecuteActionAsync
abstract ExecuteActionAsync : unit -> unit

function ExecuteActionAsync();
protected:
virtual void ExecuteActionAsync() abstract
Remarks
Implementers should call ExecuteAction on a separate thread and check the return value. If it returns true, that means it needs to run again. The following is a sample implementation using a regular dedicated thread.
Copy
protected override void ExecuteActionAsync()
{
    Thread actionThread = new Thread(() =>
    {
        while (ExecuteAction())
        {
        }
    });

    actionThread.Start();
}
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.Run Method

Grid Solutions Framework SynchronizedOperationBaseRun Method
Executes the action on this thread or marks the operation as pending if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Run()
Public Sub Run
abstract Run : unit -> unit
override Run : unit -> unit
function Run();
public:
virtual void Run() sealed

Implements

ISynchronizedOperationRun
Remarks

When the operation is marked as pending, it will run again after the operation that is currently running has completed. This is useful if an update has invalidated the operation that is currently running and will therefore need to be run again.

This method does not guarantee that control will be returned to the thread that called it. If other threads continuously mark the operation as pending, this thread will continue to run the operation indefinitely.

See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.RunOnce Method

Grid Solutions Framework SynchronizedOperationBaseRunOnce Method
Executes the action on this thread or marks the operation as pending if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RunOnce()
Public Sub RunOnce
abstract RunOnce : unit -> unit
override RunOnce : unit -> unit
function RunOnce();
public:
virtual void RunOnce() sealed

Implements

ISynchronizedOperationRunOnce
Remarks
When the operation is marked as pending, it will run again after the operation that is currently running has completed. This is useful if an update has invalidated the operation that is currently running and will therefore need to be run again.
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.RunOnceAsync Method

Grid Solutions Framework SynchronizedOperationBaseRunOnceAsync Method
Executes the action on another thread or marks the operation as pending if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RunOnceAsync()
Public Sub RunOnceAsync
abstract RunOnceAsync : unit -> unit
override RunOnceAsync : unit -> unit
function RunOnceAsync();
public:
virtual void RunOnceAsync() sealed

Implements

ISynchronizedOperationRunOnceAsync
Remarks
When the operation is marked as pending, it will run again after the operation that is currently running has completed. This is useful if an update has invalidated the operation that is currently running and will therefore need to be run again.
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.TryRun Method

Grid Solutions Framework SynchronizedOperationBaseTryRun Method
Attempts to execute the action on this thread. Does nothing if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void TryRun()
Public Sub TryRun
abstract TryRun : unit -> unit
override TryRun : unit -> unit
function TryRun();
public:
virtual void TryRun() sealed

Implements

ISynchronizedOperationTryRun
Remarks
This method does not guarantee that control will be returned to the thread that called it. If other threads continuously mark the operation as pending, this thread will continue to run the operation indefinitely.
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.TryRunOnce Method

Grid Solutions Framework SynchronizedOperationBaseTryRunOnce Method
Attempts to execute the action on this thread. Does nothing if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void TryRunOnce()
Public Sub TryRunOnce
abstract TryRunOnce : unit -> unit
override TryRunOnce : unit -> unit
function TryRunOnce();
public:
virtual void TryRunOnce() sealed

Implements

ISynchronizedOperationTryRunOnce
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.TryRunOnceAsync Method

Grid Solutions Framework SynchronizedOperationBaseTryRunOnceAsync Method
Attempts to execute the action on another thread. Does nothing if the operation is already running.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void TryRunOnceAsync()
Public Sub TryRunOnceAsync
abstract TryRunOnceAsync : unit -> unit
override TryRunOnceAsync : unit -> unit
function TryRunOnceAsync();
public:
virtual void TryRunOnceAsync() sealed

Implements

ISynchronizedOperationTryRunOnceAsync
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase Properties

Grid Solutions Framework SynchronizedOperationBase Properties

The SynchronizedOperationBase type exposes the following members.

Properties
 | Name | Description
Public property | IsPending | Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed.
Public property | IsRunning | Gets a value to indicate whether the synchronized operation is currently executing its action.
Top
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.IsPending Property

Grid Solutions Framework SynchronizedOperationBaseIsPending Property
Gets a value to indiate whether the synchronized operation has an additional operation that is pending execution after the currently running action has completed.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsPending { get; }
Public ReadOnly Property IsPending As Boolean
    Get
abstract IsPending : bool with get
override IsPending : bool with get
function get_IsPending();

public:
virtual property bool IsPending {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISynchronizedOperationIsPending
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationBase.IsRunning Property

Grid Solutions Framework SynchronizedOperationBaseIsRunning Property
Gets a value to indicate whether the synchronized operation is currently executing its action.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsRunning { get; }
Public ReadOnly Property IsRunning As Boolean
    Get
abstract IsRunning : bool with get
override IsRunning : bool with get
function get_IsRunning();

public:
virtual property bool IsRunning {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISynchronizedOperationIsRunning
See Also

Reference

SynchronizedOperationBase Class
GSF.Threading Namespace


SynchronizedOperationType Enumeration

Grid Solutions Framework SynchronizedOperationType Enumeration
Represents the available types of synchronized operations.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SynchronizedOperationType
Public Enumeration SynchronizedOperationType
type SynchronizedOperationType
GSF.Threading.SynchronizedOperationType = function();
GSF.Threading.SynchronizedOperationType.createEnum('GSF.Threading.SynchronizedOperationType', false);
public enum class SynchronizedOperationType
Members
Member name | Value | Description
Short | 0 | ShortSynchronizedOperation
Long | 1 | LongSynchronizedOperation
LongBackground | 2 | LongSynchronizedOperation with IsBackground set to true
Mixed | 3 | MixedSynchronizedOperation
See Also

Reference

GSF.Threading Namespace


ThreadingMode Enumeration

Grid Solutions Framework ThreadingMode Enumeration
Specifies the threading mode to use for the ScheduledTask

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ThreadingMode
Public Enumeration ThreadingMode
type ThreadingMode
GSF.Threading.ThreadingMode = function();
GSF.Threading.ThreadingMode.createEnum('GSF.Threading.ThreadingMode', false);
public enum class ThreadingMode
Members
Member name | Value | Description
DedicatedForeground | 0 | A dedicated thread that is a foreground thread.
DedicatedBackground | 1 | A dedicated thread that is a background thread.
ThreadPool | 2 | A background thread from the thread pool.
See Also

Reference

GSF.Threading Namespace


ThreadStatus Enumeration

Grid Solutions Framework ThreadStatus Enumeration
Managed Thread States

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ThreadStatus
Public Enumeration ThreadStatus
type ThreadStatus
GSF.Threading.ThreadStatus = function();
GSF.Threading.ThreadStatus.createEnum('GSF.Threading.ThreadStatus', false);
public enum class ThreadStatus
Members
Member name | Value | Description
Unstarted | 0 | Thread created, not started
Queued | 1 | Thread queued for execution
Started | 2 | Thread start requested, execution pending
Executing | 3 | Thread executing
Completed | 4 | Thread completed
Aborted | 5 | Thread aborted
See Also

Reference

GSF.Threading Namespace


ThreadType Enumeration

Grid Solutions Framework ThreadType Enumeration
Managed Thread Types

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ThreadType
Public Enumeration ThreadType
type ThreadType
GSF.Threading.ThreadType = function();
GSF.Threading.ThreadType.createEnum('GSF.Threading.ThreadType', false);
public enum class ThreadType
Members
Member name | Value | Description
StandardThread | 0 | Standard thread created with public constructor
QueuedThread | 1 | Queued thread added into managed thread pool
See Also

Reference

GSF.Threading Namespace


WeakAction Class

Grid Solutions Framework WeakAction Class
Provides a weak referenced action delegate.
Inheritance Hierarchy
SystemObject
SystemWeakReference
GSF.ThreadingWeakAction

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class WeakAction : WeakReference
<SerializableAttribute>
Public Class WeakAction
    Inherits WeakReference
[<SerializableAttribute>]
type WeakAction =
    class
        inherit WeakReference
    end
GSF.Threading.WeakAction = function();

Type.createClass(
    'GSF.Threading.WeakAction',
    WeakReference);
[SerializableAttribute]
public ref class WeakAction : public WeakReference

The WeakAction type exposes the following members.

Constructors
 | Name | Description
Public method | WeakAction | Creates a high speed weak action.
Top
Methods
 | Name | Description
Public method | Clear | Clears Action callback target.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Discards the reference to the target represented by the current WeakReference object. (Inherited from WeakReference.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize the current WeakReference object. (Inherited from WeakReference.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryInvoke | Attempts to invoke the delegate to a weak reference object.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsAlive | Gets an indication whether the object referenced by the current WeakReference object has been garbage collected. (Inherited from WeakReference.)
Public property | Target | Gets or sets the object (the target) referenced by the current WeakReference object. (Inherited from WeakReference.)
Public property | TrackResurrection | Gets an indication whether the object referenced by the current WeakReference object is tracked after it is finalized. (Inherited from WeakReference.)
Top
Remarks

Unlike many implementations of a weak action, this class does not use reflection so calls will be faster. However, a strong reference *must* be maintained for the Action callback passed to this class. This reference is returned through an out parameter in the constructor.

Careful consideration must be made when deciding where to store the strong reference as this strong reference will need to also lose reference. A good place would be as a member variable of the object of the target method.

See Also

Reference

GSF.Threading Namespace


WeakAction Constructor

Grid Solutions Framework WeakAction Constructor
Creates a high speed weak action.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WeakAction(
    Action callback,
    out Object localStrongReference
)
Public Sub New (
    callback As Action,
    <OutAttribute> ByRef localStrongReference As Object
)
new :
        callback : Action *
        localStrongReference : Object byref -> WeakAction
GSF.Threading.WeakAction = function(callback, localStrongReference);
public:
WeakAction(
    Action^ callback,
    [OutAttribute] Object^% localStrongReference
)

Parameters

callback
Type: SystemAction
The callback.
localStrongReference
Type: SystemObject
A strong reference that must be maintained in the class that is the target of the action.
See Also

Reference

WeakAction Class
GSF.Threading Namespace


WeakAction Methods

Grid Solutions Framework WeakAction Methods

The WeakAction type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears Action callback target.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Discards the reference to the target represented by the current WeakReference object. (Inherited from WeakReference.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize the current WeakReference object. (Inherited from WeakReference.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryInvoke | Attempts to invoke the delegate to a weak reference object.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WeakAction Class
GSF.Threading Namespace


WeakAction.Clear Method

Grid Solutions Framework WeakActionClear Method
Clears Action callback target.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
See Also

Reference

WeakAction Class
GSF.Threading Namespace


WeakAction.TryInvoke Method

Grid Solutions Framework WeakActionTryInvoke Method
Attempts to invoke the delegate to a weak reference object.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryInvoke()
Public Function TryInvoke As Boolean
member TryInvoke : unit -> bool

function TryInvoke();
public:
bool TryInvoke()

Return Value

Type: Boolean
true if successful; otherwise, false.
See Also

Reference

WeakAction Class
GSF.Threading Namespace


WeakAction Properties

Grid Solutions Framework WeakAction Properties

The WeakAction type exposes the following members.

Properties
 | Name | Description
Public property | IsAlive | Gets an indication whether the object referenced by the current WeakReference object has been garbage collected. (Inherited from WeakReference.)
Public property | Target | Gets or sets the object (the target) referenced by the current WeakReference object. (Inherited from WeakReference.)
Public property | TrackResurrection | Gets an indication whether the object referenced by the current WeakReference object is tracked after it is finalized. (Inherited from WeakReference.)
Top
See Also

Reference

WeakAction Class
GSF.Threading Namespace


WeakAction(T) Class

Grid Solutions Framework WeakActionT Class
Provides a weak referenced action delegate.
Inheritance Hierarchy
SystemObject
SystemWeakReference
GSF.ThreadingWeakActionT

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class WeakAction<T> : WeakReference

<SerializableAttribute>
Public Class WeakAction(Of T)
    Inherits WeakReference
[<SerializableAttribute>]
type WeakAction<'T> =
    class
        inherit WeakReference
    end
JavaScript does not support generic types or methods.
[SerializableAttribute]
generic<typename T>
public ref class WeakAction : public WeakReference

Type Parameters

T

[Missing <typeparam name="T"/> documentation for "T:GSF.Threading.WeakAction`1"]

The WeakActionT type exposes the following members.

Constructors
 | Name | Description
Public method | WeakActionT | Creates a high speed weak action
Top
Methods
 | Name | Description
Public method | Clear | Clears Action callback target.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Discards the reference to the target represented by the current WeakReference object. (Inherited from WeakReference.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize the current WeakReference object. (Inherited from WeakReference.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryInvoke | Attempts to invoke the delegate to a weak reference object.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | IsAlive | Gets an indication whether the object referenced by the current WeakReference object has been garbage collected. (Inherited from WeakReference.)
Public property | Target | Gets or sets the object (the target) referenced by the current WeakReference object. (Inherited from WeakReference.)
Public property | TrackResurrection | Gets an indication whether the object referenced by the current WeakReference object is tracked after it is finalized. (Inherited from WeakReference.)
Top
Remarks

Unlike many implementations of a weak action, this class does not use reflection so calls will be faster. However, a strong reference *must* be maintained for the Action callback passed to this class. This reference is returned through an out parameter in the constructor.

Careful consideration must be made when deciding where to store the strong reference as this strong reference will need to also lose reference. A good place would be as a member variable of the object of the target method.

See Also

Reference

GSF.Threading Namespace


WeakAction(T) Constructor

Grid Solutions Framework WeakActionT Constructor
Creates a high speed weak action

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WeakAction(
    Action<T> callback,
    out Object localStrongReference
)
Public Sub New (
    callback As Action(Of T),
    <OutAttribute> ByRef localStrongReference As Object
)
new :
        callback : Action<'T> *
        localStrongReference : Object byref -> WeakAction
GSF.Threading.WeakAction = function(callback, localStrongReference);
public:
WeakAction(
    Action<T>^ callback,
    [OutAttribute] Object^% localStrongReference
)

Parameters

callback
Type: SystemAction T
The callback.
localStrongReference
Type: SystemObject
A strong reference that must be maintained in the class that is the target of the action.
See Also

Reference

WeakActionT Class
GSF.Threading Namespace


WeakAction(T) Methods

Grid Solutions Framework WeakActionT Methods

The WeakActionT generic type exposes the following members.

Methods
 | Name | Description
Public method | Clear | Clears Action callback target.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Discards the reference to the target represented by the current WeakReference object. (Inherited from WeakReference.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetObjectData | Populates a SerializationInfo object with all the data needed to serialize the current WeakReference object. (Inherited from WeakReference.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryInvoke | Attempts to invoke the delegate to a weak reference object.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WeakActionT Class
GSF.Threading Namespace


WeakAction(T).Clear Method

Grid Solutions Framework WeakActionTClear Method
Clears Action callback target.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Clear()
Public Sub Clear
member Clear : unit -> unit

function Clear();
public:
void Clear()
See Also

Reference

WeakActionT Class
GSF.Threading Namespace


WeakAction(T).TryInvoke Method

Grid Solutions Framework WeakActionTTryInvoke Method
Attempts to invoke the delegate to a weak reference object.

Namespace: GSF.Threading
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryInvoke(
    T args
)
Public Function TryInvoke (
    args As T
) As Boolean
member TryInvoke :
        args : 'T -> bool

function TryInvoke(args);
public:
bool TryInvoke(
    T args
)

Parameters

args
Type: T

[Missing <param name="args"/> documentation for "M:GSF.Threading.WeakAction`1.TryInvoke(`0)"]

Return Value

Type: Boolean
true if successful; otherwise, false.
See Also

Reference

WeakActionT Class
GSF.Threading Namespace


WeakAction(T) Properties

Grid Solutions Framework WeakActionT Properties

The WeakActionT generic type exposes the following members.

Properties
 | Name | Description
Public property | IsAlive | Gets an indication whether the object referenced by the current WeakReference object has been garbage collected. (Inherited from WeakReference.)
Public property | Target | Gets or sets the object (the target) referenced by the current WeakReference object. (Inherited from WeakReference.)
Public property | TrackResurrection | Gets an indication whether the object referenced by the current WeakReference object is tracked after it is finalized. (Inherited from WeakReference.)
Top
See Also

Reference

WeakActionT Class
GSF.Threading Namespace


GSF.TimeSeries Namespace

Grid Solutions Framework GSF.TimeSeries Namespace
Contains classes used to abstractly define time-series measured values and provide mechanisms for managing measurements.
Classes
 | Class | Description
Public class | Alarm | Represents an alarm that tests the values of an incoming signal to determine the state of alarm.
Public class | BufferBlockMeasurement | Represents a byte buffer that can be transported through the system as a IMeasurement.
Public class | ConcentratorBase | Measurement concentrator base class.
Public class | ConsoleHost | Console application operations used to host the time-series framework service.
Public class | DebugHostBase | Windows form application used to host the time-series framework service.
Public class | Frame | Implementation of a basic IFrame.
Public class | IMeasurementExtensions | Defines static extension functions for IMeasurement implementations.
Public class | ImmediateMeasurements | Represents the absolute latest measurement values received by a ConcentratorBase implementation.
Public class | InstallerBase | Defines a common installer class for the applications based on the time-series framework.
Public class | Measurement | Implementation of a basic measurement.
Public class | MeasurementKey | Represents a primary key for a measurement.
Public class | PrecisionInputTimer | Precision input timer.
Public class | ServiceClientBase | Represents a client that can remotely access the time-series framework service host.
Public class | ServiceHostBase | Represents the time-series framework service host.
Public class | TemporalMeasurement | Represents a time constrained measured value.
Public class | TimeSeriesStartupOperations | Defines a data operations to be performed at startup.
Interfaces
 | Interface | Description
Public interface | IDevice | Represents a device that acts as a source of IMeasurements.
Public interface | IFrame | Abstract frame interface representing a collection of measurements at an exact moment in time.
Public interface | IMeasurement | Represents an interface for an abstract measurement value measured by a device at an exact time.
Public interface | ITimeSeriesValue | Represents the fundamental binary value interface for a time-series value.
Public interface | ITimeSeriesValueT | Represents the fundamental typed interface for a time-series value.
Delegates
 | Delegate | Description
Public delegate | MeasurementValueFilterFunction | Method signature for function used to apply a value filter over a sequence of IMeasurement values.
Enumerations
 | Enumeration | Description
Public enumeration | AlarmOperation | Represents the operation to be performed when testing values from an incoming signal.
Public enumeration | AlarmSeverity | Represents the severity of alarms.
Public enumeration | AlarmState | Represents the two states that an alarm can be in: raised or cleared.
Public enumeration | ConfigurationType | Configuration data source type enumeration.
Public enumeration | DownsamplingMethod | Down-sampling method enumeration.
Public enumeration | MeasurementStateFlags | Measurement state flags.


Alarm Class

Grid Solutions Framework Alarm Class
Represents an alarm that tests the values of an incoming signal to determine the state of alarm.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesAlarm

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class Alarm : ICloneable
<SerializableAttribute>
Public Class Alarm
    Implements ICloneable
[<SerializableAttribute>]
type Alarm =
    class
        interface ICloneable
    end
GSF.TimeSeries.Alarm = function();

Type.createClass(
    'GSF.TimeSeries.Alarm',
    null,
    ICloneable);
[SerializableAttribute]
public ref class Alarm : ICloneable

The Alarm type exposes the following members.

Constructors
 | Name | Description
Public method | Alarm | Creates a new instance of the Alarm class.
Public method | Alarm(AlarmOperation) | Creates a new instance of the Alarm class.
Top
Methods
 | Name | Description
Public method | Clone | Creates a new alarm that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Test | Tests the value of the given measurement to determine whether the alarm should be raised or cleared.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AssociatedMeasurementID | Gets or sets the identification number of the measurements generated for alarm events.
Public property | Cause | Gets the most recent measurement that caused the alarm to be raised.
Public property | Delay | Gets or sets the amount of time that the signal must be exhibiting alarming behavior before the alarm is raised.
Public property | Description | Gets or sets the description of the alarm.
Public property | Hysteresis | Gets or sets the hysteresis used when clearing alarms. This value is only relevant in greater than (or equal) and less than (or equal) operations.
Public property | ID | Gets or sets the identification number of the alarm.
Public property | Operation | Gets or sets the operation to be performed when testing values from the incoming signal.
Public property | SetPoint | Gets or sets the value to be compared against the signal to determine whether to raise the alarm. This value is irrelevant for the Flatline operation.
Public property | Severity | Gets or sets the severity of the alarm.
Public property | SignalID | Gets or sets the identification number of the signal whose value is monitored by the alarm.
Public property | State | Gets or sets the current state of the alarm (raised or cleared).
Public property | TagName | Gets or sets the tag name of the alarm.
Public property | TimeRaised | Gets or sets the timestamp of the most recent measurement that caused the alarm to be raised.
Public property | Tolerance | Gets or sets a tolerance window around the SetPoint to use when comparing against the value of the signal. This value is only relevant for the Equal and NotEqual operations.
Top
See Also

Reference

GSF.TimeSeries Namespace


Alarm Constructor

Grid Solutions Framework Alarm Constructor
Overload List
 | Name | Description
Public method | Alarm | Creates a new instance of the Alarm class.
Public method | Alarm(AlarmOperation) | Creates a new instance of the Alarm class.
Top
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm Constructor

Grid Solutions Framework Alarm Constructor
Creates a new instance of the Alarm class.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Alarm()
Public Sub New
new : unit -> Alarm
GSF.TimeSeries.Alarm = function();
public:
Alarm()
See Also

Reference

Alarm Class
Alarm Overload
GSF.TimeSeries Namespace


Alarm Constructor (AlarmOperation)

Grid Solutions Framework Alarm Constructor (AlarmOperation)
Creates a new instance of the Alarm class.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Alarm(
    AlarmOperation operation
)
Public Sub New (
    operation As AlarmOperation
)
new :
        operation : AlarmOperation -> Alarm
GSF.TimeSeries.Alarm = function(operation);
public:
Alarm(
    AlarmOperation operation
)

Parameters

operation
Type: GSF.TimeSeriesAlarmOperation
The operation to be performed when testing values from the incoming signal.
See Also

Reference

Alarm Class
Alarm Overload
GSF.TimeSeries Namespace


Alarm Methods

Grid Solutions Framework Alarm Methods

The Alarm type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Creates a new alarm that is a copy of the current instance.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Test | Tests the value of the given measurement to determine whether the alarm should be raised or cleared.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Clone Method

Grid Solutions Framework AlarmClone Method
Creates a new alarm that is a copy of the current instance.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Alarm Clone()
Public Function Clone As Alarm
member Clone : unit -> Alarm

function Clone();
public:
Alarm^ Clone()

Return Value

Type: Alarm
A new alarm that is a copy of this instance.
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Test Method

Grid Solutions Framework AlarmTest Method
Tests the value of the given measurement to determine whether the alarm should be raised or cleared.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Test(
    IMeasurement measurement
)
Public Function Test (
    measurement As IMeasurement
) As Boolean
member Test :
        measurement : IMeasurement -> bool

function Test(measurement);
public:
bool Test(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
The measurement whose value is to be tested.

Return Value

Type: Boolean
true if the alarm's state changed; false otherwise
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm Properties

Grid Solutions Framework Alarm Properties

The Alarm type exposes the following members.

Properties
 | Name | Description
Public property | AssociatedMeasurementID | Gets or sets the identification number of the measurements generated for alarm events.
Public property | Cause | Gets the most recent measurement that caused the alarm to be raised.
Public property | Delay | Gets or sets the amount of time that the signal must be exhibiting alarming behavior before the alarm is raised.
Public property | Description | Gets or sets the description of the alarm.
Public property | Hysteresis | Gets or sets the hysteresis used when clearing alarms. This value is only relevant in greater than (or equal) and less than (or equal) operations.
Public property | ID | Gets or sets the identification number of the alarm.
Public property | Operation | Gets or sets the operation to be performed when testing values from the incoming signal.
Public property | SetPoint | Gets or sets the value to be compared against the signal to determine whether to raise the alarm. This value is irrelevant for the Flatline operation.
Public property | Severity | Gets or sets the severity of the alarm.
Public property | SignalID | Gets or sets the identification number of the signal whose value is monitored by the alarm.
Public property | State | Gets or sets the current state of the alarm (raised or cleared).
Public property | TagName | Gets or sets the tag name of the alarm.
Public property | TimeRaised | Gets or sets the timestamp of the most recent measurement that caused the alarm to be raised.
Public property | Tolerance | Gets or sets a tolerance window around the SetPoint to use when comparing against the value of the signal. This value is only relevant for the Equal and NotEqual operations.
Top
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.AssociatedMeasurementID Property

Grid Solutions Framework AlarmAssociatedMeasurementID Property
Gets or sets the identification number of the measurements generated for alarm events.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Nullable<Guid> AssociatedMeasurementID { get; set; }
Public Property AssociatedMeasurementID As Nullable(Of Guid)
    Get
    Set
member AssociatedMeasurementID : Nullable<Guid> with get, set

function get_AssociatedMeasurementID();
function set_AssociatedMeasurementID(value);
public:
property Nullable<Guid> AssociatedMeasurementID {
    Nullable<Guid> get ();
    void set (Nullable<Guid> value);
}

Property Value

Type: Nullable Guid
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Cause Property

Grid Solutions Framework AlarmCause Property
Gets the most recent measurement that caused the alarm to be raised.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IMeasurement Cause { get; }
Public ReadOnly Property Cause As IMeasurement
    Get
member Cause : IMeasurement with get

function get_Cause();

public:
property IMeasurement^ Cause {
    IMeasurement^ get ();
}

Property Value

Type: IMeasurement
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Delay Property

Grid Solutions Framework AlarmDelay Property
Gets or sets the amount of time that the signal must be exhibiting alarming behavior before the alarm is raised.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Nullable<double> Delay { get; set; }
Public Property Delay As Nullable(Of Double)
    Get
    Set
member Delay : Nullable<float> with get, set

function get_Delay();
function set_Delay(value);
public:
property Nullable<double> Delay {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Description Property

Grid Solutions Framework AlarmDescription Property
Gets or sets the description of the alarm.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Description { get; set; }
Public Property Description As String
    Get
    Set
member Description : string with get, set

function get_Description();
function set_Description(value);
public:
property String^ Description {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Hysteresis Property

Grid Solutions Framework AlarmHysteresis Property
Gets or sets the hysteresis used when clearing alarms. This value is only relevant in greater than (or equal) and less than (or equal) operations.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Nullable<double> Hysteresis { get; set; }
Public Property Hysteresis As Nullable(Of Double)
    Get
    Set
member Hysteresis : Nullable<float> with get, set

function get_Hysteresis();
function set_Hysteresis(value);
public:
property Nullable<double> Hysteresis {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
Remarks

The hysteresis is an offset that provides padding between the point at which the alarm is raised and the point at which the alarm is cleared. For example, in the case of the GreaterOrEqual operation:

  • Raised: value >= SetPoint
  • Cleared: value < SetPoint - Hysteresis

The direction of the offset depends on whether the operation is greater than (or equal) or less than (or equal). The hysteresis must be greater than zero.

See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.ID Property

Grid Solutions Framework AlarmID Property
Gets or sets the identification number of the alarm.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ID { get; set; }
Public Property ID As Integer
    Get
    Set
member ID : int with get, set

function get_ID();
function set_ID(value);
public:
property int ID {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Operation Property

Grid Solutions Framework AlarmOperation Property
Gets or sets the operation to be performed when testing values from the incoming signal.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AlarmOperation Operation { get; set; }
Public Property Operation As AlarmOperation
    Get
    Set
member Operation : AlarmOperation with get, set

function get_Operation();
function set_Operation(value);
public:
property AlarmOperation Operation {
    AlarmOperation get ();
    void set (AlarmOperation value);
}

Property Value

Type: AlarmOperation
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.SetPoint Property

Grid Solutions Framework AlarmSetPoint Property
Gets or sets the value to be compared against the signal to determine whether to raise the alarm. This value is irrelevant for the Flatline operation.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Nullable<double> SetPoint { get; set; }
Public Property SetPoint As Nullable(Of Double)
    Get
    Set
member SetPoint : Nullable<float> with get, set

function get_SetPoint();
function set_SetPoint(value);
public:
property Nullable<double> SetPoint {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Severity Property

Grid Solutions Framework AlarmSeverity Property
Gets or sets the severity of the alarm.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AlarmSeverity Severity { get; set; }
Public Property Severity As AlarmSeverity
    Get
    Set
member Severity : AlarmSeverity with get, set

function get_Severity();
function set_Severity(value);
public:
property AlarmSeverity Severity {
    AlarmSeverity get ();
    void set (AlarmSeverity value);
}

Property Value

Type: AlarmSeverity
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.SignalID Property

Grid Solutions Framework AlarmSignalID Property
Gets or sets the identification number of the signal whose value is monitored by the alarm.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid SignalID { get; set; }
Public Property SignalID As Guid
    Get
    Set
member SignalID : Guid with get, set

function get_SignalID();
function set_SignalID(value);
public:
property Guid SignalID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.State Property

Grid Solutions Framework AlarmState Property
Gets or sets the current state of the alarm (raised or cleared).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AlarmState State { get; set; }
Public Property State As AlarmState
    Get
    Set
member State : AlarmState with get, set

function get_State();
function set_State(value);
public:
property AlarmState State {
    AlarmState get ();
    void set (AlarmState value);
}

Property Value

Type: AlarmState
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.TagName Property

Grid Solutions Framework AlarmTagName Property
Gets or sets the tag name of the alarm.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string TagName { get; set; }
Public Property TagName As String
    Get
    Set
member TagName : string with get, set

function get_TagName();
function set_TagName(value);
public:
property String^ TagName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.TimeRaised Property

Grid Solutions Framework AlarmTimeRaised Property
Gets or sets the timestamp of the most recent measurement that caused the alarm to be raised.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks TimeRaised { get; set; }
Public Property TimeRaised As Ticks
    Get
    Set
member TimeRaised : Ticks with get, set

function get_TimeRaised();
function set_TimeRaised(value);
public:
property Ticks TimeRaised {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


Alarm.Tolerance Property

Grid Solutions Framework AlarmTolerance Property
Gets or sets a tolerance window around the SetPoint to use when comparing against the value of the signal. This value is only relevant for the Equal and NotEqual operations.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Nullable<double> Tolerance { get; set; }
Public Property Tolerance As Nullable(Of Double)
    Get
    Set
member Tolerance : Nullable<float> with get, set

function get_Tolerance();
function set_Tolerance(value);
public:
property Nullable<double> Tolerance {
    Nullable<double> get ();
    void set (Nullable<double> value);
}

Property Value

Type: Nullable Double
Remarks

The equal and not equal operations are actually internal and external range tests based on the setpoint and the tolerance. The two tests are performed as follows.

  • Equal: (value >= SetPoint - Tolerance) && (value <= SetPoint + Tolerance)
  • Not equal: (value < SetPoint - Tolerance) || (value > SetPoint + Tolerance)
See Also

Reference

Alarm Class
GSF.TimeSeries Namespace


AlarmOperation Enumeration

Grid Solutions Framework AlarmOperation Enumeration
Represents the operation to be performed when testing values from an incoming signal.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum AlarmOperation
Public Enumeration AlarmOperation
type AlarmOperation
GSF.TimeSeries.AlarmOperation = function();
GSF.TimeSeries.AlarmOperation.createEnum('GSF.TimeSeries.AlarmOperation', false);
public enum class AlarmOperation
Members
Member name | Value | Description
Equal | 1 | Internal range test
NotEqual | 2 | External range test
GreaterOrEqual | 11 | Upper bound
LessOrEqual | 21 | Lower bound
GreaterThan | 12 | Upper limit
LessThan | 22 | Lower limit
Flatline | 3 | Latched value
See Also

Reference

GSF.TimeSeries Namespace


AlarmSeverity Enumeration

Grid Solutions Framework AlarmSeverity Enumeration
Represents the severity of alarms.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum AlarmSeverity
Public Enumeration AlarmSeverity
type AlarmSeverity
GSF.TimeSeries.AlarmSeverity = function();
GSF.TimeSeries.AlarmSeverity.createEnum('GSF.TimeSeries.AlarmSeverity', false);
public enum class AlarmSeverity
Members
Member name | Value | Description
None | 0 | Indicates that an alarm is of no importance.
Information | 50 | Indicates that an alarm is informative, but not dangerous.
Low | 150 | Indicates that an alarm is not very important.
MediumLow | 300 | Indicates that an alarm is somewhat important.
Medium | 500 | Indicates that an alarm is moderately importance.
MediumHigh | 700 | Indicates that an alarm is important.
High | 850 | Indicates that an alarm is very important.
Unreasonable | 900 | Indicates an alarm for a value that is unreasonable.
Critical | 950 | Indicates than an alarm signifies a dangerous situation.
Latched | 980 | Indicates an alarm for a value that is latched, i.e., flat-lined.
Error | 1000 | Indicates that an alarm reports bad data.
See Also

Reference

GSF.TimeSeries Namespace


AlarmState Enumeration

Grid Solutions Framework AlarmState Enumeration
Represents the two states that an alarm can be in: raised or cleared.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum AlarmState
Public Enumeration AlarmState
type AlarmState
GSF.TimeSeries.AlarmState = function();
GSF.TimeSeries.AlarmState.createEnum('GSF.TimeSeries.AlarmState', false);
public enum class AlarmState
Members
Member name | Value | Description
Cleared | 0 | Indicates that an alarm is cleared.
Raised | 1 | Indicates that an alarm has been raised.
See Also

Reference

GSF.TimeSeries Namespace


BufferBlockMeasurement Class

Grid Solutions Framework BufferBlockMeasurement Class
Represents a byte buffer that can be transported through the system as a IMeasurement.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesMeasurement
GSF.TimeSeriesBufferBlockMeasurement

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BufferBlockMeasurement : Measurement
Public Class BufferBlockMeasurement
    Inherits Measurement
type BufferBlockMeasurement =
    class
        inherit Measurement
    end
GSF.TimeSeries.BufferBlockMeasurement = function();

Type.createClass(
    'GSF.TimeSeries.BufferBlockMeasurement',
    GSF.TimeSeries.Measurement);
public ref class BufferBlockMeasurement : public Measurement

The BufferBlockMeasurement type exposes the following members.

Constructors
 | Name | Description
Public method | BufferBlockMeasurement | Creates a new BufferBlockMeasurement.
Public method | BufferBlockMeasurement(Byte, Int32, Int32) | Creates a new BufferBlockMeasurement from an existing buffer.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | Buffer | Cached buffer image.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | Length | Valid length of cached buffer image.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
See Also

Reference

GSF.TimeSeries Namespace


BufferBlockMeasurement Constructor

Grid Solutions Framework BufferBlockMeasurement Constructor
Overload List
 | Name | Description
Public method | BufferBlockMeasurement | Creates a new BufferBlockMeasurement.
Public method | BufferBlockMeasurement(Byte, Int32, Int32) | Creates a new BufferBlockMeasurement from an existing buffer.
Top
See Also

Reference

BufferBlockMeasurement Class
GSF.TimeSeries Namespace


BufferBlockMeasurement Constructor

Grid Solutions Framework BufferBlockMeasurement Constructor
Creates a new BufferBlockMeasurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BufferBlockMeasurement()
Public Sub New
new : unit -> BufferBlockMeasurement
GSF.TimeSeries.BufferBlockMeasurement = function();
public:
BufferBlockMeasurement()
See Also

Reference

BufferBlockMeasurement Class
BufferBlockMeasurement Overload
GSF.TimeSeries Namespace


BufferBlockMeasurement Constructor (Byte[], Int32, Int32)

Grid Solutions Framework BufferBlockMeasurement Constructor (Byte, Int32, Int32)
Creates a new BufferBlockMeasurement from an existing buffer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BufferBlockMeasurement(
    byte[] buffer,
    int startIndex,
    int length
)
Public Sub New (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
)
new :
        buffer : byte[] *
        startIndex : int *
        length : int -> BufferBlockMeasurement
GSF.TimeSeries.BufferBlockMeasurement = function(buffer, startIndex, length);
public:
BufferBlockMeasurement(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte

[Missing <param name="buffer"/> documentation for "M:GSF.TimeSeries.BufferBlockMeasurement.#ctor(System.Byte[],System.Int32,System.Int32)"]

startIndex
Type: SystemInt32

[Missing <param name="startIndex"/> documentation for "M:GSF.TimeSeries.BufferBlockMeasurement.#ctor(System.Byte[],System.Int32,System.Int32)"]

length
Type: SystemInt32

[Missing <param name="length"/> documentation for "M:GSF.TimeSeries.BufferBlockMeasurement.#ctor(System.Byte[],System.Int32,System.Int32)"]

Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
See Also

Reference

BufferBlockMeasurement Class
BufferBlockMeasurement Overload
GSF.TimeSeries Namespace


BufferBlockMeasurement Methods

Grid Solutions Framework BufferBlockMeasurement Methods

The BufferBlockMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BufferBlockMeasurement Class
GSF.TimeSeries Namespace


BufferBlockMeasurement Properties

Grid Solutions Framework BufferBlockMeasurement Properties

The BufferBlockMeasurement type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | Buffer | Cached buffer image.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | Length | Valid length of cached buffer image.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
See Also

Reference

BufferBlockMeasurement Class
GSF.TimeSeries Namespace


BufferBlockMeasurement.Buffer Property

Grid Solutions Framework BufferBlockMeasurementBuffer Property
Cached buffer image.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[] Buffer { get; }
Public ReadOnly Property Buffer As Byte()
    Get
member Buffer : byte[] with get

function get_Buffer();

public:
property array<unsigned char>^ Buffer {
    array<unsigned char>^ get ();
}

Property Value

Type: Byte
See Also

Reference

BufferBlockMeasurement Class
GSF.TimeSeries Namespace


BufferBlockMeasurement.Length Property

Grid Solutions Framework BufferBlockMeasurementLength Property
Valid length of cached buffer image.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Length { get; }
Public ReadOnly Property Length As Integer
    Get
member Length : int with get

function get_Length();

public:
property int Length {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

BufferBlockMeasurement Class
GSF.TimeSeries Namespace


ConcentratorBase Class

Grid Solutions Framework ConcentratorBase Class
Measurement concentrator base class.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesConcentratorBase
GSF.TimeSeries.AdaptersActionAdapterBase

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ConcentratorBase : IDisposable
Public MustInherit Class ConcentratorBase
    Implements IDisposable
[<AbstractClassAttribute>]
type ConcentratorBase =
    class
        interface IDisposable
    end
GSF.TimeSeries.ConcentratorBase = function();

Type.createClass(
    'GSF.TimeSeries.ConcentratorBase',
    null,
    IDisposable);
public ref class ConcentratorBase abstract : IDisposable

The ConcentratorBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ConcentratorBase | Creates a new ConcentratorBase.
Protected method | ConcentratorBase(Int32, Double, Double) | Creates a new ConcentratorBase from specified parameters.
Top
Methods
 | Name | Description
Protected method | AssignMeasurementToFrame | Assigns IMeasurement to its associated IFrame.
Protected method | CreateNewFrame | Creates a new IFrame for the given timestamp.
Public method | Dispose | Releases all the resources used by the ConcentratorBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConcentratorBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ConcentratorBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MillisecondsFromRealTime | Returns the deviation, in milliseconds, that the given number of ticks is from real-time (i.e., RealTime).
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event.
Protected method | OnProcessException | Raises the ProcessException event.
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Protected method | PublishFrame | Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime.
Public method | ResetStatistics | Resets the statistics of the concentrator.
Public method | SecondsFromRealTime | Returns the deviation, in seconds, that the given number of ticks is from real-time (i.e., RealTime).
Public method | SortMeasurement | Sorts the IMeasurement placing the data point in its proper IFrame.
Public method | SortMeasurements | Sorts each IMeasurement placing each data point in its proper IFrame.
Public method | Start | Starts the concentrator, if it is not already running.
Public method | Stop | Stops the concentrator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowPreemptivePublishing | Gets or sets flag that allows system to preemptively publish frames assuming all ExpectedMeasurements have arrived.
Public property | AllowSortsByArrival | Gets or sets flag that determines whether or not to allow incoming measurements with bad timestamps to be sorted by arrival time.
Public property | AveragePublicationTimePerFrame | Gets the average required frame publication time, in seconds.
Public property | DiscardedMeasurements | Gets the total number of measurements that have been discarded because of old timestamps (i.e., measurements that were outside the time deviation tolerance from base time, past or future).
Public property | DownsampledMeasurements | Gets the total number of down-sampled measurements processed by the concentrator.
Public property | DownsamplingMethod | Gets or sets the DownsamplingMethod to be used by the concentrator.
Public property | Enabled | Gets or sets the current enabled state of concentrator.
Public property | ExpectedMeasurements | Gets or sets the expected number of measurements to be assigned to a single frame.
Public property | FramesAheadOfSchedule | Gets the total number of frames ahead of schedule processed by the concentrator.
Public property | FramesPerSecond | Gets or sets the number of frames per second.
Public property | IgnoreBadTimestamps | Gets or sets flag that determines if bad timestamps (as determined by measurement's timestamp quality) should be ignored when sorting measurements.
Public property | LagTicks | Gets defined past time deviation tolerance, in ticks.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LastDiscardedMeasurement | Gets a reference the last IMeasurement that was discarded by the concentrator.
Public property | LastDiscardedMeasurementLatency | Gets the calculated latency of the last IMeasurement that was discarded by the concentrator.
Public property | LastFrame | Gets reference to the last published IFrame.
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values.
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | MaximumPublicationTimeout | Gets or sets the maximum frame publication timeout in milliseconds, set to Infinite(-1) to wait indefinitely.
Public property | MeasurementsSortedByArrival | Gets the total number of measurements that were sorted by arrival because the measurement reported a bad timestamp quality.
Public property | MissedSortsByTimeout | Gets the total number of missed sorts by timeout processed by the concentrator.
Public property | PerformTimestampReasonabilityCheck | Gets or sets flag that determines if timestamp reasonability checks should be performed on incoming measurements (i.e., measurement timestamps are compared to system clock for reasonability using LeadTime tolerance).
Public property | ProcessByReceivedTimestamp | Gets or sets flag that determines if concentrator should sort measurements by received time.
Public property | ProcessedMeasurements | Gets the total number of measurements successfully sorted.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter.
Public property | PublishedFrames | Gets the total number of published frames.
Public property | PublishedMeasurements | Gets the total number of published measurements.
Public property | QueueState | Gets detailed state of concentrator frame queue.
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement, or UtcNow if no measurement timestamps are within time deviation tolerances as specified by the LeadTime value.
Public property | ReceivedMeasurements | Gets the total number of measurements ever requested for sorting.
Public property | RunTime | Gets the total amount of time, in seconds, that the concentrator has been active.
Public property | StartTime | Gets the UTC time the concentrator was started.
Public property | Status | Gets current detailed state and status of concentrator for display purposes.
Public property | StopTime | Gets the UTC time the concentrator was stopped.
Public property | TicksPerFrame | Gets the number of ticks per frame.
Public property | TimeResolution | Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.
Public property | TotalPublicationTime | Gets the total number of seconds frames have spent in the publication process since concentrator started.
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values.
Public property | TrackPublishedTimestamp | Gets or sets flag that determines if system should track timestamp of publication for all frames and measurements.
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real-time.
Public property | UsePrecisionTimer | Gets or sets flag that determines if precision timer should be used for frame publication.
Public property | WaitHandleExpirations | Gets the total number of wait handle expirations encountered due to delayed precision timer releases.
Top
Events
 | Name | Description
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | This event is raised when ConcentratorBase is disposed.
Public event | ProcessException | This event is raised if there is an exception encountered while attempting to process a frame in the sample queue.
Public event | UnpublishedSamples | This event is raised every 5 seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
Remarks

This class synchronizes (i.e., sorts by timestamp) real-time measurements.

Note that your lag time should be defined as it relates to the rate at which data data is coming into the concentrator. Make sure you allow enough time for transmission of data over the network allowing any needed time for possible network congestion. Lead time should be defined as your confidence in the accuracy of your local clock (e.g., if you set lead time to 2, this means you trust that your local clock is within plus or minus 2 seconds of real-time.)

This concentrator is designed to sort measurements being transmitted in real-time for data being sent at rates of at least 1 sample per second. Slower rates (e.g., once every few seconds) are not supported since sorting data at these speeds would be trivial. There is no defined maximum number of supported samples per second - but keep in mind that CPU utilization will increase as the measurement volume and frame rate increase.

See Also

Reference

GSF.TimeSeries Namespace


ConcentratorBase Constructor

Grid Solutions Framework ConcentratorBase Constructor
Overload List
 | Name | Description
Protected method | ConcentratorBase | Creates a new ConcentratorBase.
Protected method | ConcentratorBase(Int32, Double, Double) | Creates a new ConcentratorBase from specified parameters.
Top
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase Constructor

Grid Solutions Framework ConcentratorBase Constructor
Creates a new ConcentratorBase.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConcentratorBase()
Protected Sub New
new : unit -> ConcentratorBase
GSF.TimeSeries.ConcentratorBase = function();
protected:
ConcentratorBase()
Remarks
Concentration will not begin until consumer "Starts" concentrator (i.e., calling Start method or setting Enabled = true).
See Also

Reference

ConcentratorBase Class
ConcentratorBase Overload
GSF.TimeSeries Namespace


ConcentratorBase Constructor (Int32, Double, Double)

Grid Solutions Framework ConcentratorBase Constructor (Int32, Double, Double)
Creates a new ConcentratorBase from specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConcentratorBase(
    int framesPerSecond,
    double lagTime,
    double leadTime
)
Protected Sub New (
    framesPerSecond As Integer,
    lagTime As Double,
    leadTime As Double
)
new :
        framesPerSecond : int *
        lagTime : float *
        leadTime : float -> ConcentratorBase
GSF.TimeSeries.ConcentratorBase = function(framesPerSecond, lagTime, leadTime);
protected:
ConcentratorBase(
    int framesPerSecond,
    double lagTime,
    double leadTime
)

Parameters

framesPerSecond
Type: SystemInt32
Number of frames to publish per second.
lagTime
Type: SystemDouble
Past time deviation tolerance, in seconds - this becomes the amount of time to wait before publishing begins.
leadTime
Type: SystemDouble
Future time deviation tolerance, in seconds - this becomes the tolerated +/- accuracy of the local clock to real-time.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Specified argument is outside of allowed value range (see remarks).
Remarks

framesPerSecond must be greater then 0.

lagTime must be greater than zero, but can be specified in sub-second intervals (e.g., set to .25 for a quarter-second lag time). Note that this defines time sensitivity to past timestamps.

leadTime must be greater than zero, but can be specified in sub-second intervals (e.g., set to .5 for a half-second lead time). Note that this defines time sensitivity to future timestamps.

Concentration will not begin until consumer "Starts" concentrator (i.e., calling Start method or setting Enabled = true).

See Also

Reference

ConcentratorBase Class
ConcentratorBase Overload
GSF.TimeSeries Namespace


ConcentratorBase Methods

Grid Solutions Framework ConcentratorBase Methods

The ConcentratorBase type exposes the following members.

Methods
 | Name | Description
Protected method | AssignMeasurementToFrame | Assigns IMeasurement to its associated IFrame.
Protected method | CreateNewFrame | Creates a new IFrame for the given timestamp.
Public method | Dispose | Releases all the resources used by the ConcentratorBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConcentratorBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ConcentratorBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MillisecondsFromRealTime | Returns the deviation, in milliseconds, that the given number of ticks is from real-time (i.e., RealTime).
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event.
Protected method | OnProcessException | Raises the ProcessException event.
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Protected method | PublishFrame | Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime.
Public method | ResetStatistics | Resets the statistics of the concentrator.
Public method | SecondsFromRealTime | Returns the deviation, in seconds, that the given number of ticks is from real-time (i.e., RealTime).
Public method | SortMeasurement | Sorts the IMeasurement placing the data point in its proper IFrame.
Public method | SortMeasurements | Sorts each IMeasurement placing each data point in its proper IFrame.
Public method | Start | Starts the concentrator, if it is not already running.
Public method | Stop | Stops the concentrator.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.AssignMeasurementToFrame Method

Grid Solutions Framework ConcentratorBaseAssignMeasurementToFrame Method
Assigns IMeasurement to its associated IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void AssignMeasurementToFrame(
    IFrame frame,
    IMeasurement measurement
)
Protected Overridable Sub AssignMeasurementToFrame (
    frame As IFrame,
    measurement As IMeasurement
)
abstract AssignMeasurementToFrame :
        frame : IFrame *
        measurement : IMeasurement -> unit
override AssignMeasurementToFrame :
        frame : IFrame *
        measurement : IMeasurement -> unit
function AssignMeasurementToFrame(frame, measurement);
protected:
virtual void AssignMeasurementToFrame(
    IFrame^ frame,
    IMeasurement^ measurement
)

Parameters

frame
Type: GSF.TimeSeriesIFrame
The IFrame that is used.
measurement
Type: GSF.TimeSeriesIMeasurement
The type of IMeasurement to use."/>
Remarks
Derived classes can choose to override this method to handle custom assignment of a IMeasurement to its IFrame. Default behavior simply assigns measurement to frame's keyed measurement dictionary:
Copy
frame.Measurements[measurement.Key] = measurement;
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.CreateNewFrame Method

Grid Solutions Framework ConcentratorBaseCreateNewFrame Method
Creates a new IFrame for the given timestamp.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IFrame CreateNewFrame(
    Ticks timestamp
)
Protected Overridable Function CreateNewFrame (
    timestamp As Ticks
) As IFrame
abstract CreateNewFrame :
        timestamp : Ticks -> IFrame
override CreateNewFrame :
        timestamp : Ticks -> IFrame
function CreateNewFrame(timestamp);
protected:
virtual IFrame^ CreateNewFrame(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp for new IFrame in Ticks.

Return Value

Type: IFrame
New IFrame at given timestamp.
Remarks
Derived classes can override this method to create a new custom IFrame. Default behavior creates a basic Frame to hold synchronized measurements.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.Dispose Method

Grid Solutions Framework ConcentratorBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ConcentratorBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ConcentratorBase object and optionally releases the managed resources.
Top
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.Dispose Method

Grid Solutions Framework ConcentratorBaseDispose Method
Releases all the resources used by the ConcentratorBase object.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ConcentratorBase Class
Dispose Overload
GSF.TimeSeries Namespace


ConcentratorBase.Dispose Method (Boolean)

Grid Solutions Framework ConcentratorBaseDispose Method (Boolean)
Releases the unmanaged resources used by the ConcentratorBase object and optionally releases the managed resources.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ConcentratorBase Class
Dispose Overload
GSF.TimeSeries Namespace


ConcentratorBase.Finalize Method

Grid Solutions Framework ConcentratorBaseFinalize Method
Releases the unmanaged resources before the ConcentratorBase object is reclaimed by GC.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.MillisecondsFromRealTime Method

Grid Solutions Framework ConcentratorBaseMillisecondsFromRealTime Method
Returns the deviation, in milliseconds, that the given number of ticks is from real-time (i.e., RealTime).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double MillisecondsFromRealTime(
    Ticks timestamp
)
Public Function MillisecondsFromRealTime (
    timestamp As Ticks
) As Double
member MillisecondsFromRealTime :
        timestamp : Ticks -> float

function MillisecondsFromRealTime(timestamp);
public:
double MillisecondsFromRealTime(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp to calculate distance from real-time.

Return Value

Type: Double
A Double value indicating the deviation in milliseconds.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.OnDiscardingMeasurements Method

Grid Solutions Framework ConcentratorBaseOnDiscardingMeasurements Method
Raises the DiscardingMeasurements event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDiscardingMeasurements(
    IEnumerable<IMeasurement> measurements
)
Protected Overridable Sub OnDiscardingMeasurements (
    measurements As IEnumerable(Of IMeasurement)
)
abstract OnDiscardingMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
override OnDiscardingMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
function OnDiscardingMeasurements(measurements);
protected:
virtual void OnDiscardingMeasurements(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Enumeration of IMeasurement values being discarded.
Remarks
Allows derived classes to raise a discarding measurements event.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.OnProcessException Method

Grid Solutions Framework ConcentratorBaseOnProcessException Method
Raises the ProcessException event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to send to ProcessException event.
Remarks
Allows derived classes to raise a processing exception.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.OnUnpublishedSamples Method

Grid Solutions Framework ConcentratorBaseOnUnpublishedSamples Method
Raises the UnpublishedSamples event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnpublishedSamples(
    int seconds
)
Protected Overridable Sub OnUnpublishedSamples (
    seconds As Integer
)
abstract OnUnpublishedSamples :
        seconds : int -> unit
override OnUnpublishedSamples :
        seconds : int -> unit
function OnUnpublishedSamples(seconds);
protected:
virtual void OnUnpublishedSamples(
    int seconds
)

Parameters

seconds
Type: SystemInt32
Total number of unpublished seconds of data.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.PublishFrame Method

Grid Solutions Framework ConcentratorBasePublishFrame Method
Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void PublishFrame(
    IFrame frame,
    int index
)
Protected MustOverride Sub PublishFrame (
    frame As IFrame,
    index As Integer
)
abstract PublishFrame :
        frame : IFrame *
        index : int -> unit

function PublishFrame(frame, index);
protected:
virtual void PublishFrame(
    IFrame^ frame,
    int index
) abstract

Parameters

frame
Type: GSF.TimeSeriesIFrame
IFrame of measurements with the same timestamp that arrived within LagTime that are ready for processing.
index
Type: SystemInt32
Index of IFrame within a second ranging from zero to FramesPerSecond - 1.
Remarks
If user implemented publication function consistently exceeds available publishing time (i.e., 1 / FramesPerSecond seconds), concentration will fall behind. A small amount of this time is required by the ConcentratorBase for processing overhead, so actual total time available for user function process will always be slightly less than 1 / FramesPerSecond seconds.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.ResetStatistics Method

Grid Solutions Framework ConcentratorBaseResetStatistics Method
Resets the statistics of the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void ResetStatistics()
Public Overridable Sub ResetStatistics
abstract ResetStatistics : unit -> unit
override ResetStatistics : unit -> unit
function ResetStatistics();
public:
virtual void ResetStatistics()
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.SecondsFromRealTime Method

Grid Solutions Framework ConcentratorBaseSecondsFromRealTime Method
Returns the deviation, in seconds, that the given number of ticks is from real-time (i.e., RealTime).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double SecondsFromRealTime(
    Ticks timestamp
)
Public Function SecondsFromRealTime (
    timestamp As Ticks
) As Double
member SecondsFromRealTime :
        timestamp : Ticks -> float

function SecondsFromRealTime(timestamp);
public:
double SecondsFromRealTime(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp to calculate distance from real-time.

Return Value

Type: Double
A Double value indicating the deviation, in seconds, from real-time.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.SortMeasurement Method

Grid Solutions Framework ConcentratorBaseSortMeasurement Method
Sorts the IMeasurement placing the data point in its proper IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SortMeasurement(
    IMeasurement measurement
)
Public Overridable Sub SortMeasurement (
    measurement As IMeasurement
)
abstract SortMeasurement :
        measurement : IMeasurement -> unit
override SortMeasurement :
        measurement : IMeasurement -> unit
function SortMeasurement(measurement);
public:
virtual void SortMeasurement(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement to sort.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.SortMeasurements Method

Grid Solutions Framework ConcentratorBaseSortMeasurements Method
Sorts each IMeasurement placing each data point in its proper IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SortMeasurements(
    IEnumerable<IMeasurement> measurements
)
Public Overridable Sub SortMeasurements (
    measurements As IEnumerable(Of IMeasurement)
)
abstract SortMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
override SortMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
function SortMeasurements(measurements);
public:
virtual void SortMeasurements(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Collection of IMeasurement's to sort.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.Start Method

Grid Solutions Framework ConcentratorBaseStart Method
Starts the concentrator, if it is not already running.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Start()
Public Overridable Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start()
Remarks
Concentrator must be started by calling Start method or setting Enabled = true) before concentration will begin.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.Stop Method

Grid Solutions Framework ConcentratorBaseStop Method
Stops the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Stop()
Public Overridable Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop()
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase Properties

Grid Solutions Framework ConcentratorBase Properties

The ConcentratorBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowPreemptivePublishing | Gets or sets flag that allows system to preemptively publish frames assuming all ExpectedMeasurements have arrived.
Public property | AllowSortsByArrival | Gets or sets flag that determines whether or not to allow incoming measurements with bad timestamps to be sorted by arrival time.
Public property | AveragePublicationTimePerFrame | Gets the average required frame publication time, in seconds.
Public property | DiscardedMeasurements | Gets the total number of measurements that have been discarded because of old timestamps (i.e., measurements that were outside the time deviation tolerance from base time, past or future).
Public property | DownsampledMeasurements | Gets the total number of down-sampled measurements processed by the concentrator.
Public property | DownsamplingMethod | Gets or sets the DownsamplingMethod to be used by the concentrator.
Public property | Enabled | Gets or sets the current enabled state of concentrator.
Public property | ExpectedMeasurements | Gets or sets the expected number of measurements to be assigned to a single frame.
Public property | FramesAheadOfSchedule | Gets the total number of frames ahead of schedule processed by the concentrator.
Public property | FramesPerSecond | Gets or sets the number of frames per second.
Public property | IgnoreBadTimestamps | Gets or sets flag that determines if bad timestamps (as determined by measurement's timestamp quality) should be ignored when sorting measurements.
Public property | LagTicks | Gets defined past time deviation tolerance, in ticks.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LastDiscardedMeasurement | Gets a reference the last IMeasurement that was discarded by the concentrator.
Public property | LastDiscardedMeasurementLatency | Gets the calculated latency of the last IMeasurement that was discarded by the concentrator.
Public property | LastFrame | Gets reference to the last published IFrame.
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values.
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | MaximumPublicationTimeout | Gets or sets the maximum frame publication timeout in milliseconds, set to Infinite(-1) to wait indefinitely.
Public property | MeasurementsSortedByArrival | Gets the total number of measurements that were sorted by arrival because the measurement reported a bad timestamp quality.
Public property | MissedSortsByTimeout | Gets the total number of missed sorts by timeout processed by the concentrator.
Public property | PerformTimestampReasonabilityCheck | Gets or sets flag that determines if timestamp reasonability checks should be performed on incoming measurements (i.e., measurement timestamps are compared to system clock for reasonability using LeadTime tolerance).
Public property | ProcessByReceivedTimestamp | Gets or sets flag that determines if concentrator should sort measurements by received time.
Public property | ProcessedMeasurements | Gets the total number of measurements successfully sorted.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter.
Public property | PublishedFrames | Gets the total number of published frames.
Public property | PublishedMeasurements | Gets the total number of published measurements.
Public property | QueueState | Gets detailed state of concentrator frame queue.
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement, or UtcNow if no measurement timestamps are within time deviation tolerances as specified by the LeadTime value.
Public property | ReceivedMeasurements | Gets the total number of measurements ever requested for sorting.
Public property | RunTime | Gets the total amount of time, in seconds, that the concentrator has been active.
Public property | StartTime | Gets the UTC time the concentrator was started.
Public property | Status | Gets current detailed state and status of concentrator for display purposes.
Public property | StopTime | Gets the UTC time the concentrator was stopped.
Public property | TicksPerFrame | Gets the number of ticks per frame.
Public property | TimeResolution | Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.
Public property | TotalPublicationTime | Gets the total number of seconds frames have spent in the publication process since concentrator started.
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values.
Public property | TrackPublishedTimestamp | Gets or sets flag that determines if system should track timestamp of publication for all frames and measurements.
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real-time.
Public property | UsePrecisionTimer | Gets or sets flag that determines if precision timer should be used for frame publication.
Public property | WaitHandleExpirations | Gets the total number of wait handle expirations encountered due to delayed precision timer releases.
Top
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.AllowPreemptivePublishing Property

Grid Solutions Framework ConcentratorBaseAllowPreemptivePublishing Property
Gets or sets flag that allows system to preemptively publish frames assuming all ExpectedMeasurements have arrived.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllowPreemptivePublishing { get; set; }
Public Property AllowPreemptivePublishing As Boolean
    Get
    Set
member AllowPreemptivePublishing : bool with get, set

function get_AllowPreemptivePublishing();
function set_AllowPreemptivePublishing(value);
public:
property bool AllowPreemptivePublishing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
In order for this property to used, the ExpectedMeasurements must be defined.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.AllowSortsByArrival Property

Grid Solutions Framework ConcentratorBaseAllowSortsByArrival Property
Gets or sets flag that determines whether or not to allow incoming measurements with bad timestamps to be sorted by arrival time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllowSortsByArrival { get; set; }
Public Property AllowSortsByArrival As Boolean
    Get
    Set
member AllowSortsByArrival : bool with get, set

function get_AllowSortsByArrival();
function set_AllowSortsByArrival(value);
public:
property bool AllowSortsByArrival {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

Value defaults to true, so any incoming measurement with a bad timestamp quality will be sorted according to its arrival time. Setting the property to false will cause all measurements with a bad timestamp quality to be discarded. This property will only be considered when IgnoreBadTimestamps is false.

Value will be forced to false if ProcessByReceivedTimestamp is true.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.AveragePublicationTimePerFrame Property

Grid Solutions Framework ConcentratorBaseAveragePublicationTimePerFrame Property
Gets the average required frame publication time, in seconds.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time AveragePublicationTimePerFrame { get; }
Public ReadOnly Property AveragePublicationTimePerFrame As Time
    Get
member AveragePublicationTimePerFrame : Time with get

function get_AveragePublicationTimePerFrame();

public:
property Time AveragePublicationTimePerFrame {
    Time get ();
}

Property Value

Type: Time
Remarks
If user publication function, PublishFrame(IFrame, Int32), consistently exceeds available publishing time (i.e., 1 / FramesPerSecond), concentration will fall behind.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.DiscardedMeasurements Property

Grid Solutions Framework ConcentratorBaseDiscardedMeasurements Property
Gets the total number of measurements that have been discarded because of old timestamps (i.e., measurements that were outside the time deviation tolerance from base time, past or future).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long DiscardedMeasurements { get; }
Public ReadOnly Property DiscardedMeasurements As Long
    Get
member DiscardedMeasurements : int64 with get

function get_DiscardedMeasurements();

public:
property long long DiscardedMeasurements {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.DownsampledMeasurements Property

Grid Solutions Framework ConcentratorBaseDownsampledMeasurements Property
Gets the total number of down-sampled measurements processed by the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long DownsampledMeasurements { get; }
Public ReadOnly Property DownsampledMeasurements As Long
    Get
member DownsampledMeasurements : int64 with get

function get_DownsampledMeasurements();

public:
property long long DownsampledMeasurements {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.DownsamplingMethod Property

Grid Solutions Framework ConcentratorBaseDownsamplingMethod Property
Gets or sets the DownsamplingMethod to be used by the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DownsamplingMethod DownsamplingMethod { get; set; }
Public Property DownsamplingMethod As DownsamplingMethod
    Get
    Set
member DownsamplingMethod : DownsamplingMethod with get, set

function get_DownsamplingMethod();
function set_DownsamplingMethod(value);
public:
property DownsamplingMethod DownsamplingMethod {
    DownsamplingMethod get ();
    void set (DownsamplingMethod value);
}

Property Value

Type: DownsamplingMethod
Remarks
The down-sampling method determines the algorithm to use if input is being received at a higher-resolution than the defined output.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.Enabled Property

Grid Solutions Framework ConcentratorBaseEnabled Property
Gets or sets the current enabled state of concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Enabled { get; set; }
Public Overridable Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Return Value

Type: Boolean
Current enabled state of concentrator
Remarks
Concentrator must be started by calling Start method or setting Enabled = true) before concentration will begin.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.ExpectedMeasurements Property

Grid Solutions Framework ConcentratorBaseExpectedMeasurements Property
Gets or sets the expected number of measurements to be assigned to a single frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ExpectedMeasurements { get; set; }
Public Property ExpectedMeasurements As Integer
    Get
    Set
member ExpectedMeasurements : int with get, set

function get_ExpectedMeasurements();
function set_ExpectedMeasurements(value);
public:
property int ExpectedMeasurements {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.FramesAheadOfSchedule Property

Grid Solutions Framework ConcentratorBaseFramesAheadOfSchedule Property
Gets the total number of frames ahead of schedule processed by the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long FramesAheadOfSchedule { get; }
Public ReadOnly Property FramesAheadOfSchedule As Long
    Get
member FramesAheadOfSchedule : int64 with get

function get_FramesAheadOfSchedule();

public:
property long long FramesAheadOfSchedule {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.FramesPerSecond Property

Grid Solutions Framework ConcentratorBaseFramesPerSecond Property
Gets or sets the number of frames per second.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int FramesPerSecond { get; set; }
Public Property FramesPerSecond As Integer
    Get
    Set
member FramesPerSecond : int with get, set

function get_FramesPerSecond();
function set_FramesPerSecond(value);
public:
property int FramesPerSecond {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Valid frame rates for a ConcentratorBase are greater than 0 frames per second.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.IgnoreBadTimestamps Property

Grid Solutions Framework ConcentratorBaseIgnoreBadTimestamps Property
Gets or sets flag that determines if bad timestamps (as determined by measurement's timestamp quality) should be ignored when sorting measurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IgnoreBadTimestamps { get; set; }
Public Property IgnoreBadTimestamps As Boolean
    Get
    Set
member IgnoreBadTimestamps : bool with get, set

function get_IgnoreBadTimestamps();
function set_IgnoreBadTimestamps(value);
public:
property bool IgnoreBadTimestamps {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Setting this property to true forces system to use timestamps as-is without checking quality. If this property is true, it will supersede operation of AllowSortsByArrival.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.LagTicks Property

Grid Solutions Framework ConcentratorBaseLagTicks Property
Gets defined past time deviation tolerance, in ticks.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks LagTicks { get; }
Public ReadOnly Property LagTicks As Ticks
    Get
member LagTicks : Ticks with get

function get_LagTicks();

public:
property Ticks LagTicks {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.LagTime Property

Grid Solutions Framework ConcentratorBaseLagTime Property
Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double LagTime { get; set; }
Public Property LagTime As Double
    Get
    Set
member LagTime : float with get, set

function get_LagTime();
function set_LagTime(value);
public:
property double LagTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to past measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too old.

This becomes the amount of delay introduced by the concentrator to allow time for data to flow into the system.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.LastDiscardedMeasurement Property

Grid Solutions Framework ConcentratorBaseLastDiscardedMeasurement Property
Gets a reference the last IMeasurement that was discarded by the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IMeasurement LastDiscardedMeasurement { get; }
Public ReadOnly Property LastDiscardedMeasurement As IMeasurement
    Get
member LastDiscardedMeasurement : IMeasurement with get

function get_LastDiscardedMeasurement();

public:
property IMeasurement^ LastDiscardedMeasurement {
    IMeasurement^ get ();
}

Property Value

Type: IMeasurement
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.LastDiscardedMeasurementLatency Property

Grid Solutions Framework ConcentratorBaseLastDiscardedMeasurementLatency Property
Gets the calculated latency of the last IMeasurement that was discarded by the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks LastDiscardedMeasurementLatency { get; }
Public ReadOnly Property LastDiscardedMeasurementLatency As Ticks
    Get
member LastDiscardedMeasurementLatency : Ticks with get

function get_LastDiscardedMeasurementLatency();

public:
property Ticks LastDiscardedMeasurementLatency {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.LastFrame Property

Grid Solutions Framework ConcentratorBaseLastFrame Property
Gets reference to the last published IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IFrame LastFrame { get; }
Public ReadOnly Property LastFrame As IFrame
    Get
member LastFrame : IFrame with get

function get_LastFrame();

public:
property IFrame^ LastFrame {
    IFrame^ get ();
}

Property Value

Type: IFrame
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.LatestMeasurements Property

Grid Solutions Framework ConcentratorBaseLatestMeasurements Property
Gets reference to the collection of absolute latest received measurement values.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ImmediateMeasurements LatestMeasurements { get; }
Public ReadOnly Property LatestMeasurements As ImmediateMeasurements
    Get
member LatestMeasurements : ImmediateMeasurements with get

function get_LatestMeasurements();

public:
property ImmediateMeasurements^ LatestMeasurements {
    ImmediateMeasurements^ get ();
}

Property Value

Type: ImmediateMeasurements
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.LeadTime Property

Grid Solutions Framework ConcentratorBaseLeadTime Property
Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double LeadTime { get; set; }
Public Property LeadTime As Double
    Get
    Set
member LeadTime : float with get, set

function get_LeadTime();
function set_LeadTime(value);
public:
property double LeadTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LeadTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to future measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too advanced.

This becomes the tolerated +/- accuracy of the local clock to real-time.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.MaximumPublicationTimeout Property

Grid Solutions Framework ConcentratorBaseMaximumPublicationTimeout Property
Gets or sets the maximum frame publication timeout in milliseconds, set to Infinite(-1) to wait indefinitely.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MaximumPublicationTimeout { get; set; }
Public Property MaximumPublicationTimeout As Integer
    Get
    Set
member MaximumPublicationTimeout : int with get, set

function get_MaximumPublicationTimeout();
function set_MaximumPublicationTimeout(value);
public:
property int MaximumPublicationTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

The concentrator automatically defines a precision timer to provide the heartbeat for frame publication, however if the system gets busy the heartbeat signals can be missed. This property defines a maximum wait timeout before reception of the heartbeat signal to make sure frame publications continue to occur in a timely fashion even when a system is under stress.

This property is automatically defined as 2% more than the number of milliseconds per frame when the FramesPerSecond property is set. Users can override this default value to provide custom behavior for this timeout.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.MeasurementsSortedByArrival Property

Grid Solutions Framework ConcentratorBaseMeasurementsSortedByArrival Property
Gets the total number of measurements that were sorted by arrival because the measurement reported a bad timestamp quality.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MeasurementsSortedByArrival { get; }
Public ReadOnly Property MeasurementsSortedByArrival As Long
    Get
member MeasurementsSortedByArrival : int64 with get

function get_MeasurementsSortedByArrival();

public:
property long long MeasurementsSortedByArrival {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.MissedSortsByTimeout Property

Grid Solutions Framework ConcentratorBaseMissedSortsByTimeout Property
Gets the total number of missed sorts by timeout processed by the concentrator.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MissedSortsByTimeout { get; }
Public ReadOnly Property MissedSortsByTimeout As Long
    Get
member MissedSortsByTimeout : int64 with get

function get_MissedSortsByTimeout();

public:
property long long MissedSortsByTimeout {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.PerformTimestampReasonabilityCheck Property

Grid Solutions Framework ConcentratorBasePerformTimestampReasonabilityCheck Property
Gets or sets flag that determines if timestamp reasonability checks should be performed on incoming measurements (i.e., measurement timestamps are compared to system clock for reasonability using LeadTime tolerance).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PerformTimestampReasonabilityCheck { get; set; }
Public Property PerformTimestampReasonabilityCheck As Boolean
    Get
    Set
member PerformTimestampReasonabilityCheck : bool with get, set

function get_PerformTimestampReasonabilityCheck();
function set_PerformTimestampReasonabilityCheck(value);
public:
property bool PerformTimestampReasonabilityCheck {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Setting this value to false will make the concentrator use the latest value received as "real-time" without validation; this is not recommended in production since time reported by source devices may be grossly incorrect. For non-production configurations, setting this value to false will allow concentration of historical data.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.ProcessByReceivedTimestamp Property

Grid Solutions Framework ConcentratorBaseProcessByReceivedTimestamp Property
Gets or sets flag that determines if concentrator should sort measurements by received time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ProcessByReceivedTimestamp { get; set; }
Public Property ProcessByReceivedTimestamp As Boolean
    Get
    Set
member ProcessByReceivedTimestamp : bool with get, set

function get_ProcessByReceivedTimestamp();
function set_ProcessByReceivedTimestamp(value);
public:
property bool ProcessByReceivedTimestamp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

Setting this value to true will make concentrator use the timestamp of measurement reception, which is typically the IMeasurement creation time, for sorting and publication. This is useful in scenarios where the concentrator will be receiving very large volumes of data but not necessarily in real-time, such as, reading values from a file where you want data to be sorted and processed as fast as possible.

Setting this value to true will force UseLocalClockAsRealTime to be true and AllowSortsByArrival to be false.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.ProcessedMeasurements Property

Grid Solutions Framework ConcentratorBaseProcessedMeasurements Property
Gets the total number of measurements successfully sorted.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ProcessedMeasurements { get; }
Public ReadOnly Property ProcessedMeasurements As Long
    Get
abstract ProcessedMeasurements : int64 with get
override ProcessedMeasurements : int64 with get
function get_ProcessedMeasurements();

public:
virtual property long long ProcessedMeasurements {
    long long get () sealed;
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.ProcessingInterval Property

Grid Solutions Framework ConcentratorBaseProcessingInterval Property
Gets or sets the desired processing interval, in milliseconds, for the adapter.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ProcessingInterval { get; set; }
Public Overridable Property ProcessingInterval As Integer
    Get
    Set
abstract ProcessingInterval : int with get, set
override ProcessingInterval : int with get, set
function get_ProcessingInterval();
function set_ProcessingInterval(value);
public:
virtual property int ProcessingInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks

This property is normally only used when you need the concentrator to send data at faster than real-time speeds, e.g., faster than the defined FramesPerSecond. A use case would be pushing historical data through the concentrator where you want to sort and publish data as quickly as possible.

With the exception of the values of -1 and 0, this value specifies the desired processing interval for data, e.g., a timer interval, over which to process data. A value of -1 means to use the default processing interval, i.e., use the FramesPerSecond, while a value of 0 means to process data as fast as possible.

From a real-time perspective the ConcentratorBase defines its general processing interval based on the defined FramesPerSecond property. The frames per second property, however, is more than a basic processing interval since it is used to define the intervals in one second that will become the time sorting destination "buckets" used by the concentrator irrespective of the data rate of the incoming data. As an example, if the frames per second of the concentrator is set to 30 and the source data rate is 60fps, then data will be down-sampled to 30 frames of sorted incoming data but the assigned processing interval will be used to publish the frames at the specified rate.

The implemented functionality of the process interval property will be to respond to values in the following way:

Value | Response
< 0 | In this case the default processing interval has been requested, as a result the ProcessByReceivedTimestamp will be set to false and the concentrator processing interval will be defined based on the currently defined FramesPerSecond property, e.g., if the frames per second is 30 the processing interval will be 33.33ms.
0 | In this case the processing interval has been defined to process data as fast as possible, as a result the ProcessByReceivedTimestamp property will be set to true and UsePrecisionTimer property will be set to false. With a processing interval of zero data is expected to flow into the concentrator as quick as it can be provided. The FramesPerSecond property will still be used to sort data by time into appropriate frames, but the concentrator will use the reception time of the measurements against the defined lag-time to make sure needed data has arrived before publication and frames will be published at the same rate of data arrival.
> 0 | In this case a specific processing interval has been defined for processing data, as a result both the ProcessByReceivedTimestamp and UsePrecisionTimer properties will be set to true. With a specifically defined processing interval, data is expected to flow into the concentrator at a similar rate. The FramesPerSecond property will still be used to sort data by time into appropriate frames, but the concentrator will use the reception time of the measurements against the defined lag-time to make sure needed data has arrived before publication and frames will be published on the specified interval. If multiple frames are ready for publication when the processing interval executes, then all the ready frames will be published sequentially as quickly as possible.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.PublishedFrames Property

Grid Solutions Framework ConcentratorBasePublishedFrames Property
Gets the total number of published frames.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long PublishedFrames { get; }
Public ReadOnly Property PublishedFrames As Long
    Get
member PublishedFrames : int64 with get

function get_PublishedFrames();

public:
property long long PublishedFrames {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.PublishedMeasurements Property

Grid Solutions Framework ConcentratorBasePublishedMeasurements Property
Gets the total number of published measurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long PublishedMeasurements { get; }
Public ReadOnly Property PublishedMeasurements As Long
    Get
member PublishedMeasurements : int64 with get

function get_PublishedMeasurements();

public:
property long long PublishedMeasurements {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.QueueState Property

Grid Solutions Framework ConcentratorBaseQueueState Property
Gets detailed state of concentrator frame queue.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string QueueState { get; }
Public ReadOnly Property QueueState As String
    Get
member QueueState : string with get

function get_QueueState();

public:
property String^ QueueState {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.RealTime Property

Grid Solutions Framework ConcentratorBaseRealTime Property
Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement, or UtcNow if no measurement timestamps are within time deviation tolerances as specified by the LeadTime value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks RealTime { get; }
Public ReadOnly Property RealTime As Ticks
    Get
member RealTime : Ticks with get

function get_RealTime();

public:
property Ticks RealTime {
    Ticks get ();
}

Property Value

Type: Ticks
Remarks
Because the measurements being received by remote devices are often measured relative to GPS time, these timestamps are typically more accurate than the local clock. As a result, we can use the latest received timestamp as the best local time measurement we have (ignoring transmission delays); but, even these times can be incorrect so we still have to apply reasonability checks to these times. To do this, we use the local system time and the LeadTime value to validate the latest measured timestamp. If the newest received measurement timestamp gets too old or creeps too far into the future (both validated + and - against defined lead time property value), we will fall back on local system time. Note that this creates a dependency on a fairly accurate local clock - the smaller the lead time deviation tolerance, the better the needed local clock accuracy. For example, a lead time deviation tolerance of a few seconds might only require keeping the local clock synchronized to an NTP time source; but, a sub-second tolerance would require that the local clock be very close to GPS time.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.ReceivedMeasurements Property

Grid Solutions Framework ConcentratorBaseReceivedMeasurements Property
Gets the total number of measurements ever requested for sorting.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long ReceivedMeasurements { get; }
Public ReadOnly Property ReceivedMeasurements As Long
    Get
member ReceivedMeasurements : int64 with get

function get_ReceivedMeasurements();

public:
property long long ReceivedMeasurements {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.RunTime Property

Grid Solutions Framework ConcentratorBaseRunTime Property
Gets the total amount of time, in seconds, that the concentrator has been active.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Time RunTime { get; }
Public Overridable ReadOnly Property RunTime As Time
    Get
abstract RunTime : Time with get
override RunTime : Time with get
function get_RunTime();

public:
virtual property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.StartTime Property

Grid Solutions Framework ConcentratorBaseStartTime Property
Gets the UTC time the concentrator was started.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks StartTime { get; }
Public ReadOnly Property StartTime As Ticks
    Get
member StartTime : Ticks with get

function get_StartTime();

public:
property Ticks StartTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.Status Property

Grid Solutions Framework ConcentratorBaseStatus Property
Gets current detailed state and status of concentrator for display purposes.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.StopTime Property

Grid Solutions Framework ConcentratorBaseStopTime Property
Gets the UTC time the concentrator was stopped.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks StopTime { get; }
Public ReadOnly Property StopTime As Ticks
    Get
member StopTime : Ticks with get

function get_StopTime();

public:
property Ticks StopTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.TicksPerFrame Property

Grid Solutions Framework ConcentratorBaseTicksPerFrame Property
Gets the number of ticks per frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double TicksPerFrame { get; }
Public ReadOnly Property TicksPerFrame As Double
    Get
member TicksPerFrame : float with get

function get_TicksPerFrame();

public:
property double TicksPerFrame {
    double get ();
}

Property Value

Type: Double
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.TimeResolution Property

Grid Solutions Framework ConcentratorBaseTimeResolution Property
Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TimeResolution { get; set; }
Public Property TimeResolution As Long
    Get
    Set
member TimeResolution : int64 with get, set

function get_TimeResolution();
function set_TimeResolution(value);
public:
property long long TimeResolution {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Remarks
Desired maximum resolution | Value to assign
Seconds | Ticks.PerSecond
Milliseconds | Ticks.PerMillisecond
Microseconds | Ticks.PerMicrosecond
100-Nanoseconds | 0
Assigning values less than zero will be set to zero since minimum possible concentrator resolution is one tick (100-nanoseconds). Assigning values values greater than Ticks.PerSecond will be set to Ticks.PerSecond since maximum possible concentrator resolution is one second (i.e., 1 frame per second).
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.TotalPublicationTime Property

Grid Solutions Framework ConcentratorBaseTotalPublicationTime Property
Gets the total number of seconds frames have spent in the publication process since concentrator started.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time TotalPublicationTime { get; }
Public ReadOnly Property TotalPublicationTime As Time
    Get
member TotalPublicationTime : Time with get

function get_TotalPublicationTime();

public:
property Time TotalPublicationTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.TrackLatestMeasurements Property

Grid Solutions Framework ConcentratorBaseTrackLatestMeasurements Property
Gets or sets flag to start tracking the absolute latest received measurement values.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TrackLatestMeasurements { get; set; }
Public Property TrackLatestMeasurements As Boolean
    Get
    Set
member TrackLatestMeasurements : bool with get, set

function get_TrackLatestMeasurements();
function set_TrackLatestMeasurements(value);
public:
property bool TrackLatestMeasurements {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Latest received measurement value will be available via the LatestMeasurements property. Note that enabling this option will slightly increase the required sorting time.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.TrackPublishedTimestamp Property

Grid Solutions Framework ConcentratorBaseTrackPublishedTimestamp Property
Gets or sets flag that determines if system should track timestamp of publication for all frames and measurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TrackPublishedTimestamp { get; set; }
Public Property TrackPublishedTimestamp As Boolean
    Get
    Set
member TrackPublishedTimestamp : bool with get, set

function get_TrackPublishedTimestamp();
function set_TrackPublishedTimestamp(value);
public:
property bool TrackPublishedTimestamp {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Setting this value to true will cause the concentrator to mark the timestamp of publication in each PublishedTimestamp and its measurement's PublishedTimestamp. Since this is extra processing time that may not be needed except in cases of calculating statistics for system performance, this must be explicitly enabled.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.UseLocalClockAsRealTime Property

Grid Solutions Framework ConcentratorBaseUseLocalClockAsRealTime Property
Gets or sets flag that determines whether or not to use the local clock time as real-time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseLocalClockAsRealTime { get; set; }
Public Property UseLocalClockAsRealTime As Boolean
    Get
    Set
member UseLocalClockAsRealTime : bool with get, set

function get_UseLocalClockAsRealTime();
function set_UseLocalClockAsRealTime(value);
public:
property bool UseLocalClockAsRealTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks

Use your local system clock as real-time only if the time is locally GPS-synchronized, or if the measurement values being sorted were not measured relative to a GPS-synchronized clock.

If ProcessByReceivedTimestamp is true, UseLocalClockAsRealTime will always be set to true, even if you try to set it to false.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.UsePrecisionTimer Property

Grid Solutions Framework ConcentratorBaseUsePrecisionTimer Property
Gets or sets flag that determines if precision timer should be used for frame publication.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UsePrecisionTimer { get; set; }
Public Property UsePrecisionTimer As Boolean
    Get
    Set
member UsePrecisionTimer : bool with get, set

function get_UsePrecisionTimer();
function set_UsePrecisionTimer(value);
public:
property bool UsePrecisionTimer {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.WaitHandleExpirations Property

Grid Solutions Framework ConcentratorBaseWaitHandleExpirations Property
Gets the total number of wait handle expirations encountered due to delayed precision timer releases.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long WaitHandleExpirations { get; }
Public ReadOnly Property WaitHandleExpirations As Long
    Get
member WaitHandleExpirations : int64 with get

function get_WaitHandleExpirations();

public:
property long long WaitHandleExpirations {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase Events

Grid Solutions Framework ConcentratorBase Events

The ConcentratorBase type exposes the following members.

Events
 | Name | Description
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | This event is raised when ConcentratorBase is disposed.
Public event | ProcessException | This event is raised if there is an exception encountered while attempting to process a frame in the sample queue.
Public event | UnpublishedSamples | This event is raised every 5 seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.DiscardingMeasurements Event

Grid Solutions Framework ConcentratorBaseDiscardingMeasurements Event
This event is raised if there are any measurements being discarded during the sorting process.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IEnumerable<IMeasurement>>> DiscardingMeasurements
Public Event DiscardingMeasurements As EventHandler(Of EventArgs(Of IEnumerable(Of IMeasurement)))
abstract DiscardingMeasurements : IEvent<EventHandler<EventArgs<IEnumerable<IMeasurement>>>,
    EventArgs<IEnumerable<IMeasurement>>>
override DiscardingMeasurements : IEvent<EventHandler<EventArgs<IEnumerable<IMeasurement>>>,
    EventArgs<IEnumerable<IMeasurement>>>
function add_DiscardingMeasurements(value);
function remove_DiscardingMeasurements(value);
public:
virtual  event EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ DiscardingMeasurements {
    void add (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IEnumerable IMeasurement
Remarks
Argument is the enumeration of IMeasurement values that are being discarded during the sorting process.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.Disposed Event

Grid Solutions Framework ConcentratorBaseDisposed Event
This event is raised when ConcentratorBase is disposed.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.ProcessException Event

Grid Solutions Framework ConcentratorBaseProcessException Event
This event is raised if there is an exception encountered while attempting to process a frame in the sample queue.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ProcessException(value);
function remove_ProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks

Argument is the Exception encountered while parsing the data stream.

Processing will not stop for any exceptions thrown by the user function, but any captured exceptions will be exposed through this event.

See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConcentratorBase.UnpublishedSamples Event

Grid Solutions Framework ConcentratorBaseUnpublishedSamples Event
This event is raised every 5 seconds allowing consumer to track current number of unpublished seconds of data in the queue.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> UnpublishedSamples
Public Event UnpublishedSamples As EventHandler(Of EventArgs(Of Integer))
abstract UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
override UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
function add_UnpublishedSamples(value);
function remove_UnpublishedSamples(value);
public:
virtual  event EventHandler<EventArgs<int>^>^ UnpublishedSamples {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32
Remarks
Argument is the total number of unpublished seconds of data.
See Also

Reference

ConcentratorBase Class
GSF.TimeSeries Namespace


ConfigurationType Enumeration

Grid Solutions Framework ConfigurationType Enumeration
Configuration data source type enumeration.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ConfigurationType
Public Enumeration ConfigurationType
type ConfigurationType
GSF.TimeSeries.ConfigurationType = function();
GSF.TimeSeries.ConfigurationType.createEnum('GSF.TimeSeries.ConfigurationType', false);
public enum class ConfigurationType
Members
Member name | Value | Description
Database | 0 | Configuration source is a database.
WebService | 1 | Configuration source is a web-service.
BinaryFile | 2 | Configuration source is a binary file.
XmlFile | 3 | Configuration source is a XML file.
See Also

Reference

GSF.TimeSeries Namespace


ConsoleHost Class

Grid Solutions Framework ConsoleHost Class
Console application operations used to host the time-series framework service.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesConsoleHost

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ConsoleHost
Public Class ConsoleHost
type ConsoleHost =  class end
GSF.TimeSeries.ConsoleHost = function();

Type.createClass(
    'GSF.TimeSeries.ConsoleHost');
public ref class ConsoleHost

The ConsoleHost type exposes the following members.

Constructors
 | Name | Description
Public method | ConsoleHost | Creates new ConsoleHost.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the console host.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.TimeSeries Namespace


ConsoleHost Constructor

Grid Solutions Framework ConsoleHost Constructor
Creates new ConsoleHost.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConsoleHost(
    ServiceHostBase serviceHost
)
Public Sub New (
    serviceHost As ServiceHostBase
)
new :
        serviceHost : ServiceHostBase -> ConsoleHost
GSF.TimeSeries.ConsoleHost = function(serviceHost);
public:
ConsoleHost(
    ServiceHostBase^ serviceHost
)

Parameters

serviceHost
Type: GSF.TimeSeriesServiceHostBase
Service host instance.
See Also

Reference

ConsoleHost Class
GSF.TimeSeries Namespace


ConsoleHost Methods

Grid Solutions Framework ConsoleHost Methods

The ConsoleHost type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Run | Runs the console host.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConsoleHost Class
GSF.TimeSeries Namespace


ConsoleHost.Run Method

Grid Solutions Framework ConsoleHostRun Method
Runs the console host.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Run()
Public Sub Run
member Run : unit -> unit

function Run();
public:
void Run()
See Also

Reference

ConsoleHost Class
GSF.TimeSeries Namespace


DebugHostBase Class

Grid Solutions Framework DebugHostBase Class
Windows form application used to host the time-series framework service.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
GSF.TimeSeriesDebugHostBase

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DebugHostBase : Form
Public Class DebugHostBase
    Inherits Form
type DebugHostBase =
    class
        inherit Form
    end
GSF.TimeSeries.DebugHostBase = function();

Type.createClass(
    'GSF.TimeSeries.DebugHostBase',
    Form);
public ref class DebugHostBase : public Form

The DebugHostBase type exposes the following members.

Constructors
 | Name | Description
Public method | DebugHostBase | Creates a new instance of the DebugHostBase windows form.
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DebugHostLoading | Invoked when the debug host is loading. By default this launches the remote service client.
Protected method | DebugHostUnloading | Invoked when the debug host is unloading. By default this shuts down the remote service client.
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
Fields
 | Name | Description
Public field | ServiceHost | Reference to instance of ServiceHostBase.
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ServiceClientName | Gets the executable name of the service client that can remotely access the time-series framework service.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

GSF.TimeSeries Namespace


DebugHostBase Constructor

Grid Solutions Framework DebugHostBase Constructor
Creates a new instance of the DebugHostBase windows form.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DebugHostBase()
Public Sub New
new : unit -> DebugHostBase
GSF.TimeSeries.DebugHostBase = function();
public:
DebugHostBase()
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase Fields

Grid Solutions Framework DebugHostBase Fields

The DebugHostBase type exposes the following members.

Fields
 | Name | Description
Public field | ServiceHost | Reference to instance of ServiceHostBase.
Top
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase.ServiceHost Field

Grid Solutions Framework DebugHostBaseServiceHost Field
Reference to instance of ServiceHostBase.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceHostBase ServiceHost
Public ServiceHost As ServiceHostBase
val mutable ServiceHost: ServiceHostBase
var ServiceHost
public:
ServiceHostBase^ ServiceHost

Field Value

Type: ServiceHostBase
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase Methods

Grid Solutions Framework DebugHostBase Methods

The DebugHostBase type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DebugHostLoading | Invoked when the debug host is loading. By default this launches the remote service client.
Protected method | DebugHostUnloading | Invoked when the debug host is unloading. By default this shuts down the remote service client.
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase.DebugHostLoading Method

Grid Solutions Framework DebugHostBaseDebugHostLoading Method
Invoked when the debug host is loading. By default this launches the remote service client.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void DebugHostLoading()
Protected Overridable Sub DebugHostLoading
abstract DebugHostLoading : unit -> unit
override DebugHostLoading : unit -> unit
function DebugHostLoading();
protected:
virtual void DebugHostLoading()
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase.DebugHostUnloading Method

Grid Solutions Framework DebugHostBaseDebugHostUnloading Method
Invoked when the debug host is unloading. By default this shuts down the remote service client.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void DebugHostUnloading()
Protected Overridable Sub DebugHostUnloading
abstract DebugHostUnloading : unit -> unit
override DebugHostUnloading : unit -> unit
function DebugHostUnloading();
protected:
virtual void DebugHostUnloading()
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase.Dispose Method

Grid Solutions Framework DebugHostBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase.Dispose Method (Boolean)

Grid Solutions Framework DebugHostBaseDispose Method (Boolean)
Clean up any resources being used.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

DebugHostBase Class
Dispose Overload
GSF.TimeSeries Namespace


DebugHostBase Properties

Grid Solutions Framework DebugHostBase Properties

The DebugHostBase type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ServiceClientName | Gets the executable name of the service client that can remotely access the time-series framework service.
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase.ServiceClientName Property

Grid Solutions Framework DebugHostBaseServiceClientName Property
Gets the executable name of the service client that can remotely access the time-series framework service.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string ServiceClientName { get; }
Protected Overridable ReadOnly Property ServiceClientName As String
    Get
abstract ServiceClientName : string with get
override ServiceClientName : string with get
function get_ServiceClientName();

protected:
virtual property String^ ServiceClientName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DebugHostBase Events

Grid Solutions Framework DebugHostBase Events

The DebugHostBase type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

DebugHostBase Class
GSF.TimeSeries Namespace


DownsamplingMethod Enumeration

Grid Solutions Framework DownsamplingMethod Enumeration
Down-sampling method enumeration.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DownsamplingMethod
Public Enumeration DownsamplingMethod
type DownsamplingMethod
GSF.TimeSeries.DownsamplingMethod = function();
GSF.TimeSeries.DownsamplingMethod.createEnum('GSF.TimeSeries.DownsamplingMethod', false);
public enum class DownsamplingMethod
Members
Member name | Value | Description
LastReceived | 0 | Down-samples to the last measurement received.
Closest | 1 | Down-samples to the measurement closest to frame time.
Filtered | 2 | Down-samples by applying a user-defined value filter over all received measurements to anti-alias the results.
BestQuality | 3 | Down-samples to the measurement that has the best quality closest to frame time.
See Also

Reference

GSF.TimeSeries Namespace


Frame Class

Grid Solutions Framework Frame Class
Implementation of a basic IFrame.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesFrame

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class Frame : IFrame, IEquatable<IFrame>,
    IComparable<IFrame>, IComparable
Public Class Frame
    Implements IFrame, IEquatable(Of IFrame),
    IComparable(Of IFrame), IComparable
type Frame =
    class
        interface IFrame
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
    end
GSF.TimeSeries.Frame = function();

Type.createClass(
    'GSF.TimeSeries.Frame',
    null,
    GSF.TimeSeries.IFrame,
    IEquatable`1,
    IComparable`1,
    IComparable);
public ref class Frame : IFrame, IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable

The Frame type exposes the following members.

Constructors
 | Name | Description
Public method | Frame(Ticks, IDictionaryMeasurementKey, IMeasurement) | Constructs a new Frame given the specified parameters.
Public method | Frame(Ticks, Int32) | Constructs a new Frame given the specified parameters.
Top
Methods
 | Name | Description
Public method | Clone | Create a copy of this Frame and its measurements.
Public method | CompareTo(Object) | Compares the Frame with the specified Object.
Public method | CompareTo(IFrame) | Compares the Frame with an IFrame.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Frame. (Overrides ObjectEquals(Object).)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current Frame.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current Frame. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Operators
Name | Description
Equality | Compares two Frame timestamps for equality.
GreaterThan | Returns true if left Frame timestamp is greater than right Frame timestamp.
GreaterThanOrEqual | Returns true if left Frame timestamp is greater than or equal to right Frame timestamp.
Inequality | Compares two Frame timestamps for inequality.
LessThan | Returns true if left Frame timestamp is less than right Frame timestamp.
LessThanOrEqual | Returns true if left Frame timestamp is less than or equal to right Frame timestamp.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | LastSortedMeasurement | Gets or sets reference to last measurement that was sorted into this Frame.
Public property | Measurements | Keyed measurements in this Frame.
Public property | Published | Gets or sets published state of this Frame (pre-processing).
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Frame was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Frame was received (i.e., created).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this Frame.
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this Frame.
Top
Remarks
A frame represents a collection of measurements at a given time.
See Also

Reference

GSF.TimeSeries Namespace


Frame Constructor

Grid Solutions Framework Frame Constructor
Overload List
 | Name | Description
Public method | Frame(Ticks, IDictionaryMeasurementKey, IMeasurement) | Constructs a new Frame given the specified parameters.
Public method | Frame(Ticks, Int32) | Constructs a new Frame given the specified parameters.
Top
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame Constructor (Ticks, IDictionary(MeasurementKey, IMeasurement))

Grid Solutions Framework Frame Constructor (Ticks, IDictionaryMeasurementKey, IMeasurement)
Constructs a new Frame given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Frame(
    Ticks timestamp,
    IDictionary<MeasurementKey, IMeasurement> measurements
)
Public Sub New (
    timestamp As Ticks,
    measurements As IDictionary(Of MeasurementKey, IMeasurement)
)
new :
        timestamp : Ticks *
        measurements : IDictionary<MeasurementKey, IMeasurement> -> Frame
GSF.TimeSeries.Frame = function(timestamp, measurements);
public:
Frame(
    Ticks timestamp,
    IDictionary<MeasurementKey^, IMeasurement^>^ measurements
)

Parameters

timestamp
Type: GSFTicks
Timestamp, in ticks, for this Frame.
measurements
Type: System.Collections.GenericIDictionary MeasurementKey, IMeasurement
Initial set of measurements to load into the Frame, if any.
See Also

Reference

Frame Class
Frame Overload
GSF.TimeSeries Namespace


Frame Constructor (Ticks, Int32)

Grid Solutions Framework Frame Constructor (Ticks, Int32)
Constructs a new Frame given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Frame(
    Ticks timestamp,
    int expectedMeasurements = -1
)
Public Sub New (
    timestamp As Ticks,
    Optional expectedMeasurements As Integer = -1
)
new :
        timestamp : Ticks *
        ?expectedMeasurements : int
(* Defaults:
        let _expectedMeasurements = defaultArg expectedMeasurements -1
*)
-> Frame
GSF.TimeSeries.Frame = function(timestamp, expectedMeasurements);
public:
Frame(
    Ticks timestamp,
    int expectedMeasurements = -1
)

Parameters

timestamp
Type: GSFTicks
Timestamp, in ticks, for this Frame.
expectedMeasurements (Optional)
Type: SystemInt32
Expected number of measurements for the Frame.
See Also

Reference

Frame Class
Frame Overload
GSF.TimeSeries Namespace


Frame Methods

Grid Solutions Framework Frame Methods

The Frame type exposes the following members.

Methods
 | Name | Description
Public method | Clone | Create a copy of this Frame and its measurements.
Public method | CompareTo(Object) | Compares the Frame with the specified Object.
Public method | CompareTo(IFrame) | Compares the Frame with an IFrame.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Frame. (Overrides ObjectEquals(Object).)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current Frame.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current Frame. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.Clone Method

Grid Solutions Framework FrameClone Method
Create a copy of this Frame and its measurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Frame Clone()
Public Overridable Function Clone As Frame
abstract Clone : unit -> Frame
override Clone : unit -> Frame
function Clone();
public:
virtual Frame^ Clone()

Return Value

Type: Frame
A cloned Frame.
Remarks
The measurement dictionary of this Frame is synclocked during copy.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.CompareTo Method

Grid Solutions Framework FrameCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the Frame with the specified Object.
Public method | CompareTo(IFrame) | Compares the Frame with an IFrame.
Top
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.CompareTo Method (Object)

Grid Solutions Framework FrameCompareTo Method (Object)
Compares the Frame with the specified Object.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: SystemObject
The Object to compare with the current Frame.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | obj is not an IFrame.
Remarks
This implementation of a basic frame compares itself by timestamp.
See Also

Reference

Frame Class
CompareTo Overload
GSF.TimeSeries Namespace


Frame.CompareTo Method (IFrame)

Grid Solutions Framework FrameCompareTo Method (IFrame)
Compares the Frame with an IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    IFrame other
)
Public Function CompareTo (
    other As IFrame
) As Integer
abstract CompareTo :
        other : IFrame -> int
override CompareTo :
        other : IFrame -> int
function CompareTo(other);
public:
virtual int CompareTo(
    IFrame^ other
) sealed

Parameters

other
Type: GSF.TimeSeriesIFrame
The IFrame to compare with the current Frame.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
Remarks
This implementation of a basic frame compares itself by timestamp.
See Also

Reference

Frame Class
CompareTo Overload
GSF.TimeSeries Namespace


Frame.Equals Method

Grid Solutions Framework FrameEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Frame. (Overrides ObjectEquals(Object).)
Public method | Equals(IFrame) | Determines whether the specified IFrame is equal to the current Frame.
Top
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.Equals Method (Object)

Grid Solutions Framework FrameEquals Method (Object)
Determines whether the specified Object is equal to the current Frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The Object to compare with the current Frame.

Return Value

Type: Boolean
true if the specified Object is equal to the current Frame; otherwise, false.
See Also

Reference

Frame Class
Equals Overload
GSF.TimeSeries Namespace


Frame.Equals Method (IFrame)

Grid Solutions Framework FrameEquals Method (IFrame)
Determines whether the specified IFrame is equal to the current Frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    IFrame other
)
Public Function Equals (
    other As IFrame
) As Boolean
abstract Equals :
        other : IFrame -> bool
override Equals :
        other : IFrame -> bool
function Equals(other);
public:
virtual bool Equals(
    IFrame^ other
) sealed

Parameters

other
Type: GSF.TimeSeriesIFrame
The IFrame to compare with the current Frame.

Return Value

Type: Boolean
true if the specified IFrame is equal to the current Frame; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

Frame Class
Equals Overload
GSF.TimeSeries Namespace


Frame.GetHashCode Method

Grid Solutions Framework FrameGetHashCode Method
Serves as a hash function for the current Frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current Frame.
Remarks
Hash code based on timestamp of frame.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame Operators

Grid Solutions Framework Frame Operators

The Frame type exposes the following members.

Operators
Name | Description
Equality | Compares two Frame timestamps for equality.
GreaterThan | Returns true if left Frame timestamp is greater than right Frame timestamp.
GreaterThanOrEqual | Returns true if left Frame timestamp is greater than or equal to right Frame timestamp.
Inequality | Compares two Frame timestamps for inequality.
LessThan | Returns true if left Frame timestamp is less than right Frame timestamp.
LessThanOrEqual | Returns true if left Frame timestamp is less than or equal to right Frame timestamp.
Top
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.Equality Operator

Grid Solutions Framework FrameEquality Operator
Compares two Frame timestamps for equality.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Frame frame1,
    Frame frame2
)
Public Shared Operator = (
    frame1 As Frame,
    frame2 As Frame
) As Boolean
static let inline (=)
        frame1 : Frame *
        frame2 : Frame  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Frame^ frame1,
    Frame^ frame2
)

Parameters

frame1
Type: GSF.TimeSeriesFrame
The Frame left hand operand.
frame2
Type: GSF.TimeSeriesFrame
The Frame right hand operand.

Return Value

Type: Boolean
A Boolean representing the result of the operation.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.GreaterThan Operator

Grid Solutions Framework FrameGreaterThan Operator
Returns true if left Frame timestamp is greater than right Frame timestamp.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Frame frame1,
    Frame frame2
)
Public Shared Operator > (
    frame1 As Frame,
    frame2 As Frame
) As Boolean
static let inline (>)
        frame1 : Frame *
        frame2 : Frame  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Frame^ frame1,
    Frame^ frame2
)

Parameters

frame1
Type: GSF.TimeSeriesFrame
The Frame left hand operand.
frame2
Type: GSF.TimeSeriesFrame
The Frame right hand operand.

Return Value

Type: Boolean
A Boolean representing the result of the operation.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.GreaterThanOrEqual Operator

Grid Solutions Framework FrameGreaterThanOrEqual Operator
Returns true if left Frame timestamp is greater than or equal to right Frame timestamp.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Frame frame1,
    Frame frame2
)
Public Shared Operator >= (
    frame1 As Frame,
    frame2 As Frame
) As Boolean
static let inline (>=)
        frame1 : Frame *
        frame2 : Frame  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Frame^ frame1,
    Frame^ frame2
)

Parameters

frame1
Type: GSF.TimeSeriesFrame
The Frame left hand operand.
frame2
Type: GSF.TimeSeriesFrame
The Frame right hand operand.

Return Value

Type: Boolean
A Boolean representing the result of the operation.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.Inequality Operator

Grid Solutions Framework FrameInequality Operator
Compares two Frame timestamps for inequality.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Frame frame1,
    Frame frame2
)
Public Shared Operator <> (
    frame1 As Frame,
    frame2 As Frame
) As Boolean
static let inline (<>)
        frame1 : Frame *
        frame2 : Frame  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Frame^ frame1,
    Frame^ frame2
)

Parameters

frame1
Type: GSF.TimeSeriesFrame
The Frame left hand operand.
frame2
Type: GSF.TimeSeriesFrame
The Frame right hand operand.

Return Value

Type: Boolean
A Boolean representing the result of the operation.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.LessThan Operator

Grid Solutions Framework FrameLessThan Operator
Returns true if left Frame timestamp is less than right Frame timestamp.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Frame frame1,
    Frame frame2
)
Public Shared Operator < (
    frame1 As Frame,
    frame2 As Frame
) As Boolean
static let inline (<)
        frame1 : Frame *
        frame2 : Frame  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Frame^ frame1,
    Frame^ frame2
)

Parameters

frame1
Type: GSF.TimeSeriesFrame
The Frame left hand operand.
frame2
Type: GSF.TimeSeriesFrame
The Frame right hand operand.

Return Value

Type: Boolean
A Boolean representing the result of the operation.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.LessThanOrEqual Operator

Grid Solutions Framework FrameLessThanOrEqual Operator
Returns true if left Frame timestamp is less than or equal to right Frame timestamp.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Frame frame1,
    Frame frame2
)
Public Shared Operator <= (
    frame1 As Frame,
    frame2 As Frame
) As Boolean
static let inline (<=)
        frame1 : Frame *
        frame2 : Frame  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Frame^ frame1,
    Frame^ frame2
)

Parameters

frame1
Type: GSF.TimeSeriesFrame
The Frame left hand operand.
frame2
Type: GSF.TimeSeriesFrame
The Frame right hand operand.

Return Value

Type: Boolean
A Boolean representing the result of the operation.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame Properties

Grid Solutions Framework Frame Properties

The Frame type exposes the following members.

Properties
 | Name | Description
Public property | LastSortedMeasurement | Gets or sets reference to last measurement that was sorted into this Frame.
Public property | Measurements | Keyed measurements in this Frame.
Public property | Published | Gets or sets published state of this Frame (pre-processing).
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Frame was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Frame was received (i.e., created).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this Frame.
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this Frame.
Top
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.LastSortedMeasurement Property

Grid Solutions Framework FrameLastSortedMeasurement Property
Gets or sets reference to last measurement that was sorted into this Frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IMeasurement LastSortedMeasurement { get; set; }
Public Property LastSortedMeasurement As IMeasurement
    Get
    Set
abstract LastSortedMeasurement : IMeasurement with get, set
override LastSortedMeasurement : IMeasurement with get, set
function get_LastSortedMeasurement();
function set_LastSortedMeasurement(value);
public:
virtual property IMeasurement^ LastSortedMeasurement {
    IMeasurement^ get () sealed;
    void set (IMeasurement^ value) sealed;
}

Property Value

Type: IMeasurement

Implements

IFrameLastSortedMeasurement
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.Measurements Property

Grid Solutions Framework FrameMeasurements Property
Keyed measurements in this Frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConcurrentDictionary<MeasurementKey, IMeasurement> Measurements { get; }
Public ReadOnly Property Measurements As ConcurrentDictionary(Of MeasurementKey, IMeasurement)
    Get
abstract Measurements : ConcurrentDictionary<MeasurementKey, IMeasurement> with get
override Measurements : ConcurrentDictionary<MeasurementKey, IMeasurement> with get
function get_Measurements();

public:
virtual property ConcurrentDictionary<MeasurementKey^, IMeasurement^>^ Measurements {
    ConcurrentDictionary<MeasurementKey^, IMeasurement^>^ get () sealed;
}

Property Value

Type: ConcurrentDictionary MeasurementKey, IMeasurement

Implements

IFrameMeasurements
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.Published Property

Grid Solutions Framework FramePublished Property
Gets or sets published state of this Frame (pre-processing).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Published { get; set; }
Public Property Published As Boolean
    Get
    Set
abstract Published : bool with get, set
override Published : bool with get, set
function get_Published();
function set_Published(value);
public:
virtual property bool Published {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IFramePublished
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.PublishedTimestamp Property

Grid Solutions Framework FramePublishedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this Frame was published (post-processing).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks PublishedTimestamp { get; set; }
Public Property PublishedTimestamp As Ticks
    Get
    Set
abstract PublishedTimestamp : Ticks with get, set
override PublishedTimestamp : Ticks with get, set
function get_PublishedTimestamp();
function set_PublishedTimestamp(value);
public:
virtual property Ticks PublishedTimestamp {
    Ticks get () sealed;
    void set (Ticks value) sealed;
}

Property Value

Type: Ticks

Implements

IFramePublishedTimestamp
Remarks

In the default implementation, setting this property will update all associated PublishedTimestamp.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.ReceivedTimestamp Property

Grid Solutions Framework FrameReceivedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this Frame was received (i.e., created).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks ReceivedTimestamp { get; set; }
Public Property ReceivedTimestamp As Ticks
    Get
    Set
abstract ReceivedTimestamp : Ticks with get, set
override ReceivedTimestamp : Ticks with get, set
function get_ReceivedTimestamp();
function set_ReceivedTimestamp(value);
public:
virtual property Ticks ReceivedTimestamp {
    Ticks get () sealed;
    void set (Ticks value) sealed;
}

Property Value

Type: Ticks

Implements

IFrameReceivedTimestamp
Remarks

In the default implementation, this timestamp will simply be the ticks of UtcNow of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.SortedMeasurements Property

Grid Solutions Framework FrameSortedMeasurements Property
Gets or sets total number of measurements that have been sorted into this Frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int SortedMeasurements { get; set; }
Public Property SortedMeasurements As Integer
    Get
    Set
abstract SortedMeasurements : int with get, set
override SortedMeasurements : int with get, set
function get_SortedMeasurements();
function set_SortedMeasurements(value);
public:
virtual property int SortedMeasurements {
    int get () sealed;
    void set (int value) sealed;
}

Property Value

Type: Int32

Implements

IFrameSortedMeasurements
Remarks
If this property has not been assigned a value, the property will return measurement count.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


Frame.Timestamp Property

Grid Solutions Framework FrameTimestamp Property
Gets or sets exact timestamp, in Ticks, of the data represented in this Frame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks Timestamp { get; set; }
Public Overridable Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

IFrameTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Frame Class
GSF.TimeSeries Namespace


IDevice Interface

Grid Solutions Framework IDevice Interface
Represents a device that acts as a source of IMeasurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IDevice
Public Interface IDevice
type IDevice =  interface end
GSF.TimeSeries.IDevice = function();
GSF.TimeSeries.IDevice.createInterface('GSF.TimeSeries.IDevice');
public interface class IDevice

The IDevice type exposes the following members.

Properties
 | Name | Description
Public property | DataQualityErrors | Gets or sets total data quality errors of this IDevice.
Public property | DeviceErrors | Gets or sets total device errors of this IDevice.
Public property | MeasurementsExpected | Gets or sets total measurements expected to have been received for this IDevice.
Public property | MeasurementsReceived | Gets or sets total measurements received for this IDevice.
Public property | TimeQualityErrors | Gets or sets total time quality errors of this IDevice.
Top
See Also

Reference

GSF.TimeSeries Namespace


IDevice Properties

Grid Solutions Framework IDevice Properties

The IDevice type exposes the following members.

Properties
 | Name | Description
Public property | DataQualityErrors | Gets or sets total data quality errors of this IDevice.
Public property | DeviceErrors | Gets or sets total device errors of this IDevice.
Public property | MeasurementsExpected | Gets or sets total measurements expected to have been received for this IDevice.
Public property | MeasurementsReceived | Gets or sets total measurements received for this IDevice.
Public property | TimeQualityErrors | Gets or sets total time quality errors of this IDevice.
Top
See Also

Reference

IDevice Interface
GSF.TimeSeries Namespace


IDevice.DataQualityErrors Property

Grid Solutions Framework IDeviceDataQualityErrors Property
Gets or sets total data quality errors of this IDevice.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
long DataQualityErrors { get; set; }
Property DataQualityErrors As Long
    Get
    Set
abstract DataQualityErrors : int64 with get, set

function get_DataQualityErrors();
function set_DataQualityErrors(value);
property long long DataQualityErrors {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IDevice Interface
GSF.TimeSeries Namespace


IDevice.DeviceErrors Property

Grid Solutions Framework IDeviceDeviceErrors Property
Gets or sets total device errors of this IDevice.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
long DeviceErrors { get; set; }
Property DeviceErrors As Long
    Get
    Set
abstract DeviceErrors : int64 with get, set

function get_DeviceErrors();
function set_DeviceErrors(value);
property long long DeviceErrors {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IDevice Interface
GSF.TimeSeries Namespace


IDevice.MeasurementsExpected Property

Grid Solutions Framework IDeviceMeasurementsExpected Property
Gets or sets total measurements expected to have been received for this IDevice.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
long MeasurementsExpected { get; set; }
Property MeasurementsExpected As Long
    Get
    Set
abstract MeasurementsExpected : int64 with get, set

function get_MeasurementsExpected();
function set_MeasurementsExpected(value);
property long long MeasurementsExpected {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IDevice Interface
GSF.TimeSeries Namespace


IDevice.MeasurementsReceived Property

Grid Solutions Framework IDeviceMeasurementsReceived Property
Gets or sets total measurements received for this IDevice.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
long MeasurementsReceived { get; set; }
Property MeasurementsReceived As Long
    Get
    Set
abstract MeasurementsReceived : int64 with get, set

function get_MeasurementsReceived();
function set_MeasurementsReceived(value);
property long long MeasurementsReceived {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IDevice Interface
GSF.TimeSeries Namespace


IDevice.TimeQualityErrors Property

Grid Solutions Framework IDeviceTimeQualityErrors Property
Gets or sets total time quality errors of this IDevice.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
long TimeQualityErrors { get; set; }
Property TimeQualityErrors As Long
    Get
    Set
abstract TimeQualityErrors : int64 with get, set

function get_TimeQualityErrors();
function set_TimeQualityErrors(value);
property long long TimeQualityErrors {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
See Also

Reference

IDevice Interface
GSF.TimeSeries Namespace


IFrame Interface

Grid Solutions Framework IFrame Interface
Abstract frame interface representing a collection of measurements at an exact moment in time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IFrame : IEquatable<IFrame>,
    IComparable<IFrame>, IComparable
Public Interface IFrame
    Inherits IEquatable(Of IFrame), IComparable(Of IFrame),
    IComparable
type IFrame =
    interface
        interface IEquatable<IFrame>
        interface IComparable<IFrame>
        interface IComparable
    end
GSF.TimeSeries.IFrame = function();
GSF.TimeSeries.IFrame.createInterface('GSF.TimeSeries.IFrame');
public interface class IFrame : IEquatable<IFrame^>,
    IComparable<IFrame^>, IComparable

The IFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame.)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame.)
Top
Properties
 | Name | Description
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame.
Public property | Measurements | Keyed measurements in this IFrame.
Public property | Published | Gets or sets published state of this IFrame (pre-processing).
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame.
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame.
Top
See Also

Reference

GSF.TimeSeries Namespace


IFrame Methods

Grid Solutions Framework IFrame Methods

The IFrame type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable IFrame .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable IFrame .)
Top
See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame Properties

Grid Solutions Framework IFrame Properties

The IFrame type exposes the following members.

Properties
 | Name | Description
Public property | LastSortedMeasurement | Gets or sets reference to last IMeasurement that was sorted into this IFrame.
Public property | Measurements | Keyed measurements in this IFrame.
Public property | Published | Gets or sets published state of this IFrame (pre-processing).
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created).
Public property | SortedMeasurements | Gets or sets total number of measurements that have been sorted into this IFrame.
Public property | Timestamp | Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame.
Top
See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame.LastSortedMeasurement Property

Grid Solutions Framework IFrameLastSortedMeasurement Property
Gets or sets reference to last IMeasurement that was sorted into this IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IMeasurement LastSortedMeasurement { get; set; }
Property LastSortedMeasurement As IMeasurement
    Get
    Set
abstract LastSortedMeasurement : IMeasurement with get, set

function get_LastSortedMeasurement();
function set_LastSortedMeasurement(value);
property IMeasurement^ LastSortedMeasurement {
    IMeasurement^ get ();
    void set (IMeasurement^ value);
}

Property Value

Type: IMeasurement
Remarks

This value is used to help monitor slow moving measurements that are being sorted into the IFrame.

Implementers need only track the value.

See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame.Measurements Property

Grid Solutions Framework IFrameMeasurements Property
Keyed measurements in this IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
ConcurrentDictionary<MeasurementKey, IMeasurement> Measurements { get; }
ReadOnly Property Measurements As ConcurrentDictionary(Of MeasurementKey, IMeasurement)
    Get
abstract Measurements : ConcurrentDictionary<MeasurementKey, IMeasurement> with get

function get_Measurements();

property ConcurrentDictionary<MeasurementKey^, IMeasurement^>^ Measurements {
    ConcurrentDictionary<MeasurementKey^, IMeasurement^>^ get ();
}

Property Value

Type: ConcurrentDictionary MeasurementKey, IMeasurement
Remarks
Represents a concurrent dictionary of measurements, keyed by MeasurementKey.
See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame.Published Property

Grid Solutions Framework IFramePublished Property
Gets or sets published state of this IFrame (pre-processing).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Published { get; set; }
Property Published As Boolean
    Get
    Set
abstract Published : bool with get, set

function get_Published();
function set_Published(value);
property bool Published {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame.PublishedTimestamp Property

Grid Solutions Framework IFramePublishedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Ticks PublishedTimestamp { get; set; }
Property PublishedTimestamp As Ticks
    Get
    Set
abstract PublishedTimestamp : Ticks with get, set

function get_PublishedTimestamp();
function set_PublishedTimestamp(value);
property Ticks PublishedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks

Implementers should update all associated PublishedTimestamp values when setting this property.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame.ReceivedTimestamp Property

Grid Solutions Framework IFrameReceivedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Ticks ReceivedTimestamp { get; set; }
Property ReceivedTimestamp As Ticks
    Get
    Set
abstract ReceivedTimestamp : Ticks with get, set

function get_ReceivedTimestamp();
function set_ReceivedTimestamp(value);
property Ticks ReceivedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks

Implementers should set this timestamp to be the ticks of UtcNow of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame.SortedMeasurements Property

Grid Solutions Framework IFrameSortedMeasurements Property
Gets or sets total number of measurements that have been sorted into this IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int SortedMeasurements { get; set; }
Property SortedMeasurements As Integer
    Get
    Set
abstract SortedMeasurements : int with get, set

function get_SortedMeasurements();
function set_SortedMeasurements(value);
property int SortedMeasurements {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
If this property has not been assigned a value, implementers should return measurement count.
See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IFrame.Timestamp Property

Grid Solutions Framework IFrameTimestamp Property
Gets or sets exact timestamp, in Ticks, of the data represented in this IFrame.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Ticks Timestamp { get; set; }
Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set

function get_Timestamp();
function set_Timestamp(value);
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

IFrame Interface
GSF.TimeSeries Namespace


IMeasurement Interface

Grid Solutions Framework IMeasurement Interface
Represents an interface for an abstract measurement value measured by a device at an exact time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IMeasurement : ITimeSeriesValue<double>,
    ITimeSeriesValue, IEquatable<ITimeSeriesValue>, IComparable<ITimeSeriesValue>,
    IComparable
Public Interface IMeasurement
    Inherits ITimeSeriesValue(Of Double), ITimeSeriesValue, IEquatable(Of ITimeSeriesValue),
    IComparable(Of ITimeSeriesValue), IComparable
type IMeasurement =
    interface
        interface ITimeSeriesValue<float>
        interface ITimeSeriesValue
        interface IEquatable<ITimeSeriesValue>
        interface IComparable<ITimeSeriesValue>
        interface IComparable
    end
GSF.TimeSeries.IMeasurement = function();
GSF.TimeSeries.IMeasurement.createInterface('GSF.TimeSeries.IMeasurement');
public interface class IMeasurement : ITimeSeriesValue<double>,
    ITimeSeriesValue, IEquatable<ITimeSeriesValue^>, IComparable<ITimeSeriesValue^>,
    IComparable

The IMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable ITimeSeriesValue .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable ITimeSeriesValue .)
Public method | GetHashCode | Get the hash code for the ID. (Inherited from ITimeSeriesValue.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
Properties
 | Name | Description
Public property | Adder | Defines an offset to add to the IMeasurement value.
Public property | AdjustedValue | Gets the adjusted numeric value of this IMeasurement, taking into account the specified Adder and Multiplier offsets.
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Key | Gets or sets the primary key of this IMeasurement.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.
Public property | Multiplier | Defines a multiplicative offset to apply to the IMeasurement value.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created).
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this IMeasurement.
Public property | TagName | Gets or sets the text based tag name of this IMeasurement.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw typed value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValueT.)
Top
Remarks
This interface abstractly represents a measured value at an exact time interval.
See Also

Reference

GSF.TimeSeries Namespace


IMeasurement Methods

Grid Solutions Framework IMeasurement Methods

The IMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable ITimeSeriesValue .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable ITimeSeriesValue .)
Public method | GetHashCode | Get the hash code for the ID. (Inherited from ITimeSeriesValue.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement Properties

Grid Solutions Framework IMeasurement Properties

The IMeasurement type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Defines an offset to add to the IMeasurement value.
Public property | AdjustedValue | Gets the adjusted numeric value of this IMeasurement, taking into account the specified Adder and Multiplier offsets.
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Key | Gets or sets the primary key of this IMeasurement.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.
Public property | Multiplier | Defines a multiplicative offset to apply to the IMeasurement value.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created).
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this IMeasurement.
Public property | TagName | Gets or sets the text based tag name of this IMeasurement.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw typed value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValueT.)
Top
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.Adder Property

Grid Solutions Framework IMeasurementAdder Property
Defines an offset to add to the IMeasurement value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Adder { get; set; }
Property Adder As Double
    Get
    Set
abstract Adder : float with get, set

function get_Adder();
function set_Adder(value);
property double Adder {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
Implementers should make sure this value defaults to zero.
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.AdjustedValue Property

Grid Solutions Framework IMeasurementAdjustedValue Property
Gets the adjusted numeric value of this IMeasurement, taking into account the specified Adder and Multiplier offsets.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
double AdjustedValue { get; }
ReadOnly Property AdjustedValue As Double
    Get
abstract AdjustedValue : float with get

function get_AdjustedValue();

property double AdjustedValue {
    double get ();
}

Property Value

Type: Double
Remarks

Implementers need to account for Adder and Multiplier in return value, e.g.:
return Value * Multiplier + Adder

See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.Key Property

Grid Solutions Framework IMeasurementKey Property
Gets or sets the primary key of this IMeasurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementKey Key { get; set; }
Property Key As MeasurementKey
    Get
    Set
abstract Key : MeasurementKey with get, set

function get_Key();
function set_Key(value);
property MeasurementKey^ Key {
    MeasurementKey^ get ();
    void set (MeasurementKey^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.MeasurementValueFilter Property

Grid Solutions Framework IMeasurementMeasurementValueFilter Property
Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementValueFilterFunction MeasurementValueFilter { get; set; }
Property MeasurementValueFilter As MeasurementValueFilterFunction
    Get
    Set
abstract MeasurementValueFilter : MeasurementValueFilterFunction with get, set

function get_MeasurementValueFilter();
function set_MeasurementValueFilter(value);
property MeasurementValueFilterFunction^ MeasurementValueFilter {
    MeasurementValueFilterFunction^ get ();
    void set (MeasurementValueFilterFunction^ value);
}

Property Value

Type: MeasurementValueFilterFunction
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.Multiplier Property

Grid Solutions Framework IMeasurementMultiplier Property
Defines a multiplicative offset to apply to the IMeasurement value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
double Multiplier { get; set; }
Property Multiplier As Double
    Get
    Set
abstract Multiplier : float with get, set

function get_Multiplier();
function set_Multiplier(value);
property double Multiplier {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Remarks
Implementers should make sure this value defaults to one.
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.PublishedTimestamp Property

Grid Solutions Framework IMeasurementPublishedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Ticks PublishedTimestamp { get; set; }
Property PublishedTimestamp As Ticks
    Get
    Set
abstract PublishedTimestamp : Ticks with get, set

function get_PublishedTimestamp();
function set_PublishedTimestamp(value);
property Ticks PublishedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.ReceivedTimestamp Property

Grid Solutions Framework IMeasurementReceivedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Ticks ReceivedTimestamp { get; set; }
Property ReceivedTimestamp As Ticks
    Get
    Set
abstract ReceivedTimestamp : Ticks with get, set

function get_ReceivedTimestamp();
function set_ReceivedTimestamp(value);
property Ticks ReceivedTimestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks

Implementers should set this timestamp to be the ticks of UtcNow of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.StateFlags Property

Grid Solutions Framework IMeasurementStateFlags Property
Gets or sets MeasurementStateFlags associated with this IMeasurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementStateFlags StateFlags { get; set; }
Property StateFlags As MeasurementStateFlags
    Get
    Set
abstract StateFlags : MeasurementStateFlags with get, set

function get_StateFlags();
function set_StateFlags(value);
property MeasurementStateFlags StateFlags {
    MeasurementStateFlags get ();
    void set (MeasurementStateFlags value);
}

Property Value

Type: MeasurementStateFlags
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurement.TagName Property

Grid Solutions Framework IMeasurementTagName Property
Gets or sets the text based tag name of this IMeasurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string TagName { get; set; }
Property TagName As String
    Get
    Set
abstract TagName : string with get, set

function get_TagName();
function set_TagName(value);
property String^ TagName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IMeasurement Interface
GSF.TimeSeries Namespace


IMeasurementExtensions Class

Grid Solutions Framework IMeasurementExtensions Class
Defines static extension functions for IMeasurement implementations.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesIMeasurementExtensions

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class IMeasurementExtensions
<ExtensionAttribute>
Public NotInheritable Class IMeasurementExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IMeasurementExtensions =  class end
GSF.TimeSeries.IMeasurementExtensions = function();

Type.createClass(
    'GSF.TimeSeries.IMeasurementExtensions');
[ExtensionAttribute]
public ref class IMeasurementExtensions abstract sealed

The IMeasurementExtensions type exposes the following members.

Methods
Name | Description
GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting.
IsCalculated | Returns true if CalcuatedValue is set.
IsDiscarded | Returns true if DiscardedValue is set.
MeasurementKeys | Returns the MeasurementKey values of a IMeasurement enumeration.
RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key.
TimestampQualityIsGood | Returns true if BadTime is not set.
ValueQualityIsGood | Returns true if BadData is not set.
Top
Remarks
These helper functions map to the previously defined corresponding properties to help with the transition of MeasurementStateFlags.
See Also

Reference

GSF.TimeSeries Namespace


IMeasurementExtensions Methods

Grid Solutions Framework IMeasurementExtensions Methods

The IMeasurementExtensions type exposes the following members.

Methods
Name | Description
GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting.
IsCalculated | Returns true if CalcuatedValue is set.
IsDiscarded | Returns true if DiscardedValue is set.
MeasurementKeys | Returns the MeasurementKey values of a IMeasurement enumeration.
RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key.
TimestampQualityIsGood | Returns true if BadTime is not set.
ValueQualityIsGood | Returns true if BadData is not set.
Top
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


IMeasurementExtensions.GetSignalType Method

Grid Solutions Framework IMeasurementExtensionsGetSignalType Method
Gets a unique (run-time only) signal type ID for the given measurement useful for sorting.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int GetSignalType(
    this IMeasurement measurement,
    DataSet dataSource
)
<ExtensionAttribute>
Public Shared Function GetSignalType (
    measurement As IMeasurement,
    dataSource As DataSet
) As Integer
static member GetSignalType :
        measurement : IMeasurement *
        dataSource : DataSet -> int

GSF.TimeSeries.IMeasurementExtensions.GetSignalType = function(measurement, dataSource);
public:
[ExtensionAttribute]
static int GetSignalType(
    IMeasurement^ measurement,
    DataSet^ dataSource
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement to obtain signal type for.
dataSource
Type: System.DataDataSet
DataSet that contains measurement metadata.

Return Value

Type: Int32
Unique (run-time only) signal type ID for the given measurement.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMeasurement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


IMeasurementExtensions.IsCalculated Method

Grid Solutions Framework IMeasurementExtensionsIsCalculated Method
Returns true if CalcuatedValue is set.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsCalculated(
    this IMeasurement measurement
)
<ExtensionAttribute>
Public Shared Function IsCalculated (
    measurement As IMeasurement
) As Boolean
static member IsCalculated :
        measurement : IMeasurement -> bool

GSF.TimeSeries.IMeasurementExtensions.IsCalculated = function(measurement);
public:
[ExtensionAttribute]
static bool IsCalculated(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement instance to test.

Return Value

Type: Boolean
true if CalcuatedValue is not set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMeasurement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


IMeasurementExtensions.IsDiscarded Method

Grid Solutions Framework IMeasurementExtensionsIsDiscarded Method
Returns true if DiscardedValue is set.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsDiscarded(
    this IMeasurement measurement
)
<ExtensionAttribute>
Public Shared Function IsDiscarded (
    measurement As IMeasurement
) As Boolean
static member IsDiscarded :
        measurement : IMeasurement -> bool

GSF.TimeSeries.IMeasurementExtensions.IsDiscarded = function(measurement);
public:
[ExtensionAttribute]
static bool IsDiscarded(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement instance to test.

Return Value

Type: Boolean
true if DiscardedValue is not set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMeasurement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


IMeasurementExtensions.MeasurementKeys Method

Grid Solutions Framework IMeasurementExtensionsMeasurementKeys Method
Returns the MeasurementKey values of a IMeasurement enumeration.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey[] MeasurementKeys(
    this IEnumerable<IMeasurement> measurements
)
<ExtensionAttribute>
Public Shared Function MeasurementKeys (
    measurements As IEnumerable(Of IMeasurement)
) As MeasurementKey()
static member MeasurementKeys :
        measurements : IEnumerable<IMeasurement> -> MeasurementKey[]

GSF.TimeSeries.IMeasurementExtensions.MeasurementKeys = function(measurements);
public:
[ExtensionAttribute]
static array<MeasurementKey^>^ MeasurementKeys(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
IMeasurement enumeration to convert.

Return Value

Type: MeasurementKey
MeasurementKey values of the IMeasurement enumeration.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable IMeasurement . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


IMeasurementExtensions.RuntimeSignalID Method

Grid Solutions Framework IMeasurementExtensionsRuntimeSignalID Method
Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Guid RuntimeSignalID(
    this IMeasurement measurement
)
<ExtensionAttribute>
Public Shared Function RuntimeSignalID (
    measurement As IMeasurement
) As Guid
static member RuntimeSignalID :
        measurement : IMeasurement -> Guid

GSF.TimeSeries.IMeasurementExtensions.RuntimeSignalID = function(measurement);
public:
[ExtensionAttribute]
static Guid RuntimeSignalID(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement instance to test.

Return Value

Type: Guid
Measurement ID if defined, otherwise the run-time signal ID associated with the measurement key.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMeasurement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


IMeasurementExtensions.TimestampQualityIsGood Method

Grid Solutions Framework IMeasurementExtensionsTimestampQualityIsGood Method
Returns true if BadTime is not set.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TimestampQualityIsGood(
    this IMeasurement measurement
)
<ExtensionAttribute>
Public Shared Function TimestampQualityIsGood (
    measurement As IMeasurement
) As Boolean
static member TimestampQualityIsGood :
        measurement : IMeasurement -> bool

GSF.TimeSeries.IMeasurementExtensions.TimestampQualityIsGood = function(measurement);
public:
[ExtensionAttribute]
static bool TimestampQualityIsGood(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement instance to test.

Return Value

Type: Boolean
true if BadTime is not set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMeasurement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


IMeasurementExtensions.ValueQualityIsGood Method

Grid Solutions Framework IMeasurementExtensionsValueQualityIsGood Method
Returns true if BadData is not set.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ValueQualityIsGood(
    this IMeasurement measurement
)
<ExtensionAttribute>
Public Shared Function ValueQualityIsGood (
    measurement As IMeasurement
) As Boolean
static member ValueQualityIsGood :
        measurement : IMeasurement -> bool

GSF.TimeSeries.IMeasurementExtensions.ValueQualityIsGood = function(measurement);
public:
[ExtensionAttribute]
static bool ValueQualityIsGood(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement instance to test.

Return Value

Type: Boolean
true if BadData is not set.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IMeasurement. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IMeasurementExtensions Class
GSF.TimeSeries Namespace


ImmediateMeasurements Class

Grid Solutions Framework ImmediateMeasurements Class
Represents the absolute latest measurement values received by a ConcentratorBase implementation.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesImmediateMeasurements

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ImmediateMeasurements : IEnumerable<TemporalMeasurement>,
    IEnumerable, IDisposable
Public Class ImmediateMeasurements
    Implements IEnumerable(Of TemporalMeasurement), IEnumerable,
    IDisposable
type ImmediateMeasurements =
    class
        interface IEnumerable<TemporalMeasurement>
        interface IEnumerable
        interface IDisposable
    end
GSF.TimeSeries.ImmediateMeasurements = function();

Type.createClass(
    'GSF.TimeSeries.ImmediateMeasurements',
    null,
    IEnumerable`1,
    IEnumerable,
    IDisposable);
public ref class ImmediateMeasurements : IEnumerable<TemporalMeasurement^>,
    IEnumerable, IDisposable

The ImmediateMeasurements type exposes the following members.

Constructors
 | Name | Description
Public method | ImmediateMeasurements | Creates a new instance of the ImmediateMeasurements class.
Top
Methods
 | Name | Description
Public method | AddTaggedMeasurement | Associates a new measurement ID with a tag, creating the new tag if needed.
Public method | CalculateAverage | Calculates an average of all measurements.
Public method | CalculateTagAverage | Calculates an average of all measurements associated with the specified tag.
Public method | ClearMeasurementCache | Clears the existing measurement cache.
Public method | DefineTaggedMeasurements | Defines tagged measurements from a data table.
Public method | Dispose | Releases all the resources used by the ImmediateMeasurements object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ImmediateMeasurements object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ImmediateMeasurements object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Measurement(IMeasurement) | Retrieves the specified immediate temporal measurement, creating it if needed.
Public method | Measurement(MeasurementKey) | Retrieves the specified immediate temporal measurement, creating it if needed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLagTimeUpdated | Updates the tracked temporal measurements lag time.
Protected method | OnLeadTimeUpdated | Updates the tracked temporal measurements lead time.
Public method | TaggedMeasurementKeys | Returns measurement list of specified tag, if it exists.
Public method | TagMaximum | Returns the maximum value of all measurements associated with the specified tag.
Public method | TagMinimum | Returns the minimum value of all measurements associated with the specified tag.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateMeasurementValue | Store new measurement.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByTemporalMeasurement, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityTemporalMeasurement | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityTemporalMeasurement(TemporalMeasurement) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxTemporalMeasurement(FuncTemporalMeasurement, TemporalMeasurement, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxTemporalMeasurement(IComparerTemporalMeasurement) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByTemporalMeasurement, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinTemporalMeasurement(FuncTemporalMeasurement, TemporalMeasurement, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinTemporalMeasurement(IComparerTemporalMeasurement) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByTemporalMeasurement, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityTemporalMeasurement | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityTemporalMeasurement(TemporalMeasurement) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringTemporalMeasurement | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringTemporalMeasurement(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringTemporalMeasurement(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | Item | We retrieve adjusted measurement values within time tolerance of concentrator real-time.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | Maximum | Returns the maximum value of all measurements.
Public property | MeasurementIDs | Returns collection of measurement ID's.
Public property | Minimum | Returns the minimum value of all measurements.
Public property | RealTimeFunction | Gets or sets function to return real-time.
Public property | Tags | Returns ID collection for measurement tags.
Top
See Also

Reference

GSF.TimeSeries Namespace


ImmediateMeasurements Constructor

Grid Solutions Framework ImmediateMeasurements Constructor
Creates a new instance of the ImmediateMeasurements class.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ImmediateMeasurements()
Public Sub New
new : unit -> ImmediateMeasurements
GSF.TimeSeries.ImmediateMeasurements = function();
public:
ImmediateMeasurements()
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements Methods

Grid Solutions Framework ImmediateMeasurements Methods

The ImmediateMeasurements type exposes the following members.

Methods
 | Name | Description
Public method | AddTaggedMeasurement | Associates a new measurement ID with a tag, creating the new tag if needed.
Public method | CalculateAverage | Calculates an average of all measurements.
Public method | CalculateTagAverage | Calculates an average of all measurements associated with the specified tag.
Public method | ClearMeasurementCache | Clears the existing measurement cache.
Public method | DefineTaggedMeasurements | Defines tagged measurements from a data table.
Public method | Dispose | Releases all the resources used by the ImmediateMeasurements object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ImmediateMeasurements object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ImmediateMeasurements object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Measurement(IMeasurement) | Retrieves the specified immediate temporal measurement, creating it if needed.
Public method | Measurement(MeasurementKey) | Retrieves the specified immediate temporal measurement, creating it if needed.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnLagTimeUpdated | Updates the tracked temporal measurements lag time.
Protected method | OnLeadTimeUpdated | Updates the tracked temporal measurements lead time.
Public method | TaggedMeasurementKeys | Returns measurement list of specified tag, if it exists.
Public method | TagMaximum | Returns the maximum value of all measurements associated with the specified tag.
Public method | TagMinimum | Returns the minimum value of all measurements associated with the specified tag.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UpdateMeasurementValue | Store new measurement.
Top
Extension Methods
 | Name | Description
Public Extension Method | DistinctByTemporalMeasurement, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MajorityTemporalMeasurement | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityTemporalMeasurement(TemporalMeasurement) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxTemporalMeasurement(FuncTemporalMeasurement, TemporalMeasurement, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxTemporalMeasurement(IComparerTemporalMeasurement) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByTemporalMeasurement, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinTemporalMeasurement(FuncTemporalMeasurement, TemporalMeasurement, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinTemporalMeasurement(IComparerTemporalMeasurement) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByTemporalMeasurement, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityTemporalMeasurement | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityTemporalMeasurement(TemporalMeasurement) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringTemporalMeasurement | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringTemporalMeasurement(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringTemporalMeasurement(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Top
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.AddTaggedMeasurement Method

Grid Solutions Framework ImmediateMeasurementsAddTaggedMeasurement Method
Associates a new measurement ID with a tag, creating the new tag if needed.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddTaggedMeasurement(
    string tag,
    MeasurementKey id
)
Public Sub AddTaggedMeasurement (
    tag As String,
    id As MeasurementKey
)
member AddTaggedMeasurement :
        tag : string *
        id : MeasurementKey -> unit

function AddTaggedMeasurement(tag, id);
public:
void AddTaggedMeasurement(
    String^ tag,
    MeasurementKey^ id
)

Parameters

tag
Type: SystemString
A String to represent the key.
id
Type: GSF.TimeSeriesMeasurementKey
A Guid ID to associate with the tag.
Remarks
Allows you to define "grouped" points so you can aggregate certain measurements.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.CalculateAverage Method

Grid Solutions Framework ImmediateMeasurementsCalculateAverage Method
Calculates an average of all measurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculateAverage(
    ref int count
)
Public Function CalculateAverage (
    ByRef count As Integer
) As Double
member CalculateAverage :
        count : int byref -> float

function CalculateAverage(count);
public:
double CalculateAverage(
    int% count
)

Parameters

count
Type: SystemInt32
An Int32 value to get the count of values averaged.

Return Value

Type: Double
A Double value representing the average of the measurements.
Remarks
This is only useful if all measurements represent the same type of measurement.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.CalculateTagAverage Method

Grid Solutions Framework ImmediateMeasurementsCalculateTagAverage Method
Calculates an average of all measurements associated with the specified tag.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double CalculateTagAverage(
    string tag,
    ref int count
)
Public Function CalculateTagAverage (
    tag As String,
    ByRef count As Integer
) As Double
member CalculateTagAverage :
        tag : string *
        count : int byref -> float

function CalculateTagAverage(tag, count);
public:
double CalculateTagAverage(
    String^ tag,
    int% count
)

Parameters

tag
Type: SystemString
The type of measurements to average.
count
Type: SystemInt32
An Int32 value to get the count of values averaged.

Return Value

Type: Double
A Double value representing the average of the tags.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.ClearMeasurementCache Method

Grid Solutions Framework ImmediateMeasurementsClearMeasurementCache Method
Clears the existing measurement cache.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ClearMeasurementCache()
Public Sub ClearMeasurementCache
member ClearMeasurementCache : unit -> unit

function ClearMeasurementCache();
public:
void ClearMeasurementCache()
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.DefineTaggedMeasurements Method

Grid Solutions Framework ImmediateMeasurementsDefineTaggedMeasurements Method
Defines tagged measurements from a data table.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void DefineTaggedMeasurements(
    DataTable taggedMeasurements
)
Public Sub DefineTaggedMeasurements (
    taggedMeasurements As DataTable
)
member DefineTaggedMeasurements :
        taggedMeasurements : DataTable -> unit

function DefineTaggedMeasurements(taggedMeasurements);
public:
void DefineTaggedMeasurements(
    DataTable^ taggedMeasurements
)

Parameters

taggedMeasurements
Type: System.DataDataTable
A DataTable to use for defining the tagged measurements.
Remarks
Expects String based tag field to be aliased as "Tag" and Guid based measurement ID field to be aliased as "ID".
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Dispose Method

Grid Solutions Framework ImmediateMeasurementsDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ImmediateMeasurements object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ImmediateMeasurements object and optionally releases the managed resources.
Top
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Dispose Method

Grid Solutions Framework ImmediateMeasurementsDispose Method
Releases all the resources used by the ImmediateMeasurements object.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ImmediateMeasurements Class
Dispose Overload
GSF.TimeSeries Namespace


ImmediateMeasurements.Dispose Method (Boolean)

Grid Solutions Framework ImmediateMeasurementsDispose Method (Boolean)
Releases the unmanaged resources used by the ImmediateMeasurements object and optionally releases the managed resources.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ImmediateMeasurements Class
Dispose Overload
GSF.TimeSeries Namespace


ImmediateMeasurements.Finalize Method

Grid Solutions Framework ImmediateMeasurementsFinalize Method
Releases the unmanaged resources before the ImmediateMeasurements object is reclaimed by GC.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Measurement Method

Grid Solutions Framework ImmediateMeasurementsMeasurement Method
Overload List
 | Name | Description
Public method | Measurement(IMeasurement) | Retrieves the specified immediate temporal measurement, creating it if needed.
Public method | Measurement(MeasurementKey) | Retrieves the specified immediate temporal measurement, creating it if needed.
Top
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Measurement Method (IMeasurement)

Grid Solutions Framework ImmediateMeasurementsMeasurement Method (IMeasurement)
Retrieves the specified immediate temporal measurement, creating it if needed.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TemporalMeasurement Measurement(
    IMeasurement measurement
)
Public Function Measurement (
    measurement As IMeasurement
) As TemporalMeasurement
member Measurement :
        measurement : IMeasurement -> TemporalMeasurement

function Measurement(measurement);
public:
TemporalMeasurement^ Measurement(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Source IMeasurement value.

Return Value

Type: TemporalMeasurement
A TemporalMeasurement object.
See Also

Reference

ImmediateMeasurements Class
Measurement Overload
GSF.TimeSeries Namespace


ImmediateMeasurements.Measurement Method (MeasurementKey)

Grid Solutions Framework ImmediateMeasurementsMeasurement Method (MeasurementKey)
Retrieves the specified immediate temporal measurement, creating it if needed.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TemporalMeasurement Measurement(
    MeasurementKey id
)
Public Function Measurement (
    id As MeasurementKey
) As TemporalMeasurement
member Measurement :
        id : MeasurementKey -> TemporalMeasurement

function Measurement(id);
public:
TemporalMeasurement^ Measurement(
    MeasurementKey^ id
)

Parameters

id
Type: GSF.TimeSeriesMeasurementKey
Guid based signal ID of measurement.

Return Value

Type: TemporalMeasurement
A TemporalMeasurement object.
See Also

Reference

ImmediateMeasurements Class
Measurement Overload
GSF.TimeSeries Namespace


ImmediateMeasurements.OnLagTimeUpdated Method

Grid Solutions Framework ImmediateMeasurementsOnLagTimeUpdated Method
Updates the tracked temporal measurements lag time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnLagTimeUpdated(
    double lagTime
)
Protected Sub OnLagTimeUpdated (
    lagTime As Double
)
member OnLagTimeUpdated :
        lagTime : float -> unit

function OnLagTimeUpdated(lagTime);
protected:
void OnLagTimeUpdated(
    double lagTime
)

Parameters

lagTime
Type: SystemDouble
New lag time.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.OnLeadTimeUpdated Method

Grid Solutions Framework ImmediateMeasurementsOnLeadTimeUpdated Method
Updates the tracked temporal measurements lead time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnLeadTimeUpdated(
    double leadTime
)
Protected Sub OnLeadTimeUpdated (
    leadTime As Double
)
member OnLeadTimeUpdated :
        leadTime : float -> unit

function OnLeadTimeUpdated(leadTime);
protected:
void OnLeadTimeUpdated(
    double leadTime
)

Parameters

leadTime
Type: SystemDouble
New lead time.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.TaggedMeasurementKeys Method

Grid Solutions Framework ImmediateMeasurementsTaggedMeasurementKeys Method
Returns measurement list of specified tag, if it exists.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ReadOnlyCollection<MeasurementKey> TaggedMeasurementKeys(
    string tag
)
Public Function TaggedMeasurementKeys (
    tag As String
) As ReadOnlyCollection(Of MeasurementKey)
member TaggedMeasurementKeys :
        tag : string -> ReadOnlyCollection<MeasurementKey>

function TaggedMeasurementKeys(tag);
public:
ReadOnlyCollection<MeasurementKey^>^ TaggedMeasurementKeys(
    String^ tag
)

Parameters

tag
Type: SystemString
A String that indicates the tag to use.

Return Value

Type: ReadOnlyCollection MeasurementKey
A collection of measurement keys.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.TagMaximum Method

Grid Solutions Framework ImmediateMeasurementsTagMaximum Method
Returns the maximum value of all measurements associated with the specified tag.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double TagMaximum(
    string tag
)
Public Function TagMaximum (
    tag As String
) As Double
member TagMaximum :
        tag : string -> float

function TagMaximum(tag);
public:
double TagMaximum(
    String^ tag
)

Parameters

tag
Type: SystemString
The tag group to evaluate.

Return Value

Type: Double
A Double value representing the tag maximum.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.TagMinimum Method

Grid Solutions Framework ImmediateMeasurementsTagMinimum Method
Returns the minimum value of all measurements associated with the specified tag.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double TagMinimum(
    string tag
)
Public Function TagMinimum (
    tag As String
) As Double
member TagMinimum :
        tag : string -> float

function TagMinimum(tag);
public:
double TagMinimum(
    String^ tag
)

Parameters

tag
Type: SystemString
The tag group to evaluate.

Return Value

Type: Double
A Double value representing the tag minimum.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.UpdateMeasurementValue Method

Grid Solutions Framework ImmediateMeasurementsUpdateMeasurementValue Method
Store new measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateMeasurementValue(
    IMeasurement newMeasurement
)
Public Sub UpdateMeasurementValue (
    newMeasurement As IMeasurement
)
member UpdateMeasurementValue :
        newMeasurement : IMeasurement -> unit

function UpdateMeasurementValue(newMeasurement);
public:
void UpdateMeasurementValue(
    IMeasurement^ newMeasurement
)

Parameters

newMeasurement
Type: GSF.TimeSeriesIMeasurement
New measurement value to update.
Remarks
Value is only stored if it is newer than the cached value.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements Properties

Grid Solutions Framework ImmediateMeasurements Properties

The ImmediateMeasurements type exposes the following members.

Properties
 | Name | Description
Public property | Item | We retrieve adjusted measurement values within time tolerance of concentrator real-time.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | Maximum | Returns the maximum value of all measurements.
Public property | MeasurementIDs | Returns collection of measurement ID's.
Public property | Minimum | Returns the minimum value of all measurements.
Public property | RealTimeFunction | Gets or sets function to return real-time.
Public property | Tags | Returns ID collection for measurement tags.
Top
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Item Property

Grid Solutions Framework ImmediateMeasurementsItem Property
We retrieve adjusted measurement values within time tolerance of concentrator real-time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double this[
    MeasurementKey id
] { get; }
Public ReadOnly Default Property Item (
    id As MeasurementKey
) As Double
    Get
member Item : float with get

function get_Item(id);

public:
property double default[MeasurementKey^ id] {
    double get (MeasurementKey^ id);
}

Parameters

id
Type: GSF.TimeSeriesMeasurementKey
A Guid representing the measurement ID.

Return Value

Type: Double
A Double representing the adjusted measurement value.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.LagTime Property

Grid Solutions Framework ImmediateMeasurementsLagTime Property
Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double LagTime { get; set; }
Public Property LagTime As Double
    Get
    Set
member LagTime : float with get, set

function get_LagTime();
function set_LagTime(value);
public:
property double LagTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to past measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too old.

See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.LeadTime Property

Grid Solutions Framework ImmediateMeasurementsLeadTime Property
Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double LeadTime { get; set; }
Public Property LeadTime As Double
    Get
    Set
member LeadTime : float with get, set

function get_LeadTime();
function set_LeadTime(value);
public:
property double LeadTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LeadTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to future measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too advanced.

See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Maximum Property

Grid Solutions Framework ImmediateMeasurementsMaximum Property
Returns the maximum value of all measurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Maximum { get; }
Public ReadOnly Property Maximum As Double
    Get
member Maximum : float with get

function get_Maximum();

public:
property double Maximum {
    double get ();
}

Property Value

Type: Double
Remarks
This is only useful if all measurements represent the same type of measurement.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.MeasurementIDs Property

Grid Solutions Framework ImmediateMeasurementsMeasurementIDs Property
Returns collection of measurement ID's.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<MeasurementKey> MeasurementIDs { get; }
Public ReadOnly Property MeasurementIDs As ICollection(Of MeasurementKey)
    Get
member MeasurementIDs : ICollection<MeasurementKey> with get

function get_MeasurementIDs();

public:
property ICollection<MeasurementKey^>^ MeasurementIDs {
    ICollection<MeasurementKey^>^ get ();
}

Property Value

Type: ICollection MeasurementKey
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Minimum Property

Grid Solutions Framework ImmediateMeasurementsMinimum Property
Returns the minimum value of all measurements.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Minimum { get; }
Public ReadOnly Property Minimum As Double
    Get
member Minimum : float with get

function get_Minimum();

public:
property double Minimum {
    double get ();
}

Property Value

Type: Double
Remarks
This is only useful if all measurements represent the same type of measurement.
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.RealTimeFunction Property

Grid Solutions Framework ImmediateMeasurementsRealTimeFunction Property
Gets or sets function to return real-time.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Func<Ticks> RealTimeFunction { get; set; }
Public Property RealTimeFunction As Func(Of Ticks)
    Get
    Set
member RealTimeFunction : Func<Ticks> with get, set

function get_RealTimeFunction();
function set_RealTimeFunction(value);
public:
property Func<Ticks>^ RealTimeFunction {
    Func<Ticks>^ get ();
    void set (Func<Ticks>^ value);
}

Property Value

Type: Func Ticks
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


ImmediateMeasurements.Tags Property

Grid Solutions Framework ImmediateMeasurementsTags Property
Returns ID collection for measurement tags.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ICollection<string> Tags { get; }
Public ReadOnly Property Tags As ICollection(Of String)
    Get
member Tags : ICollection<string> with get

function get_Tags();

public:
property ICollection<String^>^ Tags {
    ICollection<String^>^ get ();
}

Property Value

Type: ICollection String
See Also

Reference

ImmediateMeasurements Class
GSF.TimeSeries Namespace


InstallerBase Class

Grid Solutions Framework InstallerBase Class
Defines a common installer class for the applications based on the time-series framework.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Configuration.InstallInstaller
GSF.TimeSeriesInstallerBase

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class InstallerBase : Installer
Public Class InstallerBase
    Inherits Installer
type InstallerBase =
    class
        inherit Installer
    end
GSF.TimeSeries.InstallerBase = function();

Type.createClass(
    'GSF.TimeSeries.InstallerBase',
    Installer);
public ref class InstallerBase : public Installer

The InstallerBase type exposes the following members.

Constructors
 | Name | Description
Public method | InstallerBase | Initializes a new instance of the InstallerBase class
Top
Methods
 | Name | Description
Public method | Commit | When overridden in a derived class, completes the install transaction. (Inherited from Installer.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Install | Installs the class. (Overrides InstallerInstall(IDictionary).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterInstall | Raises the AfterInstall event. (Inherited from Installer.)
Protected method | OnAfterRollback | Raises the AfterRollback event. (Inherited from Installer.)
Protected method | OnAfterUninstall | Raises the AfterUninstall event. (Inherited from Installer.)
Protected method | OnBeforeInstall | Raises the BeforeInstall event. (Inherited from Installer.)
Protected method | OnBeforeRollback | Raises the BeforeRollback event. (Inherited from Installer.)
Protected method | OnBeforeUninstall | Raises the BeforeUninstall event. (Inherited from Installer.)
Protected method | OnCommitted | Raises the Committed event. (Inherited from Installer.)
Protected method | OnCommitting | Raises the Committing event. (Inherited from Installer.)
Protected method | OnSystemSettingsLoaded | Called when system settings are loaded.
Public method | Rollback | When overridden in a derived class, restores the pre-installation state of the computer. (Inherited from Installer.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Uninstall | When overridden in a derived class, removes an installation. (Inherited from Installer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Protected property | ConfigurationName | Gets associated application configuration file name.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Context | Gets or sets information about the current installation. (Inherited from Installer.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | HelpText | Gets the help text for all the installers in the installer collection. (Inherited from Installer.)
Public property | Installers | Gets the collection of installers that this installer contains. (Inherited from Installer.)
Public property | Parent | Gets or sets the installer containing the collection that this installer belongs to. (Inherited from Installer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | AfterInstall | Occurs after the Install(IDictionary) methods of all the installers in the Installers property have run. (Inherited from Installer.)
Public event | AfterRollback | Occurs after the installations of all the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | AfterUninstall | Occurs after all the installers in the Installers property perform their uninstallation operations. (Inherited from Installer.)
Public event | BeforeInstall | Occurs before the Install(IDictionary) method of each installer in the installer collection has run. (Inherited from Installer.)
Public event | BeforeRollback | Occurs before the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | BeforeUninstall | Occurs before the installers in the Installers property perform their uninstall operations. (Inherited from Installer.)
Public event | Committed | Occurs after all the installers in the Installers property have committed their installations. (Inherited from Installer.)
Public event | Committing | Occurs before the installers in the Installers property committ their installations. (Inherited from Installer.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
Remarks
Users may choose to only install service application or its management tools, in either case common installation steps need to occur, so these steps are managed in this one common base class.
See Also

Reference

GSF.TimeSeries Namespace


InstallerBase Constructor

Grid Solutions Framework InstallerBase Constructor
Initializes a new instance of the InstallerBase class

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InstallerBase()
Public Sub New
new : unit -> InstallerBase
GSF.TimeSeries.InstallerBase = function();
public:
InstallerBase()
See Also

Reference

InstallerBase Class
GSF.TimeSeries Namespace


InstallerBase Methods

Grid Solutions Framework InstallerBase Methods

The InstallerBase type exposes the following members.

Methods
 | Name | Description
Public method | Commit | When overridden in a derived class, completes the install transaction. (Inherited from Installer.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the Component and optionally releases the managed resources. (Inherited from Component.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | Install | Installs the class. (Overrides InstallerInstall(IDictionary).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnAfterInstall | Raises the AfterInstall event. (Inherited from Installer.)
Protected method | OnAfterRollback | Raises the AfterRollback event. (Inherited from Installer.)
Protected method | OnAfterUninstall | Raises the AfterUninstall event. (Inherited from Installer.)
Protected method | OnBeforeInstall | Raises the BeforeInstall event. (Inherited from Installer.)
Protected method | OnBeforeRollback | Raises the BeforeRollback event. (Inherited from Installer.)
Protected method | OnBeforeUninstall | Raises the BeforeUninstall event. (Inherited from Installer.)
Protected method | OnCommitted | Raises the Committed event. (Inherited from Installer.)
Protected method | OnCommitting | Raises the Committing event. (Inherited from Installer.)
Protected method | OnSystemSettingsLoaded | Called when system settings are loaded.
Public method | Rollback | When overridden in a derived class, restores the pre-installation state of the computer. (Inherited from Installer.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Public method | Uninstall | When overridden in a derived class, removes an installation. (Inherited from Installer.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

InstallerBase Class
GSF.TimeSeries Namespace


InstallerBase.Install Method

Grid Solutions Framework InstallerBaseInstall Method
Installs the class.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Install(
    IDictionary stateSaver
)
Public Overrides Sub Install (
    stateSaver As IDictionary
)
abstract Install :
        stateSaver : IDictionary -> unit
override Install :
        stateSaver : IDictionary -> unit
function Install(stateSaver);
public:
virtual void Install(
    IDictionary^ stateSaver
) override

Parameters

stateSaver
Type: System.CollectionsIDictionary
Current state information.
See Also

Reference

InstallerBase Class
GSF.TimeSeries Namespace


InstallerBase.OnSystemSettingsLoaded Method

Grid Solutions Framework InstallerBaseOnSystemSettingsLoaded Method
Called when system settings are loaded.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnSystemSettingsLoaded(
    XmlDocument configurationFile,
    XmlNode systemSettingsNode
)
Protected Overridable Sub OnSystemSettingsLoaded (
    configurationFile As XmlDocument,
    systemSettingsNode As XmlNode
)
abstract OnSystemSettingsLoaded :
        configurationFile : XmlDocument *
        systemSettingsNode : XmlNode -> unit
override OnSystemSettingsLoaded :
        configurationFile : XmlDocument *
        systemSettingsNode : XmlNode -> unit
function OnSystemSettingsLoaded(configurationFile, systemSettingsNode);
protected:
virtual void OnSystemSettingsLoaded(
    XmlDocument^ configurationFile,
    XmlNode^ systemSettingsNode
)

Parameters

configurationFile
Type: System.XmlXmlDocument
Open xml document containing configuration settings.
systemSettingsNode
Type: System.XmlXmlNode
Xml node containing system settings.
Remarks
This method will only be called if implementor overrides ConfigurationName with a valid config name.
See Also

Reference

InstallerBase Class
GSF.TimeSeries Namespace


InstallerBase Properties

Grid Solutions Framework InstallerBase Properties

The InstallerBase type exposes the following members.

Properties
 | Name | Description
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Protected property | ConfigurationName | Gets associated application configuration file name.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | Context | Gets or sets information about the current installation. (Inherited from Installer.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | HelpText | Gets the help text for all the installers in the installer collection. (Inherited from Installer.)
Public property | Installers | Gets the collection of installers that this installer contains. (Inherited from Installer.)
Public property | Parent | Gets or sets the installer containing the collection that this installer belongs to. (Inherited from Installer.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
See Also

Reference

InstallerBase Class
GSF.TimeSeries Namespace


InstallerBase.ConfigurationName Property

Grid Solutions Framework InstallerBaseConfigurationName Property
Gets associated application configuration file name.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string ConfigurationName { get; }
Protected Overridable ReadOnly Property ConfigurationName As String
    Get
abstract ConfigurationName : string with get
override ConfigurationName : string with get
function get_ConfigurationName();

protected:
virtual property String^ ConfigurationName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

InstallerBase Class
GSF.TimeSeries Namespace


InstallerBase Events

Grid Solutions Framework InstallerBase Events

The InstallerBase type exposes the following members.

Events
 | Name | Description
Public event | AfterInstall | Occurs after the Install(IDictionary) methods of all the installers in the Installers property have run. (Inherited from Installer.)
Public event | AfterRollback | Occurs after the installations of all the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | AfterUninstall | Occurs after all the installers in the Installers property perform their uninstallation operations. (Inherited from Installer.)
Public event | BeforeInstall | Occurs before the Install(IDictionary) method of each installer in the installer collection has run. (Inherited from Installer.)
Public event | BeforeRollback | Occurs before the installers in the Installers property are rolled back. (Inherited from Installer.)
Public event | BeforeUninstall | Occurs before the installers in the Installers property perform their uninstall operations. (Inherited from Installer.)
Public event | Committed | Occurs after all the installers in the Installers property have committed their installations. (Inherited from Installer.)
Public event | Committing | Occurs before the installers in the Installers property committ their installations. (Inherited from Installer.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
See Also

Reference

InstallerBase Class
GSF.TimeSeries Namespace


ITimeSeriesValue Interface

Grid Solutions Framework ITimeSeriesValue Interface
Represents the fundamental binary value interface for a time-series value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ITimeSeriesValue
Public Interface ITimeSeriesValue
type ITimeSeriesValue =  interface end
GSF.TimeSeries.ITimeSeriesValue = function();
GSF.TimeSeries.ITimeSeriesValue.createInterface('GSF.TimeSeries.ITimeSeriesValue');
public interface class ITimeSeriesValue

The ITimeSeriesValue type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | Get the hash code for the ID.
Top
Properties
 | Name | Description
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT.
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT.
Top
See Also

Reference

GSF.TimeSeries Namespace


ITimeSeriesValue Methods

Grid Solutions Framework ITimeSeriesValue Methods

The ITimeSeriesValue type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | Get the hash code for the ID.
Top
See Also

Reference

ITimeSeriesValue Interface
GSF.TimeSeries Namespace


ITimeSeriesValue.GetHashCode Method

Grid Solutions Framework ITimeSeriesValueGetHashCode Method
Get the hash code for the ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int GetHashCode()
Function GetHashCode As Integer
abstract GetHashCode : unit -> int

function GetHashCode();
int GetHashCode()

Return Value

Type: Int32
Hash code for the ID.
Remarks
Implementers should always return the hash code based on ID of measurement.
See Also

Reference

ITimeSeriesValue Interface
GSF.TimeSeries Namespace


ITimeSeriesValue Properties

Grid Solutions Framework ITimeSeriesValue Properties

The ITimeSeriesValue type exposes the following members.

Properties
 | Name | Description
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT.
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT.
Top
See Also

Reference

ITimeSeriesValue Interface
GSF.TimeSeries Namespace


ITimeSeriesValue.ID Property

Grid Solutions Framework ITimeSeriesValueID Property
Gets or sets the Guid based signal ID of this ITimeSeriesValueT.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Guid ID { get; }
ReadOnly Property ID As Guid
    Get
abstract ID : Guid with get

function get_ID();

property Guid ID {
    Guid get ();
}

Property Value

Type: Guid
Remarks
This is the fundamental identifier of the ITimeSeriesValueT.
See Also

Reference

ITimeSeriesValue Interface
GSF.TimeSeries Namespace


ITimeSeriesValue.Timestamp Property

Grid Solutions Framework ITimeSeriesValueTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Ticks Timestamp { get; set; }
Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set

function get_Timestamp();
function set_Timestamp(value);
property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

ITimeSeriesValue Interface
GSF.TimeSeries Namespace


ITimeSeriesValue.Value Property

Grid Solutions Framework ITimeSeriesValueValue Property
Gets or sets the raw value of this ITimeSeriesValueT.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
BigBinaryValue Value { get; set; }
Property Value As BigBinaryValue
    Get
    Set
abstract Value : BigBinaryValue with get, set

function get_Value();
function set_Value(value);
property BigBinaryValue^ Value {
    BigBinaryValue^ get ();
    void set (BigBinaryValue^ value);
}

Property Value

Type: BigBinaryValue
See Also

Reference

ITimeSeriesValue Interface
GSF.TimeSeries Namespace


ITimeSeriesValue(T) Interface

Grid Solutions Framework ITimeSeriesValueT Interface
Represents the fundamental typed interface for a time-series value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface ITimeSeriesValue<T> : ITimeSeriesValue

Public Interface ITimeSeriesValue(Of T)
    Inherits ITimeSeriesValue
type ITimeSeriesValue<'T> =
    interface
        interface ITimeSeriesValue
    end
JavaScript does not support generic types or methods.
generic<typename T>
public interface class ITimeSeriesValue : ITimeSeriesValue

Type Parameters

T
Type of the time-series value.

The ITimeSeriesValueT type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | Get the hash code for the ID. (Inherited from ITimeSeriesValue.)
Top
Properties
 | Name | Description
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw typed value of this ITimeSeriesValueT.
Top
See Also

Reference

GSF.TimeSeries Namespace


ITimeSeriesValue(T) Methods

Grid Solutions Framework ITimeSeriesValueT Methods

The ITimeSeriesValueT generic type exposes the following members.

Methods
 | Name | Description
Public method | GetHashCode | Get the hash code for the ID. (Inherited from ITimeSeriesValue.)
Top
See Also

Reference

ITimeSeriesValueT Interface
GSF.TimeSeries Namespace


ITimeSeriesValue(T) Properties

Grid Solutions Framework ITimeSeriesValueT Properties

The ITimeSeriesValueT generic type exposes the following members.

Properties
 | Name | Description
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw typed value of this ITimeSeriesValueT.
Top
See Also

Reference

ITimeSeriesValueT Interface
GSF.TimeSeries Namespace


ITimeSeriesValue(T).Value Property

Grid Solutions Framework ITimeSeriesValueTValue Property
Overload List
 | Name | Description
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw typed value of this ITimeSeriesValueT.
Top
See Also

Reference

ITimeSeriesValueT Interface
GSF.TimeSeries Namespace


ITimeSeriesValue(T).Value Property

Grid Solutions Framework ITimeSeriesValueTValue Property
Gets or sets the raw typed value of this ITimeSeriesValueT.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
T Value { get; set; }
Property Value As T
    Get
    Set
abstract Value : 'T with get, set

function get_Value();
function set_Value(value);
property T Value {
    T get ();
    void set (T value);
}

Property Value

Type: T
See Also

Reference

ITimeSeriesValueT Interface
Value Overload
GSF.TimeSeries Namespace


Measurement Class

Grid Solutions Framework Measurement Class
Implementation of a basic measurement.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesMeasurement
GSF.TimeSeriesBufferBlockMeasurement
GSF.TimeSeriesTemporalMeasurement
GSF.TimeSeries.TransportCompactMeasurement
GSF.TimeSeries.TransportSerializableMeasurement

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class Measurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>, IComparable<ITimeSeriesValue>,
    IComparable
<SerializableAttribute>
Public Class Measurement
    Implements IMeasurement, ITimeSeriesValue(Of Double),
    ITimeSeriesValue, IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue),
    IComparable
[<SerializableAttribute>]
type Measurement =
    class
        interface IMeasurement
        interface ITimeSeriesValue<float>
        interface ITimeSeriesValue
        interface IEquatable<ITimeSeriesValue>
        interface IComparable<ITimeSeriesValue>
        interface IComparable
    end
GSF.TimeSeries.Measurement = function();

Type.createClass(
    'GSF.TimeSeries.Measurement',
    null,
    GSF.TimeSeries.IMeasurement,
    GSF.TimeSeries.ITimeSeriesValue`1,
    GSF.TimeSeries.ITimeSeriesValue,
    IEquatable`1,
    IComparable`1,
    IComparable);
[SerializableAttribute]
public ref class Measurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>, IComparable<ITimeSeriesValue^>,
    IComparable

The Measurement type exposes the following members.

Constructors
 | Name | Description
Public method | Measurement | Constructs a new Measurement using default settings.
Top
Methods
 | Name | Description
 | AverageValueFilter | Calculates an average of the specified sequence of IMeasurement values.
 | Clone(IMeasurement) | Creates a copy of the specified measurement.
 | Clone(IMeasurement, Ticks) | Creates a copy of the specified measurement using a new timestamp.
 | Clone(IMeasurement, Double, Ticks) | Creates a copy of the specified measurement using a new value and timestamp.
Public method | CompareTo(Object) | Compares the Measurement with the specified Object.
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Overrides ObjectEquals(Object).)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MajorityValueFilter | Returns the majority value of the specified sequence of IMeasurement values.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Measurement. (Overrides ObjectToString.)
 | ToString(IMeasurement, Boolean) | Returns a String that represents the specified IMeasurement.
Top
Operators
Name | Description
Equality | Compares two Measurement values for equality.
GreaterThan | Returns true if left Measurement value is greater than right Measurement value.
GreaterThanOrEqual | Returns true if left Measurement value is greater than or equal to right Measurement value.
Inequality | Compares two Measurement values for inequality.
LessThan | Returns true if left Measurement value is less than right Measurement value.
LessThanOrEqual | Returns true if left Measurement value is less than or equal to right Measurement value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
Fields
Name | Description
Undefined | Represents an undefined measurement.
Top
Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0.
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available.
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created).
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement.
Public property | TagName | Gets or sets the text based tag name of this Measurement.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement.
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
Top
See Also

Reference

GSF.TimeSeries Namespace


Measurement Constructor

Grid Solutions Framework Measurement Constructor
Constructs a new Measurement using default settings.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Measurement()
Public Sub New
new : unit -> Measurement
GSF.TimeSeries.Measurement = function();
public:
Measurement()
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement Fields

Grid Solutions Framework Measurement Fields

The Measurement type exposes the following members.

Fields
Name | Description
Undefined | Represents an undefined measurement.
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Undefined Field

Grid Solutions Framework MeasurementUndefined Field
Represents an undefined measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Measurement Undefined
Public Shared ReadOnly Undefined As Measurement
static val Undefined: Measurement
var GSF.TimeSeries.Measurement.Undefined
public:
static initonly Measurement^ Undefined

Field Value

Type: Measurement
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement Methods

Grid Solutions Framework Measurement Methods

The Measurement type exposes the following members.

Methods
 | Name | Description
 | AverageValueFilter | Calculates an average of the specified sequence of IMeasurement values.
 | Clone(IMeasurement) | Creates a copy of the specified measurement.
 | Clone(IMeasurement, Ticks) | Creates a copy of the specified measurement using a new timestamp.
 | Clone(IMeasurement, Double, Ticks) | Creates a copy of the specified measurement using a new value and timestamp.
Public method | CompareTo(Object) | Compares the Measurement with the specified Object.
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue.
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Overrides ObjectEquals(Object).)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | MajorityValueFilter | Returns the majority value of the specified sequence of IMeasurement values.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current Measurement. (Overrides ObjectToString.)
 | ToString(IMeasurement, Boolean) | Returns a String that represents the specified IMeasurement.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.AverageValueFilter Method

Grid Solutions Framework MeasurementAverageValueFilter Method
Calculates an average of the specified sequence of IMeasurement values.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double AverageValueFilter(
    IEnumerable<IMeasurement> source
)
Public Shared Function AverageValueFilter (
    source As IEnumerable(Of IMeasurement)
) As Double
static member AverageValueFilter :
        source : IEnumerable<IMeasurement> -> float

GSF.TimeSeries.Measurement.AverageValueFilter = function(source);
public:
static double AverageValueFilter(
    IEnumerable<IMeasurement^>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable IMeasurement
Sequence of IMeasurement values over which to run calculation.

Return Value

Type: Double
Average of the specified sequence of IMeasurement values.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Clone Method

Grid Solutions Framework MeasurementClone Method
Overload List
Name | Description
Clone(IMeasurement) | Creates a copy of the specified measurement.
Clone(IMeasurement, Ticks) | Creates a copy of the specified measurement using a new timestamp.
Clone(IMeasurement, Double, Ticks) | Creates a copy of the specified measurement using a new value and timestamp.
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Clone Method (IMeasurement)

Grid Solutions Framework MeasurementClone Method (IMeasurement)
Creates a copy of the specified measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Measurement Clone(
    IMeasurement measurementToClone
)
Public Shared Function Clone (
    measurementToClone As IMeasurement
) As Measurement
static member Clone :
        measurementToClone : IMeasurement -> Measurement

GSF.TimeSeries.Measurement.Clone = function(measurementToClone);
public:
static Measurement^ Clone(
    IMeasurement^ measurementToClone
)

Parameters

measurementToClone
Type: GSF.TimeSeriesIMeasurement
Specified measurement to clone.

Return Value

Type: Measurement
A copy of the Measurement object.
See Also

Reference

Measurement Class
Clone Overload
GSF.TimeSeries Namespace


Measurement.Clone Method (IMeasurement, Ticks)

Grid Solutions Framework MeasurementClone Method (IMeasurement, Ticks)
Creates a copy of the specified measurement using a new timestamp.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Measurement Clone(
    IMeasurement measurementToClone,
    Ticks timestamp
)
Public Shared Function Clone (
    measurementToClone As IMeasurement,
    timestamp As Ticks
) As Measurement
static member Clone :
        measurementToClone : IMeasurement *
        timestamp : Ticks -> Measurement

GSF.TimeSeries.Measurement.Clone = function(measurementToClone, timestamp);
public:
static Measurement^ Clone(
    IMeasurement^ measurementToClone,
    Ticks timestamp
)

Parameters

measurementToClone
Type: GSF.TimeSeriesIMeasurement
Specified measurement to clone.
timestamp
Type: GSFTicks
New timestamp, in ticks, for cloned measurement.

Return Value

Type: Measurement
A copy of the Measurement object.
See Also

Reference

Measurement Class
Clone Overload
GSF.TimeSeries Namespace


Measurement.Clone Method (IMeasurement, Double, Ticks)

Grid Solutions Framework MeasurementClone Method (IMeasurement, Double, Ticks)
Creates a copy of the specified measurement using a new value and timestamp.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Measurement Clone(
    IMeasurement measurementToClone,
    double value,
    Ticks timestamp
)
Public Shared Function Clone (
    measurementToClone As IMeasurement,
    value As Double,
    timestamp As Ticks
) As Measurement
static member Clone :
        measurementToClone : IMeasurement *
        value : float *
        timestamp : Ticks -> Measurement

GSF.TimeSeries.Measurement.Clone = function(measurementToClone, value, timestamp);
public:
static Measurement^ Clone(
    IMeasurement^ measurementToClone,
    double value,
    Ticks timestamp
)

Parameters

measurementToClone
Type: GSF.TimeSeriesIMeasurement
Specified measurement to clone.
value
Type: SystemDouble
New value for cloned measurement.
timestamp
Type: GSFTicks
New timestamp, in ticks, for cloned measurement.

Return Value

Type: Measurement
A copy of the Measurement object.
See Also

Reference

Measurement Class
Clone Overload
GSF.TimeSeries Namespace


Measurement.CompareTo Method

Grid Solutions Framework MeasurementCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object.
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue.
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.CompareTo Method (Object)

Grid Solutions Framework MeasurementCompareTo Method (Object)
Compares the Measurement with the specified Object.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
abstract CompareTo :
        obj : Object -> int
override CompareTo :
        obj : Object -> int
function CompareTo(obj);
public:
virtual int CompareTo(
    Object^ obj
) sealed

Parameters

obj
Type: SystemObject
The Object to compare with the current Measurement.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | obj is not an IMeasurement.
Remarks
Measurement implementations should compare by hash code.
See Also

Reference

Measurement Class
CompareTo Overload
GSF.TimeSeries Namespace


Measurement.CompareTo Method (ITimeSeriesValue)

Grid Solutions Framework MeasurementCompareTo Method (ITimeSeriesValue)
Compares the Measurement with an ITimeSeriesValue.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    ITimeSeriesValue other
)
Public Function CompareTo (
    other As ITimeSeriesValue
) As Integer
abstract CompareTo :
        other : ITimeSeriesValue -> int
override CompareTo :
        other : ITimeSeriesValue -> int
function CompareTo(other);
public:
virtual int CompareTo(
    ITimeSeriesValue^ other
) sealed

Parameters

other
Type: GSF.TimeSeriesITimeSeriesValue
The ITimeSeriesValue to compare with the current Measurement.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
Remarks
Measurement implementations should compare by hash code.
See Also

Reference

Measurement Class
CompareTo Overload
GSF.TimeSeries Namespace


Measurement.Equals Method

Grid Solutions Framework MeasurementEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Overrides ObjectEquals(Object).)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement.
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Equals Method (Object)

Grid Solutions Framework MeasurementEquals Method (Object)
Determines whether the specified Object is equal to the current Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
The Object to compare with the current Measurement.

Return Value

Type: Boolean
true if the specified Object is equal to the current Measurement; otherwise, false.
See Also

Reference

Measurement Class
Equals Overload
GSF.TimeSeries Namespace


Measurement.Equals Method (ITimeSeriesValue)

Grid Solutions Framework MeasurementEquals Method (ITimeSeriesValue)
Determines whether the specified ITimeSeriesValue is equal to the current Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    ITimeSeriesValue other
)
Public Function Equals (
    other As ITimeSeriesValue
) As Boolean
abstract Equals :
        other : ITimeSeriesValue -> bool
override Equals :
        other : ITimeSeriesValue -> bool
function Equals(other);
public:
virtual bool Equals(
    ITimeSeriesValue^ other
) sealed

Parameters

other
Type: GSF.TimeSeriesITimeSeriesValue
The ITimeSeriesValue to compare with the current Measurement.

Return Value

Type: Boolean
true if the specified ITimeSeriesValue is equal to the current Measurement; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

Measurement Class
Equals Overload
GSF.TimeSeries Namespace


Measurement.GetHashCode Method

Grid Solutions Framework MeasurementGetHashCode Method
Serves as a hash function for the current Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current Measurement.

Implements

ITimeSeriesValueGetHashCode
Remarks
Hash code based on value of measurement.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.MajorityValueFilter Method

Grid Solutions Framework MeasurementMajorityValueFilter Method
Returns the majority value of the specified sequence of IMeasurement values.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double MajorityValueFilter(
    IEnumerable<IMeasurement> source
)
Public Shared Function MajorityValueFilter (
    source As IEnumerable(Of IMeasurement)
) As Double
static member MajorityValueFilter :
        source : IEnumerable<IMeasurement> -> float

GSF.TimeSeries.Measurement.MajorityValueFilter = function(source);
public:
static double MajorityValueFilter(
    IEnumerable<IMeasurement^>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable IMeasurement
Sequence of IMeasurement values over which to run calculation.

Return Value

Type: Double
Majority value of the specified sequence of IMeasurement values.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.ToString Method

Grid Solutions Framework MeasurementToString Method
Overload List
 | Name | Description
Public method | ToString | Returns a String that represents the current Measurement. (Overrides ObjectToString.)
 | ToString(IMeasurement, Boolean) | Returns a String that represents the specified IMeasurement.
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.ToString Method

Grid Solutions Framework MeasurementToString Method
Returns a String that represents the current Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current Measurement.
See Also

Reference

Measurement Class
ToString Overload
GSF.TimeSeries Namespace


Measurement.ToString Method (IMeasurement, Boolean)

Grid Solutions Framework MeasurementToString Method (IMeasurement, Boolean)
Returns a String that represents the specified IMeasurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    IMeasurement measurement,
    bool includeTagName = true
)
Public Shared Function ToString (
    measurement As IMeasurement,
    Optional includeTagName As Boolean = true
) As String
static member ToString :
        measurement : IMeasurement *
        ?includeTagName : bool
(* Defaults:
        let _includeTagName = defaultArg includeTagName true
*)
-> string

GSF.TimeSeries.Measurement.ToString = function(measurement, includeTagName);
public:
static String^ ToString(
    IMeasurement^ measurement,
    bool includeTagName = true
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
IMeasurement to convert to a String representation.
includeTagName (Optional)
Type: SystemBoolean
Set to true to include measurement's tag name, if defined; otherwise set to false.

Return Value

Type: String
A String that represents the specified IMeasurement.
See Also

Reference

Measurement Class
ToString Overload
GSF.TimeSeries Namespace


Measurement Operators

Grid Solutions Framework Measurement Operators

The Measurement type exposes the following members.

Operators
Name | Description
Equality | Compares two Measurement values for equality.
GreaterThan | Returns true if left Measurement value is greater than right Measurement value.
GreaterThanOrEqual | Returns true if left Measurement value is greater than or equal to right Measurement value.
Inequality | Compares two Measurement values for inequality.
LessThan | Returns true if left Measurement value is less than right Measurement value.
LessThanOrEqual | Returns true if left Measurement value is less than or equal to right Measurement value.
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Equality Operator

Grid Solutions Framework MeasurementEquality Operator
Compares two Measurement values for equality.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Measurement measurement1,
    Measurement measurement2
)
Public Shared Operator = (
    measurement1 As Measurement,
    measurement2 As Measurement
) As Boolean
static let inline (=)
        measurement1 : Measurement *
        measurement2 : Measurement  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Measurement^ measurement1,
    Measurement^ measurement2
)

Parameters

measurement1
Type: GSF.TimeSeriesMeasurement
A Measurement left hand operand.
measurement2
Type: GSF.TimeSeriesMeasurement
A Measurement right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.GreaterThan Operator

Grid Solutions Framework MeasurementGreaterThan Operator
Returns true if left Measurement value is greater than right Measurement value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Measurement measurement1,
    Measurement measurement2
)
Public Shared Operator > (
    measurement1 As Measurement,
    measurement2 As Measurement
) As Boolean
static let inline (>)
        measurement1 : Measurement *
        measurement2 : Measurement  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Measurement^ measurement1,
    Measurement^ measurement2
)

Parameters

measurement1
Type: GSF.TimeSeriesMeasurement
A Measurement left hand operand.
measurement2
Type: GSF.TimeSeriesMeasurement
A Measurement right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.GreaterThanOrEqual Operator

Grid Solutions Framework MeasurementGreaterThanOrEqual Operator
Returns true if left Measurement value is greater than or equal to right Measurement value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Measurement measurement1,
    Measurement measurement2
)
Public Shared Operator >= (
    measurement1 As Measurement,
    measurement2 As Measurement
) As Boolean
static let inline (>=)
        measurement1 : Measurement *
        measurement2 : Measurement  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Measurement^ measurement1,
    Measurement^ measurement2
)

Parameters

measurement1
Type: GSF.TimeSeriesMeasurement
A Measurement left hand operand.
measurement2
Type: GSF.TimeSeriesMeasurement
A Measurement right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Inequality Operator

Grid Solutions Framework MeasurementInequality Operator
Compares two Measurement values for inequality.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Measurement measurement1,
    Measurement measurement2
)
Public Shared Operator <> (
    measurement1 As Measurement,
    measurement2 As Measurement
) As Boolean
static let inline (<>)
        measurement1 : Measurement *
        measurement2 : Measurement  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Measurement^ measurement1,
    Measurement^ measurement2
)

Parameters

measurement1
Type: GSF.TimeSeriesMeasurement
A Measurement left hand operand.
measurement2
Type: GSF.TimeSeriesMeasurement
A Measurement right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.LessThan Operator

Grid Solutions Framework MeasurementLessThan Operator
Returns true if left Measurement value is less than right Measurement value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Measurement measurement1,
    Measurement measurement2
)
Public Shared Operator < (
    measurement1 As Measurement,
    measurement2 As Measurement
) As Boolean
static let inline (<)
        measurement1 : Measurement *
        measurement2 : Measurement  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Measurement^ measurement1,
    Measurement^ measurement2
)

Parameters

measurement1
Type: GSF.TimeSeriesMeasurement
A Measurement left hand operand.
measurement2
Type: GSF.TimeSeriesMeasurement
A Measurement right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.LessThanOrEqual Operator

Grid Solutions Framework MeasurementLessThanOrEqual Operator
Returns true if left Measurement value is less than or equal to right Measurement value.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Measurement measurement1,
    Measurement measurement2
)
Public Shared Operator <= (
    measurement1 As Measurement,
    measurement2 As Measurement
) As Boolean
static let inline (<=)
        measurement1 : Measurement *
        measurement2 : Measurement  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Measurement^ measurement1,
    Measurement^ measurement2
)

Parameters

measurement1
Type: GSF.TimeSeriesMeasurement
A Measurement left hand operand.
measurement2
Type: GSF.TimeSeriesMeasurement
A Measurement right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement Properties

Grid Solutions Framework Measurement Properties

The Measurement type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0.
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available.
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement.
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0.
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing).
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created).
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement.
Public property | TagName | Gets or sets the text based tag name of this Measurement.
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement.
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier.
Top
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Adder Property

Grid Solutions Framework MeasurementAdder Property
Gets or sets an offset to add to the measurement value. This defaults to 0.0.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(0)]
public virtual double Adder { get; set; }
<DefaultValueAttribute(0)>
Public Overridable Property Adder As Double
    Get
    Set
[<DefaultValueAttribute(0)>]
abstract Adder : float with get, set
[<DefaultValueAttribute(0)>]
override Adder : float with get, set
function get_Adder();
function set_Adder(value);
public:
[DefaultValueAttribute(0)]
virtual property double Adder {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IMeasurementAdder
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.AdjustedValue Property

Grid Solutions Framework MeasurementAdjustedValue Property
Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double AdjustedValue { get; }
Public Overridable ReadOnly Property AdjustedValue As Double
    Get
abstract AdjustedValue : float with get
override AdjustedValue : float with get
function get_AdjustedValue();

public:
virtual property double AdjustedValue {
    double get ();
}

Return Value

Type: Double
Value offset by Adder and Multiplier (i.e., Value * Multiplier + Adder).

Implements

IMeasurementAdjustedValue
Remarks
Note that returned value will be offset by Adder and Multiplier.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.ID Property

Grid Solutions Framework MeasurementID Property
Gets or sets the Guid based signal ID of this Measurement, if available.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid ID { get; }
Public ReadOnly Property ID As Guid
    Get
abstract ID : Guid with get
override ID : Guid with get
function get_ID();

public:
virtual property Guid ID {
    Guid get () sealed;
}

Property Value

Type: Guid

Implements

ITimeSeriesValueID
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Key Property

Grid Solutions Framework MeasurementKey Property
Gets or sets the primary MeasurementKey of this Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public MeasurementKey Key { get; set; }
Public Property Key As MeasurementKey
    Get
    Set
abstract Key : MeasurementKey with get, set
override Key : MeasurementKey with get, set
function get_Key();
function set_Key(value);
public:
virtual property MeasurementKey^ Key {
    MeasurementKey^ get () sealed;
    void set (MeasurementKey^ value) sealed;
}

Property Value

Type: MeasurementKey

Implements

IMeasurementKey
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.MeasurementValueFilter Property

Grid Solutions Framework MeasurementMeasurementValueFilter Property
Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementValueFilterFunction MeasurementValueFilter { get; set; }
Public Overridable Property MeasurementValueFilter As MeasurementValueFilterFunction
    Get
    Set
abstract MeasurementValueFilter : MeasurementValueFilterFunction with get, set
override MeasurementValueFilter : MeasurementValueFilterFunction with get, set
function get_MeasurementValueFilter();
function set_MeasurementValueFilter(value);
public:
virtual property MeasurementValueFilterFunction^ MeasurementValueFilter {
    MeasurementValueFilterFunction^ get ();
    void set (MeasurementValueFilterFunction^ value);
}

Property Value

Type: MeasurementValueFilterFunction

Implements

IMeasurementMeasurementValueFilter
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Multiplier Property

Grid Solutions Framework MeasurementMultiplier Property
Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(1)]
public virtual double Multiplier { get; set; }
<DefaultValueAttribute(1)>
Public Overridable Property Multiplier As Double
    Get
    Set
[<DefaultValueAttribute(1)>]
abstract Multiplier : float with get, set
[<DefaultValueAttribute(1)>]
override Multiplier : float with get, set
function get_Multiplier();
function set_Multiplier(value);
public:
[DefaultValueAttribute(1)]
virtual property double Multiplier {
    double get ();
    void set (double value);
}

Property Value

Type: Double

Implements

IMeasurementMultiplier
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.PublishedTimestamp Property

Grid Solutions Framework MeasurementPublishedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks PublishedTimestamp { get; set; }
Public Property PublishedTimestamp As Ticks
    Get
    Set
abstract PublishedTimestamp : Ticks with get, set
override PublishedTimestamp : Ticks with get, set
function get_PublishedTimestamp();
function set_PublishedTimestamp(value);
public:
virtual property Ticks PublishedTimestamp {
    Ticks get () sealed;
    void set (Ticks value) sealed;
}

Property Value

Type: Ticks

Implements

IMeasurementPublishedTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.ReceivedTimestamp Property

Grid Solutions Framework MeasurementReceivedTimestamp Property
Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks ReceivedTimestamp { get; set; }
Public Property ReceivedTimestamp As Ticks
    Get
    Set
abstract ReceivedTimestamp : Ticks with get, set
override ReceivedTimestamp : Ticks with get, set
function get_ReceivedTimestamp();
function set_ReceivedTimestamp(value);
public:
virtual property Ticks ReceivedTimestamp {
    Ticks get () sealed;
    void set (Ticks value) sealed;
}

Property Value

Type: Ticks

Implements

IMeasurementReceivedTimestamp
Remarks

In the default implementation, this timestamp will simply be the ticks of UtcNow of when this class was created.

The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.

See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.StateFlags Property

Grid Solutions Framework MeasurementStateFlags Property
Gets or sets MeasurementStateFlags associated with this Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementStateFlags StateFlags { get; set; }
Public Overridable Property StateFlags As MeasurementStateFlags
    Get
    Set
abstract StateFlags : MeasurementStateFlags with get, set
override StateFlags : MeasurementStateFlags with get, set
function get_StateFlags();
function set_StateFlags(value);
public:
virtual property MeasurementStateFlags StateFlags {
    MeasurementStateFlags get ();
    void set (MeasurementStateFlags value);
}

Property Value

Type: MeasurementStateFlags

Implements

IMeasurementStateFlags
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.TagName Property

Grid Solutions Framework MeasurementTagName Property
Gets or sets the text based tag name of this Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string TagName { get; set; }
Public Overridable Property TagName As String
    Get
    Set
abstract TagName : string with get, set
override TagName : string with get, set
function get_TagName();
function set_TagName(value);
public:
virtual property String^ TagName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IMeasurementTagName
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Timestamp Property

Grid Solutions Framework MeasurementTimestamp Property
Gets or sets exact timestamp, in ticks, of the data represented by this Measurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Ticks Timestamp { get; set; }
Public Overridable Property Timestamp As Ticks
    Get
    Set
abstract Timestamp : Ticks with get, set
override Timestamp : Ticks with get, set
function get_Timestamp();
function set_Timestamp(value);
public:
virtual property Ticks Timestamp {
    Ticks get ();
    void set (Ticks value);
}

Property Value

Type: Ticks

Implements

ITimeSeriesValueTimestamp
Remarks
The value of this property represents the number of 100-nanosecond intervals that have elapsed since 12:00:00 midnight, January 1, 0001.
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


Measurement.Value Property

Grid Solutions Framework MeasurementValue Property
Gets or sets the raw measurement value that is not offset by Adder and Multiplier.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double Value { get; set; }
Public Overridable Property Value As Double
    Get
    Set
abstract Value : float with get, set
override Value : float with get, set
function get_Value();
function set_Value(value);
public:
virtual property double Value {
    double get ();
    void set (double value);
}

Return Value

Type: Double
Raw value of this Measurement (i.e., value that is not offset by Adder and Multiplier).

Implements

ITimeSeriesValueTValue
See Also

Reference

Measurement Class
GSF.TimeSeries Namespace


MeasurementKey Class

Grid Solutions Framework MeasurementKey Class
Represents a primary key for a measurement.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesMeasurementKey

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class MeasurementKey
<SerializableAttribute>
Public Class MeasurementKey
[<SerializableAttribute>]
type MeasurementKey =  class end
GSF.TimeSeries.MeasurementKey = function();

Type.createClass(
    'GSF.TimeSeries.MeasurementKey');
[SerializableAttribute]
public ref class MeasurementKey

The MeasurementKey type exposes the following members.

Methods
 | Name | Description
 | CreateOrUpdate(Guid, String) | Constructs a new MeasurementKey given the specified parameters.
 | CreateOrUpdate(Guid, String, UInt32) | Constructs a new MeasurementKey given the specified parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EstablishDefaultCache | Establish default MeasurementKey cache.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current MeasurementKey. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LookUpBySignalID | Looks up the measurement key associated with the given signal ID.
 | LookUpBySource | Looks up the measurement key associated with the given source and ID.
 | LookUpOrCreate(String) | Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the parsed source and ID.
 | LookUpOrCreate(Guid, String) | Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID and the parsed source, and ID.
 | LookUpOrCreate(String, UInt32) | Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the given source and ID.
 | LookUpOrCreate(Guid, String, UInt32) | Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID, source, and ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the string representation of a MeasurementKey into its value equivalent.
Public method | ToString | Returns a String that represents the current MeasurementKey. (Overrides ObjectToString.)
 | TryCreateOrUpdate(Guid, String, MeasurementKey) | Constructs a new MeasurementKey given the specified parameters.
 | TryCreateOrUpdate(Guid, String, UInt32, MeasurementKey) | Constructs a new MeasurementKey given the specified parameters.
 | TryParse | Attempts to convert the string representation of a MeasurementKey into its value equivalent.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
Undefined | Represents an undefined measurement key.
Top
Properties
 | Name | Description
Public property | ID | Gets or sets the numeric ID of this MeasurementKey.
Public property | SignalID | Gets or sets Guid ID of signal associated with this MeasurementKey.
Public property | Source | Gets or sets the source of this MeasurementKey.
Top
Remarks
In the Static section of this class, all edits to IDCache as well as the ConcurrentDictionaries in KeyCache should occur within a lock on SyncEdits.
See Also

Reference

GSF.TimeSeries Namespace


MeasurementKey Fields

Grid Solutions Framework MeasurementKey Fields

The MeasurementKey type exposes the following members.

Fields
Name | Description
Undefined | Represents an undefined measurement key.
Top
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.Undefined Field

Grid Solutions Framework MeasurementKeyUndefined Field
Represents an undefined measurement key.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly MeasurementKey Undefined
Public Shared ReadOnly Undefined As MeasurementKey
static val Undefined: MeasurementKey
var GSF.TimeSeries.MeasurementKey.Undefined
public:
static initonly MeasurementKey^ Undefined

Field Value

Type: MeasurementKey
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey Methods

Grid Solutions Framework MeasurementKey Methods

The MeasurementKey type exposes the following members.

Methods
 | Name | Description
 | CreateOrUpdate(Guid, String) | Constructs a new MeasurementKey given the specified parameters.
 | CreateOrUpdate(Guid, String, UInt32) | Constructs a new MeasurementKey given the specified parameters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EstablishDefaultCache | Establish default MeasurementKey cache.
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for the current MeasurementKey. (Overrides ObjectGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | LookUpBySignalID | Looks up the measurement key associated with the given signal ID.
 | LookUpBySource | Looks up the measurement key associated with the given source and ID.
 | LookUpOrCreate(String) | Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the parsed source and ID.
 | LookUpOrCreate(Guid, String) | Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID and the parsed source, and ID.
 | LookUpOrCreate(String, UInt32) | Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the given source and ID.
 | LookUpOrCreate(Guid, String, UInt32) | Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID, source, and ID.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse | Converts the string representation of a MeasurementKey into its value equivalent.
Public method | ToString | Returns a String that represents the current MeasurementKey. (Overrides ObjectToString.)
 | TryCreateOrUpdate(Guid, String, MeasurementKey) | Constructs a new MeasurementKey given the specified parameters.
 | TryCreateOrUpdate(Guid, String, UInt32, MeasurementKey) | Constructs a new MeasurementKey given the specified parameters.
 | TryParse | Attempts to convert the string representation of a MeasurementKey into its value equivalent.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.CreateOrUpdate Method

Grid Solutions Framework MeasurementKeyCreateOrUpdate Method
Overload List
Name | Description
CreateOrUpdate(Guid, String) | Constructs a new MeasurementKey given the specified parameters.
CreateOrUpdate(Guid, String, UInt32) | Constructs a new MeasurementKey given the specified parameters.
Top
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.CreateOrUpdate Method (Guid, String)

Grid Solutions Framework MeasurementKeyCreateOrUpdate Method (Guid, String)
Constructs a new MeasurementKey given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey CreateOrUpdate(
    Guid signalID,
    string value
)
Public Shared Function CreateOrUpdate (
    signalID As Guid,
    value As String
) As MeasurementKey
static member CreateOrUpdate :
        signalID : Guid *
        value : string -> MeasurementKey

GSF.TimeSeries.MeasurementKey.CreateOrUpdate = function(signalID, value);
public:
static MeasurementKey^ CreateOrUpdate(
    Guid signalID,
    String^ value
)

Parameters

signalID
Type: SystemGuid
Guid ID of associated signal, if defined.
value
Type: SystemString
A string representation of the MeasurementKey.

Return Value

Type: MeasurementKey

[Missing <returns> documentation for "M:GSF.TimeSeries.MeasurementKey.CreateOrUpdate(System.Guid,System.String)"]

Exceptions
Exception | Condition
ArgumentException | signalID cannot be empty
FormatException | The value is not in the correct format for a MeasurementKey value.
See Also

Reference

MeasurementKey Class
CreateOrUpdate Overload
GSF.TimeSeries Namespace


MeasurementKey.CreateOrUpdate Method (Guid, String, UInt32)

Grid Solutions Framework MeasurementKeyCreateOrUpdate Method (Guid, String, UInt32)
Constructs a new MeasurementKey given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey CreateOrUpdate(
    Guid signalID,
    string source,
    uint id
)
Public Shared Function CreateOrUpdate (
    signalID As Guid,
    source As String,
    id As UInteger
) As MeasurementKey
static member CreateOrUpdate :
        signalID : Guid *
        source : string *
        id : uint32 -> MeasurementKey

GSF.TimeSeries.MeasurementKey.CreateOrUpdate = function(signalID, source, id);
public:
static MeasurementKey^ CreateOrUpdate(
    Guid signalID,
    String^ source,
    unsigned int id
)

Parameters

signalID
Type: SystemGuid
Guid ID of associated signal, if defined.
source
Type: SystemString
Source of the measurement that this MeasurementKey represents (e.g., name of archive).
id
Type: SystemUInt32
Numeric ID of the measurement that this MeasurementKey represents.

Return Value

Type: MeasurementKey

[Missing <returns> documentation for "M:GSF.TimeSeries.MeasurementKey.CreateOrUpdate(System.Guid,System.String,System.UInt32)"]

Exceptions
Exception | Condition
ArgumentException | signalID cannot be empty.
ArgumentNullException | source cannot be null.
See Also

Reference

MeasurementKey Class
CreateOrUpdate Overload
GSF.TimeSeries Namespace


MeasurementKey.EstablishDefaultCache Method

Grid Solutions Framework MeasurementKeyEstablishDefaultCache Method
Establish default MeasurementKey cache.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void EstablishDefaultCache(
    IDbConnection connection,
    Type adapterType,
    string measurementTable = "ActiveMeasurement"
)
Public Shared Sub EstablishDefaultCache (
    connection As IDbConnection,
    adapterType As Type,
    Optional measurementTable As String = "ActiveMeasurement"
)
static member EstablishDefaultCache :
        connection : IDbConnection *
        adapterType : Type *
        ?measurementTable : string
(* Defaults:
        let _measurementTable = defaultArg measurementTable "ActiveMeasurement"
*)
-> unit

GSF.TimeSeries.MeasurementKey.EstablishDefaultCache = function(connection, adapterType, measurementTable);
public:
static void EstablishDefaultCache(
    IDbConnection^ connection,
    Type^ adapterType,
    String^ measurementTable = L"ActiveMeasurement"
)

Parameters

connection
Type: System.DataIDbConnection
The database connection.
adapterType
Type: SystemType
The database adapter type.
measurementTable (Optional)
Type: SystemString
Measurement table name used to load measurement key cache.
Remarks
Source tables are expected to have at least the following fields:
Copy
ID          NVARCHAR    Measurement key formatted as: ArchiveSource:PointID
SignalID    GUID        Unique identification for measurement
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.GetHashCode Method

Grid Solutions Framework MeasurementKeyGetHashCode Method
Serves as a hash function for the current MeasurementKey.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current MeasurementKey.
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.LookUpBySignalID Method

Grid Solutions Framework MeasurementKeyLookUpBySignalID Method
Looks up the measurement key associated with the given signal ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey LookUpBySignalID(
    Guid signalID
)
Public Shared Function LookUpBySignalID (
    signalID As Guid
) As MeasurementKey
static member LookUpBySignalID :
        signalID : Guid -> MeasurementKey

GSF.TimeSeries.MeasurementKey.LookUpBySignalID = function(signalID);
public:
static MeasurementKey^ LookUpBySignalID(
    Guid signalID
)

Parameters

signalID
Type: SystemGuid
The signal ID of the measurement key.

Return Value

Type: MeasurementKey
The measurement key associated with the given signal ID.
Remarks
If no measurement key is found with the given signal ID, this method returns Undefined.
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.LookUpBySource Method

Grid Solutions Framework MeasurementKeyLookUpBySource Method
Looks up the measurement key associated with the given source and ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey LookUpBySource(
    string source,
    uint id
)
Public Shared Function LookUpBySource (
    source As String,
    id As UInteger
) As MeasurementKey
static member LookUpBySource :
        source : string *
        id : uint32 -> MeasurementKey

GSF.TimeSeries.MeasurementKey.LookUpBySource = function(source, id);
public:
static MeasurementKey^ LookUpBySource(
    String^ source,
    unsigned int id
)

Parameters

source
Type: SystemString
The source of the signal.
id
Type: SystemUInt32
The source-specific unique integer identifier.

Return Value

Type: MeasurementKey
The measurement key associated with the given source and ID.
Remarks
If no measurement key is found with the given source and ID, this method returns Undefined.
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.LookUpOrCreate Method

Grid Solutions Framework MeasurementKeyLookUpOrCreate Method
Overload List
Name | Description
LookUpOrCreate(String) | Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the parsed source and ID.
LookUpOrCreate(Guid, String) | Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID and the parsed source, and ID.
LookUpOrCreate(String, UInt32) | Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the given source and ID.
LookUpOrCreate(Guid, String, UInt32) | Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID, source, and ID.
Top
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.LookUpOrCreate Method (String)

Grid Solutions Framework MeasurementKeyLookUpOrCreate Method (String)
Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the parsed source and ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey LookUpOrCreate(
    string value
)
Public Shared Function LookUpOrCreate (
    value As String
) As MeasurementKey
static member LookUpOrCreate :
        value : string -> MeasurementKey

GSF.TimeSeries.MeasurementKey.LookUpOrCreate = function(value);
public:
static MeasurementKey^ LookUpOrCreate(
    String^ value
)

Parameters

value
Type: SystemString
A string representation of the MeasurementKey.

Return Value

Type: MeasurementKey
If the lookup succeeds, an existing measurement key with a matching signalID. If creation succeeds, a new measurement key with matching signal ID, source, and ID. Otherwise, Undefined.
See Also

Reference

MeasurementKey Class
LookUpOrCreate Overload
GSF.TimeSeries Namespace


MeasurementKey.LookUpOrCreate Method (Guid, String)

Grid Solutions Framework MeasurementKeyLookUpOrCreate Method (Guid, String)
Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID and the parsed source, and ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey LookUpOrCreate(
    Guid signalID,
    string value
)
Public Shared Function LookUpOrCreate (
    signalID As Guid,
    value As String
) As MeasurementKey
static member LookUpOrCreate :
        signalID : Guid *
        value : string -> MeasurementKey

GSF.TimeSeries.MeasurementKey.LookUpOrCreate = function(signalID, value);
public:
static MeasurementKey^ LookUpOrCreate(
    Guid signalID,
    String^ value
)

Parameters

signalID
Type: SystemGuid
The signal ID of the key to be looked up.
value
Type: SystemString
A string representation of the MeasurementKey.

Return Value

Type: MeasurementKey
If the lookup succeeds, an existing measurement key with a matching signalID. If creation succeeds, a new measurement key with matching signal ID, source, and ID. Otherwise, Undefined.
See Also

Reference

MeasurementKey Class
LookUpOrCreate Overload
GSF.TimeSeries Namespace


MeasurementKey.LookUpOrCreate Method (String, UInt32)

Grid Solutions Framework MeasurementKeyLookUpOrCreate Method (String, UInt32)
Performs a lookup by source and, failing that, attempts to create the key using a newly generated signal ID and the given source and ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey LookUpOrCreate(
    string source,
    uint id
)
Public Shared Function LookUpOrCreate (
    source As String,
    id As UInteger
) As MeasurementKey
static member LookUpOrCreate :
        source : string *
        id : uint32 -> MeasurementKey

GSF.TimeSeries.MeasurementKey.LookUpOrCreate = function(source, id);
public:
static MeasurementKey^ LookUpOrCreate(
    String^ source,
    unsigned int id
)

Parameters

source
Type: SystemString
The source to use for the key if the lookup fails.
id
Type: SystemUInt32
The ID to use for the key if the lookup fails.

Return Value

Type: MeasurementKey
If the lookup succeeds, an existing measurement key with a matching signalID. If creation succeeds, a new measurement key with matching signal ID, source, and ID. Otherwise, Undefined.
See Also

Reference

MeasurementKey Class
LookUpOrCreate Overload
GSF.TimeSeries Namespace


MeasurementKey.LookUpOrCreate Method (Guid, String, UInt32)

Grid Solutions Framework MeasurementKeyLookUpOrCreate Method (Guid, String, UInt32)
Performs a lookup by signal ID and, failing that, attempts to create the key using the given signal ID, source, and ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey LookUpOrCreate(
    Guid signalID,
    string source,
    uint id
)
Public Shared Function LookUpOrCreate (
    signalID As Guid,
    source As String,
    id As UInteger
) As MeasurementKey
static member LookUpOrCreate :
        signalID : Guid *
        source : string *
        id : uint32 -> MeasurementKey

GSF.TimeSeries.MeasurementKey.LookUpOrCreate = function(signalID, source, id);
public:
static MeasurementKey^ LookUpOrCreate(
    Guid signalID,
    String^ source,
    unsigned int id
)

Parameters

signalID
Type: SystemGuid
The signal ID of the key to be looked up.
source
Type: SystemString
The source to use for the key if the lookup fails.
id
Type: SystemUInt32
The ID to use for the key if the lookup fails.

Return Value

Type: MeasurementKey
If the lookup succeeds, an existing measurement key with a matching signalID. If creation succeeds, a new measurement key with matching signal ID, source, and ID. Otherwise, Undefined.
See Also

Reference

MeasurementKey Class
LookUpOrCreate Overload
GSF.TimeSeries Namespace


MeasurementKey.Parse Method

Grid Solutions Framework MeasurementKeyParse Method
Converts the string representation of a MeasurementKey into its value equivalent.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey Parse(
    string value
)
Public Shared Function Parse (
    value As String
) As MeasurementKey
static member Parse :
        value : string -> MeasurementKey

GSF.TimeSeries.MeasurementKey.Parse = function(value);
public:
static MeasurementKey^ Parse(
    String^ value
)

Parameters

value
Type: SystemString
A string representing the MeasurementKey to convert.

Return Value

Type: MeasurementKey
A MeasurementKey value equivalent the representation contained in value.
Exceptions
Exception | Condition
FormatException | The value is not in the correct format for a MeasurementKey value.
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.ToString Method

Grid Solutions Framework MeasurementKeyToString Method
Returns a String that represents the current MeasurementKey.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current MeasurementKey.
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.TryCreateOrUpdate Method

Grid Solutions Framework MeasurementKeyTryCreateOrUpdate Method
Overload List
Name | Description
TryCreateOrUpdate(Guid, String, MeasurementKey) | Constructs a new MeasurementKey given the specified parameters.
TryCreateOrUpdate(Guid, String, UInt32, MeasurementKey) | Constructs a new MeasurementKey given the specified parameters.
Top
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.TryCreateOrUpdate Method (Guid, String, MeasurementKey)

Grid Solutions Framework MeasurementKeyTryCreateOrUpdate Method (Guid, String, MeasurementKey)
Constructs a new MeasurementKey given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryCreateOrUpdate(
    Guid signalID,
    string value,
    out MeasurementKey key
)
Public Shared Function TryCreateOrUpdate (
    signalID As Guid,
    value As String,
    <OutAttribute> ByRef key As MeasurementKey
) As Boolean
static member TryCreateOrUpdate :
        signalID : Guid *
        value : string *
        key : MeasurementKey byref -> bool

GSF.TimeSeries.MeasurementKey.TryCreateOrUpdate = function(signalID, value, key);
public:
static bool TryCreateOrUpdate(
    Guid signalID,
    String^ value,
    [OutAttribute] MeasurementKey^% key
)

Parameters

signalID
Type: SystemGuid
Guid ID of associated signal, if defined.
value
Type: SystemString
A string representation of the MeasurementKey.
key
Type: GSF.TimeSeriesMeasurementKey
The measurement key that was created or updated or Undefined.

Return Value

Type: Boolean
True if the measurement key was successfully created or updated, false otherwise.
Exceptions
Exception | Condition
ArgumentException | signalID cannot be empty.
ArgumentNullException | Measurement key Source cannot be null.
See Also

Reference

MeasurementKey Class
TryCreateOrUpdate Overload
GSF.TimeSeries Namespace


MeasurementKey.TryCreateOrUpdate Method (Guid, String, UInt32, MeasurementKey)

Grid Solutions Framework MeasurementKeyTryCreateOrUpdate Method (Guid, String, UInt32, MeasurementKey)
Constructs a new MeasurementKey given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryCreateOrUpdate(
    Guid signalID,
    string source,
    uint id,
    out MeasurementKey key
)
Public Shared Function TryCreateOrUpdate (
    signalID As Guid,
    source As String,
    id As UInteger,
    <OutAttribute> ByRef key As MeasurementKey
) As Boolean
static member TryCreateOrUpdate :
        signalID : Guid *
        source : string *
        id : uint32 *
        key : MeasurementKey byref -> bool

GSF.TimeSeries.MeasurementKey.TryCreateOrUpdate = function(signalID, source, id, key);
public:
static bool TryCreateOrUpdate(
    Guid signalID,
    String^ source,
    unsigned int id,
    [OutAttribute] MeasurementKey^% key
)

Parameters

signalID
Type: SystemGuid
Guid ID of associated signal, if defined.
source
Type: SystemString
Source of the measurement that this MeasurementKey represents (e.g., name of archive).
id
Type: SystemUInt32
Numeric ID of the measurement that this MeasurementKey represents.
key
Type: GSF.TimeSeriesMeasurementKey
The measurement key that was created or updated or Undefined.

Return Value

Type: Boolean
True if the measurement key was successfully created or updated, false otherwise.
Exceptions
Exception | Condition
ArgumentException | signalID cannot be empty.
ArgumentNullException | source cannot be null.
See Also

Reference

MeasurementKey Class
TryCreateOrUpdate Overload
GSF.TimeSeries Namespace


MeasurementKey.TryParse Method

Grid Solutions Framework MeasurementKeyTryParse Method
Attempts to convert the string representation of a MeasurementKey into its value equivalent.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string value,
    out MeasurementKey key
)
Public Shared Function TryParse (
    value As String,
    <OutAttribute> ByRef key As MeasurementKey
) As Boolean
static member TryParse :
        value : string *
        key : MeasurementKey byref -> bool

GSF.TimeSeries.MeasurementKey.TryParse = function(value, key);
public:
static bool TryParse(
    String^ value,
    [OutAttribute] MeasurementKey^% key
)

Parameters

value
Type: SystemString
A string representing the MeasurementKey to convert.
key
Type: GSF.TimeSeriesMeasurementKey
Output MeasurementKey in which to stored parsed value.

Return Value

Type: Boolean
A true if MeasurementKeyrepresentation contained in value could be parsed; otherwise false.
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey Properties

Grid Solutions Framework MeasurementKey Properties

The MeasurementKey type exposes the following members.

Properties
 | Name | Description
Public property | ID | Gets or sets the numeric ID of this MeasurementKey.
Public property | SignalID | Gets or sets Guid ID of signal associated with this MeasurementKey.
Public property | Source | Gets or sets the source of this MeasurementKey.
Top
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.ID Property

Grid Solutions Framework MeasurementKeyID Property
Gets or sets the numeric ID of this MeasurementKey.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint ID { get; }
Public ReadOnly Property ID As UInteger
    Get
member ID : uint32 with get

function get_ID();

public:
property unsigned int ID {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.SignalID Property

Grid Solutions Framework MeasurementKeySignalID Property
Gets or sets Guid ID of signal associated with this MeasurementKey.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid SignalID { get; }
Public ReadOnly Property SignalID As Guid
    Get
member SignalID : Guid with get

function get_SignalID();

public:
property Guid SignalID {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementKey.Source Property

Grid Solutions Framework MeasurementKeySource Property
Gets or sets the source of this MeasurementKey.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Source { get; }
Public ReadOnly Property Source As String
    Get
member Source : string with get

function get_Source();

public:
property String^ Source {
    String^ get ();
}

Property Value

Type: String
Remarks
This value is typically used to track the archive name in which the measurement, that this MeasurementKey represents, is stored.
See Also

Reference

MeasurementKey Class
GSF.TimeSeries Namespace


MeasurementStateFlags Enumeration

Grid Solutions Framework MeasurementStateFlags Enumeration
Measurement state flags.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum MeasurementStateFlags
<FlagsAttribute>
Public Enumeration MeasurementStateFlags
[<FlagsAttribute>]
type MeasurementStateFlags
GSF.TimeSeries.MeasurementStateFlags = function();
GSF.TimeSeries.MeasurementStateFlags.createEnum('GSF.TimeSeries.MeasurementStateFlags', true);
[FlagsAttribute]
public enum class MeasurementStateFlags
Members
Member name | Value | Description
Normal | 0 | Defines normal state.
BadData | 1 | Defines bad data state.
SuspectData | 2 | Defines suspect data state.
OverRangeError | 4 | Defines over range error, i.e., unreasonable high value.
UnderRangeError | 8 | Defines under range error, i.e., unreasonable low value.
AlarmHigh | 16 | Defines alarm for high value.
AlarmLow | 32 | Defines alarm for low value.
WarningHigh | 64 | Defines warning for high value.
WarningLow | 128 | Defines warning for low value.
FlatlineAlarm | 256 | Defines alarm for flat-lined value, i.e., latched value test alarm.
ComparisonAlarm | 512 | Defines comparison alarm, i.e., outside threshold of comparison with a real-time value.
ROCAlarm | 1024 | Defines rate-of-change alarm.
ReceivedAsBad | 2048 | Defines bad value received.
CalcuatedValue | 4096 | Defines calculated value state.
CalculationError | 8192 | Defines calculation error with the value.
CalculationWarning | 16384 | Defines calculation warning with the value.
ReservedQualityFlag | 32768 | Defines reserved quality flag.
BadTime | 65536 | Defines bad time state.
SuspectTime | 131072 | Defines suspect time state.
LateTimeAlarm | 262144 | Defines late time alarm.
FutureTimeAlarm | 524288 | Defines future time alarm.
UpSampled | 1048576 | Defines up-sampled state.
DownSampled | 2097152 | Defines down-sampled state.
DiscardedValue | 4194304 | Defines discarded value state.
ReservedTimeFlag | 8388608 | Defines reserved time flag.
UserDefinedFlag1 | 16777216 | Defines user defined flag 1.
UserDefinedFlag2 | 33554432 | Defines user defined flag 2.
UserDefinedFlag3 | 67108864 | Defines user defined flag 3.
UserDefinedFlag4 | 134217728 | Defines user defined flag 4.
UserDefinedFlag5 | 268435456 | Defines user defined flag 5.
SystemError | 536870912 | Defines system error state.
SystemWarning | 1073741824 | Defines system warning state.
MeasurementError | 2147483648 | Defines measurement error flag.
See Also

Reference

GSF.TimeSeries Namespace


MeasurementValueFilterFunction Delegate

Grid Solutions Framework MeasurementValueFilterFunction Delegate
Method signature for function used to apply a value filter over a sequence of IMeasurement values.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate double MeasurementValueFilterFunction(
    IEnumerable<IMeasurement> source
)
Public Delegate Function MeasurementValueFilterFunction (
    source As IEnumerable(Of IMeasurement)
) As Double
type MeasurementValueFilterFunction =
    delegate of
        source : IEnumerable<IMeasurement> -> float
function(source);
public delegate double MeasurementValueFilterFunction(
    IEnumerable<IMeasurement^>^ source
)

Parameters

source
Type: System.Collections.GenericIEnumerable IMeasurement
Sequence of IMeasurement values over which to apply filter.

Return Value

Type: Double
Result of filter applied to sequence of IMeasurement values.
See Also

Reference

GSF.TimeSeries Namespace


PrecisionInputTimer Class

Grid Solutions Framework PrecisionInputTimer Class
Precision input timer.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesPrecisionInputTimer

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class PrecisionInputTimer : IDisposable
Public NotInheritable Class PrecisionInputTimer
    Implements IDisposable
[<SealedAttribute>]
type PrecisionInputTimer =
    class
        interface IDisposable
    end
GSF.TimeSeries.PrecisionInputTimer = function();

Type.createClass(
    'GSF.TimeSeries.PrecisionInputTimer',
    null,
    IDisposable);
public ref class PrecisionInputTimer sealed : IDisposable

The PrecisionInputTimer type exposes the following members.

Methods
 | Name | Description
Public method | AddReference | Adds a reference to this PrecisionInputTimer.
 | Attach | Attach to a PrecisionInputTimer for the specified framesPerSecond.
 | Detach | Detach from the PrecisionInputTimer.
Public method | Dispose | Releases all the resources used by the PrecisionInputTimer object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveReference | Removes a reference to this PrecisionInputTimer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ExceptionHandler | Gets or sets function used to handle exceptions.
Public property | FrameMilliseconds | Gets array of frame millisecond times for this PrecisionInputTimer.
Public property | FramesPerSecond | Gets frames per second for this PrecisionInputTimer.
Public property | FrameWaitHandle | Gets a reference to the frame wait handle.
Public property | LastFrameTime | Gets time of last frame, in ticks.
Public property | ReferenceCount | Gets reference count for this PrecisionInputTimer.
Public property | Resynchronizations | Gets number of resynchronizations that have occurred for this PrecisionInputTimer.
Top
Remarks
This class is used to create highly accurate simulated data inputs aligned to the local clock.
One static instance of this internal class is created per encountered frame rate.
See Also

Reference

GSF.TimeSeries Namespace


PrecisionInputTimer Methods

Grid Solutions Framework PrecisionInputTimer Methods

The PrecisionInputTimer type exposes the following members.

Methods
 | Name | Description
Public method | AddReference | Adds a reference to this PrecisionInputTimer.
 | Attach | Attach to a PrecisionInputTimer for the specified framesPerSecond.
 | Detach | Detach from the PrecisionInputTimer.
Public method | Dispose | Releases all the resources used by the PrecisionInputTimer object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | RemoveReference | Removes a reference to this PrecisionInputTimer.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.AddReference Method

Grid Solutions Framework PrecisionInputTimerAddReference Method
Adds a reference to this PrecisionInputTimer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddReference()
Public Sub AddReference
member AddReference : unit -> unit

function AddReference();
public:
void AddReference()
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.Attach Method

Grid Solutions Framework PrecisionInputTimerAttach Method
Attach to a PrecisionInputTimer for the specified framesPerSecond.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static PrecisionInputTimer Attach(
    int framesPerSecond,
    Action<Exception> exceptionHandler = null
)
Public Shared Function Attach (
    framesPerSecond As Integer,
    Optional exceptionHandler As Action(Of Exception) = Nothing
) As PrecisionInputTimer
static member Attach :
        framesPerSecond : int *
        ?exceptionHandler : Action<Exception>
(* Defaults:
        let _exceptionHandler = defaultArg exceptionHandler null
*)
-> PrecisionInputTimer

GSF.TimeSeries.PrecisionInputTimer.Attach = function(framesPerSecond, exceptionHandler);
public:
static PrecisionInputTimer^ Attach(
    int framesPerSecond,
    Action<Exception^>^ exceptionHandler = nullptr
)

Parameters

framesPerSecond
Type: SystemInt32
Desired frames per second for the input timer.
exceptionHandler (Optional)
Type: SystemAction Exception
Optional delegate to handle exception reporting from the timer.

Return Value

Type: PrecisionInputTimer
A PrecisionInputTimer that can be used for the specified framesPerSecond.
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.Detach Method

Grid Solutions Framework PrecisionInputTimerDetach Method
Detach from the PrecisionInputTimer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Detach(
    ref PrecisionInputTimer timer
)
Public Shared Sub Detach (
    ByRef timer As PrecisionInputTimer
)
static member Detach :
        timer : PrecisionInputTimer byref -> unit

GSF.TimeSeries.PrecisionInputTimer.Detach = function(timer);
public:
static void Detach(
    PrecisionInputTimer^% timer
)

Parameters

timer
Type: GSF.TimeSeriesPrecisionInputTimer
Timer instance to detach from.
Remarks
Timer reference will be set to null after detach.
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.Dispose Method

Grid Solutions Framework PrecisionInputTimerDispose Method
Releases all the resources used by the PrecisionInputTimer object.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.RemoveReference Method

Grid Solutions Framework PrecisionInputTimerRemoveReference Method
Removes a reference to this PrecisionInputTimer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void RemoveReference()
Public Sub RemoveReference
member RemoveReference : unit -> unit

function RemoveReference();
public:
void RemoveReference()
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer Properties

Grid Solutions Framework PrecisionInputTimer Properties

The PrecisionInputTimer type exposes the following members.

Properties
 | Name | Description
Public property | ExceptionHandler | Gets or sets function used to handle exceptions.
Public property | FrameMilliseconds | Gets array of frame millisecond times for this PrecisionInputTimer.
Public property | FramesPerSecond | Gets frames per second for this PrecisionInputTimer.
Public property | FrameWaitHandle | Gets a reference to the frame wait handle.
Public property | LastFrameTime | Gets time of last frame, in ticks.
Public property | ReferenceCount | Gets reference count for this PrecisionInputTimer.
Public property | Resynchronizations | Gets number of resynchronizations that have occurred for this PrecisionInputTimer.
Top
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.ExceptionHandler Property

Grid Solutions Framework PrecisionInputTimerExceptionHandler Property
Gets or sets function used to handle exceptions.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Action<Exception> ExceptionHandler { get; set; }
Public Property ExceptionHandler As Action(Of Exception)
    Get
    Set
member ExceptionHandler : Action<Exception> with get, set

function get_ExceptionHandler();
function set_ExceptionHandler(value);
public:
property Action<Exception^>^ ExceptionHandler {
    Action<Exception^>^ get ();
    void set (Action<Exception^>^ value);
}

Property Value

Type: Action Exception
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.FrameMilliseconds Property

Grid Solutions Framework PrecisionInputTimerFrameMilliseconds Property
Gets array of frame millisecond times for this PrecisionInputTimer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int[] FrameMilliseconds { get; }
Public ReadOnly Property FrameMilliseconds As Integer()
    Get
member FrameMilliseconds : int[] with get

function get_FrameMilliseconds();

public:
property array<int>^ FrameMilliseconds {
    array<int>^ get ();
}

Property Value

Type: Int32
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.FramesPerSecond Property

Grid Solutions Framework PrecisionInputTimerFramesPerSecond Property
Gets frames per second for this PrecisionInputTimer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int FramesPerSecond { get; }
Public ReadOnly Property FramesPerSecond As Integer
    Get
member FramesPerSecond : int with get

function get_FramesPerSecond();

public:
property int FramesPerSecond {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.FrameWaitHandle Property

Grid Solutions Framework PrecisionInputTimerFrameWaitHandle Property
Gets a reference to the frame wait handle.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ManualResetEventSlim FrameWaitHandle { get; }
Public ReadOnly Property FrameWaitHandle As ManualResetEventSlim
    Get
member FrameWaitHandle : ManualResetEventSlim with get

function get_FrameWaitHandle();

public:
property ManualResetEventSlim^ FrameWaitHandle {
    ManualResetEventSlim^ get ();
}

Property Value

Type: ManualResetEventSlim
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.LastFrameTime Property

Grid Solutions Framework PrecisionInputTimerLastFrameTime Property
Gets time of last frame, in ticks.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long LastFrameTime { get; }
Public ReadOnly Property LastFrameTime As Long
    Get
member LastFrameTime : int64 with get

function get_LastFrameTime();

public:
property long long LastFrameTime {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.ReferenceCount Property

Grid Solutions Framework PrecisionInputTimerReferenceCount Property
Gets reference count for this PrecisionInputTimer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ReferenceCount { get; }
Public ReadOnly Property ReferenceCount As Integer
    Get
member ReferenceCount : int with get

function get_ReferenceCount();

public:
property int ReferenceCount {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


PrecisionInputTimer.Resynchronizations Property

Grid Solutions Framework PrecisionInputTimerResynchronizations Property
Gets number of resynchronizations that have occurred for this PrecisionInputTimer.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long Resynchronizations { get; }
Public ReadOnly Property Resynchronizations As Long
    Get
member Resynchronizations : int64 with get

function get_Resynchronizations();

public:
property long long Resynchronizations {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

PrecisionInputTimer Class
GSF.TimeSeries Namespace


ServiceClientBase Class

Grid Solutions Framework ServiceClientBase Class
Represents a client that can remotely access the time-series framework service host.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesServiceClientBase

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ServiceClientBase : IDisposable
Public Class ServiceClientBase
    Implements IDisposable
type ServiceClientBase =
    class
        interface IDisposable
    end
GSF.TimeSeries.ServiceClientBase = function();

Type.createClass(
    'GSF.TimeSeries.ServiceClientBase',
    null,
    IDisposable);
public ref class ServiceClientBase : IDisposable

The ServiceClientBase type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceClientBase | Creates a new instance of the ServiceClientBase class.
Top
Methods
 | Name | Description
Protected method | ClientHelper_ReceivedServiceResponse | Client helper service response reception handler.
Protected method | ClientHelper_ReceivedServiceUpdate | Client helper service update reception handler.
Protected method | ClientHelper_TelnetSessionEstablished | Client helper telnet session established handler.
Protected method | ClientHelper_TelnetSessionTerminated | Client helper telnet session terminated handler.
Public method | Dispose | Releases all the resources used by the ServiceClientBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceClientBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ServiceClientBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the remoting client, client helper, and error logger.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Handles service start event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.TimeSeries Namespace


ServiceClientBase Constructor

Grid Solutions Framework ServiceClientBase Constructor
Creates a new instance of the ServiceClientBase class.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceClientBase()
Public Sub New
new : unit -> ServiceClientBase
GSF.TimeSeries.ServiceClientBase = function();
public:
ServiceClientBase()
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase Methods

Grid Solutions Framework ServiceClientBase Methods

The ServiceClientBase type exposes the following members.

Methods
 | Name | Description
Protected method | ClientHelper_ReceivedServiceResponse | Client helper service response reception handler.
Protected method | ClientHelper_ReceivedServiceUpdate | Client helper service update reception handler.
Protected method | ClientHelper_TelnetSessionEstablished | Client helper telnet session established handler.
Protected method | ClientHelper_TelnetSessionTerminated | Client helper telnet session terminated handler.
Public method | Dispose | Releases all the resources used by the ServiceClientBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceClientBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ServiceClientBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the remoting client, client helper, and error logger.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Start | Handles service start event.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.ClientHelper_ReceivedServiceResponse Method

Grid Solutions Framework ServiceClientBaseClientHelper_ReceivedServiceResponse Method
Client helper service response reception handler.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ClientHelper_ReceivedServiceResponse(
    Object sender,
    EventArgs<ServiceResponse> e
)
Protected Overridable Sub ClientHelper_ReceivedServiceResponse (
    sender As Object,
    e As EventArgs(Of ServiceResponse)
)
abstract ClientHelper_ReceivedServiceResponse :
        sender : Object *
        e : EventArgs<ServiceResponse> -> unit
override ClientHelper_ReceivedServiceResponse :
        sender : Object *
        e : EventArgs<ServiceResponse> -> unit
function ClientHelper_ReceivedServiceResponse(sender, e);
protected:
virtual void ClientHelper_ReceivedServiceResponse(
    Object^ sender,
    EventArgs<ServiceResponse^>^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: GSFEventArgs ServiceResponse
Event argument containing the service response.
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.ClientHelper_ReceivedServiceUpdate Method

Grid Solutions Framework ServiceClientBaseClientHelper_ReceivedServiceUpdate Method
Client helper service update reception handler.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ClientHelper_ReceivedServiceUpdate(
    Object sender,
    EventArgs<UpdateType, string> e
)
Protected Overridable Sub ClientHelper_ReceivedServiceUpdate (
    sender As Object,
    e As EventArgs(Of UpdateType, String)
)
abstract ClientHelper_ReceivedServiceUpdate :
        sender : Object *
        e : EventArgs<UpdateType, string> -> unit
override ClientHelper_ReceivedServiceUpdate :
        sender : Object *
        e : EventArgs<UpdateType, string> -> unit
function ClientHelper_ReceivedServiceUpdate(sender, e);
protected:
virtual void ClientHelper_ReceivedServiceUpdate(
    Object^ sender,
    EventArgs<UpdateType, String^>^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: GSFEventArgs UpdateType, String
Event argument containing update type and associated message data.
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.ClientHelper_TelnetSessionEstablished Method

Grid Solutions Framework ServiceClientBaseClientHelper_TelnetSessionEstablished Method
Client helper telnet session established handler.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ClientHelper_TelnetSessionEstablished(
    Object sender,
    EventArgs e
)
Protected Overridable Sub ClientHelper_TelnetSessionEstablished (
    sender As Object,
    e As EventArgs
)
abstract ClientHelper_TelnetSessionEstablished :
        sender : Object *
        e : EventArgs -> unit
override ClientHelper_TelnetSessionEstablished :
        sender : Object *
        e : EventArgs -> unit
function ClientHelper_TelnetSessionEstablished(sender, e);
protected:
virtual void ClientHelper_TelnetSessionEstablished(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: SystemEventArgs
Event arguments, if any.
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.ClientHelper_TelnetSessionTerminated Method

Grid Solutions Framework ServiceClientBaseClientHelper_TelnetSessionTerminated Method
Client helper telnet session terminated handler.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ClientHelper_TelnetSessionTerminated(
    Object sender,
    EventArgs e
)
Protected Overridable Sub ClientHelper_TelnetSessionTerminated (
    sender As Object,
    e As EventArgs
)
abstract ClientHelper_TelnetSessionTerminated :
        sender : Object *
        e : EventArgs -> unit
override ClientHelper_TelnetSessionTerminated :
        sender : Object *
        e : EventArgs -> unit
function ClientHelper_TelnetSessionTerminated(sender, e);
protected:
virtual void ClientHelper_TelnetSessionTerminated(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: SystemEventArgs
Event arguments, if any.
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.Dispose Method

Grid Solutions Framework ServiceClientBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ServiceClientBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceClientBase object and optionally releases the managed resources.
Top
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.Dispose Method

Grid Solutions Framework ServiceClientBaseDispose Method
Releases all the resources used by the ServiceClientBase object.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ServiceClientBase Class
Dispose Overload
GSF.TimeSeries Namespace


ServiceClientBase.Dispose Method (Boolean)

Grid Solutions Framework ServiceClientBaseDispose Method (Boolean)
Releases the unmanaged resources used by the ServiceClientBase object and optionally releases the managed resources.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ServiceClientBase Class
Dispose Overload
GSF.TimeSeries Namespace


ServiceClientBase.Finalize Method

Grid Solutions Framework ServiceClientBaseFinalize Method
Releases the unmanaged resources before the ServiceClientBase object is reclaimed by GC.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.Initialize Method

Grid Solutions Framework ServiceClientBaseInitialize Method
Initializes the remoting client, client helper, and error logger.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
member Initialize : unit -> unit

function Initialize();
public:
void Initialize()
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceClientBase.Start Method

Grid Solutions Framework ServiceClientBaseStart Method
Handles service start event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Start(
    string[] args
)
Public Overridable Sub Start (
    args As String()
)
abstract Start :
        args : string[] -> unit
override Start :
        args : string[] -> unit
function Start(args);
public:
virtual void Start(
    array<String^>^ args
)

Parameters

args
Type: SystemString
Service start arguments.
See Also

Reference

ServiceClientBase Class
GSF.TimeSeries Namespace


ServiceHostBase Class

Grid Solutions Framework ServiceHostBase Class
Represents the time-series framework service host.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.ServiceProcessServiceBase
GSF.TimeSeriesServiceHostBase

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ServiceHostBase : ServiceBase
Public Class ServiceHostBase
    Inherits ServiceBase
type ServiceHostBase =
    class
        inherit ServiceBase
    end
GSF.TimeSeries.ServiceHostBase = function();

Type.createClass(
    'GSF.TimeSeries.ServiceHostBase',
    ServiceBase);
public ref class ServiceHostBase : public ServiceBase

The ServiceHostBase type exposes the following members.

Constructors
 | Name | Description
Public method | ServiceHostBase | Creates a new ServiceHostBase.
Public method | ServiceHostBase(IContainer) | Creates a new ServiceHostBase from specified parameters.
Top
Methods
 | Name | Description
Protected method | ActionRequestHandler | Generic adapter request handler.
Protected method | AuthenticateRequestHandler | Attempts to authenticate or re-authenticate to network shares.
Protected method | CacheCurrentConfiguration | Caches the current system configuration.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DisplayResponseMessage | Displays a response message to client requester.
Protected method | DisplayStatusMessage(String, UpdateType) | Displays a broadcast message to all subscribed clients.
Protected method | DisplayStatusMessage(String, UpdateType, Object) | Displays a broadcast message to all subscribed clients.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceHostBase object and optionally releases the managed resources. (Overrides ServiceBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetRequestedAdapter(ClientRequestInfo) | Gets requested IAdapter.
Protected method | GetRequestedAdapter(ClientRequestInfo, IAdapterCollection) | Gets requested IAdapter and its containing IAdapterCollection.
Protected method | GetRequestedCollection | Gets requested IAdapterCollection.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HealthMonitorProcessHandler | Event handler for scheduled health monitor display.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeRequestHandler | Performs initialization or reinitialization of specified adapter or collection.
Public method | InitializeServiceHelper | Initializes the service helper.
Protected method | InvokeRequestHandler | Invokes specified adapter command.
Protected method | ListCommandsRequestHandler | Lists possible commands of specified adapter.
Protected method | ListRequestHandler | Displays status of specified adapter or collection.
Protected method | LogEventRequestHandler | Sends remote entry for logging.
Protected method | LogException | Logs an exception to the service helper ErrorLogger.
Protected method | LogExceptionHandler | Event handler for processing exceptions encountered while writing entries to a log file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnContinue | Handles service continue event. (Overrides ServiceBaseOnContinue.)
Protected method | OnCustomCommand | When implemented in a derived class, OnCustomCommand(Int32) executes when the Service Control Manager (SCM) passes a custom command to the service. Specifies actions to take when a command with the specified parameter value occurs. (Inherited from ServiceBase.)
Protected method | OnPause | Handles service pause event. (Overrides ServiceBaseOnPause.)
Protected method | OnPowerEvent | When implemented in a derived class, executes when the computer's power status has changed. This applies to laptop computers when they go into suspended mode, which is not the same as a system shutdown. (Inherited from ServiceBase.)
Protected method | OnSessionChange | Executes when a change event is received from a Terminal Server session. (Inherited from ServiceBase.)
Protected method | OnShutdown | Handles service shut down event. (Overrides ServiceBaseOnShutdown.)
Protected method | OnStart | Handles service start event. (Overrides ServiceBaseOnStart(String).)
Protected method | OnStop | Handles service stop event. (Overrides ServiceBaseOnStop.)
Protected method | RefreshRoutesRequestHandler | Recalculates routing tables.
Protected method | ReloadConfigRequestHandler | Manually reloads system configuration.
Protected method | ReportingProcessHandler | Event handler for scheduled reporting services.
Public method | RequestAdditionalTime | Requests additional time for a pending operation. (Inherited from ServiceBase.)
Protected method | RestartServiceHandler | Attempts to restart the hose service.
Protected method | SendResponse(ClientRequestInfo, Boolean) | Sends an actionable response to client.
Protected method | SendResponse(ClientRequestInfo, Boolean, String, Object) | Sends an actionable response to client with a formatted message.
Protected method | SendResponseWithAttachment | Sends an actionable response to client with a formatted message and attachment.
Public method | ServiceMainCallback | Registers the command handler and starts the service. (Inherited from ServiceBase.)
Protected method | ServiceStartedHandler | Event handler for service started operation.
Protected method | ServiceStartingHandler | Event handler for service starting operations.
Protected method | ServiceStoppingHandler | Event handler for service stopping operation.
Protected method | StartRequestHandler | Starts specified adapter.
Protected method | StatusExportProcessHandler | Event handler for scheduled adapter status export.
Public method | Stop | Stops the executing service. (Inherited from ServiceBase.)
Protected method | StopRequestHandler | Stops specified adapter.
Protected method | TemporalSupportRequestHandler | Determines support for temporal processing from existing adapters.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | UpdateConfigFileRequestHandler | Updates an option in the configuration file.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | ActionAdapters | Gets reference to the ActionAdapterCollection.
Protected property | AllAdapters | Gets reference to the AllAdaptersCollection.
Public property | AutoLog | Indicates whether to report Start, Stop, Pause, and Continue commands in the event log. (Inherited from ServiceBase.)
Public property | CanHandlePowerEvent | Gets or sets a value indicating whether the service can handle notifications of computer power status changes. (Inherited from ServiceBase.)
Public property | CanHandleSessionChangeEvent | Gets or sets a value that indicates whether the service can handle session change events received from a Terminal Server session. (Inherited from ServiceBase.)
Public property | CanPauseAndContinue | Gets or sets a value indicating whether the service can be paused and resumed. (Inherited from ServiceBase.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CanShutdown | Gets or sets a value indicating whether the service should be notified when the system is shutting down. (Inherited from ServiceBase.)
Public property | CanStop | Gets or sets a value indicating whether the service can be stopped once it has started. (Inherited from ServiceBase.)
Protected property | ConfigurationType | Gets the defined system ConfigurationType.
Protected property | ConsoleApplicationName | Gets the related remote console application name.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DataSource | Gets the currently loaded system configuration DataSet.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | EventLog | Gets an event log you can use to write notification of service command calls, such as Start and Stop, to the Application event log. (Inherited from ServiceBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExitCode | Gets or sets the exit code for the service. (Inherited from ServiceBase.)
Protected property | InputAdapters | Gets reference to the InputAdapterCollection.
Protected property | NodeID | Gets the current node ID.
Protected property | NodeIDQueryString | Gets the current node ID formatted for use in a SQL query string based on ConfigurationType.
Protected property | OutputAdapters | Gets reference to the OutputAdapterCollection.
Protected property | RemotingServer | Gets reference to the TcpServer based remoting server.
Protected property | ServiceHandle | Gets the service control handle for the service. (Inherited from ServiceBase.)
Protected property | ServiceHelper | Gets access to the ServiceHelper.
Public property | ServiceName | Gets or sets the short name used to identify the service to the system. (Inherited from ServiceBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
See Also

Reference

GSF.TimeSeries Namespace


ServiceHostBase Constructor

Grid Solutions Framework ServiceHostBase Constructor
Overload List
 | Name | Description
Public method | ServiceHostBase | Creates a new ServiceHostBase.
Public method | ServiceHostBase(IContainer) | Creates a new ServiceHostBase from specified parameters.
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase Constructor

Grid Solutions Framework ServiceHostBase Constructor
Creates a new ServiceHostBase.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceHostBase()
Public Sub New
new : unit -> ServiceHostBase
GSF.TimeSeries.ServiceHostBase = function();
public:
ServiceHostBase()
See Also

Reference

ServiceHostBase Class
ServiceHostBase Overload
GSF.TimeSeries Namespace


ServiceHostBase Constructor (IContainer)

Grid Solutions Framework ServiceHostBase Constructor (IContainer)
Creates a new ServiceHostBase from specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ServiceHostBase(
    IContainer container
)
Public Sub New (
    container As IContainer
)
new :
        container : IContainer -> ServiceHostBase
GSF.TimeSeries.ServiceHostBase = function(container);
public:
ServiceHostBase(
    IContainer^ container
)

Parameters

container
Type: System.ComponentModelIContainer
Service host IContainer.
See Also

Reference

ServiceHostBase Class
ServiceHostBase Overload
GSF.TimeSeries Namespace


ServiceHostBase Methods

Grid Solutions Framework ServiceHostBase Methods

The ServiceHostBase type exposes the following members.

Methods
 | Name | Description
Protected method | ActionRequestHandler | Generic adapter request handler.
Protected method | AuthenticateRequestHandler | Attempts to authenticate or re-authenticate to network shares.
Protected method | CacheCurrentConfiguration | Caches the current system configuration.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DisplayResponseMessage | Displays a response message to client requester.
Protected method | DisplayStatusMessage(String, UpdateType) | Displays a broadcast message to all subscribed clients.
Protected method | DisplayStatusMessage(String, UpdateType, Object) | Displays a broadcast message to all subscribed clients.
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceHostBase object and optionally releases the managed resources. (Overrides ServiceBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetRequestedAdapter(ClientRequestInfo) | Gets requested IAdapter.
Protected method | GetRequestedAdapter(ClientRequestInfo, IAdapterCollection) | Gets requested IAdapter and its containing IAdapterCollection.
Protected method | GetRequestedCollection | Gets requested IAdapterCollection.
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HealthMonitorProcessHandler | Event handler for scheduled health monitor display.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeRequestHandler | Performs initialization or reinitialization of specified adapter or collection.
Public method | InitializeServiceHelper | Initializes the service helper.
Protected method | InvokeRequestHandler | Invokes specified adapter command.
Protected method | ListCommandsRequestHandler | Lists possible commands of specified adapter.
Protected method | ListRequestHandler | Displays status of specified adapter or collection.
Protected method | LogEventRequestHandler | Sends remote entry for logging.
Protected method | LogException | Logs an exception to the service helper ErrorLogger.
Protected method | LogExceptionHandler | Event handler for processing exceptions encountered while writing entries to a log file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnContinue | Handles service continue event. (Overrides ServiceBaseOnContinue.)
Protected method | OnCustomCommand | When implemented in a derived class, OnCustomCommand(Int32) executes when the Service Control Manager (SCM) passes a custom command to the service. Specifies actions to take when a command with the specified parameter value occurs. (Inherited from ServiceBase.)
Protected method | OnPause | Handles service pause event. (Overrides ServiceBaseOnPause.)
Protected method | OnPowerEvent | When implemented in a derived class, executes when the computer's power status has changed. This applies to laptop computers when they go into suspended mode, which is not the same as a system shutdown. (Inherited from ServiceBase.)
Protected method | OnSessionChange | Executes when a change event is received from a Terminal Server session. (Inherited from ServiceBase.)
Protected method | OnShutdown | Handles service shut down event. (Overrides ServiceBaseOnShutdown.)
Protected method | OnStart | Handles service start event. (Overrides ServiceBaseOnStart(String).)
Protected method | OnStop | Handles service stop event. (Overrides ServiceBaseOnStop.)
Protected method | RefreshRoutesRequestHandler | Recalculates routing tables.
Protected method | ReloadConfigRequestHandler | Manually reloads system configuration.
Protected method | ReportingProcessHandler | Event handler for scheduled reporting services.
Public method | RequestAdditionalTime | Requests additional time for a pending operation. (Inherited from ServiceBase.)
Protected method | RestartServiceHandler | Attempts to restart the hose service.
Protected method | SendResponse(ClientRequestInfo, Boolean) | Sends an actionable response to client.
Protected method | SendResponse(ClientRequestInfo, Boolean, String, Object) | Sends an actionable response to client with a formatted message.
Protected method | SendResponseWithAttachment | Sends an actionable response to client with a formatted message and attachment.
Public method | ServiceMainCallback | Registers the command handler and starts the service. (Inherited from ServiceBase.)
Protected method | ServiceStartedHandler | Event handler for service started operation.
Protected method | ServiceStartingHandler | Event handler for service starting operations.
Protected method | ServiceStoppingHandler | Event handler for service stopping operation.
Protected method | StartRequestHandler | Starts specified adapter.
Protected method | StatusExportProcessHandler | Event handler for scheduled adapter status export.
Public method | Stop | Stops the executing service. (Inherited from ServiceBase.)
Protected method | StopRequestHandler | Stops specified adapter.
Protected method | TemporalSupportRequestHandler | Determines support for temporal processing from existing adapters.
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | UpdateConfigFileRequestHandler | Updates an option in the configuration file.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ActionRequestHandler Method

Grid Solutions Framework ServiceHostBaseActionRequestHandler Method
Generic adapter request handler.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ActionRequestHandler(
    ClientRequestInfo requestInfo,
    Action<IAdapter> adapterAction
)
Protected Overridable Sub ActionRequestHandler (
    requestInfo As ClientRequestInfo,
    adapterAction As Action(Of IAdapter)
)
abstract ActionRequestHandler :
        requestInfo : ClientRequestInfo *
        adapterAction : Action<IAdapter> -> unit
override ActionRequestHandler :
        requestInfo : ClientRequestInfo *
        adapterAction : Action<IAdapter> -> unit
function ActionRequestHandler(requestInfo, adapterAction);
protected:
virtual void ActionRequestHandler(
    ClientRequestInfo^ requestInfo,
    Action<IAdapter^>^ adapterAction
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
adapterAction
Type: SystemAction IAdapter
Action to perform on IAdapter.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.AuthenticateRequestHandler Method

Grid Solutions Framework ServiceHostBaseAuthenticateRequestHandler Method
Attempts to authenticate or re-authenticate to network shares.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void AuthenticateRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub AuthenticateRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract AuthenticateRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override AuthenticateRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function AuthenticateRequestHandler(requestInfo);
protected:
virtual void AuthenticateRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.CacheCurrentConfiguration Method

Grid Solutions Framework ServiceHostBaseCacheCurrentConfiguration Method
Caches the current system configuration.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void CacheCurrentConfiguration(
    DataSet configuration
)
Protected Overridable Sub CacheCurrentConfiguration (
    configuration As DataSet
)
abstract CacheCurrentConfiguration :
        configuration : DataSet -> unit
override CacheCurrentConfiguration :
        configuration : DataSet -> unit
function CacheCurrentConfiguration(configuration);
protected:
virtual void CacheCurrentConfiguration(
    DataSet^ configuration
)

Parameters

configuration
Type: System.DataDataSet
Configuration DataSet.
Remarks
This method allows caching of the current system configuration so it can be used if primary configuration source is unavailable.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.DisplayResponseMessage Method

Grid Solutions Framework ServiceHostBaseDisplayResponseMessage Method
Displays a response message to client requester.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void DisplayResponseMessage(
    ClientRequestInfo requestInfo,
    string status,
    params Object[] args
)
Protected Overridable Sub DisplayResponseMessage (
    requestInfo As ClientRequestInfo,
    status As String,
    ParamArray args As Object()
)
abstract DisplayResponseMessage :
        requestInfo : ClientRequestInfo *
        status : string *
        args : Object[] -> unit
override DisplayResponseMessage :
        requestInfo : ClientRequestInfo *
        status : string *
        args : Object[] -> unit
function DisplayResponseMessage(requestInfo, status, ... args);
protected:
virtual void DisplayResponseMessage(
    ClientRequestInfo^ requestInfo,
    String^ status,
    ... array<Object^>^ args
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
status
Type: SystemString
Formatted status message to send to client.
args
Type: SystemObject
Arguments of the formatted status message.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.DisplayStatusMessage Method

Grid Solutions Framework ServiceHostBaseDisplayStatusMessage Method
Overload List
 | Name | Description
Protected method | DisplayStatusMessage(String, UpdateType) | Displays a broadcast message to all subscribed clients.
Protected method | DisplayStatusMessage(String, UpdateType, Object) | Displays a broadcast message to all subscribed clients.
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.DisplayStatusMessage Method (String, UpdateType)

Grid Solutions Framework ServiceHostBaseDisplayStatusMessage Method (String, UpdateType)
Displays a broadcast message to all subscribed clients.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void DisplayStatusMessage(
    string status,
    UpdateType type
)
Protected Overridable Sub DisplayStatusMessage (
    status As String,
    type As UpdateType
)
abstract DisplayStatusMessage :
        status : string *
        type : UpdateType -> unit
override DisplayStatusMessage :
        status : string *
        type : UpdateType -> unit
function DisplayStatusMessage(status, type);
protected:
virtual void DisplayStatusMessage(
    String^ status,
    UpdateType type
)

Parameters

status
Type: SystemString
Status message to send to all clients.
type
Type: GSFUpdateType
UpdateType of message to send.
See Also

Reference

ServiceHostBase Class
DisplayStatusMessage Overload
GSF.TimeSeries Namespace


ServiceHostBase.DisplayStatusMessage Method (String, UpdateType, Object[])

Grid Solutions Framework ServiceHostBaseDisplayStatusMessage Method (String, UpdateType, Object)
Displays a broadcast message to all subscribed clients.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void DisplayStatusMessage(
    string status,
    UpdateType type,
    params Object[] args
)
Protected Overridable Sub DisplayStatusMessage (
    status As String,
    type As UpdateType,
    ParamArray args As Object()
)
abstract DisplayStatusMessage :
        status : string *
        type : UpdateType *
        args : Object[] -> unit
override DisplayStatusMessage :
        status : string *
        type : UpdateType *
        args : Object[] -> unit
function DisplayStatusMessage(status, type, ... args);
protected:
virtual void DisplayStatusMessage(
    String^ status,
    UpdateType type,
    ... array<Object^>^ args
)

Parameters

status
Type: SystemString
Formatted status message to send to all clients.
type
Type: GSFUpdateType
UpdateType of message to send.
args
Type: SystemObject
Arguments of the formatted status message.
See Also

Reference

ServiceHostBase Class
DisplayStatusMessage Overload
GSF.TimeSeries Namespace


ServiceHostBase.Dispose Method

Grid Solutions Framework ServiceHostBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ServiceHostBase object and optionally releases the managed resources. (Overrides ServiceBaseDispose(Boolean).)
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.Dispose Method (Boolean)

Grid Solutions Framework ServiceHostBaseDispose Method (Boolean)
Releases the unmanaged resources used by the ServiceHostBase object and optionally releases the managed resources.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ServiceHostBase Class
Dispose Overload
GSF.TimeSeries Namespace


ServiceHostBase.GetRequestedAdapter Method

Grid Solutions Framework ServiceHostBaseGetRequestedAdapter Method
Overload List
 | Name | Description
Protected method | GetRequestedAdapter(ClientRequestInfo) | Gets requested IAdapter.
Protected method | GetRequestedAdapter(ClientRequestInfo, IAdapterCollection) | Gets requested IAdapter and its containing IAdapterCollection.
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.GetRequestedAdapter Method (ClientRequestInfo)

Grid Solutions Framework ServiceHostBaseGetRequestedAdapter Method (ClientRequestInfo)
Gets requested IAdapter.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IAdapter GetRequestedAdapter(
    ClientRequestInfo requestInfo
)
Protected Overridable Function GetRequestedAdapter (
    requestInfo As ClientRequestInfo
) As IAdapter
abstract GetRequestedAdapter :
        requestInfo : ClientRequestInfo -> IAdapter
override GetRequestedAdapter :
        requestInfo : ClientRequestInfo -> IAdapter
function GetRequestedAdapter(requestInfo);
protected:
virtual IAdapter^ GetRequestedAdapter(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.

Return Value

Type: IAdapter
Requested IAdapter.
See Also

Reference

ServiceHostBase Class
GetRequestedAdapter Overload
GSF.TimeSeries Namespace


ServiceHostBase.GetRequestedAdapter Method (ClientRequestInfo, IAdapterCollection)

Grid Solutions Framework ServiceHostBaseGetRequestedAdapter Method (ClientRequestInfo, IAdapterCollection)
Gets requested IAdapter and its containing IAdapterCollection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IAdapter GetRequestedAdapter(
    ClientRequestInfo requestInfo,
    out IAdapterCollection collection
)
Protected Overridable Function GetRequestedAdapter (
    requestInfo As ClientRequestInfo,
    <OutAttribute> ByRef collection As IAdapterCollection
) As IAdapter
abstract GetRequestedAdapter :
        requestInfo : ClientRequestInfo *
        collection : IAdapterCollection byref -> IAdapter
override GetRequestedAdapter :
        requestInfo : ClientRequestInfo *
        collection : IAdapterCollection byref -> IAdapter
function GetRequestedAdapter(requestInfo, collection);
protected:
virtual IAdapter^ GetRequestedAdapter(
    ClientRequestInfo^ requestInfo,
    [OutAttribute] IAdapterCollection^% collection
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
collection
Type: GSF.TimeSeries.AdaptersIAdapterCollection
Containing IAdapterCollection for IAdapter.

Return Value

Type: IAdapter
Requested IAdapter.
See Also

Reference

ServiceHostBase Class
GetRequestedAdapter Overload
GSF.TimeSeries Namespace


ServiceHostBase.GetRequestedCollection Method

Grid Solutions Framework ServiceHostBaseGetRequestedCollection Method
Gets requested IAdapterCollection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual IAdapterCollection GetRequestedCollection(
    ClientRequestInfo requestInfo
)
Protected Overridable Function GetRequestedCollection (
    requestInfo As ClientRequestInfo
) As IAdapterCollection
abstract GetRequestedCollection :
        requestInfo : ClientRequestInfo -> IAdapterCollection
override GetRequestedCollection :
        requestInfo : ClientRequestInfo -> IAdapterCollection
function GetRequestedCollection(requestInfo);
protected:
virtual IAdapterCollection^ GetRequestedCollection(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.

Return Value

Type: IAdapterCollection
Requested IAdapterCollection.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.HealthMonitorProcessHandler Method

Grid Solutions Framework ServiceHostBaseHealthMonitorProcessHandler Method
Event handler for scheduled health monitor display.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void HealthMonitorProcessHandler(
    string name,
    Object[] parameters
)
Protected Overridable Sub HealthMonitorProcessHandler (
    name As String,
    parameters As Object()
)
abstract HealthMonitorProcessHandler :
        name : string *
        parameters : Object[] -> unit
override HealthMonitorProcessHandler :
        name : string *
        parameters : Object[] -> unit
function HealthMonitorProcessHandler(name, parameters);
protected:
virtual void HealthMonitorProcessHandler(
    String^ name,
    array<Object^>^ parameters
)

Parameters

name
Type: SystemString
Scheduled event name.
parameters
Type: SystemObject
Scheduled event parameters.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.InitializeRequestHandler Method

Grid Solutions Framework ServiceHostBaseInitializeRequestHandler Method
Performs initialization or reinitialization of specified adapter or collection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void InitializeRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub InitializeRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract InitializeRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override InitializeRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function InitializeRequestHandler(requestInfo);
protected:
virtual void InitializeRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.InitializeServiceHelper Method

Grid Solutions Framework ServiceHostBaseInitializeServiceHelper Method
Initializes the service helper.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void InitializeServiceHelper()
Public Sub InitializeServiceHelper
member InitializeServiceHelper : unit -> unit

function InitializeServiceHelper();
public:
void InitializeServiceHelper()
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.InvokeRequestHandler Method

Grid Solutions Framework ServiceHostBaseInvokeRequestHandler Method
Invokes specified adapter command.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void InvokeRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub InvokeRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract InvokeRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override InvokeRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function InvokeRequestHandler(requestInfo);
protected:
virtual void InvokeRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ListCommandsRequestHandler Method

Grid Solutions Framework ServiceHostBaseListCommandsRequestHandler Method
Lists possible commands of specified adapter.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ListCommandsRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub ListCommandsRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract ListCommandsRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override ListCommandsRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function ListCommandsRequestHandler(requestInfo);
protected:
virtual void ListCommandsRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ListRequestHandler Method

Grid Solutions Framework ServiceHostBaseListRequestHandler Method
Displays status of specified adapter or collection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ListRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub ListRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract ListRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override ListRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function ListRequestHandler(requestInfo);
protected:
virtual void ListRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.LogEventRequestHandler Method

Grid Solutions Framework ServiceHostBaseLogEventRequestHandler Method
Sends remote entry for logging.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void LogEventRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub LogEventRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract LogEventRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override LogEventRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function LogEventRequestHandler(requestInfo);
protected:
virtual void LogEventRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo

[Missing <param name="requestInfo"/> documentation for "M:GSF.TimeSeries.ServiceHostBase.LogEventRequestHandler(GSF.ServiceProcess.ClientRequestInfo)"]

See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.LogException Method

Grid Solutions Framework ServiceHostBaseLogException Method
Logs an exception to the service helper ErrorLogger.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void LogException(
    Exception ex
)
Protected Overridable Sub LogException (
    ex As Exception
)
abstract LogException :
        ex : Exception -> unit
override LogException :
        ex : Exception -> unit
function LogException(ex);
protected:
virtual void LogException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Exception to log.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.LogExceptionHandler Method

Grid Solutions Framework ServiceHostBaseLogExceptionHandler Method
Event handler for processing exceptions encountered while writing entries to a log file.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void LogExceptionHandler(
    Object sender,
    EventArgs<Exception> e
)
Protected Overridable Sub LogExceptionHandler (
    sender As Object,
    e As EventArgs(Of Exception)
)
abstract LogExceptionHandler :
        sender : Object *
        e : EventArgs<Exception> -> unit
override LogExceptionHandler :
        sender : Object *
        e : EventArgs<Exception> -> unit
function LogExceptionHandler(sender, e);
protected:
virtual void LogExceptionHandler(
    Object^ sender,
    EventArgs<Exception^>^ e
)

Parameters

sender
Type: SystemObject
Event source of the exception.
e
Type: GSFEventArgs Exception
Event arguments containing the exception to report.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.OnContinue Method

Grid Solutions Framework ServiceHostBaseOnContinue Method
Handles service continue event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnContinue()
Protected Overrides Sub OnContinue
abstract OnContinue : unit -> unit
override OnContinue : unit -> unit
function OnContinue();
protected:
virtual void OnContinue() override
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.OnPause Method

Grid Solutions Framework ServiceHostBaseOnPause Method
Handles service pause event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnPause()
Protected Overrides Sub OnPause
abstract OnPause : unit -> unit
override OnPause : unit -> unit
function OnPause();
protected:
virtual void OnPause() override
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.OnShutdown Method

Grid Solutions Framework ServiceHostBaseOnShutdown Method
Handles service shut down event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnShutdown()
Protected Overrides Sub OnShutdown
abstract OnShutdown : unit -> unit
override OnShutdown : unit -> unit
function OnShutdown();
protected:
virtual void OnShutdown() override
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.OnStart Method

Grid Solutions Framework ServiceHostBaseOnStart Method
Handles service start event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnStart(
    string[] args
)
Protected Overrides Sub OnStart (
    args As String()
)
abstract OnStart :
        args : string[] -> unit
override OnStart :
        args : string[] -> unit
function OnStart(args);
protected:
virtual void OnStart(
    array<String^>^ args
) override

Parameters

args
Type: SystemString
Service startup arguments, if any.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.OnStop Method

Grid Solutions Framework ServiceHostBaseOnStop Method
Handles service stop event.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void OnStop()
Protected Overrides Sub OnStop
abstract OnStop : unit -> unit
override OnStop : unit -> unit
function OnStop();
protected:
virtual void OnStop() override
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.RefreshRoutesRequestHandler Method

Grid Solutions Framework ServiceHostBaseRefreshRoutesRequestHandler Method
Recalculates routing tables.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void RefreshRoutesRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub RefreshRoutesRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract RefreshRoutesRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override RefreshRoutesRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function RefreshRoutesRequestHandler(requestInfo);
protected:
virtual void RefreshRoutesRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ReloadConfigRequestHandler Method

Grid Solutions Framework ServiceHostBaseReloadConfigRequestHandler Method
Manually reloads system configuration.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ReloadConfigRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub ReloadConfigRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract ReloadConfigRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override ReloadConfigRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function ReloadConfigRequestHandler(requestInfo);
protected:
virtual void ReloadConfigRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ReportingProcessHandler Method

Grid Solutions Framework ServiceHostBaseReportingProcessHandler Method
Event handler for scheduled reporting services.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ReportingProcessHandler(
    string name,
    Object[] parameters
)
Protected Overridable Sub ReportingProcessHandler (
    name As String,
    parameters As Object()
)
abstract ReportingProcessHandler :
        name : string *
        parameters : Object[] -> unit
override ReportingProcessHandler :
        name : string *
        parameters : Object[] -> unit
function ReportingProcessHandler(name, parameters);
protected:
virtual void ReportingProcessHandler(
    String^ name,
    array<Object^>^ parameters
)

Parameters

name
Type: SystemString
Scheduled event name.
parameters
Type: SystemObject
Scheduled event parameters.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.RestartServiceHandler Method

Grid Solutions Framework ServiceHostBaseRestartServiceHandler Method
Attempts to restart the hose service.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void RestartServiceHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub RestartServiceHandler (
    requestInfo As ClientRequestInfo
)
abstract RestartServiceHandler :
        requestInfo : ClientRequestInfo -> unit
override RestartServiceHandler :
        requestInfo : ClientRequestInfo -> unit
function RestartServiceHandler(requestInfo);
protected:
virtual void RestartServiceHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.SendResponse Method

Grid Solutions Framework ServiceHostBaseSendResponse Method
Overload List
 | Name | Description
Protected method | SendResponse(ClientRequestInfo, Boolean) | Sends an actionable response to client.
Protected method | SendResponse(ClientRequestInfo, Boolean, String, Object) | Sends an actionable response to client with a formatted message.
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.SendResponse Method (ClientRequestInfo, Boolean)

Grid Solutions Framework ServiceHostBaseSendResponse Method (ClientRequestInfo, Boolean)
Sends an actionable response to client.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void SendResponse(
    ClientRequestInfo requestInfo,
    bool success
)
Protected Overridable Sub SendResponse (
    requestInfo As ClientRequestInfo,
    success As Boolean
)
abstract SendResponse :
        requestInfo : ClientRequestInfo *
        success : bool -> unit
override SendResponse :
        requestInfo : ClientRequestInfo *
        success : bool -> unit
function SendResponse(requestInfo, success);
protected:
virtual void SendResponse(
    ClientRequestInfo^ requestInfo,
    bool success
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
success
Type: SystemBoolean
Flag that determines if this response to client request was a success.
See Also

Reference

ServiceHostBase Class
SendResponse Overload
GSF.TimeSeries Namespace


ServiceHostBase.SendResponse Method (ClientRequestInfo, Boolean, String, Object[])

Grid Solutions Framework ServiceHostBaseSendResponse Method (ClientRequestInfo, Boolean, String, Object)
Sends an actionable response to client with a formatted message.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void SendResponse(
    ClientRequestInfo requestInfo,
    bool success,
    string status,
    params Object[] args
)
Protected Overridable Sub SendResponse (
    requestInfo As ClientRequestInfo,
    success As Boolean,
    status As String,
    ParamArray args As Object()
)
abstract SendResponse :
        requestInfo : ClientRequestInfo *
        success : bool *
        status : string *
        args : Object[] -> unit
override SendResponse :
        requestInfo : ClientRequestInfo *
        success : bool *
        status : string *
        args : Object[] -> unit
function SendResponse(requestInfo, success, status, ... args);
protected:
virtual void SendResponse(
    ClientRequestInfo^ requestInfo,
    bool success,
    String^ status,
    ... array<Object^>^ args
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
success
Type: SystemBoolean
Flag that determines if this response to client request was a success.
status
Type: SystemString
Formatted status message to send with response.
args
Type: SystemObject
Arguments of the formatted status message.
See Also

Reference

ServiceHostBase Class
SendResponse Overload
GSF.TimeSeries Namespace


ServiceHostBase.SendResponseWithAttachment Method

Grid Solutions Framework ServiceHostBaseSendResponseWithAttachment Method
Sends an actionable response to client with a formatted message and attachment.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void SendResponseWithAttachment(
    ClientRequestInfo requestInfo,
    bool success,
    Object attachment,
    string status,
    params Object[] args
)
Protected Overridable Sub SendResponseWithAttachment (
    requestInfo As ClientRequestInfo,
    success As Boolean,
    attachment As Object,
    status As String,
    ParamArray args As Object()
)
abstract SendResponseWithAttachment :
        requestInfo : ClientRequestInfo *
        success : bool *
        attachment : Object *
        status : string *
        args : Object[] -> unit
override SendResponseWithAttachment :
        requestInfo : ClientRequestInfo *
        success : bool *
        attachment : Object *
        status : string *
        args : Object[] -> unit
function SendResponseWithAttachment(requestInfo, success, attachment, status, ... args);
protected:
virtual void SendResponseWithAttachment(
    ClientRequestInfo^ requestInfo,
    bool success,
    Object^ attachment,
    String^ status,
    ... array<Object^>^ args
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
success
Type: SystemBoolean
Flag that determines if this response to client request was a success.
attachment
Type: SystemObject
Attachment to send with response.
status
Type: SystemString
Formatted status message to send with response.
args
Type: SystemObject
Arguments of the formatted status message.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ServiceStartedHandler Method

Grid Solutions Framework ServiceHostBaseServiceStartedHandler Method
Event handler for service started operation.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ServiceStartedHandler(
    Object sender,
    EventArgs e
)
Protected Overridable Sub ServiceStartedHandler (
    sender As Object,
    e As EventArgs
)
abstract ServiceStartedHandler :
        sender : Object *
        e : EventArgs -> unit
override ServiceStartedHandler :
        sender : Object *
        e : EventArgs -> unit
function ServiceStartedHandler(sender, e);
protected:
virtual void ServiceStartedHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Event source.
e
Type: SystemEventArgs
Event arguments.
Remarks
Time-series framework uses this handler to handle initialization of system objects.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ServiceStartingHandler Method

Grid Solutions Framework ServiceHostBaseServiceStartingHandler Method
Event handler for service starting operations.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ServiceStartingHandler(
    Object sender,
    EventArgs<string[]> e
)
Protected Overridable Sub ServiceStartingHandler (
    sender As Object,
    e As EventArgs(Of String())
)
abstract ServiceStartingHandler :
        sender : Object *
        e : EventArgs<string[]> -> unit
override ServiceStartingHandler :
        sender : Object *
        e : EventArgs<string[]> -> unit
function ServiceStartingHandler(sender, e);
protected:
virtual void ServiceStartingHandler(
    Object^ sender,
    EventArgs<array<String^>^>^ e
)

Parameters

sender
Type: SystemObject
Event source.
e
Type: GSFEventArgs String
Event arguments containing command line arguments passed into service at startup.
Remarks
Time-series framework uses this handler to load settings from configuration file as service is starting.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ServiceStoppingHandler Method

Grid Solutions Framework ServiceHostBaseServiceStoppingHandler Method
Event handler for service stopping operation.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ServiceStoppingHandler(
    Object sender,
    EventArgs e
)
Protected Overridable Sub ServiceStoppingHandler (
    sender As Object,
    e As EventArgs
)
abstract ServiceStoppingHandler :
        sender : Object *
        e : EventArgs -> unit
override ServiceStoppingHandler :
        sender : Object *
        e : EventArgs -> unit
function ServiceStoppingHandler(sender, e);
protected:
virtual void ServiceStoppingHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Event source.
e
Type: SystemEventArgs
Event arguments.
Remarks
Time-series framework uses this handler to un-wire events and dispose of system objects.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.StartRequestHandler Method

Grid Solutions Framework ServiceHostBaseStartRequestHandler Method
Starts specified adapter.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void StartRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub StartRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract StartRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override StartRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function StartRequestHandler(requestInfo);
protected:
virtual void StartRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.StatusExportProcessHandler Method

Grid Solutions Framework ServiceHostBaseStatusExportProcessHandler Method
Event handler for scheduled adapter status export.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void StatusExportProcessHandler(
    string name,
    Object[] parameters
)
Protected Overridable Sub StatusExportProcessHandler (
    name As String,
    parameters As Object()
)
abstract StatusExportProcessHandler :
        name : string *
        parameters : Object[] -> unit
override StatusExportProcessHandler :
        name : string *
        parameters : Object[] -> unit
function StatusExportProcessHandler(name, parameters);
protected:
virtual void StatusExportProcessHandler(
    String^ name,
    array<Object^>^ parameters
)

Parameters

name
Type: SystemString
Scheduled event name.
parameters
Type: SystemObject
Scheduled event parameters.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.StopRequestHandler Method

Grid Solutions Framework ServiceHostBaseStopRequestHandler Method
Stops specified adapter.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void StopRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub StopRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract StopRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override StopRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function StopRequestHandler(requestInfo);
protected:
virtual void StopRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.TemporalSupportRequestHandler Method

Grid Solutions Framework ServiceHostBaseTemporalSupportRequestHandler Method
Determines support for temporal processing from existing adapters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void TemporalSupportRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub TemporalSupportRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract TemporalSupportRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override TemporalSupportRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function TemporalSupportRequestHandler(requestInfo);
protected:
virtual void TemporalSupportRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.UpdateConfigFileRequestHandler Method

Grid Solutions Framework ServiceHostBaseUpdateConfigFileRequestHandler Method
Updates an option in the configuration file.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void UpdateConfigFileRequestHandler(
    ClientRequestInfo requestInfo
)
Protected Overridable Sub UpdateConfigFileRequestHandler (
    requestInfo As ClientRequestInfo
)
abstract UpdateConfigFileRequestHandler :
        requestInfo : ClientRequestInfo -> unit
override UpdateConfigFileRequestHandler :
        requestInfo : ClientRequestInfo -> unit
function UpdateConfigFileRequestHandler(requestInfo);
protected:
virtual void UpdateConfigFileRequestHandler(
    ClientRequestInfo^ requestInfo
)

Parameters

requestInfo
Type: GSF.ServiceProcessClientRequestInfo
ClientRequestInfo instance containing the client request.
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase Properties

Grid Solutions Framework ServiceHostBase Properties

The ServiceHostBase type exposes the following members.

Properties
 | Name | Description
Protected property | ActionAdapters | Gets reference to the ActionAdapterCollection.
Protected property | AllAdapters | Gets reference to the AllAdaptersCollection.
Public property | AutoLog | Indicates whether to report Start, Stop, Pause, and Continue commands in the event log. (Inherited from ServiceBase.)
Public property | CanHandlePowerEvent | Gets or sets a value indicating whether the service can handle notifications of computer power status changes. (Inherited from ServiceBase.)
Public property | CanHandleSessionChangeEvent | Gets or sets a value that indicates whether the service can handle session change events received from a Terminal Server session. (Inherited from ServiceBase.)
Public property | CanPauseAndContinue | Gets or sets a value indicating whether the service can be paused and resumed. (Inherited from ServiceBase.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | CanShutdown | Gets or sets a value indicating whether the service should be notified when the system is shutting down. (Inherited from ServiceBase.)
Public property | CanStop | Gets or sets a value indicating whether the service can be stopped once it has started. (Inherited from ServiceBase.)
Protected property | ConfigurationType | Gets the defined system ConfigurationType.
Protected property | ConsoleApplicationName | Gets the related remote console application name.
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Protected property | DataSource | Gets the currently loaded system configuration DataSet.
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | EventLog | Gets an event log you can use to write notification of service command calls, such as Start and Stop, to the Application event log. (Inherited from ServiceBase.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExitCode | Gets or sets the exit code for the service. (Inherited from ServiceBase.)
Protected property | InputAdapters | Gets reference to the InputAdapterCollection.
Protected property | NodeID | Gets the current node ID.
Protected property | NodeIDQueryString | Gets the current node ID formatted for use in a SQL query string based on ConfigurationType.
Protected property | OutputAdapters | Gets reference to the OutputAdapterCollection.
Protected property | RemotingServer | Gets reference to the TcpServer based remoting server.
Protected property | ServiceHandle | Gets the service control handle for the service. (Inherited from ServiceBase.)
Protected property | ServiceHelper | Gets access to the ServiceHelper.
Public property | ServiceName | Gets or sets the short name used to identify the service to the system. (Inherited from ServiceBase.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ActionAdapters Property

Grid Solutions Framework ServiceHostBaseActionAdapters Property
Gets reference to the ActionAdapterCollection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ActionAdapterCollection ActionAdapters { get; }
Protected ReadOnly Property ActionAdapters As ActionAdapterCollection
    Get
member ActionAdapters : ActionAdapterCollection with get

function get_ActionAdapters();

protected:
property ActionAdapterCollection^ ActionAdapters {
    ActionAdapterCollection^ get ();
}

Property Value

Type: ActionAdapterCollection
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.AllAdapters Property

Grid Solutions Framework ServiceHostBaseAllAdapters Property
Gets reference to the AllAdaptersCollection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AllAdaptersCollection AllAdapters { get; }
Protected ReadOnly Property AllAdapters As AllAdaptersCollection
    Get
member AllAdapters : AllAdaptersCollection with get

function get_AllAdapters();

protected:
property AllAdaptersCollection^ AllAdapters {
    AllAdaptersCollection^ get ();
}

Property Value

Type: AllAdaptersCollection
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ConfigurationType Property

Grid Solutions Framework ServiceHostBaseConfigurationType Property
Gets the defined system ConfigurationType.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConfigurationType ConfigurationType { get; }
Protected ReadOnly Property ConfigurationType As ConfigurationType
    Get
member ConfigurationType : ConfigurationType with get

function get_ConfigurationType();

protected:
property ConfigurationType ConfigurationType {
    ConfigurationType get ();
}

Property Value

Type: ConfigurationType
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ConsoleApplicationName Property

Grid Solutions Framework ServiceHostBaseConsoleApplicationName Property
Gets the related remote console application name.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string ConsoleApplicationName { get; }
Protected Overridable ReadOnly Property ConsoleApplicationName As String
    Get
abstract ConsoleApplicationName : string with get
override ConsoleApplicationName : string with get
function get_ConsoleApplicationName();

protected:
virtual property String^ ConsoleApplicationName {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.DataSource Property

Grid Solutions Framework ServiceHostBaseDataSource Property
Gets the currently loaded system configuration DataSet.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected DataSet DataSource { get; }
Protected ReadOnly Property DataSource As DataSet
    Get
member DataSource : DataSet with get

function get_DataSource();

protected:
property DataSet^ DataSource {
    DataSet^ get ();
}

Property Value

Type: DataSet
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.InputAdapters Property

Grid Solutions Framework ServiceHostBaseInputAdapters Property
Gets reference to the InputAdapterCollection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected InputAdapterCollection InputAdapters { get; }
Protected ReadOnly Property InputAdapters As InputAdapterCollection
    Get
member InputAdapters : InputAdapterCollection with get

function get_InputAdapters();

protected:
property InputAdapterCollection^ InputAdapters {
    InputAdapterCollection^ get ();
}

Property Value

Type: InputAdapterCollection
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.NodeID Property

Grid Solutions Framework ServiceHostBaseNodeID Property
Gets the current node ID.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Guid NodeID { get; }
Protected ReadOnly Property NodeID As Guid
    Get
member NodeID : Guid with get

function get_NodeID();

protected:
property Guid NodeID {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.NodeIDQueryString Property

Grid Solutions Framework ServiceHostBaseNodeIDQueryString Property
Gets the current node ID formatted for use in a SQL query string based on ConfigurationType.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected string NodeIDQueryString { get; }
Protected ReadOnly Property NodeIDQueryString As String
    Get
member NodeIDQueryString : string with get

function get_NodeIDQueryString();

protected:
property String^ NodeIDQueryString {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.OutputAdapters Property

Grid Solutions Framework ServiceHostBaseOutputAdapters Property
Gets reference to the OutputAdapterCollection.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected OutputAdapterCollection OutputAdapters { get; }
Protected ReadOnly Property OutputAdapters As OutputAdapterCollection
    Get
member OutputAdapters : OutputAdapterCollection with get

function get_OutputAdapters();

protected:
property OutputAdapterCollection^ OutputAdapters {
    OutputAdapterCollection^ get ();
}

Property Value

Type: OutputAdapterCollection
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.RemotingServer Property

Grid Solutions Framework ServiceHostBaseRemotingServer Property
Gets reference to the TcpServer based remoting server.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ServerBase RemotingServer { get; }
Protected ReadOnly Property RemotingServer As ServerBase
    Get
member RemotingServer : ServerBase with get

function get_RemotingServer();

protected:
property ServerBase^ RemotingServer {
    ServerBase^ get ();
}

Property Value

Type: ServerBase
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase.ServiceHelper Property

Grid Solutions Framework ServiceHostBaseServiceHelper Property
Gets access to the ServiceHelper.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ServiceHelper ServiceHelper { get; }
Protected ReadOnly Property ServiceHelper As ServiceHelper
    Get
member ServiceHelper : ServiceHelper with get

function get_ServiceHelper();

protected:
property ServiceHelper^ ServiceHelper {
    ServiceHelper^ get ();
}

Property Value

Type: ServiceHelper
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


ServiceHostBase Events

Grid Solutions Framework ServiceHostBase Events

The ServiceHostBase type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Top
See Also

Reference

ServiceHostBase Class
GSF.TimeSeries Namespace


TemporalMeasurement Class

Grid Solutions Framework TemporalMeasurement Class
Represents a time constrained measured value.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesMeasurement
GSF.TimeSeriesTemporalMeasurement

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class TemporalMeasurement : Measurement
Public Class TemporalMeasurement
    Inherits Measurement
type TemporalMeasurement =
    class
        inherit Measurement
    end
GSF.TimeSeries.TemporalMeasurement = function();

Type.createClass(
    'GSF.TimeSeries.TemporalMeasurement',
    GSF.TimeSeries.Measurement);
public ref class TemporalMeasurement : public Measurement

The TemporalMeasurement type exposes the following members.

Constructors
 | Name | Description
Public method | TemporalMeasurement(Double, Double) | Constructs a new TemporalMeasurement given the specified parameters.
Public method | TemporalMeasurement(IMeasurement, Double, Double) | Constructs a new TemporalMeasurement given the specified parameters.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAdjustedValue | Gets numeric adjusted value of this TemporalMeasurement, constrained within specified ticks.
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets numeric value of this TemporalMeasurement, constrained within specified ticks.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets numeric value and timestamp, as ticks, of this TemporalMeasurement.
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | LagTime | Allowed past time deviation tolerance in seconds (can be sub-second).
Public property | LeadTime | Allowed future time deviation tolerance in seconds (can be sub-second).
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
See Also

Reference

GSF.TimeSeries Namespace


TemporalMeasurement Constructor

Grid Solutions Framework TemporalMeasurement Constructor
Overload List
 | Name | Description
Public method | TemporalMeasurement(Double, Double) | Constructs a new TemporalMeasurement given the specified parameters.
Public method | TemporalMeasurement(IMeasurement, Double, Double) | Constructs a new TemporalMeasurement given the specified parameters.
Top
See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TemporalMeasurement Constructor (Double, Double)

Grid Solutions Framework TemporalMeasurement Constructor (Double, Double)
Constructs a new TemporalMeasurement given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TemporalMeasurement(
    double lagTime,
    double leadTime
)
Public Sub New (
    lagTime As Double,
    leadTime As Double
)
new :
        lagTime : float *
        leadTime : float -> TemporalMeasurement
GSF.TimeSeries.TemporalMeasurement = function(lagTime, leadTime);
public:
TemporalMeasurement(
    double lagTime,
    double leadTime
)

Parameters

lagTime
Type: SystemDouble
Past time deviation tolerance, in seconds - this becomes the amount of time to wait before publishing begins.
leadTime
Type: SystemDouble
Future time deviation tolerance, in seconds - this becomes the tolerated +/- accuracy of the local clock to real-time.
See Also

Reference

TemporalMeasurement Class
TemporalMeasurement Overload
GSF.TimeSeries Namespace


TemporalMeasurement Constructor (IMeasurement, Double, Double)

Grid Solutions Framework TemporalMeasurement Constructor (IMeasurement, Double, Double)
Constructs a new TemporalMeasurement given the specified parameters.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TemporalMeasurement(
    IMeasurement measurement,
    double lagTime,
    double leadTime
)
Public Sub New (
    measurement As IMeasurement,
    lagTime As Double,
    leadTime As Double
)
new :
        measurement : IMeasurement *
        lagTime : float *
        leadTime : float -> TemporalMeasurement
GSF.TimeSeries.TemporalMeasurement = function(measurement, lagTime, leadTime);
public:
TemporalMeasurement(
    IMeasurement^ measurement,
    double lagTime,
    double leadTime
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Source IMeasurement value.
lagTime
Type: SystemDouble
Past time deviation tolerance, in seconds - this becomes the amount of time to wait before publishing begins.
leadTime
Type: SystemDouble
Future time deviation tolerance, in seconds - this becomes the tolerated +/- accuracy of the local clock to real-time.
See Also

Reference

TemporalMeasurement Class
TemporalMeasurement Overload
GSF.TimeSeries Namespace


TemporalMeasurement Methods

Grid Solutions Framework TemporalMeasurement Methods

The TemporalMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetAdjustedValue | Gets numeric adjusted value of this TemporalMeasurement, constrained within specified ticks.
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetValue | Gets numeric value of this TemporalMeasurement, constrained within specified ticks.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SetValue | Sets numeric value and timestamp, as ticks, of this TemporalMeasurement.
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TemporalMeasurement.GetAdjustedValue Method

Grid Solutions Framework TemporalMeasurementGetAdjustedValue Method
Gets numeric adjusted value of this TemporalMeasurement, constrained within specified ticks.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double GetAdjustedValue(
    Ticks timestamp
)
Public Function GetAdjustedValue (
    timestamp As Ticks
) As Double
member GetAdjustedValue :
        timestamp : Ticks -> float

function GetAdjustedValue(timestamp);
public:
double GetAdjustedValue(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp used to constrain TemporalMeasurement (typically set to real-time, i.e. "now").

Return Value

Type: Double
Value offset by adder and multiplier (i.e., Value * Multiplier + Adder).
Remarks

Operation will return NaN if ticks are outside of time deviation tolerances.

Note that returned value will be offset by adder and multiplier.

See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TemporalMeasurement.GetValue Method

Grid Solutions Framework TemporalMeasurementGetValue Method
Gets numeric value of this TemporalMeasurement, constrained within specified ticks.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double GetValue(
    Ticks timestamp
)
Public Function GetValue (
    timestamp As Ticks
) As Double
member GetValue :
        timestamp : Ticks -> float

function GetValue(timestamp);
public:
double GetValue(
    Ticks timestamp
)

Parameters

timestamp
Type: GSFTicks
Timestamp, in ticks, used to constrain TemporalMeasurement (typically set to real-time, i.e. "now").

Return Value

Type: Double
Raw value of this measurement (i.e., value that is not offset by adder and multiplier).
Remarks

Operation will return NaN if ticks are outside of time deviation tolerances.

See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TemporalMeasurement.SetValue Method

Grid Solutions Framework TemporalMeasurementSetValue Method
Sets numeric value and timestamp, as ticks, of this TemporalMeasurement.

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SetValue(
    Ticks timestamp,
    double value
)
Public Function SetValue (
    timestamp As Ticks,
    value As Double
) As Boolean
member SetValue :
        timestamp : Ticks *
        value : float -> bool

function SetValue(timestamp, value);
public:
bool SetValue(
    Ticks timestamp,
    double value
)

Parameters

timestamp
Type: GSFTicks
New timestamp, in ticks, for TemporalMeasurement.
value
Type: SystemDouble
New value for TemporalMeasurement, only stored if timestamp are newer than current Ticks.

Return Value

Type: Boolean
true if value was updated; otherwise false.
Remarks

Operation will only store a value that is newer than the cached value.

See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TemporalMeasurement Properties

Grid Solutions Framework TemporalMeasurement Properties

The TemporalMeasurement type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | LagTime | Allowed past time deviation tolerance in seconds (can be sub-second).
Public property | LeadTime | Allowed future time deviation tolerance in seconds (can be sub-second).
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TemporalMeasurement.LagTime Property

Grid Solutions Framework TemporalMeasurementLagTime Property
Allowed past time deviation tolerance in seconds (can be sub-second).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double LagTime { get; set; }
Public Property LagTime As Double
    Get
    Set
member LagTime : float with get, set

function get_LagTime();
function set_LagTime(value);
public:
property double LagTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime must be greater than zero, but it can be less than one.
Remarks

This value defines the time sensitivity to past measurement timestamps.

Defined the number of seconds allowed before assuming a measurement timestamp is too old.

See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TemporalMeasurement.LeadTime Property

Grid Solutions Framework TemporalMeasurementLeadTime Property
Allowed future time deviation tolerance in seconds (can be sub-second).

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double LeadTime { get; set; }
Public Property LeadTime As Double
    Get
    Set
member LeadTime : float with get, set

function get_LeadTime();
function set_LeadTime(value);
public:
property double LeadTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LeadTime must be greater than zero, but it can be less than one.
Remarks

This value defines the time sensitivity to future measurement timestamps.

Defined the number of seconds allowed before assuming a measurement timestamp is too advanced.

See Also

Reference

TemporalMeasurement Class
GSF.TimeSeries Namespace


TimeSeriesStartupOperations Class

Grid Solutions Framework TimeSeriesStartupOperations Class
Defines a data operations to be performed at startup.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesTimeSeriesStartupOperations

Namespace: GSF.TimeSeries
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class TimeSeriesStartupOperations
Public NotInheritable Class TimeSeriesStartupOperations
[<AbstractClassAttribute>]
[<SealedAttribute>]
type TimeSeriesStartupOperations =  class end
GSF.TimeSeries.TimeSeriesStartupOperations = function();

Type.createClass(
    'GSF.TimeSeries.TimeSeriesStartupOperations');
public ref class TimeSeriesStartupOperations abstract sealed
See Also

Reference

GSF.TimeSeries Namespace


GSF.TimeSeries.Adapters Namespace

Grid Solutions Framework GSF.TimeSeries.Adapters Namespace
Contains classes that define an adapter interface layer used to route measurements through a cycle of input, sorted actions and queued output.
Classes
 | Class | Description
Public class | ActionAdapterBase | Represents the base class for action adapters.
Public class | ActionAdapterCollection | Represents a collection of IActionAdapter implementations.
Public class | AdapterBase | Represents the base class for any adapter.
Public class | AdapterCollectionBaseT | Represents a collection of IAdapter implementations.
Public class | AdapterCommandAttribute | Represents an attribute that allows a method in an IAdapter class to be exposed as an invokable command.
Public class | AllAdaptersCollection | Represents a collection of all IAdapterCollection implementations (i.e., a collection of IAdapterCollection's).
Public class | ConnectionStringParameterAttribute | Marks a parameter as being a connection string parameter used to configure an IAdapter.
Public class | CustomConfigurationEditorAttribute | Marks a parameter or class as having a custom configuration editor page used to configure that parameter or class.
Public class | FacileActionAdapterBase | Represents the base class for simple, non-time-aligned, action adapters.
Public class | IAdapterExtensions | Defines static extension functions for IAdapter implementations.
Public class | IaonSession | Represents a new Input, Action, Output interface session.
Public class | InputAdapterBase | Represents the base class for any incoming input adapter.
Public class | InputAdapterCollection | Represents a collection of IInputAdapter implementations.
Public class | OutputAdapterBase | Represents the base class for any outgoing data stream.
Public class | OutputAdapterCollection | Represents a collection of IOutputAdapter implementations.
Public class | RoutingTables | Represents the routing tables for the Iaon adapters.
Interfaces
 | Interface | Description
Public interface | IActionAdapter | Represents the abstract interface for any action adapter.
Public interface | IAdapter | Represents the abstract interface for any adapter.
Public interface | IAdapterCollection | Represents the abstract interface for a collection of adapters.
Public interface | IInputAdapter | Represents the abstract interface for any incoming adapter.
Public interface | IOutputAdapter | Represents that abstract interface for any outgoing adapter.


ActionAdapterBase Class

Grid Solutions Framework ActionAdapterBase Class
Represents the base class for action adapters.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesConcentratorBase
GSF.TimeSeries.AdaptersActionAdapterBase

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ActionAdapterBase : ConcentratorBase,
    IActionAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public MustInherit Class ActionAdapterBase
    Inherits ConcentratorBase
    Implements IActionAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
[<AbstractClassAttribute>]
type ActionAdapterBase =
    class
        inherit ConcentratorBase
        interface IActionAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.ActionAdapterBase = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.ActionAdapterBase',
    GSF.TimeSeries.ConcentratorBase,
    GSF.TimeSeries.Adapters.IActionAdapter,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class ActionAdapterBase abstract : public ConcentratorBase,
    IActionAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The ActionAdapterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ActionAdapterBase | Creates a new ActionAdapterBase.
Top
Methods
 | Name | Description
Protected method | AssignMeasurementToFrame | Assigns IMeasurement to its associated IFrame. (Inherited from ConcentratorBase.)
Protected method | CreateNewFrame | Creates a new IFrame for the given timestamp. (Inherited from ConcentratorBase.)
Public method | Dispose | Releases all the resources used by the ConcentratorBase object. (Inherited from ConcentratorBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ActionAdapterBase object and optionally releases the managed resources. (Overrides ConcentratorBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExamineQueueState | Examines the concentrator frame queue state of the ActionAdapterBase.
Protected method | Finalize | Releases the unmanaged resources before the ConcentratorBase object is reclaimed by GC. (Inherited from ConcentratorBase.)
Public method | GetHashCode | Serves as a hash function for the current ActionAdapterBase. (Overrides ObjectGetHashCode.)
Public method | GetShortStatus | Gets a short one-line status of this ActionAdapterBase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes ActionAdapterBase.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MillisecondsFromRealTime | Returns the deviation, in milliseconds, that the given number of ticks is from real-time (i.e., RealTime). (Inherited from ConcentratorBase.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from ConcentratorBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises the ProcessException event. (Inherited from ConcentratorBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from ConcentratorBase.)
Protected method | PublishFrame | Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime. (Inherited from ConcentratorBase.)
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | ResetStatistics | Resets the statistics of the ActionAdapterBase. (Overrides ConcentratorBaseResetStatistics.)
Public method | SecondsFromRealTime | Returns the deviation, in seconds, that the given number of ticks is from real-time (i.e., RealTime). (Inherited from ConcentratorBase.)
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter.
Public method | SortMeasurement | Sorts the IMeasurement placing the data point in its proper IFrame. (Inherited from ConcentratorBase.)
Public method | SortMeasurements | Sorts each IMeasurement placing each data point in its proper IFrame. (Inherited from ConcentratorBase.)
Public method | Start | Starts the ActionAdapterBase or restarts it if it is already running. (Overrides ConcentratorBaseStart.)
Public method | Stop | Stops the ActionAdapterBase. (Overrides ConcentratorBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TryGetMinimumNeededMeasurements | Attempts to retrieve the minimum needed number of measurements from the frame (as specified by MinimumMeasurementsToUse)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AllowPreemptivePublishing | Gets or sets flag that allows system to preemptively publish frames assuming all ExpectedMeasurements have arrived. (Inherited from ConcentratorBase.)
Public property | AllowSortsByArrival | Gets or sets flag that determines whether or not to allow incoming measurements with bad timestamps to be sorted by arrival time. (Inherited from ConcentratorBase.)
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand.
Public property | AveragePublicationTimePerFrame | Gets the average required frame publication time, in seconds. (Inherited from ConcentratorBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to action adapter.
Public property | DataSource | Gets or sets DataSet based data source available to this ActionAdapterBase.
Public property | DiscardedMeasurements | Gets the total number of measurements that have been discarded because of old timestamps (i.e., measurements that were outside the time deviation tolerance from base time, past or future). (Inherited from ConcentratorBase.)
Public property | DownsampledMeasurements | Gets the total number of down-sampled measurements processed by the concentrator. (Inherited from ConcentratorBase.)
Public property | DownsamplingMethod | Gets or sets the DownsamplingMethod to be used by the concentrator. (Inherited from ConcentratorBase.)
Public property | Enabled | Gets or sets the current enabled state of concentrator. (Inherited from ConcentratorBase.)
Public property | ExpectedMeasurements | Gets or sets the expected number of measurements to be assigned to a single frame. (Inherited from ConcentratorBase.)
Public property | FramesAheadOfSchedule | Gets the total number of frames ahead of schedule processed by the concentrator. (Inherited from ConcentratorBase.)
Public property | FramesPerSecond | Gets or sets the number of frames per second.
Public property | ID | Gets or sets numeric ID associated with this action adapter.
Public property | IgnoreBadTimestamps | Gets or sets flag that determines if bad timestamps (as determined by measurement's timestamp quality) should be ignored when sorting measurements. (Inherited from ConcentratorBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the action adapter has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the action adapter expects.
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LagTicks | Gets defined past time deviation tolerance, in ticks. (Inherited from ConcentratorBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LastDiscardedMeasurement | Gets a reference the last IMeasurement that was discarded by the concentrator. (Inherited from ConcentratorBase.)
Public property | LastDiscardedMeasurementLatency | Gets the calculated latency of the last IMeasurement that was discarded by the concentrator. (Inherited from ConcentratorBase.)
Public property | LastFrame | Gets reference to the last published IFrame. (Inherited from ConcentratorBase.)
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values. (Inherited from ConcentratorBase.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | MaximumPublicationTimeout | Gets or sets the maximum frame publication timeout in milliseconds, set to Infinite(-1) to wait indefinitely. (Inherited from ConcentratorBase.)
Public property | MeasurementsSortedByArrival | Gets the total number of measurements that were sorted by arrival because the measurement reported a bad timestamp quality. (Inherited from ConcentratorBase.)
Public property | MinimumMeasurementsToUse | Gets or sets minimum number of input measurements required for adapter. Set to -1 to require all.
Public property | MissedSortsByTimeout | Gets the total number of missed sorts by timeout processed by the concentrator. (Inherited from ConcentratorBase.)
Public property | Name | Gets name of the action adapter.
Public property | OutputMeasurements | Gets or sets output measurements that the action adapter will produce, if any.
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | PerformTimestampReasonabilityCheck | Gets or sets flag that determines if timestamp reasonability checks should be performed on incoming measurements (i.e., measurement timestamps are compared to system clock for reasonability using LeadTime tolerance). (Inherited from ConcentratorBase.)
Public property | ProcessByReceivedTimestamp | Gets or sets flag that determines if concentrator should sort measurements by received time. (Inherited from ConcentratorBase.)
Public property | ProcessedMeasurements | Gets the total number of measurements successfully sorted. (Inherited from ConcentratorBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from ConcentratorBase.)
Public property | PublishedFrames | Gets the total number of published frames. (Inherited from ConcentratorBase.)
Public property | PublishedMeasurements | Gets the total number of published measurements. (Inherited from ConcentratorBase.)
Public property | QueueState | Gets detailed state of concentrator frame queue. (Inherited from ConcentratorBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement, or UtcNow if no measurement timestamps are within time deviation tolerances as specified by the LeadTime value. (Inherited from ConcentratorBase.)
Public property | ReceivedMeasurements | Gets the total number of measurements ever requested for sorting. (Inherited from ConcentratorBase.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | RunTime | Gets the total amount of time, in seconds, that the concentrator has been active. (Inherited from ConcentratorBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTime | Gets the UTC time the concentrator was started. (Inherited from ConcentratorBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Returns the detailed status of the action adapter. (Overrides ConcentratorBaseStatus.)
Public property | StopTime | Gets the UTC time the concentrator was stopped. (Inherited from ConcentratorBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing.
Public property | TicksPerFrame | Gets the number of ticks per frame. (Inherited from ConcentratorBase.)
Public property | TimeResolution | Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame. (Inherited from ConcentratorBase.)
Public property | TotalPublicationTime | Gets the total number of seconds frames have spent in the publication process since concentrator started. (Inherited from ConcentratorBase.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values. (Inherited from ConcentratorBase.)
Public property | TrackPublishedTimestamp | Gets or sets flag that determines if system should track timestamp of publication for all frames and measurements. (Inherited from ConcentratorBase.)
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real-time. (Inherited from ConcentratorBase.)
Public property | UsePrecisionTimer | Gets or sets flag that determines if precision timer should be used for frame publication. (Inherited from ConcentratorBase.)
Public property | WaitHandleExpirations | Gets the total number of wait handle expirations encountered due to delayed precision timer releases. (Inherited from ConcentratorBase.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from ConcentratorBase.)
Public event | Disposed | This event is raised when ConcentratorBase is disposed. (Inherited from ConcentratorBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | NewMeasurements | Provides new measurements from action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | This event is raised if there is an exception encountered while attempting to process a frame in the sample queue. (Inherited from ConcentratorBase.)
Public event | StatusMessage | Provides status messages to consumer.
Public event | UnpublishedSamples | This event is raised every 5 seconds allowing consumer to track current number of unpublished seconds of data in the queue. (Inherited from ConcentratorBase.)
Top
Remarks
This base class acts as a measurement concentrator which time aligns all incoming measurements for proper processing. Derived classes are expected to override PublishFrame(IFrame, Int32) to handle time aligned measurements and call OnNewMeasurements(ICollectionIMeasurement) for any new measurements that may get created.
See Also

Reference

GSF.TimeSeries.Adapters Namespace


ActionAdapterBase Constructor

Grid Solutions Framework ActionAdapterBase Constructor
Creates a new ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ActionAdapterBase()
Protected Sub New
new : unit -> ActionAdapterBase
GSF.TimeSeries.Adapters.ActionAdapterBase = function();
protected:
ActionAdapterBase()
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase Methods

Grid Solutions Framework ActionAdapterBase Methods

The ActionAdapterBase type exposes the following members.

Methods
 | Name | Description
Protected method | AssignMeasurementToFrame | Assigns IMeasurement to its associated IFrame. (Inherited from ConcentratorBase.)
Protected method | CreateNewFrame | Creates a new IFrame for the given timestamp. (Inherited from ConcentratorBase.)
Public method | Dispose | Releases all the resources used by the ConcentratorBase object. (Inherited from ConcentratorBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ActionAdapterBase object and optionally releases the managed resources. (Overrides ConcentratorBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | ExamineQueueState | Examines the concentrator frame queue state of the ActionAdapterBase.
Protected method | Finalize | Releases the unmanaged resources before the ConcentratorBase object is reclaimed by GC. (Inherited from ConcentratorBase.)
Public method | GetHashCode | Serves as a hash function for the current ActionAdapterBase. (Overrides ObjectGetHashCode.)
Public method | GetShortStatus | Gets a short one-line status of this ActionAdapterBase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes ActionAdapterBase.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MillisecondsFromRealTime | Returns the deviation, in milliseconds, that the given number of ticks is from real-time (i.e., RealTime). (Inherited from ConcentratorBase.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from ConcentratorBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises the ProcessException event. (Inherited from ConcentratorBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from ConcentratorBase.)
Protected method | PublishFrame | Publish IFrame of time-aligned collection of IMeasurement values that arrived within the concentrator's defined LagTime. (Inherited from ConcentratorBase.)
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | ResetStatistics | Resets the statistics of the ActionAdapterBase. (Overrides ConcentratorBaseResetStatistics.)
Public method | SecondsFromRealTime | Returns the deviation, in seconds, that the given number of ticks is from real-time (i.e., RealTime). (Inherited from ConcentratorBase.)
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter.
Public method | SortMeasurement | Sorts the IMeasurement placing the data point in its proper IFrame. (Inherited from ConcentratorBase.)
Public method | SortMeasurements | Sorts each IMeasurement placing each data point in its proper IFrame. (Inherited from ConcentratorBase.)
Public method | Start | Starts the ActionAdapterBase or restarts it if it is already running. (Overrides ConcentratorBaseStart.)
Public method | Stop | Stops the ActionAdapterBase. (Overrides ConcentratorBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TryGetMinimumNeededMeasurements | Attempts to retrieve the minimum needed number of measurements from the frame (as specified by MinimumMeasurementsToUse)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Dispose Method

Grid Solutions Framework ActionAdapterBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ConcentratorBase object. (Inherited from ConcentratorBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ActionAdapterBase object and optionally releases the managed resources. (Overrides ConcentratorBaseDispose(Boolean).)
Top
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Dispose Method (Boolean)

Grid Solutions Framework ActionAdapterBaseDispose Method (Boolean)
Releases the unmanaged resources used by the ActionAdapterBase object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ActionAdapterBase Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.ExamineQueueState Method

Grid Solutions Framework ActionAdapterBaseExamineQueueState Method
Examines the concentrator frame queue state of the ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Examines concentration frame queue state.", new string[] { ... })]
public void ExamineQueueState()
<AdapterCommandAttribute("Examines concentration frame queue state.", New String() { ... })>
Public Sub ExamineQueueState
[<AdapterCommandAttribute("Examines concentration frame queue state.", new string[] { ... })>]
member ExamineQueueState : unit -> unit

function ExamineQueueState();
public:
[AdapterCommandAttribute(L"Examines concentration frame queue state.", __gc new array<String^>^ { ... })]
void ExamineQueueState()
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.GetHashCode Method

Grid Solutions Framework ActionAdapterBaseGetHashCode Method
Serves as a hash function for the current ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current ActionAdapterBase.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.GetShortStatus Method

Grid Solutions Framework ActionAdapterBaseGetShortStatus Method
Gets a short one-line status of this ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string GetShortStatus(
    int maxLength
)
Public Overridable Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string
override GetShortStatus :
        maxLength : int -> string
function GetShortStatus(maxLength);
public:
virtual String^ GetShortStatus(
    int maxLength
)

Parameters

maxLength
Type: SystemInt32
Maximum number of available characters for display.

Return Value

Type: String
A short one-line summary of the current status of this AdapterBase.

Implements

IAdapterGetShortStatus(Int32)
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Initialize Method

Grid Solutions Framework ActionAdapterBaseInitialize Method
Initializes ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize()

Implements

ISupportLifecycleInitialize
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OnConfigurationChanged Method

Grid Solutions Framework ActionAdapterBaseOnConfigurationChanged Method
Raises ConfigurationChanged event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConfigurationChanged()
Protected Overridable Sub OnConfigurationChanged
abstract OnConfigurationChanged : unit -> unit
override OnConfigurationChanged : unit -> unit
function OnConfigurationChanged();
protected:
virtual void OnConfigurationChanged()
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OnInputMeasurementKeysUpdated Method

Grid Solutions Framework ActionAdapterBaseOnInputMeasurementKeysUpdated Method
Raises InputMeasurementKeysUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnInputMeasurementKeysUpdated()
Protected Overridable Sub OnInputMeasurementKeysUpdated
abstract OnInputMeasurementKeysUpdated : unit -> unit
override OnInputMeasurementKeysUpdated : unit -> unit
function OnInputMeasurementKeysUpdated();
protected:
virtual void OnInputMeasurementKeysUpdated()
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OnNewMeasurements Method

Grid Solutions Framework ActionAdapterBaseOnNewMeasurements Method
Raises the NewMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNewMeasurements(
    ICollection<IMeasurement> measurements
)
Protected Overridable Sub OnNewMeasurements (
    measurements As ICollection(Of IMeasurement)
)
abstract OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
override OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
function OnNewMeasurements(measurements);
protected:
virtual void OnNewMeasurements(
    ICollection<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericICollection IMeasurement

[Missing <param name="measurements"/> documentation for "M:GSF.TimeSeries.Adapters.ActionAdapterBase.OnNewMeasurements(System.Collections.Generic.ICollection{GSF.TimeSeries.IMeasurement})"]

See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OnOutputMeasurementsUpdated Method

Grid Solutions Framework ActionAdapterBaseOnOutputMeasurementsUpdated Method
Raises OutputMeasurementsUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOutputMeasurementsUpdated()
Protected Overridable Sub OnOutputMeasurementsUpdated
abstract OnOutputMeasurementsUpdated : unit -> unit
override OnOutputMeasurementsUpdated : unit -> unit
function OnOutputMeasurementsUpdated();
protected:
virtual void OnOutputMeasurementsUpdated()
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OnStatusMessage Method

Grid Solutions Framework ActionAdapterBaseOnStatusMessage Method
Overload List
 | Name | Description
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Top
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OnStatusMessage Method (String)

Grid Solutions Framework ActionAdapterBaseOnStatusMessage Method (String)
Raises the StatusMessage event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string status
)
Protected Overridable Sub OnStatusMessage (
    status As String
)
abstract OnStatusMessage :
        status : string -> unit
override OnStatusMessage :
        status : string -> unit
function OnStatusMessage(status);
protected:
virtual void OnStatusMessage(
    String^ status
)

Parameters

status
Type: SystemString
New status message.
See Also

Reference

ActionAdapterBase Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OnStatusMessage Method (String, Object[])

Grid Solutions Framework ActionAdapterBaseOnStatusMessage Method (String, Object)
Raises the StatusMessage event with a formatted status message.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string formattedStatus,
    params Object[] args
)
Protected Overridable Sub OnStatusMessage (
    formattedStatus As String,
    ParamArray args As Object()
)
abstract OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
override OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
function OnStatusMessage(formattedStatus, ... args);
protected:
virtual void OnStatusMessage(
    String^ formattedStatus,
    ... array<Object^>^ args
)

Parameters

formattedStatus
Type: SystemString
Formatted status message.
args
Type: SystemObject
Arguments for formattedStatus.
Remarks
This overload combines string.Format and SendStatusMessage for convenience.
See Also

Reference

ActionAdapterBase Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.QueueMeasurementsForProcessing Method

Grid Solutions Framework ActionAdapterBaseQueueMeasurementsForProcessing Method
Queues a collection of measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overridable Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Collection of measurements to queue for processing.

Implements

IActionAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
Remarks
Measurements are filtered against the defined InputMeasurementKeys.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.ResetStatistics Method

Grid Solutions Framework ActionAdapterBaseResetStatistics Method
Resets the statistics of the ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Resets the statistics of the action adapter.", new string[] { ... })]
public override void ResetStatistics()
<AdapterCommandAttribute("Resets the statistics of the action adapter.", New String() { ... })>
Public Overrides Sub ResetStatistics
[<AdapterCommandAttribute("Resets the statistics of the action adapter.",
    new string[] { ... })>]
abstract ResetStatistics : unit -> unit
[<AdapterCommandAttribute("Resets the statistics of the action adapter.",
    new string[] { ... })>]
override ResetStatistics : unit -> unit
function ResetStatistics();
public:
[AdapterCommandAttribute(L"Resets the statistics of the action adapter.",
    __gc new array<String^>^ { ... })]
virtual void ResetStatistics() override
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.SetInitializedState Method

Grid Solutions Framework ActionAdapterBaseSetInitializedState Method
Manually sets the initialized state of the AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Manually sets the initialized state of the action adapter.",
    new string[] { ... })]
public virtual void SetInitializedState(
    bool initialized
)
<AdapterCommandAttribute("Manually sets the initialized state of the action adapter.",
    New String() { ... })>
Public Overridable Sub SetInitializedState (
    initialized As Boolean
)
[<AdapterCommandAttribute("Manually sets the initialized state of the action adapter.",
    new string[] { ... })>]
abstract SetInitializedState :
        initialized : bool -> unit
[<AdapterCommandAttribute("Manually sets the initialized state of the action adapter.",
    new string[] { ... })>]
override SetInitializedState :
        initialized : bool -> unit
function SetInitializedState(initialized);
public:
[AdapterCommandAttribute(L"Manually sets the initialized state of the action adapter.",
    __gc new array<String^>^ { ... })]
virtual void SetInitializedState(
    bool initialized
)

Parameters

initialized
Type: SystemBoolean
Desired initialized state.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.SetTemporalConstraint Method

Grid Solutions Framework ActionAdapterBaseSetTemporalConstraint Method
Defines a temporal processing constraint for the adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    new string[] { ... })]
public virtual void SetTemporalConstraint(
    string startTime,
    string stopTime,
    string constraintParameters
)
<AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    New String() { ... })>
Public Overridable Sub SetTemporalConstraint (
    startTime As String,
    stopTime As String,
    constraintParameters As String
)
[<AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    new string[] { ... })>]
abstract SetTemporalConstraint :
        startTime : string *
        stopTime : string *
        constraintParameters : string -> unit
[<AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    new string[] { ... })>]
override SetTemporalConstraint :
        startTime : string *
        stopTime : string *
        constraintParameters : string -> unit
function SetTemporalConstraint(startTime, stopTime, constraintParameters);
public:
[AdapterCommandAttribute(L"Defines a temporal processing constraint for the adapter.",
    __gc new array<String^>^ { ... })]
virtual void SetTemporalConstraint(
    String^ startTime,
    String^ stopTime,
    String^ constraintParameters
)

Parameters

startTime
Type: SystemString
Defines a relative or exact start time for the temporal constraint.
stopTime
Type: SystemString
Defines a relative or exact stop time for the temporal constraint.
constraintParameters
Type: SystemString
Defines any temporal parameters related to the constraint.

Implements

IAdapterSetTemporalConstraint(String, String, String)
Remarks

This method defines a temporal processing constraint for an adapter, i.e., the start and stop time over which an adapter will process data. Actual implementation of the constraint will be adapter specific. Implementations should be able to dynamically handle multiple calls to this function with new constraints. Passing in null for the startTime and stopTime should cancel the temporal constraint and return the adapter to standard / real-time operation.

The startTime and stopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Start Method

Grid Solutions Framework ActionAdapterBaseStart Method
Starts the ActionAdapterBase or restarts it if it is already running.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Starts the action adapter or restarts it if it is already running.",
    new string[] { ... })]
public override void Start()
<AdapterCommandAttribute("Starts the action adapter or restarts it if it is already running.",
    New String() { ... })>
Public Overrides Sub Start
[<AdapterCommandAttribute("Starts the action adapter or restarts it if it is already running.",
    new string[] { ... })>]
abstract Start : unit -> unit
[<AdapterCommandAttribute("Starts the action adapter or restarts it if it is already running.",
    new string[] { ... })>]
override Start : unit -> unit
function Start();
public:
[AdapterCommandAttribute(L"Starts the action adapter or restarts it if it is already running.",
    __gc new array<String^>^ { ... })]
virtual void Start() override

Implements

IAdapterStart
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Stop Method

Grid Solutions Framework ActionAdapterBaseStop Method
Stops the ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Stops the action adapter.", new string[] { ... })]
public override void Stop()
<AdapterCommandAttribute("Stops the action adapter.", New String() { ... })>
Public Overrides Sub Stop
[<AdapterCommandAttribute("Stops the action adapter.", new string[] { ... })>]
abstract Stop : unit -> unit
[<AdapterCommandAttribute("Stops the action adapter.", new string[] { ... })>]
override Stop : unit -> unit
function Stop();
public:
[AdapterCommandAttribute(L"Stops the action adapter.", __gc new array<String^>^ { ... })]
virtual void Stop() override

Implements

IAdapterStop
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.TryGetMinimumNeededMeasurements Method

Grid Solutions Framework ActionAdapterBaseTryGetMinimumNeededMeasurements Method
Attempts to retrieve the minimum needed number of measurements from the frame (as specified by MinimumMeasurementsToUse)

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool TryGetMinimumNeededMeasurements(
    IFrame frame,
    ref IMeasurement[] measurements
)
Protected Overridable Function TryGetMinimumNeededMeasurements (
    frame As IFrame,
    ByRef measurements As IMeasurement()
) As Boolean
abstract TryGetMinimumNeededMeasurements :
        frame : IFrame *
        measurements : IMeasurement[] byref -> bool
override TryGetMinimumNeededMeasurements :
        frame : IFrame *
        measurements : IMeasurement[] byref -> bool
function TryGetMinimumNeededMeasurements(frame, measurements);
protected:
virtual bool TryGetMinimumNeededMeasurements(
    IFrame^ frame,
    array<IMeasurement^>^% measurements
)

Parameters

frame
Type: GSF.TimeSeriesIFrame
Source frame for the measurements
measurements
Type: GSF.TimeSeriesIMeasurement
Return array of measurements

Return Value

Type: Boolean
True if minimum needed number of measurements were returned in measurement array
Remarks

Remember this function will *only* return the minimum needed number of measurements, no more. If you want to use all available measurements in your adapter you should just use Frame.Measurements.Values directly.

Note that the measurements array parameter will be created if the reference is null, otherwise if caller creates array it must be sized to MinimumMeasurementsToUse

See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase Properties

Grid Solutions Framework ActionAdapterBase Properties

The ActionAdapterBase type exposes the following members.

Properties
 | Name | Description
Public property | AllowPreemptivePublishing | Gets or sets flag that allows system to preemptively publish frames assuming all ExpectedMeasurements have arrived. (Inherited from ConcentratorBase.)
Public property | AllowSortsByArrival | Gets or sets flag that determines whether or not to allow incoming measurements with bad timestamps to be sorted by arrival time. (Inherited from ConcentratorBase.)
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand.
Public property | AveragePublicationTimePerFrame | Gets the average required frame publication time, in seconds. (Inherited from ConcentratorBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to action adapter.
Public property | DataSource | Gets or sets DataSet based data source available to this ActionAdapterBase.
Public property | DiscardedMeasurements | Gets the total number of measurements that have been discarded because of old timestamps (i.e., measurements that were outside the time deviation tolerance from base time, past or future). (Inherited from ConcentratorBase.)
Public property | DownsampledMeasurements | Gets the total number of down-sampled measurements processed by the concentrator. (Inherited from ConcentratorBase.)
Public property | DownsamplingMethod | Gets or sets the DownsamplingMethod to be used by the concentrator. (Inherited from ConcentratorBase.)
Public property | Enabled | Gets or sets the current enabled state of concentrator. (Inherited from ConcentratorBase.)
Public property | ExpectedMeasurements | Gets or sets the expected number of measurements to be assigned to a single frame. (Inherited from ConcentratorBase.)
Public property | FramesAheadOfSchedule | Gets the total number of frames ahead of schedule processed by the concentrator. (Inherited from ConcentratorBase.)
Public property | FramesPerSecond | Gets or sets the number of frames per second.
Public property | ID | Gets or sets numeric ID associated with this action adapter.
Public property | IgnoreBadTimestamps | Gets or sets flag that determines if bad timestamps (as determined by measurement's timestamp quality) should be ignored when sorting measurements. (Inherited from ConcentratorBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the action adapter has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the action adapter expects.
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LagTicks | Gets defined past time deviation tolerance, in ticks. (Inherited from ConcentratorBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LastDiscardedMeasurement | Gets a reference the last IMeasurement that was discarded by the concentrator. (Inherited from ConcentratorBase.)
Public property | LastDiscardedMeasurementLatency | Gets the calculated latency of the last IMeasurement that was discarded by the concentrator. (Inherited from ConcentratorBase.)
Public property | LastFrame | Gets reference to the last published IFrame. (Inherited from ConcentratorBase.)
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values. (Inherited from ConcentratorBase.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | MaximumPublicationTimeout | Gets or sets the maximum frame publication timeout in milliseconds, set to Infinite(-1) to wait indefinitely. (Inherited from ConcentratorBase.)
Public property | MeasurementsSortedByArrival | Gets the total number of measurements that were sorted by arrival because the measurement reported a bad timestamp quality. (Inherited from ConcentratorBase.)
Public property | MinimumMeasurementsToUse | Gets or sets minimum number of input measurements required for adapter. Set to -1 to require all.
Public property | MissedSortsByTimeout | Gets the total number of missed sorts by timeout processed by the concentrator. (Inherited from ConcentratorBase.)
Public property | Name | Gets name of the action adapter.
Public property | OutputMeasurements | Gets or sets output measurements that the action adapter will produce, if any.
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | PerformTimestampReasonabilityCheck | Gets or sets flag that determines if timestamp reasonability checks should be performed on incoming measurements (i.e., measurement timestamps are compared to system clock for reasonability using LeadTime tolerance). (Inherited from ConcentratorBase.)
Public property | ProcessByReceivedTimestamp | Gets or sets flag that determines if concentrator should sort measurements by received time. (Inherited from ConcentratorBase.)
Public property | ProcessedMeasurements | Gets the total number of measurements successfully sorted. (Inherited from ConcentratorBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from ConcentratorBase.)
Public property | PublishedFrames | Gets the total number of published frames. (Inherited from ConcentratorBase.)
Public property | PublishedMeasurements | Gets the total number of published measurements. (Inherited from ConcentratorBase.)
Public property | QueueState | Gets detailed state of concentrator frame queue. (Inherited from ConcentratorBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement, or UtcNow if no measurement timestamps are within time deviation tolerances as specified by the LeadTime value. (Inherited from ConcentratorBase.)
Public property | ReceivedMeasurements | Gets the total number of measurements ever requested for sorting. (Inherited from ConcentratorBase.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | RunTime | Gets the total amount of time, in seconds, that the concentrator has been active. (Inherited from ConcentratorBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTime | Gets the UTC time the concentrator was started. (Inherited from ConcentratorBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Returns the detailed status of the action adapter. (Overrides ConcentratorBaseStatus.)
Public property | StopTime | Gets the UTC time the concentrator was stopped. (Inherited from ConcentratorBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing.
Public property | TicksPerFrame | Gets the number of ticks per frame. (Inherited from ConcentratorBase.)
Public property | TimeResolution | Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame. (Inherited from ConcentratorBase.)
Public property | TotalPublicationTime | Gets the total number of seconds frames have spent in the publication process since concentrator started. (Inherited from ConcentratorBase.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values. (Inherited from ConcentratorBase.)
Public property | TrackPublishedTimestamp | Gets or sets flag that determines if system should track timestamp of publication for all frames and measurements. (Inherited from ConcentratorBase.)
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real-time. (Inherited from ConcentratorBase.)
Public property | UsePrecisionTimer | Gets or sets flag that determines if precision timer should be used for frame publication. (Inherited from ConcentratorBase.)
Public property | WaitHandleExpirations | Gets the total number of wait handle expirations encountered due to delayed precision timer releases. (Inherited from ConcentratorBase.)
Top
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.AutoStart Property

Grid Solutions Framework ActionAdapterBaseAutoStart Property
Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool AutoStart { get; set; }
Public Overridable Property AutoStart As Boolean
    Get
    Set
abstract AutoStart : bool with get, set
override AutoStart : bool with get, set
function get_AutoStart();
function set_AutoStart(value);
public:
virtual property bool AutoStart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IAdapterAutoStart
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.ConnectionString Property

Grid Solutions Framework ActionAdapterBaseConnectionString Property
Gets or sets key/value pair connection information specific to action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ConnectionString { get; set; }
Public Overridable Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set
override ConnectionString : string with get, set
function get_ConnectionString();
function set_ConnectionString(value);
public:
virtual property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterConnectionString
Remarks

Example connection string using manually defined measurements:
framesPerSecond=30; lagTime=1.0; leadTime=0.5; minimumMeasurementsToUse=-1; useLocalClockAsRealTime=true; allowSortsByArrival=false;
inputMeasurementKeys={P1:1245;P1:1247;P2:1335};
outputMeasurements={P3:1345,60.0,1.0;P3:1346;P3:1347}
When defined manually, elements in key:
* inputMeasurementKeys are defined as "ArchiveSource:PointID"
* outputMeasurements are defined as "ArchiveSource:PointID,Adder,Multiplier", the adder and multiplier are optional defaulting to 0.0 and 1.0 respectively.

            Example connection string using measurements defined in a DataSource table:
framesPerSecond=30; lagTime=1.0; leadTime=0.5; minimumMeasurementsToUse=-1;
            useLocalClockAsRealTime=true; allowSortsByArrival=false;
inputMeasurementKeys={FILTER ActiveMeasurements WHERE Company='GSF' AND SignalType='FREQ' ORDER BY ID};
outputMeasurements={FILTER ActiveMeasurements WHERE SignalType IN ('IPHA','VPHA') AND Phase='+'}

Basic filtering syntax is as follows:

{FILTER <TableName> WHERE <Expression> [ORDER BY <SortField>]}

Source tables are expected to have at least the following fields:

Name | Type | Description.
ID | NVARCHAR | Measurement key formatted as: ArchiveSource:PointID.
PointTag | NVARCHAR | Point tag of measurement.
Adder | FLOAT | Adder to apply to value, if any (default to 0.0).
Multiplier | FLOAT | Multiplier to apply to value, if any (default to 1.0).

Note that framesPerSecond, lagTime and leadTime are required parameters, all other parameters are optional.

See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.DataSource Property

Grid Solutions Framework ActionAdapterBaseDataSource Property
Gets or sets DataSet based data source available to this ActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataSet DataSource { get; set; }
Public Overridable Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get ();
    void set (DataSet^ value);
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.FramesPerSecond Property

Grid Solutions Framework ActionAdapterBaseFramesPerSecond Property
Gets or sets the number of frames per second.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
public int FramesPerSecond { get; set; }
<ConnectionStringParameterAttribute>
Public Property FramesPerSecond As Integer
    Get
    Set
[<ConnectionStringParameterAttribute>]
member FramesPerSecond : int with get, set

function get_FramesPerSecond();
function set_FramesPerSecond(value);
public:
[ConnectionStringParameterAttribute]
property int FramesPerSecond {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Valid frame rates for a ConcentratorBase are greater than 0 frames per second.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.ID Property

Grid Solutions Framework ActionAdapterBaseID Property
Gets or sets numeric ID associated with this action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual uint ID { get; set; }
Public Overridable Property ID As UInteger
    Get
    Set
abstract ID : uint32 with get, set
override ID : uint32 with get, set
function get_ID();
function set_ID(value);
public:
virtual property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32

Implements

IAdapterID
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.InitializationTimeout Property

Grid Solutions Framework ActionAdapterBaseInitializationTimeout Property
Gets or sets maximum time system will wait during Start for initialization.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int InitializationTimeout { get; set; }
Public Overridable Property InitializationTimeout As Integer
    Get
    Set
abstract InitializationTimeout : int with get, set
override InitializationTimeout : int with get, set
function get_InitializationTimeout();
function set_InitializationTimeout(value);
public:
virtual property int InitializationTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IAdapterInitializationTimeout
Remarks
Set to Infinite to wait indefinitely.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Initialized Property

Grid Solutions Framework ActionAdapterBaseInitialized Property
Gets or sets flag indicating if the action adapter has been initialized successfully.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Initialized { get; set; }
Public Overridable Property Initialized As Boolean
    Get
    Set
abstract Initialized : bool with get, set
override Initialized : bool with get, set
function get_Initialized();
function set_Initialized(value);
public:
virtual property bool Initialized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IAdapterInitialized
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.InputMeasurementKeys Property

Grid Solutions Framework ActionAdapterBaseInputMeasurementKeys Property
Gets or sets primary keys of input measurements the action adapter expects.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)]
[DefaultValueAttribute(null)]
public virtual MeasurementKey[] InputMeasurementKeys { get; set; }
<ConnectionStringParameterAttribute>
<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    Nothing)>
<DefaultValueAttribute(Nothing)>
Public Overridable Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<DefaultValueAttribute(null)>]
abstract InputMeasurementKeys : MeasurementKey[] with get, set
[<ConnectionStringParameterAttribute>]
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<DefaultValueAttribute(null)>]
override InputMeasurementKeys : MeasurementKey[] with get, set
function get_InputMeasurementKeys();
function set_InputMeasurementKeys(value);
public:
[ConnectionStringParameterAttribute]
[CustomConfigurationEditorAttribute(L"GSF.TimeSeries.UI.WPF.dll", L"GSF.TimeSeries.UI.Editors.MeasurementEditor",
    nullptr)]
[DefaultValueAttribute(nullptr)]
virtual property array<MeasurementKey^>^ InputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IAdapterInputMeasurementKeys
Remarks
If your adapter needs to receive all measurements, you must explicitly set InputMeasurementKeys to null.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.InputSourceIDs Property

Grid Solutions Framework ActionAdapterBaseInputSourceIDs Property
Gets or sets Source values used to filter input measurement keys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] InputSourceIDs { get; set; }
Public Overridable Property InputSourceIDs As String()
    Get
    Set
abstract InputSourceIDs : string[] with get, set
override InputSourceIDs : string[] with get, set
function get_InputSourceIDs();
function set_InputSourceIDs(value);
public:
virtual property array<String^>^ InputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String

Implements

IActionAdapterInputSourceIDs
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.IsDisposed Property

Grid Solutions Framework ActionAdapterBaseIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.LagTime Property

Grid Solutions Framework ActionAdapterBaseLagTime Property
Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
public double LagTime { get; set; }
<ConnectionStringParameterAttribute>
Public Property LagTime As Double
    Get
    Set
[<ConnectionStringParameterAttribute>]
member LagTime : float with get, set

function get_LagTime();
function set_LagTime(value);
public:
[ConnectionStringParameterAttribute]
property double LagTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to past measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too old.

This becomes the amount of delay introduced by the concentrator to allow time for data to flow into the system.

See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.LeadTime Property

Grid Solutions Framework ActionAdapterBaseLeadTime Property
Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
public double LeadTime { get; set; }
<ConnectionStringParameterAttribute>
Public Property LeadTime As Double
    Get
    Set
[<ConnectionStringParameterAttribute>]
member LeadTime : float with get, set

function get_LeadTime();
function set_LeadTime(value);
public:
[ConnectionStringParameterAttribute]
property double LeadTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LeadTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to future measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too advanced.

This becomes the tolerated +/- accuracy of the local clock to real-time.

See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.MinimumMeasurementsToUse Property

Grid Solutions Framework ActionAdapterBaseMinimumMeasurementsToUse Property
Gets or sets minimum number of input measurements required for adapter. Set to -1 to require all.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int MinimumMeasurementsToUse { get; set; }
Public Overridable Property MinimumMeasurementsToUse As Integer
    Get
    Set
abstract MinimumMeasurementsToUse : int with get, set
override MinimumMeasurementsToUse : int with get, set
function get_MinimumMeasurementsToUse();
function set_MinimumMeasurementsToUse(value);
public:
virtual property int MinimumMeasurementsToUse {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Name Property

Grid Solutions Framework ActionAdapterBaseName Property
Gets name of the action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterName
IProvideStatusName
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OutputMeasurements Property

Grid Solutions Framework ActionAdapterBaseOutputMeasurements Property
Gets or sets output measurements that the action adapter will produce, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(null)]
[ConnectionStringParameterAttribute]
[CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)]
public virtual IMeasurement[] OutputMeasurements { get; set; }
<DefaultValueAttribute(Nothing)>
<ConnectionStringParameterAttribute>
<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    Nothing)>
Public Overridable Property OutputMeasurements As IMeasurement()
    Get
    Set
[<DefaultValueAttribute(null)>]
[<ConnectionStringParameterAttribute>]
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
abstract OutputMeasurements : IMeasurement[] with get, set
[<DefaultValueAttribute(null)>]
[<ConnectionStringParameterAttribute>]
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
override OutputMeasurements : IMeasurement[] with get, set
function get_OutputMeasurements();
function set_OutputMeasurements(value);
public:
[DefaultValueAttribute(nullptr)]
[ConnectionStringParameterAttribute]
[CustomConfigurationEditorAttribute(L"GSF.TimeSeries.UI.WPF.dll", L"GSF.TimeSeries.UI.Editors.MeasurementEditor",
    nullptr)]
virtual property array<IMeasurement^>^ OutputMeasurements {
    array<IMeasurement^>^ get ();
    void set (array<IMeasurement^>^ value);
}

Property Value

Type: IMeasurement

Implements

IAdapterOutputMeasurements
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OutputSourceIDs Property

Grid Solutions Framework ActionAdapterBaseOutputSourceIDs Property
Gets or sets Source values used to filter output measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] OutputSourceIDs { get; set; }
Public Overridable Property OutputSourceIDs As String()
    Get
    Set
abstract OutputSourceIDs : string[] with get, set
override OutputSourceIDs : string[] with get, set
function get_OutputSourceIDs();
function set_OutputSourceIDs(value);
public:
virtual property array<String^>^ OutputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String

Implements

IActionAdapterOutputSourceIDs
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.RequestedInputMeasurementKeys Property

Grid Solutions Framework ActionAdapterBaseRequestedInputMeasurementKeys Property
Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedInputMeasurementKeys { get; set; }
Public Overridable Property RequestedInputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedInputMeasurementKeys : MeasurementKey[] with get, set
override RequestedInputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedInputMeasurementKeys();
function set_RequestedInputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedInputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IActionAdapterRequestedInputMeasurementKeys
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.RequestedOutputMeasurementKeys Property

Grid Solutions Framework ActionAdapterBaseRequestedOutputMeasurementKeys Property
Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedOutputMeasurementKeys { get; set; }
Public Overridable Property RequestedOutputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
override RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedOutputMeasurementKeys();
function set_RequestedOutputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedOutputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IActionAdapterRequestedOutputMeasurementKeys
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.RespectInputDemands Property

Grid Solutions Framework ActionAdapterBaseRespectInputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RespectInputDemands { get; set; }
Public Overridable Property RespectInputDemands As Boolean
    Get
    Set
abstract RespectInputDemands : bool with get, set
override RespectInputDemands : bool with get, set
function get_RespectInputDemands();
function set_RespectInputDemands(value);
public:
virtual property bool RespectInputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IActionAdapterRespectInputDemands
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start input demands, as an example, this would be false for an action adapter that calculated measurement, but true for an action adapter used to archive inputs.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.RespectOutputDemands Property

Grid Solutions Framework ActionAdapterBaseRespectOutputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RespectOutputDemands { get; set; }
Public Overridable Property RespectOutputDemands As Boolean
    Get
    Set
abstract RespectOutputDemands : bool with get, set
override RespectOutputDemands : bool with get, set
function get_RespectOutputDemands();
function set_RespectOutputDemands(value);
public:
virtual property bool RespectOutputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IActionAdapterRespectOutputDemands
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start output demands, as an example, this would be true for an action adapter that calculated measurement, but false for an action adapter used to archive inputs.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Settings Property

Grid Solutions Framework ActionAdapterBaseSettings Property
Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<string, string> Settings { get; }
Public ReadOnly Property Settings As Dictionary(Of String, String)
    Get
abstract Settings : Dictionary<string, string> with get
override Settings : Dictionary<string, string> with get
function get_Settings();

public:
virtual property Dictionary<String^, String^>^ Settings {
    Dictionary<String^, String^>^ get () sealed;
}

Property Value

Type: Dictionary String, String

Implements

IAdapterSettings
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.StartTimeConstraint Property

Grid Solutions Framework ActionAdapterBaseStartTimeConstraint Property
Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DateTime StartTimeConstraint { get; }
Public Overridable ReadOnly Property StartTimeConstraint As DateTime
    Get
abstract StartTimeConstraint : DateTime with get
override StartTimeConstraint : DateTime with get
function get_StartTimeConstraint();

public:
virtual property DateTime StartTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime

Implements

IAdapterStartTimeConstraint
Remarks
This value will be MinValue when start time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.Status Property

Grid Solutions Framework ActionAdapterBaseStatus Property
Returns the detailed status of the action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
Remarks
Derived classes should extend status with implementation specific information.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.StopTimeConstraint Property

Grid Solutions Framework ActionAdapterBaseStopTimeConstraint Property
Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DateTime StopTimeConstraint { get; }
Public Overridable ReadOnly Property StopTimeConstraint As DateTime
    Get
abstract StopTimeConstraint : DateTime with get
override StopTimeConstraint : DateTime with get
function get_StopTimeConstraint();

public:
virtual property DateTime StopTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime

Implements

IAdapterStopTimeConstraint
Remarks
This value will be MaxValue when stop time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.SupportsTemporalProcessing Property

Grid Solutions Framework ActionAdapterBaseSupportsTemporalProcessing Property
Gets the flag indicating if this adapter supports temporal processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool SupportsTemporalProcessing { get; }
Public MustOverride ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get

function get_SupportsTemporalProcessing();

public:
virtual property bool SupportsTemporalProcessing {
    bool get () abstract;
}

Property Value

Type: Boolean

Implements

IAdapterSupportsTemporalProcessing
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase Events

Grid Solutions Framework ActionAdapterBase Events

The ActionAdapterBase type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from ConcentratorBase.)
Public event | Disposed | This event is raised when ConcentratorBase is disposed. (Inherited from ConcentratorBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | NewMeasurements | Provides new measurements from action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | This event is raised if there is an exception encountered while attempting to process a frame in the sample queue. (Inherited from ConcentratorBase.)
Public event | StatusMessage | Provides status messages to consumer.
Public event | UnpublishedSamples | This event is raised every 5 seconds allowing consumer to track current number of unpublished seconds of data in the queue. (Inherited from ConcentratorBase.)
Top
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.ConfigurationChanged Event

Grid Solutions Framework ActionAdapterBaseConfigurationChanged Event
Event is raised when adapter is aware of a configuration change.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
override ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
public:
virtual  event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterConfigurationChanged
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.InputMeasurementKeysUpdated Event

Grid Solutions Framework ActionAdapterBaseInputMeasurementKeysUpdated Event
Event is raised when InputMeasurementKeys are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler InputMeasurementKeysUpdated
Public Event InputMeasurementKeysUpdated As EventHandler
abstract InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>
override InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>
function add_InputMeasurementKeysUpdated(value);
function remove_InputMeasurementKeysUpdated(value);
public:
virtual  event EventHandler^ InputMeasurementKeysUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterInputMeasurementKeysUpdated
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.NewMeasurements Event

Grid Solutions Framework ActionAdapterBaseNewMeasurements Event
Provides new measurements from action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICollection<IMeasurement>>> NewMeasurements
Public Event NewMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
override NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
function add_NewMeasurements(value);
function remove_NewMeasurements(value);
public:
virtual  event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ NewMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement

Implements

IActionAdapterNewMeasurements
Remarks
Argument is a collection of new measurements for host to process.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.OutputMeasurementsUpdated Event

Grid Solutions Framework ActionAdapterBaseOutputMeasurementsUpdated Event
Event is raised when OutputMeasurements are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler OutputMeasurementsUpdated
Public Event OutputMeasurementsUpdated As EventHandler
abstract OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>
override OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>
function add_OutputMeasurementsUpdated(value);
function remove_OutputMeasurementsUpdated(value);
public:
virtual  event EventHandler^ OutputMeasurementsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterOutputMeasurementsUpdated
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterBase.StatusMessage Event

Grid Solutions Framework ActionAdapterBaseStatusMessage Event
Provides status messages to consumer.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IAdapterStatusMessage
Remarks
Argument is new status message.
See Also

Reference

ActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection Class

Grid Solutions Framework ActionAdapterCollection Class
Represents a collection of IActionAdapter implementations.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IActionAdapter
GSF.CollectionsListCollection IActionAdapter
GSF.TimeSeries.AdaptersAdapterCollectionBase IActionAdapter
GSF.TimeSeries.AdaptersActionAdapterCollection
GSF.TimeSeries.TransportDataPublisher

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ActionAdapterCollection : AdapterCollectionBase<IActionAdapter>,
    IActionAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public Class ActionAdapterCollection
    Inherits AdapterCollectionBase(Of IActionAdapter)
    Implements IActionAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
type ActionAdapterCollection =
    class
        inherit AdapterCollectionBase<IActionAdapter>
        interface IActionAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.ActionAdapterCollection = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.ActionAdapterCollection',
    GSF.TimeSeries.Adapters.AdapterCollectionBase`1,
    GSF.TimeSeries.Adapters.IActionAdapter,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class ActionAdapterCollection : public AdapterCollectionBase<IActionAdapter^>,
    IActionAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The ActionAdapterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ActionAdapterCollection | Constructs a new instance of the ActionAdapterCollection.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Unwires events and disposes of IActionAdapter implementation. (Overrides AdapterCollectionBaseTDisposeItem(T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Initializes the ActionAdapterCollection. (Overrides AdapterCollectionBaseTInitialize.)
Protected method | InitializeItem | Wires events and initializes new IActionAdapter implementation. (Overrides AdapterCollectionBaseTInitializeItem(T).)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnRequestTemporalSupport | Raises RequestTemporalSupport event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing to each IActionAdapter implementation in this ActionAdapterCollection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Inherited from AdapterCollectionBaseT.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this ActionAdapterCollection. (Overrides AdapterCollectionBaseTStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | NewMeasurements | This event will be raised when there are new measurements available from the action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | RequestTemporalSupport | Event is raised when temporal support is requested.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection Constructor

Grid Solutions Framework ActionAdapterCollection Constructor
Constructs a new instance of the ActionAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ActionAdapterCollection()
Public Sub New
new : unit -> ActionAdapterCollection
GSF.TimeSeries.Adapters.ActionAdapterCollection = function();
public:
ActionAdapterCollection()
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection Methods

Grid Solutions Framework ActionAdapterCollection Methods

The ActionAdapterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Unwires events and disposes of IActionAdapter implementation. (Overrides AdapterCollectionBaseTDisposeItem(T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Initializes the ActionAdapterCollection. (Overrides AdapterCollectionBaseTInitialize.)
Protected method | InitializeItem | Wires events and initializes new IActionAdapter implementation. (Overrides AdapterCollectionBaseTInitializeItem(T).)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnRequestTemporalSupport | Raises RequestTemporalSupport event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing to each IActionAdapter implementation in this ActionAdapterCollection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.DisposeItem Method

Grid Solutions Framework ActionAdapterCollectionDisposeItem Method
Unwires events and disposes of IActionAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void DisposeItem(
    IActionAdapter item
)
Protected Overrides Sub DisposeItem (
    item As IActionAdapter
)
abstract DisposeItem :
        item : IActionAdapter -> unit
override DisposeItem :
        item : IActionAdapter -> unit
function DisposeItem(item);
protected:
virtual void DisposeItem(
    IActionAdapter^ item
) override

Parameters

item
Type: GSF.TimeSeries.AdaptersIActionAdapter
IActionAdapter to dispose.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.Initialize Method

Grid Solutions Framework ActionAdapterCollectionInitialize Method
Initializes the ActionAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.InitializeItem Method

Grid Solutions Framework ActionAdapterCollectionInitializeItem Method
Wires events and initializes new IActionAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InitializeItem(
    IActionAdapter item
)
Protected Overrides Sub InitializeItem (
    item As IActionAdapter
)
abstract InitializeItem :
        item : IActionAdapter -> unit
override InitializeItem :
        item : IActionAdapter -> unit
function InitializeItem(item);
protected:
virtual void InitializeItem(
    IActionAdapter^ item
) override

Parameters

item
Type: GSF.TimeSeries.AdaptersIActionAdapter
New IActionAdapter implementation.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.OnDiscardingMeasurements Method

Grid Solutions Framework ActionAdapterCollectionOnDiscardingMeasurements Method
Raises the DiscardingMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDiscardingMeasurements(
    IEnumerable<IMeasurement> measurements
)
Protected Overridable Sub OnDiscardingMeasurements (
    measurements As IEnumerable(Of IMeasurement)
)
abstract OnDiscardingMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
override OnDiscardingMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
function OnDiscardingMeasurements(measurements);
protected:
virtual void OnDiscardingMeasurements(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Enumeration of IMeasurement values being discarded.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.OnNewMeasurements Method

Grid Solutions Framework ActionAdapterCollectionOnNewMeasurements Method
Raises the NewMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNewMeasurements(
    ICollection<IMeasurement> measurements
)
Protected Overridable Sub OnNewMeasurements (
    measurements As ICollection(Of IMeasurement)
)
abstract OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
override OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
function OnNewMeasurements(measurements);
protected:
virtual void OnNewMeasurements(
    ICollection<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericICollection IMeasurement
New measurements.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.OnRequestTemporalSupport Method

Grid Solutions Framework ActionAdapterCollectionOnRequestTemporalSupport Method
Raises RequestTemporalSupport event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRequestTemporalSupport()
Protected Overridable Sub OnRequestTemporalSupport
abstract OnRequestTemporalSupport : unit -> unit
override OnRequestTemporalSupport : unit -> unit
function OnRequestTemporalSupport();
protected:
virtual void OnRequestTemporalSupport()
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.OnUnpublishedSamples Method

Grid Solutions Framework ActionAdapterCollectionOnUnpublishedSamples Method
Raises the UnpublishedSamples event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnpublishedSamples(
    int unpublishedSamples
)
Protected Overridable Sub OnUnpublishedSamples (
    unpublishedSamples As Integer
)
abstract OnUnpublishedSamples :
        unpublishedSamples : int -> unit
override OnUnpublishedSamples :
        unpublishedSamples : int -> unit
function OnUnpublishedSamples(unpublishedSamples);
protected:
virtual void OnUnpublishedSamples(
    int unpublishedSamples
)

Parameters

unpublishedSamples
Type: SystemInt32
Total number of unpublished seconds of data in the queue.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.QueueMeasurementsForProcessing Method

Grid Solutions Framework ActionAdapterCollectionQueueMeasurementsForProcessing Method
Queues a collection of measurements for processing to each IActionAdapter implementation in this ActionAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overridable Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Measurements to queue for processing.

Implements

IActionAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection Properties

Grid Solutions Framework ActionAdapterCollection Properties

The ActionAdapterCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Inherited from AdapterCollectionBaseT.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this ActionAdapterCollection. (Overrides AdapterCollectionBaseTStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.RespectInputDemands Property

Grid Solutions Framework ActionAdapterCollectionRespectInputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RespectInputDemands { get; set; }
Public Overridable Property RespectInputDemands As Boolean
    Get
    Set
abstract RespectInputDemands : bool with get, set
override RespectInputDemands : bool with get, set
function get_RespectInputDemands();
function set_RespectInputDemands(value);
public:
virtual property bool RespectInputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IActionAdapterRespectInputDemands
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start input demands, as an example, this would be false for an action adapter that calculated measurement, but true for an action adapter used to archive inputs.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.RespectOutputDemands Property

Grid Solutions Framework ActionAdapterCollectionRespectOutputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RespectOutputDemands { get; set; }
Public Overridable Property RespectOutputDemands As Boolean
    Get
    Set
abstract RespectOutputDemands : bool with get, set
override RespectOutputDemands : bool with get, set
function get_RespectOutputDemands();
function set_RespectOutputDemands(value);
public:
virtual property bool RespectOutputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IActionAdapterRespectOutputDemands
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start output demands, as an example, this would be true for an action adapter that calculated measurement, but false for an action adapter used to archive inputs.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.Status Property

Grid Solutions Framework ActionAdapterCollectionStatus Property
Gets the descriptive status of this ActionAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection Events

Grid Solutions Framework ActionAdapterCollection Events

The ActionAdapterCollection type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | NewMeasurements | This event will be raised when there are new measurements available from the action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | RequestTemporalSupport | Event is raised when temporal support is requested.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.DiscardingMeasurements Event

Grid Solutions Framework ActionAdapterCollectionDiscardingMeasurements Event
This event is raised if there are any measurements being discarded during the sorting process.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IEnumerable<IMeasurement>>> DiscardingMeasurements
Public Event DiscardingMeasurements As EventHandler(Of EventArgs(Of IEnumerable(Of IMeasurement)))
abstract DiscardingMeasurements : IEvent<EventHandler<EventArgs<IEnumerable<IMeasurement>>>,
    EventArgs<IEnumerable<IMeasurement>>>
override DiscardingMeasurements : IEvent<EventHandler<EventArgs<IEnumerable<IMeasurement>>>,
    EventArgs<IEnumerable<IMeasurement>>>
function add_DiscardingMeasurements(value);
function remove_DiscardingMeasurements(value);
public:
virtual  event EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ DiscardingMeasurements {
    void add (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IEnumerable IMeasurement

Implements

IActionAdapterDiscardingMeasurements
Remarks
Argument is the enumeration of IMeasurement values that are being discarded during the sorting process.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.NewMeasurements Event

Grid Solutions Framework ActionAdapterCollectionNewMeasurements Event
This event will be raised when there are new measurements available from the action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICollection<IMeasurement>>> NewMeasurements
Public Event NewMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
override NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
function add_NewMeasurements(value);
function remove_NewMeasurements(value);
public:
virtual  event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ NewMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement

Implements

IActionAdapterNewMeasurements
Remarks
Argument is collection of new measurements for host to process.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.RequestTemporalSupport Event

Grid Solutions Framework ActionAdapterCollectionRequestTemporalSupport Event
Event is raised when temporal support is requested.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler RequestTemporalSupport
Public Event RequestTemporalSupport As EventHandler
member RequestTemporalSupport : IEvent<EventHandler,
    EventArgs>

function add_RequestTemporalSupport(value);
function remove_RequestTemporalSupport(value);
public:
 event EventHandler^ RequestTemporalSupport {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


ActionAdapterCollection.UnpublishedSamples Event

Grid Solutions Framework ActionAdapterCollectionUnpublishedSamples Event
This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> UnpublishedSamples
Public Event UnpublishedSamples As EventHandler(Of EventArgs(Of Integer))
abstract UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
override UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
function add_UnpublishedSamples(value);
function remove_UnpublishedSamples(value);
public:
virtual  event EventHandler<EventArgs<int>^>^ UnpublishedSamples {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32

Implements

IActionAdapterUnpublishedSamples
Remarks
Argument is the total number of unpublished seconds of data.
See Also

Reference

ActionAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


AdapterBase Class

Grid Solutions Framework AdapterBase Class
Represents the base class for any adapter.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersAdapterBase
GSF.TimeSeries.AdaptersFacileActionAdapterBase
GSF.TimeSeries.AdaptersInputAdapterBase
GSF.TimeSeries.AdaptersOutputAdapterBase

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class AdapterBase : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus
Public MustInherit Class AdapterBase
    Implements IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
[<AbstractClassAttribute>]
type AdapterBase =
    class
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.AdapterBase = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.AdapterBase',
    null,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class AdapterBase abstract : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus

The AdapterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | AdapterBase | Constructs a new instance of the AdapterBase.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Overrides ObjectGetHashCode.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements.
Public method | Initialize | Initializes AdapterBase.
 | LoadInputSourceIDs | Loads an IOutputAdapter or IActionAdapter instance's input measurement keys from a specific set of source ID's.
 | LoadOutputSourceIDs | Loads an IInputAdapter or IActionAdapter instance's output measurements from a specific set of source ID's.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
 | ParseFilterExpression | Parses a standard FILTER styles expression into its constituent parts.
 | ParseInputMeasurementKeys | Parses input measurement keys from connection string setting.
 | ParseOutputMeasurementKeys | Parses output measurement keys from connection string setting.
 | ParseOutputMeasurements | Parses output measurements from connection string setting.
 | ParseTimeTag | Parses a string formatted as an absolute or relative time tag.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter.
Public method | Start | Starts the AdapterBase or restarts it if it is already running.
Public method | Stop | Stops the AdapterBase.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Fields
Name | Description
DefaultInitializationTimeout | Default initialization timeout.
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase.
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase.
Public property | Enabled | Gets or sets enabled state of this AdapterBase.
Public property | ID | Gets or sets numeric ID associated with this AdapterBase.
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval.
Public property | Name | Gets or sets the name of this AdapterBase.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTime | Gets the UTC time this AdapterBase was started.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Gets the status of this AdapterBase.
Public property | StopTime | Gets the UTC time this AdapterBase was stopped.
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Event is raised when AdapterBase is disposed.
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


AdapterBase Constructor

Grid Solutions Framework AdapterBase Constructor
Constructs a new instance of the AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AdapterBase()
Protected Sub New
new : unit -> AdapterBase
GSF.TimeSeries.Adapters.AdapterBase = function();
protected:
AdapterBase()
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase Fields

Grid Solutions Framework AdapterBase Fields

The AdapterBase type exposes the following members.

Fields
Name | Description
DefaultInitializationTimeout | Default initialization timeout.
Top
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.DefaultInitializationTimeout Field

Grid Solutions Framework AdapterBaseDefaultInitializationTimeout Field
Default initialization timeout.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultInitializationTimeout
Public Const DefaultInitializationTimeout As Integer
static val mutable DefaultInitializationTimeout: int
var GSF.TimeSeries.Adapters.AdapterBase.DefaultInitializationTimeout
public:
literal int DefaultInitializationTimeout

Field Value

Type: Int32
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase Methods

Grid Solutions Framework AdapterBase Methods

The AdapterBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Overrides ObjectGetHashCode.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements.
Public method | Initialize | Initializes AdapterBase.
 | LoadInputSourceIDs | Loads an IOutputAdapter or IActionAdapter instance's input measurement keys from a specific set of source ID's.
 | LoadOutputSourceIDs | Loads an IInputAdapter or IActionAdapter instance's output measurements from a specific set of source ID's.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
 | ParseFilterExpression | Parses a standard FILTER styles expression into its constituent parts.
 | ParseInputMeasurementKeys | Parses input measurement keys from connection string setting.
 | ParseOutputMeasurementKeys | Parses output measurement keys from connection string setting.
 | ParseOutputMeasurements | Parses output measurements from connection string setting.
 | ParseTimeTag | Parses a string formatted as an absolute or relative time tag.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter.
Public method | Start | Starts the AdapterBase or restarts it if it is already running.
Public method | Stop | Stops the AdapterBase.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Dispose Method

Grid Solutions Framework AdapterBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources.
Top
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Dispose Method

Grid Solutions Framework AdapterBaseDispose Method
Releases all the resources used by the AdapterBase object.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

AdapterBase Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


AdapterBase.Dispose Method (Boolean)

Grid Solutions Framework AdapterBaseDispose Method (Boolean)
Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

AdapterBase Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


AdapterBase.Finalize Method

Grid Solutions Framework AdapterBaseFinalize Method
Releases the unmanaged resources before the AdapterBase object is reclaimed by GC.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.GetHashCode Method

Grid Solutions Framework AdapterBaseGetHashCode Method
Serves as a hash function for the current AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A hash code for the current AdapterBase.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.GetShortStatus Method

Grid Solutions Framework AdapterBaseGetShortStatus Method
Gets a short one-line status of this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract string GetShortStatus(
    int maxLength
)
Public MustOverride Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string

function GetShortStatus(maxLength);
public:
virtual String^ GetShortStatus(
    int maxLength
) abstract

Parameters

maxLength
Type: SystemInt32
Maximum number of available characters for display.

Return Value

Type: String
A short one-line summary of the current status of this AdapterBase.

Implements

IAdapterGetShortStatus(Int32)
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.IncrementProcessedMeasurements Method

Grid Solutions Framework AdapterBaseIncrementProcessedMeasurements Method
Safely increments the total processed measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void IncrementProcessedMeasurements(
    long totalAdded
)
Protected Overridable Sub IncrementProcessedMeasurements (
    totalAdded As Long
)
abstract IncrementProcessedMeasurements :
        totalAdded : int64 -> unit
override IncrementProcessedMeasurements :
        totalAdded : int64 -> unit
function IncrementProcessedMeasurements(totalAdded);
protected:
virtual void IncrementProcessedMeasurements(
    long long totalAdded
)

Parameters

totalAdded
Type: SystemInt64

[Missing <param name="totalAdded"/> documentation for "M:GSF.TimeSeries.Adapters.AdapterBase.IncrementProcessedMeasurements(System.Int64)"]

See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Initialize Method

Grid Solutions Framework AdapterBaseInitialize Method
Initializes AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize()

Implements

ISupportLifecycleInitialize
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.LoadInputSourceIDs Method

Grid Solutions Framework AdapterBaseLoadInputSourceIDs Method
Loads an IOutputAdapter or IActionAdapter instance's input measurement keys from a specific set of source ID's.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void LoadInputSourceIDs(
    IAdapter adapter,
    string measurementTable = "ActiveMeasurements"
)
Public Shared Sub LoadInputSourceIDs (
    adapter As IAdapter,
    Optional measurementTable As String = "ActiveMeasurements"
)
static member LoadInputSourceIDs :
        adapter : IAdapter *
        ?measurementTable : string
(* Defaults:
        let _measurementTable = defaultArg measurementTable "ActiveMeasurements"
*)
-> unit

GSF.TimeSeries.Adapters.AdapterBase.LoadInputSourceIDs = function(adapter, measurementTable);
public:
static void LoadInputSourceIDs(
    IAdapter^ adapter,
    String^ measurementTable = L"ActiveMeasurements"
)

Parameters

adapter
Type: GSF.TimeSeries.AdaptersIAdapter
IAdapter to load input measurement keys for.
measurementTable (Optional)
Type: SystemString
Measurement table name used to load input source ID's.
Remarks
Any existing input measurement keys will be distinctly merged with those associated with specified source ID's.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.LoadOutputSourceIDs Method

Grid Solutions Framework AdapterBaseLoadOutputSourceIDs Method
Loads an IInputAdapter or IActionAdapter instance's output measurements from a specific set of source ID's.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void LoadOutputSourceIDs(
    IAdapter adapter,
    string measurementTable = "ActiveMeasurements"
)
Public Shared Sub LoadOutputSourceIDs (
    adapter As IAdapter,
    Optional measurementTable As String = "ActiveMeasurements"
)
static member LoadOutputSourceIDs :
        adapter : IAdapter *
        ?measurementTable : string
(* Defaults:
        let _measurementTable = defaultArg measurementTable "ActiveMeasurements"
*)
-> unit

GSF.TimeSeries.Adapters.AdapterBase.LoadOutputSourceIDs = function(adapter, measurementTable);
public:
static void LoadOutputSourceIDs(
    IAdapter^ adapter,
    String^ measurementTable = L"ActiveMeasurements"
)

Parameters

adapter
Type: GSF.TimeSeries.AdaptersIAdapter
IAdapter to load output measurements for.
measurementTable (Optional)
Type: SystemString
Measurement table name used to load output source ID's.
Remarks
Any existing output measurements will be distinctly merged with those associated with specified source ID's.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OnConfigurationChanged Method

Grid Solutions Framework AdapterBaseOnConfigurationChanged Method
Raises ConfigurationChanged event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConfigurationChanged()
Protected Overridable Sub OnConfigurationChanged
abstract OnConfigurationChanged : unit -> unit
override OnConfigurationChanged : unit -> unit
function OnConfigurationChanged();
protected:
virtual void OnConfigurationChanged()
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OnInputMeasurementKeysUpdated Method

Grid Solutions Framework AdapterBaseOnInputMeasurementKeysUpdated Method
Raises InputMeasurementKeysUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnInputMeasurementKeysUpdated()
Protected Overridable Sub OnInputMeasurementKeysUpdated
abstract OnInputMeasurementKeysUpdated : unit -> unit
override OnInputMeasurementKeysUpdated : unit -> unit
function OnInputMeasurementKeysUpdated();
protected:
virtual void OnInputMeasurementKeysUpdated()
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OnOutputMeasurementsUpdated Method

Grid Solutions Framework AdapterBaseOnOutputMeasurementsUpdated Method
Raises OutputMeasurementsUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOutputMeasurementsUpdated()
Protected Overridable Sub OnOutputMeasurementsUpdated
abstract OnOutputMeasurementsUpdated : unit -> unit
override OnOutputMeasurementsUpdated : unit -> unit
function OnOutputMeasurementsUpdated();
protected:
virtual void OnOutputMeasurementsUpdated()
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OnProcessException Method

Grid Solutions Framework AdapterBaseOnProcessException Method
Raises ProcessException event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OnStatusMessage Method

Grid Solutions Framework AdapterBaseOnStatusMessage Method
Overload List
 | Name | Description
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Top
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OnStatusMessage Method (String)

Grid Solutions Framework AdapterBaseOnStatusMessage Method (String)
Raises the StatusMessage event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string status
)
Protected Overridable Sub OnStatusMessage (
    status As String
)
abstract OnStatusMessage :
        status : string -> unit
override OnStatusMessage :
        status : string -> unit
function OnStatusMessage(status);
protected:
virtual void OnStatusMessage(
    String^ status
)

Parameters

status
Type: SystemString
New status message.
See Also

Reference

AdapterBase Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


AdapterBase.OnStatusMessage Method (String, Object[])

Grid Solutions Framework AdapterBaseOnStatusMessage Method (String, Object)
Raises the StatusMessage event with a formatted status message.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string formattedStatus,
    params Object[] args
)
Protected Overridable Sub OnStatusMessage (
    formattedStatus As String,
    ParamArray args As Object()
)
abstract OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
override OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
function OnStatusMessage(formattedStatus, ... args);
protected:
virtual void OnStatusMessage(
    String^ formattedStatus,
    ... array<Object^>^ args
)

Parameters

formattedStatus
Type: SystemString
Formatted status message.
args
Type: SystemObject
Arguments for formattedStatus.
Remarks
This overload combines string.Format and SendStatusMessage for convenience.
See Also

Reference

AdapterBase Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


AdapterBase.ParseFilterExpression Method

Grid Solutions Framework AdapterBaseParseFilterExpression Method
Parses a standard FILTER styles expression into its constituent parts.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool ParseFilterExpression(
    string filterExpression,
    out string tableName,
    out string whereExpression,
    out string sortField,
    out int takeCount
)
Public Shared Function ParseFilterExpression (
    filterExpression As String,
    <OutAttribute> ByRef tableName As String,
    <OutAttribute> ByRef whereExpression As String,
    <OutAttribute> ByRef sortField As String,
    <OutAttribute> ByRef takeCount As Integer
) As Boolean
static member ParseFilterExpression :
        filterExpression : string *
        tableName : string byref *
        whereExpression : string byref *
        sortField : string byref *
        takeCount : int byref -> bool

GSF.TimeSeries.Adapters.AdapterBase.ParseFilterExpression = function(filterExpression, tableName, whereExpression, sortField, takeCount);
public:
static bool ParseFilterExpression(
    String^ filterExpression,
    [OutAttribute] String^% tableName,
    [OutAttribute] String^% whereExpression,
    [OutAttribute] String^% sortField,
    [OutAttribute] int% takeCount
)

Parameters

filterExpression
Type: SystemString
Filter expression to parse.
tableName
Type: SystemString
Name of table in filter expression.
whereExpression
Type: SystemString
Where expression in filter expression.
sortField
Type: SystemString
Sort field, if any, in filter expression.
takeCount
Type: SystemInt32
Total row restriction, if any, in filter expression.

Return Value

Type: Boolean
true if filter expression was successfully parsed; otherwise false.
Remarks
This method can be safely called from multiple threads.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ParseInputMeasurementKeys Method

Grid Solutions Framework AdapterBaseParseInputMeasurementKeys Method
Parses input measurement keys from connection string setting.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey[] ParseInputMeasurementKeys(
    DataSet dataSource,
    bool allowSelect,
    string value,
    string measurementTable = "ActiveMeasurements"
)
Public Shared Function ParseInputMeasurementKeys (
    dataSource As DataSet,
    allowSelect As Boolean,
    value As String,
    Optional measurementTable As String = "ActiveMeasurements"
) As MeasurementKey()
static member ParseInputMeasurementKeys :
        dataSource : DataSet *
        allowSelect : bool *
        value : string *
        ?measurementTable : string
(* Defaults:
        let _measurementTable = defaultArg measurementTable "ActiveMeasurements"
*)
-> MeasurementKey[]

GSF.TimeSeries.Adapters.AdapterBase.ParseInputMeasurementKeys = function(dataSource, allowSelect, value, measurementTable);
public:
static array<MeasurementKey^>^ ParseInputMeasurementKeys(
    DataSet^ dataSource,
    bool allowSelect,
    String^ value,
    String^ measurementTable = L"ActiveMeasurements"
)

Parameters

dataSource
Type: System.DataDataSet
The DataSet used to define input measurement keys.
allowSelect
Type: SystemBoolean
Determines if database access via "SELECT" statement should be allowed for defining input measurement keys (see remarks about security).
value
Type: SystemString
Value of setting used to define input measurement keys, typically "inputMeasurementKeys".
measurementTable (Optional)
Type: SystemString
Measurement table name used to load additional meta-data; this is not used when specifying a FILTER expression.

Return Value

Type: MeasurementKey
User selected input measurement keys.
Remarks
Security warning: allowing SELECT statements, i.e., setting allowSelect to true, should only be allowed in cases where SQL injection would not be an issue (e.g., in places where a user can already access the database and would have nothing to gain via an injection attack).
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ParseOutputMeasurementKeys Method

Grid Solutions Framework AdapterBaseParseOutputMeasurementKeys Method
Parses output measurement keys from connection string setting.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey[] ParseOutputMeasurementKeys(
    DataSet dataSource,
    bool allowSelect,
    string value,
    string measurementTable = "ActiveMeasurements"
)
Public Shared Function ParseOutputMeasurementKeys (
    dataSource As DataSet,
    allowSelect As Boolean,
    value As String,
    Optional measurementTable As String = "ActiveMeasurements"
) As MeasurementKey()
static member ParseOutputMeasurementKeys :
        dataSource : DataSet *
        allowSelect : bool *
        value : string *
        ?measurementTable : string
(* Defaults:
        let _measurementTable = defaultArg measurementTable "ActiveMeasurements"
*)
-> MeasurementKey[]

GSF.TimeSeries.Adapters.AdapterBase.ParseOutputMeasurementKeys = function(dataSource, allowSelect, value, measurementTable);
public:
static array<MeasurementKey^>^ ParseOutputMeasurementKeys(
    DataSet^ dataSource,
    bool allowSelect,
    String^ value,
    String^ measurementTable = L"ActiveMeasurements"
)

Parameters

dataSource
Type: System.DataDataSet
The DataSet used to define output measurements.
allowSelect
Type: SystemBoolean
Determines if database access via "SELECT" statement should be allowed for defining output measurement keys (see remarks about security).
value
Type: SystemString
Value of setting used to define output measurements, typically "outputMeasurements".
measurementTable (Optional)
Type: SystemString
Measurement table name used to load additional meta-data; this is not used when specifying a FILTER expression.

Return Value

Type: MeasurementKey
User selected output measurements.
Remarks
Security warning: allowing SELECT statements, i.e., setting allowSelect to true, should only be allowed in cases where SQL injection would not be an issue (e.g., in places where a user can already access the database and would have nothing to gain via an injection attack).
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ParseOutputMeasurements Method

Grid Solutions Framework AdapterBaseParseOutputMeasurements Method
Parses output measurements from connection string setting.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IMeasurement[] ParseOutputMeasurements(
    DataSet dataSource,
    bool allowSelect,
    string value,
    string measurementTable = "ActiveMeasurements"
)
Public Shared Function ParseOutputMeasurements (
    dataSource As DataSet,
    allowSelect As Boolean,
    value As String,
    Optional measurementTable As String = "ActiveMeasurements"
) As IMeasurement()
static member ParseOutputMeasurements :
        dataSource : DataSet *
        allowSelect : bool *
        value : string *
        ?measurementTable : string
(* Defaults:
        let _measurementTable = defaultArg measurementTable "ActiveMeasurements"
*)
-> IMeasurement[]

GSF.TimeSeries.Adapters.AdapterBase.ParseOutputMeasurements = function(dataSource, allowSelect, value, measurementTable);
public:
static array<IMeasurement^>^ ParseOutputMeasurements(
    DataSet^ dataSource,
    bool allowSelect,
    String^ value,
    String^ measurementTable = L"ActiveMeasurements"
)

Parameters

dataSource
Type: System.DataDataSet
The DataSet used to define output measurements.
allowSelect
Type: SystemBoolean
Determines if database access via "SELECT" statement should be allowed for defining output measurements (see remarks about security).
value
Type: SystemString
Value of setting used to define output measurements, typically "outputMeasurements".
measurementTable (Optional)
Type: SystemString
Measurement table name used to load additional meta-data; this is not used when specifying a FILTER expression.

Return Value

Type: IMeasurement
User selected output measurements.
Remarks
Security warning: allowing SELECT statements, i.e., setting allowSelect to true, should only be allowed in cases where SQL injection would not be an issue (e.g., in places where a user can already access the database and would have nothing to gain via an injection attack).
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ParseTimeTag Method

Grid Solutions Framework AdapterBaseParseTimeTag Method
Parses a string formatted as an absolute or relative time tag.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DateTime ParseTimeTag(
    string timetag
)
Public Shared Function ParseTimeTag (
    timetag As String
) As DateTime
static member ParseTimeTag :
        timetag : string -> DateTime

GSF.TimeSeries.Adapters.AdapterBase.ParseTimeTag = function(timetag);
public:
static DateTime ParseTimeTag(
    String^ timetag
)

Parameters

timetag
Type: SystemString
String formatted as an absolute or relative time tag.

Return Value

Type: DateTime
DateTime representing the parsed timetag string formatted as an absolute or relative time tag.
Exceptions
Exception | Condition
ArgumentNullException | timetag parameter cannot be null or empty.
FormatException | timetag does not contain a valid string representation of a date and time.
Remarks

Relative times are parsed based on an offset to current time (UTC) specified by "*".

The timetag parameter can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.
*+2d | Evaluates to 2 days from UtcNow.

See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.SetInitializedState Method

Grid Solutions Framework AdapterBaseSetInitializedState Method
Manually sets the initialized state of the AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Manually sets the initialized state of the adapter.",
    new string[] { ... })]
public virtual void SetInitializedState(
    bool initialized
)
<AdapterCommandAttribute("Manually sets the initialized state of the adapter.",
    New String() { ... })>
Public Overridable Sub SetInitializedState (
    initialized As Boolean
)
[<AdapterCommandAttribute("Manually sets the initialized state of the adapter.",
    new string[] { ... })>]
abstract SetInitializedState :
        initialized : bool -> unit
[<AdapterCommandAttribute("Manually sets the initialized state of the adapter.",
    new string[] { ... })>]
override SetInitializedState :
        initialized : bool -> unit
function SetInitializedState(initialized);
public:
[AdapterCommandAttribute(L"Manually sets the initialized state of the adapter.",
    __gc new array<String^>^ { ... })]
virtual void SetInitializedState(
    bool initialized
)

Parameters

initialized
Type: SystemBoolean
Desired initialized state.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.SetTemporalConstraint Method

Grid Solutions Framework AdapterBaseSetTemporalConstraint Method
Defines a temporal processing constraint for the adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    new string[] { ... })]
public virtual void SetTemporalConstraint(
    string startTime,
    string stopTime,
    string constraintParameters
)
<AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    New String() { ... })>
Public Overridable Sub SetTemporalConstraint (
    startTime As String,
    stopTime As String,
    constraintParameters As String
)
[<AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    new string[] { ... })>]
abstract SetTemporalConstraint :
        startTime : string *
        stopTime : string *
        constraintParameters : string -> unit
[<AdapterCommandAttribute("Defines a temporal processing constraint for the adapter.",
    new string[] { ... })>]
override SetTemporalConstraint :
        startTime : string *
        stopTime : string *
        constraintParameters : string -> unit
function SetTemporalConstraint(startTime, stopTime, constraintParameters);
public:
[AdapterCommandAttribute(L"Defines a temporal processing constraint for the adapter.",
    __gc new array<String^>^ { ... })]
virtual void SetTemporalConstraint(
    String^ startTime,
    String^ stopTime,
    String^ constraintParameters
)

Parameters

startTime
Type: SystemString
Defines a relative or exact start time for the temporal constraint.
stopTime
Type: SystemString
Defines a relative or exact stop time for the temporal constraint.
constraintParameters
Type: SystemString
Defines any temporal parameters related to the constraint.

Implements

IAdapterSetTemporalConstraint(String, String, String)
Remarks

This method defines a temporal processing constraint for an adapter, i.e., the start and stop time over which an adapter will process data. Actual implementation of the constraint will be adapter specific. Implementations should be able to dynamically handle multiple calls to this function with new constraints. Passing in null for the startTime and stopTime should cancel the temporal constraint and return the adapter to standard / real-time operation.

The startTime and stopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Start Method

Grid Solutions Framework AdapterBaseStart Method
Starts the AdapterBase or restarts it if it is already running.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Starts the adapter or restarts it if it is already running.",
    new string[] { ... })]
public virtual void Start()
<AdapterCommandAttribute("Starts the adapter or restarts it if it is already running.",
    New String() { ... })>
Public Overridable Sub Start
[<AdapterCommandAttribute("Starts the adapter or restarts it if it is already running.",
    new string[] { ... })>]
abstract Start : unit -> unit
[<AdapterCommandAttribute("Starts the adapter or restarts it if it is already running.",
    new string[] { ... })>]
override Start : unit -> unit
function Start();
public:
[AdapterCommandAttribute(L"Starts the adapter or restarts it if it is already running.",
    __gc new array<String^>^ { ... })]
virtual void Start()

Implements

IAdapterStart
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Stop Method

Grid Solutions Framework AdapterBaseStop Method
Stops the AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Stops the adapter.", new string[] { ... })]
public virtual void Stop()
<AdapterCommandAttribute("Stops the adapter.", New String() { ... })>
Public Overridable Sub Stop
[<AdapterCommandAttribute("Stops the adapter.", new string[] { ... })>]
abstract Stop : unit -> unit
[<AdapterCommandAttribute("Stops the adapter.", new string[] { ... })>]
override Stop : unit -> unit
function Stop();
public:
[AdapterCommandAttribute(L"Stops the adapter.", __gc new array<String^>^ { ... })]
virtual void Stop()

Implements

IAdapterStop
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase Properties

Grid Solutions Framework AdapterBase Properties

The AdapterBase type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase.
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase.
Public property | Enabled | Gets or sets enabled state of this AdapterBase.
Public property | ID | Gets or sets numeric ID associated with this AdapterBase.
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval.
Public property | Name | Gets or sets the name of this AdapterBase.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTime | Gets the UTC time this AdapterBase was started.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Gets the status of this AdapterBase.
Public property | StopTime | Gets the UTC time this AdapterBase was stopped.
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing.
Top
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.AutoStart Property

Grid Solutions Framework AdapterBaseAutoStart Property
Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool AutoStart { get; set; }
Public Overridable Property AutoStart As Boolean
    Get
    Set
abstract AutoStart : bool with get, set
override AutoStart : bool with get, set
function get_AutoStart();
function set_AutoStart(value);
public:
virtual property bool AutoStart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IAdapterAutoStart
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ConnectionString Property

Grid Solutions Framework AdapterBaseConnectionString Property
Gets or sets key/value pair connection information specific to this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ConnectionString { get; set; }
Public Overridable Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set
override ConnectionString : string with get, set
function get_ConnectionString();
function set_ConnectionString(value);
public:
virtual property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterConnectionString
Remarks

Example connection string using manually defined measurements:
inputMeasurementKeys={P1:1245;P1:1247;P2:1335};
outputMeasurements={P3:1345,60.0,1.0;P3:1346;P3:1347}
When defined manually, elements in key:
* inputMeasurementKeys are defined as "ArchiveSource:PointID"
* outputMeasurements are defined as "ArchiveSource:PointID,Adder,Multiplier", the adder and multiplier are optional defaulting to 0.0 and 1.0 respectively.

Example connection string using measurements defined in a DataSource table:
inputMeasurementKeys={FILTER ActiveMeasurements WHERE Company='GSF' AND SignalType='FREQ' ORDER BY ID};
outputMeasurements={FILTER ActiveMeasurements WHERE SignalType IN ('IPHA','VPHA') AND Phase='+'}

Basic filtering syntax is as follows:

{FILTER <TableName> WHERE <Expression> [ORDER BY <SortField>]}

Source tables are expected to have at least the following fields:

Name | Type | Description.
ID | NVARCHAR | Measurement key formatted as: ArchiveSource:PointID.
PointTag | NVARCHAR | Point tag of measurement.
Adder | FLOAT | Adder to apply to value, if any (default to 0.0).
Multiplier | FLOAT | Multiplier to apply to value, if any (default to 1.0).

See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.DataSource Property

Grid Solutions Framework AdapterBaseDataSource Property
Gets or sets DataSet based data source available to this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataSet DataSource { get; set; }
Public Overridable Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get ();
    void set (DataSet^ value);
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Enabled Property

Grid Solutions Framework AdapterBaseEnabled Property
Gets or sets enabled state of this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
Remarks
Base class simply starts or stops AdapterBase based on flag value. Derived classes should extend this if needed to enable or disable operational state of the adapter based on flag value.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ID Property

Grid Solutions Framework AdapterBaseID Property
Gets or sets numeric ID associated with this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual uint ID { get; set; }
Public Overridable Property ID As UInteger
    Get
    Set
abstract ID : uint32 with get, set
override ID : uint32 with get, set
function get_ID();
function set_ID(value);
public:
virtual property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32

Implements

IAdapterID
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.InitializationTimeout Property

Grid Solutions Framework AdapterBaseInitializationTimeout Property
Gets or sets maximum time system will wait during Start for initialization.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int InitializationTimeout { get; set; }
Public Overridable Property InitializationTimeout As Integer
    Get
    Set
abstract InitializationTimeout : int with get, set
override InitializationTimeout : int with get, set
function get_InitializationTimeout();
function set_InitializationTimeout(value);
public:
virtual property int InitializationTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IAdapterInitializationTimeout
Remarks
Set to Infinite to wait indefinitely.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Initialized Property

Grid Solutions Framework AdapterBaseInitialized Property
Gets or sets flag indicating if the adapter has been initialized successfully.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Initialized { get; set; }
Public Overridable Property Initialized As Boolean
    Get
    Set
abstract Initialized : bool with get, set
override Initialized : bool with get, set
function get_Initialized();
function set_Initialized(value);
public:
virtual property bool Initialized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IAdapterInitialized
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.InputMeasurementKeys Property

Grid Solutions Framework AdapterBaseInputMeasurementKeys Property
Gets or sets primary keys of input measurements the AdapterBase expects, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(null)]
[CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)]
[ConnectionStringParameterAttribute]
public virtual MeasurementKey[] InputMeasurementKeys { get; set; }
<DefaultValueAttribute(Nothing)>
<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    Nothing)>
<ConnectionStringParameterAttribute>
Public Overridable Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
[<DefaultValueAttribute(null)>]
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<ConnectionStringParameterAttribute>]
abstract InputMeasurementKeys : MeasurementKey[] with get, set
[<DefaultValueAttribute(null)>]
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<ConnectionStringParameterAttribute>]
override InputMeasurementKeys : MeasurementKey[] with get, set
function get_InputMeasurementKeys();
function set_InputMeasurementKeys(value);
public:
[DefaultValueAttribute(nullptr)]
[CustomConfigurationEditorAttribute(L"GSF.TimeSeries.UI.WPF.dll", L"GSF.TimeSeries.UI.Editors.MeasurementEditor",
    nullptr)]
[ConnectionStringParameterAttribute]
virtual property array<MeasurementKey^>^ InputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IAdapterInputMeasurementKeys
Remarks
If your adapter needs to receive all measurements, you must explicitly set InputMeasurementKeys to null.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.IsDisposed Property

Grid Solutions Framework AdapterBaseIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.MeasurementReportingInterval Property

Grid Solutions Framework AdapterBaseMeasurementReportingInterval Property
Gets or sets the measurement reporting interval.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int MeasurementReportingInterval { get; set; }
Public Overridable Property MeasurementReportingInterval As Integer
    Get
    Set
abstract MeasurementReportingInterval : int with get, set
override MeasurementReportingInterval : int with get, set
function get_MeasurementReportingInterval();
function set_MeasurementReportingInterval(value);
public:
virtual property int MeasurementReportingInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This is used to determined how many measurements should be processed before reporting status.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Name Property

Grid Solutions Framework AdapterBaseName Property
Gets or sets the name of this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterName
IProvideStatusName
Remarks
Derived classes should provide a name for the adapter.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OutputMeasurements Property

Grid Solutions Framework AdapterBaseOutputMeasurements Property
Gets or sets output measurements that the AdapterBase will produce, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)]
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(null)]
public virtual IMeasurement[] OutputMeasurements { get; set; }
<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    Nothing)>
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(Nothing)>
Public Overridable Property OutputMeasurements As IMeasurement()
    Get
    Set
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(null)>]
abstract OutputMeasurements : IMeasurement[] with get, set
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(null)>]
override OutputMeasurements : IMeasurement[] with get, set
function get_OutputMeasurements();
function set_OutputMeasurements(value);
public:
[CustomConfigurationEditorAttribute(L"GSF.TimeSeries.UI.WPF.dll", L"GSF.TimeSeries.UI.Editors.MeasurementEditor",
    nullptr)]
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(nullptr)]
virtual property array<IMeasurement^>^ OutputMeasurements {
    array<IMeasurement^>^ get ();
    void set (array<IMeasurement^>^ value);
}

Property Value

Type: IMeasurement

Implements

IAdapterOutputMeasurements
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ProcessedMeasurements Property

Grid Solutions Framework AdapterBaseProcessedMeasurements Property
Gets the total number of measurements handled thus far by the AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual long ProcessedMeasurements { get; }
Public Overridable ReadOnly Property ProcessedMeasurements As Long
    Get
abstract ProcessedMeasurements : int64 with get
override ProcessedMeasurements : int64 with get
function get_ProcessedMeasurements();

public:
virtual property long long ProcessedMeasurements {
    long long get ();
}

Property Value

Type: Int64

Implements

IAdapterProcessedMeasurements
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ProcessingInterval Property

Grid Solutions Framework AdapterBaseProcessingInterval Property
Gets or sets the desired processing interval, in milliseconds, for the adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ProcessingInterval { get; set; }
Public Overridable Property ProcessingInterval As Integer
    Get
    Set
abstract ProcessingInterval : int with get, set
override ProcessingInterval : int with get, set
function get_ProcessingInterval();
function set_ProcessingInterval(value);
public:
virtual property int ProcessingInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IAdapterProcessingInterval
Remarks
With the exception of the values of -1 and 0, this value specifies the desired processing interval for data, i.e., basically a delay, or timer interval, over which to process data. A value of -1 means to use the default processing interval while a value of 0 means to process data as fast as possible.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.RunTime Property

Grid Solutions Framework AdapterBaseRunTime Property
Gets the total amount of time, in seconds, that the adapter has been active.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Time RunTime { get; }
Public Overridable ReadOnly Property RunTime As Time
    Get
abstract RunTime : Time with get
override RunTime : Time with get
function get_RunTime();

public:
virtual property Time RunTime {
    Time get ();
}

Property Value

Type: Time
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Settings Property

Grid Solutions Framework AdapterBaseSettings Property
Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<string, string> Settings { get; }
Public ReadOnly Property Settings As Dictionary(Of String, String)
    Get
abstract Settings : Dictionary<string, string> with get
override Settings : Dictionary<string, string> with get
function get_Settings();

public:
virtual property Dictionary<String^, String^>^ Settings {
    Dictionary<String^, String^>^ get () sealed;
}

Property Value

Type: Dictionary String, String

Implements

IAdapterSettings
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.StartTime Property

Grid Solutions Framework AdapterBaseStartTime Property
Gets the UTC time this AdapterBase was started.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks StartTime { get; }
Public ReadOnly Property StartTime As Ticks
    Get
member StartTime : Ticks with get

function get_StartTime();

public:
property Ticks StartTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.StartTimeConstraint Property

Grid Solutions Framework AdapterBaseStartTimeConstraint Property
Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DateTime StartTimeConstraint { get; }
Public Overridable ReadOnly Property StartTimeConstraint As DateTime
    Get
abstract StartTimeConstraint : DateTime with get
override StartTimeConstraint : DateTime with get
function get_StartTimeConstraint();

public:
virtual property DateTime StartTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime

Implements

IAdapterStartTimeConstraint
Remarks
This value will be MinValue when start time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Status Property

Grid Solutions Framework AdapterBaseStatus Property
Gets the status of this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
Remarks
Derived classes should provide current status information about the adapter for display purposes.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.StopTime Property

Grid Solutions Framework AdapterBaseStopTime Property
Gets the UTC time this AdapterBase was stopped.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks StopTime { get; }
Public ReadOnly Property StopTime As Ticks
    Get
member StopTime : Ticks with get

function get_StopTime();

public:
property Ticks StopTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.StopTimeConstraint Property

Grid Solutions Framework AdapterBaseStopTimeConstraint Property
Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DateTime StopTimeConstraint { get; }
Public Overridable ReadOnly Property StopTimeConstraint As DateTime
    Get
abstract StopTimeConstraint : DateTime with get
override StopTimeConstraint : DateTime with get
function get_StopTimeConstraint();

public:
virtual property DateTime StopTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime

Implements

IAdapterStopTimeConstraint
Remarks
This value will be MaxValue when stop time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.SupportsTemporalProcessing Property

Grid Solutions Framework AdapterBaseSupportsTemporalProcessing Property
Gets the flag indicating if this adapter supports temporal processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool SupportsTemporalProcessing { get; }
Public MustOverride ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get

function get_SupportsTemporalProcessing();

public:
virtual property bool SupportsTemporalProcessing {
    bool get () abstract;
}

Property Value

Type: Boolean

Implements

IAdapterSupportsTemporalProcessing
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase Events

Grid Solutions Framework AdapterBase Events

The AdapterBase type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Event is raised when AdapterBase is disposed.
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ConfigurationChanged Event

Grid Solutions Framework AdapterBaseConfigurationChanged Event
Event is raised when adapter is aware of a configuration change.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
override ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
public:
virtual  event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterConfigurationChanged
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.Disposed Event

Grid Solutions Framework AdapterBaseDisposed Event
Event is raised when AdapterBase is disposed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.InputMeasurementKeysUpdated Event

Grid Solutions Framework AdapterBaseInputMeasurementKeysUpdated Event
Event is raised when InputMeasurementKeys are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler InputMeasurementKeysUpdated
Public Event InputMeasurementKeysUpdated As EventHandler
abstract InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>
override InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>
function add_InputMeasurementKeysUpdated(value);
function remove_InputMeasurementKeysUpdated(value);
public:
virtual  event EventHandler^ InputMeasurementKeysUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterInputMeasurementKeysUpdated
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.OutputMeasurementsUpdated Event

Grid Solutions Framework AdapterBaseOutputMeasurementsUpdated Event
Event is raised when OutputMeasurements are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler OutputMeasurementsUpdated
Public Event OutputMeasurementsUpdated As EventHandler
abstract OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>
override OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>
function add_OutputMeasurementsUpdated(value);
function remove_OutputMeasurementsUpdated(value);
public:
virtual  event EventHandler^ OutputMeasurementsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterOutputMeasurementsUpdated
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.ProcessException Event

Grid Solutions Framework AdapterBaseProcessException Event
Event is raised when there is an exception encountered while processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ProcessException(value);
function remove_ProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IAdapterProcessException
Remarks
Argument is the exception that was thrown.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterBase.StatusMessage Event

Grid Solutions Framework AdapterBaseStatusMessage Event
Provides status messages to consumer.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IAdapterStatusMessage
Remarks
Argument is new status message.
See Also

Reference

AdapterBase Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T) Class

Grid Solutions Framework AdapterCollectionBaseT Class
Represents a collection of IAdapter implementations.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection T
GSF.CollectionsListCollection T
GSF.TimeSeries.AdaptersAdapterCollectionBaseT
GSF.TimeSeries.AdaptersActionAdapterCollection
GSF.TimeSeries.AdaptersAllAdaptersCollection
GSF.TimeSeries.AdaptersInputAdapterCollection
GSF.TimeSeries.AdaptersOutputAdapterCollection

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public abstract class AdapterCollectionBase<T> : ListCollection<T>,
    IAdapterCollection, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IList<IAdapter>, ICollection<IAdapter>, IEnumerable<IAdapter>,
    IEnumerable
where T : class, IAdapter

<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public MustInherit Class AdapterCollectionBase(Of T As {Class, IAdapter})
    Inherits ListCollection(Of T)
    Implements IAdapterCollection, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IList(Of IAdapter), ICollection(Of IAdapter),
    IEnumerable(Of IAdapter), IEnumerable
[<AbstractClassAttribute>]
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type AdapterCollectionBase<'T when 'T : not struct and IAdapter> =
    class
        inherit ListCollection<'T>
        interface IAdapterCollection
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IList<IAdapter>
        interface ICollection<IAdapter>
        interface IEnumerable<IAdapter>
        interface IEnumerable
    end
JavaScript does not support generic types or methods.
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
generic<typename T>
where T : ref class, IAdapter
public ref class AdapterCollectionBase abstract : public ListCollection<T>,
    IAdapterCollection, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IList<IAdapter^>, ICollection<IAdapter^>, IEnumerable<IAdapter^>,
    IEnumerable

Type Parameters

T
Type of IAdapter this collection contains.

The AdapterCollectionBaseT type exposes the following members.

Constructors
 | Name | Description
Protected method | AdapterCollectionBaseT | Constructs a new instance of the AdapterCollectionBaseT.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides ListCollectionTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources.
Protected method | DisposeItem | Un-wires events and disposes of IAdapter implementation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Loads all IAdapter implementations defined in DataSource.
Protected method | InitializeItem | Wires events and initializes new IAdapter implementation.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Overrides ListCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides ListCollectionTRemoveItem(Int32).)
Public method | ResetStatistics | Resets the statistics of this collection.
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Overrides ListCollectionTSetItem(Int32, T).)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter.
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT.
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow.
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function.
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id.
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name.
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAdapter | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByIAdapter, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeIAdapter | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfIAdapter | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | InputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | InputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of input measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, Char, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter(IAdapter) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(IComparerIAdapter) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByIAdapter, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(IComparerIAdapter) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByIAdapter, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter(IAdapter) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | OutputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of output measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | ScrambleIAdapter | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleIAdapter(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Public Extension Method | ToDelimitedStringIAdapter | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleIAdapter | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeIAdapter | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection.
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT.
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT.
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT.
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT.
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any.
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only.
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT.
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any.
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter.
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT.
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed.
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T) Constructor

Grid Solutions Framework AdapterCollectionBaseT Constructor
Constructs a new instance of the AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected AdapterCollectionBase()
Protected Sub New
new : unit -> AdapterCollectionBase
GSF.TimeSeries.Adapters.AdapterCollectionBase = function();
protected:
AdapterCollectionBase()
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T) Methods

Grid Solutions Framework AdapterCollectionBaseT Methods

The AdapterCollectionBaseT generic type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Overrides ListCollectionTClearItems.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources.
Protected method | DisposeItem | Un-wires events and disposes of IAdapter implementation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Loads all IAdapter implementations defined in DataSource.
Protected method | InitializeItem | Wires events and initializes new IAdapter implementation.
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Overrides ListCollectionTInsertItem(Int32, T).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Overrides ListCollectionTRemoveItem(Int32).)
Public method | ResetStatistics | Resets the statistics of this collection.
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Overrides ListCollectionTSetItem(Int32, T).)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter.
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT.
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow.
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function.
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id.
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name.
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAdapter | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByIAdapter, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetRangeIAdapter | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfIAdapter | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | InputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | InputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of input measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, Char, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter(IAdapter) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(IComparerIAdapter) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByIAdapter, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(IComparerIAdapter) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByIAdapter, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter(IAdapter) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | OutputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of output measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | ScrambleIAdapter | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleIAdapter(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Public Extension Method | ToDelimitedStringIAdapter | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleIAdapter | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeIAdapter | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ClearItems Method

Grid Solutions Framework AdapterCollectionBaseTClearItems Method
Removes all elements from the CollectionT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ClearItems()
Protected Overrides Sub ClearItems
abstract ClearItems : unit -> unit
override ClearItems : unit -> unit
function ClearItems();
protected:
virtual void ClearItems() override
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Dispose Method

Grid Solutions Framework AdapterCollectionBaseTDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources.
Top
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Dispose Method

Grid Solutions Framework AdapterCollectionBaseTDispose Method
Releases all the resources used by the AdapterCollectionBaseT object.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

AdapterCollectionBaseT Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Dispose Method (Boolean)

Grid Solutions Framework AdapterCollectionBaseTDispose Method (Boolean)
Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

AdapterCollectionBaseT Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).DisposeItem Method

Grid Solutions Framework AdapterCollectionBaseTDisposeItem Method
Un-wires events and disposes of IAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void DisposeItem(
    T item
)
Protected Overridable Sub DisposeItem (
    item As T
)
abstract DisposeItem :
        item : 'T -> unit
override DisposeItem :
        item : 'T -> unit
function DisposeItem(item);
protected:
virtual void DisposeItem(
    T item
)

Parameters

item
Type: T
IAdapter to dispose.
Remarks
Derived classes should override if more events are defined.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Finalize Method

Grid Solutions Framework AdapterCollectionBaseTFinalize Method
Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).GetShortStatus Method

Grid Solutions Framework AdapterCollectionBaseTGetShortStatus Method
Gets a short one-line status of this AdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string GetShortStatus(
    int maxLength
)
Public Overridable Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string
override GetShortStatus :
        maxLength : int -> string
function GetShortStatus(maxLength);
public:
virtual String^ GetShortStatus(
    int maxLength
)

Parameters

maxLength
Type: SystemInt32
Maximum number of available characters for display.

Return Value

Type: String
A short one-line summary of the current status of this AdapterBase.

Implements

IAdapterGetShortStatus(Int32)
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Initialize Method

Grid Solutions Framework AdapterCollectionBaseTInitialize Method
Loads all IAdapter implementations defined in DataSource.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize()
Public Overridable Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize()

Implements

ISupportLifecycleInitialize
Exceptions
Exception | Condition
NullReferenceException | DataSource is null.
InvalidOperationException | DataMember is null or empty.
Remarks

Table name specified in DataMember from DataSource is expected to have the following table column names:
ID, AdapterName, AssemblyName, TypeName, ConnectionString
ID column type should be integer based, all other column types are expected to be string based.

Note that when calling this method any existing items will be cleared allowing a "re-initialize".

See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).InitializeItem Method

Grid Solutions Framework AdapterCollectionBaseTInitializeItem Method
Wires events and initializes new IAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void InitializeItem(
    T item
)
Protected Overridable Sub InitializeItem (
    item As T
)
abstract InitializeItem :
        item : 'T -> unit
override InitializeItem :
        item : 'T -> unit
function InitializeItem(item);
protected:
virtual void InitializeItem(
    T item
)

Parameters

item
Type: T
New IAdapter implementation.
Remarks
Derived classes should override if more events are defined.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).InsertItem Method

Grid Solutions Framework AdapterCollectionBaseTInsertItem Method
Inserts an element into the CollectionT the specified index.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InsertItem(
    int index,
    T item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As T
)
abstract InsertItem :
        index : int *
        item : 'T -> unit
override InsertItem :
        index : int *
        item : 'T -> unit
function InsertItem(index, item);
protected:
virtual void InsertItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: T
The IAdapter implementation to insert.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OnConfigurationChanged Method

Grid Solutions Framework AdapterCollectionBaseTOnConfigurationChanged Method
Raises ConfigurationChanged event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConfigurationChanged()
Protected Overridable Sub OnConfigurationChanged
abstract OnConfigurationChanged : unit -> unit
override OnConfigurationChanged : unit -> unit
function OnConfigurationChanged();
protected:
virtual void OnConfigurationChanged()
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OnInputMeasurementKeysUpdated Method

Grid Solutions Framework AdapterCollectionBaseTOnInputMeasurementKeysUpdated Method
Raises InputMeasurementKeysUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnInputMeasurementKeysUpdated()
Protected Overridable Sub OnInputMeasurementKeysUpdated
abstract OnInputMeasurementKeysUpdated : unit -> unit
override OnInputMeasurementKeysUpdated : unit -> unit
function OnInputMeasurementKeysUpdated();
protected:
virtual void OnInputMeasurementKeysUpdated()
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OnOutputMeasurementsUpdated Method

Grid Solutions Framework AdapterCollectionBaseTOnOutputMeasurementsUpdated Method
Raises OutputMeasurementsUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOutputMeasurementsUpdated()
Protected Overridable Sub OnOutputMeasurementsUpdated
abstract OnOutputMeasurementsUpdated : unit -> unit
override OnOutputMeasurementsUpdated : unit -> unit
function OnOutputMeasurementsUpdated();
protected:
virtual void OnOutputMeasurementsUpdated()
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OnProcessException Method

Grid Solutions Framework AdapterCollectionBaseTOnProcessException Method
Raises ProcessException event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OnStatusMessage Method

Grid Solutions Framework AdapterCollectionBaseTOnStatusMessage Method
Overload List
 | Name | Description
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Top
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OnStatusMessage Method (String)

Grid Solutions Framework AdapterCollectionBaseTOnStatusMessage Method (String)
Raises the StatusMessage event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string status
)
Protected Overridable Sub OnStatusMessage (
    status As String
)
abstract OnStatusMessage :
        status : string -> unit
override OnStatusMessage :
        status : string -> unit
function OnStatusMessage(status);
protected:
virtual void OnStatusMessage(
    String^ status
)

Parameters

status
Type: SystemString
New status message.
See Also

Reference

AdapterCollectionBaseT Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OnStatusMessage Method (String, Object[])

Grid Solutions Framework AdapterCollectionBaseTOnStatusMessage Method (String, Object)
Raises the StatusMessage event with a formatted status message.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string formattedStatus,
    params Object[] args
)
Protected Overridable Sub OnStatusMessage (
    formattedStatus As String,
    ParamArray args As Object()
)
abstract OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
override OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
function OnStatusMessage(formattedStatus, ... args);
protected:
virtual void OnStatusMessage(
    String^ formattedStatus,
    ... array<Object^>^ args
)

Parameters

formattedStatus
Type: SystemString
Formatted status message.
args
Type: SystemObject
Arguments for formattedStatus.
Remarks
This overload combines string.Format and SendStatusMessage for convenience.
See Also

Reference

AdapterCollectionBaseT Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).RemoveItem Method

Grid Solutions Framework AdapterCollectionBaseTRemoveItem Method
Removes the element at the specified index of the CollectionT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void RemoveItem(
    int index
)
Protected Overrides Sub RemoveItem (
    index As Integer
)
abstract RemoveItem :
        index : int -> unit
override RemoveItem :
        index : int -> unit
function RemoveItem(index);
protected:
virtual void RemoveItem(
    int index
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to remove.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ResetStatistics Method

Grid Solutions Framework AdapterCollectionBaseTResetStatistics Method
Resets the statistics of this collection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Resets the statistics of this collection.", new string[] { ... })]
public void ResetStatistics()
<AdapterCommandAttribute("Resets the statistics of this collection.", New String() { ... })>
Public Sub ResetStatistics
[<AdapterCommandAttribute("Resets the statistics of this collection.", new string[] { ... })>]
abstract ResetStatistics : unit -> unit
[<AdapterCommandAttribute("Resets the statistics of this collection.", new string[] { ... })>]
override ResetStatistics : unit -> unit
function ResetStatistics();
public:
[AdapterCommandAttribute(L"Resets the statistics of this collection.", __gc new array<String^>^ { ... })]
virtual void ResetStatistics() sealed

Implements

IAdapterCollectionResetStatistics
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).SetItem Method

Grid Solutions Framework AdapterCollectionBaseTSetItem Method
Assigns a new element to the CollectionT at the specified index.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SetItem(
    int index,
    T item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As T
)
abstract SetItem :
        index : int *
        item : 'T -> unit
override SetItem :
        index : int *
        item : 'T -> unit
function SetItem(index, item);
protected:
virtual void SetItem(
    int index,
    T item
) override

Parameters

index
Type: SystemInt32
The zero-based index for which item should be assigned.
item
Type: T
The IAdapter implementation to assign.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).SetTemporalConstraint Method

Grid Solutions Framework AdapterCollectionBaseTSetTemporalConstraint Method
Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Defines a temporal processing constraint for each adapter in the collection.",
    new string[] { ... })]
public virtual void SetTemporalConstraint(
    string startTime,
    string stopTime,
    string constraintParameters
)
<AdapterCommandAttribute("Defines a temporal processing constraint for each adapter in the collection.",
    New String() { ... })>
Public Overridable Sub SetTemporalConstraint (
    startTime As String,
    stopTime As String,
    constraintParameters As String
)
[<AdapterCommandAttribute("Defines a temporal processing constraint for each adapter in the collection.",
    new string[] { ... })>]
abstract SetTemporalConstraint :
        startTime : string *
        stopTime : string *
        constraintParameters : string -> unit
[<AdapterCommandAttribute("Defines a temporal processing constraint for each adapter in the collection.",
    new string[] { ... })>]
override SetTemporalConstraint :
        startTime : string *
        stopTime : string *
        constraintParameters : string -> unit
function SetTemporalConstraint(startTime, stopTime, constraintParameters);
public:
[AdapterCommandAttribute(L"Defines a temporal processing constraint for each adapter in the collection.",
    __gc new array<String^>^ { ... })]
virtual void SetTemporalConstraint(
    String^ startTime,
    String^ stopTime,
    String^ constraintParameters
)

Parameters

startTime
Type: SystemString
Defines a relative or exact start time for the temporal constraint.
stopTime
Type: SystemString
Defines a relative or exact stop time for the temporal constraint.
constraintParameters
Type: SystemString
Defines any temporal parameters related to the constraint.

Implements

IAdapterSetTemporalConstraint(String, String, String)
Remarks

This method defines a temporal processing constraint for an adapter, i.e., the start and stop time over which an adapter will process data. Actual implementation of the constraint will be adapter specific. Implementations should be able to dynamically handle multiple calls to this function with new constraints. Passing in null for the startTime and stopTime should cancel the temporal constraint and return the adapter to standard / real-time operation.

The startTime and stopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Start Method

Grid Solutions Framework AdapterCollectionBaseTStart Method
Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Starts, or restarts, each adapter in the collection.",
    new string[] { ... })]
public virtual void Start()
<AdapterCommandAttribute("Starts, or restarts, each adapter in the collection.",
    New String() { ... })>
Public Overridable Sub Start
[<AdapterCommandAttribute("Starts, or restarts, each adapter in the collection.",
    new string[] { ... })>]
abstract Start : unit -> unit
[<AdapterCommandAttribute("Starts, or restarts, each adapter in the collection.",
    new string[] { ... })>]
override Start : unit -> unit
function Start();
public:
[AdapterCommandAttribute(L"Starts, or restarts, each adapter in the collection.",
    __gc new array<String^>^ { ... })]
virtual void Start()

Implements

IAdapterStart
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Stop Method

Grid Solutions Framework AdapterCollectionBaseTStop Method
Stops each IAdapter implementation in this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Stops each adapter in the collection.", new string[] { ... })]
public virtual void Stop()
<AdapterCommandAttribute("Stops each adapter in the collection.", New String() { ... })>
Public Overridable Sub Stop
[<AdapterCommandAttribute("Stops each adapter in the collection.", new string[] { ... })>]
abstract Stop : unit -> unit
[<AdapterCommandAttribute("Stops each adapter in the collection.", new string[] { ... })>]
override Stop : unit -> unit
function Stop();
public:
[AdapterCommandAttribute(L"Stops each adapter in the collection.", __gc new array<String^>^ { ... })]
virtual void Stop()

Implements

IAdapterStop
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).TryCreateAdapter Method

Grid Solutions Framework AdapterCollectionBaseTTryCreateAdapter Method
Attempts to create an IAdapter from the specified DataRow.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryCreateAdapter(
    DataRow adapterRow,
    out T adapter
)
Public Overridable Function TryCreateAdapter (
    adapterRow As DataRow,
    <OutAttribute> ByRef adapter As T
) As Boolean
abstract TryCreateAdapter :
        adapterRow : DataRow *
        adapter : 'T byref -> bool
override TryCreateAdapter :
        adapterRow : DataRow *
        adapter : 'T byref -> bool
function TryCreateAdapter(adapterRow, adapter);
public:
virtual bool TryCreateAdapter(
    DataRow^ adapterRow,
    [OutAttribute] T% adapter
)

Parameters

adapterRow
Type: System.DataDataRow
DataRow containing item information to initialize.
adapter
Type: T
Initialized adapter if successful; otherwise null.

Return Value

Type: Boolean
true if item was successfully initialized; otherwise false.
Exceptions
Exception | Condition
NullReferenceException | adapterRow is null.
Remarks
See DataSource property for expected DataRow column names.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).TryGetAdapter(TValue) Method

Grid Solutions Framework AdapterCollectionBaseTTryGetAdapterTValue Method
Attempts to get the adapter with the specified value given testItem function.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool TryGetAdapter<TValue>(
    TValue value,
    Func<T, TValue, bool> testItem,
    out T adapter
)

Protected Overridable Function TryGetAdapter(Of TValue) (
    value As TValue,
    testItem As Func(Of T, TValue, Boolean),
    <OutAttribute> ByRef adapter As T
) As Boolean
abstract TryGetAdapter :
        value : 'TValue *
        testItem : Func<'T, 'TValue, bool> *
        adapter : 'T byref -> bool
override TryGetAdapter :
        value : 'TValue *
        testItem : Func<'T, 'TValue, bool> *
        adapter : 'T byref -> bool
JavaScript does not support generic types or methods.
protected:
generic<typename TValue>
virtual bool TryGetAdapter(
    TValue value,
    Func<T, TValue, bool>^ testItem,
    [OutAttribute] T% adapter
)

Parameters

value
Type: TValue
Value of adapter to get.
testItem
Type: SystemFunc T, TValue, Boolean
Function delegate used to test item value.
adapter
Type: T
Adapter reference if found; otherwise null.

Type Parameters

TValue

[Missing <typeparam name="TValue"/> documentation for "M:GSF.TimeSeries.Adapters.AdapterCollectionBase`1.TryGetAdapter``1(``0,System.Func{`0,``0,System.Boolean},`0@)"]

Return Value

Type: Boolean
true if adapter with the specified value was found; otherwise false.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).TryGetAdapterByID Method

Grid Solutions Framework AdapterCollectionBaseTTryGetAdapterByID Method
Attempts to get the adapter with the specified id.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryGetAdapterByID(
    uint id,
    out T adapter
)
Public Overridable Function TryGetAdapterByID (
    id As UInteger,
    <OutAttribute> ByRef adapter As T
) As Boolean
abstract TryGetAdapterByID :
        id : uint32 *
        adapter : 'T byref -> bool
override TryGetAdapterByID :
        id : uint32 *
        adapter : 'T byref -> bool
function TryGetAdapterByID(id, adapter);
public:
virtual bool TryGetAdapterByID(
    unsigned int id,
    [OutAttribute] T% adapter
)

Parameters

id
Type: SystemUInt32
ID of adapter to get.
adapter
Type: T
Adapter reference if found; otherwise null.

Return Value

Type: Boolean
true if adapter with the specified id was found; otherwise false.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).TryGetAdapterByName Method

Grid Solutions Framework AdapterCollectionBaseTTryGetAdapterByName Method
Attempts to get the adapter with the specified name.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryGetAdapterByName(
    string name,
    out T adapter
)
Public Overridable Function TryGetAdapterByName (
    name As String,
    <OutAttribute> ByRef adapter As T
) As Boolean
abstract TryGetAdapterByName :
        name : string *
        adapter : 'T byref -> bool
override TryGetAdapterByName :
        name : string *
        adapter : 'T byref -> bool
function TryGetAdapterByName(name, adapter);
public:
virtual bool TryGetAdapterByName(
    String^ name,
    [OutAttribute] T% adapter
)

Parameters

name
Type: SystemString
Name of adapter to get.
adapter
Type: T
Adapter reference if found; otherwise null.

Return Value

Type: Boolean
true if adapter with the specified name was found; otherwise false.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).TryInitializeAdapterByID Method

Grid Solutions Framework AdapterCollectionBaseTTryInitializeAdapterByID Method
Attempts to initialize (or reinitialize) an individual IAdapter based on its ID.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TryInitializeAdapterByID(
    uint id
)
Public Overridable Function TryInitializeAdapterByID (
    id As UInteger
) As Boolean
abstract TryInitializeAdapterByID :
        id : uint32 -> bool
override TryInitializeAdapterByID :
        id : uint32 -> bool
function TryInitializeAdapterByID(id);
public:
virtual bool TryInitializeAdapterByID(
    unsigned int id
)

Parameters

id
Type: SystemUInt32
The numeric ID associated with the IAdapter to be initialized.

Return Value

Type: Boolean
true if item was successfully initialized; otherwise false.

Implements

IAdapterCollectionTryInitializeAdapterByID(UInt32)
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T) Properties

Grid Solutions Framework AdapterCollectionBaseT Properties

The AdapterCollectionBaseT generic type exposes the following members.

Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection.
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT.
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT.
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT.
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT.
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT.
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any.
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only.
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT.
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any.
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter.
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT.
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing.
Top
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).AutoInitialize Property

Grid Solutions Framework AdapterCollectionBaseTAutoInitialize Property
Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool AutoInitialize { get; }
Protected Overridable ReadOnly Property AutoInitialize As Boolean
    Get
abstract AutoInitialize : bool with get
override AutoInitialize : bool with get
function get_AutoInitialize();

protected:
virtual property bool AutoInitialize {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).AutoStart Property

Grid Solutions Framework AdapterCollectionBaseTAutoStart Property
Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool AutoStart { get; set; }
Public Overridable Property AutoStart As Boolean
    Get
    Set
abstract AutoStart : bool with get, set
override AutoStart : bool with get, set
function get_AutoStart();
function set_AutoStart(value);
public:
virtual property bool AutoStart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IAdapterAutoStart
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ConnectionString Property

Grid Solutions Framework AdapterCollectionBaseTConnectionString Property
Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ConnectionString { get; set; }
Public Overridable Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set
override ConnectionString : string with get, set
function get_ConnectionString();
function set_ConnectionString(value);
public:
virtual property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterConnectionString
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).DataMember Property

Grid Solutions Framework AdapterCollectionBaseTDataMember Property
Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string DataMember { get; set; }
Public Overridable Property DataMember As String
    Get
    Set
abstract DataMember : string with get, set
override DataMember : string with get, set
function get_DataMember();
function set_DataMember(value);
public:
virtual property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterCollectionDataMember
Remarks
Table name specified in DataMember from DataSource is expected to have the following table column names:
ID, AdapterName, AssemblyName, TypeName, ConnectionString
ID column type should be integer based, all other column types are expected to be string based.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).DataSource Property

Grid Solutions Framework AdapterCollectionBaseTDataSource Property
Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataSet DataSource { get; set; }
Public Overridable Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get ();
    void set (DataSet^ value);
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
Remarks
Table name specified in DataMember from DataSource is expected to have the following table column names:
ID, AdapterName, AssemblyName, TypeName, ConnectionString
ID column type should be integer based, all other column types are expected to be string based.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Enabled Property

Grid Solutions Framework AdapterCollectionBaseTEnabled Property
Gets or sets enabled state of this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Enabled { get; set; }
Public Overridable Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ID Property

Grid Solutions Framework AdapterCollectionBaseTID Property
Gets or sets numeric ID associated with this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual uint ID { get; set; }
Public Overridable Property ID As UInteger
    Get
    Set
abstract ID : uint32 with get, set
override ID : uint32 with get, set
function get_ID();
function set_ID(value);
public:
virtual property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32

Implements

IAdapterID
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).InitializationTimeout Property

Grid Solutions Framework AdapterCollectionBaseTInitializationTimeout Property
Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int InitializationTimeout { get; set; }
Public Overridable Property InitializationTimeout As Integer
    Get
    Set
abstract InitializationTimeout : int with get, set
override InitializationTimeout : int with get, set
function get_InitializationTimeout();
function set_InitializationTimeout(value);
public:
virtual property int InitializationTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IAdapterInitializationTimeout
Remarks
Set to Infinite to wait indefinitely.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Initialized Property

Grid Solutions Framework AdapterCollectionBaseTInitialized Property
Gets or sets flag indicating if the adapter collection has been initialized successfully.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Initialized { get; set; }
Public Overridable Property Initialized As Boolean
    Get
    Set
abstract Initialized : bool with get, set
override Initialized : bool with get, set
function get_Initialized();
function set_Initialized(value);
public:
virtual property bool Initialized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IAdapterInitialized
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).InputMeasurementKeys Property

Grid Solutions Framework AdapterCollectionBaseTInputMeasurementKeys Property
Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] InputMeasurementKeys { get; set; }
Public Overridable Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract InputMeasurementKeys : MeasurementKey[] with get, set
override InputMeasurementKeys : MeasurementKey[] with get, set
function get_InputMeasurementKeys();
function set_InputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ InputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IAdapterInputMeasurementKeys
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).InputSourceIDs Property

Grid Solutions Framework AdapterCollectionBaseTInputSourceIDs Property
Gets or sets Source values used to filter input measurement keys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] InputSourceIDs { get; set; }
Public Overridable Property InputSourceIDs As String()
    Get
    Set
abstract InputSourceIDs : string[] with get, set
override InputSourceIDs : string[] with get, set
function get_InputSourceIDs();
function set_InputSourceIDs(value);
public:
virtual property array<String^>^ InputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
Remarks
The collection classes simply track this value if assigned, no automatic action is taken.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).IsDisposed Property

Grid Solutions Framework AdapterCollectionBaseTIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).IsReadOnly Property

Grid Solutions Framework AdapterCollectionBaseTIsReadOnly Property
Gets a value indicating whether the AdapterCollectionBaseT is read-only.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool IsReadOnly { get; }
Public Overridable ReadOnly Property IsReadOnly As Boolean
    Get
abstract IsReadOnly : bool with get
override IsReadOnly : bool with get
function get_IsReadOnly();

public:
virtual property bool IsReadOnly {
    bool get ();
}

Property Value

Type: Boolean

Implements

ICollectionTIsReadOnly
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).MonitorTimerEnabled Property

Grid Solutions Framework AdapterCollectionBaseTMonitorTimerEnabled Property
Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool MonitorTimerEnabled { get; set; }
Protected Overridable Property MonitorTimerEnabled As Boolean
    Get
    Set
abstract MonitorTimerEnabled : bool with get, set
override MonitorTimerEnabled : bool with get, set
function get_MonitorTimerEnabled();
function set_MonitorTimerEnabled(value);
protected:
virtual property bool MonitorTimerEnabled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Name Property

Grid Solutions Framework AdapterCollectionBaseTName Property
Gets or sets the name of this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IAdapterName
IProvideStatusName
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OutputMeasurements Property

Grid Solutions Framework AdapterCollectionBaseTOutputMeasurements Property
Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IMeasurement[] OutputMeasurements { get; set; }
Public Overridable Property OutputMeasurements As IMeasurement()
    Get
    Set
abstract OutputMeasurements : IMeasurement[] with get, set
override OutputMeasurements : IMeasurement[] with get, set
function get_OutputMeasurements();
function set_OutputMeasurements(value);
public:
virtual property array<IMeasurement^>^ OutputMeasurements {
    array<IMeasurement^>^ get ();
    void set (array<IMeasurement^>^ value);
}

Property Value

Type: IMeasurement

Implements

IAdapterOutputMeasurements
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OutputSourceIDs Property

Grid Solutions Framework AdapterCollectionBaseTOutputSourceIDs Property
Gets or sets Source values used to filter output measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] OutputSourceIDs { get; set; }
Public Overridable Property OutputSourceIDs As String()
    Get
    Set
abstract OutputSourceIDs : string[] with get, set
override OutputSourceIDs : string[] with get, set
function get_OutputSourceIDs();
function set_OutputSourceIDs(value);
public:
virtual property array<String^>^ OutputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
Remarks
The collection classes simply track this value if assigned, no automatic action is taken.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ProcessedMeasurements Property

Grid Solutions Framework AdapterCollectionBaseTProcessedMeasurements Property
Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual long ProcessedMeasurements { get; }
Public Overridable ReadOnly Property ProcessedMeasurements As Long
    Get
abstract ProcessedMeasurements : int64 with get
override ProcessedMeasurements : int64 with get
function get_ProcessedMeasurements();

public:
virtual property long long ProcessedMeasurements {
    long long get ();
}

Property Value

Type: Int64

Implements

IAdapterProcessedMeasurements
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ProcessingInterval Property

Grid Solutions Framework AdapterCollectionBaseTProcessingInterval Property
Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ProcessingInterval { get; set; }
Public Overridable Property ProcessingInterval As Integer
    Get
    Set
abstract ProcessingInterval : int with get, set
override ProcessingInterval : int with get, set
function get_ProcessingInterval();
function set_ProcessingInterval(value);
public:
virtual property int ProcessingInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32

Implements

IAdapterProcessingInterval
Remarks
With the exception of the values of -1 and 0, this value specifies the desired processing interval for data, i.e., basically a delay, or timer interval, over which to process data. A value of -1 means to use the default processing interval while a value of 0 means to process data as fast as possible.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).RequestedInputMeasurementKeys Property

Grid Solutions Framework AdapterCollectionBaseTRequestedInputMeasurementKeys Property
Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedInputMeasurementKeys { get; set; }
Public Overridable Property RequestedInputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedInputMeasurementKeys : MeasurementKey[] with get, set
override RequestedInputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedInputMeasurementKeys();
function set_RequestedInputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedInputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).RequestedOutputMeasurementKeys Property

Grid Solutions Framework AdapterCollectionBaseTRequestedOutputMeasurementKeys Property
Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedOutputMeasurementKeys { get; set; }
Public Overridable Property RequestedOutputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
override RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedOutputMeasurementKeys();
function set_RequestedOutputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedOutputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Settings Property

Grid Solutions Framework AdapterCollectionBaseTSettings Property
Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Dictionary<string, string> Settings { get; }
Public ReadOnly Property Settings As Dictionary(Of String, String)
    Get
abstract Settings : Dictionary<string, string> with get
override Settings : Dictionary<string, string> with get
function get_Settings();

public:
virtual property Dictionary<String^, String^>^ Settings {
    Dictionary<String^, String^>^ get () sealed;
}

Property Value

Type: Dictionary String, String

Implements

IAdapterSettings
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).StartTimeConstraint Property

Grid Solutions Framework AdapterCollectionBaseTStartTimeConstraint Property
Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DateTime StartTimeConstraint { get; }
Public Overridable ReadOnly Property StartTimeConstraint As DateTime
    Get
abstract StartTimeConstraint : DateTime with get
override StartTimeConstraint : DateTime with get
function get_StartTimeConstraint();

public:
virtual property DateTime StartTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime

Implements

IAdapterStartTimeConstraint
Remarks
This value will be MinValue when start time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Status Property

Grid Solutions Framework AdapterCollectionBaseTStatus Property
Gets the descriptive status of this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).StopTimeConstraint Property

Grid Solutions Framework AdapterCollectionBaseTStopTimeConstraint Property
Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DateTime StopTimeConstraint { get; }
Public Overridable ReadOnly Property StopTimeConstraint As DateTime
    Get
abstract StopTimeConstraint : DateTime with get
override StopTimeConstraint : DateTime with get
function get_StopTimeConstraint();

public:
virtual property DateTime StopTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime

Implements

IAdapterStopTimeConstraint
Remarks
This value will be MaxValue when stop time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).SupportsTemporalProcessing Property

Grid Solutions Framework AdapterCollectionBaseTSupportsTemporalProcessing Property
Gets the flag indicating if this adapter collection supports temporal processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool SupportsTemporalProcessing { get; }
Public Overridable ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get
override SupportsTemporalProcessing : bool with get
function get_SupportsTemporalProcessing();

public:
virtual property bool SupportsTemporalProcessing {
    bool get ();
}

Property Value

Type: Boolean

Implements

IAdapterSupportsTemporalProcessing
Remarks
For collections this defaults to false.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T) Events

Grid Solutions Framework AdapterCollectionBaseT Events

The AdapterCollectionBaseT generic type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed.
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ConfigurationChanged Event

Grid Solutions Framework AdapterCollectionBaseTConfigurationChanged Event
Event is raised when adapter is aware of a configuration change.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
override ConfigurationChanged : IEvent<EventHandler,
    EventArgs>
function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
public:
virtual  event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterConfigurationChanged
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).Disposed Event

Grid Solutions Framework AdapterCollectionBaseTDisposed Event
Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).InputMeasurementKeysUpdated Event

Grid Solutions Framework AdapterCollectionBaseTInputMeasurementKeysUpdated Event
Event is raised when InputMeasurementKeys are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler InputMeasurementKeysUpdated
Public Event InputMeasurementKeysUpdated As EventHandler
abstract InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>
override InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>
function add_InputMeasurementKeysUpdated(value);
function remove_InputMeasurementKeysUpdated(value);
public:
virtual  event EventHandler^ InputMeasurementKeysUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterInputMeasurementKeysUpdated
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).OutputMeasurementsUpdated Event

Grid Solutions Framework AdapterCollectionBaseTOutputMeasurementsUpdated Event
Event is raised when OutputMeasurements are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler OutputMeasurementsUpdated
Public Event OutputMeasurementsUpdated As EventHandler
abstract OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>
override OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>
function add_OutputMeasurementsUpdated(value);
function remove_OutputMeasurementsUpdated(value);
public:
virtual  event EventHandler^ OutputMeasurementsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IAdapterOutputMeasurementsUpdated
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).ProcessException Event

Grid Solutions Framework AdapterCollectionBaseTProcessException Event
Event is raised when there is an exception encountered while processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ProcessException(value);
function remove_ProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IAdapterProcessException
Remarks
Argument is the exception that was thrown.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCollectionBase(T).StatusMessage Event

Grid Solutions Framework AdapterCollectionBaseTStatusMessage Event
Provides status messages to consumer.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IAdapterStatusMessage
Remarks
Argument is new status message.
See Also

Reference

AdapterCollectionBaseT Class
GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute Class

Grid Solutions Framework AdapterCommandAttribute Class
Represents an attribute that allows a method in an IAdapter class to be exposed as an invokable command.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.TimeSeries.AdaptersAdapterCommandAttribute

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Method)]
public sealed class AdapterCommandAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Method)>
Public NotInheritable Class AdapterCommandAttribute
    Inherits Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Method)>]
type AdapterCommandAttribute =
    class
        inherit Attribute
    end
GSF.TimeSeries.Adapters.AdapterCommandAttribute = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.AdapterCommandAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Method)]
public ref class AdapterCommandAttribute sealed : public Attribute

The AdapterCommandAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | AdapterCommandAttribute(String) | Creates a new AdapterCommandAttribute with the specified description value.
Public method | AdapterCommandAttribute(String, String) | Creates a new AdapterCommandAttribute with the specified description value.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowedRoles | Gets the roles which are allowed to invoke this adapter command.
Public property | Description | Gets the description of this adapter command.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Remarks
Only public methods will be exposed as invokable.
See Also

Reference

GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute Constructor

Grid Solutions Framework AdapterCommandAttribute Constructor
Overload List
 | Name | Description
Public method | AdapterCommandAttribute(String) | Creates a new AdapterCommandAttribute with the specified description value.
Public method | AdapterCommandAttribute(String, String) | Creates a new AdapterCommandAttribute with the specified description value.
Top
See Also

Reference

AdapterCommandAttribute Class
GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute Constructor (String)

Grid Solutions Framework AdapterCommandAttribute Constructor (String)
Creates a new AdapterCommandAttribute with the specified description value.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdapterCommandAttribute(
    string description
)
Public Sub New (
    description As String
)
new :
        description : string -> AdapterCommandAttribute
GSF.TimeSeries.Adapters.AdapterCommandAttribute = function(description);
public:
AdapterCommandAttribute(
    String^ description
)

Parameters

description
Type: SystemString
Assigns the description for this adapter command.
See Also

Reference

AdapterCommandAttribute Class
AdapterCommandAttribute Overload
GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute Constructor (String, String[])

Grid Solutions Framework AdapterCommandAttribute Constructor (String, String)
Creates a new AdapterCommandAttribute with the specified description value.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AdapterCommandAttribute(
    string description,
    params string[] allowedRoles
)
Public Sub New (
    description As String,
    ParamArray allowedRoles As String()
)
new :
        description : string *
        allowedRoles : string[] -> AdapterCommandAttribute
GSF.TimeSeries.Adapters.AdapterCommandAttribute = function(description, ... allowedRoles);
public:
AdapterCommandAttribute(
    String^ description,
    ... array<String^>^ allowedRoles
)

Parameters

description
Type: SystemString
Assigns the description for this adapter command.
allowedRoles
Type: SystemString
Assigns the roles which are allowed to invoke this adapter command.
See Also

Reference

AdapterCommandAttribute Class
AdapterCommandAttribute Overload
GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute Methods

Grid Solutions Framework AdapterCommandAttribute Methods

The AdapterCommandAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AdapterCommandAttribute Class
GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute Properties

Grid Solutions Framework AdapterCommandAttribute Properties

The AdapterCommandAttribute type exposes the following members.

Properties
 | Name | Description
Public property | AllowedRoles | Gets the roles which are allowed to invoke this adapter command.
Public property | Description | Gets the description of this adapter command.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

AdapterCommandAttribute Class
GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute.AllowedRoles Property

Grid Solutions Framework AdapterCommandAttributeAllowedRoles Property
Gets the roles which are allowed to invoke this adapter command.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string[] AllowedRoles { get; }
Public ReadOnly Property AllowedRoles As String()
    Get
member AllowedRoles : string[] with get

function get_AllowedRoles();

public:
property array<String^>^ AllowedRoles {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

AdapterCommandAttribute Class
GSF.TimeSeries.Adapters Namespace


AdapterCommandAttribute.Description Property

Grid Solutions Framework AdapterCommandAttributeDescription Property
Gets the description of this adapter command.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Description { get; }
Public ReadOnly Property Description As String
    Get
member Description : string with get

function get_Description();

public:
property String^ Description {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

AdapterCommandAttribute Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection Class

Grid Solutions Framework AllAdaptersCollection Class
Represents a collection of all IAdapterCollection implementations (i.e., a collection of IAdapterCollection's).
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IAdapterCollection
GSF.CollectionsListCollection IAdapterCollection
GSF.TimeSeries.AdaptersAdapterCollectionBase IAdapterCollection
GSF.TimeSeries.AdaptersAllAdaptersCollection

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AllAdaptersCollection : AdapterCollectionBase<IAdapterCollection>
Public Class AllAdaptersCollection
    Inherits AdapterCollectionBase(Of IAdapterCollection)
type AllAdaptersCollection =
    class
        inherit AdapterCollectionBase<IAdapterCollection>
    end
GSF.TimeSeries.Adapters.AllAdaptersCollection = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.AllAdaptersCollection',
    GSF.TimeSeries.Adapters.AdapterCollectionBase`1);
public ref class AllAdaptersCollection : public AdapterCollectionBase<IAdapterCollection^>

The AllAdaptersCollection type exposes the following members.

Constructors
 | Name | Description
Public method | AllAdaptersCollection | Constructs a new instance of the AllAdaptersCollection.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Un-wires events and disposes of IAdapter implementation. (Inherited from AdapterCollectionBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Initializes each IAdapterCollection implementation in this AllAdaptersCollection. (Overrides AdapterCollectionBaseTInitialize.)
Protected method | InitializeItem | Wires events and initializes new IAdapter implementation. (Inherited from AdapterCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | This method is not implemented in AllAdaptersCollection. (Overrides AdapterCollectionBaseTTryCreateAdapter(DataRow, T).)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | This method is not implemented in AllAdaptersCollection. (Overrides AdapterCollectionBaseTTryGetAdapterByID(UInt32, T).)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAnyAdapterByID | Attempts to get any adapter in all collections with the specified id.
Public method | TryGetAnyAdapterByName | Attempts to get any adapter in all collections with the specified name.
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID from any collection. (Overrides AdapterCollectionBaseTTryInitializeAdapterByID(UInt32).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Overrides AdapterCollectionBaseTAutoInitialize.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Overrides AdapterCollectionBaseTDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Top
Remarks
This collection allows all IAdapterCollection implementations to be managed as a group.
See Also

Reference

GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection Constructor

Grid Solutions Framework AllAdaptersCollection Constructor
Constructs a new instance of the AllAdaptersCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AllAdaptersCollection()
Public Sub New
new : unit -> AllAdaptersCollection
GSF.TimeSeries.Adapters.AllAdaptersCollection = function();
public:
AllAdaptersCollection()
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection Methods

Grid Solutions Framework AllAdaptersCollection Methods

The AllAdaptersCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Un-wires events and disposes of IAdapter implementation. (Inherited from AdapterCollectionBaseT.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Initializes each IAdapterCollection implementation in this AllAdaptersCollection. (Overrides AdapterCollectionBaseTInitialize.)
Protected method | InitializeItem | Wires events and initializes new IAdapter implementation. (Inherited from AdapterCollectionBaseT.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | This method is not implemented in AllAdaptersCollection. (Overrides AdapterCollectionBaseTTryCreateAdapter(DataRow, T).)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | This method is not implemented in AllAdaptersCollection. (Overrides AdapterCollectionBaseTTryGetAdapterByID(UInt32, T).)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAnyAdapterByID | Attempts to get any adapter in all collections with the specified id.
Public method | TryGetAnyAdapterByName | Attempts to get any adapter in all collections with the specified name.
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID from any collection. (Overrides AdapterCollectionBaseTTryInitializeAdapterByID(UInt32).)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.Initialize Method

Grid Solutions Framework AllAdaptersCollectionInitialize Method
Initializes each IAdapterCollection implementation in this AllAdaptersCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.TryCreateAdapter Method

Grid Solutions Framework AllAdaptersCollectionTryCreateAdapter Method
This method is not implemented in AllAdaptersCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool TryCreateAdapter(
    DataRow adapterRow,
    out IAdapterCollection adapter
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function TryCreateAdapter (
    adapterRow As DataRow,
    <OutAttribute> ByRef adapter As IAdapterCollection
) As Boolean
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract TryCreateAdapter :
        adapterRow : DataRow *
        adapter : IAdapterCollection byref -> bool
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override TryCreateAdapter :
        adapterRow : DataRow *
        adapter : IAdapterCollection byref -> bool
function TryCreateAdapter(adapterRow, adapter);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual bool TryCreateAdapter(
    DataRow^ adapterRow,
    [OutAttribute] IAdapterCollection^% adapter
) override

Parameters

adapterRow
Type: System.DataDataRow

[Missing <param name="adapterRow"/> documentation for "M:GSF.TimeSeries.Adapters.AllAdaptersCollection.TryCreateAdapter(System.Data.DataRow,GSF.TimeSeries.Adapters.IAdapterCollection@)"]

adapter
Type: GSF.TimeSeries.AdaptersIAdapterCollection

[Missing <param name="adapter"/> documentation for "M:GSF.TimeSeries.Adapters.AllAdaptersCollection.TryCreateAdapter(System.Data.DataRow,GSF.TimeSeries.Adapters.IAdapterCollection@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.TimeSeries.Adapters.AllAdaptersCollection.TryCreateAdapter(System.Data.DataRow,GSF.TimeSeries.Adapters.IAdapterCollection@)"]

See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.TryGetAdapterByID Method

Grid Solutions Framework AllAdaptersCollectionTryGetAdapterByID Method
This method is not implemented in AllAdaptersCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public override bool TryGetAdapterByID(
    uint ID,
    out IAdapterCollection adapter
)
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Overrides Function TryGetAdapterByID (
    ID As UInteger,
    <OutAttribute> ByRef adapter As IAdapterCollection
) As Boolean
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
abstract TryGetAdapterByID :
        ID : uint32 *
        adapter : IAdapterCollection byref -> bool
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
override TryGetAdapterByID :
        ID : uint32 *
        adapter : IAdapterCollection byref -> bool
function TryGetAdapterByID(ID, adapter);
public:
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
virtual bool TryGetAdapterByID(
    unsigned int ID,
    [OutAttribute] IAdapterCollection^% adapter
) override

Parameters

ID
Type: SystemUInt32

[Missing <param name="ID"/> documentation for "M:GSF.TimeSeries.Adapters.AllAdaptersCollection.TryGetAdapterByID(System.UInt32,GSF.TimeSeries.Adapters.IAdapterCollection@)"]

adapter
Type: GSF.TimeSeries.AdaptersIAdapterCollection

[Missing <param name="adapter"/> documentation for "M:GSF.TimeSeries.Adapters.AllAdaptersCollection.TryGetAdapterByID(System.UInt32,GSF.TimeSeries.Adapters.IAdapterCollection@)"]

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.TimeSeries.Adapters.AllAdaptersCollection.TryGetAdapterByID(System.UInt32,GSF.TimeSeries.Adapters.IAdapterCollection@)"]

See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.TryGetAnyAdapterByID Method

Grid Solutions Framework AllAdaptersCollectionTryGetAnyAdapterByID Method
Attempts to get any adapter in all collections with the specified id.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetAnyAdapterByID(
    uint id,
    out IAdapter adapter,
    out IAdapterCollection adapterCollection
)
Public Function TryGetAnyAdapterByID (
    id As UInteger,
    <OutAttribute> ByRef adapter As IAdapter,
    <OutAttribute> ByRef adapterCollection As IAdapterCollection
) As Boolean
member TryGetAnyAdapterByID :
        id : uint32 *
        adapter : IAdapter byref *
        adapterCollection : IAdapterCollection byref -> bool

function TryGetAnyAdapterByID(id, adapter, adapterCollection);
public:
bool TryGetAnyAdapterByID(
    unsigned int id,
    [OutAttribute] IAdapter^% adapter,
    [OutAttribute] IAdapterCollection^% adapterCollection
)

Parameters

id
Type: SystemUInt32
ID of adapter to get.
adapter
Type: GSF.TimeSeries.AdaptersIAdapter
Adapter reference if found; otherwise null.
adapterCollection
Type: GSF.TimeSeries.AdaptersIAdapterCollection
Adapter collection reference if adapter is found; otherwise null.

Return Value

Type: Boolean
true if adapter with the specified id was found; otherwise false.
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.TryGetAnyAdapterByName Method

Grid Solutions Framework AllAdaptersCollectionTryGetAnyAdapterByName Method
Attempts to get any adapter in all collections with the specified name.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool TryGetAnyAdapterByName(
    string name,
    out IAdapter adapter,
    out IAdapterCollection adapterCollection
)
Public Function TryGetAnyAdapterByName (
    name As String,
    <OutAttribute> ByRef adapter As IAdapter,
    <OutAttribute> ByRef adapterCollection As IAdapterCollection
) As Boolean
member TryGetAnyAdapterByName :
        name : string *
        adapter : IAdapter byref *
        adapterCollection : IAdapterCollection byref -> bool

function TryGetAnyAdapterByName(name, adapter, adapterCollection);
public:
bool TryGetAnyAdapterByName(
    String^ name,
    [OutAttribute] IAdapter^% adapter,
    [OutAttribute] IAdapterCollection^% adapterCollection
)

Parameters

name
Type: SystemString
Name of adapter to get.
adapter
Type: GSF.TimeSeries.AdaptersIAdapter
Adapter reference if found; otherwise null.
adapterCollection
Type: GSF.TimeSeries.AdaptersIAdapterCollection
Adapter collection reference if adapter is found; otherwise null.

Return Value

Type: Boolean
true if adapter with the specified name was found; otherwise false.
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.TryInitializeAdapterByID Method

Grid Solutions Framework AllAdaptersCollectionTryInitializeAdapterByID Method
Attempts to initialize (or reinitialize) an individual IAdapter based on its ID from any collection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool TryInitializeAdapterByID(
    uint id
)
Public Overrides Function TryInitializeAdapterByID (
    id As UInteger
) As Boolean
abstract TryInitializeAdapterByID :
        id : uint32 -> bool
override TryInitializeAdapterByID :
        id : uint32 -> bool
function TryInitializeAdapterByID(id);
public:
virtual bool TryInitializeAdapterByID(
    unsigned int id
) override

Parameters

id
Type: SystemUInt32
The numeric ID associated with the IAdapter to be initialized.

Return Value

Type: Boolean
true if item was successfully initialized; otherwise false.

Implements

IAdapterCollectionTryInitializeAdapterByID(UInt32)
Remarks
This method traverses all collections looking for an adapter with the specified ID.
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection Properties

Grid Solutions Framework AllAdaptersCollection Properties

The AllAdaptersCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Overrides AdapterCollectionBaseTAutoInitialize.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Overrides AdapterCollectionBaseTDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.AutoInitialize Property

Grid Solutions Framework AllAdaptersCollectionAutoInitialize Property
Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool AutoInitialize { get; }
Protected Overrides ReadOnly Property AutoInitialize As Boolean
    Get
abstract AutoInitialize : bool with get
override AutoInitialize : bool with get
function get_AutoInitialize();

protected:
virtual property bool AutoInitialize {
    bool get () override;
}

Property Value

Type: Boolean
Remarks
We don't auto-initialize collections added to the AllAdaptersCollection since no data source will be available when the collections are being created.
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection.DataSource Property

Grid Solutions Framework AllAdaptersCollectionDataSource Property
Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSet DataSource { get; set; }
Public Overrides Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get () override;
    void set (DataSet^ value) override;
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
Remarks
Table name specified in DataMember from DataSource is expected to have the following table column names:
ID, AdapterName, AssemblyName, TypeName, ConnectionString
ID column type should be integer based, all other column types are expected to be string based.
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


AllAdaptersCollection Events

Grid Solutions Framework AllAdaptersCollection Events

The AllAdaptersCollection type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Top
See Also

Reference

AllAdaptersCollection Class
GSF.TimeSeries.Adapters Namespace


ConnectionStringParameterAttribute Class

Grid Solutions Framework ConnectionStringParameterAttribute Class
Marks a parameter as being a connection string parameter used to configure an IAdapter.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.TimeSeries.AdaptersConnectionStringParameterAttribute

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Property)]
public sealed class ConnectionStringParameterAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Property)>
Public NotInheritable Class ConnectionStringParameterAttribute
    Inherits Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Property)>]
type ConnectionStringParameterAttribute =
    class
        inherit Attribute
    end
GSF.TimeSeries.Adapters.ConnectionStringParameterAttribute = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.ConnectionStringParameterAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Property)]
public ref class ConnectionStringParameterAttribute sealed : public Attribute

The ConnectionStringParameterAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | ConnectionStringParameterAttribute | Initializes a new instance of the ConnectionStringParameterAttribute class
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


ConnectionStringParameterAttribute Constructor

Grid Solutions Framework ConnectionStringParameterAttribute Constructor
Initializes a new instance of the ConnectionStringParameterAttribute class

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConnectionStringParameterAttribute()
Public Sub New
new : unit -> ConnectionStringParameterAttribute
GSF.TimeSeries.Adapters.ConnectionStringParameterAttribute = function();
public:
ConnectionStringParameterAttribute()
See Also

Reference

ConnectionStringParameterAttribute Class
GSF.TimeSeries.Adapters Namespace


ConnectionStringParameterAttribute Methods

Grid Solutions Framework ConnectionStringParameterAttribute Methods

The ConnectionStringParameterAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ConnectionStringParameterAttribute Class
GSF.TimeSeries.Adapters Namespace


ConnectionStringParameterAttribute Properties

Grid Solutions Framework ConnectionStringParameterAttribute Properties

The ConnectionStringParameterAttribute type exposes the following members.

Properties
 | Name | Description
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

ConnectionStringParameterAttribute Class
GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute Class

Grid Solutions Framework CustomConfigurationEditorAttribute Class
Marks a parameter or class as having a custom configuration editor page used to configure that parameter or class.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.TimeSeries.AdaptersCustomConfigurationEditorAttribute

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Property)]
public class CustomConfigurationEditorAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Class Or AttributeTargets.Property)>
Public Class CustomConfigurationEditorAttribute
    Inherits Attribute
[<AttributeUsageAttribute(AttributeTargets.Class|AttributeTargets.Property)>]
type CustomConfigurationEditorAttribute =
    class
        inherit Attribute
    end
GSF.TimeSeries.Adapters.CustomConfigurationEditorAttribute = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.CustomConfigurationEditorAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Class|AttributeTargets::Property)]
public ref class CustomConfigurationEditorAttribute : public Attribute

The CustomConfigurationEditorAttribute type exposes the following members.

Constructors
 | Name | Description
Public method | CustomConfigurationEditorAttribute(Type, String) | Creates a new instance of the CustomConfigurationEditorAttribute class.
Public method | CustomConfigurationEditorAttribute(String, String, String) | Creates a new instance of the CustomConfigurationEditorAttribute class.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConnectionString | Gets the connection string used to configure the editor.
Public property | EditorType | Gets the type of the UI editor used to configure the custom adapter.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute Constructor

Grid Solutions Framework CustomConfigurationEditorAttribute Constructor
Overload List
 | Name | Description
Public method | CustomConfigurationEditorAttribute(Type, String) | Creates a new instance of the CustomConfigurationEditorAttribute class.
Public method | CustomConfigurationEditorAttribute(String, String, String) | Creates a new instance of the CustomConfigurationEditorAttribute class.
Top
See Also

Reference

CustomConfigurationEditorAttribute Class
GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute Constructor (Type, String)

Grid Solutions Framework CustomConfigurationEditorAttribute Constructor (Type, String)
Creates a new instance of the CustomConfigurationEditorAttribute class.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CustomConfigurationEditorAttribute(
    Type editorType,
    string connectionString = null
)
Public Sub New (
    editorType As Type,
    Optional connectionString As String = Nothing
)
new :
        editorType : Type *
        ?connectionString : string
(* Defaults:
        let _connectionString = defaultArg connectionString null
*)
-> CustomConfigurationEditorAttribute
GSF.TimeSeries.Adapters.CustomConfigurationEditorAttribute = function(editorType, connectionString);
public:
CustomConfigurationEditorAttribute(
    Type^ editorType,
    String^ connectionString = nullptr
)

Parameters

editorType
Type: SystemType
The type of the editor.
connectionString (Optional)
Type: SystemString
The connection string for the custom configuration screen.
See Also

Reference

CustomConfigurationEditorAttribute Class
CustomConfigurationEditorAttribute Overload
GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute Constructor (String, String, String)

Grid Solutions Framework CustomConfigurationEditorAttribute Constructor (String, String, String)
Creates a new instance of the CustomConfigurationEditorAttribute class.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CustomConfigurationEditorAttribute(
    string assemblyName,
    string typeName,
    string connectionString = null
)
Public Sub New (
    assemblyName As String,
    typeName As String,
    Optional connectionString As String = Nothing
)
new :
        assemblyName : string *
        typeName : string *
        ?connectionString : string
(* Defaults:
        let _connectionString = defaultArg connectionString null
*)
-> CustomConfigurationEditorAttribute
GSF.TimeSeries.Adapters.CustomConfigurationEditorAttribute = function(assemblyName, typeName, connectionString);
public:
CustomConfigurationEditorAttribute(
    String^ assemblyName,
    String^ typeName,
    String^ connectionString = nullptr
)

Parameters

assemblyName
Type: SystemString
The name of the assembly in which the editor type resides.
typeName
Type: SystemString
The full name of the type of the editor.
connectionString (Optional)
Type: SystemString
The connection string for the custom configuration screen.
See Also

Reference

CustomConfigurationEditorAttribute Class
CustomConfigurationEditorAttribute Overload
GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute Methods

Grid Solutions Framework CustomConfigurationEditorAttribute Methods

The CustomConfigurationEditorAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CustomConfigurationEditorAttribute Class
GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute Properties

Grid Solutions Framework CustomConfigurationEditorAttribute Properties

The CustomConfigurationEditorAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString | Gets the connection string used to configure the editor.
Public property | EditorType | Gets the type of the UI editor used to configure the custom adapter.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

CustomConfigurationEditorAttribute Class
GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute.ConnectionString Property

Grid Solutions Framework CustomConfigurationEditorAttributeConnectionString Property
Gets the connection string used to configure the editor.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString { get; }
Public ReadOnly Property ConnectionString As String
    Get
member ConnectionString : string with get

function get_ConnectionString();

public:
property String^ ConnectionString {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

CustomConfigurationEditorAttribute Class
GSF.TimeSeries.Adapters Namespace


CustomConfigurationEditorAttribute.EditorType Property

Grid Solutions Framework CustomConfigurationEditorAttributeEditorType Property
Gets the type of the UI editor used to configure the custom adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Type EditorType { get; }
Public ReadOnly Property EditorType As Type
    Get
member EditorType : Type with get

function get_EditorType();

public:
property Type^ EditorType {
    Type^ get ();
}

Property Value

Type: Type
See Also

Reference

CustomConfigurationEditorAttribute Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase Class

Grid Solutions Framework FacileActionAdapterBase Class
Represents the base class for simple, non-time-aligned, action adapters.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersAdapterBase
GSF.TimeSeries.AdaptersFacileActionAdapterBase
GSF.TimeSeries.StatisticsStatisticsEngine
GSF.TimeSeries.TransportTemporalClientSubscriptionProxy

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class FacileActionAdapterBase : AdapterBase,
    IActionAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public MustInherit Class FacileActionAdapterBase
    Inherits AdapterBase
    Implements IActionAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
[<AbstractClassAttribute>]
type FacileActionAdapterBase =
    class
        inherit AdapterBase
        interface IActionAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.FacileActionAdapterBase = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.FacileActionAdapterBase',
    GSF.TimeSeries.Adapters.AdapterBase,
    GSF.TimeSeries.Adapters.IActionAdapter,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class FacileActionAdapterBase abstract : public AdapterBase,
    IActionAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The FacileActionAdapterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | FacileActionAdapterBase | Creates a new instance of the FacileActionAdapterBase class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources. (Inherited from AdapterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes FacileActionAdapterBase. (Overrides AdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts the AdapterBase or restarts it if it is already running. (Inherited from AdapterBase.)
Public method | Stop | Stops the AdapterBase. (Inherited from AdapterBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase. (Inherited from AdapterBase.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | FramesPerSecond | Gets or sets the frames per second to be used by the FacileActionAdapterBase.
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the FacileActionAdapterBase expects, if any. (Overrides AdapterBaseInputMeasurementKeys.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values.
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement.
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. (Overrides AdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from AdapterBase.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values.
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real time.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnpublishedSamples | This event is raised by derived class, if needed, to track current number of unpublished seconds of data in the queue.
Top
Remarks
This base class acts on incoming measurements, in a non-time-aligned fashion, for general processing. If derived class needs time-aligned data for processing, the ActionAdapterBase class should be used instead. Derived classes are expected call OnNewMeasurements(ICollectionIMeasurement) for any new measurements that may get created.
See Also

Reference

GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase Constructor

Grid Solutions Framework FacileActionAdapterBase Constructor
Creates a new instance of the FacileActionAdapterBase class.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected FacileActionAdapterBase()
Protected Sub New
new : unit -> FacileActionAdapterBase
GSF.TimeSeries.Adapters.FacileActionAdapterBase = function();
protected:
FacileActionAdapterBase()
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase Methods

Grid Solutions Framework FacileActionAdapterBase Methods

The FacileActionAdapterBase type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources. (Inherited from AdapterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes FacileActionAdapterBase. (Overrides AdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts the AdapterBase or restarts it if it is already running. (Inherited from AdapterBase.)
Public method | Stop | Stops the AdapterBase. (Inherited from AdapterBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.Initialize Method

Grid Solutions Framework FacileActionAdapterBaseInitialize Method
Initializes FacileActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.OnDiscardingMeasurements Method

Grid Solutions Framework FacileActionAdapterBaseOnDiscardingMeasurements Method
Raises the DiscardingMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDiscardingMeasurements(
    IEnumerable<IMeasurement> measurements
)
Protected Overridable Sub OnDiscardingMeasurements (
    measurements As IEnumerable(Of IMeasurement)
)
abstract OnDiscardingMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
override OnDiscardingMeasurements :
        measurements : IEnumerable<IMeasurement> -> unit
function OnDiscardingMeasurements(measurements);
protected:
virtual void OnDiscardingMeasurements(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Enumeration of IMeasurement values being discarded.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.OnNewMeasurements Method

Grid Solutions Framework FacileActionAdapterBaseOnNewMeasurements Method
Raises the NewMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNewMeasurements(
    ICollection<IMeasurement> measurements
)
Protected Overridable Sub OnNewMeasurements (
    measurements As ICollection(Of IMeasurement)
)
abstract OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
override OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
function OnNewMeasurements(measurements);
protected:
virtual void OnNewMeasurements(
    ICollection<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericICollection IMeasurement

[Missing <param name="measurements"/> documentation for "M:GSF.TimeSeries.Adapters.FacileActionAdapterBase.OnNewMeasurements(System.Collections.Generic.ICollection{GSF.TimeSeries.IMeasurement})"]

See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.OnUnpublishedSamples Method

Grid Solutions Framework FacileActionAdapterBaseOnUnpublishedSamples Method
Raises the UnpublishedSamples event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnpublishedSamples(
    int seconds
)
Protected Overridable Sub OnUnpublishedSamples (
    seconds As Integer
)
abstract OnUnpublishedSamples :
        seconds : int -> unit
override OnUnpublishedSamples :
        seconds : int -> unit
function OnUnpublishedSamples(seconds);
protected:
virtual void OnUnpublishedSamples(
    int seconds
)

Parameters

seconds
Type: SystemInt32
Total number of unpublished seconds of data.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.QueueMeasurementForProcessing Method

Grid Solutions Framework FacileActionAdapterBaseQueueMeasurementForProcessing Method
Queues a single measurement for processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void QueueMeasurementForProcessing(
    IMeasurement measurement
)
Public Overridable Sub QueueMeasurementForProcessing (
    measurement As IMeasurement
)
abstract QueueMeasurementForProcessing :
        measurement : IMeasurement -> unit
override QueueMeasurementForProcessing :
        measurement : IMeasurement -> unit
function QueueMeasurementForProcessing(measurement);
public:
virtual void QueueMeasurementForProcessing(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Measurement to queue for processing.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.QueueMeasurementsForProcessing Method

Grid Solutions Framework FacileActionAdapterBaseQueueMeasurementsForProcessing Method
Queues a collection of measurements for processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overridable Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Measurements to queue for processing.

Implements

IActionAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase Properties

Grid Solutions Framework FacileActionAdapterBase Properties

The FacileActionAdapterBase type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase. (Inherited from AdapterBase.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | FramesPerSecond | Gets or sets the frames per second to be used by the FacileActionAdapterBase.
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the FacileActionAdapterBase expects, if any. (Overrides AdapterBaseInputMeasurementKeys.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values.
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement.
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. (Overrides AdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from AdapterBase.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values.
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real time.
Top
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.FramesPerSecond Property

Grid Solutions Framework FacileActionAdapterBaseFramesPerSecond Property
Gets or sets the frames per second to be used by the FacileActionAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(0)]
public virtual int FramesPerSecond { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(0)>
Public Overridable Property FramesPerSecond As Integer
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(0)>]
abstract FramesPerSecond : int with get, set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(0)>]
override FramesPerSecond : int with get, set
function get_FramesPerSecond();
function set_FramesPerSecond(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(0)]
virtual property int FramesPerSecond {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
This value is only tracked in the FacileActionAdapterBase, derived class will determine its use.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.InputMeasurementKeys Property

Grid Solutions Framework FacileActionAdapterBaseInputMeasurementKeys Property
Gets or sets primary keys of input measurements the FacileActionAdapterBase expects, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)]
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(null)]
public override MeasurementKey[] InputMeasurementKeys { get; set; }
<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    Nothing)>
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(Nothing)>
Public Overrides Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(null)>]
abstract InputMeasurementKeys : MeasurementKey[] with get, set
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(null)>]
override InputMeasurementKeys : MeasurementKey[] with get, set
function get_InputMeasurementKeys();
function set_InputMeasurementKeys(value);
public:
[CustomConfigurationEditorAttribute(L"GSF.TimeSeries.UI.WPF.dll", L"GSF.TimeSeries.UI.Editors.MeasurementEditor",
    nullptr)]
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(nullptr)]
virtual property array<MeasurementKey^>^ InputMeasurementKeys {
    array<MeasurementKey^>^ get () override;
    void set (array<MeasurementKey^>^ value) override;
}

Property Value

Type: MeasurementKey

Implements

IAdapterInputMeasurementKeys
IAdapterInputMeasurementKeys
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.InputSourceIDs Property

Grid Solutions Framework FacileActionAdapterBaseInputSourceIDs Property
Gets or sets Source values used to filter input measurement keys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] InputSourceIDs { get; set; }
Public Overridable Property InputSourceIDs As String()
    Get
    Set
abstract InputSourceIDs : string[] with get, set
override InputSourceIDs : string[] with get, set
function get_InputSourceIDs();
function set_InputSourceIDs(value);
public:
virtual property array<String^>^ InputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String

Implements

IActionAdapterInputSourceIDs
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.LagTime Property

Grid Solutions Framework FacileActionAdapterBaseLagTime Property
Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(10)]
[ConnectionStringParameterAttribute]
public double LagTime { get; set; }
<DefaultValueAttribute(10)>
<ConnectionStringParameterAttribute>
Public Property LagTime As Double
    Get
    Set
[<DefaultValueAttribute(10)>]
[<ConnectionStringParameterAttribute>]
member LagTime : float with get, set

function get_LagTime();
function set_LagTime(value);
public:
[DefaultValueAttribute(10)]
[ConnectionStringParameterAttribute]
property double LagTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LagTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to past measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too old.

This becomes the amount of delay introduced by the concentrator to allow time for data to flow into the system.

See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.LatestMeasurements Property

Grid Solutions Framework FacileActionAdapterBaseLatestMeasurements Property
Gets reference to the collection of absolute latest received measurement values.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ImmediateMeasurements LatestMeasurements { get; }
Public Overridable ReadOnly Property LatestMeasurements As ImmediateMeasurements
    Get
abstract LatestMeasurements : ImmediateMeasurements with get
override LatestMeasurements : ImmediateMeasurements with get
function get_LatestMeasurements();

public:
virtual property ImmediateMeasurements^ LatestMeasurements {
    ImmediateMeasurements^ get ();
}

Property Value

Type: ImmediateMeasurements
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.LeadTime Property

Grid Solutions Framework FacileActionAdapterBaseLeadTime Property
Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(5)]
public double LeadTime { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(5)>
Public Property LeadTime As Double
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(5)>]
member LeadTime : float with get, set

function get_LeadTime();
function set_LeadTime(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(5)]
property double LeadTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
Exceptions
Exception | Condition
ArgumentOutOfRangeException | LeadTime must be greater than zero, but it can be less than one.
Remarks

Defines the time sensitivity to future measurement timestamps.

The number of seconds allowed before assuming a measurement timestamp is too advanced.

This becomes the tolerated +/- accuracy of the local clock to real-time.

See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.OutputSourceIDs Property

Grid Solutions Framework FacileActionAdapterBaseOutputSourceIDs Property
Gets or sets Source values used to filter output measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] OutputSourceIDs { get; set; }
Public Overridable Property OutputSourceIDs As String()
    Get
    Set
abstract OutputSourceIDs : string[] with get, set
override OutputSourceIDs : string[] with get, set
function get_OutputSourceIDs();
function set_OutputSourceIDs(value);
public:
virtual property array<String^>^ OutputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String

Implements

IActionAdapterOutputSourceIDs
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.RealTime Property

Grid Solutions Framework FacileActionAdapterBaseRealTime Property
Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks RealTime { get; }
Public ReadOnly Property RealTime As Ticks
    Get
member RealTime : Ticks with get

function get_RealTime();

public:
property Ticks RealTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.RequestedInputMeasurementKeys Property

Grid Solutions Framework FacileActionAdapterBaseRequestedInputMeasurementKeys Property
Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedInputMeasurementKeys { get; set; }
Public Overridable Property RequestedInputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedInputMeasurementKeys : MeasurementKey[] with get, set
override RequestedInputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedInputMeasurementKeys();
function set_RequestedInputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedInputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IActionAdapterRequestedInputMeasurementKeys
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.RequestedOutputMeasurementKeys Property

Grid Solutions Framework FacileActionAdapterBaseRequestedOutputMeasurementKeys Property
Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedOutputMeasurementKeys { get; set; }
Public Overridable Property RequestedOutputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
override RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedOutputMeasurementKeys();
function set_RequestedOutputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedOutputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IActionAdapterRequestedOutputMeasurementKeys
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.RespectInputDemands Property

Grid Solutions Framework FacileActionAdapterBaseRespectInputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RespectInputDemands { get; set; }
Public Overridable Property RespectInputDemands As Boolean
    Get
    Set
abstract RespectInputDemands : bool with get, set
override RespectInputDemands : bool with get, set
function get_RespectInputDemands();
function set_RespectInputDemands(value);
public:
virtual property bool RespectInputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IActionAdapterRespectInputDemands
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start input demands, as an example, this would be false for an action adapter that calculated measurement, but true for an action adapter used to archive inputs.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.RespectOutputDemands Property

Grid Solutions Framework FacileActionAdapterBaseRespectOutputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RespectOutputDemands { get; set; }
Public Overridable Property RespectOutputDemands As Boolean
    Get
    Set
abstract RespectOutputDemands : bool with get, set
override RespectOutputDemands : bool with get, set
function get_RespectOutputDemands();
function set_RespectOutputDemands(value);
public:
virtual property bool RespectOutputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean

Implements

IActionAdapterRespectOutputDemands
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start output demands, as an example, this would be true for an action adapter that calculated measurement, but false for an action adapter used to archive inputs.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.Status Property

Grid Solutions Framework FacileActionAdapterBaseStatus Property
Returns the detailed status of the data input source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
Remarks
Derived classes should extend status with implementation specific information.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.TrackLatestMeasurements Property

Grid Solutions Framework FacileActionAdapterBaseTrackLatestMeasurements Property
Gets or sets flag to start tracking the absolute latest received measurement values.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TrackLatestMeasurements { get; set; }
Public Overridable Property TrackLatestMeasurements As Boolean
    Get
    Set
abstract TrackLatestMeasurements : bool with get, set
override TrackLatestMeasurements : bool with get, set
function get_TrackLatestMeasurements();
function set_TrackLatestMeasurements(value);
public:
virtual property bool TrackLatestMeasurements {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Latest received measurement value will be available via the LatestMeasurements property.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.UseLocalClockAsRealTime Property

Grid Solutions Framework FacileActionAdapterBaseUseLocalClockAsRealTime Property
Gets or sets flag that determines whether or not to use the local clock time as real time.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool UseLocalClockAsRealTime { get; set; }
Public Overridable Property UseLocalClockAsRealTime As Boolean
    Get
    Set
abstract UseLocalClockAsRealTime : bool with get, set
override UseLocalClockAsRealTime : bool with get, set
function get_UseLocalClockAsRealTime();
function set_UseLocalClockAsRealTime(value);
public:
virtual property bool UseLocalClockAsRealTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Use your local system clock as real time only if the time is locally GPS-synchronized, or if the measurement values being sorted were not measured relative to a GPS-synchronized clock. Turn this off if the class is intended to process historical data.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase Events

Grid Solutions Framework FacileActionAdapterBase Events

The FacileActionAdapterBase type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnpublishedSamples | This event is raised by derived class, if needed, to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.DiscardingMeasurements Event

Grid Solutions Framework FacileActionAdapterBaseDiscardingMeasurements Event
This event is raised if there are any measurements being discarded during the sorting process.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<IEnumerable<IMeasurement>>> DiscardingMeasurements
Public Event DiscardingMeasurements As EventHandler(Of EventArgs(Of IEnumerable(Of IMeasurement)))
abstract DiscardingMeasurements : IEvent<EventHandler<EventArgs<IEnumerable<IMeasurement>>>,
    EventArgs<IEnumerable<IMeasurement>>>
override DiscardingMeasurements : IEvent<EventHandler<EventArgs<IEnumerable<IMeasurement>>>,
    EventArgs<IEnumerable<IMeasurement>>>
function add_DiscardingMeasurements(value);
function remove_DiscardingMeasurements(value);
public:
virtual  event EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ DiscardingMeasurements {
    void add (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IEnumerable IMeasurement

Implements

IActionAdapterDiscardingMeasurements
Remarks
Argument is the enumeration of IMeasurement values that are being discarded during the sorting process.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.NewMeasurements Event

Grid Solutions Framework FacileActionAdapterBaseNewMeasurements Event
Provides new measurements from action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICollection<IMeasurement>>> NewMeasurements
Public Event NewMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
override NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
function add_NewMeasurements(value);
function remove_NewMeasurements(value);
public:
virtual  event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ NewMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement

Implements

IActionAdapterNewMeasurements
Remarks
Argument is a collection of new measurements for host to process.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


FacileActionAdapterBase.UnpublishedSamples Event

Grid Solutions Framework FacileActionAdapterBaseUnpublishedSamples Event
This event is raised by derived class, if needed, to track current number of unpublished seconds of data in the queue.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> UnpublishedSamples
Public Event UnpublishedSamples As EventHandler(Of EventArgs(Of Integer))
abstract UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
override UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
function add_UnpublishedSamples(value);
function remove_UnpublishedSamples(value);
public:
virtual  event EventHandler<EventArgs<int>^>^ UnpublishedSamples {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32

Implements

IActionAdapterUnpublishedSamples
Remarks
Argument is the total number of unpublished seconds of data.
See Also

Reference

FacileActionAdapterBase Class
GSF.TimeSeries.Adapters Namespace


IActionAdapter Interface

Grid Solutions Framework IActionAdapter Interface
Represents the abstract interface for any action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IActionAdapter : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus
Public Interface IActionAdapter
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
type IActionAdapter =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.IActionAdapter = function();
GSF.TimeSeries.Adapters.IActionAdapter.createInterface('GSF.TimeSeries.Adapters.IActionAdapter');
public interface class IActionAdapter : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus

The IActionAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | QueueMeasurementsForProcessing | Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | NewMeasurements | Provides new measurements from action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


IActionAdapter Methods

Grid Solutions Framework IActionAdapter Methods

The IActionAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | QueueMeasurementsForProcessing | Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.QueueMeasurementsForProcessing Method

Grid Solutions Framework IActionAdapterQueueMeasurementsForProcessing Method
Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit

function QueueMeasurementsForProcessing(measurements);
void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Collection of measurements to queue for calculation processing.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter Properties

Grid Solutions Framework IActionAdapter Properties

The IActionAdapter type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.InputSourceIDs Property

Grid Solutions Framework IActionAdapterInputSourceIDs Property
Gets or sets Source values used to filter input measurement keys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string[] InputSourceIDs { get; set; }
Property InputSourceIDs As String()
    Get
    Set
abstract InputSourceIDs : string[] with get, set

function get_InputSourceIDs();
function set_InputSourceIDs(value);
property array<String^>^ InputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null to apply no filter.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.OutputSourceIDs Property

Grid Solutions Framework IActionAdapterOutputSourceIDs Property
Gets or sets Source values used to filter output measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string[] OutputSourceIDs { get; set; }
Property OutputSourceIDs As String()
    Get
    Set
abstract OutputSourceIDs : string[] with get, set

function get_OutputSourceIDs();
function set_OutputSourceIDs(value);
property array<String^>^ OutputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null to apply no filter.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.RequestedInputMeasurementKeys Property

Grid Solutions Framework IActionAdapterRequestedInputMeasurementKeys Property
Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementKey[] RequestedInputMeasurementKeys { get; set; }
Property RequestedInputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedInputMeasurementKeys : MeasurementKey[] with get, set

function get_RequestedInputMeasurementKeys();
function set_RequestedInputMeasurementKeys(value);
property array<MeasurementKey^>^ RequestedInputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.RequestedOutputMeasurementKeys Property

Grid Solutions Framework IActionAdapterRequestedOutputMeasurementKeys Property
Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementKey[] RequestedOutputMeasurementKeys { get; set; }
Property RequestedOutputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedOutputMeasurementKeys : MeasurementKey[] with get, set

function get_RequestedOutputMeasurementKeys();
function set_RequestedOutputMeasurementKeys(value);
property array<MeasurementKey^>^ RequestedOutputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.RespectInputDemands Property

Grid Solutions Framework IActionAdapterRespectInputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool RespectInputDemands { get; set; }
Property RespectInputDemands As Boolean
    Get
    Set
abstract RespectInputDemands : bool with get, set

function get_RespectInputDemands();
function set_RespectInputDemands(value);
property bool RespectInputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start input demands, as an example, this would be false for an action adapter that calculated measurement, but true for an action adapter used to archive inputs.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.RespectOutputDemands Property

Grid Solutions Framework IActionAdapterRespectOutputDemands Property
Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool RespectOutputDemands { get; set; }
Property RespectOutputDemands As Boolean
    Get
    Set
abstract RespectOutputDemands : bool with get, set

function get_RespectOutputDemands();
function set_RespectOutputDemands(value);
property bool RespectOutputDemands {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Action adapters are in the curious position of being able to both consume and produce points, as such the user needs to be able to control how their adapter will behave concerning routing demands when the adapter is setup to connect on demand. In the case of respecting auto-start output demands, as an example, this would be true for an action adapter that calculated measurement, but false for an action adapter used to archive inputs.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter Events

Grid Solutions Framework IActionAdapter Events

The IActionAdapter type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | NewMeasurements | Provides new measurements from action adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.DiscardingMeasurements Event

Grid Solutions Framework IActionAdapterDiscardingMeasurements Event
This event is raised if there are any measurements being discarded during the sorting process.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<IEnumerable<IMeasurement>>> DiscardingMeasurements
Event DiscardingMeasurements As EventHandler(Of EventArgs(Of IEnumerable(Of IMeasurement)))
abstract DiscardingMeasurements : IEvent<EventHandler<EventArgs<IEnumerable<IMeasurement>>>,
    EventArgs<IEnumerable<IMeasurement>>>

function add_DiscardingMeasurements(value);
function remove_DiscardingMeasurements(value);
 event EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ DiscardingMeasurements {
    void add (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<IEnumerable<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IEnumerable IMeasurement
Remarks
Argument is the enumeration of IMeasurement values that are being discarded during the sorting process.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.NewMeasurements Event

Grid Solutions Framework IActionAdapterNewMeasurements Event
Provides new measurements from action adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<ICollection<IMeasurement>>> NewMeasurements
Event NewMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>

function add_NewMeasurements(value);
function remove_NewMeasurements(value);
 event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ NewMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement
Remarks
Argument is a collection of new measurements for host to process.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IActionAdapter.UnpublishedSamples Event

Grid Solutions Framework IActionAdapterUnpublishedSamples Event
This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<int>> UnpublishedSamples
Event UnpublishedSamples As EventHandler(Of EventArgs(Of Integer))
abstract UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>

function add_UnpublishedSamples(value);
function remove_UnpublishedSamples(value);
 event EventHandler<EventArgs<int>^>^ UnpublishedSamples {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32
Remarks
Argument is the total number of unpublished seconds of data.
See Also

Reference

IActionAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter Interface

Grid Solutions Framework IAdapter Interface
Represents the abstract interface for any adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IAdapter : ISupportLifecycle,
    IDisposable, IProvideStatus
Public Interface IAdapter
    Inherits ISupportLifecycle, IDisposable, IProvideStatus
type IAdapter =
    interface
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.IAdapter = function();
GSF.TimeSeries.Adapters.IAdapter.createInterface('GSF.TimeSeries.Adapters.IAdapter');
public interface class IAdapter : ISupportLifecycle,
    IDisposable, IProvideStatus

The IAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter.
Public method | Start | Starts the adapter, if it is not already running.
Public method | Stop | Stops the adapter.
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter.
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter.
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter.
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


IAdapter Methods

Grid Solutions Framework IAdapter Methods

The IAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter.
Public method | Start | Starts the adapter, if it is not already running.
Public method | Stop | Stops the adapter.
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.GetShortStatus Method

Grid Solutions Framework IAdapterGetShortStatus Method
Gets a short one-line adapter status.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string GetShortStatus(
    int maxLength
)
Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string

function GetShortStatus(maxLength);
String^ GetShortStatus(
    int maxLength
)

Parameters

maxLength
Type: SystemInt32
Maximum number of available characters for display.

Return Value

Type: String
A short one-line summary of the current adapter status.
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.SetTemporalConstraint Method

Grid Solutions Framework IAdapterSetTemporalConstraint Method
Defines a temporal processing constraint for the adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void SetTemporalConstraint(
    string startTime,
    string stopTime,
    string constraintParameters
)
Sub SetTemporalConstraint (
    startTime As String,
    stopTime As String,
    constraintParameters As String
)
abstract SetTemporalConstraint :
        startTime : string *
        stopTime : string *
        constraintParameters : string -> unit

function SetTemporalConstraint(startTime, stopTime, constraintParameters);
void SetTemporalConstraint(
    String^ startTime,
    String^ stopTime,
    String^ constraintParameters
)

Parameters

startTime
Type: SystemString
Defines a relative or exact start time for the temporal constraint.
stopTime
Type: SystemString
Defines a relative or exact stop time for the temporal constraint.
constraintParameters
Type: SystemString
Defines any temporal parameters related to the constraint.
Remarks

This method defines a temporal processing constraint for an adapter, i.e., the start and stop time over which an adapter will process data. Actual implementation of the constraint will be adapter specific. Implementations should be able to dynamically handle multiple calls to this function with new constraints. Passing in null for the startTime and stopTime should cancel the temporal constraint and return the adapter to standard / real-time operation.

The startTime and stopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.Start Method

Grid Solutions Framework IAdapterStart Method
Starts the adapter, if it is not already running.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Start()
Sub Start
abstract Start : unit -> unit

function Start();
void Start()
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.Stop Method

Grid Solutions Framework IAdapterStop Method
Stops the adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Stop()
Sub Stop
abstract Stop : unit -> unit

function Stop();
void Stop()
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter Properties

Grid Solutions Framework IAdapter Properties

The IAdapter type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter.
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter.
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter.
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization.
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully.
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter.
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter.
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing.
Top
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.AutoStart Property

Grid Solutions Framework IAdapterAutoStart Property
Gets or sets flag indicating if adapter should automatically start or connect on demand.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool AutoStart { get; set; }
Property AutoStart As Boolean
    Get
    Set
abstract AutoStart : bool with get, set

function get_AutoStart();
function set_AutoStart(value);
property bool AutoStart {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.ConnectionString Property

Grid Solutions Framework IAdapterConnectionString Property
Gets or sets key/value pair connection information specific to IAdapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ConnectionString { get; set; }
Property ConnectionString As String
    Get
    Set
abstract ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.DataSource Property

Grid Solutions Framework IAdapterDataSource Property
Gets or sets DataSet based data source available to IAdapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataSet DataSource { get; set; }
Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set

function get_DataSource();
function set_DataSource(value);
property DataSet^ DataSource {
    DataSet^ get ();
    void set (DataSet^ value);
}

Property Value

Type: DataSet
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.ID Property

Grid Solutions Framework IAdapterID Property
Gets or sets the numeric ID associated with this IAdapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
uint ID { get; set; }
Property ID As UInteger
    Get
    Set
abstract ID : uint32 with get, set

function get_ID();
function set_ID(value);
property unsigned int ID {
    unsigned int get ();
    void set (unsigned int value);
}

Property Value

Type: UInt32
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.InitializationTimeout Property

Grid Solutions Framework IAdapterInitializationTimeout Property
Gets or sets maximum time system will wait during Start for initialization.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int InitializationTimeout { get; set; }
Property InitializationTimeout As Integer
    Get
    Set
abstract InitializationTimeout : int with get, set

function get_InitializationTimeout();
function set_InitializationTimeout(value);
property int InitializationTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
Implementers should use value Infinite to wait indefinitely.
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.Initialized Property

Grid Solutions Framework IAdapterInitialized Property
Gets or sets flag indicating if the adapter has been initialized successfully.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Initialized { get; set; }
Property Initialized As Boolean
    Get
    Set
abstract Initialized : bool with get, set

function get_Initialized();
function set_Initialized(value);
property bool Initialized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
Implementers only need to track this value.
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.InputMeasurementKeys Property

Grid Solutions Framework IAdapterInputMeasurementKeys Property
Gets or sets primary keys of input measurements the adapter expects.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementKey[] InputMeasurementKeys { get; set; }
Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract InputMeasurementKeys : MeasurementKey[] with get, set

function get_InputMeasurementKeys();
function set_InputMeasurementKeys(value);
property array<MeasurementKey^>^ InputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.Name Property

Grid Solutions Framework IAdapterName Property
Overload List
 | Name | Description
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter.
Top
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.Name Property

Grid Solutions Framework IAdapterName Property
Gets or sets name of this IAdapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Name { get; set; }
Property Name As String
    Get
    Set
abstract Name : string with get, set

function get_Name();
function set_Name(value);
property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

IAdapter Interface
Name Overload
GSF.TimeSeries.Adapters Namespace


IAdapter.OutputMeasurements Property

Grid Solutions Framework IAdapterOutputMeasurements Property
Gets or sets output measurements that the adapter will produce, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
IMeasurement[] OutputMeasurements { get; set; }
Property OutputMeasurements As IMeasurement()
    Get
    Set
abstract OutputMeasurements : IMeasurement[] with get, set

function get_OutputMeasurements();
function set_OutputMeasurements(value);
property array<IMeasurement^>^ OutputMeasurements {
    array<IMeasurement^>^ get ();
    void set (array<IMeasurement^>^ value);
}

Property Value

Type: IMeasurement
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.ProcessedMeasurements Property

Grid Solutions Framework IAdapterProcessedMeasurements Property
Gets the total number of measurements processed thus far by the IAdapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
long ProcessedMeasurements { get; }
ReadOnly Property ProcessedMeasurements As Long
    Get
abstract ProcessedMeasurements : int64 with get

function get_ProcessedMeasurements();

property long long ProcessedMeasurements {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.ProcessingInterval Property

Grid Solutions Framework IAdapterProcessingInterval Property
Gets or sets the desired processing interval, in milliseconds, for the adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int ProcessingInterval { get; set; }
Property ProcessingInterval As Integer
    Get
    Set
abstract ProcessingInterval : int with get, set

function get_ProcessingInterval();
function set_ProcessingInterval(value);
property int ProcessingInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
With the exception of the values of -1 and 0, this value specifies the desired processing interval for data, i.e., basically a delay, or timer interval, over which to process data. A value of -1 means to use the default processing interval while a value of 0 means to process data as fast as possible.
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.Settings Property

Grid Solutions Framework IAdapterSettings Property
Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Dictionary<string, string> Settings { get; }
ReadOnly Property Settings As Dictionary(Of String, String)
    Get
abstract Settings : Dictionary<string, string> with get

function get_Settings();

property Dictionary<String^, String^>^ Settings {
    Dictionary<String^, String^>^ get ();
}

Property Value

Type: Dictionary String, String
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.StartTimeConstraint Property

Grid Solutions Framework IAdapterStartTimeConstraint Property
Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DateTime StartTimeConstraint { get; }
ReadOnly Property StartTimeConstraint As DateTime
    Get
abstract StartTimeConstraint : DateTime with get

function get_StartTimeConstraint();

property DateTime StartTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime
Remarks
This value will be MinValue when start time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.StopTimeConstraint Property

Grid Solutions Framework IAdapterStopTimeConstraint Property
Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String).

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DateTime StopTimeConstraint { get; }
ReadOnly Property StopTimeConstraint As DateTime
    Get
abstract StopTimeConstraint : DateTime with get

function get_StopTimeConstraint();

property DateTime StopTimeConstraint {
    DateTime get ();
}

Property Value

Type: DateTime
Remarks
This value will be MaxValue when stop time constraint is not set - meaning the adapter is processing data in real-time.
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.SupportsTemporalProcessing Property

Grid Solutions Framework IAdapterSupportsTemporalProcessing Property
Gets the flag indicating if this adapter supports temporal processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool SupportsTemporalProcessing { get; }
ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get

function get_SupportsTemporalProcessing();

property bool SupportsTemporalProcessing {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter Events

Grid Solutions Framework IAdapter Events

The IAdapter type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.ConfigurationChanged Event

Grid Solutions Framework IAdapterConfigurationChanged Event
Event is raised when adapter is aware of a configuration change.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ConfigurationChanged
Event ConfigurationChanged As EventHandler
abstract ConfigurationChanged : IEvent<EventHandler,
    EventArgs>

function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
 event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.InputMeasurementKeysUpdated Event

Grid Solutions Framework IAdapterInputMeasurementKeysUpdated Event
Event is raised when InputMeasurementKeys are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler InputMeasurementKeysUpdated
Event InputMeasurementKeysUpdated As EventHandler
abstract InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>

function add_InputMeasurementKeysUpdated(value);
function remove_InputMeasurementKeysUpdated(value);
 event EventHandler^ InputMeasurementKeysUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.OutputMeasurementsUpdated Event

Grid Solutions Framework IAdapterOutputMeasurementsUpdated Event
Event is raised when OutputMeasurements are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler OutputMeasurementsUpdated
Event OutputMeasurementsUpdated As EventHandler
abstract OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>

function add_OutputMeasurementsUpdated(value);
function remove_OutputMeasurementsUpdated(value);
 event EventHandler^ OutputMeasurementsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.ProcessException Event

Grid Solutions Framework IAdapterProcessException Event
Event is raised when there is an exception encountered while processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ProcessException
Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks

Implementations of this interface are expected to capture any exceptions that might be thrown by user code in any processing to prevent third-party code from causing an unhandled exception in the host. Errors are reported via this event so host administrators will be aware of the exception. Any needed connection cycle to data adapter should be restarted when an exception is encountered.

Argument is the exception that was thrown.

See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapter.StatusMessage Event

Grid Solutions Framework IAdapterStatusMessage Event
Provides status messages to consumer.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<string>> StatusMessage
Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_StatusMessage(value);
function remove_StatusMessage(value);
 event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is new status message.
See Also

Reference

IAdapter Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection Interface

Grid Solutions Framework IAdapterCollection Interface
Represents the abstract interface for a collection of adapters.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IAdapterCollection : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IList<IAdapter>,
    ICollection<IAdapter>, IEnumerable<IAdapter>, IEnumerable
Public Interface IAdapterCollection
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus,
    IList(Of IAdapter), ICollection(Of IAdapter), IEnumerable(Of IAdapter),
    IEnumerable
type IAdapterCollection =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IList<IAdapter>
        interface ICollection<IAdapter>
        interface IEnumerable<IAdapter>
        interface IEnumerable
    end
GSF.TimeSeries.Adapters.IAdapterCollection = function();
GSF.TimeSeries.Adapters.IAdapterCollection.createInterface('GSF.TimeSeries.Adapters.IAdapterCollection');
public interface class IAdapterCollection : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus, IList<IAdapter^>,
    ICollection<IAdapter^>, IEnumerable<IAdapter^>, IEnumerable

The IAdapterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IAdapter .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IAdapter .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IAdapter .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IAdapter .)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IAdapter .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IAdapter .)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IAdapter .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IAdapter .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IAdapter .)
Public method | ResetStatistics | Resets the statistics of this collection.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow.
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id.
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name.
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAdapter | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByIAdapter, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetRangeIAdapter | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfIAdapter | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | InputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | InputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of input measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, Char, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter(IAdapter) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(IComparerIAdapter) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByIAdapter, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(IComparerIAdapter) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByIAdapter, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter(IAdapter) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | OutputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of output measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | ScrambleIAdapter | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleIAdapter(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Public Extension Method | ToDelimitedStringIAdapter | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleIAdapter | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeIAdapter | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IAdapter .)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to initialize this IAdapterCollection.
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IAdapter .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IAdapter .)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


IAdapterCollection Methods

Grid Solutions Framework IAdapterCollection Methods

The IAdapterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ICollection IAdapter .)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ICollection IAdapter .)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ICollection IAdapter .)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ICollection IAdapter .)
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetEnumerator | Returns an enumerator that iterates through the collection. (Inherited from IEnumerable IAdapter .)
Public method | GetEnumerator | Returns an enumerator that iterates through a collection. (Inherited from IEnumerable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from IList IAdapter .)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from IList IAdapter .)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ICollection IAdapter .)
Public method | RemoveAt | Removes the IListT item at the specified index. (Inherited from IList IAdapter .)
Public method | ResetStatistics | Resets the statistics of this collection.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow.
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id.
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name.
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID.
Top
Extension Methods
 | Name | Description
Public Extension Method | AddRangeIAdapter | Adds the specified items to the collection. (Defined by CollectionExtensions.)
Public Extension Method | DistinctByIAdapter, TKey | Returns only the elements whose keys are distinct. (Defined by CollectionExtensions.)
Public Extension Method | GetRangeIAdapter | Returns elements in the specified range from the collection. (Defined by CollectionExtensions.)
Public Extension Method | IndexOfIAdapter | Returns the index of the first element of the sequence that satisfies a condition or -1 if no such element is found. (Defined by CollectionExtensions.)
Public Extension Method | InputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | InputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of input measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, using the default delimiter ("|") into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, Char, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | LoadDelimitedStringIAdapter(String, String, FuncString, IAdapter) | Overloaded. Appends items parsed from delimited string, created with ToDelimitedString, into the given list. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter | Overloaded. Returns the majority value in the collection, or default type value if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MajorityIAdapter(IAdapter) | Overloaded. Returns the majority value in the collection, or defaultValue if no item represents the majority. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxIAdapter(IComparerIAdapter) | Overloaded. Returns the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MaxByIAdapter, TKey | Selects the largest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(FuncIAdapter, IAdapter, Int32) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinIAdapter(IComparerIAdapter) | Overloaded. Returns the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinByIAdapter, TKey | Selects the smallest item from the enumeration. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter | Overloaded. Returns the minority value in the collection, or default type value if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | MinorityIAdapter(IAdapter) | Overloaded. Returns the minority value in the collection, or defaultValue if no item represents the minority. (Defined by CollectionExtensions.)
Public Extension Method | OutputMeasurementKeys | Overloaded. Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeysIAdapter | Overloaded. Gets a distinct list of output measurement keys for all of the provided adapters. (Defined by IAdapterExtensions.)
Public Extension Method | ScrambleIAdapter | Overloaded. Rearranges all the elements in the list into a highly-random order. (Defined by CollectionExtensions.)
Public Extension Method | ScrambleIAdapter(Int32) | Overloaded. Rearranges all the elements in the list into a repeatable pseudo-random order. (Defined by CollectionExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Public Extension Method | ToDelimitedStringIAdapter | Overloaded. Converts an enumeration to a string, using the default delimiter ("|") that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(Char) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | ToDelimitedStringIAdapter(String) | Overloaded. Converts an enumeration to a string that can later be converted back to a list using LoadDelimitedString. (Defined by CollectionExtensions.)
Public Extension Method | UnscrambleIAdapter | Rearranges all the elements in the list previously scrambled with ScrambleTSource(IListTSource, Int32) back into their original order. (Defined by CollectionExtensions.)
Public Extension Method | UpdateRangeIAdapter | Updates collection starting at the index with the specified items. (Defined by CollectionExtensions.)
Top
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection.ResetStatistics Method

Grid Solutions Framework IAdapterCollectionResetStatistics Method
Resets the statistics of this collection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void ResetStatistics()
Sub ResetStatistics
abstract ResetStatistics : unit -> unit

function ResetStatistics();
void ResetStatistics()
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection.TryCreateAdapter Method

Grid Solutions Framework IAdapterCollectionTryCreateAdapter Method
Attempts to create an IAdapter from the specified DataRow.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool TryCreateAdapter(
    DataRow adapterRow,
    out IAdapter adapter
)
Function TryCreateAdapter (
    adapterRow As DataRow,
    <OutAttribute> ByRef adapter As IAdapter
) As Boolean
abstract TryCreateAdapter :
        adapterRow : DataRow *
        adapter : IAdapter byref -> bool

function TryCreateAdapter(adapterRow, adapter);
bool TryCreateAdapter(
    DataRow^ adapterRow,
    [OutAttribute] IAdapter^% adapter
)

Parameters

adapterRow
Type: System.DataDataRow
DataRow containing item information to initialize.
adapter
Type: GSF.TimeSeries.AdaptersIAdapter
Initialized adapter if successful; otherwise null.

Return Value

Type: Boolean
true if item was successfully initialized; otherwise false.
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection.TryGetAdapterByID Method

Grid Solutions Framework IAdapterCollectionTryGetAdapterByID Method
Attempts to get the adapter with the specified id.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool TryGetAdapterByID(
    uint id,
    out IAdapter adapter
)
Function TryGetAdapterByID (
    id As UInteger,
    <OutAttribute> ByRef adapter As IAdapter
) As Boolean
abstract TryGetAdapterByID :
        id : uint32 *
        adapter : IAdapter byref -> bool

function TryGetAdapterByID(id, adapter);
bool TryGetAdapterByID(
    unsigned int id,
    [OutAttribute] IAdapter^% adapter
)

Parameters

id
Type: SystemUInt32
ID of adapter to get.
adapter
Type: GSF.TimeSeries.AdaptersIAdapter
Adapter reference if found; otherwise null.

Return Value

Type: Boolean
true if adapter with the specified id was found; otherwise false.
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection.TryGetAdapterByName Method

Grid Solutions Framework IAdapterCollectionTryGetAdapterByName Method
Attempts to get the adapter with the specified name.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool TryGetAdapterByName(
    string name,
    out IAdapter adapter
)
Function TryGetAdapterByName (
    name As String,
    <OutAttribute> ByRef adapter As IAdapter
) As Boolean
abstract TryGetAdapterByName :
        name : string *
        adapter : IAdapter byref -> bool

function TryGetAdapterByName(name, adapter);
bool TryGetAdapterByName(
    String^ name,
    [OutAttribute] IAdapter^% adapter
)

Parameters

name
Type: SystemString
Name of adapter to get.
adapter
Type: GSF.TimeSeries.AdaptersIAdapter
Adapter reference if found; otherwise null.

Return Value

Type: Boolean
true if adapter with the specified name was found; otherwise false.
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection.TryInitializeAdapterByID Method

Grid Solutions Framework IAdapterCollectionTryInitializeAdapterByID Method
Attempts to initialize (or reinitialize) an individual IAdapter based on its ID.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool TryInitializeAdapterByID(
    uint id
)
Function TryInitializeAdapterByID (
    id As UInteger
) As Boolean
abstract TryInitializeAdapterByID :
        id : uint32 -> bool

function TryInitializeAdapterByID(id);
bool TryInitializeAdapterByID(
    unsigned int id
)

Parameters

id
Type: SystemUInt32
The numeric ID associated with the IAdapter to be initialized.

Return Value

Type: Boolean
true if item was successfully initialized; otherwise false.
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection Properties

Grid Solutions Framework IAdapterCollection Properties

The IAdapterCollection type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ICollection IAdapter .)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to initialize this IAdapterCollection.
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | IsReadOnly | Gets a value indicating whether the ICollectionT is read-only. (Inherited from ICollection IAdapter .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from IList IAdapter .)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection.DataMember Property

Grid Solutions Framework IAdapterCollectionDataMember Property
Gets or sets specific data member (e.g., table name) in DataSource used to initialize this IAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string DataMember { get; set; }
Property DataMember As String
    Get
    Set
abstract DataMember : string with get, set

function get_DataMember();
function set_DataMember(value);
property String^ DataMember {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Table name specified in DataMember from DataSource is expected to have the following table column names:
ID, AdapterName, AssemblyName, TypeName, ConnectionString
ID column type should be integer based, all other column types are expected to be string based.
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterCollection Events

Grid Solutions Framework IAdapterCollection Events

The IAdapterCollection type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Top
See Also

Reference

IAdapterCollection Interface
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions Class

Grid Solutions Framework IAdapterExtensions Class
Defines static extension functions for IAdapter implementations.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersIAdapterExtensions

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class IAdapterExtensions
<ExtensionAttribute>
Public NotInheritable Class IAdapterExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IAdapterExtensions =  class end
GSF.TimeSeries.Adapters.IAdapterExtensions = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.IAdapterExtensions');
[ExtensionAttribute]
public ref class IAdapterExtensions abstract sealed

The IAdapterExtensions type exposes the following members.

Methods
Name | Description
InputMeasurementKeys(IAdapter) | Returns the MeasurementKey values of the IAdapter input measurements.
InputMeasurementKeysT(IEnumerableT) | Gets a distinct list of input measurement keys for all of the provided adapters.
OutputMeasurementKeys(IAdapter) | Returns the MeasurementKey values of the IAdapter output measurements.
OutputMeasurementKeysT(IEnumerableT) | Gets a distinct list of output measurement keys for all of the provided adapters.
TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


IAdapterExtensions Methods

Grid Solutions Framework IAdapterExtensions Methods

The IAdapterExtensions type exposes the following members.

Methods
Name | Description
InputMeasurementKeys(IAdapter) | Returns the MeasurementKey values of the IAdapter input measurements.
InputMeasurementKeysT(IEnumerableT) | Gets a distinct list of input measurement keys for all of the provided adapters.
OutputMeasurementKeys(IAdapter) | Returns the MeasurementKey values of the IAdapter output measurements.
OutputMeasurementKeysT(IEnumerableT) | Gets a distinct list of output measurement keys for all of the provided adapters.
TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value.
Top
See Also

Reference

IAdapterExtensions Class
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions.InputMeasurementKeys Method

Grid Solutions Framework IAdapterExtensionsInputMeasurementKeys Method
Overload List
Name | Description
InputMeasurementKeysT(IEnumerableT) | Gets a distinct list of input measurement keys for all of the provided adapters.
InputMeasurementKeys(IAdapter) | Returns the MeasurementKey values of the IAdapter input measurements.
Top
See Also

Reference

IAdapterExtensions Class
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions.InputMeasurementKeys(T) Method (IEnumerable(T))

Grid Solutions Framework IAdapterExtensionsInputMeasurementKeysT Method (IEnumerableT)
Gets a distinct list of input measurement keys for all of the provided adapters.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey[] InputMeasurementKeys<T>(
    this IEnumerable<T> adapters
)
where T : IAdapter

<ExtensionAttribute>
Public Shared Function InputMeasurementKeys(Of T As IAdapter) (
    adapters As IEnumerable(Of T)
) As MeasurementKey()
static member InputMeasurementKeys :
        adapters : IEnumerable<'T> -> MeasurementKey[]  when 'T : IAdapter

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : IAdapter
static array<MeasurementKey^>^ InputMeasurementKeys(
    IEnumerable<T>^ adapters
)

Parameters

adapters
Type: System.Collections.GenericIEnumerable T
Source IAdapter enumeration.

Type Parameters

T
Type of IAdapter.

Return Value

Type: MeasurementKey
Distinct list of input measurement keys for all of the provided adapters.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IAdapterExtensions Class
InputMeasurementKeys Overload
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions.InputMeasurementKeys Method (IAdapter)

Grid Solutions Framework IAdapterExtensionsInputMeasurementKeys Method (IAdapter)
Returns the MeasurementKey values of the IAdapter input measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey[] InputMeasurementKeys(
    this IAdapter adapter
)
<ExtensionAttribute>
Public Shared Function InputMeasurementKeys (
    adapter As IAdapter
) As MeasurementKey()
static member InputMeasurementKeys :
        adapter : IAdapter -> MeasurementKey[]

GSF.TimeSeries.Adapters.IAdapterExtensions.InputMeasurementKeys = function(adapter);
public:
[ExtensionAttribute]
static array<MeasurementKey^>^ InputMeasurementKeys(
    IAdapter^ adapter
)

Parameters

adapter
Type: GSF.TimeSeries.AdaptersIAdapter
IAdapter instance input measurements to convert.

Return Value

Type: MeasurementKey
MeasurementKey values of the IAdapter input measurements.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAdapter. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IAdapterExtensions Class
InputMeasurementKeys Overload
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions.OutputMeasurementKeys Method

Grid Solutions Framework IAdapterExtensionsOutputMeasurementKeys Method
Overload List
Name | Description
OutputMeasurementKeysT(IEnumerableT) | Gets a distinct list of output measurement keys for all of the provided adapters.
OutputMeasurementKeys(IAdapter) | Returns the MeasurementKey values of the IAdapter output measurements.
Top
See Also

Reference

IAdapterExtensions Class
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions.OutputMeasurementKeys(T) Method (IEnumerable(T))

Grid Solutions Framework IAdapterExtensionsOutputMeasurementKeysT Method (IEnumerableT)
Gets a distinct list of output measurement keys for all of the provided adapters.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey[] OutputMeasurementKeys<T>(
    this IEnumerable<T> adapters
)
where T : IAdapter

<ExtensionAttribute>
Public Shared Function OutputMeasurementKeys(Of T As IAdapter) (
    adapters As IEnumerable(Of T)
) As MeasurementKey()
static member OutputMeasurementKeys :
        adapters : IEnumerable<'T> -> MeasurementKey[]  when 'T : IAdapter

JavaScript does not support generic types or methods.
public:
[ExtensionAttribute]
generic<typename T>
where T : IAdapter
static array<MeasurementKey^>^ OutputMeasurementKeys(
    IEnumerable<T>^ adapters
)

Parameters

adapters
Type: System.Collections.GenericIEnumerable T
Source IAdapter enumeration.

Type Parameters

T
Type of IAdapter.

Return Value

Type: MeasurementKey
Distinct list of output measurement keys for all of the provided adapters.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable T. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IAdapterExtensions Class
OutputMeasurementKeys Overload
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions.OutputMeasurementKeys Method (IAdapter)

Grid Solutions Framework IAdapterExtensionsOutputMeasurementKeys Method (IAdapter)
Returns the MeasurementKey values of the IAdapter output measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static MeasurementKey[] OutputMeasurementKeys(
    this IAdapter adapter
)
<ExtensionAttribute>
Public Shared Function OutputMeasurementKeys (
    adapter As IAdapter
) As MeasurementKey()
static member OutputMeasurementKeys :
        adapter : IAdapter -> MeasurementKey[]

GSF.TimeSeries.Adapters.IAdapterExtensions.OutputMeasurementKeys = function(adapter);
public:
[ExtensionAttribute]
static array<MeasurementKey^>^ OutputMeasurementKeys(
    IAdapter^ adapter
)

Parameters

adapter
Type: GSF.TimeSeries.AdaptersIAdapter
IAdapter instance output measurements to convert.

Return Value

Type: MeasurementKey
MeasurementKey values of the IAdapter output measurements.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAdapter. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IAdapterExtensions Class
OutputMeasurementKeys Overload
GSF.TimeSeries.Adapters Namespace


IAdapterExtensions.TemporalConstraintIsDefined Method

Grid Solutions Framework IAdapterExtensionsTemporalConstraintIsDefined Method
Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TemporalConstraintIsDefined(
    this IAdapter adapter
)
<ExtensionAttribute>
Public Shared Function TemporalConstraintIsDefined (
    adapter As IAdapter
) As Boolean
static member TemporalConstraintIsDefined :
        adapter : IAdapter -> bool

GSF.TimeSeries.Adapters.IAdapterExtensions.TemporalConstraintIsDefined = function(adapter);
public:
[ExtensionAttribute]
static bool TemporalConstraintIsDefined(
    IAdapter^ adapter
)

Parameters

adapter
Type: GSF.TimeSeries.AdaptersIAdapter
IAdapter instance to test.

Return Value

Type: Boolean
true if IAdapter has a temporal constraint defined.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IAdapter. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IAdapterExtensions Class
GSF.TimeSeries.Adapters Namespace


IaonSession Class

Grid Solutions Framework IaonSession Class
Represents a new Input, Action, Output interface session.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersIaonSession

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IaonSession : IProvideStatus,
    IDisposable
Public Class IaonSession
    Implements IProvideStatus, IDisposable
type IaonSession =
    class
        interface IProvideStatus
        interface IDisposable
    end
GSF.TimeSeries.Adapters.IaonSession = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.IaonSession',
    null,
    GSF.IProvideStatus,
    IDisposable);
public ref class IaonSession : IProvideStatus,
    IDisposable

The IaonSession type exposes the following members.

Constructors
 | Name | Description
Public method | IaonSession | Creates a new IaonSession.
Top
Methods
 | Name | Description
Public method | ConfigurationChangedHandler | Event handler for adapter notifications about configuration changes.
Public method | Dispose | Releases all the resources used by the IaonSession object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IaonSession object and optionally releases the managed resources.
Public method | DisposedHandler | Event handler for disposed events from all adapters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractTemporalConfiguration | Extracts a configuration that supports temporal processing from an existing real-time configuration.
Protected method | Finalize | Releases the unmanaged resources before the IaonSession object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetDerivedName | Gets derived name of specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize and start adapters.
Public method | InputMeasurementKeysUpdatedHandler | Event handler for updates to adapter input measurement key definitions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnDisposed | Raises the Disposed event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnStatusMessage(Object, String, UpdateType) | Raises the StatusMessage event.
Protected method | OnStatusMessage(Object, String, UpdateType, Object) | Raises the StatusMessage event with a formatted status message.
Protected method | OnUnprocessedMeasurements | Raises the UnprocessedMeasurements event.
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Public method | OutputMeasurementsUpdatedHandler | Event handler for updates to adapter output measurement definitions.
Public method | ProcessExceptionHandler | Event handler for processing reported exceptions.
Public method | ProcessingCompleteHandler | Event handler for processing complete notifications from input adapters.
Public method | RecalculateRoutingTables | Recalculates routing tables as long as all adapters have been initialized.
Public method | RequestTemporalSupportHandler | Event handler for requesting temporal support.
Public method | StatusMessageHandler | Event handler for reporting status messages.
Public method | TemporalProcessingSupportExists | Gets flag that determines if temporal processing is supported in this IaonSession.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnprocessedMeasurementsHandler | Event handler for monitoring unprocessed measurements.
Public method | UnpublishedSamplesHandler | Event handler for monitoring unpublished samples.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ActionAdapters | Gets the action adapter collection for this IaonSession.
Public property | AllAdapters | Gets the all adapters collection for this IaonSession.
Public property | DataSource | Gets or sets the configuration DataSet for this IaonSession.
Public property | InputAdapters | Gets the input adapter collection for this IaonSession.
Public property | InputMeasurementKeysRestriction | Gets or sets a routing table restriction for a collection of input measurement keys.
Public property | Name | Gets name assigned to this IaonSession, if any.
Public property | NodeID | Gets or sets the Guid node ID for this IaonSession.
Public property | OutputAdapters | Gets the output adapter collection for this IaonSession.
Public property | RoutingTables | Gets the routing tables for this IaonSession.
Public property | Status | Gets the combined status of the adapters in this IaonSession.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed.
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | ProcessingComplete | Indicates to the host that processing for one of the input adapters has completed.
Public event | StatusMessage | Provides status messages to consumer.
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Public event | UnpublishedSamples | Event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


IaonSession Constructor

Grid Solutions Framework IaonSession Constructor
Creates a new IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IaonSession()
Public Sub New
new : unit -> IaonSession
GSF.TimeSeries.Adapters.IaonSession = function();
public:
IaonSession()
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession Methods

Grid Solutions Framework IaonSession Methods

The IaonSession type exposes the following members.

Methods
 | Name | Description
Public method | ConfigurationChangedHandler | Event handler for adapter notifications about configuration changes.
Public method | Dispose | Releases all the resources used by the IaonSession object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IaonSession object and optionally releases the managed resources.
Public method | DisposedHandler | Event handler for disposed events from all adapters.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ExtractTemporalConfiguration | Extracts a configuration that supports temporal processing from an existing real-time configuration.
Protected method | Finalize | Releases the unmanaged resources before the IaonSession object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetDerivedName | Gets derived name of specified object.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initialize and start adapters.
Public method | InputMeasurementKeysUpdatedHandler | Event handler for updates to adapter input measurement key definitions.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event.
Protected method | OnDisposed | Raises the Disposed event.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event.
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnStatusMessage(Object, String, UpdateType) | Raises the StatusMessage event.
Protected method | OnStatusMessage(Object, String, UpdateType, Object) | Raises the StatusMessage event with a formatted status message.
Protected method | OnUnprocessedMeasurements | Raises the UnprocessedMeasurements event.
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event.
Public method | OutputMeasurementsUpdatedHandler | Event handler for updates to adapter output measurement definitions.
Public method | ProcessExceptionHandler | Event handler for processing reported exceptions.
Public method | ProcessingCompleteHandler | Event handler for processing complete notifications from input adapters.
Public method | RecalculateRoutingTables | Recalculates routing tables as long as all adapters have been initialized.
Public method | RequestTemporalSupportHandler | Event handler for requesting temporal support.
Public method | StatusMessageHandler | Event handler for reporting status messages.
Public method | TemporalProcessingSupportExists | Gets flag that determines if temporal processing is supported in this IaonSession.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | UnprocessedMeasurementsHandler | Event handler for monitoring unprocessed measurements.
Public method | UnpublishedSamplesHandler | Event handler for monitoring unpublished samples.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ConfigurationChangedHandler Method

Grid Solutions Framework IaonSessionConfigurationChangedHandler Method
Event handler for adapter notifications about configuration changes.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void ConfigurationChangedHandler(
    Object sender,
    EventArgs e
)
Public Overridable Sub ConfigurationChangedHandler (
    sender As Object,
    e As EventArgs
)
abstract ConfigurationChangedHandler :
        sender : Object *
        e : EventArgs -> unit
override ConfigurationChangedHandler :
        sender : Object *
        e : EventArgs -> unit
function ConfigurationChangedHandler(sender, e);
public:
virtual void ConfigurationChangedHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: SystemEventArgs
Event arguments, if any.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.Dispose Method

Grid Solutions Framework IaonSessionDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the IaonSession object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the IaonSession object and optionally releases the managed resources.
Top
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.Dispose Method

Grid Solutions Framework IaonSessionDispose Method
Releases all the resources used by the IaonSession object.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

IaonSession Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


IaonSession.Dispose Method (Boolean)

Grid Solutions Framework IaonSessionDispose Method (Boolean)
Releases the unmanaged resources used by the IaonSession object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

IaonSession Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


IaonSession.DisposedHandler Method

Grid Solutions Framework IaonSessionDisposedHandler Method
Event handler for disposed events from all adapters.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void DisposedHandler(
    Object sender,
    EventArgs e
)
Public Overridable Sub DisposedHandler (
    sender As Object,
    e As EventArgs
)
abstract DisposedHandler :
        sender : Object *
        e : EventArgs -> unit
override DisposedHandler :
        sender : Object *
        e : EventArgs -> unit
function DisposedHandler(sender, e);
public:
virtual void DisposedHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: SystemEventArgs
Event arguments, if any.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ExtractTemporalConfiguration Method

Grid Solutions Framework IaonSessionExtractTemporalConfiguration Method
Extracts a configuration that supports temporal processing from an existing real-time configuration.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet ExtractTemporalConfiguration(
    DataSet realtimeConfiguration
)
Public Shared Function ExtractTemporalConfiguration (
    realtimeConfiguration As DataSet
) As DataSet
static member ExtractTemporalConfiguration :
        realtimeConfiguration : DataSet -> DataSet

GSF.TimeSeries.Adapters.IaonSession.ExtractTemporalConfiguration = function(realtimeConfiguration);
public:
static DataSet^ ExtractTemporalConfiguration(
    DataSet^ realtimeConfiguration
)

Parameters

realtimeConfiguration
Type: System.DataDataSet
Real-time DataSet configuration.

Return Value

Type: DataSet
A new DataSet configuration for adapters that support temporal processing.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.Finalize Method

Grid Solutions Framework IaonSessionFinalize Method
Releases the unmanaged resources before the IaonSession object is reclaimed by GC.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.GetDerivedName Method

Grid Solutions Framework IaonSessionGetDerivedName Method
Gets derived name of specified object.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string GetDerivedName(
    Object sender
)
Public Overridable Function GetDerivedName (
    sender As Object
) As String
abstract GetDerivedName :
        sender : Object -> string
override GetDerivedName :
        sender : Object -> string
function GetDerivedName(sender);
public:
virtual String^ GetDerivedName(
    Object^ sender
)

Parameters

sender
Type: SystemObject
Sending object from which to derive name.

Return Value

Type: String
Derived name of specified object.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.Initialize Method

Grid Solutions Framework IaonSessionInitialize Method
Initialize and start adapters.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Initialize(
    bool autoStart = true
)
Public Overridable Sub Initialize (
    Optional autoStart As Boolean = true
)
abstract Initialize :
        ?autoStart : bool
(* Defaults:
        let _autoStart = defaultArg autoStart true
*)
-> unit
override Initialize :
        ?autoStart : bool
(* Defaults:
        let _autoStart = defaultArg autoStart true
*)
-> unit
function Initialize(autoStart);
public:
virtual void Initialize(
    bool autoStart = true
)

Parameters

autoStart (Optional)
Type: SystemBoolean
Sets flag that determines if adapters should be automatically started.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.InputMeasurementKeysUpdatedHandler Method

Grid Solutions Framework IaonSessionInputMeasurementKeysUpdatedHandler Method
Event handler for updates to adapter input measurement key definitions.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void InputMeasurementKeysUpdatedHandler(
    Object sender,
    EventArgs e
)
Public Overridable Sub InputMeasurementKeysUpdatedHandler (
    sender As Object,
    e As EventArgs
)
abstract InputMeasurementKeysUpdatedHandler :
        sender : Object *
        e : EventArgs -> unit
override InputMeasurementKeysUpdatedHandler :
        sender : Object *
        e : EventArgs -> unit
function InputMeasurementKeysUpdatedHandler(sender, e);
public:
virtual void InputMeasurementKeysUpdatedHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: SystemEventArgs
Event arguments, if any.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnConfigurationChanged Method

Grid Solutions Framework IaonSessionOnConfigurationChanged Method
Raises ConfigurationChanged event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConfigurationChanged(
    Object sender
)
Protected Overridable Sub OnConfigurationChanged (
    sender As Object
)
abstract OnConfigurationChanged :
        sender : Object -> unit
override OnConfigurationChanged :
        sender : Object -> unit
function OnConfigurationChanged(sender);
protected:
virtual void OnConfigurationChanged(
    Object^ sender
)

Parameters

sender
Type: SystemObject
Object source raising the event.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnDisposed Method

Grid Solutions Framework IaonSessionOnDisposed Method
Raises the Disposed event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDisposed(
    Object sender
)
Protected Overridable Sub OnDisposed (
    sender As Object
)
abstract OnDisposed :
        sender : Object -> unit
override OnDisposed :
        sender : Object -> unit
function OnDisposed(sender);
protected:
virtual void OnDisposed(
    Object^ sender
)

Parameters

sender
Type: SystemObject
Object source raising the event.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnInputMeasurementKeysUpdated Method

Grid Solutions Framework IaonSessionOnInputMeasurementKeysUpdated Method
Raises InputMeasurementKeysUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnInputMeasurementKeysUpdated(
    Object sender
)
Protected Overridable Sub OnInputMeasurementKeysUpdated (
    sender As Object
)
abstract OnInputMeasurementKeysUpdated :
        sender : Object -> unit
override OnInputMeasurementKeysUpdated :
        sender : Object -> unit
function OnInputMeasurementKeysUpdated(sender);
protected:
virtual void OnInputMeasurementKeysUpdated(
    Object^ sender
)

Parameters

sender
Type: SystemObject
Object source raising the event.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnOutputMeasurementsUpdated Method

Grid Solutions Framework IaonSessionOnOutputMeasurementsUpdated Method
Raises OutputMeasurementsUpdated event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnOutputMeasurementsUpdated(
    Object sender
)
Protected Overridable Sub OnOutputMeasurementsUpdated (
    sender As Object
)
abstract OnOutputMeasurementsUpdated :
        sender : Object -> unit
override OnOutputMeasurementsUpdated :
        sender : Object -> unit
function OnOutputMeasurementsUpdated(sender);
protected:
virtual void OnOutputMeasurementsUpdated(
    Object^ sender
)

Parameters

sender
Type: SystemObject
Object source raising the event.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnProcessException Method

Grid Solutions Framework IaonSessionOnProcessException Method
Raises ProcessException event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Object sender,
    Exception ex
)
Protected Overridable Sub OnProcessException (
    sender As Object,
    ex As Exception
)
abstract OnProcessException :
        sender : Object *
        ex : Exception -> unit
override OnProcessException :
        sender : Object *
        ex : Exception -> unit
function OnProcessException(sender, ex);
protected:
virtual void OnProcessException(
    Object^ sender,
    Exception^ ex
)

Parameters

sender
Type: SystemObject
Object source raising the event.
ex
Type: SystemException
Processing Exception.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnProcessingComplete Method

Grid Solutions Framework IaonSessionOnProcessingComplete Method
Raises the ProcessingComplete event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessingComplete(
    Object sender,
    EventArgs e = null
)
Protected Overridable Sub OnProcessingComplete (
    sender As Object,
    Optional e As EventArgs = Nothing
)
abstract OnProcessingComplete :
        sender : Object *
        ?e : EventArgs
(* Defaults:
        let _e = defaultArg e null
*)
-> unit
override OnProcessingComplete :
        sender : Object *
        ?e : EventArgs
(* Defaults:
        let _e = defaultArg e null
*)
-> unit
function OnProcessingComplete(sender, e);
protected:
virtual void OnProcessingComplete(
    Object^ sender,
    EventArgs^ e = nullptr
)

Parameters

sender
Type: SystemObject
Object source raising the event.
e (Optional)
Type: SystemEventArgs
EventArgs, if any.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnStatusMessage Method

Grid Solutions Framework IaonSessionOnStatusMessage Method
Overload List
 | Name | Description
Protected method | OnStatusMessage(Object, String, UpdateType) | Raises the StatusMessage event.
Protected method | OnStatusMessage(Object, String, UpdateType, Object) | Raises the StatusMessage event with a formatted status message.
Top
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnStatusMessage Method (Object, String, UpdateType)

Grid Solutions Framework IaonSessionOnStatusMessage Method (Object, String, UpdateType)
Raises the StatusMessage event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    Object sender,
    string status,
    UpdateType type = UpdateType.Information
)
Protected Overridable Sub OnStatusMessage (
    sender As Object,
    status As String,
    Optional type As UpdateType = UpdateType.Information
)
abstract OnStatusMessage :
        sender : Object *
        status : string *
        ?type : UpdateType
(* Defaults:
        let _type = defaultArg type UpdateType.Information
*)
-> unit
override OnStatusMessage :
        sender : Object *
        status : string *
        ?type : UpdateType
(* Defaults:
        let _type = defaultArg type UpdateType.Information
*)
-> unit
function OnStatusMessage(sender, status, type);
protected:
virtual void OnStatusMessage(
    Object^ sender,
    String^ status,
    UpdateType type = UpdateType::Information
)

Parameters

sender
Type: SystemObject
Object source raising the event.
status
Type: SystemString
New status message.
type (Optional)
Type: GSFUpdateType
UpdateType of status message.
See Also

Reference

IaonSession Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


IaonSession.OnStatusMessage Method (Object, String, UpdateType, Object[])

Grid Solutions Framework IaonSessionOnStatusMessage Method (Object, String, UpdateType, Object)
Raises the StatusMessage event with a formatted status message.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    Object sender,
    string formattedStatus,
    UpdateType type,
    params Object[] args
)
Protected Overridable Sub OnStatusMessage (
    sender As Object,
    formattedStatus As String,
    type As UpdateType,
    ParamArray args As Object()
)
abstract OnStatusMessage :
        sender : Object *
        formattedStatus : string *
        type : UpdateType *
        args : Object[] -> unit
override OnStatusMessage :
        sender : Object *
        formattedStatus : string *
        type : UpdateType *
        args : Object[] -> unit
function OnStatusMessage(sender, formattedStatus, type, ... args);
protected:
virtual void OnStatusMessage(
    Object^ sender,
    String^ formattedStatus,
    UpdateType type,
    ... array<Object^>^ args
)

Parameters

sender
Type: SystemObject
Object source raising the event.
formattedStatus
Type: SystemString
Formatted status message.
type
Type: GSFUpdateType
UpdateType of status message.
args
Type: SystemObject
Arguments for formattedStatus.
Remarks
This overload combines string.Format and SendStatusMessage for convenience.
See Also

Reference

IaonSession Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


IaonSession.OnUnprocessedMeasurements Method

Grid Solutions Framework IaonSessionOnUnprocessedMeasurements Method
Raises the UnprocessedMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnprocessedMeasurements(
    Object sender,
    int unprocessedMeasurements
)
Protected Overridable Sub OnUnprocessedMeasurements (
    sender As Object,
    unprocessedMeasurements As Integer
)
abstract OnUnprocessedMeasurements :
        sender : Object *
        unprocessedMeasurements : int -> unit
override OnUnprocessedMeasurements :
        sender : Object *
        unprocessedMeasurements : int -> unit
function OnUnprocessedMeasurements(sender, unprocessedMeasurements);
protected:
virtual void OnUnprocessedMeasurements(
    Object^ sender,
    int unprocessedMeasurements
)

Parameters

sender
Type: SystemObject
Object source raising the event.
unprocessedMeasurements
Type: SystemInt32
Total measurements in the queue that have not been processed.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OnUnpublishedSamples Method

Grid Solutions Framework IaonSessionOnUnpublishedSamples Method
Raises the UnpublishedSamples event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnpublishedSamples(
    Object sender,
    int seconds
)
Protected Overridable Sub OnUnpublishedSamples (
    sender As Object,
    seconds As Integer
)
abstract OnUnpublishedSamples :
        sender : Object *
        seconds : int -> unit
override OnUnpublishedSamples :
        sender : Object *
        seconds : int -> unit
function OnUnpublishedSamples(sender, seconds);
protected:
virtual void OnUnpublishedSamples(
    Object^ sender,
    int seconds
)

Parameters

sender
Type: SystemObject
Object source raising the event.
seconds
Type: SystemInt32
Total number of unpublished seconds of data.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OutputMeasurementsUpdatedHandler Method

Grid Solutions Framework IaonSessionOutputMeasurementsUpdatedHandler Method
Event handler for updates to adapter output measurement definitions.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void OutputMeasurementsUpdatedHandler(
    Object sender,
    EventArgs e
)
Public Overridable Sub OutputMeasurementsUpdatedHandler (
    sender As Object,
    e As EventArgs
)
abstract OutputMeasurementsUpdatedHandler :
        sender : Object *
        e : EventArgs -> unit
override OutputMeasurementsUpdatedHandler :
        sender : Object *
        e : EventArgs -> unit
function OutputMeasurementsUpdatedHandler(sender, e);
public:
virtual void OutputMeasurementsUpdatedHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Sending object.
e
Type: SystemEventArgs
Event arguments, if any.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ProcessExceptionHandler Method

Grid Solutions Framework IaonSessionProcessExceptionHandler Method
Event handler for processing reported exceptions.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void ProcessExceptionHandler(
    Object sender,
    EventArgs<Exception> e
)
Public Overridable Sub ProcessExceptionHandler (
    sender As Object,
    e As EventArgs(Of Exception)
)
abstract ProcessExceptionHandler :
        sender : Object *
        e : EventArgs<Exception> -> unit
override ProcessExceptionHandler :
        sender : Object *
        e : EventArgs<Exception> -> unit
function ProcessExceptionHandler(sender, e);
public:
virtual void ProcessExceptionHandler(
    Object^ sender,
    EventArgs<Exception^>^ e
)

Parameters

sender
Type: SystemObject
Event source of the exception.
e
Type: GSFEventArgs Exception
Event arguments containing the exception to report.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ProcessingCompleteHandler Method

Grid Solutions Framework IaonSessionProcessingCompleteHandler Method
Event handler for processing complete notifications from input adapters.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void ProcessingCompleteHandler(
    Object sender,
    EventArgs e
)
Public Overridable Sub ProcessingCompleteHandler (
    sender As Object,
    e As EventArgs
)
abstract ProcessingCompleteHandler :
        sender : Object *
        e : EventArgs -> unit
override ProcessingCompleteHandler :
        sender : Object *
        e : EventArgs -> unit
function ProcessingCompleteHandler(sender, e);
public:
virtual void ProcessingCompleteHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Event source reference to input adapter that is reporting processing completion.
e
Type: SystemEventArgs
Event arguments for event, if any; otherwise Empty.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.RecalculateRoutingTables Method

Grid Solutions Framework IaonSessionRecalculateRoutingTables Method
Recalculates routing tables as long as all adapters have been initialized.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RecalculateRoutingTables()
Public Overridable Sub RecalculateRoutingTables
abstract RecalculateRoutingTables : unit -> unit
override RecalculateRoutingTables : unit -> unit
function RecalculateRoutingTables();
public:
virtual void RecalculateRoutingTables()
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.RequestTemporalSupportHandler Method

Grid Solutions Framework IaonSessionRequestTemporalSupportHandler Method
Event handler for requesting temporal support.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RequestTemporalSupportHandler(
    Object sender,
    EventArgs e
)
Public Overridable Sub RequestTemporalSupportHandler (
    sender As Object,
    e As EventArgs
)
abstract RequestTemporalSupportHandler :
        sender : Object *
        e : EventArgs -> unit
override RequestTemporalSupportHandler :
        sender : Object *
        e : EventArgs -> unit
function RequestTemporalSupportHandler(sender, e);
public:
virtual void RequestTemporalSupportHandler(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Event source reference to adapter collection, typically an action adapter collection, that is requesting temporal support.
e
Type: SystemEventArgs
Event arguments are not used.
Remarks
Action adapter collections use this handler to make sure temporal support is initialized before setting up temporal sessions.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.StatusMessageHandler Method

Grid Solutions Framework IaonSessionStatusMessageHandler Method
Event handler for reporting status messages.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void StatusMessageHandler(
    Object sender,
    EventArgs<string> e
)
Public Overridable Sub StatusMessageHandler (
    sender As Object,
    e As EventArgs(Of String)
)
abstract StatusMessageHandler :
        sender : Object *
        e : EventArgs<string> -> unit
override StatusMessageHandler :
        sender : Object *
        e : EventArgs<string> -> unit
function StatusMessageHandler(sender, e);
public:
virtual void StatusMessageHandler(
    Object^ sender,
    EventArgs<String^>^ e
)

Parameters

sender
Type: SystemObject
Event source of the status message.
e
Type: GSFEventArgs String
Event arguments containing the status message to report.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.TemporalProcessingSupportExists Method

Grid Solutions Framework IaonSessionTemporalProcessingSupportExists Method
Gets flag that determines if temporal processing is supported in this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool TemporalProcessingSupportExists(
    string collection = null
)
Public Overridable Function TemporalProcessingSupportExists (
    Optional collection As String = Nothing
) As Boolean
abstract TemporalProcessingSupportExists :
        ?collection : string
(* Defaults:
        let _collection = defaultArg collection null
*)
-> bool
override TemporalProcessingSupportExists :
        ?collection : string
(* Defaults:
        let _collection = defaultArg collection null
*)
-> bool
function TemporalProcessingSupportExists(collection);
public:
virtual bool TemporalProcessingSupportExists(
    String^ collection = nullptr
)

Parameters

collection (Optional)
Type: SystemString
Name of collection over which to check support (e.g., "InputAdapters"); or null for all collections.

Return Value

Type: Boolean
Flag that determines if temporal processing is supported in this IaonSession.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.UnprocessedMeasurementsHandler Method

Grid Solutions Framework IaonSessionUnprocessedMeasurementsHandler Method
Event handler for monitoring unprocessed measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void UnprocessedMeasurementsHandler(
    Object sender,
    EventArgs<int> e
)
Public Overridable Sub UnprocessedMeasurementsHandler (
    sender As Object,
    e As EventArgs(Of Integer)
)
abstract UnprocessedMeasurementsHandler :
        sender : Object *
        e : EventArgs<int> -> unit
override UnprocessedMeasurementsHandler :
        sender : Object *
        e : EventArgs<int> -> unit
function UnprocessedMeasurementsHandler(sender, e);
public:
virtual void UnprocessedMeasurementsHandler(
    Object^ sender,
    EventArgs<int>^ e
)

Parameters

sender
Type: SystemObject
Event source reference to adapter, typically an output adapter, that is reporting the number of unprocessed measurements.
e
Type: GSFEventArgs Int32
Event arguments containing number of queued (i.e., unprocessed) measurements in the source adapter.
Remarks
Time-series framework uses this handler to monitor the number of unprocessed measurements in output adapters.
This method is typically called once every five seconds.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.UnpublishedSamplesHandler Method

Grid Solutions Framework IaonSessionUnpublishedSamplesHandler Method
Event handler for monitoring unpublished samples.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void UnpublishedSamplesHandler(
    Object sender,
    EventArgs<int> e
)
Public Overridable Sub UnpublishedSamplesHandler (
    sender As Object,
    e As EventArgs(Of Integer)
)
abstract UnpublishedSamplesHandler :
        sender : Object *
        e : EventArgs<int> -> unit
override UnpublishedSamplesHandler :
        sender : Object *
        e : EventArgs<int> -> unit
function UnpublishedSamplesHandler(sender, e);
public:
virtual void UnpublishedSamplesHandler(
    Object^ sender,
    EventArgs<int>^ e
)

Parameters

sender
Type: SystemObject
Event source reference to adapter, typically an action adapter, that is reporting the number of unpublished data samples.
e
Type: GSFEventArgs Int32
Event arguments containing number of samples, in seconds of data, of unpublished data in the source adapter.
Remarks
Time-series framework uses this handler to monitor the number of unpublished samples, in seconds of data, in action adapters.
This method is typically called once every five seconds.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession Properties

Grid Solutions Framework IaonSession Properties

The IaonSession type exposes the following members.

Properties
 | Name | Description
Public property | ActionAdapters | Gets the action adapter collection for this IaonSession.
Public property | AllAdapters | Gets the all adapters collection for this IaonSession.
Public property | DataSource | Gets or sets the configuration DataSet for this IaonSession.
Public property | InputAdapters | Gets the input adapter collection for this IaonSession.
Public property | InputMeasurementKeysRestriction | Gets or sets a routing table restriction for a collection of input measurement keys.
Public property | Name | Gets name assigned to this IaonSession, if any.
Public property | NodeID | Gets or sets the Guid node ID for this IaonSession.
Public property | OutputAdapters | Gets the output adapter collection for this IaonSession.
Public property | RoutingTables | Gets the routing tables for this IaonSession.
Public property | Status | Gets the combined status of the adapters in this IaonSession.
Top
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ActionAdapters Property

Grid Solutions Framework IaonSessionActionAdapters Property
Gets the action adapter collection for this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual ActionAdapterCollection ActionAdapters { get; }
Public Overridable ReadOnly Property ActionAdapters As ActionAdapterCollection
    Get
abstract ActionAdapters : ActionAdapterCollection with get
override ActionAdapters : ActionAdapterCollection with get
function get_ActionAdapters();

public:
virtual property ActionAdapterCollection^ ActionAdapters {
    ActionAdapterCollection^ get ();
}

Property Value

Type: ActionAdapterCollection
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.AllAdapters Property

Grid Solutions Framework IaonSessionAllAdapters Property
Gets the all adapters collection for this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual AllAdaptersCollection AllAdapters { get; }
Public Overridable ReadOnly Property AllAdapters As AllAdaptersCollection
    Get
abstract AllAdapters : AllAdaptersCollection with get
override AllAdapters : AllAdaptersCollection with get
function get_AllAdapters();

public:
virtual property AllAdaptersCollection^ AllAdapters {
    AllAdaptersCollection^ get ();
}

Property Value

Type: AllAdaptersCollection
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.DataSource Property

Grid Solutions Framework IaonSessionDataSource Property
Gets or sets the configuration DataSet for this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual DataSet DataSource { get; set; }
Public Overridable Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get ();
    void set (DataSet^ value);
}

Property Value

Type: DataSet
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.InputAdapters Property

Grid Solutions Framework IaonSessionInputAdapters Property
Gets the input adapter collection for this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual InputAdapterCollection InputAdapters { get; }
Public Overridable ReadOnly Property InputAdapters As InputAdapterCollection
    Get
abstract InputAdapters : InputAdapterCollection with get
override InputAdapters : InputAdapterCollection with get
function get_InputAdapters();

public:
virtual property InputAdapterCollection^ InputAdapters {
    InputAdapterCollection^ get ();
}

Property Value

Type: InputAdapterCollection
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.InputMeasurementKeysRestriction Property

Grid Solutions Framework IaonSessionInputMeasurementKeysRestriction Property
Gets or sets a routing table restriction for a collection of input measurement keys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] InputMeasurementKeysRestriction { get; set; }
Public Overridable Property InputMeasurementKeysRestriction As MeasurementKey()
    Get
    Set
abstract InputMeasurementKeysRestriction : MeasurementKey[] with get, set
override InputMeasurementKeysRestriction : MeasurementKey[] with get, set
function get_InputMeasurementKeysRestriction();
function set_InputMeasurementKeysRestriction(value);
public:
virtual property array<MeasurementKey^>^ InputMeasurementKeysRestriction {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.Name Property

Grid Solutions Framework IaonSessionName Property
Gets name assigned to this IaonSession, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Name { get; set; }
Public Overridable Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.NodeID Property

Grid Solutions Framework IaonSessionNodeID Property
Gets or sets the Guid node ID for this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual Guid NodeID { get; set; }
Public Overridable Property NodeID As Guid
    Get
    Set
abstract NodeID : Guid with get, set
override NodeID : Guid with get, set
function get_NodeID();
function set_NodeID(value);
public:
virtual property Guid NodeID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OutputAdapters Property

Grid Solutions Framework IaonSessionOutputAdapters Property
Gets the output adapter collection for this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual OutputAdapterCollection OutputAdapters { get; }
Public Overridable ReadOnly Property OutputAdapters As OutputAdapterCollection
    Get
abstract OutputAdapters : OutputAdapterCollection with get
override OutputAdapters : OutputAdapterCollection with get
function get_OutputAdapters();

public:
virtual property OutputAdapterCollection^ OutputAdapters {
    OutputAdapterCollection^ get ();
}

Property Value

Type: OutputAdapterCollection
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.RoutingTables Property

Grid Solutions Framework IaonSessionRoutingTables Property
Gets the routing tables for this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual RoutingTables RoutingTables { get; }
Public Overridable ReadOnly Property RoutingTables As RoutingTables
    Get
abstract RoutingTables : RoutingTables with get
override RoutingTables : RoutingTables with get
function get_RoutingTables();

public:
virtual property RoutingTables^ RoutingTables {
    RoutingTables^ get ();
}

Property Value

Type: RoutingTables
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.Status Property

Grid Solutions Framework IaonSessionStatus Property
Gets the combined status of the adapters in this IaonSession.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession Events

Grid Solutions Framework IaonSession Events

The IaonSession type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change.
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed.
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated.
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | ProcessingComplete | Indicates to the host that processing for one of the input adapters has completed.
Public event | StatusMessage | Provides status messages to consumer.
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Public event | UnpublishedSamples | Event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.
Top
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ConfigurationChanged Event

Grid Solutions Framework IaonSessionConfigurationChanged Event
Event is raised when adapter is aware of a configuration change.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConfigurationChanged
Public Event ConfigurationChanged As EventHandler
member ConfigurationChanged : IEvent<EventHandler,
    EventArgs>

function add_ConfigurationChanged(value);
function remove_ConfigurationChanged(value);
public:
 event EventHandler^ ConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.Disposed Event

Grid Solutions Framework IaonSessionDisposed Event
Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
member Disposed : IEvent<EventHandler,
    EventArgs>

function add_Disposed(value);
function remove_Disposed(value);
public:
 event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.InputMeasurementKeysUpdated Event

Grid Solutions Framework IaonSessionInputMeasurementKeysUpdated Event
Event is raised when InputMeasurementKeys are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler InputMeasurementKeysUpdated
Public Event InputMeasurementKeysUpdated As EventHandler
member InputMeasurementKeysUpdated : IEvent<EventHandler,
    EventArgs>

function add_InputMeasurementKeysUpdated(value);
function remove_InputMeasurementKeysUpdated(value);
public:
 event EventHandler^ InputMeasurementKeysUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.OutputMeasurementsUpdated Event

Grid Solutions Framework IaonSessionOutputMeasurementsUpdated Event
Event is raised when OutputMeasurements are updated.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler OutputMeasurementsUpdated
Public Event OutputMeasurementsUpdated As EventHandler
member OutputMeasurementsUpdated : IEvent<EventHandler,
    EventArgs>

function add_OutputMeasurementsUpdated(value);
function remove_OutputMeasurementsUpdated(value);
public:
 event EventHandler^ OutputMeasurementsUpdated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ProcessException Event

Grid Solutions Framework IaonSessionProcessException Event
Event is raised when there is an exception encountered while processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the exception that was thrown.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.ProcessingComplete Event

Grid Solutions Framework IaonSessionProcessingComplete Event
Indicates to the host that processing for one of the input adapters has completed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ProcessingComplete
Public Event ProcessingComplete As EventHandler
member ProcessingComplete : IEvent<EventHandler,
    EventArgs>

function add_ProcessingComplete(value);
function remove_ProcessingComplete(value);
public:
 event EventHandler^ ProcessingComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks
This event is expected to only be raised when an input adapter has been designed to process a finite amount of data, e.g., reading a historical range of data during temporal processing.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.StatusMessage Event

Grid Solutions Framework IaonSessionStatusMessage Event
Provides status messages to consumer.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string, UpdateType>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String, UpdateType))
member StatusMessage : IEvent<EventHandler<EventArgs<string, UpdateType>>,
    EventArgs<string, UpdateType>>

function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
 event EventHandler<EventArgs<String^, UpdateType>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^, UpdateType>^>^ value);
    void remove (EventHandler<EventArgs<String^, UpdateType>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String, UpdateType
Remarks
Argument1 is the new status message.
Argument2 is the message UpdateType.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.UnprocessedMeasurements Event

Grid Solutions Framework IaonSessionUnprocessedMeasurements Event
Event is raised every five seconds allowing host to track total number of unprocessed measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> UnprocessedMeasurements
Public Event UnprocessedMeasurements As EventHandler(Of EventArgs(Of Integer))
member UnprocessedMeasurements : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>

function add_UnprocessedMeasurements(value);
function remove_UnprocessedMeasurements(value);
public:
 event EventHandler<EventArgs<int>^>^ UnprocessedMeasurements {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32
Remarks

Each IOutputAdapter implementation reports its current queue size of unprocessed measurements so that if queue size reaches an unhealthy threshold, host can take evasive action.

Argument is total number of unprocessed measurements.

See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IaonSession.UnpublishedSamples Event

Grid Solutions Framework IaonSessionUnpublishedSamples Event
Event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> UnpublishedSamples
Public Event UnpublishedSamples As EventHandler(Of EventArgs(Of Integer))
member UnpublishedSamples : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>

function add_UnpublishedSamples(value);
function remove_UnpublishedSamples(value);
public:
 event EventHandler<EventArgs<int>^>^ UnpublishedSamples {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32
Remarks
Argument is the total number of unpublished seconds of data.
See Also

Reference

IaonSession Class
GSF.TimeSeries.Adapters Namespace


IInputAdapter Interface

Grid Solutions Framework IInputAdapter Interface
Represents the abstract interface for any incoming adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IInputAdapter : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus
Public Interface IInputAdapter
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
type IInputAdapter =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.IInputAdapter = function();
GSF.TimeSeries.Adapters.IInputAdapter.createInterface('GSF.TimeSeries.Adapters.IInputAdapter');
public interface class IInputAdapter : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus

The IInputAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | NewMeasurements | Provides new measurements from input adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | ProcessingComplete | Indicates to the host that processing for the input adapter has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


IInputAdapter Methods

Grid Solutions Framework IInputAdapter Methods

The IInputAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

IInputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IInputAdapter Properties

Grid Solutions Framework IInputAdapter Properties

The IInputAdapter type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
See Also

Reference

IInputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IInputAdapter.OutputSourceIDs Property

Grid Solutions Framework IInputAdapterOutputSourceIDs Property
Gets or sets Source values used to filter output measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string[] OutputSourceIDs { get; set; }
Property OutputSourceIDs As String()
    Get
    Set
abstract OutputSourceIDs : string[] with get, set

function get_OutputSourceIDs();
function set_OutputSourceIDs(value);
property array<String^>^ OutputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

IInputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IInputAdapter.RequestedOutputMeasurementKeys Property

Grid Solutions Framework IInputAdapterRequestedOutputMeasurementKeys Property
Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementKey[] RequestedOutputMeasurementKeys { get; set; }
Property RequestedOutputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedOutputMeasurementKeys : MeasurementKey[] with get, set

function get_RequestedOutputMeasurementKeys();
function set_RequestedOutputMeasurementKeys(value);
property array<MeasurementKey^>^ RequestedOutputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

IInputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IInputAdapter Events

Grid Solutions Framework IInputAdapter Events

The IInputAdapter type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | NewMeasurements | Provides new measurements from input adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | ProcessingComplete | Indicates to the host that processing for the input adapter has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Top
See Also

Reference

IInputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IInputAdapter.NewMeasurements Event

Grid Solutions Framework IInputAdapterNewMeasurements Event
Provides new measurements from input adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<ICollection<IMeasurement>>> NewMeasurements
Event NewMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>

function add_NewMeasurements(value);
function remove_NewMeasurements(value);
 event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ NewMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement
Remarks
Argument is a collection of new measurements for host to process.
See Also

Reference

IInputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IInputAdapter.ProcessingComplete Event

Grid Solutions Framework IInputAdapterProcessingComplete Event
Indicates to the host that processing for the input adapter has completed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler ProcessingComplete
Event ProcessingComplete As EventHandler
abstract ProcessingComplete : IEvent<EventHandler,
    EventArgs>

function add_ProcessingComplete(value);
function remove_ProcessingComplete(value);
 event EventHandler^ ProcessingComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks
This event is expected to only be raised when an input adapter has been designed to process a finite amount of data, e.g., reading a historical range of data during temporal processing.
See Also

Reference

IInputAdapter Interface
GSF.TimeSeries.Adapters Namespace


InputAdapterBase Class

Grid Solutions Framework InputAdapterBase Class
Represents the base class for any incoming input adapter.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersAdapterBase
GSF.TimeSeries.AdaptersInputAdapterBase
GSF.TimeSeries.TransportDataSubscriber

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class InputAdapterBase : AdapterBase,
    IInputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public MustInherit Class InputAdapterBase
    Inherits AdapterBase
    Implements IInputAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
[<AbstractClassAttribute>]
type InputAdapterBase =
    class
        inherit AdapterBase
        interface IInputAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.InputAdapterBase = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.InputAdapterBase',
    GSF.TimeSeries.Adapters.AdapterBase,
    GSF.TimeSeries.Adapters.IInputAdapter,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class InputAdapterBase abstract : public AdapterBase,
    IInputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The InputAdapterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | InputAdapterBase | Constructs a new instance of the InputAdapterBase.
Top
Methods
 | Name | Description
Protected method | AttemptConnection | Attempts to connect to data input source.
Protected method | AttemptDisconnection | Attempts to disconnect from data input source.
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InputAdapterBase object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes InputAdapterBase. (Overrides AdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnConnected | Called when data input source connection is established.
Protected method | OnDisconnected | Called when data input source is disconnected.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts this InputAdapterBase and initiates connection cycle to data input source. (Overrides AdapterBaseStart.)
Public method | Stop | Stops this InputAdapterBase and disconnects from data input source. (Overrides AdapterBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Protected property | ConnectionAttemptInterval | Gets or sets the connection attempt interval, in milliseconds, for the data input source.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase. (Inherited from AdapterBase.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any.
Public property | IsConnected | Gets flag that determines if InputAdapterBase is connected.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. (Overrides AdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from AdapterBase.)
Protected property | UseAsyncConnect | Gets flag that determines if the data input connects asynchronously.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from input adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | ProcessingComplete | Indicates to the host that processing for the input adapter has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Top
Remarks
Derived classes are expected to call OnNewMeasurements(ICollectionIMeasurement) when new measurements are received.
See Also

Reference

GSF.TimeSeries.Adapters Namespace


InputAdapterBase Constructor

Grid Solutions Framework InputAdapterBase Constructor
Constructs a new instance of the InputAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected InputAdapterBase()
Protected Sub New
new : unit -> InputAdapterBase
GSF.TimeSeries.Adapters.InputAdapterBase = function();
protected:
InputAdapterBase()
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase Methods

Grid Solutions Framework InputAdapterBase Methods

The InputAdapterBase type exposes the following members.

Methods
 | Name | Description
Protected method | AttemptConnection | Attempts to connect to data input source.
Protected method | AttemptDisconnection | Attempts to disconnect from data input source.
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InputAdapterBase object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes InputAdapterBase. (Overrides AdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnConnected | Called when data input source connection is established.
Protected method | OnDisconnected | Called when data input source is disconnected.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts this InputAdapterBase and initiates connection cycle to data input source. (Overrides AdapterBaseStart.)
Public method | Stop | Stops this InputAdapterBase and disconnects from data input source. (Overrides AdapterBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.AttemptConnection Method

Grid Solutions Framework InputAdapterBaseAttemptConnection Method
Attempts to connect to data input source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void AttemptConnection()
Protected MustOverride Sub AttemptConnection
abstract AttemptConnection : unit -> unit

function AttemptConnection();
protected:
virtual void AttemptConnection() abstract
Remarks
Derived classes should attempt connection to data input source here. Any exceptions thrown by this implementation will result in restart of the connection cycle.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.AttemptDisconnection Method

Grid Solutions Framework InputAdapterBaseAttemptDisconnection Method
Attempts to disconnect from data input source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void AttemptDisconnection()
Protected MustOverride Sub AttemptDisconnection
abstract AttemptDisconnection : unit -> unit

function AttemptDisconnection();
protected:
virtual void AttemptDisconnection() abstract
Remarks
Derived classes should attempt disconnect from data input source here. Any exceptions thrown by this implementation will be reported to host via ProcessException event.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.Dispose Method

Grid Solutions Framework InputAdapterBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the InputAdapterBase object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Top
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.Dispose Method (Boolean)

Grid Solutions Framework InputAdapterBaseDispose Method (Boolean)
Releases the unmanaged resources used by the InputAdapterBase object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

InputAdapterBase Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.Initialize Method

Grid Solutions Framework InputAdapterBaseInitialize Method
Initializes InputAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.OnConnected Method

Grid Solutions Framework InputAdapterBaseOnConnected Method
Called when data input source connection is established.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConnected()
Protected Overridable Sub OnConnected
abstract OnConnected : unit -> unit
override OnConnected : unit -> unit
function OnConnected();
protected:
virtual void OnConnected()
Remarks
Derived classes should call this method manually if UseAsyncConnect is true.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.OnDisconnected Method

Grid Solutions Framework InputAdapterBaseOnDisconnected Method
Called when data input source is disconnected.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDisconnected()
Protected Overridable Sub OnDisconnected
abstract OnDisconnected : unit -> unit
override OnDisconnected : unit -> unit
function OnDisconnected();
protected:
virtual void OnDisconnected()
Remarks
Derived classes should call this method manually if UseAsyncConnect is true.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.OnNewMeasurements Method

Grid Solutions Framework InputAdapterBaseOnNewMeasurements Method
Raises the NewMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNewMeasurements(
    ICollection<IMeasurement> measurements
)
Protected Overridable Sub OnNewMeasurements (
    measurements As ICollection(Of IMeasurement)
)
abstract OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
override OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
function OnNewMeasurements(measurements);
protected:
virtual void OnNewMeasurements(
    ICollection<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericICollection IMeasurement

[Missing <param name="measurements"/> documentation for "M:GSF.TimeSeries.Adapters.InputAdapterBase.OnNewMeasurements(System.Collections.Generic.ICollection{GSF.TimeSeries.IMeasurement})"]

See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.OnProcessingComplete Method

Grid Solutions Framework InputAdapterBaseOnProcessingComplete Method
Raises the ProcessingComplete event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessingComplete()
Protected Overridable Sub OnProcessingComplete
abstract OnProcessingComplete : unit -> unit
override OnProcessingComplete : unit -> unit
function OnProcessingComplete();
protected:
virtual void OnProcessingComplete()
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.Start Method

Grid Solutions Framework InputAdapterBaseStart Method
Starts this InputAdapterBase and initiates connection cycle to data input source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IAdapterStart
IAdapterStart
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.Stop Method

Grid Solutions Framework InputAdapterBaseStop Method
Stops this InputAdapterBase and disconnects from data input source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Stop()
Public Overrides Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() override

Implements

IAdapterStop
IAdapterStop
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase Properties

Grid Solutions Framework InputAdapterBase Properties

The InputAdapterBase type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Protected property | ConnectionAttemptInterval | Gets or sets the connection attempt interval, in milliseconds, for the data input source.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase. (Inherited from AdapterBase.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any.
Public property | IsConnected | Gets flag that determines if InputAdapterBase is connected.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. (Overrides AdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from AdapterBase.)
Protected property | UseAsyncConnect | Gets flag that determines if the data input connects asynchronously.
Top
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.ConnectionAttemptInterval Property

Grid Solutions Framework InputAdapterBaseConnectionAttemptInterval Property
Gets or sets the connection attempt interval, in milliseconds, for the data input source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected double ConnectionAttemptInterval { get; set; }
Protected Property ConnectionAttemptInterval As Double
    Get
    Set
member ConnectionAttemptInterval : float with get, set

function get_ConnectionAttemptInterval();
function set_ConnectionAttemptInterval(value);
protected:
property double ConnectionAttemptInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.InputMeasurementKeys Property

Grid Solutions Framework InputAdapterBaseInputMeasurementKeys Property
Gets or sets primary keys of input measurements the AdapterBase expects, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] InputMeasurementKeys { get; set; }
Public Overridable Property InputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract InputMeasurementKeys : MeasurementKey[] with get, set
override InputMeasurementKeys : MeasurementKey[] with get, set
function get_InputMeasurementKeys();
function set_InputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ InputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IAdapterInputMeasurementKeys
Remarks
Redefined to hide attributes defined in the base class.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.IsConnected Property

Grid Solutions Framework InputAdapterBaseIsConnected Property
Gets flag that determines if InputAdapterBase is connected.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool IsConnected { get; protected set; }
Public Overridable Property IsConnected As Boolean
    Get
    Protected Set
abstract IsConnected : bool with get, set
override IsConnected : bool with get, set
function get_IsConnected();
function set_IsConnected(value);
public:
virtual property bool IsConnected {
    bool get ();
    protected: void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.OutputSourceIDs Property

Grid Solutions Framework InputAdapterBaseOutputSourceIDs Property
Gets or sets Source values used to filter output measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] OutputSourceIDs { get; set; }
Public Overridable Property OutputSourceIDs As String()
    Get
    Set
abstract OutputSourceIDs : string[] with get, set
override OutputSourceIDs : string[] with get, set
function get_OutputSourceIDs();
function set_OutputSourceIDs(value);
public:
virtual property array<String^>^ OutputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String

Implements

IInputAdapterOutputSourceIDs
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.RequestedOutputMeasurementKeys Property

Grid Solutions Framework InputAdapterBaseRequestedOutputMeasurementKeys Property
Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedOutputMeasurementKeys { get; set; }
Public Overridable Property RequestedOutputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
override RequestedOutputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedOutputMeasurementKeys();
function set_RequestedOutputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedOutputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IInputAdapterRequestedOutputMeasurementKeys
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.Status Property

Grid Solutions Framework InputAdapterBaseStatus Property
Returns the detailed status of the data input source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
Remarks
Derived classes should extend status with implementation specific information.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.UseAsyncConnect Property

Grid Solutions Framework InputAdapterBaseUseAsyncConnect Property
Gets flag that determines if the data input connects asynchronously.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract bool UseAsyncConnect { get; }
Protected MustOverride ReadOnly Property UseAsyncConnect As Boolean
    Get
abstract UseAsyncConnect : bool with get

function get_UseAsyncConnect();

protected:
virtual property bool UseAsyncConnect {
    bool get () abstract;
}

Property Value

Type: Boolean
Remarks
Derived classes should return true when data input source is connects asynchronously, otherwise return false.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase Events

Grid Solutions Framework InputAdapterBase Events

The InputAdapterBase type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from input adapter.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | ProcessingComplete | Indicates to the host that processing for the input adapter has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Top
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.NewMeasurements Event

Grid Solutions Framework InputAdapterBaseNewMeasurements Event
Provides new measurements from input adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICollection<IMeasurement>>> NewMeasurements
Public Event NewMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
override NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
function add_NewMeasurements(value);
function remove_NewMeasurements(value);
public:
virtual  event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ NewMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement

Implements

IInputAdapterNewMeasurements
Remarks
Argument is a collection of new measurements for host to process.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterBase.ProcessingComplete Event

Grid Solutions Framework InputAdapterBaseProcessingComplete Event
Indicates to the host that processing for the input adapter has completed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ProcessingComplete
Public Event ProcessingComplete As EventHandler
abstract ProcessingComplete : IEvent<EventHandler,
    EventArgs>
override ProcessingComplete : IEvent<EventHandler,
    EventArgs>
function add_ProcessingComplete(value);
function remove_ProcessingComplete(value);
public:
virtual  event EventHandler^ ProcessingComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IInputAdapterProcessingComplete
Remarks
This event is expected to only be raised when an input adapter has been designed to process a finite amount of data, e.g., reading a historical range of data during temporal processing.
See Also

Reference

InputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection Class

Grid Solutions Framework InputAdapterCollection Class
Represents a collection of IInputAdapter implementations.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IInputAdapter
GSF.CollectionsListCollection IInputAdapter
GSF.TimeSeries.AdaptersAdapterCollectionBase IInputAdapter
GSF.TimeSeries.AdaptersInputAdapterCollection

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class InputAdapterCollection : AdapterCollectionBase<IInputAdapter>,
    IInputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public Class InputAdapterCollection
    Inherits AdapterCollectionBase(Of IInputAdapter)
    Implements IInputAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
type InputAdapterCollection =
    class
        inherit AdapterCollectionBase<IInputAdapter>
        interface IInputAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.InputAdapterCollection = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.InputAdapterCollection',
    GSF.TimeSeries.Adapters.AdapterCollectionBase`1,
    GSF.TimeSeries.Adapters.IInputAdapter,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class InputAdapterCollection : public AdapterCollectionBase<IInputAdapter^>,
    IInputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The InputAdapterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | InputAdapterCollection | Creates a new InputAdapterCollection.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Unwires events and disposes of IInputAdapter implementation. (Overrides AdapterCollectionBaseTDisposeItem(T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Loads all IAdapter implementations defined in DataSource. (Inherited from AdapterCollectionBaseT.)
Protected method | InitializeItem | Wires events and initializes new IInputAdapter implementation. (Overrides AdapterCollectionBaseTInitializeItem(T).)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Inherited from AdapterCollectionBaseT.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | NewMeasurements | This event will be raised when there are new measurements available from the input data source.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessingComplete | Indicates to the host that processing for one of the input adapters has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


InputAdapterCollection Constructor

Grid Solutions Framework InputAdapterCollection Constructor
Creates a new InputAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InputAdapterCollection()
Public Sub New
new : unit -> InputAdapterCollection
GSF.TimeSeries.Adapters.InputAdapterCollection = function();
public:
InputAdapterCollection()
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection Methods

Grid Solutions Framework InputAdapterCollection Methods

The InputAdapterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Unwires events and disposes of IInputAdapter implementation. (Overrides AdapterCollectionBaseTDisposeItem(T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Loads all IAdapter implementations defined in DataSource. (Inherited from AdapterCollectionBaseT.)
Protected method | InitializeItem | Wires events and initializes new IInputAdapter implementation. (Overrides AdapterCollectionBaseTInitializeItem(T).)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection.DisposeItem Method

Grid Solutions Framework InputAdapterCollectionDisposeItem Method
Unwires events and disposes of IInputAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void DisposeItem(
    IInputAdapter item
)
Protected Overrides Sub DisposeItem (
    item As IInputAdapter
)
abstract DisposeItem :
        item : IInputAdapter -> unit
override DisposeItem :
        item : IInputAdapter -> unit
function DisposeItem(item);
protected:
virtual void DisposeItem(
    IInputAdapter^ item
) override

Parameters

item
Type: GSF.TimeSeries.AdaptersIInputAdapter
IInputAdapter to dispose.
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection.InitializeItem Method

Grid Solutions Framework InputAdapterCollectionInitializeItem Method
Wires events and initializes new IInputAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InitializeItem(
    IInputAdapter item
)
Protected Overrides Sub InitializeItem (
    item As IInputAdapter
)
abstract InitializeItem :
        item : IInputAdapter -> unit
override InitializeItem :
        item : IInputAdapter -> unit
function InitializeItem(item);
protected:
virtual void InitializeItem(
    IInputAdapter^ item
) override

Parameters

item
Type: GSF.TimeSeries.AdaptersIInputAdapter
New IInputAdapter implementation.
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection.OnNewMeasurements Method

Grid Solutions Framework InputAdapterCollectionOnNewMeasurements Method
Raises the NewMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnNewMeasurements(
    ICollection<IMeasurement> measurements
)
Protected Overridable Sub OnNewMeasurements (
    measurements As ICollection(Of IMeasurement)
)
abstract OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
override OnNewMeasurements :
        measurements : ICollection<IMeasurement> -> unit
function OnNewMeasurements(measurements);
protected:
virtual void OnNewMeasurements(
    ICollection<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericICollection IMeasurement
New measurements.
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection.OnProcessingComplete Method

Grid Solutions Framework InputAdapterCollectionOnProcessingComplete Method
Raises the ProcessingComplete event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessingComplete()
Protected Overridable Sub OnProcessingComplete
abstract OnProcessingComplete : unit -> unit
override OnProcessingComplete : unit -> unit
function OnProcessingComplete();
protected:
virtual void OnProcessingComplete()
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection Properties

Grid Solutions Framework InputAdapterCollection Properties

The InputAdapterCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Inherited from AdapterCollectionBaseT.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection Events

Grid Solutions Framework InputAdapterCollection Events

The InputAdapterCollection type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | NewMeasurements | This event will be raised when there are new measurements available from the input data source.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessingComplete | Indicates to the host that processing for one of the input adapters has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Top
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection.NewMeasurements Event

Grid Solutions Framework InputAdapterCollectionNewMeasurements Event
This event will be raised when there are new measurements available from the input data source.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICollection<IMeasurement>>> NewMeasurements
Public Event NewMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
override NewMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>
function add_NewMeasurements(value);
function remove_NewMeasurements(value);
public:
virtual  event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ NewMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement

Implements

IInputAdapterNewMeasurements
Remarks
Argument is collection of new measurements for host to process.
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


InputAdapterCollection.ProcessingComplete Event

Grid Solutions Framework InputAdapterCollectionProcessingComplete Event
Indicates to the host that processing for one of the input adapters has completed.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ProcessingComplete
Public Event ProcessingComplete As EventHandler
abstract ProcessingComplete : IEvent<EventHandler,
    EventArgs>
override ProcessingComplete : IEvent<EventHandler,
    EventArgs>
function add_ProcessingComplete(value);
function remove_ProcessingComplete(value);
public:
virtual  event EventHandler^ ProcessingComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

IInputAdapterProcessingComplete
Remarks
This event is expected to only be raised when an input adapter has been designed to process a finite amount of data, e.g., reading a historical range of data during temporal processing.
See Also

Reference

InputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


IOutputAdapter Interface

Grid Solutions Framework IOutputAdapter Interface
Represents that abstract interface for any outgoing adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IOutputAdapter : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus
Public Interface IOutputAdapter
    Inherits IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
type IOutputAdapter =
    interface
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.IOutputAdapter = function();
GSF.TimeSeries.Adapters.IOutputAdapter.createInterface('GSF.TimeSeries.Adapters.IOutputAdapter');
public interface class IOutputAdapter : IAdapter,
    ISupportLifecycle, IDisposable, IProvideStatus

The IOutputAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | QueueMeasurementsForProcessing | Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | RemoveMeasurements | Implementations of this function should remove a range of measurements from the internal measurement queue.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurements.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputIsForArchive | Returns a flag that determines if measurements sent to this IOutputAdapter are destined for archival.
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


IOutputAdapter Methods

Grid Solutions Framework IOutputAdapter Methods

The IOutputAdapter type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | QueueMeasurementsForProcessing | Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | RemoveMeasurements | Implementations of this function should remove a range of measurements from the internal measurement queue.
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter.QueueMeasurementsForProcessing Method

Grid Solutions Framework IOutputAdapterQueueMeasurementsForProcessing Method
Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit

function QueueMeasurementsForProcessing(measurements);
void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Collection of measurements to queue for processing.
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter.RemoveMeasurements Method

Grid Solutions Framework IOutputAdapterRemoveMeasurements Method
Implementations of this function should remove a range of measurements from the internal measurement queue.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void RemoveMeasurements(
    int total
)
Sub RemoveMeasurements (
    total As Integer
)
abstract RemoveMeasurements :
        total : int -> unit

function RemoveMeasurements(total);
void RemoveMeasurements(
    int total
)

Parameters

total
Type: SystemInt32

[Missing <param name="total"/> documentation for "M:GSF.TimeSeries.Adapters.IOutputAdapter.RemoveMeasurements(System.Int32)"]

Remarks
This method is typically only used to curtail size of measurement queue if it's getting too large. If more points are requested than there are points available - all points in the queue should be removed.
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter Properties

Grid Solutions Framework IOutputAdapter Properties

The IOutputAdapter type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurements.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputIsForArchive | Returns a flag that determines if measurements sent to this IOutputAdapter are destined for archival.
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Top
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter.InputSourceIDs Property

Grid Solutions Framework IOutputAdapterInputSourceIDs Property
Gets or sets Source values used to filter input measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string[] InputSourceIDs { get; set; }
Property InputSourceIDs As String()
    Get
    Set
abstract InputSourceIDs : string[] with get, set

function get_InputSourceIDs();
function set_InputSourceIDs(value);
property array<String^>^ InputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter.OutputIsForArchive Property

Grid Solutions Framework IOutputAdapterOutputIsForArchive Property
Returns a flag that determines if measurements sent to this IOutputAdapter are destined for archival.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool OutputIsForArchive { get; }
ReadOnly Property OutputIsForArchive As Boolean
    Get
abstract OutputIsForArchive : bool with get

function get_OutputIsForArchive();

property bool OutputIsForArchive {
    bool get ();
}

Property Value

Type: Boolean
Remarks
This property allows the OutputAdapterCollection to calculate statistics on how many measurements have been archived per minute. Historians would normally set this property to true; other custom exports would set this property to false.
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter.RequestedInputMeasurementKeys Property

Grid Solutions Framework IOutputAdapterRequestedInputMeasurementKeys Property
Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
MeasurementKey[] RequestedInputMeasurementKeys { get; set; }
Property RequestedInputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedInputMeasurementKeys : MeasurementKey[] with get, set

function get_RequestedInputMeasurementKeys();
function set_RequestedInputMeasurementKeys(value);
property array<MeasurementKey^>^ RequestedInputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter Events

Grid Solutions Framework IOutputAdapter Events

The IOutputAdapter type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Top
See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


IOutputAdapter.UnprocessedMeasurements Event

Grid Solutions Framework IOutputAdapterUnprocessedMeasurements Event
Event is raised every five seconds allowing host to track total number of unprocessed measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<int>> UnprocessedMeasurements
Event UnprocessedMeasurements As EventHandler(Of EventArgs(Of Integer))
abstract UnprocessedMeasurements : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>

function add_UnprocessedMeasurements(value);
function remove_UnprocessedMeasurements(value);
 event EventHandler<EventArgs<int>^>^ UnprocessedMeasurements {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32
Remarks

Implementations of this interface are expected to report current queue size of unprocessed measurements so that if queue size reaches an unhealthy threshold, host can take evasive action.

Argument is total number of unprocessed measurements.

See Also

Reference

IOutputAdapter Interface
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase Class

Grid Solutions Framework OutputAdapterBase Class
Represents the base class for any outgoing data stream.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersAdapterBase
GSF.TimeSeries.AdaptersOutputAdapterBase

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class OutputAdapterBase : AdapterBase,
    IOutputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public MustInherit Class OutputAdapterBase
    Inherits AdapterBase
    Implements IOutputAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
[<AbstractClassAttribute>]
type OutputAdapterBase =
    class
        inherit AdapterBase
        interface IOutputAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.OutputAdapterBase = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.OutputAdapterBase',
    GSF.TimeSeries.Adapters.AdapterBase,
    GSF.TimeSeries.Adapters.IOutputAdapter,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class OutputAdapterBase abstract : public AdapterBase,
    IOutputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The OutputAdapterBase type exposes the following members.

Constructors
 | Name | Description
Protected method | OutputAdapterBase | Constructs a new instance of the OutputAdapterBase.
Top
Methods
 | Name | Description
Protected method | AttemptConnection | Attempts to connect to data output stream.
Protected method | AttemptDisconnection | Attempts to disconnect from data output stream.
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutputAdapterBase object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteMetadataRefresh | Executes the metadata refresh in a synchronous fashion.
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | Flush | Blocks the current thread, if the OutputAdapterBase is connected, until all items in OutputAdapterBase queue are processed, and then stops processing.
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes OutputAdapterBase. (Overrides AdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnConnected | Called when data output source connection is established.
Protected method | OnDisconnected | Called when data input source is disconnected.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnprocessedMeasurements | Raises the UnprocessedMeasurements event.
Protected method | ProcessMeasurements | Serializes measurements to data output stream.
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing. Measurement is automatically filtered to the defined InputMeasurementKeys.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | RefreshMetadata | Initiates request for metadata refresh for OutputAdapterBase, if implemented.
Public method | RemoveMeasurements | This removes a range of measurements from the internal measurement queue.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts this OutputAdapterBase and initiates connection cycle to data output stream. (Overrides AdapterBaseStart.)
Public method | Stop | Stops this OutputAdapterBase and disconnects from data output stream. (Overrides AdapterBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Protected property | ConnectionAttemptInterval | Gets or sets the connection attempt interval, in milliseconds, for the data output adapter.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this OutputAdapterBase. (Overrides AdapterBaseDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any. (Inherited from AdapterBase.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurements.
Protected property | InternalProcessQueue | Allows derived class access to internal processing queue.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Protected property | MetadataRefreshOperation | Gets the operation that calls ExecuteMetadataRefresh.
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputIsForArchive | Gets the flag that determines if measurements sent to this OutputAdapterBase are destined for archival.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the output adapter. (Overrides AdapterBaseProcessingInterval.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequeueOnException | Gets or sets whether or not to automatically place measurements back into the processing queue if an exception occurs while processing. Defaults to false.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. Derived classes should extend status with implementation specific information. (Overrides AdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this OutputAdapterBase implementation supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Protected property | UseAsyncConnect | Gets flag that determines if the data output stream connects asynchronously.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Top
Remarks
This base class acts as a measurement queue so that output adapters can temporarily go offline without losing any measurements to be processed. Derived classes are expected to override ProcessMeasurements(IMeasurement) to handle queued measurements.
See Also

Reference

GSF.TimeSeries.Adapters Namespace


OutputAdapterBase Constructor

Grid Solutions Framework OutputAdapterBase Constructor
Constructs a new instance of the OutputAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected OutputAdapterBase()
Protected Sub New
new : unit -> OutputAdapterBase
GSF.TimeSeries.Adapters.OutputAdapterBase = function();
protected:
OutputAdapterBase()
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase Methods

Grid Solutions Framework OutputAdapterBase Methods

The OutputAdapterBase type exposes the following members.

Methods
 | Name | Description
Protected method | AttemptConnection | Attempts to connect to data output stream.
Protected method | AttemptDisconnection | Attempts to disconnect from data output stream.
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutputAdapterBase object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExecuteMetadataRefresh | Executes the metadata refresh in a synchronous fashion.
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | Flush | Blocks the current thread, if the OutputAdapterBase is connected, until all items in OutputAdapterBase queue are processed, and then stops processing.
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes OutputAdapterBase. (Overrides AdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnConnected | Called when data output source connection is established.
Protected method | OnDisconnected | Called when data input source is disconnected.
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnprocessedMeasurements | Raises the UnprocessedMeasurements event.
Protected method | ProcessMeasurements | Serializes measurements to data output stream.
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing. Measurement is automatically filtered to the defined InputMeasurementKeys.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.
Public method | RefreshMetadata | Initiates request for metadata refresh for OutputAdapterBase, if implemented.
Public method | RemoveMeasurements | This removes a range of measurements from the internal measurement queue.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts this OutputAdapterBase and initiates connection cycle to data output stream. (Overrides AdapterBaseStart.)
Public method | Stop | Stops this OutputAdapterBase and disconnects from data output stream. (Overrides AdapterBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.AttemptConnection Method

Grid Solutions Framework OutputAdapterBaseAttemptConnection Method
Attempts to connect to data output stream.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void AttemptConnection()
Protected MustOverride Sub AttemptConnection
abstract AttemptConnection : unit -> unit

function AttemptConnection();
protected:
virtual void AttemptConnection() abstract
Remarks
Derived classes should attempt connection to data output stream here. Any exceptions thrown by this implementation will result in restart of the connection cycle.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.AttemptDisconnection Method

Grid Solutions Framework OutputAdapterBaseAttemptDisconnection Method
Attempts to disconnect from data output stream.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void AttemptDisconnection()
Protected MustOverride Sub AttemptDisconnection
abstract AttemptDisconnection : unit -> unit

function AttemptDisconnection();
protected:
virtual void AttemptDisconnection() abstract
Remarks
Derived classes should attempt disconnect from data output stream here. Any exceptions thrown by this implementation will be reported to host via ProcessException event.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.Dispose Method

Grid Solutions Framework OutputAdapterBaseDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the OutputAdapterBase object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Top
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.Dispose Method (Boolean)

Grid Solutions Framework OutputAdapterBaseDispose Method (Boolean)
Releases the unmanaged resources used by the OutputAdapterBase object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

OutputAdapterBase Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.ExecuteMetadataRefresh Method

Grid Solutions Framework OutputAdapterBaseExecuteMetadataRefresh Method
Executes the metadata refresh in a synchronous fashion.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExecuteMetadataRefresh()
Protected Overridable Sub ExecuteMetadataRefresh
abstract ExecuteMetadataRefresh : unit -> unit
override ExecuteMetadataRefresh : unit -> unit
function ExecuteMetadataRefresh();
protected:
virtual void ExecuteMetadataRefresh()
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.Flush Method

Grid Solutions Framework OutputAdapterBaseFlush Method
Blocks the current thread, if the OutputAdapterBase is connected, until all items in OutputAdapterBase queue are processed, and then stops processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Flush()
Public Overridable Sub Flush
abstract Flush : unit -> unit
override Flush : unit -> unit
function Flush();
public:
virtual void Flush()
Remarks

It is possible for items to be added to the queue while the flush is executing. The flush will continue to process items as quickly as possible until the queue is empty. Unless the user stops queuing items to be processed, the flush call may never return (not a happy situation on shutdown).

The OutputAdapterBase does not clear queue prior to destruction. If the user fails to call this method before the class is destructed, there may be items that remain unprocessed in the queue.

See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.Initialize Method

Grid Solutions Framework OutputAdapterBaseInitialize Method
Initializes OutputAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.OnConnected Method

Grid Solutions Framework OutputAdapterBaseOnConnected Method
Called when data output source connection is established.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnConnected()
Protected Overridable Sub OnConnected
abstract OnConnected : unit -> unit
override OnConnected : unit -> unit
function OnConnected();
protected:
virtual void OnConnected()
Remarks
Derived classes should call this method manually if UseAsyncConnect is true.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.OnDisconnected Method

Grid Solutions Framework OutputAdapterBaseOnDisconnected Method
Called when data input source is disconnected.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnDisconnected()
Protected Overridable Sub OnDisconnected
abstract OnDisconnected : unit -> unit
override OnDisconnected : unit -> unit
function OnDisconnected();
protected:
virtual void OnDisconnected()
Remarks
Derived classes should call this method manually if UseAsyncConnect is true.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.OnUnprocessedMeasurements Method

Grid Solutions Framework OutputAdapterBaseOnUnprocessedMeasurements Method
Raises the UnprocessedMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnprocessedMeasurements(
    int unprocessedMeasurements
)
Protected Overridable Sub OnUnprocessedMeasurements (
    unprocessedMeasurements As Integer
)
abstract OnUnprocessedMeasurements :
        unprocessedMeasurements : int -> unit
override OnUnprocessedMeasurements :
        unprocessedMeasurements : int -> unit
function OnUnprocessedMeasurements(unprocessedMeasurements);
protected:
virtual void OnUnprocessedMeasurements(
    int unprocessedMeasurements
)

Parameters

unprocessedMeasurements
Type: SystemInt32
Total measurements in the queue that have not been processed.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.ProcessMeasurements Method

Grid Solutions Framework OutputAdapterBaseProcessMeasurements Method
Serializes measurements to data output stream.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract void ProcessMeasurements(
    IMeasurement[] measurements
)
Protected MustOverride Sub ProcessMeasurements (
    measurements As IMeasurement()
)
abstract ProcessMeasurements :
        measurements : IMeasurement[] -> unit

function ProcessMeasurements(measurements);
protected:
virtual void ProcessMeasurements(
    array<IMeasurement^>^ measurements
) abstract

Parameters

measurements
Type: GSF.TimeSeriesIMeasurement

[Missing <param name="measurements"/> documentation for "M:GSF.TimeSeries.Adapters.OutputAdapterBase.ProcessMeasurements(GSF.TimeSeries.IMeasurement[])"]

Remarks

Derived classes must implement this function to process queued measurements. For example, this function would "archive" measurements if output adapter is for a historian.

It is important that consumers "resume" connection cycle if processing fails (e.g., connection to archive is lost). Here is an example:

Examples
Copy
protected virtual void ProcessMeasurements(IMeasurement[] measurements)
{
    try
    {
        // Process measurements...
        foreach (IMeasurement measurement in measurement)
        {
            ArchiveMeasurement(measurement);
        }
    }
    catch (Exception)
    {
        // So long as user hasn't requested to stop, restart connection cycle
        if (Enabled)
            Start();
    }
}

See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.QueueMeasurementForProcessing Method

Grid Solutions Framework OutputAdapterBaseQueueMeasurementForProcessing Method
Queues a single measurement for processing. Measurement is automatically filtered to the defined InputMeasurementKeys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void QueueMeasurementForProcessing(
    IMeasurement measurement
)
Public Overridable Sub QueueMeasurementForProcessing (
    measurement As IMeasurement
)
abstract QueueMeasurementForProcessing :
        measurement : IMeasurement -> unit
override QueueMeasurementForProcessing :
        measurement : IMeasurement -> unit
function QueueMeasurementForProcessing(measurement);
public:
virtual void QueueMeasurementForProcessing(
    IMeasurement^ measurement
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Measurement to queue for processing.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.QueueMeasurementsForProcessing Method

Grid Solutions Framework OutputAdapterBaseQueueMeasurementsForProcessing Method
Queues a collection of measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overridable Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Measurements to queue for processing.

Implements

IOutputAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.RefreshMetadata Method

Grid Solutions Framework OutputAdapterBaseRefreshMetadata Method
Initiates request for metadata refresh for OutputAdapterBase, if implemented.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Requests metadata refresh of output adapter.", new string[] { ... })]
public void RefreshMetadata()
<AdapterCommandAttribute("Requests metadata refresh of output adapter.", New String() { ... })>
Public Sub RefreshMetadata
[<AdapterCommandAttribute("Requests metadata refresh of output adapter.",
    new string[] { ... })>]
member RefreshMetadata : unit -> unit

function RefreshMetadata();
public:
[AdapterCommandAttribute(L"Requests metadata refresh of output adapter.",
    __gc new array<String^>^ { ... })]
void RefreshMetadata()
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.RemoveMeasurements Method

Grid Solutions Framework OutputAdapterBaseRemoveMeasurements Method
This removes a range of measurements from the internal measurement queue.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RemoveMeasurements(
    int total
)
Public Overridable Sub RemoveMeasurements (
    total As Integer
)
abstract RemoveMeasurements :
        total : int -> unit
override RemoveMeasurements :
        total : int -> unit
function RemoveMeasurements(total);
public:
virtual void RemoveMeasurements(
    int total
)

Parameters

total
Type: SystemInt32

[Missing <param name="total"/> documentation for "M:GSF.TimeSeries.Adapters.OutputAdapterBase.RemoveMeasurements(System.Int32)"]

Implements

IOutputAdapterRemoveMeasurements(Int32)
Remarks
This method is typically only used to curtail size of measurement queue if it's getting too large. If more points are requested than there are points available - all points in the queue will be removed.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.Start Method

Grid Solutions Framework OutputAdapterBaseStart Method
Starts this OutputAdapterBase and initiates connection cycle to data output stream.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IAdapterStart
IAdapterStart
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.Stop Method

Grid Solutions Framework OutputAdapterBaseStop Method
Stops this OutputAdapterBase and disconnects from data output stream.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Stop()
Public Overrides Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() override

Implements

IAdapterStop
IAdapterStop
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase Properties

Grid Solutions Framework OutputAdapterBase Properties

The OutputAdapterBase type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Protected property | ConnectionAttemptInterval | Gets or sets the connection attempt interval, in milliseconds, for the data output adapter.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this OutputAdapterBase. (Overrides AdapterBaseDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any. (Inherited from AdapterBase.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurements.
Protected property | InternalProcessQueue | Allows derived class access to internal processing queue.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Protected property | MetadataRefreshOperation | Gets the operation that calls ExecuteMetadataRefresh.
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputIsForArchive | Gets the flag that determines if measurements sent to this OutputAdapterBase are destined for archival.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the output adapter. (Overrides AdapterBaseProcessingInterval.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.
Public property | RequeueOnException | Gets or sets whether or not to automatically place measurements back into the processing queue if an exception occurs while processing. Defaults to false.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. Derived classes should extend status with implementation specific information. (Overrides AdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this OutputAdapterBase implementation supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Protected property | UseAsyncConnect | Gets flag that determines if the data output stream connects asynchronously.
Top
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.ConnectionAttemptInterval Property

Grid Solutions Framework OutputAdapterBaseConnectionAttemptInterval Property
Gets or sets the connection attempt interval, in milliseconds, for the data output adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected double ConnectionAttemptInterval { get; set; }
Protected Property ConnectionAttemptInterval As Double
    Get
    Set
member ConnectionAttemptInterval : float with get, set

function get_ConnectionAttemptInterval();
function set_ConnectionAttemptInterval(value);
protected:
property double ConnectionAttemptInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.DataSource Property

Grid Solutions Framework OutputAdapterBaseDataSource Property
Gets or sets DataSet based data source available to this OutputAdapterBase.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSet DataSource { get; set; }
Public Overrides Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get () override;
    void set (DataSet^ value) override;
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
IAdapterDataSource
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.InputSourceIDs Property

Grid Solutions Framework OutputAdapterBaseInputSourceIDs Property
Gets or sets Source values used to filter input measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string[] InputSourceIDs { get; set; }
Public Overridable Property InputSourceIDs As String()
    Get
    Set
abstract InputSourceIDs : string[] with get, set
override InputSourceIDs : string[] with get, set
function get_InputSourceIDs();
function set_InputSourceIDs(value);
public:
virtual property array<String^>^ InputSourceIDs {
    array<String^>^ get ();
    void set (array<String^>^ value);
}

Property Value

Type: String

Implements

IOutputAdapterInputSourceIDs
Remarks
This allows an adapter to associate itself with entire collections of measurements based on the source of the measurement keys. Set to null apply no filter.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.InternalProcessQueue Property

Grid Solutions Framework OutputAdapterBaseInternalProcessQueue Property
Allows derived class access to internal processing queue.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ProcessQueue<IMeasurement> InternalProcessQueue { get; }
Protected ReadOnly Property InternalProcessQueue As ProcessQueue(Of IMeasurement)
    Get
member InternalProcessQueue : ProcessQueue<IMeasurement> with get

function get_InternalProcessQueue();

protected:
property ProcessQueue<IMeasurement^>^ InternalProcessQueue {
    ProcessQueue<IMeasurement^>^ get ();
}

Property Value

Type: ProcessQueue IMeasurement
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.MetadataRefreshOperation Property

Grid Solutions Framework OutputAdapterBaseMetadataRefreshOperation Property
Gets the operation that calls ExecuteMetadataRefresh.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected LongSynchronizedOperation MetadataRefreshOperation { get; }
Protected ReadOnly Property MetadataRefreshOperation As LongSynchronizedOperation
    Get
member MetadataRefreshOperation : LongSynchronizedOperation with get

function get_MetadataRefreshOperation();

protected:
property LongSynchronizedOperation^ MetadataRefreshOperation {
    LongSynchronizedOperation^ get ();
}

Property Value

Type: LongSynchronizedOperation
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.OutputIsForArchive Property

Grid Solutions Framework OutputAdapterBaseOutputIsForArchive Property
Gets the flag that determines if measurements sent to this OutputAdapterBase are destined for archival.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract bool OutputIsForArchive { get; }
Public MustOverride ReadOnly Property OutputIsForArchive As Boolean
    Get
abstract OutputIsForArchive : bool with get

function get_OutputIsForArchive();

public:
virtual property bool OutputIsForArchive {
    bool get () abstract;
}

Property Value

Type: Boolean

Implements

IOutputAdapterOutputIsForArchive
Remarks
This property allows the OutputAdapterCollection to calculate statistics on how many measurements have been archived per minute. Historians would normally set this property to true; other custom exports would set this property to false.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.OutputMeasurements Property

Grid Solutions Framework OutputAdapterBaseOutputMeasurements Property
Gets or sets output measurements that the AdapterBase will produce, if any.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual IMeasurement[] OutputMeasurements { get; set; }
Public Overridable Property OutputMeasurements As IMeasurement()
    Get
    Set
abstract OutputMeasurements : IMeasurement[] with get, set
override OutputMeasurements : IMeasurement[] with get, set
function get_OutputMeasurements();
function set_OutputMeasurements(value);
public:
virtual property array<IMeasurement^>^ OutputMeasurements {
    array<IMeasurement^>^ get ();
    void set (array<IMeasurement^>^ value);
}

Property Value

Type: IMeasurement

Implements

IAdapterOutputMeasurements
Remarks
Redefined to hide attributes defined in the base class.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.ProcessingInterval Property

Grid Solutions Framework OutputAdapterBaseProcessingInterval Property
Gets or sets the desired processing interval, in milliseconds, for the output adapter.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ProcessingInterval { get; set; }
Public Overrides Property ProcessingInterval As Integer
    Get
    Set
abstract ProcessingInterval : int with get, set
override ProcessingInterval : int with get, set
function get_ProcessingInterval();
function set_ProcessingInterval(value);
public:
virtual property int ProcessingInterval {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32

Implements

IAdapterProcessingInterval
IAdapterProcessingInterval
Remarks
With the exception of the values of -1 and 0, this value specifies the desired processing interval for data, i.e., basically a delay, or timer interval, over which to process data. A value of -1 means to use the default processing interval while a value of 0 means to process data as fast as possible.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.RequestedInputMeasurementKeys Property

Grid Solutions Framework OutputAdapterBaseRequestedInputMeasurementKeys Property
Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual MeasurementKey[] RequestedInputMeasurementKeys { get; set; }
Public Overridable Property RequestedInputMeasurementKeys As MeasurementKey()
    Get
    Set
abstract RequestedInputMeasurementKeys : MeasurementKey[] with get, set
override RequestedInputMeasurementKeys : MeasurementKey[] with get, set
function get_RequestedInputMeasurementKeys();
function set_RequestedInputMeasurementKeys(value);
public:
virtual property array<MeasurementKey^>^ RequestedInputMeasurementKeys {
    array<MeasurementKey^>^ get ();
    void set (array<MeasurementKey^>^ value);
}

Property Value

Type: MeasurementKey

Implements

IOutputAdapterRequestedInputMeasurementKeys
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.RequeueOnException Property

Grid Solutions Framework OutputAdapterBaseRequeueOnException Property
Gets or sets whether or not to automatically place measurements back into the processing queue if an exception occurs while processing. Defaults to false.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
public virtual bool RequeueOnException { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(false)>
Public Overridable Property RequeueOnException As Boolean
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(false)>]
abstract RequeueOnException : bool with get, set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(false)>]
override RequeueOnException : bool with get, set
function get_RequeueOnException();
function set_RequeueOnException(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
virtual property bool RequeueOnException {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.Status Property

Grid Solutions Framework OutputAdapterBaseStatus Property
Returns the detailed status of the data input source. Derived classes should extend status with implementation specific information.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.SupportsTemporalProcessing Property

Grid Solutions Framework OutputAdapterBaseSupportsTemporalProcessing Property
Gets the flag indicating if this OutputAdapterBase implementation supports temporal processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get
override SupportsTemporalProcessing : bool with get
function get_SupportsTemporalProcessing();

public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IAdapterSupportsTemporalProcessing
IAdapterSupportsTemporalProcessing
Remarks
For output adapters that archive data it is assumed that the desired behavior will be to not support temporal processing since the data being processed has already been archived (i.e., no need to attempt to rearchive old data). As a result the default behavior for an output adapter is to not support temporal processing when OutputIsForArchive is true. If you have an output adapter that you want to support temporal data processing independent of the OutputIsForArchive value, then override this property and force the base value to the desired state.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.UseAsyncConnect Property

Grid Solutions Framework OutputAdapterBaseUseAsyncConnect Property
Gets flag that determines if the data output stream connects asynchronously.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected abstract bool UseAsyncConnect { get; }
Protected MustOverride ReadOnly Property UseAsyncConnect As Boolean
    Get
abstract UseAsyncConnect : bool with get

function get_UseAsyncConnect();

protected:
virtual property bool UseAsyncConnect {
    bool get () abstract;
}

Property Value

Type: Boolean
Remarks
Derived classes should return true when data output stream connects asynchronously, otherwise return false.
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase Events

Grid Solutions Framework OutputAdapterBase Events

The OutputAdapterBase type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Top
See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterBase.UnprocessedMeasurements Event

Grid Solutions Framework OutputAdapterBaseUnprocessedMeasurements Event
Event is raised every five seconds allowing host to track total number of unprocessed measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> UnprocessedMeasurements
Public Event UnprocessedMeasurements As EventHandler(Of EventArgs(Of Integer))
abstract UnprocessedMeasurements : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
override UnprocessedMeasurements : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
function add_UnprocessedMeasurements(value);
function remove_UnprocessedMeasurements(value);
public:
virtual  event EventHandler<EventArgs<int>^>^ UnprocessedMeasurements {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32

Implements

IOutputAdapterUnprocessedMeasurements
Remarks

Base class reports current queue size of unprocessed measurements so that if queue size reaches an unhealthy threshold, host can take evasive action.

Argument is total number of unprocessed measurements.

See Also

Reference

OutputAdapterBase Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection Class

Grid Solutions Framework OutputAdapterCollection Class
Represents a collection of IOutputAdapter implementations.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IOutputAdapter
GSF.CollectionsListCollection IOutputAdapter
GSF.TimeSeries.AdaptersAdapterCollectionBase IOutputAdapter
GSF.TimeSeries.AdaptersOutputAdapterCollection

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class OutputAdapterCollection : AdapterCollectionBase<IOutputAdapter>,
    IOutputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public Class OutputAdapterCollection
    Inherits AdapterCollectionBase(Of IOutputAdapter)
    Implements IOutputAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
type OutputAdapterCollection =
    class
        inherit AdapterCollectionBase<IOutputAdapter>
        interface IOutputAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Adapters.OutputAdapterCollection = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.OutputAdapterCollection',
    GSF.TimeSeries.Adapters.AdapterCollectionBase`1,
    GSF.TimeSeries.Adapters.IOutputAdapter,
    GSF.TimeSeries.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class OutputAdapterCollection : public AdapterCollectionBase<IOutputAdapter^>,
    IOutputAdapter, IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The OutputAdapterCollection type exposes the following members.

Constructors
 | Name | Description
Public method | OutputAdapterCollection | Creates a new OutputAdapterCollection.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Unwires events and disposes of IOutputAdapter implementation. (Overrides AdapterCollectionBaseTDisposeItem(T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Loads all IAdapter implementations defined in DataSource. (Inherited from AdapterCollectionBaseT.)
Protected method | InitializeItem | Wires events and initializes new IOutputAdapter implementation. (Overrides AdapterCollectionBaseTInitializeItem(T).)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Protected method | OnUnprocessedMeasurements | Raises the UnprocessedMeasurements event.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing to each IOutputAdapter implementation in this OutputAdapterCollection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | RemoveMeasurements | This function removes a range of measurements from the internal measurement queues. Note that the requested total will be removed from each IOutputAdapter implementation in this OutputAdapterCollection.
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Inherited from AdapterCollectionBaseT.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputIsForArchive | Returns a flag that determines if all measurements sent to this OutputAdapterCollection are destined for archival.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed and destined for archive thus far by each IOutputAdapter implementation in the OutputAdapterCollection. (Overrides AdapterCollectionBaseTProcessedMeasurements.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection Constructor

Grid Solutions Framework OutputAdapterCollection Constructor
Creates a new OutputAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OutputAdapterCollection()
Public Sub New
new : unit -> OutputAdapterCollection
GSF.TimeSeries.Adapters.OutputAdapterCollection = function();
public:
OutputAdapterCollection()
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection Methods

Grid Solutions Framework OutputAdapterCollection Methods

The OutputAdapterCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterCollectionBaseT object and optionally releases the managed resources. (Inherited from AdapterCollectionBaseT.)
Protected method | DisposeItem | Unwires events and disposes of IOutputAdapter implementation. (Overrides AdapterCollectionBaseTDisposeItem(T).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterCollectionBaseT object is reclaimed by GC. (Inherited from AdapterCollectionBaseT.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetShortStatus | Gets a short one-line status of this AdapterBase. (Inherited from AdapterCollectionBaseT.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Loads all IAdapter implementations defined in DataSource. (Inherited from AdapterCollectionBaseT.)
Protected method | InitializeItem | Wires events and initializes new IOutputAdapter implementation. (Overrides AdapterCollectionBaseTInitializeItem(T).)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Protected method | OnUnprocessedMeasurements | Raises the UnprocessedMeasurements event.
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing to each IOutputAdapter implementation in this OutputAdapterCollection.
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | RemoveMeasurements | This function removes a range of measurements from the internal measurement queues. Note that the requested total will be removed from each IOutputAdapter implementation in this OutputAdapterCollection.
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Starts, or restarts, each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | Stop | Stops each IAdapter implementation in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.DisposeItem Method

Grid Solutions Framework OutputAdapterCollectionDisposeItem Method
Unwires events and disposes of IOutputAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void DisposeItem(
    IOutputAdapter item
)
Protected Overrides Sub DisposeItem (
    item As IOutputAdapter
)
abstract DisposeItem :
        item : IOutputAdapter -> unit
override DisposeItem :
        item : IOutputAdapter -> unit
function DisposeItem(item);
protected:
virtual void DisposeItem(
    IOutputAdapter^ item
) override

Parameters

item
Type: GSF.TimeSeries.AdaptersIOutputAdapter
IOutputAdapter to dispose.
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.InitializeItem Method

Grid Solutions Framework OutputAdapterCollectionInitializeItem Method
Wires events and initializes new IOutputAdapter implementation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InitializeItem(
    IOutputAdapter item
)
Protected Overrides Sub InitializeItem (
    item As IOutputAdapter
)
abstract InitializeItem :
        item : IOutputAdapter -> unit
override InitializeItem :
        item : IOutputAdapter -> unit
function InitializeItem(item);
protected:
virtual void InitializeItem(
    IOutputAdapter^ item
) override

Parameters

item
Type: GSF.TimeSeries.AdaptersIOutputAdapter
New IOutputAdapter implementation.
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.OnUnprocessedMeasurements Method

Grid Solutions Framework OutputAdapterCollectionOnUnprocessedMeasurements Method
Raises the UnprocessedMeasurements event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnUnprocessedMeasurements(
    int unprocessedMeasurements
)
Protected Overridable Sub OnUnprocessedMeasurements (
    unprocessedMeasurements As Integer
)
abstract OnUnprocessedMeasurements :
        unprocessedMeasurements : int -> unit
override OnUnprocessedMeasurements :
        unprocessedMeasurements : int -> unit
function OnUnprocessedMeasurements(unprocessedMeasurements);
protected:
virtual void OnUnprocessedMeasurements(
    int unprocessedMeasurements
)

Parameters

unprocessedMeasurements
Type: SystemInt32
Total measurements in the queue that have not been processed.
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.QueueMeasurementsForProcessing Method

Grid Solutions Framework OutputAdapterCollectionQueueMeasurementsForProcessing Method
Queues a collection of measurements for processing to each IOutputAdapter implementation in this OutputAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overridable Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Measurements to queue for processing.

Implements

IOutputAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.RemoveMeasurements Method

Grid Solutions Framework OutputAdapterCollectionRemoveMeasurements Method
This function removes a range of measurements from the internal measurement queues. Note that the requested total will be removed from each IOutputAdapter implementation in this OutputAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void RemoveMeasurements(
    int total
)
Public Overridable Sub RemoveMeasurements (
    total As Integer
)
abstract RemoveMeasurements :
        total : int -> unit
override RemoveMeasurements :
        total : int -> unit
function RemoveMeasurements(total);
public:
virtual void RemoveMeasurements(
    int total
)

Parameters

total
Type: SystemInt32
Total measurements to remove from the each IOutputAdapter queue.

Implements

IOutputAdapterRemoveMeasurements(Int32)
Remarks
This method is typically only used to curtail size of measurement queue if it's getting too large. If more points are requested than there are points available - all points in the queue will be removed.
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection Properties

Grid Solutions Framework OutputAdapterCollection Properties

The OutputAdapterCollection type exposes the following members.

Properties
 | Name | Description
Protected property | AutoInitialize | Gets flag that determines if IAdapter implementations are automatically initialized when they are added to the collection. (Inherited from AdapterCollectionBaseT.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | OutputIsForArchive | Returns a flag that determines if all measurements sent to this OutputAdapterCollection are destined for archival.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed and destined for archive thus far by each IOutputAdapter implementation in the OutputAdapterCollection. (Overrides AdapterCollectionBaseTProcessedMeasurements.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Top
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.OutputIsForArchive Property

Grid Solutions Framework OutputAdapterCollectionOutputIsForArchive Property
Returns a flag that determines if all measurements sent to this OutputAdapterCollection are destined for archival.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool OutputIsForArchive { get; }
Public Overridable ReadOnly Property OutputIsForArchive As Boolean
    Get
abstract OutputIsForArchive : bool with get
override OutputIsForArchive : bool with get
function get_OutputIsForArchive();

public:
virtual property bool OutputIsForArchive {
    bool get ();
}

Property Value

Type: Boolean

Implements

IOutputAdapterOutputIsForArchive
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.ProcessedMeasurements Property

Grid Solutions Framework OutputAdapterCollectionProcessedMeasurements Property
Gets the total number of measurements processed and destined for archive thus far by each IOutputAdapter implementation in the OutputAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override long ProcessedMeasurements { get; }
Public Overrides ReadOnly Property ProcessedMeasurements As Long
    Get
abstract ProcessedMeasurements : int64 with get
override ProcessedMeasurements : int64 with get
function get_ProcessedMeasurements();

public:
virtual property long long ProcessedMeasurements {
    long long get () override;
}

Property Value

Type: Int64

Implements

IAdapterProcessedMeasurements
IAdapterProcessedMeasurements
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection Events

Grid Solutions Framework OutputAdapterCollection Events

The OutputAdapterCollection type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Public event | UnprocessedMeasurements | Event is raised every five seconds allowing host to track total number of unprocessed measurements.
Top
See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


OutputAdapterCollection.UnprocessedMeasurements Event

Grid Solutions Framework OutputAdapterCollectionUnprocessedMeasurements Event
Event is raised every five seconds allowing host to track total number of unprocessed measurements.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<int>> UnprocessedMeasurements
Public Event UnprocessedMeasurements As EventHandler(Of EventArgs(Of Integer))
abstract UnprocessedMeasurements : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
override UnprocessedMeasurements : IEvent<EventHandler<EventArgs<int>>,
    EventArgs<int>>
function add_UnprocessedMeasurements(value);
function remove_UnprocessedMeasurements(value);
public:
virtual  event EventHandler<EventArgs<int>^>^ UnprocessedMeasurements {
    void add (EventHandler<EventArgs<int>^>^ value);
    void remove (EventHandler<EventArgs<int>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Int32

Implements

IOutputAdapterUnprocessedMeasurements
Remarks

Each IOutputAdapter implementation reports its current queue size of unprocessed measurements so that if queue size reaches an unhealthy threshold, host can take evasive action.

Argument is total number of unprocessed measurements.

See Also

Reference

OutputAdapterCollection Class
GSF.TimeSeries.Adapters Namespace


RoutingTables Class

Grid Solutions Framework RoutingTables Class
Represents the routing tables for the Iaon adapters.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersRoutingTables

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class RoutingTables : IDisposable
Public Class RoutingTables
    Implements IDisposable
type RoutingTables =
    class
        interface IDisposable
    end
GSF.TimeSeries.Adapters.RoutingTables = function();

Type.createClass(
    'GSF.TimeSeries.Adapters.RoutingTables',
    null,
    IDisposable);
public ref class RoutingTables : IDisposable

The RoutingTables type exposes the following members.

Constructors
 | Name | Description
Public method | RoutingTables | Creates a new instance of the RoutingTables class.
Top
Methods
 | Name | Description
Public method | BroadcastMeasurementsHandler | Event handler for distributing new measurements in a broadcast fashion.
Public method | CalculateRoutingTables | Spawn routing tables recalculation.
Public method | Dispose | Releases all the resources used by the RoutingTables object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RoutingTables object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the RoutingTables object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoutedMeasurementsHandler | Gets a handler for measurements that routes measurements to the appropriate consumers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleConnectOnDemandAdapters | Starts or stops connect on demand adapters based on current state of demanded input or output signals.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TraverseDependencyChain(IInputAdapter, IActionAdapter, IOutputAdapter) | Determines the set of adapters in the dependency chain for all adapters in the system which are either not connect or demand or are demanded.
Protected method | TraverseDependencyChain(ISetMeasurementKey, IInputAdapter, IActionAdapter, IOutputAdapter) | Determines the set of adapters in the dependency chain that produces the set of signals in the inputMeasurementKeysRestriction and returns the set of input signals required by the adapters in the chain and the set of output signals produced by the adapters in the chain.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ActionAdapters | Gets or sets the active ActionAdapterCollection.
Public property | InputAdapters | Gets or sets the active InputAdapterCollection.
Public property | OutputAdapters | Gets or sets the active OutputAdapterCollection.
Top
Events
 | Name | Description
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

GSF.TimeSeries.Adapters Namespace


RoutingTables Constructor

Grid Solutions Framework RoutingTables Constructor
Creates a new instance of the RoutingTables class.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public RoutingTables()
Public Sub New
new : unit -> RoutingTables
GSF.TimeSeries.Adapters.RoutingTables = function();
public:
RoutingTables()
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables Methods

Grid Solutions Framework RoutingTables Methods

The RoutingTables type exposes the following members.

Methods
 | Name | Description
Public method | BroadcastMeasurementsHandler | Event handler for distributing new measurements in a broadcast fashion.
Public method | CalculateRoutingTables | Spawn routing tables recalculation.
Public method | Dispose | Releases all the resources used by the RoutingTables object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RoutingTables object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the RoutingTables object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetRoutedMeasurementsHandler | Gets a handler for measurements that routes measurements to the appropriate consumers.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | HandleConnectOnDemandAdapters | Starts or stops connect on demand adapters based on current state of demanded input or output signals.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TraverseDependencyChain(IInputAdapter, IActionAdapter, IOutputAdapter) | Determines the set of adapters in the dependency chain for all adapters in the system which are either not connect or demand or are demanded.
Protected method | TraverseDependencyChain(ISetMeasurementKey, IInputAdapter, IActionAdapter, IOutputAdapter) | Determines the set of adapters in the dependency chain that produces the set of signals in the inputMeasurementKeysRestriction and returns the set of input signals required by the adapters in the chain and the set of output signals produced by the adapters in the chain.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.BroadcastMeasurementsHandler Method

Grid Solutions Framework RoutingTablesBroadcastMeasurementsHandler Method
Event handler for distributing new measurements in a broadcast fashion.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void BroadcastMeasurementsHandler(
    Object sender,
    EventArgs<ICollection<IMeasurement>> e
)
Public Overridable Sub BroadcastMeasurementsHandler (
    sender As Object,
    e As EventArgs(Of ICollection(Of IMeasurement))
)
abstract BroadcastMeasurementsHandler :
        sender : Object *
        e : EventArgs<ICollection<IMeasurement>> -> unit
override BroadcastMeasurementsHandler :
        sender : Object *
        e : EventArgs<ICollection<IMeasurement>> -> unit
function BroadcastMeasurementsHandler(sender, e);
public:
virtual void BroadcastMeasurementsHandler(
    Object^ sender,
    EventArgs<ICollection<IMeasurement^>^>^ e
)

Parameters

sender
Type: SystemObject
Event source reference to adapter that generated new measurements.
e
Type: GSFEventArgs ICollection IMeasurement
Event arguments containing a collection of new measurements.
Remarks
Time-series framework uses this handler to route new measurements to the action and output adapters; adapter will handle filtering.
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.CalculateRoutingTables Method

Grid Solutions Framework RoutingTablesCalculateRoutingTables Method
Spawn routing tables recalculation.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void CalculateRoutingTables(
    MeasurementKey[] inputMeasurementKeysRestriction
)
Public Overridable Sub CalculateRoutingTables (
    inputMeasurementKeysRestriction As MeasurementKey()
)
abstract CalculateRoutingTables :
        inputMeasurementKeysRestriction : MeasurementKey[] -> unit
override CalculateRoutingTables :
        inputMeasurementKeysRestriction : MeasurementKey[] -> unit
function CalculateRoutingTables(inputMeasurementKeysRestriction);
public:
virtual void CalculateRoutingTables(
    array<MeasurementKey^>^ inputMeasurementKeysRestriction
)

Parameters

inputMeasurementKeysRestriction
Type: GSF.TimeSeriesMeasurementKey
Input measurement keys restriction.
Remarks
Set the inputMeasurementKeysRestriction to null to use full adapter I/O routing demands.
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.Dispose Method

Grid Solutions Framework RoutingTablesDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the RoutingTables object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the RoutingTables object and optionally releases the managed resources.
Top
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.Dispose Method

Grid Solutions Framework RoutingTablesDispose Method
Releases all the resources used by the RoutingTables object.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

RoutingTables Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


RoutingTables.Dispose Method (Boolean)

Grid Solutions Framework RoutingTablesDispose Method (Boolean)
Releases the unmanaged resources used by the RoutingTables object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

RoutingTables Class
Dispose Overload
GSF.TimeSeries.Adapters Namespace


RoutingTables.Finalize Method

Grid Solutions Framework RoutingTablesFinalize Method
Releases the unmanaged resources before the RoutingTables object is reclaimed by GC.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.GetRoutedMeasurementsHandler Method

Grid Solutions Framework RoutingTablesGetRoutedMeasurementsHandler Method
Gets a handler for measurements that routes measurements to the appropriate consumers.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual EventHandler<EventArgs<ICollection<IMeasurement>>> GetRoutedMeasurementsHandler()
Public Overridable Function GetRoutedMeasurementsHandler As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
abstract GetRoutedMeasurementsHandler : unit -> EventHandler<EventArgs<ICollection<IMeasurement>>>
override GetRoutedMeasurementsHandler : unit -> EventHandler<EventArgs<ICollection<IMeasurement>>>
function GetRoutedMeasurementsHandler();
public:
virtual EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ GetRoutedMeasurementsHandler()

Return Value

Type: EventHandler EventArgs ICollection IMeasurement
The measurement handler used for routing.
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.HandleConnectOnDemandAdapters Method

Grid Solutions Framework RoutingTablesHandleConnectOnDemandAdapters Method
Starts or stops connect on demand adapters based on current state of demanded input or output signals.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void HandleConnectOnDemandAdapters(
    ISet<MeasurementKey> inputMeasurementKeysRestriction,
    IInputAdapter[] inputAdapterCollection,
    IActionAdapter[] actionAdapterCollection,
    IOutputAdapter[] outputAdapterCollection
)
Protected Overridable Sub HandleConnectOnDemandAdapters (
    inputMeasurementKeysRestriction As ISet(Of MeasurementKey),
    inputAdapterCollection As IInputAdapter(),
    actionAdapterCollection As IActionAdapter(),
    outputAdapterCollection As IOutputAdapter()
)
abstract HandleConnectOnDemandAdapters :
        inputMeasurementKeysRestriction : ISet<MeasurementKey> *
        inputAdapterCollection : IInputAdapter[] *
        actionAdapterCollection : IActionAdapter[] *
        outputAdapterCollection : IOutputAdapter[] -> unit
override HandleConnectOnDemandAdapters :
        inputMeasurementKeysRestriction : ISet<MeasurementKey> *
        inputAdapterCollection : IInputAdapter[] *
        actionAdapterCollection : IActionAdapter[] *
        outputAdapterCollection : IOutputAdapter[] -> unit
function HandleConnectOnDemandAdapters(inputMeasurementKeysRestriction, inputAdapterCollection, actionAdapterCollection, outputAdapterCollection);
protected:
virtual void HandleConnectOnDemandAdapters(
    ISet<MeasurementKey^>^ inputMeasurementKeysRestriction,
    array<IInputAdapter^>^ inputAdapterCollection,
    array<IActionAdapter^>^ actionAdapterCollection,
    array<IOutputAdapter^>^ outputAdapterCollection
)

Parameters

inputMeasurementKeysRestriction
Type: System.Collections.GenericISet MeasurementKey
The set of signals to be produced by the chain of adapters to be handled.
inputAdapterCollection
Type: GSF.TimeSeries.AdaptersIInputAdapter
Collection of input adapters at start of routing table calculation.
actionAdapterCollection
Type: GSF.TimeSeries.AdaptersIActionAdapter
Collection of action adapters at start of routing table calculation.
outputAdapterCollection
Type: GSF.TimeSeries.AdaptersIOutputAdapter
Collection of output adapters at start of routing table calculation.
Remarks
Set the inputMeasurementKeysRestriction to null to use full adapter routing demands.
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.OnProcessException Method

Grid Solutions Framework RoutingTablesOnProcessException Method
Raises ProcessException event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.OnStatusMessage Method

Grid Solutions Framework RoutingTablesOnStatusMessage Method
Overload List
 | Name | Description
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Top
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.OnStatusMessage Method (String)

Grid Solutions Framework RoutingTablesOnStatusMessage Method (String)
Raises the StatusMessage event.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string status
)
Protected Overridable Sub OnStatusMessage (
    status As String
)
abstract OnStatusMessage :
        status : string -> unit
override OnStatusMessage :
        status : string -> unit
function OnStatusMessage(status);
protected:
virtual void OnStatusMessage(
    String^ status
)

Parameters

status
Type: SystemString
New status message.
See Also

Reference

RoutingTables Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


RoutingTables.OnStatusMessage Method (String, Object[])

Grid Solutions Framework RoutingTablesOnStatusMessage Method (String, Object)
Raises the StatusMessage event with a formatted status message.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string formattedStatus,
    params Object[] args
)
Protected Overridable Sub OnStatusMessage (
    formattedStatus As String,
    ParamArray args As Object()
)
abstract OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
override OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
function OnStatusMessage(formattedStatus, ... args);
protected:
virtual void OnStatusMessage(
    String^ formattedStatus,
    ... array<Object^>^ args
)

Parameters

formattedStatus
Type: SystemString
Formatted status message.
args
Type: SystemObject
Arguments for formattedStatus.
Remarks
This overload combines string.Format and SendStatusMessage for convenience.
See Also

Reference

RoutingTables Class
OnStatusMessage Overload
GSF.TimeSeries.Adapters Namespace


RoutingTables.TraverseDependencyChain Method

Grid Solutions Framework RoutingTablesTraverseDependencyChain Method
Overload List
 | Name | Description
Protected method | TraverseDependencyChain(IInputAdapter, IActionAdapter, IOutputAdapter) | Determines the set of adapters in the dependency chain for all adapters in the system which are either not connect or demand or are demanded.
Protected method | TraverseDependencyChain(ISetMeasurementKey, IInputAdapter, IActionAdapter, IOutputAdapter) | Determines the set of adapters in the dependency chain that produces the set of signals in the inputMeasurementKeysRestriction and returns the set of input signals required by the adapters in the chain and the set of output signals produced by the adapters in the chain.
Top
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.TraverseDependencyChain Method (IInputAdapter[], IActionAdapter[], IOutputAdapter[])

Grid Solutions Framework RoutingTablesTraverseDependencyChain Method (IInputAdapter, IActionAdapter, IOutputAdapter)
Determines the set of adapters in the dependency chain for all adapters in the system which are either not connect or demand or are demanded.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual ISet<IAdapter> TraverseDependencyChain(
    IInputAdapter[] inputAdapterCollection,
    IActionAdapter[] actionAdapterCollection,
    IOutputAdapter[] outputAdapterCollection
)
Protected Overridable Function TraverseDependencyChain (
    inputAdapterCollection As IInputAdapter(),
    actionAdapterCollection As IActionAdapter(),
    outputAdapterCollection As IOutputAdapter()
) As ISet(Of IAdapter)
abstract TraverseDependencyChain :
        inputAdapterCollection : IInputAdapter[] *
        actionAdapterCollection : IActionAdapter[] *
        outputAdapterCollection : IOutputAdapter[] -> ISet<IAdapter>
override TraverseDependencyChain :
        inputAdapterCollection : IInputAdapter[] *
        actionAdapterCollection : IActionAdapter[] *
        outputAdapterCollection : IOutputAdapter[] -> ISet<IAdapter>
function TraverseDependencyChain(inputAdapterCollection, actionAdapterCollection, outputAdapterCollection);
protected:
virtual ISet<IAdapter^>^ TraverseDependencyChain(
    array<IInputAdapter^>^ inputAdapterCollection,
    array<IActionAdapter^>^ actionAdapterCollection,
    array<IOutputAdapter^>^ outputAdapterCollection
)

Parameters

inputAdapterCollection
Type: GSF.TimeSeries.AdaptersIInputAdapter
Collection of input adapters at start of routing table calculation.
actionAdapterCollection
Type: GSF.TimeSeries.AdaptersIActionAdapter
Collection of action adapters at start of routing table calculation.
outputAdapterCollection
Type: GSF.TimeSeries.AdaptersIOutputAdapter
Collection of output adapters at start of routing table calculation.

Return Value

Type: ISet IAdapter

[Missing <returns> documentation for "M:GSF.TimeSeries.Adapters.RoutingTables.TraverseDependencyChain(GSF.TimeSeries.Adapters.IInputAdapter[],GSF.TimeSeries.Adapters.IActionAdapter[],GSF.TimeSeries.Adapters.IOutputAdapter[])"]

See Also

Reference

RoutingTables Class
TraverseDependencyChain Overload
GSF.TimeSeries.Adapters Namespace


RoutingTables.TraverseDependencyChain Method (ISet(MeasurementKey), IInputAdapter[], IActionAdapter[], IOutputAdapter[])

Grid Solutions Framework RoutingTablesTraverseDependencyChain Method (ISetMeasurementKey, IInputAdapter, IActionAdapter, IOutputAdapter)
Determines the set of adapters in the dependency chain that produces the set of signals in the inputMeasurementKeysRestriction and returns the set of input signals required by the adapters in the chain and the set of output signals produced by the adapters in the chain.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual ISet<IAdapter> TraverseDependencyChain(
    ISet<MeasurementKey> inputMeasurementKeysRestriction,
    IInputAdapter[] inputAdapterCollection,
    IActionAdapter[] actionAdapterCollection,
    IOutputAdapter[] outputAdapterCollection
)
Protected Overridable Function TraverseDependencyChain (
    inputMeasurementKeysRestriction As ISet(Of MeasurementKey),
    inputAdapterCollection As IInputAdapter(),
    actionAdapterCollection As IActionAdapter(),
    outputAdapterCollection As IOutputAdapter()
) As ISet(Of IAdapter)
abstract TraverseDependencyChain :
        inputMeasurementKeysRestriction : ISet<MeasurementKey> *
        inputAdapterCollection : IInputAdapter[] *
        actionAdapterCollection : IActionAdapter[] *
        outputAdapterCollection : IOutputAdapter[] -> ISet<IAdapter>
override TraverseDependencyChain :
        inputMeasurementKeysRestriction : ISet<MeasurementKey> *
        inputAdapterCollection : IInputAdapter[] *
        actionAdapterCollection : IActionAdapter[] *
        outputAdapterCollection : IOutputAdapter[] -> ISet<IAdapter>
function TraverseDependencyChain(inputMeasurementKeysRestriction, inputAdapterCollection, actionAdapterCollection, outputAdapterCollection);
protected:
virtual ISet<IAdapter^>^ TraverseDependencyChain(
    ISet<MeasurementKey^>^ inputMeasurementKeysRestriction,
    array<IInputAdapter^>^ inputAdapterCollection,
    array<IActionAdapter^>^ actionAdapterCollection,
    array<IOutputAdapter^>^ outputAdapterCollection
)

Parameters

inputMeasurementKeysRestriction
Type: System.Collections.GenericISet MeasurementKey
The set of signals that must be produced by the dependency chain.
inputAdapterCollection
Type: GSF.TimeSeries.AdaptersIInputAdapter
Collection of input adapters at start of routing table calculation.
actionAdapterCollection
Type: GSF.TimeSeries.AdaptersIActionAdapter
Collection of action adapters at start of routing table calculation.
outputAdapterCollection
Type: GSF.TimeSeries.AdaptersIOutputAdapter
Collection of output adapters at start of routing table calculation.

Return Value

Type: ISet IAdapter

[Missing <returns> documentation for "M:GSF.TimeSeries.Adapters.RoutingTables.TraverseDependencyChain(System.Collections.Generic.ISet{GSF.TimeSeries.MeasurementKey},GSF.TimeSeries.Adapters.IInputAdapter[],GSF.TimeSeries.Adapters.IActionAdapter[],GSF.TimeSeries.Adapters.IOutputAdapter[])"]

See Also

Reference

RoutingTables Class
TraverseDependencyChain Overload
GSF.TimeSeries.Adapters Namespace


RoutingTables Properties

Grid Solutions Framework RoutingTables Properties

The RoutingTables type exposes the following members.

Properties
 | Name | Description
Public property | ActionAdapters | Gets or sets the active ActionAdapterCollection.
Public property | InputAdapters | Gets or sets the active InputAdapterCollection.
Public property | OutputAdapters | Gets or sets the active OutputAdapterCollection.
Top
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.ActionAdapters Property

Grid Solutions Framework RoutingTablesActionAdapters Property
Gets or sets the active ActionAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ActionAdapterCollection ActionAdapters { get; set; }
Public Property ActionAdapters As ActionAdapterCollection
    Get
    Set
member ActionAdapters : ActionAdapterCollection with get, set

function get_ActionAdapters();
function set_ActionAdapters(value);
public:
property ActionAdapterCollection^ ActionAdapters {
    ActionAdapterCollection^ get ();
    void set (ActionAdapterCollection^ value);
}

Property Value

Type: ActionAdapterCollection
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.InputAdapters Property

Grid Solutions Framework RoutingTablesInputAdapters Property
Gets or sets the active InputAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public InputAdapterCollection InputAdapters { get; set; }
Public Property InputAdapters As InputAdapterCollection
    Get
    Set
member InputAdapters : InputAdapterCollection with get, set

function get_InputAdapters();
function set_InputAdapters(value);
public:
property InputAdapterCollection^ InputAdapters {
    InputAdapterCollection^ get ();
    void set (InputAdapterCollection^ value);
}

Property Value

Type: InputAdapterCollection
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.OutputAdapters Property

Grid Solutions Framework RoutingTablesOutputAdapters Property
Gets or sets the active OutputAdapterCollection.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OutputAdapterCollection OutputAdapters { get; set; }
Public Property OutputAdapters As OutputAdapterCollection
    Get
    Set
member OutputAdapters : OutputAdapterCollection with get, set

function get_OutputAdapters();
function set_OutputAdapters(value);
public:
property OutputAdapterCollection^ OutputAdapters {
    OutputAdapterCollection^ get ();
    void set (OutputAdapterCollection^ value);
}

Property Value

Type: OutputAdapterCollection
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables Events

Grid Solutions Framework RoutingTables Events

The RoutingTables type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Event is raised when there is an exception encountered while processing.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.ProcessException Event

Grid Solutions Framework RoutingTablesProcessException Event
Event is raised when there is an exception encountered while processing.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the exception that was thrown.
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


RoutingTables.StatusMessage Event

Grid Solutions Framework RoutingTablesStatusMessage Event
Provides status messages to consumer.

Namespace: GSF.TimeSeries.Adapters
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
member StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
 event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is new status message.
See Also

Reference

RoutingTables Class
GSF.TimeSeries.Adapters Namespace


GSF.TimeSeries.Configuration Namespace

Grid Solutions Framework GSF.TimeSeries.Configuration Namespace

[Missing <summary> documentation for "N:GSF.TimeSeries.Configuration"]

Classes
 | Class | Description
Public class | BinaryFileConfigurationLoader | Represents a configuration loader that gets its configuration from a binary file.
Public class | DatabaseConfigurationLoader | Represents a configuration loader that gets its configuration from a database connection.
Public class | WebServiceConfigurationLoader | Represents a configuration loader that queries a web service for its configuration.
Public class | XMLConfigurationLoader | Represents a configuration loader that gets its configuration from an XML file.
Interfaces
 | Interface | Description
Public interface | IConfigurationLoader | Represents the interface by which the time-series engine's system configuration is loaded from a configuration source.
Delegates
 | Delegate | Description
Public delegate | DataOperationFunction | Defines a method signature for a bootstrap data source operation.


BinaryFileConfigurationLoader Class

Grid Solutions Framework BinaryFileConfigurationLoader Class
Represents a configuration loader that gets its configuration from a binary file.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.ConfigurationBinaryFileConfigurationLoader

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class BinaryFileConfigurationLoader : IConfigurationLoader
Public Class BinaryFileConfigurationLoader
    Implements IConfigurationLoader
type BinaryFileConfigurationLoader =
    class
        interface IConfigurationLoader
    end
GSF.TimeSeries.Configuration.BinaryFileConfigurationLoader = function();

Type.createClass(
    'GSF.TimeSeries.Configuration.BinaryFileConfigurationLoader',
    null,
    GSF.TimeSeries.Configuration.IConfigurationLoader);
public ref class BinaryFileConfigurationLoader : IConfigurationLoader

The BinaryFileConfigurationLoader type exposes the following members.

Constructors
 | Name | Description
Public method | BinaryFileConfigurationLoader | Initializes a new instance of the BinaryFileConfigurationLoader class
Top
Methods
 | Name | Description
Public method | Augment | Not supported.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | FilePath | Gets or sets the path to the binary file.
Top
Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader Constructor

Grid Solutions Framework BinaryFileConfigurationLoader Constructor
Initializes a new instance of the BinaryFileConfigurationLoader class

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public BinaryFileConfigurationLoader()
Public Sub New
new : unit -> BinaryFileConfigurationLoader
GSF.TimeSeries.Configuration.BinaryFileConfigurationLoader = function();
public:
BinaryFileConfigurationLoader()
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader Methods

Grid Solutions Framework BinaryFileConfigurationLoader Methods

The BinaryFileConfigurationLoader type exposes the following members.

Methods
 | Name | Description
Public method | Augment | Not supported.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader.Augment Method

Grid Solutions Framework BinaryFileConfigurationLoaderAugment Method
Not supported.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Augment(
    DataSet configuration
)
Public Sub Augment (
    configuration As DataSet
)
abstract Augment :
        configuration : DataSet -> unit
override Augment :
        configuration : DataSet -> unit
function Augment(configuration);
public:
virtual void Augment(
    DataSet^ configuration
) sealed

Parameters

configuration
Type: System.DataDataSet

[Missing <param name="configuration"/> documentation for "M:GSF.TimeSeries.Configuration.BinaryFileConfigurationLoader.Augment(System.Data.DataSet)"]

Implements

IConfigurationLoaderAugment(DataSet)
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader.Load Method

Grid Solutions Framework BinaryFileConfigurationLoaderLoad Method
Loads the entire configuration data set from scratch.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet Load()
Public Function Load As DataSet
abstract Load : unit -> DataSet
override Load : unit -> DataSet
function Load();
public:
virtual DataSet^ Load() sealed

Return Value

Type: DataSet
The configuration data set.

Implements

IConfigurationLoaderLoad
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader Properties

Grid Solutions Framework BinaryFileConfigurationLoader Properties

The BinaryFileConfigurationLoader type exposes the following members.

Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | FilePath | Gets or sets the path to the binary file.
Top
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader.CanAugment Property

Grid Solutions Framework BinaryFileConfigurationLoaderCanAugment Property
Gets the flag that indicates whether augmentation is supported by this configuration loader.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CanAugment { get; }
Public ReadOnly Property CanAugment As Boolean
    Get
abstract CanAugment : bool with get
override CanAugment : bool with get
function get_CanAugment();

public:
virtual property bool CanAugment {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IConfigurationLoaderCanAugment
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader.FilePath Property

Grid Solutions Framework BinaryFileConfigurationLoaderFilePath Property
Gets or sets the path to the binary file.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
member FilePath : string with get, set

function get_FilePath();
function set_FilePath(value);
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader Events

Grid Solutions Framework BinaryFileConfigurationLoader Events

The BinaryFileConfigurationLoader type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader.ProcessException Event

Grid Solutions Framework BinaryFileConfigurationLoaderProcessException Event
Occurs when the configuration loader encounters a non-catastrophic exception.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ProcessException(value);
function remove_ProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IConfigurationLoaderProcessException
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


BinaryFileConfigurationLoader.StatusMessage Event

Grid Solutions Framework BinaryFileConfigurationLoaderStatusMessage Event
Occurs when the configuration loader has a message to provide about its current status.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IConfigurationLoaderStatusMessage
See Also

Reference

BinaryFileConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader Class

Grid Solutions Framework DatabaseConfigurationLoader Class
Represents a configuration loader that gets its configuration from a database connection.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.ConfigurationDatabaseConfigurationLoader

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DatabaseConfigurationLoader : IConfigurationLoader,
    IDisposable
Public Class DatabaseConfigurationLoader
    Implements IConfigurationLoader, IDisposable
type DatabaseConfigurationLoader =
    class
        interface IConfigurationLoader
        interface IDisposable
    end
GSF.TimeSeries.Configuration.DatabaseConfigurationLoader = function();

Type.createClass(
    'GSF.TimeSeries.Configuration.DatabaseConfigurationLoader',
    null,
    GSF.TimeSeries.Configuration.IConfigurationLoader,
    IDisposable);
public ref class DatabaseConfigurationLoader : IConfigurationLoader,
    IDisposable

The DatabaseConfigurationLoader type exposes the following members.

Constructors
 | Name | Description
Public method | DatabaseConfigurationLoader | Initializes a new instance of the DatabaseConfigurationLoader class
Top
Methods
 | Name | Description
Public method | Augment | Augments the given configuration data set with the changes tracked since the version of the given configuration data set.
Public method | Close | Closes the database connection.
Public method | Dispose | Releases all the resources used by the DatabaseConfigurationLoader object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the database connection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | ConnectionString | Gets or sets the connection string which defines how to connect to the database.
Public property | DataProviderString | Gets or sets the data provider string, which determines the .NET types to use when opening connections to the database.
Public property | NodeIDQueryString | Gets or sets the string to use in queries when filtering results by node ID.
Top
Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader Constructor

Grid Solutions Framework DatabaseConfigurationLoader Constructor
Initializes a new instance of the DatabaseConfigurationLoader class

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DatabaseConfigurationLoader()
Public Sub New
new : unit -> DatabaseConfigurationLoader
GSF.TimeSeries.Configuration.DatabaseConfigurationLoader = function();
public:
DatabaseConfigurationLoader()
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader Methods

Grid Solutions Framework DatabaseConfigurationLoader Methods

The DatabaseConfigurationLoader type exposes the following members.

Methods
 | Name | Description
Public method | Augment | Augments the given configuration data set with the changes tracked since the version of the given configuration data set.
Public method | Close | Closes the database connection.
Public method | Dispose | Releases all the resources used by the DatabaseConfigurationLoader object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Open | Opens the database connection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.Augment Method

Grid Solutions Framework DatabaseConfigurationLoaderAugment Method
Augments the given configuration data set with the changes tracked since the version of the given configuration data set.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Augment(
    DataSet configuration
)
Public Sub Augment (
    configuration As DataSet
)
abstract Augment :
        configuration : DataSet -> unit
override Augment :
        configuration : DataSet -> unit
function Augment(configuration);
public:
virtual void Augment(
    DataSet^ configuration
) sealed

Parameters

configuration
Type: System.DataDataSet
The configuration data set to be augmented.

Implements

IConfigurationLoaderAugment(DataSet)
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.Close Method

Grid Solutions Framework DatabaseConfigurationLoaderClose Method
Closes the database connection.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Close()
Public Sub Close
member Close : unit -> unit

function Close();
public:
void Close()
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.Dispose Method

Grid Solutions Framework DatabaseConfigurationLoaderDispose Method
Releases all the resources used by the DatabaseConfigurationLoader object.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.Load Method

Grid Solutions Framework DatabaseConfigurationLoaderLoad Method
Loads the entire configuration data set from scratch.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet Load()
Public Function Load As DataSet
abstract Load : unit -> DataSet
override Load : unit -> DataSet
function Load();
public:
virtual DataSet^ Load() sealed

Return Value

Type: DataSet
The configuration data set.

Implements

IConfigurationLoaderLoad
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.Open Method

Grid Solutions Framework DatabaseConfigurationLoaderOpen Method
Opens the database connection.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Open()
Public Sub Open
member Open : unit -> unit

function Open();
public:
void Open()
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader Properties

Grid Solutions Framework DatabaseConfigurationLoader Properties

The DatabaseConfigurationLoader type exposes the following members.

Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | ConnectionString | Gets or sets the connection string which defines how to connect to the database.
Public property | DataProviderString | Gets or sets the data provider string, which determines the .NET types to use when opening connections to the database.
Public property | NodeIDQueryString | Gets or sets the string to use in queries when filtering results by node ID.
Top
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.CanAugment Property

Grid Solutions Framework DatabaseConfigurationLoaderCanAugment Property
Gets the flag that indicates whether augmentation is supported by this configuration loader.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CanAugment { get; }
Public ReadOnly Property CanAugment As Boolean
    Get
abstract CanAugment : bool with get
override CanAugment : bool with get
function get_CanAugment();

public:
virtual property bool CanAugment {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IConfigurationLoaderCanAugment
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.ConnectionString Property

Grid Solutions Framework DatabaseConfigurationLoaderConnectionString Property
Gets or sets the connection string which defines how to connect to the database.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
member ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.DataProviderString Property

Grid Solutions Framework DatabaseConfigurationLoaderDataProviderString Property
Gets or sets the data provider string, which determines the .NET types to use when opening connections to the database.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string DataProviderString { get; set; }
Public Property DataProviderString As String
    Get
    Set
member DataProviderString : string with get, set

function get_DataProviderString();
function set_DataProviderString(value);
public:
property String^ DataProviderString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.NodeIDQueryString Property

Grid Solutions Framework DatabaseConfigurationLoaderNodeIDQueryString Property
Gets or sets the string to use in queries when filtering results by node ID.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string NodeIDQueryString { get; set; }
Public Property NodeIDQueryString As String
    Get
    Set
member NodeIDQueryString : string with get, set

function get_NodeIDQueryString();
function set_NodeIDQueryString(value);
public:
property String^ NodeIDQueryString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader Events

Grid Solutions Framework DatabaseConfigurationLoader Events

The DatabaseConfigurationLoader type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.ProcessException Event

Grid Solutions Framework DatabaseConfigurationLoaderProcessException Event
Occurs when the configuration loader encounters a non-catastrophic exception.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ProcessException(value);
function remove_ProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IConfigurationLoaderProcessException
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DatabaseConfigurationLoader.StatusMessage Event

Grid Solutions Framework DatabaseConfigurationLoaderStatusMessage Event
Occurs when the configuration loader has a message to provide about its current status.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IConfigurationLoaderStatusMessage
See Also

Reference

DatabaseConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


DataOperationFunction Delegate

Grid Solutions Framework DataOperationFunction Delegate
Defines a method signature for a bootstrap data source operation.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate void DataOperationFunction(
    AdoDataConnection database,
    string nodeIDQueryString,
    ulong trackingVersion,
    string arguments,
    Action<string> statusMessage,
    Action<Exception> processException
)
Public Delegate Sub DataOperationFunction (
    database As AdoDataConnection,
    nodeIDQueryString As String,
    trackingVersion As ULong,
    arguments As String,
    statusMessage As Action(Of String),
    processException As Action(Of Exception)
)
type DataOperationFunction =
    delegate of
        database : AdoDataConnection *
        nodeIDQueryString : string *
        trackingVersion : uint64 *
        arguments : string *
        statusMessage : Action<string> *
        processException : Action<Exception> -> unit
function(database, nodeIDQueryString, trackingVersion, arguments, statusMessage, processException);
public delegate void DataOperationFunction(
    AdoDataConnection^ database,
    String^ nodeIDQueryString,
    unsigned long long trackingVersion,
    String^ arguments,
    Action<String^>^ statusMessage,
    Action<Exception^>^ processException
)

Parameters

database
Type: GSF.DataAdoDataConnection
Connection to database.
nodeIDQueryString
Type: SystemString
Formatted node ID Guid query string.
trackingVersion
Type: SystemUInt64
Latest version of the configuration to which data operations were previously applied.
arguments
Type: SystemString
Optional data operation arguments.
statusMessage
Type: SystemAction String
Reference to host status message function.
processException
Type: SystemAction Exception
Reference to host process exception function.
See Also

Reference

GSF.TimeSeries.Configuration Namespace


IConfigurationLoader Interface

Grid Solutions Framework IConfigurationLoader Interface
Represents the interface by which the time-series engine's system configuration is loaded from a configuration source.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IConfigurationLoader
Public Interface IConfigurationLoader
type IConfigurationLoader =  interface end
GSF.TimeSeries.Configuration.IConfigurationLoader = function();
GSF.TimeSeries.Configuration.IConfigurationLoader.createInterface('GSF.TimeSeries.Configuration.IConfigurationLoader');
public interface class IConfigurationLoader

The IConfigurationLoader type exposes the following members.

Methods
 | Name | Description
Public method | Augment | Augments the given configuration data set with the changes tracked since the version of the given configuration data set.
Public method | Load | Loads the entire configuration data set from scratch.
Top
Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Top
Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

GSF.TimeSeries.Configuration Namespace


IConfigurationLoader Methods

Grid Solutions Framework IConfigurationLoader Methods

The IConfigurationLoader type exposes the following members.

Methods
 | Name | Description
Public method | Augment | Augments the given configuration data set with the changes tracked since the version of the given configuration data set.
Public method | Load | Loads the entire configuration data set from scratch.
Top
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


IConfigurationLoader.Augment Method

Grid Solutions Framework IConfigurationLoaderAugment Method
Augments the given configuration data set with the changes tracked since the version of the given configuration data set.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void Augment(
    DataSet configuration
)
Sub Augment (
    configuration As DataSet
)
abstract Augment :
        configuration : DataSet -> unit

function Augment(configuration);
void Augment(
    DataSet^ configuration
)

Parameters

configuration
Type: System.DataDataSet
The configuration data set to be augmented.
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


IConfigurationLoader.Load Method

Grid Solutions Framework IConfigurationLoaderLoad Method
Loads the entire configuration data set from scratch.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
DataSet Load()
Function Load As DataSet
abstract Load : unit -> DataSet

function Load();
DataSet^ Load()

Return Value

Type: DataSet
The configuration data set.
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


IConfigurationLoader Properties

Grid Solutions Framework IConfigurationLoader Properties

The IConfigurationLoader type exposes the following members.

Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Top
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


IConfigurationLoader.CanAugment Property

Grid Solutions Framework IConfigurationLoaderCanAugment Property
Gets the flag that indicates whether augmentation is supported by this configuration loader.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool CanAugment { get; }
ReadOnly Property CanAugment As Boolean
    Get
abstract CanAugment : bool with get

function get_CanAugment();

property bool CanAugment {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


IConfigurationLoader Events

Grid Solutions Framework IConfigurationLoader Events

The IConfigurationLoader type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


IConfigurationLoader.ProcessException Event

Grid Solutions Framework IConfigurationLoaderProcessException Event
Occurs when the configuration loader encounters a non-catastrophic exception.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<Exception>> ProcessException
Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


IConfigurationLoader.StatusMessage Event

Grid Solutions Framework IConfigurationLoaderStatusMessage Event
Occurs when the configuration loader has a message to provide about its current status.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<string>> StatusMessage
Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_StatusMessage(value);
function remove_StatusMessage(value);
 event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
See Also

Reference

IConfigurationLoader Interface
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader Class

Grid Solutions Framework WebServiceConfigurationLoader Class
Represents a configuration loader that queries a web service for its configuration.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.ConfigurationWebServiceConfigurationLoader

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class WebServiceConfigurationLoader : IConfigurationLoader
Public Class WebServiceConfigurationLoader
    Implements IConfigurationLoader
type WebServiceConfigurationLoader =
    class
        interface IConfigurationLoader
    end
GSF.TimeSeries.Configuration.WebServiceConfigurationLoader = function();

Type.createClass(
    'GSF.TimeSeries.Configuration.WebServiceConfigurationLoader',
    null,
    GSF.TimeSeries.Configuration.IConfigurationLoader);
public ref class WebServiceConfigurationLoader : IConfigurationLoader

The WebServiceConfigurationLoader type exposes the following members.

Constructors
 | Name | Description
Public method | WebServiceConfigurationLoader | Initializes a new instance of the WebServiceConfigurationLoader class
Top
Methods
 | Name | Description
Public method | Augment | Not supported.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | URI | Gets or sets the URI for the web service.
Top
Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader Constructor

Grid Solutions Framework WebServiceConfigurationLoader Constructor
Initializes a new instance of the WebServiceConfigurationLoader class

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public WebServiceConfigurationLoader()
Public Sub New
new : unit -> WebServiceConfigurationLoader
GSF.TimeSeries.Configuration.WebServiceConfigurationLoader = function();
public:
WebServiceConfigurationLoader()
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader Methods

Grid Solutions Framework WebServiceConfigurationLoader Methods

The WebServiceConfigurationLoader type exposes the following members.

Methods
 | Name | Description
Public method | Augment | Not supported.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader.Augment Method

Grid Solutions Framework WebServiceConfigurationLoaderAugment Method
Not supported.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Augment(
    DataSet configuration
)
Public Sub Augment (
    configuration As DataSet
)
abstract Augment :
        configuration : DataSet -> unit
override Augment :
        configuration : DataSet -> unit
function Augment(configuration);
public:
virtual void Augment(
    DataSet^ configuration
) sealed

Parameters

configuration
Type: System.DataDataSet

[Missing <param name="configuration"/> documentation for "M:GSF.TimeSeries.Configuration.WebServiceConfigurationLoader.Augment(System.Data.DataSet)"]

Implements

IConfigurationLoaderAugment(DataSet)
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader.Load Method

Grid Solutions Framework WebServiceConfigurationLoaderLoad Method
Loads the entire configuration data set from scratch.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet Load()
Public Function Load As DataSet
abstract Load : unit -> DataSet
override Load : unit -> DataSet
function Load();
public:
virtual DataSet^ Load() sealed

Return Value

Type: DataSet
The configuration data set.

Implements

IConfigurationLoaderLoad
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader Properties

Grid Solutions Framework WebServiceConfigurationLoader Properties

The WebServiceConfigurationLoader type exposes the following members.

Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | URI | Gets or sets the URI for the web service.
Top
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader.CanAugment Property

Grid Solutions Framework WebServiceConfigurationLoaderCanAugment Property
Gets the flag that indicates whether augmentation is supported by this configuration loader.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CanAugment { get; }
Public ReadOnly Property CanAugment As Boolean
    Get
abstract CanAugment : bool with get
override CanAugment : bool with get
function get_CanAugment();

public:
virtual property bool CanAugment {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IConfigurationLoaderCanAugment
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader.URI Property

Grid Solutions Framework WebServiceConfigurationLoaderURI Property
Gets or sets the URI for the web service.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string URI { get; set; }
Public Property URI As String
    Get
    Set
member URI : string with get, set

function get_URI();
function set_URI(value);
public:
property String^ URI {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader Events

Grid Solutions Framework WebServiceConfigurationLoader Events

The WebServiceConfigurationLoader type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader.ProcessException Event

Grid Solutions Framework WebServiceConfigurationLoaderProcessException Event
Occurs when the configuration loader encounters a non-catastrophic exception.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ProcessException(value);
function remove_ProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IConfigurationLoaderProcessException
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


WebServiceConfigurationLoader.StatusMessage Event

Grid Solutions Framework WebServiceConfigurationLoaderStatusMessage Event
Occurs when the configuration loader has a message to provide about its current status.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IConfigurationLoaderStatusMessage
See Also

Reference

WebServiceConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader Class

Grid Solutions Framework XMLConfigurationLoader Class
Represents a configuration loader that gets its configuration from an XML file.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.ConfigurationXMLConfigurationLoader

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class XMLConfigurationLoader : IConfigurationLoader
Public Class XMLConfigurationLoader
    Implements IConfigurationLoader
type XMLConfigurationLoader =
    class
        interface IConfigurationLoader
    end
GSF.TimeSeries.Configuration.XMLConfigurationLoader = function();

Type.createClass(
    'GSF.TimeSeries.Configuration.XMLConfigurationLoader',
    null,
    GSF.TimeSeries.Configuration.IConfigurationLoader);
public ref class XMLConfigurationLoader : IConfigurationLoader

The XMLConfigurationLoader type exposes the following members.

Constructors
 | Name | Description
Public method | XMLConfigurationLoader | Initializes a new instance of the XMLConfigurationLoader class
Top
Methods
 | Name | Description
Public method | Augment | Not supported.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | FilePath | Gets or sets the path to the XML file.
Top
Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader Constructor

Grid Solutions Framework XMLConfigurationLoader Constructor
Initializes a new instance of the XMLConfigurationLoader class

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public XMLConfigurationLoader()
Public Sub New
new : unit -> XMLConfigurationLoader
GSF.TimeSeries.Configuration.XMLConfigurationLoader = function();
public:
XMLConfigurationLoader()
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader Methods

Grid Solutions Framework XMLConfigurationLoader Methods

The XMLConfigurationLoader type exposes the following members.

Methods
 | Name | Description
Public method | Augment | Not supported.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Load | Loads the entire configuration data set from scratch.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader.Augment Method

Grid Solutions Framework XMLConfigurationLoaderAugment Method
Not supported.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Augment(
    DataSet configuration
)
Public Sub Augment (
    configuration As DataSet
)
abstract Augment :
        configuration : DataSet -> unit
override Augment :
        configuration : DataSet -> unit
function Augment(configuration);
public:
virtual void Augment(
    DataSet^ configuration
) sealed

Parameters

configuration
Type: System.DataDataSet

[Missing <param name="configuration"/> documentation for "M:GSF.TimeSeries.Configuration.XMLConfigurationLoader.Augment(System.Data.DataSet)"]

Implements

IConfigurationLoaderAugment(DataSet)
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader.Load Method

Grid Solutions Framework XMLConfigurationLoaderLoad Method
Loads the entire configuration data set from scratch.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet Load()
Public Function Load As DataSet
abstract Load : unit -> DataSet
override Load : unit -> DataSet
function Load();
public:
virtual DataSet^ Load() sealed

Return Value

Type: DataSet
The configuration data set.

Implements

IConfigurationLoaderLoad
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader Properties

Grid Solutions Framework XMLConfigurationLoader Properties

The XMLConfigurationLoader type exposes the following members.

Properties
 | Name | Description
Public property | CanAugment | Gets the flag that indicates whether augmentation is supported by this configuration loader.
Public property | FilePath | Gets or sets the path to the XML file.
Top
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader.CanAugment Property

Grid Solutions Framework XMLConfigurationLoaderCanAugment Property
Gets the flag that indicates whether augmentation is supported by this configuration loader.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CanAugment { get; }
Public ReadOnly Property CanAugment As Boolean
    Get
abstract CanAugment : bool with get
override CanAugment : bool with get
function get_CanAugment();

public:
virtual property bool CanAugment {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

IConfigurationLoaderCanAugment
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader.FilePath Property

Grid Solutions Framework XMLConfigurationLoaderFilePath Property
Gets or sets the path to the XML file.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FilePath { get; set; }
Public Property FilePath As String
    Get
    Set
member FilePath : string with get, set

function get_FilePath();
function set_FilePath(value);
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader Events

Grid Solutions Framework XMLConfigurationLoader Events

The XMLConfigurationLoader type exposes the following members.

Events
 | Name | Description
Public event | ProcessException | Occurs when the configuration loader encounters a non-catastrophic exception.
Public event | StatusMessage | Occurs when the configuration loader has a message to provide about its current status.
Top
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader.ProcessException Event

Grid Solutions Framework XMLConfigurationLoaderProcessException Event
Occurs when the configuration loader encounters a non-catastrophic exception.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
abstract ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
override ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>
function add_ProcessException(value);
function remove_ProcessException(value);
public:
virtual  event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception

Implements

IConfigurationLoaderProcessException
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


XMLConfigurationLoader.StatusMessage Event

Grid Solutions Framework XMLConfigurationLoaderStatusMessage Event
Occurs when the configuration loader has a message to provide about its current status.

Namespace: GSF.TimeSeries.Configuration
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
abstract StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
override StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>
function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
virtual  event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String

Implements

IConfigurationLoaderStatusMessage
See Also

Reference

XMLConfigurationLoader Class
GSF.TimeSeries.Configuration Namespace


GSF.TimeSeries.Reports Namespace

Grid Solutions Framework GSF.TimeSeries.Reports Namespace

[Missing <summary> documentation for "N:GSF.TimeSeries.Reports"]

Classes
 | Class | Description
Public class | CompletenessReportingProcess | Represents the process that generates completeness reports for the time-series service.
Public class | CorrectnessReportingProcess | Represents the process that generates correctness reports for the time-series service.
Public class | ReportingProcessBase | Represents the base functionality for reporting processes.
Public class | ReportingProcessCollection | Represents a collection of IReportingProcess items.
Interfaces
 | Interface | Description
Public interface | IReportingProcess | Defines an interface for reporting processes.


CompletenessReportingProcess Class

Grid Solutions Framework CompletenessReportingProcess Class
Represents the process that generates completeness reports for the time-series service.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.ReportsReportingProcessBase
GSF.TimeSeries.ReportsCompletenessReportingProcess

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CompletenessReportingProcess : ReportingProcessBase
Public Class CompletenessReportingProcess
    Inherits ReportingProcessBase
type CompletenessReportingProcess =
    class
        inherit ReportingProcessBase
    end
GSF.TimeSeries.Reports.CompletenessReportingProcess = function();

Type.createClass(
    'GSF.TimeSeries.Reports.CompletenessReportingProcess',
    GSF.TimeSeries.Reports.ReportingProcessBase);
public ref class CompletenessReportingProcess : public ReportingProcessBase

The CompletenessReportingProcess type exposes the following members.

Constructors
 | Name | Description
Public method | CompletenessReportingProcess | Creates a new instance of the CompletenessReportingProcess class.
Top
Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime. (Inherited from ReportingProcessBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateReport | Queues up a report to be generated on a separate thread. (Inherited from ReportingProcessBase.)
Public method | GetArguments | Gets the command line arguments for the reporting process. (Overrides ReportingProcessBaseGetArguments.)
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date. (Inherited from ReportingProcessBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated. (Inherited from ReportingProcessBase.)
Public method | GetReportsList | Returns the list of reports that are available from the report location. (Inherited from ReportingProcessBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadSettings | Loads saved settings from the config file. (Overrides ReportingProcessBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveSettings | Saves settings to the config file. (Overrides ReportingProcessBaseSaveSettings.)
Public method | SetArguments | Applies any received command line arguments for the reporting process. (Overrides ReportingProcessBaseSetArguments(Arguments).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived. (Inherited from ReportingProcessBase.)
Public property | Company | Gets or sets the name of the company to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports. (Inherited from ReportingProcessBase.)
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days. (Inherited from ReportingProcessBase.)
Public property | Level3Alias | Gets or sets the alias for the level 3 category.
Public property | Level3Threshold | Gets or sets the minimum percentage of measurements received from devices in level 3.
Public property | Level4Alias | Gets or sets the alias for the level 4 category.
Public property | Level4Threshold | Gets or sets the minimum percentage of measurements received from devices in level 4.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from ReportingProcessBase.)
Public property | ReportLocation | Gets or sets the directory to which reports will be written. (Inherited from ReportingProcessBase.)
Public property | ReportType | Gets report type, i.e., basically the report name associated with this reporting process. (Inherited from ReportingProcessBase.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from ReportingProcessBase.)
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | Status | Gets the current status details about reporting process. (Overrides ReportingProcessBaseStatus.)
Public property | Title | Gets or sets the title to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Top
See Also

Reference

GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess Constructor

Grid Solutions Framework CompletenessReportingProcess Constructor
Creates a new instance of the CompletenessReportingProcess class.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompletenessReportingProcess()
Public Sub New
new : unit -> CompletenessReportingProcess
GSF.TimeSeries.Reports.CompletenessReportingProcess = function();
public:
CompletenessReportingProcess()
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess Methods

Grid Solutions Framework CompletenessReportingProcess Methods

The CompletenessReportingProcess type exposes the following members.

Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime. (Inherited from ReportingProcessBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateReport | Queues up a report to be generated on a separate thread. (Inherited from ReportingProcessBase.)
Public method | GetArguments | Gets the command line arguments for the reporting process. (Overrides ReportingProcessBaseGetArguments.)
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date. (Inherited from ReportingProcessBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated. (Inherited from ReportingProcessBase.)
Public method | GetReportsList | Returns the list of reports that are available from the report location. (Inherited from ReportingProcessBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadSettings | Loads saved settings from the config file. (Overrides ReportingProcessBaseLoadSettings.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveSettings | Saves settings to the config file. (Overrides ReportingProcessBaseSaveSettings.)
Public method | SetArguments | Applies any received command line arguments for the reporting process. (Overrides ReportingProcessBaseSetArguments(Arguments).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.GetArguments Method

Grid Solutions Framework CompletenessReportingProcessGetArguments Method
Overload List
 | Name | Description
Public method | GetArguments | Gets the command line arguments for the reporting process. (Overrides ReportingProcessBaseGetArguments.)
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date. (Inherited from ReportingProcessBase.)
Top
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.GetArguments Method

Grid Solutions Framework CompletenessReportingProcessGetArguments Method
Gets the command line arguments for the reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetArguments()
Public Overrides Function GetArguments As String
abstract GetArguments : unit -> string
override GetArguments : unit -> string
function GetArguments();
public:
virtual String^ GetArguments() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.TimeSeries.Reports.CompletenessReportingProcess.GetArguments"]

Implements

IReportingProcessGetArguments
See Also

Reference

CompletenessReportingProcess Class
GetArguments Overload
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.LoadSettings Method

Grid Solutions Framework CompletenessReportingProcessLoadSettings Method
Loads saved settings from the config file.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.SaveSettings Method

Grid Solutions Framework CompletenessReportingProcessSaveSettings Method
Saves settings to the config file.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.SetArguments Method

Grid Solutions Framework CompletenessReportingProcessSetArguments Method
Applies any received command line arguments for the reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SetArguments(
    Arguments args
)
Public Overrides Sub SetArguments (
    args As Arguments
)
abstract SetArguments :
        args : Arguments -> unit
override SetArguments :
        args : Arguments -> unit
function SetArguments(args);
public:
virtual void SetArguments(
    Arguments^ args
) override

Parameters

args
Type: GSF.ConsoleArguments
Received command line arguments.

Implements

IReportingProcessSetArguments(Arguments)
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess Properties

Grid Solutions Framework CompletenessReportingProcess Properties

The CompletenessReportingProcess type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived. (Inherited from ReportingProcessBase.)
Public property | Company | Gets or sets the name of the company to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports. (Inherited from ReportingProcessBase.)
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days. (Inherited from ReportingProcessBase.)
Public property | Level3Alias | Gets or sets the alias for the level 3 category.
Public property | Level3Threshold | Gets or sets the minimum percentage of measurements received from devices in level 3.
Public property | Level4Alias | Gets or sets the alias for the level 4 category.
Public property | Level4Threshold | Gets or sets the minimum percentage of measurements received from devices in level 4.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from ReportingProcessBase.)
Public property | ReportLocation | Gets or sets the directory to which reports will be written. (Inherited from ReportingProcessBase.)
Public property | ReportType | Gets report type, i.e., basically the report name associated with this reporting process. (Inherited from ReportingProcessBase.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from ReportingProcessBase.)
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | Status | Gets the current status details about reporting process. (Overrides ReportingProcessBaseStatus.)
Public property | Title | Gets or sets the title to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Top
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.Level3Alias Property

Grid Solutions Framework CompletenessReportingProcessLevel3Alias Property
Gets or sets the alias for the level 3 category.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Level3Alias { get; set; }
Public Property Level3Alias As String
    Get
    Set
member Level3Alias : string with get, set

function get_Level3Alias();
function set_Level3Alias(value);
public:
property String^ Level3Alias {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.Level3Threshold Property

Grid Solutions Framework CompletenessReportingProcessLevel3Threshold Property
Gets or sets the minimum percentage of measurements received from devices in level 3.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Level3Threshold { get; set; }
Public Property Level3Threshold As Double
    Get
    Set
member Level3Threshold : float with get, set

function get_Level3Threshold();
function set_Level3Threshold(value);
public:
property double Level3Threshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.Level4Alias Property

Grid Solutions Framework CompletenessReportingProcessLevel4Alias Property
Gets or sets the alias for the level 4 category.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Level4Alias { get; set; }
Public Property Level4Alias As String
    Get
    Set
member Level4Alias : string with get, set

function get_Level4Alias();
function set_Level4Alias(value);
public:
property String^ Level4Alias {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.Level4Threshold Property

Grid Solutions Framework CompletenessReportingProcessLevel4Threshold Property
Gets or sets the minimum percentage of measurements received from devices in level 4.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double Level4Threshold { get; set; }
Public Property Level4Threshold As Double
    Get
    Set
member Level4Threshold : float with get, set

function get_Level4Threshold();
function set_Level4Threshold(value);
public:
property double Level4Threshold {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CompletenessReportingProcess.Status Property

Grid Solutions Framework CompletenessReportingProcessStatus Property
Gets the current status details about reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

CompletenessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CorrectnessReportingProcess Class

Grid Solutions Framework CorrectnessReportingProcess Class
Represents the process that generates correctness reports for the time-series service.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.ReportsReportingProcessBase
GSF.TimeSeries.ReportsCorrectnessReportingProcess

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CorrectnessReportingProcess : ReportingProcessBase
Public Class CorrectnessReportingProcess
    Inherits ReportingProcessBase
type CorrectnessReportingProcess =
    class
        inherit ReportingProcessBase
    end
GSF.TimeSeries.Reports.CorrectnessReportingProcess = function();

Type.createClass(
    'GSF.TimeSeries.Reports.CorrectnessReportingProcess',
    GSF.TimeSeries.Reports.ReportingProcessBase);
public ref class CorrectnessReportingProcess : public ReportingProcessBase

The CorrectnessReportingProcess type exposes the following members.

Constructors
 | Name | Description
Public method | CorrectnessReportingProcess | Creates a new instance of the CorrectnessReportingProcess class.
Top
Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime. (Inherited from ReportingProcessBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateReport | Queues up a report to be generated on a separate thread. (Inherited from ReportingProcessBase.)
Public method | GetArguments | Gets the command line arguments for the reporting process. (Inherited from ReportingProcessBase.)
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date. (Inherited from ReportingProcessBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated. (Inherited from ReportingProcessBase.)
Public method | GetReportsList | Returns the list of reports that are available from the report location. (Inherited from ReportingProcessBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from ReportingProcessBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from ReportingProcessBase.)
Public method | SetArguments | Applies any received command line arguments for the reporting process. (Inherited from ReportingProcessBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived. (Inherited from ReportingProcessBase.)
Public property | Company | Gets or sets the name of the company to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports. (Inherited from ReportingProcessBase.)
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days. (Inherited from ReportingProcessBase.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from ReportingProcessBase.)
Public property | ReportLocation | Gets or sets the directory to which reports will be written. (Inherited from ReportingProcessBase.)
Public property | ReportType | Gets report type, i.e., basically the report name associated with this reporting process. (Inherited from ReportingProcessBase.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from ReportingProcessBase.)
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | Status | Gets the current status details about reporting process. (Inherited from ReportingProcessBase.)
Public property | Title | Gets or sets the title to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Top
See Also

Reference

GSF.TimeSeries.Reports Namespace


CorrectnessReportingProcess Constructor

Grid Solutions Framework CorrectnessReportingProcess Constructor
Creates a new instance of the CorrectnessReportingProcess class.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CorrectnessReportingProcess()
Public Sub New
new : unit -> CorrectnessReportingProcess
GSF.TimeSeries.Reports.CorrectnessReportingProcess = function();
public:
CorrectnessReportingProcess()
See Also

Reference

CorrectnessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CorrectnessReportingProcess Methods

Grid Solutions Framework CorrectnessReportingProcess Methods

The CorrectnessReportingProcess type exposes the following members.

Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime. (Inherited from ReportingProcessBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateReport | Queues up a report to be generated on a separate thread. (Inherited from ReportingProcessBase.)
Public method | GetArguments | Gets the command line arguments for the reporting process. (Inherited from ReportingProcessBase.)
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date. (Inherited from ReportingProcessBase.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated. (Inherited from ReportingProcessBase.)
Public method | GetReportsList | Returns the list of reports that are available from the report location. (Inherited from ReportingProcessBase.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from ReportingProcessBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from ReportingProcessBase.)
Public method | SetArguments | Applies any received command line arguments for the reporting process. (Inherited from ReportingProcessBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

CorrectnessReportingProcess Class
GSF.TimeSeries.Reports Namespace


CorrectnessReportingProcess Properties

Grid Solutions Framework CorrectnessReportingProcess Properties

The CorrectnessReportingProcess type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived. (Inherited from ReportingProcessBase.)
Public property | Company | Gets or sets the name of the company to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports. (Inherited from ReportingProcessBase.)
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days. (Inherited from ReportingProcessBase.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from ReportingProcessBase.)
Public property | ReportLocation | Gets or sets the directory to which reports will be written. (Inherited from ReportingProcessBase.)
Public property | ReportType | Gets report type, i.e., basically the report name associated with this reporting process. (Inherited from ReportingProcessBase.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from ReportingProcessBase.)
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Public property | Status | Gets the current status details about reporting process. (Inherited from ReportingProcessBase.)
Public property | Title | Gets or sets the title to be displayed on reports. (Inherited from ReportingProcessBase.)
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports. (Inherited from ReportingProcessBase.)
Top
See Also

Reference

CorrectnessReportingProcess Class
GSF.TimeSeries.Reports Namespace


IReportingProcess Interface

Grid Solutions Framework IReportingProcess Interface
Defines an interface for reporting processes.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IReportingProcess : IProvideStatus,
    IPersistSettings
Public Interface IReportingProcess
    Inherits IProvideStatus, IPersistSettings
type IReportingProcess =
    interface
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.TimeSeries.Reports.IReportingProcess = function();
GSF.TimeSeries.Reports.IReportingProcess.createInterface('GSF.TimeSeries.Reports.IReportingProcess');
public interface class IReportingProcess : IProvideStatus,
    IPersistSettings

The IReportingProcess type exposes the following members.

Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime.
Public method | GenerateReport | Queues up a report to be generated on a separate thread.
Public method | GetArguments | Gets the command line arguments for the reporting process.
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date.
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated.
Public method | GetReportsList | Returns the list of reports that are available from the report location.
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Public method | SetArguments | Applies any received command line arguments for the reporting process.
Top
Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived.
Public property | Company | Gets or sets the name of the company to be displayed on reports.
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports.
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports.
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ReportLocation | Gets or sets the directory to which reports will be written.
Public property | ReportType | Gets report type (i.e., name) for this reporting process.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | Title | Gets or sets the title to be displayed on reports.
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports.
Top
See Also

Reference

GSF.TimeSeries.Reports Namespace


IReportingProcess Methods

Grid Solutions Framework IReportingProcess Methods

The IReportingProcess type exposes the following members.

Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime.
Public method | GenerateReport | Queues up a report to be generated on a separate thread.
Public method | GetArguments | Gets the command line arguments for the reporting process.
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date.
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated.
Public method | GetReportsList | Returns the list of reports that are available from the report location.
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Public method | SetArguments | Applies any received command line arguments for the reporting process.
Top
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.CleanReportLocation Method

Grid Solutions Framework IReportingProcessCleanReportLocation Method
Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void CleanReportLocation()
Sub CleanReportLocation
abstract CleanReportLocation : unit -> unit

function CleanReportLocation();
void CleanReportLocation()
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.GenerateReport Method

Grid Solutions Framework IReportingProcessGenerateReport Method
Queues up a report to be generated on a separate thread.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void GenerateReport(
    DateTime reportDate,
    bool emailReport
)
Sub GenerateReport (
    reportDate As DateTime,
    emailReport As Boolean
)
abstract GenerateReport :
        reportDate : DateTime *
        emailReport : bool -> unit

function GenerateReport(reportDate, emailReport);
void GenerateReport(
    DateTime reportDate,
    bool emailReport
)

Parameters

reportDate
Type: SystemDateTime
The date of the report to be generated.
emailReport
Type: SystemBoolean
Flag that determines if report should be e-mailed, if enabled.
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.GetArguments Method

Grid Solutions Framework IReportingProcessGetArguments Method
Overload List
 | Name | Description
Public method | GetArguments | Gets the command line arguments for the reporting process.
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date.
Top
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.GetArguments Method

Grid Solutions Framework IReportingProcessGetArguments Method
Gets the command line arguments for the reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string GetArguments()
Function GetArguments As String
abstract GetArguments : unit -> string

function GetArguments();
String^ GetArguments()

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.TimeSeries.Reports.IReportingProcess.GetArguments"]

See Also

Reference

IReportingProcess Interface
GetArguments Overload
GSF.TimeSeries.Reports Namespace


IReportingProcess.GetArguments Method (DateTime, Boolean)

Grid Solutions Framework IReportingProcessGetArguments Method (DateTime, Boolean)
Gets the command line arguments for the reporting process for a given report date.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string GetArguments(
    DateTime reportDate,
    bool emailReport
)
Function GetArguments (
    reportDate As DateTime,
    emailReport As Boolean
) As String
abstract GetArguments :
        reportDate : DateTime *
        emailReport : bool -> string

function GetArguments(reportDate, emailReport);
String^ GetArguments(
    DateTime reportDate,
    bool emailReport
)

Parameters

reportDate
Type: SystemDateTime
The date of the report to be generated.
emailReport
Type: SystemBoolean
Flag that determines if report should be e-mailed, if enabled.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.TimeSeries.Reports.IReportingProcess.GetArguments(System.DateTime,System.Boolean)"]

See Also

Reference

IReportingProcess Interface
GetArguments Overload
GSF.TimeSeries.Reports Namespace


IReportingProcess.GetPendingReportsList Method

Grid Solutions Framework IReportingProcessGetPendingReportsList Method
Returns the list of reports which are in the queue but are yet to be generated.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
List<string> GetPendingReportsList()
Function GetPendingReportsList As List(Of String)
abstract GetPendingReportsList : unit -> List<string>

function GetPendingReportsList();
List<String^>^ GetPendingReportsList()

Return Value

Type: List String
The list of pending reports.
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.GetReportsList Method

Grid Solutions Framework IReportingProcessGetReportsList Method
Returns the list of reports that are available from the report location.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
List<string> GetReportsList()
Function GetReportsList As List(Of String)
abstract GetReportsList : unit -> List<string>

function GetReportsList();
List<String^>^ GetReportsList()

Return Value

Type: List String
The list of generated reports.
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.SetArguments Method

Grid Solutions Framework IReportingProcessSetArguments Method
Applies any received command line arguments for the reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void SetArguments(
    Arguments args
)
Sub SetArguments (
    args As Arguments
)
abstract SetArguments :
        args : Arguments -> unit

function SetArguments(args);
void SetArguments(
    Arguments^ args
)

Parameters

args
Type: GSF.ConsoleArguments
Received command line arguments.
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess Properties

Grid Solutions Framework IReportingProcess Properties

The IReportingProcess type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived.
Public property | Company | Gets or sets the name of the company to be displayed on reports.
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports.
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports.
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days.
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ReportLocation | Gets or sets the directory to which reports will be written.
Public property | ReportType | Gets report type (i.e., name) for this reporting process.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports.
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | Title | Gets or sets the title to be displayed on reports.
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports.
Top
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.ArchiveFilePath Property

Grid Solutions Framework IReportingProcessArchiveFilePath Property
Gets or sets the path to the archive file to which the statistics required for reporting are archived.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ArchiveFilePath { get; set; }
Property ArchiveFilePath As String
    Get
    Set
abstract ArchiveFilePath : string with get, set

function get_ArchiveFilePath();
function set_ArchiveFilePath(value);
property String^ ArchiveFilePath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.Company Property

Grid Solutions Framework IReportingProcessCompany Property
Gets or sets the name of the company to be displayed on reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Company { get; set; }
Property Company As String
    Get
    Set
abstract Company : string with get, set

function get_Company();
function set_Company(value);
property String^ Company {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.EnableReportEmail Property

Grid Solutions Framework IReportingProcessEnableReportEmail Property
Gets or sets flag to enable e-mailing of reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool EnableReportEmail { get; set; }
Property EnableReportEmail As Boolean
    Get
    Set
abstract EnableReportEmail : bool with get, set

function get_EnableReportEmail();
function set_EnableReportEmail(value);
property bool EnableReportEmail {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.FromAddress Property

Grid Solutions Framework IReportingProcessFromAddress Property
Gets or sets the "from" address to use when e-mailing reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string FromAddress { get; set; }
Property FromAddress As String
    Get
    Set
abstract FromAddress : string with get, set

function get_FromAddress();
function set_FromAddress(value);
property String^ FromAddress {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.IdleReportLifetime Property

Grid Solutions Framework IReportingProcessIdleReportLifetime Property
Gets or sets the minimum lifetime of a report since the last time it was accessed, in days.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
double IdleReportLifetime { get; set; }
Property IdleReportLifetime As Double
    Get
    Set
abstract IdleReportLifetime : float with get, set

function get_IdleReportLifetime();
function set_IdleReportLifetime(value);
property double IdleReportLifetime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.ReportLocation Property

Grid Solutions Framework IReportingProcessReportLocation Property
Gets or sets the directory to which reports will be written.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ReportLocation { get; set; }
Property ReportLocation As String
    Get
    Set
abstract ReportLocation : string with get, set

function get_ReportLocation();
function set_ReportLocation(value);
property String^ ReportLocation {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.ReportType Property

Grid Solutions Framework IReportingProcessReportType Property
Gets report type (i.e., name) for this reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ReportType { get; }
ReadOnly Property ReportType As String
    Get
abstract ReportType : string with get

function get_ReportType();

property String^ ReportType {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.SmtpServer Property

Grid Solutions Framework IReportingProcessSmtpServer Property
Gets or sets SMTP server to use when e-mailing reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string SmtpServer { get; set; }
Property SmtpServer As String
    Get
    Set
abstract SmtpServer : string with get, set

function get_SmtpServer();
function set_SmtpServer(value);
property String^ SmtpServer {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.Title Property

Grid Solutions Framework IReportingProcessTitle Property
Gets or sets the title to be displayed on reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string Title { get; set; }
Property Title As String
    Get
    Set
abstract Title : string with get, set

function get_Title();
function set_Title(value);
property String^ Title {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


IReportingProcess.ToAddresses Property

Grid Solutions Framework IReportingProcessToAddresses Property
Gets or sets the comma separated "to" addresses to use when e-mailing reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string ToAddresses { get; set; }
Property ToAddresses As String
    Get
    Set
abstract ToAddresses : string with get, set

function get_ToAddresses();
function set_ToAddresses(value);
property String^ ToAddresses {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IReportingProcess Interface
GSF.TimeSeries.Reports Namespace


ReportingProcessBase Class

Grid Solutions Framework ReportingProcessBase Class
Represents the base functionality for reporting processes.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.ReportsReportingProcessBase
GSF.TimeSeries.ReportsCompletenessReportingProcess
GSF.TimeSeries.ReportsCorrectnessReportingProcess

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class ReportingProcessBase : IReportingProcess,
    IProvideStatus, IPersistSettings
Public MustInherit Class ReportingProcessBase
    Implements IReportingProcess, IProvideStatus, IPersistSettings
[<AbstractClassAttribute>]
type ReportingProcessBase =
    class
        interface IReportingProcess
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.TimeSeries.Reports.ReportingProcessBase = function();

Type.createClass(
    'GSF.TimeSeries.Reports.ReportingProcessBase',
    null,
    GSF.TimeSeries.Reports.IReportingProcess,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
public ref class ReportingProcessBase abstract : IReportingProcess,
    IProvideStatus, IPersistSettings

The ReportingProcessBase type exposes the following members.

Constructors
 | Name | Description
Protected method | ReportingProcessBase | Creates a new instance of the ReportingProcessBase class.
Top
Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateReport | Queues up a report to be generated on a separate thread.
Public method | GetArguments | Gets the command line arguments for the reporting process.
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated.
Public method | GetReportsList | Returns the list of reports that are available from the report location.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadSettings | Loads saved settings from the config file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveSettings | Saves settings to the config file.
Public method | SetArguments | Applies any received command line arguments for the reporting process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived.
Public property | Company | Gets or sets the name of the company to be displayed on reports.
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports.
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports.
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file.
Public property | ReportLocation | Gets or sets the directory to which reports will be written.
Public property | ReportType | Gets report type, i.e., basically the report name associated with this reporting process.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file.
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports.
Public property | Status | Gets the current status details about reporting process.
Public property | Title | Gets or sets the title to be displayed on reports.
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports.
Top
See Also

Reference

GSF.TimeSeries.Reports Namespace


ReportingProcessBase Constructor

Grid Solutions Framework ReportingProcessBase Constructor
Creates a new instance of the ReportingProcessBase class.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ReportingProcessBase(
    string reportType
)
Protected Sub New (
    reportType As String
)
new :
        reportType : string -> ReportingProcessBase
GSF.TimeSeries.Reports.ReportingProcessBase = function(reportType);
protected:
ReportingProcessBase(
    String^ reportType
)

Parameters

reportType
Type: SystemString
Report type - passed into StatHistorianReportGenerator.
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase Methods

Grid Solutions Framework ReportingProcessBase Methods

The ReportingProcessBase type exposes the following members.

Methods
 | Name | Description
Public method | CleanReportLocation | Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateReport | Queues up a report to be generated on a separate thread.
Public method | GetArguments | Gets the command line arguments for the reporting process.
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetPendingReportsList | Returns the list of reports which are in the queue but are yet to be generated.
Public method | GetReportsList | Returns the list of reports that are available from the report location.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | LoadSettings | Loads saved settings from the config file.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | SaveSettings | Saves settings to the config file.
Public method | SetArguments | Applies any received command line arguments for the reporting process.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.CleanReportLocation Method

Grid Solutions Framework ReportingProcessBaseCleanReportLocation Method
Deletes reports from the ReportLocation that have been idle for the length of the IdleReportLifetime.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void CleanReportLocation()
Public Sub CleanReportLocation
abstract CleanReportLocation : unit -> unit
override CleanReportLocation : unit -> unit
function CleanReportLocation();
public:
virtual void CleanReportLocation() sealed

Implements

IReportingProcessCleanReportLocation
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.GenerateReport Method

Grid Solutions Framework ReportingProcessBaseGenerateReport Method
Queues up a report to be generated on a separate thread.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void GenerateReport(
    DateTime reportDate,
    bool emailReport
)
Public Sub GenerateReport (
    reportDate As DateTime,
    emailReport As Boolean
)
abstract GenerateReport :
        reportDate : DateTime *
        emailReport : bool -> unit
override GenerateReport :
        reportDate : DateTime *
        emailReport : bool -> unit
function GenerateReport(reportDate, emailReport);
public:
virtual void GenerateReport(
    DateTime reportDate,
    bool emailReport
) sealed

Parameters

reportDate
Type: SystemDateTime
The date of the report to be generated.
emailReport
Type: SystemBoolean
Flag that determines if report should be e-mailed, if enabled.

Implements

IReportingProcessGenerateReport(DateTime, Boolean)
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.GetArguments Method

Grid Solutions Framework ReportingProcessBaseGetArguments Method
Overload List
 | Name | Description
Public method | GetArguments | Gets the command line arguments for the reporting process.
Public method | GetArguments(DateTime, Boolean) | Gets the command line arguments for the reporting process for a given report date.
Top
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.GetArguments Method

Grid Solutions Framework ReportingProcessBaseGetArguments Method
Gets the command line arguments for the reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string GetArguments()
Public Overridable Function GetArguments As String
abstract GetArguments : unit -> string
override GetArguments : unit -> string
function GetArguments();
public:
virtual String^ GetArguments()

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.TimeSeries.Reports.ReportingProcessBase.GetArguments"]

Implements

IReportingProcessGetArguments
See Also

Reference

ReportingProcessBase Class
GetArguments Overload
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.GetArguments Method (DateTime, Boolean)

Grid Solutions Framework ReportingProcessBaseGetArguments Method (DateTime, Boolean)
Gets the command line arguments for the reporting process for a given report date.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string GetArguments(
    DateTime reportDate,
    bool emailReport
)
Public Function GetArguments (
    reportDate As DateTime,
    emailReport As Boolean
) As String
abstract GetArguments :
        reportDate : DateTime *
        emailReport : bool -> string
override GetArguments :
        reportDate : DateTime *
        emailReport : bool -> string
function GetArguments(reportDate, emailReport);
public:
virtual String^ GetArguments(
    DateTime reportDate,
    bool emailReport
) sealed

Parameters

reportDate
Type: SystemDateTime
The date of the report to be generated.
emailReport
Type: SystemBoolean
Flag that determines if report should be e-mailed, if enabled.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.TimeSeries.Reports.ReportingProcessBase.GetArguments(System.DateTime,System.Boolean)"]

Implements

IReportingProcessGetArguments(DateTime, Boolean)
See Also

Reference

ReportingProcessBase Class
GetArguments Overload
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.GetPendingReportsList Method

Grid Solutions Framework ReportingProcessBaseGetPendingReportsList Method
Returns the list of reports which are in the queue but are yet to be generated.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<string> GetPendingReportsList()
Public Function GetPendingReportsList As List(Of String)
abstract GetPendingReportsList : unit -> List<string>
override GetPendingReportsList : unit -> List<string>
function GetPendingReportsList();
public:
virtual List<String^>^ GetPendingReportsList() sealed

Return Value

Type: List String
The list of pending reports.

Implements

IReportingProcessGetPendingReportsList
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.GetReportsList Method

Grid Solutions Framework ReportingProcessBaseGetReportsList Method
Returns the list of reports that are available from the report location.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<string> GetReportsList()
Public Function GetReportsList As List(Of String)
abstract GetReportsList : unit -> List<string>
override GetReportsList : unit -> List<string>
function GetReportsList();
public:
virtual List<String^>^ GetReportsList() sealed

Return Value

Type: List String
The list of generated reports.

Implements

IReportingProcessGetReportsList
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.LoadSettings Method

Grid Solutions Framework ReportingProcessBaseLoadSettings Method
Loads saved settings from the config file.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void LoadSettings()
Public Overridable Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings()

Implements

IPersistSettingsLoadSettings
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.SaveSettings Method

Grid Solutions Framework ReportingProcessBaseSaveSettings Method
Saves settings to the config file.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SaveSettings()
Public Overridable Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings()

Implements

IPersistSettingsSaveSettings
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.SetArguments Method

Grid Solutions Framework ReportingProcessBaseSetArguments Method
Applies any received command line arguments for the reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void SetArguments(
    Arguments args
)
Public Overridable Sub SetArguments (
    args As Arguments
)
abstract SetArguments :
        args : Arguments -> unit
override SetArguments :
        args : Arguments -> unit
function SetArguments(args);
public:
virtual void SetArguments(
    Arguments^ args
)

Parameters

args
Type: GSF.ConsoleArguments
Received command line arguments.

Implements

IReportingProcessSetArguments(Arguments)
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase Properties

Grid Solutions Framework ReportingProcessBase Properties

The ReportingProcessBase type exposes the following members.

Properties
 | Name | Description
Public property | ArchiveFilePath | Gets or sets the path to the archive file to which the statistics required for reporting are archived.
Public property | Company | Gets or sets the name of the company to be displayed on reports.
Public property | EnableReportEmail | Gets or sets flag to enable e-mailing of reports.
Public property | FromAddress | Gets or sets the "from" address to use when e-mailing reports.
Public property | IdleReportLifetime | Gets or sets the minimum lifetime of a report since the last time it was accessed, in days.
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file.
Public property | ReportLocation | Gets or sets the directory to which reports will be written.
Public property | ReportType | Gets report type, i.e., basically the report name associated with this reporting process.
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file.
Public property | SmtpServer | Gets or sets SMTP server to use when e-mailing reports.
Public property | Status | Gets the current status details about reporting process.
Public property | Title | Gets or sets the title to be displayed on reports.
Public property | ToAddresses | Gets or sets the comma separated "to" addresses to use when e-mailing reports.
Top
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.ArchiveFilePath Property

Grid Solutions Framework ReportingProcessBaseArchiveFilePath Property
Gets or sets the path to the archive file to which the statistics required for reporting are archived.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ArchiveFilePath { get; set; }
Public Property ArchiveFilePath As String
    Get
    Set
abstract ArchiveFilePath : string with get, set
override ArchiveFilePath : string with get, set
function get_ArchiveFilePath();
function set_ArchiveFilePath(value);
public:
virtual property String^ ArchiveFilePath {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReportingProcessArchiveFilePath
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.Company Property

Grid Solutions Framework ReportingProcessBaseCompany Property
Gets or sets the name of the company to be displayed on reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Company { get; set; }
Public Property Company As String
    Get
    Set
abstract Company : string with get, set
override Company : string with get, set
function get_Company();
function set_Company(value);
public:
virtual property String^ Company {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReportingProcessCompany
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.EnableReportEmail Property

Grid Solutions Framework ReportingProcessBaseEnableReportEmail Property
Gets or sets flag to enable e-mailing of reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool EnableReportEmail { get; set; }
Public Property EnableReportEmail As Boolean
    Get
    Set
abstract EnableReportEmail : bool with get, set
override EnableReportEmail : bool with get, set
function get_EnableReportEmail();
function set_EnableReportEmail(value);
public:
virtual property bool EnableReportEmail {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IReportingProcessEnableReportEmail
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.FromAddress Property

Grid Solutions Framework ReportingProcessBaseFromAddress Property
Gets or sets the "from" address to use when e-mailing reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FromAddress { get; set; }
Public Property FromAddress As String
    Get
    Set
abstract FromAddress : string with get, set
override FromAddress : string with get, set
function get_FromAddress();
function set_FromAddress(value);
public:
virtual property String^ FromAddress {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReportingProcessFromAddress
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.IdleReportLifetime Property

Grid Solutions Framework ReportingProcessBaseIdleReportLifetime Property
Gets or sets the minimum lifetime of a report since the last time it was accessed, in days.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double IdleReportLifetime { get; set; }
Public Property IdleReportLifetime As Double
    Get
    Set
abstract IdleReportLifetime : float with get, set
override IdleReportLifetime : float with get, set
function get_IdleReportLifetime();
function set_IdleReportLifetime(value);
public:
virtual property double IdleReportLifetime {
    double get () sealed;
    void set (double value) sealed;
}

Property Value

Type: Double

Implements

IReportingProcessIdleReportLifetime
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.PersistSettings Property

Grid Solutions Framework ReportingProcessBasePersistSettings Property
Determines whether the object settings are to be persisted to the config file.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool PersistSettings { get; set; }
Public Property PersistSettings As Boolean
    Get
    Set
abstract PersistSettings : bool with get, set
override PersistSettings : bool with get, set
function get_PersistSettings();
function set_PersistSettings(value);
public:
virtual property bool PersistSettings {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

IPersistSettingsPersistSettings
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.ReportLocation Property

Grid Solutions Framework ReportingProcessBaseReportLocation Property
Gets or sets the directory to which reports will be written.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ReportLocation { get; set; }
Public Property ReportLocation As String
    Get
    Set
abstract ReportLocation : string with get, set
override ReportLocation : string with get, set
function get_ReportLocation();
function set_ReportLocation(value);
public:
virtual property String^ ReportLocation {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReportingProcessReportLocation
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.ReportType Property

Grid Solutions Framework ReportingProcessBaseReportType Property
Gets report type, i.e., basically the report name associated with this reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ReportType { get; }
Public ReadOnly Property ReportType As String
    Get
abstract ReportType : string with get
override ReportType : string with get
function get_ReportType();

public:
virtual property String^ ReportType {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IReportingProcessReportType
Remarks
This value is passed to StatHistorianReportGenerator as "reportType" parameter.
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.SettingsCategory Property

Grid Solutions Framework ReportingProcessBaseSettingsCategory Property
Gets or sets the category name under which the object settings are persisted in the config file.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SettingsCategory { get; set; }
Public Property SettingsCategory As String
    Get
    Set
abstract SettingsCategory : string with get, set
override SettingsCategory : string with get, set
function get_SettingsCategory();
function set_SettingsCategory(value);
public:
virtual property String^ SettingsCategory {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IPersistSettingsSettingsCategory
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.SmtpServer Property

Grid Solutions Framework ReportingProcessBaseSmtpServer Property
Gets or sets SMTP server to use when e-mailing reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SmtpServer { get; set; }
Public Property SmtpServer As String
    Get
    Set
abstract SmtpServer : string with get, set
override SmtpServer : string with get, set
function get_SmtpServer();
function set_SmtpServer(value);
public:
virtual property String^ SmtpServer {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReportingProcessSmtpServer
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.Status Property

Grid Solutions Framework ReportingProcessBaseStatus Property
Gets the current status details about reporting process.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.Title Property

Grid Solutions Framework ReportingProcessBaseTitle Property
Gets or sets the title to be displayed on reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Title { get; set; }
Public Property Title As String
    Get
    Set
abstract Title : string with get, set
override Title : string with get, set
function get_Title();
function set_Title(value);
public:
virtual property String^ Title {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReportingProcessTitle
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessBase.ToAddresses Property

Grid Solutions Framework ReportingProcessBaseToAddresses Property
Gets or sets the comma separated "to" addresses to use when e-mailing reports.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToAddresses { get; set; }
Public Property ToAddresses As String
    Get
    Set
abstract ToAddresses : string with get, set
override ToAddresses : string with get, set
function get_ToAddresses();
function set_ToAddresses(value);
public:
virtual property String^ ToAddresses {
    String^ get () sealed;
    void set (String^ value) sealed;
}

Property Value

Type: String

Implements

IReportingProcessToAddresses
See Also

Reference

ReportingProcessBase Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection Class

Grid Solutions Framework ReportingProcessCollection Class
Represents a collection of IReportingProcess items.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IReportingProcess
GSF.TimeSeries.ReportsReportingProcessCollection

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ReportingProcessCollection : Collection<IReportingProcess>,
    IProvideStatus
Public Class ReportingProcessCollection
    Inherits Collection(Of IReportingProcess)
    Implements IProvideStatus
type ReportingProcessCollection =
    class
        inherit Collection<IReportingProcess>
        interface IProvideStatus
    end
GSF.TimeSeries.Reports.ReportingProcessCollection = function();

Type.createClass(
    'GSF.TimeSeries.Reports.ReportingProcessCollection',
    Collection`1,
    GSF.IProvideStatus);
public ref class ReportingProcessCollection : public Collection<IReportingProcess^>,
    IProvideStatus

The ReportingProcessCollection type exposes the following members.

Constructors
 | Name | Description
Public method | ReportingProcessCollection | Initializes a new instance of the ReportingProcessCollection class
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IReportingProcess .)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IReportingProcess .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindReportType | Finds the IReportingProcess for the specified reportType name.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IReportingProcess .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IReportingProcess .)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
 | LoadImplementations | Loads available IReportingProcess implementations.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IReportingProcess .)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from Collection IReportingProcess .)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IReportingProcess .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection IReportingProcess .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IReportingProcess .)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT.
Top
See Also

Reference

GSF.TimeSeries.Reports Namespace


ReportingProcessCollection Constructor

Grid Solutions Framework ReportingProcessCollection Constructor
Initializes a new instance of the ReportingProcessCollection class

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ReportingProcessCollection()
Public Sub New
new : unit -> ReportingProcessCollection
GSF.TimeSeries.Reports.ReportingProcessCollection = function();
public:
ReportingProcessCollection()
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection Methods

Grid Solutions Framework ReportingProcessCollection Methods

The ReportingProcessCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection IReportingProcess .)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | Contains | Determines whether an element is in the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection IReportingProcess .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindReportType | Finds the IReportingProcess for the specified reportType name.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection IReportingProcess .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection IReportingProcess .)
Protected method | InsertItem | Inserts an element into the CollectionT at the specified index. (Overrides CollectionTInsertItem(Int32, T).)
 | LoadImplementations | Loads available IReportingProcess implementations.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection IReportingProcess .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection IReportingProcess .)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from Collection IReportingProcess .)
Protected method | SetItem | Replaces the element at the specified index. (Overrides CollectionTSetItem(Int32, T).)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection.FindReportType Method

Grid Solutions Framework ReportingProcessCollectionFindReportType Method
Finds the IReportingProcess for the specified reportType name.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IReportingProcess FindReportType(
    string reportType
)
Public Function FindReportType (
    reportType As String
) As IReportingProcess
member FindReportType :
        reportType : string -> IReportingProcess

function FindReportType(reportType);
public:
IReportingProcess^ FindReportType(
    String^ reportType
)

Parameters

reportType
Type: SystemString
Name of the report type to find.

Return Value

Type: IReportingProcess
The IReportingProcess for the specified reportType name, if found; otherwise, null if not found.
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection.InsertItem Method

Grid Solutions Framework ReportingProcessCollectionInsertItem Method
Inserts an element into the CollectionT at the specified index.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void InsertItem(
    int index,
    IReportingProcess item
)
Protected Overrides Sub InsertItem (
    index As Integer,
    item As IReportingProcess
)
abstract InsertItem :
        index : int *
        item : IReportingProcess -> unit
override InsertItem :
        index : int *
        item : IReportingProcess -> unit
function InsertItem(index, item);
protected:
virtual void InsertItem(
    int index,
    IReportingProcess^ item
) override

Parameters

index
Type: SystemInt32
The zero-based index at which item should be inserted.
item
Type: GSF.TimeSeries.ReportsIReportingProcess
The object to insert. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection.LoadImplementations Method

Grid Solutions Framework ReportingProcessCollectionLoadImplementations Method
Loads available IReportingProcess implementations.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static ReportingProcessCollection LoadImplementations(
    Action<Exception> exceptionHandler = null
)
Public Shared Function LoadImplementations (
    Optional exceptionHandler As Action(Of Exception) = Nothing
) As ReportingProcessCollection
static member LoadImplementations :
        ?exceptionHandler : Action<Exception>
(* Defaults:
        let _exceptionHandler = defaultArg exceptionHandler null
*)
-> ReportingProcessCollection

GSF.TimeSeries.Reports.ReportingProcessCollection.LoadImplementations = function(exceptionHandler);
public:
static ReportingProcessCollection^ LoadImplementations(
    Action<Exception^>^ exceptionHandler = nullptr
)

Parameters

exceptionHandler (Optional)
Type: SystemAction Exception
Exception handler, if any, to call when type creation fails; otherwise, if null any exceptions will be thrown.

Return Value

Type: ReportingProcessCollection
New collection of IReportingProcess implementations.
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection.SetItem Method

Grid Solutions Framework ReportingProcessCollectionSetItem Method
Replaces the element at the specified index.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void SetItem(
    int index,
    IReportingProcess item
)
Protected Overrides Sub SetItem (
    index As Integer,
    item As IReportingProcess
)
abstract SetItem :
        index : int *
        item : IReportingProcess -> unit
override SetItem :
        index : int *
        item : IReportingProcess -> unit
function SetItem(index, item);
protected:
virtual void SetItem(
    int index,
    IReportingProcess^ item
) override

Parameters

index
Type: SystemInt32
The zero-based index of the element to replace.
item
Type: GSF.TimeSeries.ReportsIReportingProcess
The new value for the element at the specified index. The value can be null for reference types.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | index is less than zero. -or- index is greater than Count.
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection Properties

Grid Solutions Framework ReportingProcessCollection Properties

The ReportingProcessCollection type exposes the following members.

Properties
 | Name | Description
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection IReportingProcess .)
Public property | Item | Gets or sets the element at the specified index. (Inherited from Collection IReportingProcess .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection IReportingProcess .)
Public property | Status | Gets the descriptive status of this AdapterCollectionBaseT.
Top
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


ReportingProcessCollection.Status Property

Grid Solutions Framework ReportingProcessCollectionStatus Property
Gets the descriptive status of this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Reports
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string Status { get; }
Public Overridable ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get ();
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ReportingProcessCollection Class
GSF.TimeSeries.Reports Namespace


GSF.TimeSeries.Statistics Namespace

Grid Solutions Framework GSF.TimeSeries.Statistics Namespace

[Missing <summary> documentation for "N:GSF.TimeSeries.Statistics"]

Classes
 | Class | Description
Public class | DeviceStatisticsHelperT | Helper class for calculating device statistics.
Public class | StatisticsEngine | Represents the engine that computes statistics within applications of the TimeSeriesFramework.
Public class | StatisticValueState | Represents an object that can track the current and previous state of a statistic and get the difference between them.
Public class | StatisticValueStateCache | Caches statistic values to provide the difference between the current and previous values of any statistic given that statistic's source, name, and current value.
Delegates
 | Delegate | Description
Public delegate | StatisticCalculationFunction | Method signature for function used to calculate a statistic for a given object.


DeviceStatisticsHelper(T) Class

Grid Solutions Framework DeviceStatisticsHelperT Class
Helper class for calculating device statistics.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.StatisticsDeviceStatisticsHelperT

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DeviceStatisticsHelper<T>
where T : class, IDevice

Public Class DeviceStatisticsHelper(Of T As {Class, IDevice})
type DeviceStatisticsHelper<'T when 'T : not struct and IDevice> =  class end
JavaScript does not support generic types or methods.
generic<typename T>
where T : ref class, IDevice
public ref class DeviceStatisticsHelper

Type Parameters

T
The type of the devices whose statistics are to be calculated.

The DeviceStatisticsHelperT type exposes the following members.

Constructors
 | Name | Description
Public method | DeviceStatisticsHelperT | Creates a new instance of the DeviceStatisticsHelperT class.
Top
Methods
 | Name | Description
Public method | AddToMeasurementsReceived | Increases the count of the number of measurements received from the device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the member variables used to track statistics for the device wrapped by this helper.
Public method | Reset(Int64) | Resets the member variables used to track statistics for the device wrapped by this helper.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.
Public method | Update(Int64) | Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Device | Gets the device whose statistics are being calculated using this helper.
Public property | ExpectedMeasurementsPerSecond | Gets or sets the number of measurements expected to be received from the device per second.
Top
See Also

Reference

GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T) Constructor

Grid Solutions Framework DeviceStatisticsHelperT Constructor
Creates a new instance of the DeviceStatisticsHelperT class.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DeviceStatisticsHelper(
    T device
)
Public Sub New (
    device As T
)
new :
        device : 'T -> DeviceStatisticsHelper
GSF.TimeSeries.Statistics.DeviceStatisticsHelper = function(device);
public:
DeviceStatisticsHelper(
    T device
)

Parameters

device
Type: T
The device whose statistics are to be calculated using this helper.
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T) Methods

Grid Solutions Framework DeviceStatisticsHelperT Methods

The DeviceStatisticsHelperT generic type exposes the following members.

Methods
 | Name | Description
Public method | AddToMeasurementsReceived | Increases the count of the number of measurements received from the device.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Reset | Resets the member variables used to track statistics for the device wrapped by this helper.
Public method | Reset(Int64) | Resets the member variables used to track statistics for the device wrapped by this helper.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Update | Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.
Public method | Update(Int64) | Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).AddToMeasurementsReceived Method

Grid Solutions Framework DeviceStatisticsHelperTAddToMeasurementsReceived Method
Increases the count of the number of measurements received from the device.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddToMeasurementsReceived(
    int count
)
Public Sub AddToMeasurementsReceived (
    count As Integer
)
member AddToMeasurementsReceived :
        count : int -> unit

function AddToMeasurementsReceived(count);
public:
void AddToMeasurementsReceived(
    int count
)

Parameters

count
Type: SystemInt32
The number of measurements received from the device since the last time this method was called.
Remarks
Call this each time measurements have been received by the device in order to properly track the MeasurementsReceived statistic.
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).Reset Method

Grid Solutions Framework DeviceStatisticsHelperTReset Method
Overload List
 | Name | Description
Public method | Reset | Resets the member variables used to track statistics for the device wrapped by this helper.
Public method | Reset(Int64) | Resets the member variables used to track statistics for the device wrapped by this helper.
Top
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).Reset Method

Grid Solutions Framework DeviceStatisticsHelperTReset Method
Resets the member variables used to track statistics for the device wrapped by this helper.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset()
Public Sub Reset
member Reset : unit -> unit

function Reset();
public:
void Reset()
Remarks
Call this when the connection to a device has been reset to mark a starting point for statistics gathering. Since the Update(Int64) method keeps track of the time it was last called, it is necessary to call this method during long periods of downtime where Update was not being called in order to avoid momentary, unexpectedly large values to be calculated for measurements expected.
See Also

Reference

DeviceStatisticsHelperT Class
Reset Overload
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).Reset Method (Int64)

Grid Solutions Framework DeviceStatisticsHelperTReset Method (Int64)
Resets the member variables used to track statistics for the device wrapped by this helper.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Reset(
    long nowTicks
)
Public Sub Reset (
    nowTicks As Long
)
member Reset :
        nowTicks : int64 -> unit

function Reset(nowTicks);
public:
void Reset(
    long long nowTicks
)

Parameters

nowTicks
Type: SystemInt64
The current time, in ticks.
Remarks
Call this when the connection to a device has been reset to mark a starting point for statistics gathering. Since the Update(Int64) method keeps track of the time it was last called, it is necessary to call this method during long periods of downtime where Update was not being called in order to avoid momentary, unexpectedly large values to be calculated for measurements expected. This method is preferred when tracking statistics for multiple IDevices to reduce the number of calls to UtcNow.
See Also

Reference

DeviceStatisticsHelperT Class
Reset Overload
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).Update Method

Grid Solutions Framework DeviceStatisticsHelperTUpdate Method
Overload List
 | Name | Description
Public method | Update | Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.
Public method | Update(Int64) | Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.
Top
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).Update Method

Grid Solutions Framework DeviceStatisticsHelperTUpdate Method
Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update()
Public Sub Update
member Update : unit -> unit

function Update();
public:
void Update()
Remarks
Call this periodically, preferably on a slow timer (e.g., once per second), in order to update the MeasurementsReceived and MeasurementsExpected statistics.
See Also

Reference

DeviceStatisticsHelperT Class
Update Overload
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).Update Method (Int64)

Grid Solutions Framework DeviceStatisticsHelperTUpdate Method (Int64)
Updates the statistics for the number of measurements received and the number of measurements expected in the IDevice wrapped by this helper.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Update(
    long nowTicks
)
Public Sub Update (
    nowTicks As Long
)
member Update :
        nowTicks : int64 -> unit

function Update(nowTicks);
public:
void Update(
    long long nowTicks
)

Parameters

nowTicks
Type: SystemInt64
The current time, in ticks.
Remarks
Call this periodically, preferably on a slow timer (e.g., once per second), in order to update the MeasurementsReceived and MeasurementsExpected statistics. This method is preferred when tracking statistics for multiple IDevices to reduce the number of calls to UtcNow.
See Also

Reference

DeviceStatisticsHelperT Class
Update Overload
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T) Properties

Grid Solutions Framework DeviceStatisticsHelperT Properties

The DeviceStatisticsHelperT generic type exposes the following members.

Properties
 | Name | Description
Public property | Device | Gets the device whose statistics are being calculated using this helper.
Public property | ExpectedMeasurementsPerSecond | Gets or sets the number of measurements expected to be received from the device per second.
Top
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).Device Property

Grid Solutions Framework DeviceStatisticsHelperTDevice Property
Gets the device whose statistics are being calculated using this helper.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public T Device { get; }
Public ReadOnly Property Device As T
    Get
member Device : 'T with get

function get_Device();

public:
property T Device {
    T get ();
}

Property Value

Type: T
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


DeviceStatisticsHelper(T).ExpectedMeasurementsPerSecond Property

Grid Solutions Framework DeviceStatisticsHelperTExpectedMeasurementsPerSecond Property
Gets or sets the number of measurements expected to be received from the device per second.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ExpectedMeasurementsPerSecond { get; set; }
Public Property ExpectedMeasurementsPerSecond As Integer
    Get
    Set
member ExpectedMeasurementsPerSecond : int with get, set

function get_ExpectedMeasurementsPerSecond();
function set_ExpectedMeasurementsPerSecond(value);
public:
property int ExpectedMeasurementsPerSecond {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DeviceStatisticsHelperT Class
GSF.TimeSeries.Statistics Namespace


StatisticCalculationFunction Delegate

Grid Solutions Framework StatisticCalculationFunction Delegate
Method signature for function used to calculate a statistic for a given object.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public delegate double StatisticCalculationFunction(
    Object source,
    string arguments
)
Public Delegate Function StatisticCalculationFunction (
    source As Object,
    arguments As String
) As Double
type StatisticCalculationFunction =
    delegate of
        source : Object *
        arguments : string -> float
function(source, arguments);
public delegate double StatisticCalculationFunction(
    Object^ source,
    String^ arguments
)

Parameters

source
Type: SystemObject
Source object.
arguments
Type: SystemString
Any needed arguments for statistic calculation.

Return Value

Type: Double
Actual calculated statistic.
See Also

Reference

GSF.TimeSeries.Statistics Namespace


StatisticsEngine Class

Grid Solutions Framework StatisticsEngine Class
Represents the engine that computes statistics within applications of the TimeSeriesFramework.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersAdapterBase
GSF.TimeSeries.AdaptersFacileActionAdapterBase
GSF.TimeSeries.StatisticsStatisticsEngine

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class StatisticsEngine : FacileActionAdapterBase
Public Class StatisticsEngine
    Inherits FacileActionAdapterBase
type StatisticsEngine =
    class
        inherit FacileActionAdapterBase
    end
GSF.TimeSeries.Statistics.StatisticsEngine = function();

Type.createClass(
    'GSF.TimeSeries.Statistics.StatisticsEngine',
    GSF.TimeSeries.Adapters.FacileActionAdapterBase);
public ref class StatisticsEngine : public FacileActionAdapterBase

The StatisticsEngine type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticsEngine | Creates a new instance of the StatisticsEngine class.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StatisticsEngine object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this StatisticsEngine. (Overrides AdapterBaseGetShortStatus(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes StatisticsEngine. (Overrides FacileActionAdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing. (Overrides FacileActionAdapterBaseQueueMeasurementsForProcessing(IEnumerableIMeasurement).)
 | RegexMatch | Determines whether the given signal reference matches the signal reference regular expression using the given suffix.
 | Register(IAdapter, String, String, String) | Registers the given adapter with the statistics engine as a source of statistics.
 | Register(Object, String, String, String, String) | Registers the given object with the statistics engine as a source of statistics.
Public method | ReloadStatistics | Loads or reloads system statistics.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts the StatisticsEngine or restarts it if it is already running. (Overrides AdapterBaseStart.)
Public method | Stop | Stops the StatisticsEngine. (Overrides AdapterBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unregister | Unregisters the given source, removing it from the list of statistic sources so that it no longer generates statistics.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to the StatisticsEngine. (Overrides AdapterBaseDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | FramesPerSecond | Gets or sets the frames per second to be used by the FacileActionAdapterBase. (Inherited from FacileActionAdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the FacileActionAdapterBase expects, if any. (Inherited from FacileActionAdapterBase.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from FacileActionAdapterBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from FacileActionAdapterBase.)
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement. (Inherited from FacileActionAdapterBase.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from FacileActionAdapterBase.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from FacileActionAdapterBase.)
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the statistics engine. (Overrides FacileActionAdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real time. (Inherited from FacileActionAdapterBase.)
Top
Events
 | Name | Description
 | BeforeCalculate | Event is raised before statistics calculation.
 | Calculated | Event is raised after statistics calculation.
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from FacileActionAdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from action adapter. (Inherited from FacileActionAdapterBase.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnpublishedSamples | This event is raised by derived class, if needed, to track current number of unpublished seconds of data in the queue. (Inherited from FacileActionAdapterBase.)
Top
See Also

Reference

GSF.TimeSeries.Statistics Namespace


StatisticsEngine Constructor

Grid Solutions Framework StatisticsEngine Constructor
Creates a new instance of the StatisticsEngine class.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatisticsEngine()
Public Sub New
new : unit -> StatisticsEngine
GSF.TimeSeries.Statistics.StatisticsEngine = function();
public:
StatisticsEngine()
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine Methods

Grid Solutions Framework StatisticsEngine Methods

The StatisticsEngine type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StatisticsEngine object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this StatisticsEngine. (Overrides AdapterBaseGetShortStatus(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes StatisticsEngine. (Overrides FacileActionAdapterBaseInitialize.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing. (Overrides FacileActionAdapterBaseQueueMeasurementsForProcessing(IEnumerableIMeasurement).)
 | RegexMatch | Determines whether the given signal reference matches the signal reference regular expression using the given suffix.
 | Register(IAdapter, String, String, String) | Registers the given adapter with the statistics engine as a source of statistics.
 | Register(Object, String, String, String, String) | Registers the given object with the statistics engine as a source of statistics.
Public method | ReloadStatistics | Loads or reloads system statistics.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts the StatisticsEngine or restarts it if it is already running. (Overrides AdapterBaseStart.)
Public method | Stop | Stops the StatisticsEngine. (Overrides AdapterBaseStop.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
 | Unregister | Unregisters the given source, removing it from the list of statistic sources so that it no longer generates statistics.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Dispose Method

Grid Solutions Framework StatisticsEngineDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the StatisticsEngine object and optionally releases the managed resources. (Overrides AdapterBaseDispose(Boolean).)
Top
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Dispose Method (Boolean)

Grid Solutions Framework StatisticsEngineDispose Method (Boolean)
Releases the unmanaged resources used by the StatisticsEngine object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

StatisticsEngine Class
Dispose Overload
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.GetShortStatus Method

Grid Solutions Framework StatisticsEngineGetShortStatus Method
Gets a short one-line status of this StatisticsEngine.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string
override GetShortStatus :
        maxLength : int -> string
function GetShortStatus(maxLength);
public:
virtual String^ GetShortStatus(
    int maxLength
) override

Parameters

maxLength
Type: SystemInt32
Maximum number of available characters for display.

Return Value

Type: String
A short one-line summary of the current status of this StatisticsEngine.

Implements

IAdapterGetShortStatus(Int32)
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Initialize Method

Grid Solutions Framework StatisticsEngineInitialize Method
Initializes StatisticsEngine.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.QueueMeasurementsForProcessing Method

Grid Solutions Framework StatisticsEngineQueueMeasurementsForProcessing Method
Queues a collection of measurements for processing.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overrides Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
) override

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Measurements to queue for processing.

Implements

IActionAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.RegexMatch Method

Grid Solutions Framework StatisticsEngineRegexMatch Method
Determines whether the given signal reference matches the signal reference regular expression using the given suffix.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool RegexMatch(
    string signalReference,
    string suffix
)
Public Shared Function RegexMatch (
    signalReference As String,
    suffix As String
) As Boolean
static member RegexMatch :
        signalReference : string *
        suffix : string -> bool

GSF.TimeSeries.Statistics.StatisticsEngine.RegexMatch = function(signalReference, suffix);
public:
static bool RegexMatch(
    String^ signalReference,
    String^ suffix
)

Parameters

signalReference
Type: SystemString
The signal reference to be matched against the regular expression.
suffix
Type: SystemString
The suffix used by a particular type of statistic.

Return Value

Type: Boolean
Flag indicating whether the signal reference matches the regular expression.
Remarks
The format for signal reference of statistics is: ACRONYM!SUFFIX-ST#, where ACRONYM is the acronym of the measurement's source, SUFFIX is the suffix given as a parameter to this method, and # is an index used to differentiate between statistics with the same source and type.
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Register Method

Grid Solutions Framework StatisticsEngineRegister Method
Overload List
Name | Description
Register(IAdapter, String, String, String) | Registers the given adapter with the statistics engine as a source of statistics.
Register(Object, String, String, String, String) | Registers the given object with the statistics engine as a source of statistics.
Top
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Register Method (IAdapter, String, String, String)

Grid Solutions Framework StatisticsEngineRegister Method (IAdapter, String, String, String)
Registers the given adapter with the statistics engine as a source of statistics.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Register(
    IAdapter adapter,
    string sourceCategory,
    string sourceAcronym,
    string statisticMeasurementNameFormat = "{}"
)
Public Shared Sub Register (
    adapter As IAdapter,
    sourceCategory As String,
    sourceAcronym As String,
    Optional statisticMeasurementNameFormat As String = "{}"
)
static member Register :
        adapter : IAdapter *
        sourceCategory : string *
        sourceAcronym : string *
        ?statisticMeasurementNameFormat : string
(* Defaults:
        let _statisticMeasurementNameFormat = defaultArg statisticMeasurementNameFormat "{}"
*)
-> unit

GSF.TimeSeries.Statistics.StatisticsEngine.Register = function(adapter, sourceCategory, sourceAcronym, statisticMeasurementNameFormat);
public:
static void Register(
    IAdapter^ adapter,
    String^ sourceCategory,
    String^ sourceAcronym,
    String^ statisticMeasurementNameFormat = L"{}"
)

Parameters

adapter
Type: GSF.TimeSeries.AdaptersIAdapter
The source of the statistics.
sourceCategory
Type: SystemString
The category of the statistics.
sourceAcronym
Type: SystemString
The acronym used in signal references.
statisticMeasurementNameFormat (Optional)
Type: SystemString
Format string used to name statistic measurements for this source.
See Also

Reference

StatisticsEngine Class
Register Overload
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Register Method (Object, String, String, String, String)

Grid Solutions Framework StatisticsEngineRegister Method (Object, String, String, String, String)
Registers the given object with the statistics engine as a source of statistics.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Register(
    Object source,
    string sourceName,
    string sourceCategory,
    string sourceAcronym,
    string statisticMeasurementNameFormat = "{}"
)
Public Shared Sub Register (
    source As Object,
    sourceName As String,
    sourceCategory As String,
    sourceAcronym As String,
    Optional statisticMeasurementNameFormat As String = "{}"
)
static member Register :
        source : Object *
        sourceName : string *
        sourceCategory : string *
        sourceAcronym : string *
        ?statisticMeasurementNameFormat : string
(* Defaults:
        let _statisticMeasurementNameFormat = defaultArg statisticMeasurementNameFormat "{}"
*)
-> unit

GSF.TimeSeries.Statistics.StatisticsEngine.Register = function(source, sourceName, sourceCategory, sourceAcronym, statisticMeasurementNameFormat);
public:
static void Register(
    Object^ source,
    String^ sourceName,
    String^ sourceCategory,
    String^ sourceAcronym,
    String^ statisticMeasurementNameFormat = L"{}"
)

Parameters

source
Type: SystemObject
The source of the statistics.
sourceName
Type: SystemString
The name of the source.
sourceCategory
Type: SystemString
The category of the statistics.
sourceAcronym
Type: SystemString
The acronym used in signal references.
statisticMeasurementNameFormat (Optional)
Type: SystemString
Format string used to name statistic measurements for this source.
See Also

Reference

StatisticsEngine Class
Register Overload
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.ReloadStatistics Method

Grid Solutions Framework StatisticsEngineReloadStatistics Method
Loads or reloads system statistics.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Reloads system statistics.", new string[] { ... })]
public void ReloadStatistics()
<AdapterCommandAttribute("Reloads system statistics.", New String() { ... })>
Public Sub ReloadStatistics
[<AdapterCommandAttribute("Reloads system statistics.", new string[] { ... })>]
member ReloadStatistics : unit -> unit

function ReloadStatistics();
public:
[AdapterCommandAttribute(L"Reloads system statistics.", __gc new array<String^>^ { ... })]
void ReloadStatistics()
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Start Method

Grid Solutions Framework StatisticsEngineStart Method
Starts the StatisticsEngine or restarts it if it is already running.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Starts the statistics engine or restarts it if it is already running.",
    new string[] { ... })]
public override void Start()
<AdapterCommandAttribute("Starts the statistics engine or restarts it if it is already running.",
    New String() { ... })>
Public Overrides Sub Start
[<AdapterCommandAttribute("Starts the statistics engine or restarts it if it is already running.",
    new string[] { ... })>]
abstract Start : unit -> unit
[<AdapterCommandAttribute("Starts the statistics engine or restarts it if it is already running.",
    new string[] { ... })>]
override Start : unit -> unit
function Start();
public:
[AdapterCommandAttribute(L"Starts the statistics engine or restarts it if it is already running.",
    __gc new array<String^>^ { ... })]
virtual void Start() override

Implements

IAdapterStart
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Stop Method

Grid Solutions Framework StatisticsEngineStop Method
Stops the StatisticsEngine.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Stops the statistics engine.", new string[] { ... })]
public override void Stop()
<AdapterCommandAttribute("Stops the statistics engine.", New String() { ... })>
Public Overrides Sub Stop
[<AdapterCommandAttribute("Stops the statistics engine.", new string[] { ... })>]
abstract Stop : unit -> unit
[<AdapterCommandAttribute("Stops the statistics engine.", new string[] { ... })>]
override Stop : unit -> unit
function Stop();
public:
[AdapterCommandAttribute(L"Stops the statistics engine.", __gc new array<String^>^ { ... })]
virtual void Stop() override

Implements

IAdapterStop
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Unregister Method

Grid Solutions Framework StatisticsEngineUnregister Method
Unregisters the given source, removing it from the list of statistic sources so that it no longer generates statistics.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Unregister(
    Object source
)
Public Shared Sub Unregister (
    source As Object
)
static member Unregister :
        source : Object -> unit

GSF.TimeSeries.Statistics.StatisticsEngine.Unregister = function(source);
public:
static void Unregister(
    Object^ source
)

Parameters

source
Type: SystemObject
The adapter to be unregistered with the statistics engine.
Remarks
Sources that implement IAdapter do not need to explicitly unregister themselves from the statistics engine. The engine automatically unregisters them by attaching to the Disposed event.
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine Properties

Grid Solutions Framework StatisticsEngine Properties

The StatisticsEngine type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to the StatisticsEngine. (Overrides AdapterBaseDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | FramesPerSecond | Gets or sets the frames per second to be used by the FacileActionAdapterBase. (Inherited from FacileActionAdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the FacileActionAdapterBase expects, if any. (Inherited from FacileActionAdapterBase.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from FacileActionAdapterBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from FacileActionAdapterBase.)
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement. (Inherited from FacileActionAdapterBase.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from FacileActionAdapterBase.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from FacileActionAdapterBase.)
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the statistics engine. (Overrides FacileActionAdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real time. (Inherited from FacileActionAdapterBase.)
Top
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.DataSource Property

Grid Solutions Framework StatisticsEngineDataSource Property
Gets or sets DataSet based data source available to the StatisticsEngine.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSet DataSource { get; set; }
Public Overrides Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get () override;
    void set (DataSet^ value) override;
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Status Property

Grid Solutions Framework StatisticsEngineStatus Property
Returns the detailed status of the statistics engine.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.SupportsTemporalProcessing Property

Grid Solutions Framework StatisticsEngineSupportsTemporalProcessing Property
Gets the flag indicating if this adapter supports temporal processing.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get
override SupportsTemporalProcessing : bool with get
function get_SupportsTemporalProcessing();

public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IAdapterSupportsTemporalProcessing
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine Events

Grid Solutions Framework StatisticsEngine Events

The StatisticsEngine type exposes the following members.

Events
 | Name | Description
 | BeforeCalculate | Event is raised before statistics calculation.
 | Calculated | Event is raised after statistics calculation.
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from FacileActionAdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from action adapter. (Inherited from FacileActionAdapterBase.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnpublishedSamples | This event is raised by derived class, if needed, to track current number of unpublished seconds of data in the queue. (Inherited from FacileActionAdapterBase.)
Top
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.BeforeCalculate Event

Grid Solutions Framework StatisticsEngineBeforeCalculate Event
Event is raised before statistics calculation.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static event EventHandler BeforeCalculate
Public Shared Event BeforeCalculate As EventHandler
member BeforeCalculate : IEvent<EventHandler,
    EventArgs>

function add_BeforeCalculate(value);
function remove_BeforeCalculate(value);
public:
static  event EventHandler^ BeforeCalculate {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticsEngine.Calculated Event

Grid Solutions Framework StatisticsEngineCalculated Event
Event is raised after statistics calculation.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static event EventHandler Calculated
Public Shared Event Calculated As EventHandler
member Calculated : IEvent<EventHandler,
    EventArgs>

function add_Calculated(value);
function remove_Calculated(value);
public:
static  event EventHandler^ Calculated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

StatisticsEngine Class
GSF.TimeSeries.Statistics Namespace


StatisticValueState Class

Grid Solutions Framework StatisticValueState Class
Represents an object that can track the current and previous state of a statistic and get the difference between them.
Inheritance Hierarchy
SystemObject
GSFObjectState Double
GSF.TimeSeries.StatisticsStatisticValueState

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class StatisticValueState : ObjectState<double>
Public Class StatisticValueState
    Inherits ObjectState(Of Double)
type StatisticValueState =
    class
        inherit ObjectState<float>
    end
GSF.TimeSeries.Statistics.StatisticValueState = function();

Type.createClass(
    'GSF.TimeSeries.Statistics.StatisticValueState',
    GSF.ObjectState`1);
public ref class StatisticValueState : public ObjectState<double>

The StatisticValueState type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticValueState | Creates a new StatisticValueState.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDifference | Gets the statistical difference between current and previous statistic value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current state of the object. (Inherited from ObjectStateTState.)
Public property | ObjectName | Gets or sets a text label for the object whose state is being tracked. (Inherited from ObjectStateTState.)
Public property | PreviousState | Gets or sets the previous state of the object. (Inherited from ObjectStateTState.)
Top
See Also

Reference

GSF.TimeSeries.Statistics Namespace


StatisticValueState Constructor

Grid Solutions Framework StatisticValueState Constructor
Creates a new StatisticValueState.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatisticValueState(
    string name
)
Public Sub New (
    name As String
)
new :
        name : string -> StatisticValueState
GSF.TimeSeries.Statistics.StatisticValueState = function(name);
public:
StatisticValueState(
    String^ name
)

Parameters

name
Type: SystemString
Name of statistic.
See Also

Reference

StatisticValueState Class
GSF.TimeSeries.Statistics Namespace


StatisticValueState Methods

Grid Solutions Framework StatisticValueState Methods

The StatisticValueState type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDifference | Gets the statistical difference between current and previous statistic value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

StatisticValueState Class
GSF.TimeSeries.Statistics Namespace


StatisticValueState.GetDifference Method

Grid Solutions Framework StatisticValueStateGetDifference Method
Gets the statistical difference between current and previous statistic value.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double GetDifference()
Public Function GetDifference As Double
member GetDifference : unit -> float

function GetDifference();
public:
double GetDifference()

Return Value

Type: Double
Difference from last cached statistic value.
See Also

Reference

StatisticValueState Class
GSF.TimeSeries.Statistics Namespace


StatisticValueState Properties

Grid Solutions Framework StatisticValueState Properties

The StatisticValueState type exposes the following members.

Properties
 | Name | Description
Public property | CurrentState | Gets or sets the current state of the object. (Inherited from ObjectStateTState.)
Public property | ObjectName | Gets or sets a text label for the object whose state is being tracked. (Inherited from ObjectStateTState.)
Public property | PreviousState | Gets or sets the previous state of the object. (Inherited from ObjectStateTState.)
Top
See Also

Reference

StatisticValueState Class
GSF.TimeSeries.Statistics Namespace


StatisticValueStateCache Class

Grid Solutions Framework StatisticValueStateCache Class
Caches statistic values to provide the difference between the current and previous values of any statistic given that statistic's source, name, and current value.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.StatisticsStatisticValueStateCache

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class StatisticValueStateCache
Public Class StatisticValueStateCache
type StatisticValueStateCache =  class end
GSF.TimeSeries.Statistics.StatisticValueStateCache = function();

Type.createClass(
    'GSF.TimeSeries.Statistics.StatisticValueStateCache');
public ref class StatisticValueStateCache

The StatisticValueStateCache type exposes the following members.

Constructors
 | Name | Description
Public method | StatisticValueStateCache | Creates a new instance of the StatisticValueStateCache.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDifference | Gets the statistical difference between current and previous statistic value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.TimeSeries.Statistics Namespace


StatisticValueStateCache Constructor

Grid Solutions Framework StatisticValueStateCache Constructor
Creates a new instance of the StatisticValueStateCache.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public StatisticValueStateCache()
Public Sub New
new : unit -> StatisticValueStateCache
GSF.TimeSeries.Statistics.StatisticValueStateCache = function();
public:
StatisticValueStateCache()
See Also

Reference

StatisticValueStateCache Class
GSF.TimeSeries.Statistics Namespace


StatisticValueStateCache Methods

Grid Solutions Framework StatisticValueStateCache Methods

The StatisticValueStateCache type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetDifference | Gets the statistical difference between current and previous statistic value.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

StatisticValueStateCache Class
GSF.TimeSeries.Statistics Namespace


StatisticValueStateCache.GetDifference Method

Grid Solutions Framework StatisticValueStateCacheGetDifference Method
Gets the statistical difference between current and previous statistic value.

Namespace: GSF.TimeSeries.Statistics
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double GetDifference(
    Object source,
    double statistic,
    string name
)
Public Function GetDifference (
    source As Object,
    statistic As Double,
    name As String
) As Double
member GetDifference :
        source : Object *
        statistic : float *
        name : string -> float

function GetDifference(source, statistic, name);
public:
double GetDifference(
    Object^ source,
    double statistic,
    String^ name
)

Parameters

source
Type: SystemObject
Source Device.
statistic
Type: SystemDouble
Current statistic value.
name
Type: SystemString
Name of statistic calculation.

Return Value

Type: Double
Difference from last cached statistic value.
See Also

Reference

StatisticValueStateCache Class
GSF.TimeSeries.Statistics Namespace


GSF.TimeSeries.Transport Namespace

Grid Solutions Framework GSF.TimeSeries.Transport Namespace

[Missing <summary> documentation for "N:GSF.TimeSeries.Transport"]

Classes
 | Class | Description
Public class | ClientConnection | Represents a DataSubscriber client connection to the DataPublisher.
Public class | Common | Common static methods and extensions for transport library.
Public class | CompactMeasurement | Represents a IMeasurement that can be serialized with minimal size.
Public class | CompactMeasurementExtensions | Defines extension functions related to CompactMeasurement.
Public class | DataGapRecoverer | Represents a data gap recovery module.
Public class | DataPublisher | Represents a data publishing server that allows multiple connections for data subscriptions.
Public class | DataSubscriber | Represents a data subscribing client that will connect to a data publisher for a data subscription.
Public class | IClientSubscriptionExtensions | Defines static extension functions for IClientSubscription implementations.
Public class | SerializableMeasurement | Represents a IMeasurement that can be serialized.
Public class | SignalIndexCache | Represents a serializable Guid signal ID to UInt16 index cross reference.
Public class | SourceDevice | Represents a device which acts as a source for measurements provided to a DataSubscriber.
Public class | SubscriptionInfo | Configuration object for data subscriptions.
Public class | SynchronizedSubscriptionInfo | Configuration object for synchronized data subscriptions.
Public class | TemporalClientSubscriptionProxy | Represents an action adapter that exists within a temporal IaonSession to proxy data back to its parent IClientSubscription instance.
Public class | UnsynchronizedSubscriptionInfo | Configuration object for unsynchronized data subscriptions.
Interfaces
 | Interface | Description
Public interface | IBinaryMeasurement | Defines a IMeasurement that supports ISupportBinaryImage.
Public interface | IClientSubscription | Represents a common set of interfaces for a client adapter subscription to the DataPublisher.
Enumerations
 | Enumeration | Description
Public enumeration | DataPacketFlags | DataPublisher data packet flags.
Public enumeration | GatewayCompressionMode | Enumeration for compression modes supported by the Gateway Exchange Protocol.
Public enumeration | OperationalEncoding | Enumeration for character encodings supported by the Gateway Exchange Protocol.
Public enumeration | OperationalModes | Operational modes that affect how DataPublisher and DataSubscriber communicate.
Public enumeration | SecurityMode | Security modes used by the DataPublisher to secure data sent over the command channel.
Public enumeration | ServerCommand | Server commands received by DataPublisher and sent by DataSubscriber.
Public enumeration | ServerResponse | Server responses sent by DataPublisher and received by DataSubscriber.


ClientConnection Class

Grid Solutions Framework ClientConnection Class
Represents a DataSubscriber client connection to the DataPublisher.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportClientConnection

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ClientConnection : IProvideStatus,
    IDisposable
Public Class ClientConnection
    Implements IProvideStatus, IDisposable
type ClientConnection =
    class
        interface IProvideStatus
        interface IDisposable
    end
GSF.TimeSeries.Transport.ClientConnection = function();

Type.createClass(
    'GSF.TimeSeries.Transport.ClientConnection',
    null,
    GSF.IProvideStatus,
    IDisposable);
public ref class ClientConnection : IProvideStatus,
    IDisposable

The ClientConnection type exposes the following members.

Constructors
 | Name | Description
Public method | ClientConnection | Creates a new ClientConnection instance.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the ClientConnection object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ClientConnection object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ClientConnection object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetCommandChannelSocket | Gets the Socket instance used by this client connection to send and receive data over the command channel.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RotateCipherKeys | Rotates or initializes the crypto keys for this ClientConnection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Authenticated | Gets or sets authenticated state of this ClientConnection.
Public property | CipherIndex | Gets current cipher index.
Public property | ClientID | Gets client ID of this ClientConnection.
Public property | CommandChannel | Gets IServer command channel.
Public property | ConnectionID | Gets the connection identification of this ClientConnection.
Public property | DataChannel | Gets or sets reference to UdpServer data channel, attaching to or detaching from events as needed, associated with this ClientConnection.
Public property | Encoding | Character encoding used to send messages to subscriber.
Public property | IPAddress | Gets the IP address of the remote client connection.
Public property | IsConnected | Gets connected state of the associated client socket.
Public property | IsSubscribed | Gets or sets IsSubscribed state.
Public property | KeyIVs | Gets active and standby keys and initialization vectors.
Public property | LastCipherKeyUpdateTime | Gets time of last cipher key update.
Public property | Name | Gets the subscriber name of this ClientConnection.
Public property | OperationalModes | Gets or sets a set of flags that define ways in which the subscriber and publisher communicate.
Public property | PublishChannel | Gets IServer publication channel - that is, data channel if defined otherwise command channel.
Public property | SharedSecret | Gets or sets shared secret used to lookup cipher keys only known to client and server.
Public property | Status | Gets a formatted message describing the status of this ClientConnection.
Public property | SubscriberAcronym | Gets or sets the subscriber acronym of this ClientConnection.
Public property | SubscriberID | Gets or sets the Guid based subscriber ID of this ClientConnection.
Public property | SubscriberInfo | Gets or sets subscriber info for this ClientConnection.
Public property | SubscriberName | Gets or sets the subscriber name of this ClientConnection.
Public property | Subscription | Gets or sets subscription associated with this ClientConnection.
Public property | ValidIPAddresses | Gets or sets the list of valid IP addresses that this client can connect from.
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


ClientConnection Constructor

Grid Solutions Framework ClientConnection Constructor
Creates a new ClientConnection instance.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ClientConnection(
    DataPublisher parent,
    Guid clientID,
    IServer commandChannel
)
Public Sub New (
    parent As DataPublisher,
    clientID As Guid,
    commandChannel As IServer
)
new :
        parent : DataPublisher *
        clientID : Guid *
        commandChannel : IServer -> ClientConnection
GSF.TimeSeries.Transport.ClientConnection = function(parent, clientID, commandChannel);
public:
ClientConnection(
    DataPublisher^ parent,
    Guid clientID,
    IServer^ commandChannel
)

Parameters

parent
Type: GSF.TimeSeries.TransportDataPublisher
Parent data publisher.
clientID
Type: SystemGuid
Client ID of associated connection.
commandChannel
Type: GSF.CommunicationIServer
TcpServer command channel used to lookup connection information.
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection Methods

Grid Solutions Framework ClientConnection Methods

The ClientConnection type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the ClientConnection object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ClientConnection object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the ClientConnection object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | GetCommandChannelSocket | Gets the Socket instance used by this client connection to send and receive data over the command channel.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | RotateCipherKeys | Rotates or initializes the crypto keys for this ClientConnection.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.Dispose Method

Grid Solutions Framework ClientConnectionDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the ClientConnection object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ClientConnection object and optionally releases the managed resources.
Top
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.Dispose Method

Grid Solutions Framework ClientConnectionDispose Method
Releases all the resources used by the ClientConnection object.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

ClientConnection Class
Dispose Overload
GSF.TimeSeries.Transport Namespace


ClientConnection.Dispose Method (Boolean)

Grid Solutions Framework ClientConnectionDispose Method (Boolean)
Releases the unmanaged resources used by the ClientConnection object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

ClientConnection Class
Dispose Overload
GSF.TimeSeries.Transport Namespace


ClientConnection.Finalize Method

Grid Solutions Framework ClientConnectionFinalize Method
Releases the unmanaged resources before the ClientConnection object is reclaimed by GC.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.GetCommandChannelSocket Method

Grid Solutions Framework ClientConnectionGetCommandChannelSocket Method
Gets the Socket instance used by this client connection to send and receive data over the command channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Socket GetCommandChannelSocket()
Public Function GetCommandChannelSocket As Socket
member GetCommandChannelSocket : unit -> Socket

function GetCommandChannelSocket();
public:
Socket^ GetCommandChannelSocket()

Return Value

Type: Socket
The socket instance used by the client to send and receive data over the command channel.
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.RotateCipherKeys Method

Grid Solutions Framework ClientConnectionRotateCipherKeys Method
Rotates or initializes the crypto keys for this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RotateCipherKeys()
Public Function RotateCipherKeys As Boolean
member RotateCipherKeys : unit -> bool

function RotateCipherKeys();
public:
bool RotateCipherKeys()

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.TimeSeries.Transport.ClientConnection.RotateCipherKeys"]

See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection Properties

Grid Solutions Framework ClientConnection Properties

The ClientConnection type exposes the following members.

Properties
 | Name | Description
Public property | Authenticated | Gets or sets authenticated state of this ClientConnection.
Public property | CipherIndex | Gets current cipher index.
Public property | ClientID | Gets client ID of this ClientConnection.
Public property | CommandChannel | Gets IServer command channel.
Public property | ConnectionID | Gets the connection identification of this ClientConnection.
Public property | DataChannel | Gets or sets reference to UdpServer data channel, attaching to or detaching from events as needed, associated with this ClientConnection.
Public property | Encoding | Character encoding used to send messages to subscriber.
Public property | IPAddress | Gets the IP address of the remote client connection.
Public property | IsConnected | Gets connected state of the associated client socket.
Public property | IsSubscribed | Gets or sets IsSubscribed state.
Public property | KeyIVs | Gets active and standby keys and initialization vectors.
Public property | LastCipherKeyUpdateTime | Gets time of last cipher key update.
Public property | Name | Gets the subscriber name of this ClientConnection.
Public property | OperationalModes | Gets or sets a set of flags that define ways in which the subscriber and publisher communicate.
Public property | PublishChannel | Gets IServer publication channel - that is, data channel if defined otherwise command channel.
Public property | SharedSecret | Gets or sets shared secret used to lookup cipher keys only known to client and server.
Public property | Status | Gets a formatted message describing the status of this ClientConnection.
Public property | SubscriberAcronym | Gets or sets the subscriber acronym of this ClientConnection.
Public property | SubscriberID | Gets or sets the Guid based subscriber ID of this ClientConnection.
Public property | SubscriberInfo | Gets or sets subscriber info for this ClientConnection.
Public property | SubscriberName | Gets or sets the subscriber name of this ClientConnection.
Public property | Subscription | Gets or sets subscription associated with this ClientConnection.
Public property | ValidIPAddresses | Gets or sets the list of valid IP addresses that this client can connect from.
Top
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.Authenticated Property

Grid Solutions Framework ClientConnectionAuthenticated Property
Gets or sets authenticated state of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Authenticated { get; set; }
Public Property Authenticated As Boolean
    Get
    Set
member Authenticated : bool with get, set

function get_Authenticated();
function set_Authenticated(value);
public:
property bool Authenticated {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.CipherIndex Property

Grid Solutions Framework ClientConnectionCipherIndex Property
Gets current cipher index.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CipherIndex { get; }
Public ReadOnly Property CipherIndex As Integer
    Get
member CipherIndex : int with get

function get_CipherIndex();

public:
property int CipherIndex {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.ClientID Property

Grid Solutions Framework ClientConnectionClientID Property
Gets client ID of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid ClientID { get; }
Public ReadOnly Property ClientID As Guid
    Get
member ClientID : Guid with get

function get_ClientID();

public:
property Guid ClientID {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.CommandChannel Property

Grid Solutions Framework ClientConnectionCommandChannel Property
Gets IServer command channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IServer CommandChannel { get; }
Public ReadOnly Property CommandChannel As IServer
    Get
member CommandChannel : IServer with get

function get_CommandChannel();

public:
property IServer^ CommandChannel {
    IServer^ get ();
}

Property Value

Type: IServer
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.ConnectionID Property

Grid Solutions Framework ClientConnectionConnectionID Property
Gets the connection identification of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionID { get; }
Public ReadOnly Property ConnectionID As String
    Get
member ConnectionID : string with get

function get_ConnectionID();

public:
property String^ ConnectionID {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.DataChannel Property

Grid Solutions Framework ClientConnectionDataChannel Property
Gets or sets reference to UdpServer data channel, attaching to or detaching from events as needed, associated with this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UdpServer DataChannel { get; set; }
Public Property DataChannel As UdpServer
    Get
    Set
member DataChannel : UdpServer with get, set

function get_DataChannel();
function set_DataChannel(value);
public:
property UdpServer^ DataChannel {
    UdpServer^ get ();
    void set (UdpServer^ value);
}

Property Value

Type: UdpServer
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.Encoding Property

Grid Solutions Framework ClientConnectionEncoding Property
Character encoding used to send messages to subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Encoding Encoding { get; }
Public ReadOnly Property Encoding As Encoding
    Get
member Encoding : Encoding with get

function get_Encoding();

public:
property Encoding^ Encoding {
    Encoding^ get ();
}

Property Value

Type: Encoding
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.IPAddress Property

Grid Solutions Framework ClientConnectionIPAddress Property
Gets the IP address of the remote client connection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IPAddress IPAddress { get; }
Public ReadOnly Property IPAddress As IPAddress
    Get
member IPAddress : IPAddress with get

function get_IPAddress();

public:
property IPAddress^ IPAddress {
    IPAddress^ get ();
}

Property Value

Type: IPAddress
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.IsConnected Property

Grid Solutions Framework ClientConnectionIsConnected Property
Gets connected state of the associated client socket.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
member IsConnected : bool with get

function get_IsConnected();

public:
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.IsSubscribed Property

Grid Solutions Framework ClientConnectionIsSubscribed Property
Gets or sets IsSubscribed state.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsSubscribed { get; set; }
Public Property IsSubscribed As Boolean
    Get
    Set
member IsSubscribed : bool with get, set

function get_IsSubscribed();
function set_IsSubscribed(value);
public:
property bool IsSubscribed {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.KeyIVs Property

Grid Solutions Framework ClientConnectionKeyIVs Property
Gets active and standby keys and initialization vectors.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte[][][] KeyIVs { get; }
Public ReadOnly Property KeyIVs As Byte()()()
    Get
member KeyIVs : byte[][][] with get

function get_KeyIVs();

public:
property array<array<array<unsigned char>^>^>^ KeyIVs {
    array<array<array<unsigned char>^>^>^ get ();
}

Property Value

Type: Byte
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.LastCipherKeyUpdateTime Property

Grid Solutions Framework ClientConnectionLastCipherKeyUpdateTime Property
Gets time of last cipher key update.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks LastCipherKeyUpdateTime { get; }
Public ReadOnly Property LastCipherKeyUpdateTime As Ticks
    Get
member LastCipherKeyUpdateTime : Ticks with get

function get_LastCipherKeyUpdateTime();

public:
property Ticks LastCipherKeyUpdateTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.Name Property

Grid Solutions Framework ClientConnectionName Property
Gets the subscriber name of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Name { get; }
Public ReadOnly Property Name As String
    Get
abstract Name : string with get
override Name : string with get
function get_Name();

public:
virtual property String^ Name {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusName
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.OperationalModes Property

Grid Solutions Framework ClientConnectionOperationalModes Property
Gets or sets a set of flags that define ways in which the subscriber and publisher communicate.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OperationalModes OperationalModes { get; set; }
Public Property OperationalModes As OperationalModes
    Get
    Set
member OperationalModes : OperationalModes with get, set

function get_OperationalModes();
function set_OperationalModes(value);
public:
property OperationalModes OperationalModes {
    OperationalModes get ();
    void set (OperationalModes value);
}

Property Value

Type: OperationalModes
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.PublishChannel Property

Grid Solutions Framework ClientConnectionPublishChannel Property
Gets IServer publication channel - that is, data channel if defined otherwise command channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IServer PublishChannel { get; }
Public ReadOnly Property PublishChannel As IServer
    Get
member PublishChannel : IServer with get

function get_PublishChannel();

public:
property IServer^ PublishChannel {
    IServer^ get ();
}

Property Value

Type: IServer
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.SharedSecret Property

Grid Solutions Framework ClientConnectionSharedSecret Property
Gets or sets shared secret used to lookup cipher keys only known to client and server.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SharedSecret { get; set; }
Public Property SharedSecret As String
    Get
    Set
member SharedSecret : string with get, set

function get_SharedSecret();
function set_SharedSecret(value);
public:
property String^ SharedSecret {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.Status Property

Grid Solutions Framework ClientConnectionStatus Property
Gets a formatted message describing the status of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.SubscriberAcronym Property

Grid Solutions Framework ClientConnectionSubscriberAcronym Property
Gets or sets the subscriber acronym of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SubscriberAcronym { get; set; }
Public Property SubscriberAcronym As String
    Get
    Set
member SubscriberAcronym : string with get, set

function get_SubscriberAcronym();
function set_SubscriberAcronym(value);
public:
property String^ SubscriberAcronym {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.SubscriberID Property

Grid Solutions Framework ClientConnectionSubscriberID Property
Gets or sets the Guid based subscriber ID of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid SubscriberID { get; set; }
Public Property SubscriberID As Guid
    Get
    Set
member SubscriberID : Guid with get, set

function get_SubscriberID();
function set_SubscriberID(value);
public:
property Guid SubscriberID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.SubscriberInfo Property

Grid Solutions Framework ClientConnectionSubscriberInfo Property
Gets or sets subscriber info for this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SubscriberInfo { get; set; }
Public Property SubscriberInfo As String
    Get
    Set
member SubscriberInfo : string with get, set

function get_SubscriberInfo();
function set_SubscriberInfo(value);
public:
property String^ SubscriberInfo {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.SubscriberName Property

Grid Solutions Framework ClientConnectionSubscriberName Property
Gets or sets the subscriber name of this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SubscriberName { get; set; }
Public Property SubscriberName As String
    Get
    Set
member SubscriberName : string with get, set

function get_SubscriberName();
function set_SubscriberName(value);
public:
property String^ SubscriberName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.Subscription Property

Grid Solutions Framework ClientConnectionSubscription Property
Gets or sets subscription associated with this ClientConnection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IClientSubscription Subscription { get; set; }
Public Property Subscription As IClientSubscription
    Get
    Set
member Subscription : IClientSubscription with get, set

function get_Subscription();
function set_Subscription(value);
public:
property IClientSubscription^ Subscription {
    IClientSubscription^ get ();
    void set (IClientSubscription^ value);
}

Property Value

Type: IClientSubscription
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


ClientConnection.ValidIPAddresses Property

Grid Solutions Framework ClientConnectionValidIPAddresses Property
Gets or sets the list of valid IP addresses that this client can connect from.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public List<IPAddress> ValidIPAddresses { get; set; }
Public Property ValidIPAddresses As List(Of IPAddress)
    Get
    Set
member ValidIPAddresses : List<IPAddress> with get, set

function get_ValidIPAddresses();
function set_ValidIPAddresses(value);
public:
property List<IPAddress^>^ ValidIPAddresses {
    List<IPAddress^>^ get ();
    void set (List<IPAddress^>^ value);
}

Property Value

Type: List IPAddress
See Also

Reference

ClientConnection Class
GSF.TimeSeries.Transport Namespace


Common Class

Grid Solutions Framework Common Class
Common static methods and extensions for transport library.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportCommon

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class Common
<ExtensionAttribute>
Public NotInheritable Class Common
[<AbstractClassAttribute>]
[<SealedAttribute>]
type Common =  class end
GSF.TimeSeries.Transport.Common = function();

Type.createClass(
    'GSF.TimeSeries.Transport.Common');
[ExtensionAttribute]
public ref class Common abstract sealed

The Common type exposes the following members.

Methods
Name | Description
IsSolicited | Returns true if ServerResponse code is for a solicited ServerCommand.
Top
Properties
Name | Description
SymmetricAlgorithm | Gets an AES symmetric algorithm to use for encryption or decryption.
UseManagedEncryption | Gets flag that determines if managed encryption should be used.
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


Common Methods

Grid Solutions Framework Common Methods

The Common type exposes the following members.

Methods
Name | Description
IsSolicited | Returns true if ServerResponse code is for a solicited ServerCommand.
Top
See Also

Reference

Common Class
GSF.TimeSeries.Transport Namespace


Common.IsSolicited Method

Grid Solutions Framework CommonIsSolicited Method
Returns true if ServerResponse code is for a solicited ServerCommand.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool IsSolicited(
    this ServerResponse responseCode
)
<ExtensionAttribute>
Public Shared Function IsSolicited (
    responseCode As ServerResponse
) As Boolean
static member IsSolicited :
        responseCode : ServerResponse -> bool

GSF.TimeSeries.Transport.Common.IsSolicited = function(responseCode);
public:
[ExtensionAttribute]
static bool IsSolicited(
    ServerResponse responseCode
)

Parameters

responseCode
Type: GSF.TimeSeries.TransportServerResponse
ServerResponse code to test.

Return Value

Type: Boolean
true if ServerResponse code is for a solicited ServerCommand; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type ServerResponse. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Only the Succeeded and Failed response codes are from solicited server commands.
See Also

Reference

Common Class
GSF.TimeSeries.Transport Namespace


Common Properties

Grid Solutions Framework Common Properties

The Common type exposes the following members.

Properties
Name | Description
SymmetricAlgorithm | Gets an AES symmetric algorithm to use for encryption or decryption.
UseManagedEncryption | Gets flag that determines if managed encryption should be used.
Top
See Also

Reference

Common Class
GSF.TimeSeries.Transport Namespace


Common.SymmetricAlgorithm Property

Grid Solutions Framework CommonSymmetricAlgorithm Property
Gets an AES symmetric algorithm to use for encryption or decryption.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SymmetricAlgorithm SymmetricAlgorithm { get; }
Public Shared ReadOnly Property SymmetricAlgorithm As SymmetricAlgorithm
    Get
static member SymmetricAlgorithm : SymmetricAlgorithm with get

GSF.TimeSeries.Transport.Common.get_SymmetricAlgorithm = function();

public:
static property SymmetricAlgorithm^ SymmetricAlgorithm {
    SymmetricAlgorithm^ get ();
}

Property Value

Type: SymmetricAlgorithm
See Also

Reference

Common Class
GSF.TimeSeries.Transport Namespace


Common.UseManagedEncryption Property

Grid Solutions Framework CommonUseManagedEncryption Property
Gets flag that determines if managed encryption should be used.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool UseManagedEncryption { get; }
Public Shared ReadOnly Property UseManagedEncryption As Boolean
    Get
static member UseManagedEncryption : bool with get

GSF.TimeSeries.Transport.Common.get_UseManagedEncryption = function();

public:
static property bool UseManagedEncryption {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

Common Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement Class

Grid Solutions Framework CompactMeasurement Class
Represents a IMeasurement that can be serialized with minimal size.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesMeasurement
GSF.TimeSeries.TransportCompactMeasurement

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class CompactMeasurement : Measurement,
    IBinaryMeasurement, IMeasurement, ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>,
    IComparable<ITimeSeriesValue>, IComparable, ISupportBinaryImage
Public Class CompactMeasurement
    Inherits Measurement
    Implements IBinaryMeasurement, IMeasurement, ITimeSeriesValue(Of Double),
    ITimeSeriesValue, IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue),
    IComparable, ISupportBinaryImage
type CompactMeasurement =
    class
        inherit Measurement
        interface IBinaryMeasurement
        interface IMeasurement
        interface ITimeSeriesValue<float>
        interface ITimeSeriesValue
        interface IEquatable<ITimeSeriesValue>
        interface IComparable<ITimeSeriesValue>
        interface IComparable
        interface ISupportBinaryImage
    end
GSF.TimeSeries.Transport.CompactMeasurement = function();

Type.createClass(
    'GSF.TimeSeries.Transport.CompactMeasurement',
    GSF.TimeSeries.Measurement,
    GSF.TimeSeries.Transport.IBinaryMeasurement,
    GSF.TimeSeries.IMeasurement,
    GSF.TimeSeries.ITimeSeriesValue`1,
    GSF.TimeSeries.ITimeSeriesValue,
    IEquatable`1,
    IComparable`1,
    IComparable,
    GSF.Parsing.ISupportBinaryImage);
public ref class CompactMeasurement : public Measurement,
    IBinaryMeasurement, IMeasurement, ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>,
    IComparable<ITimeSeriesValue^>, IComparable, ISupportBinaryImage

The CompactMeasurement type exposes the following members.

Constructors
 | Name | Description
Public method | CompactMeasurement(SignalIndexCache, Boolean, Int64, Int32, Boolean) | Creates a new CompactMeasurement.
Public method | CompactMeasurement(IMeasurement, SignalIndexCache, Boolean, Int64, Int32, Boolean) | Creates a new CompactMeasurement from an existing IMeasurement value.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the CompactMeasurement and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes CompactMeasurement from the specified binary image.
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
Fields
Name | Description
FixedLength | Fixed byte length of a CompactMeasurement.
Top
Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | BinaryLength | Gets the length of the CompactMeasurement.
Public property | CompactStateFlags | Gets or sets byte level compact state flags with encoded time index and base time offset bits.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | IncludeTime | Gets flag that determines if time is serialized into measurement binary image.
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | RuntimeID | Gets or sets the 2-byte run-time signal index for this measurement.
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | TimestampC2 | Gets offset compressed millisecond-resolution 2-byte timestamp.
Public property | TimestampC4 | Gets offset compressed tick-resolution 4-byte timestamp.
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
Remarks
This measurement implementation is serialized through ISupportBinaryImage to allow complete control of binary format. Only critical measurements properties are serialized and every attempt is made to optimize the binary image for purposes of size reduction.
See Also

Reference

GSF.TimeSeries.Transport Namespace


CompactMeasurement Constructor

Grid Solutions Framework CompactMeasurement Constructor
Overload List
 | Name | Description
Public method | CompactMeasurement(SignalIndexCache, Boolean, Int64, Int32, Boolean) | Creates a new CompactMeasurement.
Public method | CompactMeasurement(IMeasurement, SignalIndexCache, Boolean, Int64, Int32, Boolean) | Creates a new CompactMeasurement from an existing IMeasurement value.
Top
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement Constructor (SignalIndexCache, Boolean, Int64[], Int32, Boolean)

Grid Solutions Framework CompactMeasurement Constructor (SignalIndexCache, Boolean, Int64, Int32, Boolean)
Creates a new CompactMeasurement.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompactMeasurement(
    SignalIndexCache signalIndexCache,
    bool includeTime = true,
    long[] baseTimeOffsets = null,
    int timeIndex = 0,
    bool useMillisecondResolution = false
)
Public Sub New (
    signalIndexCache As SignalIndexCache,
    Optional includeTime As Boolean = true,
    Optional baseTimeOffsets As Long() = Nothing,
    Optional timeIndex As Integer = 0,
    Optional useMillisecondResolution As Boolean = false
)
new :
        signalIndexCache : SignalIndexCache *
        ?includeTime : bool *
        ?baseTimeOffsets : int64[] *
        ?timeIndex : int *
        ?useMillisecondResolution : bool
(* Defaults:
        let _includeTime = defaultArg includeTime true
        let _baseTimeOffsets = defaultArg baseTimeOffsets null
        let _timeIndex = defaultArg timeIndex 0
        let _useMillisecondResolution = defaultArg useMillisecondResolution false
*)
-> CompactMeasurement
GSF.TimeSeries.Transport.CompactMeasurement = function(signalIndexCache, includeTime, baseTimeOffsets, timeIndex, useMillisecondResolution);
public:
CompactMeasurement(
    SignalIndexCache^ signalIndexCache,
    bool includeTime = true,
    array<long long>^ baseTimeOffsets = nullptr,
    int timeIndex = 0,
    bool useMillisecondResolution = false
)

Parameters

signalIndexCache
Type: GSF.TimeSeries.TransportSignalIndexCache
Signal index cache used to serialize or deserialize runtime information.
includeTime (Optional)
Type: SystemBoolean
Set to true to include time in serialized packet; otherwise false.
baseTimeOffsets (Optional)
Type: SystemInt64
Base time offset array - set to null to use full fidelity measurement time.
timeIndex (Optional)
Type: SystemInt32
Time index to use for base offset.
useMillisecondResolution (Optional)
Type: SystemBoolean
Flag that determines if millisecond resolution is in use for this serialization.
See Also

Reference

CompactMeasurement Class
CompactMeasurement Overload
GSF.TimeSeries.Transport Namespace


CompactMeasurement Constructor (IMeasurement, SignalIndexCache, Boolean, Int64[], Int32, Boolean)

Grid Solutions Framework CompactMeasurement Constructor (IMeasurement, SignalIndexCache, Boolean, Int64, Int32, Boolean)
Creates a new CompactMeasurement from an existing IMeasurement value.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public CompactMeasurement(
    IMeasurement measurement,
    SignalIndexCache signalIndexCache,
    bool includeTime = true,
    long[] baseTimeOffsets = null,
    int timeIndex = 0,
    bool useMillisecondResolution = false
)
Public Sub New (
    measurement As IMeasurement,
    signalIndexCache As SignalIndexCache,
    Optional includeTime As Boolean = true,
    Optional baseTimeOffsets As Long() = Nothing,
    Optional timeIndex As Integer = 0,
    Optional useMillisecondResolution As Boolean = false
)
new :
        measurement : IMeasurement *
        signalIndexCache : SignalIndexCache *
        ?includeTime : bool *
        ?baseTimeOffsets : int64[] *
        ?timeIndex : int *
        ?useMillisecondResolution : bool
(* Defaults:
        let _includeTime = defaultArg includeTime true
        let _baseTimeOffsets = defaultArg baseTimeOffsets null
        let _timeIndex = defaultArg timeIndex 0
        let _useMillisecondResolution = defaultArg useMillisecondResolution false
*)
-> CompactMeasurement
GSF.TimeSeries.Transport.CompactMeasurement = function(measurement, signalIndexCache, includeTime, baseTimeOffsets, timeIndex, useMillisecondResolution);
public:
CompactMeasurement(
    IMeasurement^ measurement,
    SignalIndexCache^ signalIndexCache,
    bool includeTime = true,
    array<long long>^ baseTimeOffsets = nullptr,
    int timeIndex = 0,
    bool useMillisecondResolution = false
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Source IMeasurement value.
signalIndexCache
Type: GSF.TimeSeries.TransportSignalIndexCache
Signal index cache used to serialize or deserialize runtime information.
includeTime (Optional)
Type: SystemBoolean
Set to true to include time in serialized packet; otherwise false.
baseTimeOffsets (Optional)
Type: SystemInt64
Base time offset array - set to null to use full fidelity measurement time.
timeIndex (Optional)
Type: SystemInt32
Time index to use for base offset.
useMillisecondResolution (Optional)
Type: SystemBoolean
Flag that determines if millisecond resolution is in use for this serialization.
See Also

Reference

CompactMeasurement Class
CompactMeasurement Overload
GSF.TimeSeries.Transport Namespace


CompactMeasurement Fields

Grid Solutions Framework CompactMeasurement Fields

The CompactMeasurement type exposes the following members.

Fields
Name | Description
FixedLength | Fixed byte length of a CompactMeasurement.
Top
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.FixedLength Field

Grid Solutions Framework CompactMeasurementFixedLength Field
Fixed byte length of a CompactMeasurement.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.TimeSeries.Transport.CompactMeasurement.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement Methods

Grid Solutions Framework CompactMeasurement Methods

The CompactMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the CompactMeasurement and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes CompactMeasurement from the specified binary image.
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.GenerateBinaryImage Method

Grid Solutions Framework CompactMeasurementGenerateBinaryImage Method
Generates binary image of the CompactMeasurement and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
Remarks

Field: Bytes:
-------- -------
Flags 1
ID 2
Value 4
[Time] 2?

Constant Length = 7
Variable Length = 0, 2, 4 or 8 (i.e., total size is 7, 9, 11 or 15)

See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.ParseBinaryImage Method

Grid Solutions Framework CompactMeasurementParseBinaryImage Method
Initializes CompactMeasurement from the specified binary image.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | Not enough buffer available to deserialize measurement.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement Properties

Grid Solutions Framework CompactMeasurement Properties

The CompactMeasurement type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | BinaryLength | Gets the length of the CompactMeasurement.
Public property | CompactStateFlags | Gets or sets byte level compact state flags with encoded time index and base time offset bits.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | IncludeTime | Gets flag that determines if time is serialized into measurement binary image.
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | RuntimeID | Gets or sets the 2-byte run-time signal index for this measurement.
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | TimestampC2 | Gets offset compressed millisecond-resolution 2-byte timestamp.
Public property | TimestampC4 | Gets offset compressed tick-resolution 4-byte timestamp.
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.BinaryLength Property

Grid Solutions Framework CompactMeasurementBinaryLength Property
Gets the length of the CompactMeasurement.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.CompactStateFlags Property

Grid Solutions Framework CompactMeasurementCompactStateFlags Property
Gets or sets byte level compact state flags with encoded time index and base time offset bits.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public byte CompactStateFlags { get; set; }
Public Property CompactStateFlags As Byte
    Get
    Set
member CompactStateFlags : byte with get, set

function get_CompactStateFlags();
function set_CompactStateFlags(value);
public:
property unsigned char CompactStateFlags {
    unsigned char get ();
    void set (unsigned char value);
}

Property Value

Type: Byte
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.IncludeTime Property

Grid Solutions Framework CompactMeasurementIncludeTime Property
Gets flag that determines if time is serialized into measurement binary image.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IncludeTime { get; }
Public ReadOnly Property IncludeTime As Boolean
    Get
member IncludeTime : bool with get

function get_IncludeTime();

public:
property bool IncludeTime {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.RuntimeID Property

Grid Solutions Framework CompactMeasurementRuntimeID Property
Gets or sets the 2-byte run-time signal index for this measurement.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort RuntimeID { get; set; }
Public Property RuntimeID As UShort
    Get
    Set
member RuntimeID : uint16 with get, set

function get_RuntimeID();
function set_RuntimeID(value);
public:
property unsigned short RuntimeID {
    unsigned short get ();
    void set (unsigned short value);
}

Property Value

Type: UInt16
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.TimestampC2 Property

Grid Solutions Framework CompactMeasurementTimestampC2 Property
Gets offset compressed millisecond-resolution 2-byte timestamp.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort TimestampC2 { get; }
Public ReadOnly Property TimestampC2 As UShort
    Get
member TimestampC2 : uint16 with get

function get_TimestampC2();

public:
property unsigned short TimestampC2 {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurement.TimestampC4 Property

Grid Solutions Framework CompactMeasurementTimestampC4 Property
Gets offset compressed tick-resolution 4-byte timestamp.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public uint TimestampC4 { get; }
Public ReadOnly Property TimestampC4 As UInteger
    Get
member TimestampC4 : uint32 with get

function get_TimestampC4();

public:
property unsigned int TimestampC4 {
    unsigned int get ();
}

Property Value

Type: UInt32
See Also

Reference

CompactMeasurement Class
GSF.TimeSeries.Transport Namespace


CompactMeasurementExtensions Class

Grid Solutions Framework CompactMeasurementExtensions Class
Defines extension functions related to CompactMeasurement.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportCompactMeasurementExtensions

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class CompactMeasurementExtensions
<ExtensionAttribute>
Public NotInheritable Class CompactMeasurementExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type CompactMeasurementExtensions =  class end
GSF.TimeSeries.Transport.CompactMeasurementExtensions = function();

Type.createClass(
    'GSF.TimeSeries.Transport.CompactMeasurementExtensions');
[ExtensionAttribute]
public ref class CompactMeasurementExtensions abstract sealed

The CompactMeasurementExtensions type exposes the following members.

Methods
Name | Description
CompressPayload | Attempts to compress payload of CompactMeasurement values onto the destination stream.
DecompressPayload | Decompresses CompactMeasurement values from the given source buffer.
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


CompactMeasurementExtensions Methods

Grid Solutions Framework CompactMeasurementExtensions Methods

The CompactMeasurementExtensions type exposes the following members.

Methods
Name | Description
CompressPayload | Attempts to compress payload of CompactMeasurement values onto the destination stream.
DecompressPayload | Decompresses CompactMeasurement values from the given source buffer.
Top
See Also

Reference

CompactMeasurementExtensions Class
GSF.TimeSeries.Transport Namespace


CompactMeasurementExtensions.CompressPayload Method

Grid Solutions Framework CompactMeasurementExtensionsCompressPayload Method
Attempts to compress payload of CompactMeasurement values onto the destination stream.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool CompressPayload(
    this IEnumerable<CompactMeasurement> compactMeasurements,
    BlockAllocatedMemoryStream destination,
    byte compressionStrength,
    bool includeTime,
    ref DataPacketFlags flags
)
<ExtensionAttribute>
Public Shared Function CompressPayload (
    compactMeasurements As IEnumerable(Of CompactMeasurement),
    destination As BlockAllocatedMemoryStream,
    compressionStrength As Byte,
    includeTime As Boolean,
    ByRef flags As DataPacketFlags
) As Boolean
static member CompressPayload :
        compactMeasurements : IEnumerable<CompactMeasurement> *
        destination : BlockAllocatedMemoryStream *
        compressionStrength : byte *
        includeTime : bool *
        flags : DataPacketFlags byref -> bool

GSF.TimeSeries.Transport.CompactMeasurementExtensions.CompressPayload = function(compactMeasurements, destination, compressionStrength, includeTime, flags);
public:
[ExtensionAttribute]
static bool CompressPayload(
    IEnumerable<CompactMeasurement^>^ compactMeasurements,
    BlockAllocatedMemoryStream^ destination,
    unsigned char compressionStrength,
    bool includeTime,
    DataPacketFlags% flags
)

Parameters

compactMeasurements
Type: System.Collections.GenericIEnumerable CompactMeasurement
Payload of CompactMeasurement values.
destination
Type: GSF.IOBlockAllocatedMemoryStream
Memory based destination stream to hold compressed payload.
compressionStrength
Type: SystemByte
Compression strength to use.
includeTime
Type: SystemBoolean
Flag that determines if time should be included in the compressed payload.
flags
Type: GSF.TimeSeries.TransportDataPacketFlags
Current DataPacketFlags.

Return Value

Type: Boolean
true if payload was compressed and encoded onto destination stream; otherwise false.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IEnumerable CompactMeasurement . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Compressed payload will only be encoded onto destination stream if compressed size would be smaller than normal serialized size.

As an optimization this function uses a compression method that uses pointers to native structures, as such the endian order encoding of the compressed data will always be in the native-endian order of the operating system. This will be an important consideration when writing a endian order neutral payload decompressor. To help with this the actual endian order used during compression is marked in the data flags. However, measurements values are consistently encoded in big-endian order prior to buffer compression.

See Also

Reference

CompactMeasurementExtensions Class
GSF.TimeSeries.Transport Namespace


CompactMeasurementExtensions.DecompressPayload Method

Grid Solutions Framework CompactMeasurementExtensionsDecompressPayload Method
Decompresses CompactMeasurement values from the given source buffer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static CompactMeasurement[] DecompressPayload(
    this byte[] source,
    SignalIndexCache signalIndexCache,
    int index,
    int dataLength,
    int measurementCount,
    bool includeTime,
    DataPacketFlags flags
)
<ExtensionAttribute>
Public Shared Function DecompressPayload (
    source As Byte(),
    signalIndexCache As SignalIndexCache,
    index As Integer,
    dataLength As Integer,
    measurementCount As Integer,
    includeTime As Boolean,
    flags As DataPacketFlags
) As CompactMeasurement()
static member DecompressPayload :
        source : byte[] *
        signalIndexCache : SignalIndexCache *
        index : int *
        dataLength : int *
        measurementCount : int *
        includeTime : bool *
        flags : DataPacketFlags -> CompactMeasurement[]

GSF.TimeSeries.Transport.CompactMeasurementExtensions.DecompressPayload = function(source, signalIndexCache, index, dataLength, measurementCount, includeTime, flags);
public:
[ExtensionAttribute]
static array<CompactMeasurement^>^ DecompressPayload(
    array<unsigned char>^ source,
    SignalIndexCache^ signalIndexCache,
    int index,
    int dataLength,
    int measurementCount,
    bool includeTime,
    DataPacketFlags flags
)

Parameters

source
Type: SystemByte
Buffer with compressed CompactMeasurement payload.
signalIndexCache
Type: GSF.TimeSeries.TransportSignalIndexCache
Current SignalIndexCache.
index
Type: SystemInt32
Index into buffer where compressed payload begins.
dataLength
Type: SystemInt32
Length of all data within source buffer.
measurementCount
Type: SystemInt32
Number of compressed measurements in the payload.
includeTime
Type: SystemBoolean
Flag that determines if timestamps as included in the payload.
flags
Type: GSF.TimeSeries.TransportDataPacketFlags
Current DataPacketFlags.

Return Value

Type: CompactMeasurement
Decompressed CompactMeasurement values from the given source buffer.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type . When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

CompactMeasurementExtensions Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer Class

Grid Solutions Framework DataGapRecoverer Class
Represents a data gap recovery module.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportDataGapRecoverer

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class DataGapRecoverer : ISupportLifecycle,
    IDisposable, IProvideStatus
Public Class DataGapRecoverer
    Implements ISupportLifecycle, IDisposable, IProvideStatus
type DataGapRecoverer =
    class
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Transport.DataGapRecoverer = function();

Type.createClass(
    'GSF.TimeSeries.Transport.DataGapRecoverer',
    null,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus);
public ref class DataGapRecoverer : ISupportLifecycle,
    IDisposable, IProvideStatus

The DataGapRecoverer type exposes the following members.

Constructors
 | Name | Description
Public method | DataGapRecoverer | Creates a new DataGapRecoverer.
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the DataGapRecoverer object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataGapRecoverer object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the DataGapRecoverer object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | FlushLog | Blocks calling thread until data gap OutageLog has been flushed to disk.
Public method | FlushLogAsync | Queues up a flush to happen asynchronously.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the DataGapRecoverer.
Public method | LogDataGap | Logs a new data gap for processing.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnRecoveredMeasurements | Raises the RecoveredMeasurements event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultDataMonitoringInterval | Default value for DataMonitoringInterval.
DefaultFilterExpression | Default value for FilterExpression.
DefaultMaximumRecoverySpan | Default value for MaximumRecoverySpan.
DefaultMinimumRecoverySpan | Default value for MinimumRecoverySpan.
DefaultRecoveryProcessingInterval | Default value for RecoveryProcessingInterval.
DefaultRecoveryStartDelay | Default value for RecoveryStartDelay.
DefaultUseMillisecondResolution | Default value for UseMillisecondResolution.
Top
Properties
 | Name | Description
Public property | ConnectionString | Gets or sets connection string that will be used to make a temporal subscription when recovering data for an Outage.
Public property | ConstraintParameters | Gets or sets any additional constraint parameters that will be supplied to adapters in temporal subscription used when recovering data for an Outage.
Protected property | DataGapLog | Gets reference to the data gap OutageLog for this DataGapRecoverer.
Protected property | DataGapLogProcessor | Gets reference to the data gap OutageLogProcessor for this DataGapRecoverer.
Public property | DataMonitoringInterval | Gets or sets the interval, in seconds, over which the data monitor will check for new data.
Public property | DataSource | Gets or sets DataSet based data source available to this DataGapRecoverer.
Public property | Enabled | Gets or sets a boolean value that indicates whether the DataGapRecoverer is enabled.
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested for data recovery during an Outage.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LoggingPath | Gets or sets logging path to be used to be runtime and outage logs of the subscriber which are required for automated data recovery.
Public property | MaximumRecoverySpan | Gets to sets the maximum time span, in seconds, for which a data recovery will be attempted. Set to MaxValue for no maximum.
Public property | MinimumRecoverySpan | Gets to sets the minimum time span, in seconds, for which a data recovery will be attempted. Set to zero for no minimum.
Public property | RecoveryProcessingInterval | Gets or sets the data recovery processing interval, in whole milliseconds, to use in the temporal data subscription when recovering data for an Outage. A value of -1 indicates the default processing interval will be requested. A value of 0 indicates data will be processed as fast as possible.
Public property | RecoveryStartDelay | Gets or sets the minimum time delay, in seconds, to wait before starting the data recovery for an Outage.
Public property | SourceConnectionName | Gets or sets name of source connection device (e.g., a data subscriber).
Public property | Status | Gets the status of this DataGapRecoverer.
Public property | TemporalSubscriptionStatus | Gets the status of the temporal DataSubscriber used to query historical data.
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, time will be of Ticks resolution.
Top
Events
 | Name | Description
Public event | Disposed | Raised after the DataGapRecoverer has been properly disposed.
Public event | ProcessException | Event is raised when there is an exception encountered during DataGapRecoverer processing.
Public event | RecoveredMeasurements | Provides recovered measurements from temporal subscription.
Public event | StatusMessage | Provides status messages to consumer.
Top
Remarks

Data gaps will be recovered using an unsynchronized temporal subscription.

This class expects that source historian that feeds temporal subscription will recover data in time-sorted order.

See Also

Reference

GSF.TimeSeries.Transport Namespace


DataGapRecoverer Constructor

Grid Solutions Framework DataGapRecoverer Constructor
Creates a new DataGapRecoverer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataGapRecoverer()
Public Sub New
new : unit -> DataGapRecoverer
GSF.TimeSeries.Transport.DataGapRecoverer = function();
public:
DataGapRecoverer()
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer Fields

Grid Solutions Framework DataGapRecoverer Fields

The DataGapRecoverer type exposes the following members.

Fields
Name | Description
DefaultDataMonitoringInterval | Default value for DataMonitoringInterval.
DefaultFilterExpression | Default value for FilterExpression.
DefaultMaximumRecoverySpan | Default value for MaximumRecoverySpan.
DefaultMinimumRecoverySpan | Default value for MinimumRecoverySpan.
DefaultRecoveryProcessingInterval | Default value for RecoveryProcessingInterval.
DefaultRecoveryStartDelay | Default value for RecoveryStartDelay.
DefaultUseMillisecondResolution | Default value for UseMillisecondResolution.
Top
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DefaultDataMonitoringInterval Field

Grid Solutions Framework DataGapRecovererDefaultDataMonitoringInterval Field
Default value for DataMonitoringInterval.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultDataMonitoringInterval
Public Const DefaultDataMonitoringInterval As Double
static val mutable DefaultDataMonitoringInterval: float
var GSF.TimeSeries.Transport.DataGapRecoverer.DefaultDataMonitoringInterval
public:
literal double DefaultDataMonitoringInterval

Field Value

Type: Double
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DefaultFilterExpression Field

Grid Solutions Framework DataGapRecovererDefaultFilterExpression Field
Default value for FilterExpression.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultFilterExpression
Public Const DefaultFilterExpression As String
static val mutable DefaultFilterExpression: string
var GSF.TimeSeries.Transport.DataGapRecoverer.DefaultFilterExpression
public:
literal String^ DefaultFilterExpression

Field Value

Type: String
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DefaultMaximumRecoverySpan Field

Grid Solutions Framework DataGapRecovererDefaultMaximumRecoverySpan Field
Default value for MaximumRecoverySpan.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultMaximumRecoverySpan
Public Const DefaultMaximumRecoverySpan As Double
static val mutable DefaultMaximumRecoverySpan: float
var GSF.TimeSeries.Transport.DataGapRecoverer.DefaultMaximumRecoverySpan
public:
literal double DefaultMaximumRecoverySpan

Field Value

Type: Double
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DefaultMinimumRecoverySpan Field

Grid Solutions Framework DataGapRecovererDefaultMinimumRecoverySpan Field
Default value for MinimumRecoverySpan.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultMinimumRecoverySpan
Public Const DefaultMinimumRecoverySpan As Double
static val mutable DefaultMinimumRecoverySpan: float
var GSF.TimeSeries.Transport.DataGapRecoverer.DefaultMinimumRecoverySpan
public:
literal double DefaultMinimumRecoverySpan

Field Value

Type: Double
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DefaultRecoveryProcessingInterval Field

Grid Solutions Framework DataGapRecovererDefaultRecoveryProcessingInterval Field
Default value for RecoveryProcessingInterval.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultRecoveryProcessingInterval
Public Const DefaultRecoveryProcessingInterval As Integer
static val mutable DefaultRecoveryProcessingInterval: int
var GSF.TimeSeries.Transport.DataGapRecoverer.DefaultRecoveryProcessingInterval
public:
literal int DefaultRecoveryProcessingInterval

Field Value

Type: Int32
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DefaultRecoveryStartDelay Field

Grid Solutions Framework DataGapRecovererDefaultRecoveryStartDelay Field
Default value for RecoveryStartDelay.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultRecoveryStartDelay
Public Const DefaultRecoveryStartDelay As Double
static val mutable DefaultRecoveryStartDelay: float
var GSF.TimeSeries.Transport.DataGapRecoverer.DefaultRecoveryStartDelay
public:
literal double DefaultRecoveryStartDelay

Field Value

Type: Double
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DefaultUseMillisecondResolution Field

Grid Solutions Framework DataGapRecovererDefaultUseMillisecondResolution Field
Default value for UseMillisecondResolution.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultUseMillisecondResolution
Public Const DefaultUseMillisecondResolution As Boolean
static val mutable DefaultUseMillisecondResolution: bool
var GSF.TimeSeries.Transport.DataGapRecoverer.DefaultUseMillisecondResolution
public:
literal bool DefaultUseMillisecondResolution

Field Value

Type: Boolean
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer Methods

Grid Solutions Framework DataGapRecoverer Methods

The DataGapRecoverer type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the DataGapRecoverer object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataGapRecoverer object and optionally releases the managed resources.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the DataGapRecoverer object is reclaimed by GC. (Overrides ObjectFinalize.)
Public method | FlushLog | Blocks calling thread until data gap OutageLog has been flushed to disk.
Public method | FlushLogAsync | Queues up a flush to happen asynchronously.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the DataGapRecoverer.
Public method | LogDataGap | Logs a new data gap for processing.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnProcessException | Raises ProcessException event.
Protected method | OnRecoveredMeasurements | Raises the RecoveredMeasurements event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Dispose Method

Grid Solutions Framework DataGapRecovererDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the DataGapRecoverer object.
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataGapRecoverer object and optionally releases the managed resources.
Top
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Dispose Method

Grid Solutions Framework DataGapRecovererDispose Method
Releases all the resources used by the DataGapRecoverer object.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Dispose()
Public Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose() sealed

Implements

IDisposableDispose
See Also

Reference

DataGapRecoverer Class
Dispose Overload
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Dispose Method (Boolean)

Grid Solutions Framework DataGapRecovererDispose Method (Boolean)
Releases the unmanaged resources used by the DataGapRecoverer object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Dispose(
    bool disposing
)
Protected Overridable Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
)

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

DataGapRecoverer Class
Dispose Overload
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Finalize Method

Grid Solutions Framework DataGapRecovererFinalize Method
Releases the unmanaged resources before the DataGapRecoverer object is reclaimed by GC.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.FlushLog Method

Grid Solutions Framework DataGapRecovererFlushLog Method
Blocks calling thread until data gap OutageLog has been flushed to disk.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool FlushLog(
    int timeout = -1
)
Public Function FlushLog (
    Optional timeout As Integer = -1
) As Boolean
member FlushLog :
        ?timeout : int
(* Defaults:
        let _timeout = defaultArg timeout -1
*)
-> bool

function FlushLog(timeout);
public:
bool FlushLog(
    int timeout = -1
)

Parameters

timeout (Optional)
Type: SystemInt32
Optional time-out for waiting thread block. Defaults to waiting indefinitely.

Return Value

Type: Boolean
true if log was flushed successfully; otherwise, false if flush timed out.
Remarks

Data gap log is automatically persisted to disk as Outage items are added or removed from the log. This function only exists to force a flush and block calling thread until flush has completed.

Function first waits for any pending data gap operation to complete then waits for data gap log to be flushed. Both waits use the same timeout value, as a result it is possible that total wait time could be longer than specified wait time.

See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.FlushLogAsync Method

Grid Solutions Framework DataGapRecovererFlushLogAsync Method
Queues up a flush to happen asynchronously.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void FlushLogAsync()
Public Sub FlushLogAsync
member FlushLogAsync : unit -> unit

function FlushLogAsync();
public:
void FlushLogAsync()
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Initialize Method

Grid Solutions Framework DataGapRecovererInitialize Method
Initializes the DataGapRecoverer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void Initialize()
Public Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() sealed

Implements

ISupportLifecycleInitialize
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.LogDataGap Method

Grid Solutions Framework DataGapRecovererLogDataGap Method
Logs a new data gap for processing.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool LogDataGap(
    DateTime startTime,
    DateTime endTime
)
Public Function LogDataGap (
    startTime As DateTime,
    endTime As DateTime
) As Boolean
member LogDataGap :
        startTime : DateTime *
        endTime : DateTime -> bool

function LogDataGap(startTime, endTime);
public:
bool LogDataGap(
    DateTime startTime,
    DateTime endTime
)

Parameters

startTime
Type: SystemDateTime
Start time of data gap.
endTime
Type: SystemDateTime
End time of data gap.

Return Value

Type: Boolean
true if data gap was logged for processing; otherwise, false.
Remarks
Data gap will not be logged for processing if the startTime and endTime do not represent a valid time span for recovery according to MinimumRecoverySpan and MaximumRecoverySpan.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.OnProcessException Method

Grid Solutions Framework DataGapRecovererOnProcessException Method
Raises ProcessException event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessException(
    Exception ex
)
Protected Overridable Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit
override OnProcessException :
        ex : Exception -> unit
function OnProcessException(ex);
protected:
virtual void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.OnRecoveredMeasurements Method

Grid Solutions Framework DataGapRecovererOnRecoveredMeasurements Method
Raises the RecoveredMeasurements event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnRecoveredMeasurements(
    ICollection<IMeasurement> measurements
)
Protected Overridable Sub OnRecoveredMeasurements (
    measurements As ICollection(Of IMeasurement)
)
abstract OnRecoveredMeasurements :
        measurements : ICollection<IMeasurement> -> unit
override OnRecoveredMeasurements :
        measurements : ICollection<IMeasurement> -> unit
function OnRecoveredMeasurements(measurements);
protected:
virtual void OnRecoveredMeasurements(
    ICollection<IMeasurement^>^ measurements
)

Parameters

measurements
Type: System.Collections.GenericICollection IMeasurement

[Missing <param name="measurements"/> documentation for "M:GSF.TimeSeries.Transport.DataGapRecoverer.OnRecoveredMeasurements(System.Collections.Generic.ICollection{GSF.TimeSeries.IMeasurement})"]

See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.OnStatusMessage Method

Grid Solutions Framework DataGapRecovererOnStatusMessage Method
Overload List
 | Name | Description
Protected method | OnStatusMessage(String) | Raises the StatusMessage event.
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message.
Top
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.OnStatusMessage Method (String)

Grid Solutions Framework DataGapRecovererOnStatusMessage Method (String)
Raises the StatusMessage event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string status
)
Protected Overridable Sub OnStatusMessage (
    status As String
)
abstract OnStatusMessage :
        status : string -> unit
override OnStatusMessage :
        status : string -> unit
function OnStatusMessage(status);
protected:
virtual void OnStatusMessage(
    String^ status
)

Parameters

status
Type: SystemString
New status message.
See Also

Reference

DataGapRecoverer Class
OnStatusMessage Overload
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.OnStatusMessage Method (String, Object[])

Grid Solutions Framework DataGapRecovererOnStatusMessage Method (String, Object)
Raises the StatusMessage event with a formatted status message.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnStatusMessage(
    string formattedStatus,
    params Object[] args
)
Protected Overridable Sub OnStatusMessage (
    formattedStatus As String,
    ParamArray args As Object()
)
abstract OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
override OnStatusMessage :
        formattedStatus : string *
        args : Object[] -> unit
function OnStatusMessage(formattedStatus, ... args);
protected:
virtual void OnStatusMessage(
    String^ formattedStatus,
    ... array<Object^>^ args
)

Parameters

formattedStatus
Type: SystemString
Formatted status message.
args
Type: SystemObject
Arguments for formattedStatus.
Remarks
This overload combines string.Format and SendStatusMessage for convenience.
See Also

Reference

DataGapRecoverer Class
OnStatusMessage Overload
GSF.TimeSeries.Transport Namespace


DataGapRecoverer Properties

Grid Solutions Framework DataGapRecoverer Properties

The DataGapRecoverer type exposes the following members.

Properties
 | Name | Description
Public property | ConnectionString | Gets or sets connection string that will be used to make a temporal subscription when recovering data for an Outage.
Public property | ConstraintParameters | Gets or sets any additional constraint parameters that will be supplied to adapters in temporal subscription used when recovering data for an Outage.
Protected property | DataGapLog | Gets reference to the data gap OutageLog for this DataGapRecoverer.
Protected property | DataGapLogProcessor | Gets reference to the data gap OutageLogProcessor for this DataGapRecoverer.
Public property | DataMonitoringInterval | Gets or sets the interval, in seconds, over which the data monitor will check for new data.
Public property | DataSource | Gets or sets DataSet based data source available to this DataGapRecoverer.
Public property | Enabled | Gets or sets a boolean value that indicates whether the DataGapRecoverer is enabled.
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested for data recovery during an Outage.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed.
Public property | LoggingPath | Gets or sets logging path to be used to be runtime and outage logs of the subscriber which are required for automated data recovery.
Public property | MaximumRecoverySpan | Gets to sets the maximum time span, in seconds, for which a data recovery will be attempted. Set to MaxValue for no maximum.
Public property | MinimumRecoverySpan | Gets to sets the minimum time span, in seconds, for which a data recovery will be attempted. Set to zero for no minimum.
Public property | RecoveryProcessingInterval | Gets or sets the data recovery processing interval, in whole milliseconds, to use in the temporal data subscription when recovering data for an Outage. A value of -1 indicates the default processing interval will be requested. A value of 0 indicates data will be processed as fast as possible.
Public property | RecoveryStartDelay | Gets or sets the minimum time delay, in seconds, to wait before starting the data recovery for an Outage.
Public property | SourceConnectionName | Gets or sets name of source connection device (e.g., a data subscriber).
Public property | Status | Gets the status of this DataGapRecoverer.
Public property | TemporalSubscriptionStatus | Gets the status of the temporal DataSubscriber used to query historical data.
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, time will be of Ticks resolution.
Top
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.ConnectionString Property

Grid Solutions Framework DataGapRecovererConnectionString Property
Gets or sets connection string that will be used to make a temporal subscription when recovering data for an Outage.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConnectionString { get; set; }
Public Property ConnectionString As String
    Get
    Set
member ConnectionString : string with get, set

function get_ConnectionString();
function set_ConnectionString(value);
public:
property String^ ConnectionString {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value cannot be null or an empty string.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.ConstraintParameters Property

Grid Solutions Framework DataGapRecovererConstraintParameters Property
Gets or sets any additional constraint parameters that will be supplied to adapters in temporal subscription used when recovering data for an Outage.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ConstraintParameters { get; set; }
Public Property ConstraintParameters As String
    Get
    Set
member ConstraintParameters : string with get, set

function get_ConstraintParameters();
function set_ConstraintParameters(value);
public:
property String^ ConstraintParameters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DataGapLog Property

Grid Solutions Framework DataGapRecovererDataGapLog Property
Gets reference to the data gap OutageLog for this DataGapRecoverer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected OutageLog DataGapLog { get; }
Protected ReadOnly Property DataGapLog As OutageLog
    Get
member DataGapLog : OutageLog with get

function get_DataGapLog();

protected:
property OutageLog^ DataGapLog {
    OutageLog^ get ();
}

Property Value

Type: OutageLog
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DataGapLogProcessor Property

Grid Solutions Framework DataGapRecovererDataGapLogProcessor Property
Gets reference to the data gap OutageLogProcessor for this DataGapRecoverer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected OutageLogProcessor DataGapLogProcessor { get; }
Protected ReadOnly Property DataGapLogProcessor As OutageLogProcessor
    Get
member DataGapLogProcessor : OutageLogProcessor with get

function get_DataGapLogProcessor();

protected:
property OutageLogProcessor^ DataGapLogProcessor {
    OutageLogProcessor^ get ();
}

Property Value

Type: OutageLogProcessor
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DataMonitoringInterval Property

Grid Solutions Framework DataGapRecovererDataMonitoringInterval Property
Gets or sets the interval, in seconds, over which the data monitor will check for new data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time DataMonitoringInterval { get; set; }
Public Property DataMonitoringInterval As Time
    Get
    Set
member DataMonitoringInterval : Time with get, set

function get_DataMonitoringInterval();
function set_DataMonitoringInterval(value);
public:
property Time DataMonitoringInterval {
    Time get ();
    void set (Time value);
}

Property Value

Type: Time
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value cannot be zero or a negative number.
Remarks
Once a connection is established a timer is enabled to monitor for new incoming data. The data monitoring timer exists to make sure data is being received so that the process of recovery does not wait endlessly for data that may never come because of a possible error in the recovery process. The DataMonitoringInterval allows the consumer to adjust the interval over which the timer will check for new incoming data.

It will take some time, perhaps a couple of seconds, to start the temporal subscription and begin the process of recovering data for an Outage. Make sure the value for DataMonitoringInterval is sufficiently large enough to handle any initial delays in data transmission.

See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.DataSource Property

Grid Solutions Framework DataGapRecovererDataSource Property
Gets or sets DataSet based data source available to this DataGapRecoverer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSet DataSource { get; set; }
Public Property DataSource As DataSet
    Get
    Set
member DataSource : DataSet with get, set

function get_DataSource();
function set_DataSource(value);
public:
property DataSet^ DataSource {
    DataSet^ get ();
    void set (DataSet^ value);
}

Property Value

Type: DataSet
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Enabled Property

Grid Solutions Framework DataGapRecovererEnabled Property
Gets or sets a boolean value that indicates whether the DataGapRecoverer is enabled.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Enabled { get; set; }
Public Property Enabled As Boolean
    Get
    Set
abstract Enabled : bool with get, set
override Enabled : bool with get, set
function get_Enabled();
function set_Enabled(value);
public:
virtual property bool Enabled {
    bool get () sealed;
    void set (bool value) sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleEnabled
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.FilterExpression Property

Grid Solutions Framework DataGapRecovererFilterExpression Property
Gets or sets the filter expression used to define which measurements are being requested for data recovery during an Outage.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string FilterExpression { get; set; }
Public Property FilterExpression As String
    Get
    Set
member FilterExpression : string with get, set

function get_FilterExpression();
function set_FilterExpression(value);
public:
property String^ FilterExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.IsDisposed Property

Grid Solutions Framework DataGapRecovererIsDisposed Property
Gets a flag that indicates whether the object has been disposed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsDisposed { get; }
Public ReadOnly Property IsDisposed As Boolean
    Get
abstract IsDisposed : bool with get
override IsDisposed : bool with get
function get_IsDisposed();

public:
virtual property bool IsDisposed {
    bool get () sealed;
}

Property Value

Type: Boolean

Implements

ISupportLifecycleIsDisposed
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.LoggingPath Property

Grid Solutions Framework DataGapRecovererLoggingPath Property
Gets or sets logging path to be used to be runtime and outage logs of the subscriber which are required for automated data recovery.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LoggingPath { get; set; }
Public Property LoggingPath As String
    Get
    Set
member LoggingPath : string with get, set

function get_LoggingPath();
function set_LoggingPath(value);
public:
property String^ LoggingPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Leave value blank for default path, i.e., installation folder. Can be a fully qualified path or a path that is relative to the installation folder, e.g., a value of "ConfigurationCache" might resolve to "C:\Program Files\MyTimeSeriespPp\ConfigurationCache\".
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.MaximumRecoverySpan Property

Grid Solutions Framework DataGapRecovererMaximumRecoverySpan Property
Gets to sets the maximum time span, in seconds, for which a data recovery will be attempted. Set to MaxValue for no maximum.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time MaximumRecoverySpan { get; set; }
Public Property MaximumRecoverySpan As Time
    Get
    Set
member MaximumRecoverySpan : Time with get, set

function get_MaximumRecoverySpan();
function set_MaximumRecoverySpan(value);
public:
property Time MaximumRecoverySpan {
    Time get ();
    void set (Time value);
}

Property Value

Type: Time
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value cannot be zero or a negative number.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.MinimumRecoverySpan Property

Grid Solutions Framework DataGapRecovererMinimumRecoverySpan Property
Gets to sets the minimum time span, in seconds, for which a data recovery will be attempted. Set to zero for no minimum.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time MinimumRecoverySpan { get; set; }
Public Property MinimumRecoverySpan As Time
    Get
    Set
member MinimumRecoverySpan : Time with get, set

function get_MinimumRecoverySpan();
function set_MinimumRecoverySpan(value);
public:
property Time MinimumRecoverySpan {
    Time get ();
    void set (Time value);
}

Property Value

Type: Time
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value cannot be a negative number.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.RecoveryProcessingInterval Property

Grid Solutions Framework DataGapRecovererRecoveryProcessingInterval Property
Gets or sets the data recovery processing interval, in whole milliseconds, to use in the temporal data subscription when recovering data for an Outage.
A value of -1 indicates the default processing interval will be requested.
A value of 0 indicates data will be processed as fast as possible.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int RecoveryProcessingInterval { get; set; }
Public Property RecoveryProcessingInterval As Integer
    Get
    Set
member RecoveryProcessingInterval : int with get, set

function get_RecoveryProcessingInterval();
function set_RecoveryProcessingInterval(value);
public:
property int RecoveryProcessingInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
With the exception of the values of -1 and 0, the RecoveryProcessingInterval value specifies the desired historical data playback processing interval in milliseconds. This is basically a delay, or timer interval, over which to process data. Setting this value to -1 means to use the default processing interval while setting the value to 0 means to process data as fast as possible, i.e., as fast as the historian can query the data. Depending on the available bandwidth, this parameter may need to be adjusted such that the data being recovered does not adversely interfere with the ongoing transmission of real-time data.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.RecoveryStartDelay Property

Grid Solutions Framework DataGapRecovererRecoveryStartDelay Property
Gets or sets the minimum time delay, in seconds, to wait before starting the data recovery for an Outage.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time RecoveryStartDelay { get; set; }
Public Property RecoveryStartDelay As Time
    Get
    Set
member RecoveryStartDelay : Time with get, set

function get_RecoveryStartDelay();
function set_RecoveryStartDelay(value);
public:
property Time RecoveryStartDelay {
    Time get ();
    void set (Time value);
}

Property Value

Type: Time
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value cannot be a negative number.
Remarks

For some archiving systems it may take a few seconds for data to make it to disk and therefore be readily available for a temporal subscription query. The RecoveryStartDelay should be adjusted based on the nature of the system used to archive data. If the archival system makes data immediately available because of internal caching or other means, this value can be zero.

Use of this value depends on the local clock, as such the value should be increased by the uncertainty of accuracy of the local clock. For example, if it is know that the local clock floats +/-5 seconds from real-time, then increase the desired value of the RecoveryStartDelay by 5 seconds.

See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.SourceConnectionName Property

Grid Solutions Framework DataGapRecovererSourceConnectionName Property
Gets or sets name of source connection device (e.g., a data subscriber).

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string SourceConnectionName { get; set; }
Public Property SourceConnectionName As String
    Get
    Set
member SourceConnectionName : string with get, set

function get_SourceConnectionName();
function set_SourceConnectionName(value);
public:
property String^ SourceConnectionName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Value cannot be null or an empty string.
Remarks
This name will be used to create the FileName.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Status Property

Grid Solutions Framework DataGapRecovererStatus Property
Gets the status of this DataGapRecoverer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Status { get; }
Public ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () sealed;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.TemporalSubscriptionStatus Property

Grid Solutions Framework DataGapRecovererTemporalSubscriptionStatus Property
Gets the status of the temporal DataSubscriber used to query historical data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string TemporalSubscriptionStatus { get; }
Public ReadOnly Property TemporalSubscriptionStatus As String
    Get
member TemporalSubscriptionStatus : string with get

function get_TemporalSubscriptionStatus();

public:
property String^ TemporalSubscriptionStatus {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.UseMillisecondResolution Property

Grid Solutions Framework DataGapRecovererUseMillisecondResolution Property
Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, time will be of Ticks resolution.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseMillisecondResolution { get; set; }
Public Property UseMillisecondResolution As Boolean
    Get
    Set
member UseMillisecondResolution : bool with get, set

function get_UseMillisecondResolution();
function set_UseMillisecondResolution(value);
public:
property bool UseMillisecondResolution {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
If the source and destination historians can handle timestamps at a greater than millisecond resolution then the UseMillisecondResolution can be set to false to ensure that a full resolution timestamp is delivered through the data recovery process. Setting this property to true allows the temporal subscription used in the data recovery process to conserve data transmission bandwidth since not as much space will be needed for a timestamp with only millisecond resolution.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer Events

Grid Solutions Framework DataGapRecoverer Events

The DataGapRecoverer type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the DataGapRecoverer has been properly disposed.
Public event | ProcessException | Event is raised when there is an exception encountered during DataGapRecoverer processing.
Public event | RecoveredMeasurements | Provides recovered measurements from temporal subscription.
Public event | StatusMessage | Provides status messages to consumer.
Top
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.Disposed Event

Grid Solutions Framework DataGapRecovererDisposed Event
Raised after the DataGapRecoverer has been properly disposed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler Disposed
Public Event Disposed As EventHandler
abstract Disposed : IEvent<EventHandler,
    EventArgs>
override Disposed : IEvent<EventHandler,
    EventArgs>
function add_Disposed(value);
function remove_Disposed(value);
public:
virtual  event EventHandler^ Disposed {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler

Implements

ISupportLifecycleDisposed
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.ProcessException Event

Grid Solutions Framework DataGapRecovererProcessException Event
Event is raised when there is an exception encountered during DataGapRecoverer processing.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Exception>> ProcessException
Public Event ProcessException As EventHandler(Of EventArgs(Of Exception))
member ProcessException : IEvent<EventHandler<EventArgs<Exception>>,
    EventArgs<Exception>>

function add_ProcessException(value);
function remove_ProcessException(value);
public:
 event EventHandler<EventArgs<Exception^>^>^ ProcessException {
    void add (EventHandler<EventArgs<Exception^>^>^ value);
    void remove (EventHandler<EventArgs<Exception^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Exception
Remarks
Argument is the exception that was thrown.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.RecoveredMeasurements Event

Grid Solutions Framework DataGapRecovererRecoveredMeasurements Event
Provides recovered measurements from temporal subscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ICollection<IMeasurement>>> RecoveredMeasurements
Public Event RecoveredMeasurements As EventHandler(Of EventArgs(Of ICollection(Of IMeasurement)))
member RecoveredMeasurements : IEvent<EventHandler<EventArgs<ICollection<IMeasurement>>>,
    EventArgs<ICollection<IMeasurement>>>

function add_RecoveredMeasurements(value);
function remove_RecoveredMeasurements(value);
public:
 event EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ RecoveredMeasurements {
    void add (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
    void remove (EventHandler<EventArgs<ICollection<IMeasurement^>^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ICollection IMeasurement
Remarks
Argument is a collection of measurements for consumer to process.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataGapRecoverer.StatusMessage Event

Grid Solutions Framework DataGapRecovererStatusMessage Event
Provides status messages to consumer.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> StatusMessage
Public Event StatusMessage As EventHandler(Of EventArgs(Of String))
member StatusMessage : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_StatusMessage(value);
function remove_StatusMessage(value);
public:
 event EventHandler<EventArgs<String^>^>^ StatusMessage {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
Argument is new status message.
See Also

Reference

DataGapRecoverer Class
GSF.TimeSeries.Transport Namespace


DataPacketFlags Enumeration

Grid Solutions Framework DataPacketFlags Enumeration
DataPublisher data packet flags.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum DataPacketFlags
<FlagsAttribute>
Public Enumeration DataPacketFlags
[<FlagsAttribute>]
type DataPacketFlags
GSF.TimeSeries.Transport.DataPacketFlags = function();
GSF.TimeSeries.Transport.DataPacketFlags.createEnum('GSF.TimeSeries.Transport.DataPacketFlags', true);
[FlagsAttribute]
public enum class DataPacketFlags
Members
Member name | Value | Description
Synchronized | 1 | Determines if data packet is synchronized.
Compact | 2 | Determines if serialized measurement is compact.
CipherIndex | 4 | Determines which cipher index to use when encrypting data packet.
Compressed | 8 | Determines if data packet payload is compressed.
LittleEndianCompression | 16 | Determines if the compressed data payload is in little-endian order.
NoFlags | 0 | No flags set.
See Also

Reference

GSF.TimeSeries.Transport Namespace


DataPublisher Class

Grid Solutions Framework DataPublisher Class
Represents a data publishing server that allows multiple connections for data subscriptions.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection IActionAdapter
GSF.CollectionsListCollection IActionAdapter
GSF.TimeSeries.AdaptersAdapterCollectionBase IActionAdapter
GSF.TimeSeries.AdaptersActionAdapterCollection
GSF.TimeSeries.TransportDataPublisher

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Always)]
public class DataPublisher : ActionAdapterCollection
<EditorBrowsableAttribute(EditorBrowsableState.Always)>
Public Class DataPublisher
    Inherits ActionAdapterCollection
[<EditorBrowsableAttribute(EditorBrowsableState.Always)>]
type DataPublisher =
    class
        inherit ActionAdapterCollection
    end
GSF.TimeSeries.Transport.DataPublisher = function();

Type.createClass(
    'GSF.TimeSeries.Transport.DataPublisher',
    GSF.TimeSeries.Adapters.ActionAdapterCollection);
[EditorBrowsableAttribute(EditorBrowsableState::Always)]
public ref class DataPublisher : public ActionAdapterCollection

The DataPublisher type exposes the following members.

Constructors
 | Name | Description
Public method | DataPublisher | Creates a new DataPublisher.
Top
Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Protected method | AquireMetadata | Gets meta-data to return to DataSubscriber.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataPublisher object and optionally releases the managed resources. (Overrides AdapterCollectionBaseTDispose(Boolean).)
Protected method | DisposeItem | Unwires events and disposes of IActionAdapter implementation. (Inherited from ActionAdapterCollection.)
Public method | EnumerateClients | Enumerates connected clients.
Public method | EnumerateTemporalClients | Enumerates connected clients with active temporal sessions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the DataPublisher object is reclaimed by GC. (Overrides AdapterCollectionBaseTFinalize.)
Protected method | GetClientEncoding | Gets the text encoding associated with a particular client.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalCertificate | Gets the local certificate currently in use by the data publisher.
Public method | GetShortStatus | Gets a short one-line status of this DataPublisher. (Overrides AdapterCollectionBaseTGetShortStatus(Int32).)
Public method | GetSubscriberInfo | Gets subscriber information for specified client connection.
Public method | GetSubscriberStatus | Gets subscriber status for specified subscriber ID.
Public method | GetTemporalStatus | Gets temporal status for a specified client connection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportCertificate | Imports a certificate to the trusted certificates path.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Initializes DataPublisher. (Overrides ActionAdapterCollectionInitialize.)
Protected method | InitializeItem | Wires events and initializes new IActionAdapter implementation. (Inherited from ActionAdapterCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | LookupSignalID | Looks up Guid signal ID for given MeasurementKey.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClientConnected | Raises the ClientConnected event.
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from ActionAdapterCollection.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from ActionAdapterCollection.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnRequestTemporalSupport | Raises RequestTemporalSupport event. (Inherited from ActionAdapterCollection.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from ActionAdapterCollection.)
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing to each IActionAdapter connected to this DataPublisher. (Overrides ActionAdapterCollectionQueueMeasurementsForProcessing(IEnumerableIMeasurement).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetLifetimeCounters | Resets the counters for the lifetime statistics without interrupting the adapter's operations.
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Public method | RotateCipherKeys | Rotates cipher keys for specified client connection.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand) | Sends response back to specified client.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, Byte) | Sends response back to specified client with attached data.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, String) | Sends response back to specified client with a message.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, String, Object) | Sends response back to specified client with a formatted message.
Protected method | SendDataStartTime | Sends the start time of the first measurement in a connection transmission.
Public method | SendNotification | Sends a notification to all subscribers.
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Establish DataPublisher and start listening for client connections. (Overrides AdapterCollectionBaseTStart.)
Public method | Stop | Terminate DataPublisher and stop listening for client connections. (Overrides AdapterCollectionBaseTStop.)
Protected method | SubscriberHasRights(Guid, Guid) | Determines if subscriber has rights to specified signalID.
Protected method | SubscriberHasRights(Guid, MeasurementKey, Guid) | Determines if subscriber has rights to specified MeasurementKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Protected method | UpdateLatencyStatistics | Updates latency statistics based on the collection of latencies passed into the method.
Protected method | UpdateLatestMeasurementCache | Updates the latest measurement cache when the set of cached measurements may have changed.
Protected method | UpdateRights | Updates each subscription's inputs based on possible updates to that subscriber's rights.
Public method | UpdateSignalIndexCache | Updates signal index cache based on input measurement keys.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ClientResponseHeaderSize | Size of client response header in bytes.
DefaultAllowMetadataRefresh | Default value for AllowMetadataRefresh.
DefaultAllowNaNValueFilter | Default value for AllowNaNValueFilter.
DefaultAllowPayloadCompression | Default value for AllowPayloadCompression.
DefaultAllowSynchronizedSubscription | Default value for AllowSynchronizedSubscription.
DefaultCipherKeyRotationPeriod | Default value for CipherKeyRotationPeriod.
DefaultCompressionStrength | Default value for CompressionStrength.
DefaultEncryptPayload | Default value for EncryptPayload.
DefaultForceNaNValueFilter | Default value for ForceNaNValueFilter.
DefaultMetadataTables | Default value for MetadataTables.
DefaultRequireAuthentication | Default value for RequireAuthentication.
DefaultSecurityMode | Default value for SecurityMode.
DefaultSharedDatabase | Default value for SharedDatabase.
DefaultUseBaseTimeOffsets | Default value for UseBaseTimeOffsets.
MaxPacketSize | Maximum packet size before software fragmentation of payload.
Top
Properties
 | Name | Description
Public property | AllowMetadataRefresh | Gets or sets flag that indicates if this publisher will allow synchronized subscriptions when requested by subscribers.
Public property | AllowNaNValueFilter | Gets or sets flag that indicates if this publisher will allow filtering of data which is not a number.
Public property | AllowPayloadCompression | Gets or sets flag that indicates if this publisher will allow payload compression when requested by subscribers.
Public property | AllowSynchronizedSubscription | Gets or sets flag that indicates if this publisher will allow synchronized subscriptions when requested by subscribers.
Protected property | AutoInitialize | Gets flag that determines if DataPublisher subscriptions are automatically initialized when they are added to the collection. (Overrides AdapterCollectionBaseTAutoInitialize.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | AverageMeasurementsPerSecond | Gets the average value of the measurements per second calculation.
Public property | BufferBlockRetransmissions | Gets the total number of buffer block retransmissions on all subscriptions over the lifetime of the publisher.
Public property | CacheMeasurementKeys | Gets or sets the set of measurements which are cached by the data publisher to be published to subscribers immediately upon subscription.
Public property | CipherKeyRotationPeriod | Gets or sets the cipher key rotation period.
Protected property | ClientConnections | Gets dictionary of connected clients.
Protected property | CommandChannel | Gets or sets reference to TcpServer command channel, attaching and/or detaching to events as needed.
Public property | CompressionStrength | Gets or sets the compression strength value to use when compressing data for subscribers.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Overrides AdapterCollectionBaseTDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | EncryptPayload | Gets or sets flag that determines whether data sent over the data channel should be encrypted.
Public property | ForceNaNValueFilter | Gets or sets flag that indicates if this publisher will force filtering of data which is not a number.
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsConnected | Gets flag indicating if publisher is connected and listening.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | LifetimeAverageLatency | Gets the average latency calculated over the full lifetime of the publisher.
Public property | LifetimeMaximumLatency | Gets the maximum latency calculated over the full lifetime of the publisher.
Public property | LifetimeMeasurements | Gets the total number of measurements processed through this data publisher over the lifetime of the publisher.
Public property | LifetimeMinimumLatency | Gets the minimum latency calculated over the full lifetime of the publisher.
Public property | MaximumMeasurementsPerSecond | Gets the maximum value of the measurements per second calculation.
Public property | MetadataTables | Gets or sets semi-colon separated list of SQL select statements used to create data for meta-data exchange.
Public property | MinimumMeasurementsPerSecond | Gets the minimum value of the measurements per second calculation.
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this DataPublisher. (Overrides AdapterCollectionBaseTName.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequireAuthentication | Gets or sets flag that determines if DataPublisher should require subscribers to authenticate before making data requests.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from ActionAdapterCollection.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from ActionAdapterCollection.)
Public property | SecurityMode | Gets or sets the security mode of the DataPublisher's command channel.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | SharedDatabase | Gets or sets flag that indicates whether this publisher is publishing data that this node subscribed to from another node in a shared database.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the status of this DataPublisher. (Overrides ActionAdapterCollectionStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Public property | TotalBytesSent | Gets the total number of bytes sent to clients of this data publisher.
Public property | UseBaseTimeOffsets | Gets or sets flag that determines whether to use base time offsets to decrease the size of compact measurements.
Public property | UseZeroMQChannel | Gets or sets flag that determines if ZeroMQ should be used for command channel communications.
Top
Events
 | Name | Description
Public event | ClientConnected | Indicates that a new client has connected to the publisher.
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from ActionAdapterCollection.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | NewMeasurements | This event will be raised when there are new measurements available from the action adapter. (Inherited from ActionAdapterCollection.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessingComplete | Indicates to the host that processing for an input adapter (via temporal session) has completed.
Public event | RequestTemporalSupport | Event is raised when temporal support is requested. (Inherited from ActionAdapterCollection.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue. (Inherited from ActionAdapterCollection.)
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


DataPublisher Constructor

Grid Solutions Framework DataPublisher Constructor
Creates a new DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataPublisher()
Public Sub New
new : unit -> DataPublisher
GSF.TimeSeries.Transport.DataPublisher = function();
public:
DataPublisher()
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher Fields

Grid Solutions Framework DataPublisher Fields

The DataPublisher type exposes the following members.

Fields
Name | Description
ClientResponseHeaderSize | Size of client response header in bytes.
DefaultAllowMetadataRefresh | Default value for AllowMetadataRefresh.
DefaultAllowNaNValueFilter | Default value for AllowNaNValueFilter.
DefaultAllowPayloadCompression | Default value for AllowPayloadCompression.
DefaultAllowSynchronizedSubscription | Default value for AllowSynchronizedSubscription.
DefaultCipherKeyRotationPeriod | Default value for CipherKeyRotationPeriod.
DefaultCompressionStrength | Default value for CompressionStrength.
DefaultEncryptPayload | Default value for EncryptPayload.
DefaultForceNaNValueFilter | Default value for ForceNaNValueFilter.
DefaultMetadataTables | Default value for MetadataTables.
DefaultRequireAuthentication | Default value for RequireAuthentication.
DefaultSecurityMode | Default value for SecurityMode.
DefaultSharedDatabase | Default value for SharedDatabase.
DefaultUseBaseTimeOffsets | Default value for UseBaseTimeOffsets.
MaxPacketSize | Maximum packet size before software fragmentation of payload.
Top
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.ClientResponseHeaderSize Field

Grid Solutions Framework DataPublisherClientResponseHeaderSize Field
Size of client response header in bytes.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int ClientResponseHeaderSize
Public Const ClientResponseHeaderSize As Integer
static val mutable ClientResponseHeaderSize: int
var GSF.TimeSeries.Transport.DataPublisher.ClientResponseHeaderSize
public:
literal int ClientResponseHeaderSize

Field Value

Type: Int32
Remarks
Header consists of response byte, in-response-to server command byte, 4-byte int representing payload length.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultAllowMetadataRefresh Field

Grid Solutions Framework DataPublisherDefaultAllowMetadataRefresh Field
Default value for AllowMetadataRefresh.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowMetadataRefresh
Public Const DefaultAllowMetadataRefresh As Boolean
static val mutable DefaultAllowMetadataRefresh: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultAllowMetadataRefresh
public:
literal bool DefaultAllowMetadataRefresh

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultAllowNaNValueFilter Field

Grid Solutions Framework DataPublisherDefaultAllowNaNValueFilter Field
Default value for AllowNaNValueFilter.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowNaNValueFilter
Public Const DefaultAllowNaNValueFilter As Boolean
static val mutable DefaultAllowNaNValueFilter: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultAllowNaNValueFilter
public:
literal bool DefaultAllowNaNValueFilter

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultAllowPayloadCompression Field

Grid Solutions Framework DataPublisherDefaultAllowPayloadCompression Field
Default value for AllowPayloadCompression.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowPayloadCompression
Public Const DefaultAllowPayloadCompression As Boolean
static val mutable DefaultAllowPayloadCompression: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultAllowPayloadCompression
public:
literal bool DefaultAllowPayloadCompression

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultAllowSynchronizedSubscription Field

Grid Solutions Framework DataPublisherDefaultAllowSynchronizedSubscription Field
Default value for AllowSynchronizedSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultAllowSynchronizedSubscription
Public Const DefaultAllowSynchronizedSubscription As Boolean
static val mutable DefaultAllowSynchronizedSubscription: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultAllowSynchronizedSubscription
public:
literal bool DefaultAllowSynchronizedSubscription

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultCipherKeyRotationPeriod Field

Grid Solutions Framework DataPublisherDefaultCipherKeyRotationPeriod Field
Default value for CipherKeyRotationPeriod.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double DefaultCipherKeyRotationPeriod
Public Const DefaultCipherKeyRotationPeriod As Double
static val mutable DefaultCipherKeyRotationPeriod: float
var GSF.TimeSeries.Transport.DataPublisher.DefaultCipherKeyRotationPeriod
public:
literal double DefaultCipherKeyRotationPeriod

Field Value

Type: Double
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultCompressionStrength Field

Grid Solutions Framework DataPublisherDefaultCompressionStrength Field
Default value for CompressionStrength.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultCompressionStrength
Public Const DefaultCompressionStrength As Integer
static val mutable DefaultCompressionStrength: int
var GSF.TimeSeries.Transport.DataPublisher.DefaultCompressionStrength
public:
literal int DefaultCompressionStrength

Field Value

Type: Int32
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultEncryptPayload Field

Grid Solutions Framework DataPublisherDefaultEncryptPayload Field
Default value for EncryptPayload.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultEncryptPayload
Public Const DefaultEncryptPayload As Boolean
static val mutable DefaultEncryptPayload: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultEncryptPayload
public:
literal bool DefaultEncryptPayload

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultForceNaNValueFilter Field

Grid Solutions Framework DataPublisherDefaultForceNaNValueFilter Field
Default value for ForceNaNValueFilter.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultForceNaNValueFilter
Public Const DefaultForceNaNValueFilter As Boolean
static val mutable DefaultForceNaNValueFilter: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultForceNaNValueFilter
public:
literal bool DefaultForceNaNValueFilter

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultMetadataTables Field

Grid Solutions Framework DataPublisherDefaultMetadataTables Field
Default value for MetadataTables.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultMetadataTables
Public Const DefaultMetadataTables As String
static val mutable DefaultMetadataTables: string
var GSF.TimeSeries.Transport.DataPublisher.DefaultMetadataTables
public:
literal String^ DefaultMetadataTables

Field Value

Type: String
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultRequireAuthentication Field

Grid Solutions Framework DataPublisherDefaultRequireAuthentication Field
Default value for RequireAuthentication.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultRequireAuthentication
Public Const DefaultRequireAuthentication As Boolean
static val mutable DefaultRequireAuthentication: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultRequireAuthentication
public:
literal bool DefaultRequireAuthentication

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultSecurityMode Field

Grid Solutions Framework DataPublisherDefaultSecurityMode Field
Default value for SecurityMode.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const SecurityMode DefaultSecurityMode
Public Const DefaultSecurityMode As SecurityMode
static val mutable DefaultSecurityMode: SecurityMode
var GSF.TimeSeries.Transport.DataPublisher.DefaultSecurityMode
public:
literal SecurityMode DefaultSecurityMode

Field Value

Type: SecurityMode
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultSharedDatabase Field

Grid Solutions Framework DataPublisherDefaultSharedDatabase Field
Default value for SharedDatabase.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultSharedDatabase
Public Const DefaultSharedDatabase As Boolean
static val mutable DefaultSharedDatabase: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultSharedDatabase
public:
literal bool DefaultSharedDatabase

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DefaultUseBaseTimeOffsets Field

Grid Solutions Framework DataPublisherDefaultUseBaseTimeOffsets Field
Default value for UseBaseTimeOffsets.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultUseBaseTimeOffsets
Public Const DefaultUseBaseTimeOffsets As Boolean
static val mutable DefaultUseBaseTimeOffsets: bool
var GSF.TimeSeries.Transport.DataPublisher.DefaultUseBaseTimeOffsets
public:
literal bool DefaultUseBaseTimeOffsets

Field Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.MaxPacketSize Field

Grid Solutions Framework DataPublisherMaxPacketSize Field
Maximum packet size before software fragmentation of payload.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int MaxPacketSize
Public Const MaxPacketSize As Integer
static val mutable MaxPacketSize: int
var GSF.TimeSeries.Transport.DataPublisher.MaxPacketSize
public:
literal int MaxPacketSize

Field Value

Type: Int32
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher Methods

Grid Solutions Framework DataPublisher Methods

The DataPublisher type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an item to the ICollectionT. (Inherited from ListCollectionT.)
Protected method | AquireMetadata | Gets meta-data to return to DataSubscriber.
Public method | Clear | Removes all items from the ICollectionT. (Inherited from ListCollectionT.)
Protected method | ClearItems | Removes all elements from the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | Contains | Determines whether the ICollectionT contains a specific value. (Inherited from ListCollectionT.)
Public method | CopyTo | Copies the elements of the ICollectionT to an Array, starting at a particular Array index. (Inherited from ListCollectionT.)
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataPublisher object and optionally releases the managed resources. (Overrides AdapterCollectionBaseTDispose(Boolean).)
Protected method | DisposeItem | Unwires events and disposes of IActionAdapter implementation. (Inherited from ActionAdapterCollection.)
Public method | EnumerateClients | Enumerates connected clients.
Public method | EnumerateTemporalClients | Enumerates connected clients with active temporal sessions.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the DataPublisher object is reclaimed by GC. (Overrides AdapterCollectionBaseTFinalize.)
Protected method | GetClientEncoding | Gets the text encoding associated with a particular client.
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from ListCollectionT.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLocalCertificate | Gets the local certificate currently in use by the data publisher.
Public method | GetShortStatus | Gets a short one-line status of this DataPublisher. (Overrides AdapterCollectionBaseTGetShortStatus(Int32).)
Public method | GetSubscriberInfo | Gets subscriber information for specified client connection.
Public method | GetSubscriberStatus | Gets subscriber status for specified subscriber ID.
Public method | GetTemporalStatus | Gets temporal status for a specified client connection.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ImportCertificate | Imports a certificate to the trusted certificates path.
Public method | IndexOf | Determines the index of a specific item in the IListT. (Inherited from ListCollectionT.)
Public method | Initialize | Initializes DataPublisher. (Overrides ActionAdapterCollectionInitialize.)
Protected method | InitializeItem | Wires events and initializes new IActionAdapter implementation. (Inherited from ActionAdapterCollection.)
Public method | Insert | Inserts an item to the IListT at the specified index. (Inherited from ListCollectionT.)
Protected method | InsertItem | Inserts an element into the CollectionT the specified index. (Inherited from AdapterCollectionBaseT.)
Protected method | LookupSignalID | Looks up Guid signal ID for given MeasurementKey.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnClientConnected | Raises the ClientConnected event.
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from ActionAdapterCollection.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from ActionAdapterCollection.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event.
Protected method | OnRequestTemporalSupport | Raises RequestTemporalSupport event. (Inherited from ActionAdapterCollection.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterCollectionBaseT.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterCollectionBaseT.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from ActionAdapterCollection.)
Public method | QueueMeasurementsForProcessing | Queues a collection of measurements for processing to each IActionAdapter connected to this DataPublisher. (Overrides ActionAdapterCollectionQueueMeasurementsForProcessing(IEnumerableIMeasurement).)
Public method | Remove | Removes the first occurrence of a specific object from the ICollectionT. (Inherited from ListCollectionT.)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from ListCollectionT.)
Protected method | RemoveItem | Removes the element at the specified index of the CollectionT. (Inherited from AdapterCollectionBaseT.)
Public method | ResetLifetimeCounters | Resets the counters for the lifetime statistics without interrupting the adapter's operations.
Public method | ResetStatistics | Resets the statistics of this collection. (Inherited from AdapterCollectionBaseT.)
Public method | RotateCipherKeys | Rotates cipher keys for specified client connection.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand) | Sends response back to specified client.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, Byte) | Sends response back to specified client with attached data.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, String) | Sends response back to specified client with a message.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, String, Object) | Sends response back to specified client with a formatted message.
Protected method | SendDataStartTime | Sends the start time of the first measurement in a connection transmission.
Public method | SendNotification | Sends a notification to all subscribers.
Protected method | SetItem | Assigns a new element to the CollectionT at the specified index. (Inherited from AdapterCollectionBaseT.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter collection and applies this constraint to each adapter. (Inherited from AdapterCollectionBaseT.)
Public method | Start | Establish DataPublisher and start listening for client connections. (Overrides AdapterCollectionBaseTStart.)
Public method | Stop | Terminate DataPublisher and stop listening for client connections. (Overrides AdapterCollectionBaseTStop.)
Protected method | SubscriberHasRights(Guid, Guid) | Determines if subscriber has rights to specified signalID.
Protected method | SubscriberHasRights(Guid, MeasurementKey, Guid) | Determines if subscriber has rights to specified MeasurementKey.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | TryCreateAdapter | Attempts to create an IAdapter from the specified DataRow. (Inherited from AdapterCollectionBaseT.)
Protected method | TryGetAdapterTValue | Attempts to get the adapter with the specified value given testItem function. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByID | Attempts to get the adapter with the specified id. (Inherited from AdapterCollectionBaseT.)
Public method | TryGetAdapterByName | Attempts to get the adapter with the specified name. (Inherited from AdapterCollectionBaseT.)
Public method | TryInitializeAdapterByID | Attempts to initialize (or reinitialize) an individual IAdapter based on its ID. (Inherited from AdapterCollectionBaseT.)
Protected method | UpdateLatencyStatistics | Updates latency statistics based on the collection of latencies passed into the method.
Protected method | UpdateLatestMeasurementCache | Updates the latest measurement cache when the set of cached measurements may have changed.
Protected method | UpdateRights | Updates each subscription's inputs based on possible updates to that subscriber's rights.
Public method | UpdateSignalIndexCache | Updates signal index cache based on input measurement keys.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.AquireMetadata Method

Grid Solutions Framework DataPublisherAquireMetadata Method
Gets meta-data to return to DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual DataSet AquireMetadata(
    ClientConnection connection,
    Dictionary<string, Tuple<string, string, int>> filterExpressions
)
Protected Overridable Function AquireMetadata (
    connection As ClientConnection,
    filterExpressions As Dictionary(Of String, Tuple(Of String, String, Integer))
) As DataSet
abstract AquireMetadata :
        connection : ClientConnection *
        filterExpressions : Dictionary<string, Tuple<string, string, int>> -> DataSet
override AquireMetadata :
        connection : ClientConnection *
        filterExpressions : Dictionary<string, Tuple<string, string, int>> -> DataSet
function AquireMetadata(connection, filterExpressions);
protected:
virtual DataSet^ AquireMetadata(
    ClientConnection^ connection,
    Dictionary<String^, Tuple<String^, String^, int>^>^ filterExpressions
)

Parameters

connection
Type: GSF.TimeSeries.TransportClientConnection
Client connection requesting meta-data.
filterExpressions
Type: System.Collections.GenericDictionary String, Tuple String, String, Int32
Any meta-data filter expressions requested by client.

Return Value

Type: DataSet
Meta-data to be returned to client.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Dispose Method

Grid Solutions Framework DataPublisherDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterCollectionBaseT object. (Inherited from AdapterCollectionBaseT.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataPublisher object and optionally releases the managed resources. (Overrides AdapterCollectionBaseTDispose(Boolean).)
Top
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Dispose Method (Boolean)

Grid Solutions Framework DataPublisherDispose Method (Boolean)
Releases the unmanaged resources used by the DataPublisher object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

DataPublisher Class
Dispose Overload
GSF.TimeSeries.Transport Namespace


DataPublisher.EnumerateClients Method

Grid Solutions Framework DataPublisherEnumerateClients Method
Enumerates connected clients.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Enumerates connected clients.", new string[] { ... })]
public virtual void EnumerateClients()
<AdapterCommandAttribute("Enumerates connected clients.", New String() { ... })>
Public Overridable Sub EnumerateClients
[<AdapterCommandAttribute("Enumerates connected clients.", new string[] { ... })>]
abstract EnumerateClients : unit -> unit
[<AdapterCommandAttribute("Enumerates connected clients.", new string[] { ... })>]
override EnumerateClients : unit -> unit
function EnumerateClients();
public:
[AdapterCommandAttribute(L"Enumerates connected clients.", __gc new array<String^>^ { ... })]
virtual void EnumerateClients()
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.EnumerateTemporalClients Method

Grid Solutions Framework DataPublisherEnumerateTemporalClients Method
Enumerates connected clients with active temporal sessions.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Enumerates connected clients with active temporal sessions.",
    new string[] { ... })]
public virtual void EnumerateTemporalClients()
<AdapterCommandAttribute("Enumerates connected clients with active temporal sessions.",
    New String() { ... })>
Public Overridable Sub EnumerateTemporalClients
[<AdapterCommandAttribute("Enumerates connected clients with active temporal sessions.",
    new string[] { ... })>]
abstract EnumerateTemporalClients : unit -> unit
[<AdapterCommandAttribute("Enumerates connected clients with active temporal sessions.",
    new string[] { ... })>]
override EnumerateTemporalClients : unit -> unit
function EnumerateTemporalClients();
public:
[AdapterCommandAttribute(L"Enumerates connected clients with active temporal sessions.",
    __gc new array<String^>^ { ... })]
virtual void EnumerateTemporalClients()
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Finalize Method

Grid Solutions Framework DataPublisherFinalize Method
Releases the unmanaged resources before the DataPublisher object is reclaimed by GC.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Finalize()
Protected Overrides Sub Finalize
abstract Finalize : unit -> unit
override Finalize : unit -> unit
function Finalize();
protected:
virtual void Finalize() override
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.GetClientEncoding Method

Grid Solutions Framework DataPublisherGetClientEncoding Method
Gets the text encoding associated with a particular client.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Encoding GetClientEncoding(
    Guid clientID
)
Protected Function GetClientEncoding (
    clientID As Guid
) As Encoding
member GetClientEncoding :
        clientID : Guid -> Encoding

function GetClientEncoding(clientID);
protected:
Encoding^ GetClientEncoding(
    Guid clientID
)

Parameters

clientID
Type: SystemGuid
ID of client.

Return Value

Type: Encoding
Text encoding associated with a particular client.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.GetLocalCertificate Method

Grid Solutions Framework DataPublisherGetLocalCertificate Method
Gets the local certificate currently in use by the data publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Gets the local certificate currently in use by the data publisher.",
    new string[] { ... })]
public virtual byte[] GetLocalCertificate()
<AdapterCommandAttribute("Gets the local certificate currently in use by the data publisher.",
    New String() { ... })>
Public Overridable Function GetLocalCertificate As Byte()
[<AdapterCommandAttribute("Gets the local certificate currently in use by the data publisher.",
    new string[] { ... })>]
abstract GetLocalCertificate : unit -> byte[]
[<AdapterCommandAttribute("Gets the local certificate currently in use by the data publisher.",
    new string[] { ... })>]
override GetLocalCertificate : unit -> byte[]
function GetLocalCertificate();
public:
[AdapterCommandAttribute(L"Gets the local certificate currently in use by the data publisher.",
    __gc new array<String^>^ { ... })]
virtual array<unsigned char>^ GetLocalCertificate()

Return Value

Type: Byte
The local certificate file read directly from the certificate file as an array of bytes.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.GetShortStatus Method

Grid Solutions Framework DataPublisherGetShortStatus Method
Gets a short one-line status of this DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string
override GetShortStatus :
        maxLength : int -> string
function GetShortStatus(maxLength);
public:
virtual String^ GetShortStatus(
    int maxLength
) override

Parameters

maxLength
Type: SystemInt32
Maximum number of available characters for display.

Return Value

Type: String
A short one-line summary of the current status of the DataPublisher.

Implements

IAdapterGetShortStatus(Int32)
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.GetSubscriberInfo Method

Grid Solutions Framework DataPublisherGetSubscriberInfo Method
Gets subscriber information for specified client connection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Gets subscriber information for client connection using its enumerated index.",
    new string[] { ... })]
public virtual string GetSubscriberInfo(
    int clientIndex
)
<AdapterCommandAttribute("Gets subscriber information for client connection using its enumerated index.",
    New String() { ... })>
Public Overridable Function GetSubscriberInfo (
    clientIndex As Integer
) As String
[<AdapterCommandAttribute("Gets subscriber information for client connection using its enumerated index.",
    new string[] { ... })>]
abstract GetSubscriberInfo :
        clientIndex : int -> string
[<AdapterCommandAttribute("Gets subscriber information for client connection using its enumerated index.",
    new string[] { ... })>]
override GetSubscriberInfo :
        clientIndex : int -> string
function GetSubscriberInfo(clientIndex);
public:
[AdapterCommandAttribute(L"Gets subscriber information for client connection using its enumerated index.",
    __gc new array<String^>^ { ... })]
virtual String^ GetSubscriberInfo(
    int clientIndex
)

Parameters

clientIndex
Type: SystemInt32
Enumerated index for client connection.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.TimeSeries.Transport.DataPublisher.GetSubscriberInfo(System.Int32)"]

See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.GetSubscriberStatus Method

Grid Solutions Framework DataPublisherGetSubscriberStatus Method
Gets subscriber status for specified subscriber ID.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Gets subscriber status for client connection using its subscriber ID.",
    new string[] { ... })]
public virtual Tuple<Guid, bool, string> GetSubscriberStatus(
    Guid subscriberID
)
<AdapterCommandAttribute("Gets subscriber status for client connection using its subscriber ID.",
    New String() { ... })>
Public Overridable Function GetSubscriberStatus (
    subscriberID As Guid
) As Tuple(Of Guid, Boolean, String)
[<AdapterCommandAttribute("Gets subscriber status for client connection using its subscriber ID.",
    new string[] { ... })>]
abstract GetSubscriberStatus :
        subscriberID : Guid -> Tuple<Guid, bool, string>
[<AdapterCommandAttribute("Gets subscriber status for client connection using its subscriber ID.",
    new string[] { ... })>]
override GetSubscriberStatus :
        subscriberID : Guid -> Tuple<Guid, bool, string>
function GetSubscriberStatus(subscriberID);
public:
[AdapterCommandAttribute(L"Gets subscriber status for client connection using its subscriber ID.",
    __gc new array<String^>^ { ... })]
virtual Tuple<Guid, bool, String^>^ GetSubscriberStatus(
    Guid subscriberID
)

Parameters

subscriberID
Type: SystemGuid
Guid based subscriber ID for client connection.

Return Value

Type: Tuple Guid, Boolean, String

[Missing <returns> documentation for "M:GSF.TimeSeries.Transport.DataPublisher.GetSubscriberStatus(System.Guid)"]

See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.GetTemporalStatus Method

Grid Solutions Framework DataPublisherGetTemporalStatus Method
Gets temporal status for a specified client connection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Gets temporal status for a subscriber, if any, using its enumerated index.",
    new string[] { ... })]
public virtual string GetTemporalStatus(
    int clientIndex
)
<AdapterCommandAttribute("Gets temporal status for a subscriber, if any, using its enumerated index.",
    New String() { ... })>
Public Overridable Function GetTemporalStatus (
    clientIndex As Integer
) As String
[<AdapterCommandAttribute("Gets temporal status for a subscriber, if any, using its enumerated index.",
    new string[] { ... })>]
abstract GetTemporalStatus :
        clientIndex : int -> string
[<AdapterCommandAttribute("Gets temporal status for a subscriber, if any, using its enumerated index.",
    new string[] { ... })>]
override GetTemporalStatus :
        clientIndex : int -> string
function GetTemporalStatus(clientIndex);
public:
[AdapterCommandAttribute(L"Gets temporal status for a subscriber, if any, using its enumerated index.",
    __gc new array<String^>^ { ... })]
virtual String^ GetTemporalStatus(
    int clientIndex
)

Parameters

clientIndex
Type: SystemInt32
Enumerated index for client connection.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.TimeSeries.Transport.DataPublisher.GetTemporalStatus(System.Int32)"]

See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.ImportCertificate Method

Grid Solutions Framework DataPublisherImportCertificate Method
Imports a certificate to the trusted certificates path.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Imports a certificate to the trusted certificates path.",
    new string[] { ... })]
public virtual string ImportCertificate(
    string fileName,
    byte[] certificateData
)
<AdapterCommandAttribute("Imports a certificate to the trusted certificates path.",
    New String() { ... })>
Public Overridable Function ImportCertificate (
    fileName As String,
    certificateData As Byte()
) As String
[<AdapterCommandAttribute("Imports a certificate to the trusted certificates path.",
    new string[] { ... })>]
abstract ImportCertificate :
        fileName : string *
        certificateData : byte[] -> string
[<AdapterCommandAttribute("Imports a certificate to the trusted certificates path.",
    new string[] { ... })>]
override ImportCertificate :
        fileName : string *
        certificateData : byte[] -> string
function ImportCertificate(fileName, certificateData);
public:
[AdapterCommandAttribute(L"Imports a certificate to the trusted certificates path.",
    __gc new array<String^>^ { ... })]
virtual String^ ImportCertificate(
    String^ fileName,
    array<unsigned char>^ certificateData
)

Parameters

fileName
Type: SystemString
The file name to give to the certificate when imported.
certificateData
Type: SystemByte
The data to be written to the certificate file.

Return Value

Type: String
The local path on the server where the file was written.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Initialize Method

Grid Solutions Framework DataPublisherInitialize Method
Initializes DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.LookupSignalID Method

Grid Solutions Framework DataPublisherLookupSignalID Method
Looks up Guid signal ID for given MeasurementKey.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Guid LookupSignalID(
    MeasurementKey key
)
Protected Function LookupSignalID (
    key As MeasurementKey
) As Guid
member LookupSignalID :
        key : MeasurementKey -> Guid

function LookupSignalID(key);
protected:
Guid LookupSignalID(
    MeasurementKey^ key
)

Parameters

key
Type: GSF.TimeSeriesMeasurementKey
MeasurementKey to lookup.

Return Value

Type: Guid
Guid signal ID if found; otherwise an empty Guid.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.OnClientConnected Method

Grid Solutions Framework DataPublisherOnClientConnected Method
Raises the ClientConnected event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnClientConnected(
    Guid subscriberID,
    string connectionID,
    string subscriberInfo
)
Protected Overridable Sub OnClientConnected (
    subscriberID As Guid,
    connectionID As String,
    subscriberInfo As String
)
abstract OnClientConnected :
        subscriberID : Guid *
        connectionID : string *
        subscriberInfo : string -> unit
override OnClientConnected :
        subscriberID : Guid *
        connectionID : string *
        subscriberInfo : string -> unit
function OnClientConnected(subscriberID, connectionID, subscriberInfo);
protected:
virtual void OnClientConnected(
    Guid subscriberID,
    String^ connectionID,
    String^ subscriberInfo
)

Parameters

subscriberID
Type: SystemGuid
Subscriber Guid (normally SubscriberID).
connectionID
Type: SystemString
Connection identification (normally ConnectionID).
subscriberInfo
Type: SystemString
Subscriber information (normally SubscriberInfo).
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.OnProcessingComplete Method

Grid Solutions Framework DataPublisherOnProcessingComplete Method
Raises the ProcessingComplete event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void OnProcessingComplete()
Protected Overridable Sub OnProcessingComplete
abstract OnProcessingComplete : unit -> unit
override OnProcessingComplete : unit -> unit
function OnProcessingComplete();
protected:
virtual void OnProcessingComplete()
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.QueueMeasurementsForProcessing Method

Grid Solutions Framework DataPublisherQueueMeasurementsForProcessing Method
Queues a collection of measurements for processing to each IActionAdapter connected to this DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overrides Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
) override

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Measurements to queue for processing.

Implements

IActionAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.ResetLifetimeCounters Method

Grid Solutions Framework DataPublisherResetLifetimeCounters Method
Resets the counters for the lifetime statistics without interrupting the adapter's operations.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    new string[] { ... })]
public virtual void ResetLifetimeCounters()
<AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    New String() { ... })>
Public Overridable Sub ResetLifetimeCounters
[<AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    new string[] { ... })>]
abstract ResetLifetimeCounters : unit -> unit
[<AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    new string[] { ... })>]
override ResetLifetimeCounters : unit -> unit
function ResetLifetimeCounters();
public:
[AdapterCommandAttribute(L"Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    __gc new array<String^>^ { ... })]
virtual void ResetLifetimeCounters()
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.RotateCipherKeys Method

Grid Solutions Framework DataPublisherRotateCipherKeys Method
Rotates cipher keys for specified client connection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Rotates cipher keys for client connection using its enumerated index.",
    new string[] { ... })]
public virtual void RotateCipherKeys(
    int clientIndex
)
<AdapterCommandAttribute("Rotates cipher keys for client connection using its enumerated index.",
    New String() { ... })>
Public Overridable Sub RotateCipherKeys (
    clientIndex As Integer
)
[<AdapterCommandAttribute("Rotates cipher keys for client connection using its enumerated index.",
    new string[] { ... })>]
abstract RotateCipherKeys :
        clientIndex : int -> unit
[<AdapterCommandAttribute("Rotates cipher keys for client connection using its enumerated index.",
    new string[] { ... })>]
override RotateCipherKeys :
        clientIndex : int -> unit
function RotateCipherKeys(clientIndex);
public:
[AdapterCommandAttribute(L"Rotates cipher keys for client connection using its enumerated index.",
    __gc new array<String^>^ { ... })]
virtual void RotateCipherKeys(
    int clientIndex
)

Parameters

clientIndex
Type: SystemInt32
Enumerated index for client connection.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.SendClientResponse Method

Grid Solutions Framework DataPublisherSendClientResponse Method
Overload List
 | Name | Description
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand) | Sends response back to specified client.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, Byte) | Sends response back to specified client with attached data.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, String) | Sends response back to specified client with a message.
Protected method | SendClientResponse(Guid, ServerResponse, ServerCommand, String, Object) | Sends response back to specified client with a formatted message.
Top
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.SendClientResponse Method (Guid, ServerResponse, ServerCommand)

Grid Solutions Framework DataPublisherSendClientResponse Method (Guid, ServerResponse, ServerCommand)
Sends response back to specified client.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command
)
Protected Overridable Function SendClientResponse (
    clientID As Guid,
    response As ServerResponse,
    command As ServerCommand
) As Boolean
abstract SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand -> bool
override SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand -> bool
function SendClientResponse(clientID, response, command);
protected:
virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command
)

Parameters

clientID
Type: SystemGuid
ID of client to send response.
response
Type: GSF.TimeSeries.TransportServerResponse
Server response.
command
Type: GSF.TimeSeries.TransportServerCommand
In response to command.

Return Value

Type: Boolean
true if send was successful; otherwise false.
See Also

Reference

DataPublisher Class
SendClientResponse Overload
GSF.TimeSeries.Transport Namespace


DataPublisher.SendClientResponse Method (Guid, ServerResponse, ServerCommand, Byte[])

Grid Solutions Framework DataPublisherSendClientResponse Method (Guid, ServerResponse, ServerCommand, Byte)
Sends response back to specified client with attached data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command,
    byte[] data
)
Protected Overridable Function SendClientResponse (
    clientID As Guid,
    response As ServerResponse,
    command As ServerCommand,
    data As Byte()
) As Boolean
abstract SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand *
        data : byte[] -> bool
override SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand *
        data : byte[] -> bool
function SendClientResponse(clientID, response, command, data);
protected:
virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command,
    array<unsigned char>^ data
)

Parameters

clientID
Type: SystemGuid
ID of client to send response.
response
Type: GSF.TimeSeries.TransportServerResponse
Server response.
command
Type: GSF.TimeSeries.TransportServerCommand
In response to command.
data
Type: SystemByte
Data to return to client; null if none.

Return Value

Type: Boolean
true if send was successful; otherwise false.
See Also

Reference

DataPublisher Class
SendClientResponse Overload
GSF.TimeSeries.Transport Namespace


DataPublisher.SendClientResponse Method (Guid, ServerResponse, ServerCommand, String)

Grid Solutions Framework DataPublisherSendClientResponse Method (Guid, ServerResponse, ServerCommand, String)
Sends response back to specified client with a message.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command,
    string status
)
Protected Overridable Function SendClientResponse (
    clientID As Guid,
    response As ServerResponse,
    command As ServerCommand,
    status As String
) As Boolean
abstract SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand *
        status : string -> bool
override SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand *
        status : string -> bool
function SendClientResponse(clientID, response, command, status);
protected:
virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command,
    String^ status
)

Parameters

clientID
Type: SystemGuid
ID of client to send response.
response
Type: GSF.TimeSeries.TransportServerResponse
Server response.
command
Type: GSF.TimeSeries.TransportServerCommand
In response to command.
status
Type: SystemString
Status message to return.

Return Value

Type: Boolean
true if send was successful; otherwise false.
See Also

Reference

DataPublisher Class
SendClientResponse Overload
GSF.TimeSeries.Transport Namespace


DataPublisher.SendClientResponse Method (Guid, ServerResponse, ServerCommand, String, Object[])

Grid Solutions Framework DataPublisherSendClientResponse Method (Guid, ServerResponse, ServerCommand, String, Object)
Sends response back to specified client with a formatted message.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command,
    string formattedStatus,
    params Object[] args
)
Protected Overridable Function SendClientResponse (
    clientID As Guid,
    response As ServerResponse,
    command As ServerCommand,
    formattedStatus As String,
    ParamArray args As Object()
) As Boolean
abstract SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand *
        formattedStatus : string *
        args : Object[] -> bool
override SendClientResponse :
        clientID : Guid *
        response : ServerResponse *
        command : ServerCommand *
        formattedStatus : string *
        args : Object[] -> bool
function SendClientResponse(clientID, response, command, formattedStatus, ... args);
protected:
virtual bool SendClientResponse(
    Guid clientID,
    ServerResponse response,
    ServerCommand command,
    String^ formattedStatus,
    ... array<Object^>^ args
)

Parameters

clientID
Type: SystemGuid
ID of client to send response.
response
Type: GSF.TimeSeries.TransportServerResponse
Server response.
command
Type: GSF.TimeSeries.TransportServerCommand
In response to command.
formattedStatus
Type: SystemString
Formatted status message to return.
args
Type: SystemObject
Arguments for formattedStatus.

Return Value

Type: Boolean
true if send was successful; otherwise false.
See Also

Reference

DataPublisher Class
SendClientResponse Overload
GSF.TimeSeries.Transport Namespace


DataPublisher.SendDataStartTime Method

Grid Solutions Framework DataPublisherSendDataStartTime Method
Sends the start time of the first measurement in a connection transmission.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool SendDataStartTime(
    Guid clientID,
    Ticks startTime
)
Protected Overridable Function SendDataStartTime (
    clientID As Guid,
    startTime As Ticks
) As Boolean
abstract SendDataStartTime :
        clientID : Guid *
        startTime : Ticks -> bool
override SendDataStartTime :
        clientID : Guid *
        startTime : Ticks -> bool
function SendDataStartTime(clientID, startTime);
protected:
virtual bool SendDataStartTime(
    Guid clientID,
    Ticks startTime
)

Parameters

clientID
Type: SystemGuid
ID of client to send response.
startTime
Type: GSFTicks
Start time, in Ticks, of first measurement transmitted.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:GSF.TimeSeries.Transport.DataPublisher.SendDataStartTime(System.Guid,GSF.Ticks)"]

See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.SendNotification Method

Grid Solutions Framework DataPublisherSendNotification Method
Sends a notification to all subscribers.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Sends a notification to all subscribers.", new string[] { ... })]
public virtual void SendNotification(
    string message
)
<AdapterCommandAttribute("Sends a notification to all subscribers.", New String() { ... })>
Public Overridable Sub SendNotification (
    message As String
)
[<AdapterCommandAttribute("Sends a notification to all subscribers.", new string[] { ... })>]
abstract SendNotification :
        message : string -> unit
[<AdapterCommandAttribute("Sends a notification to all subscribers.", new string[] { ... })>]
override SendNotification :
        message : string -> unit
function SendNotification(message);
public:
[AdapterCommandAttribute(L"Sends a notification to all subscribers.", __gc new array<String^>^ { ... })]
virtual void SendNotification(
    String^ message
)

Parameters

message
Type: SystemString
The message to be sent.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Start Method

Grid Solutions Framework DataPublisherStart Method
Establish DataPublisher and start listening for client connections.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Start()
Public Overrides Sub Start
abstract Start : unit -> unit
override Start : unit -> unit
function Start();
public:
virtual void Start() override

Implements

IAdapterStart
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Stop Method

Grid Solutions Framework DataPublisherStop Method
Terminate DataPublisher and stop listening for client connections.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Stop()
Public Overrides Sub Stop
abstract Stop : unit -> unit
override Stop : unit -> unit
function Stop();
public:
virtual void Stop() override

Implements

IAdapterStop
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.SubscriberHasRights Method

Grid Solutions Framework DataPublisherSubscriberHasRights Method
Overload List
 | Name | Description
Protected method | SubscriberHasRights(Guid, Guid) | Determines if subscriber has rights to specified signalID.
Protected method | SubscriberHasRights(Guid, MeasurementKey, Guid) | Determines if subscriber has rights to specified MeasurementKey.
Top
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.SubscriberHasRights Method (Guid, Guid)

Grid Solutions Framework DataPublisherSubscriberHasRights Method (Guid, Guid)
Determines if subscriber has rights to specified signalID.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool SubscriberHasRights(
    Guid subscriberID,
    Guid signalID
)
Protected Function SubscriberHasRights (
    subscriberID As Guid,
    signalID As Guid
) As Boolean
member SubscriberHasRights :
        subscriberID : Guid *
        signalID : Guid -> bool

function SubscriberHasRights(subscriberID, signalID);
protected:
bool SubscriberHasRights(
    Guid subscriberID,
    Guid signalID
)

Parameters

subscriberID
Type: SystemGuid
Guid based subscriber ID.
signalID
Type: SystemGuid
Guid signal ID to lookup.

Return Value

Type: Boolean
true if subscriber has rights to specified MeasurementKey; otherwise false.
See Also

Reference

DataPublisher Class
SubscriberHasRights Overload
GSF.TimeSeries.Transport Namespace


DataPublisher.SubscriberHasRights Method (Guid, MeasurementKey, Guid)

Grid Solutions Framework DataPublisherSubscriberHasRights Method (Guid, MeasurementKey, Guid)
Determines if subscriber has rights to specified MeasurementKey.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected bool SubscriberHasRights(
    Guid subscriberID,
    MeasurementKey key,
    out Guid signalID
)
Protected Function SubscriberHasRights (
    subscriberID As Guid,
    key As MeasurementKey,
    <OutAttribute> ByRef signalID As Guid
) As Boolean
member SubscriberHasRights :
        subscriberID : Guid *
        key : MeasurementKey *
        signalID : Guid byref -> bool

function SubscriberHasRights(subscriberID, key, signalID);
protected:
bool SubscriberHasRights(
    Guid subscriberID,
    MeasurementKey^ key,
    [OutAttribute] Guid% signalID
)

Parameters

subscriberID
Type: SystemGuid
Guid based subscriber ID.
key
Type: GSF.TimeSeriesMeasurementKey
MeasurementKey to lookup.
signalID
Type: SystemGuid
Guid signal ID if found; otherwise an empty Guid.

Return Value

Type: Boolean
true if subscriber has rights to specified MeasurementKey; otherwise false.
See Also

Reference

DataPublisher Class
SubscriberHasRights Overload
GSF.TimeSeries.Transport Namespace


DataPublisher.UpdateLatencyStatistics Method

Grid Solutions Framework DataPublisherUpdateLatencyStatistics Method
Updates latency statistics based on the collection of latencies passed into the method.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void UpdateLatencyStatistics(
    IEnumerable<long> latencies
)
Protected Overridable Sub UpdateLatencyStatistics (
    latencies As IEnumerable(Of Long)
)
abstract UpdateLatencyStatistics :
        latencies : IEnumerable<int64> -> unit
override UpdateLatencyStatistics :
        latencies : IEnumerable<int64> -> unit
function UpdateLatencyStatistics(latencies);
protected:
virtual void UpdateLatencyStatistics(
    IEnumerable<long long>^ latencies
)

Parameters

latencies
Type: System.Collections.GenericIEnumerable Int64
The latencies of the measurements sent by the publisher.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.UpdateLatestMeasurementCache Method

Grid Solutions Framework DataPublisherUpdateLatestMeasurementCache Method
Updates the latest measurement cache when the set of cached measurements may have changed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void UpdateLatestMeasurementCache()
Protected Sub UpdateLatestMeasurementCache
member UpdateLatestMeasurementCache : unit -> unit

function UpdateLatestMeasurementCache();
protected:
void UpdateLatestMeasurementCache()
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.UpdateRights Method

Grid Solutions Framework DataPublisherUpdateRights Method
Updates each subscription's inputs based on possible updates to that subscriber's rights.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void UpdateRights()
Protected Sub UpdateRights
member UpdateRights : unit -> unit

function UpdateRights();
protected:
void UpdateRights()
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.UpdateSignalIndexCache Method

Grid Solutions Framework DataPublisherUpdateSignalIndexCache Method
Updates signal index cache based on input measurement keys.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void UpdateSignalIndexCache(
    Guid clientID,
    SignalIndexCache signalIndexCache,
    MeasurementKey[] inputMeasurementKeys
)
Public Sub UpdateSignalIndexCache (
    clientID As Guid,
    signalIndexCache As SignalIndexCache,
    inputMeasurementKeys As MeasurementKey()
)
member UpdateSignalIndexCache :
        clientID : Guid *
        signalIndexCache : SignalIndexCache *
        inputMeasurementKeys : MeasurementKey[] -> unit

function UpdateSignalIndexCache(clientID, signalIndexCache, inputMeasurementKeys);
public:
void UpdateSignalIndexCache(
    Guid clientID,
    SignalIndexCache^ signalIndexCache,
    array<MeasurementKey^>^ inputMeasurementKeys
)

Parameters

clientID
Type: SystemGuid
Client ID of connection over which to update signal index cache.
signalIndexCache
Type: GSF.TimeSeries.TransportSignalIndexCache
New signal index cache.
inputMeasurementKeys
Type: GSF.TimeSeriesMeasurementKey
Subscribed measurement keys.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher Properties

Grid Solutions Framework DataPublisher Properties

The DataPublisher type exposes the following members.

Properties
 | Name | Description
Public property | AllowMetadataRefresh | Gets or sets flag that indicates if this publisher will allow synchronized subscriptions when requested by subscribers.
Public property | AllowNaNValueFilter | Gets or sets flag that indicates if this publisher will allow filtering of data which is not a number.
Public property | AllowPayloadCompression | Gets or sets flag that indicates if this publisher will allow payload compression when requested by subscribers.
Public property | AllowSynchronizedSubscription | Gets or sets flag that indicates if this publisher will allow synchronized subscriptions when requested by subscribers.
Protected property | AutoInitialize | Gets flag that determines if DataPublisher subscriptions are automatically initialized when they are added to the collection. (Overrides AdapterCollectionBaseTAutoInitialize.)
Public property | AutoStart | Gets or sets flag indicating if adapter collection should automatically start items when AutoInitialize is false. (Inherited from AdapterCollectionBaseT.)
Public property | AverageMeasurementsPerSecond | Gets the average value of the measurements per second calculation.
Public property | BufferBlockRetransmissions | Gets the total number of buffer block retransmissions on all subscriptions over the lifetime of the publisher.
Public property | CacheMeasurementKeys | Gets or sets the set of measurements which are cached by the data publisher to be published to subscribers immediately upon subscription.
Public property | CipherKeyRotationPeriod | Gets or sets the cipher key rotation period.
Protected property | ClientConnections | Gets dictionary of connected clients.
Protected property | CommandChannel | Gets or sets reference to TcpServer command channel, attaching and/or detaching to events as needed.
Public property | CompressionStrength | Gets or sets the compression strength value to use when compressing data for subscribers.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Count | Gets the number of elements contained in the ICollectionT. (Inherited from ListCollectionT.)
Public property | DataMember | Gets or sets specific data member (e.g., table name) in DataSource used to Initialize this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | DataSource | Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT. (Overrides AdapterCollectionBaseTDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | EncryptPayload | Gets or sets flag that determines whether data sent over the data channel should be encrypted.
Public property | ForceNaNValueFilter | Gets or sets flag that indicates if this publisher will force filtering of data which is not a number.
Public property | ID | Gets or sets numeric ID associated with this AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | InitializationTimeout | Gets or sets the default adapter time that represents the maximum time system will wait during Start for initialization. (Inherited from AdapterCollectionBaseT.)
Public property | Initialized | Gets or sets flag indicating if the adapter collection has been initialized successfully. (Inherited from AdapterCollectionBaseT.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterCollectionBaseT expects, if any. (Inherited from AdapterCollectionBaseT.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from AdapterCollectionBaseT.)
Public property | IsConnected | Gets flag indicating if publisher is connected and listening.
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterCollectionBaseT.)
Public property | IsReadOnly | Gets a value indicating whether the AdapterCollectionBaseT is read-only. (Inherited from AdapterCollectionBaseT.)
Public property | Item | Gets or sets the element at the specified index. (Inherited from ListCollectionT.)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from ListCollectionT.)
Public property | LifetimeAverageLatency | Gets the average latency calculated over the full lifetime of the publisher.
Public property | LifetimeMaximumLatency | Gets the maximum latency calculated over the full lifetime of the publisher.
Public property | LifetimeMeasurements | Gets the total number of measurements processed through this data publisher over the lifetime of the publisher.
Public property | LifetimeMinimumLatency | Gets the minimum latency calculated over the full lifetime of the publisher.
Public property | MaximumMeasurementsPerSecond | Gets the maximum value of the measurements per second calculation.
Public property | MetadataTables | Gets or sets semi-colon separated list of SQL select statements used to create data for meta-data exchange.
Public property | MinimumMeasurementsPerSecond | Gets the minimum value of the measurements per second calculation.
Protected property | MonitorTimerEnabled | Gets or sets flag that determines if monitor timer should be used for monitoring processed measurement statistics for the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | Name | Gets or sets the name of this DataPublisher. (Overrides AdapterCollectionBaseTName.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterCollectionBaseT will produce, if any. (Inherited from AdapterCollectionBaseT.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by each IAdapter implementation in the AdapterCollectionBaseT. (Inherited from AdapterCollectionBaseT.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter collection and applies this interval to each adapter. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from AdapterCollectionBaseT.)
Public property | RequireAuthentication | Gets or sets flag that determines if DataPublisher should require subscribers to authenticate before making data requests.
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from ActionAdapterCollection.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from ActionAdapterCollection.)
Public property | SecurityMode | Gets or sets the security mode of the DataPublisher's command channel.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterCollectionBaseT.)
Public property | SharedDatabase | Gets or sets flag that indicates whether this publisher is publishing data that this node subscribed to from another node in a shared database.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | Status | Gets the status of this DataPublisher. (Overrides ActionAdapterCollectionStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterCollectionBaseT.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter collection supports temporal processing. (Inherited from AdapterCollectionBaseT.)
Public property | TotalBytesSent | Gets the total number of bytes sent to clients of this data publisher.
Public property | UseBaseTimeOffsets | Gets or sets flag that determines whether to use base time offsets to decrease the size of compact measurements.
Public property | UseZeroMQChannel | Gets or sets flag that determines if ZeroMQ should be used for command channel communications.
Top
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.AllowMetadataRefresh Property

Grid Solutions Framework DataPublisherAllowMetadataRefresh Property
Gets or sets flag that indicates if this publisher will allow synchronized subscriptions when requested by subscribers.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public bool AllowMetadataRefresh { get; set; }
<DefaultValueAttribute(true)>
<ConnectionStringParameterAttribute>
Public Property AllowMetadataRefresh As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
[<ConnectionStringParameterAttribute>]
member AllowMetadataRefresh : bool with get, set

function get_AllowMetadataRefresh();
function set_AllowMetadataRefresh(value);
public:
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
property bool AllowMetadataRefresh {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.AllowNaNValueFilter Property

Grid Solutions Framework DataPublisherAllowNaNValueFilter Property
Gets or sets flag that indicates if this publisher will allow filtering of data which is not a number.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public bool AllowNaNValueFilter { get; set; }
<DefaultValueAttribute(true)>
<ConnectionStringParameterAttribute>
Public Property AllowNaNValueFilter As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
[<ConnectionStringParameterAttribute>]
member AllowNaNValueFilter : bool with get, set

function get_AllowNaNValueFilter();
function set_AllowNaNValueFilter(value);
public:
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
property bool AllowNaNValueFilter {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.AllowPayloadCompression Property

Grid Solutions Framework DataPublisherAllowPayloadCompression Property
Gets or sets flag that indicates if this publisher will allow payload compression when requested by subscribers.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public bool AllowPayloadCompression { get; set; }
<DefaultValueAttribute(true)>
<ConnectionStringParameterAttribute>
Public Property AllowPayloadCompression As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
[<ConnectionStringParameterAttribute>]
member AllowPayloadCompression : bool with get, set

function get_AllowPayloadCompression();
function set_AllowPayloadCompression(value);
public:
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
property bool AllowPayloadCompression {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.AllowSynchronizedSubscription Property

Grid Solutions Framework DataPublisherAllowSynchronizedSubscription Property
Gets or sets flag that indicates if this publisher will allow synchronized subscriptions when requested by subscribers.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
public bool AllowSynchronizedSubscription { get; set; }
<DefaultValueAttribute(true)>
<ConnectionStringParameterAttribute>
Public Property AllowSynchronizedSubscription As Boolean
    Get
    Set
[<DefaultValueAttribute(true)>]
[<ConnectionStringParameterAttribute>]
member AllowSynchronizedSubscription : bool with get, set

function get_AllowSynchronizedSubscription();
function set_AllowSynchronizedSubscription(value);
public:
[DefaultValueAttribute(true)]
[ConnectionStringParameterAttribute]
property bool AllowSynchronizedSubscription {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.AutoInitialize Property

Grid Solutions Framework DataPublisherAutoInitialize Property
Gets flag that determines if DataPublisher subscriptions are automatically initialized when they are added to the collection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool AutoInitialize { get; }
Protected Overrides ReadOnly Property AutoInitialize As Boolean
    Get
abstract AutoInitialize : bool with get
override AutoInitialize : bool with get
function get_AutoInitialize();

protected:
virtual property bool AutoInitialize {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.AverageMeasurementsPerSecond Property

Grid Solutions Framework DataPublisherAverageMeasurementsPerSecond Property
Gets the average value of the measurements per second calculation.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long AverageMeasurementsPerSecond { get; }
Public ReadOnly Property AverageMeasurementsPerSecond As Long
    Get
member AverageMeasurementsPerSecond : int64 with get

function get_AverageMeasurementsPerSecond();

public:
property long long AverageMeasurementsPerSecond {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.BufferBlockRetransmissions Property

Grid Solutions Framework DataPublisherBufferBlockRetransmissions Property
Gets the total number of buffer block retransmissions on all subscriptions over the lifetime of the publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long BufferBlockRetransmissions { get; }
Public ReadOnly Property BufferBlockRetransmissions As Long
    Get
member BufferBlockRetransmissions : int64 with get

function get_BufferBlockRetransmissions();

public:
property long long BufferBlockRetransmissions {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.CacheMeasurementKeys Property

Grid Solutions Framework DataPublisherCacheMeasurementKeys Property
Gets or sets the set of measurements which are cached by the data publisher to be published to subscribers immediately upon subscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute("")]
[CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)]
public string CacheMeasurementKeys { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute("")>
<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    Nothing)>
Public Property CacheMeasurementKeys As String
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute("")>]
[<CustomConfigurationEditorAttribute("GSF.TimeSeries.UI.WPF.dll", "GSF.TimeSeries.UI.Editors.MeasurementEditor",
    null)>]
member CacheMeasurementKeys : string with get, set

function get_CacheMeasurementKeys();
function set_CacheMeasurementKeys(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(L"")]
[CustomConfigurationEditorAttribute(L"GSF.TimeSeries.UI.WPF.dll", L"GSF.TimeSeries.UI.Editors.MeasurementEditor",
    nullptr)]
property String^ CacheMeasurementKeys {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.CipherKeyRotationPeriod Property

Grid Solutions Framework DataPublisherCipherKeyRotationPeriod Property
Gets or sets the cipher key rotation period.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(60000)]
[ConnectionStringParameterAttribute]
public double CipherKeyRotationPeriod { get; set; }
<DefaultValueAttribute(60000)>
<ConnectionStringParameterAttribute>
Public Property CipherKeyRotationPeriod As Double
    Get
    Set
[<DefaultValueAttribute(60000)>]
[<ConnectionStringParameterAttribute>]
member CipherKeyRotationPeriod : float with get, set

function get_CipherKeyRotationPeriod();
function set_CipherKeyRotationPeriod(value);
public:
[DefaultValueAttribute(60000)]
[ConnectionStringParameterAttribute]
property double CipherKeyRotationPeriod {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.ClientConnections Property

Grid Solutions Framework DataPublisherClientConnections Property
Gets dictionary of connected clients.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected ConcurrentDictionary<Guid, ClientConnection> ClientConnections { get; }
Protected ReadOnly Property ClientConnections As ConcurrentDictionary(Of Guid, ClientConnection)
    Get
member ClientConnections : ConcurrentDictionary<Guid, ClientConnection> with get

function get_ClientConnections();

protected:
property ConcurrentDictionary<Guid, ClientConnection^>^ ClientConnections {
    ConcurrentDictionary<Guid, ClientConnection^>^ get ();
}

Property Value

Type: ConcurrentDictionary Guid, ClientConnection
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.CommandChannel Property

Grid Solutions Framework DataPublisherCommandChannel Property
Gets or sets reference to TcpServer command channel, attaching and/or detaching to events as needed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IServer CommandChannel { get; set; }
Protected Property CommandChannel As IServer
    Get
    Set
member CommandChannel : IServer with get, set

function get_CommandChannel();
function set_CommandChannel(value);
protected:
property IServer^ CommandChannel {
    IServer^ get ();
    void set (IServer^ value);
}

Property Value

Type: IServer
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.CompressionStrength Property

Grid Solutions Framework DataPublisherCompressionStrength Property
Gets or sets the compression strength value to use when compressing data for subscribers.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(31)]
[ConnectionStringParameterAttribute]
public int CompressionStrength { get; set; }
<DefaultValueAttribute(31)>
<ConnectionStringParameterAttribute>
Public Property CompressionStrength As Integer
    Get
    Set
[<DefaultValueAttribute(31)>]
[<ConnectionStringParameterAttribute>]
member CompressionStrength : int with get, set

function get_CompressionStrength();
function set_CompressionStrength(value);
public:
[DefaultValueAttribute(31)]
[ConnectionStringParameterAttribute]
property int CompressionStrength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.DataSource Property

Grid Solutions Framework DataPublisherDataSource Property
Gets or sets DataSet based data source used to load each IAdapter. Updates to this property will cascade to all items in this AdapterCollectionBaseT.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSet DataSource { get; set; }
Public Overrides Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get () override;
    void set (DataSet^ value) override;
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.EncryptPayload Property

Grid Solutions Framework DataPublisherEncryptPayload Property
Gets or sets flag that determines whether data sent over the data channel should be encrypted.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
[ConnectionStringParameterAttribute]
public bool EncryptPayload { get; set; }
<DefaultValueAttribute(false)>
<ConnectionStringParameterAttribute>
Public Property EncryptPayload As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
[<ConnectionStringParameterAttribute>]
member EncryptPayload : bool with get, set

function get_EncryptPayload();
function set_EncryptPayload(value);
public:
[DefaultValueAttribute(false)]
[ConnectionStringParameterAttribute]
property bool EncryptPayload {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This value is only relevant if RequireAuthentication is true.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.ForceNaNValueFilter Property

Grid Solutions Framework DataPublisherForceNaNValueFilter Property
Gets or sets flag that indicates if this publisher will force filtering of data which is not a number.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
public bool ForceNaNValueFilter { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(false)>
Public Property ForceNaNValueFilter As Boolean
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(false)>]
member ForceNaNValueFilter : bool with get, set

function get_ForceNaNValueFilter();
function set_ForceNaNValueFilter(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
property bool ForceNaNValueFilter {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.IsConnected Property

Grid Solutions Framework DataPublisherIsConnected Property
Gets flag indicating if publisher is connected and listening.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IsConnected { get; }
Public ReadOnly Property IsConnected As Boolean
    Get
member IsConnected : bool with get

function get_IsConnected();

public:
property bool IsConnected {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.LifetimeAverageLatency Property

Grid Solutions Framework DataPublisherLifetimeAverageLatency Property
Gets the average latency calculated over the full lifetime of the publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LifetimeAverageLatency { get; }
Public ReadOnly Property LifetimeAverageLatency As Integer
    Get
member LifetimeAverageLatency : int with get

function get_LifetimeAverageLatency();

public:
property int LifetimeAverageLatency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.LifetimeMaximumLatency Property

Grid Solutions Framework DataPublisherLifetimeMaximumLatency Property
Gets the maximum latency calculated over the full lifetime of the publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LifetimeMaximumLatency { get; }
Public ReadOnly Property LifetimeMaximumLatency As Integer
    Get
member LifetimeMaximumLatency : int with get

function get_LifetimeMaximumLatency();

public:
property int LifetimeMaximumLatency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.LifetimeMeasurements Property

Grid Solutions Framework DataPublisherLifetimeMeasurements Property
Gets the total number of measurements processed through this data publisher over the lifetime of the publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long LifetimeMeasurements { get; }
Public ReadOnly Property LifetimeMeasurements As Long
    Get
member LifetimeMeasurements : int64 with get

function get_LifetimeMeasurements();

public:
property long long LifetimeMeasurements {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.LifetimeMinimumLatency Property

Grid Solutions Framework DataPublisherLifetimeMinimumLatency Property
Gets the minimum latency calculated over the full lifetime of the publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LifetimeMinimumLatency { get; }
Public ReadOnly Property LifetimeMinimumLatency As Integer
    Get
member LifetimeMinimumLatency : int with get

function get_LifetimeMinimumLatency();

public:
property int LifetimeMinimumLatency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.MaximumMeasurementsPerSecond Property

Grid Solutions Framework DataPublisherMaximumMeasurementsPerSecond Property
Gets the maximum value of the measurements per second calculation.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MaximumMeasurementsPerSecond { get; }
Public ReadOnly Property MaximumMeasurementsPerSecond As Long
    Get
member MaximumMeasurementsPerSecond : int64 with get

function get_MaximumMeasurementsPerSecond();

public:
property long long MaximumMeasurementsPerSecond {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.MetadataTables Property

Grid Solutions Framework DataPublisherMetadataTables Property
Gets or sets semi-colon separated list of SQL select statements used to create data for meta-data exchange.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute("SELECT NodeID, UniqueID, OriginalSource, IsConcentrator, Acronym, Name, AccessID, ParentAcronym, ProtocolName, FramesPerSecond, CompanyAcronym, VendorAcronym, VendorDeviceName, Longitude, Latitude, InterconnectionName, ContactList, Enabled, UpdatedOn FROM DeviceDetail WHERE IsConcentrator = 0;SELECT DeviceAcronym, ID, SignalID, PointTag, SignalReference, SignalAcronym, PhasorSourceIndex, Description, Internal, Enabled, UpdatedOn FROM MeasurementDetail;SELECT DeviceAcronym, Label, Type, Phase, SourceIndex, UpdatedOn FROM PhasorDetail;SELECT VersionNumber FROM SchemaVersion")]
public string MetadataTables { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute("SELECT NodeID, UniqueID, OriginalSource, IsConcentrator, Acronym, Name, AccessID, ParentAcronym, ProtocolName, FramesPerSecond, CompanyAcronym, VendorAcronym, VendorDeviceName, Longitude, Latitude, InterconnectionName, ContactList, Enabled, UpdatedOn FROM DeviceDetail WHERE IsConcentrator = 0;SELECT DeviceAcronym, ID, SignalID, PointTag, SignalReference, SignalAcronym, PhasorSourceIndex, Description, Internal, Enabled, UpdatedOn FROM MeasurementDetail;SELECT DeviceAcronym, Label, Type, Phase, SourceIndex, UpdatedOn FROM PhasorDetail;SELECT VersionNumber FROM SchemaVersion")>
Public Property MetadataTables As String
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute("SELECT NodeID, UniqueID, OriginalSource, IsConcentrator, Acronym, Name, AccessID, ParentAcronym, ProtocolName, FramesPerSecond, CompanyAcronym, VendorAcronym, VendorDeviceName, Longitude, Latitude, InterconnectionName, ContactList, Enabled, UpdatedOn FROM DeviceDetail WHERE IsConcentrator = 0;SELECT DeviceAcronym, ID, SignalID, PointTag, SignalReference, SignalAcronym, PhasorSourceIndex, Description, Internal, Enabled, UpdatedOn FROM MeasurementDetail;SELECT DeviceAcronym, Label, Type, Phase, SourceIndex, UpdatedOn FROM PhasorDetail;SELECT VersionNumber FROM SchemaVersion")>]
member MetadataTables : string with get, set

function get_MetadataTables();
function set_MetadataTables(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(L"SELECT NodeID, UniqueID, OriginalSource, IsConcentrator, Acronym, Name, AccessID, ParentAcronym, ProtocolName, FramesPerSecond, CompanyAcronym, VendorAcronym, VendorDeviceName, Longitude, Latitude, InterconnectionName, ContactList, Enabled, UpdatedOn FROM DeviceDetail WHERE IsConcentrator = 0;SELECT DeviceAcronym, ID, SignalID, PointTag, SignalReference, SignalAcronym, PhasorSourceIndex, Description, Internal, Enabled, UpdatedOn FROM MeasurementDetail;SELECT DeviceAcronym, Label, Type, Phase, SourceIndex, UpdatedOn FROM PhasorDetail;SELECT VersionNumber FROM SchemaVersion")]
property String^ MetadataTables {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.MinimumMeasurementsPerSecond Property

Grid Solutions Framework DataPublisherMinimumMeasurementsPerSecond Property
Gets the minimum value of the measurements per second calculation.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MinimumMeasurementsPerSecond { get; }
Public ReadOnly Property MinimumMeasurementsPerSecond As Long
    Get
member MinimumMeasurementsPerSecond : int64 with get

function get_MinimumMeasurementsPerSecond();

public:
property long long MinimumMeasurementsPerSecond {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Name Property

Grid Solutions Framework DataPublisherName Property
Gets or sets the name of this DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Name { get; set; }
Public Overrides Property Name As String
    Get
    Set
abstract Name : string with get, set
override Name : string with get, set
function get_Name();
function set_Name(value);
public:
virtual property String^ Name {
    String^ get () override;
    void set (String^ value) override;
}

Property Value

Type: String

Implements

IAdapterName
IProvideStatusName
Remarks
The assigned name is used as the settings category when persisting the TCP server settings.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.RequireAuthentication Property

Grid Solutions Framework DataPublisherRequireAuthentication Property
Gets or sets flag that determines if DataPublisher should require subscribers to authenticate before making data requests.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
[ConnectionStringParameterAttribute]
public bool RequireAuthentication { get; set; }
<DefaultValueAttribute(false)>
<ConnectionStringParameterAttribute>
Public Property RequireAuthentication As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
[<ConnectionStringParameterAttribute>]
member RequireAuthentication : bool with get, set

function get_RequireAuthentication();
function set_RequireAuthentication(value);
public:
[DefaultValueAttribute(false)]
[ConnectionStringParameterAttribute]
property bool RequireAuthentication {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.SecurityMode Property

Grid Solutions Framework DataPublisherSecurityMode Property
Gets or sets the security mode of the DataPublisher's command channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(SecurityMode.None)]
public SecurityMode SecurityMode { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(SecurityMode.None)>
Public Property SecurityMode As SecurityMode
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(SecurityMode.None)>]
member SecurityMode : SecurityMode with get, set

function get_SecurityMode();
function set_SecurityMode(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(SecurityMode::None)]
property SecurityMode SecurityMode {
    SecurityMode get ();
    void set (SecurityMode value);
}

Property Value

Type: SecurityMode
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.SharedDatabase Property

Grid Solutions Framework DataPublisherSharedDatabase Property
Gets or sets flag that indicates whether this publisher is publishing data that this node subscribed to from another node in a shared database.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
public bool SharedDatabase { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(false)>
Public Property SharedDatabase As Boolean
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(false)>]
member SharedDatabase : bool with get, set

function get_SharedDatabase();
function set_SharedDatabase(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
property bool SharedDatabase {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.Status Property

Grid Solutions Framework DataPublisherStatus Property
Gets the status of this DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
Remarks
Derived classes should provide current status information about the adapter for display purposes.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.TotalBytesSent Property

Grid Solutions Framework DataPublisherTotalBytesSent Property
Gets the total number of bytes sent to clients of this data publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalBytesSent { get; }
Public ReadOnly Property TotalBytesSent As Long
    Get
member TotalBytesSent : int64 with get

function get_TotalBytesSent();

public:
property long long TotalBytesSent {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.UseBaseTimeOffsets Property

Grid Solutions Framework DataPublisherUseBaseTimeOffsets Property
Gets or sets flag that determines whether to use base time offsets to decrease the size of compact measurements.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
public bool UseBaseTimeOffsets { get; set; }
<ConnectionStringParameterAttribute>
<DefaultValueAttribute(false)>
Public Property UseBaseTimeOffsets As Boolean
    Get
    Set
[<ConnectionStringParameterAttribute>]
[<DefaultValueAttribute(false)>]
member UseBaseTimeOffsets : bool with get, set

function get_UseBaseTimeOffsets();
function set_UseBaseTimeOffsets(value);
public:
[ConnectionStringParameterAttribute]
[DefaultValueAttribute(false)]
property bool UseBaseTimeOffsets {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.UseZeroMQChannel Property

Grid Solutions Framework DataPublisherUseZeroMQChannel Property
Gets or sets flag that determines if ZeroMQ should be used for command channel communications.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
[ConnectionStringParameterAttribute]
public bool UseZeroMQChannel { get; set; }
<DefaultValueAttribute(false)>
<ConnectionStringParameterAttribute>
Public Property UseZeroMQChannel As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
[<ConnectionStringParameterAttribute>]
member UseZeroMQChannel : bool with get, set

function get_UseZeroMQChannel();
function set_UseZeroMQChannel(value);
public:
[DefaultValueAttribute(false)]
[ConnectionStringParameterAttribute]
property bool UseZeroMQChannel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher Events

Grid Solutions Framework DataPublisher Events

The DataPublisher type exposes the following members.

Events
 | Name | Description
Public event | ClientConnected | Indicates that a new client has connected to the publisher.
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterCollectionBaseT.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from ActionAdapterCollection.)
Public event | Disposed | Event is raised when this AdapterCollectionBaseT is disposed or an IAdapter in the collection is disposed. (Inherited from AdapterCollectionBaseT.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterCollectionBaseT.)
Public event | NewMeasurements | This event will be raised when there are new measurements available from the action adapter. (Inherited from ActionAdapterCollection.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterCollectionBaseT.)
Public event | ProcessingComplete | Indicates to the host that processing for an input adapter (via temporal session) has completed.
Public event | RequestTemporalSupport | Event is raised when temporal support is requested. (Inherited from ActionAdapterCollection.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterCollectionBaseT.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue. (Inherited from ActionAdapterCollection.)
Top
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.ClientConnected Event

Grid Solutions Framework DataPublisherClientConnected Event
Indicates that a new client has connected to the publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Guid, string, string>> ClientConnected
Public Event ClientConnected As EventHandler(Of EventArgs(Of Guid, String, String))
member ClientConnected : IEvent<EventHandler<EventArgs<Guid, string, string>>,
    EventArgs<Guid, string, string>>

function add_ClientConnected(value);
function remove_ClientConnected(value);
public:
 event EventHandler<EventArgs<Guid, String^, String^>^>^ ClientConnected {
    void add (EventHandler<EventArgs<Guid, String^, String^>^>^ value);
    void remove (EventHandler<EventArgs<Guid, String^, String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Guid, String, String
Remarks
Argument1 is the Guid based subscriber ID.
Argument2 is the connection identification (e.g., IP and DNS name, if available).
Argument3 is the subscriber information as reported by the client.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataPublisher.ProcessingComplete Event

Grid Solutions Framework DataPublisherProcessingComplete Event
Indicates to the host that processing for an input adapter (via temporal session) has completed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ProcessingComplete
Public Event ProcessingComplete As EventHandler
member ProcessingComplete : IEvent<EventHandler,
    EventArgs>

function add_ProcessingComplete(value);
function remove_ProcessingComplete(value);
public:
 event EventHandler^ ProcessingComplete {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
Remarks
This event is expected to only be raised when an input adapter has been designed to process a finite amount of data, e.g., reading a historical range of data during temporal processing.
See Also

Reference

DataPublisher Class
GSF.TimeSeries.Transport Namespace


DataSubscriber Class

Grid Solutions Framework DataSubscriber Class
Represents a data subscribing client that will connect to a data publisher for a data subscription.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersAdapterBase
GSF.TimeSeries.AdaptersInputAdapterBase
GSF.TimeSeries.TransportDataSubscriber

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Advanced)]
public class DataSubscriber : InputAdapterBase
<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>
Public Class DataSubscriber
    Inherits InputAdapterBase
[<EditorBrowsableAttribute(EditorBrowsableState.Advanced)>]
type DataSubscriber =
    class
        inherit InputAdapterBase
    end
GSF.TimeSeries.Transport.DataSubscriber = function();

Type.createClass(
    'GSF.TimeSeries.Transport.DataSubscriber',
    GSF.TimeSeries.Adapters.InputAdapterBase);
[EditorBrowsableAttribute(EditorBrowsableState::Advanced)]
public ref class DataSubscriber : public InputAdapterBase

The DataSubscriber type exposes the following members.

Constructors
 | Name | Description
Public method | DataSubscriber | Creates a new DataSubscriber.
Top
Methods
 | Name | Description
Protected method | AttemptConnection | Attempts to connect to this DataSubscriber. (Overrides InputAdapterBaseAttemptConnection.)
Protected method | AttemptDisconnection | Attempts to disconnect from this DataSubscriber. (Overrides InputAdapterBaseAttemptDisconnection.)
Public method | Authenticate | Authenticates subscriber to a data publisher.
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataSubscriber object and optionally releases the managed resources. (Overrides InputAdapterBaseDispose(Boolean).)
Protected method | DisposeLocalConcentrator | Disposes of any previously defined local concentrator.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetAuthorizedSignalIDs | Returns the measurements signal IDs that were authorized after the last successful subscription request.
Public method | GetDataGapRecoverySubscriptionStatus | Gets the status of the temporal DataSubscriber used by the data gap recovery module.
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Protected method | GetLoggingPath | Gets file path for any defined logging path.
Public method | GetShortStatus | Gets a short one-line status of this DataSubscriber. (Overrides AdapterBaseGetShortStatus(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnauthorizedSignalIDs | Returns the measurements signal IDs that were unauthorized after the last successful subscription request.
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes DataSubscriber. (Overrides InputAdapterBaseInitialize.)
Protected method | InterpretResponseMessage | Get message from string based response.
Public method | LocallySynchronizedSubscribe | Obsolete. Subscribes (or re-subscribes) to a data publisher for a locally synchronized set of data points.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnConnected | Called when data input source connection is established. (Inherited from InputAdapterBase.)
Protected method | OnConnectionAuthenticated | Raises the ConnectionAuthenticated event.
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event.
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event.
Protected method | OnDataStartTime | Raises the DataStartTime event.
Protected method | OnDisconnected | Called when data input source is disconnected. (Inherited from InputAdapterBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnMetaDataReceived | Raises the MetaDataReceived event.
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from InputAdapterBase.)
Protected method | OnNotificationReceived | Raises the NotificationReceived event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event. (Inherited from InputAdapterBase.)
Protected method | OnProcessingComplete(String) | Raises the ProcessingComplete event.
Protected method | OnReceivedServerResponse | Raises the ReceivedServerResponse event.
Protected method | OnServerConfigurationChanged | Raises the ServerConfigurationChanged event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Public method | RefreshMetadata | Initiate a meta-data refresh.
Public method | RemotelySynchronizedSubscribe | Obsolete. Subscribes (or re-subscribes) to a data publisher for a remotely synchronized set of data points.
Public method | ResetLifetimeCounters | Resets the counters for the lifetime statistics without interrupting the adapter's operations.
Public method | SendServerCommand(ServerCommand, Byte) | Sends a server command to the publisher connection.
Public method | SendServerCommand(ServerCommand, String) | Sends a server command to the publisher connection with associated message data.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts this InputAdapterBase and initiates connection cycle to data input source. (Inherited from InputAdapterBase.)
Public method | Stop | Stops this InputAdapterBase and disconnects from data input source. (Inherited from InputAdapterBase.)
Public method | Subscribe(SubscriptionInfo) | Subscribes (or re-subscribes) to a data publisher for a set of data points.
Public method | Subscribe(Boolean, Boolean, String) | Subscribes (or re-subscribes) to a data publisher for a set of data points.
Public method | SynchronizedSubscribe | Subscribes (or re-subscribes) to a data publisher for a synchronized set of data points.
Protected method | SynchronizeMetadata | Handles meta-data synchronization to local system.
Public method | SynchronizeMetadata(DataSet) | Spawn meta-data synchronization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unsubscribe | Unsubscribes from a data publisher.
Public method | UnsynchronizedSubscribe(UnsynchronizedSubscriptionInfo) | Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.
Public method | UnsynchronizedSubscribe(Boolean, Boolean, String, String, Boolean, Double, Double, Boolean, String, String, String, Int32, String, Int32) | Obsolete. Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultLoggingPath | Default value for LoggingPath.
DefaultMetadataSynchronizationTimeout | Defines the default value for the MetadataSynchronizationTimeout property.
DefaultOperationalModes | Defines default value for OperationalModes.
DefaultUseTransactionForMetadata | Defines the default value for the UseTransactionForMetadata property.
Top
Properties
 | Name | Description
Public property | Authenticated | Gets flag that determines if this DataSubscriber has successfully authenticated with the DataPublisher.
Public property | AutoConnect | Gets or sets flag that determines if DataSubscriber should attempt to auto-connection to DataPublisher using defined connection settings.
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | AutoSynchronizeMetadata | Gets or sets flag that determines if DataSubscriber should automatically request meta-data synchronization and synchronize publisher meta-data with its own database configuration.
Public property | AverageMeasurementsPerSecond | Gets the average value of the measurements per second calculation.
Protected property | CommandChannel | Gets or sets reference to TcpClient command channel, attaching and/or detaching to events as needed.
Public property | CompressMetadata | Gets or sets the operational mode flag to compress meta-data.
Public property | CompressPayload | Gets or sets the operational mode flag to compress data payloads.
Public property | CompressSignalIndexCache | Gets or sets the operational mode flag to compress the signal index cache.
Protected property | ConnectionAttemptInterval | Gets or sets the connection attempt interval, in milliseconds, for the data input source. (Inherited from InputAdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Protected property | DataChannel | Gets or sets reference to UdpClient data channel, attaching and/or detaching to events as needed.
Public property | DataLossInterval | Gets or sets data loss monitoring interval, in seconds. Set to zero to disable monitoring.
Public property | DataSource | Gets or sets DataSet based data source available to this DataSubscriber. (Overrides AdapterBaseDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | GatewayCompressionMode | Gets or sets the GatewayCompressionMode used by the subscriber and publisher.
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any. (Inherited from InputAdapterBase.)
Public property | IsConnected | Gets flag that determines if InputAdapterBase is connected. (Inherited from InputAdapterBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LifetimeAverageLatency | Gets the average latency calculated over the full lifetime of the subscriber.
Public property | LifetimeMaximumLatency | Gets the maximum latency calculated over the full lifetime of the subscriber.
Public property | LifetimeMeasurements | Gets the total number of measurements processed through this data publisher over the lifetime of the subscriber.
Public property | LifetimeMinimumLatency | Gets the minimum latency calculated over the full lifetime of the subscriber.
Public property | LoggingPath | Gets or sets logging path to be used to be runtime and outage logs of the subscriber which are required for automated data recovery.
Public property | MaximumMeasurementsPerSecond | Gets the maximum value of the measurements per second calculation.
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
 | MetadataFilters | Gets or sets requested meta-data filter expressions to be applied by DataPublisher before meta-data is sent.
Public property | MetadataSynchronizationTimeout | Gets or sets the timeout used when executing database queries during meta-data synchronization.
Public property | MinimumMeasurementsPerSecond | Gets the minimum value of the measurements per second calculation.
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OperationalEncoding | Gets or sets the OperationalEncoding used by the subscriber and publisher.
Public property | OperationalModes | Gets or sets a set of flags that define ways in which the subscriber and publisher communicate.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from InputAdapterBase.)
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Overrides AdapterBaseProcessingInterval.)
Protected property | RealTime | Gets real-time as determined by either the local clock or the latest measurement received.
Public property | ReceiveExternalMetadata | Gets or sets the operational mode flag to receive external meta-data.
Public property | ReceiveInternalMetadata | Gets or sets the operational mode flag to receive internal meta-data.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from InputAdapterBase.)
Public property | RequireAuthentication | Gets or sets flag that determines if DataPublisher requires subscribers to authenticate before making data requests.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | SecurityMode | Gets or sets the security mode used for communications over the command channel.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Gets the status of this DataSubscriber. (Overrides InputAdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Public property | TotalBytesReceived | Gets total data packet bytes received during this session.
Protected property | UseAsyncConnect | Gets a flag that determines if this DataSubscriber uses an asynchronous connection. (Overrides InputAdapterBaseUseAsyncConnect.)
Public property | UseCommonSerializationFormat | Gets or sets the operational mode flag to use the common serialization format.
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether to use the local clock when calculating statistics.
Public property | UseMillisecondResolution | Obsolete. Gets or sets flag that informs publisher if base time-offsets can use millisecond resolution to conserve bandwidth.
Public property | UseTransactionForMetadata | Gets or sets flag that determines if meta-data synchronization should be performed within a transaction.
Public property | UseZeroMQChannel | Gets or sets flag that determines if ZeroMQ should be used for command channel communications.
Public property | Version | Gets the version number of the protocol in use by this subscriber.
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | ConnectionAuthenticated | Occurs when client connection to the data publication server has successfully authenticated.
Public event | ConnectionEstablished | Occurs when client connection to the data publication server is established.
Public event | ConnectionTerminated | Occurs when client connection to the data publication server is terminated.
Public event | DataStartTime | Occurs when first measurement is transmitted by data publication server.
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | MetaDataReceived | Occurs when client receives requested meta-data transmitted by data publication server.
Public event | NewMeasurements | Provides new measurements from input adapter. (Inherited from InputAdapterBase.)
Public event | NotificationReceived | Occurs when a notification has been received from the DataPublisher.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | ProcessingComplete | Indicates that processing for an input adapter (via temporal session) has completed.
Public event | ReceivedServerResponse | Occurs when client receives response from the server.
Public event | ServerConfigurationChanged | Occurs when the server has sent a notification that its configuration has changed, this can allow subscriber to request updated meta-data if desired.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


DataSubscriber Constructor

Grid Solutions Framework DataSubscriber Constructor
Creates a new DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DataSubscriber()
Public Sub New
new : unit -> DataSubscriber
GSF.TimeSeries.Transport.DataSubscriber = function();
public:
DataSubscriber()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber Fields

Grid Solutions Framework DataSubscriber Fields

The DataSubscriber type exposes the following members.

Fields
Name | Description
DefaultLoggingPath | Default value for LoggingPath.
DefaultMetadataSynchronizationTimeout | Defines the default value for the MetadataSynchronizationTimeout property.
DefaultOperationalModes | Defines default value for OperationalModes.
DefaultUseTransactionForMetadata | Defines the default value for the UseTransactionForMetadata property.
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DefaultLoggingPath Field

Grid Solutions Framework DataSubscriberDefaultLoggingPath Field
Default value for LoggingPath.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string DefaultLoggingPath
Public Const DefaultLoggingPath As String
static val mutable DefaultLoggingPath: string
var GSF.TimeSeries.Transport.DataSubscriber.DefaultLoggingPath
public:
literal String^ DefaultLoggingPath

Field Value

Type: String
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DefaultMetadataSynchronizationTimeout Field

Grid Solutions Framework DataSubscriberDefaultMetadataSynchronizationTimeout Field
Defines the default value for the MetadataSynchronizationTimeout property.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int DefaultMetadataSynchronizationTimeout
Public Const DefaultMetadataSynchronizationTimeout As Integer
static val mutable DefaultMetadataSynchronizationTimeout: int
var GSF.TimeSeries.Transport.DataSubscriber.DefaultMetadataSynchronizationTimeout
public:
literal int DefaultMetadataSynchronizationTimeout

Field Value

Type: Int32
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DefaultOperationalModes Field

Grid Solutions Framework DataSubscriberDefaultOperationalModes Field
Defines default value for OperationalModes.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const OperationalModes DefaultOperationalModes
Public Const DefaultOperationalModes As OperationalModes
static val mutable DefaultOperationalModes: OperationalModes
var GSF.TimeSeries.Transport.DataSubscriber.DefaultOperationalModes
public:
literal OperationalModes DefaultOperationalModes

Field Value

Type: OperationalModes
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DefaultUseTransactionForMetadata Field

Grid Solutions Framework DataSubscriberDefaultUseTransactionForMetadata Field
Defines the default value for the UseTransactionForMetadata property.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultUseTransactionForMetadata
Public Const DefaultUseTransactionForMetadata As Boolean
static val mutable DefaultUseTransactionForMetadata: bool
var GSF.TimeSeries.Transport.DataSubscriber.DefaultUseTransactionForMetadata
public:
literal bool DefaultUseTransactionForMetadata

Field Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber Methods

Grid Solutions Framework DataSubscriber Methods

The DataSubscriber type exposes the following members.

Methods
 | Name | Description
Protected method | AttemptConnection | Attempts to connect to this DataSubscriber. (Overrides InputAdapterBaseAttemptConnection.)
Protected method | AttemptDisconnection | Attempts to disconnect from this DataSubscriber. (Overrides InputAdapterBaseAttemptDisconnection.)
Public method | Authenticate | Authenticates subscriber to a data publisher.
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataSubscriber object and optionally releases the managed resources. (Overrides InputAdapterBaseDispose(Boolean).)
Protected method | DisposeLocalConcentrator | Disposes of any previously defined local concentrator.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetAuthorizedSignalIDs | Returns the measurements signal IDs that were authorized after the last successful subscription request.
Public method | GetDataGapRecoverySubscriptionStatus | Gets the status of the temporal DataSubscriber used by the data gap recovery module.
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Protected method | GetLoggingPath | Gets file path for any defined logging path.
Public method | GetShortStatus | Gets a short one-line status of this DataSubscriber. (Overrides AdapterBaseGetShortStatus(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetUnauthorizedSignalIDs | Returns the measurements signal IDs that were unauthorized after the last successful subscription request.
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes DataSubscriber. (Overrides InputAdapterBaseInitialize.)
Protected method | InterpretResponseMessage | Get message from string based response.
Public method | LocallySynchronizedSubscribe | Obsolete. Subscribes (or re-subscribes) to a data publisher for a locally synchronized set of data points.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnConnected | Called when data input source connection is established. (Inherited from InputAdapterBase.)
Protected method | OnConnectionAuthenticated | Raises the ConnectionAuthenticated event.
Protected method | OnConnectionEstablished | Raises the ConnectionEstablished event.
Protected method | OnConnectionTerminated | Raises the ConnectionTerminated event.
Protected method | OnDataStartTime | Raises the DataStartTime event.
Protected method | OnDisconnected | Called when data input source is disconnected. (Inherited from InputAdapterBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnMetaDataReceived | Raises the MetaDataReceived event.
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from InputAdapterBase.)
Protected method | OnNotificationReceived | Raises the NotificationReceived event.
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnProcessingComplete | Raises the ProcessingComplete event. (Inherited from InputAdapterBase.)
Protected method | OnProcessingComplete(String) | Raises the ProcessingComplete event.
Protected method | OnReceivedServerResponse | Raises the ReceivedServerResponse event.
Protected method | OnServerConfigurationChanged | Raises the ServerConfigurationChanged event.
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Public method | RefreshMetadata | Initiate a meta-data refresh.
Public method | RemotelySynchronizedSubscribe | Obsolete. Subscribes (or re-subscribes) to a data publisher for a remotely synchronized set of data points.
Public method | ResetLifetimeCounters | Resets the counters for the lifetime statistics without interrupting the adapter's operations.
Public method | SendServerCommand(ServerCommand, Byte) | Sends a server command to the publisher connection.
Public method | SendServerCommand(ServerCommand, String) | Sends a server command to the publisher connection with associated message data.
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts this InputAdapterBase and initiates connection cycle to data input source. (Inherited from InputAdapterBase.)
Public method | Stop | Stops this InputAdapterBase and disconnects from data input source. (Inherited from InputAdapterBase.)
Public method | Subscribe(SubscriptionInfo) | Subscribes (or re-subscribes) to a data publisher for a set of data points.
Public method | Subscribe(Boolean, Boolean, String) | Subscribes (or re-subscribes) to a data publisher for a set of data points.
Public method | SynchronizedSubscribe | Subscribes (or re-subscribes) to a data publisher for a synchronized set of data points.
Protected method | SynchronizeMetadata | Handles meta-data synchronization to local system.
Public method | SynchronizeMetadata(DataSet) | Spawn meta-data synchronization.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Unsubscribe | Unsubscribes from a data publisher.
Public method | UnsynchronizedSubscribe(UnsynchronizedSubscriptionInfo) | Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.
Public method | UnsynchronizedSubscribe(Boolean, Boolean, String, String, Boolean, Double, Double, Boolean, String, String, String, Int32, String, Int32) | Obsolete. Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.AttemptConnection Method

Grid Solutions Framework DataSubscriberAttemptConnection Method
Attempts to connect to this DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void AttemptConnection()
Protected Overrides Sub AttemptConnection
abstract AttemptConnection : unit -> unit
override AttemptConnection : unit -> unit
function AttemptConnection();
protected:
virtual void AttemptConnection() override
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.AttemptDisconnection Method

Grid Solutions Framework DataSubscriberAttemptDisconnection Method
Attempts to disconnect from this DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void AttemptDisconnection()
Protected Overrides Sub AttemptDisconnection
abstract AttemptDisconnection : unit -> unit
override AttemptDisconnection : unit -> unit
function AttemptDisconnection();
protected:
virtual void AttemptDisconnection() override
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Authenticate Method

Grid Solutions Framework DataSubscriberAuthenticate Method
Authenticates subscriber to a data publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Authenticate(
    string sharedSecret,
    string authenticationID
)
Public Overridable Function Authenticate (
    sharedSecret As String,
    authenticationID As String
) As Boolean
abstract Authenticate :
        sharedSecret : string *
        authenticationID : string -> bool
override Authenticate :
        sharedSecret : string *
        authenticationID : string -> bool
function Authenticate(sharedSecret, authenticationID);
public:
virtual bool Authenticate(
    String^ sharedSecret,
    String^ authenticationID
)

Parameters

sharedSecret
Type: SystemString
Shared secret used to look up private crypto key and initialization vector.
authenticationID
Type: SystemString
Authentication ID that publisher will use to validate subscriber identity.

Return Value

Type: Boolean
true if authentication transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Dispose Method

Grid Solutions Framework DataSubscriberDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the DataSubscriber object and optionally releases the managed resources. (Overrides InputAdapterBaseDispose(Boolean).)
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Dispose Method (Boolean)

Grid Solutions Framework DataSubscriberDispose Method (Boolean)
Releases the unmanaged resources used by the DataSubscriber object and optionally releases the managed resources.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true to release both managed and unmanaged resources; false to release only unmanaged resources.
See Also

Reference

DataSubscriber Class
Dispose Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.DisposeLocalConcentrator Method

Grid Solutions Framework DataSubscriberDisposeLocalConcentrator Method
Disposes of any previously defined local concentrator.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void DisposeLocalConcentrator()
Protected Sub DisposeLocalConcentrator
member DisposeLocalConcentrator : unit -> unit

function DisposeLocalConcentrator();
protected:
void DisposeLocalConcentrator()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.GetAuthorizedSignalIDs Method

Grid Solutions Framework DataSubscriberGetAuthorizedSignalIDs Method
Returns the measurements signal IDs that were authorized after the last successful subscription request.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Gets authorized signal IDs from last subscription request.",
    new string[] { ... })]
public virtual Guid[] GetAuthorizedSignalIDs()
<AdapterCommandAttribute("Gets authorized signal IDs from last subscription request.",
    New String() { ... })>
Public Overridable Function GetAuthorizedSignalIDs As Guid()
[<AdapterCommandAttribute("Gets authorized signal IDs from last subscription request.",
    new string[] { ... })>]
abstract GetAuthorizedSignalIDs : unit -> Guid[]
[<AdapterCommandAttribute("Gets authorized signal IDs from last subscription request.",
    new string[] { ... })>]
override GetAuthorizedSignalIDs : unit -> Guid[]
function GetAuthorizedSignalIDs();
public:
[AdapterCommandAttribute(L"Gets authorized signal IDs from last subscription request.",
    __gc new array<String^>^ { ... })]
virtual array<Guid>^ GetAuthorizedSignalIDs()

Return Value

Type: Guid

[Missing <returns> documentation for "M:GSF.TimeSeries.Transport.DataSubscriber.GetAuthorizedSignalIDs"]

See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.GetDataGapRecoverySubscriptionStatus Method

Grid Solutions Framework DataSubscriberGetDataGapRecoverySubscriptionStatus Method
Gets the status of the temporal DataSubscriber used by the data gap recovery module.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Gets the status of the temporal subscription used by the data gap recovery module.",
    new string[] { ... })]
public virtual string GetDataGapRecoverySubscriptionStatus()
<AdapterCommandAttribute("Gets the status of the temporal subscription used by the data gap recovery module.",
    New String() { ... })>
Public Overridable Function GetDataGapRecoverySubscriptionStatus As String
[<AdapterCommandAttribute("Gets the status of the temporal subscription used by the data gap recovery module.",
    new string[] { ... })>]
abstract GetDataGapRecoverySubscriptionStatus : unit -> string
[<AdapterCommandAttribute("Gets the status of the temporal subscription used by the data gap recovery module.",
    new string[] { ... })>]
override GetDataGapRecoverySubscriptionStatus : unit -> string
function GetDataGapRecoverySubscriptionStatus();
public:
[AdapterCommandAttribute(L"Gets the status of the temporal subscription used by the data gap recovery module.",
    __gc new array<String^>^ { ... })]
virtual String^ GetDataGapRecoverySubscriptionStatus()

Return Value

Type: String
Status of the temporal DataSubscriber used by the data gap recovery module.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.GetLoggingPath Method

Grid Solutions Framework DataSubscriberGetLoggingPath Method
Gets file path for any defined logging path.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected string GetLoggingPath(
    string filePath
)
Protected Function GetLoggingPath (
    filePath As String
) As String
member GetLoggingPath :
        filePath : string -> string

function GetLoggingPath(filePath);
protected:
String^ GetLoggingPath(
    String^ filePath
)

Parameters

filePath
Type: SystemString
Path to acquire within logging path.

Return Value

Type: String
File path within any defined logging path.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.GetShortStatus Method

Grid Solutions Framework DataSubscriberGetShortStatus Method
Gets a short one-line status of this DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string
override GetShortStatus :
        maxLength : int -> string
function GetShortStatus(maxLength);
public:
virtual String^ GetShortStatus(
    int maxLength
) override

Parameters

maxLength
Type: SystemInt32
Maximum length of the status message.

Return Value

Type: String
Text of the status message.

Implements

IAdapterGetShortStatus(Int32)
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.GetUnauthorizedSignalIDs Method

Grid Solutions Framework DataSubscriberGetUnauthorizedSignalIDs Method
Returns the measurements signal IDs that were unauthorized after the last successful subscription request.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Gets unauthorized signal IDs from last subscription request.",
    new string[] { ... })]
public virtual Guid[] GetUnauthorizedSignalIDs()
<AdapterCommandAttribute("Gets unauthorized signal IDs from last subscription request.",
    New String() { ... })>
Public Overridable Function GetUnauthorizedSignalIDs As Guid()
[<AdapterCommandAttribute("Gets unauthorized signal IDs from last subscription request.",
    new string[] { ... })>]
abstract GetUnauthorizedSignalIDs : unit -> Guid[]
[<AdapterCommandAttribute("Gets unauthorized signal IDs from last subscription request.",
    new string[] { ... })>]
override GetUnauthorizedSignalIDs : unit -> Guid[]
function GetUnauthorizedSignalIDs();
public:
[AdapterCommandAttribute(L"Gets unauthorized signal IDs from last subscription request.",
    __gc new array<String^>^ { ... })]
virtual array<Guid>^ GetUnauthorizedSignalIDs()

Return Value

Type: Guid

[Missing <returns> documentation for "M:GSF.TimeSeries.Transport.DataSubscriber.GetUnauthorizedSignalIDs"]

See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Initialize Method

Grid Solutions Framework DataSubscriberInitialize Method
Initializes DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void Initialize()
Public Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
public:
virtual void Initialize() override

Implements

ISupportLifecycleInitialize
ISupportLifecycleInitialize
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.InterpretResponseMessage Method

Grid Solutions Framework DataSubscriberInterpretResponseMessage Method
Get message from string based response.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected string InterpretResponseMessage(
    byte[] buffer,
    int startIndex,
    int length
)
Protected Function InterpretResponseMessage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As String
member InterpretResponseMessage :
        buffer : byte[] *
        startIndex : int *
        length : int -> string

function InterpretResponseMessage(buffer, startIndex, length);
protected:
String^ InterpretResponseMessage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
)

Parameters

buffer
Type: SystemByte
Response buffer.
startIndex
Type: SystemInt32
Start index of response message.
length
Type: SystemInt32
Length of response message.

Return Value

Type: String
Decoded response string.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.LocallySynchronizedSubscribe Method

Grid Solutions Framework DataSubscriberLocallySynchronizedSubscribe Method

Note: This API is now obsolete.

Subscribes (or re-subscribes) to a data publisher for a locally synchronized set of data points.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)]
public virtual bool LocallySynchronizedSubscribe(
    bool compactFormat,
    int framesPerSecond,
    double lagTime,
    double leadTime,
    string filterExpression,
    string dataChannel = null,
    bool useLocalClockAsRealTime = false,
    bool ignoreBadTimestamps = false,
    bool allowSortsByArrival = true,
    long timeResolution = 10000,
    bool allowPreemptivePublishing = true,
    DownsamplingMethod downsamplingMethod = DownsamplingMethod.LastReceived,
    string startTime = null,
    string stopTime = null,
    string constraintParameters = null,
    int processingInterval = -1,
    string waitHandleNames = null,
    int waitHandleTimeout = 0
)
<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>
Public Overridable Function LocallySynchronizedSubscribe (
    compactFormat As Boolean,
    framesPerSecond As Integer,
    lagTime As Double,
    leadTime As Double,
    filterExpression As String,
    Optional dataChannel As String = Nothing,
    Optional useLocalClockAsRealTime As Boolean = false,
    Optional ignoreBadTimestamps As Boolean = false,
    Optional allowSortsByArrival As Boolean = true,
    Optional timeResolution As Long = 10000,
    Optional allowPreemptivePublishing As Boolean = true,
    Optional downsamplingMethod As DownsamplingMethod = DownsamplingMethod.LastReceived,
    Optional startTime As String = Nothing,
    Optional stopTime As String = Nothing,
    Optional constraintParameters As String = Nothing,
    Optional processingInterval As Integer = -1,
    Optional waitHandleNames As String = Nothing,
    Optional waitHandleTimeout As Integer = 0
) As Boolean
[<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>]
abstract LocallySynchronizedSubscribe :
        compactFormat : bool *
        framesPerSecond : int *
        lagTime : float *
        leadTime : float *
        filterExpression : string *
        ?dataChannel : string *
        ?useLocalClockAsRealTime : bool *
        ?ignoreBadTimestamps : bool *
        ?allowSortsByArrival : bool *
        ?timeResolution : int64 *
        ?allowPreemptivePublishing : bool *
        ?downsamplingMethod : DownsamplingMethod *
        ?startTime : string *
        ?stopTime : string *
        ?constraintParameters : string *
        ?processingInterval : int *
        ?waitHandleNames : string *
        ?waitHandleTimeout : int
(* Defaults:
        let _dataChannel = defaultArg dataChannel null
        let _useLocalClockAsRealTime = defaultArg useLocalClockAsRealTime false
        let _ignoreBadTimestamps = defaultArg ignoreBadTimestamps false
        let _allowSortsByArrival = defaultArg allowSortsByArrival true
        let _timeResolution = defaultArg timeResolution 10000
        let _allowPreemptivePublishing = defaultArg allowPreemptivePublishing true
        let _downsamplingMethod = defaultArg downsamplingMethod DownsamplingMethod.LastReceived
        let _startTime = defaultArg startTime null
        let _stopTime = defaultArg stopTime null
        let _constraintParameters = defaultArg constraintParameters null
        let _processingInterval = defaultArg processingInterval -1
        let _waitHandleNames = defaultArg waitHandleNames null
        let _waitHandleTimeout = defaultArg waitHandleTimeout 0
*)
-> bool
[<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>]
override LocallySynchronizedSubscribe :
        compactFormat : bool *
        framesPerSecond : int *
        lagTime : float *
        leadTime : float *
        filterExpression : string *
        ?dataChannel : string *
        ?useLocalClockAsRealTime : bool *
        ?ignoreBadTimestamps : bool *
        ?allowSortsByArrival : bool *
        ?timeResolution : int64 *
        ?allowPreemptivePublishing : bool *
        ?downsamplingMethod : DownsamplingMethod *
        ?startTime : string *
        ?stopTime : string *
        ?constraintParameters : string *
        ?processingInterval : int *
        ?waitHandleNames : string *
        ?waitHandleTimeout : int
(* Defaults:
        let _dataChannel = defaultArg dataChannel null
        let _useLocalClockAsRealTime = defaultArg useLocalClockAsRealTime false
        let _ignoreBadTimestamps = defaultArg ignoreBadTimestamps false
        let _allowSortsByArrival = defaultArg allowSortsByArrival true
        let _timeResolution = defaultArg timeResolution 10000
        let _allowPreemptivePublishing = defaultArg allowPreemptivePublishing true
        let _downsamplingMethod = defaultArg downsamplingMethod DownsamplingMethod.LastReceived
        let _startTime = defaultArg startTime null
        let _stopTime = defaultArg stopTime null
        let _constraintParameters = defaultArg constraintParameters null
        let _processingInterval = defaultArg processingInterval -1
        let _waitHandleNames = defaultArg waitHandleNames null
        let _waitHandleTimeout = defaultArg waitHandleTimeout 0
*)
-> bool
function LocallySynchronizedSubscribe(compactFormat, framesPerSecond, lagTime, leadTime, filterExpression, dataChannel, useLocalClockAsRealTime, ignoreBadTimestamps, allowSortsByArrival, timeResolution, allowPreemptivePublishing, downsamplingMethod, startTime, stopTime, constraintParameters, processingInterval, waitHandleNames, waitHandleTimeout);
public:
[ObsoleteAttribute(L"Preferred method uses SubscriptionInfo object to subscribe.",
    false)]
virtual bool LocallySynchronizedSubscribe(
    bool compactFormat,
    int framesPerSecond,
    double lagTime,
    double leadTime,
    String^ filterExpression,
    String^ dataChannel = nullptr,
    bool useLocalClockAsRealTime = false,
    bool ignoreBadTimestamps = false,
    bool allowSortsByArrival = true,
    long long timeResolution = 10000,
    bool allowPreemptivePublishing = true,
    DownsamplingMethod downsamplingMethod = DownsamplingMethod::LastReceived,
    String^ startTime = nullptr,
    String^ stopTime = nullptr,
    String^ constraintParameters = nullptr,
    int processingInterval = -1,
    String^ waitHandleNames = nullptr,
    int waitHandleTimeout = 0
)

Parameters

compactFormat
Type: SystemBoolean
Boolean value that determines if the compact measurement format should be used. Set to false for full fidelity measurement serialization; otherwise set to true for bandwidth conservation.
framesPerSecond
Type: SystemInt32
The desired number of data frames per second.
lagTime
Type: SystemDouble
Allowed past time deviation tolerance, in seconds (can be sub-second).
leadTime
Type: SystemDouble
Allowed future time deviation tolerance, in seconds (can be sub-second).
filterExpression
Type: SystemString
Filtering expression that defines the measurements that are being subscribed.
dataChannel (Optional)
Type: SystemString
Desired UDP return data channel connection string to use for data packet transmission. Set to null to use TCP channel for data transmission.
useLocalClockAsRealTime (Optional)
Type: SystemBoolean
Boolean value that determines whether or not to use the local clock time as real-time.
ignoreBadTimestamps (Optional)
Type: SystemBoolean
Boolean value that determines if bad timestamps (as determined by measurement's timestamp quality) should be ignored when sorting measurements.
allowSortsByArrival (Optional)
Type: SystemBoolean
Gets or sets flag that determines whether or not to allow incoming measurements with bad timestamps to be sorted by arrival time.
timeResolution (Optional)
Type: SystemInt64
Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.
allowPreemptivePublishing (Optional)
Type: SystemBoolean
Gets or sets flag that allows system to preemptively publish frames assuming all expected measurements have arrived.
downsamplingMethod (Optional)
Type: GSF.TimeSeriesDownsamplingMethod
Gets the total number of down-sampled measurements processed by the concentrator.
startTime (Optional)
Type: SystemString
Defines a relative or exact start time for the temporal constraint to use for historical playback.
stopTime (Optional)
Type: SystemString
Defines a relative or exact stop time for the temporal constraint to use for historical playback.
constraintParameters (Optional)
Type: SystemString
Defines any temporal parameters related to the constraint to use for historical playback.
processingInterval (Optional)
Type: SystemInt32
Defines the desired processing interval milliseconds, i.e., historical play back speed, to use when temporal constraints are defined.
waitHandleNames (Optional)
Type: SystemString
Comma separated list of wait handle names used to establish external event wait handles needed for inter-adapter synchronization.
waitHandleTimeout (Optional)
Type: SystemInt32
Maximum wait time for external events, in milliseconds, before proceeding.

Return Value

Type: Boolean
true if subscribe transmission was successful; otherwise false.
Remarks

When the startTime or stopTime temporal processing constraints are defined (i.e., not null), this specifies the start and stop time over which the subscriber session will process data. Passing in null for the startTime and stopTime specifies the subscriber session will process data in standard, i.e., real-time, operation.

With the exception of the values of -1 and 0, the processingInterval value specifies the desired historical playback data processing interval in milliseconds. This is basically a delay, or timer interval, over which to process data. Setting this value to -1 means to use the default processing interval while setting the value to 0 means to process data as fast as possible.

The startTime and stopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnConnectionAuthenticated Method

Grid Solutions Framework DataSubscriberOnConnectionAuthenticated Method
Raises the ConnectionAuthenticated event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnConnectionAuthenticated()
Protected Sub OnConnectionAuthenticated
member OnConnectionAuthenticated : unit -> unit

function OnConnectionAuthenticated();
protected:
void OnConnectionAuthenticated()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnConnectionEstablished Method

Grid Solutions Framework DataSubscriberOnConnectionEstablished Method
Raises the ConnectionEstablished event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnConnectionEstablished()
Protected Sub OnConnectionEstablished
member OnConnectionEstablished : unit -> unit

function OnConnectionEstablished();
protected:
void OnConnectionEstablished()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnConnectionTerminated Method

Grid Solutions Framework DataSubscriberOnConnectionTerminated Method
Raises the ConnectionTerminated event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnConnectionTerminated()
Protected Sub OnConnectionTerminated
member OnConnectionTerminated : unit -> unit

function OnConnectionTerminated();
protected:
void OnConnectionTerminated()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnDataStartTime Method

Grid Solutions Framework DataSubscriberOnDataStartTime Method
Raises the DataStartTime event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnDataStartTime(
    Ticks startTime
)
Protected Sub OnDataStartTime (
    startTime As Ticks
)
member OnDataStartTime :
        startTime : Ticks -> unit

function OnDataStartTime(startTime);
protected:
void OnDataStartTime(
    Ticks startTime
)

Parameters

startTime
Type: GSFTicks
Start time, in Ticks, of first measurement transmitted.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnMetaDataReceived Method

Grid Solutions Framework DataSubscriberOnMetaDataReceived Method
Raises the MetaDataReceived event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnMetaDataReceived(
    DataSet metadata
)
Protected Sub OnMetaDataReceived (
    metadata As DataSet
)
member OnMetaDataReceived :
        metadata : DataSet -> unit

function OnMetaDataReceived(metadata);
protected:
void OnMetaDataReceived(
    DataSet^ metadata
)

Parameters

metadata
Type: System.DataDataSet
Meta-data DataSet instance to send to client subscription.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnNotificationReceived Method

Grid Solutions Framework DataSubscriberOnNotificationReceived Method
Raises the NotificationReceived event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnNotificationReceived(
    string message
)
Protected Sub OnNotificationReceived (
    message As String
)
member OnNotificationReceived :
        message : string -> unit

function OnNotificationReceived(message);
protected:
void OnNotificationReceived(
    String^ message
)

Parameters

message
Type: SystemString
Message for the notification.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnProcessingComplete Method

Grid Solutions Framework DataSubscriberOnProcessingComplete Method
Overload List
 | Name | Description
Protected method | OnProcessingComplete | Raises the ProcessingComplete event. (Inherited from InputAdapterBase.)
Protected method | OnProcessingComplete(String) | Raises the ProcessingComplete event.
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnProcessingComplete Method (String)

Grid Solutions Framework DataSubscriberOnProcessingComplete Method (String)
Raises the ProcessingComplete event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnProcessingComplete(
    string source
)
Protected Sub OnProcessingComplete (
    source As String
)
member OnProcessingComplete :
        source : string -> unit

function OnProcessingComplete(source);
protected:
void OnProcessingComplete(
    String^ source
)

Parameters

source
Type: SystemString
Type name of adapter that sent the processing completed notification.
See Also

Reference

DataSubscriber Class
OnProcessingComplete Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnReceivedServerResponse Method

Grid Solutions Framework DataSubscriberOnReceivedServerResponse Method
Raises the ReceivedServerResponse event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnReceivedServerResponse(
    ServerResponse responseCode,
    ServerCommand commandCode
)
Protected Sub OnReceivedServerResponse (
    responseCode As ServerResponse,
    commandCode As ServerCommand
)
member OnReceivedServerResponse :
        responseCode : ServerResponse *
        commandCode : ServerCommand -> unit

function OnReceivedServerResponse(responseCode, commandCode);
protected:
void OnReceivedServerResponse(
    ServerResponse responseCode,
    ServerCommand commandCode
)

Parameters

responseCode
Type: GSF.TimeSeries.TransportServerResponse
Response received from the server.
commandCode
Type: GSF.TimeSeries.TransportServerCommand
Command that the server responded to.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OnServerConfigurationChanged Method

Grid Solutions Framework DataSubscriberOnServerConfigurationChanged Method
Raises the ServerConfigurationChanged event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void OnServerConfigurationChanged()
Protected Sub OnServerConfigurationChanged
member OnServerConfigurationChanged : unit -> unit

function OnServerConfigurationChanged();
protected:
void OnServerConfigurationChanged()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.RefreshMetadata Method

Grid Solutions Framework DataSubscriberRefreshMetadata Method
Initiate a meta-data refresh.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Initiates a meta-data refresh.", new string[] { ... })]
public virtual void RefreshMetadata()
<AdapterCommandAttribute("Initiates a meta-data refresh.", New String() { ... })>
Public Overridable Sub RefreshMetadata
[<AdapterCommandAttribute("Initiates a meta-data refresh.", new string[] { ... })>]
abstract RefreshMetadata : unit -> unit
[<AdapterCommandAttribute("Initiates a meta-data refresh.", new string[] { ... })>]
override RefreshMetadata : unit -> unit
function RefreshMetadata();
public:
[AdapterCommandAttribute(L"Initiates a meta-data refresh.", __gc new array<String^>^ { ... })]
virtual void RefreshMetadata()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.RemotelySynchronizedSubscribe Method

Grid Solutions Framework DataSubscriberRemotelySynchronizedSubscribe Method

Note: This API is now obsolete.

Subscribes (or re-subscribes) to a data publisher for a remotely synchronized set of data points.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)]
public virtual bool RemotelySynchronizedSubscribe(
    bool compactFormat,
    int framesPerSecond,
    double lagTime,
    double leadTime,
    string filterExpression,
    string dataChannel = null,
    bool useLocalClockAsRealTime = false,
    bool ignoreBadTimestamps = false,
    bool allowSortsByArrival = true,
    long timeResolution = 10000,
    bool allowPreemptivePublishing = true,
    DownsamplingMethod downsamplingMethod = DownsamplingMethod.LastReceived,
    string startTime = null,
    string stopTime = null,
    string constraintParameters = null,
    int processingInterval = -1,
    string waitHandleNames = null,
    int waitHandleTimeout = 0
)
<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>
Public Overridable Function RemotelySynchronizedSubscribe (
    compactFormat As Boolean,
    framesPerSecond As Integer,
    lagTime As Double,
    leadTime As Double,
    filterExpression As String,
    Optional dataChannel As String = Nothing,
    Optional useLocalClockAsRealTime As Boolean = false,
    Optional ignoreBadTimestamps As Boolean = false,
    Optional allowSortsByArrival As Boolean = true,
    Optional timeResolution As Long = 10000,
    Optional allowPreemptivePublishing As Boolean = true,
    Optional downsamplingMethod As DownsamplingMethod = DownsamplingMethod.LastReceived,
    Optional startTime As String = Nothing,
    Optional stopTime As String = Nothing,
    Optional constraintParameters As String = Nothing,
    Optional processingInterval As Integer = -1,
    Optional waitHandleNames As String = Nothing,
    Optional waitHandleTimeout As Integer = 0
) As Boolean
[<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>]
abstract RemotelySynchronizedSubscribe :
        compactFormat : bool *
        framesPerSecond : int *
        lagTime : float *
        leadTime : float *
        filterExpression : string *
        ?dataChannel : string *
        ?useLocalClockAsRealTime : bool *
        ?ignoreBadTimestamps : bool *
        ?allowSortsByArrival : bool *
        ?timeResolution : int64 *
        ?allowPreemptivePublishing : bool *
        ?downsamplingMethod : DownsamplingMethod *
        ?startTime : string *
        ?stopTime : string *
        ?constraintParameters : string *
        ?processingInterval : int *
        ?waitHandleNames : string *
        ?waitHandleTimeout : int
(* Defaults:
        let _dataChannel = defaultArg dataChannel null
        let _useLocalClockAsRealTime = defaultArg useLocalClockAsRealTime false
        let _ignoreBadTimestamps = defaultArg ignoreBadTimestamps false
        let _allowSortsByArrival = defaultArg allowSortsByArrival true
        let _timeResolution = defaultArg timeResolution 10000
        let _allowPreemptivePublishing = defaultArg allowPreemptivePublishing true
        let _downsamplingMethod = defaultArg downsamplingMethod DownsamplingMethod.LastReceived
        let _startTime = defaultArg startTime null
        let _stopTime = defaultArg stopTime null
        let _constraintParameters = defaultArg constraintParameters null
        let _processingInterval = defaultArg processingInterval -1
        let _waitHandleNames = defaultArg waitHandleNames null
        let _waitHandleTimeout = defaultArg waitHandleTimeout 0
*)
-> bool
[<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>]
override RemotelySynchronizedSubscribe :
        compactFormat : bool *
        framesPerSecond : int *
        lagTime : float *
        leadTime : float *
        filterExpression : string *
        ?dataChannel : string *
        ?useLocalClockAsRealTime : bool *
        ?ignoreBadTimestamps : bool *
        ?allowSortsByArrival : bool *
        ?timeResolution : int64 *
        ?allowPreemptivePublishing : bool *
        ?downsamplingMethod : DownsamplingMethod *
        ?startTime : string *
        ?stopTime : string *
        ?constraintParameters : string *
        ?processingInterval : int *
        ?waitHandleNames : string *
        ?waitHandleTimeout : int
(* Defaults:
        let _dataChannel = defaultArg dataChannel null
        let _useLocalClockAsRealTime = defaultArg useLocalClockAsRealTime false
        let _ignoreBadTimestamps = defaultArg ignoreBadTimestamps false
        let _allowSortsByArrival = defaultArg allowSortsByArrival true
        let _timeResolution = defaultArg timeResolution 10000
        let _allowPreemptivePublishing = defaultArg allowPreemptivePublishing true
        let _downsamplingMethod = defaultArg downsamplingMethod DownsamplingMethod.LastReceived
        let _startTime = defaultArg startTime null
        let _stopTime = defaultArg stopTime null
        let _constraintParameters = defaultArg constraintParameters null
        let _processingInterval = defaultArg processingInterval -1
        let _waitHandleNames = defaultArg waitHandleNames null
        let _waitHandleTimeout = defaultArg waitHandleTimeout 0
*)
-> bool
function RemotelySynchronizedSubscribe(compactFormat, framesPerSecond, lagTime, leadTime, filterExpression, dataChannel, useLocalClockAsRealTime, ignoreBadTimestamps, allowSortsByArrival, timeResolution, allowPreemptivePublishing, downsamplingMethod, startTime, stopTime, constraintParameters, processingInterval, waitHandleNames, waitHandleTimeout);
public:
[ObsoleteAttribute(L"Preferred method uses SubscriptionInfo object to subscribe.",
    false)]
virtual bool RemotelySynchronizedSubscribe(
    bool compactFormat,
    int framesPerSecond,
    double lagTime,
    double leadTime,
    String^ filterExpression,
    String^ dataChannel = nullptr,
    bool useLocalClockAsRealTime = false,
    bool ignoreBadTimestamps = false,
    bool allowSortsByArrival = true,
    long long timeResolution = 10000,
    bool allowPreemptivePublishing = true,
    DownsamplingMethod downsamplingMethod = DownsamplingMethod::LastReceived,
    String^ startTime = nullptr,
    String^ stopTime = nullptr,
    String^ constraintParameters = nullptr,
    int processingInterval = -1,
    String^ waitHandleNames = nullptr,
    int waitHandleTimeout = 0
)

Parameters

compactFormat
Type: SystemBoolean
Boolean value that determines if the compact measurement format should be used. Set to false for full fidelity measurement serialization; otherwise set to true for bandwidth conservation.
framesPerSecond
Type: SystemInt32
The desired number of data frames per second.
lagTime
Type: SystemDouble
Allowed past time deviation tolerance, in seconds (can be sub-second).
leadTime
Type: SystemDouble
Allowed future time deviation tolerance, in seconds (can be sub-second).
filterExpression
Type: SystemString
Filtering expression that defines the measurements that are being subscribed.
dataChannel (Optional)
Type: SystemString
Desired UDP return data channel connection string to use for data packet transmission. Set to null to use TCP channel for data transmission.
useLocalClockAsRealTime (Optional)
Type: SystemBoolean
Boolean value that determines whether or not to use the local clock time as real-time.
ignoreBadTimestamps (Optional)
Type: SystemBoolean
Boolean value that determines if bad timestamps (as determined by measurement's timestamp quality) should be ignored when sorting measurements.
allowSortsByArrival (Optional)
Type: SystemBoolean
Gets or sets flag that determines whether or not to allow incoming measurements with bad timestamps to be sorted by arrival time.
timeResolution (Optional)
Type: SystemInt64
Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.
allowPreemptivePublishing (Optional)
Type: SystemBoolean
Gets or sets flag that allows system to preemptively publish frames assuming all expected measurements have arrived.
downsamplingMethod (Optional)
Type: GSF.TimeSeriesDownsamplingMethod
Gets the total number of down-sampled measurements processed by the concentrator.
startTime (Optional)
Type: SystemString
Defines a relative or exact start time for the temporal constraint to use for historical playback.
stopTime (Optional)
Type: SystemString
Defines a relative or exact stop time for the temporal constraint to use for historical playback.
constraintParameters (Optional)
Type: SystemString
Defines any temporal parameters related to the constraint to use for historical playback.
processingInterval (Optional)
Type: SystemInt32
Defines the desired processing interval milliseconds, i.e., historical play back speed, to use when temporal constraints are defined.
waitHandleNames (Optional)
Type: SystemString
Comma separated list of wait handle names used to establish external event wait handles needed for inter-adapter synchronization.
waitHandleTimeout (Optional)
Type: SystemInt32
Maximum wait time for external events, in milliseconds, before proceeding.

Return Value

Type: Boolean
true if subscribe transmission was successful; otherwise false.
Remarks

When the startTime or stopTime temporal processing constraints are defined (i.e., not null), this specifies the start and stop time over which the subscriber session will process data. Passing in null for the startTime and stopTime specifies the subscriber session will process data in standard, i.e., real-time, operation.

With the exception of the values of -1 and 0, the processingInterval value specifies the desired historical playback data processing interval in milliseconds. This is basically a delay, or timer interval, over which to process data. Setting this value to -1 means to use the default processing interval while setting the value to 0 means to process data as fast as possible.

The startTime and stopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ResetLifetimeCounters Method

Grid Solutions Framework DataSubscriberResetLifetimeCounters Method
Resets the counters for the lifetime statistics without interrupting the adapter's operations.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    new string[] { ... })]
public virtual void ResetLifetimeCounters()
<AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    New String() { ... })>
Public Overridable Sub ResetLifetimeCounters
[<AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    new string[] { ... })>]
abstract ResetLifetimeCounters : unit -> unit
[<AdapterCommandAttribute("Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    new string[] { ... })>]
override ResetLifetimeCounters : unit -> unit
function ResetLifetimeCounters();
public:
[AdapterCommandAttribute(L"Resets the counters for the lifetime statistics without interrupting the adapter's operations.",
    __gc new array<String^>^ { ... })]
virtual void ResetLifetimeCounters()
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.SendServerCommand Method

Grid Solutions Framework DataSubscriberSendServerCommand Method
Overload List
 | Name | Description
Public method | SendServerCommand(ServerCommand, Byte) | Sends a server command to the publisher connection.
Public method | SendServerCommand(ServerCommand, String) | Sends a server command to the publisher connection with associated message data.
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.SendServerCommand Method (ServerCommand, Byte[])

Grid Solutions Framework DataSubscriberSendServerCommand Method (ServerCommand, Byte)
Sends a server command to the publisher connection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool SendServerCommand(
    ServerCommand commandCode,
    byte[] data = null
)
Public Overridable Function SendServerCommand (
    commandCode As ServerCommand,
    Optional data As Byte() = Nothing
) As Boolean
abstract SendServerCommand :
        commandCode : ServerCommand *
        ?data : byte[]
(* Defaults:
        let _data = defaultArg data null
*)
-> bool
override SendServerCommand :
        commandCode : ServerCommand *
        ?data : byte[]
(* Defaults:
        let _data = defaultArg data null
*)
-> bool
function SendServerCommand(commandCode, data);
public:
virtual bool SendServerCommand(
    ServerCommand commandCode,
    array<unsigned char>^ data = nullptr
)

Parameters

commandCode
Type: GSF.TimeSeries.TransportServerCommand
ServerCommand to send.
data (Optional)
Type: SystemByte
Optional command data to send.

Return Value

Type: Boolean
true if commandCode transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
SendServerCommand Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.SendServerCommand Method (ServerCommand, String)

Grid Solutions Framework DataSubscriberSendServerCommand Method (ServerCommand, String)
Sends a server command to the publisher connection with associated message data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool SendServerCommand(
    ServerCommand commandCode,
    string message
)
Public Overridable Function SendServerCommand (
    commandCode As ServerCommand,
    message As String
) As Boolean
abstract SendServerCommand :
        commandCode : ServerCommand *
        message : string -> bool
override SendServerCommand :
        commandCode : ServerCommand *
        message : string -> bool
function SendServerCommand(commandCode, message);
public:
virtual bool SendServerCommand(
    ServerCommand commandCode,
    String^ message
)

Parameters

commandCode
Type: GSF.TimeSeries.TransportServerCommand
ServerCommand to send.
message
Type: SystemString
String based command data to send to server.

Return Value

Type: Boolean
true if commandCode transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
SendServerCommand Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.Subscribe Method

Grid Solutions Framework DataSubscriberSubscribe Method
Overload List
 | Name | Description
Public method | Subscribe(SubscriptionInfo) | Subscribes (or re-subscribes) to a data publisher for a set of data points.
Public method | Subscribe(Boolean, Boolean, String) | Subscribes (or re-subscribes) to a data publisher for a set of data points.
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Subscribe Method (SubscriptionInfo)

Grid Solutions Framework DataSubscriberSubscribe Method (SubscriptionInfo)
Subscribes (or re-subscribes) to a data publisher for a set of data points.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Subscribe(
    SubscriptionInfo info
)
Public Function Subscribe (
    info As SubscriptionInfo
) As Boolean
member Subscribe :
        info : SubscriptionInfo -> bool

function Subscribe(info);
public:
bool Subscribe(
    SubscriptionInfo^ info
)

Parameters

info
Type: GSF.TimeSeries.TransportSubscriptionInfo
Configuration object that defines the subscription.

Return Value

Type: Boolean
true if subscribe transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
Subscribe Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.Subscribe Method (Boolean, Boolean, String)

Grid Solutions Framework DataSubscriberSubscribe Method (Boolean, Boolean, String)
Subscribes (or re-subscribes) to a data publisher for a set of data points.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Subscribe(
    bool remotelySynchronized,
    bool compactFormat,
    string connectionString
)
Public Overridable Function Subscribe (
    remotelySynchronized As Boolean,
    compactFormat As Boolean,
    connectionString As String
) As Boolean
abstract Subscribe :
        remotelySynchronized : bool *
        compactFormat : bool *
        connectionString : string -> bool
override Subscribe :
        remotelySynchronized : bool *
        compactFormat : bool *
        connectionString : string -> bool
function Subscribe(remotelySynchronized, compactFormat, connectionString);
public:
virtual bool Subscribe(
    bool remotelySynchronized,
    bool compactFormat,
    String^ connectionString
)

Parameters

remotelySynchronized
Type: SystemBoolean
Boolean value that determines if subscription should be remotely synchronized - note that data publisher may not allow remote synchronization.
compactFormat
Type: SystemBoolean
Boolean value that determines if the compact measurement format should be used. Set to false for full fidelity measurement serialization; otherwise set to true for bandwidth conservation.
connectionString
Type: SystemString
Connection string that defines required and optional parameters for the subscription.

Return Value

Type: Boolean
true if subscribe transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
Subscribe Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.SynchronizedSubscribe Method

Grid Solutions Framework DataSubscriberSynchronizedSubscribe Method
Subscribes (or re-subscribes) to a data publisher for a synchronized set of data points.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool SynchronizedSubscribe(
    SynchronizedSubscriptionInfo info
)
Public Function SynchronizedSubscribe (
    info As SynchronizedSubscriptionInfo
) As Boolean
member SynchronizedSubscribe :
        info : SynchronizedSubscriptionInfo -> bool

function SynchronizedSubscribe(info);
public:
bool SynchronizedSubscribe(
    SynchronizedSubscriptionInfo^ info
)

Parameters

info
Type: GSF.TimeSeries.TransportSynchronizedSubscriptionInfo
Configuration object that defines the subscription.

Return Value

Type: Boolean
true if subscribe transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.SynchronizeMetadata Method

Grid Solutions Framework DataSubscriberSynchronizeMetadata Method
Overload List
 | Name | Description
Protected method | SynchronizeMetadata | Handles meta-data synchronization to local system.
Public method | SynchronizeMetadata(DataSet) | Spawn meta-data synchronization.
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.SynchronizeMetadata Method

Grid Solutions Framework DataSubscriberSynchronizeMetadata Method
Handles meta-data synchronization to local system.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void SynchronizeMetadata()
Protected Overridable Sub SynchronizeMetadata
abstract SynchronizeMetadata : unit -> unit
override SynchronizeMetadata : unit -> unit
function SynchronizeMetadata();
protected:
virtual void SynchronizeMetadata()
Remarks
This function should only be initiated from call to SynchronizeMetadata(DataSet) to make sure only one meta-data synchronization happens at once. Users can override this method to customize process of meta-data synchronization.
See Also

Reference

DataSubscriber Class
SynchronizeMetadata Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.SynchronizeMetadata Method (DataSet)

Grid Solutions Framework DataSubscriberSynchronizeMetadata Method (DataSet)
Spawn meta-data synchronization.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SynchronizeMetadata(
    DataSet metadata
)
Public Sub SynchronizeMetadata (
    metadata As DataSet
)
member SynchronizeMetadata :
        metadata : DataSet -> unit

function SynchronizeMetadata(metadata);
public:
void SynchronizeMetadata(
    DataSet^ metadata
)

Parameters

metadata
Type: System.DataDataSet
DataSet to use for synchronization.
Remarks
This method makes sure only one meta-data synchronization happens at a time.
See Also

Reference

DataSubscriber Class
SynchronizeMetadata Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.Unsubscribe Method

Grid Solutions Framework DataSubscriberUnsubscribe Method
Unsubscribes from a data publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool Unsubscribe()
Public Overridable Function Unsubscribe As Boolean
abstract Unsubscribe : unit -> bool
override Unsubscribe : unit -> bool
function Unsubscribe();
public:
virtual bool Unsubscribe()

Return Value

Type: Boolean
true if unsubscribe transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UnsynchronizedSubscribe Method

Grid Solutions Framework DataSubscriberUnsynchronizedSubscribe Method
Overload List
 | Name | Description
Public method | UnsynchronizedSubscribe(UnsynchronizedSubscriptionInfo) | Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.
Public method | UnsynchronizedSubscribe(Boolean, Boolean, String, String, Boolean, Double, Double, Boolean, String, String, String, Int32, String, Int32) | Obsolete. Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UnsynchronizedSubscribe Method (UnsynchronizedSubscriptionInfo)

Grid Solutions Framework DataSubscriberUnsynchronizedSubscribe Method (UnsynchronizedSubscriptionInfo)
Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UnsynchronizedSubscribe(
    UnsynchronizedSubscriptionInfo info
)
Public Function UnsynchronizedSubscribe (
    info As UnsynchronizedSubscriptionInfo
) As Boolean
member UnsynchronizedSubscribe :
        info : UnsynchronizedSubscriptionInfo -> bool

function UnsynchronizedSubscribe(info);
public:
bool UnsynchronizedSubscribe(
    UnsynchronizedSubscriptionInfo^ info
)

Parameters

info
Type: GSF.TimeSeries.TransportUnsynchronizedSubscriptionInfo
Configuration object that defines the subscription.

Return Value

Type: Boolean
true if subscribe transmission was successful; otherwise false.
See Also

Reference

DataSubscriber Class
UnsynchronizedSubscribe Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber.UnsynchronizedSubscribe Method (Boolean, Boolean, String, String, Boolean, Double, Double, Boolean, String, String, String, Int32, String, Int32)

Grid Solutions Framework DataSubscriberUnsynchronizedSubscribe Method (Boolean, Boolean, String, String, Boolean, Double, Double, Boolean, String, String, String, Int32, String, Int32)

Note: This API is now obsolete.

Subscribes (or re-subscribes) to a data publisher for an unsynchronized set of data points.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)]
public virtual bool UnsynchronizedSubscribe(
    bool compactFormat,
    bool throttled,
    string filterExpression,
    string dataChannel = null,
    bool includeTime = true,
    double lagTime = 10,
    double leadTime = 5,
    bool useLocalClockAsRealTime = false,
    string startTime = null,
    string stopTime = null,
    string constraintParameters = null,
    int processingInterval = -1,
    string waitHandleNames = null,
    int waitHandleTimeout = 0
)
<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>
Public Overridable Function UnsynchronizedSubscribe (
    compactFormat As Boolean,
    throttled As Boolean,
    filterExpression As String,
    Optional dataChannel As String = Nothing,
    Optional includeTime As Boolean = true,
    Optional lagTime As Double = 10,
    Optional leadTime As Double = 5,
    Optional useLocalClockAsRealTime As Boolean = false,
    Optional startTime As String = Nothing,
    Optional stopTime As String = Nothing,
    Optional constraintParameters As String = Nothing,
    Optional processingInterval As Integer = -1,
    Optional waitHandleNames As String = Nothing,
    Optional waitHandleTimeout As Integer = 0
) As Boolean
[<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>]
abstract UnsynchronizedSubscribe :
        compactFormat : bool *
        throttled : bool *
        filterExpression : string *
        ?dataChannel : string *
        ?includeTime : bool *
        ?lagTime : float *
        ?leadTime : float *
        ?useLocalClockAsRealTime : bool *
        ?startTime : string *
        ?stopTime : string *
        ?constraintParameters : string *
        ?processingInterval : int *
        ?waitHandleNames : string *
        ?waitHandleTimeout : int
(* Defaults:
        let _dataChannel = defaultArg dataChannel null
        let _includeTime = defaultArg includeTime true
        let _lagTime = defaultArg lagTime 10
        let _leadTime = defaultArg leadTime 5
        let _useLocalClockAsRealTime = defaultArg useLocalClockAsRealTime false
        let _startTime = defaultArg startTime null
        let _stopTime = defaultArg stopTime null
        let _constraintParameters = defaultArg constraintParameters null
        let _processingInterval = defaultArg processingInterval -1
        let _waitHandleNames = defaultArg waitHandleNames null
        let _waitHandleTimeout = defaultArg waitHandleTimeout 0
*)
-> bool
[<ObsoleteAttribute("Preferred method uses SubscriptionInfo object to subscribe.",
    false)>]
override UnsynchronizedSubscribe :
        compactFormat : bool *
        throttled : bool *
        filterExpression : string *
        ?dataChannel : string *
        ?includeTime : bool *
        ?lagTime : float *
        ?leadTime : float *
        ?useLocalClockAsRealTime : bool *
        ?startTime : string *
        ?stopTime : string *
        ?constraintParameters : string *
        ?processingInterval : int *
        ?waitHandleNames : string *
        ?waitHandleTimeout : int
(* Defaults:
        let _dataChannel = defaultArg dataChannel null
        let _includeTime = defaultArg includeTime true
        let _lagTime = defaultArg lagTime 10
        let _leadTime = defaultArg leadTime 5
        let _useLocalClockAsRealTime = defaultArg useLocalClockAsRealTime false
        let _startTime = defaultArg startTime null
        let _stopTime = defaultArg stopTime null
        let _constraintParameters = defaultArg constraintParameters null
        let _processingInterval = defaultArg processingInterval -1
        let _waitHandleNames = defaultArg waitHandleNames null
        let _waitHandleTimeout = defaultArg waitHandleTimeout 0
*)
-> bool
function UnsynchronizedSubscribe(compactFormat, throttled, filterExpression, dataChannel, includeTime, lagTime, leadTime, useLocalClockAsRealTime, startTime, stopTime, constraintParameters, processingInterval, waitHandleNames, waitHandleTimeout);
public:
[ObsoleteAttribute(L"Preferred method uses SubscriptionInfo object to subscribe.",
    false)]
virtual bool UnsynchronizedSubscribe(
    bool compactFormat,
    bool throttled,
    String^ filterExpression,
    String^ dataChannel = nullptr,
    bool includeTime = true,
    double lagTime = 10,
    double leadTime = 5,
    bool useLocalClockAsRealTime = false,
    String^ startTime = nullptr,
    String^ stopTime = nullptr,
    String^ constraintParameters = nullptr,
    int processingInterval = -1,
    String^ waitHandleNames = nullptr,
    int waitHandleTimeout = 0
)

Parameters

compactFormat
Type: SystemBoolean
Boolean value that determines if the compact measurement format should be used. Set to false for full fidelity measurement serialization; otherwise set to true for bandwidth conservation.
throttled
Type: SystemBoolean
Boolean value that determines if data should be throttled at a set transmission interval or sent on change.
filterExpression
Type: SystemString
Filtering expression that defines the measurements that are being subscribed.
dataChannel (Optional)
Type: SystemString
Desired UDP return data channel connection string to use for data packet transmission. Set to null to use TCP channel for data transmission.
includeTime (Optional)
Type: SystemBoolean
Boolean value that determines if time is a necessary component in streaming data.
lagTime (Optional)
Type: SystemDouble
When throttled is true, defines the data transmission speed in seconds (can be sub-second).
leadTime (Optional)
Type: SystemDouble
When throttled is true, defines the allowed time deviation tolerance to real-time in seconds (can be sub-second).
useLocalClockAsRealTime (Optional)
Type: SystemBoolean
When throttled is true, defines boolean value that determines whether or not to use the local clock time as real-time. Set to false to use latest received measurement timestamp as real-time.
startTime (Optional)
Type: SystemString
Defines a relative or exact start time for the temporal constraint to use for historical playback.
stopTime (Optional)
Type: SystemString
Defines a relative or exact stop time for the temporal constraint to use for historical playback.
constraintParameters (Optional)
Type: SystemString
Defines any temporal parameters related to the constraint to use for historical playback.
processingInterval (Optional)
Type: SystemInt32
Defines the desired processing interval milliseconds, i.e., historical play back speed, to use when temporal constraints are defined.
waitHandleNames (Optional)
Type: SystemString
Comma separated list of wait handle names used to establish external event wait handles needed for inter-adapter synchronization.
waitHandleTimeout (Optional)
Type: SystemInt32
Maximum wait time for external events, in milliseconds, before proceeding.

Return Value

Type: Boolean
true if subscribe transmission was successful; otherwise false.
Remarks

When the startTime or stopTime temporal processing constraints are defined (i.e., not null), this specifies the start and stop time over which the subscriber session will process data. Passing in null for the startTime and stopTime specifies the subscriber session will process data in standard, i.e., real-time, operation.

With the exception of the values of -1 and 0, the processingInterval value specifies the desired historical playback data processing interval in milliseconds. This is basically a delay, or timer interval, over which to process data. Setting this value to -1 means to use the default processing interval while setting the value to 0 means to process data as fast as possible.

The startTime and stopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

DataSubscriber Class
UnsynchronizedSubscribe Overload
GSF.TimeSeries.Transport Namespace


DataSubscriber Properties

Grid Solutions Framework DataSubscriber Properties

The DataSubscriber type exposes the following members.

Properties
 | Name | Description
Public property | Authenticated | Gets flag that determines if this DataSubscriber has successfully authenticated with the DataPublisher.
Public property | AutoConnect | Gets or sets flag that determines if DataSubscriber should attempt to auto-connection to DataPublisher using defined connection settings.
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | AutoSynchronizeMetadata | Gets or sets flag that determines if DataSubscriber should automatically request meta-data synchronization and synchronize publisher meta-data with its own database configuration.
Public property | AverageMeasurementsPerSecond | Gets the average value of the measurements per second calculation.
Protected property | CommandChannel | Gets or sets reference to TcpClient command channel, attaching and/or detaching to events as needed.
Public property | CompressMetadata | Gets or sets the operational mode flag to compress meta-data.
Public property | CompressPayload | Gets or sets the operational mode flag to compress data payloads.
Public property | CompressSignalIndexCache | Gets or sets the operational mode flag to compress the signal index cache.
Protected property | ConnectionAttemptInterval | Gets or sets the connection attempt interval, in milliseconds, for the data input source. (Inherited from InputAdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Protected property | DataChannel | Gets or sets reference to UdpClient data channel, attaching and/or detaching to events as needed.
Public property | DataLossInterval | Gets or sets data loss monitoring interval, in seconds. Set to zero to disable monitoring.
Public property | DataSource | Gets or sets DataSet based data source available to this DataSubscriber. (Overrides AdapterBaseDataSource.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | GatewayCompressionMode | Gets or sets the GatewayCompressionMode used by the subscriber and publisher.
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the AdapterBase expects, if any. (Inherited from InputAdapterBase.)
Public property | IsConnected | Gets flag that determines if InputAdapterBase is connected. (Inherited from InputAdapterBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LifetimeAverageLatency | Gets the average latency calculated over the full lifetime of the subscriber.
Public property | LifetimeMaximumLatency | Gets the maximum latency calculated over the full lifetime of the subscriber.
Public property | LifetimeMeasurements | Gets the total number of measurements processed through this data publisher over the lifetime of the subscriber.
Public property | LifetimeMinimumLatency | Gets the minimum latency calculated over the full lifetime of the subscriber.
Public property | LoggingPath | Gets or sets logging path to be used to be runtime and outage logs of the subscriber which are required for automated data recovery.
Public property | MaximumMeasurementsPerSecond | Gets the maximum value of the measurements per second calculation.
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
 | MetadataFilters | Gets or sets requested meta-data filter expressions to be applied by DataPublisher before meta-data is sent.
Public property | MetadataSynchronizationTimeout | Gets or sets the timeout used when executing database queries during meta-data synchronization.
Public property | MinimumMeasurementsPerSecond | Gets the minimum value of the measurements per second calculation.
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OperationalEncoding | Gets or sets the OperationalEncoding used by the subscriber and publisher.
Public property | OperationalModes | Gets or sets a set of flags that define ways in which the subscriber and publisher communicate.
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from InputAdapterBase.)
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Overrides AdapterBaseProcessingInterval.)
Protected property | RealTime | Gets real-time as determined by either the local clock or the latest measurement received.
Public property | ReceiveExternalMetadata | Gets or sets the operational mode flag to receive external meta-data.
Public property | ReceiveInternalMetadata | Gets or sets the operational mode flag to receive internal meta-data.
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from InputAdapterBase.)
Public property | RequireAuthentication | Gets or sets flag that determines if DataPublisher requires subscribers to authenticate before making data requests.
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | SecurityMode | Gets or sets the security mode used for communications over the command channel.
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Gets the status of this DataSubscriber. (Overrides InputAdapterBaseStatus.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Public property | TotalBytesReceived | Gets total data packet bytes received during this session.
Protected property | UseAsyncConnect | Gets a flag that determines if this DataSubscriber uses an asynchronous connection. (Overrides InputAdapterBaseUseAsyncConnect.)
Public property | UseCommonSerializationFormat | Gets or sets the operational mode flag to use the common serialization format.
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether to use the local clock when calculating statistics.
Public property | UseMillisecondResolution | Obsolete. Gets or sets flag that informs publisher if base time-offsets can use millisecond resolution to conserve bandwidth.
Public property | UseTransactionForMetadata | Gets or sets flag that determines if meta-data synchronization should be performed within a transaction.
Public property | UseZeroMQChannel | Gets or sets flag that determines if ZeroMQ should be used for command channel communications.
Public property | Version | Gets the version number of the protocol in use by this subscriber.
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Authenticated Property

Grid Solutions Framework DataSubscriberAuthenticated Property
Gets flag that determines if this DataSubscriber has successfully authenticated with the DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Authenticated { get; }
Public ReadOnly Property Authenticated As Boolean
    Get
member Authenticated : bool with get

function get_Authenticated();

public:
property bool Authenticated {
    bool get ();
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.AutoConnect Property

Grid Solutions Framework DataSubscriberAutoConnect Property
Gets or sets flag that determines if DataSubscriber should attempt to auto-connection to DataPublisher using defined connection settings.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AutoConnect { get; set; }
Public Property AutoConnect As Boolean
    Get
    Set
member AutoConnect : bool with get, set

function get_AutoConnect();
function set_AutoConnect(value);
public:
property bool AutoConnect {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.AutoSynchronizeMetadata Property

Grid Solutions Framework DataSubscriberAutoSynchronizeMetadata Property
Gets or sets flag that determines if DataSubscriber should automatically request meta-data synchronization and synchronize publisher meta-data with its own database configuration.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AutoSynchronizeMetadata { get; set; }
Public Property AutoSynchronizeMetadata As Boolean
    Get
    Set
member AutoSynchronizeMetadata : bool with get, set

function get_AutoSynchronizeMetadata();
function set_AutoSynchronizeMetadata(value);
public:
property bool AutoSynchronizeMetadata {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.AverageMeasurementsPerSecond Property

Grid Solutions Framework DataSubscriberAverageMeasurementsPerSecond Property
Gets the average value of the measurements per second calculation.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long AverageMeasurementsPerSecond { get; }
Public ReadOnly Property AverageMeasurementsPerSecond As Long
    Get
member AverageMeasurementsPerSecond : int64 with get

function get_AverageMeasurementsPerSecond();

public:
property long long AverageMeasurementsPerSecond {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.CommandChannel Property

Grid Solutions Framework DataSubscriberCommandChannel Property
Gets or sets reference to TcpClient command channel, attaching and/or detaching to events as needed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected IClient CommandChannel { get; set; }
Protected Property CommandChannel As IClient
    Get
    Set
member CommandChannel : IClient with get, set

function get_CommandChannel();
function set_CommandChannel(value);
protected:
property IClient^ CommandChannel {
    IClient^ get ();
    void set (IClient^ value);
}

Property Value

Type: IClient
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.CompressMetadata Property

Grid Solutions Framework DataSubscriberCompressMetadata Property
Gets or sets the operational mode flag to compress meta-data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CompressMetadata { get; set; }
Public Property CompressMetadata As Boolean
    Get
    Set
member CompressMetadata : bool with get, set

function get_CompressMetadata();
function set_CompressMetadata(value);
public:
property bool CompressMetadata {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.CompressPayload Property

Grid Solutions Framework DataSubscriberCompressPayload Property
Gets or sets the operational mode flag to compress data payloads.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CompressPayload { get; set; }
Public Property CompressPayload As Boolean
    Get
    Set
member CompressPayload : bool with get, set

function get_CompressPayload();
function set_CompressPayload(value);
public:
property bool CompressPayload {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.CompressSignalIndexCache Property

Grid Solutions Framework DataSubscriberCompressSignalIndexCache Property
Gets or sets the operational mode flag to compress the signal index cache.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool CompressSignalIndexCache { get; set; }
Public Property CompressSignalIndexCache As Boolean
    Get
    Set
member CompressSignalIndexCache : bool with get, set

function get_CompressSignalIndexCache();
function set_CompressSignalIndexCache(value);
public:
property bool CompressSignalIndexCache {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DataChannel Property

Grid Solutions Framework DataSubscriberDataChannel Property
Gets or sets reference to UdpClient data channel, attaching and/or detaching to events as needed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected UdpClient DataChannel { get; set; }
Protected Property DataChannel As UdpClient
    Get
    Set
member DataChannel : UdpClient with get, set

function get_DataChannel();
function set_DataChannel(value);
protected:
property UdpClient^ DataChannel {
    UdpClient^ get ();
    void set (UdpClient^ value);
}

Property Value

Type: UdpClient
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DataLossInterval Property

Grid Solutions Framework DataSubscriberDataLossInterval Property
Gets or sets data loss monitoring interval, in seconds. Set to zero to disable monitoring.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double DataLossInterval { get; set; }
Public Property DataLossInterval As Double
    Get
    Set
member DataLossInterval : float with get, set

function get_DataLossInterval();
function set_DataLossInterval(value);
public:
property double DataLossInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DataSource Property

Grid Solutions Framework DataSubscriberDataSource Property
Gets or sets DataSet based data source available to this DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override DataSet DataSource { get; set; }
Public Overrides Property DataSource As DataSet
    Get
    Set
abstract DataSource : DataSet with get, set
override DataSource : DataSet with get, set
function get_DataSource();
function set_DataSource(value);
public:
virtual property DataSet^ DataSource {
    DataSet^ get () override;
    void set (DataSet^ value) override;
}

Property Value

Type: DataSet

Implements

IAdapterDataSource
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.GatewayCompressionMode Property

Grid Solutions Framework DataSubscriberGatewayCompressionMode Property
Gets or sets the GatewayCompressionMode used by the subscriber and publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public GatewayCompressionMode GatewayCompressionMode { get; set; }
Public Property GatewayCompressionMode As GatewayCompressionMode
    Get
    Set
member GatewayCompressionMode : GatewayCompressionMode with get, set

function get_GatewayCompressionMode();
function set_GatewayCompressionMode(value);
public:
property GatewayCompressionMode GatewayCompressionMode {
    GatewayCompressionMode get ();
    void set (GatewayCompressionMode value);
}

Property Value

Type: GatewayCompressionMode
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.LifetimeAverageLatency Property

Grid Solutions Framework DataSubscriberLifetimeAverageLatency Property
Gets the average latency calculated over the full lifetime of the subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LifetimeAverageLatency { get; }
Public ReadOnly Property LifetimeAverageLatency As Integer
    Get
member LifetimeAverageLatency : int with get

function get_LifetimeAverageLatency();

public:
property int LifetimeAverageLatency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.LifetimeMaximumLatency Property

Grid Solutions Framework DataSubscriberLifetimeMaximumLatency Property
Gets the maximum latency calculated over the full lifetime of the subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LifetimeMaximumLatency { get; }
Public ReadOnly Property LifetimeMaximumLatency As Integer
    Get
member LifetimeMaximumLatency : int with get

function get_LifetimeMaximumLatency();

public:
property int LifetimeMaximumLatency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.LifetimeMeasurements Property

Grid Solutions Framework DataSubscriberLifetimeMeasurements Property
Gets the total number of measurements processed through this data publisher over the lifetime of the subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long LifetimeMeasurements { get; }
Public ReadOnly Property LifetimeMeasurements As Long
    Get
member LifetimeMeasurements : int64 with get

function get_LifetimeMeasurements();

public:
property long long LifetimeMeasurements {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.LifetimeMinimumLatency Property

Grid Solutions Framework DataSubscriberLifetimeMinimumLatency Property
Gets the minimum latency calculated over the full lifetime of the subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int LifetimeMinimumLatency { get; }
Public ReadOnly Property LifetimeMinimumLatency As Integer
    Get
member LifetimeMinimumLatency : int with get

function get_LifetimeMinimumLatency();

public:
property int LifetimeMinimumLatency {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.LoggingPath Property

Grid Solutions Framework DataSubscriberLoggingPath Property
Gets or sets logging path to be used to be runtime and outage logs of the subscriber which are required for automated data recovery.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string LoggingPath { get; set; }
Public Property LoggingPath As String
    Get
    Set
member LoggingPath : string with get, set

function get_LoggingPath();
function set_LoggingPath(value);
public:
property String^ LoggingPath {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Leave value blank for default path, i.e., installation folder. Can be a fully qualified path or a path that is relative to the installation folder, e.g., a value of "ConfigurationCache" might resolve to "C:\Program Files\MyTimeSeriespPp\ConfigurationCache\".
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.MaximumMeasurementsPerSecond Property

Grid Solutions Framework DataSubscriberMaximumMeasurementsPerSecond Property
Gets the maximum value of the measurements per second calculation.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MaximumMeasurementsPerSecond { get; }
Public ReadOnly Property MaximumMeasurementsPerSecond As Long
    Get
member MaximumMeasurementsPerSecond : int64 with get

function get_MaximumMeasurementsPerSecond();

public:
property long long MaximumMeasurementsPerSecond {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.MetadataFilters Property

Grid Solutions Framework DataSubscriberMetadataFilters Property
Gets or sets requested meta-data filter expressions to be applied by DataPublisher before meta-data is sent.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string MetadataFilters { get; set; }
Public Property MetadataFilters As String
    Get
    Set
member MetadataFilters : string with get, set

function get_MetadataFilters();
function set_MetadataFilters(value);
public:
property String^ MetadataFilters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks
Multiple meta-data filters, such filters for different data tables, should be separated by a semicolon. Specifying fields in the filter expression that do not exist in the data publisher's current meta-data set could cause filter expressions to not be applied and possibly result in no meta-data being received for the specified data table.
Examples
FILTER MeasurementDetail WHERE SignalType <> 'STAT'; FILTER PhasorDetail WHERE Phase = '+'
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.MetadataSynchronizationTimeout Property

Grid Solutions Framework DataSubscriberMetadataSynchronizationTimeout Property
Gets or sets the timeout used when executing database queries during meta-data synchronization.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int MetadataSynchronizationTimeout { get; set; }
Public Property MetadataSynchronizationTimeout As Integer
    Get
    Set
member MetadataSynchronizationTimeout : int with get, set

function get_MetadataSynchronizationTimeout();
function set_MetadataSynchronizationTimeout(value);
public:
property int MetadataSynchronizationTimeout {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.MinimumMeasurementsPerSecond Property

Grid Solutions Framework DataSubscriberMinimumMeasurementsPerSecond Property
Gets the minimum value of the measurements per second calculation.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MinimumMeasurementsPerSecond { get; }
Public ReadOnly Property MinimumMeasurementsPerSecond As Long
    Get
member MinimumMeasurementsPerSecond : int64 with get

function get_MinimumMeasurementsPerSecond();

public:
property long long MinimumMeasurementsPerSecond {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OperationalEncoding Property

Grid Solutions Framework DataSubscriberOperationalEncoding Property
Gets or sets the OperationalEncoding used by the subscriber and publisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OperationalEncoding OperationalEncoding { get; set; }
Public Property OperationalEncoding As OperationalEncoding
    Get
    Set
member OperationalEncoding : OperationalEncoding with get, set

function get_OperationalEncoding();
function set_OperationalEncoding(value);
public:
property OperationalEncoding OperationalEncoding {
    OperationalEncoding get ();
    void set (OperationalEncoding value);
}

Property Value

Type: OperationalEncoding
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.OperationalModes Property

Grid Solutions Framework DataSubscriberOperationalModes Property
Gets or sets a set of flags that define ways in which the subscriber and publisher communicate.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public OperationalModes OperationalModes { get; set; }
Public Property OperationalModes As OperationalModes
    Get
    Set
member OperationalModes : OperationalModes with get, set

function get_OperationalModes();
function set_OperationalModes(value);
public:
property OperationalModes OperationalModes {
    OperationalModes get ();
    void set (OperationalModes value);
}

Property Value

Type: OperationalModes
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ProcessingInterval Property

Grid Solutions Framework DataSubscriberProcessingInterval Property
Gets or sets the desired processing interval, in milliseconds, for the adapter.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int ProcessingInterval { get; set; }
Public Overrides Property ProcessingInterval As Integer
    Get
    Set
abstract ProcessingInterval : int with get, set
override ProcessingInterval : int with get, set
function get_ProcessingInterval();
function set_ProcessingInterval(value);
public:
virtual property int ProcessingInterval {
    int get () override;
    void set (int value) override;
}

Property Value

Type: Int32

Implements

IAdapterProcessingInterval
Remarks
With the exception of the values of -1 and 0, this value specifies the desired processing interval for data, i.e., basically a delay, or timer interval, over which to process data. A value of -1 means to use the default processing interval while a value of 0 means to process data as fast as possible.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.RealTime Property

Grid Solutions Framework DataSubscriberRealTime Property
Gets real-time as determined by either the local clock or the latest measurement received.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Ticks RealTime { get; }
Protected ReadOnly Property RealTime As Ticks
    Get
member RealTime : Ticks with get

function get_RealTime();

protected:
property Ticks RealTime {
    Ticks get ();
}

Property Value

Type: Ticks
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ReceiveExternalMetadata Property

Grid Solutions Framework DataSubscriberReceiveExternalMetadata Property
Gets or sets the operational mode flag to receive external meta-data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReceiveExternalMetadata { get; set; }
Public Property ReceiveExternalMetadata As Boolean
    Get
    Set
member ReceiveExternalMetadata : bool with get, set

function get_ReceiveExternalMetadata();
function set_ReceiveExternalMetadata(value);
public:
property bool ReceiveExternalMetadata {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ReceiveInternalMetadata Property

Grid Solutions Framework DataSubscriberReceiveInternalMetadata Property
Gets or sets the operational mode flag to receive internal meta-data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ReceiveInternalMetadata { get; set; }
Public Property ReceiveInternalMetadata As Boolean
    Get
    Set
member ReceiveInternalMetadata : bool with get, set

function get_ReceiveInternalMetadata();
function set_ReceiveInternalMetadata(value);
public:
property bool ReceiveInternalMetadata {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.RequireAuthentication Property

Grid Solutions Framework DataSubscriberRequireAuthentication Property
Gets or sets flag that determines if DataPublisher requires subscribers to authenticate before making data requests.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RequireAuthentication { get; set; }
Public Property RequireAuthentication As Boolean
    Get
    Set
member RequireAuthentication : bool with get, set

function get_RequireAuthentication();
function set_RequireAuthentication(value);
public:
property bool RequireAuthentication {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.SecurityMode Property

Grid Solutions Framework DataSubscriberSecurityMode Property
Gets or sets the security mode used for communications over the command channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityMode SecurityMode { get; set; }
Public Property SecurityMode As SecurityMode
    Get
    Set
member SecurityMode : SecurityMode with get, set

function get_SecurityMode();
function set_SecurityMode(value);
public:
property SecurityMode SecurityMode {
    SecurityMode get ();
    void set (SecurityMode value);
}

Property Value

Type: SecurityMode
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Status Property

Grid Solutions Framework DataSubscriberStatus Property
Gets the status of this DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
IProvideStatusStatus
Remarks
Derived classes should provide current status information about the adapter for display purposes.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.SupportsTemporalProcessing Property

Grid Solutions Framework DataSubscriberSupportsTemporalProcessing Property
Gets the flag indicating if this adapter supports temporal processing.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get
override SupportsTemporalProcessing : bool with get
function get_SupportsTemporalProcessing();

public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IAdapterSupportsTemporalProcessing
Remarks
Although the data subscriber provisions support for temporal processing by receiving historical data from a remote source, the adapter opens sockets and does not need to be engaged within an actual temporal IaonSession, therefore this method returns false to make sure the adapter doesn't get instantiated within a temporal session.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.TotalBytesReceived Property

Grid Solutions Framework DataSubscriberTotalBytesReceived Property
Gets total data packet bytes received during this session.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TotalBytesReceived { get; }
Public ReadOnly Property TotalBytesReceived As Long
    Get
member TotalBytesReceived : int64 with get

function get_TotalBytesReceived();

public:
property long long TotalBytesReceived {
    long long get ();
}

Property Value

Type: Int64
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UseAsyncConnect Property

Grid Solutions Framework DataSubscriberUseAsyncConnect Property
Gets a flag that determines if this DataSubscriber uses an asynchronous connection.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool UseAsyncConnect { get; }
Protected Overrides ReadOnly Property UseAsyncConnect As Boolean
    Get
abstract UseAsyncConnect : bool with get
override UseAsyncConnect : bool with get
function get_UseAsyncConnect();

protected:
virtual property bool UseAsyncConnect {
    bool get () override;
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UseCommonSerializationFormat Property

Grid Solutions Framework DataSubscriberUseCommonSerializationFormat Property
Gets or sets the operational mode flag to use the common serialization format.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseCommonSerializationFormat { get; set; }
Public Property UseCommonSerializationFormat As Boolean
    Get
    Set
member UseCommonSerializationFormat : bool with get, set

function get_UseCommonSerializationFormat();
function set_UseCommonSerializationFormat(value);
public:
property bool UseCommonSerializationFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UseLocalClockAsRealTime Property

Grid Solutions Framework DataSubscriberUseLocalClockAsRealTime Property
Gets or sets flag that determines whether to use the local clock when calculating statistics.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseLocalClockAsRealTime { get; set; }
Public Property UseLocalClockAsRealTime As Boolean
    Get
    Set
member UseLocalClockAsRealTime : bool with get, set

function get_UseLocalClockAsRealTime();
function set_UseLocalClockAsRealTime(value);
public:
property bool UseLocalClockAsRealTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UseMillisecondResolution Property

Grid Solutions Framework DataSubscriberUseMillisecondResolution Property

Note: This API is now obsolete.

Gets or sets flag that informs publisher if base time-offsets can use millisecond resolution to conserve bandwidth.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ObsoleteAttribute("SubscriptionInfo object defines this parameter.",
    false)]
public bool UseMillisecondResolution { get; set; }
<ObsoleteAttribute("SubscriptionInfo object defines this parameter.",
    false)>
Public Property UseMillisecondResolution As Boolean
    Get
    Set
[<ObsoleteAttribute("SubscriptionInfo object defines this parameter.",
    false)>]
member UseMillisecondResolution : bool with get, set

function get_UseMillisecondResolution();
function set_UseMillisecondResolution(value);
public:
[ObsoleteAttribute(L"SubscriptionInfo object defines this parameter.",
    false)]
property bool UseMillisecondResolution {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UseTransactionForMetadata Property

Grid Solutions Framework DataSubscriberUseTransactionForMetadata Property
Gets or sets flag that determines if meta-data synchronization should be performed within a transaction.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseTransactionForMetadata { get; set; }
Public Property UseTransactionForMetadata As Boolean
    Get
    Set
member UseTransactionForMetadata : bool with get, set

function get_UseTransactionForMetadata();
function set_UseTransactionForMetadata(value);
public:
property bool UseTransactionForMetadata {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.UseZeroMQChannel Property

Grid Solutions Framework DataSubscriberUseZeroMQChannel Property
Gets or sets flag that determines if ZeroMQ should be used for command channel communications.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool UseZeroMQChannel { get; set; }
Public Property UseZeroMQChannel As Boolean
    Get
    Set
member UseZeroMQChannel : bool with get, set

function get_UseZeroMQChannel();
function set_UseZeroMQChannel(value);
public:
property bool UseZeroMQChannel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.Version Property

Grid Solutions Framework DataSubscriberVersion Property
Gets the version number of the protocol in use by this subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Version { get; }
Public ReadOnly Property Version As Integer
    Get
member Version : int with get

function get_Version();

public:
property int Version {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber Events

Grid Solutions Framework DataSubscriber Events

The DataSubscriber type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | ConnectionAuthenticated | Occurs when client connection to the data publication server has successfully authenticated.
Public event | ConnectionEstablished | Occurs when client connection to the data publication server is established.
Public event | ConnectionTerminated | Occurs when client connection to the data publication server is terminated.
Public event | DataStartTime | Occurs when first measurement is transmitted by data publication server.
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | MetaDataReceived | Occurs when client receives requested meta-data transmitted by data publication server.
Public event | NewMeasurements | Provides new measurements from input adapter. (Inherited from InputAdapterBase.)
Public event | NotificationReceived | Occurs when a notification has been received from the DataPublisher.
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | ProcessingComplete | Indicates that processing for an input adapter (via temporal session) has completed.
Public event | ReceivedServerResponse | Occurs when client receives response from the server.
Public event | ServerConfigurationChanged | Occurs when the server has sent a notification that its configuration has changed, this can allow subscriber to request updated meta-data if desired.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Top
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ConnectionAuthenticated Event

Grid Solutions Framework DataSubscriberConnectionAuthenticated Event
Occurs when client connection to the data publication server has successfully authenticated.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionAuthenticated
Public Event ConnectionAuthenticated As EventHandler
member ConnectionAuthenticated : IEvent<EventHandler,
    EventArgs>

function add_ConnectionAuthenticated(value);
function remove_ConnectionAuthenticated(value);
public:
 event EventHandler^ ConnectionAuthenticated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ConnectionEstablished Event

Grid Solutions Framework DataSubscriberConnectionEstablished Event
Occurs when client connection to the data publication server is established.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionEstablished
Public Event ConnectionEstablished As EventHandler
member ConnectionEstablished : IEvent<EventHandler,
    EventArgs>

function add_ConnectionEstablished(value);
function remove_ConnectionEstablished(value);
public:
 event EventHandler^ ConnectionEstablished {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ConnectionTerminated Event

Grid Solutions Framework DataSubscriberConnectionTerminated Event
Occurs when client connection to the data publication server is terminated.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ConnectionTerminated
Public Event ConnectionTerminated As EventHandler
member ConnectionTerminated : IEvent<EventHandler,
    EventArgs>

function add_ConnectionTerminated(value);
function remove_ConnectionTerminated(value);
public:
 event EventHandler^ ConnectionTerminated {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.DataStartTime Event

Grid Solutions Framework DataSubscriberDataStartTime Event
Occurs when first measurement is transmitted by data publication server.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<Ticks>> DataStartTime
Public Event DataStartTime As EventHandler(Of EventArgs(Of Ticks))
member DataStartTime : IEvent<EventHandler<EventArgs<Ticks>>,
    EventArgs<Ticks>>

function add_DataStartTime(value);
function remove_DataStartTime(value);
public:
 event EventHandler<EventArgs<Ticks>^>^ DataStartTime {
    void add (EventHandler<EventArgs<Ticks>^>^ value);
    void remove (EventHandler<EventArgs<Ticks>^>^ value);
}

Value

Type: SystemEventHandler EventArgs Ticks
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.MetaDataReceived Event

Grid Solutions Framework DataSubscriberMetaDataReceived Event
Occurs when client receives requested meta-data transmitted by data publication server.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<DataSet>> MetaDataReceived
Public Event MetaDataReceived As EventHandler(Of EventArgs(Of DataSet))
member MetaDataReceived : IEvent<EventHandler<EventArgs<DataSet>>,
    EventArgs<DataSet>>

function add_MetaDataReceived(value);
function remove_MetaDataReceived(value);
public:
 event EventHandler<EventArgs<DataSet^>^>^ MetaDataReceived {
    void add (EventHandler<EventArgs<DataSet^>^>^ value);
    void remove (EventHandler<EventArgs<DataSet^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs DataSet
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.NotificationReceived Event

Grid Solutions Framework DataSubscriberNotificationReceived Event
Occurs when a notification has been received from the DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> NotificationReceived
Public Event NotificationReceived As EventHandler(Of EventArgs(Of String))
member NotificationReceived : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_NotificationReceived(value);
function remove_NotificationReceived(value);
public:
 event EventHandler<EventArgs<String^>^>^ NotificationReceived {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ProcessingComplete Event

Grid Solutions Framework DataSubscriberProcessingComplete Event
Indicates that processing for an input adapter (via temporal session) has completed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<string>> ProcessingComplete
Public Event ProcessingComplete As EventHandler(Of EventArgs(Of String))
member ProcessingComplete : IEvent<EventHandler<EventArgs<string>>,
    EventArgs<string>>

function add_ProcessingComplete(value);
function remove_ProcessingComplete(value);
public:
 event EventHandler<EventArgs<String^>^>^ ProcessingComplete {
    void add (EventHandler<EventArgs<String^>^>^ value);
    void remove (EventHandler<EventArgs<String^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs String
Remarks
This event is expected to only be raised when an input adapter has been designed to process a finite amount of data, e.g., reading a historical range of data during temporal processing.
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ReceivedServerResponse Event

Grid Solutions Framework DataSubscriberReceivedServerResponse Event
Occurs when client receives response from the server.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler<EventArgs<ServerResponse, ServerCommand>> ReceivedServerResponse
Public Event ReceivedServerResponse As EventHandler(Of EventArgs(Of ServerResponse, ServerCommand))
member ReceivedServerResponse : IEvent<EventHandler<EventArgs<ServerResponse, ServerCommand>>,
    EventArgs<ServerResponse, ServerCommand>>

function add_ReceivedServerResponse(value);
function remove_ReceivedServerResponse(value);
public:
 event EventHandler<EventArgs<ServerResponse, ServerCommand>^>^ ReceivedServerResponse {
    void add (EventHandler<EventArgs<ServerResponse, ServerCommand>^>^ value);
    void remove (EventHandler<EventArgs<ServerResponse, ServerCommand>^>^ value);
}

Value

Type: SystemEventHandler EventArgs ServerResponse, ServerCommand
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


DataSubscriber.ServerConfigurationChanged Event

Grid Solutions Framework DataSubscriberServerConfigurationChanged Event
Occurs when the server has sent a notification that its configuration has changed, this can allow subscriber to request updated meta-data if desired.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public event EventHandler ServerConfigurationChanged
Public Event ServerConfigurationChanged As EventHandler
member ServerConfigurationChanged : IEvent<EventHandler,
    EventArgs>

function add_ServerConfigurationChanged(value);
function remove_ServerConfigurationChanged(value);
public:
 event EventHandler^ ServerConfigurationChanged {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

DataSubscriber Class
GSF.TimeSeries.Transport Namespace


GatewayCompressionMode Enumeration

Grid Solutions Framework GatewayCompressionMode Enumeration
Enumeration for compression modes supported by the Gateway Exchange Protocol.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum GatewayCompressionMode
Public Enumeration GatewayCompressionMode
type GatewayCompressionMode
GSF.TimeSeries.Transport.GatewayCompressionMode = function();
GSF.TimeSeries.Transport.GatewayCompressionMode.createEnum('GSF.TimeSeries.Transport.GatewayCompressionMode', false);
public enum class GatewayCompressionMode
Members
Member name | Value | Description
GZip | 32 | GZip compression
None | 0 | No compression
See Also

Reference

GSF.TimeSeries.Transport Namespace


IBinaryMeasurement Interface

Grid Solutions Framework IBinaryMeasurement Interface
Defines a IMeasurement that supports ISupportBinaryImage.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IBinaryMeasurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>, IComparable<ITimeSeriesValue>,
    IComparable, ISupportBinaryImage
Public Interface IBinaryMeasurement
    Inherits IMeasurement, ITimeSeriesValue(Of Double), ITimeSeriesValue,
    IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue), IComparable,
    ISupportBinaryImage
type IBinaryMeasurement =
    interface
        interface IMeasurement
        interface ITimeSeriesValue<float>
        interface ITimeSeriesValue
        interface IEquatable<ITimeSeriesValue>
        interface IComparable<ITimeSeriesValue>
        interface IComparable
        interface ISupportBinaryImage
    end
GSF.TimeSeries.Transport.IBinaryMeasurement = function();
GSF.TimeSeries.Transport.IBinaryMeasurement.createInterface('GSF.TimeSeries.Transport.IBinaryMeasurement');
public interface class IBinaryMeasurement : IMeasurement,
    ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>, IComparable<ITimeSeriesValue^>,
    IComparable, ISupportBinaryImage

The IBinaryMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable ITimeSeriesValue .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable ITimeSeriesValue .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetHashCode | Get the hash code for the ID. (Inherited from ITimeSeriesValue.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
Properties
 | Name | Description
Public property | Adder | Defines an offset to add to the IMeasurement value. (Inherited from IMeasurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this IMeasurement, taking into account the specified Adder and Multiplier offsets. (Inherited from IMeasurement.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Key | Gets or sets the primary key of this IMeasurement. (Inherited from IMeasurement.)
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from IMeasurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the IMeasurement value. (Inherited from IMeasurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IMeasurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IMeasurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this IMeasurement. (Inherited from IMeasurement.)
Public property | TagName | Gets or sets the text based tag name of this IMeasurement. (Inherited from IMeasurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw typed value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValueT.)
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


IBinaryMeasurement Methods

Grid Solutions Framework IBinaryMeasurement Methods

The IBinaryMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current instance with another object of the same type and returns an integer that indicates whether the current instance precedes, follows, or occurs in the same position in the sort order as the other object. (Inherited from IComparable.)
Public method | CompareTo(T) | Compares the current object with another object of the same type. (Inherited from IComparable ITimeSeriesValue .)
Public method | Equals | Indicates whether the current object is equal to another object of the same type. (Inherited from IEquatable ITimeSeriesValue .)
Public method | GenerateBinaryImage | Generates binary image of the object and copies it into the given buffer, for BinaryLength bytes. (Inherited from ISupportBinaryImage.)
Public method | GetHashCode | Get the hash code for the ID. (Inherited from ITimeSeriesValue.)
Public method | ParseBinaryImage | Initializes object by parsing the specified buffer containing a binary image. (Inherited from ISupportBinaryImage.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
See Also

Reference

IBinaryMeasurement Interface
GSF.TimeSeries.Transport Namespace


IBinaryMeasurement Properties

Grid Solutions Framework IBinaryMeasurement Properties

The IBinaryMeasurement type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Defines an offset to add to the IMeasurement value. (Inherited from IMeasurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this IMeasurement, taking into account the specified Adder and Multiplier offsets. (Inherited from IMeasurement.)
Public property | BinaryLength | Gets the length of the binary image. (Inherited from ISupportBinaryImage.)
Public property | ID | Gets or sets the Guid based signal ID of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Key | Gets or sets the primary key of this IMeasurement. (Inherited from IMeasurement.)
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from IMeasurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the IMeasurement value. (Inherited from IMeasurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was published (post-processing). (Inherited from IMeasurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this IMeasurement was received (i.e., created). (Inherited from IMeasurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this IMeasurement. (Inherited from IMeasurement.)
Public property | TagName | Gets or sets the text based tag name of this IMeasurement. (Inherited from IMeasurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValue.)
Public property | Value | Gets or sets the raw typed value of this ITimeSeriesValueT. (Inherited from ITimeSeriesValueT.)
Top
See Also

Reference

IBinaryMeasurement Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription Interface

Grid Solutions Framework IClientSubscription Interface
Represents a common set of interfaces for a client adapter subscription to the DataPublisher.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IClientSubscription : IActionAdapter,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus
Public Interface IClientSubscription
    Inherits IActionAdapter, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus
type IClientSubscription =
    interface
        interface IActionAdapter
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
    end
GSF.TimeSeries.Transport.IClientSubscription = function();
GSF.TimeSeries.Transport.IClientSubscription.createInterface('GSF.TimeSeries.Transport.IClientSubscription');
public interface class IClientSubscription : IActionAdapter,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus

The IClientSubscription type exposes the following members.

Methods
 | Name | Description
Public method | ConfirmBufferBlock | Handles the confirmation message received from the subscriber to indicate that a buffer block was received.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | OnProcessException | Explicitly raises the ProcessException event.
Public method | OnProcessingCompleted | Explicitly raises the ProcessingComplete event.
Public method | OnStatusMessage | Explicitly raises the StatusMessage event.
Public method | QueueMeasurementsForProcessing | Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys. (Inherited from IActionAdapter.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateTemporalSession | Returns a new temporal IaonSession for a IClientSubscription. (Defined by IClientSubscriptionExtensions.)
Public Extension Method | DisposeTemporalSession | Disposes a temporal IaonSession created using CreateTemporalSession(IClientSubscription). (Defined by IClientSubscriptionExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ClientID | Gets the Guid client TCP connection identifier of this IClientSubscription.
Public property | CompressionStrength | Gets or sets the compression strength value to use when UsePayloadCompression is true for this IClientSubscription.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostName | Gets or sets host name used to identify connection source of client subscription.
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from IActionAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from IActionAdapter.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedInputFilter | Gets the input filter requested by the subscriber when establishing this IClientSubscription.
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from IActionAdapter.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from IActionAdapter.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from IActionAdapter.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from IActionAdapter.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | SignalIndexCache | Gets the current signal index cache of this IClientSubscription.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SubscriberID | Gets the Guid based subscriber ID of this IClientSubscription.
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Public property | TemporalSessionStatus | Gets the status of the active temporal session, if any.
Public property | TimestampSize | Gets size of timestamp in bytes.
Public property | UseCompactMeasurementFormat | Gets or sets flag that determines if the compact measurement format should be used in data packets of this IClientSubscription.
Public property | UsePayloadCompression | Gets or sets flag that determines if payload compression should be enabled in data packets of this IClientSubscription.
Top
Events
 | Name | Description
Public event | BufferBlockRetransmission | Indicates that a buffer block needed to be retransmitted because it was previously sent, but no confirmation was received.
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from IActionAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | NewMeasurements | Provides new measurements from action adapter. (Inherited from IActionAdapter.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | ProcessingComplete | Indicates to the host that processing for an input adapter (via temporal session) has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue. (Inherited from IActionAdapter.)
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


IClientSubscription Methods

Grid Solutions Framework IClientSubscription Methods

The IClientSubscription type exposes the following members.

Methods
 | Name | Description
Public method | ConfirmBufferBlock | Handles the confirmation message received from the subscriber to indicate that a buffer block was received.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetShortStatus | Gets a short one-line adapter status. (Inherited from IAdapter.)
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | OnProcessException | Explicitly raises the ProcessException event.
Public method | OnProcessingCompleted | Explicitly raises the ProcessingComplete event.
Public method | OnStatusMessage | Explicitly raises the StatusMessage event.
Public method | QueueMeasurementsForProcessing | Queues measurements for processing. Measurements are automatically filtered to the defined InputMeasurementKeys. (Inherited from IActionAdapter.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from IAdapter.)
Public method | Start | Starts the adapter, if it is not already running. (Inherited from IAdapter.)
Public method | Stop | Stops the adapter. (Inherited from IAdapter.)
Top
Extension Methods
 | Name | Description
Public Extension Method | CreateTemporalSession | Returns a new temporal IaonSession for a IClientSubscription. (Defined by IClientSubscriptionExtensions.)
Public Extension Method | DisposeTemporalSession | Disposes a temporal IaonSession created using CreateTemporalSession(IClientSubscription). (Defined by IClientSubscriptionExtensions.)
Public Extension Method | InputMeasurementKeys | Returns the MeasurementKey values of the IAdapter input measurements. (Defined by IAdapterExtensions.)
Public Extension Method | OutputMeasurementKeys | Returns the MeasurementKey values of the IAdapter output measurements. (Defined by IAdapterExtensions.)
Public Extension Method | TemporalConstraintIsDefined | Returns true if IAdapter has a temporal constraint defined, i.e., either StartTimeConstraint or StopTimeConstraint is not set to its default value. (Defined by IAdapterExtensions.)
Top
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.ConfirmBufferBlock Method

Grid Solutions Framework IClientSubscriptionConfirmBufferBlock Method
Handles the confirmation message received from the subscriber to indicate that a buffer block was received.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void ConfirmBufferBlock(
    uint sequenceNumber
)
Sub ConfirmBufferBlock (
    sequenceNumber As UInteger
)
abstract ConfirmBufferBlock :
        sequenceNumber : uint32 -> unit

function ConfirmBufferBlock(sequenceNumber);
void ConfirmBufferBlock(
    unsigned int sequenceNumber
)

Parameters

sequenceNumber
Type: SystemUInt32
The sequence number of the buffer block.

Return Value

Type:
A list of buffer block sequence numbers for blocks that need to be retransmitted.
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.OnProcessException Method

Grid Solutions Framework IClientSubscriptionOnProcessException Method
Explicitly raises the ProcessException event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void OnProcessException(
    Exception ex
)
Sub OnProcessException (
    ex As Exception
)
abstract OnProcessException :
        ex : Exception -> unit

function OnProcessException(ex);
void OnProcessException(
    Exception^ ex
)

Parameters

ex
Type: SystemException
Processing Exception.
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.OnProcessingCompleted Method

Grid Solutions Framework IClientSubscriptionOnProcessingCompleted Method
Explicitly raises the ProcessingComplete event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void OnProcessingCompleted(
    Object sender,
    EventArgs e
)
Sub OnProcessingCompleted (
    sender As Object,
    e As EventArgs
)
abstract OnProcessingCompleted :
        sender : Object *
        e : EventArgs -> unit

function OnProcessingCompleted(sender, e);
void OnProcessingCompleted(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
IInputAdapter raising the notification.
e
Type: SystemEventArgs
Event arguments for notification, if any.
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.OnStatusMessage Method

Grid Solutions Framework IClientSubscriptionOnStatusMessage Method
Explicitly raises the StatusMessage event.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
void OnStatusMessage(
    string status
)
Sub OnStatusMessage (
    status As String
)
abstract OnStatusMessage :
        status : string -> unit

function OnStatusMessage(status);
void OnStatusMessage(
    String^ status
)

Parameters

status
Type: SystemString
New status message.
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription Properties

Grid Solutions Framework IClientSubscription Properties

The IClientSubscription type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or connect on demand. (Inherited from IAdapter.)
Public property | ClientID | Gets the Guid client TCP connection identifier of this IClientSubscription.
Public property | CompressionStrength | Gets or sets the compression strength value to use when UsePayloadCompression is true for this IClientSubscription.
Public property | ConnectionString | Gets or sets key/value pair connection information specific to IAdapter. (Inherited from IAdapter.)
Public property | DataSource | Gets or sets DataSet based data source available to IAdapter. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | HostName | Gets or sets host name used to identify connection source of client subscription.
Public property | ID | Gets or sets the numeric ID associated with this IAdapter. (Inherited from IAdapter.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from IAdapter.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from IAdapter.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the adapter expects. (Inherited from IAdapter.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from IActionAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | Name | Gets or sets name of this IAdapter. (Inherited from IAdapter.)
Public property | OutputMeasurements | Gets or sets output measurements that the adapter will produce, if any. (Inherited from IAdapter.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from IActionAdapter.)
Public property | ProcessedMeasurements | Gets the total number of measurements processed thus far by the IAdapter. (Inherited from IAdapter.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from IAdapter.)
Public property | RequestedInputFilter | Gets the input filter requested by the subscriber when establishing this IClientSubscription.
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from IActionAdapter.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from IActionAdapter.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from IActionAdapter.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from IActionAdapter.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from IAdapter.)
Public property | SignalIndexCache | Gets the current signal index cache of this IClientSubscription.
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from IAdapter.)
Public property | SubscriberID | Gets the Guid based subscriber ID of this IClientSubscription.
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Inherited from IAdapter.)
Public property | TemporalSessionStatus | Gets the status of the active temporal session, if any.
Public property | TimestampSize | Gets size of timestamp in bytes.
Public property | UseCompactMeasurementFormat | Gets or sets flag that determines if the compact measurement format should be used in data packets of this IClientSubscription.
Public property | UsePayloadCompression | Gets or sets flag that determines if payload compression should be enabled in data packets of this IClientSubscription.
Top
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.ClientID Property

Grid Solutions Framework IClientSubscriptionClientID Property
Gets the Guid client TCP connection identifier of this IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Guid ClientID { get; }
ReadOnly Property ClientID As Guid
    Get
abstract ClientID : Guid with get

function get_ClientID();

property Guid ClientID {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.CompressionStrength Property

Grid Solutions Framework IClientSubscriptionCompressionStrength Property
Gets or sets the compression strength value to use when UsePayloadCompression is true for this IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int CompressionStrength { get; set; }
Property CompressionStrength As Integer
    Get
    Set
abstract CompressionStrength : int with get, set

function get_CompressionStrength();
function set_CompressionStrength(value);
property int CompressionStrength {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.HostName Property

Grid Solutions Framework IClientSubscriptionHostName Property
Gets or sets host name used to identify connection source of client subscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string HostName { get; set; }
Property HostName As String
    Get
    Set
abstract HostName : string with get, set

function get_HostName();
function set_HostName(value);
property String^ HostName {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.RequestedInputFilter Property

Grid Solutions Framework IClientSubscriptionRequestedInputFilter Property
Gets the input filter requested by the subscriber when establishing this IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string RequestedInputFilter { get; }
ReadOnly Property RequestedInputFilter As String
    Get
abstract RequestedInputFilter : string with get

function get_RequestedInputFilter();

property String^ RequestedInputFilter {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.SignalIndexCache Property

Grid Solutions Framework IClientSubscriptionSignalIndexCache Property
Gets the current signal index cache of this IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
SignalIndexCache SignalIndexCache { get; }
ReadOnly Property SignalIndexCache As SignalIndexCache
    Get
abstract SignalIndexCache : SignalIndexCache with get

function get_SignalIndexCache();

property SignalIndexCache^ SignalIndexCache {
    SignalIndexCache^ get ();
}

Property Value

Type: SignalIndexCache
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.SubscriberID Property

Grid Solutions Framework IClientSubscriptionSubscriberID Property
Gets the Guid based subscriber ID of this IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
Guid SubscriberID { get; }
ReadOnly Property SubscriberID As Guid
    Get
abstract SubscriberID : Guid with get

function get_SubscriberID();

property Guid SubscriberID {
    Guid get ();
}

Property Value

Type: Guid
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.TemporalSessionStatus Property

Grid Solutions Framework IClientSubscriptionTemporalSessionStatus Property
Gets the status of the active temporal session, if any.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
string TemporalSessionStatus { get; }
ReadOnly Property TemporalSessionStatus As String
    Get
abstract TemporalSessionStatus : string with get

function get_TemporalSessionStatus();

property String^ TemporalSessionStatus {
    String^ get ();
}

Property Value

Type: String
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.TimestampSize Property

Grid Solutions Framework IClientSubscriptionTimestampSize Property
Gets size of timestamp in bytes.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
int TimestampSize { get; }
ReadOnly Property TimestampSize As Integer
    Get
abstract TimestampSize : int with get

function get_TimestampSize();

property int TimestampSize {
    int get ();
}

Property Value

Type: Int32
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.UseCompactMeasurementFormat Property

Grid Solutions Framework IClientSubscriptionUseCompactMeasurementFormat Property
Gets or sets flag that determines if the compact measurement format should be used in data packets of this IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool UseCompactMeasurementFormat { get; set; }
Property UseCompactMeasurementFormat As Boolean
    Get
    Set
abstract UseCompactMeasurementFormat : bool with get, set

function get_UseCompactMeasurementFormat();
function set_UseCompactMeasurementFormat(value);
property bool UseCompactMeasurementFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.UsePayloadCompression Property

Grid Solutions Framework IClientSubscriptionUsePayloadCompression Property
Gets or sets flag that determines if payload compression should be enabled in data packets of this IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool UsePayloadCompression { get; set; }
Property UsePayloadCompression As Boolean
    Get
    Set
abstract UsePayloadCompression : bool with get, set

function get_UsePayloadCompression();
function set_UsePayloadCompression(value);
property bool UsePayloadCompression {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription Events

Grid Solutions Framework IClientSubscription Events

The IClientSubscription type exposes the following members.

Events
 | Name | Description
Public event | BufferBlockRetransmission | Indicates that a buffer block needed to be retransmitted because it was previously sent, but no confirmation was received.
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from IAdapter.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from IActionAdapter.)
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from IAdapter.)
Public event | NewMeasurements | Provides new measurements from action adapter. (Inherited from IActionAdapter.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from IAdapter.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from IAdapter.)
Public event | ProcessingComplete | Indicates to the host that processing for an input adapter (via temporal session) has completed.
Public event | StatusMessage | Provides status messages to consumer. (Inherited from IAdapter.)
Public event | UnpublishedSamples | This event is raised every five seconds allowing consumer to track current number of unpublished seconds of data in the queue. (Inherited from IActionAdapter.)
Top
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.BufferBlockRetransmission Event

Grid Solutions Framework IClientSubscriptionBufferBlockRetransmission Event
Indicates that a buffer block needed to be retransmitted because it was previously sent, but no confirmation was received.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler BufferBlockRetransmission
Event BufferBlockRetransmission As EventHandler
abstract BufferBlockRetransmission : IEvent<EventHandler,
    EventArgs>

function add_BufferBlockRetransmission(value);
function remove_BufferBlockRetransmission(value);
 event EventHandler^ BufferBlockRetransmission {
    void add (EventHandler^ value);
    void remove (EventHandler^ value);
}

Value

Type: SystemEventHandler
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscription.ProcessingComplete Event

Grid Solutions Framework IClientSubscriptionProcessingComplete Event
Indicates to the host that processing for an input adapter (via temporal session) has completed.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
event EventHandler<EventArgs<IClientSubscription, EventArgs>> ProcessingComplete
Event ProcessingComplete As EventHandler(Of EventArgs(Of IClientSubscription, EventArgs))
abstract ProcessingComplete : IEvent<EventHandler<EventArgs<IClientSubscription, EventArgs>>,
    EventArgs<IClientSubscription, EventArgs>>

function add_ProcessingComplete(value);
function remove_ProcessingComplete(value);
 event EventHandler<EventArgs<IClientSubscription^, EventArgs^>^>^ ProcessingComplete {
    void add (EventHandler<EventArgs<IClientSubscription^, EventArgs^>^>^ value);
    void remove (EventHandler<EventArgs<IClientSubscription^, EventArgs^>^>^ value);
}

Value

Type: SystemEventHandler EventArgs IClientSubscription, EventArgs
Remarks
This event is expected to only be raised when an input adapter has been designed to process a finite amount of data, e.g., reading a historical range of data during temporal processing.
See Also

Reference

IClientSubscription Interface
GSF.TimeSeries.Transport Namespace


IClientSubscriptionExtensions Class

Grid Solutions Framework IClientSubscriptionExtensions Class
Defines static extension functions for IClientSubscription implementations.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportIClientSubscriptionExtensions

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class IClientSubscriptionExtensions
<ExtensionAttribute>
Public NotInheritable Class IClientSubscriptionExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type IClientSubscriptionExtensions =  class end
GSF.TimeSeries.Transport.IClientSubscriptionExtensions = function();

Type.createClass(
    'GSF.TimeSeries.Transport.IClientSubscriptionExtensions');
[ExtensionAttribute]
public ref class IClientSubscriptionExtensions abstract sealed

The IClientSubscriptionExtensions type exposes the following members.

Methods
Name | Description
CreateTemporalSession | Returns a new temporal IaonSession for a IClientSubscription.
DisposeTemporalSession | Disposes a temporal IaonSession created using CreateTemporalSession(IClientSubscription).
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


IClientSubscriptionExtensions Methods

Grid Solutions Framework IClientSubscriptionExtensions Methods

The IClientSubscriptionExtensions type exposes the following members.

Methods
Name | Description
CreateTemporalSession | Returns a new temporal IaonSession for a IClientSubscription.
DisposeTemporalSession | Disposes a temporal IaonSession created using CreateTemporalSession(IClientSubscription).
Top
See Also

Reference

IClientSubscriptionExtensions Class
GSF.TimeSeries.Transport Namespace


IClientSubscriptionExtensions.CreateTemporalSession Method

Grid Solutions Framework IClientSubscriptionExtensionsCreateTemporalSession Method
Returns a new temporal IaonSession for a IClientSubscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static IaonSession CreateTemporalSession(
    this IClientSubscription clientSubscription
)
<ExtensionAttribute>
Public Shared Function CreateTemporalSession (
    clientSubscription As IClientSubscription
) As IaonSession
static member CreateTemporalSession :
        clientSubscription : IClientSubscription -> IaonSession

GSF.TimeSeries.Transport.IClientSubscriptionExtensions.CreateTemporalSession = function(clientSubscription);
public:
[ExtensionAttribute]
static IaonSession^ CreateTemporalSession(
    IClientSubscription^ clientSubscription
)

Parameters

clientSubscription
Type: GSF.TimeSeries.TransportIClientSubscription
IClientSubscription instance to create temporal IaonSession for.

Return Value

Type: IaonSession
New temporal IaonSession for a IClientSubscription.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IClientSubscription. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IClientSubscriptionExtensions Class
GSF.TimeSeries.Transport Namespace


IClientSubscriptionExtensions.DisposeTemporalSession Method

Grid Solutions Framework IClientSubscriptionExtensionsDisposeTemporalSession Method
Disposes a temporal IaonSession created using CreateTemporalSession(IClientSubscription).

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void DisposeTemporalSession(
    this IClientSubscription adapter,
    ref IaonSession session
)
<ExtensionAttribute>
Public Shared Sub DisposeTemporalSession (
    adapter As IClientSubscription,
    ByRef session As IaonSession
)
static member DisposeTemporalSession :
        adapter : IClientSubscription *
        session : IaonSession byref -> unit

GSF.TimeSeries.Transport.IClientSubscriptionExtensions.DisposeTemporalSession = function(adapter, session);
public:
[ExtensionAttribute]
static void DisposeTemporalSession(
    IClientSubscription^ adapter,
    IaonSession^% session
)

Parameters

adapter
Type: GSF.TimeSeries.TransportIClientSubscription
IClientSubscription source instance.
session
Type: GSF.TimeSeries.AdaptersIaonSession
IaonSession instance to dispose.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type IClientSubscription. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

IClientSubscriptionExtensions Class
GSF.TimeSeries.Transport Namespace


OperationalEncoding Enumeration

Grid Solutions Framework OperationalEncoding Enumeration
Enumeration for character encodings supported by the Gateway Exchange Protocol.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum OperationalEncoding
Public Enumeration OperationalEncoding
type OperationalEncoding
GSF.TimeSeries.Transport.OperationalEncoding = function();
GSF.TimeSeries.Transport.OperationalEncoding.createEnum('GSF.TimeSeries.Transport.OperationalEncoding', false);
public enum class OperationalEncoding
Members
Member name | Value | Description
Unicode | 0 | UTF-16, little endian
BigEndianUnicode | 256 | UTF-16, big endian
UTF8 | 512 | UTF-8
ANSI | 768 | ANSI
See Also

Reference

GSF.TimeSeries.Transport Namespace


OperationalModes Enumeration

Grid Solutions Framework OperationalModes Enumeration
Operational modes that affect how DataPublisher and DataSubscriber communicate.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum OperationalModes
<FlagsAttribute>
Public Enumeration OperationalModes
[<FlagsAttribute>]
type OperationalModes
GSF.TimeSeries.Transport.OperationalModes = function();
GSF.TimeSeries.Transport.OperationalModes.createEnum('GSF.TimeSeries.Transport.OperationalModes', true);
[FlagsAttribute]
public enum class OperationalModes
Members
Member name | Value | Description
VersionMask | 31 | Mask to get version number of protocol.
CompressionModeMask | 224 | Mask to get mode of compression.
EncodingMask | 768 | Mask to get character encoding used when exchanging messages between publisher and subscriber.
UseCommonSerializationFormat | 16777216 | Determines type of serialization to use when exchanging signal index cache and metadata.
ReceiveExternalMetadata | 33554432 | Determines whether external measurements are exchanged during metadata synchronization.
ReceiveInternalMetadata | 67108864 | Determines whether internal measurements are exchanged during metadata synchronization.
CompressPayloadData | 536870912 | Determines whether payload data is compressed when exchanging between publisher and subscriber.
CompressSignalIndexCache | 1073741824 | Determines whether the signal index cache is compressed when exchanging between publisher and subscriber.
CompressMetadata | 2147483648 | Determines whether metadata is compressed when exchanging between publisher and subscriber.
NoFlags | 0 | No flags set.
Remarks
Operational modes are sent from a subscriber to a publisher to request operational behaviors for the connection, as a result the operation modes must be sent before any other command. The publisher may silently refuse some requests (e.g., compression) based on its configuration. Operational modes only apply to fundamental protocol control.
See Also

Reference

GSF.TimeSeries.Transport Namespace


SecurityMode Enumeration

Grid Solutions Framework SecurityMode Enumeration
Security modes used by the DataPublisher to secure data sent over the command channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum SecurityMode
Public Enumeration SecurityMode
type SecurityMode
GSF.TimeSeries.Transport.SecurityMode = function();
GSF.TimeSeries.Transport.SecurityMode.createEnum('GSF.TimeSeries.Transport.SecurityMode', false);
public enum class SecurityMode
Members
Member name | Value | Description
None | 0 | No security.
TLS | 1 | Transport Layer Security.
Gateway | 2 | Pre-shared key.
See Also

Reference

GSF.TimeSeries.Transport Namespace


SerializableMeasurement Class

Grid Solutions Framework SerializableMeasurement Class
Represents a IMeasurement that can be serialized.
Inheritance Hierarchy
SystemObject
GSF.TimeSeriesMeasurement
GSF.TimeSeries.TransportSerializableMeasurement

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SerializableMeasurement : Measurement,
    IBinaryMeasurement, IMeasurement, ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue>,
    IComparable<ITimeSeriesValue>, IComparable, ISupportBinaryImage
Public Class SerializableMeasurement
    Inherits Measurement
    Implements IBinaryMeasurement, IMeasurement, ITimeSeriesValue(Of Double),
    ITimeSeriesValue, IEquatable(Of ITimeSeriesValue), IComparable(Of ITimeSeriesValue),
    IComparable, ISupportBinaryImage
type SerializableMeasurement =
    class
        inherit Measurement
        interface IBinaryMeasurement
        interface IMeasurement
        interface ITimeSeriesValue<float>
        interface ITimeSeriesValue
        interface IEquatable<ITimeSeriesValue>
        interface IComparable<ITimeSeriesValue>
        interface IComparable
        interface ISupportBinaryImage
    end
GSF.TimeSeries.Transport.SerializableMeasurement = function();

Type.createClass(
    'GSF.TimeSeries.Transport.SerializableMeasurement',
    GSF.TimeSeries.Measurement,
    GSF.TimeSeries.Transport.IBinaryMeasurement,
    GSF.TimeSeries.IMeasurement,
    GSF.TimeSeries.ITimeSeriesValue`1,
    GSF.TimeSeries.ITimeSeriesValue,
    IEquatable`1,
    IComparable`1,
    IComparable,
    GSF.Parsing.ISupportBinaryImage);
public ref class SerializableMeasurement : public Measurement,
    IBinaryMeasurement, IMeasurement, ITimeSeriesValue<double>, ITimeSeriesValue, IEquatable<ITimeSeriesValue^>,
    IComparable<ITimeSeriesValue^>, IComparable, ISupportBinaryImage

The SerializableMeasurement type exposes the following members.

Constructors
 | Name | Description
Public method | SerializableMeasurement(Encoding) | Creates a new SerializableMeasurement.
Public method | SerializableMeasurement(IMeasurement, Encoding) | Creates a new SerializableMeasurement from an existing IMeasurement value.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the SerializableMeasurement and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes SerializableMeasurement from the specified binary image.
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
Fields
Name | Description
FixedLength | Fixed byte length of a SerializableMeasurement.
Top
Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | BinaryLength | Gets the length of the SerializableMeasurement.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
Remarks
This measurement implementation is serialized through ISupportBinaryImage to allow complete control of binary format. All measurement properties are serialized at their full resolution and no attempt is made to optimize the binary image for purposes of size reduction.
See Also

Reference

GSF.TimeSeries.Transport Namespace


SerializableMeasurement Constructor

Grid Solutions Framework SerializableMeasurement Constructor
Overload List
 | Name | Description
Public method | SerializableMeasurement(Encoding) | Creates a new SerializableMeasurement.
Public method | SerializableMeasurement(IMeasurement, Encoding) | Creates a new SerializableMeasurement from an existing IMeasurement value.
Top
See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


SerializableMeasurement Constructor (Encoding)

Grid Solutions Framework SerializableMeasurement Constructor (Encoding)
Creates a new SerializableMeasurement.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMeasurement(
    Encoding encoding
)
Public Sub New (
    encoding As Encoding
)
new :
        encoding : Encoding -> SerializableMeasurement
GSF.TimeSeries.Transport.SerializableMeasurement = function(encoding);
public:
SerializableMeasurement(
    Encoding^ encoding
)

Parameters

encoding
Type: System.TextEncoding
Character encoding used to convert strings to binary.
See Also

Reference

SerializableMeasurement Class
SerializableMeasurement Overload
GSF.TimeSeries.Transport Namespace


SerializableMeasurement Constructor (IMeasurement, Encoding)

Grid Solutions Framework SerializableMeasurement Constructor (IMeasurement, Encoding)
Creates a new SerializableMeasurement from an existing IMeasurement value.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SerializableMeasurement(
    IMeasurement measurement,
    Encoding encoding
)
Public Sub New (
    measurement As IMeasurement,
    encoding As Encoding
)
new :
        measurement : IMeasurement *
        encoding : Encoding -> SerializableMeasurement
GSF.TimeSeries.Transport.SerializableMeasurement = function(measurement, encoding);
public:
SerializableMeasurement(
    IMeasurement^ measurement,
    Encoding^ encoding
)

Parameters

measurement
Type: GSF.TimeSeriesIMeasurement
Source IMeasurement value.
encoding
Type: System.TextEncoding
Character encoding used to convert strings to binary.
See Also

Reference

SerializableMeasurement Class
SerializableMeasurement Overload
GSF.TimeSeries.Transport Namespace


SerializableMeasurement Fields

Grid Solutions Framework SerializableMeasurement Fields

The SerializableMeasurement type exposes the following members.

Fields
Name | Description
FixedLength | Fixed byte length of a SerializableMeasurement.
Top
See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


SerializableMeasurement.FixedLength Field

Grid Solutions Framework SerializableMeasurementFixedLength Field
Fixed byte length of a SerializableMeasurement.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int FixedLength
Public Const FixedLength As Integer
static val mutable FixedLength: int
var GSF.TimeSeries.Transport.SerializableMeasurement.FixedLength
public:
literal int FixedLength

Field Value

Type: Int32
See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


SerializableMeasurement Methods

Grid Solutions Framework SerializableMeasurement Methods

The SerializableMeasurement type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the Measurement with the specified Object. (Inherited from Measurement.)
Public method | CompareTo(ITimeSeriesValue) | Compares the Measurement with an ITimeSeriesValue. (Inherited from Measurement.)
Public method | Equals(Object) | Determines whether the specified Object is equal to the current Measurement. (Inherited from Measurement.)
Public method | Equals(ITimeSeriesValue) | Determines whether the specified ITimeSeriesValue is equal to the current Measurement. (Inherited from Measurement.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the SerializableMeasurement and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for the current Measurement. (Inherited from Measurement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes SerializableMeasurement from the specified binary image.
Public method | ToString | Returns a String that represents the current Measurement. (Inherited from Measurement.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetSignalType | Gets a unique (run-time only) signal type ID for the given measurement useful for sorting. (Defined by IMeasurementExtensions.)
Public Extension Method | HistorianQuality | Gets a Quality value from a IMeasurement value. (Defined by QualityExtensions.)
Public Extension Method | IsCalculated | Returns true if CalcuatedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | IsDiscarded | Returns true if DiscardedValue is set. (Defined by IMeasurementExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | RuntimeSignalID | Returns the measurement ID if defined, otherwise the run-time signal ID associated with the measurement key. (Defined by IMeasurementExtensions.)
Public Extension Method | TimestampQualityIsGood | Returns true if BadTime is not set. (Defined by IMeasurementExtensions.)
Public Extension Method | ValueQualityIsGood | Returns true if BadData is not set. (Defined by IMeasurementExtensions.)
Top
See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


SerializableMeasurement.GenerateBinaryImage Method

Grid Solutions Framework SerializableMeasurementGenerateBinaryImage Method
Generates binary image of the SerializableMeasurement and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
Exceptions
Exception | Condition
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or BinaryLength is less than 0 -or- startIndex and BinaryLength will exceed buffer length.
Remarks

Field: Bytes:
--------- ---------
Key ID 4
SourceLen 4
Source SourceLen
Signal ID 16
TagLen 4
Tag TagLen
Value 8
Adder 8
Multiplier 8
Ticks 8
Flags 4

Constant Length = 64
Variable Length = SourceLen + TagLen

See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


SerializableMeasurement.ParseBinaryImage Method

Grid Solutions Framework SerializableMeasurementParseBinaryImage Method
Initializes SerializableMeasurement from the specified binary image.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
Exceptions
Exception | Condition
InvalidOperationException | Not enough buffer available to deserialize measurement.
ArgumentNullException | buffer is null.
ArgumentOutOfRangeException | startIndex or length is less than 0 -or- startIndex and length will exceed buffer length.
See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


SerializableMeasurement Properties

Grid Solutions Framework SerializableMeasurement Properties

The SerializableMeasurement type exposes the following members.

Properties
 | Name | Description
Public property | Adder | Gets or sets an offset to add to the measurement value. This defaults to 0.0. (Inherited from Measurement.)
Public property | AdjustedValue | Gets the adjusted numeric value of this measurement, taking into account the specified Adder and Multiplier offsets. (Inherited from Measurement.)
Public property | BinaryLength | Gets the length of the SerializableMeasurement.
Public property | ID | Gets or sets the Guid based signal ID of this Measurement, if available. (Inherited from Measurement.)
Public property | Key | Gets or sets the primary MeasurementKey of this Measurement. (Inherited from Measurement.)
Public property | MeasurementValueFilter | Gets or sets function used to apply a down-sampling filter over a sequence of IMeasurement values. (Inherited from Measurement.)
Public property | Multiplier | Defines a multiplicative offset to apply to the measurement value. This defaults to 1.0. (Inherited from Measurement.)
Public property | PublishedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was published (post-processing). (Inherited from Measurement.)
Public property | ReceivedTimestamp | Gets or sets exact timestamp, in ticks, of when this Measurement was received (i.e., created). (Inherited from Measurement.)
Public property | StateFlags | Gets or sets MeasurementStateFlags associated with this Measurement. (Inherited from Measurement.)
Public property | TagName | Gets or sets the text based tag name of this Measurement. (Inherited from Measurement.)
Public property | Timestamp | Gets or sets exact timestamp, in ticks, of the data represented by this Measurement. (Inherited from Measurement.)
Public property | Value | Gets or sets the raw measurement value that is not offset by Adder and Multiplier. (Inherited from Measurement.)
Top
See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


SerializableMeasurement.BinaryLength Property

Grid Solutions Framework SerializableMeasurementBinaryLength Property
Gets the length of the SerializableMeasurement.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

SerializableMeasurement Class
GSF.TimeSeries.Transport Namespace


ServerCommand Enumeration

Grid Solutions Framework ServerCommand Enumeration
Server commands received by DataPublisher and sent by DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ServerCommand
Public Enumeration ServerCommand
type ServerCommand
GSF.TimeSeries.Transport.ServerCommand = function();
GSF.TimeSeries.Transport.ServerCommand.createEnum('GSF.TimeSeries.Transport.ServerCommand', false);
public enum class ServerCommand
Members
Member name | Value | Description
Authenticate | 0 | Authenticate command.
MetaDataRefresh | 1 | Meta data refresh command.
Subscribe | 2 | Subscribe command.
Unsubscribe | 3 | Unsubscribe command.
RotateCipherKeys | 4 | Rotate cipher keys.
UpdateProcessingInterval | 5 | Update processing interval.
DefineOperationalModes | 6 | Define operational modes for subscriber connection.
ConfirmNotification | 7 | Confirm receipt of a notification.
ConfirmBufferBlock | 8 | Confirm receipt of a buffer block measurement.
Remarks
Solicited server commands will receive a Succeeded or Failed response code along with an associated success or failure message. Message type for successful responses will be based on server command - for example, server response for a successful MetaDataRefresh command will return a serialized DataSet of the available server metadata. Message type for failed responses will always be a string of text representing the error message.
See Also

Reference

GSF.TimeSeries.Transport Namespace


ServerResponse Enumeration

Grid Solutions Framework ServerResponse Enumeration
Server responses sent by DataPublisher and received by DataSubscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ServerResponse
Public Enumeration ServerResponse
type ServerResponse
GSF.TimeSeries.Transport.ServerResponse = function();
GSF.TimeSeries.Transport.ServerResponse.createEnum('GSF.TimeSeries.Transport.ServerResponse', false);
public enum class ServerResponse
Members
Member name | Value | Description
Succeeded | 128 | Command succeeded response.
Failed | 129 | Command failed response.
DataPacket | 130 | Data packet response.
UpdateSignalIndexCache | 131 | Update signal index cache response.
UpdateBaseTimes | 132 | Update runtime base-timestamp offsets response.
UpdateCipherKeys | 133 | Update runtime cipher keys response.
DataStartTime | 134 | Data start time response packet.
ProcessingComplete | 135 | Processing complete notification.
BufferBlock | 136 | Buffer block response.
Notify | 137 | Notify response.
ConfigurationChanged | 138 | Configuration changed response.
NoOP | 255 | No operation keep-alive ping.
See Also

Reference

GSF.TimeSeries.Transport Namespace


SignalIndexCache Class

Grid Solutions Framework SignalIndexCache Class
Represents a serializable Guid signal ID to UInt16 index cross reference.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportSignalIndexCache

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public class SignalIndexCache : ISupportBinaryImage
<SerializableAttribute>
Public Class SignalIndexCache
    Implements ISupportBinaryImage
[<SerializableAttribute>]
type SignalIndexCache =
    class
        interface ISupportBinaryImage
    end
GSF.TimeSeries.Transport.SignalIndexCache = function();

Type.createClass(
    'GSF.TimeSeries.Transport.SignalIndexCache',
    null,
    GSF.Parsing.ISupportBinaryImage);
[SerializableAttribute]
public ref class SignalIndexCache : ISupportBinaryImage

The SignalIndexCache type exposes the following members.

Constructors
 | Name | Description
Public method | SignalIndexCache | Creates a new SignalIndexCache instance.
Public method | SignalIndexCache(DataSet, SignalIndexCache) | Creates a new local system cache from one that was received remotely.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the SignalIndexCache and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSignalIndex | Gets runtime signal index for given Guid signal ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the SignalIndexCache by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
Properties
 | Name | Description
Public property | AuthorizedSignalIDs | Gets reference to array of requested input measurement signal IDs that were authorized.
Public property | BinaryLength | Gets the length of the binary image.
Public property | Encoding | Gets or sets character encoding used to convert strings to binary.
Public property | MaximumIndex | Gets the current maximum integer signal index.
Public property | Reference | Gets or sets integer signal index cross reference dictionary.
Public property | SubscriberID | Gets or sets the Guid based subscriber ID of this SignalIndexCache.
Public property | UnauthorizedSignalIDs | Gets or sets reference to array of requested input measurement signal IDs that were unauthorized.
Top
Remarks
This class is used to create a runtime index to be used for data exchange so that a 16-bit integer is exchanged in the data packets for signal identification instead of the 128-bit Guid signal ID to reduce bandwidth required for signal exchange. This means the total number of unique signal IDs that could be exchanged using this method in a single session is 65,535. This number seems reasonable for the currently envisioned use cases, however, multiple sessions each with their own runtime signal index cache could be established if this is a limitation for a given data set.
See Also

Reference

GSF.TimeSeries.Transport Namespace


SignalIndexCache Constructor

Grid Solutions Framework SignalIndexCache Constructor
Overload List
 | Name | Description
Public method | SignalIndexCache | Creates a new SignalIndexCache instance.
Public method | SignalIndexCache(DataSet, SignalIndexCache) | Creates a new local system cache from one that was received remotely.
Top
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache Constructor

Grid Solutions Framework SignalIndexCache Constructor
Creates a new SignalIndexCache instance.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SignalIndexCache()
Public Sub New
new : unit -> SignalIndexCache
GSF.TimeSeries.Transport.SignalIndexCache = function();
public:
SignalIndexCache()
See Also

Reference

SignalIndexCache Class
SignalIndexCache Overload
GSF.TimeSeries.Transport Namespace


SignalIndexCache Constructor (DataSet, SignalIndexCache)

Grid Solutions Framework SignalIndexCache Constructor (DataSet, SignalIndexCache)
Creates a new local system cache from one that was received remotely.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SignalIndexCache(
    DataSet dataSource,
    SignalIndexCache remoteCache
)
Public Sub New (
    dataSource As DataSet,
    remoteCache As SignalIndexCache
)
new :
        dataSource : DataSet *
        remoteCache : SignalIndexCache -> SignalIndexCache
GSF.TimeSeries.Transport.SignalIndexCache = function(dataSource, remoteCache);
public:
SignalIndexCache(
    DataSet^ dataSource,
    SignalIndexCache^ remoteCache
)

Parameters

dataSource
Type: System.DataDataSet
DataSet based data source used to interpret local measurement keys.
remoteCache
Type: GSF.TimeSeries.TransportSignalIndexCache
Deserialized remote signal index cache.
See Also

Reference

SignalIndexCache Class
SignalIndexCache Overload
GSF.TimeSeries.Transport Namespace


SignalIndexCache Methods

Grid Solutions Framework SignalIndexCache Methods

The SignalIndexCache type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GenerateBinaryImage | Generates binary image of the SignalIndexCache and copies it into the given buffer, for BinaryLength bytes.
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetSignalIndex | Gets runtime signal index for given Guid signal ID.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ParseBinaryImage | Initializes the SignalIndexCache by parsing the specified buffer containing a binary image.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BinaryImage | Returns a binary image of an object that implements ISupportBinaryImage. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyBinaryImageToStream | Copies binary image of object that implements ISupportBinaryImage to a Stream. (Defined by ISupportBinaryImageExtensions.)
Public Extension Method | CopyImage | This is a common optimized block copy function for any kind of data. (Defined by Common.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | ParseBinaryImageFromStream | Parses binary image of object that implements ISupportBinaryImage from a Stream. (Defined by ISupportBinaryImageExtensions.)
Top
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.GenerateBinaryImage Method

Grid Solutions Framework SignalIndexCacheGenerateBinaryImage Method
Generates binary image of the SignalIndexCache and copies it into the given buffer, for BinaryLength bytes.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int GenerateBinaryImage(
    byte[] buffer,
    int startIndex
)
Public Function GenerateBinaryImage (
    buffer As Byte(),
    startIndex As Integer
) As Integer
abstract GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
override GenerateBinaryImage :
        buffer : byte[] *
        startIndex : int -> int
function GenerateBinaryImage(buffer, startIndex);
public:
virtual int GenerateBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex
) sealed

Parameters

buffer
Type: SystemByte
Buffer used to hold generated binary image of the source object.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start writing.

Return Value

Type: Int32
The number of bytes written to the buffer.

Implements

ISupportBinaryImageGenerateBinaryImage(Byte, Int32)
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.GetSignalIndex Method

Grid Solutions Framework SignalIndexCacheGetSignalIndex Method
Gets runtime signal index for given Guid signal ID.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort GetSignalIndex(
    Guid signalID
)
Public Function GetSignalIndex (
    signalID As Guid
) As UShort
member GetSignalIndex :
        signalID : Guid -> uint16

function GetSignalIndex(signalID);
public:
unsigned short GetSignalIndex(
    Guid signalID
)

Parameters

signalID
Type: SystemGuid
Guid signal ID used to lookup associated runtime signal index.

Return Value

Type: UInt16
Runtime signal index for given Guid signalID.
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.ParseBinaryImage Method

Grid Solutions Framework SignalIndexCacheParseBinaryImage Method
Initializes the SignalIndexCache by parsing the specified buffer containing a binary image.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int ParseBinaryImage(
    byte[] buffer,
    int startIndex,
    int length
)
Public Function ParseBinaryImage (
    buffer As Byte(),
    startIndex As Integer,
    length As Integer
) As Integer
abstract ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
override ParseBinaryImage :
        buffer : byte[] *
        startIndex : int *
        length : int -> int
function ParseBinaryImage(buffer, startIndex, length);
public:
virtual int ParseBinaryImage(
    array<unsigned char>^ buffer,
    int startIndex,
    int length
) sealed

Parameters

buffer
Type: SystemByte
Buffer containing binary image to parse.
startIndex
Type: SystemInt32
0-based starting index in the buffer to start parsing.
length
Type: SystemInt32
Valid number of bytes within buffer to read from startIndex.

Return Value

Type: Int32
The number of bytes used for initialization in the buffer (i.e., the number of bytes parsed).

Implements

ISupportBinaryImageParseBinaryImage(Byte, Int32, Int32)
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache Properties

Grid Solutions Framework SignalIndexCache Properties

The SignalIndexCache type exposes the following members.

Properties
 | Name | Description
Public property | AuthorizedSignalIDs | Gets reference to array of requested input measurement signal IDs that were authorized.
Public property | BinaryLength | Gets the length of the binary image.
Public property | Encoding | Gets or sets character encoding used to convert strings to binary.
Public property | MaximumIndex | Gets the current maximum integer signal index.
Public property | Reference | Gets or sets integer signal index cross reference dictionary.
Public property | SubscriberID | Gets or sets the Guid based subscriber ID of this SignalIndexCache.
Public property | UnauthorizedSignalIDs | Gets or sets reference to array of requested input measurement signal IDs that were unauthorized.
Top
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.AuthorizedSignalIDs Property

Grid Solutions Framework SignalIndexCacheAuthorizedSignalIDs Property
Gets reference to array of requested input measurement signal IDs that were authorized.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid[] AuthorizedSignalIDs { get; }
Public ReadOnly Property AuthorizedSignalIDs As Guid()
    Get
member AuthorizedSignalIDs : Guid[] with get

function get_AuthorizedSignalIDs();

public:
property array<Guid>^ AuthorizedSignalIDs {
    array<Guid>^ get ();
}

Property Value

Type: Guid
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.BinaryLength Property

Grid Solutions Framework SignalIndexCacheBinaryLength Property
Gets the length of the binary image.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int BinaryLength { get; }
Public ReadOnly Property BinaryLength As Integer
    Get
abstract BinaryLength : int with get
override BinaryLength : int with get
function get_BinaryLength();

public:
virtual property int BinaryLength {
    int get () sealed;
}

Property Value

Type: Int32

Implements

ISupportBinaryImageBinaryLength
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.Encoding Property

Grid Solutions Framework SignalIndexCacheEncoding Property
Gets or sets character encoding used to convert strings to binary.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Encoding Encoding { get; set; }
Public Property Encoding As Encoding
    Get
    Set
member Encoding : Encoding with get, set

function get_Encoding();
function set_Encoding(value);
public:
property Encoding^ Encoding {
    Encoding^ get ();
    void set (Encoding^ value);
}

Property Value

Type: Encoding
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.MaximumIndex Property

Grid Solutions Framework SignalIndexCacheMaximumIndex Property
Gets the current maximum integer signal index.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ushort MaximumIndex { get; }
Public ReadOnly Property MaximumIndex As UShort
    Get
member MaximumIndex : uint16 with get

function get_MaximumIndex();

public:
property unsigned short MaximumIndex {
    unsigned short get ();
}

Property Value

Type: UInt16
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.Reference Property

Grid Solutions Framework SignalIndexCacheReference Property
Gets or sets integer signal index cross reference dictionary.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ConcurrentDictionary<ushort, Tuple<Guid, string, uint>> Reference { get; set; }
Public Property Reference As ConcurrentDictionary(Of UShort, Tuple(Of Guid, String, UInteger))
    Get
    Set
member Reference : ConcurrentDictionary<uint16, Tuple<Guid, string, uint32>> with get, set

function get_Reference();
function set_Reference(value);
public:
property ConcurrentDictionary<unsigned short, Tuple<Guid, String^, unsigned int>^>^ Reference {
    ConcurrentDictionary<unsigned short, Tuple<Guid, String^, unsigned int>^>^ get ();
    void set (ConcurrentDictionary<unsigned short, Tuple<Guid, String^, unsigned int>^>^ value);
}

Property Value

Type: ConcurrentDictionary UInt16, Tuple Guid, String, UInt32
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.SubscriberID Property

Grid Solutions Framework SignalIndexCacheSubscriberID Property
Gets or sets the Guid based subscriber ID of this SignalIndexCache.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid SubscriberID { get; set; }
Public Property SubscriberID As Guid
    Get
    Set
member SubscriberID : Guid with get, set

function get_SubscriberID();
function set_SubscriberID(value);
public:
property Guid SubscriberID {
    Guid get ();
    void set (Guid value);
}

Property Value

Type: Guid
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SignalIndexCache.UnauthorizedSignalIDs Property

Grid Solutions Framework SignalIndexCacheUnauthorizedSignalIDs Property
Gets or sets reference to array of requested input measurement signal IDs that were unauthorized.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Guid[] UnauthorizedSignalIDs { get; set; }
Public Property UnauthorizedSignalIDs As Guid()
    Get
    Set
member UnauthorizedSignalIDs : Guid[] with get, set

function get_UnauthorizedSignalIDs();
function set_UnauthorizedSignalIDs(value);
public:
property array<Guid>^ UnauthorizedSignalIDs {
    array<Guid>^ get ();
    void set (array<Guid>^ value);
}

Property Value

Type: Guid
See Also

Reference

SignalIndexCache Class
GSF.TimeSeries.Transport Namespace


SourceDevice Class

Grid Solutions Framework SourceDevice Class
Represents a device which acts as a source for measurements provided to a DataSubscriber.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportSourceDevice

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SourceDevice : IDevice
Public Class SourceDevice
    Implements IDevice
type SourceDevice =
    class
        interface IDevice
    end
GSF.TimeSeries.Transport.SourceDevice = function();

Type.createClass(
    'GSF.TimeSeries.Transport.SourceDevice',
    null,
    GSF.TimeSeries.IDevice);
public ref class SourceDevice : IDevice

The SourceDevice type exposes the following members.

Constructors
 | Name | Description
Public method | SourceDevice | Initializes a new instance of the SourceDevice class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | DataQualityErrors | Gets or sets total data quality errors of this SourceDevice.
Public property | DeviceErrors | Gets or sets total device errors of this SourceDevice.
Public property | MeasurementsExpected | Gets or sets total measurements expected to have been received for this SourceDevice.
Public property | MeasurementsReceived | Gets or sets total measurements received for this SourceDevice.
Public property | TimeQualityErrors | Gets or sets total time quality errors of this SourceDevice.
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


SourceDevice Constructor

Grid Solutions Framework SourceDevice Constructor
Initializes a new instance of the SourceDevice class

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SourceDevice()
Public Sub New
new : unit -> SourceDevice
GSF.TimeSeries.Transport.SourceDevice = function();
public:
SourceDevice()
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SourceDevice Methods

Grid Solutions Framework SourceDevice Methods

The SourceDevice type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SourceDevice Properties

Grid Solutions Framework SourceDevice Properties

The SourceDevice type exposes the following members.

Properties
 | Name | Description
Public property | DataQualityErrors | Gets or sets total data quality errors of this SourceDevice.
Public property | DeviceErrors | Gets or sets total device errors of this SourceDevice.
Public property | MeasurementsExpected | Gets or sets total measurements expected to have been received for this SourceDevice.
Public property | MeasurementsReceived | Gets or sets total measurements received for this SourceDevice.
Public property | TimeQualityErrors | Gets or sets total time quality errors of this SourceDevice.
Top
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SourceDevice.DataQualityErrors Property

Grid Solutions Framework SourceDeviceDataQualityErrors Property
Gets or sets total data quality errors of this SourceDevice.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long DataQualityErrors { get; set; }
Public Property DataQualityErrors As Long
    Get
    Set
abstract DataQualityErrors : int64 with get, set
override DataQualityErrors : int64 with get, set
function get_DataQualityErrors();
function set_DataQualityErrors(value);
public:
virtual property long long DataQualityErrors {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceDataQualityErrors
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SourceDevice.DeviceErrors Property

Grid Solutions Framework SourceDeviceDeviceErrors Property
Gets or sets total device errors of this SourceDevice.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long DeviceErrors { get; set; }
Public Property DeviceErrors As Long
    Get
    Set
abstract DeviceErrors : int64 with get, set
override DeviceErrors : int64 with get, set
function get_DeviceErrors();
function set_DeviceErrors(value);
public:
virtual property long long DeviceErrors {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceDeviceErrors
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SourceDevice.MeasurementsExpected Property

Grid Solutions Framework SourceDeviceMeasurementsExpected Property
Gets or sets total measurements expected to have been received for this SourceDevice.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MeasurementsExpected { get; set; }
Public Property MeasurementsExpected As Long
    Get
    Set
abstract MeasurementsExpected : int64 with get, set
override MeasurementsExpected : int64 with get, set
function get_MeasurementsExpected();
function set_MeasurementsExpected(value);
public:
virtual property long long MeasurementsExpected {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceMeasurementsExpected
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SourceDevice.MeasurementsReceived Property

Grid Solutions Framework SourceDeviceMeasurementsReceived Property
Gets or sets total measurements received for this SourceDevice.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long MeasurementsReceived { get; set; }
Public Property MeasurementsReceived As Long
    Get
    Set
abstract MeasurementsReceived : int64 with get, set
override MeasurementsReceived : int64 with get, set
function get_MeasurementsReceived();
function set_MeasurementsReceived(value);
public:
virtual property long long MeasurementsReceived {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceMeasurementsReceived
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SourceDevice.TimeQualityErrors Property

Grid Solutions Framework SourceDeviceTimeQualityErrors Property
Gets or sets total time quality errors of this SourceDevice.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TimeQualityErrors { get; set; }
Public Property TimeQualityErrors As Long
    Get
    Set
abstract TimeQualityErrors : int64 with get, set
override TimeQualityErrors : int64 with get, set
function get_TimeQualityErrors();
function set_TimeQualityErrors(value);
public:
virtual property long long TimeQualityErrors {
    long long get () sealed;
    void set (long long value) sealed;
}

Property Value

Type: Int64

Implements

IDeviceTimeQualityErrors
See Also

Reference

SourceDevice Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo Class

Grid Solutions Framework SubscriptionInfo Class
Configuration object for data subscriptions.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportSubscriptionInfo
GSF.TimeSeries.TransportSynchronizedSubscriptionInfo
GSF.TimeSeries.TransportUnsynchronizedSubscriptionInfo

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public abstract class SubscriptionInfo
Public MustInherit Class SubscriptionInfo
[<AbstractClassAttribute>]
type SubscriptionInfo =  class end
GSF.TimeSeries.Transport.SubscriptionInfo = function();

Type.createClass(
    'GSF.TimeSeries.Transport.SubscriptionInfo');
public ref class SubscriptionInfo abstract

The SubscriptionInfo type exposes the following members.

Constructors
 | Name | Description
Protected method | SubscriptionInfo | Creates a new instance of the SubscriptionInfo class.
Top
Methods
 | Name | Description
Public method | Copy | Creates a shallow copy of this SubscriptionInfo object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConstraintParameters | Gets or sets the additional constraint parameters supplied to temporal adapters in a temporal session.
Public property | DataChannelLocalPort | Gets or sets the port number that the UDP data channel binds to. This value is only used when the subscriber requests a separate UDP data channel.
Public property | ExtraConnectionStringParameters | Gets or sets the additional connection string parameters to be applied to the connection string sent to the publisher during subscription.
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested by the subscriber.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance in seconds (can be sub-second).
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | ProcessingInterval | Gets or sets the processing interval requested by the subscriber. A value of -1 indicates the default processing interval. A value of 0 indicates data will be processed as fast as possible.
Public property | RequestNaNValueFilter | Gets or sets the flag that determines whether to request that measurements sent to the subscriber should be filtered by the publisher prior to sending them.
Public property | StartTime | Gets or sets the start time of the requested temporal session for streaming historic data.
Public property | StopTime | Gets or sets the stop time of the requested temporal session for streaming historic data.
Public property | UdpDataChannel | Gets or sets the flag that determines whether the subscriber is requesting its data over a separate UDP data channel.
Public property | UseCompactMeasurementFormat | Gets or sets the flag that determines whether to use the compact measurement format or the full measurement format for transmitting measurements to the subscriber.
Public property | UseLocalClockAsRealTime | Gets or sets the flag that determines whether the server's local clock is used as real-time. If false, the timestamps of the measurements will be used as real-time.
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, they will use Ticks resolution.
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


SubscriptionInfo Constructor

Grid Solutions Framework SubscriptionInfo Constructor
Creates a new instance of the SubscriptionInfo class.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected SubscriptionInfo()
Protected Sub New
new : unit -> SubscriptionInfo
GSF.TimeSeries.Transport.SubscriptionInfo = function();
protected:
SubscriptionInfo()
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo Methods

Grid Solutions Framework SubscriptionInfo Methods

The SubscriptionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Creates a shallow copy of this SubscriptionInfo object.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.Copy Method

Grid Solutions Framework SubscriptionInfoCopy Method
Creates a shallow copy of this SubscriptionInfo object.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual SubscriptionInfo Copy()
Public Overridable Function Copy As SubscriptionInfo
abstract Copy : unit -> SubscriptionInfo
override Copy : unit -> SubscriptionInfo
function Copy();
public:
virtual SubscriptionInfo^ Copy()

Return Value

Type: SubscriptionInfo
The copy of this object.
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo Properties

Grid Solutions Framework SubscriptionInfo Properties

The SubscriptionInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConstraintParameters | Gets or sets the additional constraint parameters supplied to temporal adapters in a temporal session.
Public property | DataChannelLocalPort | Gets or sets the port number that the UDP data channel binds to. This value is only used when the subscriber requests a separate UDP data channel.
Public property | ExtraConnectionStringParameters | Gets or sets the additional connection string parameters to be applied to the connection string sent to the publisher during subscription.
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested by the subscriber.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance in seconds (can be sub-second).
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).
Public property | ProcessingInterval | Gets or sets the processing interval requested by the subscriber. A value of -1 indicates the default processing interval. A value of 0 indicates data will be processed as fast as possible.
Public property | RequestNaNValueFilter | Gets or sets the flag that determines whether to request that measurements sent to the subscriber should be filtered by the publisher prior to sending them.
Public property | StartTime | Gets or sets the start time of the requested temporal session for streaming historic data.
Public property | StopTime | Gets or sets the stop time of the requested temporal session for streaming historic data.
Public property | UdpDataChannel | Gets or sets the flag that determines whether the subscriber is requesting its data over a separate UDP data channel.
Public property | UseCompactMeasurementFormat | Gets or sets the flag that determines whether to use the compact measurement format or the full measurement format for transmitting measurements to the subscriber.
Public property | UseLocalClockAsRealTime | Gets or sets the flag that determines whether the server's local clock is used as real-time. If false, the timestamps of the measurements will be used as real-time.
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, they will use Ticks resolution.
Top
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.ConstraintParameters Property

Grid Solutions Framework SubscriptionInfoConstraintParameters Property
Gets or sets the additional constraint parameters supplied to temporal adapters in a temporal session.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ConstraintParameters { get; set; }
Public Overridable Property ConstraintParameters As String
    Get
    Set
abstract ConstraintParameters : string with get, set
override ConstraintParameters : string with get, set
function get_ConstraintParameters();
function set_ConstraintParameters(value);
public:
virtual property String^ ConstraintParameters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.DataChannelLocalPort Property

Grid Solutions Framework SubscriptionInfoDataChannelLocalPort Property
Gets or sets the port number that the UDP data channel binds to. This value is only used when the subscriber requests a separate UDP data channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int DataChannelLocalPort { get; set; }
Public Overridable Property DataChannelLocalPort As Integer
    Get
    Set
abstract DataChannelLocalPort : int with get, set
override DataChannelLocalPort : int with get, set
function get_DataChannelLocalPort();
function set_DataChannelLocalPort(value);
public:
virtual property int DataChannelLocalPort {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.ExtraConnectionStringParameters Property

Grid Solutions Framework SubscriptionInfoExtraConnectionStringParameters Property
Gets or sets the additional connection string parameters to be applied to the connection string sent to the publisher during subscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string ExtraConnectionStringParameters { get; set; }
Public Overridable Property ExtraConnectionStringParameters As String
    Get
    Set
abstract ExtraConnectionStringParameters : string with get, set
override ExtraConnectionStringParameters : string with get, set
function get_ExtraConnectionStringParameters();
function set_ExtraConnectionStringParameters(value);
public:
virtual property String^ ExtraConnectionStringParameters {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.FilterExpression Property

Grid Solutions Framework SubscriptionInfoFilterExpression Property
Gets or sets the filter expression used to define which measurements are being requested by the subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string FilterExpression { get; set; }
Public Overridable Property FilterExpression As String
    Get
    Set
abstract FilterExpression : string with get, set
override FilterExpression : string with get, set
function get_FilterExpression();
function set_FilterExpression(value);
public:
virtual property String^ FilterExpression {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.LagTime Property

Grid Solutions Framework SubscriptionInfoLagTime Property
Gets or sets the allowed past time deviation tolerance in seconds (can be sub-second).

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double LagTime { get; set; }
Public Overridable Property LagTime As Double
    Get
    Set
abstract LagTime : float with get, set
override LagTime : float with get, set
function get_LagTime();
function set_LagTime(value);
public:
virtual property double LagTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.LeadTime Property

Grid Solutions Framework SubscriptionInfoLeadTime Property
Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second).

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual double LeadTime { get; set; }
Public Overridable Property LeadTime As Double
    Get
    Set
abstract LeadTime : float with get, set
override LeadTime : float with get, set
function get_LeadTime();
function set_LeadTime(value);
public:
virtual property double LeadTime {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.ProcessingInterval Property

Grid Solutions Framework SubscriptionInfoProcessingInterval Property
Gets or sets the processing interval requested by the subscriber. A value of -1 indicates the default processing interval. A value of 0 indicates data will be processed as fast as possible.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual int ProcessingInterval { get; set; }
Public Overridable Property ProcessingInterval As Integer
    Get
    Set
abstract ProcessingInterval : int with get, set
override ProcessingInterval : int with get, set
function get_ProcessingInterval();
function set_ProcessingInterval(value);
public:
virtual property int ProcessingInterval {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
Remarks
With the exception of the values of -1 and 0, the ProcessingInterval value specifies the desired historical playback data processing interval in milliseconds. This is basically a delay, or timer interval, over which to process data. Setting this value to -1 means to use the default processing interval while setting the value to 0 means to process data as fast as possible.
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.RequestNaNValueFilter Property

Grid Solutions Framework SubscriptionInfoRequestNaNValueFilter Property
Gets or sets the flag that determines whether to request that measurements sent to the subscriber should be filtered by the publisher prior to sending them.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool RequestNaNValueFilter { get; set; }
Public Overridable Property RequestNaNValueFilter As Boolean
    Get
    Set
abstract RequestNaNValueFilter : bool with get, set
override RequestNaNValueFilter : bool with get, set
function get_RequestNaNValueFilter();
function set_RequestNaNValueFilter(value);
public:
virtual property bool RequestNaNValueFilter {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.StartTime Property

Grid Solutions Framework SubscriptionInfoStartTime Property
Gets or sets the start time of the requested temporal session for streaming historic data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string StartTime { get; set; }
Public Overridable Property StartTime As String
    Get
    Set
abstract StartTime : string with get, set
override StartTime : string with get, set
function get_StartTime();
function set_StartTime(value);
public:
virtual property String^ StartTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

When the StartTime or StopTime temporal processing constraints are defined (i.e., not null), this specifies the start and stop time over which the subscriber session will process data. Passing in null for the StartTime and StopTime specifies the the subscriber session will process data in standard, i.e., real-time, operation.

Both the StartTime and StopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.StopTime Property

Grid Solutions Framework SubscriptionInfoStopTime Property
Gets or sets the stop time of the requested temporal session for streaming historic data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual string StopTime { get; set; }
Public Overridable Property StopTime As String
    Get
    Set
abstract StopTime : string with get, set
override StopTime : string with get, set
function get_StopTime();
function set_StopTime(value);
public:
virtual property String^ StopTime {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
Remarks

When the StartTime or StopTime temporal processing constraints are defined (i.e., not null), this specifies the start and stop time over which the subscriber session will process data. Passing in null for the StartTime and StopTime specifies the the subscriber session will process data in standard, i.e., real-time, operation.

Both the StartTime and StopTime parameters can be specified in one of the following formats:

Time Format | Format Description
12-30-2000 23:59:59.033 | Absolute date and time.
* | Evaluates to UtcNow.
*-20s | Evaluates to 20 seconds before UtcNow.
*-10m | Evaluates to 10 minutes before UtcNow.
*-1h | Evaluates to 1 hour before UtcNow.
*-1d | Evaluates to 1 day before UtcNow.

See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.UdpDataChannel Property

Grid Solutions Framework SubscriptionInfoUdpDataChannel Property
Gets or sets the flag that determines whether the subscriber is requesting its data over a separate UDP data channel.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool UdpDataChannel { get; set; }
Public Overridable Property UdpDataChannel As Boolean
    Get
    Set
abstract UdpDataChannel : bool with get, set
override UdpDataChannel : bool with get, set
function get_UdpDataChannel();
function set_UdpDataChannel(value);
public:
virtual property bool UdpDataChannel {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.UseCompactMeasurementFormat Property

Grid Solutions Framework SubscriptionInfoUseCompactMeasurementFormat Property
Gets or sets the flag that determines whether to use the compact measurement format or the full measurement format for transmitting measurements to the subscriber.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool UseCompactMeasurementFormat { get; set; }
Public Overridable Property UseCompactMeasurementFormat As Boolean
    Get
    Set
abstract UseCompactMeasurementFormat : bool with get, set
override UseCompactMeasurementFormat : bool with get, set
function get_UseCompactMeasurementFormat();
function set_UseCompactMeasurementFormat(value);
public:
virtual property bool UseCompactMeasurementFormat {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.UseLocalClockAsRealTime Property

Grid Solutions Framework SubscriptionInfoUseLocalClockAsRealTime Property
Gets or sets the flag that determines whether the server's local clock is used as real-time. If false, the timestamps of the measurements will be used as real-time.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool UseLocalClockAsRealTime { get; set; }
Public Overridable Property UseLocalClockAsRealTime As Boolean
    Get
    Set
abstract UseLocalClockAsRealTime : bool with get, set
override UseLocalClockAsRealTime : bool with get, set
function get_UseLocalClockAsRealTime();
function set_UseLocalClockAsRealTime(value);
public:
virtual property bool UseLocalClockAsRealTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SubscriptionInfo.UseMillisecondResolution Property

Grid Solutions Framework SubscriptionInfoUseMillisecondResolution Property
Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, they will use Ticks resolution.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool UseMillisecondResolution { get; set; }
Public Overridable Property UseMillisecondResolution As Boolean
    Get
    Set
abstract UseMillisecondResolution : bool with get, set
override UseMillisecondResolution : bool with get, set
function get_UseMillisecondResolution();
function set_UseMillisecondResolution(value);
public:
virtual property bool UseMillisecondResolution {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This flag determines the size of the timestamps transmitted as part of the compact measurement format when the server is using base time offsets.
See Also

Reference

SubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo Class

Grid Solutions Framework SynchronizedSubscriptionInfo Class
Configuration object for synchronized data subscriptions.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportSubscriptionInfo
GSF.TimeSeries.TransportSynchronizedSubscriptionInfo

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class SynchronizedSubscriptionInfo : SubscriptionInfo
Public NotInheritable Class SynchronizedSubscriptionInfo
    Inherits SubscriptionInfo
[<SealedAttribute>]
type SynchronizedSubscriptionInfo =
    class
        inherit SubscriptionInfo
    end
GSF.TimeSeries.Transport.SynchronizedSubscriptionInfo = function();

Type.createClass(
    'GSF.TimeSeries.Transport.SynchronizedSubscriptionInfo',
    GSF.TimeSeries.Transport.SubscriptionInfo);
public ref class SynchronizedSubscriptionInfo sealed : public SubscriptionInfo

The SynchronizedSubscriptionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | SynchronizedSubscriptionInfo | Creates a new instance of the SynchronizedSubscriptionInfo class.
Top
Methods
 | Name | Description
Public method | Copy | Creates a shallow copy of this SubscriptionInfo object. (Inherited from SubscriptionInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowPreemptivePublishing | Gets or sets the flag that determines whether frames should be published as soon as the data is available. If false, frames will be published when their timestamp expires (realTime > timestamp + lagTime).
Public property | AllowSortsByArrival | Gets or sets the flag that determines whether to allow measurement sorting based on the measurement's time of arrival, if its timestamp is unreasonable.
Public property | ConstraintParameters | Gets or sets the additional constraint parameters supplied to temporal adapters in a temporal session. (Inherited from SubscriptionInfo.)
Public property | DataChannelLocalPort | Gets or sets the port number that the UDP data channel binds to. This value is only used when the subscriber requests a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | DownsamplingMethod | Gets or sets the down-sampling method used when the frame rate of the subscription is lower than the frame rate of the measurement's source.
Public property | ExtraConnectionStringParameters | Gets or sets the additional connection string parameters to be applied to the connection string sent to the publisher during subscription. (Inherited from SubscriptionInfo.)
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested by the subscriber. (Inherited from SubscriptionInfo.)
Public property | FramesPerSecond | Gets or sets the frame rate of the subscription in frames per second.
Public property | IgnoreBadTimestamps | Gets or sets the flag that determines whether to ignore bad timestamps when sorting measurements.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | ProcessingInterval | Gets or sets the processing interval requested by the subscriber. A value of -1 indicates the default processing interval. A value of 0 indicates data will be processed as fast as possible. (Inherited from SubscriptionInfo.)
Public property | RemotelySynchronized | Gets or sets the flag that determines whether this subscription is remotely synchronized or locally synchronized.
Public property | RequestNaNValueFilter | Gets or sets the flag that determines whether to request that measurements sent to the subscriber should be filtered by the publisher prior to sending them. (Inherited from SubscriptionInfo.)
Public property | StartTime | Gets or sets the start time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | StopTime | Gets or sets the stop time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | TimeResolution | Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.
Public property | UdpDataChannel | Gets or sets the flag that determines whether the subscriber is requesting its data over a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | UseCompactMeasurementFormat | Gets or sets the flag that determines whether to use the compact measurement format or the full measurement format for transmitting measurements to the subscriber. (Inherited from SubscriptionInfo.)
Public property | UseLocalClockAsRealTime | Gets or sets the flag that determines whether the server's local clock is used as real-time. If false, the timestamps of the measurements will be used as real-time. (Inherited from SubscriptionInfo.)
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, they will use Ticks resolution. (Inherited from SubscriptionInfo.)
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo Constructor

Grid Solutions Framework SynchronizedSubscriptionInfo Constructor
Creates a new instance of the SynchronizedSubscriptionInfo class.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SynchronizedSubscriptionInfo(
    bool remotelySynchronized,
    int framesPerSecond
)
Public Sub New (
    remotelySynchronized As Boolean,
    framesPerSecond As Integer
)
new :
        remotelySynchronized : bool *
        framesPerSecond : int -> SynchronizedSubscriptionInfo
GSF.TimeSeries.Transport.SynchronizedSubscriptionInfo = function(remotelySynchronized, framesPerSecond);
public:
SynchronizedSubscriptionInfo(
    bool remotelySynchronized,
    int framesPerSecond
)

Parameters

remotelySynchronized
Type: SystemBoolean
Flag that determines whether the subscription defined by this object is remotely synchronized or locally synchronized.
framesPerSecond
Type: SystemInt32
Frame rate of the subscription in frames per second.
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo Methods

Grid Solutions Framework SynchronizedSubscriptionInfo Methods

The SynchronizedSubscriptionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Creates a shallow copy of this SubscriptionInfo object. (Inherited from SubscriptionInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo Properties

Grid Solutions Framework SynchronizedSubscriptionInfo Properties

The SynchronizedSubscriptionInfo type exposes the following members.

Properties
 | Name | Description
Public property | AllowPreemptivePublishing | Gets or sets the flag that determines whether frames should be published as soon as the data is available. If false, frames will be published when their timestamp expires (realTime > timestamp + lagTime).
Public property | AllowSortsByArrival | Gets or sets the flag that determines whether to allow measurement sorting based on the measurement's time of arrival, if its timestamp is unreasonable.
Public property | ConstraintParameters | Gets or sets the additional constraint parameters supplied to temporal adapters in a temporal session. (Inherited from SubscriptionInfo.)
Public property | DataChannelLocalPort | Gets or sets the port number that the UDP data channel binds to. This value is only used when the subscriber requests a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | DownsamplingMethod | Gets or sets the down-sampling method used when the frame rate of the subscription is lower than the frame rate of the measurement's source.
Public property | ExtraConnectionStringParameters | Gets or sets the additional connection string parameters to be applied to the connection string sent to the publisher during subscription. (Inherited from SubscriptionInfo.)
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested by the subscriber. (Inherited from SubscriptionInfo.)
Public property | FramesPerSecond | Gets or sets the frame rate of the subscription in frames per second.
Public property | IgnoreBadTimestamps | Gets or sets the flag that determines whether to ignore bad timestamps when sorting measurements.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | ProcessingInterval | Gets or sets the processing interval requested by the subscriber. A value of -1 indicates the default processing interval. A value of 0 indicates data will be processed as fast as possible. (Inherited from SubscriptionInfo.)
Public property | RemotelySynchronized | Gets or sets the flag that determines whether this subscription is remotely synchronized or locally synchronized.
Public property | RequestNaNValueFilter | Gets or sets the flag that determines whether to request that measurements sent to the subscriber should be filtered by the publisher prior to sending them. (Inherited from SubscriptionInfo.)
Public property | StartTime | Gets or sets the start time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | StopTime | Gets or sets the stop time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | TimeResolution | Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.
Public property | UdpDataChannel | Gets or sets the flag that determines whether the subscriber is requesting its data over a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | UseCompactMeasurementFormat | Gets or sets the flag that determines whether to use the compact measurement format or the full measurement format for transmitting measurements to the subscriber. (Inherited from SubscriptionInfo.)
Public property | UseLocalClockAsRealTime | Gets or sets the flag that determines whether the server's local clock is used as real-time. If false, the timestamps of the measurements will be used as real-time. (Inherited from SubscriptionInfo.)
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, they will use Ticks resolution. (Inherited from SubscriptionInfo.)
Top
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo.AllowPreemptivePublishing Property

Grid Solutions Framework SynchronizedSubscriptionInfoAllowPreemptivePublishing Property
Gets or sets the flag that determines whether frames should be published as soon as the data is available. If false, frames will be published when their timestamp expires (realTime > timestamp + lagTime).

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllowPreemptivePublishing { get; set; }
Public Property AllowPreemptivePublishing As Boolean
    Get
    Set
member AllowPreemptivePublishing : bool with get, set

function get_AllowPreemptivePublishing();
function set_AllowPreemptivePublishing(value);
public:
property bool AllowPreemptivePublishing {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo.AllowSortsByArrival Property

Grid Solutions Framework SynchronizedSubscriptionInfoAllowSortsByArrival Property
Gets or sets the flag that determines whether to allow measurement sorting based on the measurement's time of arrival, if its timestamp is unreasonable.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool AllowSortsByArrival { get; set; }
Public Property AllowSortsByArrival As Boolean
    Get
    Set
member AllowSortsByArrival : bool with get, set

function get_AllowSortsByArrival();
function set_AllowSortsByArrival(value);
public:
property bool AllowSortsByArrival {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo.DownsamplingMethod Property

Grid Solutions Framework SynchronizedSubscriptionInfoDownsamplingMethod Property
Gets or sets the down-sampling method used when the frame rate of the subscription is lower than the frame rate of the measurement's source.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public DownsamplingMethod DownsamplingMethod { get; set; }
Public Property DownsamplingMethod As DownsamplingMethod
    Get
    Set
member DownsamplingMethod : DownsamplingMethod with get, set

function get_DownsamplingMethod();
function set_DownsamplingMethod(value);
public:
property DownsamplingMethod DownsamplingMethod {
    DownsamplingMethod get ();
    void set (DownsamplingMethod value);
}

Property Value

Type: DownsamplingMethod
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo.FramesPerSecond Property

Grid Solutions Framework SynchronizedSubscriptionInfoFramesPerSecond Property
Gets or sets the frame rate of the subscription in frames per second.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int FramesPerSecond { get; set; }
Public Property FramesPerSecond As Integer
    Get
    Set
member FramesPerSecond : int with get, set

function get_FramesPerSecond();
function set_FramesPerSecond(value);
public:
property int FramesPerSecond {
    int get ();
    void set (int value);
}

Property Value

Type: Int32
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo.IgnoreBadTimestamps Property

Grid Solutions Framework SynchronizedSubscriptionInfoIgnoreBadTimestamps Property
Gets or sets the flag that determines whether to ignore bad timestamps when sorting measurements.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IgnoreBadTimestamps { get; set; }
Public Property IgnoreBadTimestamps As Boolean
    Get
    Set
member IgnoreBadTimestamps : bool with get, set

function get_IgnoreBadTimestamps();
function set_IgnoreBadTimestamps(value);
public:
property bool IgnoreBadTimestamps {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo.RemotelySynchronized Property

Grid Solutions Framework SynchronizedSubscriptionInfoRemotelySynchronized Property
Gets or sets the flag that determines whether this subscription is remotely synchronized or locally synchronized.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool RemotelySynchronized { get; set; }
Public Property RemotelySynchronized As Boolean
    Get
    Set
member RemotelySynchronized : bool with get, set

function get_RemotelySynchronized();
function set_RemotelySynchronized(value);
public:
property bool RemotelySynchronized {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


SynchronizedSubscriptionInfo.TimeResolution Property

Grid Solutions Framework SynchronizedSubscriptionInfoTimeResolution Property
Gets or sets the maximum time resolution, in ticks, to use when sorting measurements by timestamps into their proper destination frame.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public long TimeResolution { get; set; }
Public Property TimeResolution As Long
    Get
    Set
member TimeResolution : int64 with get, set

function get_TimeResolution();
function set_TimeResolution(value);
public:
property long long TimeResolution {
    long long get ();
    void set (long long value);
}

Property Value

Type: Int64
Remarks
Desired maximum resolution | Value to assign
Seconds | Ticks.PerSecond
Milliseconds | Ticks.PerMillisecond
Microseconds | Ticks.PerMicrosecond
100-Nanoseconds | 0
Assigning values less than zero will be set to zero since minimum possible concentrator resolution is one tick (100-nanoseconds). Assigning values values greater than Ticks.PerSecond will be set to Ticks.PerSecond since maximum possible concentrator resolution is one second (i.e., 1 frame per second).
See Also

Reference

SynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy Class

Grid Solutions Framework TemporalClientSubscriptionProxy Class
Represents an action adapter that exists within a temporal IaonSession to proxy data back to its parent IClientSubscription instance.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.AdaptersAdapterBase
GSF.TimeSeries.AdaptersFacileActionAdapterBase
GSF.TimeSeries.TransportTemporalClientSubscriptionProxy

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[EditorBrowsableAttribute(EditorBrowsableState.Never)]
public class TemporalClientSubscriptionProxy : FacileActionAdapterBase
<EditorBrowsableAttribute(EditorBrowsableState.Never)>
Public Class TemporalClientSubscriptionProxy
    Inherits FacileActionAdapterBase
[<EditorBrowsableAttribute(EditorBrowsableState.Never)>]
type TemporalClientSubscriptionProxy =
    class
        inherit FacileActionAdapterBase
    end
GSF.TimeSeries.Transport.TemporalClientSubscriptionProxy = function();

Type.createClass(
    'GSF.TimeSeries.Transport.TemporalClientSubscriptionProxy',
    GSF.TimeSeries.Adapters.FacileActionAdapterBase);
[EditorBrowsableAttribute(EditorBrowsableState::Never)]
public ref class TemporalClientSubscriptionProxy : public FacileActionAdapterBase

The TemporalClientSubscriptionProxy type exposes the following members.

Constructors
 | Name | Description
Public method | TemporalClientSubscriptionProxy | Initializes a new instance of the TemporalClientSubscriptionProxy class
Top
Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources. (Inherited from AdapterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this TemporalClientSubscriptionProxy. (Overrides AdapterBaseGetShortStatus(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes FacileActionAdapterBase. (Inherited from FacileActionAdapterBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementsForProcessing | Proxies measurements to parent adapter for processing. (Overrides FacileActionAdapterBaseQueueMeasurementsForProcessing(IEnumerableIMeasurement).)
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts the AdapterBase or restarts it if it is already running. (Inherited from AdapterBase.)
Public method | Stop | Stops the AdapterBase. (Inherited from AdapterBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase. (Inherited from AdapterBase.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | FramesPerSecond | Gets or sets the frames per second to be used by the FacileActionAdapterBase. (Inherited from FacileActionAdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the FacileActionAdapterBase expects, if any. (Inherited from FacileActionAdapterBase.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from FacileActionAdapterBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from FacileActionAdapterBase.)
Public property | Parent | Gets or sets parent subscription for the proxy used to deliver data.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement. (Inherited from FacileActionAdapterBase.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from FacileActionAdapterBase.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from FacileActionAdapterBase.)
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. (Inherited from FacileActionAdapterBase.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real time. (Inherited from FacileActionAdapterBase.)
Top
Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from FacileActionAdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from action adapter. (Inherited from FacileActionAdapterBase.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnpublishedSamples | This event is raised by derived class, if needed, to track current number of unpublished seconds of data in the queue. (Inherited from FacileActionAdapterBase.)
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy Constructor

Grid Solutions Framework TemporalClientSubscriptionProxy Constructor
Initializes a new instance of the TemporalClientSubscriptionProxy class

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TemporalClientSubscriptionProxy()
Public Sub New
new : unit -> TemporalClientSubscriptionProxy
GSF.TimeSeries.Transport.TemporalClientSubscriptionProxy = function();
public:
TemporalClientSubscriptionProxy()
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy Methods

Grid Solutions Framework TemporalClientSubscriptionProxy Methods

The TemporalClientSubscriptionProxy type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases all the resources used by the AdapterBase object. (Inherited from AdapterBase.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the AdapterBase object and optionally releases the managed resources. (Inherited from AdapterBase.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the AdapterBase object is reclaimed by GC. (Inherited from AdapterBase.)
Public method | GetHashCode | Serves as a hash function for the current AdapterBase. (Inherited from AdapterBase.)
Public method | GetShortStatus | Gets a short one-line status of this TemporalClientSubscriptionProxy. (Overrides AdapterBaseGetShortStatus(Int32).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | IncrementProcessedMeasurements | Safely increments the total processed measurements. (Inherited from AdapterBase.)
Public method | Initialize | Initializes FacileActionAdapterBase. (Inherited from FacileActionAdapterBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnConfigurationChanged | Raises ConfigurationChanged event. (Inherited from AdapterBase.)
Protected method | OnDiscardingMeasurements | Raises the DiscardingMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnInputMeasurementKeysUpdated | Raises InputMeasurementKeysUpdated event. (Inherited from AdapterBase.)
Protected method | OnNewMeasurements | Raises the NewMeasurements event. (Inherited from FacileActionAdapterBase.)
Protected method | OnOutputMeasurementsUpdated | Raises OutputMeasurementsUpdated event. (Inherited from AdapterBase.)
Protected method | OnProcessException | Raises ProcessException event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String) | Raises the StatusMessage event. (Inherited from AdapterBase.)
Protected method | OnStatusMessage(String, Object) | Raises the StatusMessage event with a formatted status message. (Inherited from AdapterBase.)
Protected method | OnUnpublishedSamples | Raises the UnpublishedSamples event. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementForProcessing | Queues a single measurement for processing. (Inherited from FacileActionAdapterBase.)
Public method | QueueMeasurementsForProcessing | Proxies measurements to parent adapter for processing. (Overrides FacileActionAdapterBaseQueueMeasurementsForProcessing(IEnumerableIMeasurement).)
Public method | SetInitializedState | Manually sets the initialized state of the AdapterBase. (Inherited from AdapterBase.)
Public method | SetTemporalConstraint | Defines a temporal processing constraint for the adapter. (Inherited from AdapterBase.)
Public method | Start | Starts the AdapterBase or restarts it if it is already running. (Inherited from AdapterBase.)
Public method | Stop | Stops the AdapterBase. (Inherited from AdapterBase.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy.GetShortStatus Method

Grid Solutions Framework TemporalClientSubscriptionProxyGetShortStatus Method
Gets a short one-line status of this TemporalClientSubscriptionProxy.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string GetShortStatus(
    int maxLength
)
Public Overrides Function GetShortStatus (
    maxLength As Integer
) As String
abstract GetShortStatus :
        maxLength : int -> string
override GetShortStatus :
        maxLength : int -> string
function GetShortStatus(maxLength);
public:
virtual String^ GetShortStatus(
    int maxLength
) override

Parameters

maxLength
Type: SystemInt32
Maximum number of available characters for display.

Return Value

Type: String
A short one-line summary of the current status for this AdapterBase.

Implements

IAdapterGetShortStatus(Int32)
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy.QueueMeasurementsForProcessing Method

Grid Solutions Framework TemporalClientSubscriptionProxyQueueMeasurementsForProcessing Method
Proxies measurements to parent adapter for processing.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement> measurements
)
Public Overrides Sub QueueMeasurementsForProcessing (
    measurements As IEnumerable(Of IMeasurement)
)
abstract QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
override QueueMeasurementsForProcessing :
        measurements : IEnumerable<IMeasurement> -> unit
function QueueMeasurementsForProcessing(measurements);
public:
virtual void QueueMeasurementsForProcessing(
    IEnumerable<IMeasurement^>^ measurements
) override

Parameters

measurements
Type: System.Collections.GenericIEnumerable IMeasurement
Collection of measurements to queue for processing.

Implements

IActionAdapterQueueMeasurementsForProcessing(IEnumerableIMeasurement)
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy Properties

Grid Solutions Framework TemporalClientSubscriptionProxy Properties

The TemporalClientSubscriptionProxy type exposes the following members.

Properties
 | Name | Description
Public property | AutoStart | Gets or sets flag indicating if adapter should automatically start or otherwise connect on demand. (Inherited from AdapterBase.)
Public property | ConnectionString | Gets or sets key/value pair connection information specific to this AdapterBase. (Inherited from AdapterBase.)
Public property | DataSource | Gets or sets DataSet based data source available to this AdapterBase. (Inherited from AdapterBase.)
Public property | Enabled | Gets or sets enabled state of this AdapterBase. (Inherited from AdapterBase.)
Public property | FramesPerSecond | Gets or sets the frames per second to be used by the FacileActionAdapterBase. (Inherited from FacileActionAdapterBase.)
Public property | ID | Gets or sets numeric ID associated with this AdapterBase. (Inherited from AdapterBase.)
Public property | InitializationTimeout | Gets or sets maximum time system will wait during Start for initialization. (Inherited from AdapterBase.)
Public property | Initialized | Gets or sets flag indicating if the adapter has been initialized successfully. (Inherited from AdapterBase.)
Public property | InputMeasurementKeys | Gets or sets primary keys of input measurements the FacileActionAdapterBase expects, if any. (Inherited from FacileActionAdapterBase.)
Public property | InputSourceIDs | Gets or sets Source values used to filter input measurement keys. (Inherited from FacileActionAdapterBase.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from AdapterBase.)
Public property | LagTime | Gets or sets the allowed past time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | LatestMeasurements | Gets reference to the collection of absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from FacileActionAdapterBase.)
Public property | MeasurementReportingInterval | Gets or sets the measurement reporting interval. (Inherited from AdapterBase.)
Public property | Name | Gets or sets the name of this AdapterBase. (Inherited from AdapterBase.)
Public property | OutputMeasurements | Gets or sets output measurements that the AdapterBase will produce, if any. (Inherited from AdapterBase.)
Public property | OutputSourceIDs | Gets or sets Source values used to filter output measurements. (Inherited from FacileActionAdapterBase.)
Public property | Parent | Gets or sets parent subscription for the proxy used to deliver data.
Public property | ProcessedMeasurements | Gets the total number of measurements handled thus far by the AdapterBase. (Inherited from AdapterBase.)
Public property | ProcessingInterval | Gets or sets the desired processing interval, in milliseconds, for the adapter. (Inherited from AdapterBase.)
Public property | RealTime | Gets the the most accurate time value that is available. If UseLocalClockAsRealTime = true, then this function will return UtcNow. Otherwise, this function will return the timestamp of the most recent measurement. (Inherited from FacileActionAdapterBase.)
Public property | RequestedInputMeasurementKeys | Gets or sets input measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RequestedOutputMeasurementKeys | Gets or sets output measurement keys that are requested by other adapters based on what adapter says it can provide. (Inherited from FacileActionAdapterBase.)
Public property | RespectInputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on input demands. (Inherited from FacileActionAdapterBase.)
Public property | RespectOutputDemands | Gets or sets flag indicating if action adapter should respect auto-start requests based on output demands. (Inherited from FacileActionAdapterBase.)
Public property | RunTime | Gets the total amount of time, in seconds, that the adapter has been active. (Inherited from AdapterBase.)
Public property | Settings | Gets settings DictionaryTKey, TValue parsed when ConnectionString was assigned. (Inherited from AdapterBase.)
Public property | StartTime | Gets the UTC time this AdapterBase was started. (Inherited from AdapterBase.)
Public property | StartTimeConstraint | Gets the start time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | Status | Returns the detailed status of the data input source. (Inherited from FacileActionAdapterBase.)
Public property | StopTime | Gets the UTC time this AdapterBase was stopped. (Inherited from AdapterBase.)
Public property | StopTimeConstraint | Gets the stop time temporal processing constraint defined by call to SetTemporalConstraint(String, String, String). (Inherited from AdapterBase.)
Public property | SupportsTemporalProcessing | Gets the flag indicating if this adapter supports temporal processing. (Overrides AdapterBaseSupportsTemporalProcessing.)
Public property | TrackLatestMeasurements | Gets or sets flag to start tracking the absolute latest received measurement values. (Inherited from FacileActionAdapterBase.)
Public property | UseLocalClockAsRealTime | Gets or sets flag that determines whether or not to use the local clock time as real time. (Inherited from FacileActionAdapterBase.)
Top
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy.Parent Property

Grid Solutions Framework TemporalClientSubscriptionProxyParent Property
Gets or sets parent subscription for the proxy used to deliver data.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IClientSubscription Parent { get; set; }
Public Property Parent As IClientSubscription
    Get
    Set
member Parent : IClientSubscription with get, set

function get_Parent();
function set_Parent(value);
public:
property IClientSubscription^ Parent {
    IClientSubscription^ get ();
    void set (IClientSubscription^ value);
}

Property Value

Type: IClientSubscription
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy.SupportsTemporalProcessing Property

Grid Solutions Framework TemporalClientSubscriptionProxySupportsTemporalProcessing Property
Gets the flag indicating if this adapter supports temporal processing.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool SupportsTemporalProcessing { get; }
Public Overrides ReadOnly Property SupportsTemporalProcessing As Boolean
    Get
abstract SupportsTemporalProcessing : bool with get
override SupportsTemporalProcessing : bool with get
function get_SupportsTemporalProcessing();

public:
virtual property bool SupportsTemporalProcessing {
    bool get () override;
}

Property Value

Type: Boolean

Implements

IAdapterSupportsTemporalProcessing
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


TemporalClientSubscriptionProxy Events

Grid Solutions Framework TemporalClientSubscriptionProxy Events

The TemporalClientSubscriptionProxy type exposes the following members.

Events
 | Name | Description
Public event | ConfigurationChanged | Event is raised when adapter is aware of a configuration change. (Inherited from AdapterBase.)
Public event | DiscardingMeasurements | This event is raised if there are any measurements being discarded during the sorting process. (Inherited from FacileActionAdapterBase.)
Public event | Disposed | Event is raised when AdapterBase is disposed. (Inherited from AdapterBase.)
Public event | InputMeasurementKeysUpdated | Event is raised when InputMeasurementKeys are updated. (Inherited from AdapterBase.)
Public event | NewMeasurements | Provides new measurements from action adapter. (Inherited from FacileActionAdapterBase.)
Public event | OutputMeasurementsUpdated | Event is raised when OutputMeasurements are updated. (Inherited from AdapterBase.)
Public event | ProcessException | Event is raised when there is an exception encountered while processing. (Inherited from AdapterBase.)
Public event | StatusMessage | Provides status messages to consumer. (Inherited from AdapterBase.)
Public event | UnpublishedSamples | This event is raised by derived class, if needed, to track current number of unpublished seconds of data in the queue. (Inherited from FacileActionAdapterBase.)
Top
See Also

Reference

TemporalClientSubscriptionProxy Class
GSF.TimeSeries.Transport Namespace


UnsynchronizedSubscriptionInfo Class

Grid Solutions Framework UnsynchronizedSubscriptionInfo Class
Configuration object for unsynchronized data subscriptions.
Inheritance Hierarchy
SystemObject
GSF.TimeSeries.TransportSubscriptionInfo
GSF.TimeSeries.TransportUnsynchronizedSubscriptionInfo

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public sealed class UnsynchronizedSubscriptionInfo : SubscriptionInfo
Public NotInheritable Class UnsynchronizedSubscriptionInfo
    Inherits SubscriptionInfo
[<SealedAttribute>]
type UnsynchronizedSubscriptionInfo =
    class
        inherit SubscriptionInfo
    end
GSF.TimeSeries.Transport.UnsynchronizedSubscriptionInfo = function();

Type.createClass(
    'GSF.TimeSeries.Transport.UnsynchronizedSubscriptionInfo',
    GSF.TimeSeries.Transport.SubscriptionInfo);
public ref class UnsynchronizedSubscriptionInfo sealed : public SubscriptionInfo

The UnsynchronizedSubscriptionInfo type exposes the following members.

Constructors
 | Name | Description
Public method | UnsynchronizedSubscriptionInfo | Creates a new instance of the UnsynchronizedSubscriptionInfo class.
Top
Methods
 | Name | Description
Public method | Copy | Creates a shallow copy of this SubscriptionInfo object. (Inherited from SubscriptionInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ConstraintParameters | Gets or sets the additional constraint parameters supplied to temporal adapters in a temporal session. (Inherited from SubscriptionInfo.)
Public property | DataChannelLocalPort | Gets or sets the port number that the UDP data channel binds to. This value is only used when the subscriber requests a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | ExtraConnectionStringParameters | Gets or sets the additional connection string parameters to be applied to the connection string sent to the publisher during subscription. (Inherited from SubscriptionInfo.)
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested by the subscriber. (Inherited from SubscriptionInfo.)
Public property | IncludeTime | Gets or sets the flag that determines whether timestamps are included in the data sent from the publisher. This value is ignored if the data is remotely synchronized.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | ProcessingInterval | Gets or sets the processing interval requested by the subscriber. A value of -1 indicates the default processing interval. A value of 0 indicates data will be processed as fast as possible. (Inherited from SubscriptionInfo.)
Public property | PublishInterval | Gets or sets the interval at which data should be published when using a throttled subscription.
Public property | RequestNaNValueFilter | Gets or sets the flag that determines whether to request that measurements sent to the subscriber should be filtered by the publisher prior to sending them. (Inherited from SubscriptionInfo.)
Public property | StartTime | Gets or sets the start time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | StopTime | Gets or sets the stop time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | Throttled | Gets or sets the flag that determines whether to request that the subscription be throttled.
Public property | UdpDataChannel | Gets or sets the flag that determines whether the subscriber is requesting its data over a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | UseCompactMeasurementFormat | Gets or sets the flag that determines whether to use the compact measurement format or the full measurement format for transmitting measurements to the subscriber. (Inherited from SubscriptionInfo.)
Public property | UseLocalClockAsRealTime | Gets or sets the flag that determines whether the server's local clock is used as real-time. If false, the timestamps of the measurements will be used as real-time. (Inherited from SubscriptionInfo.)
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, they will use Ticks resolution. (Inherited from SubscriptionInfo.)
Top
See Also

Reference

GSF.TimeSeries.Transport Namespace


UnsynchronizedSubscriptionInfo Constructor

Grid Solutions Framework UnsynchronizedSubscriptionInfo Constructor
Creates a new instance of the UnsynchronizedSubscriptionInfo class.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UnsynchronizedSubscriptionInfo(
    bool throttled
)
Public Sub New (
    throttled As Boolean
)
new :
        throttled : bool -> UnsynchronizedSubscriptionInfo
GSF.TimeSeries.Transport.UnsynchronizedSubscriptionInfo = function(throttled);
public:
UnsynchronizedSubscriptionInfo(
    bool throttled
)

Parameters

throttled
Type: SystemBoolean
The flag that determines whether to request that the subscription be throttled.
See Also

Reference

UnsynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


UnsynchronizedSubscriptionInfo Methods

Grid Solutions Framework UnsynchronizedSubscriptionInfo Methods

The UnsynchronizedSubscriptionInfo type exposes the following members.

Methods
 | Name | Description
Public method | Copy | Creates a shallow copy of this SubscriptionInfo object. (Inherited from SubscriptionInfo.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

UnsynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


UnsynchronizedSubscriptionInfo Properties

Grid Solutions Framework UnsynchronizedSubscriptionInfo Properties

The UnsynchronizedSubscriptionInfo type exposes the following members.

Properties
 | Name | Description
Public property | ConstraintParameters | Gets or sets the additional constraint parameters supplied to temporal adapters in a temporal session. (Inherited from SubscriptionInfo.)
Public property | DataChannelLocalPort | Gets or sets the port number that the UDP data channel binds to. This value is only used when the subscriber requests a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | ExtraConnectionStringParameters | Gets or sets the additional connection string parameters to be applied to the connection string sent to the publisher during subscription. (Inherited from SubscriptionInfo.)
Public property | FilterExpression | Gets or sets the filter expression used to define which measurements are being requested by the subscriber. (Inherited from SubscriptionInfo.)
Public property | IncludeTime | Gets or sets the flag that determines whether timestamps are included in the data sent from the publisher. This value is ignored if the data is remotely synchronized.
Public property | LagTime | Gets or sets the allowed past time deviation tolerance in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | LeadTime | Gets or sets the allowed future time deviation tolerance, in seconds (can be sub-second). (Inherited from SubscriptionInfo.)
Public property | ProcessingInterval | Gets or sets the processing interval requested by the subscriber. A value of -1 indicates the default processing interval. A value of 0 indicates data will be processed as fast as possible. (Inherited from SubscriptionInfo.)
Public property | PublishInterval | Gets or sets the interval at which data should be published when using a throttled subscription.
Public property | RequestNaNValueFilter | Gets or sets the flag that determines whether to request that measurements sent to the subscriber should be filtered by the publisher prior to sending them. (Inherited from SubscriptionInfo.)
Public property | StartTime | Gets or sets the start time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | StopTime | Gets or sets the stop time of the requested temporal session for streaming historic data. (Inherited from SubscriptionInfo.)
Public property | Throttled | Gets or sets the flag that determines whether to request that the subscription be throttled.
Public property | UdpDataChannel | Gets or sets the flag that determines whether the subscriber is requesting its data over a separate UDP data channel. (Inherited from SubscriptionInfo.)
Public property | UseCompactMeasurementFormat | Gets or sets the flag that determines whether to use the compact measurement format or the full measurement format for transmitting measurements to the subscriber. (Inherited from SubscriptionInfo.)
Public property | UseLocalClockAsRealTime | Gets or sets the flag that determines whether the server's local clock is used as real-time. If false, the timestamps of the measurements will be used as real-time. (Inherited from SubscriptionInfo.)
Public property | UseMillisecondResolution | Gets or sets the flag that determines whether measurement timestamps use millisecond resolution. If false, they will use Ticks resolution. (Inherited from SubscriptionInfo.)
Top
See Also

Reference

UnsynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


UnsynchronizedSubscriptionInfo.IncludeTime Property

Grid Solutions Framework UnsynchronizedSubscriptionInfoIncludeTime Property
Gets or sets the flag that determines whether timestamps are included in the data sent from the publisher. This value is ignored if the data is remotely synchronized.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool IncludeTime { get; set; }
Public Property IncludeTime As Boolean
    Get
    Set
member IncludeTime : bool with get, set

function get_IncludeTime();
function set_IncludeTime(value);
public:
property bool IncludeTime {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UnsynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


UnsynchronizedSubscriptionInfo.PublishInterval Property

Grid Solutions Framework UnsynchronizedSubscriptionInfoPublishInterval Property
Gets or sets the interval at which data should be published when using a throttled subscription.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double PublishInterval { get; set; }
Public Property PublishInterval As Double
    Get
    Set
member PublishInterval : float with get, set

function get_PublishInterval();
function set_PublishInterval(value);
public:
property double PublishInterval {
    double get ();
    void set (double value);
}

Property Value

Type: Double
See Also

Reference

UnsynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


UnsynchronizedSubscriptionInfo.Throttled Property

Grid Solutions Framework UnsynchronizedSubscriptionInfoThrottled Property
Gets or sets the flag that determines whether to request that the subscription be throttled.

Namespace: GSF.TimeSeries.Transport
Assembly: GSF.TimeSeries (in GSF.TimeSeries.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Throttled { get; set; }
Public Property Throttled As Boolean
    Get
    Set
member Throttled : bool with get, set

function get_Throttled();
function set_Throttled(value);
public:
property bool Throttled {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

UnsynchronizedSubscriptionInfo Class
GSF.TimeSeries.Transport Namespace


GSF.Units Namespace

Grid Solutions Framework GSF.Units Namespace
Contains classes used to simplify and standardize standard unit and SI conversions.
Classes
 | Class | Description
Public class | SI | Defines constant factors for SI units of measure to handle metric conversions.
Public class | SI2 | Defines constant factors based on 1024 for related binary SI units of measure used in computational measurements.
Structures
 | Structure | Description
Public structure | Angle | Represents an angle, in radians, as a double-precision floating-point number.
Public structure | Charge | Represents an electric charge measurement, in coulombs (i.e., ampere-seconds), as a double-precision floating-point number.
Public structure | Current | Represents an electric current measurement, in amperes, as a double-precision floating-point number.
Public structure | Energy | Represents an energy measurement, in joules (i.e., watt-seconds), as a double-precision floating-point number.
Public structure | Length | Represents a length measurement, in meters, as a double-precision floating-point number.
Public structure | Mass | Represents a mass measurement, in kilograms, as a double-precision floating-point number.
Public structure | Power | Represents a power measurement, in watts, as a double-precision floating-point number.
Public structure | Speed | Represents a speed measurement, in meters per second, as a double-precision floating-point number.
Public structure | Temperature | Represents a temperature, in kelvin, as a double-precision floating-point number.
Public structure | Time | Represents a time measurement, in seconds, as a double-precision floating-point number.
Public structure | Voltage | Represents an electromotive force (i.e., voltage) measurement, in volts, as a double-precision floating-point number.
Public structure | Volume | Represents a volume measurement, in cubic meters, as a double-precision floating-point number.


Angle Structure

Grid Solutions Framework Angle Structure
Represents an angle, in radians, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Angle : IComparable, IFormattable,
    IConvertible, IComparable<Angle>, IComparable<double>, IEquatable<Angle>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Angle
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Angle),
    IComparable(Of Double), IEquatable(Of Angle), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Angle =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Angle>
        interface IComparable<float>
        interface IEquatable<Angle>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Angle : IComparable,
    IFormattable, IConvertible, IComparable<Angle>, IComparable<double>,
    IEquatable<Angle>, IEquatable<double>

The Angle type exposes the following members.

Constructors
 | Name | Description
Public method | Angle | Creates a new Angle.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Angle) | Compares this instance to a specified Angle and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Angle) | Returns a value indicating whether this instance is equal to a specified Angle value.
 | FromAngularMil | Creates a new Angle value from the specified value in angular mil.
 | FromArcMinutes | Creates a new Angle value from the specified value in arcminutes.
 | FromArcSeconds | Creates a new Angle value from the specified value in arcseconds.
 | FromDegrees | Creates a new Angle value from the specified value in degrees.
 | FromGrads | Creates a new Angle value from the specified value in grads.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Angle equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Angle equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Angle equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent.
Public method | ToAngularMil | Gets the Angle value in angular mil.
Public method | ToArcMinutes | Gets the Angle value in arcminutes.
Public method | ToArcSeconds | Gets the Angle value in arcseconds.
Public method | ToDegrees | Gets the Angle value in degrees.
Public method | ToGrads | Gets the Angle value in grads.
Public method | ToRange | Gets the equivalent angle moved within the range of minValue and minValue + 2.0 * PI.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Angle) | Converts the string representation of a number to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Angle) | Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Angle) | Implicitly converts value, represented in radians, to an Angle.
(Angle to Double) | Implicitly converts Angle, represented in radians, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Angle. This field is constant.
MinValue | Represents the smallest possible value of an Angle. This field is constant.
Top
Remarks
This class behaves just like a Double representing an angle in radians; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other angle representations, specifically degrees, grads (a.k.a., grade, gradian and gon), arcminutes (a.k.a., minute of arc and MOA), arcseconds (a.k.a., second of arc) and angular mil (a.k.a. mil).
Examples
This example converts degrees to grads:
Copy
public double GetGrads(double degrees)
{
    return Angle.FromDegrees(degrees).ToGrads();
}
See Also

Reference

GSF.Units Namespace


Angle Constructor

Grid Solutions Framework Angle Constructor
Creates a new Angle.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Angle(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Angle
GSF.Units.Angle = function(value);
public:
Angle(
    double value
)

Parameters

value
Type: SystemDouble
New angle value in radians.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle Fields

Grid Solutions Framework Angle Fields

The Angle type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Angle. This field is constant.
MinValue | Represents the smallest possible value of an Angle. This field is constant.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.MaxValue Field

Grid Solutions Framework AngleMaxValue Field
Represents the largest possible value of an Angle. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Angle MaxValue
Public Shared ReadOnly MaxValue As Angle
static val MaxValue: Angle
var GSF.Units.Angle.MaxValue
public:
static initonly Angle MaxValue

Field Value

Type: Angle
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.MinValue Field

Grid Solutions Framework AngleMinValue Field
Represents the smallest possible value of an Angle. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Angle MinValue
Public Shared ReadOnly MinValue As Angle
static val MinValue: Angle
var GSF.Units.Angle.MinValue
public:
static initonly Angle MinValue

Field Value

Type: Angle
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle Methods

Grid Solutions Framework Angle Methods

The Angle type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Angle) | Compares this instance to a specified Angle and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Angle) | Returns a value indicating whether this instance is equal to a specified Angle value.
 | FromAngularMil | Creates a new Angle value from the specified value in angular mil.
 | FromArcMinutes | Creates a new Angle value from the specified value in arcminutes.
 | FromArcSeconds | Creates a new Angle value from the specified value in arcseconds.
 | FromDegrees | Creates a new Angle value from the specified value in degrees.
 | FromGrads | Creates a new Angle value from the specified value in grads.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Angle equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Angle equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Angle equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent.
Public method | ToAngularMil | Gets the Angle value in angular mil.
Public method | ToArcMinutes | Gets the Angle value in arcminutes.
Public method | ToArcSeconds | Gets the Angle value in arcseconds.
Public method | ToDegrees | Gets the Angle value in degrees.
Public method | ToGrads | Gets the Angle value in grads.
Public method | ToRange | Gets the equivalent angle moved within the range of minValue and minValue + 2.0 * PI.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Angle) | Converts the string representation of a number to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Angle) | Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.CompareTo Method

Grid Solutions Framework AngleCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Angle) | Compares this instance to a specified Angle and returns an indication of their relative values.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.CompareTo Method (Double)

Grid Solutions Framework AngleCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Angle Structure
CompareTo Overload
GSF.Units Namespace


Angle.CompareTo Method (Object)

Grid Solutions Framework AngleCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Angle.
See Also

Reference

Angle Structure
CompareTo Overload
GSF.Units Namespace


Angle.CompareTo Method (Angle)

Grid Solutions Framework AngleCompareTo Method (Angle)
Compares this instance to a specified Angle and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Angle value
)
Public Function CompareTo (
    value As Angle
) As Integer
abstract CompareTo :
        value : Angle -> int
override CompareTo :
        value : Angle -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Angle value
) sealed

Parameters

value
Type: GSF.UnitsAngle
An Angle to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Angle Structure
CompareTo Overload
GSF.Units Namespace


Angle.Equals Method

Grid Solutions Framework AngleEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Angle) | Returns a value indicating whether this instance is equal to a specified Angle value.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Equals Method (Double)

Grid Solutions Framework AngleEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Angle Structure
Equals Overload
GSF.Units Namespace


Angle.Equals Method (Object)

Grid Solutions Framework AngleEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Angle and equals the value of this instance; otherwise, False.
See Also

Reference

Angle Structure
Equals Overload
GSF.Units Namespace


Angle.Equals Method (Angle)

Grid Solutions Framework AngleEquals Method (Angle)
Returns a value indicating whether this instance is equal to a specified Angle value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Angle obj
)
Public Function Equals (
    obj As Angle
) As Boolean
abstract Equals :
        obj : Angle -> bool
override Equals :
        obj : Angle -> bool
function Equals(obj);
public:
virtual bool Equals(
    Angle obj
) sealed

Parameters

obj
Type: GSF.UnitsAngle
An Angle value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Angle Structure
Equals Overload
GSF.Units Namespace


Angle.FromAngularMil Method

Grid Solutions Framework AngleFromAngularMil Method
Creates a new Angle value from the specified value in angular mil.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle FromAngularMil(
    double value
)
Public Shared Function FromAngularMil (
    value As Double
) As Angle
static member FromAngularMil :
        value : float -> Angle

GSF.Units.Angle.FromAngularMil = function(value);
public:
static Angle FromAngularMil(
    double value
)

Parameters

value
Type: SystemDouble
New Angle value in angular mil.

Return Value

Type: Angle
New Angle object from the specified value in angular mil.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.FromArcMinutes Method

Grid Solutions Framework AngleFromArcMinutes Method
Creates a new Angle value from the specified value in arcminutes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle FromArcMinutes(
    double value
)
Public Shared Function FromArcMinutes (
    value As Double
) As Angle
static member FromArcMinutes :
        value : float -> Angle

GSF.Units.Angle.FromArcMinutes = function(value);
public:
static Angle FromArcMinutes(
    double value
)

Parameters

value
Type: SystemDouble
New Angle value in arcminutes.

Return Value

Type: Angle
New Angle object from the specified value in arcminutes.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.FromArcSeconds Method

Grid Solutions Framework AngleFromArcSeconds Method
Creates a new Angle value from the specified value in arcseconds.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle FromArcSeconds(
    double value
)
Public Shared Function FromArcSeconds (
    value As Double
) As Angle
static member FromArcSeconds :
        value : float -> Angle

GSF.Units.Angle.FromArcSeconds = function(value);
public:
static Angle FromArcSeconds(
    double value
)

Parameters

value
Type: SystemDouble
New Angle value in arcseconds.

Return Value

Type: Angle
New Angle object from the specified value in arcseconds.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.FromDegrees Method

Grid Solutions Framework AngleFromDegrees Method
Creates a new Angle value from the specified value in degrees.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle FromDegrees(
    double value
)
Public Shared Function FromDegrees (
    value As Double
) As Angle
static member FromDegrees :
        value : float -> Angle

GSF.Units.Angle.FromDegrees = function(value);
public:
static Angle FromDegrees(
    double value
)

Parameters

value
Type: SystemDouble
New Angle value in degrees.

Return Value

Type: Angle
New Angle object from the specified value in degrees.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.FromGrads Method

Grid Solutions Framework AngleFromGrads Method
Creates a new Angle value from the specified value in grads.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle FromGrads(
    double value
)
Public Shared Function FromGrads (
    value As Double
) As Angle
static member FromGrads :
        value : float -> Angle

GSF.Units.Angle.FromGrads = function(value);
public:
static Angle FromGrads(
    double value
)

Parameters

value
Type: SystemDouble
New Angle value in grads.

Return Value

Type: Angle
New Angle object from the specified value in grads.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.GetHashCode Method

Grid Solutions Framework AngleGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.GetTypeCode Method

Grid Solutions Framework AngleGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Parse Method

Grid Solutions Framework AngleParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Angle equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Angle equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Angle equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Parse Method (String)

Grid Solutions Framework AngleParse Method (String)
Converts the string representation of a number to its Angle equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Angle
static member Parse :
        s : string -> Angle

GSF.Units.Angle.Parse = function(s);
public:
static Angle Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Angle
An Angle equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Angle Structure
Parse Overload
GSF.Units Namespace


Angle.Parse Method (String, NumberStyles)

Grid Solutions Framework AngleParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Angle equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Angle
static member Parse :
        s : string *
        style : NumberStyles -> Angle

GSF.Units.Angle.Parse = function(s, style);
public:
static Angle Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Angle
An Angle equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Angle Structure
Parse Overload
GSF.Units Namespace


Angle.Parse Method (String, IFormatProvider)

Grid Solutions Framework AngleParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Angle equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Angle
static member Parse :
        s : string *
        provider : IFormatProvider -> Angle

GSF.Units.Angle.Parse = function(s, provider);
public:
static Angle Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Angle
An Angle equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Angle Structure
Parse Overload
GSF.Units Namespace


Angle.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework AngleParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Angle
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Angle

GSF.Units.Angle.Parse = function(s, style, provider);
public:
static Angle Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Angle
An Angle equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Angle Structure
Parse Overload
GSF.Units Namespace


Angle.ToAngularMil Method

Grid Solutions Framework AngleToAngularMil Method
Gets the Angle value in angular mil.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToAngularMil()
Public Function ToAngularMil As Double
member ToAngularMil : unit -> float

function ToAngularMil();
public:
double ToAngularMil()

Return Value

Type: Double
Value of Angle in angular mil.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.ToArcMinutes Method

Grid Solutions Framework AngleToArcMinutes Method
Gets the Angle value in arcminutes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToArcMinutes()
Public Function ToArcMinutes As Double
member ToArcMinutes : unit -> float

function ToArcMinutes();
public:
double ToArcMinutes()

Return Value

Type: Double
Value of Angle in arcminutes.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.ToArcSeconds Method

Grid Solutions Framework AngleToArcSeconds Method
Gets the Angle value in arcseconds.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToArcSeconds()
Public Function ToArcSeconds As Double
member ToArcSeconds : unit -> float

function ToArcSeconds();
public:
double ToArcSeconds()

Return Value

Type: Double
Value of Angle in arcseconds.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.ToDegrees Method

Grid Solutions Framework AngleToDegrees Method
Gets the Angle value in degrees.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToDegrees()
Public Function ToDegrees As Double
member ToDegrees : unit -> float

function ToDegrees();
public:
double ToDegrees()

Return Value

Type: Double
Value of Angle in degrees.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.ToGrads Method

Grid Solutions Framework AngleToGrads Method
Gets the Angle value in grads.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToGrads()
Public Function ToGrads As Double
member ToGrads : unit -> float

function ToGrads();
public:
double ToGrads()

Return Value

Type: Double
Value of Angle in grads.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.ToRange Method

Grid Solutions Framework AngleToRange Method
Gets the equivalent angle moved within the range of minValue and minValue + 2.0 * PI.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Angle ToRange(
    Angle minValue,
    bool inclusive = true
)
Public Function ToRange (
    minValue As Angle,
    Optional inclusive As Boolean = true
) As Angle
member ToRange :
        minValue : Angle *
        ?inclusive : bool
(* Defaults:
        let _inclusive = defaultArg inclusive true
*)
-> Angle

function ToRange(minValue, inclusive);
public:
Angle ToRange(
    Angle minValue,
    bool inclusive = true
)

Parameters

minValue
Type: GSF.UnitsAngle
The minimum value of the range.
inclusive (Optional)
Type: SystemBoolean
Indicates whether the range is inclusive of the minimum value.

Return Value

Type: Angle
The equivalent angle within the specified range.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.ToString Method

Grid Solutions Framework AngleToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.ToString Method

Grid Solutions Framework AngleToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Angle Structure
ToString Overload
GSF.Units Namespace


Angle.ToString Method (IFormatProvider)

Grid Solutions Framework AngleToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Angle Structure
ToString Overload
GSF.Units Namespace


Angle.ToString Method (String)

Grid Solutions Framework AngleToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Angle Structure
ToString Overload
GSF.Units Namespace


Angle.ToString Method (String, IFormatProvider)

Grid Solutions Framework AngleToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Angle Structure
ToString Overload
GSF.Units Namespace


Angle.TryParse Method

Grid Solutions Framework AngleTryParse Method
Overload List
Name | Description
TryParse(String, Angle) | Converts the string representation of a number to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Angle) | Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.TryParse Method (String, Angle)

Grid Solutions Framework AngleTryParse Method (String, Angle)
Converts the string representation of a number to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Angle result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Angle
) As Boolean
static member TryParse :
        s : string *
        result : Angle byref -> bool

GSF.Units.Angle.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Angle% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsAngle
When this method returns, contains the Angle value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Angle Structure
TryParse Overload
GSF.Units Namespace


Angle.TryParse Method (String, NumberStyles, IFormatProvider, Angle)

Grid Solutions Framework AngleTryParse Method (String, NumberStyles, IFormatProvider, Angle)
Converts the string representation of a number in a specified style and culture-specific format to its Angle equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Angle result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Angle
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Angle byref -> bool

GSF.Units.Angle.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Angle% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsAngle
When this method returns, contains the Angle value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Angle Structure
TryParse Overload
GSF.Units Namespace


Angle Operators and Type Conversions

Grid Solutions Framework Angle Operators and Type Conversions

The Angle type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Angle) | Implicitly converts value, represented in radians, to an Angle.
(Angle to Double) | Implicitly converts Angle, represented in radians, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Addition Operator

Grid Solutions Framework AngleAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle operator +(
    Angle value1,
    Angle value2
)
Public Shared Operator + (
    value1 As Angle,
    value2 As Angle
) As Angle
static let inline (+)
        value1 : Angle *
        value2 : Angle  : Angle
JavaScript does not support overloaded operators.
public:
static Angle operator +(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Angle
An Angle as the result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Division Operator

Grid Solutions Framework AngleDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle operator /(
    Angle value1,
    Angle value2
)
Public Shared Operator / (
    value1 As Angle,
    value2 As Angle
) As Angle
static let inline (/)
        value1 : Angle *
        value2 : Angle  : Angle
JavaScript does not support overloaded operators.
public:
static Angle operator /(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Angle
An Angle as the result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Equality Operator

Grid Solutions Framework AngleEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Angle value1,
    Angle value2
)
Public Shared Operator = (
    value1 As Angle,
    value2 As Angle
) As Boolean
static let inline (=)
        value1 : Angle *
        value2 : Angle  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Boolean
A Boolean as the operation result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Exponent Operator

Grid Solutions Framework AngleExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Angle,
    value2 As Angle
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Double
A Double as the result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.GreaterThan Operator

Grid Solutions Framework AngleGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Angle value1,
    Angle value2
)
Public Shared Operator > (
    value1 As Angle,
    value2 As Angle
) As Boolean
static let inline (>)
        value1 : Angle *
        value2 : Angle  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Boolean
A Boolean as the operation result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.GreaterThanOrEqual Operator

Grid Solutions Framework AngleGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Angle value1,
    Angle value2
)
Public Shared Operator >= (
    value1 As Angle,
    value2 As Angle
) As Boolean
static let inline (>=)
        value1 : Angle *
        value2 : Angle  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Boolean
A Boolean as the operation result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle Implicit Conversion Operators

Grid Solutions Framework Angle Conversion Operators
Overload List
Name | Description
(Double to Angle) | Implicitly converts value, represented in radians, to an Angle.
(Angle to Double) | Implicitly converts Angle, represented in radians, to a Double.
Top
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle Implicit Conversion (Double to Angle)

Grid Solutions Framework Angle Conversion (Double to Angle)
Implicitly converts value, represented in radians, to an Angle.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Angle (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Angle
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Angle (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Angle
An Angle object.
See Also

Reference

Angle Structure
Overload
GSF.Units Namespace


Angle Implicit Conversion (Angle to Double)

Grid Solutions Framework Angle Conversion (Angle to Double)
Implicitly converts Angle, represented in radians, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Angle value
)
Public Shared Widening Operator CType (
    value As Angle
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Angle value
)

Parameters

value
Type: GSF.UnitsAngle
An Angle object.

Return Value

Type: Double
A Double value.
See Also

Reference

Angle Structure
Overload
GSF.Units Namespace


Angle.Inequality Operator

Grid Solutions Framework AngleInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Angle value1,
    Angle value2
)
Public Shared Operator <> (
    value1 As Angle,
    value2 As Angle
) As Boolean
static let inline (<>)
        value1 : Angle *
        value2 : Angle  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Boolean
A Boolean as the operation result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.LessThan Operator

Grid Solutions Framework AngleLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Angle value1,
    Angle value2
)
Public Shared Operator < (
    value1 As Angle,
    value2 As Angle
) As Boolean
static let inline (<)
        value1 : Angle *
        value2 : Angle  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Boolean
A Boolean as the operation result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.LessThanOrEqual Operator

Grid Solutions Framework AngleLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Angle value1,
    Angle value2
)
Public Shared Operator <= (
    value1 As Angle,
    value2 As Angle
) As Boolean
static let inline (<=)
        value1 : Angle *
        value2 : Angle  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Boolean
A Boolean as the operation result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Modulus Operator

Grid Solutions Framework AngleModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle operator %(
    Angle value1,
    Angle value2
)
Public Shared Operator Mod (
    value1 As Angle,
    value2 As Angle
) As Angle
static let inline (%)
        value1 : Angle *
        value2 : Angle  : Angle
JavaScript does not support overloaded operators.
public:
static Angle operator %(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Angle
An Angle as the result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Multiply Operator

Grid Solutions Framework AngleMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle operator *(
    Angle value1,
    Angle value2
)
Public Shared Operator * (
    value1 As Angle,
    value2 As Angle
) As Angle
static let inline (*)
        value1 : Angle *
        value2 : Angle  : Angle
JavaScript does not support overloaded operators.
public:
static Angle operator *(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Angle
An Angle as the result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Angle.Subtraction Operator

Grid Solutions Framework AngleSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Angle operator -(
    Angle value1,
    Angle value2
)
Public Shared Operator - (
    value1 As Angle,
    value2 As Angle
) As Angle
static let inline (-)
        value1 : Angle *
        value2 : Angle  : Angle
JavaScript does not support overloaded operators.
public:
static Angle operator -(
    Angle value1,
    Angle value2
)

Parameters

value1
Type: GSF.UnitsAngle
An Angle as the left hand operand.
value2
Type: GSF.UnitsAngle
An Angle as the right hand operand.

Return Value

Type: Angle
An Angle as the result.
See Also

Reference

Angle Structure
GSF.Units Namespace


Charge Structure

Grid Solutions Framework Charge Structure
Represents an electric charge measurement, in coulombs (i.e., ampere-seconds), as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Charge : IComparable, IFormattable,
    IConvertible, IComparable<Charge>, IComparable<double>, IEquatable<Charge>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Charge
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Charge),
    IComparable(Of Double), IEquatable(Of Charge), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Charge =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Charge>
        interface IComparable<float>
        interface IEquatable<Charge>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Charge : IComparable,
    IFormattable, IConvertible, IComparable<Charge>, IComparable<double>,
    IEquatable<Charge>, IEquatable<double>

The Charge type exposes the following members.

Constructors
 | Name | Description
Public method | Charge | Creates a new Charge.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Charge) | Compares this instance to a specified Charge and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Charge) | Returns a value indicating whether this instance is equal to a specified Charge value.
 | FromAbcoulombs | Creates a new Charge value from the specified value in abcoulombs.
 | FromAmpereHours | Creates a new Charge value from the specified value in ampere-hours.
 | FromAtomicUnitsOfCharge | Creates a new Charge value from the specified value in atomic units of charge.
 | FromFaraday | Creates a new Charge value from the specified value in faraday.
 | FromStatcoulombs | Creates a new Charge value from the specified value in statcoulombs.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Charge equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Charge equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Charge equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent.
Public method | ToAbcoulombs | Gets the Charge value in abcoulombs.
Public method | ToAmpereHours | Gets the Energy value in ampere-hours.
Public method | ToAtomicUnitsOfCharge | Gets the Charge value in atomic units of charge.
Public method | ToFaraday | Gets the Charge value in faraday.
Public method | ToStatcoulombs | Gets the Charge value in statcoulombs.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Charge) | Converts the string representation of a number to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Charge) | Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to charge of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Charge) | Implicitly converts value, represented in coulombs, to a Charge.
(Charge to Double) | Implicitly converts Charge, represented in coulombs, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Charge. This field is constant.
MinValue | Represents the smallest possible value of an Charge. This field is constant.
Top
Remarks
This class behaves just like a Double representing a charge in coulombs; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other charge representations, specifically ampere-hours, abcoulomb (a.k.a., an electromagnetic unit), statcoulomb (a.k.a., electrostatic unit or franklin), atomic unit of charge and faraday. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert charge, in coulombs, to kilocoulombs:
Copy
public double GetKilocoulombs(Charge coulombs)
{
    return coulombs / SI.Kilo;
}
See Also

Reference

GSF.Units Namespace


Charge Constructor

Grid Solutions Framework Charge Constructor
Creates a new Charge.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Charge(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Charge
GSF.Units.Charge = function(value);
public:
Charge(
    double value
)

Parameters

value
Type: SystemDouble
New charge value in coulombs.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge Fields

Grid Solutions Framework Charge Fields

The Charge type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Charge. This field is constant.
MinValue | Represents the smallest possible value of an Charge. This field is constant.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.MaxValue Field

Grid Solutions Framework ChargeMaxValue Field
Represents the largest possible value of an Charge. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Charge MaxValue
Public Shared ReadOnly MaxValue As Charge
static val MaxValue: Charge
var GSF.Units.Charge.MaxValue
public:
static initonly Charge MaxValue

Field Value

Type: Charge
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.MinValue Field

Grid Solutions Framework ChargeMinValue Field
Represents the smallest possible value of an Charge. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Charge MinValue
Public Shared ReadOnly MinValue As Charge
static val MinValue: Charge
var GSF.Units.Charge.MinValue
public:
static initonly Charge MinValue

Field Value

Type: Charge
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge Methods

Grid Solutions Framework Charge Methods

The Charge type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Charge) | Compares this instance to a specified Charge and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Charge) | Returns a value indicating whether this instance is equal to a specified Charge value.
 | FromAbcoulombs | Creates a new Charge value from the specified value in abcoulombs.
 | FromAmpereHours | Creates a new Charge value from the specified value in ampere-hours.
 | FromAtomicUnitsOfCharge | Creates a new Charge value from the specified value in atomic units of charge.
 | FromFaraday | Creates a new Charge value from the specified value in faraday.
 | FromStatcoulombs | Creates a new Charge value from the specified value in statcoulombs.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Charge equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Charge equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Charge equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent.
Public method | ToAbcoulombs | Gets the Charge value in abcoulombs.
Public method | ToAmpereHours | Gets the Energy value in ampere-hours.
Public method | ToAtomicUnitsOfCharge | Gets the Charge value in atomic units of charge.
Public method | ToFaraday | Gets the Charge value in faraday.
Public method | ToStatcoulombs | Gets the Charge value in statcoulombs.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Charge) | Converts the string representation of a number to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Charge) | Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.CompareTo Method

Grid Solutions Framework ChargeCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Charge) | Compares this instance to a specified Charge and returns an indication of their relative values.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.CompareTo Method (Double)

Grid Solutions Framework ChargeCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Charge Structure
CompareTo Overload
GSF.Units Namespace


Charge.CompareTo Method (Object)

Grid Solutions Framework ChargeCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Charge.
See Also

Reference

Charge Structure
CompareTo Overload
GSF.Units Namespace


Charge.CompareTo Method (Charge)

Grid Solutions Framework ChargeCompareTo Method (Charge)
Compares this instance to a specified Charge and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Charge value
)
Public Function CompareTo (
    value As Charge
) As Integer
abstract CompareTo :
        value : Charge -> int
override CompareTo :
        value : Charge -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Charge value
) sealed

Parameters

value
Type: GSF.UnitsCharge
A Charge to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Charge Structure
CompareTo Overload
GSF.Units Namespace


Charge.Equals Method

Grid Solutions Framework ChargeEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Charge) | Returns a value indicating whether this instance is equal to a specified Charge value.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Equals Method (Double)

Grid Solutions Framework ChargeEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Charge Structure
Equals Overload
GSF.Units Namespace


Charge.Equals Method (Object)

Grid Solutions Framework ChargeEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Charge and equals the value of this instance; otherwise, False.
See Also

Reference

Charge Structure
Equals Overload
GSF.Units Namespace


Charge.Equals Method (Charge)

Grid Solutions Framework ChargeEquals Method (Charge)
Returns a value indicating whether this instance is equal to a specified Charge value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Charge obj
)
Public Function Equals (
    obj As Charge
) As Boolean
abstract Equals :
        obj : Charge -> bool
override Equals :
        obj : Charge -> bool
function Equals(obj);
public:
virtual bool Equals(
    Charge obj
) sealed

Parameters

obj
Type: GSF.UnitsCharge
A Charge value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Charge Structure
Equals Overload
GSF.Units Namespace


Charge.FromAbcoulombs Method

Grid Solutions Framework ChargeFromAbcoulombs Method
Creates a new Charge value from the specified value in abcoulombs.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge FromAbcoulombs(
    double value
)
Public Shared Function FromAbcoulombs (
    value As Double
) As Charge
static member FromAbcoulombs :
        value : float -> Charge

GSF.Units.Charge.FromAbcoulombs = function(value);
public:
static Charge FromAbcoulombs(
    double value
)

Parameters

value
Type: SystemDouble
New Charge value in abcoulombs.

Return Value

Type: Charge
New Charge object from the specified value in abcoulombs.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.FromAmpereHours Method

Grid Solutions Framework ChargeFromAmpereHours Method
Creates a new Charge value from the specified value in ampere-hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge FromAmpereHours(
    double value
)
Public Shared Function FromAmpereHours (
    value As Double
) As Charge
static member FromAmpereHours :
        value : float -> Charge

GSF.Units.Charge.FromAmpereHours = function(value);
public:
static Charge FromAmpereHours(
    double value
)

Parameters

value
Type: SystemDouble
New Charge value in ampere-hours.

Return Value

Type: Charge
New Charge object from the specified value in ampere-hours.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.FromAtomicUnitsOfCharge Method

Grid Solutions Framework ChargeFromAtomicUnitsOfCharge Method
Creates a new Charge value from the specified value in atomic units of charge.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge FromAtomicUnitsOfCharge(
    double value
)
Public Shared Function FromAtomicUnitsOfCharge (
    value As Double
) As Charge
static member FromAtomicUnitsOfCharge :
        value : float -> Charge

GSF.Units.Charge.FromAtomicUnitsOfCharge = function(value);
public:
static Charge FromAtomicUnitsOfCharge(
    double value
)

Parameters

value
Type: SystemDouble
New Charge value in atomic units of charge.

Return Value

Type: Charge
New Charge object from the specified value in atomic units of charge.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.FromFaraday Method

Grid Solutions Framework ChargeFromFaraday Method
Creates a new Charge value from the specified value in faraday.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge FromFaraday(
    double value
)
Public Shared Function FromFaraday (
    value As Double
) As Charge
static member FromFaraday :
        value : float -> Charge

GSF.Units.Charge.FromFaraday = function(value);
public:
static Charge FromFaraday(
    double value
)

Parameters

value
Type: SystemDouble
New Charge value in faraday.

Return Value

Type: Charge
New Charge object from the specified value in faraday.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.FromStatcoulombs Method

Grid Solutions Framework ChargeFromStatcoulombs Method
Creates a new Charge value from the specified value in statcoulombs.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge FromStatcoulombs(
    double value
)
Public Shared Function FromStatcoulombs (
    value As Double
) As Charge
static member FromStatcoulombs :
        value : float -> Charge

GSF.Units.Charge.FromStatcoulombs = function(value);
public:
static Charge FromStatcoulombs(
    double value
)

Parameters

value
Type: SystemDouble
New Charge value in statcoulombs.

Return Value

Type: Charge
New Charge object from the specified value in statcoulombs.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.GetHashCode Method

Grid Solutions Framework ChargeGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.GetTypeCode Method

Grid Solutions Framework ChargeGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Parse Method

Grid Solutions Framework ChargeParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Charge equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Charge equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Charge equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Parse Method (String)

Grid Solutions Framework ChargeParse Method (String)
Converts the string representation of a number to its Charge equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Charge
static member Parse :
        s : string -> Charge

GSF.Units.Charge.Parse = function(s);
public:
static Charge Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Charge
A Charge equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Charge Structure
Parse Overload
GSF.Units Namespace


Charge.Parse Method (String, NumberStyles)

Grid Solutions Framework ChargeParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Charge equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Charge
static member Parse :
        s : string *
        style : NumberStyles -> Charge

GSF.Units.Charge.Parse = function(s, style);
public:
static Charge Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Charge
A Charge equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Charge Structure
Parse Overload
GSF.Units Namespace


Charge.Parse Method (String, IFormatProvider)

Grid Solutions Framework ChargeParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Charge equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Charge
static member Parse :
        s : string *
        provider : IFormatProvider -> Charge

GSF.Units.Charge.Parse = function(s, provider);
public:
static Charge Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Charge
A Charge equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Charge Structure
Parse Overload
GSF.Units Namespace


Charge.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework ChargeParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Charge
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Charge

GSF.Units.Charge.Parse = function(s, style, provider);
public:
static Charge Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Charge
A Charge equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Charge Structure
Parse Overload
GSF.Units Namespace


Charge.ToAbcoulombs Method

Grid Solutions Framework ChargeToAbcoulombs Method
Gets the Charge value in abcoulombs.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToAbcoulombs()
Public Function ToAbcoulombs As Double
member ToAbcoulombs : unit -> float

function ToAbcoulombs();
public:
double ToAbcoulombs()

Return Value

Type: Double
Value of Charge in abcoulombs.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.ToAmpereHours Method

Grid Solutions Framework ChargeToAmpereHours Method
Gets the Energy value in ampere-hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToAmpereHours()
Public Function ToAmpereHours As Double
member ToAmpereHours : unit -> float

function ToAmpereHours();
public:
double ToAmpereHours()

Return Value

Type: Double
Value of Energy in ampere-hours.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.ToAtomicUnitsOfCharge Method

Grid Solutions Framework ChargeToAtomicUnitsOfCharge Method
Gets the Charge value in atomic units of charge.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToAtomicUnitsOfCharge()
Public Function ToAtomicUnitsOfCharge As Double
member ToAtomicUnitsOfCharge : unit -> float

function ToAtomicUnitsOfCharge();
public:
double ToAtomicUnitsOfCharge()

Return Value

Type: Double
Value of Charge in atomic units of charge.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.ToFaraday Method

Grid Solutions Framework ChargeToFaraday Method
Gets the Charge value in faraday.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToFaraday()
Public Function ToFaraday As Double
member ToFaraday : unit -> float

function ToFaraday();
public:
double ToFaraday()

Return Value

Type: Double
Value of Charge in faraday.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.ToStatcoulombs Method

Grid Solutions Framework ChargeToStatcoulombs Method
Gets the Charge value in statcoulombs.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToStatcoulombs()
Public Function ToStatcoulombs As Double
member ToStatcoulombs : unit -> float

function ToStatcoulombs();
public:
double ToStatcoulombs()

Return Value

Type: Double
Value of Charge in statcoulombs.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.ToString Method

Grid Solutions Framework ChargeToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.ToString Method

Grid Solutions Framework ChargeToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Charge Structure
ToString Overload
GSF.Units Namespace


Charge.ToString Method (IFormatProvider)

Grid Solutions Framework ChargeToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Charge Structure
ToString Overload
GSF.Units Namespace


Charge.ToString Method (String)

Grid Solutions Framework ChargeToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Charge Structure
ToString Overload
GSF.Units Namespace


Charge.ToString Method (String, IFormatProvider)

Grid Solutions Framework ChargeToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Charge Structure
ToString Overload
GSF.Units Namespace


Charge.TryParse Method

Grid Solutions Framework ChargeTryParse Method
Overload List
Name | Description
TryParse(String, Charge) | Converts the string representation of a number to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Charge) | Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.TryParse Method (String, Charge)

Grid Solutions Framework ChargeTryParse Method (String, Charge)
Converts the string representation of a number to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Charge result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Charge
) As Boolean
static member TryParse :
        s : string *
        result : Charge byref -> bool

GSF.Units.Charge.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Charge% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsCharge
When this method returns, contains the Charge value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paracoulomb is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This paracoulomb is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Charge Structure
TryParse Overload
GSF.Units Namespace


Charge.TryParse Method (String, NumberStyles, IFormatProvider, Charge)

Grid Solutions Framework ChargeTryParse Method (String, NumberStyles, IFormatProvider, Charge)
Converts the string representation of a number in a specified style and culture-specific format to its Charge equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Charge result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Charge
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Charge byref -> bool

GSF.Units.Charge.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Charge% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsCharge
When this method returns, contains the Charge value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paracoulomb is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This paracoulomb is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Charge Structure
TryParse Overload
GSF.Units Namespace


Charge Operators and Type Conversions

Grid Solutions Framework Charge Operators and Type Conversions

The Charge type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to charge of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Charge) | Implicitly converts value, represented in coulombs, to a Charge.
(Charge to Double) | Implicitly converts Charge, represented in coulombs, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Addition Operator

Grid Solutions Framework ChargeAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge operator +(
    Charge value1,
    Charge value2
)
Public Shared Operator + (
    value1 As Charge,
    value2 As Charge
) As Charge
static let inline (+)
        value1 : Charge *
        value2 : Charge  : Charge
JavaScript does not support overloaded operators.
public:
static Charge operator +(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Charge
A Charge object as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Division Operator

Grid Solutions Framework ChargeDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge operator /(
    Charge value1,
    Charge value2
)
Public Shared Operator / (
    value1 As Charge,
    value2 As Charge
) As Charge
static let inline (/)
        value1 : Charge *
        value2 : Charge  : Charge
JavaScript does not support overloaded operators.
public:
static Charge operator /(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Charge
A Charge object as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Equality Operator

Grid Solutions Framework ChargeEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Charge value1,
    Charge value2
)
Public Shared Operator = (
    value1 As Charge,
    value2 As Charge
) As Boolean
static let inline (=)
        value1 : Charge *
        value2 : Charge  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Exponent Operator

Grid Solutions Framework ChargeExponent Operator
Returns result of first value raised to charge of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Charge,
    value2 As Charge
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Double
A Double as the result.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.GreaterThan Operator

Grid Solutions Framework ChargeGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Charge value1,
    Charge value2
)
Public Shared Operator > (
    value1 As Charge,
    value2 As Charge
) As Boolean
static let inline (>)
        value1 : Charge *
        value2 : Charge  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.GreaterThanOrEqual Operator

Grid Solutions Framework ChargeGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Charge value1,
    Charge value2
)
Public Shared Operator >= (
    value1 As Charge,
    value2 As Charge
) As Boolean
static let inline (>=)
        value1 : Charge *
        value2 : Charge  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge Implicit Conversion Operators

Grid Solutions Framework Charge Conversion Operators
Overload List
Name | Description
(Double to Charge) | Implicitly converts value, represented in coulombs, to a Charge.
(Charge to Double) | Implicitly converts Charge, represented in coulombs, to a Double.
Top
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge Implicit Conversion (Double to Charge)

Grid Solutions Framework Charge Conversion (Double to Charge)
Implicitly converts value, represented in coulombs, to a Charge.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Charge (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Charge
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Charge (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Charge
A Charge value.
See Also

Reference

Charge Structure
Overload
GSF.Units Namespace


Charge Implicit Conversion (Charge to Double)

Grid Solutions Framework Charge Conversion (Charge to Double)
Implicitly converts Charge, represented in coulombs, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Charge value
)
Public Shared Widening Operator CType (
    value As Charge
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Charge value
)

Parameters

value
Type: GSF.UnitsCharge
A Charge value.

Return Value

Type: Double
A Double value.
See Also

Reference

Charge Structure
Overload
GSF.Units Namespace


Charge.Inequality Operator

Grid Solutions Framework ChargeInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Charge value1,
    Charge value2
)
Public Shared Operator <> (
    value1 As Charge,
    value2 As Charge
) As Boolean
static let inline (<>)
        value1 : Charge *
        value2 : Charge  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.LessThan Operator

Grid Solutions Framework ChargeLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Charge value1,
    Charge value2
)
Public Shared Operator < (
    value1 As Charge,
    value2 As Charge
) As Boolean
static let inline (<)
        value1 : Charge *
        value2 : Charge  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.LessThanOrEqual Operator

Grid Solutions Framework ChargeLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Charge value1,
    Charge value2
)
Public Shared Operator <= (
    value1 As Charge,
    value2 As Charge
) As Boolean
static let inline (<=)
        value1 : Charge *
        value2 : Charge  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Modulus Operator

Grid Solutions Framework ChargeModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge operator %(
    Charge value1,
    Charge value2
)
Public Shared Operator Mod (
    value1 As Charge,
    value2 As Charge
) As Charge
static let inline (%)
        value1 : Charge *
        value2 : Charge  : Charge
JavaScript does not support overloaded operators.
public:
static Charge operator %(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Charge
A Charge object as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Multiply Operator

Grid Solutions Framework ChargeMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge operator *(
    Charge value1,
    Charge value2
)
Public Shared Operator * (
    value1 As Charge,
    value2 As Charge
) As Charge
static let inline (*)
        value1 : Charge *
        value2 : Charge  : Charge
JavaScript does not support overloaded operators.
public:
static Charge operator *(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Charge
A Charge object as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Charge.Subtraction Operator

Grid Solutions Framework ChargeSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Charge operator -(
    Charge value1,
    Charge value2
)
Public Shared Operator - (
    value1 As Charge,
    value2 As Charge
) As Charge
static let inline (-)
        value1 : Charge *
        value2 : Charge  : Charge
JavaScript does not support overloaded operators.
public:
static Charge operator -(
    Charge value1,
    Charge value2
)

Parameters

value1
Type: GSF.UnitsCharge
A Charge object as the left hand operand.
value2
Type: GSF.UnitsCharge
A Charge object as the right hand operand.

Return Value

Type: Charge
A Charge object as the result of the operation.
See Also

Reference

Charge Structure
GSF.Units Namespace


Current Structure

Grid Solutions Framework Current Structure
Represents an electric current measurement, in amperes, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Current : IComparable, IFormattable,
    IConvertible, IComparable<Current>, IComparable<double>, IEquatable<Current>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Current
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Current),
    IComparable(Of Double), IEquatable(Of Current), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Current =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Current>
        interface IComparable<float>
        interface IEquatable<Current>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Current : IComparable,
    IFormattable, IConvertible, IComparable<Current>, IComparable<double>,
    IEquatable<Current>, IEquatable<double>

The Current type exposes the following members.

Constructors
 | Name | Description
Public method | Current | Creates a new Current.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Current) | Compares this instance to a specified Current and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Current) | Returns a value indicating whether this instance is equal to a specified Current value.
 | FromAbamperes | Creates a new Current value from the specified value in abamperes.
 | FromStatamperes | Creates a new Current value from the specified value in statamperes.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Current equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Current equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Current equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent.
Public method | ToAbamperes | Gets the Current value in abamperes.
Public method | ToStatamperes | Gets the Current value in statamperes.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Current) | Converts the string representation of a number to its Current equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Current) | Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to current of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Current) | Implicitly converts value, represented in amperes, to a Current.
(Current to Double) | Implicitly converts Current, represented in amperes, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Current. This field is constant.
MinValue | Represents the smallest possible value of an Current. This field is constant.
Top
Remarks
This class behaves just like a Double representing a current in amperes; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other current representations, specifically abampere (a.k.a., an electromagnetic unit) and statampere (a.k.a., esu per second). Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert current, in amperes, to kiloamperes:
Copy
public double GetKiloamperes(Current amperes)
{
    return amperes / SI.Kilo;
}
See Also

Reference

GSF.Units Namespace


Current Constructor

Grid Solutions Framework Current Constructor
Creates a new Current.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Current(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Current
GSF.Units.Current = function(value);
public:
Current(
    double value
)

Parameters

value
Type: SystemDouble
New current value in amperes.
See Also

Reference

Current Structure
GSF.Units Namespace


Current Fields

Grid Solutions Framework Current Fields

The Current type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Current. This field is constant.
MinValue | Represents the smallest possible value of an Current. This field is constant.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.MaxValue Field

Grid Solutions Framework CurrentMaxValue Field
Represents the largest possible value of an Current. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Current MaxValue
Public Shared ReadOnly MaxValue As Current
static val MaxValue: Current
var GSF.Units.Current.MaxValue
public:
static initonly Current MaxValue

Field Value

Type: Current
See Also

Reference

Current Structure
GSF.Units Namespace


Current.MinValue Field

Grid Solutions Framework CurrentMinValue Field
Represents the smallest possible value of an Current. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Current MinValue
Public Shared ReadOnly MinValue As Current
static val MinValue: Current
var GSF.Units.Current.MinValue
public:
static initonly Current MinValue

Field Value

Type: Current
See Also

Reference

Current Structure
GSF.Units Namespace


Current Methods

Grid Solutions Framework Current Methods

The Current type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Current) | Compares this instance to a specified Current and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Current) | Returns a value indicating whether this instance is equal to a specified Current value.
 | FromAbamperes | Creates a new Current value from the specified value in abamperes.
 | FromStatamperes | Creates a new Current value from the specified value in statamperes.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Current equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Current equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Current equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent.
Public method | ToAbamperes | Gets the Current value in abamperes.
Public method | ToStatamperes | Gets the Current value in statamperes.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Current) | Converts the string representation of a number to its Current equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Current) | Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.CompareTo Method

Grid Solutions Framework CurrentCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Current) | Compares this instance to a specified Current and returns an indication of their relative values.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.CompareTo Method (Double)

Grid Solutions Framework CurrentCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Current Structure
CompareTo Overload
GSF.Units Namespace


Current.CompareTo Method (Object)

Grid Solutions Framework CurrentCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Current.
See Also

Reference

Current Structure
CompareTo Overload
GSF.Units Namespace


Current.CompareTo Method (Current)

Grid Solutions Framework CurrentCompareTo Method (Current)
Compares this instance to a specified Current and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Current value
)
Public Function CompareTo (
    value As Current
) As Integer
abstract CompareTo :
        value : Current -> int
override CompareTo :
        value : Current -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Current value
) sealed

Parameters

value
Type: GSF.UnitsCurrent
A Current to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Current Structure
CompareTo Overload
GSF.Units Namespace


Current.Equals Method

Grid Solutions Framework CurrentEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Current) | Returns a value indicating whether this instance is equal to a specified Current value.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Equals Method (Double)

Grid Solutions Framework CurrentEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Current Structure
Equals Overload
GSF.Units Namespace


Current.Equals Method (Object)

Grid Solutions Framework CurrentEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Current and equals the value of this instance; otherwise, False.
See Also

Reference

Current Structure
Equals Overload
GSF.Units Namespace


Current.Equals Method (Current)

Grid Solutions Framework CurrentEquals Method (Current)
Returns a value indicating whether this instance is equal to a specified Current value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Current obj
)
Public Function Equals (
    obj As Current
) As Boolean
abstract Equals :
        obj : Current -> bool
override Equals :
        obj : Current -> bool
function Equals(obj);
public:
virtual bool Equals(
    Current obj
) sealed

Parameters

obj
Type: GSF.UnitsCurrent
A Current value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Current Structure
Equals Overload
GSF.Units Namespace


Current.FromAbamperes Method

Grid Solutions Framework CurrentFromAbamperes Method
Creates a new Current value from the specified value in abamperes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current FromAbamperes(
    double value
)
Public Shared Function FromAbamperes (
    value As Double
) As Current
static member FromAbamperes :
        value : float -> Current

GSF.Units.Current.FromAbamperes = function(value);
public:
static Current FromAbamperes(
    double value
)

Parameters

value
Type: SystemDouble
New Current value in abamperes.

Return Value

Type: Current
New Current object from the specified value in abamperes.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.FromStatamperes Method

Grid Solutions Framework CurrentFromStatamperes Method
Creates a new Current value from the specified value in statamperes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current FromStatamperes(
    double value
)
Public Shared Function FromStatamperes (
    value As Double
) As Current
static member FromStatamperes :
        value : float -> Current

GSF.Units.Current.FromStatamperes = function(value);
public:
static Current FromStatamperes(
    double value
)

Parameters

value
Type: SystemDouble
New Current value in statamperes.

Return Value

Type: Current
New Current object from the specified value in statamperes.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.GetHashCode Method

Grid Solutions Framework CurrentGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.GetTypeCode Method

Grid Solutions Framework CurrentGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Parse Method

Grid Solutions Framework CurrentParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Current equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Current equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Current equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Parse Method (String)

Grid Solutions Framework CurrentParse Method (String)
Converts the string representation of a number to its Current equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Current
static member Parse :
        s : string -> Current

GSF.Units.Current.Parse = function(s);
public:
static Current Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Current
A Current equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Current Structure
Parse Overload
GSF.Units Namespace


Current.Parse Method (String, NumberStyles)

Grid Solutions Framework CurrentParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Current equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Current
static member Parse :
        s : string *
        style : NumberStyles -> Current

GSF.Units.Current.Parse = function(s, style);
public:
static Current Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Current
A Current equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Current Structure
Parse Overload
GSF.Units Namespace


Current.Parse Method (String, IFormatProvider)

Grid Solutions Framework CurrentParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Current equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Current
static member Parse :
        s : string *
        provider : IFormatProvider -> Current

GSF.Units.Current.Parse = function(s, provider);
public:
static Current Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Current
A Current equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Current Structure
Parse Overload
GSF.Units Namespace


Current.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework CurrentParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Current
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Current

GSF.Units.Current.Parse = function(s, style, provider);
public:
static Current Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Current
A Current equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Current Structure
Parse Overload
GSF.Units Namespace


Current.ToAbamperes Method

Grid Solutions Framework CurrentToAbamperes Method
Gets the Current value in abamperes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToAbamperes()
Public Function ToAbamperes As Double
member ToAbamperes : unit -> float

function ToAbamperes();
public:
double ToAbamperes()

Return Value

Type: Double
Value of Current in abamperes.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.ToStatamperes Method

Grid Solutions Framework CurrentToStatamperes Method
Gets the Current value in statamperes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToStatamperes()
Public Function ToStatamperes As Double
member ToStatamperes : unit -> float

function ToStatamperes();
public:
double ToStatamperes()

Return Value

Type: Double
Value of Current in statamperes.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.ToString Method

Grid Solutions Framework CurrentToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.ToString Method

Grid Solutions Framework CurrentToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Current Structure
ToString Overload
GSF.Units Namespace


Current.ToString Method (IFormatProvider)

Grid Solutions Framework CurrentToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Current Structure
ToString Overload
GSF.Units Namespace


Current.ToString Method (String)

Grid Solutions Framework CurrentToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Current Structure
ToString Overload
GSF.Units Namespace


Current.ToString Method (String, IFormatProvider)

Grid Solutions Framework CurrentToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Current Structure
ToString Overload
GSF.Units Namespace


Current.TryParse Method

Grid Solutions Framework CurrentTryParse Method
Overload List
Name | Description
TryParse(String, Current) | Converts the string representation of a number to its Current equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Current) | Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.TryParse Method (String, Current)

Grid Solutions Framework CurrentTryParse Method (String, Current)
Converts the string representation of a number to its Current equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Current result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Current
) As Boolean
static member TryParse :
        s : string *
        result : Current byref -> bool

GSF.Units.Current.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Current% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsCurrent
When this method returns, contains the Current value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paraampere is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This paraampere is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Current Structure
TryParse Overload
GSF.Units Namespace


Current.TryParse Method (String, NumberStyles, IFormatProvider, Current)

Grid Solutions Framework CurrentTryParse Method (String, NumberStyles, IFormatProvider, Current)
Converts the string representation of a number in a specified style and culture-specific format to its Current equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Current result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Current
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Current byref -> bool

GSF.Units.Current.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Current% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsCurrent
When this method returns, contains the Current value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paraampere is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This paraampere is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Current Structure
TryParse Overload
GSF.Units Namespace


Current Operators and Type Conversions

Grid Solutions Framework Current Operators and Type Conversions

The Current type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to current of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Current) | Implicitly converts value, represented in amperes, to a Current.
(Current to Double) | Implicitly converts Current, represented in amperes, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Addition Operator

Grid Solutions Framework CurrentAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current operator +(
    Current value1,
    Current value2
)
Public Shared Operator + (
    value1 As Current,
    value2 As Current
) As Current
static let inline (+)
        value1 : Current *
        value2 : Current  : Current
JavaScript does not support overloaded operators.
public:
static Current operator +(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Current
A Current object as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Division Operator

Grid Solutions Framework CurrentDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current operator /(
    Current value1,
    Current value2
)
Public Shared Operator / (
    value1 As Current,
    value2 As Current
) As Current
static let inline (/)
        value1 : Current *
        value2 : Current  : Current
JavaScript does not support overloaded operators.
public:
static Current operator /(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Current
A Current object as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Equality Operator

Grid Solutions Framework CurrentEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Current value1,
    Current value2
)
Public Shared Operator = (
    value1 As Current,
    value2 As Current
) As Boolean
static let inline (=)
        value1 : Current *
        value2 : Current  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Exponent Operator

Grid Solutions Framework CurrentExponent Operator
Returns result of first value raised to current of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Current,
    value2 As Current
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Double
A Double value as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.GreaterThan Operator

Grid Solutions Framework CurrentGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Current value1,
    Current value2
)
Public Shared Operator > (
    value1 As Current,
    value2 As Current
) As Boolean
static let inline (>)
        value1 : Current *
        value2 : Current  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.GreaterThanOrEqual Operator

Grid Solutions Framework CurrentGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Current value1,
    Current value2
)
Public Shared Operator >= (
    value1 As Current,
    value2 As Current
) As Boolean
static let inline (>=)
        value1 : Current *
        value2 : Current  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current Implicit Conversion Operators

Grid Solutions Framework Current Conversion Operators
Overload List
Name | Description
(Double to Current) | Implicitly converts value, represented in amperes, to a Current.
(Current to Double) | Implicitly converts Current, represented in amperes, to a Double.
Top
See Also

Reference

Current Structure
GSF.Units Namespace


Current Implicit Conversion (Double to Current)

Grid Solutions Framework Current Conversion (Double to Current)
Implicitly converts value, represented in amperes, to a Current.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Current (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Current
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Current (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Current
A Current object as the result.
See Also

Reference

Current Structure
Overload
GSF.Units Namespace


Current Implicit Conversion (Current to Double)

Grid Solutions Framework Current Conversion (Current to Double)
Implicitly converts Current, represented in amperes, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Current value
)
Public Shared Widening Operator CType (
    value As Current
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Current value
)

Parameters

value
Type: GSF.UnitsCurrent
A Current object.

Return Value

Type: Double
A Double value as the result.
See Also

Reference

Current Structure
Overload
GSF.Units Namespace


Current.Inequality Operator

Grid Solutions Framework CurrentInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Current value1,
    Current value2
)
Public Shared Operator <> (
    value1 As Current,
    value2 As Current
) As Boolean
static let inline (<>)
        value1 : Current *
        value2 : Current  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.LessThan Operator

Grid Solutions Framework CurrentLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Current value1,
    Current value2
)
Public Shared Operator < (
    value1 As Current,
    value2 As Current
) As Boolean
static let inline (<)
        value1 : Current *
        value2 : Current  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.LessThanOrEqual Operator

Grid Solutions Framework CurrentLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Current value1,
    Current value2
)
Public Shared Operator <= (
    value1 As Current,
    value2 As Current
) As Boolean
static let inline (<=)
        value1 : Current *
        value2 : Current  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Modulus Operator

Grid Solutions Framework CurrentModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current operator %(
    Current value1,
    Current value2
)
Public Shared Operator Mod (
    value1 As Current,
    value2 As Current
) As Current
static let inline (%)
        value1 : Current *
        value2 : Current  : Current
JavaScript does not support overloaded operators.
public:
static Current operator %(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Current
A Current object as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Multiply Operator

Grid Solutions Framework CurrentMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current operator *(
    Current value1,
    Current value2
)
Public Shared Operator * (
    value1 As Current,
    value2 As Current
) As Current
static let inline (*)
        value1 : Current *
        value2 : Current  : Current
JavaScript does not support overloaded operators.
public:
static Current operator *(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Current
A Current object as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Current.Subtraction Operator

Grid Solutions Framework CurrentSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Current operator -(
    Current value1,
    Current value2
)
Public Shared Operator - (
    value1 As Current,
    value2 As Current
) As Current
static let inline (-)
        value1 : Current *
        value2 : Current  : Current
JavaScript does not support overloaded operators.
public:
static Current operator -(
    Current value1,
    Current value2
)

Parameters

value1
Type: GSF.UnitsCurrent
A Current object as the left hand operand.
value2
Type: GSF.UnitsCurrent
A Current object as the right hand operand.

Return Value

Type: Current
A Current object as the result of the operation.
See Also

Reference

Current Structure
GSF.Units Namespace


Energy Structure

Grid Solutions Framework Energy Structure
Represents an energy measurement, in joules (i.e., watt-seconds), as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Energy : IComparable, IFormattable,
    IConvertible, IComparable<Energy>, IComparable<double>, IEquatable<Energy>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Energy
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Energy),
    IComparable(Of Double), IEquatable(Of Energy), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Energy =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Energy>
        interface IComparable<float>
        interface IEquatable<Energy>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Energy : IComparable,
    IFormattable, IConvertible, IComparable<Energy>, IComparable<double>,
    IEquatable<Energy>, IEquatable<double>

The Energy type exposes the following members.

Constructors
 | Name | Description
Public method | Energy | Creates a new Energy.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Energy) | Compares this instance to a specified Energy and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Energy) | Returns a value indicating whether this instance is equal to a specified Energy value.
 | FromBarrelsOfOil | Creates a new Energy value from the specified value in equivalent barrels of oil.
 | FromBTU | Creates a new Energy value from the specified value in BTU (International Table).
 | FromCalories | Creates a new Energy value from the specified value in calories (International Table).
 | FromCelsiusHeatUnits | Creates a new Energy value from the specified value in Celsius heat units (International Table).
 | FromHorsepowerHours | Creates a new Energy value from the specified value in horsepower-hours.
 | FromLitersAtmosphere | Creates a new Energy value from the specified value in liters-atmosphere.
 | FromTonOfCoal | Creates a new Energy value from the specified value in equivalent tons of coal.
 | FromWattHours | Creates a new Energy value from the specified value in watt-hours.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Energy equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Energy equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Energy equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent.
Public method | ToBarrelsOfOil | Gets the Energy value in equivalent barrels of oil.
Public method | ToBTU | Gets the Energy value in BTU (International Table).
Public method | ToCalories | Gets the Energy value in calories (International Table).
Public method | ToCelsiusHeatUnits | Gets the Energy value in Celsius heat units (International Table).
Public method | ToCoulombs | Gets the Charge value in coulombs given the specified volts.
Public method | ToHorsepowerHours | Gets the Energy value in horsepower-hours.
Public method | ToLitersAtmosphere | Gets the Energy value in liters-atmosphere.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToTonsOfCoal | Gets the Energy value in equivalent tons of coal.
Public method | ToWattHours | Gets the Energy value in watt-hours.
 | TryParse(String, Energy) | Converts the string representation of a number to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Energy) | Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Energy) | Implicitly converts value, represented in joules, to an Energy.
(Energy to Double) | Implicitly converts Energy, represented in joules, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Energy. This field is constant.
MinValue | Represents the smallest possible value of an Energy. This field is constant.
Top
Remarks
This class behaves just like a Double representing an energy in joules; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other energy representations, specifically watt-hours, BTU, Celsius heat unit, liter-atmosphere, calorie, horsepower-hour, barrel of oil and ton of coal. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert energy in joules to megajoules:
Copy
public double GetMegajoules(Energy joules)
{
    return joules / SI.Mega;
}
This example converts megajoules to kilowatt-hours:
Copy
public double GetKilowattHours(double megajoules)
{
    return (new Energy(megajoules * SI.Mega)).ToWattHours() / SI.Kilo;
}
This example converts kilowatt-hours to megawatt-hours:
Copy
public double GetMegawattHours(double kilowattHours)
{
    return (kilowattHours * SI.Kilo) / SI.Mega;
}
See Also

Reference

GSF.Units Namespace


Energy Constructor

Grid Solutions Framework Energy Constructor
Creates a new Energy.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Energy(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Energy
GSF.Units.Energy = function(value);
public:
Energy(
    double value
)

Parameters

value
Type: SystemDouble
New energy value in joules.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy Fields

Grid Solutions Framework Energy Fields

The Energy type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Energy. This field is constant.
MinValue | Represents the smallest possible value of an Energy. This field is constant.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.MaxValue Field

Grid Solutions Framework EnergyMaxValue Field
Represents the largest possible value of an Energy. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Energy MaxValue
Public Shared ReadOnly MaxValue As Energy
static val MaxValue: Energy
var GSF.Units.Energy.MaxValue
public:
static initonly Energy MaxValue

Field Value

Type: Energy
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.MinValue Field

Grid Solutions Framework EnergyMinValue Field
Represents the smallest possible value of an Energy. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Energy MinValue
Public Shared ReadOnly MinValue As Energy
static val MinValue: Energy
var GSF.Units.Energy.MinValue
public:
static initonly Energy MinValue

Field Value

Type: Energy
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy Methods

Grid Solutions Framework Energy Methods

The Energy type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Energy) | Compares this instance to a specified Energy and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Energy) | Returns a value indicating whether this instance is equal to a specified Energy value.
 | FromBarrelsOfOil | Creates a new Energy value from the specified value in equivalent barrels of oil.
 | FromBTU | Creates a new Energy value from the specified value in BTU (International Table).
 | FromCalories | Creates a new Energy value from the specified value in calories (International Table).
 | FromCelsiusHeatUnits | Creates a new Energy value from the specified value in Celsius heat units (International Table).
 | FromHorsepowerHours | Creates a new Energy value from the specified value in horsepower-hours.
 | FromLitersAtmosphere | Creates a new Energy value from the specified value in liters-atmosphere.
 | FromTonOfCoal | Creates a new Energy value from the specified value in equivalent tons of coal.
 | FromWattHours | Creates a new Energy value from the specified value in watt-hours.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Energy equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Energy equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Energy equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent.
Public method | ToBarrelsOfOil | Gets the Energy value in equivalent barrels of oil.
Public method | ToBTU | Gets the Energy value in BTU (International Table).
Public method | ToCalories | Gets the Energy value in calories (International Table).
Public method | ToCelsiusHeatUnits | Gets the Energy value in Celsius heat units (International Table).
Public method | ToCoulombs | Gets the Charge value in coulombs given the specified volts.
Public method | ToHorsepowerHours | Gets the Energy value in horsepower-hours.
Public method | ToLitersAtmosphere | Gets the Energy value in liters-atmosphere.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToTonsOfCoal | Gets the Energy value in equivalent tons of coal.
Public method | ToWattHours | Gets the Energy value in watt-hours.
 | TryParse(String, Energy) | Converts the string representation of a number to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Energy) | Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.CompareTo Method

Grid Solutions Framework EnergyCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Energy) | Compares this instance to a specified Energy and returns an indication of their relative values.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.CompareTo Method (Double)

Grid Solutions Framework EnergyCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Energy Structure
CompareTo Overload
GSF.Units Namespace


Energy.CompareTo Method (Object)

Grid Solutions Framework EnergyCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Energy.
See Also

Reference

Energy Structure
CompareTo Overload
GSF.Units Namespace


Energy.CompareTo Method (Energy)

Grid Solutions Framework EnergyCompareTo Method (Energy)
Compares this instance to a specified Energy and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Energy value
)
Public Function CompareTo (
    value As Energy
) As Integer
abstract CompareTo :
        value : Energy -> int
override CompareTo :
        value : Energy -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Energy value
) sealed

Parameters

value
Type: GSF.UnitsEnergy
An Energy to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Energy Structure
CompareTo Overload
GSF.Units Namespace


Energy.Equals Method

Grid Solutions Framework EnergyEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Energy) | Returns a value indicating whether this instance is equal to a specified Energy value.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Equals Method (Double)

Grid Solutions Framework EnergyEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Energy Structure
Equals Overload
GSF.Units Namespace


Energy.Equals Method (Object)

Grid Solutions Framework EnergyEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Energy and equals the value of this instance; otherwise, False.
See Also

Reference

Energy Structure
Equals Overload
GSF.Units Namespace


Energy.Equals Method (Energy)

Grid Solutions Framework EnergyEquals Method (Energy)
Returns a value indicating whether this instance is equal to a specified Energy value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Energy obj
)
Public Function Equals (
    obj As Energy
) As Boolean
abstract Equals :
        obj : Energy -> bool
override Equals :
        obj : Energy -> bool
function Equals(obj);
public:
virtual bool Equals(
    Energy obj
) sealed

Parameters

obj
Type: GSF.UnitsEnergy
An Energy value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Energy Structure
Equals Overload
GSF.Units Namespace


Energy.FromBarrelsOfOil Method

Grid Solutions Framework EnergyFromBarrelsOfOil Method
Creates a new Energy value from the specified value in equivalent barrels of oil.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromBarrelsOfOil(
    double value
)
Public Shared Function FromBarrelsOfOil (
    value As Double
) As Energy
static member FromBarrelsOfOil :
        value : float -> Energy

GSF.Units.Energy.FromBarrelsOfOil = function(value);
public:
static Energy FromBarrelsOfOil(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in equivalent barrels of oil.

Return Value

Type: Energy
New Energy object from the specified value in equivalent barrels of oil.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.FromBTU Method

Grid Solutions Framework EnergyFromBTU Method
Creates a new Energy value from the specified value in BTU (International Table).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromBTU(
    double value
)
Public Shared Function FromBTU (
    value As Double
) As Energy
static member FromBTU :
        value : float -> Energy

GSF.Units.Energy.FromBTU = function(value);
public:
static Energy FromBTU(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in BTU.

Return Value

Type: Energy
New Energy object from the specified value in BTU.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.FromCalories Method

Grid Solutions Framework EnergyFromCalories Method
Creates a new Energy value from the specified value in calories (International Table).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromCalories(
    double value
)
Public Shared Function FromCalories (
    value As Double
) As Energy
static member FromCalories :
        value : float -> Energy

GSF.Units.Energy.FromCalories = function(value);
public:
static Energy FromCalories(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in calories.

Return Value

Type: Energy
New Energy object from the specified value in calories.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.FromCelsiusHeatUnits Method

Grid Solutions Framework EnergyFromCelsiusHeatUnits Method
Creates a new Energy value from the specified value in Celsius heat units (International Table).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromCelsiusHeatUnits(
    double value
)
Public Shared Function FromCelsiusHeatUnits (
    value As Double
) As Energy
static member FromCelsiusHeatUnits :
        value : float -> Energy

GSF.Units.Energy.FromCelsiusHeatUnits = function(value);
public:
static Energy FromCelsiusHeatUnits(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in Celsius heat units.

Return Value

Type: Energy
New Energy object from the specified value in Celsius heat units.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.FromHorsepowerHours Method

Grid Solutions Framework EnergyFromHorsepowerHours Method
Creates a new Energy value from the specified value in horsepower-hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromHorsepowerHours(
    double value
)
Public Shared Function FromHorsepowerHours (
    value As Double
) As Energy
static member FromHorsepowerHours :
        value : float -> Energy

GSF.Units.Energy.FromHorsepowerHours = function(value);
public:
static Energy FromHorsepowerHours(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in horsepower-hours.

Return Value

Type: Energy
New Energy object from the specified value in horsepower-hours.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.FromLitersAtmosphere Method

Grid Solutions Framework EnergyFromLitersAtmosphere Method
Creates a new Energy value from the specified value in liters-atmosphere.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromLitersAtmosphere(
    double value
)
Public Shared Function FromLitersAtmosphere (
    value As Double
) As Energy
static member FromLitersAtmosphere :
        value : float -> Energy

GSF.Units.Energy.FromLitersAtmosphere = function(value);
public:
static Energy FromLitersAtmosphere(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in liters-atmosphere.

Return Value

Type: Energy
New Energy object from the specified value in liters-atmosphere.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.FromTonOfCoal Method

Grid Solutions Framework EnergyFromTonOfCoal Method
Creates a new Energy value from the specified value in equivalent tons of coal.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromTonOfCoal(
    double value
)
Public Shared Function FromTonOfCoal (
    value As Double
) As Energy
static member FromTonOfCoal :
        value : float -> Energy

GSF.Units.Energy.FromTonOfCoal = function(value);
public:
static Energy FromTonOfCoal(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in equivalent tons of coal.

Return Value

Type: Energy
New Energy object from the specified value in equivalent tons of coal.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.FromWattHours Method

Grid Solutions Framework EnergyFromWattHours Method
Creates a new Energy value from the specified value in watt-hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy FromWattHours(
    double value
)
Public Shared Function FromWattHours (
    value As Double
) As Energy
static member FromWattHours :
        value : float -> Energy

GSF.Units.Energy.FromWattHours = function(value);
public:
static Energy FromWattHours(
    double value
)

Parameters

value
Type: SystemDouble
New Energy value in watt-hours.

Return Value

Type: Energy
New Energy object from the specified value in watt-hours.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.GetHashCode Method

Grid Solutions Framework EnergyGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.GetTypeCode Method

Grid Solutions Framework EnergyGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Parse Method

Grid Solutions Framework EnergyParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Energy equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Energy equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Energy equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Parse Method (String)

Grid Solutions Framework EnergyParse Method (String)
Converts the string representation of a number to its Energy equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Energy
static member Parse :
        s : string -> Energy

GSF.Units.Energy.Parse = function(s);
public:
static Energy Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Energy
An Energy equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Energy Structure
Parse Overload
GSF.Units Namespace


Energy.Parse Method (String, NumberStyles)

Grid Solutions Framework EnergyParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Energy equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Energy
static member Parse :
        s : string *
        style : NumberStyles -> Energy

GSF.Units.Energy.Parse = function(s, style);
public:
static Energy Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Energy
An Energy equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Energy Structure
Parse Overload
GSF.Units Namespace


Energy.Parse Method (String, IFormatProvider)

Grid Solutions Framework EnergyParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Energy equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Energy
static member Parse :
        s : string *
        provider : IFormatProvider -> Energy

GSF.Units.Energy.Parse = function(s, provider);
public:
static Energy Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Energy
An Energy equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Energy Structure
Parse Overload
GSF.Units Namespace


Energy.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework EnergyParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Energy
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Energy

GSF.Units.Energy.Parse = function(s, style, provider);
public:
static Energy Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Energy
An Energy equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Energy Structure
Parse Overload
GSF.Units Namespace


Energy.ToBarrelsOfOil Method

Grid Solutions Framework EnergyToBarrelsOfOil Method
Gets the Energy value in equivalent barrels of oil.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToBarrelsOfOil()
Public Function ToBarrelsOfOil As Double
member ToBarrelsOfOil : unit -> float

function ToBarrelsOfOil();
public:
double ToBarrelsOfOil()

Return Value

Type: Double
Value of Energy in equivalent barrels of oil.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToBTU Method

Grid Solutions Framework EnergyToBTU Method
Gets the Energy value in BTU (International Table).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToBTU()
Public Function ToBTU As Double
member ToBTU : unit -> float

function ToBTU();
public:
double ToBTU()

Return Value

Type: Double
Value of Energy in BTU.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToCalories Method

Grid Solutions Framework EnergyToCalories Method
Gets the Energy value in calories (International Table).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToCalories()
Public Function ToCalories As Double
member ToCalories : unit -> float

function ToCalories();
public:
double ToCalories()

Return Value

Type: Double
Value of Energy in calories.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToCelsiusHeatUnits Method

Grid Solutions Framework EnergyToCelsiusHeatUnits Method
Gets the Energy value in Celsius heat units (International Table).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToCelsiusHeatUnits()
Public Function ToCelsiusHeatUnits As Double
member ToCelsiusHeatUnits : unit -> float

function ToCelsiusHeatUnits();
public:
double ToCelsiusHeatUnits()

Return Value

Type: Double
Value of Energy in Celsius heat units.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToCoulombs Method

Grid Solutions Framework EnergyToCoulombs Method
Gets the Charge value in coulombs given the specified volts.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Charge ToCoulombs(
    Voltage volts
)
Public Function ToCoulombs (
    volts As Voltage
) As Charge
member ToCoulombs :
        volts : Voltage -> Charge

function ToCoulombs(volts);
public:
Charge ToCoulombs(
    Voltage volts
)

Parameters

volts
Type: GSF.UnitsVoltage
Source Voltage used to calculate Charge value.

Return Value

Type: Charge
Charge value in coulombs given the specified volts.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToHorsepowerHours Method

Grid Solutions Framework EnergyToHorsepowerHours Method
Gets the Energy value in horsepower-hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToHorsepowerHours()
Public Function ToHorsepowerHours As Double
member ToHorsepowerHours : unit -> float

function ToHorsepowerHours();
public:
double ToHorsepowerHours()

Return Value

Type: Double
Value of Energy in horsepower-hours.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToLitersAtmosphere Method

Grid Solutions Framework EnergyToLitersAtmosphere Method
Gets the Energy value in liters-atmosphere.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToLitersAtmosphere()
Public Function ToLitersAtmosphere As Double
member ToLitersAtmosphere : unit -> float

function ToLitersAtmosphere();
public:
double ToLitersAtmosphere()

Return Value

Type: Double
Value of Energy in liters-atmosphere.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToString Method

Grid Solutions Framework EnergyToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToString Method

Grid Solutions Framework EnergyToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Energy Structure
ToString Overload
GSF.Units Namespace


Energy.ToString Method (IFormatProvider)

Grid Solutions Framework EnergyToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Energy Structure
ToString Overload
GSF.Units Namespace


Energy.ToString Method (String)

Grid Solutions Framework EnergyToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Energy Structure
ToString Overload
GSF.Units Namespace


Energy.ToString Method (String, IFormatProvider)

Grid Solutions Framework EnergyToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Energy Structure
ToString Overload
GSF.Units Namespace


Energy.ToTonsOfCoal Method

Grid Solutions Framework EnergyToTonsOfCoal Method
Gets the Energy value in equivalent tons of coal.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToTonsOfCoal()
Public Function ToTonsOfCoal As Double
member ToTonsOfCoal : unit -> float

function ToTonsOfCoal();
public:
double ToTonsOfCoal()

Return Value

Type: Double
Value of Energy in equivalent tons of coal.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.ToWattHours Method

Grid Solutions Framework EnergyToWattHours Method
Gets the Energy value in watt-hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToWattHours()
Public Function ToWattHours As Double
member ToWattHours : unit -> float

function ToWattHours();
public:
double ToWattHours()

Return Value

Type: Double
Value of Energy in watt-hours.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.TryParse Method

Grid Solutions Framework EnergyTryParse Method
Overload List
Name | Description
TryParse(String, Energy) | Converts the string representation of a number to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Energy) | Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.TryParse Method (String, Energy)

Grid Solutions Framework EnergyTryParse Method (String, Energy)
Converts the string representation of a number to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Energy result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Energy
) As Boolean
static member TryParse :
        s : string *
        result : Energy byref -> bool

GSF.Units.Energy.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Energy% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsEnergy
When this method returns, contains the Energy value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parajoule is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parajoule is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Energy Structure
TryParse Overload
GSF.Units Namespace


Energy.TryParse Method (String, NumberStyles, IFormatProvider, Energy)

Grid Solutions Framework EnergyTryParse Method (String, NumberStyles, IFormatProvider, Energy)
Converts the string representation of a number in a specified style and culture-specific format to its Energy equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Energy result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Energy
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Energy byref -> bool

GSF.Units.Energy.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Energy% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsEnergy
When this method returns, contains the Energy value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parajoule is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parajoule is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Energy Structure
TryParse Overload
GSF.Units Namespace


Energy Operators and Type Conversions

Grid Solutions Framework Energy Operators and Type Conversions

The Energy type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Energy) | Implicitly converts value, represented in joules, to an Energy.
(Energy to Double) | Implicitly converts Energy, represented in joules, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Addition Operator

Grid Solutions Framework EnergyAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy operator +(
    Energy value1,
    Energy value2
)
Public Shared Operator + (
    value1 As Energy,
    value2 As Energy
) As Energy
static let inline (+)
        value1 : Energy *
        value2 : Energy  : Energy
JavaScript does not support overloaded operators.
public:
static Energy operator +(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Energy
An Energy object as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Division Operator

Grid Solutions Framework EnergyDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy operator /(
    Energy value1,
    Energy value2
)
Public Shared Operator / (
    value1 As Energy,
    value2 As Energy
) As Energy
static let inline (/)
        value1 : Energy *
        value2 : Energy  : Energy
JavaScript does not support overloaded operators.
public:
static Energy operator /(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Energy
An Energy object as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Equality Operator

Grid Solutions Framework EnergyEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Energy value1,
    Energy value2
)
Public Shared Operator = (
    value1 As Energy,
    value2 As Energy
) As Boolean
static let inline (=)
        value1 : Energy *
        value2 : Energy  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Exponent Operator

Grid Solutions Framework EnergyExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Energy,
    value2 As Energy
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Double
A Double value as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.GreaterThan Operator

Grid Solutions Framework EnergyGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Energy value1,
    Energy value2
)
Public Shared Operator > (
    value1 As Energy,
    value2 As Energy
) As Boolean
static let inline (>)
        value1 : Energy *
        value2 : Energy  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.GreaterThanOrEqual Operator

Grid Solutions Framework EnergyGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Energy value1,
    Energy value2
)
Public Shared Operator >= (
    value1 As Energy,
    value2 As Energy
) As Boolean
static let inline (>=)
        value1 : Energy *
        value2 : Energy  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy Implicit Conversion Operators

Grid Solutions Framework Energy Conversion Operators
Overload List
Name | Description
(Double to Energy) | Implicitly converts value, represented in joules, to an Energy.
(Energy to Double) | Implicitly converts Energy, represented in joules, to a Double.
Top
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy Implicit Conversion (Double to Energy)

Grid Solutions Framework Energy Conversion (Double to Energy)
Implicitly converts value, represented in joules, to an Energy.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Energy (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Energy
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Energy (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Energy
An Energy object.
See Also

Reference

Energy Structure
Overload
GSF.Units Namespace


Energy Implicit Conversion (Energy to Double)

Grid Solutions Framework Energy Conversion (Energy to Double)
Implicitly converts Energy, represented in joules, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Energy value
)
Public Shared Widening Operator CType (
    value As Energy
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Energy value
)

Parameters

value
Type: GSF.UnitsEnergy
An Energy object.

Return Value

Type: Double
A Double value.
See Also

Reference

Energy Structure
Overload
GSF.Units Namespace


Energy.Inequality Operator

Grid Solutions Framework EnergyInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Energy value1,
    Energy value2
)
Public Shared Operator <> (
    value1 As Energy,
    value2 As Energy
) As Boolean
static let inline (<>)
        value1 : Energy *
        value2 : Energy  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.LessThan Operator

Grid Solutions Framework EnergyLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Energy value1,
    Energy value2
)
Public Shared Operator < (
    value1 As Energy,
    value2 As Energy
) As Boolean
static let inline (<)
        value1 : Energy *
        value2 : Energy  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.LessThanOrEqual Operator

Grid Solutions Framework EnergyLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Energy value1,
    Energy value2
)
Public Shared Operator <= (
    value1 As Energy,
    value2 As Energy
) As Boolean
static let inline (<=)
        value1 : Energy *
        value2 : Energy  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Modulus Operator

Grid Solutions Framework EnergyModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy operator %(
    Energy value1,
    Energy value2
)
Public Shared Operator Mod (
    value1 As Energy,
    value2 As Energy
) As Energy
static let inline (%)
        value1 : Energy *
        value2 : Energy  : Energy
JavaScript does not support overloaded operators.
public:
static Energy operator %(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Energy
An Energy object as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Multiply Operator

Grid Solutions Framework EnergyMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy operator *(
    Energy value1,
    Energy value2
)
Public Shared Operator * (
    value1 As Energy,
    value2 As Energy
) As Energy
static let inline (*)
        value1 : Energy *
        value2 : Energy  : Energy
JavaScript does not support overloaded operators.
public:
static Energy operator *(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Energy
An Energy object as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Energy.Subtraction Operator

Grid Solutions Framework EnergySubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Energy operator -(
    Energy value1,
    Energy value2
)
Public Shared Operator - (
    value1 As Energy,
    value2 As Energy
) As Energy
static let inline (-)
        value1 : Energy *
        value2 : Energy  : Energy
JavaScript does not support overloaded operators.
public:
static Energy operator -(
    Energy value1,
    Energy value2
)

Parameters

value1
Type: GSF.UnitsEnergy
An Energy object as the left hand operand.
value2
Type: GSF.UnitsEnergy
An Energy object as the right hand operand.

Return Value

Type: Energy
An Energy object as the result of the operation.
See Also

Reference

Energy Structure
GSF.Units Namespace


Length Structure

Grid Solutions Framework Length Structure
Represents a length measurement, in meters, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Length : IComparable, IFormattable,
    IConvertible, IComparable<Length>, IComparable<double>, IEquatable<Length>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Length
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Length),
    IComparable(Of Double), IEquatable(Of Length), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Length =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Length>
        interface IComparable<float>
        interface IEquatable<Length>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Length : IComparable,
    IFormattable, IConvertible, IComparable<Length>, IComparable<double>,
    IEquatable<Length>, IEquatable<double>

The Length type exposes the following members.

Constructors
 | Name | Description
Public method | Length | Creates a new Length.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Length) | Compares this instance to a specified Length and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Length) | Returns a value indicating whether this instance is equal to a specified Length value.
 | FromFeet | Creates a new Length value from the specified value in feet.
 | FromInches | Creates a new Length value from the specified value in inches.
 | FromLightSeconds | Creates a new Length value from the specified value in light-seconds.
 | FromMiles | Creates a new Length value from the specified value in miles.
 | FromNauticalMiles | Creates a new Length value from the specified value in nautical miles.
 | FromUSSurveyFeet | Creates a new Length value from the specified value in US survey feet.
 | FromUSSurveyMiles | Creates a new Length value from the specified value in US survey miles.
 | FromYards | Creates a new Length value from the specified value in yards.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Length equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Length equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Length equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent.
Public method | ToFeet | Gets the Length value in feet.
Public method | ToInches | Gets the Length value in inches.
Public method | ToLightSeconds | Gets the Length value in light-seconds.
Public method | ToMiles | Gets the Length value in miles.
Public method | ToNauticalMiles | Gets the Length value in nautical miles.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToUSSurveyFeet | Gets the Length value in US survey feet.
Public method | ToUSSurveyMiles | Gets the Length value in US survey miles.
Public method | ToYards | Gets the Length value in yards.
 | TryParse(String, Length) | Converts the string representation of a number to its Length equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Length) | Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Length) | Implicitly converts value, represented in meters, to a Length.
(Length to Double) | Implicitly converts Length, represented in meters, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Length. This field is constant.
MinValue | Represents the smallest possible value of an Length. This field is constant.
Top
Remarks
This class behaves just like a Double representing a length in meters; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other length representations, specifically inches, feet, yards, miles, US survey feet, US survey miles, light-seconds, and nautical miles. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert length in meters to kilometers:
Copy
public double GetKilometers(Length meters)
{
    return meters / SI.Kilo;
}
This example converts feet to inches:
Copy
public double GetFeet(double inches)
{
    return Length.FromInches(inches).ToFeet();
}
See Also

Reference

GSF.Units Namespace


Length Constructor

Grid Solutions Framework Length Constructor
Creates a new Length.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Length(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Length
GSF.Units.Length = function(value);
public:
Length(
    double value
)

Parameters

value
Type: SystemDouble
New length value in meters.
See Also

Reference

Length Structure
GSF.Units Namespace


Length Fields

Grid Solutions Framework Length Fields

The Length type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Length. This field is constant.
MinValue | Represents the smallest possible value of an Length. This field is constant.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.MaxValue Field

Grid Solutions Framework LengthMaxValue Field
Represents the largest possible value of an Length. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Length MaxValue
Public Shared ReadOnly MaxValue As Length
static val MaxValue: Length
var GSF.Units.Length.MaxValue
public:
static initonly Length MaxValue

Field Value

Type: Length
See Also

Reference

Length Structure
GSF.Units Namespace


Length.MinValue Field

Grid Solutions Framework LengthMinValue Field
Represents the smallest possible value of an Length. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Length MinValue
Public Shared ReadOnly MinValue As Length
static val MinValue: Length
var GSF.Units.Length.MinValue
public:
static initonly Length MinValue

Field Value

Type: Length
See Also

Reference

Length Structure
GSF.Units Namespace


Length Methods

Grid Solutions Framework Length Methods

The Length type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Length) | Compares this instance to a specified Length and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Length) | Returns a value indicating whether this instance is equal to a specified Length value.
 | FromFeet | Creates a new Length value from the specified value in feet.
 | FromInches | Creates a new Length value from the specified value in inches.
 | FromLightSeconds | Creates a new Length value from the specified value in light-seconds.
 | FromMiles | Creates a new Length value from the specified value in miles.
 | FromNauticalMiles | Creates a new Length value from the specified value in nautical miles.
 | FromUSSurveyFeet | Creates a new Length value from the specified value in US survey feet.
 | FromUSSurveyMiles | Creates a new Length value from the specified value in US survey miles.
 | FromYards | Creates a new Length value from the specified value in yards.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Length equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Length equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Length equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent.
Public method | ToFeet | Gets the Length value in feet.
Public method | ToInches | Gets the Length value in inches.
Public method | ToLightSeconds | Gets the Length value in light-seconds.
Public method | ToMiles | Gets the Length value in miles.
Public method | ToNauticalMiles | Gets the Length value in nautical miles.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToUSSurveyFeet | Gets the Length value in US survey feet.
Public method | ToUSSurveyMiles | Gets the Length value in US survey miles.
Public method | ToYards | Gets the Length value in yards.
 | TryParse(String, Length) | Converts the string representation of a number to its Length equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Length) | Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.CompareTo Method

Grid Solutions Framework LengthCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Length) | Compares this instance to a specified Length and returns an indication of their relative values.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.CompareTo Method (Double)

Grid Solutions Framework LengthCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Length Structure
CompareTo Overload
GSF.Units Namespace


Length.CompareTo Method (Object)

Grid Solutions Framework LengthCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Length.
See Also

Reference

Length Structure
CompareTo Overload
GSF.Units Namespace


Length.CompareTo Method (Length)

Grid Solutions Framework LengthCompareTo Method (Length)
Compares this instance to a specified Length and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Length value
)
Public Function CompareTo (
    value As Length
) As Integer
abstract CompareTo :
        value : Length -> int
override CompareTo :
        value : Length -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Length value
) sealed

Parameters

value
Type: GSF.UnitsLength
A Length to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Length Structure
CompareTo Overload
GSF.Units Namespace


Length.Equals Method

Grid Solutions Framework LengthEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Length) | Returns a value indicating whether this instance is equal to a specified Length value.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Equals Method (Double)

Grid Solutions Framework LengthEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Length Structure
Equals Overload
GSF.Units Namespace


Length.Equals Method (Object)

Grid Solutions Framework LengthEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Length and equals the value of this instance; otherwise, False.
See Also

Reference

Length Structure
Equals Overload
GSF.Units Namespace


Length.Equals Method (Length)

Grid Solutions Framework LengthEquals Method (Length)
Returns a value indicating whether this instance is equal to a specified Length value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Length obj
)
Public Function Equals (
    obj As Length
) As Boolean
abstract Equals :
        obj : Length -> bool
override Equals :
        obj : Length -> bool
function Equals(obj);
public:
virtual bool Equals(
    Length obj
) sealed

Parameters

obj
Type: GSF.UnitsLength
A Length value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Length Structure
Equals Overload
GSF.Units Namespace


Length.FromFeet Method

Grid Solutions Framework LengthFromFeet Method
Creates a new Length value from the specified value in feet.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromFeet(
    double value
)
Public Shared Function FromFeet (
    value As Double
) As Length
static member FromFeet :
        value : float -> Length

GSF.Units.Length.FromFeet = function(value);
public:
static Length FromFeet(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in feet.

Return Value

Type: Length
New Length object from the specified value in feet.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.FromInches Method

Grid Solutions Framework LengthFromInches Method
Creates a new Length value from the specified value in inches.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromInches(
    double value
)
Public Shared Function FromInches (
    value As Double
) As Length
static member FromInches :
        value : float -> Length

GSF.Units.Length.FromInches = function(value);
public:
static Length FromInches(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in inches.

Return Value

Type: Length
New Length object from the specified value in inches.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.FromLightSeconds Method

Grid Solutions Framework LengthFromLightSeconds Method
Creates a new Length value from the specified value in light-seconds.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromLightSeconds(
    double value
)
Public Shared Function FromLightSeconds (
    value As Double
) As Length
static member FromLightSeconds :
        value : float -> Length

GSF.Units.Length.FromLightSeconds = function(value);
public:
static Length FromLightSeconds(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in light-seconds.

Return Value

Type: Length
New Length object from the specified value in light-seconds.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.FromMiles Method

Grid Solutions Framework LengthFromMiles Method
Creates a new Length value from the specified value in miles.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromMiles(
    double value
)
Public Shared Function FromMiles (
    value As Double
) As Length
static member FromMiles :
        value : float -> Length

GSF.Units.Length.FromMiles = function(value);
public:
static Length FromMiles(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in miles.

Return Value

Type: Length
New Length object from the specified value in miles.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.FromNauticalMiles Method

Grid Solutions Framework LengthFromNauticalMiles Method
Creates a new Length value from the specified value in nautical miles.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromNauticalMiles(
    double value
)
Public Shared Function FromNauticalMiles (
    value As Double
) As Length
static member FromNauticalMiles :
        value : float -> Length

GSF.Units.Length.FromNauticalMiles = function(value);
public:
static Length FromNauticalMiles(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in nautical miles.

Return Value

Type: Length
New Length object from the specified value in nautical miles.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.FromUSSurveyFeet Method

Grid Solutions Framework LengthFromUSSurveyFeet Method
Creates a new Length value from the specified value in US survey feet.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromUSSurveyFeet(
    double value
)
Public Shared Function FromUSSurveyFeet (
    value As Double
) As Length
static member FromUSSurveyFeet :
        value : float -> Length

GSF.Units.Length.FromUSSurveyFeet = function(value);
public:
static Length FromUSSurveyFeet(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in US survey feet.

Return Value

Type: Length
New Length object from the specified value in US survey feet.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.FromUSSurveyMiles Method

Grid Solutions Framework LengthFromUSSurveyMiles Method
Creates a new Length value from the specified value in US survey miles.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromUSSurveyMiles(
    double value
)
Public Shared Function FromUSSurveyMiles (
    value As Double
) As Length
static member FromUSSurveyMiles :
        value : float -> Length

GSF.Units.Length.FromUSSurveyMiles = function(value);
public:
static Length FromUSSurveyMiles(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in US survey miles.

Return Value

Type: Length
New Length object from the specified value in US survey miles.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.FromYards Method

Grid Solutions Framework LengthFromYards Method
Creates a new Length value from the specified value in yards.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length FromYards(
    double value
)
Public Shared Function FromYards (
    value As Double
) As Length
static member FromYards :
        value : float -> Length

GSF.Units.Length.FromYards = function(value);
public:
static Length FromYards(
    double value
)

Parameters

value
Type: SystemDouble
New Length value in yards.

Return Value

Type: Length
New Length object from the specified value in yards.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.GetHashCode Method

Grid Solutions Framework LengthGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.GetTypeCode Method

Grid Solutions Framework LengthGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Parse Method

Grid Solutions Framework LengthParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Length equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Length equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Length equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Parse Method (String)

Grid Solutions Framework LengthParse Method (String)
Converts the string representation of a number to its Length equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Length
static member Parse :
        s : string -> Length

GSF.Units.Length.Parse = function(s);
public:
static Length Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Length
A Length equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Length Structure
Parse Overload
GSF.Units Namespace


Length.Parse Method (String, NumberStyles)

Grid Solutions Framework LengthParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Length equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Length
static member Parse :
        s : string *
        style : NumberStyles -> Length

GSF.Units.Length.Parse = function(s, style);
public:
static Length Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Length
A Length equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Length Structure
Parse Overload
GSF.Units Namespace


Length.Parse Method (String, IFormatProvider)

Grid Solutions Framework LengthParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Length equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Length
static member Parse :
        s : string *
        provider : IFormatProvider -> Length

GSF.Units.Length.Parse = function(s, provider);
public:
static Length Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Length
A Length equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Length Structure
Parse Overload
GSF.Units Namespace


Length.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework LengthParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Length
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Length

GSF.Units.Length.Parse = function(s, style, provider);
public:
static Length Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Length
A Length equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Length Structure
Parse Overload
GSF.Units Namespace


Length.ToFeet Method

Grid Solutions Framework LengthToFeet Method
Gets the Length value in feet.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToFeet()
Public Function ToFeet As Double
member ToFeet : unit -> float

function ToFeet();
public:
double ToFeet()

Return Value

Type: Double
Value of Length in feet.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToInches Method

Grid Solutions Framework LengthToInches Method
Gets the Length value in inches.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToInches()
Public Function ToInches As Double
member ToInches : unit -> float

function ToInches();
public:
double ToInches()

Return Value

Type: Double
Value of Length in inches.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToLightSeconds Method

Grid Solutions Framework LengthToLightSeconds Method
Gets the Length value in light-seconds.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToLightSeconds()
Public Function ToLightSeconds As Double
member ToLightSeconds : unit -> float

function ToLightSeconds();
public:
double ToLightSeconds()

Return Value

Type: Double
Value of Length in light-seconds.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToMiles Method

Grid Solutions Framework LengthToMiles Method
Gets the Length value in miles.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMiles()
Public Function ToMiles As Double
member ToMiles : unit -> float

function ToMiles();
public:
double ToMiles()

Return Value

Type: Double
Value of Length in miles.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToNauticalMiles Method

Grid Solutions Framework LengthToNauticalMiles Method
Gets the Length value in nautical miles.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToNauticalMiles()
Public Function ToNauticalMiles As Double
member ToNauticalMiles : unit -> float

function ToNauticalMiles();
public:
double ToNauticalMiles()

Return Value

Type: Double
Value of Length in nautical miles.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToString Method

Grid Solutions Framework LengthToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToString Method

Grid Solutions Framework LengthToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Length Structure
ToString Overload
GSF.Units Namespace


Length.ToString Method (IFormatProvider)

Grid Solutions Framework LengthToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Length Structure
ToString Overload
GSF.Units Namespace


Length.ToString Method (String)

Grid Solutions Framework LengthToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Length Structure
ToString Overload
GSF.Units Namespace


Length.ToString Method (String, IFormatProvider)

Grid Solutions Framework LengthToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Length Structure
ToString Overload
GSF.Units Namespace


Length.ToUSSurveyFeet Method

Grid Solutions Framework LengthToUSSurveyFeet Method
Gets the Length value in US survey feet.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToUSSurveyFeet()
Public Function ToUSSurveyFeet As Double
member ToUSSurveyFeet : unit -> float

function ToUSSurveyFeet();
public:
double ToUSSurveyFeet()

Return Value

Type: Double
Value of Length in US survey feet.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToUSSurveyMiles Method

Grid Solutions Framework LengthToUSSurveyMiles Method
Gets the Length value in US survey miles.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToUSSurveyMiles()
Public Function ToUSSurveyMiles As Double
member ToUSSurveyMiles : unit -> float

function ToUSSurveyMiles();
public:
double ToUSSurveyMiles()

Return Value

Type: Double
Value of Length in US survey miles.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.ToYards Method

Grid Solutions Framework LengthToYards Method
Gets the Length value in yards.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToYards()
Public Function ToYards As Double
member ToYards : unit -> float

function ToYards();
public:
double ToYards()

Return Value

Type: Double
Value of Length in yards.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.TryParse Method

Grid Solutions Framework LengthTryParse Method
Overload List
Name | Description
TryParse(String, Length) | Converts the string representation of a number to its Length equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Length) | Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.TryParse Method (String, Length)

Grid Solutions Framework LengthTryParse Method (String, Length)
Converts the string representation of a number to its Length equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Length result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Length
) As Boolean
static member TryParse :
        s : string *
        result : Length byref -> bool

GSF.Units.Length.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Length% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsLength
When this method returns, contains the Length value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Length Structure
TryParse Overload
GSF.Units Namespace


Length.TryParse Method (String, NumberStyles, IFormatProvider, Length)

Grid Solutions Framework LengthTryParse Method (String, NumberStyles, IFormatProvider, Length)
Converts the string representation of a number in a specified style and culture-specific format to its Length equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Length result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Length
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Length byref -> bool

GSF.Units.Length.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Length% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsLength
When this method returns, contains the Length value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Length Structure
TryParse Overload
GSF.Units Namespace


Length Operators and Type Conversions

Grid Solutions Framework Length Operators and Type Conversions

The Length type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Length) | Implicitly converts value, represented in meters, to a Length.
(Length to Double) | Implicitly converts Length, represented in meters, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Addition Operator

Grid Solutions Framework LengthAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length operator +(
    Length value1,
    Length value2
)
Public Shared Operator + (
    value1 As Length,
    value2 As Length
) As Length
static let inline (+)
        value1 : Length *
        value2 : Length  : Length
JavaScript does not support overloaded operators.
public:
static Length operator +(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Length
A Length object as the result.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Division Operator

Grid Solutions Framework LengthDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length operator /(
    Length value1,
    Length value2
)
Public Shared Operator / (
    value1 As Length,
    value2 As Length
) As Length
static let inline (/)
        value1 : Length *
        value2 : Length  : Length
JavaScript does not support overloaded operators.
public:
static Length operator /(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Length
A Length object as the result.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Equality Operator

Grid Solutions Framework LengthEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Length value1,
    Length value2
)
Public Shared Operator = (
    value1 As Length,
    value2 As Length
) As Boolean
static let inline (=)
        value1 : Length *
        value2 : Length  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Exponent Operator

Grid Solutions Framework LengthExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Length,
    value2 As Length
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Double
A Double value as the result.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.GreaterThan Operator

Grid Solutions Framework LengthGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Length value1,
    Length value2
)
Public Shared Operator > (
    value1 As Length,
    value2 As Length
) As Boolean
static let inline (>)
        value1 : Length *
        value2 : Length  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.GreaterThanOrEqual Operator

Grid Solutions Framework LengthGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Length value1,
    Length value2
)
Public Shared Operator >= (
    value1 As Length,
    value2 As Length
) As Boolean
static let inline (>=)
        value1 : Length *
        value2 : Length  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Length Structure
GSF.Units Namespace


Length Implicit Conversion Operators

Grid Solutions Framework Length Conversion Operators
Overload List
Name | Description
(Double to Length) | Implicitly converts value, represented in meters, to a Length.
(Length to Double) | Implicitly converts Length, represented in meters, to a Double.
Top
See Also

Reference

Length Structure
GSF.Units Namespace


Length Implicit Conversion (Double to Length)

Grid Solutions Framework Length Conversion (Double to Length)
Implicitly converts value, represented in meters, to a Length.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Length (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Length
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Length (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Length
A Length object.
See Also

Reference

Length Structure
Overload
GSF.Units Namespace


Length Implicit Conversion (Length to Double)

Grid Solutions Framework Length Conversion (Length to Double)
Implicitly converts Length, represented in meters, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Length value
)
Public Shared Widening Operator CType (
    value As Length
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Length value
)

Parameters

value
Type: GSF.UnitsLength
A Length object.

Return Value

Type: Double
A Double value.
See Also

Reference

Length Structure
Overload
GSF.Units Namespace


Length.Inequality Operator

Grid Solutions Framework LengthInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Length value1,
    Length value2
)
Public Shared Operator <> (
    value1 As Length,
    value2 As Length
) As Boolean
static let inline (<>)
        value1 : Length *
        value2 : Length  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.LessThan Operator

Grid Solutions Framework LengthLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Length value1,
    Length value2
)
Public Shared Operator < (
    value1 As Length,
    value2 As Length
) As Boolean
static let inline (<)
        value1 : Length *
        value2 : Length  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.LessThanOrEqual Operator

Grid Solutions Framework LengthLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Length value1,
    Length value2
)
Public Shared Operator <= (
    value1 As Length,
    value2 As Length
) As Boolean
static let inline (<=)
        value1 : Length *
        value2 : Length  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Modulus Operator

Grid Solutions Framework LengthModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length operator %(
    Length value1,
    Length value2
)
Public Shared Operator Mod (
    value1 As Length,
    value2 As Length
) As Length
static let inline (%)
        value1 : Length *
        value2 : Length  : Length
JavaScript does not support overloaded operators.
public:
static Length operator %(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Length
A Length object as the result.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Multiply Operator

Grid Solutions Framework LengthMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length operator *(
    Length value1,
    Length value2
)
Public Shared Operator * (
    value1 As Length,
    value2 As Length
) As Length
static let inline (*)
        value1 : Length *
        value2 : Length  : Length
JavaScript does not support overloaded operators.
public:
static Length operator *(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Length
A Length object as the result.
See Also

Reference

Length Structure
GSF.Units Namespace


Length.Subtraction Operator

Grid Solutions Framework LengthSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Length operator -(
    Length value1,
    Length value2
)
Public Shared Operator - (
    value1 As Length,
    value2 As Length
) As Length
static let inline (-)
        value1 : Length *
        value2 : Length  : Length
JavaScript does not support overloaded operators.
public:
static Length operator -(
    Length value1,
    Length value2
)

Parameters

value1
Type: GSF.UnitsLength
A Length object left hand operand.
value2
Type: GSF.UnitsLength
A Length object right hand operand.

Return Value

Type: Length
A Length object as the result.
See Also

Reference

Length Structure
GSF.Units Namespace


Mass Structure

Grid Solutions Framework Mass Structure
Represents a mass measurement, in kilograms, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Mass : IComparable, IFormattable,
    IConvertible, IComparable<Mass>, IComparable<double>, IEquatable<Mass>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Mass
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Mass),
    IComparable(Of Double), IEquatable(Of Mass), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Mass =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Mass>
        interface IComparable<float>
        interface IEquatable<Mass>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Mass : IComparable, IFormattable,
    IConvertible, IComparable<Mass>, IComparable<double>, IEquatable<Mass>,
    IEquatable<double>

The Mass type exposes the following members.

Constructors
 | Name | Description
Public method | Mass | Creates a new Mass.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Mass) | Compares this instance to a specified Mass and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Mass) | Returns a value indicating whether this instance is equal to a specified Mass value.
 | FromLongTons | Creates a new Mass value from the specified value in long tons.
 | FromMetricPounds | Creates a new Mass value from the specified value in metric pounds.
 | FromMetricTons | Creates a new Mass value from the specified value in metric tons.
 | FromOunces | Creates a new Mass value from the specified value in ounces (avoirdupois).
 | FromPounds | Creates a new Mass value from the specified value in pounds (avoirdupois).
 | FromTons | Creates a new Mass value from the specified value in short tons.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Mass equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Mass equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Mass equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent.
Public method | ToLongTons | Gets the Mass value in long tons.
Public method | ToMetricPounds | Gets the Mass value in metric pounds.
Public method | ToMetricTons | Gets the Mass value in metric tons.
Public method | ToOunces | Gets the Mass value in ounces (avoirdupois).
Public method | ToPounds | Gets the Mass value in pounds (avoirdupois).
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToTons | Gets the Mass value in short tons.
 | TryParse(String, Mass) | Converts the string representation of a number to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Mass) | Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to mass of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Mass) | Implicitly converts value, represented in kilograms, to a Mass.
(Mass to Double) | Implicitly converts Mass, represented in kilograms, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Mass. This field is constant.
MinValue | Represents the smallest possible value of an Mass. This field is constant.
Top
Remarks
This class behaves just like a Double representing a mass in kilograms; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other mass representations, specifically ounces, pounds and tons. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert mass, in kilograms, to grams:
Copy
public double GetGrams(Mass kilograms)
{
    return kilograms * SI.Kilo;
}
This example converts tons to pounds:
Copy
public double GetPounds(double tons)
{
    return Mass.FromTons(tons).ToPounds();
}
See Also

Reference

GSF.Units Namespace


Mass Constructor

Grid Solutions Framework Mass Constructor
Creates a new Mass.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Mass(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Mass
GSF.Units.Mass = function(value);
public:
Mass(
    double value
)

Parameters

value
Type: SystemDouble
New mass value in kilograms.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass Fields

Grid Solutions Framework Mass Fields

The Mass type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Mass. This field is constant.
MinValue | Represents the smallest possible value of an Mass. This field is constant.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.MaxValue Field

Grid Solutions Framework MassMaxValue Field
Represents the largest possible value of an Mass. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Mass MaxValue
Public Shared ReadOnly MaxValue As Mass
static val MaxValue: Mass
var GSF.Units.Mass.MaxValue
public:
static initonly Mass MaxValue

Field Value

Type: Mass
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.MinValue Field

Grid Solutions Framework MassMinValue Field
Represents the smallest possible value of an Mass. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Mass MinValue
Public Shared ReadOnly MinValue As Mass
static val MinValue: Mass
var GSF.Units.Mass.MinValue
public:
static initonly Mass MinValue

Field Value

Type: Mass
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass Methods

Grid Solutions Framework Mass Methods

The Mass type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Mass) | Compares this instance to a specified Mass and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Mass) | Returns a value indicating whether this instance is equal to a specified Mass value.
 | FromLongTons | Creates a new Mass value from the specified value in long tons.
 | FromMetricPounds | Creates a new Mass value from the specified value in metric pounds.
 | FromMetricTons | Creates a new Mass value from the specified value in metric tons.
 | FromOunces | Creates a new Mass value from the specified value in ounces (avoirdupois).
 | FromPounds | Creates a new Mass value from the specified value in pounds (avoirdupois).
 | FromTons | Creates a new Mass value from the specified value in short tons.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Mass equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Mass equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Mass equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent.
Public method | ToLongTons | Gets the Mass value in long tons.
Public method | ToMetricPounds | Gets the Mass value in metric pounds.
Public method | ToMetricTons | Gets the Mass value in metric tons.
Public method | ToOunces | Gets the Mass value in ounces (avoirdupois).
Public method | ToPounds | Gets the Mass value in pounds (avoirdupois).
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToTons | Gets the Mass value in short tons.
 | TryParse(String, Mass) | Converts the string representation of a number to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Mass) | Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.CompareTo Method

Grid Solutions Framework MassCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Mass) | Compares this instance to a specified Mass and returns an indication of their relative values.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.CompareTo Method (Double)

Grid Solutions Framework MassCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Mass Structure
CompareTo Overload
GSF.Units Namespace


Mass.CompareTo Method (Object)

Grid Solutions Framework MassCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Mass.
See Also

Reference

Mass Structure
CompareTo Overload
GSF.Units Namespace


Mass.CompareTo Method (Mass)

Grid Solutions Framework MassCompareTo Method (Mass)
Compares this instance to a specified Mass and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Mass value
)
Public Function CompareTo (
    value As Mass
) As Integer
abstract CompareTo :
        value : Mass -> int
override CompareTo :
        value : Mass -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Mass value
) sealed

Parameters

value
Type: GSF.UnitsMass
A Mass to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Mass Structure
CompareTo Overload
GSF.Units Namespace


Mass.Equals Method

Grid Solutions Framework MassEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Mass) | Returns a value indicating whether this instance is equal to a specified Mass value.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Equals Method (Double)

Grid Solutions Framework MassEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Mass Structure
Equals Overload
GSF.Units Namespace


Mass.Equals Method (Object)

Grid Solutions Framework MassEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Mass and equals the value of this instance; otherwise, False.
See Also

Reference

Mass Structure
Equals Overload
GSF.Units Namespace


Mass.Equals Method (Mass)

Grid Solutions Framework MassEquals Method (Mass)
Returns a value indicating whether this instance is equal to a specified Mass value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Mass obj
)
Public Function Equals (
    obj As Mass
) As Boolean
abstract Equals :
        obj : Mass -> bool
override Equals :
        obj : Mass -> bool
function Equals(obj);
public:
virtual bool Equals(
    Mass obj
) sealed

Parameters

obj
Type: GSF.UnitsMass
A Mass value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Mass Structure
Equals Overload
GSF.Units Namespace


Mass.FromLongTons Method

Grid Solutions Framework MassFromLongTons Method
Creates a new Mass value from the specified value in long tons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass FromLongTons(
    double value
)
Public Shared Function FromLongTons (
    value As Double
) As Mass
static member FromLongTons :
        value : float -> Mass

GSF.Units.Mass.FromLongTons = function(value);
public:
static Mass FromLongTons(
    double value
)

Parameters

value
Type: SystemDouble
New Mass value in long tons.

Return Value

Type: Mass
New Mass object from the specified value in long tons.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.FromMetricPounds Method

Grid Solutions Framework MassFromMetricPounds Method
Creates a new Mass value from the specified value in metric pounds.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass FromMetricPounds(
    double value
)
Public Shared Function FromMetricPounds (
    value As Double
) As Mass
static member FromMetricPounds :
        value : float -> Mass

GSF.Units.Mass.FromMetricPounds = function(value);
public:
static Mass FromMetricPounds(
    double value
)

Parameters

value
Type: SystemDouble
New Mass value in metric pounds.

Return Value

Type: Mass
New Mass object from the specified value in metric pounds.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.FromMetricTons Method

Grid Solutions Framework MassFromMetricTons Method
Creates a new Mass value from the specified value in metric tons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass FromMetricTons(
    double value
)
Public Shared Function FromMetricTons (
    value As Double
) As Mass
static member FromMetricTons :
        value : float -> Mass

GSF.Units.Mass.FromMetricTons = function(value);
public:
static Mass FromMetricTons(
    double value
)

Parameters

value
Type: SystemDouble
New Mass value in metric tons.

Return Value

Type: Mass
New Mass object from the specified value in metric tons.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.FromOunces Method

Grid Solutions Framework MassFromOunces Method
Creates a new Mass value from the specified value in ounces (avoirdupois).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass FromOunces(
    double value
)
Public Shared Function FromOunces (
    value As Double
) As Mass
static member FromOunces :
        value : float -> Mass

GSF.Units.Mass.FromOunces = function(value);
public:
static Mass FromOunces(
    double value
)

Parameters

value
Type: SystemDouble
New Mass value in ounces.

Return Value

Type: Mass
New Mass object from the specified value in ounces.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.FromPounds Method

Grid Solutions Framework MassFromPounds Method
Creates a new Mass value from the specified value in pounds (avoirdupois).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass FromPounds(
    double value
)
Public Shared Function FromPounds (
    value As Double
) As Mass
static member FromPounds :
        value : float -> Mass

GSF.Units.Mass.FromPounds = function(value);
public:
static Mass FromPounds(
    double value
)

Parameters

value
Type: SystemDouble
New Mass value in pounds.

Return Value

Type: Mass
New Mass object from the specified value in pounds.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.FromTons Method

Grid Solutions Framework MassFromTons Method
Creates a new Mass value from the specified value in short tons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass FromTons(
    double value
)
Public Shared Function FromTons (
    value As Double
) As Mass
static member FromTons :
        value : float -> Mass

GSF.Units.Mass.FromTons = function(value);
public:
static Mass FromTons(
    double value
)

Parameters

value
Type: SystemDouble
New Mass value in short tons.

Return Value

Type: Mass
New Mass object from the specified value in short tons.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.GetHashCode Method

Grid Solutions Framework MassGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.GetTypeCode Method

Grid Solutions Framework MassGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Parse Method

Grid Solutions Framework MassParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Mass equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Mass equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Mass equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Parse Method (String)

Grid Solutions Framework MassParse Method (String)
Converts the string representation of a number to its Mass equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Mass
static member Parse :
        s : string -> Mass

GSF.Units.Mass.Parse = function(s);
public:
static Mass Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Mass
A Mass equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Mass Structure
Parse Overload
GSF.Units Namespace


Mass.Parse Method (String, NumberStyles)

Grid Solutions Framework MassParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Mass equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Mass
static member Parse :
        s : string *
        style : NumberStyles -> Mass

GSF.Units.Mass.Parse = function(s, style);
public:
static Mass Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Mass
A Mass equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Mass Structure
Parse Overload
GSF.Units Namespace


Mass.Parse Method (String, IFormatProvider)

Grid Solutions Framework MassParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Mass equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Mass
static member Parse :
        s : string *
        provider : IFormatProvider -> Mass

GSF.Units.Mass.Parse = function(s, provider);
public:
static Mass Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Mass
A Mass equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Mass Structure
Parse Overload
GSF.Units Namespace


Mass.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework MassParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Mass
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Mass

GSF.Units.Mass.Parse = function(s, style, provider);
public:
static Mass Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Mass
A Mass equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Mass Structure
Parse Overload
GSF.Units Namespace


Mass.ToLongTons Method

Grid Solutions Framework MassToLongTons Method
Gets the Mass value in long tons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToLongTons()
Public Function ToLongTons As Double
member ToLongTons : unit -> float

function ToLongTons();
public:
double ToLongTons()

Return Value

Type: Double
Value of Mass in long tons.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.ToMetricPounds Method

Grid Solutions Framework MassToMetricPounds Method
Gets the Mass value in metric pounds.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMetricPounds()
Public Function ToMetricPounds As Double
member ToMetricPounds : unit -> float

function ToMetricPounds();
public:
double ToMetricPounds()

Return Value

Type: Double
Value of Mass in metric pounds.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.ToMetricTons Method

Grid Solutions Framework MassToMetricTons Method
Gets the Mass value in metric tons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMetricTons()
Public Function ToMetricTons As Double
member ToMetricTons : unit -> float

function ToMetricTons();
public:
double ToMetricTons()

Return Value

Type: Double
Value of Mass in metric tons.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.ToOunces Method

Grid Solutions Framework MassToOunces Method
Gets the Mass value in ounces (avoirdupois).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToOunces()
Public Function ToOunces As Double
member ToOunces : unit -> float

function ToOunces();
public:
double ToOunces()

Return Value

Type: Double
Value of Mass in ounces.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.ToPounds Method

Grid Solutions Framework MassToPounds Method
Gets the Mass value in pounds (avoirdupois).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToPounds()
Public Function ToPounds As Double
member ToPounds : unit -> float

function ToPounds();
public:
double ToPounds()

Return Value

Type: Double
Value of Mass in pounds.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.ToString Method

Grid Solutions Framework MassToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.ToString Method

Grid Solutions Framework MassToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Mass Structure
ToString Overload
GSF.Units Namespace


Mass.ToString Method (IFormatProvider)

Grid Solutions Framework MassToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Mass Structure
ToString Overload
GSF.Units Namespace


Mass.ToString Method (String)

Grid Solutions Framework MassToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Mass Structure
ToString Overload
GSF.Units Namespace


Mass.ToString Method (String, IFormatProvider)

Grid Solutions Framework MassToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Mass Structure
ToString Overload
GSF.Units Namespace


Mass.ToTons Method

Grid Solutions Framework MassToTons Method
Gets the Mass value in short tons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToTons()
Public Function ToTons As Double
member ToTons : unit -> float

function ToTons();
public:
double ToTons()

Return Value

Type: Double
Value of Mass in short tons.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.TryParse Method

Grid Solutions Framework MassTryParse Method
Overload List
Name | Description
TryParse(String, Mass) | Converts the string representation of a number to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Mass) | Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.TryParse Method (String, Mass)

Grid Solutions Framework MassTryParse Method (String, Mass)
Converts the string representation of a number to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Mass result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Mass
) As Boolean
static member TryParse :
        s : string *
        result : Mass byref -> bool

GSF.Units.Mass.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Mass% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsMass
When this method returns, contains the Mass value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paraampere is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This paraampere is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Mass Structure
TryParse Overload
GSF.Units Namespace


Mass.TryParse Method (String, NumberStyles, IFormatProvider, Mass)

Grid Solutions Framework MassTryParse Method (String, NumberStyles, IFormatProvider, Mass)
Converts the string representation of a number in a specified style and culture-specific format to its Mass equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Mass result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Mass
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Mass byref -> bool

GSF.Units.Mass.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Mass% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsMass
When this method returns, contains the Mass value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paraampere is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This paraampere is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Mass Structure
TryParse Overload
GSF.Units Namespace


Mass Operators and Type Conversions

Grid Solutions Framework Mass Operators and Type Conversions

The Mass type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to mass of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Mass) | Implicitly converts value, represented in kilograms, to a Mass.
(Mass to Double) | Implicitly converts Mass, represented in kilograms, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Addition Operator

Grid Solutions Framework MassAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass operator +(
    Mass value1,
    Mass value2
)
Public Shared Operator + (
    value1 As Mass,
    value2 As Mass
) As Mass
static let inline (+)
        value1 : Mass *
        value2 : Mass  : Mass
JavaScript does not support overloaded operators.
public:
static Mass operator +(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Mass
A Mass object as the result of the operation.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Division Operator

Grid Solutions Framework MassDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass operator /(
    Mass value1,
    Mass value2
)
Public Shared Operator / (
    value1 As Mass,
    value2 As Mass
) As Mass
static let inline (/)
        value1 : Mass *
        value2 : Mass  : Mass
JavaScript does not support overloaded operators.
public:
static Mass operator /(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Mass
A Mass object as the result of the operation.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Equality Operator

Grid Solutions Framework MassEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Mass value1,
    Mass value2
)
Public Shared Operator = (
    value1 As Mass,
    value2 As Mass
) As Boolean
static let inline (=)
        value1 : Mass *
        value2 : Mass  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Exponent Operator

Grid Solutions Framework MassExponent Operator
Returns result of first value raised to mass of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Mass,
    value2 As Mass
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Double
A Double value as the result of the operation.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.GreaterThan Operator

Grid Solutions Framework MassGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Mass value1,
    Mass value2
)
Public Shared Operator > (
    value1 As Mass,
    value2 As Mass
) As Boolean
static let inline (>)
        value1 : Mass *
        value2 : Mass  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.GreaterThanOrEqual Operator

Grid Solutions Framework MassGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Mass value1,
    Mass value2
)
Public Shared Operator >= (
    value1 As Mass,
    value2 As Mass
) As Boolean
static let inline (>=)
        value1 : Mass *
        value2 : Mass  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass Implicit Conversion Operators

Grid Solutions Framework Mass Conversion Operators
Overload List
Name | Description
(Double to Mass) | Implicitly converts value, represented in kilograms, to a Mass.
(Mass to Double) | Implicitly converts Mass, represented in kilograms, to a Double.
Top
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass Implicit Conversion (Double to Mass)

Grid Solutions Framework Mass Conversion (Double to Mass)
Implicitly converts value, represented in kilograms, to a Mass.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Mass (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Mass
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Mass (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Mass
A Mass object.
See Also

Reference

Mass Structure
Overload
GSF.Units Namespace


Mass Implicit Conversion (Mass to Double)

Grid Solutions Framework Mass Conversion (Mass to Double)
Implicitly converts Mass, represented in kilograms, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Mass value
)
Public Shared Widening Operator CType (
    value As Mass
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Mass value
)

Parameters

value
Type: GSF.UnitsMass
A Mass object.

Return Value

Type: Double
A Double value.
See Also

Reference

Mass Structure
Overload
GSF.Units Namespace


Mass.Inequality Operator

Grid Solutions Framework MassInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Mass value1,
    Mass value2
)
Public Shared Operator <> (
    value1 As Mass,
    value2 As Mass
) As Boolean
static let inline (<>)
        value1 : Mass *
        value2 : Mass  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.LessThan Operator

Grid Solutions Framework MassLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Mass value1,
    Mass value2
)
Public Shared Operator < (
    value1 As Mass,
    value2 As Mass
) As Boolean
static let inline (<)
        value1 : Mass *
        value2 : Mass  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.LessThanOrEqual Operator

Grid Solutions Framework MassLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Mass value1,
    Mass value2
)
Public Shared Operator <= (
    value1 As Mass,
    value2 As Mass
) As Boolean
static let inline (<=)
        value1 : Mass *
        value2 : Mass  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Modulus Operator

Grid Solutions Framework MassModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass operator %(
    Mass value1,
    Mass value2
)
Public Shared Operator Mod (
    value1 As Mass,
    value2 As Mass
) As Mass
static let inline (%)
        value1 : Mass *
        value2 : Mass  : Mass
JavaScript does not support overloaded operators.
public:
static Mass operator %(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Mass
A Mass object as the result of the operation.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Multiply Operator

Grid Solutions Framework MassMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass operator *(
    Mass value1,
    Mass value2
)
Public Shared Operator * (
    value1 As Mass,
    value2 As Mass
) As Mass
static let inline (*)
        value1 : Mass *
        value2 : Mass  : Mass
JavaScript does not support overloaded operators.
public:
static Mass operator *(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Mass
A Mass object as the result of the operation.
See Also

Reference

Mass Structure
GSF.Units Namespace


Mass.Subtraction Operator

Grid Solutions Framework MassSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Mass operator -(
    Mass value1,
    Mass value2
)
Public Shared Operator - (
    value1 As Mass,
    value2 As Mass
) As Mass
static let inline (-)
        value1 : Mass *
        value2 : Mass  : Mass
JavaScript does not support overloaded operators.
public:
static Mass operator -(
    Mass value1,
    Mass value2
)

Parameters

value1
Type: GSF.UnitsMass
A Mass object as the left hand operand.
value2
Type: GSF.UnitsMass
A Mass object as the right hand operand.

Return Value

Type: Mass
A Mass object as the result of the operation.
See Also

Reference

Mass Structure
GSF.Units Namespace


Power Structure

Grid Solutions Framework Power Structure
Represents a power measurement, in watts, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Power : IComparable, IFormattable,
    IConvertible, IComparable<Power>, IComparable<double>, IEquatable<Power>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Power
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Power),
    IComparable(Of Double), IEquatable(Of Power), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Power =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Power>
        interface IComparable<float>
        interface IEquatable<Power>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Power : IComparable,
    IFormattable, IConvertible, IComparable<Power>, IComparable<double>,
    IEquatable<Power>, IEquatable<double>

The Power type exposes the following members.

Constructors
 | Name | Description
Public method | Power | Creates a new Power.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Power) | Compares this instance to a specified Power and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Power) | Returns a value indicating whether this instance is equal to a specified Power value.
 | FromBoilerHorsepower | Creates a new Power value from the specified value in boiler horsepower.
 | FromBTUPerSecond | Creates a new Power value from the specified value in BTU (International Table) per second.
 | FromCaloriesPerSecond | Creates a new Power value from the specified value in calories (International Table) per second.
 | FromHorsepower | Creates a new Power value from the specified value in mechanical horsepower (Imperial).
 | FromLitersAtmospherePerSecond | Creates a new Power value from the specified value in liters-atmosphere per second.
 | FromMetricHorsepower | Creates a new Power value from the specified value in metric horsepower.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Power equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Power equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Power equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent.
Public method | ToBoilerHorsepower | Gets the Power value in boiler horsepower.
Public method | ToBTUPerSecond | Gets the Power value in BTU (International Table) per second.
Public method | ToCaloriesPerSecond | Gets the Power value in calories (International Table) per second.
Public method | ToHorsepower | Gets the Power value in mechanical horsepower (Imperial).
Public method | ToLitersAtmospherePerSecond | Gets the Power value in liters-atmosphere per second.
Public method | ToMetricHorsepower | Gets the Power value in metric horsepower.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Power) | Converts the string representation of a number to its Power equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Power) | Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Power) | Implicitly converts value, represented in watts, to a Power.
(Power to Double) | Implicitly converts Power, represented in watts, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Power. This field is constant.
MinValue | Represents the smallest possible value of an Power. This field is constant.
Top
Remarks
This class behaves just like a Double representing a power in watts; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other power representations, specifically horsepower, metric horsepower, boiler horsepower, BTU per second, calorie per second, and liter-atmosphere per second. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert power in watts to megawatts:
Copy
public double GetMegawatts(Power watts)
{
    return watts / SI.Mega;
}
This example converts megawatts to mechanical horsepower:
Copy
public double GetHorsepower(double megawatts)
{
    return (new Power(megawatts * SI.Mega)).ToHorsepower();
}
See Also

Reference

GSF.Units Namespace


Power Constructor

Grid Solutions Framework Power Constructor
Creates a new Power.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Power(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Power
GSF.Units.Power = function(value);
public:
Power(
    double value
)

Parameters

value
Type: SystemDouble
New power value in watts.
See Also

Reference

Power Structure
GSF.Units Namespace


Power Fields

Grid Solutions Framework Power Fields

The Power type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Power. This field is constant.
MinValue | Represents the smallest possible value of an Power. This field is constant.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.MaxValue Field

Grid Solutions Framework PowerMaxValue Field
Represents the largest possible value of an Power. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Power MaxValue
Public Shared ReadOnly MaxValue As Power
static val MaxValue: Power
var GSF.Units.Power.MaxValue
public:
static initonly Power MaxValue

Field Value

Type: Power
See Also

Reference

Power Structure
GSF.Units Namespace


Power.MinValue Field

Grid Solutions Framework PowerMinValue Field
Represents the smallest possible value of an Power. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Power MinValue
Public Shared ReadOnly MinValue As Power
static val MinValue: Power
var GSF.Units.Power.MinValue
public:
static initonly Power MinValue

Field Value

Type: Power
See Also

Reference

Power Structure
GSF.Units Namespace


Power Methods

Grid Solutions Framework Power Methods

The Power type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Power) | Compares this instance to a specified Power and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Power) | Returns a value indicating whether this instance is equal to a specified Power value.
 | FromBoilerHorsepower | Creates a new Power value from the specified value in boiler horsepower.
 | FromBTUPerSecond | Creates a new Power value from the specified value in BTU (International Table) per second.
 | FromCaloriesPerSecond | Creates a new Power value from the specified value in calories (International Table) per second.
 | FromHorsepower | Creates a new Power value from the specified value in mechanical horsepower (Imperial).
 | FromLitersAtmospherePerSecond | Creates a new Power value from the specified value in liters-atmosphere per second.
 | FromMetricHorsepower | Creates a new Power value from the specified value in metric horsepower.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Power equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Power equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Power equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent.
Public method | ToBoilerHorsepower | Gets the Power value in boiler horsepower.
Public method | ToBTUPerSecond | Gets the Power value in BTU (International Table) per second.
Public method | ToCaloriesPerSecond | Gets the Power value in calories (International Table) per second.
Public method | ToHorsepower | Gets the Power value in mechanical horsepower (Imperial).
Public method | ToLitersAtmospherePerSecond | Gets the Power value in liters-atmosphere per second.
Public method | ToMetricHorsepower | Gets the Power value in metric horsepower.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Power) | Converts the string representation of a number to its Power equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Power) | Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.CompareTo Method

Grid Solutions Framework PowerCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Power) | Compares this instance to a specified Power and returns an indication of their relative values.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.CompareTo Method (Double)

Grid Solutions Framework PowerCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Power Structure
CompareTo Overload
GSF.Units Namespace


Power.CompareTo Method (Object)

Grid Solutions Framework PowerCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Power.
See Also

Reference

Power Structure
CompareTo Overload
GSF.Units Namespace


Power.CompareTo Method (Power)

Grid Solutions Framework PowerCompareTo Method (Power)
Compares this instance to a specified Power and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Power value
)
Public Function CompareTo (
    value As Power
) As Integer
abstract CompareTo :
        value : Power -> int
override CompareTo :
        value : Power -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Power value
) sealed

Parameters

value
Type: GSF.UnitsPower
A Power to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Power Structure
CompareTo Overload
GSF.Units Namespace


Power.Equals Method

Grid Solutions Framework PowerEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Power) | Returns a value indicating whether this instance is equal to a specified Power value.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Equals Method (Double)

Grid Solutions Framework PowerEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Power Structure
Equals Overload
GSF.Units Namespace


Power.Equals Method (Object)

Grid Solutions Framework PowerEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Power and equals the value of this instance; otherwise, False.
See Also

Reference

Power Structure
Equals Overload
GSF.Units Namespace


Power.Equals Method (Power)

Grid Solutions Framework PowerEquals Method (Power)
Returns a value indicating whether this instance is equal to a specified Power value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Power obj
)
Public Function Equals (
    obj As Power
) As Boolean
abstract Equals :
        obj : Power -> bool
override Equals :
        obj : Power -> bool
function Equals(obj);
public:
virtual bool Equals(
    Power obj
) sealed

Parameters

obj
Type: GSF.UnitsPower
A Power value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Power Structure
Equals Overload
GSF.Units Namespace


Power.FromBoilerHorsepower Method

Grid Solutions Framework PowerFromBoilerHorsepower Method
Creates a new Power value from the specified value in boiler horsepower.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power FromBoilerHorsepower(
    double value
)
Public Shared Function FromBoilerHorsepower (
    value As Double
) As Power
static member FromBoilerHorsepower :
        value : float -> Power

GSF.Units.Power.FromBoilerHorsepower = function(value);
public:
static Power FromBoilerHorsepower(
    double value
)

Parameters

value
Type: SystemDouble
New Power value in boiler horsepower.

Return Value

Type: Power
New Power object from the specified value in boiler horsepower.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.FromBTUPerSecond Method

Grid Solutions Framework PowerFromBTUPerSecond Method
Creates a new Power value from the specified value in BTU (International Table) per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power FromBTUPerSecond(
    double value
)
Public Shared Function FromBTUPerSecond (
    value As Double
) As Power
static member FromBTUPerSecond :
        value : float -> Power

GSF.Units.Power.FromBTUPerSecond = function(value);
public:
static Power FromBTUPerSecond(
    double value
)

Parameters

value
Type: SystemDouble
New Power value in BTU per second.

Return Value

Type: Power
New Power object from the specified value in BTU per second.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.FromCaloriesPerSecond Method

Grid Solutions Framework PowerFromCaloriesPerSecond Method
Creates a new Power value from the specified value in calories (International Table) per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power FromCaloriesPerSecond(
    double value
)
Public Shared Function FromCaloriesPerSecond (
    value As Double
) As Power
static member FromCaloriesPerSecond :
        value : float -> Power

GSF.Units.Power.FromCaloriesPerSecond = function(value);
public:
static Power FromCaloriesPerSecond(
    double value
)

Parameters

value
Type: SystemDouble
New Power value in calories per second.

Return Value

Type: Power
New Power object from the specified value in calories per second.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.FromHorsepower Method

Grid Solutions Framework PowerFromHorsepower Method
Creates a new Power value from the specified value in mechanical horsepower (Imperial).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power FromHorsepower(
    double value
)
Public Shared Function FromHorsepower (
    value As Double
) As Power
static member FromHorsepower :
        value : float -> Power

GSF.Units.Power.FromHorsepower = function(value);
public:
static Power FromHorsepower(
    double value
)

Parameters

value
Type: SystemDouble
New Power value in mechanical horsepower.

Return Value

Type: Power
New Power object from the specified value in mechanical horsepower.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.FromLitersAtmospherePerSecond Method

Grid Solutions Framework PowerFromLitersAtmospherePerSecond Method
Creates a new Power value from the specified value in liters-atmosphere per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power FromLitersAtmospherePerSecond(
    double value
)
Public Shared Function FromLitersAtmospherePerSecond (
    value As Double
) As Power
static member FromLitersAtmospherePerSecond :
        value : float -> Power

GSF.Units.Power.FromLitersAtmospherePerSecond = function(value);
public:
static Power FromLitersAtmospherePerSecond(
    double value
)

Parameters

value
Type: SystemDouble
New Power value in liters-atmosphere per second.

Return Value

Type: Power
New Power object from the specified value in liters-atmosphere per second.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.FromMetricHorsepower Method

Grid Solutions Framework PowerFromMetricHorsepower Method
Creates a new Power value from the specified value in metric horsepower.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power FromMetricHorsepower(
    double value
)
Public Shared Function FromMetricHorsepower (
    value As Double
) As Power
static member FromMetricHorsepower :
        value : float -> Power

GSF.Units.Power.FromMetricHorsepower = function(value);
public:
static Power FromMetricHorsepower(
    double value
)

Parameters

value
Type: SystemDouble
New Power value in metric horsepower.

Return Value

Type: Power
New Power object from the specified value in metric horsepower.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.GetHashCode Method

Grid Solutions Framework PowerGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.GetTypeCode Method

Grid Solutions Framework PowerGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Parse Method

Grid Solutions Framework PowerParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Power equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Power equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Power equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Parse Method (String)

Grid Solutions Framework PowerParse Method (String)
Converts the string representation of a number to its Power equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Power
static member Parse :
        s : string -> Power

GSF.Units.Power.Parse = function(s);
public:
static Power Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Power
A Power equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Power Structure
Parse Overload
GSF.Units Namespace


Power.Parse Method (String, NumberStyles)

Grid Solutions Framework PowerParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Power equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Power
static member Parse :
        s : string *
        style : NumberStyles -> Power

GSF.Units.Power.Parse = function(s, style);
public:
static Power Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Power
A Power equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Power Structure
Parse Overload
GSF.Units Namespace


Power.Parse Method (String, IFormatProvider)

Grid Solutions Framework PowerParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Power equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Power
static member Parse :
        s : string *
        provider : IFormatProvider -> Power

GSF.Units.Power.Parse = function(s, provider);
public:
static Power Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Power
A Power equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Power Structure
Parse Overload
GSF.Units Namespace


Power.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework PowerParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Power
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Power

GSF.Units.Power.Parse = function(s, style, provider);
public:
static Power Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Power
A Power equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Power Structure
Parse Overload
GSF.Units Namespace


Power.ToBoilerHorsepower Method

Grid Solutions Framework PowerToBoilerHorsepower Method
Gets the Power value in boiler horsepower.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToBoilerHorsepower()
Public Function ToBoilerHorsepower As Double
member ToBoilerHorsepower : unit -> float

function ToBoilerHorsepower();
public:
double ToBoilerHorsepower()

Return Value

Type: Double
Value of Power in boiler horsepower.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.ToBTUPerSecond Method

Grid Solutions Framework PowerToBTUPerSecond Method
Gets the Power value in BTU (International Table) per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToBTUPerSecond()
Public Function ToBTUPerSecond As Double
member ToBTUPerSecond : unit -> float

function ToBTUPerSecond();
public:
double ToBTUPerSecond()

Return Value

Type: Double
Value of Power in BTU per second.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.ToCaloriesPerSecond Method

Grid Solutions Framework PowerToCaloriesPerSecond Method
Gets the Power value in calories (International Table) per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToCaloriesPerSecond()
Public Function ToCaloriesPerSecond As Double
member ToCaloriesPerSecond : unit -> float

function ToCaloriesPerSecond();
public:
double ToCaloriesPerSecond()

Return Value

Type: Double
Value of Power in calories per second.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.ToHorsepower Method

Grid Solutions Framework PowerToHorsepower Method
Gets the Power value in mechanical horsepower (Imperial).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToHorsepower()
Public Function ToHorsepower As Double
member ToHorsepower : unit -> float

function ToHorsepower();
public:
double ToHorsepower()

Return Value

Type: Double
Value of Power in mechanical horsepower.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.ToLitersAtmospherePerSecond Method

Grid Solutions Framework PowerToLitersAtmospherePerSecond Method
Gets the Power value in liters-atmosphere per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToLitersAtmospherePerSecond()
Public Function ToLitersAtmospherePerSecond As Double
member ToLitersAtmospherePerSecond : unit -> float

function ToLitersAtmospherePerSecond();
public:
double ToLitersAtmospherePerSecond()

Return Value

Type: Double
Value of Power in liters-atmosphere per second.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.ToMetricHorsepower Method

Grid Solutions Framework PowerToMetricHorsepower Method
Gets the Power value in metric horsepower.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMetricHorsepower()
Public Function ToMetricHorsepower As Double
member ToMetricHorsepower : unit -> float

function ToMetricHorsepower();
public:
double ToMetricHorsepower()

Return Value

Type: Double
Value of Power in metric horsepower.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.ToString Method

Grid Solutions Framework PowerToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.ToString Method

Grid Solutions Framework PowerToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Power Structure
ToString Overload
GSF.Units Namespace


Power.ToString Method (IFormatProvider)

Grid Solutions Framework PowerToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Power Structure
ToString Overload
GSF.Units Namespace


Power.ToString Method (String)

Grid Solutions Framework PowerToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Power Structure
ToString Overload
GSF.Units Namespace


Power.ToString Method (String, IFormatProvider)

Grid Solutions Framework PowerToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Power Structure
ToString Overload
GSF.Units Namespace


Power.TryParse Method

Grid Solutions Framework PowerTryParse Method
Overload List
Name | Description
TryParse(String, Power) | Converts the string representation of a number to its Power equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Power) | Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.TryParse Method (String, Power)

Grid Solutions Framework PowerTryParse Method (String, Power)
Converts the string representation of a number to its Power equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Power result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Power
) As Boolean
static member TryParse :
        s : string *
        result : Power byref -> bool

GSF.Units.Power.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Power% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsPower
When this method returns, contains the Power value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parawatt is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parawatt is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Power Structure
TryParse Overload
GSF.Units Namespace


Power.TryParse Method (String, NumberStyles, IFormatProvider, Power)

Grid Solutions Framework PowerTryParse Method (String, NumberStyles, IFormatProvider, Power)
Converts the string representation of a number in a specified style and culture-specific format to its Power equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Power result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Power
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Power byref -> bool

GSF.Units.Power.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Power% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsPower
When this method returns, contains the Power value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parawatt is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parawatt is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Power Structure
TryParse Overload
GSF.Units Namespace


Power Operators and Type Conversions

Grid Solutions Framework Power Operators and Type Conversions

The Power type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Power) | Implicitly converts value, represented in watts, to a Power.
(Power to Double) | Implicitly converts Power, represented in watts, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Addition Operator

Grid Solutions Framework PowerAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power operator +(
    Power value1,
    Power value2
)
Public Shared Operator + (
    value1 As Power,
    value2 As Power
) As Power
static let inline (+)
        value1 : Power *
        value2 : Power  : Power
JavaScript does not support overloaded operators.
public:
static Power operator +(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power left hand operand.
value2
Type: GSF.UnitsPower
A Power right hand operand.

Return Value

Type: Power
A Power object as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Division Operator

Grid Solutions Framework PowerDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power operator /(
    Power value1,
    Power value2
)
Public Shared Operator / (
    value1 As Power,
    value2 As Power
) As Power
static let inline (/)
        value1 : Power *
        value2 : Power  : Power
JavaScript does not support overloaded operators.
public:
static Power operator /(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power left hand operand.
value2
Type: GSF.UnitsPower
A Power right hand operand.

Return Value

Type: Power
A Power object as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Equality Operator

Grid Solutions Framework PowerEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Power value1,
    Power value2
)
Public Shared Operator = (
    value1 As Power,
    value2 As Power
) As Boolean
static let inline (=)
        value1 : Power *
        value2 : Power  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power object as the left hand operand.
value2
Type: GSF.UnitsPower
A Power object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Exponent Operator

Grid Solutions Framework PowerExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Power,
    value2 As Power
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsPower
A Power left hand operand.
value2
Type: GSF.UnitsPower
A Power right hand operand.

Return Value

Type: Double
A Double value as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.GreaterThan Operator

Grid Solutions Framework PowerGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Power value1,
    Power value2
)
Public Shared Operator > (
    value1 As Power,
    value2 As Power
) As Boolean
static let inline (>)
        value1 : Power *
        value2 : Power  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power object as the left hand operand.
value2
Type: GSF.UnitsPower
A Power object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.GreaterThanOrEqual Operator

Grid Solutions Framework PowerGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Power value1,
    Power value2
)
Public Shared Operator >= (
    value1 As Power,
    value2 As Power
) As Boolean
static let inline (>=)
        value1 : Power *
        value2 : Power  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power object as the left hand operand.
value2
Type: GSF.UnitsPower
A Power object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power Implicit Conversion Operators

Grid Solutions Framework Power Conversion Operators
Overload List
Name | Description
(Double to Power) | Implicitly converts value, represented in watts, to a Power.
(Power to Double) | Implicitly converts Power, represented in watts, to a Double.
Top
See Also

Reference

Power Structure
GSF.Units Namespace


Power Implicit Conversion (Double to Power)

Grid Solutions Framework Power Conversion (Double to Power)
Implicitly converts value, represented in watts, to a Power.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Power (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Power
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Power (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Power
A Power object.
See Also

Reference

Power Structure
Overload
GSF.Units Namespace


Power Implicit Conversion (Power to Double)

Grid Solutions Framework Power Conversion (Power to Double)
Implicitly converts Power, represented in watts, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Power value
)
Public Shared Widening Operator CType (
    value As Power
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Power value
)

Parameters

value
Type: GSF.UnitsPower
A Power object.

Return Value

Type: Double
A Double value.
See Also

Reference

Power Structure
Overload
GSF.Units Namespace


Power.Inequality Operator

Grid Solutions Framework PowerInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Power value1,
    Power value2
)
Public Shared Operator <> (
    value1 As Power,
    value2 As Power
) As Boolean
static let inline (<>)
        value1 : Power *
        value2 : Power  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power object as the left hand operand.
value2
Type: GSF.UnitsPower
A Power object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.LessThan Operator

Grid Solutions Framework PowerLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Power value1,
    Power value2
)
Public Shared Operator < (
    value1 As Power,
    value2 As Power
) As Boolean
static let inline (<)
        value1 : Power *
        value2 : Power  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power object as the left hand operand.
value2
Type: GSF.UnitsPower
A Power object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.LessThanOrEqual Operator

Grid Solutions Framework PowerLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Power value1,
    Power value2
)
Public Shared Operator <= (
    value1 As Power,
    value2 As Power
) As Boolean
static let inline (<=)
        value1 : Power *
        value2 : Power  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power object as the left hand operand.
value2
Type: GSF.UnitsPower
A Power object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Modulus Operator

Grid Solutions Framework PowerModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power operator %(
    Power value1,
    Power value2
)
Public Shared Operator Mod (
    value1 As Power,
    value2 As Power
) As Power
static let inline (%)
        value1 : Power *
        value2 : Power  : Power
JavaScript does not support overloaded operators.
public:
static Power operator %(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power left hand operand.
value2
Type: GSF.UnitsPower
A Power right hand operand.

Return Value

Type: Power
A Power object as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Multiply Operator

Grid Solutions Framework PowerMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power operator *(
    Power value1,
    Power value2
)
Public Shared Operator * (
    value1 As Power,
    value2 As Power
) As Power
static let inline (*)
        value1 : Power *
        value2 : Power  : Power
JavaScript does not support overloaded operators.
public:
static Power operator *(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power left hand operand.
value2
Type: GSF.UnitsPower
A Power right hand operand.

Return Value

Type: Power
A Power object as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


Power.Subtraction Operator

Grid Solutions Framework PowerSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Power operator -(
    Power value1,
    Power value2
)
Public Shared Operator - (
    value1 As Power,
    value2 As Power
) As Power
static let inline (-)
        value1 : Power *
        value2 : Power  : Power
JavaScript does not support overloaded operators.
public:
static Power operator -(
    Power value1,
    Power value2
)

Parameters

value1
Type: GSF.UnitsPower
A Power left hand operand.
value2
Type: GSF.UnitsPower
A Power right hand operand.

Return Value

Type: Power
A Power object as the result of the operation.
See Also

Reference

Power Structure
GSF.Units Namespace


SI Class

Grid Solutions Framework SI Class
Defines constant factors for SI units of measure to handle metric conversions.
Inheritance Hierarchy
SystemObject
GSF.UnitsSI

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SI
Public NotInheritable Class SI
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SI =  class end
GSF.Units.SI = function();

Type.createClass(
    'GSF.Units.SI');
public ref class SI abstract sealed

The SI type exposes the following members.

Methods
Name | Description
ToScaledString(Double, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, Int32, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, String, String, String, Int32, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling given string array of factor names or symbols.
Top
Fields
Name | Description
Atto | SI prefix a, 10^-18
Centi | SI prefix c, 10^-2
Deca | SI prefix da, 10^1
Deci | SI prefix d, 10^-1
Exa | SI prefix E, 10^18
Femto | SI prefix f, 10^-15
Giga | SI prefix G, 10^9
Hecto | SI prefix h, 10^2
Kilo | SI prefix k, 10^3
Mega | SI prefix M, 10^6
Micro | SI prefix µ, 10^-6
Milli | SI prefix m, 10^-3
Nano | SI prefix n, 10^-9
Peta | SI prefix P, 10^15
Pico | SI prefix p, 10^-12
Tera | SI prefix T, 10^12
Yocto | SI prefix y, 10^-24
Yotta | SI prefix Y, 10^24
Zepto | SI prefix z, 10^-21
Zetta | SI prefix Z, 10^21
Top
Properties
Name | Description
Factors | Gets an array of all the defined SI unit factors ordered from least (Yocto) to greatest (Yotta).
Names | Gets an array of all the defined unit factor SI names ordered from least (Yocto) to greatest (Yotta).
Symbols | Gets an array of all the defined unit factor SI prefix symbols ordered from least (Yocto) to greatest (Yotta).
Top
See Also

Reference

GSF.Units Namespace


SI Fields

Grid Solutions Framework SI Fields

The SI type exposes the following members.

Fields
Name | Description
Atto | SI prefix a, 10^-18
Centi | SI prefix c, 10^-2
Deca | SI prefix da, 10^1
Deci | SI prefix d, 10^-1
Exa | SI prefix E, 10^18
Femto | SI prefix f, 10^-15
Giga | SI prefix G, 10^9
Hecto | SI prefix h, 10^2
Kilo | SI prefix k, 10^3
Mega | SI prefix M, 10^6
Micro | SI prefix µ, 10^-6
Milli | SI prefix m, 10^-3
Nano | SI prefix n, 10^-9
Peta | SI prefix P, 10^15
Pico | SI prefix p, 10^-12
Tera | SI prefix T, 10^12
Yocto | SI prefix y, 10^-24
Yotta | SI prefix Y, 10^24
Zepto | SI prefix z, 10^-21
Zetta | SI prefix Z, 10^21
Top
See Also

Reference

SI Class
GSF.Units Namespace


SI.Atto Field

Grid Solutions Framework SIAtto Field
SI prefix a, 10^-18

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Atto
Public Const Atto As Double
static val mutable Atto: float
var GSF.Units.SI.Atto
public:
literal double Atto

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Centi Field

Grid Solutions Framework SICenti Field
SI prefix c, 10^-2

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Centi
Public Const Centi As Double
static val mutable Centi: float
var GSF.Units.SI.Centi
public:
literal double Centi

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Deca Field

Grid Solutions Framework SIDeca Field
SI prefix da, 10^1

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Deca
Public Const Deca As Double
static val mutable Deca: float
var GSF.Units.SI.Deca
public:
literal double Deca

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Deci Field

Grid Solutions Framework SIDeci Field
SI prefix d, 10^-1

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Deci
Public Const Deci As Double
static val mutable Deci: float
var GSF.Units.SI.Deci
public:
literal double Deci

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Exa Field

Grid Solutions Framework SIExa Field
SI prefix E, 10^18

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Exa
Public Const Exa As Double
static val mutable Exa: float
var GSF.Units.SI.Exa
public:
literal double Exa

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Femto Field

Grid Solutions Framework SIFemto Field
SI prefix f, 10^-15

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Femto
Public Const Femto As Double
static val mutable Femto: float
var GSF.Units.SI.Femto
public:
literal double Femto

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Giga Field

Grid Solutions Framework SIGiga Field
SI prefix G, 10^9

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Giga
Public Const Giga As Double
static val mutable Giga: float
var GSF.Units.SI.Giga
public:
literal double Giga

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Hecto Field

Grid Solutions Framework SIHecto Field
SI prefix h, 10^2

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Hecto
Public Const Hecto As Double
static val mutable Hecto: float
var GSF.Units.SI.Hecto
public:
literal double Hecto

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Kilo Field

Grid Solutions Framework SIKilo Field
SI prefix k, 10^3

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Kilo
Public Const Kilo As Double
static val mutable Kilo: float
var GSF.Units.SI.Kilo
public:
literal double Kilo

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Mega Field

Grid Solutions Framework SIMega Field
SI prefix M, 10^6

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Mega
Public Const Mega As Double
static val mutable Mega: float
var GSF.Units.SI.Mega
public:
literal double Mega

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Micro Field

Grid Solutions Framework SIMicro Field
SI prefix µ, 10^-6

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Micro
Public Const Micro As Double
static val mutable Micro: float
var GSF.Units.SI.Micro
public:
literal double Micro

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Milli Field

Grid Solutions Framework SIMilli Field
SI prefix m, 10^-3

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Milli
Public Const Milli As Double
static val mutable Milli: float
var GSF.Units.SI.Milli
public:
literal double Milli

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Nano Field

Grid Solutions Framework SINano Field
SI prefix n, 10^-9

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Nano
Public Const Nano As Double
static val mutable Nano: float
var GSF.Units.SI.Nano
public:
literal double Nano

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Peta Field

Grid Solutions Framework SIPeta Field
SI prefix P, 10^15

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Peta
Public Const Peta As Double
static val mutable Peta: float
var GSF.Units.SI.Peta
public:
literal double Peta

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Pico Field

Grid Solutions Framework SIPico Field
SI prefix p, 10^-12

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Pico
Public Const Pico As Double
static val mutable Pico: float
var GSF.Units.SI.Pico
public:
literal double Pico

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Tera Field

Grid Solutions Framework SITera Field
SI prefix T, 10^12

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Tera
Public Const Tera As Double
static val mutable Tera: float
var GSF.Units.SI.Tera
public:
literal double Tera

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Yocto Field

Grid Solutions Framework SIYocto Field
SI prefix y, 10^-24

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Yocto
Public Const Yocto As Double
static val mutable Yocto: float
var GSF.Units.SI.Yocto
public:
literal double Yocto

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Yotta Field

Grid Solutions Framework SIYotta Field
SI prefix Y, 10^24

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Yotta
Public Const Yotta As Double
static val mutable Yotta: float
var GSF.Units.SI.Yotta
public:
literal double Yotta

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Zepto Field

Grid Solutions Framework SIZepto Field
SI prefix z, 10^-21

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Zepto
Public Const Zepto As Double
static val mutable Zepto: float
var GSF.Units.SI.Zepto
public:
literal double Zepto

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Zetta Field

Grid Solutions Framework SIZetta Field
SI prefix Z, 10^21

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double Zetta
Public Const Zetta As Double
static val mutable Zetta: float
var GSF.Units.SI.Zetta
public:
literal double Zetta

Field Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI Methods

Grid Solutions Framework SI Methods
Methods
Name | Description
ToScaledString(Double, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, Int32, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, String, String, String, Int32, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling given string array of factor names or symbols.
Top
See Also

Reference

SI Class
GSF.Units Namespace


SI.ToScaledString Method

Grid Solutions Framework SIToScaledString Method
Overload List
Name | Description
ToScaledString(Double, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, Int32, String, String, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling.
ToScaledString(Double, String, String, String, Int32, Double, Double) | Turns the given number of units into a textual representation with an appropriate unit scaling given string array of factor names or symbols.
Top
See Also

Reference

SI Class
GSF.Units Namespace


SI.ToScaledString Method (Double, String, String, Double, Double)

Grid Solutions Framework SIToScaledString Method (Double, String, String, Double, Double)
Turns the given number of units into a textual representation with an appropriate unit scaling.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    double totalUnits,
    string format,
    string unitName,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)
Public Shared Function ToScaledString (
    totalUnits As Double,
    format As String,
    unitName As String,
    Optional minimumFactor As Double = 1E-24,
    Optional maximumFactor As Double = 1E+24
) As String
static member ToScaledString :
        totalUnits : float *
        format : string *
        unitName : string *
        ?minimumFactor : float *
        ?maximumFactor : float
(* Defaults:
        let _minimumFactor = defaultArg minimumFactor 1E-24
        let _maximumFactor = defaultArg maximumFactor 1E+24
*)
-> string

GSF.Units.SI.ToScaledString = function(totalUnits, format, unitName, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    double totalUnits,
    String^ format,
    String^ unitName,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)

Parameters

totalUnits
Type: SystemDouble
Total units to represent textually.
format
Type: SystemString
A numeric string format for scaled totalUnits.
unitName
Type: SystemString
Name of unit display (e.g., you could use "m/h" for meters per hour).
minimumFactor (Optional)
Type: SystemDouble
Optional minimum SI factor. Defaults to Yocto.
maximumFactor (Optional)
Type: SystemDouble
Optional maximum SI factor. Defaults to Yotta.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
Symbols array is used for displaying SI symbol prefix for unitName.
See Also

Reference

SI Class
ToScaledString Overload
GSF.Units Namespace


SI.ToScaledString Method (Double, String, String[], Double, Double)

Grid Solutions Framework SIToScaledString Method (Double, String, String, Double, Double)
Turns the given number of units into a textual representation with an appropriate unit scaling.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    double totalUnits,
    string unitName,
    string[] symbolNames = null,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)
Public Shared Function ToScaledString (
    totalUnits As Double,
    unitName As String,
    Optional symbolNames As String() = Nothing,
    Optional minimumFactor As Double = 1E-24,
    Optional maximumFactor As Double = 1E+24
) As String
static member ToScaledString :
        totalUnits : float *
        unitName : string *
        ?symbolNames : string[] *
        ?minimumFactor : float *
        ?maximumFactor : float
(* Defaults:
        let _symbolNames = defaultArg symbolNames null
        let _minimumFactor = defaultArg minimumFactor 1E-24
        let _maximumFactor = defaultArg maximumFactor 1E+24
*)
-> string

GSF.Units.SI.ToScaledString = function(totalUnits, unitName, symbolNames, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    double totalUnits,
    String^ unitName,
    array<String^>^ symbolNames = nullptr,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)

Parameters

totalUnits
Type: SystemDouble
Total units to represent textually.
unitName
Type: SystemString
Name of unit display (e.g., you could use "m/h" for meters per hour).
symbolNames (Optional)
Type: SystemString
Optional SI factor symbol or name array to use during textual conversion, defaults to Symbols.
minimumFactor (Optional)
Type: SystemDouble
Optional minimum SI factor. Defaults to Yocto.
maximumFactor (Optional)
Type: SystemDouble
Optional maximum SI factor. Defaults to Yotta.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
The symbolNames array needs one string entry for each defined SI item ordered from least (Yocto) to greatest (Yotta), see Names or Symbols arrays for examples.
See Also

Reference

SI Class
ToScaledString Overload
GSF.Units Namespace


SI.ToScaledString Method (Double, Int32, String, String[], Double, Double)

Grid Solutions Framework SIToScaledString Method (Double, Int32, String, String, Double, Double)
Turns the given number of units into a textual representation with an appropriate unit scaling.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    double totalUnits,
    int decimalPlaces,
    string unitName,
    string[] symbolNames = null,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)
Public Shared Function ToScaledString (
    totalUnits As Double,
    decimalPlaces As Integer,
    unitName As String,
    Optional symbolNames As String() = Nothing,
    Optional minimumFactor As Double = 1E-24,
    Optional maximumFactor As Double = 1E+24
) As String
static member ToScaledString :
        totalUnits : float *
        decimalPlaces : int *
        unitName : string *
        ?symbolNames : string[] *
        ?minimumFactor : float *
        ?maximumFactor : float
(* Defaults:
        let _symbolNames = defaultArg symbolNames null
        let _minimumFactor = defaultArg minimumFactor 1E-24
        let _maximumFactor = defaultArg maximumFactor 1E+24
*)
-> string

GSF.Units.SI.ToScaledString = function(totalUnits, decimalPlaces, unitName, symbolNames, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    double totalUnits,
    int decimalPlaces,
    String^ unitName,
    array<String^>^ symbolNames = nullptr,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)

Parameters

totalUnits
Type: SystemDouble
Total units to represent textually.
decimalPlaces
Type: SystemInt32
Number of decimal places to display.
unitName
Type: SystemString
Name of unit display (e.g., you could use "m/h" for meters per hour).
symbolNames (Optional)
Type: SystemString
Optional SI factor symbol or name array to use during textual conversion, defaults to Symbols.
minimumFactor (Optional)
Type: SystemDouble
Optional minimum SI factor. Defaults to Yocto.
maximumFactor (Optional)
Type: SystemDouble
Optional maximum SI factor. Defaults to Yotta.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | decimalPlaces cannot be negative.
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
The symbolNames array needs one string entry for each defined SI item ordered from least (Yocto) to greatest (Yotta), see Names or Symbols arrays for examples.
See Also

Reference

SI Class
ToScaledString Overload
GSF.Units Namespace


SI.ToScaledString Method (Double, String, String, String[], Int32, Double, Double)

Grid Solutions Framework SIToScaledString Method (Double, String, String, String, Int32, Double, Double)
Turns the given number of units into a textual representation with an appropriate unit scaling given string array of factor names or symbols.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    double totalUnits,
    string format,
    string unitName,
    string[] symbolNames,
    int decimalPlaces = -1,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)
Public Shared Function ToScaledString (
    totalUnits As Double,
    format As String,
    unitName As String,
    symbolNames As String(),
    Optional decimalPlaces As Integer = -1,
    Optional minimumFactor As Double = 1E-24,
    Optional maximumFactor As Double = 1E+24
) As String
static member ToScaledString :
        totalUnits : float *
        format : string *
        unitName : string *
        symbolNames : string[] *
        ?decimalPlaces : int *
        ?minimumFactor : float *
        ?maximumFactor : float
(* Defaults:
        let _decimalPlaces = defaultArg decimalPlaces -1
        let _minimumFactor = defaultArg minimumFactor 1E-24
        let _maximumFactor = defaultArg maximumFactor 1E+24
*)
-> string

GSF.Units.SI.ToScaledString = function(totalUnits, format, unitName, symbolNames, decimalPlaces, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    double totalUnits,
    String^ format,
    String^ unitName,
    array<String^>^ symbolNames,
    int decimalPlaces = -1,
    double minimumFactor = 1E-24,
    double maximumFactor = 1E+24
)

Parameters

totalUnits
Type: SystemDouble
Total units to represent textually.
format
Type: SystemString
A numeric string format for scaled totalUnits.
unitName
Type: SystemString
Name of unit display (e.g., you could use "m/h" for meters per hour).
symbolNames
Type: SystemString
SI factor symbol or name array to use during textual conversion.
decimalPlaces (Optional)
Type: SystemInt32
Optional number of decimal places to display.
minimumFactor (Optional)
Type: SystemDouble
Optional minimum SI factor. Defaults to Yocto.
maximumFactor (Optional)
Type: SystemDouble
Optional maximum SI factor. Defaults to Yotta.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
The symbolNames array needs one string entry for each defined SI item ordered from least (Yocto) to greatest (Yotta), see Names or Symbols arrays for examples.
See Also

Reference

SI Class
ToScaledString Overload
GSF.Units Namespace


SI Properties

Grid Solutions Framework SI Properties

The SI type exposes the following members.

Properties
Name | Description
Factors | Gets an array of all the defined SI unit factors ordered from least (Yocto) to greatest (Yotta).
Names | Gets an array of all the defined unit factor SI names ordered from least (Yocto) to greatest (Yotta).
Symbols | Gets an array of all the defined unit factor SI prefix symbols ordered from least (Yocto) to greatest (Yotta).
Top
See Also

Reference

SI Class
GSF.Units Namespace


SI.Factors Property

Grid Solutions Framework SIFactors Property
Gets an array of all the defined SI unit factors ordered from least (Yocto) to greatest (Yotta).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static double[] Factors { get; }
Public Shared ReadOnly Property Factors As Double()
    Get
static member Factors : float[] with get

GSF.Units.SI.get_Factors = function();

public:
static property array<double>^ Factors {
    array<double>^ get ();
}

Property Value

Type: Double
See Also

Reference

SI Class
GSF.Units Namespace


SI.Names Property

Grid Solutions Framework SINames Property
Gets an array of all the defined unit factor SI names ordered from least (Yocto) to greatest (Yotta).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] Names { get; }
Public Shared ReadOnly Property Names As String()
    Get
static member Names : string[] with get

GSF.Units.SI.get_Names = function();

public:
static property array<String^>^ Names {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

SI Class
GSF.Units Namespace


SI.Symbols Property

Grid Solutions Framework SISymbols Property
Gets an array of all the defined unit factor SI prefix symbols ordered from least (Yocto) to greatest (Yotta).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] Symbols { get; }
Public Shared ReadOnly Property Symbols As String()
    Get
static member Symbols : string[] with get

GSF.Units.SI.get_Symbols = function();

public:
static property array<String^>^ Symbols {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

SI Class
GSF.Units Namespace


SI2 Class

Grid Solutions Framework SI2 Class
Defines constant factors based on 1024 for related binary SI units of measure used in computational measurements.
Inheritance Hierarchy
SystemObject
GSF.UnitsSI2

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SI2
Public NotInheritable Class SI2
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SI2 =  class end
GSF.Units.SI2 = function();

Type.createClass(
    'GSF.Units.SI2');
public ref class SI2 abstract sealed

The SI2 type exposes the following members.

Methods
Name | Description
ToScaledString(Int64, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, Int32, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, String, String, String, Int32, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling given string array of factor names or symbols.
Top
Fields
Name | Description
Exa | 1 exa, binary (E) = 1,152,921,504,606,846,976
Exbi | 1 exbi (Ei) = 1,152,921,504,606,846,976
Gibi | 1 gibi (Gi) = 1,073,741,824
Giga | 1 giga, binary (G) = 1,073,741,824
Kibi | 1 kibi (Ki) = 1,024
Kilo | 1 kilo, binary (K) = 1,024
Mebi | 1 mebi (Mi) = 1,048,576
Mega | 1 mega, binary (M) = 1,048,576
Pebi | 1 pebi (Pi) = 1,125,899,906,842,624
Peta | 1 peta, binary (P) = 1,125,899,906,842,624
Tebi | 1 tebi (Ti) = 1,099,511,627,776
Tera | 1 tera, binary (T) = 1,099,511,627,776
Top
Properties
Name | Description
Factors | Gets an array of all the defined binary SI unit factors ordered from least (Kilo) to greatest (Exa).
IECNames | Gets an array of all the defined IEC binary unit factor SI names ordered from least (Kibi) to greatest (Exbi).
IECSymbols | Gets an array of all the defined IEC binary unit factor SI prefix symbols ordered from least (Kibi) to greatest (Exbi).
Names | Gets an array of all the defined common binary unit factor SI names ordered from least (Kilo) to greatest (Exa).
Symbols | Gets an array of all the defined common binary unit factor SI prefix symbols ordered from least (Kilo) to greatest (Exa).
Top
Remarks
See NIST Reference for information on IEC standard names.
See Also

Reference

GSF.Units Namespace


SI2 Fields

Grid Solutions Framework SI2 Fields

The SI2 type exposes the following members.

Fields
Name | Description
Exa | 1 exa, binary (E) = 1,152,921,504,606,846,976
Exbi | 1 exbi (Ei) = 1,152,921,504,606,846,976
Gibi | 1 gibi (Gi) = 1,073,741,824
Giga | 1 giga, binary (G) = 1,073,741,824
Kibi | 1 kibi (Ki) = 1,024
Kilo | 1 kilo, binary (K) = 1,024
Mebi | 1 mebi (Mi) = 1,048,576
Mega | 1 mega, binary (M) = 1,048,576
Pebi | 1 pebi (Pi) = 1,125,899,906,842,624
Peta | 1 peta, binary (P) = 1,125,899,906,842,624
Tebi | 1 tebi (Ti) = 1,099,511,627,776
Tera | 1 tera, binary (T) = 1,099,511,627,776
Top
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Exa Field

Grid Solutions Framework SI2Exa Field
1 exa, binary (E) = 1,152,921,504,606,846,976

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Exa
Public Const Exa As Long
static val mutable Exa: int64
var GSF.Units.SI2.Exa
public:
literal long long Exa

Field Value

Type: Int64
Remarks
This is the common name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Exbi Field

Grid Solutions Framework SI2Exbi Field
1 exbi (Ei) = 1,152,921,504,606,846,976

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Exbi
Public Const Exbi As Long
static val mutable Exbi: int64
var GSF.Units.SI2.Exbi
public:
literal long long Exbi

Field Value

Type: Int64
Remarks
This is the IEC standard name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Gibi Field

Grid Solutions Framework SI2Gibi Field
1 gibi (Gi) = 1,073,741,824

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Gibi
Public Const Gibi As Long
static val mutable Gibi: int64
var GSF.Units.SI2.Gibi
public:
literal long long Gibi

Field Value

Type: Int64
Remarks
This is the IEC standard name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Giga Field

Grid Solutions Framework SI2Giga Field
1 giga, binary (G) = 1,073,741,824

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Giga
Public Const Giga As Long
static val mutable Giga: int64
var GSF.Units.SI2.Giga
public:
literal long long Giga

Field Value

Type: Int64
Remarks
This is the common name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Kibi Field

Grid Solutions Framework SI2Kibi Field
1 kibi (Ki) = 1,024

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Kibi
Public Const Kibi As Long
static val mutable Kibi: int64
var GSF.Units.SI2.Kibi
public:
literal long long Kibi

Field Value

Type: Int64
Remarks
This is the IEC standard name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Kilo Field

Grid Solutions Framework SI2Kilo Field
1 kilo, binary (K) = 1,024

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Kilo
Public Const Kilo As Long
static val mutable Kilo: int64
var GSF.Units.SI2.Kilo
public:
literal long long Kilo

Field Value

Type: Int64
Remarks
This is the common name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Mebi Field

Grid Solutions Framework SI2Mebi Field
1 mebi (Mi) = 1,048,576

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Mebi
Public Const Mebi As Long
static val mutable Mebi: int64
var GSF.Units.SI2.Mebi
public:
literal long long Mebi

Field Value

Type: Int64
Remarks
This is the IEC standard name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Mega Field

Grid Solutions Framework SI2Mega Field
1 mega, binary (M) = 1,048,576

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Mega
Public Const Mega As Long
static val mutable Mega: int64
var GSF.Units.SI2.Mega
public:
literal long long Mega

Field Value

Type: Int64
Remarks
This is the common name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Pebi Field

Grid Solutions Framework SI2Pebi Field
1 pebi (Pi) = 1,125,899,906,842,624

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Pebi
Public Const Pebi As Long
static val mutable Pebi: int64
var GSF.Units.SI2.Pebi
public:
literal long long Pebi

Field Value

Type: Int64
Remarks
This is the IEC standard name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Peta Field

Grid Solutions Framework SI2Peta Field
1 peta, binary (P) = 1,125,899,906,842,624

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Peta
Public Const Peta As Long
static val mutable Peta: int64
var GSF.Units.SI2.Peta
public:
literal long long Peta

Field Value

Type: Int64
Remarks
This is the common name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Tebi Field

Grid Solutions Framework SI2Tebi Field
1 tebi (Ti) = 1,099,511,627,776

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Tebi
Public Const Tebi As Long
static val mutable Tebi: int64
var GSF.Units.SI2.Tebi
public:
literal long long Tebi

Field Value

Type: Int64
Remarks
This is the IEC standard name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Tera Field

Grid Solutions Framework SI2Tera Field
1 tera, binary (T) = 1,099,511,627,776

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const long Tera
Public Const Tera As Long
static val mutable Tera: int64
var GSF.Units.SI2.Tera
public:
literal long long Tera

Field Value

Type: Int64
Remarks
This is the common name.
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2 Methods

Grid Solutions Framework SI2 Methods
Methods
Name | Description
ToScaledString(Int64, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, Int32, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, String, String, String, Int32, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling given string array of factor names or symbols.
Top
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.ToScaledString Method

Grid Solutions Framework SI2ToScaledString Method
Overload List
Name | Description
ToScaledString(Int64, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, Int32, String, String, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).
ToScaledString(Int64, String, String, String, Int32, Int64, Int64) | Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling given string array of factor names or symbols.
Top
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.ToScaledString Method (Int64, String, String, Int64, Int64)

Grid Solutions Framework SI2ToScaledString Method (Int64, String, String, Int64, Int64)
Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    long totalUnits,
    string format,
    string unitName,
    long minimumFactor = 1024,
    long maximumFactor = 1152921504606846976
)
Public Shared Function ToScaledString (
    totalUnits As Long,
    format As String,
    unitName As String,
    Optional minimumFactor As Long = 1024,
    Optional maximumFactor As Long = 1152921504606846976
) As String
static member ToScaledString :
        totalUnits : int64 *
        format : string *
        unitName : string *
        ?minimumFactor : int64 *
        ?maximumFactor : int64
(* Defaults:
        let _minimumFactor = defaultArg minimumFactor 1024
        let _maximumFactor = defaultArg maximumFactor 1152921504606846976
*)
-> string

GSF.Units.SI2.ToScaledString = function(totalUnits, format, unitName, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    long long totalUnits,
    String^ format,
    String^ unitName,
    long long minimumFactor = 1024,
    long long maximumFactor = 1152921504606846976
)

Parameters

totalUnits
Type: SystemInt64
Total units to represent textually.
format
Type: SystemString
A numeric string format for scaled totalUnits.
unitName
Type: SystemString
Name of unit display (e.g., you could use "B" for bytes).
minimumFactor (Optional)
Type: SystemInt64
Optional minimum SI factor. Defaults to Kilo.
maximumFactor (Optional)
Type: SystemInt64
Optional maximum SI factor. Defaults to Exa.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
Symbols array is used for displaying SI symbol prefix for unitName.
See Also

Reference

SI2 Class
ToScaledString Overload
GSF.Units Namespace


SI2.ToScaledString Method (Int64, String, String[], Int64, Int64)

Grid Solutions Framework SI2ToScaledString Method (Int64, String, String, Int64, Int64)
Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    long totalUnits,
    string unitName,
    string[] symbolNames = null,
    long minimumFactor = 1024,
    long maximumFactor = 1152921504606846976
)
Public Shared Function ToScaledString (
    totalUnits As Long,
    unitName As String,
    Optional symbolNames As String() = Nothing,
    Optional minimumFactor As Long = 1024,
    Optional maximumFactor As Long = 1152921504606846976
) As String
static member ToScaledString :
        totalUnits : int64 *
        unitName : string *
        ?symbolNames : string[] *
        ?minimumFactor : int64 *
        ?maximumFactor : int64
(* Defaults:
        let _symbolNames = defaultArg symbolNames null
        let _minimumFactor = defaultArg minimumFactor 1024
        let _maximumFactor = defaultArg maximumFactor 1152921504606846976
*)
-> string

GSF.Units.SI2.ToScaledString = function(totalUnits, unitName, symbolNames, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    long long totalUnits,
    String^ unitName,
    array<String^>^ symbolNames = nullptr,
    long long minimumFactor = 1024,
    long long maximumFactor = 1152921504606846976
)

Parameters

totalUnits
Type: SystemInt64
Total units to represent textually.
unitName
Type: SystemString
Name of unit display (e.g., you could use "B" for bytes).
symbolNames (Optional)
Type: SystemString
Optional SI factor symbol or name array to use during textual conversion, defaults to Symbols.
minimumFactor (Optional)
Type: SystemInt64
Optional minimum SI factor. Defaults to Kilo.
maximumFactor (Optional)
Type: SystemInt64
Optional maximum SI factor. Defaults to Exa.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
The symbolNames array needs one string entry for each defined SI item ordered from least (Kilo) to greatest (Exa), see Names or Symbols arrays for examples.
See Also

Reference

SI2 Class
ToScaledString Overload
GSF.Units Namespace


SI2.ToScaledString Method (Int64, Int32, String, String[], Int64, Int64)

Grid Solutions Framework SI2ToScaledString Method (Int64, Int32, String, String, Int64, Int64)
Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling and common named representation (e.g., KB, MB, GB, TB, etc.).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    long totalUnits,
    int decimalPlaces,
    string unitName,
    string[] symbolNames = null,
    long minimumFactor = 1024,
    long maximumFactor = 1152921504606846976
)
Public Shared Function ToScaledString (
    totalUnits As Long,
    decimalPlaces As Integer,
    unitName As String,
    Optional symbolNames As String() = Nothing,
    Optional minimumFactor As Long = 1024,
    Optional maximumFactor As Long = 1152921504606846976
) As String
static member ToScaledString :
        totalUnits : int64 *
        decimalPlaces : int *
        unitName : string *
        ?symbolNames : string[] *
        ?minimumFactor : int64 *
        ?maximumFactor : int64
(* Defaults:
        let _symbolNames = defaultArg symbolNames null
        let _minimumFactor = defaultArg minimumFactor 1024
        let _maximumFactor = defaultArg maximumFactor 1152921504606846976
*)
-> string

GSF.Units.SI2.ToScaledString = function(totalUnits, decimalPlaces, unitName, symbolNames, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    long long totalUnits,
    int decimalPlaces,
    String^ unitName,
    array<String^>^ symbolNames = nullptr,
    long long minimumFactor = 1024,
    long long maximumFactor = 1152921504606846976
)

Parameters

totalUnits
Type: SystemInt64
Total units to represent textually.
decimalPlaces
Type: SystemInt32
Number of decimal places to display.
unitName
Type: SystemString
Name of unit display (e.g., you could use "B" for bytes).
symbolNames (Optional)
Type: SystemString
Optional SI factor symbol or name array to use during textual conversion, defaults to Symbols.
minimumFactor (Optional)
Type: SystemInt64
Optional minimum SI factor. Defaults to Kilo.
maximumFactor (Optional)
Type: SystemInt64
Optional maximum SI factor. Defaults to Exa.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | decimalPlaces cannot be negative.
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
The symbolNames array needs one string entry for each defined SI item ordered from least (Kilo) to greatest (Exa), see Names or Symbols arrays for examples.
See Also

Reference

SI2 Class
ToScaledString Overload
GSF.Units Namespace


SI2.ToScaledString Method (Int64, String, String, String[], Int32, Int64, Int64)

Grid Solutions Framework SI2ToScaledString Method (Int64, String, String, String, Int32, Int64, Int64)
Turns the given number of units (e.g., bytes) into a textual representation with an appropriate unit scaling given string array of factor names or symbols.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToScaledString(
    long totalUnits,
    string format,
    string unitName,
    string[] symbolNames,
    int decimalPlaces = -1,
    long minimumFactor = 1024,
    long maximumFactor = 1152921504606846976
)
Public Shared Function ToScaledString (
    totalUnits As Long,
    format As String,
    unitName As String,
    symbolNames As String(),
    Optional decimalPlaces As Integer = -1,
    Optional minimumFactor As Long = 1024,
    Optional maximumFactor As Long = 1152921504606846976
) As String
static member ToScaledString :
        totalUnits : int64 *
        format : string *
        unitName : string *
        symbolNames : string[] *
        ?decimalPlaces : int *
        ?minimumFactor : int64 *
        ?maximumFactor : int64
(* Defaults:
        let _decimalPlaces = defaultArg decimalPlaces -1
        let _minimumFactor = defaultArg minimumFactor 1024
        let _maximumFactor = defaultArg maximumFactor 1152921504606846976
*)
-> string

GSF.Units.SI2.ToScaledString = function(totalUnits, format, unitName, symbolNames, decimalPlaces, minimumFactor, maximumFactor);
public:
static String^ ToScaledString(
    long long totalUnits,
    String^ format,
    String^ unitName,
    array<String^>^ symbolNames,
    int decimalPlaces = -1,
    long long minimumFactor = 1024,
    long long maximumFactor = 1152921504606846976
)

Parameters

totalUnits
Type: SystemInt64
Total units to represent textually.
format
Type: SystemString
A numeric string format for scaled totalUnits.
unitName
Type: SystemString
Name of unit display (e.g., you could use "B" for bytes).
symbolNames
Type: SystemString
SI factor symbol or name array to use during textual conversion.
decimalPlaces (Optional)
Type: SystemInt32
Optional number of decimal places to display.
minimumFactor (Optional)
Type: SystemInt64
Optional minimum SI factor. Defaults to Kilo.
maximumFactor (Optional)
Type: SystemInt64
Optional maximum SI factor. Defaults to Exa.

Return Value

Type: String
A String representation of the number of units.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumFactor or maximumFactor is not defined in Factors array.
Remarks
The symbolNames array needs one string entry for each defined SI item ordered from least (Kilo) to greatest (Exa), see Names or Symbols arrays for examples.
See Also

Reference

SI2 Class
ToScaledString Overload
GSF.Units Namespace


SI2 Properties

Grid Solutions Framework SI2 Properties

The SI2 type exposes the following members.

Properties
Name | Description
Factors | Gets an array of all the defined binary SI unit factors ordered from least (Kilo) to greatest (Exa).
IECNames | Gets an array of all the defined IEC binary unit factor SI names ordered from least (Kibi) to greatest (Exbi).
IECSymbols | Gets an array of all the defined IEC binary unit factor SI prefix symbols ordered from least (Kibi) to greatest (Exbi).
Names | Gets an array of all the defined common binary unit factor SI names ordered from least (Kilo) to greatest (Exa).
Symbols | Gets an array of all the defined common binary unit factor SI prefix symbols ordered from least (Kilo) to greatest (Exa).
Top
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Factors Property

Grid Solutions Framework SI2Factors Property
Gets an array of all the defined binary SI unit factors ordered from least (Kilo) to greatest (Exa).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long[] Factors { get; }
Public Shared ReadOnly Property Factors As Long()
    Get
static member Factors : int64[] with get

GSF.Units.SI2.get_Factors = function();

public:
static property array<long long>^ Factors {
    array<long long>^ get ();
}

Property Value

Type: Int64
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.IECNames Property

Grid Solutions Framework SI2IECNames Property
Gets an array of all the defined IEC binary unit factor SI names ordered from least (Kibi) to greatest (Exbi).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] IECNames { get; }
Public Shared ReadOnly Property IECNames As String()
    Get
static member IECNames : string[] with get

GSF.Units.SI2.get_IECNames = function();

public:
static property array<String^>^ IECNames {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.IECSymbols Property

Grid Solutions Framework SI2IECSymbols Property
Gets an array of all the defined IEC binary unit factor SI prefix symbols ordered from least (Kibi) to greatest (Exbi).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] IECSymbols { get; }
Public Shared ReadOnly Property IECSymbols As String()
    Get
static member IECSymbols : string[] with get

GSF.Units.SI2.get_IECSymbols = function();

public:
static property array<String^>^ IECSymbols {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Names Property

Grid Solutions Framework SI2Names Property
Gets an array of all the defined common binary unit factor SI names ordered from least (Kilo) to greatest (Exa).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] Names { get; }
Public Shared ReadOnly Property Names As String()
    Get
static member Names : string[] with get

GSF.Units.SI2.get_Names = function();

public:
static property array<String^>^ Names {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

SI2 Class
GSF.Units Namespace


SI2.Symbols Property

Grid Solutions Framework SI2Symbols Property
Gets an array of all the defined common binary unit factor SI prefix symbols ordered from least (Kilo) to greatest (Exa).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string[] Symbols { get; }
Public Shared ReadOnly Property Symbols As String()
    Get
static member Symbols : string[] with get

GSF.Units.SI2.get_Symbols = function();

public:
static property array<String^>^ Symbols {
    array<String^>^ get ();
}

Property Value

Type: String
See Also

Reference

SI2 Class
GSF.Units Namespace


Speed Structure

Grid Solutions Framework Speed Structure
Represents a speed measurement, in meters per second, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Speed : IComparable, IFormattable,
    IConvertible, IComparable<Speed>, IComparable<double>, IEquatable<Speed>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Speed
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Speed),
    IComparable(Of Double), IEquatable(Of Speed), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Speed =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Speed>
        interface IComparable<float>
        interface IEquatable<Speed>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Speed : IComparable,
    IFormattable, IConvertible, IComparable<Speed>, IComparable<double>,
    IEquatable<Speed>, IEquatable<double>

The Speed type exposes the following members.

Constructors
 | Name | Description
Public method | Speed | Creates a new Speed.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Speed) | Compares this instance to a specified Speed and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Speed) | Returns a value indicating whether this instance is equal to a specified Speed value.
 | FromFeetPerMinute | Creates a new Speed value from the specified value in feet per minute.
 | FromInchesPerSecond | Creates a new Speed value from the specified value in inches per second.
 | FromKilometersPerHour | Creates a new Speed value from the specified value in kilometers per hour.
 | FromKnots | Creates a new Speed value from the specified value in knots (International).
 | FromMach | Creates a new Speed value from the specified value in mach.
 | FromMilesPerHour | Creates a new Speed value from the specified value in miles per hour.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Speed equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Speed equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Speed equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent.
Public method | ToFeetPerMinute | Gets the Speed value in feet per minute.
Public method | ToInchesPerSecond | Gets the Speed value in inches per second.
Public method | ToKilometersPerHour | Gets the Speed value in kilometers per hour.
Public method | ToKnots | Gets the Speed value in knots (International).
Public method | ToMach | Gets the Speed value in mach.
Public method | ToMilesPerHour | Gets the Speed value in miles per hour.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Speed) | Converts the string representation of a number to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Speed) | Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to speed of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Speed) | Implicitly converts value, represented in meters per second, to a Speed.
(Speed to Double) | Implicitly converts Speed, represented in meters per second, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Speed. This field is constant.
MinValue | Represents the smallest possible value of an Speed. This field is constant.
Top
Remarks
This class behaves just like a Double representing a speed in meters per second; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other speed representations, specifically miles per hour, kilometers per hour, feet per minute, inches per second, knots and mach.
Examples
This example converts mph to km/h:
Copy
public double GetKilometersPerHour(double milesPerHour)
{
    return Speed.FromMilesPerHour(milesPerHour).ToKilometersPerHour();
}
See Also

Reference

GSF.Units Namespace


Speed Constructor

Grid Solutions Framework Speed Constructor
Creates a new Speed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Speed(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Speed
GSF.Units.Speed = function(value);
public:
Speed(
    double value
)

Parameters

value
Type: SystemDouble
New speed value in meters per second.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed Fields

Grid Solutions Framework Speed Fields

The Speed type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Speed. This field is constant.
MinValue | Represents the smallest possible value of an Speed. This field is constant.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.MaxValue Field

Grid Solutions Framework SpeedMaxValue Field
Represents the largest possible value of an Speed. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Speed MaxValue
Public Shared ReadOnly MaxValue As Speed
static val MaxValue: Speed
var GSF.Units.Speed.MaxValue
public:
static initonly Speed MaxValue

Field Value

Type: Speed
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.MinValue Field

Grid Solutions Framework SpeedMinValue Field
Represents the smallest possible value of an Speed. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Speed MinValue
Public Shared ReadOnly MinValue As Speed
static val MinValue: Speed
var GSF.Units.Speed.MinValue
public:
static initonly Speed MinValue

Field Value

Type: Speed
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed Methods

Grid Solutions Framework Speed Methods

The Speed type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Speed) | Compares this instance to a specified Speed and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Speed) | Returns a value indicating whether this instance is equal to a specified Speed value.
 | FromFeetPerMinute | Creates a new Speed value from the specified value in feet per minute.
 | FromInchesPerSecond | Creates a new Speed value from the specified value in inches per second.
 | FromKilometersPerHour | Creates a new Speed value from the specified value in kilometers per hour.
 | FromKnots | Creates a new Speed value from the specified value in knots (International).
 | FromMach | Creates a new Speed value from the specified value in mach.
 | FromMilesPerHour | Creates a new Speed value from the specified value in miles per hour.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Speed equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Speed equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Speed equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent.
Public method | ToFeetPerMinute | Gets the Speed value in feet per minute.
Public method | ToInchesPerSecond | Gets the Speed value in inches per second.
Public method | ToKilometersPerHour | Gets the Speed value in kilometers per hour.
Public method | ToKnots | Gets the Speed value in knots (International).
Public method | ToMach | Gets the Speed value in mach.
Public method | ToMilesPerHour | Gets the Speed value in miles per hour.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Speed) | Converts the string representation of a number to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Speed) | Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.CompareTo Method

Grid Solutions Framework SpeedCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Speed) | Compares this instance to a specified Speed and returns an indication of their relative values.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.CompareTo Method (Double)

Grid Solutions Framework SpeedCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Speed Structure
CompareTo Overload
GSF.Units Namespace


Speed.CompareTo Method (Object)

Grid Solutions Framework SpeedCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Speed.
See Also

Reference

Speed Structure
CompareTo Overload
GSF.Units Namespace


Speed.CompareTo Method (Speed)

Grid Solutions Framework SpeedCompareTo Method (Speed)
Compares this instance to a specified Speed and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Speed value
)
Public Function CompareTo (
    value As Speed
) As Integer
abstract CompareTo :
        value : Speed -> int
override CompareTo :
        value : Speed -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Speed value
) sealed

Parameters

value
Type: GSF.UnitsSpeed
A Speed to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Speed Structure
CompareTo Overload
GSF.Units Namespace


Speed.Equals Method

Grid Solutions Framework SpeedEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Speed) | Returns a value indicating whether this instance is equal to a specified Speed value.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Equals Method (Double)

Grid Solutions Framework SpeedEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Speed Structure
Equals Overload
GSF.Units Namespace


Speed.Equals Method (Object)

Grid Solutions Framework SpeedEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Speed and equals the value of this instance; otherwise, False.
See Also

Reference

Speed Structure
Equals Overload
GSF.Units Namespace


Speed.Equals Method (Speed)

Grid Solutions Framework SpeedEquals Method (Speed)
Returns a value indicating whether this instance is equal to a specified Speed value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Speed obj
)
Public Function Equals (
    obj As Speed
) As Boolean
abstract Equals :
        obj : Speed -> bool
override Equals :
        obj : Speed -> bool
function Equals(obj);
public:
virtual bool Equals(
    Speed obj
) sealed

Parameters

obj
Type: GSF.UnitsSpeed
A Speed value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Speed Structure
Equals Overload
GSF.Units Namespace


Speed.FromFeetPerMinute Method

Grid Solutions Framework SpeedFromFeetPerMinute Method
Creates a new Speed value from the specified value in feet per minute.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed FromFeetPerMinute(
    double value
)
Public Shared Function FromFeetPerMinute (
    value As Double
) As Speed
static member FromFeetPerMinute :
        value : float -> Speed

GSF.Units.Speed.FromFeetPerMinute = function(value);
public:
static Speed FromFeetPerMinute(
    double value
)

Parameters

value
Type: SystemDouble
New Speed value in feet per minute.

Return Value

Type: Speed
New Speed object from the specified value in feet per minute.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.FromInchesPerSecond Method

Grid Solutions Framework SpeedFromInchesPerSecond Method
Creates a new Speed value from the specified value in inches per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed FromInchesPerSecond(
    double value
)
Public Shared Function FromInchesPerSecond (
    value As Double
) As Speed
static member FromInchesPerSecond :
        value : float -> Speed

GSF.Units.Speed.FromInchesPerSecond = function(value);
public:
static Speed FromInchesPerSecond(
    double value
)

Parameters

value
Type: SystemDouble
New Speed value in inches per second.

Return Value

Type: Speed
New Speed object from the specified value in inches per second.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.FromKilometersPerHour Method

Grid Solutions Framework SpeedFromKilometersPerHour Method
Creates a new Speed value from the specified value in kilometers per hour.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed FromKilometersPerHour(
    double value
)
Public Shared Function FromKilometersPerHour (
    value As Double
) As Speed
static member FromKilometersPerHour :
        value : float -> Speed

GSF.Units.Speed.FromKilometersPerHour = function(value);
public:
static Speed FromKilometersPerHour(
    double value
)

Parameters

value
Type: SystemDouble
New Speed value in kilometers per hour.

Return Value

Type: Speed
New Speed object from the specified value in kilometers per hour.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.FromKnots Method

Grid Solutions Framework SpeedFromKnots Method
Creates a new Speed value from the specified value in knots (International).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed FromKnots(
    double value
)
Public Shared Function FromKnots (
    value As Double
) As Speed
static member FromKnots :
        value : float -> Speed

GSF.Units.Speed.FromKnots = function(value);
public:
static Speed FromKnots(
    double value
)

Parameters

value
Type: SystemDouble
New Speed value in knots.

Return Value

Type: Speed
New Speed object from the specified value in knots.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.FromMach Method

Grid Solutions Framework SpeedFromMach Method
Creates a new Speed value from the specified value in mach.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed FromMach(
    double value
)
Public Shared Function FromMach (
    value As Double
) As Speed
static member FromMach :
        value : float -> Speed

GSF.Units.Speed.FromMach = function(value);
public:
static Speed FromMach(
    double value
)

Parameters

value
Type: SystemDouble
New Speed value in mach.

Return Value

Type: Speed
New Speed object from the specified value in mach.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.FromMilesPerHour Method

Grid Solutions Framework SpeedFromMilesPerHour Method
Creates a new Speed value from the specified value in miles per hour.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed FromMilesPerHour(
    double value
)
Public Shared Function FromMilesPerHour (
    value As Double
) As Speed
static member FromMilesPerHour :
        value : float -> Speed

GSF.Units.Speed.FromMilesPerHour = function(value);
public:
static Speed FromMilesPerHour(
    double value
)

Parameters

value
Type: SystemDouble
New Speed value in miles per hour.

Return Value

Type: Speed
New Speed object from the specified value in miles per hour.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.GetHashCode Method

Grid Solutions Framework SpeedGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.GetTypeCode Method

Grid Solutions Framework SpeedGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Parse Method

Grid Solutions Framework SpeedParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Speed equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Speed equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Speed equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Parse Method (String)

Grid Solutions Framework SpeedParse Method (String)
Converts the string representation of a number to its Speed equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Speed
static member Parse :
        s : string -> Speed

GSF.Units.Speed.Parse = function(s);
public:
static Speed Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Speed
A Speed equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Speed Structure
Parse Overload
GSF.Units Namespace


Speed.Parse Method (String, NumberStyles)

Grid Solutions Framework SpeedParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Speed equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Speed
static member Parse :
        s : string *
        style : NumberStyles -> Speed

GSF.Units.Speed.Parse = function(s, style);
public:
static Speed Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Speed
A Speed equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Speed Structure
Parse Overload
GSF.Units Namespace


Speed.Parse Method (String, IFormatProvider)

Grid Solutions Framework SpeedParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Speed equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Speed
static member Parse :
        s : string *
        provider : IFormatProvider -> Speed

GSF.Units.Speed.Parse = function(s, provider);
public:
static Speed Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Speed
A Speed equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Speed Structure
Parse Overload
GSF.Units Namespace


Speed.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework SpeedParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Speed
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Speed

GSF.Units.Speed.Parse = function(s, style, provider);
public:
static Speed Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Speed
A Speed equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Speed Structure
Parse Overload
GSF.Units Namespace


Speed.ToFeetPerMinute Method

Grid Solutions Framework SpeedToFeetPerMinute Method
Gets the Speed value in feet per minute.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToFeetPerMinute()
Public Function ToFeetPerMinute As Double
member ToFeetPerMinute : unit -> float

function ToFeetPerMinute();
public:
double ToFeetPerMinute()

Return Value

Type: Double
Value of Speed in feet per minute.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.ToInchesPerSecond Method

Grid Solutions Framework SpeedToInchesPerSecond Method
Gets the Speed value in inches per second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToInchesPerSecond()
Public Function ToInchesPerSecond As Double
member ToInchesPerSecond : unit -> float

function ToInchesPerSecond();
public:
double ToInchesPerSecond()

Return Value

Type: Double
Value of Speed in inches per second.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.ToKilometersPerHour Method

Grid Solutions Framework SpeedToKilometersPerHour Method
Gets the Speed value in kilometers per hour.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToKilometersPerHour()
Public Function ToKilometersPerHour As Double
member ToKilometersPerHour : unit -> float

function ToKilometersPerHour();
public:
double ToKilometersPerHour()

Return Value

Type: Double
Value of Speed in kilometers per hour.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.ToKnots Method

Grid Solutions Framework SpeedToKnots Method
Gets the Speed value in knots (International).

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToKnots()
Public Function ToKnots As Double
member ToKnots : unit -> float

function ToKnots();
public:
double ToKnots()

Return Value

Type: Double
Value of Speed in knots.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.ToMach Method

Grid Solutions Framework SpeedToMach Method
Gets the Speed value in mach.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMach()
Public Function ToMach As Double
member ToMach : unit -> float

function ToMach();
public:
double ToMach()

Return Value

Type: Double
Value of Speed in mach.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.ToMilesPerHour Method

Grid Solutions Framework SpeedToMilesPerHour Method
Gets the Speed value in miles per hour.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMilesPerHour()
Public Function ToMilesPerHour As Double
member ToMilesPerHour : unit -> float

function ToMilesPerHour();
public:
double ToMilesPerHour()

Return Value

Type: Double
Value of Speed in miles per hour.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.ToString Method

Grid Solutions Framework SpeedToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.ToString Method

Grid Solutions Framework SpeedToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Speed Structure
ToString Overload
GSF.Units Namespace


Speed.ToString Method (IFormatProvider)

Grid Solutions Framework SpeedToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Speed Structure
ToString Overload
GSF.Units Namespace


Speed.ToString Method (String)

Grid Solutions Framework SpeedToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Speed Structure
ToString Overload
GSF.Units Namespace


Speed.ToString Method (String, IFormatProvider)

Grid Solutions Framework SpeedToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Speed Structure
ToString Overload
GSF.Units Namespace


Speed.TryParse Method

Grid Solutions Framework SpeedTryParse Method
Overload List
Name | Description
TryParse(String, Speed) | Converts the string representation of a number to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Speed) | Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.TryParse Method (String, Speed)

Grid Solutions Framework SpeedTryParse Method (String, Speed)
Converts the string representation of a number to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Speed result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Speed
) As Boolean
static member TryParse :
        s : string *
        result : Speed byref -> bool

GSF.Units.Speed.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Speed% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsSpeed
When this method returns, contains the Speed value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter per second is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parameter per second is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Speed Structure
TryParse Overload
GSF.Units Namespace


Speed.TryParse Method (String, NumberStyles, IFormatProvider, Speed)

Grid Solutions Framework SpeedTryParse Method (String, NumberStyles, IFormatProvider, Speed)
Converts the string representation of a number in a specified style and culture-specific format to its Speed equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Speed result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Speed
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Speed byref -> bool

GSF.Units.Speed.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Speed% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsSpeed
When this method returns, contains the Speed value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter per second is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parameter per second is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Speed Structure
TryParse Overload
GSF.Units Namespace


Speed Operators and Type Conversions

Grid Solutions Framework Speed Operators and Type Conversions

The Speed type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to speed of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Speed) | Implicitly converts value, represented in meters per second, to a Speed.
(Speed to Double) | Implicitly converts Speed, represented in meters per second, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Addition Operator

Grid Solutions Framework SpeedAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed operator +(
    Speed value1,
    Speed value2
)
Public Shared Operator + (
    value1 As Speed,
    value2 As Speed
) As Speed
static let inline (+)
        value1 : Speed *
        value2 : Speed  : Speed
JavaScript does not support overloaded operators.
public:
static Speed operator +(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Speed
A Speed object as the result.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Division Operator

Grid Solutions Framework SpeedDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed operator /(
    Speed value1,
    Speed value2
)
Public Shared Operator / (
    value1 As Speed,
    value2 As Speed
) As Speed
static let inline (/)
        value1 : Speed *
        value2 : Speed  : Speed
JavaScript does not support overloaded operators.
public:
static Speed operator /(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Speed
A Speed object as the result.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Equality Operator

Grid Solutions Framework SpeedEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Speed value1,
    Speed value2
)
Public Shared Operator = (
    value1 As Speed,
    value2 As Speed
) As Boolean
static let inline (=)
        value1 : Speed *
        value2 : Speed  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Exponent Operator

Grid Solutions Framework SpeedExponent Operator
Returns result of first value raised to speed of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Speed,
    value2 As Speed
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Double
A Double value as the result.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.GreaterThan Operator

Grid Solutions Framework SpeedGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Speed value1,
    Speed value2
)
Public Shared Operator > (
    value1 As Speed,
    value2 As Speed
) As Boolean
static let inline (>)
        value1 : Speed *
        value2 : Speed  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.GreaterThanOrEqual Operator

Grid Solutions Framework SpeedGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Speed value1,
    Speed value2
)
Public Shared Operator >= (
    value1 As Speed,
    value2 As Speed
) As Boolean
static let inline (>=)
        value1 : Speed *
        value2 : Speed  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed Implicit Conversion Operators

Grid Solutions Framework Speed Conversion Operators
Overload List
Name | Description
(Double to Speed) | Implicitly converts value, represented in meters per second, to a Speed.
(Speed to Double) | Implicitly converts Speed, represented in meters per second, to a Double.
Top
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed Implicit Conversion (Double to Speed)

Grid Solutions Framework Speed Conversion (Double to Speed)
Implicitly converts value, represented in meters per second, to a Speed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Speed (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Speed
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Speed (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Speed
A Speed object.
See Also

Reference

Speed Structure
Overload
GSF.Units Namespace


Speed Implicit Conversion (Speed to Double)

Grid Solutions Framework Speed Conversion (Speed to Double)
Implicitly converts Speed, represented in meters per second, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Speed value
)
Public Shared Widening Operator CType (
    value As Speed
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Speed value
)

Parameters

value
Type: GSF.UnitsSpeed
A Speed object.

Return Value

Type: Double
A Double value.
See Also

Reference

Speed Structure
Overload
GSF.Units Namespace


Speed.Inequality Operator

Grid Solutions Framework SpeedInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Speed value1,
    Speed value2
)
Public Shared Operator <> (
    value1 As Speed,
    value2 As Speed
) As Boolean
static let inline (<>)
        value1 : Speed *
        value2 : Speed  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.LessThan Operator

Grid Solutions Framework SpeedLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Speed value1,
    Speed value2
)
Public Shared Operator < (
    value1 As Speed,
    value2 As Speed
) As Boolean
static let inline (<)
        value1 : Speed *
        value2 : Speed  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.LessThanOrEqual Operator

Grid Solutions Framework SpeedLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Speed value1,
    Speed value2
)
Public Shared Operator <= (
    value1 As Speed,
    value2 As Speed
) As Boolean
static let inline (<=)
        value1 : Speed *
        value2 : Speed  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result of the operation.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Modulus Operator

Grid Solutions Framework SpeedModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed operator %(
    Speed value1,
    Speed value2
)
Public Shared Operator Mod (
    value1 As Speed,
    value2 As Speed
) As Speed
static let inline (%)
        value1 : Speed *
        value2 : Speed  : Speed
JavaScript does not support overloaded operators.
public:
static Speed operator %(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Speed
A Speed object as the result.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Multiply Operator

Grid Solutions Framework SpeedMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed operator *(
    Speed value1,
    Speed value2
)
Public Shared Operator * (
    value1 As Speed,
    value2 As Speed
) As Speed
static let inline (*)
        value1 : Speed *
        value2 : Speed  : Speed
JavaScript does not support overloaded operators.
public:
static Speed operator *(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Speed
A Speed object as the result.
See Also

Reference

Speed Structure
GSF.Units Namespace


Speed.Subtraction Operator

Grid Solutions Framework SpeedSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Speed operator -(
    Speed value1,
    Speed value2
)
Public Shared Operator - (
    value1 As Speed,
    value2 As Speed
) As Speed
static let inline (-)
        value1 : Speed *
        value2 : Speed  : Speed
JavaScript does not support overloaded operators.
public:
static Speed operator -(
    Speed value1,
    Speed value2
)

Parameters

value1
Type: GSF.UnitsSpeed
A Speed object as the left hand operand.
value2
Type: GSF.UnitsSpeed
A Speed object as the right hand operand.

Return Value

Type: Speed
A Speed object as the result.
See Also

Reference

Speed Structure
GSF.Units Namespace


Temperature Structure

Grid Solutions Framework Temperature Structure
Represents a temperature, in kelvin, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Temperature : IComparable,
    IFormattable, IConvertible, IComparable<Temperature>, IComparable<double>,
    IEquatable<Temperature>, IEquatable<double>
<SerializableAttribute>
Public Structure Temperature
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Temperature),
    IComparable(Of Double), IEquatable(Of Temperature), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Temperature =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Temperature>
        interface IComparable<float>
        interface IEquatable<Temperature>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Temperature : IComparable,
    IFormattable, IConvertible, IComparable<Temperature>, IComparable<double>,
    IEquatable<Temperature>, IEquatable<double>

The Temperature type exposes the following members.

Constructors
 | Name | Description
Public method | Temperature | Creates a new Temperature.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Temperature) | Compares this instance to a specified Temperature and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Temperature) | Returns a value indicating whether this instance is equal to a specified Temperature value.
 | FromCelsius | Creates a new Temperature value from the specified value in Celsius.
 | FromDelisle | Creates a new Temperature value from the specified value in Delisle.
 | FromFahrenheit | Creates a new Temperature value from the specified value in Fahrenheit.
 | FromNewton | Creates a new Temperature value from the specified value in Newton.
 | FromRankine | Creates a new Temperature value from the specified value in Rankine.
 | FromRéaumur | Creates a new Temperature value from the specified value in Réaumur.
 | FromRømer | Creates a new Temperature value from the specified value in Rømer.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Temperature equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Temperature equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Temperature equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent.
Public method | ToCelsius | Gets the Temperature value in Celsius.
Public method | ToDelisle | Gets the Temperature value in Delisle.
Public method | ToFahrenheit | Gets the Temperature value in Fahrenheit.
Public method | ToNewton | Gets the Temperature value in Newton.
Public method | ToRankine | Gets the Temperature value in Rankine.
Public method | ToRéaumur | Gets the Temperature value in Réaumur.
Public method | ToRømer | Gets the Temperature value in Rømer.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Temperature) | Converts the string representation of a number to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Temperature) | Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Temperature) | Implicitly converts value, represented in kelvin, to a Temperature.
(Temperature to Double) | Implicitly converts Temperature, represented in kelvin, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of a Temperature. This field is constant.
MinValue | Represents the smallest possible value of a Temperature. This field is constant.
Top
Remarks
This class behaves just like a Double representing a temperature in kelvin; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other temperature representations, specifically Celsius, Fahrenheit, Newton, Rankine, Delisle, Réaumur and Rømer.
Examples
This example converts Celsius to Fahrenheit:
Copy
public double GetFahrenheit(double celsius)
{
    return Temperature.FromCelsius(celsius).ToFahrenheit();
}
See Also

Reference

GSF.Units Namespace


Temperature Constructor

Grid Solutions Framework Temperature Constructor
Creates a new Temperature.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Temperature(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Temperature
GSF.Units.Temperature = function(value);
public:
Temperature(
    double value
)

Parameters

value
Type: SystemDouble
New temperature value in kelvin.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature Fields

Grid Solutions Framework Temperature Fields

The Temperature type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of a Temperature. This field is constant.
MinValue | Represents the smallest possible value of a Temperature. This field is constant.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.MaxValue Field

Grid Solutions Framework TemperatureMaxValue Field
Represents the largest possible value of a Temperature. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Temperature MaxValue
Public Shared ReadOnly MaxValue As Temperature
static val MaxValue: Temperature
var GSF.Units.Temperature.MaxValue
public:
static initonly Temperature MaxValue

Field Value

Type: Temperature
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.MinValue Field

Grid Solutions Framework TemperatureMinValue Field
Represents the smallest possible value of a Temperature. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Temperature MinValue
Public Shared ReadOnly MinValue As Temperature
static val MinValue: Temperature
var GSF.Units.Temperature.MinValue
public:
static initonly Temperature MinValue

Field Value

Type: Temperature
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature Methods

Grid Solutions Framework Temperature Methods

The Temperature type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Temperature) | Compares this instance to a specified Temperature and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Temperature) | Returns a value indicating whether this instance is equal to a specified Temperature value.
 | FromCelsius | Creates a new Temperature value from the specified value in Celsius.
 | FromDelisle | Creates a new Temperature value from the specified value in Delisle.
 | FromFahrenheit | Creates a new Temperature value from the specified value in Fahrenheit.
 | FromNewton | Creates a new Temperature value from the specified value in Newton.
 | FromRankine | Creates a new Temperature value from the specified value in Rankine.
 | FromRéaumur | Creates a new Temperature value from the specified value in Réaumur.
 | FromRømer | Creates a new Temperature value from the specified value in Rømer.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Temperature equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Temperature equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Temperature equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent.
Public method | ToCelsius | Gets the Temperature value in Celsius.
Public method | ToDelisle | Gets the Temperature value in Delisle.
Public method | ToFahrenheit | Gets the Temperature value in Fahrenheit.
Public method | ToNewton | Gets the Temperature value in Newton.
Public method | ToRankine | Gets the Temperature value in Rankine.
Public method | ToRéaumur | Gets the Temperature value in Réaumur.
Public method | ToRømer | Gets the Temperature value in Rømer.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Temperature) | Converts the string representation of a number to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Temperature) | Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.CompareTo Method

Grid Solutions Framework TemperatureCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Temperature) | Compares this instance to a specified Temperature and returns an indication of their relative values.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.CompareTo Method (Double)

Grid Solutions Framework TemperatureCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Temperature Structure
CompareTo Overload
GSF.Units Namespace


Temperature.CompareTo Method (Object)

Grid Solutions Framework TemperatureCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Temperature.
See Also

Reference

Temperature Structure
CompareTo Overload
GSF.Units Namespace


Temperature.CompareTo Method (Temperature)

Grid Solutions Framework TemperatureCompareTo Method (Temperature)
Compares this instance to a specified Temperature and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Temperature value
)
Public Function CompareTo (
    value As Temperature
) As Integer
abstract CompareTo :
        value : Temperature -> int
override CompareTo :
        value : Temperature -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Temperature value
) sealed

Parameters

value
Type: GSF.UnitsTemperature
A Temperature to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Temperature Structure
CompareTo Overload
GSF.Units Namespace


Temperature.Equals Method

Grid Solutions Framework TemperatureEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Temperature) | Returns a value indicating whether this instance is equal to a specified Temperature value.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Equals Method (Double)

Grid Solutions Framework TemperatureEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Temperature Structure
Equals Overload
GSF.Units Namespace


Temperature.Equals Method (Object)

Grid Solutions Framework TemperatureEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Temperature and equals the value of this instance; otherwise, False.
See Also

Reference

Temperature Structure
Equals Overload
GSF.Units Namespace


Temperature.Equals Method (Temperature)

Grid Solutions Framework TemperatureEquals Method (Temperature)
Returns a value indicating whether this instance is equal to a specified Temperature value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Temperature obj
)
Public Function Equals (
    obj As Temperature
) As Boolean
abstract Equals :
        obj : Temperature -> bool
override Equals :
        obj : Temperature -> bool
function Equals(obj);
public:
virtual bool Equals(
    Temperature obj
) sealed

Parameters

obj
Type: GSF.UnitsTemperature
A Temperature value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Temperature Structure
Equals Overload
GSF.Units Namespace


Temperature.FromCelsius Method

Grid Solutions Framework TemperatureFromCelsius Method
Creates a new Temperature value from the specified value in Celsius.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature FromCelsius(
    double value
)
Public Shared Function FromCelsius (
    value As Double
) As Temperature
static member FromCelsius :
        value : float -> Temperature

GSF.Units.Temperature.FromCelsius = function(value);
public:
static Temperature FromCelsius(
    double value
)

Parameters

value
Type: SystemDouble
New Temperature value in Celsius.

Return Value

Type: Temperature
New Temperature object from the specified value in Celsius.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.FromDelisle Method

Grid Solutions Framework TemperatureFromDelisle Method
Creates a new Temperature value from the specified value in Delisle.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature FromDelisle(
    double value
)
Public Shared Function FromDelisle (
    value As Double
) As Temperature
static member FromDelisle :
        value : float -> Temperature

GSF.Units.Temperature.FromDelisle = function(value);
public:
static Temperature FromDelisle(
    double value
)

Parameters

value
Type: SystemDouble
New Temperature value in Delisle.

Return Value

Type: Temperature
New Temperature object from the specified value in Delisle.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.FromFahrenheit Method

Grid Solutions Framework TemperatureFromFahrenheit Method
Creates a new Temperature value from the specified value in Fahrenheit.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature FromFahrenheit(
    double value
)
Public Shared Function FromFahrenheit (
    value As Double
) As Temperature
static member FromFahrenheit :
        value : float -> Temperature

GSF.Units.Temperature.FromFahrenheit = function(value);
public:
static Temperature FromFahrenheit(
    double value
)

Parameters

value
Type: SystemDouble
New Temperature value in Fahrenheit.

Return Value

Type: Temperature
New Temperature object from the specified value in Fahrenheit.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.FromNewton Method

Grid Solutions Framework TemperatureFromNewton Method
Creates a new Temperature value from the specified value in Newton.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature FromNewton(
    double value
)
Public Shared Function FromNewton (
    value As Double
) As Temperature
static member FromNewton :
        value : float -> Temperature

GSF.Units.Temperature.FromNewton = function(value);
public:
static Temperature FromNewton(
    double value
)

Parameters

value
Type: SystemDouble
New Temperature value in Newton.

Return Value

Type: Temperature
New Temperature object from the specified value in Newton.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.FromRankine Method

Grid Solutions Framework TemperatureFromRankine Method
Creates a new Temperature value from the specified value in Rankine.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature FromRankine(
    double value
)
Public Shared Function FromRankine (
    value As Double
) As Temperature
static member FromRankine :
        value : float -> Temperature

GSF.Units.Temperature.FromRankine = function(value);
public:
static Temperature FromRankine(
    double value
)

Parameters

value
Type: SystemDouble
New Temperature value in Rankine.

Return Value

Type: Temperature
New Temperature object from the specified value in Rankine.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.FromRéaumur Method

Grid Solutions Framework TemperatureFromRéaumur Method
Creates a new Temperature value from the specified value in Réaumur.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature FromRéaumur(
    double value
)
Public Shared Function FromRéaumur (
    value As Double
) As Temperature
static member FromRéaumur :
        value : float -> Temperature

GSF.Units.Temperature.FromRéaumur = function(value);
public:
static Temperature FromRéaumur(
    double value
)

Parameters

value
Type: SystemDouble
New Temperature value in Réaumur.

Return Value

Type: Temperature
New Temperature object from the specified value in Réaumur.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.FromRømer Method

Grid Solutions Framework TemperatureFromRømer Method
Creates a new Temperature value from the specified value in Rømer.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature FromRømer(
    double value
)
Public Shared Function FromRømer (
    value As Double
) As Temperature
static member FromRømer :
        value : float -> Temperature

GSF.Units.Temperature.FromRømer = function(value);
public:
static Temperature FromRømer(
    double value
)

Parameters

value
Type: SystemDouble
New Temperature value in Rømer.

Return Value

Type: Temperature
New Temperature object from the specified value in Rømer.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.GetHashCode Method

Grid Solutions Framework TemperatureGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.GetTypeCode Method

Grid Solutions Framework TemperatureGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Parse Method

Grid Solutions Framework TemperatureParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Temperature equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Temperature equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Temperature equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Parse Method (String)

Grid Solutions Framework TemperatureParse Method (String)
Converts the string representation of a number to its Temperature equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Temperature
static member Parse :
        s : string -> Temperature

GSF.Units.Temperature.Parse = function(s);
public:
static Temperature Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Temperature
A Temperature equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Temperature Structure
Parse Overload
GSF.Units Namespace


Temperature.Parse Method (String, NumberStyles)

Grid Solutions Framework TemperatureParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Temperature equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Temperature
static member Parse :
        s : string *
        style : NumberStyles -> Temperature

GSF.Units.Temperature.Parse = function(s, style);
public:
static Temperature Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Temperature
A Temperature equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Temperature Structure
Parse Overload
GSF.Units Namespace


Temperature.Parse Method (String, IFormatProvider)

Grid Solutions Framework TemperatureParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Temperature equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Temperature
static member Parse :
        s : string *
        provider : IFormatProvider -> Temperature

GSF.Units.Temperature.Parse = function(s, provider);
public:
static Temperature Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Temperature
A Temperature equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Temperature Structure
Parse Overload
GSF.Units Namespace


Temperature.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework TemperatureParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Temperature
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Temperature

GSF.Units.Temperature.Parse = function(s, style, provider);
public:
static Temperature Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Temperature
A Temperature equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Temperature Structure
Parse Overload
GSF.Units Namespace


Temperature.ToCelsius Method

Grid Solutions Framework TemperatureToCelsius Method
Gets the Temperature value in Celsius.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToCelsius()
Public Function ToCelsius As Double
member ToCelsius : unit -> float

function ToCelsius();
public:
double ToCelsius()

Return Value

Type: Double
Value of Temperature in Celsius.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToDelisle Method

Grid Solutions Framework TemperatureToDelisle Method
Gets the Temperature value in Delisle.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToDelisle()
Public Function ToDelisle As Double
member ToDelisle : unit -> float

function ToDelisle();
public:
double ToDelisle()

Return Value

Type: Double
Value of Temperature in Delisle.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToFahrenheit Method

Grid Solutions Framework TemperatureToFahrenheit Method
Gets the Temperature value in Fahrenheit.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToFahrenheit()
Public Function ToFahrenheit As Double
member ToFahrenheit : unit -> float

function ToFahrenheit();
public:
double ToFahrenheit()

Return Value

Type: Double
Value of Temperature in Fahrenheit.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToNewton Method

Grid Solutions Framework TemperatureToNewton Method
Gets the Temperature value in Newton.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToNewton()
Public Function ToNewton As Double
member ToNewton : unit -> float

function ToNewton();
public:
double ToNewton()

Return Value

Type: Double
Value of Temperature in Newton.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToRankine Method

Grid Solutions Framework TemperatureToRankine Method
Gets the Temperature value in Rankine.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToRankine()
Public Function ToRankine As Double
member ToRankine : unit -> float

function ToRankine();
public:
double ToRankine()

Return Value

Type: Double
Value of Temperature in Rankine.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToRéaumur Method

Grid Solutions Framework TemperatureToRéaumur Method
Gets the Temperature value in Réaumur.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToRéaumur()
Public Function ToRéaumur As Double
member ToRéaumur : unit -> float

function ToRéaumur();
public:
double ToRéaumur()

Return Value

Type: Double
Value of Temperature in Réaumur.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToRømer Method

Grid Solutions Framework TemperatureToRømer Method
Gets the Temperature value in Rømer.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToRømer()
Public Function ToRømer As Double
member ToRømer : unit -> float

function ToRømer();
public:
double ToRømer()

Return Value

Type: Double
Value of Temperature in Rømer.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToString Method

Grid Solutions Framework TemperatureToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.ToString Method

Grid Solutions Framework TemperatureToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Temperature Structure
ToString Overload
GSF.Units Namespace


Temperature.ToString Method (IFormatProvider)

Grid Solutions Framework TemperatureToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Temperature Structure
ToString Overload
GSF.Units Namespace


Temperature.ToString Method (String)

Grid Solutions Framework TemperatureToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Temperature Structure
ToString Overload
GSF.Units Namespace


Temperature.ToString Method (String, IFormatProvider)

Grid Solutions Framework TemperatureToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Temperature Structure
ToString Overload
GSF.Units Namespace


Temperature.TryParse Method

Grid Solutions Framework TemperatureTryParse Method
Overload List
Name | Description
TryParse(String, Temperature) | Converts the string representation of a number to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Temperature) | Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.TryParse Method (String, Temperature)

Grid Solutions Framework TemperatureTryParse Method (String, Temperature)
Converts the string representation of a number to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Temperature result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Temperature
) As Boolean
static member TryParse :
        s : string *
        result : Temperature byref -> bool

GSF.Units.Temperature.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Temperature% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsTemperature
When this method returns, contains the Temperature value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Temperature Structure
TryParse Overload
GSF.Units Namespace


Temperature.TryParse Method (String, NumberStyles, IFormatProvider, Temperature)

Grid Solutions Framework TemperatureTryParse Method (String, NumberStyles, IFormatProvider, Temperature)
Converts the string representation of a number in a specified style and culture-specific format to its Temperature equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Temperature result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Temperature
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Temperature byref -> bool

GSF.Units.Temperature.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Temperature% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsTemperature
When this method returns, contains the Temperature value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Temperature Structure
TryParse Overload
GSF.Units Namespace


Temperature Operators and Type Conversions

Grid Solutions Framework Temperature Operators and Type Conversions

The Temperature type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Temperature) | Implicitly converts value, represented in kelvin, to a Temperature.
(Temperature to Double) | Implicitly converts Temperature, represented in kelvin, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Addition Operator

Grid Solutions Framework TemperatureAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature operator +(
    Temperature value1,
    Temperature value2
)
Public Shared Operator + (
    value1 As Temperature,
    value2 As Temperature
) As Temperature
static let inline (+)
        value1 : Temperature *
        value2 : Temperature  : Temperature
JavaScript does not support overloaded operators.
public:
static Temperature operator +(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Temperature
A Temperature object as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Division Operator

Grid Solutions Framework TemperatureDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature operator /(
    Temperature value1,
    Temperature value2
)
Public Shared Operator / (
    value1 As Temperature,
    value2 As Temperature
) As Temperature
static let inline (/)
        value1 : Temperature *
        value2 : Temperature  : Temperature
JavaScript does not support overloaded operators.
public:
static Temperature operator /(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Temperature
A Temperature object as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Equality Operator

Grid Solutions Framework TemperatureEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Temperature value1,
    Temperature value2
)
Public Shared Operator = (
    value1 As Temperature,
    value2 As Temperature
) As Boolean
static let inline (=)
        value1 : Temperature *
        value2 : Temperature  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Exponent Operator

Grid Solutions Framework TemperatureExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Temperature,
    value2 As Temperature
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Double
A Double value as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.GreaterThan Operator

Grid Solutions Framework TemperatureGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Temperature value1,
    Temperature value2
)
Public Shared Operator > (
    value1 As Temperature,
    value2 As Temperature
) As Boolean
static let inline (>)
        value1 : Temperature *
        value2 : Temperature  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.GreaterThanOrEqual Operator

Grid Solutions Framework TemperatureGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Temperature value1,
    Temperature value2
)
Public Shared Operator >= (
    value1 As Temperature,
    value2 As Temperature
) As Boolean
static let inline (>=)
        value1 : Temperature *
        value2 : Temperature  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature Implicit Conversion Operators

Grid Solutions Framework Temperature Conversion Operators
Overload List
Name | Description
(Double to Temperature) | Implicitly converts value, represented in kelvin, to a Temperature.
(Temperature to Double) | Implicitly converts Temperature, represented in kelvin, to a Double.
Top
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature Implicit Conversion (Double to Temperature)

Grid Solutions Framework Temperature Conversion (Double to Temperature)
Implicitly converts value, represented in kelvin, to a Temperature.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Temperature (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Temperature
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Temperature (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Temperature
A Temperature object.
See Also

Reference

Temperature Structure
Overload
GSF.Units Namespace


Temperature Implicit Conversion (Temperature to Double)

Grid Solutions Framework Temperature Conversion (Temperature to Double)
Implicitly converts Temperature, represented in kelvin, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Temperature value
)
Public Shared Widening Operator CType (
    value As Temperature
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Temperature value
)

Parameters

value
Type: GSF.UnitsTemperature
A Temperature object.

Return Value

Type: Double
A Double value.
See Also

Reference

Temperature Structure
Overload
GSF.Units Namespace


Temperature.Inequality Operator

Grid Solutions Framework TemperatureInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Temperature value1,
    Temperature value2
)
Public Shared Operator <> (
    value1 As Temperature,
    value2 As Temperature
) As Boolean
static let inline (<>)
        value1 : Temperature *
        value2 : Temperature  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.LessThan Operator

Grid Solutions Framework TemperatureLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Temperature value1,
    Temperature value2
)
Public Shared Operator < (
    value1 As Temperature,
    value2 As Temperature
) As Boolean
static let inline (<)
        value1 : Temperature *
        value2 : Temperature  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.LessThanOrEqual Operator

Grid Solutions Framework TemperatureLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Temperature value1,
    Temperature value2
)
Public Shared Operator <= (
    value1 As Temperature,
    value2 As Temperature
) As Boolean
static let inline (<=)
        value1 : Temperature *
        value2 : Temperature  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Modulus Operator

Grid Solutions Framework TemperatureModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature operator %(
    Temperature value1,
    Temperature value2
)
Public Shared Operator Mod (
    value1 As Temperature,
    value2 As Temperature
) As Temperature
static let inline (%)
        value1 : Temperature *
        value2 : Temperature  : Temperature
JavaScript does not support overloaded operators.
public:
static Temperature operator %(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Temperature
A Temperature object as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Multiply Operator

Grid Solutions Framework TemperatureMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature operator *(
    Temperature value1,
    Temperature value2
)
Public Shared Operator * (
    value1 As Temperature,
    value2 As Temperature
) As Temperature
static let inline (*)
        value1 : Temperature *
        value2 : Temperature  : Temperature
JavaScript does not support overloaded operators.
public:
static Temperature operator *(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Temperature
A Temperature object as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Temperature.Subtraction Operator

Grid Solutions Framework TemperatureSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Temperature operator -(
    Temperature value1,
    Temperature value2
)
Public Shared Operator - (
    value1 As Temperature,
    value2 As Temperature
) As Temperature
static let inline (-)
        value1 : Temperature *
        value2 : Temperature  : Temperature
JavaScript does not support overloaded operators.
public:
static Temperature operator -(
    Temperature value1,
    Temperature value2
)

Parameters

value1
Type: GSF.UnitsTemperature
A Temperature object as the left hand operand.
value2
Type: GSF.UnitsTemperature
A Temperature object as the right hand operand.

Return Value

Type: Temperature
A Temperature object as the result of the operation.
See Also

Reference

Temperature Structure
GSF.Units Namespace


Time Structure

Grid Solutions Framework Time Structure
Represents a time measurement, in seconds, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Time : IComparable, IFormattable,
    IConvertible, IComparable<Time>, IComparable<TimeSpan>,
    IComparable<double>, IEquatable<Time>, IEquatable<TimeSpan>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Time
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Time),
    IComparable(Of TimeSpan), IComparable(Of Double), IEquatable(Of Time),
    IEquatable(Of TimeSpan), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Time =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Time>
        interface IComparable<TimeSpan>
        interface IComparable<float>
        interface IEquatable<Time>
        interface IEquatable<TimeSpan>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Time : IComparable, IFormattable,
    IConvertible, IComparable<Time>, IComparable<TimeSpan>,
    IComparable<double>, IEquatable<Time>, IEquatable<TimeSpan>,
    IEquatable<double>

The Time type exposes the following members.

Constructors
 | Name | Description
Public method | Time(Double) | Creates a new Time.
Public method | Time(TimeSpan) | Creates a new Time.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(TimeSpan) | Compares this instance to a specified TimeSpan and returns an indication of their relative values.
Public method | CompareTo(Time) | Compares this instance to a specified Time and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(TimeSpan) | Returns a value indicating whether this instance is equal to a specified TimeSpan value.
Public method | Equals(Time) | Returns a value indicating whether this instance is equal to a specified Time value.
 | FromAtomicUnitsOfTime | Creates a new Time value from the specified value in atomic units of time.
 | FromDays | Creates a new Time value from the specified value in days.
 | FromHours | Creates a new Time value from the specified value in hours.
 | FromKe | Creates a new Time value from the specified value in ke, the traditional Chinese unit of decimal time.
 | FromMinutes | Creates a new Time value from the specified value in minutes.
 | FromPlanckTime | Creates a new Time value from the specified value in Planck time.
 | FromWeeks | Creates a new Time value from the specified value in weeks.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Time equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Time equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Time equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent.
 | SecondsPerMonth | Returns the number of seconds in the specified month and year.
 | SecondsPerYear | Returns the number of seconds in the specified year.
Public method | ToAtomicUnitsOfTime | Gets the Time value in atomic units of time.
Public method | ToDays | Gets the Time value in days.
 | ToElapsedTimeString | Converts total seconds into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Public method | ToHours | Gets the Time value in hours.
Public method | ToKe | Gets the Time value in ke, the traditional Chinese unit of decimal time.
Public method | ToMinutes | Gets the Time value in minutes.
Public method | ToPlanckTime | Gets the Time value in Planck time.
Public method | ToString | Converts the Time value into a textual representation of years, days, hours, minutes and seconds. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(Int32, Double) | Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToString(Int32, String, Double) | Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Public method | ToTicks | Converts the Time value, in seconds, to 100-nanosecond tick intervals.
Public method | ToWeeks | Gets the Time value in weeks.
 | TryParse(String, Time) | Converts the string representation of a number to its Time equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Time) | Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Time) | Implicitly converts value, represented in seconds, to a Time.
(TimeSpan to Time) | Implicitly converts value, represented as a TimeSpan, to a Time.
(Time to Double) | Implicitly converts Time, represented in seconds, to a Double.
(Time to TimeSpan) | Implicitly converts Time, represented in seconds, to a TimeSpan.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of a Time. This field is constant.
MinValue | Represents the smallest possible value of a Time. This field is constant.
SecondsPerDay | Number of seconds in one day.
SecondsPerHour | Number of seconds in one hour.
SecondsPerMinute | Number of seconds in one minute.
SecondsPerTick | Fractional number of seconds in one tick.
SecondsPerWeek | Number of seconds in one week.
TimeNames | Standard time names used by ToElapsedTimeString(Double, Int32, String, Double) method.
Top
Remarks
This class behaves just like a Double representing a time in seconds; it is implicitly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other time representations, specifically minutes, hours, days, weeks, atomic units of time, Planck time and ke. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert time in nanoseconds to seconds:
Copy
public Time GetSeconds(double nanoseconds)
{
    return nanoseconds * SI.Nano;
}
Convert time in seconds to milliseconds:
Copy
public double GetMilliseconds(Time seconds)
{
    return time / SI.Milli;
}
This example converts minutes to hours:
Copy
public double GetHours(double minutes)
{
    return Time.FromMinutes(minutes).ToHours();
}

Note that the ToString method will convert the Time value, in seconds, into a textual representation of years, days, hours, minutes and seconds using the static function ToElapsedTimeString(Double, Int32, String, Double).

See Also

Reference

GSF.Units Namespace


Time Constructor

Grid Solutions Framework Time Constructor
Overload List
 | Name | Description
Public method | Time(Double) | Creates a new Time.
Public method | Time(TimeSpan) | Creates a new Time.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time Constructor (Double)

Grid Solutions Framework Time Constructor (Double)
Creates a new Time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Time
GSF.Units.Time = function(value);
public:
Time(
    double value
)

Parameters

value
Type: SystemDouble
New time value in seconds.
See Also

Reference

Time Structure
Time Overload
GSF.Units Namespace


Time Constructor (TimeSpan)

Grid Solutions Framework Time Constructor (TimeSpan)
Creates a new Time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Time(
    TimeSpan value
)
Public Sub New (
    value As TimeSpan
)
new :
        value : TimeSpan -> Time
GSF.Units.Time = function(value);
public:
Time(
    TimeSpan value
)

Parameters

value
Type: SystemTimeSpan
New time value as a TimeSpan.
See Also

Reference

Time Structure
Time Overload
GSF.Units Namespace


Time Fields

Grid Solutions Framework Time Fields

The Time type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of a Time. This field is constant.
MinValue | Represents the smallest possible value of a Time. This field is constant.
SecondsPerDay | Number of seconds in one day.
SecondsPerHour | Number of seconds in one hour.
SecondsPerMinute | Number of seconds in one minute.
SecondsPerTick | Fractional number of seconds in one tick.
SecondsPerWeek | Number of seconds in one week.
TimeNames | Standard time names used by ToElapsedTimeString(Double, Int32, String, Double) method.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.MaxValue Field

Grid Solutions Framework TimeMaxValue Field
Represents the largest possible value of a Time. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Time MaxValue
Public Shared ReadOnly MaxValue As Time
static val MaxValue: Time
var GSF.Units.Time.MaxValue
public:
static initonly Time MaxValue

Field Value

Type: Time
See Also

Reference

Time Structure
GSF.Units Namespace


Time.MinValue Field

Grid Solutions Framework TimeMinValue Field
Represents the smallest possible value of a Time. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Time MinValue
Public Shared ReadOnly MinValue As Time
static val MinValue: Time
var GSF.Units.Time.MinValue
public:
static initonly Time MinValue

Field Value

Type: Time
See Also

Reference

Time Structure
GSF.Units Namespace


Time.SecondsPerDay Field

Grid Solutions Framework TimeSecondsPerDay Field
Number of seconds in one day.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int SecondsPerDay
Public Const SecondsPerDay As Integer
static val mutable SecondsPerDay: int
var GSF.Units.Time.SecondsPerDay
public:
literal int SecondsPerDay

Field Value

Type: Int32
See Also

Reference

Time Structure
GSF.Units Namespace


Time.SecondsPerHour Field

Grid Solutions Framework TimeSecondsPerHour Field
Number of seconds in one hour.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int SecondsPerHour
Public Const SecondsPerHour As Integer
static val mutable SecondsPerHour: int
var GSF.Units.Time.SecondsPerHour
public:
literal int SecondsPerHour

Field Value

Type: Int32
See Also

Reference

Time Structure
GSF.Units Namespace


Time.SecondsPerMinute Field

Grid Solutions Framework TimeSecondsPerMinute Field
Number of seconds in one minute.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int SecondsPerMinute
Public Const SecondsPerMinute As Integer
static val mutable SecondsPerMinute: int
var GSF.Units.Time.SecondsPerMinute
public:
literal int SecondsPerMinute

Field Value

Type: Int32
See Also

Reference

Time Structure
GSF.Units Namespace


Time.SecondsPerTick Field

Grid Solutions Framework TimeSecondsPerTick Field
Fractional number of seconds in one tick.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const double SecondsPerTick
Public Const SecondsPerTick As Double
static val mutable SecondsPerTick: float
var GSF.Units.Time.SecondsPerTick
public:
literal double SecondsPerTick

Field Value

Type: Double
See Also

Reference

Time Structure
GSF.Units Namespace


Time.SecondsPerWeek Field

Grid Solutions Framework TimeSecondsPerWeek Field
Number of seconds in one week.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const int SecondsPerWeek
Public Const SecondsPerWeek As Integer
static val mutable SecondsPerWeek: int
var GSF.Units.Time.SecondsPerWeek
public:
literal int SecondsPerWeek

Field Value

Type: Int32
See Also

Reference

Time Structure
GSF.Units Namespace


Time.TimeNames Field

Grid Solutions Framework TimeTimeNames Field
Standard time names used by ToElapsedTimeString(Double, Int32, String, Double) method.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly string[] TimeNames
Public Shared ReadOnly TimeNames As String()
static val TimeNames: string[]
var GSF.Units.Time.TimeNames
public:
static initonly array<String^>^ TimeNames

Field Value

Type: String
See Also

Reference

Time Structure
GSF.Units Namespace


Time Methods

Grid Solutions Framework Time Methods

The Time type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(TimeSpan) | Compares this instance to a specified TimeSpan and returns an indication of their relative values.
Public method | CompareTo(Time) | Compares this instance to a specified Time and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(TimeSpan) | Returns a value indicating whether this instance is equal to a specified TimeSpan value.
Public method | Equals(Time) | Returns a value indicating whether this instance is equal to a specified Time value.
 | FromAtomicUnitsOfTime | Creates a new Time value from the specified value in atomic units of time.
 | FromDays | Creates a new Time value from the specified value in days.
 | FromHours | Creates a new Time value from the specified value in hours.
 | FromKe | Creates a new Time value from the specified value in ke, the traditional Chinese unit of decimal time.
 | FromMinutes | Creates a new Time value from the specified value in minutes.
 | FromPlanckTime | Creates a new Time value from the specified value in Planck time.
 | FromWeeks | Creates a new Time value from the specified value in weeks.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Time equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Time equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Time equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent.
 | SecondsPerMonth | Returns the number of seconds in the specified month and year.
 | SecondsPerYear | Returns the number of seconds in the specified year.
Public method | ToAtomicUnitsOfTime | Gets the Time value in atomic units of time.
Public method | ToDays | Gets the Time value in days.
 | ToElapsedTimeString | Converts total seconds into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Public method | ToHours | Gets the Time value in hours.
Public method | ToKe | Gets the Time value in ke, the traditional Chinese unit of decimal time.
Public method | ToMinutes | Gets the Time value in minutes.
Public method | ToPlanckTime | Gets the Time value in Planck time.
Public method | ToString | Converts the Time value into a textual representation of years, days, hours, minutes and seconds. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(Int32, Double) | Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToString(Int32, String, Double) | Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Public method | ToTicks | Converts the Time value, in seconds, to 100-nanosecond tick intervals.
Public method | ToWeeks | Gets the Time value in weeks.
 | TryParse(String, Time) | Converts the string representation of a number to its Time equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Time) | Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.CompareTo Method

Grid Solutions Framework TimeCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(TimeSpan) | Compares this instance to a specified TimeSpan and returns an indication of their relative values.
Public method | CompareTo(Time) | Compares this instance to a specified Time and returns an indication of their relative values.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.CompareTo Method (Double)

Grid Solutions Framework TimeCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
An Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Time Structure
CompareTo Overload
GSF.Units Namespace


Time.CompareTo Method (Object)

Grid Solutions Framework TimeCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Time.
See Also

Reference

Time Structure
CompareTo Overload
GSF.Units Namespace


Time.CompareTo Method (TimeSpan)

Grid Solutions Framework TimeCompareTo Method (TimeSpan)
Compares this instance to a specified TimeSpan and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    TimeSpan value
)
Public Function CompareTo (
    value As TimeSpan
) As Integer
abstract CompareTo :
        value : TimeSpan -> int
override CompareTo :
        value : TimeSpan -> int
function CompareTo(value);
public:
virtual int CompareTo(
    TimeSpan value
) sealed

Parameters

value
Type: SystemTimeSpan
A TimeSpan to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Time Structure
CompareTo Overload
GSF.Units Namespace


Time.CompareTo Method (Time)

Grid Solutions Framework TimeCompareTo Method (Time)
Compares this instance to a specified Time and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Time value
)
Public Function CompareTo (
    value As Time
) As Integer
abstract CompareTo :
        value : Time -> int
override CompareTo :
        value : Time -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Time value
) sealed

Parameters

value
Type: GSF.UnitsTime
A Time to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Time Structure
CompareTo Overload
GSF.Units Namespace


Time.Equals Method

Grid Solutions Framework TimeEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(TimeSpan) | Returns a value indicating whether this instance is equal to a specified TimeSpan value.
Public method | Equals(Time) | Returns a value indicating whether this instance is equal to a specified Time value.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Equals Method (Double)

Grid Solutions Framework TimeEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
An Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Time Structure
Equals Overload
GSF.Units Namespace


Time.Equals Method (Object)

Grid Solutions Framework TimeEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Time and equals the value of this instance; otherwise, False.
See Also

Reference

Time Structure
Equals Overload
GSF.Units Namespace


Time.Equals Method (TimeSpan)

Grid Solutions Framework TimeEquals Method (TimeSpan)
Returns a value indicating whether this instance is equal to a specified TimeSpan value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    TimeSpan obj
)
Public Function Equals (
    obj As TimeSpan
) As Boolean
abstract Equals :
        obj : TimeSpan -> bool
override Equals :
        obj : TimeSpan -> bool
function Equals(obj);
public:
virtual bool Equals(
    TimeSpan obj
) sealed

Parameters

obj
Type: SystemTimeSpan
A TimeSpan value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Time Structure
Equals Overload
GSF.Units Namespace


Time.Equals Method (Time)

Grid Solutions Framework TimeEquals Method (Time)
Returns a value indicating whether this instance is equal to a specified Time value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Time obj
)
Public Function Equals (
    obj As Time
) As Boolean
abstract Equals :
        obj : Time -> bool
override Equals :
        obj : Time -> bool
function Equals(obj);
public:
virtual bool Equals(
    Time obj
) sealed

Parameters

obj
Type: GSF.UnitsTime
A Time value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Time Structure
Equals Overload
GSF.Units Namespace


Time.FromAtomicUnitsOfTime Method

Grid Solutions Framework TimeFromAtomicUnitsOfTime Method
Creates a new Time value from the specified value in atomic units of time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time FromAtomicUnitsOfTime(
    double value
)
Public Shared Function FromAtomicUnitsOfTime (
    value As Double
) As Time
static member FromAtomicUnitsOfTime :
        value : float -> Time

GSF.Units.Time.FromAtomicUnitsOfTime = function(value);
public:
static Time FromAtomicUnitsOfTime(
    double value
)

Parameters

value
Type: SystemDouble
New Time value in atomic units of time.

Return Value

Type: Time
New Time object from the specified value in atomic units of time.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.FromDays Method

Grid Solutions Framework TimeFromDays Method
Creates a new Time value from the specified value in days.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time FromDays(
    double value
)
Public Shared Function FromDays (
    value As Double
) As Time
static member FromDays :
        value : float -> Time

GSF.Units.Time.FromDays = function(value);
public:
static Time FromDays(
    double value
)

Parameters

value
Type: SystemDouble
New Time value in days.

Return Value

Type: Time
New Time object from the specified value in days.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.FromHours Method

Grid Solutions Framework TimeFromHours Method
Creates a new Time value from the specified value in hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time FromHours(
    double value
)
Public Shared Function FromHours (
    value As Double
) As Time
static member FromHours :
        value : float -> Time

GSF.Units.Time.FromHours = function(value);
public:
static Time FromHours(
    double value
)

Parameters

value
Type: SystemDouble
New Time value in hours.

Return Value

Type: Time
New Time object from the specified value in hours.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.FromKe Method

Grid Solutions Framework TimeFromKe Method
Creates a new Time value from the specified value in ke, the traditional Chinese unit of decimal time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time FromKe(
    double value
)
Public Shared Function FromKe (
    value As Double
) As Time
static member FromKe :
        value : float -> Time

GSF.Units.Time.FromKe = function(value);
public:
static Time FromKe(
    double value
)

Parameters

value
Type: SystemDouble
New Time value in ke.

Return Value

Type: Time
New Time object from the specified value in ke.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.FromMinutes Method

Grid Solutions Framework TimeFromMinutes Method
Creates a new Time value from the specified value in minutes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time FromMinutes(
    double value
)
Public Shared Function FromMinutes (
    value As Double
) As Time
static member FromMinutes :
        value : float -> Time

GSF.Units.Time.FromMinutes = function(value);
public:
static Time FromMinutes(
    double value
)

Parameters

value
Type: SystemDouble
New Time value in minutes.

Return Value

Type: Time
New Time object from the specified value in minutes.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.FromPlanckTime Method

Grid Solutions Framework TimeFromPlanckTime Method
Creates a new Time value from the specified value in Planck time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time FromPlanckTime(
    double value
)
Public Shared Function FromPlanckTime (
    value As Double
) As Time
static member FromPlanckTime :
        value : float -> Time

GSF.Units.Time.FromPlanckTime = function(value);
public:
static Time FromPlanckTime(
    double value
)

Parameters

value
Type: SystemDouble
New Time value in Planck time.

Return Value

Type: Time
New Time object from the specified value in Planck time.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.FromWeeks Method

Grid Solutions Framework TimeFromWeeks Method
Creates a new Time value from the specified value in weeks.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time FromWeeks(
    double value
)
Public Shared Function FromWeeks (
    value As Double
) As Time
static member FromWeeks :
        value : float -> Time

GSF.Units.Time.FromWeeks = function(value);
public:
static Time FromWeeks(
    double value
)

Parameters

value
Type: SystemDouble
New Time value in weeks.

Return Value

Type: Time
New Time object from the specified value in weeks.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.GetHashCode Method

Grid Solutions Framework TimeGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.GetTypeCode Method

Grid Solutions Framework TimeGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Parse Method

Grid Solutions Framework TimeParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Time equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Time equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Time equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Parse Method (String)

Grid Solutions Framework TimeParse Method (String)
Converts the string representation of a number to its Time equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Time
static member Parse :
        s : string -> Time

GSF.Units.Time.Parse = function(s);
public:
static Time Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Time
A Time equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Time Structure
Parse Overload
GSF.Units Namespace


Time.Parse Method (String, NumberStyles)

Grid Solutions Framework TimeParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Time equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Time
static member Parse :
        s : string *
        style : NumberStyles -> Time

GSF.Units.Time.Parse = function(s, style);
public:
static Time Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Time
A Time equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Time Structure
Parse Overload
GSF.Units Namespace


Time.Parse Method (String, IFormatProvider)

Grid Solutions Framework TimeParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Time equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Time
static member Parse :
        s : string *
        provider : IFormatProvider -> Time

GSF.Units.Time.Parse = function(s, provider);
public:
static Time Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Time
A Time equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Time Structure
Parse Overload
GSF.Units Namespace


Time.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework TimeParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Time
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Time

GSF.Units.Time.Parse = function(s, style, provider);
public:
static Time Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Time
A Time equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Time Structure
Parse Overload
GSF.Units Namespace


Time.SecondsPerMonth Method

Grid Solutions Framework TimeSecondsPerMonth Method
Returns the number of seconds in the specified month and year.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int SecondsPerMonth(
    int year,
    int month
)
Public Shared Function SecondsPerMonth (
    year As Integer,
    month As Integer
) As Integer
static member SecondsPerMonth :
        year : int *
        month : int -> int

GSF.Units.Time.SecondsPerMonth = function(year, month);
public:
static int SecondsPerMonth(
    int year,
    int month
)

Parameters

year
Type: SystemInt32
The year.
month
Type: SystemInt32
The month (a number ranging from 1 to 12).

Return Value

Type: Int32
The number of seconds, as a Time, in the month for the specified year.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Month is less than 1 or greater than 12. -or- year is less than 1 or greater than 9999.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.SecondsPerYear Method

Grid Solutions Framework TimeSecondsPerYear Method
Returns the number of seconds in the specified year.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static long SecondsPerYear(
    int year
)
Public Shared Function SecondsPerYear (
    year As Integer
) As Long
static member SecondsPerYear :
        year : int -> int64

GSF.Units.Time.SecondsPerYear = function(year);
public:
static long long SecondsPerYear(
    int year
)

Parameters

year
Type: SystemInt32
The year.

Return Value

Type: Int64
The number of seconds in the specified year.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | Year is less than 1 or greater than 9999.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToAtomicUnitsOfTime Method

Grid Solutions Framework TimeToAtomicUnitsOfTime Method
Gets the Time value in atomic units of time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToAtomicUnitsOfTime()
Public Function ToAtomicUnitsOfTime As Double
member ToAtomicUnitsOfTime : unit -> float

function ToAtomicUnitsOfTime();
public:
double ToAtomicUnitsOfTime()

Return Value

Type: Double
Value of Time in atomic units of time.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToDays Method

Grid Solutions Framework TimeToDays Method
Gets the Time value in days.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToDays()
Public Function ToDays As Double
member ToDays : unit -> float

function ToDays();
public:
double ToDays()

Return Value

Type: Double
Value of Time in days.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToElapsedTimeString Method

Grid Solutions Framework TimeToElapsedTimeString Method
Converts total seconds into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToElapsedTimeString(
    double seconds,
    int secondPrecision,
    string[] timeNames = null,
    double minimumSubSecondResolution = 0.001
)
Public Shared Function ToElapsedTimeString (
    seconds As Double,
    secondPrecision As Integer,
    Optional timeNames As String() = Nothing,
    Optional minimumSubSecondResolution As Double = 0.001
) As String
static member ToElapsedTimeString :
        seconds : float *
        secondPrecision : int *
        ?timeNames : string[] *
        ?minimumSubSecondResolution : float
(* Defaults:
        let _timeNames = defaultArg timeNames null
        let _minimumSubSecondResolution = defaultArg minimumSubSecondResolution 0.001
*)
-> string

GSF.Units.Time.ToElapsedTimeString = function(seconds, secondPrecision, timeNames, minimumSubSecondResolution);
public:
static String^ ToElapsedTimeString(
    double seconds,
    int secondPrecision,
    array<String^>^ timeNames = nullptr,
    double minimumSubSecondResolution = 0.001
)

Parameters

seconds
Type: SystemDouble
Seconds to convert to elapsed time.
secondPrecision
Type: SystemInt32
Number of fractional digits to display for seconds.
timeNames (Optional)
Type: SystemString
Time names array to use during textual conversion.
minimumSubSecondResolution (Optional)
Type: SystemDouble
Minimum sub-second resolution to display. Defaults to Milli.

Return Value

Type: String
The string representation of the value of this instance, consisting of the number of years, days, hours, minutes and seconds represented by this value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumSubSecondResolution is not less than or equal to Milli or minimumSubSecondResolution is not defined in Factors array.
Remarks

Set secondPrecision to -1 to suppress seconds display, this will force minimum resolution of time display to minutes.

timeNames array needs one string entry for each of the following names:
" year", " years", " day", " days", " hour", " hours", " minute", " minutes", " second", " seconds", "less than ".

See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToHours Method

Grid Solutions Framework TimeToHours Method
Gets the Time value in hours.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToHours()
Public Function ToHours As Double
member ToHours : unit -> float

function ToHours();
public:
double ToHours()

Return Value

Type: Double
Value of Time in hours.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToKe Method

Grid Solutions Framework TimeToKe Method
Gets the Time value in ke, the traditional Chinese unit of decimal time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToKe()
Public Function ToKe As Double
member ToKe : unit -> float

function ToKe();
public:
double ToKe()

Return Value

Type: Double
Value of Time in ke.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToMinutes Method

Grid Solutions Framework TimeToMinutes Method
Gets the Time value in minutes.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMinutes()
Public Function ToMinutes As Double
member ToMinutes : unit -> float

function ToMinutes();
public:
double ToMinutes()

Return Value

Type: Double
Value of Time in minutes.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToPlanckTime Method

Grid Solutions Framework TimeToPlanckTime Method
Gets the Time value in Planck time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToPlanckTime()
Public Function ToPlanckTime As Double
member ToPlanckTime : unit -> float

function ToPlanckTime();
public:
double ToPlanckTime()

Return Value

Type: Double
Value of Time in Planck time.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToString Method

Grid Solutions Framework TimeToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the Time value into a textual representation of years, days, hours, minutes and seconds. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(Int32, Double) | Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToString(Int32, String, Double) | Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToString Method

Grid Solutions Framework TimeToString Method
Converts the Time value into a textual representation of years, days, hours, minutes and seconds.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of the number of years, days, hours, minutes and seconds represented by this value.
Remarks
Note that this ToString overload will not display fractional seconds. To allow display of fractional seconds, or completely remove second resolution from the textual representation, use the ToString(Int32, Double) overload instead.
See Also

Reference

Time Structure
ToString Overload
GSF.Units Namespace


Time.ToString Method (IFormatProvider)

Grid Solutions Framework TimeToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
Remarks
Note that this ToString overload matches ToString(IFormatProvider), use ToString(Int32, Double) to convert Time value into a textual representation of years, days, hours, minutes and seconds.
See Also

Reference

Time Structure
ToString Overload
GSF.Units Namespace


Time.ToString Method (String)

Grid Solutions Framework TimeToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
Remarks
Note that this ToString overload matches ToString(String), use ToString(Int32, Double) to convert Time value into a textual representation of years, days, hours, minutes and seconds.
See Also

Reference

Time Structure
ToString Overload
GSF.Units Namespace


Time.ToString Method (Int32, Double)

Grid Solutions Framework TimeToString Method (Int32, Double)
Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    int secondPrecision,
    double minimumSubSecondResolution = 0.001
)
Public Function ToString (
    secondPrecision As Integer,
    Optional minimumSubSecondResolution As Double = 0.001
) As String
member ToString :
        secondPrecision : int *
        ?minimumSubSecondResolution : float
(* Defaults:
        let _minimumSubSecondResolution = defaultArg minimumSubSecondResolution 0.001
*)
-> string

function ToString(secondPrecision, minimumSubSecondResolution);
public:
String^ ToString(
    int secondPrecision,
    double minimumSubSecondResolution = 0.001
)

Parameters

secondPrecision
Type: SystemInt32
Number of fractional digits to display for seconds.
minimumSubSecondResolution (Optional)
Type: SystemDouble
Minimum sub-second resolution to display. Defaults to Milli.

Return Value

Type: String
The string representation of the value of this instance, consisting of the number of years, days, hours, minutes and seconds represented by this value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumSubSecondResolution is not less than or equal to Milli or minimumSubSecondResolution is not defined in Factors array.
Remarks
Set second precision to -1 to suppress seconds display.
See Also

Reference

Time Structure
ToString Overload
GSF.Units Namespace


Time.ToString Method (String, IFormatProvider)

Grid Solutions Framework TimeToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
Remarks
Note that this ToString overload matches ToString(String, IFormatProvider), use ToString(Int32, Double) to convert Time value into a textual representation of years, days, hours, minutes and seconds.
See Also

Reference

Time Structure
ToString Overload
GSF.Units Namespace


Time.ToString Method (Int32, String[], Double)

Grid Solutions Framework TimeToString Method (Int32, String, Double)
Converts the Time value into a textual representation of years, days, hours, minutes and seconds with the specified number of fractional digits given string array of time names.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    int secondPrecision,
    string[] timeNames,
    double minimumSubSecondResolution = 0.001
)
Public Function ToString (
    secondPrecision As Integer,
    timeNames As String(),
    Optional minimumSubSecondResolution As Double = 0.001
) As String
member ToString :
        secondPrecision : int *
        timeNames : string[] *
        ?minimumSubSecondResolution : float
(* Defaults:
        let _minimumSubSecondResolution = defaultArg minimumSubSecondResolution 0.001
*)
-> string

function ToString(secondPrecision, timeNames, minimumSubSecondResolution);
public:
String^ ToString(
    int secondPrecision,
    array<String^>^ timeNames,
    double minimumSubSecondResolution = 0.001
)

Parameters

secondPrecision
Type: SystemInt32
Number of fractional digits to display for seconds.
timeNames
Type: SystemString
Time names array to use during textual conversion.
minimumSubSecondResolution (Optional)
Type: SystemDouble
Minimum sub-second resolution to display. Defaults to Milli.

Return Value

Type: String
The string representation of the value of this instance, consisting of the number of years, days, hours, minutes and seconds represented by this value.
Exceptions
Exception | Condition
ArgumentOutOfRangeException | minimumSubSecondResolution is not less than or equal to Milli or minimumSubSecondResolution is not defined in Factors array.
Remarks

Set second precision to -1 to suppress seconds display.

timeNames array needs one string entry for each of the following names:
" year", " years", " day", " days", " hour", " hours", " minute", " minutes", " second", " seconds", "less than ".

See Also

Reference

Time Structure
ToString Overload
GSF.Units Namespace


Time.ToTicks Method

Grid Solutions Framework TimeToTicks Method
Converts the Time value, in seconds, to 100-nanosecond tick intervals.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Ticks ToTicks()
Public Function ToTicks As Ticks
member ToTicks : unit -> Ticks

function ToTicks();
public:
Ticks ToTicks()

Return Value

Type: Ticks
A Ticks object.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.ToWeeks Method

Grid Solutions Framework TimeToWeeks Method
Gets the Time value in weeks.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToWeeks()
Public Function ToWeeks As Double
member ToWeeks : unit -> float

function ToWeeks();
public:
double ToWeeks()

Return Value

Type: Double
Value of Time in weeks.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.TryParse Method

Grid Solutions Framework TimeTryParse Method
Overload List
Name | Description
TryParse(String, Time) | Converts the string representation of a number to its Time equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Time) | Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.TryParse Method (String, Time)

Grid Solutions Framework TimeTryParse Method (String, Time)
Converts the string representation of a number to its Time equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Time result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Time
) As Boolean
static member TryParse :
        s : string *
        result : Time byref -> bool

GSF.Units.Time.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Time% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsTime
When this method returns, contains the Time value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Time Structure
TryParse Overload
GSF.Units Namespace


Time.TryParse Method (String, NumberStyles, IFormatProvider, Time)

Grid Solutions Framework TimeTryParse Method (String, NumberStyles, IFormatProvider, Time)
Converts the string representation of a number in a specified style and culture-specific format to its Time equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Time result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Time
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Time byref -> bool

GSF.Units.Time.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Time% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsTime
When this method returns, contains the Time value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s parameter is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This parameter is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Time Structure
TryParse Overload
GSF.Units Namespace


Time Operators and Type Conversions

Grid Solutions Framework Time Operators and Type Conversions

The Time type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Time) | Implicitly converts value, represented in seconds, to a Time.
(TimeSpan to Time) | Implicitly converts value, represented as a TimeSpan, to a Time.
(Time to Double) | Implicitly converts Time, represented in seconds, to a Double.
(Time to TimeSpan) | Implicitly converts Time, represented in seconds, to a TimeSpan.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Addition Operator

Grid Solutions Framework TimeAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time operator +(
    Time value1,
    Time value2
)
Public Shared Operator + (
    value1 As Time,
    value2 As Time
) As Time
static let inline (+)
        value1 : Time *
        value2 : Time  : Time
JavaScript does not support overloaded operators.
public:
static Time operator +(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Time
A Time object as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Division Operator

Grid Solutions Framework TimeDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time operator /(
    Time value1,
    Time value2
)
Public Shared Operator / (
    value1 As Time,
    value2 As Time
) As Time
static let inline (/)
        value1 : Time *
        value2 : Time  : Time
JavaScript does not support overloaded operators.
public:
static Time operator /(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Time
A Time object as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Equality Operator

Grid Solutions Framework TimeEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Time value1,
    Time value2
)
Public Shared Operator = (
    value1 As Time,
    value2 As Time
) As Boolean
static let inline (=)
        value1 : Time *
        value2 : Time  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Exponent Operator

Grid Solutions Framework TimeExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Time,
    value2 As Time
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Double
A Double value as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.GreaterThan Operator

Grid Solutions Framework TimeGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Time value1,
    Time value2
)
Public Shared Operator > (
    value1 As Time,
    value2 As Time
) As Boolean
static let inline (>)
        value1 : Time *
        value2 : Time  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.GreaterThanOrEqual Operator

Grid Solutions Framework TimeGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Time value1,
    Time value2
)
Public Shared Operator >= (
    value1 As Time,
    value2 As Time
) As Boolean
static let inline (>=)
        value1 : Time *
        value2 : Time  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time Implicit Conversion Operators

Grid Solutions Framework Time Conversion Operators
Overload List
Name | Description
(Double to Time) | Implicitly converts value, represented in seconds, to a Time.
(TimeSpan to Time) | Implicitly converts value, represented as a TimeSpan, to a Time.
(Time to Double) | Implicitly converts Time, represented in seconds, to a Double.
(Time to TimeSpan) | Implicitly converts Time, represented in seconds, to a TimeSpan.
Top
See Also

Reference

Time Structure
GSF.Units Namespace


Time Implicit Conversion (Double to Time)

Grid Solutions Framework Time Conversion (Double to Time)
Implicitly converts value, represented in seconds, to a Time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Time (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Time
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Time (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Time
A Time object.
See Also

Reference

Time Structure
Overload
GSF.Units Namespace


Time Implicit Conversion (TimeSpan to Time)

Grid Solutions Framework Time Conversion (TimeSpan to Time)
Implicitly converts value, represented as a TimeSpan, to a Time.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Time (
    TimeSpan value
)
Public Shared Widening Operator CType (
    value As TimeSpan
) As Time
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Time (
    TimeSpan value
)

Parameters

value
Type: SystemTimeSpan
A TimeSpan object.

Return Value

Type: Time
A Time object.
See Also

Reference

Time Structure
Overload
GSF.Units Namespace


Time Implicit Conversion (Time to Double)

Grid Solutions Framework Time Conversion (Time to Double)
Implicitly converts Time, represented in seconds, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Time value
)
Public Shared Widening Operator CType (
    value As Time
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Time value
)

Parameters

value
Type: GSF.UnitsTime
A Time object.

Return Value

Type: Double
A Double value.
See Also

Reference

Time Structure
Overload
GSF.Units Namespace


Time Implicit Conversion (Time to TimeSpan)

Grid Solutions Framework Time Conversion (Time to TimeSpan)
Implicitly converts Time, represented in seconds, to a TimeSpan.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator TimeSpan (
    Time value
)
Public Shared Widening Operator CType (
    value As Time
) As TimeSpan
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator TimeSpan (
    Time value
)

Parameters

value
Type: GSF.UnitsTime
A Time object.

Return Value

Type: TimeSpan
A TimeSpan object.
See Also

Reference

Time Structure
Overload
GSF.Units Namespace


Time.Inequality Operator

Grid Solutions Framework TimeInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Time value1,
    Time value2
)
Public Shared Operator <> (
    value1 As Time,
    value2 As Time
) As Boolean
static let inline (<>)
        value1 : Time *
        value2 : Time  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.LessThan Operator

Grid Solutions Framework TimeLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Time value1,
    Time value2
)
Public Shared Operator < (
    value1 As Time,
    value2 As Time
) As Boolean
static let inline (<)
        value1 : Time *
        value2 : Time  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.LessThanOrEqual Operator

Grid Solutions Framework TimeLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Time value1,
    Time value2
)
Public Shared Operator <= (
    value1 As Time,
    value2 As Time
) As Boolean
static let inline (<=)
        value1 : Time *
        value2 : Time  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Boolean
A Boolean as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Modulus Operator

Grid Solutions Framework TimeModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time operator %(
    Time value1,
    Time value2
)
Public Shared Operator Mod (
    value1 As Time,
    value2 As Time
) As Time
static let inline (%)
        value1 : Time *
        value2 : Time  : Time
JavaScript does not support overloaded operators.
public:
static Time operator %(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Time
A Time object as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Multiply Operator

Grid Solutions Framework TimeMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time operator *(
    Time value1,
    Time value2
)
Public Shared Operator * (
    value1 As Time,
    value2 As Time
) As Time
static let inline (*)
        value1 : Time *
        value2 : Time  : Time
JavaScript does not support overloaded operators.
public:
static Time operator *(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Time
A Time object as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Time.Subtraction Operator

Grid Solutions Framework TimeSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Time operator -(
    Time value1,
    Time value2
)
Public Shared Operator - (
    value1 As Time,
    value2 As Time
) As Time
static let inline (-)
        value1 : Time *
        value2 : Time  : Time
JavaScript does not support overloaded operators.
public:
static Time operator -(
    Time value1,
    Time value2
)

Parameters

value1
Type: GSF.UnitsTime
A Time object as the left hand operand.
value2
Type: GSF.UnitsTime
A Time object as the right hand operand.

Return Value

Type: Time
A Time object as the result of the operation.
See Also

Reference

Time Structure
GSF.Units Namespace


Voltage Structure

Grid Solutions Framework Voltage Structure
Represents an electromotive force (i.e., voltage) measurement, in volts, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Voltage : IComparable, IFormattable,
    IConvertible, IComparable<Voltage>, IComparable<double>, IEquatable<Voltage>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Voltage
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Voltage),
    IComparable(Of Double), IEquatable(Of Voltage), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Voltage =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Voltage>
        interface IComparable<float>
        interface IEquatable<Voltage>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Voltage : IComparable,
    IFormattable, IConvertible, IComparable<Voltage>, IComparable<double>,
    IEquatable<Voltage>, IEquatable<double>

The Voltage type exposes the following members.

Constructors
 | Name | Description
Public method | Voltage | Creates a new Voltage.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Voltage) | Compares this instance to a specified Voltage and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Voltage) | Returns a value indicating whether this instance is equal to a specified Voltage value.
 | FromAbvolts | Creates a new Voltage value from the specified value in abvolts.
 | FromStatvolts | Creates a new Voltage value from the specified value in statvolts.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Voltage equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Voltage equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Voltage equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent.
Public method | ToAbvolts | Gets the Voltage value in abvolts.
Public method | ToStatvolts | Gets the Voltage value in statvolts.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Voltage) | Converts the string representation of a number to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Voltage) | Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to voltage of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Voltage) | Implicitly converts value, represented in volts, to a Voltage.
(Voltage to Double) | Implicitly converts Voltage, represented in volts, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Voltage. This field is constant.
MinValue | Represents the smallest possible value of an Voltage. This field is constant.
Top
Remarks
This class behaves just like a Double representing a voltage in volts; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other voltage representations, specifically abvolt and statvolt. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert volts to megavolts:
Copy
public double GetMegavolts(Voltage volts)
{
    return volts / SI.Mega;
}
See Also

Reference

GSF.Units Namespace


Voltage Constructor

Grid Solutions Framework Voltage Constructor
Creates a new Voltage.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Voltage(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Voltage
GSF.Units.Voltage = function(value);
public:
Voltage(
    double value
)

Parameters

value
Type: SystemDouble
New voltage value in volts.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage Fields

Grid Solutions Framework Voltage Fields

The Voltage type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Voltage. This field is constant.
MinValue | Represents the smallest possible value of an Voltage. This field is constant.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.MaxValue Field

Grid Solutions Framework VoltageMaxValue Field
Represents the largest possible value of an Voltage. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Voltage MaxValue
Public Shared ReadOnly MaxValue As Voltage
static val MaxValue: Voltage
var GSF.Units.Voltage.MaxValue
public:
static initonly Voltage MaxValue

Field Value

Type: Voltage
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.MinValue Field

Grid Solutions Framework VoltageMinValue Field
Represents the smallest possible value of an Voltage. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Voltage MinValue
Public Shared ReadOnly MinValue As Voltage
static val MinValue: Voltage
var GSF.Units.Voltage.MinValue
public:
static initonly Voltage MinValue

Field Value

Type: Voltage
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage Methods

Grid Solutions Framework Voltage Methods

The Voltage type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Voltage) | Compares this instance to a specified Voltage and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Voltage) | Returns a value indicating whether this instance is equal to a specified Voltage value.
 | FromAbvolts | Creates a new Voltage value from the specified value in abvolts.
 | FromStatvolts | Creates a new Voltage value from the specified value in statvolts.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Voltage equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Voltage equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Voltage equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent.
Public method | ToAbvolts | Gets the Voltage value in abvolts.
Public method | ToStatvolts | Gets the Voltage value in statvolts.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
 | TryParse(String, Voltage) | Converts the string representation of a number to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Voltage) | Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.CompareTo Method

Grid Solutions Framework VoltageCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Voltage) | Compares this instance to a specified Voltage and returns an indication of their relative values.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.CompareTo Method (Double)

Grid Solutions Framework VoltageCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Voltage Structure
CompareTo Overload
GSF.Units Namespace


Voltage.CompareTo Method (Object)

Grid Solutions Framework VoltageCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Voltage.
See Also

Reference

Voltage Structure
CompareTo Overload
GSF.Units Namespace


Voltage.CompareTo Method (Voltage)

Grid Solutions Framework VoltageCompareTo Method (Voltage)
Compares this instance to a specified Voltage and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Voltage value
)
Public Function CompareTo (
    value As Voltage
) As Integer
abstract CompareTo :
        value : Voltage -> int
override CompareTo :
        value : Voltage -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Voltage value
) sealed

Parameters

value
Type: GSF.UnitsVoltage
A Voltage to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Voltage Structure
CompareTo Overload
GSF.Units Namespace


Voltage.Equals Method

Grid Solutions Framework VoltageEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Voltage) | Returns a value indicating whether this instance is equal to a specified Voltage value.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Equals Method (Double)

Grid Solutions Framework VoltageEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Voltage Structure
Equals Overload
GSF.Units Namespace


Voltage.Equals Method (Object)

Grid Solutions Framework VoltageEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Voltage and equals the value of this instance; otherwise, False.
See Also

Reference

Voltage Structure
Equals Overload
GSF.Units Namespace


Voltage.Equals Method (Voltage)

Grid Solutions Framework VoltageEquals Method (Voltage)
Returns a value indicating whether this instance is equal to a specified Voltage value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Voltage obj
)
Public Function Equals (
    obj As Voltage
) As Boolean
abstract Equals :
        obj : Voltage -> bool
override Equals :
        obj : Voltage -> bool
function Equals(obj);
public:
virtual bool Equals(
    Voltage obj
) sealed

Parameters

obj
Type: GSF.UnitsVoltage
A Voltage value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Voltage Structure
Equals Overload
GSF.Units Namespace


Voltage.FromAbvolts Method

Grid Solutions Framework VoltageFromAbvolts Method
Creates a new Voltage value from the specified value in abvolts.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage FromAbvolts(
    double value
)
Public Shared Function FromAbvolts (
    value As Double
) As Voltage
static member FromAbvolts :
        value : float -> Voltage

GSF.Units.Voltage.FromAbvolts = function(value);
public:
static Voltage FromAbvolts(
    double value
)

Parameters

value
Type: SystemDouble
New Voltage value in abvolts.

Return Value

Type: Voltage
New Voltage object from the specified value in abvolts.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.FromStatvolts Method

Grid Solutions Framework VoltageFromStatvolts Method
Creates a new Voltage value from the specified value in statvolts.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage FromStatvolts(
    double value
)
Public Shared Function FromStatvolts (
    value As Double
) As Voltage
static member FromStatvolts :
        value : float -> Voltage

GSF.Units.Voltage.FromStatvolts = function(value);
public:
static Voltage FromStatvolts(
    double value
)

Parameters

value
Type: SystemDouble
New Voltage value in statvolts.

Return Value

Type: Voltage
New Voltage object from the specified value in statvolts.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.GetHashCode Method

Grid Solutions Framework VoltageGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.GetTypeCode Method

Grid Solutions Framework VoltageGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Parse Method

Grid Solutions Framework VoltageParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Voltage equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Voltage equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Voltage equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Parse Method (String)

Grid Solutions Framework VoltageParse Method (String)
Converts the string representation of a number to its Voltage equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Voltage
static member Parse :
        s : string -> Voltage

GSF.Units.Voltage.Parse = function(s);
public:
static Voltage Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Voltage
A Voltage equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Voltage Structure
Parse Overload
GSF.Units Namespace


Voltage.Parse Method (String, NumberStyles)

Grid Solutions Framework VoltageParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Voltage equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Voltage
static member Parse :
        s : string *
        style : NumberStyles -> Voltage

GSF.Units.Voltage.Parse = function(s, style);
public:
static Voltage Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Voltage
A Voltage equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Voltage Structure
Parse Overload
GSF.Units Namespace


Voltage.Parse Method (String, IFormatProvider)

Grid Solutions Framework VoltageParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Voltage equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Voltage
static member Parse :
        s : string *
        provider : IFormatProvider -> Voltage

GSF.Units.Voltage.Parse = function(s, provider);
public:
static Voltage Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Voltage
A Voltage equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Voltage Structure
Parse Overload
GSF.Units Namespace


Voltage.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework VoltageParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Voltage
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Voltage

GSF.Units.Voltage.Parse = function(s, style, provider);
public:
static Voltage Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Voltage
A Voltage equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Voltage Structure
Parse Overload
GSF.Units Namespace


Voltage.ToAbvolts Method

Grid Solutions Framework VoltageToAbvolts Method
Gets the Voltage value in abvolts.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToAbvolts()
Public Function ToAbvolts As Double
member ToAbvolts : unit -> float

function ToAbvolts();
public:
double ToAbvolts()

Return Value

Type: Double
Value of Voltage in abvolts.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.ToStatvolts Method

Grid Solutions Framework VoltageToStatvolts Method
Gets the Voltage value in statvolts.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToStatvolts()
Public Function ToStatvolts As Double
member ToStatvolts : unit -> float

function ToStatvolts();
public:
double ToStatvolts()

Return Value

Type: Double
Value of Voltage in statvolts.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.ToString Method

Grid Solutions Framework VoltageToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.ToString Method

Grid Solutions Framework VoltageToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Voltage Structure
ToString Overload
GSF.Units Namespace


Voltage.ToString Method (IFormatProvider)

Grid Solutions Framework VoltageToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Voltage Structure
ToString Overload
GSF.Units Namespace


Voltage.ToString Method (String)

Grid Solutions Framework VoltageToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Voltage Structure
ToString Overload
GSF.Units Namespace


Voltage.ToString Method (String, IFormatProvider)

Grid Solutions Framework VoltageToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Voltage Structure
ToString Overload
GSF.Units Namespace


Voltage.TryParse Method

Grid Solutions Framework VoltageTryParse Method
Overload List
Name | Description
TryParse(String, Voltage) | Converts the string representation of a number to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Voltage) | Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.TryParse Method (String, Voltage)

Grid Solutions Framework VoltageTryParse Method (String, Voltage)
Converts the string representation of a number to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Voltage result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Voltage
) As Boolean
static member TryParse :
        s : string *
        result : Voltage byref -> bool

GSF.Units.Voltage.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Voltage% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsVoltage
When this method returns, contains the Voltage value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paravolt is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This paravolt is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Voltage Structure
TryParse Overload
GSF.Units Namespace


Voltage.TryParse Method (String, NumberStyles, IFormatProvider, Voltage)

Grid Solutions Framework VoltageTryParse Method (String, NumberStyles, IFormatProvider, Voltage)
Converts the string representation of a number in a specified style and culture-specific format to its Voltage equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Voltage result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Voltage
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Voltage byref -> bool

GSF.Units.Voltage.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Voltage% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsVoltage
When this method returns, contains the Voltage value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paravolt is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This paravolt is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Voltage Structure
TryParse Overload
GSF.Units Namespace


Voltage Operators and Type Conversions

Grid Solutions Framework Voltage Operators and Type Conversions

The Voltage type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to voltage of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Voltage) | Implicitly converts value, represented in volts, to a Voltage.
(Voltage to Double) | Implicitly converts Voltage, represented in volts, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Addition Operator

Grid Solutions Framework VoltageAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage operator +(
    Voltage value1,
    Voltage value2
)
Public Shared Operator + (
    value1 As Voltage,
    value2 As Voltage
) As Voltage
static let inline (+)
        value1 : Voltage *
        value2 : Voltage  : Voltage
JavaScript does not support overloaded operators.
public:
static Voltage operator +(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Voltage
A Voltage as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Division Operator

Grid Solutions Framework VoltageDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage operator /(
    Voltage value1,
    Voltage value2
)
Public Shared Operator / (
    value1 As Voltage,
    value2 As Voltage
) As Voltage
static let inline (/)
        value1 : Voltage *
        value2 : Voltage  : Voltage
JavaScript does not support overloaded operators.
public:
static Voltage operator /(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Voltage
A Voltage as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Equality Operator

Grid Solutions Framework VoltageEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Voltage value1,
    Voltage value2
)
Public Shared Operator = (
    value1 As Voltage,
    value2 As Voltage
) As Boolean
static let inline (=)
        value1 : Voltage *
        value2 : Voltage  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Exponent Operator

Grid Solutions Framework VoltageExponent Operator
Returns result of first value raised to voltage of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Voltage,
    value2 As Voltage
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Double
A Double value as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.GreaterThan Operator

Grid Solutions Framework VoltageGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Voltage value1,
    Voltage value2
)
Public Shared Operator > (
    value1 As Voltage,
    value2 As Voltage
) As Boolean
static let inline (>)
        value1 : Voltage *
        value2 : Voltage  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.GreaterThanOrEqual Operator

Grid Solutions Framework VoltageGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Voltage value1,
    Voltage value2
)
Public Shared Operator >= (
    value1 As Voltage,
    value2 As Voltage
) As Boolean
static let inline (>=)
        value1 : Voltage *
        value2 : Voltage  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage Implicit Conversion Operators

Grid Solutions Framework Voltage Conversion Operators
Overload List
Name | Description
(Double to Voltage) | Implicitly converts value, represented in volts, to a Voltage.
(Voltage to Double) | Implicitly converts Voltage, represented in volts, to a Double.
Top
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage Implicit Conversion (Double to Voltage)

Grid Solutions Framework Voltage Conversion (Double to Voltage)
Implicitly converts value, represented in volts, to a Voltage.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Voltage (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Voltage
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Voltage (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Voltage
A Voltage object.
See Also

Reference

Voltage Structure
Overload
GSF.Units Namespace


Voltage Implicit Conversion (Voltage to Double)

Grid Solutions Framework Voltage Conversion (Voltage to Double)
Implicitly converts Voltage, represented in volts, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Voltage value
)
Public Shared Widening Operator CType (
    value As Voltage
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Voltage value
)

Parameters

value
Type: GSF.UnitsVoltage
A Voltage object.

Return Value

Type: Double
A Double value.
See Also

Reference

Voltage Structure
Overload
GSF.Units Namespace


Voltage.Inequality Operator

Grid Solutions Framework VoltageInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Voltage value1,
    Voltage value2
)
Public Shared Operator <> (
    value1 As Voltage,
    value2 As Voltage
) As Boolean
static let inline (<>)
        value1 : Voltage *
        value2 : Voltage  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.LessThan Operator

Grid Solutions Framework VoltageLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Voltage value1,
    Voltage value2
)
Public Shared Operator < (
    value1 As Voltage,
    value2 As Voltage
) As Boolean
static let inline (<)
        value1 : Voltage *
        value2 : Voltage  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.LessThanOrEqual Operator

Grid Solutions Framework VoltageLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Voltage value1,
    Voltage value2
)
Public Shared Operator <= (
    value1 As Voltage,
    value2 As Voltage
) As Boolean
static let inline (<=)
        value1 : Voltage *
        value2 : Voltage  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Modulus Operator

Grid Solutions Framework VoltageModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage operator %(
    Voltage value1,
    Voltage value2
)
Public Shared Operator Mod (
    value1 As Voltage,
    value2 As Voltage
) As Voltage
static let inline (%)
        value1 : Voltage *
        value2 : Voltage  : Voltage
JavaScript does not support overloaded operators.
public:
static Voltage operator %(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Voltage
A Voltage as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Multiply Operator

Grid Solutions Framework VoltageMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage operator *(
    Voltage value1,
    Voltage value2
)
Public Shared Operator * (
    value1 As Voltage,
    value2 As Voltage
) As Voltage
static let inline (*)
        value1 : Voltage *
        value2 : Voltage  : Voltage
JavaScript does not support overloaded operators.
public:
static Voltage operator *(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Voltage
A Voltage as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Voltage.Subtraction Operator

Grid Solutions Framework VoltageSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Voltage operator -(
    Voltage value1,
    Voltage value2
)
Public Shared Operator - (
    value1 As Voltage,
    value2 As Voltage
) As Voltage
static let inline (-)
        value1 : Voltage *
        value2 : Voltage  : Voltage
JavaScript does not support overloaded operators.
public:
static Voltage operator -(
    Voltage value1,
    Voltage value2
)

Parameters

value1
Type: GSF.UnitsVoltage
A Voltage object as the left hand operand.
value2
Type: GSF.UnitsVoltage
A Voltage object as the right hand operand.

Return Value

Type: Voltage
A Voltage as the result.
See Also

Reference

Voltage Structure
GSF.Units Namespace


Volume Structure

Grid Solutions Framework Volume Structure
Represents a volume measurement, in cubic meters, as a double-precision floating-point number.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public struct Volume : IComparable, IFormattable,
    IConvertible, IComparable<Volume>, IComparable<double>, IEquatable<Volume>,
    IEquatable<double>
<SerializableAttribute>
Public Structure Volume
    Implements IComparable, IFormattable, IConvertible, IComparable(Of Volume),
    IComparable(Of Double), IEquatable(Of Volume), IEquatable(Of Double)
[<SealedAttribute>]
[<SerializableAttribute>]
type Volume =
    struct
        interface IComparable
        interface IFormattable
        interface IConvertible
        interface IComparable<Volume>
        interface IComparable<float>
        interface IEquatable<Volume>
        interface IEquatable<float>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
[SerializableAttribute]
public value class Volume : IComparable,
    IFormattable, IConvertible, IComparable<Volume>, IComparable<double>,
    IEquatable<Volume>, IEquatable<double>

The Volume type exposes the following members.

Constructors
 | Name | Description
Public method | Volume | Creates a new Volume.
Top
Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Volume) | Compares this instance to a specified Volume and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Volume) | Returns a value indicating whether this instance is equal to a specified Volume value.
 | FromCubicFeet | Creates a new Volume value from the specified value in cubic feet.
 | FromCubicInches | Creates a new Volume value from the specified value in cubic inches.
 | FromCups | Creates a new Volume value from the specified value in US cups.
 | FromFluidOunces | Creates a new Volume value from the specified value in US fluid ounces.
 | FromGallons | Creates a new Volume value from the specified value in US fluid gallons.
 | FromLiters | Creates a new Volume value from the specified value in liters.
 | FromMetricCups | Creates a new Volume value from the specified value in metric cups.
 | FromMetricTablespoons | Creates a new Volume value from the specified value in metric tablespoons.
 | FromMetricTeaspoons | Creates a new Volume value from the specified value in metric teaspoons.
 | FromPints | Creates a new Volume value from the specified value in US fluid pints.
 | FromQuarts | Creates a new Volume value from the specified value in US fluid quarts.
 | FromTablespoons | Creates a new Volume value from the specified value in US tablespoons.
 | FromTeaspoons | Creates a new Volume value from the specified value in US teaspoons.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Volume equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Volume equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Volume equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent.
Public method | ToCubicFeet | Gets the Volume value in cubic feet.
Public method | ToCubicInches | Gets the Volume value in cubic inches.
Public method | ToCups | Gets the Volume value in US cups.
Public method | ToFluidOunces | Gets the Volume value in US fluid ounces.
Public method | ToGallons | Gets the Volume value in US fluid gallons.
Public method | ToLiters | Gets the Volume value in liters.
Public method | ToMetricCups | Gets the Volume value in metric cups.
Public method | ToMetricTablespoons | Gets the Volume value in metric tablespoons.
Public method | ToMetricTeaspoons | Gets the Volume value in metric teaspoons.
Public method | ToPints | Gets the Volume value in US fluid pints.
Public method | ToQuarts | Gets the Volume value in US fluid quarts.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToTablespoons | Gets the Volume value in US tablespoons.
Public method | ToTeaspoons | Gets the Volume value in US teaspoons.
 | TryParse(String, Volume) | Converts the string representation of a number to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Volume) | Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to volume of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Volume) | Implicitly converts value, represented in cubic meters, to a Volume.
(Volume to Double) | Implicitly converts Volume, represented in cubic meters, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
MaxValue | Represents the largest possible value of an Volume. This field is constant.
MinValue | Represents the smallest possible value of an Volume. This field is constant.
Top
Remarks
This class behaves just like a Double representing a volume in cubic meters; it is implictly castable to and from a Double and therefore can be generally used "as" a double, but it has the advantage of handling conversions to and from other volume representations, specifically liters, teaspoons, tablespoons, cubic inches, fluid ounces, cups, pints, quarts, gallons and cubic feet. Metric conversions are handled simply by applying the needed SI conversion factor, for example:
Examples
Convert volume, in cubic meters, to cubic kilometers:
Copy
public double GetCubicKilometers(Volume cubicmeters)
{
    return cubicmeters / SI.Kilo;
}
This example converts teaspoons to cups:
Copy
public double GetCups(double teaspoons)
{
    return Volume.FromTeaspoons(teaspoons).ToCups();
}
This example converts liters to fluid ounces:
Copy
public double GetFluidOunces(double liters)
{
    return Volume.FromLiters(liters).ToFluidOunces();
}
See Also

Reference

GSF.Units Namespace


Volume Constructor

Grid Solutions Framework Volume Constructor
Creates a new Volume.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Volume(
    double value
)
Public Sub New (
    value As Double
)
new :
        value : float -> Volume
GSF.Units.Volume = function(value);
public:
Volume(
    double value
)

Parameters

value
Type: SystemDouble
New volume value in cubic meters.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume Fields

Grid Solutions Framework Volume Fields

The Volume type exposes the following members.

Fields
Name | Description
MaxValue | Represents the largest possible value of an Volume. This field is constant.
MinValue | Represents the smallest possible value of an Volume. This field is constant.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.MaxValue Field

Grid Solutions Framework VolumeMaxValue Field
Represents the largest possible value of an Volume. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Volume MaxValue
Public Shared ReadOnly MaxValue As Volume
static val MaxValue: Volume
var GSF.Units.Volume.MaxValue
public:
static initonly Volume MaxValue

Field Value

Type: Volume
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.MinValue Field

Grid Solutions Framework VolumeMinValue Field
Represents the smallest possible value of an Volume. This field is constant.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly Volume MinValue
Public Shared ReadOnly MinValue As Volume
static val MinValue: Volume
var GSF.Units.Volume.MinValue
public:
static initonly Volume MinValue

Field Value

Type: Volume
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume Methods

Grid Solutions Framework Volume Methods

The Volume type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Volume) | Compares this instance to a specified Volume and returns an indication of their relative values.
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Volume) | Returns a value indicating whether this instance is equal to a specified Volume value.
 | FromCubicFeet | Creates a new Volume value from the specified value in cubic feet.
 | FromCubicInches | Creates a new Volume value from the specified value in cubic inches.
 | FromCups | Creates a new Volume value from the specified value in US cups.
 | FromFluidOunces | Creates a new Volume value from the specified value in US fluid ounces.
 | FromGallons | Creates a new Volume value from the specified value in US fluid gallons.
 | FromLiters | Creates a new Volume value from the specified value in liters.
 | FromMetricCups | Creates a new Volume value from the specified value in metric cups.
 | FromMetricTablespoons | Creates a new Volume value from the specified value in metric tablespoons.
 | FromMetricTeaspoons | Creates a new Volume value from the specified value in metric teaspoons.
 | FromPints | Creates a new Volume value from the specified value in US fluid pints.
 | FromQuarts | Creates a new Volume value from the specified value in US fluid quarts.
 | FromTablespoons | Creates a new Volume value from the specified value in US tablespoons.
 | FromTeaspoons | Creates a new Volume value from the specified value in US teaspoons.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeCode | Returns the TypeCode for value type Double.
 | Parse(String) | Converts the string representation of a number to its Volume equivalent.
 | Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Volume equivalent.
 | Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Volume equivalent.
 | Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent.
Public method | ToCubicFeet | Gets the Volume value in cubic feet.
Public method | ToCubicInches | Gets the Volume value in cubic inches.
Public method | ToCups | Gets the Volume value in US cups.
Public method | ToFluidOunces | Gets the Volume value in US fluid ounces.
Public method | ToGallons | Gets the Volume value in US fluid gallons.
Public method | ToLiters | Gets the Volume value in liters.
Public method | ToMetricCups | Gets the Volume value in metric cups.
Public method | ToMetricTablespoons | Gets the Volume value in metric tablespoons.
Public method | ToMetricTeaspoons | Gets the Volume value in metric teaspoons.
Public method | ToPints | Gets the Volume value in US fluid pints.
Public method | ToQuarts | Gets the Volume value in US fluid quarts.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Public method | ToTablespoons | Gets the Volume value in US tablespoons.
Public method | ToTeaspoons | Gets the Volume value in US teaspoons.
 | TryParse(String, Volume) | Converts the string representation of a number to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.
 | TryParse(String, NumberStyles, IFormatProvider, Volume) | Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.CompareTo Method

Grid Solutions Framework VolumeCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Double) | Compares this instance to a specified Double and returns an indication of their relative values.
Public method | CompareTo(Object) | Compares this instance to a specified object and returns an indication of their relative values.
Public method | CompareTo(Volume) | Compares this instance to a specified Volume and returns an indication of their relative values.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.CompareTo Method (Double)

Grid Solutions Framework VolumeCompareTo Method (Double)
Compares this instance to a specified Double and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    double value
)
Public Function CompareTo (
    value As Double
) As Integer
abstract CompareTo :
        value : float -> int
override CompareTo :
        value : float -> int
function CompareTo(value);
public:
virtual int CompareTo(
    double value
) sealed

Parameters

value
Type: SystemDouble
A Double to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Volume Structure
CompareTo Overload
GSF.Units Namespace


Volume.CompareTo Method (Object)

Grid Solutions Framework VolumeCompareTo Method (Object)
Compares this instance to a specified object and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object value
)
Public Function CompareTo (
    value As Object
) As Integer
abstract CompareTo :
        value : Object -> int
override CompareTo :
        value : Object -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Object^ value
) sealed

Parameters

value
Type: SystemObject
An object to compare, or null.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableCompareTo(Object)
Exceptions
Exception | Condition
ArgumentException | value is not a Double or Volume.
See Also

Reference

Volume Structure
CompareTo Overload
GSF.Units Namespace


Volume.CompareTo Method (Volume)

Grid Solutions Framework VolumeCompareTo Method (Volume)
Compares this instance to a specified Volume and returns an indication of their relative values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Volume value
)
Public Function CompareTo (
    value As Volume
) As Integer
abstract CompareTo :
        value : Volume -> int
override CompareTo :
        value : Volume -> int
function CompareTo(value);
public:
virtual int CompareTo(
    Volume value
) sealed

Parameters

value
Type: GSF.UnitsVolume
A Volume to compare.

Return Value

Type: Int32
A signed number indicating the relative values of this instance and value. Returns less than zero if this instance is less than value, zero if this instance is equal to value, or greater than zero if this instance is greater than value.

Implements

IComparableTCompareTo(T)
See Also

Reference

Volume Structure
CompareTo Overload
GSF.Units Namespace


Volume.Equals Method

Grid Solutions Framework VolumeEquals Method
Overload List
 | Name | Description
Public method | Equals(Double) | Returns a value indicating whether this instance is equal to a specified Double value.
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Volume) | Returns a value indicating whether this instance is equal to a specified Volume value.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Equals Method (Double)

Grid Solutions Framework VolumeEquals Method (Double)
Returns a value indicating whether this instance is equal to a specified Double value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    double obj
)
Public Function Equals (
    obj As Double
) As Boolean
abstract Equals :
        obj : float -> bool
override Equals :
        obj : float -> bool
function Equals(obj);
public:
virtual bool Equals(
    double obj
) sealed

Parameters

obj
Type: SystemDouble
A Double value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Volume Structure
Equals Overload
GSF.Units Namespace


Volume.Equals Method (Object)

Grid Solutions Framework VolumeEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Double or Volume and equals the value of this instance; otherwise, False.
See Also

Reference

Volume Structure
Equals Overload
GSF.Units Namespace


Volume.Equals Method (Volume)

Grid Solutions Framework VolumeEquals Method (Volume)
Returns a value indicating whether this instance is equal to a specified Volume value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Volume obj
)
Public Function Equals (
    obj As Volume
) As Boolean
abstract Equals :
        obj : Volume -> bool
override Equals :
        obj : Volume -> bool
function Equals(obj);
public:
virtual bool Equals(
    Volume obj
) sealed

Parameters

obj
Type: GSF.UnitsVolume
A Volume value to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Volume Structure
Equals Overload
GSF.Units Namespace


Volume.FromCubicFeet Method

Grid Solutions Framework VolumeFromCubicFeet Method
Creates a new Volume value from the specified value in cubic feet.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromCubicFeet(
    double value
)
Public Shared Function FromCubicFeet (
    value As Double
) As Volume
static member FromCubicFeet :
        value : float -> Volume

GSF.Units.Volume.FromCubicFeet = function(value);
public:
static Volume FromCubicFeet(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in cubic feet.

Return Value

Type: Volume
New Volume object from the specified value in cubic feet.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromCubicInches Method

Grid Solutions Framework VolumeFromCubicInches Method
Creates a new Volume value from the specified value in cubic inches.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromCubicInches(
    double value
)
Public Shared Function FromCubicInches (
    value As Double
) As Volume
static member FromCubicInches :
        value : float -> Volume

GSF.Units.Volume.FromCubicInches = function(value);
public:
static Volume FromCubicInches(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in cubic inches.

Return Value

Type: Volume
New Volume object from the specified value in cubic inches.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromCups Method

Grid Solutions Framework VolumeFromCups Method
Creates a new Volume value from the specified value in US cups.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromCups(
    double value
)
Public Shared Function FromCups (
    value As Double
) As Volume
static member FromCups :
        value : float -> Volume

GSF.Units.Volume.FromCups = function(value);
public:
static Volume FromCups(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in US cups.

Return Value

Type: Volume
New Volume object from the specified value in US cups.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromFluidOunces Method

Grid Solutions Framework VolumeFromFluidOunces Method
Creates a new Volume value from the specified value in US fluid ounces.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromFluidOunces(
    double value
)
Public Shared Function FromFluidOunces (
    value As Double
) As Volume
static member FromFluidOunces :
        value : float -> Volume

GSF.Units.Volume.FromFluidOunces = function(value);
public:
static Volume FromFluidOunces(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in US fluid ounces.

Return Value

Type: Volume
New Volume object from the specified value in US fluid ounces.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromGallons Method

Grid Solutions Framework VolumeFromGallons Method
Creates a new Volume value from the specified value in US fluid gallons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromGallons(
    double value
)
Public Shared Function FromGallons (
    value As Double
) As Volume
static member FromGallons :
        value : float -> Volume

GSF.Units.Volume.FromGallons = function(value);
public:
static Volume FromGallons(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in US fluid gallons.

Return Value

Type: Volume
New Volume object from the specified value in US fluid gallons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromLiters Method

Grid Solutions Framework VolumeFromLiters Method
Creates a new Volume value from the specified value in liters.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromLiters(
    double value
)
Public Shared Function FromLiters (
    value As Double
) As Volume
static member FromLiters :
        value : float -> Volume

GSF.Units.Volume.FromLiters = function(value);
public:
static Volume FromLiters(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in liters.

Return Value

Type: Volume
New Volume object from the specified value in liters.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromMetricCups Method

Grid Solutions Framework VolumeFromMetricCups Method
Creates a new Volume value from the specified value in metric cups.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromMetricCups(
    double value
)
Public Shared Function FromMetricCups (
    value As Double
) As Volume
static member FromMetricCups :
        value : float -> Volume

GSF.Units.Volume.FromMetricCups = function(value);
public:
static Volume FromMetricCups(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in metric cups.

Return Value

Type: Volume
New Volume object from the specified value in metric cups.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromMetricTablespoons Method

Grid Solutions Framework VolumeFromMetricTablespoons Method
Creates a new Volume value from the specified value in metric tablespoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromMetricTablespoons(
    double value
)
Public Shared Function FromMetricTablespoons (
    value As Double
) As Volume
static member FromMetricTablespoons :
        value : float -> Volume

GSF.Units.Volume.FromMetricTablespoons = function(value);
public:
static Volume FromMetricTablespoons(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in metric tablespoons.

Return Value

Type: Volume
New Volume object from the specified value in metric tablespoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromMetricTeaspoons Method

Grid Solutions Framework VolumeFromMetricTeaspoons Method
Creates a new Volume value from the specified value in metric teaspoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromMetricTeaspoons(
    double value
)
Public Shared Function FromMetricTeaspoons (
    value As Double
) As Volume
static member FromMetricTeaspoons :
        value : float -> Volume

GSF.Units.Volume.FromMetricTeaspoons = function(value);
public:
static Volume FromMetricTeaspoons(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in metric teaspoons.

Return Value

Type: Volume
New Volume object from the specified value in metric teaspoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromPints Method

Grid Solutions Framework VolumeFromPints Method
Creates a new Volume value from the specified value in US fluid pints.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromPints(
    double value
)
Public Shared Function FromPints (
    value As Double
) As Volume
static member FromPints :
        value : float -> Volume

GSF.Units.Volume.FromPints = function(value);
public:
static Volume FromPints(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in US fluid pints.

Return Value

Type: Volume
New Volume object from the specified value in US fluid pints.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromQuarts Method

Grid Solutions Framework VolumeFromQuarts Method
Creates a new Volume value from the specified value in US fluid quarts.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromQuarts(
    double value
)
Public Shared Function FromQuarts (
    value As Double
) As Volume
static member FromQuarts :
        value : float -> Volume

GSF.Units.Volume.FromQuarts = function(value);
public:
static Volume FromQuarts(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in US fluid quarts.

Return Value

Type: Volume
New Volume object from the specified value in US fluid quarts.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromTablespoons Method

Grid Solutions Framework VolumeFromTablespoons Method
Creates a new Volume value from the specified value in US tablespoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromTablespoons(
    double value
)
Public Shared Function FromTablespoons (
    value As Double
) As Volume
static member FromTablespoons :
        value : float -> Volume

GSF.Units.Volume.FromTablespoons = function(value);
public:
static Volume FromTablespoons(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in US tablespoons.

Return Value

Type: Volume
New Volume object from the specified value in US tablespoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.FromTeaspoons Method

Grid Solutions Framework VolumeFromTeaspoons Method
Creates a new Volume value from the specified value in US teaspoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume FromTeaspoons(
    double value
)
Public Shared Function FromTeaspoons (
    value As Double
) As Volume
static member FromTeaspoons :
        value : float -> Volume

GSF.Units.Volume.FromTeaspoons = function(value);
public:
static Volume FromTeaspoons(
    double value
)

Parameters

value
Type: SystemDouble
New Volume value in US teaspoons.

Return Value

Type: Volume
New Volume object from the specified value in US teaspoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.GetHashCode Method

Grid Solutions Framework VolumeGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.GetTypeCode Method

Grid Solutions Framework VolumeGetTypeCode Method
Returns the TypeCode for value type Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public TypeCode GetTypeCode()
Public Function GetTypeCode As TypeCode
abstract GetTypeCode : unit -> TypeCode
override GetTypeCode : unit -> TypeCode
function GetTypeCode();
public:
virtual TypeCode GetTypeCode() sealed

Return Value

Type: TypeCode
The enumerated constant, Double.

Implements

IConvertibleGetTypeCode
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Parse Method

Grid Solutions Framework VolumeParse Method
Overload List
Name | Description
Parse(String) | Converts the string representation of a number to its Volume equivalent.
Parse(String, NumberStyles) | Converts the string representation of a number in a specified style to its Volume equivalent.
Parse(String, IFormatProvider) | Converts the string representation of a number in a specified culture-specific format to its Volume equivalent.
Parse(String, NumberStyles, IFormatProvider) | Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Parse Method (String)

Grid Solutions Framework VolumeParse Method (String)
Converts the string representation of a number to its Volume equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume Parse(
    string s
)
Public Shared Function Parse (
    s As String
) As Volume
static member Parse :
        s : string -> Volume

GSF.Units.Volume.Parse = function(s);
public:
static Volume Parse(
    String^ s
)

Parameters

s
Type: SystemString
A string containing a number to convert.

Return Value

Type: Volume
A Volume equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Volume Structure
Parse Overload
GSF.Units Namespace


Volume.Parse Method (String, NumberStyles)

Grid Solutions Framework VolumeParse Method (String, NumberStyles)
Converts the string representation of a number in a specified style to its Volume equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume Parse(
    string s,
    NumberStyles style
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles
) As Volume
static member Parse :
        s : string *
        style : NumberStyles -> Volume

GSF.Units.Volume.Parse = function(s, style);
public:
static Volume Parse(
    String^ s,
    NumberStyles style
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.

Return Value

Type: Volume
A Volume equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Volume Structure
Parse Overload
GSF.Units Namespace


Volume.Parse Method (String, IFormatProvider)

Grid Solutions Framework VolumeParse Method (String, IFormatProvider)
Converts the string representation of a number in a specified culture-specific format to its Volume equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume Parse(
    string s,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    provider As IFormatProvider
) As Volume
static member Parse :
        s : string *
        provider : IFormatProvider -> Volume

GSF.Units.Volume.Parse = function(s, provider);
public:
static Volume Parse(
    String^ s,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Volume
A Volume equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in the correct format.
See Also

Reference

Volume Structure
Parse Overload
GSF.Units Namespace


Volume.Parse Method (String, NumberStyles, IFormatProvider)

Grid Solutions Framework VolumeParse Method (String, NumberStyles, IFormatProvider)
Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume Parse(
    string s,
    NumberStyles style,
    IFormatProvider provider
)
Public Shared Function Parse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider
) As Volume
static member Parse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider -> Volume

GSF.Units.Volume.Parse = function(s, style, provider);
public:
static Volume Parse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information about s.

Return Value

Type: Volume
A Volume equivalent to the number contained in s.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
ArgumentNullException | s is null.
OverflowException | s represents a number less than MinValue or greater than MaxValue.
FormatException | s is not in a format compliant with style.
See Also

Reference

Volume Structure
Parse Overload
GSF.Units Namespace


Volume.ToCubicFeet Method

Grid Solutions Framework VolumeToCubicFeet Method
Gets the Volume value in cubic feet.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToCubicFeet()
Public Function ToCubicFeet As Double
member ToCubicFeet : unit -> float

function ToCubicFeet();
public:
double ToCubicFeet()

Return Value

Type: Double
Value of Volume in cubic feet.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToCubicInches Method

Grid Solutions Framework VolumeToCubicInches Method
Gets the Volume value in cubic inches.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToCubicInches()
Public Function ToCubicInches As Double
member ToCubicInches : unit -> float

function ToCubicInches();
public:
double ToCubicInches()

Return Value

Type: Double
Value of Volume in cubic inches.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToCups Method

Grid Solutions Framework VolumeToCups Method
Gets the Volume value in US cups.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToCups()
Public Function ToCups As Double
member ToCups : unit -> float

function ToCups();
public:
double ToCups()

Return Value

Type: Double
Value of Volume in US cups.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToFluidOunces Method

Grid Solutions Framework VolumeToFluidOunces Method
Gets the Volume value in US fluid ounces.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToFluidOunces()
Public Function ToFluidOunces As Double
member ToFluidOunces : unit -> float

function ToFluidOunces();
public:
double ToFluidOunces()

Return Value

Type: Double
Value of Volume in US fluid ounces.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToGallons Method

Grid Solutions Framework VolumeToGallons Method
Gets the Volume value in US fluid gallons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToGallons()
Public Function ToGallons As Double
member ToGallons : unit -> float

function ToGallons();
public:
double ToGallons()

Return Value

Type: Double
Value of Volume in US fluid gallons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToLiters Method

Grid Solutions Framework VolumeToLiters Method
Gets the Volume value in liters.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToLiters()
Public Function ToLiters As Double
member ToLiters : unit -> float

function ToLiters();
public:
double ToLiters()

Return Value

Type: Double
Value of Volume in liters.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToMetricCups Method

Grid Solutions Framework VolumeToMetricCups Method
Gets the Volume value in metric cups.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMetricCups()
Public Function ToMetricCups As Double
member ToMetricCups : unit -> float

function ToMetricCups();
public:
double ToMetricCups()

Return Value

Type: Double
Value of Volume in metric cups.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToMetricTablespoons Method

Grid Solutions Framework VolumeToMetricTablespoons Method
Gets the Volume value in metric tablespoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMetricTablespoons()
Public Function ToMetricTablespoons As Double
member ToMetricTablespoons : unit -> float

function ToMetricTablespoons();
public:
double ToMetricTablespoons()

Return Value

Type: Double
Value of Volume in metric tablespoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToMetricTeaspoons Method

Grid Solutions Framework VolumeToMetricTeaspoons Method
Gets the Volume value in metric teaspoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToMetricTeaspoons()
Public Function ToMetricTeaspoons As Double
member ToMetricTeaspoons : unit -> float

function ToMetricTeaspoons();
public:
double ToMetricTeaspoons()

Return Value

Type: Double
Value of Volume in metric teaspoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToPints Method

Grid Solutions Framework VolumeToPints Method
Gets the Volume value in US fluid pints.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToPints()
Public Function ToPints As Double
member ToPints : unit -> float

function ToPints();
public:
double ToPints()

Return Value

Type: Double
Value of Volume in US fluid pints.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToQuarts Method

Grid Solutions Framework VolumeToQuarts Method
Gets the Volume value in US fluid quarts.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToQuarts()
Public Function ToQuarts As Double
member ToQuarts : unit -> float

function ToQuarts();
public:
double ToQuarts()

Return Value

Type: Double
Value of Volume in US fluid quarts.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToString Method

Grid Solutions Framework VolumeToString Method
Overload List
 | Name | Description
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Public method | ToString(IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.
Public method | ToString(String) | Converts the numeric value of this instance to its equivalent string representation, using the specified format.
Public method | ToString(String, IFormatProvider) | Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToString Method

Grid Solutions Framework VolumeToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this instance, consisting of a minus sign if the value is negative, and a sequence of digits ranging from 0 to 9 with no leading zeroes.
See Also

Reference

Volume Structure
ToString Overload
GSF.Units Namespace


Volume.ToString Method (IFormatProvider)

Grid Solutions Framework VolumeToString Method (IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    IFormatProvider provider
)
Public Function ToString (
    provider As IFormatProvider
) As String
abstract ToString :
        provider : IFormatProvider -> string
override ToString :
        provider : IFormatProvider -> string
function ToString(provider);
public:
virtual String^ ToString(
    IFormatProvider^ provider
) sealed

Parameters

provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by provider.

Implements

IConvertibleToString(IFormatProvider)
See Also

Reference

Volume Structure
ToString Overload
GSF.Units Namespace


Volume.ToString Method (String)

Grid Solutions Framework VolumeToString Method (String)
Converts the numeric value of this instance to its equivalent string representation, using the specified format.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format
)
Public Function ToString (
    format As String
) As String
member ToString :
        format : string -> string

function ToString(format);
public:
String^ ToString(
    String^ format
)

Parameters

format
Type: SystemString
A format string.

Return Value

Type: String
The string representation of the value of this instance as specified by format.
See Also

Reference

Volume Structure
ToString Overload
GSF.Units Namespace


Volume.ToString Method (String, IFormatProvider)

Grid Solutions Framework VolumeToString Method (String, IFormatProvider)
Converts the numeric value of this instance to its equivalent string representation using the specified format and culture-specific format information.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ToString(
    string format,
    IFormatProvider provider
)
Public Function ToString (
    format As String,
    provider As IFormatProvider
) As String
abstract ToString :
        format : string *
        provider : IFormatProvider -> string
override ToString :
        format : string *
        provider : IFormatProvider -> string
function ToString(format, provider);
public:
virtual String^ ToString(
    String^ format,
    IFormatProvider^ provider
) sealed

Parameters

format
Type: SystemString
A format specification.
provider
Type: SystemIFormatProvider
A IFormatProvider that supplies culture-specific formatting information.

Return Value

Type: String
The string representation of the value of this instance as specified by format and provider.

Implements

IFormattableToString(String, IFormatProvider)
See Also

Reference

Volume Structure
ToString Overload
GSF.Units Namespace


Volume.ToTablespoons Method

Grid Solutions Framework VolumeToTablespoons Method
Gets the Volume value in US tablespoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToTablespoons()
Public Function ToTablespoons As Double
member ToTablespoons : unit -> float

function ToTablespoons();
public:
double ToTablespoons()

Return Value

Type: Double
Value of Volume in US tablespoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.ToTeaspoons Method

Grid Solutions Framework VolumeToTeaspoons Method
Gets the Volume value in US teaspoons.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public double ToTeaspoons()
Public Function ToTeaspoons As Double
member ToTeaspoons : unit -> float

function ToTeaspoons();
public:
double ToTeaspoons()

Return Value

Type: Double
Value of Volume in US teaspoons.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.TryParse Method

Grid Solutions Framework VolumeTryParse Method
Overload List
Name | Description
TryParse(String, Volume) | Converts the string representation of a number to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.
TryParse(String, NumberStyles, IFormatProvider, Volume) | Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.TryParse Method (String, Volume)

Grid Solutions Framework VolumeTryParse Method (String, Volume)
Converts the string representation of a number to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    out Volume result
)
Public Shared Function TryParse (
    s As String,
    <OutAttribute> ByRef result As Volume
) As Boolean
static member TryParse :
        s : string *
        result : Volume byref -> bool

GSF.Units.Volume.TryParse = function(s, result);
public:
static bool TryParse(
    String^ s,
    [OutAttribute] Volume% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
result
Type: GSF.UnitsVolume
When this method returns, contains the Volume value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paraampere is null, is not of the correct format, or represents a number less than MinValue or greater than MaxValue. This paraampere is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
See Also

Reference

Volume Structure
TryParse Overload
GSF.Units Namespace


Volume.TryParse Method (String, NumberStyles, IFormatProvider, Volume)

Grid Solutions Framework VolumeTryParse Method (String, NumberStyles, IFormatProvider, Volume)
Converts the string representation of a number in a specified style and culture-specific format to its Volume equivalent. A return value indicates whether the conversion succeeded or failed.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool TryParse(
    string s,
    NumberStyles style,
    IFormatProvider provider,
    out Volume result
)
Public Shared Function TryParse (
    s As String,
    style As NumberStyles,
    provider As IFormatProvider,
    <OutAttribute> ByRef result As Volume
) As Boolean
static member TryParse :
        s : string *
        style : NumberStyles *
        provider : IFormatProvider *
        result : Volume byref -> bool

GSF.Units.Volume.TryParse = function(s, style, provider, result);
public:
static bool TryParse(
    String^ s,
    NumberStyles style,
    IFormatProvider^ provider,
    [OutAttribute] Volume% result
)

Parameters

s
Type: SystemString
A string containing a number to convert.
style
Type: System.GlobalizationNumberStyles
A bitwise combination of System.Globalization.NumberStyles values that indicates the permitted format of s.
provider
Type: SystemIFormatProvider
A IFormatProvider object that supplies culture-specific formatting information about s.
result
Type: GSF.UnitsVolume
When this method returns, contains the Volume value equivalent to the number contained in s, if the conversion succeeded, or zero if the conversion failed. The conversion fails if the s paraampere is null, is not in a format compliant with style, or represents a number less than MinValue or greater than MaxValue. This paraampere is passed uninitialized.

Return Value

Type: Boolean
true if s was converted successfully; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | style is not a System.Globalization.NumberStyles value. -or- style is not a combination of System.Globalization.NumberStyles.AllowHexSpecifier and System.Globalization.NumberStyles.HexNumber values.
See Also

Reference

Volume Structure
TryParse Overload
GSF.Units Namespace


Volume Operators and Type Conversions

Grid Solutions Framework Volume Operators and Type Conversions

The Volume type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to volume of second value.
GreaterThan | Returns true if left value is greater than right value.
GreaterThanOrEqual | Returns true if left value is greater than or equal to right value.
(Double to Volume) | Implicitly converts value, represented in cubic meters, to a Volume.
(Volume to Double) | Implicitly converts Volume, represented in cubic meters, to a Double.
Inequality | Compares the two values for inequality.
LessThan | Returns true if left value is less than right value.
LessThanOrEqual | Returns true if left value is less or equal to than right value.
Modulus | Returns computed remainder after dividing first value by the second.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Addition Operator

Grid Solutions Framework VolumeAddition Operator
Returns computed sum of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume operator +(
    Volume value1,
    Volume value2
)
Public Shared Operator + (
    value1 As Volume,
    value2 As Volume
) As Volume
static let inline (+)
        value1 : Volume *
        value2 : Volume  : Volume
JavaScript does not support overloaded operators.
public:
static Volume operator +(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Volume
A Volume object as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Division Operator

Grid Solutions Framework VolumeDivision Operator
Returns computed division of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume operator /(
    Volume value1,
    Volume value2
)
Public Shared Operator / (
    value1 As Volume,
    value2 As Volume
) As Volume
static let inline (/)
        value1 : Volume *
        value2 : Volume  : Volume
JavaScript does not support overloaded operators.
public:
static Volume operator /(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Volume
A Volume object as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Equality Operator

Grid Solutions Framework VolumeEquality Operator
Compares the two values for equality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Volume value1,
    Volume value2
)
Public Shared Operator = (
    value1 As Volume,
    value2 As Volume
) As Boolean
static let inline (=)
        value1 : Volume *
        value2 : Volume  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Exponent Operator

Grid Solutions Framework VolumeExponent Operator
Returns result of first value raised to volume of second value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    value1 As Volume,
    value2 As Volume
) As Double
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Double
A Double value as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.GreaterThan Operator

Grid Solutions Framework VolumeGreaterThan Operator
Returns true if left value is greater than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    Volume value1,
    Volume value2
)
Public Shared Operator > (
    value1 As Volume,
    value2 As Volume
) As Boolean
static let inline (>)
        value1 : Volume *
        value2 : Volume  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.GreaterThanOrEqual Operator

Grid Solutions Framework VolumeGreaterThanOrEqual Operator
Returns true if left value is greater than or equal to right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    Volume value1,
    Volume value2
)
Public Shared Operator >= (
    value1 As Volume,
    value2 As Volume
) As Boolean
static let inline (>=)
        value1 : Volume *
        value2 : Volume  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume Implicit Conversion Operators

Grid Solutions Framework Volume Conversion Operators
Overload List
Name | Description
(Double to Volume) | Implicitly converts value, represented in cubic meters, to a Volume.
(Volume to Double) | Implicitly converts Volume, represented in cubic meters, to a Double.
Top
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume Implicit Conversion (Double to Volume)

Grid Solutions Framework Volume Conversion (Double to Volume)
Implicitly converts value, represented in cubic meters, to a Volume.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator Volume (
    double value
)
Public Shared Widening Operator CType (
    value As Double
) As Volume
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator Volume (
    double value
)

Parameters

value
Type: SystemDouble
A Double value.

Return Value

Type: Volume
A Volume object.
See Also

Reference

Volume Structure
Overload
GSF.Units Namespace


Volume Implicit Conversion (Volume to Double)

Grid Solutions Framework Volume Conversion (Volume to Double)
Implicitly converts Volume, represented in cubic meters, to a Double.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator double (
    Volume value
)
Public Shared Widening Operator CType (
    value As Volume
) As Double
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator double (
    Volume value
)

Parameters

value
Type: GSF.UnitsVolume
A Volume object.

Return Value

Type: Double
A Double value.
See Also

Reference

Volume Structure
Overload
GSF.Units Namespace


Volume.Inequality Operator

Grid Solutions Framework VolumeInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Volume value1,
    Volume value2
)
Public Shared Operator <> (
    value1 As Volume,
    value2 As Volume
) As Boolean
static let inline (<>)
        value1 : Volume *
        value2 : Volume  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.LessThan Operator

Grid Solutions Framework VolumeLessThan Operator
Returns true if left value is less than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    Volume value1,
    Volume value2
)
Public Shared Operator < (
    value1 As Volume,
    value2 As Volume
) As Boolean
static let inline (<)
        value1 : Volume *
        value2 : Volume  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.LessThanOrEqual Operator

Grid Solutions Framework VolumeLessThanOrEqual Operator
Returns true if left value is less or equal to than right value.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    Volume value1,
    Volume value2
)
Public Shared Operator <= (
    value1 As Volume,
    value2 As Volume
) As Boolean
static let inline (<=)
        value1 : Volume *
        value2 : Volume  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Boolean
A Boolean value as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Modulus Operator

Grid Solutions Framework VolumeModulus Operator
Returns computed remainder after dividing first value by the second.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume operator %(
    Volume value1,
    Volume value2
)
Public Shared Operator Mod (
    value1 As Volume,
    value2 As Volume
) As Volume
static let inline (%)
        value1 : Volume *
        value2 : Volume  : Volume
JavaScript does not support overloaded operators.
public:
static Volume operator %(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Volume
A Volume object as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Multiply Operator

Grid Solutions Framework VolumeMultiply Operator
Returns computed product of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume operator *(
    Volume value1,
    Volume value2
)
Public Shared Operator * (
    value1 As Volume,
    value2 As Volume
) As Volume
static let inline (*)
        value1 : Volume *
        value2 : Volume  : Volume
JavaScript does not support overloaded operators.
public:
static Volume operator *(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Volume
A Volume object as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


Volume.Subtraction Operator

Grid Solutions Framework VolumeSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Volume operator -(
    Volume value1,
    Volume value2
)
Public Shared Operator - (
    value1 As Volume,
    value2 As Volume
) As Volume
static let inline (-)
        value1 : Volume *
        value2 : Volume  : Volume
JavaScript does not support overloaded operators.
public:
static Volume operator -(
    Volume value1,
    Volume value2
)

Parameters

value1
Type: GSF.UnitsVolume
A Volume object as the left hand operand.
value2
Type: GSF.UnitsVolume
A Volume object as the right hand operand.

Return Value

Type: Volume
A Volume object as the result.
See Also

Reference

Volume Structure
GSF.Units Namespace


GSF.Units.EE Namespace

Grid Solutions Framework GSF.Units.EE Namespace
Contains classes that represent standard Electrical Engineering units and types.
Classes
 | Class | Description
Public class | SignalKindExtensions | Defines extension functions for the SignalKind enumeration.
Public class | SignalTypeExtensions | Defines extension functions for the SignalType enumeration.
Structures
 | Structure | Description
Public structure | Phasor | Represents a phasor as a complex number value and a type (i.e., a voltage or a current).
Public structure | SignalReference | Represents a signal that can be referenced by its constituent components.
Enumerations
 | Enumeration | Description
Public enumeration | LineFrequency | Nominal line frequencies enumeration.
Public enumeration | PhasorType | Phasor types enumeration.
Public enumeration | SignalKind | Fundamental signal type enumeration for common EE measurements that represents a kind of signal, not an explicit type.
Public enumeration | SignalType | Fundamental signal type enumeration for common EE measurements that represents an explicit type of signal.


LineFrequency Enumeration

Grid Solutions Framework LineFrequency Enumeration
Nominal line frequencies enumeration.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum LineFrequency
<SerializableAttribute>
Public Enumeration LineFrequency
[<SerializableAttribute>]
type LineFrequency
GSF.Units.EE.LineFrequency = function();
GSF.Units.EE.LineFrequency.createEnum('GSF.Units.EE.LineFrequency', false);
[SerializableAttribute]
public enum class LineFrequency
Members
Member name | Value | Description
Hz50 | 50 | 50Hz nominal frequency.
Hz60 | 60 | 60Hz nominal frequency.
See Also

Reference

GSF.Units.EE Namespace


Phasor Structure

Grid Solutions Framework Phasor Structure
Represents a phasor as a complex number value and a type (i.e., a voltage or a current).

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct Phasor : IEquatable<Phasor>
Public Structure Phasor
    Implements IEquatable(Of Phasor)
[<SealedAttribute>]
type Phasor =
    struct
        interface IEquatable<Phasor>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class Phasor : IEquatable<Phasor>

The Phasor type exposes the following members.

Constructors
 | Name | Description
Public method | Phasor(PhasorType, ComplexNumber) | Creates a Phasor of the specified type from the given ComplexNumber.
Public method | Phasor(PhasorType, Angle, Double) | Creates a Phasor of the specified type from the given polar values.
Public method | Phasor(PhasorType, Double, Double) | Creates a Phasor of the specified type from the given rectangular values.
Top
Methods
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Phasor) | Returns a value indicating whether this instance is equal to a specified Phasor value.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Pow | Returns specified Phasor raised to the specified power.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Top
Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
(Phasor to ComplexNumber) | Implicitly converts a Phasor to a ComplexNumber.
Inequality | Compares the two values for inequality.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
UnaryNegation | Returns the negated value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Type | Phasor type.
Public field | Value | Phasor value.
Top
See Also

Reference

GSF.Units.EE Namespace


Phasor Constructor

Grid Solutions Framework Phasor Constructor
Overload List
 | Name | Description
Public method | Phasor(PhasorType, ComplexNumber) | Creates a Phasor of the specified type from the given ComplexNumber.
Public method | Phasor(PhasorType, Angle, Double) | Creates a Phasor of the specified type from the given polar values.
Public method | Phasor(PhasorType, Double, Double) | Creates a Phasor of the specified type from the given rectangular values.
Top
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor Constructor (PhasorType, ComplexNumber)

Grid Solutions Framework Phasor Constructor (PhasorType, ComplexNumber)
Creates a Phasor of the specified type from the given ComplexNumber.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Phasor(
    PhasorType type,
    ComplexNumber z
)
Public Sub New (
    type As PhasorType,
    z As ComplexNumber
)
new :
        type : PhasorType *
        z : ComplexNumber -> Phasor
GSF.Units.EE.Phasor = function(type, z);
public:
Phasor(
    PhasorType type,
    ComplexNumber z
)

Parameters

type
Type: GSF.Units.EEPhasorType
Type of phasor, i.e., current or voltage.
z
Type: GSFComplexNumber
ComplexNumber to be copied.
See Also

Reference

Phasor Structure
Phasor Overload
GSF.Units.EE Namespace


Phasor Constructor (PhasorType, Angle, Double)

Grid Solutions Framework Phasor Constructor (PhasorType, Angle, Double)
Creates a Phasor of the specified type from the given polar values.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Phasor(
    PhasorType type,
    Angle angle,
    double magnitude
)
Public Sub New (
    type As PhasorType,
    angle As Angle,
    magnitude As Double
)
new :
        type : PhasorType *
        angle : Angle *
        magnitude : float -> Phasor
GSF.Units.EE.Phasor = function(type, angle, magnitude);
public:
Phasor(
    PhasorType type,
    Angle angle,
    double magnitude
)

Parameters

type
Type: GSF.Units.EEPhasorType
Type of phasor, i.e., current or voltage.
angle
Type: GSF.UnitsAngle
The Angle component, in radians, of the ComplexNumber.
magnitude
Type: SystemDouble
The magnitude (or absolute value) component of the ComplexNumber.
See Also

Reference

Phasor Structure
Phasor Overload
GSF.Units.EE Namespace


Phasor Constructor (PhasorType, Double, Double)

Grid Solutions Framework Phasor Constructor (PhasorType, Double, Double)
Creates a Phasor of the specified type from the given rectangular values.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Phasor(
    PhasorType type,
    double real,
    double imaginary
)
Public Sub New (
    type As PhasorType,
    real As Double,
    imaginary As Double
)
new :
        type : PhasorType *
        real : float *
        imaginary : float -> Phasor
GSF.Units.EE.Phasor = function(type, real, imaginary);
public:
Phasor(
    PhasorType type,
    double real,
    double imaginary
)

Parameters

type
Type: GSF.Units.EEPhasorType
Type of phasor, i.e., current or voltage.
real
Type: SystemDouble
The real component of the ComplexNumber.
imaginary
Type: SystemDouble
The imaginary component of the ComplexNumber.
See Also

Reference

Phasor Structure
Phasor Overload
GSF.Units.EE Namespace


Phasor Fields

Grid Solutions Framework Phasor Fields

The Phasor type exposes the following members.

Fields
 | Name | Description
Public field | Type | Phasor type.
Public field | Value | Phasor value.
Top
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Type Field

Grid Solutions Framework PhasorType Field
Phasor type.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public PhasorType Type
Public Type As PhasorType
val mutable Type: PhasorType
var Type
public:
PhasorType Type

Field Value

Type: PhasorType
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Value Field

Grid Solutions Framework PhasorValue Field
Phasor value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ComplexNumber Value
Public Value As ComplexNumber
val mutable Value: ComplexNumber
var Value
public:
ComplexNumber Value

Field Value

Type: ComplexNumber
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor Methods

Grid Solutions Framework Phasor Methods

The Phasor type exposes the following members.

Methods
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Phasor) | Returns a value indicating whether this instance is equal to a specified Phasor value.
Public method | GetHashCode | Returns the hash code for this instance. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
 | Pow | Returns specified Phasor raised to the specified power.
Public method | ToString | Converts the numeric value of this instance to its equivalent string representation. (Overrides ValueTypeToString.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Equals Method

Grid Solutions Framework PhasorEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Returns a value indicating whether this instance is equal to a specified object. (Overrides ValueTypeEquals(Object).)
Public method | Equals(Phasor) | Returns a value indicating whether this instance is equal to a specified Phasor value.
Top
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Equals Method (Object)

Grid Solutions Framework PhasorEquals Method (Object)
Returns a value indicating whether this instance is equal to a specified object.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare, or null.

Return Value

Type: Boolean
True if obj is an instance of Phasor and equals the value of this instance; otherwise, False.
See Also

Reference

Phasor Structure
Equals Overload
GSF.Units.EE Namespace


Phasor.Equals Method (Phasor)

Grid Solutions Framework PhasorEquals Method (Phasor)
Returns a value indicating whether this instance is equal to a specified Phasor value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    Phasor obj
)
Public Function Equals (
    obj As Phasor
) As Boolean
abstract Equals :
        obj : Phasor -> bool
override Equals :
        obj : Phasor -> bool
function Equals(obj);
public:
virtual bool Equals(
    Phasor obj
) sealed

Parameters

obj
Type: GSF.Units.EEPhasor
A Phasor to compare to this instance.

Return Value

Type: Boolean
True if obj has the same value as this instance; otherwise, False.

Implements

IEquatableTEquals(T)
See Also

Reference

Phasor Structure
Equals Overload
GSF.Units.EE Namespace


Phasor.GetHashCode Method

Grid Solutions Framework PhasorGetHashCode Method
Returns the hash code for this instance.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Pow Method

Grid Solutions Framework PhasorPow Method
Returns specified Phasor raised to the specified power.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Phasor Pow(
    Phasor z,
    double y
)
Public Shared Function Pow (
    z As Phasor,
    y As Double
) As Phasor
static member Pow :
        z : Phasor *
        y : float -> Phasor

GSF.Units.EE.Phasor.Pow = function(z, y);
public:
static Phasor Pow(
    Phasor z,
    double y
)

Parameters

z
Type: GSF.Units.EEPhasor
Phasor to be raised to power y.
y
Type: SystemDouble
Power to raise Phasor z.

Return Value

Type: Phasor
Phasor representing the result of the operation.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.ToString Method

Grid Solutions Framework PhasorToString Method
Converts the numeric value of this instance to its equivalent string representation.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
The string representation of the value of this ComplexNumber instance.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor Operators and Type Conversions

Grid Solutions Framework Phasor Operators and Type Conversions

The Phasor type exposes the following members.

Operators
Name | Description
Addition | Returns computed sum of values.
Division | Returns computed division of values.
Equality | Compares the two values for equality.
Exponent | Returns result of first value raised to power of second value.
(Phasor to ComplexNumber) | Implicitly converts a Phasor to a ComplexNumber.
Inequality | Compares the two values for inequality.
Multiply | Returns computed product of values.
Subtraction | Returns computed difference of values.
UnaryNegation | Returns the negated value.
Top
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Addition Operator

Grid Solutions Framework PhasorAddition Operator
Returns computed sum of values.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Phasor operator +(
    Phasor phasor1,
    Phasor phasor2
)
Public Shared Operator + (
    phasor1 As Phasor,
    phasor2 As Phasor
) As Phasor
static let inline (+)
        phasor1 : Phasor *
        phasor2 : Phasor  : Phasor
JavaScript does not support overloaded operators.
public:
static Phasor operator +(
    Phasor phasor1,
    Phasor phasor2
)

Parameters

phasor1
Type: GSF.Units.EEPhasor
Left hand operand.
phasor2
Type: GSF.Units.EEPhasor
Right hand operand.

Return Value

Type: Phasor
ComplexNumber representing the result of the addition operation.
Remarks
Resultant phasor will have Type of left hand operand, phasor1.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Division Operator

Grid Solutions Framework PhasorDivision Operator
Returns computed division of values.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Phasor operator /(
    Phasor phasor1,
    Phasor phasor2
)
Public Shared Operator / (
    phasor1 As Phasor,
    phasor2 As Phasor
) As Phasor
static let inline (/)
        phasor1 : Phasor *
        phasor2 : Phasor  : Phasor
JavaScript does not support overloaded operators.
public:
static Phasor operator /(
    Phasor phasor1,
    Phasor phasor2
)

Parameters

phasor1
Type: GSF.Units.EEPhasor
Left hand operand.
phasor2
Type: GSF.Units.EEPhasor
Right hand operand.

Return Value

Type: Phasor
ComplexNumber representing the result of the division operation.
Remarks
Resultant phasor will have Type of left hand operand, phasor1.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Equality Operator

Grid Solutions Framework PhasorEquality Operator
Compares the two values for equality.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    Phasor phasor1,
    Phasor phasor2
)
Public Shared Operator = (
    phasor1 As Phasor,
    phasor2 As Phasor
) As Boolean
static let inline (=)
        phasor1 : Phasor *
        phasor2 : Phasor  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    Phasor phasor1,
    Phasor phasor2
)

Parameters

phasor1
Type: GSF.Units.EEPhasor
Left hand operand.
phasor2
Type: GSF.Units.EEPhasor
Right hand operand.

Return Value

Type: Boolean
Boolean representing the result of the addition operation.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Exponent Operator

Grid Solutions Framework PhasorExponent Operator
Returns result of first value raised to power of second value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
C# does not support this operator.
Public Shared Operator ^ (
    z As Phasor,
    y As Double
) As Phasor
F# does not support this operator.
JavaScript does not support overloaded operators.
Visual C++ does not support this operator.

Parameters

z
Type: GSF.Units.EEPhasor
Phasor to be raised to power y.
y
Type: SystemDouble
Power to raise Phasor z.

Return Value

Type: Phasor
Phasor representing the result of the operation.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor Implicit Conversion (Phasor to ComplexNumber)

Grid Solutions Framework Phasor Conversion (Phasor to ComplexNumber)
Implicitly converts a Phasor to a ComplexNumber.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static implicit operator ComplexNumber (
    Phasor phasor
)
Public Shared Widening Operator CType (
    phasor As Phasor
) As ComplexNumber
F# does not support the declaration of new casting operators.
JavaScript does not support the declaration of new casting operators.
static implicit operator ComplexNumber (
    Phasor phasor
)

Parameters

phasor
Type: GSF.Units.EEPhasor
Operand.

Return Value

Type: ComplexNumber
ComplexNumber representing the result of the operation.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Inequality Operator

Grid Solutions Framework PhasorInequality Operator
Compares the two values for inequality.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    Phasor phasor1,
    Phasor phasor2
)
Public Shared Operator <> (
    phasor1 As Phasor,
    phasor2 As Phasor
) As Boolean
static let inline (<>)
        phasor1 : Phasor *
        phasor2 : Phasor  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    Phasor phasor1,
    Phasor phasor2
)

Parameters

phasor1
Type: GSF.Units.EEPhasor
Left hand operand.
phasor2
Type: GSF.Units.EEPhasor
Right hand operand.

Return Value

Type: Boolean
Boolean representing the result of the inequality operation.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Multiply Operator

Grid Solutions Framework PhasorMultiply Operator
Returns computed product of values.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Phasor operator *(
    Phasor phasor1,
    Phasor phasor2
)
Public Shared Operator * (
    phasor1 As Phasor,
    phasor2 As Phasor
) As Phasor
static let inline (*)
        phasor1 : Phasor *
        phasor2 : Phasor  : Phasor
JavaScript does not support overloaded operators.
public:
static Phasor operator *(
    Phasor phasor1,
    Phasor phasor2
)

Parameters

phasor1
Type: GSF.Units.EEPhasor
Left hand operand.
phasor2
Type: GSF.Units.EEPhasor
Right hand operand.

Return Value

Type: Phasor
ComplexNumber representing the result of the multiplication operation.
Remarks
Resultant phasor will have Type of left hand operand, phasor1.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.Subtraction Operator

Grid Solutions Framework PhasorSubtraction Operator
Returns computed difference of values.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Phasor operator -(
    Phasor phasor1,
    Phasor phasor2
)
Public Shared Operator - (
    phasor1 As Phasor,
    phasor2 As Phasor
) As Phasor
static let inline (-)
        phasor1 : Phasor *
        phasor2 : Phasor  : Phasor
JavaScript does not support overloaded operators.
public:
static Phasor operator -(
    Phasor phasor1,
    Phasor phasor2
)

Parameters

phasor1
Type: GSF.Units.EEPhasor
Left hand operand.
phasor2
Type: GSF.Units.EEPhasor
Right hand operand.

Return Value

Type: Phasor
ComplexNumber representing the result of the subtraction operation.
Remarks
Resultant phasor will have Type of left hand operand, phasor1.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


Phasor.UnaryNegation Operator

Grid Solutions Framework PhasorUnaryNegation Operator
Returns the negated value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Phasor operator -(
    Phasor z
)
Public Shared Operator - (
    z As Phasor
) As Phasor
static let inline (-)
        z : Phasor  : Phasor
JavaScript does not support overloaded operators.
public:
static Phasor operator -(
    Phasor z
)

Parameters

z
Type: GSF.Units.EEPhasor
Left hand operand.

Return Value

Type: Phasor
Phasor representing the result of the unary negation operation.
See Also

Reference

Phasor Structure
GSF.Units.EE Namespace


PhasorType Enumeration

Grid Solutions Framework PhasorType Enumeration
Phasor types enumeration.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum PhasorType
<SerializableAttribute>
Public Enumeration PhasorType
[<SerializableAttribute>]
type PhasorType
GSF.Units.EE.PhasorType = function();
GSF.Units.EE.PhasorType.createEnum('GSF.Units.EE.PhasorType', false);
[SerializableAttribute]
public enum class PhasorType
Members
Member name | Value | Description
Voltage | 0 | Voltage phasor.
Current | 1 | Current phasor.
See Also

Reference

GSF.Units.EE Namespace


SignalKind Enumeration

Grid Solutions Framework SignalKind Enumeration
Fundamental signal type enumeration for common EE measurements that represents a kind of signal, not an explicit type.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum SignalKind
<SerializableAttribute>
Public Enumeration SignalKind
[<SerializableAttribute>]
type SignalKind
GSF.Units.EE.SignalKind = function();
GSF.Units.EE.SignalKind.createEnum('GSF.Units.EE.SignalKind', false);
[SerializableAttribute]
public enum class SignalKind
Members
Member name | Value | Description
Angle | 0 | Phase angle.
Magnitude | 1 | Phase magnitude.
Frequency | 2 | Line frequency.
DfDt | 3 | Frequency delta over time (dF/dt).
Status | 4 | Status flags.
Digital | 5 | Digital value.
Analog | 6 | Analog value.
Calculation | 7 | Calculated value.
Statistic | 8 | Statistical value.
Alarm | 9 | Alarm value.
Quality | 10 | Quality flags.
Unknown | 11 | Undetermined signal type.
Remarks

This enumeration represents the basic type of a signal used to suffix a formatted signal reference. When used in context along with an optional index the fundamental signal type will identify a signal's location within a frame of data (see SignalReference).

Contrast this to the SignalType enumeration which further defines an explicit type for a signal (e.g., a voltage or current type for an angle).

See Also

Reference

GSF.Units.EE Namespace


SignalKindExtensions Class

Grid Solutions Framework SignalKindExtensions Class
Defines extension functions for the SignalKind enumeration.
Inheritance Hierarchy
SystemObject
GSF.Units.EESignalKindExtensions

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SignalKindExtensions
<ExtensionAttribute>
Public NotInheritable Class SignalKindExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SignalKindExtensions =  class end
GSF.Units.EE.SignalKindExtensions = function();

Type.createClass(
    'GSF.Units.EE.SignalKindExtensions');
[ExtensionAttribute]
public ref class SignalKindExtensions abstract sealed

The SignalKindExtensions type exposes the following members.

Methods
Name | Description
GetAcronym | Gets the acronym for the specified SignalKind.
ParseSignalKind | Gets the SignalKind for the specified acronym.
Top
See Also

Reference

GSF.Units.EE Namespace


SignalKindExtensions Methods

Grid Solutions Framework SignalKindExtensions Methods

The SignalKindExtensions type exposes the following members.

Methods
Name | Description
GetAcronym | Gets the acronym for the specified SignalKind.
ParseSignalKind | Gets the SignalKind for the specified acronym.
Top
See Also

Reference

SignalKindExtensions Class
GSF.Units.EE Namespace


SignalKindExtensions.GetAcronym Method

Grid Solutions Framework SignalKindExtensionsGetAcronym Method
Gets the acronym for the specified SignalKind.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetAcronym(
    this SignalKind signal
)
<ExtensionAttribute>
Public Shared Function GetAcronym (
    signal As SignalKind
) As String
static member GetAcronym :
        signal : SignalKind -> string

GSF.Units.EE.SignalKindExtensions.GetAcronym = function(signal);
public:
[ExtensionAttribute]
static String^ GetAcronym(
    SignalKind signal
)

Parameters

signal
Type: GSF.Units.EESignalKind
SignalKind to convert to an acronym.

Return Value

Type: String
The acronym for the specified SignalKind.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SignalKind. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SignalKindExtensions Class
GSF.Units.EE Namespace


SignalKindExtensions.ParseSignalKind Method

Grid Solutions Framework SignalKindExtensionsParseSignalKind Method
Gets the SignalKind for the specified acronym.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static SignalKind ParseSignalKind(
    this string acronym
)
<ExtensionAttribute>
Public Shared Function ParseSignalKind (
    acronym As String
) As SignalKind
static member ParseSignalKind :
        acronym : string -> SignalKind

GSF.Units.EE.SignalKindExtensions.ParseSignalKind = function(acronym);
public:
[ExtensionAttribute]
static SignalKind ParseSignalKind(
    String^ acronym
)

Parameters

acronym
Type: SystemString
Acronym of the desired SignalKind.

Return Value

Type: SignalKind
The SignalKind for the specified acronym.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SignalKindExtensions Class
GSF.Units.EE Namespace


SignalReference Structure

Grid Solutions Framework SignalReference Structure
Represents a signal that can be referenced by its constituent components.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public struct SignalReference : IEquatable<SignalReference>,
    IComparable<SignalReference>
Public Structure SignalReference
    Implements IEquatable(Of SignalReference), IComparable(Of SignalReference)
[<SealedAttribute>]
type SignalReference =
    struct
        interface IEquatable<SignalReference>
        interface IComparable<SignalReference>
    end
JavaScript supports the use of structures, but not the declaration of new ones.
public value class SignalReference : IEquatable<SignalReference>,
    IComparable<SignalReference>

The SignalReference type exposes the following members.

Constructors
 | Name | Description
Public method | SignalReference | Creates a new SignalReference.
Top
Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current object with another object of the same type.
Public method | CompareTo(SignalReference) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Indicates whether the current object is equal to another object of the same type. (Overrides ValueTypeEquals(Object).)
Public method | Equals(SignalReference) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns the hash code for this SignalReference. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current SignalReference. (Overrides ValueTypeToString.)
 | ToString(String, SignalKind) | Returns a String that represents the specified acronym and SignalKind.
 | ToString(String, SignalKind, Int32) | Returns a String that represents the specified acronym, SignalKind and index.
Top
Operators
Name | Description
Equality | Compares two SignalReference values for equality.
GreaterThan | Returns true if left SignalReference value is greater than right SignalReference value.
GreaterThanOrEqual | Returns true if left SignalReference value is greater than or equal to right SignalReference value.
Inequality | Compares two SignalReference values for inequality.
LessThan | Returns true if left SignalReference value is less than right SignalReference value.
LessThanOrEqual | Returns true if left SignalReference value is less than or equal to right SignalReference value.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
 | Name | Description
Public field | Acronym | Gets or sets the acronym of this SignalReference.
Public field | CellIndex | Gets or sets the cell index, if applicable, of this SignalReference.
Public field | Index | Gets or sets the signal index of this SignalReference.
Public field | Kind | Gets or sets the SignalKind of this SignalReference.
Top
See Also

Reference

GSF.Units.EE Namespace


SignalReference Constructor

Grid Solutions Framework SignalReference Constructor
Creates a new SignalReference.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SignalReference(
    string signal
)
Public Sub New (
    signal As String
)
new :
        signal : string -> SignalReference
GSF.Units.EE.SignalReference = function(signal);
public:
SignalReference(
    String^ signal
)

Parameters

signal
Type: SystemString
String representation of this SignalReference.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference Fields

Grid Solutions Framework SignalReference Fields

The SignalReference type exposes the following members.

Fields
 | Name | Description
Public field | Acronym | Gets or sets the acronym of this SignalReference.
Public field | CellIndex | Gets or sets the cell index, if applicable, of this SignalReference.
Public field | Index | Gets or sets the signal index of this SignalReference.
Public field | Kind | Gets or sets the SignalKind of this SignalReference.
Top
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.Acronym Field

Grid Solutions Framework SignalReferenceAcronym Field
Gets or sets the acronym of this SignalReference.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string Acronym
Public Acronym As String
val mutable Acronym: string
var Acronym
public:
String^ Acronym

Field Value

Type: String
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.CellIndex Field

Grid Solutions Framework SignalReferenceCellIndex Field
Gets or sets the cell index, if applicable, of this SignalReference.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CellIndex
Public CellIndex As Integer
val mutable CellIndex: int
var CellIndex
public:
int CellIndex

Field Value

Type: Int32
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.Index Field

Grid Solutions Framework SignalReferenceIndex Field
Gets or sets the signal index of this SignalReference.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int Index
Public Index As Integer
val mutable Index: int
var Index
public:
int Index

Field Value

Type: Int32
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.Kind Field

Grid Solutions Framework SignalReferenceKind Field
Gets or sets the SignalKind of this SignalReference.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SignalKind Kind
Public Kind As SignalKind
val mutable Kind: SignalKind
var Kind
public:
SignalKind Kind

Field Value

Type: SignalKind
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference Methods

Grid Solutions Framework SignalReference Methods

The SignalReference type exposes the following members.

Methods
 | Name | Description
Public method | CompareTo(Object) | Compares the current object with another object of the same type.
Public method | CompareTo(SignalReference) | Compares the current object with another object of the same type.
Public method | Equals(Object) | Indicates whether the current object is equal to another object of the same type. (Overrides ValueTypeEquals(Object).)
Public method | Equals(SignalReference) | Indicates whether the current object is equal to another object of the same type.
Public method | GetHashCode | Returns the hash code for this SignalReference. (Overrides ValueTypeGetHashCode.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | ToString | Returns a String that represents the current SignalReference. (Overrides ValueTypeToString.)
 | ToString(String, SignalKind) | Returns a String that represents the specified acronym and SignalKind.
 | ToString(String, SignalKind, Int32) | Returns a String that represents the specified acronym, SignalKind and index.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.CompareTo Method

Grid Solutions Framework SignalReferenceCompareTo Method
Overload List
 | Name | Description
Public method | CompareTo(Object) | Compares the current object with another object of the same type.
Public method | CompareTo(SignalReference) | Compares the current object with another object of the same type.
Top
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.CompareTo Method (Object)

Grid Solutions Framework SignalReferenceCompareTo Method (Object)
Compares the current object with another object of the same type.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    Object obj
)
Public Function CompareTo (
    obj As Object
) As Integer
member CompareTo :
        obj : Object -> int

function CompareTo(obj);
public:
int CompareTo(
    Object^ obj
)

Parameters

obj
Type: SystemObject
An object to compare with this SignalReference.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.
Exceptions
Exception | Condition
ArgumentException | Object is not a SignalReference.
See Also

Reference

SignalReference Structure
CompareTo Overload
GSF.Units.EE Namespace


SignalReference.CompareTo Method (SignalReference)

Grid Solutions Framework SignalReferenceCompareTo Method (SignalReference)
Compares the current object with another object of the same type.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public int CompareTo(
    SignalReference other
)
Public Function CompareTo (
    other As SignalReference
) As Integer
abstract CompareTo :
        other : SignalReference -> int
override CompareTo :
        other : SignalReference -> int
function CompareTo(other);
public:
virtual int CompareTo(
    SignalReference other
) sealed

Parameters

other
Type: GSF.Units.EESignalReference
Another SignalReference to compare with this SignalReference.

Return Value

Type: Int32
A 32-bit signed integer that indicates the relative order of the objects being compared.

Implements

IComparableTCompareTo(T)
See Also

Reference

SignalReference Structure
CompareTo Overload
GSF.Units.EE Namespace


SignalReference.Equals Method

Grid Solutions Framework SignalReferenceEquals Method
Overload List
 | Name | Description
Public method | Equals(Object) | Indicates whether the current object is equal to another object of the same type. (Overrides ValueTypeEquals(Object).)
Public method | Equals(SignalReference) | Indicates whether the current object is equal to another object of the same type.
Top
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.Equals Method (Object)

Grid Solutions Framework SignalReferenceEquals Method (Object)
Indicates whether the current object is equal to another object of the same type.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool Equals(
    Object obj
)
Public Overrides Function Equals (
    obj As Object
) As Boolean
abstract Equals :
        obj : Object -> bool
override Equals :
        obj : Object -> bool
function Equals(obj);
public:
virtual bool Equals(
    Object^ obj
) override

Parameters

obj
Type: SystemObject
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.
Exceptions
Exception | Condition
ArgumentException | Object is not a SignalReference.
See Also

Reference

SignalReference Structure
Equals Overload
GSF.Units.EE Namespace


SignalReference.Equals Method (SignalReference)

Grid Solutions Framework SignalReferenceEquals Method (SignalReference)
Indicates whether the current object is equal to another object of the same type.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Equals(
    SignalReference other
)
Public Function Equals (
    other As SignalReference
) As Boolean
abstract Equals :
        other : SignalReference -> bool
override Equals :
        other : SignalReference -> bool
function Equals(other);
public:
virtual bool Equals(
    SignalReference other
) sealed

Parameters

other
Type: GSF.Units.EESignalReference
An object to compare with this object.

Return Value

Type: Boolean
true if the current object is equal to the other parameter; otherwise, false.

Implements

IEquatableTEquals(T)
See Also

Reference

SignalReference Structure
Equals Overload
GSF.Units.EE Namespace


SignalReference.GetHashCode Method

Grid Solutions Framework SignalReferenceGetHashCode Method
Returns the hash code for this SignalReference.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
abstract GetHashCode : unit -> int
override GetHashCode : unit -> int
function GetHashCode();
public:
virtual int GetHashCode() override

Return Value

Type: Int32
A 32-bit signed integer hash code.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.ToString Method

Grid Solutions Framework SignalReferenceToString Method
Overload List
 | Name | Description
Public method | ToString | Returns a String that represents the current SignalReference. (Overrides ValueTypeToString.)
 | ToString(String, SignalKind) | Returns a String that represents the specified acronym and SignalKind.
 | ToString(String, SignalKind, Int32) | Returns a String that represents the specified acronym, SignalKind and index.
Top
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.ToString Method

Grid Solutions Framework SignalReferenceToString Method
Returns a String that represents the current SignalReference.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string ToString()
Public Overrides Function ToString As String
abstract ToString : unit -> string
override ToString : unit -> string
function ToString();
public:
virtual String^ ToString() override

Return Value

Type: String
A String that represents the current SignalReference.
See Also

Reference

SignalReference Structure
ToString Overload
GSF.Units.EE Namespace


SignalReference.ToString Method (String, SignalKind)

Grid Solutions Framework SignalReferenceToString Method (String, SignalKind)
Returns a String that represents the specified acronym and SignalKind.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    string acronym,
    SignalKind type
)
Public Shared Function ToString (
    acronym As String,
    type As SignalKind
) As String
static member ToString :
        acronym : string *
        type : SignalKind -> string

GSF.Units.EE.SignalReference.ToString = function(acronym, type);
public:
static String^ ToString(
    String^ acronym,
    SignalKind type
)

Parameters

acronym
Type: SystemString
Acronym portion of the desired String representation.
type
Type: GSF.Units.EESignalKind
SignalKind portion of the desired String representation.

Return Value

Type: String
A String that represents the specified acronym and SignalKind.
See Also

Reference

SignalReference Structure
ToString Overload
GSF.Units.EE Namespace


SignalReference.ToString Method (String, SignalKind, Int32)

Grid Solutions Framework SignalReferenceToString Method (String, SignalKind, Int32)
Returns a String that represents the specified acronym, SignalKind and index.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string ToString(
    string acronym,
    SignalKind type,
    int index
)
Public Shared Function ToString (
    acronym As String,
    type As SignalKind,
    index As Integer
) As String
static member ToString :
        acronym : string *
        type : SignalKind *
        index : int -> string

GSF.Units.EE.SignalReference.ToString = function(acronym, type, index);
public:
static String^ ToString(
    String^ acronym,
    SignalKind type,
    int index
)

Parameters

acronym
Type: SystemString
Acronym portion of the desired String representation.
type
Type: GSF.Units.EESignalKind
SignalKind portion of the desired String representation.
index
Type: SystemInt32
Index of SignalKind portion of the desired String representation.

Return Value

Type: String
A String that represents the specified acronym, SignalKind and index.
See Also

Reference

SignalReference Structure
ToString Overload
GSF.Units.EE Namespace


SignalReference Operators

Grid Solutions Framework SignalReference Operators

The SignalReference type exposes the following members.

Operators
Name | Description
Equality | Compares two SignalReference values for equality.
GreaterThan | Returns true if left SignalReference value is greater than right SignalReference value.
GreaterThanOrEqual | Returns true if left SignalReference value is greater than or equal to right SignalReference value.
Inequality | Compares two SignalReference values for inequality.
LessThan | Returns true if left SignalReference value is less than right SignalReference value.
LessThanOrEqual | Returns true if left SignalReference value is less than or equal to right SignalReference value.
Top
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.Equality Operator

Grid Solutions Framework SignalReferenceEquality Operator
Compares two SignalReference values for equality.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator ==(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator = (
    signal1 As SignalReference,
    signal2 As SignalReference
) As Boolean
static let inline (=)
        signal1 : SignalReference *
        signal2 : SignalReference  : bool
JavaScript does not support overloaded operators.
public:
static bool operator ==(
    SignalReference signal1,
    SignalReference signal2
)

Parameters

signal1
Type: GSF.Units.EESignalReference
A SignalReference left hand operand.
signal2
Type: GSF.Units.EESignalReference
A SignalReference right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.GreaterThan Operator

Grid Solutions Framework SignalReferenceGreaterThan Operator
Returns true if left SignalReference value is greater than right SignalReference value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator > (
    signal1 As SignalReference,
    signal2 As SignalReference
) As Boolean
static let inline (>)
        signal1 : SignalReference *
        signal2 : SignalReference  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >(
    SignalReference signal1,
    SignalReference signal2
)

Parameters

signal1
Type: GSF.Units.EESignalReference
A SignalReference left hand operand.
signal2
Type: GSF.Units.EESignalReference
A SignalReference right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.GreaterThanOrEqual Operator

Grid Solutions Framework SignalReferenceGreaterThanOrEqual Operator
Returns true if left SignalReference value is greater than or equal to right SignalReference value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator >=(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator >= (
    signal1 As SignalReference,
    signal2 As SignalReference
) As Boolean
static let inline (>=)
        signal1 : SignalReference *
        signal2 : SignalReference  : bool
JavaScript does not support overloaded operators.
public:
static bool operator >=(
    SignalReference signal1,
    SignalReference signal2
)

Parameters

signal1
Type: GSF.Units.EESignalReference
A SignalReference left hand operand.
signal2
Type: GSF.Units.EESignalReference
A SignalReference right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.Inequality Operator

Grid Solutions Framework SignalReferenceInequality Operator
Compares two SignalReference values for inequality.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator !=(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator <> (
    signal1 As SignalReference,
    signal2 As SignalReference
) As Boolean
static let inline (<>)
        signal1 : SignalReference *
        signal2 : SignalReference  : bool
JavaScript does not support overloaded operators.
public:
static bool operator !=(
    SignalReference signal1,
    SignalReference signal2
)

Parameters

signal1
Type: GSF.Units.EESignalReference
A SignalReference left hand operand.
signal2
Type: GSF.Units.EESignalReference
A SignalReference right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.LessThan Operator

Grid Solutions Framework SignalReferenceLessThan Operator
Returns true if left SignalReference value is less than right SignalReference value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator < (
    signal1 As SignalReference,
    signal2 As SignalReference
) As Boolean
static let inline (<)
        signal1 : SignalReference *
        signal2 : SignalReference  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <(
    SignalReference signal1,
    SignalReference signal2
)

Parameters

signal1
Type: GSF.Units.EESignalReference
A SignalReference left hand operand.
signal2
Type: GSF.Units.EESignalReference
A SignalReference right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalReference.LessThanOrEqual Operator

Grid Solutions Framework SignalReferenceLessThanOrEqual Operator
Returns true if left SignalReference value is less than or equal to right SignalReference value.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static bool operator <=(
    SignalReference signal1,
    SignalReference signal2
)
Public Shared Operator <= (
    signal1 As SignalReference,
    signal2 As SignalReference
) As Boolean
static let inline (<=)
        signal1 : SignalReference *
        signal2 : SignalReference  : bool
JavaScript does not support overloaded operators.
public:
static bool operator <=(
    SignalReference signal1,
    SignalReference signal2
)

Parameters

signal1
Type: GSF.Units.EESignalReference
A SignalReference left hand operand.
signal2
Type: GSF.Units.EESignalReference
A SignalReference right hand operand.

Return Value

Type: Boolean
A boolean representing the result.
See Also

Reference

SignalReference Structure
GSF.Units.EE Namespace


SignalType Enumeration

Grid Solutions Framework SignalType Enumeration
Fundamental signal type enumeration for common EE measurements that represents an explicit type of signal.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[SerializableAttribute]
public enum SignalType
<SerializableAttribute>
Public Enumeration SignalType
[<SerializableAttribute>]
type SignalType
GSF.Units.EE.SignalType = function();
GSF.Units.EE.SignalType.createEnum('GSF.Units.EE.SignalType', false);
[SerializableAttribute]
public enum class SignalType
Members
Member name | Value | Description
IPHM | 1 | Current phase magnitude.
IPHA | 2 | Current phase angle.
VPHM | 3 | Voltage phase magnitude.
VPHA | 4 | Voltage phase angle.
FREQ | 5 | Frequency.
DFDT | 6 | Frequency delta (dF/dt).
ALOG | 7 | Analog value.
FLAG | 8 | Status flags.
DIGI | 9 | Digital values.
CALC | 10 | Calculated value.
STAT | 11 | Statistical value.
ALRM | 12 | Alarm value.
QUAL | 13 | Quality flags.
NONE | -1 | Undefined signal.
Remarks

This enumeration represents the explicit type of a signal that a value represents.

Contrast this to the SignalKind enumeration which only defines an abstract type for a signal (e.g., simply a phase or an angle).

See Also

Reference

GSF.Units.EE Namespace


SignalTypeExtensions Class

Grid Solutions Framework SignalTypeExtensions Class
Defines extension functions for the SignalType enumeration.
Inheritance Hierarchy
SystemObject
GSF.Units.EESignalTypeExtensions

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class SignalTypeExtensions
<ExtensionAttribute>
Public NotInheritable Class SignalTypeExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type SignalTypeExtensions =  class end
GSF.Units.EE.SignalTypeExtensions = function();

Type.createClass(
    'GSF.Units.EE.SignalTypeExtensions');
[ExtensionAttribute]
public ref class SignalTypeExtensions abstract sealed

The SignalTypeExtensions type exposes the following members.

Methods
Name | Description
GetFormattedName | Returns display friendly signal type name.
Top
See Also

Reference

GSF.Units.EE Namespace


SignalTypeExtensions Methods

Grid Solutions Framework SignalTypeExtensions Methods

The SignalTypeExtensions type exposes the following members.

Methods
Name | Description
GetFormattedName | Returns display friendly signal type name.
Top
See Also

Reference

SignalTypeExtensions Class
GSF.Units.EE Namespace


SignalTypeExtensions.GetFormattedName Method

Grid Solutions Framework SignalTypeExtensionsGetFormattedName Method
Returns display friendly signal type name.

Namespace: GSF.Units.EE
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetFormattedName(
    this SignalType signalType
)
<ExtensionAttribute>
Public Shared Function GetFormattedName (
    signalType As SignalType
) As String
static member GetFormattedName :
        signalType : SignalType -> string

GSF.Units.EE.SignalTypeExtensions.GetFormattedName = function(signalType);
public:
[ExtensionAttribute]
static String^ GetFormattedName(
    SignalType signalType
)

Parameters

signalType
Type: GSF.Units.EESignalType
SignalType to return display name for.

Return Value

Type: String
Friendly protocol display name for specified signalType.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type SignalType. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

SignalTypeExtensions Class
GSF.Units.EE Namespace


GSF.Validation Namespace

Grid Solutions Framework GSF.Validation Namespace
Contains classes that facilitate the validation of data.
Classes
 | Class | Description
Public class | EmailAddressValidator | Represents a validator that can be used to ensure the validity of an email address.
Public class | NonNullStringValidator | Represents a validator that can be used to check for Strings that are null, empty, or consists only of whitespaces.
Public class | NumericRangeValidator | Represents a validator that can be used to ensure that a numeric value falls within a specific range.
 | ValidationService | A class that facilitates value validation using IValidator implementations.
Interfaces
 | Interface | Description
Public interface | IValidator | Defines a value validator.


EmailAddressValidator Class

Grid Solutions Framework EmailAddressValidator Class
Represents a validator that can be used to ensure the validity of an email address.
Inheritance Hierarchy
SystemObject
GSF.ValidationEmailAddressValidator

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EmailAddressValidator : IValidator
Public Class EmailAddressValidator
    Implements IValidator
type EmailAddressValidator =
    class
        interface IValidator
    end
GSF.Validation.EmailAddressValidator = function();

Type.createClass(
    'GSF.Validation.EmailAddressValidator',
    null,
    GSF.Validation.IValidator);
public ref class EmailAddressValidator : IValidator

The EmailAddressValidator type exposes the following members.

Constructors
 | Name | Description
Public method | EmailAddressValidator | Initializes a new instance of the EmailAddressValidator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Determines whether or not the specified value is a valid email address.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.Validation Namespace


EmailAddressValidator Constructor

Grid Solutions Framework EmailAddressValidator Constructor
Initializes a new instance of the EmailAddressValidator class

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EmailAddressValidator()
Public Sub New
new : unit -> EmailAddressValidator
GSF.Validation.EmailAddressValidator = function();
public:
EmailAddressValidator()
See Also

Reference

EmailAddressValidator Class
GSF.Validation Namespace


EmailAddressValidator Methods

Grid Solutions Framework EmailAddressValidator Methods

The EmailAddressValidator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Determines whether or not the specified value is a valid email address.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EmailAddressValidator Class
GSF.Validation Namespace


EmailAddressValidator.Validate Method

Grid Solutions Framework EmailAddressValidatorValidate Method
Determines whether or not the specified value is a valid email address.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Validate(
    Object value,
    out string validationError
)
Public Function Validate (
    value As Object,
    <OutAttribute> ByRef validationError As String
) As Boolean
abstract Validate :
        value : Object *
        validationError : string byref -> bool
override Validate :
        value : Object *
        validationError : string byref -> bool
function Validate(value, validationError);
public:
virtual bool Validate(
    Object^ value,
    [OutAttribute] String^% validationError
) sealed

Parameters

value
Type: SystemObject
The value to be validated.
validationError
Type: SystemString
Error message returned if the value is invalid.

Return Value

Type: Boolean
true if the value is valid; otherwise false.

Implements

IValidatorValidate(Object, String)
See Also

Reference

EmailAddressValidator Class
GSF.Validation Namespace


IValidator Interface

Grid Solutions Framework IValidator Interface
Defines a value validator.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public interface IValidator
Public Interface IValidator
type IValidator =  interface end
GSF.Validation.IValidator = function();
GSF.Validation.IValidator.createInterface('GSF.Validation.IValidator');
public interface class IValidator

The IValidator type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Determines whether or not the specified value is valid.
Top
See Also

Reference

GSF.Validation Namespace


IValidator Methods

Grid Solutions Framework IValidator Methods

The IValidator type exposes the following members.

Methods
 | Name | Description
Public method | Validate | Determines whether or not the specified value is valid.
Top
See Also

Reference

IValidator Interface
GSF.Validation Namespace


IValidator.Validate Method

Grid Solutions Framework IValidatorValidate Method
Determines whether or not the specified value is valid.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
bool Validate(
    Object value,
    out string validationError
)
Function Validate (
    value As Object,
    <OutAttribute> ByRef validationError As String
) As Boolean
abstract Validate :
        value : Object *
        validationError : string byref -> bool

function Validate(value, validationError);
bool Validate(
    Object^ value,
    [OutAttribute] String^% validationError
)

Parameters

value
Type: SystemObject
The value to be validated.
validationError
Type: SystemString
Error message returned if the value is invalid.

Return Value

Type: Boolean
true if the value is valid; otherwise false.
See Also

Reference

IValidator Interface
GSF.Validation Namespace


NonNullStringValidator Class

Grid Solutions Framework NonNullStringValidator Class
Represents a validator that can be used to check for Strings that are null, empty, or consists only of whitespaces.
Inheritance Hierarchy
SystemObject
GSF.ValidationNonNullStringValidator

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class NonNullStringValidator : IValidator
Public Class NonNullStringValidator
    Implements IValidator
type NonNullStringValidator =
    class
        interface IValidator
    end
GSF.Validation.NonNullStringValidator = function();

Type.createClass(
    'GSF.Validation.NonNullStringValidator',
    null,
    GSF.Validation.IValidator);
public ref class NonNullStringValidator : IValidator

The NonNullStringValidator type exposes the following members.

Constructors
 | Name | Description
Public method | NonNullStringValidator | Initializes a new instance of the NonNullStringValidator class
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Determines whether or not the specified value is a valid string that is not null, empty or consists only of whitespaces.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.Validation Namespace


NonNullStringValidator Constructor

Grid Solutions Framework NonNullStringValidator Constructor
Initializes a new instance of the NonNullStringValidator class

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NonNullStringValidator()
Public Sub New
new : unit -> NonNullStringValidator
GSF.Validation.NonNullStringValidator = function();
public:
NonNullStringValidator()
See Also

Reference

NonNullStringValidator Class
GSF.Validation Namespace


NonNullStringValidator Methods

Grid Solutions Framework NonNullStringValidator Methods

The NonNullStringValidator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Determines whether or not the specified value is a valid string that is not null, empty or consists only of whitespaces.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

NonNullStringValidator Class
GSF.Validation Namespace


NonNullStringValidator.Validate Method

Grid Solutions Framework NonNullStringValidatorValidate Method
Determines whether or not the specified value is a valid string that is not null, empty or consists only of whitespaces.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Validate(
    Object value,
    out string validationError
)
Public Function Validate (
    value As Object,
    <OutAttribute> ByRef validationError As String
) As Boolean
abstract Validate :
        value : Object *
        validationError : string byref -> bool
override Validate :
        value : Object *
        validationError : string byref -> bool
function Validate(value, validationError);
public:
virtual bool Validate(
    Object^ value,
    [OutAttribute] String^% validationError
) sealed

Parameters

value
Type: SystemObject
The value to be validated.
validationError
Type: SystemString
Error message returned if the value is invalid.

Return Value

Type: Boolean
true if the value is valid; otherwise false.

Implements

IValidatorValidate(Object, String)
See Also

Reference

NonNullStringValidator Class
GSF.Validation Namespace


NumericRangeValidator Class

Grid Solutions Framework NumericRangeValidator Class
Represents a validator that can be used to ensure that a numeric value falls within a specific range.
Inheritance Hierarchy
SystemObject
GSF.ValidationNumericRangeValidator

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class NumericRangeValidator : IValidator
Public Class NumericRangeValidator
    Implements IValidator
type NumericRangeValidator =
    class
        interface IValidator
    end
GSF.Validation.NumericRangeValidator = function();

Type.createClass(
    'GSF.Validation.NumericRangeValidator',
    null,
    GSF.Validation.IValidator);
public ref class NumericRangeValidator : IValidator

The NumericRangeValidator type exposes the following members.

Constructors
 | Name | Description
Public method | NumericRangeValidator | Initializes a new instance of the NumericRangeValidator class.
Top
Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Determines whether or not the specified value is a valid number that falls within the specified range.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

GSF.Validation Namespace


NumericRangeValidator Constructor

Grid Solutions Framework NumericRangeValidator Constructor
Initializes a new instance of the NumericRangeValidator class.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public NumericRangeValidator(
    decimal minimum,
    decimal maximum
)
Public Sub New (
    minimum As Decimal,
    maximum As Decimal
)
new :
        minimum : decimal *
        maximum : decimal -> NumericRangeValidator
GSF.Validation.NumericRangeValidator = function(minimum, maximum);
public:
NumericRangeValidator(
    Decimal minimum,
    Decimal maximum
)

Parameters

minimum
Type: SystemDecimal
The minimum allowed numeric value.
maximum
Type: SystemDecimal
The maximum allowed numeric value.
See Also

Reference

NumericRangeValidator Class
GSF.Validation Namespace


NumericRangeValidator Methods

Grid Solutions Framework NumericRangeValidator Methods

The NumericRangeValidator type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Determines whether or not the specified value is a valid number that falls within the specified range.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

NumericRangeValidator Class
GSF.Validation Namespace


NumericRangeValidator.Validate Method

Grid Solutions Framework NumericRangeValidatorValidate Method
Determines whether or not the specified value is a valid number that falls within the specified range.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Validate(
    Object value,
    out string validationError
)
Public Function Validate (
    value As Object,
    <OutAttribute> ByRef validationError As String
) As Boolean
abstract Validate :
        value : Object *
        validationError : string byref -> bool
override Validate :
        value : Object *
        validationError : string byref -> bool
function Validate(value, validationError);
public:
virtual bool Validate(
    Object^ value,
    [OutAttribute] String^% validationError
) sealed

Parameters

value
Type: SystemObject
The value to be validated.
validationError
Type: SystemString
Error message returned if the value is invalid.

Return Value

Type: Boolean
true if the value is valid; otherwise false.

Implements

IValidatorValidate(Object, String)
See Also

Reference

NumericRangeValidator Class
GSF.Validation Namespace


ValidationService Class

Grid Solutions Framework ValidationService Class
A class that facilitates value validation using IValidator implementations.
Inheritance Hierarchy
SystemObject
GSF.ValidationValidationService

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ValidationService
Public Class ValidationService
type ValidationService =  class end
GSF.Validation.ValidationService = function();

Type.createClass(
    'GSF.Validation.ValidationService');
public ref class ValidationService

The ValidationService type exposes the following members.

Constructors
 | Name | Description
Public method | ValidationService | Initializes a new instance of the ValidationService class.
Top
Methods
 | Name | Description
Public method | AddValidation | Adds a new validation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Executes all validations.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Examples
This example shows how to use ValidationService for input validation:
Copy
using System;
using System.Collections.Generic;
using GSF.Validation;

class Program
{
    static void Main(string[] args)
    {
        // Dictionary where captured user input is saved.
        Dictionary<string, string> input = new Dictionary<string, string>();

        // Validation service that will validate user input.
        ValidationService validation = new ValidationService(delegate(string source)
            {
                string value;
                if (input.TryGetValue(source, out value))
                    return input[source];
                else
                    return string.Empty;
            });

        // Add validation rules to the validation service.
        validation.AddValidation("Name", new NonNullStringValidator());
        validation.AddValidation("Email", new EmailAddressValidator());

        // Capture user input.
        Console.Write("Enter name: ");
        input["Name"] = Console.ReadLine();
        Console.Write("Enter email: ");
        input["Email"] = Console.ReadLine();
        Console.WriteLine("");

        // Validate user input.
        string errors;
        if (!validation.Validate(out errors))
            Console.WriteLine(errors);
        else
            Console.WriteLine("No validation errors were found!");

        Console.ReadLine();
    }
}
See Also

Reference

GSF.Validation Namespace
GSF.ValidationIValidator


ValidationService Constructor

Grid Solutions Framework ValidationService Constructor
Initializes a new instance of the ValidationService class.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ValidationService(
    Func<string, Object> valueLookupHandler
)
Public Sub New (
    valueLookupHandler As Func(Of String, Object)
)
new :
        valueLookupHandler : Func<string, Object> -> ValidationService
GSF.Validation.ValidationService = function(valueLookupHandler);
public:
ValidationService(
    Func<String^, Object^>^ valueLookupHandler
)

Parameters

valueLookupHandler
Type: SystemFunc String, Object
Delegate that will lookup the value to be validated.
See Also

Reference

ValidationService Class
GSF.Validation Namespace


ValidationService Methods

Grid Solutions Framework ValidationService Methods

The ValidationService type exposes the following members.

Methods
 | Name | Description
Public method | AddValidation | Adds a new validation.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Public method | Validate | Executes all validations.
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ValidationService Class
GSF.Validation Namespace


ValidationService.AddValidation Method

Grid Solutions Framework ValidationServiceAddValidation Method
Adds a new validation.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void AddValidation(
    string source,
    IValidator validator
)
Public Sub AddValidation (
    source As String,
    validator As IValidator
)
member AddValidation :
        source : string *
        validator : IValidator -> unit

function AddValidation(source, validator);
public:
void AddValidation(
    String^ source,
    IValidator^ validator
)

Parameters

source
Type: SystemString
The source that will provide the value to be validated.
validator
Type: GSF.ValidationIValidator
The IValidator that will validate the value.
Exceptions
Exception | Condition
ArgumentNullException | source or validator is null.
See Also

Reference

ValidationService Class
GSF.Validation Namespace


ValidationService.Validate Method

Grid Solutions Framework ValidationServiceValidate Method
Executes all validations.

Namespace: GSF.Validation
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool Validate(
    out string validationErrors
)
Public Function Validate (
    <OutAttribute> ByRef validationErrors As String
) As Boolean
member Validate :
        validationErrors : string byref -> bool

function Validate(validationErrors);
public:
bool Validate(
    [OutAttribute] String^% validationErrors
)

Parameters

validationErrors
Type: SystemString
Errors messages returned by one or more of the validations.

Return Value

Type: Boolean
true if the validation completes without errors; otherwise false.
See Also

Reference

ValidationService Class
GSF.Validation Namespace


GSF.Web Namespace

Grid Solutions Framework GSF.Web Namespace
Contains classes and extension functions related to .NET web enabled platforms such as ASP.NET and WCF.
Classes
 | Class | Description
Public class | IgnoreServicesSecurityModule | Represents an HTTP module that can be used to enable site-wide role-based security except for WCF services.
 | SecurityModule | Represents an HTTP module that can be used to enable site-wide role-based security.


IgnoreServicesSecurityModule Class

Grid Solutions Framework IgnoreServicesSecurityModule Class
Represents an HTTP module that can be used to enable site-wide role-based security except for WCF services.
Inheritance Hierarchy
SystemObject
GSF.WebSecurityModule
GSF.WebIgnoreServicesSecurityModule

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class IgnoreServicesSecurityModule : SecurityModule
Public Class IgnoreServicesSecurityModule
    Inherits SecurityModule
type IgnoreServicesSecurityModule =
    class
        inherit SecurityModule
    end
GSF.Web.IgnoreServicesSecurityModule = function();

Type.createClass(
    'GSF.Web.IgnoreServicesSecurityModule',
    GSF.Web.SecurityModule);
public ref class IgnoreServicesSecurityModule : public SecurityModule

The IgnoreServicesSecurityModule type exposes the following members.

Constructors
 | Name | Description
Public method | IgnoreServicesSecurityModule | Initializes a new instance of the IgnoreServicesSecurityModule class
Top
Methods
 | Name | Description
Public method | Dispose | Releases the resources used by SecurityModule. (Inherited from SecurityModule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed. (Inherited from SecurityModule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes the SecurityModule. (Inherited from SecurityModule.)
Protected method | IsAccessRestricted | Determines if access to the requested resource is restricted by RestrictAccessAttribute. (Inherited from SecurityModule.)
Protected method | IsAccessSecured | Determines if access to the requested resource is to be secured. (Overrides SecurityModuleIsAccessSecured(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Redirect | Redirects the client browser based on the specified httpStatusCode (Inherited from SecurityModule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | Application | Gets the current HttpApplication instance. (Inherited from SecurityModule.)
Top
See Also

Reference

GSF.Web Namespace


IgnoreServicesSecurityModule Constructor

Grid Solutions Framework IgnoreServicesSecurityModule Constructor
Initializes a new instance of the IgnoreServicesSecurityModule class

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public IgnoreServicesSecurityModule()
Public Sub New
new : unit -> IgnoreServicesSecurityModule
GSF.Web.IgnoreServicesSecurityModule = function();
public:
IgnoreServicesSecurityModule()
See Also

Reference

IgnoreServicesSecurityModule Class
GSF.Web Namespace


IgnoreServicesSecurityModule Methods

Grid Solutions Framework IgnoreServicesSecurityModule Methods

The IgnoreServicesSecurityModule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases the resources used by SecurityModule. (Inherited from SecurityModule.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed. (Inherited from SecurityModule.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes the SecurityModule. (Inherited from SecurityModule.)
Protected method | IsAccessRestricted | Determines if access to the requested resource is restricted by RestrictAccessAttribute. (Inherited from SecurityModule.)
Protected method | IsAccessSecured | Determines if access to the requested resource is to be secured. (Overrides SecurityModuleIsAccessSecured(String).)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Redirect | Redirects the client browser based on the specified httpStatusCode (Inherited from SecurityModule.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

IgnoreServicesSecurityModule Class
GSF.Web Namespace


IgnoreServicesSecurityModule.IsAccessSecured Method

Grid Solutions Framework IgnoreServicesSecurityModuleIsAccessSecured Method
Determines if access to the requested resource is to be secured.

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool IsAccessSecured(
    string resource
)
Protected Overrides Function IsAccessSecured (
    resource As String
) As Boolean
abstract IsAccessSecured :
        resource : string -> bool
override IsAccessSecured :
        resource : string -> bool
function IsAccessSecured(resource);
protected:
virtual bool IsAccessSecured(
    String^ resource
) override

Parameters

resource
Type: SystemString
Name of the resource being requested.

Return Value

Type: Boolean
True if access to the resource is to be secured, otherwise False.
See Also

Reference

IgnoreServicesSecurityModule Class
GSF.Web Namespace


IgnoreServicesSecurityModule Properties

Grid Solutions Framework IgnoreServicesSecurityModule Properties

The IgnoreServicesSecurityModule type exposes the following members.

Properties
 | Name | Description
Protected property | Application | Gets the current HttpApplication instance. (Inherited from SecurityModule.)
Top
See Also

Reference

IgnoreServicesSecurityModule Class
GSF.Web Namespace


SecurityModule Class

Grid Solutions Framework SecurityModule Class
Represents an HTTP module that can be used to enable site-wide role-based security.
Inheritance Hierarchy
SystemObject
GSF.WebSecurityModule
GSF.WebIgnoreServicesSecurityModule

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecurityModule : IHttpModule
Public Class SecurityModule
    Implements IHttpModule
type SecurityModule =
    class
        interface IHttpModule
    end
GSF.Web.SecurityModule = function();

Type.createClass(
    'GSF.Web.SecurityModule',
    null,
    IHttpModule);
public ref class SecurityModule : IHttpModule

The SecurityModule type exposes the following members.

Constructors
 | Name | Description
Public method | SecurityModule | Initializes a new instance of the SecurityModule class
Top
Methods
 | Name | Description
Public method | Dispose | Releases the resources used by SecurityModule.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes the SecurityModule.
Protected method | IsAccessRestricted | Determines if access to the requested resource is restricted by RestrictAccessAttribute.
Protected method | IsAccessSecured | Determines if access to the requested resource is to be secured.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Redirect | Redirects the client browser based on the specified httpStatusCode
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Protected property | Application | Gets the current HttpApplication instance.
Top
Examples
Required config file entries:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ApplicationName" value="" description="Name of the application being secured as defined in the backend security datastore."
        encrypted="false" />
      <add name="ConnectionString" value="" description="Connection string to be used for connection to the backend security datastore."
        encrypted="false" />
      <add name="ProviderType" value="GSF.Security.LdapSecurityProvider, GSF.Security"
        description="The type to be used for enforcing security." encrypted="false" />
      <add name="IncludedResources" value="*/*.*=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="*/WebResource.axd*;*/SecurityPortal.aspx*"
        description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
    </securityProvider>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
  <system.web>
    <authentication mode="Windows"/>
    <httpModules>
      <add name="SecurityModule" type="GSF.Web.SecurityModule, GSF.Web" />
    </httpModules>
  </system.web>
</configuration>
See Also

Reference

GSF.Web Namespace
GSF.SecurityISecurityProvider


SecurityModule Constructor

Grid Solutions Framework SecurityModule Constructor
Initializes a new instance of the SecurityModule class

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityModule()
Public Sub New
new : unit -> SecurityModule
GSF.Web.SecurityModule = function();
public:
SecurityModule()
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule Methods

Grid Solutions Framework SecurityModule Methods

The SecurityModule type exposes the following members.

Methods
 | Name | Description
Public method | Dispose | Releases the resources used by SecurityModule.
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Init | Initializes the SecurityModule.
Protected method | IsAccessRestricted | Determines if access to the requested resource is restricted by RestrictAccessAttribute.
Protected method | IsAccessSecured | Determines if access to the requested resource is to be secured.
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | Redirect | Redirects the client browser based on the specified httpStatusCode
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule.Dispose Method

Grid Solutions Framework SecurityModuleDispose Method
Releases the resources used by SecurityModule.

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Dispose()
Public Overridable Sub Dispose
abstract Dispose : unit -> unit
override Dispose : unit -> unit
function Dispose();
public:
virtual void Dispose()

Implements

IHttpModuleDispose
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule.GetResourceName Method

Grid Solutions Framework SecurityModuleGetResourceName Method
Gets the name of resource being accessed.

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetResourceName()
Protected Overridable Function GetResourceName As String
abstract GetResourceName : unit -> string
override GetResourceName : unit -> string
function GetResourceName();
protected:
virtual String^ GetResourceName()

Return Value

Type: String
Request.Url.PathAndQuery property value.
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule.Init Method

Grid Solutions Framework SecurityModuleInit Method
Initializes the SecurityModule.

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual void Init(
    HttpApplication context
)
Public Overridable Sub Init (
    context As HttpApplication
)
abstract Init :
        context : HttpApplication -> unit
override Init :
        context : HttpApplication -> unit
function Init(context);
public:
virtual void Init(
    HttpApplication^ context
)

Parameters

context
Type: System.WebHttpApplication
An HttpApplication object.

Implements

IHttpModuleInit(HttpApplication)
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule.IsAccessRestricted Method

Grid Solutions Framework SecurityModuleIsAccessRestricted Method
Determines if access to the requested resource is restricted by RestrictAccessAttribute.

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool IsAccessRestricted()
Protected Overridable Function IsAccessRestricted As Boolean
abstract IsAccessRestricted : unit -> bool
override IsAccessRestricted : unit -> bool
function IsAccessRestricted();
protected:
virtual bool IsAccessRestricted()

Return Value

Type: Boolean
true if access to the requested resource is restricted, otherwise false.
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule.IsAccessSecured Method

Grid Solutions Framework SecurityModuleIsAccessSecured Method
Determines if access to the requested resource is to be secured.

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual bool IsAccessSecured(
    string resource
)
Protected Overridable Function IsAccessSecured (
    resource As String
) As Boolean
abstract IsAccessSecured :
        resource : string -> bool
override IsAccessSecured :
        resource : string -> bool
function IsAccessSecured(resource);
protected:
virtual bool IsAccessSecured(
    String^ resource
)

Parameters

resource
Type: SystemString
Name of the resource being requested.

Return Value

Type: Boolean
True if access to the resource is to be secured, otherwise False.
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule.Redirect Method

Grid Solutions Framework SecurityModuleRedirect Method
Redirects the client browser based on the specified httpStatusCode

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void Redirect(
    HttpStatusCode httpStatusCode
)
Protected Overridable Sub Redirect (
    httpStatusCode As HttpStatusCode
)
abstract Redirect :
        httpStatusCode : HttpStatusCode -> unit
override Redirect :
        httpStatusCode : HttpStatusCode -> unit
function Redirect(httpStatusCode);
protected:
virtual void Redirect(
    HttpStatusCode httpStatusCode
)

Parameters

httpStatusCode
Type: System.NetHttpStatusCode
HttpStatusCode to be used for the redirect.
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule Properties

Grid Solutions Framework SecurityModule Properties

The SecurityModule type exposes the following members.

Properties
 | Name | Description
Protected property | Application | Gets the current HttpApplication instance.
Top
See Also

Reference

SecurityModule Class
GSF.Web Namespace


SecurityModule.Application Property

Grid Solutions Framework SecurityModuleApplication Property
Gets the current HttpApplication instance.

Namespace: GSF.Web
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HttpApplication Application { get; }
Protected ReadOnly Property Application As HttpApplication
    Get
member Application : HttpApplication with get

function get_Application();

protected:
property HttpApplication^ Application {
    HttpApplication^ get ();
}

Property Value

Type: HttpApplication
See Also

Reference

SecurityModule Class
GSF.Web Namespace


GSF.Web.Embedded Namespace

Grid Solutions Framework GSF.Web.Embedded Namespace
Contains embedded ASP.NET web pages and WCF web services that support the implementation of role-based security in .NET and non-.NET based development platforms.
Classes
Class | Description
SecurityPortal | Embedded web page used by secure ASP.NET web sites for security related tasks.
SecurityService | Embedded WCF service that can be used for securing applications using role-based security.
Interfaces
 | Interface | Description
Public interface | ISecurityService | Embedded WCF service contract used for securing external facing WCF services.


ISecurityService Interface

Grid Solutions Framework ISecurityService Interface
Embedded WCF service contract used for securing external facing WCF services.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ServiceContractAttribute]
[XmlSerializerFormatAttribute]
public interface ISecurityService : ISelfHostingService,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings
<ServiceContractAttribute>
<XmlSerializerFormatAttribute>
Public Interface ISecurityService
    Inherits ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
[<ServiceContractAttribute>]
[<XmlSerializerFormatAttribute>]
type ISecurityService =
    interface
        interface ISelfHostingService
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Web.Embedded.ISecurityService = function();
GSF.Web.Embedded.ISecurityService.createInterface('GSF.Web.Embedded.ISecurityService');
[ServiceContractAttribute]
[XmlSerializerFormatAttribute]
public interface class ISecurityService : ISelfHostingService,
    IAdapter, ISupportLifecycle, IDisposable, IProvideStatus, IPersistSettings

The ISecurityService type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Authenticates a user and caches the security context upon successful authentication for subsequent use.
Public method | ChangePassword | Changes user password.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetUserData | Returns information about the current user.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | RefreshUserData | Refreshes and returns information about the current user.
Public method | ResetPassword | Resets user password.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
Properties
 | Name | Description
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from ISelfHostingService.)
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from ISelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | ServiceHost | Gets the ServiceHost hosting the web service. (Inherited from ISelfHostingService.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from ISelfHostingService.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from ISelfHostingService.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

GSF.Web.Embedded Namespace


ISecurityService Methods

Grid Solutions Framework ISecurityService Methods

The ISecurityService type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Authenticates a user and caches the security context upon successful authentication for subsequent use.
Public method | ChangePassword | Changes user password.
Public method | Dispose | Performs application-defined tasks associated with freeing, releasing, or resetting unmanaged resources. (Inherited from IDisposable.)
Public method | GetUserData | Returns information about the current user.
Public method | Initialize | Initializes the state of the object. (Inherited from ISupportLifecycle.)
Public method | LoadSettings | Loads saved settings from the config file. (Inherited from IPersistSettings.)
Public method | RefreshUserData | Refreshes and returns information about the current user.
Public method | ResetPassword | Resets user password.
Public method | SaveSettings | Saves settings to the config file. (Inherited from IPersistSettings.)
Top
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


ISecurityService.Authenticate Method

Grid Solutions Framework ISecurityServiceAuthenticate Method
Authenticates a user and caches the security context upon successful authentication for subsequent use.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(UriTemplate = "/authenticate?username={username}&password={password}")]
[OperationContractAttribute]
UserData Authenticate(
    string username,
    string password
)
<WebGetAttribute(UriTemplate := "/authenticate?username={username}&password={password}")>
<OperationContractAttribute>
Function Authenticate (
    username As String,
    password As String
) As UserData
[<WebGetAttribute(UriTemplate = "/authenticate?username={username}&password={password}")>]
[<OperationContractAttribute>]
abstract Authenticate :
        username : string *
        password : string -> UserData

function Authenticate(username, password);
[WebGetAttribute(UriTemplate = L"/authenticate?username={username}&password={password}")]
[OperationContractAttribute]
UserData^ Authenticate(
    String^ username,
    String^ password
)

Parameters

username
Type: SystemString
Username of the user.
password
Type: SystemString
Password of the user.

Return Value

Type: UserData
An UserData object of the user.
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


ISecurityService.ChangePassword Method

Grid Solutions Framework ISecurityServiceChangePassword Method
Changes user password.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(UriTemplate = "/changepassword?oldpassword={oldPassword}&newpassword={newPassword}")]
[OperationContractAttribute]
bool ChangePassword(
    string oldPassword,
    string newPassword
)
<WebGetAttribute(UriTemplate := "/changepassword?oldpassword={oldPassword}&newpassword={newPassword}")>
<OperationContractAttribute>
Function ChangePassword (
    oldPassword As String,
    newPassword As String
) As Boolean
[<WebGetAttribute(UriTemplate = "/changepassword?oldpassword={oldPassword}&newpassword={newPassword}")>]
[<OperationContractAttribute>]
abstract ChangePassword :
        oldPassword : string *
        newPassword : string -> bool

function ChangePassword(oldPassword, newPassword);
[WebGetAttribute(UriTemplate = L"/changepassword?oldpassword={oldPassword}&newpassword={newPassword}")]
[OperationContractAttribute]
bool ChangePassword(
    String^ oldPassword,
    String^ newPassword
)

Parameters

oldPassword
Type: SystemString
User's current password.
newPassword
Type: SystemString
User's new password.

Return Value

Type: Boolean
true if the password is changed, otherwise false.
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


ISecurityService.GetUserData Method

Grid Solutions Framework ISecurityServiceGetUserData Method
Returns information about the current user.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(UriTemplate = "/getuserdata")]
[OperationContractAttribute]
UserData GetUserData()
<WebGetAttribute(UriTemplate := "/getuserdata")>
<OperationContractAttribute>
Function GetUserData As UserData
[<WebGetAttribute(UriTemplate = "/getuserdata")>]
[<OperationContractAttribute>]
abstract GetUserData : unit -> UserData

function GetUserData();
[WebGetAttribute(UriTemplate = L"/getuserdata")]
[OperationContractAttribute]
UserData^ GetUserData()

Return Value

Type: UserData
An UserData object of the user if user's security context has been initialized, otherwise null.
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


ISecurityService.RefreshUserData Method

Grid Solutions Framework ISecurityServiceRefreshUserData Method
Refreshes and returns information about the current user.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(UriTemplate = "/refreshuserdata")]
[OperationContractAttribute]
UserData RefreshUserData()
<WebGetAttribute(UriTemplate := "/refreshuserdata")>
<OperationContractAttribute>
Function RefreshUserData As UserData
[<WebGetAttribute(UriTemplate = "/refreshuserdata")>]
[<OperationContractAttribute>]
abstract RefreshUserData : unit -> UserData

function RefreshUserData();
[WebGetAttribute(UriTemplate = L"/refreshuserdata")]
[OperationContractAttribute]
UserData^ RefreshUserData()

Return Value

Type: UserData
An UserData object of the user if user's security context has been initialized, otherwise null.
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


ISecurityService.ResetPassword Method

Grid Solutions Framework ISecurityServiceResetPassword Method
Resets user password.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[WebGetAttribute(UriTemplate = "/resetpassword?securityanswer={securityAnswer}")]
[OperationContractAttribute]
bool ResetPassword(
    string securityAnswer
)
<WebGetAttribute(UriTemplate := "/resetpassword?securityanswer={securityAnswer}")>
<OperationContractAttribute>
Function ResetPassword (
    securityAnswer As String
) As Boolean
[<WebGetAttribute(UriTemplate = "/resetpassword?securityanswer={securityAnswer}")>]
[<OperationContractAttribute>]
abstract ResetPassword :
        securityAnswer : string -> bool

function ResetPassword(securityAnswer);
[WebGetAttribute(UriTemplate = L"/resetpassword?securityanswer={securityAnswer}")]
[OperationContractAttribute]
bool ResetPassword(
    String^ securityAnswer
)

Parameters

securityAnswer
Type: SystemString
Answer to user's security question.

Return Value

Type: Boolean
true if password is reset, otherwise false.
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


ISecurityService Properties

Grid Solutions Framework ISecurityService Properties

The ISecurityService type exposes the following members.

Properties
 | Name | Description
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from ISelfHostingService.)
Public property | Domain | Gets the AppDomain in which the IAdapter is executing. (Inherited from IAdapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the object is enabled. (Inherited from ISupportLifecycle.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from ISelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the IAdapter is housed. (Inherited from IAdapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ISupportLifecycle.)
Public property | MemoryUsage | Gets the memory utilization of the IAdapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from IAdapter.)
Public property | Name | Gets the name of the object providing status information. (Inherited from IProvideStatus.)
Public property | PersistSettings | Determines whether the object settings are to be persisted to the config file. (Inherited from IPersistSettings.)
Public property | ProcessorUsage | Gets the % processor utilization of the IAdapter if executing in a separate AppDomain otherwise NaN. (Inherited from IAdapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from ISelfHostingService.)
Public property | ServiceHost | Gets the ServiceHost hosting the web service. (Inherited from ISelfHostingService.)
Public property | SettingsCategory | Gets or sets the category name under which the object settings are persisted in the config file. (Inherited from IPersistSettings.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from ISelfHostingService.)
Public property | Status | Gets the current status details about object providing status information. (Inherited from IProvideStatus.)
Public property | TypeName | Gets or sets the text representation of the IAdapter's TypeName. (Inherited from IAdapter.)
Top
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


ISecurityService Events

Grid Solutions Framework ISecurityService Events

The ISecurityService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Raised after the source object has been properly disposed. (Inherited from ISupportLifecycle.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from IAdapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost can process requests via all of its endpoints. (Inherited from ISelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from ISelfHostingService.)
Public event | StatusUpdate | Occurs when the IAdapter wants to provide a status update. (Inherited from IAdapter.)
Top
See Also

Reference

ISecurityService Interface
GSF.Web.Embedded Namespace


SecurityPortal Class

Grid Solutions Framework SecurityPortal Class
Embedded web page used by secure ASP.NET web sites for security related tasks.
Inheritance Hierarchy
SystemObject
System.Web.UIControl
System.Web.UITemplateControl
System.Web.UIPage
GSF.Web.EmbeddedSecurityPortal

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecurityPortal : Page
Public Class SecurityPortal
    Inherits Page
type SecurityPortal =
    class
        inherit Page
    end
GSF.Web.Embedded.SecurityPortal = function();

Type.createClass(
    'GSF.Web.Embedded.SecurityPortal',
    Page);
public ref class SecurityPortal : public Page

The SecurityPortal type exposes the following members.

Constructors
 | Name | Description
Public method | SecurityPortal | Initializes a new instance of the SecurityPortal class
Top
Methods
 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ChangeButton_Click | Changes user password.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Protected method | DeterminePostBackModeUnvalidated | Returns a name-value collection of data that was posted to the page using either a POST or a GET command, without performing ASP.NET request validation on the request. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, Object) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | LoginButton_Click | Logins the user.
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | Page_Load | Initializes the web page.
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsic server objects of the Page object, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResetCheckButton_Click | Checks if user password can be reset.
Protected method | ResetFinalButton_Click | Resets user password.
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | TryUpdateModelTModel(TModel) | Updates the specified model instance using values from the data-bound control. (Inherited from Page.)
Public method | TryUpdateModelTModel(TModel, IValueProvider) | Updates the model instance using values from the specified value provider. (Inherited from Page.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Protected method | UpdateButton_Click | Updates user data.
Public method | UpdateModelTModel(TModel) | Updates the specified model instance using values from the data-bound control. (Inherited from Page.)
Public method | UpdateModelTModel(TModel, IValueProvider) | Updates the specified model instance using values from a specified value provider. (Inherited from Page.)
Public method | Validate | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BringToFront | Brings the page's browser window to the foreground. (Defined by ClientSideExtensions.)
Public Extension Method | Close(String) | Overloaded. Closes the current page when it has finished loading in the browser and returns the specified returnValue to the web page that opened it. (Defined by ClientSideExtensions.)
Public Extension Method | Close(String) | Overloaded. Closes the current page when the control is clicked and returns the specified returnValue to the web page that opened it. (Defined by ClientSideExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MsgBox(String, String, MsgBoxStyle, Boolean) | Overloaded. Shows a windows application style message box when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | MsgBox(String, String, MsgBoxStyle, Boolean) | Overloaded. Shows a windows application style message box when the control is clicked. (Defined by ClientSideExtensions.)
Public Extension Method | PushToBack | Pushes the page's browser window to the background. (Defined by ClientSideExtensions.)
Public Extension Method | Refresh | Overloaded. Registers the control to perform a page refresh. (Defined by ClientSideExtensions.)
Public Extension Method | Refresh(Boolean) | Overloaded. Registers this page to perform a page refresh. (Defined by ClientSideExtensions.)
Public Extension Method | Show(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modeless popup window for the specified web page url when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | Show(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modeless popup window for the specified web page url when the control is clicked. (Defined by ClientSideExtensions.)
Public Extension Method | ShowDialog(String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modal popup window for the specified web page url when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | ShowDialog(String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modal popup window for the specified web page url when the control is clicked. (Defined by ClientSideExtensions.)
Public Extension Method | ShowPopup(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a popup for the specified web page url when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | ShowPopup(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a popup for the specified web page url when the control is clicked. (Defined by ClientSideExtensions.)
Top
Fields
 | Name | Description
Protected field | AccessDeniedPanel | AccessDeniedPanel control.
Protected field | AccountUserCompany | AccountUserCompany control.
Protected field | AccountUserEmailAddress | AccountUserEmailAddress control.
Protected field | AccountUserEmailAddressValidator | AccountUserEmailAddressValidator control.
Protected field | AccountUserFirstName | AccountUserFirstName control.
Protected field | AccountUserFirstNameValidator | AccountUserFirstNameValidator control.
Protected field | AccountUserLastName | AccountUserLastName control.
Protected field | AccountUserLastNameValidator | AccountUserLastNameValidator control.
Protected field | AccountUsername | AccountUsername control.
Protected field | AccountUserPhoneNumber | AccountUserPhoneNumber control.
Protected field | AccountUserPhoneNumberAddressValidator | AccountUserPhoneNumberAddressValidator control.
Protected field | AccountUserSecurityAnswer | AccountUserSecurityAnswer control.
Protected field | AccountUserSecurityAnswerValidator | AccountUserSecurityAnswerValidator control.
Protected field | AccountUserSecurityQuestion | AccountUserSecurityQuestion control.
Protected field | ChangeButton | ChangeButton control.
Protected field | ChangePassword | ChangePassword control.
Protected field | ChangePasswordConfirmNewPassword | ChangePasswordConfirmNewPassword control.
Protected field | ChangePasswordConfirmNewPasswordValidator1 | ChangePasswordConfirmNewPasswordValidator1 control.
Protected field | ChangePasswordConfirmNewPasswordValidator2 | ChangePasswordConfirmNewPasswordValidator2 control.
Protected field | ChangePasswordNewPassword | ChangePasswordNewPassword control.
Protected field | ChangePasswordNewPasswordValidator1 | ChangePasswordNewPasswordValidator1 control.
Protected field | ChangePasswordNewPasswordValidator2 | ChangePasswordNewPasswordValidator2 control.
Protected field | ChangePasswordOldPassword | ChangePasswordOldPassword control.
Protected field | ChangePasswordOldPasswordValidator | ChangePasswordOldPasswordValidator control.
Protected field | ChangePasswordPanel | ChangePasswordPanel control.
Protected field | ChangePasswordUsername | ChangePasswordUsername control.
Protected field | ChangePasswordUsernameValidator | ChangePasswordUsernameValidator control.
Protected field | ContentPlaceHolder | ContentPlaceHolder control.
Protected field | FooterLabel | FooterLabel control.
Protected field | ForgotPassword | ForgotPassword control.
Protected field | HelpImage | HelpImage control.
Protected field | HelpLink | HelpLink control.
Protected field | LoginButton | LoginButton control.
Protected field | LoginPanel | LoginPanel control.
Protected field | LoginPassword | LoginPassword control.
Protected field | LoginPasswordValidator | LoginPasswordValidator control.
Protected field | LoginUsername | LoginUsername control.
Protected field | LoginUsernameValidator | LoginUsernameValidator control.
Protected field | LogoImage | LogoImage control.
Protected field | LogoLink | LogoLink control.
Protected field | MainForm | MainForm control.
Protected field | MessageLabel | MessageLabel control.
Protected field | MyAccountPanel | MyAccountPanel control.
Protected field | RememberUsername | RememberUsername control.
Protected field | ResetCheckButton | ResetCheckButton control.
Protected field | ResetFinalButton | ResetFinalButton control.
Protected field | ResetPasswordCheckPanel | ResetPasswordCheckPanel control.
Protected field | ResetPasswordFinalPanel | ResetPasswordFinalPanel control.
Protected field | ResetPasswordSecurityAnswer | ResetPasswordSecurityAnswer control.
Protected field | ResetPasswordSecurityQuestion | ResetPasswordSecurityQuestion control.
Protected field | ResetPasswordUsername | ResetPasswordUsername control.
Protected field | ResetPasswordUsernameValidator | ResetPasswordUsernameValidator control.
Protected field | StyleSheet | StyleSheet control.
Protected field | UpdateButton | UpdateButton control.
Protected field | WarningImage | WarningImage control.
Top
Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control in the page that is used to perform postbacks. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should check message authentication codes (MAC) in the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value that indicates whether the page request is the result of a callback. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value that indicates whether the page is being rendered for the first time or is being loaded in response to a postback. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value that indicates whether the control in the page that performs postbacks has been registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the virtual path of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | MetaDescription | Gets or sets the content of the "description" meta element. (Inherited from Page.)
Public property | MetaKeywords | Gets or sets the content of the "keywords" meta element. (Inherited from Page.)
Public property | ModelBindingExecutionContext | Gets the model binding execution context. (Inherited from Page.)
Public property | ModelState | Gets the model state dictionary object that contains the state of the model and of model-binding validation. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | RouteData | Gets the RouteData value of the current RequestContext instance. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SkipFormActionValidation | Gets or sets a value that indicates whether the query string value is validated. (Inherited from Page.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the theme that is applied to the page early in the page life cycle. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | UnobtrusiveValidationMode | Gets or sets a value that indicates whether unobtrusive JavaScript is used for client-side validation. (Inherited from Page.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the page checks client input from the browser for potentially dangerous values. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
Top
Events
 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
Examples
Config file entries for customizing the page:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityPortal>
      <add name="CompanyLogo" value="~/images/MyCompanyLogo.png" description="Image file of the company's logo." encrypted="false" />
      <add name="CompanyLink" value="http://www.mycompany.com" description="Link to the company's web site." encrypted="false" />
      <add name="HelpPage" value="~/files/Help.pdf" description="Link to the help page." encrypted="false" />
      <add name="FooterText" value="(C) My Company. All rights reserved." description="Text to be displayed in the footer." encrypted="false" />
    </securityPortal>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.Web.Embedded Namespace


SecurityPortal Constructor

Grid Solutions Framework SecurityPortal Constructor
Initializes a new instance of the SecurityPortal class

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityPortal()
Public Sub New
new : unit -> SecurityPortal
GSF.Web.Embedded.SecurityPortal = function();
public:
SecurityPortal()
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal Fields

Grid Solutions Framework SecurityPortal Fields

The SecurityPortal type exposes the following members.

Fields
 | Name | Description
Protected field | AccessDeniedPanel | AccessDeniedPanel control.
Protected field | AccountUserCompany | AccountUserCompany control.
Protected field | AccountUserEmailAddress | AccountUserEmailAddress control.
Protected field | AccountUserEmailAddressValidator | AccountUserEmailAddressValidator control.
Protected field | AccountUserFirstName | AccountUserFirstName control.
Protected field | AccountUserFirstNameValidator | AccountUserFirstNameValidator control.
Protected field | AccountUserLastName | AccountUserLastName control.
Protected field | AccountUserLastNameValidator | AccountUserLastNameValidator control.
Protected field | AccountUsername | AccountUsername control.
Protected field | AccountUserPhoneNumber | AccountUserPhoneNumber control.
Protected field | AccountUserPhoneNumberAddressValidator | AccountUserPhoneNumberAddressValidator control.
Protected field | AccountUserSecurityAnswer | AccountUserSecurityAnswer control.
Protected field | AccountUserSecurityAnswerValidator | AccountUserSecurityAnswerValidator control.
Protected field | AccountUserSecurityQuestion | AccountUserSecurityQuestion control.
Protected field | ChangeButton | ChangeButton control.
Protected field | ChangePassword | ChangePassword control.
Protected field | ChangePasswordConfirmNewPassword | ChangePasswordConfirmNewPassword control.
Protected field | ChangePasswordConfirmNewPasswordValidator1 | ChangePasswordConfirmNewPasswordValidator1 control.
Protected field | ChangePasswordConfirmNewPasswordValidator2 | ChangePasswordConfirmNewPasswordValidator2 control.
Protected field | ChangePasswordNewPassword | ChangePasswordNewPassword control.
Protected field | ChangePasswordNewPasswordValidator1 | ChangePasswordNewPasswordValidator1 control.
Protected field | ChangePasswordNewPasswordValidator2 | ChangePasswordNewPasswordValidator2 control.
Protected field | ChangePasswordOldPassword | ChangePasswordOldPassword control.
Protected field | ChangePasswordOldPasswordValidator | ChangePasswordOldPasswordValidator control.
Protected field | ChangePasswordPanel | ChangePasswordPanel control.
Protected field | ChangePasswordUsername | ChangePasswordUsername control.
Protected field | ChangePasswordUsernameValidator | ChangePasswordUsernameValidator control.
Protected field | ContentPlaceHolder | ContentPlaceHolder control.
Protected field | FooterLabel | FooterLabel control.
Protected field | ForgotPassword | ForgotPassword control.
Protected field | HelpImage | HelpImage control.
Protected field | HelpLink | HelpLink control.
Protected field | LoginButton | LoginButton control.
Protected field | LoginPanel | LoginPanel control.
Protected field | LoginPassword | LoginPassword control.
Protected field | LoginPasswordValidator | LoginPasswordValidator control.
Protected field | LoginUsername | LoginUsername control.
Protected field | LoginUsernameValidator | LoginUsernameValidator control.
Protected field | LogoImage | LogoImage control.
Protected field | LogoLink | LogoLink control.
Protected field | MainForm | MainForm control.
Protected field | MessageLabel | MessageLabel control.
Protected field | MyAccountPanel | MyAccountPanel control.
Protected field | RememberUsername | RememberUsername control.
Protected field | ResetCheckButton | ResetCheckButton control.
Protected field | ResetFinalButton | ResetFinalButton control.
Protected field | ResetPasswordCheckPanel | ResetPasswordCheckPanel control.
Protected field | ResetPasswordFinalPanel | ResetPasswordFinalPanel control.
Protected field | ResetPasswordSecurityAnswer | ResetPasswordSecurityAnswer control.
Protected field | ResetPasswordSecurityQuestion | ResetPasswordSecurityQuestion control.
Protected field | ResetPasswordUsername | ResetPasswordUsername control.
Protected field | ResetPasswordUsernameValidator | ResetPasswordUsernameValidator control.
Protected field | StyleSheet | StyleSheet control.
Protected field | UpdateButton | UpdateButton control.
Protected field | WarningImage | WarningImage control.
Top
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccessDeniedPanel Field

Grid Solutions Framework SecurityPortalAccessDeniedPanel Field
AccessDeniedPanel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Panel AccessDeniedPanel
Protected AccessDeniedPanel As Panel
val mutable AccessDeniedPanel: Panel
var AccessDeniedPanel
protected:
Panel^ AccessDeniedPanel

Field Value

Type: Panel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserCompany Field

Grid Solutions Framework SecurityPortalAccountUserCompany Field
AccountUserCompany control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox AccountUserCompany
Protected AccountUserCompany As TextBox
val mutable AccountUserCompany: TextBox
var AccountUserCompany
protected:
TextBox^ AccountUserCompany

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserEmailAddress Field

Grid Solutions Framework SecurityPortalAccountUserEmailAddress Field
AccountUserEmailAddress control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox AccountUserEmailAddress
Protected AccountUserEmailAddress As TextBox
val mutable AccountUserEmailAddress: TextBox
var AccountUserEmailAddress
protected:
TextBox^ AccountUserEmailAddress

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserEmailAddressValidator Field

Grid Solutions Framework SecurityPortalAccountUserEmailAddressValidator Field
AccountUserEmailAddressValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator AccountUserEmailAddressValidator
Protected AccountUserEmailAddressValidator As RequiredFieldValidator
val mutable AccountUserEmailAddressValidator: RequiredFieldValidator
var AccountUserEmailAddressValidator
protected:
RequiredFieldValidator^ AccountUserEmailAddressValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserFirstName Field

Grid Solutions Framework SecurityPortalAccountUserFirstName Field
AccountUserFirstName control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox AccountUserFirstName
Protected AccountUserFirstName As TextBox
val mutable AccountUserFirstName: TextBox
var AccountUserFirstName
protected:
TextBox^ AccountUserFirstName

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserFirstNameValidator Field

Grid Solutions Framework SecurityPortalAccountUserFirstNameValidator Field
AccountUserFirstNameValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator AccountUserFirstNameValidator
Protected AccountUserFirstNameValidator As RequiredFieldValidator
val mutable AccountUserFirstNameValidator: RequiredFieldValidator
var AccountUserFirstNameValidator
protected:
RequiredFieldValidator^ AccountUserFirstNameValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserLastName Field

Grid Solutions Framework SecurityPortalAccountUserLastName Field
AccountUserLastName control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox AccountUserLastName
Protected AccountUserLastName As TextBox
val mutable AccountUserLastName: TextBox
var AccountUserLastName
protected:
TextBox^ AccountUserLastName

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserLastNameValidator Field

Grid Solutions Framework SecurityPortalAccountUserLastNameValidator Field
AccountUserLastNameValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator AccountUserLastNameValidator
Protected AccountUserLastNameValidator As RequiredFieldValidator
val mutable AccountUserLastNameValidator: RequiredFieldValidator
var AccountUserLastNameValidator
protected:
RequiredFieldValidator^ AccountUserLastNameValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUsername Field

Grid Solutions Framework SecurityPortalAccountUsername Field
AccountUsername control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox AccountUsername
Protected AccountUsername As TextBox
val mutable AccountUsername: TextBox
var AccountUsername
protected:
TextBox^ AccountUsername

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserPhoneNumber Field

Grid Solutions Framework SecurityPortalAccountUserPhoneNumber Field
AccountUserPhoneNumber control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox AccountUserPhoneNumber
Protected AccountUserPhoneNumber As TextBox
val mutable AccountUserPhoneNumber: TextBox
var AccountUserPhoneNumber
protected:
TextBox^ AccountUserPhoneNumber

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserPhoneNumberAddressValidator Field

Grid Solutions Framework SecurityPortalAccountUserPhoneNumberAddressValidator Field
AccountUserPhoneNumberAddressValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator AccountUserPhoneNumberAddressValidator
Protected AccountUserPhoneNumberAddressValidator As RequiredFieldValidator
val mutable AccountUserPhoneNumberAddressValidator: RequiredFieldValidator
var AccountUserPhoneNumberAddressValidator
protected:
RequiredFieldValidator^ AccountUserPhoneNumberAddressValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserSecurityAnswer Field

Grid Solutions Framework SecurityPortalAccountUserSecurityAnswer Field
AccountUserSecurityAnswer control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox AccountUserSecurityAnswer
Protected AccountUserSecurityAnswer As TextBox
val mutable AccountUserSecurityAnswer: TextBox
var AccountUserSecurityAnswer
protected:
TextBox^ AccountUserSecurityAnswer

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserSecurityAnswerValidator Field

Grid Solutions Framework SecurityPortalAccountUserSecurityAnswerValidator Field
AccountUserSecurityAnswerValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator AccountUserSecurityAnswerValidator
Protected AccountUserSecurityAnswerValidator As RequiredFieldValidator
val mutable AccountUserSecurityAnswerValidator: RequiredFieldValidator
var AccountUserSecurityAnswerValidator
protected:
RequiredFieldValidator^ AccountUserSecurityAnswerValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.AccountUserSecurityQuestion Field

Grid Solutions Framework SecurityPortalAccountUserSecurityQuestion Field
AccountUserSecurityQuestion control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Label AccountUserSecurityQuestion
Protected AccountUserSecurityQuestion As Label
val mutable AccountUserSecurityQuestion: Label
var AccountUserSecurityQuestion
protected:
Label^ AccountUserSecurityQuestion

Field Value

Type: Label
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangeButton Field

Grid Solutions Framework SecurityPortalChangeButton Field
ChangeButton control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Button ChangeButton
Protected ChangeButton As Button
val mutable ChangeButton: Button
var ChangeButton
protected:
Button^ ChangeButton

Field Value

Type: Button
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePassword Field

Grid Solutions Framework SecurityPortalChangePassword Field
ChangePassword control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HyperLink ChangePassword
Protected ChangePassword As HyperLink
val mutable ChangePassword: HyperLink
var ChangePassword
protected:
HyperLink^ ChangePassword

Field Value

Type: HyperLink
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordConfirmNewPassword Field

Grid Solutions Framework SecurityPortalChangePasswordConfirmNewPassword Field
ChangePasswordConfirmNewPassword control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox ChangePasswordConfirmNewPassword
Protected ChangePasswordConfirmNewPassword As TextBox
val mutable ChangePasswordConfirmNewPassword: TextBox
var ChangePasswordConfirmNewPassword
protected:
TextBox^ ChangePasswordConfirmNewPassword

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordConfirmNewPasswordValidator1 Field

Grid Solutions Framework SecurityPortalChangePasswordConfirmNewPasswordValidator1 Field
ChangePasswordConfirmNewPasswordValidator1 control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator ChangePasswordConfirmNewPasswordValidator1
Protected ChangePasswordConfirmNewPasswordValidator1 As RequiredFieldValidator
val mutable ChangePasswordConfirmNewPasswordValidator1: RequiredFieldValidator
var ChangePasswordConfirmNewPasswordValidator1
protected:
RequiredFieldValidator^ ChangePasswordConfirmNewPasswordValidator1

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordConfirmNewPasswordValidator2 Field

Grid Solutions Framework SecurityPortalChangePasswordConfirmNewPasswordValidator2 Field
ChangePasswordConfirmNewPasswordValidator2 control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CompareValidator ChangePasswordConfirmNewPasswordValidator2
Protected ChangePasswordConfirmNewPasswordValidator2 As CompareValidator
val mutable ChangePasswordConfirmNewPasswordValidator2: CompareValidator
var ChangePasswordConfirmNewPasswordValidator2
protected:
CompareValidator^ ChangePasswordConfirmNewPasswordValidator2

Field Value

Type: CompareValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordNewPassword Field

Grid Solutions Framework SecurityPortalChangePasswordNewPassword Field
ChangePasswordNewPassword control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox ChangePasswordNewPassword
Protected ChangePasswordNewPassword As TextBox
val mutable ChangePasswordNewPassword: TextBox
var ChangePasswordNewPassword
protected:
TextBox^ ChangePasswordNewPassword

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordNewPasswordValidator1 Field

Grid Solutions Framework SecurityPortalChangePasswordNewPasswordValidator1 Field
ChangePasswordNewPasswordValidator1 control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator ChangePasswordNewPasswordValidator1
Protected ChangePasswordNewPasswordValidator1 As RequiredFieldValidator
val mutable ChangePasswordNewPasswordValidator1: RequiredFieldValidator
var ChangePasswordNewPasswordValidator1
protected:
RequiredFieldValidator^ ChangePasswordNewPasswordValidator1

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordNewPasswordValidator2 Field

Grid Solutions Framework SecurityPortalChangePasswordNewPasswordValidator2 Field
ChangePasswordNewPasswordValidator2 control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CompareValidator ChangePasswordNewPasswordValidator2
Protected ChangePasswordNewPasswordValidator2 As CompareValidator
val mutable ChangePasswordNewPasswordValidator2: CompareValidator
var ChangePasswordNewPasswordValidator2
protected:
CompareValidator^ ChangePasswordNewPasswordValidator2

Field Value

Type: CompareValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordOldPassword Field

Grid Solutions Framework SecurityPortalChangePasswordOldPassword Field
ChangePasswordOldPassword control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox ChangePasswordOldPassword
Protected ChangePasswordOldPassword As TextBox
val mutable ChangePasswordOldPassword: TextBox
var ChangePasswordOldPassword
protected:
TextBox^ ChangePasswordOldPassword

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordOldPasswordValidator Field

Grid Solutions Framework SecurityPortalChangePasswordOldPasswordValidator Field
ChangePasswordOldPasswordValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator ChangePasswordOldPasswordValidator
Protected ChangePasswordOldPasswordValidator As RequiredFieldValidator
val mutable ChangePasswordOldPasswordValidator: RequiredFieldValidator
var ChangePasswordOldPasswordValidator
protected:
RequiredFieldValidator^ ChangePasswordOldPasswordValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordPanel Field

Grid Solutions Framework SecurityPortalChangePasswordPanel Field
ChangePasswordPanel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Panel ChangePasswordPanel
Protected ChangePasswordPanel As Panel
val mutable ChangePasswordPanel: Panel
var ChangePasswordPanel
protected:
Panel^ ChangePasswordPanel

Field Value

Type: Panel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordUsername Field

Grid Solutions Framework SecurityPortalChangePasswordUsername Field
ChangePasswordUsername control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox ChangePasswordUsername
Protected ChangePasswordUsername As TextBox
val mutable ChangePasswordUsername: TextBox
var ChangePasswordUsername
protected:
TextBox^ ChangePasswordUsername

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangePasswordUsernameValidator Field

Grid Solutions Framework SecurityPortalChangePasswordUsernameValidator Field
ChangePasswordUsernameValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator ChangePasswordUsernameValidator
Protected ChangePasswordUsernameValidator As RequiredFieldValidator
val mutable ChangePasswordUsernameValidator: RequiredFieldValidator
var ChangePasswordUsernameValidator
protected:
RequiredFieldValidator^ ChangePasswordUsernameValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ContentPlaceHolder Field

Grid Solutions Framework SecurityPortalContentPlaceHolder Field
ContentPlaceHolder control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected PlaceHolder ContentPlaceHolder
Protected ContentPlaceHolder As PlaceHolder
val mutable ContentPlaceHolder: PlaceHolder
var ContentPlaceHolder
protected:
PlaceHolder^ ContentPlaceHolder

Field Value

Type: PlaceHolder
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.FooterLabel Field

Grid Solutions Framework SecurityPortalFooterLabel Field
FooterLabel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Label FooterLabel
Protected FooterLabel As Label
val mutable FooterLabel: Label
var FooterLabel
protected:
Label^ FooterLabel

Field Value

Type: Label
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ForgotPassword Field

Grid Solutions Framework SecurityPortalForgotPassword Field
ForgotPassword control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HyperLink ForgotPassword
Protected ForgotPassword As HyperLink
val mutable ForgotPassword: HyperLink
var ForgotPassword
protected:
HyperLink^ ForgotPassword

Field Value

Type: HyperLink
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.HelpImage Field

Grid Solutions Framework SecurityPortalHelpImage Field
HelpImage control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Image HelpImage
Protected HelpImage As Image
val mutable HelpImage: Image
var HelpImage
protected:
Image^ HelpImage

Field Value

Type: Image
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.HelpLink Field

Grid Solutions Framework SecurityPortalHelpLink Field
HelpLink control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HyperLink HelpLink
Protected HelpLink As HyperLink
val mutable HelpLink: HyperLink
var HelpLink
protected:
HyperLink^ HelpLink

Field Value

Type: HyperLink
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LoginButton Field

Grid Solutions Framework SecurityPortalLoginButton Field
LoginButton control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Button LoginButton
Protected LoginButton As Button
val mutable LoginButton: Button
var LoginButton
protected:
Button^ LoginButton

Field Value

Type: Button
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LoginPanel Field

Grid Solutions Framework SecurityPortalLoginPanel Field
LoginPanel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Panel LoginPanel
Protected LoginPanel As Panel
val mutable LoginPanel: Panel
var LoginPanel
protected:
Panel^ LoginPanel

Field Value

Type: Panel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LoginPassword Field

Grid Solutions Framework SecurityPortalLoginPassword Field
LoginPassword control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox LoginPassword
Protected LoginPassword As TextBox
val mutable LoginPassword: TextBox
var LoginPassword
protected:
TextBox^ LoginPassword

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LoginPasswordValidator Field

Grid Solutions Framework SecurityPortalLoginPasswordValidator Field
LoginPasswordValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator LoginPasswordValidator
Protected LoginPasswordValidator As RequiredFieldValidator
val mutable LoginPasswordValidator: RequiredFieldValidator
var LoginPasswordValidator
protected:
RequiredFieldValidator^ LoginPasswordValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LoginUsername Field

Grid Solutions Framework SecurityPortalLoginUsername Field
LoginUsername control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox LoginUsername
Protected LoginUsername As TextBox
val mutable LoginUsername: TextBox
var LoginUsername
protected:
TextBox^ LoginUsername

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LoginUsernameValidator Field

Grid Solutions Framework SecurityPortalLoginUsernameValidator Field
LoginUsernameValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator LoginUsernameValidator
Protected LoginUsernameValidator As RequiredFieldValidator
val mutable LoginUsernameValidator: RequiredFieldValidator
var LoginUsernameValidator
protected:
RequiredFieldValidator^ LoginUsernameValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LogoImage Field

Grid Solutions Framework SecurityPortalLogoImage Field
LogoImage control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Image LogoImage
Protected LogoImage As Image
val mutable LogoImage: Image
var LogoImage
protected:
Image^ LogoImage

Field Value

Type: Image
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LogoLink Field

Grid Solutions Framework SecurityPortalLogoLink Field
LogoLink control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HyperLink LogoLink
Protected LogoLink As HyperLink
val mutable LogoLink: HyperLink
var LogoLink
protected:
HyperLink^ LogoLink

Field Value

Type: HyperLink
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.MainForm Field

Grid Solutions Framework SecurityPortalMainForm Field
MainForm control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HtmlForm MainForm
Protected MainForm As HtmlForm
val mutable MainForm: HtmlForm
var MainForm
protected:
HtmlForm^ MainForm

Field Value

Type: HtmlForm
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.MessageLabel Field

Grid Solutions Framework SecurityPortalMessageLabel Field
MessageLabel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Label MessageLabel
Protected MessageLabel As Label
val mutable MessageLabel: Label
var MessageLabel
protected:
Label^ MessageLabel

Field Value

Type: Label
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.MyAccountPanel Field

Grid Solutions Framework SecurityPortalMyAccountPanel Field
MyAccountPanel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Panel MyAccountPanel
Protected MyAccountPanel As Panel
val mutable MyAccountPanel: Panel
var MyAccountPanel
protected:
Panel^ MyAccountPanel

Field Value

Type: Panel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.RememberUsername Field

Grid Solutions Framework SecurityPortalRememberUsername Field
RememberUsername control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected CheckBox RememberUsername
Protected RememberUsername As CheckBox
val mutable RememberUsername: CheckBox
var RememberUsername
protected:
CheckBox^ RememberUsername

Field Value

Type: CheckBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetCheckButton Field

Grid Solutions Framework SecurityPortalResetCheckButton Field
ResetCheckButton control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Button ResetCheckButton
Protected ResetCheckButton As Button
val mutable ResetCheckButton: Button
var ResetCheckButton
protected:
Button^ ResetCheckButton

Field Value

Type: Button
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetFinalButton Field

Grid Solutions Framework SecurityPortalResetFinalButton Field
ResetFinalButton control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Button ResetFinalButton
Protected ResetFinalButton As Button
val mutable ResetFinalButton: Button
var ResetFinalButton
protected:
Button^ ResetFinalButton

Field Value

Type: Button
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetPasswordCheckPanel Field

Grid Solutions Framework SecurityPortalResetPasswordCheckPanel Field
ResetPasswordCheckPanel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Panel ResetPasswordCheckPanel
Protected ResetPasswordCheckPanel As Panel
val mutable ResetPasswordCheckPanel: Panel
var ResetPasswordCheckPanel
protected:
Panel^ ResetPasswordCheckPanel

Field Value

Type: Panel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetPasswordFinalPanel Field

Grid Solutions Framework SecurityPortalResetPasswordFinalPanel Field
ResetPasswordFinalPanel control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Panel ResetPasswordFinalPanel
Protected ResetPasswordFinalPanel As Panel
val mutable ResetPasswordFinalPanel: Panel
var ResetPasswordFinalPanel
protected:
Panel^ ResetPasswordFinalPanel

Field Value

Type: Panel
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetPasswordSecurityAnswer Field

Grid Solutions Framework SecurityPortalResetPasswordSecurityAnswer Field
ResetPasswordSecurityAnswer control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox ResetPasswordSecurityAnswer
Protected ResetPasswordSecurityAnswer As TextBox
val mutable ResetPasswordSecurityAnswer: TextBox
var ResetPasswordSecurityAnswer
protected:
TextBox^ ResetPasswordSecurityAnswer

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetPasswordSecurityQuestion Field

Grid Solutions Framework SecurityPortalResetPasswordSecurityQuestion Field
ResetPasswordSecurityQuestion control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Label ResetPasswordSecurityQuestion
Protected ResetPasswordSecurityQuestion As Label
val mutable ResetPasswordSecurityQuestion: Label
var ResetPasswordSecurityQuestion
protected:
Label^ ResetPasswordSecurityQuestion

Field Value

Type: Label
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetPasswordUsername Field

Grid Solutions Framework SecurityPortalResetPasswordUsername Field
ResetPasswordUsername control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected TextBox ResetPasswordUsername
Protected ResetPasswordUsername As TextBox
val mutable ResetPasswordUsername: TextBox
var ResetPasswordUsername
protected:
TextBox^ ResetPasswordUsername

Field Value

Type: TextBox
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetPasswordUsernameValidator Field

Grid Solutions Framework SecurityPortalResetPasswordUsernameValidator Field
ResetPasswordUsernameValidator control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected RequiredFieldValidator ResetPasswordUsernameValidator
Protected ResetPasswordUsernameValidator As RequiredFieldValidator
val mutable ResetPasswordUsernameValidator: RequiredFieldValidator
var ResetPasswordUsernameValidator
protected:
RequiredFieldValidator^ ResetPasswordUsernameValidator

Field Value

Type: RequiredFieldValidator
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.StyleSheet Field

Grid Solutions Framework SecurityPortalStyleSheet Field
StyleSheet control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected HtmlLink StyleSheet
Protected StyleSheet As HtmlLink
val mutable StyleSheet: HtmlLink
var StyleSheet
protected:
HtmlLink^ StyleSheet

Field Value

Type: HtmlLink
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.UpdateButton Field

Grid Solutions Framework SecurityPortalUpdateButton Field
UpdateButton control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Button UpdateButton
Protected UpdateButton As Button
val mutable UpdateButton: Button
var UpdateButton
protected:
Button^ UpdateButton

Field Value

Type: Button
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.WarningImage Field

Grid Solutions Framework SecurityPortalWarningImage Field
WarningImage control.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected Image WarningImage
Protected WarningImage As Image
val mutable WarningImage: Image
var WarningImage
protected:
Image^ WarningImage

Field Value

Type: Image
Remarks
Auto-generated field. To modify move field declaration from designer file to code-behind file.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal Methods

Grid Solutions Framework SecurityPortal Methods

The SecurityPortal type exposes the following members.

Methods
 | Name | Description
Protected method | AddContentTemplate | Called during page initialization to create a collection of content (from content controls) that is handed to a master page, if the current page or master page refers to a master page. (Inherited from Page.)
Protected method | AddedControl | Called after a child control is added to the Controls collection of the Control object. (Inherited from Control.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler) | Registers beginning and ending event handler delegates that do not require state information for an asynchronous page. (Inherited from Page.)
Public method | AddOnPreRenderCompleteAsync(BeginEventHandler, EndEventHandler, Object) | Registers beginning and ending event handler delegates for an asynchronous page. (Inherited from Page.)
Protected method | AddParsedSubObject | Notifies the server control that an element, either XML or HTML, was parsed, and adds the element to the server control's ControlCollection object. (Inherited from Control.)
Protected method | AddWrappedFileDependencies | Adds a list of dependent files that make up the current page. This method is used internally by the ASP.NET page framework and is not intended to be used directly from your code. (Inherited from Page.)
Public method | ApplyStyleSheetSkin | Applies the style properties defined in the page style sheet to the control. (Inherited from Control.)
Protected method | AspCompatBeginProcessRequest | Initiates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AspCompatEndProcessRequest | Terminates a request for Active Server Page (ASP) resources. This method is provided for compatibility with legacy ASP applications. (Inherited from Page.)
Protected method | AsyncPageBeginProcessRequest | Begins processing an asynchronous page request. (Inherited from Page.)
Protected method | AsyncPageEndProcessRequest | Ends processing an asynchronous page request. (Inherited from Page.)
Protected method | BeginRenderTracing | Begins design-time tracing of rendering data. (Inherited from Control.)
Protected method | BuildProfileTree | Gathers information about the server control and delivers it to the Trace property to be displayed when tracing is enabled for the page. (Inherited from Control.)
Protected method | ChangeButton_Click | Changes user password.
Protected method | ClearCachedClientID | Sets the cached ClientID value to null. (Inherited from Control.)
Protected method | ClearChildControlState | Deletes the control-state information for the server control's child controls. (Inherited from Control.)
Protected method | ClearChildState | Deletes the view-state and control-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearChildViewState | Deletes the view-state information for all the server control's child controls. (Inherited from Control.)
Protected method | ClearEffectiveClientIDMode | Sets the ClientIDMode property of the current control instance and of any child controls to Inherit. (Inherited from Control.)
Protected method | Construct | Performs design-time logic. (Inherited from TemplateControl.)
Protected method | CreateChildControls | Called by the ASP.NET page framework to notify server controls that use composition-based implementation to create any child controls they contain in preparation for posting back or rendering. (Inherited from Control.)
Protected method | CreateControlCollection | Creates a new ControlCollection object to hold the child controls (both literal and server) of the server control. (Inherited from Control.)
Protected method | CreateHtmlTextWriter | Creates an HtmlTextWriter object to render the page's content. (Inherited from Page.)
Protected method | CreateResourceBasedLiteralControl | Accesses literal strings stored in a resource. The CreateResourceBasedLiteralControl(Int32, Int32, Boolean) method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | DataBind | Binds a data source to the invoked server control and all its child controls. (Inherited from Control.)
Protected method | DataBind(Boolean) | Binds a data source to the invoked server control and all its child controls with an option to raise the DataBinding event. (Inherited from Control.)
Protected method | DataBindChildren | Binds a data source to the server control's child controls. (Inherited from Control.)
Public method | DesignerInitialize | Performs any initialization of the instance of the Page class that is required by RAD designers. This method is used only at design time. (Inherited from Page.)
Protected method | DeterminePostBackMode | Returns a NameValueCollection of data posted back to the page using either a POST or a GET command. (Inherited from Page.)
Protected method | DeterminePostBackModeUnvalidated | Returns a name-value collection of data that was posted to the page using either a POST or a GET command, without performing ASP.NET request validation on the request. (Inherited from Page.)
Public method | Dispose | Enables a server control to perform final clean up before it is released from memory. (Inherited from Control.)
Protected method | EndRenderTracing | Ends design-time tracing of rendering data. (Inherited from Control.)
Protected method | EnsureChildControls | Determines whether the server control contains child controls. If it does not, it creates child controls. (Inherited from Control.)
Protected method | EnsureID | Creates an identifier for controls that do not have an identifier assigned. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Eval(String) | Evaluates a data-binding expression. (Inherited from TemplateControl.)
Protected method | Eval(String, String) | Evaluates a data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Public method | ExecuteRegisteredAsyncTasks | Starts the execution of an asynchronous task. (Inherited from Page.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindControl(String) | Searches the page naming container for a server control with the specified identifier. (Inherited from Page.)
Protected method | FindControl(String, Int32) | Searches the current naming container for a server control with the specified id and an integer, specified in the pathOffset parameter, which aids in the search. You should not override this version of the FindControl method. (Inherited from Control.)
Public method | Focus | Sets input focus to a control. (Inherited from Control.)
Protected method | FrameworkInitialize | Initializes the control tree during page generation based on the declarative nature of the page. (Inherited from Page.)
Public method | GetDataItem | Gets the data item at the top of the data-binding context stack. (Inherited from Page.)
Protected method | GetDesignModeState | Gets design-time data for a control. (Inherited from Control.)
Protected method | GetGlobalResourceObject(String, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties. (Inherited from TemplateControl.)
Protected method | GetGlobalResourceObject(String, String, Type, String) | Gets an application-level resource object based on the specified ClassKey and ResourceKey properties, object type, and property name of the resource. (Inherited from TemplateControl.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetLocalResourceObject(String) | Gets a page-level resource object based on the specified ResourceKey property. (Inherited from TemplateControl.)
Protected method | GetLocalResourceObject(String, Type, String) | Gets a page-level resource object based on the specified ResourceKey property, object type, and property name. (Inherited from TemplateControl.)
Public method | GetPostBackClientEvent | Obsolete. Gets a reference that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackClientHyperlink | Obsolete. Gets a reference, with javascript: appended to the beginning of it, that can be used in a client event to post back to the server for the specified control and with the specified event arguments. (Inherited from Page.)
Public method | GetPostBackEventReference(Control) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified Control object. (Inherited from Page.)
Public method | GetPostBackEventReference(Control, String) | Obsolete. Returns a string that can be used in a client event to cause postback to the server. The reference string is defined by the specified control that handles the postback and a string argument of additional event information. (Inherited from Page.)
Public method | GetRouteUrl(Object) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters. (Inherited from Control.)
Public method | GetRouteUrl(String, Object) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetRouteUrl(String, RouteValueDictionary) | Gets the URL that corresponds to a set of route parameters and a route name. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | GetTypeHashCode | Retrieves a hash code that is generated by Page objects that are generated at run time. This hash code is unique to the Page object's control hierarchy. (Inherited from Page.)
Public method | GetUniqueIDRelativeTo | Returns the prefixed portion of the UniqueID property of the specified control. (Inherited from Control.)
Public method | GetValidators | Returns a collection of control validators for a specified validation group. (Inherited from Page.)
Protected method | GetWrappedFileDependencies | Returns a list of physical file names that correspond to a list of virtual file locations. (Inherited from Page.)
Public method | HasControls | Determines if the server control contains any child controls. (Inherited from Control.)
Protected method | HasEvents | Returns a value indicating whether events are registered for the control or any child controls. (Inherited from Control.)
Protected method | InitializeCulture | Sets the Culture and UICulture for the current thread of the page. (Inherited from Page.)
Protected method | InitOutputCache(OutputCacheParameters) | Initializes the output cache for the current page request based on an OutputCacheParameters object. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Protected method | InitOutputCache(Int32, String, String, String, OutputCacheLocation, String) | Initializes the output cache for the current page request. (Inherited from Page.)
Public method | IsClientScriptBlockRegistered | Obsolete. Determines whether the client script block with the specified key is registered with the page. (Inherited from Page.)
Protected method | IsLiteralContent | Determines if the server control holds only literal content. (Inherited from Control.)
Public method | IsStartupScriptRegistered | Obsolete. Determines whether the client startup script is registered with the Page object. (Inherited from Page.)
Public method | LoadControl(String) | Loads a Control object from a file based on a specified virtual path. (Inherited from TemplateControl.)
Public method | LoadControl(Type, Object) | Loads a Control object based on a specified type and constructor parameters. (Inherited from TemplateControl.)
Protected method | LoadControlState | Restores control-state information from a previous page request that was saved by the SaveControlState method. (Inherited from Control.)
Protected method | LoadPageStateFromPersistenceMedium | Loads any saved view-state information to the Page object. (Inherited from Page.)
Public method | LoadTemplate | Obtains an instance of the ITemplate interface from an external file. (Inherited from TemplateControl.)
Protected method | LoadViewState | Restores view-state information from a previous page request that was saved by the SaveViewState method. (Inherited from Control.)
Protected method | LoginButton_Click | Logins the user.
Public method | MapPath | Retrieves the physical path that a virtual path, either absolute or relative, or an application-relative path maps to. (Inherited from Page.)
Protected method | MapPathSecure | Retrieves the physical path that a virtual path, either absolute or relative, maps to. (Inherited from Control.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | OnAbortTransaction | Raises the AbortTransaction event. (Inherited from TemplateControl.)
Protected method | OnBubbleEvent | Determines whether the event for the server control is passed up the page's UI server control hierarchy. (Inherited from Control.)
Protected method | OnCommitTransaction | Raises the CommitTransaction event. (Inherited from TemplateControl.)
Protected method | OnDataBinding | Raises the DataBinding event. (Inherited from Control.)
Protected method | OnError | Raises the Error event. (Inherited from TemplateControl.)
Protected method | OnInit | Raises the Init event to initialize the page. (Inherited from Page.)
Protected method | OnInitComplete | Raises the InitComplete event after page initialization. (Inherited from Page.)
Protected method | OnLoad | Raises the Load event. (Inherited from Control.)
Protected method | OnLoadComplete | Raises the LoadComplete event at the end of the page load stage. (Inherited from Page.)
Protected method | OnPreInit | Raises the PreInit event at the beginning of page initialization. (Inherited from Page.)
Protected method | OnPreLoad | Raises the PreLoad event after postback data is loaded into the page server controls but before the OnLoad(EventArgs) event. (Inherited from Page.)
Protected method | OnPreRender | Raises the PreRender event. (Inherited from Control.)
Protected method | OnPreRenderComplete | Raises the PreRenderComplete event after the OnPreRenderComplete(EventArgs) event and before the page is rendered. (Inherited from Page.)
Protected method | OnSaveStateComplete | Raises the SaveStateComplete event after the page state has been saved to the persistence medium. (Inherited from Page.)
Protected method | OnUnload | Raises the Unload event. (Inherited from Control.)
Protected method | OpenFile | Gets a Stream used to read a file. (Inherited from Control.)
Protected method | Page_Load | Initializes the web page.
Public method | ParseControl(String) | Parses an input string into a Control object on the Web Forms page or user control. (Inherited from TemplateControl.)
Public method | ParseControl(String, Boolean) | Parses an input string into a Control object on the ASP.NET Web page or user control. (Inherited from TemplateControl.)
Public method | ProcessRequest | Sets the intrinsic server objects of the Page object, such as the Context, Request, Response, and Application properties. (Inherited from Page.)
Protected method | RaiseBubbleEvent | Assigns any sources of the event and its information to the control's parent. (Inherited from Control.)
Protected method | RaisePostBackEvent | Notifies the server control that caused the postback that it should handle an incoming postback event. (Inherited from Page.)
Public method | ReadStringResource | Reads a string resource. The ReadStringResource method is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | RegisterArrayDeclaration | Obsolete. Declares a value that is declared as an ECMAScript array declaration when the page is rendered. (Inherited from Page.)
Public method | RegisterAsyncTask | Registers a new asynchronous task with the page. (Inherited from Page.)
Public method | RegisterClientScriptBlock | Obsolete. Emits client-side script blocks to the response. (Inherited from Page.)
Public method | RegisterHiddenField | Obsolete. Allows server controls to automatically register a hidden field on the form. The field will be sent to the Page object when the HtmlForm server control is rendered. (Inherited from Page.)
Public method | RegisterOnSubmitStatement | Obsolete. Allows a page to access the client OnSubmit event. The script should be a function call to client code registered elsewhere. (Inherited from Page.)
Public method | RegisterRequiresControlState | Registers a control as one whose control state must be persisted. (Inherited from Page.)
Public method | RegisterRequiresPostBack | Registers a control as one that requires postback handling when the page is posted back to the server. (Inherited from Page.)
Public method | RegisterRequiresRaiseEvent | Registers an ASP.NET server control as one requiring an event to be raised when the control is processed on the Page object. (Inherited from Page.)
Public method | RegisterRequiresViewStateEncryption | Registers a control with the page as one requiring view-state encryption. (Inherited from Page.)
Public method | RegisterStartupScript | Obsolete. Emits a client-side script block in the page response. (Inherited from Page.)
Public method | RegisterViewStateHandler | Causes page view state to be persisted, if called. (Inherited from Page.)
Protected method | RemovedControl | Called after a child control is removed from the Controls collection of the Control object. (Inherited from Control.)
Protected method | Render | Initializes the HtmlTextWriter object and calls on the child controls of the Page to render. (Inherited from Page.)
Protected method | RenderChildren | Outputs the content of a server control's children to a provided HtmlTextWriter object, which writes the content to be rendered on the client. (Inherited from Control.)
Public method | RenderControl(HtmlTextWriter) | Outputs server control content to a provided HtmlTextWriter object and stores tracing information about the control if tracing is enabled. (Inherited from Control.)
Protected method | RenderControl(HtmlTextWriter, ControlAdapter) | Outputs server control content to a provided HtmlTextWriter object using a provided ControlAdapter object. (Inherited from Control.)
Public method | RequiresControlState | Determines whether the specified Control object is registered to participate in control state management. (Inherited from Page.)
Protected method | ResetCheckButton_Click | Checks if user password can be reset.
Protected method | ResetFinalButton_Click | Resets user password.
Protected method | ResolveAdapter | Gets the control adapter responsible for rendering the specified control. (Inherited from Control.)
Public method | ResolveClientUrl | Gets a URL that can be used by the browser. (Inherited from Control.)
Public method | ResolveUrl | Converts a URL into one that is usable on the requesting client. (Inherited from Control.)
Protected method | SaveControlState | Saves any server control state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SavePageStateToPersistenceMedium | Saves any view-state and control-state information for the page. (Inherited from Page.)
Protected method | SaveViewState | Saves any server control view-state changes that have occurred since the time the page was posted back to the server. (Inherited from Control.)
Protected method | SetDesignModeState | Sets design-time data for a control. (Inherited from Control.)
Public method | SetFocus(Control) | Sets the browser focus to the specified control. (Inherited from Page.)
Public method | SetFocus(String) | Sets the browser focus to the control with the specified identifier. (Inherited from Page.)
Public method | SetRenderMethodDelegate | Assigns an event handler delegate to render the server control and its content into its parent control. (Inherited from Control.)
Protected method | SetStringResourcePointer | Sets a pointer to a string resource. The SetStringResourcePointer(Object, Int32) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Public method | SetTraceData(Object, Object) | Sets trace data for design-time tracing of rendering data, using the trace data key and the trace data value. (Inherited from Control.)
Public method | SetTraceData(Object, Object, Object) | Sets trace data for design-time tracing of rendering data, using the traced object, the trace data key, and the trace data value. (Inherited from Control.)
Public method | TestDeviceFilter | Returns a Boolean value indicating whether a device filter applies to the HTTP request. (Inherited from TemplateControl.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Protected method | TrackViewState | Causes tracking of view-state changes to the server control so they can be stored in the server control's StateBag object. This object is accessible through the ViewState property. (Inherited from Control.)
Public method | TryUpdateModelTModel(TModel) | Updates the specified model instance using values from the data-bound control. (Inherited from Page.)
Public method | TryUpdateModelTModel(TModel, IValueProvider) | Updates the model instance using values from the specified value provider. (Inherited from Page.)
Public method | UnregisterRequiresControlState | Stops persistence of control state for the specified control. (Inherited from Page.)
Protected method | UpdateButton_Click | Updates user data.
Public method | UpdateModelTModel(TModel) | Updates the specified model instance using values from the data-bound control. (Inherited from Page.)
Public method | UpdateModelTModel(TModel, IValueProvider) | Updates the specified model instance using values from a specified value provider. (Inherited from Page.)
Public method | Validate | Instructs any validation controls included on the page to validate their assigned information. (Inherited from Page.)
Public method | Validate(String) | Instructs the validation controls in the specified validation group to validate their assigned information. (Inherited from Page.)
Public method | VerifyRenderingInServerForm | Confirms that an HtmlForm control is rendered for the specified ASP.NET server control at run time. (Inherited from Page.)
Protected method | WriteUTF8ResourceString | Writes a resource string to an HtmlTextWriter control. The WriteUTF8ResourceString(HtmlTextWriter, Int32, Int32, Boolean) method is used by generated classes and is not intended for use from within your code. (Inherited from TemplateControl.)
Protected method | XPath(String) | Evaluates an XPath data-binding expression. (Inherited from TemplateControl.)
Protected method | XPath(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution. (Inherited from TemplateControl.)
Protected method | XPath(String, String) | Evaluates an XPath data-binding expression using the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPath(String, String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and the specified format string to display the result. (Inherited from TemplateControl.)
Protected method | XPathSelect(String) | Evaluates an XPath data-binding expression and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Protected method | XPathSelect(String, IXmlNamespaceResolver) | Evaluates an XPath data-binding expression using the specified prefix and namespace mappings for namespace resolution and returns a node collection that implements the IEnumerable interface. (Inherited from TemplateControl.)
Top
Extension Methods
 | Name | Description
Public Extension Method | BringToFront | Brings the page's browser window to the foreground. (Defined by ClientSideExtensions.)
Public Extension Method | Close(String) | Overloaded. Closes the current page when it has finished loading in the browser and returns the specified returnValue to the web page that opened it. (Defined by ClientSideExtensions.)
Public Extension Method | Close(String) | Overloaded. Closes the current page when the control is clicked and returns the specified returnValue to the web page that opened it. (Defined by ClientSideExtensions.)
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | MsgBox(String, String, MsgBoxStyle, Boolean) | Overloaded. Shows a windows application style message box when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | MsgBox(String, String, MsgBoxStyle, Boolean) | Overloaded. Shows a windows application style message box when the control is clicked. (Defined by ClientSideExtensions.)
Public Extension Method | PushToBack | Pushes the page's browser window to the background. (Defined by ClientSideExtensions.)
Public Extension Method | Refresh | Overloaded. Registers the control to perform a page refresh. (Defined by ClientSideExtensions.)
Public Extension Method | Refresh(Boolean) | Overloaded. Registers this page to perform a page refresh. (Defined by ClientSideExtensions.)
Public Extension Method | Show(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modeless popup window for the specified web page url when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | Show(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modeless popup window for the specified web page url when the control is clicked. (Defined by ClientSideExtensions.)
Public Extension Method | ShowDialog(String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modal popup window for the specified web page url when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | ShowDialog(String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a modal popup window for the specified web page url when the control is clicked. (Defined by ClientSideExtensions.)
Public Extension Method | ShowPopup(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a popup for the specified web page url when the page has loaded. (Defined by ClientSideExtensions.)
Public Extension Method | ShowPopup(String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Overloaded. Shows a popup for the specified web page url when the control is clicked. (Defined by ClientSideExtensions.)
Top
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ChangeButton_Click Method

Grid Solutions Framework SecurityPortalChangeButton_Click Method
Changes user password.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void ChangeButton_Click(
    Object sender,
    EventArgs e
)
Protected Sub ChangeButton_Click (
    sender As Object,
    e As EventArgs
)
member ChangeButton_Click :
        sender : Object *
        e : EventArgs -> unit

function ChangeButton_Click(sender, e);
protected:
void ChangeButton_Click(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Source of this event.
e
Type: SystemEventArgs
Arguments of this event.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.LoginButton_Click Method

Grid Solutions Framework SecurityPortalLoginButton_Click Method
Logins the user.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void LoginButton_Click(
    Object sender,
    EventArgs e
)
Protected Sub LoginButton_Click (
    sender As Object,
    e As EventArgs
)
member LoginButton_Click :
        sender : Object *
        e : EventArgs -> unit

function LoginButton_Click(sender, e);
protected:
void LoginButton_Click(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Source of this event.
e
Type: SystemEventArgs
Arguments of this event.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.Page_Load Method

Grid Solutions Framework SecurityPortalPage_Load Method
Initializes the web page.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void Page_Load(
    Object sender,
    EventArgs e
)
Protected Sub Page_Load (
    sender As Object,
    e As EventArgs
)
member Page_Load :
        sender : Object *
        e : EventArgs -> unit

function Page_Load(sender, e);
protected:
void Page_Load(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Source of this event.
e
Type: SystemEventArgs
Arguments of this event.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetCheckButton_Click Method

Grid Solutions Framework SecurityPortalResetCheckButton_Click Method
Checks if user password can be reset.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void ResetCheckButton_Click(
    Object sender,
    EventArgs e
)
Protected Sub ResetCheckButton_Click (
    sender As Object,
    e As EventArgs
)
member ResetCheckButton_Click :
        sender : Object *
        e : EventArgs -> unit

function ResetCheckButton_Click(sender, e);
protected:
void ResetCheckButton_Click(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Source of this event.
e
Type: SystemEventArgs
Arguments of this event.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.ResetFinalButton_Click Method

Grid Solutions Framework SecurityPortalResetFinalButton_Click Method
Resets user password.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void ResetFinalButton_Click(
    Object sender,
    EventArgs e
)
Protected Sub ResetFinalButton_Click (
    sender As Object,
    e As EventArgs
)
member ResetFinalButton_Click :
        sender : Object *
        e : EventArgs -> unit

function ResetFinalButton_Click(sender, e);
protected:
void ResetFinalButton_Click(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Source of this event.
e
Type: SystemEventArgs
Arguments of this event.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal.UpdateButton_Click Method

Grid Solutions Framework SecurityPortalUpdateButton_Click Method
Updates user data.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected void UpdateButton_Click(
    Object sender,
    EventArgs e
)
Protected Sub UpdateButton_Click (
    sender As Object,
    e As EventArgs
)
member UpdateButton_Click :
        sender : Object *
        e : EventArgs -> unit

function UpdateButton_Click(sender, e);
protected:
void UpdateButton_Click(
    Object^ sender,
    EventArgs^ e
)

Parameters

sender
Type: SystemObject
Source of this event.
e
Type: SystemEventArgs
Arguments of this event.
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal Properties

Grid Solutions Framework SecurityPortal Properties

The SecurityPortal type exposes the following members.

Properties
 | Name | Description
Protected property | Adapter | Gets the browser-specific adapter for the control. (Inherited from Control.)
Public property | Application | Gets the HttpApplicationState object for the current Web request. (Inherited from Page.)
Public property | AppRelativeTemplateSourceDirectory | Gets or sets the application-relative virtual directory of the Page or UserControl object that contains this control. (Inherited from Control.)
Public property | AppRelativeVirtualPath | Gets or sets the application-relative, virtual directory path to the file from which the control is parsed and compiled. (Inherited from TemplateControl.)
Protected property | AspCompatMode | Sets a value indicating whether the page can be executed on a single-threaded apartment (STA) thread. (Inherited from Page.)
Protected property | AsyncMode | Sets a value indicating whether the page is processed synchronously or asynchronously. (Inherited from Page.)
Public property | AsyncTimeout | Gets or sets a value indicating the time-out interval used when processing asynchronous tasks. (Inherited from Page.)
Protected property | AutoHandlers | Obsolete. The AutoHandlers property has been deprecated in ASP.NET NET 2.0. It is used by generated classes and is not intended for use within your code. (Inherited from TemplateControl.)
Public property | AutoPostBackControl | Gets or sets the control in the page that is used to perform postbacks. (Inherited from Page.)
Public property | BindingContainer | Gets the control that contains this control's data binding. (Inherited from Control.)
Public property | Buffer | Sets a value indicating whether the page output is buffered. (Inherited from Page.)
Public property | Cache | Gets the Cache object associated with the application in which the page resides. (Inherited from Page.)
Protected property | ChildControlsCreated | Gets a value that indicates whether the server control's child controls have been created. (Inherited from Control.)
Public property | ClientID | Gets the control ID for HTML markup that is generated by ASP.NET. (Inherited from Control.)
Public property | ClientIDMode | Gets or sets the algorithm that is used to generate the value of the ClientID property. (Inherited from Control.)
Protected property | ClientIDSeparator | Gets a character value representing the separator character used in the ClientID property. (Inherited from Control.)
Public property | ClientQueryString | Gets the query string portion of the requested URL. (Inherited from Page.)
Public property | ClientScript | Gets a ClientScriptManager object used to manage, register, and add script to the page. (Inherited from Page.)
Public property | ClientTarget | Gets or sets a value that allows you to override automatic detection of browser capabilities and to specify how a page is rendered for particular browser clients. (Inherited from Page.)
Public property | CodePage | Sets the code page identifier for the current Page. (Inherited from Page.)
Public property | ContentType | Sets the HTTP MIME type for the HttpResponse object associated with the page. (Inherited from Page.)
Protected property | Context | Gets the HttpContext object associated with the page. (Inherited from Page.)
Public property | Controls | Gets a ControlCollection object that represents the child controls for a specified server control in the UI hierarchy. (Inherited from Control.)
Public property | Culture | Sets the culture ID for the Thread object associated with the page. (Inherited from Page.)
Public property | DataItemContainer | Gets a reference to the naming container if the naming container implements IDataItemContainer. (Inherited from Control.)
Public property | DataKeysContainer | Gets a reference to the naming container if the naming container implements IDataKeysControl. (Inherited from Control.)
Protected property | DesignMode | Gets a value indicating whether a control is being used on a design surface. (Inherited from Control.)
Public property | EnableEventValidation | Gets or sets a value indicating whether the page validates postback and callback events. (Inherited from Page.)
Public property | EnableTheming | Gets or sets a Boolean value indicating whether themes apply to the control that is derived from the TemplateControl class. (Inherited from TemplateControl.)
Public property | EnableViewState | Gets or sets a value indicating whether the page maintains its view state, and the view state of any server controls it contains, when the current page request ends. (Inherited from Page.)
Public property | EnableViewStateMac | Gets or sets a value indicating whether ASP.NET should check message authentication codes (MAC) in the page's view state when the page is posted back from the client. (Inherited from Page.)
Public property | ErrorPage | Gets or sets the error page to which the requesting browser is redirected in the event of an unhandled page exception. (Inherited from Page.)
Protected property | Events | Gets a list of event handler delegates for the control. This property is read-only. (Inherited from Control.)
Protected property | FileDependencies | Obsolete. Sets an array of files that the current HttpResponse object is dependent upon. (Inherited from Page.)
Public property | Form | Gets the HTML form for the page. (Inherited from Page.)
Protected property | HasChildViewState | Gets a value indicating whether the current server control's child controls have any saved view-state settings. (Inherited from Control.)
Public property | Header | Gets the document header for the page if the head element is defined with a runat=server in the page declaration. (Inherited from Page.)
Public property | ID | Gets or sets an identifier for a particular instance of the Page class. (Inherited from Page.)
Public property | IdSeparator | Gets the character used to separate control identifiers when building a unique ID for a control on a page. (Inherited from Page.)
Public property | IsAsync | Gets a value indicating whether the page is processed asynchronously. (Inherited from Page.)
Public property | IsCallback | Gets a value that indicates whether the page request is the result of a callback. (Inherited from Page.)
Protected property | IsChildControlStateCleared | Gets a value indicating whether controls contained within this control have control state. (Inherited from Control.)
Public property | IsCrossPagePostBack | Gets a value indicating whether the page is involved in a cross-page postback. (Inherited from Page.)
Public property | IsPostBack | Gets a value that indicates whether the page is being rendered for the first time or is being loaded in response to a postback. (Inherited from Page.)
Public property | IsPostBackEventControlRegistered | Gets a value that indicates whether the control in the page that performs postbacks has been registered. (Inherited from Page.)
Public property | IsReusable | Gets a value indicating whether the Page object can be reused. (Inherited from Page.)
Protected property | IsTrackingViewState | Gets a value that indicates whether the server control is saving changes to its view state. (Inherited from Control.)
Public property | IsValid | Gets a value indicating whether page validation succeeded. (Inherited from Page.)
Protected property | IsViewStateEnabled | Gets a value indicating whether view state is enabled for this control. (Inherited from Control.)
Public property | Items | Gets a list of objects stored in the page context. (Inherited from Page.)
Public property | LCID | Sets the locale identifier for the Thread object associated with the page. (Inherited from Page.)
Protected property | LoadViewStateByID | Gets a value indicating whether the control participates in loading its view state by ID instead of index. (Inherited from Control.)
Public property | MaintainScrollPositionOnPostBack | Gets or sets a value indicating whether to return the user to the same position in the client browser after postback. This property replaces the obsolete SmartNavigation property. (Inherited from Page.)
Public property | Master | Gets the master page that determines the overall look of the page. (Inherited from Page.)
Public property | MasterPageFile | Gets or sets the virtual path of the master page. (Inherited from Page.)
Public property | MaxPageStateFieldLength | Gets or sets the maximum length for the page's state field. (Inherited from Page.)
Public property | MetaDescription | Gets or sets the content of the "description" meta element. (Inherited from Page.)
Public property | MetaKeywords | Gets or sets the content of the "keywords" meta element. (Inherited from Page.)
Public property | ModelBindingExecutionContext | Gets the model binding execution context. (Inherited from Page.)
Public property | ModelState | Gets the model state dictionary object that contains the state of the model and of model-binding validation. (Inherited from Page.)
Public property | NamingContainer | Gets a reference to the server control's naming container, which creates a unique namespace for differentiating between server controls with the same ID property value. (Inherited from Control.)
Public property | Page | Gets a reference to the Page instance that contains the server control. (Inherited from Control.)
Public property | PageAdapter | Gets the adapter that renders the page for the specific requesting browser. (Inherited from Page.)
Protected property | PageStatePersister | Gets the PageStatePersister object associated with the page. (Inherited from Page.)
Public property | Parent | Gets a reference to the server control's parent control in the page control hierarchy. (Inherited from Control.)
Public property | PreviousPage | Gets the page that transferred control to the current page. (Inherited from Page.)
Public property | RenderingCompatibility | Gets a value that specifies the ASP.NET version that rendered HTML will be compatible with. (Inherited from Control.)
Public property | Request | Gets the HttpRequest object for the requested page. (Inherited from Page.)
Public property | Response | Gets the HttpResponse object associated with the Page object. This object allows you to send HTTP response data to a client and contains information about that response. (Inherited from Page.)
Public property | ResponseEncoding | Sets the encoding language for the current HttpResponse object. (Inherited from Page.)
Public property | RouteData | Gets the RouteData value of the current RequestContext instance. (Inherited from Page.)
Public property | Server | Gets the Server object, which is an instance of the HttpServerUtility class. (Inherited from Page.)
Public property | Session | Gets the current Session object provided by ASP.NET. (Inherited from Page.)
Public property | Site | Gets information about the container that hosts the current control when rendered on a design surface. (Inherited from Control.)
Public property | SkinID | Gets or sets the skin to apply to the control. (Inherited from Control.)
Public property | SkipFormActionValidation | Gets or sets a value that indicates whether the query string value is validated. (Inherited from Page.)
Public property | SmartNavigation | Obsolete. Gets or sets a value indicating whether smart navigation is enabled. This property is deprecated. (Inherited from Page.)
Public property | StyleSheetTheme | Gets or sets the name of the theme that is applied to the page early in the page life cycle. (Inherited from Page.)
Protected property | SupportAutoEvents | Gets a value indicating whether the TemplateControl control supports automatic events. (Inherited from TemplateControl.)
Public property | TemplateControl | Gets or sets a reference to the template that contains this control. (Inherited from Control.)
Public property | TemplateSourceDirectory | Gets the virtual directory of the Page or UserControl that contains the current server control. (Inherited from Control.)
Public property | Theme | Gets or sets the name of the page theme. (Inherited from Page.)
Public property | Title | Gets or sets the title for the page. (Inherited from Page.)
Public property | Trace | Gets the TraceContext object for the current Web request. (Inherited from Page.)
Public property | TraceEnabled | Sets a value indicating whether tracing is enabled for the Page object. (Inherited from Page.)
Public property | TraceModeValue | Sets the mode in which trace statements are displayed on the page. (Inherited from Page.)
Protected property | TransactionMode | Sets the level of transaction support for the page. (Inherited from Page.)
Public property | UICulture | Sets the user interface (UI) ID for the Thread object associated with the page. (Inherited from Page.)
Protected property | UniqueFilePathSuffix | Gets a unique suffix to append to the file path for caching browsers. (Inherited from Page.)
Public property | UniqueID | Gets the unique, hierarchically qualified identifier for the server control. (Inherited from Control.)
Public property | UnobtrusiveValidationMode | Gets or sets a value that indicates whether unobtrusive JavaScript is used for client-side validation. (Inherited from Page.)
Public property | User | Gets information about the user making the page request. (Inherited from Page.)
Public property | ValidateRequestMode | Gets or sets a value that indicates whether the page checks client input from the browser for potentially dangerous values. (Inherited from Page.)
Public property | Validators | Gets a collection of all validation controls contained on the requested page. (Inherited from Page.)
Protected property | ViewState | Gets a dictionary of state information that allows you to save and restore the view state of a server control across multiple requests for the same page. (Inherited from Control.)
Public property | ViewStateEncryptionMode | Gets or sets the encryption mode of the view state. (Inherited from Page.)
Protected property | ViewStateIgnoresCase | Gets a value that indicates whether the StateBag object is case-insensitive. (Inherited from Control.)
Public property | ViewStateMode | Gets or sets the view-state mode of this control. (Inherited from Control.)
Public property | ViewStateUserKey | Assigns an identifier to an individual user in the view-state variable associated with the current page. (Inherited from Page.)
Public property | Visible | Gets or sets a value indicating whether the Page object is rendered. (Inherited from Page.)
Top
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityPortal Events

Grid Solutions Framework SecurityPortal Events

The SecurityPortal type exposes the following members.

Events
 | Name | Description
Public event | AbortTransaction | Occurs when a user ends a transaction. (Inherited from TemplateControl.)
Public event | CommitTransaction | Occurs when a transaction completes. (Inherited from TemplateControl.)
Public event | DataBinding | Occurs when the server control binds to a data source. (Inherited from Control.)
Public event | Disposed | Occurs when a server control is released from memory, which is the last stage of the server control lifecycle when an ASP.NET page is requested. (Inherited from Control.)
Public event | Error | Occurs when an unhandled exception is thrown. (Inherited from TemplateControl.)
Public event | Init | Occurs when the server control is initialized, which is the first step in its lifecycle. (Inherited from Control.)
Public event | InitComplete | Occurs when page initialization is complete. (Inherited from Page.)
Public event | Load | Occurs when the server control is loaded into the Page object. (Inherited from Control.)
Public event | LoadComplete | Occurs at the end of the load stage of the page's life cycle. (Inherited from Page.)
Public event | PreInit | Occurs at the beginning of page initialization. (Inherited from Page.)
Public event | PreLoad | Occurs before the page Load event. (Inherited from Page.)
Public event | PreRender | Occurs after the Control object is loaded but prior to rendering. (Inherited from Control.)
Public event | PreRenderComplete | Occurs before the page content is rendered. (Inherited from Page.)
Public event | SaveStateComplete | Occurs after the page has completed saving all view state and control state information for the page and controls on the page. (Inherited from Page.)
Public event | Unload | Occurs when the server control is unloaded from memory. (Inherited from Control.)
Top
See Also

Reference

SecurityPortal Class
GSF.Web.Embedded Namespace


SecurityService Class

Grid Solutions Framework SecurityService Class
Embedded WCF service that can be used for securing applications using role-based security.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
GSF.AdaptersAdapter
GSF.ServiceModelSelfHostingService
GSF.Web.EmbeddedSecurityService

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AspNetCompatibilityRequirementsAttribute(RequirementsMode = AspNetCompatibilityRequirementsMode.Allowed)]
public class SecurityService : SelfHostingService,
    ISecurityService, ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings
<AspNetCompatibilityRequirementsAttribute(RequirementsMode := AspNetCompatibilityRequirementsMode.Allowed)>
Public Class SecurityService
    Inherits SelfHostingService
    Implements ISecurityService, ISelfHostingService, IAdapter, ISupportLifecycle,
    IDisposable, IProvideStatus, IPersistSettings
[<AspNetCompatibilityRequirementsAttribute(RequirementsMode = AspNetCompatibilityRequirementsMode.Allowed)>]
type SecurityService =
    class
        inherit SelfHostingService
        interface ISecurityService
        interface ISelfHostingService
        interface IAdapter
        interface ISupportLifecycle
        interface IDisposable
        interface IProvideStatus
        interface IPersistSettings
    end
GSF.Web.Embedded.SecurityService = function();

Type.createClass(
    'GSF.Web.Embedded.SecurityService',
    GSF.ServiceModel.SelfHostingService,
    GSF.Web.Embedded.ISecurityService,
    GSF.ServiceModel.ISelfHostingService,
    GSF.Adapters.IAdapter,
    GSF.ISupportLifecycle,
    IDisposable,
    GSF.IProvideStatus,
    GSF.Configuration.IPersistSettings);
[AspNetCompatibilityRequirementsAttribute(RequirementsMode = AspNetCompatibilityRequirementsMode::Allowed)]
public ref class SecurityService : public SelfHostingService,
    ISecurityService, ISelfHostingService, IAdapter, ISupportLifecycle, IDisposable,
    IProvideStatus, IPersistSettings

The SecurityService type exposes the following members.

Constructors
 | Name | Description
Public method | SecurityService | Initializes a new instance of the SecurityService class
Top
Methods
 | Name | Description
Public method | Authenticate | Authenticates a user and caches the security context upon successful authentication for subsequent use.
Public method | ChangePassword | Changes user password.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | GetUserData | Returns information about the current user.
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Inherited from SelfHostingService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Inherited from SelfHostingService.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | RefreshUserData | Refreshes and returns information about the current user.
Public method | ResetPassword | Resets user password.
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Inherited from SelfHostingService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
Remarks
This list shows the endpoints exposed by SecurityService:
URI | Protocol
~/SecurityService.svc/soap | SOAP 1.1
~/SecurityService.svc/rest | REST
Examples
This example shows how to consume the REST endpoint of SecurityService using jQuery:
Copy
<script src="jquery.js" type="text/javascript" />
<script language="javascript" type="text/javascript">
    $(document).ready(function () { login(); });

    function login() {
        $.get("SecurityService.svc/rest/getuserdata", loginCallback);
    }

    function loginCallback(data) {
        var user = new UserData(data);
        if (!user.isAuthenticated) {
            alert('Access is denied.');
        }
        else {
            alert('Welcome ' + user.firstName + '!');
        }
    }

    function UserData(xml) {
        this.username = $(xml).find('Username').text();
        this.password = $(xml).find('Password').text();
        this.firstName = $(xml).find('FirstName').text();
        this.lastName = $(xml).find('LastName').text();
        this.companyName = $(xml).find('CompanyName').text();
        this.phoneNumber = $(xml).find('PhoneNumber').text();
        this.emailAddress = $(xml).find('EmailAddress').text();
        this.securityQuestion = $(xml).find('SecurityQuestion').text();
        this.securityAnswer = $(xml).find('SecurityAnswer').text();
        this.passwordChangeDateTime = $(xml).find('PasswordChangeDateTime').text();
        this.accountCreatedDateTime = $(xml).find('AccountCreatedDateTime').text();
        this.isDefined = $(xml).find('IsDefined').text() === 'true';
        this.isExternal = $(xml).find('IsExternal').text() === 'true';
        this.isDisabled = $(xml).find('IsDisabled').text() === 'true';
        this.isLockedOut = $(xml).find('IsLockedOut').text() === 'true';
        this.isAuthenticated = $(xml).find('IsAuthenticated').text() === 'true';
        // Retrieve user groups.
        this.groups = groups = new Array();
        $(xml).find('Group').each(function () { groups.push($(this).text()); });
        // Retrieve user roles.
        this.roles = roles = new Array();
        $(xml).find('Role').each(function () { roles.push($(this).text()); });
    }
</script>
See Also

Reference

GSF.Web.Embedded Namespace


SecurityService Constructor

Grid Solutions Framework SecurityService Constructor
Initializes a new instance of the SecurityService class

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityService()
Public Sub New
new : unit -> SecurityService
GSF.Web.Embedded.SecurityService = function();
public:
SecurityService()
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService Methods

Grid Solutions Framework SecurityService Methods

The SecurityService type exposes the following members.

Methods
 | Name | Description
Public method | Authenticate | Authenticates a user and caches the security context upon successful authentication for subsequent use.
Public method | ChangePassword | Changes user password.
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all the resources used by the Adapter. (Inherited from Adapter.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the web service and optionally releases the managed resources. (Inherited from SelfHostingService.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases the unmanaged resources before the web service is reclaimed by GC. (Inherited from SelfHostingService.)
Public method | GetFlashPolicy | Gets policy stream for Flash applications. (Inherited from SelfHostingService.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetServiceAddress | Gets an address where the ServiceHost will host the service. (Inherited from SelfHostingService.)
Public method | GetSilverlightPolicy | Gets policy stream for Silverlight applications. (Inherited from SelfHostingService.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUnusedPort | Get an unused port number. (Inherited from SelfHostingService.)
Public method | GetUserData | Returns information about the current user.
Public method | Initialize | Initializes the web service. (Inherited from SelfHostingService.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitializeServiceHost | Initializes the ServiceHost. (Inherited from SelfHostingService.)
Public method | LoadSettings | Loads saved web service settings from the config file if the PersistSettings property is set to true. (Inherited from SelfHostingService.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnDisposed | Raises the Disposed event. (Inherited from Adapter.)
Protected method | OnExecutionException | Raises the ExecutionException event. (Inherited from Adapter.)
Protected method | OnServiceHostCreated | Raises the ServiceHostCreated event. (Inherited from SelfHostingService.)
Protected method | OnServiceHostStarted | Raises the ServiceHostStarted event. (Inherited from SelfHostingService.)
Protected method | OnServiceProcessException | Raises the ServiceProcessException event. (Inherited from SelfHostingService.)
Protected method | OnStatusUpdate | Raises the StatusUpdate event. (Inherited from Adapter.)
Public method | RefreshUserData | Refreshes and returns information about the current user.
Public method | ResetPassword | Resets user password.
Public method | SaveSettings | Saves web service settings to the config file if the PersistSettings property is set to true. (Inherited from SelfHostingService.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService.Authenticate Method

Grid Solutions Framework SecurityServiceAuthenticate Method
Authenticates a user and caches the security context upon successful authentication for subsequent use.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserData Authenticate(
    string username,
    string password
)
Public Function Authenticate (
    username As String,
    password As String
) As UserData
abstract Authenticate :
        username : string *
        password : string -> UserData
override Authenticate :
        username : string *
        password : string -> UserData
function Authenticate(username, password);
public:
virtual UserData^ Authenticate(
    String^ username,
    String^ password
) sealed

Parameters

username
Type: SystemString
Username of the user.
password
Type: SystemString
Password of the user.

Return Value

Type: UserData
An UserData object of the user.

Implements

ISecurityServiceAuthenticate(String, String)
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService.ChangePassword Method

Grid Solutions Framework SecurityServiceChangePassword Method
Changes user password.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ChangePassword(
    string oldPassword,
    string newPassword
)
Public Function ChangePassword (
    oldPassword As String,
    newPassword As String
) As Boolean
abstract ChangePassword :
        oldPassword : string *
        newPassword : string -> bool
override ChangePassword :
        oldPassword : string *
        newPassword : string -> bool
function ChangePassword(oldPassword, newPassword);
public:
virtual bool ChangePassword(
    String^ oldPassword,
    String^ newPassword
) sealed

Parameters

oldPassword
Type: SystemString
User's current password.
newPassword
Type: SystemString
User's new password.

Return Value

Type: Boolean
true if the password is changed, otherwise false.

Implements

ISecurityServiceChangePassword(String, String)
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService.GetUserData Method

Grid Solutions Framework SecurityServiceGetUserData Method
Returns information about the current user.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserData GetUserData()
Public Function GetUserData As UserData
abstract GetUserData : unit -> UserData
override GetUserData : unit -> UserData
function GetUserData();
public:
virtual UserData^ GetUserData() sealed

Return Value

Type: UserData
An UserData object of the user if user's security context has been initialized, otherwise null.

Implements

ISecurityServiceGetUserData
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService.RefreshUserData Method

Grid Solutions Framework SecurityServiceRefreshUserData Method
Refreshes and returns information about the current user.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public UserData RefreshUserData()
Public Function RefreshUserData As UserData
abstract RefreshUserData : unit -> UserData
override RefreshUserData : unit -> UserData
function RefreshUserData();
public:
virtual UserData^ RefreshUserData() sealed

Return Value

Type: UserData
An UserData object of the user if user's security context has been initialized, otherwise null.

Implements

ISecurityServiceRefreshUserData
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService.ResetPassword Method

Grid Solutions Framework SecurityServiceResetPassword Method
Resets user password.

Namespace: GSF.Web.Embedded
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ResetPassword(
    string securityAnswer
)
Public Function ResetPassword (
    securityAnswer As String
) As Boolean
abstract ResetPassword :
        securityAnswer : string -> bool
override ResetPassword :
        securityAnswer : string -> bool
function ResetPassword(securityAnswer);
public:
virtual bool ResetPassword(
    String^ securityAnswer
) sealed

Parameters

securityAnswer
Type: SystemString
Answer to user's security question.

Return Value

Type: Boolean
true if password is reset, otherwise false.

Implements

ISecurityServiceResetPassword(String)
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService Properties

Grid Solutions Framework SecurityService Properties

The SecurityService type exposes the following members.

Properties
 | Name | Description
Public property | AllowCrossDomainAccess | Gets or sets flag that indicates if web services will enable cross-domain access for Silverlight and Flash applications. (Inherited from SelfHostingService.)
Public property | AllowedDomainList | Gets or sets comma separated list of allowed domains when AllowCrossDomainAccess is true. Use * for domain wildcards, e.g., *.consoto.com. (Inherited from SelfHostingService.)
Public property | ContractInterface | Gets or sets the FullName of the contract interface implemented by the web service. (Inherited from SelfHostingService.)
Public property | Domain | Gets the AppDomain in which the Adapter is executing. (Inherited from Adapter.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the web service is currently enabled. (Inherited from SelfHostingService.)
Public property | Endpoints | Gets or sets a semicolon delimited list of URIs where the web service can be accessed. (Inherited from SelfHostingService.)
Public property | HostFile | Gets or sets the path to the file where the Adapter is housed. (Inherited from Adapter.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from Adapter.)
Public property | MemoryUsage | Gets the memory utilization of the Adapter in bytes if executing in a separate AppDomain, otherwise NaN. (Inherited from Adapter.)
Public property | Name | Gets the unique identifier of the Adapter. (Inherited from Adapter.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether Adapter settings are to be saved to the config file. (Inherited from Adapter.)
Public property | ProcessorUsage | Gets the % processor utilization of the Adapter if executing in a separate AppDomain otherwise NaN. (Inherited from Adapter.)
Public property | PublishMetadata | Gets or sets a boolean value that indicates whether web service metadata is to made available at all web service Endpoints. (Inherited from SelfHostingService.)
Public property | SecurityPolicy | Gets or sets the FullName of IAuthorizationPolicy to be used for securing all web service Endpoints. (Inherited from SelfHostingService.)
Public property | ServiceEnabled | Gets or sets a boolean value that indicates whether the web service is to be enabled at startup. (Inherited from SelfHostingService.)
Public property | ServiceHost | Gets the WebServiceHost hosting the web service. (Inherited from SelfHostingService.)
Public property | SettingsCategory | Gets or sets the category under which Adapter settings are to be saved to the config file if the PersistSettings property is set to true. (Inherited from Adapter.)
Public property | Singleton | Gets or sets a boolean value that indicates whether the ServiceHost will use the current instance of the web service for processing requests or base the web service instance creation on InstanceContextMode specified in its ServiceBehaviorAttribute. (Inherited from SelfHostingService.)
Public property | Status | Gets the descriptive status of the Adapter. (Inherited from Adapter.)
Public property | TypeName | Gets or sets the text representation of the Adapter's TypeName. (Inherited from Adapter.)
Public property | WindowsAuthentication | Gets or sets a boolean value that indicates whether Windows Authentication is to be enabled. (Inherited from SelfHostingService.)
Top
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


SecurityService Events

Grid Solutions Framework SecurityService Events

The SecurityService type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when Adapter is disposed. (Inherited from Adapter.)
Public event | ExecutionException | Occurs when the IAdapter encounters an Exception during execution. (Inherited from Adapter.)
Public event | ServiceHostCreated | Occurs when the ServiceHost has been created with the specified Endpoints. (Inherited from SelfHostingService.)
Public event | ServiceHostStarted | Occurs when the ServiceHost has can process requests via all of its endpoints. (Inherited from SelfHostingService.)
Public event | ServiceProcessException | Occurs when an Exception is encountered when processing a request. (Inherited from SelfHostingService.)
Public event | StatusUpdate | Occurs when the Adapter wants to provide a status update. (Inherited from Adapter.)
Top
See Also

Reference

SecurityService Class
GSF.Web.Embedded Namespace


GSF.Web.Hosting Namespace

Grid Solutions Framework GSF.Web.Hosting Namespace
Contains classes that make-up the framework for serving content embedded in .NET assemblies over the web.
Classes
 | Class | Description
 | EmbeddedResourceFileAttribute | Attribute indicating the location of an embedded resource that should be served by the EmbeddedResourcePathProvider.
Public class | EmbeddedResourcePathProvider | A VirtualPathProvider that allows serving pages from embedded resources.
Public class | EmbeddedResourceVirtualFile | Represents a file object in embedded resource space.
Public class | VirtualFileBaseCollection | A strongly typed KeyedCollectionTKey, TItem where each element is a VirtualFileBase and is keyed off of the VirtualPath property.


EmbeddedResourceFileAttribute Class

Grid Solutions Framework EmbeddedResourceFileAttribute Class
Attribute indicating the location of an embedded resource that should be served by the EmbeddedResourcePathProvider.
Inheritance Hierarchy
SystemObject
SystemAttribute
GSF.Web.HostingEmbeddedResourceFileAttribute

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = true)]
public sealed class EmbeddedResourceFileAttribute : Attribute
<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple := true)>
Public NotInheritable Class EmbeddedResourceFileAttribute
    Inherits Attribute
[<SealedAttribute>]
[<AttributeUsageAttribute(AttributeTargets.Assembly, AllowMultiple = true)>]
type EmbeddedResourceFileAttribute =
    class
        inherit Attribute
    end
GSF.Web.Hosting.EmbeddedResourceFileAttribute = function();

Type.createClass(
    'GSF.Web.Hosting.EmbeddedResourceFileAttribute',
    Attribute);
[AttributeUsageAttribute(AttributeTargets::Assembly, AllowMultiple = true)]
public ref class EmbeddedResourceFileAttribute sealed : public Attribute

The EmbeddedResourceFileAttribute type exposes the following members.

Constructors
Name | Description
EmbeddedResourceFileAttribute | Initializes a new instance of the EmbeddedResourceFileAttribute class.
Top
Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ResourceNamespace | Gets the namespace for the embedded resource.
Public property | ResourcePath | Gets the path to the embedded resource.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
Remarks

This attribute is used by the EmbeddedResourcePathProvider module/path provider to retrieve the list of embedded resources from an assembly that should be considered a part of the virtual filesystem.

Examples

Below is an example of what it might look like to embed a web form and a user control in an assembly to be served up with the EmbeddedResourcePathProvider:

C#
Copy
[assembly: EmbeddedResourceFileAttribute("MyNamespace.WebForm1.aspx", "MyNamespace")]
[assembly: EmbeddedResourceFileAttribute("MyNamespace.UserControl1.ascx", "MyNamespace")]
See Also

Reference

GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourceFileAttribute Constructor

Grid Solutions Framework EmbeddedResourceFileAttribute Constructor
Initializes a new instance of the EmbeddedResourceFileAttribute class.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EmbeddedResourceFileAttribute(
    string resourcePath,
    string resourceNamespace
)
Public Sub New (
    resourcePath As String,
    resourceNamespace As String
)
new :
        resourcePath : string *
        resourceNamespace : string -> EmbeddedResourceFileAttribute
GSF.Web.Hosting.EmbeddedResourceFileAttribute = function(resourcePath, resourceNamespace);
public:
EmbeddedResourceFileAttribute(
    String^ resourcePath,
    String^ resourceNamespace
)

Parameters

resourcePath
Type: SystemString
The path to the embedded resource. Used to get the resource as a stream from the assembly.
resourceNamespace
Type: SystemString
The namespace the resource is in. This will generally be removed from the full resource path to calculate the "application path" for the embedded resource.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if resourcePath or resourceNamespace is .
ArgumentOutOfRangeException | Thrown if resourcePath is Empty or if it only consists of periods and/or spaces.
Remarks

Both resourcePath and resourceNamespace will be processed to have leading and trailing periods and spaces removed. If resourcePath ends up being empty, an ArgumentOutOfRangeException is thrown. No exception is thrown if resourceNamespace turns out empty.

Examples

If the resourcePath is RootNS.SubNS.AppRoot.Folder.File.aspx and the resourceNamespace is RootNS.SubNS.AppRoot, the virtual "path" to the embedded file will be Folder.File.aspx (which will be converted by the EmbeddedResourcePathProvider to ~/Folder/File.aspx).

See Also

Reference

EmbeddedResourceFileAttribute Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceFileAttribute


EmbeddedResourceFileAttribute Methods

Grid Solutions Framework EmbeddedResourceFileAttribute Methods

The EmbeddedResourceFileAttribute type exposes the following members.

Methods
 | Name | Description
Public method | Equals | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
Public method | GetHashCode | Returns the hash code for this instance. (Inherited from Attribute.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IsDefaultAttribute | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
Public method | Match | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EmbeddedResourceFileAttribute Class
GSF.Web.Hosting Namespace


EmbeddedResourceFileAttribute Properties

Grid Solutions Framework EmbeddedResourceFileAttribute Properties

The EmbeddedResourceFileAttribute type exposes the following members.

Properties
 | Name | Description
Public property | ResourceNamespace | Gets the namespace for the embedded resource.
Public property | ResourcePath | Gets the path to the embedded resource.
Public property | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Top
See Also

Reference

EmbeddedResourceFileAttribute Class
GSF.Web.Hosting Namespace


EmbeddedResourceFileAttribute.ResourceNamespace Property

Grid Solutions Framework EmbeddedResourceFileAttributeResourceNamespace Property
Gets the namespace for the embedded resource.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ResourceNamespace { get; }
Public ReadOnly Property ResourceNamespace As String
    Get
member ResourceNamespace : string with get

function get_ResourceNamespace();

public:
property String^ ResourceNamespace {
    String^ get ();
}

Property Value

Type: String
A String with the embedded resource namespace.
Remarks

This namespace will be removed from the full ResourcePath to create the virtual application path for the resource.

See Also

Reference

EmbeddedResourceFileAttribute Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceFileAttribute


EmbeddedResourceFileAttribute.ResourcePath Property

Grid Solutions Framework EmbeddedResourceFileAttributeResourcePath Property
Gets the path to the embedded resource.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ResourcePath { get; }
Public ReadOnly Property ResourcePath As String
    Get
member ResourcePath : string with get

function get_ResourcePath();

public:
property String^ ResourcePath {
    String^ get ();
}

Property Value

Type: String
A String with the full path to an embedded resource in the associated assembly.
Remarks

This path will be used to retrieve the resource from the assembly and serve it up.

See Also

Reference

EmbeddedResourceFileAttribute Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceFileAttribute


EmbeddedResourcePathProvider Class

Grid Solutions Framework EmbeddedResourcePathProvider Class
A VirtualPathProvider that allows serving pages from embedded resources.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Web.HostingVirtualPathProvider
GSF.Web.HostingEmbeddedResourcePathProvider

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EmbeddedResourcePathProvider : VirtualPathProvider
Public Class EmbeddedResourcePathProvider
    Inherits VirtualPathProvider
type EmbeddedResourcePathProvider =
    class
        inherit VirtualPathProvider
    end
GSF.Web.Hosting.EmbeddedResourcePathProvider = function();

Type.createClass(
    'GSF.Web.Hosting.EmbeddedResourcePathProvider',
    VirtualPathProvider);
public ref class EmbeddedResourcePathProvider : public VirtualPathProvider

The EmbeddedResourcePathProvider type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedResourcePathProvider | Initializes a new instance of the EmbeddedResourcePathProvider class
Top
Methods
 | Name | Description
Public method | CombineVirtualPaths | Combines a base path with a relative path to return a complete path to a virtual resource. (Inherited from VirtualPathProvider.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DirectoryExists | Gets a value that indicates whether a directory exists in the virtual file system. (Inherited from VirtualPathProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Gets a value that indicates whether a file exists in the virtual file system. (Overrides VirtualPathProviderFileExists(String).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheDependency | Creates a cache dependency based on the specified virtual paths. (Overrides VirtualPathProviderGetCacheDependency(String, IEnumerable, DateTime).)
Public method | GetCacheKey | Returns a cache key to use for the specified virtual path. (Inherited from VirtualPathProvider.)
 | GetConfiguredAssemblyNames | Gets the names of the configured assemblies from configuration.
Public method | GetDirectory | Gets a virtual directory from the virtual file system. (Inherited from VirtualPathProvider.)
Public method | GetFile | Gets a virtual file from the virtual file system. (Overrides VirtualPathProviderGetFile(String).)
Public method | GetFileHash | Returns a hash of the specified virtual paths. (Inherited from VirtualPathProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes the VirtualPathProvider instance. (Overrides VirtualPathProviderInitialize.)
Public method | InitializeLifetimeService | Gives the VirtualPathProvider object an infinite lifetime by preventing a lease from being created. (Inherited from VirtualPathProvider.)
 | MapResourceToWebApplication | Maps an embedded resource ID into a web application relative path (~/path).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ProcessEmbeddedFiles | Reads in the embedded files from an assembly an processes them into the virtual file system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ConfigKeyAllowOverrides | Appsettings key that indicates if filesystem files should override embedded files.
ConfigSectionName | The name of the configuration section containing the list of assemblies that should participate in the virtual filesystem.
Top
Properties
 | Name | Description
Public property | AllowOverrides | Gets a value indicating if embedded files can be overridden.
Public property | Files | Gets the collection of files served by this provider.
Protected property | Previous | Gets a reference to a previously registered VirtualPathProvider object in the compilation system. (Inherited from VirtualPathProvider.)
Top
Remarks

ASP.NET retrieves files to serve via the HostingEnvironment. Rather than opening a file via File, you ask the HostingEnvironment for its VirtualPathProvider and ask that provider for the file. The provider will return a VirtualFile reference that will allow you to open a stream on the file and use the contents.

This implementation of VirtualPathProvider allows you to serve files to ASP.NET through embedded resources. Rather than deploying your web forms, user controls, etc., to the file system, you can embed the files as resources right in your assembly and deploy just your assembly. The VirtualPathProvider mechanism will take care of the rest.

Caution note Caution
Most VirtualPathProvider implementations handle both directories and files. This implementation handles only files. As such, if the VirtualPathProvider is used to enumerate available files (as in directory browsing), files provided via embedded resource will not be included.

To use this VirtualPathProvider, you need to do four things to your web application.

First, you need to set all of the files you want to serve from your assembly as embedded resources. By default, web forms and so forth are set as "content" files; setting them as embedded resources will package them into your assembly.

Second, in your AssemblyInfo.cs file (or whichever file you are declaring your assembly attributes in) you need to add one EmbeddedResourceFileAttribute for every file you plan on serving. This lets the provider know which embedded resources are available and which are actually resources for other purposes. Your assembly attributes will look something like this:

C#
Copy
[assembly: EmbeddedResourceFileAttribute("MyNamespace.WebForm1.aspx", "MyNamespace")]
[assembly: EmbeddedResourceFileAttribute("MyNamespace.UserControl1.ascx", "MyNamespace")]

Third, you need to register this provider at application startup so ASP.NET knows to use it. In your Global.asax, during Application_OnStart, put the following:

C#
Copy
System.Web.Hosting.HostingEnvironment.RegisterVirtualPathProvider(new EmbeddedResourcePathProvider());

Fourth, in your web.config file, you need to set up a configuration section called embeddedFileAssemblies that lets the provider know which assemblies should be queried for embedded files. A sample configuration section looks like this:

Copy
<configuration>
  <configSections>
    <section name="embeddedFileAssemblies" type="GSF.Configuration.StringCollectionSectionHandler, GSF.Web.Hosting.EmbeddedResourcePathProvider"/>
  </configSections>
  <embeddedFileAssemblies>
    <add value="My.Web.Assembly"/>
  </embeddedFileAssemblies>
  <!-- ... other web.config items ... -->
</configuration>

Once you have that set up, you're ready to serve files from embedded resources. Simply deploy your application without putting the embedded resource files into the filesystem. When you visit the embedded locations, the provider will automatically retrieve the proper embedded resource.

File paths are mapped into the application using the EmbeddedResourceFileAttribute declarations and the MapResourceToWebApplication(String, String) method. This allows you to set up your web application as normal in Visual Studio and the folder structure, which automatically generates namespaces for your embedded resources, will translate into virtual folders in the embedded resource "filesystem."

By default, files that are embedded as resources will take precedence over files in the filesystem. If you would like the files in the filesystem to take precedence (that is, if you would like to allow the filesystem to "override" embedded files), you can set a key in the appSettings section of your web.config file that enables overrides:

Copy
<configuration>
  <!-- ... other web.config items ... -->
  <appSettings>
    <add key="GSF.Web.Hosting.EmbeddedResourcePathProvider.AllowOverrides" value="true"/>
  </appSettings>
</configuration>

For more information on virtual filesystems in ASP.NET, check out VirtualPathProvider.

See Also

Reference

GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceFileAttribute
System.Web.HostingVirtualPathProvider


EmbeddedResourcePathProvider Constructor

Grid Solutions Framework EmbeddedResourcePathProvider Constructor
Initializes a new instance of the EmbeddedResourcePathProvider class

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EmbeddedResourcePathProvider()
Public Sub New
new : unit -> EmbeddedResourcePathProvider
GSF.Web.Hosting.EmbeddedResourcePathProvider = function();
public:
EmbeddedResourcePathProvider()
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace


EmbeddedResourcePathProvider Fields

Grid Solutions Framework EmbeddedResourcePathProvider Fields

The EmbeddedResourcePathProvider type exposes the following members.

Fields
Name | Description
ConfigKeyAllowOverrides | Appsettings key that indicates if filesystem files should override embedded files.
ConfigSectionName | The name of the configuration section containing the list of assemblies that should participate in the virtual filesystem.
Top
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace


EmbeddedResourcePathProvider.ConfigKeyAllowOverrides Field

Grid Solutions Framework EmbeddedResourcePathProviderConfigKeyAllowOverrides Field
Appsettings key that indicates if filesystem files should override embedded files.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string ConfigKeyAllowOverrides
Public Const ConfigKeyAllowOverrides As String
static val mutable ConfigKeyAllowOverrides: string
var GSF.Web.Hosting.EmbeddedResourcePathProvider.ConfigKeyAllowOverrides
public:
literal String^ ConfigKeyAllowOverrides

Field Value

Type: String
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourcePathProvider.ConfigSectionName Field

Grid Solutions Framework EmbeddedResourcePathProviderConfigSectionName Field
The name of the configuration section containing the list of assemblies that should participate in the virtual filesystem.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string ConfigSectionName
Public Const ConfigSectionName As String
static val mutable ConfigSectionName: string
var GSF.Web.Hosting.EmbeddedResourcePathProvider.ConfigSectionName
public:
literal String^ ConfigSectionName

Field Value

Type: String
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourcePathProvider Methods

Grid Solutions Framework EmbeddedResourcePathProvider Methods

The EmbeddedResourcePathProvider type exposes the following members.

Methods
 | Name | Description
Public method | CombineVirtualPaths | Combines a base path with a relative path to return a complete path to a virtual resource. (Inherited from VirtualPathProvider.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | DirectoryExists | Gets a value that indicates whether a directory exists in the virtual file system. (Inherited from VirtualPathProvider.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Public method | FileExists | Gets a value that indicates whether a file exists in the virtual file system. (Overrides VirtualPathProviderFileExists(String).)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetCacheDependency | Creates a cache dependency based on the specified virtual paths. (Overrides VirtualPathProviderGetCacheDependency(String, IEnumerable, DateTime).)
Public method | GetCacheKey | Returns a cache key to use for the specified virtual path. (Inherited from VirtualPathProvider.)
 | GetConfiguredAssemblyNames | Gets the names of the configured assemblies from configuration.
Public method | GetDirectory | Gets a virtual directory from the virtual file system. (Inherited from VirtualPathProvider.)
Public method | GetFile | Gets a virtual file from the virtual file system. (Overrides VirtualPathProviderGetFile(String).)
Public method | GetFileHash | Returns a hash of the specified virtual paths. (Inherited from VirtualPathProvider.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | Initialize | Initializes the VirtualPathProvider instance. (Overrides VirtualPathProviderInitialize.)
Public method | InitializeLifetimeService | Gives the VirtualPathProvider object an infinite lifetime by preventing a lease from being created. (Inherited from VirtualPathProvider.)
 | MapResourceToWebApplication | Maps an embedded resource ID into a web application relative path (~/path).
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | ProcessEmbeddedFiles | Reads in the embedded files from an assembly an processes them into the virtual file system.
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace


EmbeddedResourcePathProvider.FileExists Method

Grid Solutions Framework EmbeddedResourcePathProviderFileExists Method
Gets a value that indicates whether a file exists in the virtual file system.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override bool FileExists(
    string virtualPath
)
Public Overrides Function FileExists (
    virtualPath As String
) As Boolean
abstract FileExists :
        virtualPath : string -> bool
override FileExists :
        virtualPath : string -> bool
function FileExists(virtualPath);
public:
virtual bool FileExists(
    String^ virtualPath
) override

Parameters

virtualPath
Type: SystemString
The path to the virtual file.

Return Value

Type: Boolean
if the file exists in the virtual file system; otherwise, .
Exceptions
Exception | Condition
ArgumentNullException | Thrown if virtualPath is .
ArgumentOutOfRangeException | Thrown if virtualPath is Empty.
Remarks

This override checks to see if the embedded resource file exists in memory. If so, this method will return . If not, it returns the value from the Previous virtual path provider.

See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider
VirtualPathProviderFileExists(String)


EmbeddedResourcePathProvider.GetCacheDependency Method

Grid Solutions Framework EmbeddedResourcePathProviderGetCacheDependency Method
Creates a cache dependency based on the specified virtual paths.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override CacheDependency GetCacheDependency(
    string virtualPath,
    IEnumerable virtualPathDependencies,
    DateTime utcStart
)
Public Overrides Function GetCacheDependency (
    virtualPath As String,
    virtualPathDependencies As IEnumerable,
    utcStart As DateTime
) As CacheDependency
abstract GetCacheDependency :
        virtualPath : string *
        virtualPathDependencies : IEnumerable *
        utcStart : DateTime -> CacheDependency
override GetCacheDependency :
        virtualPath : string *
        virtualPathDependencies : IEnumerable *
        utcStart : DateTime -> CacheDependency
function GetCacheDependency(virtualPath, virtualPathDependencies, utcStart);
public:
virtual CacheDependency^ GetCacheDependency(
    String^ virtualPath,
    IEnumerable^ virtualPathDependencies,
    DateTime utcStart
) override

Parameters

virtualPath
Type: SystemString
The path to the primary virtual resource.
virtualPathDependencies
Type: System.CollectionsIEnumerable
An array of paths to other resources required by the primary virtual resource.
utcStart
Type: SystemDateTime
The UTC time at which the virtual resources were read.

Return Value

Type: CacheDependency
A CacheDependency object for the specified virtual resources.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if virtualPath is .
ArgumentOutOfRangeException | Thrown if virtualPath is Empty.
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider
VirtualPathProviderGetCacheDependency(String, IEnumerable, DateTime)


EmbeddedResourcePathProvider.GetConfiguredAssemblyNames Method

Grid Solutions Framework EmbeddedResourcePathProviderGetConfiguredAssemblyNames Method
Gets the names of the configured assemblies from configuration.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected static string[] GetConfiguredAssemblyNames()
Protected Shared Function GetConfiguredAssemblyNames As String()
static member GetConfiguredAssemblyNames : unit -> string[]

GSF.Web.Hosting.EmbeddedResourcePathProvider.GetConfiguredAssemblyNames = function();
protected:
static array<String^>^ GetConfiguredAssemblyNames()

Return Value

Type: String
A StringCollection with the names of the configured assemblies that should participate in this path provider.
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourcePathProvider.GetFile Method

Grid Solutions Framework EmbeddedResourcePathProviderGetFile Method
Gets a virtual file from the virtual file system.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override VirtualFile GetFile(
    string virtualPath
)
Public Overrides Function GetFile (
    virtualPath As String
) As VirtualFile
abstract GetFile :
        virtualPath : string -> VirtualFile
override GetFile :
        virtualPath : string -> VirtualFile
function GetFile(virtualPath);
public:
virtual VirtualFile^ GetFile(
    String^ virtualPath
) override

Parameters

virtualPath
Type: SystemString
The path to the virtual file.

Return Value

Type: VirtualFile
A descendent of the VirtualFile class that represents a file in the virtual file system.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if virtualPath is .
ArgumentOutOfRangeException | Thrown if virtualPath is Empty.
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider
VirtualPathProviderGetFile(String)


EmbeddedResourcePathProvider.Initialize Method

Grid Solutions Framework EmbeddedResourcePathProviderInitialize Method
Initializes the VirtualPathProvider instance.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Initialize()
Protected Overrides Sub Initialize
abstract Initialize : unit -> unit
override Initialize : unit -> unit
function Initialize();
protected:
virtual void Initialize() override
Remarks

The set of assemblies configured to provide embedded resource files are queried for EmbeddedResourceFileAttribute attributes. For each one present, the associated embedded resource is added to the virtual file system served by this provider.

See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider
VirtualPathProviderInitialize


EmbeddedResourcePathProvider.MapResourceToWebApplication Method

Grid Solutions Framework EmbeddedResourcePathProviderMapResourceToWebApplication Method
Maps an embedded resource ID into a web application relative path (~/path).

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected static string MapResourceToWebApplication(
    string baseNamespace,
    string resourcePath
)
Protected Shared Function MapResourceToWebApplication (
    baseNamespace As String,
    resourcePath As String
) As String
static member MapResourceToWebApplication :
        baseNamespace : string *
        resourcePath : string -> string

GSF.Web.Hosting.EmbeddedResourcePathProvider.MapResourceToWebApplication = function(baseNamespace, resourcePath);
protected:
static String^ MapResourceToWebApplication(
    String^ baseNamespace,
    String^ resourcePath
)

Parameters

baseNamespace
Type: SystemString
The base namespace of the resource to map.
resourcePath
Type: SystemString
The fully qualified embedded resource path to map.

Return Value

Type: String
The mapped path of the resource into the web application.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if baseNamespace or resourcePath is .
ArgumentOutOfRangeException Thrown if baseNamespace or resourcePath:
  • Is Empty.
  • Start or end with period.
  • Contain two or more periods together (like MyNamespace..MySubnamespace).
Remarks

The baseNamespace is stripped from the front of the resourcePath and all but the last period in the remaining resourcePath is replaced with the directory separator character ('/'). Finally, that path is mapped into a web application relative path.

The filename being mapped must have an extension associated with it, and that extension may not have a period in it. Only one period will be kept in the mapped filename - others will be assumed to be directory separators. If a filename has multiple extensions (i.e., My.Custom.config), it will not map properly - it will end up being ~/My/Custom.config.

If baseNamespace does not occur at the start of the resourcePath, an InvalidOperationException is thrown.

Examples

Given a baseNamespace of MyNamespace, this method will process resourcePath as follows:

resourcePath value | Mapping in Web App
MyNamespace.Config.MyFile.config | ~/Config/MyFile.config
MyNamespace.MyPage.aspx | ~/MyPage.aspx
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourcePathProvider.ProcessEmbeddedFiles Method

Grid Solutions Framework EmbeddedResourcePathProviderProcessEmbeddedFiles Method
Reads in the embedded files from an assembly an processes them into the virtual file system.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ProcessEmbeddedFiles(
    string assemblyName
)
Protected Overridable Sub ProcessEmbeddedFiles (
    assemblyName As String
)
abstract ProcessEmbeddedFiles :
        assemblyName : string -> unit
override ProcessEmbeddedFiles :
        assemblyName : string -> unit
function ProcessEmbeddedFiles(assemblyName);
protected:
virtual void ProcessEmbeddedFiles(
    String^ assemblyName
)

Parameters

assemblyName
Type: SystemString
The name of the Assembly to load and process.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if assemblyName is .
ArgumentOutOfRangeException | Thrown if assemblyName is Empty.
FileNotFoundException | Thrown if the Assembly indicated by assemblyName is not found.
Remarks

The assemblyName will be passed to Load(String) so the associated assembly can be processed. If the assembly is not found, a FileNotFoundException is thrown.

Once the assembly is retrieved, it is queried for EmbeddedResourceFileAttribute instances. For each one found, the associated resources are processed into virtual files that will be stored in Files for later use.

See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider
EmbeddedResourcePathProviderInitialize


EmbeddedResourcePathProvider Properties

Grid Solutions Framework EmbeddedResourcePathProvider Properties

The EmbeddedResourcePathProvider type exposes the following members.

Properties
 | Name | Description
Public property | AllowOverrides | Gets a value indicating if embedded files can be overridden.
Public property | Files | Gets the collection of files served by this provider.
Protected property | Previous | Gets a reference to a previously registered VirtualPathProvider object in the compilation system. (Inherited from VirtualPathProvider.)
Top
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace


EmbeddedResourcePathProvider.AllowOverrides Property

Grid Solutions Framework EmbeddedResourcePathProviderAllowOverrides Property
Gets a value indicating if embedded files can be overridden.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual bool AllowOverrides { get; }
Public Overridable ReadOnly Property AllowOverrides As Boolean
    Get
abstract AllowOverrides : bool with get
override AllowOverrides : bool with get
function get_AllowOverrides();

public:
virtual property bool AllowOverrides {
    bool get ();
}

Property Value

Type: Boolean
if embedded files can be overridden by other files (e.g., if filesystem files override embedded files); if not. Defaults to .
Remarks

This property uses the AppSettings key ConfigKeyAllowOverrides to determine if overrides are allowed. If the key is present, it is parsed to a Boolean and that value is returned. If the key is not present or if any error occurs during the parsing, is returned.

See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourcePathProvider.Files Property

Grid Solutions Framework EmbeddedResourcePathProviderFiles Property
Gets the collection of files served by this provider.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public virtual VirtualFileBaseCollection Files { get; }
Public Overridable ReadOnly Property Files As VirtualFileBaseCollection
    Get
abstract Files : VirtualFileBaseCollection with get
override Files : VirtualFileBaseCollection with get
function get_Files();

public:
virtual property VirtualFileBaseCollection^ Files {
    VirtualFileBaseCollection^ get ();
}

Property Value

Type: VirtualFileBaseCollection
A VirtualFileBaseCollection that contains all of the files served by this provider.
See Also

Reference

EmbeddedResourcePathProvider Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourceVirtualFile Class

Grid Solutions Framework EmbeddedResourceVirtualFile Class
Represents a file object in embedded resource space.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.Web.HostingVirtualFileBase
System.Web.HostingVirtualFile
GSF.Web.HostingEmbeddedResourceVirtualFile

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class EmbeddedResourceVirtualFile : VirtualFile
Public Class EmbeddedResourceVirtualFile
    Inherits VirtualFile
type EmbeddedResourceVirtualFile =
    class
        inherit VirtualFile
    end
GSF.Web.Hosting.EmbeddedResourceVirtualFile = function();

Type.createClass(
    'GSF.Web.Hosting.EmbeddedResourceVirtualFile',
    VirtualFile);
public ref class EmbeddedResourceVirtualFile : public VirtualFile

The EmbeddedResourceVirtualFile type exposes the following members.

Constructors
 | Name | Description
Public method | EmbeddedResourceVirtualFile | Initializes a new instance of the EmbeddedResourceVirtualFile class.
Top
Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Gives a VirtualFileBase instance an infinite lifetime by preventing a lease from being created. (Inherited from VirtualFileBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Open | Returns a read-only stream to the virtual resource. (Overrides VirtualFileOpen.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ContainingAssembly | Gets a reference to the assembly containing the virtual file.
Public property | IsDirectory | Gets a value that indicates that this is a virtual resource that should be treated as a file. (Inherited from VirtualFile.)
Public property | Name | Gets the display name of the virtual resource. (Inherited from VirtualFileBase.)
Public property | ResourcePath | Gets the path to the embedded resource in the containing assembly.
Public property | VirtualPath | Gets the virtual file path. (Inherited from VirtualFileBase.)
Top
Remarks

This type is used by the EmbeddedResourcePathProvider to serve embedded resources as virtual files. The properties on the file can be used to retrieve an embedded resource stream from the ContainingAssembly at the appropriate ResourcePath using reflection. As part of the VirtualFile interface, you can do this easily via Open.

For more information on embedded resource virtual filesystem usage, see EmbeddedResourcePathProvider

See Also

Reference

GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourcePathProvider


EmbeddedResourceVirtualFile Constructor

Grid Solutions Framework EmbeddedResourceVirtualFile Constructor
Initializes a new instance of the EmbeddedResourceVirtualFile class.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public EmbeddedResourceVirtualFile(
    string virtualPath,
    Assembly containingAssembly,
    string resourcePath
)
Public Sub New (
    virtualPath As String,
    containingAssembly As Assembly,
    resourcePath As String
)
new :
        virtualPath : string *
        containingAssembly : Assembly *
        resourcePath : string -> EmbeddedResourceVirtualFile
GSF.Web.Hosting.EmbeddedResourceVirtualFile = function(virtualPath, containingAssembly, resourcePath);
public:
EmbeddedResourceVirtualFile(
    String^ virtualPath,
    Assembly^ containingAssembly,
    String^ resourcePath
)

Parameters

virtualPath
Type: SystemString
The virtual path to the resource represented by this instance.
containingAssembly
Type: System.ReflectionAssembly
The Assembly containing the resource represented by this instance.
resourcePath
Type: SystemString
The path to the embedded resource in the containingAssembly.
Exceptions
Exception | Condition
ArgumentNullException | Thrown if containingAssembly or resourcePath is .
ArgumentOutOfRangeException | Thrown if resourcePath is Empty.
See Also

Reference

EmbeddedResourceVirtualFile Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceVirtualFile


EmbeddedResourceVirtualFile Methods

Grid Solutions Framework EmbeddedResourceVirtualFile Methods

The EmbeddedResourceVirtualFile type exposes the following members.

Methods
 | Name | Description
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | InitializeLifetimeService | Gives a VirtualFileBase instance an infinite lifetime by preventing a lease from being created. (Inherited from VirtualFileBase.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Public method | Open | Returns a read-only stream to the virtual resource. (Overrides VirtualFileOpen.)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

EmbeddedResourceVirtualFile Class
GSF.Web.Hosting Namespace


EmbeddedResourceVirtualFile.Open Method

Grid Solutions Framework EmbeddedResourceVirtualFileOpen Method
Returns a read-only stream to the virtual resource.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override Stream Open()
Public Overrides Function Open As Stream
abstract Open : unit -> Stream
override Open : unit -> Stream
function Open();
public:
virtual Stream^ Open() override

Return Value

Type: Stream
A read-only stream to the virtual file.
See Also

Reference

EmbeddedResourceVirtualFile Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceVirtualFile
VirtualFileOpen


EmbeddedResourceVirtualFile Properties

Grid Solutions Framework EmbeddedResourceVirtualFile Properties

The EmbeddedResourceVirtualFile type exposes the following members.

Properties
 | Name | Description
Public property | ContainingAssembly | Gets a reference to the assembly containing the virtual file.
Public property | IsDirectory | Gets a value that indicates that this is a virtual resource that should be treated as a file. (Inherited from VirtualFile.)
Public property | Name | Gets the display name of the virtual resource. (Inherited from VirtualFileBase.)
Public property | ResourcePath | Gets the path to the embedded resource in the containing assembly.
Public property | VirtualPath | Gets the virtual file path. (Inherited from VirtualFileBase.)
Top
See Also

Reference

EmbeddedResourceVirtualFile Class
GSF.Web.Hosting Namespace


EmbeddedResourceVirtualFile.ContainingAssembly Property

Grid Solutions Framework EmbeddedResourceVirtualFileContainingAssembly Property
Gets a reference to the assembly containing the virtual file.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public Assembly ContainingAssembly { get; }
Public ReadOnly Property ContainingAssembly As Assembly
    Get
member ContainingAssembly : Assembly with get

function get_ContainingAssembly();

public:
property Assembly^ ContainingAssembly {
    Assembly^ get ();
}

Property Value

Type: Assembly
A Assembly that contains the embedded resource with the file contents.
See Also

Reference

EmbeddedResourceVirtualFile Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceVirtualFile


EmbeddedResourceVirtualFile.ResourcePath Property

Grid Solutions Framework EmbeddedResourceVirtualFileResourcePath Property
Gets the path to the embedded resource in the containing assembly.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string ResourcePath { get; }
Public ReadOnly Property ResourcePath As String
    Get
member ResourcePath : string with get

function get_ResourcePath();

public:
property String^ ResourcePath {
    String^ get ();
}

Property Value

Type: String
A String that indicates an embedded resource in the ContainingAssembly that represents the file for this instance.
See Also

Reference

EmbeddedResourceVirtualFile Class
GSF.Web.Hosting Namespace
GSF.Web.HostingEmbeddedResourceVirtualFile


VirtualFileBaseCollection Class

Grid Solutions Framework VirtualFileBaseCollection Class
A strongly typed KeyedCollectionTKey, TItem where each element is a VirtualFileBase and is keyed off of the VirtualPath property.
Inheritance Hierarchy
SystemObject
System.Collections.ObjectModelCollection VirtualFileBase
System.Collections.ObjectModelKeyedCollection String, VirtualFileBase
GSF.Web.HostingVirtualFileBaseCollection

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class VirtualFileBaseCollection : KeyedCollection<string, VirtualFileBase>
Public Class VirtualFileBaseCollection
    Inherits KeyedCollection(Of String, VirtualFileBase)
type VirtualFileBaseCollection =
    class
        inherit KeyedCollection<string, VirtualFileBase>
    end
GSF.Web.Hosting.VirtualFileBaseCollection = function();

Type.createClass(
    'GSF.Web.Hosting.VirtualFileBaseCollection',
    KeyedCollection`2);
public ref class VirtualFileBaseCollection : public KeyedCollection<String^, VirtualFileBase^>

The VirtualFileBaseCollection type exposes the following members.

Constructors
 | Name | Description
Public method | VirtualFileBaseCollection | Initializes a new instance of the VirtualFileBaseCollection class that uses a case-insensitive comparer.
Public method | VirtualFileBaseCollection(IEqualityComparerString) | Initializes a new instance of the VirtualFileBaseCollection class that uses the specified equality comparer.
Public method | VirtualFileBaseCollection(IEqualityComparerString, Int32) | Initializes a new instance of the VirtualFileBaseCollection class that uses the specified equality comparer.
Top
Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection VirtualFileBase .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection VirtualFileBase .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, VirtualFileBase .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, VirtualFileBase .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Public property | ItemTKey | Gets the element with the specified key. (Inherited from KeyedCollection String, VirtualFileBase .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection VirtualFileBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection VirtualFileBase .)
Top
Remarks

The default constructor for this collection does a culture-invariant case-insensitive comparison on the keys. This allows for proper case-insensitive web-oriented behavior that is generally expected.

See Also

Reference

GSF.Web.Hosting Namespace
System.Web.HostingVirtualFileBase


VirtualFileBaseCollection Constructor

Grid Solutions Framework VirtualFileBaseCollection Constructor
Overload List
 | Name | Description
Public method | VirtualFileBaseCollection | Initializes a new instance of the VirtualFileBaseCollection class that uses a case-insensitive comparer.
Public method | VirtualFileBaseCollection(IEqualityComparerString) | Initializes a new instance of the VirtualFileBaseCollection class that uses the specified equality comparer.
Public method | VirtualFileBaseCollection(IEqualityComparerString, Int32) | Initializes a new instance of the VirtualFileBaseCollection class that uses the specified equality comparer.
Top
See Also

Reference

VirtualFileBaseCollection Class
GSF.Web.Hosting Namespace


VirtualFileBaseCollection Constructor

Grid Solutions Framework VirtualFileBaseCollection Constructor
Initializes a new instance of the VirtualFileBaseCollection class that uses a case-insensitive comparer.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public VirtualFileBaseCollection()
Public Sub New
new : unit -> VirtualFileBaseCollection
GSF.Web.Hosting.VirtualFileBaseCollection = function();
public:
VirtualFileBaseCollection()
See Also

Reference

VirtualFileBaseCollection Class
VirtualFileBaseCollection Overload
GSF.Web.Hosting Namespace
GSF.Web.HostingVirtualFileBaseCollection


VirtualFileBaseCollection Constructor (IEqualityComparer(String))

Grid Solutions Framework VirtualFileBaseCollection Constructor (IEqualityComparerString)
Initializes a new instance of the VirtualFileBaseCollection class that uses the specified equality comparer.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public VirtualFileBaseCollection(
    IEqualityComparer<string> comparer
)
Public Sub New (
    comparer As IEqualityComparer(Of String)
)
new :
        comparer : IEqualityComparer<string> -> VirtualFileBaseCollection
GSF.Web.Hosting.VirtualFileBaseCollection = function(comparer);
public:
VirtualFileBaseCollection(
    IEqualityComparer<String^>^ comparer
)

Parameters

comparer
Type: System.Collections.GenericIEqualityComparer String
The implementation of the IEqualityComparerT generic interface to use when comparing keys, or to use the default equality comparer for the type of the key, obtained from Default.
See Also

Reference

VirtualFileBaseCollection Class
VirtualFileBaseCollection Overload
GSF.Web.Hosting Namespace
GSF.Web.HostingVirtualFileBaseCollection


VirtualFileBaseCollection Constructor (IEqualityComparer(String), Int32)

Grid Solutions Framework VirtualFileBaseCollection Constructor (IEqualityComparerString, Int32)
Initializes a new instance of the VirtualFileBaseCollection class that uses the specified equality comparer.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public VirtualFileBaseCollection(
    IEqualityComparer<string> comparer,
    int dictionaryCreationThreshold
)
Public Sub New (
    comparer As IEqualityComparer(Of String),
    dictionaryCreationThreshold As Integer
)
new :
        comparer : IEqualityComparer<string> *
        dictionaryCreationThreshold : int -> VirtualFileBaseCollection
GSF.Web.Hosting.VirtualFileBaseCollection = function(comparer, dictionaryCreationThreshold);
public:
VirtualFileBaseCollection(
    IEqualityComparer<String^>^ comparer,
    int dictionaryCreationThreshold
)

Parameters

comparer
Type: System.Collections.GenericIEqualityComparer String
The implementation of the IEqualityComparerT generic interface to use when comparing keys, or to use the default equality comparer for the type of the key, obtained from Default.
dictionaryCreationThreshold
Type: SystemInt32
The number of elements the collection can hold without creating a lookup dictionary (0 creates the lookup dictionary when the first item is added), or ?1 to specify that a lookup dictionary is never created.
See Also

Reference

VirtualFileBaseCollection Class
VirtualFileBaseCollection Overload
GSF.Web.Hosting Namespace
GSF.Web.HostingVirtualFileBaseCollection


VirtualFileBaseCollection Methods

Grid Solutions Framework VirtualFileBaseCollection Methods

The VirtualFileBaseCollection type exposes the following members.

Methods
 | Name | Description
Public method | Add | Adds an object to the end of the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected method | ChangeItemKey | Changes the key associated with the specified element in the lookup dictionary. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Clear | Removes all elements from the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected method | ClearItems | Removes all elements from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Contains(TKey) | Determines whether the collection contains an element with the specified key. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Contains(T) | Determines whether an element is in the CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | CopyTo | Copies the entire CollectionT to a compatible one-dimensional Array, starting at the specified index of the target array. (Inherited from Collection VirtualFileBase .)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | GetEnumerator | Returns an enumerator that iterates through the CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Protected method | GetKeyForItem | Extracts the key from the specified element. (Overrides KeyedCollectionTKey, TItemGetKeyForItem(TItem).)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | IndexOf | Searches for the specified object and returns the zero-based index of the first occurrence within the entire CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | Insert | Inserts an element into the CollectionT at the specified index. (Inherited from Collection VirtualFileBase .)
Protected method | InsertItem | Inserts an element into the KeyedCollectionTKey, TItem at the specified index. (Inherited from KeyedCollection String, VirtualFileBase .)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | Remove(TKey) | Removes the element with the specified key from the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | Remove(T) | Removes the first occurrence of a specific object from the CollectionT. (Inherited from Collection VirtualFileBase .)
Public method | RemoveAt | Removes the element at the specified index of the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected method | RemoveItem | Removes the element at the specified index of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Protected method | SetItem | Replaces the item at the specified index with the specified item. (Inherited from KeyedCollection String, VirtualFileBase .)
Public method | ToString | Returns a string that represents the current object. (Inherited from Object.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

VirtualFileBaseCollection Class
GSF.Web.Hosting Namespace


VirtualFileBaseCollection.GetKeyForItem Method

Grid Solutions Framework VirtualFileBaseCollectionGetKeyForItem Method
Extracts the key from the specified element.

Namespace: GSF.Web.Hosting
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override string GetKeyForItem(
    VirtualFileBase item
)
Protected Overrides Function GetKeyForItem (
    item As VirtualFileBase
) As String
abstract GetKeyForItem :
        item : VirtualFileBase -> string
override GetKeyForItem :
        item : VirtualFileBase -> string
function GetKeyForItem(item);
protected:
virtual String^ GetKeyForItem(
    VirtualFileBase^ item
) override

Parameters

item
Type: System.Web.HostingVirtualFileBase
The VirtualFileBase element from which to extract the key (VirtualPath).

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.Web.Hosting.VirtualFileBaseCollection.GetKeyForItem(System.Web.Hosting.VirtualFileBase)"]

See Also

Reference

VirtualFileBaseCollection Class
GSF.Web.Hosting Namespace
GSF.Web.HostingVirtualFileBaseCollection


VirtualFileBaseCollection Properties

Grid Solutions Framework VirtualFileBaseCollection Properties

The VirtualFileBaseCollection type exposes the following members.

Properties
 | Name | Description
Public property | Comparer | Gets the generic equality comparer that is used to determine equality of keys in the collection. (Inherited from KeyedCollection String, VirtualFileBase .)
Public property | Count | Gets the number of elements actually contained in the CollectionT. (Inherited from Collection VirtualFileBase .)
Protected property | Dictionary | Gets the lookup dictionary of the KeyedCollectionTKey, TItem. (Inherited from KeyedCollection String, VirtualFileBase .)
Public property | ItemTKey | Gets the element with the specified key. (Inherited from KeyedCollection String, VirtualFileBase .)
Public property | ItemInt32 | Gets or sets the element at the specified index. (Inherited from Collection VirtualFileBase .)
Protected property | Items | Gets a IListT wrapper around the CollectionT. (Inherited from Collection VirtualFileBase .)
Top
See Also

Reference

VirtualFileBaseCollection Class
GSF.Web.Hosting Namespace


GSF.Web.UI Namespace

Grid Solutions Framework GSF.Web.UI Namespace

[Missing <summary> documentation for "N:GSF.Web.UI"]

Classes
 | Class | Description
Public class | ClientSideExtensions | Defines javascript client-side extensions for web controls.
Enumerations
 | Enumeration | Description
Public enumeration | MsgBoxStyle | Specifies the buttons to be displayed in a message box.


ClientSideExtensions Class

Grid Solutions Framework ClientSideExtensions Class
Defines javascript client-side extensions for web controls.
Inheritance Hierarchy
SystemObject
GSF.Web.UIClientSideExtensions

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ClientSideExtensions
<ExtensionAttribute>
Public NotInheritable Class ClientSideExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ClientSideExtensions =  class end
GSF.Web.UI.ClientSideExtensions = function();

Type.createClass(
    'GSF.Web.UI.ClientSideExtensions');
[ExtensionAttribute]
public ref class ClientSideExtensions abstract sealed

The ClientSideExtensions type exposes the following members.

Methods
Name | Description
BringToFront | Brings the page's browser window to the foreground.
Close(Control, String) | Closes the current page when the control is clicked and returns the specified returnValue to the web page that opened it.
Close(Page, String) | Closes the current page when it has finished loading in the browser and returns the specified returnValue to the web page that opened it.
JavaScriptDecode | Decodes JavaScript characters from given string.
JavaScriptEncode | Performs JavaScript encoding on given string.
MsgBox(Control, String, String, MsgBoxStyle, Boolean) | Shows a windows application style message box when the control is clicked.
MsgBox(Page, String, String, MsgBoxStyle, Boolean) | Shows a windows application style message box when the page has loaded.
PushToBack | Pushes the page's browser window to the background.
Refresh(Control) | Registers the control to perform a page refresh.
Refresh(Page, Boolean) | Registers this page to perform a page refresh.
SetDefaultButton | Registers a default button to be activated when the ENTER key is pressed inside this textbox.
SetSubmitOnce | Registers the button to be disabled after one click to prevent multiple postbacks.
Show(Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modeless popup window for the specified web page url when the control is clicked.
Show(Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modeless popup window for the specified web page url when the page has loaded.
ShowDialog(Control, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modal popup window for the specified web page url when the control is clicked.
ShowDialog(Page, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modal popup window for the specified web page url when the page has loaded.
ShowPopup(Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Shows a popup for the specified web page url when the control is clicked.
ShowPopup(Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Shows a popup for the specified web page url when the page has loaded.
Top
See Also

Reference

GSF.Web.UI Namespace


ClientSideExtensions Methods

Grid Solutions Framework ClientSideExtensions Methods

The ClientSideExtensions type exposes the following members.

Methods
Name | Description
BringToFront | Brings the page's browser window to the foreground.
Close(Control, String) | Closes the current page when the control is clicked and returns the specified returnValue to the web page that opened it.
Close(Page, String) | Closes the current page when it has finished loading in the browser and returns the specified returnValue to the web page that opened it.
JavaScriptDecode | Decodes JavaScript characters from given string.
JavaScriptEncode | Performs JavaScript encoding on given string.
MsgBox(Control, String, String, MsgBoxStyle, Boolean) | Shows a windows application style message box when the control is clicked.
MsgBox(Page, String, String, MsgBoxStyle, Boolean) | Shows a windows application style message box when the page has loaded.
PushToBack | Pushes the page's browser window to the background.
Refresh(Control) | Registers the control to perform a page refresh.
Refresh(Page, Boolean) | Registers this page to perform a page refresh.
SetDefaultButton | Registers a default button to be activated when the ENTER key is pressed inside this textbox.
SetSubmitOnce | Registers the button to be disabled after one click to prevent multiple postbacks.
Show(Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modeless popup window for the specified web page url when the control is clicked.
Show(Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modeless popup window for the specified web page url when the page has loaded.
ShowDialog(Control, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modal popup window for the specified web page url when the control is clicked.
ShowDialog(Page, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modal popup window for the specified web page url when the page has loaded.
ShowPopup(Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Shows a popup for the specified web page url when the control is clicked.
ShowPopup(Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Shows a popup for the specified web page url when the page has loaded.
Top
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.BringToFront Method

Grid Solutions Framework ClientSideExtensionsBringToFront Method
Brings the page's browser window to the foreground.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void BringToFront(
    this Page page
)
<ExtensionAttribute>
Public Shared Sub BringToFront (
    page As Page
)
static member BringToFront :
        page : Page -> unit

GSF.Web.UI.ClientSideExtensions.BringToFront = function(page);
public:
[ExtensionAttribute]
static void BringToFront(
    Page^ page
)

Parameters

page
Type: System.Web.UIPage
Page to be brought to the foreground.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.Close Method

Grid Solutions Framework ClientSideExtensionsClose Method
Overload List
Name | Description
Close(Control, String) | Closes the current page when the control is clicked and returns the specified returnValue to the web page that opened it.
Close(Page, String) | Closes the current page when it has finished loading in the browser and returns the specified returnValue to the web page that opened it.
Top
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.Close Method (Control, String)

Grid Solutions Framework ClientSideExtensionsClose Method (Control, String)
Closes the current page when the control is clicked and returns the specified returnValue to the web page that opened it.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Close(
    this Control control,
    string returnValue = null
)
<ExtensionAttribute>
Public Shared Sub Close (
    control As Control,
    Optional returnValue As String = Nothing
)
static member Close :
        control : Control *
        ?returnValue : string
(* Defaults:
        let _returnValue = defaultArg returnValue null
*)
-> unit

GSF.Web.UI.ClientSideExtensions.Close = function(control, returnValue);
public:
[ExtensionAttribute]
static void Close(
    Control^ control,
    String^ returnValue = nullptr
)

Parameters

control
Type: System.Web.UIControl
Control that will close the current web page when clicked.
returnValue (Optional)
Type: SystemString
Value to be returned to the parent web page.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
Close Overload
GSF.Web.UI Namespace


ClientSideExtensions.Close Method (Page, String)

Grid Solutions Framework ClientSideExtensionsClose Method (Page, String)
Closes the current page when it has finished loading in the browser and returns the specified returnValue to the web page that opened it.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Close(
    this Page page,
    string returnValue = null
)
<ExtensionAttribute>
Public Shared Sub Close (
    page As Page,
    Optional returnValue As String = Nothing
)
static member Close :
        page : Page *
        ?returnValue : string
(* Defaults:
        let _returnValue = defaultArg returnValue null
*)
-> unit

GSF.Web.UI.ClientSideExtensions.Close = function(page, returnValue);
public:
[ExtensionAttribute]
static void Close(
    Page^ page,
    String^ returnValue = nullptr
)

Parameters

page
Type: System.Web.UIPage
Page to be closed.
returnValue (Optional)
Type: SystemString
Value to be returned to the parent web page.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
Close Overload
GSF.Web.UI Namespace


ClientSideExtensions.JavaScriptDecode Method

Grid Solutions Framework ClientSideExtensionsJavaScriptDecode Method
Decodes JavaScript characters from given string.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string JavaScriptDecode(
    ref string text
)
Public Shared Function JavaScriptDecode (
    ByRef text As String
) As String
static member JavaScriptDecode :
        text : string byref -> string

GSF.Web.UI.ClientSideExtensions.JavaScriptDecode = function(text);
public:
static String^ JavaScriptDecode(
    String^% text
)

Parameters

text
Type: SystemString
The string to be decoded.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.Web.UI.ClientSideExtensions.JavaScriptDecode(System.String@)"]

See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.JavaScriptEncode Method

Grid Solutions Framework ClientSideExtensionsJavaScriptEncode Method
Performs JavaScript encoding on given string.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string JavaScriptEncode(
    ref string text
)
Public Shared Function JavaScriptEncode (
    ByRef text As String
) As String
static member JavaScriptEncode :
        text : string byref -> string

GSF.Web.UI.ClientSideExtensions.JavaScriptEncode = function(text);
public:
static String^ JavaScriptEncode(
    String^% text
)

Parameters

text
Type: SystemString
The string to be encoded.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.Web.UI.ClientSideExtensions.JavaScriptEncode(System.String@)"]

See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.MsgBox Method

Grid Solutions Framework ClientSideExtensionsMsgBox Method
Overload List
Name | Description
MsgBox(Control, String, String, MsgBoxStyle, Boolean) | Shows a windows application style message box when the control is clicked.
MsgBox(Page, String, String, MsgBoxStyle, Boolean) | Shows a windows application style message box when the page has loaded.
Top
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.MsgBox Method (Control, String, String, MsgBoxStyle, Boolean)

Grid Solutions Framework ClientSideExtensionsMsgBox Method (Control, String, String, MsgBoxStyle, Boolean)
Shows a windows application style message box when the control is clicked.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void MsgBox(
    this Control control,
    string prompt,
    string title,
    MsgBoxStyle buttons,
    bool doPostBack = false
)
<ExtensionAttribute>
Public Shared Sub MsgBox (
    control As Control,
    prompt As String,
    title As String,
    buttons As MsgBoxStyle,
    Optional doPostBack As Boolean = false
)
static member MsgBox :
        control : Control *
        prompt : string *
        title : string *
        buttons : MsgBoxStyle *
        ?doPostBack : bool
(* Defaults:
        let _doPostBack = defaultArg doPostBack false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.MsgBox = function(control, prompt, title, buttons, doPostBack);
public:
[ExtensionAttribute]
static void MsgBox(
    Control^ control,
    String^ prompt,
    String^ title,
    MsgBoxStyle buttons,
    bool doPostBack = false
)

Parameters

control
Type: System.Web.UIControl
Control that will show the message box when clicked.
prompt
Type: SystemString
Text that is to be displayed in the message box.
title
Type: SystemString
Title of the message box.
buttons
Type: GSF.Web.UIMsgBoxStyle
Buttons to be displayed in the message box.
doPostBack (Optional)
Type: SystemBoolean
True if a post-back is to be performed when either OK, Retry, or Yes buttons are clicked in the message box, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
MsgBox Overload
GSF.Web.UI Namespace


ClientSideExtensions.MsgBox Method (Page, String, String, MsgBoxStyle, Boolean)

Grid Solutions Framework ClientSideExtensionsMsgBox Method (Page, String, String, MsgBoxStyle, Boolean)
Shows a windows application style message box when the page has loaded.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void MsgBox(
    this Page page,
    string prompt,
    string title,
    MsgBoxStyle buttons,
    bool doPostBack = false
)
<ExtensionAttribute>
Public Shared Sub MsgBox (
    page As Page,
    prompt As String,
    title As String,
    buttons As MsgBoxStyle,
    Optional doPostBack As Boolean = false
)
static member MsgBox :
        page : Page *
        prompt : string *
        title : string *
        buttons : MsgBoxStyle *
        ?doPostBack : bool
(* Defaults:
        let _doPostBack = defaultArg doPostBack false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.MsgBox = function(page, prompt, title, buttons, doPostBack);
public:
[ExtensionAttribute]
static void MsgBox(
    Page^ page,
    String^ prompt,
    String^ title,
    MsgBoxStyle buttons,
    bool doPostBack = false
)

Parameters

page
Type: System.Web.UIPage
Page that will show the message box when loaded.
prompt
Type: SystemString
Text that is to be displayed in the message box.
title
Type: SystemString
Title of the message box.
buttons
Type: GSF.Web.UIMsgBoxStyle
Buttons to be displayed in the message box.
doPostBack (Optional)
Type: SystemBoolean
True if a post-back is to be performed when either OK, Retry, or Yes buttons are clicked in the message box, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
MsgBox Overload
GSF.Web.UI Namespace


ClientSideExtensions.PushToBack Method

Grid Solutions Framework ClientSideExtensionsPushToBack Method
Pushes the page's browser window to the background.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void PushToBack(
    this Page page
)
<ExtensionAttribute>
Public Shared Sub PushToBack (
    page As Page
)
static member PushToBack :
        page : Page -> unit

GSF.Web.UI.ClientSideExtensions.PushToBack = function(page);
public:
[ExtensionAttribute]
static void PushToBack(
    Page^ page
)

Parameters

page
Type: System.Web.UIPage
Page to be pushed to the background.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.Refresh Method

Grid Solutions Framework ClientSideExtensionsRefresh Method
Overload List
Name | Description
Refresh(Control) | Registers the control to perform a page refresh.
Refresh(Page, Boolean) | Registers this page to perform a page refresh.
Top
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.Refresh Method (Control)

Grid Solutions Framework ClientSideExtensionsRefresh Method (Control)
Registers the control to perform a page refresh.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Refresh(
    this Control control
)
<ExtensionAttribute>
Public Shared Sub Refresh (
    control As Control
)
static member Refresh :
        control : Control -> unit

GSF.Web.UI.ClientSideExtensions.Refresh = function(control);
public:
[ExtensionAttribute]
static void Refresh(
    Control^ control
)

Parameters

control
Type: System.Web.UIControl
Control that will perform a page refresh when clicked.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
Refresh Overload
GSF.Web.UI Namespace


ClientSideExtensions.Refresh Method (Page, Boolean)

Grid Solutions Framework ClientSideExtensionsRefresh Method (Page, Boolean)
Registers this page to perform a page refresh.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Refresh(
    this Page page,
    bool refreshOnLoad = false
)
<ExtensionAttribute>
Public Shared Sub Refresh (
    page As Page,
    Optional refreshOnLoad As Boolean = false
)
static member Refresh :
        page : Page *
        ?refreshOnLoad : bool
(* Defaults:
        let _refreshOnLoad = defaultArg refreshOnLoad false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.Refresh = function(page, refreshOnLoad);
public:
[ExtensionAttribute]
static void Refresh(
    Page^ page,
    bool refreshOnLoad = false
)

Parameters

page
Type: System.Web.UIPage
Page to refresh.
refreshOnLoad (Optional)
Type: SystemBoolean
Refreshes the page after the page content has loaded.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
Refresh Overload
GSF.Web.UI Namespace


ClientSideExtensions.SetDefaultButton Method

Grid Solutions Framework ClientSideExtensionsSetDefaultButton Method
Registers a default button to be activated when the ENTER key is pressed inside this textbox.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SetDefaultButton(
    this TextBox textbox,
    Control control
)
<ExtensionAttribute>
Public Shared Sub SetDefaultButton (
    textbox As TextBox,
    control As Control
)
static member SetDefaultButton :
        textbox : TextBox *
        control : Control -> unit

GSF.Web.UI.ClientSideExtensions.SetDefaultButton = function(textbox, control);
public:
[ExtensionAttribute]
static void SetDefaultButton(
    TextBox^ textbox,
    Control^ control
)

Parameters

textbox
Type: System.Web.UI.WebControlsTextBox
TextBox for which the default button is to be registered.
control
Type: System.Web.UIControl
Button Control to be assigned as the default action handler.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type TextBox. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.SetSubmitOnce Method

Grid Solutions Framework ClientSideExtensionsSetSubmitOnce Method
Registers the button to be disabled after one click to prevent multiple postbacks.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SetSubmitOnce(
    this Button button
)
<ExtensionAttribute>
Public Shared Sub SetSubmitOnce (
    button As Button
)
static member SetSubmitOnce :
        button : Button -> unit

GSF.Web.UI.ClientSideExtensions.SetSubmitOnce = function(button);
public:
[ExtensionAttribute]
static void SetSubmitOnce(
    Button^ button
)

Parameters

button
Type: System.Web.UI.WebControlsButton
Button for which submit once script is to be registered.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Button. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.Show Method

Grid Solutions Framework ClientSideExtensionsShow Method
Overload List
Name | Description
Show(Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modeless popup window for the specified web page url when the control is clicked.
Show(Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modeless popup window for the specified web page url when the page has loaded.
Top
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.Show Method (Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework ClientSideExtensionsShow Method (Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)
Shows a modeless popup window for the specified web page url when the control is clicked.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Show(
    this Control control,
    string url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)
<ExtensionAttribute>
Public Shared Sub Show (
    control As Control,
    url As String,
    Optional height As Integer = 400,
    Optional width As Integer = 600,
    Optional left As Integer = 0,
    Optional top As Integer = 0,
    Optional center As Boolean = true,
    Optional help As Boolean = false,
    Optional resizable As Boolean = false,
    Optional status As Boolean = false
)
static member Show :
        control : Control *
        url : string *
        ?height : int *
        ?width : int *
        ?left : int *
        ?top : int *
        ?center : bool *
        ?help : bool *
        ?resizable : bool *
        ?status : bool
(* Defaults:
        let _height = defaultArg height 400
        let _width = defaultArg width 600
        let _left = defaultArg left 0
        let _top = defaultArg top 0
        let _center = defaultArg center true
        let _help = defaultArg help false
        let _resizable = defaultArg resizable false
        let _status = defaultArg status false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.Show = function(control, url, height, width, left, top, center, help, resizable, status);
public:
[ExtensionAttribute]
static void Show(
    Control^ control,
    String^ url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)

Parameters

control
Type: System.Web.UIControl
that will show the popup window when clicked.
url
Type: SystemString
Web page url for which the popup windows is to be shown.
height (Optional)
Type: SystemInt32
Height of the popup window.
width (Optional)
Type: SystemInt32
Width of the popup window.
left (Optional)
Type: SystemInt32
Location of the popup window on X-axis.
top (Optional)
Type: SystemInt32
Location of the popup window on Y-axis.
center (Optional)
Type: SystemBoolean
True if the popup window is to be centered, otherwise False.
help (Optional)
Type: SystemBoolean
True if help button is to be displayed, otherwise False.
resizable (Optional)
Type: SystemBoolean
True if the popup window can be resized, otherwise False.
status (Optional)
Type: SystemBoolean
True if the status bar is to be displayed, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
Show Overload
GSF.Web.UI Namespace


ClientSideExtensions.Show Method (Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework ClientSideExtensionsShow Method (Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)
Shows a modeless popup window for the specified web page url when the page has loaded.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void Show(
    this Page page,
    string url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)
<ExtensionAttribute>
Public Shared Sub Show (
    page As Page,
    url As String,
    Optional height As Integer = 400,
    Optional width As Integer = 600,
    Optional left As Integer = 0,
    Optional top As Integer = 0,
    Optional center As Boolean = true,
    Optional help As Boolean = false,
    Optional resizable As Boolean = false,
    Optional status As Boolean = false
)
static member Show :
        page : Page *
        url : string *
        ?height : int *
        ?width : int *
        ?left : int *
        ?top : int *
        ?center : bool *
        ?help : bool *
        ?resizable : bool *
        ?status : bool
(* Defaults:
        let _height = defaultArg height 400
        let _width = defaultArg width 600
        let _left = defaultArg left 0
        let _top = defaultArg top 0
        let _center = defaultArg center true
        let _help = defaultArg help false
        let _resizable = defaultArg resizable false
        let _status = defaultArg status false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.Show = function(page, url, height, width, left, top, center, help, resizable, status);
public:
[ExtensionAttribute]
static void Show(
    Page^ page,
    String^ url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)

Parameters

page
Type: System.Web.UIPage
that will show the popup window when loaded.
url
Type: SystemString
Web page url for which the popup windows is to be shown.
height (Optional)
Type: SystemInt32
Height of the popup window.
width (Optional)
Type: SystemInt32
Width of the popup window.
left (Optional)
Type: SystemInt32
Location of the popup window on X-axis.
top (Optional)
Type: SystemInt32
Location of the popup window on Y-axis.
center (Optional)
Type: SystemBoolean
True if the popup window is to be centered, otherwise False.
help (Optional)
Type: SystemBoolean
True if help button is to be displayed, otherwise False.
resizable (Optional)
Type: SystemBoolean
True if the popup window can be resized, otherwise False.
status (Optional)
Type: SystemBoolean
True if the status bar is to be displayed, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
Show Overload
GSF.Web.UI Namespace


ClientSideExtensions.ShowDialog Method

Grid Solutions Framework ClientSideExtensionsShowDialog Method
Overload List
Name | Description
ShowDialog(Control, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modal popup window for the specified web page url when the control is clicked.
ShowDialog(Page, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean) | Shows a modal popup window for the specified web page url when the page has loaded.
Top
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.ShowDialog Method (Control, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework ClientSideExtensionsShowDialog Method (Control, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)
Shows a modal popup window for the specified web page url when the control is clicked.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ShowDialog(
    this Control control,
    string url,
    Control dialogResultHolder = null,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)
<ExtensionAttribute>
Public Shared Sub ShowDialog (
    control As Control,
    url As String,
    Optional dialogResultHolder As Control = Nothing,
    Optional height As Integer = 400,
    Optional width As Integer = 600,
    Optional left As Integer = 0,
    Optional top As Integer = 0,
    Optional center As Boolean = true,
    Optional help As Boolean = false,
    Optional resizable As Boolean = false,
    Optional status As Boolean = false
)
static member ShowDialog :
        control : Control *
        url : string *
        ?dialogResultHolder : Control *
        ?height : int *
        ?width : int *
        ?left : int *
        ?top : int *
        ?center : bool *
        ?help : bool *
        ?resizable : bool *
        ?status : bool
(* Defaults:
        let _dialogResultHolder = defaultArg dialogResultHolder null
        let _height = defaultArg height 400
        let _width = defaultArg width 600
        let _left = defaultArg left 0
        let _top = defaultArg top 0
        let _center = defaultArg center true
        let _help = defaultArg help false
        let _resizable = defaultArg resizable false
        let _status = defaultArg status false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.ShowDialog = function(control, url, dialogResultHolder, height, width, left, top, center, help, resizable, status);
public:
[ExtensionAttribute]
static void ShowDialog(
    Control^ control,
    String^ url,
    Control^ dialogResultHolder = nullptr,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)

Parameters

control
Type: System.Web.UIControl
Control that will show the popup window when clicked.
url
Type: SystemString
Web page url for which the popup windows is to be shown.
dialogResultHolder (Optional)
Type: System.Web.UIControl
Control whose text is to updated with the text returned by the web page displayed in the popup window.
height (Optional)
Type: SystemInt32
Height of the popup window.
width (Optional)
Type: SystemInt32
Width of the popup window.
left (Optional)
Type: SystemInt32
Location of the popup window on X-axis.
top (Optional)
Type: SystemInt32
Location of the popup window on Y-axis.
center (Optional)
Type: SystemBoolean
True if the popup window is to be centered, otherwise False.
help (Optional)
Type: SystemBoolean
True if help button is to be displayed, otherwise False.
resizable (Optional)
Type: SystemBoolean
True if the popup window can be resized, otherwise False.
status (Optional)
Type: SystemBoolean
True if the status bar is to be displayed, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
ShowDialog Overload
GSF.Web.UI Namespace


ClientSideExtensions.ShowDialog Method (Page, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework ClientSideExtensionsShowDialog Method (Page, String, Control, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean)
Shows a modal popup window for the specified web page url when the page has loaded.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ShowDialog(
    this Page page,
    string url,
    Control dialogResultHolder = null,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)
<ExtensionAttribute>
Public Shared Sub ShowDialog (
    page As Page,
    url As String,
    Optional dialogResultHolder As Control = Nothing,
    Optional height As Integer = 400,
    Optional width As Integer = 600,
    Optional left As Integer = 0,
    Optional top As Integer = 0,
    Optional center As Boolean = true,
    Optional help As Boolean = false,
    Optional resizable As Boolean = false,
    Optional status As Boolean = false
)
static member ShowDialog :
        page : Page *
        url : string *
        ?dialogResultHolder : Control *
        ?height : int *
        ?width : int *
        ?left : int *
        ?top : int *
        ?center : bool *
        ?help : bool *
        ?resizable : bool *
        ?status : bool
(* Defaults:
        let _dialogResultHolder = defaultArg dialogResultHolder null
        let _height = defaultArg height 400
        let _width = defaultArg width 600
        let _left = defaultArg left 0
        let _top = defaultArg top 0
        let _center = defaultArg center true
        let _help = defaultArg help false
        let _resizable = defaultArg resizable false
        let _status = defaultArg status false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.ShowDialog = function(page, url, dialogResultHolder, height, width, left, top, center, help, resizable, status);
public:
[ExtensionAttribute]
static void ShowDialog(
    Page^ page,
    String^ url,
    Control^ dialogResultHolder = nullptr,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool help = false,
    bool resizable = false,
    bool status = false
)

Parameters

page
Type: System.Web.UIPage
Web page that will show the popup window when loaded.
url
Type: SystemString
Web page url for which the popup windows is to be shown.
dialogResultHolder (Optional)
Type: System.Web.UIControl
Control whose text is to updated with the text returned by the web page displayed in the popup window.
height (Optional)
Type: SystemInt32
Height of the popup window.
width (Optional)
Type: SystemInt32
Width of the popup window.
left (Optional)
Type: SystemInt32
Location of the popup window on X-axis.
top (Optional)
Type: SystemInt32
Location of the popup window on Y-axis.
center (Optional)
Type: SystemBoolean
True if the popup window is to be centered, otherwise False.
help (Optional)
Type: SystemBoolean
True if help button is to be displayed, otherwise False.
resizable (Optional)
Type: SystemBoolean
True if the popup window can be resized, otherwise False.
status (Optional)
Type: SystemBoolean
True if the status bar is to be displayed, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
ShowDialog Overload
GSF.Web.UI Namespace


ClientSideExtensions.ShowPopup Method

Grid Solutions Framework ClientSideExtensionsShowPopup Method
Overload List
Name | Description
ShowPopup(Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Shows a popup for the specified web page url when the control is clicked.
ShowPopup(Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean) | Shows a popup for the specified web page url when the page has loaded.
Top
See Also

Reference

ClientSideExtensions Class
GSF.Web.UI Namespace


ClientSideExtensions.ShowPopup Method (Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework ClientSideExtensionsShowPopup Method (Control, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Shows a popup for the specified web page url when the control is clicked.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ShowPopup(
    this Control control,
    string url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool resizable = false,
    bool scrollbars = false,
    bool toolbar = false,
    bool menubar = false,
    bool location = false,
    bool status = false,
    bool directories = false
)
<ExtensionAttribute>
Public Shared Sub ShowPopup (
    control As Control,
    url As String,
    Optional height As Integer = 400,
    Optional width As Integer = 600,
    Optional left As Integer = 0,
    Optional top As Integer = 0,
    Optional center As Boolean = true,
    Optional resizable As Boolean = false,
    Optional scrollbars As Boolean = false,
    Optional toolbar As Boolean = false,
    Optional menubar As Boolean = false,
    Optional location As Boolean = false,
    Optional status As Boolean = false,
    Optional directories As Boolean = false
)
static member ShowPopup :
        control : Control *
        url : string *
        ?height : int *
        ?width : int *
        ?left : int *
        ?top : int *
        ?center : bool *
        ?resizable : bool *
        ?scrollbars : bool *
        ?toolbar : bool *
        ?menubar : bool *
        ?location : bool *
        ?status : bool *
        ?directories : bool
(* Defaults:
        let _height = defaultArg height 400
        let _width = defaultArg width 600
        let _left = defaultArg left 0
        let _top = defaultArg top 0
        let _center = defaultArg center true
        let _resizable = defaultArg resizable false
        let _scrollbars = defaultArg scrollbars false
        let _toolbar = defaultArg toolbar false
        let _menubar = defaultArg menubar false
        let _location = defaultArg location false
        let _status = defaultArg status false
        let _directories = defaultArg directories false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.ShowPopup = function(control, url, height, width, left, top, center, resizable, scrollbars, toolbar, menubar, location, status, directories);
public:
[ExtensionAttribute]
static void ShowPopup(
    Control^ control,
    String^ url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool resizable = false,
    bool scrollbars = false,
    bool toolbar = false,
    bool menubar = false,
    bool location = false,
    bool status = false,
    bool directories = false
)

Parameters

control
Type: System.Web.UIControl
Control that will show the popup when clicked.
url
Type: SystemString
Web page url for which the popup is to be shown.
height (Optional)
Type: SystemInt32
Height of the popup.
width (Optional)
Type: SystemInt32
Width of the popup.
left (Optional)
Type: SystemInt32
Location of the popup on X-axis.
top (Optional)
Type: SystemInt32
Location of the popup on Y-axis.
center (Optional)
Type: SystemBoolean
True if the popup is to be centered, otherwise False.
resizable (Optional)
Type: SystemBoolean
True if the popup can be resized, otherwise False.
scrollbars (Optional)
Type: SystemBoolean
True is the scrollbars are to be displayed, otherwise False.
toolbar (Optional)
Type: SystemBoolean
True if the toolbar is to be displayed, otherwise False.
menubar (Optional)
Type: SystemBoolean
True if the menu bar is to be displayed, otherwise False.
location (Optional)
Type: SystemBoolean
True if the address bar is to be displayed, otherwise False.
status (Optional)
Type: SystemBoolean
True if the status bar is to be displayed, otherwise False.
directories (Optional)
Type: SystemBoolean
True if the directories buttons (Netscape only) are to be displayed, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Control. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
ShowPopup Overload
GSF.Web.UI Namespace


ClientSideExtensions.ShowPopup Method (Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)

Grid Solutions Framework ClientSideExtensionsShowPopup Method (Page, String, Int32, Int32, Int32, Int32, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean, Boolean)
Shows a popup for the specified web page url when the page has loaded.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void ShowPopup(
    this Page page,
    string url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool resizable = false,
    bool scrollbars = false,
    bool toolbar = false,
    bool menubar = false,
    bool location = false,
    bool status = false,
    bool directories = false
)
<ExtensionAttribute>
Public Shared Sub ShowPopup (
    page As Page,
    url As String,
    Optional height As Integer = 400,
    Optional width As Integer = 600,
    Optional left As Integer = 0,
    Optional top As Integer = 0,
    Optional center As Boolean = true,
    Optional resizable As Boolean = false,
    Optional scrollbars As Boolean = false,
    Optional toolbar As Boolean = false,
    Optional menubar As Boolean = false,
    Optional location As Boolean = false,
    Optional status As Boolean = false,
    Optional directories As Boolean = false
)
static member ShowPopup :
        page : Page *
        url : string *
        ?height : int *
        ?width : int *
        ?left : int *
        ?top : int *
        ?center : bool *
        ?resizable : bool *
        ?scrollbars : bool *
        ?toolbar : bool *
        ?menubar : bool *
        ?location : bool *
        ?status : bool *
        ?directories : bool
(* Defaults:
        let _height = defaultArg height 400
        let _width = defaultArg width 600
        let _left = defaultArg left 0
        let _top = defaultArg top 0
        let _center = defaultArg center true
        let _resizable = defaultArg resizable false
        let _scrollbars = defaultArg scrollbars false
        let _toolbar = defaultArg toolbar false
        let _menubar = defaultArg menubar false
        let _location = defaultArg location false
        let _status = defaultArg status false
        let _directories = defaultArg directories false
*)
-> unit

GSF.Web.UI.ClientSideExtensions.ShowPopup = function(page, url, height, width, left, top, center, resizable, scrollbars, toolbar, menubar, location, status, directories);
public:
[ExtensionAttribute]
static void ShowPopup(
    Page^ page,
    String^ url,
    int height = 400,
    int width = 600,
    int left = 0,
    int top = 0,
    bool center = true,
    bool resizable = false,
    bool scrollbars = false,
    bool toolbar = false,
    bool menubar = false,
    bool location = false,
    bool status = false,
    bool directories = false
)

Parameters

page
Type: System.Web.UIPage
Page that will show the popup when loaded.
url
Type: SystemString
Web page url for which the popup is to be shown.
height (Optional)
Type: SystemInt32
Height of the popup.
width (Optional)
Type: SystemInt32
Width of the popup.
left (Optional)
Type: SystemInt32
Location of the popup on X-axis.
top (Optional)
Type: SystemInt32
Location of the popup on Y-axis.
center (Optional)
Type: SystemBoolean
True if the popup is to be centered, otherwise False.
resizable (Optional)
Type: SystemBoolean
True if the popup can be resized, otherwise False.
scrollbars (Optional)
Type: SystemBoolean
True is the scrollbars are to be displayed, otherwise False.
toolbar (Optional)
Type: SystemBoolean
True if the toolbar is to be displayed, otherwise False.
menubar (Optional)
Type: SystemBoolean
True if the menu bar is to be displayed, otherwise False.
location (Optional)
Type: SystemBoolean
True if the address bar is to be displayed, otherwise False.
status (Optional)
Type: SystemBoolean
True if the status bar is to be displayed, otherwise False.
directories (Optional)
Type: SystemBoolean
True if the directories buttons (Netscape only) are to be displayed, otherwise False.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Page. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

ClientSideExtensions Class
ShowPopup Overload
GSF.Web.UI Namespace


MsgBoxStyle Enumeration

Grid Solutions Framework MsgBoxStyle Enumeration
Specifies the buttons to be displayed in a message box.

Namespace: GSF.Web.UI
Assembly: GSF.Web (in GSF.Web.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[FlagsAttribute]
public enum MsgBoxStyle
<FlagsAttribute>
Public Enumeration MsgBoxStyle
[<FlagsAttribute>]
type MsgBoxStyle
GSF.Web.UI.MsgBoxStyle = function();
GSF.Web.UI.MsgBoxStyle.createEnum('GSF.Web.UI.MsgBoxStyle', true);
[FlagsAttribute]
public enum class MsgBoxStyle
Members
Member name | Value | Description
OKOnly | 0 | OK Button.
OKCancel | 1 | OK and Cancel buttons.
AbortRetryIgnore | 2 | Abort,Retry, and Ignore buttons.
YesNoCancel | 3 | Yes, No, and Cancel buttons.
YesNo | 4 | Yes and No buttons.
RetryCancel | 5 | Retry and Cancel buttons.
Critical | 16 | Critical message.
Question | 32 | Warning query.
Exclamation | 48 | Warning message.
Information | 64 | Information message.
DefaultButton1 | 0 | First button is default.
DefaultButton2 | 256 | Second button is default.
DefaultButton3 | 512 | Third button is default.
DefaultButton4 | 768 | Fourth button is default.
ApplicationModal | 0 | Application modal message box.
SystemModal | 4096 | System modal message box.
See Also

Reference

GSF.Web.UI Namespace


GSF.Windows Namespace

Grid Solutions Framework GSF.Windows Namespace
Contains classes and extension functions related to .NET Windows-based platforms such as Windows Forms and WPF.
Classes
 | Class | Description
 | SecureWindow | Represents a WPF window secured using role-based security.
Public class | SecurityPortal | Represents a WPF window used to request user credentials and other security related information.
Enumerations
 | Enumeration | Description
Public enumeration | DisplayType | Enumerable list of portlets to be displayed on the screen.
Public enumeration | ResourceAccessiblityMode | Defines an enumeration of secure resource accessibility modes.


DisplayType Enumeration

Grid Solutions Framework DisplayType Enumeration
Enumerable list of portlets to be displayed on the screen.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum DisplayType
Public Enumeration DisplayType
type DisplayType
GSF.Windows.DisplayType = function();
GSF.Windows.DisplayType.createEnum('GSF.Windows.DisplayType', false);
public enum class DisplayType
Members
Member name | Value | Description
Login | 0 | Login screen.
AccessDenied | 1 | Access Denied screen.
ChangePassword | 2 | Change Password screen.
See Also

Reference

GSF.Windows Namespace


ResourceAccessiblityMode Enumeration

Grid Solutions Framework ResourceAccessiblityMode Enumeration
Defines an enumeration of secure resource accessibility modes.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public enum ResourceAccessiblityMode
Public Enumeration ResourceAccessiblityMode
type ResourceAccessiblityMode
GSF.Windows.ResourceAccessiblityMode = function();
GSF.Windows.ResourceAccessiblityMode.createEnum('GSF.Windows.ResourceAccessiblityMode', false);
public enum class ResourceAccessiblityMode
Members
Member name | Value | Description
Configurable | 0 | Resource security is controlled via configuration.
AlwaysIncluded | 1 | Resource is always secured.
AlwaysExcluded | 2 | Resource is never secured.
See Also

Reference

GSF.Windows Namespace


SecureWindow Class

Grid Solutions Framework SecureWindow Class
Represents a WPF window secured using role-based security.
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
GSF.WindowsSecureWindow

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecureWindow : Window
Public Class SecureWindow
    Inherits Window
type SecureWindow =
    class
        inherit Window
    end
GSF.Windows.SecureWindow = function();

Type.createClass(
    'GSF.Windows.SecureWindow',
    Window);
public ref class SecureWindow : public Window

The SecureWindow type exposes the following members.

Constructors
 | Name | Description
Public method | SecureWindow | Initializes a new instance of the SecureWindow class.
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
ForceLoginDisplayProperty | Identifies the ForceLoginDisplay dependency property.
IncludedRolesProperty | Identifies the IncludedRoles dependency property.
ResourceAccessiblityProperty | Identifies the ResourceAccessiblity dependency property.
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | ForceLoginDisplay | Gets or sets flags to force login display.
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | IncludedRoles | Gets or sets applicable roles when ResourceAccessiblity == AlwaysIncluded.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | ResourceAccessiblity | Gets or sets window's secure ResourceAccessiblityMode.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
Examples
Required config file entries:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ApplicationName" value="" description="Name of the application being secured as defined in the backend security datastore."
        encrypted="false" />
      <add name="ConnectionString" value="" description="Connection string to be used for connection to the backend security datastore."
        encrypted="false" />
      <add name="ProviderType" value="GSF.Security.LdapSecurityProvider, GSF.Security"
        description="The type to be used for enforcing security." encrypted="false" />
      <add name="IncludedResources" value="*Window*=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="" description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
    </securityProvider>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
</configuration>
XAML to be used for the WPF window that inherits from SecureWindow:
Copy
<src:SecureWindow x:Class="SecureWpfApplication.Window1"
    xmlns="http://schemas.microsoft.com/winfx/2006/xaml/presentation"
    xmlns:x="http://schemas.microsoft.com/winfx/2006/xaml"
    xmlns:src="clr-namespace:GSF.Windows;assembly=GSF.Windows"
    Title="Window1" Height="300" Width="300">
    <Grid>

    </Grid>
</src:SecureWindow>
See Also

Reference

GSF.Windows Namespace
GSF.SecurityISecurityProvider


SecureWindow Constructor

Grid Solutions Framework SecureWindow Constructor
Initializes a new instance of the SecureWindow class.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureWindow()
Public Sub New
new : unit -> SecureWindow
GSF.Windows.SecureWindow = function();
public:
SecureWindow()
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow Fields

Grid Solutions Framework SecureWindow Fields

The SecureWindow type exposes the following members.

Fields
Name | Description
ForceLoginDisplayProperty | Identifies the ForceLoginDisplay dependency property.
IncludedRolesProperty | Identifies the IncludedRoles dependency property.
ResourceAccessiblityProperty | Identifies the ResourceAccessiblity dependency property.
Top
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow.ForceLoginDisplayProperty Field

Grid Solutions Framework SecureWindowForceLoginDisplayProperty Field
Identifies the ForceLoginDisplay dependency property.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly DependencyProperty ForceLoginDisplayProperty
Public Shared ReadOnly ForceLoginDisplayProperty As DependencyProperty
static val ForceLoginDisplayProperty: DependencyProperty
var GSF.Windows.SecureWindow.ForceLoginDisplayProperty
public:
static initonly DependencyProperty^ ForceLoginDisplayProperty

Return Value

Type: DependencyProperty
identifier for the ForceLoginDisplay dependency property.
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow.IncludedRolesProperty Field

Grid Solutions Framework SecureWindowIncludedRolesProperty Field
Identifies the IncludedRoles dependency property.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly DependencyProperty IncludedRolesProperty
Public Shared ReadOnly IncludedRolesProperty As DependencyProperty
static val IncludedRolesProperty: DependencyProperty
var GSF.Windows.SecureWindow.IncludedRolesProperty
public:
static initonly DependencyProperty^ IncludedRolesProperty

Return Value

Type: DependencyProperty
identifier for the IncludedRoles dependency property.
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow.ResourceAccessiblityProperty Field

Grid Solutions Framework SecureWindowResourceAccessiblityProperty Field
Identifies the ResourceAccessiblity dependency property.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static readonly DependencyProperty ResourceAccessiblityProperty
Public Shared ReadOnly ResourceAccessiblityProperty As DependencyProperty
static val ResourceAccessiblityProperty: DependencyProperty
var GSF.Windows.SecureWindow.ResourceAccessiblityProperty
public:
static initonly DependencyProperty^ ResourceAccessiblityProperty

Return Value

Type: DependencyProperty
identifier for the ResourceAccessiblity dependency property.
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow Methods

Grid Solutions Framework SecureWindow Methods

The SecureWindow type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow.GetResourceName Method

Grid Solutions Framework SecureWindowGetResourceName Method
Gets the name of resource being accessed.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetResourceName()
Protected Overridable Function GetResourceName As String
abstract GetResourceName : unit -> string
override GetResourceName : unit -> string
function GetResourceName();
protected:
virtual String^ GetResourceName()

Return Value

Type: String
Name of the resource being accessed.
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow Properties

Grid Solutions Framework SecureWindow Properties

The SecureWindow type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | ForceLoginDisplay | Gets or sets flags to force login display.
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Public property | IncludedRoles | Gets or sets applicable roles when ResourceAccessiblity == AlwaysIncluded.
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | ResourceAccessiblity | Gets or sets window's secure ResourceAccessiblityMode.
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow.ForceLoginDisplay Property

Grid Solutions Framework SecureWindowForceLoginDisplay Property
Gets or sets flags to force login display.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ForceLoginDisplay { get; set; }
Public Property ForceLoginDisplay As Boolean
    Get
    Set
member ForceLoginDisplay : bool with get, set

function get_ForceLoginDisplay();
function set_ForceLoginDisplay(value);
public:
property bool ForceLoginDisplay {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow.IncludedRoles Property

Grid Solutions Framework SecureWindowIncludedRoles Property
Gets or sets applicable roles when ResourceAccessiblity == AlwaysIncluded.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public string IncludedRoles { get; set; }
Public Property IncludedRoles As String
    Get
    Set
member IncludedRoles : string with get, set

function get_IncludedRoles();
function set_IncludedRoles(value);
public:
property String^ IncludedRoles {
    String^ get ();
    void set (String^ value);
}

Property Value

Type: String
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow.ResourceAccessiblity Property

Grid Solutions Framework SecureWindowResourceAccessiblity Property
Gets or sets window's secure ResourceAccessiblityMode.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ResourceAccessiblityMode ResourceAccessiblity { get; set; }
Public Property ResourceAccessiblity As ResourceAccessiblityMode
    Get
    Set
member ResourceAccessiblity : ResourceAccessiblityMode with get, set

function get_ResourceAccessiblity();
function set_ResourceAccessiblity(value);
public:
property ResourceAccessiblityMode ResourceAccessiblity {
    ResourceAccessiblityMode get ();
    void set (ResourceAccessiblityMode value);
}

Property Value

Type: ResourceAccessiblityMode
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecureWindow Events

Grid Solutions Framework SecureWindow Events

The SecureWindow type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SecureWindow Class
GSF.Windows Namespace


SecurityPortal Class

Grid Solutions Framework SecurityPortal Class
Represents a WPF window used to request user credentials and other security related information.
SecurityPortal
Inheritance Hierarchy
SystemObject
System.Windows.ThreadingDispatcherObject
System.WindowsDependencyObject
System.Windows.MediaVisual
System.WindowsUIElement
System.WindowsFrameworkElement
System.Windows.ControlsControl
System.Windows.ControlsContentControl
System.WindowsWindow
GSF.WindowsSecurityPortal

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecurityPortal : Window,
    IComponentConnector
Public Class SecurityPortal
    Inherits Window
    Implements IComponentConnector
type SecurityPortal =
    class
        inherit Window
        interface IComponentConnector
    end
GSF.Windows.SecurityPortal = function();

Type.createClass(
    'GSF.Windows.SecurityPortal',
    Window,
    IComponentConnector);
public ref class SecurityPortal : public Window,
    IComponentConnector

The SecurityPortal type exposes the following members.

Constructors
 | Name | Description
Public method | SecurityPortal | Initializes a new WPF window.
Top
Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearErrorMessage | Clears error message.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DisplayErrorMessage | Displays error message.
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProviderFailure | Gets or sets flag that indicates if there was a failure during provider initialization.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

GSF.Windows Namespace


SecurityPortal Constructor

Grid Solutions Framework SecurityPortal Constructor
Initializes a new WPF window.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecurityPortal(
    DisplayType displayType
)
Public Sub New (
    displayType As DisplayType
)
new :
        displayType : DisplayType -> SecurityPortal
GSF.Windows.SecurityPortal = function(displayType);
public:
SecurityPortal(
    DisplayType displayType
)

Parameters

displayType
Type: GSF.WindowsDisplayType
Type of the message received from security API which is used to decide controls to be displayed on the screen.
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


SecurityPortal Methods

Grid Solutions Framework SecurityPortal Methods

The SecurityPortal type exposes the following members.

Methods
 | Name | Description
Public method | Activate | Attempts to bring the window to the foreground and activates it. (Inherited from Window.)
Protected method | AddChild | Adds a specified object as the child of a ContentControl. (Inherited from ContentControl.)
Public method | AddHandler(RoutedEvent, Delegate) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. (Inherited from UIElement.)
Public method | AddHandler(RoutedEvent, Delegate, Boolean) | Adds a routed event handler for a specified routed event, adding the handler to the handler collection on the current element. Specify handledEventsToo as true to have the provided handler be invoked for routed event that had already been marked as handled by another element along the event route. (Inherited from UIElement.)
Protected method | AddLogicalChild | Adds the provided object to the logical tree of this element. (Inherited from FrameworkElement.)
Protected method | AddText | Adds a specified text string to a ContentControl. (Inherited from ContentControl.)
Public method | AddToEventRoute | Adds handlers to the specified EventRoute for the current UIElement event handler collection. (Inherited from UIElement.)
Protected method | AddVisualChild | Defines the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock) | Applies an animation to a specified dependency property on this element. Any existing animations are stopped and replaced with the new animation. (Inherited from UIElement.)
Public method | ApplyAnimationClock(DependencyProperty, AnimationClock, HandoffBehavior) | Applies an animation to a specified dependency property on this element, with the ability to specify what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | ApplyTemplate | Builds the current template's visual tree if necessary, and returns a value that indicates whether the visual tree was rebuilt by this call. (Inherited from FrameworkElement.)
Public method | Arrange | Positions child elements and determines a size for a UIElement. Parent elements call this method from their ArrangeCore(Rect) implementation (or a WPF framework-level equivalent) to form a recursive layout update. This method constitutes the second pass of a layout update. (Inherited from UIElement.)
Protected method | ArrangeCore | Implements ArrangeCore(Rect) (defined as virtual in UIElement) and seals the implementation. (Inherited from FrameworkElement.)
Protected method | ArrangeOverride | Override this method to arrange and size a window and its child elements. (Inherited from Window.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline) | Starts an animation for a specified animated property on this element. (Inherited from UIElement.)
Public method | BeginAnimation(DependencyProperty, AnimationTimeline, HandoffBehavior) | Starts a specific animation for a specified animated property on this element, with the option of specifying what happens if the property already has a running animation. (Inherited from UIElement.)
Public method | BeginInit | Starts the initialization process for this element. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard) | Begins the sequence of actions that are contained in the provided storyboard. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior) | Begins the sequence of actions contained in the provided storyboard, with options specified for what should happen if the property is already animated. (Inherited from FrameworkElement.)
Public method | BeginStoryboard(Storyboard, HandoffBehavior, Boolean) | Begins the sequence of actions contained in the provided storyboard, with specified state for control of the animation after it is started. (Inherited from FrameworkElement.)
Public method | BringIntoView | Attempts to bring this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | BringIntoView(Rect) | Attempts to bring the provided region size of this element into view, within any scrollable regions it is contained within. (Inherited from FrameworkElement.)
Public method | CaptureMouse | Attempts to force capture of the mouse to this element. (Inherited from UIElement.)
Public method | CaptureStylus | Attempts to force capture of the stylus to this element. (Inherited from UIElement.)
Public method | CaptureTouch | Attempts to force capture of a touch to this element. (Inherited from UIElement.)
Public method | CheckAccess | Determines whether the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Public method | ClearErrorMessage | Clears error message.
Public method | ClearValue(DependencyProperty) | Clears the local value of a property. The property to be cleared is specified by a DependencyProperty identifier. (Inherited from DependencyObject.)
Public method | ClearValue(DependencyPropertyKey) | Clears the local value of a read-only property. The property to be cleared is specified by a DependencyPropertyKey. (Inherited from DependencyObject.)
Public method | Close | Manually closes a Window. (Inherited from Window.)
Public method | CoerceValue | Coerces the value of the specified dependency property. This is accomplished by invoking any CoerceValueCallback function specified in property metadata for the dependency property as it exists on the calling DependencyObject. (Inherited from DependencyObject.)
Public method | DisplayErrorMessage | Displays error message.
Public method | DragMove | Allows a window to be dragged by a mouse with its left button down over an exposed area of the window's client area. (Inherited from Window.)
Public method | EndInit | Indicates that the initialization process for the element is complete. (Inherited from FrameworkElement.)
Public method | Equals | Determines whether a provided DependencyObject is equivalent to the current DependencyObject. (Inherited from DependencyObject.)
Protected method | Finalize | Allows an object to try to free resources and perform other cleanup operations before it is reclaimed by garbage collection. (Inherited from Object.)
Public method | FindCommonVisualAncestor | Returns the common ancestor of two visual objects. (Inherited from Visual.)
Public method | FindName | Finds an element that has the provided identifier name. (Inherited from FrameworkElement.)
Public method | FindResource | Searches for a resource with the specified key, and throws an exception if the requested resource is not found. (Inherited from FrameworkElement.)
Public method | Focus | Attempts to set focus to this element. (Inherited from UIElement.)
Public method | GetAnimationBaseValue | Returns the base property value for the specified property on this element, disregarding any possible animated value from a running or stopped animation. (Inherited from UIElement.)
Public method | GetBindingExpression | Returns the BindingExpression that represents the binding on the specified property. (Inherited from FrameworkElement.)
Public method | GetHashCode | Gets a hash code for this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetLayoutClip | Returns a geometry for a clipping mask. The mask applies if the layout system attempts to arrange an element that is larger than the available display space. (Inherited from FrameworkElement.)
Public method | GetLocalValueEnumerator | Creates a specialized enumerator for determining which dependency properties have locally set values on this DependencyObject. (Inherited from DependencyObject.)
Protected method | GetTemplateChild | Returns the named element in the visual tree of an instantiated ControlTemplate. (Inherited from FrameworkElement.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Protected method | GetUIParentCore | Returns an alternative logical parent for this element if there is no visual parent. (Inherited from FrameworkElement.)
Public method | GetValue | Returns the current effective value of a dependency property on this instance of a DependencyObject. (Inherited from DependencyObject.)
Protected method | GetVisualChild | Overrides GetVisualChild(Int32), and returns a child at the specified index from a collection of child elements. (Inherited from FrameworkElement.)
Public method | Hide | Makes a window invisible. (Inherited from Window.)
Protected method | HitTestCore(PointHitTestParameters) | Implements HitTestCore(PointHitTestParameters) to supply base element hit testing behavior (returning HitTestResult). (Inherited from UIElement.)
Protected method | HitTestCore(GeometryHitTestParameters) | Implements HitTestCore(GeometryHitTestParameters) to supply base element hit testing behavior (returning GeometryHitTestResult). (Inherited from UIElement.)
Public method | InitializeComponent | InitializeComponent
Public method | InputHitTest | Returns the input element within the current element that is at the specified coordinates, relative to the current element's origin. (Inherited from UIElement.)
Public method | InvalidateArrange | Invalidates the arrange state (layout) for the element. After the invalidation, the element will have its layout updated, which will occur asynchronously unless subsequently forced by UpdateLayout. (Inherited from UIElement.)
Public method | InvalidateMeasure | Invalidates the measurement state (layout) for the element. (Inherited from UIElement.)
Public method | InvalidateProperty | Re-evaluates the effective value for the specified dependency property (Inherited from DependencyObject.)
Public method | InvalidateVisual | Invalidates the rendering of the element, and forces a complete new layout pass. OnRender(DrawingContext) is called after the layout cycle is completed. (Inherited from UIElement.)
Public method | IsAncestorOf | Determines whether the visual object is an ancestor of the descendant visual object. (Inherited from Visual.)
Public method | IsDescendantOf | Determines whether the visual object is a descendant of the ancestor visual object. (Inherited from Visual.)
Public method | Measure | Updates the DesiredSize of a UIElement. Parent elements call this method from their own MeasureCore(Size) implementations to form a recursive layout update. Calling this method constitutes the first pass (the "Measure" pass) of a layout update. (Inherited from UIElement.)
Protected method | MeasureCore | Implements basic measure-pass layout system behavior for FrameworkElement. (Inherited from FrameworkElement.)
Protected method | MeasureOverride | Override this method to measure the size of a window. (Inherited from Window.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Public method | MoveFocus | Moves the keyboard focus away from this element and to another element in a provided traversal direction. (Inherited from FrameworkElement.)
Protected method | OnAccessKey | Provides class handling for when an access key that is meaningful for this element is invoked. (Inherited from UIElement.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Window.)
Public method | OnApplyTemplate | When overridden in a derived class, is invoked whenever application code or internal processes call ApplyTemplate. (Inherited from FrameworkElement.)
Protected method | OnChildDesiredSizeChanged | Supports layout behavior when a child element is resized. (Inherited from UIElement.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Window.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Window.)
Protected method | OnContentChanged | Called when the Content property changes. (Inherited from Window.)
Protected method | OnContentRendered | Raises the ContentRendered event. (Inherited from Window.)
Protected method | OnContentStringFormatChanged | Occurs when the ContentStringFormat property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateChanged | Called when the ContentTemplate property changes. (Inherited from ContentControl.)
Protected method | OnContentTemplateSelectorChanged | Called when the ContentTemplateSelector property changes. (Inherited from ContentControl.)
Protected method | OnContextMenuClosing | Invoked whenever an unhandled ContextMenuClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnContextMenuOpening | Invoked whenever an unhandled ContextMenuOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnCreateAutomationPeer | Creates and returns a WindowAutomationPeer object for this Window. (Inherited from Window.)
Protected method | OnDeactivated | Raises the Deactivated event. (Inherited from Window.)
Protected method | OnDragEnter | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragLeave | Invoked when an unhandled DragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDragOver | Invoked when an unhandled DragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnDrop | Invoked when an unhandled DragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGiveFeedback | Invoked when an unhandled GiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotFocus | Invoked whenever an unhandled GotFocus event reaches this element in its route. (Inherited from FrameworkElement.)
Protected method | OnGotKeyboardFocus | Invoked when an unhandled GotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotMouseCapture | Invoked when an unhandled GotMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotStylusCapture | Invoked when an unhandled GotStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnGotTouchCapture | Provides class handling for the GotTouchCapture routed event that occurs when a touch is captured to this element. (Inherited from UIElement.)
Protected method | OnInitialized | Raises the Initialized event. This method is invoked whenever IsInitialized is set to true internally. (Inherited from FrameworkElement.)
Protected method | OnIsKeyboardFocusedChanged | Invoked when an unhandled IsKeyboardFocusedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsKeyboardFocusWithinChanged | Invoked just before the IsKeyboardFocusWithinChanged event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCapturedChanged | Invoked when an unhandled IsMouseCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseCaptureWithinChanged | Invoked when an unhandled IsMouseCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsMouseDirectlyOverChanged | Invoked when an unhandled IsMouseDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCapturedChanged | Invoked when an unhandled IsStylusCapturedChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusCaptureWithinChanged | Invoked when an unhandled IsStylusCaptureWithinChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnIsStylusDirectlyOverChanged | Invoked when an unhandled IsStylusDirectlyOverChanged event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyDown | Invoked when an unhandled KeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnKeyUp | Invoked when an unhandled KeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Window.)
Protected method | OnLostFocus | Raises the LostFocus routed event by using the event data that is provided. (Inherited from UIElement.)
Protected method | OnLostKeyboardFocus | Invoked when an unhandled LostKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostMouseCapture | Invoked when an unhandled LostMouseCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostStylusCapture | Invoked when an unhandled LostStylusCapture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnLostTouchCapture | Provides class handling for the LostTouchCapture routed event that occurs when this element loses a touch capture. (Inherited from UIElement.)
Protected method | OnManipulationBoundaryFeedback | Called when the ManipulationBoundaryFeedback event occurs. (Inherited from Window.)
Protected method | OnManipulationCompleted | Called when the ManipulationCompleted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationDelta | Called when the ManipulationDelta event occurs. (Inherited from UIElement.)
Protected method | OnManipulationInertiaStarting | Called when the ManipulationInertiaStarting event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarted | Called when the ManipulationStarted event occurs. (Inherited from UIElement.)
Protected method | OnManipulationStarting | Provides class handling for the ManipulationStarting routed event that occurs when the manipulation processor is first created. (Inherited from UIElement.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnMouseDown | Invoked when an unhandled MouseDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseEnter | Invoked when an unhandled MouseEnter attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeave | Invoked when an unhandled MouseLeave attached event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonDown | Invoked when an unhandled MouseLeftButtonDown routed event is raised on this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseLeftButtonUp | Invoked when an unhandled MouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseMove | Invoked when an unhandled MouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonDown | Invoked when an unhandled MouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseRightButtonUp | Invoked when an unhandled MouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseUp | Invoked when an unhandled MouseUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnMouseWheel | Invoked when an unhandled MouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragEnter | Invoked when an unhandled PreviewDragEnter attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragLeave | Invoked when an unhandled PreviewDragLeave attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDragOver | Invoked when an unhandled PreviewDragOver attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewDrop | Invoked when an unhandled PreviewDrop attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGiveFeedback | Invoked when an unhandled PreviewGiveFeedback attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewGotKeyboardFocus | Invoked when an unhandled PreviewGotKeyboardFocus attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyDown | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewKeyUp | Invoked when an unhandled PreviewKeyUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewLostKeyboardFocus | Invoked when an unhandled PreviewKeyDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseDoubleClick | Raises the PreviewMouseDoubleClick routed event. (Inherited from Control.)
Protected method | OnPreviewMouseDown | Invoked when an unhandled PreviewMouseDown attached routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonDown | Invoked when an unhandled PreviewMouseLeftButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseLeftButtonUp | Invoked when an unhandled PreviewMouseLeftButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseMove | Invoked when an unhandled PreviewMouseMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonDown | Invoked when an unhandled PreviewMouseRightButtonDown routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseRightButtonUp | Invoked when an unhandled PreviewMouseRightButtonUp routed event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseUp | Invoked when an unhandled PreviewMouseUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewMouseWheel | Invoked when an unhandled PreviewMouseWheel attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewQueryContinueDrag | Invoked when an unhandled PreviewQueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonDown | Invoked when an unhandled PreviewStylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusButtonUp | Invoked when an unhandled PreviewStylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusDown | Invoked when an unhandled PreviewStylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInAirMove | Invoked when an unhandled PreviewStylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusInRange | Invoked when an unhandled PreviewStylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusMove | Invoked when an unhandled PreviewStylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusOutOfRange | Invoked when an unhandled PreviewStylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusSystemGesture | Invoked when an unhandled PreviewStylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewStylusUp | Invoked when an unhandled PreviewStylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTextInput | Invoked when an unhandled PreviewTextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnPreviewTouchDown | Provides class handling for the PreviewTouchDown routed event that occurs when a touch presses this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchMove | Provides class handling for the PreviewTouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnPreviewTouchUp | Provides class handling for the PreviewTouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnPropertyChanged | Invoked whenever the effective value of any dependency property on this FrameworkElement has been updated. The specific dependency property that changed is reported in the arguments parameter. Overrides OnPropertyChanged(DependencyPropertyChangedEventArgs). (Inherited from FrameworkElement.)
Protected method | OnQueryContinueDrag | Invoked when an unhandled QueryContinueDrag attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnQueryCursor | Invoked when an unhandled QueryCursor attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnRender | When overridden in a derived class, participates in rendering operations that are directed by the layout system. The rendering instructions for this element are not used directly when this method is invoked, and are instead preserved for later asynchronous use by layout and drawing. (Inherited from UIElement.)
Protected method | OnRenderSizeChanged | Raises the SizeChanged event, using the specified information as part of the eventual event data. (Inherited from FrameworkElement.)
Protected method | OnSourceInitialized | Raises the SourceInitialized event. (Inherited from Window.)
Protected method | OnStateChanged | Raises the StateChanged event. (Inherited from Window.)
Protected method | OnStyleChanged | Invoked when the style in use on this element changes, which will invalidate the layout. (Inherited from FrameworkElement.)
Protected method | OnStylusButtonDown | Invoked when an unhandled StylusButtonDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusButtonUp | Invoked when an unhandled StylusButtonUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusDown | Invoked when an unhandled StylusDown attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusEnter | Invoked when an unhandled StylusEnter attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInAirMove | Invoked when an unhandled StylusInAirMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusInRange | Invoked when an unhandled StylusInRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusLeave | Invoked when an unhandled StylusLeave attached event is raised by this element. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusMove | Invoked when an unhandled StylusMove attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusOutOfRange | Invoked when an unhandled StylusOutOfRange attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusSystemGesture | Invoked when an unhandled StylusSystemGesture attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnStylusUp | Invoked when an unhandled StylusUp attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnTemplateChanged | Called whenever the control's template changes. (Inherited from Control.)
Protected method | OnTextInput | Invoked when an unhandled TextInput attached event reaches an element in its route that is derived from this class. Implement this method to add class handling for this event. (Inherited from UIElement.)
Protected method | OnToolTipClosing | Invoked whenever an unhandled ToolTipClosing routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnToolTipOpening | Invoked whenever the ToolTipOpening routed event reaches this class in its route. Implement this method to add class handling for this event. (Inherited from FrameworkElement.)
Protected method | OnTouchDown | Provides class handling for the TouchDown routed event that occurs when a touch presses inside this element. (Inherited from UIElement.)
Protected method | OnTouchEnter | Provides class handling for the TouchEnter routed event that occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Protected method | OnTouchLeave | Provides class handling for the TouchLeave routed event that occurs when a touch moves from inside to outside the bounds of this UIElement. (Inherited from UIElement.)
Protected method | OnTouchMove | Provides class handling for the TouchMove routed event that occurs when a touch moves while inside this element. (Inherited from UIElement.)
Protected method | OnTouchUp | Provides class handling for the TouchUp routed event that occurs when a touch is released inside this element. (Inherited from UIElement.)
Protected method | OnVisualChildrenChanged | Called when the VisualCollection of the visual object is modified. (Inherited from Visual.)
Protected method | OnVisualParentChanged | Called when the parent of the window is changed. (Inherited from Window.)
Protected method | ParentLayoutInvalidated | Supports incremental layout implementations in specialized subclasses of FrameworkElement. ParentLayoutInvalidated(UIElement) is invoked when a child element has invalidated a property that is marked in metadata as affecting the parent's measure or arrange passes during layout. (Inherited from FrameworkElement.)
Public method | PointFromScreen | Converts a Point in screen coordinates into a Point that represents the current coordinate system of the Visual. (Inherited from Visual.)
Public method | PointToScreen | Converts a Point that represents the current coordinate system of the Visual into a Point in screen coordinates. (Inherited from Visual.)
Public method | PredictFocus | Determines the next element that would receive focus relative to this element for a provided focus movement direction, but does not actually move the focus. (Inherited from FrameworkElement.)
Public method | RaiseEvent | Raises a specific routed event. The RoutedEvent to be raised is identified within the RoutedEventArgs instance that is provided (as the RoutedEvent property of that event data). (Inherited from UIElement.)
Public method | ReadLocalValue | Returns the local value of a dependency property, if it exists. (Inherited from DependencyObject.)
Public method | RegisterName | Provides an accessor that simplifies access to the NameScope registration method. (Inherited from FrameworkElement.)
Public method | ReleaseAllTouchCaptures | Releases all captured touch devices from this element. (Inherited from UIElement.)
Public method | ReleaseMouseCapture | Releases the mouse capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseStylusCapture | Releases the stylus device capture, if this element held the capture. (Inherited from UIElement.)
Public method | ReleaseTouchCapture | Attempts to release the specified touch device from this element. (Inherited from UIElement.)
Public method | RemoveHandler | Removes the specified routed event handler from this element. (Inherited from UIElement.)
Protected method | RemoveLogicalChild | Removes the provided object from this element's logical tree. FrameworkElement updates the affected logical tree parent pointers to keep in sync with this deletion. (Inherited from FrameworkElement.)
Protected method | RemoveVisualChild | Removes the parent-child relationship between two visuals. (Inherited from Visual.)
Public method | SetBinding(DependencyProperty, BindingBase) | Attaches a binding to this element, based on the provided binding object. (Inherited from FrameworkElement.)
Public method | SetBinding(DependencyProperty, String) | Attaches a binding to this element, based on the provided source property name as a path qualification to the data source. (Inherited from FrameworkElement.)
Public method | SetCurrentValue | Sets the value of a dependency property without changing its value source. (Inherited from DependencyObject.)
Public method | SetResourceReference | Searches for a resource with the specified name and sets up a resource reference to it for the specified property. (Inherited from FrameworkElement.)
Public method | SetValue(DependencyProperty, Object) | Sets the local value of a dependency property, specified by its dependency property identifier. (Inherited from DependencyObject.)
Public method | SetValue(DependencyPropertyKey, Object) | Sets the local value of a read-only dependency property, specified by the DependencyPropertyKey identifier of the dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeCommandBindings | Returns whether serialization processes should serialize the contents of the CommandBindings property on instances of this class. (Inherited from UIElement.)
Public method | ShouldSerializeContent | Indicates whether the Content property should be persisted. (Inherited from ContentControl.)
Public method | ShouldSerializeInputBindings | Returns whether serialization processes should serialize the contents of the InputBindings property on instances of this class. (Inherited from UIElement.)
Protected method | ShouldSerializeProperty | Returns a value that indicates whether serialization processes should serialize the value for the provided dependency property. (Inherited from DependencyObject.)
Public method | ShouldSerializeResources | Returns whether serialization processes should serialize the contents of the Resources property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeStyle | Returns whether serialization processes should serialize the contents of the Style property. (Inherited from FrameworkElement.)
Public method | ShouldSerializeTriggers | Returns whether serialization processes should serialize the contents of the Triggers property. (Inherited from FrameworkElement.)
Public method | Show | Opens a window and returns without waiting for the newly opened window to close. (Inherited from Window.)
Public method | ShowDialog | Opens a window and returns only when the newly opened window is closed. (Inherited from Window.)
Public method | ToString | Returns the string representation of a Control object. (Inherited from Control.)
Public method | TransformToAncestor(Visual) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToAncestor(Visual3D) | Returns a transform that can be used to transform coordinates from the Visual to the specified Visual3D ancestor of the visual object. (Inherited from Visual.)
Public method | TransformToDescendant | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object descendant. (Inherited from Visual.)
Public method | TransformToVisual | Returns a transform that can be used to transform coordinates from the Visual to the specified visual object. (Inherited from Visual.)
Public method | TranslatePoint | Translates a point relative to this element to coordinates that are relative to the specified element. (Inherited from UIElement.)
Public method | TryFindResource | Searches for a resource with the specified key, and returns that resource if found. (Inherited from FrameworkElement.)
Public method | UnregisterName | Simplifies access to the NameScope de-registration method. (Inherited from FrameworkElement.)
Public method | UpdateDefaultStyle | Reapplies the default style to the current FrameworkElement. (Inherited from FrameworkElement.)
Public method | UpdateLayout | Ensures that all visual child elements of this element are properly updated for layout. (Inherited from UIElement.)
Public method | VerifyAccess | Enforces that the calling thread has access to this DispatcherObject. (Inherited from DispatcherObject.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


SecurityPortal.ClearErrorMessage Method

Grid Solutions Framework SecurityPortalClearErrorMessage Method
Clears error message.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void ClearErrorMessage()
Public Sub ClearErrorMessage
member ClearErrorMessage : unit -> unit

function ClearErrorMessage();
public:
void ClearErrorMessage()
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


SecurityPortal.DisplayErrorMessage Method

Grid Solutions Framework SecurityPortalDisplayErrorMessage Method
Displays error message.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void DisplayErrorMessage(
    string message
)
Public Sub DisplayErrorMessage (
    message As String
)
member DisplayErrorMessage :
        message : string -> unit

function DisplayErrorMessage(message);
public:
void DisplayErrorMessage(
    String^ message
)

Parameters

message
Type: SystemString
Error message to display.
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


SecurityPortal.InitializeComponent Method

Grid Solutions Framework SecurityPortalInitializeComponent Method
InitializeComponent

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void InitializeComponent()
Public Sub InitializeComponent
abstract InitializeComponent : unit -> unit
override InitializeComponent : unit -> unit
function InitializeComponent();
public:
virtual void InitializeComponent() sealed

Implements

IComponentConnectorInitializeComponent
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


SecurityPortal Properties

Grid Solutions Framework SecurityPortal Properties

The SecurityPortal type exposes the following members.

Properties
 | Name | Description
Public property | ActualHeight | Gets the rendered height of this element. (Inherited from FrameworkElement.)
Public property | ActualWidth | Gets the rendered width of this element. (Inherited from FrameworkElement.)
Public property | AllowDrop | Gets or sets a value indicating whether this element can be used as the target of a drag-and-drop operation. This is a dependency property. (Inherited from UIElement.)
Public property | AllowsTransparency | Gets or sets a value that indicates whether a window's client area supports transparency. (Inherited from Window.)
Public property | AreAnyTouchesCaptured | Gets a value that indicates whether at least one touch is captured to this element. (Inherited from UIElement.)
Public property | AreAnyTouchesCapturedWithin | Gets a value that indicates whether at least one touch is captured to this element or to any child elements in its visual tree. (Inherited from UIElement.)
Public property | AreAnyTouchesDirectlyOver | Gets a value that indicates whether at least one touch is pressed over this element. (Inherited from UIElement.)
Public property | AreAnyTouchesOver | Gets a value that indicates whether at least one touch is pressed over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Background | Gets or sets a brush that describes the background of a control. (Inherited from Control.)
Public property | BindingGroup | Gets or sets the BindingGroup that is used for the element. (Inherited from FrameworkElement.)
Public property | BitmapEffect | Obsolete. Gets or sets a bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BitmapEffectInput | Obsolete. Gets or sets an input source for the bitmap effect that applies directly to the rendered content for this element. This is a dependency property. (Inherited from UIElement.)
Public property | BorderBrush | Gets or sets a brush that describes the border background of a control. (Inherited from Control.)
Public property | BorderThickness | Gets or sets the border thickness of a control. (Inherited from Control.)
Public property | CacheMode | Gets or sets a cached representation of the UIElement. (Inherited from UIElement.)
Public property | Clip | Gets or sets the geometry used to define the outline of the contents of an element. This is a dependency property. (Inherited from UIElement.)
Public property | ClipToBounds | Gets or sets a value indicating whether to clip the content of this element (or content coming from the child elements of this element) to fit into the size of the containing element. This is a dependency property. (Inherited from UIElement.)
Public property | CommandBindings | Gets a collection of CommandBinding objects associated with this element. A CommandBinding enables command handling for this element, and declares the linkage between a command, its events, and the handlers attached by this element. (Inherited from UIElement.)
Public property | Content | Gets or sets the content of a ContentControl. (Inherited from ContentControl.)
Public property | ContentStringFormat | Gets or sets a composite string that specifies how to format the Content property if it is displayed as a string. (Inherited from ContentControl.)
Public property | ContentTemplate | Gets or sets the data template used to display the content of the ContentControl. (Inherited from ContentControl.)
Public property | ContentTemplateSelector | Gets or sets a template selector that enables an application writer to provide custom template-selection logic. (Inherited from ContentControl.)
Public property | ContextMenu | Gets or sets the context menu element that should appear whenever the context menu is requested through user interface (UI) from within this element. (Inherited from FrameworkElement.)
Public property | Cursor | Gets or sets the cursor that displays when the mouse pointer is over this element. (Inherited from FrameworkElement.)
Public property | DataContext | Gets or sets the data context for an element when it participates in data binding. (Inherited from FrameworkElement.)
Protected property | DefaultStyleKey | Gets or sets the key to use to reference the style for this control, when theme styles are used or defined. (Inherited from FrameworkElement.)
Public property | DependencyObjectType | Gets the DependencyObjectType that wraps the CLR type of this instance. (Inherited from DependencyObject.)
Public property | DesiredSize | Gets the size that this element computed during the measure pass of the layout process. (Inherited from UIElement.)
Public property | DialogResult | Gets or sets the dialog result value, which is the value that is returned from the ShowDialog method. (Inherited from Window.)
Public property | Dispatcher | Gets the Dispatcher this DispatcherObject is associated with. (Inherited from DispatcherObject.)
Public property | Effect | Gets or sets the bitmap effect to apply to the UIElement. This is a dependency property. (Inherited from UIElement.)
Public property | FlowDirection | Gets or sets the direction that text and other user interface (UI) elements flow within any parent element that controls their layout. (Inherited from FrameworkElement.)
Public property | Focusable | Gets or sets a value that indicates whether the element can receive focus. This is a dependency property. (Inherited from UIElement.)
Public property | FocusVisualStyle | Gets or sets a property that enables customization of appearance, effects, or other style characteristics that will apply to this element when it captures keyboard focus. (Inherited from FrameworkElement.)
Public property | FontFamily | Gets or sets the font family of the control. (Inherited from Control.)
Public property | FontSize | Gets or sets the font size. (Inherited from Control.)
Public property | FontStretch | Gets or sets the degree to which a font is condensed or expanded on the screen. (Inherited from Control.)
Public property | FontStyle | Gets or sets the font style. (Inherited from Control.)
Public property | FontWeight | Gets or sets the weight or thickness of the specified font. (Inherited from Control.)
Public property | ForceCursor | Gets or sets a value that indicates whether this FrameworkElement should force the user interface (UI) to render the cursor as declared by the Cursor property. (Inherited from FrameworkElement.)
Public property | Foreground | Gets or sets a brush that describes the foreground color. (Inherited from Control.)
Protected property | HandlesScrolling | Gets a value that indicates whether a control supports scrolling. (Inherited from Control.)
Public property | HasAnimatedProperties | Gets a value indicating whether this element has any animated properties. (Inherited from UIElement.)
Public property | HasContent | Gets a value that indicates whether the ContentControl contains content. (Inherited from ContentControl.)
Protected property | HasEffectiveKeyboardFocus | Gets a value that indicates whether the UIElement has focus. (Inherited from UIElement.)
Public property | Height | Gets or sets the suggested height of the element. (Inherited from FrameworkElement.)
Public property | HorizontalAlignment | Gets or sets the horizontal alignment characteristics applied to this element when it is composed within a parent element, such as a panel or items control. (Inherited from FrameworkElement.)
Public property | HorizontalContentAlignment | Gets or sets the horizontal alignment of the control's content. (Inherited from Control.)
Public property | Icon | Gets or sets a window's icon. (Inherited from Window.)
Protected property | InheritanceBehavior | Gets or sets the scope limits for property value inheritance, resource key lookup, and RelativeSource FindAncestor lookup. (Inherited from FrameworkElement.)
Public property | InputBindings | Gets the collection of input bindings associated with this element. (Inherited from UIElement.)
Public property | InputScope | Gets or sets the context for input used by this FrameworkElement. (Inherited from FrameworkElement.)
Public property | IsActive | Gets a value that indicates whether the window is active. (Inherited from Window.)
Public property | IsArrangeValid | Gets a value indicating whether the computed size and position of child elements in this element's layout are valid. (Inherited from UIElement.)
Public property | IsEnabled | Gets or sets a value indicating whether this element is enabled in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Protected property | IsEnabledCore | Gets a value that becomes the return value of IsEnabled in derived classes. (Inherited from UIElement.)
Public property | IsFocused | Gets a value that determines whether this element has logical focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsHitTestVisible | Gets or sets a value that declares whether this element can possibly be returned as a hit test result from some portion of its rendered content. This is a dependency property. (Inherited from UIElement.)
Public property | IsInitialized | Gets a value that indicates whether this element has been initialized, either during processing by a XAML processor, or by explicitly having its EndInit method called. (Inherited from FrameworkElement.)
Public property | IsInputMethodEnabled | Gets a value indicating whether an input method system, such as an Input Method Editor (IME), is enabled for processing the input to this element. (Inherited from UIElement.)
Public property | IsKeyboardFocused | Gets a value indicating whether this element has keyboard focus. This is a dependency property. (Inherited from UIElement.)
Public property | IsKeyboardFocusWithin | Gets a value indicating whether keyboard focus is anywhere within the element or its visual tree child elements. This is a dependency property. (Inherited from UIElement.)
Public property | IsLoaded | Gets a value that indicates whether this element has been loaded for presentation. (Inherited from FrameworkElement.)
Public property | IsManipulationEnabled | Gets or sets a value that indicates whether manipulation events are enabled on this UIElement. (Inherited from UIElement.)
Public property | IsMeasureValid | Gets a value indicating whether the current size returned by layout measure is valid. (Inherited from UIElement.)
Public property | IsMouseCaptured | Gets a value indicating whether the mouse is captured to this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseCaptureWithin | Gets a value that determines whether mouse capture is held by this element or by child elements in its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseDirectlyOver | Gets a value that indicates whether the position of the mouse pointer corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsMouseOver | Gets a value indicating whether the mouse pointer is located over this element (including child elements in the visual tree). This is a dependency property. (Inherited from UIElement.)
Public property | IsSealed | Gets a value that indicates whether this instance is currently sealed (read-only). (Inherited from DependencyObject.)
Public property | IsStylusCaptured | Gets a value indicating whether the stylus is captured by this element. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusCaptureWithin | Gets a value that determines whether stylus capture is held by this element, or an element within the element bounds and its visual tree. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusDirectlyOver | Gets a value that indicates whether the stylus position corresponds to hit test results, which take element compositing into account. This is a dependency property. (Inherited from UIElement.)
Public property | IsStylusOver | Gets a value indicating whether the stylus cursor is located over this element (including visual child elements). This is a dependency property. (Inherited from UIElement.)
Public property | IsTabStop | Gets or sets a value that indicates whether a control is included in tab navigation. (Inherited from Control.)
Public property | IsVisible | Gets a value indicating whether this element is visible in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | Language | Gets or sets localization/globalization language information that applies to an element. (Inherited from FrameworkElement.)
Public property | LayoutTransform | Gets or sets a graphics transformation that should apply to this element when layout is performed. (Inherited from FrameworkElement.)
Public property | Left | Gets or sets the position of the window's left edge, in relation to the desktop. (Inherited from Window.)
Protected property | LogicalChildren | Gets an enumerator for a window's logical child elements. (Inherited from Window.)
Public property | Margin | Gets or sets the outer margin of an element. (Inherited from FrameworkElement.)
Public property | MaxHeight | Gets or sets the maximum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MaxWidth | Gets or sets the maximum width constraint of the element. (Inherited from FrameworkElement.)
Public property | MinHeight | Gets or sets the minimum height constraint of the element. (Inherited from FrameworkElement.)
Public property | MinWidth | Gets or sets the minimum width constraint of the element. (Inherited from FrameworkElement.)
Public property | Name | Gets or sets the identifying name of the element. The name provides a reference so that code-behind, such as event handler code, can refer to a markup element after it is constructed during processing by a XAML processor. (Inherited from FrameworkElement.)
Public property | Opacity | Gets or sets the opacity factor applied to the entire UIElement when it is rendered in the user interface (UI). This is a dependency property. (Inherited from UIElement.)
Public property | OpacityMask | Gets or sets an opacity mask, as a Brush implementation that is applied to any alpha-channel masking for the rendered content of this element. This is a dependency property. (Inherited from UIElement.)
Public property | OverridesDefaultStyle | Gets or sets a value that indicates whether this element incorporates style properties from theme styles. (Inherited from FrameworkElement.)
Public property | OwnedWindows | Gets a collection of windows for which this window is the owner. (Inherited from Window.)
Public property | Owner | Gets or sets the Window that owns this Window. (Inherited from Window.)
Public property | Padding | Gets or sets the padding inside a control. (Inherited from Control.)
Public property | Parent | Gets the logical parent element of this element. (Inherited from FrameworkElement.)
Public property | PersistId | Obsolete. Gets a value that uniquely identifies this element. (Inherited from UIElement.)
Public property | ProviderFailure | Gets or sets flag that indicates if there was a failure during provider initialization.
Public property | RenderSize | Gets (or sets, but see Remarks) the final render size of this element. (Inherited from UIElement.)
Public property | RenderTransform | Gets or sets transform information that affects the rendering position of this element. This is a dependency property. (Inherited from UIElement.)
Public property | RenderTransformOrigin | Gets or sets the center point of any possible render transform declared by RenderTransform, relative to the bounds of the element. This is a dependency property. (Inherited from UIElement.)
Public property | ResizeMode | Gets or sets the resize mode. (Inherited from Window.)
Public property | Resources | Gets or sets the locally-defined resource dictionary. (Inherited from FrameworkElement.)
Public property | RestoreBounds | Gets the size and location of a window before being either minimized or maximized. (Inherited from Window.)
Public property | ShowActivated | Gets or sets a value that indicates whether a window is activated when first shown. (Inherited from Window.)
Public property | ShowInTaskbar | Gets or sets a value that indicates whether the window has a task bar button. (Inherited from Window.)
Public property | SizeToContent | Gets or sets a value that indicates whether a window will automatically size itself to fit the size of its content. (Inherited from Window.)
Public property | SnapsToDevicePixels | Gets or sets a value that determines whether rendering for this element should use device-specific pixel settings during rendering. This is a dependency property. (Inherited from UIElement.)
Public property | Style | Gets or sets the style used by this element when it is rendered. (Inherited from FrameworkElement.)
Protected property | StylusPlugIns | Gets a collection of all stylus plug-in (customization) objects associated with this element. (Inherited from UIElement.)
Public property | TabIndex | Gets or sets a value that determines the order in which elements receive focus when the user navigates through controls by using the TAB key. (Inherited from Control.)
Public property | Tag | Gets or sets an arbitrary object value that can be used to store custom information about this element. (Inherited from FrameworkElement.)
Public property | TaskbarItemInfo | Gets or sets the Windows 7 taskbar thumbnail for the Window. (Inherited from Window.)
Public property | Template | Gets or sets a control template. (Inherited from Control.)
Public property | TemplatedParent | Gets a reference to the template parent of this element. This property is not relevant if the element was not created through a template. (Inherited from FrameworkElement.)
Public property | Title | Gets or sets a window's title. (Inherited from Window.)
Public property | ToolTip | Gets or sets the tool-tip object that is displayed for this element in the user interface (UI). (Inherited from FrameworkElement.)
Public property | Top | Gets or sets the position of the window's top edge, in relation to the desktop. (Inherited from Window.)
Public property | Topmost | Gets or sets a value that indicates whether a window appears in the topmost z-order. (Inherited from Window.)
Public property | TouchesCaptured | Gets all touch devices that are captured to this element. (Inherited from UIElement.)
Public property | TouchesCapturedWithin | Gets all touch devices that are captured to this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | TouchesDirectlyOver | Gets all touch devices that are over this element. (Inherited from UIElement.)
Public property | TouchesOver | Gets all touch devices that are over this element or any child elements in its visual tree. (Inherited from UIElement.)
Public property | Triggers | Gets the collection of triggers established directly on this element, or in child elements. (Inherited from FrameworkElement.)
Public property | Uid | Gets or sets the unique identifier (for localization) for this element. This is a dependency property. (Inherited from UIElement.)
Public property | UseLayoutRounding | Gets or sets a value that indicates whether layout rounding should be applied to this element's size and position during layout. (Inherited from FrameworkElement.)
Public property | VerticalAlignment | Gets or sets the vertical alignment characteristics applied to this element when it is composed within a parent element such as a panel or items control. (Inherited from FrameworkElement.)
Public property | VerticalContentAlignment | Gets or sets the vertical alignment of the control's content. (Inherited from Control.)
Public property | Visibility | Gets or sets the user interface (UI) visibility of this element. This is a dependency property. (Inherited from UIElement.)
Protected property | VisualBitmapEffect | Obsolete. Gets or sets the BitmapEffect value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapEffectInput | Obsolete. Gets or sets the BitmapEffectInput value for the Visual. (Inherited from Visual.)
Protected property | VisualBitmapScalingMode | Gets or sets the BitmapScalingMode for the Visual. (Inherited from Visual.)
Protected property | VisualCacheMode | Gets or sets a cached representation of the Visual. (Inherited from Visual.)
Protected property | VisualChildrenCount | Gets the number of visual child elements within this element. (Inherited from FrameworkElement.)
Protected property | VisualClearTypeHint | Gets or sets the ClearTypeHint that determines how ClearType is rendered in the Visual. (Inherited from Visual.)
Protected property | VisualClip | Gets or sets the clip region of the Visual as a Geometry value. (Inherited from Visual.)
Protected property | VisualEdgeMode | Gets or sets the edge mode of the Visual as an EdgeMode value. (Inherited from Visual.)
Protected property | VisualEffect | Gets or sets the bitmap effect to apply to the Visual. (Inherited from Visual.)
Protected property | VisualOffset | Gets or sets the offset value of the visual object. (Inherited from Visual.)
Protected property | VisualOpacity | Gets or sets the opacity of the Visual. (Inherited from Visual.)
Protected property | VisualOpacityMask | Gets or sets the Brush value that represents the opacity mask of the Visual. (Inherited from Visual.)
Protected property | VisualParent | Gets the visual tree parent of the visual object. (Inherited from Visual.)
Protected property | VisualScrollableAreaClip | Gets or sets a clipped scrollable area for the Visual. (Inherited from Visual.)
Protected property | VisualTextHintingMode | Gets or sets the TextHintingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTextRenderingMode | Gets or sets the TextRenderingMode of the Visual. (Inherited from Visual.)
Protected property | VisualTransform | Gets or sets the Transform value for the Visual. (Inherited from Visual.)
Protected property | VisualXSnappingGuidelines | Gets or sets the x-coordinate (vertical) guideline collection. (Inherited from Visual.)
Protected property | VisualYSnappingGuidelines | Gets or sets the y-coordinate (horizontal) guideline collection. (Inherited from Visual.)
Public property | Width | Gets or sets the width of the element. (Inherited from FrameworkElement.)
Public property | WindowStartupLocation | Gets or sets the position of the window when first shown. (Inherited from Window.)
Public property | WindowState | Gets or sets a value that indicates whether a window is restored, minimized, or maximized. (Inherited from Window.)
Public property | WindowStyle | Gets or sets a window's border style. (Inherited from Window.)
Top
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


SecurityPortal.ProviderFailure Property

Grid Solutions Framework SecurityPortalProviderFailure Property
Gets or sets flag that indicates if there was a failure during provider initialization.

Namespace: GSF.Windows
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public bool ProviderFailure { get; set; }
Public Property ProviderFailure As Boolean
    Get
    Set
member ProviderFailure : bool with get, set

function get_ProviderFailure();
function set_ProviderFailure(value);
public:
property bool ProviderFailure {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


SecurityPortal Events

Grid Solutions Framework SecurityPortal Events

The SecurityPortal type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when a window becomes the foreground window. (Inherited from Window.)
Public event | Closed | Occurs when the window is about to close. (Inherited from Window.)
Public event | Closing | Occurs directly after Close is called, and can be handled to cancel window closure. (Inherited from Window.)
Public event | ContentRendered | Occurs after a window's content has been rendered. (Inherited from Window.)
Public event | ContextMenuClosing | Occurs just before any context menu on the element is closed. (Inherited from FrameworkElement.)
Public event | ContextMenuOpening | Occurs when any context menu on the element is opened. (Inherited from FrameworkElement.)
Public event | DataContextChanged | Occurs when the data context for this element changes. (Inherited from FrameworkElement.)
Public event | Deactivated | Occurs when a window becomes a background window. (Inherited from Window.)
Public event | DragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | DragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | DragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | Drop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | FocusableChanged | Occurs when the value of the Focusable property changes. (Inherited from UIElement.)
Public event | GiveFeedback | Occurs when the input system reports an underlying drag-and-drop event that involves this element. (Inherited from UIElement.)
Public event | GotFocus | Occurs when this element gets logical focus. (Inherited from UIElement.)
Public event | GotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | GotMouseCapture | Occurs when this element captures the mouse. (Inherited from UIElement.)
Public event | GotStylusCapture | Occurs when this element captures the stylus. (Inherited from UIElement.)
Public event | GotTouchCapture | Occurs when a touch is captured to this element. (Inherited from UIElement.)
Public event | Initialized | Occurs when this FrameworkElement is initialized. This event coincides with cases where the value of the IsInitialized property changes from false (or undefined) to true. (Inherited from FrameworkElement.)
Public event | IsEnabledChanged | Occurs when the value of the IsEnabled property on this element changes. (Inherited from UIElement.)
Public event | IsHitTestVisibleChanged | Occurs when the value of the IsHitTestVisible dependency property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusedChanged | Occurs when the value of the IsKeyboardFocused property changes on this element. (Inherited from UIElement.)
Public event | IsKeyboardFocusWithinChanged | Occurs when the value of the IsKeyboardFocusWithinChanged property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCapturedChanged | Occurs when the value of the IsMouseCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsMouseCaptureWithinChanged | Occurs when the value of the IsMouseCaptureWithinProperty changes on this element. (Inherited from UIElement.)
Public event | IsMouseDirectlyOverChanged | Occurs when the value of the IsMouseDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCapturedChanged | Occurs when the value of the IsStylusCaptured property changes on this element. (Inherited from UIElement.)
Public event | IsStylusCaptureWithinChanged | Occurs when the value of the IsStylusCaptureWithin property changes on this element. (Inherited from UIElement.)
Public event | IsStylusDirectlyOverChanged | Occurs when the value of the IsStylusDirectlyOver property changes on this element. (Inherited from UIElement.)
Public event | IsVisibleChanged | Occurs when the value of the IsVisible property changes on this element. (Inherited from UIElement.)
Public event | KeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | KeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | LayoutUpdated | Occurs when the layout of the various visual elements associated with the current Dispatcher changes. (Inherited from UIElement.)
Public event | Loaded | Occurs when the element is laid out, rendered, and ready for interaction. (Inherited from FrameworkElement.)
Public event | LocationChanged | Occurs when the window's location changes. (Inherited from Window.)
Public event | LostFocus | Occurs when this element loses logical focus. (Inherited from UIElement.)
Public event | LostKeyboardFocus | Occurs when the keyboard is no longer focused on this element,. (Inherited from UIElement.)
Public event | LostMouseCapture | Occurs when this element loses mouse capture. (Inherited from UIElement.)
Public event | LostStylusCapture | Occurs when this element loses stylus capture. (Inherited from UIElement.)
Public event | LostTouchCapture | Occurs when this element loses a touch capture. (Inherited from UIElement.)
Public event | ManipulationBoundaryFeedback | Occurs when the manipulation encounters a boundary. (Inherited from UIElement.)
Public event | ManipulationCompleted | Occurs when a manipulation and inertia on the UIElement object is complete. (Inherited from UIElement.)
Public event | ManipulationDelta | Occurs when the input device changes position during a manipulation. (Inherited from UIElement.)
Public event | ManipulationInertiaStarting | Occurs when the input device loses contact with the UIElement object during a manipulation and inertia begins. (Inherited from UIElement.)
Public event | ManipulationStarted | Occurs when an input device begins a manipulation on the UIElement object. (Inherited from UIElement.)
Public event | ManipulationStarting | Occurs when the manipulation processor is first created. (Inherited from UIElement.)
Public event | MouseDoubleClick | Occurs when a mouse button is clicked two or more times. (Inherited from Control.)
Public event | MouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | MouseEnter | Occurs when the mouse pointer enters the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the bounds of this element. (Inherited from UIElement.)
Public event | MouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseMove | Occurs when the mouse pointer moves while over this element. (Inherited from UIElement.)
Public event | MouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | MouseUp | Occurs when any mouse button is released over this element. (Inherited from UIElement.)
Public event | MouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewDragEnter | Occurs when the input system reports an underlying drag event with this element as the drag target. (Inherited from UIElement.)
Public event | PreviewDragLeave | Occurs when the input system reports an underlying drag event with this element as the drag origin. (Inherited from UIElement.)
Public event | PreviewDragOver | Occurs when the input system reports an underlying drag event with this element as the potential drop target. (Inherited from UIElement.)
Public event | PreviewDrop | Occurs when the input system reports an underlying drop event with this element as the drop target. (Inherited from UIElement.)
Public event | PreviewGiveFeedback | Occurs when a drag-and-drop operation is started. (Inherited from UIElement.)
Public event | PreviewGotKeyboardFocus | Occurs when the keyboard is focused on this element. (Inherited from UIElement.)
Public event | PreviewKeyDown | Occurs when a key is pressed while focus is on this element. (Inherited from UIElement.)
Public event | PreviewKeyUp | Occurs when a key is released while focus is on this element. (Inherited from UIElement.)
Public event | PreviewLostKeyboardFocus | Occurs when the keyboard is no longer focused on this element. (Inherited from UIElement.)
Public event | PreviewMouseDoubleClick | Occurs when a user clicks the mouse button two or more times. (Inherited from Control.)
Public event | PreviewMouseDown | Occurs when any mouse button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonDown | Occurs when the left mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseLeftButtonUp | Occurs when the left mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseMove | Occurs when the mouse pointer moves while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonDown | Occurs when the right mouse button is pressed while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseRightButtonUp | Occurs when the right mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseUp | Occurs when any mouse button is released while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewMouseWheel | Occurs when the user rotates the mouse wheel while the mouse pointer is over this element. (Inherited from UIElement.)
Public event | PreviewQueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | PreviewStylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | PreviewStylusDown | Occurs when the stylus touches the digitizer while it is over this element. (Inherited from UIElement.)
Public event | PreviewStylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | PreviewStylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | PreviewStylusMove | Occurs when the stylus moves while over the element. The stylus must move while being detected by the digitizer to raise this event, otherwise, PreviewStylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | PreviewStylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected. (Inherited from UIElement.)
Public event | PreviewStylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | PreviewStylusUp | Occurs when the user raises the stylus off the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | PreviewTextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | PreviewTouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | PreviewTouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | QueryContinueDrag | Occurs when there is a change in the keyboard or mouse button state during a drag-and-drop operation. (Inherited from UIElement.)
Public event | QueryCursor | Occurs when the cursor is requested to display. This event is raised on an element each time that the mouse pointer moves to a new location, which means the cursor object might need to be changed based on its new position. (Inherited from UIElement.)
Public event | RequestBringIntoView | Occurs when BringIntoView(Rect) is called on this element. (Inherited from FrameworkElement.)
Public event | SizeChanged | Occurs when either the ActualHeight or the ActualWidth properties change value on this element. (Inherited from FrameworkElement.)
Public event | SourceInitialized | This event is raised to support interoperation with Win32. See HwndSource. (Inherited from Window.)
Public event | SourceUpdated | Occurs when the source value changes for any existing property binding on this element. (Inherited from FrameworkElement.)
Public event | StateChanged | Occurs when the window's WindowState property changes. (Inherited from Window.)
Public event | StylusButtonDown | Occurs when the stylus button is pressed while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusButtonUp | Occurs when the stylus button is released while the pointer is over this element. (Inherited from UIElement.)
Public event | StylusDown | Occurs when the stylus touches the digitizer while the stylus is over this element. (Inherited from UIElement.)
Public event | StylusEnter | Occurs when the stylus enters the bounds of this element. (Inherited from UIElement.)
Public event | StylusInAirMove | Occurs when the stylus moves over an element without actually touching the digitizer. (Inherited from UIElement.)
Public event | StylusInRange | Occurs when the stylus is close enough to the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusLeave | Occurs when the stylus leaves the bounds of the element. (Inherited from UIElement.)
Public event | StylusMove | Occurs when the stylus moves over this element. The stylus must move while on the digitizer to raise this event. Otherwise, StylusInAirMove is raised instead. (Inherited from UIElement.)
Public event | StylusOutOfRange | Occurs when the stylus is too far from the digitizer to be detected, while over this element. (Inherited from UIElement.)
Public event | StylusSystemGesture | Occurs when a user performs one of several stylus gestures. (Inherited from UIElement.)
Public event | StylusUp | Occurs when the user raises the stylus off the digitizer while it is over this element. (Inherited from UIElement.)
Public event | TargetUpdated | Occurs when the target value changes for any property binding on this element. (Inherited from FrameworkElement.)
Public event | TextInput | Occurs when this element gets text in a device-independent manner. (Inherited from UIElement.)
Public event | ToolTipClosing | Occurs just before any tooltip on the element is closed. (Inherited from FrameworkElement.)
Public event | ToolTipOpening | Occurs when any tooltip on the element is opened. (Inherited from FrameworkElement.)
Public event | TouchDown | Occurs when a finger touches the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchEnter | Occurs when a touch moves from outside to inside the bounds of this element. (Inherited from UIElement.)
Public event | TouchLeave | Occurs when a touch moves from inside to outside the bounds of this element. (Inherited from UIElement.)
Public event | TouchMove | Occurs when a finger moves on the screen while the finger is over this element. (Inherited from UIElement.)
Public event | TouchUp | Occurs when a finger is raised off of the screen while the finger is over this element. (Inherited from UIElement.)
Public event | Unloaded | Occurs when the element is removed from within an element tree of loaded elements. (Inherited from FrameworkElement.)
Top
See Also

Reference

SecurityPortal Class
GSF.Windows Namespace


GSF.Windows.ErrorManagement Namespace

Grid Solutions Framework GSF.Windows.ErrorManagement Namespace

[Missing <summary> documentation for "N:GSF.Windows.ErrorManagement"]

Classes
 | Class | Description
Public class | ErrorDialog | Represents a dialog box that can be used to display detailed exception information.
 | ErrorLogger | Represents a logger that can be used for logging handled as well as unhandled exceptions across multiple application types (Windows Application, Console Application, Windows Service, Web Application, Web Service).


ErrorDialog Class

Grid Solutions Framework ErrorDialog Class
Represents a dialog box that can be used to display detailed exception information.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
GSF.Windows.ErrorManagementErrorDialog

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class ErrorDialog : Form
Public Class ErrorDialog
    Inherits Form
type ErrorDialog =
    class
        inherit Form
    end
GSF.Windows.ErrorManagement.ErrorDialog = function();

Type.createClass(
    'GSF.Windows.ErrorManagement.ErrorDialog',
    Form);
public ref class ErrorDialog : public Form

The ErrorDialog type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorDialog | Initializes a new instance of the ErrorDialog class.
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

GSF.Windows.ErrorManagement Namespace
GSF.Windows.ErrorManagementErrorLogger


ErrorDialog Constructor

Grid Solutions Framework ErrorDialog Constructor
Initializes a new instance of the ErrorDialog class.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorDialog()
Public Sub New
new : unit -> ErrorDialog
GSF.Windows.ErrorManagement.ErrorDialog = function();
public:
ErrorDialog()
See Also

Reference

ErrorDialog Class
GSF.Windows.ErrorManagement Namespace


ErrorDialog Methods

Grid Solutions Framework ErrorDialog Methods

The ErrorDialog type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
See Also

Reference

ErrorDialog Class
GSF.Windows.ErrorManagement Namespace


ErrorDialog.Dispose Method

Grid Solutions Framework ErrorDialogDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

ErrorDialog Class
GSF.Windows.ErrorManagement Namespace


ErrorDialog.Dispose Method (Boolean)

Grid Solutions Framework ErrorDialogDispose Method (Boolean)
Clean up any resources being used.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

ErrorDialog Class
Dispose Overload
GSF.Windows.ErrorManagement Namespace


ErrorDialog Properties

Grid Solutions Framework ErrorDialog Properties

The ErrorDialog type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

ErrorDialog Class
GSF.Windows.ErrorManagement Namespace


ErrorDialog Events

Grid Solutions Framework ErrorDialog Events

The ErrorDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

ErrorDialog Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger Class

Grid Solutions Framework ErrorLogger Class
Represents a logger that can be used for logging handled as well as unhandled exceptions across multiple application types (Windows Application, Console Application, Windows Service, Web Application, Web Service).
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
GSF.ErrorManagementErrorLogger
GSF.Windows.ErrorManagementErrorLogger

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[ToolboxBitmapAttribute(typeof(ErrorLogger))]
public class ErrorLogger : ErrorLogger
<ToolboxBitmapAttribute(GetType(ErrorLogger))>
Public Class ErrorLogger
    Inherits ErrorLogger
[<ToolboxBitmapAttribute(typeof(ErrorLogger))>]
type ErrorLogger =
    class
        inherit ErrorLogger
    end
GSF.Windows.ErrorManagement.ErrorLogger = function();

Type.createClass(
    'GSF.Windows.ErrorManagement.ErrorLogger',
    GSF.ErrorManagement.ErrorLogger);
[ToolboxBitmapAttribute(typeof(ErrorLogger))]
public ref class ErrorLogger : public ErrorLogger

The ErrorLogger type exposes the following members.

Constructors
 | Name | Description
Public method | ErrorLogger | Initializes a new instance of the ErrorLogger class.
Top
Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ErrorLogger object properties are initialized. (Inherited from ErrorLogger.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ErrorLogger object and optionally releases the managed resources. (Inherited from ErrorLogger.)
Public method | EndInit | Performs necessary operations after the ErrorLogger object properties are initialized. (Inherited from ErrorLogger.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExceptionToDatabase | Logs encountered Exception to the database. (Inherited from ErrorLogger.)
Protected method | ExceptionToEmail | Logs encountered Exception to an e-mail message. (Inherited from ErrorLogger.)
Protected method | ExceptionToEventLog | Logs encountered Exception to the EventLog. (Inherited from ErrorLogger.)
Protected method | ExceptionToFile | Logs encountered Exception to the ErrorLog. (Inherited from ErrorLogger.)
Protected method | ExceptionToScreenshot | Takes a screenshot of the user's desktop when the Exception is encountered.
Protected method | ExceptionToUI | Logs encountered Exception to the application UI. (Inherited from ErrorLogger.)
Protected method | ExceptionToWebPage | Shows Exception information in a Web Site. (Inherited from ErrorLogger.)
Protected method | ExceptionToWindowsCui | Shows Exception information in a Console Application. (Inherited from ErrorLogger.)
Protected method | ExceptionToWindowsGui | Shows Exception information in a Windows Application. (Overrides ErrorLoggerExceptionToWindowsGui.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Protected method | GetEmailAttachments | Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message. (Overrides ErrorLoggerGetEmailAttachments.)
Protected method | GetExtendedMoreInfoText | Allows other loggers to extend "more info text". (Overrides ErrorLoggerGetExtendedMoreInfoText(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetMoreInfoText | Default Delegate for MoreInfoTextMethod. (Inherited from ErrorLogger.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ErrorLogger object. (Inherited from ErrorLogger.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ErrorLogger object from the config file if the PersistSettings property is set to true. (Overrides ErrorLoggerLoadSettings.)
Public method | Log(Exception) | Logs information about the encountered Exception. (Inherited from ErrorLogger.)
Public method | Log(Exception, Boolean) | Logs information about the encountered Exception. (Inherited from ErrorLogger.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnLoggingException | Raises the LoggingException event. (Inherited from ErrorLogger.)
Protected method | Register | Registers the ErrorLogger object to handle unhandled Exception if the HandleUnhandledException property is set to true. (Overrides ErrorLoggerRegister.)
Public method | SaveSettings | Saves settings for the ErrorLogger object to the config file if the PersistSettings property is set to true. (Overrides ErrorLoggerSaveSettings.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | Unregister | Unregister the ErrorLogger object from handling unhandled Exception. (Overrides ErrorLoggerUnregister.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
Fields
Name | Description
DefaultLogToScreenshot | Specifies the default value for the LogToScreenshot property.
Top
Properties
 | Name | Description
 | ActionTextMethod | Gets or sets the Delegate that provides text stating the action(s) that can be taken by the end-user after an Exception is encountered. (Inherited from ErrorLogger.)
Public property | ApplicationName | Gets the name of the currently executing application. (Inherited from ErrorLogger.)
Public property | ApplicationType | Gets the type of the currently executing application. (Inherited from ErrorLogger.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ContactEmail | Gets or sets the e-mail address where e-mail messages containing Exception information are to be sent when the LogToEmail property is set to true. (Inherited from ErrorLogger.)
Public property | ContactName | Gets or sets the name of the person who can be contacted by the end-user in case of an Exception. (Inherited from ErrorLogger.)
Public property | ContactPhone | Gets or sets the phone number that can be used by the end-user to communicate about an encountered Exception. (Inherited from ErrorLogger.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DatabaseLogSize | Gets or sets the maximum exception log size to maintain when logging exceptions to the database. (Inherited from ErrorLogger.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ErrorLogger object is currently enabled. (Inherited from ErrorLogger.)
Public property | ErrorLog | Get the LogFile object used for logging Exception information to a file. (Inherited from ErrorLogger.)
 | ErrorTextMethod | Gets or sets the Delegate that provides common text stating what could have possibly caused the Exception. (Inherited from ErrorLogger.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExitOnUnhandledException | Gets or sets a boolean value that indicates whether the application will terminate after logging an unhandled Exception. (Inherited from ErrorLogger.)
Public property | HandleUnhandledException | Gets or sets a boolean value that indicates whether the ErrorLogger object must register itself to handle Exception that are not trapped inside of a try-catch block. (Inherited from ErrorLogger.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ErrorLogger.)
Public property | LastException | Get the last encountered Exception. (Inherited from ErrorLogger.)
Public property | Loggers | Gets a list of methods registered for logging information about an encountered Exception. (Inherited from ErrorLogger.)
Public property | LogToDatabase | Gets or sets a boolean value that indicates whether Exception information is to be written to the database. (Inherited from ErrorLogger.)
Public property | LogToEmail | Gets or sets a boolean value that indicates whether Exception information is to be sent in an e-mail to the ContactEmail address. (Inherited from ErrorLogger.)
Public property | LogToEventLog | Gets or sets a boolean value that indicates whether Exception information is to be written to the EventLog. (Inherited from ErrorLogger.)
Public property | LogToFile | Gets or sets a boolean value that indicates whether Exception information is to be written to the ErrorLog. (Inherited from ErrorLogger.)
Public property | LogToScreenshot | Gets or sets a boolean value that indicates whether a screenshot of the user's desktop is to be taken when an Exception is logged.
Public property | LogToUI | Gets or sets a boolean value that indicates whether Exception information is to be displayed on the application UI. (Inherited from ErrorLogger.)
Public property | LogUserInfo | Gets or sets a boolean value that indicates whether information about local user (for windows applications) or remote user (for web applications) is to be logged when logging an Exception. (Inherited from ErrorLogger.)
Public property | MoreInfoTextMethod | Gets or sets the Delegate that provides text containing detailed information about the encountered Exception. (Inherited from ErrorLogger.)
Public property | Name | Gets the unique identifier of the ErrorLogger object. (Inherited from ErrorLogger.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ErrorLogger object are to be saved to the config file. (Inherited from ErrorLogger.)
 | ScopeTextMethod | Gets or sets the Delegate that provides text stating what is going to happen as a result of the Exception. (Inherited from ErrorLogger.)
Public property | SettingsCategory | Gets or sets the category under which the settings of ErrorLogger object are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ErrorLogger.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmtpServer | Gets or sets the SMTP server to be used for sending e-mail messages containing Exception information to the ContactEmail address. (Inherited from ErrorLogger.)
Public property | Status | Gets the descriptive status of the ErrorLogger object. (Overrides ErrorLoggerStatus.)
Public property | SuppressInteractiveLogging | Gets or sets flag that controls if Loggers requiring interaction either directly or indirectly when logging handled Exception using the Log(Exception) method are enabled. (Inherited from ErrorLogger.)
Top
Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | LoggingException | Occurs when an Exception is encountered while logging an Exception. (Inherited from ErrorLogger.)
Top
Examples
This example shows how to use the ErrorLogger component to log handled and unhandled exceptions:
Copy
using System;
using System.IO;
using GSF.Windows.ErrorManagement;

class Program
{
    static ErrorLogger s_logger;

    static Program()
    {
        s_logger = new ErrorLogger();
        s_logger.LogToUI = true;                    // Show exception info on the UI.
        s_logger.LogToFile = true;                  // Log exception info to a file.
        s_logger.LogToEmail = true;                 // Send exception info in an e-mail.
        s_logger.LogToEventLog = true;              // Log exception info to the event log.
        s_logger.LogToScreenshot = true;            // Take a screenshot of desktop on exception.
        s_logger.ContactEmail = "dev@email.com";    // Provide an e-mail address.
        s_logger.HandleUnhandledException = true;   // Configure to handle unhandled exceptions.
        s_logger.PersistSettings = true;            // Save settings to the config file.
        s_logger.Initialize();                      // Initialize ErrorLogger component for use.
    }

    static void Main(string[] args)
    {
        try
        {
            // This may cause a handled FileNotFoundException if the file doesn't exist.
            string data = File.ReadAllText(@"c:\NonExistentFile.txt");
        }
        catch (Exception ex)
        {
            // When logging handled exceptions we want to disable loggers (UI logger and E-mail logger) that
            // may require interaction either directly or indirectly as it can be annoying. All the loggers
            // are enabled automatically after the handled exception has been logged.
            s_logger.SuppressInteractiveLogging();
            s_logger.Log(ex);
        }

        int numerator = 1;
        int denominator = 0;
        int result = numerator / denominator;   // This will cause an unhandled DivideByZeroException.

        Console.ReadLine();
    }
}
See Also

Reference

GSF.Windows.ErrorManagement Namespace
GSF.ErrorManagementErrorModule


ErrorLogger Constructor

Grid Solutions Framework ErrorLogger Constructor
Initializes a new instance of the ErrorLogger class.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public ErrorLogger()
Public Sub New
new : unit -> ErrorLogger
GSF.Windows.ErrorManagement.ErrorLogger = function();
public:
ErrorLogger()
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger Fields

Grid Solutions Framework ErrorLogger Fields

The ErrorLogger type exposes the following members.

Fields
Name | Description
DefaultLogToScreenshot | Specifies the default value for the LogToScreenshot property.
Top
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.DefaultLogToScreenshot Field

Grid Solutions Framework ErrorLoggerDefaultLogToScreenshot Field
Specifies the default value for the LogToScreenshot property.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const bool DefaultLogToScreenshot
Public Const DefaultLogToScreenshot As Boolean
static val mutable DefaultLogToScreenshot: bool
var GSF.Windows.ErrorManagement.ErrorLogger.DefaultLogToScreenshot
public:
literal bool DefaultLogToScreenshot

Field Value

Type: Boolean
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger Methods

Grid Solutions Framework ErrorLogger Methods

The ErrorLogger type exposes the following members.

Methods
 | Name | Description
Public method | BeginInit | Performs necessary operations before the ErrorLogger object properties are initialized. (Inherited from ErrorLogger.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Releases the unmanaged resources used by the ErrorLogger object and optionally releases the managed resources. (Inherited from ErrorLogger.)
Public method | EndInit | Performs necessary operations after the ErrorLogger object properties are initialized. (Inherited from ErrorLogger.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | ExceptionToDatabase | Logs encountered Exception to the database. (Inherited from ErrorLogger.)
Protected method | ExceptionToEmail | Logs encountered Exception to an e-mail message. (Inherited from ErrorLogger.)
Protected method | ExceptionToEventLog | Logs encountered Exception to the EventLog. (Inherited from ErrorLogger.)
Protected method | ExceptionToFile | Logs encountered Exception to the ErrorLog. (Inherited from ErrorLogger.)
Protected method | ExceptionToScreenshot | Takes a screenshot of the user's desktop when the Exception is encountered.
Protected method | ExceptionToUI | Logs encountered Exception to the application UI. (Inherited from ErrorLogger.)
Protected method | ExceptionToWebPage | Shows Exception information in a Web Site. (Inherited from ErrorLogger.)
Protected method | ExceptionToWindowsCui | Shows Exception information in a Console Application. (Inherited from ErrorLogger.)
Protected method | ExceptionToWindowsGui | Shows Exception information in a Windows Application. (Overrides ErrorLoggerExceptionToWindowsGui.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Protected method | GetEmailAttachments | Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message. (Overrides ErrorLoggerGetEmailAttachments.)
Protected method | GetExtendedMoreInfoText | Allows other loggers to extend "more info text". (Overrides ErrorLoggerGetExtendedMoreInfoText(String).)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | GetMoreInfoText | Default Delegate for MoreInfoTextMethod. (Inherited from ErrorLogger.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Initialize | Initializes the ErrorLogger object. (Inherited from ErrorLogger.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | LoadSettings | Loads saved settings for the ErrorLogger object from the config file if the PersistSettings property is set to true. (Overrides ErrorLoggerLoadSettings.)
Public method | Log(Exception) | Logs information about the encountered Exception. (Inherited from ErrorLogger.)
Public method | Log(Exception, Boolean) | Logs information about the encountered Exception. (Inherited from ErrorLogger.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | OnLoggingException | Raises the LoggingException event. (Inherited from ErrorLogger.)
Protected method | Register | Registers the ErrorLogger object to handle unhandled Exception if the HandleUnhandledException property is set to true. (Overrides ErrorLoggerRegister.)
Public method | SaveSettings | Saves settings for the ErrorLogger object to the config file if the PersistSettings property is set to true. (Overrides ErrorLoggerSaveSettings.)
Public method | ToString | Returns a String containing the name of the Component, if any. This method should not be overridden. (Inherited from Component.)
Protected method | Unregister | Unregister the ErrorLogger object from handling unhandled Exception. (Overrides ErrorLoggerUnregister.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Top
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.ExceptionToScreenshot Method

Grid Solutions Framework ErrorLoggerExceptionToScreenshot Method
Takes a screenshot of the user's desktop when the Exception is encountered.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual void ExceptionToScreenshot(
    Exception exception
)
Protected Overridable Sub ExceptionToScreenshot (
    exception As Exception
)
abstract ExceptionToScreenshot :
        exception : Exception -> unit
override ExceptionToScreenshot :
        exception : Exception -> unit
function ExceptionToScreenshot(exception);
protected:
virtual void ExceptionToScreenshot(
    Exception^ exception
)

Parameters

exception
Type: SystemException
Exception that was encountered.
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.ExceptionToWindowsGui Method

Grid Solutions Framework ErrorLoggerExceptionToWindowsGui Method
Shows Exception information in a Windows Application.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void ExceptionToWindowsGui()
Protected Overrides Sub ExceptionToWindowsGui
abstract ExceptionToWindowsGui : unit -> unit
override ExceptionToWindowsGui : unit -> unit
function ExceptionToWindowsGui();
protected:
virtual void ExceptionToWindowsGui() override
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.GetEmailAttachments Method

Grid Solutions Framework ErrorLoggerGetEmailAttachments Method
Gets or sets the comma-separated or semicolon-separated list of file names to be attached to the Mail message.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override string GetEmailAttachments()
Protected Overrides Function GetEmailAttachments As String
abstract GetEmailAttachments : unit -> string
override GetEmailAttachments : unit -> string
function GetEmailAttachments();
protected:
virtual String^ GetEmailAttachments() override

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.Windows.ErrorManagement.ErrorLogger.GetEmailAttachments"]

See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.GetExtendedMoreInfoText Method

Grid Solutions Framework ErrorLoggerGetExtendedMoreInfoText Method
Allows other loggers to extend "more info text".

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override string GetExtendedMoreInfoText(
    string bullet
)
Protected Overrides Function GetExtendedMoreInfoText (
    bullet As String
) As String
abstract GetExtendedMoreInfoText :
        bullet : string -> string
override GetExtendedMoreInfoText :
        bullet : string -> string
function GetExtendedMoreInfoText(bullet);
protected:
virtual String^ GetExtendedMoreInfoText(
    String^ bullet
) override

Parameters

bullet
Type: SystemString
Type of bullet to use for extended info text.

Return Value

Type: String

[Missing <returns> documentation for "M:GSF.Windows.ErrorManagement.ErrorLogger.GetExtendedMoreInfoText(System.String)"]

See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.LoadSettings Method

Grid Solutions Framework ErrorLoggerLoadSettings Method
Loads saved settings for the ErrorLogger object from the config file if the PersistSettings property is set to true.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void LoadSettings()
Public Overrides Sub LoadSettings
abstract LoadSettings : unit -> unit
override LoadSettings : unit -> unit
function LoadSettings();
public:
virtual void LoadSettings() override

Implements

IPersistSettingsLoadSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.Register Method

Grid Solutions Framework ErrorLoggerRegister Method
Registers the ErrorLogger object to handle unhandled Exception if the HandleUnhandledException property is set to true.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool Register()
Protected Overrides Function Register As Boolean
abstract Register : unit -> bool
override Register : unit -> bool
function Register();
protected:
virtual bool Register() override

Return Value

Type: Boolean
true if handlers were registered; otherwise false.
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.SaveSettings Method

Grid Solutions Framework ErrorLoggerSaveSettings Method
Saves settings for the ErrorLogger object to the config file if the PersistSettings property is set to true.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override void SaveSettings()
Public Overrides Sub SaveSettings
abstract SaveSettings : unit -> unit
override SaveSettings : unit -> unit
function SaveSettings();
public:
virtual void SaveSettings() override

Implements

IPersistSettingsSaveSettings
Exceptions
Exception | Condition
ConfigurationErrorsException | SettingsCategory has a value of null or empty string.
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.Unregister Method

Grid Solutions Framework ErrorLoggerUnregister Method
Unregister the ErrorLogger object from handling unhandled Exception.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override bool Unregister()
Protected Overrides Function Unregister As Boolean
abstract Unregister : unit -> bool
override Unregister : unit -> bool
function Unregister();
protected:
virtual bool Unregister() override

Return Value

Type: Boolean
true if handlers were unregistered; otherwise false.
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger Properties

Grid Solutions Framework ErrorLogger Properties

The ErrorLogger type exposes the following members.

Properties
 | Name | Description
 | ActionTextMethod | Gets or sets the Delegate that provides text stating the action(s) that can be taken by the end-user after an Exception is encountered. (Inherited from ErrorLogger.)
Public property | ApplicationName | Gets the name of the currently executing application. (Inherited from ErrorLogger.)
Public property | ApplicationType | Gets the type of the currently executing application. (Inherited from ErrorLogger.)
Protected property | CanRaiseEvents | Gets a value indicating whether the component can raise an event. (Inherited from Component.)
Public property | ContactEmail | Gets or sets the e-mail address where e-mail messages containing Exception information are to be sent when the LogToEmail property is set to true. (Inherited from ErrorLogger.)
Public property | ContactName | Gets or sets the name of the person who can be contacted by the end-user in case of an Exception. (Inherited from ErrorLogger.)
Public property | ContactPhone | Gets or sets the phone number that can be used by the end-user to communicate about an encountered Exception. (Inherited from ErrorLogger.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | DatabaseLogSize | Gets or sets the maximum exception log size to maintain when logging exceptions to the database. (Inherited from ErrorLogger.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | Enabled | Gets or sets a boolean value that indicates whether the ErrorLogger object is currently enabled. (Inherited from ErrorLogger.)
Public property | ErrorLog | Get the LogFile object used for logging Exception information to a file. (Inherited from ErrorLogger.)
 | ErrorTextMethod | Gets or sets the Delegate that provides common text stating what could have possibly caused the Exception. (Inherited from ErrorLogger.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | ExitOnUnhandledException | Gets or sets a boolean value that indicates whether the application will terminate after logging an unhandled Exception. (Inherited from ErrorLogger.)
Public property | HandleUnhandledException | Gets or sets a boolean value that indicates whether the ErrorLogger object must register itself to handle Exception that are not trapped inside of a try-catch block. (Inherited from ErrorLogger.)
Public property | IsDisposed | Gets a flag that indicates whether the object has been disposed. (Inherited from ErrorLogger.)
Public property | LastException | Get the last encountered Exception. (Inherited from ErrorLogger.)
Public property | Loggers | Gets a list of methods registered for logging information about an encountered Exception. (Inherited from ErrorLogger.)
Public property | LogToDatabase | Gets or sets a boolean value that indicates whether Exception information is to be written to the database. (Inherited from ErrorLogger.)
Public property | LogToEmail | Gets or sets a boolean value that indicates whether Exception information is to be sent in an e-mail to the ContactEmail address. (Inherited from ErrorLogger.)
Public property | LogToEventLog | Gets or sets a boolean value that indicates whether Exception information is to be written to the EventLog. (Inherited from ErrorLogger.)
Public property | LogToFile | Gets or sets a boolean value that indicates whether Exception information is to be written to the ErrorLog. (Inherited from ErrorLogger.)
Public property | LogToScreenshot | Gets or sets a boolean value that indicates whether a screenshot of the user's desktop is to be taken when an Exception is logged.
Public property | LogToUI | Gets or sets a boolean value that indicates whether Exception information is to be displayed on the application UI. (Inherited from ErrorLogger.)
Public property | LogUserInfo | Gets or sets a boolean value that indicates whether information about local user (for windows applications) or remote user (for web applications) is to be logged when logging an Exception. (Inherited from ErrorLogger.)
Public property | MoreInfoTextMethod | Gets or sets the Delegate that provides text containing detailed information about the encountered Exception. (Inherited from ErrorLogger.)
Public property | Name | Gets the unique identifier of the ErrorLogger object. (Inherited from ErrorLogger.)
Public property | PersistSettings | Gets or sets a boolean value that indicates whether the settings of ErrorLogger object are to be saved to the config file. (Inherited from ErrorLogger.)
 | ScopeTextMethod | Gets or sets the Delegate that provides text stating what is going to happen as a result of the Exception. (Inherited from ErrorLogger.)
Public property | SettingsCategory | Gets or sets the category under which the settings of ErrorLogger object are to be saved to the config file if the PersistSettings property is set to true. (Inherited from ErrorLogger.)
Public property | Site | Gets or sets the ISite of the Component. (Inherited from Component.)
Public property | SmtpServer | Gets or sets the SMTP server to be used for sending e-mail messages containing Exception information to the ContactEmail address. (Inherited from ErrorLogger.)
Public property | Status | Gets the descriptive status of the ErrorLogger object. (Overrides ErrorLoggerStatus.)
Public property | SuppressInteractiveLogging | Gets or sets flag that controls if Loggers requiring interaction either directly or indirectly when logging handled Exception using the Log(Exception) method are enabled. (Inherited from ErrorLogger.)
Top
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.LogToScreenshot Property

Grid Solutions Framework ErrorLoggerLogToScreenshot Property
Gets or sets a boolean value that indicates whether a screenshot of the user's desktop is to be taken when an Exception is logged.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
[DefaultValueAttribute(false)]
public bool LogToScreenshot { get; set; }
<DefaultValueAttribute(false)>
Public Property LogToScreenshot As Boolean
    Get
    Set
[<DefaultValueAttribute(false)>]
member LogToScreenshot : bool with get, set

function get_LogToScreenshot();
function set_LogToScreenshot(value);
public:
[DefaultValueAttribute(false)]
property bool LogToScreenshot {
    bool get ();
    void set (bool value);
}

Property Value

Type: Boolean
Remarks
This setting is ignored in Web Application and Web Service application types.
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger.Status Property

Grid Solutions Framework ErrorLoggerStatus Property
Gets the descriptive status of the ErrorLogger object.

Namespace: GSF.Windows.ErrorManagement
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public override string Status { get; }
Public Overrides ReadOnly Property Status As String
    Get
abstract Status : string with get
override Status : string with get
function get_Status();

public:
virtual property String^ Status {
    String^ get () override;
}

Property Value

Type: String

Implements

IProvideStatusStatus
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


ErrorLogger Events

Grid Solutions Framework ErrorLogger Events

The ErrorLogger type exposes the following members.

Events
 | Name | Description
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | LoggingException | Occurs when an Exception is encountered while logging an Exception. (Inherited from ErrorLogger.)
Top
See Also

Reference

ErrorLogger Class
GSF.Windows.ErrorManagement Namespace


GSF.Windows.Forms Namespace

Grid Solutions Framework GSF.Windows.Forms Namespace
Contains classes, extension functions and forms used to simplify and standardize usage of basic Windows forms.
Classes
 | Class | Description
Public class | AboutDialog | Represents a common about dialog box.
Public class | FormExtensions | Extensions applied to all System.Windows.Forms.Form objects.
Public class | PropertyGridExtensions | Defines extension functions for the PropertyGrid control.
Public class | ScreenArea | Returns screen area statistics and capture functionality for all connected screens.
 | SecureForm | Represents a windows form secured using role-based security.


AboutDialog Class

Grid Solutions Framework AboutDialog Class
Represents a common about dialog box.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
GSF.Windows.FormsAboutDialog

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class AboutDialog : Form
Public Class AboutDialog
    Inherits Form
type AboutDialog =
    class
        inherit Form
    end
GSF.Windows.Forms.AboutDialog = function();

Type.createClass(
    'GSF.Windows.Forms.AboutDialog',
    Form);
public ref class AboutDialog : public Form

The AboutDialog type exposes the following members.

Constructors
 | Name | Description
Public method | AboutDialog | Initializes a new instance of the AboutDialog class.
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideApplicationTab | Conceals the tab where application information is displayed.
Public method | HideAssembliesTab | Conceals the tab where assemblies and their information is displayed.
Public method | HideDisclaimerTab | Conceals the tab where disclaimer text is displayed.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetCompanyDisclaimer(Stream) | Sets the disclaimer text that is to be displayed in the About Dialog.
Public method | SetCompanyDisclaimer(String) | Sets the disclaimer text that is to be displayed in the About Dialog.
Public method | SetCompanyLogo(Stream) | Sets the logo that is to be displayed in the About Dialog.
Public method | SetCompanyLogo(String) | Sets the logo that is to be displayed in the About Dialog.
Public method | SetCompanyUrl | Sets the URL that will be opened when the logo is clicked.
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

GSF.Windows.Forms Namespace


AboutDialog Constructor

Grid Solutions Framework AboutDialog Constructor
Initializes a new instance of the AboutDialog class.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public AboutDialog()
Public Sub New
new : unit -> AboutDialog
GSF.Windows.Forms.AboutDialog = function();
public:
AboutDialog()
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog Methods

Grid Solutions Framework AboutDialog Methods

The AboutDialog type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | HideApplicationTab | Conceals the tab where application information is displayed.
Public method | HideAssembliesTab | Conceals the tab where assemblies and their information is displayed.
Public method | HideDisclaimerTab | Conceals the tab where disclaimer text is displayed.
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetCompanyDisclaimer(Stream) | Sets the disclaimer text that is to be displayed in the About Dialog.
Public method | SetCompanyDisclaimer(String) | Sets the disclaimer text that is to be displayed in the About Dialog.
Public method | SetCompanyLogo(Stream) | Sets the logo that is to be displayed in the About Dialog.
Public method | SetCompanyLogo(String) | Sets the logo that is to be displayed in the About Dialog.
Public method | SetCompanyUrl | Sets the URL that will be opened when the logo is clicked.
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog.Dispose Method

Grid Solutions Framework AboutDialogDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog.Dispose Method (Boolean)

Grid Solutions Framework AboutDialogDispose Method (Boolean)
Clean up any resources being used.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

AboutDialog Class
Dispose Overload
GSF.Windows.Forms Namespace


AboutDialog.HideApplicationTab Method

Grid Solutions Framework AboutDialogHideApplicationTab Method
Conceals the tab where application information is displayed.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void HideApplicationTab()
Public Sub HideApplicationTab
member HideApplicationTab : unit -> unit

function HideApplicationTab();
public:
void HideApplicationTab()
Remarks
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog.HideAssembliesTab Method

Grid Solutions Framework AboutDialogHideAssembliesTab Method
Conceals the tab where assemblies and their information is displayed.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void HideAssembliesTab()
Public Sub HideAssembliesTab
member HideAssembliesTab : unit -> unit

function HideAssembliesTab();
public:
void HideAssembliesTab()
Remarks
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog.HideDisclaimerTab Method

Grid Solutions Framework AboutDialogHideDisclaimerTab Method
Conceals the tab where disclaimer text is displayed.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void HideDisclaimerTab()
Public Sub HideDisclaimerTab
member HideDisclaimerTab : unit -> unit

function HideDisclaimerTab();
public:
void HideDisclaimerTab()
Remarks
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog.SetCompanyDisclaimer Method

Grid Solutions Framework AboutDialogSetCompanyDisclaimer Method
Overload List
 | Name | Description
Public method | SetCompanyDisclaimer(Stream) | Sets the disclaimer text that is to be displayed in the About Dialog.
Public method | SetCompanyDisclaimer(String) | Sets the disclaimer text that is to be displayed in the About Dialog.
Top
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog.SetCompanyDisclaimer Method (Stream)

Grid Solutions Framework AboutDialogSetCompanyDisclaimer Method (Stream)
Sets the disclaimer text that is to be displayed in the About Dialog.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCompanyDisclaimer(
    Stream disclaimerStream
)
Public Sub SetCompanyDisclaimer (
    disclaimerStream As Stream
)
member SetCompanyDisclaimer :
        disclaimerStream : Stream -> unit

function SetCompanyDisclaimer(disclaimerStream);
public:
void SetCompanyDisclaimer(
    Stream^ disclaimerStream
)

Parameters

disclaimerStream
Type: System.IOStream
System.IO.Stream of the disclaimer text.
Remarks
See Also

Reference

AboutDialog Class
SetCompanyDisclaimer Overload
GSF.Windows.Forms Namespace


AboutDialog.SetCompanyDisclaimer Method (String)

Grid Solutions Framework AboutDialogSetCompanyDisclaimer Method (String)
Sets the disclaimer text that is to be displayed in the About Dialog.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCompanyDisclaimer(
    string disclaimerFile
)
Public Sub SetCompanyDisclaimer (
    disclaimerFile As String
)
member SetCompanyDisclaimer :
        disclaimerFile : string -> unit

function SetCompanyDisclaimer(disclaimerFile);
public:
void SetCompanyDisclaimer(
    String^ disclaimerFile
)

Parameters

disclaimerFile
Type: SystemString
Location of the file that contains the disclaimer text.
Remarks
See Also

Reference

AboutDialog Class
SetCompanyDisclaimer Overload
GSF.Windows.Forms Namespace


AboutDialog.SetCompanyLogo Method

Grid Solutions Framework AboutDialogSetCompanyLogo Method
Overload List
 | Name | Description
Public method | SetCompanyLogo(Stream) | Sets the logo that is to be displayed in the About Dialog.
Public method | SetCompanyLogo(String) | Sets the logo that is to be displayed in the About Dialog.
Top
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog.SetCompanyLogo Method (Stream)

Grid Solutions Framework AboutDialogSetCompanyLogo Method (Stream)
Sets the logo that is to be displayed in the About Dialog.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCompanyLogo(
    Stream logoStream
)
Public Sub SetCompanyLogo (
    logoStream As Stream
)
member SetCompanyLogo :
        logoStream : Stream -> unit

function SetCompanyLogo(logoStream);
public:
void SetCompanyLogo(
    Stream^ logoStream
)

Parameters

logoStream
Type: System.IOStream
System.IO.Stream of the logo.
Remarks
See Also

Reference

AboutDialog Class
SetCompanyLogo Overload
GSF.Windows.Forms Namespace


AboutDialog.SetCompanyLogo Method (String)

Grid Solutions Framework AboutDialogSetCompanyLogo Method (String)
Sets the logo that is to be displayed in the About Dialog.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCompanyLogo(
    string logoFile
)
Public Sub SetCompanyLogo (
    logoFile As String
)
member SetCompanyLogo :
        logoFile : string -> unit

function SetCompanyLogo(logoFile);
public:
void SetCompanyLogo(
    String^ logoFile
)

Parameters

logoFile
Type: SystemString
Location of the logo file.
Remarks
See Also

Reference

AboutDialog Class
SetCompanyLogo Overload
GSF.Windows.Forms Namespace


AboutDialog.SetCompanyUrl Method

Grid Solutions Framework AboutDialogSetCompanyUrl Method
Sets the URL that will be opened when the logo is clicked.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public void SetCompanyUrl(
    string url
)
Public Sub SetCompanyUrl (
    url As String
)
member SetCompanyUrl :
        url : string -> unit

function SetCompanyUrl(url);
public:
void SetCompanyUrl(
    String^ url
)

Parameters

url
Type: SystemString
URL of the company's home page.
Remarks
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog Properties

Grid Solutions Framework AboutDialog Properties

The AboutDialog type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


AboutDialog Events

Grid Solutions Framework AboutDialog Events

The AboutDialog type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

AboutDialog Class
GSF.Windows.Forms Namespace


FormExtensions Class

Grid Solutions Framework FormExtensions Class
Extensions applied to all System.Windows.Forms.Form objects.
Inheritance Hierarchy
SystemObject
GSF.Windows.FormsFormExtensions

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class FormExtensions
<ExtensionAttribute>
Public NotInheritable Class FormExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FormExtensions =  class end
GSF.Windows.Forms.FormExtensions = function();

Type.createClass(
    'GSF.Windows.Forms.FormExtensions');
[ExtensionAttribute]
public ref class FormExtensions abstract sealed

The FormExtensions type exposes the following members.

Methods
Name | Description
RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file.
RestoreLocation(Form) | Restores the location of the specified windowsForm from the location information saved in the application configuration file.
RestoreLocation(Form, String) | Restores the location of the specified windowsForm from the location information saved in the application configuration file.
RestoreSize(Form) | Restores the size of the specified windowsForm from the size information saved in the application configuration file.
RestoreSize(Form, String) | Restores the size of the specified windowsForm from the size information saved in the application configuration file.
SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file.
SaveLocation(Form) | Saves the location information of the specified windowsForm to the application configuration file.
SaveLocation(Form, String) | Saves the location information of the specified windowsForm to the application configuration file.
SaveSize(Form) | Saves the size information of the specified windowsForm to the application configuration file.
SaveSize(Form, String) | Saves the size information of the specified windowsForm to the application configuration file.
Top
Fields
Name | Description
LastWindowLocationSettingsCategory | Config file category under which the window location information will be saved.
LastWindowSizeSettingsCategory | Config file category under which the window size information will be saved.
Top
See Also

Reference

GSF.Windows.Forms Namespace


FormExtensions Fields

Grid Solutions Framework FormExtensions Fields

The FormExtensions type exposes the following members.

Fields
Name | Description
LastWindowLocationSettingsCategory | Config file category under which the window location information will be saved.
LastWindowSizeSettingsCategory | Config file category under which the window size information will be saved.
Top
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.LastWindowLocationSettingsCategory Field

Grid Solutions Framework FormExtensionsLastWindowLocationSettingsCategory Field
Config file category under which the window location information will be saved.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string LastWindowLocationSettingsCategory
Public Const LastWindowLocationSettingsCategory As String
static val mutable LastWindowLocationSettingsCategory: string
var GSF.Windows.Forms.FormExtensions.LastWindowLocationSettingsCategory
public:
literal String^ LastWindowLocationSettingsCategory

Field Value

Type: String
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.LastWindowSizeSettingsCategory Field

Grid Solutions Framework FormExtensionsLastWindowSizeSettingsCategory Field
Config file category under which the window size information will be saved.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public const string LastWindowSizeSettingsCategory
Public Const LastWindowSizeSettingsCategory As String
static val mutable LastWindowSizeSettingsCategory: string
var GSF.Windows.Forms.FormExtensions.LastWindowSizeSettingsCategory
public:
literal String^ LastWindowSizeSettingsCategory

Field Value

Type: String
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions Methods

Grid Solutions Framework FormExtensions Methods

The FormExtensions type exposes the following members.

Methods
Name | Description
RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file.
RestoreLocation(Form) | Restores the location of the specified windowsForm from the location information saved in the application configuration file.
RestoreLocation(Form, String) | Restores the location of the specified windowsForm from the location information saved in the application configuration file.
RestoreSize(Form) | Restores the size of the specified windowsForm from the size information saved in the application configuration file.
RestoreSize(Form, String) | Restores the size of the specified windowsForm from the size information saved in the application configuration file.
SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file.
SaveLocation(Form) | Saves the location information of the specified windowsForm to the application configuration file.
SaveLocation(Form, String) | Saves the location information of the specified windowsForm to the application configuration file.
SaveSize(Form) | Saves the size information of the specified windowsForm to the application configuration file.
SaveSize(Form, String) | Saves the size information of the specified windowsForm to the application configuration file.
Top
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.RestoreLayout Method

Grid Solutions Framework FormExtensionsRestoreLayout Method
Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void RestoreLayout(
    this Form windowsForm
)
<ExtensionAttribute>
Public Shared Sub RestoreLayout (
    windowsForm As Form
)
static member RestoreLayout :
        windowsForm : Form -> unit

GSF.Windows.Forms.FormExtensions.RestoreLayout = function(windowsForm);
public:
[ExtensionAttribute]
static void RestoreLayout(
    Form^ windowsForm
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose size and location is to be restored.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function simply calls the RestoreWindowSize and RestoreWindowLocation functions using the default settings categories
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.RestoreLocation Method

Grid Solutions Framework FormExtensionsRestoreLocation Method
Overload List
Name | Description
RestoreLocation(Form) | Restores the location of the specified windowsForm from the location information saved in the application configuration file.
RestoreLocation(Form, String) | Restores the location of the specified windowsForm from the location information saved in the application configuration file.
Top
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.RestoreLocation Method (Form)

Grid Solutions Framework FormExtensionsRestoreLocation Method (Form)
Restores the location of the specified windowsForm from the location information saved in the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void RestoreLocation(
    this Form windowsForm
)
<ExtensionAttribute>
Public Shared Sub RestoreLocation (
    windowsForm As Form
)
static member RestoreLocation :
        windowsForm : Form -> unit

GSF.Windows.Forms.FormExtensions.RestoreLocation = function(windowsForm);
public:
[ExtensionAttribute]
static void RestoreLocation(
    Form^ windowsForm
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose location is to be restored.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function uses the default settings category "LastWindowLocation"
See Also

Reference

FormExtensions Class
RestoreLocation Overload
GSF.Windows.Forms Namespace


FormExtensions.RestoreLocation Method (Form, String)

Grid Solutions Framework FormExtensionsRestoreLocation Method (Form, String)
Restores the location of the specified windowsForm from the location information saved in the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void RestoreLocation(
    this Form windowsForm,
    string settingsCategory
)
<ExtensionAttribute>
Public Shared Sub RestoreLocation (
    windowsForm As Form,
    settingsCategory As String
)
static member RestoreLocation :
        windowsForm : Form *
        settingsCategory : string -> unit

GSF.Windows.Forms.FormExtensions.RestoreLocation = function(windowsForm, settingsCategory);
public:
[ExtensionAttribute]
static void RestoreLocation(
    Form^ windowsForm,
    String^ settingsCategory
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose location is to be restored.
settingsCategory
Type: SystemString
Settings category used to persist form location information

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

FormExtensions Class
RestoreLocation Overload
GSF.Windows.Forms Namespace


FormExtensions.RestoreSize Method

Grid Solutions Framework FormExtensionsRestoreSize Method
Overload List
Name | Description
RestoreSize(Form) | Restores the size of the specified windowsForm from the size information saved in the application configuration file.
RestoreSize(Form, String) | Restores the size of the specified windowsForm from the size information saved in the application configuration file.
Top
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.RestoreSize Method (Form)

Grid Solutions Framework FormExtensionsRestoreSize Method (Form)
Restores the size of the specified windowsForm from the size information saved in the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void RestoreSize(
    this Form windowsForm
)
<ExtensionAttribute>
Public Shared Sub RestoreSize (
    windowsForm As Form
)
static member RestoreSize :
        windowsForm : Form -> unit

GSF.Windows.Forms.FormExtensions.RestoreSize = function(windowsForm);
public:
[ExtensionAttribute]
static void RestoreSize(
    Form^ windowsForm
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose size is to be restored.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function uses the default settings category "LastWindowSize"
See Also

Reference

FormExtensions Class
RestoreSize Overload
GSF.Windows.Forms Namespace


FormExtensions.RestoreSize Method (Form, String)

Grid Solutions Framework FormExtensionsRestoreSize Method (Form, String)
Restores the size of the specified windowsForm from the size information saved in the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void RestoreSize(
    this Form windowsForm,
    string settingsCategory
)
<ExtensionAttribute>
Public Shared Sub RestoreSize (
    windowsForm As Form,
    settingsCategory As String
)
static member RestoreSize :
        windowsForm : Form *
        settingsCategory : string -> unit

GSF.Windows.Forms.FormExtensions.RestoreSize = function(windowsForm, settingsCategory);
public:
[ExtensionAttribute]
static void RestoreSize(
    Form^ windowsForm,
    String^ settingsCategory
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose size is to be restored.
settingsCategory
Type: SystemString
Settings category used to persist form size information

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

FormExtensions Class
RestoreSize Overload
GSF.Windows.Forms Namespace


FormExtensions.SaveLayout Method

Grid Solutions Framework FormExtensionsSaveLayout Method
Saves the size and location information of the specified windowsForm to the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SaveLayout(
    this Form windowsForm
)
<ExtensionAttribute>
Public Shared Sub SaveLayout (
    windowsForm As Form
)
static member SaveLayout :
        windowsForm : Form -> unit

GSF.Windows.Forms.FormExtensions.SaveLayout = function(windowsForm);
public:
[ExtensionAttribute]
static void SaveLayout(
    Form^ windowsForm
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose size and location information is to be saved.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function simply calls the SaveWindowSize and SaveWindowLocation functions using the default settings categories
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.SaveLocation Method

Grid Solutions Framework FormExtensionsSaveLocation Method
Overload List
Name | Description
SaveLocation(Form) | Saves the location information of the specified windowsForm to the application configuration file.
SaveLocation(Form, String) | Saves the location information of the specified windowsForm to the application configuration file.
Top
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.SaveLocation Method (Form)

Grid Solutions Framework FormExtensionsSaveLocation Method (Form)
Saves the location information of the specified windowsForm to the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SaveLocation(
    this Form windowsForm
)
<ExtensionAttribute>
Public Shared Sub SaveLocation (
    windowsForm As Form
)
static member SaveLocation :
        windowsForm : Form -> unit

GSF.Windows.Forms.FormExtensions.SaveLocation = function(windowsForm);
public:
[ExtensionAttribute]
static void SaveLocation(
    Form^ windowsForm
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose location information is to be saved.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function uses the default settings category "LastWindowLocation"
See Also

Reference

FormExtensions Class
SaveLocation Overload
GSF.Windows.Forms Namespace


FormExtensions.SaveLocation Method (Form, String)

Grid Solutions Framework FormExtensionsSaveLocation Method (Form, String)
Saves the location information of the specified windowsForm to the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SaveLocation(
    this Form windowsForm,
    string settingsCategory
)
<ExtensionAttribute>
Public Shared Sub SaveLocation (
    windowsForm As Form,
    settingsCategory As String
)
static member SaveLocation :
        windowsForm : Form *
        settingsCategory : string -> unit

GSF.Windows.Forms.FormExtensions.SaveLocation = function(windowsForm, settingsCategory);
public:
[ExtensionAttribute]
static void SaveLocation(
    Form^ windowsForm,
    String^ settingsCategory
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose location information is to be saved.
settingsCategory
Type: SystemString
Settings category used to persist form location information

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

FormExtensions Class
SaveLocation Overload
GSF.Windows.Forms Namespace


FormExtensions.SaveSize Method

Grid Solutions Framework FormExtensionsSaveSize Method
Overload List
Name | Description
SaveSize(Form) | Saves the size information of the specified windowsForm to the application configuration file.
SaveSize(Form, String) | Saves the size information of the specified windowsForm to the application configuration file.
Top
See Also

Reference

FormExtensions Class
GSF.Windows.Forms Namespace


FormExtensions.SaveSize Method (Form)

Grid Solutions Framework FormExtensionsSaveSize Method (Form)
Saves the size information of the specified windowsForm to the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SaveSize(
    this Form windowsForm
)
<ExtensionAttribute>
Public Shared Sub SaveSize (
    windowsForm As Form
)
static member SaveSize :
        windowsForm : Form -> unit

GSF.Windows.Forms.FormExtensions.SaveSize = function(windowsForm);
public:
[ExtensionAttribute]
static void SaveSize(
    Form^ windowsForm
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose size information is to be saved.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This function uses the default settings category "LastWindowSize"
See Also

Reference

FormExtensions Class
SaveSize Overload
GSF.Windows.Forms Namespace


FormExtensions.SaveSize Method (Form, String)

Grid Solutions Framework FormExtensionsSaveSize Method (Form, String)
Saves the size information of the specified windowsForm to the application configuration file.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SaveSize(
    this Form windowsForm,
    string settingsCategory
)
<ExtensionAttribute>
Public Shared Sub SaveSize (
    windowsForm As Form,
    settingsCategory As String
)
static member SaveSize :
        windowsForm : Form *
        settingsCategory : string -> unit

GSF.Windows.Forms.FormExtensions.SaveSize = function(windowsForm, settingsCategory);
public:
[ExtensionAttribute]
static void SaveSize(
    Form^ windowsForm,
    String^ settingsCategory
)

Parameters

windowsForm
Type: System.Windows.FormsForm
The Form whose size information is to be saved.
settingsCategory
Type: SystemString
Settings category used to persist form size information

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type Form. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

FormExtensions Class
SaveSize Overload
GSF.Windows.Forms Namespace


PropertyGridExtensions Class

Grid Solutions Framework PropertyGridExtensions Class
Defines extension functions for the PropertyGrid control.
Inheritance Hierarchy
SystemObject
GSF.Windows.FormsPropertyGridExtensions

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class PropertyGridExtensions
<ExtensionAttribute>
Public NotInheritable Class PropertyGridExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type PropertyGridExtensions =  class end
GSF.Windows.Forms.PropertyGridExtensions = function();

Type.createClass(
    'GSF.Windows.Forms.PropertyGridExtensions');
[ExtensionAttribute]
public ref class PropertyGridExtensions abstract sealed

The PropertyGridExtensions type exposes the following members.

Methods
Name | Description
AdjustCommentAreaHeight | Adjusts a property grid's comment area height
AdjustLabelRatio | Adjusts a property grid's label ratio
Top
See Also

Reference

GSF.Windows.Forms Namespace


PropertyGridExtensions Methods

Grid Solutions Framework PropertyGridExtensions Methods

The PropertyGridExtensions type exposes the following members.

Methods
Name | Description
AdjustCommentAreaHeight | Adjusts a property grid's comment area height
AdjustLabelRatio | Adjusts a property grid's label ratio
Top
See Also

Reference

PropertyGridExtensions Class
GSF.Windows.Forms Namespace


PropertyGridExtensions.AdjustCommentAreaHeight Method

Grid Solutions Framework PropertyGridExtensionsAdjustCommentAreaHeight Method
Adjusts a property grid's comment area height

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void AdjustCommentAreaHeight(
    this PropertyGrid grid,
    int lines
)
<ExtensionAttribute>
Public Shared Sub AdjustCommentAreaHeight (
    grid As PropertyGrid,
    lines As Integer
)
static member AdjustCommentAreaHeight :
        grid : PropertyGrid *
        lines : int -> unit

GSF.Windows.Forms.PropertyGridExtensions.AdjustCommentAreaHeight = function(grid, lines);
public:
[ExtensionAttribute]
static void AdjustCommentAreaHeight(
    PropertyGrid^ grid,
    int lines
)

Parameters

grid
Type: System.Windows.FormsPropertyGrid
Property grid to adjust
lines
Type: SystemInt32
Number of lines to display in comment area

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PropertyGrid. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

This function only has an effect on property grids when their Visible property is set to True. To use this on an initially hidden property grid - set the property grid's Visible property to True at design time, call this function during form load, then set the Visible property to False.

This function was written to work with the .NET 2.0 PropertyGrid control. Note that reflection is used to set private properties of the property grid and as a result this function may not work with future versions of the .NET property grid.

See Also

Reference

PropertyGridExtensions Class
GSF.Windows.Forms Namespace


PropertyGridExtensions.AdjustLabelRatio Method

Grid Solutions Framework PropertyGridExtensionsAdjustLabelRatio Method
Adjusts a property grid's label ratio

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void AdjustLabelRatio(
    this PropertyGrid grid,
    double ratio
)
<ExtensionAttribute>
Public Shared Sub AdjustLabelRatio (
    grid As PropertyGrid,
    ratio As Double
)
static member AdjustLabelRatio :
        grid : PropertyGrid *
        ratio : float -> unit

GSF.Windows.Forms.PropertyGridExtensions.AdjustLabelRatio = function(grid, ratio);
public:
[ExtensionAttribute]
static void AdjustLabelRatio(
    PropertyGrid^ grid,
    double ratio
)

Parameters

grid
Type: System.Windows.FormsPropertyGrid
Property grid to adjust
ratio
Type: SystemDouble
Ratio to use use for label column

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type PropertyGrid. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

Smaller ratios (e.g., 1.75) produce a wider label column.

This function only has an effect on property grids when their Visible property is set to True. To use this on an initially hidden property grid - set the property grid's Visible property to True at design time, call this function during form load, then set the Visible property to False.

This function was written to work with the .NET 2.0 PropertyGrid control. Note that reflection is used to set private properties of the property grid and as a result this function may not work with future versions of the .NET property grid.

See Also

Reference

PropertyGridExtensions Class
GSF.Windows.Forms Namespace


ScreenArea Class

Grid Solutions Framework ScreenArea Class
Returns screen area statistics and capture functionality for all connected screens.
Inheritance Hierarchy
SystemObject
GSF.Windows.FormsScreenArea

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class ScreenArea
Public NotInheritable Class ScreenArea
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ScreenArea =  class end
GSF.Windows.Forms.ScreenArea = function();

Type.createClass(
    'GSF.Windows.Forms.ScreenArea');
public ref class ScreenArea abstract sealed

The ScreenArea type exposes the following members.

Methods
Name | Description
Capture | Performs screen capture over all monitors.
Capture(ImageFormat) | Performs screen capture over all monitors.
Capture(Rectangle) | Performs a screen capture the given Rectangle.
Capture(Screen) | Performs screen capture for given Screen.
Capture(Rectangle, ImageFormat) | Performs a screen capture the given Rectangle and ImageFormat.
Capture(Screen, ImageFormat) | Performs screen capture for given Screen and ImageFormat.
Top
Properties
Name | Description
BottomMostBound | Gets the greatest "y" coordinate of all screens on the system
LeftMostBound | Gets the least "x" coordinate of all screens on the system
MaximumHeight | Gets the height of the screen with the highest resolution.
MaximumWidth | Gets the width of the screen with the highest resolution.
MinimumHeight | Gets the height of the screen with the lowest resolution.
MinimumWidth | Gets the width of the screen with the lowest resolution.
RightMostBound | Gets the greatest "x" coordinate of all screens on the system
TopMostBound | Gets the least "y" coordinate of all screens on the system
TotalHeight | Gets the total height of all the screens relative to their arrangement.
TotalWidth | Gets the total width of all the screens relative to their arrangement.
Top
See Also

Reference

GSF.Windows.Forms Namespace


ScreenArea Methods

Grid Solutions Framework ScreenArea Methods
Methods
Name | Description
Capture | Performs screen capture over all monitors.
Capture(ImageFormat) | Performs screen capture over all monitors.
Capture(Rectangle) | Performs a screen capture the given Rectangle.
Capture(Screen) | Performs screen capture for given Screen.
Capture(Rectangle, ImageFormat) | Performs a screen capture the given Rectangle and ImageFormat.
Capture(Screen, ImageFormat) | Performs screen capture for given Screen and ImageFormat.
Top
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.Capture Method

Grid Solutions Framework ScreenAreaCapture Method
Overload List
Name | Description
Capture | Performs screen capture over all monitors.
Capture(ImageFormat) | Performs screen capture over all monitors.
Capture(Rectangle) | Performs a screen capture the given Rectangle.
Capture(Screen) | Performs screen capture for given Screen.
Capture(Rectangle, ImageFormat) | Performs a screen capture the given Rectangle and ImageFormat.
Capture(Screen, ImageFormat) | Performs screen capture for given Screen and ImageFormat.
Top
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.Capture Method

Grid Solutions Framework ScreenAreaCapture Method
Performs screen capture over all monitors.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Capture()
Public Shared Function Capture As Bitmap
static member Capture : unit -> Bitmap

GSF.Windows.Forms.ScreenArea.Capture = function();
public:
static Bitmap^ Capture()

Return Value

Type: Bitmap
Captured screen image over all monitors.
Remarks
Size captured will be for total width and height of all screens relative to their arrangement. An image square will be created large enough to cover all screens for the capture.
See Also

Reference

ScreenArea Class
Capture Overload
GSF.Windows.Forms Namespace


ScreenArea.Capture Method (ImageFormat)

Grid Solutions Framework ScreenAreaCapture Method (ImageFormat)
Performs screen capture over all monitors.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Capture(
    ImageFormat imageFormat
)
Public Shared Function Capture (
    imageFormat As ImageFormat
) As Bitmap
static member Capture :
        imageFormat : ImageFormat -> Bitmap

GSF.Windows.Forms.ScreenArea.Capture = function(imageFormat);
public:
static Bitmap^ Capture(
    ImageFormat^ imageFormat
)

Parameters

imageFormat
Type: System.Drawing.ImagingImageFormat
Desired ImageFormat for captured Bitmap.

Return Value

Type: Bitmap
Captured screen image over all monitors.
Remarks
Size captured will be for total width and height of all screens relative to their arrangement. An image square will be created large enough to cover all screens for the capture.
See Also

Reference

ScreenArea Class
Capture Overload
GSF.Windows.Forms Namespace


ScreenArea.Capture Method (Rectangle)

Grid Solutions Framework ScreenAreaCapture Method (Rectangle)
Performs a screen capture the given Rectangle.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Capture(
    Rectangle captureArea
)
Public Shared Function Capture (
    captureArea As Rectangle
) As Bitmap
static member Capture :
        captureArea : Rectangle -> Bitmap

GSF.Windows.Forms.ScreenArea.Capture = function(captureArea);
public:
static Bitmap^ Capture(
    Rectangle captureArea
)

Parameters

captureArea
Type: System.DrawingRectangle
Screen area Rectangle to capture.

Return Value

Type: Bitmap
Captured screen image for given area.
See Also

Reference

ScreenArea Class
Capture Overload
GSF.Windows.Forms Namespace


ScreenArea.Capture Method (Screen)

Grid Solutions Framework ScreenAreaCapture Method (Screen)
Performs screen capture for given Screen.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Capture(
    Screen captureScreen
)
Public Shared Function Capture (
    captureScreen As Screen
) As Bitmap
static member Capture :
        captureScreen : Screen -> Bitmap

GSF.Windows.Forms.ScreenArea.Capture = function(captureScreen);
public:
static Bitmap^ Capture(
    Screen^ captureScreen
)

Parameters

captureScreen
Type: System.Windows.FormsScreen
A Screen object to capture.

Return Value

Type: Bitmap
Captured screen image for given Screen.
See Also

Reference

ScreenArea Class
Capture Overload
GSF.Windows.Forms Namespace


ScreenArea.Capture Method (Rectangle, ImageFormat)

Grid Solutions Framework ScreenAreaCapture Method (Rectangle, ImageFormat)
Performs a screen capture the given Rectangle and ImageFormat.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Capture(
    Rectangle captureArea,
    ImageFormat imageFormat
)
Public Shared Function Capture (
    captureArea As Rectangle,
    imageFormat As ImageFormat
) As Bitmap
static member Capture :
        captureArea : Rectangle *
        imageFormat : ImageFormat -> Bitmap

GSF.Windows.Forms.ScreenArea.Capture = function(captureArea, imageFormat);
public:
static Bitmap^ Capture(
    Rectangle captureArea,
    ImageFormat^ imageFormat
)

Parameters

captureArea
Type: System.DrawingRectangle
Screen area Rectangle to capture.
imageFormat
Type: System.Drawing.ImagingImageFormat
Desired ImageFormat for captured Bitmap.

Return Value

Type: Bitmap
Captured screen image for given area.
See Also

Reference

ScreenArea Class
Capture Overload
GSF.Windows.Forms Namespace


ScreenArea.Capture Method (Screen, ImageFormat)

Grid Solutions Framework ScreenAreaCapture Method (Screen, ImageFormat)
Performs screen capture for given Screen and ImageFormat.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static Bitmap Capture(
    Screen captureScreen,
    ImageFormat imageFormat
)
Public Shared Function Capture (
    captureScreen As Screen,
    imageFormat As ImageFormat
) As Bitmap
static member Capture :
        captureScreen : Screen *
        imageFormat : ImageFormat -> Bitmap

GSF.Windows.Forms.ScreenArea.Capture = function(captureScreen, imageFormat);
public:
static Bitmap^ Capture(
    Screen^ captureScreen,
    ImageFormat^ imageFormat
)

Parameters

captureScreen
Type: System.Windows.FormsScreen
Desired Screen to capture
imageFormat
Type: System.Drawing.ImagingImageFormat
Desired ImageFormat for captured Bitmap.

Return Value

Type: Bitmap
Captured screen image for given Screen.
See Also

Reference

ScreenArea Class
Capture Overload
GSF.Windows.Forms Namespace


ScreenArea Properties

Grid Solutions Framework ScreenArea Properties

The ScreenArea type exposes the following members.

Properties
Name | Description
BottomMostBound | Gets the greatest "y" coordinate of all screens on the system
LeftMostBound | Gets the least "x" coordinate of all screens on the system
MaximumHeight | Gets the height of the screen with the highest resolution.
MaximumWidth | Gets the width of the screen with the highest resolution.
MinimumHeight | Gets the height of the screen with the lowest resolution.
MinimumWidth | Gets the width of the screen with the lowest resolution.
RightMostBound | Gets the greatest "x" coordinate of all screens on the system
TopMostBound | Gets the least "y" coordinate of all screens on the system
TotalHeight | Gets the total height of all the screens relative to their arrangement.
TotalWidth | Gets the total width of all the screens relative to their arrangement.
Top
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.BottomMostBound Property

Grid Solutions Framework ScreenAreaBottomMostBound Property
Gets the greatest "y" coordinate of all screens on the system

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int BottomMostBound { get; }
Public Shared ReadOnly Property BottomMostBound As Integer
    Get
static member BottomMostBound : int with get

GSF.Windows.Forms.ScreenArea.get_BottomMostBound = function();

public:
static property int BottomMostBound {
    int get ();
}

Return Value

Type: Int32
The largest visible "y" screen coordinate
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.LeftMostBound Property

Grid Solutions Framework ScreenAreaLeftMostBound Property
Gets the least "x" coordinate of all screens on the system

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int LeftMostBound { get; }
Public Shared ReadOnly Property LeftMostBound As Integer
    Get
static member LeftMostBound : int with get

GSF.Windows.Forms.ScreenArea.get_LeftMostBound = function();

public:
static property int LeftMostBound {
    int get ();
}

Return Value

Type: Int32
The smallest visible "x" screen coordinate
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.MaximumHeight Property

Grid Solutions Framework ScreenAreaMaximumHeight Property
Gets the height of the screen with the highest resolution.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int MaximumHeight { get; }
Public Shared ReadOnly Property MaximumHeight As Integer
    Get
static member MaximumHeight : int with get

GSF.Windows.Forms.ScreenArea.get_MaximumHeight = function();

public:
static property int MaximumHeight {
    int get ();
}

Return Value

Type: Int32
The height of the screen with the highest resolution.
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.MaximumWidth Property

Grid Solutions Framework ScreenAreaMaximumWidth Property
Gets the width of the screen with the highest resolution.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int MaximumWidth { get; }
Public Shared ReadOnly Property MaximumWidth As Integer
    Get
static member MaximumWidth : int with get

GSF.Windows.Forms.ScreenArea.get_MaximumWidth = function();

public:
static property int MaximumWidth {
    int get ();
}

Return Value

Type: Int32
The width of the screen with the highest resolution.
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.MinimumHeight Property

Grid Solutions Framework ScreenAreaMinimumHeight Property
Gets the height of the screen with the lowest resolution.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int MinimumHeight { get; }
Public Shared ReadOnly Property MinimumHeight As Integer
    Get
static member MinimumHeight : int with get

GSF.Windows.Forms.ScreenArea.get_MinimumHeight = function();

public:
static property int MinimumHeight {
    int get ();
}

Return Value

Type: Int32
The height of the screen with the lowest resolution.
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.MinimumWidth Property

Grid Solutions Framework ScreenAreaMinimumWidth Property
Gets the width of the screen with the lowest resolution.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int MinimumWidth { get; }
Public Shared ReadOnly Property MinimumWidth As Integer
    Get
static member MinimumWidth : int with get

GSF.Windows.Forms.ScreenArea.get_MinimumWidth = function();

public:
static property int MinimumWidth {
    int get ();
}

Return Value

Type: Int32
The width of the screen with the lowest resolution.
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.RightMostBound Property

Grid Solutions Framework ScreenAreaRightMostBound Property
Gets the greatest "x" coordinate of all screens on the system

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int RightMostBound { get; }
Public Shared ReadOnly Property RightMostBound As Integer
    Get
static member RightMostBound : int with get

GSF.Windows.Forms.ScreenArea.get_RightMostBound = function();

public:
static property int RightMostBound {
    int get ();
}

Return Value

Type: Int32
The largest visible "x" screen coordinate
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.TopMostBound Property

Grid Solutions Framework ScreenAreaTopMostBound Property
Gets the least "y" coordinate of all screens on the system

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int TopMostBound { get; }
Public Shared ReadOnly Property TopMostBound As Integer
    Get
static member TopMostBound : int with get

GSF.Windows.Forms.ScreenArea.get_TopMostBound = function();

public:
static property int TopMostBound {
    int get ();
}

Return Value

Type: Int32
The smallest visible "y" screen coordinate
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.TotalHeight Property

Grid Solutions Framework ScreenAreaTotalHeight Property
Gets the total height of all the screens relative to their arrangement.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int TotalHeight { get; }
Public Shared ReadOnly Property TotalHeight As Integer
    Get
static member TotalHeight : int with get

GSF.Windows.Forms.ScreenArea.get_TotalHeight = function();

public:
static property int TotalHeight {
    int get ();
}

Return Value

Type: Int32
The total height of all the screens relative to their arrangement.
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


ScreenArea.TotalWidth Property

Grid Solutions Framework ScreenAreaTotalWidth Property
Gets the total width of all the screens relative to their arrangement.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static int TotalWidth { get; }
Public Shared ReadOnly Property TotalWidth As Integer
    Get
static member TotalWidth : int with get

GSF.Windows.Forms.ScreenArea.get_TotalWidth = function();

public:
static property int TotalWidth {
    int get ();
}

Return Value

Type: Int32
The total width of all the screens relative to their arrangement.
See Also

Reference

ScreenArea Class
GSF.Windows.Forms Namespace


SecureForm Class

Grid Solutions Framework SecureForm Class
Represents a windows form secured using role-based security.
Inheritance Hierarchy
SystemObject
SystemMarshalByRefObject
System.ComponentModelComponent
System.Windows.FormsControl
System.Windows.FormsScrollableControl
System.Windows.FormsContainerControl
System.Windows.FormsForm
GSF.Windows.FormsSecureForm

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public class SecureForm : Form
Public Class SecureForm
    Inherits Form
type SecureForm =
    class
        inherit Form
    end
GSF.Windows.Forms.SecureForm = function();

Type.createClass(
    'GSF.Windows.Forms.SecureForm',
    Form);
public ref class SecureForm : public Form

The SecureForm type exposes the following members.

Constructors
 | Name | Description
Public method | SecureForm | Initializes a new instance of the SecureForm class.
Top
Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
Examples
Required config file entries:
Copy
<?xml version="1.0"?>
<configuration>
  <configSections>
    <section name="categorizedSettings" type="GSF.Configuration.CategorizedSettingsSection, GSF.Core" />
  </configSections>
  <categorizedSettings>
    <securityProvider>
      <add name="ApplicationName" value="" description="Name of the application being secured as defined in the backend security datastore."
        encrypted="false" />
      <add name="ConnectionString" value="" description="Connection string to be used for connection to the backend security datastore."
        encrypted="false" />
      <add name="ProviderType" value="GSF.Security.LdapSecurityProvider, GSF.Security"
        description="The type to be used for enforcing security." encrypted="false" />
      <add name="IncludedResources" value="*Form*=*" description="Semicolon delimited list of resources to be secured along with role names."
        encrypted="false" />
      <add name="ExcludedResources" value="" description="Semicolon delimited list of resources to be excluded from being secured."
        encrypted="false" />
      <add name="NotificationSmtpServer" value="localhost" description="SMTP server to be used for sending out email notification messages."
        encrypted="false" />
      <add name="NotificationSenderEmail" value="sender@company.com" description="Email address of the sender of email notification messages."
        encrypted="false" />
    </securityProvider>
    <activeDirectory>
      <add name="PrivilegedDomain" value="" description="Domain of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedUserName" value="" description="Username of privileged domain user account."
        encrypted="false" />
      <add name="PrivilegedPassword" value="" description="Password of privileged domain user account."
        encrypted="true" />
    </activeDirectory>
  </categorizedSettings>
</configuration>
See Also

Reference

GSF.Windows.Forms Namespace
GSF.SecurityISecurityProvider


SecureForm Constructor

Grid Solutions Framework SecureForm Constructor
Initializes a new instance of the SecureForm class.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public SecureForm()
Public Sub New
new : unit -> SecureForm
GSF.Windows.Forms.SecureForm = function();
public:
SecureForm()
See Also

Reference

SecureForm Class
GSF.Windows.Forms Namespace


SecureForm Methods

Grid Solutions Framework SecureForm Methods

The SecureForm type exposes the following members.

Methods
 | Name | Description
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control. (Inherited from Control.)
Protected method | AccessibilityNotifyClients(AccessibleEvents, Int32, Int32) | Notifies the accessibility client applications of the specified AccessibleEvents for the specified child control . (Inherited from Control.)
Public method | Activate | Activates the form and gives it focus. (Inherited from Form.)
Protected method | ActivateMdiChild | Activates the MDI child of a form. (Inherited from Form.)
Public method | AddOwnedForm | Adds an owned form to this form. (Inherited from Form.)
Protected method | AdjustFormScrollbars | Adjusts the scroll bars on the container based on the current control positions and the control currently selected. (Inherited from Form.)
Protected method | ApplyAutoScaling | Obsolete. Resizes the form according to the current value of the AutoScaleBaseSize property and the size of the current font. (Inherited from Form.)
Public method | BeginInvoke(Delegate) | Executes the specified delegate asynchronously on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BeginInvoke(Delegate, Object) | Executes the specified delegate asynchronously with the specified arguments, on the thread that the control's underlying handle was created on. (Inherited from Control.)
Public method | BringToFront | Brings the control to the front of the z-order. (Inherited from Control.)
Protected method | CenterToParent | Centers the position of the form within the bounds of the parent form. (Inherited from Form.)
Protected method | CenterToScreen | Centers the form on the current screen. (Inherited from Form.)
Public method | Close | Closes the form. (Inherited from Form.)
Public method | Contains | Retrieves a value indicating whether the specified control is a child of the control. (Inherited from Control.)
Protected method | CreateAccessibilityInstance | Creates a new accessibility object for the control. (Inherited from Control.)
Public method | CreateControl | Forces the creation of the visible control, including the creation of the handle and any visible child controls. (Inherited from Control.)
Protected method | CreateControlsInstance | (Inherited from Form.)
Public method | CreateGraphics | Creates the Graphics for the control. (Inherited from Control.)
Protected method | CreateHandle | Creates the handle for the form. If a derived class overrides this function, it must call the base implementation. (Inherited from Form.)
Public method | CreateObjRef | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
Protected method | DefWndProc | (Inherited from Form.)
Protected method | DestroyHandle | Destroys the handle associated with the control. (Inherited from Control.)
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Public method | DoDragDrop | Begins a drag-and-drop operation. (Inherited from Control.)
Public method | DrawToBitmap | Supports rendering to the specified bitmap. (Inherited from Control.)
Public method | EndInvoke | Retrieves the return value of the asynchronous operation represented by the IAsyncResult passed. (Inherited from Control.)
Public method | Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Protected method | Finalize | Releases unmanaged resources and performs other cleanup operations before the Component is reclaimed by garbage collection. (Inherited from Component.)
Public method | FindForm | Retrieves the form that the control is on. (Inherited from Control.)
Public method | Focus | Sets input focus to the control. (Inherited from Control.)
Protected method | GetAccessibilityObjectById | Retrieves the specified AccessibleObject. (Inherited from Control.)
Protected method | GetAutoSizeMode | Retrieves a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | GetChildAtPoint(Point) | Retrieves the child control that is located at the specified coordinates. (Inherited from Control.)
Public method | GetChildAtPoint(Point, GetChildAtPointSkip) | Retrieves the child control that is located at the specified coordinates, specifying whether to ignore child controls of a certain type. (Inherited from Control.)
Public method | GetContainerControl | Returns the next ContainerControl up the control's chain of parent controls. (Inherited from Control.)
Public method | GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
Public method | GetLifetimeService | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Public method | GetNextControl | Retrieves the next control forward or back in the tab order of child controls. (Inherited from Control.)
Public method | GetPreferredSize | Retrieves the size of a rectangular area into which a control can be fitted. (Inherited from Control.)
Protected method | GetResourceName | Gets the name of resource being accessed.
Protected method | GetScaledBounds | (Inherited from Form.)
Protected method | GetScrollState | Determines whether the specified flag has been set. (Inherited from ScrollableControl.)
Protected method | GetService | Returns an object that represents a service provided by the Component or by its Container. (Inherited from Component.)
Protected method | GetStyle | Retrieves the value of the specified control style bit for the control. (Inherited from Control.)
Protected method | GetTopLevel | Determines if the control is a top-level control. (Inherited from Control.)
Public method | GetType | Gets the Type of the current instance. (Inherited from Object.)
Public method | Hide | Conceals the control from the user. (Inherited from Control.)
Public method | InitializeLifetimeService | Obtains a lifetime service object to control the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
Protected method | InitLayout | Called after the control has been added to another container. (Inherited from Control.)
Public method | Invalidate | Invalidates the entire surface of the control and causes the control to be redrawn. (Inherited from Control.)
Public method | Invalidate(Region) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Boolean) | Invalidates a specific region of the control and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. (Inherited from Control.)
Public method | Invalidate(Region, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invalidate(Rectangle, Boolean) | Invalidates the specified region of the control (adds it to the control's update region, which is the area that will be repainted at the next paint operation), and causes a paint message to be sent to the control. Optionally, invalidates the child controls assigned to the control. (Inherited from Control.)
Public method | Invoke(Delegate) | Executes the specified delegate on the thread that owns the control's underlying window handle. (Inherited from Control.)
Public method | Invoke(Delegate, Object) | Executes the specified delegate, on the thread that owns the control's underlying window handle, with the specified list of arguments. (Inherited from Control.)
Protected method | InvokeGotFocus | Raises the GotFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeLostFocus | Raises the LostFocus event for the specified control. (Inherited from Control.)
Protected method | InvokeOnClick | Raises the Click event for the specified control. (Inherited from Control.)
Protected method | InvokePaint | Raises the Paint event for the specified control. (Inherited from Control.)
Protected method | InvokePaintBackground | Raises the PaintBackground event for the specified control. (Inherited from Control.)
Protected method | IsInputChar | Determines if a character is an input character that the control recognizes. (Inherited from Control.)
Protected method | IsInputKey | Determines whether the specified key is a regular input key or a special key that requires preprocessing. (Inherited from Control.)
Public method | LayoutMdi | Arranges the multiple-document interface (MDI) child forms within the MDI parent form. (Inherited from Form.)
Protected method | MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Protected method | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
Protected method | NotifyInvalidate | Raises the Invalidated event with a specified region of the control to invalidate. (Inherited from Control.)
Protected method | OnActivated | Raises the Activated event. (Inherited from Form.)
Protected method | OnAutoSizeChanged | Raises the AutoSizeChanged event. (Inherited from Control.)
Protected method | OnAutoValidateChanged | Raises the AutoValidateChanged event. (Inherited from ContainerControl.)
Protected method | OnBackColorChanged | Raises the BackColorChanged event. (Inherited from Control.)
Protected method | OnBackgroundImageChanged | Raises the BackgroundImageChanged event. (Inherited from Form.)
Protected method | OnBackgroundImageLayoutChanged | Raises the BackgroundImageLayoutChanged event. (Inherited from Form.)
Protected method | OnBindingContextChanged | Raises the BindingContextChanged event. (Inherited from Control.)
Protected method | OnCausesValidationChanged | Raises the CausesValidationChanged event. (Inherited from Control.)
Protected method | OnChangeUICues | Raises the ChangeUICues event. (Inherited from Control.)
Protected method | OnClick | Raises the Click event. (Inherited from Control.)
Protected method | OnClientSizeChanged | Raises the ClientSizeChanged event. (Inherited from Control.)
Protected method | OnClosed | Raises the Closed event. (Inherited from Form.)
Protected method | OnClosing | Raises the Closing event. (Inherited from Form.)
Protected method | OnContextMenuChanged | Raises the ContextMenuChanged event. (Inherited from Control.)
Protected method | OnContextMenuStripChanged | Raises the ContextMenuStripChanged event. (Inherited from Control.)
Protected method | OnControlAdded | Raises the ControlAdded event. (Inherited from Control.)
Protected method | OnControlRemoved | Raises the ControlRemoved event. (Inherited from Control.)
Protected method | OnCreateControl | Raises the CreateControl event. (Inherited from Form.)
Protected method | OnCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnDeactivate | Raises the Deactivate event. (Inherited from Form.)
Protected method | OnDockChanged | Raises the DockChanged event. (Inherited from Control.)
Protected method | OnDoubleClick | Raises the DoubleClick event. (Inherited from Control.)
Protected method | OnDragDrop | Raises the DragDrop event. (Inherited from Control.)
Protected method | OnDragEnter | Raises the DragEnter event. (Inherited from Control.)
Protected method | OnDragLeave | Raises the DragLeave event. (Inherited from Control.)
Protected method | OnDragOver | Raises the DragOver event. (Inherited from Control.)
Protected method | OnEnabledChanged | (Inherited from Form.)
Protected method | OnEnter | Raises the Enter event. (Inherited from Form.)
Protected method | OnFontChanged | (Inherited from Form.)
Protected method | OnForeColorChanged | Raises the ForeColorChanged event. (Inherited from Control.)
Protected method | OnFormClosed | Raises the FormClosed event. (Inherited from Form.)
Protected method | OnFormClosing | Raises the FormClosing event. (Inherited from Form.)
Protected method | OnGiveFeedback | Raises the GiveFeedback event. (Inherited from Control.)
Protected method | OnGotFocus | Raises the GotFocus event. (Inherited from Control.)
Protected method | OnHandleCreated | (Inherited from Form.)
Protected method | OnHandleDestroyed | (Inherited from Form.)
Protected method | OnHelpButtonClicked | Raises the HelpButtonClicked event. (Inherited from Form.)
Protected method | OnHelpRequested | Raises the HelpRequested event. (Inherited from Control.)
Protected method | OnImeModeChanged | Raises the ImeModeChanged event. (Inherited from Control.)
Protected method | OnInputLanguageChanged | Raises the InputLanguageChanged event. (Inherited from Form.)
Protected method | OnInputLanguageChanging | Raises the InputLanguageChanging event. (Inherited from Form.)
Protected method | OnInvalidated | Raises the Invalidated event. (Inherited from Control.)
Protected method | OnKeyDown | Raises the KeyDown event. (Inherited from Control.)
Protected method | OnKeyPress | Raises the KeyPress event. (Inherited from Control.)
Protected method | OnKeyUp | Raises the KeyUp event. (Inherited from Control.)
Protected method | OnLayout | Raises the Layout event. (Inherited from Form.)
Protected method | OnLeave | Raises the Leave event. (Inherited from Control.)
Protected method | OnLoad | Raises the Load event. (Inherited from Form.)
Protected method | OnLocationChanged | Raises the LocationChanged event. (Inherited from Control.)
Protected method | OnLostFocus | Raises the LostFocus event. (Inherited from Control.)
Protected method | OnMarginChanged | Raises the MarginChanged event. (Inherited from Control.)
Protected method | OnMaximizedBoundsChanged | Raises the MaximizedBoundsChanged event. (Inherited from Form.)
Protected method | OnMaximumSizeChanged | Raises the MaximumSizeChanged event. (Inherited from Form.)
Protected method | OnMdiChildActivate | Raises the MdiChildActivate event. (Inherited from Form.)
Protected method | OnMenuComplete | Raises the MenuComplete event. (Inherited from Form.)
Protected method | OnMenuStart | Raises the MenuStart event. (Inherited from Form.)
Protected method | OnMinimumSizeChanged | Raises the MinimumSizeChanged event. (Inherited from Form.)
Protected method | OnMouseCaptureChanged | Raises the MouseCaptureChanged event. (Inherited from Control.)
Protected method | OnMouseClick | Raises the MouseClick event. (Inherited from Control.)
Protected method | OnMouseDoubleClick | Raises the MouseDoubleClick event. (Inherited from Control.)
Protected method | OnMouseDown | Raises the MouseDown event. (Inherited from Control.)
Protected method | OnMouseEnter | Raises the MouseEnter event. (Inherited from Control.)
Protected method | OnMouseHover | Raises the MouseHover event. (Inherited from Control.)
Protected method | OnMouseLeave | Raises the MouseLeave event. (Inherited from Control.)
Protected method | OnMouseMove | Raises the MouseMove event. (Inherited from Control.)
Protected method | OnMouseUp | Raises the MouseUp event. (Inherited from Control.)
Protected method | OnMouseWheel | Raises the MouseWheel event. (Inherited from ScrollableControl.)
Protected method | OnMove | Raises the Move event. (Inherited from Control.)
Protected method | OnNotifyMessage | Notifies the control of Windows messages. (Inherited from Control.)
Protected method | OnPaddingChanged | Raises the PaddingChanged event. (Inherited from ScrollableControl.)
Protected method | OnPaint | (Inherited from Form.)
Protected method | OnPaintBackground | Paints the background of the control. (Inherited from ScrollableControl.)
Protected method | OnParentBackColorChanged | Raises the BackColorChanged event when the BackColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBackgroundImageChanged | Raises the BackgroundImageChanged event when the BackgroundImage property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentBindingContextChanged | Raises the BindingContextChanged event when the BindingContext property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentChanged | (Inherited from ContainerControl.)
Protected method | OnParentCursorChanged | Raises the CursorChanged event. (Inherited from Control.)
Protected method | OnParentEnabledChanged | Raises the EnabledChanged event when the Enabled property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentFontChanged | Raises the FontChanged event when the Font property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentForeColorChanged | Raises the ForeColorChanged event when the ForeColor property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentRightToLeftChanged | Raises the RightToLeftChanged event when the RightToLeft property value of the control's container changes. (Inherited from Control.)
Protected method | OnParentVisibleChanged | Raises the VisibleChanged event when the Visible property value of the control's container changes. (Inherited from Control.)
Protected method | OnPreviewKeyDown | Raises the PreviewKeyDown event. (Inherited from Control.)
Protected method | OnPrint | Raises the Paint event. (Inherited from Control.)
Protected method | OnQueryContinueDrag | Raises the QueryContinueDrag event. (Inherited from Control.)
Protected method | OnRegionChanged | Raises the RegionChanged event. (Inherited from Control.)
Protected method | OnResize | (Inherited from Form.)
Protected method | OnResizeBegin | Raises the ResizeBegin event. (Inherited from Form.)
Protected method | OnResizeEnd | Raises the ResizeEnd event. (Inherited from Form.)
Protected method | OnRightToLeftChanged | (Inherited from ScrollableControl.)
Protected method | OnRightToLeftLayoutChanged | Raises the RightToLeftLayoutChanged event. (Inherited from Form.)
Protected method | OnScroll | Raises the Scroll event. (Inherited from ScrollableControl.)
Protected method | OnShown | Raises the Shown event. (Inherited from Form.)
Protected method | OnSizeChanged | Raises the SizeChanged event. (Inherited from Control.)
Protected method | OnStyleChanged | (Inherited from Form.)
Protected method | OnSystemColorsChanged | Raises the SystemColorsChanged event. (Inherited from Control.)
Protected method | OnTabIndexChanged | Raises the TabIndexChanged event. (Inherited from Control.)
Protected method | OnTabStopChanged | Raises the TabStopChanged event. (Inherited from Control.)
Protected method | OnTextChanged | (Inherited from Form.)
Protected method | OnValidated | Raises the Validated event. (Inherited from Control.)
Protected method | OnValidating | Raises the Validating event. (Inherited from Control.)
Protected method | OnVisibleChanged | Raises the VisibleChanged event. (Inherited from Form.)
Public method | PerformAutoScale | Performs scaling of the container control and its children. (Inherited from ContainerControl.)
Public method | PerformLayout | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PerformLayout(Control, String) | Forces the control to apply layout logic to all its child controls. (Inherited from Control.)
Public method | PointToClient | Computes the location of the specified screen point into client coordinates. (Inherited from Control.)
Public method | PointToScreen | Computes the location of the specified client point into screen coordinates. (Inherited from Control.)
Public method | PreProcessControlMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Public method | PreProcessMessage | Preprocesses keyboard or input messages within the message loop before they are dispatched. (Inherited from Control.)
Protected method | ProcessCmdKey | Processes a command key. (Inherited from Form.)
Protected method | ProcessDialogChar | Processes a dialog character. (Inherited from Form.)
Protected method | ProcessDialogKey | Processes a dialog box key. (Inherited from Form.)
Protected method | ProcessKeyEventArgs | Processes a key message and generates the appropriate control events. (Inherited from Control.)
Protected method | ProcessKeyMessage | Processes a keyboard message. (Inherited from Control.)
Protected method | ProcessKeyPreview | (Inherited from Form.)
Protected method | ProcessMnemonic | Processes a mnemonic character. (Inherited from Form.)
Protected method | ProcessTabKey | (Inherited from Form.)
Protected method | RaiseDragEvent | Raises the appropriate drag event. (Inherited from Control.)
Protected method | RaiseKeyEvent | Raises the appropriate key event. (Inherited from Control.)
Protected method | RaiseMouseEvent | Raises the appropriate mouse event. (Inherited from Control.)
Protected method | RaisePaintEvent | Raises the appropriate paint event. (Inherited from Control.)
Protected method | RecreateHandle | Forces the re-creation of the handle for the control. (Inherited from Control.)
Public method | RectangleToClient | Computes the size and location of the specified screen rectangle in client coordinates. (Inherited from Control.)
Public method | RectangleToScreen | Computes the size and location of the specified client rectangle in screen coordinates. (Inherited from Control.)
Public method | Refresh | Forces the control to invalidate its client area and immediately redraw itself and any child controls. (Inherited from Control.)
Public method | RemoveOwnedForm | Removes an owned form from this form. (Inherited from Form.)
Public method | ResetBackColor | Resets the BackColor property to its default value. (Inherited from Control.)
Public method | ResetBindings | Causes a control bound to the BindingSource to reread all the items in the list and refresh their displayed values. (Inherited from Control.)
Public method | ResetCursor | Resets the Cursor property to its default value. (Inherited from Control.)
Public method | ResetFont | Resets the Font property to its default value. (Inherited from Control.)
Public method | ResetForeColor | Resets the ForeColor property to its default value. (Inherited from Control.)
Public method | ResetImeMode | Resets the ImeMode property to its default value. (Inherited from Control.)
Protected method | ResetMouseEventArgs | Resets the control to handle the MouseLeave event. (Inherited from Control.)
Public method | ResetRightToLeft | Resets the RightToLeft property to its default value. (Inherited from Control.)
Public method | ResetText | Resets the Text property to its default value. (Inherited from Control.)
Public method | ResumeLayout | Resumes usual layout logic. (Inherited from Control.)
Public method | ResumeLayout(Boolean) | Resumes usual layout logic, optionally forcing an immediate layout of pending layout requests. (Inherited from Control.)
Protected method | RtlTranslateAlignment(HorizontalAlignment) | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(LeftRightAlignment) | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateAlignment(ContentAlignment) | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateContent | Converts the specified ContentAlignment to the appropriate ContentAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateHorizontal | Converts the specified HorizontalAlignment to the appropriate HorizontalAlignment to support right-to-left text. (Inherited from Control.)
Protected method | RtlTranslateLeftRight | Converts the specified LeftRightAlignment to the appropriate LeftRightAlignment to support right-to-left text. (Inherited from Control.)
Public method | Scale(Single) | Obsolete. Scales the control and any child controls. (Inherited from Control.)
Public method | Scale(SizeF) | Scales the control and all child controls by the specified scaling factor. (Inherited from Control.)
Public method | Scale(Single, Single) | Obsolete. Scales the entire control and any child controls. (Inherited from Control.)
Protected method | ScaleControl | Scales the location, size, padding, and margin of a control. (Inherited from Form.)
Protected method | ScaleCore | Performs scaling of the form. (Inherited from Form.)
Public method | ScrollControlIntoView | Scrolls the specified child control into view on an auto-scroll enabled control. (Inherited from ScrollableControl.)
Protected method | ScrollToControl | Calculates the scroll offset to the specified child control. (Inherited from ScrollableControl.)
Public method | Select | Activates the control. (Inherited from Control.)
Protected method | Select(Boolean, Boolean) | Selects this form, and optionally selects the next or previous control. (Inherited from Form.)
Public method | SelectNextControl | Activates the next control. (Inherited from Control.)
Public method | SendToBack | Sends the control to the back of the z-order. (Inherited from Control.)
Public method | SetAutoScrollMargin | Sets the size of the auto-scroll margins. (Inherited from ScrollableControl.)
Protected method | SetAutoSizeMode | Sets a value indicating how a control will behave when its AutoSize property is enabled. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32) | Sets the bounds of the control to the specified location and size. (Inherited from Control.)
Public method | SetBounds(Int32, Int32, Int32, Int32, BoundsSpecified) | Sets the specified bounds of the control to the specified location and size. (Inherited from Control.)
Protected method | SetBoundsCore | (Inherited from Form.)
Protected method | SetClientSizeCore | Sets the client size of the form. This will adjust the bounds of the form to make the client size the requested size. (Inherited from Form.)
Public method | SetDesktopBounds | Sets the bounds of the form in desktop coordinates. (Inherited from Form.)
Public method | SetDesktopLocation | Sets the location of the form in desktop coordinates. (Inherited from Form.)
Protected method | SetDisplayRectLocation | Positions the display window to the specified value. (Inherited from ScrollableControl.)
Protected method | SetScrollState | Sets the specified scroll state flag. (Inherited from ScrollableControl.)
Protected method | SetStyle | Sets a specified ControlStyles flag to either true or false. (Inherited from Control.)
Protected method | SetTopLevel | Sets the control as the top-level control. (Inherited from Control.)
Protected method | SetVisibleCore | (Inherited from Form.)
Public method | Show | Displays the control to the user. (Inherited from Control.)
Public method | Show(IWin32Window) | Shows the form with the specified owner to the user. (Inherited from Form.)
Public method | ShowDialog | Shows the form as a modal dialog box. (Inherited from Form.)
Public method | ShowDialog(IWin32Window) | Shows the form as a modal dialog box with the specified owner. (Inherited from Form.)
Protected method | SizeFromClientSize | Determines the size of the entire control from the height and width of its client area. (Inherited from Control.)
Public method | SuspendLayout | Temporarily suspends the layout logic for the control. (Inherited from Control.)
Public method | ToString | Gets a string representing the current instance of the form. (Inherited from Form.)
Public method | Update | Causes the control to redraw the invalidated regions within its client area. (Inherited from Control.)
Protected method | UpdateBounds | Updates the bounds of the control with the current size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size and location. (Inherited from Control.)
Protected method | UpdateBounds(Int32, Int32, Int32, Int32, Int32, Int32) | Updates the bounds of the control with the specified size, location, and client size. (Inherited from Control.)
Protected method | UpdateDefaultButton | Updates which button is the default button. (Inherited from Form.)
Protected method | UpdateStyles | Forces the assigned styles to be reapplied to the control. (Inherited from Control.)
Protected method | UpdateZOrder | Updates the control in its parent's z-order. (Inherited from Control.)
Public method | Validate | Verifies the value of the control losing focus by causing the Validating and Validated events to occur, in that order. (Inherited from ContainerControl.)
Public method | Validate(Boolean) | Verifies the value of the control that is losing focus; conditionally dependent on whether automatic validation is turned on. (Inherited from ContainerControl.)
Public method | ValidateChildren | (Inherited from Form.)
Public method | ValidateChildren(ValidationConstraints) | (Inherited from Form.)
Protected method | WndProc | (Inherited from Form.)
Top
Extension Methods
 | Name | Description
Public Extension Method | GetEnumValueOrDefault(Type, Object) | Overloaded. Gets the enumeration constant for value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | GetEnumValueOrDefaultT(Object) | Overloaded. Gets the enumeration constant for this value, if defined in the enumeration, or a default value. (Defined by EnumExtensions.)
Public Extension Method | RestoreLayout | Restores the size and location of the specified windowsForm from the size and location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreLocation(String) | Overloaded. Restores the location of the specified windowsForm from the location information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | RestoreSize(String) | Overloaded. Restores the size of the specified windowsForm from the size information saved in the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLayout | Saves the size and location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveLocation(String) | Overloaded. Saves the location information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Public Extension Method | SaveSize(String) | Overloaded. Saves the size information of the specified windowsForm to the application configuration file. (Defined by FormExtensions.)
Top
See Also

Reference

SecureForm Class
GSF.Windows.Forms Namespace


SecureForm.Dispose Method

Grid Solutions Framework SecureFormDispose Method
Overload List
 | Name | Description
Public method | Dispose | Releases all resources used by the Component. (Inherited from Component.)
Protected method | Dispose(Boolean) | Clean up any resources being used. (Overrides FormDispose(Boolean).)
Top
See Also

Reference

SecureForm Class
GSF.Windows.Forms Namespace


SecureForm.Dispose Method (Boolean)

Grid Solutions Framework SecureFormDispose Method (Boolean)
Clean up any resources being used.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected override void Dispose(
    bool disposing
)
Protected Overrides Sub Dispose (
    disposing As Boolean
)
abstract Dispose :
        disposing : bool -> unit
override Dispose :
        disposing : bool -> unit
function Dispose(disposing);
protected:
virtual void Dispose(
    bool disposing
) override

Parameters

disposing
Type: SystemBoolean
true if managed resources should be disposed; otherwise, false.
See Also

Reference

SecureForm Class
Dispose Overload
GSF.Windows.Forms Namespace


SecureForm.GetResourceName Method

Grid Solutions Framework SecureFormGetResourceName Method
Gets the name of resource being accessed.

Namespace: GSF.Windows.Forms
Assembly: GSF.Windows (in GSF.Windows.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
protected virtual string GetResourceName()
Protected Overridable Function GetResourceName As String
abstract GetResourceName : unit -> string
override GetResourceName : unit -> string
function GetResourceName();
protected:
virtual String^ GetResourceName()

Return Value

Type: String
Name of the resource being accessed.
See Also

Reference

SecureForm Class
GSF.Windows.Forms Namespace


SecureForm Properties

Grid Solutions Framework SecureForm Properties

The SecureForm type exposes the following members.

Properties
 | Name | Description
Public property | AcceptButton | Gets or sets the button on the form that is clicked when the user presses the ENTER key. (Inherited from Form.)
Public property | AccessibilityObject | Gets the AccessibleObject assigned to the control. (Inherited from Control.)
Public property | AccessibleDefaultActionDescription | Gets or sets the default action description of the control for use by accessibility client applications. (Inherited from Control.)
Public property | AccessibleDescription | Gets or sets the description of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleName | Gets or sets the name of the control used by accessibility client applications. (Inherited from Control.)
Public property | AccessibleRole | Gets or sets the accessible role of the control (Inherited from Control.)
Public property | ActiveControl | Gets or sets the active control on the container control. (Inherited from ContainerControl.)
Public property | ActiveMdiChild | Gets the currently active multiple-document interface (MDI) child window. (Inherited from Form.)
Public property | AllowDrop | Gets or sets a value indicating whether the control can accept data that the user drags onto it. (Inherited from Control.)
Public property | AllowTransparency | Gets or sets a value indicating whether the opacity of the form can be adjusted. (Inherited from Form.)
Public property | Anchor | Gets or sets the edges of the container to which a control is bound and determines how a control is resized with its parent. (Inherited from Control.)
Public property | AutoScale | Obsolete. Gets or sets a value indicating whether the form adjusts its size to fit the height of the font used on the form and scales its controls. (Inherited from Form.)
Public property | AutoScaleBaseSize | Gets or sets the base size used for autoscaling of the form. (Inherited from Form.)
Public property | AutoScaleDimensions | Gets or sets the dimensions that the control was designed to. (Inherited from ContainerControl.)
Protected property | AutoScaleFactor | Gets the scaling factor between the current and design-time automatic scaling dimensions. (Inherited from ContainerControl.)
Public property | AutoScaleMode | Gets or sets the automatic scaling mode of the control. (Inherited from ContainerControl.)
Public property | AutoScroll | Gets or sets a value indicating whether the form enables autoscrolling. (Inherited from Form.)
Public property | AutoScrollMargin | Gets or sets the size of the auto-scroll margin. (Inherited from ScrollableControl.)
Public property | AutoScrollMinSize | Gets or sets the minimum size of the auto-scroll. (Inherited from ScrollableControl.)
Public property | AutoScrollOffset | Gets or sets where this control is scrolled to in ScrollControlIntoView(Control). (Inherited from Control.)
Public property | AutoScrollPosition | Gets or sets the location of the auto-scroll position. (Inherited from ScrollableControl.)
Public property | AutoSize | Resize the form according to the setting of AutoSizeMode. (Inherited from Form.)
Public property | AutoSizeMode | Gets or sets the mode by which the form automatically resizes itself. (Inherited from Form.)
Public property | AutoValidate | (Inherited from Form.)
Public property | BackColor | (Inherited from Form.)
Public property | BackgroundImage | Gets or sets the background image displayed in the control. (Inherited from Control.)
Public property | BackgroundImageLayout | Gets or sets the background image layout as defined in the ImageLayout enumeration. (Inherited from Control.)
Public property | BindingContext | (Inherited from ContainerControl.)
Public property | Bottom | Gets the distance, in pixels, between the bottom edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | Bounds | Gets or sets the size and location of the control including its nonclient elements, in pixels, relative to the parent control. (Inherited from Control.)
Public property | CancelButton | Gets or sets the button control that is clicked when the user presses the ESC key. (Inherited from Form.)
Protected property | CanEnableIme | Gets a value indicating whether the ImeMode property can be set to an active value, to enable IME support. (Inherited from ContainerControl.)
Public property | CanFocus | Gets a value indicating whether the control can receive focus. (Inherited from Control.)
Protected property | CanRaiseEvents | Determines if events can be raised on the control. (Inherited from Control.)
Public property | CanSelect | Gets a value indicating whether the control can be selected. (Inherited from Control.)
Public property | Capture | Gets or sets a value indicating whether the control has captured the mouse. (Inherited from Control.)
Public property | CausesValidation | Gets or sets a value indicating whether the control causes validation to be performed on any controls that require validation when it receives focus. (Inherited from Control.)
Public property | ClientRectangle | Gets the rectangle that represents the client area of the control. (Inherited from Control.)
Public property | ClientSize | Gets or sets the size of the client area of the form. (Inherited from Form.)
Public property | CompanyName | Gets the name of the company or creator of the application containing the control. (Inherited from Control.)
Public property | Container | Gets the IContainer that contains the Component. (Inherited from Component.)
Public property | ContainsFocus | Gets a value indicating whether the control, or one of its child controls, currently has the input focus. (Inherited from Control.)
Public property | ContextMenu | Gets or sets the shortcut menu associated with the control. (Inherited from Control.)
Public property | ContextMenuStrip | Gets or sets the ContextMenuStrip associated with this control. (Inherited from Control.)
Public property | ControlBox | Gets or sets a value indicating whether a control box is displayed in the caption bar of the form. (Inherited from Form.)
Public property | Controls | Gets the collection of controls contained within the control. (Inherited from Control.)
Public property | Created | Gets a value indicating whether the control has been created. (Inherited from Control.)
Protected property | CreateParams | (Inherited from Form.)
Public property | CurrentAutoScaleDimensions | Gets the current run-time dimensions of the screen. (Inherited from ContainerControl.)
Public property | Cursor | Gets or sets the cursor that is displayed when the mouse pointer is over the control. (Inherited from Control.)
Public property | DataBindings | Gets the data bindings for the control. (Inherited from Control.)
Protected property | DefaultCursor | Gets or sets the default cursor for the control. (Inherited from Control.)
Protected property | DefaultImeMode | Gets the default Input Method Editor (IME) mode supported by the control. (Inherited from Form.)
Protected property | DefaultMargin | Gets the space, in pixels, that is specified by default between controls. (Inherited from Control.)
Protected property | DefaultMaximumSize | Gets the length and height, in pixels, that is specified as the default maximum size of a control. (Inherited from Control.)
Protected property | DefaultMinimumSize | Gets the length and height, in pixels, that is specified as the default minimum size of a control. (Inherited from Control.)
Protected property | DefaultPadding | Gets the internal spacing, in pixels, of the contents of a control. (Inherited from Control.)
Protected property | DefaultSize | (Inherited from Form.)
Protected property | DesignMode | Gets a value that indicates whether the Component is currently in design mode. (Inherited from Component.)
Public property | DesktopBounds | Gets or sets the size and location of the form on the Windows desktop. (Inherited from Form.)
Public property | DesktopLocation | Gets or sets the location of the form on the Windows desktop. (Inherited from Form.)
Public property | DialogResult | Gets or sets the dialog result for the form. (Inherited from Form.)
Public property | DisplayRectangle | Gets the rectangle that represents the virtual display area of the control. (Inherited from ScrollableControl.)
Public property | Disposing | Gets a value indicating whether the base Control class is in the process of disposing. (Inherited from Control.)
Public property | Dock | Gets or sets which control borders are docked to its parent control and determines how a control is resized with its parent. (Inherited from Control.)
Public property | DockPadding | Gets the dock padding settings for all edges of the control. (Inherited from ScrollableControl.)
Protected property | DoubleBuffered | Gets or sets a value indicating whether this control should redraw its surface using a secondary buffer to reduce or prevent flicker. (Inherited from Control.)
Public property | Enabled | Gets or sets a value indicating whether the control can respond to user interaction. (Inherited from Control.)
Protected property | Events | Gets the list of event handlers that are attached to this Component. (Inherited from Component.)
Public property | Focused | Gets a value indicating whether the control has input focus. (Inherited from Control.)
Public property | Font | Gets or sets the font of the text displayed by the control. (Inherited from Control.)
Protected property | FontHeight | Gets or sets the height of the font of the control. (Inherited from Control.)
Public property | ForeColor | Gets or sets the foreground color of the control. (Inherited from Control.)
Public property | FormBorderStyle | Gets or sets the border style of the form. (Inherited from Form.)
Public property | Handle | Gets the window handle that the control is bound to. (Inherited from Control.)
Public property | HasChildren | Gets a value indicating whether the control contains one or more child controls. (Inherited from Control.)
Public property | Height | Gets or sets the height of the control. (Inherited from Control.)
Public property | HelpButton | Gets or sets a value indicating whether a Help button should be displayed in the caption box of the form. (Inherited from Form.)
Public property | HorizontalScroll | Gets the characteristics associated with the horizontal scroll bar. (Inherited from ScrollableControl.)
Protected property | HScroll | Gets or sets a value indicating whether the horizontal scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Icon | Gets or sets the icon for the form. (Inherited from Form.)
Public property | ImeMode | Gets or sets the Input Method Editor (IME) mode of the control. (Inherited from Control.)
Protected property | ImeModeBase | Gets or sets the IME mode of a control. (Inherited from Control.)
Public property | InvokeRequired | Gets a value indicating whether the caller must call an invoke method when making method calls to the control because the caller is on a different thread than the one the control was created on. (Inherited from Control.)
Public property | IsAccessible | Gets or sets a value indicating whether the control is visible to accessibility applications. (Inherited from Control.)
Public property | IsDisposed | Gets a value indicating whether the control has been disposed of. (Inherited from Control.)
Public property | IsHandleCreated | Gets a value indicating whether the control has a handle associated with it. (Inherited from Control.)
Public property | IsMdiChild | Gets a value indicating whether the form is a multiple-document interface (MDI) child form. (Inherited from Form.)
Public property | IsMdiContainer | Gets or sets a value indicating whether the form is a container for multiple-document interface (MDI) child forms. (Inherited from Form.)
Public property | IsMirrored | Gets a value indicating whether the control is mirrored. (Inherited from Control.)
Public property | IsRestrictedWindow | Gets a value indicating whether the form can use all windows and user input events without restriction. (Inherited from Form.)
Public property | KeyPreview | Gets or sets a value indicating whether the form will receive key events before the event is passed to the control that has focus. (Inherited from Form.)
Public property | LayoutEngine | Gets a cached instance of the control's layout engine. (Inherited from Control.)
Public property | Left | Gets or sets the distance, in pixels, between the left edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | Location | Gets or sets the Point that represents the upper-left corner of the Form in screen coordinates. (Inherited from Form.)
Public property | MainMenuStrip | Gets or sets the primary menu container for the form. (Inherited from Form.)
Public property | Margin | Gets or sets the space between controls. (Inherited from Form.)
Public property | MaximizeBox | Gets or sets a value indicating whether the Maximize button is displayed in the caption bar of the form. (Inherited from Form.)
Protected property | MaximizedBounds | Gets and sets the size of the form when it is maximized. (Inherited from Form.)
Public property | MaximumSize | Gets the maximum size the form can be resized to. (Inherited from Form.)
Public property | MdiChildren | Gets an array of forms that represent the multiple-document interface (MDI) child forms that are parented to this form. (Inherited from Form.)
Public property | MdiParent | Gets or sets the current multiple-document interface (MDI) parent form of this form. (Inherited from Form.)
Public property | Menu | Gets or sets the MainMenu that is displayed in the form. (Inherited from Form.)
Public property | MergedMenu | Gets the merged menu for the form. (Inherited from Form.)
Public property | MinimizeBox | Gets or sets a value indicating whether the Minimize button is displayed in the caption bar of the form. (Inherited from Form.)
Public property | MinimumSize | Gets or sets the minimum size the form can be resized to. (Inherited from Form.)
Public property | Modal | Gets a value indicating whether this form is displayed modally. (Inherited from Form.)
Public property | Name | Gets or sets the name of the control. (Inherited from Control.)
Public property | Opacity | Gets or sets the opacity level of the form. (Inherited from Form.)
Public property | OwnedForms | Gets an array of Form objects that represent all forms that are owned by this form. (Inherited from Form.)
Public property | Owner | Gets or sets the form that owns this form. (Inherited from Form.)
Public property | Padding | Gets or sets padding within the control. (Inherited from Control.)
Public property | Parent | Gets or sets the parent container of the control. (Inherited from Control.)
Public property | ParentForm | Gets the form that the container control is assigned to. (Inherited from ContainerControl.)
Public property | PreferredSize | Gets the size of a rectangular area into which the control can fit. (Inherited from Control.)
Public property | ProductName | Gets the product name of the assembly containing the control. (Inherited from Control.)
Public property | ProductVersion | Gets the version of the assembly containing the control. (Inherited from Control.)
Public property | RecreatingHandle | Gets a value indicating whether the control is currently re-creating its handle. (Inherited from Control.)
Public property | Region | Gets or sets the window region associated with the control. (Inherited from Control.)
Protected property | RenderRightToLeft | Obsolete. This property is now obsolete. (Inherited from Control.)
Protected property | ResizeRedraw | Gets or sets a value indicating whether the control redraws itself when resized. (Inherited from Control.)
Public property | RestoreBounds | Gets the location and size of the form in its normal window state. (Inherited from Form.)
Public property | Right | Gets the distance, in pixels, between the right edge of the control and the left edge of its container's client area. (Inherited from Control.)
Public property | RightToLeft | Gets or sets a value indicating whether control's elements are aligned to support locales using right-to-left fonts. (Inherited from Control.)
Public property | RightToLeftLayout | Gets or sets a value indicating whether right-to-left mirror placement is turned on. (Inherited from Form.)
Protected property | ScaleChildren | Gets a value that determines the scaling of child controls. (Inherited from Control.)
Protected property | ShowFocusCues | Gets a value indicating whether the control should display focus rectangles. (Inherited from Control.)
Public property | ShowIcon | Gets or sets a value indicating whether an icon is displayed in the caption bar of the form. (Inherited from Form.)
Public property | ShowInTaskbar | Gets or sets a value indicating whether the form is displayed in the Windows taskbar. (Inherited from Form.)
Protected property | ShowKeyboardCues | Gets a value indicating whether the user interface is in the appropriate state to show or hide keyboard accelerators. (Inherited from Control.)
Protected property | ShowWithoutActivation | Gets a value indicating whether the window will be activated when it is shown. (Inherited from Form.)
Public property | Site | Gets or sets the site of the control. (Inherited from Control.)
Public property | Size | Gets or sets the size of the form. (Inherited from Form.)
Public property | SizeGripStyle | Gets or sets the style of the size grip to display in the lower-right corner of the form. (Inherited from Form.)
Public property | StartPosition | Gets or sets the starting position of the form at run time. (Inherited from Form.)
Public property | TabIndex | Gets or sets the tab order of the control within its container. (Inherited from Form.)
Public property | TabStop | Gets or sets a value indicating whether the user can give the focus to this control using the TAB key. (Inherited from Form.)
Public property | Tag | Gets or sets the object that contains data about the control. (Inherited from Control.)
Public property | Text | (Inherited from Form.)
Public property | Top | Gets or sets the distance, in pixels, between the top edge of the control and the top edge of its container's client area. (Inherited from Control.)
Public property | TopLevel | Gets or sets a value indicating whether to display the form as a top-level window. (Inherited from Form.)
Public property | TopLevelControl | Gets the parent control that is not parented by another Windows Forms control. Typically, this is the outermost Form that the control is contained in. (Inherited from Control.)
Public property | TopMost | Gets or sets a value indicating whether the form should be displayed as a topmost form. (Inherited from Form.)
Public property | TransparencyKey | Gets or sets the color that will represent transparent areas of the form. (Inherited from Form.)
Public property | UseWaitCursor | Gets or sets a value indicating whether to use the wait cursor for the current control and all child controls. (Inherited from Control.)
Public property | VerticalScroll | Gets the characteristics associated with the vertical scroll bar. (Inherited from ScrollableControl.)
Public property | Visible | Gets or sets a value indicating whether the control and all its child controls are displayed. (Inherited from Control.)
Protected property | VScroll | Gets or sets a value indicating whether the vertical scroll bar is visible. (Inherited from ScrollableControl.)
Public property | Width | Gets or sets the width of the control. (Inherited from Control.)
Public property | WindowState | Gets or sets a value that indicates whether form is minimized, maximized, or normal. (Inherited from Form.)
Public property | WindowTarget | This property is not relevant for this class. (Inherited from Control.)
Top
See Also

Reference

SecureForm Class
GSF.Windows.Forms Namespace


SecureForm Events

Grid Solutions Framework SecureForm Events

The SecureForm type exposes the following members.

Events
 | Name | Description
Public event | Activated | Occurs when the form is activated in code or by the user. (Inherited from Form.)
Public event | AutoSizeChanged | Occurs when the AutoSize property changes. (Inherited from Form.)
Public event | AutoValidateChanged | Occurs when the AutoValidate property changes. (Inherited from Form.)
Public event | BackColorChanged | Occurs when the value of the BackColor property changes. (Inherited from Control.)
Public event | BackgroundImageChanged | Occurs when the value of the BackgroundImage property changes. (Inherited from Control.)
Public event | BackgroundImageLayoutChanged | Occurs when the BackgroundImageLayout property changes. (Inherited from Control.)
Public event | BindingContextChanged | Occurs when the value of the BindingContext property changes. (Inherited from Control.)
Public event | CausesValidationChanged | Occurs when the value of the CausesValidation property changes. (Inherited from Control.)
Public event | ChangeUICues | Occurs when the focus or keyboard user interface (UI) cues change. (Inherited from Control.)
Public event | Click | Occurs when the control is clicked. (Inherited from Control.)
Public event | ClientSizeChanged | Occurs when the value of the ClientSize property changes. (Inherited from Control.)
Public event | Closed | Occurs when the form is closed. (Inherited from Form.)
Public event | Closing | Occurs when the form is closing. (Inherited from Form.)
Public event | ContextMenuChanged | Occurs when the value of the ContextMenu property changes. (Inherited from Control.)
Public event | ContextMenuStripChanged | Occurs when the value of the ContextMenuStrip property changes. (Inherited from Control.)
Public event | ControlAdded | Occurs when a new control is added to the ControlControlCollection. (Inherited from Control.)
Public event | ControlRemoved | Occurs when a control is removed from the ControlControlCollection. (Inherited from Control.)
Public event | CursorChanged | Occurs when the value of the Cursor property changes. (Inherited from Control.)
Public event | Deactivate | Occurs when the form loses focus and is no longer the active form. (Inherited from Form.)
Public event | Disposed | Occurs when the component is disposed by a call to the Dispose method. (Inherited from Component.)
Public event | DockChanged | Occurs when the value of the Dock property changes. (Inherited from Control.)
Public event | DoubleClick | Occurs when the control is double-clicked. (Inherited from Control.)
Public event | DragDrop | Occurs when a drag-and-drop operation is completed. (Inherited from Control.)
Public event | DragEnter | Occurs when an object is dragged into the control's bounds. (Inherited from Control.)
Public event | DragLeave | Occurs when an object is dragged out of the control's bounds. (Inherited from Control.)
Public event | DragOver | Occurs when an object is dragged over the control's bounds. (Inherited from Control.)
Public event | EnabledChanged | Occurs when the Enabled property value has changed. (Inherited from Control.)
Public event | Enter | Occurs when the control is entered. (Inherited from Control.)
Public event | FontChanged | Occurs when the Font property value changes. (Inherited from Control.)
Public event | ForeColorChanged | Occurs when the ForeColor property value changes. (Inherited from Control.)
Public event | FormClosed | Occurs after the form is closed. (Inherited from Form.)
Public event | FormClosing | Occurs before the form is closed. (Inherited from Form.)
Public event | GiveFeedback | Occurs during a drag operation. (Inherited from Control.)
Public event | GotFocus | Occurs when the control receives focus. (Inherited from Control.)
Public event | HandleCreated | Occurs when a handle is created for the control. (Inherited from Control.)
Public event | HandleDestroyed | Occurs when the control's handle is in the process of being destroyed. (Inherited from Control.)
Public event | HelpButtonClicked | Occurs when the Help button is clicked. (Inherited from Form.)
Public event | HelpRequested | Occurs when the user requests help for a control. (Inherited from Control.)
Public event | ImeModeChanged | Occurs when the ImeMode property has changed. (Inherited from Control.)
Public event | InputLanguageChanged | Occurs after the input language of the form has changed. (Inherited from Form.)
Public event | InputLanguageChanging | Occurs when the user attempts to change the input language for the form. (Inherited from Form.)
Public event | Invalidated | Occurs when a control's display requires redrawing. (Inherited from Control.)
Public event | KeyDown | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyPress | Occurs when a key is pressed while the control has focus. (Inherited from Control.)
Public event | KeyUp | Occurs when a key is released while the control has focus. (Inherited from Control.)
Public event | Layout | Occurs when a control should reposition its child controls. (Inherited from Control.)
Public event | Leave | Occurs when the input focus leaves the control. (Inherited from Control.)
Public event | Load | Occurs before a form is displayed for the first time. (Inherited from Form.)
Public event | LocationChanged | Occurs when the Location property value has changed. (Inherited from Control.)
Public event | LostFocus | Occurs when the control loses focus. (Inherited from Control.)
Public event | MarginChanged | Occurs when the Margin property changes. (Inherited from Form.)
Public event | MaximizedBoundsChanged | Occurs when the value of the MaximizedBounds property has changed. (Inherited from Form.)
Public event | MaximumSizeChanged | Occurs when the value of the MaximumSize property has changed. (Inherited from Form.)
Public event | MdiChildActivate | Occurs when a multiple-document interface (MDI) child form is activated or closed within an MDI application. (Inherited from Form.)
Public event | MenuComplete | Occurs when the menu of a form loses focus. (Inherited from Form.)
Public event | MenuStart | Occurs when the menu of a form receives focus. (Inherited from Form.)
Public event | MinimumSizeChanged | Occurs when the value of the MinimumSize property has changed. (Inherited from Form.)
Public event | MouseCaptureChanged | Occurs when the control loses mouse capture. (Inherited from Control.)
Public event | MouseClick | Occurs when the control is clicked by the mouse. (Inherited from Control.)
Public event | MouseDoubleClick | Occurs when the control is double clicked by the mouse. (Inherited from Control.)
Public event | MouseDown | Occurs when the mouse pointer is over the control and a mouse button is pressed. (Inherited from Control.)
Public event | MouseEnter | Occurs when the mouse pointer enters the control. (Inherited from Control.)
Public event | MouseHover | Occurs when the mouse pointer rests on the control. (Inherited from Control.)
Public event | MouseLeave | Occurs when the mouse pointer leaves the control. (Inherited from Control.)
Public event | MouseMove | Occurs when the mouse pointer is moved over the control. (Inherited from Control.)
Public event | MouseUp | Occurs when the mouse pointer is over the control and a mouse button is released. (Inherited from Control.)
Public event | MouseWheel | Occurs when the mouse wheel moves while the control has focus. (Inherited from Control.)
Public event | Move | Occurs when the control is moved. (Inherited from Control.)
Public event | PaddingChanged | Occurs when the control's padding changes. (Inherited from Control.)
Public event | Paint | Occurs when the control is redrawn. (Inherited from Control.)
Public event | ParentChanged | Occurs when the Parent property value changes. (Inherited from Control.)
Public event | PreviewKeyDown | Occurs before the KeyDown event when a key is pressed while focus is on this control. (Inherited from Control.)
Public event | QueryAccessibilityHelp | Occurs when AccessibleObject is providing help to accessibility applications. (Inherited from Control.)
Public event | QueryContinueDrag | Occurs during a drag-and-drop operation and enables the drag source to determine whether the drag-and-drop operation should be canceled. (Inherited from Control.)
Public event | RegionChanged | Occurs when the value of the Region property changes. (Inherited from Control.)
Public event | Resize | Occurs when the control is resized. (Inherited from Control.)
Public event | ResizeBegin | Occurs when a form enters resizing mode. (Inherited from Form.)
Public event | ResizeEnd | Occurs when a form exits resizing mode. (Inherited from Form.)
Public event | RightToLeftChanged | Occurs when the RightToLeft property value changes. (Inherited from Control.)
Public event | RightToLeftLayoutChanged | Occurs after the value of the RightToLeftLayout property changes. (Inherited from Form.)
Public event | Scroll | Occurs when the user or code scrolls through the client area. (Inherited from ScrollableControl.)
Public event | Shown | Occurs whenever the form is first displayed. (Inherited from Form.)
Public event | SizeChanged | Occurs when the Size property value changes. (Inherited from Control.)
Public event | StyleChanged | Occurs when the control style changes. (Inherited from Control.)
Public event | SystemColorsChanged | Occurs when the system colors change. (Inherited from Control.)
Public event | TabIndexChanged | Occurs when the value of the TabIndex property changes. (Inherited from Form.)
Public event | TabStopChanged | Occurs when the TabStop property changes. (Inherited from Form.)
Public event | TextChanged | Occurs when the Text property value changes. (Inherited from Control.)
Public event | Validated | Occurs when the control is finished validating. (Inherited from Control.)
Public event | Validating | Occurs when the control is validating. (Inherited from Control.)
Public event | VisibleChanged | Occurs when the Visible property value changes. (Inherited from Control.)
Top
See Also

Reference

SecureForm Class
GSF.Windows.Forms Namespace


GSF.Xml Namespace

Grid Solutions Framework GSF.Xml Namespace
Contains extension functions used to simplify and standardize usage of standard Xml objects.
Classes
 | Class | Description
Public class | XmlExtensions | Defines extension functions related to Xml elements.


XmlExtensions Class

Grid Solutions Framework XmlExtensions Class
Defines extension functions related to Xml elements.
Inheritance Hierarchy
SystemObject
GSF.XmlXmlExtensions

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static class XmlExtensions
<ExtensionAttribute>
Public NotInheritable Class XmlExtensions
[<AbstractClassAttribute>]
[<SealedAttribute>]
type XmlExtensions =  class end
GSF.Xml.XmlExtensions = function();

Type.createClass(
    'GSF.Xml.XmlExtensions');
[ExtensionAttribute]
public ref class XmlExtensions abstract sealed

The XmlExtensions type exposes the following members.

Methods
Name | Description
GetAttributeValue | Safely gets or sets an XML node's attribute.
GetDataSet | Gets a data set object from an XML data set formatted as a String.
GetXmlNode(XmlDocument, String) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlNode, String) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlDocument, String, Boolean) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlNode, String, Boolean) | Gets an XML node from given path, creating the entire path if it does not exist.
SetAttributeValue | Safely sets an XML node's attribute.
Top
See Also

Reference

GSF.Xml Namespace


XmlExtensions Methods

Grid Solutions Framework XmlExtensions Methods

The XmlExtensions type exposes the following members.

Methods
Name | Description
GetAttributeValue | Safely gets or sets an XML node's attribute.
GetDataSet | Gets a data set object from an XML data set formatted as a String.
GetXmlNode(XmlDocument, String) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlNode, String) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlDocument, String, Boolean) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlNode, String, Boolean) | Gets an XML node from given path, creating the entire path if it does not exist.
SetAttributeValue | Safely sets an XML node's attribute.
Top
See Also

Reference

XmlExtensions Class
GSF.Xml Namespace


XmlExtensions.GetAttributeValue Method

Grid Solutions Framework XmlExtensionsGetAttributeValue Method
Safely gets or sets an XML node's attribute.

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static string GetAttributeValue(
    this XmlNode node,
    string name
)
<ExtensionAttribute>
Public Shared Function GetAttributeValue (
    node As XmlNode,
    name As String
) As String
static member GetAttributeValue :
        node : XmlNode *
        name : string -> string

GSF.Xml.XmlExtensions.GetAttributeValue = function(node, name);
public:
[ExtensionAttribute]
static String^ GetAttributeValue(
    XmlNode^ node,
    String^ name
)

Parameters

node
Type: System.XmlXmlNode
A XmlNode to query.
name
Type: SystemString
A String name of the value to get.

Return Value

Type: String
A String value returned for the attribute's value.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XmlNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If you get an attribute that does not exist, null will be returned.
See Also

Reference

XmlExtensions Class
GSF.Xml Namespace


XmlExtensions.GetDataSet Method

Grid Solutions Framework XmlExtensionsGetDataSet Method
Gets a data set object from an XML data set formatted as a String.

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static DataSet GetDataSet(
    this string xmlData
)
<ExtensionAttribute>
Public Shared Function GetDataSet (
    xmlData As String
) As DataSet
static member GetDataSet :
        xmlData : string -> DataSet

GSF.Xml.XmlExtensions.GetDataSet = function(xmlData);
public:
[ExtensionAttribute]
static DataSet^ GetDataSet(
    String^ xmlData
)

Parameters

xmlData
Type: SystemString
XML data string in standard DataSet format.

Return Value

Type: DataSet
A DataSet object.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type String. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlExtensions Class
GSF.Xml Namespace


XmlExtensions.GetXmlNode Method

Grid Solutions Framework XmlExtensionsGetXmlNode Method
Overload List
Name | Description
GetXmlNode(XmlDocument, String) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlNode, String) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlDocument, String, Boolean) | Gets an XML node from given path, creating the entire path if it does not exist.
GetXmlNode(XmlNode, String, Boolean) | Gets an XML node from given path, creating the entire path if it does not exist.
Top
See Also

Reference

XmlExtensions Class
GSF.Xml Namespace


XmlExtensions.GetXmlNode Method (XmlDocument, String)

Grid Solutions Framework XmlExtensionsGetXmlNode Method (XmlDocument, String)
Gets an XML node from given path, creating the entire path if it does not exist.

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static XmlNode GetXmlNode(
    this XmlDocument xmlDoc,
    string xpath
)
<ExtensionAttribute>
Public Shared Function GetXmlNode (
    xmlDoc As XmlDocument,
    xpath As String
) As XmlNode
static member GetXmlNode :
        xmlDoc : XmlDocument *
        xpath : string -> XmlNode

GSF.Xml.XmlExtensions.GetXmlNode = function(xmlDoc, xpath);
public:
[ExtensionAttribute]
static XmlNode^ GetXmlNode(
    XmlDocument^ xmlDoc,
    String^ xpath
)

Parameters

xmlDoc
Type: System.XmlXmlDocument
An XmlDocument to query.
xpath
Type: SystemString
A String xpath query.

Return Value

Type: XmlNode
An XmlNode corresponding to the xpath query.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XmlDocument. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
This overload just allows the start of the given XML document by using its root element.
See Also

Reference

XmlExtensions Class
GetXmlNode Overload
GSF.Xml Namespace


XmlExtensions.GetXmlNode Method (XmlNode, String)

Grid Solutions Framework XmlExtensionsGetXmlNode Method (XmlNode, String)
Gets an XML node from given path, creating the entire path if it does not exist.

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static XmlNode GetXmlNode(
    this XmlNode parentNode,
    string xpath
)
<ExtensionAttribute>
Public Shared Function GetXmlNode (
    parentNode As XmlNode,
    xpath As String
) As XmlNode
static member GetXmlNode :
        parentNode : XmlNode *
        xpath : string -> XmlNode

GSF.Xml.XmlExtensions.GetXmlNode = function(parentNode, xpath);
public:
[ExtensionAttribute]
static XmlNode^ GetXmlNode(
    XmlNode^ parentNode,
    String^ xpath
)

Parameters

parentNode
Type: System.XmlXmlNode
An XmlNode parent node to query.
xpath
Type: SystemString
A String xpath query.

Return Value

Type: XmlNode
An XmlNode corresponding to the xpath query.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XmlNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
See Also

Reference

XmlExtensions Class
GetXmlNode Overload
GSF.Xml Namespace


XmlExtensions.GetXmlNode Method (XmlDocument, String, Boolean)

Grid Solutions Framework XmlExtensionsGetXmlNode Method (XmlDocument, String, Boolean)
Gets an XML node from given path, creating the entire path if it does not exist.

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static XmlNode GetXmlNode(
    this XmlDocument xmlDoc,
    string xpath,
    out bool isDirty
)
<ExtensionAttribute>
Public Shared Function GetXmlNode (
    xmlDoc As XmlDocument,
    xpath As String,
    <OutAttribute> ByRef isDirty As Boolean
) As XmlNode
static member GetXmlNode :
        xmlDoc : XmlDocument *
        xpath : string *
        isDirty : bool byref -> XmlNode

GSF.Xml.XmlExtensions.GetXmlNode = function(xmlDoc, xpath, isDirty);
public:
[ExtensionAttribute]
static XmlNode^ GetXmlNode(
    XmlDocument^ xmlDoc,
    String^ xpath,
    [OutAttribute] bool% isDirty
)

Parameters

xmlDoc
Type: System.XmlXmlDocument
An XmlDocument to query.
xpath
Type: SystemString
A String xpath query.
isDirty
Type: SystemBoolean
A Boolean value indicating if items were added to the tree.

Return Value

Type: XmlNode
An XmlNode corresponding to the xpath query.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XmlDocument. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks

This overload just allows the start of the given XML document by using its root element.

Note that the isDirty parameter will be set to True if any items were added to the tree.

See Also

Reference

XmlExtensions Class
GetXmlNode Overload
GSF.Xml Namespace


XmlExtensions.GetXmlNode Method (XmlNode, String, Boolean)

Grid Solutions Framework XmlExtensionsGetXmlNode Method (XmlNode, String, Boolean)
Gets an XML node from given path, creating the entire path if it does not exist.

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static XmlNode GetXmlNode(
    this XmlNode parentNode,
    string xpath,
    out bool isDirty
)
<ExtensionAttribute>
Public Shared Function GetXmlNode (
    parentNode As XmlNode,
    xpath As String,
    <OutAttribute> ByRef isDirty As Boolean
) As XmlNode
static member GetXmlNode :
        parentNode : XmlNode *
        xpath : string *
        isDirty : bool byref -> XmlNode

GSF.Xml.XmlExtensions.GetXmlNode = function(parentNode, xpath, isDirty);
public:
[ExtensionAttribute]
static XmlNode^ GetXmlNode(
    XmlNode^ parentNode,
    String^ xpath,
    [OutAttribute] bool% isDirty
)

Parameters

parentNode
Type: System.XmlXmlNode
An XmlNode parent node to query.
xpath
Type: SystemString
A String xpath query.
isDirty
Type: SystemBoolean
A Boolean value indicating if items were added to the tree.

Return Value

Type: XmlNode
An XmlNode corresponding to the xpath query.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XmlNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
Note that the isDirty parameter will be set to True if any items were added to the tree.
See Also

Reference

XmlExtensions Class
GetXmlNode Overload
GSF.Xml Namespace


XmlExtensions.SetAttributeValue Method

Grid Solutions Framework XmlExtensionsSetAttributeValue Method
Safely sets an XML node's attribute.

Namespace: GSF.Xml
Assembly: GSF.Core (in GSF.Core.dll) Version: 2.1.122.0
Syntax
C#
VB
F#
JavaScript
C++
Copy
public static void SetAttributeValue(
    this XmlNode node,
    string name,
    string value
)
<ExtensionAttribute>
Public Shared Sub SetAttributeValue (
    node As XmlNode,
    name As String,
    value As String
)
static member SetAttributeValue :
        node : XmlNode *
        name : string *
        value : string -> unit

GSF.Xml.XmlExtensions.SetAttributeValue = function(node, name, value);
public:
[ExtensionAttribute]
static void SetAttributeValue(
    XmlNode^ node,
    String^ name,
    String^ value
)

Parameters

node
Type: System.XmlXmlNode
An XmlNode node to operate on.
name
Type: SystemString
A String indicating the node name to use.
value
Type: SystemString
A String value to set the node attribute's value to.

Usage Note

In Visual Basic and C#, you can call this method as an instance method on any object of type XmlNode. When you use instance method syntax to call this method, omit the first parameter. For more information, see Extension Methods (Visual Basic) or Extension Methods (C# Programming Guide).
Remarks
If you assign a value to an attribute that does not exist, the attribute will be created.
See Also

Reference

XmlExtensions Class
GSF.Xml Namespace


Grid Solutions Framework

Grid Solutions Framework Grid Solutions Framework

The Grid Solutions Framework (GSF) is an open source collection of .NET code used by electric power utilities and various open source projects. GSF contains a large variety of code useful for any .NET project consisting of hundreds of class libraries that extend the functionality included in the .NET Framework. It makes many of the more complex .NET features (e.g., sockets and encryption) easier to use and adds functions not included in the .NET.

See the following for documentation for time-series adapters that are available as part of the Grid Solutions Framework: Time-series Adapters

NuGet Download: https://www.nuget.org/packages/GSF.Core/

Product components in Grid Solutions Framework for developing time-series applications. The open Phasor Data Concentrator (openPDC), Secure Information Exchange Gateway (SIEGate) and open Historian (openHistorian) are examples of time-series applications that use the Grid Solutions Framework.

Example Components

  • Adapter based time-series processing and data exchange library with WPF UI configuration screens for managing real-time data

  • Various utility protocol libraries, e.g., PQDIF, COMTRADE, IEEE C37.118, IEEE 1344, IEC 61850-90-5, UTK F-NET, SEL Fast Message, BPA PDCstream, Macrodyne, MMS

  • Configuration API for easy and secure access to application settings

  • High-speed binary parsing framework for implementing protocol parsing

  • Well vetted abstract asynchronous communications framework (IServer / IClient) for socket (TCP, UDP including Multicast all over IPv6 or IPv4), serial and file based communications

  • Security framework for implementing role-based security in ASP.NET, WCF, WPF, Windows Forms and Windows Services

  • Windows Service Template for quickly developing windows services with remoting capability

  • Base WCF service for creating WCF services that can be self-hosted in Windows Service, Console, WPF or Windows Forms application

  • WCF-based Message Bus that can be hosted inside ASP.NET, Windows Service, Console, WPF or Windows Forms application

Click Library Overview below for larger image:

GSF Poster (4x3)